Getting Started

This section outlines the basics of loading and comparing In-Sight Explorer based job files.

Getting Started

Use the links below to learn more about the topics.

  • A Cognex.InSight.Job Library Overview

  • Loading an ISEJob

  • Comparing two IseJobs and Interpreting the Results


Overview

The page discusses general use and layout of the Cognex.InSight.Job library.

The Cognex.InSight.Job library was developed to ease comparison of jobs, as well as inspect existing jobs for individual values. It is split into the Cognex.InSight.Job.Common and Cognex.InSight.Job.Ise namespaces so if any major format changes happen, most applications should be able to benefit without much rework.

The Cognex.InSight.Job.Comparison.Common and Cognex.InSight.Job.Comparison.Ise namespaces are split up differently. The Common namespace contains all the comparison tools that are necessary for comparing generic spreadsheet based jobs, and does not provide any In-Sight Explorer specific code. The Ise namespace contains additional comparisons on In-Sight Explorer based spreadsheet jobs, and will likely be the most useful tool for comparisons.

Optional section title

Add one or more sections with content

See Also

Other Resources

Loading an ISEJob
Comparing two IseJobs and Interpreting the Results


Loading an ISEJob

This page goes over the steps for loading an IseJob.

Loading an IseJob

  1. Create a new IseJobReader.

  2. Determine where the job file is located. This may be on an In-Sight sensor, local machine, or at a streamable location.

  3. If the job is on an In-Sight sensor, either locally download it or use the Cognex.InSight.Ftp namespace from the In-Sight SDK to download it for you.

  4. Determine the appropriate Read method to use. There are two variants, IseJobReaderRead(String) for filenames, and IseJobReaderRead(Stream)

  5. Use the Read method, which will return an IseJob.

Example
C#
Copy
using System;
using System.IO;
using Cognex.InSight.Job.Common;
using Cognex.InSight.Job.Ise;

namespace IseJobLoadExample
{
  public class IseJobStreamLoadExample
  {
      public static IseJob LoadJob(Stream jobStream)
      {
          var iseReader = new IseJobReader();
          try
          {
              return iseReader.Read(jobStream);
          }
          catch (JobLoadException e)
          {
              Console.WriteLine("Exception reading the job, it is likely malformed: {0}", e);
              throw;
          }
          catch (Exception e)
          {
              Console.WriteLine("Exception reading the job: {0}", e);
              throw;
          }
      }
  }
}

An instance of the IseJobReader class is not thread-safe.

Many exceptions can be thrown while loading an IseJob. Any exception extending the JobLoadException indicates a fatal exception in loading the job, and no results will be returned. In a malformed job, exceptions may be thrown from the system, which will be left for the user to handle. If a file is being loaded with the IseJobReaderRead(String) method, any file-loading exception will be sent to the user to handle.

See Also

Reference

IseJob
IseJobReaderIseJobReader
IseJobReaderRead(String)
IseJobReaderRead(Stream)

Other Resources

Comparing two IseJobs and Interpreting the Results


Comparing two IseJobs and Interpreting the Results

Required introduction

Comparing Two IseJobs

  1. Load the IseJobs using the Loading an ISEJob guide.

  2. Use the static method IseJobComparatorCompare(IseJob, IseJob) with the two jobs as arguments to get the resulting IseJobDifference.

Contents of an IseJobDifference

An IseJobDifference has several fields, but all are based on the BasicDifferenceT class. A BasicDifferenceT can either be null, indicating that there is no difference, or non-null, in which case it will hold the value for the difference type for each job in the BasicDifferenceTValueA and BasicDifferenceTValueB fields.

Interpreting the results of a job comparison

  1. To understand metadata differences like camera model and firmware version, look into the IseJobDifferenceMetadataDifference field.

  2. To understand differences in the job pass/fail differences, look into the IseJobDifferencePassFailSettingsDifference field.

  3. To understand differences in the spreadsheet the job holds, go into the IseJobDifferenceSheetDifference field. There are multiple underlying fields that contain the differences between existing cells, as well as fields that have the cells that were added and removed.

Example
C#
Copy
using System;
using System.IO;
using Cognex.InSight.Job.Comparison.Common;
using Cognex.InSight.Job.Comparison.Ise;
using Cognex.InSight.Job.Common;
using Cognex.InSight.Job.Ise;

namespace IseJobCompareExample
{
    public class IseJobLoadExample
    {
        public static void CompareJobs(IseJob jobA, IseJob jobB)
        {
            var comparison = IseJobComparator.Compare(jobA, jobB);

            if (comparison.MetadataDifference != null)
            {
                // Do something with the metadata
            }

            if (comparison.PassFailSettingsDifference != null)
            {
                // Do something with the pass/fail settings
            }

            if (comparison.SheetDifference != null)
            {
                foreach (var changedCell in comparison.SheetDifference.ChangedCells)
                {
                    // Do something with a changed sheet item
                }
                foreach (var addedCell in comparison.SheetDifference.InsertedCells)
                {
                    Console.WriteLine("Cell was added at location {0} with expression `{1}`", addedCell.LocationB, addedCell.Expression);
                }
                foreach (var removedCell in comparison.SheetDifference.RemovedCells)
                {
                    Console.WriteLine("Cell was removed from location {0} with expression `{1}`", removedCell.LocationA, removedCell.Expression);
                }
            }
        }
    }
}
See Also

Reference

IseJobComparator
IseJobComparatorCompare(IseJob, IseJob)
BasicDifferenceT

Other Resources

Loading an IseJob


Namespaces

Namespaces
Namespace | Description
Cognex.InSight.Job.Common | Base classes for an In-Sight based spreadsheet job.
Cognex.InSight.Job.Common.EasyView | Base classes for EasyView in In-Sight spreadsheet jobs.
Cognex.InSight.Job.Comparison.Common | Utilities for comparing In-Sight based spreadsheets and jobs.
Cognex.InSight.Job.Comparison.Ise | Utilities for comparing In-Sight Explorer based jobs.
Cognex.InSight.Job.Ise | Classes for loading and inspecting In-Sight Explorer based jobs.
Cognex.InSight.Job.Ise.Tags | Classes for storing tag values attached to In-Sight Explorer based spreadsheet cells.


Cognex.InSight.Job.Common Namespace

Base classes for an In-Sight based spreadsheet job.
Classes
 | Class | Description
Public class | BasicExpressionParser | Contains parsers for simple expressions.
Public class | Cell | The base class for a generic spreadsheet cell.
Public class | CellLocationComparators | Implementations of common comparison orders for CellLocations.
Public class | CellLocationOffset | Represents an offset from a CellLocation.
Public class | JobEncryptedException | Thrown when a job is encrypted but a password has not been supplied.
Public class | JobLoadException | A fatal exception that occurred while loading a job.
Public class | Region |
Public class | SheetTCell | A basic implementation of ISheetTCell.
Structures
 | Structure | Description
Public structure | CellLocation | Represents a column and row location within a table.
Public structure | CellRange | Represents a range of column and row locations within a table.
Interfaces
 | Interface | Description
Public interface | ICell | A writable representation of a cell in a spreadsheet.
Public interface | IJobTCell | A mutable job.
Public interface | IReadOnlyCell | Represents a cell in a spreadsheet.
Public interface | IReadOnlyJobTCell | A job that cannot be modified.
Public interface | IReadOnlySheetTCell | A sheet that caannot be modified.
Public interface | ISheetTCell | A mutable sheet.


BasicExpressionParser Class

Contains parsers for simple expressions.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonBasicExpressionParser

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static class BasicExpressionParser
Public NotInheritable Class BasicExpressionParser

The BasicExpressionParser type exposes the following members.

Methods
Name | Description
SplitArgList | Splits an argument string into a list
TryParseFunction(String, String, ListString) | Parses an expression into a function name and an argument list
TryParseFunction(String, String, String) | Parses an expression into a function name and an argument string
Top
Remarks
As stated in its name, this class is meant to provide only simple expression parsing. For fully featured parsing, use [!:Cognex.InSight.Job.Expression]. The parsing in this class should be limited to that which is required to load a job file and should not have dependencies outside of the .NET BCL.
See Also

Reference

Cognex.InSight.Job.Common Namespace


BasicExpressionParser Methods

The BasicExpressionParser type exposes the following members.

Methods
Name | Description
SplitArgList | Splits an argument string into a list
TryParseFunction(String, String, ListString) | Parses an expression into a function name and an argument list
TryParseFunction(String, String, String) | Parses an expression into a function name and an argument string
Top
See Also

Reference

BasicExpressionParser Class
Cognex.InSight.Job.Common Namespace


BasicExpressionParser.SplitArgList Method

Cognex.InSight.Job Help

BasicExpressionParserSplitArgList Method

Splits an argument string into a list

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static List<string> SplitArgList(
    string argListStr
)
Public Shared Function SplitArgList (
    argListStr As String
) As List(Of String)

Parameters

argListStr
Type: SystemString
The argument string

Return Value

Type: List String
The argument list
Remarks
The argument string should not include the surrounding parentheses. This function supports strings and sub expressions, but does not split argument lists of sub expressions. Additionally, all whitespace will be stripped, except that within a string. For example, `A0, Concatenate("My string (", GetCount( A3 ), ")" ), D3+ E4` will be split as: 0: `A0` 1: `Concatenate("My string (",GetCount( A3 ),")")` 2: `D3+E4`
See Also

Reference

BasicExpressionParser Class
Cognex.InSight.Job.Common Namespace


BasicExpressionParser.TryParseFunction Method

BasicExpressionParserTryParseFunction Method

Overload List
Name | Description
TryParseFunction(String, String, ListString) | Parses an expression into a function name and an argument list
TryParseFunction(String, String, String) | Parses an expression into a function name and an argument string
Top
See Also

Reference

BasicExpressionParser Class
Cognex.InSight.Job.Common Namespace


BasicExpressionParser.TryParseFunction Method (String, String, List(String))

BasicExpressionParserTryParseFunction Method (String, String, ListString)

Parses an expression into a function name and an argument list

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool TryParseFunction(
    string expr,
    out string name,
    out List<string> argList
)
Public Shared Function TryParseFunction (
    expr As String,
    <OutAttribute> ByRef name As String,
    <OutAttribute> ByRef argList As List(Of String)
) As Boolean

Parameters

expr
Type: SystemString
The expression to parse
name
Type: SystemString
The parsed function name
argList
Type: System.Collections.GenericList String
The parsed argument list

Return Value

Type: Boolean
true if the expression could pe parsed as a function, else false
Remarks
This function only supports a single outer function with optional surrounding whitespace. Inner functions/arguments are not parsed, so they may have complex expressions. See SplitArgList(String) for details on how the argument list is processed.
See Also

Reference

BasicExpressionParser Class
TryParseFunction Overload
Cognex.InSight.Job.Common Namespace


BasicExpressionParser.TryParseFunction Method (String, String, String)

BasicExpressionParserTryParseFunction Method (String, String, String)

Parses an expression into a function name and an argument string

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool TryParseFunction(
    string expr,
    out string name,
    out string argListStr
)
Public Shared Function TryParseFunction (
    expr As String,
    <OutAttribute> ByRef name As String,
    <OutAttribute> ByRef argListStr As String
) As Boolean

Parameters

expr
Type: SystemString
The expression to parse
name
Type: SystemString
The parsed function name
argListStr
Type: SystemString
The parsed argument string

Return Value

Type: Boolean
true if the expression could pe parsed as a function, else false
Remarks
This function only supports a single outer function with optional surrounding whitespace. Inner functions/arguments are not parsed, so they may have complex expressions. For example, MyFunction(A0, GetRow(A1)+B2) is parseable, but MyFunction1(A0, GetRow(A1)+B2)+MyFunction2() is not parseable. The argument string is exactly the content within the parentheses, including whitespace but excluding the outer parentheses.
See Also

Reference

BasicExpressionParser Class
TryParseFunction Overload
Cognex.InSight.Job.Common Namespace


Cell Class

The base class for a generic spreadsheet cell.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonCell
Cognex.InSight.Job.IseIseCell

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class Cell : ICell, IReadOnlyCell
Public Class Cell
    Implements ICell, IReadOnlyCell

The Cell type exposes the following members.

Constructors
 | Name | Description
Public method | Cell | Creates a new, empty Cell at the provided CellLocation.
Top
Properties
 | Name | Description
Public property | CellState | The cell's enabled state (condition).
Public property | Comment | The cell's comment.
Public property | Expression | The cell's expression (formula).
Public property | Location | The cell location within a sheet.
Public property | Name | The cell's name (symbolic tag).
Public property | Saved | The cell's stored data.
Public property | Value | The cell's output value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


Cell Constructor

Creates a new, empty Cell at the provided CellLocation.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Cell(
    CellLocation location
)
Public Sub New (
    location As CellLocation
)

Parameters

location
Type: Cognex.InSight.Job.CommonCellLocation
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell Properties

The Cell type exposes the following members.

Properties
 | Name | Description
Public property | CellState | The cell's enabled state (condition).
Public property | Comment | The cell's comment.
Public property | Expression | The cell's expression (formula).
Public property | Location | The cell location within a sheet.
Public property | Name | The cell's name (symbolic tag).
Public property | Saved | The cell's stored data.
Public property | Value | The cell's output value.
Top
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.CellState Property

CellCellState Property

The cell's enabled state (condition).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string CellState { get; set; }
Public Property CellState As String
    Get
    Set

Property Value

Type: String
This will be null or "1" when the cell is enabled, "0" when the cell is disabled, or a cell reference (e.g. "A2", "$B$3") when the cell is conditinally enabled.

Implements

ICellCellState
IReadOnlyCellCellState
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.Comment Property

CellComment Property

The cell's comment.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Comment { get; set; }
Public Property Comment As String
    Get
    Set

Property Value

Type: String

Implements

ICellComment
IReadOnlyCellComment
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.Expression Property

CellExpression Property

The cell's expression (formula).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Expression { get; set; }
Public Property Expression As String
    Get
    Set

Property Value

Type: String

Implements

ICellExpression
IReadOnlyCellExpression
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.Location Property

CellLocation Property

The cell location within a sheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation Location { get; }
Public ReadOnly Property Location As CellLocation
    Get

Property Value

Type: CellLocation

Implements

IReadOnlyCellLocation
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.Name Property

CellName Property

The cell's name (symbolic tag).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

ICellName
IReadOnlyCellName
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.Saved Property

CellSaved Property

The cell's stored data.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Object Saved { get; set; }
Public Property Saved As Object
    Get
    Set

Property Value

Type: Object

Implements

ICellSaved
IReadOnlyCellSaved
Remarks
If the cell has no stored data, returns null. This may be the literal data stored with a cell (e.g. a byte[]) or may be parsed into a class type. If the saved data is parsed, it should contain all of the necessary fields to serialize back into the original form (or an equivalent form).
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell.Value Property

CellValue Property

The cell's output value.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Object Value { get; set; }
Public Property Value As Object
    Get
    Set

Property Value

Type: Object
This may be null if no applicable data converters are available for this cell's saved data.

Implements

ICellValue
IReadOnlyCellValue
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


Cell Methods

The Cell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cell Class
Cognex.InSight.Job.Common Namespace


CellLocation Structure

Represents a column and row location within a table.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public struct CellLocation : ICloneable,
    IComparable<CellLocation>, IComparable, IEquatable<CellLocation>
Public Structure CellLocation
    Implements ICloneable, IComparable(Of CellLocation),
    IComparable, IEquatable(Of CellLocation)

The CellLocation type exposes the following members.

Constructors
 | Name | Description
Public method | CellLocation(String) | Constructs a new instance of the CellLocation structure.
Public method | CellLocation(Int32, Int32) | Constructs a new CellLocation.
Public method | CellLocation(String, Int32, Boolean, Boolean, Int32) | Constructs a new instance of the CellLocation structure.
Top
Properties
 | Name | Description
Public property | Column | The column (horizontal) coordinate.
Public property | IsValid | Determines whether the table location is with the supported range.
Public property | Row | The row (vertical) coordinate.
Top
Methods
 | Name | Description
Public method | Clone | Performas a deep copy of this instance.
 | ColumnFromString(String) | Parses a string containing a column name from "A" (0) to "XFD" (16383).
 | ColumnFromString(String, Int32, Boolean, Int32) | Parses a column string.
 | ColumnToString(Int32) | Converts a column number to a string.
 | ColumnToString(Int32, StringBuilder) | Converts a column number to a string.
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(CellLocation) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(CellLocation) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RowFromString | Parses a row string.
Public method | ToString | Gets a string representation of the table location. (Overrides ValueTypeToString.)
Public method | ToString(Boolean, Boolean) | Gets a string representation of the table location.
 | ToString(Int32, Int32, Boolean, Boolean) | Converts a table location into a string.
Top
Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
Fields
Name | Description
Invalid | Designates an invalid table location.
MaxColumn | The maximum supported column number.
MaxOneLetterColumn | The maximum one-letter column number.
MaxRow | The maximum supported row number.
MaxTwoLetterColumn | The maximum two-letter column number.
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


CellLocation Constructor

Overload List
 | Name | Description
Public method | CellLocation(String) | Constructs a new instance of the CellLocation structure.
Public method | CellLocation(Int32, Int32) | Constructs a new CellLocation.
Public method | CellLocation(String, Int32, Boolean, Boolean, Int32) | Constructs a new instance of the CellLocation structure.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation Constructor (String)

Constructs a new instance of the CellLocation structure.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation(
    string str
)
Public Sub New (
    str As String
)

Parameters

str
Type: SystemString
The location string, e.g. "B$5".
Remarks
'$' characters that precede rows or columns will be stripped when the location is parsed. If the string is not valid, the Row and Column will be set to Int32.MinValue but no exception is thrown.
See Also

Reference

CellLocation Structure
CellLocation Overload
Cognex.InSight.Job.Common Namespace


CellLocation Constructor (Int32, Int32)

Constructs a new CellLocation.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation(
    int column,
    int row
)
Public Sub New (
    column As Integer,
    row As Integer
)

Parameters

column
Type: SystemInt32
The column (horizontal) coordinate.
row
Type: SystemInt32
The row (vertical) coordinate.
See Also

Reference

CellLocation Structure
CellLocation Overload
Cognex.InSight.Job.Common Namespace


CellLocation Constructor (String, Int32, Boolean, Boolean, Int32)

Constructs a new instance of the CellLocation structure.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation(
    string str,
    int index,
    out bool absoluteColumn,
    out bool absoluteRow,
    out int numChars
)
Public Sub New (
    str As String,
    index As Integer,
    <OutAttribute> ByRef absoluteColumn As Boolean,
    <OutAttribute> ByRef absoluteRow As Boolean,
    <OutAttribute> ByRef numChars As Integer
)

Parameters

str
Type: SystemString
A string containing a table location e.g. "$b35". The string may contain additional characters.
index
Type: SystemInt32
The starting index at which to read the table location from the string.
absoluteColumn
Type: SystemBoolean
Returns true if the column had a '$' prefix.
absoluteRow
Type: SystemBoolean
Returns true if the row had a '$' prefix.
numChars
Type: SystemInt32
Returns the number of characters in the location name.

Return Value

Type:
Returns a valid table location if the string is parsed okay, or Invalid if not.
See Also

Reference

CellLocation Structure
CellLocation Overload
Cognex.InSight.Job.Common Namespace


CellLocation Properties

The CellLocation type exposes the following members.

Properties
 | Name | Description
Public property | Column | The column (horizontal) coordinate.
Public property | IsValid | Determines whether the table location is with the supported range.
Public property | Row | The row (vertical) coordinate.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Column Property

CellLocationColumn Property

The column (horizontal) coordinate.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int Column { get; }
Public ReadOnly Property Column As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.IsValid Property

CellLocationIsValid Property

Determines whether the table location is with the supported range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool IsValid { get; }
Public ReadOnly Property IsValid As Boolean
    Get

Return Value

Type: Boolean
True if both the row and column are within the supported range.
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Row Property

CellLocationRow Property

The row (vertical) coordinate.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int Row { get; }
Public ReadOnly Property Row As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation Methods

The CellLocation type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Performas a deep copy of this instance.
 | ColumnFromString(String) | Parses a string containing a column name from "A" (0) to "XFD" (16383).
 | ColumnFromString(String, Int32, Boolean, Int32) | Parses a column string.
 | ColumnToString(Int32) | Converts a column number to a string.
 | ColumnToString(Int32, StringBuilder) | Converts a column number to a string.
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(CellLocation) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(CellLocation) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | RowFromString | Parses a row string.
Public method | ToString | Gets a string representation of the table location. (Overrides ValueTypeToString.)
Public method | ToString(Boolean, Boolean) | Gets a string representation of the table location.
 | ToString(Int32, Int32, Boolean, Boolean) | Converts a table location into a string.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Clone Method

CellLocationClone Method

Performas a deep copy of this instance.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation Clone()
Public Function Clone As CellLocation

Return Value

Type: CellLocation
A deep copy of this instance.
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.ColumnFromString Method

CellLocationColumnFromString Method

Overload List
Name | Description
ColumnFromString(String) | Parses a string containing a column name from "A" (0) to "XFD" (16383).
ColumnFromString(String, Int32, Boolean, Int32) | Parses a column string.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.ColumnFromString Method (String)

CellLocationColumnFromString Method (String)

Parses a string containing a column name from "A" (0) to "XFD" (16383).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static int ColumnFromString(
    string str
)
Public Shared Function ColumnFromString (
    str As String
) As Integer

Parameters

str
Type: SystemString
A string containing an optional dollar sign '$' followed by one to three letters, not case-sensitive.

Return Value

Type: Int32
The column number, or Int32.MinValue if the string is not valid.
See Also

Reference

CellLocation Structure
ColumnFromString Overload
Cognex.InSight.Job.Common Namespace


CellLocation.ColumnFromString Method (String, Int32, Boolean, Int32)

CellLocationColumnFromString Method (String, Int32, Boolean, Int32)

Parses a column string.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static int ColumnFromString(
    string str,
    int index,
    out bool absoluteColumn,
    out int numChars
)
Public Shared Function ColumnFromString (
    str As String,
    index As Integer,
    <OutAttribute> ByRef absoluteColumn As Boolean,
    <OutAttribute> ByRef numChars As Integer
) As Integer

Parameters

str
Type: SystemString
A string containing a column name.
index
Type: SystemInt32
The starting index at which to read the column name from the string.
absoluteColumn
Type: SystemBoolean
Returns true if the column name begins with a $.
numChars
Type: SystemInt32
Returns the number of characters that are part of the column name.

Return Value

Type: Int32
The column number, or Int32.MinValue if the string is not valid.
See Also

Reference

CellLocation Structure
ColumnFromString Overload
Cognex.InSight.Job.Common Namespace


CellLocation.ColumnToString Method

CellLocationColumnToString Method

Overload List
Name | Description
ColumnToString(Int32) | Converts a column number to a string.
ColumnToString(Int32, StringBuilder) | Converts a column number to a string.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.ColumnToString Method (Int32)

CellLocationColumnToString Method (Int32)

Converts a column number to a string.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static string ColumnToString(
    int column
)
Public Shared Function ColumnToString (
    column As Integer
) As String

Parameters

column
Type: SystemInt32
The column number.

Return Value

Type: String
A string representation of the column number.
See Also

Reference

CellLocation Structure
ColumnToString Overload
Cognex.InSight.Job.Common Namespace


CellLocation.ColumnToString Method (Int32, StringBuilder)

CellLocationColumnToString Method (Int32, StringBuilder)

Converts a column number to a string.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static void ColumnToString(
    int column,
    StringBuilder sb
)
Public Shared Sub ColumnToString (
    column As Integer,
    sb As StringBuilder
)

Parameters

column
Type: SystemInt32
The column number.
sb
Type: System.TextStringBuilder
A StringBuilder to which to write the column name.
See Also

Reference

CellLocation Structure
ColumnToString Overload
Cognex.InSight.Job.Common Namespace


CellLocation.CompareTo Method

CellLocationCompareTo Method

Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.
Public method | CompareTo(CellLocation) | Compares the current object with another object of the same type.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.CompareTo Method (Object)

CellLocationCompareTo Method (Object)

Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer

Parameters

obj
Type: SystemObject
An object to compare with this instance.

Return Value

Type: Int32
A value that indicates the relative order of the objects being compared. The return value has these meanings: Value Meaning Less than zero This instance precedes obj in the sort order. Zero This instance occurs in the same position in the sort order as obj. Greater than zero This instance follows obj in the sort order.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | obj is not the same type as this instance.
See Also

Reference

CellLocation Structure
CompareTo Overload
Cognex.InSight.Job.Common Namespace


CellLocation.CompareTo Method (CellLocation)

CellLocationCompareTo Method (CellLocation)

Compares the current object with another object of the same type.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int CompareTo(
    CellLocation other
)
Public Function CompareTo (
    other As CellLocation
) As Integer

Parameters

other
Type: Cognex.InSight.Job.CommonCellLocation
An object to compare with this object.

Return Value

Type: Int32
A value that indicates the relative order of the objects being compared. The return value has the following meanings: Value Meaning Less than zero This object is less than the other parameter.Zero This object is equal to other. Greater than zero This object is greater than other.

Implements

IComparableTCompareTo(T)
See Also

Reference

CellLocation Structure
CompareTo Overload
Cognex.InSight.Job.Common Namespace


CellLocation.Equals Method

CellLocationEquals Method

Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether this instance and a specified object are equal. (Overrides ValueTypeEquals(Object).)
Public method | Equals(CellLocation) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Equals Method (Object)

CellLocationEquals Method (Object)

Indicates whether this instance and a specified object are equal.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
The object to compare with the current instance.

Return Value

Type: Boolean
true if obj and this instance are the same type and represent the same value; otherwise, false.
See Also

Reference

CellLocation Structure
Equals Overload
Cognex.InSight.Job.Common Namespace


CellLocation.Equals Method (CellLocation)

CellLocationEquals Method (CellLocation)

Indicates whether the current object is equal to another object of the same type.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool Equals(
    CellLocation other
)
Public Function Equals (
    other As CellLocation
) As Boolean

Parameters

other
Type: Cognex.InSight.Job.CommonCellLocation
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

CellLocation Structure
Equals Overload
Cognex.InSight.Job.Common Namespace


CellLocation.GetHashCode Method

CellLocationGetHashCode Method

Returns the hash code for this instance.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
A 32-bit signed integer that is the hash code for this instance.
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.RowFromString Method

CellLocationRowFromString Method

Parses a row string.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static int RowFromString(
    string str,
    int index,
    out bool absoluteRow,
    out int numChars
)
Public Shared Function RowFromString (
    str As String,
    index As Integer,
    <OutAttribute> ByRef absoluteRow As Boolean,
    <OutAttribute> ByRef numChars As Integer
) As Integer

Parameters

str
Type: SystemString
A string containing a row number.
index
Type: SystemInt32
The starting index at which to read the row number from the string.
absoluteRow
Type: SystemBoolean
Returns true if the row number begins with a $.
numChars
Type: SystemInt32
Returns the number of characters that are part of the row number.

Return Value

Type: Int32
The row number, or Int32.MinValue if the string is not valid.
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.ToString Method

CellLocationToString Method

Overload List
 | Name | Description
Public method | ToString | Gets a string representation of the table location. (Overrides ValueTypeToString.)
Public method | ToString(Boolean, Boolean) | Gets a string representation of the table location.
 | ToString(Int32, Int32, Boolean, Boolean) | Converts a table location into a string.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.ToString Method

CellLocationToString Method

Gets a string representation of the table location.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
A string representing the column as a letter followed by the row as an integer. For example if Column=2 and Row=5, the string representation is 'C5'.
See Also

Reference

CellLocation Structure
ToString Overload
Cognex.InSight.Job.Common Namespace


CellLocation.ToString Method (Boolean, Boolean)

CellLocationToString Method (Boolean, Boolean)

Gets a string representation of the table location.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string ToString(
    bool absoluteColumn,
    bool absoluteRow
)
Public Function ToString (
    absoluteColumn As Boolean,
    absoluteRow As Boolean
) As String

Parameters

absoluteColumn
Type: SystemBoolean
If true, the returned string will include the $ symbol to represent an absolute column reference (e.g. $B5).
absoluteRow
Type: SystemBoolean
If true, the returned string will include the $ symbol to represent an absolute row reference (e.g. B$5).

Return Value

Type: String
A string representing the column as a letter followed by the row as an integer. For example if Column=2 and Row=5, the string representation is 'C5'.
See Also

Reference

CellLocation Structure
ToString Overload
Cognex.InSight.Job.Common Namespace


CellLocation.ToString Method (Int32, Int32, Boolean, Boolean)

CellLocationToString Method (Int32, Int32, Boolean, Boolean)

Converts a table location into a string.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static string ToString(
    int column,
    int row,
    bool absoluteColumn,
    bool absoluteRow
)
Public Shared Function ToString (
    column As Integer,
    row As Integer,
    absoluteColumn As Boolean,
    absoluteRow As Boolean
) As String

Parameters

column
Type: SystemInt32
The column coordinate.
row
Type: SystemInt32
The row coordinate.
absoluteColumn
Type: SystemBoolean
If true, the returned string will include the $ symbol to represent an absolute column reference (e.g. $B5).
absoluteRow
Type: SystemBoolean
If true, the returned string will include the $ symbol to represent an absolute row reference (e.g. B$5).

Return Value

Type: String
A string representing the table location.
See Also

Reference

CellLocation Structure
ToString Overload
Cognex.InSight.Job.Common Namespace


CellLocation Operators

The CellLocation type exposes the following members.

Operators
Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Equality Operator

CellLocationEquality Operator

[Missing <summary> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Equality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator ==(
    CellLocation a,
    CellLocation b
)
Public Shared Operator = (
    a As CellLocation,
    b As CellLocation
) As Boolean

Parameters

a
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="a"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Equality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

b
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="b"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Equality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Equality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.GreaterThan Operator

CellLocationGreaterThan Operator

[Missing <summary> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator >(
    CellLocation lhs,
    CellLocation rhs
)
Public Shared Operator > (
    lhs As CellLocation,
    rhs As CellLocation
) As Boolean

Parameters

lhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="lhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

rhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="rhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.GreaterThanOrEqual Operator

CellLocationGreaterThanOrEqual Operator

[Missing <summary> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator >=(
    CellLocation lhs,
    CellLocation rhs
)
Public Shared Operator >= (
    lhs As CellLocation,
    rhs As CellLocation
) As Boolean

Parameters

lhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="lhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

rhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="rhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_GreaterThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Inequality Operator

CellLocationInequality Operator

[Missing <summary> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Inequality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator !=(
    CellLocation a,
    CellLocation b
)
Public Shared Operator <> (
    a As CellLocation,
    b As CellLocation
) As Boolean

Parameters

a
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="a"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Inequality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

b
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="b"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Inequality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_Inequality(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.LessThan Operator

CellLocationLessThan Operator

[Missing <summary> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator <(
    CellLocation lhs,
    CellLocation rhs
)
Public Shared Operator < (
    lhs As CellLocation,
    rhs As CellLocation
) As Boolean

Parameters

lhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="lhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

rhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="rhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThan(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.LessThanOrEqual Operator

CellLocationLessThanOrEqual Operator

[Missing <summary> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator <=(
    CellLocation lhs,
    CellLocation rhs
)
Public Shared Operator <= (
    lhs As CellLocation,
    rhs As CellLocation
) As Boolean

Parameters

lhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="lhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

rhs
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="rhs"/> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Cognex.InSight.Job.Common.CellLocation.op_LessThanOrEqual(Cognex.InSight.Job.Common.CellLocation,Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation Fields

The CellLocation type exposes the following members.

Fields
Name | Description
Invalid | Designates an invalid table location.
MaxColumn | The maximum supported column number.
MaxOneLetterColumn | The maximum one-letter column number.
MaxRow | The maximum supported row number.
MaxTwoLetterColumn | The maximum two-letter column number.
Top
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.Invalid Field

CellLocationInvalid Field

Designates an invalid table location.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static readonly CellLocation Invalid
Public Shared ReadOnly Invalid As CellLocation

Field Value

Type: CellLocation
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.MaxColumn Field

CellLocationMaxColumn Field

The maximum supported column number.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public const int MaxColumn = 16383
Public Const MaxColumn As Integer = 16383

Field Value

Type: Int32
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.MaxOneLetterColumn Field

CellLocationMaxOneLetterColumn Field

The maximum one-letter column number.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public const int MaxOneLetterColumn = 25
Public Const MaxOneLetterColumn As Integer = 25

Field Value

Type: Int32
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.MaxRow Field

CellLocationMaxRow Field

The maximum supported row number.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public const int MaxRow = 32766
Public Const MaxRow As Integer = 32766

Field Value

Type: Int32
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocation.MaxTwoLetterColumn Field

CellLocationMaxTwoLetterColumn Field

The maximum two-letter column number.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public const int MaxTwoLetterColumn = 701
Public Const MaxTwoLetterColumn As Integer = 701

Field Value

Type: Int32
See Also

Reference

CellLocation Structure
Cognex.InSight.Job.Common Namespace


CellLocationComparators Class

Implementations of common comparison orders for CellLocations.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonCellLocationComparators

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static class CellLocationComparators
Public NotInheritable Class CellLocationComparators

The CellLocationComparators type exposes the following members.

Fields
Name | Description
Default | The default order which CellLocations will be compared in, which is equal to LeftRightTopBottom.
LeftRightTopBottom | Compare cells first by row, then by column (A0, B0, A1, B1)
TopBottomLeftRight | Compare cells first by column, then by row (A0, A1, B0, B1)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


CellLocationComparators Fields

The CellLocationComparators type exposes the following members.

Fields
Name | Description
Default | The default order which CellLocations will be compared in, which is equal to LeftRightTopBottom.
LeftRightTopBottom | Compare cells first by row, then by column (A0, B0, A1, B1)
TopBottomLeftRight | Compare cells first by column, then by row (A0, A1, B0, B1)
Top
See Also

Reference

CellLocationComparators Class
Cognex.InSight.Job.Common Namespace


CellLocationComparators.Default Field

CellLocationComparatorsDefault Field

The default order which CellLocations will be compared in, which is equal to LeftRightTopBottom.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static readonly IComparer<CellLocation> Default
Public Shared ReadOnly Default As IComparer(Of CellLocation)

Field Value

Type: IComparer CellLocation
See Also

Reference

CellLocationComparators Class
Cognex.InSight.Job.Common Namespace


CellLocationComparators.LeftRightTopBottom Field

CellLocationComparatorsLeftRightTopBottom Field

Compare cells first by row, then by column (A0, B0, A1, B1)

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static readonly IComparer<CellLocation> LeftRightTopBottom
Public Shared ReadOnly LeftRightTopBottom As IComparer(Of CellLocation)

Field Value

Type: IComparer CellLocation
See Also

Reference

CellLocationComparators Class
Cognex.InSight.Job.Common Namespace


CellLocationComparators.TopBottomLeftRight Field

CellLocationComparatorsTopBottomLeftRight Field

Compare cells first by column, then by row (A0, A1, B0, B1)

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static readonly IComparer<CellLocation> TopBottomLeftRight
Public Shared ReadOnly TopBottomLeftRight As IComparer(Of CellLocation)

Field Value

Type: IComparer CellLocation
See Also

Reference

CellLocationComparators Class
Cognex.InSight.Job.Common Namespace


CellLocationOffset Class

Represents an offset from a CellLocation.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonCellLocationOffset

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class CellLocationOffset
Public Class CellLocationOffset

The CellLocationOffset type exposes the following members.

Constructors
 | Name | Description
Public method | CellLocationOffset | Creates a new instance of the CellLocationOffset structure.
Top
Properties
 | Name | Description
Public property | Columns | The number of columns to offset a CellLocation by.
Public property | Rows | The number of rows to offset a CellLocation by.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffsetLocation | Constructs a new CellLocation from the given CellLocation which is offset by the amount given by this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


CellLocationOffset Constructor

Creates a new instance of the CellLocationOffset structure.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocationOffset(
    int columns,
    int rows
)
Public Sub New (
    columns As Integer,
    rows As Integer
)

Parameters

columns
Type: SystemInt32
The number of columns to offset a CellLocation by.
rows
Type: SystemInt32
The number of rows to offset a CellLocation by.
See Also

Reference

CellLocationOffset Class
Cognex.InSight.Job.Common Namespace


CellLocationOffset Properties

The CellLocationOffset type exposes the following members.

Properties
 | Name | Description
Public property | Columns | The number of columns to offset a CellLocation by.
Public property | Rows | The number of rows to offset a CellLocation by.
Top
See Also

Reference

CellLocationOffset Class
Cognex.InSight.Job.Common Namespace


CellLocationOffset.Columns Property

CellLocationOffsetColumns Property

The number of columns to offset a CellLocation by.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CellLocationOffset Class
Cognex.InSight.Job.Common Namespace


CellLocationOffset.Rows Property

CellLocationOffsetRows Property

The number of rows to offset a CellLocation by.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CellLocationOffset Class
Cognex.InSight.Job.Common Namespace


CellLocationOffset Methods

The CellLocationOffset type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OffsetLocation | Constructs a new CellLocation from the given CellLocation which is offset by the amount given by this instance.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CellLocationOffset Class
Cognex.InSight.Job.Common Namespace


CellLocationOffset.OffsetLocation Method

CellLocationOffsetOffsetLocation Method

Constructs a new CellLocation from the given CellLocation which is offset by the amount given by this instance.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation OffsetLocation(
    CellLocation baseLocation
)
Public Function OffsetLocation (
    baseLocation As CellLocation
) As CellLocation

Parameters

baseLocation
Type: Cognex.InSight.Job.CommonCellLocation
The location to offset from.

Return Value

Type: CellLocation
The base location offset by the amount specified by this instance.
See Also

Reference

CellLocationOffset Class
Cognex.InSight.Job.Common Namespace


CellRange Structure

Represents a range of column and row locations within a table.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public struct CellRange
Public Structure CellRange

The CellRange type exposes the following members.

Constructors
 | Name | Description
Public method | CellRange(CellLocation) | Constructs a new CellRange.
Public method | CellRange(Int32, Int32) | Constructs a new CellRange.
Public method | CellRange(CellLocation, CellLocation) | Constructs a new CellRange.
Top
Properties
 | Name | Description
Public property | Columns | Gets the number of columns in the range.
 | Empty | Gets an empty table range.
Public property | First | The starting location of the range.
Public property | IsEmpty | Returns true if the range contains zero rows and columns.
Public property | Last | The ending location of the range.
Public property | Rows | Gets the number of rows in the range.
Top
Methods
 | Name | Description
Public method | Contains(CellLocation) | Determines whether this range contains the given location.
Public method | Contains(CellRange) | Determines whether this range contains the given range.
Public method | ContainsColumn | Determines whether this range contains the given column.
Public method | ContainsRow | Determines whether this range contains the given row.
Public method | Equals | Compares this CellRange with a given object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets a hash code for this CellLocation. (Overrides ValueTypeGetHashCode.)
Public method | GetNearest | Given a location, finds the nearest location that is within the range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Intersect | Returns a third CellRange structure that represents the intersection of two other CellRange structures.
Public method | ToString | Gets a string representation of the table location. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Equality | Equality operator.
Inequality | Inequality operator.
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


CellRange Constructor

Overload List
 | Name | Description
Public method | CellRange(CellLocation) | Constructs a new CellRange.
Public method | CellRange(Int32, Int32) | Constructs a new CellRange.
Public method | CellRange(CellLocation, CellLocation) | Constructs a new CellRange.
Top
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange Constructor (CellLocation)

Constructs a new CellRange.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellRange(
    CellLocation location
)
Public Sub New (
    location As CellLocation
)

Parameters

location
Type: Cognex.InSight.Job.CommonCellLocation
The starting and ending location of the range.
See Also

Reference

CellRange Structure
CellRange Overload
Cognex.InSight.Job.Common Namespace


CellRange Constructor (Int32, Int32)

Constructs a new CellRange.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellRange(
    int column,
    int row
)
Public Sub New (
    column As Integer,
    row As Integer
)

Parameters

column
Type: SystemInt32
The starting and ending column of the range.
row
Type: SystemInt32
The starting and ending row of the range.
See Also

Reference

CellRange Structure
CellRange Overload
Cognex.InSight.Job.Common Namespace


CellRange Constructor (CellLocation, CellLocation)

Constructs a new CellRange.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellRange(
    CellLocation first,
    CellLocation last
)
Public Sub New (
    first As CellLocation,
    last As CellLocation
)

Parameters

first
Type: Cognex.InSight.Job.CommonCellLocation
The starting location of the range.
last
Type: Cognex.InSight.Job.CommonCellLocation
The ending location of the range.
See Also

Reference

CellRange Structure
CellRange Overload
Cognex.InSight.Job.Common Namespace


CellRange Properties

The CellRange type exposes the following members.

Properties
 | Name | Description
Public property | Columns | Gets the number of columns in the range.
 | Empty | Gets an empty table range.
Public property | First | The starting location of the range.
Public property | IsEmpty | Returns true if the range contains zero rows and columns.
Public property | Last | The ending location of the range.
Public property | Rows | Gets the number of rows in the range.
Top
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Columns Property

CellRangeColumns Property

Gets the number of columns in the range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int Columns { get; }
Public ReadOnly Property Columns As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Empty Property

CellRangeEmpty Property

Gets an empty table range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static CellRange Empty { get; }
Public Shared ReadOnly Property Empty As CellRange
    Get

Property Value

Type: CellRange
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.First Property

CellRangeFirst Property

The starting location of the range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation First { get; }
Public ReadOnly Property First As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.IsEmpty Property

CellRangeIsEmpty Property

Returns true if the range contains zero rows and columns.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool IsEmpty { get; }
Public ReadOnly Property IsEmpty As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Last Property

CellRangeLast Property

The ending location of the range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation Last { get; }
Public ReadOnly Property Last As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Rows Property

CellRangeRows Property

Gets the number of rows in the range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int Rows { get; }
Public ReadOnly Property Rows As Integer
    Get

Property Value

Type: Int32
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange Methods

The CellRange type exposes the following members.

Methods
 | Name | Description
Public method | Contains(CellLocation) | Determines whether this range contains the given location.
Public method | Contains(CellRange) | Determines whether this range contains the given range.
Public method | ContainsColumn | Determines whether this range contains the given column.
Public method | ContainsRow | Determines whether this range contains the given row.
Public method | Equals | Compares this CellRange with a given object. (Overrides ValueTypeEquals(Object).)
Public method | GetHashCode | Gets a hash code for this CellLocation. (Overrides ValueTypeGetHashCode.)
Public method | GetNearest | Given a location, finds the nearest location that is within the range.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Intersect | Returns a third CellRange structure that represents the intersection of two other CellRange structures.
Public method | ToString | Gets a string representation of the table location. (Overrides ValueTypeToString.)
Top
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Contains Method

CellRangeContains Method

Overload List
 | Name | Description
Public method | Contains(CellLocation) | Determines whether this range contains the given location.
Public method | Contains(CellRange) | Determines whether this range contains the given range.
Top
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Contains Method (CellLocation)

CellRangeContains Method (CellLocation)

Determines whether this range contains the given location.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool Contains(
    CellLocation location
)
Public Function Contains (
    location As CellLocation
) As Boolean

Parameters

location
Type: Cognex.InSight.Job.CommonCellLocation
The location to test.

Return Value

Type: Boolean
True if the range contains the given location.
See Also

Reference

CellRange Structure
Contains Overload
Cognex.InSight.Job.Common Namespace


CellRange.Contains Method (CellRange)

CellRangeContains Method (CellRange)

Determines whether this range contains the given range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool Contains(
    CellRange range
)
Public Function Contains (
    range As CellRange
) As Boolean

Parameters

range
Type: Cognex.InSight.Job.CommonCellRange
The range to test.

Return Value

Type: Boolean
True if this range completely contains the given range.
See Also

Reference

CellRange Structure
Contains Overload
Cognex.InSight.Job.Common Namespace


CellRange.ContainsColumn Method

CellRangeContainsColumn Method

Determines whether this range contains the given column.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool ContainsColumn(
    int column
)
Public Function ContainsColumn (
    column As Integer
) As Boolean

Parameters

column
Type: SystemInt32
The column to test.

Return Value

Type: Boolean
True if the range contains the given column.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.ContainsRow Method

CellRangeContainsRow Method

Determines whether this range contains the given row.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool ContainsRow(
    int row
)
Public Function ContainsRow (
    row As Integer
) As Boolean

Parameters

row
Type: SystemInt32
The row to test.

Return Value

Type: Boolean
True if the range contains the given row.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Equals Method

CellRangeEquals Method

Compares this CellRange with a given object.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean

Parameters

obj
Type: SystemObject
object to compare this object to

Return Value

Type: Boolean
True if the given object is a CellRange that equals this one.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.GetHashCode Method

CellRangeGetHashCode Method

Gets a hash code for this CellLocation.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer

Return Value

Type: Int32
The hash code of the First.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.GetNearest Method

CellRangeGetNearest Method

Given a location, finds the nearest location that is within the range.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation GetNearest(
    CellLocation location
)
Public Function GetNearest (
    location As CellLocation
) As CellLocation

Parameters

location
Type: Cognex.InSight.Job.CommonCellLocation
The location to locate a point that is closest to it.

Return Value

Type: CellLocation
If location is within the range, simply returns it. Otherwise, returns the nearest location that within the range. If the range is empty, returns the location of the empty range.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Intersect Method

CellRangeIntersect Method

Returns a third CellRange structure that represents the intersection of two other CellRange structures.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static CellRange Intersect(
    CellRange a,
    CellRange b
)
Public Shared Function Intersect (
    a As CellRange,
    b As CellRange
) As CellRange

Parameters

a
Type: Cognex.InSight.Job.CommonCellRange
The first CellRange.
b
Type: Cognex.InSight.Job.CommonCellRange
The second CellRange.

Return Value

Type: CellRange
A new range that represents the intersection of the two ranges, or if there is no intersection, Empty.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.ToString Method

CellRangeToString Method

Gets a string representation of the table location.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public override string ToString()
Public Overrides Function ToString As String

Return Value

Type: String
If First equals Last, i.e. the range contains only a single location, this method just returns the string representation of the First. Otherwise it returns the string representation of the First followed by a colon and the string representation of the Last
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange Operators

The CellRange type exposes the following members.

Operators
Name | Description
Equality | Equality operator.
Inequality | Inequality operator.
Top
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Equality Operator

CellRangeEquality Operator

Equality operator.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator ==(
    CellRange a,
    CellRange b
)
Public Shared Operator = (
    a As CellRange,
    b As CellRange
) As Boolean

Parameters

a
Type: Cognex.InSight.Job.CommonCellRange
The first CellRange.
b
Type: Cognex.InSight.Job.CommonCellRange
The second CellRange.

Return Value

Type: Boolean
True if the given ranges are equal.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


CellRange.Inequality Operator

CellRangeInequality Operator

Inequality operator.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool operator !=(
    CellRange a,
    CellRange b
)
Public Shared Operator <> (
    a As CellRange,
    b As CellRange
) As Boolean

Parameters

a
Type: Cognex.InSight.Job.CommonCellRange
The first CellRange.
b
Type: Cognex.InSight.Job.CommonCellRange
The second CellRange.

Return Value

Type: Boolean
True if the given ranges are NOT equal.
See Also

Reference

CellRange Structure
Cognex.InSight.Job.Common Namespace


ICell Interface

A writable representation of a cell in a spreadsheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface ICell : IReadOnlyCell
Public Interface ICell
    Inherits IReadOnlyCell

The ICell type exposes the following members.

Properties
 | Name | Description
Public property | CellState | The cell's enabled state (condition).
Public property | Comment | The cell's comment.
Public property | Expression | The cell's expression (formula).
Public property | Location | The cell location within a sheet. (Inherited from IReadOnlyCell.)
Public property | Name | The cell's name (symbolic tag).
Public property | Saved | The cell's stored data.
Public property | Value | The cell's output value.
Top
Remarks
This should contain exactly the same fields as IReadOnlyCell, with the exception of Location, which is intentionally always readonly.
See Also

Reference

Cognex.InSight.Job.Common Namespace


ICell Properties

The ICell type exposes the following members.

Properties
 | Name | Description
Public property | CellState | The cell's enabled state (condition).
Public property | Comment | The cell's comment.
Public property | Expression | The cell's expression (formula).
Public property | Location | The cell location within a sheet. (Inherited from IReadOnlyCell.)
Public property | Name | The cell's name (symbolic tag).
Public property | Saved | The cell's stored data.
Public property | Value | The cell's output value.
Top
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


ICell.CellState Property

ICellCellState Property

The cell's enabled state (condition).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string CellState { get; set; }
Property CellState As String
    Get
    Set

Property Value

Type: String
This will be null or "1" when the cell is enabled, "0" when the cell is disabled, or a cell reference (e.g. "A2", "$B$3") when the cell is conditinally enabled.

Implements

IReadOnlyCellCellState
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


ICell.Comment Property

ICellComment Property

The cell's comment.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Comment { get; set; }
Property Comment As String
    Get
    Set

Property Value

Type: String

Implements

IReadOnlyCellComment
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


ICell.Expression Property

ICellExpression Property

The cell's expression (formula).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Expression { get; set; }
Property Expression As String
    Get
    Set

Property Value

Type: String

Implements

IReadOnlyCellExpression
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


ICell.Name Property

ICellName Property

The cell's name (symbolic tag).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String

Implements

IReadOnlyCellName
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


ICell.Saved Property

ICellSaved Property

The cell's stored data.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
Object Saved { get; set; }
Property Saved As Object
    Get
    Set

Property Value

Type: Object

Implements

IReadOnlyCellSaved
Remarks
If the cell has no stored data, returns null. This may be the literal data stored with a cell (e.g. a byte[]) or may be parsed into a class type. If the saved data is parsed, it should contain all of the necessary fields to serialize back into the original form (or an equivalent form).
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


ICell.Value Property

ICellValue Property

The cell's output value.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
Object Value { get; set; }
Property Value As Object
    Get
    Set

Property Value

Type: Object
This may be null if no applicable data converters are available for this cell's saved data.

Implements

IReadOnlyCellValue
See Also

Reference

ICell Interface
Cognex.InSight.Job.Common Namespace


IJob(TCell) Interface

IJobTCell Interface

A mutable job.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface IJob<TCell> : IReadOnlyJob<TCell>
where TCell : IReadOnlyCell

Public Interface IJob(Of TCell As IReadOnlyCell)
    Inherits IReadOnlyJob(Of TCell)

Type Parameters

TCell
The most specific implementation of IReadOnlyCell that is desired.

The IJobTCell type exposes the following members.

Properties
 | Name | Description
Public property | EasyViewTable | Stores all of the EasyView information for a given job.
Public property | Name | The name of the job.
Public property | Sheets | All of the sheets stored in this job. (Inherited from IReadOnlyJobTCell.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


IJob(TCell) Properties

IJobTCell Properties

The IJobTCell generic type exposes the following members.

Properties
 | Name | Description
Public property | EasyViewTable | Stores all of the EasyView information for a given job.
Public property | Name | The name of the job.
Public property | Sheets | All of the sheets stored in this job. (Inherited from IReadOnlyJobTCell.)
Top
See Also

Reference

IJobTCell Interface
Cognex.InSight.Job.Common Namespace


IJob(TCell).EasyViewTable Property

IJobTCellEasyViewTable Property

Stores all of the EasyView information for a given job.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
EasyViewTable EasyViewTable { get; set; }
Property EasyViewTable As EasyViewTable
    Get
    Set

Property Value

Type: EasyViewTable
See Also

Reference

IJobTCell Interface
Cognex.InSight.Job.Common Namespace


IJob(TCell).Name Property

IJobTCellName Property

The name of the job.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Name { get; set; }
Property Name As String
    Get
    Set

Property Value

Type: String

Implements

IReadOnlyJobTCellName
See Also

Reference

IJobTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell Interface

Represents a cell in a spreadsheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface IReadOnlyCell
Public Interface IReadOnlyCell

The IReadOnlyCell type exposes the following members.

Properties
 | Name | Description
Public property | CellState | The cell's enabled state (condition).
Public property | Comment | The cell's comment.
Public property | Expression | The cell's expression (formula).
Public property | Location | The cell location within a sheet.
Public property | Name | The cell's name (symbolic tag).
Public property | Saved | The cell's stored data.
Public property | Value | The cell's output value.
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


IReadOnlyCell Properties

The IReadOnlyCell type exposes the following members.

Properties
 | Name | Description
Public property | CellState | The cell's enabled state (condition).
Public property | Comment | The cell's comment.
Public property | Expression | The cell's expression (formula).
Public property | Location | The cell location within a sheet.
Public property | Name | The cell's name (symbolic tag).
Public property | Saved | The cell's stored data.
Public property | Value | The cell's output value.
Top
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.CellState Property

IReadOnlyCellCellState Property

The cell's enabled state (condition).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string CellState { get; }
ReadOnly Property CellState As String
    Get

Property Value

Type: String
This will be null or "1" when the cell is enabled, "0" when the cell is disabled, or a cell reference (e.g. "A2", "$B$3") when the cell is conditinally enabled.
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.Comment Property

IReadOnlyCellComment Property

The cell's comment.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Comment { get; }
ReadOnly Property Comment As String
    Get

Property Value

Type: String
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.Expression Property

IReadOnlyCellExpression Property

The cell's expression (formula).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Expression { get; }
ReadOnly Property Expression As String
    Get

Property Value

Type: String
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.Location Property

IReadOnlyCellLocation Property

The cell location within a sheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
CellLocation Location { get; }
ReadOnly Property Location As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.Name Property

IReadOnlyCellName Property

The cell's name (symbolic tag).

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.Saved Property

IReadOnlyCellSaved Property

The cell's stored data.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
Object Saved { get; }
ReadOnly Property Saved As Object
    Get

Property Value

Type: Object
Remarks
If the cell has no stored data, returns null. This may be the literal data stored with a cell (e.g. a byte[]) or may be parsed into a class type. If the saved data is parsed, it should contain all of the necessary fields to serialize back into the original form (or an equivalent form).
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyCell.Value Property

IReadOnlyCellValue Property

The cell's output value.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
Object Value { get; }
ReadOnly Property Value As Object
    Get

Property Value

Type: Object
This may be null if no applicable data converters are available for this cell's saved data.
See Also

Reference

IReadOnlyCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyJob(TCell) Interface

IReadOnlyJobTCell Interface

A job that cannot be modified.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface IReadOnlyJob<TCell>
where TCell : IReadOnlyCell

Public Interface IReadOnlyJob(Of TCell As IReadOnlyCell)

Type Parameters

TCell
The most specific implementation of IReadOnlyCell that is desired.

The IReadOnlyJobTCell type exposes the following members.

Properties
 | Name | Description
Public property | Name | The name of the job.
Public property | Sheets | All of the sheets stored in this job.
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


IReadOnlyJob(TCell) Properties

IReadOnlyJobTCell Properties

The IReadOnlyJobTCell generic type exposes the following members.

Properties
 | Name | Description
Public property | Name | The name of the job.
Public property | Sheets | All of the sheets stored in this job.
Top
See Also

Reference

IReadOnlyJobTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyJob(TCell).Name Property

IReadOnlyJobTCellName Property

The name of the job.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IReadOnlyJobTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlyJob(TCell).Sheets Property

IReadOnlyJobTCellSheets Property

All of the sheets stored in this job.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
IReadOnlyCollection<IReadOnlySheet<TCell>> Sheets { get; }
ReadOnly Property Sheets As IReadOnlyCollection(Of IReadOnlySheet(Of TCell))
    Get

Property Value

Type: IReadOnlyCollection IReadOnlySheet TCell
See Also

Reference

IReadOnlyJobTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlySheet(TCell) Interface

IReadOnlySheetTCell Interface

A sheet that caannot be modified.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface IReadOnlySheet<TCell> : IEnumerable<TCell>,
    IEnumerable
where TCell : IReadOnlyCell

Public Interface IReadOnlySheet(Of TCell As IReadOnlyCell)
    Inherits IEnumerable(Of TCell), IEnumerable

Type Parameters

TCell
The most specific implementation of IReadOnlyCell that is desired.

The IReadOnlySheetTCell type exposes the following members.

Properties
 | Name | Description
Public property | Cells | A mapping from all of the CellLocations that contain a TCell to that TCell.
Public property | Name | The name of this sheet.
Top
Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable TCell.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


IReadOnlySheet(TCell) Properties

IReadOnlySheetTCell Properties

The IReadOnlySheetTCell generic type exposes the following members.

Properties
 | Name | Description
Public property | Cells | A mapping from all of the CellLocations that contain a TCell to that TCell.
Public property | Name | The name of this sheet.
Top
See Also

Reference

IReadOnlySheetTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlySheet(TCell).Cells Property

IReadOnlySheetTCellCells Property

A mapping from all of the CellLocations that contain a TCell to that TCell.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
IReadOnlyDictionary<CellLocation, TCell> Cells { get; }
ReadOnly Property Cells As IReadOnlyDictionary(Of CellLocation, TCell)
    Get

Property Value

Type: IReadOnlyDictionary CellLocation, TCell
See Also

Reference

IReadOnlySheetTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlySheet(TCell).Name Property

IReadOnlySheetTCellName Property

The name of this sheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Name { get; }
ReadOnly Property Name As String
    Get

Property Value

Type: String
See Also

Reference

IReadOnlySheetTCell Interface
Cognex.InSight.Job.Common Namespace


IReadOnlySheet(TCell) Methods

IReadOnlySheetTCell Methods

The IReadOnlySheetTCell generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable TCell .)
Top
See Also

Reference

IReadOnlySheetTCell Interface
Cognex.InSight.Job.Common Namespace


ISheet(TCell) Interface

ISheetTCell Interface

A mutable sheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface ISheet<TCell> : IReadOnlySheet<TCell>,
    IEnumerable<TCell>, IEnumerable
where TCell : IReadOnlyCell

Public Interface ISheet(Of TCell As IReadOnlyCell)
    Inherits IReadOnlySheet(Of TCell), IEnumerable(Of TCell),
    IEnumerable

Type Parameters

TCell
The most specific implementation of IReadOnlyCell that is desired.

The ISheetTCell type exposes the following members.

Properties
 | Name | Description
Public property | Cells | A mapping from all of the CellLocations that contain a TCell to that TCell.
Public property | Name | The name of this sheet. (Inherited from IReadOnlySheetTCell.)
Top
Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable TCell.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


ISheet(TCell) Properties

ISheetTCell Properties

The ISheetTCell generic type exposes the following members.

Properties
 | Name | Description
Public property | Cells | A mapping from all of the CellLocations that contain a TCell to that TCell.
Public property | Name | The name of this sheet. (Inherited from IReadOnlySheetTCell.)
Top
See Also

Reference

ISheetTCell Interface
Cognex.InSight.Job.Common Namespace


ISheet(TCell).Cells Property

ISheetTCellCells Property

A mapping from all of the CellLocations that contain a TCell to that TCell.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
IDictionary<CellLocation, TCell> Cells { get; }
ReadOnly Property Cells As IDictionary(Of CellLocation, TCell)
    Get

Property Value

Type: IDictionary CellLocation, TCell
See Also

Reference

ISheetTCell Interface
Cognex.InSight.Job.Common Namespace


ISheet(TCell) Methods

ISheetTCell Methods

The ISheetTCell generic type exposes the following members.

Methods
 | Name | Description
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable TCell .)
Top
See Also

Reference

ISheetTCell Interface
Cognex.InSight.Job.Common Namespace


JobEncryptedException Class

Thrown when a job is encrypted but a password has not been supplied.
Inheritance Hierarchy
SystemObject
SystemException
Cognex.InSight.Job.CommonJobLoadException
Cognex.InSight.Job.CommonJobEncryptedException

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class JobEncryptedException : JobLoadException
Public Class JobEncryptedException
    Inherits JobLoadException

The JobEncryptedException type exposes the following members.

Constructors
 | Name | Description
Public method | JobEncryptedException | Creates a new JobEncryptedException with a default message.
Public method | JobEncryptedException(String) | Creates a new JobEncryptedException with a provided message.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


JobEncryptedException Constructor

Overload List
 | Name | Description
Public method | JobEncryptedException | Creates a new JobEncryptedException with a default message.
Public method | JobEncryptedException(String) | Creates a new JobEncryptedException with a provided message.
Top
See Also

Reference

JobEncryptedException Class
Cognex.InSight.Job.Common Namespace


JobEncryptedException Constructor

Creates a new JobEncryptedException with a default message.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public JobEncryptedException()
Public Sub New
See Also

Reference

JobEncryptedException Class
JobEncryptedException Overload
Cognex.InSight.Job.Common Namespace


JobEncryptedException Constructor (String)

Creates a new JobEncryptedException with a provided message.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public JobEncryptedException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the exception.
See Also

Reference

JobEncryptedException Class
JobEncryptedException Overload
Cognex.InSight.Job.Common Namespace


JobEncryptedException Properties

The JobEncryptedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

JobEncryptedException Class
Cognex.InSight.Job.Common Namespace


JobEncryptedException Methods

The JobEncryptedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

JobEncryptedException Class
Cognex.InSight.Job.Common Namespace


JobEncryptedException Events

The JobEncryptedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

JobEncryptedException Class
Cognex.InSight.Job.Common Namespace


JobLoadException Class

A fatal exception that occurred while loading a job.
Inheritance Hierarchy
SystemObject
SystemException
Cognex.InSight.Job.CommonJobLoadException
Cognex.InSight.Job.CommonJobEncryptedException
Cognex.InSight.Job.Ise.TagsUnknownTagTypeException

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class JobLoadException : Exception
Public Class JobLoadException
    Inherits Exception

The JobLoadException type exposes the following members.

Constructors
 | Name | Description
Public method | JobLoadException(String) | Creates a new JobLoadException with the provided message.
Public method | JobLoadException(String, Exception) | Creates a new JobLoadException with the provided message and underlying cause.
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


JobLoadException Constructor

Overload List
 | Name | Description
Public method | JobLoadException(String) | Creates a new JobLoadException with the provided message.
Public method | JobLoadException(String, Exception) | Creates a new JobLoadException with the provided message and underlying cause.
Top
See Also

Reference

JobLoadException Class
Cognex.InSight.Job.Common Namespace


JobLoadException Constructor (String)

Creates a new JobLoadException with the provided message.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public JobLoadException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message that describes the exception.
See Also

Reference

JobLoadException Class
JobLoadException Overload
Cognex.InSight.Job.Common Namespace


JobLoadException Constructor (String, Exception)

Creates a new JobLoadException with the provided message and underlying cause.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public JobLoadException(
    string message,
    Exception underlying
)
Public Sub New (
    message As String,
    underlying As Exception
)

Parameters

message
Type: SystemString
The message that describes the exception.
underlying
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

JobLoadException Class
JobLoadException Overload
Cognex.InSight.Job.Common Namespace


JobLoadException Properties

The JobLoadException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

JobLoadException Class
Cognex.InSight.Job.Common Namespace


JobLoadException Methods

The JobLoadException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

JobLoadException Class
Cognex.InSight.Job.Common Namespace


JobLoadException Events

The JobLoadException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

JobLoadException Class
Cognex.InSight.Job.Common Namespace


Region Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Common.Region"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonRegion

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class Region
Public Class Region

The Region type exposes the following members.

Constructors
 | Name | Description
Public method | Region | Initializes a new instance of the Region class
Public method | Region(Double, Double, Double, Double, Double, Double) | Initializes a new instance of the Region class
Top
Properties
 | Name | Description
Public property | Angle |
Public property | Curve |
Public property | Height |
Public property | Width |
Public property | X |
Public property | Y |
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


Region Constructor

Overload List
 | Name | Description
Public method | Region | Initializes a new instance of the Region class
Public method | Region(Double, Double, Double, Double, Double, Double) | Initializes a new instance of the Region class
Top
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region Constructor

Initializes a new instance of the Region class

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Region()
Public Sub New
See Also

Reference

Region Class
Region Overload
Cognex.InSight.Job.Common Namespace


Region Constructor (Double, Double, Double, Double, Double, Double)

Initializes a new instance of the Region class

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Region(
    double x,
    double y,
    double width,
    double height,
    double angle = 0,
    double curve = 0
)
Public Sub New (
    x As Double,
    y As Double,
    width As Double,
    height As Double,
    Optional angle As Double = 0,
    Optional curve As Double = 0
)

Parameters

x
Type: SystemDouble

[Missing <param name="x"/> documentation for "M:Cognex.InSight.Job.Common.Region.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

y
Type: SystemDouble

[Missing <param name="y"/> documentation for "M:Cognex.InSight.Job.Common.Region.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

width
Type: SystemDouble

[Missing <param name="width"/> documentation for "M:Cognex.InSight.Job.Common.Region.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

height
Type: SystemDouble

[Missing <param name="height"/> documentation for "M:Cognex.InSight.Job.Common.Region.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

angle (Optional)
Type: SystemDouble

[Missing <param name="angle"/> documentation for "M:Cognex.InSight.Job.Common.Region.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

curve (Optional)
Type: SystemDouble

[Missing <param name="curve"/> documentation for "M:Cognex.InSight.Job.Common.Region.#ctor(System.Double,System.Double,System.Double,System.Double,System.Double,System.Double)"]

See Also

Reference

Region Class
Region Overload
Cognex.InSight.Job.Common Namespace


Region Properties

The Region type exposes the following members.

Properties
 | Name | Description
Public property | Angle |
Public property | Curve |
Public property | Height |
Public property | Width |
Public property | X |
Public property | Y |
Top
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region.Angle Property

RegionAngle Property

[Missing <summary> documentation for "P:Cognex.InSight.Job.Common.Region.Angle"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double Angle { get; set; }
Public Property Angle As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region.Curve Property

RegionCurve Property

[Missing <summary> documentation for "P:Cognex.InSight.Job.Common.Region.Curve"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double Curve { get; set; }
Public Property Curve As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region.Height Property

RegionHeight Property

[Missing <summary> documentation for "P:Cognex.InSight.Job.Common.Region.Height"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double Height { get; set; }
Public Property Height As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region.Width Property

RegionWidth Property

[Missing <summary> documentation for "P:Cognex.InSight.Job.Common.Region.Width"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double Width { get; set; }
Public Property Width As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region.X Property

RegionX Property

[Missing <summary> documentation for "P:Cognex.InSight.Job.Common.Region.X"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double X { get; set; }
Public Property X As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region.Y Property

RegionY Property

[Missing <summary> documentation for "P:Cognex.InSight.Job.Common.Region.Y"]

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double Y { get; set; }
Public Property Y As Double
    Get
    Set

Property Value

Type: Double
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Region Methods

The Region type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Region Class
Cognex.InSight.Job.Common Namespace


Sheet(TCell) Class

SheetTCell Class

A basic implementation of ISheetTCell.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonSheetTCell
Cognex.InSight.Job.IseIseSheet

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class Sheet<TCell> : ISheet<TCell>,
    IReadOnlySheet<TCell>, IEnumerable<TCell>, IEnumerable
where TCell : IReadOnlyCell

Public Class Sheet(Of TCell As IReadOnlyCell)
    Implements ISheet(Of TCell), IReadOnlySheet(Of TCell),
    IEnumerable(Of TCell), IEnumerable

Type Parameters

TCell
The most specific implementation of IReadOnlyCell that is desired.

The SheetTCell type exposes the following members.

Constructors
 | Name | Description
Public method | SheetTCell | Creates a new SheetTCell with no cells, and the provided name or null.
Top
Properties
 | Name | Description
Public property | Cells | A mutable collection of the cells in this sheet.
Public property | Name | The name of this sheet.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common Namespace


Sheet(TCell) Constructor

SheetTCell Constructor

Creates a new SheetTCell with no cells, and the provided name or null.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Sheet(
    string name = null
)
Public Sub New (
    Optional name As String = Nothing
)

Parameters

name (Optional)
Type: SystemString
See Also

Reference

SheetTCell Class
Cognex.InSight.Job.Common Namespace


Sheet(TCell) Properties

SheetTCell Properties

The SheetTCell generic type exposes the following members.

Properties
 | Name | Description
Public property | Cells | A mutable collection of the cells in this sheet.
Public property | Name | The name of this sheet.
Top
See Also

Reference

SheetTCell Class
Cognex.InSight.Job.Common Namespace


Sheet(TCell).Cells Property

SheetTCellCells Property

A mutable collection of the cells in this sheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IDictionary<CellLocation, TCell> Cells { get; set; }
Public Property Cells As IDictionary(Of CellLocation, TCell)
    Get
    Set

Property Value

Type: IDictionary CellLocation, TCell

Implements

ISheetTCellCells
See Also

Reference

SheetTCell Class
Cognex.InSight.Job.Common Namespace


Sheet(TCell).Name Property

SheetTCellName Property

The name of this sheet.

Namespace: Cognex.InSight.Job.Common
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

IReadOnlySheetTCellName
See Also

Reference

SheetTCell Class
Cognex.InSight.Job.Common Namespace


Sheet(TCell) Methods

SheetTCell Methods

The SheetTCell generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SheetTCell Class
Cognex.InSight.Job.Common Namespace


Cognex.InSight.Job.Common.EasyView Namespace

Base classes for EasyView in In-Sight spreadsheet jobs.
Classes
 | Class | Description
Public class | EasyViewDataItem | An EasyView item that has a caption and cell name.
Public class | EasyViewLabelItem | An EasyView item that only has a caption.
Public class | EasyViewTable | A table for a collection of IEasyViewItems.
Interfaces
 | Interface | Description
Public interface | IEasyViewItem | A basic EasyView item interface.


EasyViewDataItem Class

An EasyView item that has a caption and cell name.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Common.EasyViewEasyViewDataItem

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class EasyViewDataItem : IEasyViewItem
Public Class EasyViewDataItem
    Implements IEasyViewItem

The EasyViewDataItem type exposes the following members.

Constructors
 | Name | Description
Public method | EasyViewDataItem | Creates a new EasyViewDataItem with the provided parameters.
Top
Properties
 | Name | Description
Public property | Caption | The caption to be shown for this item.
Public property | CellName | The name that this cell should have in EasyView mode.
Public property | IsReadOnly | Whether or not this item is read only.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common.EasyView Namespace


EasyViewDataItem Constructor

Creates a new EasyViewDataItem with the provided parameters.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public EasyViewDataItem(
    string caption,
    string cellName,
    bool isReadOnly
)
Public Sub New (
    caption As String,
    cellName As String,
    isReadOnly As Boolean
)

Parameters

caption
Type: SystemString
The caption to be shown for this item.
cellName
Type: SystemString
The name that this cell should have in EasyView mode.
isReadOnly
Type: SystemBoolean
Whether or not this item is read only.
See Also

Reference

EasyViewDataItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewDataItem Properties

The EasyViewDataItem type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption to be shown for this item.
Public property | CellName | The name that this cell should have in EasyView mode.
Public property | IsReadOnly | Whether or not this item is read only.
Top
See Also

Reference

EasyViewDataItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewDataItem.Caption Property

EasyViewDataItemCaption Property

The caption to be shown for this item.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String

Implements

IEasyViewItemCaption
See Also

Reference

EasyViewDataItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewDataItem.CellName Property

EasyViewDataItemCellName Property

The name that this cell should have in EasyView mode.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string CellName { get; set; }
Public Property CellName As String
    Get
    Set

Property Value

Type: String
See Also

Reference

EasyViewDataItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewDataItem.IsReadOnly Property

EasyViewDataItemIsReadOnly Property

Whether or not this item is read only.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool IsReadOnly { get; set; }
Public Property IsReadOnly As Boolean
    Get
    Set

Property Value

Type: Boolean
See Also

Reference

EasyViewDataItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewDataItem Methods

The EasyViewDataItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EasyViewDataItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewLabelItem Class

An EasyView item that only has a caption.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Common.EasyViewEasyViewLabelItem

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class EasyViewLabelItem : IEasyViewItem
Public Class EasyViewLabelItem
    Implements IEasyViewItem

The EasyViewLabelItem type exposes the following members.

Constructors
 | Name | Description
Public method | EasyViewLabelItem | Creates a new EasyViewLabelItem with the provided parameters.
Top
Properties
 | Name | Description
Public property | Caption | The caption to be shown for this item.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common.EasyView Namespace


EasyViewLabelItem Constructor

Creates a new EasyViewLabelItem with the provided parameters.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public EasyViewLabelItem(
    string caption
)
Public Sub New (
    caption As String
)

Parameters

caption
Type: SystemString
The caption to be shown for this item.
See Also

Reference

EasyViewLabelItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewLabelItem Properties

The EasyViewLabelItem type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption to be shown for this item.
Top
See Also

Reference

EasyViewLabelItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewLabelItem.Caption Property

EasyViewLabelItemCaption Property

The caption to be shown for this item.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Caption { get; set; }
Public Property Caption As String
    Get
    Set

Property Value

Type: String

Implements

IEasyViewItemCaption
See Also

Reference

EasyViewLabelItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewLabelItem Methods

The EasyViewLabelItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EasyViewLabelItem Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewTable Class

A table for a collection of IEasyViewItems.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Common.EasyViewEasyViewTable

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class EasyViewTable
Public Class EasyViewTable

The EasyViewTable type exposes the following members.

Constructors
 | Name | Description
Public method | EasyViewTable | Creates a new EasyViewTable with no IEasyViewItems.
Top
Properties
 | Name | Description
Public property | Items | All of the IEasyViewItems that are stored in this table.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Common.EasyView Namespace


EasyViewTable Constructor

Creates a new EasyViewTable with no IEasyViewItems.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public EasyViewTable()
Public Sub New
See Also

Reference

EasyViewTable Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewTable Properties

The EasyViewTable type exposes the following members.

Properties
 | Name | Description
Public property | Items | All of the IEasyViewItems that are stored in this table.
Top
See Also

Reference

EasyViewTable Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewTable.Items Property

EasyViewTableItems Property

All of the IEasyViewItems that are stored in this table.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IList<IEasyViewItem> Items { get; set; }
Public Property Items As IList(Of IEasyViewItem)
    Get
    Set

Property Value

Type: IList IEasyViewItem
See Also

Reference

EasyViewTable Class
Cognex.InSight.Job.Common.EasyView Namespace


EasyViewTable Methods

The EasyViewTable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

EasyViewTable Class
Cognex.InSight.Job.Common.EasyView Namespace


IEasyViewItem Interface

A basic EasyView item interface.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface IEasyViewItem
Public Interface IEasyViewItem

The IEasyViewItem type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption to be shown for this item.
Top
See Also

Reference

Cognex.InSight.Job.Common.EasyView Namespace


IEasyViewItem Properties

The IEasyViewItem type exposes the following members.

Properties
 | Name | Description
Public property | Caption | The caption to be shown for this item.
Top
See Also

Reference

IEasyViewItem Interface
Cognex.InSight.Job.Common.EasyView Namespace


IEasyViewItem.Caption Property

IEasyViewItemCaption Property

The caption to be shown for this item.

Namespace: Cognex.InSight.Job.Common.EasyView
Assembly: Cognex.InSight.Job.Common (in Cognex.InSight.Job.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
string Caption { get; set; }
Property Caption As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IEasyViewItem Interface
Cognex.InSight.Job.Common.EasyView Namespace


Cognex.InSight.Job.Comparison.Common Namespace

Utilities for comparing In-Sight based spreadsheets and jobs.
Classes
 | Class | Description
Public class | BasicComparators | Defines a way to compare two values that would return a BasicDifferenceT that gives some simple overloads for common comparisons.
Public class | BasicDifferenceT | Contains a single difference between two objects.
Public class | CellComparator | Compares two cells, regardless of whether or not they are the same type.
Public class | CellDifference | Contains all of the differences that are based on values stored in both ISE and ISVS cells. If any of the fields are null, that indicates that that value is the same between the cells that were compared.
Public class | CollectionComparator | Provides simple comparison utilities for two collections.
Public class | SheetComparatorTCell, TCellDifference | Compares two sheets, regardless of whether or not they are the same type.
Public class | SheetDifferenceTCellDifference, TCell | Contains all of the differences between two SheetTCells.
Interfaces
 | Interface | Description
Public interface | ISheetDifferenceTCellDifference, TCell | Contains all of the differences between two SheetTCells.


BasicComparators Class

Defines a way to compare two values that would return a BasicDifferenceT that gives some simple overloads for common comparisons.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonBasicComparators

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static class BasicComparators
Public NotInheritable Class BasicComparators

The BasicComparators type exposes the following members.

Methods
Name | Description
CaseInsensitiveCompare | Compares two strings, ignoring differences in their capitalization.
CompareT(T, T) | Compares the two values given using the default equals implementation. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.
CompareT(T, T, FuncT, T, Boolean) | Compares the two values given using the specified comparison function. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


BasicComparators Methods

The BasicComparators type exposes the following members.

Methods
Name | Description
CaseInsensitiveCompare | Compares two strings, ignoring differences in their capitalization.
CompareT(T, T) | Compares the two values given using the default equals implementation. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.
CompareT(T, T, FuncT, T, Boolean) | Compares the two values given using the specified comparison function. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.
Top
See Also

Reference

BasicComparators Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicComparators.CaseInsensitiveCompare Method

BasicComparatorsCaseInsensitiveCompare Method

Compares two strings, ignoring differences in their capitalization.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static BasicDifference<string> CaseInsensitiveCompare(
    string stringA,
    string stringB
)
Public Shared Function CaseInsensitiveCompare (
    stringA As String,
    stringB As String
) As BasicDifference(Of String)

Parameters

stringA
Type: SystemString
The string in the 'A' cell.
stringB
Type: SystemString
The string in the 'B' cell.

Return Value

Type: BasicDifference String
A new BasicDifferenceT if there was a difference, null otherwise.
See Also

Reference

BasicComparators Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicComparators.Compare Method

BasicComparatorsCompare Method

Overload List
Name | Description
CompareT(T, T) | Compares the two values given using the default equals implementation. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.
CompareT(T, T, FuncT, T, Boolean) | Compares the two values given using the specified comparison function. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.
Top
See Also

Reference

BasicComparators Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicComparators.Compare(T) Method (T, T)

BasicComparatorsCompareT Method (T, T)

Compares the two values given using the default equals implementation. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static BasicDifference<T> Compare<T>(
    T valueA,
    T valueB
)

Public Shared Function Compare(Of T) (
    valueA As T,
    valueB As T
) As BasicDifference(Of T)

Parameters

valueA
Type: T
The value in the 'A' cell.
valueB
Type: T
The value in the 'B' cell.

Type Parameters

T
The type of the value.

Return Value

Type: BasicDifference T
A new BasicDifferenceT if there was a difference, null otherwise.
See Also

Reference

BasicComparators Class
Compare Overload
Cognex.InSight.Job.Comparison.Common Namespace


BasicComparators.Compare(T) Method (T, T, Func(T, T, Boolean))

BasicComparatorsCompareT Method (T, T, FuncT, T, Boolean)

Compares the two values given using the specified comparison function. If the values are different, returns a new BasicDifferenceT. Otherwise, returns null.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static BasicDifference<T> Compare<T>(
    T valueA,
    T valueB,
    Func<T, T, bool> comparator
)

Public Shared Function Compare(Of T) (
    valueA As T,
    valueB As T,
    comparator As Func(Of T, T, Boolean)
) As BasicDifference(Of T)

Parameters

valueA
Type: T
The value in the 'A' cell.
valueB
Type: T
The value in the 'B' cell.
comparator
Type: SystemFunc T, T, Boolean
The comparison function to use.

Type Parameters

T
The type of the value.

Return Value

Type: BasicDifference T
A new BasicDifferenceT if there was a difference, null otherwise.
See Also

Reference

BasicComparators Class
Compare Overload
Cognex.InSight.Job.Comparison.Common Namespace


BasicDifference(T) Class

BasicDifferenceT Class

Contains a single difference between two objects.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonBasicDifferenceT

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class BasicDifference<T>

Public Class BasicDifference(Of T)

Type Parameters

T
The type of the value that this different.

The BasicDifferenceT type exposes the following members.

Constructors
 | Name | Description
Public method | BasicDifferenceT | Creates a new BasicDifferenceT that has the values from each object being compared.
Top
Properties
 | Name | Description
Public property | ValueA | The value in the 'A' object.
Public property | ValueB | The value in the 'B' object.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


BasicDifference(T) Constructor

BasicDifferenceT Constructor

Creates a new BasicDifferenceT that has the values from each object being compared.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference(
    T valueA,
    T valueB
)
Public Sub New (
    valueA As T,
    valueB As T
)

Parameters

valueA
Type: T
The value from the 'A' object.
valueB
Type: T
The value from the 'B' object.
See Also

Reference

BasicDifferenceT Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicDifference(T) Properties

BasicDifferenceT Properties

The BasicDifferenceT generic type exposes the following members.

Properties
 | Name | Description
Public property | ValueA | The value in the 'A' object.
Public property | ValueB | The value in the 'B' object.
Top
See Also

Reference

BasicDifferenceT Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicDifference(T).ValueA Property

BasicDifferenceTValueA Property

The value in the 'A' object.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public T ValueA { get; }
Public ReadOnly Property ValueA As T
    Get

Property Value

Type: T
See Also

Reference

BasicDifferenceT Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicDifference(T).ValueB Property

BasicDifferenceTValueB Property

The value in the 'B' object.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public T ValueB { get; }
Public ReadOnly Property ValueB As T
    Get

Property Value

Type: T
See Also

Reference

BasicDifferenceT Class
Cognex.InSight.Job.Comparison.Common Namespace


BasicDifference(T) Methods

BasicDifferenceT Methods

The BasicDifferenceT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BasicDifferenceT Class
Cognex.InSight.Job.Comparison.Common Namespace


CellComparator Class

Compares two cells, regardless of whether or not they are the same type.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonCellComparator

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static class CellComparator
Public NotInheritable Class CellComparator

The CellComparator type exposes the following members.

Methods
Name | Description
Compare | Compares the two cells given, returning a CellDifference or null if no differences were detected.
FillCellDifference | Checks for differences that exist in both Job generations between the two cells. If any differences are found, returns true.
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


CellComparator Methods

The CellComparator type exposes the following members.

Methods
Name | Description
Compare | Compares the two cells given, returning a CellDifference or null if no differences were detected.
FillCellDifference | Checks for differences that exist in both Job generations between the two cells. If any differences are found, returns true.
Top
See Also

Reference

CellComparator Class
Cognex.InSight.Job.Comparison.Common Namespace


CellComparator.Compare Method

CellComparatorCompare Method

Compares the two cells given, returning a CellDifference or null if no differences were detected.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static CellDifference Compare(
    IReadOnlyCell cellA,
    IReadOnlyCell cellB
)
Public Shared Function Compare (
    cellA As IReadOnlyCell,
    cellB As IReadOnlyCell
) As CellDifference

Parameters

cellA
Type: Cognex.InSight.Job.CommonIReadOnlyCell
The cell from sheet 'A' to compare.
cellB
Type: Cognex.InSight.Job.CommonIReadOnlyCell
The cell from sheet 'B' to compare.

Return Value

Type: CellDifference
A CellDifference if there were any differences, null otherwise.
See Also

Reference

CellComparator Class
Cognex.InSight.Job.Comparison.Common Namespace


CellComparator.FillCellDifference Method

CellComparatorFillCellDifference Method

Checks for differences that exist in both Job generations between the two cells. If any differences are found, returns true.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool FillCellDifference(
    IReadOnlyCell cellA,
    IReadOnlyCell cellB,
    CellDifference diff
)
Public Shared Function FillCellDifference (
    cellA As IReadOnlyCell,
    cellB As IReadOnlyCell,
    diff As CellDifference
) As Boolean

Parameters

cellA
Type: Cognex.InSight.Job.CommonIReadOnlyCell
The cell from sheet 'A' to compare.
cellB
Type: Cognex.InSight.Job.CommonIReadOnlyCell
The cell from sheet 'B' to compare.
diff
Type: Cognex.InSight.Job.Comparison.CommonCellDifference
The CellDifference that will hold any differences found.

Return Value

Type: Boolean
True if there were any differences between the cells, otherwise false.
See Also

Reference

CellComparator Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference Class

Contains all of the differences that are based on values stored in both ISE and ISVS cells. If any of the fields are null, that indicates that that value is the same between the cells that were compared.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonCellDifference
Cognex.InSight.Job.Comparison.IseIseCellDifference

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class CellDifference
Public Class CellDifference

The CellDifference type exposes the following members.

Constructors
 | Name | Description
Public method | CellDifference | Creates a new CellDifference that has the two locations of the cells being compared. Defaults to all differences being null, indicating that nothing is different.
Top
Properties
 | Name | Description
Public property | CellState | Whether or not the cell is enabled, disabled, or conditionally enabled.
Public property | Comment | The comment that is applied to a cell.
Public property | Expression | The expression that the cell contains.
Public property | LocationA | The location of the cell in the 'A' sheet.
Public property | LocationB | The location of the cell in the 'B' sheet.
Public property | Name | The name of the cell.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


CellDifference Constructor

Creates a new CellDifference that has the two locations of the cells being compared. Defaults to all differences being null, indicating that nothing is different.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellDifference(
    CellLocation locationA,
    CellLocation locationB
)
Public Sub New (
    locationA As CellLocation,
    locationB As CellLocation
)

Parameters

locationA
Type: Cognex.InSight.Job.CommonCellLocation
The location of the cell in the 'A' sheet.
locationB
Type: Cognex.InSight.Job.CommonCellLocation
The location of the cell in the 'B' sheet.
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference Properties

The CellDifference type exposes the following members.

Properties
 | Name | Description
Public property | CellState | Whether or not the cell is enabled, disabled, or conditionally enabled.
Public property | Comment | The comment that is applied to a cell.
Public property | Expression | The expression that the cell contains.
Public property | LocationA | The location of the cell in the 'A' sheet.
Public property | LocationB | The location of the cell in the 'B' sheet.
Public property | Name | The name of the cell.
Top
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference.CellState Property

CellDifferenceCellState Property

Whether or not the cell is enabled, disabled, or conditionally enabled.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> CellState { get; }
Public ReadOnly Property CellState As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference.Comment Property

CellDifferenceComment Property

The comment that is applied to a cell.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> Comment { get; }
Public ReadOnly Property Comment As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference.Expression Property

CellDifferenceExpression Property

The expression that the cell contains.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> Expression { get; }
Public ReadOnly Property Expression As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference.LocationA Property

CellDifferenceLocationA Property

The location of the cell in the 'A' sheet.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation LocationA { get; }
Public ReadOnly Property LocationA As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference.LocationB Property

CellDifferenceLocationB Property

The location of the cell in the 'B' sheet.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation LocationB { get; }
Public ReadOnly Property LocationB As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference.Name Property

CellDifferenceName Property

The name of the cell.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> Name { get; }
Public ReadOnly Property Name As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CellDifference Methods

The CellDifference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator Class

Provides simple comparison utilities for two collections.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonCollectionComparator

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static class CollectionComparator
Public NotInheritable Class CollectionComparator
Methods
Name | Description
AreEqualT(T, T, FuncObject, Object, Boolean) | Compares two non-generic collections using the provided comparator as the element comparison operator.
AreEqualT, E(T, T, FuncE, E, Boolean) | Compares two collections using the provided comparator as the element comparison operator.
CompareT, E(T, T) | Compares two collections using Equals(Object) as the element comparison operator.
CompareT, E(T, T, FuncE, E, Boolean) | Compares two collections using the provided comparator as the element comparison operator.
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator Methods

Methods
Name | Description
AreEqualT(T, T, FuncObject, Object, Boolean) | Compares two non-generic collections using the provided comparator as the element comparison operator.
AreEqualT, E(T, T, FuncE, E, Boolean) | Compares two collections using the provided comparator as the element comparison operator.
CompareT, E(T, T) | Compares two collections using Equals(Object) as the element comparison operator.
CompareT, E(T, T, FuncE, E, Boolean) | Compares two collections using the provided comparator as the element comparison operator.
Top
See Also

Reference

CollectionComparator Class
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator.AreEqual Method

CollectionComparatorAreEqual Method

Overload List
Name | Description
AreEqualT(T, T, FuncObject, Object, Boolean) | Compares two non-generic collections using the provided comparator as the element comparison operator.
AreEqualT, E(T, T, FuncE, E, Boolean) | Compares two collections using the provided comparator as the element comparison operator.
Top
See Also

Reference

CollectionComparator Class
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator.AreEqual(T) Method (T, T, Func(Object, Object, Boolean))

CollectionComparatorAreEqualT Method (T, T, FuncObject, Object, Boolean)

Compares two non-generic collections using the provided comparator as the element comparison operator.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool AreEqual<T>(
    T collectionA,
    T collectionB,
    Func<Object, Object, bool> elementComparator = null
)
where T : ICollection

Public Shared Function AreEqual(Of T As ICollection) (
    collectionA As T,
    collectionB As T,
    Optional elementComparator As Func(Of Object, Object, Boolean) = Nothing
) As Boolean

Parameters

collectionA
Type: T
One of the collections to compare.
collectionB
Type: T
The other collection to compare.
elementComparator (Optional)
Type: SystemFunc Object, Object, Boolean
The comparison function to be used on objects, or null if Equals(Object) should be used.

Type Parameters

T
The collection type.

Return Value

Type: Boolean
True if the collections are the same, otherwise false.
See Also

Reference

CollectionComparator Class
AreEqual Overload
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator.AreEqual(T, E) Method (T, T, Func(E, E, Boolean))

CollectionComparatorAreEqualT, E Method (T, T, FuncE, E, Boolean)

Compares two collections using the provided comparator as the element comparison operator.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool AreEqual<T, E>(
    T collectionA,
    T collectionB,
    Func<E, E, bool> elementComparator = null
)
where T : Object, ICollection<E>

Public Shared Function AreEqual(Of T As {Object, ICollection(Of E)}, E) (
    collectionA As T,
    collectionB As T,
    Optional elementComparator As Func(Of E, E, Boolean) = Nothing
) As Boolean

Parameters

collectionA
Type: T
One of the collections to compare.
collectionB
Type: T
The other collection to compare.
elementComparator (Optional)
Type: SystemFunc E, E, Boolean
The comparison function to be used on objects, or null if Equals(Object) should be used.

Type Parameters

T
The collection type.
E
The type of the items stored in the collection.

Return Value

Type: Boolean
True if the collections are the same, otherwise false.
See Also

Reference

CollectionComparator Class
AreEqual Overload
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator.Compare Method

CollectionComparatorCompare Method

Overload List
Name | Description
CompareT, E(T, T) | Compares two collections using Equals(Object) as the element comparison operator.
CompareT, E(T, T, FuncE, E, Boolean) | Compares two collections using the provided comparator as the element comparison operator.
Top
See Also

Reference

CollectionComparator Class
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator.Compare(T, E) Method (T, T)

CollectionComparatorCompareT, E Method (T, T)

Compares two collections using Equals(Object) as the element comparison operator.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static BasicDifference<T> Compare<T, E>(
    T collectionA,
    T collectionB
)
where T : Object, ICollection<E>

Public Shared Function Compare(Of T As {Object, ICollection(Of E)}, E) (
    collectionA As T,
    collectionB As T
) As BasicDifference(Of T)

Parameters

collectionA
Type: T
One of the collections to compare.
collectionB
Type: T
The other collection to compare.

Type Parameters

T
The collection type.
E
The type of the items stored in the collection.

Return Value

Type: BasicDifference T
A new BasicDifferenceT if the collections are different, otherwise null.
See Also

Reference

CollectionComparator Class
Compare Overload
Cognex.InSight.Job.Comparison.Common Namespace


CollectionComparator.Compare(T, E) Method (T, T, Func(E, E, Boolean))

CollectionComparatorCompareT, E Method (T, T, FuncE, E, Boolean)

Compares two collections using the provided comparator as the element comparison operator.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static BasicDifference<T> Compare<T, E>(
    T collectionA,
    T collectionB,
    Func<E, E, bool> elementComparator = null
)
where T : Object, ICollection<E>

Public Shared Function Compare(Of T As {Object, ICollection(Of E)}, E) (
    collectionA As T,
    collectionB As T,
    Optional elementComparator As Func(Of E, E, Boolean) = Nothing
) As BasicDifference(Of T)

Parameters

collectionA
Type: T
One of the collections to compare.
collectionB
Type: T
The other collection to compare.
elementComparator (Optional)
Type: SystemFunc E, E, Boolean
The comparison function to be used on objects, or null if Equals(Object) should be used.

Type Parameters

T
The collection type.
E
The type of the items stored in the collection.

Return Value

Type: BasicDifference T
A new BasicDifferenceT if the collections are different, otherwise null.
See Also

Reference

CollectionComparator Class
Compare Overload
Cognex.InSight.Job.Comparison.Common Namespace


ISheetDifference(TCellDifference, TCell) Interface

ISheetDifferenceTCellDifference, TCell Interface

Contains all of the differences between two SheetTCells.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public interface ISheetDifference<out TCellDifference, out TCell>
where TCellDifference : CellDifference
where TCell : IReadOnlyCell

Public Interface ISheetDifference(Of Out TCellDifference As CellDifference, Out TCell As IReadOnlyCell)

Type Parameters

TCellDifference
The type of cell differences this sheet difference contains.
TCell
The type of cells this sheet difference contains.

The ISheetDifferenceTCellDifference, TCell type exposes the following members.

Properties
 | Name | Description
Public property | ChangedCells | A collection of all of the cell changes where one or more things were different between cells.
Public property | InsertedCells | A collection of all of the cells that were inserted into the 'B' sheet.
Public property | RemovedCells | A collection of all of the cells that were removed from the 'B' sheet.
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


ISheetDifference(TCellDifference, TCell) Properties

ISheetDifferenceTCellDifference, TCell Properties

The ISheetDifferenceTCellDifference, TCell generic type exposes the following members.

Properties
 | Name | Description
Public property | ChangedCells | A collection of all of the cell changes where one or more things were different between cells.
Public property | InsertedCells | A collection of all of the cells that were inserted into the 'B' sheet.
Public property | RemovedCells | A collection of all of the cells that were removed from the 'B' sheet.
Top
See Also

Reference

ISheetDifferenceTCellDifference, TCell Interface
Cognex.InSight.Job.Comparison.Common Namespace


ISheetDifference(TCellDifference, TCell).ChangedCells Property

ISheetDifferenceTCellDifference, TCellChangedCells Property

A collection of all of the cell changes where one or more things were different between cells.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
IReadOnlyCollection<TCellDifference> ChangedCells { get; }
ReadOnly Property ChangedCells As IReadOnlyCollection(Of TCellDifference)
    Get

Property Value

Type: IReadOnlyCollection TCellDifference
See Also

Reference

ISheetDifferenceTCellDifference, TCell Interface
Cognex.InSight.Job.Comparison.Common Namespace


ISheetDifference(TCellDifference, TCell).InsertedCells Property

ISheetDifferenceTCellDifference, TCellInsertedCells Property

A collection of all of the cells that were inserted into the 'B' sheet.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
IReadOnlyCollection<TCell> InsertedCells { get; }
ReadOnly Property InsertedCells As IReadOnlyCollection(Of TCell)
    Get

Property Value

Type: IReadOnlyCollection TCell
See Also

Reference

ISheetDifferenceTCellDifference, TCell Interface
Cognex.InSight.Job.Comparison.Common Namespace


ISheetDifference(TCellDifference, TCell).RemovedCells Property

ISheetDifferenceTCellDifference, TCellRemovedCells Property

A collection of all of the cells that were removed from the 'B' sheet.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
IReadOnlyCollection<TCell> RemovedCells { get; }
ReadOnly Property RemovedCells As IReadOnlyCollection(Of TCell)
    Get

Property Value

Type: IReadOnlyCollection TCell
See Also

Reference

ISheetDifferenceTCellDifference, TCell Interface
Cognex.InSight.Job.Comparison.Common Namespace


SheetComparator(TCell, TCellDifference) Class

SheetComparatorTCell, TCellDifference Class

Compares two sheets, regardless of whether or not they are the same type.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonSheetComparatorTCell, TCellDifference

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class SheetComparator<TCell, TCellDifference>
where TCell : IReadOnlyCell
where TCellDifference : CellDifference

Public Class SheetComparator(Of TCell As IReadOnlyCell, TCellDifference As CellDifference)

Type Parameters

TCell
The type of cells that the sheet contains.
TCellDifference
The difference type that the cell comparer will return.

The SheetComparatorTCell, TCellDifference type exposes the following members.

Methods
 | Name | Description
 | Compare | Compares 2 sheets, running the specified comparator on each cell.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


SheetComparator(TCell, TCellDifference) Methods

SheetComparatorTCell, TCellDifference Methods

The SheetComparatorTCell, TCellDifference generic type exposes the following members.

Methods
 | Name | Description
 | Compare | Compares 2 sheets, running the specified comparator on each cell.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SheetComparatorTCell, TCellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetComparator(TCell, TCellDifference).Compare Method

SheetComparatorTCell, TCellDifferenceCompare Method

Compares 2 sheets, running the specified comparator on each cell.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static SheetDifference<TCellDifference, TCell> Compare(
    IReadOnlySheet<TCell> sheetA,
    IReadOnlySheet<TCell> sheetB,
    Func<TCell, TCell, TCellDifference> cellComparator
)
Public Shared Function Compare (
    sheetA As IReadOnlySheet(Of TCell),
    sheetB As IReadOnlySheet(Of TCell),
    cellComparator As Func(Of TCell, TCell, TCellDifference)
) As SheetDifference(Of TCellDifference, TCell)

Parameters

sheetA
Type: Cognex.InSight.Job.CommonIReadOnlySheet TCell
The first sheet in the comparison
sheetB
Type: Cognex.InSight.Job.CommonIReadOnlySheet TCell
The second sheet in the comparison
cellComparator
Type: SystemFunc TCell, TCell, TCellDifference
The cell comaprator to use fo compare cells in the same location

Return Value

Type: SheetDifference TCellDifference, TCell
A SheetDifferenceTCellDifference, TCell that contains all of the differences found in the sheets.
Remarks
Currently, this does a simple compare based on cell locations and does not detect row and column insertion.
See Also

Reference

SheetComparatorTCell, TCellDifference Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell) Class

SheetDifferenceTCellDifference, TCell Class

Contains all of the differences between two SheetTCells.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonSheetDifferenceTCellDifference, TCell

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class SheetDifference<TCellDifference, TCell> : ISheetDifference<TCellDifference, TCell>
where TCellDifference : CellDifference
where TCell : IReadOnlyCell

Public Class SheetDifference(Of TCellDifference As CellDifference, TCell As IReadOnlyCell)
    Implements ISheetDifference(Of TCellDifference, TCell)

Type Parameters

TCellDifference
The type of cell differences this sheet difference contains.
TCell
The type of cells this sheet difference contains.

The SheetDifferenceTCellDifference, TCell type exposes the following members.

Constructors
 | Name | Description
Public method | SheetDifferenceTCellDifference, TCell | Creates a new SheetDifferenceTCellDifference, TCell that contains all of the differences in cells, as well as all of the cells that were added and removed.
Top
Properties
 | Name | Description
Public property | ChangedCells | A collection of all of the cell changes where one or more things were different between cells.
Public property | InsertedCells | A collection of all of the cells that were inserted into the 'B' sheet.
Public property | RemovedCells | A collection of all of the cells that were removed from the 'B' sheet.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell) Constructor

SheetDifferenceTCellDifference, TCell Constructor

Creates a new SheetDifferenceTCellDifference, TCell that contains all of the differences in cells, as well as all of the cells that were added and removed.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public SheetDifference(
    IEnumerable<TCellDifference> changedCells,
    IEnumerable<TCell> insertedCells,
    IEnumerable<TCell> removedCells
)
Public Sub New (
    changedCells As IEnumerable(Of TCellDifference),
    insertedCells As IEnumerable(Of TCell),
    removedCells As IEnumerable(Of TCell)
)

Parameters

changedCells
Type: System.Collections.GenericIEnumerable TCellDifference
A collection of all of the CellDifferences that were present.
insertedCells
Type: System.Collections.GenericIEnumerable TCell
A collection of all of the locations that cells were inserted into the 'B' sheet.
removedCells
Type: System.Collections.GenericIEnumerable TCell
A collection of all of the locations that cells were removed from in the 'B' sheet.
See Also

Reference

SheetDifferenceTCellDifference, TCell Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell) Properties

SheetDifferenceTCellDifference, TCell Properties

The SheetDifferenceTCellDifference, TCell generic type exposes the following members.

Properties
 | Name | Description
Public property | ChangedCells | A collection of all of the cell changes where one or more things were different between cells.
Public property | InsertedCells | A collection of all of the cells that were inserted into the 'B' sheet.
Public property | RemovedCells | A collection of all of the cells that were removed from the 'B' sheet.
Top
See Also

Reference

SheetDifferenceTCellDifference, TCell Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell).ChangedCells Property

SheetDifferenceTCellDifference, TCellChangedCells Property

A collection of all of the cell changes where one or more things were different between cells.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IReadOnlyCollection<TCellDifference> ChangedCells { get; }
Public ReadOnly Property ChangedCells As IReadOnlyCollection(Of TCellDifference)
    Get

Property Value

Type: IReadOnlyCollection TCellDifference

Implements

ISheetDifferenceTCellDifference, TCellChangedCells
See Also

Reference

SheetDifferenceTCellDifference, TCell Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell).InsertedCells Property

SheetDifferenceTCellDifference, TCellInsertedCells Property

A collection of all of the cells that were inserted into the 'B' sheet.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IReadOnlyCollection<TCell> InsertedCells { get; }
Public ReadOnly Property InsertedCells As IReadOnlyCollection(Of TCell)
    Get

Property Value

Type: IReadOnlyCollection TCell

Implements

ISheetDifferenceTCellDifference, TCellInsertedCells
See Also

Reference

SheetDifferenceTCellDifference, TCell Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell).RemovedCells Property

SheetDifferenceTCellDifference, TCellRemovedCells Property

A collection of all of the cells that were removed from the 'B' sheet.

Namespace: Cognex.InSight.Job.Comparison.Common
Assembly: Cognex.InSight.Job.Comparison.Common (in Cognex.InSight.Job.Comparison.Common.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IReadOnlyCollection<TCell> RemovedCells { get; }
Public ReadOnly Property RemovedCells As IReadOnlyCollection(Of TCell)
    Get

Property Value

Type: IReadOnlyCollection TCell

Implements

ISheetDifferenceTCellDifference, TCellRemovedCells
See Also

Reference

SheetDifferenceTCellDifference, TCell Class
Cognex.InSight.Job.Comparison.Common Namespace


SheetDifference(TCellDifference, TCell) Methods

SheetDifferenceTCellDifference, TCell Methods

The SheetDifferenceTCellDifference, TCell generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

SheetDifferenceTCellDifference, TCell Class
Cognex.InSight.Job.Comparison.Common Namespace


Cognex.InSight.Job.Comparison.Ise Namespace

Utilities for comparing In-Sight Explorer based jobs.
Classes
 | Class | Description
Public class | IseCellComparator | Compares two ISE cells.
Public class | IseCellDifference | Contains all of the ISE cell specific differences. If any of the fields are null, that indicates that that value is the same between the cells that were compared.
Public class | IseJobComparator | Compares the IseSheets contained by two IseJobs. Finds differences in metadata as well as the underlying sheets.
Public class | IseJobDifference | Contains the SheetDifference, IseJobMetadataDifference, and IsePassFailSettingsDifference that hold the differences between different IseJobs.
Public class | IseJobMetadataDifference | Stores the differences in metadata of IseJobs.
Public class | IsePassFailSettingsDifference | Holds the differences between two jobs pass/fail settings.


IseCellComparator Class

Compares two ISE cells.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.IseIseCellComparator

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static class IseCellComparator
Public NotInheritable Class IseCellComparator

The IseCellComparator type exposes the following members.

Methods
Name | Description
Compare | Compares the two cells given, returning a IseCellDifference or null if no differences were detected.
FillCellDifference | Checks for differences that exist between the cells. If any differences are found, returns true.
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Ise Namespace


IseCellComparator Methods

The IseCellComparator type exposes the following members.

Methods
Name | Description
Compare | Compares the two cells given, returning a IseCellDifference or null if no differences were detected.
FillCellDifference | Checks for differences that exist between the cells. If any differences are found, returns true.
Top
See Also

Reference

IseCellComparator Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellComparator.Compare Method

IseCellComparatorCompare Method

Compares the two cells given, returning a IseCellDifference or null if no differences were detected.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static IseCellDifference Compare(
    IseCell cellA,
    IseCell cellB
)
Public Shared Function Compare (
    cellA As IseCell,
    cellB As IseCell
) As IseCellDifference

Parameters

cellA
Type: Cognex.InSight.Job.IseIseCell
The cell from sheet 'A' to compare.
cellB
Type: Cognex.InSight.Job.IseIseCell
The cell from sheet 'B' to compare.

Return Value

Type: IseCellDifference
A IseCellDifference if there were any differences, null otherwise.
See Also

Reference

IseCellComparator Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellComparator.FillCellDifference Method

IseCellComparatorFillCellDifference Method

Checks for differences that exist between the cells. If any differences are found, returns true.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static bool FillCellDifference(
    IseCell cellA,
    IseCell cellB,
    IseCellDifference diff
)
Public Shared Function FillCellDifference (
    cellA As IseCell,
    cellB As IseCell,
    diff As IseCellDifference
) As Boolean

Parameters

cellA
Type: Cognex.InSight.Job.IseIseCell
The cell from sheet 'A' to compare.
cellB
Type: Cognex.InSight.Job.IseIseCell
The cell from sheet 'B' to compare.
diff
Type: Cognex.InSight.Job.Comparison.IseIseCellDifference
The IseCellDifference that will hold any differences found.

Return Value

Type: Boolean
True if there were any differences between the cells, otherwise false.
See Also

Reference

IseCellComparator Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference Class

Contains all of the ISE cell specific differences. If any of the fields are null, that indicates that that value is the same between the cells that were compared.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.CommonCellDifference
Cognex.InSight.Job.Comparison.IseIseCellDifference

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseCellDifference : CellDifference
Public Class IseCellDifference
    Inherits CellDifference

The IseCellDifference type exposes the following members.

Constructors
 | Name | Description
Public method | IseCellDifference | Creates a new IseCellDifference that has the two locations of the cells being compared. Defaults to all differences being null, indicating that nothing is different.
Top
Properties
 | Name | Description
Public property | AuditTagEnabled | Whether or not the audit tag is enabled for the EasyBuilder tag.
Public property | CellState | Whether or not the cell is enabled, disabled, or conditionally enabled. (Inherited from CellDifference.)
Public property | Comment | The comment that is applied to a cell. (Inherited from CellDifference.)
Public property | EasyBuilderTag | The EasyBuilder tag that the cell holds.
Public property | EasyViewTagEnabled | Whether or not the EasyView tag is enabled for the EasyBuilder tag.
Public property | Expression | The expression that the cell contains. (Inherited from CellDifference.)
Public property | LocationA | The location of the cell in the 'A' sheet. (Inherited from CellDifference.)
Public property | LocationB | The location of the cell in the 'B' sheet. (Inherited from CellDifference.)
Public property | Name | The name of the cell. (Inherited from CellDifference.)
Public property | OpcTagEnabled | Whether or not the OPC tag is enabled for the EasyBuilder tag.
Public property | Saved | The cell's stored data.
Public property | Value | The cell result value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference Constructor

Creates a new IseCellDifference that has the two locations of the cells being compared. Defaults to all differences being null, indicating that nothing is different.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseCellDifference(
    CellLocation locationA,
    CellLocation locationB
)
Public Sub New (
    locationA As CellLocation,
    locationB As CellLocation
)

Parameters

locationA
Type: Cognex.InSight.Job.CommonCellLocation
The location of the cell in the 'A' sheet.
locationB
Type: Cognex.InSight.Job.CommonCellLocation
The location of the cell in the 'B' sheet.
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference Properties

The IseCellDifference type exposes the following members.

Properties
 | Name | Description
Public property | AuditTagEnabled | Whether or not the audit tag is enabled for the EasyBuilder tag.
Public property | CellState | Whether or not the cell is enabled, disabled, or conditionally enabled. (Inherited from CellDifference.)
Public property | Comment | The comment that is applied to a cell. (Inherited from CellDifference.)
Public property | EasyBuilderTag | The EasyBuilder tag that the cell holds.
Public property | EasyViewTagEnabled | Whether or not the EasyView tag is enabled for the EasyBuilder tag.
Public property | Expression | The expression that the cell contains. (Inherited from CellDifference.)
Public property | LocationA | The location of the cell in the 'A' sheet. (Inherited from CellDifference.)
Public property | LocationB | The location of the cell in the 'B' sheet. (Inherited from CellDifference.)
Public property | Name | The name of the cell. (Inherited from CellDifference.)
Public property | OpcTagEnabled | Whether or not the OPC tag is enabled for the EasyBuilder tag.
Public property | Saved | The cell's stored data.
Public property | Value | The cell result value.
Top
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference.AuditTagEnabled Property

IseCellDifferenceAuditTagEnabled Property

Whether or not the audit tag is enabled for the EasyBuilder tag.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<bool> AuditTagEnabled { get; }
Public ReadOnly Property AuditTagEnabled As BasicDifference(Of Boolean)
    Get

Property Value

Type: BasicDifference Boolean
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference.EasyBuilderTag Property

IseCellDifferenceEasyBuilderTag Property

The EasyBuilder tag that the cell holds.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> EasyBuilderTag { get; }
Public ReadOnly Property EasyBuilderTag As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference.EasyViewTagEnabled Property

IseCellDifferenceEasyViewTagEnabled Property

Whether or not the EasyView tag is enabled for the EasyBuilder tag.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<bool> EasyViewTagEnabled { get; }
Public ReadOnly Property EasyViewTagEnabled As BasicDifference(Of Boolean)
    Get

Property Value

Type: BasicDifference Boolean
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference.OpcTagEnabled Property

IseCellDifferenceOpcTagEnabled Property

Whether or not the OPC tag is enabled for the EasyBuilder tag.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<bool> OpcTagEnabled { get; }
Public ReadOnly Property OpcTagEnabled As BasicDifference(Of Boolean)
    Get

Property Value

Type: BasicDifference Boolean
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference.Saved Property

IseCellDifferenceSaved Property

The cell's stored data.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<Object> Saved { get; }
Public ReadOnly Property Saved As BasicDifference(Of Object)
    Get

Property Value

Type: BasicDifference Object
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference.Value Property

IseCellDifferenceValue Property

The cell result value.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<Object> Value { get; }
Public ReadOnly Property Value As BasicDifference(Of Object)
    Get

Property Value

Type: BasicDifference Object
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseCellDifference Methods

The IseCellDifference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseCellDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobComparator Class

Compares the IseSheets contained by two IseJobs. Finds differences in metadata as well as the underlying sheets.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.IseIseJobComparator

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseJobComparator
Public Class IseJobComparator

The IseJobComparator type exposes the following members.

Constructors
 | Name | Description
Public method | IseJobComparator | Initializes a new instance of the IseJobComparator class
Top
Methods
 | Name | Description
 | Compare | Compares the IseSheets contained by two IseJobs. Finds differences in metadata as well as the underlying sheets.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Ise Namespace


IseJobComparator Constructor

Initializes a new instance of the IseJobComparator class

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJobComparator()
Public Sub New
See Also

Reference

IseJobComparator Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobComparator Methods

The IseJobComparator type exposes the following members.

Methods
 | Name | Description
 | Compare | Compares the IseSheets contained by two IseJobs. Finds differences in metadata as well as the underlying sheets.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseJobComparator Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobComparator.Compare Method

IseJobComparatorCompare Method

Compares the IseSheets contained by two IseJobs. Finds differences in metadata as well as the underlying sheets.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static IseJobDifference Compare(
    IseJob jobA,
    IseJob jobB
)
Public Shared Function Compare (
    jobA As IseJob,
    jobB As IseJob
) As IseJobDifference

Parameters

jobA
Type: Cognex.InSight.Job.IseIseJob
The 'A' job to compare.
jobB
Type: Cognex.InSight.Job.IseIseJob
The 'B' job to compare.

Return Value

Type: IseJobDifference
A IseJobDifference containing all of the metadata, sheet, and cell differences.
See Also

Reference

IseJobComparator Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference Class

Contains the SheetDifference, IseJobMetadataDifference, and IsePassFailSettingsDifference that hold the differences between different IseJobs.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.IseIseJobDifference

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseJobDifference
Public Class IseJobDifference

The IseJobDifference type exposes the following members.

Constructors
 | Name | Description
Public method | IseJobDifference | Creates a new IseJobDifference with the given metadata and sheet differences.
Top
Properties
 | Name | Description
Public property | MetadataDifference | The differences in job metadata that were detected, or null if no metadata differences were detected.
Public property | PassFailSettingsDifference | The differences in the job pass/fail settings, or null if there are none.
Public property | SheetDifference | The differences in the sheet contained by the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference Constructor

Creates a new IseJobDifference with the given metadata and sheet differences.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJobDifference(
    IseJobMetadataDifference metadata,
    SheetDifference<IseCellDifference, IseCell> sheetDifference,
    IsePassFailSettingsDifference passFailSettingsDifference
)
Public Sub New (
    metadata As IseJobMetadataDifference,
    sheetDifference As SheetDifference(Of IseCellDifference, IseCell),
    passFailSettingsDifference As IsePassFailSettingsDifference
)

Parameters

metadata
Type: Cognex.InSight.Job.Comparison.IseIseJobMetadataDifference
The metadata differences in the job, or null if there are none.
sheetDifference
Type: Cognex.InSight.Job.Comparison.CommonSheetDifference IseCellDifference, IseCell
The differences in the sheets that were compared.
passFailSettingsDifference
Type: Cognex.InSight.Job.Comparison.IseIsePassFailSettingsDifference
The differences in the job pass/fail settings, or null if there are none.
See Also

Reference

IseJobDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference Properties

The IseJobDifference type exposes the following members.

Properties
 | Name | Description
Public property | MetadataDifference | The differences in job metadata that were detected, or null if no metadata differences were detected.
Public property | PassFailSettingsDifference | The differences in the job pass/fail settings, or null if there are none.
Public property | SheetDifference | The differences in the sheet contained by the job.
Top
See Also

Reference

IseJobDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference.MetadataDifference Property

IseJobDifferenceMetadataDifference Property

The differences in job metadata that were detected, or null if no metadata differences were detected.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJobMetadataDifference MetadataDifference { get; }
Public ReadOnly Property MetadataDifference As IseJobMetadataDifference
    Get

Property Value

Type: IseJobMetadataDifference
See Also

Reference

IseJobDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference.PassFailSettingsDifference Property

IseJobDifferencePassFailSettingsDifference Property

The differences in the job pass/fail settings, or null if there are none.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailSettingsDifference PassFailSettingsDifference { get; }
Public ReadOnly Property PassFailSettingsDifference As IsePassFailSettingsDifference
    Get

Property Value

Type: IsePassFailSettingsDifference
See Also

Reference

IseJobDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference.SheetDifference Property

IseJobDifferenceSheetDifference Property

The differences in the sheet contained by the job.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public SheetDifference<IseCellDifference, IseCell> SheetDifference { get; }
Public ReadOnly Property SheetDifference As SheetDifference(Of IseCellDifference, IseCell)
    Get

Property Value

Type: SheetDifference IseCellDifference, IseCell
See Also

Reference

IseJobDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobDifference Methods

The IseJobDifference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseJobDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference Class

Stores the differences in metadata of IseJobs.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.IseIseJobMetadataDifference

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseJobMetadataDifference
Public Class IseJobMetadataDifference

The IseJobMetadataDifference type exposes the following members.

Constructors
 | Name | Description
Public method | IseJobMetadataDifference | Initializes a new instance of the IseJobMetadataDifference class
Top
Properties
 | Name | Description
Public property | CameraFirmwareVersion | The version of firmware used on the Camera that wrote the job.
Public property | CameraModel | The model of the camera used to write the job.
Public property | JobFormatVersion | The version of the job format used to write the job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference Constructor

Initializes a new instance of the IseJobMetadataDifference class

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJobMetadataDifference()
Public Sub New
See Also

Reference

IseJobMetadataDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference Properties

The IseJobMetadataDifference type exposes the following members.

Properties
 | Name | Description
Public property | CameraFirmwareVersion | The version of firmware used on the Camera that wrote the job.
Public property | CameraModel | The model of the camera used to write the job.
Public property | JobFormatVersion | The version of the job format used to write the job.
Top
See Also

Reference

IseJobMetadataDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference.CameraFirmwareVersion Property

IseJobMetadataDifferenceCameraFirmwareVersion Property

The version of firmware used on the Camera that wrote the job.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> CameraFirmwareVersion { get; }
Public ReadOnly Property CameraFirmwareVersion As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

IseJobMetadataDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference.CameraModel Property

IseJobMetadataDifferenceCameraModel Property

The model of the camera used to write the job.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<string> CameraModel { get; }
Public ReadOnly Property CameraModel As BasicDifference(Of String)
    Get

Property Value

Type: BasicDifference String
See Also

Reference

IseJobMetadataDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference.JobFormatVersion Property

IseJobMetadataDifferenceJobFormatVersion Property

The version of the job format used to write the job.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<int> JobFormatVersion { get; }
Public ReadOnly Property JobFormatVersion As BasicDifference(Of Integer)
    Get

Property Value

Type: BasicDifference Int32
See Also

Reference

IseJobMetadataDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IseJobMetadataDifference Methods

The IseJobMetadataDifference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseJobMetadataDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference Class

Holds the differences between two jobs pass/fail settings.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Comparison.IseIsePassFailSettingsDifference

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IsePassFailSettingsDifference
Public Class IsePassFailSettingsDifference

The IsePassFailSettingsDifference type exposes the following members.

Constructors
 | Name | Description
Public method | IsePassFailSettingsDifference | Initializes a new instance of the IsePassFailSettingsDifference class
Top
Properties
 | Name | Description
Public property | OnError | The result that will be displayed if the cell value is an error.
Public property | OnNegative | The result that will be displayed if the cell value is negative.
Public property | OnPosition | The result that will be displayed if the cell value is a cell location.
Public property | OnPositive | The result that will be displayed if the cell value is positive.
Public property | OnStruct | The result that will be displayed if the cell value is a tool.
Public property | OnZero | The result that will be displayed if the cell value is zero.
Public property | PassFailCellLocation | The location of the cell used to compute the pass/fail status.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference Constructor

Initializes a new instance of the IsePassFailSettingsDifference class

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailSettingsDifference()
Public Sub New
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference Properties

The IsePassFailSettingsDifference type exposes the following members.

Properties
 | Name | Description
Public property | OnError | The result that will be displayed if the cell value is an error.
Public property | OnNegative | The result that will be displayed if the cell value is negative.
Public property | OnPosition | The result that will be displayed if the cell value is a cell location.
Public property | OnPositive | The result that will be displayed if the cell value is positive.
Public property | OnStruct | The result that will be displayed if the cell value is a tool.
Public property | OnZero | The result that will be displayed if the cell value is zero.
Public property | PassFailCellLocation | The location of the cell used to compute the pass/fail status.
Top
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.OnError Property

IsePassFailSettingsDifferenceOnError Property

The result that will be displayed if the cell value is an error.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<IsePassFailResultStatus> OnError { get; }
Public ReadOnly Property OnError As BasicDifference(Of IsePassFailResultStatus)
    Get

Property Value

Type: BasicDifference IsePassFailResultStatus
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.OnNegative Property

IsePassFailSettingsDifferenceOnNegative Property

The result that will be displayed if the cell value is negative.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<IsePassFailResultStatus> OnNegative { get; }
Public ReadOnly Property OnNegative As BasicDifference(Of IsePassFailResultStatus)
    Get

Property Value

Type: BasicDifference IsePassFailResultStatus
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.OnPosition Property

IsePassFailSettingsDifferenceOnPosition Property

The result that will be displayed if the cell value is a cell location.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<IsePassFailResultStatus> OnPosition { get; }
Public ReadOnly Property OnPosition As BasicDifference(Of IsePassFailResultStatus)
    Get

Property Value

Type: BasicDifference IsePassFailResultStatus
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.OnPositive Property

IsePassFailSettingsDifferenceOnPositive Property

The result that will be displayed if the cell value is positive.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<IsePassFailResultStatus> OnPositive { get; }
Public ReadOnly Property OnPositive As BasicDifference(Of IsePassFailResultStatus)
    Get

Property Value

Type: BasicDifference IsePassFailResultStatus
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.OnStruct Property

IsePassFailSettingsDifferenceOnStruct Property

The result that will be displayed if the cell value is a tool.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<IsePassFailResultStatus> OnStruct { get; }
Public ReadOnly Property OnStruct As BasicDifference(Of IsePassFailResultStatus)
    Get

Property Value

Type: BasicDifference IsePassFailResultStatus
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.OnZero Property

IsePassFailSettingsDifferenceOnZero Property

The result that will be displayed if the cell value is zero.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<IsePassFailResultStatus> OnZero { get; }
Public ReadOnly Property OnZero As BasicDifference(Of IsePassFailResultStatus)
    Get

Property Value

Type: BasicDifference IsePassFailResultStatus
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference.PassFailCellLocation Property

IsePassFailSettingsDifferencePassFailCellLocation Property

The location of the cell used to compute the pass/fail status.

Namespace: Cognex.InSight.Job.Comparison.Ise
Assembly: Cognex.InSight.Job.Comparison.Ise (in Cognex.InSight.Job.Comparison.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BasicDifference<CellLocation> PassFailCellLocation { get; }
Public ReadOnly Property PassFailCellLocation As BasicDifference(Of CellLocation)
    Get

Property Value

Type: BasicDifference CellLocation
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


IsePassFailSettingsDifference Methods

The IsePassFailSettingsDifference type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsePassFailSettingsDifference Class
Cognex.InSight.Job.Comparison.Ise Namespace


Cognex.InSight.Job.Ise Namespace

Classes for loading and inspecting In-Sight Explorer based jobs.
Classes
 | Class | Description
Public class | IseCell | A cell that contains additional fields used by ISE.
Public class | IseJob | An implementation of IJobTCell that contains additional ISE-specific job fields.
Public class | IseJobReader | Reads ISE-based In-Sight (1.x-6.x) .job files
Public class | IseJobStream | A wrapper stream that handles the common IseJob reading functions.
Public class | IsePassFailSettings | The pass/fail settings for a singular job.
Public class | IseSheet | A basic implementation of an ISheetTCell.
Enumerations
 | Enumeration | Description
Public enumeration | IsePassFailResultStatus | What the job will report as its status if this value is selected.


IseCell Class

A cell that contains additional fields used by ISE.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonCell
Cognex.InSight.Job.IseIseCell

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseCell : Cell, ICell,
    IReadOnlyCell
Public Class IseCell
    Inherits Cell
    Implements ICell, IReadOnlyCell

The IseCell type exposes the following members.

Constructors
 | Name | Description
Public method | IseCell | Creates a new IseCell with the provided parameters.
Top
Properties
 | Name | Description
Public property | AuditTagOn | Whether or not the symbolic tag is exposed as an audit tag.
Public property | CellState | The cell's enabled state (condition). (Inherited from Cell.)
Public property | Comment | The cell's comment. (Inherited from Cell.)
Public property | EasyBuilderTag | The EasyBuilder tag that the cell holds.
Public property | EasyViewTagOn | Whether or not the symbolic tag is exposed as an EasyView tag.
Public property | Expression | The cell's expression (formula). (Inherited from Cell.)
Public property | Location | The cell location within a sheet. (Inherited from Cell.)
Public property | Name | The cell's name (symbolic tag). (Inherited from Cell.)
Public property | OpcTagOn | Whether or not the symbolic tag is exposed as an OPC tag.
Public property | Saved | The cell's stored data. (Inherited from Cell.)
Public property | Value | The cell's output value. (Inherited from Cell.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IseCell Constructor

Creates a new IseCell with the provided parameters.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseCell(
    CellLocation location
)
Public Sub New (
    location As CellLocation
)

Parameters

location
Type: Cognex.InSight.Job.CommonCellLocation
The lcoation this cell is at.
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseCell Properties

The IseCell type exposes the following members.

Properties
 | Name | Description
Public property | AuditTagOn | Whether or not the symbolic tag is exposed as an audit tag.
Public property | CellState | The cell's enabled state (condition). (Inherited from Cell.)
Public property | Comment | The cell's comment. (Inherited from Cell.)
Public property | EasyBuilderTag | The EasyBuilder tag that the cell holds.
Public property | EasyViewTagOn | Whether or not the symbolic tag is exposed as an EasyView tag.
Public property | Expression | The cell's expression (formula). (Inherited from Cell.)
Public property | Location | The cell location within a sheet. (Inherited from Cell.)
Public property | Name | The cell's name (symbolic tag). (Inherited from Cell.)
Public property | OpcTagOn | Whether or not the symbolic tag is exposed as an OPC tag.
Public property | Saved | The cell's stored data. (Inherited from Cell.)
Public property | Value | The cell's output value. (Inherited from Cell.)
Top
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseCell.AuditTagOn Property

IseCellAuditTagOn Property

Whether or not the symbolic tag is exposed as an audit tag.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool AuditTagOn { get; }
Public ReadOnly Property AuditTagOn As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseCell.EasyBuilderTag Property

IseCellEasyBuilderTag Property

The EasyBuilder tag that the cell holds.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string EasyBuilderTag { get; }
Public ReadOnly Property EasyBuilderTag As String
    Get

Property Value

Type: String
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseCell.EasyViewTagOn Property

IseCellEasyViewTagOn Property

Whether or not the symbolic tag is exposed as an EasyView tag.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool EasyViewTagOn { get; }
Public ReadOnly Property EasyViewTagOn As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseCell.OpcTagOn Property

IseCellOpcTagOn Property

Whether or not the symbolic tag is exposed as an OPC tag.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool OpcTagOn { get; }
Public ReadOnly Property OpcTagOn As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseCell Methods

The IseCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseCell Class
Cognex.InSight.Job.Ise Namespace


IseJob Class

An implementation of IJobTCell that contains additional ISE-specific job fields.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.IseIseJob

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseJob : IJob<IseCell>,
    IReadOnlyJob<IseCell>
Public Class IseJob
    Implements IJob(Of IseCell), IReadOnlyJob(Of IseCell)

The IseJob type exposes the following members.

Constructors
 | Name | Description
Public method | IseJob | Creates a new IseJob that is empty.
Top
Properties
 | Name | Description
Public property | CameraFirmwareVersion | The software version this job was created with.
Public property | CameraModel | The camera model that was used to create this job.
Public property | EasyViewTable | Stores all of the EasyView information in the job.
Public property | ExtraLines | Holds all unparsed lines.
Public property | JobVersion | The job version.
Public property | Name | The name of the job.
Public property | PassFailSettings | Contains the pass/fail settings for the job, or null if the job does not specify custom settings.
Public property | Sheet | The sheet stored in this job.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(Stream) | Reads and returns the job read from the specified stream. Throws an exception if the job was malformed.
 | Read(String) | Reads and returns the job at the specified filename. Throws an exception if the file could not be opened, or if the job was malformed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IseJob Constructor

Creates a new IseJob that is empty.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJob()
Public Sub New
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob Properties

The IseJob type exposes the following members.

Properties
 | Name | Description
Public property | CameraFirmwareVersion | The software version this job was created with.
Public property | CameraModel | The camera model that was used to create this job.
Public property | EasyViewTable | Stores all of the EasyView information in the job.
Public property | ExtraLines | Holds all unparsed lines.
Public property | JobVersion | The job version.
Public property | Name | The name of the job.
Public property | PassFailSettings | Contains the pass/fail settings for the job, or null if the job does not specify custom settings.
Public property | Sheet | The sheet stored in this job.
Top
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.CameraFirmwareVersion Property

IseJobCameraFirmwareVersion Property

The software version this job was created with.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string CameraFirmwareVersion { get; set; }
Public Property CameraFirmwareVersion As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.CameraModel Property

IseJobCameraModel Property

The camera model that was used to create this job.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string CameraModel { get; set; }
Public Property CameraModel As String
    Get
    Set

Property Value

Type: String
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.EasyViewTable Property

IseJobEasyViewTable Property

Stores all of the EasyView information in the job.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public EasyViewTable EasyViewTable { get; set; }
Public Property EasyViewTable As EasyViewTable
    Get
    Set

Property Value

Type: EasyViewTable

Implements

IJobTCellEasyViewTable
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.ExtraLines Property

IseJobExtraLines Property

Holds all unparsed lines.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public List<string> ExtraLines { get; set; }
Public Property ExtraLines As List(Of String)
    Get
    Set

Property Value

Type: List String
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.JobVersion Property

IseJobJobVersion Property

The job version.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int JobVersion { get; set; }
Public Property JobVersion As Integer
    Get
    Set

Property Value

Type: Int32
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.Name Property

IseJobName Property

The name of the job.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set

Property Value

Type: String

Implements

IJobTCellName
IReadOnlyJobTCellName
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.PassFailSettings Property

IseJobPassFailSettings Property

Contains the pass/fail settings for the job, or null if the job does not specify custom settings.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailSettings PassFailSettings { get; set; }
Public Property PassFailSettings As IsePassFailSettings
    Get
    Set

Property Value

Type: IsePassFailSettings
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.Sheet Property

IseJobSheet Property

The sheet stored in this job.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseSheet Sheet { get; set; }
Public Property Sheet As IseSheet
    Get
    Set

Property Value

Type: IseSheet
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob Methods

The IseJob type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(Stream) | Reads and returns the job read from the specified stream. Throws an exception if the job was malformed.
 | Read(String) | Reads and returns the job at the specified filename. Throws an exception if the file could not be opened, or if the job was malformed.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.Read Method

IseJobRead Method

Overload List
Name | Description
Read(Stream) | Reads and returns the job read from the specified stream. Throws an exception if the job was malformed.
Read(String) | Reads and returns the job at the specified filename. Throws an exception if the file could not be opened, or if the job was malformed.
Top
See Also

Reference

IseJob Class
Cognex.InSight.Job.Ise Namespace


IseJob.Read Method (Stream)

IseJobRead Method (Stream)

Reads and returns the job read from the specified stream. Throws an exception if the job was malformed.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static IseJob Read(
    Stream stream
)
Public Shared Function Read (
    stream As Stream
) As IseJob

Parameters

stream
Type: System.IOStream
The stream to read from.

Return Value

Type: IseJob
The IseJob read from the stream.
See Also

Reference

IseJob Class
Read Overload
Cognex.InSight.Job.Ise Namespace


IseJob.Read Method (String)

IseJobRead Method (String)

Reads and returns the job at the specified filename. Throws an exception if the file could not be opened, or if the job was malformed.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static IseJob Read(
    string filename
)
Public Shared Function Read (
    filename As String
) As IseJob

Parameters

filename
Type: SystemString
The filename to read from.

Return Value

Type: IseJob
The IseJob read from the file.
See Also

Reference

IseJob Class
Read Overload
Cognex.InSight.Job.Ise Namespace


IseJobReader Class

Reads ISE-based In-Sight (1.x-6.x) .job files
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.IseIseJobReader

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseJobReader
Public Class IseJobReader

The IseJobReader type exposes the following members.

Constructors
 | Name | Description
Public method | IseJobReader | Initializes a new instance of the IseJobReader class
Top
Methods
 | Name | Description
Protected method | ConvertExpression | Converts the strings in parts into a IseCell, reading the value if we know how to.
Protected method | ConvertSetCellName | Parses the SetCellName function, getting the location, tag, and flags. Creates a new cell if the cell did not already exist in the sheet.
Protected method | ConvertSetOverallPassFail | Processes SetOverallPassFail calls.
Protected method | ConvertSetTagTo | Reads the cell range, then reads the tags associated with the SetTagTo`X` call.
Protected method | ConvertSetTagToJob | Reads a SetTagToJob binary block. Currently, this only parses EasyView tags, though this could be expanded.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseJobVersion | Parses the job version, software version, and camera model this job was created with.
Public method | Read(Stream) | Reads a job from the specified stream.
Public method | Read(String) | Reads the specified job file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IseJobReader Constructor

Initializes a new instance of the IseJobReader class

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJobReader()
Public Sub New
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader Methods

The IseJobReader type exposes the following members.

Methods
 | Name | Description
Protected method | ConvertExpression | Converts the strings in parts into a IseCell, reading the value if we know how to.
Protected method | ConvertSetCellName | Parses the SetCellName function, getting the location, tag, and flags. Creates a new cell if the cell did not already exist in the sheet.
Protected method | ConvertSetOverallPassFail | Processes SetOverallPassFail calls.
Protected method | ConvertSetTagTo | Reads the cell range, then reads the tags associated with the SetTagTo`X` call.
Protected method | ConvertSetTagToJob | Reads a SetTagToJob binary block. Currently, this only parses EasyView tags, though this could be expanded.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | ParseJobVersion | Parses the job version, software version, and camera model this job was created with.
Public method | Read(Stream) | Reads a job from the specified stream.
Public method | Read(String) | Reads the specified job file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.ConvertExpression Method

IseJobReaderConvertExpression Method

Converts the strings in parts into a IseCell, reading the value if we know how to.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected IseCell ConvertExpression(
    string[] parts
)
Protected Function ConvertExpression (
    parts As String()
) As IseCell

Parameters

parts
Type: SystemString
The individual parts of the job line.

Return Value

Type: IseCell
The IseCell specified by the parts.
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.ConvertSetCellName Method

IseJobReaderConvertSetCellName Method

Parses the SetCellName function, getting the location, tag, and flags. Creates a new cell if the cell did not already exist in the sheet.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected IseCell ConvertSetCellName(
    IReadOnlyList<string> args
)
Protected Function ConvertSetCellName (
    args As IReadOnlyList(Of String)
) As IseCell

Parameters

args
Type: System.Collections.GenericIReadOnlyList String
The arguments provided to the SetCellName call.

Return Value

Type: IseCell
The cell that the tag was applied to.
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.ConvertSetOverallPassFail Method

IseJobReaderConvertSetOverallPassFail Method

Processes SetOverallPassFail calls.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected void ConvertSetOverallPassFail(
    List<string> args
)
Protected Sub ConvertSetOverallPassFail (
    args As List(Of String)
)

Parameters

args
Type: System.Collections.GenericList String
The arguments provided to SetOverallPassFail.
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.ConvertSetTagTo Method

IseJobReaderConvertSetTagTo Method

Reads the cell range, then reads the tags associated with the SetTagTo`X` call.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected void ConvertSetTagTo(
    string fnName,
    IReadOnlyList<string> args
)
Protected Sub ConvertSetTagTo (
    fnName As String,
    args As IReadOnlyList(Of String)
)

Parameters

fnName
Type: SystemString
The name of the function from the SetTagTo family to process.
args
Type: System.Collections.GenericIReadOnlyList String
The arguments provided to the SetTagTo call.
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.ConvertSetTagToJob Method

IseJobReaderConvertSetTagToJob Method

Reads a SetTagToJob binary block. Currently, this only parses EasyView tags, though this could be expanded.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected void ConvertSetTagToJob()
Protected Sub ConvertSetTagToJob
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.ParseJobVersion Method

IseJobReaderParseJobVersion Method

Parses the job version, software version, and camera model this job was created with.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected void ParseJobVersion(
    string line
)
Protected Sub ParseJobVersion (
    line As String
)

Parameters

line
Type: SystemString
The line containing the version string.
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.Read Method

IseJobReaderRead Method

Overload List
 | Name | Description
Public method | Read(Stream) | Reads a job from the specified stream.
Public method | Read(String) | Reads the specified job file.
Top
See Also

Reference

IseJobReader Class
Cognex.InSight.Job.Ise Namespace


IseJobReader.Read Method (Stream)

IseJobReaderRead Method (Stream)

Reads a job from the specified stream.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJob Read(
    Stream stream
)
Public Function Read (
    stream As Stream
) As IseJob

Parameters

stream
Type: System.IOStream
The stream to read the job from.

Return Value

Type: IseJob
The loaded job.
Exceptions
Exception | Condition
JobLoadException | If the job is malformed.
See Also

Reference

IseJobReader Class
Read Overload
Cognex.InSight.Job.Ise Namespace


IseJobReader.Read Method (String)

IseJobReaderRead Method (String)

Reads the specified job file.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJob Read(
    string filename
)
Public Function Read (
    filename As String
) As IseJob

Parameters

filename
Type: SystemString
The filename to read from.

Return Value

Type: IseJob
The loaded job.
Exceptions
Exception | Condition
JobLoadException | If the job is malformed.
See Also

Reference

IseJobReader Class
Read Overload
Cognex.InSight.Job.Ise Namespace


IseJobStream Class

A wrapper stream that handles the common IseJob reading functions.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.IseIseJobStream

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseJobStream
Public Class IseJobStream

The IseJobStream type exposes the following members.

Constructors
 | Name | Description
Public method | IseJobStream | Creates a IseJobStream that read from the inStream.
Top
Properties
 | Name | Description
Public property | Eof | True if we have reached the EOF of the stream.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExplicitReadBin | Reads a line that should signal a binary block, then reads the binary block that follows it. If a binary block is not signalled, or if ReadBinBlock throws an exception, an exception will be thrown.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextLineIsBinary | Checks if the next line signals a binary block.
Public method | ReadBinBlock | Reads a binary block from the job file. If this line should not be a binary block, throws an exception signalling that. If we reach the end of the file, throws an exception signalling that.
Public method | ReadLine | Reads a non-empty line if there are any left in the stream. If there is not an empty line left, sets the EOF flag to true. Check if the line that was just read is a binary block indicator, setting the value in isBin to true if it was.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IseJobStream Constructor

Creates a IseJobStream that read from the inStream.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseJobStream(
    Stream inStream
)
Public Sub New (
    inStream As Stream
)

Parameters

inStream
Type: System.IOStream
The underlying stream to read the job from.
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream Properties

The IseJobStream type exposes the following members.

Properties
 | Name | Description
Public property | Eof | True if we have reached the EOF of the stream.
Top
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream.Eof Property

IseJobStreamEof Property

True if we have reached the EOF of the stream.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool Eof { get; }
Public ReadOnly Property Eof As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream Methods

The IseJobStream type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Public method | ExplicitReadBin | Reads a line that should signal a binary block, then reads the binary block that follows it. If a binary block is not signalled, or if ReadBinBlock throws an exception, an exception will be thrown.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextLineIsBinary | Checks if the next line signals a binary block.
Public method | ReadBinBlock | Reads a binary block from the job file. If this line should not be a binary block, throws an exception signalling that. If we reach the end of the file, throws an exception signalling that.
Public method | ReadLine | Reads a non-empty line if there are any left in the stream. If there is not an empty line left, sets the EOF flag to true. Check if the line that was just read is a binary block indicator, setting the value in isBin to true if it was.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream.ExplicitReadBin Method

IseJobStreamExplicitReadBin Method

Reads a line that should signal a binary block, then reads the binary block that follows it. If a binary block is not signalled, or if ReadBinBlock throws an exception, an exception will be thrown.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public byte[] ExplicitReadBin()
Public Function ExplicitReadBin As Byte()

Return Value

Type: Byte
The bytes of the binary block.
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream.NextLineIsBinary Method

IseJobStreamNextLineIsBinary Method

Checks if the next line signals a binary block.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool NextLineIsBinary()
Public Function NextLineIsBinary As Boolean

Return Value

Type: Boolean
True if the next line signals a binary block, otherwise false.
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream.ReadBinBlock Method

IseJobStreamReadBinBlock Method

Reads a binary block from the job file. If this line should not be a binary block, throws an exception signalling that. If we reach the end of the file, throws an exception signalling that.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public byte[] ReadBinBlock()
Public Function ReadBinBlock As Byte()

Return Value

Type: Byte
The bytes of the binary block.
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IseJobStream.ReadLine Method

IseJobStreamReadLine Method

Reads a non-empty line if there are any left in the stream. If there is not an empty line left, sets the EOF flag to true. Check if the line that was just read is a binary block indicator, setting the value in isBin to true if it was.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string ReadLine(
    out bool isBin
)
Public Function ReadLine (
    <OutAttribute> ByRef isBin As Boolean
) As String

Parameters

isBin
Type: SystemBoolean
Whether or not the line that was read was a binary block indicator.

Return Value

Type: String
The next non-empty line if it exists, else an empty string.
See Also

Reference

IseJobStream Class
Cognex.InSight.Job.Ise Namespace


IsePassFailResultStatus Enumeration

What the job will report as its status if this value is selected.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public enum IsePassFailResultStatus
Public Enumeration IsePassFailResultStatus
Members
Member name | Value | Description
None | 0 | The job will not report a status.
Pass | 1 | The job will report that it passed.
Fail | 2 | The job will report that it failed.
Warn | 3 | The job will report a warning.
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IsePassFailSettings Class

The pass/fail settings for a singular job.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.IseIsePassFailSettings

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IsePassFailSettings
Public Class IsePassFailSettings

The IsePassFailSettings type exposes the following members.

Constructors
 | Name | Description
Public method | IsePassFailSettings | Creates a new PassFailSettings with the provided parameters.
Top
Properties
 | Name | Description
Public property | CellLocation | The location of the cell to use as the status for the job.
Public property | OnError | The result that will be displayed if the cell value is an error.
Public property | OnNegative | The result that will be displayed if the cell value is negative.
Public property | OnPosition | The result that will be displayed if the cell value is a cell location.
Public property | OnPositive | The result that will be displayed if the cell value is positive.
Public property | OnStruct | The result that will be displayed if the cell value is a tool.
Public property | OnZero | The result that will be displayed if the cell value is zero.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IsePassFailSettings Constructor

Creates a new PassFailSettings with the provided parameters.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailSettings(
    CellLocation cellLocation,
    IsePassFailResultStatus onNegative,
    IsePassFailResultStatus onZero,
    IsePassFailResultStatus onPositive,
    IsePassFailResultStatus onPosition,
    IsePassFailResultStatus onError,
    IsePassFailResultStatus onStruct
)
Public Sub New (
    cellLocation As CellLocation,
    onNegative As IsePassFailResultStatus,
    onZero As IsePassFailResultStatus,
    onPositive As IsePassFailResultStatus,
    onPosition As IsePassFailResultStatus,
    onError As IsePassFailResultStatus,
    onStruct As IsePassFailResultStatus
)

Parameters

cellLocation
Type: Cognex.InSight.Job.CommonCellLocation
The location of the pass/fail cell.
onNegative
Type: Cognex.InSight.Job.IseIsePassFailResultStatus
The result that will be displayed if the cell value is negative.
onZero
Type: Cognex.InSight.Job.IseIsePassFailResultStatus
The result that will be displayed if the cell value is zero.
onPositive
Type: Cognex.InSight.Job.IseIsePassFailResultStatus
The result that will be displayed if the cell value is positive.
onPosition
Type: Cognex.InSight.Job.IseIsePassFailResultStatus
The result that will be displayed if the cell value is a cell location.
onError
Type: Cognex.InSight.Job.IseIsePassFailResultStatus
The result that will be displayed if the cell value is an error.
onStruct
Type: Cognex.InSight.Job.IseIsePassFailResultStatus
The result that will be displayed if the cell value is a tool.
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings Properties

The IsePassFailSettings type exposes the following members.

Properties
 | Name | Description
Public property | CellLocation | The location of the cell to use as the status for the job.
Public property | OnError | The result that will be displayed if the cell value is an error.
Public property | OnNegative | The result that will be displayed if the cell value is negative.
Public property | OnPosition | The result that will be displayed if the cell value is a cell location.
Public property | OnPositive | The result that will be displayed if the cell value is positive.
Public property | OnStruct | The result that will be displayed if the cell value is a tool.
Public property | OnZero | The result that will be displayed if the cell value is zero.
Top
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.CellLocation Property

IsePassFailSettingsCellLocation Property

The location of the cell to use as the status for the job.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation CellLocation { get; }
Public ReadOnly Property CellLocation As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.OnError Property

IsePassFailSettingsOnError Property

The result that will be displayed if the cell value is an error.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailResultStatus OnError { get; }
Public ReadOnly Property OnError As IsePassFailResultStatus
    Get

Property Value

Type: IsePassFailResultStatus
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.OnNegative Property

IsePassFailSettingsOnNegative Property

The result that will be displayed if the cell value is negative.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailResultStatus OnNegative { get; }
Public ReadOnly Property OnNegative As IsePassFailResultStatus
    Get

Property Value

Type: IsePassFailResultStatus
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.OnPosition Property

IsePassFailSettingsOnPosition Property

The result that will be displayed if the cell value is a cell location.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailResultStatus OnPosition { get; }
Public ReadOnly Property OnPosition As IsePassFailResultStatus
    Get

Property Value

Type: IsePassFailResultStatus
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.OnPositive Property

IsePassFailSettingsOnPositive Property

The result that will be displayed if the cell value is positive.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailResultStatus OnPositive { get; }
Public ReadOnly Property OnPositive As IsePassFailResultStatus
    Get

Property Value

Type: IsePassFailResultStatus
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.OnStruct Property

IsePassFailSettingsOnStruct Property

The result that will be displayed if the cell value is a tool.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailResultStatus OnStruct { get; }
Public ReadOnly Property OnStruct As IsePassFailResultStatus
    Get

Property Value

Type: IsePassFailResultStatus
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings.OnZero Property

IsePassFailSettingsOnZero Property

The result that will be displayed if the cell value is zero.

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IsePassFailResultStatus OnZero { get; }
Public ReadOnly Property OnZero As IsePassFailResultStatus
    Get

Property Value

Type: IsePassFailResultStatus
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IsePassFailSettings Methods

The IsePassFailSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IsePassFailSettings Class
Cognex.InSight.Job.Ise Namespace


IseSheet Class

A basic implementation of an ISheetTCell.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.CommonSheet IseCell
Cognex.InSight.Job.IseIseSheet

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IseSheet : Sheet<IseCell>
Public Class IseSheet
    Inherits Sheet(Of IseCell)

The IseSheet type exposes the following members.

Constructors
 | Name | Description
Public method | IseSheet | Initializes a new instance of the IseSheet class
Top
Properties
 | Name | Description
Public property | Cells | A mutable collection of the cells in this sheet. (Inherited from SheetTCell.)
Public property | Name | The name of this sheet. (Inherited from SheetTCell.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise Namespace


IseSheet Constructor

Initializes a new instance of the IseSheet class

Namespace: Cognex.InSight.Job.Ise
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IseSheet()
Public Sub New
See Also

Reference

IseSheet Class
Cognex.InSight.Job.Ise Namespace


IseSheet Properties

The IseSheet type exposes the following members.

Properties
 | Name | Description
Public property | Cells | A mutable collection of the cells in this sheet. (Inherited from SheetTCell.)
Public property | Name | The name of this sheet. (Inherited from SheetTCell.)
Top
See Also

Reference

IseSheet Class
Cognex.InSight.Job.Ise Namespace


IseSheet Methods

The IseSheet type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IseSheet Class
Cognex.InSight.Job.Ise Namespace


Cognex.InSight.Job.Ise.Tags Namespace

Classes for storing tag values attached to In-Sight Explorer based spreadsheet cells.
Classes
 | Class | Description
Public class | BoolTag |
Public class | ByteArrayTag |
Public class | CellLocationOffsetTag |
Public class | CellLocationTag |
Public class | CellRangeTag |
Public class | ColorMapArrayTag |
Public class | ColorMapTag |
Public class | ColorTag |
Public class | DateTimeTag |
Public class | FloatArrayTag |
Public class | FloatTag |
Public class | IntArrayTag |
Public class | IntTag |
Public class | NullTag |
Public class | PointTag |
Public class | RectangleTag |
Public class | StringArrayTag |
Public class | StringTag |
Public class | Tag | A tag that may or may not contain a typed value.
Public class | TagGroup |
Public class | TagReader | Reads and converts the tags found in the binary blocks after SetTagToCell() calls.
Public class | TagSet | A group of tags that describe whatever the tag applies to.
Public class | UnknownTagTypeException | Non-fatal exception that signals that a tag was read that could not be understood, but could be safely skipped.
Enumerations
 | Enumeration | Description
Public enumeration | TagType | Defines what this tag applies to.


BoolTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.BoolTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsBoolTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class BoolTag : Tag
Public Class BoolTag
    Inherits Tag

The BoolTag type exposes the following members.

Constructors
 | Name | Description
Public method | BoolTag | Creates a new BoolTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Value | The bool value stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


BoolTag Constructor

Creates a new BoolTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public BoolTag(
    bool value
)
Public Sub New (
    value As Boolean
)

Parameters

value
Type: SystemBoolean

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.BoolTag.#ctor(System.Boolean)"]

See Also

Reference

BoolTag Class
Cognex.InSight.Job.Ise.Tags Namespace


BoolTag Properties

The BoolTag type exposes the following members.

Properties
 | Name | Description
Public property | Value | The bool value stored in this tag.
Top
See Also

Reference

BoolTag Class
Cognex.InSight.Job.Ise.Tags Namespace


BoolTag.Value Property

BoolTagValue Property

The bool value stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool Value { get; }
Public ReadOnly Property Value As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

BoolTag Class
Cognex.InSight.Job.Ise.Tags Namespace


BoolTag Methods

The BoolTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

BoolTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ByteArrayTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.ByteArrayTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsByteArrayTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class ByteArrayTag : Tag
Public Class ByteArrayTag
    Inherits Tag

The ByteArrayTag type exposes the following members.

Constructors
 | Name | Description
Public method | ByteArrayTag | Creates a new ByteArrayTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Array | The byte array stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


ByteArrayTag Constructor

Creates a new ByteArrayTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public ByteArrayTag(
    byte[] array
)
Public Sub New (
    array As Byte()
)

Parameters

array
Type: SystemByte

[Missing <param name="array"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.ByteArrayTag.#ctor(System.Byte[])"]

See Also

Reference

ByteArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ByteArrayTag Properties

The ByteArrayTag type exposes the following members.

Properties
 | Name | Description
Public property | Array | The byte array stored in this tag.
Top
See Also

Reference

ByteArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ByteArrayTag.Array Property

ByteArrayTagArray Property

The byte array stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public byte[] Array { get; }
Public ReadOnly Property Array As Byte()
    Get

Property Value

Type: Byte
See Also

Reference

ByteArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ByteArrayTag Methods

The ByteArrayTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ByteArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationOffsetTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.CellLocationOffsetTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsCellLocationOffsetTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class CellLocationOffsetTag : Tag
Public Class CellLocationOffsetTag
    Inherits Tag

The CellLocationOffsetTag type exposes the following members.

Constructors
 | Name | Description
Public method | CellLocationOffsetTag | Creates a new CellLocationOffsetTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Offset | The cell location offset stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


CellLocationOffsetTag Constructor

Creates a new CellLocationOffsetTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocationOffsetTag(
    CellLocationOffset offset
)
Public Sub New (
    offset As CellLocationOffset
)

Parameters

offset
Type: Cognex.InSight.Job.CommonCellLocationOffset

[Missing <param name="offset"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.CellLocationOffsetTag.#ctor(Cognex.InSight.Job.Common.CellLocationOffset)"]

See Also

Reference

CellLocationOffsetTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationOffsetTag Properties

The CellLocationOffsetTag type exposes the following members.

Properties
 | Name | Description
Public property | Offset | The cell location offset stored in this tag.
Top
See Also

Reference

CellLocationOffsetTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationOffsetTag.Offset Property

CellLocationOffsetTagOffset Property

The cell location offset stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocationOffset Offset { get; }
Public ReadOnly Property Offset As CellLocationOffset
    Get

Property Value

Type: CellLocationOffset
See Also

Reference

CellLocationOffsetTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationOffsetTag Methods

The CellLocationOffsetTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CellLocationOffsetTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.CellLocationTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsCellLocationTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class CellLocationTag : Tag
Public Class CellLocationTag
    Inherits Tag

The CellLocationTag type exposes the following members.

Constructors
 | Name | Description
Public method | CellLocationTag | Creates a new CellLocationTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Location | The cell location stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


CellLocationTag Constructor

Creates a new CellLocationTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocationTag(
    CellLocation location
)
Public Sub New (
    location As CellLocation
)

Parameters

location
Type: Cognex.InSight.Job.CommonCellLocation

[Missing <param name="location"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.CellLocationTag.#ctor(Cognex.InSight.Job.Common.CellLocation)"]

See Also

Reference

CellLocationTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationTag Properties

The CellLocationTag type exposes the following members.

Properties
 | Name | Description
Public property | Location | The cell location stored in this tag.
Top
See Also

Reference

CellLocationTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationTag.Location Property

CellLocationTagLocation Property

The cell location stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellLocation Location { get; }
Public ReadOnly Property Location As CellLocation
    Get

Property Value

Type: CellLocation
See Also

Reference

CellLocationTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellLocationTag Methods

The CellLocationTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CellLocationTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellRangeTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.CellRangeTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsCellRangeTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class CellRangeTag : Tag
Public Class CellRangeTag
    Inherits Tag

The CellRangeTag type exposes the following members.

Constructors
 | Name | Description
Public method | CellRangeTag | Creates a new CellRangeTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Range | The cell range stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


CellRangeTag Constructor

Creates a new CellRangeTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellRangeTag(
    CellRange range
)
Public Sub New (
    range As CellRange
)

Parameters

range
Type: Cognex.InSight.Job.CommonCellRange

[Missing <param name="range"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.CellRangeTag.#ctor(Cognex.InSight.Job.Common.CellRange)"]

See Also

Reference

CellRangeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellRangeTag Properties

The CellRangeTag type exposes the following members.

Properties
 | Name | Description
Public property | Range | The cell range stored in this tag.
Top
See Also

Reference

CellRangeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellRangeTag.Range Property

CellRangeTagRange Property

The cell range stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public CellRange Range { get; }
Public ReadOnly Property Range As CellRange
    Get

Property Value

Type: CellRange
See Also

Reference

CellRangeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


CellRangeTag Methods

The CellRangeTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

CellRangeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapArrayTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.ColorMapArrayTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsColorMapArrayTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class ColorMapArrayTag : Tag
Public Class ColorMapArrayTag
    Inherits Tag

The ColorMapArrayTag type exposes the following members.

Constructors
 | Name | Description
Public method | ColorMapArrayTag | Creates a new ColorMapArrayTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | MappingArray | The color mapping array stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


ColorMapArrayTag Constructor

Creates a new ColorMapArrayTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public ColorMapArrayTag(
    Dictionary<Color, Color>[] mappingArray
)
Public Sub New (
    mappingArray As Dictionary(Of Color, Color)()
)

Parameters

mappingArray
Type: System.Collections.GenericDictionary Color, Color

[Missing <param name="mappingArray"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.ColorMapArrayTag.#ctor(System.Collections.Generic.Dictionary{System.Drawing.Color,System.Drawing.Color}[])"]

See Also

Reference

ColorMapArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapArrayTag Properties

The ColorMapArrayTag type exposes the following members.

Properties
 | Name | Description
Public property | MappingArray | The color mapping array stored in this tag.
Top
See Also

Reference

ColorMapArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapArrayTag.MappingArray Property

ColorMapArrayTagMappingArray Property

The color mapping array stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Dictionary<Color, Color>[] MappingArray { get; }
Public ReadOnly Property MappingArray As Dictionary(Of Color, Color)()
    Get

Property Value

Type: Dictionary Color, Color
See Also

Reference

ColorMapArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapArrayTag Methods

The ColorMapArrayTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorMapArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.ColorMapTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsColorMapTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class ColorMapTag : Tag
Public Class ColorMapTag
    Inherits Tag

The ColorMapTag type exposes the following members.

Constructors
 | Name | Description
Public method | ColorMapTag | Creates a new ColorMapTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Mapping | The color mapping stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


ColorMapTag Constructor

Creates a new ColorMapTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public ColorMapTag(
    Dictionary<Color, Color> mapping
)
Public Sub New (
    mapping As Dictionary(Of Color, Color)
)

Parameters

mapping
Type: System.Collections.GenericDictionary Color, Color

[Missing <param name="mapping"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.ColorMapTag.#ctor(System.Collections.Generic.Dictionary{System.Drawing.Color,System.Drawing.Color})"]

See Also

Reference

ColorMapTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapTag Properties

The ColorMapTag type exposes the following members.

Properties
 | Name | Description
Public property | Mapping | The color mapping stored in this tag.
Top
See Also

Reference

ColorMapTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapTag.Mapping Property

ColorMapTagMapping Property

The color mapping stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Dictionary<Color, Color> Mapping { get; }
Public ReadOnly Property Mapping As Dictionary(Of Color, Color)
    Get

Property Value

Type: Dictionary Color, Color
See Also

Reference

ColorMapTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorMapTag Methods

The ColorMapTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorMapTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.ColorTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsColorTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class ColorTag : Tag
Public Class ColorTag
    Inherits Tag

The ColorTag type exposes the following members.

Constructors
 | Name | Description
Public method | ColorTag | Creates a new ColorTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Color | The color stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


ColorTag Constructor

Creates a new ColorTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public ColorTag(
    Color color
)
Public Sub New (
    color As Color
)

Parameters

color
Type: System.DrawingColor

[Missing <param name="color"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.ColorTag.#ctor(System.Drawing.Color)"]

See Also

Reference

ColorTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorTag Properties

The ColorTag type exposes the following members.

Properties
 | Name | Description
Public property | Color | The color stored in this tag.
Top
See Also

Reference

ColorTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorTag.Color Property

ColorTagColor Property

The color stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Color Color { get; }
Public ReadOnly Property Color As Color
    Get

Property Value

Type: Color
See Also

Reference

ColorTag Class
Cognex.InSight.Job.Ise.Tags Namespace


ColorTag Methods

The ColorTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

ColorTag Class
Cognex.InSight.Job.Ise.Tags Namespace


DateTimeTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.DateTimeTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsDateTimeTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class DateTimeTag : Tag
Public Class DateTimeTag
    Inherits Tag

The DateTimeTag type exposes the following members.

Constructors
 | Name | Description
Public method | DateTimeTag | Creates a new DateTimeTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | DateTime | The date and time stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


DateTimeTag Constructor

Creates a new DateTimeTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public DateTimeTag(
    DateTime dateTime
)
Public Sub New (
    dateTime As DateTime
)

Parameters

dateTime
Type: SystemDateTime

[Missing <param name="dateTime"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.DateTimeTag.#ctor(System.DateTime)"]

See Also

Reference

DateTimeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


DateTimeTag Properties

The DateTimeTag type exposes the following members.

Properties
 | Name | Description
Public property | DateTime | The date and time stored in this tag.
Top
See Also

Reference

DateTimeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


DateTimeTag.DateTime Property

DateTimeTagDateTime Property

The date and time stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public DateTime DateTime { get; }
Public ReadOnly Property DateTime As DateTime
    Get

Property Value

Type: DateTime
See Also

Reference

DateTimeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


DateTimeTag Methods

The DateTimeTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

DateTimeTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatArrayTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.FloatArrayTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsFloatArrayTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class FloatArrayTag : Tag
Public Class FloatArrayTag
    Inherits Tag

The FloatArrayTag type exposes the following members.

Constructors
 | Name | Description
Public method | FloatArrayTag | Creates a new FloatArrayTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Array | The float array stored in this tag.
Public property | IsSinglePrecision | Whether each value in this array was originally single or double precision.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


FloatArrayTag Constructor

Creates a new FloatArrayTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public FloatArrayTag(
    double[] array,
    bool isSinglePrecision
)
Public Sub New (
    array As Double(),
    isSinglePrecision As Boolean
)

Parameters

array
Type: SystemDouble

[Missing <param name="array"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.FloatArrayTag.#ctor(System.Double[],System.Boolean)"]

isSinglePrecision
Type: SystemBoolean

[Missing <param name="isSinglePrecision"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.FloatArrayTag.#ctor(System.Double[],System.Boolean)"]

See Also

Reference

FloatArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatArrayTag Properties

The FloatArrayTag type exposes the following members.

Properties
 | Name | Description
Public property | Array | The float array stored in this tag.
Public property | IsSinglePrecision | Whether each value in this array was originally single or double precision.
Top
See Also

Reference

FloatArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatArrayTag.Array Property

FloatArrayTagArray Property

The float array stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double[] Array { get; }
Public ReadOnly Property Array As Double()
    Get

Property Value

Type: Double
See Also

Reference

FloatArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatArrayTag.IsSinglePrecision Property

FloatArrayTagIsSinglePrecision Property

Whether each value in this array was originally single or double precision.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool IsSinglePrecision { get; }
Public ReadOnly Property IsSinglePrecision As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FloatArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatArrayTag Methods

The FloatArrayTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FloatArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.FloatTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsFloatTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class FloatTag : Tag
Public Class FloatTag
    Inherits Tag

The FloatTag type exposes the following members.

Constructors
 | Name | Description
Public method | FloatTag | Creates a new FloatTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | IsSinglePrecision | Whether this value was originally single or double precision.
Public property | Value | The float value stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


FloatTag Constructor

Creates a new FloatTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public FloatTag(
    double value,
    bool isSinglePrecision
)
Public Sub New (
    value As Double,
    isSinglePrecision As Boolean
)

Parameters

value
Type: SystemDouble

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.FloatTag.#ctor(System.Double,System.Boolean)"]

isSinglePrecision
Type: SystemBoolean

[Missing <param name="isSinglePrecision"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.FloatTag.#ctor(System.Double,System.Boolean)"]

See Also

Reference

FloatTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatTag Properties

The FloatTag type exposes the following members.

Properties
 | Name | Description
Public property | IsSinglePrecision | Whether this value was originally single or double precision.
Public property | Value | The float value stored in this tag.
Top
See Also

Reference

FloatTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatTag.IsSinglePrecision Property

FloatTagIsSinglePrecision Property

Whether this value was originally single or double precision.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public bool IsSinglePrecision { get; }
Public ReadOnly Property IsSinglePrecision As Boolean
    Get

Property Value

Type: Boolean
See Also

Reference

FloatTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatTag.Value Property

FloatTagValue Property

The float value stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public double Value { get; }
Public ReadOnly Property Value As Double
    Get

Property Value

Type: Double
See Also

Reference

FloatTag Class
Cognex.InSight.Job.Ise.Tags Namespace


FloatTag Methods

The FloatTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

FloatTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntArrayTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.IntArrayTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsIntArrayTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IntArrayTag : Tag
Public Class IntArrayTag
    Inherits Tag

The IntArrayTag type exposes the following members.

Constructors
 | Name | Description
Public method | IntArrayTag | Creates a new IntArrayTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Array | The int array stored in this tag.
Public property | NumBytesPerElement | The number of bytes each element in this array originally held.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


IntArrayTag Constructor

Creates a new IntArrayTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IntArrayTag(
    int[] array,
    int numBytesPerElement
)
Public Sub New (
    array As Integer(),
    numBytesPerElement As Integer
)

Parameters

array
Type: SystemInt32

[Missing <param name="array"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.IntArrayTag.#ctor(System.Int32[],System.Int32)"]

numBytesPerElement
Type: SystemInt32

[Missing <param name="numBytesPerElement"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.IntArrayTag.#ctor(System.Int32[],System.Int32)"]

See Also

Reference

IntArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntArrayTag Properties

The IntArrayTag type exposes the following members.

Properties
 | Name | Description
Public property | Array | The int array stored in this tag.
Public property | NumBytesPerElement | The number of bytes each element in this array originally held.
Top
See Also

Reference

IntArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntArrayTag.Array Property

IntArrayTagArray Property

The int array stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int[] Array { get; }
Public ReadOnly Property Array As Integer()
    Get

Property Value

Type: Int32
See Also

Reference

IntArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntArrayTag.NumBytesPerElement Property

IntArrayTagNumBytesPerElement Property

The number of bytes each element in this array originally held.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int NumBytesPerElement { get; }
Public ReadOnly Property NumBytesPerElement As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IntArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntArrayTag Methods

The IntArrayTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.IntTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsIntTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class IntTag : Tag
Public Class IntTag
    Inherits Tag

The IntTag type exposes the following members.

Constructors
 | Name | Description
Public method | IntTag | Creates a new IntTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | NumBytes | The number of bytes that this tag type originally held.
Public property | Value | The int value stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


IntTag Constructor

Creates a new IntTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public IntTag(
    long value,
    int numBytes
)
Public Sub New (
    value As Long,
    numBytes As Integer
)

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.IntTag.#ctor(System.Int64,System.Int32)"]

numBytes
Type: SystemInt32

[Missing <param name="numBytes"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.IntTag.#ctor(System.Int64,System.Int32)"]

See Also

Reference

IntTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntTag Properties

The IntTag type exposes the following members.

Properties
 | Name | Description
Public property | NumBytes | The number of bytes that this tag type originally held.
Public property | Value | The int value stored in this tag.
Top
See Also

Reference

IntTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntTag.NumBytes Property

IntTagNumBytes Property

The number of bytes that this tag type originally held.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public int NumBytes { get; }
Public ReadOnly Property NumBytes As Integer
    Get

Property Value

Type: Int32
See Also

Reference

IntTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntTag.Value Property

IntTagValue Property

The int value stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public long Value { get; }
Public ReadOnly Property Value As Long
    Get

Property Value

Type: Int64
See Also

Reference

IntTag Class
Cognex.InSight.Job.Ise.Tags Namespace


IntTag Methods

The IntTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

IntTag Class
Cognex.InSight.Job.Ise.Tags Namespace


NullTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.NullTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsNullTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class NullTag : Tag
Public Class NullTag
    Inherits Tag

The NullTag type exposes the following members.

Constructors
 | Name | Description
Public method | NullTag | Creates a new NullTag with the provided parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


NullTag Constructor

Creates a new NullTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public NullTag()
Public Sub New
See Also

Reference

NullTag Class
Cognex.InSight.Job.Ise.Tags Namespace


NullTag Methods

The NullTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

NullTag Class
Cognex.InSight.Job.Ise.Tags Namespace


PointTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.PointTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsPointTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class PointTag : Tag
Public Class PointTag
    Inherits Tag

The PointTag type exposes the following members.

Constructors
 | Name | Description
Public method | PointTag | Creates a new PointTag with the provided parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Fields
 | Name | Description
Public field | Point | The point stored in this tag.
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


PointTag Constructor

Creates a new PointTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public PointTag(
    Point point
)
Public Sub New (
    point As Point
)

Parameters

point
Type: System.DrawingPoint

[Missing <param name="point"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.PointTag.#ctor(System.Drawing.Point)"]

See Also

Reference

PointTag Class
Cognex.InSight.Job.Ise.Tags Namespace


PointTag Methods

The PointTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

PointTag Class
Cognex.InSight.Job.Ise.Tags Namespace


PointTag Fields

The PointTag type exposes the following members.

Fields
 | Name | Description
Public field | Point | The point stored in this tag.
Top
See Also

Reference

PointTag Class
Cognex.InSight.Job.Ise.Tags Namespace


PointTag.Point Field

PointTagPoint Field

The point stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Point Point
Public Point As Point

Field Value

Type: Point
See Also

Reference

PointTag Class
Cognex.InSight.Job.Ise.Tags Namespace


RectangleTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.RectangleTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsRectangleTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class RectangleTag : Tag
Public Class RectangleTag
    Inherits Tag

The RectangleTag type exposes the following members.

Constructors
 | Name | Description
Public method | RectangleTag | Creates a new RectangleTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Rectangle | The rectangle stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


RectangleTag Constructor

Creates a new RectangleTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public RectangleTag(
    Rectangle rectangle
)
Public Sub New (
    rectangle As Rectangle
)

Parameters

rectangle
Type: System.DrawingRectangle

[Missing <param name="rectangle"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.RectangleTag.#ctor(System.Drawing.Rectangle)"]

See Also

Reference

RectangleTag Class
Cognex.InSight.Job.Ise.Tags Namespace


RectangleTag Properties

The RectangleTag type exposes the following members.

Properties
 | Name | Description
Public property | Rectangle | The rectangle stored in this tag.
Top
See Also

Reference

RectangleTag Class
Cognex.InSight.Job.Ise.Tags Namespace


RectangleTag.Rectangle Property

RectangleTagRectangle Property

The rectangle stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public Rectangle Rectangle { get; }
Public ReadOnly Property Rectangle As Rectangle
    Get

Property Value

Type: Rectangle
See Also

Reference

RectangleTag Class
Cognex.InSight.Job.Ise.Tags Namespace


RectangleTag Methods

The RectangleTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

RectangleTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringArrayTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.StringArrayTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsStringArrayTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class StringArrayTag : Tag
Public Class StringArrayTag
    Inherits Tag

The StringArrayTag type exposes the following members.

Constructors
 | Name | Description
Public method | StringArrayTag | Creates a new StringArrayTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Array | The string array stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


StringArrayTag Constructor

Creates a new StringArrayTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public StringArrayTag(
    string[] array
)
Public Sub New (
    array As String()
)

Parameters

array
Type: SystemString

[Missing <param name="array"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.StringArrayTag.#ctor(System.String[])"]

See Also

Reference

StringArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringArrayTag Properties

The StringArrayTag type exposes the following members.

Properties
 | Name | Description
Public property | Array | The string array stored in this tag.
Top
See Also

Reference

StringArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringArrayTag.Array Property

StringArrayTagArray Property

The string array stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string[] Array { get; }
Public ReadOnly Property Array As String()
    Get

Property Value

Type: String
See Also

Reference

StringArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringArrayTag Methods

The StringArrayTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringArrayTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringTag Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.StringTag"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsStringTag

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class StringTag : Tag
Public Class StringTag
    Inherits Tag

The StringTag type exposes the following members.

Constructors
 | Name | Description
Public method | StringTag | Creates a new StringTag with the provided parameters.
Top
Properties
 | Name | Description
Public property | Value | The string value stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


StringTag Constructor

Creates a new StringTag with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public StringTag(
    string value
)
Public Sub New (
    value As String
)

Parameters

value
Type: SystemString

[Missing <param name="value"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.StringTag.#ctor(System.String)"]

See Also

Reference

StringTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringTag Properties

The StringTag type exposes the following members.

Properties
 | Name | Description
Public property | Value | The string value stored in this tag.
Top
See Also

Reference

StringTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringTag.Value Property

StringTagValue Property

The string value stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Value { get; }
Public ReadOnly Property Value As String
    Get

Property Value

Type: String
See Also

Reference

StringTag Class
Cognex.InSight.Job.Ise.Tags Namespace


StringTag Methods

The StringTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

StringTag Class
Cognex.InSight.Job.Ise.Tags Namespace


Tag Class

A tag that may or may not contain a typed value.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
More...

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public abstract class Tag
Public MustInherit Class Tag

The Tag type exposes the following members.

Constructors
 | Name | Description
Protected method | Tag | Initializes a new instance of the Tag class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsBoolTag
Cognex.InSight.Job.Ise.TagsByteArrayTag
Cognex.InSight.Job.Ise.TagsCellLocationOffsetTag
Cognex.InSight.Job.Ise.TagsCellLocationTag
Cognex.InSight.Job.Ise.TagsCellRangeTag
Cognex.InSight.Job.Ise.TagsColorMapArrayTag
Cognex.InSight.Job.Ise.TagsColorMapTag
Cognex.InSight.Job.Ise.TagsColorTag
Cognex.InSight.Job.Ise.TagsDateTimeTag
Cognex.InSight.Job.Ise.TagsFloatArrayTag
Cognex.InSight.Job.Ise.TagsFloatTag
Cognex.InSight.Job.Ise.TagsIntArrayTag
Cognex.InSight.Job.Ise.TagsIntTag
Cognex.InSight.Job.Ise.TagsNullTag
Cognex.InSight.Job.Ise.TagsPointTag
Cognex.InSight.Job.Ise.TagsRectangleTag
Cognex.InSight.Job.Ise.TagsStringArrayTag
Cognex.InSight.Job.Ise.TagsStringTag
Cognex.InSight.Job.Ise.TagsTagGroup


Tag Constructor

Initializes a new instance of the Tag class

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
protected Tag()
Protected Sub New
See Also

Reference

Tag Class
Cognex.InSight.Job.Ise.Tags Namespace


Tag Methods

The Tag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Tag Class
Cognex.InSight.Job.Ise.Tags Namespace


TagGroup Class

[Missing <summary> documentation for "T:Cognex.InSight.Job.Ise.Tags.TagGroup"]

Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTag
Cognex.InSight.Job.Ise.TagsTagGroup

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class TagGroup : Tag
Public Class TagGroup
    Inherits Tag

The TagGroup type exposes the following members.

Constructors
 | Name | Description
Public method | TagGroup | Creates a new TagGroup with the provided parameters.
Top
Properties
 | Name | Description
Public property | SubTags | The subtags stored in this tag.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


TagGroup Constructor

Creates a new TagGroup with the provided parameters.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public TagGroup(
    TagSet subtags
)
Public Sub New (
    subtags As TagSet
)

Parameters

subtags
Type: Cognex.InSight.Job.Ise.TagsTagSet

[Missing <param name="subtags"/> documentation for "M:Cognex.InSight.Job.Ise.Tags.TagGroup.#ctor(Cognex.InSight.Job.Ise.Tags.TagSet)"]

See Also

Reference

TagGroup Class
Cognex.InSight.Job.Ise.Tags Namespace


TagGroup Properties

The TagGroup type exposes the following members.

Properties
 | Name | Description
Public property | SubTags | The subtags stored in this tag.
Top
See Also

Reference

TagGroup Class
Cognex.InSight.Job.Ise.Tags Namespace


TagGroup.SubTags Property

TagGroupSubTags Property

The subtags stored in this tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public TagSet SubTags { get; }
Public ReadOnly Property SubTags As TagSet
    Get

Property Value

Type: TagSet
See Also

Reference

TagGroup Class
Cognex.InSight.Job.Ise.Tags Namespace


TagGroup Methods

The TagGroup type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TagGroup Class
Cognex.InSight.Job.Ise.Tags Namespace


TagReader Class

Reads and converts the tags found in the binary blocks after SetTagToCell() calls.
Inheritance Hierarchy
SystemObject
Cognex.InSight.Job.Ise.TagsTagReader

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class TagReader : IDisposable
Public Class TagReader
    Implements IDisposable

The TagReader type exposes the following members.

Properties
 | Name | Description
Public property | AllTags | A dictionary of all of the top-level tags for the binary block that was read.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read | Reads all of the tags that are present in the given binary block.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


TagReader Properties

The TagReader type exposes the following members.

Properties
 | Name | Description
Public property | AllTags | A dictionary of all of the top-level tags for the binary block that was read.
Top
See Also

Reference

TagReader Class
Cognex.InSight.Job.Ise.Tags Namespace


TagReader.AllTags Property

TagReaderAllTags Property

A dictionary of all of the top-level tags for the binary block that was read.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public TagSet AllTags { get; }
Public ReadOnly Property AllTags As TagSet
    Get

Property Value

Type: TagSet
See Also

Reference

TagReader Class
Cognex.InSight.Job.Ise.Tags Namespace


TagReader Methods

The TagReader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read | Reads all of the tags that are present in the given binary block.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
See Also

Reference

TagReader Class
Cognex.InSight.Job.Ise.Tags Namespace


TagReader.Dispose Method

TagReaderDispose Method

Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public void Dispose()
Public Sub Dispose

Implements

IDisposableDispose
See Also

Reference

TagReader Class
Cognex.InSight.Job.Ise.Tags Namespace


TagReader.Read Method

TagReaderRead Method

Reads all of the tags that are present in the given binary block.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public static TagReader Read(
    byte[] binBlock
)
Public Shared Function Read (
    binBlock As Byte()
) As TagReader

Parameters

binBlock
Type: SystemByte
The binary block that is a representation of the tags.

Return Value

Type: TagReader

[Missing <returns> documentation for "M:Cognex.InSight.Job.Ise.Tags.TagReader.Read(System.Byte[])"]

See Also

Reference

TagReader Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet Class

A group of tags that describe whatever the tag applies to.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, Tag
Cognex.InSight.Job.Ise.TagsTagSet

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class TagSet : Dictionary<string, Tag>
Public Class TagSet
    Inherits Dictionary(Of String, Tag)

The TagSet type exposes the following members.

Constructors
 | Name | Description
Public method | TagSet | Creates a new TagSet that targets the type of tags specified.
Top
Properties
 | Name | Description
Public property | Comment | If this TagSet applies to cells and has a comment, the value of that comment.
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary String, Tag .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public property | EasyBuilderTag | If this TagSet applies to cells and has a EasyBuilder tag, the value of that tag.
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary String, Tag .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public property | TagType | The type of tag that the values in this TagSet target.
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary String, Tag .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary String, Tag .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary String, Tag .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetTTag | Returns the tag with the given key, or null if the key did not exist or was not of the expected type.
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary String, Tag .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary String, Tag .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary String, Tag .)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


TagSet Constructor

Creates a new TagSet that targets the type of tags specified.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public TagSet(
    TagType type
)
Public Sub New (
    type As TagType
)

Parameters

type
Type: Cognex.InSight.Job.Ise.TagsTagType
What the values in this TagSet target.
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet Properties

The TagSet type exposes the following members.

Properties
 | Name | Description
Public property | Comment | If this TagSet applies to cells and has a comment, the value of that comment.
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary String, Tag .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public property | EasyBuilderTag | If this TagSet applies to cells and has a EasyBuilder tag, the value of that tag.
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary String, Tag .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public property | TagType | The type of tag that the values in this TagSet target.
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Top
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet.Comment Property

TagSetComment Property

If this TagSet applies to cells and has a comment, the value of that comment.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string Comment { get; }
Public ReadOnly Property Comment As String
    Get

Property Value

Type: String
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet.EasyBuilderTag Property

TagSetEasyBuilderTag Property

If this TagSet applies to cells and has a EasyBuilder tag, the value of that tag.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public string EasyBuilderTag { get; }
Public ReadOnly Property EasyBuilderTag As String
    Get

Property Value

Type: String
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet.TagType Property

TagSetTagType Property

The type of tag that the values in this TagSet target.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public TagType TagType { get; }
Public ReadOnly Property TagType As TagType
    Get

Property Value

Type: TagType
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet Methods

The TagSet type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary String, Tag .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary String, Tag .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary String, Tag .)
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetTTag | Returns the tag with the given key, or null if the key did not exist or was not of the expected type.
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary String, Tag .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary String, Tag .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary String, Tag .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary String, Tag .)
Top
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagSet.Get(TTag) Method

TagSetGetTTag Method

Returns the tag with the given key, or null if the key did not exist or was not of the expected type.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public TTag Get<TTag>(
    string key
)
where TTag : Tag

Public Function Get(Of TTag As Tag) (
    key As String
) As TTag

Parameters

key
Type: SystemString
The key of the tag to look for.

Type Parameters

TTag
The type of tag to return.

Return Value

Type: TTag
The tag for the key, or null if not found.
See Also

Reference

TagSet Class
Cognex.InSight.Job.Ise.Tags Namespace


TagType Enumeration

Defines what this tag applies to.

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public enum TagType
Public Enumeration TagType
Members
Member name | Value | Description
CellTags | 0 | Applies to cells.
JobTags | 1 | Applies to entire jobs.
Subtag | 2 | Is a subtag.
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


UnknownTagTypeException Class

Non-fatal exception that signals that a tag was read that could not be understood, but could be safely skipped.
Inheritance Hierarchy
SystemObject
SystemException
Cognex.InSight.Job.CommonJobLoadException
Cognex.InSight.Job.Ise.TagsUnknownTagTypeException

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public class UnknownTagTypeException : JobLoadException
Public Class UnknownTagTypeException
    Inherits JobLoadException

The UnknownTagTypeException type exposes the following members.

Constructors
 | Name | Description
Public method | UnknownTagTypeException | Initializes a new instance of the UnknownTagTypeException class
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

Cognex.InSight.Job.Ise.Tags Namespace


UnknownTagTypeException Constructor

Initializes a new instance of the UnknownTagTypeException class

Namespace: Cognex.InSight.Job.Ise.Tags
Assembly: Cognex.InSight.Job.Ise (in Cognex.InSight.Job.Ise.dll) Version: 1.0.0
Syntax
C#
VB
Copy
public UnknownTagTypeException(
    string message
)
Public Sub New (
    message As String
)

Parameters

message
Type: SystemString
The message to pass to the exception.
See Also

Reference

UnknownTagTypeException Class
Cognex.InSight.Job.Ise.Tags Namespace


UnknownTagTypeException Properties

The UnknownTagTypeException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnknownTagTypeException Class
Cognex.InSight.Job.Ise.Tags Namespace


UnknownTagTypeException Methods

The UnknownTagTypeException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as the default hash function. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
See Also

Reference

UnknownTagTypeException Class
Cognex.InSight.Job.Ise.Tags Namespace


UnknownTagTypeException Events

The UnknownTagTypeException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

UnknownTagTypeException Class
Cognex.InSight.Job.Ise.Tags Namespace