In-Sight Explorer にようこそ

ようこそ In-Sight® Explorer へ!

Version: 5.6.0

はじめに

In-Sight® Explorer は、強力で完全に統合されたビジョンシステム構成、管理、およびオペレータインタフェースすべてを 1 つのソフトウェアパッケージで提供します。さらに、今回のバージョンから、In-Sight ビジョンシステムをプログラムするための 3 つの開発環境、EasyBuilder とスプレッドシートが使用できるようになりました。

EasyBuilder

EasyBuilder® には、アプリケーションのセットアップを簡略化するためのステップ単位のテンプレートと、画像を中心としたインタフェースが用意されています。このインタフェースでは、検査の設定時に画像内の対象となる特徴をポイント & クリックで選択できます。

スプレッドシート

スプレッドシートは従来の In-Sight Explorer 開発環境で、高度な柔軟性とフルセットの開発ツールを提供します。「In-Sight 関数リファレンス」では、スプレッドシートのセルに挿入できるすべての関数が説明されています。

[センサ/デバイスをネットワークに追加] ダイアログは、ネットワーク上で In-Sight やそのほかのデバイスをすばやく設定できるユーティリティです。

「In-Sight 通信リファレンス」では、In-Sight ビジョンシステムが TCP/IP ネットワークまたはシリアルポート接続経由で外部デバイスと通信する方法が説明されています。

Cognex Connect

Cognex Connect™ を使用すると、In-Sight ビジョンシステムを既存の自動化制御システムに簡単に統合できます。Cognex Connect には、ビジョンシステムで使用可能な非常に広範な通信機能が用意されています。

In-Sight を初めて使用する場合

初めて In-Sight 製品を使用する場合は、「用語集」と「ヘルプの表記規則」トピックから参照されることを推奨します。これらのトピックには、重要な用語の定義や、このヘルプファイルを使用する上でのアドバイスが記載されています。

In-Sight を既に使用している場合

このヘルプファイルは、In-Sight Explorer バージョン 5.x.x での使用を前提にしています。既に In-Sight Explorer や PC Host を熟知している場合は、In-Sight Explorer リリースノートの新機能に関するセクションをお読みください。

In-Sight® Explorerヘルプ　 - Version 5.6.0

06/11/2019 18:09

Copyright © 1999 -2019

Cognex Corporation

All Rights Reserved.


はじめに

In-Sight Explorer にようこそ
  • マシンビジョンの概要
  • マシンビジョンアプリケーションの開発
  • In-Sight Explorer の開発環境
  • In-Sight ビジョンシステムへの接続

マシンビジョンの概要

In-Sight ビジョンシステムは、通常、対象物の視覚的検査を実行するようにプログラムされたファクトリオートメーション環境に統合されます。ビジョンシステムのプログラミングには次の内容が含まれます。

  • 画像内で際立っている「対象の特徴」(特徴とも呼ばれます に基づき、何を探すかをビジョンシステムに指示する
  • いつ画像を取り込むか、どのように部品を最適に照らすかを指示する
  • 解析結果の通信方法と、結果に基づく操作方法を指示する

In-Sight ビジョンシステムマシンビジョンソリューション

一般に、マシンビジョン問題に対する In-Sight ソリューションには、次のものがあります。

  • In-Sight ビジョンシステム。画像を取り込むためのデジタルグレースケールまたはカラーカメラとそれらをデジタル化する CCD チップ、プログラムされた画像解析を実行する PC プロセッサ、および結果をレポートしたり、HMI、PLC、ロボットなどの他のデバイスとの間でメッセージを送受信したりする入出力ハードウェアと通信リンクが含まれます。
  • In-Sight Explorer　コンピュータソフトウェア。画像解析を実行し他のデバイスと通信するように In-Sight ビジョンシステムをプログラムするために使用されます。
  • レンズ。視野 (FOV) 内の対象の特徴を最適化します。
  • いくつかの形式の照明。画像内の特徴のコントラストを強化します。

オプションのコンポーネントには、次のものがあります。

  • 対象物検出同期センサ (通常は光学式または磁気センサ)。ビジョンシステムの画像の取り込みと処理をトリガします。
  • いくつかの形式のアクチュエータ。画像解析の結果に基づき部品を拒否またはソートします。

このシステムでは、同期センサが、部品または対象物が検査位置に着いたタイミングを示します。同期センサは、部品または対象物がビジョンシステムのそばを通るときに、その画像を取り込むように In-Sight ビジョンシステムをトリガします。この段階では、一般に、パルスが照明メカニズムに送られ照明もトリガされます。部品または対象物を照らすために使用される照明は、対象の特徴を強調し、影や反射などの対象外の特徴は不明瞭で目立たなくするように設計されます。

画像取り込みのプロセスでは、In-Sight ビジョンシステムのレンズが FOV (In-Sight ビジョンシステムが認識する物理領域) から光エネルギーを取り込み、それをデジタル形式に変換します。2D グリッドの値はピクセルと呼ばれ、個々のピクセルが位置 (X、Y 座標) とその位置の照明輝度を表すグレースケール値 (0 ～ 255、0 = 純黒、255 = 純白) に対応します。

Closed 例 - 画像の座標

注: In-Sight カラービジョンシステムは、ピクセルの色成分をレポートします。

その後、In-Sight ビジョンシステムは画像を処理し、画像解析 (画像内の対象物、寸法、または特徴のカウント、測定、識別など) を実行します。ビジョンシステムは、画像解析の結果に基づいて、部品の合格または不合格を判断し、アクチュエータへ信号を送信したり、ネットワーク接続されたデバイスと画像解析結果を通信したりします。

Closed ファクトリオートメーション環境でネットワーク接続された In-Sight ビジョンシステムの例

マシンビジョンアプリケーションの開発

In-Sight ビジョンシステムを使用したマシンビジョンアプリケーション開発には、次の 3 つの主要なコンポーネントがあります。

  • 問題の解析
  • ジョブの作成
  • テストと導入

問題の解析

マシンビジョンアプリケーションでは、問題の解析は 4 つの段階に分かれます。

  • 画像解析
  • 画像の取り込み
  • 外部との相互通信
  • オペレータの対話型操作

画像解析

画像解析の条件を検討する場合は、最初に検査を定義します。部品の考えられる合格/不合格条件、実行する検査の種類 (良/不良を判断する定性検査、または量や数量などの定量検査) を定義します。例えば、カウント、測定、存在/欠落の検出、識別のすべてまたはそのいずれかの実行や、速度対精度などの必要な妥協レベルを定義します。

注: 合格/不合格条件は主観的であってはなりません。何が合格で何が不合格かを示す明確な分類が必要です。

また、次の点も考慮します。

  • 部品は固定位置にあるか、移動するか (移動する場合は、どのようなタイプの移動であるか)。
  • ビジョンシステムが部品の画像取り込みに要する時間はどのぐらいか。
  • ビジョンシステムはどの程度迅速に結果を通信する必要があるか。

次に、部品を見て、何が対象の特徴であるかを識別します。一般にマシンビジョンでは、対象の特徴は、パターン、ブロブ、エッジ、コード/シンボル、またはテキストのいずれかです。それらの特徴の「良」または「不良」を判断する条件や、サイズ、形状、または数量を何によって測定するかを検討します。良い部品と不良部品を明確に区別できない場合、適切なビジョン検査を設計することはきわめて困難です。プロセスのこの部分を容易にするために、部品が合格するために満たす必要のある条件をすべて一覧にします。

画像の取り込み

マシンビジョンアプリケーションでは、良質の画像がなければ、アプリケーションがいかに綿密に設計されていても、正常に実行されません。部品の最適な画像を取り込む方法 (部品の対象の特徴を強調する必要がある) を検討する場合は、最初に、必要となる物理的な設定を計算します。In-Sight ビジョンシステムの適切な物理的設定を決定するには、画像内の部品の最適なサイズ、ビジョンシステムと部品との間のワークディスタンス、および最適な視野 (FOV) を計算します。

Closed 例 - 物理的な設定

ヒント: Cognex のレンズアドバイザを使用すると、ご使用のマシンビジョンアプリケーションに適したレンズを確認できます。

次は、問題の最も難しい側面である、対象の特徴を最適化して影を目立たなくする照明および光学的なソリューションを設計します。詳細については、照明と光学系のトピックを参照してください。

外部との相互通信

In-Sight ビジョンシステムは、通常、ファクトリオートメーション環境に統合されるため、ビジョンシステムは、ロボット、プログラマブルロジックコントローラ (PLC) などの他のデバイス、ヒューマンマシンインタフェース (HMI) を介したオペレータ、FTP ファイルサーバのすべてまたはそのいずれかと相互通信する必要があります。

このような環境では、ビジョンシステムが外部デバイスからのデータを受信すると見込まれるか、検査結果を通信すると見込まれるか、およびどの結果を送信するかを決定し、結果に基づいて実行する操作を決定します。

さらに、ビジョンシステムが、シリアル (ロボット)、ディスクリート (PLC)、Ethernet のすべてまたはどの通信プロトコルで通信するかを決定します。また、ディスクリートラインの追加を容易にするために Cognex 入力/出力 (I/O) モジュールが必要かどうか、ビジョンシステムの画像取り込み、部品の検査、および結果の通信をトリガするために使用する信号の種類は何かを考慮します。検査画像を FTP ファイルサーバに格納するかどうかも検討します。

 | ファクトリデバイス | プロトコル | プロトコルの種類
PLC | 三菱電機 | SLMP | 産業用 Ethernet
 |  | CC-Link | フィールドバス
 |  | PLC ファンクションブロック | 設定済みのデバイスのコマンドおよび属性
 | Rockwell | EtherNet/IP | 産業用 Ethernet
 |  | [DeviceNet] | フィールドバス
 |  | AOP | 設定済みのデバイスのコマンドおよび属性
 | Siemens | PROFINET | 産業用 Ethernet
 |  | PROFIBUS | フィールドバス
 | その他のプロトコル | MODBUS TCP | 産業用 Ethernet
 |  | Modbus | シリアル
 |  | ASCII 文字列コマンド | シリアル
 |  | OPC | 産業用 Ethernet
 |  | TCP | 産業用 Ethernet
 |  | UDP | 産業用 Ethernet
FTP サーバ |  | FTP | FTP 画像転送
ロボット | ABB、Denso、FANUC、Kuka、三菱電機、Motoman、および Staubli | 設定済みのドライバおよび ASCII 文字列コマンド | シリアル/Ethernet
 | Adept、Epson、IAI、Kawasaki、Nachi、Yamaha、およびその他のロボット | ASCII 文字列コマンド | シリアル/Ethernet

オペレータの対話型操作

ファクトリオートメーション環境では、オペレータは環境内の機器を管理および保守する責任者です。大半のオペレータは、マシンビジョンアプリケーションの設計とプログラムの責任は担っていないため、ユーザアクセスの容易さを考慮する必要があります。

実装する起動オプションのタイプと、ユーザの管理方法 (ユーザ名とユーザリスト、それぞれのパスワードを作成する必要があります) について綿密に検討します。オペレータには、ビジョンシステムとやり取りするためのインタフェースも必要です。ここでは、ジョブが作成された開発環境に応じて、設定可能にする必要のあるパラメータ、オペレータが責任を担う対話レベル、およびインタフェースのレイアウトとプレゼンテーションについて検討します。

ジョブの作成

In-Sight の用語で「ジョブ」と呼ばれる、マシンビジョンアプリケーションの作成には 4 つのステップがあります。

  1. ビジョンシステムへの接続と画像のロード
  2. 検査ツールの設定
  3. 検査ツールの結果の設定
  4. 最終的な実行時設定の構成

ビジョンシステムへの接続と画像のロード

In-Sight Explorer EasyBuilder またはスプレッドシートのいずれかの開発環境を使用してジョブを作成できます。最初のステップで、In-Sight ビジョンシステムまたはエミュレータのどちらかに接続します。ジョブを実際のビジョンシステムまたはエミュレータ (PC 上のビジョンシステムをシミュレートしたバージョン) のどちらで作成するかを決定します。

注: ジョブをエミュレータで作成する場合は、入力/出力機能は開発できません。また、事前に取り込んだ画像をロードする必要があります。

ビジョンシステムまたはエミュレータに接続した後、必要なネットワーク設定値を設定し、その後、画像取り込みパラメータを設定します (ビジョンシステムに接続されている場合)。ここで、特徴を最適化するために焦点と照明を調整し、画像取り込みトリガと露光のタイミングを設定し、必要な場合は、画像をピクセルから実世界の単位にキャリブレーションします。

検査ツールの設定

In-Sight ビジョンツールと EasyBuilder の位置決めツールと検査ツールは次の用途に使用されます。

  • 検査: 存在/欠落の検出、欠陥解析、パターンマッチング
  • 識別: 色、データコード、製造ロット番号、シリアル番号、テキスト
  • 測定: 計測、カウント、検出

画像解析に基づいて、検査に適したツールを選択します。

  • ブロブツールは、しみのような特徴を検出する場合に使用されます。特徴のサイズと形状は部品ごとに異なる場合があります。ブロブは、検査と測定の両方のアプリケーションで使用できます。
  • カラーツールは、色データに基づいて対象物を識別し照合するために使用されます。カラーツールには In-Sight カラービジョンシステムが必要であり、検査、識別、および測定の各アプリケーションで使用できます。
  • エッジツールは、ピクセルグレースケール値が明らかに不連続な円エッジ、カーブエッジ、または直線エッジを検出するために使用されます。エッジツールは、一般に検査と測定のアプリケーションで使用されます。
  • 傷検出ツールは、高度なパターンマッチング解析を実行して欠陥の有無を検証するために使用されます。傷検出ツールは一般に検査アプリケーションで使用されますが、一部の測定アプリケーションで使用されることもあります。
  • ヒストグラムツールは、コントラストや平均グレースケール (またはカラー) 値などのピクセル値に関するデータを返します。
  • ID ツールは、識別アプリケーションで 1D コード、2D コード、およびシンボルを識別するために使用されます。検出されたコード/シンボルは、他の種類の検査用の位置データも提供します。
  • 画像ツールは、画像を他の関数でさらに解析または使用する目的で、画像内の特徴を強調したり目立たなくしたりするために使用されます。画像ツールは、検査アプリケーションと測定アプリケーションにそのまま使用することができます。また、他のビジョンツールの入力画像として使用することもできます。
  • エッジ検査ツールは、詳細なエッジ解析 (エッジの位置、エッジペアの位置と間隔、エッジ幅の測定など) を行って、エッジに欠陥またはギャップが存在するかどうかを判定するために使用します。エッジツールは、検査アプリケーションと測定アプリケーションで使用されます。
  • OCR/OCV ツールは、ABC/123 などの英数字の読み取りと照合の両方またはいずれかを実行するために使用されます。一般に OCR/OCV ツールは識別アプリケーションで使用され、ID ツールと同様に、検出されたテキストはほかの種類の検査用の位置情報を提供します。
  • パターンマッチングは、領域とその他の幾何学的条件に基づきます。

ヒント: ツールの設定時には、いくつかの部品の画像をロードすることを推奨します。ロードされた画像を再生し、ツールの範囲やしきい値を調整して偏差を補正できます。画像には、部品の許容可能な偏差の所定の範囲と、いくつかの既知の欠陥品質が含まれます。

一般に、カラー、傷検出、エッジ検査、およびパターンの各ツールは最も低速ですが最も正確です。エッジツールが最速で、ブロブ、ヒストグラム、ID、および OCV/OCR の各ツールは中程度です。

注: EasyBuilder 位置決めツールと検査ツールは、アプリケーションの機能によって分類されます。

フィクスチャ

部品が画像内で移動する場合は、フィクスチャを作成する必要があります。フィクスチャは、部品の特徴を検出し、他のビジョンツールに、それぞれの検査を実行すべき場所を指示します。フィクスチャは、部品が示す移動のタイプに応じて、パターン、ブロブ、またはエッジ特徴に基づきます。部品が水平方向のみ、または垂直方向のみに移動する状況では、エッジを使用して他のツールを固定できます。角度方向が不要で、形状が各画像でほぼ同じ場合は、ブロブを使用できます。正確な座標が必要で、特徴が移動またはスケールやサイズの微小変化を示す場合は、パターンが非常に効果的です。

キャリブレーション

測定アプリケーションでは、特に、In-Sight ビジョンシステムから返されたピクセル座標をワールド座標に変換することが非常に重要です。EasyBuilder 開発環境では、[画像の設定] ステップで、[キャリブレーション (画像座標系をワールド座標系に変換)] グループボックスを使用して、ピクセル結果を実世界の測定単位として設定できます。スプレッドシートでは、キャリブレーションツールを使用します。

論理演算関数

結果、別のツール、またはツールセットのみに基づいて機能するようにツールを設定するなどのジョブのロジックを追加できます。追加には、EasyBuilder 開発環境では [部品の検査] ステップで Math & Logic ツールを使用し、スプレッドシート開発環境では、条件付き参照、セル状態、および数値演算関数を使用します。画像の強調および変更ツールを追加して、検査の前に画像をフィルタしてさらに処理することもできます。

検査ツールの結果の設定

検査ツールが実行され、結果が返されたら、結果をデバイス間で共有し、結果に基づいて操作を開始することで結果を活用する必要があります。ジョブ開発のこの部分では、ビジョンシステムと外部デバイス間の入力と出力を定義します。ディスクリート入力およびディスクリート出力の複雑さは、Cognex I/O モジュールを使用するかしないかに大きく依存します。In-Sight ビジョンシステム単独では、ビジョンシステムのオンボード I/O に制限されることが理由です (モデルによって異なります)。Cognex I/O モジュールは、ビジョンシステムへの電力に加え、追加のディスクリート I/O ラインへのアクセスも提供します。

この機能に関する詳細については、入出力関数および In-Sight 通信のトピックを参照してください。

最終的な実行時設定の構成

検査ツールが実行され、結果の通信が確立されたら、ジョブ開発の最終ステップに注目します。このプロセスでは、VisionView インタフェースパネルまたは別のサポートされている HMI 上で表示できる、カスタムビュー (スプレッドシート) または EasyView (EasyBuilder) を作成することで、オペレータに提示する必要のあるインタフェースの種類とパラメータについて検討します。フィルムストリップを使用して、後から確認するために合格/不合格条件に基づいて画像を記録するようにビジョンシステムを設定します。ジョブファイルをビジョンシステムに保存して、ジョブファイルを PC にバックアップします。最後に、ビジョンシステムをオンラインにして、導入する前にジョブをテストします。

ここで、ジョブの実行時間を決定できます。実行時間 = 遅延 + 画像取り込み時間 + ジョブ実行時間 + 表示時間

  • 遅延: 内部的 (最大 250 マイクロ秒) または外部的 (数ミリ秒) のいずれかで、ビジョンシステムの画像取り込みをトリガするために必要な時間。遅延を減らすには、ビジョンシステムの内部トリガを使用します。
  • 画像取り込み時間: 露光のための時間と、画像を画像処理プロセスに転送するための時間。画像取り込み時間を短縮するには、露光時間を短くして、部分的な画像取り込みを実行します。
  • ジョブ実行時間: ジョブファイル内のすべての実行時間の合計。ジョブ実行時間を短縮するには、小さい対象領域を使用して、偏差を少なくします。
  • 表示時間: 画像やグラフィカルオーバレイを表示するために使用される時間。表示時間を短縮するには、カスタムビューや EasyView などのオペレータインタフェース内の画像、グラフィックス、オーバレイの表示要素を無効にします。

テストと導入

導入前のジョブのテストには 4 つのステップがあります。

  1. オンライン化
  2. ジョブのテスト
  3. 範囲と制限の微調整
  4. 導入

オンライン化

このステップでは、In-Sight ビジョンシステムをオンライン状態にして、ジョブの実行命令や外部相互通信に基づいてジョブを実行できるようにします。

ジョブのテスト

返された結果をモニタし、外部デバイスとの適切な通信を確保します。TestRun は、予測されたパラメータの範囲内でマシンビジョンアプリケーションが動作しているかを確認する組み込みの方法を提供します。TestRun は、In-Sight ビジョンシステムでテストを実行し、その結果を想定される値と比較します。

範囲と制限の微調整

この段階では、ビジョンシステムをオフラインにし、必要に応じて各種ツールのパラメータを調整します。ここでも TestRun は、予測されたパラメータの範囲内でマシンビジョンアプリケーションが動作しているかを確認する組み込みの方法を提供します。

導入

ビジョンシステムをオンラインにし、ファクトリオートメーション環境内で動作させます。

In-Sight Explorer開発環境

In-Sight Explorer には、In-Sight ビジョンシステムのプログラミングと管理のために EasyBuilder とスプレッドシートの 3 種類の開発環境が用意されています。

EasyBuilder

EasyBuilder には、「ジョブ」と呼ばれる In-Sight ビジョンシステム用マシンビジョンアプリケーションの構築作業をタスクに分解するために、ステップ単位のテンプレート (アプリケーションステップ) が用意されています。EasyBuilder は画像を中心としたインタフェースに基づいて開発されていて、画像上で位置決めツールや検査ツールの対話型グラフィックス (領域) を移動し、結果を即座にフィードバックすることができます。インタフェースの下枠にある [設定] ペインは選択したステップに基づいて更新されます。また、このペインにはツールの結果をモニタし、アプリケーションのトラブルシューティングを行うための結果テーブルも表示されます。アプリケーションの開発や設置中には、ヘルプや入出力の統合モニタからガイダンスや有益なフィードバックを得ることができます。

注: EasyBuilder 開発環境の使用方法の詳細については、EasyBuilder ヘルプを参照してください。

スプレッドシート

スプレッドシートは従来の In-Sight Explorer プログラミング環境です。この環境では、半透明のスプレッドシートオーバレイを使用して、ビジョンタスク用に In-Sight ビジョンシステムを構成することができます。スプレッドシートのパレットには非常に広範な画像処理関数および通信関数が用意されています。このパレットには、In-Sight の関数およびスニペットの展開可能なメニューがあります。これらはドラッグ & ドロップするだけで、簡単にスプレッドシートに挿入できます。メニューバーとツールバーは、画像取り込み機能や、セルへの関数の挿入機能のほか、ビジョンアプリケーションに関するあらゆる機能へのアクセスを提供します。

注: 一部の In-Sight ビジョンシステムでは、スプレッドシートは利用できません。

EasyBuilder とスプレッドシート

EasyBuilder では、スプレッドシート環境と直接対話しなくても、容易に In-Sight ビジョンシステムをプログラミングすることができます。EasyBuilder でジョブを作成すると、プログラムされたアプリケーションステップと対応する In-Sight 関数が自動的にスプレッドシートに入力されます。それでも、スプレッドシート環境の柔軟性や包括的なツールセットは利用可能なので、In-Sight Explorer では、EasyBuilder の [表示] メニューで [スプレッドシート]、またはスプレッドシートの [表示] メニューで EasyBuilder を選択することによって、EasyBuilder 環境、スプレッドシート環境のどちらでもジョブの表示やプログラミングができます。

注: 一部の In-Sight ビジョンシステムでは、スプレッドシートは利用できません。

スプレッドシートに挿入した関数やセルは編集可能なので、EasyBuilder インタフェースで表示するパラメータをカスタマイズできます。位置決めツールや検査ツールのパラメータは、追加、削除、名前変更が可能です。

注: スプレッドシート環境で EasyBuilder パラメータを編集するには、スプレッドシートプログラミング環境に関する高度な知識が必要です。

EasyBuilder は、次のタイプのマシンビジョンアプリケーションに適しています。

  • 有無判定ツールまたは計数検査ツールを利用したコンポーネントアセンブリの検証。
  • ID コードの読み取り、パターン、またはカラー識別検査ツールを利用した製品の検証。
  • 距離および角度測定検査ツールを利用し、さらに、[画像の設定] ステップでキャリブレーション機能を使用して結果を実世界の測定単位にキャリブレーションする機能を持つ計測アプリケーション。
  • [通信] ステップで、PatMax パターン位置決めツールとベンダ固有の通信プロトコルを使用するビジョンガイド付きロボットアプリケーション。
  • 文字認識検査ツールを利用し、さらに、外部デバイスからテキスト文字列を入力する機能を持つ高コントラスト OCV/OCR アプリケーション。
  • ブロブ、輝度、コントラスト、ピクセル数の有無判定検査ツールを利用する簡単な欠陥検出アプリケーション。

次のタイプのアプリケーションでは、スプレッドシートの機能や関数へのアクセスが必要です。

  • 高度な欠陥検出や難しい ID、OCV/OCR など、画像をフィルタする機能を必要とするアプリケーション。
  • ID 検証アプリケーション。このようなアプリケーションでは、通常、大規模なカスタマイズが必要で、スプレッドシート機能に最適です。
  • 複雑なロジックを使用してツール結果を組み合わせたり、ツール結果を分類したり、ツール結果に基づいて出力をカスタマイズしたりする、ロジックやカスタマイズされた結果が関係するアプリケーション。
  • ランダムな方向を向いた複数の対象物が関係するアプリケーション。位置決めツールは複数の製品を検出できますが、結果をソートする能力は持ちません。
  • 個数のわからない対象物が関連するアプリケーション。このようなアプリケーションでは、スプレッドシートで複雑な編集が必要になります。

In-Sight ビジョンシステムへの接続

In-Sight Explorer は、サブネット上のすべての In-Sight ビジョンシステムを自動的に検出し、表示します。 アイコンとともに表示されるビジョンシステムは、実在する In-Sight ビジョンシステム (In-Sight 5100 など) を表し、 [image] アイコンは、ネットワーク接続された PC 上で動作する In-Sight エミュレータを表します。エミュレータの名前は、Microsoft Windows 環境での PC の名前です。

すべての In-Sight ビジョンシステムは出荷時に DHCP を使用するようにネットワーク設定されています。このため、DHCP サーバが用意されているネットワークでは、新しい In-Sight ビジョンシステムをアクティブなネットワークポートに接続するだけで、すぐ通信することができます。ネットワークで DHCP サーバを使用しない場合、またはビジョンシステムを PC に直接接続する場合は、[センサ/デバイスをネットワークに追加] ダイアログを使用して、ビジョンシステムとの接続を確立します。

実行モード動作時に In-Sight ビジョンシステムでプログラミングや表示を行うには、In-Sight ビジョンシステムに「ログオン」する必要があります。ビジョンシステムにログオンするには、有効なユーザ名とパスワードを使用する必要があります。新しいビジョンシステムは、admin、monitor、および operator という 3 つの標準アカウントを含むユーザリストを備えて出荷されます。これらのアカウントにはパスワードは設定されていません。

In-Sight Explorer を起動すると、デフォルトで admin ユーザとしてログオンされます。このスタートアップユーザ名は、[オプション] ダイアログで変更できます。現在のユーザ名やパスワードを変更するには、[システム] メニューの [ログオン/ログオフ] をクリックします。現在のユーザが変更されるたびに、In-Sight Explorer はユーザに関する情報を保存し、ほかの In-Sight ビジョンシステムへの接続時にこの情報を使用します。

In-Sight ビジョンシステムに接続 (通常、使用可能なビジョンシステムやエミュレータのリストから、目的のビジョンシステムまたはエミュレータをダブルクリック) すると、このビジョンシステムまたはエミュレータにユーザ名とパスワードが送信され、バッファされた画像、設定とジョブ、さらに取り込まれた画像から構成されるビュー、およびステータスバーが表示されます。

Version: 5.6.0


ヘルプの表記規則

In-Sight Explorer にようこそ

このページでは、このヘルプファイルで使用されているいくつかの書式について説明します。

注

「注」は、説明に関する追加情報を提供します。通常は、その「注」の直前に記載されている説明文に対する補足です。

注: これは、「注」の表記例です。

ヒント

「ヒント」には、理解を助ける示唆やショートカットが示されています。

ヒント: これは、「ヒント」の表記例です。

ポップアップウィンドウ

多くのヘルプトピックには、現在のページの上に重ねて表示される「ポップアップ」ウィンドウが含まれています。ポップアップウィンドウを閉じるには、ウィンドウ外の任意の場所をクリックします。また、ポップアップウィンドウ内の図以外の場所をクリックすることによって閉じることもできます。

ポップアップウィンドウの例

ドロップダウンホットスポット

ヘルプ内には先頭に Closed 矢印がついているテキストがあります。このテキストをクリックすると、ページの一部が「ドロップダウン」して、追加のテキストやグラフィックスが表示されます。例えば、前述の「矢印」をクリックしてみてください。

ドロップダウンテキストおよびグラフィックスは、簡潔にするために最初は表示されていない情報 (大規模なグラフィックスや例など) が存在することを示します。追加の内容を確認したら、もう一度「非表示」にすることができます。

注: リンクをもう一度クリックすると、こうしたテキストを「隠す」ことができます。

注: ドロップダウンホットスポットを正常に機能させるには、Internet Explorer 4.0 以降を使用する必要があります。


EasyBuilder グラフィカルユーザインタフェース

概要

EasyBuilder GUI リファレンス

EasyBuilder グラフィカルユーザインタフェース (GUI) は画像を中心に構成されています。画像を取り囲むペインやコントロールは、マシンビジョンアプリケーション (「ジョブ」) を構築するプロセスをガイドするように設計されています。

EasyBuilder の GUI は、次の 6 つの部分で構成されています。メニューバー、ツールバー (標準、EasyBuilder、Explorer)、アプリケーションステップ、EasyBuilder ビュー、パレット および設定ペイン。

ウィンドウペインのカスタマイズ

[アプリケーションステップ] (EasyBuilder ビューのみ)、[In-Sight のネットワーク]、[In-Sight のファイル] および [パレット] ペインはウィンドウペインにドッキングすることができます。また、ペインのタイトルバーをドラッグまたは右クリックすることによってカスタマイズすることができます。

ドラッグによるカスタマイズ

ウィンドウペインのタイトルをクリックして、目的の位置にドラッグします。

ウィンドウペインのドッキング

ウィンドウペインをユーザインタフェースの特定の範囲に固定するには、ドッキング先のウィンドウの端にウィンドウペインをドラッグして、ユーザインタフェースに表示される小さな正方形のいずれか 1 つにドロップします。小さな正方形にウィンドウペインを合わせると、ドッキング先の範囲が青色で表示されます。

ユーザインタフェースの左側にドッキングします。
ユーザインタフェースの右側にドッキングします。
ユーザインタフェースの上側にドッキングします。
ユーザインタフェースの下側にドッキングします。
ウィンドウペインをタブとしてドッキングします。

右クリックによるドッキング

ウィンドウペインのタイトルを右クリックすると、次のメニューが表示されます。

  • [ドッキング] (デフォルト): ウィンドウペインをユーザインタフェースに固定します。
  • [自動的に隠す]: ウィンドウペインをユーザインタフェースの横に「ピン留め」します。ウィンドウペインを表示するには、ユーザインタフェースのサイドバーにカーソルを合わせます。このメニューは [Floating] が選択されていると使用できません。
  • [隠す]: ウィンドウペインを閉じます。再表示するには、[表示] メニューからウィンドウペインを選択します。このメニューは EasyBuilder の [アプリケーションステップ] ウィンドウペインでは使用できません。

注: ドッキングしていないウィンドウペインをダブルクリックすると、最後にドッキングした位置に戻ります。ドッキングしているウィンドウペインをダブルクリックすると、ユーザインタフェースから分離します。
Version: 5.6.0


[ファイル] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[ファイル] メニューによって、ジョブファイルと画像ファイルをロードして保存し、アクティブジョブの結果テーブルのハードコピーを印刷することができます。このメニューから EasyBuilder を閉じることもできます。

注: EasyBuilder ビューがアクティブでないとき、次の [ファイル] メニューの一部またはすべてが利用できない場合があります。

[ファイル] メニューの項目

  • [ジョブの新規作成]: 現在のジョブを閉じ、空白のジョブファイルを開きます。新しいジョブが作成される前に、アクティブジョブを保存するよう求められます。
  • [ジョブを開く]: [開く] ダイアログを使用して、In-Sight センサまたはエミュレータからジョブファイルをロードします。ジョブが開くと、そのジョブがアクティブジョブになります。
  • [ジョブの保存]: [名前を付けて保存] ダイアログを使用して、アクティブジョブをファイルに書き込みます。アクティブジョブがすでに保存されている場合、このオプションは最後の保存以降に加えられたあらゆる変更を既存のファイルに上書きします。その際、[保存] ダイアログは表示されません。ジョブは In-Sight センサまたはエミュレータに保存できます。
  • [ジョブに名前を付けて保存]: アクティブジョブを新しいファイルに書き込みます。このオプションでは、保存前にファイル名を付けることを求める [名前を付けて保存] ダイアログが表示されます。ジョブは In-Sight センサまたはエミュレータに保存できます。
  • [画像を開く]: [開く] ダイアログを使用して、In-Sight センサまたはエミュレータから画像をロードします。画像が開かれると、その画像は表示領域に配置されます。
  • [画像に名前を付けて保存]: 現在の画像を新しいファイルに書き込みます。このオプションでは、保存前にファイル名を付けることを求める [名前を付けて保存] ダイアログが表示されます。画像は In-Sight センサまたはエミュレータに保存できます。

注: 画像が In-Sight センサに保存されると、選択されたファイル名に関係なく、その画像が現在の画像 (image.bmp) になります。In-Sight センサでは、任意の名前の画像ファイルはサポートされません。

  • [ページ設定]: 用紙のサイズ、方向、マージンを設定できる [ページ設定] ダイアログを表示します。
  • [印刷プレビュー]: 印刷前にページをプレビューすることができる [印刷プレビュー] ウィンドウを表示します。
  • [印刷]: アクティブジョブの結果テーブルをローカルまたはネットワークのプリンタに印刷します。[印刷] オプションによって [印刷] ダイアログが表示されます。
  • [終了]: EasyBuilder を閉じます。実行中の場合、In-Sight エミュレータはアプリケーションとともにシャットダウンします。

スプレッドシートビュー

[ファイル] メニューでは、ジョブファイルおよび画像ファイルのロードと保存、セルデータ (.CXD) ファイルのインポートおよびエクスポート、ジョブの保護、アクティブなスプレッドシートのハードコピーの印刷を行うことができます。このメニューから In-Sight Explorer を閉じることもできます。

注: スプレッドシートビューがアクティブでないとき、次の [ファイル] メニューの一部またはすべてが利用できない場合があります。

[ファイル] メニューの項目

  • [ジョブの新規作成]: 現在のジョブを閉じ、空白のスプレッドシートを開きます。新しいジョブが作成される前に、アクティブジョブを保存するよう求められます。

注: ジョブが New.job というファイル名で、In-Sight Explorer.exe が保存されている同じディレクトリに保存されると、このジョブファイルが [ジョブの新規作成] のテンプレートになります。[ジョブの新規作成] が選択されるたびに、空白のスプレッドシートではなく、この保存されたジョブがロードされます。New.job が特定のセンサモデルまたはファームウェアリビジョンの機能を使用している場合、互換性のないセンサで新しいジョブが作成されると、エラーが発生する可能性があります。無効な関数はテキスト文字列に変換されます。

  • [ジョブを開く]: [開く] ダイアログを使用して、In-Sight センサまたはエミュレータからジョブファイルをロードします。ジョブが開くと、そのジョブがアクティブジョブになります。
  • [ジョブの保存]: [名前を付けて保存] ダイアログを使用して、アクティブジョブをファイルに書き込みます。アクティブジョブがすでに保存されている場合、このオプションは最後の保存以降に加えられたあらゆる変更を既存のファイルに上書きします。その際、[保存] ダイアログは表示されません。ジョブは In-Sight センサまたはエミュレータに保存できます。
  • [ジョブに名前を付けて保存]: アクティブジョブを新しいファイルに書き込みます。このオプションでは、保存前にファイル名を付けることを求める [名前を付けて保存] ダイアログが表示されます。ジョブは In-Sight センサまたはエミュレータに保存できます。
  • [スニペット]: セルデータ (.CXD) ファイルとして保存された事前設定済みセルのグループを PC の Snippets フォルダにエクスポートすることにより、[スニペット] ダイアログにアクセスして、よく実行されるタスクを自動化します。その後、このスニペットをスプレッドシートにインポートすることができます。または、スニペットをパレットからスプレッドシートに直接ドラッグ & ドロップしてインポートすることができます。

    • [インポート]: [スニペット] ダイアログを開いて、スニペットをスプレッドシートにインポートします。

    • [エクスポート]: [スニペット] ダイアログを開いて、スニペットを PC の Snippets フォルダにエクスポートします。

  • [セルのインポート]: [セルのインポート] ダイアログを使用して、別のセルのデータまたは関数を .CXD ファイルとしてスプレッドシートにインポートする、ユーザ起動式の手段を提供します。このデータファイルは別のローカルまたはネットワークセンサのフラッシュメモリ、RAM ディスク、あるいは FTP サーバからロードすることができます。
  • [セルのエクスポート]: [セルのエクスポート] ダイアログを使用して、セル内のデータまたは関数を .CXD ファイルとして保存する、ユーザ起動式の手段を提供します。このデータファイルはローカルまたはリモートセンサのフラッシュメモリ、センサまたはエミュレータの RAM ディスク、FTP サーバあるいはローカル PC の Snippets フォルダに保存することができます。
  • [ジョブの保護]: ユーザがジョブ内のデータを変更、移動、または削除できないようにします。このオプションでは [ジョブの保護] ダイアログが表示され、ジョブを保護するためにパスワードの入力が求められます。
  • [画像を開く]: [開く] ダイアログを使用して、In-Sight センサまたはエミュレータから画像をロードします。画像が開かれると、透明なスプレッドシートオーバレイの背後に配置されます。
  • [画像に名前を付けて保存]: 現在の画像を新しいファイルに書き込みます。このオプションでは、保存前にファイル名を付けることを求める [名前を付けて保存] ダイアログが表示されます。画像は In-Sight センサまたはエミュレータに保存できます。

注: 画像が In-Sight センサに保存されると、選択されたファイル名に関係なく、その画像が現在の画像 (image.bmp) になります。In-Sight センサでは、任意の名前の画像ファイルはサポートされません。

  • [ページ設定]: 用紙のサイズ、方向、マージンを設定できる [ページ設定] ダイアログを表示します。
  • [印刷プレビュー]: 印刷前にページをプレビューすることができる [印刷プレビュー] ウィンドウを表示します。
  • [印刷]: [印刷] ダイアログが表示され、アクティブジョブのスプレッドシートをローカルまたはネットワークのプリンタに印刷できます。
  • [終了]: In-Sight Explorer を閉じます。実行中の場合、In-Sight エミュレータはアプリケーションとともにシャットダウンします。


[保存] および [開く] ダイアログ

[ファイル] メニュー

In-Sight Explorer GUI リファレンス

[保存] および [開く] ダイアログは、本質的に FTP クライアントとして、2 つの In-Sight ビジョンシステム間の接続を確立します。ジョブおよび画像ファイルは、リモートビジョンシステムからロードしたり、リモートビジョンシステムに保存したりすることができます。

  • ジョブを開く
  • ジョブを保存する
  • 画像を開く
  • 画像を保存する
注:
  • In-Sight ビジョンシステムの設定 (ネットワーク設定など) は、[ジョブに名前を付けて保存] ダイアログを使用して保存することはできません。ビジョンシステム設定ファイル (proc.set) は、標準の FTP コマンドを使用することによってのみ、ネットワーク上の In-Sight エミュレータまたは In-Sight 以外の FTP デバイスから転送することができます。
  • 1 つの In-Sight ビジョンシステムには 1024 個以上のファイルを保存できますが、FTP プロンプトまたは Telnet セッションからファイルリストを表示した場合、リストに表示されるファイルは 1024 個のみで、[保存] および [開く] ダイアログには 1024 ファイルしか表示できません。
  • ワーキングエミュレータのディレクトリは 2 つあります (C:\ProgramData\Cognex\In-Sight\Emulators\5.x.x および C:\ProgramData\Cognex\In-Sight\Emulators\4.x.x)。In-Sight エミュレータを使用する場合は、エミュレーションモデルに応じて、ジョブ/画像を保存したり、開いたりするために別のディレクトリが使用されます。例えば、エミュレータモデルが In-Sight 8405 に設定されている場合、ジョブ/画像は 5.x.x ディレクトリに保存されます。エミュレータモデルが In-Sight Micro 1400 に設定されている場合、ジョブ/画像は 4.x.x ディレクトリに保存されます。したがって、ジョブが 4.x.x エミュレータ (In-Sight Micro 1400 など) に保存される場合に、エミュレータモデルを 5.x.x (標準モデルなど) に変更すると、[開く] ダイアログからジョブを開こうとするときに、そのジョブはダイアログのリストに表示されません。エミュレータモデルとエミュレータのバージョンの詳細については、「[オプション] ダイアログ」のトピック (エミュレーションパネル) を参照してください。

ジョブを開く

[ジョブを開く] ダイアログを使用すると、ジョブファイルを In-Sight ビジョンシステムのメモリにアクティブなジョブとしてロードすることができます。

In-Sight ビジョンシステムからジョブファイルを開くには、以下の操作を実行します。

  1. [ファイル] メニューで、[ジョブを開く] をクリックします。

  2. 開くジョブファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上の RAM ディスクフォルダ (有効化および設定済み) と SD カードフォルダを含む、検出された In-Sight ビジョンシステムとエミュレータ、 ジョブサーバ と Explorer ホストテーブルで定義されたすべてのデバイスが含まれています。ビジョンシステムで使用可能なジョブを表示するには、ドロップダウンリストから目的のビジョンシステムを選択します。In-Sight ビジョンシステムまたはエミュレータの RAM ディスクフォルダまたは SD カードフォルダを選択するには、まず、目的の RAM ディスクフォルダまたは SD カードフォルダがある In-Sight ビジョンシステムまたはエミュレータをクリックして、表示された「RAMDisk」フォルダまたは「SDCARD」フォルダをダブルクリックします。
  3. 必要なジョブをハイライトして、[開く] をクリックします。または、ジョブファイルをダブルクリックするか、[ファイル名] にファイル名を入力して [開く] をクリックします。
注:
  • Explorer のホストテーブルで定義されていない限り、サブネット上に存在しない In-Sight ビジョンシステムが [ファイルの場所] ドロップダウンリストに自動的に表示されることはありません。
  • 次の場合は、[ジョブを開く] ダイアログを使用できません。
    • アクティブな In-Sight ビジョンシステムがオンラインになっている
    • ユーザのアクセスレベルがロックである
  • プロテクトアクセスレベルのユーザは、ユーザリストでその特定ユーザに FTP 読み出し権限が与えられている場合にのみ、[開く] ダイアログを使用できます。
  • In-Sight ビジョンシステムの設定を [ジョブを開く] ダイアログから開くことはできません。ビジョンシステム設定ファイル (proc.set) は、標準の FTP コマンドを使用することによってのみ、ネットワーク上の In-Sight エミュレータまたは In-Sight 以外の FTP デバイスから転送することができます。

  • ジョブサーバの場所は、[ジョブサーバの設定] ダイアログを使ってジョブサーバを有効にしている場合にだけ表示されます。

  • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  • ダイアログでファイルを右クリックすることにより、ファイルをコピー、削除、または名前変更できます。コピーしたジョブは、ほかの In-Sight ビジョンシステム、エミュレータまたは SD カードに貼り付けることができます。

ジョブを保存する

[ジョブに名前を付けて保存] ダイアログを使用すると、ジョブファイルを In-Sight ビジョンシステムのメモリに格納できます。格納先デバイスが In-Sight エミュレータの場合、ジョブは PC のハードディスク上のファイルに保存されます。

In-Sight ビジョンシステムにジョブファイルを保存するには、以下の操作を実行します。

  1. [ファイル] メニューで、[ジョブに名前を付けて保存] をクリックします。

  2. ファイルを保存する場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上の RAM ディスクフォルダ (有効化および設定済み) と SD カードフォルダを含む、検出された In-Sight ビジョンシステムとエミュレータ、 ジョブサーバ と Explorer ホストテーブルで定義されたすべてのデバイスが含まれています。ビジョンシステムで使用可能なジョブを表示するには、ドロップダウンリストから目的のビジョンシステムを選択します。In-Sight ビジョンシステムまたはエミュレータの RAM ディスクフォルダまたは SD カードフォルダを選択するには、まず、目的の RAM ディスクフォルダまたは SD カードフォルダがある In-Sight ビジョンシステムまたはエミュレータをクリックして、表示された「RAMDisk」フォルダまたは「SDCARD」フォルダをダブルクリックします。
  3. アクティブジョブを新規ファイルに保存するには、[ファイル名] テキストボックスに名前を入力して、[保存] をクリックします。既存のファイルに上書き保存するには、そのファイルをリストから選択して、[保存] をクリックします。

注:
  • ファイルを初めて保存する場合は、ファイル名の指定を求められます。ファイルに名前を付けるときには、円記号 (¥) を使用しないでください。名前に円記号が含まれているファイルは、ファイル名を変更して円記号をなくしてからでなければ、コピーや削除ができません。また、ファイル名に円記号が含まれていると、リストア操作の際にエラーが発生します。
  • ファイル名にはスペースを含めることができます。
  • ファイル名に、/ : , ; * ? " < > | % の各文字を含めることはできません。
  • ジョブの保存中は、ビジョンシステムの電源を入れ直さないでください。ファイルの保存中に電源が遮断された場合は、ファイルをもう一度保存しなおす必要があります。
  • ジョブのサイズやジョブの保存先デバイスの接続速度によっては、ほかのジョブよりも保存に時間がかかるジョブがあります。
  • ファイルのコピーを保存する場合、またはファイルを別の場所に保存する場合は、[ファイル] メニューから [ジョブに名前を付けて保存] を選択します。
  • ジョブファイルのパス名は最大 255 文字です。ジョブファイルのパス名とは、ルートディレクトリからファイル名とファイル拡張子のすべての文字のことです。ネイティブモードコマンドを使用する場合、ファイル名の前のジョブスロットも合計文字数に含める必要があります。
  • Explorer のホストテーブルで定義されていない限り、サブネット上に存在しない In-Sight ビジョンシステムが [ファイルの場所] ドロップダウンリストに自動的に表示されることはありません。
  • 次の場合は、[ジョブに名前を付けて保存] ダイアログを使用できません。

    • アクティブな In-Sight ビジョンシステムがオンラインになっているただし、[ユーザ] ダイアログの [オンラインでもジョブを保存] チェックボックスをオンにすると、[フル] または [プロテクト] アクセス権限を持つユーザは [名前を付けて保存] ダイアログにアクセスできるようになります。

    • ユーザのアクセスレベルがロックである

  • プロテクトアクセスレベルのユーザは、ユーザリストでその特定のユーザに FTP 書き込み権限が与えられている場合にのみ、[名前を付けて保存] ダイアログを使用できます。
  • In-Sight Explorer 4.4.1 以降で、ジョブが保護されている場合は、ドロップダウンメニューのオプション [暗号化] が有効になります。オプションは、[高速 (デフォルト)] と [レガシー] の 2 つです。[高速] オプションでは、特に大規模なジョブファイルのジョブに関連する遅延を低減します。[レガシー] オプションは、In-Sight Explorer 4.4.0 以前を実行中の In-Sight ビジョンシステムと互換性を持たせる必要があるジョブの場合に使用します。[暗号化] ドロップダウンは、ジョブで使用されている現在の暗号化オプションに設定されます。

  • ジョブサーバの場所は、[ジョブサーバの設定] ダイアログを使ってジョブサーバを有効にしている場合にだけ表示されます。

  • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  • ダイアログでファイルを右クリックすることにより、ファイルをコピー、削除、または名前変更できます。コピーしたジョブは、ほかの In-Sight ビジョンシステム、エミュレータまたは SD カードに貼り付けることができます。

画像を開く

[画像を開く] ダイアログを使用すると、標準の .BMP または .JPG ファイルを In-Sight ビジョンシステムにロードすることができます。画像はロード先ビジョンシステムでアクティブな画像となり、In-Sight ファイルシステムの image.bmp と置き換えられます。

画像ファイルをアクティブな画像として In-Sight ビジョンシステムにロードするには

  1. [ファイル] メニューで、[画像を開く] をクリックします。

  2. 開く画像ファイルが格納されている場所を選択します。開く画像ファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上で検出された In-Sight ビジョンシステムとエミュレータ (SD カードフォルダを含む)、および Explorer のホストテーブルで定義されているすべてのデバイスが含まれています。In-Sight ビジョンシステムの SD カードフォルダを選択するには、まず、目的の SD カードフォルダがある In-Sight ビジョンシステムをクリックして、表示された「SDCARD」フォルダをダブルクリックします。
  3. 必要な画像をハイライト表示して、[開く] をクリックします。または、画像ファイルをダブルクリックするか、[ファイル名] にファイル名を入力して [開く] をクリックします。

注:
  • 次の場合は、[開く] ダイアログを使用できません。

    • アクティブな In-Sight ビジョンシステムがオンラインになっている

    • ユーザのアクセスレベルがロックである

  • プロテクトアクセスレベルのユーザは、ユーザリストでその特定ユーザに FTP 読み出し権限が与えられている場合にのみ、[開く] ダイアログを使用できます。
  • In-Sight ビジョンシステム (カラービジョンシステムを除く) は、最後に取り込んだ画像を低解像度画像として出力できます。個別の FTP 接続から FTP コマンドの get [ファイル名] を使用することによって、低解像度画像を image2.bmp (1/2 の高さ × 1/2 の幅) または image4.bmp (1/4 の高さ × 1/4 の幅) として入手できます。例えば、FTP コマンドラインから get image2.bmp と入力します。

画像を保存する

[画像に名前を付けて保存] ダイアログを使用すると、In-Sight ビジョンシステムのアクティブな画像を、後で取得するために保存することができます。画像は、ビットマップ (*.BMP) または JPEG (*.JPG) フォーマットで、任意の In-Sight ビジョンシステムまたはエミュレータに保存できます。

注: 画像を In-Sight ビジョンシステムに保存すると、その画像が、デバイス上の image.bmp と置き換えられてアクティブな画像になります。画像ファイルの別名は、In-Sight ビジョンシステムではサポートされていません。ただし、In-Sight エミュレータでは、画像ファイルの別名が許されます。この場合、画像を保存できる容量は、PC のハードディスクの容量に基づきます。

画像ファイルを In-Sight ビジョンシステムに保存するには

  1. [ファイル] メニューで、[画像に名前を付けて保存] をクリックします。

  2. 画像の保存先 In-Sight ビジョンシステムを選択します。開く画像ファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカル PC 上のドライブ、ネットワークドライブ、ローカルサブネット上で検出された In-Sight ビジョンシステムとエミュレータ (SD カードフォルダを含む)、および Explorer のホストテーブルで定義されているすべてのデバイスが含まれています。In-Sight ビジョンシステムの SD カードフォルダを選択するには、まず、目的の SD カードフォルダがある In-Sight ビジョンシステムをクリックして、表示された「SDCARD」フォルダをダブルクリックします。
  3. 画像を新規ファイルとして保存するには、[ファイル名] テキストボックスに名前を入力し、[保存] をクリックします。既存のファイルに上書き保存するには、そのファイルをリストから選択して、[保存] をクリックします。
注:
  • 画像ファイル名の最大長は 251 文字です (.BMP または .JPG 拡張子以外)。
  • ファイル名に、/ : , ; * ? " < > | % の各文字を含めることはできません。
  • オンラインモード時に自動的に画像を保存するには、スプレッドシートに WriteImageFTP 関数を挿入します。
  • 次の場合は、[名前を付けて保存] ダイアログを使用できません。

    • アクティブな In-Sight ビジョンシステムがオンラインになっている

    • ユーザのアクセスレベルがロックである

  • プロテクトアクセスレベルのユーザは、ユーザリストでその特定のユーザに FTP 書き込み権限が与えられている場合にのみ、[名前を付けて保存] ダイアログを使用できます。


[ページの設定] ダイアログ

[ファイル] メニュー

In-Sight Explorer GUI リファレンス

[ページの設定] ダイアログでは、印刷時に使用されるページ設定を指定できます。

[ページの設定] ダイアログを表示するには

  1. [ファイル] メニューで、[ページの設定...] をクリックします。

[ページの設定] ダイアログの設定項目

  • [Paper (用紙)]: 任意の用紙タイプのサイズと給紙方法を入力します。これら 2 つのドロップダウンリストには、[印刷] ダイアログで現在選択されているプリンタに基づいて自動的に値が取り込まれます。
  • [画像方向]: [Portrait (縦)] と [Landscape (横)] のどちらか適切な方向を入力します。
  • [Margin (inches) (余白 (インチ))]: 任意の余白を入力します。
Version: 5.6.0


[印刷プレビュー]

[ファイル] メニュー

In-Sight Explorer GUI リファレンス

この[印刷プレビュー]ウィンドウでは、印刷前にページのプレビューを表示できます。

[印刷プレビュー] ウィンドウを表示するには

  1. [ファイル] メニューで、[印刷プレビュー] をクリックします。

[印刷プレビュー]の設定項目

この[印刷プレビュー]ウィンドウから、すべてのページを印刷し、設定されているパーセンテージを使用してズームし、一度に表示するページ数を選択し、表示する特定のページを選択することができます。スプレッドシートビューでセルを選択すると、それぞれのセルのみが表示および印刷されます。セルが何も選択されていない場合は、データまたは数式が格納されているすべてのセルが表示および印刷されます。


[印刷] ダイアログ

[ファイル] メニュー

In-Sight Explorer GUI リファレンス

[印刷] ダイアログでは、特定のプリンタと印刷データを選択できます。

[印刷] ダイアログを表示するには

  1. [ファイル] メニューで、[印刷] をクリックするか、CTRL+P を押します。

[印刷] ダイアログの設定項目

  • [プリンタ]: プリンタを選択します。選択したプリンタの情報も表示されます。印刷時に [Print to file (ファイルに印刷)] を選択すると、印刷出力はプリンタの代わりにファイルに送信されます。
  • [Print range (印刷範囲)]: 印刷するページを指定します。[ページ] をクリックする場合は、必要なページ数も入力する必要があります。[選択] が有効な場合は、ハイライト表示されているセルのみが印刷されます。
  • [コピー]: 印刷するコピー枚数を指定します。[Collate (照合)] が選択されていると、次のコピーの最初のページが印刷される前に、ドキュメントの完全なコピーが印刷されます。
注:
  • 印刷されるデータのサイズは、[シートズーム] ダイアログで選択するパーセンテージに基づきます。
  • 新しいプリンタをプリンタのリストに追加するには、[ページ設定] ダイアログから [プリンタ...] を選択します。
  • [カスタムビュー] またはユーザ作成ダイアログを印刷する場合、印刷出力は単一ページのビューに適合するように自動的に縮小されます。
  • 一部の古いプリンタドライバでは、正しく印刷されないことがあります。この問題が発生した場合は、プリンタの製造元からプリンタドライバの更新を試みてください。ドライバを更新しても問題が解決しない場合は、In-Sight Explorer で印刷のために必要とされる機能の一部がそのプリンタでサポートされていない可能性があります。別の方法として、(CTRL+SHIFT+C または ALT+PRINTSCREEN を押して) 画面の表示部をクリップボードにコピーし、画像をサポートする別のアプリケーションに貼り付け、そのアプリケーションから印刷します。


[編集] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[編集] メニューには、ジョブデータ、ファイル、画像を操作するための機能が含まれています。

注: EasyBuilder ビューがアクティブであるとき、[編集] メニューのコマンドは [位置決め] および [検査] ステップのみで利用することができます。[In-Sight のファイル] ペインがアクティブであるとき、編集コマンドの一部をファイル管理に利用することができます (あるビジョンシステムから別のビジョンシステムにファイルをコピーして貼り付けるなど)。

[編集] メニューの項目

  • [元に戻す]: EasyBuilder ジョブに対する編集の最後の操作 (コピー、ペースト、削除など) を元に戻します。
  • [やり直し]: [元に戻す] コマンドの最後の操作を元に戻します。
  • [切り取り]: EasyBuilder ビューでは使用できません。
  • [コピー]: 選択した位置決めツールまたは検査ツールの内容を EasyBuilder ジョブの位置決めまたは検査ステップのメモリに複製するために保存します。元のコンテンツはそのまま保持されます。[In-Sight のファイル] ペインで [コピー] をクリックすると、ハイライトされた任意のファイルが、目的の In-Sight ビジョンシステムに貼り付けられるように、Windows のクリップボードに置かれます。
  • [貼り付け]: コピーされたデータをメモリから EasyBuilder ジョブの位置決めまたは検査ステップに書き込みます。ファイルを目的の In-Sight ビジョンシステムまたは任意の Microsoft Windows エクスプローラフォルダ (デスクトップを含む) に書き込みます。

注: 画像ファイルが In-Sight ビジョンシステムに貼り付けられると、そのファイルはアクティブな画像になり、image.bmp で表されます。In-Sight ビジョンシステムは、アクティブでない画像を保存しません。ただし、In-Sight エミュレータは、数に制限なく画像を保存できます (PC のハードディスク容量によってのみ制限されます)。

  • [削除]: アクティブであるウィンドウによっては、[削除] を使用して EasyBuilder ジョブのツールを削除することができます。[In-Sight のファイル] がアクティブである場合、[削除] により、特定のファイルを除いて、選択したファイルを削除することができます。
  • [領域の最大化]: 表示領域のサイズに合わせて、選択したツールグラフィックスのサイズを変更します。
  • [HMI ビューの選択]: [HMI ビューの選択] ダイアログを開き、HMI アプリケーションでユーザが確認可能な Run モードビュー、および HMI アプリケーションの [Switch View] ボタンが押されたときにビューの順序を指定します。

スプレッドシートビュー

[編集] メニューには、スプレッドシートのセルデータ、セルの状態、ファイルおよび画像を操作するための機能が含まれています。新しいカスタムビューを作成するか、既存のカスタムビューのパラメータを変更することもできます。

注: スプレッドシートビューがアクティブでないとき、次のメニューの一部またはすべてが利用できない場合があります。

[編集] メニューの項目

  • [元に戻す]: 以下の最後の操作を元に戻します。
    • セルの編集 (切り取り、コピー、ペースト、削除)。
    • スプレッドシートの編集 (行/列の追加、削除、挿入、行/列の高さまたは幅の調整、行/列の表示/非表示)。
    • 数式の変更 (絶対/相対参照または関数の削除、ダイアログで加えられた全ての編集を元に戻す、プロパティシートまたは対話型グラフィックスモードセッション)。
    • 対話型グラフィックスモードセッション内の操作。

  • [やり直し]: [元に戻す] コマンドの最後の操作を元に戻します。

    注: [元に戻す] および [やり直し] 操作は、ダイアログまたはプロパティシート内の個々の操作には機能しません。ダイアログまたはプロパティシートが許可されて閉じられると、[元に戻す] ボタンによってセッション全体で加えられたすべての変更が元に戻ります。
  • [切り取り]: 選択した任意のセルのコンテンツを削除して、データのコピーをメモリに置きます。[切り取り] は、多くの場合に、セルデータを「移動」するために ([貼り付け] とともに) 使用されます。

注: ある In-Sight ビジョンシステムのスプレッドシートビューからデータを切り取った場合、そのデータを別のビジョンシステムのスプレッドシートビューに貼り付けることはできません。データは、同じビジョンシステムのスプレッドシートビューに貼り付ける必要があります。新しいジョブがアクティブな In-Sight ビジョンシステムにロードされる場合、またはビジョンシステムが再起動される場合、クリップボードのデータは失われることに注意してください。異なる In-Sight ビジョンシステム間で作業する際は、[切り取り] と [貼り付け] ではなく、[コピー] と [貼り付け] を使用してください。

  • [コピー]: 選択したセルのコンテンツを、スプレッドシート内のほかのセルに複製するために、メモリに保存します。元のコンテンツはそのまま保持されます。[In-Sight のファイル] ペインで [コピー] をクリックすると、ハイライトされた任意のファイルが、目的の In-Sight ビジョンシステムに貼り付けられるように、Windows のクリップボードに置かれます。
  • [貼り付け]: 切り取りまたはコピーされたデータを、メモリから、アクティブセルに関連するスプレッドシートに書き込みます。ファイルを目的の In-Sight ビジョンシステムまたは任意の Microsoft Windows エクスプローラフォルダ (デスクトップを含む) に書き込みます。

注: 画像ファイルが In-Sight ビジョンシステムに貼り付けられると、そのファイルはアクティブな画像になり、image.bmp で表されます。In-Sight ビジョンシステムは、アクティブでない画像を保存しません。ただし、In-Sight エミュレータは、数に制限なく画像を保存できます (PC のハードディスク容量によってのみ制限されます)。

  • [クリア]: データ、フォーマット、コンテンツ、コメント、およびシンボリックタグをセルから削除します。
    • [すべて]: コメントおよびシンボリックタグを含むすべてのコンテンツとフォーマットを、選択したセルから削除します。
    • [フォーマット]: 項目から、フォーマットのみを削除します。コンテンツおよびコメントは変更されません。
    • [コンテンツ]: セルのフォーマットまたはコメントに影響を与えることなく、選択したセルからセルのコンテンツ (データおよび数式) を削除します。
    • [コメント]: 選択したセルに添付されたコメントのみを削除します。セルのコンテンツおよびフォーマットは変更されません。
    • [シンボリックタグ]: 選択したセルに添付されたシンボリックタグのみを削除します。セルのコンテンツおよびフォーマットは変更されません。
  • [削除]: アクティブであるウィンドウによっては、[削除] を使用してスプレッドシートからファイルまたはセルを削除することができます。[In-Sight のファイル] がアクティブである場合、[削除] によって特定のファイルを削除することができます。スプレッドシートビューがアクティブでスプレッドシートが表示されている場合、[Delete Cells] ダイアログ経由で [削除] を使用して、現在選択されているセルに関連するスプレッドシートからセルを削除します。このオプションを利用するには、少なくとも 1 つのセルがハイライトされている必要があります。削除するセルは、既存のセルを右または下に移行するか、またはセルの列または行全体を削除するかを指定できます。

注: 一部のファイルは In-Sight ビジョンシステムから切り取りまたは削除を実行することができません。また、セル A0 はスプレッドシートから削除することはできません。

  • [検索]: [検索] ダイアログのパラメータを使用して、スプレッドシートで指定したテキスト文字列または数値を検索し、そのテキストまたは数値が含まれる最初のセルを選択します。テキスト文字列または数値が行、列、数式、値またはコメントにあるのか、文字の大文字/小文字、すべてのセルを特定する必要があるのかどうかを指定することにより、検索を最適化することができます。
  • [移動]: [移動] ダイアログによって、特定のセルに直接ジャンプし、そのセルをアクティブセルにすることができます。
  • [セルのグラフィック]: アクティブセル内の関数に、関連する対話型グラフィックスがある場合、対話型グラフィックスモードを呼び出します。それ以外の場合、このメニューオプションは無効になります。
  • [領域の最大化]: セルグラフィックスの領域サイズを、参照している [image] データ構造体の画像領域と同じサイズに変更します。セル A0 は、デフォルトの画像ソースです。アクティブセル内の関数に関連するセルグラフィックスの領域がない場合、このメニューオプションは無効になります。
  • [セル状態]: [セル状態] ダイアログにより、選択したセルを明示的または条件付きのいずれかで有効または無効にすることができます。これにより、各画像取り込みサイクルにおいて、選択したセル内の式を実行するかどうかが決まります。
  • [カスタムビューの設定]: [カスタムビューの設定] ダイアログによって、カスタムビューのプロパティを定義します。複数のセルが選択されている場合、選択された範囲が、新しいカスタムビューのセル範囲として使用されます。

  • [EasyView の設定]: [EasyView の設定] ダイアログを開いて、VisionView のデータの表示方法をカスタマイズします。

  • [HMI ビューの選択]: [HMI ビューの選択] ダイアログを開き、HMI アプリケーションでユーザが確認可能な Run モードビュー、および HMI アプリケーションの [Switch View] ボタンが押されたときにビューの順序を指定します。
Version: 5.6.0


[HMI ビューの選択] ダイアログ

[編集] メニュー

In-Sight ExplorerGUI リファレンス

[HMI ビューの選択] ダイアログでは、ヒューマンマシンインタフェース (HMI) アプリケーションからユーザが表示することのできる [実行モード] ビューと、HMI アプリケーションの [表示切り替え] ボタンを押すときに表示されるビューの順序を指定できます。[HMI ビューの選択] 設定はジョブファイルに保存されます。

注:
  • [現在の画像と最後に FAIL した画像 (水平)] および [現在の画像と最後に FAIL した画像 (垂直)] オプションは、In-Sight Explorer 4.5.0 以降を使用して作成されたジョブファイルに自動的に追加されます。以前のバージョンの In-Sight Explorer を使用してジョブファイルが作成されている場合、これらのオプションが追加されるのは、ジョブに カスタムビューまたは EasyView が含まれていない場合のみです。
  • [現在の画像と最後に FAIL した画像 (水平)]、[現在の画像と最後に FAIL した画像 (垂直)]、および [画像とグラフィックおよびカスタムビュー] の各オプションは、VisionView でのみサポートされています。
  • Web HMI で [実行モード] ビューを切り換えるには、まず [HMI の設定] ダイアログで [ビュー選択の許可] オプションを有効にする必要があります。
  • VisionView で [実行モード] ビューを切り換えるには、まず VisionView の [オペレータコントロール] 画面で [表示切り替え] オプションを有効にする必要があります。

[HMI ビューの選択] ダイアログを表示するには

  • [編集] メニューで、[HMI ビューの選択] を選択します。

[HMI ビューの選択] ダイアログのコントロール

  • [ビュー]: アクティブなジョブファイルで使用可能なすべての Run モードビューのリストを表示します。
    • [画像とグラフィックおよび EasyView]: 画像、ツールグラフィックス、および EasyView を表示します。[画像とグラフィックおよび EasyView] オプションがダイアログに表示されるようにするには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。
    • [画像とグラフィックおよびカスタムビュー] - VisionView のみ: 画像、ツールグラフィックス、およびカスタムビューを表示します。[画像とグラフィックおよびカスタムビュー] オプションがダイアログに表示されるようにするには、まず In-Sight Explorer 内でカスタムビューを作成し、ジョブと一緒に保存する必要があります。
    • [画像のみ]: 画像のみを表示します。
    • [画像とグラフィックス]: 画像とツールグラフィックスを表示します。
    • [現在の画像と最後に FAIL した画像 (水平)] - VisionView のみ: 取り込まれた最新の画像および HMI 表示に送信される最後に取り込みに失敗した検査画像を表示します。画面が半分に分割され、左側に現在の画像、右側に最後に取り込みに失敗した画像が表示されます。
    注:
    • [VisionView Custom View Position] が [As Specified in Job]、[Upper Left]、[Upper Right]、[Lower Left]、[Lower Right] または [Centered] に設定されている場合は、カスタムビューによって現在の画像が上書きされます。
    • フィルムストリップが停止した場合は、現在の画像の代わりにハイライトされたフィルムストリップ画像が表示され、最後に取り込みに失敗した画像は更新されません。
    • [現在の画像と最後に FAIL した画像 (垂直)] - VisionView のみ: 取り込まれた最新の画像および HMI 表示に送信される最後に取り込みに失敗した検査画像を表示します。画面が半分に分割され、上側に現在の画像、下側に最後に取り込みに失敗した画像が表示されます。
    注:
    • [VisionView Custom View Position] が [As Specified in Job]、[Upper Left]、[Upper Right]、[Lower Left]、[Lower Right] または [Centered] に設定されている場合は、カスタムビューによって現在の画像が上書きされます。
    • フィルムストリップが停止した場合は、現在の画像の代わりにハイライトされたフィルムストリップ画像が表示され、最後に取り込みに失敗した画像は更新されません。
    • [EasyView のみ]: EasyView のみを表示します。[EasyView のみ] オプションがダイアログに表示されるようにするには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。
  • [表示]: オンの場合は、対応する [実行モード] ビューを HMI アプリケーションから表示できます。
  • [上へ] および [下へ]: [上へ] および [下へ] ボタンを使用して、Web HMI アプリケーションで [表示切り替え] を押した後のビューの順序を指定します。[上へ] ボタンを押すと、ハイライトされたビューがリストの上側に移動し、[下へ] ボタンを押すと、ハイライトされたビューがリストの下側に移動します。HMI アプリケーションを開くと、[HMI ビューの選択] ダイアログでの最初のビューがデフォルトのビューとして表示されます。

関連項目

Web HMI の設定

カスタムビュー

EasyView の設定

HMI の設定

ウェブブラウザビューを開く

Web HMI 表示

Version: 5.6.0


[表示] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

  • EasyBuilder ビュー
  • スプレッドシートビュー

EasyBuilder ビュー

[表示] メニューを使用すると、EasyBuilder のユーザインタフェースをカスタマイズできます。

注: EasyBuilder ビューがアクティブでないとき、次の [表示] メニューの一部またはすべてが利用できない場合があります。

[表示] メニューの項目

  • [In-Sight のネットワーク]: [In-Sight のネットワーク] ペインの表示/非表示を切り替えます。このペインには、[Explorer のホストテーブル] で定義されているビジョンシステムに加えて、ローカルサブネット上で検出されたすべての In-Sight ビジョンシステムが表示されます。
  • [In-Sight のファイル]: [In-Sight のファイル] ペインの表示/非表示を切り替えます。このペインには、In-Sight ビジョンシステムまたはエミュレータに含まれているファイルが表示されます。ドラッグ & ドロップを使用して、FTP を通して、ネットワーク上の In-Sight ビジョンシステム間でジョブファイル、画像、およびビジョンシステム設定をコピーできます。
  • [パレット]: [パレット] の表示/非表示を切り替えます。ここには[ヘルプ]、[結果]、[I/O] タブが表示されます。
  • [ツールバー]: [標準] ツールバー、[ジョブの表示] ツールバー、および [Explorer] ツールバーの表示/非表示を切り替えます (デフォルトでは、ツールバーは非表示になっています) 。
  • [更新]: [In-Sight のファイル] ペインのファイルリスト、および [接続] ペイントと [In-Sight のネットワーク] ペインのビジョンシステム/エミュレータのリストを更新し、次の項目を反映させます。
    • リモートで保存、名前変更、または削除されたファイルやフォルダ
    • ネットワークとの接続が切断されたビジョンシステムまたはエミュレータ
  • [選択したツールのグラフィックスのみ表示]: 選択されたツールに関連付けられているオーバレイグラフィックスの表示/非表示を切り替えます。
  • [フィードバックの即時表示]: 位置決めツールおよび検査ツールの領域が移動またはサイズ変更された場合の、即時フィードバックの表示/非表示を切り替えます。この項目を有効にすると、領域が移動またはサイズ変更された時、グラフィックスがすぐに更新されます。無効になっている場合、領域が移動またはサイズ変更されても、グラフィックスは更新されません。
  • [テキストサイズ]: グラフィックスオーバレイテキストのスケールを定義します。この設定はすべてのグラフィックスオーバレイテキストに適用されますが、ジョブファイルには保存されません(デフォルト = 画像サイズに合わせる)。
    • [画像サイズに合わせる]: 画像を拡大または縮小すると、グラフィックスオーバレイテキストは画像に合わせてスケーリングされます。
    • [縮小のみ]: 画像を縮小すると、グラフィックスオーバレイテキストのスケールは小さくなります。画像を拡大し、グラフィックスオーバレイテキストがデフォルトのフォントサイズ (9 ポイント) より小さくなると、グラフィックスオーバレイテキストのスケールは、デフォルトのフォントサイズになるまで大きくなります。
    • [固定]: グラフィックスオーバレイテキストのサイズは、画像の倍率レベルに関係なく固定されています。
  • [フィルムストリップ]: フィルムストリップの表示/非表示を切り替えます。ここには PC またはビジョンシステムに格納された画像が表示されます。

  • [フォーカスメトリクス]: 画像のフォーカス得点を判定する際に有用なフォーカスメトリクスの表示/非表示を切り替えます。これは、「シーン」(つまり、その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または画像の領域に含まれる度合を示します。

    注: In-Sight 2000 シリーズのビジョンセンサに接続している場合、フォーカスメトリクスの最小値、最大値、およびフォーカス値は非表示になります。

  • [アプリケーションステップ]: 使用可能な EasyBuilder のアプリケーションステップに移動することができます。
  • [スプレッドシート]: スプレッドシートビューに現在のジョブを表示します。

スプレッドシートビュー

[表示] メニューを使用すると、In-Sight Explorer のユーザインタフェースをカスタマイズできます。

注: スプレッドシートビューがアクティブでないとき、次の [表示] メニューの一部またはすべてが利用できない場合があります。

[表示] メニューの項目

  • [In-Sight のネットワーク]: [In-Sight のネットワーク] ペインの表示/非表示を切り替えます。このペインには、[Explorer のホストテーブル] で定義されているビジョンシステムに加えて、ローカルサブネット上で検出されたすべての In-Sight ビジョンシステムが表示されます。
  • [In-Sight のファイル]: [In-Sight のファイル] ペインの表示/非表示を切り替えます。このペインには、In-Sight ビジョンシステムまたはエミュレータに含まれているファイルが表示されます。ドラッグ & ドロップを使用して、FTP を通して、ネットワーク上の In-Sight ビジョンシステム間でジョブファイル、画像、およびビジョンシステム設定をコピーできます。
  • [パレット]: [パレット] の表示/非表示を切り替えます。ここではビジョンツール、画面表示関数、およびスニペットに、ドラッグ ＆ ドロップでアクセスできます。
  • [スクリプトコンソール出力]: 現在接続されている In-Sight ビジョンシステムまたはエミュレータのすべての Script 関数に対するコンソール出力を表示します。
注:
  • [スクリプトコンソール出力] は、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • パフォーマンスを向上させるには、ビジョンシステムがオンラインのときに [スクリプトコンソール出力] を閉じてください。
  • [ツールバー]: [標準] ツールバー、[フォーマット] ツールバー、[ジョブの表示] ツールバー、[ジョブの編集] ツールバー、[ジョブの監査] ツールバー、[記録/再生] ツールバー、および [Explorer] ツールバーの表示/非表示を切り替えます。
  • [更新]: [In-Sight のネットワーク] および [In-Sight のファイル] ペインを更新し、次の項目を反映させます。
    • リモートで保存、名前変更、または削除されたファイルやフォルダ
    • ネットワークとの接続が切断されたビジョンシステムまたはエミュレータ
  • [カスタムビュー]: スプレッドシートオーバレイの[カスタムビュー] を有効/無効にします。
  • [オーバレイ]: 半透明のスプレッドシートオーバレイの表示/非表示を切り替えます。
  • [グラフィックス]: スプレッドシートの関数に関連付けられているオーバレイグラフィックスの表示/非表示を切り替えます。
  • [テキストサイズ]: グラフィックスオーバレイテキストのスケールを定義します。この設定はスプレッドシート内のすべてのセルに適用されますが、ジョブファイルには保存されません(デフォルト = 画像サイズに合わせる)。

    ヒント: 個々のセルにのみスケール設定を適用し、その設定をジョブファイルに保存するには、[セルのフォーマット] ダイアログを使用します。

    • [画像サイズに合わせる]: 画像を拡大または縮小すると、グラフィックスオーバレイテキストは画像に合わせてスケーリングされます。
    • [縮小のみ]: 画像を縮小すると、グラフィックスオーバレイテキストのスケールは小さくなります。画像を拡大し、グラフィックスオーバレイテキストがデフォルトのフォントサイズ (9 ポイント) より小さくなると、グラフィックスオーバレイテキストのスケールは、デフォルトのフォントサイズになるまで大きくなります。
    • [固定]: グラフィックスオーバレイテキストのサイズは、画像の倍率レベルに関係なく固定されています。
  • [フィルムストリップ]: フィルムストリップの表示/非表示を切り替えます。ここには PC またはビジョンシステムに格納された画像が表示されます。

  • [フォーカスメトリクス]: 画像のフォーカス得点を判定する際に有用なフォーカスメトリクスの表示/非表示を切り替えます。これは、「シーン」(つまり、その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または画像の領域に含まれる度合を示します。

    注: In-Sight 2000 シリーズのビジョンセンサに接続している場合、フォーカスメトリクスの最小値、最大値、およびフォーカス値は非表示になります。

  • [シートズーム]: [シートズーム] ダイアログにアクセスし、スプレッドシートの表示倍率を増減することができます。
  • [ジョブの監査]: ジョブ内のセル依存関係 を表示/非表示にして、アクティブセルの最初のエラー参照元にジャンプします。

    • [依存レベルを上げる]このボタンをクリックすると、トレース矢印の表示がオンになり、表示する依存関係のトレースレベルが 1 段階上がります。いずれかのトレース矢印 (参照元、参照先、およびエラー) を表示するには、このボタンをクリックする必要があります。

    • [依存レベルを下げる]: このボタンをクリックすると、表示する依存関係のトレースレベルが 1 段階下がります。

    • [依存レベルをリセットする]: このボタンをクリックすると、表示されているすべての依存関係が削除されます。

    • [エラーのある依存関係のみ表示]: このボタンをクリックすると、参照元セルにエラーがある依存関係のトレース矢印のみが表示されます。

    • [エラー元セルにジャンプ]: エラー (#ERR) のあるセルでこのボタンをクリックすると、スプレッドシート上でエラーが発生している参照元セルにジャンプし、アクティブセルになります。アクティブセルが、エラーが発生している別のセルに依存していない限りは、このボタンを押しても何も起こりません。

  • [EasyBuilder]: EasyBuilder ビューに現在のジョブを表示します。


In-Sight のネットワーク

[表示] メニュー

In-Sight Explorer GUI リファレンス

[In-Sight のネットワーク] ペインには、サブネット上で自動的に検出されたすべての In-Sight ビジョンシステム、ビジョンセンサおよびエミュレータのほか、[Explorer のホストテーブル] ダイアログに手動で入力されたすべてのホストテーブルが「ツリー」形式で表示されます。[In-Sight のネットワーク] ペインは、複数の In-Sight デバイスを同時に管理するのにとても便利です。

ヒント: In-Sight Explorer をカスタマイズすることによって、[In-Sight のネットワーク] ペインをドッキング表示 (ウィンドウの端に固定) またはフロート表示にしたり、移動したり、サイズを変更したりすることができます。

  • [In-Sight のネットワーク] ペインの表示/非表示
  • [In-Sight のネットワーク] ペインのプロパティ
  • ネットワークの操作
  • 列の表示/非表示
  • トークンを使用したフィルタ操作
  • グループ操作
  • 列を使用したソート操作

[In-Sight のネットワーク] ペインの表示/非表示

  • [表示] メニューで [In-Sight ネットワーク] をクリックします (または、[Explorer] ツールバーの [In-Sight のネットワーク] [image] ボタンをクリックするか、Ctrl+Shift+1 キーを押します)。

[In-Sight のネットワーク] ペインのプロパティ

注:
  • デフォルトでは、[In-Sight のネットワーク] ペインでデバイスをダブルクリックすると、EasyBuilder ビューが開きます。スプレッドシートビューも、一部のビジョンシステムおよびエミュレータで使用できます。[オプション] ダイアログボックスを使用して、スプレッドシートビューをデフォルトにすることができます。
  • In-Sight にログオンして、アクティブなビューを開いているとき、別のユーザが同じデバイスにログオンしても、デバイスのアイコンは「ログオン」状態のままです。
  • SD カードフォルダおよび RAM ディスクフォルダは [In-Sight のファイル] ペインにのみ表示されます。
  • [フィルタ] テキストボックス: In-Sight デバイス (ビジョンシステム、ビジョンセンサ、エミュレータ、ホストテーブル) をフィルタリングします。
  • [適用] ボタン: In-Sight デバイスをフィルタリングするためのトークンを作成します。詳細については、「トークンを使用したフィルタ操作」セクションを参照してください。

列

注: [モデル]、[IP]、[MAC] および/または [バージョン] 列を表示あるいは非表示にして、[In-Sight のネットワーク] ペインをカスタマイズすることができます。詳細については、「列の表示/非表示」セクションを参照してください。

  • [名前]: In-Sight デバイスのホスト名。

    注:

    • In-Sight ビジョンシステムまたはビジョンセンサのホスト名は、[ネットワークの設定] ダイアログで設定できます。ホストテーブルのホスト名は、[Explorer のホストテーブル] ダイアログで設定できます。
    • In-Sight エミュレータは、Microsoft Windows のローカルコンピュータ名をホスト名として使用します。

  • [モデル]: In-Sight デバイスのモデルのタイプです。デフォルトでは、この列は非表示になっています。

    注:

    • これがホストテーブルの場合、「Host Table Entry (ホストテーブルエントリ)」が表示されます。
    • これがエミュレータであり、[オプション] ダイアログの エミュレーションモデルが [標準] に設定されている場合、「PCHOST」が表示されます。これがエミュレータであり、エミュレーションモデルが特定の In-Sight モデルに設定されている場合、「PC-xxxx」(xxxx = モデル番号) が表示されます。例えば、エミュレータモデルが [In-Sight 5705] に設定されている場合、「PC-5705」が表示されます。
  • [IP]: In-Sight デバイスの IP アドレス。デフォルトでは、この列は非表示になっています。
  • [MAC]: In-Sight デバイスの MAC アドレス。デフォルトでは、この列は非表示になっています。
  • [バージョン]: In-Sight デバイスのファームウェアバージョン。デフォルトでは、この列は非表示になっています。

  • アイコン: 各ホストの横にあるアイコンは、デバイスのタイプと、デバイスにログオンしているかどうかを示します。次の表は、In-Sight デバイスの [In-Sight のネットワーク] の各種ステータスアイコンのリストです。

    アイコン

    デバイスのタイプ

            説明

    In-Sight Micro 1000 シリーズまたは In-Sight 8000 シリーズビジョンシステム

            ログオンしていない In-Sight ビジョンシステム。

    In-Sight Micro 1000 シリーズまたは In-Sight 8000 シリーズビジョンシステム

    ログオンしている In-Sight ビジョンシステム。

    In-Sight 2000 シリーズビジョンセンサ | ログオンしていない In-Sight ビジョンセンサ。
    In-Sight 2000 シリーズビジョンセンサ | ログオンしている In-Sight ビジョンセンサ。
    In-Sight 2000 Mini シリーズビジョンセンサ | ログオンしていない In-Sight ビジョンセンサ。
    In-Sight 2000 Mini シリーズビジョンセンサ | ログオンしている In-Sight ビジョンセンサ。

    In-Sight 5000 シリーズビジョンシステム

    ログオンしていない In-Sight ビジョンシステム。

    In-Sight 5000 シリーズビジョンシステム

    ログオンしている In-Sight ビジョンシステム。

    In-Sight 70xx - 74xx シリーズビジョンシステム | ログオンしていない In-Sight ビジョンシステム。
    In-Sight 70xx - 74xx シリーズビジョンシステム | ログオンしている In-Sight ビジョンシステム。
    In-Sight 76xx - 79xx シリーズビジョンシステム | ログオンしていない In-Sight ビジョンシステム。
    In-Sight 76xx - 79xx シリーズビジョンシステム | ログオンしている In-Sight ビジョンシステム。

    In-Sight エミュレータ

    ログオンしていない In-Sight エミュレータ。

    In-Sight エミュレータ

    ログオンしている In-Sight エミュレータ。

ネットワークの操作

[In-Sight のネットワーク] ペインで In-Sight デバイス (ビジョンシステム、ビジョンセンサまたはエミュレータ) をクリックすると、メニューが表示され、以下の操作を実行できます。

  • [表示 EasyBuilder ビュー]: In-Sight デバイスの現在の画像、および EasyBuilder グラフィカルユーザインタフェースの現在のジョブが表示されます。ステータスバーがオンライン/オフラインステータスを示します。

  • [表示 スプレッドシートビュー]: In-Sight ビジョンシステムの現在の画像と半透明のスプレッドシートオーバレイ、またはカスタムビュー (オプション) が表示されます。ステータスバーがオンライン/オフラインステータスを示します。複数のビジョンシステムのスプレッドシートビューを同時に表示することができます。

    注: このオプションは、EasyBuilder 専用のビジョンセンサでは使用できません。

  • [表示 センサのステータスビュー]: センサのステータスビューには、マシンステータススタックを構成するメモリバッファに含まれる情報が表示されます。
  • [ウェブブラウザビューを開く]:[ウェブブラウザビューを開く] により、選択された In-Sight ビジョンシステムまたはセンサの Web ベースのヒューマンマシンインタフェース (HMI) にデフォルトのブラウザが開きます。
  • [貼り付け]: クリップボードにコピーしたジョブファイルを貼り付けします。
  • [レポート作成]: 1 つまたは複数の In-Sight デバイスのジョブおよびネットワーク設定の詳細を含む HTML または XML レポートを作成します。
  • [バックアップ]: そのデバイスのジョブのアーカイブおよび設定データをバックアップディレクトリに保存します。
  • [リストア]: このデバイスのジョブのアーカイブおよび設定データを取得します。

  • [プロパティ]: ハードウェア情報、ネットワーク識別情報、フラッシュ、RAM メモリおよび SD カード構成の詳細を表示します。

    注: SD カード構成は、SD カードが装着された In-Sight ビジョンシステムでのみ表示されます。

  • [Group (グループ化)] または [UnGroup (グループ解除)]: 選択した複数の In-Sight デバイスをグループ化するか、選択したグループを解除します。詳細については、グループ操作をご参照ください。
  • [移動]: 選択した In-Sight デバイスを別のグループに移動します。詳細については、グループ操作をご参照ください。
注:
  • ファイルは、[In-Sight のファイル] ペインと Microsoft Windows エクスプローラのフォルダの両方から [In-Sight のネットワーク] ペイン内の任意のデバイスにドラッグできます。この操作でもファイルがコピーされます。
  • [In-Sight のファイル] ペインまたは Microsoft Windows エクスプローラのフォルダのいずれかから切り取りまたはコピー操作をしても、Windows クリップボードにファイルが配置されます。デバイスを右クリックして [貼り付け] を選択すると、これらのファイルをデバイスに貼り付けることができます。

列の表示/非表示

[モデル]、[IP]、[MAC] および/または [バージョン] 列を表示あるいは非表示にして、[In-Sight のネットワーク] ペインをカスタマイズすることができます。

注: [名前] 列は常に表示され、非表示することはできません。

  1. 任意の列を右クリックします。[列の選択] メニューが表示されます。

  2. 表示するチェックボックスを選択します。
  3. 選択した列が表示されます。
  4. 列を非表示にするには、非表示にするチェックボックスのチェックを外します。

トークンを使用したフィルタ操作

複数の「トークン」を使用して、In-Sight デバイス (ビジョンシステム、ビジョンセンサ、エミュレータおよびホストテーブル) をフィルタリングすることができます。

  1. [フィルタ] テキストボックスにキーワードを入力します。
  2. [適用] をクリックします。[フィルタ] テキストボックスでキーワードは「トークン」として表示されます。
  3. すべてのキーワードが追加されるまで、手順 1 ～ 2 を繰り返します。
  4. フィルタリングされた In-Sight デバイスが表示されます。
  5. [フィルタ] テキストボックスからトークンを削除するには、トークン上で「x」をクリックします。

グループ操作

1 つまたは複数のグループを作成して、In-Sight デバイス (ビジョンシステム、ビジョンセンサ、エミュレータ、ホストテーブル) を整理することができます。

グループの作成

  1. [In-Sight のネットワーク] ペインから 1 つ以上の In-Sight デバイスを選択します。

    ヒント: 順番に並んでいない複数のアイテムをまとめて選択するには、CTRL キーを押したまま各アイテムを順番にハイライトしてください。順番に並んでいる複数のアイテムをまとめて選択するには、SHIFT キーを押したままペインの最初のアイテムをハイライトし、次に最後のアイテムをハイライトしてください。

  2. 選択したデバイスを右クリックして [Group (グループ化)] を選択します。
  3. 選択したデバイスは <新規グループ> という名前のグループに配置されます。

グループ名の変更

  1. 名前を変更するグループを選択します。
  2. グループのテキストを再度クリックするか、F2 キーを押します。
  3. グループの新しい名前を入力して、キーボードの Enter キーを押すか、テキストボックス外をクリックします。
  4. これでグループの名前が変更されます。

グループ解除

  1. グループ解除するグループを右クリックして、[Ungroup (グループ解除)] を選択します。
  2. 選択したグループは [In-Sight のネットワーク] ペインから削除され、グループ内の In-Sight デバイスは、In-Sight センサノードに移動します。

別のグループへの In-Sight デバイスの移動

  1. 別のグループに移動する In-Sight デバイス (ビジョンシステム、ビジョンセンサ、エミュレータ、および/またはホストテーブル) を選択します。

    注: 同時に複数の In-Sight デバイスを移動することもできます。

  2. 選択した In-Sight デバイスを右クリックして [移動] → 目的のグループを選択します。
  3. 選択した In-Sight デバイスが目的のグループに移動します。

列を使用したソート操作

列を使用して、In-Sight デバイス (ビジョンシステム、ビジョンセンサ、エミュレータ、ホストテーブル) を昇順 (デフォルト) または降順でソートすることができます。

  1. ソートする 1 つ以上の列をクリックします。

    注: 複数の列をまとめて選択するには、SHIFT キーを押したまま列をハイライトしてください。

  2. In-Sight ビジョンデバイスは昇順または降順にソートされます。
    • 矢印が非表示の場合、列は昇順にソートされています。
    • 矢印が下向きの場合、列は昇順にソートされています。
    • 矢印が上向きの場合、列は降順にソートされています。
Version: 5.6.0


In-Sight のファイル

[表示] メニュー

In-Sight Explorer GUI リファレンス

[In-Sight のファイル] ペインには 2 種類の情報が表示されます。最初は、[In-Sight のファイル] ペインには、ネットワーク上で検出されたすべての In-Sight ビジョンシステムと、Explorer のホストテーブルにある任意のエントリが表示されます。デバイスをダブルクリックすると、そのデバイスに保存されているファイル、および設定済みで使用可能な RAM ディスクのフォルダと SD カードのフォルダが表示されます。

  • [In-Sight のファイル] ペインを表示/非表示するには
  • [In-Sight のファイル] ペインの使用法
  • 削除不可能なファイル
  • SD カードおよび RAM ディスクのフォルダ

ヒント: In-Sight Explorer をカスタマイズすることによって、[In-Sight のファイル] ペインをドッキング表示 (ウィンドウの端に固定) またはフロート表示にしたり、移動したり、サイズを変更したりすることができます。

[In-Sight のファイル] ペインを表示/非表示するには

  • [表示] メニューで [In-Sight のファイル] をクリックします (または、[Explorer] ツールバーの [In-Sight のファイル] [image] ボタンをクリックするか、Ctrl+Shift+2 キーを押します)。

    注: [In-Sight のファイル] ペインに AAF ファイル (*.aaf) が表示されることがあります。AAF ファイルは、監査メッセージサーバがアクセス不可能な場合に In-Sight フラッシュメモリに保存される監査メッセージです。監査メッセージサーバへの接続が再度確立されると、AAF ファイルは 1 つずつ送信され、監査メッセージサーバの想定される応答が受け取られると、削除されます。

[In-Sight のファイル] ペインの使用法

ドラッグ ＆ ドロップ

ジョブまたは画像ファイルは、[In-Sight のファイル] ペインからスプレッドシート上にドラッグするだけで、In-Sight ビジョンシステムにロードできます。ファイルは、[In-Sight のファイル] ペインと Windows エクスプローラのフォルダの両方から [In-Sight のネットワーク] ペイン内の任意のデバイスにドラッグでき、この操作でファイルがコピーされます。

注:
  • ビジョンシステムのタイトルバーには、アクティブなジョブのビジョンシステム名とファイル名が表示されます。PC からジョブファイルをドラッグ ＆ ドロップした場合、ジョブがビジョンシステムに保存されるまでは、タイトルバーにジョブ名は表示されません。
  • PC からジョブファイルをドラッグ ＆ ドロップすると、ジョブがビジョンシステムに保存されるまでは、[センサのステータス] ビューの現在のジョブには「Drag And Drop Job」が表示されます。
  • [In-Sight のファイル] ペインからジョブファイルをドラッグ ＆ ドロップし、スプレッドシートビューのスクロールバーをクリックしてから、マウスのホイールを使用してスクロールをすると、[スプレッドシート] ペインではなく [In-Sight のファイル] ペインがスクロールされます。スプレッドシートビューをスクロールするには、マウスのホイールではなく矢印またはスライダを使用します。

コピー、削除、名前変更

[In-Sight のファイル] ペインでファイルを右クリックすると、 Closed ファイルをコピー、削除、または名前変更するためのショートカットメニューが表示されます。コピーしたジョブは、ほかの In-Sight ビジョンシステム、エミュレータや SD カードに貼り付けることができます。コピーした画像を貼り付けることもできますが、In-Sight ビジョンシステムでは、貼り付けたファイルは貼り付け先のビジョンシステムのアクティブな画像として image.bmp および image.jpg と置き換えられます。元のファイル名は保持されないので注意してください。

注:
  • image.bmp、image.jpg、image2.bmp および image4.bmp はエミュレータに貼り付けることはできません。

削除不可能なファイル

次の In-Sight システムファイルを削除することはできません。

  • hosts.net: In-Sight のホストテーブルのエントリを含む
  • image.jpg: アクティブな画像
  • image.bmp: アクティブな画像
  • image 2.bmp: アクティブな画像の高さと幅が 1/2 のバージョン (ファームウェアバージョン 2.60 以降)。
  • image 4.bmp: アクティブな画像の高さと幅が 1/4 のバージョン (ファームウェアバージョン 2.60 以降。
  • proc.set: ネットワーク構成およびビジョンシステム設定を含む

画像をファイルとして In-Sight ビジョンシステムにとして格納することはできません。画像ファイル をビジョンシステムの [In-Sight のファイル] ペインまたはアクティブビューにドラッグすると、そのビジョンシステムのアクティブな画像になります。ただし、In-Sight の エミュレータでは、任意のファイル名で画像を格納することができます。

SD カードおよび RAM ディスクのフォルダ

SD カードフォルダ

SD カードがビジョンシステムに搭載されている場合、SD カードフォルダは [In-Sight のファイル] ペインに表示されます。SD カードでは、ジョブ/画像 ([保存] および [開く] ダイアログ) とセルデータ ([セルのエクスポート]、[セルのインポート] ダイアログ、ExportData および ImportData 関数) がサポートされます。

注:
  • SD カードでは、次のダイアログおよび機能はサポートされません。[記録/再生のオプション] および フィルムストリップ。
  • 次のパスを使用して SD カードのファイルにアクセスします。SDCARD/filename.type
  • SNTP サービスが有効化されており、かつ SNTP サーバがネットワーク時刻を取得可能でない限り、SD カード上でファイルが作成された時刻は、正確にはなりません。

RAM ディスクフォルダ

ビジョンシステムまたはエミュレータに、有効化され、設定された RAM ディスクフォルダがある場合、この RAM フォルダは [In-Sight のファイル] ペインに表示されます。詳細については、[RAM ディスクの設定] ダイアログのトピックを参照してください。


パレット

[表示] メニュー

In-Sight Explorer GUI リファレンス

  • EasyBuilder ビュー
  • スプレッドシートビュー

EasyBuilder ビュー

パレットは、以下のタブを介してユーザガイダンスを提供する参照ペインです。

  • [ヘルプ]
  • [結果]
  • [リンク]
  • [I/O]
  • [TestRun]
  • [パレットの表示]

注: EasyBuilder をカスタマイズすることによって、パレットをドッキング表示 (ウィンドウの端に固定) またはフロート表示にしたり、移動したり、サイズを変更したりすることができます。

[ヘルプ] タブ

[ヘルプ] タブは EasyBuilder ヘルプファイルを表示し、現在の [アプリケーションステップ] を反映して更新され、そのステップを完了する方法に関する詳細な手順を表示します。必要に応じて、コントロールやパラメータに関する説明やガイドラインも表示されます。より詳細な説明が記載されているそのほかのヘルプトピックへのリンクが含まれることもあります。

注: EasyBuilder ヘルプファイルは、オンラインヘルプのフォーマットで表示することもできます。F1 キーボードを押すか、[ヘルプ] タブのヘルプ [image] ボタンを押すか、あるいは [ヘルプ] メニューから [EasyBuilder ヘルプ] を選択して、EasyBuilder オンラインヘルプファイルを開きます。

[結果] タブ

[結果] タブには、ジョブ設定のトラブルシューティングや最適化のために必要な、各ツールのパフォーマンスが表示されます。このタブでは次の操作を行うことができます。

  • 結果をモニタすることによって、どのツールが [image] 成功、または [image] 失敗しているかをひと目で判断することができます。これは [位置決め] または [検査] 設定ペインの [設定] または [制限範囲] タブにも表示されます。
  • ツールをクリックして、このツール (オレンジ色でハイライトされているもの) とそのジョブで使用されているそのほかのツールの依存関係を表示し、ツールの不具合がほかのツールの不具合に関係しているかどうかを判断することができます。ツールが別のツールを参照しているときには依存関係が存在します。1 つの依存関係は、参照元と参照先の 2 つの部分から構成されます。これらは線で結ばれています。参照元とはデータのソース (入力を提供するツール) のことで、円で表されます。参照先とはデータのディスティネーション (出力を受け取るツール) のことで、矢印で表されます。青い依存関係グラフィックスは選択したツールが参照先であることを、緑色のグラフィックスは選択したツールが参照元であることを示します。
  • ツールアイコン (例: Presence/Absence Edge、Identification Read Text、Counting Blobs) によって、ツールのタイプを目で見て確認することができます。
  • 名前およびタイプ別にツールを識別することができます。
  • 必要に応じて、ツールをダブルクリックして修正できます。[アプリケーションステップ] ペインは [検査] ステップに戻ります。設定ペインには選択したツールのパラメータ、表示領域にはオーバレイグラフィックスが表示されます。必要に応じて、パラメータまたはグラフィックスを編集します。

また、[結果] タブのツールを右クリックして、編集用ショートメニューを表示することもできます。このメニューの内容は、そのときのアプリケーションステップによって次のように異なります。

  • [位置決め] または [検査] では、右クリックメニューから、選択したツールのコピー、貼り付け、削除、 または、スプレッドシートビューでの編集を行うことができます。
  • そのほかのアプリケーションステップでは、このメニューから、[このツールにジャンプして編集] をクリックして [検査] ステップに戻り、選択したツールを編集したり、 スプレッドシートビューで編集したりすることができます。

[リンク] タブ

注: [リンク] タブは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。

位置決めツールおよび検査ツールをジョブに追加したら、[リンク] タブでそのプロパティ (入力パラメータと出力結果) を結合することができます。[リンク] タブでは、あるツールの出力結果を、別のツールへの入力パラメータとして使用することができます。また、ジョブに現在ロードされているすべての位置決めツールおよび検査ツールがツリービューで表示されます。

ツールのプロパティ (入力パラメータと出力結果) は、シンボリックタグで参照されます。これは、プロパティに含まれる値へのシンボリック参照です。この値は、関連するデータ型を持っています (Action、Floating Point、Integer、String のいずれか)。ツールプロパティは入力および出力プロパティに分けられ、リンクは、出力プロパティから入力プロパティに対してのみ生成することができます。出力プロパティは複数の別々の入力プロパティにリンクすることができますが、入力プロパティがリンクとして受け入れる出力プロパティは 1 つのみです。

[リンク] タブに表示して設定するツールプロパティを選択するには、ツールプロパティを右クリックして [リンクするプロパティを選択] ダイアログを開きます。[リンクするプロパティを選択] ダイアログには、ジョブ内にあるすべてのツールのツリービューリストと、関連する入力および出力両方のすべてのツールプロパティが表示されます。[リンク] タブに表示するツールプロパティをカスタマイズするには、表示するツールプロパティを選択します ([追加]/[削除] ボタンを使用して、複数の選択肢をハイライトさせてから追加または削除します)。

[I/O] タブ

[I/O] タブには、ジョブの入力/出力ラインそれぞれの [image] アクティブ、または [image] 非アクティブステータスが表示されます。ここから、I/O ラインをモニタすることができます。

[TestRun] タブ

[TestRun] タブでは、マシンビジョンの検証テストを作成します。ビジョンの検証は、マシンビジョンアプリケーションが想定されるパラメータの範囲内で動作していることを確認するプロセスです。検証では、ビジョンシステムでテストを実行し、その結果を想定される値と比較します。

パレットの表示

  • [表示] メニューで [パレット] をクリックします (または、[Explorer] ツールバーの [パレット] [image] ボタンをクリックするか、Ctrl+Shift+3 キーを押します)。

スプレッドシートビュー

パレットは、以下のタブを介してユーザガイダンスを提供する参照およびリソースペインです。

  • [関数] タブ
  • [スニペット] タブ
  • [TestRun] タブ
  • パレットの表示
  • パレットの使用

注: In-Sight Explorer をカスタマイズすることによって、パレットをドッキング表示 (ウィンドウの端に固定) またはフロート表示にしたり、移動したり、サイズを変更したりすることができます。

[関数] タブ

[関数] タブには、アクティブな In-Sight ビジョンシステムで使用可能なすべての関数がツリー表示されます。In-Sight 関数へのドラッグ ＆ ドロップによるアクセスができるようになります。

[スニペット] タブ

[スニペット] タブには、PC 上のスニペットフォルダにある使用可能なすべてのスニペットがツリー表示されます。[スニペット] ダイアログを使用して、スニペットを PC にエクスポートすると、そのスニペットが [スニペット] タブに自動的に追加されます。

注: ExportData 関数を使用して、スニペットを PC にエクスポートすることはできません。

[TestRun] タブ

[TestRun] タブでは、マシンビジョンの検証テストを作成します。ビジョンの検証は、マシンビジョンアプリケーションが想定されるパラメータの範囲内で動作していることを確認するプロセスです。TestRun では、ビジョンシステムでテストを実行し、その結果を想定される値と比較します。

パレットの表示

  • [表示] メニューで [パレット] をクリックします (または、[Explorer] ツールバーの [パレット] [image] ボタンをクリックするか、Ctrl+Shift+3 キーを押します)。

パレットの使用

プラスアイコン [image] をクリックして、カテゴリを展開します。この操作によって、そのカテゴリに含まれるすべての関数またはスニペットが表示されます。展開したカテゴリは、マイナスアイコン [image] をクリックすることによって折り畳むことができます。マウスを使用する場合は、パレットからスプレッドシートのセルに関数またはスニペットを直接ドラッグできます。また、関数名やスニペットをダブルクリックすると、それをアクティブセルに挿入することができます。選択した関数にプロパティシートがある場合、関数をセルに挿入すると、そのシートが自動的に開きます。

注:
  • 実行中の操作や開いているダイアログによっては、パレットが使用できない場合があります。パレットを使用できない一般的な例は、次のとおりです。
    • アクティブな In-Sight センサがオンラインになっている。
    • ライブビデオ。
    • プロパティシートが開いている。
    • 対話型グラフィックスを編集中である。
    • セル選択モードになっている。
  • 関数やスニペットをセル A0 に挿入することはできません。
  • セル A0 をスニペットとしてエクスポートすることはできません。
  • 既にデータを含んでいるセルに関数をドラッグ＆ドロップすると、セルが上書きされる前に確認メッセージが表示されます。
  • スニペットは、複数のセルをスプレッドシートに挿入します。既にデータが格納されているセルにスニペットをドラッグ＆ドロップすると、セルがハイライトされて、上書きされる前に確認メッセージが表示されます。


ツールバー

[表示] メニュー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

EasyBuilder には、メニューバーの下に表示される 3 つのツールバーがあり、クリックするだけで、よく使用するタスクを実行することができます。[標準] および [Explorer] ツールバーは、[表示] メニューを使用して表示したり非表示にしたりすることができます。

  • [標準] ツールバー: 一般的なファイル操作を行います。新規ジョブの作成、ジョブファイルを開く/保存、アクティブジョブの印刷、アクティブジョブの印刷プレビュー、ツールやファイルのコピー/貼り付け/削除、元に戻す/やり直しなどを行います。
  • [ジョブの表示] ツールバー: 記録や再生オプションに関連する操作の実行、表示領域内での画像の操作、および画像領域グラフィックスのサイズ変更を行います。画像の記録、再生画像の選択、記録した画像の再生または一時停止、[記録/再生のオプション] ダイアログの表示などが可能です。新しい画像の取り込み、ライブビデオモードへの切り替え、画像の表示倍率の設定、幅に合わせて表示、画像の回転、画像彩度の表示/非表示、グラフィックスオーバレイテキストスケールの指定、フィルムストリップの表示/非表示、アクティブな In-Sight センサのオンラインステータスの切り替えなどが可能です。また、表示領域のサイズに合わせて、画像領域グラフィックスのサイズを変更することもできます。
  • [Explorer] ツールバー: システム全体の操作を行います。[In-Sight のネットワーク] の表示、[In-Sight のファイル] の表示、[パレット] の表示、ログオン/ログオフ、1 つまたは複数の In-Sight センサ/エミュレータについてのレポートの作成、1 つまたは複数の In-Sight センサ/エミュレータ上のファイルのバックアップおよびリストア、[センサ/デバイスをネットワークに追加] ダイアログの表示、In-Sight Explorer のヘルプおよびオンラインサポートへのアクセスなどを行います。
注:
  • ツールバーを移動したり、サイズを変更したりすることで EasyBuilder をカスタマイズできます。
  • 現在の状況で対応する機能を使用できない場合は、アイコンが灰色に表示されます。
  • 個々のツールバーにアイコンを追加したり、削除したりすることができます。ツールバーの右端をクリックし、[追加] または [削除] ボタンメニューを選択してから目的のアイコンを有効または無効にします。
  • [オプション] ダイアログで、大きなアイコンの表示を選択することができます。

[標準] ツールバー:

空白の新規ジョブをアクティブな In-Sight センサにロードします。新規ジョブを作成する前に、変更内容を前のジョブに保存したことを確認してください。

[ジョブを開く] ダイアログを表示します。このダイアログを使用すると、ローカルまたはリモートのジョブファイルをアクティブジョブとして In-Sight センサにロードできます。

アクティブジョブを保存します。ジョブがまだ保存されていない場合、このボタンを押すと、[ジョブに名前を付けて保存] ダイアログが表示されます。ジョブが既に保存されている場合は、ジョブの内容が現在のファイル名に書き込まれます。

[印刷] ダイアログを開きます。現在のジョブの結果テーブルをローカルプリンタまたはネットワーク接続されたプリンタで印刷することができます。

[印刷プレビュー] ウィンドウを開きます。現在のジョブの結果テーブルの印刷プレビューを確認することができます。

EasyBuilder では使用できません。

選択されているツールまたはファイルをクリップボードにコピーします。多くの場合、[貼り付け] と組み合わせて使用されます。

コピーされたツールまたはファイルを貼り付けます。

選択されているツールまたはファイルを削除します。

最後の操作を元に戻します。

最後の操作をやり直します。

[ジョブの表示] ツールバー

再生フォルダに保存されている最初の画像に移動します。
再生フォルダに保存されている前の画像に移動します。
再生フォルダに保存されているすべての画像を再生します。
再生フォルダに保存されている画像の再生を一時停止します。
再生フォルダに保存されている次の画像に移動します。
再生フォルダに保存されている最後の画像に移動します。
取り込んだ画像を記録フォルダに記録します。
記録フォルダへの取り込み画像の記録を停止します。
[記録/再生のオプション] ダイアログを開いて、記録/再生の設定を行います。

注:

  • 再生中に [記録] ボタンをクリックすると、再生中の画像は、[記録/再生のオプション] ダイアログで指定されたソートパラメータに応じて、記録フォルダ、Good フォルダ、または Bad フォルダに記録されます。このとき、再生フォルダ上のファイル名と同じ名前で記録されます。
  • センサがオンラインモードのときに画像の再生ができるようにするには、[画像の設定] ステップの [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。

In-Sight センサから画像を 1 つ取り込みます (手動トリガ)。

連続トリガモードに切り替えます。このモードは、アプリケーションがライブ画像に対して予想どおりに動作することを確認できるように、表示領域に連続して画像を取り込みます。

ライブビデオモードに切り替えます。In-Sight センサから連続的に画像を取り込み、表示領域に表示します。

画像の表示倍率を上げます。

画像の表示倍率を下げます。

表示領域にあわせて画像を表示します。画像は、表示領域内で、画像全体が表示される最大限の大きさに自動調整されます。画像のアスペクト比は維持されます。このため、画像の周囲にグレーの余白が表示される場合があります。

画像を右回りに 90 度回転します。

グレーレベルが [露光過少レベル] 以下の画像内のピクセルを青色でハイライトし、[露光過多レベル] 以上のピクセルを赤色でハイライトします。

[HMI ビューの選択] ダイアログを開き、HMI アプリケーションでユーザが確認可能な Run モードビュー、および HMI アプリケーションの [Switch View] ボタンが押されたときにビューが表示される順序を指定します。

また、表示領域のサイズに合わせて、画像領域グラフィックスのサイズを変更することもできます。このボタンは、関連する領域グラフィックスを持つツールがジョブに含まれ、[位置決め] または [検査] ステップが選択されている場合のみ、選択可能になります。

選択されたツールグラフィックスのみを表示/非表示にします。

画像を拡大または縮小すると、グラフィックスオーバレイテキストは画像に合わせてスケーリングされます。(デフォルト) この設定はすべてのグラフィックスオーバレイテキストに適用されますが、ジョブファイルには保存されません。

画像を縮小すると、グラフィックスオーバレイテキストのスケールは小さくなります。画像を拡大し、グラフィックスオーバレイテキストがデフォルトのフォントサイズ (9 ポイント) より小さくなると、グラフィックスオーバレイテキストのスケールは、デフォルトのフォントサイズになるまで大きくなります。この設定はすべてのグラフィックスオーバレイテキストに適用されますが、ジョブファイルには保存されません

グラフィックスオーバレイテキストのサイズは、画像の倍率レベルに関係なく固定されています。この設定はすべてのグラフィックスオーバレイテキストに適用されますが、ジョブファイルには保存されません

フィルムストリップを表示/非表示にします。
[フォーカスメトリクス] を表示または非表示にします。

アクティブな In-Sight センサのオンライン/オフライン状態を切り替えます。

[Explorer] ツールバー

[In-Sight のネットワーク] ペインを表示します。

[In-Sight のファイル] ペインを表示します。

[パレット] を表示します。

In-Sight センサにログオンする際に使用するユーザ名とパスワードを設定します。

1 つまたは複数の In-Sight センサのジョブおよびネットワーク設定の詳細を含む HTML または XML レポートを作成します。

1 つまたは複数の In-Sight センサのジョブやセンサ設定をバックアップします。

1 つまたは複数の In-Sight センサのジョブやセンサ設定をリストアします。

[センサ/デバイスをネットワークに追加] ダイアログを開きます。

In-Sight Explorer のヘルプにアクセスします。

オンラインサポートにアクセスします。

スプレッドシートビュー

In-Sight Explorer には、メニューバーの下に表示される 7 つのツールバーがあり、クリックするだけで、よく使用するタスクを実行することができます。次のツールバーは、[表示] メニューを使用して表示したり、非表示にしたりすることができます。

  • [標準] ツールバー: 一般的なファイル操作を行います。新規ジョブファイルの作成、ジョブファイルを開くまたは保存する、アクティブシートの印刷、アクティブシートの印刷プレビュー、スプレッドシートのデータやファイルの切り取り/コピー/貼り付け、元に戻すまたはやり直し、スプレッドシート内のテキストの検索などを行います。
  • [フォーマット] ツールバー: スプレッドシートの外観を設定します。フォントのタイプとサイズの選択、太字の設定、斜体の設定、テキストの左揃え、中央揃え、右揃え、小数点以下の桁数の増減、背景色または前景色の追加、セルのフォーマット、フォントサイズの増減、列の幅の設定、行の高さの設定などが可能です。
  • [ジョブの表示] ツールバー: スプレッドシートオーバレイの奥に表示される画像を操作します。新しい画像の取り込み、ライブ取り込みモードへの切り替え、画像の表示倍率の設定、最大のサイズに拡大、倍率 1:1、全体表示、幅に合わせて表示、画像の回転、画像彩度の表示/非表示、スプレッドシートオーバレイの透明度の調整、[カスタムビューの設定] ダイアログを開く、カスタムビューの表示切り替え、[EasyView の設定] ダイアログを開く、スプレッドシートの表示/非表示、オーバレイグラフィックスの表示/非表示、グラフィックスオーバレイテキストスケールの指定、フィルムストリップの表示/非表示、シートの表示倍率の設定、アクティブな In-Sight センサのオンラインステータスの切り替えなどが可能です。
  • [ジョブの編集] ツールバー: スプレッドシート関数に関する操作を行います。スプレッドシートへのセル参照または関数の挿入、セルグラフィックスの編集、セル状態の編集、コメントの挿入、シンボリックタグの挿入、アクティブセルの数式の表示などを行います。
  • [ジョブの監査] ツールバー: ジョブ内の依存関係をグラフィカルに表示します。ジョブ内のセル間の依存関係の表示、依存関係レベルのゼロへのリセット、エラーのあるセルの表示、アクティブセルの最初のエラー (#ERR) 参照元へのジャンプを行います。
  • [記録/再生] ツールバー: 記録および再生オプションに関する操作を行います。画像の記録、再生画像の選択、記録した画像の再生または一時停止、[記録/再生のオプション] ダイアログの表示などが可能です。
  • [Explorer] ツールバー: システム全体の操作を行います。[In-Sight のネットワーク] の表示、[In-Sight のファイル] の表示、[パレット] の表示、ログオン/ログオフ、In-Sight センサについてのレポートの作成、In-Sight センサ上のファイルのバックアップおよびリストア、[センサ/デバイスをネットワークに追加] ダイアログの表示、In-Sight Explorer のヘルプおよびオンラインサポートへのアクセスなどを実行します。
注:
  • スプレッドシートビューがアクティブでないとき、ツールバーの一部が利用できない場合があります。
  • ツールバーを移動したり、サイズを変更したりすることで In-Sight Explorer をカスタマイズできます。
  • 現在の状況で対応する機能を使用できない場合は、アイコンが灰色に表示されます。
  • 個々のツールバーにアイコンを追加したり、削除したりすることができます。
  • [オプション] ダイアログで、大きなアイコンの表示を選択することができます。

[標準] ツールバー:

空白の新規ジョブをアクティブな In-Sight センサにロードします。新規ジョブを作成する前に、変更内容を前のジョブに保存したことを確認してください。

[ジョブを開く] ダイアログを表示します。このダイアログを使用すると、ローカルまたはリモートのジョブファイルをアクティブジョブとして In-Sight センサにロードできます。

アクティブジョブを保存します。ジョブがまだ保存されていない場合、このボタンを押すと、[ジョブに名前を付けて保存] ダイアログが表示されます。ジョブが既に保存されている場合は、ジョブの内容が現在のファイル名に書き込まれます。

[印刷] ダイアログを開きます。現在のスプレッドシートをローカルプリンタまたはネットワーク接続されたプリンタで印刷することができます。

[印刷プレビュー] ウィンドウを開きます。アクティブなスプレッドシートの印刷プレビューを確認できます。

選択したセルを切り取ります。多くの場合、[貼り付け] と組み合わせて使用されます。

選択されているセルまたはファイルをクリップボードにコピーします。多くの場合、[貼り付け] と組み合わせて使用されます。

切り取りまたはコピーされたセルを貼り付けます。

最後の操作を元に戻します。

最後の操作をやり直します。

[検索] ダイアログを開きます。指定したテキスト文字列をスプレッドシートから検索して、そのテキストを含む最初のセルを選択します。

[フォーマット] ツールバー

注: PlotString 関数を含むセルにフォーマットを指定すると、そのセルだけでなくプロットされるテキスト文字列にもフォント、サイズ、スタイルの設定が適用されます。プロットされたテキスト文字列のフォントサイズは画像のズームレベルとともに変化するため、テキストのサイズは画像の表示サイズと比例します。ご使用のアプリケーションにおいてテキストサイズが大きすぎる、または小さすぎる場合、[フォーマット] ツールバーの [フォントサイズ] ドロップダウンメニューを使用して、フォントサイズを変更してください。

フォントを選択します。

フォントサイズを選択します。

テキストを太字にします。

テキストを斜体にします。

テキストをセルの左端に揃えます。

テキストをセルの中央に揃えます。

テキストをセルの右端に揃えます。

小数点以下の桁数を増やします。

小数点以下の桁数を減らします。

背景色を追加します。

注: ColorLabel 関数を含むセルについては、背景色の変更は無視されます。

前景色を追加します。

注: ColorLabel 関数を含むセルについては、前景色の変更は無視されます。

[セルのフォーマット] ダイアログを開いて、選択したセルの数値、配置、フォント、および保護を設定します。

フォントサイズを大きくします。

フォントサイズを小さくします。

[列の幅] ダイアログを開いて、スプレッドシートの 1 列または複数の列の幅を調整します。

[行の高さ] ダイアログを開いて、スプレッドシートの 1 行または複数の行の高さを調整します。

[ジョブの表示] ツールバー

In-Sight センサから画像を 1 つ取り込みます (トリガ)。

ライブビデオモードに切り替えます。In-Sight センサから連続的に画像を取り込み、半透明のスプレッドシートの下に表示します。

背景画像の表示倍率を上げます。

背景画像の表示倍率を下げます。

背景画像の表示倍率を最大まで上げます。

表示倍率を 1:1 に設定します。画像の 1 ピクセルに対して PC ディスプレイの 1 ピクセルで表示します。拡大/縮小の自動調整は実行されません。

ウィンドウ全体に画像が表示されるように自動調整します。画像の周囲に余白は表示されません。このため、ウィンドウの形状によっては画像の一部が表示されない場合があります。

ウィンドウ内に画像全体が表示されるように自動調整します。画像は、スプレッドシートの下で画像全体が表示される最大限の大きさに自動調整されます。画像のアスペクト比は維持されます。このため、画像の周囲にグレーの余白が表示される場合があります。

画像を右回りに 90 度回転します。

グレーレベルが [露光過少レベル] 以下の画像内のピクセルを青色でハイライトし、[露光過多レベル] 以上のピクセルを赤色でハイライトします。

スプレッドシートオーバレイの透明度を上げます。画像はより鮮明になり、スプレッドシートはより透明になります。

スプレッドシートオーバレイの透明度を下げます。画像はより不鮮明になり、スプレッドシートはより不透明になります。

[カスタムビューの設定] ダイアログを開きます。

[カスタムビューの設定] ダイアログでの定義に従って、カスタムビューの表示を切り替えます。

[EasyView の設定] ダイアログを開きます。

[HMI ビューの選択] ダイアログを開き、HMI アプリケーションでユーザが確認可能な Run モードビュー、および HMI アプリケーションの [Switch View] ボタンが押されたときにビューが表示される順序を指定します。

半透明のスプレッドシートオーバレイの表示/非表示を切り替えます。

スプレッドシートの関数に関連付けられているオーバレイグラフィックスの表示/非表示を切り替えます。

画像を拡大または縮小すると、グラフィックスオーバレイテキストは画像に合わせてスケーリングされます。(デフォルト) この設定はスプレッドシート内のすべてのセルに適用されますが、ジョブファイルには保存されません。

画像を縮小すると、グラフィックスオーバレイテキストのスケールは小さくなります。画像を拡大し、グラフィックスオーバレイテキストがデフォルトのフォントサイズ (9 ポイント) より小さくなると、グラフィックスオーバレイテキストのスケールは、デフォルトのフォントサイズになるまで大きくなります。この設定はスプレッドシート内のすべてのセルに適用されますが、ジョブファイルには保存されません

グラフィックスオーバレイテキストのサイズは、画像の倍率レベルに関係なく固定されています。この設定はスプレッドシート内のすべてのセルに適用されますが、ジョブファイルには保存されません

ヒント: 個々のセルにのみスケール設定を適用し、その設定をジョブファイルに保存するには、[セルのフォーマット] ダイアログを使用します。

フィルムストリップを表示/非表示にします。

スプレッドシートの表示倍率を設定します。
[フォーカスメトリクス] を表示または非表示にします。

アクティブな In-Sight センサのオンライン/オフライン状態を切り替えます。

[ジョブの編集] ツールバー

絶対セル参照をアクティブセルに挿入します。

相対セル参照をアクティブセルに挿入します。

[関数の挿入] ダイアログを開いて、関数をアクティブセルに挿入します。プロパティシートを持つ関数がアクティブセルに含まれている場合は、[関数の挿入] ダイアログの代わりにプロパティシートが開きます。

対話型グラフィックスモードに切り替えて、セルグラフィックスを編集します。このボタンは、関連するセルグラフィックスを持つ関数がアクティブセルに含まれている場合にのみ使用できます。

領域グラフィックスのサイズを、参照している [image] データ構造体の画像領域と同じサイズに変更します。セル A0 は、デフォルトの画像ソースです。このボタンは、関連する領域セルグラフィックスを持つ関数がアクティブセルに含まれている場合にのみ使用できます。

[セル状態] ダイアログを開いて、セルの実行を明示的に有効または無効にしたり、参照セルの値に基づいて条件付きで有効または無効にしたりします。

[コメントの編集] ダイアログを開いて、アクティブセルのコメントを追加したり、編集したりします。

シンボリックタグエディタを開いて、アクティブセルに新しいシンボリックタグを挿入したり、既存のシンボリックタグを編集したりします。

現在の変更を確定します。

現在の変更をキャンセルして、変更前の値に戻します。

スプレッドシートの数式、値、またはラベルをアクティブセルに入力します。

[ジョブの監査] ツールバー

トレース矢印の表示を ON にして、表示する依存関係のトレースレベルを 1 段階上げます。

表示する依存関係のトレースレベルを 1 段階減らします。

トレース矢印をすべて消去します。

参照元セルがエラー (#ERR) の依存関係のみを表示します。

アクティブセルの最初の #ERR 参照元にジャンプします。

[記録/再生] ツールバー

記録中:

再生中:

再生フォルダに保存されている最初の画像に移動します。

再生フォルダに保存されている前の画像に移動します。

再生フォルダに保存されているすべての画像を再生します。

再生フォルダに保存されている画像の再生を一時停止します。

再生フォルダに保存されている次の画像に移動します。

再生フォルダに保存されている最後の画像に移動します。

取り込んだ画像を記録フォルダに記録します。

記録フォルダへの取り込み画像の記録を停止します。

[記録/再生のオプション] ダイアログを開いて、記録/再生の設定を行います。

注:
  • 再生中に [記録] ボタンをクリックすると、再生中の画像は、[監視セルによる振り分け] の設定に応じて、記録フォルダ、Good フォルダ、または Bad フォルダに記録されます。このとき、再生フォルダ上のファイル名と同じ名前で記録されます。
  • センサがオンラインモードのときに画像の再生ができるようにするには、AcquireImage 関数の [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。

[Explorer] ツールバー

[In-Sight のネットワーク] ペインを表示します。

[In-Sight のファイル] ペインを表示します。

[パレット] を表示します。

In-Sight センサにログオンする際に使用するユーザ名とパスワードを設定します。

1 つまたは複数の In-Sight センサのジョブおよびネットワーク設定の詳細を含む HTML または XML レポートを作成します。

1 つまたは複数の In-Sight センサのジョブファイルおよび設定データをバックアップします。

1 つまたは複数の In-Sight センサのジョブファイルおよび設定データをリストアします。

[センサ/デバイスをネットワークに追加] ダイアログを開きます。

In-Sight Explorer のヘルプにアクセスします。

オンラインサポートにアクセスします。


フィルムストリップ

[表示] メニュー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

フィルムストリップを使用して、PC に記録された画像の再生や、ビジョンシステムに保存された画像や結果の確認を行うことができます。

PC フィルムストリップ

センサフィルムストリップ

フィルムストリップを表示するには

  • [表示] メニューで [フィルムストリップ] をクリックします (または、EasyBuilder ツールバーの [フィルムストリップ] ボタン [image] をクリックします)。

PC フィルムストリップ

[記録/再生のオプション] ダイアログの設定が終わると、[記録] ボタンが押されて画像が取り込まれたときに、成功画像と失敗画像が記録されて PC に保存されます。オンラインまたはオフラインのビジョンシステムから、PC 上で「書き込み」権限のある任意のフォルダに画像を保存することができます。PC の再生モードを使用して、記録された画像を再生することができます。この場合、画像はビジョンシステムに送信され、再生されている画像に対してジョブが実行されます。PC に保存できる画像の数は最大 10,000 です。

注:
  • 画像は、ビジョンシステムがオンライン、またはオフラインである場合に記録できます。
  • ビジョンシステムがオンラインモードのときに画像を再生できるようにするには、[画像の設定] アプリケーションステップの [トリガ] パラメータが、[外部]、[手動]、または [ネットワーク] に設定されている必要があります。
  • フィルムストリップでは、ビジョンシステムに装着された SD カードへの画像の保存はサポートされません。

PC フィルムストリップのコントロール

フィルムストリップのインジケータ
 | 黄色のハイライトは、フィルムストリップで現在選択されている画像を示します。緑色の矩形は、フィルムストリップに現在表示されている結果の部分を示します。
ナビゲーションボタン
 | 再生フォルダに保存されている最初の画像に移動します。
 | 再生フォルダに保存されている前の画像に移動します。
 | 再生フォルダに保存されている次の画像に移動します。
 | 再生フォルダに保存されている最後の画像に移動します。
 | 再生フォルダに保存されているすべての画像を再生します。
 | 再生フォルダに保存されている画像の再生を一時停止します。

PC フィルムストリップの使用

この手順を使用して成功画像と失敗画像を記録し、元になる良好画像と不良画像のセットを作成します。再生フォルダの場所を指定してこれらの画像を PC フィルムストリップで再生し、画像に対してジョブを再度実行することができます。

記録の設定

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの記録に関する設定を行うことができます。

  1. [画像の設定] アプリケーションステップで、[画像取り込み/ロード] グループボックスの [PC から画像をロード] をクリックします。
  2. 表示される [記録/再生のオプション] ダイアログで [記録] タブをクリックし、記録の設定を行います。
  3. 成功画像と失敗画像を自動的に振り分けるには、[Pass/Fail の振り分け] 条件の [Pass/Fail に応じて画像を Good/Bad フォルダに振り分ける] を選択します。
  4. ほかのすべての記録設定を指定したら、[OK] をクリックして [記録/再生のオプション] ダイアログを閉じます。成功画像と失敗画像が記録されると、指定した記録フォルダの場所に「Good」および「Bad」フォルダが自動的に作成されます。

画像の記録

  1. フィルムストリップの [PC] ボタンをクリックします。

  2. EasyBuilder ツールバーの [記録] ボタンをクリックします。

    注: 画像は、ビジョンシステムがオンライン、またはオフラインである場合に記録できます。

  3. ビジョンシステムで画像取り込みをトリガします。画像が取り込まれると、成功画像を Good フォルダに失敗画像を Bad フォルダに自動的に振り分けて保存します。
  4. 再度 [記録] ボタンをクリックすると記録が停止します。
  5. PC から手動で記録フォルダに移動します。画像が Good と Bad の両方またはどちらかに保存されていることを確認します。

再生の設定

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの再生に関する設定を行うことができます。

  1. [フィルムストリップ] アプリケーションステップで、[PC の設定] グループボックスの [再生] をクリックします。
  2. [記録/再生のオプション] ダイアログで [再生] タブをクリックし、再生の設定を行います。

  3. 成功画像のみを再生するには、[再生フォルダ] フィールドで自動的に作成された Good フォルダを指定します。失敗画像のみを再生するには、[再生フォルダ] フィールドで自動的に作成された Bad フォルダを指定します。

    ヒント: デフォルトでは、再生フォルダは EasyBuilder Sample Jobs フォルダを参照します。EasyBuilder サンプルジョブには、[記録/再生のオプション] の有用性を示した例も用意されています。[記録/再生のオプション] によって、あらかじめ取り込んでおいた複数の画像を繰り返し使用できるようになり、ツールの結果を即座にフィードバックし、しきい値や制限を簡単に設定できるようになります。

  4. ほかのすべての再生設定を指定したら、[OK] をクリックして [記録/再生のオプション] ダイアログを閉じます。

画像の再生

  1. フィルムストリップの [PC] ボタンをクリックします。
  2. [画像の設定] アプリケーションステップの [トリガ] パラメータが [カメラ] または [連続] に設定されている場合は、ビジョンシステムをオフラインにして画像を再生します。[トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている場合は、ビジョンシステムをオンラインにしたままで画像を再生することができます。
  3. フィルムストリップの [再生] ボタンをクリックして画像を再生するか、またはナビゲーションボタンをクリックして手動で画像を順に表示します。

  4. [ジョブの実行] アプリケーションステップに移動して、結果テーブルを表示します (または、[パレット] の [結果] タブをクリックします)。

センサフィルムストリップ

ビジョンシステムをオンラインにして画像を取り込んだ場合は、センサフィルムストリップを使用してジョブの実行をモニタすることができます。画像が取得されると、取り込んだ画像および付随するジョブデータを含む、ジョブの結果がビジョンシステムの RAM に保存されます。結果がビジョンシステムに保存されると、PASS または FAIL 画像がフィルムストリップに追加されます。フィルムストリップの結果をハイライトすると、フィルムストリップの表示がグラフィックスからサムネイル画像に変わり、対応する画像が表示領域にロードされます。[フィルムストリップ] アプリケーションステップの [センサの設定] グループボックスにあるコントロールを使用して、ビジョンシステムの動作を設定します。最大 20 の結果を保存することができますが、その数はビジョンシステムの解像度および RAM 空き容量によります。

注:
  • 結果をフィルムストリップに追加するためには、ビジョンシステムがオンラインである必要があります。
  • センサフィルムストリップを有効にすると、ジョブの実行時間が長くなることがあります。実行時間の許容範囲を確認してください。
  • ビジョンシステムが、使用可能な最大画像バッファ数を使用し、オンラインのときにセンサフィルムストリップを使用するように設定されている場合は、フィルムストリップ画像をビジョンシステムに保存するために必要なメモリが十分でない可能性があります。この場合、画像バッファの数を最大値より少なくします。
  • [センサの設定] グループボックスの [キュー]、[キューのサイズ]、または [キューのタイプ] 設定を変更したり、新規ジョブをロードしたり、ビジョンシステムの電源を入れ直したりすると、結果はすべてビジョンシステムから削除されます。
  • 使用できる RAM が不足して決められた数の結果を保存できない場合、ビジョンシステムは自動的にキューサイズを調節します。ただし、[センサの設定] グループボックスの [キューのサイズ] 設定は変更されません。
  • フィルムストリップでは、ビジョンシステムに装着された SD カードへの画像の保存はサポートされません。

センサフィルムストリップのコントロール

結果インジケータ
 | 結果インジケータは、各結果のステータスを示します。黄色のハイライトは、フィルムストリップで現在選択されている結果を示します。黒色の矩形は、フィルムストリップに現在表示されている結果の部分を示します。
ナビゲーションボタン
 | フィルムストリップの最初の画像に移動して、その画像に付随する結果を結果テーブルと [パレット] の [結果] タブに表示します。
 | フィルムストリップの前の画像に移動して、その画像に付随する結果を結果テーブルと [パレット] の [結果] タブに表示します。
 | フィルムストリップの次の画像に移動して、その画像に付随する結果を結果テーブルと [パレット] の [結果] タブに表示します。
 | フィルムストリップの最後の画像に移動して、その画像に付随する結果を結果テーブルと [パレット] の [結果] タブに表示します。
 | フィルムストリップで成功結果の表示を切り替えます。 [センサフィルムストリップ] ダイアログ内の [キュー] ドロップダウンの [成功/失敗結果を分ける] が選択されている場合のみ、このボタンは表示されます。
 | フィルムストリップで失敗結果の表示を切り替えます。 [センサフィルムストリップ] ダイアログ内の [キュー] ドロップダウンの [成功/失敗結果を分ける] が選択されている場合のみ、このボタンは表示されます。
 | クリックして、結果を確認します。
 | クリックして、更新を再開します。
 | クリックして、フィルムストリップ画像を指定された保存フォルダに保存します。PC 上の「書き込み」権限を持つフォルダならどれにでも画像を保存することができます。また、PC 再生モードを使用して、画像を確認することもできます。
 | キューをクリアします。

センサフィルムストリップの使用

センサの設定

  1. [フィルムストリップ] アプリケーションステップ の [センサの設定] グループボックスで設定を行います。

ビジョンシステムの結果のモニタ

  1. EasyBuilder ツールバーで [オンライン] ボタンをクリックして、ビジョンシステムをオンラインにします。

  2. ビジョンシステムで画像取り込みをトリガします。画像が取り込まれると、画像は、[センサの設定] グループボックスで指定したキューの設定に従ってビジョンシステムに保存され、フィルムストリップに表示されます。

  3. フィルムストリップに、成功/失敗の結果を表す状態グラフィックスが更新されて表示されます。次の場合、ビジョンシステムはオンラインのままですが、フィルムストリップは更新を停止して「停止」モードに切り替わります (表示領域の上部に黄色のバーで表示されます)。
    • 結果が失敗ステータスを受信し、[センサの設定] グループボックスで [失敗時に停止] が指定されている場合。
    • 結果が失敗ステータスを受信し、[センサの設定] グループボックスで [失敗時に一時停止] が指定されている場合。

    • 成功/失敗を示すグラフィックスが選択されているか、ナビゲーションボタンがクリックされたか、または [停止] ボタンがクリックされた場合。

      注: オンライン中にフィルムストリップが更新を中止しても、ジョブは実行を続行しますが、表示領域は更新されません。

      「停止」モードでは、フィルストリップ内の結果間を移動するか、またはビジョンシステムから PC に画像を保存することができます。ジョブのパラメータを誤って編集してしまうのを防ぐために、すべてのアプリケーションステップは、薄く表示されたり、グレーアウトされたりします。その間、ジョブは引き続き実行されますが、キューには何も追加されません。次のいずれかの場合、フィルムストリップは更新を再開し、すべてのアプリケーションステップが有効になります。

      • 指定した [一時停止ディレイ] 時間が経過した場合。
      • [再開] ボタンがクリックされた場合。
      • [キューのクリア] ボタンがクリックされた場合。

  4. 結果のモニタが終了したら、ツールバーの [オンライン] ボタンを再度クリックし、ビジョンシステムをオフラインにします。ビジョンシステムがオフラインのときは、フィルムストリップに新しい結果は追加されません。フィルムストリップで成功または失敗を示す既存のグラフィックスが選択されている場合、保存されている画像は表示領域にロードされ、ステップがすべて無効化されます。[再開] または [キューのクリア] ボタンをクリックすると、標準のオフラインモードに戻ります。

ビジョンシステムから PC への画像の保存

オンラインまたはオフラインのビジョンシステムから、PC 上で「書き込み」権限のある任意のフォルダに画像を保存することができます。

以下の手順に従って、保存フォルダを確認します。

  1. ビジョンシステムがオフラインであることを確認します。
  2. [保存フォルダ] フィールドの横の [参照] ボタンをクリックします。
  3. [フォルダの参照] ダイアログで保存先のフォルダを指定し、[OK] をクリックします。選択したフォルダのパスが、[保存フォルダ] フィールドに表示されます。

以下の手順に従って、オンラインまたはオフラインのビジョンシステムから PC に画像を保存します。

  1. フィルムストリップ内の結果を選択するか、または [停止] ボタンをクリックして「停止」モードに切り替えます。このモードに切り替えると、表示領域の上部に黄色のバーで表示されます。ジョブのパラメータを誤って編集してしまうのを防ぐために、すべてのアプリケーションステップは、薄く表示されたり、グレーアウトされたりします。その間、ジョブは引き続き実行されますが、キューには何も追加されません。
  2. フィルムストリップの [画像の保存] ボタンをクリックします。
  3. 画像を保存先フォルダに追加するには、[再開] ボタンまたは [キューのクリア] ボタンをクリックして「停止」モードを終了し、別の結果をキューに追加することを許可して、手順 1 と 2 を繰り返します。

スプレッドシートビュー

フィルムストリップを使用して、PC に記録された画像の再生や、ビジョンシステムに保存された画像や結果の確認を行うことができます。

PC フィルムストリップ

センサフィルムストリップ

フィルムストリップを表示するには

  • [表示] メニューで [フィルムストリップ] をクリックします (または、[ジョブの表示] ツールバーの [フィルムストリップ] ボタン [image] をクリックします)。

PC フィルムストリップ

[記録/再生のオプション] ダイアログの設定が終わると、[記録] ボタンが押されて画像が取り込まれたときに、成功画像と失敗画像が記録されて PC に保存されます。オンラインまたはオフラインのビジョンシステムから、PC 上で「書き込み」権限のある任意のフォルダに画像を保存することができます。PC の再生モードを使用して、記録された画像を再生することができます。この場合、画像はビジョンシステムに送信され、再生されている画像に対してジョブが実行されます。PC に保存できる画像の数は最大 10,000 です。

注:
  • 画像は、ビジョンシステムがオンライン、またはオフラインである場合に記録できます。
  • ビジョンシステムがオンラインのときに画像を再生できるようにするには、AcquireImage 関数の [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。
  • フィルムストリップでは、ビジョンシステムに装着された SD カードはサポートされません。

PC フィルムストリップのコントロール

フィルムストリップのインジケータ
 | 黄色のハイライトは、フィルムストリップで現在選択されている画像を示します。緑色の矩形は、フィルムストリップに現在表示されている結果の部分を示します。
ナビゲーションボタン
 | 再生フォルダに保存されている最初の画像に移動します。
 | 再生フォルダに保存されている前の画像に移動します。
 | 再生フォルダに保存されている次の画像に移動します。
 | 再生フォルダに保存されている最後の画像に移動します。
 | 再生フォルダに保存されているすべての画像を再生します。
 | 再生フォルダに保存されている画像の再生を一時停止します。

PC フィルムストリップの使用

この手順を使用して成功画像と失敗画像を記録し、元になる良好画像と不良画像のセットを作成します。再生フォルダの場所を指定してこれらの画像を PC フィルムストリップで再生し、画像に対してジョブを再度実行することができます。

記録/再生の設定

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの記録/再生の設定を行うことができます。

  1. [記録/再生のオプション] ダイアログを開きます。
  2. [記録] タブをクリックして、記録の設定を行います。
  3. 成功画像と失敗画像を自動的に振り分けるには、[監視セルによる振り分け] のオプションから [監視セルの値に応じて Good/Bad フォルダに振り分ける] を選択します。成功画像と失敗画像が記録されると、指定した記録フォルダ内に自動的に「Good」および「Bad」フォルダが作成されます。
  4. [再生] タブをクリックして、再生の設定を行います。
  5. 成功画像のみを再生するには、[再生フォルダ] フィールドで自動的に作成された Good フォルダを指定します。失敗画像のみを再生するには、[再生フォルダ] フィールドで自動的に作成された Bad フォルダを指定します。
  6. ほかのすべての記録/再生の設定を指定したら、[OK] をクリックして [記録/再生のオプション] ダイアログを閉じます。

画像の記録

  1. フィルムストリップの [PC] ボタンをクリックします。
  2. [記録/再生] ツールバーの [記録] ボタンをクリックします。

注: 画像は、ビジョンシステムがオンライン、またはオフラインである場合に記録できます。

  3. ビジョンシステムで画像取り込みをトリガします。画像が取り込まれると、成功画像を Good フォルダに失敗画像を Bad フォルダに自動的に振り分けて保存します。
  4. 再度 [記録] ボタンをクリックすると記録が停止します。
  5. PC から手動で記録フォルダに移動します。画像が Good と Bad の両方またはどちらかに保存されていることを確認します。

画像の再生

  1. フィルムストリップの [PC] ボタンをクリックします。
  2. AcquireImage 関数の [トリガ] パラメータが [カメラ] または [連続] に設定されている場合は、ビジョンシステムをオフラインにして画像を再生します。[トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている場合は、ビジョンシステムをオンラインにしたままで画像を再生することができます。
  3. フィルムストリップの [再生] ボタンをクリックして画像を再生するか、またはナビゲーションボタンをクリックして手動で画像を順に表示します。

センサフィルムストリップ

ビジョンシステムをオンラインにして画像を取り込んだ場合は、センサフィルムストリップを使用してジョブの実行をモニタすることができます。画像が取得されると、取り込んだ画像および付随するジョブデータを含む、ジョブの結果がビジョンシステムの RAM に保存されます。結果がビジョンシステムに保存されると、PASS または FAIL 画像がフィルムストリップに追加されます。フィルムストリップの結果をハイライトすると、フィルムストリップの表示がグラフィックスからサムネイル画像に変わり、対応する画像が表示領域にロードされます。[フィルムストリップ] アプリケーションステップの [センサの設定] グループボックスにあるコントロールを使用して、ビジョンシステムの動作を設定します。最大 20 の結果を保存することができますが、その数はビジョンシステムの解像度および RAM 空き容量によります。

注:
  • 結果をフィルムストリップに追加するためには、ビジョンシステムがオンラインである必要があります。
  • センサフィルムストリップを有効にすると、ジョブの実行時間が長くなることがあります。実行時間の許容範囲を確認してください。
  • ビジョンシステムが、使用可能な最大画像バッファ数を使用し、オンラインのときにセンサフィルムストリップを使用するように設定されている場合は、フィルムストリップ画像をビジョンシステムに保存するために必要なメモリが十分でない可能性があります。この場合、画像バッファの数を最大値より少なくします。
  • 画像ツール関数を使用して出力された画像は、ビジョンシステムに保存されません。
  • [キュー]、[キューのサイズ]、または [キューのタイプ] 設定を変更したり、新規ジョブをロードしたり、ビジョンシステムの電源を入れ直したりすると、結果はすべてビジョンシステムから削除されます。
  • メモリが不足して決められた数の結果を保存できない場合、ビジョンシステムは自動的に [キューのサイズ] を調整します。フィルムストリップの [センサの設定] ダイアログの [キューのサイズ] 設定は変更されません。
  • フィルムストリップでは、ビジョンシステムに装着された SD カードはサポートされません。

センサフィルムストリップのコントロール

結果インジケータ
 | 結果インジケータは、各結果のステータスを示します。黄色のハイライトは、フィルムストリップで現在選択されている結果を示します。黒色の矩形は、フィルムストリップに現在表示されている結果の部分を示します。
ナビゲーションボタン
 | フィルムストリップの最初の画像に移動して、その画像に付随する結果を表示します。
 | フィルムストリップの前の画像に移動して、その画像に付随する結果を表示します。
 | フィルムストリップの次の画像に移動して、その画像に付随する結果を表示します。
 | フィルムストリップの最後の画像に移動して、その画像に付随する結果を表示します。
 | フィルムストリップで成功結果の表示を切り替えます。 [センサフィルムストリップ] ダイアログ内の [キュー] ドロップダウンの [成功/失敗結果を分ける] が選択されている場合のみ、このボタンは表示されます。
 | フィルムストリップで失敗結果の表示を切り替えます。 [センサフィルムストリップ] ダイアログ内の [キュー] ドロップダウンの [成功/失敗結果を分ける] が選択されている場合のみ、このボタンは表示されます。
 | クリックして、結果を確認します。
 | クリックして、更新を再開します。
 | クリックして、フィルムストリップ画像を指定された保存フォルダに保存します。PC 上の「書き込み」権限を持つフォルダならどれにでも画像を保存することができます。また、PC 再生モードを使用して、画像を確認することもできます。
 | キューをクリアします。

センサフィルムストリップの使用

センサの設定

  1. フィルムストリップの [センサの設定] ダイアログを開きます。
  2. フィルムストリップを設定します。

ビジョンシステムの結果のモニタ

  1. [ジョブの表示] ツールバーの [オンライン] ボタンをクリックして、ビジョンシステムをオンラインにします。
  2. ビジョンシステムで画像取り込みをトリガします。画像が取り込まれると、画像はフィルムストリップの [センサの設定] ダイアログで指定した キューの設定に従ってビジョンシステムに保存され、フィルムストリップに表示されます。

  3. フィルムストリップに、成功/失敗の結果を表す状態グラフィックスが更新されて表示されます。次の場合、ビジョンシステムはオンラインのままですが、フィルムストリップは更新を停止して「停止」モードに切り替わります (表示領域の上部に黄色のバーで表示されます)。
  • 結果が失敗ステータスを受信し、 フィルムストリップの [センサの設定] ダイアログで [失敗時に停止] が指定されている場合。
  • 結果が失敗ステータスを受信し、フィルムストリップの [センサの設定] ダイアログで [失敗時に一時停止] が指定されている場合。

  • 成功/失敗を示すグラフィックスが選択されているか、ナビゲーションボタンがクリックされたか、または [停止] ボタンがクリックされた場合。

注: オンライン中にフィルムストリップが更新を中止しても、ジョブは実行を続行しますが、表示領域は更新されません。

「停止」モードでは、フィルストリップ内の結果間を移動するか、またはビジョンシステムから PC に画像を保存することができます。保存された画像とスプレッドシートの結果が表示にロードされ、スプレッドシートは読み取り専用になります。その間、ジョブは引き続き実行されますが、キューには何も追加されません。次のいずれかの場合、フィルムストリップは更新を再開します。

  • 指定した [一時停止ディレイ] 時間が経過した場合。
  • [再開] ボタンがクリックされた場合。
  • [キューのクリア] ボタンがクリックされた場合。
  4. 結果のモニタが終了したら、ツールバーの [オンライン] ボタンを再度クリックし、ビジョンシステムをオフラインにします。ビジョンシステムがオフラインのときは、フィルムストリップに新しい結果は追加されません。成功/失敗を示す既存のグラフィックスを選択すると、キューに保存された画像とスプレッドシートの結果がディスプレイ部分にロードされ、スプレッドシートは読み取り専用になります。[再開] ボタンをクリックすると、標準のオフライン操作モードに戻ります。

ビジョンシステムから PC への画像の保存

オンラインまたはオフラインのビジョンシステムから、PC 上で「書き込み」権限のある任意のフォルダに画像を保存することができます。

以下の手順に従って、保存フォルダを確認します。

  1. ビジョンシステムがオフラインであることを確認します。
  2. フィルムストリップの [センサの設定] ダイアログを開き、[保存フォルダ] フィールドの横の [参照] ボタンをクリックします。
  3. [フォルダの参照] ダイアログで保存先のフォルダを指定し、[OK] をクリックします。選択したフォルダのパスが、[保存フォルダ] フィールドに表示されます。
  4. [OK] をクリックして、フィルムストリップの [センサの設定] ダイアログを閉じます。

以下の手順に従って、オンラインまたはオフラインのセンサから PC に画像を保存します。

  1. フィルムストリップ内の結果を選択するか、または [停止] ボタンをクリックして「停止」モードに切り替えます。このモードに切り替えると、表示領域の上部に黄色のバーで表示されます。保存された画像とスプレッドシートの結果が表示にロードされ、スプレッドシートは読み取り専用になります。その間、ジョブは引き続き実行されますが、キューには何も追加されません。
  2. フィルムストリップの [画像の保存] ボタンをクリックします。
  3. 画像を保存先フォルダに追加するには、[再開] ボタンまたは [キューのクリア] ボタンをクリックして「停止」モードを終了し、別の結果をキューに追加することを許可して、手順 1 と 2 を繰り返します。
Version: 5.6.0


アプリケーションステップ

EasyBuilder GUI リファレンス

[アプリケーションステップ] ペインからは、EasyBuilder のどのステップにも 1 クリックで簡単にアクセスできます。[アプリケーションステップ] は、ジョブの構築に一般的に使用される順序で表示されます。ジョブの構築後、これらのステップには任意の順序で再アクセスできるので、目的の結果が得られるまで、ジョブパラメータを変更したり、微調整したりすることが可能です。

アクセスレベル、実行中のタスク、接続先がセンサかエミュレータか、In-Sight センサがオンラインかどうかなどによっては、[アプリケーションステップ] がグレーアウトされることがあります。

注: [アプリケーションステップ] ペインを移動またはサイズ変更して、EasyBuilder をカスタマイズすることができます。

アプリケーションステップの使用

ジョブパラメータを設定するには、目的のステップをクリックして、その設定ペインにアクセスします。ここでは、各ステップについて簡単に説明します。

  • [接続]: In-Sight センサまたはエミュレータに接続し、既存の EasyBuilder ジョブを開くか、新規ジョブを開始します。
  • [画像の設定]: 画像を取り込み、またはロードして、取り込み設定を調整し、実世界の単位に画像をキャリブレーションします。
  • [位置決め]: 位置決めツールをジョブに追加し設定して、フィクスチャを生成します。フィクスチャは、そのほかのビジョン検査ツールの原点となる基準点を定義するビジョン検査ツールです。
  • [検査]: 製品の検査ツールをジョブに追加し設定して、画像解析基準に基づいて製品を検査し、品質や数量を確認します。
  • [入力/出力]: 入力ライン名のカスタマイズ、信号タイプの設定、信号のエッジ遷移の選択、強制的な入出力によるアプリケーションのテストを行うことによって、サポートされている Cognex 製 I/O モジュールのディスクリート入出力ラインの設定を定義します。
  • [通信]: VisionView 用に EasyView を設定し、In-Sight センサのネットワークおよびシリアル通信の設定値を定義して、センサがロボットや PLC などのほかのデバイスとデータをやり取りできるようにするため、オープンデータアクセスおよび交換 (OPC) の検査結果を定義します。
  • [フィルムストリップ]: 取得された画像を、センサまたは PC から確認するためのフィルムストリップ設定を行います。
  • [ジョブの保存]: センサがオフラインのときに、さまざまなファイル管理タスクやセンサ保守タスクを行います。

注: [ユーザ] ダイアログの [オンライン時にジョブ保存] チェックボックスがオンの場合、オンラインでは、フルまたはプロテクトレベルのアクセス権を持つユーザだけがジョブを保存できます。

  • [ジョブの実行]: ジョブを実行し、結果を確認して、必要に応じて設定を変更またはトラブルシューティングします。

注: EasyBuilder には「自動保存」機能はありません。開発中は、定期的に CTRL+S キーを押して、ジョブを保存することを推奨します。
Version: 5.6.0


スプレッドシートのグラフィカルユーザインタフェース

概要

In-Sight Explorer GUI リファレンス

スプレッドシートのグラフィカルユーザインタフェース (GUI) は、以下の 6 つの主なコンポーネントで構成されています。メニューバー、 ツールバー (標準、記録/再生、ジョブの表示、Explorer、フォーマット、ジョブの監査、およびジョブの編集)、In-Sight のネットワーク、In-Sight のファイル、スプレッドシートビュー/センサのステータスビュー、およびパレット。

注:
  • スプレッドシートビューがアクティブでないとき、[挿入]、[フォーマット]、[画像]、[センサ] メニューは使用できません。
  • スプレッドシートビューがアクティブでないとき、[記録/再生]、[ジョブの表示]、[フォーマット]、[ジョブの監査]、[ジョブの編集] ツールバーは使用できません。
  • グラフィカルユーザインタフェース
  • ユーザインタフェースのカスタマイズ

グラフィカルユーザインタフェース

詳細については、赤い枠で囲まれた各領域のいずれかをクリックしてください。

ウィンドウペインのカスタマイズ

[アプリケーションステップ] (EasyBuilder ビューのみ)、[In-Sight のネットワーク]、[In-Sight のファイル] および [パレット] ペインはウィンドウペインにドッキングすることができます。また、ペインのタイトルバーをドラッグまたは右クリックすることによってカスタマイズすることができます。

ドラッグによるカスタマイズ

ウィンドウペインのタイトルをクリックして、目的の位置にドラッグします。

ウィンドウペインのドッキング

ウィンドウペインをユーザインタフェースの特定の範囲に固定するには、ドッキング先のウィンドウの端にウィンドウペインをドラッグして、ユーザインタフェースに表示される小さな正方形のいずれか 1 つにドロップします。小さな正方形にウィンドウペインを合わせると、ドッキング先の範囲が青色で表示されます。

ユーザインタフェースの左側にドッキングします。
ユーザインタフェースの右側にドッキングします。
ユーザインタフェースの上側にドッキングします。
ユーザインタフェースの下側にドッキングします。
ウィンドウペインをタブとしてドッキングします。

右クリックによるドッキング

ウィンドウペインのタイトルを右クリックすると、次のメニューが表示されます。

  • [ドッキング] (デフォルト): ウィンドウペインをユーザインタフェースに固定します。
  • [自動的に隠す]: ウィンドウペインをユーザインタフェースの横に「ピン留め」します。ウィンドウペインを表示するには、ユーザインタフェースのサイドバーにカーソルを合わせます。このメニューは [Floating] が選択されていると使用できません。
  • [隠す]: ウィンドウペインを閉じます。再表示するには、[表示] メニューからウィンドウペインを選択します。このメニューは EasyBuilder の [アプリケーションステップ] ウィンドウペインでは使用できません。

注: ドッキングしていないウィンドウペインをダブルクリックすると、最後にドッキングした位置に戻ります。ドッキングしているウィンドウペインをダブルクリックすると、ユーザインタフェースから分離します。


[画像] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[画像] メニューを使用すると、表示領域に表示される画像に関連した操作を実行できます。

注: EasyBuilder ビューがアクティブでないとき、次の [画像] メニューの一部またはすべてが利用できない場合があります。

[画像] メニューの項目

  • [トリガ]: アクティブな In-Sight センサから新しい画像を 1 つ取得します。
  • [連続トリガ]: アプリケーションがライブ画像に対して予想どおりに動作することを確認するために、画像を連続して取り込みます。
注:
  • [連続トリガ] は、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
  • この機能は、すべてのアプリケーションステップで利用できます。
  • このモードを終了するには、[ジョブの表示] ツールバーの [連続トリガ] ボタンをクリックするか、画像メニューから再度 [連続トリガ] を選択してください。
  • [ライブビデオ]: センサのレンズと視野の調節を行うときに使用するライブビデオ画像を表示します。また、画像のフォーカス得点を判定する際に有用なフォーカスメトリクス得点を開始します。これは、「シーン」(つまり、その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または画像の領域に含まれる度合を示します。
注:
  • この機能は、すべてのアプリケーションステップで利用できます。
  • このモードを終了するには、[画像の設定] ステップでコンテキストペインの [ライブビデオ] ボタンをクリックし、[ジョブの表示] ツールバーの [ライブビデオ] ボタンをクリックするか、画像をクリックしてください。
  • 意味のあるデータを得るには、「フォーカスメトリクス」得点をまったく同じシーンの別の「フォーカスメトリクス」得点と比較する必要があります (シーンは同一である必要があります)。
  • [フォーカスメトリクス] をオフにするには、[ジョブの表示] ツールバーで [フォーカスメトリクス] アイコンをクリックするか (画像がライブビデオの場合)、[ビュー] メニューで [フォーカスメトリクス] オプションを選択します。
  • [記録]: 取り込んだ画像を、ユーザ指定の記録フォルダに記録します。記録はオンラインとオフラインの両方のモードで機能します。
注:
  • ライブビデオモードでは、画像を記録できません。
  • 再生中に [記録] をクリックすると、再生中の画像は、[記録/再生のオプション] ダイアログで指定されたソートパラメータに応じて、記録フォルダ、Good フォルダ、または Bad フォルダに記録されます。このとき、再生フォルダ上のファイル名と同じ名前で記録されます。
  • [再生]: 再生する画像を選択します。
    • [最初の画像]: 再生フォルダに保存されている最初の画像に移動します。
    • [前の画像]: 再生フォルダに保存されている前の画像に移動します。
    • [再生]: 再生フォルダに保存されているすべての画像を再生します。

注: センサがオンラインモードのときに画像の再生ができるようにするには、[画像の設定] ステップの [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。

  • [次の画像]: 再生フォルダに保存されている次の画像に移動します。
  • [最後の画像]: 再生フォルダに保存されている最後の画像に移動します。
  • [記録/再生のオプション]: [記録/再生のオプション] ダイアログを開きます。このダイアログでは、記録画像を保存するフォルダの指定、再生する画像の保存されているフォルダの指定、画像の最大保存数の指定、保存済み画像数の確認、検査結果に基づく複数フォルダへの画像の振り分け、画像解像度の設定、記録画像のファイル名のフォーマットの選択、および記録画像の再生モードと一時停止時間の設定を行うことができます。
  • [ズーム]: 背景画像の表示倍率を変更します。

    • [拡大]: 画像の表示倍率を 1 段階上げます。

    • [縮小]: 画像の表示倍率を 1 段階下げます。

    • [倍率 1:1]: 画像の 1 ピクセルに対して PC ディスプレイの 1 ピクセルで表示するようにします。

    • [最大のサイズに拡大]: 表示倍率を最大限まで高めます。

    • [全体表示]: ウィンドウ内に画像全体が表示されるように自動調整します。境界線は表示されません。

    • [幅に合わせる]: ウィンドウ全体に画像が表示されるように自動調整します。画像の周囲に余白は表示されません。

注:
  • [倍率 1:1]、[最大のサイズに拡大]、[幅に合わせる]、[全体表示] は一度に 2 つの項目を選択することはできません。いずれか 1 つのみ選択できます。 相互に排他的です。
  • [全体表示] と [幅に合わせる] の表示倍率は、ウィンドウのサイズが変更されると、自動的に調整されます。
  • [画像の回転]: 取り込んだ画像を表示する向きを選択します。ハイライトされたアイコンは現在の回転状態を示します。この設定は、表示の変更のみを目的とし、センサからの画像の取り込み方法やビジョンツールによる画像の処理方法、および PC 上のファイルへの画像の保存やファイルからのロードには影響を与えません。したがって、表示の向きはいつでも変更でき、ジョブの処理結果には影響しません。なお、この設定はジョブファイルに保存されるので、ジョブごとに特定の向きで画像を表示するように設定することができます。
    • [標準]
    • [右に 90 度回転]
    • [180 度回転]
    • [270 度回転]

注: 画像は、取り込み時の向きでファイルに保存されます。

  • [露光過多・過少を表示]: グレーレベルが [露光過少レベル] 以下の画像内のピクセルの青色でのハイライト、および [露光過多レベル] 以上のピクセルの赤色でのハイライトを有効化/無効化します。

スプレッドシートビュー

[画像] メニューを使用すると、半透明のスプレッドシートオーバレイの下に表示される画像に関連した操作を実行できます。

注: スプレッドシートビューがアクティブでないとき、次のメニューの一部またはすべてが利用できない場合があります。

[画像] メニューの項目

  • [トリガ]: アクティブな In-Sight センサから新しい画像を 1 つ取得します。

  • [連続トリガ]: アプリケーションがライブ画像に対して予想どおりに動作することを確認するために、画像を連続して取り込みます。

    注:
    • [連続トリガ] は、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
    • このモードを終了するには、[ジョブの表示] ツールバーの [連続トリガ] ボタンをクリックするか、画像メニューから再度 [連続トリガ] を選択してください。
  • [ライブビデオ]: センサのレンズと視野の調節を行うときに使用するライブ画像を表示します。いずれかのボタンを押すと、ライブビデオを終了してスプレッドシートに戻ります。また、画像のフォーカス得点を判定する際に有用なフォーカスメトリクス得点を開始します。これは、「シーン」(つまり、その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または画像の領域に含まれる度合を示します。
注:
  • 関連するデータを提供するには、まったく同一のシーンから取得した別の画像のフォーカスメトリックス得点と比較する必要があります。
  • [フォーカスメトリクス] をオフにするには、[ジョブの表示] ツールバーで [フォーカスメトリクス] アイコンをクリックするか (画像がライブビデオの場合)、[表示] メニューで [フォーカスメトリクス] オプションを選択します。
  • [記録]: 取り込んだ画像を、ユーザ指定の記録フォルダに記録します。記録はオンラインとオフラインの両方のモードで機能します。
注:
  • ライブビデオモードでは、画像を記録できません。
  • 再生中に [記録] ボタンをクリックすると、再生中の画像は、[監視セルによる振り分け] の設定に応じて、記録フォルダ、Good フォルダ、または Bad フォルダに記録されます。このとき、再生フォルダ上のファイル名と同じ名前で記録されます。
  • [再生]: 再生する画像を選択します。
    • [最初の画像]: 再生フォルダに保存されている最初の画像に移動します。
    • [前の画像]: 再生フォルダに保存されている前の画像に移動します。
    • [再生]: 再生フォルダに保存されているすべての画像を再生します。

注: センサがオンラインモードのときに画像の再生ができるようにするには、AcquireImage 関数の [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。

  • [次の画像]: 再生フォルダに保存されている次の画像に移動します。
  • [最後の画像]: 再生フォルダに保存されている最後の画像に移動します。
  • [記録/再生のオプション]: [記録/再生のオプション] ダイアログを開きます。このダイアログでは、記録画像を保存するフォルダの指定、再生する画像の保存されているフォルダの指定、画像の最大保存数の指定、保存済み画像数の確認、検査結果に基づく複数フォルダへの画像の振り分け、画像解像度の設定、記録画像のファイル名のフォーマットの選択、および記録画像の再生モードと一時停止時間の設定を行うことができます。
  • [ズーム]: 背景画像の表示倍率を変更します。
    • [拡大]: 画像の表示倍率を 1 段階上げます。
    • [縮小]: 画像の表示倍率を 1 段階下げます。
    • [倍率 1:1]: 画像の 1 ピクセルに対して PC ディスプレイの 1 ピクセルで表示するようにします。
    • [最大のサイズに拡大]: 表示倍率を最大限まで高めます。
    • [幅に合わせる]: ウィンドウ全体に画像が表示されるように自動調整します。画像の周囲に余白は表示されません。
    • [全体表示]: ウィンドウ内に画像全体が表示されるように自動調整します。境界線は表示されません。
注:
  • [倍率 1:1]、[最大のサイズに拡大]、[幅に合わせる]、[全体表示] は一度に 2 つの項目を選択することはできません。いずれか 1 つのみ選択できます。 相互に排他的です。
  • [全体表示] と [幅に合わせる] の表示倍率は、アプリケーションウィンドウのサイズが変更されると、自動的に調整されます。
  • [画像の回転]: 取り込んだ画像を表示する向きを選択します。ハイライトされたアイコンは現在の回転状態を示します。この設定は、表示の変更のみを目的とし、センサからの画像の取り込み方法やビジョンツールによる画像の処理方法、および PC 上のファイルへの画像の保存やファイルからのロードには影響を与えません。したがって、表示の向きはいつでも変更でき、ジョブの処理結果には影響しません。なお、この設定はジョブファイルに保存されるので、ジョブごとに特定の向きで画像を表示するように設定することができます。
    • [標準]
    • [右に 90 度回転]
    • [180 度回転]
    • [270 度回転]

注: ファイル保存時の画像の向きは、AcquireImage 関数の [画像の回転] パラメータで指定されます。

  • [露光過多・過少を表示]: グレーレベルが [露光過少レベル] 以下の画像内のピクセルの青色でのハイライト、および [露光過多レベル] 以上のピクセルの赤色でのハイライトを有効化/無効化します。
  • [オーバレイの透明度]: [オーバレイの透明度] ダイアログでは、画像やグラフィックスに対するスプレッドシートオーバレイの不透明度を調整することができます。


[センサ] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[センサ] メニューを使用すると、アクティブな In-Sight ビジョンシステムに関する設定と操作を実行できます。

注: EasyBuilder ビューがアクティブでないとき、次の [センサ] メニューの一部またはすべてが利用できない場合があります。

[センサ] メニューの項目

  • [オンライン]: アクティブな In-Sight ビジョンシステムのオンライン/オフライン状態を切り替えます。
  • [ネットワークの設定]: [ネットワークの設定] ダイアログを開きます。このダイアログでは、TCP/IP ネットワークで通信できるようにビジョンシステムを設定することができます。
  • [日付/時刻の設定]: [日付/時刻の設定] ダイアログを表示します。このダイアログでは、現在の日付または時刻を調整して、タイムゾーンを設定します。また、自動時刻同期に使用する SNTP サーバの設定を行います。
  • [ホストテーブル]: [ホストテーブル] ダイアログを開いて、ネットワークのホスト名から IP アドレスへのローカルマッピングを指定することができます。これによって、異なるサブネットにある In-Sight ビジョンシステムやサードパーティの FTP サーバにアクセスできるようになります。
  • [FTP の設定]: [FTP の設定] ダイアログを開きます。ここでは、ほかのデバイスと通信するために FTP (File Transfer Protocol) を設定することができます。

  • ジョブサーバの設定: [ジョブサーバの設定] ダイアログを開いて、ジョブファイルをロードし保存する FTP サーバにアクセスするようにビジョンシステムを設定します。

    注: [ジョブサーバ] ダイアログは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。

  • [照明の設定]:[照明の設定] ダイアログを開き、In-Sight 7000 シリーズビジョンシステムに接続されている照明デバイスを設定します。
  • [スタートアップ]: 起動時のスタートアップパラメータを設定します。これには、オンライン/オフラインステータスや起動時にロードするジョブなどが含まれます。
  • [ユーザアクセス設定]: ユーザのアクセスレベル権限を表示または変更します。
  • [HMI の設定]: [HMI の設定] ダイアログを開き、接続を許可するヒューマンマシンインタフェース (HMI) アプリケーションの数、HMI サーバおよび HMI ディスプレイのオプションを設定します。
  • [画像の設定]: [画像の設定] ダイアログを開き、ライブ画像およびオンライン画像の解像度とフレームレート、ビジョンシステムのデフォルトの解像度を設定します。

  • [画像バッファ]: [画像バッファ] ダイアログ を開き、スタートアップ時に In-Sight ビジョンシステムに割り当てる画像バッファの数を設定します。

  • [TestRun]: [TestRun セットアップ] ダイアログを開き、TestRun テストを設定します。さらに、TestRun テストの開始、壊れた値またはテストの修復、テストのインポートおよびエクスポート、新しいテストの起動を行うこともできます。
    • [新規]: 以前に作成した TestRun テストをクリアします。
    • [設定]: [TestRun セットアップ] ダイアログを起動して、TestRun テストを設定および編集します。
    • [実行]: TestRun テストの実行を開始します。
    • [バッチ実行]: [バッチ実行] ダイアログを開き、.job ファイルのバッチで実行する TestRun を設定します。
    • [修復]: TestRun の値またはテストの修復を開始します。
    • [インポート]: [開く] ダイアログを起動して、以前に作成した TestRun テストをインポートします。
    • [エクスポート]: [名前を付けて保存] ダイアログを起動して、TestRun テストを保存およびエクスポートします。
  • [ジョブサイズ制限]: [ジョブサイズ制限] ダイアログを開き、選択中の In-Sight ビジョンシステムのメモリ割り当て量を設定します。
  • [ライセンス]: [ライセンス] ダイアログを開きます。ここで、セル保護ライセンスを管理できます。
  • [再起動]: [センサの再起動] ダイアログが表示されます。ここで、ビジョンシステムを再起動するかどうかが確認されます。

スプレッドシートビュー

[センサ] メニューを使用すると、アクティブな In-Sight ビジョンシステムに関する設定と操作を実行できます。

注: スプレッドシートビューがアクティブでないとき、次の [センサ] メニューの一部またはすべてが利用できない場合があります。

[センサ] メニューの項目

  • [オンライン]: アクティブな In-Sight ビジョンシステムのオンライン/オフライン状態を切り替えます。
  • [ネットワークの設定]: [ネットワークの設定] ダイアログを開きます。このダイアログでは、TCP/IP ネットワークで通信できるようにビジョンシステムを設定することができます。
  • [日付/時刻の設定]: [日付/時刻の設定] ダイアログを表示します。このダイアログでは、現在の日付または時刻を調整して、タイムゾーンを設定します。また、自動時刻同期に使用する SNTP サーバの設定を行います。
  • [ホストテーブル]: [ホストテーブル] ダイアログを開いて、ネットワークのホスト名から IP アドレスへのローカルマッピングを指定することができます。これによって、異なるサブネットにある In-Sight ビジョンシステムやサードパーティの FTP サーバにアクセスできるようになります。
  • [FTP の設定]: [FTP の設定] ダイアログを開きます。ここでは、ほかのデバイスと通信するために FTP (File Transfer Protocol) を設定することができます。

  • ジョブサーバの設定: [ジョブサーバの設定] ダイアログを開いて、ジョブファイルをロードし保存する FTP サーバにアクセスするようにビジョンシステムを設定します。

  • [シリアルポートの設定]: シリアルポートの通信パラメータを設定します。

  • [CC-Link の設定]: [CC-Link の設定] ダイアログを開き、CIO-MICRO-CC I/O モジュール上での CC-Link 通信を設定します。

    注:CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • [ディスクリート I/O の設定]: ディスクリート入力および出力のデータラインを設定します。
  • [照明の設定]:[照明の設定] ダイアログを開き、In-Sight 7000 シリーズビジョンシステムに接続されている照明デバイスを設定します。
  • [監査メッセージの設定]: [監査メッセージの設定] ダイアログを開き、アクティブなビジョンシステムの自動監査メッセージの有効化または無効化、監査メッセージサーバの IP アドレスと TCP/IP ポートの指定、および監査メッセージを生成するイベントタイプの指定を行います。
  • [ラインスキャンの設定]: [ラインスキャンの設定] ダイアログを開き、In-Sight 5604 ラインスキャンビジョンシステムを設定します。
  • [スタートアップ]: 起動時のスタートアップパラメータを設定します。これには、オンライン/オフラインステータスや起動時にロードするジョブなどが含まれます。
  • [ユーザアクセス設定]: ユーザのアクセスレベル権限を表示または変更します。
  • [HMI の設定]: [HMI の設定] ダイアログを開き、接続を許可するヒューマンマシンインタフェース (HMI) アプリケーションの数、HMI サーバおよび HMI ディスプレイのオプションを設定します。
  • [画像の設定]: [画像の設定] ダイアログを開き、ライブ画像およびオンライン画像の解像度とフレームレート、ビジョンシステムのデフォルトの解像度を設定します。
  • [画像バッファ]: [画像バッファ] ダイアログ を開き、スタートアップ時に In-Sight ビジョンシステムに割り当てる画像バッファの数を設定します。
  • [センサフィルムストリップの設定]: [センサフィルムストリップの設定] ダイアログを開き、ビジョンシステムに格納する結果のタイプ、ビジョンシステムに格納する結果の数、結果の成功または失敗ステータスを決定する要素、および失敗ステータス時のフィルムストリップの動作を設定します。
  • [RAM ディスクの設定]: [RAM ディスクの設定] ダイアログを開いて、ビジョンシステムまたはエミュレータの RAM ディスクフォルダを有効にして設定します。RAM ディスクフォルダは、ジョブ、画像、またはセルデータなどのデータの格納と共有に使用することができます。セルデータは [セルのインポート]、[セルのエクスポート] ダイアログや [スニペット] ダイアログ、または ExportData/ImportData 関数で使用されます。
  • [アクティブセル制限]: 使用可能なスプレッドシートのセル数を設定するための [アクティブセル制限] ダイアログを開きます。
  • [ジョブのプロファイル]: セルの実行時間のベンチマークテストを実行できるプロファイラを開きます。
  • [ジョブの PASS/FAIL]: [ジョブの Pass/Fail セルの設定] ダイアログを開きます。ここでは、モニタするセルを選択します。このセルは、ジョブの全体的な成功/失敗ステータスを決定するもので、ビジョンシステムからの出力として Cognex VisionView などそのほかのアプリケーションへ送信することができます。
  • [TestRun]: [TestRun セットアップ] ダイアログを開き、TestRun テストを設定します。さらに、TestRun テストの開始、壊れた値またはテストの修復、テストのインポートおよびエクスポート、新しいテストの起動を行うこともできます。
    • [新規]: 以前に作成した TestRun テストをクリアします。
    • [設定]: [TestRun セットアップ] ダイアログを起動して、TestRun テストを設定および編集します。
    • [実行]: TestRun テストの実行を開始します。
    • [バッチ実行]: [バッチ実行] ダイアログを開き、.job ファイルのバッチで実行する TestRun を設定します。
    • [修復]: TestRun の値またはテストの修復を開始します。
    • [インポート]: [開く] ダイアログを起動して、以前に作成した TestRun テストをインポートします。
    • [エクスポート]: [名前を付けて保存] ダイアログを起動して、TestRun テストを保存およびエクスポートします。
  • [Dialog 関数キャンセル表示]: 有効にすると、ジョブ内のすべての Dialog 関数で [キャンセル] ボタンが使用できるようになります。無効にすると、ジョブ内のすべての Dialog 関数で [キャンセル] ボタンが使用できなくなります。
  • [ライセンス]: [ライセンス] ダイアログを開きます。ここで、セル保護ライセンスの管理および保護されたセルへのアクセスを提供するテンポラリパスワードの入力を実行できます。
  • [再起動]: [センサの再起動] ダイアログが表示されます。ここで、ビジョンシステムを再起動するかどうかが確認されます。


オンライン

オンライン/オフライン

[センサ] メニュー

In-Sight ExplorerGUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

現在のオンライン/オフラインの状態は、ユーザインタフェースの右下隅のステータスバーに表示されます。ステータスバーに [image] と表示されるようにするには、次の 3 つがそれぞれオンライン状態である必要があります。GUI オンライン、通信オンライン、およびディスクリート I/O オンラインです。次のいずれかの操作によって、アクティブなビジョンシステムの GUI オンライン/オフラインのステータスが切り替わります。

  • [センサ] メニューの、[オンライン] をクリックします。
  • EasyBuilder ツールバーで、[オンライン/オフライン] [image] ボタンをクリックします。
  • [ジョブの実行] 設定ペインで [オンライン] ボタンをクリックします。
  • Ctrl + F8 キーを押します。

次の表は、ビジョンシステムのさまざまなオンライン/オフラインモードをまとめたものです。

オンライン/オフラインステータス | 条件
 | 通信およびディスクリート I/O はオンライン状態ですが、ビジョンシステムは GUI からオフライン状態に設定されています。
 | 3 つのそれぞれがオンライン状態です。ビジョンシステムはオンライン操作モードです。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、通信プロトコル (ProfiNET、EtherNet/IP、ネイティブモードなど) によって、ビジョンシステムはオフラインのままになっています。例えば、ネイティブモードで、ビジョンシステムをオフラインにする Set Online コマンド SO0 が発行されました。ビジョンシステムをオンラインにするには、Set Online コマンド SO1 をビジョンシステムに送信する必要があります。 注: アプリケーションは、管理関数 (バックアップやリストアなど) を実行するために、Set Online コマンドをビジョンシステムに送信します。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、オンライン/オフラインタイプとして設定されたディスクリート入力ラインが Low (0) に設定されています。ディスクリート入力信号の状態が High (1) になると、ビジョンシステムはオンラインモードになります。

オンラインモードについて

ビジョンシステムがオンラインの場合、次の操作が可能です。

  • ネットワーク入出力関数を使用して、ネットワークを介して EasyBuilder ジョブのデータの送受信を行う。
  • シリアルポートを介して、テキスト、ネイティブ、デバイスネット、および Motoman モードで EasyBuilder ジョブのデータを送受信する。
  • 「カメラ」、「外部」、および「ネットワーク」画像の取り込みトリガに応答する。
  • ディスクリート入出力の読み取りおよび書き込みを行う。
  • EasyBuilder ジョブの結果テーブルを印刷する。
  • [記録/再生] オプションを使用して画像を表示する (画像取り込みトリガを「手動」に設定する必要があります)。

ビジョンシステムがオンラインの場合、次の操作はできません。

  • ジョブや画像を保存および開く (画像取り込みトリガが手動に設定されている場合を除く。この場合は、オンラインの間に画像を開くことができます)。

注: [ユーザ] ダイアログの [オンライン時にジョブ保存] チェックボックスが ON の場合、フルまたはプロテクトレベルのアクセス権を持つユーザはオンライン状態でジョブを保存することができます。

  • EasyBuilder ジョブでのツールの編集、コピー、または貼り付け。
  • ビジョンシステム固有のメニュー項目の実行。ただし、ビジョンシステムをオフラインにすることはできます。

オフラインモードについて

ビジョンシステムはオフラインの場合、画像取り込みトリガに応答することも、ジョブとの間でデータを送受信することもできません。ただし、このビジョンシステムは、シリアル、ネットワーク、およびディスクリートなどの選択によって、特にオンライン状態を切り替えるような入力コマンドに対して応答することができます。

スプレッドシートビュー

現在のオンライン/オフラインの状態は、スプレッドシートの右下隅のステータスバーに表示されます。ステータスバーに [image] と表示されるようにするには、次の 3 つがそれぞれオンライン状態である必要があります。GUI オンライン、通信オンライン、およびディスクリート I/O オンラインです。次のいずれかの操作によって、アクティブなビジョンシステムの GUI オンライン/オフラインのステータスが切り替わります。

  • [センサ] メニューの、[オンライン] をクリックします。
  • [ジョブの表示] ツールバーで、[オンライン] [image] ボタンをクリックします。
  • Ctrl + F8 キーを押します。

次の表は、ビジョンシステムのさまざまなオンライン/オフラインモードをまとめたものです。

オンライン/オフラインステータス | 条件
 | 通信およびディスクリート I/O はオンライン状態ですが、ビジョンシステムは GUI からオフライン状態に設定されています。
 | 3 つのそれぞれがオンライン状態です。ビジョンシステムはオンライン操作モードです。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、通信プロトコル (ProfiNET、EtherNet/IP、ネイティブモードなど) によって、ビジョンシステムはオフラインのままになっています。例えば、ネイティブモードで、ビジョンシステムをオフラインにする Set Online コマンド SO0 が発行されました。ビジョンシステムをオンラインにするには、Set Online コマンド SO1 をビジョンシステムに送信する必要があります。 注: アプリケーションは、管理関数 (バックアップやリストアなど) を実行するために、Set Online コマンドをビジョンシステムに送信します。
 | ビジョンシステムは GUI からオンラインモードに設定されましたが、オンライン/オフラインタイプとして設定されたディスクリート入力ラインが Low (0) に設定されています。ディスクリート入力信号の状態が High (1) になると、ビジョンシステムはオンラインモードになります。

ヒント: [スタートアップ] ダイアログで、アクティブなビジョンシステムをオンラインモードで起動するように設定することができます。

オンラインモードについて

ビジョンシステムがオンラインの場合、次の操作が可能です。

  • ネットワーク入出力関数を使用して、ネットワークを介してスプレッドシートのデータの送受信を行う。
  • テキスト、ネイティブ、DeviceNet、および Motoman モードを使用し、シリアルポートを介してスプレッドシートのデータの送受信を行う。
  • 「カメラ」、「外部」、および「ネットワーク」画像の画像取り込みトリガに応答する。
  • ディスクリート入出力の読み込みおよび書き込みを行う。
  • スプレッドシートを印刷する。
  • 記録/再生オプションを使用して画像を表示する (ビジョンシステムの AcquireImage 関数の トリガパラメータは手動に設定しておく必要があります)。

ビジョンシステムがオンラインの場合、次の操作はできません。

  • ジョブや画像を保存および開く (画像取り込みトリガが手動に設定されている場合を除く。この場合は、オンラインの間に画像を開くことができます)。

注: [ユーザ] ダイアログの [オンライン時にジョブ保存] チェックボックスが ON の場合、フルまたはプロテクトレベルのアクセス権を持つユーザはオンライン状態でジョブを保存することができます。

  • スプレッドシートのセルの編集、移動、コピー、または貼り付け。
  • ビジョンシステム固有のメニュー項目の実行。ただし、ビジョンシステムをオフラインにすることはできます。
  • 対話型グラフィックスモード (ただし、EditRegion 関数は、ビジョンシステムがオンライン時に修正可能であるため例外)。

オフラインモードについて

ビジョンシステムはオフラインの場合、画像取り込みトリガに応答することも、スプレッドシートとの間でデータを送受信することもできません。ただし、このビジョンシステムは、シリアル、ネットワーク、およびディスクリートなどの選択によって、特にオンライン状態を切り替えるような入力コマンドに対して応答することができます。
Version: 5.6.0


[ネットワークの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[ネットワークの設定] ダイアログでは、TCP/IP ネットワークで通信できるようにアクティブな In-Sight ビジョンシステムを設定します。

  • [ネットワークの設定] ダイアログの表示
  • [ネットワークの設定] ダイアログの設定項目
  • DHCP による In-Sight ビジョンシステムの自動的な設定
  • DHCP サーバを使用していないネットワークでの In-Sight ビジョンシステムの手動による設定
  • 関連項目

注:

  • ネットワーク設定を変更した後は In-Sight ビジョンシステムを再起動してください。In-Sight Explorer の [ネットワークの設定] ダイアログで新しい設定値が表示されていても、再起動するまではビジョンシステムの内部状態は更新されません。
  • In-Sight エミュレータは、Windows のネットワーク設定を使用します。この設定を、In-Sight Explorer で変更することはできません。エミュレータのネットワーク設定を変更するには、Windows のコントロールパネルでネットワーク設定を開き、必要な変更を加えます。
  • In-Sight は、IPv4 Organization Local Scope (239.192.0.0/14) から EtherNet/IP マルチキャストアドレスを自動的に割り当てます。

[ネットワークの設定] ダイアログの表示

  • [センサ] メニューで、[ネットワークの設定] をクリックします。

    ファームウェアバージョン 5.4.0 以降を実行している In-Sight ビジョンシステム/センサに接続されている場合

    ファームウェアバージョン 5.3.0 以降を実行している In-Sight ビジョンシステム/センサに接続されている場合

    ファームウェアバージョン 5.2.X 以降を実行している In-Sight ビジョンシステムに接続されている場合

[ネットワークの設定] ダイアログの設定項目

  • [ホスト名]: [In-Sight ネットワーク] に表示される In-Sight ビジョンシステムの名前を定義します。ローカルシステムがネットワークに接続され、In-Sight エミュレータを動作させている PC の場合、ホスト名には、Windows オペレーティングシステムで定義されている PC 名が自動的に使用されます。

    各 In-Sight ビジョンシステムには、初めて起動したときにホスト名が自動的に設定されます。この名前は、「In-Sight」を表す「is」で始まり、その後にモデル番号とアンダースコアが続き、ビジョンシステムの一意の MAC アドレスの最後の 6 文字で終わります。例えば、MAC アドレス 00-d0-24-01-02-03 を持つ In-Sight 5100 ビジョンシステムのホスト名は「is5100_010203」です。また、MAC アドレス 00-d0-24-57-09-31 を持つ In-Sight 5400C ビジョンシステムのホスト名は「is5400C_570931」になります。

    ホスト名は、このフィールドに新しい名前を入力することによって変更できます。

    注:

    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、ピリオド (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。

  • [DHCP サーバの使用]: アクティブな In-Sight ビジョンシステムの起動時に DHCP サーバによって動的にネットワークの設定が行われるようにします。
    • [IP アドレス]: ローカルネットワークの IP アドレス割り当てルールに従って、ネットワーク上の各 In-Sight ビジョンシステムに一意なアドレスが割り当てられます。
    • [サブネットマスク]: IP アドレスのどの部分がネットワークを示し、どの部分がホストを示すかを定義します。IP アドレスのネットワーク部分は同じサブネットのすべてのホストにおいて共通しており、残りは各ホスト固有です。
    • [デフォルトゲートウェイ]: ネットワーク上に利用できるゲートウェイホストがある場合、その IP アドレスを指定します。ゲートウェイホストは、別々のネットワーク上のホスト間でデータのリレーを行います。
    • [DNS サーバ]: ネットワーク上に、DNS 解決を提供するホストがあれば、その IP アドレスを指定します。

    • [ドメイン名]: ホストネットワークのネットワークドメインを指定します。

      注: ドメイン名は最大 63 文字です。

    • [DHCP タイムアウト]: In-Sight ビジョンシステムが DHCP 用に設定されているときに、DHCP サーバが有効な IP アドレスで応答するのをビジョンシステムが待つ時間 (5 ～ 180 秒、デフォルト = 60) を指定します。DHCP サーバからの応答待ち時間がタイムアウトすると、ネットワーク通信は中断されます。ビジョンシステムは電源を入れ直すまでネットワークへの再接続を試みません。

      ヒント: In-Sight ビジョンシステムをネットワークに接続する予定がない場合は、最小時間の 5 秒を指定すると、ビジョンシステムの起動時間を短縮できます。このとき、ビジョンシステムは DHCP 用に設定する必要があります。

  • [Telnet]: ビジョンシステムの Telnet 設定を指定します。
    • [Telnet ポート番号]: アクティブな In-Sight ビジョンシステム (通信を待っている TCP/IP サーバ) がリモートデバイス (通信を開始する TCP/IP クライアント) からの要求を受け入れる Telnet ポートを割り当てます。 有効なポート割り当ては、In-Sight 通信のために予約されているポートを除いて、1 ～ 65535 の未使用の任意の番号です。
  • Link 関数:

    • [ライン速度]: ビジョンシステムとネットワークデバイスの間のイーサネットの速度とデュープレックスモードを指定します。

      警告:指定のリンク速度をサポートするようにネットワークデバイスが設定されていない場合、ビジョンシステムにアクセスすることはできません。ビジョンシステムのイーサネット設定に合わせてネットワークデバイスのイーサネット設定を行ってください。

      • [オートネゴシエーション] (デフォルト): ビジョンシステムとネットワークデバイスは、両方の出デバイスでサポートされる最速のイーサネット速度とデュープレックスモードを選択するために通信します。
      • [10 Mbps Half Duplex (10 Mbps 半二重): イーサネット速度が 10 メガビット/秒に固定され、データは指定された時刻にのみ送受信可能です。
      • [10 Mbps Full Duplex (10 Mbps 全二重): イーサネット速度が 10 メガビット/秒に固定され、データは任意の時刻に送受信可能です。
      • [100 Mbps Half Duplex (10 Mbps 半二重): イーサネット速度が 100 メガビット/秒に固定され、データは指定された時刻にのみ送受信可能です。
      • [100 Mbps Full Duplex (10 Mbps 全二重): イーサネット速度が 100 メガビット/秒に固定され、データは任意の時刻に送受信可能です。

      • [1000 Mbps Full Duplex (10 Mbps 全二重): イーサネット速度が 1000 メガビット/秒に固定され、データは任意の時刻に送受信可能です。

        注:[1000 Mbps 全二重] オプションは、1000 Mbps イーサネット速度をサポートするビジョンシステムだけで使用できます。In-Sight 5600 シリーズのビジョンシステムの場合、128MB 以上の不揮発性フラッシュメモリを搭載したモデルだけで使用できます。

    • [現在のスピード]: ビジョンシステムの現在のイーサネットリンク速度とデュープレックスモード (全二重または半二重) を表示します。

  • [プロトコルサービス]: ビジョンシステムのパフォーマンスを高めるために、特定のサービスを有効または無効にします。

    • [Modbus TCP サーバを有効にする]: In-Sight ビジョンシステムを Modbus/TCP サーバとして動作するように設定するかどうかを、有効または無効にして指定します。複数の接続を同時にサポートし、またセッションのアイドルタイムアウトもサポートします。Modbus/TCP サーバとして設定すると、ビジョンシステムは、接続を許容するクライアントの動作数を維持します。新規接続が確立されるたびに、サーバは 0 になるまで最大許可接続数から接続数を減算し、0 になると、後続のすべての接続要求を明示的に拒否します。現在接続中のクライアントが明示的に接続を切断するか、またはアイドルタイムアウトによって黙示的に接続が切断されたときのみ、サーバはその後の接続要求を受け入れます。

      注:
      • [プロトコルサービス] グループボックスの [Modbus TCP サーバを有効にする] チェックボックス、[最大接続数]、[アイドルタイムアウト] の各設定項目は、ファームウェア 4.x.x が実行されている In-Sight ビジョンシステムでのみ設定可能になります。ファームウェア 5.3.0 以降のファームウェアバージョンが実行されている In-Sight ビジョンシステムを使用する場合は、[産業用イーサネットプロトコル] グループボックスの Modbus TCP サーバを参照してください。
      • チェックボックスを有効にした場合、最大接続数の制限は、アプリケーションが実際に要求する Modbus/TCP 接続数の 2 倍に設定することを推奨します。このように設定すると、電源異常が発生したり、電源を再投入した場合に、以前の接続がタイムアウトするのを待たずに、すべての接続を再確立することが可能です。
      • [最大接続数]: ビジョンシステムがサポートする、最大同時接続可能数を指定します (1 ～ 6、デフォルト = 4)。
      • [アイドルタイムアウト]: 最後に発行された Modbus/TCP 要求をクライアントのサーバが受信してから、そのセッションがアイドル状態と宣言されるまでの時間を指定します (0 ～ 3600 秒、デフォルト = 120 秒)。Modbus/TCP サーバは、500ms おきに接続セッションをすべてチェックして、アイドルタイムに達したセッションがあるかどうかを決定します。アイドル状態のセッションに対し、Modbus/TCP サーバは、ソケットを閉じるコマンドを発行し、アイドル状態のセッションに割り当てられたリソースを再要求します。
      • [ユーザデータバイパスの有効化]: キャッシュデータをバイパスして、生ユーザデータを直接読み取る場合は、このチェックボックスをオンにします。デフォルトでは、この設定は無効になっています。

  • [iQ センサソリューション]: In-Sight ビジョンシステムの iQ センサソリューションを有効または無効にします。

    注:
    • iQ センサソリューションは、In-Sight ファームウェア 4.x.x を使用している In-Sight ビジョンシステムだけで使用できます。
    • iQSS (GXWorks) と [ネットワーク設定] ダイアログにおいて、ネットワーク設定を同時に変更しないでください。

  • [産業用イーサネットプロトコル]: In-Sight ビジョンシステムの特定の Ethernet プロトコルを有効または無効にします。

    注:
    • EasyBuilder を使用する場合は、[通信] アプリケーションステップで [産業用イーサネットデバイス] の設定項目を追加および設定する必要があります。そうしないと、[フォーマット出力バッファ] の設定項目が設定されず、結果データが何も出力されなくなります。詳細については、EasyBuilder ヘルプの「デバイスの設定」([通信] → [デバイスの設定]) のトピックを参照してください。
    • スプレッドシートを使用する場合は、このダイアログを使用して産業用イーサネットプロトコルを有効にする必要があります。選択されているプロトコルが、PROFINET、SLMP Scanner、POWERLINK または Modbus TCP サーバの場合は、[設定] ボタンを使用して設定項目を設定する必要があります。
    • EtherNet/IP、PROFINET、SLMP スキャナ、POWERLINK および Modbus TCP サーバプロトコルは相互に排他的であるため、これらのプロトコルを同時に有効にすることはできません。

    • [EtherNet/IP]: ビジョンシステムの EtherNet/IP サービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [EtherNet/IP の設定] ダイアログを起動し、[ユーザデータバイパスの有効化] を設定します。[ユーザデータバイパスの有効化] チェックボックスをオンにしてキャッシュデータをバイパスし、未処理のユーザデータを直接読み取ります。デフォルトでは、この設定はオフになっています。

      注: EtherNet/IP オプションの横の [設定] ボタンは、In-Sight ファームウェア 5.4.0 以降が実行されている In-Sight ビジョンシステムでのみ使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

    • [PROFINET]: ビジョンシステムの PROFINET サービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [PROFINET スキャナ設定] ダイアログを起動し、設定を行います。

      注:POWERLINK は、In-Sight のファームウェアバージョン 4.7.2 以上、および In-Sight Explorer のソフトウェアバージョン 4.7.2 以上を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムでのみサポートされています。ファームウェアバージョン 5.1.0 以上ではサポートされません。

    • [SLMP スキャナ]: ビジョンシステムの SLMP スキャナサービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [SLMP スキャナ設定] ダイアログを起動し、設定を行います。
    • [CC-Link IE フィールド Basic]: ビジョンシステムで CC-Link IE フィールド Basic プロトコルを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [CC-Link IE フィールド Basic設定] ダイアログを起動し、[ユーザデータバイパス] を設定します。
    • [POWERLINK]: ビジョンシステムの POWERLINK プロトコルを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [POWERLINK の設定] ダイアログを起動し、設定を行います。

    • [Modbus TCP サーバ]: ビジョンシステムの Modbus TCP サーバサービスを有効にします。選択すると、このオプションの右側にある [設定] ボタンが有効になります。このボタンによって [Modbus TCP サーバの設定] ダイアログを起動し、設定を行います。

      注: このオプションは、In-Sight ファームウェアバージョン 5.3.0 以降が実行されている In-Sight ビジョンシステムでのみ使用可能です。

    • [なし]: ビジョンシステムの産業用イーサネットプロトコルを無効にします。

DHCP による In-Sight ビジョンシステムの自動的な設定

ネットワークで DHCP サーバを使用して IP アドレスを割り当てる場合は、[DHCP サーバの使用] チェックボックスを ON にしてください。アクティブな In-Sight ビジョンシステムは、起動時に DHCP サーバによって動的にネットワークの設定が行われます。必要に応じて、新しいホスト名と DHCP タイムアウトを指定することができますが、[ネットワークの設定] ダイアログのほかのフィールドはすべて無効になります。多数のビジョンシステムを使用するネットワークでは、各ビジョンシステムに手動で構成設定を入力するよりも、DHCP セットアップの方がよく使用されます。しかし、初期設定を完了した後は、ビジョンシステムの DHCP を無効にして、固定 IP アドレスを割り当てることを強く推奨します。

[DHCP サーバの使用] チェックボックスがオフの場合は、アクティブな In-Sight ビジョンシステムのネットワーク設定を手動で行う必要があります。

DHCP サーバを使用していないネットワークでの In-Sight ビジョンシステムの手動による設定

  1. [DHCP サーバの使用] チェックボックスが現在オンになっている場合は、オフにします。

    注: In-Sight ビジョンシステムのネットワーク設定を以前に手動で行ったことがある場合は、[DHCP サーバの使用] チェックボックスをオフにすると、それらの設定内容が自動的にリストアされます。

  2. [IP アドレス] を入力します。
  3. [サブネットマスク] を入力します。
  4. 必要に応じて、[ホスト名]、[デフォルトゲートウェイ]、[DNS サーバ]、および [ドメイン名] を設定します。
  5. [OK] をクリックします。
  6. すべての変更を有効にするために、ビジョンシステムの電源を入れ直すように求められます。

関連項目

  • ネットワーク接続
  • In-Sight ネットワーク
  • [PROFINET の設定] ダイアログ
  • [SLMP スキャナ設定] ダイアログ
  • ネットワークのトラブルシューティング
Version: 5.6.0


[日付/時刻の設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[日付/時刻の設定] ダイアログは、アクティブな In-Sight ビジョンシステムで、日付と時刻を設定するために使用します。また、IEEE 1588 (バージョン 2) 規格で定義されている CIP-Sync および PTP (Precision Time Protocol) を使用して、非決定性 EtherNet/IP 経由で In-Sight ビジョンシステムと外部デバイス (PLC など) の間のイベントを同期化するようにビジョンシステムを設定するために使用します。ローカルタイムゾーンを設定したり、サマータイムの調整を自動的に行わせたりすることもできます。さらに、SNTP (Simple Network Time Protocol) サーバに接続して、ビジョンシステムの内部時計を自動的に同期化することができます。

注:
  • [日付/時刻の設定] ダイアログで設定した後、アクティブな In-Sight ビジョンシステムの電源を入れ直す必要があります。
  • [時刻同期] を選択すると、自動的に [SNTP サービス] が無効にされます。また、[SNTP サービス] を有効にすると、自動的に [時刻同期] が無効にされます。1 つのビジョンシステムでは 1 つのサービスのみを有効にすることができます。
  • CIP-Sync/PTP は In-Sight 7000 Gen2 シリーズのビジョンシステム、128MB の不揮発性フラッシュメモリを搭載し、ファームウェアバージョン 4.5.0 以上を実行している In-Sight 5000 シリーズビジョンシステムで使用できます。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステム、In-Sight 5705C ビジョンシステムは例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-2R) は CIP-Sync/PTP をサポートしています。
  • [日付/時刻の設定] ダイアログは、エミュレータでは使用できません。
  • ファームウェアのリビジョンが 2.40 よりも古い場合、[日付/時刻の設定] ダイアログは使用できません。
  • In-Sight ビジョンシステムが SNTP を使用するように設定されており、[ディスクリート出力ライン] が [Job Complete] に設定され、ビジョンシステムがオンラインの場合は、SNTP 同期が発生すると [Job Complete] 信号が送信されます。

[日付/時刻の設定] ダイアログを表示するには

  • [センサ] メニューで、[日付/時刻の設定] をクリックします。

[日付/時刻の設定] ダイアログの設定項目

  • [日付]: アクティブな In-Sight センサの現在の日付を表示します。アクティブな In-Sight センサの日付を手動で調整できます。
  • [時間]: アクティブな In-Sight センサの現在の時刻を表示します。アクティブな In-Sight センサの時刻を手動で調整できます。

注: SNTP サーバに接続できない状態で In-Sight システムの電源を入れ直すと、1970 年 1 月 1 日 0 時 00 分に初期化されます。

  • [タイムゾーン]: すべてのタイムゾーンのリストです。
  • [自動的に夏時間の調整を行う]: サマータイムに合わせて調整します。
  • [時刻同期を使用する]: IEEE 1588 (バージョン 2) 規格で定義されている CIP-Sync および PTP (Precision Time Protocol) のサポートを有効にして、非決定性 EtherNet 経由で In-Sight ビジョンシステムと外部デバイス (PLC など) の間のイベントを同期化します。PTP の IEEE 1588 仕様に従うことによって、デバイスは、非決定性ネットワーク上でローカルクロックをマスタクロックに同期化することができます。[時刻同期] を有効にした後、ビジョンシステムの電源を入れ直して PTP の使用を開始し、ビジョンシステムの日付と時刻の設定をマスタと同期化する必要があります。さらに、ビジョンシステムを有効にして電源を入れ直した後で、AcquireImage 関数の [トリガ] パラメータを [タイムスタンプ] に設定すると、EtherNet/IP 経由で送信されたタイムスタンプを介してビジョンシステムをトリガすることができます。

注:CIP-Sync/PTP は In-Sight 7000 Gen2 シリーズのビジョンシステム、128MB の不揮発性フラッシュメモリを搭載し、ファームウェアバージョン 4.5.0 以上を実行している In-Sight 5000 シリーズビジョンシステムで使用できます。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステム、In-Sight 5705C ビジョンシステムは例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-2R) は CIP-Sync/PTP をサポートしています。 In-Sight ビジョンシステムを PTP と併用する場合のセットアップと設定の詳細については、「時刻同期の設定」のトピックを参照してください。

  • [同期の詳細設定]: このボタンをクリックすると [Time Synchronization Details] ダイアログが起動し、PTP スタックに関する読み取り専用の詳細な情報が表示されます。
  • [SNTP サービスを使用する]: このチェックボックスを ON にすると、アクティブな In-Sight センサは自動的に SNTP サーバとの日時の同期化を試みます。このチェックボックスが OFF の場合、または SNTP サーバを使用できない場合は、[日付/時刻の設定] ダイアログで手動で日時を設定できます。

注: In-Sight センサに固定 IP アドレスが割り当てられている場合、デフォルトゲートウェイが適切に設定されていないと、同期化ができないことがあります。

  • [同期させる]: SNTP サーバと日時を同期化させるには、このボタンをクリックします。手動で設定された日時の値は上書きされます。
  • [更新間隔]: SNTP サーバと日時を同期化する間隔を分単位で指定します。デフォルトの更新間隔は 120 分です。値を小さくすると、より頻繁に同期化を実行します。指定可能な最小更新間隔は、15 分に 1 回です。値を大きくすると、同期化の頻度が低下します。指定可能な最大更新間隔は、1,440 分に 1 回、つまり 1 日 1 回です。

注: In-Sight センサでは、12 時間に約 15 秒の割合で時間が遅れます。

  • [DHCP より SNTP サーバを取得]: このチェックボックスを ON にすると、アクティブな In-Sight センサは、DHCP サーバによって提供される SNTP サーバへの接続を試みます。SNTP サーバが DHCP サーバによって提供されない場合や DHCP サーバに接続できない場合は、自動的に主サーバやセカンダリサーバへの接続を試みます。

SNTP サーバが DHCP サーバによって指定されていない場合に、[主サーバ] や [セカンダリ] のサーバも指定されていないと、In-Sight センサはネットワーク上の任意の SNTP サーバへの接続を試みます。このチェックボックスを OFF にすると、主サーバとセカンダリの SNTP サーバだけが使用されます。

  • [主サーバ]: [DHCP より SNTP サーバを取得] チェックボックスが OFF の場合や DHCP サーバが SNTP サーバを検出できない場合に使用する、プライマリ SNTP サーバの IP アドレスまたはホスト名を指定します。主サーバの SNTP サーバを使用できない場合は、セカンダリサーバが使用されます。
  • [セカンダリ]: [DHCP より SNTP サーバを取得] チェックボックスが OFF で、主サーバの SNTP サーバも使用できない場合に使用する、セカンダリ SNTP サーバの IP アドレスまたはホスト名を指定します。
  • [現在使用中のサーバ]: 現在使用中の SNTP サーバがある場合は、その SNTP サーバの IP アドレスを表示します。そうでない場合は、0.0.0.0 と表示します。
Version: 5.6.0


[In-Sight ホストテーブル] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[In-Sight ホストテーブル] では、別々のネットワーク (サブネット) に存在する In-Sight ビジョンシステムが相互に通信できるように設定します。ホストテーブルのエントリによって、指定された IP アドレスのホストのネットワークの設定が実際に変更されることはありません。これらのエントリは、アクティブな In-Sight ビジョンシステムへの追加のビジョンシステムとして単に表示されます。

警告: DHCP を使用して設定されるビジョンシステムの場合は、特定の IP アドレスが割り当てられることを保証することはできません。このホストテーブルでは、ビジョンシステムと通信するために固定 IP アドレスを必要とするため、Cognex では、異なるサブネット上のすべてのビジョンシステムを固定 IP アドレスを指定して設定するよう強くお勧めします。

注:
  • ホストテーブルは、In-Sight エミュレータからターゲットシステムへの hosts.net ファイルの FTP アップロードを介して、ほかの In-Sight ビジョンシステムと共有可能です。アップロードされるファイルのそれぞれのラインのフォーマットは "xxx.xxx.xxx.xxx host_name" ("xxx.xxx.xxx.xxx" は任意の有効な IP アドレス) に従う必要があります。空白のライン、不完全なライン、および先頭が '#' 文字になっているラインは無視されます。また、ホスト名に続く文字もすべて無視されます。ファイルは FTP 経由でダウンロードすることも可能ですが、アップロードされるファイルの元のフォーマットは維持されません。
  • [ファームウェアアップデート] ダイアログでは、別のネットワーク上に存在するか、[In-Sight ホストテーブル] を使用して In-Sight Explorer に追加された In-Sight ビジョンシステムのファームウェアを更新することはできません。ただし、[エクスプローラリモートサブネットリスト] を使用して In-Sight Explorer に追加される、異なるネットワーク上に存在するビジョンシステムのファームウェアは更新可能です。Cognex では、ファームウェアの更新時にはビジョンシステムをローカルネットワークに配置して、ネットワーク障害を防止するようお勧めします。

[In-Sight ホストテーブル] ダイアログを表示するには

  • [センサ] メニューで、[ホストテーブル] をクリックします。

[In-Sight ホストテーブル] ダイアログの設定項目

  • [追加]: ホストテーブルに新規エントリを作成します。[追加] をクリックすると、 Closed [Add Host (ホストの追加)] ダイアログが表示されます。このダイアログで、新規ホストのホスト名と IP アドレスを入力します。

注:

  • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、カンマ (.)、およびアンダースコア (_) です。
  • ホスト名は最大 63 文字です。
  • [編集]: 既存のホストテーブルのエントリを変更します。リストからエントリを選択して [編集] をクリックします。[Edit Host (ホストの編集)] Closed ダイアログが表示されます。このダイアログで、選択したホストのホスト名や IP アドレスを変更できます。

  • [削除]: ホストテーブルからホストを削除します。削除するホストを選択し、[削除] をクリックします。

ヒント: 複数のホストを削除するには、CTRL キーを押しながらホスト名を選択します。

  • [ホストテーブルを DNS より優先する]: オンにすると、In-Sight ホスト名のサーチ順序が、(1) ホストテーブル、(2) ネットワークブラウザ、(3) DNS に指定されます。オフにすると、ホスト名のサーチ順序は、(1) ネットワークブラウザ、(2) DNS、(3) ホストテーブルとなります。

ホストのパラメータ

  • [ホスト名]: 指定した IP アドレスにマップする (割り当てる)、ネットワーク接続された In-Sight ビジョンシステムの名前。ホストテーブル内で指定されているホスト名は、アクティブな In-Sight ビジョンシステムからのみアクセス可能です。
  • [IP アドレス]: 指定したホスト名にマップする、ネットワーク接続された In-Sight ビジョンシステムの IP アドレス。


[FTP の設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[FTP の設定] ダイアログでは、ファイル転送プロトコルを使用するほかのネットワークデバイスとの間で、ジョブ、画像および設定を共有するように In-Sight センサを設定します。

すべての FTP 接続が In-Sight センサ間で行われる In-Sight 専用のローカルネットワークでは、通常、ユーザがデフォルト設定を変える必要はありません。ただし、In-Sight センサとほかのネットワークサーバとの間、または別のネットワーク上の In-Sight センサとの間で FTP 接続が必要とされる場合は、デフォルトの FTP 設定を変更しなければならないことがあります。

[FTP の設定] ダイアログを表示するには

  • [センサ] メニューで、[FTP の設定] をクリックします。

[FTP の設定] ダイアログの設定項目

  • [アイドルタイムアウト]: 別のホストからこの In-Sight センサへの接続がタイムアウトする (切断される) までに、その接続をアクティビティなしの状態で開いたままにする時間 (秒)。(デフォルト = 120)
  • [Read Timeout (読み取りタイムアウト)]: アクティブな In-Sight センサがリモート FTP サーバへの接続後にデータを待つときの時間 (秒)。この値は、無応答のピアから復旧するのに使用されます。(デフォルト = 120)
  • [接続リトライ]: In-Sight センサがリモート FTP サーバへの再接続を試みる回数 (最初の接続試行に失敗した場合)。(デフォルト = 1)
  • [ローカルポート]: ローカルポートは、アクティブな In-Sight センサが着信 FTP 接続を待ち受けるときのポートです。(デフォルト = 21)

ローカルポートの例: is5100_010203 という名前の In-Sight センサの [ローカルポート] は 442 に設定されています。is5100_010203 は FTP サーバとして動作し、ポート 442 でリモートセンサからの着信接続を待ち受けています。is5100_010203 に接続するすべての In-Sight センサまたはエミュレータは、[リモートポート] を 442 に設定することが必要になります。In-Sight Explorer で is5100_010203 上のファイルを表示するには、[Explorer の FTP ポート] を 442 に設定する必要があります。

警告: [ローカルポート] が [Explorer の FTP ポート] と同じ値に設定されていないと、In-Sight Explorer は、In-Sight センサで、バックアップ、リストア、ファームウェア更新、または [In-Sight のファイル] ペインの表示などの操作を実行できなくなります。

  • [リモートポート]: リモートポートは、アクティブな In-Sight センサがほかの In-Sight システムや FTP サーバへの接続を試みるときのポートです。(デフォルト = 21)

リモートポートの例: FLOOR1 という名前の In-Sight センサが、FLOOR2 という名前のリモート In-Sight センサからジョブファイルをロードする必要があると仮定します。FLOOR2 では [ローカルポート] が 2360 に設定されています。言い換えると、FLOOR2 はポート 2360 で FTP サーバを実行しています。この場合 FLOOR1 では、FLOOR2 に接続してジョブファイルをロードするため、その [リモートポート] を 2360 に設定する必要があります。

  • [パッシブ転送]: このチェックボックスをオンにすると、パッシブ FTP クライアント転送が有効になります。この転送方式は、In-Sight センサが、外部から接続が開始されることを許可しないファイアウォールを介して FTP サーバに接続しなければならない場合に必要とされます。(デフォルト = 未選択)


照明の設定

センサメニュー

In-Sight Explorer GUI リファレンス

[照明の設定] ダイアログを使用して、In-Sight 7000 シリーズのビジョンシステムに接続されている照明デバイスを設定します。このダイアログの外観は、ビジョンシステムのタイプおよびビジョンシステムに接続されている照明デバイスのタイプに応じて異なります。

  • In-Sight 70xx ～ 74xx シリーズ
  • In-Sight 76xx ～ 79xx シリーズ
    • 組み込み: In-Sight 照明
    • 組み込み: DataMan 標準照明
    • 組み込み: DataMan 高出力照明
    • 外部
  • 関連項目

ダイアログ照明の設定を表示するには

  • [センサ] メニューで、[照明の設定] をクリックします。

In-Sight 70xx ～ 74xx シリーズ

In-Sight 70xx ～ 74xx シリーズのビジョンシステムでは、照明ケーブルを使用して外部のストロボデバイスまたは連続照明デバイスをビジョンシステムの LIGHT コネクタに接続することができます。接続が検出された場合、[照明の設定] ダイアログを使用して、In-Sight 70xx ～ 74xx シリーズのビジョンシステムに接続されている外部ストロボまたは連続照明デバイスのタイプを指定できます。

注: 内部 LED リング照明を使用する In-Sight 70xx ～ 74xx シリーズのビジョンシステムの場合は、照明制御の設定を使用して内部 LED リング照明を設定します。

設定

  • [極性]:ビジョンシステムに接続されているストロボデバイスまたは連続照明デバイスのタイプを指定します。
    • [無効]:ビジョンシステムが照明デバイスに接続されていません。
    • [PNP (ソース)]:ビジョンシステムが PNP (現在のソース) 照明デバイスに接続されています。
    • [NPN (シンク)]:ビジョンシステムが NPN (現在のシンク) 照明デバイスに接続されています。

In-Sight 76xx ～ 79xx シリーズ

In-Sight 76xx ～ 79xx シリーズのビジョンシステムでは、ビジョンシステムのフェースプレートへの組み込み照明アクセサリの接続、およびビジョンシステムの LIGHT コネクタへの外部照明の接続がサポートされますが、両方の照明器具を同時に使用することはできません。サポート対象アクセサリの完全な一覧については、『In-Sight® 7000 Gen2 Series Vision System Reference Guide』を参照してください。

  • ビジョンシステムのフェースプレートに組み込み照明アクセサリが取り付けられている場合は、[照明の設定] ダイアログを使用して LED リング照明の照明設定を指定できます。
  • ビジョンシステムの LIGHT コネクタに外部照明が接続されている場合は、[照明の設定] ダイアログを使用して外部ストロボまたは連続照明デバイスの照明設定を指定できます。
注: IntegratedLightControl または ExternalLightControl 関数がスプレッドシートに挿入されている場合は、[照明の設定] ダイアログで設定の変更を試みると、ダイアログで指定した設定がスプレッドシート関数によって上書きされます。

組み込み: In-Sight 照明

In-Sight 照明アクセサリには、4 つの LED バンクに分かれた 8 のLED が含まれています。

設定

  • [輝度]:照明アクセサリ LED バンクの実効輝度をパーセンテージとして指定します。 すべての LED バンクで共通の輝度値が共有され、輝度は 50% ～ 100% に制限されています。これは、すべての LED バンクで輝度が均等に分散されるようにするためです。(50% ～ 100%、デフォルト = 100%)

  • [露光時間]:画像取得の際に使用する、固定された露光値を指定します。

    In-Sight モデル

             解像度 露光時間 (ミリ秒)
    In-Sight 7600、7600C、7800、7800C、7900、7900C | 800 × 6001 | 0.014 ～ 550 (デフォルト = 1.000)
    In-Sight 7600、7600C、7800、7800C、7900、7900C | 640 × 4801 | 0.014 ～ 520 (デフォルト = 1.000)
    In-Sight 7801、7801C、7901、7901C | 1280 × 1024 | 0.017 ～ 750 (デフォルト = 1.000)
    In-Sight 7802、7802C、7902、7902C | 1600 × 1200 | 0.020 ～ 940 (デフォルト = 1.000)
    In-Sight 7802、7802C、7902、7902C | 800 × 600 (低照明モード)1 | 0.020 ～ 940 (デフォルト = 1.000)
    In-Sight 7905、7905C | 2448 × 2048 | 0.021 ～ 1000 (デフォルト = 1.000)

    1解像度は、[画像の設定] ダイアログで設定できます。

    注:

    • この In-Sight 照明アクセサリには、明度、LED リングライト色、ビジョンシステムの解像度、取り込まれた行数によって左右される最大ストロボパルス幅があります。照明アクセサリは特定の露光時間の間、点灯します。露光時間が最大ストロボパルス幅を超過した場合、LED リングライトは最大ストロボパルス幅の間だけ点灯します。次に例を示します。

      LED リングライト色 | 明度 | 最大ストロボパルス幅 (ミリ秒)

      In-Sight 7600/7800/7900

      800×6001

      In-Sight 7600/7800/7900

      640×4801

      In-Sight 7801/7901

      1280×1024

      In-Sight 7802/7902

      1600×12001

      In-Sight 7802/7902

      800×600 (低照明モード)1

      In-Sight 7905

      2448×2048
      白 100% 0.314 0.232 0.704 1.022 1.022

      1.599
      50% 0.779 0.574 1.744 2.531 2.531

      3.961
      赤 100% 0.375 0.277 0.841 1.220 1.220

      1.847
      50% 1.083 0.799 2.426 3.519 3.519

      5.508
      赤外線 | 100% | 0.351 | 0.259 | 0.786 | 1.140 | 1.140 | 1.785
      50% | 0.857 | 0.632 | 1.921 | 2.787 | 2.787 | 4.361
      青 | 100% | 0.314 | 0.232 | 0.704 | 1.022 | 1.022 | 1.599
      50% | 0.765 | 0.564 | 1.713 | 2.485 | 2.485 | 3.889
      LED リングライト色 | 明度 | 最大ストロボパルス幅 (ミリ秒)

      In-Sight 7600C/7800C/7900C

      800×6001

      In-Sight 7600C/7800C/7900C

      640×4801

      In-Sight 7801C/7901C

      1280×1024

      In-Sight 7802C/7902C

      1600×12001

      In-Sight 7802C/7902C

      800×600 (低照明モード)1

      In-Sight 7905C

      2448×2048
      白 100% 0.314 0.232 0.704 1.022 1.022

      1.599
      50% 0.779 0.574 1.744 2.531 2.531

      3.961

      1解像度は、[画像の設定] ダイアログで設定できます。
    • 露光時間が最大ストロボパルス幅を超える場合、LED の効率性が低電流で増すため、輝度が低くなって画像がより明るくなることがあります。
  • [常に ON]:複数の取り込みの間に一貫した光レベルを提供するため、選択された LED バンクは常にオンになります。

  • [ライブビデオ]:照明設定を調整するときに使うライブ画像を表示するために、ビジョンシステムをライブビデオモードにします。[ライブビデオ] ボタンをもう一度クリックすると、ライブビデオモードが終了します。

    ヒント: ビジョンシステムにオートフォーカスアクセサリが取り付けられている場合、レンズのフォーカス位置はライブビデオモードのときに調整可能です。

組み込み: DataMan 標準照明

注:DataMan 標準照明アクセサリと高出力照明アクセサリは、In-Sight 7905 または 7905C ではサポートされません。

DataMan 標準照明アクセサリには、8 つの LED バンクに分かれた 36 のLED が含まれています。

設定

  • [輝度]:照明アクセサリ LED バンクの実効輝度をパーセンテージとして指定します。 すべての LED バンクが共通の輝度値を共有します。(0% ～ 100%、デフォルト = 100%)
  • [露光時間]:画像取得の際に使用する、固定された露光値を指定します。(0 ミリ秒～ 1000 ミリ秒、デフォルト = 8 ミリ秒)
  • [ライブビデオ]:照明設定を調整するときに使うライブ画像を表示するために、ビジョンシステムをライブビデオモードにします。[ライブビデオ] ボタンをもう一度クリックすると、ライブビデオモードが終了します。

組み込み: DataMan 高出力照明

注:DataMan 標準照明アクセサリと高出力照明アクセサリは、In-Sight 7905 または 7905C ではサポートされません。

DataMan 高出力照明アクセサリには 8 つの LED が含まれており、これらはすべて自身の LED バンクとして個別にアドレス指定が可能です。

設定

  • [輝度]:LED バンクには輝度の制御がなく、オンまたはオフのいずれかになっています。輝度は 100% に固定されています。
  • [露光時間]:画像取得の際に使用する、固定された露光値を指定します。(0 ミリ秒～ 1000 ミリ秒、デフォルト = 8 ミリ秒)
  • [ライブビデオ]:照明設定を調整するときに使うライブ画像を表示するために、ビジョンシステムをライブビデオモードにします。[ライブビデオ] ボタンをもう一度クリックすると、ライブビデオモードが終了します。

外部

設定

  • [極性]:ビジョンシステムに接続されているストロボデバイスまたは連続照明デバイスのタイプを指定します。
    • [無効]:ビジョンシステムが照明デバイスに接続されていません。
    • [PNP (ソース)]:ビジョンシステムが PNP (現在のソース) 照明デバイスに接続されています。
    • [NPN (シンク)]:ビジョンシステムが NPN (現在のシンク) 照明デバイスに接続されています。
  • [輝度]:接続されたストロボデバイスの有効な照明輝度をパーセンテージで指定します。(0 ～ 100、デフォルト = 100)
  • [ストロボ開始位置]:ストロボ出力を開始する位置を指定します。
    • [画像取り込み開始]:ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。
    • [カメラトリガ]:カメラトリガイベントを受信したときにストロボ出力を開始するよう指定します。

関連項目

  • IntegratedLightControl
  • ExternalLightControl
Version: 5.6.0


[ユーザアクセス設定] ダイアログ

[センサ] メニュー

In-Sight ExplorerGUI リファレンス

[ユーザアクセス設定] ダイアログでは、In-Sight ビジョンシステムのセキュリティモードを設定します。

  • [ユーザアクセス設定] ダイアログの設定項目と使用方法
  • 関連項目

[ユーザアクセス設定] ダイアログの設定項目と使用方法

[ユーザアクセス設定] ダイアログでは、以前のリリースと同様に、In-Sight ビジョンシステムおよびエミュレータへのアクセスを許可されたユーザのアクセスレベルや、FTP の読み取り/書き込みの権限を維持管理します。[ユーザアクセス設定] によって、[ログオン/ログオフ] ダイアログから特定の In-Sight ビジョンシステムにログオンできるユーザ、およびユーザがアクティブジョブに加えることができる変更の種類が決まります。各 In-Sight ビジョンシステムは、ネットワーク上のほかのビジョンシステムから分離された独自のユーザリストを持ちます。したがって、あるビジョンシステムにアクセスする必要があるユーザは、既にそのビジョンシステムのユーザリストに登録されているユーザ名とパスワードを確認する必要があります。

  • [ユーザアクセス設定] ダイアログの表示
  • [ユーザアクセス設定] ダイアログの設定項目
  • 新しいユーザの作成
  • 既存ユーザの設定の変更
  • ユーザの削除
注:
  • すべての In-Sight ビジョンシステムには、あらかじめ admin、operator、monitor の 3 つのユーザ名が設定されています。これらのユーザには、それぞれ、フルアクセス、プロテクト、ロックのアクセスレベルが設定されています。
  • 1 つの In-Sight ビジョンシステムに登録できるユーザの数は最大 32 です。

[ユーザアクセス設定] ダイアログの表示

  • [センサ] メニューで、[ユーザアクセス設定] をクリックします。

[ユーザアクセス設定] ダイアログの設定項目

  • [名前]: ビジョンシステムへのログオンに使用されるユーザ名を指定します。
  • [アクセス]: ユーザのアクセスレベルを指定します。ユーザのアクセス許可を、フルアクセス、プロテクト、ロックという 3 つのレベルで詳細に設定することができます。

  • [表示]: [ジョブビュー] がスプレッドシートビューの場合に、正常にログオンした後に表示するビューを指定します。「標準」が指定されている場合は、ログオン後にスプレッドシートビューが表示されます。「カスタム」が指定されている場合は、ログオン後にカスタムビューが表示されます。

    注:
    • フルアクセスレベルのユーザの場合は、初期ビューが指定されます。ログオンすると、そのユーザは、F6 を押すか、[ジョブの表示] ツールバーで [カスタムビュー] ボタンをクリックすることにより、スプレッドシートビューとカスタムビューを切り替えることができます。
    • アクセスレベルが「プロテクト」または「ロック」のユーザは、カスタムビューにのみアクセスできます。
  • [FTP 読]: FTP 読み取り権限を指定します。この権限によって、ユーザがビジョンシステムにジョブをロードできるかどうかを制御します。[はい] の場合、ユーザはジョブをロードできます。[いいえ] の場合、ユーザはジョブをロードできません。
  • [FTP 書]: FTP 書き込み権限を指定します。この権限によって、ユーザがビジョンシステムにジョブを保存できるかどうかを制御します。[はい] の場合、ユーザはジョブを保存できます。[いいえ] の場合、ユーザはジョブを保存できません。
  • [オンライン/オフライン]: ユーザがビジョンシステムのオンライン/オフラインステータスを変更できるかどうかを指定します。[有効] の場合、ユーザはビジョンシステムのオンライン/オフライン状態を切り替えることができます。[無効] の場合、ユーザはビジョンシステムのオンライン/オフライン状態を切り替えることができません。
  • [オンライン時にジョブ保存]: ビジョンシステムがオンラインのときに、ユーザがジョブを保存できるかどうかを指定します。[有効] の場合、ユーザはオンラインのときにジョブを保存できます。[無効] の場合、ユーザはオンラインのときはジョブを保存できません。

新しいユーザの作成

  1. [追加] をクリックします。

  2. [ユーザ名] フィールドに英数字文字列を入力します。
  3. 新しいユーザのパスワードを入力します。
  4. [パスワードの確認] フィールドにパスワードを再度入力します。

注: ユーザ名とパスワードの文字列は、15 文字を超える長さにすることはできません (ユーザ名は 1 ～ 15 文字、パスワードは 0 ～ 15 文字にする必要があります)。文字、数字、「_」、および「-」を使用できます。

  5. [アクセス] ドロップダウンリストをクリックして、新しいユーザのアクセスレベルを選択します。

アクセスレベルは、設定変更が誤ってまたは無断で行われないように、現在のユーザに許可されるインタフェースの対話レベルを制御します。選択したアクセスレベルは、指定したユーザ名とパスワードで In-Sight Explorer にログオンすると有効になります。

アクセスレベルには次の 3 種類があります。

  • [フルアクセス]: ユーザは In-Sight ビジョンシステムの全体に制限なくアクセスできます。すべてのジョブをロード、変更、保存することができ、すべてのメニュー項目を使用できます。デフォルトの admin ユーザアカウントのアクセスレベルは [フルアクセス] です。
  • [プロテクト]: ビジョンシステムに対するユーザのアクセスは制限されます。プロテクトモードでは、ライブビデオモードにアクセスし、ビジョンシステムのオンライン/オフラインステータスを切り替え (ユーザの [オンライン/オフライン切替可] 権限によって許可される場合)、ジョブを開くか保存し (ユーザの [FTP 読み取り/書き込み] 権限によって許可される場合)、[オプション] ダイアログからインタフェースの外観をカスタマイズできます。EasyBuilder ビューのプロテクトモードでは、ツールパラメータの編集はできますが、ツールの追加や削除はできません。スプレッドシートビューの場合、プロテクトモードでは、必ずスプレッドシートのカスタムビューが表示されます。プロテクトモードのユーザは、カスタムビューに表示されるオペレータ I/F 関数のすべての値を編集できますが、関数そのものに変更を加えることはできません。デフォルトの operator ユーザアカウントのアクセスレベルは [プロテクト] です。
  • [ロック]: このモードでは、アクセスは最も制限されます。モニタできるのは、現在の In-Sight ビジョンシステムの動作のみです。デフォルトの monitor ユーザアカウントのアクセスレベルは [ロック] です。

  6. 必要に応じて [ログオン時にカスタムビューを表示] チェックボックスをオフにし、[ジョブビュー] がスプレッドシートビューになっている場合には、正常にログオンした後にスプレッドシートビューが表示されるようにします。デフォルトでは、このチェックボックスはオンになっており、ログオン時にカスタムビューが表示されます。このチェックボックスは、選択したアクセスレベルが [プロテクト] または [ロック] のときには、常にグレーアウトされます。

    注:
    • このチェックボックスは、デフォルトでは、事前設定された admin ユーザによってオフにされます。
    • このチェックボックスをオンにすると、[ユーザアクセス設定] ダイアログの [表示] 列に「カスタム」と表示されます。このチェックボックスをオフにすると、[ユーザアクセス設定] ダイアログの [表示] 列に「標準」と表示されます。
  7. 必要に応じて、[オンライン/オフライン切替可] チェックボックスをオフにして、プロテクトレベルのユーザに制限を加え、ビジョンシステムのオンライン/オフライン状態を切り替えることができないようにします。このチェックボックスは、選択したアクセスレベルがフルアクセスまたはロックのときには、常にグレーアウトされます。

  8. 必要に応じて、[オンラインでもジョブを保存] チェックボックスをオンにし、フルまたはプロテクトアクセス権限が与えられたユーザがオンライン時にジョブを保存できるようにします。このチェックボックスは、選択したアクセスレベルがロックのときにはグレーアウトされます。

    注:
    • このチェックボックスをオンにすると、プロテクトアクセス権限を持つユーザは、FTP 書き込み権限がない場合でも、ジョブを保存することができます。

    • [オンラインでもジョブを保存] チェックボックスがオンのとき、最大限のトリガレートでジョブが実行された場合、ジョブの保存中にトリガが失敗することがあります。
  9. ユーザの FTP、読み取り、および書き込み権限を指定します。FTP 読み取り権限は In-Sight ビジョンシステムのジョブまたは画像ファイルを開く操作に適用され、FTP 書き込み権限は In-Sight ビジョンシステムにジョブまたは画像を保存する操作に適用されます。さらに、これらの権限は、ユーザがネットワーク上のリモート FTP クライアントから、アクティブな In-Sight システムにログオンを試みる際にも有効です。
  10. [OK] をクリックします。

既存ユーザの設定の変更

  1. リストのユーザをハイライトします。
  2. [編集] をクリックします。

  3. 必要に応じて、ユーザの設定を変更します。ユーザオプションの詳細については、前のセクション「新しいユーザの作成」を参照してください。
注:
  • admin ユーザのパスワードを変更した場合は、ビジョンシステムから一度ログオフし、新しいパスワードでログオンし直す必要があります。そうしないと、エラー が発生します。
  • admin のアクセスレベル、[オンライン/オフライン切替可] 権限、FTP 権限、およびユーザ名は変更できません。
  • [ログオン時にカスタムビューを表示] チェックボックスの影響を受けるのは、スプレッドシートビューのみです。EasyBuilder はカスタムビューをサポートしていません。

ユーザの削除

  1. リストのユーザをハイライトします。
  2. [削除] をクリックします。

ヒント: 複数のユーザを削除するには、Ctrl キーを押しながらユーザ名を選択します。

  3. 削除することを確認します。

注: admin ユーザは削除できません。

関連項目

  • 起動時にカスタムビューをロードする方法


[HMI の設定] ダイアログ

[センサ] メニュー

In-Sight ExplorerGUI リファレンス

[HMI の設定] ダイアログでは、Web HMI の設定を行うことができます。

注: Web HMI アプリケーションは、In-Sight ファームウェア 5.6.0 以上を実行しているビジョンシステムまたはセンサのみで使用できます。

[HMI の設定] ダイアログを表示するには

  • [センサ] メニューで、[HMI の設定] をクリックします。

最大ビュー接続

[最大ビュー接続] 設定を使用して、1 つの In-Sight　ビジョンシステムまたはセンサに接続可能なアプリケーション (In-Sight Explorer、In-Sight 表示コントロール、In-Sight SDK、VisionView または Web HMI) の最大数 (1 ～ 5、デフォルト = 2) を設定します。[最大ビュー接続] の値を変更し、その変更を有効にするには、In-Sight ビジョンシステムまたはセンサを再起動する必要があります。

注:
  • [最大ビュー接続] を 2 以上に設定すると、In-Sight ビジョンシステムに追加の画像バッファが自動的に割り当てられます。例えば、[最大ビュー接続] を 2 に設定し、[画像バッファ] ダイアログで [画像バッファ] の値を 3 に設定すると、ビジョンシステムまたはセンサに 5 つの画像バッファが割り当てられます。画像バッファの合計数がビジョンシステムまたはセンサで利用可能な画像バッファの最大数を超える場合は、画像バッファの最大数がビジョンシステムまたはセンサに割り当てられます。
  • ビュー接続数を増やすと、ジョブのロードや画像の取り込みなど、そのほかのタスクで使用できる RAM の量が減り、パフォーマンスが低下する場合があります。

接続モード

1 つの In-Sight ビジョンシステムまたはセンサは、標準ビュー接続では 1 つのアプリケーションにのみ、またビュー専用接続では 4 つ以下のアプリケーションに接続できます。

最大ビュー接続 | 標準ビュー接続 (In-Sight Explorer、In-Sight 表示コントロール、In-Sight SDK、VisionView または Web HMI) | ビュー専用接続 (VisionView または/および Web HMI)
1 | 1 | 0
2 | 1 | 1
3 | 1 | 2
4 | 1 | 3
5 | 1 | 4

  • 標準ビュー接続:

    任意のアクセスレベル (フル、プロテクトまたはロック) を許可します。通常、この接続モードは、対話型コントロールの編集、ビジョンシステムまたはセンサのオンライン/オフラインの切り替え、新規ジョブのロード、ビジョンシステムまたはセンサのトリガなどのさまざまな実行モードのアクションを行うアプリケーションで使用されます。

    複数のアプリケーションを In-Sight ビジョンシステムまたはセンサに接続する場合、標準ビュー接続ではアプリケーションを 1 つだけ確立することができます。[最大ビュー接続] を 1 に設定すると、アプリケーションは自動的に標準ビュー接続で接続されます。

    注: In-Sight Explorer、In-Sight 表示コントロール、および In-Sight SDK は、標準ビュー接続モードでのみ接続できます。

  • ビュー専用接続:

    ロックアクセスのみを許可します。この接続モードの場合、アプリケーションでは、In-Sight ビジョンシステムまたはセンサの動作の表示のみを行うことができます。対話型コントロールや、[トリガ] および [オンライン/オフライン] などのボタンは、すべて無効になります。

HMI サーバ

  • [サーバの有効化]: Web HMI サーバを有効にするには、このチェックボックスをオンにします。

  • [ポート番号]: 選択したビジョンシステムまたはセンサの Web アドレスで使用するポート番号 (デフォルト = 8087) を指定します。ポート番号はデフォルトで 8087 に設定されますが、サーバで使用可能な任意のポートに変更できます。

    注: 次のポート番号は使用できません。21、22、23、80、502、1069、1070、2222、44818、および 50000。

  • [無通信タイムアウト]: アプリケーションでユーザをログオフするまでに、Web HMI アプリケーションが無通信の状態を続けることができる時間 (0 ～ 60 分、デフォルト = 15) を指定します。[無通信タイムアウト] を無効にするには、値を 0 に設定します。

    注: [無通信タイムアウト] 設定は、デフォルトの認証情報 (すなわち、パスワードなしの管理ユーザ) を使用するビジョンシステムまたはセンサには適用されません。

  • [ローカルへの保存の許可]: ブラウザで Web HMI の設定 (画像スケール、画像角度、画像オフセット、および表示の設定) を記憶するかどうかを指定します。このチェックボックスをオンにする (デフォルト設定) と、[表示切り替え] ボタンをクリックするか、または画像表示設定を調整するごとに、Web HMI 設定が自動的に保存されます。

    注: Web ブラウザの設定をチェックし、Cookies と DOM/ローカルストレージが有効になっていることを確認してください。有効になっていないと、Web HMI の設定が保存されず、エラーメッセージが表示されることがあります。
  • [ビュー選択の許可]: Web HMI アプリケーションで [表示切り替え] ボタンを有効にするかどうかを指定します。
  • [オンライン/オフラインの許可]: Web HMI アプリケーションで [オンライン/オフライン] ボタンを有効にするかどうかを指定します。
  • [ライブビデオの許可]: Web HMI アプリケーションで [ライブモード] ボタンを有効にするかどうかを指定します。
  • [トリガの許可]: Web HMI アプリケーションで [トリガ] ボタンを有効にするかどうかを指定します。
  • [画像調整の許可]: Web HMI アプリケーションで画像ツールバーを有効にするかどうかを指定します。

関連項目

Web HMI の設定

EasyView の設定

HMI ビューの選択

ウェブブラウザビューを開く

Web HMI 表示

Version: 5.6.0


[画像の設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[画像の設定] ダイアログでは、ライブ画像およびオンライン画像の解像度とフレームレート、および画像の取り込みで使用する解像度を設定します。

注:
  • ライブ取り込みとオンライン画像の設定は、In-Sight Explorer ユーザインタフェースに送信される画像にのみ適用され、ビジョンシステムの画像取り込みには適用されません。
  • [解像度] オプションは、In-Sight Micro 1500、In-Sight 7600、In-Sight 7800、In-Sight 7802 ビジョンシステム、および In-Sight 2000-130 と In-Sight 2000-130C ビジョンセンサのみで使用できます。

[画像 の設定] ダイアログを表示するには

  • [センサ] メニューで、[画像の設定] をクリックします。

[画像の設定] ダイアログの設定項目

[ライブ取り込み] (ライブビデオ):

  • [解像度]: In-Sight Explorer ユーザインタフェースに表示されるライブ画像のフル、ハーフおよびクォーター解像度。
  • [ビット深度]: カラー画像を表示するビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [16 ビット])。

注: このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。

  • [最大レートを制限する]: このチェックボックスを ON にすると、[ライブ画像] の [最大レート] テキストボックスが有効になります。

    注:このオプションは、In-Sight ファームウェア 4.x.x を搭載している In-Sight ビジョンシステムでのみ有効にできます。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは無効になります。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • [最大レート (フレーム/秒)]: ビジョンシステムが 1 秒間に送信可能な最大画像数を指定します (0.016 ～ 100)。この機能を使用すると、画像の送信数を制限することによってネットワークトラフィックを軽減することができます。

    注: このオプションは、[最大レートを制限する] チェックボックスがオンの場合にのみ有効になります。

[オンライン] (オンラインモード)

  • [解像度]: In-Sight Explorer ユーザインタフェースに表示されるライブ画像の最適化、フル、ハーフおよびクォーター解像度。

    注: In-Sight ファームウェア 4.x.x が実行されている In-Sight を使用する場合は、最適化により、手動トリガではフルサイズ画像が返され、カメラまたは連続トリガではハーフ解像度の画像が返されます。In-Sight 5.1.0 以降が実行されているビジョンシステムを使用する場合は、最適化により、速度を考慮して In-Sight Explorer に送信される画像の解像度が最適化されます。

  • [ビット深度]: カラー画像を表示するビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [16 ビット])。

注: このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。

  • [最大レートを制限する]: このチェックボックスを ON にすると、[オンライン] の [最大レート] テキストボックスが有効になります。

    注: このオプションは、In-Sight ファームウェア 4.x.x を搭載している In-Sight ビジョンシステムでのみ有効にできます。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは無効になります。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • [最大レート (フレーム/秒)]: ビジョンシステムが 1 秒間に送信可能な最大画像数を指定します (0.016 ～ 100)。この機能を使用すると、画像の送信数を制限することによってネットワークトラフィックを軽減することができます。

    注: このオプションは、[最大レートを制限する] チェックボックスがオンの場合にのみ有効になります。

[Acquisition (画像取り込み)]

  • [解像度]: 画像取り込みで使用する解像度を指定します。変更を有効にするには、ビジョンシステムを再起動する必要があります。[Acquisition (画像取り込み)] の [解像度] オプションは、以下のビジョンセンサとビジョンシステムでのみ指定できます。

    In-Sight モデル オプション デフォルト
    In-Sight Micro 1500

    800 × 600

    640 × 480

             640 × 480

    In-Sight 2000-130、2000-130C

    800 × 600

    640 × 480

             640 × 480
    In-Sight 2000-23M

    800 × 600

    640 × 480

             800 × 600
    In-Sight 7600、7600C、7800、7800C、7900、7900C

    800 × 600

    640 × 480

             800 × 600
    In-Sight 7802、7802C、7902、7902C

    1600 × 1200

    800 × 600 (低照明モード)

             1600 × 1200

    注:
    • In-Sight 2000-130、2000-130C または 2000-23M ビジョンセンサで解像度 640 × 480 を使用する場合、[画像拡大モード] は、[画像の設定] アプリケーションステップで有効化および無効化することができます。In-Sight 2000-130、2000-130C または 2000-23M ビジョンセンサで解像度 800 × 600 を使用する場合、[画像拡大モード] は常に有効であり、無効にすることはできません。詳細については、EasyBuilder ヘルプをご参照ください。
    • In-Sight 7802、7802C、7902 および 7902C で 800 × 600 (低照明モード) を使用すると、低い解像度で照明感度を高めることができます。
    • サポートされる露光、取り込み開始行および行数は、選択した画像取り込み解像度に応じてさまざまです。

[フォーカス]

注: このグループボックスは、In-Sight 2000 Mini シリーズのビジョンセンサへの接続時にのみ表示されます。

  • [ジョブロード時にフォーカスを上書き]: ビジョンセンサが、Easy Builder の [画像の設定] アプリケーションステップの [フォーカス] タブで設定した [フォーカス距離 (%)] 設定を優先するかどうかを指定します。デフォルトでは、このチェックボックスはオフ (無効) になっています。オンにすると、[設定] ボタンが有効になります。
  • [設定] ボタン: クリックすると、[現在のフォーカス距離 (%)] の値と一致するように [フォーカス距離の上書き (%)] の値が設定されます。
  • [現在のフォーカス距離 (%)]: ビジョンセンサのファームウェアに保存されている現在のフォーカス距離 (%) の値が表示されます。
  • [フォーカス距離の上書き (%)]: ジョブをロードするときに使用するフォーカス距離 (%) の値が表示されます。
Version: 5.6.0


[画像バッファ] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス
  • の概要[画像バッファ] ダイアログ
  • の表示[画像バッファ] ダイアログ
  • [画像バッファ] ダイアログの設定項目
  • 関連項目

の概要[画像バッファ] ダイアログ

[画像バッファ] ダイアログでは、[バッファモード] パラメータで [オーバーラップ] が選択されている場合に、起動時に In-Sight ビジョンシステムに割り当てる画像バッファの数を設定します。各ビジョンシステムには、画像取り込みおよびスプレッドシートや関数の実行において利用可能なデフォルトの画像バッファ数が設定されています。利用可能な最初のバッファは、画像取り込みに使用されます。取り込みが完了すると、ほかのバッファがロックされ、次の取り込みに使用されます。バッファされた画像はスプレッドシートに送信され、ジョブが実行されます。バッファは、ジョブが実行されるまでロックされたままです。一部の関数 (WriteImageFTP や WriteSMTP など) では、ジョブが実行された後もバッファがロックされたままになりますが、スプレッドシートでは、関数のバッファがロックされていても別のバッファされた画像を受け入れることができます。ジョブが実行中の場合、または (In-Sight Explorer または VisionView アプリケーションから) 表示するためのキューに画像が入っている場合、バッファされた画像がキューに入れられます。

注:

  • での画像バッファの数の設定は、[画像バッファ] ダイアログ ファームウェアバージョン 4.6.0 以降が実行されているビジョンシステムでのみサポートされます。ビジョンシステムでファームウェアバージョン 4.5.0 以前が実行されている場合は、ネイティブモードの拡張コマンド SetSystemConfig() を使用して画像バッファの数を設定する必要があります。
  • [カメラトリガ] モードでは、トリガを受信しても画像取り込みにバッファを利用できなければ、画像取り込みは実行されません。また、ディスクリート出力ラインが　[エラー: 画像取り込みミス] を使用するように設定されている場合、この信号は、バッファが使用可能になるまで画像取り込みごとに発信されます。
  • ビジョンシステムが、利用可能な画像バッファの最大数を使用するように設定されていて、ビジョンシステムがオンラインのときにセンサフィルムストリップを使用するようにも設定されている場合、フィルムストリップをビジョンシステムに保存するために利用可能なメモリが十分にないことがあります。この場合は、画像バッファの数を最大値より少なくします。

の表示[画像バッファ] ダイアログ

  • [センサ] メニューで、[画像バッファ] をクリックします。

[画像バッファ] ダイアログの設定項目

スライダコントロールを使用して、起動時にビジョンシステムに割り当てる画像バッファの数を設定することができます。画像バッファのデフォルト数と最大数は、ビジョンシステムの解像度と RAM サイズによって異なります。変更を有効にするには、ビジョンシステムを再起動する必要があります。

注:

  • ビジョンシステムの RAM サイズを調べるには、[In-Sight のネットワーク] ペイン内でビジョンシステムを右クリックして、[プロパティ] をクリックします。[プロパティ] ダイアログで、[メモリ] タブを選択します。
  • 画像バッファの数を増やすと、ジョブのロードや画像の取り込みなど、そのほかのタスクで使用できる RAM の量が減り、パフォーマンスが低下する場合があります。
  • [HMI の設定] ダイアログの [最大ビュー接続数] が 2 以上に設定されている場合は、追加の画像バッファが自動的に In-Sight ビジョンシステムに割り当てられます。例えば、[最大ビュー接続数] が 2 に設定され、[画像バッファ] が 3 に設定されている場合には、5 つの画像バッファがビジョンシステムに割り当てられます。画像バッファの合計数がビジョンシステムで利用可能な画像バッファの最大数を超える場合は、画像バッファの最大数がビジョンシステムに割り当てられます。

In-Sight ビジョンシステム

In-Sight モデル | 解像度 (ピクセル) | RAM | 画像バッファのデフォルト数 | 画像バッファの最大数
In-Sight Micro 1020、1050、1100、1110、1400、1410 | 640 × 480 | 128MB | 6 | 25
In-Sight Micro 1020、1050、1100、1110、1400、1410 | 640 × 480 | 256MB | 12 | 25
In-Sight Micro 1100C、1400C (128MB RAM) | 640 × 480 | 128MB | 3 | 6
In-Sight Micro 1100C、1400C | 640 × 480 | 256MB | 6 | 25
In-Sight Micro 1402、1412 | 1280 × 1024 | 256MB | 12 | 25
In-Sight Micro 1403、1413 | 1600 × 1200 | 128MB | 3 | 6
In-Sight Micro 1403、1413 | 1600 × 1200 | 256MB | 12 | 25
In-Sight Micro 1403C | 1600 × 1200 | 128MB | 3 | 6
In-Sight Micro 1403C | 1600 × 1200 | 256MB | 6 | 16
In-Sight Micro 1500 | 640 × 4801 | 256MB | 12 | 25
 | 800 × 6001 |  | 12 | 25
5100、5110、5400、5410 | 640 × 480 | 256MB | 12 | 25
5100C、5400C | 640 × 480 | 256MB | 6 | 25
5403、5413 | 1600 × 1200 | 256MB | 12 | 25
5600、5610 | 640 × 480 | 128MB | 6 | 25
5600、5610 | 640 × 480 | 256MB | 12 | 25
5603、5613 (128MB RAM) | 1600 × 1200 | 128MB | 3 | 6
5603、5613 | 1600 × 1200 | 256MB | 12 | 25
ラインスキャン 5604、5614 | 1024 × 2048 | 128MB | 6 | 6
 | 1024 × 8192 |  | 5 | 6
ラインスキャン 5604、5614 | 1024 × 2048 | 256MB | 6 | 25
 | 1024 × 8192 |  | 6 | 16
5605、5615 | 2448 × 2048 | 256MB | 6 | 16
5705、5715 | 2448 × 2048 | 512MB | 12 | 25
5705C | 2448 × 2048 | 512MB | 8 | 16
7010、7020、7050、7200、7210、7230、7400、7410、7430 | 800 × 600 | 256MB | 12 | 25
7010C、7200C、7400C | 800 × 600 | 256MB | 6 | 25
7402、7412、7432 | 1280 × 1024 | 256MB | 12 | 25
7402C | 1280 × 1024 | 256MB | 6 | 25
7600、7800、7900 | 800 × 6001 | 512MB | 12 | 25
 | 640 × 4801 |  | 12 | 25
7600C、7800C、7900C | 800 × 6001 | 512MB | 8 | 25
 | 640 × 4801 |  | 8 | 25
7801、7901 | 1280 × 1024 | 512MB | 12 | 25
7801C、7901C | 1280 × 1024 | 512MB | 8 | 25
7802、7902 | 1600 × 1200 | 512MB | 12 | 25
 | 800 × 600 (低照明モード)1 |  | 12 | 25
7802C、7902C | 1600 × 1200 | 512MB | 8 | 16
 | 800 × 600 (低照明モード)1 |  | 8 | 25
7905 | 2448 × 2048 | 512MB | 12 | 25
7905C | 2448 × 2048 | 512MB | 8 | 16
8200、8400 | 640 × 480 | 512MB | 12 | 25
8200C、8400C | 640 × 480 | 512MB | 6 | 25
8401 | 1280 × 1024 | 512MB | 12 | 25
8401C | 1280 × 1024 | 512MB | 6 | 25
8402 | 1600 × 1200 | 512MB | 12 | 25
8402C | 1600 × 1200 | 512MB | 6 | 25
8405 | 2592 × 1944 | 512MB | 6 | 25
1解像度は、[画像の設定] ダイアログで設定できます。

In-Sight 2000 シリーズビジョンセンサ

In-Sight モデル | 解像度 (ピクセル) | RAM | 画像バッファのデフォルト数 | 画像バッファの最小数 | 画像バッファの最大数
2000-110 & 2000-120 | 640 × 480 | 128MB | 6 | 3 | 25
2000-1301 | 640 × 480 | 128MB | 6 | 3 | 25
 | 800 × 600 |  | 3 | 3 | 6
2000-120C | 640 × 480 | 128MB | 3 | 3 | 6
2000-130Ci1 | 640 × 480 | 128MB | 3 | 3 | 6
 | 800 × 600 |  | 3 | 3 | 6
2000-23M | 800 × 600 | 128MB | 3 | 3 | 6

1解像度は、[画像の設定] ダイアログで設定できます。

関連項目

AcquireImage 関数

[ラインスキャンの設定] ダイアログ

[ディスクリート I/O の設定] ダイアログ

Version: 5.6.0


TestRun™

In-Sight Explorer GUI リファレンス

TestRun™ は、マシンビジョンアプリケーションが想定されるパラメータの範囲内で動作していることを確認するのに使用します。TestRun は、In-Sight ビジョンシステムでテストを実行し、その結果を想定される値と比較します。

注: TestRun を使用できるのは、フルアクセス権限を持つユーザのみです。

TestRun は、In-Sight ビジョンシステムに関する次のテストから構成されます。

  • 限界テスト: パラメータのリストを参照して、現在の値が、該当するパラメータに対して設定されている上限値と下限値の間に収まっているかどうかを判別します。このパラメータ値を設定するには、ジョブ内のオペレータ I/F 関数、ジョブに読み取られたディスクリート入力値、または通信プロトコルを介して外部デバイスから送信された値を使用します。
  • 画像テスト: 該当する品質の画像 (「良好」および「不良」) のセットをビジョンシステムに送信し、各画像の現在のジョブ結果が想定される結果と一致しているかどうかを判別します。
  • ハードウェアテスト: ビジョンシステムが取り込んだ画像の品質を想定される画像品質と比較し、カメラの位置、フォーカス、照明などが変化したかどうかを判別します。

In-Sight ビジョンシステムをテストする理由

マシンビジョンアプリケーションは非常に複雑であり、オペレータが調整可能なパラメータ、相互に関係する検査ツール、および想定される結果に影響を与える環境変数が多数存在します。In-Sight ビジョンシステムをテストすることは、システムの一部分に変更を加えてもほかの部分の動作には影響を与えないことを保証する「ベースライン」を提供することになります。例えば、日中に窓から絶えず差し込む環境光によって露出が過度になり、想定される結果に影響を与える場合があります。

製造現場の工場マネージャは、TestRun を使用することによって、ビジョン検査システムが欠陥を検出し、良好な部品を不合格にしていないことを確認することができます。また、ビジョンシステムのエンジニアは、TestRun を使用することによって、システムに新しいツールを追加したときの性能を即座に確認することができます。さらに、メンテナンス技術者は、TestRun を使用することによって、パラメータの調整具合を即座にチェックすることができます。このため、ある領域で行った調整が、そのほかのツールに問題を引き起こしていないかどうかを確認することができます。

TestRun の設定

TestRun では、次の前提が必要です。

  • マシンビジョンアプリケーションは既に開発済みで、.job ファイルとして In-Sight ビジョンシステムに保存されている。
  • In-Sight Explorer 内で、ビジョンシステムへの接続が確立されており、.job ファイルがロードされている。
  • アプリケーションで使用する画像を含む画像データベースが作成されている。

注: 画像データベースに、「良好」画像 (合格した画像) および「不良」画像 (不合格の画像) の両方の例が含まれているのが理想的です。TestRun は、さまざまなファイル規格構造を持つ画像データベースで動作可能です。ただし、TestRun を起動する前に、画像を「良好」および「不良」のフォルダにソートしておくと、それ以降のプロセスが単純化されます。

EasyBuilder ビューおよびスプレッドシートビューで開発したジョブ

In-Sight Explorer には、In-Sight マシンビジョンアプリケーション (.job ファイル) の開発用に、EasyBuilder ビューおよびスプレッドシートビューという 2 つの異なるプログラミング環境が用意されています。TestRun は、いずれの環境で開発された .job ファイルでも動作します。ただし、使用した開発環境に応じて、TestRun の設定には多少の違いがあります。例えば、TestRun は、参照としてシンボリックタグを基にしています。EasyBuilder 開発環境では、シンボリックタグは、ジョブが構築されたときに自動的に作成されます。一方、スプレッドシート環境では、通常セル参照が使用されます (TestRun には、シンボリックタグを自動的に作成する機能があります)。

以下のトピックでは、それぞれの開発環境での TestRun の構成および設定を説明しています。

  • TestRun - EasyBuilder ビュー
  • TestRun - スプレッドシートビュー


ジョブサイズ制限

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[ジョブサイズ制限] ダイアログを使用して、EasyBuilder 開発環境で使用するために特定の In-Sight ビジョンシステムで利用することができるジョブサイズのメモリ割り当てを設定します。

注: ジョブサイズは、ジョブが開発された開発環境によって異なります。EasyBuilder 開発環境で開発されたジョブの場合、3 つの列で使用可能で残されている行の数として領域が計算されます。スプレッドシート開発環境で開発されたジョブの場合、割り当てられたジョブ領域内のまだ使用可能な未使用のセルの数に基づいて領域が計算され、[アクティブセル制限] ダイアログを使用してセルの数を設定します。

[Job Size (ジョブサイズ)]ジョブサイズ制限ダイアログを表示するには

[センサ] メニューで [ジョブサイズ制限] を選択します。

注:

[ジョブサイズ制限] メニューオプションは、以下の場合に無効となります。

  • In-Sight ビジョンシステムがオンラインの場合、または画像を再生している場合。
  • In-Sight ビジョンシステムがライブビデオになっている場合。
  • ユーザが [位置決め] または [検査] アプリケーションステップを実行中の場合。
  • ユーザに十分な管理権限がない場合。
  • In-Sight ビジョンシステムが、ジョブサイズの調整をサポートしていない場合。

ジョブにツールを追加しているときに、ジョブメモリについてのエラーメッセージ (「ジョブにこのツールを実行するための十分なメモリがありません。」) が表示された場合に、[ジョブサイズの調整] ボタンを押して、このダイアログにアクセスすることも可能です。

ジョブサイズ制限ダイアログの設定項目

スライダコントロールを使用して、In-Sight ビジョンシステムのメモリ割り当てを設定することができます。スライダを調整して、ジョブのメモリサイズの割り当てを設定します。In-Sight ビジョンシステムのジョブサイズ制限を調整するには、ビジョンシステムを再起動する必要があります。再起動を行うと、すべてのジョブと設定ファイルが不揮発性フラッシュメモリから消去されます。続行する前に、ジョブを保存するかバックアップしてください。

注:
  • ジョブサイズ制限の更新中は、ビジョンシステムの電源を入れ直さないでください。
  • 最小パーセンテージおよび最大パーセンテージは、In-Sight ビジョンシステムのタイプによって異なります。


ライセンス

In-Sight Explorer GUI リファレンス

パスワード保護は、ジョブファイル内の個々のセル、または一定範囲のセルに適用可能です。セルがパスワードで保護されている場合、セルの数式は非表示にされて編集できません。セルの値または関数は [数式バー] に「***」として表示されます。In-Sight ライセンスジェネレータを使用して、単一または複数のビジョンシステム用に 1 つのライセンスを生成します。生成されたライセンスは、[ライセンス] ダイアログを使用してビジョンシステムに追加できます。ライセンスがビジョンシステムに追加されると、ジョブファイルの実行においてパスワード保護されたセルと結果が表示されますが、セルの数式は非表示のままになり、編集できません。

セルへのパスワード保護の追加

単一ビジョンシステムへのライセンスの追加

複数のビジョンシステムへのサイトライセンスの追加

パスワード保護されたセルへのテンポラリアクセス

セルからのパスワード保護の削除

ビジョンシステムからのライセンスの削除

注:
  • 正当なライセンスなしにパスワード保護されたセルを含むジョブをビジョンシステムにロードすると、セルには「#ERR」と表示されます。 Closed 「#ERR」と表示されているセルの上にマウスを置くか、または GetErrorString 関数を使用して、「#ERR」と表示されているセルの診断情報を返します。対応するライセンスがビジョンシステムに存在しない場合は、「A license is required to run this cell (このセルを実行するにはライセンスが必要です)」というエラーメッセージが返されます。
  • [ライセンス] ダイアログで適切なパスワードを入力することによって、パスワード保護されたセルを編集するためのテンポラリアクセス権を取得できます。
  • 1 つのジョブファイルで複数のパスワードを使用して異なるセルまたは一定範囲のセルを保護することができます。ジョブファイルに含まれているパスワードごとに、対応するライセンスを作成する必要があります。ライセンスによって保護されたセルのみを実行します。
  • いずれかのライセンス処理を実行するには、ビジョンシステムの管理権限が必要です。
  • エミュレータで保護されたセルを実行するためのライセンスは不要です。

セルへのパスワード保護の追加

  1. EasyBuilder View または Spreadsheet View を使用してジョブを開発します。

警告: EasyBuilder 環境でジョブが作成および開発されると、EasyBuilder 固有のスプレッドシートが自動的に作成され、EasyBuilder スニペットによってプログラムされます。これらの自動生成された EasyBuilder スニペットが格納されているセルは、EasyBuilder ジョブと干渉する可能性があるため保護しないでください。

  2. スプレッドシートビューで、保護するセルをハイライト表示します。

注: 空白のセルは保護されません。保護されたセルを削除すると、保護されない空白のセルになります。

  3. [フォーマット] メニューで、[セル] をクリックして [セルのフォーマット] ダイアログを開きます。
  4. [保護] タブをクリックします。

  5. [パスワード] フィールドにパスワードを入力します。
  6. [パスワードの確認] フィールドにパスワードを再入力します。
  7. [OK] ボタンをクリックします。セルの数式が非表示になり、編集できなくなります。セルの値または関数は、[数式バー] に「***」として表示されます。ジョブファイルは、そのジョブを実行する任意のビジョンシステムに配信することができます。次に、以下のセクションの説明に従ってライセンスを追加し、パスワード保護されたセルの実行を有効にすることができます。
  8. ジョブファイルを保存します。

単一ビジョンシステムへのライセンスの追加

  1. Windows の [スタート] メニューを開き、[すべてのプログラム] → [Cognex] → [In-Sight] → [In-Sight x.x.x] → [In-Sight ライセンスジェネレータ] をクリックして、In-Sight ライセンスジェネレータを開きます。
  2. [パスワード] フィールドに、ジョブのセルをパスワード保護するために使用したパスワードを入力します。
  3. [MAC ID] フィールドにビジョンシステムの MAC アドレスを入力します。
  4. [Generate License (ライセンスの生成)] ボタンをクリックします。

  5. [クリップボードにコピー] ボタンをクリックしてライセンスをコピーします。
  6. In-Sight Explorer からビジョンシステムに接続します。
  7. [センサ] メニューで、[ライセンス] をクリックして [ライセンス] ダイアログを開きます。
  8. [新規ライセンスの入力] フィールドを右クリックし、[貼り付け] を選択してライセンスをそのフィールドに貼り付けます。接続されているビジョンシステムの MAC アドレスを使用してライセンスが生成されなかった場合は、警告が表示されます。

注: [EasyBuilder ライセンス] ダイアログに、[テンポラリパスワードの入力] フィールドは含まれません。

  9. [追加] ボタンをクリックします。
  10. [閉じる] ボタンをクリックします。これで、セルが実行されて結果が表示されますが、セルの数式は非表示のままになって編集できなくなります。

複数のビジョンシステムへのサイトライセンスの追加

  1. Windows の [スタート] メニューを開き、[すべてのプログラム] → [Cognex] → [In-Sight] → [In-Sight x.x.x] → [In-Sight ライセンスジェネレータ] をクリックして、In-Sight ライセンスジェネレータを開きます。
  2. [パスワード] フィールドに、ジョブのセルをパスワード保護するために使用したパスワードを入力します。

注: 複数のビジョンシステムで使用されることになるライセンスを作成する場合、MAC ID を入力する必要はありません。

  3. [Site License (サイトライセンス)] チェックボックスをオンにします。

  4. [Generate License (ライセンスの生成)] ボタンをクリックします。

  5. [クリップボードにコピー] ボタンをクリックしてライセンスをコピーします。
  6. In-Sight Explorer からビジョンシステムに接続します。
  7. [センサ] メニューで、[ライセンス] をクリックして [ライセンス] ダイアログを開きます。
  8. [新規ライセンスの入力] フィールドを右クリックし、[貼り付け] を選択してライセンスをそのフィールドにコピーします。

注: [EasyBuilder ライセンス] ダイアログに、[テンポラリパスワードの入力] フィールドは含まれません。

  9. [追加] ボタンをクリックします。
  10. [閉じる] ボタンをクリックします。これで、セルが実行されて結果が表示されますが、セルの数式は非表示のままになって編集できなくなります。
  11. ジョブファイルを保存します。これで、ジョブとサイトライセンスをほかのビジョンシステムに配信できます。

パスワード保護されたセルへのテンポラリアクセス

[ライセンス] ダイアログで適切なパスワードを入力することによって、パスワード保護されたセルを編集するためのテンポラリアクセス権を取得できます。テンポラリアクセス権は、別のジョブファイルをロードするときに、または In-Sight Explorer を使用してビジョンシステムから切断されるときに失効します。

  1. [センサ] メニューで、[ライセンス] をクリックして [ライセンス] ダイアログを開きます。

  2. [テンポラリパスワードの入力] フィールドに、ジョブにパスワード保護を追加するために使用したパスワードを入力します。

注: [EasyBuilder ライセンス] ダイアログに、[テンポラリパスワードの入力] フィールドは含まれません。

  3. [入力] ボタンをクリックします。そのパスワードに関連付けられたすべてのセルがアクセス可能になります。
  4. [閉じる] ボタンをクリックします。

セルからのパスワード保護の削除

  1. スプレッドシートビューで、保護されたセルをハイライト表示します。
  2. キーボードで Delete キーを押してセルの内容をクリアします。セルの値と数式が削除され、セルの保護が取り除かれます。
  3. ジョブファイルを保存します。

ビジョンシステムからのライセンスの削除

  1. In-Sight Explorer からビジョンシステムに接続します。
  2. [センサ] メニューで、[ライセンス] をクリックして [ライセンス] ダイアログを開きます。
  3. 削除するライセンスをハイライト表示します。

  4. [削除] ボタンをクリックします。そのライセンスがリストから削除されます。
  5. [閉じる] ボタンをクリックします。
  6. ジョブファイルを保存します。そのライセンスはビジョンシステムから削除されます。


[システム] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

  • EasyBuilder ビュー
  • スプレッドシートビュー

EasyBuilder ビュー

[システム] メニューを使用すると、複数の In-Sight センサに対してファイル操作を実行することができます。また、このメニューには、In-Sight Explorer に関する機能やオプションも含まれています。[センサ/デバイスをネットワークに追加] ダイアログを使用すると、ネットワーク上で動作するように、または PC と直接通信するように、新規または既存のセンサを設定できます。

[システム] メニュー項目

  • [ログオン/ログオフ]: [ログオン/ログオフ] ダイアログを表示します。このダイアログによって、ユーザ名とパスワードを In-Sight Explorer に対して入力したり、すべてのセンサからログオフしたりすることができます。
  • [レポート作成]: 1 つまたは複数の In-Sight センサのジョブやセンサ設定を記述した XML ファイルを生成します。
  • [バックアップ]: [バックアップ] ダイアログを表示します。このダイアログを使用すると、すべてのジョブ、画像、およびセンサ設定のコピーをローカル PC のフォルダに保存することができます。これらの圧縮バックアップを保存するフォルダは、[オプション] ダイアログで定義されています。
  • [リストア]: [リストア] ダイアログを表示します。このダイアログを使用すると、最後に保存したバックアップから 1 つまたは複数のセンサにジョブ、画像、およびセンサ設定をリストアできます。
  • [選択してリストア]: [ここからリストア] ダイアログを表示します。このダイアログを使用すると、1 つの In-Sight センサに任意のバックアップ (異なるセンサを含む) をリストアすることができます。
  • [クローン作成]: 複製元 In-Sight センサから、1 つまたは複数の複製先 In-Sight センサに、ジョブ、画像、およびセンサ設定を複製します。
  • [ファームウェアアップデート]: [ファームウェアアップデート] ダイアログを使用して、1 つまたは複数の In-Sight センサにファームウェアファイルを書き込みます。
  • [センサ/デバイスをネットワークに追加]: [センサ/デバイスをネットワークに追加] ダイアログを表示します。このダイアログでは、TCP/IP サブネットでの通信、または PC への直接接続について、新規および既存の In-Sight センサを設定することができます。
  • [Explorer のホストテーブル]: [Explorer のホストテーブルの設定] ダイアログを表示します。このダイアログを使用すると、In-Sight Explorer が、異なるサブネット上の In-Sight センサと通信できるようになります。Explorer のホストテーブルのエントリは、自動的に検出されるセンサと同じように、[In-Sight のネットワーク] ペインに表示されます。
  • [リモートサブネット]: [エクスプローラリモートサブネットリスト] ダイアログを表示します。ここでは、In-Sight Explorer が、リモートサブネットを追加および管理することができます。
  • [表示レイアウトを保存]: 現在開いているすべての EasyBuilder ビューおよびセンサステータスビューのスナップショットを生成し、この 2 つのビューの画面上での配置を記憶します。次回の EasyBuilder の起動時に、指定されたセンサやエミュレータにログオンし、各ビューをレイアウトの保存時と同じように配置します。

ヒント: Shift+F7 キーを押すことによって、レイアウトを保存することもできます。

注: ツールバーやペインのドッキングが解除されているときにレイアウトを保存すると、これらが正常に表示されないことがあります。レイアウトを保存する前に、ツールバーやペインをすべてドッキングしておくことを推奨します。

  • [オプション]: [オプション] ダイアログを表示します。このダイアログを使用すると、In-Sight Explorer の起動、GUI、およびエミュレータの環境を設定することができます。

スプレッドシートビュー

[システム] メニューを使用すると、複数の In-Sight センサに対してファイル操作を実行することができます。また、このメニューには、In-Sight Explorer に関する機能やオプションも含まれています。[センサ/デバイスをネットワークに追加] ダイアログを使用すると、ネットワーク上で動作するように、または PC と直接通信するように、新規または既存のセンサを設定できます。

[システム] メニュー項目

  • [ログオン/ログオフ]: [ログオン/ログオフ] ダイアログを表示します。このダイアログによって、ユーザ名とパスワードを In-Sight Explorer に対して入力したり、すべてのセンサからログオフしたりすることができます。
  • [レポート作成]: 1 つまたは複数の In-Sight センサのジョブやセンサ設定を記述した XML ファイルを生成します。
  • [バックアップ]: [バックアップ] ダイアログを表示します。このダイアログを使用すると、すべてのジョブ、画像、およびセンサ設定のコピーをローカル PC のフォルダに保存することができます。これらの圧縮バックアップを保存するフォルダは、[オプション] ダイアログで定義されています。
  • [リストア]: [リストア] ダイアログを表示します。このダイアログを使用すると、最後に保存したバックアップから 1 つまたは複数のセンサにジョブ、画像、およびセンサ設定をリストアできます。
  • [選択してリストア]: [ここからリストア] ダイアログを表示します。このダイアログを使用すると、1 つの In-Sight センサに任意のバックアップ (異なるセンサを含む) をリストアすることができます。
  • [クローン作成]: 複製元 In-Sight センサから、1 つまたは複数の複製先 In-Sight センサに、ジョブ、画像、およびセンサ設定を複製します。
  • [ファームウェアアップデート]: [ファームウェアアップデート] ダイアログを使用して、1 つまたは複数の In-Sight センサにファームウェアファイルを書き込みます。
  • [センサ/デバイスをネットワークに追加]: [センサ/デバイスをネットワークに追加] ダイアログを表示します。このダイアログでは、TCP/IP サブネットでの通信、または PC への直接接続について、新規および既存の In-Sight センサを設定することができます。
  • [Explorer のホストテーブル]: [Explorer のホストテーブルの設定] ダイアログを表示します。このダイアログを使用すると、In-Sight Explorer が、異なるサブネット上の In-Sight センサと通信できるようになります。Explorer のホストテーブルのエントリは、自動的に検出されるセンサと同じように、[In-Sight のネットワーク] ペインに表示されます。
  • [リモートサブネット]: [エクスプローラリモートサブネットリスト] ダイアログを表示します。ここでは、In-Sight Explorer が、リモートサブネットを追加および管理することができます。
  • [表示レイアウトを保存]: 現在開いているすべてのスプレッドシートビューおよびセンサステータスビューのスナップショットを生成し、この 2 つのビューの画面上での配置を記憶します。次回の In-Sight Explorer の起動時に、指定されたセンサやエミュレータにログオンし、各ビューをレイアウトの保存時と同じように配置します。

ヒント: Shift+F7 キーを押すことによって、レイアウトを保存することもできます。

注: ツールバーやペインのドッキングが解除されているときにレイアウトを保存すると、これらが正常に表示されないことがあります。レイアウトを保存する前に、ツールバーやペインをすべてドッキングしておくことを推奨します。

  • [オプション]: [オプション] ダイアログを表示します。このダイアログを使用すると、In-Sight Explorer の起動、GUI、およびエミュレータの環境を設定することができます。


[ログオン/ログオフ] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[ログオン/ログオフ] ダイアログでは、個々の In-Sight ビジョンシステムへのログオンに使用するユーザ名とパスワードを設定します。

このダイアログを使用して、すべてのビジョンシステムからログオフすることもできます。デフォルトでは、In-Sight Explorer は、admin というユーザ名と空白パスワードを使用してビジョンシステムにログオンします。[オプション] ダイアログで定義されたスタートアップユーザ名およびパスワードが、[ユーザアクセス設定] ダイアログで定義されたユーザ名およびパスワードと一致しない場合に In-Sight Explorer を起動すると、[ログオン/ログオフ] ダイアログが表示されます。

In-Sight Explorer は、ジョブの編集および表示機能に加えて、バックアップ、リストア、レポート作成、ファイル管理などの管理サービスも提供します。これらの管理サービスを使用するには、FTP やネイティブモードプロトコルを使用して In-Sight ビジョンシステムに接続する必要があります。これらの機能は常に利用可能なものとして表示されますが、操作の開始時にビジョンシステムごとにユーザ認証が確認され、現在のユーザ名に基づき、現在のユーザの各ビジョンシステムにおけるアクセスレベルに応じて、これらの機能の実行が許可または拒否されます。

In-Sight ビジョンシステムへのログオン

  1. [システム] メニューで、[ログオン/ログオフ] をクリックします。

  2. ユーザ名とパスワードを入力します。
  3. 入力したユーザ名とパスワードを、次回ログオンするときのために記憶させる場合は、[パスワード保存] チェックボックスをオンにします。デフォルトでは、このオプションはオフになっているため、システムにログオンするたびにパスワードを入力する必要があります。
  4. [ログオン] ボタンをクリックして完了します。前の手順で入力したユーザ名とパスワードを使用して、個々の In-Sight ビジョンシステムにログオンします ([In-Sight ネットワーク] ペインのビジョンシステム名をダブルクリックするとログオンできます)。

注: ビジョンシステムにログオンしてユーザ名またはパスワードを変更すると、新しいユーザ情報を認証できないビジョンシステムとの接続が切断される場合があります。

ログオンが完了すると、ログオンを開始した In-Sight ビジョンシステムでのユーザのアクセスレベルにかかわらず、アクセス先のシステムのユーザリストでユーザ名に対して指定されたアクセスレベルが有効になります。


[レポート作成] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[レポート作成] ダイアログでは、ネットワーク上の 1 つまたは複数の In-Sight センサまたはエミュレータのネットワーク構成とジョブの詳細が文書化された、HTML または XML ベースの出力ファイルを生成できます。

1 つまたは複数の In-Sight センサのレポートを生成するには

  1. [システム] メニューで、[レポート作成] をクリックします。

  2. レポートに含めるすべての In-Sight センサをハイライト表示します。
  3. [Files of type (ファイル形式)] ドロップダウンメニューで、出力ファイル形式 ([HTML] または [XML]) を選択します。
  4. [レポート作成] をクリックします。
  5. レポートのファイル名を入力します。
  6. [保存] をクリックします。


[バックアップ] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[バックアップ] ダイアログにより、In-Sight センサまたはエミュレータでのジョブ、画像およびセンサ設定のアーカイブコピーを、PC のハードディスクやビジョンシステムに装着されている SD カードに保存することができます。[ネットワークの設定] は、バックアップ内に保存されますが、バックアップを作成したときと同じセンサにリストアする場合にのみリストアできます。

PC へのバックアップ

アーカイブされたデータの In-Sight ビジョンシステム/エミュレータの宛先フォルダ、つまりバックアップディレクトリは、[オプション] ダイアログで定義します。In-Sight Explorer がビジョンシステムまたはエミュレータからのデータをアーカイブすると、バックアップディレクトリに、ビジョンシステムのホスト名と名前が同じで、その名前に「.000」から始まる数値サフィックスが付加されたフォルダが作成されます。その特定のセンサのバックアップがすでに存在する場合は、数値サフィックスの値が増分されます (is5400_010203.000、is5400_010203.001など)。

注:
  • 最大 1,000 件のバックアップを In-Sight センサに保存可能です。
  • ホスト名でコロンを 1 つ以上使用するビジョンシステムをバックアップすると、結果のフォルダ名にはコロンの代わりにプラス記号 (+) が使用されます。Windows ではフォルダ名にコロンを使用できないため、これは予期される挙動です。
  • 通常、バックアップ処理は、ファイル転送処理により時間が重要なジョブのパフォーマンスが影響を受ける可能性があるため、In-Sight ビジョンシステムがオフラインの間に実施する必要があります。時間が重要ではないジョブの場合は、[オプション] ダイアログ内の [オンラインでもバックアップを行う] チェックボックスをオンにすることによってオンラインバックアップを有効にすることができます。
  • オンラインセンサでバックアッププロセスが進行している場合、センサのステータスは一時的に [image] に変更されます。バックアップが完了すると、ステータスは [image] に戻ります。

  • [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。

    • Windows 7/Windows 10:
      C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x

ビジョンシステムに装着された SD カードへのバックアップ

SD カードにはバックアップが 1 つだけ保存されます。その後のバックアップでは、前のバックアップが上書きされるからです。

注: ビジョンシステムは、SD カードにバックアップするために、オフラインになっている必要があります。

[バックアップ] ダイアログを表示するには

  • [システム] メニューで、[バックアップ] をクリックします。

[バックアップ] ダイアログの使用法

  1. 左側にあるチェックボックスをオンにすることによって、バックアップするビジョンシステム/センサまたはエミュレータを選択します。SD カードにバックアップする場合は、[SD カードを使用] チェックボックスをオンにします。

    注:
    • 目的のビジョンシステム/センサまたはエミュレータは、検索ボックスを使用して動的にサーチすることができます。
    • [SD カードを使用] チェックボックスは、ビジョンシステムに SD カードが装着されている場合にのみ有効になります。
    • SD カードが装着されているビジョンシステムを選択しても、[SD カードを使用] チェックボックスがオフの場合、バックアップデータは PC にアーカイブされます。
  2. [バックアップ] をクリックします。
Version: 5.6.0


[リストア] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[リストア] ダイアログでは、In-Sight ビジョンシステム/センサまたはエミュレータから、ジョブ、画像、およびセンサ設定のアーカイブされたコピーを取得できます。これらの情報は、[リストア] ダイアログに表示される前に、ローカル PC にバックアップされる必要があります。このダイアログではまた、In-Sight ビジョンシステムに装着された SD カードに保存されているバックアップを取得することもできます。

PC からのリストア

アーカイブされたバックアップは、[オプション] ダイアログで定義する [バックアップディレクトリ] からリストアされます。In-Sight Explorer は、In-Sight ネットワークからセンサ名が一致するサブフォルダをすべて探し、それらのサブフォルダを [リストア] ダイアログに表示します。

注:
  • アーカイブされたビジョンシステム/センサの最新のバックアップのみが [リストア] ダイアログのリストに表示されます。古いバックアップからリストアする場合、または別のビジョンシステム/センサからのバックアップをリストアする場合は、代わりに [選択してリストア] ダイアログを使用します。
  • [リストア] 機能を実行するには、ビジョンシステム/センサをオフラインにする必要があります。オンラインのビジョンシステム/センサのリストアを試みると、センサをオフラインにすることについての警告ダイアログが表示されます。
  • リストア時、ビジョンシステム/センサまたはエミュレータ上の同じ名前の既存のファイルが、現在のネットワーク設定を含めて上書きされます。リストア対象の一連のファイルに含まれていない既存のファイルは上書きされません。
  • ビジョンシステム/センサがリストアされるとき、ユーザリストはクリアされません。したがって、ビジョンシステム/センサがリストアされる前にユーザリストに追加したユーザ名は、リストア後もビジョンシステム/センサに保存されています。ビジョンシステム/センサがリストアされた後で、ユーザリストからユーザを手動で追加または削除してください。

  • [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。

    • Windows 7/Windows 10:
      C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x

In-Sight ビジョンシステムに装着された SD カードからのリストア

SD カードにある最新のバックアップが In-Sight ビジョンシステムにリストアされます。

注:
  • SD カードからリストアするためには、ビジョンシステムがオフラインになっている必要があります。
  • SD カードにはバックアップが 1 つだけ保存されます。その後のバックアップでは、前のバックアップが上書きされるからです。
  • SD カード上のバックアップは、SD カードが装着されている In-Sight ビジョンシステムにのみリストア可能です。

[リストア] ダイアログを表示するには

  • [システム] メニューで、[リストア] をクリックします。

[リストア] ダイアログの使用法

  1. 左側にあるチェックボックスをオンにすることによって、リストアするビジョンシステム/センサまたはエミュレータを選択します。SD カードからリストアする場合は、[SD カードを使用] チェックボックスをオンにします。

    注:
    • 目的のビジョンシステム/センサまたはエミュレータは、検索ボックスを使用して動的にサーチすることができます。
    • [SD カードを使用] チェックボックスは、ビジョンシステムに SD カードが装着されており、PC で選択したビジョンシステムのバックアップが存在する場合にのみ有効になります。
    • ビジョンシステムに SD カードが装着されていない場合、[SD カードを使用] チェックボックスは無効になります。ビジョンシステムに SD カードが装着されていても、PC 上に選択したビジョンシステムのバックアップが存在しなければ、[SD カードを使用] チェックボックスがオンになって無効になります。
    • SD カードが装着されているビジョンシステムを選択しても、[SD カードを使用] チェックボックスがオフの場合、アーカイブされたデータは PC からリストアされます。アーカイブ先 (PC または SD カード) の詳細については、「[バックアップ] ダイアログ」を参照してください。
  2. [リストア] をクリックします。


[選択してリストア] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[選択してリストア] ダイアログでは、以下のデータを取得できます。

  • In-Sight ビジョンシステム/エミュレータのジョブ、画像、および設定データの最新のアーカイブ。
  • In-Sight ビジョンシステム/エミュレータのジョブ、画像、および設定データの古いアーカイブコピー。
  • 別の In-Sight ビジョンシステム/エミュレータからのアーカイブ。
  • ビジョンシステムに装着された SD カードからのバックアップ

PC からのリストア

In-Sight ビジョンシステム/センサ上のアーカイブされたバックアップは、[オプション] ダイアログで定義する [バックアップディレクトリ] からリストアされます。In-Sight Explorer は、In-Sight ネットワークからセンサ名が一致するサブフォルダをすべて探し、それらのサブフォルダを [リストア] ダイアログに表示します。

そのビジョンシステムが一度だけバックアップされている場合は、右側のペインにその名前のインスタンスが (フォルダ [image] アイコン付き) 1 つだけ表示されます。そのセンサのバックアップが複数回実行されている場合は、センサ名の後に増分値が続く形式の名前 (is5401_010203.000、is5401_010203.001 など) で追加のフォルダが表示されます。最大の数字が対象のセンサの最新バックアップに対応します。

注:
  • [選択してリストア] 機能を実行するためには、ビジョンシステム/センサをオフラインにする必要があります。オンラインのビジョンシステム/センサのリストアを試みると、センサをオフラインにすることについての警告ダイアログが表示されます。
  • 異なるビジョンシステム/センサのアーカイブから In-Sight ビジョンシステム/センサをリストアする場合は、両方のセンサのモデルが異なっていると　(例えば、In-Sight 5400C のアーカイブから In-Sight Micro 1400 ビジョンシステムにリストアを試みる場合)、予期せぬ動作が引き起こされる可能性があります。例えば、リストア元の In-Sight ビジョンシステム/センサのいくつかのジョブ機能は、リストア先の In-Sight ビジョンシステム/センサではサポートされていないという場合もあります
  • リストア時、ビジョンシステム/センサまたはエミュレータ上の同じ名前の既存のファイルが、現在のネットワーク設定を含めて上書きされます。リストア対象の一連のファイルに含まれていない既存のファイルは上書きされません。
  • ビジョンシステム/センサがリストアされるとき、ユーザリストはクリアされません。したがって、ビジョンシステム/センサがリストアされる前にユーザリストに追加したユーザ名は、リストア後もビジョンシステム/センサに保存されています。ビジョンシステム/センサがリストアされた後で、ユーザリストからユーザを手動で追加または削除してください。

  • [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。

    • Windows 7/Windows 10:
      C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x

In-Sight ビジョンシステムに装着された SD カードからのリストア

SD カードにある最新のバックアップが In-Sight ビジョンシステムにリストアされます。

注:
  • SD カードからリストアするためには、ビジョンシステムがオフラインになっている必要があります。
  • SD カードにはバックアップが 1 つだけ保存されます。その後のバックアップでは、前のバックアップが上書きされるからです。
  • SD カード上のバックアップは、SD カードが装着されている In-Sight ビジョンシステムにのみリストア可能です。

[選択してリストア] ダイアログを表示するには

  • [システム] メニューで、[選択してリストア] をクリックします。

[選択してリストア] ダイアログの使用法

  1. バックアップからファイルを取り込むビジョンシステムまたはエミュレータを左側のペインから選択します。一度に選択できるビジョンシステムまたはエミュレータは 1 つだけです。
  2. 右側のペインで、リストアするバックアップの場所を選択します。

    1. [SD カード]: 最後のバックアップがリストアされます。

      注: [SD カード] オプションは、左側のペイン ([Select In-Sight Sensor to Restore (リストアする In-Sight センサを選択)] リストボックス) で SD カードが装着されている In-Sight ビジョンシステムが選択されている場合にのみ有効になります。
    2. [バックアップセット]: リストからアーカイブを選択します。
  3. [選択してリストア] をクリックします。


[クローン作成] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[クローン作成] ダイアログを使用すると、ジョブと画像データ (およびほとんどのビジョンシステム設定) を、クローン元の In-Sight ビジョンシステムから、1 台または複数のクローン先 In-Sight ビジョンシステムにコピーできます。

注:
  • [ホスト名]、[DHCP サーバを使用]、[IP アドレス]、[サブネットマスク]、[デフォルトゲートウェイ]、[DNS サーバ]、および [ドメイン名] 設定は、クローン先ビジョンシステムにコピーされません。
  • ビジョンシステムのクローンを作成しても、ユーザリストはクリアされません。したがって、ビジョンシステムのクローンを作成する前にユーザリストに追加したユーザ名は、リストア後もビジョンシステムに保存されています。ビジョンシステムのクローンを作成した後で、ユーザリストからユーザを手動で追加または削除してください。

[クローン作成] ダイアログを表示するには

  • [システム] メニューで、[クローン作成] をクリックします。

[クローン作成] ダイアログの使用法

  1. クローン元として使用するビジョンシステムを左側のリストから選択します。
  2. クローン元ビジョンシステムからファイルのコピーを受け取る 1 台または複数のビジョンシステムを、右側のペインから選択します。
  3. [クローン作成] をクリックします。


[ファームウェアアップデート] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[ファームウェアアップデート] ダイアログは、最新バージョンの In-Sight ファームウェアを In-Sight ビジョンシステムにロードするために使用します。サポートされるファームウェアのバージョンについては、ここをクリックしてください。

  • ファームウェアの更新
  • トラブルシューティング

ファームウェアの更新

注:
  • In-Sight ビジョンシステムのファームウェアを更新するには、フルアクセスのアクセス権を持つユーザとしてログオンする必要があります。

  • このダイアログは、I/O モジュールのファームウェアの更新、または別のネットワーク上に存在し、[In-Sight ホストテーブル] を使用して In-Sight Explorer に追加された In-Sight ビジョンシステムのファームウェアの更新をサポートしていません。ただし、[エクスプローラリモートサブネットリスト] を使用して In-Sight Explorer に追加される、異なるネットワーク上に存在するビジョンシステムのファームウェアは更新可能です。Cognex では、ファームウェアの更新時にはビジョンシステムをローカルネットワークに配置して、ネットワーク障害を防止するようお勧めします。

警告! ファームウェアの更新中は、デバイスの電源を入れ直さないでください。

  1. インストールマニュアルの指示に従って In-Sight ビジョンシステムをネットワークに接続します。
  2. In-Sight Explorer を起動します。
  3. 任意で、ファームウェアの更新に進む前に、各ビジョンシステムをバックアップします。

注: ファームウェアの更新プロセスでは、すべてのジョブと設定ファイルが In-Sight の不揮発性メモリから消去されます。In-Sight Explorer は、ファームウェアを更新する前にすべてのジョブと設定の一時的なコピーを生成しますが、ファームウェアの更新プロセスを開始する前にこれらのファイルを手動でバックアップすることを推奨します。

  4. 次のことを確認します。
  • 更新するすべてのビジョンシステムがオフラインになっている
  • 更新するビジョンシステムにほかのユーザがログオンしていない
  • 各ビジョンシステムに新規ジョブがロードされている

注: [強制アップデート] を使用して、対象のビジョンシステムをオフラインにし、フォームウェアの更新プロセス中はターゲットのビジョンシステムからほかのユーザを切り離すことができます。

  5. [システム] メニューで、[ファームウェアアップデート] をクリックします。

  6. ビジョンシステムのチェックボックスをオンにすることにより、更新対象の In-Sight ビジョンシステムを選択します。

    注:
    • [New Version (新バージョン)] 列には、ビジョンシステムにインストールされるファームウェアのバージョンが表示されます。インストールされるファームウェアのバージョンは、ビジョンシステムのモデルタイプに応じて異なります。ビジョンシステムは、サポートされる最新のファームウェアバージョンにのみ更新可能です。例えば、In-Sight 1000 シリーズのビジョンシステムは、サポートされる最新のファームウェアバージョンであるバージョン 4.x.x にのみ更新可能です。一方、In-Sight 8405 ビジョンシステムは、現行バージョンに更新できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

    • PC に複数のバージョンの In-Sight Explorer ソフトウェアがインストールされている場合は、[New Version (新バージョン)] 列のドロップダウンを使用して別のバージョンにファームウェアをアップグレードまたはダウングレードできます。例えば、PC に In-Sight Explorer 5.4.0 および 5.6.0 がインストールされている場合は、In-Sight 2000 シリーズのビジョンセンサのファームウェアを 5.6.0 または 5.4.0 にアップグレードまたはダウングレードするか、In-Sight 1000 シリーズのビジョンシステムのファームウェアを 4.10.5 または 4.10.4 にアップグレードまたはダウングレードできます。

    • [New Version (新バージョン)] 列に異なるファームウェアバージョンが表示されているとしても、複数のビジョンシステムを同時に更新することができます。
    • モデルタイプの前に「Faulted」が付加されている場合 (「Faulted 8405」など) は、ビジョンシステムでファームウェアの更新プロセスを完了することができず、使用不可の状態になっていることを示します。この場合は、ビジョンシステムを DHCP サーバに接続し、ファームウェアの更新を再試行して、この状態から復旧する必要があります。

    ヒント:
    • サーチボックスを使用して、[名前]、[モデル]、[バージョン] の各列の情報に基づいて、ビジョンシステムを動的にフィルタすることが可能です。ビジョンシステムはステータスに基づいてフィルタされません。
    • 複数の連続しないビジョンシステムを選択するには、CTRL キーを押したままツールをハイライト表示し、ハイライト表示したチェックボックスの 1 つをオンにします。
    • 連続する複数のツールを選択するには、Shift キーを押したまま最初のビジョンシステムハイライト表示し、次にリストの最後のツールをハイライト表示して、それからハイライト表示したチェックボックスの 1 つをオンにします。
  7. 必要に応じて、次のチェックボックスをオンにします。

    • [強制アップデート]: オンにすると、In-Sight Explorer は、ビジョンシステムをオフラインにし、ほかのユーザをビジョンシステムから切り離すか、またはすべてのバックアップエラーを無視します。デフォルトでは、このチェックボックスはオフになっており、ビジョンシステムがオンラインの場合、ほかのユーザがログオンした場合、またはバックアップエラーが発生した場合には、ファームウェアの更新が中止されます。

      注:
      • ファームウェアの更新前にジョブを保存してください。[強制アップデート] チェックボックスをオンにすると、未保存のジョブはファームウェアの更新プロセス中に消失します。
      • ビジョンシステムは、強制的にオフラインにされた場合には、ファームウェアの更新が完了すると同時に再びオンラインに戻ります。
      • ビジョンシステムから強制的に切り離されたユーザは、ファームウェアの更新が完了すると同時に再びビジョンシステムに接続されます。
    • [バックアップおよびリストアの無効化]: オンにすると、ファームウェアはファイルをバックアップおよびリストアすることなく更新されます。デフォルトでは、このチェックボックスはオフになっており、バックアップとリストアの処理が実行されます。バックアップエラーが発生すると、ファームウェアの更新は中止されます。
  8. [次へ] をクリックします。
  9. ダイアログのリストにある各ビジョンシステムが新しいファームウェアに更新されることを確認します。

  10. [更新] をクリックします。

  11. すべてのビジョンシステムが更新されて再起動されたら、[OK] をクリックして [ファームウェアアップデート] ダイアログを閉じるか、または [Go Back (戻る)] をクリックしてほかのビジョンシステムのファームウェアの更新を続行します。ファームウェアの更新に失敗した場合は、[Go Back (戻る)] をクリックし、[強制アップデート] および/または [バックアップおよびリストアの無効化] チェックボックスをオンにして、もう一度ファームウェアを更新します。

    注: ファームウェアの更新に失敗した場合、バックアップファイルは　[オプション] ダイアログで指定した [バックアップディレクトリ] 内に保持されます。

トラブルシューティング

エラーメッセージ

ファームウェアの更新プロセスの実行時にエラーが発生する場合は、In-Sight ビジョンシステムの電源を入れ直して、ファームウェアの更新をやり直してください。

使用可能なフラッシュメモリの不足

ファームウェアの更新を試みているときに多数の関数を含むジョブが In-Sight ビジョンシステムにロードされると、使用可能なフラッシュメモリが不足するために更新が中断されることがあります。このような場合は、以下の操作を実行します。

  1. ビジョンシステムがオフラインであることを確認します。
  2. 新規ジョブをロードします ([ファイル] メニューの [ジョブの新規作成] をクリック)。
  3. ファームウェアの更新をもう一度実行します。

In-Sight ビジョンシステムのジョブがメモリの空き容量を大量に消費すると、使用可能なフラッシュメモリが不足するためにファームウェアの更新が中断されることがあります。このような場合は、以下の操作を実行します。

  1. ビジョンシステムからジョブファイルを削除します。
  2. ファームウェアの更新をもう一度実行します。

注: In-Sight 70xx ～ 74xx シリーズのビジョンシステム上で使用可能なフラッシュメモリ容量は、In-Sight 4.7.0 ファームウェアでは 256MB であったのに対し、In-Sight 4.7.1 以降のファームウェアでは 512MB に増加しました。したがって、In-Sight 70xx ～ 74xx シリーズのビジョンシステムのファームウェアを 4.7.1 以降から 4.7.0 にダウングレードするときに、データ量が 256MB 以上ある場合は、リストア中に 1 つまたは複数のファイルが正しくコピー & ペーストされない可能性があります。proc.set ファイルが正しくリストアされない場合、PC のバックアップディレクトリから proc.set ファイルをコピーし、ビジョンシステム上の不必要なファイルを削除してから、proc.set ファイルをディレクトリに貼り付けてください。

関連項目

エラーメッセージ

Version: 5.6.0


ファームウェアのバージョン

In-Sight Explorer GUI リファレンス

次の表は、In-Sight モデル番号、不揮発性フラッシュメモリの量 (利用可能な場合)、部品番号/製品タイプ、およびサポートされているファームウェアのバージョンをまとめたものです。

  • In-Sight ファームウェアバージョン 4.x.x 以前
  • In-Sight ファームウェアバージョン 5.x.x 以降
注:
  • 最後の対応ファームウェアがバージョン「4.9.x」であるモデルは、ファームウェアバージョン 5.1.0 以降にアップグレードすることはできません。
  • 末尾が「R」の部品番号/製品タイプは、RoHS 指令に適合していることを示します。

In-Sight ファームウェアバージョン 4.x.x 以前

In-Sight モデル | 部品番号/ 製品タイプ | 最初の対応ファームウェア | 最後の対応ファームウェア
1000 1010 1000C (4MB の不揮発性フラッシュメモリ) | 800-5740-1 800-5749-1 800-5760-1 | 2.00.00 2.00.00 2.20.00 | 2.71.00 PR1
3000 (4MB の不揮発性フラッシュメモリ) | 800-5747-1 | 2.00.00 | 2.52.03
4000 4100 4001 (8MB の不揮発性フラッシュメモリ) | 800-5762-1 800-5763-1 800-5770-1 | 2.30.00 | 2.71.00 PR1
3400 (16MB の不揮発性フラッシュメモリ) | 800-5809-1 | 2.51.00 | 4.2.0
5100 5110 (16MB の不揮発性フラッシュメモリ) | 800-5834-1/2/3 800-5854-1 | 2.53.00 | 4.2.0
5400 5410 (16MB の不揮発性フラッシュメモリ) | 800-5828-1/2/3 | 2.53.00 | 4.2.0
5101 5111 (16MB の不揮発性フラッシュメモリ) | 800-5838-1/2/3 | 2.65.00 | 4.2.0
5100C (16MB の不揮発性フラッシュメモリ) | 800-5837-1/2/3 | 2.65.00 | 4.2.0
5000 (16MB の不揮発性フラッシュメモリ) | 800-5840-1/2/3 | 2.70.00 | 4.2.0
5400C 5400CS (16 MB の不揮発性フラッシュメモリ) | 800-5837-1/2/3 | 2.80.00 | 4.2.0
5401 5411 (16MB の不揮発性フラッシュメモリ) | 800-5838-1/2/3 | 2.80.00 | 4.2.0
5403 5403S (16MB の不揮発性フラッシュメモリ) | 800-5830-1/2/3 | 2.80.00 | 4.2.0
5000 (32MB の不揮発性フラッシュメモリ) | 800-5840-4/5/6 | 2.80.01 PR1 | 4.2.0
5400R (32MB の不揮発性フラッシュメモリ) | 800-5829-1/1R | 2.80.01 PR1 | 4.5.0
5100 5110 (32MB の不揮発性フラッシュメモリ) | 800-5870-1/1R/2/2R/3/3R | 2.80.01 PR1 | 4.7.3
5400 5410 5400S 5410S (32MB の不揮発性フラッシュメモリ) | 800-5855-1/1R/2/2R/3/3R | 2.80.01 PR1 | 4.7.3
5400C 5400CS (32MB の不揮発性フラッシュメモリ) | 800-5837-4/4R/5/5R/6/6R | 2.80.01 PR1 | 4.7.3
5401 5411 (32MB の不揮発性フラッシュメモリ) | 800-5838-4/4R/5/5R/6/6R | 2.80.01 PR1 | 4.7.3
5403 5413 5403S (32MB の不揮発性フラッシュメモリ) | 800-5830-4/4R/5/5R/6/6R | 2.80.01 PR1 | 4.7.3
5100C (32MB の不揮発性フラッシュメモリ) | 800-5837-4/4R/5/5R/6/6R | 3.4.0 | 4.7.3
5600 5610 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 800-5871-1/1R/2/2R/3/3R | 3.4.0 | 4.10.x
5603 5613 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 800-5873-1/1R | 3.4.0 | 4.10.x
In-Sight Micro 1020 1050 1100 1110 1400 1410 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0002-1R タイプ 821-0002-5R | 4.1.0 | 4.10.x
In-Sight Micro 1403 1413 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0003-1R タイプ 821-0003-5R | 4.1.0 | 4.10.x
CIO-MICRO I/O モジュール | タイプ 821-0016-1R タイプ 821-0016-2R | 4.2.0 | 4.9.3
CIO-MICRO-CC I/O モジュール | タイプ 821-0017-1R タイプ 821-0017-2R | 4.3.0 | 4.9.3
In-Sight Micro 1100C 1400C (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0002-2R タイプ 821-0002-6R | 4.3.0 | 4.10.x
In-Sight Micro 1403C (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0003-2R タイプ 821-0003-6R | 4.3.0 | 4.10.x
5604 (64MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 800-5874-1R タイプ 800-5874-2R | 4.3.1 | 4.10.x
5605 5615 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0032-1R タイプ 821-0032-2R | 4.4.1 | 4.10.x
5100 5110 5400 5410 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0034-1R | 4.4.3 | 4.10.x
5100C 5400C (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0036-1R | 4.4.3 | 4.10.x
5400S 5410S (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0038-1R | 4.4.3 | 4.10.x
5400CS (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0039-1R | 4.4.3 | 4.10.x
5401 5411 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0035-1R | 4.4.3 | 4.10.x
5403 5413 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0037-1R | 4.4.3 | 4.10.x
5403S (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0040-1R | 4.4.3 | 4.10.x
5600 5610 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0041-1R | 4.4.3 | 4.10.x
5603 5613 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0042-1R | 4.4.3 | 4.10.x
5604 5614 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0051-1R | 4.4.3 | 4.10.x
In-Sight Micro 1020 1050 1100 1110 1400 1410 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0043-1R | 4.4.3 | 4.10.x
In-Sight Micro 1100C 1400C (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0044-1R | 4.4.3 | 4.10.x
In-Sight Micro 1403 1413 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0047-1R | 4.4.3 | 4.10.x
In-Sight Micro 1403C (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0048-1R | 4.4.3 | 4.10.x
In-Sight Micro 1402 1412 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | タイプ 821-0078-1R | 4.6.0 | 4.10.x
C マウントレンズ構成: 7010 7020 7050 7200 7210 7230 7400 7410 7430 7402 7412 7432 (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | タイプ 821-0084-1R タイプ 821-0084-3R タイプ 821-0084-5R タイプ 821-0084-9R | 4.9.0 | 4.10.x
M12 レンズ構成: 7010 7020 7050 7200 7210 7230 7400 7410 7430 7402 7412 7432 (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | タイプ 821-0084-2R タイプ 821-0084-4R タイプ 821-0084-6R | 4.9.0 | 4.10.x
C マウントレンズ構成: 7010C 7200C 7400C 7402C (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | タイプ 821-0100-1R タイプ 821-0100-3R | 4.9.0 | 4.10.x
M12 レンズ構成: 7010C 7200C 7400C 7402C (512MB の不揮発性フラッシュメモリ。最大 134.2MB のファイルサイズを利用可能) | タイプ 821-0100-2R タイプ 821-0100-4R | 4.9.0 | 4.10.x
In-Sight Micro 1500 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 規制モデル 1AAN | 4.9.1 | 4.10.x

In-Sight ファームウェアバージョン 5.x.x 以降

In-Sight モデル | 規制モデル | サポートされるファームウェアバージョン
In-Sight 5705 および 5715 (128MB の不揮発性フラッシュメモリ。最大 33.5MB のファイルサイズを利用可能) | 規制モデル 1AAF | 5.1.0 5.2.0 5.3.0 5.4.0 5.5.0 5.6.0
In-Sight 8405 (512MB の不揮発性フラッシュメモリ。最大 234MB のファイルサイズを利用可能) | 規制モデル 1AAU | 5.1.1 5.2.0 5.3.0 5.4.0 5.5.0 5.6.0
In-Sight 8200 8400 8401 8402 (512MB の不揮発性フラッシュメモリ。最大 234MB のファイルサイズを利用可能) | 規制モデル 1AAW | 5.2.0 5.3.0 5.4.0 5.5.0 5.6.0
In-Sight 2000-110 2000-120 2000-130 (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) | 規制モデル R00039 | 5.2.1 5.2.3 5.3.0 5.4.0 5.5.0 5.6.0
In-Sight 2000-120C 2000-130C (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) | 規制モデル R00039 | 5.3.0 5.4.0 5.5.0 5.6.0
In-Sight 7600 7800 7801 7802 (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル 1AAB | 5.4.0 5.5.0 5.6.0
In-Sight 2000-23M | 規制モデル R00039 | 5.5.0 5.6.0
In-Sight 2000-110 Mini 2000-120 Mini 2000-130 Mini 2000-120C Mini 2000-130C Mini (32MB の不揮発性フラッシュメモリ。最大 15.9MB のファイルサイズを利用可能) | 規制モデル 1ABD | 5.5.0 5.6.0
In-Sight 2000-23M Mini | 規制モデル 1ABD | 5.5.0 5.6.0
In-Sight 7600C 7800C 7801C 7802C 7900 7902 (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル 1AAB | 5.5.0 5.6.0
In-Sight 8200C 8400C 8401C 8402C (512MB の不揮発性フラッシュメモリ。最大 234MB のファイルサイズを利用可能) | 規制モデル 1AAW | 5.5.0 5.6.0
In-Sight 7900C 7901 7901C 7902C (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル 1AAB | 5.6.0
In-Sight 7905 7905C (7.2GB の不揮発性フラッシュメモリ。最大 1.0GB のファイルサイズを利用可能) | 規制モデル R00063 | 5.6.0


[センサ/デバイスをネットワークに追加] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[センサ/デバイスをネットワークに追加] ダイアログにより、In-Sight EtherNet デバイスを設定できます。このダイアログを使用して、次の設定を行うことができます。

  • TCP/IP サブネットでの通信、または PC への直接接続用に In-Sight デバイスを設定する。

  • 無効なネットワーク設定で In-Sight デバイスを設定する。これらのデバイスは、自動的に検出されてリストに表示されます。また、このダイアログが開いている時に In-Sight デバイスに電源が再投入されると、そのデバイスはリストに追加されます。

    ヒント: デバイスが自動的にリストに表示されない場合は、[すべて表示] ラジオボタンを選択して、サブネットで検出されたすべての In-Sight デバイスが表示されるようにします。
  • 管理用パスワードをリセットします。
  • In-Sight デバイスを工場出荷時のデフォルト設定にリセットします。
注:
  • [センサ/デバイスをネットワークに追加] の各操作を実行するには、このデバイスに対する管理権限が必要です。
  • ファームウェア 4.1.0 以降が実行されていないデバイスでは、[センサ/デバイスをネットワークに追加] ダイアログの機能の一部が使用できません。最新バージョンへアップグレードすることを推奨します。
  • PC に搭載されているネットワークアダプタにリンクローカル IP アドレスが割り当てられていない場合、一時的なリンクローカル IP アドレスを持つデバイスは自動的に [センサ/デバイスをネットワークに追加] ダイアログに表示されます。このようなデバイスの IP アドレスは、固定または動的 IP アドレスに置き換えることを強く推奨します。
  • リモートネットワーク上のデバイスはこのダイアログには表示されません。リモートネットワーク上のデバイスに接続するには、[システム] メニューの [Explorer のホストテーブル] ダイアログまたは [Explorer Host Table (エクスプローラリモートサブネットリスト)] ダイアログを使用します。

[センサ/デバイスをネットワークに追加] ダイアログの表示

  • [システム] メニューで、[センサ/デバイスをネットワークに追加] をクリックします。または、[In-Sight ネットワーク] ペインで In-Sight センサアイコン [image] を右クリックし、表示されたポップアップメニューから [センサ/デバイスを追加] を選択します。

[センサ/デバイスをネットワークに追加] ダイアログの設定項目

リストでデバイスを選択するまで、このダイアログ内のフィールドは無効のままです。

  • [ホスト名]: ネットワークに接続された In-Sight デバイスの名前を定義します。各デバイスには、初めて起動したときにホスト名が自動的に設定されます。ホスト名を変更するには、このフィールドに変更後の名前を入力します。

    注:

    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、ピリオド (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。
  • [DHCP で IP アドレスを自動的に取得する]: In-Sight デバイスのネットワーク設定が起動時に DHCP サーバによって動的に行われるように指定します。
  • [次のネットワーク設定を使用する]: In-Sight デバイスが以下で設定されるネットワーク設定に従って設定されるように指定します。
    • [IP アドレス]: ローカルネットワークの IP アドレス番号付けルールに従って、ネットワーク上の各 In-Sight デバイスの一意な識別子を指定します。
    • [サブネットマスク]: IP アドレスのどの部分がネットワークを示し、どの部分がホストを示すかを定義します。IP アドレスのネットワーク部分は同じサブネットのすべてのホストにおいて共通しており、残りは各ホスト固有です。
    • [デフォルトゲートウェイ]: ネットワーク上に利用できるゲートウェイホストがある場合、その IP アドレスを指定します。ゲートウェイホストは、別々のネットワーク上のホスト間でデータのリレーを行います。
    • [DNS サーバ]: ネットワーク上に、DNS 解決を提供するホストがあれば、その IP アドレスを指定します。
    • [ドメイン名]: ホストネットワークのネットワークドメインを指定します。

注: ドメイン名は最大 63 文字です。

  • [PC のネットワーク設定をコピーする]: このチェックボックスをオンにすると、In-Sight デバイスのネットワーク設定が、IP アドレスのホスト部分を除き、すべてローカルコンピュータのネットワーク設定に従って構成されます。
  • [管理者パスワードのリセット]: このチェックボックスをオンにすると、In-Sight ビジョンシステムの管理者パスワードが工場出荷時の状態 (空白) にリセットされます。

  • [センサを工場出荷時の状態に初期化する]: このチェックボックスをオンにすると、In-Sight ビジョンシステムの設定がすべて (このダイアログのネットワーク設定を除き) 工場出荷時のデフォルト状態にリセットされます。例えば、ユーザリスト、ディスクリート入出力、日付/時刻、ホストリスト、シリアルおよび FTP 設定はすべてリセットされます。

    注:
    • このオプションは、CIO-MICRO モジュール、および CIO-MICRO-CC I/O モジュールについては無効になっています。
    • In-Sight エミュレータは、[オプション] ダイアログからアクセスできる [初期値に戻す] ダイアログの [エミュレーション] オプションを使用して、工場出荷時の状態にリセットすることができます。
  • [LED 点滅開始]: このボタンをクリックすると、In-Sight デバイス上の LED が点滅を開始するため、見つけやすくなります。同時にボタンのラベルが [LED 点滅停止] に変わります。LED は [LED 点滅停止] をクリックするか、[センサ/デバイスをネットワークに追加] ダイアログを閉じるか、またはリストから別のデバイスを選択するまで点滅を続けます。
  • [更新]: In-Sight デバイスのリストを更新します。
  • [すべて表示]: サブネットで検出されたすべての In-Sight デバイスを表示します。
  • [新規を表示] (デフォルト): サブネット上のネットワーク設定が無効な In-Sight デバイスを表示します。このダイアログが開かれている間にサブネット上で電源が入れ直された In-Sight デバイスもこのリストに追加されます。

不正なネットワーク設定を再構成するには

  1. デバイスが物理的にネットワークに接続されていることを確認します。

  2. [センサ/デバイスをネットワークに追加] ダイアログを開き、リストからデバイスを選択します。デバイスがリストに表示されない場合は、[すべて表示] ボタンを選択するか、デバイスの電源を入れ直します。

    注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムの電源を入れ直す場合、電源の接続を 5 秒以上切断することを推奨します。
  3. ホスト名が正しいことを確認します。

  4. デバイスに動的 IP アドレス、または固定 IP アドレスを使用します。

    動的 IP アドレスを使用する場合:

    1. [DHCP で IP アドレスを自動的に取得する] を選択します。デバイスが DHCP サーバによって起動時に動的に構成されるようになります。

    固定 IP アドレスを使用する場合:

    1. [次のネットワーク設定を使用する] を選択します。
    2. IP アドレスを入力します。
    3. 次のいずれかの操作を行います。
      • [PC のネットワーク設定をコピーする] をクリックします。ローカルコンピュータのサブネットマスク、デフォルトゲートウェイ、DNS サーバ、およびドメイン名が自動的にデバイスに割り当てられます。
      • サブネットマスク、デフォルトゲートウェイ、DNS サーバ、ドメイン名を担当のネットワーク管理者に問い合わせ、手動で入力します。

  5. [適用] をクリックします。

    注: 選択したビジョンシステムでファームウェア 3.4.x 以降が実行されている場合:
    • ビジョンシステムの設定が自動的に工場出荷時の状態にリセットされることを示すダイアログが表示されます。
    • 進行状況バーが表示され、ビジョンシステムの電源を入れ直すことを促すメッセージが表示されます (電源を入れ直すと、手順 8 と 9 で説明されているダイアログは表示されなくなります)。
  8. 確認ダイアログが表示されたら、[OK] をクリックします。
  9. 検証ダイアログが表示されたら、[OK] をクリックします。

In-Sight ビジョンシステム設定を工場出荷時の状態にリセットするには

このオプションを選択すると、In-Sight ビジョンシステムの設定がすべて (このダイアログでのネットワーク設定を除き) 工場出荷時のデフォルト状態にリセットされます。例えば、ユーザリスト、ディスクリート入出力、日付/時刻、ホストリスト、シリアルおよび FTP 設定はすべてリセットされます。また、ビジョンシステムのパスワードを忘れたためにデフォルト (<blank>) に戻す必要がある場合にも、この機能が使用できます。

注:
  • このオプションは、CIO-MICRO モジュール、および CIO-MICRO-CC I/O モジュールについては無効になっています。
  • In-Sight エミュレータは、[オプション] ダイアログからアクセスできる [初期値に戻す] ダイアログの [エミュレーション] オプションを使用して、工場出荷時の状態にリセットすることができます。
  1. デバイスが物理的にネットワークに接続されていることを確認します。

  2. [センサ/デバイスをネットワークに追加] ダイアログを開き、リストからデバイスを選択します。デバイスがリストに表示されない場合は、[すべて表示] ボタンを選択するか、デバイスの電源を入れ直します。

    注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムの電源を入れ直す場合、電源の接続を 5 秒以上切断することを推奨します。
  3. [センサを工場出荷時の状態に初期化する] を選択します。
  4. [適用] をクリックします。
  5. 確認ダイアログが表示されたら、[OK] をクリックします。
  6. 進行状況バーが表示されます。プロンプトが表示されたらビジョンシステムの電源を入れ直し、設定の変更を有効にします。

    7. 注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムの電源を入れ直す場合、電源の接続を 5 秒以上切断することを推奨します。

  7. 検証ダイアログが表示されたら、[OK] をクリックします。

関連項目

ネットワークのトラブルシューティング

Version: 5.6.0


[Explorer のホストテーブルの設定] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[Explorer のホストテーブルの設定] ダイアログでは、In-Sight Explorer から異なるサブネット上のビジョンシステム/センサまたはエミュレータにアクセスし、ビジョンシステム/センサまたはエミュレータのエイリアスを作成することができます。Explorer のホストテーブルのエントリによって、指定された IP アドレスのホストのネットワーク設定が実際に変更されることはありません。これらのエントリは、追加のビジョンシステム/センサまたはエミュレータとして [In-Sight ネットワーク] ペインに表示されるだけです。

警告: DHCP を使用して設定されるセンサは、特定の IP アドレスを持つことを保証できません。Explorer のホストテーブルでは、センサと通信するために固定 IP アドレスを必要とするため、異なるサブネット上のすべてのセンサを固定 IP アドレスを指定して設定することを強くお勧めします。

[Explorer のホストテーブルの設定] ダイアログを表示するには

  • [システム] メニューで、[Explorer のホストテーブル] をクリックします。

[Explorer のホストテーブルの設定] ダイアログの設定項目

  • [追加]: ホストテーブルに新規エントリを作成します。[Add Host (ホストの追加)] ダイアログが表示されます。このダイアログでは、新規ホストのホスト名、IP アドレス、およびデバイスタイプを入力できます。終了したら、[OK] をクリックします。

    注:

    • ホスト名に使用できる文字は、A ～ Z (大文字および小文字)、0 ～ 9、ハイフン (-)、コロン (:)、カンマ (.)、およびアンダースコア (_) です。
    • ホスト名は最大 63 文字です。

  • [編集]: ホストテーブルにある既存のエントリを変更します。リストからエントリを選択して [編集] をクリックします。[Edit Host (ホストの編集)] ダイアログが表示されます。このダイアログでは、選択したホストのホスト名、IP アドレス、またはデバイスタイプを変更できます。終了したら、[OK] をクリックします。

  • [削除]: ホストテーブルからホストを削除します。削除するホストを選択し、[削除] をクリックします。

ヒント: ホストを複数選択するには、CTRL キーを押しながらホスト名を選択します。

ホストのパラメータ

  • [ホスト名]: 指定した IP アドレスにマップする (割り当てる)、ネットワーク接続された In-Sight ビジョンシステム/センサまたはエミュレータの名前。入力したホスト名は、In-Sight インタフェースの全体でホスト名のすべてのリストに表示されます。
  • [IP アドレス]: 指定したホスト名にマップする、ネットワーク接続された In-Sight ビジョンシステム/センサまたはエミュレータの IP アドレス。
  • [センサタイプ]: 指定したホスト名/ IP アドレスにマップする、ネットワーク接続された In-Sight ビジョンシステム/センサまたはエミュレータのデバイスタイプ。指定したデバイスタイプのアイコンがドロップダウンの横に表示されます。


[エクスプローラリモートサブネットリスト] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

リモートサブネットを設定し、[In-Sight ネットワーク] ペインにサブネットを追加して管理します。リモートサブネットワークが設定されていない場合、PC と同じサブネットワークに存在しないビジョンシステムは自動検出時に無視されます。リモートサブネットを設定すると、そのサブネットワークのビジョンシステムは、PC と同じサブネットワークに存在していなくても、PC で検出メッセージが受信されると自動的に In-Sight のネットワークリストに表示されます。

  • [エクスプローラリモートサブネットリスト] ダイアログの設定項目
  • [サブネットの追加/編集] ダイアログの設定項目
  • 関連項目

[エクスプローラリモートサブネットリスト] ダイアログの設定項目

  • [システム] メニューで、[リモートサブネット] をクリックします。

  • [名前]: [In-Sight ネットワーク] ペインに表示されているように、サブネットの名前を表示します。
  • [IP アドレス]: リモートサブネットのネットワーク IP アドレスを表示します。
  • [マスク]: リモートサブネットのサブネットマスクを表示します。
  • [カスタムゲートウェイ]: 必要に応じて、ゲートウェイ IP アドレスを表示します。
  • [追加]: [サブネットの追加] ダイアログを起動します。ここで、サブネット情報を追加します。
  • [編集]: [サブネットの編集] ダイアログを起動します。ここで、以前に作成したサブネットを変更することができます。
  • [削除]: 選択したサブネットをリストから削除します。

[サブネットの追加/編集] ダイアログの設定項目

[サブネットの追加] ダイアログは、[エクスプローラリモートサブネットリスト] で [追加] ボタンをクリックすると起動します。[サブネットの編集] ダイアログは、[エクスプローラリモートサブネットリスト] で既存のサブネットを選択して [編集] ボタンを押すか、リスト内で選択したサブネットをダブルクリックすると起動します。

  • [名前]: [In-Sight ネットワーク] ペインに表示されているように、サブネットのわかりやすい名前を指定します。
  • [IP アドレス]: リモートサブネットのネットワーク IP アドレスを指定します。
  • [マスク]: リモートサブネットのサブネットマスクを指定します。
  • [カスタムゲートウェイの使用]: ネットワークインフラストラクチャでネットワークにルーティングできない場合に、サブネットにアクセスするためにカスタムゲートウェイが必要かどうかを指定します。
  • [ゲートウェイ]: リモートサブネットにアクセスするのに使用するゲートウェイ IP アドレスを指定します。

関連項目

  • POWERLINK 通信
  • POWERLINK ファクトリインタフェース


[オプション] ダイアログ

[システム] メニュー

In-Sight Explorer GUI リファレンス

[オプション] ダイアログを使用すると、In-Sight Explorer のスタートアップおよびデフォルト GUI 環境をカスタマイズしたり、オフライン In-Sight エミュレータを設定したり、ファイルユーティリティ環境を設定したりすることができます。[オプション] ダイアログは、次のオプション設定から構成されます。

  • [アクセス管理]
  • [エミュレーション]
  • [ファイルユーティリティ]
  • [画像ディスプレイ]
  • [ジョブビュー]
  • [記録]
  • ユーザインタフェース

[オプション] ダイアログを表示するには

  • [システム] メニューで、[オプション] をクリックします。

[オプション] ダイアログの設定項目

[初期値に戻す]

[初期値に戻す] ダイアログを使用すると、個別のオプションを In-Sight Explorer の初期値に戻すことができます。例えば、この機能は、表示解像度を変更したために、特定のダイアログがデスクトップの外に出てしまった場合などに有効です。オプションは、選択するチェックボックスによって、カテゴリごとにリストアするか、または一度にすべてをリストアできます。

注: 下記の各カテゴリの画面は、デフォルトの設定を示しています。

[アクセス管理] パネル

  • [Windows のログオン時に In-Sight Explorer を起動する]: このチェックボックスをオンにすると、Microsoft Windows を実行している PC にログオンしたときに、自動的に In-Sight Explorer を起動します。

    注: Windows に標準ユーザとしてログインし、ユーザアカウント制御 (UAC) を無効にしている場合に、[Windows のログオン時に In-Sight Explorer を起動する] オプションを変更しようとすると、[Run As (ファイル名を指定して実行)] ダイアログが表示されます。管理者認証を指定して、操作を続行します。

  • [プログラムの終了を確認する]: このチェックボックスをオンにすると、In-Sight Explorer を終了しようとするたびに確認ダイアログが表示されます。これは、In-Sight Explorer の終了時に、ローカルエミュレータ上のアクティブジョブが失われることを防ぐためです。このチェックボックスをオフにすると、アプリケーションの終了時に確認を求められなくなります。

    注: In-Sight ビジョンシステム上のジョブは、In-Sight Explorer を終了しても失われません。ただし、ジョブを保存せずにビジョンシステムの電源を入れ直すと、保存していないデータは失われます。

  • [スタートアップユーザ名]: In-Sight Explorer の起動時に自動ログオンするユーザ名を指定します。デフォルトでは、admin が選択されています。

  • [スタートアップパスワード]: スタートアップユーザ名に対応するパスワードを指定します。デフォルトでは、このフィールドは空白です。

    注:
    • [オプション] ダイアログのユーザ名およびパスワードは、[ユーザアクセス設定] ダイアログで定義されたユーザ名およびパスワードと一致する必要があります。一致しないと、アプリケーションが起動されたときに [ログオン/ログオフ] ダイアログが表示され、[ユーザアクセス設定] ダイアログで指定したユーザ名とパスワードを入力するよう求められます。
    • ユーザ名とパスワードは最大 15 文字で、どちらも大文字と小文字の区別があります。

  • [終了時にパスワードを要求する]: このチェックボックスをオンにすると、In-Sight Explorer を終了しようとするたびにパスワードの入力を求められます。

    注: このチェックボックスをオフにしようとすると、パスワードの入力を求められます (デフォルトパスワードは空白です)。

  • [パスワードの設定]: [パスワードの変更] ダイアログを開き、In-Sight Explorer 終了時のパスワードを設定します。

[エミュレーション] パネル

  • [エミュレータを使用する]: このチェックボックスをオンにすると、In-Sight オフラインエミュレータというオフラインプログラミング環境を使用できるようになります。エミュレータは、In-Sight Explorer の起動とともに動作を開始します。エミュレータを無効にするには、このチェックボックスをオフにします。

    警告: [エミュレータを使用する] チェックボックスをオフにすると、WriteFTP、WriteImageFTP、制御、またはログ処理を含むすべてのローカル FTP サービスがシャットダウンされます。

  • [モデル]: エミュレータの動作を決定します。ドロップダウンリストには、サポートされるすべての In-Sight ビジョンシステム、およびそれらのビジョンシステムで使用可能なツールと関数が含まれます。

    注:
    • 起動されるエミュレータは、最新のエミュレータを常に起動する標準 (デフォルト) のモデルを除いた、最後にサポートされるバージョンのモデルです。例えば、In-Sight 8405 が選択されたモデルである場合は、5.x.x エミュレータが起動されます。例えば、In-Micro 1400 が選択されたモデルである場合は、4.x.x エミュレータが起動されます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
    • ワーキングエミュレータディレクトリは、エミュレータのバージョン (5.x.x または 4.x.x) に応じて異なります。
      • 5.x.x エミュレータ: [ProgramData]\Cognex\In-Sight\Emulators\5.x.x
      • 4.x.x エミュレータ: [ProgramData]\Cognex\In-Sight\Emulators\4.x.x

      例えば、ジョブが 4.x.x エミュレータ (In-Sight Micro 1400 など) に保存される場合に、エミュレータモデルを 5.x.x (標準、など) に変更すると、そのジョブは、[開く] ダイアログからジョブを開こうとしてもダイアログのリストに表示されません。

    • 上記のワーキングエミュレータディレクトリは、In-Sight Explorer のインストール場所に関係なく使用されます。
    • 画像取り込み関数の一部の機能 (部分取り込み、照明制御など) は、エミュレータではサポートされていません。In-Sight ビジョンシステム上でこれらの機能を使用したジョブを作成し、そのジョブをエミュレータにロードすることは可能ですが、このとき、セル A0 の AcquireImage 関数が #ERR を報告することがあります。
  • [FTP サーバ接続数]: エミュレータが同時に受け入れることのできる FTP 接続要求の最大数を定義します (0 ～ 32、デフォルト = 20)。

  • [FTP ルートディレクトリ]: FTP サービスのパスを指定します。これは、FTP サーバへのアクセスに使用可能で、ファイルと画像にアクセスして保存することができる追加のディレクトリで、これにより、(エミュレータのワーキングディレクトリに加えて) ディレクトリとサブディレクトリを FTP サーバからアクセス可能にすることができます。

    注: このオプションを指定するには、[エミュレータを使用する] チェックボックスをオンにする必要があります。FTP ディレクトリはルートから始まるローカルパス (C:\...) で、ディレクトリへの正当な直接書き込み許可が有効になっている必要があります。FTP ディレクトリも存在する必要があります。[FTP ルートディレクトリ] へのアクセスの試みは、指定されたパスと正確に一致している必要があります。例えば、[FTP ルートディレクトリ] が C:\temp の場合、そのディレクトリへの「abc.txt」ファイルの保存要求のフォーマットは、「put c:\temp\abc.txt」とする必要があります。代わりに、そのコマンドが「put abc.txt」と指定された場合、ファイルはエミュレータのディレクトリに格納されます。

  • [オフラインプログラミングの問い合わせ番号]: PC の設定に基づいて自動的に生成されるコード番号です。この問い合わせ番号を使用して、エミュレータのロックを解除するためのオフラインプログラミングキーを取得できます。

  • [オフラインプログラミングのキー]: In-Sight Explorer がネットワーク上の In-Sight ビジョンシステムをまったく検出しない場合、In-Sight オフラインエミュレータ環境でローカルに In-Sight ジョブを設定するため、オフラインプログラミングのキーをここに入力する必要があります。キーを取得するには、Cognex の Web サイトの In-Sight® キージェネレータのページにアクセスし、画面の指示に従います。

    警告: オフラインプログラミングキーを入力せずに [オプション] ダイアログを閉じると、問い合わせ番号が変更されます。この場合、ダイアログをもう一度開くには、新しいキーを入手する必要があります。

    注:
    • Windows に標準ユーザとしてログインしており、ユーザアカウント制御 (UAC) が無効になっている場合に、オフラインプログラミングキーを入力しようとすると、[Run As (ファイル名を指定して実行)] ダイアログが表示されます。管理者認証を指定して、操作を続行します。
    • いずれかのバージョンの PC Host 用のオフラインプログラミングラインセンスを購入済みの場合は、これらのライセンスを、In-Sight Explorer 用の有効なオフラインプログラミングキーとして使用できます。
  • [ヘルプ]: ソフトウェアの登録に関するヘルプ項目を表示します。

[ファイルユーティリティ] パネル

  • [Explorer の FTP ポート]: ファイルを保存したり開いたりするために、In-Sight Explorer がリモート In-Sight ビジョンシステムへの接続を試みるネットワークポートを定義します。In-Sight ビジョンシステムの [ローカルポート] が [Explorer の FTP ポート] と同じ値に設定されていないと、In-Sight Explorer は、バックアップ、リストア、ファームウェアアップデートなどのファイル操作を実行したり、[In-Sight のファイル] ペインにファイルを表示したりすることができません (1 ～ 65535、デフォルト = 21)。
  • [バックアップディレクトリ]: In-Sight ビジョンシステムやエミュレータのバックアップを格納するローカル PC 上のフォルダを定義します。
注: [バックアップディレクトリ] のデフォルトのフォルダ位置は、Program Files フォルダから次の場所に移動されており、標準ユーザがアクセスすることができます (In-Sight Explorer 4.5.0 以降)。
  • Windows 7/Windows 10: C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x
  • [オンラインでもバックアップを行う]: このチェックボックスをオンにすると、ビジョンシステムがオンラインモードであってもそのビジョンシステムをバックアップできるようになります。オフのときは、オンラインビジョンシステムをバックアップすることはできません。この場合、バックアップ操作を進める前に、ビジョンシステムをオフラインにすることを求めるダイアログが表示されます。

[画像ディスプレイ] パネル

  • [露光過少レベル]: [露光過多・過少を表示] がオンのとき、指定した 8 ビット値 (モノクロの In-Sight ビジョンシステムではグレースケール値、カラーの In-Sight ビジョンシステムでは RGB 成分の最大値) 以下のピクセルが青色で表示されます(0 ～ 255、デフォルト = 5)。
  • [露光過多レベル]: [露光過多・過少を表示] がオンのとき、指定した 8 ビット値 (モノクロの In-Sight ビジョンシステムではグレースケール値、カラーの In-Sight ビジョンシステムでは RGB 成分の最大値) 以上のピクセルが赤色で表示されます(1 ～ 255、デフォルト = 240)。

[ジョブビュー] パネル

  • [スプレッドシートビューをデフォルトにする]: このチェックボックスをオンにすると、In-Sight Explorer を起動したときに、スプレッドシートビューが表示されるようになります。
  • [ロックされた接続]: このチェックボックスがオンのときには、既に別のユーザがビジョンシステムまたはエミュレータにログオンしている場合、そのビジョンシステムまたはエミュレータにリモートからログオンすることはできません。
  • [オンライン/オフライン切り替えの際に確認をする]: このチェックボックスをオンにすると、In-Sight ビジョンシステムのオンライン状態を切り替えようとするたびに確認ダイアログが表示されます。オフにすると、オンライン/オフラインの切り替え時に確認を求められなくなります。
  • [デフォルトの透明度]: 画像やグラフィックスに対するスプレッドシートオーバレイのデフォルトの不透明度を指定します。この値を 0 に設定すると、スプレッドシートオーバレイによって画像やグラフィックスが完全に見えなくなります。値を高くすると、画像やグラフィックスがスプレッドシートを通してより鮮明に表示されるようになります。一時的な変更は [画像] メニューの [オーバレイの透明度] で行うことができます。

注: カスタムビューを設定することによって、スプレッドシートのグリッド線を隠したり、表示されるスプレッドシートのサイズや位置、そのほかの特性を調整したりすることができます。

[記録] パネル

[記録] パネルのオプションは、[記録] オプションを初めて実行するときに、すべてのビジョンシステムおよびエミュレータで使用されるデフォルト設定です。個々のビジョンシステムの記録設定を調整するには、[記録/再生のオプション] ダイアログを使用してください。

ヒント: [記録] パネルは、[記録] オプションを初めて実行する前に、複数のビジョンシステムおよびエミュレータの記録設定を設定するために使用します。 例えば、まだ [記録] オプションを実行したことがない複数のビジョンシステムについて、デフォルトの [記録フォルダ] のディレクトリパスを変更することができます。

  • [記録フォルダ]: 画像を保存するためのディレクトリを指定します。

    注: [記録フォルダ] のデフォルトの場所は、C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x です。
  • [最大保存数]: 記録フォルダに保存する画像の最大数。(1 ～ 10,000、デフォルト = 10,000)。
  • [画像の解像度]: 画像を記録するときのセンサの解像度。記録が完了すると、センサの解像度は [画像の設定] ダイアログで設定した元の設定に戻ります。保存する画像の解像度として指定できるのは、フルアクセス、ハーフ (1/2)、クォーター (1/4) です。デフォルトの解像度はフルアクセスです。

  • [ビット深度]: カラー画像を記録するビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [24 ビット])。

    注:

    • このオプションは、カラー In-Sight ビジョンシステムでのみサポートされます。
    • JPEG (*.jpg) 画像は常に 24 ビット深度で記録されます。16 ビットで記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。
  • [ファイル名のフォーマット]: 記録画像のファイル名のフォーマットとファイルの種類。
    • [接頭語]: 記録画像のファイル名の接頭辞。
    • [フォーマット]: 記録画像のファイル名のフォーマット。[フォーマット] オプションは、[Index] と [DateTime] です。
    • [ファイル形式]: 記録画像のファイルの種類。選択できるファイルの種類は、[ビットマップファイル (*.bmp)] と [JPEG ファイル (*.jpg)] です。
    • 例: [フォーマット] および [ファイル形式] ドロップダウンリストで選択した [ファイル名のフォーマット] オプションに基づいて、記録画像ファイルの命名規則の例が表示されます。

[ユーザインタフェース] パネル

  • [言語]: In-Sight Explorer のインタフェース全体で使用する言語を設定します。変更を有効にするには、In-Sight Explorer を再起動する必要があります。In-Sight Explorer は、英語、日本語、フランス語、ドイツ語、スペイン語、中国語 (簡体字)、および韓国語をサポートしています。
  • [英語シンボリックタグを EasyBuilder で使用]: このチェックボックスをオンにすると、EasyBuilder ジョブのすべてのシンボリックタグを作成できる言語が英語のみになります。この場合、ユーザインタフェースは [言語] パラメータで設定した言語で表示されますが、すべてのシンボリックタグ、位置決めツール、および検査ツールは、デフォルトでは、英語で表示されます。例えば、「Blobs Counting Tool」が追加されると、ツールのシンボリックタグは英語になり (Blob_1.Blob_Count)、デフォルトのツール名も英語になります (Blobs_1)。ジョブ内の既存のツールでこの機能を有効にしても、ツール名は英語に変換されません。
  • [大きいツールバーアイコン]: このチェックボックスをオンにすると、ツールバーアイコンのサイズが大きくなります。
  • [大きいツリーアイコン]: このチェックボックスをオンにすると、[In-Sight ネットワーク]、[In-Sight のファイル]、および [パレット] のアイコンのサイズが大きくなります。
注:
  • [英語シンボリックタグを EasyBuilder で使用] 設定を適切に適用するには、EasyBuilder ビューから [オプション] メニューにアクセスする必要があります。スプレッドシートビューでこの設定を適用しても、この機能は正常に動作しません。この場合、テキストは [言語] パラメータで設定した言語のままで表示されます。
  • [英語シンボリックタグを EasyBuilder で使用] 設定を有効にしてから [取り消し] ボタンをクリックしても、この操作を取り消すことはできません。先に最後に実行した操作を取り消してから、この設定を有効にします。この設定を無効にするには、手動で行う必要があります。
Version: 5.6.0


[ウィンドウ] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[ウィンドウ] メニューでは、EasyBuilder ビュー 、スプレッドシートビューまたは [In-Sight のネットワーク] ペインで選択した In-Sight デバイスのセンサのステータスビューを表示することができます。また、[ウィンドウ] メニューでは、EasyBuilder ビュー、スプレッドシートビュー、またはセンサのステータスビューを開いたすべての In-Sight センサおよびエミュレータが表示されます。[ウィンドウ] メニューでデバイスを選択して、ビューを表示します。

注: EasyBuilder ビューがアクティブでないとき、次の [ウィンドウ] メニューの一部またはすべてが利用できない場合があります。

[ウィンドウ] メニューの項目

  • [表示 EasyBuilder ビュー]: 現在の設定とともに、EasyBuilder GUI から現在の画像を表示します。オンライン/オフラインステータスを示すステータスバーが含まれます。
  • [表示 スプレッドシートビュー]: スプレッドシートビューで、ジョブパラメータがスプレッドシートのフォーマットで表示されます。オンライン/オフラインステータスを示す ステータスバーが含まれます。
  • [表示 センサのステータスビュー]: センサのステータスビューには、マシンステータススタックを構成するメモリバッファに含まれる情報が表示されます。
  • [ウェブブラウザビューを開く]:[ウェブブラウザビューを開く] により、選択された In-Sight ビジョンシステムまたはセンサの Web ベースのヒューマンマシンインタフェース (HMI) にデフォルトのブラウザが開きます。
  • [アイコンの整列]: 複数のウィンドウが最小化されている場合、[アイコンの整列] オプションによって、最小化されたすべてのウィンドウが作業領域の下部でグループ化されます。
  • [水平に並べて表示]: 最小化されていないすべてのウィンドウを水平に並べます。
  • [垂直に並べて表示]: 最小化されていないすべてのウィンドウを垂直に並べます。
  • [重ねて表示]: 最小化されていないすべてのウィンドウを重ねて表示します。

スプレッドシートビュー

[ウィンドウ] メニューでは、EasyBuilder ビュー、スプレッドシートビューまたは [In-Sight のネットワーク] ペインで選択した In-Sight デバイスのセンサのステータスビューを表示することができます。また、[ウィンドウ] メニューでは、EasyBuilder ビュー、スプレッドシートビュー、またはセンサのステータスビューを開いたすべての In-Sight センサおよびエミュレータが表示されます。[ウィンドウ] メニューでデバイスを選択して、ビューを表示します。

注: スプレッドシートビューがアクティブでないとき、次の [ウィンドウ] メニューの一部またはすべてが利用できない場合があります。

[ウィンドウ] メニューの項目

  • [表示 EasyBuilder ビュー]: 現在の設定とともに、EasyBuilder GUI から現在の画像を表示します。オンライン/オフラインステータスを示すステータスバーが含まれます。このコマンドは、このビューをサポートするエミュレータまたはセンサが [In-Sight のネットワーク] ペインで選択されている場合に有効になります。
  • [表示 スプレッドシートビュー]: In-Sight センサの現在の画像と半透明のスプレッドシートオーバレイ、またはカスタムビュー (オプション) が表示されます。オンライン/オフラインステータスを示すステータスバーが含まれます。複数のセンサのスプレッドシートビューを同時に表示することができます。
  • [表示 センサのステータスビュー]: センサのステータスビューには、マシンステータススタックを構成するメモリバッファに含まれる情報が表示されます。
  • [ウェブブラウザビューを開く]:[ウェブブラウザビューを開く] により、選択された In-Sight ビジョンシステムまたはセンサの Web ベースのヒューマンマシンインタフェース (HMI) にデフォルトのブラウザが開きます。
  • [アイコンの整列]: 複数のウィンドウが最小化されている場合、[アイコンの整列] オプションによって、最小化されたすべてのウィンドウが作業領域の下部でグループ化されます。
  • [水平に並べて表示]: 最小化されていないすべてのウィンドウを水平に並べます。
  • [垂直に並べて表示]: 最小化されていないすべてのウィンドウを垂直に並べます。
  • [重ねて表示]: 最小化されていないすべてのウィンドウを重ねて表示します。


EasyBuilder ビュー

[ウィンドウ] メニュー → [表示 EasyBuilder ビュー]

EasyBuilder GUI リファレンス

EasyBuilder ビューは EasyBuilder の中心にあります。ジョブパラメータは、このビューの表示内容に基づいて設定および編集されます。

EasyBuilder ビューは、次の 3 つの部分で構成されています。

  • タイトルバー: ここには、アクティブなジョブのビジョンシステム名とファイル名が表示されます。
  • 表示領域: ここは In-Sight ビジョンシステムからのアクティブな画像で構成されます。
  • ステータスバー: 割り当てられたサイズの割合 (%) としての現在使用可能なジョブサイズ (この値を変更するには [ジョブサイズ制限] ダイアログを使用します) と、アクティブな In-Sight ビジョンシステムのオンライン/オフラインステータスを示します。
注:
  • ジョブを PC からドラッグ＆ドロップすると、ジョブをビジョンシステムに保存するまで、タイトルバーには「EasyBuilder ビュー」と表示されます。ジョブを保存すると、ファイル名が表示されます。
  • 画像のショートカットを表示領域または [In-Sight のファイル] ペインにドラッグすることはできません。ショートカットではなく、元のコピー元画像を目的の場所にドラッグしてください。
  • EasyBuilder では、GUI 内に、EasyBuilder ビュー、スプレッドシートビューおよびセンサステータスビューなどの複数のビューを表示できます。ただし、スプレッドシートビュー、またはセンサステータスビューをクリックすると、GUI は EasyBuilder から選択したビューに対応するインタフェースに切り替わります。
  • 同時に表示できるビューの数は、PC のハードウェア (主に CPU の動作速度とメモリ容量) によって異なります。ジョブが特に複雑である場合は、7 個以上のウィンドウを開くと、メモリのリソースを上回り、予期しない動作を引き起こす可能性があります。


スプレッドシートビュー

[ウィンドウ] メニュー → [表示 スプレッドシートビュー]

In-Sight Explorer GUI リファレンス

In-Sight Explorer のグラフィカルユーザインタフェース (GUI) の中心的なコンポーネントは、スプレッドシートです。スプレッドシートは、In-Sight センサから取り込まれたビデオ画像に重ねて表示される、調整可能な半透明のオーバレイです。

注: スプレッドシートを右クリックすると、ショートカットメニューが表示され、さまざまなスプレッドシート操作を実行することができます。

スプレッドシートビューは、アクティブジョブを含む半透明のスプレッドシートオーバレイに加え、次の項目から構成されています。

  • In-Sight センサから取り込まれるアクティブな画像
  • 使用可能な割り当て済みセルの数 ([ジョブサイズ制限] ダイアログを使用して値を変更) として現在使用可能なジョブサイズ、およびアクティブな In-Sight センサのオンライン/オフラインステータスとジョブ処理時間を示すステータスバー
  • アクティブなジョブのセンサ名とファイル名を示すタイトルバー
注:
  • ジョブを PC からドラッグ＆ドロップすると、ジョブをセンサに保存するまで、タイトルバーには「スプレッドシートビュー」と表示されます。ジョブを保存すると、ファイル名が表示されます。
  • 画像のショートカットをスプレッドシートビューまたは [In-Sight のファイル] ペインにドラッグすることはできません。ショートカットではなく、元のコピー元画像を目的の場所にドラッグしてください。
  • 同時に表示できるスプレッドシートビューの数は、PC のハードウェア (主に CPU の動作速度とメモリ容量) によって異なります。ジョブが特に複雑である場合は、11 個以上のウィンドウを開くと、メモリのリソースを上回り、予期しない動作を引き起こす可能性があります。
  • すべての In-Sight センサがスプレッドビューにアクセスできるわけではありません。

スプレッドシートビューの表示

In-Sight センサまたはエミュレータのスプレッドシートビューを表示するには、次のいずれかを実行します。

  • [In-Sight のネットワーク] ペインで対象のセンサまたはエミュレータをダブルクリックします。必要に応じて、[ウィンドウ] メニューの [表示 スプレッドシートビュー] をクリックします。
  • [In-Sight のネットワーク] ペインのセンサまたはエミュレータを右クリックし、表示されたドロップダウンメニューから [表示 スプレッドシートビュー] をクリックします。

注: 使用する In-Sight センサまたはエミュレータに、既に別のユーザがログオンしている場合は、警告メッセージが表示されます。[はい] をクリックすると、アクセス先のシステムから、ほかのユーザの接続を切り、ログオンプロセスを続行します。[いいえ] をクリックすると、ログオンを中止して、In-Sight Explorer に戻ります。

関連項目

  • スプレッドシートのセルの実行と参照の編集
  • キーボードとマウスのショートカット
  • スプレッドシートの右クリックメニュー
  • 関数の挿入: スプレッドシートに挿入する関数を選択するために使用します。
  • プロパティシート: 固定数のパラメータを持つビジョンツールを設定します。
  • 対話型グラフィックスモード: 画像上の対話型グラフィックス領域を調整してビジョンツールの特定のパラメータを設定します。
  • セル選択モード: セルのアドレスを覚えることなく、セルをグラフィカルに参照できます。
  • [編集] メニュー: スプレッドシートセルのデータを操作するための機能があります。
  • [フォーマット] メニュー: 半透明のスプレッドシートオーバレイを定義するセル、行、および列の表示プロパティを変更できます。
  • [挿入] メニュー: スプレッドシートのアクティブセルにオブジェクトを挿入することができます。
  • #ERR: 正しくない数式の結果として表示されるさまざまなエラーメッセージを定義します。


センサのステータスビュー

センサのステータスビュー(マシンステータススタック)

[ウィンドウ] メニュー → [表示 センサのステータスビュー]

In-Sight Explorer GUI リファレンス

マシンステータススタックの In-Sight ビジョンシステムのメモリには、8 つのメモリバッファが割り当てられています。In-Sight Explorer のビジョンシステムのステータスビューには、これらのメモリバッファの内容とともに、In-Sight ビジョンシステムのエラーを診断するために使用される診断記録情報が表示されます。

最初のバッファ (バッファ 0) は現在のマシンステータス情報を格納するために使用されます。PushMSStack 関数が実行されると、現在のマシンステータスがバッファ 0 にロードされ、前のマシンステータス情報は次のバッファに移ります。スタックのすべてのバッファに情報が保存されると、バッファ 7 のデータが破棄されます。In-Sight ビジョンシステムの電源を入れ直すと、スタック内の全てデータがクリアされます。

注:
  • スタックに保存されているマシンステータスデータにアクセスするには、GetMSBuffer 拡張ネイティブモードコマンド 、またはマシンステータスポートを使用します。
  • In-Sight Explorer がマシンステータスポートを使用しているとき、PC 上のほかのアプリケーションからもマシンステータスポートにアクセスすることができます。
  • マシンステータスポートは、約 10 ～ 15 秒でタイムアウトになります。ステータスのポーリングを停止させたままこの時間が経過すると、接続は切断されます。

ビジョンシステムのステータスダイアログボックス

ビジョンシステムのステータスダイアログボックス内の動作ステータス情報は、以下で構成されます。

  • アクティブなビジョンシステム名を表示するタイトルバー
  • バッファインデックス番号 (0 ～ 7)
  • システムの現在の日付および時間
  • オンライン/オフラインステータス
  • アクティブなジョブのファイル名と場所
  • アクティブなジョブがロードされた日付と時刻
  • In-Sight ビジョンシステムにログオンしているユーザ名
  • In-Sight ビジョンシステムまたはエミュレータへのログオンに使用されているアクティブなエミュレータの名前
  • ユーザデータ (WriteMSStack 関数によって決まります)
  • In-Sight ビジョンシステムのエラーを診断するために使用する情報のログ
注:
  • ビジョンシステムのステータスダイアログボックスには、マシンステータススタックのすべての内容が表示されるわけではありません。In-Sight ビジョンシステムのモデル番号、ファームウェアやビルドのバージョン、前回のシステム再起動日時、および動作ステータス (IDLE: In-Sight システムはオンラインですが、ジョブ内のセルは 1 つも実行されていません。 アイドル /BUSY: In-Sight システムはオンラインで、ジョブ内のセルは現在実行されています。 ビジー /MAINTENANCE: In-Sight システムはオフラインです。 メンテナンス ) を含むすべての内容を表示するには、GetMSBuffer 拡張ネイティブモードコマンドを使用するか、またはマシンステータスポートからアクセスします。
  • PC からジョブファイルをドラッグ＆ドロップした場合、ジョブがビジョンシステムに保存されるまでは、現在のジョブのフィールドには「Drag And Drop Job」が表示されます。
  • ローカル PC のパスは、その PC における絶対パスであり、ある PC のディレクトリの階層がほかの PC では存在しない場合があるため、現在のジョブの PC パスは表示されません。
  • In-Sight ビジョンシステムが Modbus/TCP サーバとして設定されている場合、診断ログにはクライアント接続、クライアント切断、クライアントアイドルタイムアウト、およびクライアント接続拒否/最大接続数制限に関する情報が表示されます。各診断メッセージには、クライアントの日付、時刻、セッション ID (同じ Modbus/TCP クライアント間の診断メッセージをリンクするために使用できる、一意のセッション識別子)、および IP アドレスが含まれます。


ウェブブラウザビューを開く

Windows メニュー → [ウェブブラウザビューを開く]

In-Sight Explorer GUI リファレンス

[ウェブブラウザビューを開く] により、選択された In-Sight ビジョンシステムまたはセンサの Web ベースのヒューマンマシンインタフェース (HMI) にデフォルトのブラウザが開きます。

注: Web HMI アプリケーションは、In-Sight ファームウェア 5.6.0 以上を実行しているビジョンシステムまたはセンサのみで使用できます。

ブラウザの要件

Web HMI アプリケーションでは次の Web ブラウザがサポートされています。

  • Google Chrome™ ブラウザ、バージョン 64 以降
  • Internet Explorer バージョン 11 以降
注: HTTPS (HTTP Secure) は現在サポートされていません。

[ログイン] ダイアログ

デフォルトの認証情報 (すなわち、パスワードなしの管理ユーザ) を使用する場合は、Web HMI アプリケーションが自動的に表示されます。使用しない場合は、ユーザ名とパスワードを入力してビジョンシステムまたはセンサにログオンするよう求めるプロンプトが表示されます。

Web HMI アプリケーションは、接続モードと、[センサ] メニューの [ユーザアクセス設定] ダイアログで定義するユーザアクセスレベルに基づいて表示されます。

  • [フル]: Web HMI アプリケーションのすべてに無制限にアクセスできます。

    • 注:

    • Web HMI アプリケーションに、[オンライン/オフライン]、[トリガ]、[ライブモード] および [表示切り替え] コントロールボタンを表示するには、まず [HMI の設定] ダイアログで対応するチェックボックスをオンにする必要があります。
    • Web HMI アプリケーションの接続モードがビュー専用接続になっている場合は、ロックアクセスでのみ Web HMI アプリケーションにアクセスできます。

  • [プロテクト]: [オンライン/オフライン]、[トリガ]、[ライブモード] および [表示切り替え] コントロールボタン、画像ツールバー、および編集可能な [EasyView] ペインにアクセスできます。

    注:

    • Web HMI アプリケーションに、[オンライン/オフライン]、[トリガ]、[ライブモード] および [表示切り替え] コントロールボタンを表示するには、まず [HMI の設定] ダイアログで対応するチェックボックスをオンにする必要があります。
    • Web HMI アプリケーションの接続モードがビュー専用接続になっている場合は、ロックアクセスでのみ Web HMI アプリケーションにアクセスできます。
  • [ロック]: [表示切り替え] ボタン、画像ツールバー、および読み取り専用の [EasyView] ペインにアクセスできます。

関連項目

Web HMI の設定

HMI の設定

HMI ビューの選択

Web HMI 表示


Web HMI 表示

ユーザインタフェース

In-Sight Explorer GUI リファレンス

  • 画像ツールバー
  • ステータス境界線
  • [EasyView] ペイン
  • [実行モードのコントロール] ペイン
  • Web HMI のサポートされるセルタイプ
  • 対話型グラフィックスモード

関連項目

Web HMI の設定

EasyView の設定

HMI の設定

HMI ビューの選択


画像ツールバー

[ユーザインタフェース] → [Web HMI 表示]

In-Sight Explorer GUI リファレンス

画像ツールバーは、[HMI の設定] ダイアログの [画像調整の許可] チェックボックスが選択されている場合に表示されます。

拡大 | このボタンをクリックして、画像の表示倍率を上げます。
縮小 | このボタンをクリックして、画像の表示倍率を下げます。
Fit (ウィンドウに合わせる) | このボタンをクリックして、画像ウィンドウ内に画像全体を表示します。
埋める | このボタンをクリックして、画像でウィンドウ全体を埋めます。境界線は表示されません。
Rotate Counter-Clockwise (反時計回りに回転) | このボタンをクリックして、画像を 90 度ずつ反時計方向に回転します。
Rotate Clockwise (時計回りに回転) | このボタンをクリックして、画像を 90 度ずつ時計方向に回転します。
Show Pan Control (パンコントロールの表示) | このボタンをクリックして、パンコントロール [image] ボタンを表示または非表示にします。デフォルトで、パンコントロール [image] ボタンは表示されます。
Pan Control Button (パンコントロールボタン) | 上下および左右の矢印をクリックして画像を移動します。パンコントロールボタンの中央の円をクリックして、画像を元の位置に戻します。

関連項目

HMI の設定

Web HMI 表示

Version: 5.6.0


ステータス境界線

[ユーザインタフェース] → [Web HMI 表示]

In-Sight Explorer GUI リファレンス

ステータスの境界線 (枠) は、ジョブの成功または失敗ステータスを示します。結果が成功すると、枠は緑になります。結果が失敗すると、枠は赤になります。

関連項目

Web HMI 表示

Version: 5.6.0


[EasyView] ペイン

[ユーザインタフェース] → [Web HMI 表示]

In-Sight Explorer GUI リファレンス

Web HMI アプリケーションで [EasyView] ペインを表示するには、次のことを実行する必要があります。

  1. In-Sight Explorer または EasyBuilder 内で EasyView を作成し、ジョブとともに保存します。
  2. [HMI ビューの選択] ダイアログで [画像とグラフィックおよび EasyView] および/または [EasyView のみ] を選択します。
  3. [画像とグラフィックおよび EasyView] または [EasyView のみ] のいずれも [HMI ビューの選択] ダイアログで最初に表示されない場場合、[HMI の設定] ダイアログで [ビュー選択の許可] を有効にします。
注: ユーザのアクセスレベルがロックであるか、または Web HMI 接続モードがビュー専用接続である場合、EasyView ペインは読み取り専用になります。

関連項目

[EasyView の設定]

Web HMI 表示

Web HMI がサポートされるセルのタイプ

Version: 5.6.0


[実行モードのコントロール] ペイン

[ユーザインタフェース] → [Web HMI 表示]

In-Sight Explorer GUI リファレンス

ボタンをクリックして、[実行モードのコントロール] ペインを表示するか、または非表示にします。

[実行モードのコントロール] ペインには次が含まれます。

  • 動作ステータス情報
  • コントロールボタン
  • [デバイス情報] ダイアログ

動作ステータス情報

[実行モードのコントロール] ペインには、接続されているビジョンシステムまたはセンサの次の動作ステータス情報が表示されます。

  • 接続されている In-Sight ビジョンシステムまたはセンサの名前
  • オンライン/オフラインステータス
  • アクティブなジョブのファイル名

コントロールボタン

注: コントロールボタンは、Web HMI の設定、Web HMI 接続モード、ユーザアクセスレベルに基づいて有効化または無効化されます。

このボタンをクリックしてビジョンシステムまたはセンサをオンラインにします。このボタンを使用するには、[HMI の設定] ダイアログで [オンライン/オフラインの許可] チェックボックスをオンにする必要があります。

このボタンをクリックしてビジョンシステムまたはセンサをオフラインにします。このボタンを使用するには、[HMI の設定] ダイアログで [オンライン/オフラインの許可] チェックボックスをオンにする必要があります。

このボタンをクリックして画像取り込みを手動でトリガします。このボタンを使用するには、[HMI の設定] ダイアログで [トリガの許可] チェックボックスをオンにする必要があります。

このボタンをクリックして、ビジョンシステムまたはセンサのレンズ、視野およびフォーカスを調整するときに使用するライブビデオ画像を表示します。このボタンを使用するには、[HMI の設定] ダイアログで [ライブビデオの許可] チェックボックスをオンにする必要があります。

このボタンをクリックして次のビューを表示します。このボタンを使用するには、[HMI の設定] ダイアログで [ビュー選択の許可] チェックボックスをオンにする必要があります。

[HMI ビューの選択] ダイアログで表示可能なビューとその順序をカスタマイズできます。Web HMI アプリケーションを開くと、[HMI ビューの選択] ダイアログのリストで最初のビューがデフォルトのビューとして表示されます。

Web HMI アプリケーションでは次のビューがサポートされています。

  • [画像とグラフィックおよび EasyView]: 画像、ツールグラフィックス、および EasyView を表示します。このビューを表示するには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。次に、[HMI ビューの選択] ダイアロブでこのビューを有効にする必要があります。
  • [画像のみ]: 画像のみを表示します。
  • [画像とグラフィックス]: 画像とツールグラフィックスを表示します。
  • [EasyView のみ]: EasyView のみを表示します。このビューを表示するには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。次に、[HMI ビューの選択] ダイアロブでこのビューを有効にする必要があります。

このボタンをクリックして、現在のセッションからログアウトします。このボタンは、デフォルトの認証情報 (すなわち、パスワードなしの管理ユーザ) がある場合には表示されません。このボタンをクリックすると、Web HMI アプリケーションが閉じられ、[ログイン] ダイアロブボックスが表示されます。

[デバイス情報] ダイアログ

ボタンをクリックすると、[デバイス情報] ダイアロブが開き、ビジョンシステムまたはセンサのハードウェア情報とネットワーク識別情報の詳細が表示されます。

関連項目

Web HMI 表示

Version: 5.6.0


Web HMI のサポートされるセルタイプ

[ユーザインタフェース] → [Web HMI 表示]

In-Sight Explorer GUI リファレンス

Web HMI アプリケーションの [EasyView] ペインでは、次のセルタイプがサポートされています。

  • Button 関数: [EasyView] ペインにラベル付きボタンを表示します。ボタンをクリックするとイベントがトリガされます。
  • CheckBox 関数: [EasyView] ペインにラベル付きチェックボックスを表示します。チェックボックスを選択すると、チェックボックスの状態と関連付けられた値が切り替わります。
  • ColorLabel 関数: [EasyView] ペインに色付きのテキスト文字列を色付きの背景で表示します。
  • EditAnnulus 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、円環の位置とサイズが調整可能になります。
  • EditCircle 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、円の位置とサイズが調整可能になります。
  • EditCompositeRegion 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、合成領域が調整可能になります。合成領域は複数のサブ領域で構成できます。サブ領域は、円環、円、ポリゴン、または矩形で構成できます。
  • EditFloat 関数: [EasyView] ペインに編集ボックスを表示します。このボックスでユーザは、浮動小数点の数値を入力できます。
  • EditInt 関数: [EasyView] ペインに編集ボックスを表示します。このボックスでユーザは、正数値を入力できます。
  • EditLine 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、線の位置とサイズが調整可能になります。
  • EditMaskedRegion 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、合成領域が調整可能になります。合成領域は複数のマスク領域で構成できます。
  • EditPoint 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、点の位置が調整可能になります。
  • EditPolygon 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、ポリゴンの位置とサイズが調整可能になります。
  • EditPolylinePath 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、合成領域が調整可能になります。合成領域は複数のパスセグメントで構成できます。
  • EditRegion 関数: [EasyView] ペインにボタンを表示します。このボタンをクリックすると表示が対話型グラフィックスモードに切り替わり、領域の位置、サイズ、回転、および曲りが調整可能になります。
  • EditString 関数: [EasyView] ペインにテキスト編集ボックスを表示します。このボックスでユーザは、英数テキスト文字列を入力できます。
  • FloatResult 関数: [EasyView]　ペインに、浮動小数点の数値を固定テキストとして表示します。
  • ListBox 関数: [EasyView] ペインにドロップダウンリストボックスを表示します。このリストボックスには、ユーザが選択するオプションが表示されます。現在選択されているオプションは強調表示されます。
  • MultiStatus 関数: [EasyView] ペインに、シミュレーションされた LED ステータス配列を表示します。
  • Status 関数: [EasyView] ペインに、シミュレーションされた多色ステータス LED をテキストラベル付きで表示します。
  • StatusLight 関数: [EasyView] ペインに、シミュレーションされた LED ステータス照明をテキストラベル付きで表示します。ステータス照明の色とラベルは、どちらもユーザが指定できます。
  • StringResult 関数: [EasyView]　ペインに、英数テキスト文字列を固定テキストとして表示します。

関連項目

EasyView の設定

Web HMI 表示

Version: 5.6.0


対話型グラフィックスモード

[ユーザインタフェース] → [Web HMI 表示]

In-Sight Explorer GUI リファレンス

対話型グラフィックスモードにするには、[EasyView] ペインで対話型グラフィックスコントロールボタン (EditAnnulus、EditCircle、EditCompositeRegion、EditMaskedRegion、EditPoint、EditPolygon、EditPolylinePath、EditRegion) をクリックします。対話型グラフィックスと [データエディタ] ペインは Web HMI 表示に表示されます。

対話型グラフィックスを変更するには、適切なハンドルを選択してアクティブにします。アクティブなハンドルは黄色で表示されます。次に、ハンドルを新しい位置にドラッグします。

[データエディタ] ペインには、アクティブなハンドルの現在位置、サイズ、回転または曲げが表示されます。また、値ボックスをダブルクリックすることによってアクティブなハンドルの値を手動で入力して、対話型グラフィックスを変更することもできます。

注:
  • 対話型グラフィックスの使用方法の詳細については、「対話型グラフィックスモード」のトピックを参照してください。
  • 使用可能なハンドルのタイプは、変更される対話型グラフィックスのコントロールボタンと、In-Sight Explorer で最初に設定されたときにハンドルが有効化されたかどうかに応じて異なります。

変更を受け入れて対話型グラフィックスモードを終了するには、[アクセプト] をクリックします。変更をキャンセルして対話型グラフィックスモードを終了するには、[キャンセル] をクリックします。

関連項目

Web HMI 表示

Version: 5.6.0


[ヘルプ] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[ヘルプ] メニューでは In-Sight Explorer のヘルプおよびサポートサービスのほか、バージョンビルド情報と In-Sight センサハードウェアの詳細にアクセスできます。

[ヘルプ] メニューの項目

  • [In-Sight Explorer のヘルプ]: このオンラインヘルプファイルを開きます。

  • [EasyBuilder ヘルプ]: EasyBuilder オンラインヘルプファイルを開きます。

    注:
    • EasyBuilder ヘルプファイルは 2 つのフォーマットで提供されます。パレットヘルプとオンラインヘルプです。EasyBuilder パレットヘルプは、パレットの [ヘルプ] タブに表示されます。EasyBuilder オンラインヘルプは、CHM フォーマットのヘルプシステムで、検索機能を持ちます。
    • EasyBuilder ヘルプファイルには、In-Sight Explorer オンラインヘルプファイルへのリンクが含まれています。EasyBuilder パレットヘルプでこれらのリンクをクリックすると、In-Sight Explorer オンラインヘルプが開き、リンクしたトピックが表示されます。ただし、EasyBuilder オンラインヘルプファイルでこれらのリンクをクリックしても、In-Sight Explorer オンラインヘルプファイルは開かず、In-Sight Explorer オンラインヘルプファイルからリンクしたトピックは EasyBuilder オンラインヘルプファイル内に表示されます。EasyBuilder ヘルプのトピックに戻るには、[戻る] ボタンを押してください。
    • [検索] タブを使用して EasyBuilder オンラインヘルプファイルを検索すると、In-Sight Explorer ヘルプファイルの検索結果も表示されます。
  • [In-Sight リリースノート]: In-Sight Explorer および In-Sight ファームウェアのリリースノートが表示されます。
  • [オンラインサポート]: Cognex In-Sight センサのサポートホームページが開きます (インターネットのアクセスが必要です)。
  • [In-Sight Explorer について]: In-Sight Explorer のバージョンおよびビルド情報のほか、ネットワーク上で検出された各 In-Sight センサのハードウェアおよびネットワークの詳細 (Explorer ホストテーブルのエントリを含む) が表示されます。

スプレッドシートビュー

[ヘルプ] メニューでは In-Sight Explorer のヘルプおよびサポートサービスのほか、バージョンビルド情報と In-Sight センサハードウェアの詳細にアクセスできます。

[ヘルプ] メニューの項目

  • [In-Sight Explorer のヘルプ]: このオンラインヘルプファイルを開きます。
  • [In-Sight リリースノート]: In-Sight Explorer および In-Sight ファームウェアのリリースノートが表示されます。
  • [オンラインサポート]: Cognex In-Sight センサのサポートホームページが開きます (インターネットのアクセスが必要です)。
  • [In-Sight Explorer について]: In-Sight Explorer のバージョンおよびビルド情報のほか、ネットワーク上で検出された各 In-Sight センサのハードウェアおよびネットワークの詳細 (Explorer ホストテーブルのエントリを含む) が表示されます。


[In-Sight Explorer について] ダイアログ

[ヘルプ] メニュー

In-Sight Explorer GUI リファレンス

[In-Sight Explorer について] ダイアログには、主に以下の 2 つのグループの情報が表示されます。

  • In-Sight Explorer アプリケーションのコードコンパイル (ビルド) の詳細。
  • サブネットで検出された In-Sight ビジョンシステムとエミュレータのハードウェア、ファームウェア、および設定の詳細、および Explorer のホストテーブルで定義されているデバイス。

Cognex テクニカルサポートによる支援が必要な場合には、この情報を提供する必要があります。

注: In-Sight ビジョンシステムに固有の情報は、Windows のクリップボードにコピー可能です。詳細については、以下の「In-Sight ビジョンシステムに固有の情報のコピー」セクションを参照してください。

[In-Sight Explorer について] ダイアログを表示するには

  • [ヘルプ] メニューで、[In-Sight Explorer について] をクリックします。

In-Sight Explorer に固有の情報

  • In-Sight Explorer アプリケーションのメジャー番号、マイナー番号、およびリビジョンバージョン番号。[5.5.0]
  • In-Sight Explorer アプリケーションのインクリメンタルビルド番号。[798]

ネットワーク上の In-Sight ビジョンシステムに固有の情報

以下のセクションでの例として、上記のテーブルの最初のビジョンシステムを使用します。

  • ビジョンシステムのホスト名。[is2000-130_040506]
  • ビジョンシステムのタイプ。In-Sight ビジョンシステムの具体的なモデル、エミュレータが実行されている PC、または Explorer のホストテーブルのエントリを示します。[2000-130]
  • ビジョンシステムで実行されている特定のファームウェアバージョンのメジャー番号、マイナー番号、リビジョン番号、およびビルド番号。[5.5.0 (358)]
  • ビジョンシステムの MAC アドレス[00-d0-24-3c-ef-28]
  • ビジョンシステムの IP アドレス。[192.168.0.1]
  • ビジョンシステムのシリアル番号。[1A1538XA014394]

In-Sight ビジョンシステムに固有の情報のコピー

テーブルに含まれる In-Sight ビジョンシステムの情報は、Windows のクリップボードにコピー可能です。この機能は、Cognex テクニカルサポートに問い合わせる場合に便利です。対象のビジョンシステムの情報をコピーするには、以下のいずれかの手順に従います。

  • 対象のビジョンシステムを選択し、CTRL+C を押します。
  • 対象のビジョンシステムを右クリックし、[コピー] を選択します。
注:
  • テーブル内のすべてのビジョンシステムの情報を選択するには、CTRL+A を押すか、右クリックして [すべて選択] を選択します。
  • 連続していない複数のビジョンシステムの情報を選択するには、CTRL キーを押したまま対象のビジョンシステムを選択してハイライト表示します。

  • 連続した複数の項目を選択するには、最初のビジョンシステムをハイライト表示し、SHIFT キーを押したままリストの最後のビジョンシステムを選択してハイライト表示します。


設定ペイン

EasyBuilder GUI リファレンス

設定ペインは自動的に更新され、選択したアプリケーションステップのパラメータが表示されます。ほとんどのステップでは、パラメータが特定の順序で設定されている必要があります。ジョブの開発中、各ステップの指示については、[パレット] の [ヘルプ] タブを参照してください。

注: 設定ペインのコントロールは、アクセスレベル、現在実行中のタスク、接続先がセンサかエミュレータか、In-Sight センサがオンラインかどうかなどによってグレーアウトされることがあります。

設定ペインの使用

設定ペインは、左側に一般的なパラメータを表示し、右側に進むにつれて、より限定的なパラメータを表示してステップを誘導するように設計されています。

可能な場合には、その時点で使用可能なコントロールのみがペインに表示されます。例えば、[通信] ステップでは、[デバイス] ドロップダウンリストからの選択が行われるまで、[メーカー] と [プロトコル] のドロップダウンリストが非表示になります。同様に、位置決めツールまたは検査ツールのパラメータは、ツールがジョブに追加されるまでは非表示になります。

さらに、追加されるツールに応じて、[位置決め] ステップと [検査] ステップでは、(アプリケーションのパラメータを設定できるようにするための) フィードバックテーブルやグラフ、および (PASS/FAIL 基準を設定するための) [制限範囲] タブなどの視覚支援機能も表示されます。

ジョブの構築後、これらのステップには任意の順序で再アクセスできるので、目的の結果が得られるまで、ジョブパラメータを変更し、微調整することが可能です。


ステータスバー

ユーザインタフェース

In-Sight Explorer GUI リファレンス

  • EasyBuilder ビュー
  • スプレッドシートビュー

EasyBuilder ビュー

ステータスバーは、各 EasyBuilder ビューの表示領域の下に表示されます。そのときに実行されているタスクに応じて、ステータスバーには、現在の画像についてのピクセル値情報およびビジョンシステムの接続ステータス、ジョブサイズ、I/O ステータス、またはオンライン/オフラインステータスに関するメッセージが表示されます。

画像ステータス

ステータスバーには、ピクセル値情報のほか、画像の記録/再生情報が表示されることがあります。

ステータスバーのフィールド | 説明
 | 画像上でマウスをスクロールすると、ステータスバーの左側に、その画像についてのピクセル値情報が表示されます。 注:カラービジョンシステムを使用している場合、RGB 値の情報が表示されます。詳細については、「ピクセル値表示モード」を参照してください。
 | 画像を記録しているときは、ステータスバーの左側には、記録フォルダ、Good フォルダ、または Bad フォルダのディレクトリパスと、そのとき記録している画像名が表示されます。
 | 記録した画像の再生中は、ステータスバーの左側には、再生中の画像名と再生フォルダのディレクトリパスが表示されます。
 | 現在使用可能なジョブサイズを、割当てられたサイズのパーセンテージで表示します。数値を変更するには、[ジョブサイズ制限] ダイアログを使用します。

接続ステータス

各 In-Sight ビジョンシステムは、1 度に 1 つの接続のみを許可します。PC 上の別のアプリケーションや、ビジョンシステムにログオンしてきた別ユーザによって、接続が切断されることがあります。このときステータスバーには、「… からのユーザ admin はすでにログオンしています」というメッセージが表示されます。EasyBuilder は定期的にビジョンシステムへの再接続を試み、ステータスバーにはその進行状況が表示されます (例えば、「再接続待機中」や「接続中」)。ビジョンシステムがネットワークに接続していない場合、ステータスバーにはネットワークエラーなどのほかのエラーメッセージが表示されることがあります。

I/O ステータス

I/O ステータスバーには、ビジョンシステムと CIO-MICRO、CIO-MICRO-CC、または CIO-WENET Ethernet I/O モジュール間の EtherNet/IP 接続ステータスが表示されます。

ステータスバーのフィールド | 説明
 | 「I/O OK」が表示されている場合、モジュールへの接続は正常に動作しています。
 | 「I/O Not Responding」が表示されている場合、モジュールへの接続は失われています。診断情報の詳細については、センサスのテータスビューを参照してください。

オンライン/オフラインステータス

ステータスバーの右側には、常に In-Sight ビジョンシステムのオンラインまたはオフラインステータスに関する情報が表示されます。

ステータスバーのフィールド | 説明
 | 「オフライン」が表示される場合、In-Sight ビジョンセンサは現在オフラインです。
 | 「ライブ」が表示される場合、In-Sight ビジョンシステムは EasyBuilder ユーザインタフェース ([画像の設定] 設定ペインの EasyBuilder ツールバー、または [画像] メニュー) で [ライブビデオ] に設定されています。ビジョンシステムのレンズと視野の調節を行うとき、In-Sight ビジョンシステムは使用するライブ画像を表示します。
 | 「オンライン」が表示される場合、In-Sight ビジョンシステムは現在オンラインモードで作動しています。
 | 「通信オンライン?」が表示される場合、In-Sight ビジョンシステムは EasyBuilder ユーザインタフェースによってオンラインモードに設定されましたが、通信プロトコル (ProfiNET、EtherNet/IP、ネイティブモードなど) によってビジョンシステムはオフラインのままになっています。例えば、ネイティブモードで、 In-Sight ビジョンシステムをオフラインにする Set Online コマンド SO0 が発行されました。In-Sight ビジョンシステムをオンラインにするには、Set Online コマンド SO1 を In-Sight ビジョンシステムに送信する必要があります。
 | 「ディスクリートオンライン?」が表示される場合、In-Sight ビジョンシステムは EasyBuilder ユーザインタフェースによってオンラインモードに設定されていますが、オンライン/オフラインタイプとして設定されたディスクリート入力ラインが Low (0) に設定されています。ディスクリート入力信号の状態が High (1) になると、In-Sight ビジョンシステムはオンラインモードになります。

ヒント: [EasyBuilder] ツールバー、または実行ジョブの設定ペインのいずれかでオンライン/オフラインボタン [image] をクリックすると、オンラインとオフラインのステータスが切り替えられるようになります。

警告:

ステータスバーの右側には警告が表示されることがあります。

ステータスバーのフィールド | 説明
 | このエクスクラメーションマークが表示された場合、接続された In-Sight ビジョンシステムのファームウェアバージョンに In-Sight Explorer バージョンが対応していません。In-Sight Explorer バージョン 5.1.0 以上には、5.x.x バージョン (現行バージョン) と最新の 4.x.x バージョンの 2 つのファームウェアバージョンがリリースされています。例えば、In-Sight Explorer 5.1.0 には、In-Sight ファームウェア 5.1.0 と 4.9.3 がリリースされています。したがって、ファームウェア 4.9.3 を実行するビジョンシステムが In-Sight Explorer 5.1.0 に接続されている場合、ステータスバーにインジケータが表示されません。ただし、ファームウェア 4.9.1 を実行するビジョンシステムが In-Sight Explorer 5.1.0 に接続されている場合、このエクスクラメーションマークがステータスバーに表示されます。 注: ファームウェアバージョンの詳細については、「ファームウェアバージョン」のトピックを参照してください。

スプレッドシートビュー

ステータスバーは、各スプレッドシートビューの最下部に表示されます。ステータスバーには 3 つの部分があり、表示されているスプレッドシートビューに関する情報を、実行中の操作に応じて表示します。

セルと画像のステータス

スプレッドシートのオーバレイがアクティブかどうか、また 対話型グラフィックスモードになっているかどうかに応じて、ステータスバーには個々のセルに関する情報、ピクセル値情報、または画像に関する参照情報が表示されます。ステータスバーには、画像取り込み時間と画像の記録/再生情報も表示されます。

ステータスバーのフィールド 説明

スプレッドシートオーバレイが表示されている場合、関数またはデータを含んでいるセルの上でマウスをスクロールすると、その関数またはデータが左側に表示されます。

注: [カスタムビュー]では、情報は表示されません。

スプレッドシートオーバレイが非表示の場合、画像上でマウスをスクロールすると、ステータスバーの左側にその画像についてのピクセル値情報が表示されます。

注:
  • カラービジョンシステムを使用している場合、RGB 値の情報が表示されます。詳細については、「ピクセル値表示モード」を参照してください。
  • スプレッドシートビューでの絶対ピクセル値は、画像の表示倍率が 1:1 に設定された場合にだけ表示され、ステータスバーには値が次のように表示されます。 . 画像表示倍率が 1:1 以外の場合は、「近似」ピクセル値が表示され、ステータスバーには値が次のように表示されます。 . EasyBuilder ビューでの絶対ピクセル値は、画像表示倍率に関係なく常に表示されます。

対話型グラフィックスモードの場合、ステータスバーの左側には、領域の位置、サイズ、回転およびカーブなどの対話型グラフィックス関連の情報が表示されます。

画像の取り込みによってスプレッドシートが更新された場合、ステータスバーにジョブ処理時間 (ミリ秒単位) が表示されます。

注:
  • センサフィルムストリップの処理時間もジョブの処理時間に含まれています。
  • ステータスバーと GetAllTime 関数は、[ジョブのプロファイル] ダイアログとは別に時間を計算します。また、[ジョブのプロファイル] ダイアログでは結果のグラフィックスの構築についても説明します。ほかの 2 つのはこれを行いません。

画像を記録しているときは、ステータスバーの左側には、記録フォルダ、Good フォルダ、または Bad フォルダのディレクトリパスと、そのとき記録している画像名が表示されます。

記録した画像の再生中は、ステータスバーの左側には、再生中の画像名と再生フォルダのディレクトリパスが表示されます。

現在使用可能なジョブサイズを、使用可能で割当て済みのセルの数で表示します。数値を変更するには、[ジョブサイズ制限] ダイアログを使用します。

接続ステータス

ほかの PC や In-Sight コンソールのユーザが 1 つの In-Sight ビジョンシステムにログオンして、接続が切断された場合、In-Sight Explorer は定期的にビジョンシステムへの再接続を試みます。「… からのユーザ admin はすでにログオンしています」というメッセージは、別のユーザまたはアプリケーションがビジョンシステムにログオンしていることを示します。各ビジョンシステムには 1 度に 1 つの接続しか許可されていないため、このメッセージが表示されたときには、別の PC、または同じ PC 上で実行している別のアプリケーションがビジョンシステムに接続している可能性があります。ビジョンシステムがネットワークに接続していない場合、ステータスバーにはネットワークエラーなどのほかのエラーメッセージが表示されることがあります。

I/O ステータス

I/O ステータスバーには、ビジョンシステムと CIO-MICRO、CIO-MICRO-CC、または CIO-WENET Ethernet I/O モジュール間の EtherNet/IP 接続ステータスが表示されます。

ステータスバーのフィールド | 説明
 | "I/O OK" が表示されている場合、モジュールへの接続は正常に動作しています。
 | 「I/O Not Responding」が表示されている場合、モジュールへの接続は失われています。診断情報の詳細については、センサスのテータスビューを参照してください。

オンライン/オフラインステータス

ステータスバーの右側には、常に In-Sight ビジョンシステムのオンラインまたはオフラインステータスに関する情報が表示されます。

ステータスバーのフィールド | 説明
 | 「オフライン」が表示される場合、In-Sight ビジョンセンサは現在オフラインです。
 | 「ライブ」が表示される場合、In-Sight ビジョンシステムは In-Sight Explorer ユーザインタフェース ([ジョブの表示] ツールバーまたは [画像] メニュー) で [ライブビデオ] に設定されています。ビジョンシステムのレンズと視野の調節を行うとき、In-Sight ビジョンシステムは使用するライブ画像を表示します。いずれかのボタンを押すと、ライブビデオを終了してスプレッドシートに戻ります。
 | 「オンライン」が表示される場合、In-Sight ビジョンシステムは現在オンラインモードで作動しています。
 | 「通信オンライン?」が表示される場合、In-Sight ビジョンシステムは In-Sight Explorer ユーザインタフェースによってオンラインモードに設定されましたが、通信プロトコル (ProfiNET、EtherNet/IP、ネイティブモードなど) によってビジョンシステムはオフラインのままになっています。例えば、ネイティブモードで、 In-Sight ビジョンシステムをオフラインにする Set Online コマンド SO0 が発行されました。In-Sight ビジョンシステムをオンラインにするには、Set Online コマンド SO1 を In-Sight ビジョンシステムに送信する必要があります。
 | 「ディスクリートオンライン?」が表示される場合、In-Sight ビジョンシステムは In-Sight Explorer ユーザインタフェースによってオンラインモードに設定されていますが、オンライン/オフラインタイプとして設定されたディスクリート入力ラインが Low (0) に設定されています。ディスクリート入力信号の状態が High (1) になると、In-Sight ビジョンシステムはオンラインモードになります。

ヒント: [ジョブの表示] ツールバーでオンライン/オフライン [image] ボタンをクリックすると、オンラインとオフラインのステータスが切り替えられるようになります。

警告:

ステータスバーの右側には警告が表示されることがあります。

ステータスバーのフィールド | 説明
 | このエクスクラメーションマークが表示された場合、接続された In-Sight ビジョンシステムのファームウェアバージョンに In-Sight Explorer バージョンが対応していません。In-Sight Explorer バージョン 5.1.0 以上には、5.x.x バージョン (現行バージョン) と最新の 4.x.x バージョンの 2 つのファームウェアバージョンがリリースされています。例えば、In-Sight Explorer 5.1.0 には、In-Sight ファームウェア 5.1.0 と 4.9.3 がリリースされています。したがって、ファームウェア 4.9.3 を実行するビジョンシステムが In-Sight Explorer 5.1.0 に接続されている場合、ステータスバーにインジケータが表示されません。ただし、ファームウェア 4.9.1 を実行するビジョンシステムが In-Sight Explorer 5.1.0 に接続されている場合、このエクスクラメーションマークがステータスバーに表示されます。 注: ファームウェアバージョンの詳細については、「ファームウェアバージョン」のトピックを参照してください。
Version: 5.6.0


TestRun - EasyBuilder ビュー

In-Sight Explorer GUI リファレンス

対象となる In-Sight ビジョンシステムに接続し、該当する .job ファイルをビジョンシステムにロードしたら、TestRun の設定を開始する必要があります。TestRun を設定するには、[TestRun セットアップ] ダイアログを使用します。ここでは、TestRun をプログラムするための一連の画面がステップ単位で表示されます。ダイアログの左側にはナビゲーションペインが表示されており、ここで設定画面のいずれかを選択できます。

注: TestRun の初期設定が完了した後に、いずれかのステップを再度確認するには、ナビゲーションペインでそのステップを選択します。

  • [画像データベースフォルダ]
  • [バリアントの設定]
  • [ジョブ/バリアント] - [アクションのセットアップ]
  • [ジョブ/バリアント] - [リミットテスト]
  • [ジョブ/バリアント] - [画像の選択]
  • [ジョブ/バリアント] - [欠陥テスト]
  • [ハードウェアテスト] - [アクションのセットアップ]
  • [ハードウェアテスト] - [テスト]
  • [クリーンアップアクション]

[TestRun セットアップ] ダイアログを設定したら、[パレット] に戻り、次のボタンを使用してそれぞれの処理を行います。

  • [新規]:新しい TestRun テストを作成します。
  • [設定]:[TestRun セットアップ] ダイアログを起動します。
  • [実行]:既存の TestRun テストを実行します。

    • 注: In-Sight ファームウェアバージョン 4.10.x、または In-Sight ファームウェア 5.6.0 以上を実行している In-Sight ビジョンシステムでは、EtherNet/IP 通信または PROFINET 通信経由で、PLC などの外部デバイスからも TestRun を開始できるようになりました。

  • [修復]:壊れたテストまたは値を修復します。
  • [インポート]:以前に作成したテストをインポートします。
  • [エクスポート]:テストをエクスポートします。
  • [バッチ実行]: TestRun を設定して .job ファイルのバッチを実行する際に使用する [TestRun バッチ実行] ダイアログを開きます。

TestRun を表示するには

  1. [パレット] で、[TestRun™] タブをクリックします。

注: [パレット] が表示されない場合は、[表示] メニューから [パレット] を選択します。

  2. [設定] ボタンをクリックして、[TestRun セットアップ] ダイアログを起動します。
  3. [TestRun セットアップ] ダイアログのステップをすべて設定したら、[パレット] の [TestRun] タブにある [image] [実行] ボタンをクリックして、テストを実行します。

注: [TestRun セットアップ] ダイアログの設定を完了したら、[パレット] で使用できるすべてのボタンが表示された右クリックメニューが選択できるようになります。さらに、テストの特定のセクションからテストを実行する機能も使用できるようになります (例えば、ジョブテストを実行せずにハードウェアテストから開始する、など)。

[画像データベースフォルダ]

TestRun を EasyBuilder ビューで使用している場合、[TestRun セットアップ] ダイアログの最初のステップで表示される画面は、[画像データベースフォルダ] です。[画像データベースフォルダ] ステップでは、テストを作成するのに使用される格納画像へのリンクを生成します。

このステップでは、テスト画像データベースへのパスを生成します。ディレクトリパスでは、次のいずれかのフォーマットを使用する必要があります。

  • C:\TestRun\BracketJob
  • file:///\\TestRun\BracketJob
  • ftp://TestRunServer/BracketJob
  • ftp://10.28.127.73/BracketJob

注:シグナル駆動の TestRun 用に設定されたビジョンシステムの場合、FTP サーバを使用するように [画像データベースフォルダ] を設定する必要があります。

画像はすべて、1 つの共通のルートフォルダに格納する必要があります。画像が複数のフォルダに格納されている場合は、すべての画像とそのサブフォルダが含まれているフォルダを選択します。TestRun が各種ファイル構造に対応できる場合は、次のタイプの構造を使用することを推奨します。

このタイプの構造を使用すると、「画像データベース」フォルダが選択されます。

最後に、[未知の画像] ドロップダウンメニューを設定します (無視、Pass と仮定、Fail と仮定、デフォルト = 無視)。[未知の画像] ドロップダウンを使用して、[画像の選択] ステップでは明示的に TestRun に追加されなかった画像の、TestRun による処理方法を決定します。ドロップダウンを [無視] に設定すると、設定されていない画像を TestRun で単純に無視することができます。ドロップダウンを [Pass と仮定] に設定すると、画像に対するジョブは TestRun で成功したものとみなされます。ドロップダウンを [Fail と仮定] に設定すると、画像に対するジョブは TestRun で失敗したものとみなされます。

TestRun 画像データベースで使用するフォルダの選択

  1. [参照] ボタンをクリックします。
  2. [フォルダの参照] ダイアログで、保存先の画像フォルダに移動して選択します。フォルダを選択してから [OK] ボタンをクリックします。
    3. 注:
    • 既に画像フォルダにアクセスしている場合は、ドロップダウンメニューから選択できます。

    • シグナル駆動の TestRun 用に設定されたビジョンシステムの場合、FTP サーバを使用するように [画像データベースフォルダ] を設定する必要があります。
  3. 必要に応じて、画像ディレクトリにアクセスするためのユーザ名とパスワードを入力します。

注: TestRun の [画像データベースフォルダ] 設定時に、ジョブの開発者が自分自身の特定のユーザ認証を使用して、TestRun が別のアプリケーションで使用するフォルダにアクセスした場合 (例えば、Windows Explorer を使用して、ネットワークフォルダの画像を表示する場合など) に、別のユーザ認証が指定されている場合 (例えば、ライン上のオペレータが使用する汎用のユーザ名とパスワードなど)、TestRun はそのフォルダにアクセスすることはできません。この状態から復旧するには、フォルダにアクセスしているアプリケーションを閉じてから、[TestRun セットアップ] ダイアログを閉じて再度開きます。

  4. 必要に応じて、ドメインの情報を入力します。
  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。
  6. このステップから抜けると、TestRun は、自動的に .jpg および .bmp 画像ファイル用の画像ディレクトリを検索します。
注:
  • 以前にこのステップを設定済みの場合、TestRun は、ディレクトリに格納されているファイルに関する情報を保持します。画像の場所が変更されると、画像の場所を基準にしたパスに基づいて画像を照合し、照合した画像ごとにそのプロパティを転送します。
  • フォルダが生成されると、ドロップダウンメニューの下に次の項目が表示されます。フォルダ内の画像の総数、以前に [ジョブ]　→ [画像の選択] 画面で設定した画像の数、以前に設定した際にはフォルダ内に存在していたが、現在は存在していない画像の数、および最後に設定してからフォルダに新しく追加された画像の数。

[バリアントの設定]

通常 1 つのジョブには、1 つ以上の検査が含まれています。ジョブ内のそれぞれの検査は、ジョブバリアントとみなされます。例えば、以降何度もジョブを変更するのを避けるために、複数の製品を処理するようにジョブを作成するとします。この場合、ジョブ内のそれぞれの検査は、ジョブバリアントとみなされます。

通常、外部入力 (例えば、PLC からのコマンド) によって複数のバリアントを選択します。各バリアントには、独自のビジョンツールセット、別のサーチ領域、別の露光設定値などがあります。TestRun では、ジョブ内のすべてのバリアントをテストできます。

注:各ジョブバリアントは、個別に設定します。

ジョブバリアントの追加

  1. デフォルトでは、「ジョブ」という名前のバリアントが自動的に追加されます。

注: 名前を変更するには、対象のバリアントを選択し、[名前の変更] ボタンをクリックしてから、新しい名前を入力します。名前を変更したら、設定ステップペインにある名前が自動的に更新されます。

  2. [追加] ボタンをクリックして、新しいバリアントを作成します。
  3. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブバリアントの並べ替え

注:バリアントの順序を変更すると、TestRun テストの実行順序が変更されます。

  1. バリアントを選択します。
  2. 目的の方向に応じて、[上に移動] または [下に移動] のいずれかのボタンをクリックします。
  3. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - アクションのセットアップ

テストを開始するには、TestRun でジョブの一部のパラメータを設定し、実行する特定のバリアントを設定する際にオペレータが実行する動作をコピーします。通常、ジョブに複数のバリアントがある場合は、設定の一部を、選択したバリアント用のジョブに合わせる必要があります。TestRun で特定のバリアント用の画像を処理するには、最初にそれに応じてジョブの状態を設定する必要があります。[アクションのセットアップ] のステップでは、選択したバリアントの画像に必要なパラメータを設定します。

[アクションのセットアップ] 画面は、2 つの列から構成されます。1 つは [シンボル] 列で、ここにはシンボリックタグ付きジョブの設定値がすべて表示されます。もう 1 つは [アクションのセットアップ] 列で、ここには TestRun で設定するジョブのパラメータ設定値がすべて表示されます。

ジョブを設定して現在のバリアントをテスト

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - リミットテスト

マシンビジョンアプリケーションには多数のパラメータが用意されており、これらは必要に応じてマシンオペレータやメンテナンス技術者が調整できます。ビジョンアプリケーションの開発者は、TestRun のリミットテストを使用して、テストする調整可能なパラメータの選択、そのパラメータの上限値および下限値の設定、およびそのパラメータが設定した限界値内に収まっているかどうかの判別を行うことができます。例えば、開発者はシステムを引き続き動作させるために、TestRun のハードコーディングされた限界値をオペレータや技術者が柔軟に調整できるように設定することができます。さらに、パラメータが範囲を外れたことを確認することもできます。

[リミットテスト] 画面では、編集可能なパラメータ限界値に関するテストを設定できます。この画面は、2 つの列から構成されています。1 つは [シンボル] 列で、ここにはシンボリックタグ付きジョブの設定値がすべて表示されます。もう 1 つは [リミットテスト] 列で、ここには TestRun でテストするジョブのパラメータ設定値がすべて表示されます。

限界をテストするための変数の選択と設定

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[リミットテスト] 列に設定が自動的に入力されます。
  3. 設定を有効にして [リミットテスト] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。使用可能なテストのタイプは、編集可能なパラメータのタイプに応じて決まります。
  • EditInt 関数: [Is In Range]
  • EditFloat 関数: [Is In Range]
  • EditString 関数: [Is Equal]
  • ListBox 関数: [Is Equal]
  • CheckBox 関数: [Is Equal]
  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - 画像の選択

この画面では、特定のバリアントのテスト時に使用される画像を選択し、「良好」または「不良」のいずれかとして定義します。この場合、「良好」画像の状態は合格で、「不良」画像の状態は不合格です。

注: 画像はバリアント内で共有できます。

このバリアントの画像を選択し、画像を「良好」または「不良」として定義します。

  1. ツリーコントロールを使用して、画像のディレクトリを展開します。
  2. ディレクトリに「良好」および「不良」画像が混在して含まれている場合に個別の画像を選択するには、その画像をオンにしてから、ディレクトリの下にあるセレクタを使用し、[良好] または [不良] として定義します。必要に応じて、画像に関するコメントを追加します。
  3. ディレクトリが「良好」および「不良」画像を含む別々のディレクトリに分割されている場合は、トップレベルをオンにしてそのグループ内にあるすべての画像をオンにし、トップレベルで同じ分類 ([良好] または [不良]) を共有します。
  4. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - 欠陥テスト

[欠陥テスト] 画面では、画像とそれに対応して想定される欠陥が互いに関連付けられており、データベース内の各画像に対して、想定される結果を示すデータベースが作成されています。この画面で欠陥テストを設定するには、各画像に存在する欠陥 (ある場合) を選択して、その欠陥をジョブのパラメータの想定される結果に関連付けます。

初期のデフォルト設定では、各画像に対して [ジョブ FAIL] という欠陥が存在しています。これは、「不良」画像として指定されたすべての画像に対して自動的にオンになります。欠陥がチェック (オン) されることは、その画像に欠陥が存在することを示します。欠陥テストは、ビジョンアプリケーションが画像の合格または不合格を誤って判定した理由を特定するのに役立ちます。大部分のビジョンアプリケーションでは、1 つの画像に対して複数の検査が実行され、それを総合して全体の合格/不合格の結果が生成されます。ビジョン設計者は、TestRun を使用すると、個別の画像の合格/不合格を判定できるだけではなく、特定の欠陥を想定して実際に検出することができます。

例えば、穴が欠落しているために部品が「不良」と判定された場合、TestRun では、実際に部品に穴が欠落しているとジョブで判定されたために、その部品が不合格になったことを確認するのに役立ちます。フィクスチャとして使用したツールが、穴が欠落しているために部品を不合格と判定したとします。これは、ツールのサーチ領域が穴が欠落していることを特定して画像を取り込むのに十分な大きさを持っていたからで、元々このツールは穴の欠落を特定するためのツールではなかった場合、ジョブのロジックは正常には実行されておらず、TestRun はその不一致を特定するのに使用できます。

注: [欠陥テスト] 画面に移動すると、現在選択されているバリアントに対して設定操作が実行され、ジョブの状態が適切に設定されているかどうかが確認されます。

テストする欠陥の定義

  1. 画像を選択します。
  2. デフォルトの欠陥 [ジョブ FAIL] を設定します。
  3. 必要に応じて別の欠陥を追加し、それに対して想定される結果を定義します。

画像の選択

  1. 処理を開始するには、最初に [画像] グループボックスにある画像再生ボタンを使用して、画像を選択します。[次の画像] ボタンをクリックして、画像を進めます。

注: TestRun では、[画像の選択] ステップで定義した画像が使用されます。

  2. [画像] グループボックスおよび EasyBuilder ビューに画像が表示されます。画像とその名前が含まれるフォルダが、画面上部のドロップダウンに表示されます。
  3. 以前に定義した欠陥に対して想定される結果も更新されます。

欠陥 [ジョブ FAIL] の想定される結果の設定

  1. デフォルトでは、欠陥 [ジョブ FAIL] が自動的に追加されて有効になります (チェックボックスがオンになります)。欠陥 [ジョブ FAIL] では、ジョブ全体がエラーを返すかどうかを決定するための想定される結果が定義されます。
  2. 欠陥 [ジョブ FAIL] を定義するには、[欠陥] グループボックスで、「次の場合、欠陥　"(欠陥名)"　が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します (デフォルトでは、「<ジョブ PASS/FAIL>」が選択されています)。[ジョブ FAIL] はシンボリックタグではありませんが、[<ジョブ PASS/FAIL>] のセルとして設定されたセルをテストします。
  3. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。

別の欠陥の追加および想定される結果の定義

  1. [追加] ボタンをクリックします。
  2. デフォルトの名前が「欠陥」である欠陥が追加されます。デフォルトでは、新しく追加した欠陥が有効にされます (チェックボックスがオンになります)。

注: 既に欠陥が追加されており、デフォルトの名前のままである場合、TestRun は名前の数値を 1 つ増加させます (例えば、「Defect01」、「Defect02」など)。[名前の変更] ボタンをクリックして、デフォルトの名前を編集し、欠陥にわかりやすい名前を割り当てます。

  3. [欠陥] グループボックスで、「次の場合欠陥　"欠陥"　が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  4. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。
  5. 必要に応じて、オンにしたエディットコントロールを使用し、テストを設定します。
  6. 必要に応じて、手順 1 ～ 4 を繰り返し、欠陥を追加します。

欠陥の編集

  1. リストから欠陥を選択します。
  2. [欠陥] グループボックスで、「次の場合欠陥 "(欠陥名)" が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  3. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。

[ハードウェアテスト-アクションのセットアップ]

TestRun でテストを行い、In-Sight ビジョンシステムが正しい画像を取り込んでいるかを確認するには、最初にそれに応じてジョブの状態を設定する必要があります。この画面では、テストを行う前にパラメータ設定を有効にして、ビジョンシステムが正しい画像を取り込んでいるかを確認します。

ジョブを設定して TestRun のハードウェアテストを実行

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。
  7. [アクションのセットアップ] のプログラムを実行したら、TestRun は自動的に In-Sight ビジョンシステムをトリガし、画像を取り込みます。

[ハードウェアテスト - テスト]

このステップでは、テストを設定して、取り込んだ画像が正しいかを確認します。TestRun では、特定のジョブパラメータとその想定される結果を画像と関連付けることによって、画像が正しい結果を生成しているかどうかを判別することができます。例えば、レンズが汚れているために、画像が不鮮明、傷がついている、または暗くなっているとします。この場合、In-Sight ビジョンシステムに不用意に接触すると、その視野 (FOV) が変わることがあります。または、ビジョンシステムに接続されているレンズのフォーカスや絞りが、振動によって時間とともに変化することがあります。このような状態をテストするには、ジョブパラメータを想定される結果に関連付けます。想定される結果が返されない場合は、画像処理に問題が発生しています。

FOV が正しいかどうかを判別するには、部品の特徴 (または、部品がない場合の背景) を使用します。画像に特徴が存在しない場合、FOV が変わっています。部品が検査前にフィクスチャに置かれている場合は、フィクスチャの 4 つの隅の特徴を使用して適切な FOV を設定できます。特徴がない場合、FOV が変わっています。または、特徴が近すぎるか離れすぎている場合は、In-Sight ビジョンシステムと FOV の間の距離が変化している可能性があります。特徴が矩形を形成しているが、四辺形ではない場合、ビジョンシステムに接触して軸がずれ、遠近歪みが生じている可能性があります。

TestRun ビジョンシステムの画像取り込みテストの定義

  1. 画像を取り込みます。
  2. 必要に応じて、テストを追加し、設定します。

画像の取り込み

  1. [画像] グループボックスの下の [手動トリガ] ボタンをクリックし、In-Sight ビジョンシステムから画像を取り込みます。
  2. [画像] グループボックスおよび EasyBuilder ビューに画像が表示されます。

注: または、[画像のロード] ボタンをクリックして [開く] ダイアログを表示し、画像ファイルに移動します。

テストの追加と設定

  1. [ハードウェアテスト] グループボックスで、[追加] ボタンをクリックします。
  2. デフォルトの名前が「テスト」というテストが追加され、[テスト] グループボックスに置かれます。ここで、設定を行うことができます。

注: 既にテストが追加されており、デフォルトの名前のままである場合、TestRun は名前の数値を 1 つ増加させます (例えば、「Test01」、「Test02」など)。[名前変更] ボタンをクリックして、デフォルトの名前を編集し、テストにわかりやすい名前を割り当てます。

  3. [テスト] グループボックスで、「次の場合欠陥 "xxx" が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  4. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。
  5. 必要に応じて、手順 1 ～ 4 を繰り返し、テストを追加します。

クリーンアップアクション

テストが完了したら、それに応じてジョブの状態を設定する必要があります。このステップでは、TestRun がテストを完了した後、ジョブを目的の状態に設定するのに必要な設定操作を定義します。

TestRun を設定して、テスト後にジョブパラメータを設定

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。
  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [閉じる] ボタンをクリックして、TestRun の設定を完了します。
  7. [TestRun セットアップ] ダイアログを閉じたら、[パレット] の [TestRun] タブにある [image] [実行] アイコンをクリックして、TestRun テストを実行します。

注: [TestRun セットアップ] ダイアログの設定を完了したら、[パレット] で使用できるすべてのボタンが表示された右クリックメニューが選択できるようになります。さらに、テストの特定のセクションからテストを実行する機能も使用できるようになります (例えば、ジョブテストを実行せずにハードウェアテストから開始する、など)。


キーボードのショートカット

ナビゲーションとショートカット

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

このセクションでは、EasyBuilder GUI の全体で操作を実行できるキーボードとマウス両方のショートカットについて説明します。

  • EasyBuilder のショートカット: アクティブな EasyBuilder ビュー内で実行できる操作。
  • Explorer のショートカット: 複数の EasyBuilder ビュー、GUI コンポーネントおよび EasyBuilder アプリケーションに全体として影響を与える操作。
  • OCV/OCR のショートカット: フォントの登録処理時の文字セグメント変更中に実行できる操作。

Explorer のショートカット

操作 | キーボード | マウス
In-Sight Explorer オンラインヘルプを開く | F1 | [ヘルプ] メニューで、[In-Sight Explorer のヘルプ] をクリックします。または、[Explorer] ツールバーで、[In-Sight Explorer のヘルプ] [image] ボタンをクリックします。
[In-Sight のネットワーク] ペインおよび [In-Sight のファイル] ペインを更新 | N/A | [接続] 設定ペインで、[更新] をクリックします。または、[表示] メニューで [更新] をクリックします。
コピー 1 | CTRL+C | [標準] ツールバーで、[コピー] [image] ボタンをクリックします。
貼り付け 1 | CTRL+V | [標準] ツールバーで、[貼り付け] [image] ボタンをクリックします。
[Program Icon (プログラムアイコン)] メニュー Closed を表示 [Program Icon (プログラムアイコン)] メニューでは、矢印キーを使用してアプリケーションウィンドウの位置とサイズを制御できます。このメニューから In-Sight Explorer を復元、最大化、最小化、および閉じることもできます。 | ALT+ スペースキー | アプリケーションウィンドウの左上隅にある [Program Icon (プログラムアイコン)] [image] をクリックします。
メニューバーにアクセス | ALT または F10 | 任意のメニュー項目をクリックします。
メニューバーを移動 | 矢印キー | メニューをクリックします。
メニューバーを選択 | ENTER | 項目をクリックします。
表示レイアウトを保存 | SHIFT+F7 | [システム] メニューで [表示レイアウトを保存] をクリックします。
再生フォルダに保存されている最初の画像に移動 | N/A | EasyBuilder ツールバーで [最初の画像] [image] ボタンをクリックします。
再生フォルダに保存されている前の画像に移動 | N/A | EasyBuilder ツールバーで、[前の画像] [image] ボタンをクリックします。
再生フォルダに保存されている画像の再生と一時停止を切り替え | N/A | EasyBuilder ツールバーで、[再生] [image] ボタンまたは [一時停止] [image] ボタンをクリックします。
再生フォルダに保存されている次の画像に移動 | N/A | EasyBuilder ツールバーで、[次の画像] [image] ボタンをクリックします。
再生フォルダに保存されている最後の画像に移動 | N/A | EasyBuilder ツールバーで、[最後の画像] [image] ボタンをクリックします。
取り込んだ画像の記録フォルダへの記録と停止を切り替え | N/A | EasyBuilder ツールバーで、[記録] [image] ボタンまたは [Stop Recording (記録の停止)] [image] ボタンをクリックします。
[記録/再生のオプション] ダイアログを開いて、記録および再生の設定を行う | N/A | EasyBuilder ツールバーで [記録/再生のオプション] [image] ボタンをクリックします。
1 これらの操作は、[位置決め] ステップおよび [検査] ステップの両方のツールと、[In-Sight のファイル] ペイン内のファイルで動作します。

OCV/OCR セグメント編集のショートカット

操作 | キーボード | マウス
次のセグメントをハイライト (変更) | CTRL+→ キーまたは CTRL+← キー | 目的のセグメントをクリックします。
次のセグメントをハイライト (ラベルの変更、削除) | 矢印キー | 目的のセグメントをクリックします。
セグメントを承諾 (変更、ラベルの変更、削除) | ENTER | 目的のセグメントをダブルクリックします。
対話型グラフィックス編集モードを切り替え (変更) | F9 | N/A

スプレッドシートビュー

このセクションでは、In-Sight Explorer インタフェースの全体で操作を実行できるキーボードとマウス両方のショートカットについて説明します。

  • スプレッドシートのショートカット: アクティブなスプレッドシートまたはスプレッドシートビュー内で実行できる操作。
  • Explorer のショートカット: 複数のスプレッドシートビュー、GUI コンポーネントおよび In-Sight Explorer アプリケーションに全体として影響を与える操作。
  • OCV/OCR のショートカット: フォントの登録処理時の文字セグメント変更中に実行できる操作。
  • プロパティシートのショートカット: プロパティシートが表示されているときに実行できる操作。
  • 対話型グラフィックスモードのショートカット: 対話型グラフィックス領域の調整時に実行できる操作。

スプレッドシートのショートカット

操作 | キーボード | マウス
ヘルプ | F1 | [ヘルプ] メニューで、[In-Sight Explorer のヘルプ] をクリックします。または、[Explorer] ツールバーで、[In-Sight Explorer のヘルプ] [image] ボタンをクリックします。
新規画像の取り込み | F5 | [ジョブの表示] ツールバーで、[トリガ] [image] ボタンをクリックします。
ジョブの新規作成 | CTRL+N | [標準] ツールバーで、[ジョブの新規作成] [image] ボタンをクリックします。
アクティブセルで新しい数式を開始 1 | 等号 (=) | 空白のセルをダブルクリックします。
アクティブセルの数式を編集する | F2 | 数式バー内をクリックします。
アクティブセルにテキストラベルを挿入 1 | アポストロフィ (') | N/A
新規または変更された数式を受諾 | ENTER | [ジョブの編集] ツールバーで、[OK] [image] ボタンをクリックします。
新規または変更された数式を取り消す | ESC | [ジョブの編集] ツールバーで、[キャンセル] [image] ボタンをクリックします。
ジョブを開く | CTRL+O または CTRL+F12 | [標準] ツールバーで、[ジョブを開く] [image] ボタンをクリックします。
ジョブを保存 2 | CTRL+S または SHIFT+F12 | [標準] ツールバーで、[ジョブの保存] [image] ボタンをクリックします。
ジョブに名前を付けて保存 | F12 | [ファイル] メニューで、[ジョブに名前を付けて保存] をクリックします。
画像を開く | CTRL+SHIFT + O | [ファイル] メニューで、[画像を開く] をクリックします。
画像に名前を付けて保存 | CTRL + SHIFT + S | [ファイル] メニューで、[画像に名前を付けて保存] をクリックします。
[ページ設定] ダイアログを開く | CTRL+ALT+P | [ファイル] メニューで、[ページ設定] をクリックします。
[印刷プレビュー] ウィンドウを開く | CTRL+SHIFT+P | [標準] ツールバーで、[印刷プレビュー] [image] ボタンをクリックします。
[印刷] ダイアログを開く | CTRL+P | [標準] ツールバーで、[Print Sheet (シートの印刷)] [image] ボタンをクリックします。
[関数の挿入] ダイアログを開く 3 | CTRL+SHIFT+F または SHIFT+F3 | [ジョブの編集] ツールバーで、[関数] [image] ボタンをクリックします。
スプレッドシートを移動 | 矢印キー | 目的のセルをクリックします。
相対セル参照を挿入 | CTRL+SHIFT+R | [ジョブの編集] ツールバーで、[相対参照] [image] ボタンをクリックします。
絶対セル参照を挿入 | CTRL+SHIFT+A | [ジョブの編集] ツールバーで、[絶対参照] [image] ボタンをクリックします。
カーソルがセルのテキストボックス内に置かれているときに、4 つのセル参照タイプを切り替え | F4 | N/A
セル A0 にジャンプ | CTRL+HOME | N/A
セル Z399 にジャンプ | CTRL+END | N/A
現在の行のはじめ (列 A) にジャンプ | HOME | N/A
現在の行の終わり (列 Z) にジャンプ | END | N/A
1 つ上のページにジャンプ | PAGE UP | スライダと上向き矢印の間にある縦のスクロールバーをクリックします。
1 つ下のページにジャンプ | PAGE DOWN | スライダと下向き矢印の間にある縦のスクロールバーをクリックします。
行内のセルをマーク | SHIFT+→ キー SHIFT+← キー | マウスポインタをクリックして右または左にドラッグします。
列内のセルをマーク | SHIFT+↑ キー SHIFT+↓ キー | マウスポインタをクリックして上または下にドラッグします。
行全体をマーク | SHIFT+ スペースキー ヒント: 行をハイライトすると、SHIFT+ ↑ キーまたは SHIFT+ ↓ キーを押して複数の行をマークすることができます。 | 行のヘッダをクリックします。ドラッグして複数の行を選択します。
列全体をマーク | CTRL+ スペースキー ヒント: 列をハイライトすると、SHIFT+ → キーまたは SHIFT+ ← キーを押して複数の列をマークすることができます。 | 列のヘッダをクリックします。ドラッグして複数の列を選択します。
コピー | CTRL+C または CTRL+INSERT | [標準] ツールバーで、[コピー] [image] ボタンをクリックします。
スプレッドシートの表示された部分の画像をクリップボードにコピー | CTRL+SHIFT+C | N/A
切り取り | CTRL+X または SHIFT+DELETE | [標準] ツールバーで、[切り取り] [image] ボタンをクリックします。
貼り付け | CTRL+V または SHIFT+INSERT | [標準] ツールバーで、[貼り付け] [image] ボタンをクリックします。
コンテンツのクリア | CTRL+D または DELETE | [編集] メニューで、[クリア] → [コンテンツ] をクリックします。
すべてをクリア | CTRL+SHIFT+D | [編集] メニューで、[クリア] → [すべて] をクリックします。
テキストを検索 | CTRL+F | [標準] ツールバーで、[検索] [image] ボタンをクリックします。
セルに移動 | CTRL+G | [編集] メニューで、[移動] をクリックします。
操作を元に戻す | CTRL+Z | [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。
操作をやり直し | CTRL+Y | [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。
セルのフォーマット | CTRL+1 | [フォーマット] ツールバーで、[セルのフォーマット] [image] ボタンをクリックします。
選択したセルに太字フォーマットを適用 | CTRL+B | [フォーマット] ツールバーで、[太字] [image] ボタンをクリックします。
選択したセルに斜体フォーマットを適用 | CTRL+I | [フォーマット] ツールバーで、[斜体] [image] ボタンをクリックします。
変更を確定する | ENTER | [OK] をクリックします。
変更をキャンセルする | ESC | [キャンセル] をクリックします。
オンライン/オフラインモードを切り替え | CTRL+F8 | [ジョブの表示] ツールバーで、[オンライン/オフライン] [image] ボタンをクリックします。
対話型グラフィックス領域を編集 | F9 | [ジョブの表示] ツールバーで、[セルグラフィックスの編集] [image] ボタンをクリックします。
スプレッドシート内のすべての対話型グラフィックスの色を変更 | SHIFT+F9 | N/A
デフォルトのセルグラフィックスの領域サイズを、参照している [image] データ構造体の画像領域と同じサイズに変更 | Ctrl+Shift+M | [ジョブの編集] ツールバーで、[Maximize Cell Region (セル領域の最大化)] [image] ボタンをクリックします。
画像を拡大 | SHIFT+ プラス (テンキーの +) または CTRL+ マウスを左クリック (このオプションは、スプレッドシートのオーバレイが非表示の場合にのみ利用できます) | [ジョブの表示] ツールバーで、[拡大] [image] ボタンをクリックします。
画像を縮小 | SHIFT+ マイナス (テンキーの -) | [ジョブの表示] ツールバーで、[縮小] [image] ボタンをクリックします。
画像の 1 ピクセルに対して PC ディスプレイの 1 ピクセルで表示するように画像を拡大 | SHIFT+ 乗算 (テンキーの *) | [ジョブの表示] ツールバーで、[倍率 1:1] [image] ボタンをクリックします。
拡大した画像をパン。パンを有効にするには、拡大した画像が、スプレッドシートビューウィンドウの外にまで拡大している必要があります。 注: この機能は、スプレッドシートのオーバレイが非表示の場合にのみ利用できます。 | SHIFT+CTRL+ マウスを左クリックして [image] カーソルをドラッグします。 | N/A
領域の大きさに拡大: 画像領域の周囲に点の矩形を作成して拡大します。ユーザ定義済みの矩形が拡大してスプレッドシートビュー全体を埋めます。矩形の作成時は、カーソルの最初の位置が矩形の中心になります。倍率が最大になると、領域の大きさに拡大は無効になります。 注: この機能は、スプレッドシートのオーバレイが非表示の場合にのみ利用できます。 | CTRL+ マウスを左クリックして [image] カーソルをドラッグします。 領域の大きさに拡大モードを終了するには、CTRL キーを離します。カーソルは、標準の [image] カーソルに戻ります。 | N/A
シートを拡大 | CTRL+プラス (テンキーの +) | [ジョブの表示] ツールバーで、[シートズーム] の倍率 [image] を上げます。
シートを縮小 | CTRL+マイナス (テンキーの -) | [ジョブの表示] ツールバーで、[シートズーム] の倍率 [image] を下げます。
シートを、選択したセルの範囲に適合するように拡大するか、単一のセルが選択されている場合に 100% に拡大 | CTRL+ 乗算 (テンキーの *) | [ジョブの表示] ツールバーで、[シートズーム] の倍率 [image] を目的の数値に変更します。
画像の向きを変更 | SHIFT+ 除算 (テンキーの /) | [ジョブの表示] ツールバーで、[Rotate Image (画像の回転)] [image] ボタンをクリックします。
スプレッドシートの関数に関連付けられているオーバレイグラフィックスの表示/非表示を切り替え | Ctrl+Shift+G | [ジョブの表示] ツールバーで、[Graphics (グラフィックス)] [image] ボタンをクリックします。
グレーレベルが [露光過少レベル] 以下の画像内のピクセルを青色でハイライトし、[露光過多レベル] 以上のピクセルを赤色でハイライト | Ctrl+Shift+S | [ジョブの表示] ツールバーで、[露光過多・過少を表示] [image] ボタンをクリックします。
トレース矢印の表示を ON にして、表示する依存関係のトレースレベルを 1 段階上げる | F11 | [ジョブの監査] ツールバーで、[Show Dependency Levels Increase (依存レベルの上昇を表示)] [image] ボタンを押します。
表示する依存関係のトレースレベルを 1 段階減らす | SHIFT+F11 | [ジョブの監査] ツールバーで、[Show Dependency Levels Decrease (依存レベルの下降を表示)] [image] ボタンを押します。
トレース矢印をすべて消去 | CTRL+F11 | [ジョブの監査] ツールバーで、[Show Dependency Levels Reset (依存レベルのリセットを表示)] [image] ボタンを押します。
参照元セルがエラー (#ERR) の依存関係のみを表示 | ALT+F11 | [ジョブの監査] ツールバーで、[エラーのある依存関係のみ表示] [image] ボタンを押します。
アクティブセルの最初の #ERR 参照元にジャンプ | CTRL+SHIFT+F11 | [ジョブの監査] ツールバーで、[エラー元セルにジャンプ] [image] ボタンを押します。
スプレッドシートオーバレイの表示/非表示を切り替え | SHIFT+F6 | [ジョブの表示] ツールバーで、[Show Overlay (オーバレイを表示)] [image] ボタンをクリックします。
カスタムビューを切り替え | F6 | [ジョブの表示] ツールバーで、[Show Custom View (カスタムビューを表示)] [image] ボタンをクリックします。
表示されている次のスプレッドシートビューまたはステータスビューにジャンプ 4 | CTRL+F6 | 目的のビューをクリックします。または、[ウィンドウ] メニューで目的のビューを選択します。
アクティブなスプレッドシートビューまたはステータスビューを閉じる | CTRL+F4 | 目的のビューで、[閉じる] [image] ボタンをクリックします。
表示レイアウトを保存 | SHIFT+F7 | [システム] メニューの [表示レイアウトを保存] をクリックします。
右クリックメニューを表示 | SHIFT+F10 | 項目を右クリックします。
1 アクティブセルは空白である必要があります。 2 ジョブが少なくとも 1 回保存されていないと、この操作では [ジョブに名前を付けて保存] ダイアログが表示されます。 3 アクティブセルにプロパティシートを持つ関数が含まれている場合は、[関数の挿入] ダイアログの代わりにプロパティシートが開きます。 4 この操作が機能するためには、少なくとも 2 つのビュー (スプレッドシートまたはステータスのいずれか) が表示されている必要があります。

Explorer のショートカット

操作 | キーボード | マウス
ヘルプ | F1 | [ヘルプ] メニューで、[In-Sight Explorer のヘルプ] をクリックします。
[In-Sight のネットワーク] ペインおよび [In-Sight のファイル] ペインを更新 | 1.いずれかのペインに到達するまで、TAB キーを押します。 2.F5 キーを押します。 | [表示] メニューで、[更新] をクリックします。
コピー 1 | CTRL+C または CTRL+INSERT | [標準] ツールバーで、[コピー] [image] ボタンをクリックします。
切り取り 1 | CTRL+X または SHIFT+DELETE | [標準] ツールバーで、[切り取り] [image] ボタンをクリックします。
貼り付け 1 | CTRL+V または SHIFT+INSERT | [標準] ツールバーで、[貼り付け] [image] ボタンをクリックします。
コンテンツのクリア 1 | CTRL+D または DELETE | [編集] メニューで、[クリア] → [コンテンツ] をクリックします。
右クリックメニューを表示 | SHIFT+F10 | 項目を右クリックします。
[Program Icon (プログラムアイコン)] メニュー Closed を表示 [Program Icon (プログラムアイコン)] メニューでは、矢印キーを使用してアプリケーションウィンドウの位置とサイズを制御できます。このメニューから In-Sight Explorer を復元、最大化、最小化、および閉じることもできます。 | ALT+ スペースキー | アプリケーションウィンドウの左上隅にある [Program Icon (プログラムアイコン)] [image] をクリックします。
メニューバーにアクセス | ALT または F10 | 任意のメニュー項目をクリックします。
メニューバーを移動 | 矢印キー | メニューをクリックします。
メニューバーを選択 | ENTER | 項目をクリックします。
表示レイアウトを保存 | SHIFT+F7 | [システム] メニューで [表示レイアウトを保存] をクリックします。
再生フォルダに保存されている最初の画像に移動 | CTRL+H | [記録/再生] ツールバーで [最初の画像] [image] ボタンをクリックします。
再生フォルダに保存されている前の画像に移動 | CTRL+J | [記録/再生] ツールバーで [前の画像] [image] ボタンをクリックします。
再生フォルダに保存されている画像の再生と一時停止を切り替え | CTRL+M | [記録/再生] ツールバーで、[再生] [image] ボタンまたは [一時停止] [image] ボタンをクリックします。
再生フォルダに保存されている次の画像に移動 | CTRL+K | [記録/再生] ツールバーで [次の画像] [image] ボタンをクリックします。
再生フォルダに保存されている最後の画像に移動 | CTRL+L | [記録/再生] ツールバーで [最後の画像] [image] ボタンをクリックします。
取り込んだ画像の記録フォルダへの記録と停止を切り替え | CTRL+R | [記録/再生] ツールバーで、[記録] [image] ボタンまたは [Stop Recording (記録の停止)] [image] ボタンをクリックします。
[記録/再生のオプション] ダイアログを開いて、記録および再生の設定を行う | CTRL+T | [記録/再生] ツールバーで [記録/再生のオプション] [image] ボタンをクリックします。
1 これらの操作は、スプレッドシートのセルデータと [In-Sight のファイル] ペイン内のファイルの両方で機能します。

OCV/OCR セグメント編集のショートカット

操作 | キーボード | マウス
次のセグメントをハイライト (変更) | CTRL+→ キーまたは CTRL+← キー | 目的のセグメントをクリックします。
次のセグメントをハイライト (ラベルの変更、削除) | 矢印キー | 目的のセグメントをクリックします。
セグメントを承諾 (変更、ラベルの変更、削除) | ENTER | 目的のセグメントをダブルクリックします。
対話型グラフィックス編集モードを切り替え (変更) | F9 | N/A
画像の拡大および画像のパンを含む OCV/OCR セグメントの編集コマンドの詳細については、「対話型グラフィックスモードのショートカット」を参照してください。
Version: 5.6.0


EasyBuilder ジョブおよびスプレッドシート

EasyBuilder ジョブおよびスプレッドシート

スプレッドシートでの EasyBuilder ジョブの編集

スプレッドシートでの EasyBuilder ツールパラメータの追加、削除および名前変更

スプレッドシートでの EasyBuilder ジョブの編集ラウンドトリップアプリケーション開発

EasyBuilder とスプレッドシート

EasyBuilder ツールのスニペット構造体

ラウンドトリップアプリケーション開発とは、In-Sight Explorer の EasyBuilder とスプレッドシートの両開発環境でマシンビジョンアプリケーションをビルドするプロセスのことを指します。EasyBuilder 環境で開始されたジョブは、スプレッドシート環境で編集することができ、これにより EasyBuilder インタフェースに表示されるパラメータをカスタマイズすることができます。例えば、位置決めツールと検査ツールのパラメータを追加、削除または名前変更したり、スプレッドシート環境でのみ使用可能な追加のロジックと機能を追加して EasyBuilder ジョブを強化したりすることが可能です。

注:
  • In-Sight ビジョンシステムによっては、スプレッドシートにアクセスできなかったり、スプレッドシート環境で変更された EasyBuilder ジョブをロードできなかったりする場合があります。EasyBuilder 環境で開発されたジョブをスプレッドシート環境で編集する場合、このジョブは、EasyBuilder のみの In-Sight ビジョンシステム/センサに展開できません。

EasyBuilder とスプレッドシート

EasyBuilder 環境でジョブが作成および開発されると、同時に EasyBuilder 固有のスプレッドシートが作成され、EasyBuilder スニペットによってプログラムされます。事前設定され、空間的に定義され、論理的に統合された In-Sight の関数と、特定のタスクを実行する EasyBuilder タグおよびラベルによるグループで、セルデータ (.CXD) ファイルとして保存されます。 EasyBuilder スニペットEasyBuilder スニペットは、EasyBuilder 環境のアプリケーションステップに追加されて設定される機能に相当します。

EasyBuilder 互換スプレッドシートは特定のフォーマットに適合しており、EasyBuilder スニペットの 3 つの垂直セクションで構成されています。

  • セルの列 A ～ H が最初の垂直セクションを形成し、[画像の設定] ステップでの画像取得設定のための EasyBuilder スニペットと、EasyBuilder に追加される位置決めツールと検査ツール用の EasyBuilder スニペットが格納されます。
  • セルの列 J ～ Q は 2 番目の垂直セクションを形成します。この列は通常、最初の列に値が取り込まれていない限り空になっています。この列は、その時点で、EasyBuilder の位置決めツールと検査ツールのスニペットで使用されます。
  • セルの列 S ～ Z は最後の 3 番目のセクションを形成し、全体的なジョブの PASS/FAIL の結果を求める EasyBuilder スニペット、[入力] ステップと [出力] ステップ、[画像の設定] でのキャリブレーション、および [通信] ステップが格納されます。

すべての EasyBuilder スニペットは 8 列以下の列を占めるようにフォーマットされ、3 つの垂直セクションのいずれかに挿入されます。位置決めツールまたは検査ツールが EasyBuilder 環境内のジョブに追加されると、スプレッドシート内の使用可能なスペースに基づいて、対応する EasyBuilder スニペットが EasyBuilder 固有のスプレッドシートに自動的に追加されます。

例えば、ブロブ計数ツールが EasyBuilder 開発環境のジョブに追加されると、スプレッドシート内の使用可能なスペースに基づき、スプレッドシートの最初のセクション (列 A　～ H) か 2 番目のセクション (列 J ～ Q) のどちらかに、EasyBuilder スニペットファイル BlobCount.cxd が自動的に追加されます。

Closed 例 - EasyBuilder BlobCount スニペット

EasyBuilder スニペットでは、スニペット内の個々のセルと、ほかの EasyBuilder スニペットのセルの両方の間の絶対セル参照も保持されます。このセル間の空間関係は、セル実行順序を関連付けることと、EasyBuilder 環境でのテキストラベルと表示パラメータの表示順を決めることの両方の働きを持つメカニズムとして利用されます。EasyBuilder スニペットは、左から右に1 行ずつスキャンされ、セルはスニペット内での配置に基づいて個々に実行されます。

例えば、EasyBuilder スニペットファイル BlobCount.cxd では、オペレータ I/F 関数の上の行と下の行のテキストラベル間の空間関係に基づいて、EasyBuilder 環境で表示されるパラメータの名前とコントロールが作成されます。

Closed 例 - スプレッドシートビューと EasyBuilder ビュー

EasyBuilder ツールのスニペット構造体

EasyBuilder ツールのスニペットは、EasyBuilder 環境で位置決めツールと検査ツールをビルドするために使用されます。EasyBuilder ツールのスニペットは、スプレッドシート環境から In-Sight のビジョンツール関数のパラメータを表示し、それらのパラメータを EasyBuilder 環境で容易に設定できるようにしています。

EasyBuilder ツールのスニペットは、ツールの複雑さに応じて、さまざまな行数で 8 列以内に収まるようにフォーマットされます。スニペットに含まれる In-Sight の関数および EasyBuilder タグとラベルは、条件付きで有効にされ、スニペット内のセル間の特定の空間関係に依存しています。

Closed 例 - EasyBuilder エッジ位置決めツール - EdgeLocation スニペット

Closed 例 -EdgeLocation スニペット EnabledStatus セル依存関係

EasyBuilder ツールのスニペットは、以下のコンポーネントで構成されています。

  • EasyBuilder タグとタグラベル
  • In-Sight ビジョンツールの関数
  • ツールのパラメータ
  • 表示されるグラフィックスと対象領域

EasyBuilder タグとタグラベル

EasyBuilder タグにより、GUI フォーマットとセル参照のデータが EasyBuilder 環境に提供され、EasyBuilder タグラベルにより、EasyBuilder 環境で表示されるテキストが提供されるか、スプレッドシートでの EasyBuilder タグが示されます。EasyBuilder タグが付いていることは、セルの左下隅に表示される緑の三角形のコメントインジケータによって示されます。また、マウスにより表示されるツールチップが含まれます。

Closed 例 - EasyBuilder タグとテキストラベルのセル

EasyBuilder タグのセルは特定のシンタックスに準拠しており、1 つのセル、または事前定義された相互の空間関係を保持する必要があるセルグループを意味します。例えば、EasyBuilder タグ Input:Fixture は、必ず 3 つの連続するセル (EasyBuilder のタグラベル [行]、[列]、および [角度] の行の下) の行で構成される必要があり、これにより EasyBuilder 環境における X、Y、および Angle データが関連付けられます。セルの空間関係を変更したり、特定のセルを削除したりすると、ジョブで予期せぬ動作が引き起こされる可能性があります。

位置決めツールまたは検査ツールが EasyBuilder ジョブに追加されると、EasyBuilder アプリケーションでは、ツールの動作と EasyBuilder 環境で表示される項目を定義する、EasyBuilder タグおよびテキストラベルのセルの EasyBuilder スプレッドシートを解析します。EasyBuilder タグのセルは、ツールのスニペット内のほかの EasyBuilder タグのセル間のセル参照も意味し、さらにジョブ内のほかの EasyBuilder スニペットへのリンクも意味します。例えば、EasyBuilder ツールのスニペットは、EasyBuilder タグのセルを介して、フィクスチャ、キャリブレーション、および全体的な PASS/FAIL ステータスデータを管理します。

In-Sight ビジョンツールの関数

ビジョン処理アルゴリズムを提供する In-Sight ビジョンツールの関数は、EasyBuilder 開発環境における位置決めツールと検査ツールの中核機能です。ほとんどの In-Sight ビジョンツールの関数は、関数のパラメータに含まれる複雑で動的な引数に依存しているため、これらの数式は編集しないことをお勧めします。

Closed 例 - EdgeLocation スニペットの FindLine セル依存関係と FindLine プロパティシート

ツールのパラメータ

オペレータ I/F 関数は、In-Sight ビジョンツール関数やほかの In-Sight 関数のプロパティシートのパラメータとリンクされており、これにより、EasyBuilder 環境における位置決めツールと検査ツールのコントロールパラメータが決まります。EasyBuilder 環境で表示されるパラメータは、6 つのオペレータ I/F 関数のいずれか 1 つのすぐ上にあるツールパラメータラベルによって示されます。

  • Button 関数: EasyBuilder 環境でボタンコントロールを表示します。
  • CheckBox 関数: EasyBuilder 環境でチェックボックスコントロールを表示します。
  • EditFloat 関数: EasyBuilder 環境で整数編集コントロールを表示します。
  • EditInt 関数: EasyBuilder 環境で浮動小数点数編集コントロールを表示します。
  • EditString 関数: EasyBuilder 環境でテキスト編集コントロールを表示します。
  • ListBox 関数: EasyBuilder 環境でドロップダウンリストボックスコントロールを表示します。

オペレータ I/F 関数は、In-Sight ビジョンツール関数やほかの In-Sight 関数のプロパティシートのパラメータと相関しています。通常は、スプレッドシートでの絶対セル参照を介して別の入力パラメータにリンクされています。別の状況では、オペレータ I/F 関数がいくつかの関数のパラメータにリンクされていたり、EasyBuilder の位置決めツールまたは検査ツールに追加のロジックを提供するために含められていたりすることもあります。EasyBuilder 開発環境で正常に表示されるためには、オペレータ I/F 関数のすぐ上のセルにツールパラメータラベルを入力する必要があります (テキストの入力前にアポストロフィ (') を入力します)。

例えば、エッジ位置決めツールのエッジコントラストコントロールの場合は、EditInt 関数のすぐ上に「Edge Contrast (エッジコントラスト)」というツールパラメータラベルがあります。このラベルは、FindLine 関数の AcceptThresh パラメータへの絶対セル参照として設定されています。

Closed 例 - オペレータ I/F 関数と EasyBuilder パラメータコントロール

表示されるグラフィックスと対象領域

EasyBuilder 環境における対象領域グラフィックスと検出された特徴の表示方法を定義するオペレータ I/F 関数。EasyBuilder の各位置決めツールと検査ツールには領域 (円形または矩形) があり、EditAnnulus または EditRegion 関数を使用して領域の形状を定義します。各円形領域は、EditAnnulus 関数で構成され、その後に、行、列、内側の半径および外側の半径を定義するセルが続きます (これらのセルは、正常に機能するためには、常にこの順序で表示される必要があります)。各矩形領域は、EditRegion 関数で構成され、その後に、行、列、高さ、幅、角度およびカーブのデータを定義するセルが続きます (これらのセルは、正常に機能するためには、常にこの順序で表示される必要があります)。

Closed 例 - オペレータ I/F 関数と表示される EasyBuilder のグラフィックス

スプレッドシートでの EasyBuilder ツールパラメータの追加、削除および名前変更

EasyBuilder ツールのスニペットへのパラメータの追加

EasyBuilder ツールのスニペットパラメータの削除

EasyBuilder ツールのスニペットパラメータの名前変更

EasyBuilder ツールのスニペットはさまざまな In-Sight 関数で構成され、それらの関数のいくつかには、デフォルトで、EasyBuilder 開発環境では表示されない追加機能が含まれています。これらの追加パラメータは、スプレッドシート環境内で設定することによって、EasyBuilder 環境で有効にして表示することができます。

ヒント: プロパティシートのパラメータは、設定項目をドラッグ & ドロップして、スプレッドシートに配置することができます。プロパティシートからパラメータを選択してから、それをスプレッドシートにドラッグすることによって、パラメータのラベルとエディットコントロールが自動的に作成され、スプレッドシートで参照できるようになります。例えば、ExtractBlobs 関数のプロパティシートが開いている場合に、[しきい値] パラメータをスプレッドシートのセル A2 にドラッグ & ドロップすると、セル A2 に「Threshold (しきい値)」というテキストが入力され、セル A3 に EditInt 関数が入力されます。この場合、ExtractBlobs 関数のプロパティシートにある [しきい値] パラメータが、自動的にセル A3 への絶対参照として設定されます。

スプレッドシートで EasyBuilder ジョブを編集する場合の重要な指針

行を追加または削除するときには、個々のセルをクリックして、[挿入] メニューで [セル] を選択するか、右クリックメニューを使用して [挿入] または [削除] を選択します。これによりそれぞれ、[セルの挿入] ダイアログか [セルの削除] ダイアログが開かれます。必ず、2 つある [セルをシフト] オプションのいずれかを選択してください。

  • EasyBuilder スニペットには列を挿入しないでください。
  • スニペットから EasyBuilder のタグを削除しないでください。
  • 列 I または R には関数または数式を挿入しないでください。

これらのいずれかの操作を実行すると、依存関係が壊れ、EasyBuilder ジョブが正常に機能しなくなる可能性があります。

注: スプレッドシート環境でジョブを編集するには、ユーザのアクセスレベルがフルアクセスに設定されている必要があります。デフォルトでは、スプレッドシート環境でジョブが誤って編集されるのを防止するため、EasyBuilder ジョブがロックされています。開始前に、[ファイル] メニューで [ジョブの保護を解除...] を選択してジョブの保護を解除してください。

EasyBuilder ツールのスニペットへのパラメータの追加

EasyBuilder のほとんどの位置決めツールと検査ツールには、オペレータ I/F 関数を追加し、次に新規作成されたコントロールをスプレッドシートの既存のプロパティシートパラメータまたはロジックにリンクすることによって追加のパラメータを表示する機能があります。スプレッドシートでのオペレータ I/F　関数の配置により、EasyBuilder 開発環境での表示順序が決まります。

注: デフォルトでは、スプレッドシート環境でジョブが誤って編集されるのを防止するため、EasyBuilder ジョブがロックされています。開始前に、[ファイル] メニューで [ジョブの保護を解除...] を選択してジョブの保護を解除してください。

スプレッドシート環境で EasyBuilder の位置決めツールまたは検査ツールにパラメータを追加するには:

  1. [パレット] の [結果] タブでツールを右クリックして [Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択するか、または [表示] メニューで [スプレッドシート] を選択することにより、スプレッドシート環境内のツールに移動します。

注: EasyBuilder 環境の [パレット] の [結果] タブでツールがハイライト表示されている場合は、スプレッドシートでツールのスニペットがハイライト表示されます。

  2. 表示されるスプレッドシート関数のパラメータを識別し、パラメータのタイプに基づいてテキストラベルとオペレータ I/F 関数を追加します。各オペレータ I/F 関数では、その上のセルにテキストラベルが表示されている必要があります。ラベルは、EasyBuilder に対して、表示されているパラメータの「名前」と、EasyBuilder の設定ペインおよび [結果の設定] アプリケーションステップ に表示される項目 ([入力]、[出力]、および [通信]) を示します。例えば、エッジ位置決めツールは、EditInt 関数の上に「Edge Width (エッジ幅)」というテキストラベルを追加することによって、FindLine 関数の [エッジ幅] パラメータが表示されるように変更できます。

注: スニペットで新しいラベルとコントロールを挿入するため空のセルが不足している場合は、既存のラベルとコントロールを切り取り、追加の行を挿入して、切り取ったラベルとコントロールを新しく作成した領域に貼り付けます。列は挿入しないでください。ラベルのテキストを入力する場合には、テキストの前にアポストロフィ (') を忘れずに入力してください。

  3. 目的の関数のパラメータと新規作成したオペレータ I/F 関数の間の絶対セル参照を作成します。目的の関数のプロパティシートを開き、目的のパラメータを選択して、プロパティシートのツールバーで [絶対参照を挿入] ボタンをクリックします。これにより、セル選択モードに切り替わります。新規作成したオペレータ I/F 関数を選択し、[OK] ボタンをクリックして選択を確定します。
  4. オペレータ I/F 関数の [セル状態] を EasyBuilder タグの EnabledStatus セルに設定して、コントロールを条件付きで有効にします。コントロールは、EasyBuilder 環境で正常に機能して表示されるためには、条件付きで有効化され、この特定のセルへの絶対参照として設定される必要があります。
  5. オペレータ I/F 関数が格納されているセルをハイライト表示し、[編集] メニューから [セル状態] を選択します。これにより、[セル状態] ダイアログが開きます。
  6. [Conditionally Enabled (条件付きで有効化)] オプションを選択し、[Conditional Reference (条件付き参照)] を [絶対] に設定して、[セルの選択] ボタンをクリックします。これで、セル選択モードに切り替わります。「Enabled Status (有効化ステータス)」ラベルのセルの直下にある EasyBuilder タグの EnabledStatus セルを選択します。[OK] ボタンをクリックして選択を確定します。
  7. これで、EasyBuilder 開発環境に戻るときに、新しく追加したコントロールが有効になって表示されます。
Closed 例 - エッジ位置決めツールへの EdgeWidth パラメータの追加

この例では、EditInt 関数の上に「Edge Width (エッジ幅)」というテキストラベルを追加することによって、FindLine 関数の [エッジ幅] パラメータが表示されるようにエッジ位置決めツールに変更を加えます。

  1. EasyBuilder 開発環境において、[位置決め] アプリケーションステップ内で、エッジ位置決めツールを追加します。
  2. [パレット] の [結果] タブで、エッジ位置決めツールを右クリックし、[Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択します。

  3. エッジ位置決めツールには、オペレータ I/F 関数とツールパラメータラベルによる 2 行が含まれており、ツールパラメータラベル「Tool Enabled (ツール有効化)」で始まり、その下に ListBox 関数が配置されます。この例では、EasyBuilder 開発環境で表示される [エッジ幅] パラメータが [Edge Contrast (エッジコントラスト)] パラメータと [Edge Transition (エッジ移動)] パラメータの間に表示されるようにします。したがって、「Edge Contrast (エッジコントラスト)」ラベルと ListBox 関数の右側の 2 行のセルをハイライト表示し、8 個のセルを 1 列右側にカット & ペーストします。

  4. ツールパラメータラベル「Edge Contrast　(エッジコントラスト)」のセルの右側のセルに、「Edge Width (エッジ幅)」という名前でツールパラメータラベルを入力します (テキストを入力する前にアポストロフィ (') を使用します)。

  5. ツールパラメータラベルの下のセルに、右クリックメニューを使用して [関数の挿入] を選択するか、[挿入] メニューで [関数] を選択することによって EditInt 関数を挿入して、[関数の挿入] ダイアログを開きます。

  6. EditInt 関数を挿入すると、関数のプロパティシートが自動的に開きます。EditInt 関数の [最小] と [最大] のパラメータを 0 と 10 に設定し、[OK] ボタンをクリックして変更を確認します。

  7. スニペット内で ( [image] データ構造体によって示される) FindLine 関数を見つけ、そのセルをダブルクリックして関数のプロパティシートを開きます。

  8. FindLine プロパティシートで、EdgeWidth パラメータを選択して、プロパティシートのツールバーで [絶対参照を挿入] ボタンをクリックします。

  9. これによりセル選択モードが開始されるので、EditInt 関数が格納されているセルを選択します。セルをダブルクリックするか、または [ジョブの編集] ツールバーで [OK] ボタンをクリックして、選択を確定します。

  10. FindLine のプロパティシートが再表示されます。EdgeWidth パラメータには、EditInt 関数への絶対セル参照が表示されます。[OK] ボタンをクリックして変更を確定します。

  11. 最後に、FindLine 関数の EdgeWidth パラメータを制御している EditInt 関数は、ツールで実行するように条件付きで有効にされる必要があります。EditInt 関数を右クリックし、右クリックメニューから [セル状態] を選択して [セル状態] ダイアログを開きます。
  12. [セル状態] を [Conditionally Enabled (条件付きで有効化)] に設定し、[セルの選択] ボタンをクリックしてセル選択モードを開始します。

  13. EasyBuilder タグのセル「EnabledStatus」を選択します。セルをダブルクリックするか、または [ジョブの編集] ツールバーで [OK] ボタンをクリックして、選択を確定します。

  14. [セル状態] ダイアログが再び表示されます。[OK] ボタンをクリックして選択を確定します。
  15. EasyBuilder 開発環境に戻ります。ツールの [設定] タブに、[エッジ幅] パラメータが表示されます。

EasyBuilder ツールのスニペットからのパラメータの削除

一部のアプリケーションでは、EasyBuilder の位置決めツールまたは検査ツールにおいて、有効にするコントロールのサブセットの数を制限する必要があります。このような状況では、特定のコントロールを削除してツールを簡素化することができます。

スプレッドシート環境の EasyBuilder の位置決めツールまたは検査ツールからパラメータを削除するには:

  1. [パレット] の [結果] タブでツールを右クリックして [Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択するか、または [表示] メニューで [スプレッドシート] を選択することにより、スプレッドシート環境内のツールに移動します。
  2. 削除するパラメータのラベルおよびオペレータ I/F 関数が格納されているセルを選択します。ハイライト表示したセルを右クリックし、[コンテンツのクリア] オプションを選択します。

注: セルは削除しないでください。セルの位置がずれると依存関係が破れ、ジョブが正常に機能しなくなる可能性があります。

  3. これでセルが空になります。EasyBuilder 開発環境に戻っても、コントロールは表示されません。

EasyBuilder ツールのスニペットのパラメータ名の変更

EasyBuilder の位置決めツールと検査ツールのパラメータ名は、パラメータ名を変更することにより、アプリケーションとジョブに応じてカスタマイズ可能です。

スプレッドシート環境の EasyBuilder の位置決めツールまたは検査ツールからパラメータを削除するには:

  1. [パレット] の [結果] タブでツールを右クリックして [Go to this tool in the Spreadsheet (スプレッドシート内のこのツールに移動)] を選択するか、または [表示] メニューで [スプレッドシート] を選択することにより、スプレッドシート環境内のツールに移動します。
  2. 変更するテキストラベルのセルを選択し、[ジョブの編集] ツールバーの数式エディタに新しい名前を入力します。テキストの前からアポストロフィ (') を削除しないでください。削除すると、テキストラベルが EasyBuilder に認識されなくなります。
  3. これで、EasyBuilder 開発環境に戻ると、コントロールが新しい名前で表示されます。
Version: 5.6.0


EasyBuilder のサンプルジョブとサンプル画像

サンプルジョブとサンプル画像

EasyBuilder のサンプルジョブとサンプル画像の概要

EasyBuilder サンプルジョブのロード

EasyBuilder サンプル画像のロード

EasyBuilder のサンプルジョブとサンプル画像の概要

EasyBuilder には、複数のサンプルジョブと、これに対応するサンプル画像が含まれます。これらのサンプルジョブは、EasyBuilder の検査ツールを使用して実際の応用事例を解決する方法を示します。想定される応用事例を幅広く網羅した EasyBuilder サンプルジョブは、特定の状況で位置決めツール、および検査ツールを使用する方法の有用な例を提供し、フィクスチャツールの検索や使用方式を最適化するために領域グラフィックスを配置する方法を示します。

EasyBuilder サンプルジョブには、[記録/再生のオプション] の有用性を表した例も用意されています。[記録/再生のオプション] によって、あらかじめ取り込んでおいた複数の画像を繰り返し使用できるようになり、ツールの結果を即座にフィードバックし、しきい値や制限を簡単に設定できるようになります。マシンビジョンアプリケーションを設計するときは、検査における「良い」画像と「悪い」画像の例となる多数の画像を広い範囲にわたって取り込んでおくことが理想的です。その後で、「良い」画像を中心に応用事例を設計し、そのほかの画像は許容可能な値の範囲を確立する手段として使用します。

EasyBuilder サンプルジョブのロード

EasyBuilder サンプルジョブを使用するには、サンプルジョブと、それに付随する画像をロードする必要があります。

  1. [接続] ステップから、ローカルエミュレータ、または In-Sight センサに接続します。[ジョブのロード] セクションの [ジョブを開く] ボタンをクリックします。
  2. [開く] ダイアログから In-Sight Explorer EasyBuilder の Sample Jobs ディレクトリに移動し、ロードするサンプルジョブを選択します。
注: 標準ユーザがアクセスできるようにするため、In-Sight Explorer 4.5.0 以降では、Sample Job のデフォルトフォルダの場所は Program Files フォルダから次の場所に変更されています。
  • Windows 7/Windows 10: C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Explorer x.x.x
  3. サンプルジョブをロードしたら、次に対応するサンプル画像をロードする必要があります。

EasyBuilder サンプル画像のロード

サンプルジョブに対応するサンプル画像のロードを開始するには次の 2 つの方法があります。

  • オプション 1: [EasyBuilder] ツールバーの [image] アイコンをクリックします。[記録/再生のオプション] ダイアログが表示されます。
  • オプション 2: [画像の設定] ステップをクリックし、[画像取り込み/ロード] セクションの [PC から画像をロード] ボタンを押します。この方法でも、[記録/再生のオプション] ダイアログが表示されます。
  1. [記録/再生のオプション] ダイアログは、自動的に [再生] タブが表示された状態で開きます。表示されていない場合は、[再生] タブをクリックします。
  2. [再生フォルダ] セクションで [参照] ボタンをクリックし、[フォルダの参照] ダイアログを表示します。[Sample Jobs] → [EasyBuilder] ディレクトリに移動し、サンプルジョブをロードしたときに指定したフォルダを選択します。[OK] ボタンをクリックして続行します。
  3. [再生フォルダ] には指定したディレクトリが表示されます。[画像カウント] はこのディレクトリに保存されている画像の数を示しています。[記録/再生のオプション] ダイアログの [OK] ボタンをクリックして、続行します。
  4. サンプルジョブとサンプル画像を揃えたら、[ジョブの実行] ステップに移動し、[EasyBuilder] ツールバーの [image] ボタンをクリックして、検査ツールの実行を観察するか、または [位置決め] または [検査] ステップに移動して、その応用事例でツールがどのように変更されているかを確認します。
Version: 5.6.0


対話型グラフィックスモード

対話型グラフィックスモード(セルグラフィックス)

[編集] メニュー

In-Sight Explorer GUI リファレンス
  • 対話型グラフィックスについて
  • 対話型グラフィックスモードの使用
  • 対話型グラフィックスモードのショートカット

対話型グラフィックスについて

多くの In-Sight 関数、特にビジョンツール関数のパラメータは、画像の上にあるグラフィックスを調整して設定することができます。対話型グラフィックスを使用して、簡単に対象領域のサイズ、位置、回転を設定したり、モデル領域を登録したりすることができます。対応するグラフィックスのある関数が含まれる任意のスプレッドシートセルのほか、プロパティシート上に対応するグラフィックスがある任意のパラメータの値から、対話型グラフィックスを調整することができます。対話型グラフィックスモードはスプレッドシートの標準ビューまたはカスタムビューのいずれかで、ユーザのアクセスレベルでの許可に従ってアクセスできます。

対話型グラフィックスモードの使用

  1. 関連付けられている対話型グラフィックスがあるスプレッドシートセルまたはプロパティシートの値を選択します (対応する関数が現在の状況で使用不可能な場合、[セルグラフィックスの編集] [image] アイコンはグレーアウトされて表示されます)。

  2. 対話型グラフィックスモードを開始する方法は 4 つあります。

    • F9 キーを押します。
    • [ジョブの編集] ツールバーの [セルグラフィックスの編集] [image] ボタンをクリックします。
    • プロパティシートのツールバー上の [セルグラフィックスの編集] [image] ボタンをクリックします。
    • 右クリックしてショートカットメニューから [セルのグラフィック] を選択します。
  3. 半透明のスプレッドシートオーバレイまたはプロパティシートが消えて、画像の上に対話型グラフィックスが表示されます。対話型グラフィックスモードには、円環、領域、円、十字、点、線の 6 種類が存在します。対話型グラフィックス内に表示される対話型グラフィックスモードのアイコンのタイプは、セルまたは値に必要な入力のタイプに応じて異なります。

    • 円環:

      移動

      画像の円環を再配置します。円環の中心ポイントのピクセル座標が表示されます。マウスの使用時は、ピクセル座標がステータスバーに表示されます。

      操作 キーボード マウス

      左に移動

      ← キー

      円環内をクリックして左方向にドラッグします。

      右に移動

      → キー

      円環内をクリックして右方向にドラッグします。

      上に移動

      ↑ キー

      円環内をクリックして上方向にドラッグします。

      下に移動

      ↓ キー

      円環内をクリックして下方向にドラッグします。

      サイズ変更モードに切り替え

      F9

      N/A

      円環色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

              [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

              [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      サイズ変更

      円環の内側の半径および外側の半径を中心から増減します。内側の半径 (右向き矢印) および外側の半径 (下向き矢印) は、ピクセルで示されます。マウスの使用時は、内側の半径および外側の半径の値がステータスバーに表示されます。

      操作 キーボード マウス

      内側の半径を縮小

      ↑ キー

      内側の円の端をクリックして、中心に向かってドラッグします。

      内側の半径を拡大

      ↓ キー

      内側の円の端をクリックして、中心から外側に向かってドラッグします。

      外側の半径を縮小

      ← キー

      外側の円の端をクリックして、中心に向かってドラッグします。

      外側の半径を拡大

      → キー

      外側の円の端をクリックして、中心から外側に向かってドラッグします。

      移動モードに切り替え

      F9

      N/A

      円環色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

    • 領域: 領域は、[Bend (屈曲)] パラメータの値に応じて 3 つの異なる動作を持ちます。
      • [Bend (屈曲)] = 0: 領域は矩形として動作します。
      • 0 < [Bend (屈曲)] < 120: 領域は円弧セグメントとして動作します。

      • [Bend (屈曲)] >= 120: 領域は円として動作します。

      これらのさまざまな動作は、サイズ変更モードで作業する場合にのみ確認できます。

      移動

      画像の領域を再配置します。領域の中心のピクセル座標が表示されます。マウスの使用時は、ピクセル座標がステータスバーに表示されます。

      操作 キーボード マウス

      左に移動

      ← キー

      領域内をクリックして左向きにドラッグします。

      右に移動

      → キー

      領域内をクリックして右向きにドラッグします。

      上に移動

      ↑ キー

      領域内をクリックして上向きにドラッグします。

      下に移動

      ↓ キー

      領域内をクリックして下向きにドラッグします。

      サイズ変更モードに切り替え

      F9

      N/A

      領域色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      サイズ変更

      (矩形)

      領域の [Bend (屈曲)] パラメータが 0 に設定されている場合、その領域は矩形のように動作します。矩形の高さおよび幅 (ピクセル) は中心ポイントの近くに表示されます。マウスの使用時は、矩形の高さと幅 (ピクセル) はステータスバーに表示されます。高さと幅は、次の方法で変更することができます。

      操作 キーボード マウス

      幅を減少

      ← キー

      任意の端点 [image] をクリックして内向きにドラッグします。

      幅を増加

      → キー

      任意の端点 [image] をクリックして外向きにドラッグします。

      高さを減少

      ↑ キー

      任意の端点 [image] をクリックして内向きにドラッグします。

      高さを増加

      ↓ キー

      任意の端点 [image] をクリックして外向きにドラッグします。

      回転モードに切り替え

      F9

      N/A

      領域色を変更

      SHIFT+F9

      N/A

      セル領域を最大化

      Ctrl+Shift+M

              [ジョブの編集] ツールバーで [Maximize Cell Region (セル領域の最大化)] [image] ボタンをクリックします。

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      サイズ変更

      (円弧セグメント)

      領域の [Bend (屈曲)] パラメータが 0 ～ 120 の間 (120 未満) にある場合、その領域は円弧セグメントのように動作します。この場合、[Wide (幅)] パラメータは Y 軸に沿った中間ポイントの円弧セグメントの長さを示し、[High (高さ)] パラメータは X 軸に沿ったセグメントの長さを示します。円弧状の領域の高さと幅 (ピクセル) は中心ポイントの近くに表示されます。マウスの使用時は、円弧状の領域の高さと幅がステータスバーに表示されます。高さと幅は、次の方法で変更することができます。

      操作 | キーボード | マウス

      Y 軸の弧の長さを減少

              ← キー 任意の端点 [image] をクリックして内向きにドラッグします。

      Y 軸の弧の長さを増加

              → キー 任意の端点 [image] をクリックして外向きにドラッグします。

      X 軸のセグメント長さを減少

              ↑ キー 任意の端点 [image] をクリックして内向きにドラッグします。

      X 軸のセグメント長さを増加

              ↓ キー 任意の端点 [image] をクリックして外向きにドラッグします。

      回転モードに切り替え

              F9 N/A

      領域色を変更

              SHIFT+F9 N/A
      セル領域を最大化 | Ctrl+Shift+M | [ジョブの編集] ツールバーで [Maximize Cell Region (セル領域の最大化)] [image] ボタンをクリックします。

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      サイズ変更

      (円)

      領域の [Bend (屈曲)] パラメータが 120 以上である場合、その領域は円のように動作します。円モードでは、マウスを使用して端点をドラッグしても、同時に内側と外側の両方の弧の長さを変更することはできません。これにより、領域を円状のオブジェクトに形成するプロセスが容易になります。

      円モードでは、[Wide (幅)] パラメータは Y 軸に沿った中間ポイントの円弧セグメントの長さを示し、[High (高さ)] パラメータは X 軸に沿ったセグメントの長さを示します。円弧状の領域の高さと幅 (ピクセル) は中心ポイントの近くに表示されます。マウスの使用時は、円弧状の領域の高さと幅がステータスバーに表示されます。高さと幅は、次の方法で変更することができます。

      操作 キーボード マウス

      Y 軸の弧の長さ (幅) を減少

      ← キー

      任意の端点 [image] をクリックして内向きにドラッグします。

      Y 軸の弧の長さ (幅) を増加

      → キー

      任意の端点 [image] をクリックして外向きにドラッグします。

      X 軸のセグメント長さ (高さ) を減少

      ↑ キー

      任意の端点 [image] をクリックして内向きにドラッグします。

      X 軸のセグメント長さ (高さ) を増加

      ↓ キー

      任意の端点 [image] をクリックして外向きにドラッグします。

      回転モードに切り替え

      F9

      N/A

      領域色を変更

      SHIFT+F9

      N/A

      セル領域を最大化

      Ctrl+Shift+M

      [ジョブの編集] ツールバーで [Maximize Cell Region (セル領域の最大化)] [image] ボタンをクリックします。

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      回転

      領域の時計回りまたは反時計回りの回転を調整します。回転の角度 (度数) が領域の中心に表示されます (0 ～ 360)。マウスの使用時は、回転の角度がステータスバーに表示されます。

      操作 キーボード マウス

      時計回りに回転

      → キー

      回転 [image] アイコンをクリックして、時計回りにドラッグします。

      反時計回りに回転

      ← キー

      回転 [image] アイコンをクリックして、半時計回りにドラッグします。

      カーブモードに切り替え

      F9

      N/A

      領域色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      屈曲

      領域を上向きまたは下向きに曲げます。弧状の領域および環状の領域を作成するために使用します。

      操作 キーボード マウス

      上に曲げる

      ← キー

      カーブ [image] アイコンをクリックして、上向きにドラッグします。

      下に曲げる

      → キー

      カーブ [image] アイコンをクリックして、下向きにドラッグします。

      移動モードに切り替え

      F9

      N/A

      領域色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

    • 十字:

      移動

      画像の十字を再配置します。十字の中央ポイントのピクセル座標が表示されます。マウスの使用時は、ピクセル座標がステータスバーに表示されます。

      操作 キーボード マウス

      左に移動

      ← キー

      十字をクリックして左向きにドラッグします。

      右に移動

      → キー

      十字をクリックして右向きにドラッグします。

      上に移動

      ↑ キー

      十字をクリックして上向きにドラッグします。

      下に移動

      ↓ キー

      十字をクリックして下向きにドラッグします。

      サイズ変更モードに切り替え

      F9

      N/A

      十字色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      サイズ変更

      十字の縦および横の軸の長さを増減します。各軸の長さが (ピクセルで) 表示されます。マウスの使用時は、長さがステータスバーに表示されます。

      操作 キーボード マウス

      縦の軸を小さくする

      ↑ キー

      垂直の矢印の先端をクリックして、十字の中央ポイントに向かってドラッグします。

      縦の軸を大きくする

      ↓ キー

      垂直の矢印の先端をクリックして、十字の中央ポイントから外側に向かってドラッグします。

      横の軸を小さくする

      ← キー

      水平の矢印の先端をクリックして、十字の中央ポイントに向かってドラッグします。

      横の軸を大きくする

      → キー

      水平の矢印の先端をクリックして、十字の中央ポイントから外側に向かってドラッグします。

      回転モードに切り替え

      F9

      N/A

      十字色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

      回転

      十字の時計回りまたは反時計回りの回転を調整します。回転の角度 (度数) が、十字の中央に表示されます (0 ～ 360)。マウスの使用時は、回転の角度がステータスバーに表示されます。

      操作 キーボード マウス

      時計回りに回転

      ← キー

      回転 [image] アイコンをクリックして、時計回りにドラッグします。

      反時計回りに回転

      → キー

      回転 [image] アイコンをクリックして、半時計回りにドラッグします。

      移動モードに切り替え

      F9

      N/A

      十字色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

    • 点:

      移動

      画像の点を再配置します。点のピクセル座標が表示されます。マウスの使用時は、ピクセル座標がステータスバーに表示されます。

      操作 キーボード マウス

      左に移動

      ← キー

      点をクリックして左にドラッグします。

      右に移動

      → キー

      点をクリックして右にドラッグします。

      上に移動

      ↑ キー

      点をクリックして上にドラッグします。

      下に移動

      ↓ キー

      点をクリックして下にドラッグします。

      点の色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

    • 線:

      端点の設定

      線の両方の端点の位置を設定します。現在の端点のピクセル座標が表示されます。マウスの使用時は、ピクセル座標がステータスバーに表示されます。

      操作 キーボード マウス

      端点を左に移動

      ← キー

      端点 [image] をクリックして左にドラッグします。

      端点を右に移動

      → キー

      端点 [image] をクリックして右にドラッグします。

      端点を上に移動

      ↑ キー

      端点 [image] をクリックして上にドラッグします。

      端点を下に移動

      ↓ キー

      端点 [image] をクリックして下にドラッグします。

      端点間を切り替え

      F9

      N/A

      線の色を変更

      SHIFT+F9

      N/A

      操作を元に戻す

      CTRL+Z

      [標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

      操作をやり直し

      CTRL+Y

      [標準] ツールバーで、[やり直し] [image] ボタンをクリックします。

  4. 変更を許可する場合は、ENTER キーを押してください。グラフィックスは画像の上 (デフォルトで赤色)、半透明のスプレッドシートの下に表示されます。変更を取り消すには、ESC キーを押してください。変更を許可すると、新しい値が自動的にセルの数式か、対話型グラフィックスモードにアクセスされたプロパティシートの値に入力されます。

対話型グラフィックスモードのショートカット

操作 | キーボード | マウス

対話型グラフィックスモードを開始

注: 対話型グラフィックスモードを開始するためには、アクティブセルまたはプロパティシートの値に、関連付けられた対話型グラフィックスが存在する必要があります。
 F9
  • [ジョブの編集] ツールバーで [セルグラフィックスの編集] [image] ボタンをクリックします。
  • プロパティシート内から、プロパティシートのツールバー上の [グラフィックスの編集] [image] ボタンをクリックします。

セルグラフィックスの領域を最大化

 N/A
  • [ジョブの編集] ツールバーで [Maximize Cell Region (セル領域の最大化)] [image] ボタンをクリックします。
  • プロパティシート内から、プロパティシートのツールバー上の [領域の最大化] [image] ボタンをクリックします。
以下の操作は、対話型グラフィックスモードでのみ使用することができます。

対話型グラフィックスモード間を切り替え

注: 使用する対話型グラフィックスモードによっては、F9 キーを押すと対話型グラフィックス内のアイコンが変更される場合があります。
 F9 N/A

対話型グラフィックスを軸方向に移動

上に移動: ↑ キー

下に移動: ↓ キー

左に移動: ← キー

右に移動: → キー
対話型グラフィックス内をクリックして、目的の位置にドラッグします。

対話型グラフィックスを斜めに移動する

左上に移動: HOME

右上に移動: PG UP

左下に移動: END

右下に移動: PG DN
対話型グラフィックス内をクリックして、目的の位置にドラッグします。

画像をゆっくりパンする

上にパン: SHIFT+↑ キー

下にパン: SHIFT+↓ キー

右にパン: SHIFT+→ キー

左にパン: SHIFT+← キー
画像のスクロールバーをクリックしてドラッグします。

画像をすばやくパンする

上にパン: SHIFT+PG UP

下にパン: SHIFT+PG DN

右にパン: SHIFT+END

左にパン: SHIFT+HOME
画像のスクロールバーをクリックしてドラッグします。

拡大 (画像)

 SHIFT+ (テンキーの)
プラス記号
  • [ジョブの表示] ツールバーで、[拡大] [image] ボタンをクリックします。
  • 画像内の特定の位置を拡大するには、SHIFT キーを押しながら、中央に配置する位置を左ダブルクリックします。
縮小 (画像) SHIFT+ (テンキーの)
マイナス記号
  • [ジョブの表示] ツールバーで、[縮小] [image] ボタンをクリックします。
  • 画像内の特定の位置を縮小するには、SHIFT キーを押しながら、中央に配置する位置を右ダブルクリックします。
グラフィックス色を切り替え | SHIFT+F9 | N/A
対話型グラフィックスに加えられた変更を許可する | ENTER | 対話型グラフィックス内をダブルクリックするか、[ジョブの編集] ツールバーで、[Enter] [image] ボタンをクリックします。
対話型グラフィックスに加えられた変更を取り消す | ESC | [ジョブの編集] ツールバーで、[キャンセル] [image] ボタンをクリックします。

操作を元に戻す

CTRL+Z

[標準] ツールバーで、[元に戻す] [image] ボタンをクリックします。

操作をやり直し

CTRL+Y

[標準] ツールバーで、[やり直し] [image] ボタンをクリックします。
対話型グラフィックスモード上でヘルプを表示 | F1 | [ヘルプ] メニューで、[In-Sight Explorer のヘルプ] をクリックします。
Version: 5.6.0


ピクセル値表示モード

In-Sight Explorer GUI リファレンス

ピクセル値表示モードでは、スプレッドシートのオーバレイが表示されていないときに、カーソルを使用して画像の単一ピクセルを参照します。このモードで、カーソルを画像の上に移動すると、その座標位置にあるピクセルに対して 8 ビットのグレースケール値 (モノクロの In-Sight センサの場合) または 8 ビットの RGB 値 (カラーの In-Sight センサの場合) が登録されます。値はアクティブなスプレッドシートビューのステータスバーに表示されます。

ピクセル値表示モードを呼び出すには

[表示] メニューで、[Overlay (オーバレイ)] をクリックしてスプレッドシートのオーバレイを非表示にします。または、[ジョブの表示] ツールバーで、[Overlay (オーバレイ)] [image] ボタンをクリックします。その後、カーソルを画像の上にスクロールして、値をステータスバーで登録します。

1 つ目の例では、カーソルが (x,y) = (173,266) にあり、8 ビットのグレースケール値は 159 です。2 つ目の例は In-Sight カラーセンサからのもので、カーソルは (x,y) = (275,455) にあり、赤、緑、青の色成分は (R,G,B) = (156,150,115) です。

ピクセルの絶対値およびピクセルの近似値

スプレッドシートビューでの絶対ピクセル値は、画像の表示倍率が 1:1 に設定された場合にだけ表示され、ステータスバーには値が次のように表示されます。 . 画像表示倍率が 1:1 以外の場合は、「近似」ピクセル値が表示され、ステータスバーには値が次のように表示されます。 . EasyBuilder ビューでの絶対ピクセル値は、画像表示倍率に関係なく常に表示されます。


セル選択モード

ユーザインタフェース

In-Sight Explorer GUI リファレンス

相対および絶対セル参照を挿入する最も便利な方法は、セル選択モードを使用することです。セル選択モードでは、スプレッドシートでセルを直接クリックするとセル参照が作成されます。これにより、例えばセル G67 またはセル D25 にブロブカウントが含まれていたかどうかを覚えておく必要がなく、視覚的にセルを選択する手段が与えられます。

  • セル選択モードの呼び出し
  • セル参照の確立
  • セル選択モードの例

セル選択モードの呼び出し

[相対参照] [image] ボタンまたは [絶対参照] [image] ボタンをクリックすることにより、セル選択モードを次のいずれかから呼び出すことができます。

  • プロパティシート
  • [カスタムビューの設定] ダイアログ
  • [セル状態] ダイアログ
  • ユーザダイアログ

セル選択モードでは、ディスプレイが一時的に In-Sight スプレッドシート独自のビューに切り替わります。このディスプレイでは、画像がスプレッドシートの下に表示されず、参照対象のセルが、展開可能な赤枠の長方形で示されます。

セル参照の確立

  1. 参照するセルを選択します。マウスまたはキーボードで 1 つまたは複数のセルを選択することができます。マウスで複数のセルを選択するには、参照する任意のセルをクリックしてドラッグします。キーボードを使用する場合、SHIFT キーを押しながら、矢印キーを押してセルのグループを選択します。
  2. 参照を確定します。目的のセルをダブルクリックする (単一のセル参照の場合) か、または ENTER キーを押す (単一のセルまたは複数のセルのいずれを参照する場合) ことにより、参照を確定することができます。参照が確定されると、ディスプレイは、セル選択モードが起動されたプロパティシート、ダイアログ、またはスプレッドシートのセルに切り替わります。

セル選択モードの例

次の 2 つの例では、サンプル画像 IMAGE2B.BMP を使用して単一セルと複数セルのアプリケーションの両方の選択モードについて説明します。

  • 単一セル参照の例
  • 複数セル参照の例

単一セル参照の例

画像上でブロブ解析を実行すると仮定します。セル A2 にある ExtractBlobs 関数は、(GetNFound 関数を使用して) セル B2 に出力を生成します。この出力は、画像内にあるブロブの数を表します。目標は、セル A6 内に GetNFound の結果の「リンクされたコピー」を表示することです。この新しい値は、セル B2 のブロブの元の数が変更されると更新されます。セル A6 内でセル B2 への絶対セル参照を作成することにより、この 2 つのセルは同期されます。

次のスプレッドシートを考えてみます。

セル A6 に検出されたブロブの数 (4.000) の同期されたコピーを作成するには:

  1. セル A6 をハイライトします。
  2. [ジョブの編集] ツールバーで、[絶対参照] [image] ボタンをクリックします。これにより、セル選択モードが呼び出されます。
  3. セル B2 をダブルクリックします。

注: 前の図では、セル A2 の ExtractBlobs 関数の [表示] パラメータは、入力および結果グラフィックスの両方を表示するように設定されていました (図解のため)。

セル A6 に配置された数式は、セル A2 への絶対参照です ($A$2)。セル B2 の値が変更されるたびに、A6 は適宜更新されます。

複数セル参照の例

複数セル参照は、プロパティシートで複数の値を持つパラメータ (フィクスチャや領域など) を定義する際に有効です。

次のスプレッドシートを考えてみます。

実行時の操作中に (赤色で示された) 対話型グラフィックス領域を制御できるようにする必要があると仮定します。次のように、領域の各プロパティ (X、Y、高さ、幅、角度、カーブ) に対して [EditFloat] オペレータ I/F を定義することができます。

A10 = 'X

B10 = 'Y

C10 = '幅

D10 = '高さ

E10 = '角度

F10 = 'カーブ

A11 = EditFloat(0,480)

B11 = EditFloat(0,640)

C11 = EditFloat($B$7,$B$8)

D11 = EditFloat($B$7,$B$8)

E11 = EditFloat(0,360)

F11 = EditFloat(0,400)

EditFloat 関数の制限 (MinValue および MaxValue) は任意で選択できますが、領域への範囲外の入力値からエラーが発生しないように合理的に選択する必要があります。セル B7 には 10.000 が含まれますが、これは、絶対参照 $B$7 を [EditFloat] オペレータ I/F の最初の引数として幅および高さの値の下限を定義しています。同様に、セル B8 はこれらの オペレータ I/F で 500.000 の上限を設定します。

セル A2 をハイライトします。([ジョブの編集] ツールバーで) 関数 [image] ボタンをクリックすると、ExtractBlobs 関数のプロパティシートが開きます。

[Region] パラメータを選択します。次に、([ジョブの編集] ツールバーで) [絶対参照] [image] ボタンをクリックして、セル選択モードを呼び出します。マウスまたはキーボード (SHIFT+ 矢印キー) のいずれかを使用して、図のようにセル A11 から F11 までをハイライトします。

ENTER キーを押して範囲を確定します。[OK] をクリックしてプロパティシートを閉じます。対話型グラフィックス領域を、スプレッドシート上の [編集] オペレータ I/F を使用して調整できるようになります。


セル参照

セル参照 - 相対/絶対

[挿入] メニュー

In-Sight Explorer GUI リファレンス

セル参照は別のセルへのリンクです。ソースのセルのデータが変更されると、ディスティネーションのセル (参照が含まれるセル) の値が自動的に更新されます。ただし、ソースのセルは別のセルによって参照されていることが分からないため、このリンクは一方向です。

  • セル参照について
  • セル参照作成用のショートカット
  • セル参照の例

セル参照について

セル参照には、次の 2 種類が存在します。

  • 相対: 相対セル参照は、新しい位置にコピーされると、行および列のアドレスが変化する参照のことです。変化の量は、コピーされたセルと貼り付けられたセルの間の距離 (行および列の両方に関して) と同じです。例えば、セル A2 に相対参照 A1 が含まれているとします。セル A2 がセル S43 にコピーされると、S43 には S42 が含まれます。この場合、セル参照は「常に 1 つ上のセルを指し示す」ことになります。
  • 絶対: 絶対セル参照は、新しい位置にコピーされても変化しないセル参照のことです。数式では、ドル記号 ($) が絶対参照であることを示します。この記号は、任意の行または列 (あるいはその両方) と組み合わせて絶対セル参照を構成することができます。

相対参照と絶対参照を組み合わせて、「混合」参照を作成することができます。

次の表は、4 種類の絶対セル参照および相対セル参照と、それぞれが別のセルにコピーおよび貼り付けされるとどうなるかを示しています。

説明 | 参照の種類 | 例 | 新しいセルに貼り付けた結果
相対列と相対行 | 相対 | B4 | 行 (4) と列 (B) の両方が、元のセルからの距離に基づいて変化します。
固定列と固定行 | 絶対 | $A$1 | 常に $A$1 になります。
固定列と相対行 | 混合 | $D9 | 列は常に D になりますが、行 (9) は元のセルからの距離 (行数) に基づいて変化します。
相対列と固定行 | 混合 | G$3 | 列の G は、元のセルからの距離 (列数) に基づいて変化しますが、行は常に 3 のままになります。

セル参照作成用のショートカット

  • 相対: CTRL+SHIFT+R キーを押すか、または相対参照 [image] ボタンをクリックします。セル選択モードでは、参照する目的のセルを選択することができます。
  • 絶対: CTRL+SHIFT+A キーを押すか、または絶対参照 [image] ボタンをクリックします。セル選択モードでは、参照する目的のセルをスプレッドシートからグラフィカルに選択することができます。

セル参照の例

Closed 相対列と相対行 (相対参照)

セル C9 に E14 が含まれているとします。C9 が B1 にコピーされた場合、B1 に D6 が含まれます。

Closed 固定列と固定行 (絶対参照)

セル E2 に $F$7 が含まれているとします。E2 が R7 にコピーされた場合、R7 に $F$7 が含まれます。

Closed 固定列と相対行 (混合参照)

別のセルにコピーする際に、常に列 A を参照するものの、行アドレスは、元のセルからコピー先セルへの距離の変化に関連して変化するセル参照を必要としていると仮定します。図のように、セル A2、A3、および A4 に 3 つのデータポイント (5、18、および 55) が存在するとします。

この場合、列の前にドル記号を使用しますが ($A) 、行 (2) の前には使用せず、$A2 のセル参照を作成します。この参照はセル B2 に配置できます。次にセル B2 がセル B3、B4、C2、C3 および C4 にコピーされ貼り付けられます。貼り付けられたセルは常に列 A を参照しますが、行は、参照を貼り付けたセルと相対的に決定されることに注目してください。

Closed 相対列と固定行 (混合参照)

別のセルにコピーする際に、常に行 2 を参照するものの、列アドレスは、コピー先列までの距離の変化に関連して変化するセル参照を必要としていると仮定します。図のように、セル A2、B2、および C2 に 3 つのデータポイント (13、20、および 26) が存在するとします。

この場合、列を相対的 (A)、行を絶対的 ($2) に参照して、A$2 のセル参照を作成します。この参照はセル A3 に配置できます。次にセル A3 がセル A4、B3、B4、C3 および C4 にコピーされ、貼り付けられます。貼り付けられたセルは常に行 2 を参照しますが、列は、参照を貼り付けたセルと相対的に決定されることに注目してください。


[セル状態] ダイアログ

[編集] メニュー

In-Sight Explorer GUI リファレンス

[セル状態] ダイアログでは、参照セルの値に基づき、明示的または条件付きで、セルの実行を有効または無効にすることができます。無効にされたセルはスプレッドシートが更新されても実行されないため、再び有効にされない限りこれらのセルには現在値が無期限に保持されることになります。

  • 1 つ以上のセルの状態の設定
  • セル状態のコピー & ペースト
  • 関連項目

1 つ以上のセルの状態の設定

  1. スプレッドシートで、1 つまたは一定範囲のセルを選択します。

  2. [編集] メニューで、[セル状態] をクリックします。

  3. 選択したセルについて、以下の状態のいずれかを選択します。
    • [無効]: 選択したセルはトリガ時に実行されません。
    • [有効]: 選択したセルはトリガ時に実行されます。
    • [Conditionally Enabled (条件付き有効)]: 選択したセルは参照セルの値が 0 以外であれば有効にされます。
  4. 前の手順で [Conditionally Enabled (条件付き有効)] を選択した場合:
    1. セル参照のタイプとして [Relative (相対)] または [Absolute (絶対)] を選択します。

    2. [セルの選択] をクリックし、セル選択モードを入力します。

      注: セルがそれ自体を参照している場合、その参照は無視されます。
    3. 手順 (1) で選択したセルの状態が、その値によって決まるセルを決定します。[セル参照] が 0 と評価されると、選択したセルは無効になり、それ以外の場合は有効になります。
    4. [OK] をクリックします。

セル状態のコピー & ペースト

状態が条件付き有効になっているセルをコピー & ペーストする場合、貼り付けられたセルの状態は、コピーされたセルの条件付き参照として選択した参照のタイプによって決まります。セル参照は、新しい場所にセルをコピー & ペーストする場合、相対または絶対セル参照として動作します。ただし、カット & ペーストの場合は、常に切り取られたセルのタイプと同じセル参照になります。

相対と絶対の条件付きセル状態の違いは、セルの内容をコピー & ペーストするときに明らかになります。状態が条件付き - 相対のセルをコピーして新しい場所に貼り付ける場合、貼り付けられたセルの状態は、コピーされたセルのセル参照の場所に対して相対的なセルの値によって決まります。

一方、状態が条件付き - 絶対のセルをコピーして新しい場所に貼り付ける場合、貼り付けられたセルの状態は、貼り付けられる場所に関係なく、常にコピーされたセルのセル参照の評価に絶対的に依存して決まります。

注: カット & ペースト操作 (コピー & ペーストではなく) では、単にセルの内容が移動され、相対セル参照の変換は実行されません。

例

  • 相対条件付きセル状態の例
  • 絶対条件付きセル状態の例

相対条件付きセル状態の例

スプレッドシートが次のように設定されていると仮定します。

A0 = AcquireImage(...)

A2 = 'Enabled

A3 = 1.000

B2 = 'Disabled

B3 = 0.000

D2 = 'Copied

D3 = 37.000

E4 = 'Pasted
  1. セル D3 を右クリックして [セル状態] を選択します。
  2. [Conditionally Enabled (条件付き有効)] をクリックします。
  3. 「条件付き参照」で、[相対] をクリックします。
  4. [セルの選択] をクリックします。
  5. セル A3 をダブルクリックします。
  6. [OK] をクリックします。
  7. セル D3 を右クリックして [コピー] を選択します。
  8. セル E3 を選択します。
  9. [編集] メニューで、[貼り付け] をクリックします。

値 37.000 がセル E3 に貼り付けられます。このとき、コピーされたセル D3 は有効でしたが、E3 は無効 (グレー表示) になっています。D3 のセル状態は A3 の値について相対条件付きであったため、貼り付けられた E3 の状態は、セルが 1 つ右に「移動」したことにより B3 の値に基づいて条件付きで決まることになります。相対セル状態参照では、(水平および垂直の両方向で) 同じ距離にあるセルをセルの内容として変換します。セル E3 は、B3 の値が 0.000 になっているため無効になります。

セル E3 を選択すると、相対セル状態参照 (B3 の場合) は [ジョブの編集] ツールバーで次のように視覚的に識別できます。

B3 に 0 以外の値が格納されていれば、E3 の値が 37 と表示されます。

絶対条件付きセル状態の例

上の例を拡張し、スプレッドシートに以下のセルを追加します。

A4 = 1.000

B4 = 0.000

D4 = 442.000
  1. セル D4 を右クリックして [セル状態] を選択します。
  2. [Conditionally Enabled (条件付き有効)] をクリックします。
  3. 「条件付き参照」で、[絶対] をクリックします。
  4. [セルの選択] をクリックします。
  5. セル A4 をダブルクリックします。
  6. [OK] をクリックし、[Edit Cell State (セル状態の編集)] ダイアログを閉じます。
  7. セル D4 を右クリックして [コピー] を選択します。
  8. セル E4 を右クリックして [貼り付け] を選択します。

値 442.000 がセル E4 に貼り付けられます。E4 が有効になりますが、これは、コピーされたセル D4 のセル状態は A4 の値について絶対条件付きであったためです。絶対条件付きセル状態参照では、セルが新しい場所に貼り付けられても変換されません。

セル E4 を選択すると、相対セル状態参照 ($A$4 の場合) は [ジョブの編集] ツールバーで次のように視覚的に識別できます。

A4 に 0 以外の値が格納されていれば、E4 の値は 442 になります。

関連項目

  • 絶対セル参照
  • 相対セル参照
  • スプレッドシートのセルロジックと参照
  • [プロファイラ] ダイアログ
Version: 5.6.0


In-Sight 座標システム

In-Sight Explorer GUI リファレンス

In-Sight ビジョンシステムで取り込んだ画像の場合、座標 (0,0) の画像の原点は、ピクセルの中央に配置されます。座標 0,0 は、ピクセルの中心を示します (ピクセルは矩形であることが前提です)。整数の座標の値は、ピクセル中心間の中間の点を指定します。

X 軸は原点から下に向かって垂直に延び、Y 軸は原点から右に向かって水平に延びます。高さは X 軸、幅は Y 軸で示され、角度は反時計方向 (右側) に向かって増えます。
Version: 5.6.0


[スニペット] ダイアログ

[ファイル] メニュー → [スニペット] → [インポート/エクスポート]

In-Sight Explorer GUI リファレンス

[スニペット] ダイアログでは、セルデータ (.CXD) ファイルとして保存されている事前設定セルのグループを PC の Snippets フォルダへエクスポートすることにより、頻繁に実行されるスプレッドシートのタスクを自動化できます。その後スニペットは、スプレッドシートにインポートされます。あるいは、ツールパレットからスプレッドシートに直接ドラッグアンドドロップすることによってスニペットをインポートすることもできます。

注:
  • PC の Snippets フォルダに格納されているスニペットは、パレットに自動的に取り込まれます。
  • ExportData/ImportData 関数を使用して、スニペットを PC にエクスポート/インポートすることはできません。

スニペットのエクスポート

スニペットのインポート

スニペットのエクスポート

  1. エクスポートするデータが格納されているセルを選択します。
  2. [ファイル] メニューで [スニペット] → [エクスポート] をクリックするか、またはエクスポートするデータが格納されているセルを右クリックして、ショートカットメニューで [スニペット] → [エクスポート] を選択します。

  3. エクスポートするスニペットを保存する場所を選択します。
  4. アクティブセルを新規ファイルとして保存するには、[ファイル名] テキストボックスに名前を入力して、[保存] をクリックします。既存のファイルを置き換えるには、リストからそのファイルを選択して [保存] をクリックします (これにより、ファイルに記録されているすべてのデータが上書きされます)。In-Sight Explorer は、エクスポートされるすべてのセルに .CXD ファイル拡張子を自動的に付加します。

注: In-Sight Explorer 4.4.1 以降で、ジョブが保護されている場合は、ドロップダウンメニューのオプション [暗号化] が有効になります。オプションは、[高速 (デフォルト)] と [レガシー] の 2 つです。[高速] オプションでは、特に大規模なジョブファイルのジョブに関連する遅延を低減します。[レガシー] オプションは、In-Sight Explorer 4.4.0 以前を実行中の In-Sight ビジョンシステムと互換性を持たせる必要があるジョブの場合に使用します。[暗号化] ドロップダウンは、ジョブで使用されている現在の暗号化オプションに設定されます。

スニペットのインポート

  1. 空のセルを選択します。
  2. [ファイル] メニューで [スニペット] → [インポート] をクリックするか、またはそのセルを右クリックしてショートカットメニューで [スニペット] → [インポート] を選択します。

  3. 開くスニペットが格納されている場所を選択します。
  4. 対象のファイルをハイライト表示して、[開く] をクリックします。あるいは、スニペットファイルをダブルクリックするか、ファイル名を入力することができます。

関連項目

パレット

Version: 5.6.0


[セルのインポート] / [セルのエクスポート] ダイアログ

[ファイル] メニュー

In-Sight Explorer GUI リファレンス

[セルのエクスポート] ダイアログでは、スプレッドシートのセルデータをセルデータ (.CXD) ファイルにエクスポートすることができます。.CXD ファイルは、次の場所に保存できます。

  • 中央サーバ (FTP 経由)。
  • ローカルまたはリモートの In-Sight ビジョンシステムまたはエミュレータ。
  • ローカルまたはリモートの In-Sight ビジョンシステムまたはエミュレータの RAMDisk フォルダ。
  • ローカルまたはリモートの In-Sight ビジョンシステムの SD Card フォルダ。
  • PC の Snippets フォルダ。

[セルのインポート] ダイアログでは、.CXD ファイル内のデータを次の場所からスプレッドシートにインポートできます。

  • 中央サーバ (FTP 経由)。
  • ローカルまたはリモートの In-Sight ビジョンシステムまたはエミュレータ。
  • ローカルまたはリモートの In-Sight ビジョンシステムまたはエミュレータの RAMDisk フォルダ。
  • ローカルまたはリモートの In-Sight ビジョンシステムの SD Card フォルダ。
  • PC の Snippets フォルダ。

[セルのエクスポート]　/ [セルのインポート] ダイアログでは、任意のセルデータ型が格納されているセルをエクスポートおよびインポートすることができ、セルのエクスポートおよびインポート操作はユーザが開始します。[セルのエクスポート] / [セルのインポート] ダイアログを使用してセルデータをインポートする場合、インポートされるデータはスプレッドシート内で編集可能です。

セルのエクスポート

セルのインポート

セルのエクスポート

  1. エクスポートするデータが格納されているセルを選択します。
  2. [ファイル] メニューで [セルのエクスポート...] をクリックするか、またはエクスポートするデータが格納されているセルを右クリックしてショートカットメニューで [セルのエクスポート...] を選択します。

  3. エクスポートするセルを保存する場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカルサブネット上の In-Sight ビジョンシステムで検出されたすべてのローカルドライブとネットワークドライブ、エミュレータ、RAMDisk フォルダと SD Card フォルダ、および Explorer のホストテーブルで定義されているすべてのデバイスが含まれます。

注: Snippets フォルダにエクスポートされた .CXD ファイルは、[パレット] に自動的に取り込まれます。

  4. アクティブセルを新規ファイルとして保存するには、[ファイル名] テキストボックスに名前を入力して、[保存] をクリックします。既存のファイルを置き換えるには、リストからそのファイルを選択して [保存] をクリックします (これにより、ファイルに記録されているすべてのデータが上書きされます)。In-Sight Explorer は、エクスポートされるすべてのセルに .CXD ファイル拡張子を自動的に付加します。

セルのインポート

  1. 空のセルを選択します。
  2. [ファイル] メニューで [セルのインポート...] をクリックするか、またはそのセルを右クリックしてショートカットメニューで [セルのインポート...] を選択します。

  3. 開く .CXD ファイルが格納されている場所を選択します。[ファイルの場所] ドロップダウンリストには、ローカルサブネット上の In-Sight ビジョンシステムで検出されたすべてのローカルドライブとネットワークドライブ、エミュレータ、RAMDisk フォルダと SD Card フォルダ、および Explorer のホストテーブルで定義されているすべてのデバイスが含まれます。ビジョンシステムに存在する .CXD ファイルのリストを表示するには、ドロップダウンリストから対象のビジョンシステムを選択します。
  4. 対象のファイルをハイライト表示して、[開く] をクリックします。あるいは、.CXD ファイルをダブルクリックするか、ファイル名を入力することができます。

関連項目

ExportData 関数

ImportData 関数

[RAMDisk] ダイアログ

パレット

Version: 5.6.0


[ジョブの保護] ダイアログ

[挿入] メニュー

In-Sight Explorer GUI リファレンス

[ジョブの保護] ダイアログでは、ジョブの特定の部分が変更されないようにします。これは、例えば、ジョブが正常に機能するために変更されないままにする必要があるセルを含むジョブを作成し、同時にジョブの残りはカスタマイズできるようにする場合に役立ちます。ジョブはユーザ指定のパスワード (空白のままにすることが可能) によって保護され、ジョブの保護を解除するのにもパスワードが必要です。

ジョブが保護されている場合、ロックされた任意のセル内の数式は変更できませんが、ロックされたセルのフォーマット (フォントや色など) は変更することができます。マウスのポインタがロックされたセルの位置にある間、ロックされたセルの数式は数式バーとスプレッドシートビューのステータスバーに表示されますが、グレーアウトされます。ロックされたセルの場合には無効なメニュー項目およびツールバーのボタンは、ロックされたセルが選択されると無効になります。ロックされたセルの数式内の値は、編集関数を使用して変更できます。例えば、整数値は EditInt 関数を使用して変更可能です。ジョブが保護されている場合は、シートの左上角に小さな錠アイコンが表示されます。

ジョブが保護されている場合、ロックされているセルでは、次のアクションが無効になります。

  • すべてクリア
  • コンテンツのクリア
  • 切り取り
  • セル、行、列の削除
  • セルの数式の編集 (数式バーとプロパティシートのいずれかから)
  • セルのグラフィックスの編集
  • セル状態の編集
  • 絶対参照と相対参照の挿入
  • シンボリックタグの挿入、削除、偏向
  • 関数の挿入
  • 貼り付け

また、ジョブが保護されている場合は、次のアクションも無効になります。

  • セル、行、列の挿入

[ジョブの保護] ダイアログを表示するには

  1. [ファイル] メニューで、[ジョブの保護...] をクリックします。

注: [OK]　をクリックすると、パスワードが入力されていなくてもジョブが保護されます。

  2. パスワードを入力して、[OK] をクリックします。確認のためにパスワードの再入力を求められます。

確認用のパスワードが元のパスワードと異なると、検証に失敗し、次のダイアログが表示されます。

検証に失敗した場合は、パスワードを入力し、それから検証する必要があります。


[Delete Cells (セルの削除)] ダイアログ

[挿入] メニュー

In-Sight Explorer GUI リファレンス

[Delete Cells (セルの削除)] ダイアログを使用して、1 つのセル、一定範囲のセル、またはスプレッドシートの行または列を削除します。

[Delete Cells (セルの削除)] ダイアログを表示するには

  1. 削除する 1 つのセル、一定範囲のセル、行または列をクリックします。
  2. [編集] メニューで、[削除] をクリックします。または、削除するセルを右クリックして、ショートカットメニューから [削除] を選択します。

  3. セル、行、または列の削除方法が決まったら、[OK] をクリックしてそれらのセル、行、または列を削除します。

[Delete Cells (セルの削除)] ダイアログの設定項目

  • [セルを左にシフト]: 選択したセルを削除し、残りのセルを左にシフトします。削除しようとするセルと同じ数のセルを選択します。
  • [セルを上にシフト]: 選択したセルを削除し、残りのセルを上にシフトします。削除しようとするセルと同じ数のセルを選択します。
  • [行全体]: セルの行全体を削除します。削除する行の 1 つのセルをクリックします。例えば、行 5 を削除するには、行 5 内の 1 つのセルをクリックします。
  • [列全体]: セルの列全体を削除します。削除する列の 1 つのセルをクリックします。例えば、列 B を削除するには、列 B 内の 1 つのセルをクリックします。


[検索] ダイアログ

[編集] メニュー

In-Sight Explorer GUI リファレンス

[検索] ダイアログを使用して、スプレッドシート内のテキスト文字列や数値を見つけます。

[検索] ダイアログを表示するには

  1. [編集] メニューで [検索] をクリックするか、または [標準] ツールバーの [検索] ボタン [image] をクリックします。
  2. [検索対象] バーにテキストまたは数値を入力し、[次を検索] ボタンをクリックしてサーチを開始します。

注: [検索] ダイアログを有効にするには、センサが [ライブビデオ] ではなく、また [オフライン] になっており、さらにスプレッドシートのオーバーレイが表示されている必要があります。

[検索] ダイアログの設定項目

  • [検索対象]: このボックスを使用して、サーチを定義するテキストまたは数値を入力します。ドロップダウンメニューを使用して過去のサーチを表示することができます。テキストや数値を入力しない場合、In-Sight Explorer は、数式、値またはコメントが格納されていない次のセルを検索します。
  • [サーチ]: 行別または列別のサーチ順を指定します。
  • [ファイルの場所]: サーチを実行する場所 ([Formulas (数式)]、[値] または [Comments (コメント)]) を指定します。
  • [大文字と小文字を区別する]: サーチで大文字と小文字を区別するかどうかを指定します。大文字と小文字を区別してサーチするにはチェックボックスをオンにします。
  • [完全に同一なセルだけを検索する]: サーチパラメータで文字列全体または従属文字列を特定する必要があるかどうかを指定します。文字列全体を特定するときに指定したサーチを有効にするには、チェックボックスをオンにします。
  • [次を検索]: このボタンを押してサーチを開始し、もう一度押してサーチ条件の次の繰り返しインスタンスを検索します。一致するセルがすべて検出された後に [次を検索] を押すと、サーチ条件の最初のインスタンスが返されます。
  • [閉じる]: このボタンを押して [検索] ダイアログを終了します。


[移動] ダイアログ

[編集] メニュー

In-Sight Explorer GUI リファレンス

[移動] ダイアログを使用して、スプレッドシート内の特定のセルを指定し、そのセルをアクティブセルにします。検索するセルがスプレッドシートの表示領域外にある場合、スプレッドシートは指定されたセルまで自動的にスクロールします。

[移動] ダイアログを表示するには

  • [編集] メニューで、[移動] をクリックします。

注: [移動] ダイアログを有効にするには、センサが [ライブビデオ] ではなく、また [オフライン] になっており、さらにスプレッドシートのオーバーレイが表示されている必要があります。

[移動] ダイアログの設定項目

  • [移動]: このテキストボックスを使用して、ジャンプ先のアクティブにするセルを入力します。セルは 1 つだけ入力可能です。
  • [OK]: このボタンをクリックしてサーチを開始します。
  • [キャンセル]: このボタンをクリックしてダイアログを閉じます。


[カスタムビューの設定] ダイアログ

[編集] メニュー

In-Sight Explorer GUI リファレンス

[カスタムビューの設定] ダイアログでは、スプレッドシートのカスタムビューのプロパティを設定します。アプリケーション開発者は、カスタムビューを使用して実行時表示を作成し、関係のあるジョブデータのみが表示され、スプレッドシート内の詳細な数式がすべて非表示になるようにすることができます。ダイアログやウィザードなどのグラフィックコントロールがカスタムビューに含まれる場合、生産現場のオペレータはジョブ設定に簡単な調整を加えることができますが、スプレッドシートやプロパティシートで数式を直接変更することはできません。

Closed カスタムビューのサンプル

注: カスタムビューは、In-Sight センサにログオンする、アクセスレベルがプロテクトまたはロックのユーザが表示することができるスプレッドシートの唯一のビューです。

スプレッドシートのカスタムビューを定義するには

  1. [編集] メニューで、[カスタムビューの設定] をクリックします。

  2. [セルの選択] をクリックします。セル選択モードでは、カスタムビューで表示されるセル範囲をハイライト表示することができます。定義された位置とサイズ (次の手順) に収めるにはこの範囲が大きすぎる場合、カスタムビューでは、スクロールして範囲内のすべてのセルにアクセスすることができます。

注: カスタムビューのセル範囲は、スプレッドシート内のセルグループをハイライト表示し、範囲内を右クリックして [カスタムビューの設定] を選択することにより、すばやく定義することができます。

  3. 次のボタンを使用して、カスタムビューの位置とサイズを設定します。
  • [移動/サイズ変更]: 対話型グラフィックス領域を調整することにより、カスタムビューの位置、高さ、幅を定義できます。

注: カスタムビューのサイズを、前の手順で設定したセル範囲のサイズより大きくすることはできません。

  • [Center (中央)]: カスタムビューの位置をディスプレイの中央にします。この設定は、[移動/サイズ変更] で設定するどの位置よりも優先されます。
  • [Size To Fit (サイズを合わせる)]: カスタムビューのサイズを [セルの選択] で指定した範囲に合うように変更します。この設定は、[移動/サイズ変更] で設定するどのサイズよりも優先されます。
  4. カスタムビューに表示する [Display Elements (表示要素)] を選択します。
  • [画像]: オンにすると、カスタムビューオーバーレイの下に画像が表示されます。画像を非表示にするには [画像] チェックボックスをオフにします。
  • [オーバレイ]: オンにすると、カスタムビューオーバーレイが常に表示されます。カスタムビューオーバーレイを非表示にするには、[オーバーレイ] チェックボックスをオフにします。
  • [グラフィックス]: オンにすると、スプレッドシートの関数によって生成されたグラフィックスが画像の上部に常時表示されます。すべてのグラフィックスを非表示にするには、[グラフィックス] チェックボックスをオフにします。

注: 必要な要素に限定して表示すると、In-Sight Explorer で表示を更新するのにかかる時間が短縮され、検査の総所要時間を削減することができます。

  5. [オプション]: 選択した表示要素を更新する条件を指定します。
  • [Refresh Conditionally (条件付き更新)]: 参照セルの値に基づいて、表示要素を条件付きで更新します。

このチェックボックスをオンにすると、選択した表示要素は、「参照」に 0 以外の値が格納されている場合にのみ更新されます。「参照」が 0 に評価されると、画像、グラフィックスおよびオーバーレイは、それぞれのチェックボックスの状態に関係なく更新されません。選択した表示要素を取り込んだ後に必ず更新するには、このチェックボックスをオフにします。

  • [参照]: 表示要素を更新するタイミングを決めるセル参照を設定します。

条件付き更新の例: [Refresh Conditionally (条件付き更新)] が選択されており、[参照] が $A$1 を指すように設定されている (障害状態が発生すると必ず 1.000 と評価) と仮定します。この場合、画像、グラフィックスおよびカスタムビューオーバーレイは、セル $A$1 の値が 0 以外であれば、取り込み後にのみ更新されることになります。それ以外の場合、画像、グラフィックスおよびカスタムビューオーバーレイは、障害状態が発生するまで、そのままの状態で静的に表示されます。

  6. [オプション] [ジョブの表示] ツールバーでシートズームのパーセンテージを入力することにより、カスタムビューのシートズームレベルを指定します。この操作は、[カスタムビューの設定] ダイアログが開かれているか、カスタムビューが表示されている場合にはいつでも行うことができます。カスタムビューのシートズームパーセンテージが変更されると、カスタムビューのサイズは、[セルの選択] で指定した範囲に合わせて自動的に変更されます。

注: スプレッドシートビューとカスタムビューでは、別々のシートズーム値が保持されます。

  7. [OK] をクリックしてカスタムビューに対する変更に同意するか、[キャンセル] をクリックして変更を破棄します。

関連項目

起動時にカスタムビューをロードする方法


[EasyView の設定] ダイアログ

[編集] メニュー

In-Sight Explorer GUI リファレンス

HMI アプリケーションを使用する場合は、EasyView を作成して、データの表示方法をカスタマイズし、オペレータによってデータを編集可能かどうかを決定できます。まず、In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存します。次に、PC の VisionView PC Demo アプリケーションか Web HMI を使用して EasyView をプレビューし、正しく設定されていることを確認します。

注:

  • VisionView PC Demo は、45 分で自動的にタイムアウトします。すべての機能を搭載した、タイムアウトのないライセンス版を購入するには、VisionView PC Software をインストールしてください。VisionView PC Software は、VisionView サポートサイトからダウンロードできます。
  • VisionView PC Demo の使用感は、VisionView オペレータインタフェースパネルまたは VisionView VGA とは異なります。

EasyView の設定

  1. EasyView に含めるデータを持つスプレッドシート内のセルを選択します。
  2. セルのシンボリックタグを作成します。
  3. シンボリックタグエディタで、[EasyView] チェックボックスをオンにします。

  4. [EasyView の設定] ダイアログを開きます。[EasyView の設定] ダイアログに項目が自動的に表示されます。

    注:

    • 以前に定義したシンボリックタグがジョブに含まれる場合は、[追加] ボタンを押して、[Select EasyView Items] ダイアログを起動し、[EasyView の設定] ダイアログに手動で項目を追加します。
    • ジョブが元々 EasyBuilder で作成されている場合、[Select EasyView Items] ダイアログにはジョブに追加された位置決めツールや検査ツールからのデータが自動的に組み込まれます。

  5. 必要な場合には、[編集の可否] チェックボックスをオンにすると、オペレータは VisionView でその項目を変更できます。

    注: VisionView からの編集を可能にするには、その項目に対する読み書き許可が必要です。
  6. 必要な場合には、[ラベルの挿入] ボタンを押してヘッダラベルを作成します。ラベルは、項目の分類に有効です。
  7. [キャプション] は、HMI アプリケーションで表示される名前です。項目またはラベルの [キャプション] フィールド内をクリックし、記述的な名前を入力するとデフォルトのキャプションを変更できます。変更を確定するには Enter キーを押すか、[キャプション] フィールドの外側をクリックします。変更を取り消すには、Escape キーを押します。
  8. 項目やラベルの表示方法を再調整するには、リストでそれらの項目またはラベルを選択し、[上へ] または [下へ] ボタンをクリックして適切な順序に設定します。
  9. ジョブファイルを保存します。

  10. EasyView の表示方法をプレビューするには、VisionView PC Demo または Web HMI を起動します。

    注: VisionView PC Demo が PC にインストールされている場合、デフォルトのインストールディレクトリは、C:/Program Files/Cognex/VisionView/PC Demo x.x.x.VisionView PC デモがインストールされていない場合、Cognex オンラインサポートサイトからアプリケーションをダウンロードできます。
  11. VisionView PC Demo または Web HMI が起動したら、センサからログオフします。

  12. Web HMI を使用する場合は、[EasyView] ペインで EasyView をプレビューできます。

    VisionView PC Demo を使用する場合は、[選択中のセンサ] リストにセンサを追加し、実行モードに切り替え、[表示切り替え] ボタンをクリックして EasyView をプレビューします。

    注:
    • EasyView をプレビューするには、まず [HMI ビューの選択] ダイアログで EasyView のオプションを有効にする必要があります。
    • エミュレータにログオンしているときに EasyView をプレビューするには、最初に VisionView アプリケーションの [Selected Sensors] リストにエミュレータを追加する必要があります。

[EasyView の設定] ダイアログを表示するには

  • [EasyView の設定] ダイアログを表示するには、[編集] メニューで [EasyView の設定] をクリックします (または、スプレッドシートを右クリックし、ショートカットメニューから [EasyView の設定] を選択します)。

[EasyView の設定] ダイアログの設定項目

  • [追加]: [EasyView アイテムの選択] Closed ダイアログを起動して、[EasyView の設定] ダイアログに項目を手動で追加します。

  • [削除]: ハイライトした項目を [EasyView の設定] ダイアログから削除します。
  • [クリア]: [EasyView の設定] ダイアログのすべての項目をクリアします。
  • [ラベルの挿入]: 項目を分類するためのヘッダラベルを作成します。
  • [上へ]: ハイライトした項目をリストの上に移動します。
  • [下へ]: ハイライトした項目をリストの下に移動します。

関連項目

Web HMI の設定

シンボリックタグエディタ

Version: 5.6.0


[スクリプトの編集] ダイアログ

In-Sight Explorer GUI リファレンス

[スクリプトの編集] ダイアログは Script 関数と組み合わせて使用され、JavaScript ソースコードの作成、編集、およびテストを行います。

  • 概要
  • [スクリプトの編集] ダイアログを表示するには
  • [スクリプトの編集] ダイアログペインとコントロール
  • 関連項目

概要

[スクリプトの編集] ダイアログは、Script 関数を含んでいるセルに入力すると表示され、これを使用して JavaScript ソースコードの作成、編集、およびテストを行います。デフォルトでは、初めて [スクリプトの編集] ダイアログを開いたときに、サンプルスクリプトと引数がロードされます (サンプルスクリプトは C:\ProgramData\Cognex\In-Sight\In-Sight Explorer 5.x.x\Scripts にあります)。サンプルスクリプトは、カスタムスクリプトを作成するためのテンプレートとして使用することができます。

注: スクリプトの編集と作成の詳細については、Script 関数のトピックおよび「スクリプト関数」のトピックを参照してください。

[スクリプトの編集] ダイアログを表示するには

[スクリプトの編集] ダイアログを表示するには、次の 2 つの方法があります。

  • Script 関数を空のセルに追加する。
  • 既存の Script 関数をダブルクリックする。

[スクリプトの編集] ダイアログペインとコントロール

[スクリプトの編集] ダイアログは、異なる 4 つのペインで構成されています。引数テキストボックス、コードエディタ、コンソール出力、および結果です。

注: このダイアログ内のペインはそれぞれ、ダイアログの横にドッキングすることができます。[OK] ボタンを押して [スクリプトの編集] ダイアログを閉じても、ペインの位置は保存されます。

ペインのほか、[スクリプトの編集] ダイアログには次のメニュー項目とコントロールが含まれています。

  • [スクリプト]: さまざまなアクションにアクセスしてスクリプトを変更することができます。
    • [テストスクリプト]: [テストスクリプト] ボタンと同じアクションを実行します。
    • [スクリプトのインポート]: [開く] ダイアログを開き、保存されているスクリプトファイル (.js ファイル拡張子で示されます) を表示します。スクリプトをインポートすると、コードエディタ内の現在のスクリプトが置き換えられます。
    • [スクリプトのエクスポート]: [保存] ダイアログを開き、スクリプトファイルを保存したり (.js ファイル拡張子を使用)、以前に保存したスクリプトを上書きしたりすることができます。
    • [戻す]: スクリプトを、開かれている [スクリプトの編集] ダイアログより前の状態に戻します。
    • [閉じる]: [スクリプトの編集] ダイアログを閉じます。変更を行った場合には、ダイアログを閉じる前に変更内容を保存するよう求められます。
  • [編集]: コードエディタでソースコードを変更するためのさまざまなアクションを実行することができます。
    • [元に戻す]: コードエディタでスクリプトに行った最後の変更を元に戻します。
    • [やり直し]: コードエディタで、スクリプトで元に戻した最後の変更をやり直します。
    • [コピー]: コードエディタで選択したテキストをクリップボードにコピーします。
    • [切り取り]: コードエディタで選択したテキストを切り取って、クリップボードにコピーします。
    • [貼り付け]: クリップボードの内容をコードエディタに貼り付けます。
    • [検索]: [検索と置換] ダイアログの [検索] タブを開き、コード内のテキストを探します。
    • [置換]: [検索と置換] ダイアログの [置換] タブを開き、コード内のテキストを探してその他のテキストと置き換えます。
    • [移動]: [行に移動] ダイアログを開き、これを使用してコード内の特定の行番号に移動します。
  • [テストスクリプト]: 関数を含んでいるセルに現在の JavaScript ソースコードを適用して、セルおよびその依存関係のいずれかを実行します。
  • [OK]: 関数を含んでいるセルに現在の JavaScript ソースコードを適用して、セルおよびその依存関係のいずれかを実行し、ダイアログを閉じます。
  • [取り消し]: セルを、開かれている [スクリプトの編集] ダイアログより前の状態に戻します。

引数テキストボックス

[引数] ペインには、Script 関数に入力された引数が表示されます。これはテキストボックスで直接編集することができます。スクリプトを保存すると、スクリプトの引数が保存されます。

コードエディタ

コードエディタに JavaScript ソースコードが表示され、これを使用してスクリプトの作成と編集を行います。エディタ内には、シンタックスのハイライト、行番号、および基本テキストの編集機能 (元に戻す/やり直し、コピー/切り取り/貼り付けなど) が備えられています。

注:
  • テキストを選択しないで切り取り操作を開始すると、カーソルがある行全体が切り取られます。
  • JavaScript 言語は Unicode 文字をサポートおよび使用しており、コードエディタおよびコンソール出力の両方で Unicode 文字がサポートされています。したがって、大部分の国際文字を JavaScript コードに挿入することができます。ただし、Script 関数が文字列をスプレッドシートに返すときには、現在選択されている言語がサポートする文字のみが正しく表されます ([オプション] ダイアログで設定)。

ショートカット

コードエディタでは、次のショートカットを使用することができます。

  • Ctrl + A: コード内のすべてのテキストを選択します。
  • Ctrl + C: 選択したテキストをコピーします。
  • Ctrl + F: [検索と置換] ダイアログの [検索] タブを開き、コード内の値のインスタンスを探します。
  • Ctrl + G: [行に移動] ダイアログを開き、これを使用してコード内の特定の行番号に移動します。
  • Ctrl + H: [検索と置換] ダイアログの [置換] タブを開き、コード内の値のインスタンスを探して代わりの値と置き換えます。
  • Ctrl + I: [クイック検索] アイコンをクリックして入力を開始すると、コード内で次に見つかった、入力された文字のインスタンスにカーソルが移動します。
  • Ctrl + L: カーソルがある行を削除します。
  • Ctrl + P: コピーしたテキストを貼り付けます。
  • Ctrl + T: カーソルがある文字を、その後の文字とスワップします。
  • Ctrl + W: カーソル位置の横にある単語を選択します。
  • Ctrl + X: 選択したテキストを切り取って、クリップボードにコピーします。
  • Ctrl + Z: 最後に実行された操作を取り消します。

コンソール出力

[コンソール出力] ペインには、現在選択している In-Sight ビジョンシステムまたはエミュレータのすべてのスクリプトのコンソールオブジェクトに送信された、ログメッセージが表示されます。

注:
  • スプレッドシートビューにログメッセージを表示するには、[表示] メニューから [スクリプトコンソール出力] オプションを選択します。
  • パフォーマンスを向上させるには、ビジョンシステムがオンラインであるときは [スクリプトコンソール出力] ウィンドウを閉じます。

結果

[結果] ペインには、スクリプトの run() 関数によって返された最後の値が表示されます。[テストスクリプト] ボタンを押すと、表示されている値が更新されます。

関連項目

  • スクリプト関数
  • Script 関数
  • Get 関数


[シートズーム] ダイアログ

[表示] メニュー

In-Sight Explorer GUI リファレンス

[シートズーム] ダイアログでは、スプレッドシートの表示倍率を増減することができます。

注: スプレッドシートビューとカスタムビューでは、別々のシートズーム値が保持されます。

[シートズーム] ダイアログを表示するには

  • [表示] メニューで、[シートズーム] を選択します。

注: あるいは、Explorer ツールバーにある [シートズーム] [image] ドロップダウンにシートズーム値を入力することができます。

[シートズーム] ダイアログを使用するには

  1. 適度なレベルの表示倍率を入力します。
  2. [OK] をクリックします。[シートズーム] は 10% ～ 400% の任意のパーセンテージ値にすることができます。

ヒント: シートズーム値を入力した後は、TAB を押してスプレッドシートで [シートズーム] 設定をプレビューできます。


[ジョブの監査]

[表示] メニュー

In-Sight Explorer GUI リファレンス

[ジョブの監査] では、ジョブ内のセルの依存関係をグラフィカルに表示するとともに、ジョブ内のエラー (#ERR) のあるセルを表示することができます。

  • [ジョブの監査] について
  • [ジョブの監査] の使用
  • [ジョブの監査] のショートカット

[ジョブの監査] について

[ジョブの監査] では、ジョブ内のセルの依存関係をグラフィカルに表示するとともに、ジョブ内のエラー (#ERR) のあるセルを表示することができます。セル内の式が別のセルまたは一定範囲のセルを参照する場合は、依存関係が存在します。各依存関係には、参照元と参照先の 2 つの部分があります。参照元はデータのソース (セルの式によって参照されるセルまたは一定範囲のセル) を意味し、参照先はデータのデスティネーション (ほかのセルを参照する式が格納されているセル) を意味します。

1 つの式に含まれるすべてのセル参照が、1 つの参照元と 1 つの参照先で成る明確な 1 つの依存関係を構成します。各依存関係は、参照元から参照先を指す色分けされた矢印で表示されます。矢印の端の小さな円は、参照元セルを示します。エラーの矢印はエラー以外の矢印の上に重ねて表示され、参照元の矢印は参照先の矢印の上に重ねて表示されます。

依存関係は次の順序で描画されます。

  1. 通常の参照先 = 緑の矢印
  2. 通常の参照元 = 青の矢印
  3. エラーのある参照先 = 黄の矢印
  4. エラーのある参照元 = 赤の矢印

以下の場合、依存関係は異なる方法で描画されます。

  • 複数セルの参照元: 複数のセルが 1 つの参照元を参照する場合、一定範囲のセルの輪郭が表示され、範囲内の左端のセルのドットから矢印が始まります。例については、 Closed ここをクリックしてください。

  • 条件付き参照: セルが条件付きで有効化される場合、条件付き参照は破線を使用して描画されます。例については、 Closed ここをクリックしてください。

  • 非表示の行と列: 依存関係が非表示の行または列を参照する場合は、近接する表示行または表示列の間に存在する区切り線に依存関係線が描画されます。例については、 Closed ここをクリックしてください。

  • 空のセル: セルの式が空のセルを参照する場合、この関係は参照先セルが選択されるときに表示されますが、空の参照元セルが選択された場合には表示されません。選択したセルに関係なく、参照先セルにクエスチョンマークが赤で表示されます。例については、 Closed ここをクリックしてください。

    参照先セルが選択されます。

    参照元セルが選択されます。

  • Dialog 関数: メインスプレッドシートのセルと Dialog 関数に属するセルの間の依存関係を表示することができます。依存関係は、Dialog 関数に含まれる個々のセルではなく、Dialog 関数が格納されているセルとの間に矢印を描画することによって表示されます。例については、 Closed ここをクリックしてください。

  • デッドエンドセル: セルに参照先がない場合、そのセルはマゼンタ色の破線の境界線で描画されます。マゼンタ色の境界線は、選択したセルに関係なく、スプレッドシート内のすべてのデッドエンドセルの場合に表示されます。例については、 Closed ここをクリックしてください。

    セル A0 と C2 には参照先がない
    ため、それらのセルは、ハイ
    ライト表示されたセルに関係なく、マゼンタ
    色の境界線で描画されます。

    セル C4 はセル A0 と C2 の参照先
    であるため、セル A0 と C2 はマゼンタ色
    の境界線で描画されません。

次のデッドエンドセルには、マゼンタ色の境界線が表示されません。

  • シンボリックタグが付いているセル。
  • テキストラベルが格納されているセル
  • ColorLabel、Dialog、Link、Wizard、MessageBox、SetEvent または Timer 関数が格納されているセル。
  • 「Plot」関数 (PlotString、PlotRegion など) が格納されているセル。
  • 「Write」関数 (WriteDeviceNetBuffer、WriteFTP、WriteSerial など) が格納されているセル。

[ジョブの監査] の使用

  • 特定のセルの依存関係の表示
  • ジョブ内のすべての依存関係の表示
  • 特定のセルのエラーのある依存関係の表示
  • ジョブに存在するセルの依存関係エラーのみの表示
  • アクティブセルの最初のエラー (#ERR) のある参照元へのジャンプ
  • すべての依存関係矢印の削除

特定のセルの依存関係の表示

  1. 参照先セルと参照元セルを検出するデータが格納されているセルを選択します。
  2. [表示] メニューで、[ジョブの監査] をクリックし、[依存レベルを上げる] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [Show Dependency Levels Increase (依存レベルの増加の表示)] ボタンを押します。
  3. アクティブセルにデータを入力するセルの次のレベルを識別するには、[依存レベルを上げる] をもう一度選択します。
  4. 依存関係矢印を一度に 1 レベルずつ削除するには、[表示] メニューで [ジョブの監査] をクリックし、[依存レベルを下げる] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [Show Dependency Levels Increase (依存レベルの減少の表示)] ボタンを押します。

ジョブ内のすべての依存関係の表示

  1. スプレッドシートの左上角をクリックしてスプレッドシート全体をハイライト表示します。
  2. [表示] メニューで、[ジョブの監査] をクリックし、[依存レベルを上げる] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [Show Dependency Levels Increase (依存レベルの増加の表示)] ボタンを押します。これにより、ジョブ内に存在するすべての依存関係矢印がアクティブになります。

特定のセルのエラーのある依存関係の表示

  1. 参照先セルと参照元セルを検出する、エラーのあるデータが格納されているセルを選択します。
  2. [表示] メニューで、[ジョブの監査] をクリックし、[依存レベルを上げる] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [Show Dependency Levels Increase (依存レベルの増加の表示)] ボタンを押します。
  3. [表示] メニューで、[ジョブの監査] をクリックし、[エラーのある依存関係のみ表示] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [エラーのある依存関係のみ表示] ボタンを押します。これにより、通常の参照先セルと参照元セルの関係を示す緑と青の矢印が削除され、エラーのある参照先セルまたは参照元セルを示す黄または赤の矢印のみが残されます。

ジョブに存在するセルの依存関係エラーのみの表示

  1. スプレッドシートの左上角をクリックしてスプレッドシート全体をハイライト表示します。
  2. [表示] メニューで、[ジョブの監査] をクリックし、[依存レベルを上げる] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [Show Dependency Levels Increase (依存レベルの増加の表示)] ボタンを押します。これにより、ジョブ内に存在するすべての依存関係矢印がアクティブになります。
  3. [表示] メニューで、[ジョブの監査] をクリックし、[エラーのある依存関係のみ表示] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [エラーのある依存関係のみ表示] ボタンを押します。これにより、通常の参照先セルと参照元セルの関係を示す緑と青の矢印が削除され、エラーのある参照先セルまたは参照元セルを示す黄または赤の矢印のみが残されます。

アクティブセルの最初のエラー (#ERR) のある参照元へのジャンプ

  1. エラー状態にある別のセルに依存するセルを選択します。
  2. [表示] メニューで、[ジョブの監査] をクリックし、[最初のエラーに移動] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [最初のエラーに移動] ボタンを押します。
  3. これにより、スプレッドシートがアクティブセルのエラーのある最初の参照元セルにジャンプし、そのセルがアクティブセルになります。アクティブセルにエラーのある参照元セルがない場合、またはアクティブセルがメインのスプレッドシート内に存在してその最初のエラー参照元がダイアログに存在する場合、またはその逆の場合には、何も起こりません。

すべての依存関係矢印の削除

  1. スプレッドシートから依存関係矢印を削除するには、[表示] メニューで [ジョブの監査] をクリックし、[依存レベルをリセットする] を選択します。あるいは、[ジョブの監査] ツールバーで [image] [Show Dependency Levels Reset (依存レベルのリセットの表示)] ボタンを押します。
Version: 5.6.0


[挿入] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

[挿入] メニューでは、スプレッドシートのアクティブセルにオブジェクトを挿入することができます。

注: スプレッドシートビューがアクティブでないとき、[挿入] メニューは使用できません。

[挿入] メニューの項目

  • [式]: 関数をアクティブセルに挿入するために、[関数の挿入] ダイアログを開きます。アクティブセルにプロパティシートのある関数が含まれる場合、このプロパティシートが開きます。
  • [絶対参照]: セル選択モードを介して絶対セル参照をアクティブセルに挿入します。
  • [相対参照]: セル選択モードを介して相対セル参照をアクティブセルに挿入します。
  • [コメント]: [コメント] ダイアログを使用して、セルに色分けされたコメントを挿入することができます。
  • [シンボリックタグ]: シンボリックタグをセルに挿入します。このタグは、オープンデータアクセスおよびエクスチェンジ (OPC) 用に検査の結果を定義したり、VisionView アプリケーションに EasyView を設定したりするために使用できます。詳細については、OPC ヘルプファイルまたは『VisionView® ソフトウェアマニュアル』を参照してください。
  • [セル]: [セルの挿入] ダイアログを使用して、現在選択されているセルを基準として、スプレッドシートにセルを挿入します。このオプションを利用するには、少なくとも 1 つのセルが選択されている必要があります。挿入するセルは、既存のセルを右または下に移動するか、完全に新しいセルの行または列を挿入するかを指定できます。
  • [行]: 現在選択されている行を基準として、スプレッドシートに行を挿入します (このオプションを利用するには、少なくとも 1 つのセルが選択済みであり、最終行が空白である必要があります)。挿入される行数は、選択した行数と同じです。選択した行内のデータは、その数に応じて下方向に移動します。スプレッドシートに行を挿入しても、スプレッドシート全体の寸法は変わりません。
  • [列]: 現在選択されている列を基準として、スプレッドシートに列を挿入します (このオプションを利用するには、少なくとも 1 つのセルが選択済みであり、最終列が空白である必要があります)。挿入される列数は、選択した列数と同じです。選択した列内のデータは、その数に応じて右方向に移動します。スプレッドシートに列を挿入しても、スプレッドシート全体の寸法は変わりません。


[関数の挿入] ダイアログ

[挿入] メニュー

In-Sight Explorer GUI リファレンス

In-Sight のジョブに含まれているすべての関数は、[関数の挿入] ダイアログからスプレッドシートに配置することができます。[関数の挿入] ダイアログの左側には、ツールのカテゴリ、サブカテゴリ、および関数の展開/折り畳み可能なリストが配置されています。左側でツールのカテゴリを選択すると、そのカテゴリの関数のリストが右側に表示されます。すべての In-Sight 関数については、関数リファレンスで詳しく説明されています。

右側で関数を選択するには、選択する関数をハイライト表示して [OK] ボタンを押すか、ハイライト表示した関数をダブルクリックします。該当する場合は、この関数のプロパティシートが開きます。該当しない場合は、スプレッドシートの現在の挿入位置に関数が配置されます。

注: 任意の数式において許容される、関数、引数、および演算子の最大合計数は 254 個です。関数に対する引数が一定範囲のセルになっている場合は、範囲内のそれぞれのセルが 1 つの引数として数えられます。例えば、Sum(1,2,A3:A6) という数式は、1 つの関数 (Sum) と 6 つの引数 (1、2、A3、A4、A5、A6) によって構成されています。つまり、この数式では、使用可能な 254 の要素のうちの 7 つを使用しています。

[関数の挿入] ダイアログを表示するには

  1. 数式を受け入れるスプレッドシートを選択します。
  2. [挿入] メニューで [関数] をクリックするか、または [ジョブの編集] ツールバーの [関数] ボタン [image] をクリックします。

[関数の挿入] ダイアログのコンポーネント

[状況依存ヘルプ]: [関数の挿入] ダイアログの下部には、ハイライト表示した関数についての簡潔な状況依存ヘルプテキストが表示されます。

注: 関数についての詳細な状況依存ヘルプを表示するには、関数リストから対象の関数を選択して F1 を押します。対応する関数リファレンスのトピックが表示されます。

関連項目

プロパティシート

Version: 5.6.0


コメントダイアログ

[挿入] メニュー

In-Sight Explorer GUI リファレンス

コメントとは、そのほかのセル内容とは別にセルに付加する注釈のことです。コメント付きのセルは、色分けされた三角形のインジケータが右上隅に表示されます。コメント付きのセル上にマウスを置くと、そのセルのコメントが表示されます。例については、 Closed ここをクリックしてください。

コメントダイアログを表示するには

  1. コメントを挿入するセルをクリックします。
  2. [挿入] メニューで、[コメント] をクリックします。または、コメントを挿入するセルを右クリックして、ショートカットメニューから [コメントの挿入] を選択します。
  3. 表示されるボックスに、コメントのテキストを入力します。

注: コメントダイアログは、コメントの挿入を選択した場合でも編集を選択した場合でも、常に [コメントの編集] ダイアログとして表示されます。

  4. コメントテキストの入力を完了した後、[フラグの色] ドロップダウンメニューを使用して、三角形のインジケータの色をカスタマイズすることができます。
  5. テキストとインジケータの色が確定したら、[OK] をクリックしてコメントを挿入します。

コメントを編集するには

  1. コメントがあるセルをクリックします。
  2. [挿入] メニューで、[コメント] をクリックします。または、コメント付きのセルを右クリックして、ショートカットメニューから [コメントの編集] を選択します。
  3. 編集が完了したら、[OK] をクリックして [コメントの編集] ダイアログを終了します。

コメントをセルから削除するには

  1. 削除したいコメントが付いているセルをクリックします。
  2. [編集] メニューの [クリア] オプションを展開し、[コメント] を選択します。または、[挿入] メニューの [コメント] をクリックして、ハイライト表示されたテキストを削除し、[OK] をクリックして [コメントの編集] ダイアログを終了します。

コメントダイアログの設定項目

  • コメントボックス: コメントボックスは、コメントのためのテキストを入力する領域です。コメントには最大 256 文字を入力することができます。
  • [フラグの色]: このドロップダウンリストから色を選択して、三角形のインジケータの色をカスタマイズすることができます。


シンボリックタグエディタ

[挿入] メニュー

In-Sight ExplorerGUI リファレンス

シンボリックタグエディタは、OPC チャネルから In-Sight OPC サーバに転送して、監査メッセージサーバに監査メッセージを生成するか、または EasyView の作成に使用できるデータを含むセルのシンボリックタグの追加、選択、削除、編集にも使用します。これにより、Cognex VisionView デバイスでのデータの表示方法をカスタマイズし、データがオペレータによって編集可能かどうかを決定することができます。

シンボリックタグが格納されているセルの右下角には、色分けされた三角形のインジケータが表示されます。タグ付きのセルの上にマウスを置くと、そのタグ名が表示されます。例については Closed ここをクリックしてください。

注:
  • OPC チェンネルに送信可能な値のタイプの詳細、および In-Sight OPC サーバに関する情報については、In-Sight OPC サーバのヘルプファイルを参照してください。
  • VisionView の詳細については、VisionView Help® ファイルを参照してください。
  • ジョブが英語以外の言語で作成および設定されており、[オプション] ダイアログ で [英語シンボリックタグを EasyBuilder で使用] オプションが有効 (チェックボックスがオン) になっている場合は、このオプションを有効にする前に作成したすべてのシンボリックタグ参照を英語名バージョンに更新する必要があります。
  • シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。この場合は、シンボリックタグ名としてセル名またはセル名と同じフォーマットを使用しないでください。

シンボリックタグエディタの表示

[シンボリックタグエディタ] ダイアログの設定項目

シンボリックタグの要件

シンボリックタグエディタの表示

  1. 送信する情報が格納されているスプレッドシートのセル、またはシンボリックタグが格納されているセルを 1 つ選択します。
  2. [挿入] メニューで、[シンボリックタグ] をクリックします。あるいは、セルを右クリックして、ショートカットメニューから [シンボリックタグの挿入] を選択します。セルにシンボリックタグがすでに格納されている場合、ショートカットメニューのオプションは [シンボリックタグの編集] となります。

注: EasyBuilder でジョブを作成すると、EasyBuilder の全体的なジョブの結果を参照する EasyBuilder タグが自動的にスプレッドシートに挿入されます。すべての EasyBuilder タグを OPC チャンネルを介した送信用に選択可能ですが、一部のタグは EasyView の作成に使用できません。

[シンボリックタグエディタ] ダイアログの設定項目

  • [追加]: AcquireImage　セル (A0) を自動的に挿入します。それ以後は、[追加] ボタンがクリックされるたびに、スプレッドシート内を順番 (列別、次に行別) に移動して、送信可能なデータが格納されている最初の使用可能なセルがスプレッドシートにそ自動的に挿入されます。
  • [セルの選択]: セル選択モードを開始して、シンボリックタグが割り当てられるセルを選択します。
  • [削除]: 選択したシンボリックタグを完全に削除します。

警告: EasyBuilder によって作成されたシンボリックタグは削除しないでください。削除すると、依存関係が破損し、EasyBuilder ジョブが正常に機能しなくなる可能性があります。

注: あるいは、[編集] メニューを使用してシンボリックタグを削除することも可能です。
  1. シンボリックタグが格納されているセルをクリックします。
  2. [編集] メニューの [クリア] サブメニューで、[シンボリックタグ] をクリックします。これにより、セルからタグが削除されます。
  • [Tag Name (タグ名)]: シンボリックタグの名前を指定します。シンボリックタグの名前を変更する場合は、「シンボリックタグの要件」のセクションで概要が述べられている命名規則に従ってください。
  • [Use OPC (OPC の使用)]: オンにすると、シンボリックタグが OPC チャネル経由で送信されます。

注: OPC 経由で書込み可能なのは、EditFloat、EditInt および EditString セルのみです。ターゲットセルにこれらの機能のいずれかが格納されていない場合、In-Sight OPC サーバとサードパーティの OPC クライアントに対しては読み取り専用になります。

  • [監査メッセージ]: オンの場合は、セルの内容に変更を加える (セルの数式や対話型コントロールの値に変更を加える) と、TCP/IP 経由で監査メッセージが自動的に生成され、送信されます。このメッセージは、準拠ソフトウェアシステムの監査メッセージサーバにインポートできます。[監査メッセージの設定] ダイアログを使用して、アクティブなビジョンシステムの監査メッセージの設定を行い、監査メッセージサーバの TCP/IP ポートを指定します。
  • [In EasyView]: オンにすると、シンボリックタグが EasyView に追加されます。[In EasyView] チェックボックスをオンにした後は、[EasyView の設定] ダイアログを使用して VisionView でのデータの表示方法をカスタマイズできます。

シンボリックタグの要件

  • 複数のタグで同じセルを参照することはできません。
  • [Tag Name (タグ名)]:
    • 数字で始めることはできません。
    • 文字として、A ～ Z、a ～ z、0 ～ 9、アンダースコア文字「_」のみを使用できます。スペースや、英語以外の言語の文字は使用できません。
    • 最小で 1 文字、最大で 127 文字を使用できます。
    • セル名にしたり、セル名と同じフォーマット (B2 や B22222 など) を使用したりすることはできません
    • 一意である必要があります。大文字か小文字かに関係なく、同じジョブ内では重複するタグ名を使用できません。例えば、「test」という名前のタグがあるときに、「Test」という名前の別のタグを使用することはできません。

タグを In-Sight OPC サーバに送信する場合は、以下の要件を満たす必要があります。

  • OPC タグでは、In-Sight OPC サーバで使用される以下の事前定義のタグ名は使用できません。
    • AcquistionCount
    • DiscreteOnline
    • GuiOnline
    • JobName
    • LiveMode
    • NativeOnline
    • Online
    • SaveJobAs
    • TriggerEvent
  • In-Sight Explorer および In-Sight OPC サーバ内の OPC タグでは、大文字と小文字が区別されます。In-Sight Explorer で OPC タグを作成する場合は、In-Sight OPC サーバでの対応する OPC タグで正確に同じ大文字と小文字を使用する必要があります。2　つの名前が厳密に一致しない場合は、エラーが生成されます。
  • 転送されるデータ値である OPC 文字列には、8 ビットまたは 2 バイトの文字を含めることができます。

関連項目

[EasyView の設定] ダイアログ

[監査メッセージの設定] ダイアログ


[セルの挿入] ダイアログ

[挿入] メニュー

In-Sight Explorer GUI リファレンス

[セルの挿入] ダイアログを使用して、1 つのセル、一定範囲のセル、新しい行または新しい列をスプレッドシートに追加します。

[セルの挿入] ダイアログを表示するには

  1. 新しいセル、一定範囲のセル、新しい行または新しい列を挿入する 1 つのセルまたは一定範囲のセルをクリックします。
  2. [挿入] メニューで、[セル] をクリックします。または、追加のセル、行、または列を挿入するセルを右クリックし、ショートカットメニューから [挿入] を選択します。

  3. 追加のセル、行、または列の追加方法が決まったら、[OK] をクックしてそれらのセル、行、または列を挿入します。

[セルの挿入] ダイアログの設定項目

  • [セルを右にシフト]: 選択したセルの左側に新しいセルを挿入します。挿入しようとするセルと同じ数のセルを選択します。
  • [セルを下にシフト]: 選択したセルの上に新しいセルを挿入します。挿入しようとするセルと同じ数のセルを選択します。
  • [行全体]: セルの行全体を挿入します。新しい行を挿入しようとする行の直下の行のセルをクリックします。例えば、新しい行を行 5 の上に挿入するには、行 5 内のセルをクリックします。
  • [列全体]: セルの列全体を挿入します。新しい列を挿入しようとする列のすぐ右側の列のセルをクリックします。例えば、新しい列を列 B の左側に挿入するには、列 B 内のセルをクリックします。


[フォーマット] メニュー

メニューバー

In-Sight Explorer GUI リファレンス

[フォーマット] メニューでは、半透明のスプレッドシートオーバレイを定義する行、および列の表示プロパティを変更できます。

注: スプレッドシートビューがアクティブでないとき、[フォーマット] メニューは使用できません。

[フォーマット] メニューの項目

  • [セル]: [セルのフォーマット] ダイアログを使用して、小数点以下の桁数、テキスト配置、フォントのタイプ、スタイル、サイズ、色、セルグラフィックスの線の幅、単一または複数のセルの色を変更することができます。セルのロック設定およびセルのパスワード保護を有効にすることもできます。
  • [行]: スプレッドシートの行のプロパティを調整します。
    • [行の高さ]: 選択したスプレッドシートの行の高さを増減します。
    • [自動調整]: 選択したセル内に含まれる最も幅の広いコンテンツに収まるように、選択した行のサイズを変更します。
    • [行の非表示]: 選択した行をスプレッドシート上で非表示にします。
    • [行の再表示]: 選択した行間で非表示になっている行を再度表示します。行を再表示するためには、スプレッドシートの最上部または最下部の 1 つ以上の行が非表示になっている場合を除き、少なくとも 2 行が選択されている必要があります。スプレッドシートの最上部または最下部の行を再表示するには、非表示になっていない最初または最後の行を選択します。

注: 列がハイライトされているときに [行の再表示] を選択すると、スプレッドシートのすべての行が再表示されます。

  • [列]: スプレッドシートの列のプロパティを調整します。
  • [列の幅]: 選択したスプレッドシートの列の幅を増減します。
  • [自動調整]: 選択したセル内に含まれる最も幅の広いコンテンツに収まるように、選択した列のサイズを変更します。
  • [列の非表示]: 選択した列をスプレッドシート上で非表示にします。
  • [列の再表示]: 選択した列間で非表示になっている列を再度表示します。列を再表示するためには、スプレッドシートの左または右の 1 つ以上の列が非表示になっている場合を除き、少なくとも 2 列が選択されている必要があります。スプレッドシートの左または右の列を再表示するには、非表示になっていない最初または最後の列を選択します。

注: 行がハイライトされているときに [列の再表示] を選択すると、スプレッドシートのすべての列が再表示されます。


[セルのフォーマット] ダイアログ

[フォーマット] メニュー

In-Sight ExplorerGUI リファレンス

[セルのフォーマット] ダイアログは、スプレッドシートの 1 つのセルまたはセル範囲のフォーマットを調整するために使用します。[セルのフォーマット] ダイアログには、次の 6 つのタブがあります。

  • [数値] タブ
  • [ピクチャー] タブ
  • [フォント] タブ
  • [配置] タブ
  • [保護] タブ
  • [グラフィックス] タブ

[セルのフォーマット] ダイアログを表示するには

  • セルまたはセル範囲をハイライトします。
  • [フォーマット] メニューで、[セル] をクリックします。別の方法として、[フォーマット] ツールバーの [セル] [image] ボタンをクリックし、右クリックして、ショートカットメニューから [フォーマット] → [セルのフォーマット] を選択するか、または Ctrl+1 キーを押します。

[セルのフォーマット] ダイアログの設定項目

[数値] タブ

[数値] タブをクリックして、セルの数値の小数点以下の桁数を 0 ～ 6 に設定します。デフォルトの設定は 3 です。

ヒント: 小数点以下の桁数は、[フォーマット] ツールバーの [小数点以下の桁数の増加] [image] ボタンおよび [小数点以下の桁数の縮小] [image] ボタンを使用して設定することもできます。

[ピクチャー] タブ

[ピクチャー] タブをクリックして、セルにグラフィックスを挿入し、スプレッドシート内にアイコンまたはそのほかのグラフィックスを表示します。ピクチャーファイルは、[開く] ボタンを使用してジョブとともに保存するか、[リンク] ボタンを使用してジョブにリンクすることができます。以下のファイル拡張子がサポートされています。

  • BMP
  • GIF*
  • ICO*
  • JPG、JPEG
  • WMF*、EMF*
  • TIF*、TIFF*
  • PNG*
  • EXIF

* これらの画像タイプでは透過色をサポートしています。

[開く] ボタンを使用してピクチャーを挿入すると、ピクチャーファイルがジョブにコピーされるため、ジョブファイルのサイズがそのピクチャーの分だけ大きくなります。

ピクチャーファイルのサイズが 20,000 バイトを超える場合は、次のような警告メッセージが表示されます。

ピクチャーをジョブ内に保存する代わりに、[リンク] ボタンで挿入すると、ローカル PC または共有ネットワークからピクチャーをリンクすることができます。

ピクチャーがリンクされると、ファイルパスがテキストボックスに表示されます。このパスは編集可能です。別のコンピュータで作成されたジョブをロードする場合など、リンク切れを修正することが可能です。

ファイルが見つからない場合は、スプレッドシートとダイアログに赤い×印が表示されます。

パスを編集する場合、有効なピクチャーファイルを示すパスを指定する必要があります。パスが無効な場合はエラーメッセージが表示されます。

[スケール] 数値ボックスには、1 ～ 1,000,000,000 パーセントの範囲で表示倍率を指定することができます。数値ボックスの下には、指定したスケールに基づくピクチャーの実効サイズが表示されます。

セルからピクチャーを削除するには、[クリア] ボタンを使用します。

注:
  • ピクチャーがセルに入りきらない場合は、切り詰められます。ピクチャー全体を表示するには、[行の高さ] と [列の幅] を調整して、セルを拡大してください。
  • 動的に変更されるピクチャーファイルへのリンクはサポートされていません。In-Sight Explorer の外部でファイルに変更が加えられても、元のピクチャーのままです。
  • ピクチャーを開くと、ピクチャーが現在のセルの高さまたは幅 (いずれか小さい方) の 90 パーセントになるように、[スケール] の値が自動的に設定されます。

[フォント] タブ

[フォント] タブをクリックして、フォント、スタイル (標準、斜体、太字、太字斜体)、サイズ (8 ～ 72 ポイント)、文字の色 (前景色) とセルの色 (背景色) を選択します。

[デフォルトのフォントにする] チェックボックスを ON にすると、変更内容をスプレッドシートのすべてのセルのデフォルト設定として設定することができます。

注:
  • 使用可能なフォントのリストは、ホスト PC にロードされているフォントによって異なります。そのフォントを持たない PC にジョブがロードされた場合は、その PC の標準フォントが使用されます。
  • ColorLabel 関数を含むセルについては、前景色と背景色の変更は無視されます。
  • 特に、テキストを含む 2 つのセルの間に空白のセルがある場合など、場合によっては、背景色によって罫線が見えなくなることがあります。このような場合は、空白セルにアポストロフィのみを入力して空白文字列を作成し、背景色を指定してください。
  • PlotString 関数を含むセルにフォーマットを指定すると、そのセルだけでなくプロットされるテキスト文字列にもフォント、スタイル、サイズの設定が適用されます。

ヒント: [フォーマット] ツールバーの [フォント] ボックス、[フォントサイズ] ボックス、[太字] ボタン、[斜体] ボタン、[背景色] ボタン、[前景色] ボタン、[フォントサイズの拡大] ボタン、[フォントサイズの縮小] ボタンを使用すると、[セルのフォーマット] ダイアログを開かなくても、テキストのフォーマットを変更することができます。

[配置] タブ

[配置] タブをクリックして、セル内のデータの横位置を、左詰め、中央揃え、右詰めに設定します。また、データの縦位置を、上詰め、中央揃え、下詰めに設定します。デフォルトの配置に戻すには標準を選択します。

ヒント: セルの配置は、[フォーマット] ツールバーの [左揃え] ボタン [image] 、[中央揃え] ボタン [image] 、[右揃え] ボタン [image] で設定することもできます。

[保護] タブ

セルの保護を設定するには、[保護] タブをクリックします。

[ロック] チェックボックスをオンにして、1 つのセルまたはセル範囲をロックします。セルまたはセル範囲を保護すると、セル内の式を変更できなくなります。セルのフォーマットを変更することはできます。ロックを有効にするには、ジョブを保護する必要があります。ジョブを保護するには、[ファイル] メニューの [ジョブの保護] を選択します。

[パスワード] フィールドにパスワードを入力し、[パスワードの再確認] フィールドに再度入力して、セルの数式を非表示にします。

注:
  • セルがロックされていて、ジョブが保護されていないときには、スプレッドシートの左上隅に黄色のロックアイコン [image] が表示されます。ロック済みのセルを含むジョブが保護されたときには、同じ位置に赤いロックアイコン [image] が表示されます。
  • ライセンスパスワードを入力すると、セルの数式は非表示になり、[ライセンス] ダイアログを使用してビジョンシステムにライセンスが追加されるまで、セルは実行できなくなります。
    • ライセンスが追加されると、セルが実行され、結果が表示されます。セルの編集アクセス権は、[ライセンス] ダイアログでパスワードを入力することで取得できます。
    • [保護] タブでパスワードを再入力するか、ビジョンシステムから切断されると、アクセス権は無効になります。
    • ライセンスは、In-Sight License Generator を使用して生成されます。
    • ライセンス付与の手順は、[ライセンス] ダイアログのトピックで詳しく説明しています。

[グラフィックス] タブ

[グラフィックス] タブをクリックして、セルのグラフィックスの線幅とグラフィックスオーバレイテキストのスケールを設定します。このフォーマットは、対話型グラフィックスまたは結果グラフィックスが関連付けられている関数を含むセルにのみ適用されます。

  • [線の幅]: セルのグラフィックスの線幅をピクセル単位で設定します。フォーマットされたセルに関連付けられたグラフィックスはすべて、同じ線幅になります(1 ～ 15、デフォルト = 1)
  • [テキストサイズ]: グラフィックスオーバレイテキストのスケールを設定します。フォーマットされたセルに関連付けられたテキストはすべて、同じスケールになります(デフォルト = [標準])。
    • [標準]: [ジョブの表示] ツールバーで定義されたスケール設定が、フォーマットされたセルで使用されます。
    • [画像サイズに合わせる]: 画像を拡大または縮小すると、グラフィックスオーバレイテキストは画像に合わせてスケーリングされます。
    • [縮小のみ]: 画像を縮小すると、グラフィックスオーバレイテキストのスケールは小さくなります。画像を拡大し、グラフィックスオーバレイテキストがデフォルトのフォントサイズ (9 ポイント) より小さくなると、グラフィックスオーバレイテキストのスケールは、デフォルトのフォントサイズになるまで大きくなります。
    • [固定]: グラフィックスオーバレイテキストのサイズは、画像の倍率レベルに関係なく固定されています。
注:
  • [テキストサイズ] で [標準] が選択されている場合、スケールの設定はジョブファイルには保存されません。
  • [テキストサイズ] で [画像サイズに合わせる]、[縮小のみ]、または [固定] が選択されている場合、この設定は [ジョブの表示] ツールバーで定義された設定よりも優先され、ジョブファイルに保存されます。


[行の高さ] ダイアログ

[フォーマット] メニュー → [行]

In-Sight Explorer GUI リファレンス

スプレッドシートの 1 つ以上の行の幅を変更するには:

  1. 1 つ以上の行をハイライト表示します。
  2. [フォーマット] メニューで、[行] をクリックします。
  3. [行の高さ] をクリックします。または、[フォーマット] ツールバーで [Format Row Height (行高さのフォーマット)] [image] ボタンをクリックします。

  4. 適切な行高さを入力し、[OK] をクリックします。

注: 行高さは、1 ～ 2000 の間の任意の整数にすることができます。デフォルトの行高さは 20 です。

ヒント: 1 行の高さは、行文字の右側の区切り線をクリックして適切な高さになるまでドラッグすることによっても調整できます。


[列の幅] ダイアログ

[フォーマット] メニュー → [列]

In-Sight Explorer GUI リファレンス

スプレッドシートの 1 つ以上の列の幅を変更するには:

  1. 1 つ以上の列をハイライト表示します。
  2. [フォーマット] メニューで、[列] をクリックします。
  3. [列の幅] をクリックします。または、[フォーマット][Format Column Width (列幅のフォーマット)] ツールバーで [image] ボタンをクリックします。

  4. 適切な列幅を入力し、[OK] をクリックします。

注: 列幅は、1 ～ 2000 の間の任意の整数にすることができます。デフォルトの列幅は 64 です。

ヒント: 1 つの列の幅は、列文字の右側の区切り線をクリックして適切な幅になるまでドラッグすることによっても調整できます。


[記録/再生のオプション] ダイアログ

[画像] メニュー

In-Sight ExplorerGUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの記録/再生の設定を行うことができます。このダイアログで設定を行った後、取り込んだ画像の記録と再生を行うことができます。画像は、PC 上の指定した記録フォルダに保存されます。

注:
  • [オプション] ダイアログの [記録] パネルは、[記録] オプションを初めて実行する前に、その初期値を設定するために使用します。
  • [記録] オプションを初めて実行した後、[オプション] ダイアログの [記録] パネルで行った変更は、アクティブなビジョンシステムまたはエミュレータの [記録/再生のオプション] ダイアログから [初期値に戻す] を選択しない限り、[記録/再生のオプション] ダイアログには反映されません。
  • In-Sight カラービジョンシステムでは、1/4 解像度の画像は記録できません。カラービジョンシステムの [記録/再生のオプション] ダイアログで 1/4 解像度の画像を記録するように設定した場合、実際に記録される画像は 1/2 解像度の画像です。
  • [記録/再生のオプション] ダイアログボックスは、ビジョンシステムに装着された SD カードをサポートしません。

[記録/再生のオプション] ダイアログを表示するには

次のいずれかの操作を行います。

  • [画像] メニューで、[記録/再生のオプション] をクリックします。
  • EasyBuilder ツールバーで、[記録/再生のオプション] ボタン [image] をクリックします。
  • CTRL+T キーを押します。
  • [画像の設定] 設定ペインで [PCから画像をロード] をクリックします。
  • フィルムストリップの設定ペインで [再生] をクリックします。

[記録] タブの設定項目

  • [記録フォルダ]: 画像を保存するためのディレクトリを指定します。

注: 記録フォルダのサブディレクトリとして、Good フォルダと Bad フォルダが作成されます。

  • [画像カウント]: [記録フォルダにすべての画像を記録する] を選択している場合、[画像カウント] には、記録フォルダに保存されている画像の数が表示されます。[記録フォルダにすべての画像を記録する] が選択されていない場合、[画像カウント] には、Good/Bad フォルダに保存されている画像の数が表示されます。
  • [ファイル名のフォーマット]: 記録画像のファイル名のフォーマットとファイルの種類。
    • [接頭語]: 記録画像のファイル名の接頭辞。
    • [フォーマット]: 記録画像のファイル名のフォーマット。[フォーマット] オプションは、[Index] と [DateTime] です。
    • [ファイル形式]: 記録画像のファイルの種類。選択できるファイルの種類は、[ビットマップファイル (*.bmp)] と [JPEG ファイル (*.jpg)] です。
    • 例: [フォーマット] および [ファイル形式] ドロップダウンリストで選択した [ファイル名のフォーマット] オプションに基づいて、記録画像ファイルの命名規則の例が表示されます。
  • [最大保存数]: 記録フォルダに保存する画像の最大数。(1 ～ 10,000、デフォルト 10,000)
  • [画像の解像度]: 画像の記録時に使用する In-Sight ビジョンシステムの解像度を指定します。記録が完了すると、ビジョンシステムの解像度は [画像の設定] ダイアログで設定した元の設定に戻ります。保存する画像の解像度として指定できるのは、フルアクセス、ハーフ (1/2)、クォーター (1/4) です。デフォルトの解像度はフルアクセスです。

注:
  • ビジョンシステムがフル解像度をサポートしていない場合、このオプションをドロップダウンリストから選択することはできません。
  • この設定は、ビジョンシステムがオンラインのときにのみ使用できます。ビジョンシステムがオフラインのときに記録された画像はすべて、フル解像度で記録されます。

  • [ビット深度]: カラー画像を記録するときのビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [24 ビット])。

    注:

    • このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。
    • JPEG (*.jpg) 画像は常に 24 ビット深度で記録されます。16 ビットで記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。
  • [記録フォルダのクリア]: [記録された画像の削除] Closed ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

注: 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [Good/Bad フォルダのクリア]: [記録された画像の削除] Closed ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

注: 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [PASS/FAIL の振り分け]: ジョブの全体的な成功/失敗ステータスに基づいて、画像を特定のフォルダに振り分けます。
    • [記録フォルダにすべての画像を記録する]: すべての画像を記録フォルダに記録します。成功/失敗の振り分けは無効になります。
    • [PASS 画像を Good フォルダに記録する]: 成功 (PASS) した画像を Good フォルダに記録します。
    • [FAIL 画像を Bad フォルダに記録する]: 失敗 (FAIL) した画像を Bad フォルダに記録します。
    • [PASS/FAIL に応じて画像を Good/Bad フォルダに振り分ける]: 成功 (PASS) した画像を Good フォルダに、失敗 (FAIL) した画像を Bad フォルダに振り分け、記録します。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。

[再生] タブの設定項目

  • [再生フォルダ]: 再生する画像の保存されているディレクトリを指定します。
  • [画像カウント]: 再生フォルダに保存されている画像の数を示します。
  • [再生モード]: [画像] メニューまたは EasyBuilder ツールバーの [再生] を選択したときの画像の表示方法を決めます。画像はアルファベット順に再生され、次に番号順に再生されます。画像の再生を一時停止した後に [再生] を選択する場合は、[再生] を選択すると、最後に表示された画像から再生が再開されます。[画像] メニューから [最初の画像] を選択するか、[記録/再生] ツールバーの [最初の画像] を選択すると、始めから再生が開始されます。

注: ビジョンシステムがオンラインモードのときに画像の再生ができるようにするには、[画像の設定] ステップの [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。

  • [連続]: 再生フォルダに保存されている画像を連続再生します。
  • [一巡]: 再生フォルダに保存されている画像を 1 回だけ再生します。
  • [一時停止時間]: ある画像を再生してから次の画像を再生するまでの時間遅延 (0 ～ 60 秒、デフォルト = 0.5)。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。

スプレッドシートビュー

[記録/再生のオプション] ダイアログでは、個々のビジョンシステムやエミュレータの記録/再生の設定を行うことができます。このダイアログで設定を行った後、取り込んだ画像の記録と再生を行うことができます。画像は、PC 上の指定した記録フォルダに保存されます。

注:
  • [オプション] ダイアログの [記録] パネルは、[記録] オプションを初めて実行する前に、その初期値を設定するために使用します。
  • [記録] オプションを初めて実行した後、[オプション] ダイアログの [記録] パネルで行った変更は、アクティブなビジョンシステムまたはエミュレータの [記録/再生のオプション] ダイアログから [初期値に戻す] を選択しない限り、[記録/再生のオプション] ダイアログには反映されません。
  • [記録/再生のオプション] ダイアログボックスは、ビジョンシステムに装着された SD カードをサポートしません。

[記録/再生のオプション] ダイアログを表示するには

  • [画像] メニューで、[記録/再生のオプション] をクリックします (または、[記録/再生] ツールバーの [記録/再生のオプション] ボタン [image] をクリックするか、CTRL+T キーを押します)。

[記録] タブの設定項目

  • [記録フォルダ]: 画像を保存するためのディレクトリを指定します。

注: 記録フォルダのサブディレクトリとして、Good フォルダと Bad フォルダが作成されます。

  • [画像カウント]: [監視セルを使用しない (記録フォルダにすべて記録する)] を選択している場合、[画像カウント] には、記録フォルダに保存されている画像の数が表示されます。それ以外の振り分け方法を選択している場合、[画像カウント] には、Good/Bad フォルダに保存されている画像の数が表示されます。
  • [ファイル名のフォーマット]: 記録画像のファイル名のフォーマットとファイルの種類。
    • [接頭語]: 記録画像のファイル名の接頭辞。
    • [フォーマット]: 記録画像のファイル名のフォーマット。[フォーマット] オプションは、[Index] と [DateTime] です。
    • [ファイル形式]: 記録画像のファイルの種類。選択できるファイルの種類は、[ビットマップファイル (*.bmp)] と [JPEG ファイル (*.jpg)] です。
    • 例: [フォーマット] および [ファイル形式] ドロップダウンリストで選択した [ファイル名のフォーマット] オプションに基づいて、記録画像ファイルの命名規則の例が表示されます。
  • [最大保存数]: 記録フォルダに保存する画像の最大数。(1 ～ 10,000、デフォルト 10,000)
  • [画像の解像度]: 画像の記録時に使用する In-Sight ビジョンシステムの解像度を指定します。記録が完了すると、ビジョンシステムの解像度は [画像の設定] ダイアログで設定した元の設定に戻ります。保存する画像の解像度として指定できるのは、フルアクセス、ハーフ (1/2)、クォーター (1/4) です。デフォルトの解像度はフルアクセスです。

注: ビジョンシステムがフル解像度をサポートしていない場合、このオプションをドロップダウンリストから選択することはできません。

  • [ビット深度]: カラー画像を記録するときのビット深度を指定します ([16 ビット] または [24 ビット]。デフォルト = [24 ビット])。

    注:

    • このオプションは、カラー In-Sight ビジョンシステムでのみ使用可能になります。
    • JPEG (*.jpg) 画像は常に 24 ビット深度で記録されます。16 ビットで記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。
  • [記録フォルダのクリア]: [記録された画像の削除] Closed ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

注: 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [Good/Bad フォルダのクリア]: [記録された画像の削除] Closed ダイアログが開かれます。このダイアログでは、記録フォルダ、Good フォルダ、および Bad フォルダから画像を削除することができます。

注: 記録フォルダと再生フォルダが同じ場合、記録フォルダを選択すると、再生フォルダの画像もすべて削除されます。

  • [監視セルによる振り分け]: 監視セルの値に基づいて、画像を特定のフォルダに保存します。

    注:In-Sight で類似の効果を持つ監視セルが 3 つあります ([ジョブの PASS/FAIL] セル、[フィルムストリップ] 監視セル および [記録/再生] の監視セル)。これらの 3 つの監視セルを個々に設定し、異なる機能を制御することができます。

  • [監視セルを使用しない (記録フォルダにすべて記録する)]: すべての画像を記録フォルダに記録します。[監視セル] は無効になります。
  • [監視セルの値が 0 でない場合、Good フォルダに記録する]: 画像取り込みの際に、監視セルがゼロ以外の数値を含んでいた場合、画像は Good フォルダに保存されます。画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいた場合、画像は記録されません。
  • [監視セルの値が 0 または #ERR の場合、Bad フォルダに記録]: 画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいた場合、画像は Bad フォルダに保存されます。画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいなかった場合、画像は記録されません。
  • [監視セルの値に応じて Good/Bad フォルダに振り分ける]: 画像取り込みの際に、監視セルがゼロ以外の数値を含んでいた場合、画像は Good フォルダに保存されます。画像取り込みの際に、監視セルがゼロまたは #ERR を含んでいた場合、画像は Bad フォルダに保存されます。
  • [監視セル]: 監視対象のセルを示します。
  • [セルの選択]: このボタンをクリックするとセル選択モードに切り替わり、画像を Good または Bad フォルダに保存するかどうかを判断するための監視セルを参照することができます。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。

[再生] タブの設定項目

  • [再生フォルダ]: 再生する画像の保存されているディレクトリを指定します。
  • [画像カウント]: 再生フォルダに保存されている画像の数を示します。
  • [再生モード]: [画像] メニューまたは [記録/再生] ツールバーの [再生] を選択したときの画像の表示方法を決めます。画像はアルファベット順に再生され、次に番号順に再生されます。画像の再生を一時停止した後に [再生] を選択する場合は、[再生] を選択すると、最後に表示された画像から再生が再開されます。[画像] メニューから [最初の画像] を選択するか、[記録/再生] ツールバーの [最初の画像] を選択すると、始めから再生が開始されます。

注: ビジョンシステムがオンラインモードのときに画像の再生ができるようにするには、AcquireImage 関数の [トリガ] パラメータが [外部]、[手動]、または [ネットワーク] に設定されている必要があります。

  • [連続]: 再生フォルダに保存されている画像を連続再生します。
  • [一巡]: 再生フォルダに保存されている画像を 1 回だけ再生します。
  • [一時停止時間]: ある画像を再生してから次の画像を再生するまでの時間遅延 (0 ～ 60 秒、デフォルト = 0.5)。
  • [記録/再生の前に、常にこのダイアログを表示する]: このチェックボックスをオンにすると、画像を記録または再生する前に [記録/再生のオプション] ダイアログが開きます。
  • [初期値に戻す]: [記録フォルダ]、[最大保存数]、[画像の解像度]、および [ファイル名のフォーマット] 設定を、[オプション] ダイアログの [記録] パネルの現在の設定に一致するようにリセットします。[記録] タブと [再生] タブの残りの設定は、デフォルトに戻ります。
Version: 5.6.0


[オーバレイの透明度] ダイアログ

[画像] メニュー

In-Sight Explorer GUI リファレンス

[オーバレイの透明度] ダイアログでは、画像やグラフィックスに対するスプレッドシートオーバーレイの不透明度を調整することができます。この値を 0 に設定すると、スプレッドシートオーバーレイによって画像やグラフィックスが完全に見えなくなります。[オーバーレイの透明度] の値を上げると、画像やグラフィックスがスプレッドシートを通してより鮮明に表示されるようになります。[オーバーレイの透明度] は 0% ～ 100% の任意の値に設定できます。

[オーバーレイの透明度] ダイアログを表示するには

  • [画像] メニューで、[オーバーレイの透明度] をクリックします。

ヒント: オーバーレイの透明度の値を入力したら、TAB を押してスプレッドシートでの [オーバーレイの透明度] 設定をプレビューします。


[ジョブサーバの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[ジョブサーバの設定] ダイアログを使用して、In-Sight ビジョンシステムの In-Sight ジョブファイルをホストする FTP サーバを設定します。これにより、PLC やロボットコントローラなどの別のデバイスでは、LF および TF ネイティブモードコマンドを介し、場所を指定することなくジョブを変更することができます。

注:
  • [ジョブサーバの設定] ダイアログは FileZilla FTP サーバソフトウェアでテストされています。
  • 古いバージョンの In-Sight Explorer (In-Sight Explorer 4.9.1 以前) からリモートジョブサーバを使用するように設定されているビジョンシステムに接続する場合、デフォルトでは、In-Sight Explorer がそのビジョンシステムのファイルシステムに設定されます。VisionView オペレータインタフェースパネル経由で接続する場合にも、同様に設定されます。
  • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  • ジョブサーバに保存されているジョブの場合、ジョブのネイティブモードコマンド (Set Job、Get Job、Delete Job、Store Job、Write Job) は使用できません。

[ジョブサーバの設定] ダイアログを表示するには

  • [センサ] メニューで、[ジョブサーバの設定] をクリックします。

ジョブサーバの使用

ジョブサーバの設定

  1. [ジョブサーバの設定] ダイアログで、[Enable Job Server (ジョブサーバの有効化)] チェックボックスをオンにして、[サーバ]、[サーバポート]、[ユーザ名]、[パスワード]、[ディレクトリ] の各フィールドを有効にします。

  2. FTP サーバの [サーバ]、[サーバポート]、[ユーザ名]、[パスワード] を入力します。必要に応じて、ジョブを保存またはロードする場合の FTP サーバにおけるディレクトリ名 (または、ディレクトリパス) を入力します。

    注:
    • ユーザには、FTP サーバへの書き込み/読み取り許可が必要です。
    • In-Sight エミュレータがサーバとして指定されている場合:
      • ジョブは Emulator ディレクトリ (C:\ProgramData\Cognex\Emulators\x.x.x) との間で保存またはロードされます。詳細については、[オプション] ダイアログトピック ([エミュレーション] パネル) を参照してください。
      • [ディレクトリ] フィールドはサポートされません。
    • [ユーザ名] は最大 63 文字で、大文字と小文字の区別があります。
    • [パスワード] は最大 127 文字で、大文字と小文字の区別があります。
    • FTP パス全体 (ftp://Username:Password@Server:PortNumber/Directory) は最大 208 文字です。
  3. [OK] をクリックします。In-Sight ビジョンシステムは、ジョブのロードと保存のためにジョブサーバに接続されます。
注:
  • ジョブサーバを使用したジョブの手動保存またはロードの詳細については、「[保存] および [開く] ダイアログ」のトピックを参照してください。
  • 起動時にジョブサーバからジョブを自動的にロードする方法の詳細については、「[スタートアップ] ダイアログ」のトピックを参照してください。

ジョブサーバの無効化

  1. [ジョブサーバの設定] ダイアログで、[Enable Job Server (ジョブサーバの有効化)] チェックボックスをオフにし、[サーバ]、[サーバポート]、[ユーザ名]、[パスワード]、[ディレクトリ] の各フィールドを無効にします。
  2. [OK] をクリックします。これで、In-Sight ビジョンシステムがジョブサーバから切断されます。

ネイティブモードコマンドによるジョブの保存またはロード

ジョブサーバが有効になると、In-Sight ビジョンシステムでは、ジョブを保存またはロードする場合、TF または LF ネイティブモードコマンドが発行されると自動的にそのジョブサーバを使用します。例えば、ジョブサーバを有効にした後に LFProduct.job が発行されると、ジョブサーバに保存されている LFProduct.job ファイルがビジョンシステムにロードされます。

注: TF または LF のネイティブモードコマンドの詳細については、「Store File」および「Load File」のトピックを参照してください。

関連項目

[保存] および [開く] ダイアログ

[スタートアップ] ダイアログ

Store File

Load File

Version: 5.6.0


[シリアルポートの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[シリアルポートの設定] ダイアログでは、アクティブな In-Sight ビジョンシステムのシリアル通信環境を設定します。入力文字列は、ReadSerial 関数を使用してシリアルポート経由でスプレッドシートに読み込まれます。出力文字列は、WriteSerial 関数を使用してシリアルポート経由で、スプレッドシートから送信されます。

注:
  • シリアルデータを送受信するためには、ビジョンシステムがオンラインである必要があります。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

シリアルポート設定を行うには

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。

  2. I/O モジュールに接続されている場合は、[I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。[OK] ボタンをクリックして [I/O モジュールの設定] ダイアログを閉じ、[シリアルポートの設定] ダイアログに戻ります。

    注:
    • ビジョンシステムと I/O モジュール間の最初の接続に成功すると、センサに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されます。
    • CIO-MICRO、CIO-MICRO-CC、または CIO-WENET が、選択された I/O モジュールである場合に、[OK] ボタンをクリックすると、ビジョンシステムは指定の IP アドレスを使って、モジュールとの EtherNet/IP 通信を確立しようとします。IP アドレスがネットワークに存在せず、EtherNet/IP がモジュールで有効になっていない場合、または別のデバイスがすでにモジュールとの EtherNet/IP 接続を確立している場合は、エラーメッセージが表示されます。

  3. シリアル設定を行います。次の表に、設定可能な設定項目のリストを示します。

    特徴 直接接続 I/O または CIO-1350 CIO-1400 CIO-14501 CIO-14601 CIO-MICRO CIO-MICRO-CC CIO-WENET1

    ビット/秒2

    4800

    9600

    19200

    38400

    57600

    115200

    2400

    4800

    9600

    19200

    38400

    57600

    115200

    1200

    2400

    4800

    9600

    19200

    38400

    57600

    115200

    1200

    2400

    4800

    9600

    19200

    38400

    57600

    115200

    4800

    9600

    19200

    38400

    57600

    115200

    4800

    9600

    19200

    38400

    57600

    115200

    無効

    DataBits

    7、8

    8

    7、8

    7、8

    7、8

    7、8

    無効

    StopBits

    1、2

    1

    1、2

    1、2

    1、2

    1、2

    無効

    Parity

    なし

    偶数

    奇数

    なし

    偶数

    奇数

    なし

    偶数

    奇数

    なし

    偶数

    奇数

    なし

    偶数

    奇数

    なし

    偶数

    奇数

    無効

    Handshake

    なし

    Xon/Xoff

    ハードウェア

    なし

    Xon/Xoff

    ハードウェア

    なし

    Xon/Xoff

    ハードウェア

    なし

    Xon/Xoff

    ハードウェア

    なし

    Xon/Xoff

    ハードウェア

    なし

    Xon/Xoff

    ハードウェア

    無効

    モード

    Text
    Native

    DeviceNet

    Motoman

    Kuka

    未使用

    Text
    Native

    DeviceNet

    Motoman

    Kuka

    未使用

    Text
    Native

    DeviceNet

    Motoman

    Kuka

    未使用

    Text
    Native

    DeviceNet

    Motoman

    Kuka

    未使用

    Text
    Native

    DeviceNet

    Motoman

    Kuka

    未使用

    Text
    Native

    DeviceNet

    Motoman

    Kuka

    未使用

    無効

    1CIO-1450、CIO-1460 および CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。

    2DeviceNet は最大 57600 ビット/秒をサポートします。
  4. [OK] ボタンをクリックします。

[シリアルポートの設定] ダイアログの設定項目

  • [ビット　/　秒]: 1200、2400、4800、9600、19200、38400、57600、または 115200。

    注:DeviceNet は最大 57600 ビット/秒をサポートします。

  • [データビット]: 7 または 8。
  • [ストップビット]: 1 または 2。
  • [パリティ]: なし、偶数、または奇数。

  • [フロー制御]: なし、Xon/Xoff、またはハードウェア。

    注:
    • 構成に関係なく、[フロー制御] ドロップダウンメニューは常に有効です。ほとんどの In-Sight ビジョンシステムでは、ビジョンシステムが I/O モジュールに接続されている場合、ハードウェアフロー制御のみをサポートします。ハードウェアフロー制御を有効にするために必要な物理接続の条件については、ご使用のビジョンシステムのインストールマニュアルを参照してください。
    • 大量のデータを送信する場合は、[フロー制御] パラメータを [Xon/Xoff] に設定し、フロー制御を使用してデータが欠落しないようにすることを推奨します。

  • [モード]: 使用するシリアルプロトコルを設定します。

    モード

    説明

    Text

    標準の ASCII プロトコルでテキスト文字列の送受信を行います。

    Native

    カスタマイズした ASCII プロトコルで In-Sight をシリアルデバイスからリモート制御します。

    DeviceNet

    デバイスネット通信をするためのプロトコル。

    注: DeviceNet の設定には、サードパーティの RS-232 デバイスネットゲートウェイアダプタが必要です。この設定は従来のインストール環境で使用できます。ただし、最新のアプリケーションで使用する場合は、RS-232 デバイスネットゲートウェイコンバータを完全にテストして、そのアプリケーションでも使用できることを確認してください。

    Motoman

    DCI モードで動作している MRC、MRC-II、および XRC ロボットコントローラなどの Motoman と通信するためのプロトコル。

    Kuka

    Kuka KR C2 および KR C2 Edition 2005 ロボットコントローラと通信するためのプロトコル。

    未使用

    シリアルポートを閉じるので、コマンドもデータも送受信できません。
  • 詳細: [モード] が [DeviceNet]、[Native]、または [Text] に設定されている場合、ダイアログの [詳細設定] 部分で、選択したモードに固有の入力/出力終端記号およびパケットデータサイズを設定することができます。

Text モードの詳細設定

Text モードの詳細設定では、テキストモードのシリアル通信に使用する終端記号を定義します。これらの詳細設定は、[モード] が [Text] に設定されているときのみ使用できます。

  • [固定長の入力]: イベントをトリガする前に固定長の文字列を読み取ります。
  • [入力終端記号]: In-Sight によって入力文字列の最後の文字として認識される ASCII 値。デフォルトは 13 (キャリッジリターン) です。[固定長の入力] をオンにすると、[入力終端記号] は無効になります。
  • [出力終端記号]: In-Sight によって各出力文字列に追加され、送信文字列の終わりを示す ASCII 値。デフォルトは -1 です。-1 は「CRLF」 (キャリッジリターン/ラインフィード)、0 は「終端記号なし」を指定します。

Native モードの詳細設定

Native モードの詳細設定では、ネイティブモードシリアル通信の終端記号を設定します。これらの詳細設定は、[モード] が [Native] に設定されているときのみ使用できます。

  • [固定長の入力]: イベントをトリガする前に固定長の文字列を読み取ります。
  • [入力終端記号]: In-Sight によって入力文字列の最後の文字として認識される ASCII 値。デフォルトは 13 (キャリッジリターン) です。[固定長の入力] をオンにすると、[入力終端記号] は無効になります。
  • [出力終端記号]: In-Sight によって各出力文字列に追加され、送信文字列の終わりを示す ASCII 値。デフォルトは -1 です。-1 は「CRLF」 (キャリッジリターン/ラインフィード)、0 は「終端記号なし」を指定します。

DeviceNet モードの詳細設定

DeviceNet モードの詳細設定では、オプションのデバイスネットインタフェースモジュールを使用して、In-Sight ビジョンシステムにデバイスネット接続する場合のパケットサイズを設定します。これらの詳細設定は、[モード] が [DeviceNet] に設定されているときのみ使用できます。

  • [入力パケットサイズ]: デバイスネットインタフェースモジュールを通じて受信する予想パケットサイズをバイト単位で設定します。この設定は RS-232 デバイスネットゲートウェイ設定の MaxWidth 値を満たす必要があります。
  • [出力パケットサイズ]: デバイスネットインタフェースモジュールを通じて送信するパケットサイズをバイト単位で設定します。この設定は RS-232 デバイスネットゲートウェイ設定の Transmit Width 値を満たす必要があります。
  • [第一バイトでトリガをかける]: 先頭のバイトを受信したときに画像取り込みのトリガをかけます。AcquireImage 関数のプロパティシートで、トリガパラメータが外部トリガに設定されている必要があります。

注: [第一バイトでトリガをかける] が有効な場合、In-Sight ビジョンシステムがトリガされると、前の画像が表示され、以前のスプレッドシートの更新時に取得されたデータがセルデータとして表示されることがあります。

関連項目

  • In-Sight 70xx ～ 74xx シリーズのビジョンシステムでのシリアル通信の有効化
  • [I/O モジュールの設定] ダイアログ
  • シリアル I/O 関数
  • ネイティブモードでのシリアル通信
  • Motoman との通信
  • Kuka との通信
Version: 5.6.0


[CC-Link 設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[CC-Link 設定] ダイアログでは、CIO-MICRO-CC I/O モジュールを使用した CC-Link 通信用にアクティブな In-Sight ビジョンシステムを設定します。入力データは、ReadCCLinkBitBuffer 関数と ReadCCLinkWordBuffer 関数を使用してスプレッドシートに読み込まれます。出力データは、WriteCCLinkBitBuffer 関数と WriteCCLinkWordBuffer 関数を使用してスプレッドシートから CC-Link ネットワークに書き込まれます。

注:
  • CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CC-Link の配線構成については、『In-Sight® CIO-MICRO & CIO-MICRO-CC I/O モジュールインストールガイド』を参照してください。

[CC-Link 設定] ダイアログを表示するには:

  1. [センサ] メニューで、[CC-Link 設定] をクリックします。

  2. [I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。[OK] ボタンを押して [I/O モジュールの設定] ダイアログを閉じ、[CC-Link 設定] ダイアログに戻ります。

    注:
    • ビジョンシステムと I/O モジュール間の最初の接続に成功すると、センサに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されます。
    • CIO-MICRO、CIO-MICRO-CC、または CIO-WENET が、選択された I/O モジュールである場合に、[OK] ボタンをクリックすると、ビジョンシステムは指定の IP アドレスを使って、モジュールとの EtherNet/IP 通信を確立しようとします。IP アドレスがネットワークに存在せず、EtherNet/IP がモジュールで有効になっていない場合、または別のデバイスがすでにモジュールとの EtherNet/IP 接続を確立している場合は、エラーメッセージが表示されます。
  3. CC-Link を設定します。

[CC-Link 設定] ダイアログの設定項目

  • バージョン:V1、V2。
  • [ビット　/　秒]: 10M、5M、2.5M、625K、156K。
  • [Station Number (ステーション番号): 1 ～ 64
  • Number of Stations (ステーション数): 1 ～ 41 に設定する場合、入力と出力は 16 ビットです。2 に設定する場合、入力と出力は 48 ビットです。3 に設定する場合、入力と出力は 80 ビットです。4 に設定する場合、入力と出力は 112 ビットです。
  • Extension Cycles (拡張サイクル): 1X (無効)、2X、4X、8X。

関連項目

[I/O モジュールの設定] ダイアログ (CIO-MICRO、CIO-MICRO-CC および CIO-WENET)

ReadCCLinkBitBuffer 関数

WriteCCLinkBitBuffer 関数

ReadCCLinkWordBuffer 関数

WriteCCLinkWordBuffer 関数

Version: 5.6.0


[ディスクリート I/O の設定] ダイアログ

[センサ] メニュー → [ディスクリート I/O の設定]

In-Sight Explorer GUI リファレンス
  • [ディスクリート I/O の設定] ダイアログについて
  • ディスクリート I/O ラインの設定
  • 関連項目

[ディスクリート I/O の設定] ダイアログについて

[ディスクリート I/O 設定] ダイアログでは、In-Sight ビジョンシステムのデジタル入出力ラインを設定します。

  • ディスクリート入力信号は、ReadDiscrete 関数を使用してスプレッドシートに読み込まれます。
  • ディスクリート出力信号は、WriteDiscrete 関数または Waveform 関数、WriteWaveformPulseTrain および WriteWaveformClocked を使用して、スプレッドシートから書き出すことができます。

次のとおり、In-Sight ビジョンシステムごとに直接接続 (組み込み) 入力と出力の数は異なります。

In-Sight ビジョンシステム 直接 (組み込み) 入力1 直接接続 (組み込み) 出力
In-Sight Micro 1000 シリーズ なし

高速出力×2
ユーザ設定可能 LED×2 (緑×1、赤×1)
In-Sight 5000 シリーズ なし

高速出力×2
ユーザ設定可能 LED×2 (緑×1、赤×1)
In-Sight 70xx ～ 74xx シリーズ 汎用入力×3

高速出力×4
ユーザ設定可能 LED×2 (緑×1、赤×1)
In-Sight 76xx ～ 79xx シリーズ 汎用入力×3 (最大)2

高速出力×最大 42
ユーザ設定可能 LED×2 (緑×1 または赤×1)
In-Sight 8000 シリーズ なし

高速出力×2
ユーザ設定可能 LED×2 (緑×1、赤×1)

1In-Sight ビジョンシステムには、画像取り込み専用のトリガがビジョンシステム上に 1 つあります。詳細については、AcquireImage 関数のトピックのトリガパラメータを参照してください。また、In-Sight Explorer ソフトウェアに収録されているビジョンシステムのインストールガイドまたはリファレンスガイドも参照してください。

2ブレークアウトケーブル接続時、ビジョンシステムは双方向高速出力および汎用入力を、HS OUT 2 / IN 2 および HS OUT 3 / IN 3 で使用することができます。これらのラインはデフォルトで出力に設定されています。

I/O モジュールを使用してディスクリート入力および出力を追加できます。I/O モジュールのディスクリート入出力数は次の通りです。

I/O モジュール | サポート対象の In-Sight ビジョンシステム | ディスクリート入力ライン | ディスクリート出力ライン
CIO-1400 | In-Sight 5000 シリーズ (5604 を除く)、In-Sight 76xx ～ 79xx シリーズ1 | 汎用入力×7 | 汎用出力×6
CIO-MICRO23 | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 70xx ～ 79xx シリーズ、In-Sight Micro 8000 シリーズ | 汎用入力× 8 | 汎用出力× 8
CIO-MICRO-CC34 | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ (5705、5705C、5715 を除く)、In-Sight 70xx ～ 74xx シリーズ | 汎用入力× 8 | 汎用出力× 8
CIO-14505 | In-Sight 5000 シリーズ (5604、5705、5705C および 5715 を除く) | 汎用入力× 8 | 汎用出力× 8
CIO-14605 | In-Sight 5000 シリーズ (5604、5605、5705、5705C および 5715 を除く) | 汎用入力× 8 | 汎用出力× 8
CIO-WENET5 | In-Sight Micro 1000 シリーズ | 汎用入力× 8 | 汎用出力× 8

1 CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以上を使用している In-Sight 76xx ～ 79xx シリーズのビジョンシステムをサポートしています。このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。

2CIO-MICRO I/O モジュールは、ファームウェア 5.3.0 以上を搭載した In-Sight 5705、5705C、5715、In-Sight Micro 8000 シリーズのビジョンシステムをサポートします。

3CIO-MICRO-CC I/O モジュールは、In-Sight 76xx ～ 79xx シリーズのビジョンシステムをサポートしていません。

4CIO-MICRO および CIO-MICRO-CC I/O モジュールがサポートしているのは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズと 5400 シリーズのビジョンシステムです。モデルはタイプ番号 (821-xxxx-xx) で特定できます。このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。モデル、およびタイプ番号と不揮発性フラッシュメモリの一覧については、ここをクリックしてください。

5CIO-1450、CIO-1460 および CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。

注:

  • In-Sight 70xx ～ 74xx シリーズのビジョンシステムは、ブレークアウトケーブルと、CIO-MICRO または CIO-MICRO-CC I/O モジュールとの同時接続をサポートしています。
  • In-Sight 76xx ～ 79xx シリーズのビジョンシステムは、ブレークアウトケーブルと CIO-MICRO I/O モジュールとの同時接続をサポートしています。
  • In-Sight 7000 シリーズ (70xx ～ 79xx シリーズ) のビジョンシステムの内蔵入力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • In-Sight 70xx ～ 74xx シリーズの高速出力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • 外部ストロボデバイスを In-Sight 70xx ～ 74xx シリーズのビジョンシステムの外部照明ケーブルに接続する場合は、[照明の設定] ダイアログを使用して外部照明の設定を行います。
  • 外部ストロボデバイスを In-Sight 76xx ～ 79xx シリーズのビジョンシステムの外部照明ケーブルに接続する場合、または照明アクセサリをビジョンシステムのフェースプレートに接続する場合は、[照明の設定] ダイアログを使用して照明の設定を行います。
  • In-Sight ビジョンシステムを使って、Opto 22、Wago、Sixnet などの他のベンダーが提供する標準イーサネット I/O ソリューションと通信して、実質的に無制限の数の I/O チャネルを提供することもできます。ただし、Modbus パケットタイプの通信用に設定された In-Sight TCPDevice 関数を使って、イーサネットベースの I/O をこれらのビジョンシステム上で設定する必要があります。
  • パルスディスクリート出力が CIO-1450 I/O モジュールから送信されるときには、パルス幅が指定より 10 ミリ秒長くなることがあります。
  • CIO-1460 I/O モジュールの電源を入れ直すと、ディスクリート出力は初期化時におよそ 250 ミリ秒間出力されます。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

警告:

  • In-Sight 70xx ～ 74xx シリーズのビジョンシステムを CIO-MICRO または CIO-MICRO-CC I/O モジュールと接続する場合、I/O モジュールの I/O ポート (DB15) と TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON 端子はサポートされません。リモートデバイスからこれらの端子にリード線を接続しないでください。
  • In-Sight 76xx ～ 79xx シリーズのビジョンシステムをブレークアウトケーブルに接続する場合、CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。リモートデバイスからこれらの端子にリード線を接続しないでください。

ディスクリート I/O ラインの設定

  1. [センサ] メニューで、[ディスクリート I/O の設定] をクリックします。

  2. オプションで、[I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。設定を完了したら、[OK] ボタンをクリックして [I/O モジュールの設定] ダイアログを閉じ、[ディスクリート I/O の設定] ダイアログに戻ります。

    注:

    • ビジョンシステムと I/O モジュール間の最初の接続に成功すると、センサに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されます。
    • CIO-MICRO、CIO-MICRO-CC、または CIO-WENET が、選択された I/O モジュールである場合に、[OK] ボタンをクリックすると、ビジョンシステムは指定の IP アドレスを使って、モジュールとの EtherNet/IP 通信を確立しようとします。IP アドレスがネットワークに存在せず、EtherNet/IP がモジュールで有効になっていない場合、または別のデバイスがすでにモジュールとの EtherNet/IP 接続を確立している場合は、エラーメッセージが表示されます。

  3. 設定する入力または出力ラインを選択します。デフォルト設定は、設定対象の In-Sight ビジョンシステムおよびビジョンシステムに接続されている I/O モジュールのタイプによって異なります。

    Closed In-Sight Micro 1000 シリーズ

    直接接続 I/O

    出力 | 名前
    0 | HS 出力 0 (HSOUT 0)1
    1 | HS 出力 1 (HSOUT 1)1
    4 | 緑色の LED
    5 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-MICRO または CIO-MICRO-CC

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)1
    9 | HS 出力 1 (HSOUT 1)1
    10 | 緑色の LED
    11 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-WENET

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)1
    9 | HS 出力 1 (HSOUT 1)1
    10 | 緑色の LED
    11 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。
    Closed In-Sight 5000 シリーズ

    CIO-1400

    入力 | 名前
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | HS 出力 0 (HSOUT 0)1
    1 | HS 出力 1 (HSOUT 1)1
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | 緑色の LED
    9 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-1450

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)1
    9 | HS 出力 1 (HSOUT 1)1
    10 | 緑色の LED
    11 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-1460

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)1
    9 | HS 出力 1 (HSOUT 1)1
    10 | 緑色の LED
    11 | 赤色の LED
    12 | 無効
    13 | 無効
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-MICRO/CIO-MICRO-CC

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)1
    9 | HS 出力 1 (HSOUT 1)1
    10 | 緑色の LED
    11 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。
    Closed In-Sight 70xx ～ 74xx シリーズ

    注:

    • In-Sight 70xx ～ 74xx シリーズのビジョンシステムは、ブレークアウトケーブルと、CIO-MICRO または CIO-MICRO-CC I/O モジュールとの同時接続をサポートしています。
    • In-Sight 7000 シリーズ (70xx ～ 79xx シリーズ) のビジョンシステムの内蔵入力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
    • In-Sight 70xx ～ 74xx シリーズの高速出力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
    • In-Sight 70xx ～ 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように設定されている場合、ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

    警告:

    • In-Sight 70xx ～ 74xx シリーズのビジョンシステムを CIO-MICRO または CIO-MICRO-CC I/O モジュールと接続する場合、I/O モジュールの I/O ポート (DB15) と TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON 端子はサポートされません。リモートデバイスからこれらの端子にリード線を接続しないでください。
    • In-Sight 70xx ～ 74xx シリーズのビジョンシステムを CIO-MICRO または CIO-MICRO-CC I/O モジュールと接続する場合、I/O モジュールの I/O ポート (DB15) はサポートされていません。このポートには何も接続しないでください。

    直接接続 I/O

    入力 | 名前
    1 | 入力 1 (IN 1)1/シリアル受信
    2 | 入力 2 (IN 2)1
    3 | 入力 3 (IN 3)1
    出力 | 名前
    0 | HS 出力 0 (HSOUT 0)2
    1 | HS 出力 1 (HSOUT 1)2/シリアル通信
    2 | HS 出力 2 (HSOUT 2)2
    3 | HS 出力 3 (HSOUT 3)2
    4 | 緑色の LED
    5 | 赤色の LED

    1内蔵入力、ビジョンシステムと直接接続。

    2内蔵高速出力、ビジョンシステムと直接接続。

    CIO-MICRO/CIO-MICRO-CC

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    9 | 入力 1 (IN 1)1
    10 | 入力 2 (IN 2)1
    11 | 入力 3 (IN 3)1
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)2
    9 | HS 出力 1 (HSOUT 1)2
    10 | HS 出力 2 (HSOUT 2)2
    11 | HS 出力 3 (HSOUT 3)2
    12 | 緑色の LED
    13 | 赤色の LED

    1組み込み入力、ブレークアウトケーブルに接続されている場合は In-Sight ビジョンシステムから直接入力する。

    2高速出力、ブレークアウトケーブルに接続されている場合は In-Sight ビジョンシステムから直接出力する。
    Closed In-Sight 76xx ～ 79xx シリーズ

    直接接続 I/O

    入力 | 方向 | 名前
    1 | 固定入力 | 入力 1 (IN 1)1
    2 | 入力2 | 入力 2 (IN 2)1
    3 | 入力2 | 入力 3 (IN 3)1
    出力 | 方向 | 名前
    0 | 固定出力 | HS 出力 0 (HSOUT 0)3
    1 | 固定出力 | HS 出力 1 (HSOUT 1)3
    2 | 出力2 | HS 出力 2 (HSOUT 2)3
    3 | 出力2 | HS 出力 3 (HSOUT 3)3
    4 | 固定出力 | PASS/FAIL LED
    5 | 固定出力 | エラー LED

    1内蔵入力、ビジョンシステムと直接接続。

    2双方向ラインは、入力または出力用に設定することができ、デフォルトでは出力に設定されています。このラインは、ブレークアウトケーブルに接続されているときのみサポートされており、設定可能となります。

    3内蔵高速出力、ビジョンシステムと直接接続。

    CIO-1400

    注: CIO-1400　I/O モジュールに接続されている場合、ビジョンシステムの入力 1 (IN 1)、入力 2 (IN 2)、入力 3 (IN 3)、HS 出力 2 (HS OUT 2) および HS 出力 3 (HS OUT 3) ラインはサポートされません。
    入力 | 名前
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | HS 出力 0 (HSOUT 0)1
    1 | HS 出力 1 (HSOUT 1)1
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | PASS/FAIL LED
    9 | エラー LED
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-MICRO

    注:

    • In-Sight 76xx ～ 79xx シリーズのビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへの Ethernet 接続が確立されている場合:
      • CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON の各端子はサポートされていません。リモートデバイスからこれらの端子にリード線を接続しないでください。
      • ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
    • In-Sight 76xx ～ 79xx シリーズのビジョンシステムが I/O モジュールケーブルを介して CIO-MICRO I/O モジュールに接続されている場合:
      • TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON は CIO-MICRO I/O モジュール端子を介して接続されます。
      • ビジョンシステムの IN 1、IN 2、IN 3、HS OUT 2、HS OUT 3 の各ラインが [ディスクリート I/O 設定] ダイアログに表示されますが、これらはサポートされていません。これらのラインは、ビジョンシステムがブレークアウトケーブルに接続されている場合にだけサポートされます。
      • ビジョンシステムのフェースプレートまたは LIGHT コネクタに接続された照明アクセサリはサポートされません。これらの照明アクセサリを接続する場合、ブレークアウトケーブルを使ってビジョンシステムに給電し、I/O モジュールへの接続をイーサネットのみで確立する必要があります。
    入力 | 方向 | 名前
    0 | 固定入力 | ライン 0 (Line 0)
    1 | 固定入力 | ライン 1 (Line 1)
    2 | 固定入力 | ライン 2 (Line 2)
    3 | 固定入力 | ライン 3 (Line 3)
    4 | 固定入力 | ライン 4 (Line 4)
    5 | 固定入力 | ライン 5 (Line 5)
    6 | 固定入力 | ライン 6 (Line 6)
    7 | 固定入力 | ライン 7 (Line 7)
    9 | 固定入力 | 入力 1 (IN 1)1
    10 | 入力2 | 入力 2 (IN 2)1
    11 | 入力2 | 入力 3 (IN 3)1
    出力 | 方向 | 名前
    0 | 固定出力 | ライン 0 (Line 0)
    1 | 固定出力 | ライン 1 (Line 1)
    2 | 固定出力 | ライン 2 (Line 2)
    3 | 固定出力 | ライン 3 (Line 3)
    4 | 固定出力 | ライン 4 (Line 4)
    5 | 固定出力 | ライン 5 (Line 5)
    6 | 固定出力 | ライン 6 (Line 6)
    7 | 固定出力 | ライン 7 (Line 7)
    8 | 固定出力 | HS 出力 0 (HSOUT 0)3
    9 | 固定出力 | HS 出力 1 (HSOUT 1)3
    10 | 出力2 | HS 出力 2 (HSOUT 2)3
    11 | 出力2 | HS 出力 3 (HSOUT 3)3
    12 | 固定出力 | PASS/FAIL LED
    13 | 固定出力 | エラー LED

    1内蔵入力、ビジョンシステムと直接接続。

    2双方向ラインは、入力または出力用に設定することができ、デフォルトでは出力に設定されています。このラインは、ブレークアウトケーブルに接続されているときのみサポートされており、設定可能となります。

    3内蔵高速出力、ビジョンシステムと直接接続。
    Closed In-Sight 8000 シリーズ

    直接接続 I/O

    出力 | 名前
    0 | HS 出力 0 (HSOUT 0)1
    1 | HS 出力 1 (HSOUT 1)1
    4 | 緑色の LED
    5 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。

    CIO-MICRO

    入力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    出力 | 名前
    0 | ライン 0 (Line 0)
    1 | ライン 1 (Line 1)
    2 | ライン 2 (Line 2)
    3 | ライン 3 (Line 3)
    4 | ライン 4 (Line 4)
    5 | ライン 5 (Line 5)
    6 | ライン 6 (Line 6)
    7 | ライン 7 (Line 7)
    8 | HS 出力 0 (HSOUT 0)1
    9 | HS 出力 1 (HSOUT 1)1
    10 | 緑色の LED
    11 | 赤色の LED
    1内蔵高速出力、ビジョンシステムと直接接続。
  4. In-Sight 76xx ～ 79xx シリーズのみ: ラインが双方向 I/O をサポートする場合は、[方向] ドロップダウンから [入力] または [出力] を選択します。
  5. 必要に応じて、デフォルト名を含むフィールドを選択して新しい名前を入力し、ラインの新しい [名前] を入力します。名前に使用できる文字数は最大 15 文字です。この名前は参照目的のみに使用され、ラインの機能を変更したり、スプレッドシートで参照したりすることはできません。

  6. 選択した入力ラインの [信号タイプ] 入力を選択します。次の表の機能を各入力ラインに設定することができます。

    入力信号タイプ 説明

    ユーザデータ

    汎用入力ライン。スプレッドシートにイベントを送ったり、ReadDiscrete 関数を使用してスプレッドシートに値を設定したりする場合に使用します。

    イベントトリガ

    イベントをトリガします。スプレッドシートを更新するには、[トリガ] パラメータがこのディスクリート入力ライン番号に設定されているイベント構造体がそのスプレッドシートに含まれている必要があります。

    ジョブ ID 番号

    ジョブ ID 番号を構成する 1 ビット。[信号タイプ] が [ジョブを開く] になっている別の入力ラインが ON の場合に読み込まれます。

    注:
    • ジョブ ID 番号の機能を使用する場合は、ジョブファイル名の先頭に 0 ～ 127 の接頭辞を付けておく必要があります。
    • ジョブ ID 番号の最小値は、I/O モジュール上のディスクリート入力ラインの最小値に対応しています。

    オンライン/オフライン*

    In-Sight ビジョンシステムを、強制的にオフラインまたはオンラインにします (0 = オフライン、1 = オンライン)。

    注: [信号タイプ] を [オンライン] に設定しても、In-Sight Explorer ユーザインタフェースを介して手動でオフラインに設定された場合や、ネイティブモードの Set Online コマンド (SO0) が発行され、In-Sight ビジョンシステムにオフラインになるよう指示された場合、ビジョンシステムはオフラインのままになります。

    画像取り込みトリガ*

    (CIO-1400 ではサポートされていません)

    In-Sight ビジョンシステムをトリガして画像を取り込みます。

    注:
    • AcquireImage プロパティシートの [トリガ] パラメータを [外部] に設定し、信号ラインを物理的に In-Sight ビジョンシステムの入力に接続して画像取り込みトリガ入力を使用する必要があります。
    • AcquireImage 関数の [トリガ] パラメータを [外部] に設定し、取り込みに失敗すると、「エラー:画像取り込み失敗」出力はビジョンシステムから送信されません。「エラー: 画像取り込み失敗」シグナルは、AcquireImage 関数の [トリガ] パラメータが [カメラ] に設定されている場合にだけサポートされます。
    • トリガレートを上げるには、画像取り込みトリガとして構成された汎用入力ラインを使ってビジョンシステムをトリガ (AcquireImage 関数の [トリガ] パラメータを [外部] に設定) するのではなく、ビジョンシステムに組み込まれている取り込みトリガ入力を使用 (AcquireImage 関数の [トリガ] パラメータを [カメラ] に設定) します。

    ジョブを開く*

    入力ラインの状態が ON になると、すべてのジョブ ID 番号を読み取り、指定されたジョブをロードします。

    注: In-Sight ビジョンシステムはオフラインになっている必要があります。

    シリアル受信
    (直接接続 I/O のみ)

    このラインをシリアル受信ラインとして設定します。

    注:
    • [シリアル受信] は、In-Sight Explorer 4.7.1 以上が搭載されている In-Sight 70xx ～ 74xx シリーズビジョンシステムに接続し、In-Sight 4.7.1 以上のファームウェアを使用している場合のみ使用可能です。
    • 直接接続 I/O が選択されている場合、この入力タイプはライン 1 に対してのみ有効です。
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
    * この入力タイプを、同時に複数のラインに割り当てることはできません。
  7. 選択された入力ラインの [エッジタイプ] を設定します。これは、エッジの遷移に対する入力ラインの状態を制御します。
    • [立ち上がりエッジ]: パルスの立ち上がりエッジで入力ラインの状態が変わります。
    • [立ち下がりエッジ]: パルスの立ち下がりエッジで入力ラインの状態が変わります。
    • [両方のエッジ]: パルスの立ち上がりエッジと立ち下がりエッジのどちらでも入力ラインの状態が変わります。このオプションは [イベントトリガ] タイプでのみ利用できます。

  8. 選択した出力ラインの [信号タイプ] を選択します。各出力ラインは、次の機能のいずれか 1 つについて設定できます。

    出力信号タイプ 説明

    ユーザ用

    (デフォルト)

    スプレッドシートの WriteDiscrete 関数が、この出力ラインの状態を制御できるようにします。パルスまたは定常状態です。

    高

    出力を High (1) にします。

    低

    出力を LOW (0) にします。

    画像取り込み開始

    ビジョンシステムが画像取り込みを開始したことを示す信号です。常にパルスとなります。

    注: In-Sight Micro 8405 ビジョンシステムでは、最初のピクセル行が露光したときに、画像取り込み開始信号がパルス出力されます。詳細については、「ローリングシャッターの操作」を参照してください。

    画像取り込み終了

    ビジョンシステムが画像の取り込みを完了したことを示す信号です。常にパルスとなります。

    注: In-Sight Micro 8405 ビジョンシステムでは、画像読み出しがすべて完了したときに、画像取り込み終了信号がパルス出力されます。詳細については、「ローリングシャッターの操作」を参照してください。

    ジョブ完了

    スプレッドシートが更新を完了するたびに出す信号です。常にパルスとなります。

    システムビジー

    ビジョンシステムがジョブを実行しているとき、またはユーザ入力に応答しているときは HIGH になります。ビジョンシステムがアイドルの場合は LOW です。

    ジョブを開く - 完了

    ジョブのロードが成功したことを示す信号です。常にパルスとなります。

    エラー: ジョブを開く

    ジョブのロードが失敗したことを示す信号です。常にパルスとなります。

    エラー: 画像取り込み失敗

    画像取り込み終了信号が送信される前に画像取り込みトリガを受信したか、または画像取り込みトリガを受信したときに画像バッファが利用できないことを示す信号です。常にパルスとなります。

    注: AcquireImage プロパティシートの [トリガ] パラメータは、[カメラ] に設定して [エラー: 画像取り込み失敗] を使用する必要があります。

    エラー: トラックオーバラン

    予想時刻よりやや遅れてスプレッドシートが遅延ディスクリート出力信号を出力したことを示す信号です。常にパルスとなります。

    エラー: トラックキューフル

    同時に別の出力が発生するように予定されていたラインに、スプレッドシートが遅延ディスクリート出力信号を出力したことを示す信号です。常にパルスとなります。

    オンライン/オフライン

    ビジョンシステムがオンラインのときは HIGH (1) になり、ビジョンシステムがオフラインの場合は LOW (0) になります。

    ストロボ

    信号の立ち上がりエッジまたは立ち下がりエッジでストロボにトリガをかけることができます。

    • [NPN 設定]: [ストロボ/照明制御のトリガ] を [立ち上がりエッジ] に設定すると、信号は画像センサの露光時に HIGH になり、それ以外では LOW になります。[ストロボ/照明制御のトリガ] を [立ち下がりエッジ] に設定すると、信号は画像センサの露光時に LOW になり、それ以外では HIGH になります。露光時は常にパルスとなります。露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。
    • [PNP 設定]: [ストロボ/照明制御のトリガ] を [立ち上がりエッジ] に設定すると、信号は画像センサの露光時に LOW になり、それ以外では HIGH になります。[ストロボ/照明制御のトリガ] を [立ち下がりエッジ] に設定すると、信号は画像センサの露光時に HIGH になり、それ以外では LOW になります。露光時は常にパルスとなります。露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    注:

    • In-Sight 5600 シリーズ、5705、5705C、5715 ビジョンシステムでは、ストロボ動作が反転しています。例えば、NPN 配線では、立ち上がりエッジおよび立ち下がりエッジが PNP 配線のように動作します。
    • ストロボが正常に動作するには、ビジョンシステムとストロボデバイスが同じグラウンドに接続されている必要があります。
    • In-Sight Micro 1000 シリーズのビジョンシステムでは、[直接接続 I/O] が選択されている場合には出力ライン 1 (HSOUT 1) が許可され、[CIO-MICRO]、[CIO-MICRO-CC] または [CIO-WENET] が選択されている場合には出力ライン 9 (HSOUT 1) が許可されます。
    • In-Sight 5000 シリーズのビジョンシステムでは、[直接接続 I/O] / [CIO-1350] または [CIO-1400] が選択されている場合には出力ライン 1 (HSOUT 1) でのストロボ出力タイプが許可され、[CIO-1450]、[CIO-1460]、[CIO-MICRO] または [CIO-MICRO-CC] が選択されている場合には出力ライン 9 (HSOUT 1) が許可されます。
    • In-Sight 70xx ～ 74xx シリーズのビジョンシステムでは、[直接接続 I/O] が選択されている場合には出力ライン 0 (HSOUT 0) でのストロボ出力タイプが許可され、CIO-MICRO または CIO-MICRO-CC が選択されている場合には出力ライン 8 (HSOUT 0) が許可されます。
    • In-Sight 76xx ～ 79xx シリーズビジョンシステムでは、[直接接続 I/O] または [CIO-1400] が選択されている場合には出力ライン 1 (HSOUT 1) でのストロボ出力タイプが許可され、[CIO-MICRO] が選択されている場合には出力ライン 9 (HSOUT 1) が許可されます。
    • In-Sight 8000 シリーズのビジョンシステムでは、[直接接続 I/O] が選択されている場合には出力ライン 1 (HSOUT 1) が許可され、[CIO-MICRO] が選択されている場合には出力ライン 9 (HSOUT 1) が許可されます。
    • In-Sight Micro 8405 ビジョンシステムでは、ストロボ開始位置は [すべての行を露光] に固定されています。すべてのピクセル行が露光されたときのみ、出力信号がパルス出力されます。In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、「ローリングシャッターの操作」を参照してください。

    照明制御

    (CIO-1460 のみ)

    信号の立ち上がりエッジまたは立ち下がりエッジで照明にトリガをかけることができます。[ストロボ/照明制御のトリガ] を [立ち上がりエッジ] に設定すると、信号は画像センサの露光時に HIGH になり、それ以外では LOW になります。[ストロボ/照明制御のトリガ] を [立ち下がりエッジ] に設定すると、信号は画像センサの露光時に LOW になり、それ以外では HIGH になります。露光時は常にパルスとなります。露光時間は外部照明デバイスで設定されているパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    注:

    • 照明デバイスが正常に動作するには、ビジョンシステムと照明デバイスが同じグラウンドに接続されている必要があります。
    • この出力タイプは、In-Sight 5000 シリーズのビジョンシステムで CIO-1460 I/O モジュールを設定するときに、出力ライン 9 (HSOUT 1) に対してのみ有効です。

    I/O モジュールスタンバイ

    (CIO-1450 および CIO-1460 のみ)

    [ON] は、I/O モジュールがビジョンシステムとその I/O モジュールの間の通信エラーを検知し、通信の再確立を試みていることを示します。I/O モジュールによりエラー状態が修正されたことが検出されると、ラインは OFF になります。

    注: このオプションは、CIO-1450 または CIO-1460 I/O モジュールを設定するときに、ライン 0 ～ 7 に対してのみ使用できます。

    ライフライン

    (CIO-MICRO および CIO-MICRO-CC のみ)

    HIGH (ビジョンシステムが、アクティブに CIO-MICRO または CIO-MICRO-CC に接続されている場合)。LOW (ビジョンシステムが接続に失敗する場合)。
    波形

    スプレッドシートの Waveform 関数、WriteWaveformPulseTrain または WriteWaveformClocked が、この出力ラインの状態を制御できるようにします。

    シリアル送信

    (直接接続 I/O のみ)

    ラインをシリアル送信ラインとして設定します。

    注:

    • [シリアル送信] は、In-Sight Explorer 4.7.1 以上が搭載されている In-Sight 70xx ～ 74xx シリーズビジョンシステムに接続し、In-Sight 4.7.1 以上のファームウェアを使用している場合のみ使用可能です。
    • この出力タイプは、[直接接続 I/O] 選択時に、ライン 1 でのみ使用可能です。
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。

    ジョブの PASS/FAIL セル

    (In-Sight 76xx ～ 79xx シリーズのみ)

             この設定が選択された場合は、指定のジョブ PASS/FAIL セルの現在の状態に基づいて、ビジョンシステムの PASS/FAIL LED およびインジケータリングが緑 (PASS) または赤 (FAIL) で点灯します。ジョブ PASS/FAIL セルが指定されていない場合、または ジョブ PASS/FAIL セルが [警告] または [なし] の [ジョブのステータス] を返す場合、この LED は点灯しません。
  9. 指定した出力タイプの詳細設定が使用可能な場合、[詳細] ボタンを押すと、選択した出力ラインの [出力詳細] ダイアログが開きます。

  10. 必要に応じて、[オフライン中は出力を OFF にする] チェックボックスをオンにして、ビジョンシステムがオフラインになるときに出力の電源を切ります。

    注:

    • [オフライン中は出力を OFF にする] チェックボックスがオンになっており、ビジョンシステムがオンラインになっている場合は、[ディスクリート I/O 設定] ダイアログを使用して設定された出力ラインがリストアされます。WriteDiscrete 関数を使用して設定された出力ラインはリストアされません。関数で指定されたイベントが発生するまで、これらの出力ラインはリストアされません。
    • [オフライン中は出力を OFF にする] チェックボックスが ON で、CIO-MICRO または CIO-MICRO-CC I/O の出力ラインが [ライフライン] 信号タイプに設定されている場合、接続中のビジョンシステムがオフラインでもラインは HIGH となります。
  11. [OK] をクリックすると、変更が適用されます (変更はフラッシュメモリに保存されます)。変更を取り消す場合は、[キャンセル] をクリックします。

関連項目

  • [I/O モジュールの設定] ダイアログ
  • [出力詳細] ダイアログ
  • In-Sight 7000 Gen2 シリーズ I/O 設定
  • ReadDiscrete 関数
  • WriteDiscrete 関数
  • Waveform 関数
  • ローリングシャッターの操作
  • CIO-WENET の IP アドレスの設定
Version: 5.6.0


[I/O モジュールの設定] ダイアログ

In-Sight Explorer GUI リファレンス

[I/O モジュールの設定] ダイアログでは、In-Sight Explorer 内で使用する I/O モジュールの設定を行います。

  • [I/O モジュールの設定] ダイアログにアクセスする
  • CIO-1400、CIO-1450、または CIO-1460 を設定する
  • CIO-MICRO または CIO-MICRO-CC を設定する
  • CIO-WENET を設定する

[I/O モジュールの設定] ダイアログにアクセスする

EasyBuilder ビュー

  • [アプリケーションステップ] ペインから、以下の操作を実行します。
    • [入力] または [出力] アプリケーションステップをクリックします。または、
    • [通信] アプリケーションステップをクリックし、シリアルデバイスを追加して、[シリアルポートの設定] タブをクリックします。
  • [I/O モジュール] ボタンをクリックします。

スプレッドシートビュー

  • [センサ] メニューから、以下の操作を実行します。
    • [シリアルポートの設定] を選択します。または
    • [ディスクリート I/O の設定] を選択します
  • [I/O モジュール] ボタンをクリックします。

CIO-1400、CIO-1450、または CIO-1460 を設定する

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから、[CIO-1400]、[CIO-1450]、または [CIO-1460] を選択します。

  4. [OK] をクリックしてダイアログを閉じます。

CIO-MICRO または CIO-MICRO-CC を設定する

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。

  3. [I/O モジュールの選択] ドロップダウンリストから、[CIO-MICRO] または [CIO-MICRO-CC] を選択します。

  4. [接続先] ドロップダウンリストから適切な I/O モジュールを選択します。

    注: I/O モジュールのホスト名がリストに表示されない場合は、<IP アドレスによって接続> を選択して、I/O モジュールの IP アドレスを手動で入力します。

  5. [更新間隔] フィールドで、ビジョンシステムと CIO-MICRO または CIO-MICRO-CC I/O モジュールとの間で入出力を同期するために必要な時間間隔 (3 ～ 500 ミリ秒、デフォルト = 20 ミリ秒) を指定します。

    注:

    • 出力信号の大幅な遅延が問題になる場合は、更新間隔を短くします。ただし、更新間隔はアプリケーションで必要とされる以上に短くしないでください。更新間隔が短くなると、ジョブの実行にかかる時間が長くなることがあります。
    • CIO-MICRO または CIO-MICRO-CC I/O モジュールを設定する場合、指定する [更新間隔] は、予期される最短の入力または出力信号の時間の半分以下にし、信号が正しく送受信されるようにする必要があります。例えば、予期される最短の I/O 信号が 100 ミリ秒の場合、[更新間隔] は 50 ミリ秒以下にします。
  6. 必要に応じて、[設定の変更] ボタンをクリックして、I/O モジュールのネットワーク設定を行います。

    • デフォルトでは、In-Sight CIO-MICRO および CIO-MICRO-CC I/O モジュールは、DHCP サーバによって起動時に動的に設定されます。新しいホスト名を割り当てることもできますが、ダイアログ内のそのほかのフィールドはすべて無効です。

      注: DHCP サーバが使用できない場合は、I/O モジュールはタイムアウトし、リンクローカル IP アドレスに接続します。

    • CIO-MICRO および CIO-MICRO-CC には、固定 IP アドレスも使用することができます。[DHCP サーバの使用] チェックボックスをオフにして、[IP アドレス]、[サブネットマスク]、[デフォルトゲートウェイ]、[DNS サーバ] および [ドメイン名] フィールドに適切なネットワーク設定を指定します。

  7. [OK] をクリックしてダイアログを閉じます。

CIO-WENET を設定する

注: In-Sight Explorer で CIO-WENET Ethernet I/O モジュールを設定するには、最初に、モジュールに IP アドレスを割り当てる必要があります。

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。

  3. [I/O モジュールの選択] ドロップダウンリストから、[CIO-WENET] を選択します。

  4. [IP アドレス] フィールドには、CIO-WENET に事前に割り当てた IP アドレスを指定します。

  5. [更新間隔] フィールドで、In-Sight Micro 1000 シリーズのビジョンシステムと CIO-WENET I/O モジュール間の入出力を同期させるのに必要な時間間隔を指定します (1　～ 500 ミリ秒。デフォルト = 20 ミリ秒)。

    注:
    • 出力信号の大幅な遅延が問題になる場合は、更新間隔を短くします。ただし、更新間隔はアプリケーションで必要とされる以上に短くしないでください。更新間隔が短くなると、ジョブの実行にかかる時間が長くなることがあります。
    • CIO-WENET では、同期させるのに必要な時間は、[更新時間] より 3ms 長くなります。
  6. [OK] をクリックしてダイアログを閉じます。

関連項目

[シリアルポートの設定] ダイアログ

[ディスクリート I/O の設定] ダイアログ

Version: 5.6.0


[出力詳細] ダイアログ

[センサ] メニュー → [ディスクリート I/O の設定]　→ [詳細設定]

In-Sight Explorer GUI リファレンス

[出力詳細] ダイアログを使用して、[ディスクリート I/O 設定] ダイアログ内から個々の出力ラインパラメータを設定します。

[出力詳細] ダイアログを表示する

  1. [センサ] メニューで、[ディスクリート I/O の設定] をクリックします。
  2. [ディスクリート I/O 設定] ダイアログで、設定する出力ラインを選択し、[詳細設定] をクリックします。

選択した出力ライン信号タイプに応じて、次の [出力詳細] ダイアログのいずれかが表示されます。

信号タイプ | [出力詳細] ダイアログの例
ユーザ用 |
画像取り込み開始 画像取り込み終了 ジョブを開く - 完了 エラー: ジョブを開く エラー: 画像取り込み失敗 エラー: トラックオーバラン エラー: トラックキューフル |
ジョブ完了 |
ストロボ |

ハイ (High)、ロー (Low)、システムビジー、オンライン/オフライン、ライフライン、I/O モジュールスタンバイ、ジョブの PASS/FAIL セルの信号タイプの出力詳細は設定できません。

[出力詳細] ダイアログのコントロール

  • [パルス]: このチェックボックスをオンにすると、出力は [パルス幅] の期間パルス出力されます。OFF にすると定常状態に設定されます。[取り込み遅延] が 0 以外の場合、パルス出力になります。

  • [パルス幅 (ミリ秒)]:出力パルスの持続時間。

    ビジョンシステム/ビジョンセンサ | 最小パルス幅 | 最大パルス幅 | デフォルトのパルス幅
    汎用出力1 | 高速出力
    In-Sight Micro 1000 シリーズ (1402、1412、1500 を除く) | 10 ミリ秒 | 10 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
    In-Sight Micro 1402、1412、1500 | 10 ミリ秒 | 1 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
    In-Sight 5000 シリーズ | 10 ミリ秒 | 10 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
    In-Sight 70xx ～ 74xx シリーズ | 10 ミリ秒 | 1 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
    In-Sight 76xx ～ 79xx シリーズ | 10 ミリ秒 | 1 ミリ秒2 | 1000 ミリ秒 | 10 ミリ秒
    In-Sight 8000 シリーズ | 10 ミリ秒 | 1 ミリ秒2 | 1000 ミリ秒 | 10 ミリ秒

    1CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用しているときに、汎用出力の最小パルス幅は [I/O モジュールの設定] ダイアログの [更新間隔] 設定によって制限されます。例えば、[I/O モジュールの設定] ダイアログの [更新間隔] が 20ms に設定されている場合、最小パルス幅は 30ms 以下に設定することはできません。

    21 ミリ秒の最小パルス幅は、In-Sight ファームウェアバージョン 5.5.0 以上を使用している場合にだけサポートされます。より前のバージョンのファームウェアを使用している場合、最小パルス幅は 10 ミリ秒です。

  • [取り込み遅延 (N)]: 出力ラインが信号パルスを受信した後に、出力を遅らせる画像取り込みまたはトラックパルスの数 (0 ～ 1000) です。画像取り込み遅延が 0 の場合、In-Sight センサは、WriteDiscrete 関数を評価するとすぐに出力ラインを更新します。[取り込み遅延] が 0 よりも大きい場合、出力ラインは常にパルス出力されます。

    注: [取り込み遅延] と [トリガ後の時間] を同時に使用することはできません。これらは個別に使用する必要があります。例えば、[取り込み遅延] が有効になると、[トリガ後の時間] は無効になります。逆に、[トリガ後の時間] が有効になると、[取り込み遅延] は無効になります。

  • [トリガ後の時間 (ms)]: このチェックボックスを ON にすると、指定された時間 (0 ～ 10000 ミリ秒) の経過後に、出力が行われます。

    注: [取り込み遅延] と [トリガ後の時間] を同時に使用することはできません。これらは個別に使用する必要があります。例えば、[取り込み遅延] が有効になると、[トリガ後の時間] は無効になります。逆に、[トリガ後の時間] が有効になると、[取り込み遅延] は無効になります。

  • [ストロボ/照明制御のトリガ]: 信号の立ち上がりエッジまたは立ち下がりエッジでストロボにトリガをかけることができます。
    • [NPN 設定]: [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が HIGH になり、それ以外は LOW となります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が LOW になり、それ以外は HIGH となります。露光時は常にパルスとなります。露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    • [PNP 設定]: [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が LOW になり、それ以外は HIGH となります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が HIGH になり、それ以外は LOW となります。露光時は常にパルスとなります。露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    注: In-Sight 5600 シリーズ、5705、5705C、5715 ビジョンシステムでは、ストロボ動作が反転しています。例えば、NPN 配線では、立ち上がりエッジおよび立ち下がりエッジが PNP 配線のように動作します。
  • [ストロボ開始位置]: ストロボ出力を開始する位置を指定します。
    • [画像取り込み開始]:ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。In-Sight 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • [カメラトリガ]: カメラトリガイベントを受信したときにストロボがパルス出力されるように指定します。In-Sight 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。

    • [すべての行を露光]: すべてのピクセル行が露光されたときにのみストロボがパルス出力されるよう指定します。In-Sight 8405 ビジョンシステムでのみサポートされています。

      注: In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、「ローリングシャッターの操作」を参照してください。

  • [三色 LED]: 三色 LED ラインの動作を設定します。([OFF/緑]、[OFF/赤]、[赤/緑]、デフォルト = [OFF/緑]) このオプションは、そのラインが 3 色 LED をサポートしている場合にのみ指定できます。

    注: このオプションは、PASS/FAIL LED を使用する In-Sight 76xx ～ 79xx シリーズのビジョンシステムでサポートされていますが、[信号タイプ] として PASS FAIL ジョブセルが選択されている場合には指定できません。
Version: 5.6.0


In-Sight 7000 Gen2 シリーズ I/O 設定

In-Sight Explorer GUI リファレンス

In-Sight 7000 Gen2 シリーズのビジョンシステムのトリガ、入力、出力、シリアル送受信および電源の接続用に、いくつかのオプションが用意されています。

  • ブレークアウトケーブルのみ
  • ブレークアウトケーブルと CIO-MICRO I/O モジュール
  • I/O モジュールケーブルと CIO-MICRO I/O モジュール
  • I/O モジュールケーブルと CIO-1400 I/O モジュール

ブレークアウトケーブルのみ

ビジョンシステムはブレークアウトケーブルに接続され、直接接続 I/O は [I/O モジュールの設定] ダイアログで設定されています。この設定の場合:

  • ブレークアウトケーブルは、ビジョンシステムに給電します。
  • I/O モジュールには接続されていない。
ブレークアウトケーブル | サポート
トリガ (TRIGGER) | √
HS 出力 0 (HS OUT 0) | √
HS 出力 1 (HS OUT 1) | √
入力 1 (IN 1) | √
入力 2 (IN 2) / HS 出力 2 (HS OUT 2)1 | √
入力 3 (IN 3) / HS 出力 3 (HS OUT 3)1 | √
コモン入力 (COMMON IN) | √
コモン出力 (COMMON OUT) | √
RS-232 送信 (RS-232 TRANSMIT) | √
RS-232 受信 (RS-232 RECEIVE) | √
+24VDC | √
GND | √
1双方向ラインは、入力または出力用に設定することができ、デフォルトでは出力に設定されています。このラインは、ブレークアウトケーブルに接続されているときのみサポートされており、設定可能となります。

ブレークアウトケーブルと CIO-MICRO I/O モジュール

ビジョンシステムはブレークアウトケーブルに接続され、CIO-MICRO I/O モジュールへの Ethernet 接続は [I/O モジュールの設定] ダイアログで設定されています。この設定の場合:

  • ブレークアウトケーブルは、ビジョンシステムに給電します。
  • CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON の各端子はサポートされていません。リモートデバイスからこれらの端子にリード線を接続しないでください。
  • ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
ブレークアウトケーブル | サポート
トリガ (TRIGGER) | √
HS 出力 0 (HS OUT 0) | √
HS 出力 1 (HS OUT 1) | √
入力 1 (IN 1) | √
入力 2 (IN 2) / HS 出力 2 (HS OUT 2)1 | √
入力 3 (IN 3) / HS 出力 3 (HS OUT 3)1 | √
コモン入力 (COMMON IN) | √
コモン出力 (COMMON OUT) | √
RS-232 送信 (RS-232 TRANSMIT) | 非サポート
RS-232 受信 (RS-232 RECEIVE) | 非サポート
+24VDC | √
GND | √
CIO-MICRO I/O モジュール |
+24VDC | 非サポート
-24VDC | 非サポート
トリガ＋ (TRIGGER+) | 非サポート
トリガ－ (TRIGGER-) | 非サポート
HS 出力 1 (HS OUT 1) | 非サポート
HS 出力 0 (HS OUT 0) | 非サポート
HS コモン (HS COMMON) | 非サポート
入力 7 (INPUT 7) | √
入力 6 (INPUT 6) | √
入力 5 (INPUT 5) | √
入力 4 (INPUT 4) | √
入力 3 (INPUT 3) | √
入力 2 (INPUT 2) | √
入力 1 (INPUT 1) | √
入力 0 (INPUT 0) | √
入力コモン (IN COMMON) | √
出力 7 (OUT 7) | √
出力 6 (OUT 6) | √
出力 5 (OUT 5) | √
出力 4 (OUT 4) | √
出力 3 (OUT 3) | √
出力 2 (OUT 2) | √
出力 1 (OUT 1) | √
出力 0 (OUT 0) | √
出力コモン (OUT COMMON) | √
RS-232 出力 (RS-232 OUT) | √
1双方向ラインは、入力または出力用に設定することができ、デフォルトでは出力に設定されています。このラインは、ブレークアウトケーブルに接続されているときのみサポートされており、設定可能となります。

I/O モジュールケーブルと CIO-MICRO I/O モジュール

ビジョンシステムは I/O モジュールケーブルに接続され、CIO-MICRO I/O モジュールへの Ethernet 接続は [I/O モジュールの設定] ダイアログで設定されています。この設定の場合:

  • I/O モジュールケーブルは、ビジョンシステムに給電します。
  • TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON は CIO-MICRO I/O モジュール端子を介して接続されます。
  • ビジョンシステムの IN 1、IN 2、IN 3、HS OUT 2、HS OUT 3 の各ラインが [ディスクリート I/O 設定] ダイアログに表示されますが、これらはサポートされていません。これらのラインは、ビジョンシステムがブレークアウトケーブルに接続されている場合にだけサポートされます。
  • ビジョンシステムのフェースプレートまたは LIGHT コネクタに接続された照明アクセサリはサポートされません。これらの照明アクセサリを接続する場合、ブレークアウトケーブルを使ってビジョンシステムに給電し、I/O モジュールへの接続をイーサネットのみで確立する必要があります。
CIO-MICRO I/O モジュール | サポート
+24VDC | √
-24VDC | √
トリガ＋ (TRIGGER+) | √
トリガ－ (TRIGGER-) | √
HS 出力 0 (HS OUT 0) | √
HS 出力 1 (HS OUT 1) | √
HS コモン (HS COMMON) | √
入力 7 (INPUT 7) | √
入力 6 (INPUT 6) | √
入力 5 (INPUT 5) | √
入力 4 (INPUT 4) | √
入力 3 (INPUT 3) | √
入力 2 (INPUT 2) | √
入力 1 (INPUT 1) | √
入力 0 (INPUT 0) | √
入力コモン (IN COMMON) | √
出力 7 (OUT 7) | √
出力 6 (OUT 6) | √
出力 5 (OUT 5) | √
出力 4 (OUT 4) | √
出力 3 (OUT 3) | √
出力 2 (OUT 2) | √
出力 1 (OUT 1) | √
出力 0 (OUT 0) | √
出力コモン (OUT COMMON) | √
RS-232 出力 (RS-232 OUT) | √

I/O モジュールケーブルと CIO-1400 I/O モジュール

ビジョンシステムは I/O モジュールケーブルに接続され、CIO-1400 I/O モジュールへの接続は [I/O モジュールの設定] ダイアログで設定されています。この設定の場合:

  • I/O モジュールケーブルは、ビジョンシステムに給電します。
  • ビジョンシステムの入力 1 (IN 1)、入力 2 (IN 2)、入力 3 (IN 3)、HS 出力 2 (HS OUT 2) および HS 出力 3 (HS OUT 3) ラインはサポートされていません。
CIO-1400 I/O モジュール | サポート
+24VDC | √
-24VDC | √
トリガ－ (TRIGGER-) | √
トリガ＋ (TRIGGER+) | √
入力 7 (INPUT 7) | √
入力 6 (INPUT 6) | √
入力 5 (INPUT 5) | √
入力 4 (INPUT 4) | √
入力 3 (INPUT 3) | √
入力 2 (INPUT 2) | √
入力 1 (INPUT 1) | √
入力 0 (INPUT 0) | √
入力コモン (IN COMMON) | √
出力 7 (OUT 7) | √
出力 6 (OUT 6) | √
出力 5 (OUT 5) | √
出力 4 (OUT 4) | √
出力 3 (OUT 3) | √
出力 2 (OUT 2) | √
出力 1 (OUT 1) | √
出力 0 (OUT 0) | √
HS 出力 1 (HS OUT 1) | √
HS 出力 0 (HS OUT 0) | √
出力コモン (OUT COMMON) | √
RS-232 出力 (RS-232 OUT) | √


[監査メッセージの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[監査メッセージの設定] ダイアログでは、アクティブなビジョンシステムの自動監査メッセージの有効化または無効化、監査メッセージサーバの IP アドレスと TCP/IP ポートの指定、および監査メッセージを生成するイベントタイプの指定を行うことができます。

注: Cognex では、In-Sight ビジョンシステムからの監査メッセージを「リスン」する方法を示す Cognex 監査メッセージサーバを用意しています。メッセージは、ユーザ保守監査トレイルログまたはデータベースアプリケーションにアーカイブすることができます。詳細については、コグネックスの代理店にお問い合わせください。

[監査メッセージの設定] ダイアログを表示するには

  • [センサ] メニューで、[監査メッセージの設定] をクリックします。

[監査メッセージの設定] ダイアログの設定項目

  • [監査メッセージを有効にする]: アクティブなビジョンシステムの自動監査メッセージを無効にします。
  • [サーバアドレス]: 監査メッセージサーバの IP アドレスを指定します。
  • [サーバポート]: 監査メッセージサーバの TCP/IP ポートを指定します。(デフォルト = 5753)

注: 有効なポート番号は、In-Sight 通信のために予約されているポートを除いて、1 ～ 65535 の未使用の任意の番号です。

  • [メッセージタイプ]: 監査メッセージの生成対象となるイベントのタイプを指定します。

    • [システムイベント]: In-Sight のシステムイベント (ビジョンシステムのログオン/ログオフ、ジョブファイルのロードまたは保存、オンラインモードからオフラインモードへの遷移、システムの起動、およびファームウェア更新) が発生すると、監査メッセージが生成されます。特定のイベント (起動、ジョブを開く、ジョブの保存、ログオン失敗およびファームウェア更新) の場合には、追加データを <value> タグで囲んで、追加の情報が伝達されます。

      注: ログオンの試みに失敗すると、次の情報が <value> タグ内に表示されます。
      • [無効なパスワード]: 入力したパスワードが正しくありません。
      • [無効なユーザ名]: 入力したユーザ名は [ユーザリスト] 内に存在しません。
      • [System Locked (システムがロックされました)]: ビジョンシステムは別のユーザによってロックされます。この情報は、通常、ファームウェアの更新が進行しているときに表示されます。
      • [Access Not Permitted For User (ユーザにアクセスは許可されていません)]: ユーザにはビジョンシステムにアクセスする権限がありません。
      • [Spreadsheet Vew Access Not Permitted (スプレッドシートビューへのアクセスは許可されていません)]: ユーザにはビジョンシステムのスプレッドシートビューへのアクセス許可がありません。この情報は、通常、ユーザが EasyBuilder ビューに対してのみアクセス権を持っている場合に表示されます。
      • [Unspecified Failure (未指定の障害)]: 不明な理由でログオンの試みに成功しませんでした。
    • [タグ付きセル変更時]: In-Sight Explorer、カスタムアプリケーション、VisionView、または PLC を使用してシンボリックタグ付きセルを編集する (例えば、セルの数式または対話型コントロールの値を変更する場合など) と、監査メッセージが生成されます。
    • [システム設定変更時]: システム設定 (proc.set ファイルに保存されているすべての設定) を変更すると、監査メッセージが生成されます。

関連項目

監査メッセージサーバのデモ

シンボリックタグエディタ

Version: 5.6.0


[ラインスキャンの設定] ダイアログ

[センサ] メニュー

In-Sight ExplorerGUI リファレンス

の概要[ラインスキャンの設定] ダイアログ

の表示[ラインスキャンの設定] ダイアログ

[ラインスキャンの設定] ダイアログの設定項目

関連項目

の概要[ラインスキャンの設定] ダイアログ

[ラインスキャンの設定] ダイアログでは、In-Sight 5604 ラインスキャンビジョンシステムのハードウェアエンコーダを設定します。また、このビジョンシステムの特定の診断値を表示します。

注: In-Sight 5604 ラインスキャンビジョンシステムに接続して、4 位相ハードウェアエンコーダを利用しているときに、ビジョンシステムが画像の取り込みを開始し、4 位相ハードウェアエンコーダが、反対方向に移動してフレームトリガの開始点を通過したという信号を出力した場合、取り込まれた画像は正常には生成されておらず、使用することはできません。このような状況が発生した場合は、4 位相ハードウェアエンコーダが方向を反転したという信号を出力したときに、ビジョンシステムをオフラインにします。次に、4 位相ハードウェアエンコーダが以前の方向に戻ったという信号を出力したときに、ビジョンシステムをオンラインに戻します。

の表示[ラインスキャンの設定] ダイアログ

  • [センサ] メニューから [ラインスキャンの設定] をクリックします。

[ラインスキャンの設定] ダイアログの設定項目

  • [画像最大高]: ラインスキャンビジョンシステムでの画像の生成に使用する最大行数 (2048、4096、または 8192、デフォルト = 2048) を指定します。

    注:
    • ラインスキャンビジョンシステムの [画像最大高] の設定を変更するには、ビジョンシステムを再起動する必要があります。その結果、ビジョンシステムでそのときに行われているジョブは消去されます。続行する前に、ジョブを保存するかバックアップしてください。
    • 起動時にビジョンシステムに割り当てられる画像バッファのデフォルト数は、ビジョンシステムの解像度と RAM サイズによって異なります。[画像最大高] の設定を調整すると、ビジョンシステムで利用可能な画像バッファの最大数が増加または減少します。必要に応じて、[画像バッファ] ダイアログを使用し、起動時にビジョンシステムに割り当てる画像バッファの数を変更してください。
    • 使用しているラインスキャンビジョンシステムの [画像最大高] が 8192 に設定されているときに、ビジョンツールの対象領域の幅を 3072 よりも大きい値に設定する必要がある場合は、数式バーから手動で領域値を入力するか、あるいはコントロール関数または構造体関数を別途作成して、ツールの内部 [領域] パラメータの代わりに参照する必要があります。

  • [ハードウェアエンコーダ]

    注: [エンコーダタイプ]、[方向]、または [画像最大高] を変更するには、次の条件を満たす必要があります。
    • AcquireImage プロパティシートの [ライントリガタイプ] パラメータを、[ハードウェアエンコーダ] に設定しておく必要があります。
    • In-Sight 5604 はオフラインになっている必要があります。
    • ユーザがフルアクセスのアクセス権を持っている必要があります。
    • [エンコーダタイプ]: ラインをトリガするために使用されるエンコーダのタイプとして、[単位相] (デフォルト) または [4 位相] を指定します。

    • [Direction (方向)]: エンコーダの方向として、[プラス] (デフォルト) または [マイナス] を指定します。このコントロールは、[エンコーダタイプ] に [4 位相] が設定されている場合に有効になります。

      注: このコントロールは、[エンコーダタイプ] に [単位相] が設定されている場合には無効化されます。

  • Diagnostics

    注: [リセット] ボタンをクリックしたとき、またはビジョンシステムをオンラインまたはオフラインに切り替えたときには、すべての診断統計情報がリセットされます。

    • [エンコーダ数]: エンコーダのステップ数 (ソフトウェアエンコーダの場合はミリ秒) を表示します。
    • [ライン数]: カウンタが前回リセットされてから現在までに実行された画像取り込みライン数の合計を表示します。
    • [ラインオーバラップ数]: エンコーダレートが大きすぎたために失われたラインの数を表示します。
    • [バッファオーバラン数]: ビジョンシステムで画像バッファが不足した回数を表示します。
    • [フレーム/秒]: 1 秒あたりに取り込まれたフレームの数を表示します。
    • [ステップ/秒]: AcquireImage 関数の [ライントリガタイプ] パラメータを [ハードウェアエンコーダ] に設定した場合は、1 秒間に外部エンコーダから受信するステップの数を表示します。AcquireImage 関数の [ライントリガタイプ] パラメータを [ソフトウェアエンコーダ] に設定した場合は、1 秒間のマイクロ秒数を表示します。

    • [リセット]: このボタンは、すべての診断統計情報を 0 にリセットします。

      注: ビジョンシステムがオンラインまたはオフラインに切り替わったときにはいつでも、統計情報がリセットされます。

関連項目

ラインスキャンデータアクセス関数

LineScanDistortion 関数

TrainLineScanDistortion 関数

Version: 5.6.0


[スタートアップ] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[スタートアップ] ダイアログでは、デフォルトのジョブやオンライン/オフラインステータスなど、In-Sight ビジョンシステムのジョブ関連の起動時オプションを指定します。ユーザ関連のスタートアップパラメータは [オプション] ダイアログで指定します。

注:
  • 変更を有効にするには、In-Sight ビジョンシステムを手動で再起動する必要があります。同様に、[スタートアップ] の設定を有効にするには、[オプション] ダイアログで In-Sight エミュレータを無効にして再有効化する必要があります。
  • 指定したスタートアップジョブが存在しない場合でも、警告は表示されません (例えば、ジョブが削除されたり、名前が変更されたりした後)。
  • ジョブサーバに保存されたジョブは、デフォルトジョブとしても使用し、スタートアップ時にビジョンシステムに自動でロードできます。[ジョブサーバの設定] ダイアログを使用して、ジョブサーバを有効にしてください。

[スタートアップ] ダイアログを表示するには

  • [センサ] メニューで、[スタートアップ] をクリックします。

    ジョブサーバが有効な場合は、以下のダイアログが表示されます。

[スタートアップ] ダイアログの設定項目

  • [起動時にジョブをロード]: このチェックボックスをオンにすると、選択したジョブがスタートアップ時に自動的にロードされます。リストには、接続されているビジョンシステム/センサ、接続されているビジョンシステムに装着されている SD カード、またはエミュレータに保存されているジョブが含まれます。

  • [起動時にリモートからジョブをロード]: このチェックボックスをオンにすると、選択したジョブがスタートアップ時に自動的にロードされます。リストには、ジョブサーバに保存されているジョブが含まれます。

    注:
    • このチェックボックスは、[ジョブサーバの設定] ダイアログでジョブサーバが有効化されている場合にのみ表示されます。
    • ジョブサーバを有効にすると、ジョブサーバ内に保存したジョブを選択できるようなります。ビジョンシステム上に保存したジョブをスタートアップ時にロードするには、ジョブサーバを無効にしてください。

  • [起動時にオンラインモードにする]: このチェックボックスをオンにすると、アクティブな In-Sight ビジョンシステム/センサがオンラインモードで起動します。

    注: ロボットなどの外部デバイスが不意に作動するのを防止するための安全手段として、In-Sight ビジョンシステムでは、[オンライン] チェックボックスがオンの場合、ジョブのロード時に初期化画像を自動的に取得しません。このため、最初の取得トリガを受信するときに、通常のジョブの処理時間よりも処理に時間を要します。後続の画像は通常の速度で処理されます。


[センサフィルムストリップの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[センサフィルムストリップの設定] ダイアログでは、次の内容を含む、個々のセンサのフィルムストリップの動作を指定することができます。

  • センサに保存される結果の種類。
  • センサに保存される結果の数。
  • 結果の成功または失敗ステータスを決める要素。
  • 失敗結果が検出されたときのフィルムストリップの動作。

[センサフィルムストリップの設定] ダイアログを表示するには[センサフィルムストリップの設定] ダイアログ

  • [センサ] メニューで、[センサフィルムストリップの設定] をクリックします。

[センサフィルムストリップの設定] ダイアログの設定項目

注: センサの電源を入れ直したり、[キュー]、[キューのサイズ]、または [キューの種類] 設定を変更したりすると、すべての結果が削除されます。

  • [キュー]: センサに保存される結果の種類。
    • [無効] (デフォルト): 結果は保存されません。
    • [成功結果]: 成功結果が保存されます。
    • [失敗結果]: 失敗結果が保存されます。
    • [成功/失敗結果]: 成功結果と失敗結果が保存されます。

    • [成功/失敗結果を分ける]: 成功と失敗の結果は保存され、[成功結果] ボタンと [失敗結果] ボタンの切り替え状態に応じて、フィルムストリップ内に同時または別々に表示可能です。

      注:

      • [成功/失敗結果を分ける] が選択されている場合:
        • [キューのサイズ] ドロップダウンが無効になります。
        • [PASS サイズ] および [FAIL サイズ] ドロップダウンが有効になります。
        • [成功結果] および [失敗結果 ] ボタンがフィルムストリップの隣に表示されます。これらのボタンを切り替えて、フィルムストリップに成功/失敗結果を表示します。

  • [キューのサイズ]: センサに保存される結果の数。ビジョンシステムの解像度とセンサで使用できる RAM に応じて、最高 20 個の結果を保存できます。指定した [キューのサイズ] がセンサの使用可能 RAM を超えていた場合は、可能な最大数の結果が自動的にビジョンシステムに割り当てられます。

    注: このオプションは、[成功/失敗結果を分ける] が [キュー] ドロップダウンから選択されている場合には無効になります。

  • [PASS サイズ]: ビジョンシステムに保存される成功結果の数。[PASS サイズ] および [FAIL サイズ] の総計は、ビジョンシステムがサポートする [キュー] サイズを超過することはできません。 [キュー] ドロップダウンから、[成功/失敗結果を分ける] が選択されている場合のみ、このオプションは有効になります。(最小 = 1)

  • [FAIL サイズ]: ビジョンシステムに保存される失敗結果の数。[PASS サイズ] および [FAIL サイズ] の総計は、ビジョンシステムがサポートする [キュー] サイズを超過することはできません。 [キュー] ドロップダウンから、[成功/失敗結果を分ける] が選択されている場合のみ、このオプションは有効になります。(最小 = 1)

  • [キューのタイプ]: センサへの結果の保存方法を決めます。保存される結果の数は、[キューのサイズ] によって異なります。例えば、[キューのサイズ] が 10 であり、[キューのタイプ] として [最初のみ] を選択した場合は、最初の 10 個の結果だけが保存されます。[キューの種類] として [最後] を選択した場合は、最新の 10 個の結果だけが保存されます。
    • [最初のみ]: 最初の X 個の結果が保存されます。X は [キューのサイズ] です。
    • [最後] (デフォルト): 最新の X 個の結果が保存されます。X は [キューのサイズ] です。
  • [表示モード]: 監視セルの結果が失敗ステータスを受け取ったときのフィルムストリップの動作です。
    • [失敗時に停止]: 監視セルの結果が失敗ステータスを受け取った場合、結果はフィルムストリップに追加され、[再開] ボタンをクリックするまで、フィルムストリップは更新を停止します。
    • [失敗時に一時停止]: 監視セルの結果が失敗ステータスを受け取った場合、結果はフィルムストリップに追加され、指定した [一時停止ディレイ] の時間だけ、フィルムストリップは一時停止します。
    • [ノーマル] (デフォルト): フィルムストリップは、監視セルの結果に関係なく、更新を続行します。
  • [一時停止ディレイ]: [表示モード] として [失敗時に一時停止] が指定されている場合、これは、更新を再開するまでにフィルムストリップが一時停止する時間 (秒) です。(1 ～ 120、デフォルト = 5)。
  • [保存フォルダ]: フィルムストリップ画像の保存場所を指定します。ユーザは、指定した場所への書き込み権限を持っている必要があります。
  • [キューイング条件]: 監視セルの値に基づいて、成功または失敗ステータスを決めます。

  • [監視セル]: 監視対象のセルを示します。

    注:In-Sight で類似の効果を持つ監視セルが 3 つあります ([ジョブの PASS/FAIL] セル、[フィルムストリップ] 監視セル および [記録/再生] の監視セル)。これらの 3 つの監視セルを個々に設定し、異なる機能を制御することができます。

  • [セルの選択]: [セルの選択] をクリックすると、セル選択モードに切り替わり、結果が成功または失敗のいずれのステータスを受け取るかを決める監視セルを参照することができます。
    • [セル <= 0]: 画像取り込みの際、監視セルがゼロ以下の数値を含んでいる。
    • [セル = #ERR]: 画像取り込みの際、監視セルが #ERR を含んでいる。
    • [セル > 0]: 画像取り込みの際、監視セルがゼロより大きい数値を含んでいる。
  • [LED スタイル]: 成功結果および失敗結果をフィルムストリップにステータスアイコンとして表示します。
    • [幾何]: 成功結果は緑色の円　 [image] 　で、失敗結果は赤色の矩形　 [image] 　で表示されます。
    • [OK/NG]: 成功結果は緑色の OK [image] で、失敗結果は赤色の NG [image] で表示されます。
    • [チェック/X]: 成功結果は緑色のチェックマーク　 [image] 　で、失敗結果は赤色の X [image] で表示されます。
  • [オンラインモードへの切り替え時にクリアする]: これをオンにすると (デフォルト)、センサがオンラインになるたびにフィルムストリップがクリアされます。

関連項目

フィルムストリップ

Version: 5.6.0


[RAM ディスクの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[RAM ディスクの設定] ダイアログによりユーザは、In-Sight センサまたはエミュレータのシステム RAM を利用することによって、ファイルシステムをエミュレートできます。Export/Import Cells 関数、ExportData 関数、および ImportData 関数と併用すれば、RAM ディスクにより、In-Sight センサと外部デバイス (PLC やロボットコントローラなど) の間で外部デバイスを共有できます。RAM ディスクが有効にされ、そのサイズが設定されると、[In-Sight のファイル] ペインに「RAMDisk」という名前のフォルダがセンサまたはエミュレータのサブディレクトリとして表示されます。

注:
  • ジョブ (.JOB) ファイルとセルデータ (.CXD) ファイルのみがサポートされており、RAMDisk フォルダに格納できます。
  • RAMDisk フォルダに格納されているすべてのファイルが削除されるのは、センサの電源が入れ直されるときか、RAMDisk の設定が無効にされるときです。

[RAM ディスクの設定] ダイアログを表示するには

  • [センサ] メニューで、[RAM ディスクの設定] をクリックします。

注: センサまたはエミュレータで RAM ディスクがサポートされていない場合、[RAM ディスクの設定] メニュー項目はグレーアウトされます。ファームウェアバージョン 3.20.00 以降のセンサのみがサポートされています。

[RAM ディスクの設定] の設定項目

  • [有効]: チェックボックスをオンにすると、RAM ディスクの使用が有効になります。デフォルトでは、RAM ディスクは有効ではありません。
  • [サイズ (MB)]: この設定により、RAM ディスクに保存されるデータの最大量 (メガバイト単位) が決まります。RAM ディスクは使用されるメモリの合計量を追跡し、[サイズ] 設定に対してその値を照会します。センサの最大サイズは 32MB で、エミュレータの最大設定は 64MB です。

センサまたはエミュレータの RAM ディスクへのファイルの保存

.JOB ファイルの保存

.JOB ファイルをセンサまたはエミュレータの RAMDisk フォルダに保存するには、[名前を付けて保存] ダイアログを使用し、[ファイルの場所:] ドロップダウンリストを使用してファイルの場所を目的のセンサまたはエミュレータの RAMDisk フォルダに設定します。あるいは、[In-Sight のファイル] ペインから .JOB ファイルをドラッグし、目的のセンサまたはエミュレータの RAMDisk フォルダにドロップすることもできます。または、[In-Sight のファイル] ペインで右クリックのショートカットメニューを使用し、.JOB ファイルをコピーして RAMDisk フォルダに貼り付けることもできます。

.CXD ファイルの保存

複数のスプレッドシートのセルを .CXD ファイルに保存し、そのファイルをセンサまたはエミュレータの RAMDisk フォルダにエクスポートするには、[セルのエクスポート] ダイアログを使用し、目的のセンサまたはエミュレータの RAMDisk フォルダを指定します。単一セルのデータを .CXD ファイルに保存し、そのファイルをセンサまたはエミュレータの RAMDisk フォルダにエクスポートするには、ExportData 関数を使用して、目的のセンサまたはエミュレータの RAMDisk フォルダを指定します。

注:
  • ファイルに名前を付けるときには、円記号 (¥) を使用しないでください。名前に円記号が含まれているファイルは、ファイル名を変更して円記号をなくしてからでなければ、コピーや削除ができません。また、ファイル名に円記号が含まれていると、リストア操作の際にエラーが発生します。
  • RAMDisk フォルダでは大文字と小文字が区別されませんが、RAMDisk フォルダの名前を変更することはできません。RAMDisk フォルダ自体はコピーされませんが、フォルダの内容はコピー可能です。

センサまたはエミュレータの RAM ディスク内のファイルへのアクセス

.JOB ファイルを開く

センサまたはエミュレータの RAMDisk フォルダの .JOB ファイルを開くには、[開く] ダイアログを使用し、[ファイルの場所:] ドロップダウンリストを使用してファイルの場所を目的のセンサまたはエミュレータの RAMDisk フォルダに設定します。

.CXD ファイルを開く

センサまたはエミュレータの RAMDisk フォルダを開くには、[セルのインポート] ダイアログ (複数のスプレッドシートセルを含むファイルの場合) または ImportData 関数 (単一セルのデータを含むファイルの場合) を使用し、目的のセンサまたはエミュレータの RAMDisk フォルダを指定します。

RAMDisk ファイルへのリモートアクセス

センサまたはエミュレータの RAMDisk フォルダのファイルにリモートアクセスする場合は、次のファイル名のプロトコルに従います。

  • In-Sight センサ: 「ramdisk/filename.type」
  • FTP コマンドプロンプトを使用して Closed センサに接続します。

注:
  • FTP コマンドの CD (change directory) はサポートされません。
  • Web ブラウザから FTP を使用して RAMDisk フォルダにアクセスすることはできません。
  • ネイティブモード: 「[Command]RAMDisk/filename.job」。例えば、Read File ネイティブモードコマンドを使用して「Model.job」ファイルを読み取るには、「RFRAMDisk/Model.job」コマンドを発行します。

注: Get Filelist ネイティブモードコマンドを使用して RAMDisk フォルダからファイルリストを取得することはできません。RAMDisk フォルダのファイルリストを取得するには、代わりに FTP プロトコルを使用してください。


[アクティブセル制限] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[アクティブセル制限] ダイアログは、プログラマブルなスプレッドシートのセル数を設定するために使用します。このダイアログを使用すると、特定の In-Sight センサまたはビジョンシステムが使用できるジョブ内のセル数を増減できます。

[アクティブセル制限] ダイアログを表示するには

[センサ] メニューで [アクティブセル制限] を選択します。

[アクティブセル制限] ダイアログの設定項目

スライダコントロールを使用すると、スプレッドシートのプログラム可能なセルの数を設定できます。スライダを調整して、プログラム可能なセルの数を設定します。

In-Sight ビジョンシステムのアクティブセル制限を調整するには、ビジョンシステムを再起動する必要があります。再起動を行うと、すべてのジョブと設定ファイルが不揮発性フラッシュメモリから消去されます。続行する前に、ジョブを保存するかバックアップしてください。

注: アクティブセル制限の更新中は、ビジョンシステムの電源は落とさないでください。

アクティブセル制限

 | 最小 | デフォルト | 最大
In-Sight ビジョンシステム | 2048 | 6144 | 10400

注: In-Sight 5000 では [アクティブセル制限] ダイアログは無効になっています。最小および最大のアクティブセル制限値は 4,096 であり、変更できません。


[プロファイラ] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[プロファイラ] ダイアログには、数式またはデータを含むアクティブなジョブに関する、すべてのセルの依存関係と実行時間が表示されます。テキストまたは定数だけを含むセルは除外されます。

  • 概要
  • [プロファイラ] ダイアログの表示
  • [プロファイラ] ダイアログの列
  • [プロファイラ] ダイアログの設定項目

概要

依存関係と実行時間の情報は、スプレッドシートのパフォーマンスを上げる際に最も有用です。なぜなら、実行に最も時間のかかる関数を簡単に探し出し、最適化することができるからです。[プロファイラ] ダイアログは、In-Sight ジョブでエラー (#ERR) の原因となっている数式や関数を調べる際にも有効です。

注:
  • 同じジョブを異なる In-Sight ビジョンシステムモデルや In-Sight エミュレータで実行した場合、実行時間は各システムの処理能力と画像解像度によって異なります。
  • [プロファイラ] ダイアログは、オンラインモード時や、現在のユーザがプロテクトまたはロックのアクセスレベルでログオンしている場合にはアクセスできません。
  • [プロファイラ] ダイアログでは、ネットワークまたはシリアル通信、ディスクリート入出力、ビジョンシステムのオンボード画像取り込みトリガなど、イベントで駆動される操作のタイミングデータは表示されません。
  • [プロファイラ] ダイアログで計算される時間は、ステータスバーおよび GetAllTime 関数で計算される時間とは異なります。また、[ジョブのプロファイル] ダイアログでは結果のグラフィックスの構築についても説明します。ほかの 2 つのはこれを行いません。

[プロファイラ] ダイアログの表示

  • ビジョンシステムメニューで、[ジョブのプロファイル] をクリックします。

[プロファイラ] ダイアログの列

ヒント:
  • [プロファイラ] のデータは、列見出しをクリックすることによってソートできます。また、2 つの列の間の区切り線をドラッグすることによって、列のサイズを変更できます。
  • [プロファイラ] ダイアログ内のセルをハイライトすると、スプレッドシート内のセルが検索されます。
  • [順序]: セルはスプレッドシートでの実行順にリストされます。ただし、[依存関係] チェックボックスがオンの場合を除きます。[依存関係] チェックボックスがオンのときには、セルは選択したセルに対して相対的な依存関係の順にリストされます。
  • [セル]: 実行プロファイルに含まれるセルをリストします。この表には、[構造体のみ] チェックボックスがオンの場合を除き、使用されているセルすべてが表示されます。デフォルトで、セルはスプレッドシートでの実行順にリストされます。
  • [結果]: 各セルに含まれている現在の値を示します。構造体を含んでいるセルは、実行が成功の場合は Pass を示し、失敗の場合は #ERR を示します。
  • [時間]: 各セルの数式の実行時間 (ミリ秒単位) を示します。
  • [状態]: 各セルのセル状態を示します。[状態] 列に「X」と表示される場合、対応するセル状態は「有効」です。「-」と表示される場合、対応するセル状態は「無効」です。
  • [式]: 各セルに含まれている数式を示します。

ヒント: 式が長すぎて、デフォルトのダイアログサイズではすべてを表示できない場合は、数式全体が表示されるように、ダイアログのサイズを変更してください。

[プロファイラ] ダイアログの設定項目

  • [画像取り込み]: 新しい画像を取り込み、ジョブを実行して、[プロファイラ] の表を更新します。このボタンを押すと、時間が画像取り込み時間、ジョブ実行時間、結果のグラフィックスの生成時間に等しくなります。
  • [実行開始位置]: このボタンは、新しい画像を取り込まず (AcquireImage 関数の実行時間も更新せず)、ハイライトされているセルとそれらの依存関係だけを実行します。ほかのどのセルも実行されず、その結果も示されません。

注: [実行開始位置] ボタンを押したとき、以前に画像が取り込まれていた場合は、表には以前の画像取り込み時間がそのまま表示されていますが、この時間はジョブ時間の計算には含められません。

  • [構造体のみ]: このチェックボックスをオンにすると、[プロファイラ] ダイアログの表示が、データ構造体を含んでいるセルのみに限定されます。
  • [依存関係]: このチェックボックスをオンにすると、選択したセルに相対的な依存関係の順にセルがリストされ、リスト内の各セルの依存関係インジケータが表示されます。選択したセルは、 [image] 　印の付いたすべてのセルに依存しています。 　印の付いたセルは、選択したセルに直接依存しています。二重矢印は間接依存を示します。
  • [総合時間]: [画像取り込み] ボタンを押して [プロファイラ] ダイアログを更新した場合、[総合時間] には、画像取り込みの時間も含めて、リスト内のすべてのセルの実行時間の合計が表示されます。[実行開始位置] ボタンを押した場合、[総合時間] には、ハイライトしたセルとその依存関係のそれぞれの合計実行時間が表示されます。
  • [利用可能セル数]: スプレッドシートで現在編集できるセルの数を示します。
  • [リストとしてコピー]: [プロファイラ] ダイアログの内容をクリップボードにコピーして、Microsoft Word または Excel に貼り付けることができます。

注: メモリを大量に消費する関数がジョブファイルに含まれていた場合、[利用可能セル数] の合計数を使用する前に、ビジョンシステムがメモリ不足になることがあります。


[ジョブの PASS/FAIL セルの設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

[ジョブの PASS/FAIL セルの設定] ダイアログでは、数値の結果を含むセルをモニタし、ジョブ全体の成功/失敗ステータスを判定できます。ジョブのステータスは、センサからの出力として、Cognex VisionView などそのほかのアプリケーションへ送信することができます。

注:
  • [ジョブの PASS/FAIL セルの設定] ダイアログを使用できるのは、admin レベルのユーザだけです。

  • In-Sight で類似の効果を持つ監視セルが 3 つあります ([ジョブの PASS/FAIL] セル、[フィルムストリップ] 監視セル および [記録/再生] の監視セル)。これらの 3 つの監視セルを個々に設定し、異なる機能を制御することができます。

  • デフォルトでは、EasyBuilder ビューに表示されるすべての EasyBuilder ジョブが、同じジョブの PASS/FAIL セルを参照します。このセル参照が [ジョブの PASS/FAIL セルの設定] ダイアログで変更された場合でも、EasyBuilder ビューでジョブが再表示されると、参照先はデフォルトのセルに戻ります。

ジョブの PASS/FAIL セルを設定するには

  1. [ジョブの PASS/FAIL セルの設定] ダイアログを表示するには、[センサ] メニューの [ジョブの PASS/FAIL] をクリックします (または、セルを右クリックし、[ジョブの PASS/FAIL] をクリックします)。
  2. [ジョブの PASS/FAIL セルを使用する] チェックボックスをオンにし、ダイアログ内のほかのコントロールにアクセスできるようにします。

  3. [セルの選択] をクリックし、[ジョブの PASS/FAIL セルの設定] ダイアログをセル選択モードに切り替えます。
  4. スプレッドシート内の対象のセルを選択し、Enter キーを押してセルの選択を確定します。[ジョブの PASS/FAIL セルの設定] ダイアログが再表示され、[ジョブの PASS/FAIL セル] フィールドに選択したセル参照が示されます (セルをダブルクリックするか、または [ジョブの編集] ツールバーの [OK] [image] ボタンをクリックすることでもセルの選択を確定できます)。
  5. [ジョブのステータス] ドロップダウンリストで、ジョブの成功/失敗の数値結果をジョブの成功/失敗ステータスにマップする方法を定義します。ステータスのオプションには、[なし]、[PASS]、[FAIL]、または [警告] があります。
    • [セル値 < 0]: 選択したセルに、ゼロより小さい数値が含まれています。(デフォルト = FAIL)
    • [セル値 = 0]: 選択したセルに、数値ゼロが含まれています。(デフォルト = FAIL)
    • [セル値 > 0]: 選択したセルに、ゼロより大きい数値が含まれています。(デフォルト = PASS)

    6. 注: 次の場合は、ジョブステータスが自動的に割り当てられます。
    • セルに、#ERR 以外の数値ではない結果が含まれている (例: 文字列): PASS
    • セルが空である: なし
    • セルに #ERR が含まれている: FAIL
    • セルが選択されていない: なし

  6. [OK] をクリックします。


ビジョンツール

In-Sight 関数リファレンス

In-Sight ビジョン処理ツールは、画像の特徴を抽出および処理して、さらにデータ分析を実行して意思決定を行うための関数で構成されます。ビジョンツールは、[関数の挿入] ダイアログまたは [パレット] の関数を使ってスプレッドシートに挿入されます。ビジョンツールには以下が含まれます。

  • ブロブ: 画像領域からブロブデータを抽出、選択、ソートします。このタイプのビジョン処理は、連結性解析と呼ばれることがあります。
  • カラー: カラーデータを抽出し、検出した色を登録済みモデルと照合します。
  • エッジ: 直線エッジとカーブエッジを特定します。エッジをペアにソートします。エッジ統計を計算します。
  • 傷検出関数: 許容できないばらつきがないか、部品または製品に対して高度な検出機能を実行します。
  • ヒストグラム: 統計画像分析と特徴分類を目的に画像のピクセル数をカウントします。
  • ID: 線形バーコード、1D バーコード、2D マトリックスコードを読み取り、検証します。
  • 画像: 不必要な特徴を削除するか弱めながら、必要とされる特徴が強調されるように画像を処理します。
  • InspectEdge: 欠陥を検出するために、高度なエッジ分析を実行します。
  • 文字照合/認識関数: 画像内の文字列の読み取り (OCR) と検証 (OCV) のために、フォントをセグメント化、抽出、登録します。
  • パターンマッチ関数: これまでに定義したパターンに対して最大の類似性を示す、画像内の特徴を特定します。

注:関数とビジョンツールが使用可能かどうかは、特定の In-Sight ビジョンシステムとファームウェアによって異なります。特定の関数とビジョンツールが使用可能かどうかの詳細については、Cognex 販売代理店にお問い合わせください。


プロパティシート

ユーザインタフェース

In-Sight Explorer GUI リファレンス

プロパティシートについて

プロパティシートを表示するには

プロパティシートからセルグラフィックスを編集するには

セルグラフィックスの領域を最大化するには

プロパティシートに関数を挿入するには

プロパティシートからセル参照を挿入するには

プロパティシートのショートカット

プロパティシートについて

プロパティシートは、関数が構造体を返すとき、または関数に多くの入力パラメータがあるときに、In-Sight Explorer の関数を設定するために使用します。

注: 可変数のパラメータを受け入れる関数 (オペレータ I/F 関数の ListBox、Select、Wizard など) には、プロパティシートはありません。これらの関数は、セルで直接設定するか、[ジョブの編集] ツールバーの数式バーで設定します。プロパティシートがあるのは、固定数のパラメータを持つ関数だけです。

すべてのプロパティシートには、関数のデフォルトのパラメータ、値、および式を示す表が表示されます。プロパティシートの各行は、パラメータの名前と値、または展開/折り畳み可能なパラメータと値のグループで構成され、展開と折り畳みは [image] / [image] 記号で示されます。

ヒント: プロパティシートのパラメータは、設定項目をドラッグ & ドロップして、スプレッドシートに配置することができます。プロパティシートからパラメータを選択してから、それをスプレッドシートにドラッグすることによって、パラメータのラベルとエディットコントロールが自動的に作成され、スプレッドシートで参照できるようになります。例えば、ExtractBlobs 関数のプロパティシートが開いている場合に、[しきい値] パラメータをスプレッドシートのセル A2 にドラッグ & ドロップすると、セル A2 に「Threshold (しきい値)」というテキストが入力され、セル A3 に EditInt 関数が入力されます。この場合、ExtractBlobs 関数のプロパティシートにある [しきい値] パラメータが、自動的にセル A3 への絶対参照として設定されます。

パラメータの値は、以下の方法で割り当てることができます。

  • セル参照: 値は、スプレッドシート内のセルへの絶対参照または相対参照のいずれかによって決まります。

注: In-Sight Explorer の実行時には、パラメータ値をダブルクリックして Esc キーを押すと、そのパラメータのテキストがオペレーティングシステムのクリップボードにコピーされ、以前にコピーされたすべてのテキストが上書きされます。プロパティシートの編集時には、パラメータをダブルクリックするのではなく、プロパティシートのメニューまたはツールバーボタンを使用してパラメータを編集することを推奨します。

  • 座標: 値は、対話型グラフィックスモードに切り替えることによって、または座標の数値を手動で入力することによって決まります。
  • 整数: 　ボタンをクリックすることによって値を増減したり、目的の数値を手動で入力したりすることができます。
  • テキスト: 値は英数字によって表されます。
  • チェックボックス: チェックボックスがオフのときには 0 の値が割り当てられ、チェックボックスがオンのときには 1 の値が割り当てられます。
  • ドロップダウンリスト: 値は、リスト内の選択項目から選択されます。値は、リストから選択された項目のインデックス番号 (ゼロから始まります) に設定されます。

注: プロパティシートのパラメータは、操作手順の状況によって異なります。したがって、メニューバーとツールバーは、選択したパラメータが特定の編集または挿入操作をサポートしている場合のみ有効になります。

プロパティシートを表示するには

[関数の挿入] ダイアログを使用して、スプレッドシートのセルに関数を挿入します。関数にプロパティシートがある場合には、プロパティシートが自動的に開きます。

各プロパティシートは、以下のもので構成されています。

  • センサ、ダイアログ、および関数の名前を示すタイトルバー
  • メニューバー
  • ツールバー
  • パラメータ設定領域
  • 状況依存ヘルプ

注: テキストが赤色でハイライト表示された場合は、値にエラーが含まれており、確定するにはそのエラーを修正する必要があります。別のパラメータまたは [OK] ボタンを選択すると、エラー部分はそれ以前に指定されていた有効な値に戻ります。

プロパティシートでセルグラフィックスを編集するには

  1. セルグラフィックスが関連付けられているパラメータをクリックします。
  2. プロパティシートの [編集] メニューの [グラフィックス] をクリックします。または、プロパティシートのツールバーにある [グラフィックスの編集] [image] ボタンをクリックするか、セルグラフィックスが関連付けられているパラメータ名をダブルクリックします。プロパティシートが消えて、画像の上に対話型グラフィックスが表示されます。

注: 選択したパラメータにセルグラフィックスが関連付けられていない場合、[グラフィックスの編集] メニューおよびツールバーボタンは、グレーアウトされます。

  3. 変更を確定するには、[ジョブの編集] ツールバーの [OK] ボタンをクリックするか、Enter キーを押すか、セルグラフィックス内をダブルクリックします。変更をキャンセルするには、[ジョブの編集] ツールバーの　[キャンセル] ボタンをクリックするか、Esc キーを押します。

セルグラフィックスの領域を最大化するには

  1. セルグラフィックスが関連付けられているパラメータをクリックします。
  2. プロパティシートの [編集] メニューの [領域の最大化] をクリックします。または、プロパティシートのツールバーにある [領域の最大化]　 [image] ボタンをクリックします。領域のセルグラフィックスのサイズが、参照される　 [image] 　データ構造体の画像領域と同じサイズに変更されます。セル A0 は、デフォルトの画像ソースです。

注: 選択したパラメータにセルグラフィックスが関連付けられていない場合、[領域の最大化] メニューおよびツールバーボタンは、グレーアウトされます。

  3. 変更を確定するには、[OK] ボタンをクリックします。変更をキャンセルするには、[キャンセル] ボタンをクリックします。

Closed 例

  1. スプレッドシートに FindPatterns 関数を挿入します。FindPatterns のプロパティシートが自動的に開きます。[画像] パラメータの値は $A$0 であり、デフォルトの画像ソースであるセル A0 を参照しています。
  2. [サーチ領域] パラメータをハイライトします。

  3. プロパティシートの [編集] メニューの [領域の最大化] をクリックします。領域のセルグラフィックスのサイズが、参照される　 [image] 　データ構造体 (セル A0) の画像領域と同じサイズに変更されます。
  4. [モデル領域] パラメータをハイライトします。
  5. プロパティシートの [編集] メニューの [領域の最大化] をクリックします。領域のセルグラフィックスのサイズが、[サーチ領域] パラメータと同じサイズに変更されます。

プロパティシートに関数を挿入するには

プロパティシートのパラメータに関数を挿入することによって、動的引数を作成することができます。例えば、FindPatterns 関数を使用していて、変動する偏差のセットに基づいて、画像取り込みの際に [アクセプトしきい値] パラメータを動的に変更する必要がある場合には、数値演算関数をパラメータに挿入して、偏差に応じて計算することができます。パラメータに関数を追加することによって (スプレッドシート内で個別の関数を作成し、同じ数式を作成して、それらのセルを参照するのではなく)、時間とスプレッドシートの計算スペースを節約することができます。

注: 数式の最大長は 248 文字です。248 文字を超える長さの数式を入力すると、プロパティシートを閉じて変更をキャンセルするまで、In-Sight Explorer が応答しなくなる場合があります。変更はすべて失われ、更新した数式は受け付けられません。

  1. 関数を挿入したいパラメータをクリックします。

注: 折り畳まれているグループに関数を挿入することはできません。プラスボタンを押して、グループを展開しておく必要があります。次に、個々のサブパラメータを選択します。

  2. プロパティシートの [挿入] メニューの [関数] をクリックします。または、プロパティシートのツールバーにある [関数の挿入]　 [image] ボタンをクリックします。

注: 選択したパラメータが関数をサポートしていない場合、[関数の挿入] メニューおよびツールバーボタンは、グレーアウトされます。

  3. パラメータの値が編集可能な式に変わります。

  4. 手動で関数の名前を入力して、その後ろに左括弧とパラメータデータを入力するか、キーボードの ↑/↓ キーを押して、関数ボックスを開きます。関数ボックスには、適用可能な関数のリストが表示されます。

注: 関数の名前を手動で入力するときにテキストが赤色でハイライト表示された場合は、その数式にエラーが含まれており、確定するには修正する必要があります。

関数を見つけるには、関数の名前を入力するか、関数のリストをスクロールします。挿入したい関数が見つかったら、Tab キーを押すか、関数をダブルクリックします。パラメータに数値または数式がある場合、→ キーを押すと、関数ボックスに関係演算子のリストが表示されます。

注: ← キーを押すと、関数ボックスは関数選択モードに戻ります。

  5. 関数を作成したら、Tab キーを押して関数を確定し、次のパラメータに移動します。

  6. Enter キーを押すと、自動的に関数が確定されて、プロパティシートは閉じます。Esc キーを押すと、確定せずにプロパティシートを閉じます。

プロパティシートからセル参照を挿入するには

  1. セル参照を挿入したいパラメータをクリックします。
  2. プロパティシートの [挿入] メニューから、[絶対参照] または [相対参照] をクリックします。または、プロパティシートのツールバーにある [絶対参照の挿入] [image] ボタンまたは [相対参照の挿入] [image] ボタンをクリックします。プロパティシートが消えて、セル選択モードになります。

ヒント: パラメータの種類によっては、パラメータをダブルクリックしてセル選択モードに切り替えることもできます。

  3. プロパティシートのパラメータの値を含むセルを選択します。
ヒント:
  • 複数セル参照は、複数の値を持つパラメータ (フィクスチャや領域など) を定義する際に有効です。
  • パラメータにセル参照が設定されると、スプレッドシートでハイライトされます。このとき、プロパティシートを閉じずにマウスでセル参照先を移動することができます。
  • パラメータに手動で関数を入力する場合 (可能な場合)、相対セル参照カーソル [image] (Shift キーを押すと、絶対セル参照カーソル　 [image] 　に変わります) を使用してスプレッドシートのセルをクリックすると、セル参照を挿入することができます。
  4. セル参照を確定するには、[ジョブの編集] ツールバーの [OK] ボタンをクリックするか、Enter キーを押すか、セルをダブルクリックします。セル参照をキャンセルするには、[ジョブの編集] ツールバーの [キャンセル] ボタンをクリックするか、Esc キーを押します。
  5. プロパティシートの値をすべて変更した後、[OK] をクリックすると変更が適用されます。[キャンセル] を押すと、すべての変更が元に戻されて、スプレッドシートに戻ります。

プロパティシートのショートカット

[プロパティシートのショートカット]

操作 | キーボード | マウス
プロパティシートを開く | 1. 矢印キーで目的のセルに移動します。 2. Enter または Shift+F3 キーを押します。 | スプレッドシート内の関数をダブルクリックします。 または、[ジョブの編集] ツールバーで、[式] [image] ボタンをクリックします。
変更を確定する | 1. Tab キーを押して、フォーカスを [OK] ボタンまで移動させます。 2. Enter キーを押します。 | [OK] をクリックします。
変更をキャンセルする | ESC | [キャンセル] をクリックします。
パラメータの間を移動 | ↑/↓ キー Tab/Shift+Tab キー | 移動先のパラメータをクリックします。
パラメータの値を変更 | ↑/↓ キーを使用して、数を増減させることができます。 注: テキスト文字列パラメータには引用符が自動的に追加されます。 | 必要に応じて、パラメータのエディットコントロール ( [image] など) を使用して値を調整します。
パラメータの最大値を設定する | Ctrl+↑ キー | なし
パラメータの最小値を設定する | Ctrl+↓ キー | なし
関数を挿入する | Ctrl+Shift+F キー | プロパティシートのツールバーにある [関数の挿入] [image] ボタンをクリックします。
絶対セル参照を挿入 | Ctrl+Shift+A キー | プロパティシートのツールバーにある [絶対参照の挿入] [image] ボタンをクリックします。
相対セル参照を挿入 | Ctrl+Shift+R キー | 相対セルを挿入するパラメータの数値または式が入力されているセルをダブルクリックします。 または プロパティシートのツールバーにある [相対参照の挿入] [image] ボタンをクリックします。
プロパティグループを展開 | プラス (テンキーの +) キー | プラス記号 [image] をクリックするか、関数をダブルクリックします。
プロパティグループを折り畳む | マイナス (テンキーの -) キー | マイナス記号 [image] をクリックします。
ドロップダウンリストを展開 | Alt+↓ キー | ドロップダウンリストの [image] コントロールをクリックします。
ドロップダウンリストを折り畳む | Alt+↑ キー | ドロップダウンリストの [image] コントロールをクリックします。
ドロップダウンリストの項目を移動 | ↑ キー ↓ キー | 目的の値を選択します。
対話型グラフィックスを編集 | F9 | プロパティシートのツールバーにある [セルグラフィックスの編集] [image] ボタンをクリックします。
セルグラフィックスの領域を最大化する | Ctrl+Shift+M キー | プロパティシートのツールバーで、[領域の最大化] [image] ボタンをクリックします。
1 プロパティシートがない関数の場合は、代わりに [関数の挿入] ダイアログが開きます。 2 特定の関数 (コントロールなど) は、セルで Enter キーを押したときに特別な操作が行われます。これらの関数については、Shift+F3 キーを押してプロパティシートを開いてください。

関連項目

[関数の挿入] ダイアログ

セル参照

対話型グラフィックスモード

Version: 5.6.0


AcquireImage 関数

In-Sight 関数リファレンス

デジタル画像を取り込み In-Sight ビジョンシステムのメモリに転送するための、In-Sight ビジョンシステムのパラメータを指定します。

  • 画像取り込みについて
  • AcquireImage 関数の入力パラメータ
  • AcquireImage 関数の出力

画像取り込みについて

In-Sight ビジョンシステムは、非同期リセットとプログレッシブスキャンを使用してすべての画像を取り込みます。グレースケールの In-Sight ビジョンシステムは 8 ビットの画像を生成し、カラーの In-Sight ビジョンシステムは 24 ビットの画像を生成します。すべてのセンサで約 250µs 以内に画像取り込みが開始され、次のように進行します。

  • 画像センサは、[露光時間] パラメータで設定された時間の間、光を蓄積します。
  • 画像センサに蓄積された画像は行単位でシリアルシフトレジスタに転送されます。

  • すべての行転送に対し、センサはピクセルごとに画像センサ外部でシフトレジスタをクロッキングして、次の経路を通じてピクセル値を転送します。

    ビデオ増幅器 → ゲインおよびオフセット → A/D コンバータ → In-Sight センサのメモリ

  • 転送は取り込み開始行から開始され、指定された行数が処理されます。

取り込まれた画像を含むメモリバッファは、スプレッドシート内で　 [image] データ構造体として表されます。AcquireImage 関数によって返される [image] データ構造体は、画像領域を処理するスプレッドシートのほかの関数によって順番に参照されます。取り込まれた画像データに直接あるいは間接的に依存する関数はすべて、新しい画像が取り込まれるたびに更新されます。入力画像とスプレッドシート内のほかの関数との関係が、In-Sight ビジョンシステムで実行される画像処理タスクを決定します。

依存関係およびセルの実行順序の詳細について

注:
  • スプレッドシート内のほかの関数と異なり、AcquireImage 関数はセル A0 内に常駐しているため、スプレッドシートから切り取ったり、コピーしたり、クリアしたりすることはできません。この制限によって、画像が必ずあらかじめ定義された位置にあることが保証されます。これを利用して、ほとんどのビジョンツール関数や、ほかの多くの関数では、デフォルトの画像ソースとしてセル A0 を絶対参照するように指定しています。
  • デフォルトの AcquireImage パラメータ設定は、ビジョンシステムモデルに基づいて変わります。ジョブをあるモデル上で開発した後、異なるモデル上にロードした場合は、パラメータ設定が適切に構成されていることを検証します。
  • AcquireImage 関数のパラメータがプログラムによって変更された場合、この関数が変更されたパラメータをいつ表示するかは、選択した [トリガ] パラメータに応じて決まります。[トリガ] パラメータを [カメラ] に設定した場合、AcquireImage 関数のパラメータは、取り込まれた直後にロードされます。したがって、例えば、関数の [最大露光時間] の値がプログラムによって調整された場合、この変更は次の画像では不可視ですが、次の次では可視となります。その他すべての [トリガ] パラメータモードでは、取り込みの信号が受信されるとこのパラメータ値がロードされるので、変更は次の画像で反映されます。
  • [キャンセル] ボタンを使用して AcquireImage プロパティシートを閉じると、予期しない結果になる場合があります。現在、In-Sight 5000 シリーズビジョンシステムで画像が表示され、AcquireImage プロパティシートが開かれており、[キャンセル] ボタンをクリックしてプロパティシートを閉じると、表示されている画像またはプロパティシートは開かれる前のステータスに復元されません。AcquireImage プロパティシートを開くと、ビジョンシステムは、[キャンセル] ボタンを使用してプロパティシートを閉じたかどうかに関係なく新たに取り込んだ画像を表示します。新しい画像とプロパティシートへの変更は、表示された画像とプロパティシートの両方で保持されます。現在表示されている画像が必要な場合は、画像を保存してから AcquireImage プロパティシートを開き、その後、画像を再ロードします。
  • In-Sight エミュレータに接続しており、部分取り込みパラメータ ([取り込み開始行] および [行数]) が有効な状態で画像を取り込んだ In-Sight ビジョンシステムからの画像を表示する場合は、エミュレータの [取り込み開始行] および [行数] パラメータを、画像を取り込んだ In-Sight ビジョンシステムのパラメータ値と同じ値に設定します。
  • カラーの In-Sight ビジョンシステムを使用している場合、ホワイトバランスが、照明条件の変化に合わせて色を補正するための手段として多く使用されます。AcquireImage 関数のプロパティシートを開く前に白いフィールド画像 (白紙の断片など) を取り込む必要があります。画像が飽和状態 (すべてのピクセル値が 255) に近づかないようにレンズの絞りを調整する必要があります。[ホワイトバランス] ボタンを押すことは、スプレッドシートの WhiteBalance 関数を実行することと同じです。
  • In-Sight 5.x.x ファームウェアを搭載する In-Sight ビジョンシステムまたはセンサに電源が再投入され、Ethernet 接続が検出されなかった場合は、30 秒のネットワークタイムアウトが完了し、ビジョンシステム/センサが完全に再起動するまでは、トリガが失敗した状態となることがあります。

AcquireImage 関数の入力パラメータ

AcquireImage 関数(

トリガ,

手動,

露光時間,

自動露光.モード,

自動露光.最大露光時間,

自動露光.目標輝度,

Auto Expose Region.X,

Auto Expose Region.Y,

Auto Expose Region.High,

Auto Expose Region.Wide,

取り込み開始行,

行数,

ラインの数,

照明制御.モード,

照明制御.照明 0,

照明制御.照明 1,

照明制御.未使用,

照明制御.未使用,

ゲイン,

オフセット,

Orientation,

ネットワークトリガ.マスタ,

ネットワークトリガ.マスタ名,

ネットワークトリガ.マスタデータ,

バッファモード,

遅延,

フォーカスメトリクス領域.X,

フォーカスメトリクス領域.Y,

フォーカスメトリクス領域.高さ,

フォーカスメトリクス領域.幅,フォーカスメトリクス領域.角度,

フォーカスメトリクス領域.カーブ,

ホワイトバランス領域.X,

ホワイトバランス領域.Y,

ホワイトバランス領域.高さ,

ホワイトバランス領域.幅,

ラインスキャン.ライントリガタイプ,

ラインスキャン.ライン間隔/ラインごとのステップ数,

ラインスキャン.エンコーダ画像取り込み時のタイムアウト,

ラインスキャン.Clip Mode,

トリガデバウンス

)

トリガ

In-Sight ビジョンシステムがオンライン時の画像取り込みトリガのソースを指定します。

注: センサがオンラインの間、[トリガ] パラメータの値を変更しないでください。変更すると、センサが予期しない状態になることがあります。

0 = カメラ (デフォルト)

ビジョンシステムの専用取り込みトリガ入力において検出される立ち上がりエッジで画像取り込みを有効にします。

注: [エラー: 画像取り込みミス] の出力信号は、[トリガ] パラメータが [カメラ] に設定されている場合のみサポートされます。

1 = 連続

「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。

2 = 外部トリガ

シリアルコマンドで ([DeviceNet モードの詳細設定] ダイアログで [第一バイトでトリガをかける] が ON になっている場合)、画像取り込みトリガとして設定されているディスクリート入力ラインに適用された立ち上がりエッジで、または産業用イーサネットプロトコルを使用する PLC からのいずれかで、画像取り込みを有効にします。

注:
  • トリガレートを上げるには、画像取り込みトリガとして構成された汎用入力ラインを使ってビジョンシステムをトリガ (AcquireImage 関数の [トリガ] パラメータを [外部] に設定) するのではなく、ビジョンシステムに組み込まれている取り込みトリガ入力を使用 (AcquireImage 関数の [トリガ] パラメータを [カメラ] に設定) します。
  • AcquireImage 関数の [トリガ] パラメータを [外部] に設定し、取り込みに失敗すると、「エラー:画像取り込み失敗」出力はビジョンシステムから送信されません。「エラー: 画像取り込み失敗」シグナルは、AcquireImage 関数の [トリガ] パラメータが [カメラ] に設定されている場合にだけサポートされます。

5 = タイムスタンプ

タイムスタンプトリガが EtherNet/IP 経由で PLC からビジョンシステムに送信されたときに、画像取り込みを有効にします。

注:
  • [タイムスタンプ] オプションは、128MB の不揮発性フラッシュメモリ付き In-Sight 5000 シリーズビジョンシステムで、バージョン 4.5.0 以降のファームウェアが実行されている場合のみ使用できます。In-Sight 5605 ビジョンシステム、ハードウェアタイプ 821-0032-1R は例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム、ハードウェアタイプ 821-0032-2R は CIP-Sync をサポートしています。
  • このビジョンシステムでタイムスタンプの画像取り込みトリガを選択するには、[日付/時刻の設定] ダイアログの [時刻同期を使用する] オプションを有効にしておく必要があります。
  • ビジョンシステムが受け取ったタイムスタンプトリガが期限切れの場合、または 1 時間以上先である場合、TimeTriggerFault が設定され、Eip.TimestampTriggerFaults カウントが増分されます。
  • 既にほかの取り込みが進行中のために、計画されていた取り込みが実行できなかった場合、ビジョンシステムから Missed Acquisition 信号が送信されます。
  • SetSystemConfig("Eip.TriggerTimestampInputOffset",0) コマンドを使用して、このオフセットを EtherNet/IP 入力アセンブリに設定することができます。
6 = 産業用イーサネット

EtherNet/IP、POWERLINK、PROFINET、SLMP スキャナ、または Modbus TCP サーバなどの産業用イーサネットプロトコルから開始されたトリガによる画像取り込みを有効にします。

注: ネットワーク設定がプロトコルに対して正しく有効化されていることを検証してください ([ネットワーク設定] ダイアログの [産業用イーサネットプロトコル] グループボックス)。

次の表は、それぞれのプロトコルを使用してビジョンシステムをトリガする方法を示しています。詳細については、表内にあるリンクをクリックしてください。

プロトコル | ファームウェア バージョン | ハウツー
EtherNet/IP | 5.x.x | 出力アセンブリ - インスタンス 22 (バイト 0) でビット 1 をトグルする
 | 4.x.x | 出力アセンブリ - インスタンス 21 (バイト 0) でビット 1 をトグルする
POWERLINK | 4.x.x | 制御オブジェクトでビット 1 をトグルする
PROFINET | 5.x.x | 画像取り込み制御モジュールでビット 1 をトグルする
 | 4.x.x | 画像取り込み制御モジュールでビット 1 をトグルする
SLMP スキャナ | 5.x.x | ビジョンコントロールブロック (バイト 0) でビット 1 をトグルする
 | 4.x.x | ビジョンコントロールブロック (バイト 0) でビット 1 をトグルする
Modbus TCP サーバ | 5.3.0 以降 | ビジョンコントロールブロック (バイト 0) でビット 1 をトグルする

32 = 手動

F5 キーが押されたときに、画像取り込みを有効にします。F5 キーを使用して手動で画像を取り込むには、スプレッドシートにフォーカスがある必要があります。

99 = ネットワーク

ネットワーク上の特定の In-Sight "マスタ" システムがトリガされたときに、画像取り込みを有効にします。[マスター] チェックボックスを OFF にし、有効なマスタ名を指定する必要があります。

手動

In-Sight センサがオフラインのときに、手動による画像取り込みトリガを有効にします。

0 = OFF | センサがオフラインのときに、画像取り込みの開始を無効にします。[手動] が OFF に設定され、センサがオフラインの場合は、画像取り込みはいかなる方法でも実行できません。
1 = ON (デフォルト) | アクティブなセンサがオフライン時の画像取り込みの開始を有効にします。[手動] が ON のときに、センサがオフラインの場合は、F5 キーを押すか、([ジョブの表示] ツールバーの) [トリガ] [image] ボタンを押すと、画像取り込みが開始されます。

露光時間

露光時間をミリ秒単位で指定します。センサがトリガ信号を受信すると、指定された露光時間の間、画像センサ (CCD または CMOS) アレイに光が蓄積されます。モーションを停止するには露光時間が短い方が好都合ですが、十分な画像濃度を実現するために、レンズの絞りを開放したり、増幅器のゲインを上げたりする必要があります。

注:
  • [自動露光] が ON のとき、[露光時間] の設定は無効になります。
  • 露光時間は、指定したセンサ用の適切な値の近似値となる 64µs の倍数で切り捨てられます。
  • このパラメータが技術的に 0 に設定されている場合、露光時間は In-Sight ビジョンシステムに依存します。露光時間の値が 0 の場合は、デフォルトで、選択したビジョンシステムの最小露光時間 (ミリ秒またはマイクロ秒単位) となります。
  • In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、「ローリングシャッターの操作」を参照してください。
  • In-Sight 5604 ラインスキャンビジョンシステムに接続されている場合、露光時間はマイクロ秒 (µs) 単位で設定されます。

  • 露光時間を計算するとき、画像取り込みフレームレートおよびジョブ実行変数によっては、照明の予熱時間を考慮するために若干の時間を露光時間に追加する必要があります。内部 LED リング照明を使用する In-Sight 70xx ～ 74xx シリーズのビジョンシステムでは、露光時間に 0.4 ～ 0.5 ミリ秒を追加する必要が生じることがあります。外部光源を使用する In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、および In-Sight 8000 シリーズのビジョンシステム用 LED ライトの予熱時間の詳細については、照明の製造元のユーザマニュアルを参照してください。

さまざまな In-Sight ビジョンシステムモデルの露光時間を、次の表に示します。

In-Sight モデル | 解像度 | センサタイプ | 露光時間 (ミリ秒)
Micro 1020、1050、1100、1110、1100C、1400、1410、1400C | 640 × 480 | CCD、グローバルシャッター | 0.016 ～ 1000
Micro 1402、1412 | 1280 × 1024 | CMOS、グローバルシャッター | 0.016 ～ 950
Micro 1403、1413、1403C | 1600 × 1200 | CCD、グローバルシャッター | 0.052 ～ 1000
Micro 1500 | 640 × 4801 | CMOS、グローバルシャッター | 0.004 ～ 500
 | 800 × 6001 | CMOS、グローバルシャッター | 0.005 ～ 500
5100、5110、5100C、5400、5410、5400C、5600、5610 | 640 × 480 | CCD、グローバルシャッター | 0.016 ～ 1000
5403、5413、5603、5613 | 1600 × 1200 | CCD、グローバルシャッター | 0.027 ～ 1000
5604 および 5614 ラインスキャン | 1024 × 1 | CCD、グローバルシャッター | 1.33 ～ 1000 µs
5605、5615、5705、5715 | 2448 × 2048 | CCD、グローバルシャッター | 0.014 ～ 1000
5705C | 2448 × 2048 | CCD、グローバルシャッター | 0.016 ～ 1000
7010、7010C、7020、7050、7200、7210、7230、7200C、7400、7410、7430、7400C | 800 × 600 | CMOS、グローバルシャッター | 0.016 ～ 950
7402、7412、7432、7402C | 1280 × 1024 | CMOS、グローバルシャッター | 0.016 ～ 950
7600、7600C、7800、7800C、7900、7900C | 800 × 6001 | CMOS、グローバルシャッター | 0.014 ～ 550
 | 640 × 4801 | CMOS、グローバルシャッター | 0.014 ～ 520
7801、7801C、7901、7901C | 1280 × 1024 | CMOS、グローバルシャッター | 0.017 ～ 750
7802、7802C、7902、7902C | 1600 × 12001 | CMOS、グローバルシャッター | 0.020 ～ 940
 | 800 × 600 (低照明モード)1 | CMOS、グローバルシャッター | 0.020 ～ 940
7905、7905C | 2448 × 2048 | CMOS、グローバルシャッター | 0.021 ～ 1000
8200、8200C、8400、8400C | 640 × 480 | CMOS、グローバルシャッター | 0.014 ～ 520
8401、8401C | 1280 × 1024 | CMOS、グローバルシャッター | 0.0174 ～ 750
8402、8402C | 1600 × 1200 | CMOS、グローバルシャッター | 0.020 ～ 940
8405 | 2592 × 1944 | CMOS、ローリングシャッター | 0.032 ～ 10002
1解像度は、[画像の設定] ダイアログで設定できます。 2In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、「ローリングシャッターの操作」を参照してください。

自動露光

露光時間が自動的に決定されるかどうかを指定します。これをオンにすると、露光時間はさまざまな照明状態を補正するように自動調整されます。

注: この機能は、In-Sight 5604、In-Sight 5605、In-Sight 5705、In-Sight 5705C、In-Sight 76xx ～ 79xx シリーズ、および In-Sight 8000 シリーズのビジョンシステムではサポートされていません。In-Sight ビジョンシステムがこの機能をサポートしていない場合、[自動露光] パラメータは無効になります。

モード

自動露光をどのように決定するかを指定します。

0 = 無効

[自動露光] オプションは無効になります。

1 = 連続

さまざまな照明状態を補正するために、画像の取り込みごとに露光時間が自動調整されます。

注: 連続モードでは、取り込みの間隔が長くなります。

2 = シングルショット

最初の取り込み: センサがオフラインの場合、最初の取り込みは露光時間の決定のために使用されます。この露光時間の値は、シングルショットが無効になるまで格納されます。センサがオフラインの間に取り込みが行われなかった場合、センサをオンラインにしたときの最初の取り込みが露光時間の決定に使用されます。

2 回目以降の取り込み: センサは、最初の取り込みで計算された露光時間の値を使用して、画像を取り込みます。

注: [シングルショット] チェックボックスの ON/OFF を切り替えるか、異なる自動露光モードを選択すると、露光時間の値がリセットされます。露光時間のリセット後に行われた最初の取り込みは、新しい露光時間の値を決定するために使用されます。

最大露光時間

適切な露光時間を決定するときに使用される最大露光時間を指定します。

目標輝度

必要な輝度レベル (0 ～ 100、デフォルト = 10) を指定します。[目標輝度] パラメータが使用可能な飽和ピクセルの割合 (255) を指定します。[自動露光] がオンの場合、[目標輝度] 設定は露光時間の値を調整し、飽和ピクセル「x%」の「目標輝度」を持つ画像を返します。例えば、画像が 10000 ピクセルのときに [目標輝度] パラメータが 20 に設定されると、[自動露光] は露光時間の値を調整し、約 2000 飽和ピクセルを含む画像を返します。

Auto Expose Region

露光時間の自動計算に使用される領域を指定します。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
High | 領域の X 軸に沿った寸法。
Wide | 領域の Y 軸に沿った寸法。

取り込み開始行

画像センサから In-Sight センサのメモリに転送される最初の行を指定します。

解像度 | 有効な取り込み開始行の値
640 × 480 | 0 ～ 479
800 × 600 | 0 ～ 599
1024 × 768 | 0 ～ 767
1280 × 1024 | 0 ～ 1023
1600 × 1200 | 0 ～ 1199
2448 × 2048 | 0 ～ 2047
2592 × 1944 | 0 ～ 1943

注:
  • ベイヤーパターンの制約によって、In-Sight カラーセンサに対する [取り込み開始行] パラメータの値には偶数を指定する必要があります。[取り込み開始行] パラメータの値に偶数が設定されていない場合、この値は自動的に偶数に変換されます。AcquireImage 関数のプロパティシートには、元の奇数値がそのまま残りますが、GetRow(A0) 関数は変換後の偶数値を戻します。

  • 多くの In-Sight ビジョンツール関数の対象領域 (ROI) の計算では、一度に 4 ピクセル行に対してアルゴリズムが計算され、ROI のサイズは 4 で割り切れるか、4 ピクセル境界に適合するように自動調整されます (そのように設定されていない場合)。部分取り込みを使用した画像取り込みで、ビジョンツールの ROI が 4 で割り切れないか 4 ピクセル境界に適合しない場合、ROI は自動拡張されます。これによって ROI が画像境界を越え #ERR 状態になることがあります。

行数

In-Sight センサのメモリに転送される画像センサの行の数を指定します。

解像度 | 許容される行数
640 × 480 | 1 ～ 480
800 × 600 | 1 ～ 600
1024 × 768 | 1 ～ 768
1280 × 1024 | 1 ～ 1024
1600 × 1200 | 1 ～ 1200
2448 × 2048 | 1 ～ 2048
2592 × 1944 | 1 ～ 1944

注:
  • ベイヤーパターンの制約によって、In-Sight カラーセンサに対する [取り込み開始行] パラメータの値には偶数を指定する必要があります。[取り込み開始行] パラメータの値に偶数が設定されていない場合、この値は自動的に偶数に変換されます。AcquireImage 関数のプロパティシートには、元の奇数値がそのまま残りますが、GetRow(A0) 関数は変換後の偶数値を戻します。
  • 多くの In-Sight ビジョンツール関数の対象領域 (ROI) の計算では、一度に 4 ピクセル行に対してアルゴリズムが計算され、ROI のサイズは 4 で割り切れるか、4 ピクセル境界に適合するように自動調整されます (そのように設定されていない場合)。部分取り込みを使用した画像取り込みで、ビジョンツールの ROI が 4 で割り切れないか 4 ピクセル境界に適合しない場合、ROI は自動拡張されます。これによって ROI が画像境界を越え #ERR 状態になることがあります。

ラインの数

(In-Sight 5604 のみ)

In-Sight 5604 ラインスキャンビジョンシステムで画像を生成するために取り込むラインの数 (1 ～ 8192、デフォルトは 2048) を指定します。In-Sight 5604 は、デフォルトでは、幅 1024 ピクセル×高さ 2048 ピクセルの高解像度標準領域画像を生成します。幅の値 1024 ピクセルは変更できませんが、高さの値 2048 ピクセルは変更することができます。高さの値を変更するには、[エンコーダの設定] ボタンをクリックして [ラインスキャンの設定] ダイアログを開きます。

注:
  • 回転する対象物の画像を取り込む場合は、画像トリガの欠落を避けるため、[ライン数] の値を、任意の 2 つのフレームトリガ間の行数より小さくする必要があります。
  • このパラメータは形式上 1 に設定できますが、8 を下回る値の場合は、画像取り込みに失敗します。

照明制御

(In-Sight 5000 シリーズおよび 70xx ～ 74xx シリーズのみ)

LED 照明バンクおよびリングを制御するパラメータは次のとおりです。

注: M12 レンズ設定の In-Sight 70xx ～ 74xx シリーズのビジョンシステムには、[照明制御] パラメータは事前にインストールされた内部 LED リング照明の設定でのみ使用されます。外部ストロボデバイスをビジョンシステムの照明ケーブルに接続する場合は、[照明の設定] ダイアログを使用して照明の設定を行います。

モード

(5000 シリーズおよび 70xx ～ 74xx シリーズ)

In-Sight 5000 シリーズまたは 70xx ～ 74xx シリーズビジョンシステムのリング照明を、指定された露光時間のみ点灯するか、常に点灯しておくかを指定します。

0 = 露光制御 | 露光時間中のみリング照明を点灯します。
1 = 常時点灯 | リング照明を常に点灯します。画像を露光していないときに 50% の輝度で LED を点灯し続けることによって、ストロボの効果が低下します。
2 = 無効 | リング照明を無効にします (In-Sight 70xx ～ 74xx シリーズのみ)。

照明 0

(5000 シリーズのみ)

 最大 4 つの LED 照明チャネルの ON/OFF を指定します。0 以外の値 (1 ～ 255) を指定すると露光時間の間、照明チャネルが ON になります。0 を指定すると、照明チャネルは OFF のままです。In-Sight 5000 シリーズのリング照明 (P/N 200-0187-1) は、水平方向と垂直方向の 2 つの LED バンクに分かれています。照明 0 は水平 LED バンクを制御し、照明 1 は垂直 LED バンクを制御します。

注:
  • 外付けのストロボを使用する場合は、照明 0 および照明 1 をゼロ (0) に設定する必要があります。
  • [光量] パラメータの値を大きくしても、LED の輝度は強くなりません。

Light Intensity

(70xx ～ 74xx シリーズのみ)

 LED の実効輝度 [(0 ～ 100)、デフォルト = 1、OFF = 0] を制御します。

ゲイン

A/D コンバータの前段の増幅器のゲインを指定します。

In-Sight モデル | ゲインの設定
Micro 1000 シリーズ (In-Sight Micro 1402、1412、または 1500 を除く) | 0 ～ 255、デフォルト = 128
Micro 1500 | 0 ～ 3、デフォルト = 0
5000 シリーズ | 0 ～ 255、デフォルト = 128
70xx ～ 74xx シリーズおよび In-Sight Micro 1402 および 1412 | 0 ～ 7、デフォルト = 0
7600、7600C、7800、7800C、7801、7801C、7802、7802C、7900、7900C、7901、7901C、7902、7902C | 0 ～ 6、デフォルト = 0
7905、7905C | 0 ～ 240、デフォルト = 60
8200、8200C、8400、8400C、8401、8401C、8402、8402C | 0 ～ 6、デフォルト = 0
8405 | 0 ～ 159、デフォルト = 16

注: In-Sight 5604 ラインスキャンビジョンシステムに接続している場合、[ゲイン] 設定は 0 ～ 255 の範囲内で 0.25 ずつ増分できるため、きめ細かくゲインを調整できます。

オフセット

A/D 変換の前に In-Sight ビジョンシステムからのアナログ信号に対して加算または減算する DC レベルを指定します。[オフセット] は、画像内のダイナミックレンジを維持しながら、画像の明暗に影響します。

注:In-Sight 7905 ビジョンシステムの [オフセット] パラメータと [画像方向] パラメータが [AcquireImage] プロパティシート外で変更された場合 (つまり、ジョブが別のパラメータ値でロードされるか、パラメータ値がプログラムによって変更された場合)、カメラまたはタイムスタンプのトリガタイプの取り込みに失敗するか、他のトリガタイプの次の取り込み開始が約 9 ミリ秒遅れることがあります。その後の取り込みでは、このような遅延は発生しません。
In-Sight モデル | オフセット設定
Micro 1000 シリーズ | 0 ～ 255。デフォルトはタイプによって異なる。
5000 シリーズ | 0 ～ 255。デフォルトはタイプによって異なる。
70xx ～ 74xx シリーズ | 0 ～ 255。デフォルトはタイプによって異なる。
7600、7600C、7800、7800C、7900、および 7900C (640 × 480)1 | 0 ～ 90。デフォルトはタイプによって異なる。
7600、7600C、7800、7800C、7900、および 7900C (800 × 600)1 | 0 ～ 128。デフォルトはタイプによって異なる。
7801、7801C、7802、7802C、7901、7901C、7902、7902C | 0 ～ 128。デフォルトはタイプによって異なる。
7905、7905C | 0 ～ 255。デフォルトはタイプによって異なる。
8200、8200C、8400、および 8400C | 0 ～ 90。デフォルトはタイプによって異なる。
8401、8401C、8402、8402C、8405 | 0 ～ 255。デフォルトはタイプによって異なる。
1解像度は、[画像の設定] ダイアログで設定できます。
Orientation

画像の向きを指定します。

0 = 標準 (デフォルト)

1 = 左右反転

2 = 上下反転

3 = 180 度回転

注:
  • In-Sight ビジョンシステムがこの機能をサポートしていない場合、[画像の回転] パラメータは無効になります。この機能は、In-Sight 5100C、In-Sight 5400C、In-Sight 5705C、および In-Sight 8405 ビジョンシステムではサポートされていません。
  • In-Sight 7905 ビジョンシステムの [オフセット] パラメータと [画像方向] パラメータが [AcquireImage] プロパティシート外で変更された場合 (つまり、ジョブが別のパラメータ値でロードされるか、パラメータ値がプログラムによって変更された場合)、カメラまたはタイムスタンプのトリガタイプの取り込みに失敗するか、他のトリガタイプの次の取り込み開始が約 9 ミリ秒遅れることがあります。その後の取り込みでは、このような遅延は発生しません。
  • In-Sight 5604 ラインスキャンビジョンシステムは、[標準] および [左右反転] の設定のみをサポートしています。
  • センサがオンラインの間、[画像の回転] パラメータの値を変更しないでください。変更すると、センサが予期しない状態になることがあります。

マスタ

このチェックボックスが ON になっている場合、アクティブな In-Sight センサが In-Sight センサのネットワーク上での「マスタ」デバイスとして指定されます。アクティブな In-Sight センサは、マスタシステムとしてネットワーク上のほかのセンサ (「スレーブ」) に対し、ネットワークを介する画像取り込みトリガを生成することができます。

0 = OFF (デフォルト) | アクティブな In-Sight センサからネットワークトリガを生成できません。
1 = ON | アクティブな In-Sight センサからネットワークトリガが生成されます。特定の「マスタ名」で設定され、「ネットワークトリガ」に設定されたネットワーク上の In-Sight スレーブは、In-Sight マスタが画像を取り込むとその画像を常に取り込みます。
注:
  • In-Sight センサは、マスタおよびスレーブとしてネットワーク上で同時に動作することはできません。つまり、ネットワークでトリガを受けてから、さらにトリガを生成することはできないということです。したがって、トリガが [ネットワーク] に設定されている場合は、[マスター] チェックボックスを OFF にしてください。
  • 1 つのネットワーク上で複数の In-Sight センサをマスタとして動作させることは可能です。マスタ名パラメータにおいて、各マスタとこのマスタを参照するすべてのスレーブは一意の名前を共有する必要があります。
  • In-Sight Micro 1020 ビジョンシステムは、[マスター] パラメータをサポートしていません。
  • In-Sight ビジョンシステムは、EasyBuilder ビューではマスタ/スレーブ構成のスレーブとしてのみ機能します。[マスタ] オプションはスプレッドシートビューでのみ使用できます。

マスタ名

[トリガ] の設定が [(99) ネットワーク] ではなく、[マスター] が選択されている (ON である) 場合、[マスター名] フィールドには、アクティブな In-Sight センサによってそのスレーブをトリガするために送信されるネットワークトリガの名前を指定します。

[トリガ] が [(99) ネットワーク] に設定されていて、[マスター] が選択されていない (OFF である) 場合、[マスター名] フィールドには、アクティブな In-Sight センサで画像取り込みを発生させるネットワークトリガの名前を指定します。

注:
  • スレーブセンサ上の [マスター名] フィールドは、マスタセンサ上の [マスター名] フィールドと一致している必要があります。一致していない場合、スレーブセンサはトリガされません。
  • [マスター名] フィールドが空白のスレーブセンサは、ネットワーク上のすべてのマスタセンサによってトリガされます。
  • [マスター名] では大文字と小文字が区別されます。

マスタデータ

アクティブな In-Sight センサがネットワーク上のマスタに設定されている場合、トリガの送リ先になる In-Sight スレーブに英数字の文字列データを送ることもできます。ネットワークトリガによって受信したマスタデータを読み取るには、In-Sight スレーブのスプレッドシートにセル A0 の AcquireImage 関数を参照する GetString 関数が含まれている必要があります。
バッファモード

画像の取り込みに使用されるバッファの数を指定します。センサがオンラインの間は、バッファモードパラメータを変更することができません。

0 = オーバラップ (デフォルト) | [画像バッファ] ダイアログで指定した画像バッファの数を、画像取り込みで使用します。
1 = シングル | 画像取り込みに単一バッファのみを使用します。このオプションは、[トリガ] パラメータが [カメラ] に設定されている場合のみサポートされます。
遅延

[トリガ] パラメータが [カメラ] または [ネットワーク] に設定されている場合、トリガを受信してから、センサが画像取り込みを開始するまでの遅延をミリ秒単位 (0 ～ 10,000) で指定します。[トリガ] パラメータが [連続] に設定されている場合は、画像取り込みの間隔をミリ秒単位 (0 ～ 10,000、デフォルトは 500) で指定します。In-Sight 5604 ラインスキャンビジョンシステムに接続されており、[トリガ] パラメータが [カメラ] に設定されている場合は、カメラトリガが発生してから、画像取り込みを開始するまでの遅延をラインの数で指定します。

注:
  • [トリガ] パラメータが [連続] に設定されている場合、この遅延は、ジョブで画像処理を完了するまでに必要な時間によって異なります。例えば、[遅延] パラメータが 5,000 ミリ秒に設定された場合、ジョブで 5,000 ミリ秒以内に画像処理が完了すれば、In-Sight ビジョンシステムは 5,000 ミリ秒ごとに画像を取り込みます。そうでなければ、In-Sight ビジョンシステムは画像処理が完了した時点で画像を取り込みます。
  • 遅延時間の正確性は、指定ミリ秒 ± 最大ライン露光時間 (64 マイクロ秒) となります。
  • [画像取り込み開始] または [ストロボ] が [ディスクリート I/O の設定] ダイアログで [タイプ] に指定されている場合、これらの出力も指定された時間だけ遅れます。
  • In-Sight 5604 ラインスキャンビジョンシステムに接続され、[遅延] パラメータが 0 以外の値に設定されている場合、ビジョンシステムが [遅延] 期間内に画像取り込みトリガを受け取ると、[遅延] パラメータに指定された期間が完了するまで、トリガはアクティブ化されず、取り込みミスは報告されません。
  • In-Sight 5604 ラインスキャンビジョンシステムに接続され、[遅延] パラメータが長い期間に設定されている場合、システムがオンライン/オフラインのいずれであるか、またはエンコーダ画像取り込み時のタイムアウトに達しているかどうかに関係なく、遅延期間が完了するまでシステムは別の画像取り込みを開始しません。ビジョンシステムが、In-Sight Explorer [センサ] メニューの [リセット] オプションまたは Reset System ネイティブモードコマンドによってリセットされた場合、ビジョンシステムが無応答となり、電源を入れ直してシステムを復元する必要が生じることがあります。[遅延] 期間が完了するまで待機してから、ソフトリセットを送信してください。

フォーカスメトリクス領域

ライブ画像モードでフォーカスメトリクス得点の自動計算に使用する領域を指定します。

注: In-Sight 7000 シリーズビジョンシステムの場合は、ライブビデオモードの間でも、フォーカスメトリクス領域を使用して、レンズのオートフォーカスの計算、またはレンズの焦点位置の設定に使用する領域を定義します。
X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。
ホワイトバランス領域

ホワイトバランスの計算に使用する領域を指定します。

注: WhiteBalance 関数は、ホワイトバランス領域を参照し、このパラメータを使用してホワイトバランスを計算します。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。

ラインスキャン

(In-Sight 5604 のみ)

[ラインスキャン] コントロールでは、In-Sight 5604 ラインスキャンビジョンシステムの設定値を指定します。In-Sight 5604 は、対象物が通過するにつれて行単位で画像を生成するため、円柱状の対象物の完全な「展開図」画像や、面を連続的にスライスした画像を生成できます。In-Sight 5604 をユーザが提供するハードウェアエンコーダに接続すると、対象物の速度が変化しても、非常に正確な画像を生成できます。
注:
  • これらのコントロールを有効にするには、In-Sight 5604 ラインスキャンビジョンシステムまたはエミュレータに接続している必要があります。
  • In-Sight 5604 はオフラインになっている必要があります。
  • ユーザがフルアクセスのアクセス権を持っている必要があります。
  • In-Sight 5604 に接続されており、AcquireImage プロパティシートにアクセスしている場合に、[OK] または [キャンセル] をクリックしてプロパティシートを閉じると、GUI は画像間の同期を失います。例えば、[キャンセル] ボタンをクリックしてプロパティシートを閉じた場合、GUI は新たに取り込んだ画像を表示しますが、ビジョンツールは以前に取り込んだ画像に対して関数を実行します。[OK] ボタンをクリックした場合は、新しい画像が取り込まれ、ビジョンツールはこの画像に対して動作しますが、別の新しい画像が取り込まれて表示されると、ビジョンツールはこの画像に対して動作しません。AcquireImage プロパティシートにアクセス後に、特定の画像に戻る必要が生じた場合は、必ず手動で画像を取り込み、現在表示されている画像を保存してから、AcquireImage にアクセスしてください。

ライントリガタイプ

エンコーダのタイプを指定します。[ソフトウェアエンコーダ] または [ハードウェアエンコーダ] です。

0 = ハードウェアエンコーダ | [ハードウェアエンコーダ] を指定すると、ライントリガの駆動に [ラインごとのステップ数] 設定値と外部ハードウェアエンコーダが使用されます。 ハードウェアエンコーダは、対象物が指定した方向または距離を移動するたびに信号を変化させることで対象物の位置をデジタル化する装置です。In-Sight 5604 は、2 種類のハードウェアエンコーダをサポートします。[単位相] または [直交] です。これを指定するには、[エンコーダの設定] ボタンをクリックして [ラインスキャンの設定] ダイアログを開きます。
1 = ソフトウェアエンコーダ (デフォルト) | [ソフトウェアエンコーダ] を指定すると、[ライン間隔] 設定で指定した間隔で周期的にライントリガが駆動されます。 ソフトウェアエンコーダは、ハードウェアエンコーダのソフトウェアエミュレーションで、指定された周期でラインを取り込みます。この方式では、対象物の速度の変化 (低周波の速度変化や高周波の揺れ) によって垂直の不要画像が生じることがあるため、主に設定とトラブルシューティングに使用します。

ライン間隔/ラインごとのステップ数

ライン間の時間を、[ライントリガタイプ] が [ソフトウェアエンコーダ] に設定されている場合はマイクロ秒単位で、ライントリガタイプ] が [ハードウェアエンコーダ] に設定されている場合はエンコーダのステップ数で指定します。

Line Period

画像ラインごとの間隔周期をマイクロ秒単位 (0.25 ～ 1000000 µs、デフォルト = 40 µs) で指定します。

注:
  • このコントロールを有効にするには、[ライントリガタイプ] が [ソフトウェアエンコーダ] に設定されている必要があります。
  • ライントリガの欠落を避けるため、[ライン間隔] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 (最短 1.33 µs) より 21.47 µs 長くなるように設定する必要があります。

Steps Per Line

画像ラインごとの間隔エンコーダのステップ数 (0.25 ～ 256、デフォルト = 40) を指定します。

直交エンコーダを使用する場合、「ステップ」はエンコーダ信号の 1 サイクルです。シングルラインハードウェアエンコーダの場合は、1 ステップは 2 回の信号変化に等しく、直交ハードウェアエンコーダの場合は 4 回の信号変化に等しくなります。

Closed ハードウェアエンコーダのラインごとのステップ数のタイミング図

注:
  • このコントロールを有効にするには、[ライントリガタイプ] が [ハードウェアエンコーダ] に設定されている必要があります。
  • [ラインごとのステップ数] の値は、シングルラインハードウェアエンコーダの場合は 0.5 ずつ、直交ハードウェアエンコーダの場合は 0.25 ずつの値で設定する必要があります。
  • ライントリガの欠落を避けるため、[ラインごとのステップ数] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 (最短 1.33 µs) より 21.47 µs 長くなるように設定する必要があります。

エンコーダ画像取り込み時のタイムアウト

画像取り込みの最長時間をミリ秒単位 (0 ～ 300,000、デフォルト = 0、タイムアウトの無効化) で指定します。画像取り込みが指定した時間内に完了しなかった場合、画像取り込みは中断され、画像取り込みエラーが発生します。

注: タイムアウトを無効にするには、パラメータを 0 に設定します。

Clip Mode

画像取り込みトリガを受信したときに指定された数のラインの取り込みが完了していない場合の動作を指定します。

注:
  • [黒く塗りつぶし] または [ラインスキャンラインの間引き] が有効な場合、トリガタイプを [カメラ] に設定し、画像を適切にクリッピングします。他のトリガタイプでは、画像が取り込まれている間にトリガが到達すると、現在の画像はクリッピングされず、新しく到達したトリガは失敗します。
  • [黒く塗りつぶし] オプションでは、1 行埋めるのに約 2 µs かかります (100 行あたり 0.2 ミリ秒)。時間に厳密なアプリケーションの場合は [ラインスキャンラインの間引き] オプションを選択します。[黒く塗りつぶし] オプションを使用する場合は、埋める行数は数百行程度までに抑えます。
  • In-Sight 5604 ラインスキャンビジョンシステムに接続されており、このパラメータが [黒く塗りつぶし] または [ラインスキャンラインの間引き] に設定されている場合に、Set Event ネイティブモードコマンドを送信して画像取り込みをトリガし、画像が取り込まれている間にトリガが到達すると、現在の画像はクリッピングされず、新しく到達したトリガは失敗します。

0 = クリッピングなし (デフォルト) | 画像トリガを無視し、「画像取り込みエラー」イベントを生成するように指定します。 Closed クリッピングなしの場合の図
1 = 黒く塗りつぶし | 残りのラインを黒いピクセルで埋め、新しい画像を即座に開始するように指定します。「画像取り込みエラー」イベントは生成されません。 Closed 黒く塗りつぶし場合の図
2 = ラインスキャンラインの間引き | 現在の画像を現在取り込んだ行数のサイズに縮小し、即座に新しい画像を開始するように指定します。 Closed ラインスキャンラインの間引き
トリガデバウンス

入力トリガを有効なトリガとして認識するまでアクティブなままにしておく時間をマイクロ秒単位で指定します (0 ～ 65,536、デフォルト = 1)。この設定で指定した時間だけ、有効なトリガの認識を遅らせます。

注:
  • このコントロールを有効にするには、[トリガ] パラメータを [カメラ] に設定する必要があります。
  • トリガデバウンスオプションは In-Sight Micro 1000 シリーズ、In-Sight 7000 シリーズ、および In-Sight 8000 シリーズビジョンシステムで利用可能です。このオプションは、In-Sight 5100 シリーズ、5400 シリーズ、5600、5603 および 5605 ビジョンシステムでも利用可能です。モデルはタイプ番号 (821-xxxx-xx) で特定できます。このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。モデル、およびタイプ番号と不揮発性フラッシュメモリの一覧については、ここをクリックしてください。

AcquireImage 関数の出力

AcquireImage 関数は、 [image] データ構造体を返します。センサモデルによって、返される画像のタイプは異なります。

In-Sight モデル | 画像の寸法 (ピクセル単位) | グレースケール / カラー | ビット深度 | グレースケール階調数または色数 | FPS
Micro 1020、1050、1100、1110、1400、1410 | 640 × 480 | グレースケール | 8 ビット | 256 | 60
Micro 1100C および 1400C | 640 × 480 | カラー | 24 ビット | 16,777,216 | 58
Micro 1402 および 1412 | 1280 × 1024 | グレースケール | 8 ビット | 256 | 60
Micro 1403 および 1413 | 1600 × 1200 | グレースケール | 8 ビット | 256 | 14
Micro 1403C | 1600 × 1200 | カラー | 24 ビット | 16,777,216 | 7
Micro 1500 | 640 × 4801 | グレースケール | 8 ビット | 256 | 213
 | 800 × 6001 | グレースケール | 8 ビット | 256 | 157
5100、5110、5400、5410、5600 | 640 × 480 | グレースケール | 8 ビット | 256 | 60
5100C および 5400C | 640 × 480 | カラー | 24 ビット | 16,777,216 | 60
5604 および 5614 ラインスキャン | 1024 × 1 | グレースケール | 8 ビット | 256 | 44 KHz
5403、5413、5603、および 5613 | 1600 × 1200 | グレースケール | 8 ビット | 256 | 14
5605、5615、5705、および 5715 | 48 × 2048 | グレースケール | 8 ビット | 256 | 16
5705C | 2448 × 2048 | カラー | 24 ビット | 16,777,216 | 14
7010、7020、7050、7200、7210、7230、7400、7410、7430 | 800 × 600 | グレースケール | 8 ビット | 256 | 102
7010C、7200C、7400C | 800 × 600 | カラー | 24 ビット | 16,777,216 | 50
7402、7412、7432 | 1280 × 1024 | グレースケール | 8 ビット | 256 | 60
7402C | 1280 × 1024 | カラー | 24 ビット | 16,777,216 | 30
7600、7800、7900 | 800 × 6001 | グレースケール | 8 ビット | 256 | 165
 | 640 × 4801 | グレースケール | 8 ビット | 256 | 217
7600C、7800C、7900C | 800 × 6001 | カラー | 24 ビット | 16,777,216 | 100
 | 640 × 4801 | カラー | 24 ビット | 16,777,216 | 135
7801、7901 | 1280 × 1024 | グレースケール | 8 ビット | 256 | 76
7801C、7901C | 1280 × 1024 | カラー | 24 ビット | 16,777,216 | 45
7802、7902 | 1600 × 12001 | グレースケール | 8 ビット | 256 | 53
 | 800 × 600 (低照明モード)1 | グレースケール | 8 ビット | 256 | 53
7802C、7902C | 1600 × 12001 | カラー | 24 ビット | 16,777,216 | 33
 | 800 × 600 (低照明モード)1 | カラー | 24 ビット | 16,777,216 | 45
7905 | 2448 × 2048 | グレースケール | 8 ビット | 256 | 32
7905C | 2448 × 2048 | カラー | 24 ビット | 16,777,216 | 17
8200 | 640 × 480 | グレースケール | 8 ビット | 256 | 217
8200C | 640 × 480 | カラー | 24 ビット | 16,777,216 | 135
8400 | 640 × 480 | グレースケール | 8 ビット | 256 | 217
8400C | 640 × 480 | カラー | 24 ビット | 16,777,216 | 135
8401 | 1280 × 1024 | グレースケール | 8 ビット | 256 | 76
8401C | 1280 × 1024 | カラー | 24 ビット | 16,777,216 | 45
8402 | 1600 × 1200 | グレースケール | 8 ビット | 256 | 53
8402C | 1600 × 1200 | カラー | 24 ビット | 16,777,216 | 33
8405 | 2592 × 1944 | グレースケール | 8 ビット | 256 | 13
1解像度は、[画像の設定] ダイアログで設定できます。

注:
  • 1 秒あたりの最大フレーム数は、ジョブ依存で、専用取り込みトリガを使用した最小露光と画像フレーム全体のキャプチャに基づき、ビジョンシステムへのユーザインタフェース接続がないことを前提にしています。
  • In-Sight 5604 および 5614 ラインスキャンモデルの場合、取り込みレートは周波数 (KHz) 単位で表されます。
  • 解像度は、[画像の設定] ダイアログで設定できます。
  • 画像パラメータを必要とする関数は、有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。すべてのプロパティシートにおいて、画像パラメータのデフォルトの参照先はセル A0 です。セル A0 には、AcquireImage 関数によって返される [image] データ構造体が含まれています。しかし、CompareImage 関数、FindCircleDefects 関数、NeighborFilter 関数、および PointFilter 関数によって返される [image] データ構造体もプロパティシートの画像パラメータ値に対して有効な参照です。
Version: 5.6.0


TestRun - スプレッドシートビュー

In-Sight Explorer GUI リファレンス

対象となる In-Sight ビジョンシステムに接続し、該当する .job ファイルをビジョンシステムにロードしたら、TestRun の設定を開始する必要があります。TestRun を設定するには、[TestRun セットアップ] ダイアログを使用します。ここでは、TestRun をプログラムするための一連の画面がステップ単位で表示されます。ダイアログの左側にはナビゲーションペインが表示されており、ここで設定画面のいずれかを選択できます。

注: TestRun の初期設定が完了した後に、いずれかのステップを再度確認するには、ナビゲーションペインでそのステップを選択します。

  • [ジョブの PASS/FAIL]
  • [シンボリックタグ]
  • [画像データベースフォルダ]
  • [バリアントの設定]
  • [ジョブ/バリアント] - [アクションのセットアップ]
  • [ジョブ/バリアント] - [リミットテスト]
  • [ジョブ/バリアント] - [画像の選択]
  • [ジョブ/バリアント] - [欠陥テスト]
  • [ハードウェアテスト] - [アクションのセットアップ]
  • [ハードウェアテスト] - [テスト]
  • [クリーンアップアクション]

[TestRun セットアップ] ダイアログを設定したら、[パレット] に戻り、次のボタンを使用してそれぞれの処理を行います。

  • [新規]:新しい TestRun テストを作成します。
  • [設定]:[TestRun セットアップ] ダイアログを起動します。
  • [実行]:既存の TestRun テストを実行します。

    • 注: In-Sight ファームウェアバージョン 4.10.x、または In-Sight ファームウェア 5.6.0 以上を実行している In-Sight ビジョンシステムでは、EtherNet/IP 通信または PROFINET 通信経由で、PLC などの外部デバイスからも TestRun を開始できるようになりました。

  • [修復]:壊れたテストまたは値を修復します。
  • [インポート]:以前に作成したテストをインポートします。
  • [エクスポート]:テストをエクスポートします。
  • [バッチ実行]:TestRun を設定して .job ファイルのバッチを実行する際に使用する [TestRun バッチ実行] ダイアログを開きます。

注: [TestRun] ボタンは TestRun の実行中は無効になります。

TestRun を表示するには

  1. [パレット] で、[TestRun™] タブをクリックします。

注: [パレット] が表示されない場合は、[表示] メニューから [パレット] を選択します。

  2. [設定] ボタンをクリックして、[TestRun セットアップ] ダイアログを起動します。
  3. [TestRun セットアップ] ダイアログのステップをすべて設定したら、[パレット] の [TestRun] タブにある [image] [実行] ボタンをクリックして、テストを実行します。

注: [TestRun セットアップ] ダイアログの設定を完了したら、[パレット] で使用できるすべてのボタンが表示された右クリックメニューが選択できるようになります。さらに、テストの特定のセクションからテストを実行する機能も使用できるようになります (例えば、ジョブテストを実行せずにハードウェアテストから開始する、など)。

[ジョブの PASS/FAIL]

スプレッドシートビューで TestRun を使用する際は、最初にジョブに対して PASS/FAIL タグを使用してセルを設定する必要があります。このタグは、マシンビジョン検査の成功または失敗を示します。技術面からは、ジョブに対して PASS/FAIL セルを設定する必要はありませんが、ジョブの PASS/FAIL を記録するためにセルにタグを付けることは 2 つの点で有利です。まず、PASS/FAIL セルを使用すると、Cognex VisionView アプリケーションは、合格画像と不合格画像を識別し、それに応じて色分けすることができます。次に、TestRun は、ジョブの PASS/FAIL セルの情報を「不合格」画像の識別情報と組み合わせることによって、ジョブの PASS/FAIL ステータスを判定する欠陥テスト、および各画像で想定される結果を作成して設定することができます。

注: [ジョブの PASS/FAIL セルの設定] ダイアログが既に設定されている場合、[TestRun セットアップ] ダイアログのこのステップで、設定が自動的に入力されます。

ジョブの PASS/FAIL セルの設定

  1. [ジョブの PASS/FAIL セルを使用する] チェックボックスがオンになっていることを確認します (デフォルトでは、オン)。
  2. [セルの選択] ボタンをクリックして、セル選択モードに切り替えて、ジョブの PASS/FAIL セルとして使用するセルを選択します。
  3. 3 つの [ジョブのステータス] を設定すると、PASS/FAIL セルの状態に応じて、ジョブの適切なステータスを示すことができます (負、ゼロ、または正)。
  4. [次へ] ボタンをクリックして、TestRun の設定を続行します。

[シンボリックタグ]

TestRun では、セル位置ではなくシンボリックタグに基づいて、ジョブ内の関数およびツールを参照します (シンボリックタグを使用すると、ジョブの開発者は、TestRun に影響を与えずにセルを移動することができます)。このため、TestRun で使用される値はすべて、シンボリックタグを持っている必要があります。ジョブが EasyBuilder ビューで開発されている場合、テスト可能なすべての値に対して、最初からシンボリックタグが存在しています。つまり、EasyBuilder ビューからアクセスする場合、このステップは省略されます。ジョブをスプレッドシートビューで開発した場合は、シンボリックタグを作成する必要があります。

シンボリックタグの作成

スプレッドシートビューでシンボリックタグを作成するには 2 つの方法があります。1 つは、目的のセルを手動で追加してタグを付ける方法です。もう 1 つは、自動タグ機能を使用して、サポートされるセルタイプに自動的にタグを付ける方法です。

注: シンボリックタグを追加したら、名前またはセル位置別にソートすることができます ([名前] または [セル位置] 列見出しをクリックします)。

手動によるシンボリックタグの追加

  1. [追加] ボタンをクリックして、セル選択モードに切り替えて、シンボリックタグに関連付けるセルを選択します。
  2. TestRun では、選択したセルに「Cell_<loc>」というフォーマットでシンボリックタグを割り当てます。ここで <loc> はセル位置です (例: B52)。
  3. 新しいシンボリックタグを選択し、タグが編集できるようになります。
  4. 必要に応じて、タグの名前をアプリケーションに適用できる名前に変更します。目的のタグを選択して、[名前の変更] ボタンをクリックします。新しい名前を入力し、Enter キーを押して変更を受け入れます。

注: TestRun でシンボリックタグの名前を変更すると、スプレッドシート内のシンボリックタグの名前も変更されます。

  5. 目的のセルがすべて追加されるまで、手順 1 ～ 4 を繰り返します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。

シンボリックタグの自動的な追加

[自動タグ] ボタンをクリックすると、TestRun はジョブを調べ、次のタイプの関数に対して自動的にシンボリックタグを作成します。

  • Button 関数
  • CheckBox 関数
  • ListBox 関数
  • EditInt 関数
  • EditFloat 関数
  • EditString 関数

注: Button および CheckBox 関数の場合、関数に割り当てられた名前は、空の文字列でない限り、シンボリックタグの名前として使用されます。

  1. [自動タグ] ボタンをクリックします。
  2. TestRun では、上記の関数を含むセルを検索してタグを付けます。関数が Dialog 関数内にある場合は、Dialog 関数の名前が接頭辞になります (例: 「DialogName」_EditFloat)。関数がカスタムビュー内にある場合は、「Custom_View」が接頭辞になります。

注: 目的の関数が自動的に追加されていない場合は、[追加] ボタンを使用して、手動で関数を追加します。

  3. 不必要なタグを削除する場合は、そのタグを選択してから [削除] ボタンをクリックします。
  4. 必要に応じて、タグの名前をアプリケーションに適用できる名前に変更します。目的のタグを選択して、[名前の変更] ボタンをクリックします。新しい名前を入力し、Enter キーを押して変更を受け入れます。

注: TestRun でシンボリックタグの名前を変更すると、スプレッドシート内のシンボリックタグの名前も変更されます。

  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。

[画像データベースフォルダ]

ジョブ全体の PASS/FAIL セルを設定してシンボリックタグを作成したら、[TestRun セットアップ] の次のステップは [画像データベースフォルダ] です。

このステップでは、テスト画像データベースへのパスを生成します。ディレクトリパスでは、次のいずれかのフォーマットを使用する必要があります。

  • C:\TestRun\BracketJob
  • file:///\\TestRun\BracketJob
  • ftp://TestRunServer/BracketJob
  • ftp://10.28.127.73/BracketJob

注:シグナル駆動の TestRun 用に設定されたビジョンシステムの場合、FTP サーバを使用するように [画像データベースフォルダ] を設定する必要があります。

画像はすべて、1 つの共通のルートフォルダに格納する必要があります。画像が複数のフォルダに格納されている場合は、すべての画像とそのサブフォルダが含まれているフォルダを選択します。TestRun が各種ファイル構造に対応できる場合は、次のタイプの構造を使用することを推奨します。

このタイプの構造を使用すると、「画像データベース」フォルダが選択されます。

最後に、[未知の画像] ドロップダウンメニューを設定します (無視、Pass と仮定、Fail と仮定、デフォルト = 無視)。[未知の画像] ドロップダウンを使用して、[画像の選択] ステップでは明示的に TestRun に追加されなかった画像の、TestRun による処理方法を決定します。ドロップダウンを [無視] に設定すると、設定されていない画像を TestRun で単純に無視することができます。ドロップダウンを [Pass と仮定] に設定すると、画像に対するジョブは TestRun で成功したものとみなされます。ドロップダウンを [Fail と仮定] に設定すると、画像に対するジョブは TestRun で失敗したものとみなされます。

TestRun 画像データベースで使用するフォルダの選択

  1. [参照] ボタンをクリックします。
  2. [フォルダの参照] ダイアログで、保存先の画像フォルダに移動して選択します。フォルダを選択してから [OK] ボタンをクリックします。
    3. 注:
    • 既に画像フォルダにアクセスしている場合は、ドロップダウンメニューから選択できます。

    • シグナル駆動の TestRun 用に設定されたビジョンシステムの場合、FTP サーバを使用するように [画像データベースフォルダ] を設定する必要があります。
  3. 必要に応じて、画像ディレクトリにアクセスするためのユーザ名とパスワードを入力します。

注: TestRun の [画像データベースフォルダ] 設定時に、ジョブの開発者が自分自身の特定のユーザ認証を使用して、TestRun が別のアプリケーションで使用するフォルダにアクセスした場合 (例えば、Windows Explorer を使用して、ネットワークフォルダの画像を表示する場合など) に、別のユーザ認証が指定されている場合 (例えば、ライン上のオペレータが使用する汎用のユーザ名とパスワードなど)、TestRun はそのフォルダにアクセスすることはできません。この状態から復旧するには、フォルダにアクセスしているアプリケーションを閉じてから、[TestRun セットアップ] ダイアログを閉じて再度開きます。

  4. 必要に応じて、ドメインの情報を入力します。
  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。
  6. このステップから抜けると、TestRun は、自動的に .jpg および .bmp 画像ファイル用の画像ディレクトリを検索します。
注:
  • 以前にこのステップを設定済みの場合、TestRun は、ディレクトリに格納されているファイルに関する情報を保持します。画像の場所が変更されると、画像の場所を基準にしたパスに基づいて画像を照合し、照合した画像ごとにそのプロパティを転送します。
  • フォルダが生成されると、ドロップダウンメニューの下に次の項目が表示されます。フォルダ内の画像の総数、以前に [ジョブ]　→ [画像の選択] 画面で設定した画像の数、以前に設定した際にはフォルダ内に存在していたが、現在は存在していない画像の数、および最後に設定してからフォルダに新しく追加された画像の数。

バリアントの設定

通常 1 つのジョブには、1 つ以上の検査が含まれています。ジョブ内のそれぞれの検査は、ジョブバリアントとみなされます。例えば、以降何度もジョブを変更するのを避けるために、複数の製品を処理するようにジョブを作成するとします。この場合、ジョブ内のそれぞれの検査は、ジョブバリアントとみなされます。

通常、外部入力 (例えば、PLC からのコマンド) によって複数のバリアントを選択します。各バリアントには、独自のビジョンツールセット、別のサーチ領域、別の露光設定値などがあります。TestRun では、ジョブ内のすべてのバリアントをテストできます。

注:各ジョブバリアントは、個別に設定します。

ジョブバリアントの追加

  1. デフォルトでは、「ジョブ」という名前のバリアントが自動的に追加されます。

注: 名前を変更するには、対象のバリアントを選択し、[名前の変更] ボタンをクリックしてから、新しい名前を入力します。名前を変更したら、設定ステップペインにある名前が自動的に更新されます。

  2. [追加] ボタンをクリックして、新しいバリアントを作成します。
  3. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブバリアントの並べ替え

注:バリアントの順序を変更すると、TestRun テストの実行順序が変更されます。

  1. バリアントを選択します。
  2. 目的の方向に応じて、[上に移動] または [下に移動] のいずれかのボタンをクリックします。
  3. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - アクションのセットアップ

テストを開始するには、TestRun でジョブの一部のパラメータを設定し、実行する特定のバリアントを設定する際にオペレータが実行する動作をコピーします。通常、ジョブに複数のバリアントがある場合は、設定の一部を、選択したバリアント用のジョブに合わせる必要があります。TestRun で特定のバリアント用の画像を処理するには、最初にそれに応じてジョブの状態を設定する必要があります。[アクションのセットアップ] のステップでは、選択したバリアントの画像に必要なパラメータを設定します。

[アクションのセットアップ] 画面は、2 つの列から構成されます。1 つは [シンボル] 列で、ここにはシンボリックタグ付きジョブの設定値がすべて表示されます。もう 1 つは [アクションのセットアップ] 列で、ここには TestRun で設定するジョブのパラメータ設定値がすべて表示されます。

ジョブを設定して現在のバリアントをテスト

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。

注: 設定を選択すると、スプレッドシートでそのパラメータがハイライトされます。

  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - リミットテスト

マシンビジョンアプリケーションには多数のパラメータが用意されており、これらは必要に応じてマシンオペレータやメンテナンス技術者が調整できます。ビジョンアプリケーションの開発者は、TestRun のリミットテストを使用して、テストする調整可能なパラメータの選択、そのパラメータの上限値および下限値の設定、およびそのパラメータが設定した限界値内に収まっているかどうかの判別を行うことができます。例えば、開発者はシステムを引き続き動作させるために、TestRun のハードコーディングされた限界値をオペレータや技術者が柔軟に調整できるように設定することができます。さらに、パラメータが範囲を外れたことを確認することもできます。

[リミットテスト] 画面では、編集可能なパラメータ限界値に関するテストを設定できます。この画面は、2 つの列から構成されています。1 つは [シンボル] 列で、ここにはシンボリックタグ付きジョブの設定値がすべて表示されます。もう 1 つは [リミットテスト] 列で、ここには TestRun でテストするジョブのパラメータ設定値がすべて表示されます。

限界をテストするための変数の選択と設定

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。

注: 設定を選択すると、スプレッドシートでそのパラメータがハイライトされます。

  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[リミットテスト] 列に設定が自動的に入力されます。
  3. 設定を有効にして [リミットテスト] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。使用可能なテストのタイプは、編集可能なパラメータのタイプに応じて決まります。
  • EditInt 関数: [Is In Range]
  • EditFloat 関数: [Is In Range]
  • EditString 関数: [Is Equal]
  • ListBox 関数: [Is Equal]
  • CheckBox 関数: [Is Equal]
  5. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - 画像の選択

この画面では、特定のバリアントのテスト時に使用される画像を選択し、「良好」または「不良」のいずれかとして定義します。この場合、「良好」画像の状態は合格で、「不良」画像の状態は不合格です。

注: 画像はバリアント内で共有できます。

このバリアントの画像を選択し、画像を「良好」または「不良」として定義します。

  1. ツリーコントロールを使用して、画像のディレクトリを展開します。
  2. ディレクトリに「良好」および「不良」画像が混在して含まれている場合に個別の画像を選択するには、その画像をオンにしてから、ディレクトリの下にあるセレクタを使用し、[良好] または [不良] として定義します。必要に応じて、画像に関するコメントを追加します。
  3. ディレクトリが「良好」および「不良」画像を含む別々のディレクトリに分割されている場合は、トップレベルをオンにしてそのグループ内にあるすべての画像をオンにし、トップレベルで同じ分類 ([良好] または [不良]) を共有します。
  4. [次へ] ボタンをクリックして、TestRun の設定を続行します。

ジョブ/バリアント - 欠陥テスト

[欠陥テスト] 画面では、画像とそれに対応して想定される欠陥が互いに関連付けられており、データベース内の各画像に対して、想定される結果を示すデータベースが作成されています。この画面で欠陥テストを設定するには、各画像に存在する欠陥 (ある場合) を選択して、その欠陥をジョブのパラメータの想定される結果に関連付けます。

初期のデフォルト設定では、各画像に対して [ジョブ FAIL] という欠陥が存在しています。これは、「不良」画像として指定されたすべての画像に対して自動的にオンになります。欠陥がチェック (オン) されることは、その画像に欠陥が存在することを示します。欠陥テストは、ビジョンアプリケーションが画像の合格または不合格を誤って判定した理由を特定するのに役立ちます。大部分のビジョンアプリケーションでは、1 つの画像に対して複数の検査が実行され、それを総合して全体の合格/不合格の結果が生成されます。ビジョン設計者は、TestRun を使用すると、個別の画像の合格/不合格を判定できるだけではなく、特定の欠陥を想定して実際に検出することができます。

例えば、穴が欠落しているために部品が「不良」と判定された場合、TestRun では、実際に部品に穴が欠落しているとジョブで判定されたために、その部品が不合格になったことを確認するのに役立ちます。フィクスチャとして使用したツールが、穴が欠落しているために部品を不合格と判定したとします。これは、ツールのサーチ領域が穴が欠落していることを特定して画像を取り込むのに十分な大きさを持っていたからで、元々このツールは穴の欠落を特定するためのツールではなかった場合、ジョブのロジックは正常には実行されておらず、TestRun はその不一致を特定するのに使用できます。

注: [欠陥テスト] 画面に移動すると、現在選択されているバリアントに対して設定操作が実行され、ジョブの状態が適切に設定されているかどうかが確認されます。

テストする欠陥の定義

  1. 画像を選択します。
  2. デフォルトの欠陥 [ジョブ FAIL] を設定します。
  3. 必要に応じて別の欠陥を追加し、それに対して想定される結果を定義します。

画像の選択

  1. 処理を開始するには、最初に [画像] グループボックスにある画像再生ボタンを使用して、画像を選択します。[次の画像] ボタンをクリックして、画像を進めます。

注: TestRun では、[画像の選択] ステップで定義した画像が使用されます。

  2. [画像] グループボックスおよびスプレッドシートビューに画像が表示されます。画像とその名前が含まれるフォルダが、画面上部のドロップダウンに表示されます。
  3. 以前に定義した欠陥に対して想定される結果も更新されます。

欠陥 [ジョブ FAIL] の想定される結果の設定

  1. デフォルトでは、欠陥 [ジョブ FAIL] が自動的に追加されて有効になります (チェックボックスがオンになります)。欠陥 [ジョブ FAIL] では、ジョブ全体がエラーを返すかどうかを決定するための想定される結果が定義されます。
  2. 欠陥 [ジョブ FAIL] を定義するには、[欠陥] グループボックスで、「次の場合、欠陥　"(欠陥名)"　が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します (デフォルトでは、「<ジョブ PASS/FAIL>」が選択されています)。[ジョブ FAIL] はシンボリックタグではありませんが、[<ジョブ PASS/FAIL>] のセルとして設定されたセルをテストします。
  3. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。

別の欠陥の追加および想定される結果の定義

  1. [追加] ボタンをクリックします。
  2. デフォルトの名前が「欠陥」である欠陥が追加されます。デフォルトでは、新しく追加した欠陥が有効にされます (チェックボックスがオンになります)。

注: 既に欠陥が追加されており、デフォルトの名前のままである場合、TestRun は名前の数値を 1 つ増加させます (例えば、「Defect01」、「Defect02」など)。[名前の変更] ボタンをクリックして、デフォルトの名前を編集し、欠陥にわかりやすい名前を割り当てます。

  3. [欠陥] グループボックスで、「次の場合欠陥　"欠陥"　が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  4. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。
  5. 必要に応じて、オンにしたエディットコントロールを使用し、テストを設定します。
  6. 必要に応じて、手順 1 ～ 4 を繰り返し、欠陥を追加します。

欠陥の編集

  1. リストから欠陥を選択します。
  2. [欠陥] グループボックスで、「次の場合欠陥 "(欠陥名)" が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  3. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。

[ハードウェアテスト-アクションのセットアップ]

TestRun でテストを行い、In-Sight ビジョンシステムが正しい画像を取り込んでいるかを確認するには、最初にそれに応じてジョブの状態を設定する必要があります。この画面では、テストを行う前にパラメータ設定を有効にして、ビジョンシステムが正しい画像を取り込んでいるかを確認します。

ジョブを設定して TestRun のハードウェアテストを実行

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。

注: 設定を選択すると、スプレッドシートでそのパラメータがハイライトされます。

  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [次へ] ボタンをクリックして、TestRun の設定を続行します。
  7. [アクションのセットアップ] のプログラムを実行したら、TestRun は自動的に In-Sight ビジョンシステムをトリガし、画像を取り込みます。

[ハードウェアテスト - テスト]

このステップでは、テストを設定して、取り込んだ画像が正しいかを確認します。TestRun では、特定のジョブパラメータとその想定される結果を画像と関連付けることによって、画像が正しい結果を生成しているかどうかを判別することができます。例えば、レンズが汚れているために、画像が不鮮明、傷がついている、または暗くなっているとします。この場合、In-Sight ビジョンシステムに不用意に接触すると、その視野 (FOV) が変わることがあります。または、ビジョンシステムに接続されているレンズのフォーカスや絞りが、振動によって時間とともに変化することがあります。このような状態をテストするには、ジョブパラメータを想定される結果に関連付けます。想定される結果が返されない場合は、画像処理に問題が発生しています。

FOV が正しいかどうかを判別するには、部品の特徴 (または、部品がない場合の背景) を使用します。画像に特徴が存在しない場合、FOV が変わっています。部品が検査前にフィクスチャに置かれている場合は、フィクスチャの 4 つの隅の特徴を使用して適切な FOV を設定できます。特徴がない場合、FOV が変わっています。または、特徴が近すぎるか離れすぎている場合は、In-Sight ビジョンシステムと FOV の間の距離が変化している可能性があります。特徴が矩形を形成しているが、四辺形ではない場合、ビジョンシステムに接触して軸がずれ、遠近歪みが生じている可能性があります。

TestRun ビジョンシステムの画像取り込みテストの定義

  1. 画像を取り込みます。
  2. 必要に応じて、テストを追加し、設定します。

画像の取り込み

  1. [画像] グループボックスの下の [手動トリガ] ボタンをクリックし、In-Sight ビジョンシステムから画像を取り込みます。
  2. [画像] グループボックスおよびスプレッドシートビューに画像が表示されます。

注: または、[画像のロード] ボタンをクリックして [開く] ダイアログを表示し、画像ファイルに移動します。

テストの追加と設定

  1. [ハードウェアテスト] グループボックスで、[追加] ボタンをクリックします。
  2. デフォルトの名前が「テスト」というテストが追加され、[テスト] グループボックスに置かれます。ここで、設定を行うことができます。

注: 既にテストが追加されており、デフォルトの名前のままである場合、TestRun は名前の数値を 1 つ増加させます (例えば、「Test01」、「Test02」など)。[名前変更] ボタンをクリックして、デフォルトの名前を編集し、テストにわかりやすい名前を割り当てます。

  3. [テスト] グループボックスで、「次の場合欠陥 "xxx" が存在します」テキストの下にあるドロップダウンメニューを使用し、該当するシンボリックタグを選択します。
  4. 選択したシンボリックタグの [テストタイプ] ドロップダウンメニューを適切に設定します。
  5. 必要に応じて、手順 1 ～ 4 を繰り返し、テストを追加します。

クリーンアップアクション

テストが完了したら、それに応じてジョブの状態を設定する必要があります。このステップでは、TestRun がテストを完了した後、ジョブを目的の状態に設定するのに必要な設定操作を定義します。

TestRun を設定して、テスト後にジョブパラメータを設定

  1. [シンボル] 列のリストからパラメータ設定を選択します。必要に応じて、プラス記号をクリックし、リストを展開します。

注: 設定を選択すると、スプレッドシートでそのパラメータがハイライトされます。

  2. 設定を有効にするには、設定の横にあるチェックボックスをオンにします。[アクションのセットアップ] 列に設定が自動的に入力されます。
  3. 設定を有効にして [アクションのセットアップ] 列でその設定を選択すると、2 つの列の下に設定のエディットコントロールが表示されます。
  4. 必要に応じて、設定を調整します。
  5. 設定が複数ある場合は、[上に移動]/[下に移動] ボタンを使用して、設定を実行順に並べます。TestRun では、この画面に表示されている順序に従って、設定操作を実行します。
  6. [閉じる] ボタンをクリックして、TestRun の設定を完了します。
  7. [TestRun セットアップ] ダイアログを閉じたら、[パレット] の [TestRun] タブにある [image] [実行] アイコンをクリックして、TestRun テストを実行します。

注: [TestRun セットアップ] ダイアログの設定を完了したら、[パレット] で使用できるすべてのボタンが表示された右クリックメニューが選択できるようになります。さらに、テストの特定のセクションからテストを実行する機能も使用できるようになります (例えば、ジョブテストを実行せずにハードウェアテストから開始する、など)。


マウスの操作

ナビゲーションとショートカット

In-Sight Explorer GUI リファレンス

以下の表に、In-Sight Explorer インタフェース内で使用される一般的なマウス操作をまとめています。

操作

In-Sight のネットワーク

In-Sight のファイル

スプレッドシート

左クリック

In-Sight センサが選択されている場合、[In-Sight のファイル] ペインが表示されますが、これが表示されている場合、最上部のレベルに戻ります。すべての In-Sight センサ (Explorer ホストテーブルのエントリ を含む) が [ファイル] リスト (フォルダ [image] アイコンによって示されます) に表示されます。

In-Sight センサ [image] またはエミュレータ [image] が選択されている場合、[In-Sight のファイル] ペインに、そのセンサのすべてのファイルが表示されます。

リストからファイルまたはセンサを選択します。

スプレッドシートのセルを選択し、そのセルをアクティブセルにします。

項目を選択して開きます。

値に加えられた変更を確定します。

対話型グラフィックスを調整します。

右クリック

In-Sight センサが選択されている場合、 Closed ショートカットメニュー が表示され、In-Sight のネットワークを更新できるほか、Explorer ホストテーブルにアクセスできます。

In-Sight センサ [image] またはエミュレータ [image] が選択されている場合、 Closed センサ固有のショートカットメニューが表示され、そのセンサのスプレッドシートビューまたはセンサのステータスビューを開くこと、レポートの作成、ファイルのバックアップ、ファイルのリストアが可能なほか、センサのプロパティを表示できます。

[In-Sight のネットワーク] ペインで In-Sight センサが選択されている場合、[In-Sight のファイル] ペインが最上部のレベルに戻ります。In-Sight センサ (フォルダ [image] アイコンによって示されます) が選択されている場合、 Closed [開く] メニューが表示され、選択されたセンサのすべてのファイルを表示することができます。

センサ (フォルダ [image] アイコンによって示されます) が選択されていない場合、 Closed [表示] メニューが表示され、サムネイル、タイル、リスト、または詳細ビューでファイルを配置することができます。

[In-Sight のネットワーク] ペインで In-Sight センサ [image] またはエミュレータ [image] が選択されている場合、[In-Sight のファイル] ペインに、そのセンサのすべてのファイルが表示されます。ファイルが選択されていない場合、 Closed センサ固有のショートカットメニュー が表示され、サムネイル、タイル、リスト、または詳細ビューごとにファイルを配置することができるほか、そのセンサでレポートの作成、ファイルのバックアップ、およびファイルの復元を実行できます。

ファイルが選択されている場合、 Closed ファイル固有のショートカットメニューが表示され、そのファイルをコピー、削除、または名前を変更することができます。

ショートカットメニューを表示します。

左ダブルクリック

In-Sight センサ [image] またはエミュレータ [image] をダブルクリックした場合、そのセンサまたはエミュレータのスプレッドシートビューが開きます。

[In-Sight のネットワーク] ペインで In-Sight センサが選択されている場合、[In-Sight のファイル] ペインが最上部のレベルに戻ります。In-Sight センサ (フォルダ [image] アイコンによって示されます) が選択されている場合、[In-Sight のファイル] ペインにそのセンサのすべてのファイルが表示されます。

スプレッドシートのセルを選択し、セルにボタンまたは編集コントロールが含まれていない限り、そのセルの数式を所定の場所で編集するか、またはプロパティシートを使用してセルの数式を編集します。セルにボタンが含まれている場合、最初のクリックによってボタンが有効になります。セルに編集コントロールが含まれる場合、最初のクリックによってセルの値の編集が開始されます。

行または列の分割線をダブルクリックした場合、その行または列はコンテンツに合わせて自動的にサイズが変更されます。

左クリックしてドラッグ

N/A

In-Sight センサ間でファイルをコピーします。ファイルは、[ファイル] ペインから、[In-Sight のネットワーク]のリストにある任意の In-Sight センサにドラッグすることができます。

ジョブファイルおよび画像ファイルをドラッグしてスプレッドシートビューを開くことができます。これにより、そのジョブまたは画像が目的のセンサでアクティブなジョブ/画像としてロードされます。

ブロックの編集操作をするためにセル、行または列の範囲を選択します。行または列の分割線をドラッグすると、行または列のサイズが変更されます。

右クリックしてドラッグ

N/A

In-Sight センサ間でファイルをコピーします。ファイルは、[ファイル] ペインから、[In-Sight のネットワーク]のリストにある任意の In-Sight センサにドラッグすることができます。

ジョブファイルおよび画像ファイルをドラッグしてスプレッドシートビューを開くことができます。これにより、そのジョブまたは画像が目的のセンサでアクティブなジョブ/画像としてロードされます。

ブロックの編集操作をするためにセル、行または列の範囲を選択します。右クリックするとショートカットメニューが直後に表示されます。

関連項目

キーボードのショートカット


関数リファレンス

In-Sight関数リファレンス

In-Sight 関数リファレンス

In-Sight Explorer 内で、スプレッドシートのセルに式を挿入することによって、アプリケーションを設定することができます。これらの式は、[関数の挿入] ダイアログで使用可能な関数を使用して構築します。In-Sight 関数は、次のカテゴリに分類されます。

  • ビジョンツール: 画像の特徴を抽出して処理します。
  • 幾何計測関数: 円、点、および線セグメントなど、標準の幾何学的構造体間の距離を計算します。
  • 画面表示関数: スプレッドシートと画像の表示を、対話型コントロールおよびグラフィックスデータ表示を使用してカスタマイズします。
  • 数値演算関数: 標準の数学演算子、論理関数、統計関数、および三角関数を使用して数式を構築します。
  • 文字列操作関数: 英数字データ文字列の表示および通信に関する書式設定を行います。
  • 座標補正関数: 画像、フィクスチャ、およびワールド座標系の間で特徴の位置および距離を変換します。
  • 入出力関数: In-Sight がリモートデバイスと通信する方法を制御します。
  • クロックドデータ関数: 時間の経過に従って、指定されたイベントに関する値を合計し続けます。
  • データアクセス関数: データ構造体から個別の値を抽出します。
  • 構造体関数: 他の関数で使用することができるグラフィックス、領域、およびフィクスチャを作成します。
  • スクリプト関数: ジョブに関連するタスクを実行するため、カスタム設計の JavaScript ソースコードを作成します。

上記に一覧表示されているカテゴリの関数に加えて、AcquireImage 関数はスプレッドシートのあらゆるジョブの必須条件であり、自動的にスプレッドシートのセル A0 に挿入されます。

注:関数とビジョンツールが使用可能かどうかは、特定の In-Sight ビジョンシステムとファームウェアによって異なります。特定の関数とビジョンツールが使用可能かどうかの詳細については、Cognex 販売代理店にお問い合わせください。

In-Sight® Explorerヘルプ　 - Version 5.6.0

06/11/2019 18:10

Copyright © 1999 -2019

Cognex Corporation

All Rights Reserved.


ブロブ

ビジョンツール

In-Sight 関数リファレンス

マシンビジョンの用語では、2 次元で、形状が変化しやすく、同じようにシェーディングされた連結されているピクセルのグループは、「ブロブ」と呼ばれます。これらのブロブを画像から抽出し、対象領域 (ROI) 内でブロブを検出し、それらを特定の基準に基づいてソートするプロセスは、ブロブ解析と呼ばれます。

In-Sight ビジョンシステムでは、ブロブツールの次の関数を使用して、ブロブ解析を実行します。

  • DetectBlobs 関数: 画像内のブロブを検出し、そのデータを抽出します。この関数は、ExtractBlobs より新しいアルゴリズムを使用してします。
  • ExtractBlobs 関数: 画像内のブロブを検出し、そのデータを抽出します。この関数は、ブロブ解析の最初のステップです。
  • FindBlobs 関数: 抽出されたブロブのリストを、特定の基準および検出されたブロブがその基準にどの程度マッチするかに基づいて、フィルタおよびソートします。
  • SortBlobs 関数: フィクスチャに対するブロブの位置に基づいて、ブロブのセットをソートします。

注: FindBlobs および SortBlobs 関数の両方とも、 [image] データ構造体を参照する必要があります。このデータ構造体は、DetectBlobs、ExtractBlobs、FindBlobs、または SortBlobs 関数によって作成することができます。

In-Sight についてブロブツール

ブロブ解析とは

In-Sight ブロブツールは、接続性の解析と呼ばれるタイプのブロブ解析を実行し、このステップは DetectBlobs または ExtractBlobs 関数を使用して実行されます。DetectBlobs または ExtractBlobs 関数をスプレッドシートに挿入してそのパラメータを設定すると、最初に ROI をセグメント化することによって解析の実行が開始されます。

このプロセス中、ROI 内のピクセルは、グレースケールしきい値に基づいて、ブロブと背景の 2 つのカテゴリに分類されます。このしきい値でピクセルを切り分けて、しきい値を下回るピクセルは黒として分類し、上回るピクセルは白として分類します。

注: このしきい値を指定するには、DetectBlobs または ExtractBlobs 関数の [しきい値] パラメータの自動設定を使用するか、試行錯誤しながら手動設定するか、またはヒストグラム関数の計算結果への参照として使用します。

このプロセスが実行されていくにつれて、ピクセルが検証され、 Closed その周囲のピクセルに接続されているかどうかが判定されます。ブロブピクセルの左右、上下、または斜めにある類似した値の別のピクセルに、ブロブピクセルが接触している場合、ブロブピクセルが周囲のピクセルに接続していると考えられます。背景ピクセルの左右、または上下にある類似した値の別のピクセルに、背景ピクセルが接触している場合、背景ピクセルが周囲のピクセルに接続していると考えられます。

下記の図は、In-Sight ブロブツールで画像を解析する方法を示しています。この例では、グレースケールしきい値 150 を使用して、画像をブロブピクセルと背景ピクセルにセグメント化しています。グレースケール値が 150 以上であるピクセルはすべて、白または背景として分類され、150 未満の値を持つピクセルはすべて、黒ピクセルまたはブロブピクセルとして分類されます。

ブロブが画像から抽出されると、DetectBlobs または ExtractBlobs 関数によって自動的に、 [image] データ構造体および抽出されたブロブに関するデータを含んでいる結果データが作成されます。返された情報は、FindBlobs および SortBlobs 関数によって使用され、検出されたその他のブロブをその物理的な特性と位置に基づいて、それぞれフィルタおよびソートすることができます。

FindBlobs 関数は ROI 内にあるブロブを解析して、検出されたブロブが指定した要件とマッチするかどうかを調べます。要件を満たすブロブが返され、それらがどの程度要件にマッチするかに関して、降順に得点化されます。

SortBlobs 関数は ROI 内にあるブロブを解析して、ブロブがフィクスチャに対してどこに位置しているかを特定します。このことは、別のブロブに対するブロブの位置を特定する場合に役立ち、DetectBlobs または ExtractBlobs 関数の 1 つを使用して ROI 内の多数のブロブを一度に検出することができます。

ブロブ解析を使用するタイミング

In-Sight ブロブツールは、次の条件が適用される場合に最適に使用することができます。

  • 画像が 2 次元のオブジェクトのものである。
  • 画像でピクセルの白黒の差がはっきりしており、高コントラストになっている。

注: In-Sight ブロブツールはグレースケール画像のみを解析します。カラー画像はすべて、自動的にグレースケール値に変換されます。

ブロブ解析を使用する理由

以上の条件が満たされると、ブロブ解析は次のアプリケーションで非常に役立つことができます。

  • 大まかな測定のアプリケーション。パーツの特定方向の幅を特定するために正方形の寸法を計測するなどします。
  • 初回通過の位置決めアプリケーション。ここでブロブツールを使用して大まかなフィクスチャをすばやく探し、別のツール用に配置します。
  • 有無を調べるアプリケーション。ここでブロブツールを使用して、画像内のブロブの有無を判定します。
  • 計数アプリケーション。ここでブロブツールを使用して、面積や周囲長などの特性に基づいて、ブロブの計数およびソートを設定することができます。

ブロブ解析の実行方法

In-Sight ブロブツールでは、ブロブ解析のプロセスは、次の 3 つに分けることができます。

ステップ 1 - 画像を調べて、画像とその条件がブロブ解析の要件を満たすかどうかを判定します。

ステップ 2 - DetectBlobs または ExtractBlobs 関数をスプレッドシートに挿入して適切に設定し、画像内のブロブを探して識別します。

ステップ 3 - FindBlobs または SortBlobs 関数をスプレッドシートに挿入し、ブロブの物理的な特性または位置に基づいて、検出されたブロブのリストをそれぞれフィルタします。


DetectBlobs

DetectBlobs |
ビジョンツール → ブロブ | In-Sight 関数リファレンス

DetectBlobs 関数は、対象領域 (ROI) において、「連結性解析」と呼ばれる一種のブロブ解析を実行します。

  • DetectBlobs の概要
  • DetectBlobs の入力パラメータ
  • DetectBlobs の出力
  • DetectBlobs データアクセス関数
  • DetectBlobs 関数の例
  • 関連項目

注: この関数は、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

DetectBlobs概要

この「連結性解析」の間、ROI に含まれるピクセルは、ブロブと背景の 2 つのカテゴリに分類されます。分類はグレースケールしきい値に基づいて行われ、このしきい値を下回るピクセルはすべて黒カテゴリに、上回るピクセルは白カテゴリに入ります。

同様に、類似した値を持つピクセルは、その「色」、および周囲のピクセルとの「接触」の有無を基準にグループ化されます。背景ピクセルは、左、右、上、下にあるピクセルと接触している場合は、周囲のピクセルと接続できます。一方、ブロブピクセルを周囲のピクセルと Closed 接続できるのは、左、右、上、下、または斜めにあるピクセルと接触している場合です。

処理の完了した画像は、ブロブまたは背景ピクセル値に分類されます。ROI 内のブロブは、画像内での位置 (列、行の座標)、面積、周囲長、拡散、伸長などの物理的な特性と割り当てられた値によって識別されます。抽出されたブロブのデータは、 [image] データ構造体に格納、報告されます。

この関数は、ブロブ分析の第 1 ステップとなります。FindBlobs と SortBlobs 関数は両方とも最終的に、直接またはセル依存関係の連鎖の中で、DetectBlobs 関数の [image] データ構造体を参照します。

DetectBlobsの入力パラメータ

DetectBlobs(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

外部定義領域,

ソートする数,

しきい値,

穴を埋める,

境界ブロブ,

ブロブの色,

背景色,

最小面積,

最大面積,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高 | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

ソートする数

返されるブロブの数を指定します。

0 | ブロブの色/背景色、および最小面積/最大面積パラメータで指定された色やサイズの設定に合うすべてのブロブを自動的に抽出していたはずです。
1 ～ 4096 (デフォルト = 1) | ブロブの色/背景色、および最小面積/最大面積パラメータで指定された色やサイズの設定に合うすべてのブロブを自動的に抽出していたはずです。上限値を上回る数のブロブが検出された場合、面積の大きい順に選択されます。

注: [ソートする数] パラメータの値が 0 より大きい場合、DetectBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

しきい値

ブロブを背景と区別するために使用されるグレースケール値を指定します。この値を決定するには、DetectBlobs 関数の自動設定 (デフォルト設定) を使用するか、試行錯誤しながら手動設定するか、またはヒストグラム関数の計算結果への参照として設定します。

-1 (デフォルト) | この関数は、しきい値を画像のグレースケール統計に基づいて自動的に評価、計算します。
0 ～ 255 | グレースケールのしきい値を 0 から 255 の範囲で指定します。

穴を埋める

穴に累積された統計を処理する 2 つの方法のうちの 1 つを指定します。

0 = OFF (デフォルト)

ブロブ統計全体における穴の効果を有効にします。例えば、ブロブに穴を追加すると、ブロブの面積が減少します。

注: OFF に設定すると、別のブロブ内の穴であるブロブが報告されます。下記の例では、ブロブ 0 内にあるブロブ 1 が報告されています。ブロブ統計で、ブロブ 0 の面積 (上の行) の値にはブロブ 1 の面積 (下の行) は含まれていません。

1 = ON

ブロブ統計全体における穴の効果を無効にします。例えば、ブロブに穴を追加しても、ブロブの面積は影響を受けません。

注: ON に設定すると、別のブロブ内の穴であるブロブは無視されます。下記の例では、ブロブ 0 内の穴は無視され、1 つのブロブ (ブロブ 0) のみが報告されています。ブロブ統計で、ブロブ 0 の面積の値には、穴を含むブロブ領域全体が含まれています。

注: ExtractBlobs の [穴を埋める] は、[穴を埋める] チェックボックスをオンにすると別のブロブ内の穴を報告するもので、DetectBlobs の [穴を埋める] とは異なります。

境界ブロブ

ROI 境界線を横切るブロブを処理する 2 つの方法のうちの 1 つを指定します。

0 = OFF | ROI 境界線と交差するブロブを除外します。ROI 境界線と交差するブロブは一切、最終的な [image] データ構造体には含まれません。
1 = ON (デフォルト) | ROI 境界線と交差するブロブが含まれます。ROI 境界線と交差するすべてのブロブは、最終的な [image] データ構造体に含まれます (ただし、同時に、ブロブの色/背景色、および最小面積/最大面積 パラメータの設定も満たしている場合)。

色: ブロブ

ブロブの色を指定します。

0 = 黒 | 指定されたグレースケールしきい値を下回るブロブのみ返されます。
1 = 白 | 指定されたグレースケールしきい値を上回るブロブのみ返されます。
2 = 任意 (デフォルト) | ブロブの色に対する条件はありません。
注:

  • [色: ブロブ] および [色: 背景] が同じ色に設定されている場合、ブロブは報告されません。例えば、[色: ブロブ] が「黒」に設定され、[色: 背景] も「黒」に設定されている場合、ブロブは報告されません。

    色: ブロブ = 黒

    色: 背景 = 黒

    色: ブロブ = いずれか一方が白

    色: 背景 = 黒

    ただし、[色: ブロブ] および [色: 背景] が同じ色に設定されている場合でも、ブロブが反対色のエリアによって含められているときには、ブロブが報告されます (下記の例を参照)。ブロブのいずれかの部分が反対色によって含められていない場合は、ブロブは報告されません。

    色: ブロブ = 黒
    色: 背景 = 黒

    色: ブロブ = 白

    色: 背景 = 白

  • 色: DetectBlobs の [色: ブロブ] は ExtractBlobs の [色: ブロブ] とは異なります。こちらは [色: ブロブ] および [色: 背景] が同じ色に設定されている場合でも、ブロブの選択された色を報告します。

    Closed DetectBlobs および ExtractBlobs 関数の例
    DetectBlobs 関数 ExtractBlobs 関数

    色: ブロブ = 黒

    色: 背景 = 黒

    色: ブロブ = いずれか一方が白

    色: 背景 = 黒

色: 背景

取り込まれた画像の背景色を指定します。8 方向の連結性解析は前景上で実行され、4 方向の連結性解析は背景上で実行されます。

0 = 黒

1 = 白 (デフォルト)

最小面積

返されるブロブすべてに対する最小面積の制限をピクセル数で指定します (0 ～ 900000、デフォルト = 100)。[最小面積] の値を上回る面積を持つ穴のみ返されます。

最大面積

返されるブロブすべてに対する最大面積の制限をピクセル数で指定します (0 ～ 900000。デフォルト = 100000)。[最大面積] の値を下回る面積を持つブロブのみが返されます。

表示

画像上にオーバレイする DetectBlobs グラフィックスの表示モードを指定します。

0 = 非表示 (デフォルト) | DetectBlobs 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブの輪郭が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と抽出されたブロブのアウトラインの両方が常に表示されます。

DetectBlobsの出力

戻り値

画像から抽出されたブロブを含んでいる [image] データ構造体。入力パラメータのいずれかが無効であれば #ERR を返します。

結果

DetectBlobs 関数を初めてセルに挿入すると、スプレッドシートに Closed 結果テーブルが作成されます。[ソートする数] が 0 の場合、テーブルは GetNFound 関数のみで構成されます。[ソートする数] が 0 より大きい場合は、複数の関数が挿入され、ソートする数の行が最大になるブロブの結果テーブルが作成されます。

注: [ソートする数] パラメータの値が 0 より大きい場合、DetectBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

DetectBlobsデータアクセス関数

ここでは、画像内のブロブに関する重要な統計情報を提供する関数について説明します。

次のデータアクセス関数が、DetectBlobs [image] データ構造体結果テーブルを作成するためにスプレッドシートに自動挿入されます。

スプレッドシートの関数 | 関数名 | 説明
インデックス | なし | インデックスで指定されたブロブを、エリア内で大きい順にソートして返します。
行 | GetRow(ブロブ, ブロブインデックス) | ブロブの重心の Y 座標 (行) を返します。 Closed 例
列 | GetCol(ブロブ, ブロブインデックス) | ブロブの重心の X 座標 (列) を返します。 Closed 例
角度 | GetAngle(ブロブ, ブロブインデックス) | Y 軸に対するブロブの主 (メジャー) 軸の角度を返します。 注: 矩形の [角度] の値は、ExtractBlobs 関数の角度とは異なり、180° と報告される場合があります。 Closed 例
色 | GetColor(ブロブ, ブロブインデックス) | ブロブの色の値 (0 = 黒、1 = 白) を返します。
得点 | GetScore(ブロブ, ブロブインデックス) | ブロブが、FindBlobs 関数の条件にどの程度一致しているかを表します。
面積 | GetArea(ブロブ, ブロブインデックス) | ブロブの面積を返します (ピクセル単位)。 Closed 例 注: ブロブに穴がある場合、[面積] の値は、[穴を埋める] チェックボックスが ON か OFF かによって異なります。
伸長 | GetElongation(ブロブ, ブロブインデックス) | ブロブのピクセルが、ブロブの重心からどの程度伸びているかを表す値を返します。例えば、円の伸長は 0 ですが、釘の伸長の値は大きくなります。 Closed 例
穴 | GetHoles(ブロブ, ブロブインデックス) | ブロブに含まれている穴の数を返します。 注: [最小面積] の値を上回る面積を持つ穴のみ返されます。
周囲長 | GetPerimeter(ブロブ, ブロブインデックス) | ブロブを囲む境界線の長さを返します。周囲長は、ブロブの境界線を形成するピクセルの外部エッジをカウントすることにより計算されます。 Closed 例
拡散 | GetSpread(ブロブ, ブロブインデックス) | ブロブのピクセルが、ブロブの重心からどの程度拡散しているかを表す値を返します。例えば、円形の対象物の拡散値は楕円形の対象物の場合よりも小さくなります。 Closed 例

DetectBlobs 関数の例

DetectBlobs 関数を使用して、連結されているピクセルのブロブを識別して配置し、さまざまな形状およびサイズで構成することができます。この例では、DetectBlobs データ構造体結果テーブルに返される情報と検出されたブロブとの関連性、また、後にこの情報を使用して、ブロブを特性に基づいてソートし、フィルタする方法を示します。

この例では、次の画像は、DetectBlobs 関数の結果ページに返された値の意味を表すために使用されています。

DetectBlobs 関数が、スプレッドシートの空のセルに挿入されました。形状に基づいて、 Closed DetectBlobs プロパティシートのパラメータは次のように構成されました。

  • 画像: この例ではデフォルト設定が使用されていますが、ブロブを検出する前に画像から余分なノイズを除去する処理を行う Filter 関数により生成された [image] データ構造体など、このパラメータはどの [image] データ構造体でも参照できます。
  • フィクスチャ: 画像が静止していて、回転や移動をしないので、デフォルト設定を使用しました。ただし、DetectBlobs 関数を使用して画像の移動処理を行う場合は、画像の範囲をフィクスチャに割り当てることを推奨します。
  • 領域: 分析される形状すべてが含まれるように、画像領域を最大化しました。領域パラメータをクリックし、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。
  • ソートする数: [ソートする数] は 6 に設定されました。このパラメータは 0 に設定することもできましたが、その場合、このツールはブロブの色/背景色、および最小面積/最大面積パラメータで指定された色やサイズの設定に合うすべてのブロブを自動的に抽出していたはずです。
  • しきい値: デフォルト設定を使用して、グレースケールのしきい値を自動的に計算します。この画像では、グレースケール値の差は非常に顕著で、どのピクセルが暗く、どのピクセルが明るいかは明白です。微妙なグラデーションがかかり、しきい値の自動設定ではうまく値を分類できない場合は、HistHead 関数や HistTail 関数などのヒストグラム関数を使用して、画像のさまざまな領域のグレースケール濃度を判定します。
  • 穴を埋める: デフォルト設定が使用されます。このとき、ブロブにある穴が影響するため、穴の開いたブロブの全体の面積は小さくなります。[穴を埋める] チェックボックスを ON にすると、ブロブ内の穴が報告されて穴の面積が加算され、穴の開いたブロブの面積が大きくなります。
  • 境界ブロブ: デフォルト設定を使用しました。このとき、画像領域の境界線に触れているブロブも含まれます。この設定では、カメラ画像を左に移動して、最大の円と最小の正方形を領域の左端と交差させたとき、これらの形状のうち、領域の境界線内に入っている部分はブロブとして抽出されます。このチェックボックスが OFF の場合、これらのブロブは処理されません。
  • 最小面積/最大面積: デフォルト設定を使用しました。これらの設定によって、抽出中に領域内のブロブがフィルタされ、ブロブの最大面積と最小面積の設定に基づいて、そのブロブをブロブとして分類できるかどうかが判定されます。
  • 表示: デフォルト設定を使用しました。このとき、下の例にあるように、 [image] データ構造体を含むセルが選択されている場合だけ、結果のグラフィックスが表示されます。

DetectBlobs プロパティシートを設定すると、 [image] データ構造体と Closed 結果データテーブルが生成されます。

結果テーブルに返された値は、FindBlobs 関数および SortBlobs 関数を使用したブロブのフィルタとソートに使用できます。例えば、FindBlobs 関数をスプレッドシートに挿入し、DetectBlobs 関数を参照することができます。その後、FindBlobs 関数を使用し、ブロブの拡散に基づいて、ブロブをフィルタします。さらに、スプレッドシートに SortBlobs 関数を挿入すると、この関数はあらかじめ作成しておいた FindBlobs 関数を参照して、ブロブの X、Y 位置に基づいてブロブのリストをソートすることができるようになります。

関連項目

  • ブロブツールについて
  • ブロブデータアクセス関数
  • FindBlobs 関数
  • SortBlobs 関数
  • プロパティシートの使用方法
Version: 5.6.0


ExtractBlobs 関数

ExtractBlobs 関数 |
ビジョンツール → ブロブ | In-Sight 関数リファレンス

ExtractBlobs 関数は、対象領域 (ROI) において、「連結性解析」と呼ばれる一種のブロブ解析を実行します。

  • ExtractBlobs 関数の概要
  • ExtractBlobs の入力パラメータ
  • ExtractBlobs の出力
  • ExtractBlobs データアクセス関数
  • ExtractBlobs 関数の例
  • 関連項目

ExtractBlobs 関数概要

この「連結性解析」の間、ROI に含まれるピクセルは、ブロブと背景の 2 つのカテゴリに分類されます。分類はグレースケールしきい値に基づいて行われ、このしきい値を下回るピクセルはすべて黒カテゴリに、上回るピクセルは白カテゴリに入ります。

同様に、類似した値を持つピクセルは、その「色」、および周囲のピクセルとの「接触」の有無を基準にグループ化されます。背景ピクセルは、左、右、上、下にあるピクセルと接触している場合は、周囲のピクセルと接続できます。一方、ブロブピクセルを周囲のピクセルと Closed その周囲のピクセルに接続されているかどうかができるのは、左、右、上、下、または斜めにあるピクセルと接触している場合です。

処理の完了した画像は、ブロブまたは背景ピクセル値に分類されます。ROI 内のブロブは、画像内での位置 (列、行の座標)、面積、周囲長、拡散、伸長などの物理的な特性と割り当てられた値によって識別されます。抽出されたブロブのデータは、 [image] データ構造体に格納、報告されます。

この関数は、ブロブ分析の第 1 ステップとなります。FindBlobs と SortBlobs は両方とも最終的に、直接またはセル依存関係の連鎖の中で、ExtractBlobs 関数の [image] データ構造体を参照します。

ExtractBlobs 関数の入力パラメータ

ExtractBlobs 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

外部定義領域 ,

ソートする数 ,

しきい値 ,

穴を埋める ,

境界ブロブ ,

カラーブロブ ,

背景色 ,

面積制限: 最小 ,

面積制限: 最大 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

ソートする数

返されるブロブの数を指定します。

0 | ブロブの色/背景色、および最小面積/最大面積パラメータで指定された色やサイズの設定に合うすべてのブロブを自動的に抽出していたはずです。
1 ～ 4096 (デフォルト = 1) | ブロブの色/背景色、および最小面積/最大面積パラメータで指定された色やサイズの設定に合うすべてのブロブを自動的に抽出していたはずです。上限値を上回る数のブロブが検出された場合、面積の大きい順に選択されます。

注意: [ソートする数] パラメータの値が 0 より大きい場合、ExtractBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

Threshold

ブロブを背景と区別するために使用されるグレースケール値を指定します。この値を決定するには、ExtractBlobs 関数の自動設定 (デフォルト設定) を使用するか、試行錯誤しながら手動設定するか、またはヒストグラム関数の計算結果への参照として設定します。

-1 (デフォルト) | この関数は、しきい値を画像のグレースケール統計に基づいて自動的に評価、計算します。
0 ～ 255 | グレースケールのしきい値を 0 から 255 の範囲で指定します。

Fill Holes

穴に累積された統計を処理する 2 つの方法のうちの 1 つを指定します。

Closed 例

次のブロブの形は、ブロブ統計全体で穴の効果を有効または無効にしたときの効果を表しています。

上側が [穴を埋める] チェックボックスを OFF にしたときの結果で、下側が ON のときの結果です。[穴を埋める] チェックボックスを OFF にすると、面積の値が小さくなることがわかります。

0 = OFF (デフォルト) | ブロブ統計全体における穴の効果を有効にします。例えば、ブロブに穴を追加すると、ブロブの面積が減少します。
1 = ON | ブロブ統計全体における穴の効果を無効にします。例えば、ブロブに穴を追加しても、ブロブの面積は影響を受けません。

Boundary Blobs

ROI 境界線を横切るブロブを処理する 2 つの方法のうちの 1 つを指定します。

0 = OFF | ROI 境界線と交差するブロブを除外します。ROI 境界線と交差するブロブは一切、最終的な [image] データ構造体には含まれません。
1 = ON (デフォルト) | ROI 境界線と交差するブロブが含まれます。ROI 境界線と交差するすべてのブロブは、最終的な [image] データ構造体に含まれます (ただし、同時に、ブロブの色/背景色、および最小面積/最大面積 パラメータの設定も満たしている場合)。

Color Blob

ブロブの色を指定します。

0 = 黒 | 指定されたグレースケールしきい値を下回るブロブのみ返されます。
1 = 白 | 指定されたグレースケールしきい値を上回るブロブのみ返されます。
2 = 任意 (デフォルト) | ブロブの色に対する条件はありません。

Color Background

取り込まれた画像の背景色を指定します。背景色がブロブの色と異なる場合、8 方向の連結性解析が実行されます。 背景色とブロブの色が一致する場合は、4 方向の連結性解析が行われます。

0 = 黒

1 = 白 (デフォルト)

Area Limit: Min

返されるブロブすべてに対する最小面積の制限をピクセル数で指定します (0 ～ 900000、デフォルト = 100)。[最小面積] の値を上回る面積を持つ穴のみ返されます。

Area Limit: Max

返されるブロブすべてに対する最大面積の制限をピクセル数で指定します (0 ～ 900000。デフォルト = 100000)。[最大面積] の値を下回る面積を持つブロブのみが返されます。

Show

画像上の ExtractBlobs グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | ExtractBlobs 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブの輪郭が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と抽出されたブロブのアウトラインの両方が常に表示されます。

ExtractBlobs 関数の出力

戻り値

画像から抽出されたブロブを含んでいる [image] データ構造体。入力パラメータのいずれかが無効であれば #ERR を返します。

結果

ExtractBlobs 関数を初めてセルに挿入すると、スプレッドシートに Closed 結果テーブルが作成されます。[ソートする数] が 0 の場合、テーブルは GetNFound 関数のみで構成されます。[ソートする数] が 0 より大きい場合は、複数の関数が挿入され、ソートする数の行が最大になるブロブの結果テーブルが作成されます。

注意: [ソートする数] パラメータの値が 0 より大きい場合、ExtractBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

ExtractBlobs 関数データアクセス関数

ここでは、画像内のブロブに関する重要な統計情報を提供する関数について説明します。

次のデータアクセス関数が、ExtractBlobs [image] データ構造体結果テーブルを作成するためにスプレッドシートに自動挿入されます。

スプレッドシート名 | 関数名 | 説明
インデックス | なし | インデックスで指定されたブロブを、エリア内で大きい順にソートして返します。
行 | GetRow(ブロブ, ブロブインデックス) | ブロブの重心の Y 座標 (行) を返します。 Closed 例
列 | GetCol(ブロブ, ブロブインデックス) | ブロブの重心の X 座標 (列) を返します。 Closed 例
角度 | GetAngle(ブロブ, ブロブインデックス) | ROI の中心に対するブロブの主軸の角度を返します。 Closed 例
カラー | GetColor(ブロブ, ブロブインデックス) | ブロブの色の値 (0 = 黒、1 = 白) を返します。
得点 | GetScore(ブロブ, ブロブインデックス) | ブロブが、FindBlobs 関数の条件にどの程度一致しているかを表します。
面積 | GetArea(ブロブ, ブロブインデックス) | ブロブの面積を返します (ピクセル単位)。 Closed 例 注: ブロブに穴がある場合、面積の値は、[穴を埋める] チェックボックスが ON か OFF かによって異なります。
伸長 | GetElongation(ブロブ, ブロブインデックス) | ブロブのピクセルが、ブロブの重心からどの程度伸びているかを表す値を返します。例えば、円の伸長は 0 ですが、釘の伸長の値は大きくなります。 Closed 例
穴 | GetHoles(ブロブ, ブロブインデックス) | ブロブに含まれている穴の数を返します。
周囲長 | GetPerimeter(ブロブ, ブロブインデックス) | ブロブを囲む境界線の長さを返します。周囲長は、ブロブの境界線を形成するピクセルの外部エッジをカウントすることにより計算されます。 Closed 例
拡散 | GetSpread(ブロブ, ブロブインデックス) | ブロブのピクセルが、ブロブの重心からどの程度拡散しているかを表す値を返します。例えば、円形の対象物の拡散値は楕円形の対象物の場合よりも小さくなります。 Closed 例

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

しきい値 | GetThresh(ブロブ) | 画像のセグメント化に使用されたしきい値を返します。
検出数 | GetNFound(ブロブ) | 検出されたブロブの数を返します。
高さ | GetHigh(ブロブ, ブロブインデックス) | インデックス付きブロブの高さを返します。
幅 | GetWide(ブロブ, ブロブインデックス) | インデックス付きブロブの幅を返します。
最小行 | GetMinRow(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、ブロブの周りを囲む正方形の境界ボックスの一番上の行座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最小列 | GetMinCol(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、ブロブの周りを囲む正方形の境界ボックスの左端の列座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最大行 | GetMaxRow(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、ブロブの周りを囲む正方形の境界ボックスの一番下の行座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最大列 | GetMaxCol(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、ブロブの周りを囲む正方形の境界ボックスの左端の列座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。

ExtractBlobs 関数の例

分析される形状すべてが含まれるように、画像領域は最大化されました。この例では、ExtractBlobs データ構造体結果テーブルに返される情報と検出されたブロブとの関連性、また、後にこの情報を使用して、ブロブを特性に基づいてソートし、フィルタする方法を示します。

この例では、次の画像は、ExtractBlobs 関数の結果ページに返された値の意味を表すために使用されています。

ExtractBlobs 関数が、スプレッドシートの空のセルに挿入されました。形状に基づいて、 Closed ExtractBlobs プロパティシートのパラメータは次のように構成されました。

画像: この例ではデフォルト設定が使用されていますが、ブロブを検出する前に画像から余分なノイズを除去する処理を行う NeighborFilter 関数により生成された [image] データ構造体など、このパラメータはどの [image] データ構造体でも参照できます。

フィクスチャ: 画像が静止していて、回転や移動をしないので、デフォルト設定を使用しました。ただし、ExtractBlobs 関数を使用して画像の移動処理を行う場合は、画像の範囲をフィクスチャに割り当てることを推奨します。

領域: 分析される形状すべてが含まれるように、画像領域を最大化しました。領域パラメータをクリックし、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

ソートする数: 6 個の形状があるので、ソートする数は 6 に設定しました。このパラメータは 0 に設定することも可能で、その場合、自動的に 6 個の形状が抽出されます。

しきい値: デフォルト設定を使用して、グレースケールのしきい値を自動的に計算します。この画像では、グレースケール値の差は非常に顕著で、どのピクセルが暗く、どのピクセルが明るいかは明白です。微妙なグラデーションがかかり、しきい値の自動設定ではうまく値を分類できない場合は、HistHead 関数や HistTail 関数などのヒストグラム関数を使用して、画像のさまざまな領域のグレースケール濃度を判定します。

穴を埋める: デフォルト設定が使用されます。このとき、ブロブにある穴が影響するため、穴の開いたブロブの全体の面積は小さくなります。[穴を埋める] チェックボックスを ON にすると、穴の面積が加算され、穴の開いたブロブの面積が大きくなります。

境界ブロブ: デフォルト設定を使用しました。このとき、画像領域の境界線に触れているブロブも含まれます。この設定では、カメラ画像を左に移動して、円とダンベル形の図形を領域の左端と交差させたとき、これらの形状のうち、領域の境界線内に入っている部分はブロブとして抽出されます。このチェックボックスが OFF の場合、これらのブロブは処理されません。

最小/面積/最大面積: デフォルト設定を使用しました。これらの設定によって、抽出中に領域内のブロブがフィルタされ、ブロブの最大面積と最小面積の設定に基づいて、そのブロブをブロブとして分類できるかどうかが判定されます。

表示: デフォルト設定を使用しました。このとき、下の例にあるように、 [image] データ構造体を含むセルが選択されている場合だけ、結果のグラフィックスが表示されます。

ExtractBlobs プロパティシートを設定すると、 [image] データ構造体と Closed 結果データテーブルが生成されます。

結果を見ると、すべての形状の面積はほとんど同じで、角度、伸長、周囲長などそのほかの値は大きなばらつきを示しています。結果テーブルに返された値は、FindBlobs 関数および SortBlobs 関数を使用したブロブのフィルタとソートに使用できます。例えば、FindBlobs 関数をスプレッドシートに挿入し、ExtractBlobs 関数を参照することができます。その後、FindBlobs 関数を使用し、ブロブの拡散に基づいて、ブロブをフィルタします。さらに、スプレッドシートに SortBlobs 関数を挿入すると、この関数はあらかじめ作成しておいた FindBlobs 関数を参照して、ブロブの X、Y 位置に基づいてブロブのリストをソートすることができるようになります。

関連項目

  • ブロブツールについて
  • ブロブデータアクセス関数
  • FindBlobs 関数
  • SortBlobs 関数
  • プロパティシートの使用方法


FindBlobs 関数

FindBlobs 関数 |
ビジョンツール → ブロブ | In-Sight 関数リファレンス

FindBlobs を使用して、 [image] データ構造体で返されたブロブのフィルタとソートを行います。

  • FindBlobs 関数の概要
  • FindBlobs の入力パラメータ
  • FindBlobs の出力
  • FindBlobs データアクセス関数
  • FindBlobs の例

FindBlobs 関数概要

FindBlobs パラメータ設定を使用して、得点を計算する式を作成し、 [image] データ構造体で参照されているブロブが「最適な」ブロブとどの程度一致するかを計測します。このパラメータ設定に基づいて、FindBlobs 関数は指定した要件を満たすブロブのみを次々に返します。

参照されている [image] データ構造体内の各ブロブは、2 ステップの分析を受けます。最初に、個別の FindBlobs パラメータ設定のそれぞれで、特定のパラメータ値を評価する式を作成します。例えば、角度の得点を計算するには、[範囲] と [角度] パラメータの [角度] の値と、[範囲] と参照されるブロブの [角度] の値との差を除算して、[重量] の値で乗算します。個別の得点を計算した後、個別のパラメータの得点のそれぞれを加算して、個別の [重量] パラメータ値の合計で除算します。その後この得点は [アクセプトしきい値] の値と比較されて、ブロブが指定した要件を満たすかどうかを判定します。

FindBlobs 関数で抽出されたブロブのフィルタおよびソートを完了すると、新しい [image] データ構造体とこれに伴う結果テーブルが自動的にスプレッドシートに挿入されます。この結果テーブルは、検出されたブロブが設定されている要件とどの程度一致するかによって、降順にソートされます。

FindBlobs 関数は、欠陥検出のために特徴を分類する際に非常に有用です。例えば、ジョブで表面上の傷を検出しようとする場合に、FindBlobs 関数は [伸長] の値がより高いブロブのみを返すように設定することができます。または、エッジのギザギザの欠陥を検出することが目的であった場合、[周囲長] または [拡散] の値がより高いブロブのみを FindBlobs 関数が返すように設定することができます。

FindBlobs 関数の入力パラメータ

FindBlobs 関数(

ブロブ ,

検出する数 ,

アクセプトしきい値 ,

角度.角度 ,

角度.範囲 ,

角度.重量 ,

領域.領域 ,

領域.範囲 ,

領域.重量 ,

伸長.伸長 ,

伸長.範囲 ,

伸長.重量 ,

穴.数 ,

穴.範囲 ,

穴.重量 ,

周囲長.周囲長 ,

周囲長.範囲 ,

周囲長.重量 ,

拡散.拡散 ,

拡散.範囲 ,

拡散.重量 ,

表示

)

ブロブ

このパラメータは、フィルタおよびソートの対象となる [image] データ構造体を含むスプレッドシートのセルを参照します。

検出する数

返されるブロブの最大数 (1 ～ 4096、デフォルト = 3) を指定します。[アクセプトしきい値] 設定を上回る得点を持つブロブが、指定した数よりも多く画像内に存在する場合は、最高得点のブロブが選択されます。

注意: [検出する数] パラメータの値が 0 より大きい場合、FindBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

アクセプトしきい値

許容できる一致最低得点を指定します (0 ～ 100、デフォルト = 10)。FindBlobs 関数は、[アクセプトしきい値] を超える一致得点を持つブロブのみを返します。一致得点は、次の式で計算されます。

([角度] 得点 + [面積] 得点 + [伸長] 得点 + [穴] 得点 + [周囲長] 得点 + [拡散] 得点) × (100 ÷ パラメータの [重量] の値の合計)

角度

このパラメータを使用して、検出されたブロブの最適な [角度] 得点を割り出す得点付けの式を設定します。

Closed 角度を得点付けする式

FindBlobs 関数の [角度] 得点は、次の式を使用して計算されます。

[角度] 得点 = [([範囲] + [角度]) - BlobAngleVal] ÷ [範囲] × WeightVal

BlobAngleVal = 参照されているブロブの出力 [角度] の値

WeightVal = [重量] ÷ (すべての重量の値の合計) × 100

角度 | 最適なブロブの角度 (-360 ～ 360、デフォルト = 0)
範囲: | 類似性得点付けでのブロブの角度の許容値 (0 ～ 360、デフォルト = 0)
重量 | 類似性得点付けでのブロブ角度の相対的な重要度 (0 ～ 100、デフォルト = 0)

面積

このパラメータを使用して、検出されたブロブの最適な [面積] 得点を割り出す得点付けの式を設定します。

Closed 面積を得点付けする式

FindBlobs の [面積] 得点は、BlobAreaVal および [面積] の値に応じて、次の式を使用して計算されます。

BlobAreaVal が [面積] の値よりも大きい場合は、この式が使用されます。

[面積] 得点 = [([範囲] + [面積]) - BlobAreaVal] ÷ [範囲] × WeightVal

BlobAreaVal が [面積] の値より小さい場合は、この式が使用されます。

[面積] 得点 = [BlobAreaVal - ([面積] - [範囲])] ÷ [範囲] × Weight Val

BlobAreaVal = 参照されているブロブの出力 [範囲] の値

WeightVal = [重量] ÷ (すべての重量の値の合計) × 100

面積 | ブロブの最適な面積サイズ (ピクセル単位) (0 ～ 900000、デフォルト = 1000)。
範囲 | 類似性得点付けでのブロブの面積の許容値 (0 ～ 900000、デフォルト = 20000)。
重量 | 類似性得点付けでのブロブ面積の相対的な重要度 (0 ～ 100、デフォルト = 50)。

伸長

このパラメータを使用して、検出されたブロブの最適な [伸長] 得点を割り出す得点付けの式を設定します。

Closed 伸長を得点付けする式

FindBlobs 関数の [伸長] 得点は、次の式を使用して計算されます。

[伸長] 得点 = [([範囲] + [伸長]) - BlobElongationVal] ÷ [範囲] × WeightVal

BlobElongationVal = 参照されているブロブの出力 [伸長] の値

WeightVal = [重量] ÷ (すべての重量の値の合計) × 100

伸長 | ブロブの最適な伸長 (0 ～ 900000、デフォルト = 1)。
範囲 | 類似性得点付けでのブロブの伸長の許容値 (0 ～ 900000、デフォルト = 2)。
重量 | 類似性得点付けでのブロブ伸長の相対的な重要度 (0 ～ 100、デフォルト = 50)。

穴

このパラメータを使用して、検出されたブロブの最適な [穴] 得点を割り出す得点付けの式を設定します。

Closed 穴を得点付けする式

FindBlobs 関数の [穴] 得点は、次の式を使用して計算されます。

[穴] 得点 = [([範囲] + [数]) - BlobHolesVal] ÷ [範囲] × WeightVal

BlobHolesVal = 参照されているブロブの出力 [穴] の値

WeightVal = [重量] ÷ (すべての重量の値の合計) × 100

数 | ブロブの最適な穴の数 (0 ～ 10000、デフォルト = 0)。
範囲 | 類似性得点付けでのブロブの穴の数の許容値 (0 ～ 10000、デフォルト = 2)。
重量 | 類似性得点付けでのブロブの穴の数の相対的な重要度 (0 ～ 100、デフォルト = 0)。

周囲長

このパラメータを使用して、検出されたブロブの最適な [周囲長] 得点を割り出す得点付けの式を設定します。

Closed 周囲長を得点付けする式

FindBlobs 関数の [周囲長] 得点は、次の式を使用して計算されます。

[周囲長] 得点 = [([範囲] + [周囲長]) - BlobPerimeterVal] ÷ [範囲] × WeightVal

BlobPerimeterVal = 参照されているブロブの出力 [周囲長] の値

WeightVal = [重量] ÷ (すべての重量の値の合計) × 100

周囲長 | ブロブの最適な周囲長 (0 ～ 100000、デフォルト = 1000)。
範囲 | 類似性得点付けでのブロブの周囲長の許容値 (0 ～ 100000、デフォルト = 10000)。
重量 | 類似性得点付けでのブロブ周囲長の相対的な重要度 (0 ～ 100、デフォルト = 50)。

拡散

このパラメータを使用して、検出されたブロブの最適な [拡散] 得点を割り出す得点付けの式を設定します。

Closed 拡散を得点付けする式

FindBlobs 関数の [拡散] 得点は、次の式を使用して計算されます。

[拡散] 得点 = [([範囲] + [拡散]) - BlobSpreadVal] ÷ [範囲] × WeightVal

BlobSpreadVal = 参照されているブロブの出力 [拡散] の値

WeightVal = [重量] ÷ (すべての重量の値の合計) × 100

拡散 | ブロブの最適な拡散 (0 ～ 900000、デフォルト = 1)。
範囲 | 類似性得点付けでのブロブの拡散の許容値 (0 ～ 900000、デフォルト = 2)。
重量 | 類似性得点付けでのブロブ拡散の相対的な重要度 (0 ～ 100、デフォルト = 50)。

表示

画像上の FindBlobs グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindBlobs 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブの輪郭が常に表示されます。

FindBlobs 関数の出力

戻り値 | 得点によってソートされ、一致したブロブを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindBlobs 関数を初めてセルに挿入すると、 Closed 結果テーブルがスプレッドシートに作成されます。 注意: [検出する数] パラメータの値が 0 より大きい場合、FindBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

FindBlobs 関数データアクセス関数

FindBlobs [image] データ構造体の結果テーブルを作成するために、次のデータアクセス関数がスプレッドシートに自動挿入されます。

スプレッドシート名 | 関数名 | 説明
行 | GetRow(ブロブ, ブロブインデックス) | 参照されるブロブの重心の Y 座標 (行) を返します。 Closed 例
列 | GetCol(ブロブ, ブロブインデックス) | 参照されるブロブの重心の X 座標 (列) を返します。 Closed 例
角度 | GetAngle(ブロブ, ブロブインデックス) | ROI の中心に対するブロブの主軸の角度を返します。 Closed 例
色 | GetColor(ブロブ, ブロブインデックス) | 参照されるブロブのカラーの値 (0 = 黒、1 = 白) を返します。
得点 | GetScore(ブロブ, ブロブインデックス) | ブロブが、FindBlobs 関数の条件にどの程度一致しているかを表します。
面積 | GetArea(ブロブ, ブロブインデックス) | 参照されるブロブの面積を返します (ピクセル単位)。 Closed 例 注: ブロブに穴がある場合、面積の値は、[穴を埋める] チェックボックスが ON か OFF かによって異なります。
伸長 | GetElongation(ブロブ, ブロブインデックス) | 参照されるブロブのピクセルが、ブロブの重心からどの程度伸びているかを表す値を返します。例えば、円の伸長は 0 ですが、釘の伸長の値は大きくなります。 Closed 例
穴 | GetHoles(ブロブ, ブロブインデックス) | 参照されるブロブに含まれている穴の数を返します。
周囲長 | GetPerimeter(ブロブ, ブロブインデックス) | 参照されるブロブを囲む境界線の長さを返します。周囲長は、ブロブの境界線を形成するピクセルの外部エッジをカウントすることにより計算されます。 Closed 例
拡散 | GetSpread(ブロブ, ブロブインデックス) | 参照されるブロブのピクセルが、ブロブの重心からどの程度拡散しているかを表す値を返します。例えば、円形の対象物の拡散値は楕円形の対象物の場合よりも小さくなります。 Closed 例

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

しきい値 | GetThresh(ブロブ) | 画像のセグメント化に使用されたしきい値
検出数 | GetNFound(ブロブ) | 検出されたブロブの数
最小行 | GetMinRow(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの一番上の行座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最小列 | GetMinCol(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの左端の列座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最大行 | GetMaxRow(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの一番下の行座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最大列 | GetMaxCol(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの左端の列座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。

FindBlobs の例

FindBlobs 関数を使用して、 [image] データ構造体で返されたブロブのフィルタとソートを行います。この例では、FindBlobs パラメータ設定で、ブロブのリストを検査し、指定した最適な値に一致するブロブのみを返すように設定する方法を説明します。

DetectBlobs の例で作成されたものと同じ画像と [image] データ構造体を使用して、FindBlobs 関数がスプレッドシートに挿入され、自動的に Closed FindBlobs プロパティシートが起動されています。この例の目的として、ブロブが検査され、その他の基準に関係なく、1 個以下の穴があるブロブのみを返すようにパラメータが設定されています。

これらの要件に基づいて、FindBlobs パラメータは次のように構成されます。

ブロブ: このパラメータは、以前生成された DetectBlobs [image] データ構造体への絶対セル参照として設定されています。

検出する数: このようなブロブが 1 つだけ画像に含まれているので、このパラメータは 1 に設定されています。このパラメータをより高い値に設定すると、この値を下回るブロブが返されたセルは #ERR となります。

アクセプトしきい値: デフォルト設定が使用されています。ブロブに関して確実性が低い状況でこの設定を使用することによって、より低いしきい値で、より多くのブロブが返されることを保証しますが、最適な値との類似性が低下します。

ブロブが検査されて 1 個以下の穴があるブロブのみが返されているので、設定する必要のあるパラメータは、[穴] パラメータだけです。ブロブのその他すべてのプロパティのパラメータは、[重量] 設定が 0 に設定されている場合以外、デフォルト設定のままになります。

穴: この例では、[穴] の [数] の値が 0 に設定されていますが、[範囲] の値は 0 に引き下げられ、[重量] は 100 に設定されています。これによって、得られる FindBlobs [image] データ構造体および結果データテーブルでは、 [image] データ構造体内で値が 0 のブロブのみが返されることが Closed 保証されます。

関連項目

  • ブロブツールについて
  • ブロブデータアクセス関数
  • ExtractBlobs 関数
  • DetectBlobs 関数
  • SortBlobs 関数
  • プロパティシートの使用方法


SortBlobs 関数

SortBlobs 関数 |
ビジョンツール → ブロブ | In-Sight 関数リファレンス

SortBlobs 関数は、フィクスチャに関して [image] データ構造体で参照されているブロブをソートするために使用されます。

  • SortBlobs 関数の概要
  • SortBlobs の入力パラメータ
  • SortBlobs の出力
  • SortBlobs データアクセス関数
  • SortBlobs 関数の例

SortBlobs 関数概要

指定された画像フィクスチャ座標系に対する、参照されているブロブの重心の位置を計算することにより、SortBlobs 関数は、x 軸または y 軸に沿ったブロブの距離、フィクスチャの原点またはグリッドからの距離、ブロブの角度や角度絶対値などの測定特性の 1 つを基準にして、参照されているブロブをソートします。

参照されているブロブのデータ構造体に含まれる個々のブログが調査され、ソート基準パラメータ設定に基づいてブロブが識別されます。その後、ブロブの距離、またはある決まった位置との角度関係のどちらかを測定することにより、このブロブの位置が計算されます。

SortBlobs 関数により、参照されているブロブのソートが完了すると、新しい [image] データ構造体とこれに伴う結果テーブルが自動的にスプレッドシートに挿入されます。結果テーブルは、選択されたフィクスチャに対するブロブの距離を基準に、降順でソートされます （最も近いブロブがリストの先頭になります。2 番目に近いブロブはリストの 2 番目…のように並べられます）。

SortBlobs 関数は、複数のブロブが存在し、ほかのブロブに対する個々のブロブの位置を判断する必要のあるインスタンスにおいて非常に有効な関数です。

SortBlobs 関数の入力パラメータ

SortBlobs 関数(

ブロブ,

ソートする数,

ソート基準,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

表示

)

ブロブ

このパラメータは、ソートの対象となる [image] データ構造体を含むスプレッドシートのセルを参照します。

ソートする数

返されるブロブの最大数 (1 ～ 4096、デフォルト = 3) を指定します。

注意: このパラメータの値が 0 より大きい場合、SortBlobs 関数は、 [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。 新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

ソート基準

ブロブの測定方法とソート方法を表します。

0 = X (デフォルト)

x 軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。

Closed 例

1 = Y

y 軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。

Closed 例

2 = 角度

フィクスチャ座標系の X 軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (0 ～ 360 度) を、小さいものから大きいものの順 (降順) にソートします。

Closed 例

3 = 角度絶対値

フィクスチャ座標系の x 軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。

Closed 例

4 = 距離

フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。

Closed 例

5 = グリッド X

まず、フィクスチャの x 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に y 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。

注: SortBlobs 関数は、グリッド X が選択され、CalibrateImage 関数や TransBlobsToWorld 関数の出力などのワールド座標にキャリブレーションされた画像を関数が参照している場合には、#ERR を返します。グリッド X のソートは、ピクセル座標にのみ適用できます。ワールド座標を使用してグリッド X のソート方法を使用するには、SortBlobs 関数によって参照されている ExtractBlobs 関数が、SortBlobs 関数によってピクセル座標でソートされた TransformImage 関数の出力を参照する必要があります。出力データは、その後、TransBlobsToWorld 関数を使用してワールド座標に変換できます。

Closed 例

6 = グリッド Y

まず、フィクスチャの y 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に x 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。

注: SortBlobs 関数は、グリッド Y が選択され、CalibrateImage 関数や TransBlobsToWorld 関数の出力などのワールド座標にキャリブレーションされた画像を関数が参照している場合には、#ERR を返します。グリッド Y のソートは、ピクセル座標にのみ適用できます。ワールド座標を使用してグリッド Y のソート方法を使用するには、SortBlobs 関数によって参照されている ExtractBlobs 関数が、SortBlobs 関数によってピクセル座標でソートされた TransformImage 関数の出力を参照する必要があります。出力データは、その後、TransBlobsToWorld 関数を使用してワールド座標に変換できます。

Closed 例

7 = 幅

幅値によって広いものから狭いものへソートします。

注:
  • In-Sight 5605 ビジョンシステムは、このパラメータオプションをサポートしていません。
  • In-Sight 5604 ビジョンシステムでは、[幅] オプションと [高さ] オプションは入れ替わります。つまり、幅 = 8 および高さ = 7 となります。

8 = 高さ

高さ値によって高いものから低いものへソートします。

注:
  • In-Sight 5605 ビジョンシステムは、このパラメータオプションをサポートしていません。
  • In-Sight 5604 ビジョンシステムでは、[幅] オプションと [高さ] オプションは入れ替わります。つまり、幅 = 8 および高さ = 7 となります。

フィクスチャ

フィクスチャ入力に対する、ブロブの重心またはビジョンツール関数の画像座標系の出力を定義します。フィクスチャに対してブロブの重心を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して参照されるブロブを確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

表示

画像上の SortBlobs グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | SortBlobs 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブの輪郭が常に表示されます。

SortBlobs 関数の出力

戻り値 | ソートされたブロブを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | SortBlobs を初めてセルに挿入すると、 Closed 結果テーブルがスプレッドシート内に作成されます。 注意: [ソートする数] パラメータが 0 より大きい場合、SortBlobs は [image] データ構造体内の最初の 10 個のブロブに対応する最大 10 のエントリが含まれている結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいブロブがインデックスされるようにしてください。

SortBlobs 関数データアクセス関数

SortBlobs [image] データ構造体の結果テーブルを作成するために、次のデータアクセス関数がスプレッドシートに自動挿入されます。

スプレッドシート名 | 関数名 | 説明
行 | GetRow(ブロブ, ブロブインデックス) | 参照されるブロブの重心の Y 座標 (行) を返します。 Closed 例
列 | GetCol(ブロブ, ブロブインデックス) | 参照されるブロブの重心の X 座標 (列) を返します。 Closed 例
角度 | GetAngle(ブロブ, ブロブインデックス) | ROI の中心に対するブロブの主軸の角度を返します。 Closed 例
カラー | GetColor(ブロブ, ブロブインデックス) | 参照されるブロブのカラーの値 (0 = 黒、1 = 白) を返します。
得点 | GetScore(ブロブ, ブロブインデックス) | ブロブが、FindBlobs 関数の条件にどの程度一致しているかを表します。
面積 | GetArea(ブロブ, ブロブインデックス) | 参照されるブロブの面積を返します (ピクセル単位)。 Closed 例 注: ブロブに穴がある場合、面積の値は、[穴を埋める] チェックボックスが ON か OFF かによって異なります。
伸長 | GetElongation(ブロブ, ブロブインデックス) | 参照されるブロブのピクセルが、ブロブの重心からどの程度伸びているかを表す値を返します。例えば、円の伸長は 0 ですが、釘の伸長の値は大きくなります。 Closed 例
穴 | GetHoles(ブロブ, ブロブインデックス) | 参照されるブロブに含まれている穴の数を返します。
周囲長 | GetPerimeter(ブロブ, ブロブインデックス) | 参照されるブロブを囲む境界線の長さを返します。周囲長は、ブロブの境界線を形成するピクセルの外部エッジをカウントすることにより計算されます。 Closed 例
拡散 | GetSpread(ブロブ, ブロブインデックス) | 参照されるブロブのピクセルが、ブロブの重心からどの程度拡散しているかを表す値を返します。例えば、円形の対象物の拡散値は楕円形の対象物の場合よりも小さくなります。 Closed 例

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

しきい値 | GetThresh(ブロブ) | 画像のセグメント化に使用されたしきい値
検出数 | GetNFound(ブロブ) | 検出されたブロブの数
最小行 | GetMinRow(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの一番上の行座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最小列 | GetMinCol(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの左端の列座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最大行 | GetMaxRow(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの一番下の行座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。
最大列 | GetMaxCol(ブロブ, ブロブインデックス) | 画像座標フレームの方向を向いた、参照されるブロブの周りを囲む正方形の境界ボックスの左端の列座標を返します。 注: 異なる方向を持つ境界ボックスについては、BoundingRectangle 関数を参照してください。

SortBlobs 関数の例

SortBlobs 関数は、フィクスチャからブロブまでの距離を基準に、 [image] データ構造体で参照されているブロブをソートするために使用されます。この例では、フィクスチャに対するブロブの位置を基準に、一連のブロブをソートするために SortBlobs パラメータ設定を使用する方法を説明します。

DetectBlobs 関数の例で作成されたものと同じ画像と [image] データ構造体を使用して、SortBlobs 関数がスプレッドシートの空のセルに挿入され、 Closed SortBlobs プロパティシートが自動的に起動されました。

この例では、パラメータは、FindBlobs 関数の例によりフィクスチャとして返されたブロブを使用し、前述の DetectBlobs 関数の例で明らかにしたブロブをソートできるように設定されています。

これらの条件に基づいて、SortBlobs パラメータは次のように構成されます。

ブロブ: このパラメータは、以前生成された DetectBlobs [image] データ構造体への絶対セル参照として設定されています。

ソートする数: このパラメータは、ソート対象のブロブが 6 つあるため、6 に設定されます。

ソート基準: このパラメータはフィクスチャ原点からの距離に設定されています。このパラメータの設定値を選択すると、計測の起点を判定するためにフィクスチャパラメータを設定する必要があります。

フィクスチャ: このパラメータは、FindBlobs 関数の例の [image] データ構造体で返された行座標および列座標へのセル参照として設定されています。このパラメータの設定値を選択すると、計測やソートは、常に画像内の指定された特徴を原点として行われるようになります。画像内の別の特徴 (エッジなど、点、ブロブなど) を使用することが可能です。例えば、この例では、FindBlobs 関数の例から返されたブロブは、フィクスチャ座標を設定するために使用されます。

表示: デフォルト設定を使用しました。このとき、下の例にあるように、 [image] データ構造体を含むセルが選択されている場合だけ、結果のグラフィックスが表示されます。

SortBlobs プロパティシートの設定後、 [image] データ構造体と Closed 結果データテーブルが生成されます。

関連項目

  • ブロブツールについて
  • ブロブデータアクセス関数
  • ExtractBlobs 関数
  • DetectBlobs 関数
  • FindBlobs 関数
  • プロパティシートの使用方法


カラー

ビジョンツール

In-Sight 関数リファレンス

In-Sight カラーツールは、カラーデータに基づいて対象物を識別し照合するために使用されます。このカラーツールには次の関数があります。

  • ExtractColor 関数: TrainExtractColor カラーライブラリで選択された登録カラーモデルを照合する、対象領域 (ROI) 内にあるピクセルの数を特定します。
  • MatchColor 関数: TrainMatchColor カラーライブラリの登録カラーと照合する、ROI 内のカラーを特定します。
  • TrainExtractColor 関数: ExtractColor 関数と共に使用するようにカラーライブラリを構築します。
  • TrainMatchColor 関数: MatchColor 関数と共に使用するようにカラーライブラリを構築します。

注:
  • カラーの In-Sight ビジョンシステムまたはエミュレータに接続して、これらのビジョンツールを有効にする必要があります。
  • ExtractColor 関数は TrainExtractColor [image] データ構造体を参照する必要があり、MatchColor 関数は TrainMatchColor [image] データ構造体を参照する必要があります。参照していない場合、これらの関数は #ERR を返します。

ツールカラーについて

ツールのカラー内容

ExtractColor および MatchColor ツールは、カラーデータに基づいて対象物を識別し照合します。形状が同じであるものの、異なるカラーまたはカラーのシェードで構成されている対象物を検査するなどします。このツールは、ピークカラーの表示を計算する ExtractColor ツールおよび平均カラーの表示を計算する MatchColor ツールを使用して、内部でカラーのヒストグラムプロジェクションを生成して、カラーデータを計算します。

ExtractColor と TrainExtractColor

カラーマシンビジョンアプリケーションの開発では、頻繁に対象物をその独特のカラーに基づいて識別する必要があります。ただし、ワールド座標では、例えば照明や対象物のトポログラフィなどが原因で、対象物のカラーが均一でなく、ある程度のばらつきがあることがあります。

ExtractColor ツールは、このばらつきを検査時に考慮するようにプログラミングすることができます。トレーニングフェーズでは、TrainExtractColor 関数を使用して複雑なカラーモードのライブラリを作成し、RGB 値の 3D 分布を統合します。次に、ランタイム操作時に、ExtractColor 関数によって、作成されて TrainExtractColor 関数のライブラリに格納された、登録カラーモデルを照合する ROI 内のピクセルの数の表示を調べます。ピクセル数が最高のカラーモデルは、最適一致としてランクされます。

MatchColor と TrainMatchColor

速度が重要であり、検査されているカラーがほぼ均一であるマシンビジョンアプリケーションでは、MatchColor ツールによって必要な速度と精度が得られます。MatchColor ツールで ROI 内の平均カラーを調べ、以前に登録されたカラーが保存されているリストとこの値を比較します。トレーニングフェーズでは、TrainMatchColor 関数を使用してカラーのライブラリを作成し、ROI 内の RGB と HSI の平均値を調べます。次に、ランタイム操作時に、MatchColor 関数によって、作成されて TrainMatchColor 関数のライブラリに格納された、登録カラーを照合する ROI 内の RGB または HSI の平均値の表示を調べます。最高得点のカラーは、最適一致としてランクされます。

ツールをカラー使用する場合

このカラーツールは、次の状況で有用です。

ExtractColor と TrainExtractColor

  • ExtractColor ツールは、各種のシェードとカラーで構成された対象物に使用すると最も効果的です。
  • ExtractColor ツールは MatchColor ツールよりも低速ですが、より正確であり、より複雑なカラーや微妙な違いを識別することができます。
  • ExtractColor 関数は、その他の In-Sight ビジョンツールによって参照できる画像を出力します。

MatchColor と TrainMatchColor

  • MatchColor ツールは、程度の差はあっても、均一な色や単色の対象物に使用すると最も効果的です。
  • MatchColor ツールは ExtractColor ツールよりも高速で、解像度は 24 ビットです。

ツールをカラー使用する理由

カラーツールのカラー解析は、以下のようなアプリケーションで非常に有用です。

ExtractColor と TrainExtractColor

パーツ有無判定アプリケーション

対象物と関連付けられ、参照されているカラーモデルのピクセル数に基づいて、対象物が存在するかどうかを判定するように、ExtractColor ツールを設定することができます。ピクセル数データから十分なデータが得られない場合は、バイナリ画像を出力するように ExtractColor 関数を設定し、これを ExtractBlobs 関数によって参照できるようにして、ExtractColor 関数によって出力されたバイナリピクセルのブロブが、対象物に設定されたブロブ許容値の範囲内になるようにします。

パーツの識別

パーツに固有のカラーを計算することによって、存在する対象物を識別するように ExtractColor ツールを設定することができます。このタイプのアプリケーションでは、ピクセル数が最高のカラーモデルが、画像内の対象物の表示を表すカラーモデルであると見なされます。

MatchColor と TrainMatchColor

カラーの検証

現在の画像内の ROI が、登録カラーのライブラリにどの程度合致するかを数値化するように、MatchColor ツールを設定することができます。この目的は、ROI 内のカラーと登録カラーとの差異が小さくなるようにすることです。

パーツまたはカラーの照合

このタイプのアプリケーションでは、画像内の現在のカラーに最適一致するカラーを報告するように、MatchColor ツールを設定することができます。一致得点を使用して各登録カラーをランク付けし、最高一致得点のカラーが最適一致であると判断されます。

ツールのカラー使用方法

このカラーツールは、通常は次の方法で使用します。

ステップ 1 - 対象物を検証して、ExtractColor または MatchColor ツールによって、そのカラーデータの解析がより良好に行われるかどうかを判定します。

ステップ 2 - TrainExtractColor または TrainMatchColor 関数をスプレッドシートに挿入し、登録カラーのライブラリを構築します。

ステップ 3 - ExtractColor または MatchColor 関数をスプレッドシートに挿入し、ライブ画像を登録ライブラリと比較します。


ExtractColor 関数

ExtractColor 関数 |
ビジョンツール → カラー | In-Sight 関数リファレンス

ExtractColor 関数は、TrainExtractColor 関数によって返された [image] データ構造体を参照し、TrainExtractColor カラーライブラリ内で選択した登録カラーモデルと一致する、対象領域 (ROI) 内にあるピクセルの数を判定します。抽出されたカラーモデルは、ピクセル数が最高のカラーモデルに対応します。

ExtractColor 関数は [image] データ構造体を出力し、ここには抽出されたカラーモデル、およびその他の In-Sight ビジョンツールによって参照することができる出力画像のピクセル数が含まれています。

  • ExtractColor の入力パラメータ
  • ExtractColor の出力
  • ExtractColor データアクセス関数
  • 関連項目

ExtractColor 関数の入力パラメータ

  • [全般] タブ
  • [カラーモデル] タブ

[全般] タブ

ExtractColor 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

外部領域,

カラーライブラリの抽出,

ピクセル計数,

出力画像,

表示

)

画像

この引数は、AcquireImage 関数によって出力された有効なカラー [image] データ構造体、または別の ExtractColor 関数によって出力された [image] データ構造体を参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注: このパラメータはカラー画像を参照している必要があります。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:

  • ピクセルがカウントされるようにするには、ピクセルが画像領域の範囲内に完全に含まれている必要があります。部分的に含まれているピクセルは計算されません。
  • [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注: このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

カラーライブラリの抽出

適切なカラーライブラリおよびカラーモデルを含んでいる TrainExtractColor 関数への参照を否定します。

注: これは、TrainExtractColor [image] データ構造体を参照している必要があります。この関数は、TrainMatchColor 関数によって出力された [image] データ構造体を参照することはできません。参照すると、ExtractColor 関数は #ERR を返します。

ピクセル計数

ピクセル計数のオンまたはオフを指定します。

注: ピクセル計数が不要の場合は、このパラメータをオフにして処理時間を節約してください。ピクセル計数のみが必要な場合は、このパラメータをオンにして、[出力画像] パラメータを [画像なし] に設定すると、処理時間が最高速となり、メモリへの影響は最小限になります。

0 = OFF | ピクセル計数をオフにします。
1 = ON (デフォルト) | ピクセル計数をオンにします。

出力画像

出力される画像のタイプを指定します。出力画像は、他の In-Sight ビジョンツールの [画像] パラメータによって参照することができます。

ExtractColor 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。

0 = マークした画像 | マークした画像が出力されるように指定します。この出力画像で、有効なカラーモデルとマッチするピクセルがマークしたカラーに設定されます。これは、カラーモデル内にある最初の色のピークと反対の色です。 注: この出力画像には非常に有用なユーザのフィードバック情報が含まれていますが、非常に長い処理時間を必要とします。
1 = バイナリ画像 (デフォルト) | バイナリのグレースケール画像が出力されるように指定します。この出力画像では、有効なカラーモデルにマッチする各ピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定します。この画像は、ExtractBlobs 関数などの他の In-Sight ビジョンツールによって使用することができます。 注: この出力画像は最速の画像出力であり、メモリへの影響を最小限にします。
2 = カラー画像 | カラー画像が出力されるように指定します。この出力画像では、有効なカラーモデルにマッチする各ピクセルは元の値を保持しますが、その他すべてのピクセルは 0,0,0 (RGB) に設定されます。この画像は、他の In-Sight ビジョンツールによって使用することができます。 注: この出力画像は RGB および明度の情報を含んでいるので、サイズはバイナリ画像の 4 倍です。
3 = 画像なし | 画像が出力されないように指定します。 注: この設定は、最高速の実行時間を必要とするジョブで適用できます。ピクセル計数のみが必要な場合は、[ピクセル計数] パラメータをオンにして、[出力画像] パラメータを [画像なし] に設定すると、処理時間が最高速となり、メモリへの影響は最小限になります。

表示

画像上の ExtractColor グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | ExtractColor 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
2 = 結果のグラフィックスのみ | 入力画像領域が常に表示されます。
3 = 入力と結果のグラフィックス | 入力画像領域と抽出された色のアウトラインの両方が常に表示されます。

[カラーモデル] タブ

参照する TrainExtractColor [image] データ構造体から抽出するカラーモデルを指定します。デフォルトでは、参照するライブラリ内に登録されているカラーモデルがすべて自動的に有効になります。

注: SetExtClrColorModelState 関数を使用して、スプレッドシートからカラーモデルを有効にすることもできます。

ExtractColor 関数の出力

戻り値 | ピクセル計数および出力画像を含んでいる [image] データ構造体 ([出力画像] パラメータで [画像なし] が指定されている場合以外)。入力パラメータが無効であれば #ERR を返します。
結果 | ExtractColor 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

ExtractColor 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

インデックス | GetExtClrModelByRank(色, ランク) | ランク別のカラーモデルインデックス。
モデルカラーの抽出 | GetActiveExtClrModelNa me(色, インデックス) | インデックス別のカラーモデル名。
ピクセル計数 | GetPixelCountByIndex(色, インデックス) | インデックス別のピクセル計数。
全体のピクセル計数 | GetOverallPixelCount(色) | すべてのアクティブなカラーモデルのピクセル計数。

関連項目

  • TrainExtractColor 関数
  • カラーデータアクセス関数
  • ExtractColor ツールの使用方法
Version: 5.6.0


MatchColor 関数

MatchColor 関数 |
ビジョンツール → カラー | In-Sight 関数リファレンス

MatchColor 関数は、TrainMatchColor 関数によって返された [image] データ構造体を参照し、対象領域 (ROI) の中で、TrainMatchColor カラーライブラリで登録された色に一致する色を判定します。MatchColor 関数は [image] データ構造体を出力します。この構造体には、 [image] データ構造体で参照されるアクティブなカラーごとに、色の距離と一致得点、および全体的な信頼性得点が含まれます。

  • MatchColor の入力パラメータ
  • MatchColor の出力
  • MatchColor 関数のデータアクセス関数
  • 関連項目

MatchColor 関数の入力パラメータ

  • [全般] タブ
  • [カラー] タブ

[全般] タブ

MatchColor 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

外部領域,

カラーライブラリ,

カラー空間,

表示

)

画像

カラー画像の参照を指定します。この引数は、AcquireImage 関数によって出力された有効なカラー [image] データ構造体、または別の MatchColor 関数によって出力された [image] データ構造体を参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注: このパラメータはカラー画像を参照している必要があります。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:

  • ピクセルがカウントされるようにするには、ピクセルが画像領域の範囲内に完全に含まれている必要があります。部分的に含まれているピクセルは計算されません。
  • [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注: このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

カラーライブラリ

必要なカラーを含む TrainMatchColor 関数への参照を指定します。

注: これは、TrainMatchColor [image] データ構造体を参照している必要があります。この関数は、TrainExtractColor 関数によって出力された [image] データ構造体は参照できません。参照すると、MatchColor 関数は #ERR を返します。

カラー空間

色の距離を計測するために使用するカラー空間を指定します。

0 = RGB (デフォルト) | 関数は、RGB カラー空間で動作します。
1 = HSI | 関数は、HSI カラー空間で動作します。 注:ExtractColorHistogram 関数で返された HSI 値は、MatchColor 関数と TrainMatchColor 関数で返される HSI 値と異なることがあります。MatchColor 関数と TrainMatchColor 関数は、HSI の処理の前にピクセルの平均値を出し、ExtractColorHistogram 関数は HSI の処理の後にピクセルの平均値を出します。画像で検出される色のランダム性に応じて相違が大きくなります。

表示

画像上にオーバレイする MatchColor グラフィックスの表示モードを指定します。

0 = 非表示 (デフォルト) | MatchColor 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

[カラー] タブ

参照する TrainMatchColor [image] データ構造体から抽出するカラーを指定します。デフォルトでは、参照するライブラリ内に登録されているカラーがすべて自動的に有効になります。

注: SetMatchClrColorState 関数を使用して、スプレッドシートからカラーを有効にすることもできます。

MatchColor 関数の出力

戻り値 | アクティブなカラーから ROI 内の平均色までの RGB および HSI での色の距離を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | MatchColor 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

MatchColor 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

インデックス | GetMatchClrColorByRank(色, ランク) | ランク別の色インデックス。
MatchColor の色 | GetActiveMatchClrColorName(色, インデックス) | インデックス別の名前。
得点 | GetMatchClrScoreByIndex(色, インデックス) | インデックス別の色得点。
色距離 | GetMatchClrDistByIndex(色, インデックス) | インデックス別の色の距離。
信頼性得点 | GetConfidenceScore(色) | 検査の信頼性得点。

関連項目

  • TrainMatchColor ツール
  • カラーデータアクセス関数
  • MatchColor ツールの使用方法
Version: 5.6.0


TrainExtractColor 関数

TrainExtractColor 関数 |
ビジョンツール → カラー | In-Sight 関数リファレンス

ExtractColor 関数で使用するため、画像領域からカラーモデルを抽出し登録します。TrainExtractColor 関数カラーモデルに色を登録してから、ExtractColor 関数を使って、画像内にあるカラーモデルを特定します。

  • TrainExtractColor の概要
  • [TrainExtractColor 登録] タブ
  • [TrainExtractColor 画像] タブ
  • [TrainExtractColor 外部登録] タブ
  • 関連項目

TrainExtractColor 関数概要

TrainExtractColor 関数を使用してカラーライブラリを構築します ([ExtractColor 登録] ダイアログの [登録] タブで設定します)。ライブラリには最大 100 の個別カラーモデルを含めることができ、カラーモデルは個々の色で構成されています。

カラーモデルは、RGB 値の集約 3D 分布を定義します。カラーモデルは個々の色分布を順次加算または減算することで形成されます。

色は、その登録時に対象領域 (ROI) 内に存在するピーク RGB 値を基に、RGB 値の 3D 分布を定義します。分布は個々のカラー許容値設定を基に拡大または縮小でき、カラーモデルで定義された集約分布に対して加算または減算することができます。

登録段階で色を定義するときに、TrainExtractColor 関数によって ROI 内にある色の 3D カラーヒストグラムが内部生成されます。生成後、この関数は、ROI 内のピークカラーを決定します。図 1 に、ワッシャの画像の 3D カラーヒストグラムを示します。ヒストグラムのデータは、ワッシャの色が単色で構成されているのではなく、RGB 空間内の多くの色の 3 次元分布で占められていることを示します。

Closed 図 1- ワッシャの 3D RGB ヒストグラム

3D ヒストグラムは、素材表面から反射される光、および素材本体から反射される光で構成される 2 色性反射を表します。

  • ピークカラーの面積は、一致するピクセルが最も集中しているヒストグラムの場所を表します。
  • 暗/明線は、オブジェクト本体から反射される光に相当し、原点 (黒、0,0,0) をピークカラーに結んでからヒストグラムの境界を超えて伸びる線として表されます。
  • ハイライト線は表面反射成分を表し、ピークカラーから照度ベクトル (白、255,255,255) に沿ってヒストグラムの境界まで伸びます。

ピークカラーと式相

色を初めて登録すると、ROI にある個々の色の統計分析が関数によって実行されます。ピークカラーが決定され、赤チャネル、緑チャネル、青チャネルからの標準偏差が計算されます。この計算はシグマ係数と呼ばれ、式相の設定項目を調整することで、ピークカラーからの標準偏差の数が設定されます。色が登録済みの色の一部と見なされるには、標準偏差内にある必要があり、標準偏差の数によって、RGB 色チャネルの上限と下限が決まります。例えば、式相の設定項目がシグマ係数 3 に設定された場合、RGB の値がピークカラーから 3 つの標準偏差内にあるピクセルは、その色に一致するものとしてカウントされます。

暗/明線

暗/明の設定項目を調整すると、ピークカラーとシグマ係数の境界を越えてモデルを拡張し、暗/明線に沿って色の多くのバリエーションを含めることができます。これらの設定項目を使用すると、ピークカラーの比率を維持するが明度にばらつきのある RGB 値を追加/除外できます。これらの色は、原点に位置する頂点からヒストグラムの境界まで伸びてピークカラーを包含するボリューム内にあります。図 2 は、図 1 の 3D ヒストグラムを示しますが、ここでは暗/明限界があります。色の暗/明線は、暗/明限界値によって制限されます。これらの値は、色等級 (ピークカラーから原点のユークリッド距離) の割合として設定されます。暗限界と明限界の範囲値の割合も別途計算されます。

Closed 図 2 - 3D ヒストグラムの暗/明限界

ハイライト線

ハイライト設定項目を調整すると、その色に属すると見なされる色の数を拡大できます。追加の色は、ピークカラーから始まるボリューム内に含まれます。ボリュームは図 3 に示すように、幅が暗/明ボリュームの幅に等しく、ハイライト線を抱含します。ハイライト線の上限は、調整できる唯一の制限で、色等級の割合として設定されています。

Closed 図 3 - 3D ヒストグラムのハイライト制限

TrainExtractColor 関数[登録] タブ

注: ここで説明するパラメータを使用して、In-Sight カラービジョンシステムがオフラインのときに、カラーモデルの登録を設定できます。

[登録] タブの設定項目は、ライブラリに色とカラーモデルを手動で登録するために使用されます。

  • [カラーモデル] の設定項目
  • [登録] の設定項目
  • [カラー許容値] の設定項目
  • [画像マーク] の設定項目

[カラーモデル] の設定項目

ライブラリディレクトリの構造

ライブラリディレクトリ構造には、ライブラリのカラーモデルが表示されます。

  • [新規モデル]: 新しいカラーモデルをライブラリに追加します。
  • 名前変更: デフォルトのカラーモデル名 (Model_1) を変更できます。
  • モデルを削除: 選択したカラーモデルをライブラリから削除します。

[カラー] テーブル

[カラー] テーブルには、[ライブラリ] ウィンドウで選択したカラーモデルの色、カラー名、RGB 値、操作が表示されます。

  • カラーの名前変更: デフォルトのカラー名 (Color_1) を変更できます。
  • [カラーの追加]: カラーモデル内の色の加色操作を指定します。
  • [カラーの除外]: カラーモデル内の色の減色操作を指定します。
  • [このカラーを下に移動]: カラーモデル内のカラーリストで、選択した色を下に移動します。
  • [このカラーを上に移動]: カラーモデル内のカラーリストで、選択した色を上に移動します。
  • [色を削除]: カラーモデル内のカラーリストから、選択した色を削除します。

[登録] の設定項目

色の登録方法、色の定義に使用する ROI、およびカラーモデル内の色の操作を指定します。

  • [最も優勢な主調色]: 定義したカラーモデル内の色が 1 つ登録され、押されたボタンに応じて ([加色の作成] / [減色の作成]) に応じて、カラーモデルでその色が加色または減色されるように指定します。
  • [複数の色]: ROI にある RGB データに従って、カラーモデルに色が自動的に追加され、押されたボタン ([加色の作成] / [減色の作成]) に応じて、加色操作または減色操作が新たに作成された色に割り当てられるように指定します。その後、個々の色のプロパティを設定できます。

注: このパラメータにより、[最小色面積] パラメータと [最初に画像を平滑化] パラメータが有効になります。

  • 最初に画像を平滑化: 登録前に適用する画像平滑化係数 (0 ～ 10、デフォルト = 1) を指定して、画像のノイズを減らします。

注: この設定項目は、[複数の色] が選択されていないと有効になりません。

  • 最小色面積 (%): 色の登録に必要な、ROI 内の最小ピクセル数 (1 ～ 80、デフォルト = 2) を、ROI 内の総ピクセル数の割合として指定します。

注: この設定項目は、[複数の色] が選択されていないと有効になりません。

  • [領域の選択]: 色の定義に、矩形の ROI を使用するように指定します。
  • [円の選択]: 色の定義に、円形の ROI を使用するように指定します。
  • [ドーナツ領域の選択]: 色の定義に、ドーナツ形の ROI を使用するように指定します。
  • [ポリゴンの選択]: 色の定義に、ポリゴンの ROI を使用するように指定します。
  • [フリーハンドで描画]: 色の定義に、フリーハンド形状の ROI を使用するように指定します。
  • [加色の作成]: 色の加色を指定します。
  • [加色の作成]: 色の減色を指定します。

[カラー許容値] の設定項目

選択した色に対する許容値を指定します。

ヒント: [カラー許容値] の設定項目を設定する場合、画像を簡単に見ることができる位置に TrainExtractColor プロパティシートを配置します。設定項目の調整を進めていくと、選択した画像マークの種類に応じて画像が更新され、変更が反映されます。

  • [暗]: 下限 を指定します。この設定により、0,0.0 とピークカラーを通る線に沿って、色分布が低い方に広がります。
  • [明]: 上限 を指定します。この設定により、0,0.0 とピークカラーを通る線に沿って、色分布が高い方に広がります。
  • ハイライト: 登録のハイライトの制限 (1.0 ～ 10.0、デフォルト = 1.0) を指定します。この設定により、色分布がピークカラーから高い方 (255,255,255) へと広がります。
  • [色相]: 単色のシグマ係数 (0.0 ～ 10.0、デフォルト = 2.0) を指定します。この設定により、色分布が広がって、ピークカラーに似た色を含めることができます。シグマ係数は、各カラープレーンの登録時に内部で実行される標準偏差計算です。[式相の制限] は、3 つの各カラープレーンのピークカラーについての標準偏差の数を設定します。例えば、[式相の制限] が 2.0 の場合、各カラープレーンのピークカラーの周囲に ±1 の標準偏差のボックスが設定されます。

[画像マーク] の設定項目

画像における色の表示を指定します。

  • グループ全体の結果をマーク: カラーモデルのすべての色が画像名でマークされるように指定します。
  • 選択した色までの結果をマーク: 3 つの色のリストから 2 番目の色を選択した場合、最初の色と 2 番目の色が画像内でマークされます。
  • 選択した色のみをマーク: 選択した色だけが画像内でマークされます。

TrainExtractColor 関数[画像] タブ

ライブラリのカラーモデルの登録に使用される画像を指定するには、[画像] タブを使用します。

注: ここで説明するパラメータを使用して、In-Sight カラービジョンシステムがオフラインのときに、カラーモデルの登録を設定できます。

  • [ライブの開始]: ビジョンシステムをライブビデオモードにして、リアルタイム画像を表示します。
  • [画像を開く]: ネットワークに接続されたどのビジョンシステム、ローカル PC、またはネットワーク接続された PC からでも画像をロードします。

TrainExtractColor 関数[外部登録] タブ

外部登録用の再登録パラメータを設定するには、[外部登録] タブを使用します。

注: ここで説明するパラメータを使用して、In-Sight カラービジョンシステムがオンラインのときに、カラーモデルの再登録を設定できます。

  • TrainExtractColor の入力パラメータ
  • TrainExtractColor の結果出力
  • TrainExtractColor データアクセス関数
  • 関連項目

TrainExtractColor 関数の入力パラメータ

TrainExtractColor 関数 (

画像 ,

イベント ,

外部定義領域 ,

再登録操作 ,

再登録手順 ,

再登録モード ,

カラーモデル名 ,

暗限界 ,

明限界 ,

ハイライト限界 ,

色相限界 ,

最小カラー領域 ,

平滑化

)

画像

カラー画像の参照を指定します。この引数は、AcquireImage 関数によって出力された有効なカラー [image] データ構造体、または ExtractColor 関数によって出力された [image] データ構造体を参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注: このパラメータはカラー画像を参照している必要があります。

イベント

カラーモデルを登録する更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • Event 関数によって返される [image] データ構造体を含むセル
  • Button 関数を含んでいるセル

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注: このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

再登録操作

カラーモデル内の色の操作を指定します。

0 = 加色 | 新たに登録した色に対して、カラーモデルの [加色操作] が実行されます。
1 = 減色 | 新たに登録した色に対して、カラーモデルの [減色操作] が実行されます。

再登録手順

新しい色をカラーモデルに追加するために使用する方法を指定します。

0 = 既存の色に付加 (デフォルト) | 新しい色をカラーモデルの既存の色に追加します。
1 = 既存の色を削除して付加 | これまでのすべての色が削除され、新しい色がカラーモデルに追加されます。

再登録モード

登録モードを指定します。

0 = 単色 (デフォルト) | 定義したカラーモデル内の色が 1 つ登録され、[再登録操作] パラメータ設定に応じて、カラーモデルでその色が加色または減色されます。
1 = 複数の色 | ROI にある RGB データに従って、カラーモデルに色が自動的に追加され、[登録操作] パラメータ ([加色] / [減色]) で設定されたプロパティを新たに作成された色に割り当てられます。その後、個々の色のプロパティを設定できます。 注: このパラメータにより、[最小色面積] パラメータと [平滑化] パラメータが有効になります。

カラーモデル名

[登録] タブで設定される、オンライン再登録で再登録するカラーモデルの名前を指定します。カラーモデルが存在しない場合は、新しいカラーモデルが生成されます。

暗限界

オンライン登録の下限 (0 ～ 1.0、デフォルト = 1.0) を指定します。この設定により、0,0.0 とピークカラーを通る線に沿って、色分布が低い方に広がります。

明限界

オンライン登録の上限 (1.0 ～ 10.0、デフォルト = 1.0) を指定します。この設定により、0,0.0 とピークカラーを通る線に沿って、色分布が高い方に広がります。

ハイライト限界

オンライン登録のハイライトの制限 (1.0 ～ 10.0、デフォルト = 1.0) を指定します。この設定により、色分布がピークカラーから高い方 (255,255,255) へと広がります。

色相限界

単色オンライン登録のシグマ係数 (0.0 ～ 10.0、デフォルト = 2.0) を指定します。この設定により、色分布が広がって、ピークカラーに似た色を含めることができます。シグマ係数は、各カラープレーンの登録時に内部で実行される標準偏差計算です。[式相の制限] は、3 つの各カラープレーンのピークカラーについての標準偏差の数を設定します。例えば、[式相の制限] が 2.0 の場合、各カラープレーンのピークカラーの周囲に ±1 の標準偏差のボックスが設定されます。

注: このパラメータは、[再登録モード] パラメータが [単色] に設定されていないと有効になりません。

最小カラー領域

色の登録に必要な、ROI 内の最小ピクセル数 (1 ～ 80、デフォルト = 2) を、ROI 内の総ピクセル数の割合として指定します。

注: このパラメータは、[再登録モード] パラメータが [複数の色] に設定されていないと有効になりません。

平滑化

登録前に適用する画像平滑化係数 (0～10、デフォルト = 1) を指定して、画像のノイズを減らします。

注: このパラメータは、[再登録モード] パラメータが [複数の色] に設定されていないと有効になりません。

TrainExtractColor 関数の出力

戻り値

ExtractColor ツール用に登録されたカラーモデルを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

TrainExtractColor 関数データアクセス関数

データアクセス関数を使用して、次のデータ要素を取得できます。

GetNTrainExtClrModels(カラーライブラリ抽出) | TrainExtractColor ツールが生成した [image] データ構造体内のカラーモデルの数を返します。
GetTrainExtClrModelName(カラーライブラリ抽出,[インデックス]) | TrainExtractColor ツールが生成した [image] データ構造体内のインデックス付きのカラーモデルの名前を返します。
GetColorLibraryName(カラーライブラリ抽出) | 参照されている [image] データ構造体からカラーライブラリの名前を返します。

関連項目

  • ExtractColor 関数
  • カラーデータアクセス関数
  • ExtractColor ツールの使用方法


TrainMatchColor 関数

TrainMatchColor 関数 |
ビジョンツール → カラー | In-Sight 関数リファレンス

MatchColor 関数で使用するため、画像領域からカラーを抽出し登録します。TrainMatchColor 関数TrainMatchColor 関数でライブラリにカラーを登録し、その後、MatchColor 関数を使用し、現在の画像と登録されたカラーの間の色の距離に基づいて、画像内に存在するカラーを識別します。

  • TrainMatchColor の概要
  • [TrainMatchColor 登録] タブ
  • [TrainMatchColor 画像] タブ
  • [TrainMatchColor 外部登録] タブ
  • 関連項目

TrainMatchColor 関数概要

TrainMatchColor 関数を使用してカラーライブラリを生成します ([MatchColor 登録] ダイアログの [登録] タブで設定します)。ライブラリは最高 100 種類のカラーを含むことができます。これらの検査対象物の RGB/HSI 値から構成されています。

カラーは、対象領域 (ROI) によって定義され、登録時に ROI に含まれる平均 RGB および HSI 値を保存します。個々のカラーは、カラー空間内の 1 色を定義します。[カラー許容値] の設定項目を調整することによって、あるカラーを、そのカラーよりもわずかに濃い色または薄い色でも一致とみなすように設定することができます。

RGB カラー空間では、暗限界と明限界は、登録されたカラーの色等級を基準にしています。色等級は、原点から始まり、登録されたカラーで終わるベクトルの長さとして表されます。値 1 は登録されたカラーに対応し、値 0.5 は登録されたカラーの半分に対応します。

HSI カラー空間では、暗限界と明限界は、明度平面のみを基準にしています。検査対象のオブジェクトの明度コンポーネントが、登録されたカラーの暗限界と明限界内に収まる場合、このオブジェクトの色の距離は、色相および彩度のみによって決められます。明度コンポーネントが暗限界と明限界内に収まらない場合、色の距離は、色相、彩度、および現在の明度の値と最も近い暗限界値または明限界値の差分に基づいて決定されます。

注: ExtractColorHistogram 関数で返された HSI 値は、MatchColor 関数と TrainMatchColor 関数で返される HSI 値と異なることがあります。MatchColor 関数と TrainMatchColor 関数は、HSI の処理の前にピクセルの平均値を出し、ExtractColorHistogram 関数は HSI の処理の後にピクセルの平均値を出します。画像で検出される色のランダム性に応じて相違が大きくなります。

TrainMatchColor 関数[登録] タブ

注: ここで説明するパラメータを使用して、In-Sight カラービジョンシステムがオフラインのときに、カラーの登録を設定できます。

[登録] タブの設定項目は、ライブラリにカラーを手動で登録するために使用されます。

  • ライブラリ名
  • [カラー] テーブル
  • [登録] の設定項目
  • [カラー許容値] の設定項目

ライブラリ名

  • [ライブラリ名]: ライブラリの名前を指定します (デフォルト名は「ライブラリ」です)。

[カラー] テーブル

[カラー] テーブルには、ライブラリのカラーが表示されます。このテーブルには、カラーの名前、RGB 値、および HSI 値が表示されます。

  • カラーの名前変更: デフォルトのカラー名 (Color_1) を変更できます。
  • [色を削除]: 選択したカラーをライブラリから削除します。

[登録] の設定項目

[登録] の設定項目は、カラーの追加と保持に使用されるもので、カラーの定義に使用される ROI を指定します。

  • [領域の選択]: カラーの定義に、矩形の ROI を使用することを指定します。
  • [円の選択]: カラーの定義に、円形の ROI を使用することを指定します。
  • [ドーナツ領域の選択]: カラーの定義に、ドーナツ形の ROI を使用することを指定します。
  • [ポリゴンの選択]: カラーの定義に、円形の ROI を使用することを指定します。
  • [フリーハンドで描画]: カラーの定義に、フリーハンド形状の ROI を使用することを指定します。
  • [点の編集]: カラーの定義に使用される画像のポイントを指定します。
  • [加色の作成]: 新規カラーをライブラリに追加することを指定します。
  • [カラーの再登録]: 選択したカラーの再登録を指定します。

[カラー許容値] の設定項目

選択された色に対する許容値を指定します。

ヒント: [カラー許容値] の設定項目を設定する場合、画像を簡単に見ることができる位置に TrainMatchColor プロパティシートを配置します。設定項目を調整するに従って、画像が更新され、変更が反映されます。

  • [暗]: [暗] の範囲 (0 ～ 1.0、デフォルト = 1.0) を指定します。[カラー空間] を [RGB] に設定した場合、[暗] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比例的に低くなります。[カラー空間] が [HSI] に設定されている場合、[暗] の範囲を拡大すると、登録される色の明度が小さくなります。
  • [明]: [明] の範囲を指定します。[カラー空間] を [RGB] に設定した場合、[明] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比例的に高くなります。[カラー空間] が [HSI] に設定されている場合、[明] の範囲を拡大すると、登録される色の明度が大きくなります。

TrainMatchColor 関数[画像] タブ

ライブラリのカラーの登録に使用される画像を指定するには、[画像] タブを使用します。

注: ここで説明するパラメータを使用して、In-Sight カラービジョンシステムがオフラインのときに、カラーモデルの登録を設定できます。

  • [ライブの開始]: ビジョンシステムをライブビデオモードにして、リアルタイム画像を表示します。
  • [画像を開く]: ネットワークに接続されたどのビジョンシステム、ローカル PC、またはネットワーク接続された PC からでも画像をロードします。

TrainMatchColor 関数[外部登録] タブ

外部登録用の再登録パラメータを設定するには、[外部登録] タブを使用します。

注: ここで説明するパラメータを使用して、In-Sight カラービジョンシステムがオンラインのときに、カラーの再登録を設定できます。

  • TrainMatchColor の入力パラメータ
  • TrainMatchColor 関数の出力パラメータ
  • TrainMatchColor データアクセス関数

TrainMatchColor 関数の入力パラメータ

TrainMatchColor 関数(

画像,

イベント,

外部定義領域,

カラー名,

暗限界,

明限界,

)

画像

カラー画像の参照を指定します。この引数は、AcquireImage 関数によって出力された有効なカラー [image] データ構造体、または MatchColor 関数によって出力された [image] データ構造体を参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注: このパラメータはカラー画像を参照している必要があります。

イベント

カラーモデルを登録する更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • Event 関数によって返される [image] データ構造体を含むセル
  • Button 関数を含んでいるセル

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注: このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

カラー名

[登録] タブで設定される、オンライン再登録で再登録するカラーの名前を指定します。カラーが存在しない場合は、新しいカラーが生成されます。

暗限界

オンライン登録用に暗限界を指定します。[カラー空間] を [RGB] に設定した場合、[暗] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比例的に低くなります。[カラー空間] が [HSI] に設定されている場合、[暗] の範囲を拡大すると、登録される色の明度が小さくなります。

明限界

オンライン登録用に明限界を指定します。[カラー空間] を [RGB] に設定した場合、[明] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比例的に高くなります。[カラー空間] が [HSI] に設定されている場合、[明] の範囲を拡大すると、登録される色の明度が大きくなります。

TrainMatchColor 関数の出力

戻り値

MatchColor ツール用に登録されたカラーを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

TrainMatchColor 関数データアクセス関数

データアクセス関数を使用して、次のデータ要素を取得できます。

GetNTrainMatchClrColors(カラーライブラリ) | TrainMatchColor ツールが生成した [image] データ構造体内のカラーの数を返します。
GetTrainMatchClrColorName(カラーライブラリ,[インデックス]) | TrainMatchColor ツールが生成した [image] データ構造体内のインデックス付きのカラーの名前を返します。
GetColorLibraryName(カラーまたはカラーライブラリ) | 参照されている [image] データ構造体からカラーライブラリの名前を返します。

関連項目

  • MatchColor 関数
  • カラーデータアクセス関数
  • MatchColor ツールの使用方法
Version: 5.6.0


エッジ

ビジョンツール

In-Sight 関数リファレンス

マシンビジョンの用語では、エッジは、対照的なグレースケール値を持つ 2 つの隣接するピクセルグループ間の境界 (線、円弧、円のいずれか) と定義されています。In-Sight エッジツールを使用して、検出されたエッジに関する統計を検出して処理します。

In-Sight ビジョンシステムでは、エッジツールの次の関数を使用して、エッジの検出と処理を実行します。

  • Caliper 関数: エッジモデルに基づいて、対象領域 (ROI) 内でエッジ間の幅を計測し、エッジおよびエッジペアの位置と間隔を探します。
  • FindCircle 関数: 円環 ROI 内で単一の円形状エッジを探します。
  • FindCircleMinMax 関数: 連続するエッジの循環性を検査します。
  • FindCurve 関数: 曲がった ROI 内で単一の円弧状エッジを探します。
  • FindLine 関数: ROI 内で単一の直線エッジを探します。
  • FindMultiLine 関数: ROI 内で複数の直線エッジを探します。
  • FindSegment 関数: ROI 内で複数の直線エッジのペアを探します。
  • PairEdges 関数: エッジの配列をエッジペアの配列にソートします。
  • PairDistance 関数: 2 つのエッジ間の距離を計算します。
  • PairMaxDistance 関数: 最大エッジペア距離を検出します。
  • PairMeanDistance 関数: 平均エッジペア距離を計算します。
  • PairMinDistance 関数: 最小エッジペア距離を検出します。
  • PairSDevDistance 関数: エッジペアの長さの標準偏差を計算します。
  • PairsToEdges 関数: エッジペアの配列を (平均化によって) エッジの配列に変換します。
  • SortEdges 関数: 特定の基準でエッジをソートします。

In-Sight についてエッジツール

In-Sight エッジツールを使用して、検出されたエッジに関する統計を検出して処理します。

エッジ検出とは

In-Sight エッジツール関数で、ピクセル極性の不連続に関する対象領域 (ROI)、つまり白黒 (またはその逆) のピクセル間に急激な変化がある画像内のエリアを検査することによって、エッジを検出します。エッジは 2、3、または数個のピクセルのみに広がっていることもあります。

エッジの例

エッジは単一のエッジまたはエッジのペアで構成することができ、黒から白、または白から黒への 2 つの遷移で構成されています。次の図は、エッジのタイプを示しています。

Caliper、FindLine、または FindCircle 関数などのエッジツールをスプレッドシートに挿入すると、ROI でピクセル値の不連続がスキャンされます。下記の図は、矩形および円環の領域でエッジの特徴がスキャンされる方向を示しています。矩形の領域では、スキャン方向 (スキャン方向は、2 つの方向指示の矢印で示されます) が左上隅から開始し、右端まで進み、その後右下隅に到達するまでこのパターンを続行します。

スキャン方向 - 矩形および円環の領域

このプロセスで、グレースケールヒストグラムで ROI および高コントラスト (ROI 内で検出されたグレースケール値の差異) によって定義されたエリアを計算し、指定したその他のパラメータと合わせてエッジを定義します。

エッジのレスポンスチャート ([表示] パラメータが [すべて表示: 入力、結果、およびチャート] に設定されている場合に表示されます) に、ROI 内で検出されたグレースケール値の一次微分が表示されます。下記の図に示すように、大きなエッジ遷移を示す山と谷が表示されています。[アクセプトしきい値/最小コントラスト] パラメータを使用して、最小ピーク高さ (コントラストしきい値) を設定します。この設定で、最小ピーク高さより低いピークは結果から除外されます。これによって、検査の分析の対象を、画像内の特定の強度のエッジのみに限定することができます。関数のエッジのレスポンスチャートを使用して、正しいコントラストしきい値を判断します。

エッジのレスポンスチャートの例

  • [得点] 軸は、このツールに対して設定されている [得点] (100 および -100) と [アクセプトしきい値] パラメータによって定義されます。山 (つまり正の得点) は、エッジが黒から白へ遷移していることを示しており、谷 (つまり負の得点) は、エッジが白から黒へ遷移していることを示しています (得点 0 は、エッジが検出されなかったことを示します)。
  • [オフセット] 軸は、エッジの特徴を検出する ROI を指しています。ここで、0 は領域の開始位置を表し、右端の値は領域の最大幅をピクセル単位でマークしています。[オフセット] 軸沿いになる山または谷の頂点が、ROI 内で検出されたエッジの位置を示します。

エッジ幅 - エッジのフィルタ

[エッジ幅] パラメータを使用して、入力画像からノイズを除去し、エッジプロファイルのピークを強調します。[エッジ幅] パラメータのサイズは、画像内のエッジのサイズと厳密に一致し、ピークは低く緩やかであるのに対して、シャープで急勾配であるように指定する必要があります。エッジのサイズとは、エッジ幅のピクセル数です。エッジが 1 または 2 ピクセルにのみ広がっている場合はエッジがシャープであることがあり、複数のピクセルに広がっている場合は鈍いことがあります。エッジサイズに近い [エッジ幅] 設定を指定して、画像内のエッジのピークをより強くすることができます。一方で、[エッジ幅] 設定が大きすぎるかまたは小さすぎると、画像内に広く低いピークが作成されます。

エッジの結果

エッジが定義されると、エッジツール関数によって、自動的に [image] データ構造体および定義されたエッジに関するデータを含んでいる結果テーブルが作成されます。返される情報は、その他の In-Sight ビジョンツールによってフィクスチャ入力として使用するか、その他のエッジツール関数で使用して、エッジに関連するデータをさらに推定することができます。

エッジツールを使用する場合

次の状況では、エッジツールを使用する必要があります。

  • エッジでピクセルの白黒の差がはっきりしており、高コントラストになっている。
  • アプリケーションで特徴を迅速に検出する必要がある。エッジツールは高速な In-Sight ビジョンツールの中にあり、例えば、パターンよりも高速にエッジの特徴を検出する機能を備えています。

注: In-Sight エッジツールはグレースケール画像のみを解析します。カラー画像はすべて、自動的にグレースケール値に変換されます。

エッジツールを使用する理由

エッジの検出およびデータの推定は、次のアプリケーションで非常に有用です。

  • 計測アプリケーション。ガスケットなどのパーツ上の円形状の特徴の半径を測定したり、回路基板上の回路の長さを測定したりします。
  • パーツ上の特徴を探すアプリケーション。パーツの円形状の特徴や平坦な終端などを探し、In-Sight ビジョンツールでフィクスチャ入力として使用します。
  • 有無を調べるアプリケーション。ここでエッジツールを使用して、エッジの特徴が存在するかしないかを判定します。
  • 計数およびソートを行うアプリケーション。ここでエッジツールを使用して、確立されているパラメータに基づいて、エッジの計数とソートを行います。

注: 水平または垂直方向の直線エッジの特徴をフィクスチャ入力として使用する場合、FindLine ツールは、ROI のスキャン方向の位置に応じて、水平軸または垂直軸に沿った一方向へのエッジの移動のみを考慮します。

エッジツールの使用方法

エッジツールは通常、次の方法で使用されます。

  • ステップ 1 - 画像を検査し、エッジツールがアプリケーションの要件を満たすかどうかを判定します。
  • ステップ 2 - Caliper、FindCircle、FindCircleMinMax、FindCurve、FindLine、FindMultiLine、または FindSegment などのエッジツールの 1 つをスプレッドシートに挿入し、画像内のエッジまたはエッジペアを定義して検出するように、パラメータを設定します。
  • ステップ 3 - PairDistance、PairEdges、PairMaxDistance、PairMeanDistance、PairMinDistance、PairSDevDistance、PairsToEdges、または SortEdges などのエッジツールをもう 1 つ挿入し、検出されたエッジまたはエッジペアを、特定の基準に基づいてフィルタ、計算、またはソートします。


Caliper 関数

Caliper 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

この関数を使用して、対象物の幅の計測、単一エッジの位置およびエッジペアの位置と間隔の特定などの、エッジに関する検査を実行します。Caliper 関数は最も正確なエッジツール関数ですが、セットアップと構成に時間がかかります。

  • Caliper 関数の概要
  • Caliper の入力パラメータ
    • Caliper 関数の [得点付け方法] タブ
  • Caliper の出力
  • Caliper データアクセス関数
  • 関連項目

Caliper 関数概要

Caliper 関数を使用して画像を調べ、1 次元のエッジ、周囲のピクセルのグレースケール値の変化を探します。この関数は、画像の指定した部分 ([領域] パラメータで定義) を調べ、黒から白、または白から黒への一方向に、ピクセルのグレースケール値の遷移をスキャンします。単一エッジまたはエッジのペア (予測される幅によって区別されます) は、この関数で探すことができます。

Caliper 関数は、対象物の内部または周囲のエッジの特徴の、正確な位置に関する詳細情報を展開するアプリケーションに有用です。例えば、この関数を使用して、チップのリードのカウント、パーツの幅の計測、または別のビジョンツールで入力として使用するエッジポイントの検出を行うことができます。この関数は、エッジモデルに基づいてエッジまたはエッジペアを探し、ここで潜在的なエッジ候補のピークがシンプルな 1D カーネルを使用して検出され、モデルと得点付け方法に対して得点化されます。

画像内で対象エッジの位置と方向を特定したら、Caliper 関数を適用することができます。

  • [領域] を、エッジまたはエッジペアを囲むように設定します。
  • [エッジモード] パラメータをエッジのタイプに設定し (単一エッジまたはエッジペア)、検出するエッジの数を指定して、[第 1エッジ]、[第 2エッジ]、および [エッジ間の距離] パラメータを、エッジ極性、位置、および間隔が含まれているエッジモデルを作成するように設定します。
  • [エッジ幅] および [最小コントラスト] パラメータを、エッジまたはエッジペアを分離するように設定します。
  • エッジ候補の得点付けに使用される得点付け方法を定義します。

領域の設定

領域を位置決めするときに、目的とするエッジを適切に識別できるように、スキャン方向を設定します。スキャン方向は、検出する最初のエッジの方向を指している必要があります。エッジの位置は、領域の中心に対して、エッジが検出される位置によって特定されます

エッジの分離とエッジモデルの定義

領域内にエッジが配置されると、Caliper 関数は画像内の各エッジ候補の得点を計算します。各エッジの得点は、現在の画像内のエッジと定義された最適なエッジとの類似性に基づいて計算されます。現在の画像内のエッジは「エッジ候補」とみなされますが、最適なエッジは「エッジモデル」と呼ばれます (単一エッジまたはエッジのペア)。

エッジモデル

画像内のエッジ候補が、要求されたエッジと良好にマッチするかどうかを評価するには、対象エッジを正確に表現するモデルを定義する必要があります。エッジモデルを定義するには、最初にエッジのタイプ (単一エッジまたはエッジのペア) を定義します。次に、エッジタイプの内いくつを領域内に配置するかを定義します。その後、極性 (白→黒または黒→白)、モデル内の各エッジの位置 (領域に対するエッジの位置によって指定されます)、およびエッジ間の間隔 (エッジペアを定義する場合) を指定します。

コントラストしきい値が最小であるエッジ検出、ピーク検出

[エッジ幅] パラメータを使用して、入力画像からノイズを除去し、エッジプロファイルのピークを強調します。[最小コントラスト] パラメータを使用して、最小ピーク高さ (コントラストしきい値) を設定します。

エッジモード得点付け

Caliper 関数で領域をフィルタし、指定したコントラストしきい値を超えるエッジピークのリストを作成すると、画像内の各エッジ候補の得点が計算されます。この得点によって、画像内のどのエッジ候補が、実際の対象エッジのインスタンスを、エッジモデルによって定義されているように表しているかを判定します。

Caliper 関数は、得点付け方法と呼ばれるユーザ定義の得点付け基準に基づいて、エッジ候補をエッジモデルと比較することによって、各エッジの得点を計算します。

得点付け方法には次の 2 つの部分があります。

  • 評価するエッジの計測値を定義する、得点付け方法のタイプ。
  • 未処理の計測値と、得点付け方法用に作成されるマッピングされた得点との関係を定義する、得点付け関数。

得点付け方法は複数定義することができます。Caliper 関数は、定義したすべての得点付け方法を画像内の各エッジ候補に適用し、各エッジ候補全体の得点を返します。適切な得点付け方法を定義すると、最高得点のエッジ候補が対象エッジとなります。

得点付け方法の種類

Caliper 関数は、エッジ候補がエッジモデルとどのように異なるかについての、エッジ候補の得点に基づいています。この差異を査定するためにこのツールで使用する特定の計測方法は、ユーザが定義します。指定できる測定方法の種類は、得点付け方法の種類によって呼び出され、コントラスト、位置、サイズ、およびまたがるの 4 種類の得点付け方法があります。

この関数で得点付け方法の種類をエッジ候補に適用すると、生スコアとなります。未処理の得点は、得点付け方法の種類によって異なります。得点付け方法の種類とその未処理の得点については、次のセクションで説明します。

コントラストの得点付け方法

エッジ候補を、エッジ候補のコントラストに基づいて得点付けすることができます。エッジのコントラストは、ピクセル単位でのエッジのサイズによって分類されたピクセル値の変化を単位として表されます。コントラストの得点付け方法での未処理の得点は、100 の値がコントラストの 256 (最大限のコントラスト) と等しくなるように正規化されます。エッジペアモデルを指定する場合、未処理の得点は 2 つのエッジのコントラストの平均となります。

位置の得点付け方法

エッジ候補を、領域の中心に対するエッジ候補の位置に基づいて得点付けすることができます。位置は、エッジ候補内の中心とモデルの原点との距離として定義します。対象エッジが領域の中心からの特定の距離であると予測される場合、絶対位置の得点付け方法を定義することができ、未処理の得点はピクセル単位で絶対距離として表されます。エッジペアモデルが使用されており、エッジ候補と、モデルのサイズに相対する領域の中心との間の位置の変動を考慮する必要がある場合、相対的な位置の得点付け方法を定義します。この場合、距離がモデルのサイズと等しかったことを 100 の値が指すように、未処理の得点が正規化されます。

サイズの得点付け方法

エッジペアモデルが使用されている場合、エッジ候補のエッジ間の幅が、エッジモデルのエッジ間の幅とどの程度異なるかに基づいて、エッジ候補を得点付けすることができます。サイズの得点付け方法は絶対的であるように定義することができ、この場合、未処理の得点は絶対的なサイズの差異としてピクセル単位で返されます。モデルのサイズに相対するサイズの差異を識別する必要がある場合、相対的サイズ得点付け方法を定義します。この場合、サイズの差異がモデルのサイズと等しかったことを 100 の値が指すように、未処理の得点が正規化されます。

またがるの得点付け方法

エッジペアモデルが使用されている場合、2 つのエッジが領域の中心のいずれかの側に位置しているかどうかに基づいて、エッジペア候補を得点付けすることができます。このタイプの得点付け方法を使用して、領域の中心に位置すると予測されるエッジのペアによって定義された対象物を見つけることができます。エッジが領域の中心をまたいでいる場合、未処理の得点は 100 として返され、エッジが領域の中心をまたいでいない場合は、0 が返されます。

得点付け関数

それぞれの得点付け方法で、選択した得点付け方法のタイプが未処理の得点を生成します。この未処理の得点が、エッジ候補全体の得点に与える影響は、得点付け関数を定義することによって制御されます。得点付け関数は、未処理の得点をマッピングされた得点にマッピングします。エッジ候補の各得点付け方法のマッピングされた得点が統合され、そのエッジ候補全体の得点となります。

Caliper 関数の入力パラメータ

Caliper 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

エッジモード ,

検出する数 ,

最小コントラスト ,

アクセプトしきい値 ,

エッジ幅 ,

エッジ: 第 1 ,

エッジ: 第 2 ,

エッジ: 距離 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

エッジモード

単一エッジまたはエッジペアのいずれを探すかを指定します。

単一エッジ | 指定した基準を満たす単一エッジを領域でサーチし、その位置を返します。このモードでは、位置およびコントラストの得点付け方法を使用できます。
エッジペア | 指定した基準を満たすエッジペアを領域内でサーチします。このモードでは、位置、コントラスト、サイズ、およびまたがるの得点付け方法を使用できます。

検出する数

返されるエッジまたはエッジペアの最大数を指定します (1 ～ In-Sight ビジョンシステムの画像の幅 - 1、デフォルト = 1)。特定の In-Sight ビジョンシステムが画像を取り込んでいる場合、検出されるエッジの最大数は画像の幅より 1 少ない数になります (つまり、In-Sight 5100 ビジョンシステムの最大数は 639 で、ビジョンシステムの画像解像度 640×480 より 1 少ない数になります)。得点が アクセプトしきい値 パラメータを超えるエッジまたはエッジペアがこの最大数より多い場合は、最も得点の高いエッジまたはエッジペアが選択されます。

最小コントラスト

エッジまたはエッジペアの最小コントラスト (0 ～ 100、デフォルト = 5) を指定します。このコントラストの値は、領域内のグレースケールヒストグラムから 0 ～ 100 のスケールに正規化されます。この関数は、この設定を上回るコントラストの値を持つエッジまたはエッジペアのみを返します。

アクセプトしきい値

エッジ候補の許容できる最低一致得点 (0 ～ 100、デフォルト = 5) を指定します。この関数は、この値を超える一致得点を持つエッジまたはエッジペアのみを返します。一致得点は、指定したすべての得点付け方法の幾何平均です。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 2)。エッジを抽出する前に、Edge Width を使用して画像をフィルタします。

エッジ: 第 1

領域内のスキャン方向に相対的に、ペアの第 1 エッジの極性を指定します。白→黒または黒→白のいずれかを設定すると、第 1 エッジに指定した極性があるエッジペアのみが報告されます。

0 = 黒→白 | エッジ極性が黒→白になるように指定します。
1 = 白→黒 | エッジ極性が白→黒になるように指定します。
2 = 任意 (デフォルト) | エッジ極性が黒→白または白→黒に変化するように指定します。

エッジ: 第 2

領域内のスキャン方向に相対的に、ペアの第 2 エッジの極性を指定します。白→黒または黒→白のいずれかを設定すると、第 2 エッジに指定した極性があるエッジペアのみが報告されます。

注: このパラメータは、[エッジモード] パラメータが [エッジペア] に設定されている場合にのみ使用されます。

0 = 黒→白 | エッジ極性が黒→白になるように指定します。
1 = 白→黒 | エッジ極性が白→黒になるように指定します。
2 = 任意 (デフォルト) | エッジ極性が黒→白または白→黒に変化するように指定します。

エッジ: 距離

エッジペアの 2 つのエッジ間のピクセル距離を指定します (In-Sight ビジョンシステムの幅の 1 ～ 3 倍、デフォルト = 10)。このパラメータは、エッジペアモードの場合のみ使用されます。エッジ間の距離が領域の幅より長い場合、この関数は #ERR を返します。領域が回転も湾曲もしていない場合、この値は [領域] → [幅] の値未満にする必要があります。

注:In-Sight ビジョンシステムの画像の幅は、画像を取り込んでいる特定の In-Sight ビジョンシステムの画像の幅になります (つまり、In-Sight 5100 ビジョンシステムの最大幅は 1920 で、ビジョンシステムの画像解像度 640×480 より 3 倍多い値になります)。

表示

画像上の Caliper グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | Caliper 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 直線エッジが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と直線エッジは常に表示されます。
3 = すべて表示: 入力、結果、およびチャート | 入力画像領域、直線エッジ、およびエッジのレスポンスチャートが常に表示されます。

Caliper 関数[得点付け方法] タブ

[得点付け方法] タブを使用して、エッジモデルに対してエッジ候補に得点付けするために使用される得点付け関数を選択し、編集します。各エッジ候補について、選択したそれぞれの得点付け方法での未処理の得点を Caliper 関数で計算し、得点付け関数を適用すると、エッジ候補全体の得点が計算されます。全体の得点は、マップされた得点の積の N 番目のルートを取得することによって計算されます。例えば、4 つの得点付け方法が定義されている場合、Caliper 関数では 4 つの得点を乗算し、その結果の 4 番目のルートを取得します (1 つの得点付け関数の結果が 0 の値である場合は、エッジ候補全体の得点も 0 になります)。

注: 得点付け方法は少なくとも 1 つ指定する必要があります。指定しないと #ERR が返されます。デフォルトでは、コントラストの得点付け関数が適用されます。

  • 得点付け関数
  • 得点付け関数の編集

得点付け関数

位置

エッジペアおよび単一エッジに使用可能なこの得点付け方法は、領域の左側または中央を基準とした、エッジまたはエッジペアの相対位置に基づいています。得点付け設定を調整して、領域の左側までの近さに基づいてエッジまたはエッジペアに 0 ～ 100 の範囲の得点を割り当てるように指定します。

[中心領域] チェックボックスがオンの場合 (デフォルトの状態)、外側エッジまたは中央エッジを得点付けの計算の基準に使用し、領域の中心からの相対位置に基づいてエッジまたはエッジペアに得点が付けられます。中央エッジは領域の中心に近いエッジ、外側エッジは中心から離れているエッジです。

[中心領域] チェックボックスがオフの場合、得点付けは、右または左のエッジを得点計算の基準に使用し、領域の左側からの相対位置に基づいて行われます。

[エッジペア距離に正規化する] チェックボックス (エッジペアにのみ使用され、デフォルトでオンになっています) は、エッジペアのエッジ間の距離を [エッジ間の距離] パラメータ値で除算し、その後得点を計算します。これによって、得点計算に実際の値ではなくパーセンテージ値を使用することで、領域内のサイズの変化に適応することができます。

コントラスト

エッジペアおよび単一エッジに使用可能なこの得点付け方法は、エッジ候補のコントラスト、つまり、エッジを構成する隣接ピクセル間のコントラストの変化に基づいています。エッジペアでは、2 つのエッジの平均コントラストが使用されます。得点付け設定を調整して、エッジまたはエッジペアに 0 ～ 100 の範囲の得点を割り当てるように指定します。得点計算の基準は、高コントラストのエッジまたは低コントラストのエッジのいずれかとすることができます。

サイズ

エッジペアにのみ使用できるこの得点付け方法は、エッジペア間の距離 (サイズ) に基づいています。得点付け設定を調整して、エッジペアに、そのサイズに基づいて 0 ～ 100 の範囲の得点を割り当てるように指定します。

[エッジペア距離を正規化する] チェックボックスは、得点の計算に実際の距離を使用します。得点計算の基準として、[エッジ間の距離] パラメータにより近い距離またはより離れている距離 (ピクセル単位) を使用します。それ以外の場合、得点計算の基準は、予想された [エッジ間の距離] パラメータ値より長いか、または短いエッジ間の距離になります。

[左右対称モードを使用する] チェックボックスで (デフォルトではオフ)、領域を拡大/縮小することができます。この設定を使用すると、[エッジ間の距離] パラメータ値より短いサイズと長いサイズの両方を指定することができます。この設定によって一方向への変化が受け入れられ、その他は無視されます。例えば、短い距離を許容して、より長い距離により低い得点を付けるように設定することができます。

またがる

エッジペアにのみ使用できるこの得点付け方法は、2 つのエッジが、領域の中心の両側に位置しているかどうかに基づいています。このタイプの得点付け方法を使用して、画像領域の中心に位置すると予測されるエッジのペアによって定義された対象物を見つけることができます。エッジペアのエッジが画像領域の中心にまたがらない場合の得点は 0 で、またがる場合は 100 点になります。

得点付け関数の編集

得点付け関数は、低いおよび高い入力値と出力値を指定することで定義します。得点付け関数には、片側と両側の 2 つのタイプの得点付け関数があります。

片側得点付け関数

この得点付け関数は、xC、x1、x0、y1、および y0 の値を定義することによって設定します。y0 と y1 に定義される値は、0 ～ 100 である必要があります。xC、x1、および x0 に指定される値は、負の値を含むことができ (xC、x1、および x0 ポイントの 1 つ以上がゼロ未満の未処理の得点となることが予測される場合に、負の値を指定します)、選択された得点付け方法のタイプによってその範囲が決まります。定義された得点付け関数は、次のように入力得点を出力得点にマッピングします。

  • x0 を超える入力値は、出力得点 y0 にマッピングされます。
  • xC を下回る入力値は、出力得点 0 にマッピングされます。
  • xc ～ x1 の入力値は、得点 y1 にマッピングされます。
  • x1 ～ x0 の入力値は、y1 ～ y0 の得点の範囲に直線的にマッピングされます。

上記に示される得点付け関数は、コントラストの得点付け方法のように、高い入力得点から高い出力得点が得られる場合に適しています。ここでは、エッジのコントラストが大きいほど、得られる得点が高くなります。

両側得点付け関数

エッジペアを使用している場合に、エッジモデルより小さいエッジ候補に、エッジモデルより大きいエッジ候補とは異なる得点を付けるように、両側得点付け関数を定義することができます。上記の図は、エッジモデルより小さいエッジ候補よりも、エッジモデルより大きいエッジ候補の許容度が高くなっている、両側得点付け関数の例を示しています。この例では、エッジ候補がエッジモデルとまったく同じサイズである場合、入力得点は 0.0 となり、エッジ候補がエッジモデルより小さい場合は、入力得点は 0 未満になり、エッジ候補がエッジモデルより大きい場合は、入力得点は 0 より大きくなります。

両側得点付け関数が指定されている場合、未処理の得点が正規化され、エッジモデルのサイズと同じ分量だけエッジモデルより小さいエッジ候補が、入力得点 -100 を受け取るようにし、エッジモデルのサイズと同じ分量だけエッジモデルより大きいエッジ候補は、入力得点 100 を受け取るようにします。

Caliper 関数の出力

戻り値

ペアエッジを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

結果

Caliper 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

エッジモードに [単一エッジ] が選択されている場合、結果テーブルには、各エッジの、インデックス、行 0、列 0、行 1、列 1、得点、コントラスト、および位置が含まれます。インデックスは 0 から始まり、表示される行数は [検出する数] の設定値と等しくなります。

エッジモードに [エッジペア] が選択されている場合、結果テーブルには、各エッジのインデックス、行 0、列 0、行 1、および列 1 と、そのペアの最初のエッジの得点、コントラスト、位置、および距離が含まれます。インデックスは 0 から始まり、表示される行数は [検出する数] の設定値の 2 倍になります。

Caliper 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(エッジ, エッジインデックス, 0) | 指定されたエッジの 1 番目の始点の行座標
列 0 | GetCol(エッジ, エッジインデックス, 0) | 指定されたエッジの 1 番目の始点の列座標
行 1 | GetRow(エッジ, エッジインデックス, 1) | 指定されたエッジの 2 番目の終点の行座標
列 1 | GetCol(エッジ, エッジインデックス, 1) | 指定されたエッジの 2 番目の終点の列座標
得点 | GetScore(エッジ, エッジインデックス) | エッジまたはエッジペアの得点。指定したすべての得点付け関数の幾何平均です。
コントラスト | GetContrast(エッジ, エッジインデックス) | エッジの前景と背景の間の平均コントラスト (グレースケール階調で、0 ～ 255)。コントラストは黒→白の場合は正の値、白→黒の場合は負の値。
位置 | GetPosition(エッジ, エッジインデックス) | エッジまたはエッジペアの中心の、画像領域の左側からの相対的な X 位置。
距離 | GetEdgeDistance(エッジ, エッジインデックス) | エッジモードに [エッジペア] が選択されている場合の、エッジペア間の距離。エッジモードに [単一エッジ] が選択されている場合は、#ERR が返ります。

関連項目

  • Caliper 関数の使用方法
  • エッジビジョンツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


FindCircle 関数

FindCircle 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

円環画像領域内で単一の円形状エッジを探します。FindCircle 関数は、半径が大きくなる方向にスキャンされた、同心円上のピクセル値を合計することによって、画像領域の 1 次元プロジェクションを形成します。投影された画像データからエッジ遷移が抽出されます。

  • FindCircle の入力パラメータ
  • FindCircle の出力
  • FindCircle データアクセス関数
  • 関連項目

FindCircle 関数の入力パラメータ

FindCircle 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

ドーナツ領域.X ,

ドーナツ領域.Y ,

ドーナツ領域.内側半径 ,

ドーナツ領域.外側半径 ,

極性 ,

検索 ,

アクセプトしきい値 ,

スコアの正規化 ,

エッジ幅 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

ドーナツ領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能なドーナツ状画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
内側の半径 | 内側の半径のサイズ。
外側の半径 | 外側の半径のサイズ。

注:[フィクスチャ] パラメータと [ドーナツ領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

極性

領域の scan direction に対する、特定対象のエッジの極性を指定します。この関数は、指定された極性のエッジだけを報告します。

0 = 黒→白 | エッジ極性が黒→白になるように指定します。
1 = 白→黒 | エッジ極性が白→黒になるように指定します。
2 = 任意 (デフォルト) | エッジ極性が黒→白または白→黒に変化するように指定します。

検索

関数が複数のエッジ候補から 1 つのエッジを選択する際に使用するエッジ選択手法を指定します。

0 = 最高得点 (デフォルト) | 最高スコアのエッジが注目されるように指定します。
1 = 最小の円 | 検出された最小の円に注目するように指定します。
2 = 最大の円 | 検出された最大の円に注目するように指定します。

アクセプトしきい値

最小許容エッジコントラストを指定します (0 ～ 100、デフォルト = 25)。コントラスト値は、領域内のグレースケールヒストグラムから 0 ～ 100 の範囲で正規化されます。この関数は、コントラストスコアがこの値を下回るエッジを拒否します。

スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。[スコアの正規化] を有効にすると、次の式を使うことで、画像領域内で見つかった最大コントラストで生エッジスコアが正規化されます。

スコア = (生エッジスコア)×(100/最大コントラスト)

生エッジスコアは、エッジ全体のグレースケール階調の差で、最大コントラストは、画像領域内の最大および最小グレースケール階調 (0 ～ 255) の差です。

[スコアの正規化] を無効にすると、低コントラストのエッジのスコアは、高コントラストのエッジよりも低くなります。次の式が使用されます。

スコア = (生エッジスコア)×(100/255)

0 = OFF | スコアを正規化しないでください。
1 = ON (デフォルト) | スコアを正規化します。

ヒント:このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 3)。[エッジ幅] は、エッジが抽出される前に画像をフィルタ処理するために使用されます。

表示

画像上の FindCircle グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindCircle 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 円状形エッジが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と円状形エッジが両方とも常に表示されます。
3 = すべて表示: 入力、結果、およびチャート | 入力画像領域、円状形エッジ、およびエッジのレスポンスチャートが常に表示されます。

FindCircle 関数の出力

戻り値 | 単一の円状形エッジを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindCircle 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindCircle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

中心行 | GetRow(エッジ, 0, 0) | 中心行
中心列 | GetCol(エッジ, 0, 0) | 中心列
半径 | GetRadius(エッジ, 0) | 半径
得点 | GetScore(エッジ, 0) | エッジコントラストの得点得点は黒→白の場合は正の値、白→黒の場合は負の値になります。

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


FindCircleMinMax 関数

FindCircleMinMax 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

エッジからの最小または最大偏差およびエッジ上のすべての点の半径の標準偏差を検出することで、連続するエッジの循環性を検査します。

注: FindCircleMinMax 関数は、円形状エッジを探す場合には使用しません。FindCircle 関数を使用して円形状エッジを探します。

  • FindCircleMinMax の入力パラメータ
  • FindCircleMinMax の出力
  • FindCircleMinMax データアクセス関数
  • 関連項目

FindCircleMinMax 関数の入力パラメータ

FindCircleMinMax 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

ドーナツ領域.X ,

ドーナツ領域.Y ,

ドーナツ領域.内側半径 ,

ドーナツ領域.外側半径 ,

極性 ,

最小コントラスト ,

エッジ幅 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

ドーナツ領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能なドーナツ状画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
内側の半径 | 内側の半径のサイズ。
外側の半径 | 外側の半径のサイズ。

注:[フィクスチャ] パラメータと [ドーナツ領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

極性

領域のスキャン方向に相対的に円の内側から外側に移動する、検出対象のエッジの極性を指定します。この関数は、指定した極性のエッジのみを報告します。

0 = 黒→白 (デフォルト)

1 = 白→黒

最小コントラスト

円に沿った各点でのグレースケールコントラストの最小値 (0 ～ 255、デフォルト = 10) を指定します 。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 3)。[エッジ幅] は、エッジが抽出される前に画像をフィルタ処理するために使用されます。

表示

画像上の FindCircleMinMax グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindCircleMinMax 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 円状形エッジと偏差の最低および最高ポイントが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域、円状形エッジ、および偏差の最低と最高ポイントが常に表示されます。

FindCircleMinMax 関数の出力

戻り値 | 単一の円状形エッジを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindCircleMinMax 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindCircleMinMax 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

中心行 | GetRow(エッジ) | 円形状エッジの中心行
中心列 | GetCol(エッジ) | 円形状エッジの中心列
半径 | GetRadius(エッジ) | 円形状エッジの半径
最小 | GetMin(エッジ) | 円形状エッジの最小偏差
最大 | GetMax(エッジ) | 円形状エッジの最大偏差
標準偏差 | GetSDev(エッジ) | 連続するエッジのすべての点の半径からの標準偏差
得点 | GetScore(エッジ) | 円形状エッジの半径および標準偏差に基づいた、連続するエッジの循環性の計測値。標準偏差が小さいと得点が高くなり、標準偏差が大きいと得点は低くなります。 「得点」は次の式で計算します。 得点 = 100 × (1 - 2 × 標準偏差 ÷ 半径)

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

最小行 | GetRow(エッジ, 1) | 円形状エッジの最小半径点の行
最大行 | GetRow(エッジ, 2) | 円形状エッジの最大半径点の行
最小列 | GetCol(エッジ, 1) | 円形状エッジの最小半径点の列
最大列 | GetCol(エッジ, 2) | 円形状エッジの最大半径点の列
コントラスト | GetContrast(エッジ) | 円形状エッジの前景と背景の間の平均コントラスト (グレースケール階調で、0 ～ 255)。コントラストは黒→白の場合は正の値、白→黒の場合は負の値。

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


FindCurve 関数

FindCurve 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

カーブのある画像領域内で単一の円弧エッジを探します。FindCurve 関数は、領域のローカル座標系に相対的な正の X 方向にスキャンされた、同心円弧セグメントのピクセル値を合計することによって、画像領域の 1 次元プロジェクションを形成します。投影された画像データからエッジ遷移が抽出されます。

  • FindCurve の入力パラメータ
  • FindCurve の出力
  • FindCurve データアクセス関数
  • 関連項目

FindCurve 関数の入力パラメータ

FindCurve 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

極性,

検索,

アクセプトしきい値,

スコアの正規化,

角度範囲,

エッジ幅,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

極性

領域の scan direction に対する、特定対象のエッジの極性を指定します。この関数は、指定された極性のエッジだけを報告します。

0 = 黒→白 | エッジ極性が黒→白になるように指定します。
1 = 白→黒 | エッジ極性が白→黒になるように指定します。
2 = 任意 (デフォルト) | エッジ極性が黒→白または白→黒に変化するように指定します。

検索

関数が複数のエッジ候補から 1 つのエッジを選択する際に使用するエッジ選択手法を指定します。

0 = 最高得点 (デフォルト) | 最高スコアのエッジが注目されるように指定します。
1 = 最初のエッジ | 検出された最初のエッジが注目されるように指定します。
2 = 最後のエッジ | 検出された最後のエッジが注目されるように指定します。

アクセプトしきい値

最小許容エッジコントラストを指定します (0 ～ 100、デフォルト = 25)。コントラスト値は、領域内のグレースケールヒストグラムから 0 ～ 100 の範囲で正規化されます。この関数は、コントラストスコアがこの値を下回るエッジを拒否します。

スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。[スコアの正規化] を有効にすると、次の式を使うことで、画像領域内で見つかった最大コントラストで生エッジスコアが正規化されます。

スコア = (生エッジスコア)×(100/最大コントラスト)

生エッジスコアは、エッジ全体のグレースケール階調の差で、最大コントラストは、画像領域内の最大および最小グレースケール階調 (0 ～ 255) の差です。

[スコアの正規化] を無効にすると、低コントラストのエッジのスコアは、高コントラストのエッジよりも低くなります。次の式が使用されます。

スコア = (生エッジスコア)×(100/255)

0 = OFF | スコアを正規化しないでください。
1 = ON (デフォルト) | スコアを正規化します。

ヒント:このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

角度範囲

エッジの回転に対する関数の許容範囲を指定します (0 ～ 10、デフォルト = 0)。この関数は、指定された範囲外のエッジも検出しますが、精度は高くないことがあります。

注:
  • このパラメータを 0 より大きい値に設定すると、関数の速度が低下します。
  • この設定は、現在は無視されています。円環セグメント内では、[角度範囲] の最大値 10 が必ず許可されます。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 3)。[エッジ幅] は、エッジが抽出される前に画像をフィルタ処理するために使用されます。

表示

画像上の FindCurve グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindCurve 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | カーブのあるエッジが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域とカーブのあるエッジが両方とも常に表示されます。
3 = すべて表示: 入力、結果、およびチャート | 入力画像領域、カーブのあるエッジ、およびエッジのレスポンスチャートが常に表示されます。

FindCurve 関数の出力

戻り値 | 単一のカーブのあるエッジセグメントを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindCurve 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindCurve 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

中心行 | GetRow(エッジ, 0, 0) | 湾曲の中心の行座標
中心列 | GetCol(エッジ, 0, 0) | 湾曲の中心の列座標
始点行 | GetRow(エッジ, 0, 1) | 始点の行座標。
始点列 | GetCol(エッジ, 0, 1) | 始点の列座標。
終点行 | GetRow(エッジ, 0, 2) | 終点の行座標。
終点列 | GetCol(エッジ, 0, 2) | 終点の列座標
半径 | GetRadius(エッジ, 0) | 円弧の半径
得点 | GetScore(エッジ, 0) | エッジコントラストの得点。得点は黒→白の場合は正の値、白→黒の場合は負の値になります。

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


FindLine 関数

FindLine 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

画像領域内で単一の直線エッジを探します。FindLine 関数は、領域のローカル座標系に相対的な正の Y 方向にスキャンされた、放射線セグメントのピクセル値を合計することによって、画像領域の 1 次元プロジェクションを形成します。投影された画像データからエッジ遷移が抽出されます。

  • FindLine の入力パラメータ
  • FindLine の出力
  • FindLine データアクセス関数
  • 関連項目

FindLine 関数の入力パラメータ

FindLine 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

極性 ,

検索 ,

アクセプトしきい値 ,

スコアの正規化 ,

角度範囲 ,

エッジ幅 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

極性

領域の scan direction に対する、特定対象のエッジの極性を指定します。この関数は、指定された極性のエッジだけを報告します。

注: 水平または垂直方向の直線エッジの特徴をフィクスチャ入力として使用する場合、この関数は、ROI のスキャン方向の位置に応じて、水平軸または垂直軸に沿った一方向へのエッジの移動のみを考慮します。

0 = 黒→白 | エッジ極性が黒→白になるように指定します。
1 = 白→黒 | エッジ極性が白→黒になるように指定します。
2 = 任意 (デフォルト) | エッジ極性が黒→白または白→黒に変化するように指定します。

検索

関数が複数のエッジ候補から 1 つのエッジを選択する際に使用するエッジ選択手法を指定します。

0 = 最高得点 (デフォルト) | 最高スコアのエッジが注目されるように指定します。
1 = 最初のエッジ | 検出された最初のエッジが注目されるように指定します。
2 = 最後のエッジ | 検出された最後のエッジが注目されるように指定します。

アクセプトしきい値

最小許容エッジコントラストを指定します (0 ～ 100、デフォルト = 25)。コントラスト値は、領域内のグレースケールヒストグラムから 0 ～ 100 の範囲で正規化されます。この関数は、コントラストスコアがこの値を下回るエッジを拒否します。

スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。[スコアの正規化] を有効にすると、次の式を使うことで、画像領域内で見つかった最大コントラストで生エッジスコアが正規化されます。

スコア = (生エッジスコア)×(100/最大コントラスト)

生エッジスコアは、エッジ全体のグレースケール階調の差で、最大コントラストは、画像領域内の最大および最小グレースケール階調 (0 ～ 255) の差です。

[スコアの正規化] を無効にすると、低コントラストのエッジのスコアは、高コントラストのエッジよりも低くなります。次の式が使用されます。

スコア = (生エッジスコア)×(100/255)

0 = OFF | スコアを正規化しないでください。
1 = ON (デフォルト) | スコアを正規化します。

ヒント:このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

角度範囲

エッジの回転に対する関数の許容範囲を指定します (0 ～ 10、デフォルト = 0)。この関数は、指定された範囲外のエッジも検出しますが、精度は高くないことがあります。

注:このパラメータを 0 より大きい値に設定すると、関数の速度が低下します。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 3)。[エッジ幅] は、エッジが抽出される前に画像をフィルタ処理するために使用されます。

表示

画像上の FindLine グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindLine 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 直線エッジが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と直線エッジが両方とも常に表示されます。
3 = すべて表示: 入力、結果、およびチャート | 入力画像領域、直線エッジ、およびエッジのレスポンスチャートが常に表示されます。

FindLine 関数の出力

戻り値 | 単一の直線エッジセグメントを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindLine 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

角度 | GetAngle(エッジ) | エッジの角度
行 0 | GetRow(エッジ,0,0) | 始点の行座標。
列 0 | GetCol(エッジ,0,0) | 始点の列座標。
行 1 | GetRow(エッジ,0,1) | 終点の行座標。
列 1 | GetCol(エッジ,0,1) | 終点の列座標
得点 | GetScore(エッジ,0) | エッジコントラストの得点。得点は黒→白の場合は正の値、白→黒の場合は負の値になります。

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


FindMultiLine 関数

FindMultiLine 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

画像領域内で複数の直線エッジを探します。FindMultiLine 関数は、領域のローカル座標系に相対的な正の Y 方向にスキャンされた、放射線セグメントのピクセル値を合計することによって、画像領域の 1 次元プロジェクションを形成します。投影された画像データからエッジ遷移が抽出されます。

  • FindMultiLine の入力パラメータ
  • FindMultiLine の出力
  • FindMultiLine データアクセス関数
  • 関連項目

FindMultiLine 関数の入力パラメータ

FindMultiLine 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

検出する数 ,

Threshold B2W ,

Threshold W2B ,

スコアの正規化 ,

検索 ,

角度範囲 ,

エッジ幅 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

検出する数

この関数が返すエッジの最大数を指定します (1 ～ センサの画像の幅 - 1、デフォルト = 3)。特定の In-Sight ビジョンシステムが画像を取り込んでいる場合、検出されるエッジの最大数は画像の幅より 1 少ない数になります (つまり、In-Sight 5100 ビジョンシステムの最大数は 639 で、ビジョンシステムの画像解像度 640×480 より 1 少ない数になります)。

Threshold B2W

黒→白エッジコントラストの許容可能な最小値を指定します (0 ～ 100、デフォルト = 25)。FindMultiLine 関数は、コントラスト得点が [Threshold B2W] を下回る黒→白エッジを拒否します。エッジコントラストは、スキャン領域のグレースケールヒストグラムによって正規化されます。

Threshold W2B

白→黒エッジコントラストの許容可能な最小値を指定します (0 ～ 100、デフォルト = 25)。FindMultiLine 関数は、コントラスト得点が [Threshold W2B] を下回る白→黒エッジを拒否します。エッジコントラストは、スキャン領域のグレースケールヒストグラムによって正規化されます。

スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。[スコアの正規化] を有効にすると、次の式を使うことで、画像領域内で見つかった最大コントラストで生エッジスコアが正規化されます。

スコア = (生エッジスコア)×(100/最大コントラスト)

生エッジスコアは、エッジ全体のグレースケール階調の差で、最大コントラストは、画像領域内の最大および最小グレースケール階調 (0 ～ 255) の差です。

[スコアの正規化] を無効にすると、低コントラストのエッジのスコアは、高コントラストのエッジよりも低くなります。次の式が使用されます。

スコア = (生エッジスコア)×(100/255)

0 = OFF | スコアを正規化しないでください。
1 = ON (デフォルト) | スコアを正規化します。

ヒント:このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

検索

関数が複数のエッジ候補から 1 つのエッジを選択する際に使用するエッジ選択手法を指定します。

0 = 最高得点 (デフォルト) | 最高スコアのエッジが注目されるように指定します。
1 = 最初のエッジ | 検出された最初のエッジが注目されるように指定します。
2 = 最後のエッジ | 検出された最後のエッジが注目されるように指定します。

角度範囲

エッジの回転に対する関数の許容範囲を指定します (0 ～ 10、デフォルト = 0)。この関数は、指定された範囲外のエッジも検出しますが、精度は高くないことがあります。

注:このパラメータを 0 より大きい値に設定すると、関数の速度が低下します。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 3)。[エッジ幅] は、エッジが抽出される前に画像をフィルタ処理するために使用されます。

表示

画像上の FindMultiLine グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindMultiLine 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 検出された直線エッジが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と検出された直線エッジが両方とも常に表示されます。
3 = すべて表示: 入力、結果、およびチャート | 入力画像領域、検出された直線エッジ、およびエッジのレスポンスチャートが常に表示されます。

FindMultiLine 関数の出力

戻り値 | 複数の直線エッジセグメントを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindMultiLine 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindMultiLine 関数データアクセス関数

データアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

検出数

GetNFound(エッジ)

検出数は検出されたエッジの数です。

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

角度 | GetAngle(エッジ, インデックス) | 指定したエッジの角度。
行 0 | GetRow(エッジ, エッジインデックス, 0) | 始点の行座標。
列 0 | GetCol(エッジ, エッジインデックス, 0) | 始点の列座標。
行 1 | GetRow(エッジ, エッジインデックス, 1) | 終点の行座標。
列 1 | GetCol(エッジ, エッジインデックス, 1) | 終点の列座標
得点 | GetScore(エッジ, エッジインデックス) | エッジコントラストの得点。得点は黒→白の場合は正の値、白→黒の場合は負の値になります。

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


FindSegment 関数

ビジョンツール → エッジ

In-Sight 関数リファレンス

画像領域内でエッジのペアを探し、その間の円弧の距離を計算します。FindSegment 関数は、領域の X 方向のピクセル値を合計することによって、画像領域の 1 次元プロジェクションを形成します。投影された画像データからエッジ遷移が抽出されます。そのエッジからエッジへの距離を計算する円弧セグメントは、エッジの抽出に使用される領域から派生します。

  • FindSegment の入力パラメータ
  • FindSegment の出力
  • FindSegment データアクセス関数
  • 関連項目

FindSegment 関数の入力パラメータ

FindSegment 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

セグメントの色 ,

検索 ,

アクセプトしきい値 ,

スコアの正規化 ,

角度範囲 ,

エッジ幅 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

セグメントの色

探す対象のセグメントの色を指定します。FindSegment 関数は、指定した極性のエッジペアのみを報告します。

0 = 黒 (デフォルト) | 黒または白→黒、その後に黒→白の極性を指定します。
1 = 白 | 白または黒→白、その後に白→黒の極性を指定します。

検索

エッジの選択技術を指定します。

0 = 最も幅の広いセグメント (デフォルト) | 指定した [Segment Color] のセグメントを識別することができる、最も遠く離れた 2 つのエッジを検出します。
1 = 最強のエッジ | 指定した [Segment Color] のセグメントを識別することができる、最も強いレスポンス得点を持つ 2 つのエッジを検出します。
2 = 最も幅の広い隣接するセグメント | 指定した [Segment Color] のセグメントを識別することができ、その間に他のエッジがない 2 つのエッジを検出します。
3 = 最も狭いセグメント | 指定した [Segment Color] のセグメントを識別することができる、相互に最も近い 2 つのエッジを検出します。

アクセプトしきい値

最小許容エッジコントラストを指定します (0 ～ 100、デフォルト = 25)。コントラスト値は、領域内のグレースケールヒストグラムから 0 ～ 100 の範囲で正規化されます。この関数は、コントラストスコアがこの値を下回るエッジを拒否します。

スコアの正規化

エッジスコアを領域のグレースケールヒストグラムで正規化するかどうかを指定します。[スコアの正規化] を有効にすると、次の式を使うことで、画像領域内で見つかった最大コントラストで生エッジスコアが正規化されます。

スコア = (生エッジスコア)×(100/最大コントラスト)

生エッジスコアは、エッジ全体のグレースケール階調の差で、最大コントラストは、画像領域内の最大および最小グレースケール階調 (0 ～ 255) の差です。

[スコアの正規化] を無効にすると、低コントラストのエッジのスコアは、高コントラストのエッジよりも低くなります。次の式が使用されます。

スコア = (生エッジスコア)×(100/255)

0 = OFF | スコアを正規化しないでください。
1 = ON (デフォルト) | スコアを正規化します。

ヒント:このパラメータは、低コントラスト領域でエッジを見つける場合に有用です。検出対象のエッジが高コントラストだけの場合は、このパラメータを無効にします。

角度範囲

エッジの回転に対する関数の許容範囲を指定します (0 ～ 10、デフォルト = 0)。この関数は、指定された範囲外のエッジも検出しますが、精度は高くないことがあります。

注:このパラメータを 0 より大きい値に設定すると、関数の速度が低下します。

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 50、デフォルト = 3)。[エッジ幅] は、エッジが抽出される前に画像をフィルタ処理するために使用されます。

表示

画像上の FindSegment グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | FindSegment 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | エッジセグメントを定義する 2 つのエッジが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と 2 つのエッジが両方とも常に表示されます。
3 = すべて表示: 入力、結果、およびチャート | 入力画像領域、2 つのエッジ、およびエッジのレスポンスチャートが常に表示されます。

FindSegment 関数の出力

戻り値 | 直線エッジの一致するペアを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindSegment 関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindSegment 関数データアクセス関数

2 つのデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

距離 | PairDistance(エッジ, 0, 1) | セグメントの距離
得点 | GetScore(エッジ, 0) | セグメントのコントラスト得点

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

角度 | GetAngle(エッジ, インデックス) | 指定したエッジの角度。
行 0 | GetRow(エッジ, エッジインデックス, 0) | 始点の行座標。
列 0 | GetCol(エッジ, エッジインデックス, 0) | 始点の列座標。
行 1 | GetRow(エッジ, エッジインデックス, 1) | 終点の行座標。
列 1 | GetCol(Edges, エッジインデックス, 1) | 終点の列座標

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


PairDistance 関数

PairDistance 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

データ構造体の 2 つのエッジ間の距離を計算します。PairDistance 関数は、インデックス番号によって 2 つのエッジを参照し、それらの中間点間の距離を報告します。そのエッジからエッジへの距離を計算するセグメントは、画像からエッジを抽出するために元々使用されていた領域から派生します。

注: Abs 式、例えば Abs(B2)+PairDistance(C2,0,1) に PairDistance 関数を追加する場合、PairDistance 関数はスプレッドシートの専用のセルに挿入し、Abs 式へのセル参照を使用することを推奨します。

  • PairDistance の入力パラメータ
  • PairDistance の出力
  • 関連項目

PairDistance 関数の入力パラメータ

PairDistance 関数 (

エッジ ,

第 1 エッジ ,

第 2 エッジ

)

エッジ | データ構造体を含んでいるスプレッドシートセルへの参照。複数の直線エッジで構成する必要があります。
第 1 エッジ | エッジペアの 1 番目のエッジのインデックス番号 (0 ～ 10000、デフォルト = 0) を指定します。
第 2 エッジ | エッジペアの 2 番目のエッジのインデックス番号 (0 ～ 10000、デフォルト = 1) を指定します。

PairDistance 関数の出力

戻り値

エッジ間の円弧の距離を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


PairEdges 関数

PairEdges 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

エッジの配列をエッジペアの配列にソートします。PairEdges 関数は、 [image] データ構造体で指定した許容値内のエッジペアをスキャンします。ペアに属するエッジは、連続して順序付けされます。例えば、ペアの 1 番目のエッジは偶数のインデックス番号、ペアの 2 番目のエッジは奇数のインデックス番号となります。

  • PairEdges の入力パラメータ
  • PairEdges の出力
  • PairEdges データアクセス関数
  • 関連項目

PairEdges 関数の入力パラメータ

PairEdges 関数 (

エッジ,

ペア数,

エッジ: 第 1,

エッジ: 第 2,

エッジ距離: 最小,

エッジ距離: 最大,

中間エッジ.最小 B2W,

中間エッジ.最大 B2W,

中間エッジ.最小 W2B,

中間エッジ.最大 W2B,

表示

)

エッジ

データ構造体を含んでいるスプレッドシートセルへの参照。複数の直線エッジで構成する必要があります。

注: PairEdges 関数は、Caliper 関数によって返される [image] データ構造体を参照することはできません。

ペア数

報告されるペアの最大数を指定します。(0 ～ 80、デフォルト = 1)。

エッジ: 第 1

ペアの 1 番目のエッジの極性を指定します。PairEdges 関数は、1 番目のエッジが指定極性を持つエッジペアだけを報告します。

0 = 黒→白

1 = 白→黒 (デフォルト)

2 = 任意

エッジ: 第 2

ペアの 2 番目のエッジの極性を指定します。PairEdges 関数は、2 番目のエッジが指定極性を持つエッジペアだけを報告します。

0 = 黒→白 (デフォルト)

1 = 白→黒

2 = 任意

エッジ距離: 最小

ペアのエッジ間の最小円弧距離 (0 ～ 1920、デフォルト = 0) を指定します。PairEdges 関数は、[エッジ距離: 最小] の距離よりも離れているエッジペアのみを報告します。

エッジ距離: 最大

ペアのエッジ間の最大円弧距離 (0 ～ 1920、デフォルト = 50) を指定します。PairEdges 関数は、[エッジ距離: 最大] の距離よりも近いエッジペアのみを報告します。

中間エッジ

エッジペアの終了ポイント間に位置するエッジについて、予想される数および極性を指定します。PairEdges 関数は、予想される数の中間エッジを含んでいるエッジペアのみを報告します。

Min B2W | エッジペアの終了ポイント間で、予想される黒→白のエッジの最小数を指定します(0 ～ 320、デフォルト = 0)。
Max B2W | エッジペアの終了ポイント間で、予想される黒→白のエッジの最大数を指定します(0 ～ 320、デフォルト = 0)。
Min W2B | エッジペアの終了ポイント間で、予想される白→黒のエッジの最小数を指定します(0 ～ 320、デフォルト = 0)。
Max W2B | エッジペアの終了ポイント間で、予想される白→黒のエッジの最大数を指定します(0 ～ 320、デフォルト = 0)。

表示

画像上の PairEdges グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | PairEdges 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 直線エッジが常に表示されます。

PairEdges 関数の出力

戻り値 | ペアエッジを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | PairEdges 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

PairEdges 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

ペア数 | GetNFound(エッジ) | 検出されたエッジペアの数
最小距離 | PairMinDistance(エッジ) | ペアになっているエッジ間の最小距離
最大距離 | PairMaxDistance(エッジ) | ペアになっているエッジ間の最大距離
平均距離 | PairMeanDistance(エッジ) | ペアになっているエッジ間の平均距離
距離の標準偏差 | PairSDevDistance(エッジ) | ペアになっているエッジ間の距離の標準偏差。

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

角度 | GetAngle(エッジ, インデックス) | 指定したエッジの角度。
行 0 | GetRow(エッジ, エッジインデックス, 0) | 指定されたエッジの 1 番目の始点の行座標
列 0 | GetCol(エッジ, エッジインデックス, 0) | 指定されたエッジの 1 番目の始点の列座標
行 1 | GetRow(エッジ, エッジインデックス, 1) | 指定されたエッジの 2 番目の終点の行座標
列 1 | GetCol(エッジ, エッジインデックス, 1) | 指定されたエッジの 2 番目の終点の列座標
得点 | GetScore(エッジ, エッジインデックス) | 指定したエッジのエッジコントラスト得点

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


PairMaxDistance 関数

PairMaxDistance 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

ペアになっているエッジ間の最大距離を検出します。PairMaxDistance 関数は、 [image] データ構造体に含まれているエッジペアの配列で、円弧の最大長さを囲むエッジペアをサーチし、距離の値を返します。

  • PairMaxDistance の入力パラメータ
  • PairMaxDistance の出力
  • 関連項目

PairMaxDistance 関数の入力パラメータ

PairMaxDistance 関数 (

エッジ

)

エッジ

複数の直線エッジで構成される必要がある [image] データ構造体を含んだスプレッドシートセルへの参照。偶数のインデックスが付いたエッジにはエッジペアの最初のエッジが含まれ、奇数のインデックスが付いたエッジにはエッジペアの2番目のエッジが含まれるというように、この関数では、入力 [image] データ構造体がペアでソートされることを想定しています。

PairMaxDistance 関数の出力

戻り値

最大のエッジペア距離を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


PairMeanDistance 関数

PairMeanDistance 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

エッジペアの距離の平均を計算します。

  • PairMeanDistance の入力パラメータ
  • PairMeanDistance の出力
  • 関連項目

PairMeanDistance 関数の入力パラメータ

PairMeanDistance 関数 (

エッジ

)

エッジ

複数の直線エッジで構成される必要がある [image] データ構造体を含んだスプレッドシートセルへの参照。偶数のインデックスが付いたエッジにはエッジペアの最初のエッジが含まれ、奇数のインデックスが付いたエッジにはエッジペアの2番目のエッジが含まれるというように、この関数では、入力 [image] データ構造体がペアでソートされることを想定しています。

PairMeanDistance 関数の出力

戻り値

エッジペアの距離の平均を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


PairMinDistance 関数

PairMinDistance 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

エッジペアの距離の最小値を検出します。PairMinDistance 関数は、 [image] データ構造体に含まれているエッジペアの配列で、円弧の最大長さを囲むエッジペアをサーチし、距離の値を返します。

  • PairMinDistance の入力パラメータ
  • PairMinDistance の出力
  • 関連項目

PairMinDistance 関数の入力パラメータ

PairMinDistance 関数 (

エッジ

)

エッジ

複数の直線エッジで構成される必要がある [image] データ構造体を含んだスプレッドシートセルへの参照。偶数のインデックスが付いたエッジにはエッジペアの最初のエッジが含まれ、奇数のインデックスが付いたエッジにはエッジペアの2番目のエッジが含まれるというように、この関数では、入力 [image] データ構造体がペアでソートされることを想定しています。

PairMinDistance 関数の出力

戻り値

最小のエッジペア距離を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


PairSDevDistance 関数

PairSDevDistance 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

エッジペアの距離の標準偏差を計算します。

  • PairSDevDistance の入力パラメータ
  • PairSDevDistance の出力
  • 関連項目

PairSDevDistance 関数の入力パラメータ

PairSDevDistance 関数 (

エッジ

)

エッジ

複数の直線エッジで構成される必要がある [image] データ構造体を含んだスプレッドシートセルへの参照。偶数のインデックスが付いたエッジにはエッジペアの最初のエッジが含まれ、奇数のインデックスが付いたエッジにはエッジペアの2番目のエッジが含まれるというように、この関数では、入力 [image] データ構造体がペアでソートされることを想定しています。

PairSDevDistance 関数の出力

戻り値

エッジペアの距離の標準偏差を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


PairsToEdges 関数

PairsToEdges 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

エッジペアの配列をエッジの配列に変換します。この関数は、偶数のインデックスで指定されたエッジの行と列の座標と、対応する奇数のインデックスで指定されたエッジの行と列の座標との平均を求めて、エッジのペアを単一のエッジに変換します。

  • PairsToEdges の入力パラメータ
  • PairsToEdges の出力
  • PairsToEdges データアクセス関数
  • 関連項目

PairsToEdges 関数の入力パラメータ

PairsToEdges 関数 (

エッジ ,

ペア数 ,

表示

)

エッジ

複数の直線エッジで構成される必要がある [image] データ構造体を含んだスプレッドシートセルへの参照。偶数のインデックスが付いたエッジにはエッジペアの最初のエッジが含まれ、奇数のインデックスが付いたエッジにはエッジペアの2番目のエッジが含まれるというように、この関数では、入力 [image] データ構造体がペアでソートされることを想定しています。

ペア数

エッジに変換するエッジペアの数を指定します (0 ～ 80、デフォルト = 1)。

表示

画像上の PairsToEdges グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | PairsToEdges 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | エッジペアが常に表示されます。

PairsToEdges 関数の出力

戻り値 | エッジペアから派生したエッジを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | PairsToEdges 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

PairsToEdges 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(エッジ, エッジインデックス, 0) | 始点の行座標。
列 0 | GetCol(エッジ, エッジインデックス, 0) | 始点の列座標。
行 1 | GetRow(エッジ, エッジインデックス, 1) | 終点の行座標。
列 1 | GetCol(エッジ, エッジインデックス, 1) | 終点の列座標
得点 | GetScore(エッジ, エッジインデックス) | エッジコントラストの得点。

関連項目

  • エッジツールについて
  • Edges データアクセス関数
  • プロパティシートの使用方法


SortEdges 関数

SortEdges 関数 |
ビジョンツール → エッジ | In-Sight 関数リファレンス

指定した基準でエッジのアレイをソートします。

  • SortEdges の入力パラメータ
  • SortEdges の出力
  • SortEdges データアクセス関数
  • 関連項目

SortEdges 関数入力

SortEdges 関数 (

エッジ ,

ソートする数 ,

ソート基準 ,

表示

)

エッジ

データ構造体を含むスプレッドシートセルへの参照です。 データ構造体は、複数の直線エッジで構成する必要があります。

ソートする数

ソートするエッジの数を指定します (0 ～ 160、デフォルト = 2)。

ソート基準

エッジのソート方法を指定します。

0 = 最高得点 | 降順のコントラストスコアでソートします。
1 = 最初から最後 (デフォルト) | 元のスキャン方向でソートします。
2 = 得点を基準とした B2W、得点を基準とした W2B | 最初に極性でソートし、次に得点でソートします。
3 = B2W 最初から最後、W2B 最初から最後 | 最初に極性でソートし、次に元のスキャン順でソートします。
4 = 最後から最初 | 逆のスキャン順でソートします。

表示

画像上の SortEdges グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | SortEdges 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 直線エッジが常に表示されます。

SortEdges 関数の出力

戻り値 | ソートされたエッジを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | SortEdges 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

SortEdges 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

角度 | GetAngle(エッジ, インデックス) | 指定したエッジの角度。
行 0 | GetRow(エッジ, エッジインデックス, 0) | 始点の行座標。
列 0 | GetCol(エッジ, エッジインデックス, 0) | 始点の列座標。
行 1 | GetRow(エッジ, エッジインデックス, 1) | 終点の行座標。
列 1 | GetCol(エッジ, エッジインデックス, 1) | 終点の列座標。
得点 | GetScore(エッジ, エッジインデックス) | エッジコントラストの得点。

関連項目

  • エッジツールについて
  • エッジデータアクセス関数
  • プロパティシートの使用方法


傷検出

ビジョンツール

In-Sight 関数リファレンス

傷検出ビジョンツールの SurfaceFlaw 関数、DetectFlaw 関数、FlexFlawModel 関数および TrainFlawModel 関数は、欠陥の有無を検証するための高度なパターン一致分析の実行に使用されます。

傷検出ビジョンツールの SurfaceFlaw 関数は、登録モデルを使用せずに、ピクセル明度のばらつきに基づいて小さな欠陥を検出するために使用されます。このツールは、グレースケール画像またはカラー画像から、傷、刃こぼれ、裂け目、汚れまたは破片などの欠陥を検出するように設計されています。

傷検出ビジョンツールの DetectFlaw 関数、FlexFlawModel 関数および TrainFlawModel 関数は「ゴールデン」部品、つまり完全な部品に基づくモデルを作成してから、高度なパターン一致アルゴリズムを使用してこのモデルと取り込んだ画像を比較し、エッジの欠落や表面の傷、正しく印刷されていないロゴなどの欠陥の有無を判断します。

In-Sight ビジョンシステムは、傷検出ビジョンツールの次の関数を使用して、詳細な欠陥検出分析を実行します。

  • SurfaceFlaw 関数: 欠陥の有無を判断するための画像内のローカルな明度のばらつきを検出します。
  • DetectFlaw 関数: 取り込んだ画像とモデルを比較したときに欠陥の有無を判断するためのパラメータを作成します。
  • FlexFlawModel 関数: プロセスばらつきを補正するためのオプションの Flex アルゴリズムを作成します。
  • TrainFlawModel 関数: 「ゴールデン」部品のモデルを作成します。

注: FlexFlawModel 関数は、TrainFlawModel 関数によって出力されたデータ構造体を参照する必要があります。DetectFlaw 関数は、TrainFlawModel 関数または DetectFlaw 関数によって出力されたデータ構造体を参照することがあります。

In-Sight について傷検出ツール

傷検出ビジョンツールは、SurfaceFlaw 関数および、DetectFlaw 関数、FlexFlawModel 関数、TrainFlawModel 関数の、2 つのツールグループによって構成されています。

  • 傷検出ビジョンツールの SurfaceFlaw 関数
  • 傷検出ビジョンツールの DetectFlaw 関数、FlexFlawModel 関数 および TrainFlawModel 関数

傷検出ビジョンツールの SurfaceFlaw 関数

概要

SurfaceFlaw 関数は、生産プロセスにおける欠陥である、ローカルな明度のばらつきとカラーのばらつきのある領域を検出するように設計されています。この関数は、ブロブ解析を適用して欠陥の有無を判断する前に、内部のフィルタ操作を使用して、最初にカラーまたはグレースケールに急な変動のあったエッジと領域をハイライトします。

SurfaceFlaw 関数はスタンドアローン関数です。モデルを使用する必要がないため、設定が簡略化され実行時間が改善されます。モデルを組み込まないため、この関数は実行時の照明のばらつきを考慮し、欠陥を正確に検出することができます。ただし、DetectFlaw 関数、FlexFlawModel 関数、および TrainFlawModel 関数が持つような、発生する可能性のあるばらつきを補正する機能はないため、部品のプロセスのばらつきを調整することはできません。このため、SurfaceFlaw 関数は、検査される部品の領域が均一である、つまり、明度に急な変動があると欠陥として分類されるアプリケーションに適しています。部品に明度のばらつきがある場合、そのほかの傷検出関数によってそうしたばらつきが考慮される必要があります。

注: SurfaceFlaw 関数は、Mask 関数によって出力された [image] データ構造体を受け入れます。これにより、画像内の指定した領域のみを検査することができます。

傷検出ビジョンツールの DetectFlaw 関数、FlexFlawModel 関数 および TrainFlawModel 関数

概要

傷検出ツールの DetectFlaw 関数、FlexFlawModel 関数および TrainFlawModel 関数は、欠陥が存在するかどうかを検証するための高度なパターン一致分析を実行するように設計されています。このツールの関数は、モデルの「引き伸ばし」(発生する可能性のあるばらつきを補正するように関数に指示すること) および画像の減算を組み合わせて、取り込まれた画像と比較する詳細モデルを作成し、取り込まれた画像に欠陥が存在するかどうかを判断します。このアーキテクチャでは、関数は実行時にモデルを動的に更新する機能を提供します。

これらの関数を組み合わせて、次の種類の検査を実行することができます。

  • 境界線の欠陥 - 部品や対象物が同じ形状を維持していることを確認します。
  • 表面の欠陥 - 部品や対象物に汚れや傷がないことを確認します。
  • 印刷の検査 - 部品や対象物にロゴが正しくシルクスクリーン印刷され、欠陥がないことを確認します。

モデルの作成

すべてのアプリケーションと同様に、「良好」と「不良」の両方の状態の部品が含まれる部品の画像のデータベースが最初にロードされます。傷検出ツールの使用を開始するには、最初に、検査する対象物や部品の画像を取り込みます。この対象物や部品は、検査される対象物や部品を「ゴールデン」として、つまり完全に表現したものです。これによって、対象物や部品の正しい特徴がすべてオリジナルのモデルに含まれていることが確認されます。画像の取り込み後、TrainFlawModel 関数がスプレッドシートに追加され、画像内の対象物や部品を定義するために、この関数の内部領域、または外部領域やパスへの参照のいずれかが指定されます。モデルが適切に定義されるように、すべてのパラメータを調整すると、この関数によって、モデルに関するデータがすべて格納されるようになります。

傷検出

登録モデルの準備ができたら、DetectFlaw 関数を使用して、取り込まれた画像に現れる対象物や部品内の欠陥を分類できるようになります。DetectFlaw 関数は TrainFlawModel 関数に格納されたモデルデータと取り込まれた画像を比較し、対象物や部品に面積欠陥またはエッジ欠陥、もしくはこの両方が存在するかどうかを判断します。領域の検査では、対象物や部品の表面上の傷や汚れなどの欠陥の有無が検証されます。また、エッジの検査では、余分なエッジ、またはエッジの欠落がないかどうか、また対象物や部品の境界線が一定であるかどうかが検証されます。領域とエッジの欠陥検査を組み合わせることによって、最高レベルの検査を行うことができます。

DetectFlaw 関数には、実行時に特定の欠陥を無視するようにマスクを動的に調整するためのコントロールも含まれています。

モデルの Flex 化

対象物や部品に歪みまたはプロセスばらつきが生じる場合、必要に応じて、FlexFlawModel 関数を使用して、歪みやプロセスばらつきを補正するための Flex アルゴリズムを作成することができます。FlexFlawModel 関数を使用して、モデルを「引き伸ばし」する、つまり部品で発生する可能性のあるばらつきの範囲がより広くなるようにモデルを修正し、DetectFlaw 関数がこのばらつきを欠陥として分類しないようにすることができます。

用語の定義:

  • エッジピクセル: 異なるピクセル値を持つ 2 つの領域間の境界線上に位置する画像内のピクセル。
  • エッジセグメント: 異なるピクセル値を持つ領域間の連続する境界線。エッジセグメントは、エッジピクセル (つまり、「エッジ特徴」) のリストによって表されます。
  • Flex: 位置決めエラー、レンズや遠近歪み、登録エラー、またはそのほかの通常のプロセスばらつきによって引き起こされるエッジピクセルとエッジセグメントの変位。
  • 囲まれたセグメントおよび囲まれたセグメント Flex: 囲まれたセグメントは、始点と終点が同じエッジセグメントです。また、囲まれたセグメント Flex は囲まれたセグメントの変位です。
  • 線分 Flex: 線分はエッジセグメントの一部です。これは囲まれていることもあり、囲まれていないこともあります。線分 Flex は線分の変位です。
  • ピクセル Flex: エッジピクセルの変位。
  • Flex 解像度: Flex に対する訂正が適用されるときに、モデル画像およびマスク画像に適用される倍率。解像度が高いほど、より正確に非線形歪みを処理できるようになりますが、消費されるメモリの量も増加します。
  • マスク/マスキング: 処理中に無視されるピクセル位置の集合。ピクセル値に関係なく、マスクされたピクセルが欠陥を生成することはありません。

注: 傷検出ツールが持つマスク/マスキング機能は EditCompositeRegion 関数で適用される機能とは異なります。EditCompositeRegion 関数は通常、不規則な対象領域 (ROI) を定義し、画像の領域を除外するために使用されます。一方、傷検出ツールで使用されるマスキングは、モデルを作成するときのピクセルグレースケール勾配値を決定するために計算されます。

  • 面積欠陥: 登録モデル画像のピクセルと取り込まれた画像を比較し、ピクセル値 (グレースケールまたは色の明度) が同じであるかどうかを検証することによって検出される欠陥のタイプ。面積欠陥は通常、ブロブ状で、変色、染み、汚れ、または縞を含むことがあります。
  • エッジの欠落の欠陥: あらかじめ登録しておいたエッジセグメントが、取り込まれた画像に存在しないときに発生する欠陥のタイプ。エッジの欠落という欠陥には、通常、部品の外形の変化や特徴の欠損などの欠陥が含まれます。
  • 余分なエッジの欠陥: 取り込まれた画像に現れているエッジセグメントが、登録されているエッジセグメントには存在しないときに発生する欠陥のタイプ。余分なエッジの欠陥には、通常、余分な特徴、傷、裂け目などの欠陥が含まれます。
  • モデル画像: 登録中に保存された画像。モデル画像は、面積欠陥を検出するために、取り込まれた画像と比較されます。
  • マスク画像: マスクされたピクセルの位置と値、およびマスクされたエッジセグメントの位置を表します。マスク画像には、EditCompositeRegion 関数の形状やそのほかの非矩形形状によって除外された画像の領域は含まれません。
  • 残余画像:　 取り込んだ画像をモデル画像およびマスク画像と比較することによって作成される画像。この画像は、面積欠陥を検出するために生成されます。


SurfaceFlaw 関数

SurfaceFlaw 関数 |
ビジョンツール → 傷検出 | In-Sight 関数リファレンス

SurfaceFlaw 関数を使用して、検査対象の対象物や部品のスクラッチ、刃こぼれ、裂け目などの欠陥を示す、ローカルな明度のばらつきを検出します。

  • SurfaceFlaw 関数の概要
  • SurfaceFlaw の入力パラメータ
  • SurfaceFlaw の出力
  • SurfaceFlaw 関数のデータアクセス関数
  • 関連項目

概要

SurfaceFlaw 関数は、生産プロセスの欠陥である、ローカルな明度のばらつきとカラーのばらつきのある領域を検出するように設計されています。この関数は、2 種類の内部フィルタ操作 (エッジ状の欠陥の検出に使用する [高速検出]、またはブロブ状の欠陥の検出に使用する [明るい傷]、[暗い傷]、[両方]) を使用します。しきい値を設定し、ブロブ解析を適用して欠陥の有無を判断する前に、最初に、カラーまたはグレースケールに急な変動のあったエッジと領域をハイライトします。

SurfaceFlaw 関数はスタンドアローン関数です。モデルを使用する必要がないため、設定が簡略化され実行時間が改善されます。モデルを組み込まないため、この関数は実行時の照明のばらつきを考慮し、欠陥を正確に検出することができます。ただし、DetectFlaw 関数、FlexFlawModel 関数、および TrainFlawModel 関数が備えているような、発生する可能性のあるばらつきを補正する機能はないため、部品のプロセスのばらつきを調整することはできません。このため、SurfaceFlaw 関数は、検査される部品の領域が均一である、つまり、明度に急な変動があると欠陥として分類されるアプリケーションに適しています。部品にプロセスのばらつきがある場合、ほかの Flaw Detection 関数でばらつきが考慮される必要があります。

注: SurfaceFlaw 関数は、Mask 関数によって出力された [image] データ構造体を受け入れます。これにより、画像内の指定した領域のみを検査することができます。

SurfaceFlaw 関数の設定

SurfaceFlaw 関数の設定では、欠陥の有無の判別に使用されるしきい値を確立します。開始前に、検査対象となる部品の画像のデータベースを収集します。これには、誤差のない状態の部品画像と、一般的な誤差を示す画像が含まれます。画像は [記録/再生のオプション] ダイアログを使用してロードします。

まず最初に、誤差のない状態の部品の画像をロードします。SurfaceFlaw 関数をスプレッドシートに挿入し、検査対象の画像領域を囲むように [領域] を調整します。[領域] を設定するときは、ラベルや、文字またはロゴのエッジなどの無関係な特徴は含めないようにします。検査対象に部品のエッジを含める場合、領域がエッジに対して平行に位置される必要があります (円形の領域についても同様に、部品のエッジに対して円形のカーブ領域が平行)。ただし、エッジを超えないようにします。

注:
  • 部品が動きを有する場合、[フィクスチャ] を使用して [領域] が部品に応じて移動することを確認してください。
  • ラベルや英数字などの検査対象から除外する必要のある領域が部品に含まれる場合、Mask 関数によって出力された [image] データ構造体を使用し、除外する領域を削除します。これにより、画像内の指定した領域のみを検査することができます。

関数のパラメータが欠陥を特定しないように設定されていることを確認します。SurfaceFlaw 関数には、[表示画像] パラメータが含まれています。このパラメータによって、パラメータでの調整がどのように関数に影響するかを示す視覚的フィードバックが提供されます。四角形の赤ボックス内に検出される傷がすべて含まれるように、[画像表示] パラメータを [傷候補] に設定します。

パラメータを調整する際は、[サンプル係数] と [平滑化係数] パラメータを調整することを推奨します。勾配の少ない傷を検出したり、低コントラストの大きな傷を検出したりするには、[サンプル化係数] を大きくします。[サンプル係数] パラメータを大きくすると、小さな欠陥や疑似欠陥を除外することができます。

これらのパラメータを調整したら、[検出タイプ]、[検出サイズ]、および [検出軸] パラメータのさまざまなオプションを使用します。この関数には、エッジ状の欠陥と、ブロブ状の欠陥の、2 種類の欠陥の検出方法があります。[検出タイプ] パラメータを [高速検出] に設定すると、「領域」タイプの欠陥のエッジに対してエッジ状の欠陥を検出するエロージョン/ダイレーションフィルタを実行します。これにより、欠陥の面積全体ではなく、欠陥の境界ボックスの周囲長として欠陥のサイズが報告されます。この設定は、スクラッチや裂け目などの欠陥を検出するのに有用です。

[検出タイプ] のオプション ([明るい傷]、[暗い傷]、または [両方]) は、ボトムハットフィルタとトップハットフィルタの組み合わせを使用してブロブ状の欠陥を検出します。これにより、ピクセルサイズに基づいて欠陥を検出することができます。このオプションは、斑点、染み、汚れなどの欠陥の面積を基準にして欠陥を検出するのに有用です。ただし、この 3 種類の [検出タイプ] オプションは、一般的により長い処理時間を必要とします。

[検出タイプ] パラメータを [高速検出] に設定する必要のあるほとんどのアプリケーションで、[検出サイズ] は通常、1 に設定するのが適切です。[明るい傷]、[暗い傷]、または [両方] に設定する必要のあるアプリケーションでは、[検出サイズ] パラメータは、検出対象の欠陥の半径よりも大きいサイズに設定する必要があります。

注: [領域] がエッジに対して平行に設定された場合、[検出軸] を領域と平行になるように設定する必要があります。

最後に、[最小傷面積]、[最大傷面積] および [最小コントラスト] パラメータを調整し、欠陥がそれぞれ適切に検出され、ハイライトされることを確認します。

誤差のない状態の部品を正しく検査したら、欠陥の含まれる部品の画像をロードします。ここでも、関数が目的の欠陥を正しく特定するまでパラメータを調整するプロセスを実行します。欠陥が特定されたら、誤差のない状態の部品の画像を再ロードして、欠陥が含まれていない画像として正しく検査されることを確認します。データベースのすべての画像が正常に設定されると、実行時の検査向けの関数の準備が整います。

SurfaceFlaw 関数の入力パラメータ

SurfaceFlaw 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

外部定義領域,

歪みのない画像,

サンプル係数,

自動平滑化,

平滑化係数,

検出タイプ,

検出サイズ,

検出軸,

傷データの計算,

傷形の計算,

最小傷面積,

最大傷面積,

最小コントラスト,

タイムアウト,

表示画像,

表示行,

表示列,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

注:
  • SurfaceFlaw 関数はピクセル座標で動作します。
  • SurfaceFlaw 関数では、グレースケール画像とカラー画像の両方がサポートされています。カラー画像を参照する場合、赤、緑、および青 (RGB) の 3 つのカラープレーンのいずれかの欠陥が識別されます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

Row (デフォルト = 0) | 画像座標での行オフセット。
Column (デフォルト = 0) | 画像座標での列オフセット
Theta (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

注: 別のビジョンツール関数またはオペレータ I/F 関数の出力に対する ROI を定義する場合、領域座標へのセル参照を設定する代わりに、[外部定義領域] パラメータを使用します。[外部定義領域] パラメータはフィクスチャの動きを正しく考慮しますが、セル参照は正しく機能しない可能性があり、フィクスチャの動きを参照する関数は #ERR を返すことがあります。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域

オペレータ I/F 関数、または Mask 関数によって出力された　 [image] 　データ構造体を含むスプレッドシートのセルへの参照を指定します。このパラメータを使用すると、この関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域に指定された画像領域を検査します。

注:
  • このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

歪みのない画像

画像処理を先に進める前に、カーブや角度のある対象領域 (ROI) から歪みを取り除くかどうかを指定します。このパラメータは、欠陥を特定の軸 (X または Y) に沿ってのみ検出する場合に使用すると有用です。検出カーネルは ROI の方向や形に関係なく、常に画像の X 軸および Y 軸に沿って処理するようになります。画像内で「対角」の直線エッジに沿って欠陥を検出するには、最初に画像の歪みを取り除く必要があります。

注:

  • このパラメータは、内部 [領域] または [外部定義領域] パラメータに角度やカーブがある場合に必要になります。
  • 角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。
0 = OFF (デフォルト) | カーブや角度のある ROI から歪みを取り除かないように指定します。
1 = ON | カーブや角度のある ROI から歪みを取り除くように指定します。

サンプリング係数

入力画像をサンプリングする量 (1 ～ 99999、デフォルト = 1) を指定します。これにより解像度を下げます。サンプリングは関数の実行時間を短縮するのに有用ですが、精度に影響を与えます。画像のサブサンプリングは欠陥のコントラストが低く、少しずつ移動するような場合に有用です。サブサンプリングによってピクセルがより密接するため、変化がより短く急になります。適切なサンプリング値を決定する際、値 1 はサンプリングを実行しないことを示します。つまり、入力画像はフル解像度で使用されます。値を高くすると解像度と精度が低くなりますが、実行時間はより速くなります。

自動平滑化

画像を滑らかにする最適な平滑化係数を選択するかどうかを指定します。最適な平滑化係数を選択することによって、通常、パフォーマンスを向上させることができます。

注: [自動平滑化] パラメータはデフォルトでオフになっています。このパラメータをオンにするには、[サンプル係数] パラメータを 1 より大きい値に設定する必要があります。[サンプル係数] パラメータを 1 より大きい値に設定し、[自動平滑化] を使用しない場合は、パラメータをオフにし、代わりに [サンプル係数] パラメータを使用して適切な値を設定します。

0 = OFF (デフォルト) | [サンプル係数] パラメータを使用して手動の平滑化係数を適用するように指定します。
1 = ON | 最適な平滑化係数を決定するように指定します。

平滑化係数

画像を滑らかにする係数 (0 ～ 99999、デフォルト = 0) を指定します。最適な値を決定する際は、[サンプル係数] パラメータに指定した値に近い値から開始します。平滑化を指定しない場合、値を 0 に設定します。

注: [自動平滑数] パラメータがオンに設定されている場合、このパラメータは使用できません。

平滑化係数

画像に適用して欠陥の有無を判別する画像処理のタイプを指定します。

注: 画像処理のタイプに [明るい傷]、[暗い傷]、または [両方] を選択する場合、[検出サイズ] パラメータに検出する欠陥の最大サイズを設定する必要があります。

0 = 高速検出 (デフォルト) | このオプションは、縞やスクラッチなど、表面の「エッジ状」の明度変化に適しています。傷のエッジをハイライト表示する、収縮誇張処理を適用します。実行時間は一番短いですが、報告されるのは傷の面積ではなく、周囲長のみとなります。
1 = 明るい傷 | このオプションは、暗い背景にある「ブロブ状」の欠陥を、面積のピクセルサイズを基準にして検出するのに適しています。「トップハット」フィルタ処理を行い、[検出サイズ] パラメータで指定した値より小さい白い特徴以外をすべて取り除き、潜在的な傷を検出します。
2 = 暗い傷 | このオプションは、明るい背景にある「ブロブ状」の欠陥を、面積のピクセルサイズを基準にして検出するのに適しています。「ボトムハット」フィルタ処理を行い、[検出サイズ] パラメータで指定した値より小さい黒い特徴以外をすべて取り除き、潜在的な傷を検出します。
3 = 両方 | このオプションは、暗い、または明るい「ブロブ状」の欠陥を、面積のピクセルサイズを基準にして検出するのに適しています。「ボトムハット」および「トップハット」両方の処理を行い、両方の処理の最大結果を使用します。

検出サイズ

検出した近傍のサイズ (1 ～ 99999、デフォルト = 1) をピクセル単位で指定します。このパラメータは、[検出タイプ] パラメータで使用する処理近傍またはカーネルを構築するために使用します。

注: [高速検出] 以外の [検出タイプ] 操作では、サイズ値に、検出する欠陥の最大の長さまたは幅以上の値を設定する必要があります。

検出軸

欠陥候補を検出する軸を指定します。このパラメータはカーネルの高さも決定します。例えば、このパラメータを [X および Y] に設定し、[検出サイズ] を 1 に設定すると、カーネルは 3 × 3 グリッドになります。このパラメータを [X] に設定し、[検出サイズ] を 1 に設定すると、カーネルは 1 × 3 グリッドになります。

0 = X | X 軸に沿って欠陥を検出します。
1 = Y | Y 軸に沿って欠陥を検出します。
2 = X および Y (デフォルト) | X 軸と Y 軸の両方に沿って欠陥を検出します。

傷データの計算

検出された個々の欠陥の面積、明度、境界ボックスを計算するかどうかを指定します。

注:
  • このパラメータを無効にすると、関数の実行時間が短縮されます。このパラメータを無効にすると、内部のブロブ解析は実行されません。これにより、「欠陥」ピクセルの総面積のみが返されます。画像内の欠陥の位置を示すグラフィックス情報は返されません。この関数によって自動的に生成される結果テーブルは、個々の結果に #ERR を返します。データを抽出するには、すべての欠陥を合わせた総面積を返す GetTotalFlawArea データアクセス関数を使用します。

0 = OFF | 検出された個々の欠陥の面積、明度、境界ボックスを計算しないように指定します。
1 = ON (デフォルト) | 検出された個々の欠陥の面積、明度、境界ボックスを計算するように指定します。

傷形の計算

検出された個々の欠陥の周辺長および真円度を計算するかどうかを指定します。真円度は、欠陥がどのくらい円状であるかを単位のない数値で示します。完璧な真円は、値 1.0 です。伸長した欠陥は、1 より大きい値になります。数値が増えると伸長がさらに大きくなることを示します。点状の欠陥は 0 に近い値になります。

注: このパラメータを有効にするには、[傷データの計算] パラメータを ON にしておく必要があります。

0 = OFF | 個々の欠陥の周辺長および真円度を計算しないように指定します。
1 = ON (デフォルト) | 個々の欠陥の周辺長および真円度を計算するように指定します。

最小傷面積

検出する欠陥の最小サイズをピクセル単位で指定します (1 ～ 99999、デフォルト = 30)。

最大傷面積

検出する欠陥の最大サイズをピクセル単位で指定します (1 ～ 99999、デフォルト = 99999)。値 0 は最大サイズを指定しません。

最小コントラスト

欠陥の検出に使用する明度しきい値を指定します (1 ～ 255、デフォルト = 20)。傷を検出するには、明度は背景の値と異なる必要があります。

タイムアウト (ミリ秒)

この関数による欠陥のサーチ時間をミリ秒単位で指定します (0 ～ 30000、デフォルト = 0/タイムアウトなし)。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示画像

表示する出力画像を指定します。

注: この画像は表示のためにのみ使用されます。別の関数への入力として使用することはできません。

0 = 入力画像 | そのときに取り込まれている画像が表示されるように指定します。
1 = 歪みのない画像 | 角度またはカーブのある ROI が入力として使用された場合、変換され、歪みが取り除かれた画像が表示されるように指定します。
2 = サンプル画像 | 平滑化され、サンプリングされた画像が表示されるように指定します。角度またはカーブのある ROI が入力として使用された場合、平滑化およびサンプリング効果に加えて、変換されて、歪みが取り除かれた画像が表示されるように指定します。
3 = 傷候補 | 欠陥の候補が表示されるように指定します。傷候補は背景に対比してハイライトされ、赤色の境界ボックスで囲まれます。この表示オプションには、定義した欠陥 ([最小傷面積] および [最大傷面積]) の範囲外の欠陥も含まれます。
4 = 傷マスク画像 (デフォルト) | 欠陥が表示されるように指定します。欠陥は白色で描画され、そのほかの領域は黒色で描画されます。

表示行

表示画像が表示される行座標 (デフォルト = 0) を左上隅を基準に指定します。

注:このパラメータは次の条件下で有効になります。
  • [画像表示] パラメータは [サンプル画像]、[傷候補]、または [傷マスク画像] のいずれかに設定され、[サンプリング係数] パラメータは 1 より大きい値に設定されます。
  • [画像表示] パラメータは [歪みのない画像]、[サンプル画像]、[傷候補]、または [傷マスク画像] に設定され、[歪みのない画像] パラメータは有効にされ、[領域の 角度] パラメータまたは [曲線] パラメータの設定は 0 になりません。

表示列

表示画像が表示される列座標 (デフォルト = 0) を左上隅を基準に指定します。

注:このパラメータは次の条件下で有効になります。
  • [画像表示] パラメータは [サンプル画像]、[傷候補]、または [傷マスク画像] のいずれかに設定され、[サンプリング係数] パラメータは 1 より大きい値に設定されます。
  • [画像表示] パラメータは [歪みのない画像]、[サンプル画像]、[傷候補]、または [傷マスク画像] に設定され、[歪みのない画像] パラメータは有効にされ、[領域の 角度] パラメータまたは [曲線] パラメータの設定は 0 になりません。

表示

画像上にオーバレイする SurfaceFlaw グラフィックスの表示モードを指定します。

0 = 非表示 (デフォルト) | SurfaceFlaw 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 指定された [表示画像] が常に表示されます。
2 = 入力と結果のグラフィックス | 指定された [表示画像] と結果グラフィックス (検出された欠陥は赤色の矩形に囲まれて描画されます) が常に表示されます。 注: [外部定義領域] パラメータを [image] データ構造体の参照として設定すると、入力画像は表示されません。

SurfaceFlaw 関数の出力

戻り値 | 表示画像データと検出された欠陥を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが作成されます。 注: [傷データの計算] パラメータを無効にすると、すべての検出された欠陥の総面積のみを返します。すべての欠陥を合わせた総面積を返すには、GetTotalFlawArea データアクセス関数を使用します。

SurfaceFlaw 関数データアクセス関数

次のデータアクセス関数が、SurfaceFlaw データ構造体結果テーブルを作成するためにスプレッドシートに自動挿入されます。

スプレッドシート名 | 関数名 | 説明
傷総サイズ | GetTotalFlawArea(傷検査) | すべての欠陥の面積を足した総面積を返します。
インデックス | N/A | 面積内で最大から最小までソートされた、インデックス付き欠陥を返します。
行 | GetRow(傷検査, インデックス) | 欠陥を囲む境界ボックスの行座標をピクセル単位で返します。
列 | GetCol(傷検査, インデックス) | 欠陥を囲む境界ボックスの列座標をピクセル単位で返します。
高さ | GetHigh(傷検査, インデックス) | 欠陥を囲む境界ボックスの高さ値をピクセル単位で返します。
幅 | GetWide(傷検査, インデックス) | 欠陥を囲む境界ボックスの幅の値をピクセル単位で返します。
面積 | GetArea(傷検査, インデックス) | 欠陥の面積をピクセル単位で返します。
周囲長 | GetPerimeter(傷検査, インデックス) | 欠陥の周辺長をピクセル単位で返します。
明度 | GetAverageIntensity(傷検査, インデックス) | 欠陥の平均ピクセル明度の値を返します。
真円度 | GetRoundedness(傷検査, インデックス) | 欠陥の真円度をピクセル単位で返します。

関連項目

  • 傷検出ツールについて
  • TransSurfaceFlawToWorld 関数
  • プロパティシートの使用方法


DetectFlaw 関数

DetectFlaw 関数 |
ビジョンツール → 傷検出 | In-Sight 関数リファレンス

DetectFlaw 関数を使用し、TrainFlawModel 関数によって返された有効な [image] データ構造体、または FlexFlawModel 関数によって返された [image] データ構造体のいずれかに含まれる登録データと、そのときに取り込まれている画像を比較して、欠陥を識別します。DetectFlaw 関数は、面積欠陥、エッジの欠落、および余分なエッジの 3 タイプの傷を識別することができます。

領域の検査では、対象物や部品の表面上の傷や汚れなどの欠陥の有無が検証されます。エッジの検査では、余分なエッジ、またはエッジの欠落がないかどうか、また対象物や部品の境界が一定であるかどうかが確認されます。領域とエッジの欠陥検査を組み合わせることによって、最高レベルの検査を行うことができます。

ヒント:
  • 1 つまたは複数の DetectFlaw 関数で 1 つの TrainFlawModel 関数を参照できます。この結果、個々の DetectFlaw 関数は、必要に応じて設定を変え、対象物または部品のさまざまな部分を検査することができます。
  • [表示画像] パラメータが [エッジ画像]、[モデル画像]、[マスク画像] または [残余画像] のいずれかに設定されている場合、DetectFlaw の出力画像に対して、さらに画像処理を行うこともできます。例えば、ExtractBlobs 関数の [画像] パラメータを設定して、DetectFlaw 関数の残余画像を入力として使用することによって、追加でブロブ画像解析を行うことが可能です。
  • この関数の実行時間を短縮するには、関数の [画像の解像度] パラメータを [中程度] または [粗粒度] に設定します。この結果、画像がダウンサンプリングされ、画像のノイズやごく小さなばらつきに対する関数の感度が低くなります。
  • DetectFlaw の入力パラメータ
    • DetectFlaw 関数の [標準] タブ
    • DetectFlaw 関数の [マスク編集] タブ
    • DetectFlaw 関数の [欠陥リスト] タブ
  • DetectFlaw の出力
  • DetectFlaw Vision のデータアクセス関数
  • DetectFlaw 関数の関連項目

DetectFlaw 関数入力パラメータ

[全般] タブ

DetectFlaw 関数(

Flaw Model Reference,

検査領域.X,

検査領域.Y,

検査領域.高さ,

検査領域.幅,

検査領域.角度,

検査領域.カーブ,

外部検査領域/パス,

画像の解像度,

マスク画像制御.残余画像の追加,

マスク画像制御.Default Mask,

欠陥パラメータ.最小コントラスト,

欠陥パラメータ.正規化,

欠陥パラメータ.面積欠陥タイプ,

欠陥パラメータ.最小面積欠陥サイズ,

欠陥パラメータ.エッジ欠陥タイプ,

欠陥パラメータ.最小エッジ欠陥サイズ,

エッジマーキング描画,

傷マーキング描画,

表示画像,

表示

)

Flaw Model Reference

 TrainFlawModel 関数によって返された有効な [image] データ構造体、または FlexFlawModel 関数によって返された [image] データ構造体のいずれかを含んでいるスプレッドシートセルへの参照を指定します。

検査領域

これは対象領域 (ROI) とも呼ばれ、画像解析の対象となる画像の領域を指定します。変形および回転可能な矩形の画像領域を形成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

注:
  • [検査領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。
  • [検査領域] は、参照されている TrainFlawModel 関数で指定されているものと同じ入力フィクスチャへ自動的にフィクスチャされます。フィクスチャ参照が無効である場合、フィクスチャはデフォルトの 0,0,0 になります。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

外部検査領域/パス

オペレータ I/F 関数が入力されているスプレッドシートのセルへの参照を指定します。このパラメータを使用すると、TrainFlawModel ツールは、[領域] と [フィクスチャ] の設定を無視し、参照先領域に指定された画像領域を検査します。

注: このパラメータが外部領域またはパスの参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部領域またはパスを参照します。

画像の解像度

この関数で使用される画像処理解像度を指定します。それによって、この関数では検査画像をダウンサンプリングすることができます。このパラメータによって、傷検出に使用される解像度、および出力画像と画像上のマーキングの解像度も指定されます。

ヒント: [中程度] または [粗粒度] の設定を使用すると、関数の実行時間を短縮することができます。また、この設定では画像のノイズやごく小さなばらつきに対する関数の感度を下げることもできます。

注: FlexFlawModel 関数によって返された [image] データ構造体を [モデル参照] パラメータが参照している場合、このパラメータは無効化され、代わりに FlexFlawModel 関数の [画像の解像度] パラメータの設定が使用されます。

1 = 細粒度 (デフォルト) | フル解像度の画像が使用されるように指定します。
2 = 中程度 | ハーフ解像度の画像が使用されるように指定します。
3 = 粗粒度 | 1/4 の解像度の画像が使用されるように指定します。

マスク画像制御

マスク画像の処理方法を制御するための Button 関数または Event 関数への外部参照を指定します。この参照によって、実行時に特定の欠陥を無視するようにマスクを動的に調整することができます。

残余画像の追加 | 現在の残余画像をマスク画像に追加するための Button 関数または Event 関数への参照を指定します。
Default Mask | モデル画像からマスクデータを再生成することによって、マスク画像を最初に登録したときの状態に設定する Button 関数または Event 関数への参照を指定します。

欠陥パラメータ

面積欠陥またはエッジ欠陥、もしくはこの両方の判別で使用する制限値を指定します。面積欠陥は通常、汚れや変色などの欠陥で、ピクセルのグレースケール値の偏差で判断されます。エッジ欠陥は通常、傷や裂け目、余分な特徴などの欠陥で、エッジ特徴の有無に従って判断されます。

注: DetectFlaw 関数を適用したときに、欠陥パラメータの許容範囲が狭く (例えば、15 ピクセル以下)、画像のノイズに見られる変化が小さい場合、この変化については [欠陥を無視] および [残余画像の追加] オプションで考慮されないことがあります。このような状況では、[欠陥を無視] または [残余画像の追加] オプションを適用する前に、欠陥パラメータで使用される許容範囲の拡張を試みてください。

最小コントラスト

エッジ欠陥または面積欠陥とみなされるコントラストの最小変化値 (1 ～ 255、デフォルト = 25) を指定します。

正規化

領域から面積欠陥を検査する前に残余画像の明度レベルを正規化するかどうかを指定します。

0 = OFF (デフォルト) | 面積欠陥を検査する前にこの関数で明度レベルが正規化されないように指定します。
1 = ON | 面積欠陥を検査する前にこの関数で明度レベルが正規化されるように指定します。

面積欠陥タイプ

識別する面積欠陥のタイプを指定します。このオプションが有効である場合、残余画像から [最小コントラスト] および [最小面積欠陥サイズ] で指定された値を超えるピクセルのブロブがこの関数で識別されます。

0 = なし | 面積欠陥の検出を無効にします。
1 = 両方 (デフォルト) | 取り込まれた画像のピクセルのうち、登録モデルのピクセルよりも明るいもの、または暗いものが原因で発生している欠陥がこの関数で識別されます。
2 = 白い欠陥 | 取り込まれた画像のピクセルのうち、登録モデルのピクセルよりも明るいものが原因で発生している欠陥のみがこの関数で識別されます。
3 = 黒い欠陥 | 取り込まれた画像のピクセルのうち、登録モデルのピクセルよりも暗いものが原因で発生している欠陥のみがこの関数で識別されます。
最小面積欠陥サイズ

最小面積欠陥サイズをピクセル単位で指定します (2 ～ 400000、デフォルト = 30)。この値より小さい領域は欠陥とはみなされません。
エッジ欠陥タイプ

識別するエッジ欠陥のタイプを指定します。

0 = なし | この関数でエッジ欠陥は識別されません。
1 = 両方 | この関数で [欠落エッジ] と [余分エッジ] の両方の有無を検証します。
2 = 欠落エッジ (デフォルト) | モデルにあらかじめ登録されているエッジが、取り込まれた画像にすべて存在することをこの関数で検証します。[最小エッジ欠陥サイズ] で指定された値を超えるエッジの欠落は、欠陥として分類されます。
3 = 余分エッジ | 登録モデルに存在しないエッジが、取り込まれた画像にも存在しないことをこの関数で検証します。[最小エッジ欠陥サイズ] で指定された値を超える余分なエッジは、欠陥として分類されます。
最小エッジ欠陥サイズ エッジの欠落、または余分なエッジ、もしくはこの両方として分類するために、エッジの長さの最小値を指定します (2 ～ 1000、デフォルト = 5)。この設定より短いエッジが検出されても欠陥として分類されません。
エッジマーキング描画

検出されたエッジマークをこの関数で画像上に緑色で描画するかどうかを指定します。出力マーキングは、どのピクセルが、登録されているモデル画像内のピクセルと一致するかを示します。取り込まれた画像のピクセルのうち、登録されているモデル画像内の登録エッジ線分と一致するものは緑色で描画されます。許容値を外れ、エッジ欠陥または面積欠陥に分類されるピクセルは赤色で描画され、その周りは赤色の境界ボックスで囲まれます。

0 = OFF (デフォルト) | この関数で画像上にエッジマークを描画しないように指定します。
1 = ON | この関数で画像上にエッジマークを描画するように指定します。
傷マーキング描画

検出された欠陥マークをこの関数で画像上に赤色で描画するかどうかを指定します。出力マーキングは、どのピクセルが、登録されているモデル画像内のピクセルと一致するかを示します。取り込まれた画像のピクセルのうち、登録されているモデル画像内の登録エッジ線分と一致するものは緑色で描画されます。許容値を外れ、エッジ欠陥または面積欠陥に分類されるピクセルは赤色で描画され、その周りは赤色の境界ボックスで囲まれます。

0 = OFF (デフォルト) | この関数で画像上に欠陥マークを赤色で描画しないように指定します。
1 = ON | この関数で画像上に欠陥マークを赤色で描画するように指定します。
表示画像

この関数によって生成される出力のタイプを指定します。

0 = 実行時画像 (デフォルト) | この関数では、取り込んだ画像を出力画像として生成します。
1 = エッジ画像 | この関数では、取り込んだ画像からエッジモデルを出力画像として生成します。このオプションは、[エッジ欠陥タイプ] パラメータが [欠落エッジ]、[余分エッジ]、または [両方] に設定されている場合、もしくはこの関数が FlexFlawModel 関数によって返された [image] データ構造体を [モデル参照] パラメータで参照している場合にのみ使用できます。
2 = モデル画像 | この関数では、フィクスチャおよびスケール (必要に応じて、Flex アルゴリズム) に基づく変換の後、登録されるモデル画像を生成します。
3 = マスク画像 | この関数では、フィクスチャおよびスケール (必要に応じて、Flex アルゴリズム) に基づく変換の後、現在のマスク画像を生成します。
4 = 残余画像 | この関数では、欠陥検出分析に基づいて、残余画像を生成します。 注: 残余画像を出力画像として使用している場合は [面積欠陥] を有効にしておく必要があります。有効にしていないと、エッジ欠陥は描画されますが、出力画像は生成されず、エラーメッセージが表示されます。

表示

画像上の DetectFlaw グラフィックスオーバレイの表示モードを指定します。出力マーキングは、どのピクセルが、登録されているモデル画像内のピクセルと一致するかを示します。

注: DetectFlaw プロパティシートが開いているときに、[エッジマーキング描画] および [傷マーキング描画] パラメータが有効にされていると、画像上にはすべてのマーキングが描画されます。

0 = 非表示 (デフォルト) | DetectFlaw 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 有効にされているマーキング、欠陥、および入力領域は常に表示されます。
2 = すべて表示: 入力と結果のグラフィックス | 入力領域、検出された欠陥、および検出されたエッジは常に表示されます。 注: 検出された欠陥やエッジを表示するには、[エッジマーキング描画] および [傷マーキング描画] パラメータを有効にしておく必要があります。

[マスク編集] タブ

マスク画像の編集コントロール

[マスク画像の編集] コントロールは、参照している [image] データ構造体に保存されたマスク画像を操作する手段として使用します。[マスクの編集] タブが選択されているとき、この画像は表示されますが、[エッジ欠陥タイプ] パラメータが有効である場合はマスクされたエッジがマーキングされ、[面積欠陥タイプ] パラメータが有効である場合はマスク画像が表示されます。

注:
  • マスク画像を調整すると、このマスク画像を含む同一の TrainFlawModel 関数を参照しているそのほかの DetectFlaw 関数もすべて調整の影響を受けます。
  • DetectFlaw 関数を適用したときに、欠陥パラメータの許容範囲が狭く (例えば、15 ピクセル以下)、画像のノイズに見られる変化が小さい場合、この変化については [欠陥を無視] および [残余画像の追加] オプションで考慮されないことがあります。このような状況では、[欠陥を無視] または [残余画像の追加] オプションを適用する前に、欠陥パラメータで使用される許容範囲の拡張を試みてください。

Add Residual Image | 残余画像と残余エッジをマスクに追加するように指定します。この設定は、画像で識別された欠陥を、欠陥ではないものに変更する効果があります。
Expand Mask | マスク内のピクセル領域を拡張することを指定します。 注: このオプションを使用するには、[面積欠陥タイプ] を有効にする必要があります。
Shrink Mask | マスク内のピクセル領域を縮小することを指定します。 注: このオプションを使用するには、[面積欠陥タイプ] を有効にする必要があります。
Remove Mask | すべてのマスクデータを削除することを指定します。
Default Mask | モデル画像からマスクデータを再生成することによって、マスク画像を最初に登録したときの状態にリセットすることを指定します。

[欠陥リスト] タブ

[欠陥リスト] テーブル

[欠陥リスト] は検出された欠陥の一覧表で、内容をソートすることができます。このリストから欠陥を選択すると、画像内でその欠陥がハイライトされます。また、[欠陥を無視] ボタンも有効になります。一度に複数の欠陥を選択するには、Ctrl または Shift キーを押しながらリストから欠陥を選択します。

注: DetectFlaw 関数を適用したときに、欠陥パラメータの許容範囲が狭く (例えば、15 ピクセル以下)、画像のノイズに見られる変化が小さい場合、この変化については [欠陥を無視] および [残余画像の追加] オプションで考慮されないことがあります。このような状況では、[欠陥を無視] または [残余画像の追加] オプションを適用する前に、欠陥パラメータで使用される許容範囲の拡張を試みてください。

Number | 検出された欠陥の順序を 1 から N までの数字で指定します。
Type | 傷のタイプ (余分なエッジ、エッジの欠落、または面積) を指定します。
Size | 欠陥のサイズをピクセル単位で指定します。
Contrast | 欠陥のコントラストを指定します。
Row | 欠陥を囲む境界ボックスの行座標を指定します。
Column | 欠陥を囲む境界ボックスの列座標を指定します。
Height | 欠陥を囲む境界ボックスの高さを指定します。
Width | 欠陥を囲む境界ボックスの幅を指定します。
Ignore Defect Button | 選択された欠陥をマスク画像に追加し、今後欠陥として報告されずにリストから削除することを指定します。このボタンを有効にするには、欠陥を選択する必要があります。

DetectFlaw 関数の出力

戻り値 | 検出された欠陥を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。 注: そのほかのビジョンツールについては、 [image] データ構造体を画像入力として使用することができます。
結果 | DetectFlaw 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが作成されます。

DetectFlaw 関数データアクセス関数

DetectFlaw データ構造体結果テーブルを作成するために、次のデータアクセス関数がスプレッドシートに自動挿入されます。

スプレッドシート名 | 関数名 | 説明
要約
総数 | GetTotalFlawCount(DetectFlaw, Type) | 欠陥のタイプに関係なく、検出された欠陥の総数を返します。
傷総サイズ | GetTotalFlawSize(DetectFlaw, Type) | 欠陥として分類されたピクセルの総数を返します。
数
面積 | GetTotalFlawCount(DetectFlaw, Type) | 検出された面積欠陥の総数を返します。
欠落エッジ | GetTotalFlawCount(DetectFlaw, Type) | 検出されたエッジの欠落の総数を返します。
余分エッジ | GetTotalFlawCount(DetectFlaw, Type) | 検出された余分なエッジの総数を返します。
傷サイズ
面積 | GetTotalFlawSize(DetectFlaw, Type) | 面積欠陥として分類されたピクセルの総数を返します。
欠落エッジ | GetTotalFlawSize(DetectFlaw, Type) | エッジの欠落として分類されたピクセルの総数を返します。
余分エッジ | GetTotalFlawSize(DetectFlaw, Type) | 余分なエッジピクセルとして分類されたピクセルの総数を返します。
傷タイプ 注: 欠陥のタイプ (面積、エッジの欠落、および余分なエッジ) それぞれについて、検出された最初の 5 個の欠陥が表示されます。
サイズ | GetFlawSize(DetectFlaw, Type, Index) | 欠陥のサイズをピクセル単位で返します。
コントラスト | GetFlawContrast(DetectFlaw, Type, Index) | 欠陥のコントラストを返します。
行 | GetFlawRow(DetectFlaw, Type, Index) | 傷を囲む境界ボックスの行座標を返します。
列 | GetFlawCol(DetectFlaw, Type, Index) | 欠陥を囲む境界ボックスの列座標を返します。
高さ | GetFlawHigh(DetectFlaw, Type, Index) | 欠陥を囲む境界ボックスの高さを返します。
幅 | GetFlawWide(DetectFlaw, Type, Index) | 欠陥を囲む境界ボックスの幅を返します。

関連項目

  • 傷検出ツールについて
  • TrainFlawModel 関数
  • FlexFlawModel 関数
  • 欠陥を検出するためのデータアクセス関数
  • プロパティシートの使用方法


FlexFlawModel 関数

FlexFlawModel 関数 |
ビジョンツール → 傷検出 | In-Sight 関数リファレンス

FlexFlawModel 関数は、オプションの Flex アルゴリズムの構築に使用されます。この関数によって、TrainFlawModel 関数で許容されるプロセスばらつきが補正され、DetectFlaw 関数でより正確に欠陥を分類することができます。FlexFlawModel 関数は、登録されているエッジモデルと現在取り込まれている画像のエッジモデルを比較することによって、TrainFlawModel 関数または Mask 関数の領域内における変位を測定します。

  • FlexFlawModel 関数の概要
  • FlexFlawModel の入力パラメータ
  • FlexFlawModel の出力
  • FlexFlawModel 関数の関連項目

FlexFlawModel 関数概要

FlexFlawModel 関数は、参照されている TrainFlawModel 関数によって指定された ROI 内で動作します。検査中、この関数は、参照されている TrainFlawModel 関数のフィクスチャおよびスケール値に基づいて、登録されているエッジモデルを部品の現在位置および方向に対して変換、回転、およびスケール変更します。その後、FlexFlawModel 関数は ROI 内から、指定された [画像の解像度] 値にあるエッジを抽出します。これらの抽出されたエッジは、登録されているエッジモデルと比較されます。次に、最初の一致得点が計算されますが、この最初の得点が小さすぎる場合は、#ERR が返されます。一致得点が十分に大きな値である場合、この関数では、[フレックスレシピ] の値に基づいて Flex アルゴリズムが実行されます。その後、最終的な Flex 得点が計算されます。

[フレックスパラメータ] を調整して Flex アルゴリズムを構築することによって、モデルを「引き伸ばし」、何もしなければ欠陥として分類される可能性のある許容範囲内のばらつきを補正することができます。この引き伸ばしによって、現在取り込まれている画像の部品にいっそう近い外観のモデルにすることも可能です。DetectFlaw 関数を実行する前に Flex を適用してこの部品に合わせて調整し、誤った不合格を減らすこともできます。

Flex アルゴリズムで補正できるものは次のとおりです。

  • 画像から画像へのわずかな動きのような位置エラー。
  • レンズまたは遠近歪み。
  • 形状や表面値のわずかな差異のような許容範囲内の部品のばらつき。
  • ラインスキャン画像に関連するようなピクセルの伸長。
  • 画像内での部品のスケール変化。

FlexFlawModel 関数の入力パラメータ

FlexFlawModel 関数(

登録傷モデル,

画像の解像度,

最小エッジ強度,

最小マッチ得点,

フレックスパラメータ.フレックスレシピ,

フレックスパラメータ.フレックスグリッドのサイズ,

フレックスパラメータ.包囲セグメントフレックスの許容,

フレックスパラメータ.包囲セグメントフレックス,

フレックスパラメータ.ラインセグメントフレックスの許容,

フレックスパラメータ.ラインセグメントフレックス,

フレックスパラメータ.ラインセグメント最大ラインサイズ,

フレックスパラメータ.ピクセルフレックスの許容,

フレックスパラメータ.ピクセルフレックス,

描画オプション,

表示画像,

表示

)

登録傷モデル

 TrainFlawModel 関数によって返された有効な [image] データ構造体を含むスプレッドシートセルへの参照を指定します。

画像の解像度

この関数で使用される画像処理解像度を指定します。それによって、この関数では検査画像をダウンサンプリングすることができます。このパラメータによって、傷検出に使用される解像度、および出力画像と画像上のマーキングの解像度も指定されます。

ヒント: [中程度] または [粗粒度] の設定を使用すると、関数の実行時間を短縮することができます。また、この設定では画像のノイズやごく小さなばらつきに対する関数の感度を下げることもできます。

1 = 細粒度 (デフォルト) | フル解像度の画像が使用されるように指定します。
2 = 中程度 | ハーフ解像度の画像が使用されるように指定します。
3 = 粗粒度 | 1/4 の解像度の画像が使用されるように指定します。

最小エッジ強度

画像からエッジ特徴を抽出するために必要なグレースケール明度の最小変化値 (5 ～ 255、デフォルト = 20) を指定します。

最小マッチ得点

[フレックスパラメータ] の使用を開始するために、一致得点の初期値の最小値 (10 ～ 100、デフォルト = 30) を指定します。一致得点の初期値がこの値より小さい場合、[フレックスパラメータ] は処理されず、関数の結果は #ERR になります。

フレックスパラメータ

Flex タイプに対する制限値と、許容できる Flex の大きさを指定します。

フレックスレシピ

事前に設定されている読み取り専用の設定値セットを指定します。これはさまざまなアプリケーションについて推奨される値のセットです。

0 = デフォルト

フレックスグリッドのサイズ = 8x8、包囲セグメントフレックスの許容 = Off、包囲セグメントフレックス = 20、ラインセグメントフレックスの許容 = On、ラインセグメントフレックス = 10、ラインセグメント最大ラインサイズ = 15、ピクセルフレックスの許容 = On、ピクセルフレックス = 1。

1 = 高フレックス

フレックスグリッドのサイズ = 4x4、包囲セグメントフレックスの許容 = On、包囲セグメントフレックス = 40、ラインセグメントフレックスの許容 = On、ラインセグメントフレックス = 20、ラインセグメント最大ラインサイズ = 8、ピクセルフレックスの許容 = On、ピクセルフレックス = 10。

ヒント: [高フレックス] は、大きな非線形歪みが見られるアプリケーションに最も適しています。

2 = 印刷拡張

フレックスグリッドのサイズ = 4x4、包囲セグメントフレックスの許容 = On、包囲セグメントフレックス = 30、ラインセグメントフレックスの許容 = On、ラインセグメントフレックス = 1、ラインセグメント最大ラインサイズ = 40、ピクセルフレックスの許容 = On、ピクセルフレックス = 1。

ヒント: [印刷拡張] は印刷された文字の品質を検証するアプリケーションに最も適しており、この関数は文字の拡張を調整する必要があります。
3 = 部分欠落

フレックスグリッドのサイズ = 8x8、包囲セグメントフレックスの許容 = On、包囲セグメントフレックス = 5、ラインセグメントフレックスの許容 = On、ラインセグメントフレックス = 5、ラインセグメント最大ラインサイズ = 10、ピクセルフレックスの許容 = On、ピクセルフレックス = 1。

ヒント: [部分欠落] は、エッジの境界線に基づくアプリケーションに最適であり、その欠陥サイズは非常に小さいものとなっています。
4 = 微細特徴

フレックスグリッドのサイズ = 2x2、包囲セグメントフレックスの許容 = On、包囲セグメントフレックス = 10、ラインセグメントフレックスの許容 = On、ラインセグメントフレックス = 3、ラインセグメント最大ラインサイズ = 15、ピクセルフレックスの許容 = On、ピクセルフレックス = 1。

ヒント: [微細特徴] は、大きな非線形歪みがあるアプリケーションで、小さな欠陥を検出する場合に最も適しています。このオプションを指定すると、処理に長時間かかります。
98 = カスタム

[フレックスパラメータ] に手動でさまざまな値を入力して、[フレックスレシピ] 設定をカスタマイズすることができます。直前に選択したレシピのデフォルト値が初期値として表示されます。

注: [フレックスレシピ] の選択肢を制御するためのセル参照が作成されているときに、この関数のプロパティシートを開き、[フレックスレシピ] パラメータへの変更を行った場合、このセル参照のコマンドが関数によって上書きされます。
99 = フレックスなし

フレックスグリッドのサイズ = 2x2、包囲セグメントフレックスの許容 = Off、包囲セグメントフレックス = 1、ラインセグメントフレックスの許容 = Off、ラインセグメントフレックス = 1、ラインセグメント最大ラインサイズ = 3、ピクセルフレックスの許容 = Off、ピクセルフレックス = 1。

注: [フレックスなし] 設定は、この関数が、Flex の計算に必要最小限の設定を使用することを指示します。どのような場合でも [フレックスなし] を適用するには、FlexFlawModel 関数自体を無効にする必要があります。

フレックスグリッドのサイズ

Flex に対する訂正が使用されるときに、モデル画像およびマスク画像に適用される粒度設定を指定します。粒度が高いほど、より正確に非線形歪みを処理できるようになりますが、消費されるメモリの量も増加します。

1 = 2×2 | 粒度設定の最高値を指定します。
2 = 4×4 | 粒度設定の 2 番目に高い値を指定します。
3 = 8×8 (デフォルト) | 粒度設定の 3 番目に高い値を指定します。
4 = 16×16 | 粒度設定の最も低い値を指定します。

包囲セグメントフレックスの許容

この関数で、囲まれたセグメントの変位を許容するかどうかを指定します。

1 = ON | 囲まれたセグメントの変位を許容します。
0 = OFF (デフォルト) | 囲まれたセグメントの変位を許容しません。
包囲セグメントフレックス | 囲まれたセグメントの中心から許容される変位の最大値 (1 ～ 40、デフォルト = 20) を指定します。
ラインセグメントフレックスの許容

エッジの一部分の変位を許容するかどうかを指定します。

1 = ON (デフォルト) | エッジの一部分の変位を許容します。
0 = OFF | エッジの一部分の変位を許容しません。
ラインセグメントフレックス | エッジセグメントに対して許容される線分変位の最大量 (1 ～ 20、デフォルト = 10) を指定します。
ラインセグメント最大ラインサイズ | エッジを分割する場合に、分割されたエッジの最大長 (3 ～ 500、デフォルト = 15) を指定します。
ピクセルフレックスの許容

個々のエッジピクセルについて、Flex を計算するかどうかを指定します。

1 = ON (デフォルト) | 個々のエッジピクセルについて Flex を計算します。
0 = OFF | 個々のエッジピクセルについて Flex を計算しません。
ピクセルフレックス | ピクセルに適用される変位の最大量 (1 ～ 10、デフォルト = 1) を指定します。

描画オプション

この関数が画像上に描画する結果を指定します。

0 = エッジマーキング (デフォルト) | この関数で、現在のエッジモデルと、Flex アルゴリズムの適用後のエッジモデルとの間にエッジの照合結果を描画するように指定します。
1 = エッジ移動距離 | 現在取り込まれている画像との照合のために、Flex アルゴリズムによってモデル画像がどのように修正されたかを示す結果を描画するように指定します。
2 = グリッド移動距離 | 現在取り込まれている画像との照合の際、Flex アルゴリズムを使用して、グリッドのセクション内のピクセルを修正する量と方向を示すために、まず、画像を内部的にグリッドに分割することを指定します。
3 = なし | 描画を行わないように指定します。

表示画像

この関数によって生成される出力画像のタイプを指定します。

0 = 実行時画像 (デフォルト) | 現在取り込まれている画像を表示するように指定します。
1 = エッジ画像 | 現在取り込まれている画像から生成されたエッジモデルを表示するように指定します。

表示

画像上の FlexFlawModel グラフィックスオーバレイの表示モードを指定します。登録モデルのピクセルと一致するピクセルは緑色で表示されます。一致しないピクセルは黄色になります。マスク画像から欠落しているピクセルは青色、マスク画像内の余分なピクセルは濃いマゼンタ色で表示されます。また、余分なエッジの欠陥はマゼンタ色、欠落しているエッジや面積欠陥ピクセルは赤色で表示されます。

0 = 非表示 (デフォルト) | FlexFlawModel 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスは表示されません。
1 = 結果のグラフィックスのみ | [描画オプション] および [表示画像] で指定された選択内容、および参照されている TrainFlawModel の検査領域は常に表示されます。
2 = すべて表示: 入力と結果のグラフィックス | 入力領域、[描画オプション] および [表示画像] で指定された選択内容、および参照されている TrainFlawModel の検査領域は常に表示されます。

FlexFlawModel 関数の出力

戻り値 | Flex アルゴリズムによって修正されたモデルデータを含む [image] データ構造体。入力パラメータが無効である場合は、#ERR が返されます。
結果 | 最初に FlexFlawModel 関数がデータ構造体の右側にあるセルに挿入されている場合、2 つのセルに、データアクセス関数である GetMatchScore 関数および GetFlexScore 関数が自動的に入力されます。GetMatchScore 関数は Flex アルゴリズムを適用する前のエッジ一致得点を示す値を、また、GetFlexScore 関数は Flex アルゴリズム適用後のエッジ得点を示す値を返します。

関連項目

  • 傷検出ツールについて
  • TrainFlawModel 関数
  • DetectFlaw 関数
  • 欠陥を検出するためのデータアクセス関数
  • プロパティシートの使用方法


TrainFlawModel 関数

TrainFlawModel 関数 |
ビジョンツール → 傷検出 | In-Sight 関数リファレンス

TrainFlawModel 関数は、取り込まれた画像との比較対象となる「ゴールデン」、つまり完全な部品/対象物のモデルを作成するために使用します。この関数は検査の対象を定義します。[領域]、または [外部定義領域またはパス] パラメータで設定される対象領域は、登録される画像の領域とともに、これを参照する DetectFlaw および FlexFlawModel 関数が検索を実行する場所を定義します。

画像取り込みごとに、そのときのフィクスチャの値に基づいて ROI が調整されます。ROI の座標および更新後の [スケール] の値は、この関数を参照しているすべての DetectFlaw または FlexFlawModel 関数に渡されます。TrainFlawModel はこのモデルを保持します。

注: TrainFlawModel 関数は、TrainFlawModel 関数を参照している DetectFlaw および FlexFlawModel 関数に更新後の領域、フィクスチャ、およびスケールデータを渡します。したがって、TrainFlawModel 関数を無効にする場合は、これを参照している関数をすべて無効にした後である必要があります。そうしないと、TrainFlawModel 関数を参照している関数では、無効化前の TrainFlawModel 関数の状態に基づいてデータが処理されます。

  • TrainFlawModel の入力パラメータ
  • TrainFlawModel の出力
  • TrainFlawModel データアクセス関数
  • 関連項目

TrainFlawModel 関数の入力パラメータ

TrainFlawModel 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

外部領域またはパス,

スケール,

エッジマスクサイズ,

最小エッジ強度,

最小エッジ長,

強制登録,

表示解像度,

エッジマーキング描画,

表示画像,

タイムアウト,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

注:
  • TrainFlawModel 関数は、キャリブレーションされた結果をサポートしていません。この関数は、ピクセル座標でのみ動作します。
  • TrainFlawModel 関数では、グレースケール画像とカラー画像の両方がサポートされています。カラー画像を参照する場合、赤、緑、および青 (RGB) の 3 つのカラープレーンのいずれかの欠陥が識別されます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

Row (デフォルト = 0) | 画像座標での行オフセット。
Column (デフォルト = 0) | 画像座標での列オフセット
Theta (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

注:別のビジョンツール関数またはオペレータ I/F 関数の出力に対する ROI を定義する場合は、セル参照を領域座標に設定する代わりに、[外部定義領域またはパス]　パラメータを使用します。[外部定義領域またはパス] パラメータはフィクスチャの動きを正しく考慮しますが、セル参照は正しく機能しない可能性があり、フィクスチャの動きを参照する関数は #ERR を返すことがあります。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域またはパス

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:
  • モデルの定義に外部定義領域またはパスを使用しているときに、この外部定義領域またはパスを変更する場合は、モデルの再登録を開始するために、[強制登録] パラメータを有効にする必要があります。外部定義領域またはパスが参照されているときに、プロパティシートを開いて閉じても再登録は開始されません。
  • このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

スケール

実行時に想定されるモデル部品/対象物のスケーリング後のサイズを登録モデルに対する割合 (%) で指定します (80 ～ 120、デフォルト = 100)。

注: 例えば、[フィクスチャ] 値の入力に FindPatMaxPatterns 関数を使用している場合、TrainFlawModel 関数の [スケール] パラメータが、FindPatMaxPatterns 関数によって出力される [スケール] 値へのセル参照として設定されることがあります。

エッジマスクサイズ

エッジのどのくらい近くまでマスク画像に構築されるか、その許容値を指定します (0 ～ 5、デフォルト = 0)。

最小エッジ強度

エッジ全体について、モデルに取り込まれる輝度の最小変化値を指定します (10 ～ 255、デフォルト = 30)。

最小エッジ長

モデルに取り込まれる最短のエッジの長さを指定します (10 ～ 1000、デフォルト = 20)。これより短いエッジは、モデルから除外されます。この値は、エッジに接続されるエッジピクセル数の最小値を表します。このパラメータの設定値を大きくすると、検出されるエッジの数が少なくなりますが、小さくすると検出されるエッジの数が増えます。この設定は、通常短いエッジとして現れるノイズエッジピクセルの除去に有効です。

強制登録

スプレッドシートが更新されたときに、モデルを自動的に再登録するかどうかを指定します。

[強制登録] パラメータに関係なく、この関数のプロパティシートを開いて次のパラメータの変更を行い、[OK] ボタンを押して確認すると、モデルは再登録されます。

  • [画像] パラメータの変更
  • [フィクスチャ] パラメータの変更
  • [領域] パラメータの変更
  • [外部定義領域またはパス] パラメータの変更
  • [スケール] パラメータの変更
  • [エッジマスクサイズ] パラメータの変更
  • [最小エッジ強度] パラメータの変更
  • [最小エッジ長] パラメータの変更

ランタイム操作中、次のいずれの操作が行われた場合、モデルは再登録されます。

  • [画像] パラメータの変更
  • [領域] パラメータの変更
  • [外部定義領域またはパス] パラメータの変更
  • [最小エッジ強度] パラメータの変更
  • [最小エッジ長] パラメータの変更
0 = OFF (デフォルト) | プロパティシートを開いて前述のパラメータの 1 つを変更し、プロパティシートの [OK] ボタンを押してその変更を確認した場合のみ、再登録が行われます。 注: パラメータがスプレッドシートに入力されている場合、TrainFlawModel 関数のプロパティシートを開かずにこれらのパラメータを変更すると、モデルの再登録は行われません。モデルの再登録を行うには、プロパティシートを開くか、または [強制登録] パラメータをオンに設定する必要があります。
1 = ON | スプレッドシートが実行されるたびに、新しいモデルが登録されます。
表示解像度

モデル画像とエッジモデルの表示に使用する解像度を指定します。[中程度] または [粗粒度] を指定すると、画像はダウンサンプリングされ、細部やノイズは除去されます。

0 = 細粒度 (デフォルト) | フル解像度でモデルが登録されるように指定します。
1 = 中程度 | ハーフ解像度でモデルが登録されるように指定します。
2 = 粗粒度 | 1/4 の解像度でモデルが登録されるように指定します。
エッジマーキング描画

モデルのエッジを画像上に描画するかどうかを指定します。登録されているエッジは緑色で、マスクされたエッジは青色で描画されます。

0 = ON (デフォルト) | 画像上にエッジマークを描画します。
1 = OFF | 画像上にエッジマークを描画しません。
表示画像

表示する出力画像を指定します。

注: この画像は表示のためにのみ使用されます。別の関数への入力として使用することはできません。

0 = 実行時画像 | そのときに取り込まれている画像が表示されるように指定します。
1 = エッジ画像 | 画像内の登録されているエッジが表示されるように指定します。
2 = モデル画像 (デフォルト) | 登録されているモデルが表示されるように指定します。
3 = マスク画像 | そのときに登録されているマスク画像が表示されるように指定します。
タイムアウト (ミリ秒) この関数が有効なモデルを検索する時間をミリ秒単位で指定します (0 ～ 30000、デフォルト = 5000)。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示

画像上の TrainFlawModel グラフィックスオーバレイの表示モードを指定します。登録モデルのピクセルと一致するピクセルは緑色で表示されます。一致しないピクセルは黄色になります。マスク画像から欠落しているピクセルは青色、マスク画像内の余分なピクセルは濃いマゼンタ色で表示されます。また、余分なエッジの欠陥はマゼンタ色、欠落しているエッジや面積欠陥ピクセルは赤色で表示されます。

0 = 非表示 (デフォルト) | TrainFlawModel 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 指定された表示画像が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域、モデル画像、およびマスク画像が常に表示されます。

TrainFlawModel 関数の出力

戻り値 | 各解像度で表されたモデル画像、エッジモデル画像、およびマスク画像が入った [image] データ構造体。入力パラメータのいずれかが無効である場合は #ERR が返されます。
結果 | TrainFlawModel 関数が初めてセルに挿入されると、登録状態が右隣のセルに自動的に表示されます。モデルを登録できない場合は #ERR が挿入されます。

TrainFlawModel 関数データアクセス関数

1 つのデータアクセス関数がスプレッドシートに自動挿入されます。

登録 GetTrained(傷モデルの登録) モデルを登録できた場合には 1、登録できなかった場合には 0 を返します。

関連項目

  • 傷検出ツールについて
  • DetectFlaw 関数
  • FlexFlawModel 関数
  • プロパティシートの使用方法


ヒストグラム

ビジョンツール

In-Sight 関数リファレンス

マシンビジョンの用語では、ヒストグラムとは、対象領域 (ROI) 内のピクセル、その数、個々のグレースケール値の配列を指します。In-Sight のヒストグラムツールは、統計的解析と特徴分類を目的とした、ピクセルのカウントに使用されます。

In-Sight ビジョンシステムでは、ヒストグラムツールの次の関数を使用して、ヒストグラム解析を実行します。

  • ExtractColorHistogram 関数: ROI からカラーヒストグラム配列を抽出します。
  • ExtractHistogram 関数: ROI からグレースケールヒストグラム配列を抽出します。
  • HistContrast 関数: ROI 内のコントラストを計算します。
  • HistCount 関数: グレースケール値の範囲内に存在するピクセルの数をカウントします。
  • HistHead 関数: 範囲内の最小のグレースケール値を検出します。
  • HistHeadPercentage 関数: ヒストグラムの指定された範囲内に含まれるピクセルのうち、指定された割合（%）よりも大きなグレースケール値を返します。
  • HistMax 関数: 範囲内の最も一般的なグレースケール値を検出します。
  • HistMean 関数: グレースケールの平均値を計算します。
  • HistMin 関数: 範囲内の最も発生頻度の低いグレースケール値を検出します。
  • HistSDev 関数: グレースケールの標準偏差を計算します。
  • HistSum 関数: ピクセルグレースケールの合計を計算します。
  • HistSumSquare 関数: 二乗したピクセルグレースケールの合計を計算します。
  • HistTail 関数: 範囲内の最大のグレースケール値を検出します。
  • HistTailPercentage 関数: ヒストグラムの指定された範囲内に含まれるピクセルのうち、指定された割合（%）よりも小さなグレースケール値を返します。
  • HistThresh 関数: 最適 2 値化しきい値を計算します。

ツールヒストグラムについて

ヒストグラムの概要

In-Sight ヒストグラムツールは、ROI を調べ、その中の個々のピクセルをグレースケール値に従って分類し、ピクセルのグレースケール値に従って「階層」に配置して、ヒストグラム解析を実行します。8 ビットグレースケール画像では、グレースケール値 (0 ～ 255) に基づき 256 の階層があります。各階層には、それに属するピクセル個数が含まれ、階層がそのカウントのインデックスとなります。例えば、画像がグレースケール値が 33 である 46 ピクセルを含んでいた場合、その領域のヒストグラムの 33 番目の階層には値 46 が含まれています。また、ヒストグラム配列内の階層の合計は、その抽出元の領域と常に同じです。

次の画像は、ExtractHistogram 関数によるヒストグラムチャートの例です。ヒストグラムチャートは、関数の ROI 内のピクセルのグレースケール値を表示します。

  • グラフの X 軸は、グレースケール値 (0 ～ 255) を表します。
  • グラフの Y 軸は、特定のグレースケール値のピクセル合計数を表します。Y 軸の目盛は、ピクセル合計数が最大であるグレースケール値を表示することによって構築されます。
  • 緑色の垂直線はしきい値を示します。

ヒストグラムツールを使用する場合

ヒストグラムは、すべての位置データを除き、画像に含まれるピクセルデータを簡潔に表すために重要です。関数は ROI 内のピクセル数と個々のグレースケール (またはカラー) 値に関する情報のみを返します。つまり、このヒストグラム配列から位置に依存しないすべてのグレースケール画像統計を直接計算することができます。

ヒストグラムツールは、特徴の有無の検出、照明値のチェックや、傷、ほこり、破片などがないかどうか判断するためのグレースケール値の非均一性の特定などの問題について画像を調べる際に有効です。

ヒストグラムツールの使用方法

ヒストグラムツールは通常、次の方法で使用されます (明るさの最大、最小値を用いることで良否を判別する場合)。

  • 手順 1 - 処理する画像がグレースケールの場合、ExtractHistogram 関数をスプレッドシートに挿入し、ヒストグラム解析を実施する画像領域を定義するためにパラメータを設定します。画像がカラー画像の場合は、ExtractColorHistogram 関数を使用します。
  • 手順 2 - 次に、HistHead 関数と HistTail 関数を使用してそれぞれ最初と最後の 0 以外の階層を検出します。HistHead 関数と HistTail 関数の出力を使用して、他のヒストグラム関数が解析を実行する範囲を設定し、ピクセルを含まない階層を削除します。
  • 手順 3 - 最後に、HistMin 関数と HistMax 関数を使用して、それぞれ最初と最後の 0 以外の階層間の最小と最大を判断します。他のヒストグラムツールを使用して追加の解析を実行することもできます (範囲を定義する HistHead 関数と HistTail 関数の出力を使用)。

注: HistMin 関数の FirstBin パラメータ引数にデフォルトの 0 が指定されている場合、HistHead 関数の出力に関係なく、HistMin 関数はピクセルを含まない最初の階層である、階層 0 を常に返します。


ExtractColorHistogram 関数

ExtractColorHistogram 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

画像領域からカラーヒストグラム配列を抽出します。

  • ExtractColorHistogram 関数の概要
  • ExtractColorHistogram の入力パラメータ
  • ExtractColorHistogram の出力
  • ExtractColorHistogram 関数のデータアクセス関数
  • 関連項目

ExtractColorHistogram 関数概要

ExtractColorHistogram 関数は、画像領域内のすべてのピクセルにアクセスしてカラーヒストグラムを累積します。各カラーピクセルは、3 つの個別の色成分によって構成されています。これらの成分は、赤、緑、および青の組み合わせ (RGB) と、色相、彩度、および明度の組み合わせ (HSI) の両方またはどちらかとして表されます。RGB も HSI も、ピクセルの各成分は 0 ～ 255 の値に変換されます。したがって、累積されるヒストグラムには各色成分について 256 の要素が含まれており、各要素には、配列要素のインデックス番号と等しい値を持つピクセルの総数を示す値が含まれています。

注: ExtractColorHistogram 関数で返された HSI 値は、MatchColor 関数と TrainMatchColor 関数で返される HSI 値と異なることがあります。MatchColor 関数と TrainMatchColor 関数は、HSI の処理の前にピクセルの平均値を出し、ExtractColorHistogram 関数は HSI の処理の後にピクセルの平均値を出します。画像で検出される色のランダム性に応じて相違が大きくなります。

ExtractColorHistogram 関数の入力パラメータ

ExtractColorHistogram 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

カラーモード,

表示

)

画像

この引数は有効な カラー [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注: 有効なカラー [image] データ構造体を返す関数は、AcquireImage 関数だけです。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:

  • ピクセルがヒストグラムに計算されるようにするには、ピクセルが画像領域の範囲内に完全に含まれている必要があります。部分的に含まれているピクセルは計算されません。
  • [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

カラーモード

ヒストグラム内で計算して表示するカラー表現タイプを指定します。

注: ExtractColorHistogram 関数で返された HSI 値は、MatchColor 関数と TrainMatchColor 関数で返される HSI 値と異なることがあります。MatchColor 関数と TrainMatchColor 関数は、HSI の処理の前にピクセルの平均値を出し、ExtractColorHistogram 関数は HSI の処理の後にピクセルの平均値を出します。画像で検出される色のランダム性に応じて相違が大きくなります。
0 = RGB (デフォルト) | すべての入力ピクセルの赤、緑、および青 (RGB) 成分を計算します。ヒストグラム内では、赤成分は赤色の線で、緑成分は緑色の線で、青成分は青色の線で表示されます。
1 = RGB+HSI | すべての入力ピクセルの赤、緑、および青 (RGB) 成分と、色相、彩度、および明度 (HSI) 成分を計算します。ヒストグラムは HSI のみを表示し、色相成分は赤色の線で、彩度成分は緑色の線で、明度成分は青色の線で示します。
2 = HSI | すべての入力ピクセルの色相、彩度、および明度 (HSI) 成分を、最適な HSI 処理で計算します。ヒストグラム内では、色相成分は赤色の線で、彩度成分は緑色の線で、明度成分は青色の線で表示されます。

表示

画像上の ExtractColorHistogram グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | ExtractColorHistogram 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。
3 = すべて表示: 入力とチャート | 入力画像領域とヒストグラムチャートは両方とも常に表示されます。

ExtractColorHistogram 関数の出力

戻り値 | RGB と HSI 度数分布の両方またはどちらかを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | ExtractColorHistogram 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

ExtractColorHistogram 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

注: これらのデータアクセス関数は、[カラーモード] パラメータの値に関わらず、自動的にスプレッドシートに挿入されます。[RGB] (カラーモード = 0) を指定すると、色相、彩度、明度については #ERR が返されます。[HSI] (カラーモード = 2) を指定すると、赤、緑、青については #ERR が返されます。
赤 | HistMean(カラーヒストグラム, 0, 255, 0) | 平均赤チャネル値
緑 | HistMean(カラーヒストグラム, 0, 255, 1) | 平均緑チャネル値
青 | HistMean(カラーヒストグラム, 0, 255, 2) | 平均青チャネル値
色相 | HistMean(カラーヒストグラム, 0, 255, 3) | 平均色相レベル値
彩度 | HistMean(カラーヒストグラム, 0, 255, 4) | 平均彩度レベル値
明度 | HistMean(カラーヒストグラム, 0, 255, 5) | 平均明度レベル値

関連項目

  • ヒストグラムツールについて
  • カラーヒストグラムデータアクセス関数
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法
Version: 5.6.0


ExtractHistogram 関数

ExtractHistogram 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

画像領域からヒストグラム配列を抽出します。

  • ExtractHistogram 関数の概要
  • ExtractHistogram の入力パラメータ
  • ExtractHistogram の出力
  • ExtractHistogram データアクセス関数
  • 関連項目

ExtractHistogram 関数概要

Histogram 関数は、対象領域内のピクセル値の 1 次元表現を返します。ヒストグラムは整数の配列によって表され、そこで配列の各要素はビンと呼ばれ、領域内のピクセル数のカウントを格納します。そこではビン n 内の値はピクセル値 n の領域内のピクセル数です。配列内のすべてのビンのカウントは、領域内のピクセル数と同じです。

ExtractHistogram 関数の入力パラメータ

ExtractHistogram 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

外部領域,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:

  • ピクセルがヒストグラムに計算されるようにするには、ピクセルが画像領域の範囲内に完全に含まれている必要があります。部分的に含まれているピクセルは計算されません。
  • [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

表示

画像上の ExtractHistogram グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | ExtractHistogram 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックスが表示されません。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。
3 = すべて表示: 入力とチャート | 入力画像領域とヒストグラムチャートは両方とも常に表示されます。

ExtractHistogram 関数の出力

戻り値 | グレースケール度数分布を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | ExtractHistogram 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

ExtractHistogram 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

しきい値 | HistThresh(Hist, 0, 255) | 2 値化しきい値
コントラスト | HistContrast(Hist, 0, 255) | グレースケール画像のコントラスト
暗ピクセル | HistCount(Hist, 0, Thresh-1) | しきい値を下回るピクセル数
明ピクセル | HistCount(Hist, Thresh, 255) | しきい値を上回るピクセル数
平均 | HistMean(Hist, 0, 255) | 平均グレースケール値

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistContrast 関数

HistContrast 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

最適なバイナリしきい値を見つけて画像コントラストを計算し、しきい値を超えるグレースケールの平均と、しきい値を下回るグレースケールの平均との差を取得します。このコントラスト値は、常に 0 ～ 255 の数値として返されます。

  • HistContrast の入力パラメータ
  • HistContrast の出力
  • 関連項目

HistContrast 関数の入力パラメータ

HistContrast 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistContrast 関数の出力

戻り値

画像コントラストを表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistCount 関数

HistCount 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

グレースケール値の指定した範囲内に存在するピクセルの数をカウントします。

  • HistCount の入力パラメータ
  • HistCount の出力
  • 関連項目

HistCount 関数の入力パラメータ

HistCount 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistCount 関数の出力

戻り値

ピクセル数を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistHead 関数

HistHead 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

指定した値の範囲から、最小グレースケール値を識別します。

  • HistHead の入力パラメータ
  • HistHead の出力
  • 関連項目

HistHead 関数の入力パラメータ

HistHead 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistHead 関数の出力

戻り値

最小グレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistHeadPercentage 関数

HistHeadPercentage 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

ヒストグラムの指定された範囲内に含まれるピクセルの内、指定された割合 (%) よりも大きなグレースケール値を返します。

  • HistHeadPercentage の入力パラメータ
  • HistHeadPercentage の出力
  • 関連項目

HistHeadPercentage 関数の入力パラメータ

HistHeadPercentage 関数 (

構造体 ,

倍率 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

倍率

グレースケール値の指定の範囲内に存在する、ヒストグラムで表されている合計ピクセルのパーセンテージを指定します。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistHeadPercentage 関数の出力

戻り値

最も明るいグレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • HistTailPercentage 関数
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法
Version: 5.6.0


HistMax 関数

HistMax 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

指定した値の範囲内で、最も発生頻度の高いグレースケール値を識別します。

  • HistMax の入力パラメータ
  • HistMax の出力
  • 関連項目

HistMax 関数の入力パラメータ

HistMax 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistMax 関数の出力

戻り値

最も使用頻度の高いグレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistMean 関数

HistMean 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

指定した範囲にあるすべてのピクセルのグレースケール値を合計し、同じ範囲内のピクセル数で除算することによって、グレースケールの平均を計算します。

  • HistMean の入力パラメータ
  • HistMean の出力
  • 関連項目

HistMean 関数の入力パラメータ

HistMean 関数(

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistMean 関数の出力

戻り値

平均のグレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistMin 関数

HistMin 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

指定した値の範囲内で、最も発生頻度の低いグレースケール値を識別します。

  • HistMin の入力パラメータ
  • HistMin の出力
  • 関連項目

HistMin 関数の入力パラメータ

HistMin 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistMin 関数の出力

戻り値

最も使用頻度の低いグレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistSDev 関数

HistSDev 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

グレースケール値の指定範囲内で、ピクセル値のグレースケール標準偏差を計算します。

  • HistSDev の入力パラメータ
  • HistSDev の出力
  • 関連項目

HistSDev 関数の入力パラメータ

HistSDev 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistSDev 関数の出力

戻り値

グレースケールの標準偏差を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistSum 関数

HistSum 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

グレースケール値の指定範囲内で、ピクセル値を合計します。

  • HistSum の入力パラメータ
  • HistSum の出力
  • 関連項目

HistSum 関数の入力パラメータ

HistSum 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistSum 関数の出力

戻り値

ピクセル値の合計を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistSumSquare 関数

HistSumSquare 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

グレースケール値の指定範囲内で、ピクセル値の二乗を合計します。

  • HistSumSquare の入力パラメータ
  • HistSumSquare の出力
  • 関連項目

HistSumSquare 関数の入力パラメータ

HistSumSquare 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistSumSquare 関数の出力

戻り値

ピクセル値の二乗の合計を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistTail 関数

HistTail 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

指定した値の範囲から、最大グレースケール値を識別します。

  • HistTail の入力パラメータ
  • HistTail の出力
  • 関連項目

HistTail 関数の入力パラメータ

HistTail 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistTail 関数の出力

戻り値

最大グレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


HistTailPercentage 関数

HistTailPercentage 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

ヒストグラムの指定された範囲内に含まれるピクセルの内、指定された割合 (%) よりも小さいグレースケール値を返します。

  • HistTailPercentage の入力パラメータ
  • HistTailPercentage の出力
  • 関連項目

HistTailPercentage 関数の入力パラメータ

HistTailPercentage 関数 (

構造体 ,

倍率 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

倍率

グレースケール値の指定の範囲内に存在する、ヒストグラムで表されている合計ピクセルのパーセンテージを指定します。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistTailPercentage 関数の出力

戻り値

最高のグレースケール値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • HistHeadPercentage 関数
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法

Version: 5.6.0


HistThresh 関数

HistThresh 関数 |
ビジョンツール → ヒストグラム | In-Sight 関数リファレンス

ExtractHistogram または ExtractColorHistogram 関数の領域間で正規化された相関関係およびすべての可能なバイナリ再量子化を取得することによって、最適なバイナリしきい値を計算し、類似性を最大限にするしきい値レベルを探します。

  • HistThresh の入力パラメータ
  • HistThresh の出力
  • 関連項目

HistThresh 関数の入力パラメータ

HistThresh 関数 (

構造体 ,

[FirstBin],

[LastBin],

[ カラー ]

)

構造体

この引数は、 [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照する必要があります。

FirstBin

ヒストグラムの定義に使用する最初の「ビン」を指定します (0 ～ 255、デフォルト = 0)。

LastBin

ヒストグラムの定義に使用する最後の「ビン」を指定します (0 ～ 255、デフォルト = 255)。

カラー

データ構造体からの色成分のヒストグラムのインデックスを指定します (デフォルト = 0)。

注:[カラー] パラメータはオプションで、カラー In-Sight ビジョンシステムに接続されている場合にだけ使用でき、 [image] 構造体が [構造体] パラメータで参照されている場合は無視されます。カラービジョンシステムに接続されている場合に、[構造体] パラメータが [image] 構造体 (ExtractColorHistogram 関数によって出力) を参照すると、[カラー] パラメータを使って色成分を選択できます。

0 = 赤 | データ構造体からの赤成分を指定します。
1 = 緑 | データ構造体からの緑成分を指定します。
2 = 青 | データ構造体からの青成分を指定します。
3 = 色相 | データ構造体からの色相成分を指定します。
4 = 彩度 | データ構造体からの彩度成分を指定します。
5 = 明度 | データ構造体からの明度成分を指定します。

HistThresh 関数の出力

戻り値

最適なバイナリしきい値を表す値。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ヒストグラムツールについて
  • ヒストグラムデータアクセス関数
  • プロパティシートの使用方法


ID

ビジョンツール

In-Sight 関数リファレンス

In-Sight ID ツール関数は、線形 1D および 2D シンボルに含まれている英数字データ文字列を読み取ります。また、必要に応じて、公表されている仕様に従って大半のシンボルの品質を検証することができます。ID ツールには次の関数があります。

  • ReadIDMax 関数: 対象領域内の 1D または 2D シンボル (1D/スタックド、データマトリックス、QR コード、および郵便番号) を検出し、デコードします。この関数を設定して、さまざまなシンボルと多くの結果を取得し、極度の回転および遠近歪みでも処理することができます。オプションで、データマトリックスと QR コードモデルの登録、および品質測定の検証にも使用することができます。

  • ReadIDCode 関数: 1D および 2D のシンボルに含まれている情報をデコードし、必要に応じて品質を検証します。

    注:
    • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
    • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。
  • ValidateIDData 関数: 1D および 2D シンボルからデコードされたデータを検証します。
  • VerifyIDCode 関数: 1D および 2D シンボルからコードの読み取り易さとマークの品質に関連する方法を抽出するために使用します。

1D および 2D シンボルの読み取り

ReadIDMax および ReadIDCode 関数を使用して、対象領域内の 1D および 2D シンボルを探してデコードします。新しいコード読み取りアプリケーションには、ReadIDMax 関数を使用することを推奨します。この関数は、既存の ReadIDCode 関数を超える次の利点があるからです。

  • 同じ画像内で、混合タイプの複数の 1D シンボルをデコードします。
  • 同じ画像内で、同じタイプの複数の 2D シンボルをデコードします。
  • 最新のシンボルデコードアルゴリズムをサポートしています。

1D および 2D シンボルの品質の検証

  • 1D バーコードシンボルの品質の検証
  • 2D シンボルの品質の検証
  • 検証および妥当性検査の技術の追加

1D バーコードシンボルの品質の検証

In-Sight ビジョンシステムは 1D バーコードを読み取り、オプションでバーコードの品質を検証することができます。In-Sight がシンボルの品質の検証に使用する方法は、米国規格協会 (ANSI) によって承認されています。

ReadIDMax または ReadIDCode 関数で [検証] チェックボックスをオンにすると、In-Sight で適用可能なすべてのアプリケーションテストが実行されます。バーコードの品質検証に使用される品質検証テストは複数あります (詳細は、データアクセス関数のトピックの IDMax および IDCode 関数を参照してください)。これらのテストそれぞれに、A (4.0) ～ F (0.0) の「グレード」があります。シンボルの全体的な品質は、いずれかのテストによって獲得される最低のグレードです。ただし、個別の品質テストそれぞれでアルファベットのグレードや同等の数値を返すことはなく、In-Sight では実際の結果の値プラスシンボル全体のグレードを返します。

注: バーコードの品質は、暗黙的にその読み取り可能性に関係していますが、1 つ以上のテストで低い、または不合格のグレードでありながら、読み取り可能なシンボルもあります。ただし、品質仕様を満たすことができなかったシンボルは、プロセスの問題に原因があるので、照明条件の変化や、再度キャリブレーションが必要な刻印機などについては注意が必要です。

2D シンボルの品質の検証

In-Sight はデータマトリックス、QR コード、PDF 417、および EAN/UCC コンポジットシンボルを読み取り、シンボルの品質も検証します。In-Sight でシンボルの品質の検証に使用する方法は、International Symbology Specification (ISS) のセクション 8 および Annexe N - データマトリックス (BC11-1997)、International Symbology Specification (ISS) のセクション 8 および Annexe M - QR コード (ITS/97-001)、Uniform Symbology Specification (USS) のセクション 3 および ４ - PDF 417 (AIM International が発行し、American National Standards Institute (ANSI) が承認)、および International Standard - バーコードシンボル印刷品質の評価仕様 (ISO/IEC-15416) (International Organization for Standardization (ISO) および International Electrotechnical Commission (IEC) が発行) で定義されています。

ReadIDMax または ReadIDCode 関数で [検証] チェックボックスをオンにすると、In-Sight で適用可能なすべてのアプリケーションテストが実行されます。AIM 仕様で説明されているように、品質検証テストは複数あり、シンボルの品質の検証に使用されます。使用される検証テストのタイプは、選択されているシンボルのタイプに応じて決まります。PDF 417 および EAN/UCC コンポジット 2D コンポーネントは、1D バーコードといくつかの検証テストを共有しています。これらのテストそれぞれに、A (4.0) ～ F (0.0) の「グレード」があります。シンボルの全体的な品質は、いずれかのテストによって獲得される最低のグレードです。ただし、品質テストそれぞれでアルファベットのグレードや同等の数値を返すことはなく、In-Sight では実際の結果の値プラスシンボル全体のグレードを返します。

注: シンボルの品質は、暗黙的にその読み取り可能性に関係していますが、1 つ以上のテストで低い、または不合格のグレードでありながら、読み取り可能なシンボルもあります。ただし、品質仕様を満たすことができなかったシンボルは、プロセスの問題に原因があるので、照明条件の変化や、再度キャリブレーションが必要な刻印機などについては注意が必要です。

検証および妥当性検査の技術の追加

ReadIDMax および ReadIDCode 関数のビルトイン品質検証測定に加えて、ValidateIDData および VerifyIDCode 関数を使用して、ReadIDMax および ReadIDCode 関数の両方またはどちらかによって読み取られ、デコードされたシンボルの妥当性検査と検証を実行することができます。

ValidateIDData 関数

ValidateIDData 関数を使用して、シンボルのデータの完全性の妥当性検査を行い、そのデータが MIL-STD 130 および GS1 標準に準拠していることを確認します。ValidateIDData データアクセス関数を使用して、データを解析し、適用標準に準拠していることを確認することができます。

VerifyIDCode 関数

VerifyIDCode 関数を使用して、シンボルに対してさらに検証測定を実行し、コードの読み取り可能性とシンボルのマークの品質に関連する方法を抽出します。VerifyIDCode データアクセス関数を使用して、シンボルの検証グレードを抽出することができます。


ReadIDCode 関数

ビジョンツール → ID

In-Sight 関数リファレンス

1D および 2D のバーコードおよびシンボルに含まれている情報をデコードし、必要に応じて品質を検証します。

注:
  • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。

ReadIDCode 関数の入力パラメータ

ReadIDCode 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

コード種類,

デコード設定.チェックサム,

デコード設定.全方向読み取り,

デコード設定.スキャン,

デコード設定.コントラスト,

デコード設定.シンボルフォーマット,

デコード設定.行数,

デコード設定.列数,

デコード設定.スケール許容,

デコード設定.カラー,

デコード設定.ミラー,

デコード設定.アルゴリズム,

デコード設定.モード,

デコード設定.遠近補正,

デコード設定.QRモード,

照合,

タイムアウト,

表示

)

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

領域

移動および回転可能な矩形の画像領域を指定します。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。 注: ReadIDCode 関数でサポートされる最大領域のサイズは 2048 ピクセル (高さ) × 2048 ピクセル (幅) です。[高さ] または [幅] パラメータを 2048 ピクセル以上に設定すると、#ERR を返します。
幅 | 領域の Y 軸に沿った寸法。 注: ReadIDCode 関数でサポートされる最大サイズは 2048 ピクセル (高さ) × 2048 ピクセル (幅) です。[高さ] または [幅] パラメータを 2048 ピクセル以上に設定すると、#ERR を返します。
角度 | フィクスチャ座標での角度。

注: [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

コード種類

読み取りの対象となる 1D シンボルと 2D シンボルの種類を指定します。

注:

  • 選択したコード種類に適用されないデコード設定は、グレーアウトされます。
  • 郵便POSTNET、PLANET、UPU 4-State、Australia Post 4-State、Japan Post 4-State、USPS OneCode
    4-State の     コード    デコードアルゴリズムは、初期画像処理の段階で [Region.Angle] の値を使用します。画像内でバーコードが完全に水平である場合、[全方向読み取り] パラメータが OFF のときに、[角度] の値が 0 で動作が最適化されます。画像内でバーコードが完全に垂直である場合は、動作を最適化するために [領域] を ±90 度回転させる必要があります。
  • GS1 コードはすべてサポートされています。詳細については、www.gs1.org を参照してください。

255 = 自動

シートが更新されるたびに、領域内のすべてのシンボルを実行することによってデコードし、最初にデコードに成功したシンボルを選択します。後続するスプレッドシートの更新では、デコードに成功した最新のコード種類のデコードを最初に試みてから、そのほかのコード種類を試みます。

Closed コード種類を試みる順序

  1. 最も新しくデコードされたコード種類 (存在する場合)
  2. データマトリックス
  3. RSS CC-A
  4. RSS CC-B
  5. PDF417
  6. QR コード
  7. マイクロ QR コード
  8. RSS14 & スタックド
  9. RSS リミテッド
  10. UPC
  11. EAN
  12. Code 128
  13. POSTNET
  14. PLANET
  15. UPU 4-State
  16. Australia 4-State
  17. Japan 4-State
  18. USPS OneCode 4-State
  19. Code 39
  20. Code I2of5
  21. Code 93
  22. Codabar (NW-7)

注: 「自動」では、PharmaCode バーコードはデコードされません。

-1 = 学習 (デフォルト)

コード種類を学習します。このパラメータには、最初にデコードされたコード種類が再実装されます。

注: 「学習」では、PharmaCode バーコードはデコードされません。

ヒント:

  • シンボルが学習されると、「コード種類」パラメータには、そのシンボルのコード種類が表示されます。実行中のモードが学習モードであるかどうかを確認するには、空のスプレッドシートセルに、ReadIDCode 構造体を参照する GetLearned データアクセス関数を入力します。1 が返された場合、この関数は学習モードで実行されています。
  • シンボルの形式が変更されると想定される場合は、コード種類が同じであったとしても、学習モードでは実行しないでください。学習設定は、最初にデコードされたシンボルの形式 (コード種類、極性、形式、モジュール、サイズなど) を記憶しています。新しいシンボルの形式のいずれかが学習されたコードから変更された場合、コード種類が同じでも、読み取りは失敗します。シンボル形式の学習を解除しても同じコード種類を維持するには、別のコード種類を一度選択してから正しいコード種類を選択しなおす必要があります。形式が変化するシンボルを ReadIDCode 関数がデコードできるようにするには、コード種類を自動に設定します。シンボルの変化が予想されない場合は、特定のシンボルを選択します。
  • [アルゴリズム] パラメータが ON のときに [学習] を選択すると、デコード時間が長くなる可能性があります。
  • ここを Closed クリックして、コード種類の再学習をプログラムで行う例を参照してください。

    1.セル A1 にボタンを作成します。

    2.セル A2 に式 If(A1,255,-1) を挿入します。

    3.画像内に表示されるシンボルなしで ReadIDCode を作成します。

    4.ReadIDCodeの「コード種類」パラメータがセル A2 を参照するようにします。

    5.セル A1 のボタンをクリックして、ReadIDCode 関数に再学習 (学習解除してからの再学習を含む) させます。

0 = Code 39

Code 39 (別名 Code 3 of 9 および BC39) の読み取りを選択します。

1 = Code 128

Code 128 の読み取りを選択します。コードセット A、B、および C のバーコードをサポートします。

2 = Code I2of5

I2of5 (Interleaved 2 of 5含む) の読み取りを選択します。

3 = UPC

UPC (Universal Product Code含む) の読み取りを選択します。バージョン A (標準バージョン含む) およびバージョン E (ゼロ抑制バージョン含む) の UPC バーコードと、2 文字および 5 文字の補足コードをサポートします。

4 = EAN

EAN (European Article Numbering含む) の読み取りを選択します。EAN-8 および EAN-13 バーコードと同時に、2 文字および 5 文字の補足コードがサポートされています。

7 = PharmaCode

PharmaCode の読み取りを選択します。

5 = POSTNET

POSTNET の読み取りを選択します。

6 = PLANET

PLANET の読み取りを選択します。

9 = RSS-14 & スタックド

RSS-14 (Reduced Space Symbology含む) および RSS スタックドの読み取りを選択します。

10 = RSS リミテッド

RSS リミテッドの読み取りを選択します。

12 = Codabar (NW-7)

Codabar (USD-4 および Code 2 of 7 含む) の読み取りを選択します。

11 = Code 93

Code 93 の読み取りを選択します。

8 = UPU 4-State

UPU 4-State の読み取りを選択します。

13 = Australia Post 4-State

Australia Post 4-State の読み取りを選択します。

14 = Japan Post 4-State

Japan Post 4-State の読み取りを選択します。

15 = USPS OneCode 4-State

USPS OneCode 4-State の読み取りを選択します。

128 = データマトリックス

データマトリックスの読み取りを選択します。

注:

  • 読み取りの対象となるデータマトリックスシンボルの種類を指定するには、データマトリックスパラメータを使用します。
  • [アルゴリズム] パラメータが有効な場合は最大 144 × 144 のグリッドがサポートされ、無効な場合は最大 48 × 48 のグリッドがサポートされます。

129 = QR

QR コードの読み取りを選択します。

注: 読み取りの対象となる QR シンボルの種類を指定するには、QR パラメータを使用します。

130 = RSS CC-A

2D CC-A (コンポジットコンポーネント含む) の読み取りを選択します。

131 = RSS CC-B

2D CC-B (コンポジットコンポーネント含む) の読み取りを選択します。

132 = PDF417

PDF417 の読み取りを選択します。

デコード設定

1D および 2D シンボルのデコードに使用される設定を指定します。

注: 選択したコード種類に適用されないデコード設定は、グレーアウトされます。

チェックサム

信頼性を保証するためにエラー検出アルゴリズムを使用してシンボルを検証するかどうかを指定します。チェックサムは、シンボルに含まれるオプションのチェックサムアルゴリズムを備えたシンボルのみに適用されます。各シンボルは、固有のチェックサムアルゴリズムを備えています。使用されるチェックサム (使用可能な場合含む) のタイプは、選択したコードのタイプによって異なります。

0 = OFF (デフォルト) | チェックサムを検証しません。
1 = ON | チェックサムの検証に合格する必要があります。

注: Code 128、Code 93、RSS、UPC、および EAN バーコードは、パラメータの選択にかかわらず、チェックサムによって検証されます。その他のバーコードで [チェックサム] を ON にし、チェックサムがエンコードされていない場合、読み取りに失敗します。

全方向読み取り

バーコードのエレメントをすべて検出するために、領域内に抽出されるスキャンラインの方向を指定します。デコードを成功させるには、バーコードのすべてのエレメント間で、少なくとも 1 つのスキャンラインを抽出する必要があります。

0 = OFF | スキャンラインが 1 つの角度で抽出され、領域に対して平行なバーコードが検出されます。
1 = ON (デフォルト) | スキャンラインが複数の角度で抽出され、領域に対して回転しているバーコードが検出されます。

注: 領域から 90 度以上回転していると、PharmaCode バーコードは正しくデコードしません。

スキャン

領域内で抽出された各スキャンライン間で、スペースをピクセル単位で指定します。[高精度] が選択された場合、バーコードは高精度で読み取られます。[粗いモデル] が選択されると、実行時間が短縮されます。最大で領域の高さまでで、1 ～ 255 の整数値を入力することもできます。

3 = 高精度

12 = 中程度 (デフォルト)

48 = 粗粒度

注: 1D シンボルに対して、[全方向読み取り] が ON の場合は、[スキャン] パラメータは無効になります。

コントラスト

予想されるシンボルのコントラストを指定します。

0 = 自動 (デフォルト) | 自動コントラストルーチンを選択し、グレースケール画像統計に基づいてしきい値を計算します。
16 = 低 | 低コントラストのシンボル用です。
32 = 標準 | 通常のコントラストのシンボル用です。
64 = 高 | 高コントラストのシンボル用です。

注: [コントラスト] パラメータは、ポスタルおよび RSS コードでのみ有効です。

シンボルフォーマット

シンボルの行および列のフォーマットを指定します。シンボルフォーマットが無効 (デフォルト含む) の場合、シンボルフォーマットは自動的に決定されます。有効になっている場合は、行数および列数を指定する必要があります。

注: [シンボルフォーマット] パラメータは実装されていません。

行

シンボル内の行数を指定します。

注: [行数] パラメータは実装されていません。

列

シンボル内の列数を指定します。

注: [列数] パラメータは実装されていません。

スケール許容

シンボルサーチ時に許容するスケール変化の割合 (%　含む) を指定します (0 ～ 50、デフォルト = 0)。

注: [スケール許容] パラメータは実装されていません。

カラー

シンボルの色を指定します。

0 = 黒 | シンボルは背景よりも暗くなります。
1 = 白 | シンボルは背景よりも明るくなります。

注: [カラー] パラメータは、1D RSS シンボルに対してのみ実装されます。

ミラー

デコードする前に、シンボルモデルを左から右への鏡像にするかどうかを指定します。

0 = いいえ | 鏡像にしないでシンボルをデコードします。
1 = はい | デコード前にシンボルを鏡像にします。
2 = 自動 (デフォルト) | デコードを試みる前にシンボルを鏡像にする必要があるかどうかを自動的に検出します。

アルゴリズム

読み取り精度を向上させるために、高度なアルゴリズムを使用するかどうかを指定します。

注: [アルゴリズム] が ON の場合、最小バーエレメントの幅が 10 ピクセル以上を超える 1D バーコードがデコードできないことがあります。

0 = OFF | 高度なアルゴリズムを使用しません。無効になっている場合、この関数は、レガシー ID 関数で使用されていたアルゴリズムを適用します。このアルゴリズムを使用する場合、デコード速度は向上する可能性がありますが、精度が劣る可能性があります。
1 = ON (デフォルト) | 高度なアルゴリズムを使用してデコードを行います。このアルゴリズムは、レガシーアルゴリズムよりも高精度ですが、デコード速度は低下する可能性があります。これが ON のとき、データマトリックスおよび RSS シンボルは、IDMax® を使用してデコードされます。

モード

特定のシンボルを読み取るために使用するモードを指定します。

0 = デフォルト

非整合データマトリックスシンボルの読み取りは行われません。

2 = 非整合モジュールを許可

非整合データマトリックスシンボルを読み取り、デコードオプションを試行するための時間を追加します。

注:

  • コード種類でデータマトリックスシンボルをデコードするには、[自動]、[学習]、または [データマトリックス] を選択する必要があります。また、[アルゴリズム] パラメータを ON にする必要があります。
  • データマトリックスシンボルのモジュールがハローやそれに類する外観を示している場合は、このオプションを選択します。

3 = 高速/高コントラスト

高コントラストデータマトリックス、RSS-14、および RSS リミテッドのシンボルを読み取ります。この選択肢を使用すると、デコード速度が向上します。シンボルのコントラストが低い、シンボルが損傷している、または不鮮明である場合は選択しないでください。

注:

  • [学習] が選択された コード種類で、[アルゴリズム] パラメータが有効である必要があります。
  • [高速/高コントラスト] オプションは、一部の高速読み取りアプリケーションに対して、より繰り返し可能なデコード時間を提供できるように設計されています。 一般に、マークの品質が場所によって異なるような、コントラストの高いインクジェットコードの読み取りに使用されます。 このようなアプリケーションでは、各マークのデコードに必要な時間に大きなばらつきが見られることがよくあります (つまり、印刷品質の悪いマークのデコードにかかる時間は、品質の良いマークの場合よりも 3 ～ 5 倍、長くなります)。 [高速/高コントラスト] オプションによって、平均速度を高く保ちながら、デコード時間のばらつきを軽減できます。 ただし、すべてのアプリケーションでこの恩恵を受けられるわけではないことに注意してください。使用しているアプリケーションにこのオプションが適しているかどうかを判定するには、適切なテストを実行する必要があります。

遠近補正

遠近歪みを持つデータマトリックスシンボルおよび QR コードシンボルのデコードを指定します。また、必要に応じて、既知の遠近歪みに対するデータマトリックスシンボルを登録することも可能です。

注:

  • [コード種類] で、遠近歪みを持つデータマトリックスシンボルまたは QR コードシンボルをデコードするには、[自動]、[学習]、[データマトリックス]、または [QR] を選択する必要があります。また、[アルゴリズム] パラメータをオンにする必要があります。
  • [遠近補正あり] または [学習時に遠近補正データを登録] が選択されている場合、品質検証はサポートされません。

0 = 遠近補正なし (デフォルト)

遠近歪みのないデータマトリックスシンボルおよび QR コードシンボルをデコードします。

3 = 遠近補正あり

遠近歪みを持つデータマトリックスシンボルおよび QR コードシンボルをデコードします。遠近歪みは、モデルの登録中およびランタイムに、個別に予測されます。

7 = 学習時に遠近補正データを登録

既知の遠近歪みを持つデータマトリックスシンボルをデコードします。コード種類で [学習] が選択されている場合、遠近補正は、そのほかの 「学習済み」 属性とともに登録されます。ランタイムに、学習済み属性を使用して入力画像の遠近歪みが補正されている空間から、このシンボルがサーチされます。このオプションでは、ランタイムシンボルを、学習時間シンボルと同じ平面に配置する必要があります。このオプションを指定すると、既知の遠近歪みを持つひどく損傷したシンボルでもデコードを行うことができます。コード種類で [自動] が選択されている場合、このオプションは、「3 = 遠近補正あり」 と同じです。

ヒント: センサは入射角 (センサの光軸と、シンボルが存在する平面の法線ベクトルの角度含む) が 40 度を超えないように、またシンボルの解像度が 1 セルあたり最低 5 ピクセルになるように取り付けることを推奨します。

QR モード

読み取りの対象となる QR コードの種類を指定します。

3 = QR コードモデル 1 と 2

4 = マイクロ QR コード

6 = QR コードモデル 2、およびマイクロ QR コード (デフォルト)

7 = QR コードモデル 1 と 2、およびマイクロ QR コード

照合

印刷品質テスト (品質検証測定ともいいます) を実行するかどうかを指定します。

0 = OFF (デフォルト) | 品質をテストしません。
1 = ON | 品質をテストし、スプレッドシートに結果を表示します。

注:

  • 文字列をデコードできなかった場合、スプレッドシートに自動挿入された結果すべてに、#ERR が返されます。
  • PharmaCode および RSS スタックド以外のすべてのコード種類は、品質検証をサポートしています。

タイムアウト

関数が有効な ID シンボルを検索する時間をミリ秒単位で指定します (0 ～ 30000)。この時間が経過すると、処理は中止され、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示

画像上の ReadIDCode グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | ReadIDCode 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力領域境界は表示されません。
1 = 結果のグラフィックスのみ | 結果のグラフィックス (データマトリックスおよび QR コード用ボックス含む) が常に表示されます。
2 = 入力と結果のグラフィックス | 入力グラフィックスと結果のグラフィックスが常に表示されます。 注: [表示] パラメータは、データマトリックスシンボルと QR コードシンボルに対してのみ実装されます。

ReadIDCode 関数の出力

戻り値 | デコードされた英数字文字列を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、デコードされた文字列が隣のセルに自動的に表示されます。バーコードまたはシンボルをデコードできない場合は #ERR が挿入されます。

ReadIDCode 関数データアクセス関数

[照合] チェックボックスを OFF にした ReadIDCode 関数をスプレッドシートに配置すると、データアクセス関数が 1 つだけスプレッドシートに自動挿入されます。

文字列

GetString(ID コード)

バーコードまたはシンボル内でエンコードされている英数字文字列を返します。

[照合] チェックボックスを ON にした ReadIDCode 関数をスプレッドシートに配置すると、自動的にデータアクセス関数が挿入されます。データアクセス関数の組み合わせは、選択したコード種類によって変わります。

注: ReadIDCode 関数をスプレッドシートに配置した後で [照合] チェックボックスを ON にしても、データアクセス関数は自動挿入されません。手動でセットしたデータアクセス関数を実行するには、[照合] チェックボックスを ON にしてください。

ReadIDCode データアクセス関数を使用して、そのほかのデータの取得ができます。


ReadIDMax 関数

ビジョンツール → ID

In-Sight 関数リファレンス

対象領域内の 1D または 2D シンボル (1D/スタックド、データマトリックス、QR コード、および郵便番号) を検出し、デコードします。この関数を設定して、さまざまなシンボルと多くの結果を取得し、極度の回転および遠近歪みでも処理することができます。オプションで、データマトリックスと QR コードモデルの登録、および品質測定の検証にも使用することができます。

  • ReadIDMax 関数の概要
  • ReadIDMax の入力パラメータ
  • ReadIDMax の出力
  • ReadIDMax データアクセス関数
  • 関連項目

ReadIDMax 関数概要

ReadIDMax 関数を使用して、1D および 2D シンボルを探してデコードします。

  • 1D シンボル
  • 2D シンボル
  • 1D/2D 画像要件
  • IDMax® と IDQuick™
  • 結果

1D シンボル

ReadIDMax 関数は、同じ画像内で、次のタイプの 1D シンボルを含む複数の 1D シンボルのデコードをサポートしています。

  • Code 128
  • UPC/EAN
  • Code 39
  • Code 93
  • Interleaved 2 of 5
  • Codabar
  • Pharmacode
  • DataBar
  • PDF417
  • EAN.UCC Composite
  • POSTNET
  • PLANET
  • Japan Post
  • Australia Post
  • UPU
  • Intelligent Mail Barcode

注: 1D シンボルは登録する必要はありません。

2D シンボル

ReadIDMax 関数は、2D データマトリックスおよび QR コードのシンボルを探してデコードすることができます。この関数は複数の 2D シンボルを探すことができますが、1D シンボルとは異なり、すべてのシンボルが同じシンボルタイプである必要があります。例えば、画像にデータマトリックスと QR コードのシンボルが混在しており、この関数の [シンボルグループ] パラメータが [データマトリックス] に設定されていた場合、QR コードシンボルは無視され、データマトリックスのシンボルのみが返されます。

この関数を登録して、シンボルのグリッドサイズのサイズ、およびシンボルが含んでいるデータの精度を検証するためにシンボルが使用する、2D シンボルタイプおよびエラーのチェックと修正 (ECC) の方法を確立することによって、同じタイプの 2D シンボルをデコードすることができます。

注: アプリケーションで使用される 2D シンボルすべてが同じ特性を共有する場合は、この関数を登録することを推奨します。例えば、2D シンボルがグリッドサイズまたは極性の点で異なることがある場合は、関数を登録しなければ、2D シンボルのデコード時にすべての可能な設定を考慮することができます。

ReadIDMax 関数を登録すると、特にデコードするすべてのシンボルが同じ品質を共有するときにはパフォーマンスが向上しますが、関数を登録しない場合は、より幅広い種類のシンボルをデコードすることができ、再構成する必要もありません。

1D/2D 画像要件

ReadIDMax 関数は、1D シンボルをスキャンする場合には最小構成を必要としますが、次のガイドラインを入力画像に使用する必要があります。

  • すべてのシンボルは 50 ピクセルよりも大きい必要がありますが、どのモジュールの最大幅も 10 ピクセルを超えることはできません。

注: モジュールはシンボルの最も狭いエレメントです (スペースまたはバーのいずれか)。

  • リニアシンボル (モジュールの幅は異なりますが、高さは均一です) の場合、モジュールの幅は 1.6 ピクセル以上、高さは 50 ピクセル以上である必要があります。ポスタルコード (モジュールの幅は均一ですが、高さは異なります) の場合、モジュールの幅は 2.5 ピクセル以上である必要があります。
  • クワイエットゾーン (マークを含んでいないシンボルのいずれかの端の領域) は、シンボルタイプの印刷仕様で指定された最小サイズ以上で存在する必要があります。
  • モジュールと背景間のコントラストは、32 グレーレベル以上である必要があります。
  • ピクセルアスペクト比は、1.35 対 1 より大きくすることはできせん。

2D シンボルでの画像の要件は少な目です。通常は、シンボルの 4 つすべてのサイドを取り囲むクワイエットゾーン (つまりマージン) が存在する必要があり、シンボル自体の内部の 1 つのモジュールの幅と等しくなっています。

IDMax と IDQuick

ReadIDMax 関数は、アルゴリズムのデコードに関して次の 2 つの処理モードを提供します。

  • 形が整いハイコントラストで表示されるシンボルを高速でデコードする場合は、IDQuick 関数を選択します。
  • 難易度の高い画像に対して、高度な画像処理および画像解析技術を必要とする場合は、IDMax 関数を選択します。

デフォルトでは、この関数は IDMax モードを使用しますが、アプリケーションで関数のパフォーマンスにどのように影響するか判定するには、IDQuick で試してみてください。

結果

検出されてデコードされたシンボルのみが結果を生成します。画像内の各シンボルについて、ReadIDMax 関数はデータアクセス関数によって次の結果を生成します。

  • デコードされた文字列
  • 検出されたシンボルの角度 (度単位)
  • シンボルの中心の位置 (行/列)
  • シンボルの特定のコード
  • 業界標準に従ってシンボルを一意に識別するための、ISO/IEC のコードおよび修飾子

注: デコードされた文字列を超える結果を生成するには、[照合] チェックボックスをオンにする必要があります。VerifyIDCode および ValidateIDData 関数を使用して、デコードされたシンボルに関する検証測定をさらに処理します。

ReadIDMax 関数の入力パラメータ

ReadIDMax 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

シンボルグループ,

最大結果,

詳細デコードモード,

登録の有効化,

1D シンボル.Code 128,

1D シンボル.Code 128,

1D シンボル.I2of5,

1D シンボル.Pharmacode,

1D シンボル.UPC/EAN,

1D シンボル.Code 128,

1D シンボル.Codabar,

スタックドシンボル.PDF 417,

スタックドシンボル.DataBar,

スタックドシンボル.DataBar リミテッド,

スタックドシンボル.DataBar Expanded,

スタックドシンボル.EAN.UCC コンポジット,

ポスタルシンボル.POSTNET,

ポスタルシンボル.PLANET,

ポスタルシンボル.Japan Post,

ポスタルシンボル.Australia Post,

ポスタルシンボル.UPU,

ポスタルシンボル.インテリジェントメールバーコード,

デコード設定.遠近補正,

デコード設定.QRモード,

デコード設定.極性を無視,

デコード設定.フレキシブルグリッドサイズの許容,

デコード設定.チェックサム,

デコード設定.極性,

デコード設定.全方向読み取り,

デコード設定.ソートモード,

デコード設定.同一 1D シンボルの許容,

デコード設定.Expand UPC-E,

照合,

タイムアウト,

表示

)

注: ReadIDMax 関数のプロパティシートを設定している場合、パラメータ値の更新の影響を確認するには、[OK] ボタンをクリックして変更を受け入れてからプロパティシートを閉じます。ReadIDMax 関数では、プロパティシートを開いたまま更新された結果を表示することはできません。

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

注: カラーの In-Sight ビジョンシステムを使用している場合、この関数は、カラー画像をグレースケールに変換する画像処理関数 (例えば ColorToGreyscaleFilter) を参照する必要があります。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。 注: 1D/スタックドシンボルおよびポスタルシンボルを読み取る場合、ReadIDMax 関数でサポートされる最大領域サイズは 2048 ピクセル (高さ) × 2048 ピクセル (幅) です。[高さ] または [幅] パラメータを 2048 ピクセル以上に設定すると、#ERR を返します。
幅 | 領域の Y 軸に沿った寸法。 注: 1D/スタックドシンボルおよびポスタルシンボルを読み取る場合、ReadIDMax 関数でサポートされる最大サイズは 2048 ピクセル (高さ) × 2048 ピクセル (幅) です。[高さ] または [幅] パラメータを 2048 ピクセル以上に設定すると、#ERR を返します。
角度 | フィクスチャ座標での角度。

シンボルグループ

読み取りの対象となるコードグループを 4 種類の中から 1 つ指定します。

1D/スタックド (デフォルト) | 1D およびスタックドコードの読み取りを選択します。
Data Matrix | データマトリックスの読み取りを選択します。
QR Code | QR コードの読み取りを選択します。
Postal | ポスタルコードの読み取りを選択します。

最大結果

配置してデコードするシンボルの最大数 (1 ～ 128、デフォルト = 1) を指定します。

注: このパラメータの指定された値が ROI 内のシンボル数を超える場合でも、この関数は指定された数のシンボルの検索を続行します。ROI 内のシンボルの数が変化する場合、[タイムアウト] パラメータ設定を低くすることで、関数の実行時間を短縮することができます。

詳細デコードモード

データマトリックス、または 1D/スタックドコードグループのデコードに使用する設定を指定します。

IDMax® (デフォルト) | 整合シンボルのみを読み取ります。非整合シンボルの読み取りは行われません。
非整合モジュールを許可 | 非整合シンボルを読み取り、デコードオプションを試行するための時間を追加します。
高速/高コントラスト | 高コントラストのシンボルを読み取ります。この選択肢を使用すると、デコード速度が向上します。シンボルのコントラストが低い、シンボルが損傷している、または不鮮明である場合は選択しないでください。 注: このオプションは、一部の高速読み取りアプリケーションに対して、より繰り返し可能なデコード時間を提供できるように設計されています。一般に、マークの品質が場所によって異なるような、コントラストの高いインクジェットコードの読み取りに使用されます。このようなアプリケーションでは、各マークのデコードに必要な時間に大きなばらつきが見られることがよくあります (つまり、印刷品質の悪いマークのデコードにかかる時間は、品質の良いマークの場合よりも 3 ～ 5 倍、長くなります)。このオプションによって、平均速度を高く保ちながら、デコード時間のばらつきを軽減できます。ただし、すべてのアプリケーションでこの恩恵を受けられるわけではないことに注意してください。アプリケーションにこのオプションが適しているかどうかを判定するには、適切なテストを実行する必要があります。
IDQuick™ (高速) | ワーピングや歪みが生じる可能性のあるシンボルや非均一な背景に表示されるシンボルに使用します。このモードは、分離されたドットではなく、「連続した」ファインダパターンのコード用に設計されています。

登録の有効化

有効な場合、最初に読み込まれたデータマトリックスまたは QR コードのシンボルのモデルを登録します。この関数を登録すると、特にデコード対象のすべてのシンボルが類似する特性を共有する場合に、パフォーマンスを向上させることができます。

登録情報は、このチェックボックスをオフにするまで保持されます。シンボルを保持するには、チェックボックスをオフにしてから、再度オンにしてください。

ヒント: 登録が有効にされている場合、領域内のシンボルは 1 つのみにすることを推奨します。

OFF (デフォルト) | モデルの登録を行いません。
ON | 最初に読み込まれたシンボルのモデルを登録します。

1D シンボル

読み取りの対象となる 1D コードを指定します (複数のコードを選択して、読み取ることができます)。

Code 128

Code 128 の読み取りを選択します。Code 128 は非常に高密度の英数字シンボルであり、双方向でスキャンすることができます。このシンボルは、128 の ASCII 文字セット全体および非データの 4 文字をエンコードすることができます。Code 128 シンボルを使用するシンボルは、11 個の白黒のモジュールを使用して各文字をエンコードし、各シンボルはチェックサム文字を含んでいます。

Code 39

Code 39 の読み取りを選択します。Code 39 (別名 USS Code 39、BC39、または Code 3 of 9) は、小売り以外の環境で使用するために開発された、広く使用されているシンボルであり、文字と数字の両方、および「%」や「/」などの特殊文字をエンコードすることができます。Code 39 シンボルを使用するシンボルは、5 本のバーと 4 本のスペースの合計 9 本のエレメントを使用して各文字をエンコードし、9 本のエレメントの内 3 本が常に幅となります。シンボルは、エラー検出用にチェックサム文字を含むことができます。

Interleaved 2 of 5

Interleaved 2 of 5 の読み取りを選択します。倉庫管理アプリケーションで評判の良い Interleaved 2 of 5 (別名 I2of5、I-2/5、または ITF) は、可変長の数値のみのコードです。Interleaved 2 of 5 シンボルを使用するシンボルは、5 本のバーとスペースのユニットで 2 文字をエンコードし、ここで偶数位置の文字がバーにエンコードされ、奇数位置の文字はスペースにエンコードされます。Interleaved 2 of 5 のシンボルは、偶数番目の長さのデータのみをエンコードすることができます。シンボルは、エラー検出用にチェックサム文字を含むことができます。

Pharmacode

Pharmacode の読み取りを選択します。Pharmacode は、医薬品産業で包装管理システムとして使用されます。

UPC/EAN

UPC (Universal Product Code) および EAN (European Article Numbering) の読み取りを選択します。UPC は固定長の数値のみのシンボルであり、双方向にスキャンすることができます。UPC シンボルのサイズを変更して、各種の印刷プロセスに適用することができますが、シンボルの高さがその幅を超える場合に、このコードは最適に機能します。ヨーロッパの企業は、ほぼ同等の EAN システムを使用しています。

UPC は、バージョン A (標準バージョン) およびバージョン E (ゼロ抑制バージョン) の UPC バーコードと、2 文字および 5 文字の補足コードをサポートします。EAN は、EAN-8 および EAN-13 バーコードと同時に、2 文字および 5 文字の補足コードをサポートします。

Code 93

Code 93 の読み取りを選択します。Code 93 は Code 39 と同じ文字をエンコードしますが、文字ごとに 15 本ではなく 9 本のバーコードエレメントを使用します。

Codabar

Codabar (USD-4 および Code 2 of 7 含む) の読み取りを選択します。Codabar はデジットをエンコードする古いシンボルです。

スタックドコード

読み取りの対象となるスタックドコードを指定します (複数のコードを選択して、読み取ることができます)。

PDF 417 | PDF417 の読み取りを選択します。PDF417 は、各種のアプリケーション、一次輸送、ID カード、および在庫管理で使用される一次元のスタックドバーコードシンボルフォーマットです。
DataBar | DataBar の読み取りを選択します (以前は RSS と呼ばれており、別名 GS1 DataBar です)。DataBar のシンボルは小さいアイテムを識別し、現在の EAN/UPC バーコードよりも多くの情報を伝達することができます。
DataBar Limited | DataBar Limited の読み取りを選択します (別名 GS1 DataBar Limited)。
DataBar Expanded | DataBar Expanded の読み取りを選択します (別名 GS1 DataBar Expanded)。
EAN.UCC Composite | EAN.UCC コンポジットの読み取りを選択します。有効にすると、コンポジットコード (2D コンポーネントを含んでいる 1D コード) をデコードすることができます。EAN.UCC で使用することができる 1D コードは、DataBar および Code 128 です。

ポスタルシンボル

読み取りの対象となるスタックドコードを指定します (複数のコードを選択して、読み取ることができます)。

POSTNET | POSTNET の読み取りを選択します。Postal Numeric Encoding Technique (POSTNET) バーコードは、米国の郵政局が郵便番号の情報をエンコードするために考案したものです。POSTNET のシンボルを使用するバーコードは、5 本のバー (短いものまたは長いもの) の組み合わせを使用して、それぞれの数字をエンコードします。POSTNET バーコードは、5 桁の郵便番号、5 桁の郵便番号 + 4 つのコード、または 11 桁の納入場所コードを含むことができます。このシンボルは必ずチェックサム文字を含んでいます。
PLANET | PLANET の読み取りを選択します。PLANET のバーコードは POSTNET バーコードの逆であり、POSTNET シンボルが長いバーを使用する箇所で短いバーを使用し、POSTNET シンボルが短いバーを使用する箇所で、PLANET は長いバーを使用します。米国の郵政局は PLANET バーコードを使用して郵便を追跡します。PLANET のバーコードは 12 桁まで含むことができます。
Japan Post | Japan Post の読み取りを選択します。
Australia Post | Australia Post の読み取りを選択します。4-State Customer Barcode という別名があり、オーストラリアの郵便局が採用する英数字のシンボルです。4-State のシンボルを使用するバーコードは、異なる 4 種類のバーを使用して各文字をエンコードし、バーはそれぞれ別個の名前と値を持っています。4-State のバーコードは、37 本のバー (標準)、52 本のバー、または 67 本のバーの 3 つの異なる構造体の 1 つに生成することができます。ReadIDMax 関数は、オーストラリア、日本の郵便局、UPU、および USPS バージョンの 4-state シンボルをサポートしています。
UPU | UPU の読み取りを選択します。
インテリジェントメール バーコード | インテリジェントメールバーコードの読み取りを選択します。IM バーコードという別名があり、米国で郵便に使用されている 65 バーコードです。

デコード設定

遠近補正

遠近歪みを持つデータマトリックスシンボルおよび QR コードシンボルのデコードを指定します。また、必要に応じて、既知の遠近歪みに対するデータマトリックスシンボルを登録することも可能です。

No perspective

遠近歪みのないデータマトリックスシンボルをデコードします。

Perspective (デフォルト)

遠近歪みを持つデータマトリックスシンボル、QR コードシンボル、および 1D/スタックドシンボルをデコードします。遠近歪みは、モデルの登録中およびランタイムに、個別に予測されます。

学習時に遠近補正データを登録

既知の遠近歪みを持つデータマトリックスシンボルをデコードします。遠近歪みは登録されており、ランタイムに、登録された属性を使用して入力画像の遠近歪みが補正されている空間から、このシンボルがサーチされます。このオプションでは、ランタイムシンボルを、登録されたシンボルと同じ平面に配置する必要があります。このオプションは、既知の遠近歪みを持つひどく損傷したシンボルでもデコードを行うことができます。

ヒント: ビジョンシステムは入射角 (センサの光軸と、シンボルが存在する平面の法線ベクトルとの間の角度) が 40 度を超えないように、またシンボルの解像度が 1 セルあたり 5 ピクセル以上になるように取り付けることを推奨します。

QR モード

読み取りの対象となる QR コードの種類を指定します。

QR コードモデル 1

QR コードモデル 2

QR コードモデル 1 と 2

Micro QR

Micro QR および QR コードモデル 1

Micro QR および QR コードモデル 2

すべての QR モード (デフォルト)

極性を無視

登録されたシンボルに対して極性が反転しているデータマトリックスシンボルを読み取り可能にするかどうかを指定します。

注: このパラメータは、[登録の有効化] パラメータが「オン」の場合にのみ有効になります。

OFF (デフォルト) | 登録モデルからの極性の反転を認めません。
ON | 登録モデルからの極性の反転を認めます。

フレキシブルグリッド
サイズの許容

登録されたシンボルに対してグリッドサイズの異なるデータマトリックスシンボルおよび QR コードシンボルを読み取り可能にするかどうかを指定します。

注: このパラメータは、[登録の有効化] パラメータが「オン」の場合にのみ有効になります。

OFF (デフォルト) | 登録シンボルと同じグリッドサイズのシンボルのみ、読み取りを認めます。
ON | 登録シンボルとグリッドサイズの異なるシンボルの読み取りを認めます。

チェックサム

信頼性を保証するためにエラー検出アルゴリズムを使用してシンボルを検証するかどうかを指定します。チェックサムは、シンボルに含まれるオプションのチェックサムアルゴリズムを備えたシンボルのみに適用されます。各シンボルは、固有のチェックサムアルゴリズムを備えています。使用されるチェックサム (使用可能な場合含む) のタイプは、選択したコードのタイプによって異なります。

OFF (デフォルト) | チェックサムを検証しません。
ON | チェックサムの検証に合格する必要があります。

注: Code 128、Code 93、DataBar、UPC、および EAN バーコードは、パラメータの選択にかかわらず、チェックサムによって検証されます。その他のバーコードで [チェックサム] を ON にし、チェックサムがエンコードされていない場合、読み取りに失敗します。

極性

シンボルの色を指定します。

Black | シンボルは背景よりも暗くなります。
White | シンボルは背景よりも明るくなります。
Auto (デフォルト) | シンボルの極性を自動的に選択します。

全方向読み取り

バーコードのエレメントをすべて検出するために、領域内に抽出されるスキャンラインの方向を指定します。デコードを成功させるには、バーコードのすべてのエレメント間で、少なくとも 1 つのスキャンラインを抽出する必要があります。

0 = OFF (デフォルト) | スキャンラインが 1 つの角度で抽出され、領域に対して平行なバーコードが検出されます。
1 = ON | スキャンラインが複数の角度で抽出され、領域に対して回転しているバーコードが検出されます。

注: 領域から 90 度以上回転していると、PharmaCode バーコードは正しくデコードしません。

ソートモード

順序がある場合、結果を返すときの順序を指定します。

注: シンボルを正確にソートするために、[最大結果] パラメータは、画像に含まれるシンボル数以上の値に設定する必要があります。

なし (デフォルト) | 最初にデコードされた結果から順にソートします。デコードされなかった結果は、デコードされた結果の後に表示されます。
上→下 | 行の昇順にソートします。
左→右 | 列の昇順にソートします。
アルファベット順 | 結果をアルファベット順にソートします。
文字列長 | 結果を文字列の長さの順に (短いものから長いものへ) ソートします。
行 | シンボルを行にグループ化した後、それらを各行の中で左から右へソートすることで、結果をソートします。行によるソート時に、1 つのシンボルの中心が別のシンボルの一部と垂直にオーバラップする場合、この 2 つのシンボルは同じ行に属するものとみなされます。
列 | シンボルを列にグループ化した後、それらを各列の中で上から下へソートすることで、結果をソートします。列によるソート時に、1 つのシンボルの中心が別のシンボルの一部と水平にオーバラップする場合、この 2 つのシンボルは同じ列に属するものとみなされます。

同一 1D シンボルの許容

領域内のすべてのシンボルが同一の場合でも、それらのシンボルをデコードするかどうかを指定します。長さ、シンボルの種類、およびデコードされた文字列が同一の場合、2 つのシンボルは同一とみなされます。

OFF (デフォルト) | 複数のシンボルがデコードされた場合に結果を 1 つだけ返します。
ON | 結果が同一の場合でもすべての結果を返します。
拡張 UPC-E

デコードされたシンボルが 6 桁の UPC-E 文字列を返すか、あるいは拡張された 11 桁の UPC-A 同等文字列を返すかを指定します。

OFF | デコードされたシンボルが、6 桁の UPC-E 文字列を返します。
ON (デフォルト) | デコードされたシンボルが、拡張された 11 桁の UPC-A 同等文字列を返します。
注:
  • [Expand UPC-E] パラメータは、1D/スタックドシンボルに対してのみ実装されます。
  • [Expand UPC-E] パラメータは、バージョン 4.10.1 以降のファームウェアを搭載した In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズおよび In-Sight 70xx ～ 74xx シリーズビジョンシステムでのみサポートされています。

照合

印刷品質テスト (品質検証測定ともいいます) を実行するかどうかを指定します。

OFF (デフォルト) | 品質をテストしません。
ON | 品質をテストし、スプレッドシートに結果を表示します。

注:

  • 文字列をデコードできなかった場合、スプレッドシートに自動挿入された結果すべてに、#ERR が返されます。
  • PDF 417、Pharmacode、および DataBar 以外のすべてのコード種類は、品質検証測定をサポートしています。UCC.EAN Composite コード種類は、線形 1D シンボル部分の検証測定をサポートしますが、2D 部分はサポートしていません。

タイムアウト

関数が有効な ID シンボルを検索する時間をミリ秒単位で指定します (0 ～ 30000)。この時間が経過すると、処理は中止され、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

注: ReadIDMax 関数の実行時間が、指定されたタイムアウト時間を超えることがあります。この場合には、超過分を考慮してタイムアウト時間を小さく設定してください。

表示

画像上の ReadIDMax グラフィックスオーバレイの表示モードを指定します。

注: [表示] パラメータは、データマトリックスシンボルと QR コードシンボルに対してのみ実装されます。

非表示 (デフォルト) | ReadIDMax 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力領域境界は表示されません。
結果のグラフィックスのみ | 結果のグラフィックス (データマトリックスおよび QR コード用ボックス含む) が常に表示されます。
入力と結果のグラフィックス | 入力グラフィックスと結果のグラフィックスが常に表示されます。

ReadIDMax 関数の出力

戻り値

デコードされた英数字文字列を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

結果

この関数が最初からセルに挿入されている場合、結果テーブルはこのスプレッドシートに挿入されます。結果テーブルに返されるインデックス付き文字列の数は、[最大結果] パラメータに入力された値と同じです。シンボルを配置してデコードできない場合、#ERR が返されます。

注: データマトリックスシンボルの場合、Base 256 ラッチ文字 (10 進数 231、16 進数 E7) によってエンコードされたデータは、(ISO/IEC 16022 データマトリックス仕様に従い) バイト単位で処理されます。GetStringIDMax 関数を使用して、エンコードされたデータを返します。

ReadIDMax 関数データアクセス関数

[照合] チェックボックスを OFF にした ReadIDMax 関数をスプレッドシートに配置すると、データアクセス関数が 1 つだけスプレッドシートに自動挿入されます。

文字列

GetString(ID 最大, [インデックス])

インデックス付きシンボル内でエンコードされている英数字文字列を返します。

[照合] チェックボックスを ON にした場合 (関数は追加の品質検証測定を実行します)、ReadIDMax 関数をスプレッドシートに配置すると、自動的にデータアクセス関数が挿入されます。データアクセス関数の組み合わせは、選択したコードグループによって変わります。ReadIDMax データアクセス関数を使用して、そのほかのデータの取得ができます。

注:
  • ReadIDMax 関数をスプレッドシートに配置した後で [照合] チェックボックスを ON にしても、データアクセス関数は自動挿入されません。手動でセットしたデータアクセス関数を実行するには、[照合] チェックボックスを ON にしてください。
  • データマトリックスのシンボルをデコードしている場合は、GetString 関数ではなく GetStringIDMax 関数を使用すると、デコードされたシンボルに関してより精度が高く詳細な情報を取得することができます。

関連項目

  • ReadIDMax データアクセス関数
  • ValidateIDData 関数
  • VerifyIDCode 関数
  • IDValidate データアクセス関数
  • IDVerify データアクセス関数
Version: 5.6.0


ValidateIDData 関数

ビジョンツール → ID

In-Sight 関数リファレンス

ReadIDMax 関数、または ReadIDCode 関数で初めに読み込まれた ID コードからデコードされたデータに対して、MIL-STD 130 および GS1 に準拠した検証を実行します。

  • ValidateIDData の入力パラメータ
  • ValidateIDData の出力
  • ValidateIDData データアクセス関数
  • 関連項目

注:

  • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。
  • 参照元の ReadIDMax 関数では、[照合]　パラメータをオンにしておく必要があります。
  • 参照元の ReadIDCode 関数では、[アルゴリズム]　パラメータをオンにしておく必要があります。
  • カラー In-Sight ビジョンシステムを使用する場合、ReadIDCode 関数は、カラー画像をグレースケールに変換する画像処理関数 (ColorToGreyscaleFilter など) を参照する必要があります。

ValidateIDData 関数の入力パラメータ

ValidateIDData 関数(

ID コード,

検証オプション,

DoD UID コンストラクト,

)

ID コード

この引数は、ReadIDMax 関数によって返される有効な [image] データ構造体、または ReadIDCode 関数によって返される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

注: ReadIDMax 関数を参照する場合は、[照合] パラメータを有効にする必要があります。ReadIDCode 関数を参照する場合は、[アルゴリズム] パラメータを有効にする必要があります。

検証オプション

使用する検証オプションを指定します。

0 = データ修飾子 (デフォルト)

データ内のデータ修飾子が Closed データの直前に付く指定の文字または文字列で、後に続くデータの一般的なカテゴリまたは用途を定義します。有効で、各データ修飾子に続く文字の型、長さ、値が適合することを指定します。次の 3 つのカテゴリのデータクオリファイアを検証できます。

  • アプリケーション識別子 (AI)- ISO/IEC 15434 のフォーマット 05
  • データ識別子 (DI)- ISO/IEC 15434 のフォーマット 06
  • テキスト要素識別子 (TEI)

1 = ISO 15434

検証オプションに ISO 15434 を指定します。詳細については、

www.iso.org を参照してください。

2 = DoD UID

検証オプションに米国国防総省 (DoD) の固有識別子 (UID) を指定します。詳細については、

www.acq.osd.mil/dpap/ を参照してください。

注: DoD の機械判読可能な情報 (MRI: Machine Readable Information) シンボルに関する必要最低条件は、ISO 16022 仕様によって定義された Data Matrix ECC 200 シンボルです。

3 = GS1

検証オプションに GS1 標準を指定します。詳細については、www.gs1.org を参照してください。

注:
  • In-Sight ファームウェアバージョン 4.10.1 を搭載する In-Sight Micro 1000 シリーズ、5000 シリーズ、および 70xx ～ 74xx シリーズビジョンシステムが、GS1 General Specification (GS1 仕様書) V14 に対応するようになりました。
  • In-Sight のファームウェアバージョン 5.1.0 ～ 5.3.0 は、GS1 General Specification (GS1 仕様書) V10、2010 年 1 月第一版に対応しています。
  • In-Sight のファームウェアバージョン 5.4.0 以上は、GS1 General Specification (GS1 仕様書) V14 に対応しています。

4 = securPharm (高レベル)

検査オプションに「厳しい」 securPharm (DataMatrix シンボルを使用したドイツ医薬品産業のバーコードパッケージングシステム) を指定します。医薬品番号 (PPN)、シリアル番号、ロット番号、有効期限 (GTIN はオプション) が必要です。

5 = securPharm (低レベル)

検査オプションに「緩い」 securPharm (DataMatrix シンボルを使用したドイツ医薬品産業のバーコードパッケージングシステム) を指定します。医薬品番号 (PPN) が必要です。それ以外の情報はオプションです。

DoD UID コンストラクト

検証する DoD UID コンストラクトの種類を指定します。

注: このパラメータは、[検証オプション]　パラメータの値に DoD UID が選択されている場合のみ有効になります。

0 = DoD UID コンストラクト #1 または #2 (デフォルト)

検証オプションとして、DoD UID コンストラクト #1 または #2 を指定します。

DoD コンストラクト #1 UID に準拠する場合、すべてのフィールドが検証されます。また、すべてのフィールドに少なくとも次の情報が含まれている必要があります。

  • エンタープライズ ID
  • エンタープライズ ID 内のシリアル番号

DoD コンストラクト #2 UID に準拠する場合、すべてのフィールドが検証されます。また、すべてのフィールドに少なくとも次の情報が含まれている必要があります。

  • エンタープライズ ID
  • 元の部品番号、ロット番号、またはバッチ番号
  • 元の部品番号、ロット番号、またはバッチ番号内のシリアル番号
  • 現在の部品番号、ロット番号、またはバッチ番号

1 = DoD UID コンストラクト #1

検証オプションとして、DoD UID コンストラクト #1 を指定します。

2 = DoD UID コンストラクト #2

検証オプションとして、DoD UID コンストラクト #2 を指定します。

ValidateIDData 関数の出力

戻り値 | シンボル の検証方法を含むを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、 [image] データ構造体の右隣のセルに、該当する情報文字列とともに検証ステータスが自動的に表示されます。

ValidateIDData 関数データアクセス関数

ValidateIDData 関数が初めて生成されると、次のデータアクセス関数が、結果テーブルを作成するためにスプレッドシートに自動挿入されます。

Valid | GetValid(ID 有効) | データの妥当性 (0 = 無効、1 = 有効)。
Diagnostic Info | GetDiagnosticString(ID 有効) | 診断情報文字列を返します。

IDValidate データアクセス関数を使用して、そのほかのデータを取得することができます。

関連項目

  • ReadIDMax 関数
  • ReadIDCode 関数
  • VerifyIDCode 関数
  • IDValidate データアクセス関数
Version: 5.6.0


VerifyIDCode 関数

ビジョンツール → ID

In-Sight 関数リファレンス

ReadIDMax 関数または ReadIDCode 関数によって最初に読み取られるシンボルから、コードの読み取りやすさとマークの品質に関連する測定を抽出するために使用します。

  • VerifyIDCode の入力パラメータ
  • VerifyIDCode の出力
  • VerifyIDCode データアクセス関数
  • 関連項目

注:

  • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。
  • 参照元の ReadIDMax 関数では、[照合]　パラメータをオンにしておく必要があります。
  • 参照元の ReadIDCode 関数では、[アルゴリズム]　パラメータをオンにしておく必要があります。
  • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

VerifyIDCode 関数の入力パラメータ

VerifyIDCode 関数 (

ID コード ,

メトリクス ,

IAQG 9132 メトリクス ,

Cognex メトリクス ,

最小セルサイズ ,

絞りの割合 ,

タイムアウト ,

表示

)

ID コード

この引数は、ReadIDMax 関数によって返される有効な [image] データ構造体、または ReadIDCode 関数によって返される [image] データ構造体を含んだスプレッドシートのセルを参照している必要があります。

注:ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

メトリクス

ISO 検証測定が使用されるかどうかを指定します。

注: QR コードを検証する場合、ISO 16022:2000 Enhanced と ISO 16022:2000 Traditional のみがサポートされます。

0 = なし | ISO/AIM 検証測定は、ID 検証では使用されません。
1 =ISO 16022:2000 Enhanced Closed International symbology specification - Data Matrix。 | Enhanced ISO 16022:2000 品質測定は、より強固で信頼できる ID 検証結果を出すために、高度な手法を使って計算されます。 ISO の詳細については、ここをクリックしてください。
2 = ISO 16022:2000 Traditional | Traditional ISO 16022:2000 品質測定は、ID 検証用の ISO 16022:2000 規格に記載の手法に厳密に従って計算されます。
3 =ISO 15415:2004 (デフォルト) Closed バーコード印刷品質テストの仕様 - 2D シンボル。 | ISO 15415 品質測定は、ID 検証用の ISO 15415:2004 規格で定義された要件に厳密に従って計算されます。
4 = AIM DPM-プロセス管理 | AIM DPM-プロセス管理品質測定は、AIM で定義された次の要件に従って計算されます。
5 = AIM DPM-契約適合性 | AIM DPM-契約適合性品質測定は、AIM で定義された次の要件に従って計算されます。
6 = 郵便番号検証 | 郵便番号の品質測定は、MERLIN 仕様 (ソフトウェアリリースバージョン 2.02 日付: 2002 年 6 月 20 日) で定義された要件に従って計算されます。

IAQG 9132 メトリクス

Data Matrix シンボルを検証するために、IAQG AS9132、改訂 A Closed Data Matrix (2D) Coding Quality Requirements for Parts Marking (Data Matrix (2D) 部品マーキングのためのコード品質要求事項) 検証測定が使われるかどうか (ドット楕円率を含む) を指定します。IAQG の詳細については、ここをクリックしてください。

注: IAQG 9132 測定は、QR コードの検証には対応していません。

ON (デフォルト) | IAQG 9132 検証測定が ID 検証に使用されます。
OFF | IAQG 9132 検証測定は ID 検証に使用されません。

Cognex メトリクス

Cognex の補足的な検証測定が使用されるかどうかを指定します。

ON (デフォルト) | Cognex 検証測定が ID 検証に使用されます。
OFF | Cognex 検証測定は ID 検証に使用されません。

最小セルサイズ

予測される最小モジュールとも呼ばれるセルは単一の正方形で、黒または白のいずれかになります。例えば、10×10のシンボルは、100 の黒と白のセルで構成されます。1 つのセルは、1 ビットのデータに相当します。 セルサイズを指定します (0 ～ 255、デフォルト = 0)。値 0 は現在のシンボルのセルサイズを使用します。

注: このパラメータを有効にするには、ISO 15415:2004 に ISO 測定を選択する必要があります。

絞りの割合

セルの最小値から合成開口サイズを計算するための割合 (0 ～ 100、デフォルト = 80) を指定します。この値は、検証測定の評価で使用されます。

注: このパラメータを有効にするには、ISO 15415 に ISO 測定を選択する必要があります。

タイムアウト

関数が ID シンボルを検証する時間をミリ秒単位で指定します (0 ～ 30000)。この時間が経過すると、処理は中止され、#ERR が返されます。

表示

Data Matrix シンボルと QR コードシンボルを検証するときの、画像上の VerifyIDCode グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | VerifyIDCode 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、表示されません。
1 = 結果のグラフィックスのみ | 結果のグラフィックス (Data Matrix および QR コード用ボックス含む) が常に表示されます。
2 = すべて表示: 入力、結果、およびエラーのモジュール | 入力した領域グラフィックス、結果グラフィックス (Data Matrix と QR コードのボックス)、および Closed エラーモジュール診断グラフィックス(Data Matrix のみ) が常に表示されます。 ISO 15415, AIM DPM-プロセス管理または AIM DPM-契約適合性、および AIM-DPM の両バージョンが選択されると、エラーがグラフィックス表示されます。代表的なグラフィックスは、検出されたエラーの種類によります。 カラーの四角形は、変調グレードを表します。四角形の色はグレードによります。 四角形なし = 4 • 青い四角形 = 2 または 3 • 黄色の四角形 = 1 • 赤い四角形 = 0 赤い [image] はビットエラーを表します (黒いビットが予測されていた場合は白いビット、およびその逆)。

VerifyIDCode 関数の出力

戻り値 | シンボルの検証測定を含んだ [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、検証されたシンボルのグレードが隣のセルに表示されます。シンボルを検証できない場合は #ERR が挿入されます。

VerifyIDCode 関数データアクセス関数

VerifyIDCode 関数が初めて作成されるときに、選択された検証測定に応じて IDVerify データアクセス関数が自動的にスプレッドシートに挿入されます。

関連項目

  • ReadIDCode 関数
  • ReadIDMax 関数
  • IDVerify データアクセス関数


画像フィルタ関数

ビジョンツール

In-Sight 関数リファレンス

In-Sight の画像フィルタツールは、必要とされる特徴は強調し、不必要な特徴は削除するか弱めるように、入力画像を処理します。結果として、ブロブ解析やヒストグラム分析などの追加のデータ抽出関数により適した、改善された入力画像や新しい出力画像が得られます。画像フィルタツールには次の関数があります。

  • ColorToGreyscaleFilter 関数: カラーの画像または対象領域 (ROI) 内の各ピクセルを、1 つのカラーパラメータからなる単純なフィルタに基づいて、グレースケール値に変換します (カラー In-Sight ビジョンシステムおよびカラー対応のエミュレータのみ)。
  • CompareImage 関数: 入力画像とテンプレート画像を比較し、各ピクセルが正規化された差を表すグレースケール出力画像を生成します。
  • ComputeImageSharpness 関数: In-Sight ビジョンシステムのレンズを再調整するための反復プロセスの一部として、入力画像の相対的なフォーカスの基準を計算します。
  • [フィルタ]: カラーまたはグレースケール出力画像を生成します。ここでは、各ピクセルが入力画像または ROI で画像強調技術の結果となっています。

注:この関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • FindCircleDefects 関数: ユーザが設定したしきい値に基づいて、入力画像のドーナツ状 (リング状) 領域内の各ピクセルを黒または白に変換します。白は、環状でない、または放射状でないという特徴を示します。
  • GreyscaleDistance 関数: ユーザが設定したさまざまなカラーパラメータに基づいて、カラー画像または ROI 内の各ピクセルをグレースケール値または黒および白に変換します (カラーの In-Sight ビジョンシステムまたはカラー対応のエミュレータのみ)。
  • ImageMath 関数: 各ピクセルが、2 つの入力画像間で実行された算術演算 (加算、減算、平均など) の結果となるグレースケールまたは白黒の出力画像を生成します (多目的関数の詳細については、ImageMath 関数の「入力パラメータ」セクションを参照してください)。
  • LineScanDistortion 関数: In-Sight 5604 ラインスキャンビジョンシステムで使用するために、TrainLineScanDistortion 関数の計算に基づいて、歪みのない出力画像を生成します。
  • NeighborFilter 関数: 各ピクセルが、「局所的な」画像強調技術 (縮小、拡大、塗りつぶし、平滑化、またはエッジ強度など) を入力画像または ROI の一連の隣接するピクセル (「近傍」) に適用した結果であるグレースケール出力画像を生成します (多目的関数の詳細については、NeighborFilter 関数の「入力パラメータ」セクションを参照してください)。

注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • PointFilter 関数: 各ピクセルが、「グローバルな」画像強調技術 (バイナリ、反転、ヒストグラム平坦化、グレースケール伸長またはクリップなど) を入力画像または ROI の各ピクセルに適用した結果である白黒またはグレースケール出力画像を生成します (多目的関数の詳細については、PointFilter 関数の「入力パラメータ」セクションを参照してください)。

注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • ScaleColorImage 関数: カラー入力画像または ROI のピクセルを再サンプリングして、縮小、拡大、回転または折り曲げの行われていない状態のカラー画像を生成します。
  • ScaleImage 関数: 入力画像または ROI のピクセルを再サンプリングして、縮小、拡大、回転または折り曲げの行われていない状態の画像を生成します。
  • SceneCorrection 関数: グレースケール画像を作成し、均一でない照明またはシェーディングのある画像を向上させます。

注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • SurfaceFX 関数: さまざまな方向からの照明が取り込まれた複数の画像を解析して、高コントラストの出力画像を作成し、エッジ、しわ、刻み目、および突出など、スムーズネスからの逸脱をサーフェスの高さが示す領域をハイライトします。
  • TrainLineScanDistortion 関数: In-Sight 5604 ラインスキャンビジョンシステムで使用するために、画像の領域内に存在するレンズの歪みを計算します。
  • WhiteBalance 関数: RGB (赤、緑、および青) 値を計算し、In-Sight ジョブに保存されたカラーテーブルに従ってそれらを修正することで、カラー画像の色かぶりを除去します (カラー In-Sight ビジョンシステムおよびカラー対応のエミュレータのみ)。

これらの画像フィルタ関数を操作別に表示するには、「画像処理の用途」セクションの表を参照してください。

注: 画像パラメータを必要とする関数は、有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。画像パラメータのデフォルトの参照先はセル A0 です。セル A0 には、AcquireImage 関数によって返される [image] データ構造体が含まれています。そのほかの有効な画像パラメータには、CompareImage、FindCircleDefects、NeighborFilter、および PointFilter の各関数によって返される [image] データ構造体があります。

In-Sight について画像フィルタ関数ツール

画像処理

マシンビジョンアプリケーションには、高品質な画像が必要です。画像にフォーカスが合ってない、歪みがある、または照明が不足しているなどの場合にはデータが失われます。このような状況では、ブロブ解析やヒストグラム解析などのデータ抽出関数が十分に動作できなかったり、失敗したりすることがあります。

高品質な画像を生成する最初のステップは、取り込んだ画像に鮮明にフォーカスが合い、歪みがなく、均一に照明が当たるように、機器のセットアップ時に照明やレンズなどのハードウェアと環境面の問題を確実に最適化することです。In-Sight ジョブで画像から必要なデータを抽出するのが困難な場合、第 2 のステップとして、画像フィルタ関数を使用して画像をさらに強調することができます。

すべての写真と同様、In-Sight の画像は「ラスターグラフィックス」です。ラスターグラフィックスは、画素 (「ピクセル」) からなるグリッドに、画像の特性に関する情報を保存しています。グリッドは、画像の最小で完結したサンプルであるため、拡大や縮小はできません。ラスター画像の品質は、ピクセルの総数 (別名「解像度」) と各ピクセルの情報量によって決まります。

画像の中の必要な対象物を強調し、不要な特徴は削除するか弱めるために (カラー、明度、コントラストまたはスケールなどを調整して)、In-Sight 画像フィルタ関数は、精巧な画像処理アルゴリズムを使用して、個々のピクセルまたは一連の隣接するピクセル (別名「近傍」) に対してデータを追加または除去します。

画像処理の用途

多くのユーザは画像フィルタツールを使用せずに In-Sight ジョブを作成し、ジョブで必要な結果を生成できない場合にのみツールを使用します。画像フィルタ関数は、次のいずれの場合でも使用できます。

  • 取り込んだ画像がカラーである。In-Sight ツールはグレースケール画像でのみ動作します。各ツールは画像をカラーからグレースケールに自動的に変換するように設計されていますが、画像フィルタ関数を使用して 1 回だけ変換を実行し、後続のツールは変換された画像を参照するようにするとより効率的です。
  • 取り込んだ画像の対象物と背景のコントラストが弱い。
  • 取り込んだ画像に、対象物の視覚的影響を最小化する不要な特徴が含まれている。
  • 取り込んだ画像のフォーカスがずれているため、ビジョンシステムのレンズを調整する必要がある。
  • 拡大、縮小、折り曲げまたは回転の行われていない状態の取り込み画像が、別の In-Sight ツールで必要とされている。
  • 白黒の取り込み画像が別の In-Sight ツールで必要とされている。

画像フィルタ関数は、さまざまな画像処理操作を実行できます。ほとんどの関数は特定の操作を対象としています。多目的に設計されている関数は 3 つあります。次の表は、一般的な操作とそれに使用可能な画像フィルタ関数の一覧です。

操作 | 説明 | 使用可能な画像フィルタ関数
明度/コントラスト | 各ピクセルのグレースケール値をユーザが指定した最小値または最大値に「クリッピング」 (「スケールアップ」または「スケールダウン」) して、明度とコントラストを変更します。 | Filter 関数 PointFilter 関数 SurfaceFX 関数
カラー調整 | 入力画像のカラーを変換または修正します。カラー In-Sight ビジョンシステムまたはカラー対応のエミュレータでのみ使用可能です。 | ColorToGreyscaleFilter 関数 GreyscaleDistance 関数 WhiteBalance 関数
拡大/縮小 | 入力画像または ROI 内の特徴を拡大または縮小します。 | Filter 関数 NeighborFilter 関数
塗りつぶし | 隣接するピクセルに近い外観になるように、ピクセルを白値または黒値で埋めます。 | Filter 関数 NeighborFilter 関数
フィルタ処理 | 不要なデータをブロックし、必要なデータのみを通します。 | ColorToGreyscaleFilter 関数 GreyscaleDistance 関数 Filter 関数 NeighborFilter 関数 PointFilter 関数
画像の差分 | 入力画像を、テンプレート、別の画像または形状と比較し、2 つの画像間の差を判定します。 | CompareImage 関数 FindCircleDefects 関数 ImageMath 関数
反転 | 「ネガティブ」状態の画像を作成します。 | Filter 関数 PointFilter 関数
レンズの調整 | 反復プロセスを通じてレンズのフォーカスを測定し、調整します。 | ComputeImageSharpness 関数
スケーリング (サイズ設定) | 拡大または縮小された入力画像をジョブビューに表示します。 | ScaleImage 関数 ScaleColorImage 関数
強調 | 方向 (垂直、水平) に基づいて「エッジ」(画像内でピクセルのグレースケール値が急激に変化する領域) を検出します。または、「平滑化された」画像とオリジナルの画像を比較して、エッジを強調します。 | Filter 関数 NeighborFilter 関数
平滑化 | 入力画像内の一連の隣接するピクセル (「近傍」) のグレースケール値を平均し、急速に変化するグレースケール値の影響を弱めます。 | Filter 関数 NeighborFilter 関数 SceneCorrection 関数 SurfaceFX
2 値化 | ユーザ設定のしきい値に基づき、白黒の入力画像または ROI を生成します。 | Filter 関数 FindCircleDefects 関数 GreyscaleDistance 関数 ImageMath 関数 PointFilter 関数

画像処理を使用する理由

画像の品質が低いために In-Sight ジョブが失敗する場合、必要なデータを容易に抽出できるように画像を強調するには、画像フィルタ関数が有効です。例えば、次のような場合があります。

  • ブロブ解析用にノイズを除去したり、対象物の連結性を変更したりする場合。
  • ヒストグラム解析用の統計計算のために、空間的な特徴をグレースケール値に変換する場合。
  • 2D コードの読み取り用に、背景に対する 2D シンボルのコントラストを強める場合。
  • PatFind テンプレートサーチ用に速度と信頼性を改善するために、モデルと画像ピクセルデータの両方で、曖昧または不要な空間周波数特性を最小化する場合。

画像処理の実行方法

In-Sight Explorer では、画像処理手順は、次の 3 つに分けることができます。

  • 手順 1:取り込んだ画像を分析し、画像処理が有効かどうか、どのような種類の変更が必要かを判定します。
  • 手順 2:適切な画像フィルタ関数を In-Sight スプレッドシートに挿入し、複数のパラメータを試して、画像を強調するための最適な設定値を判定します。
  • 手順 3:必要に応じて、別の画像フィルタ関数を In-Sight スプレッドシートに挿入し、前の関数の出力画像を参照させ、複数のパラメータ設定を試します。必要に応じて繰り返します。

このように、取り込んだ画像の品質を改善するには、複数の画像フィルタ関数を使用し、後続の画像フィルタ関数の出力にそれぞれ参照されるようにする必要が生じることがあります。ただし、画像フィルタツールを使用して達成できる改善の程度は、取り込んだ画像の品質によって決まります。つまり、照明や光学系などの外部要因によって多くが決まります。画像フィルタツールでは、粗悪な写真を良質な写真にすることはできません。


ColorToGreyscaleFilter 関数

ColorToGreyscaleFilter 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

カラーの In-Sight センサおよびカラーを有効にしたエミュレータのみに使用な可能な ColorToGreyscaleFilter 関数は、1 つのカラーパラメータからなる単純なフィルタに基づいて、カラーの画像または対象領域 (ROI) 内の各ピクセルを、グレースケール値に変換します。カラーパラメータとは、「純」赤、緑、青 (RGB)、色相、彩度、または明度 (HSI)、明るさ、または RGB 成分の加重平均明度の補間です。

注: GreyscaleDistance 関数と似ていますが、ColorToGreyscaleFilter 関数の操作はより簡単で、各出力ピクセルは選択した変換フィルタの機能であり、ピクセルの 1 つの成分にのみ集中します (例えば、赤の値では、GreyscaleDistance 関数のように 赤、緑、青の値を一緒にはしません)。両方で試してみて、アプリケーションに最適なカラー変換関数を決定する必要があります。

ColorToGreyscaleFilter の入力パラメータ

ColorToGreyscaleFilter の出力

ColorToGreyscaleFilter 関数の例

ColorToGreyscaleFilter 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

変換 ,

表示

)

ColorToGreyscaleFilter 関数の入力パラメータ

画像

この引数は有効なカラー [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注意: 有効なカラー [image] データ構造体を返す関数は、AcquireImage 関数だけです。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセットを指定します。
列 | 画像座標での列オフセットを指定します。
角度 | 画像座標での角度を指定します。

領域

これは対象領域 (ROI) とも呼ばれ、画像処理の対象となる画像の領域を指定します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、[領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセットを指定します。
Y | フィクスチャ座標での原点の Y オフセットを指定します。
高さ | 領域の X 軸に沿った寸法を指定します。
幅 | 領域の Y 軸に沿った寸法を指定します。
角度 | フィクスチャ座標での角度を指定します。

注: フィクスチャおよび領域パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

変換

変換フィルタのタイプを指定します。

注:

  • 各カラーピクセルは、色成分に分けられます。
  • その他の In-Sight ツールによって使用されるデフォルトの色変換は、ColorToGreyscaleFilter の補間変換フィルタに相当します。

0 = 明るさ (デフォルト) | 色の明るさ用の変換フィルタを指定します。その結果は、明るさの出力画像です。入力画像内のピクセルから放射されるライトが多くなるほど、出力画像の外観はより明るくなります。
1 = 赤 | 色の赤の成分用の変換フィルタを指定します。この結果、ピクセルの赤の成分以外はすべて除去されます。入力画像内のピクセルの赤の値が高くなるほど、出力画像の外観はより明るくなります。
2 = 緑 | 色の緑の成分用の変換フィルタを指定します。この結果、ピクセルの緑の成分以外はすべて除去されます。入力画像内のピクセルの緑の値が高くなるほど、出力画像の外観はより明るくなります。
3 = 青 | 色の青の成分用の変換フィルタを指定します。この結果、ピクセルの青の成分以外はすべて除去されます。入力画像内のピクセルの青の値が高くなるほど、出力画像の外観はより明るくなります。
4 = 色相 | 色の色相の成分用の変換フィルタを指定します。この結果、ピクセルの色相の成分以外はすべて除去されます。入力画像内のピクセルの色相の値が高くなるほど、出力画像の外観はより明るくなります (例えば、色相の値が 0 の赤は暗く表示されます)。
5 = 彩度 | 色の彩度の成分用の変換フィルタを指定します。この結果、ピクセルの彩度の成分以外はすべて除去されます。入力画像内のピクセルの彩度の値が高くなるほど、出力画像の外観はより明るくなります (例えば、彩度の値が 0 の白は暗く表示されます)。
6 = 明度 | 色の明度の成分用の変換フィルタを指定します。この結果、ピクセルの明度以外はすべて除去され、ピクセルの RGB 成分の平均明度が分かります。入力画像内のピクセルの明度の値が高くなるほど、出力画像の外観はより明るくなります (例えば、明度の値が 255 の白は明るく表示されます)。
7 = 補間 | 色の補間用の変換フィルタを指定します。明度フィルタと同様に、この結果、ピクセルの明度の成分以外はすべて除去されます。入力画像内のピクセルの明度の値が高くなるほど、出力画像の外観はより明るくなります (例えば、明度の値が 255 の白は明るく表示されます)。ただし、補間フィルタは RGB 成分の加重平均明度を決定するので、非標準の変換フィルタです。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | ColorToGrayscaleFilter 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

ColorToGreyscaleFilter 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

ColorToGreyscaleFilter 関数の例

この例では、入力画像内の対象物は黄色の Cognex センサであり、GreyscaleDistance 関数の例でも使用されています。画像のランダムサンプリング ([表示] メニューで [オーバレイ] を選択し、センサ上でカーソルを動かしてウィンドウの左下隅にあるステータスバーに RGB 情報を表示することで、オーバーレイビューをオフに切り替えて実行します) は、このセンサについて 205-185-124、193-177-110、175-154-39、133-104-2、および 115-91-6 の RGB 値を表示します。

In-Sight スプレッドシートに関数を挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。画像の上に赤い ROI ボックスが現れます。カーソルを使用してボックスを移動するかサイズを変更してから、In-Sight ツールバーにある緑の「チェックマーク」アイコンをクリックし (または、キーボードの Enter キーを押し)、選択を確定してプロパティシートに戻ります。

変換フィルタを選択し、そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

赤、緑、青のフィルタが適用された 3 つの出力画像を、それぞれ下記に示します。予測されるように、センサの黄色は赤のフィルタが適用された画像で最も明るくなっています。これは、黄色のセンサでは赤が最も強い色成分だからです (画像の赤の最大の値は 210、平均は 116、中央値は 127 です)。入力ピクセルの値がフィルタの値に近いほど、出力ピクセルは明るくなります。

センサの黄色は、緑のフィルタが適用された画像ではわずかに暗くなります。これは、赤と比較して、含まれている緑が少ないからです (最大は 199、平均は 112、中央値は 125)。

センサの黄色は、青のフィルタが適用された画像で最も暗くなります。これは、赤と比較して、含まれている青が少ないからです (最大は 197、平均は 101、中央値は 121)。

関連項目

画像ツールについて

画像データアクセス関数

プロパティシートの使用方法


CompareImage 関数

CompareImage 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

入力画像とテンプレート画像を比較し、各ピクセルが正規化された差異を表すグレースケール出力画像を生成します。

  • CompareImage 関数の概要
  • CompareImage の入力パラメータ
  • CompareImage の出力
  • CompareImage 関数の例
  • 関連項目

CompareImage 関数概要

CompareImage 関数は、プロパティシートで [登録を強制] チェックボックスをオンにすると、現在の画像からテンプレートを抽出するように設計されています。このチェックボックスをオフにすると、CompareImage 関数はテンプレートのピクセルを入力画像にマッピングし、これらを比較してグレースケールの出力画像を作成します。特定の許容値内にあるテンプレート画像と一致しないピクセルは、明るい、つまり白いピクセルとして表示されます。

CompareImage 関数の入力パラメータ

CompareImage 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

登録を強制 ,

Edge Range ,

補間 ,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

登録を強制

いつテンプレートを現在の画像から抽出するかを指定します。ROI のサイズが変更されたとき、または [登録を強制] パラメータが選択されたときのいずれかです。

0 = OFF (デフォルト) | ROI のサイズが変更されたときにのみ、現在の画像からテンプレートが抽出されます。ユーザがテンプレート画像を選択 (または「登録」) 済みの場合にこれを選択すると、「登録」パラメータが無効になり、テンプレートが上書きされないよう防ぎます。
1 = ON | テンプレートが現在の画像から抽出されます。ユーザがまだテンプレート画像を選択 (または「登録」) している場合には、これが選択されます。

Edge Range

画像の比較時に許容される、エッジ周囲のピクセルの数を指定します (0 ～ 24、デフォルト = 3)。この数値が高いほど、テンプレートと入力画像間で一致するエッジが厳密ではなくなります (つまり、不完全で一致しそうにないエッジは、出力画像で「差異」として表されます)。

補間

テンプレートを入力画像にマッピングして差異の出力画像を作成する場合に実行する、ピクセルの比較のタイプを指定します。

0 = 最も近い近傍 (デフォルト) | テンプレートの各ピクセルが、入力画像の最も近いピクセルと比較されて、各ピクセルの正規化されたグレースケールの差異を計算します。これはより高速ですが、より精度の低い方法です。
1 = バイリニア | テンプレートの各ピクセルが加重平均 (入力画像内の最も近い 4 つのピクセルのグレースケール値を表します) と比較されて、各ピクセルの正規化されたグレースケールの差異を計算します。これはより正確ですが、低速な方法です。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | CompareImage 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、使用可能なグラフィックス項目は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域と関連付けられているグラフィックス項目が常に表示されます。
3 = 全て表示: 入力グラフィックスおよびテンプレート画像 | 入力画像領域に関連付けられているグラフィックス項目が常に表示されますが、CompareImage プロパティシートでは、テンプレート画像も表示されます。

CompareImage 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

CompareImage 関数例

この例では、CompareImage 関数を使用して、「良好な」ガスケットのテンプレート画像と生産ライン上のガスケットの入力画像を比較することを目的としています。

最初に、CompareImage 関数をスプレッドシートに挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。画像の上に赤い ROI ボックスが現れます。カーソルを使用してボックスを移動するかサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし (または、Enter キーを押し)、選択を確定してプロパティシートに戻ります。

次に、ツールを別のデータ構造体に固定します。固定するときに、対象物のすべてのインスタンスに表示される際立った特性を識別して、後続のビジョンツールの参照点として指定します。参照点によって、対象物が生産ライン上でわずかに回転したりずれたりした場合でも、正確な比較または検査を行うことができます。

この関数を固定するには、プロパティシートで「固定」という単語をクリックし、プロパティシートのツールバーにある [絶対参照] [image] または [相対参照] [image] ボタンのいずれかをクリックします。

プロパティシートが非表示になり、In-Sight スプレッドシートが表示されます。カーソルを移動して、スプレッドシート内の別のデータ構造体 (例えば FindPatterns) から [行]、[列]、[角度] のセルをフィクスチャの参照点として選択し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし (または Enter キーを押し)、選択を確定してプロパティシートに戻ります。

次に、プロパティシートの [登録を強制] チェックボックスがオンになっていることを確認して、画像の取り込みを手動でトリガすると、自動的にテンプレート画像 (下記) が抽出されるようにすることができます。ただし、単純に [登録を強制] チェックボックスをオンにすれば、画像の取り込みがトリガされるので、現在の画像が受け入れられたら、画像の設定および取り込みの手動でのトリガをスキップすることができます。テンプレートを選択したら、このチェックボックスをオフにして、テンプレートが上書きされないようにします。

そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

ランタイム時に、このツールはテンプレート画像を入力画像と比較します。「不良」入力画像は、白い跡 (下記) によって損なわれたガスケットで構成されていることがあります。

2 つの差異は、グレスケールの出力画像内で明るいピクセルとして表示されます (下記)。

別のツール (例えば ExtractBlobs、下記を参照) では、出力画像を参照して、ガスケットが検査に合格したか不合格であるかを決定します。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


ComputeImageSharpness 関数

ComputeImageSharpness 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

ComputeImageSharpness 関数で、In-Sight ビジョンシステムのレンズを再調整するための反復プロセスの一部として、入力画像の相対的なフォーカスの基準を計算します。

  • ComputeImageSharpness 関数の概要
  • ComputeImageSharpness の入力パラメータ
  • ComputeImageSharpness の出力
  • ComputeImageSharpness 関数の例
  • 関連項目

ComputeImageSharpness 関数概要

「画像シャープネス得点」と呼ばれるこの手段は、「シーン」(つまり、その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または対象領域 (ROI) に含まれる度合を示します。

操作はシンプルです。画像を取り込むと、ComputeImageSharpness 関数このツールによって画像シャープネス得点が取得されます。次に、再度レンズの焦点が合わされ、シーン内では何も変わりませんが、新しい画像が取り込まれて得点付けされます。得点が高いほど、よりシャープに焦点が合わされます。このプロセスは、ユーザが焦点を受け入れられるまで繰り返されます。

注: 画像シャープネス得点 1 つでは、画像の絶対的なシャープネスに関して有用な情報は得られません。まったく同じシーンの別の画像シャープネス得点と比較する必要があります。シーンは同じであることが必要です。

ComputeImageSharpness 関数の入力パラメータ

ComputeImageSharpness 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

操作,

スムーズネス,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

操作

[勾配エネルギー]: 画像または ROI の「ローカルグレーレベル勾配」のエネルギーに基づいて、画像シャープネス得点を計算します。ローカルグレーレベル勾配は、指定したエリアでのグレースケール値の変化の割合を表します。グレースケールでの突然の変化は、グレーレベル勾配で大きな等級となり、画像シャープネス得点が高くなります。

スムーズネス

ROI 内に存在することがある高周波のノイズを除去できるように、画像スムージング操作を指定します。次の 3 つの設定があります。

0 = なし (デフォルト) | スムージングは行われません。高速のパフォーマンスが得られます。
1 = スムージングレベル 1 | ある程度のスムージングが ROI に適用されます。ROI 内の超高周波のノイズを除去します。
2 = スムージングレベル 2 | さらに上の度合いのスムージングが ROI に適用されます。ROI 内の高周波および超高周波のノイズを除去します。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | ComputeImageSharpness 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、使用可能なグラフィックス項目は表示されません。
1 = 入力のグラフィックスのみ | 入力画像領域と関連付けられているグラフィックス項目が常に表示されます。

ComputeImageSharpness 関数の出力

戻り値

浮動小数点で表された画像シャープネス得点。入力パラメータが無効の場合は #ERR が返されます。

ComputeImageSharpness 関数例

この例では、入力画像の対象物は Cognex ビジョンシステムです。

最初に、ライブビデオモードでレンズの焦点を調整します。これを入力するには、ジョブディスプレイツールバーにある [ライブビデオ] [image] ボタンをクリックし、キーボード上の任意のキーを押すか、再度 [ライブビデオ] ボタンをクリックして終了します。

ライブビデオモードの終了後、In-Sight スプレッドシートに関数を挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。画像の上に赤い ROI ボックスが現れます。カーソルを使用してボックスを移動してサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし、選択を確定してプロパティシートに戻ります。Enter キーを押すか、ROI 内をダブルクリックすることで、選択を確定することもできます。

そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

下記の 2 つの画像は、Cognex ビジョンシステムの不鮮明な画像と、画像シャープネス得点が 3.161 であることを示すオーバーレイビューを示しています。

ライブビデオモードでレンズの焦点を調節すると、画像は不鮮明ではなくなってきます。ライブビデオモードを終了すると、新しい画像シャープネス得点 10.952 を表示することができます。

画像はまだ不鮮明なので、ライブビデオモードで焦点の調節を続行する必要があり、対象物の焦点がシャープになるまで、画像シャープネス得点を比較します。焦点が不十分なままの場合は、レンズ、レンズと対象物との距離、またはその他のハードウェアパラメータを変更する必要があることがあります。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法
Version: 5.6.0


Filter

ビジョンツール → 画像

In-Sight 関数リファレンス

カラーまたはグレースケール出力画像を生成します。ここでは、各ピクセルが入力画像または ROI で画像強調技術の結果となっています。

  • Filter 関数の概要
  • Filter の入力パラメータ
  • Filter 関数の出力結果
  • 関連項目

注:この関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

Filter概要

多目的関数である Filter で、低コントラスト画像や画像内の特徴を強調するのに使用される、カラーまたはグレースケール出力画像を生成します。この関数は、検出したい特徴を強調したり、不要な特徴を最小にしたりするのに有効です。効果的に使用することによって、検査アプリケーションの信頼性と再現性を高めることができます。

Filter 関数では、さまざまな種類のローカルおよびグローバル画像強調技術を使用することができます。[フィルタタイプ] から、使用する画像強調技術を選択してください。

Filter 関数の使用方法

Filter 関数の設定には、画像の強調に使用する [フィルタタイプ] を選択することで、画像強調技術を指定することが含まれます。

最初に、画像をロードします。Filter 関数をスプレッドシートに挿入し、強調する画像領域を囲むように [領域] を調整します。[領域] の設定時には、強調する必要のある画像の領域のみを囲むようにします。強調の必要がない領域を囲むと、画像強調技術の適用方法および関数の実行時間の両方に影響します。

次に、適切な [フィルタタイプ] を選択します。選択した [フィルタタイプ] に応じて追加のパラメータが有効になり、この技術の適用方法をさらに定義できます。有効になったパラメータを調整して、適切な画像強調エフェクトを実現します。

注:
  • 強調を必要とする画像の領域が動きを有する場合、[フィクスチャ] を使用して [領域] がその領域に応じて移動することを確認してください。
  • 開始前に、検査対象の画像のデータベースを収集します。画像は [記録/再生のオプション] ダイアログを使用してロードすることができます。
  • 関数を設定したら、追加の画像をロードし、必要に応じてパラメータを調整して、画像の範囲全体に画像強調技術が正しく適用されていることを確認します。

Filterの入力パラメータ

Filter(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

フィルタタイプ ,

カーネル行 ,

カーネル列 ,

自動しきい値 ,

しきい値 ,

最小 ,

最大 ,

ゲイン ,

スムーズネス ,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高 | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

フィルタタイプ

実行する画像強調技術のタイプを指定します。結果は、グレースケール出力画像で表示されます。

0 = 2 値化 (デフォルト)

各入力ピクセルとしきい値を比較する白黒 (「2 値化」) のしきい値操作を指定して、出力ピクセルが白か黒かを特定します。[しきい値] パラメータ以上の入力ピクセル値は白であり、しきい値未満の値は黒です。

注: カラー入力画像が使用される場合、出力画像はグレースケール画像となります。

1 = ボトムハット

「ボトムハット」フィルタ処理操作を指定します。この操作は、近傍カーネルのサイズより小さい、暗い特徴以外のすべてを除去します。結果は、これらの暗い特徴が明るいピクセルで表示され、背景が暗く表示された出力画像になります。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

2 = クリップ

グレースケールスペクトルの両端を除去する「クリッピング操作」を指定して、出力画像内の特徴をより均一にします。この操作で、各入力ピクセルのグレースケール値と、[最小] および [最大] パラメータ値とを比較します。

  • 入力ピクセル値が最小値または最大値と同じかそれを超える場合、出力ピクセルはそれぞれ最小値または最大値に割り当てられます (クリッピングされます)。
  • 入力ピクセル値が最小値と最大値の範囲内の場合、出力ピクセルは入力ピクセルの値に割り当てられます。

3 = クローズ

「クロージング」操作を指定します。この操作はダイレーションの後にエロージョンを実行し、近傍カーネルのサイズより小さい、暗い特徴を除去します。画像をクロージングすると、画像の暗い領域を削減または完全に削除します。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

4 = 膨張

「ダイレーション」操作を指定して、画像の明るい特徴を強調する一方で、暗い特徴は表示しません。結果は、明るいピクセルがより大きな領域を占める出力画像になります。暗い斑点の除去に有効です。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

5 = エッジ強度

入力画像のダイレーションとエロージョンの差を表示する操作を指定します。結果は、エッジが明るいピクセルで表示された出力画像になります。この操作は、勾配 全方向に似ていますが、より複雑な対角線方向のエッジを表現できます (ただし、より時間がかかります)。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

6 = 等化

ヒストグラム平坦化操作を指定して、入力画像のヒストグラムを抽出し、最も多いグレースケール値を分散させて、分布をより均一にします。その結果、出力画像はコントラストが強調されます。照明が 1 つの画像から次の画像へわずかに変化する環境や、検査対象の一部の外観がわずかに変化する可能性がある場合に、このタイプのフィルタが役立ちます。

7 = 収縮

画像の明るい特徴を削減する「エロージョン」操作を指定します。結果は、暗いピクセルがより大きな領域を占める出力画像になります。明るい斑点 (ノイズピクセルおよび/または小さな欠陥) の除去に有効です。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

8 = 黒穴塗りつぶし

明るいピクセルで囲まれた暗いピクセルを明るいピクセルに変換する「ピクセル塗りつぶし」操作を指定します。結果は、暗い穴が塗りつぶされた出力画像になります。

9 = 白穴塗りつぶし

暗いピクセルで囲まれた明るいピクセルを暗いピクセルに変換する「ピクセル塗りつぶし」操作を指定します。結果は、明るい穴が塗りつぶされた出力画像になります。

10 = 勾配 全方向

「垂直方向および水平方向の傾斜」操作を指定します。結果は、垂直方向および水平方向のエッジが明るいピクセルで表示された出力画像になります。この操作は、エッジ強度に似ていますが、より簡易で (処理が早く)、対角線方向のエッジは表現しません。

11 = 勾配 水平方向

「水平方向の傾斜」操作を指定します。結果は、水平方向のエッジが明るいピクセルで表示された出力画像になります。

12 = 勾配 垂直方向

「垂直方向の傾斜」操作を指定します。結果は、垂直方向のエッジが明るいピクセルで表示された出力画像になります。

13 = グレースケール距離

各出力ピクセルのグレースケール値を、各入力ピクセルのグレースケール値としきい値レベルの差として指定します (例えば、入力ピクセル値が 100 で、しきい値が 25 の場合、出力ピクセルは 75 となります)。これは [しきい値] パラメータで指定されます。

14 = ハイパス

「ハイパス」操作を指定します。結果は、むらのないグレースケール勾配を持つ領域に対し、相対的にエッジが強調された出力画像となります。このタイプのフィルタは、高精度の特徴を強調する場合に有用です。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

15 = 反転

256 諧調のグレースケールに基づいてピクセル値の反転を指定します。結果は、入力画像の「ネガティブ」である出力画像になります (例えば、入力ピクセル値 10 を反転すると、出力ピクセル値 245 になります)。

17 = ローカル中央値

近傍カーネル内のピクセル値の中央ピクセル値を計算し、その結果を出力画像のピクセル値に使用します。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

18 = 正規化したローカル中央値

画像から背景を減算します。この操作は、入力画像から入力画像のローカル中央値を減算し、結果を右に 1 つシフトし、128 を加算して出力ピクセル値を生成します。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

19 = ローパス

「ローパス」操作を指定します。結果は、エッジが平滑化された、またはぼやけた出力画像になります。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

20 = 最大 (トップハット/ボトムハット)

トップハットおよびボトムハット操作の最大値を使用する操作を指定します。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

21 = オープン

「オープニング」操作を指定します。この操作はエロージョンの後にダイレーションを実行し、近傍カーネルのサイズより小さい明るい特徴を除去します。結果は、明るさ全体がわずかに減少した出力画像になります。少量の明るいピクセルが削除され、残りの明るい特徴が強調されています。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

22 = 光密度

ピクセル値の反転を出力ピクセル値 = 100 × log (255) - 100 × log (入力ピクセル値) 対数尺度に基づいて指定します。出力画像はオブジェクトの密度や、入力画像を通過する光の総量を計測した結果としての特徴が現れます。高密度のオブジェクトや特徴は、出力画像の明るいピクセルで表現されます。

23 = シャープ

エッジ強調に使用する「シャープネス」操作を行います。隣接ピクセル間のコントラストを評価し、高コントラストの場合、コントラストを上げます。隣接ピクセル間の大きなコントラスト差は、通常エッジを表します。しかし、この操作はローカルエッジの検出ために使用されるべきではありません。この操作の効果は、画像コンテンツおよび解像度によって異なります。

  • [スムーズネス] パラメータを使用して、ガウス (ガウシアン) カーネルを作成することによってエッジを識別します。
  • [ゲイン] パラメータはシャープネスの強度を決定します。ピクセル間の一定の差を無視することによって、軽い陰影のあるエリアを過度にシャープにしてしまうことを防ぎます。

24 = 引き伸ばし

入力画像内のグレースケール値を ([最小] および [最大] パラメータ設定に基づいて) 最大の 256 階調のグレースケールまで直線的に「スケールアップ」または「引き伸ばし」します。結果は、コントラストが強められた出力画像になります。入力ピクセル値が最小値または最大値と同じかそれを超える場合、出力ピクセルはそれぞれ 0 または 255 に割り当てられます。最小値または最大値以内の入力ピクセル値の場合、直線的に 0 ～ 255 の範囲に引き伸ばされます。例えば、[最小] が 50 で [最大] が 180 の場合、この操作では各ピクセルの明度から 50 を減算し、範囲を 0 ～ 130 にします。次に各ピクセルの明度を 255/130 で乗算し、0 ～ 255 の範囲を作成します。

25 = しきい値範囲

各入力ピクセルと 2 つのしきい値 ([最小] および [最大]) を比較する白黒 (「2 値化」) のしきい値操作を指定して、出力ピクセルが背景か前景かを特定します。入力ピクセル値が最小値または最大値以内の場合、出力ピクセルはその値を保持し、最小値または最大値の範囲外である場合は、出力ピクセルは背景レベルに設定されます。

注: 最小値が最大値よりも大きい場合は、背景が反転されます。

26 = トップハット

「トップハット」フィルタ処理操作を指定します。この操作は、近傍カーネルのサイズより小さい、明るい特徴以外のすべてを除去します。結果は、これらの明るい特徴が明るいピクセルで表示され、それ以外の背景が暗く表示された出力画像になります。

注:この操作により、[カーネル行] パラメータと [カーネル列] パラメータが有効になります。カーネルは、奇数の整数である必要があります。

カーネル行

カーネル行数 (1 ～ 25、デフォルト = 3) を指定します。カーネルとは長方形の数配列のことで、画像の各ピクセル位置に対して近傍処理操作を行います。ピクセルの近傍グレースケール値は、出力画像上のピクセル位置のグレースケール値を定義します。

注:
  • カーネルは非加重です。
  • カーネルは、奇数の整数である必要があります。通常、カーネルは 3 × 3 ですが、そのサイズは任意です。

このパラメータは、フィルタタイプが次のずれかに設定されている場合に、ON になります。

  • ボトムハット
  • クローズ
  • 膨張
  • エッジ強調
  • 収縮
  • ハイパス
  • ローカル中央値
  • 正規化したローカル中央値
  • ローパス
  • 最大 (トップハット/ボトムハット)
  • オープン
  • トップハット

カーネル列

カーネル列数を指定します (1 ～ 25、デフォルト = 3)。カーネルとは長方形の数配列のことで、画像の各ピクセル位置に対して近傍処理操作を行います。ピクセルの近傍グレースケール値は、出力画像上のピクセル位置のグレースケール値を定義します。

注:
  • カーネルは非加重です。
  • カーネルは、奇数の整数である必要があります。通常、カーネルは 3 × 3 ですが、そのサイズは任意です。

このパラメータは、フィルタタイプが次のずれかに設定されている場合に、ON になります。

  • ボトムハット
  • クローズ
  • 膨張
  • エッジ強調
  • 収縮
  • ハイパス
  • ローカル中央値
  • 正規化したローカル中央値
  • ローパス
  • 最大 (トップハット/ボトムハット)
  • オープン
  • トップハット

自動しきい値

[フィルタタイプ] を [2 値化]、[グレースケール距離] または [しきい値範囲] に設定した場合に、しきい値レベルを自動的に設定するかどうかを指定します。

注: デフォルトでは、このパラメータは有効になっています。[しきい値] パラメータを使用する場合は、このパラメータを無効にします。

  • このパラメータが有効になっているときに [フィルタタイプ] を [2 値化] に設定すると、指定領域内のグレースケール値に基づいて、しきい値レベルが自動的に設定されます。
  • このパラメータが有効になっているときに [フィルタタイプ] を [グレースケール距離] に設定すると、指定領域内の平均グレースケール値に基づいて、しきい値レベルが自動的に計算されます。
  • このパラメータが有効になっているときに [フィルタタイプ] を [しきい値範囲] に設定すると、自動的に次の内容が適用されます。
    • ピクセル値が [最小] パラメータ設定より小さい場合、あるいはピクセル値が [最大] パラメータ設定より大きい場合、ピクセル値は背景に設定されます。
    • ピクセル値が [最小] および [最大] パラメータ設定の範囲内にある場合、 ピクセル値は前景に設定されます。

しきい値

[フィルタタイプ] を [2 値化]、[グレースケール距離] または [しきい値範囲] に設定した場合に、しきい値レベルを設定します (0 ～ 255、デフォルト = 128)。

注:
  • デフォルトでは [自動しきい値] パラメータが有効になっています。[しきい値] パラメータを有効にするには、[自動しきい値] を無効にします。

最小

[フィルタタイプ] を [クリップ]、[引き伸ばし] または [しきい値範囲] に設定した場合に、最小グレースケール値を指定します (0 ～ 255、デフォルト = 128)。

最大

[フィルタタイプ] を [クリップ]、] または に設定した場合に、最大グレースケール値を指定します (0 ～ 255、デフォルト = 128)。

ゲイン

[フィルタタイプ] を [シャープ] に設定した場合に、ゲイン値を指定します (0 ～ 10、デフォルト = 1)。このパラメータは、エッジコントラストの強度を制御することによって、シャープネス強度を決定します。エッジ周囲のピクセルはその最小値または最大値により、エッジをよりシャープにします。

スムーズネス

[フィルタタイプ] を に設定した場合に、ガウス (ガウシアン) カーネルのスムーズネス値を指定します (1 ～ 4、デフォルト = 1)。スムーズネスは、ガウス (ガウシアン) カーネルの標準偏差を制御します。高スムーズネス値は、スムーズ操作では広い「絞り」となり、特徴をシャープにするのに役立ちます。

注: ガウス (ガウシアン) とは釣鐘型の曲線のことを指し、ROI 内のピクセルに加重平均を適用します。

表示

画像の上に表示されるグラフィックスオーバーレイを指定します。

0 = 非表示 (デフォルト) | Filter 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

Filterの出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注:
  • データ構造体にある処理済みの画像領域の内容は、ジョブとともに保存されることはありません。
  • この関数が返す値の追加情報については、画像データアクセス関数から参照できます。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


FindCircleDefects 関数

FindCircleDefects 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

FindCircleDefects 関数は、ユーザが設定したしきい値に基づいて、入力画像の「円環」(リング状) 領域内の各ピクセルを黒または白に変換します。白は、真円でない特徴または放射が均一でない特徴を示します。ユーザは、画像上に円環を定義して配置し、関数が円方向と放射方向のどちらの方向にピクセル勾配を計算するかを選択します。しきい値以上になる値は、白黒の出力画像内で白ピクセルとして表示されます。

  • FindCircleDefects の入力パラメータ
  • FindCircleDefects の出力
  • FindCircleDefects 関数の例
  • 関連項目

FindCircleDefects 関数の入力パラメータ

FindCircleDefects 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

ドーナツ領域.X,

ドーナツ領域.Y,

ドーナツ領域.内側半径,

ドーナツ領域.外側半径,

欠陥タイプ,

ずれ,

アクセプトしきい値,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

ドーナツ領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能なドーナツ状画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
内側の半径 | 内側の半径のサイズ。
外側の半径 | 外側の半径のサイズ。

注:[フィクスチャ] パラメータと [ドーナツ領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

欠陥タイプ

関数が検出する欠陥のタイプとして、円または放射を指定します。周囲のピクセルとグレースケール値が異なるピクセルは、欠陥である可能性があります。

0 = 環状でない特徴 (デフォルト) | 円形からの偏差を検出するために、ドーナツ領域内のピクセル勾配を円方向に計算するように指定します。
1 = 放射状でない特徴 | 放射状の特徴から偏差を検出するために、ドーナツ領域内のピクセル勾配を放射方向に計算するように指定します。

ずれ

欠陥検出の許容度を指定します。

0 = OFF (デフォルト) | 対象物が円形で、円環の中央に位置していることを指定します。許容度の低い設定です。
1 = ON | 対象物が楕円形でも、ドーナツ領域の中央からずれていてもかまわないことを指定します。許容度の高い設定です。

アクセプトしきい値

欠陥のしきい値をグレースケール値で指定します。(0 ～ 255、デフォルト = 30)

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | FindCircleDefects 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、使用可能なグラフィックス項目は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域と関連付けられているグラフィックス項目が常に表示されます。

FindCircleDefects 関数の出力

戻り値 | 白黒の (「バイナリ」) 画像を格納している [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindCircleDefects 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindCircleDefects 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

暗ピクセル | GetDarkPixelCount(画像) | 欠陥しきい値を下回るピクセルの数を返します。ピクセルは黒で表示されます。
明ピクセル | GetBrightPixelCount(画像) | 欠陥しきい値以上のピクセルの数を返します。ピクセルは白で表示されます。

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

面積

GetArea(画像)

領域の面積を返します。

FindCircleDefects 関数例

この例では、FindCircleDefect の機能を示すために、下に示す人工の円形対象物 (左側) と放射状対象物 (右側) を使用しています。どちらの対象物も色は中間のグレーで、内側および外側に太く暗い境界線があるのが特徴です。

In-Sight スプレッドシートに関数を挿入した後、プロパティシートで「Annulus」という単語をダブルクリックして円環を定義します。画像の上に赤い円環が現れます。カーソルを使用して円環を移動するかサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし、選択を確定してプロパティシートに戻ります。Enter キーを押すか、円環内をダブルクリックすることで、選択を確定することもできます。下の図は、円環が表示された対象物の画像です。

欠陥タイプ (真円でないか、放射状が均一でない) を選択し、偏差の許容を「オン」または「オフ」にして、ほかのパラメータについてはデフォルト設定を受け入れます。プロパティシートの [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

下の図は、円形対象物の白黒出力画像です。関数は真円でない欠陥を検出するよう設定され、[アクセプトしきい値] パラメータはデフォルト値の 30、偏差の許容は「オフ」(左) と「オン」(右) です。円形対象物の外側のエッジは、滑らかな円のカーブの一部に見えているにもかかわらず、欠陥の可能性ありとしてマーキングされているため、「オフ」(左) に設定した方が厳密であることがわかります。

下の図は、同じ円形対象物の白黒出力画像ですが、関数は放射状が均一でない欠陥を検出するように設定されています。関数は、外側境界線の内側エッジと外側エッジを放射状が均一でない欠陥の可能性ありとしてマーキングしています。

下の図は、放射状対象物の白黒出力画像です。関数は放射状が均一でない欠陥を検出するように設定され、[アクセプトしきい値] パラメータは 70、偏差の許容は「オフ」(左) と「オン」(右) です。ここでも、放射状の特徴の外側エッジが欠陥の可能性ありとしてマーキングされているため、「オフ」(左) に設定した方がより厳密であることがわかります。

下の図は、同じ放射状対象物の白黒出力画像ですが、ツールは真円でない欠陥を検出するように設定されています。関数は、円環内のすべての放射特徴を真円でない欠陥の可能性ありとしてマーキングしています。

実世界の用途では、ユーザは、結果に関する判定を下すために、この後出力画像を別のツールで参照することになります。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法

Version: 5.6.0


GreyscaleDistance 関数

GreyscaleDistance 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

カラーの In-Sight センサおよびカラーを有効にしたエミュレータのみに使用可能な GreyscaleDistance 関数は、次のさまざまなユーザ設定のカラーパラメータに基づいて、カラーの画像または対象領域 (ROI) 内の各ピクセルを、グレースケール値、つまり白黒に変換します。カラー表現 (赤、緑、および青、または色相、彩度、明度) および RGB または HSI カラーとしきい値に関するユーザ入力値です。グレースケール画像は、各ピクセルのカラーのユークリッド距離から得られます。

Closed ユークリッド距離に関する詳細情報

各ピクセルは 3 つの個別の色成分によって構成されています。RGB または HSI です。GreyscaleDistance 関数は、各ピクセルの全体的な RGB または HSI の値を計算し、「ユークリッド距離」を使用してその最も近いグレースケールの一致を検出します。ユークリッド距離は、ルーラで計測することができる 2 つの点の間の「通常の」距離として定義され、大部分のユーザが「距離」について話すときに指すものです。ユークリッド距離は、ピクセルの色成分の差の二乗の合計の平方根を取得することによって計算します。数式は次のとおりです。

式の内容:

x0 = プロパティシートの [カラー] セクションで、ユーザが指定した赤/色相の値

x1 = 入力ピクセルの実際の赤/色相の値

y0 = プロパティシートの [カラー] セクションで、ユーザが指定した緑/彩度の値

y1 = 入力ピクセルの実際の緑/彩度の値

z0 = プロパティシートの [カラー] セクションで、ユーザが指定した青/明度の値

z 1 = 入力ピクセルの実際の青/明度の値

D の値は 0 ～ 442 であり、0 は完全一致を表し、442 は一致がないことを表します。それぞれの D の値を [image] 3 (成分の数の平方根) で除算し、グレースケールスペクトラムに反転します。そこで 0 は黒 (一致なし)、255 は白 (完全一致) です。

注: ColorToGreyscaleFilter 関数と似てはいますが、GreyscaleDistance 関数はより多くのコントロールと柔軟性をユーザに提供します。1 つ大事なこととして、「不純な」色 (つまり、グレーまたは白を含んでいる色) は、「純粋な」色のみのフィルタを含んでいる ColorToGreyscaleFilter 関数よりも、GreyscaleDistance 関数を使用した方が良好に変換されます。両方で試してみて、アプリケーションに最適なカラー変換関数を決定する必要があります。

GreyscaleDistance の入力パラメータ

GreyscaleDistance の出力

GreyscaleDistance 関数の例

GreyscaleDistance 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

カラー表現 ,

カラー.赤/色相 ,

カラー.緑/彩度 ,

カラー.青/明度 ,

しきい値.赤/色相 ,

しきい値.緑/彩度 ,

しきい値.青/明度 ,

表示

)

GreyscaleDistance 関数の入力パラメータ

画像

この引数は有効なカラー [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注意: 有効なカラー [image] データ構造体を返す関数は、AcquireImage 関数だけです。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセットを指定します。
列 | 画像座標での列オフセットを指定します。
角度 | 画像座標での角度を指定します。

領域

これは対象領域 (ROI) とも呼ばれ、画像処理の対象となる画像の領域を指定します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、[領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセットを指定します。
Y | フィクスチャ座標での原点の Y オフセットを指定します。
高さ | 領域の X 軸に沿った寸法を指定します。
幅 | 領域の Y 軸に沿った寸法を指定します。
角度 | フィクスチャ座標での角度を指定します。

注: [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

カラー表現

カラー変換に使用するカラー表現を指定します。

0 = RGB (デフォルト) | 赤、緑、青
1 = HSI | 色相、彩度、明度

カラー

選択されたカラー表現に応じて、カラー変換に使用するカラーを指定します。3 つすべてのカラー値としきい値は、出力画像のピクセルの外観に反映されます。例えば、3 つのしきい値がすべて -1 に設定されている RGB 255-0-0 は、出力画像ですべての「純」赤のピクセルを白として表示し、その他の色はすべて、255-0-0 からのユークリッド距離に応じて暗いグレースケール値として表示します (例えば、白は暗く表されます)。

赤/色相

0 ～ 255 (デフォルト = 0)

カラーの赤/色相の成分を指定します。

緑/彩度

0 ～ 255 (デフォルト = 0)

カラーの緑/彩度の成分を指定します。

青/明度

0 ～ 255 (デフォルト = 0)

カラーの青/明度の成分を指定します。

しきい値

選択されたカラー表現に応じて、各カラー座標の白黒 (「バイナリ」) のしきい値を指定します。

注: 3 つのしきい値のデフォルトはすべて -1 であり、ユークリッド距離に基づいてグレースケールの出力画像を生成します。

[Threshold] パラメータが -1 よりも大きい整数に設定された場合は、指定されているしきい値に基づいて、出力は白黒の画像になります。

[Threshold] パラメータは「±」の値を表します。このしきい値は、上記の [カラー] セクションで指定されているカラー値との間で減算と加算が行われ、RGB または HSI 成分のしきい値の最小値と最大値を作成します。例えば、RGB または HSI の値を 200-100-50 に設定し、しきい値を 20-10-5 と設定した場合、しきい値の最大値と最小値はそれぞれ 220-110-55 および 180-90-45 となります。RGB または HSI の値がしきい値以内のピクセルは、白で表示されます。しきい値の範囲外のピクセルは、黒で表示されます。

赤/色相

-1 = 自動 (デフォルト) | ユークリッド距離に基づいて、自動変換ルーチンを有効にします。
0 ～ 255 | カラーの赤/色相の成分のバイナリしきい値を直接指定します。

緑/彩度

-1 = 自動 (デフォルト) | ユークリッド距離に基づいて、自動変換ルーチンを有効にします。
0 ～ 255 | カラーの緑/彩度の成分のバイナリしきい値を直接指定します。

青/明度

-1 = 自動 (デフォルト) | ユークリッド距離に基づいて、自動変換ルーチンを有効にします。
0 ～ 255 | カラーの青/明度の成分のバイナリしきい値を直接指定します。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 | GreyscaleDistance 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

GreyscaleDistance 関数の出力

戻り値 | 処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | GreyscaleDistance 関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

GreyscaleDistance 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

暗ピクセル | GetDarkPixelCount(画像) | バイナリしきい値レベルを下回るピクセルの数
明ピクセル | GetBrightPixelCount(画像) | バイナリしきい値レベル以上のピクセルの数

注: 3 つのしきい値がすべて -1 (デフォルト) に設定されている場合、前述の 2 つの関数は #ERR を返します。

GreyscaleDistance 関数の例

この例では、入力画像内の対象物は黄色の Cognex センサであり、ColorToGreyscaleFilter 関数の例でも使用されています。画像のランダムサンプリング ([表示] メニューで [オーバレイ] をクリックし、センサ上でカーソルを動かしてウィンドウの左下隅にあるステータスバーに RGB 情報を表示することで、オーバレイビューをオフに切り替えて実行します) は、このセンサについて 205-185-124、193-177-110、175-154-39、133-104-2、および 115-91-6 の RGB 値を表示します。

この例では、GreyscaleDistance 関数のシンプルな設定を使用して、グレースケール出力画像を生成します。

In-Sight スプレッドシートに関数を挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。画像の上に赤い ROI ボックスが現れます。カーソルを使用してボックスを移動するかサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし、選択を確定してプロパティシートに戻ります。Enter キーを押すか、ROI 内をダブルクリックすることで、選択を確定することもできます。

RGB カラー表現を選択し、プロパティシートの [カラー] セクションにある [RGB] フィールドに「205-185-124」と入力して、そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

下記は、GreyscaleDistance 関数によって生成された出力画像です。RGB の値 205-185-124 は、センサの一部の領域と完全一致であるため、センサは非常に明るいピクセルで表されています。

ColorToGreyscaleFilter 関数の赤のフィルタを使用して生成された下記の画像と、上記の画像を比較します。下記の画像ではセンサが明るくなっていますが、上記の画像では強められているコントラストがありません。

関連項目

画像ツールについて

画像データアクセス関数

プロパティシートの使用方法


ImageMath 関数

ImageMath 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

多目的関数である ImageMath 関数は、各ピクセルが、2 つの入力画像間で実行された算術演算 (加算、減算、平均など) の結果となるグレースケールまたは白黒の出力画像を生成します。

注:
  • In-Sight ファームウェア 5.2.0 以降から、この関数のアルゴリズムはより新しいアルゴリズムを使用するように変更されました。この変更により、[表示行] および [表示列] パラメータが関数に追加されました。また、[結果の配置]、[詳細設定オプション] パラメータおよび [AND]、[OR]、[XOR] オプション ([フィルタ種類] パラメータ) が関数から削除されました。
  • In-Sight ファームウェア 5.1.x 以前に設定された ImageMath 関数を含んでいるジョブを、ファームウェアバージョン 5.2.0 以降を実行する In-Sight ビジョンシステムにロードすると、[結果の配置] パラメータと [詳細設定オプション] パラメータが自動的にこの関数から削除され、[表示行] および [表示列] パラメータはデフォルト値 (0, 0) に設定されます。ImageMath 関数で [AND]、[OR]、[XOR] オプションを使用するように設定すると、#ERR が返されます。
  • In-Sight ファームウェア 5.2.0 以降に設定された ImageMath 関数を含んでいるジョブを、ファームウェアバージョン 5.1.x 以前を実行する In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されてジョブのロードが失敗します。
  • [結果の配置] オプションとして [画像 1 の原点] または [画像 2 の原点] が選択されている場合、In-Sight ファームウェア 5.1.x 以前に設定された ImageMath 関数は、キャリブレーションを後続のツールに適用することができます ([センサの原点] が選択されている場合は、結果はピクセル単位となります)。ただし、In-Sight ファームウェア 5.2.0 以降に設定された ImageMath 関数は、キャリブレーションを適用することはできません。ピクセルの計測値をワールド座標に変換するには、いくつかのオプションがあります。
    • ツール用の座標補正関数を使用します (例えば TransBlobsToWorld)。
    • ImageMath 関数を、適切なキャリブレーションを行う CalibrateImage 関数に適用して、CalibrateImage 関数を後続のツールへの入力として使用します。

ImageMath の入力パラメータ (In-Sight ファームウェア 5.2.0 以降)

ImageMath の入力パラメータ (In-Sight ファームウェア 5.1.x 以前)

ImageMath の出力

ImageMath 関数の例

In-Sight ファームウェア 5.2.0 以降

ImageMath (

画像1 ,

画像2,

操作 ,

表示行 ,

表示列 ,

表示

)

In-Sight ファームウェア 5.1.x 以前

ImageMath (

画像1 ,

画像2,

操作 ,

結果の配置 ,

詳細設定オプション.Divisor ,

詳細設定オプション.Greyscale Offset ,

表示

)

ImageMath の入力パラメータ (In-Sight 5.2.0 以降)

画像 1

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

画像 2

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

操作

グレースケールまたは白黒の出力画像を生成する画像処理演算を指定します。

0 = 差 (デフォルト)

画像 1 - 画像 2 の絶対値。このパラメータで画像 1 と画像 2 とのグレースケール値の差を計算します。画像の順序は関係ありません。

画像 1 | 画像 2 | 出力画像

1 = 減算

画像 1 - 画像 2。このパラメータは、画像 1 のグレースケールしきい値から画像 2 のグレースケールしきい値を減算します。画像の順序は関係ありません。

画像 1 | 画像 2 | 出力画像

2 = 加算

画像 1 + 画像 2。このパラメータは、画像 1 と画像 2 のグレースケール値を加算します。

画像 1 | 画像 2 | 出力画像

3 = 最大

画像 1 対 画像 2 の最大値。このパラメータは、画像 1 と画像 2 を比較し、最高のグレースケール値を持つピクセルを選択します。

4 = 最小

画像 1 対 画像 2 の最小値。このパラメータは、画像 1 と画像 2 を比較し、最低のグレースケール値を持つピクセルを選択します。

5 = 平均

画像 1 と画像 2 の平均値。このパラメータは、画像 1 と画像 2 のグレースケール値を加算して、2 で除算します。

表示行

左上隅を基準に、出力画像を表示する行座標 (デフォルト = 0) を指定します。

表示列

左上隅を基準に、出力画像を表示する列座標 (デフォルト = 0) を指定します。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | ImageMath 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、使用可能なグラフィックス項目は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。

ImageMath の入力パラメータ (In-Sight 5.1.x 以前)

画像 1

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

画像 2

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

操作

グレースケールまたは白黒の出力画像を生成する画像処理演算を指定します。

0 = 差 (デフォルト) | 画像 1 - 画像 2 の絶対値。このパラメータで画像 1 と画像 2 とのグレースケール値の差を計算します。画像の順序は関係ありません。
1 = 減算 | 画像 1 - 画像 2。このパラメータは、画像 1 のグレースケールしきい値から画像 2 のグレースケールしきい値を減算します。画像の順序は関係ありません。
2 = 加算 | 画像 1 + 画像 2。このパラメータは、画像 1 と画像 2 のグレースケール値を加算します。
3 = 最大 | 画像 1 対 画像 2 の最大値。このパラメータは、画像 1 と画像 2 を比較し、最高のグレースケール値を持つピクセルを選択します。
4 = 最小 | 画像 1 対 画像 2 の最小値。このパラメータは、画像 1 と画像 2 を比較し、最低のグレースケール値を持つピクセルを選択します。
5 = 平均 | 画像 1 と画像 2 の平均値。このパラメータは、画像 1 と画像 2 のグレースケール値を加算して、2 で除算します。
6 = AND | 画像 1 と画像 2 を比較し、論理「AND」演算に基づいて白黒の画像を生成します。出力ピクセルは、両方の入力ピクセル値が 0 より大きい場合は白、いずれかのピクセル値が 0 に等しい場合は黒です。
7 = OR | 画像 1 と画像 2 を比較し、論理「OR」演算に基づいて白黒の画像を生成します。出力ピクセルは、いずれかの入力ピクセル値が 0 より大きい場合は白、いずれのピクセル値も 0 以下の場合は黒です。
8 = XOR | 画像 1 と画像 2 を比較し、論理「排他的 OR」演算に基づいて白黒の画像を生成します。出力ピクセルは、一方の入力ピクセル値が 0 より大きく、他方が 0 に等しい場合は白、両方のピクセル値が 0 より大きいか、両方が 0 に等しい場合は黒です。

結果の配置

画像処理演算が行われた後に、出力される画像の位置を指定します。

0 = 画像 1 の原点 (デフォルト) | 画像 1 を出力画像の原点の位置として指定します。生成される画像は画像 1 をオーバレイします。
1 = 画像 2 の原点 | 画像 2 を出力画像の原点の位置として指定します。生成される画像は画像 2 をオーバレイします。
2 = センサの原点 | AcquireImage 関数の行 0、列 0 を出力画像の原点として指定します。生成される画像は画像の左上隅に配置されます。

詳細設定オプション

グレースケール出力画像に適用することができる、追加の数学的な変更を指定します。演算の順序は、(1) 除算および (2) オフセットです。

Divisor | 各出力ピクセルのグレースケール値に分割する値を指定します。(デフォルト = 1) ピクセル値の明度を変更し、255 を超えるピクセル値を「スケールダウン」することができます。
Greyscale Offset | 各出力ピクセルのグレースケール値に適用するオフセット値を指定します。(デフォルト = 0) 正および負のオフセットによって、それぞれ出力の明るさを増減します。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | ImageMath 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、使用可能なグラフィックス項目は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。

ImageMath の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

ImageMath 関数の例

この例では、ガスケットの穴のみの出力ファイルを生成することを目的としています。後で、この穴が別のツールによって参照され、穴に関する決定を行うことができます。

画像 1 では、完全なガスケットの画像を取り込んでいます (下記)。

画像 2 は画像 1 のコピーとしたいところですが、すべての白い穴が塗りつぶされています。これを生成するには、Filter 関数をスプレッドシートに挿入し、プロパティシートで [領域] という単語を選択して、プロパティシートのツールバーにある [領域の最大化] [image] ボタンをクリックすることによって、ROI を最大化します。ROI を最大化すると、画像 1 と画像 2 の ROI が同じサイズになります。

プロパティシートで [フィルタ種類] ドロップダウンメニューから [白穴塗りつぶし] を選択し、そのほかのパラメータについてはデフォルト設定を受け入れ、Filter プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します (下記の結果を参照)。

次に ImageMath 関数をスプレッドシートに挿入し、プロパティシートで A0 を画像 1 として受け入れます。ここで、フィルタ出力画像は画像 2 のソースとして参照される必要があります。プロパティシート内の画像 2 の語句をダブルクリックすると、非表示になって In-Sight スプレッドシートが表示されます。Filter 関数によって返された [image] データ構造体をクリックし、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックして、ImageMath プロパティシートに戻ります。Enter キーを押すか、 [image] データ構造体をダブルクリックすることで、選択を確定することもできます。

プロパティシートで [フィルタ種類] ドロップダウンメニューから [差] を選択し、そのほかのパラメータについてはデフォルト設定を受け入れ、ImageMath プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

この結果、ガスケットの穴のみの出力画像となります (下記)。

関連項目

画像ツールについて

画像データアクセス関数

プロパティシートの使用方法


LineScanDistortion 関数

LineScanDistortion 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

In-Sight 5604 ラインスキャンビジョンシステムで使用するために、TrainLineScanDistortion 関数の出力に基づいて、レンズの歪みを修正します。LineScanDistortion 関数は TrainLineScanDistortion 関数の計算を参照し、ラインスキャンビジョンシステムでレンズの歪みを修正する [image] データ構造体を出力します。出力された [image] データ構造体は、その他の In-Sight ビジョンツールによって参照することができます。

LineScanDistortion の入力パラメータ

LineScanDistortion の出力

LineScanDistortion (

画像 ,

Trained Distortion,

表示

)

LineScanDistortion の入力パラメータ

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

Trained Distortion

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 | LineScanDistortion 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

LineScanDistortion の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

画像ツールについて

画像データアクセス関数

TrainLineScanDistortion 関数

プロパティシートの使用方法


NeighborFilter 関数

ビジョンツール → 画像

In-Sight 関数リファレンス

多目的関数の NeighborFilter は、各ピクセルが、「局所的な」画像強調技術 (縮小、拡大、塗りつぶし、平滑化、またはエッジ強度など) を入力画像または対象領域 (ROI) の一連の隣接するピクセル (「近傍」) に適用した結果であるグレースケール出力画像を生成します。一連のピクセルは、「処理近傍」と呼ばれ、形状は矩形で、[行数] および [列数] パラメータによって、それぞれ高さと幅が定義されます。NeighborFilter 操作の多くは、処理近傍内の特徴をその形状の特性に基づいて処理 (またはモーフィング) します。

  • NeighborFilter の入力パラメータ
  • NeighborFilter の出力
  • NeighborFilter 関数の例
  • 関連項目

注:

  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは、この関数を Filter 関数に組み込みました。
  • In-Sight 5.1.x ファームウェアを実行中の In-Sight ビジョンシステムに、PointFilter 関数または NeighborFilter 関数が含まれたジョブをロードする場合に、その関数が [セルのフォーマット] ダイアログの [保護] タブを使ってパスワード保護されていると、ジョブのロードに失敗します。In-Sight ファームウェア 4.x.x を実行する In-Sight ビジョンシステムにジョブをロードして、ジョブを修正してください。パスワード保護されたセルのアクセスまたは削除の詳細については、「ライセンス」を参照してください。

NeighborFilter 関数の入力パラメータ

NeighborFilter 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

操作,

行数,

列数,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

操作

処理近傍で実行する操作を指定します。結果は、グレースケール出力画像で表示されます。一部の操作は、エッジを強調します。エッジは、ピクセルのグレースケール値が急激に変化する画像内の領域です。

0 = ボトムハット | 「ボトムハット」フィルタ処理操作を指定します。この操作は、処理近傍のサイズより小さい暗い特徴以外のすべてを除去します。結果は、これらの暗い特徴が明るいピクセルで表示され、背景が暗く表示された出力画像になります。
1 = クローズ | 「クロージング」操作を指定します。この操作はダイレーションの後にエロージョンを実行し、処理近傍のサイズより小さい暗い特徴を除去します。結果は、全体的な明度がわずかに高くなった出力画像となります。
9 = 畳み込み | 「畳み込み」操作を指定します。この操作は、周辺ピクセルの値に基づいて、個々のピクセルの値を変更します。このパラメータは非常に柔軟に設計されているため、ユーザは、さまざまな結果 (カスタムローパスフィルタ、カスタムダイレーション操作など) を生成できます。 注: [カーネル] ボタンを押すと、[畳み込みフィルタのカーネル] ダイアログが開き、処理近傍の各ピクセル値の重みを指定できます。
2 = 膨張 | 「ダイレーション」操作を指定します。この操作は、明るい特徴を拡大し、暗い特徴を縮小します。結果は、明るいピクセルがより大きな領域を占める出力画像になります。暗い斑点の除去に有効です。
3 = エッジ強度 | 入力画像のダイレーションとエロージョンの差を表示する操作を指定します。結果は、エッジが明るいピクセルで表示された出力画像になります。この操作は、勾配 全方向に似ていますが、より複雑な対角線方向のエッジを表現できます (ただし、より時間がかかります)。
4 = 収縮 | 「エロージョン」操作を指定します。この操作は、明るい特徴を縮小し、暗い特徴を拡大します。結果は、暗いピクセルがより大きな領域を占める出力画像になります。明るい斑点の除去に有効です。
14 = 黒穴埋め | 明るいピクセルで囲まれた暗いピクセルを明るいピクセルに変換する「ピクセル塗りつぶし」操作を指定します。結果は、暗い穴が塗りつぶされた出力画像になります。
13 = 白穴塗りつぶし | 暗いピクセルで囲まれた明るいピクセルを暗いピクセルに変換する「ピクセル塗りつぶし」操作を指定します。結果は、明るい穴が塗りつぶされた出力画像になります。
10 = 勾配 垂直方向 | 「垂直方向の傾斜」操作を指定します。結果は、垂直方向のエッジが明るいピクセルで表示された出力画像になります。
11 = 勾配 水平方向 | 「水平方向の傾斜」操作を指定します。結果は、水平方向のエッジが明るいピクセルで表示された出力画像になります。
12 = 勾配 全方向 | 「垂直方向および水平方向の傾斜」操作を指定します。結果は、垂直方向および水平方向のエッジが明るいピクセルで表示された出力画像になります。この操作は、エッジ強度に似ていますが、より簡易で (処理が早く)、対角線方向のエッジは表現しません。
5 = ハイパス | 「ハイパス」操作を指定します。結果は、むらのないグレースケール勾配を持つ領域に対し、相対的にエッジが強調された出力画像となります。
6 = ローパス (デフォルト) | 「ローパス」操作を指定します。結果は、エッジが「平滑化」された、またはぼやけた出力画像になります。
7 = オープン | 「オープニング」操作を指定します。この操作はエロージョンの後にダイレーションを実行し、処理近傍のサイズより小さい明るい特徴を除去します。結果は、全体的な明度がわずかに低くなった出力画像となります。
8 = トップハット | 「トップハット」フィルタ処理操作を指定します。この操作は、処理近傍のサイズより小さい明るい特徴以外のすべてを除去します。結果は、これらの明るい特徴が明るいピクセルで表示され、それ以外の背景が暗く表示された出力画像になります。

行数

処理近傍の高さ (1 ～ 25、デフォルト = 3) を指定します。

注:
  • 操作に [畳み込み] が選択されている場合、行数はピクセル単位でカーネルの高さを定義するために使用されます。

列数

処理近傍の幅 (1 ～ 25、デフォルト = 3) を指定します。

注:
  • 操作に [畳み込み] が選択されている場合、列数はピクセル単位でカーネルの幅を定義するために使用されます。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | NeighborFilter 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

NeighborFilter 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注: データ構造体にある処理済みの画像領域の内容は、ジョブとともに保存されることはありません。

NeighborFilter 関数の例

この例の目的は、NeighborFilter 関数の膨張操作を使用して、入力画像の連続した 5 つの数字の周辺にある黒い斑点を除去することです (下図)。

NeighborFilter 関数をスプレッドシートに挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。画像の上に赤い ROI ボックスが現れます。カーソルを使用してボックスを移動するかサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし、選択を確定してプロパティシートに戻ります。Enter キーを押すか、ROI 内をダブルクリックすることで、選択を確定することもできます。

プロパティシートで [フィルタ種類] ドロップダウンメニューから [膨張 (Dilate)] を選択し、そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

下の 2 つの画像では、オリジナルの入力画像と新しい出力画像の両方が [文字照合/認識] ツールによって参照されています。このツールは、数字を「照合」し、結果の信頼性を示す各数字の得点を表示します。

オリジナルの入力画像 (ダイレーションなし) では、文字照合/認識の最高得点が 100.000 (数字「2」) で、最低得点が 82.154 (数字「1」) です。数字「1」は、文字照合のデフォルトのアクセプトしきい値 90 を下回っているため、テキスト文字列は照合に失敗します。

新しい出力画像 (ダイレーションを適用) では、黒い斑点の多くが数字の周辺から除去され、数字が読み取り易くなっています。文字照合/認識の最高得点は 100.000 (数字「8」) で、最低得点は 91.518 (数字「9」) です。すべての数字が文字照合のデフォルトしきい値 90 を上回っているため、テキスト文字列は照合に成功します。

数字が薄すぎる場合は、「収縮」操作を適用し、明るい特徴を縮小して暗い特徴を拡大することができます。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


PointFilter 関数

PointFilter 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

多目的関数である PointFilter 関数は、「グローバルな」画像強調技術 (2 値化、反転、ヒストグラム平坦化、グレースケール伸長またはクリップなど) を入力画像または対象領域 (ROI) の各ピクセルに適用した結果である白黒またはグレースケール出力画像を生成します。

  • PointFilter の入力パラメータ
  • PointFilter の出力
  • PointFilter 関数の例
  • 関連項目

注:

  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは、この関数を Filter 関数に組み込みました。
  • In-Sight 5.1.x ファームウェアを実行中の In-Sight ビジョンシステムに、PointFilter 関数または NeighborFilter 関数が含まれたジョブをロードする場合に、その関数が [セルのフォーマット] ダイアログの [保護] タブを使ってパスワード保護されていると、ジョブのロードに失敗します。In-Sight ファームウェア 4.x.x を実行する In-Sight ビジョンシステムにジョブをロードして、ジョブを修正してください。パスワード保護されたセルのアクセスまたは削除の詳細については、「ライセンス」を参照してください。

PointFilter 関数の入力パラメータ

PointFilter 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

操作,

最小,

最大,

しきい値,

表示

)

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセットを指定します。
列 | 画像座標での列オフセットを指定します。
角度 | 画像座標での角度を指定します。

領域

これは対象領域 (ROI) とも呼ばれ、画像処理の対象となる画像の領域を指定します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、[領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセットを指定します。
Y | フィクスチャ座標での原点の Y オフセットを指定します。
高さ | 領域の X 軸に沿った寸法を指定します。
幅 | 領域の Y 軸に沿った寸法を指定します。
角度 | フィクスチャ座標での角度を指定します。

注: [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

操作

グレースケールまたは白黒の出力画像を生成する「ピクセルごと」の画像処理演算を指定します。

注: 選択した操作に適用できないパラメータは、薄く表示される、つまりグレーアウトされています。

0 = 2 値化(デフォルト)

各入力ピクセルとしきい値レベルを比較する白黒 (「2 値化」) のしきい値操作を指定して、出力ピクセルが白か黒かを特定します。しきい値以上の入力ピクセル値は白であり、しきい値未満の値は黒です。

1 = クリップ

グレースケールスペクトルの両端を除去する「クリッピング操作」を指定して、出力画像内の特徴をより均一にします。この操作で、各入力ピクセルのグレースケール値と、[最小値] および [最大値] とを比較します。

  • 入力ピクセル値が最小値または最大値と同じかそれを超える場合、出力ピクセルはそれぞれ最小値または最大値に割り当てられます (クリッピングされます)。
  • 入力ピクセル値が最小値または最大値以内の場合、出力ピクセルは入力ピクセルの値に割り当てられます。

2 = 等化

ヒストグラム平坦化操作を指定して、入力画像のヒストグラムを抽出し、最も多いグレースケール値を分散させて、分布をより均一にします。その結果、出力画像はコントラストが強調されます。

7 = グレースケール距離

各出力ピクセルのグレースケール値を、各入力ピクセルのグレースケール値としきい値レベルの「差」として指定します (例えば、入力ピクセル値が 100 で、しきい値が 25 の場合、出力ピクセルは 75 となります)。

4 = 反転

256 諧調のグレースケールに基づいてピクセル値の反転を指定します (例えば、入力ピクセル値 10 を反転すると、出力ピクセル値 245 になります)。結果として出力画像は入力画像の「ネガ画像」となります。

6 = しきい値範囲

各入力ピクセルと 2 つのしきい値 ([最小値] および [最大値]) を比較する白黒 (「2 値化」) のしきい値操作を指定して、出力ピクセルが白か黒かを特定します。

  • 入力ピクセル値が最小値または最大値と「同じ」か「それを超える」場合、出力ピクセルは白です。
  • 入力ピクセル値が最小値を上回るか、最大値を下回る場合、出力ピクセルは黒です。

5 = 光密度

ピクセル値の反転を出力ピクセル値 = 100 × ログ (255) - 100 × ログ (入力ピクセル値) 対数尺度に基づいて指定します。出力画像はオブジェクトの密度や、入力画像を通過する光の総量を計測した結果としての特徴が現れます。高密度のオブジェクトや特徴は、出力画像の明るいピクセルで表現されます。

3 = 引き伸ばし

引き伸ばし操作を指定します。この操作では入力画像のグレースケール値を、最大の256 諧調まで「拡大」または「引き伸ばし」します。その結果、出力画像はコントラストが強調されます。

最小

[クリップ] および [しきい値範囲] 操作の最小グレースケール値 (0 ～ 255、デフォルト = 0) を指定します。

最大

[クリップ] および [しきい値範囲] 操作の最大グレースケール値 (0 ～ 255、デフォルト = 255) を指定します。

しきい値

[2 値化] および [グレースケール距離] 操作のしきい値レベルを指定します。

-1 (デフォルト) | 指定した領域内で、グレースケール値に基づいてしきい値レベルを自動的に計算します。
0 ～ 255 | 0 ～ 255 のしきい値を直接指定します。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | PointFilter 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

PointFilter 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

PointFilter 関数の例

この例では、PointFilter 関数の各種フィルタを適用して、デンタルフロスの容器の入力画像を強調します (下記)。

PointFilter 関数をスプレッドシートに挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。「領域」が非表示になり、画像の上に赤い ROI ボックスのオーバレイが現れます。カーソルを使用してボックスを移動するかサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし、選択を確定してプロパティシートに戻ります。Enter キーを押すか、ROI 内をダブルクリックすることで、選択を確定することもできます。

プロパティシートで [フィルタ種類] ドロップダウンメニューからフィルタを選択し、そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

下記は、2 値化操作によって生成された出力画像です。ユーザ設定のしきい値以上の入力ピクセル値はすべて白で表示され、しきい値未満のすべての値は黒です。

下記は、クリッピング操作によって生成された出力画像です。最小値と最大値は、それぞれ 40 と 125 に設定されています。入力画像と比較して、下記の出力画像は、コントラストがわずかに低下して表示されていますが、まだオブジェクトと背景を区別することはできます。画像内のグレアまたは明るい領域によって、必要なデータの抽出が難しくなっている場合に、この操作が役立ちます。

下記は、クリッピング操作の逆の操作である引き伸ばしによって生成された出力画像です。最小値と最大値は、それぞれ 0 および 255 の値でグレースケールの範囲全体までスケーリングされています。その結果、出力画像は入力画像よりも高いコンストラストで表示されています。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法
Version: 5.6.0


ScaleImage 関数

ビジョンツール → 画像

In-Sight 関数リファレンス

ScaleImage 関数は、入力画像または対象領域 (ROI) のピクセルを再サンプリングして、縮小、拡大、回転または折り曲げの行われていない状態の画像を生成します。この関数は、再サンプリングされた画像を In-Sight スプレッドシートの左上隅に表示します。

  • ScaleImage の入力パラメータ
  • ScaleImage の出力
  • ScaleImage 関数の例

ScaleImage の入力パラメータ

ScaleImage (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

スケールタイプ,

X スケール,

Y スケール,

表示行,

表示列,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

スケールタイプ

ピクセルの再サンプリング方法を指定します。

0 = 補間 (デフォルト)

画像の再サンプリングのために、ピクセル領域の加重平均値の使用を指定します。

XY スケール

領域の (X, Y) 方向へのスケール比を指定します。

注: 100 から 1000 の範囲に含まれる値はアップサンプリングを指定します。例えば、スケール比の指定値が両方とも 200 である場合、再サンプリング後の画像は指定された領域の 2 倍のサイズになります。

X スケール | 領域の X 方向へのスケール比 (10 ～ 1000、デフォルト = 50) を指定します。
Y スケール | 領域の Y 方向へのスケール比 (10 ～ 1000、デフォルト = 50) を指定します。

表示行

左上隅を基準に、再スケーリングされた画像を表示する行座標 (デフォルト = 0) を指定します。

注:
  • 値 -1 を指定すると、この関数によって、スケーリングされた画像が入力画像と同じ行座標に配置されるようになります。
    • 取り込んだ画像については、AcquireImage 関数に指定した [取り込み開始行] が使用されます。このため、ScaleImage 関数の [表示行] および [表示列] パラメータを 0, 0 に設定すると、画像が部分的に取り込まれた場合、ScaleImage 関数は取り込まれた画像の上に出力結果を表示します。
    • ほかのビジョンツール (例: PointFilter 関数などの画像ツール) で画像を出力すると、入力画像を定義する行座標が使用されます。例えば、PointFilter 関数を列/行座標 100,100 に定義すると、パラメータに -1 が設定された参照している ScaleImage 関数は、行座標 100 に表示されます。
  • ファームウェアリリース 4.7.1 から 4.8.4 の間に作成された ScaleImage 関数を含むジョブを、In-Sight ビジョンシステムまたはファームウェア 4.9.0 を動作させているエミュレータにロードすると、[表示行] の値は自動的に -1 に設定されます。4.7.1 以前に作成されたジョブでは、[表示行] の値は自動的に 0 に設定されます。

表示列

左上隅を基準に、再スケーリングされた画像を表示する列座標 (デフォルト = 0) を指定します。

表示

画像上にオーバレイするグラフィックスを指定します。

0 = 非表示 (デフォルト) | ScaleImage 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力領域境界と再サンプリングされた画像は表示されません。
1 = 結果のグラフィックスのみ | 再サンプリングされた画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力領域境界が常に表示されます。

ScaleImage の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

ScaleImage 関数の例

この例では、入力画像の対象物はボトルです。この例の目的は、ボトルのサイズを 50% に縮小することです。

In-Sight スプレッドシートに関数を挿入した後、プロパティシートで「領域」という単語をダブルクリックして ROI を定義します。画像の上に赤い ROI ボックスが現れます。カーソルを使用してボックスを移動するかサイズを変更し、[ジョブの編集] ツールバーにある [OK] [image] ボタンをクリックし、選択を確定してプロパティシートに戻ります。Enter キーを押すか、ROI 内をダブルクリックすることで、選択を確定することもできます。

[X スケール] および [Y スケール] の両方のフィールドに「50」と入力し、そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。

下の図は、50% に縮小されたボトルの画像です。

ユーザは、「折り曲げ」または「回転」が行われていない対象物に対しても ScaleImage 関数を使用することができます。これにより、処理された出力画像をほかのツールで容易に参照することができます。この例では、対象物はわずかにカーブした線分です。オーバレイは削除されて表示されています (削除は、[表示] メニューの [オーバレイ] をクリックして行います)。また、入力画像と出力画像の両方を同じビューに簡単に並べて表示できるように、線分のサイズも 50% に縮小されます。

関数を挿入した後、ROI を定義し、プロパティシートで [X スケール] および [Y スケール] フィールドに「50」を指定して (ボトルの例で前述のとおり)、対象物が直線になるまで [領域] パラメータの下の [角度] および [カーブ] フィールドの値を徐々に増やしていきます。そのほかのパラメータについてはデフォルト設定を受け入れ、プロパティシートで [OK] をクリックしてこの例の設定を完了し、関数を入力画像に適用します。下の図は、中央が曲がった対象物の画像で、左上隅が縮小されており、「曲がっていない」バージョンの画像です。

この例では、カーブした線分を直線にするために、角度 17.390 およびカーブ -36.389 が必要でした。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


ScaleColorImage 関数

ビジョンツール → 画像

In-Sight 関数リファレンス

ScaleColorImage 関数は、入力画像または対象領域 (ROI) のピクセルを再サンプリングして、縮小、拡大、回転または折り曲げの行われていない状態のカラー画像を生成します。この関数は、再サンプリングされた画像を In-Sight スプレッドシートの左上隅に表示します。

  • ScaleColorImage の入力パラメータ
  • ScaleColorImage の出力

ScaleColorImage の入力パラメータ

ScaleColorImage (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

スケールタイプ,

X スケール,

Y スケール,

表示行,

表示列,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

スケールタイプ

ピクセルの再サンプリング方法を指定します。

0 = 補間 (デフォルト)

画像の再サンプリングのために、ピクセル領域の加重平均値の使用を指定します。

XY スケール

領域の (X, Y) 方向へのスケール比を指定します。

注: 100 から 1000 の範囲に含まれる値はアップサンプリングを指定します。例えば、スケール比の指定値が両方とも 200 である場合、再サンプリング後の画像は指定された領域の 2 倍のサイズになります。

X スケール | 領域の X 方向へのスケール比 (10 ～ 1000、デフォルト = 50) を指定します。
Y スケール | 領域の Y 方向へのスケール比 (10 ～ 1000、デフォルト = 50) を指定します。

表示行

 左上隅を基準に、再スケーリングされた画像を表示する行座標 (デフォルト = 0) を指定します。

注: 値 -1 を指定すると、この関数によって、スケーリングされた画像が入力画像と同じ行座標に配置されるようになります。

  • 取り込んだ画像については、AcquireImage 関数に指定した [取り込み開始行] が使用されます。このため、ScaleColorImage 関数の [表示行] および [表示列] パラメータを 0, 0 に設定すると、画像が部分的に取り込まれた場合、ScaleColorImage 関数は取り込まれた画像の上に出力結果を表示します。
  • ほかのビジョンツール (例: ExtractColor 関数などのカラーツール) で画像を出力すると、入力画像を定義する行座標が使用されます。例えば、ExtractColor 関数を列/行座標 100,100 に定義すると、パラメータに -1 が設定された参照している ScaleColorImage 関数は、行座標 100 に表示されます。

表示列

 左上隅を基準に、再スケーリングされた画像を表示する列座標 (デフォルト = 0) を指定します。

表示

画像上にオーバレイするグラフィックスを指定します。

0 = 非表示 (デフォルト) | ScaleColorImage 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力領域境界と再サンプリングされた画像は表示されません。
1 = 結果のグラフィックスのみ | 再サンプリングされた画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力領域境界が常に表示されます。

ScaleColorImage の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • ScaleImage 関数
  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


SceneCorrection 関数

ビジョンツール → 画像

In-Sight 関数リファレンス

SceneCorrection 関数は、均一でない照明やシェーディングのある画像を修正して、均一な照明があるとみなされる出力画像を生成するのに有効です。この関数は、各ピクセルが、「局所的な」画像強調技術 (「平均明度」) を対象領域 (ROI) の一連の隣接するピクセル (「近傍」) に適用した結果であるグレースケール出力画像を生成します。一連のピクセルは、「処理近傍」と呼ばれ、形状は矩形で、[行数] および [列数] パラメータによって、それぞれ高さと幅が定義されます。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは、この関数を Filter 関数 (ハイパスフィルタタイプ) に組み込みました。
  • SceneCorrection の入力パラメータ
  • SceneCorrection の出力
  • 関連項目

SceneCorrection 関数の入力パラメータ

SceneCorrection 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

操作 ,

行数 ,

列数 ,

タイムアウト ,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

操作

処理近傍で実行する操作を指定します。結果は、グレースケール出力画像で表示されます。

0 = 平均明度

「平均明度」操作を指定します。結果は、画像の平均グレースケールになります。このフィルタは、各ピクセルの明度値を処理近傍内にあるピクセルの平均明度と比較して、均一でない照明またはシェーディングの除去をシミュレートします。画像内のばらつきがほとんどない領域は、元の明度に関係なくニュートラルなグレーで表示されます。周囲のピクセルよりも暗いピクセルは、どのくらい周囲よりも暗いかによって、ニュートラルなグレーよりも暗くシェーディングされます。同様に、周囲のピクセルよりも明るいピクセルは、ニュートラルなグレーよりも明るくシェーディングされます。「ハイパス」操作と同様に、エッジおよび急速な変化は保存されます。

行数

処理近傍の高さ (画像最大高 1、デフォルト = 11) を指定します。この値は奇数値にする必要があります。

注:
  • 処理近傍は奇数で生成される必要があります (例: 行数 = 13、列数 = 13、行数 = 15、列数 = 21)。偶数を入力しても自動的に拒否されます。
  • 最大高さは In-Sight ビジョンシステムの画像領域の最大高さになります (例: 解像度 640 x 480　のビジョンシステム では 480 ピクセル)。

列数

処理近傍の幅 (画像最大幅 1、デフォルト = 11) を指定します。この値は奇数値にする必要があります。

注:
  • 処理近傍は奇数で生成される必要があります (例: 行数 = 13、列数 = 13、行数 = 15、列数 = 21)。偶数を入力しても自動的に拒否されます。
  • 最大幅は In-Sight ビジョンシステムの画像領域の最大幅になります (例: 解像度 640 x 480　のビジョンシステムでは 640 ピクセル)。

タイムアウト

適切なフィルタを計算する時間をミリ秒単位で指定します (0 ～ 30000、デフォルト = 0)。指定された時間が経過すると、実行は停止し、#ERR が返されます。タイムアウトを指定しない場合は、パラメータを 0 に設定します。

表示

画像上にオーバレイするグラフィックスを指定します。

0 = 非表示 (デフォルト) | SceneCorrection 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域が常に表示されます。

SceneCorrection 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注: データ構造体にある処理済みの画像領域の内容は、ジョブとともに保存されることはありません。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


SurfaceFX

SurfaceFX |
ビジョンツール → 画像 | In-Sight 関数リファレンス

SurfaceFX 関数で特徴の強調を実行します。照明を使用して、オブジェクトの 3D 特徴を強調する高コントラストの画像を作成し、その他のビジョンツールによって特徴の抽出と検査を行います。この関数は、浮き彫り、浮き出し、スタンプ、エッチング、凹凸、そして欠陥 (欠け、くぼみ、しわ、穴、裂け目など) が生じている表面の特徴を分離することによって、ノイズまたはクラッタ (あるいはその両方) を表面の背景から取り除きます。コントラスト画像が生成されると、その他のビジョンツール (OCRMax、TrainPatMaxRedLine、FindPatMaxRedLine、DetectBlobs、SurfaceFlaw、および InspectEdge) を検査と欠陥検出に使用することができます。

SurfaceFX のアルゴリズムでは、低い角度 (45° 未満) の 4 台の個別の光源から順番に 4 点の画像を取り込む必要があります。光源を円の円周に沿って均等に配置し、オブジェクトを照明の中心に配置する必要があります。取り込みフェーズでは、オブジェクトは静止したままとする必要があり、照明および画像取り込みシーケンスは、オブジェクトの右のクワドラントから開始して時計回りに下のクワドラント、次に左のクワドラント、最後に上のクワドラントとする必要があります。

このアルゴリズムでは次に表面に凹凸がある画像が生成され、隆起した特徴は白で、くぼんだ特徴は黒で表示されます。

注: この関数は、In-Sight ファームウェア 5.4.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • SurfaceFX 関数の入力
  • SurfaceFX 関数の出力
  • SurfaceFX の例
  • 関連項目

SurfaceFX 関数の入力

SurfaceFX (

右 ,

下 ,

左 ,

上 ,

シグマ ,

輝度 ,

コントラスト ,

表示

)

右、下、左、上

これらの引数は、オブジェクトの右、下、左、または上からの低い角度 (45° 未満) の照明がある、有効な [image] または [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

  • 右 = 右から (X の値の小さい方へ) の照明がある、入力 [image] または [image] データ構造体 0
  • 下 = 下から (Y の値の小さい方へ) の照明がある、入力 [image] または [image] データ構造体 1
  • 左 = 左から (X の値の大きい方へ) の照明がある、入力 [image] または [image] データ構造体 2
  • 上 = 上から (Y の値の大きい方へ) の照明がある、入力 [image] または [image] データ構造体 3
注:
  • 入力画像のデータ構造体が、In-Sight カメラによって取り込まれた画像であるか、別のビジョンツールによって出力された [image] データ構造体であるかにかかわらず、SurfaceFX 関数は入力画像のデータ構造体全体で動作します。したがって、入力 [image] データ構造体はすべて同じサイズである必要があります。そうでない場合、このツールは #ERR を報告します。たとえば、取り込まれた画像がそれぞれ Filter 関数 ( [image] データ構造体を出力します) によって処理された場合、Surface FX 関数に渡される前に、SurfaceFX 関数は Filter 関数の Region パラメータによって定義された取り込み画像の領域を使用し、Filter 関数の Region パラメータをすべて同じ寸法と角度に設定する必要があります。
  • 別のビジョンツールによって出力された [image] データ構造体を使用している場合、関数が提供している [image] データ構造体は、湾曲のない矩形の画像領域を含んでいる必要があり、External Region または EditCompositeRegion を使用することはできません。また、定義済みの領域を湾曲させることはできず、湾曲させた場合には SurfaceFX 関数の結果は #ERR となります。
  • 入力 [image] データ構造体を回転させることはできますが、それぞれの入力の回転は同じである必要があります。そうでない場合、この関数は #ERR を報告します。
  • 入力 [image] データ構造体は同じロケーションまたはオフセット (あるいはその両方) であることが必要ですが、横方向へのわずかなずれを示す場合があります。しかし、横方向への過剰なずれがあると、表面に凹凸のある画像が低品質で出力される結果につながります。
  • 4 つの入力 [image] データ構造体はすべて存在する必要があり、ない場合は関数が #ERR を報告します。

シグマ

スムーズネス値 (0 ～ 10。デフォルト = 1) を指定して、出力画像内の高周波ノイズを取り除くことができます。

輝度

出力画像の背景の平均明度 (0 ～ 255。デフォルト = 128) を指定します。

コントラスト

出力画像の表面の特徴と背景ピクセルの明度の差異 (0 ～ 100。デフォルト = 10) を指定します。

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | SurfaceFX 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、使用可能なグラフィックス項目は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。

SurfaceFX 関数の出力

戻り値

表面に凹凸のある処理済みの画像を含んでいる [image] データ構造体を返します。入力パラメータのいずれかが無効であれば #ERR を返します。

SurfaceFX の例

この例では、SurfaceFX 関数を使用して表面の特徴が強調された出力画像を生成し、SurfaceFlaw 関数に渡してさらに検査することを目的としています。SurfaceFX は外部光源を必要とし、光源を制御して照明と画像取り込みシーケンスを結合します。各画像では、画像平面の単一のクワドラント (右、下、左、および上) から低い角度 (45° 未満) の照明が照射される必要があります。各クワドラントに照明が当てられるに従って、画像が取り込まれます。4 点の画像がすべて取り込まれたら、画像を SurfaceFX 関数に渡すことができます。これらの画像は、セルを無効にするか、ラッチされた画像を使用して保存することができます。

この例では、イベント パラメータを対応する Button 関数 (ラッチ1、ラッチ2、ラッチ3、ラッチ4) に設定している 4 つの LatchImage 関数を使用し、それらの 領域 パラメータは共通の EditRegion 関数を共有するので、SurfaceFX 関数に渡された各画像の形状と方向は同じになります。LatchImage 関数によって保存された画像は、異なる 4 方向 (右、下、左、および上) からの照明を使用して取り込まれ、SurfaceFX 関数 (A11) に渡されます。SurfaceFlaw 関数は、SurfaceFX 関数によって出力された [image] データ構造体を参照する 画像 パラメータを使用して、オブジェクトの検査を実行します。

  1. 最初の画像では、右側からの照明がアクティブ化されて画像が取り込まれています。次に [ラッチ1] ボタン (セル A5) を押すと、取り込まれた画像は B5 の LatchImage セルに保存されます。

  2. 2 番目の画像では、下側からの照明がアクティブ化されて画像が取り込まれています。次に [ラッチ2] ボタン (セル A6) を押すと、取り込まれた画像は B6 の LatchImage セルに保存されます。

  3. 3 番目の画像では、左側からの照明がアクティブ化されて画像が取り込まれています。次に [ラッチ3] ボタン (セル A7) を押すと、取り込まれた画像は B7 の LatchImage セルに保存されます。

  4. 4 番目の画像では、上側からの照明がアクティブ化されて画像が取り込まれています。次に [ラッチ4] ボタン (セル A8) を押すと、取り込まれた画像は B8 の LatchImage セルに保存されます。

  5. この後 SurfaceFX 関数は、入力画像としての 4 つの LatchImage データ構造体に基づいて実行され、表面のへこみをハイライトする特徴が強調された出力画像を生成します (下記)。

  6. 最後に、SurfaceFlaw 関数は SurfaceFX の出力画像を入力画像として使用し、ローカルの明度とサイズにばらつきのある領域を検出し、画像内の傷を識別します (下記)。

関連項目

  • 画像ツールについて
  • 画像データアクセス関数
  • プロパティシートの使用方法


TrainLineScanDistortion 関数

TrainLineScanDistortion 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

LineScanDistortion 関数と In-Sight 5604 ラインスキャンビジョンシステムで使用するために、画像領域のレンズの歪みを計算します。TrainLineScanDistortion は、均等な間隔で黒と白に交互に並んだ列の画像を処理することでレンズの歪みを計算します。また、画像全体または画像の特定の対象領域を使って、画像に存在する歪みを計算します。レンズの歪みの計算後、LineScanDistortion 関数は TrainLineScanDistortion 出力を参照し、この計算を使ってレンズの歪みを修正します。

TrainLineScanDistortion は、In-Sight Explorer ソフトウェアとともにインストールされた画像ファイルなど、50% デューティサイクル画像 (黒と白の交互の列) と一緒に使用する必要があります。画像ファイルをロードするには、In-Sight Explorer Calibration Grids ディレクトリの Line Scan Distortion フォルダ (例: Program Files → Cognex → In-Sight → In-Sight Explorer x.x.x → Calibration Grids → Line Scan Distortion) に移動し、「LineScanDistortionTrainSample.bmp」ファイルを選択します。画像ファイルを印刷し、その印刷したファイルの画像を In-Sight 5604 ラインスキャンビジョンシステムで取り込むことを推奨します。

注:
  • TrainLineScanDistortion 関数を使用する場合、修正登録時とジョブ実行時の両方で、物理的、光学的な設定 (レンズ、In-Sight 5604 ラインスキャンビジョンシステム、およびビジョンシステムと取り込まれたシーン間の物理的関係) を同一にしてください。このうちのいずれかが変更された場合、システムを再登録する必要があります。よって、登録時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することに留意してください。ビジョンシステムとレンズも、元のセットアップと設定を保持するようにしてください。例えば、(解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、修正が無効となってしまいます。
  • TrainLineScanDistortion 関数は、システムのセットアップ時にだけ利用してください。この関数は、画像の取り込みごとに再登録されないように、デフォルトで無効にされています。

TrainLineScanDistortion の入力パラメータ

TrainLineScanDistortion の結果出力

TrainLineScanDistortion (

画像 ,

領域.X,

領域.Y,

領域.高さ,

領域.幅

)

TrainLineScanDistortion の入力パラメータ

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

領域

これは対象領域 (ROI) とも呼ばれ、画像解析の対象となる画像の領域を表します。変換可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | 画像座標での原点の X オフセット。
Y | 画像座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。

TrainLineScanDistortion の結果出力

戻り値

計算されたレンズの歪み修正を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

画像ツールについて

画像データアクセス関数

LineScanDistortion 関数

プロパティシートの使用方法


WhiteBalance 関数

WhiteBalance 関数 |
ビジョンツール → 画像 | In-Sight 関数リファレンス

カラーの In-Sight センサおよびカラーを有効にしたエミュレータを使用している場合のみ、WhiteBalance 関数を使用できます。WhiteBalance は、画像の赤、緑および青 (RGB) 値を計算し、In-Sight ジョブに保存されたカラーテーブルに従って補正を行うことによって、画像のカラーキャスト (色かぶり) を削除します。その結果、白いアイテムが画像でも白く表示されます。

ユーザは、基準となるニュートラル (灰色) 画像を取り込んで、カラーテーブルを作成する必要があります。画像全体に 18-18-18 のような均一の RGB 値を持つ灰色の画像をニュートラル画像と呼びます。このとき、画像を飽和状態 (255-255-255) にしないでください。推奨する方法は、白紙の画像を取り込む方法です。

WhiteBalance は各カラーチャネル (赤、緑、青) のヒストグラムを作成します。そして、最も大きな値を各チャネルの値で割ることでスケールファクタ (倍率) を求め、これを RGB 値の均等化に使用します。例えば、200-100-50 の RGB 値によって、1-2-4 倍のスケールファクタが求められます。

使用中のセンサのカラーテーブル設定は、ジョブファイルに保存されています。適切な WhiteBalance 情報を画像に適用するには、画像のロードや取り込みの前にジョブをロードする必要があります。

注: WhiteBalance 関数は、AcquireImage プロパティシートのホワイトバランス領域を参照し、このパラメータを使用してホワイトバランスを計算します。

WhiteBalance の入力パラメータ

WhiteBalance の出力

WhiteBalance 関数の例

WhiteBalance 関数 (

画像

)

WhiteBalance 関数の入力パラメータ

画像

この引数は有効なカラー [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

注 : 有効なカラー [image] データ構造体を返す関数は、AcquireImage 関数だけです。

WhiteBalance 関数の出力

戻り値

データ構造体。入力パラメータが無効であれば #ERR を返します。

注: WhiteBalance 関数は、セル状態が無効なスプレッドシートに挿入されます。その結果、画像は 1 回だけホワイトバランスが調整され、スプレッドシートが更新されるたびにホワイトバランスが醸成されることがなくなります。

WhiteBalance 関数の例

この例では、対象物 (センサレンズ) の入力済み画像に、修正の必要なダークブルーのキャスト (下) があります。

ユーザはまず、視野 (FOV) から対象物を削除し、代わりに白紙を配置します。次に、WhiteBalance をスプレッドシートに挿入するだけで、画像から青いキャストが除去されます。次に、プロパティシートの [OK] をクリックして、ジョブへのこの関数の追加を確定します。ジョブファイルに保存されるカラーテーブルを作成するには、紙の画像を取り込みます。対象物が FOV に戻り、画面に表示されると、青いキャストが完全になくなっています (下)。

関連項目

画像ツールについて

画像データアクセス関数

プロパティシートの使用方法


InspectEdge

ビジョンツール

In-Sight 関数リファレンス

InspectEdge ビジョンツールは次の 2 つのグループのツールで構成されています。

  • InspectEdge 関数について
  • BeadFind および BeadInspect 関数について

InspectEdge 関数について

InspectEdge ビジョンツールである、InspectEdge、InspectEdgeForDefect、InspectEdgePosition、および InspectEdgeWidth 関数は、詳細なエッジ解析 (エッジの位置、エッジペアの位置と間隔、エッジ幅の測定など) を行って、エッジに欠陥またはギャップが存在するかどうかを判定するために使用します。InspectEdge ビジョンツールは、エッジのピークが検出され、検出されたエッジの偏差 (エッジ内の欠陥やギャップなど) が検査される対象領域 (ROI) 内で、キャリパの配列を使用するエッジまたはエッジペアを探して、画像内の対象物の特徴の正確な位置に関する詳細情報を提供します。

In-Sight ビジョンシステムでは、次の関数を使用して詳細なエッジ解析を実行します。

  • InspectEdge 関数: 詳細なエッジ解析のために、参照されている ROI 内にキャリパ配列を作成します。この関数は、エッジ解析の最初のステップです。
  • InspectEdgeForDefect 関数: エッジモデルからの偏差を検出するために、エッジモデルと得点付け基準を作成し、検出されたエッジから最適な直線または最適円を作成します。
  • InspectEdgePosition 関数: エッジモデルと得点付け基準を作成し、エッジの位置を判定します。オプションで、検出されたエッジから最適な直線または最適円を作成します。
  • InspectEdgeWidth 関数: エッジペアのエッジモデルと得点付け基準を作成し、エッジペアの幅の差異を判定します。

注: InspectEdgeForDefect、InspectEdgePosition、および InspectEdgeWidth 関数は、InspectEdge 関数によって出力されたデータ構造体を参照する必要があります。

概要

InspectEdge ビジョンツールを使用して詳細なエッジ解析を実行し、対象物のエッジで亀裂、切り目、くぼみ、またはひだなどの偏差を検査します。通常は、これらのツールを使用して、対象物の内側または外側での特徴の正確な位置に関する詳細情報を作成し、これらの特徴に欠陥があるかどうかを調べます。

InspectEdge 関数は、エッジモード方法を使用して画像内のエッジまたはエッジペアを探します。この方法は、1D カーネルを使用して、個別のキャリパ内でエッジピークを検出します。InspectEdgeForDefect、InspectEdgePosition、または InspectEdgeWidth 関数を使用してエッジモデルを作成します。これらの関数は、最適なエッジまたはエッジペアを定義し、後続のエッジ候補をエッジモデルと比較して、エッジ候補に欠陥やギャップがあるどうかを判定します。

画像内で対象エッジまたはエッジペアの位置と方向が分かったら、ツールの適用における次のステップを実行します。

  • 対象のエッジまたはエッジペアを囲む ROI とキャリパ、および [キャリパ]、[最小コントラスト]、および [エッジ幅] パラメータ値を指定し、InspectEdge 関数を使用して対象エッジを分離します。
  • InspectEdgeForDefect 関数、InspectEdgePosition 関数、または InspectEdgeWidth 関数 を使用して、対象のエッジまたはエッジペアを規定するエッジモデルを定義します。

InspectEdge 関数のエッジ検出

InspectEdge ビジョンツールを使用する最初のステップとして、ツールを適用する画像内の対象領域を指定します。InspectEdge 関数は、ROI で関連するエッジ情報を画像から分離するよう慎重に定義します。

次の方法のいずれかで、画像内のどこでエッジまたはエッジペアを検出する必要があるかを判定するために、ROI を指定します。

  • InspectEdge 関数の [領域] パラメータを使用して、位置、サイズ、角度、曲げ、または回転を定義します。
  • EditMaskedRegion または EditPolylinePath などの外部 ROI を構成します。

ROI を配置するときに、対象エッジが ROI のサーチ方向と平行になるようにして、ROI ができるだけ多くのエッジまたはエッジペアを囲むようにし、さらに不要なノイズを ROI から除外します。

InspectEdge 関数の ROI 内でキャリパ配列を使用して、対象エッジを含んでいる画像の部分の 1D 表現を生成します。この 1D 画像には、対象エッジだけでなく、元の画像のノイズおよび不要な情報が原因で生じたその他のエッジも含まれています。InspectEdge 関数の [キャリパ]、[エッジ幅]、および [最小コントラスト] パラメータを 1D 画像に適用すると、対象エッジの画像の強度が上がり、同時に画像のノイズが少なくなります。

InspectEdgeForDefect、InspectEdgePosition、または InspectEdgeWidth 関数を使用したエッジモデルの定義

InspectEdge 関数で画像内にエッジを配置したら、InspectEdgeForDefect、InspectEdgePosition、または InspectEdgeWidth 関数を使用して、検査中に表示されるよう求められるエッジのエッジモデルを作成します。画像内のこのようなエッジはエッジ候補と呼ばれ、最適なエッジはエッジモデルと呼ばれます。エッジモデルの作成には、最適なラインのタイプ、検出対象のエッジのタイプ (単一エッジまたはエッジペア)、エッジの遷移、エッジ得点規則、最適ラインの規則、および検査対象の欠陥またはギャップのタイプの定義が含まれます。

InspectEdgeForDefect 関数を使用して、エッジモデルに基づいて最適ラインを作成し、エッジモデルからの偏差について検査します。InspectEdgePosition 関数を使用して、エッジモデルに対するエッジの位置を特定し、モデルからの偏差を報告して、オプションで最適ラインの作成も行います。InspectEdgeWidth 関数を使用して、エッジのペア間の距離における偏差を検査します。

これら 3 つすべての関数では、参照されている InspectEdge 関数が ROI をキャリパの配列に分割すると、それぞれのキャリパが評価され、その内部のエッジが得点付けされて、どのエッジを選択するかを決定します。位置欠陥については、検出されたそれぞれのエッジに基づいてラインをフィットさせ、検出されたエッジと最適ラインとを、許容値を超える差異に関して比較することで、欠陥を特定します。幅欠陥については、キャリパ内で検出された 2 つのエッジ間の距離を計算してそれらの距離を判定し、その距離と予測される範囲とを比較することで、欠陥を特定します。

結果の評価

エッジモデルと十分に一致することができなかった画像内の各エッジパターン候補に対して、関数は、指定されている場合には次の情報を返すことができます。

  • 最適ラインを基準にした、エッジパターン候補の位置
  • エッジパターン候補で検出された欠陥またはギャップのサイズ、領域、および位置

さらに、関連するその他の InspectEdge データアクセス関数を使用すると、InspectEdge ビジョンツールで生成されたデータに関して独自の処理と解析を実行するための追加情報を取集することができます。

BeadFind および BeadInspect 関数について

ビードとは、インクや糊のついている部分や溶接の継ぎ目のことで、その幅やカバレージ、および位置によって定義されます。一般に、ビードパスは連続するエッジのペアで、異なるピクセル値を持つ 2 つの領域間の境界を定義します (このパスは必ずしもループではありません)。

BeadFind および BeadInspect 関数を使用して、ビードの追跡と検査を行い、ビードパスが同じ位置および均一なパターンの同じ幅で、一貫して同じ位置に配置されているかどうかを検証し、ビードパスで欠落した材料がないか、見つけます。

BeadFind および BeadInspect 関数を使用して、次のタイプのビードの欠陥を検出することができます。

  • 存在しないビード
  • ビードのギャップ
  • ビードの位置偏差
  • ビードの幅欠陥
  • ビードのカバレージ欠陥

In-Sight ビジョンシステムでは、次の関数を使用して詳細なビード解析を実行します。

  • BeadFind 関数: ビードパス候補の検出、選択したビードパスの編集と登録を行う簡単な方法をユーザに提供します。登録されたビードパスは、BeadInspect の入力パラメータとして使用されます。
  • BeadInspect 関数: BeadFind 関数の結果に基づいて、ビードの登録基準および測定ルールを精緻化して、ビードに位置欠陥、幅欠陥、またはギャップがあるかどうかを調べます。BeadInspect 関数は、BeadFind 関数によって出力されたデータ構造体を参照する必要があります。
BeadFind 関数と BeadInspect 関数の使用方法の詳細については、「BeadFind 関数と BeadInspect 関数の使用」を参照してください。

注:
  • BeadFind および BeadInspect 関数は、In-Sight ファームウェア 5.5.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • BeadFind 関数と BeadInspect 関数はカラー画像をサポートしていません。カラー画像がロードされると、自動的にグレースケール画像に変換されます。


BeadFind

BeadFind |
ビジョンツール → InspectEdge | In-Sight 関数リファレンス

BeadFind 関数はビード特徴の中心を検出するために使用され、検出されたビードのパスをトレースしたポリラインを作成します。このツールで検出して登録したビードパスを、BeadInspect 関数で入力として使用して、ビードの位置的な欠陥、幅の欠陥、またはカバレージ欠陥を調べます。

注:
  • BeadFind および BeadInspect 関数は、In-Sight ファームウェア 5.5.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • BeadFind 関数と BeadInspect 関数はカラー画像をサポートしていません。カラー画像がロードされると、自動的にグレースケール画像に変換されます。

  • BeadFind 関数と BeadInspect 関数の使用方法の詳細については、「BeadFind 関数と BeadInspect 関数の使用」を参照してください。
  • BeadFind の入力パラメータ
  • BeadFind の出力
  • 関連項目

BeadFindの入力パラメータ

BeadFind(

画像,

フィクスチャ,

背景画像,

ビードサンプルの位置,

幅の最大偏差 (%) ,

ビードの検出許容,

ビード検出の最適化,

検出ビードパスの最大数,

ビードパスの検出,

選択したビードパス,

ビードパスの編集,

ビード登録の最適化,

ビードパスの登録,

グラフィックス表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

ビードパスを定義する画像座標系を指定します。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角
背景画像

(オプション) 画像の減算に使用する画像の [image] データ構造体を含んでいる、スプレッドシートのセルへの参照を指定します。

背景画像は、ビード材料を含んでいない画像である必要があります。この背景画像を使用して、ビード材料のある画像とない画像との高コントラスト画像を作成して、ビード検出解析時にパーツ上でのビード材料の可視性を強調します。

注:
  • 減算された画像は、[ビードパスの検出] ボタンをクリックしないと生成されません。減算された画像を表示するには、減算された画像チェックボックスをオンにする必要があります。
  • 減算された画像はジョブには保存されません。
Closed 例:

ビードサンプルの位置

BeadFind 関数がビードパスのサーチを開始する場所を指定します。円の範囲にビードの両方のエッジが入っていれば、円をビードパスの中心に配置する必要はありません。

Closed 例:

注: [半径] パラメータの値で、サーチキャリパの幅が決まります。サーチキャリパよりもビードのセクションの幅の方が広い場合は、ビードサーチが失敗します。

X | 画像座標での円の X オフセット (0 ～ センサ画像の高さ - 1、デフォルト = センサ画像の高さ ÷ 2)。
Y | 画像座標での円の Y オフセット (0 ～ センサ画像の幅 - 1、デフォルト = センサ画像の幅 ÷ 2)。
半径 | 画像座標での円の半径 (0 ～ センサ画像の高さ ÷ 2。デフォルト = 30)。
幅の最大偏差 (%)

ビード幅変化の最大許容値をパーセントで指定します (1 ～ 100、デフォルト = 50)。ビード幅の偏差がしきい値を上回ったか下回った場合は、ビードサーチが停止します。

Closed 例:

この例では、[幅の最大偏差] が 30 に設定されています。ビード幅の偏差がしきい値の上限を上回ったり、しきい値の下限を下回ったりした場合、ビードサーチが停止します。[幅の最大偏差] の値を、ビードパス全体がトレースされる 70 に調整します。
ビードの検出許容

ビードを構成するエッジをどの程度積極的にサーチするかを指定します (0 ～ 10、デフォルト = 3)。値が高くなると、曖昧なビードパスが存在する画像エリアでのビード検出を許可します。

0 = 最も消極的

...

10 = 最も積極的アグレッシブ
ビード検出の最適化

ビード検出パラメータを、手動で設定できるようにするか、またはツールによって自動的に計算可能にするかを指定します。

自動 | 最適化パラメータを検出するビードが、この関数によって自動的に特定されるようにするかどうかを指定します。
ビードの色 | 背景色に対するビードの色を指定します ([黒 (白い背景)] または [白 (黒い背景)]、デフォルト = [白 (黒い背景)])。
ビードの幅 | 予測されるビード幅をピクセル単位で指定します (1 ～ センサ画像の幅 - 1、デフォルト = 10)。 注: [ビードサンプルの位置] の円内のビードの平均幅が [ビードの幅] +/- [幅の最大偏差 (%)] の範囲外である場合、ビードサーチは失敗します。たとえば、予測される [ビードの幅] を 12 に設定し、[幅の最大偏差 (%)] を 25% に設定した場合、[ビードサンプルの位置] 内のビードの平均幅は 9 ～ 15 になるはずです。[ビードサンプルの位置] 内で実際に検出されたビードの平均幅が 17 の場合、ビードパスは検出されません。
最小コントラスト | ビードエッジとみなされる最小コントラストの値を指定します (1 ～ 255、デフォルト = 10)。値を低くすると、ノイズのある低コントラストの画像でビードエッジを検出できます。
検出ビードパスの最大数 検出されるビードパス候補の最大数を指定します (1 ～ 5、デフォルト = 5)。指定された数のビード候補が検出されると、関数の処理が停止します。
ビードパスの検出

このボタンをクリックして、ビードパス候補の検出を開始します。動作が完了すると、ボタンの右側に検出されたビードパスの数が表示されます。ビードパスが検出されなかった場合は、0 が表示されます。

注: [ビードパスの検出] ボタンを押すと、既存のパスまた登録済みのパスのデータに対する変更を含めて、それまでのビードパス情報がすべて消去されます。これらの情報を復元するには、[キャンセル] ボタンを押して、プロパティシートでの変更を保存せずにプロパティシートを終了します。
選択したビードパス

ビードの表示および登録に使用するビードパス候補を指定します (0 ～ 4、デフォルト = 0)。
ビードパスの編集

このボタンをクリックして対話型グラフィックスモードに切り替え、選択したビードパスの点を調整し、最適化してから登録します。

注:
  • ビードパスが検出されなかったか、[選択したビードパス] の値が検出されたパスの数よりも大きかった場合は、[ビードパスの編集] ボタンが無効になります。

  • ビードパスを登録した後に変更した場合は、ビードパスを再登録する必要があります。
Closed 例:

ポリラインのさまざまな部分にマウスカーソルを置くと、マウスカーソルが自動的に変換され、次のアクションが有効になります。

マウスアイコン 説明 右クリックコンテキストメニュー

ポリライン上の点を選択します。選択された点は緑色にハイライトされます。この点は、マウスをドラッグして移動したり、Delete キーまたは右クリックコンテキストメニューを使用して削除したりすることができます。
  • 点を削除
  • ここにポリラインを開く

ポリラインパス上にマウスを置きます。選択された位置は緑色にハイライトされます。点を追加するには、マウスをクリックするか右クリックコンテキストメニューを使用します。
  • 点の挿入
  • ここにポリラインを開く

複数の点を選択するには、これらの点を覆うようにボックスを描画します。選択された点は緑色にハイライトされます。点を選択したら、マウスをドラッグして移動したり、Delete キーまたは右クリックコンテキストメニューを使用して削除したりすることができます。
  • 点を削除
ビード登録の最適化

ビード登録の最適化に使用する登録パラメータを指定します。

キャリパの間隔 | ビードパス沿いにあるエッジ検出キャリパの密度を指定します (1 ～ 10、デフォルト = 3)。この値は、欠陥の可能性がある最小の長さを指定します。粗い欠陥の検出のみが必要な場合、値を高く設定してキャリパの数を減らします。小さな欠陥を検出する場合、値を低く設定してキャリパの数を増やします。 Closed 例:
平滑化係数 | 登録ビードパスにおいて、不均一なエッジが最適ラインに与える影響を指定します (1 ～ 10、デフォルト = 3)。ビードエッジ沿いのスパイクなどの変化に対して、最適ビードパスの感度を低くするには、高い値を使用します。ビードのエッジが非常に滑らかである場合は、低い値を使用します。 Closed 例:
ビードパスの登録

このボタンをクリックしてビードパスを登録します。

登録時に、ビード特徴の詳細解析が計算されます。これらの計算を利用して、この BeadFind ツールを参照する BeadInspect 関数の初期値を設定します。

注: BeadFind ツールを再登録すると、更新されたビード特徴で参照している BeadInspect が変更されます。
グラフィックス表示

画像上に描画される BeadFind グラフィックスオーバーレイを指定します。

ビードパス

選択したビードパスに沿った最適ラインを、ビードパスが登録されていない場合は青で、ビードパスが登録されている場合は緑で表示します。

注: ビードパスが検出されると、BeadFind プロパティシートを開いている間は常にビードパスが表示されています。
Closed 例:

ビードのエッジ

ビードパス沿いに検出されたビードエッジの位置を表示します。エッジが検出されない場合は、黄色の円が表示されて、エッジが検出されると見込まれる場所を示します。

Closed 例:

ビードのエッジ (平均)

ビードパス沿いに検出されたビードエッジの平均の位置を表示します。

Closed 例:

キャリパ

ビードパス沿いのキャリパを表示します。選択されているビードパス候補のキャリパは緑で表示されます。登録されているビードパスのキャリパは、次のいずれかの色で表示されます。

  • 緑: 両方のエッジが検出されています。
  • 黄: 一方のエッジが欠落し、エッジ塗りつぶしが使用されています。
  • 黒: 両方のエッジが欠落し、マスクが適用されています。
Closed 例:

減算された画像

背景画像のあるアクティブな画像を減算することによって作成された、減算された画像を表示します。

注: 減算された画像は、[ビードパスの検出] ボタンをクリックしないと表示されません。
Closed 例:

BeadFindの出力

戻り値 | 画像内で検出されたビードに関する情報を含んでいる [image] データ構造体。入力パラメータのいずれかが無効であれば #ERR を返します。
結果 | BeadFind 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。 Closed 例 - デフォルトの BeadFind 結果テーブル

関連項目

  • BeadFind および BeadInspect 関数について
  • BeadFind データアクセス関数
  • BeadInspect
  • BeadFind および BeadInspect 関数の使用


BeadInspect

BeadInspect |
ビジョンツール → InspectEdge | In-Sight 関数リファレンス

BeadInspect 関数を使用して、ビードの位置的な欠陥、幅の欠陥、またはカバレージ欠陥を特定します。BeadInspect ツールには、ビード解析基準および測定ルールを制御するパラメータがあります。これらのルールの初期値は、BeadFind 関数によって返された有効な [image] データ構造体から設定されます。このツールは、現在取り込まれている画像で検出されたビード特徴を、ビード解析基準と比較します。

注:
  • BeadFind および BeadInspect 関数は、In-Sight ファームウェア 5.5.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • BeadFind 関数と BeadInspect 関数はカラー画像をサポートしていません。カラー画像がロードされると、自動的にグレースケール画像に変換されます。

  • BeadFind 関数と BeadInspect 関数の使用方法の詳細については、「BeadFind 関数と BeadInspect 関数の使用」を参照してください。
  • BeadInspect の入力パラメータ
  • BeadInspect の出力
  • BeadInspect 関数の関連項目

BeadInspectの入力パラメータ

[全般] タブ

BeadInspect(

画像,

ビード検出,

検出エリアの編集,

ビードエッジ位置の許容値 (%),

コントラストしきい値,

欠陥制限,

グラフィックス表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。
ビード検出

BeadFind 関数によって出力された有効な [image] データ構造体を含んでいるスプレッドシートセルへの参照を指定します。

注:
  • BeadFind 関数を登録する必要があります。登録しないと、BeadInspect 関数は #ERR を返します。
  • BeadFind 関数を再登録すると、リンクされている BeadInspect 関数のパラメータ、マスクされたエリア、エッジ塗りつぶしエリア、および 検出エリアの編集 で以前に設定された編集がリセットされます。
検出エリアの編集 このボタンをクリックして対話型グラフィックスモードに入り、検査からマスクできるか、エッジ塗りつぶしが可能なエリアを編集します。
ビードエッジ位置の許容値 (%)

登録されたエッジ位置からエッジが外れることができる最大量 (1 ～ 200、デフォルト = 50) を、その位置のビードの平均幅のパーセンテージで指定します。許容範囲外にあるビードエッジは検出されません。

Closed 例:

登録ビードパス (緑) と位置の許容境界(シアン) との間でエッジが検出される必要があります。[ビードエッジ位置の許容値 (%)] の値は、予測エッジのいずれかの側に登録されているエッジ位置から計測されます。

ビードの平均幅は 100% とみなされます。登録されたビードパスはビードの中央にあり、登録されたビッド位置から 50% 外れています。この位置の許容値が 50% 未満の場合、ビードパスのいずれかの側に 2 本の点線があります。この位置の許容値が 50% 以上の場合は、ビードパスのいずれかの側に点線が １ 本だけ表示されます。
コントラストしきい値

有効な最小エッジコントラストの値を指定します (1 ～ 255、デフォルト = 10)。このしきい値より低いコントラストのビードエッジは、欠陥として識別されます。
欠陥制限

欠陥の定義方法、および特定タイプの欠陥を検出する必要があるかどうかを指定します。

注: BeadFind ツールが初めて参照されると、その下に表示されているパラメータのデフォルト値が自動的にリセットされ、現在のビードで欠陥が検出されなかった検査が合格となります。
ビード幅:最小 | 最小幅の欠陥検出が有効であるかどうかを示します。このパラメータを使用して、幅が狭すぎるセクションについてビードを検査します。
ビード幅:最小 (%) | ビードが登録されたときのビードの対応セクションと比較した、有効な最小ビード幅 (1 ～ 99、デフォルト = 50) をパーセンテージで指定します。この制限を下回るビードエッジが検出されると、欠陥として識別されます。例えば、最小ビード幅を 50% に設定した場合、登録ビードの半分の幅のビードの各セクションが許容されます。
ビード幅:最大 | 最大幅の欠陥検出が有効であるかどうかを示します。このパラメータを使用して、幅が広すぎるセクションについてビードを検査します。
ビード幅:最大 (%) | 登録時のビードの対応セクションと比較した、有効な最大ビード幅 (101 ～ 999、デフォルト = 150) をパーセンテージで指定します。この制限を上回るビードエッジが検出されると、欠陥として識別されます。例えば、最大ビード幅を 50% に設定した場合、登録ビードの 2 倍の幅のビード各セクションが許容されます。
ビードのカバレージ:最小 | 最小カバレージの欠陥検出が有効であるかどうかを示します。このパラメータを使用して、登録時のビードの対応セクションと比較し、白いピクセル (黒背景上の白ビードの場合) または黒いピクセル (白背景上の黒ビードの場合) が少なすぎるセクションについて、ビードを検査します。
ビードのカバレージ:最小 (%) | 登録時のビードの対応セクションと比較した、ビードの各セクションで許容される最小ビードカバレージを指定します (1 ～ 99、デフォルト = 50)。登録ビードより、はるかに白い (黒背景上の白ビード) か、はるかに黒い (白背景上の黒ビード) ビードを許可するには、低い値を使用します。
ビードのカバレージ:最大 | 最大カバレージの欠陥検出が有効であるかどうかを示します。このパラメータを使用して、登録時のビードの対応セクションと比較し、白いピクセル (黒背景上の白ビードの場合) または黒いピクセル (白背景上の黒ビードの場合) が多すぎるセクションについて、ビードを検査します。
ビードのカバレージ:最大 (%) | 登録時のビードの対応セクションと比較した、ビードの各セクションで許容される最大カバレージを指定します (101 ～ 999、デフォルト = 150)。登録ビードより、はるかに黒い (白背景上の黒ビード) か、はるかに白い (黒背景上の白ビード) ビードを許可するには、高い値を使用します。
ビードのエッジステップ:最大 | ステップの最大変化の欠陥検出が有効であるかどうかを示します。このパラメータを使用して、ビードエッジに沿った突起またはノッチを検出します。
ビードのエッジステップ:最大 (%) | 隣接エッジと比較した、ビードエッジの最大オフセット位置 (1 ～ 100、デフォルト = 30) を指定します。粗いまたは不均一なエッジを含むビードでは、許容値を上げるために高い値を使用します。エッジがより滑らかなビードには低い値を使用します。
欠陥の長さ:最小 (キャリパ) | 検査結果で報告される最小欠陥サイズ (1 ～ 10 隣接キャリパ、デフォルト = 3) を指定します。値が 1 の場合、 すべての欠陥を含みます。値が 10 の場合、10 以上の隣接キャリパから構成される欠陥のみを報告します。
グラフィックス表示

画像上に描画される BeadInspect グラフィックスオーバーレイを指定します。

ビードパス | 欠陥の検出に使用される登録ビードパス (緑) を表示します。参照されている BeadFind 関数からのパスです。
ビードのエッジ | ビードパスで検出されたエッジを黄色で表示します。 Closed 例:
位置の許容境界 | ビードエッジ検出用の境界 (シアンの点線) を表示します。境界外にあるエッジは検出されず、欠陥となります。この位置の許容値が 50 未満の場合、ビードパスのいずれかの側に 2 本の点線があります。この位置の許容値が 50 以上の場合は、ビードパスのいずれかの側に単一の点線があります。 Closed 例:
マスクおよびエッジ塗りつぶしエリア | ビードパスに沿ってマスクおよびエッジ塗りつぶしエリアを表示します。マスク領域は黒で描画されます。エッジ塗りつぶし領域はシアンで描画されます。 エッジ塗りつぶしを使用すると、ビードの片側がエリア内で検出されなくなります。その後の検査ではマスクエリアは無視され、マスクエリア内の欠陥は報告されません。 Closed 例:
ビードの幅欠陥 | ビードの幅欠陥の境界領域を (赤で) 表示します。
ビードのカバレージ欠陥 | ビードのカバレージ欠陥の境界領域を (赤で) 表示します。
ビードのエッジステップ欠陥 | ビードのエッジステップ欠陥の境界領域を (赤で) 表示します。
欠落エッジ欠陥 | 欠落エッジ欠陥の境界領域を (赤で) 表示します。

[欠陥] タブ

[欠陥] タブは、ビード検出の総合結果を表示し、[統計] と [欠陥リスト] の 2 つのセクションに分かれています。

統計関数

[統計] には次のデータが含まれており、各画像がロードされるか BeadInsepct 関数に変更が行われると、自動的に更新されます。

  • [欠陥の数]: ビードで検出された欠陥の合計数を表示します。
  • [キャリパ数]: ビードパス内のキャリパの合計数を表示します。
  • [コントラスト (第 1 エッジ)]: ビードの第 1 エッジに沿った最小、最大、および平均のコントラスト値を表示します。
  • [コントラスト (第 2 エッジ)]: ビードの第 2 エッジに沿った最小、最大、および平均のコントラスト値を表示します。
  • [ビード幅]: 最小、最大、および平均の幅を、ビードのパーセンテージで表示します。
  • [ビードのカバレージ]: ビードのカバレージをビードのパーセンテージで表示します。
  • [ビード位置のシフト (第 1 エッジ)]: 第 1 エッジの最小、最大、および平均の偏差を、ビードのパーセンテージで表示します。
  • [ビード位置のシフト (第 2 エッジ)]: 第 2 エッジの最小、最大、および平均の偏差を、ビード幅のパーセンテージで表示します。
  • [最大ビードエッジステップ (第 1 エッジ)]: ステップの最大変化を、ビードの第 1 エッジに沿ったビード幅のパーセンテージで表示します。
  • [最大ビードエッジステップ (第 2 エッジ)]: ステップの最大変化を、ビードの第 2 エッジに沿ったビード幅のパーセンテージで表示します。

[欠陥リスト]:

ツールバー

次のツールバーのボタンで、欠陥の結果テーブルの表示をカスタマイズすることができます。

: すべて開く。

: すべてたたむ。

: 欠陥タイプごとにグループ化。

: 欠陥インデックスごとにグループ化。デフォルトでは、欠陥リストテーブルは欠陥インデックスごとにグループ化されています。

: グループ化なし。

: 選択した欠陥にズームする。デフォルトでは、このオプションは選択されています。自動的に画像内の欠陥の位置まで画像がパンおよびズームされます。

欠陥結果テーブル

各欠陥について、欠陥テーブルに次の項目が表示されます。

インデックス | 欠陥のインデックス番号を表示します。
分類

欠陥タイプを表示します。

Closed 欠陥タイプ
  • 狭すぎる
  • 広すぎる
  • アンダーフィル
  • オーバーフィル
  • 第 1 エッジがありません
  • 第 2 エッジがありません
  • 両方のエッジがありません
  • ステップの変化
  • ビードを検出できません
パラメータ | 欠陥に関連付けられている BeadInspect パラメータを表示します。
実際の値 | BeadInspect 関数によって報告される実際の値を表示します。
予期 | BeadInspect 関数によって指定される、許可値の範囲を表示します。
修正 (ボタン)

次のチューニングオプションを提示して、欠陥結果テーブルから疑似欠陥を削除します。

更新 {パラメータ}

さまざまな欠陥タイプに関連付けられた、対応するパラメータを更新します。このオプションを選択すると、欠陥制限の関連する最小および最大パラメータが実際の値で更新され、欠陥結果テーブルから欠陥が削除されます。

Closed 欠陥タイプと関連パラメータ
欠陥タイプ | 関連パラメータ | 説明
狭すぎる | ビード幅:最小 (%) | 狭すぎるセクションについてビードを検査するために使用されます。
幅が広すぎる | ビード幅:最大 (%) | 広すぎるセクションについてビードを検査するために使用されます。
アンダーフィル | ビードのカバレージ:最小(%) | ビードのセクションに適用された素材が少なすぎる場合のアンダーフィルの欠陥を検査するために使用されます。
オーバーフィル | ビードのカバレージ:最大(%) | ビードのセクションに適用された素材が多すぎる場合のオーバーフィルの欠陥を検査するために使用されます。
ステップの変化 | ビードのエッジステップ:最大(%) | ビードエッジに沿った突起またはノッチを検査するために使用されます。粗いまたは不均一なエッジを含むビードでは、許容値を上げるためにより高い [ビードのエッジステップ最大] 値を使用します。なめらかなエッジを含むビードでは、より低いビードステップ値を使用します。
第 1 エッジがありません 第 2 エッジがありません 両方のエッジがありません | コントラストしきい値 | 欠落しているエッジの欠陥を検査するために使用されます。コントラストしきい値より低いコントラストのビードエッジは、欠陥として識別されます。
 | ビードエッジ位置の許容値 (%) | ビードエッジ位置の変更を検査するために使用されます。ビードエッジ位置の許容値を外れたビードエッジは検出されません。
エッジ塗りつぶしを実行

欠落エッジを含んでいる欠陥内のエッジを塗りつぶします。エッジ塗りつぶしを使用すると、ビードの片側がエリア内で検出されなくなります。

注: [第 1 エッジがありません] および [第 2 エッジがありません] の欠陥タイプの場合にのみ機能します。このオプションは、両方のエッジがない場合には使用できません。
マスク/無視

欠陥エリアを検査からマスクします。その後の検査ではマスクエリアは無視されます。マスクエリアに欠陥はないものとして報告されます。

BeadInspectの出力

戻り値

画像内で検出されたビードに関する情報を含んでいる [image] データ構造体。入力パラメータのいずれかが無効であれば #ERR を返します。

結果

BeadInspect 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Closed 例 - デフォルトの BeadInspect 結果テーブル

注:
  • 欠陥が検出されなかった場合、データアクセス関数は #ERR を返します。

  • ビードパスが検出されなかった場合は、データアクセス関数は [タイプ] が整数値 256 である単一の欠陥を返します。

BeadInspect関連項目

  • BeadFind および BeadInspect 関数について
  • BeadFind
  • ビードの BeadFind および BeadInspect 関数の使用
  • データアクセス関数


InspectEdge 関数

InspectEdge 関数 |
ビジョンツール → InspectEdge | In-Sight 関数リファレンス

InspectEdge 関数を使用して、詳細なエッジ解析を実行します。関数の参照される対象領域 (ROI) で、インデックス付きのエッジ検出サブ領域 (キャリパと呼ばれます) の配列によって、画像内のエッジまたはエッジペアを検索することで特徴の正確な位置に関する詳細な情報を作成します。この情報を使用して、エッジまたは特徴の位置、エッジペアの位置と間隔を判定したり、画像内の対象物の幅を測定したりできます。

  • InspectEdge 関数の概要
  • InspectEdge の入力パラメータ
  • InspectEdge の出力
  • InspectEdge 関数の関連項目

InspectEdge 関数概要

InspectEdge 関数が挿入されると、関数自身の内部領域を使用して、または EditMaskedRegion 関数や EditPolylinePath 関数などの外部 ROI の参照として ROI が確立され、ツールがエッジまたはエッジペアを検出する画像内の領域が決定されます。参照される ROI は個別のキャリパに分割され、各キャリパに含まれるピクセルがエッジ解析のために 1 つの畳み込みに渡されます。

ROI が設定されると、次の手順で適切に関数を適用する必要があります。

  • 対象のエッジを分離する [キャリパ]、[最小コントラスト]、および [エッジ幅] パラメータの値を指定します。
  • InspectEdgeForDefect 関数、InspectEdgePosition 関数、InspectEdgeTrainBeadPath 関数または InspectEdgeWidth 関数を使用して、対象のエッジまたはエッジペアを規定するエッジモデルを定義します。

InspectEdge 関数が配置されると、1 つの InspectEdge 関数を入力として使用して、複数の検査を実行できます。例えば、1 つの InspectEdge ROI 内で、InspectEdgeForDefect 関数が位置的な欠陥を判定する関数を参照する一方で、InspectEdgeWidth 関数が別の幅計測を実行し、InspectEdgePosition 関数が別のエッジに最適なラインを決定するといったことができます。

注: InspectEdge 関数は、InspectEdge ビジョンツールの中で最長の実行時間を必要とします。ROI 内のキャリパの数が増加すると、関数の計算時間は長くなります。

InspectEdge 関数の入力パラメータ

InspectEdge 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

外部領域またはパス ,

キャリパ.高さ ,

キャリパ.繰り返しオフセット値 ,

キャリパ.初期オフセット値 ,

最小コントラスト ,

エッジ幅 ,

全キャリパに適合 ,

キャリパグラフインデックス ,

ポリライン幅 ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、エッジ解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。黄色の点線は、エッジを検出する方向を示しています。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部領域またはパス

Annulus、Region、EditAnnulus、EditMaskedRegion、EditPolylinePath、または EditRegion の各関数を含んだスプレッドシートセルへの参照を指定します。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。

注:
  • このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。
  • このパラメータが EditPolylinePath を参照する場合、この関数は InspectEdgeForDefect 関数または InspectEdgePosition 関数への参照として使用することはできません。使用すると #ERR が返されます。

キャリパ

検出可能な欠陥やギャップのサイズを定義するために使用する ROI 内のキャリパ配列を指定します。検出可能な欠陥またはギャップのサイズは、検出可能なエッジの数によって決定されます。検出可能なエッジの数は、エッジに沿って配置されたキャリパの数によって決まります。InspectEdge セルがハイライトされているか、[表示] パラメータが [すべて表示] に設定されている場合、キャリパは ROI 内で赤い矩形として表示され、キャリパ内で検出されたエッジは緑色で表示されます。

注: 検査する欠陥のタイプに応じて、キャリパをオーバラップして配置することができます。ただし、ROI に適用されるキャリパ数が増えるほど、関数の実行時間は長くなります。

高さ | 検査方向に沿って解析されるキャリパあたりのピクセル数を指定します。有効な範囲は、1 から In-Sight ビジョンシステムの画像の幅までです。デフォルト値は 5 です。
繰り返しオフセット値 | 各キャリパの開始間のピクセル数を指定します。有効な範囲は、0 から In-Sight ビジョンシステムの画像の幅までです。デフォルト値は 5 です。[全キャリパに適合] が有効な場合を除き、最後のキャリパは領域の終わりにオーバラップすることがあります。
初期オフセット値 | 領域内の最初のキャリパのオフセットを指定します。有効な範囲は、0 から In-Sight ビジョンシステムの画像の幅までです。デフォルト値は 0 です。

最小コントラスト

エッジとみなされるグレースケールコントラストの最小変化値を指定します (0 ～ 255、デフォルト = 5)。インデックス付きキャリパごとに、青色で描画されたコントラストグラフが画像上に表示されます。グラフ内の値は、0 ～ 100 の値に自動的にスケール変更されます。このパラメータの適用時にこのグラフを使用すると、値を適切に調整できます。

Closed 例 - グラフの [最小コントラスト] パラメータ

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 領域の幅、デフォルト = 3)。この設定値は、エッジが抽出される前のグレースケールプロジェクションのフィルタ処理に使用されるピクセル演算子の大まかなサイズです。この設定値を使用して、画像からノイズをフィルタします。

全キャリパに適合

すべてのキャリパを ROI 内に配置するかどうかを指定します。

0 = OFF (デフォルト) | 関数が [キャリパ繰り返しオフセット値] パラメータおよび [初期オフセット値] パラメータに厳密に従うように指定します。この場合、キャリパが ROI を覆ってしまうことがあります。
1 = ON | ROI 内にすべてのキャリパを確実に配置するために、関数が [キャリパ繰り返しオフセット値] パラメータおよび [初期オフセット値] パラメータを自動的に再計算するように指定します。

キャリパグラフインデックス

画像上に表示するキャリパを指定します (キャリパは緑色に囲まれて表示されます)。デフォルトで表示されるキャリパは 0 です。

ポリライン幅

EditPolylinePath 関数の高さ (1 ～ 領域の高さ値、デフォルト = 20) を指定します。このパラメータを InspectEdgeTrainBeadPath 関数と組み合わせて使用すると、検査領域内を検査できます。

表示

画像上の InspectEdge グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | InspectEdge 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | キャリパグラフと指定したキャリパが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域、キャリパグラフ、および指定したキャリパが常に表示されます。
3 = すべて表示: 入力、結果、およびキャリパ | 入力画像領域、キャリパグラフ、ROI 内のすべてのキャリパが常に表示されます。

InspectEdge 関数の出力

戻り値 | 画像内で検出されたエッジとキャリパ数を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | ROI 内のキャリパの数。

関連項目

  • InspectEdge ツールについて
  • InspectEdge 関数のデータアクセス関数
  • InspectEdgeForDefect 関数
  • InspectEdgePosition 関数
  • InspectEdgeTrainBeadPath 関数
  • InspectEdgeWidth 関数
  • プロパティシートの使用方法


InspectEdgeForDefect 関数

InspectEdgeForDefect 関数 |
ビジョンツール → InspectEdge | In-Sight 関数リファレンス

InspectEdgeForDefect 関数は、InspectEdge 関数によって返されるエッジまたはエッジペアに関する詳細なエッジ解析を行うためのエッジモデルを構築するために使用します。このデータは、検出されたエッジまたはエッジペアを最適ラインからの距離などの欠陥やギャップと比較するための最適なライン適合を構築するために使用します。

  • InspectEdgeForDefect 関数の概要
  • InspectEdgeForDefects の入力パラメータ
  • InspectEdgeForDefects の出力
  • InspectEdgeForDefects 関数のデータアクセス関数
  • InspectEdgeForDefects 関数の関連項目

InspectEdgeForDefect 関数の概要

スプレッドシートにこの関数を挿入した後に、InspectEdge 関数によって出力された [image] データ構造体に対する参照を作成する必要があります。InspectEdge 関数への参照が確立されると、InspectEdgeForDefect 関数のパラメータを設定することによってエッジモデルが作成されます。エッジモデルでは次の項目が定義されます。

  • 最適ラインのタイプ - 直線または円形。
  • エッジのタイプ - 単一またはエッジペア。
  • エッジ変化のタイプ - 白から黒または黒から白。
  • 不必要なエッジをフィルタ処理するために使用するエッジ得点付け基準。
  • 最適ラインから不必要なエッジをフィルタ処理するために使用する最適ライン基準。
  • 欠陥とギャップの両方またはいずれかの検出に使用する許容値。

エッジモデルが確立されると、この関数によってエッジ候補がエッジモデルと比較され、モデルからの偏差が報告されます。

Closed 例 - 合格した最適直線エッジ

Closed 例 - 不合格の最適直線エッジ

Closed 例 - 不合格の最適円エッジ

InspectEdgeForDefect 関数の入力パラメータ

InspectEdgeForDefect 関数(

エッジ検査関数,

最適ライン,

エッジペアの検査,

エッジ方向の検出,

エッジ: 第1,

エッジ: 第2

エッジ得点.得点しきい値,

エッジ得点.エッジ規則,

エッジ得点.コントラスト上限,

エッジ得点.ペアサイズ,

最適ラインの詳細設定.外れ値の削除,

最適ラインの詳細設定.最適距離フィルタ,

最適ラインの詳細設定.最端フィルタ距離,

最適ラインの詳細設定.得点再計算,

最適ラインの詳細設定.最適ライン再計算,

欠陥/ギャップ最大数,

欠陥.最小距離,

欠陥.最大距離,

欠陥.サイズ有効,

欠陥.最小サイズ,

欠陥.最大サイズ,

欠陥.面積有効,

欠陥.最小面積,

欠陥.最大面積,

欠陥.欠陥ライン最適フィルタ,

欠陥.ソート基準,

ギャップ.有効,

ギャップ.ギャップ最小値,

ギャップ.ギャップ最大値,

ギャップ.最大移動距離,

ギャップ.終端ギャップを無視,

ギャップ.ソート基準,

キャリパインデックス,

表示

)

エッジ検査関数

InspectEdge 関数によって返された有効な [image] データ構造体を含むスプレッドシートセルへの参照を指定します。

最適ライン

検出されたエッジから作成する最適ラインの種類を指定します。

1 = 最適直線 | 関数は、検出されたエッジから最適直線を作成します。
2 = 最適円 | 関数は、検出されたエッジから最適円を作成します。
3 = 自動調整 (デフォルト) | 関数は、参照先領域に基づいて最適直線または最適円のいずれかを自動的に作成します。

エッジペアの検査

この関数でエッジペアを検出するかどうかを指定します。検出されたエッジペアには、画像内にグラフィックス表示でラベルが付けられます。最初に検出されたエッジには 0、2 番目に検出されたエッジには 1 が付けられます。

0 = OFF (デフォルト) | エッジペアを検出しません。
1 = ON | [エッジ得点] パラメータに基づいてエッジペアを検出します。

エッジ方向の検出

エッジを検出する方向を指定します。エッジを検出する方向をグラフィックス表示するために、暗い緑の矢印が追加されます。最適ラインには、画像内にグラフィックス表示でラベルが付けられます。最初の最適ラインには 0、2 番目の最適ラインには 1 が付けられます。

注:参照している InspectEdge 関数の ROI がカーブしている場合、検査はカーブの中心に対して行われます。[エッジ方向の検出] パラメータが [左→右] に設定されている場合は、カーブの中心方向に向かって検査され、[右→左] に設定されている場合はカーブの中心から外側へ向かって検査されます。

0 = 左→右 (デフォルト) | ROI の左から右に向かってエッジを検出します。 Closed 例
1 = 右→左 | ROI の右から左に向かってエッジを検出します。 Closed 例
3 = 内→外 | ROI の中心から ROI の上の境界および下の境界に向かってエッジを検出します (検出されたエッジの順序は、ROI の「X」矢印とは反対の方向の順になります)。 Closed 例 注: このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
2 = 外→内 | ROI の上下の境界から ROI の中心に向かってエッジを検出します (検出されたエッジの順序は、ROI の「X」矢印とは反対の方向の順になります)。 Closed 例 注:このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

エッジ: 第1

[エッジ方向の検出] パラメータに従って、検出された最初のエッジのコントラスト変化を指定します。

1 = 黒→白 | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 (デフォルト) | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは黒→白または白→黒のいずれかに変化でき、この関数は適切な変化を決定します。変化を指定すると、関数のパフォーマンスが改善します。

エッジ: 第2

[エッジ方向の検出] パラメータに従って、検出された 2 番目のエッジのコントラスト変化を指定します。

注:このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

1 = 黒→白 (デフォルト) | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは黒→白または白→黒のいずれかに変化でき、この関数は適切な変化を決定します。変化を指定すると、関数のパフォーマンスが改善します。

エッジ得点

指定した基準をエッジが満たすかどうかを判別するために使用する、エッジ得点モードを指定します。

得点しきい値

得点付けのしきい値を指定します。この値 (0 ～ 100、デフォルト = 10) より小さい得点のエッジはフィルタで除去されます。

エッジ規則

得点を計算するときに最も重要になるエッジのタイプを指定します。

1 = 最初のエッジ | 検出された最初のエッジに注目します。
2 = エッジ強度 | 最強のコントラスト変化を持つエッジに注目します。 注:[エッジペアの検査] パラメータがオンになっている場合、スコアは、2 つのエッジの平均コントラスト値に基づきます。
3 = 最初のエッジ/エッジ強度 (デフォルト) | 最初に検出され、最強のコントラスト変化を持つエッジに注目します。
4 = エッジペアサイズ | [ペアサイズ] パラメータに最も近いサイズで検出されたエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
5 = 最初のエッジ/エッジペアサイズ | [ペアサイズ] パラメータに最も近いサイズで検出された最初のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
6 = エッジ強度/エッジペアサイズ | 最強のコントラスト変化を持ち、[ペアサイズ] パラメータに最も近いサイズで検出されたエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
7 = 最初のエッジ/エッジ強度/エッジペアサイズ | 最強のコントラスト変化を持ち、[ペアサイズ] パラメータに最も近いサイズで検出された最初のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

コントラスト上限

エッジとみなすエッジコントラスト変化の上限 (2 ～ 255、デフォルト = 255) を指定します。この値を超えるエッジコントラスト変化を持つエッジの得点は、すべて同じ最高得点になります。

注: このパラメータを有効にするには、[エッジ規則] パラメータを、[エッジ強度]、[最初のエッジ/エッジ強度]、[エッジ強度/エッジペアサイズ]、[最初のエッジ/エッジ強度/エッジペアサイズ] のいずれかに設定しておく必要があります。

ペアサイズ

最高得点を記録するエッジペアサイズを指定します (有効な範囲は、In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト = 5)。このパラメータが有効な場合、この値の上下で検出されたエッジペアはこの値に比例して得点付けされます。例えば、[ペアサイズ] が 10 に設定されており、値が 8 と値が 14 の 2 つのエッジペア候補が検出された場合は、値 8 のエッジペアが選択されます。これは、2 番目のエッジペアより [ペアサイズ] に近いためです。

注: このパラメータを有効にするには、[エッジペアの検査] パラメータを ON にし、[エッジ規則] パラメータを [エッジペアサイズ]、[最初に検出されたエッジペアサイズ]、[エッジ強度/エッジペアサイズ]、または [最初のエッジ/エッジ強度/エッジペアサイズ] のいずれかに設定しておく必要があります。

最適ラインの詳細設定

最適ラインを構築する方法を指定します。

外れ値の削除

[最適距離フィルタ] パラメータで指定されている距離より遠い点を最適ラインから削除するように指定します。

0 = OFF (デフォルト) | 除外距離エッジを考慮しません。
1 = ON | 計算時に除外距離エッジを考慮します。

最適距離フィルタ

最適ライン再計算で利用するためにエッジが元の最適ラインから離れている必要がある距離をピクセル単位で指定します (有効な範囲は　In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト = 2)。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。この設定を有効にするには、[外れ値の削除] が ON になっている必要があります。

最端フィルタ距離

除外距離が、まだ最適ラインの一部とみなされる最適ラインからの距離を指定します (有効な範囲は In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト はビジョンシステムの画像幅の 3 倍)。この値より大きなエッジはすべて無視されます。
得点再計算

最適ラインにより近いエッジを選択するために、エッジを得点再計算するように指定します。

0 = OFF (デフォルト) | 除外距離を考慮するためにエッジを得点再計算しません。
1 = ON | 計算時に除外距離エッジを考慮するために得点再計算を行います。
最適ライン再計算

エッジの得点再計算後に最適ラインの再適合を行うように指定します。この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。

0 = OFF (デフォルト) | 最適ラインの再適合を行いません。
1 = ON | エッジの得点再計算後に最適ラインの再適合を行います。

欠陥/ギャップ最大数

検出する欠陥とギャップの両方またはいずれかの最大数を指定します (1 ～ 4096、デフォルト = 5)。この値は、欠陥とギャップに個別に適用されます。例えば、値を 5 に設定すると、最大 5 つの欠陥と 5 つのギャップが検出されます。この設定は、スプレッドシートにデータアクセス結果テーブルを構築するために使用されます。

欠陥

最適ラインのエッジの欠陥を判別するためのパラメータを指定します。

最小距離

エッジと最適ラインの間の距離をピクセル単位で指定します (有効な範囲は　In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍。デフォルト = 3 ピクセル)。この値より小さい場合は欠陥ではないと判別されます。

最大距離

エッジと最適ラインの間の距離をピクセル単位で指定します (有効な範囲は　In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍。デフォルト はビジョンシステムの画像幅の 3 倍)。この値より大きい場合は欠陥ではないと判別されます。

注: この値が [最小距離] パラメータより小さい場合、関数の結果は #ERR になります。

サイズ有効

サイズ欠陥を考慮するかどうかを指定します。サイズ欠陥では、エッジに沿った長さが考慮されます。

注: [サイズ有効] と [面積有効] が両方ともに ON の場合は、両方の条件に不適合だった欠陥のみが表示されます。

0 = OFF | サイズ欠陥を考慮しません。
1 = ON (デフォルト) | [最小サイズ] および [最大サイズ] パラメータの設定値に基づいて、サイズ欠陥を考慮します。
最小サイズ | 最小欠陥サイズをピクセル単位で指定します。(有効な範囲は　In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍。デフォルト = 3 ピクセル)。最適ラインからの連続した偏差がこの値より小さい場合は欠陥とはみなされません。
最大サイズ | 最大欠陥サイズをピクセル単位で指定します。(有効な範囲は　In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍。デフォルトはビジョンシステムの画像幅の 3 倍)。最適ラインからの連続した偏差がこの値より大きい場合は欠陥とはみなされません。
面積有効

面積欠陥を考慮するかどうかを指定します。面積欠陥では、最適ラインに沿った長さ、および欠陥エッジの最適ラインからの距離が考慮されます。

注: [サイズ有効] と [面積有効] が両方ともに ON の場合は、両方の条件に不適合だった欠陥のみが表示されます。

0 = OFF | 面積欠陥を考慮しません。
1 = ON (デフォルト) | [最小面積] および [最大面積] パラメータの設定値に基づいて、面積欠陥を考慮します。
最小面積 | 最小欠陥面積をピクセル単位で指定します (有効な範囲は　 0 ～ 1000000倍。デフォルト = 10)。この値より小さい面積は欠陥とはみなされません。
最大面積 | 最大欠陥面積をピクセル単位で指定します (有効な範囲は　 0 ～ 1000000倍。デフォルト = 1000000)。この値より大きい面積は欠陥とはみなされません。
欠陥ライン最適フィルタ

最適ラインとの相対位置に基づいて欠陥をフィルタするかどうかを指定します。

0 = フィルタしない (デフォルト) | 関数は、最適ラインの両側の欠陥を返します。
1 = 最適ラインの左側を無視 | 関数は、最適ラインの左側の欠陥をフィルタし、最適ラインの右側で検出された欠陥のみを返します。
2 = 最適ラインの右側を無視 | 関数は、最適ラインの右側の欠陥をフィルタし、最適ラインの左側で検出された欠陥のみを返します。
ソート基準

検出された欠陥をソートする方法を指定します。

サイズ (デフォルト) | 検出された欠陥を、サイズの大きい順にソートします。
面積 | 検出された欠陥を、面積の大きい順にソートします。
位置 | 検出された欠陥を、キャリパインデックス順にソートします。

ギャップ

エッジ内のギャップを判別するためのパラメータを指定します。

有効

検出されたエッジ内のギャップを考慮するかどうかを指定します。

0 = OFF | ギャップを考慮しません。
1 = ON (デフォルト) | ほかのギャップパラメータの設定に基づいて、ギャップを考慮します。

ギャップ最小値

ギャップ最小値をピクセル単位で指定します。(有効な範囲は　In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍。デフォルト = 3 ピクセル)。この値より小さいギャップはギャップとはみなされません。

ギャップ最大値

ギャップ最大値をピクセル単位で指定します。(有効な範囲は　In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍。デフォルトはビジョンシステムの画像幅の 3 倍)。この値より大きいギャップはギャップとはみなされません。
最大移動距離

最適ラインをギャップとみなす、最適ラインからの最大移動距離をピクセル単位で指定します (有効な範囲は　In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルトはビジョンシステムの画像幅の 3 倍)。この設定は、検出されたエッジのうち、ほかのエッジと同じ最適ラインに沿っていないエッジを削除するフィルタとして機能します。

注: [エッジペアの検査] パラメータが有効な場合は、領域の中心からエッジペアの中心までの最大移動距離がピクセル単位で測定されます。この距離が [最大移動距離] パラメータの値より大きい場合は、ギャップとみなされます。
終端ギャップを無視

ROI の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。

0 = OFF | ROI の始まりと終わりで検出されたギャップを考慮しません。
1 = ON (デフォルト) | ROI の始まりと終わりで検出されたギャップを考慮します。
ソート基準

検出されたギャップをソートする方法を指定します。

サイズ (デフォルト) | 検出されたギャップを、サイズの大きい順にソートします。
位置 | 検出されたギャップを、キャリパインデックス順にソートします。

キャリパインデックス

画像上に表示するキャリパを指定します (キャリパは緑色に囲まれて表示されます)。デフォルトで表示されるキャリパは 0 です。

表示

画像上のこの関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | InspectEdgeForDefect 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらかが常に表示されます。
2 = 結果のグラフィックスと検出されたエッジ | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、および検出されたエッジ点が常に表示されます。
3 = 結果のグラフィックスとキャリパの詳細 | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、検出されたエッジ点、およびインデックス付きキャリパウィンドウが常に表示されます。
4 = すべて表示: 入力と結果のグラフィックス | 入力領域、最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、および検出されたエッジ点が常に表示されます。

InspectEdgeForDefect 関数の出力

戻り値 | 検出された欠陥、除外距離、およびギャップを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | InspectEdgeForDefect 関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが作成されます。この結果テーブルは、実行中の検索タイプに対応しています。 Closed 例 - デフォルトの最適直線エッジ結果テーブル Closed 例 - デフォルトの最適円エッジ結果テーブル Closed 例 - デフォルトのエッジペア結果テーブル 注: [欠陥/ギャップ最大数] パラメータの値がゼロより大きい場合、InspectEdgeForDefect 関数は、最初の 10 個の欠陥/ギャップ/エッジ/エッジペアに対応する「最大」10 個のエントリを含む結果テーブルを自動的にデータ構造体に挿入します。追加のエントリを表示する場合は、最後の行をコピーして末尾に追加の行を貼り付けることによってテーブルを拡張することができます。

InspectEdgeForDefect 関数データアクセス関数

次のデータアクセス関数が、InspectEdgeForDefect データ構造体結果テーブルを作成するためにスプレッドシートに自動挿入されます。このスプレッドシートは、要約、欠陥、ギャップ、および除外距離の 4 つのセクションに分けられます。

注:

InspectEdgeForDefect 関数の数式はすべて次の条件に適合しています。

  • 検査 = InspectEdgeForDefect 関数によって出力された [image] データ構造体
  • キャリパインデックス = 0 ～ N (キャリパの総数は、InspectEdgeForDefect 関数が参照している InspectEdge 関数によって出力されたキャリパの数と同じ)
  • エッジペアインデックス = 0 または 1
  • エッジインデックス = 0 ～ N
  • 点インデックス = 0 ～ 1

[エッジペアの検査] パラメータが有効な場合は、エッジ 1 のデータの追加行が自動的にスプレッドシートに挿入されます。この場合、インデックス 0 はエッジ 0 に関係する情報を返し、インデックス 1 はエッジ 1 に関係する情報を返します。

スプレッドシート名 | 関数名 | 説明
要約
欠陥/ギャップ | GetDefectGapCount(検査, [エッジペアインデックス], [欠陥/ギャップ]) | 指定した内容に応じて、欠陥/ギャップの数を返します。欠陥 = 0、ギャップ = 1。
行 0/1 | GetFitEdgeRow(検査, [エッジペアインデックス], [点インデックス]) | 指定した点の行座標を返します。
列 0/1 | GetFitEdgeCol(検査, [エッジペアインデックス], [点インデックス]) | 指定した点の列座標を返します。
中心行 | GetFitEdgeCenterRow(検査, [エッジペアインデックス]) | 最適円を指定した場合に挿入され、最適円の中心の行座標を返します。
中心列 | GetFitEdgeCenterCol(検査, [エッジペアインデックス]) | 最適円を指定した場合に挿入され、最適円の中心の列座標を返します。
半径 | GetFitEdgeRadius(検査, [エッジペアインデックス]) | 最適円を指定した場合に挿入され、最適円の中心から選択したエッジペアまでの距離を返します。
欠陥/ギャップ
サイズ/面積 | GetDefectGapValue(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス], [サイズ/面積/幅]) | 欠陥またはギャップの領域のサイズを返します。欠陥 = 0、ギャップ = 1、サイズ = 0、面積 = 1、幅 = 2。
行 | GetDefectGapBoundsRow(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の行座標を返します。欠陥 = 0、ギャップ = 1。
列 | GetDefectGapBoundsCol(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の列座標を返します。欠陥 = 0、ギャップ = 1。
高さ | GetDefectGapBoundsHigh(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の高さを返します。欠陥 = 0、ギャップ = 1。
幅 | GetDefectGapBoundsWide(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の幅を返します。欠陥 = 0、ギャップ = 1。
角度 | GetDefectGapBoundsAngle(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の角度を返します。欠陥 = 0、ギャップ = 1。
カーブ | GetDefectGapBoundsCurve(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形のカーブを返します。欠陥 = 0、ギャップ = 1。
始まり/終わり | GetDefectGapCaliperIndex(検査, [欠陥/ギャップインデックス], [欠陥/ギャップ], [エッジペアインデックス], [欠陥の始まり/終わり]) | 欠陥が始まるキャリパまたは終わるキャリパを返します。欠陥 = 0、ギャップ = 1、始まり = 0、終わり = 1。
除外距離 - 最も遠い点 1/2
キャリパ | GetExtremePoints(検査, [エッジペアインデックス], [近い/遠い]) | エッジが最適ラインから最も離れているキャリパのインデックスを返します (近い = 0、遠い = 1)。
行 | GetEdgeRow(検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス]) | 参照したエッジの行座標を返します。
列 | GetEdgeCol(検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス]) | 参照したエッジの列座標を返します。
距離 | GetEdgeFromFit(検査, [キャリパインデックス], [エッジペアインデックス]) | 参照したキャリパのエッジから最適ラインまでの距離を返します。

関連項目

  • InspectEdge ツールについて
  • InspectEdge 関数
  • InspectEdge 関数のデータアクセス関数
  • InspectEdgePosition 関数
  • InspectEdgeWidth 関数
  • TransInspEdgeDefectToWorld 関数
  • プロパティシートの使用方法


InspectEdgePosition 関数

InspectEdgePosition 関数 |
ビジョンツール → InspectEdge | In-Sight 関数リファレンス

InspectEdgePosition 関数は、InspectEdge 関数によって返されるエッジに関する詳細なエッジ解析を行うためのエッジモデルを構築するために使用します。このデータは、エッジの位置の判別、除外距離エッジの識別、および必要に応じて最適ラインの構築を行うために使用します。

  • InspectEdgePosition 関数の概要
  • InspectEdgePosition の入力パラメータ
  • InspectEdgePosition の出力
  • InspectEdgePosition 関数のデータアクセス関数
  • InspectEdgePosition 関数の関連項目

InspectEdgePosition 関数概要

スプレッドシートにこの関数を挿入した後に、InspectEdge 関数によって出力された [image] データ構造体に対する参照を作成する必要があります。InspectEdge 関数への参照が確立されると、InspectEdgePosition 関数のパラメータを設定することによってエッジモデルが作成されます。エッジモデルでは次の項目が定義されます。

  • 最適ラインのタイプ - 直線または円形。
  • エッジを検出する方向。
  • エッジ変化のタイプ - 白から黒または黒から白。
  • 不必要なエッジをフィルタ処理するために使用するエッジ得点付け基準。
  • 最適ラインから不必要なエッジをフィルタ処理するために使用する最適ライン基準。

エッジモデルが確立されると、この関数によってエッジ候補がエッジモデルと比較され、モデルからの偏差が報告されます。

InspectEdgePosition 関数の入力パラメータ

InspectEdgePosition 関数(

エッジ検査関数,

最適ライン,

エッジ方向の検出,

エッジ: 第1,

エッジ得点.得点しきい値,

エッジ得点.エッジ規則,

エッジ得点.コントラスト上限,

最適ラインの詳細設定.外れ値の削除,

最適ラインの詳細設定.最適距離フィルタ,

最適ラインの詳細設定.最端フィルタ距離,

最適ラインの詳細設定.得点再計算,

最適ラインの詳細設定.最適ライン再計算,

キャリパインデックス,

表示

)

エッジ検査関数

 InspectEdge 関数によって返された有効な [image] データ構造体を含むスプレッドシートセルへの参照を指定します。

最適ライン

検出されたエッジから作成する最適ラインの種類を指定します。

0 = なし | 最適ラインを作成しません。ROI の中心を基準に、検出されたエッジの位置を測定します。
1 = 最適直線 | 関数は、検出されたエッジから最適直線を作成します。最適ラインを基準に、検出されたエッジの位置を測定します。
2 = 最適円 | 関数は、検出されたエッジから最適円を作成します。最適ラインを基準に、検出されたエッジの位置を測定します。
3 = 自動調整 (デフォルト) | 関数は、参照先領域に基づいて最適直線または最適円のいずれかを自動的に作成します。

エッジ方向の検出

エッジを検出する方向を指定します。エッジを検出する方向をグラフィックス表示するために、暗い緑の矢印が追加されます。最適ラインには、画像内にグラフィックス表示でラベルが付けられます。最初の最適ラインには 0、2 番目の最適ラインには 1 が付けられます。

注:参照している InspectEdge 関数の ROI がカーブしている場合、検査はカーブの中心に対して行われます。[エッジ方向の検出] パラメータが [左→右] に設定されている場合は、カーブの中心方向に向かって検査され、[右→左] に設定されている場合はカーブの中心から外側へ向かって検査されます。

0 = 左→右 (デフォルト) | ROI の左から右に向かってエッジを検出します。 Closed 例
1 = 右→左 | ROI の右から左に向かってエッジを検出します。 Closed 例

エッジ: 第1

[エッジ方向の検出] パラメータに従って、検出された最初のエッジのコントラスト変化を指定します。

1 = 黒→白 | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 (デフォルト) | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは黒→白または白→黒のいずれかに変化でき、この関数は適切な変化を決定します。変化を指定すると、関数のパフォーマンスが改善します。

エッジ得点

指定した基準をエッジが満たすかどうかを判別するために使用する、エッジ得点モードを指定します。

得点しきい値

得点付けのしきい値を指定します。この値 (0 ～ 100、デフォルト = 10) より小さい得点のエッジはフィルタで除去されます。

エッジ規則

得点を計算するときに最も重要になるエッジのタイプを指定します。

1 = 最初のエッジ | 検出された最初のエッジに注目します。
2 = エッジ強度 | 最強のコントラスト変化を持つエッジに注目します。
3 = 最初のエッジ/エッジ強度 (デフォルト) | 最初に検出され、最強のコントラスト変化を持つエッジに注目します。

コントラスト上限

エッジとみなすエッジコントラスト変化の上限 (2 ～ 255、デフォルト = 255) を指定します。この値を超えるエッジコントラスト変化を持つエッジの得点は、すべて同じ最高得点になります。

最適ラインの詳細設定

最適ラインを構築する方法を指定します。

外れ値の削除

[最適距離フィルタ] パラメータで指定されている距離より遠い点を最適ラインから削除するように指定します。

0 = OFF (デフォルト) | 除外距離エッジを考慮しません。
1 = ON | 計算時に除外距離エッジを考慮します。

最適距離フィルタ

最適ライン再計算で利用するためにエッジが元の最適ラインから離れている必要がある距離をピクセル単位で指定します (有効な範囲は　In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト = 2)。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。この設定を有効にするには、[外れ値の削除] が ON になっている必要があります。

最端フィルタ距離

除外距離が、まだ最適ラインの一部とみなされる最適ラインからの距離を指定します (有効な範囲は In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト はビジョンシステムの画像幅の 3 倍)。この値より大きなエッジはすべて無視されます。
得点再計算

最適ラインにより近いエッジを選択するために、エッジを得点再計算するように指定します。

0 = OFF (デフォルト) | 除外距離を考慮するためにエッジを得点再計算しません。
1 = ON | 計算時に除外距離エッジを考慮するために得点再計算を行います。
最適ライン再計算

エッジの得点再計算後に最適ラインの再適合を行うように指定します。この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。

0 = OFF (デフォルト) | 最適ラインの再適合を行いません。
1 = ON | エッジの得点再計算後に最適ラインの再適合を行います。

キャリパインデックス

画像上に表示するキャリパを指定します (キャリパは緑色に囲まれて表示されます)。デフォルトで表示されるキャリパは 0 です。

表示

画像上にオーバーレイする InspectEdgePosition グラフィックスの表示モードを指定します。

0 = 非表示 (デフォルト) | InspectEdgePosition 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらかが常に表示されます。
2 = 結果のグラフィックスとキャリパの詳細 | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、検出されたエッジ点、およびインデックス付きキャリパウィンドウが常に表示されます。
3 = すべて表示: 入力と結果のグラフィックス | 入力領域、最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、および検出されたエッジ点が常に表示されます。

InspectEdgePosition 関数の出力

戻り値 | 得点によってソートされ、一致したエッジを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | InspectEdgePosition 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。 Closed 例 - デフォルトの最適直線エッジ結果テーブル Closed 例 - デフォルトの最適円エッジ結果テーブル

InspectEdgePosition 関数データアクセス関数

次のデータアクセス関数が、InspectEdgePosition データ構造体結果テーブルを作成するためにスプレッドシートに自動挿入されます。このスプレッドシートは、最も遠い点および最適直線の 2 つのセクションに分けられます。

スプレッドシート名 | 関数名 | 説明
最も遠い点
点 1 /点 2 | GetExtremePosPoints(検査, サイド) | いずれかの側で最適ラインから最も遠いエッジを持つキャリパのインデックスを返します (近い = 0 および遠い = 1)。[最適ライン] が [なし] に設定されている場合は、領域の最も近い側の点を返します。
行 | GetEdgePosRow(検査, キャリパインデックス, エッジインデックス) | 指定したキャリパのエッジ位置の行座標を返します。
列 | GetEdgePosCol(検査, キャリパインデックス, エッジインデックス) | 指定したキャリパのエッジ位置の列座標を返します。
最適直線
行 0/行 1 | GetFitEdgePosRow(検査, 点インデックス) | 最適直線の指定した点の行座標を返します。
列 0/列 1 | GetFitEdgePosCol(検査, 点インデックス) | 最適直線の指定した点の列座標を返します。
中心行 | GetFitEdgePosCenterRow(検査, 点インデックス) | 最適円を指定した場合に挿入され、最適円の中心の行座標を返します。
中心列 | GetFitEdgePosCenterCol(検査, 点インデックス) | 最適円を指定した場合に挿入され、最適円の中心の列座標を返します。
半径 | GetFitEdgePosRadius(検査, 点インデックス) | 最適円を指定した場合に挿入され、最適円の中心からの距離を返します。

注:

InspectEdgePosition 関数の数式はすべて次の条件に適合しています。

  • 検査 = InspectEdgePosition 関数によって出力された [image] データ構造体
  • キャリパインデックス = 0 ～ N (キャリパの総数は、InspectEdgeForDefect 関数が参照している InspectEdge 関数によって出力されたキャリパの数と同じ)
  • エッジペアインデックス = 0 または 1
  • エッジインデックス = 0 ～ N
  • 点インデックス = 0 ～ 1 (0 = 始まり、1 = 終わり)

関連項目

  • InspectEdge ツールについて
  • InspectEdge 関数
  • InspectEdge 関数のデータアクセス関数
  • InspectEdgeForDefect 関数
  • InspectEdgeWidth 関数
  • プロパティシートの使用方法


InspectEdgeWidth 関数

InspectEdgeWidth 関数 |
ビジョンツール → InspectEdge | In-Sight 関数リファレンス

InspectEdgeWidth 関数は、InspectEdge 関数によって返されるエッジペアに関する詳細なエッジ解析を行うためのエッジモデルを構築するために使用します。このデータは、エッジペアを検出して、それらの間の距離を解析するために使用されます。

  • InspectEdgeWidth 関数の概要
  • InspectEdgeWidth の入力パラメータ
  • InspectEdgeWidth の出力
  • InspectEdgeWidth 関数のデータアクセス関数
  • InspectEdgeWidth 関数の関連項目

InspectEdgeWidth 関数概要

スプレッドシートにこの関数を挿入した後に、InspectEdge 関数によって出力された [image] データ構造体に対する参照を作成する必要があります。InspectEdge 関数への参照が確立されると、InspectEdgeWidth 関数のパラメータを設定することによってエッジモデルが作成されます。エッジモデルでは次の項目が定義されます。

  • エッジを検出する方向。
  • エッジ変化のタイプ - 白から黒または黒から白。
  • 不必要なエッジをフィルタ処理するために使用するエッジ得点付け基準。
  • 最適ラインから不必要なエッジをフィルタ処理するために使用する最適ライン基準。
  • 幅の偏差、欠陥とギャップの両方またはいずれかの検出に使用する許容値。
  • 位置の偏差の許容値 (ビードパスを検出する場合)。

エッジモデルが確立されると、この関数によってエッジ候補がエッジモデルと比較され、モデルからの偏差が報告されます。

注: InspectEdgeWidth 関数を InspectEdgeTrainBeadPath 関数および InspectEdge 関数と組み合わせて使用すると、ビードパスに関連する幅と位置のエラーを判別できます。InspectEdgeWidth 関数の [InspectEdge] パラメータは、InspectEdgeTrainBeadPath 関数を参照している InspectEdge 関数によって出力された [image] データ構造体を参照している必要があります。

InspectEdgeWidth 関数の入力パラメータ

InspectEdgeWidth 関数(

エッジ検査関数,

エッジ方向の検出,

エッジ: 第1,

エッジ: 第2,

エッジ得点.得点しきい値,

エッジ得点.エッジ規則,

エッジ得点.コントラスト上限,

エッジ得点.ペアサイズ,

詳細なフィルタ.得点再計算,

詳細なフィルタ.最適ライン,

詳細なフィルタ.外れ値の削除,

詳細なフィルタ.最適距離フィルタ,

欠陥/ギャップ最大数,

欠陥.最小幅,

欠陥.最大幅,

欠陥.サイズ,

欠陥.最小サイズ,

欠陥.最大サイズ,

欠陥.面積有効,

欠陥.最小面積,

欠陥.最大面積,

欠陥.ソート基準,

ギャップ.有効,

ギャップ.ギャップ最小値,

ギャップ.ギャップ最大値,

ギャップ.最大移動距離,

ギャップ.終端ギャップを無視,

ギャップ.ソート基準,

位置.有効,

位置.最小距離,

位置.最大距離,

位置.サイズ,

位置.最小サイズ,

位置.最大サイズ,

位置.面積,

位置.最小面積,

位置.最大面積,

位置.ソート基準,

キャリパインデックス,

表示

)

エッジ検査関数

InspectEdge 関数によって返された有効な [image] データ構造体を含むスプレッドシートセルへの参照を指定します。

エッジ方向の検出

エッジを検出する方向を指定します。エッジを検出する方向をグラフィックス表示するために、暗い緑の矢印が追加されます。最適ラインには、画像内にグラフィックス表示でラベルが付けられます。最初の最適ラインには 0、2 番目の最適ラインには 1 が付けられます。

注:参照している InspectEdge 関数の ROI がカーブしている場合、検査はカーブの中心に対して行われます。[エッジ方向の検出] パラメータが [左→右] に設定されている場合は、カーブの中心方向に向かって検査され、[右→左] に設定されている場合はカーブの中心から外側へ向かって検査されます。

0 = 左→右 | ROI の左から右に向かってエッジを検出します。 Closed 例
1 = 右→左 | ROI の右から左に向かってエッジを検出します。 Closed 例
3 = 内→外 (デフォルト) | ROI の中心から ROI の上の境界および下の境界に向かってエッジを検出します (検出されたエッジの順序は、ROI の「X」矢印とは反対の方向の順になります)。 Closed 例 注: このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
2 = 外→内 | ROI の上下の境界から ROI の中心に向かってエッジを検出します (検出されたエッジの順序は、ROI の「X」矢印とは反対の方向の順になります)。 Closed 例 注: このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

エッジ: 第1

[エッジ方向の検出] パラメータに従って、検出された最初のエッジのコントラスト変化を指定します。

1 = 黒→白 | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 (デフォルト) | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは黒→白または白→黒のいずれかに変化でき、この関数は適切な変化を決定します。変化を指定すると、関数のパフォーマンスが改善します。

エッジ: 第2

[エッジ方向の検出] パラメータに従って、検出された 2 番目のエッジのコントラスト変化を指定します。

注:このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

1 = 黒→白 (デフォルト) | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは黒→白または白→黒のいずれかに変化でき、この関数は適切な変化を決定します。変化を指定すると、関数のパフォーマンスが改善します。

エッジ得点

指定した基準をエッジが満たすかどうかを判別するために使用する、エッジ得点モードを指定します。

得点しきい値

得点付けのしきい値を指定します。この値 (0 ～ 100、デフォルト = 10) より小さい得点のエッジはフィルタで除去されます。

エッジ規則

得点を計算するときに最も重要になるエッジのタイプを指定します。

1 = 最初のエッジ | 検出された最初のエッジに注目します。
2 = エッジ強度 | 最強のコントラスト変化を持つエッジに注目します。 注:[エッジペアの検査] パラメータがオンになっている場合、スコアは、2 つのエッジの平均コントラスト値に基づきます。
3 = 最初のエッジ/エッジ強度 (デフォルト) | 最初に検出され、最強のコントラスト変化を持つエッジに注目します。
4 = エッジペアサイズ | [ペアサイズ] パラメータに最も近いサイズで検出されたエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
5 = 最初のエッジ/エッジペアサイズ | [ペアサイズ] パラメータに最も近いサイズで検出された最初のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
6 = エッジ強度/エッジペアサイズ | 最強のコントラスト変化を持ち、[ペアサイズ] パラメータに最も近いサイズで検出されたエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
7 = 最初のエッジ/エッジ強度/エッジペアサイズ | 最強のコントラスト変化を持ち、[ペアサイズ] パラメータに最も近いサイズで検出された最初のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

コントラスト上限

エッジとみなすエッジコントラスト変化の上限 (2 ～ 255、デフォルト = 255) を指定します。この値を超えるエッジコントラスト変化を持つエッジの得点は、すべて同じ最高得点になります。

注: このパラメータを有効にするには、[エッジ規則] パラメータを、[エッジ強度]、[最初のエッジ/エッジ強度]、[エッジ強度/エッジペアサイズ]、[最初のエッジ/エッジ強度/エッジペアサイズ] のいずれかに設定しておく必要があります。

ペアサイズ

最高得点を記録するエッジペアサイズを指定します (有効な範囲は、In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト = 5)。このパラメータが有効な場合、この値の上下で検出されたエッジペアはこの値に比例して得点付けされます。例えば、[ペアサイズ] が 10 に設定されており、値が 8 と値が 14 の 2 つのエッジペア候補が検出された場合は、値 8 のエッジペアが選択されます。これは、2 番目のエッジペアより [ペアサイズ] に近いためです。

注: このパラメータを有効にするには、[エッジペアの検査] パラメータを ON にし、[エッジ規則] パラメータを [エッジペアサイズ]、[最初に検出されたエッジペアサイズ]、[エッジ強度/エッジペアサイズ]、または [最初のエッジ/エッジ強度/エッジペアサイズ] のいずれかに設定しておく必要があります。

詳細なフィルタ

最適ラインを構築する方法を指定します。

得点再計算

最適ラインにより近いエッジを選択するために、エッジを得点再計算するように指定します。

0 = OFF (デフォルト) | 除外距離を考慮するためにエッジを得点再計算しません。
1 = ON | 計算時に除外距離エッジを考慮するために得点再計算を行います。

最適ライン

検出されたエッジから作成する最適ラインの種類を指定します。

1 = 最適直線 | 関数は、検出されたエッジから最適直線を作成します。
2 = 最適円 | 関数は、検出されたエッジから最適円を作成します。
3 = 自動調整 (デフォルト) | 関数は、参照先領域に基づいて最適直線または最適円のいずれかを自動的に作成します。

外れ値の削除

[最適距離フィルタ] パラメータで指定されている距離より遠い点を最適ラインから削除するように指定します。

0 = OFF (デフォルト) | 除外距離エッジを考慮しません。
1 = ON | 計算時に除外距離エッジを考慮します。

最適距離フィルタ

最適ライン再計算で利用するためにエッジが元の最適ラインから離れている必要がある距離をピクセル単位で指定します (有効な範囲は　In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト = 2)。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。この設定を有効にするには、[外れ値の削除] が ON になっている必要があります。

欠陥/ギャップ最大数

検出する欠陥とギャップの両方またはいずれかの最大数を指定します (1 ～ 4096、デフォルト = 5)。この値は、欠陥とギャップに個別に適用されます。例えば、値を 5 に設定すると、最大 5 つの欠陥と 5 つのギャップが検出されます。この設定は、スプレッドシートにデータアクセス結果テーブルを構築するために使用されます。

欠陥

最適ラインのエッジの欠陥を判別するためのパラメータを指定します。

最小幅

検出されたエッジペアの間の距離をピクセル単位で指定します。この値より小さい場合は欠陥であると判別されます。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは 3 ピクセルです。

最大幅

検出されたエッジペアの間の距離をピクセル単位で指定します。この値より大きい場合は欠陥であると判別されます。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは、ビジョンシステムの画像幅の 3 倍です。

注: この値が [最小幅] パラメータより小さい場合、関数の結果は #ERR になります。

サイズ有効

サイズ欠陥を考慮するかどうかを指定します。サイズ欠陥では、検出されたエッジペアの長さに沿った幅偏差が考慮されます。

注: [サイズ有効] と [面積有効] が両方ともに ON の場合は、両方の条件に不適合だった欠陥のみが表示されます。

0 = OFF | サイズ欠陥を考慮しません。
1 = ON (デフォルト) | [最小サイズ] および [最大サイズ] パラメータの設定値に基づいて、サイズ欠陥を考慮します。
最小サイズ | 最小欠陥サイズをピクセル単位で指定します。最適ラインからの連続した偏差がこの値より小さい場合は欠陥とはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは 3 ピクセルです。
最大サイズ | 最大欠陥サイズをピクセル単位で指定します。最適ラインからの連続した偏差がこの値より大きい場合は欠陥とはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは、ビジョンシステムの画像幅の 3 倍です。
面積有効

面積欠陥を考慮するかどうかを指定します。面積欠陥では、最適ラインに沿った長さ、および欠陥エッジの最適ラインからの距離が考慮されます。

注: [サイズ有効] と [面積有効] が両方ともに ON の場合は、両方の条件に不適合だった欠陥のみが表示されます。

0 = OFF | 面積欠陥を考慮しません。
1 = ON (デフォルト) | [最小面積] および [最大面積] パラメータの設定値に基づいて、面積欠陥を考慮します。
最小面積 | 最小欠陥面積をピクセル単位で指定します (有効な範囲は　 0.001 ～ 100000倍。デフォルト = 10)。この値より小さい面積は欠陥とはみなされません。
最大面積 | 最大欠陥面積をピクセル単位で指定します (有効な範囲は　 0.001 ～ 1000000倍。デフォルト = 1000000)。この値より大きい面積は欠陥とはみなされません。
ソート基準

検出された欠陥をソートする方法を指定します。

サイズ (デフォルト) | 検出された欠陥を、サイズの大きい順にソートします。
面積 | 検出された欠陥を、面積の大きい順にソートします。
位置 | 検出された欠陥を、キャリパインデックス順にソートします。
幅 | 検出された欠陥を、幅の大きい順にソートします。

ギャップ

エッジ内のギャップを判別するためのパラメータを指定します。

有効

検出されたエッジペア内のギャップを考慮するかどうかを指定します。

0 = OFF | ギャップを考慮しません。
1 = ON (デフォルト) | ほかのギャップパラメータの設定に基づいて、ギャップを考慮します。

ギャップ最小値

ギャップ最小値をピクセル単位で指定します。この値より小さいギャップはギャップとはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは 3 ピクセルです。

ギャップ最大値

ギャップ最大値をピクセル単位で指定します。この値より大きいギャップはギャップとはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは、ビジョンシステムの画像幅の 3 倍です。
最大移動距離

ギャップとみなされる、領域の中心からエッジペアの中心までの最大移動距離をピクセル単位で指定します。有効な範囲は、In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍です。デフォルトは、ビジョンシステムの画像幅の 3 倍です。
終端ギャップを無視

ROI の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。

0 = OFF | ROI の始まりと終わりで検出されたギャップを考慮しません。
1 = ON (デフォルト) | ROI の始まりと終わりで検出されたギャップを考慮します。
ソート基準

検出されたギャップをソートする方法を指定します。

サイズ (デフォルト) | 検出されたギャップを、サイズの大きい順にソートします。
位置 | 検出されたギャップを、キャリパインデックス順にソートします。

位置

エッジペア内の位置欠陥を判別するためのパラメータを指定します。パラメータは、InspectEdgeTrainBeadPath 関数によって出力されたモデルパスの中心からの偏差として欠陥を定義しています。これらのパラメータは、InspectEdgeTrainBeadPath 関数を参照する InspectEdge 関数を参照している場合にのみ使用します。

有効

検出されたエッジペア内の位置欠陥を考慮するかどうかを指定します。

0 = OFF (デフォルト) | 位置欠陥を考慮しません。
1 = ON | 他の位置パラメータの設定に基づいて、位置欠陥を考慮します。

最小距離

検出されたビードパスの中心からの最小位置移動距離をピクセル単位で指定します。この値より小さい位置偏差は、位置欠陥とはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは 3 ピクセルです。

最大距離

検出されたビードパスの中心からの最大位置移動距離をピクセル単位で指定します。この値より大きい位置偏差は、位置欠陥とはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは、ビジョンシステムの画像幅の 3 倍です。
サイズ有効

サイズ欠陥を考慮するかどうかを指定します。サイズ欠陥では、検出されたエッジペアの長さに沿った幅偏差が考慮されます。

注: [サイズ有効] と [面積有効] が両方ともに ON の場合は、両方の条件に不適合だった欠陥のみが表示されます。

0 = OFF | サイズ欠陥を考慮しません。
1 = ON (デフォルト) | [最小サイズ] および [最大サイズ] パラメータの設定値に基づいて、サイズ欠陥を考慮します。
最小サイズ | 最小欠陥サイズをピクセル単位で指定します。最適ラインからの連続した偏差がこの値より小さい場合は欠陥とはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは 3 ピクセルです。
最大サイズ | 最大欠陥サイズをピクセル単位で指定します。最適ラインからの連続した偏差がこの値より大きい場合は欠陥とはみなされません。有効な範囲は、In-Sight ビジョンシステムの画像幅の 0.001 ～ 3 倍です。デフォルトは、ビジョンシステムの画像幅の 3 倍です。
面積有効

面積欠陥を考慮するかどうかを指定します。面積欠陥では、最適ラインに沿った長さ、および欠陥エッジの最適ラインからの距離が考慮されます。

注: [サイズ有効] と [面積有効] が両方ともに ON の場合は、両方の条件に不適合だった欠陥のみが表示されます。

0 = OFF | 面積欠陥を考慮しません。
1 = ON (デフォルト) | [最小面積] および [最大面積] パラメータの設定値に基づいて、面積欠陥を考慮します。
最小面積 | 最小欠陥面積をピクセル単位で指定します。この値より小さい領域は欠陥とはみなされません。有効な範囲は 0.001 ～ 100000 で、デフォルトは 10 です。
最大面積 | 最大欠陥面積をピクセル単位で指定します。この値より大きい領域は欠陥とはみなされません。有効な範囲は 0.001 ～ 1000000 で、デフォルトは 1000000 です。
ソート基準

検出された欠陥をソートする方法を指定します。

サイズ (デフォルト) | 検出された欠陥を、サイズの大きい順にソートします。
面積 | 検出された欠陥を、面積の大きい順にソートします。
位置 | 検出された欠陥を、キャリパインデックス順にソートします。
幅 | 検出された欠陥を、幅の大きい順にソートします。

キャリパインデックス

画像上に表示するキャリパを指定します (キャリパは緑色に囲まれて表示されます)。デフォルトで表示されるキャリパは 0 です。

表示

画像上の InspectEdgeWidth グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | InspectEdgeWidth 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらかが常に表示されます。
2 = 結果のグラフィックスと検出されたエッジ | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、および検出されたエッジ点が常に表示されます。
3 = 結果のグラフィックスとキャリパの詳細 | 最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、検出されたエッジ点、およびインデックス付きキャリパウィンドウが常に表示されます。
4 = すべて表示: 入力と結果のグラフィックス | 入力領域、最適ライン、検出された欠陥、除外距離点とギャップの両方またはどちらか、および検出されたエッジ点が常に表示されます。

InspectEdgeWidth 関数の出力

戻り値 | 検出された欠陥、除外距離、およびギャップを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | 初めてInspectEdgeWidth 関数セルに挿入すると、スプレッドシートに結果テーブルが作成されます 注: [欠陥/ギャップ最大数] パラメータの値がゼロより大きい場合、InspectEdgeWidth 関数は、最初の 10 個の欠陥/ギャップ/エッジ/エッジペアに対応する「最大」10 個のエントリを含む結果テーブルを自動的にデータ構造体に挿入します。追加のエントリを表示する場合は、最後の行をコピーして末尾に追加の行を貼り付けることによってテーブルを拡張することができます。

InspectEdgeWidth 関数データアクセス関数

次のデータアクセス関数が、データ構造体結果テーブルを作成するためにスプレッドシートに自動挿入されます。

スプレッドシート名 | 関数名 | 説明
総数 | GetTotalCount(検査) | 結果の総数を返します。
欠陥/ギャップ/位置 | GetWidthCount(検査, 欠陥/ギャップ/位置) | 指定した欠陥またはギャップの総数を返します (欠陥 = 0、ギャップ = 1、位置 = 2)。
欠陥/ギャップ/位置
サイズ/面積/幅/位置 | GetDefectGapValue(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス, サイズ/面積/幅) | 欠陥またはギャップのサイズ、面積、または幅を返します (欠陥 = 0、ギャップ = 1、位置 = 2、サイズ = 0、面積 = 1、幅 = 2)。
行 | GetDefectGapBoundsRow(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス) | 欠陥に外接する矩形の行座標を返します。
列 | GetDefectGapBoundsCol(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス) | 欠陥に外接する矩形の列座標を返します。
高さ | GetDefectGapBoundsHigh(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス) | 欠陥に外接する矩形の高さを返します。
幅 | GetDefectGapBoundsWide(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス) | 欠陥に外接する矩形の幅を返します。
角度 | GetDefectGapBoundsAngle(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス) | 欠陥に外接する矩形の角度を返します。
カーブ | GetDefectGapBoundsCurve(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス) | 欠陥に外接する矩形のカーブを返します。
始まり/終わり | GetDefectGapCaliperIndex(検査, 欠陥/ギャップインデックス, 欠陥/ギャップ/位置, エッジペアインデックス, 欠陥の始まり/終わり) | 欠陥が始まるキャリパまたは終わるキャリパを返します (始まり = 0、終わり = 1)。
除外距離 - 最も遠い点 1/2
キャリパ | GetExtremeWidth(検査, 最薄/最厚) | 指定した極端な幅を含むキャリパのインデックスを返します (最薄 = 0 および最厚 = 1)。
幅 | GetWidth(検査, キャリパインデックス) | インデックス付きキャリパ内のエッジの幅を返します。インデックス付きキャリパ内でエッジが検出されなかった場合は 0 を返します。
行 (始まりおよび終わり) | GetEdgePairRow(検査, キャリパインデックス, エッジペアインデックスまたはエッジインデックス) | 参照したエッジの行座標を返します。
列 (始まりおよび終わり) | GetEdgePairCol(検査, キャリパインデックス, エッジペアインデックスまたはエッジインデックス) | 参照したエッジの列座標を返します。

注:
  • InspectEdgeWidth 関数の数式はすべて次の条件に適合しています。
  • 検査 = InspectEdgeWidth 関数によって出力された [image] データ構造体
  • キャリパインデックス = 0 ～ N (キャリパの総数は、InspectEdgeForDefect 関数が参照している InspectEdge 関数によって出力されたキャリパの数と同じ)
  • エッジペアインデックス = 0 または 1
  • エッジインデックス = 0 ～ N
  • 点インデックス = 0 ～ 1
  • [位置.有効] パラメータが ON の場合、Vision Data Access 関数の追加セクションが位置エラーに関連するスプレッドシートに挿入されます。

関連項目

  • InspectEdge ツールについて
  • InspectEdge 関数
  • InspectEdge 関数のデータアクセス関数
  • InspectEdgeForDefect 関数
  • InspectEdgePosition 関数
  • TransInspEdgeWidthToWorld 関数
  • プロパティシートの使用方法


文字照合/認識関数

ビジョンツール

In-Sight 関数リファレンス

文字照合/認識ツールは、登録フォントを使用してテキスト文字列の読み取りや照合を行います。文字照合/認識ツールには次の関数があります。

  • OCRMax 関数: テキスト文字列の文字を登録、読み取り、および照合します。
  • OCRMaxAutoTune 関数: [オートチューン] ダイアログ への外部アクセスを提供します。
  • OCRMaxSettings 関数: セグメントパラメータやその他の高度なテキスト読み込みパラメータへのプログラムによるアクセスを提供します。
  • ReadText 関数: テキスト文字列を読み取ります。
  • TrainFont 関数: フォント文字を登録します。
  • VerifyText 関数: テキスト文字列を照合します。
注:
  • TrainFont、ReadText、VerifyText の各関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadText、TrainFont および VerifyText 関数の代わりに、OCRMax 関数を使用することを推奨します。OCRMax 関数には拡張性能機能が搭載されています。

文字照合/認識関数概要

In-Sight Explorer には、画像内の英数字テキスト文字列を調べるための光学式文字照合 (OCV) と光学式文字認識 (OCR) の 2 つの異なる方法があります。使用するのは、OCRMax 関数、OCRMaxSettings 関数、ReadText 関数、TrainFont 関数、および VerifyText 関数です。

注: OCRMax 関数および OCRMaxSettings 関数は、In-Sight ファームウェアバージョン 4.7.0 以降を実行する In-Sight ビジョンシステムにのみ対応しています。

OCRMax 関数および OCRMaxSettings 関数

OCRMax 関数は、セグメンテーションと分類のプロセスを通じて OCR を実行します。セグメンテーションは、最初に実行され、しきい値技術を使用してテキスト行を含むとみなされる画像内の領域を特定します。テキストを文字にセグメンテーションした後、文字を登録し、フォントデータベースとして格納します。分類は、実行時に行われ、関数がセグメンテーションを実行した後に、検出されたテキストの「読み取り」を担います。これは、セグメンテーションされた文字の画像と登録された文字のフォントを比較することで実行されます。

注: OCRMax 関数は自己完結型の関数です。つまり、OCRMaxSettings 関数を使用せずにセグメンテーションと分類を実行できます。OCRMaxSettings 関数は、非常に難しいアプリケーション向けの高度なセグメンテーションおよび分類パラメータを提供し、設定をプログラムで制御して、リモートデバイスからのパラメータの調整をサポートします。

セグメント化

セグメンテーションプロセスでは、OCRMax 関数が ROI 内のテキスト行の位置を判別し、テキストの角度、傾き、および極性を計算します。その後、領域を正規化し、不要なノイズを除去してから、前景ピクセルと背景ピクセルに 2 値化します。2 値化画像内でブロブ解析を実行し、文字フラグメントを生成します。各文字フラグメントが単一のブロブを表します。文字フラグメントをグループ化して文字を形成し、その文字に文字矩形を割り当てます。

ROI 内のテキスト行は、個々の文字の画像に分割され、各文字は編集不可の文字矩形で囲まれます。ROI は、テキスト行のおよその位置、角度、傾きを定義します。必要に応じて、[セグメント] タブの [角度範囲] および [スキュー範囲] パラメータを使用して、偏差を補正できます。

注: OCRMax 関数が汎用目的の文字列検索機能ではない点を理解することが重要です。ROI が大きい複雑な画像内の文字列は検出できません。ROI は、テキスト行の直近に設定する必要があります。

分類

セグメンテーションが完了すると、文字はフォントデータベースに登録され、実行時の画像で文字の分類が開始されます。分類では、セグメンテーションされた文字画像を入力として使用し、対応する文字を判別します。テキスト行のセグメンテーションされた文字画像をすべて分類することで、テキスト行全体の文字列全体が返されます。

分類は登録後に実行され、入力された文字の文字列またはユーザ割り当ての値に基づいて、個々の文字にタイトルが割り当てられます。文字の集合が登録され 1 つのフォントにグループ化されると、実行時の画像がフォント内の文字と比較され、最適一致の文字と得点が返されます。

各文字は、分類対象文字の 1 つ以上の例の中から登録されます。文字は、1 つのフォントにグループ化され、OCRMax 関数の [image] データ構造体に格納されます。フォントには、すべての登録文字が含まれます。各文字は、名前、文字矩形の画像、およびその中の情報 (テキストのインクなど) から構成されます。

結果

実行時の画像内で読み取った文字の名前のほかに、追加情報も渡します。また、文字のステータス、文字分類得点、可能な代替文字、およびコンフュージョン得点もレポートします。分類得点は、実行時画像内の文字と登録インスタンスとの一致の度合いを示しています。コンフュージョン得点は、分類得点 (最高得点の登録インスタンス) と次に高い分類得点 (異なるクラスの最高得点の登録インスタンス。可能な代替文字としても使用される、[コンフュージョン] の出力) との差として計算されます。

[検査モード] (読み取りまたは認識と照合) に応じて、結果品質を示すステータスを出力します ([読み取り (Bad)]、[読み取り (Good)]、[無視]、[コンフュージョン]、[ミスマッチ]、[コンフュージョンミスマッチ]、[No read]、および [検証失敗])。認識と照合ステータスは、得点とコンフュージョン得点がそれぞれ [アクセプトしきい値] パラメータと [コンフュージョンしきい値] パラメータの範囲内の場合にのみ返されます。

ReadText 関数、TrainFont 関数、および VerifyText 関数

注: レガシー関数である ReadText、TrainFont および VerifyText 関数の代わりに、OCRMax 関数を使用することを推奨します。OCRMax 関数には拡張性能機能が搭載されています。

ReadText 関数、TrainFont 関数、および VerifyText 関数は、OCV/OCR 機能を分担しています。使用する関数は、テキスト文字列内の文字が既知 (照合) か未知 (認識) かによって決まります。

OCV と OCR のどちらについても、照合または認識する可能性のあるすべての文字の登録モデルを含んでいるフォントが必要です。フォントは、テキスト文字列を個別のセグメントに分割し、各セグメントから文字のサンプル（インスタンスと呼ばれます）を抽出することによって、登録されます。同じ文字の複数のインスタンスを抽出して、1 つの文字モデルに入れることができます。文字モデルの集合全体によって、フォントデータベースが定義されます。

OCV の使用時には、テキスト文字列の各位置の文字がユーザ登録フォントの対応する文字モデルと比較されます。照合に合格するには、モデルと比較される各文字の一致得点が、(1) 最小アクセプトしきい値を超え、(2) フォント内のほかのすべての文字モデルと比較した場合の一致得点を超える必要があります。

OCR の使用時には、テキスト文字列の各文字がユーザ登録フォントのすべての文字モデルと比較されます。必要に応じて、文字モデルの比較数を小さな文字サブセットに制限して、読み取り速度と精度を向上させることができます。最高一致得点を持つ文字モデルによって、各文字の同一性が決定されます。読み取りに合格するには、テキスト文字列の各文字の一致得点が、(1) 最小アクセプトしきい値を超え、(2) 2 番目の一致得点を持つ文字モデルの得点と指定した別のアクセプトしきい値を合わせた値を超える必要があります。

フォントの登録について

フォント登録では、未知のテキストの認識（OCR）、およびテキストの照合（OCV）のために使用される文字モデル（A、B、C、5、$ など）を定義します。実世界画像アプリケーションで発生する可能性があるわずかな差異の影響を打ち消すことができるように、多くの場合、文字モデルの複数のインスタンスが登録されます。アプリケーションで必要となる各文字についてのモデルを確立した後は、In-Sight センサは、既知または未知の文字をこれらの文字モデルと比較することができます。[OCV/OCR フォントの登録] ダイアログは、フォントデータベースの文字モデルの定義および維持に使用します。


OCRMax 関数

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

ユーザ定義の文字フォントが登録された後に、対象領域 (ROI) 内のテキスト文字列の読み取りおよび照合を行うか、またはそのどちらかを実行します。

  • 概要
  • OCRMax の入力パラメータ
    • [全般] タブ
    • [セグメント] タブ
    • [フォントの登録] タブ
    • [フィールド化] タブ
    • [結果] タブ
    • [診断] タブ
  • OCRMax の出力
  • OCRMax データアクセス関数
  • 関連項目

概要

OCRMax 関数は、セグメンテーションと分類のプロセスを通じて光学式文字認識 (OCR) を実行します。セグメンテーションは、最初に実行され、しきい値技術を使用してテキスト行を含むとみなされる画像内の領域を特定します。テキストを文字にセグメンテーションした後、文字を登録し、フォントデータベースとして格納します。分類は、実行時に行われ、関数がセグメンテーションを実行した後に、検出されたテキストの「読み取り」を担います。そして、セグメンテーションされた文字の画像と登録された文字のフォントを比較することで識別されます。

セグメンテーションプロセスでは、OCRMax 関数が ROI 内のテキスト行の位置を判別し、テキストの角度、傾き、および極性を計算します。その後、領域を正規化し、不要なノイズを除去してから、前景ピクセルと背景ピクセルに 2 値化します。2 値化画像内でブロブ解析を実行し、文字フラグメントを生成します。各文字フラグメントが単一のブロブを表します。文字フラグメントをグループ化して文字を形成し、その文字に文字領域を割り当てます。文字領域は、ROI 内の前景 (インクなど) ピクセルすべてを無駄なく囲んだ編集不可のバウンディングボックスです。

ROI 内のテキスト行は、個々の文字の画像に分割され、各文字は編集不可の文字矩形で囲まれます。ROI は、テキスト行のおよその位置、角度、傾きを定義します。必要に応じて、[セグメント] タブの [角度範囲] および [スキュー範囲] パラメータを使用して、偏差を補正できます。

OCRMax 関数の入力パラメータ

オートチューン: [オートチューン] ダイアログを起動して、自動的に最適な [セグメント] パラメータを計算し、フォントデータベースを登録します。[オートチューン] ダイアログの実行中に 1 つまたは複数の画像をロードすると、各画像が検査され、文字が正しくセグメント化および分類されていることが確認されます。文字が正しくセグメント化されていない場合、OCRMax 関数のオートチューンアルゴリズムは、現在の画像および以前に登録した画像をセグメント化する最適な [セグメント] パラメータを計算します。画像の登録数が増えるほど、OCRMax 関数のオートチューンアルゴリズムの信頼性と正確性が向上します。満足な結果が得られたら、[オートチューン] ダイアログを閉じ、新しい [セグメンテーション] パラメータを適用します。フォントデータベースは新たに登録された文字で更新されます。

[オートチューン] ダイアログには、[セグメンテーション] パラメータを手動でチューニングする場合に比べて、主に 2 つの利点があります。

  • 画像に必要なサイクルは、2 回 (1 回目に [セグメンテーション] をチューニングし、2 回目に登録する) ではなく、1 回だけです。
  • 読み取り精度は、チューニングプロセス中に取得される [セグメンテーション] パラメータによって文字が自動的に登録されることによって向上します。

注: OCRMaxAutoTune 関数を使用することにより、VisionView オペレータインタフェースパネルなどの外部デバイスを使用して、[オートチューン] ダイアログに外部からアクセスすることができます。

[全般] タブ

OCRMax 関数(

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

フォント ,

外部設定 ,

登録モード

登録文字列 ,

フォントの登録

フォントをクリア

検査モード

マッチ文字列

フィールド文字列 ,

フィールド定義,

スペース.スペースの検出 ,

スペース.スペース得点モード ,

スペース.スペース最小幅 ,

スペース.スペース最大幅

アクセプトしきい値

コンフュージョンしきい値

サブサンプリングの使用

タイムアウト ,

出力画像グラフィックス

文字ラベル位置

診断の表示 ,

カーブ領域位置,

リセット ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

ROI の X 軸はテキストのベースラインと平行となり、Y 軸は文字の垂直ストロークと平行になります。傾きがない場合は、Y 軸は X 軸に垂直になります。X 軸の正の方向が読み取り方向に対応します。

注: ROI がほぼ同じ角度で設定されるため、画像内のテキストのベースラインは任意の角度 (0 ～ 360) にすることができます。

ROI は、1 行のみの読み取り対象のテキストと周囲の背景を含みます。背景は、ノイズが入っていたり、大きな勾配や影付きの場合もあります。鮮明に印刷されノイズのほとんどないテキストを持つ画像では、ROI はテキスト行より大幅に大きくなることがあります。ノイズの多い画像では、ROI は比較的テキスト行の外郭に近くなります。

注: ROI にテキスト行以外の画像内の他の重要な特徴を含めないでください。例えば、ROI にテキスト近くの別の行やラベルのエッジが部分的に含まれることがないようにします。

経験則として、可能な場合、ROI はすべての側でテキスト行より文字幅の半分以上大きくします (ROI に他の特徴が含まれてしまう大きさにならない限り)。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

フォント

必要に応じて、別の OCRMax 関数によって出力され、登録フォントを含むデータ構造体へのセル参照を指定します。

注: 参照が設定されており、登録フォントを参照する関数内で登録文字を編集する場合、登録文字への変更は、[取り消し] ボタンを押しても取り消されません。

外部設定

必要に応じて、OCRMaxSettings または GetInternalSettings 関数によって出力されたデータ構造体へのセル参照を指定します。[セルにエクスポート] オプションを使用している場合、このパラメータは新しく作成した OCRMaxSettings 関数の [image] データ構造体への絶対セル参照として自動的に設定されます。

注:
  • このパラメータが OCRMaxSettings 関数への参照として設定されている場合、[セグメント] パラメータは無効になります (パラメータを有効なままにする場合は、GetInternalSettings 関数を使用します)。[セグメント] パラメータを再び有効にするには、このパラメータを 0 に設定します。
  • このパラメータが OCRMaxSettings 関数または GetInternalSettings 関数への参照として設定されている場合、[オートチューン] ダイアログは使用できません ([オートチューン] ダイアログを有効にするには、このパラメータを 0 に設定する必要があります)。GetInternalSettings 関数との関連で [オートチューン] ダイアログを有効にする方法については、「GetInternalSettings」関数を参照してください。

登録モード

フォントの登録方法を指定します。

0 = すべての文字をフォントに追加 | [フォントの登録] パラメータがアクティブな場合は、ROI 内のすべての文字がフォントに追加されます。
1 = 新しい文字をフォントに追加 (デフォルト) | [フォントの登録] パラメータがアクティブな場合は、ROI 内の新しい文字のみがフォントに追加されます。
2 = フォント内の登録済み文字を置き換え | [フォントの登録] パラメータがアクティブな場合は、すべての登録文字を現在の ROI 内の文字で置換します。
3 = すべてのフォントを置き換え | [フォントの登録] パラメータがアクティブな場合は、フォント内のすべての文字を現在の ROI 内の文字で置換します。

登録文字列

登録するテキスト文字列を指定します。

注: OCRMax 関数は ASCII 文字の登録のみをサポートしています。

フォントの登録

[登録モード] パラメータの設定に基づいて、文字を登録するためのイベントを指定します。

フォントをクリア

フォント内のすべての文字を削除するためのイベントを指定します。

注: [フォントの登録] および [フォントをクリア] パラメータは、フォント内のすべての文字の削除を開始するイベントと同じイベントを参照し、ROI 内の現在の文字に基づいて再登録することができます。

検査モード

実行時の関数の検査モードを指定します。

読み取り (デフォルト) | 関数は、文字の登録インスタンスに基づいて、ROI 内の文字の読み取りを試みます。
読み取りと照合 | 関数は、最初に文字の登録インスタンスに基づいて ROI 内の文字を読み取り、その後、[マッチ文字列] パラメータに指定されたテキスト文字列と読み取った文字を照合して検証を試みます。

マッチ文字列

認識と照合検査モード時に、正確に一致する必要のあるテキスト文字列を指定します。

フィールド文字列

文字列に含まれる文字数を指定します。[フィールド化] を使用して、文字列のさまざまな位置にあると予測される文字に関する情報を提供します。[フィールド化] タブのコントロールを使用して、フィールド文字列とフィールド定義を作成します (必要な場合)。

注: このパラメータは、[検査モード] パラメータが [読み取り] に設定されている場合のみ使用可能です。

フィールド定義

必要に応じ、フィールド定義設定を使用してフィールド文字列のユーザ定義エントリを作成できます。このエントリがフィールド文字列に含まれると、このエントリの挿入位置で有効となる文字のリストが限定されます。[フィールド化] タブのコントロールを使用して、フィールド文字列とフィールド定義を作成します (必要な場合)。

注: このパラメータは、[検査モード] パラメータが [読み取り] に設定されている場合のみ使用可能です。

スペース

必要な場合に、関数が文字間のスペースを考慮する方法を指定します。OCRMax 関数は、文字間のギャップをスペース文字として分類することで処理します。これらはユーザによって定義されます。

スペースの検出

関数が、他の文字間のギャップへのスペース文字の挿入をどのように処理するかを指定します。

0 = なし (デフォルト) | 関数は、文字間のギャップの大きさに関係なく、スペース文字を挿入しません。
1 = シングルスペースの挿入 | 関数は、文字間のギャップの大きさに関係なく、文字間のギャップごとにシングルスペース文字を挿入します。
2 = 複数スペースの挿入 | 関数は、文字間のギャップごとに x 個 (0 以上) のスペース文字を挿入します。

スペース得点モード

関数がスペース文字の得点を計算する方法を指定します。

0 = 常に 100 を得点 (デフォルト) | スペース文字の得点は常に 100 になります。
1 = クラッタを基に得点 | スペース文字の得点は、背景となっているピクセルの割合に基づきます。完全に背景ピクセルを構成するスペース文字の得点は 100 になります。

スペース最小幅

スペース文字の最小幅をピクセル単位で指定します (0 ～ 1000、デフォルト = 10)。

スペース最大幅

スペース文字の最大幅をピクセル単位で指定します (0 ～ 1000、デフォルト = 100)。

アクセプトしきい値

各文字の許容できる最低一致得点（0～100、デフォルト = 80）を指定します。[アクセプトしきい値] を下回る一致得点の文字は拒否されます。

コンフュージョンしきい値

最高得点の文字と 2 番目である得点の文字の一致得点の間に必要な最小差を指定します (0 ～ 40、デフォルト = 0)。

サブサンプリングの使用

画像のサブサンプリングを有効にするかどうかを指定します。有効にすると、文字解像度が低下し関数の読み取り速度が向上します。

0 = OFF (デフォルト) | この関数がサブサンプリングを実行しないように指定します。
1 = ON | この関数がサブサンプリングを実行するように指定します。

タイムアウト

この関数による文字のサーチ時間をミリ秒単位で指定します (0 ～ 30000、デフォルト = 5000)。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

出力画像グラフィックス

表示する出力画像の種類を指定します。

0 = 入力画像 (デフォルト) | 入力画像が表示されます。
1 = 正規化された画像 | 正規化された画像が表示されます。
2 = 2 値化された画像 | 2 値化された画像が表示されます。

文字ラベル位置

文字領域に対する各文字のラベルを表示する相対位置を指定します。

0 = 文字の上 (デフォルト) | 各文字ラベルは文字領域の上に表示されます。
1 = 文字の右 | 各文字ラベルは文字領域の右側に表示されます。
2 = 文字の下 | 各文字ラベルは文字領域の下に表示されます。
3 = 文字の左 | 各文字ラベルは文字領域の左側に表示されます。

診断の表示

画像に表示するグラフィックス診断データのタイプを指定します。

0 = 非表示 (デフォルト) | OCRMax 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックス診断データが表示されません。
1 = 不合格文字のみ表示 | 不合格になった文字の周囲領域が赤色で描画され、テキストのメインラインは青色の矩形で囲まれます。 Closed 例
2 = 保存されたフラグメントのみ表示 | 保存されたフラグメントの周囲領域がシアンで描画され、テキストのメインラインは青色の矩形で囲まれます。 Closed 例
3 = 不合格フラグメントのみ表示 | 不合格になったフラグメントの周囲領域が黄色で描画され、テキストのメインラインは青色の矩形で囲まれます。 Closed 例
4 = すべて表示 | 保存された文字 (緑)、不合格文字 (赤)、保存されたフラグメント (シアン)、不合格フラグメント (黄)、テキストのメインライン (青)、およびテキストの拡張メインライン (マゼンタ) の周囲領域が描画されます。

カーブ領域位置

カーブ領域を使用する場合、歪みのない領域の画像上の位置を X 座標と Y 座標で指定します。

注: このパラメータは [領域] パラメータのカーブ値が 0 より大きい場合のみ有効です。

X | 領域を配置する位置の X 座標を指定します。
Y | 領域を配置する位置の Y 座標を指定します。

リセット

[セグメント] タブのパラメータがデフォルト設定にリセットされ、フォント情報がクリアされ、この関数に関連するオートチューンレコード (.rec) ファイルが削除されるように指定します。

注: [外部設定] パラメータが GetInternalSettings 関数または OCRMaxSettings 関数への参照として設定されている場合、このボタンは無効になります。

表示

画像上の OCRMax グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | OCRMax 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 文字セグメントおよび対応するラベルが常に表示されます。
2 = 入力のグラフィックスのみ | 入力領域が常に表示されます。
3 = すべて表示: 入力と結果のグラフィックス | 画像領域、出力画像グラフィックス、文字セグメント、および対応するラベルが常に表示されます。

[セグメント] タブ

[セグメント] タブを使用して、ROI 内の文字をセグメンテーションする設定を調整および変更できます。通常は、デフォルト値とデフォルト設定で大半の文字は読み取れます。ただし、比較的困難な場合には、一部のパラメータ値を調整する必要が生じることがあります。このような場合は、最小文字幅、最大幅や最小ピッチ (文字間の距離。例えば、1 つの文字の左端からその次の文字の左端まで) を指定すると、通常は問題が解決します。

注:
  • このタブのパラメータは、外部セルから参照することはできません。セル参照が必要な場合は、[外部設定] パラメータが OCRMaxSettings 関数を参照するように設定します。
  • [外部設定] パラメータが OCRMaxSettings 関数を参照するように設定されている場合、[セグメント] タブ内のコントロールは無効になります。
  • [セグメント] タブ内では、ROI を調整でき ([グラフィックスの編集] ボタンが有効)、ROI が変更されるとセグメンテーショングラフィックス (文字矩形) が更新されます。
  • ROI と文字領域を表示した場合に、文字領域の線がスプレッドシートオーバレイによって部分的に非表示になることがあります。[セグメント] パラメータの調整時に、半透明のスプレッドシートオーバレイを非表示にすると、文字領域の部分的な遮蔽を防ぐことができます。

セグメンテーションのガイドライン

  • 背景に強度なテクスチャまたは大量のノイズ、あるいはその両方が含まれ、その背景に文字が混在している画像は、セグメンテーションが困難です。
  • ROI には、読み取る文字のみを含め、他の文字やラベルエッジなどの無関係な強い特徴は含めないようにします。
  • 2 つの文字が接触している場合は、通常、パラメータを調整する必要があります。固定幅の接触文字は文字幅を指定することで補正できますが、接触文字のプロポーショナルフォントが問題となり、関数が正しく処理できる場合とできない場合があります。
  • 短いテキスト行 (例えば、3 文字以下) または線ジッタの多い比較的短い行の場合、予測される [角度範囲] を指定すると、関数が固有の不確定度を適切に補正し、短いテキスト行の向きを決定できます。
  • 1 行の中のすべての文字が同一の向きと傾きを持っている必要があります。
  • 十分に分離されたドットマトリックスプリント (ドットが接触していない) の場合、文字を適切にセグメンテーションするには、[最小文字フラグメントサイズ] などのパラメータを調整する必要が生じることがあります。
  • 文字ストローク幅は 2 ピクセル以上にする必要があります。
  • 大きな文字 (通常、英数字) の最小文字サイズは 8 × 8 ピクセルです。小さい文字 (ピリオドなど) の最小文字サイズは 2 × 2 ピクセルです。

ヒント: [出力画像グラフィックス] パラメータを使用すると、[セグメント] パラメータを調整しながら、正規化またはバイナリ化された文字画像を表示できます (画像が鮮明に表示されるように OCRMax プロパティシートを位置づけます)。正規化された画像および 2 値化された画像は、問題を把握し修正するための有用な診断ツールとなります。

セルにエクスポート

現在の [セグメント] タブのパラメータがスプレッドシート内のセルに OCRMaxSettings 関数としてエクスポートされるように指定します。使用する場合、[セグメント] パラメータは読み取り専用となり、[外部設定] パラメータは新しく作成した OCRMaxSettings 関数への参照として設定されます。[セグメント] パラメータを再び有効にするには、[外部設定] パラメータを 0 に設定して OCRMaxSettings 関数への参照を取り消します。

リセット

[セグメント] タブのパラメータがデフォルト設定にリセットされ、フォント情報がクリアされ、この関数に関連するオートチューンレコード (.rec) ファイルが削除されるように指定します。

注: [外部設定] パラメータが GetInternalSettings 関数または OCRMaxSettings 関数への参照として設定されている場合、このボタンは無効になります。

セグメントパラメータ

セグメント分割の実行に使用されるパラメータ設定を指定します。

文字の極性

入力画像内の文字の極性を指定します。

注: 関数のパフォーマンスを改善するには、テキストの極性を指定します。

1 = 黒 (白い背景) | テキストの極性は、白い背景に黒い文字です。
2 = 白 (黒い背景) | テキストの極性は、黒い背景に白い文字です。
4 = 自動 (デフォルト) | この関数は、テキストと背景の極性を自動的に決定します。

文字幅のタイプ

フォントの文字幅の変動方法を指定します。これにより、文字フラグメントをマージするか、分割するかが決定されます。

注:文字幅は文字領域 (例: インクの境界ボックス) の幅です。ROI ではありません (ROI には通常、文字矩形のまわりのパディングも含まれます)。

1 = 自動 (デフォルト) | 文字の幅は不明です。このフォントの幅は固定、またはプロポーショナルである可能性があります。指定した最大文字幅よりも広い文字フラグメントは、関数によって決定された文字フラグメントの分割に最適な位置に基づき、個々の文字に分割されます。各文字の幅が同じになるとは限りません。
2 = 固定 | フォントの文字領域はすべて同じ幅をしています。指定した最大文字幅よりも広い文字フラグメントは、個々の文字に分割されます。各文字の幅は同じになります。
4 = 可変 | フォントの文字の文字領域の幅は一定ではない可能性があります。指定した最大文字幅よりも広い文字フラグメントは、関数によって決定された文字フラグメントの分割に最適な位置に基づき、個々の文字に分割されます。各文字の幅が同じになるとは限りません。

文字幅の最小値

文字領域の最小の幅をピクセル単位で指定します (1 ～ 1000、デフォルト = 3)。この値以上の幅を持つ文字がレポートの対象となります。この設定によって、背景ノイズまたはそのほかのテキスト以外の特徴をフィルタ処理することができます。

注: 読み取るフォントに小さなテキストの特徴 (つまり、ピリオド、コロン、ハイフンなど) が含まれる場合、最小値を高くしすぎると本物の文字まで破棄されてしまう可能性があり、背景ノイズを判別する機能が制限されることがあります。

文字幅の最大値を使用

文字幅の最大値を制限するかどうかを指定します。この設定は、文字フラグメントを分割するか、マージするかを決定する場合に有効です。文字フラグメントを分割する必要がある場合は、[文字幅のタイプ] パラメータで使用する適切な方法を決定します。

0 = OFF (デフォルト) | この関数は、文字の文字領域の幅について、許容される最大値を考慮しません。
1 = ON | この関数は、文字領域の幅について、許容される最大値を考慮します。有効な場合、指定された値よりも広い幅を持つ文字は、幅が広すぎないように、いくつかに分割されます。

文字幅の最大値

文字の文字領域について、許容される最大の幅をピクセル単位で指定します (1 ～ 5000、デフォルト = 100)。

注:この設定は、[文字幅の最大値を使用] パラメータが有効化されている場合のみ使用可能です。

文字の高さの最小値

文字領域の最小の高さをピクセル単位で指定します (1 ～ 1000、デフォルト = 3)。この値以上の高さを持つ文字がレポートの対象となります。この設定によって、背景ノイズまたはそのほかのテキスト以外の特徴をフィルタ処理することができます。

注: 読み取るフォントに小さなテキストの特徴 (つまり、ピリオド、コロン、ハイフンなど) が含まれる場合、最小値を高くしすぎると本物の文字まで破棄されてしまう可能性があり、背景ノイズを判別する機能が制限されることがあります。

文字の高さの最大値を使用

この関数で、文字の高さの最大値を有効にするかどうかを指定します。この値の使い方には 2 通りあります。この値は、まず、垂直方向に隣り合うノイズや文字が縦に並んだ行を拒否するなどのために行全体を検出するときに使用します。また、この値を上回る高さを持つ文字は、この高さに合わせてトリミングされます。

0 = OFF (デフォルト) | 文字の高さの最大値を考慮しません。
1 = ON | 文字の高さの最大値を考慮します。

文字の高さの最大値

文字の文字領域について、許容される最大の高さをピクセル単位で指定します (1 ～ 5000、デフォルト = 100)。

注:この設定は、[文字の高さの最大値を使用] パラメータが有効化されている場合のみ使用可能です。

最小文字アスペクト比を使用

文字のアスペクト比の最小許容可能値を考慮に入れるかどうかを指定します。アスペクト比は、文字列全体の高さ/文字列を囲む矩形の幅です。

0 = OFF | 文字のアスペクト比の最小許容可能値を考慮に入れません。
1 = ON (デフォルト) | 文字のアスペクト比の最小許容可能値を考慮に入れます。アスペクト比がこの値よりも小さい (幅が広すぎる) 文字は、複数のセグメントに分割されます。

最小文字アスペクト比

1 文字につき許容できる最小アスペクト比 (0 ～ 500、デフォルト = 80) を指定します。この設定値は、文字の行の高さ全体を使用した最大文字幅を間接的に設定する際に使用することができます。この最大幅は、行の高さを [最小文字アスペクト比] の値で割った値と同じになります。このパラメータで許可される幅よりも広い文字フラグメントはマージされず、分割されて、複数のフラグメントを形成します。この文字フラグメントは、幅が広すぎないように [文字幅のタイプ] パラメータによって制御されます。

注:この設定は、[Use Minimum Character Aspect Ratio] パラメータが有効化されている場合のみ使用可能です。

角度範囲

角度のサーチ範囲 (0 ～ 45、デフォルト = 0) を度単位で指定します。

注: テキスト行に角度の回転または傾きがある場合、その角度または傾きが各画像で一定の場合は、[領域] を設定してこれらのばらつきを補正します。0 を超える任意の値を指定すると、セグメントプロセスの処理時間が長くなります。

スキュー範囲

スキューのサーチ範囲 (0 ～ 45、デフォルト = 0) を度単位で指定します。

注: テキスト行に角度の回転または傾きがある場合、その角度または傾きが各画像で一定の場合は、[領域] を設定してこれらのばらつきを補正します。0 を超える任意の値を指定すると、セグメントプロセスの処理時間が長くなります。

文字フラグメントマージモード

分割された文字フラグメントを結合して文字を形成するときのマージ (結合) 方法を指定します。2 つの文字フラグメントを 1 文字の一部としてみなすためにオーバーラップする必要があるかどうか、または、間に水平ギャップのある文字フラグメントを 1 文字の一部としてみなすかどうかを決定します。

1 = 要オーバラップ (デフォルト) | 文字フラグメントは、[文字フラグメントの最小オーバーラップ値] パラメータの値を基準にして水平にオーバーラップする必要があります。
2 = 最小文字間ギャップ値に設定 | 文字の断片と断片の間に水平方向のギャップがある場合、これらの断片がマージされ、文字が形成されることがあります。[最小文字間ギャップ値] パラメータで定義された値未満のギャップを持つ 2 つの断片はマージされます。
4 = 最小文字間ギャップ値/最大文字間ギャップ値に設定 | 文字の断片と断片の間に水平方向のギャップがある場合、これらの断片がマージされ、文字が形成されることがあります。2 つの断片をマージするかどうかは、[最小文字間ギャップ値] パラメータと [最大文字内ギャップ値] パラメータで定義された値に基づいて判断されます。

文字フラグメントの最小オーバーラップ値

2 つの文字断片が同じ文字の一部とみなされるためには、この文字断片が相互に水平方向にオーバーラップしていなければなりませんが、その最小の割合を指定します (0 ～ 100、デフォルト = 0)。デフォルト値 (0) は 1 ピクセル以上オーバーラップする任意の 2 文字の断片をマージします。これよりも大きい値の場合、文字断片はより多くオーバーラップする必要があります。一部の文字のペアを水平方向に意図的にオーバーラップさせるアプリケーションや (カーニングとも呼ばれます)、最適化段階において回転や傾きを完全に修正できなかった場合は (通常、印刷が一定ではないため)、デフォルト値が必要になります。

最大文字内ギャップ値

損傷している文字であっても、1 つの文字の中で起こり得る水平方向のギャップの最大サイズをピクセル単位で指定します (0 ～ 1000、デフォルト = 5)。

注: 隣り合う文字間に発生するギャップが損傷した文字内に発生する可能性のあるギャップよりも常に広い、最も一般的なアプリケーションの場合は、[最小文字間ギャップ値] パラメータを [最大文字内ギャップ値] パラメータの値に 1 を足して設定します。例えば、文字の内部に水平ギャップが発生することのない場合は、[最大文字内ギャップ値] パラメータに 0 を設定し、[最小文字間ギャップ値] パラメータに 1 を設定します。

最小文字間ギャップ値

異なる文字に属するために、2 つの文字断片の間に必要な水平方向のギャップの最小サイズをピクセル単位で指定します (0 ～ 1000、デフォルト = 0)。このギャップは、ある文字の文字領域の右端から、その隣の文字の文字領域の左端までの距離です。2 つの断片の間のギャップがこの値よりも小さい場合、これらの断片は同じ文字の一部であるとみなされます。ただし、結合後の文字幅が広くなりすぎる場合は例外です ([文字幅の最大値] または [最小文字アスペクト比] パラメータの指定を参照)。

注: 隣り合う文字間に発生するギャップが損傷した文字内に発生する可能性のあるギャップよりも常に広い、最も一般的なアプリケーションの場合は、[最小文字間ギャップ値] パラメータを [最大文字内ギャップ値] パラメータの値に 1 を足して設定します。例えば、文字の内部に水平ギャップが発生することのない場合は、[最大文字内ギャップ値] パラメータに 0 を設定し、[最小文字間ギャップ値] パラメータに 1 を設定します。

最小文字フラグメントサイズ

前景 (つまり、テキスト) ピクセルの最小値を指定します (0 ～ 1000、デフォルト = 15)。前景のピクセル値がこの値を超えていれば、その文字断片は文字の一部であるとみなされます。この値を設定する際は、本物のテキスト断片を保持できるくらい小さい値に設定する必要がありますが、同時に、背景ノイズから小さな断片を除外できるくらい大きくします。ドットマトリックステキストや、ピリオドなどの小さい文字を含むテキストについては、小さい値が必要になります。文字が複数の小さな断片に分割されにくい文字で形成された、途切れのないストロークテキストの場合は、大きい値が必要になります。

文字サイズの最小値

前景 (つまり、テキスト) ピクセルの最小値を指定します (0 ～ 5000、デフォルト = 30)。前景のピクセル値がこの値以上である 2 値化文字がレポートの対象となり、ピクセル値が少ない文字は破棄されます。この設定によって、背景ノイズまたはそのほかのテキスト以外の特徴をフィルタ処理することができます。

注: 読み取るフォントに小さなテキストの特徴 (つまり、ピリオド、コロン、ハイフンなど) が含まれる場合、最小値を高くしすぎると本物の文字まで破棄されてしまう可能性があり、背景ノイズを判別する機能が制限されることがあります。

高度なセグメンテーションパラメータ

セグメントプロセスに適用される追加パラメータを指定します。

正規化モード

画像の正規化に使用するモードを指定します。このモードは背景のばらつきを除去し、グレースケールの 256 の値 (0 ～ 255) をすべて使用します。

注: この設定は、登録時と実行時の両方で同じでなければなりません。登録後にこの設定を変更すると、分類で問題が発生する原因となる可能性があります。

1 = なし | 正規化は行われません。
2 = グローバル | ローカルなばらつきではなく、ROI 全体の情報を使用して、グローバルな正規化が実行されます。このオプションは背景色とテキストが ROI 全体を通して一定であり、高速モードのときに最適に機能します。
4 = ローカル (デフォルト) | 画像を正規化するために、ROI 内のローカルな文字領域に関する情報を使用して、ローカルな正規化を実行します。このオプションは背景の勾配を除去します。グローバルモードが機能しない場合に使用する必要があります。
8 = ローカル詳細設定 | 画像を正規化するために、ROI 内のローカルな文字領域に関する情報を使用して、背景だけではなく、前景のコントラストの調整を含むローカルな正規化を実行します。このオプションは背景の勾配を除去し、一定でないテキストのコントラストを調整します。3 つのオプションのうち、実行時間が最も長くかかります。

ストローク幅フィルタを使用

残りの画像と同じストローク幅を持たないものをすべて、正規化された画像から削除するかどうかを指定します。このオプションは、近くの文字と接続する可能性のある薄い線などのテキスト以外の特徴について、一部の種類を削除することができます。このオプションによって、2 値化しきい値を超えて偽のフラグメントを作成したり、近くの文字と連結したりする可能性のある、低コントラストの背景のばらつきを除去することもできます。ただし、テキストに一定のストローク幅がない場合や、テキストに大きな可変コントラスト (ストロークの一部が非常に薄いなど) がある場合は、このオプションを使用することによって問題が発生することがあります。

注: この設定は、登録時と実行時の両方で同じでなければなりません。登録後にこの設定を変更すると、分類で問題が発生する原因となる可能性があります。

0 = OFF | 画像にある残りの断片と同じストローク幅を持たないものをすべて、画像から削除しません。
1 = ON (デフォルト) | 画像にある残りの断片と同じストローク幅を持たないものをすべて、画像から削除します。

境界フラグメントを無視

関数が、ROI の境界線に接触する断片をすべて、完全に無視するかどうかを指定します。ラベルのエッジなど、ROI の範囲に含まれる可能性のあるテキスト以外の特徴については、このような断片を無視することが有用です。

注: 断片が、文字領域の境界からテキストのメインラインまで伸びている場合、この断片は 1 つの文字とみなされます。このパラメータが有効化されているとき、除外されるテキストのメインラインまで断片が伸びていてはいけません。

0 = OFF (デフォルト) | 境界線の断片を無視しません。
1 = ON | 境界線の断片を無視します。

2 値化しきい値

正規化された画像において、テキストと背景の間で画像をバイナリ化するしきい値の計算に使用します。単位はパーセンテージ (0 ～ 100、デフォルト = 50) で指定します。例えば、デフォルト設定の 50% は約 128 (0 ～ 255 のグレースケール範囲で) の 2 値化しきい値を生成します。このとき、0 は白いテキスト上の黒と同じで、100 は黒いテキスト上の白と同じです。50% 未満の値を使用すると 2 値化しきい値が変更され、テキストがより少なく、背景がより広くなります。一方、50% より大きい値を使用すると、背景がより少なく、テキストがより多くなります。通常、デフォルト値は画像を正しく 2 値化しますが、背景テクスチャがある場合、またはそのほかの背景のばらつきがある場合は、この値を小さくすることで背景のばらつきを補正することができます。

注: この設定は、登録時と実行時の両方で同じでなければなりません。登録後にこの設定を変更すると、分類で問題が発生する原因となる可能性があります。

文字フラグメントのコントラストしきい値

正規化された画像のしきい値に対するコントラストの最小値を、断片全体のグレースケールレベルで指定します (0 ～ 255、デフォルト = 30)。断片のコントラストがこの値を超えていれば、その断片は文字の一部であるとみなされます。断片の各前景ピクセルは常にしきい値を満たすことを保証されますが、断片のすべてのピクセルがしきい値に非常に近いと、断片はテキストではなく、単にノイズとなる可能性が高くなります。値 0 では低コントラストの断片が拒否されるのを妨ぐことができます。

メインラインまでの最大フラグメント距離

テキストを貫通して、水平方向に伸びる「メインライン」から断片を垂直方向に削除する基準となる距離を文字の高さのパーセンテージとして指定します (0 ～ 1000、デフォルト = 0)。本来、文字は最適化された後に (角度方向および傾きを補正する段階)、水平の直線に沿って配置されることが予測されています。しかし、文字に「ジッタ」が見られることがあり、文字位置の縦方向に変動がある可能性があります。デフォルト設定では、これらの文字フラグメントは文字の「メインライン」に沿っていないため、拒否されてしまいます。このパラメータ設定を大きくすることによって、文字の「メインライン」に沿っていないフラグメントを保持することができます。

セグメント解析モード

文字の最適なセグメントを実行する文字解析モードのタイプを指定します。このパラメータは、グループステージ以外の追加の解析を実行するかどうかを決定します。

1 = 最小 | 基本のセグメント解析を実行します。グループステージ解析のみ実行します。
2 = 標準 (デフォルト) | 最適なセグメントを決定するために、文字の間隔を含め、行全体の追加の解析を実行します。有効になっている場合、[最小ピッチ値]、[文字のピッチタイプ]、[文字ピッチ位置] パラメータの影響を受けます。

最小ピッチ値

2 つの文字の間に発生する可能性のあるピッチの最小値をピクセル単位で指定します (0 ～ 1000、デフォルト = 0)。ピッチは [文字ピッチ位置] パラメータに基づいて計算されます。2 つの断片の間のピッチがこれよりも小さい場合、これらの断片は同じ文字の一部であるとみなされます。ただし、結合後の文字幅が広くなりすぎる場合は例外です（[文字幅の最大値] または [最小文字アスペクト比] パラメータの指定を参照）。

注:[セグメント解析モード] パラメータが [最小] に設定されている場合、このパラメータは無効になります。

文字ピッチ位置

2 つの連続する文字間のピッチの測定方法を指定します。ピッチは、隣り合う文字の対応する点と点の間の (おおよその) 距離として定義されます。ある文字の末尾から隣の文字の始めまでの距離 (文字間ギャップ) ではありません。文字に異なる幅がある固定ピッチフォントでは、通常、適切なピッチメトリクスが使用されている場合のみ、ピッチは一定の値を持ちます。

注:[セグメント解析モード] パラメータが [最小] に設定されている場合、このパラメータは無効になります。

1 = 自動 (デフォルト) | 未知のメトリクスが使用されていることを示します。適切なピッチはその他のピッチ位置のいずれかである可能性もありますし、一定のピッチ位置がない可能性もあります (プロポーショナルピッチフォントの場合)。また、OCRMax 関数によって適切なピッチメトリクスが決定されます。
2 = 左－左 | ある文字の文字領域の左端から隣の文字の文字領域の左端までの距離を測定したピッチを指定します。 注: 「左」および「右」という用語は、ROI により定義された座標を基準にしています。つまり、「右」は正の X 方向です。
4 = 中央－中央 | ある文字の文字領域の中央から隣の文字の文字領域の中央までの距離を測定したピッチを指定します。
8 = 右－右 | ある文字の文字領域の右端から隣の文字の文字領域の右端までの距離を測定したピッチを指定します。 注: 「左」および「右」という用語は、ROI により定義された座標を基準にしています。つまり、「右」は正の X 方向です。

文字のピッチタイプ

連続する文字の文字間隔に 1 つの固定値を確保するか、特定の文字によって異なるのかを指定します。ピッチは、隣り合う文字の対応する点と点の間の (おおよその) 距離として定義されます。ある文字の末尾から隣の文字の始めまでの距離 (文字間ギャップ) ではありません。

注:[セグメント解析モード] パラメータが [最小] に設定されている場合、このパラメータは無効になります。

1 = 自動 (デフォルト)

ピッチタイプは不明だが、固定、またはプロポーショナルのどちらかで、可変ではないことを表します。OCRMax 関数によって最適なタイプが決定されます。

2 = 固定

ピッチが固定、つまり任意の 2 文字のピッチは一定であることを表します。たとえば、文字矩形の幅は関係ありません。このピッチは、[文字ピッチ位置] パラメータを基準に測定されます。

4 = 比例

ピッチがプロポーショナルである、つまり任意の 2 文字のピッチはその文字によって異なることを表します。例えば、2 つの小文字「i」の間の距離は、2 つの大文字「M」の間の距離よりもかなり少なくなります。

注:
  • ピッチの計測値は文字列全体を通して一定ではありませんが、通常、文字間ギャップはほぼ一定です (文字間ギャップとは、ある文字の文字領域の右端から、隣の文字の文字領域の左端までの距離です)。
  • 「左」および「右」という用語は、ROI により定義された座標を基準にしています。つまり、「右」は正の X 方向です。

8 = 可変

文字列全体で、文字から文字までのメトリックが一定ではなく (たとえば、文字の配置がばらばらである)、ピッチは固定でもプロポーショナルでもないことを表します。OCRMax 関数でピッチのタイプを特定することは推奨しません。

注: [変数] ピッチは [自動] とは異なります。[自動] は、ピッチは固定またはプロポーショナルのどちらかではあるが、不明であることを前提にしています。

出力画像グラフィックス

表示する出力画像の種類を指定します。

注: このパラメータは、[全般] タブの [出力画像グラフィックス] パラメータを一時的に上書きします。[セグメント] タブを終了すると、[全般] タブの [出力画像グラフィックス] パラメータの設定が復元されます。

0 = 入力画像 (デフォルト) | 入力画像が表示されます。
1 = 正規化された画像 | 正規化された画像が表示されます。
2 = 2 値化された画像 | 2 値化された画像が表示されます。

診断の表示

画像に表示するグラフィックス診断データのタイプを指定します。

0 = 非表示 (デフォルト) | OCRMax 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックス診断データが表示されません。
1 = 不合格文字のみ表示 | 不合格になった文字の周囲領域が赤色で描画され、テキストのメインラインは青色の矩形で囲まれます。 Closed 例
2 = 保存されたフラグメントのみ表示 | 保存されたフラグメントの周囲領域がシアンで描画され、テキストのメインラインは青色の矩形で囲まれます。 Closed 例
3 = 不合格フラグメントのみ表示 | 不合格になったフラグメントの周囲領域が黄色で描画され、テキストのメインラインは青色の矩形で囲まれます。 Closed 例
4 = すべて表示 | 保存された文字 (緑)、不合格文字 (赤)、保存されたフラグメント (シアン)、不合格フラグメント (黄)、テキストのメインライン (青)、およびテキストの拡張メインライン (マゼンタ) の周囲領域が描画されます。

[フォントの登録] タブ

[フォントの登録] タブを使用して、文字の登録、表示、名前の変更、および削除を実行できます。タブは、登録フォントを管理する [文字] と、文字登録パラメータを定義する [登録] の 2 つのグループに分かれています。

注:
  • このタブのコントロールは、[全般] タブの [登録モード]、[登録文字列]、および [フォントの登録] パラメータにはリンクされていません。
  • [フォントの登録] タブ内では、ROI を調整でき ([グラフィックスの編集] ボタンが有効)、ROI が変更されるとセグメンテーショングラフィックス (文字領域) が更新されます。
  • マルチバイト文字名 (漢字など) はサポートされていません。マルチバイト文字を登録できますが、文字に指定する名前はシングルバイト名にする必要があります。

[文字] グループボックスコントロール

登録後、各登録文字はツリーで表示できます。ツリーでは、文字はフォルダとラベルが割り当てられ、それに応じてグループ化されます (文字が一致するラベルを持つ場合)。

  • ルートのフォントフォルダを選択すると、右側のパネルにフォント内のすべての文字が表示されます。文字は、下にラベルの付いたアイコンとして表示されます。
  • 文字フォルダを選択すると、右側のパネルにその文字の登録インスタンスがすべて表示されます。文字は、下にラベルの付いたアイコンとして表示されます。
  • 文字の登録インスタンスを選択すると、右側のパネルに合わせてズームされた文字が表示されます。

ヒント: OCRMax 関数に各文字の複数の登録インスタンスを実行時に読み取るように指定すると、関数は類似の文字の種類をより正確に判別できます。ただし、同じ文字のインスタンスの複数登録には、利点と欠点があります。複数のインスタンスを登録する利点は、特に、分類を間違えやすいテキスト (8 と B など) を読み取るときに、より高度な分類パフォーマンスを期待できる点です。複数のインスタンスを登録する欠点は、関数の実行時間が減少する、複数の登録インスタンスでは最高得点だけでなく 2 番目に高い得点も改善するため、信頼性得点が減少することがある、間違った文字が登録されることがあるといった点です。

  • インポート: [開く] ダイアログを起動します。このダイアログでは、OCRMax データファイル (*.ocm) として保存されたフォントをインポートできます。
  • エクスポート: [名前を付けて保存] ダイアログを起動します。このダイアログでは、フォントを OCRMax データファイル (*.ocm) として保存できます。
  • 名前変更: 項目を選択した後にクリックして、名前を変更します。ツリーまたは右側のリストパネル内の要素の名前を変更できます。

注: 文字グループの名前を変更すると、グループ内のすべての文字に新しいラベルが割り当てられます。単一文字の名前を変更すると、新しいラベルがその単一の選択された文字に割り当てられます。文字はツリー内の新しいグループまたは異なるグループに移動されます。

  • 削除: 項目を選択した後にクリックして、フォントから削除します。ツリーまたは右側のリストパネル内の要素の名前を変更できます。

注: フォントフォルダを削除すると、フォントがクリアされ、すべての文字が削除されます。文字グループを削除すると、削除したグループのラベルと一致するラベルを持つ文字はすべて削除されます。

[登録] グループボックス

文字を登録するには、事前に文字が正しくセグメンテーションされている必要があります。

  • すべての文字をフォントに追加: ROI 内のすべての文字を登録するように指定します。登録対象の文字を [文字列の登録] テキスト入力ボックスに入力してから、[登録] ボタンをクリックします。[文字列の登録] テキスト入力ボックスの文字数は、セグメンテーションされた文字の数に一致している必要があります。
  • 新規文字をフォントに追加: ROI 内の新しい文字のみを登録するように指定します。登録対象の文字を [文字列の登録] テキスト入力ボックスに入力してから、[登録] ボタンをクリックします。[文字列の登録] テキスト入力ボックスの文字数は、セグメンテーションされた文字の数に一致している必要があります。
  • 個々の文字をフォントに追加: ROI 内の特定の文字を登録するように指定します。このオプションを選択すると、[文字列の登録] テキスト入力ボックスは無効になり、[登録] ボタンをクリックすると [個々の文字をフォントに追加] ダイアログが起動します。このダイアログでは、ROI の展開された画像と、セグメンテーションされた各文字の下にラベルとテキスト入力ボックスが示されます。ラベルは、その文字に現在関連付けられているシンボルです (「?」は、不明または未登録の文字を示します)。ラベルの下にテキスト入力ボックスがあります。セグメンテーションされた各文字のラベルをテキスト入力ボックスに入力します。テキスト入力ボックスを空のままにすると、文字は再登録されません。[登録] ボタンをクリックしてダイアログを閉じます。
  • 文字列の登録: 登録するテキスト文字列を指定します。[文字列の登録] テキスト入力ボックスの文字数は、セグメンテーションされた文字の数に一致している必要があります。
  • [登録] ボタン: 登録をアクティブ化します。

[フィールド化] タブ

[フィールド化] タブでは、OCRMax 関数の [フィールド文字列] 引数と [フィールド定義] 引数をグラフィカルに作成および編集することができます。結果の値は、リテラル文字列として関数に挿入されます。

[フィールド化] は、文字列を確認し修正する機能を提供し、一連の最適一致した有効な文字列を返します。[フィールド化] には 2 通りの基本的な用途があります。

  • OCR の結果の検証。[フィールド文字列] および [フィールド定義] パラメータに基づいて、返された文字列が正しいかどうかを判断します。
  • OCR の結果の修正。返された文字列が許容可能な結果リストにない場合は、返された文字列に最も近い、そのフィールドで許可されている許容文字列の検索を試みます。

フィールド化の標準的な使用例では、文字列にプレフィックス文字またはサフィックス文字、あるいはその両方が含まれている場合に、フィールド形式を使用してプレフィックス/サフィックス文字を無視します。この場合、[フィールド文字列] と [フィールド定義] によって ROI 内の文字列位置のオフセットが決まります。

フィールド文字列

文字列に含まれる文字数を指定します。フィールド文字列エントリには、(A～Z)、(a～z)、(0～9)、ハイフン（-）、ドット（.）、スペース（ ）など、[テキスト入力] ダイアログのすべての文字を使用できます。

フィールド文字列の各文字は、0 ～ 31 のインデックス付きフィールド位置に対応します。フィールド文字列には、読み取りを成功させたい文字列の文字と少なくとも同じ数の位置が含まれている必要があります (つまり、10 文字存在し、フィールド文字列で 9 文字のみ指定した場合は、最適一致が 9 つ返されます。しかし、8 文字存在し、フィールド文字列で 9 文字指定した場合、関数は #ERR を返します)。デフォルトでは、フィールド文字列の各位置は、アスタリスク（*）か英数字の「ワイルドカード」で示されます。これは、文字列のどの位置でもすべての文字が有効であることを意味します。

ただし、フィールド文字列の個別の位置は、その位置に一部の文字しか想定されないように制限することができます。すると、対象外の文字は読み取り時に考慮されないため、全体的な性能と信頼性が向上します。

定義済みのフィールド文字列エントリは、次のとおりです。

フィールド文字列 エントリ | 説明 | 有効な文字
* | ワイルドカード | フォントに含まれる任意の登録文字です。
N | 数字 | 0123456789
A | 大文字の英字 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小文字の英字 | abcdefghijklmnopqrstuvwxyz
H | 16 進値（大文字の英字と数字） | 0123456789ABCDEF
h | 16 進値（小文字の英字と数字） | 0123456789abcdef
O | 8 進値 | 01234567

注:

  • フィールド文字列のある位置を特定の文字に制限する場合は、その文字を入力してください。文字はフォントに登録されている必要があります。また、[フィールド定義] パラメータを使用して再マップしない限り、上記の定義済みフィールド文字列エントリの文字を使用することはできません。
  • スペースを含む文字列を読み取るには、フィールド文字列にスペースを含めます。その位置の対応するフィールド文字列エントリがアスタリスク（*）の場合、ReadText 関数はスペースを読み取りません。
  • [全般] タブの [フィールド文字列] パラメータがセル参照として定義されている場合、[フィールド化] タブの [フィールド文字列] オプションは無効になり、セル参照の現在の値が表示されます。
Closed フィールド文字列の例 1

フィールド文字列が「**********AN」の場合、1～10 番目のフィールド文字列位置ではフォントに含まれるすべての文字が有効です。ただし、11 番目の位置は、読み取り時に大文字の英字だけが想定されます。また、12 番目の位置は、数字だけが想定されます。

Closed フィールド文字列の例 2

フォントには、0～9 の数字と / だけが含まれます。フィールド文字列が「NN/NN/NN」の場合、1、2、4、5、7、および 8 番目の位置では数字だけが想定されています。また、3 および 6 番目の位置ではスラッシュ（/）だけが想定されています。

ただし、フィールド文字列が「NN/NN/AA」の場合は、フォントに英字が含まれていないため、#ERR が返されます。

フィールド定義

必要に応じ、フィールド定義設定を使用してフィールド文字列のユーザ定義エントリを作成できます。このエントリがフィールド文字列に含まれると、このエントリの挿入位置で有効となる文字のリストが限定されます。いくつかの定義済みフィールド定義があり、ユーザ定義のフィールド定義を追加できます。定義済み定義はグレーのテキストで表示され、削除も編集もできず、有効または無効の切り替えのみ可能です。ユーザ定義の定義は黒色のテキストで表示され、追加、削除、または編集できます。フィールド定義を追加するには、[新規追加] ボタンをクリックし、文字のアイコンを割り当ててから、定義を文字に割り当てます。

注:
  • ユーザ定義の定義の数は、OCRMax 関数の数式の長さ (249) に制限されています。
  • OCRMax プロパティシートが閉じられたときに無効となったユーザ定義の定義は削除され、関数のプロパティシートが再度開かれたときには使用できません。
  • [全般] タブの [フィールド定義] パラメータがセル参照として定義されている場合、[フィールド化] タブの [フィールド定義] オプションは無効になり、セル参照の現在の値が表示されます。

フィールド定義エントリのために示す文字は、フォントに含まれている必要があります。次に例を示します。#=123 は、ユーザ登録フォントに 1、2、3 が含まれる場合に有効です。ただし、#=123 は、フォントに 1、2、3 が含まれない場合は無効です。

注意: 定義済みのエントリ (*, A, a, N, H, h, O) をフィールド定義パラメータで使用すると、新しい定義で有効な文字のリストが再割り当てされます。

Closed フィールド定義の例 1

フィールド定義の値が「#=123;$=3456;%=789」で、フィールド文字列が「#$%*******」の場合、1 番目の位置で有効な文字は、1、2、または 3 だけです。2 番目の位置で有効な文字は、3、4、5、または 6 だけです。また、3 番目の位置では、7、8、または 9 だけが有効です。また、4～10 番目の位置ではフォントに含まれるすべての文字が有効です。

Closed フィールド定義の例 2

フィールド定義の値が「#=123;$=3456;%=789, A=A」で、フィールド文字列が「#$%******A,」の場合、1 番目の位置で有効な文字は、1、2、または 3 だけです。2 番目の位置で有効な文字は、3、4、5、または 6 だけです。また、3 番目の位置では、7、8、または 9 だけが有効です。また、4～9 番目の位置ではフォントに含まれるすべての文字が有効です。フィールド定義「A=A」は定義済みのフィールド文字列エントリを再割り当てするため、10 番目の位置では A だけが想定されています。

フィールド定義のコントロール

  • フィールド文字列内の文字のみにマッチを行う: 関数が、フィールド文字列によって示されている文字に対してのみ文字の比較を試みるかどうかを指定します。

注: [検査モード] が [認識と照合] に設定されている場合、このパラメータは [マッチ文字列] パラメータに指定されたテキスト文字列に対して比較されます。

  • 可変長文字列: 定義されたフィールド文字列が読み取りテキスト文字列全体の中の部分文字列であるかどうかを指定します。部分文字列が検出された場合は、最適一致の部分文字列が返されます。

注: [外部設定] パラメータが OCRMaxSettings 関数への参照として設定されている場合、[フィールド文字列内の文字のみにマッチを行う] および [可変長文字列] パラメータは無効になります。

  • 最小長: [可変長文字列] パラメータが有効な場合、このパラメータは許容可能な文字列長の最小値を指定します (0 ～ 100、デフォルト = 1)。
  • 最大長: [可変長文字列] パラメータが有効な場合、このパラメータは許容可能な文字列長の最大値を指定します (0 ～ 100、デフォルト = 25)。
  • 最大開始インデックス値: [可変長文字列] パラメータが有効な場合、このパラメータは考慮対象となる、フィールド形式の部分列を指定します。部分列はこのインデックス値を超えない位置で開始する必要があります (0 ～ 100、デフォルト = 100)。
  • 最小終了インデックス値: [可変長文字列] パラメータが有効な場合、このパラメータは考慮対象となる、フィールド化の部分列を指定します。部分列はこのインデックス値以上の位置で終了する必要があります (0 ～ 100、デフォルト = 0)。

[結果] タブ

[結果] タブは、総合結果と各文字の得点を表示します。[全体結果] と [文字結果] の 2 つのセクションに分かれています。

全体結果

  • ステータス: 関数の総合結果が合格か不合格かを表示します。

文字結果

  • 文字: その位置で読み取った文字を表示します。
  • ステータス: 読み取り文字のステータス ([読み取り (Bad)]、[読み取り (Good)]、[無視]、[コンフュージョン]、[ミスマッチ]、[コンフュージョンミスマッチ]、または [検証失敗]) を表示します。
  • [読み取り (Bad)]:良好な読み取りとみなされる [アクセプトしきい値] を上回る十分に高い得点の文字ではありません。
  • [読み取り (Good)]:関数はこの位置の文字を正常に読み取りました。
  • [無視]:フィールド形式が有効な場合、フィールド形式文字列が指定され、それが関数によって読み取られた文字列より短いと、文字列の先頭または末尾の文字がセグメンテーションされますが (黄色)、総合結果には含まれません。例えば、フィールド形式定義が ABC の場合、関数によって読み取られた文字列が「12ABC34」であると、「1234」は無視されます。
  • [コンフュージョン]:関数は、良好な読み取りとして十分に得点の高い文字を識別しました ([アクセプトしきい値] パラメータ値を上回る)。ただし、得点が非常に近い別の文字があり ([コンフュージョンしきい値] パラメータ値以内)、関数が正しい文字を選択したかどうかは確実ではありません (コンフュージョン = (1 番目の得点 - 2 番目の得点)/信頼性しきい値)。
  • [ミスマッチ]:関数は、フィールド化に一致しないどの文字よりも非常に得点の高い、フィールド形式に一致しない文字を検出しました。フィールド形式に一致しない文字は、この位置に印刷されることが多くあります。このステータスを返すには、フィールド形式が有効になっている必要があります。

注: ミスマッチステータスは、OCRMaxSettings 関数が使用されており、その関数の [フィールド化していない文字を無視] が無効になっている場合のみ返されます。

  • コンフュージョンミスマッチ:コンフュージョンとミスマッチの両方の条件を満たす文字を検出しました。
  • [検証失敗]: OCRMaxSettings 関数が使用されており、その関数の [追加の文字検証をスキップ] パラメータが無効の場合、関数は追加の検証手順を通じて文字を解析し、関数が誤った読み込みを生成しないように保証します。
  • 得点: 読み取った文字がフォントデータベース内の登録文字にどのぐらい近いかを測定した得点を表示します。
  • コンフュージョン:次の最適一致の文字を表示します。
  • コンフュージョン得点:次の最適一致と比較した場合に、選択した一致がどのぐらい確実かを示す測定値を表示します。

[診断] タブ

[診断] タブには、OCRMax 関数による ROI 内の文字のセグメンテーション方法に関する情報が表示されます。このデータは、調整するパラメータ、調整する量、文字や文字フラグメントが正しくセグメント化されていないかどうかを判断する際に有用です。このタブは、診断データのグラフィックス表示を指定する [診断の表示] パラメータとともに使用します。

注: このタブは、パラメータを変更した場合や、新しい画像を取り込み/ロードすると自動的に更新されます。

メインラインのデータ

  • [メインライン角度]:ROI に対する文字領域の、角度方向の計測値を角度で表示します。
  • [文字スキュー]:ROI に対する文字領域の、角度スキューの計測値を角度で表示します。
  • [文字ピッチ]:文字の最小および最大ピッチ測定値をピクセル単位で表示します。
  • [文字間ギャップ]:文字間ギャップの最小および最大測定値をピクセル単位で表示します。
  • [文字内ギャップ]:文字内ギャップの最小および最大測定値をピクセル単位で表示します。

合格した文字

  • [幅]:合格した文字の幅の最小および最大測定値をピクセル単位で表示します。
  • [高さ]:合格した文字の高さの最小および最大測定値をピクセル単位で表示します。
  • [サイズ]:合格した文字サイズの最小および最大測定値をピクセル単位で表示します。

除外した文字

  • [幅]:除外された文字の最小および最大測定幅をピクセル単位で表示します。
  • [高さ]:除外された文字の高さの最小および最大測定値をピクセル単位で表示します。
  • [サイズ]:除外された文字サイズの最小および最大測定値をピクセル単位で表示します。

注: 除外された文字がない場合、#ERR が表示されます。

合格したフラグメント

  • [サイズ]:合格したフラグメントのサイズの最小および最大測定値をピクセル単位で表示します。
  • [コントラスト]:合格したフラグメントのコントラストの最小および最大測定値を割合 (%) で表示します。
  • [メインラインまでの距離 (%)]:合格したすべてのフラグメントの最大 Y 距離を、メインラインの高さの割合 (%) で表示します。

除外したフラグメント

  • [サイズ]:除外されたフラグメントのサイズの最小および最大測定値をピクセル単位で表示します。
  • [コントラスト]:除外されたフラグメントのコントラストの最小および最大測定値を割合 (%) で表示します。
  • [メインラインまでの距離 (%)]:除外されたすべてのフラグメントの最大 Y 距離を、メインラインの高さの割合 (%) で表示します。

OCRMax 関数の出力

戻り値 | 読み取られた文字列を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | OCRMax 関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

OCRMax 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

文字列 | GetString(OCR 最大) | 参照されているデータ構造体のテキスト文字列を返します。
文字列合格 | GetPassed(OCRMax) | 参照されているデータ構造体の文字列全体の合格/不合格ステータスを返します。
インデックス |  |
文字 | GetChar(OCRMax, インデックス) | 参照されているデータ構造体のインデックス付き文字を返します。
得点 | GetScore(OCRMax, インデックス) | 参照されているデータ構造体のインデックス付き文字の一致得点 (0 ～ 100) を返します。
合格 | GetPassed(OCRMax, インデックス) | 参照されているデータ構造体のインデックス付き文字の合格/不合格ステータスを返します。
2 番目文字 | GetChar(OCRMax, インデックス 0, [インデックス 1]) | 2 番目に高い得点の文字を返します。
2 番目得点 | GetScore(OCRMax, インデックス 0, [インデックス 1]) | 2 番目に高い得点の文字の得点を返します。
文字差 |  | インデックス付き文字の得点と 2 番目の得点値の差を返します。

関連項目

  • OCRMax 関数について
  • OCRMax 関数の設定方法
  • [オートチューン] ダイアログ
  • OCRMaxSettings 関数
  • OCRMaxAutoTune 関数
  • OCRMax データアクセス関数
  • TransOCRMaxToWorld 関数
  • プロパティシートの使用方法


OCRMaxAutoTune 関数

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

参照されている OCRMax 関数の [オートチューン] ダイアログ への外部アクセスを提供します。この関数を使用すると、[オートチューン] ダイアログを使用して、VisionView オペレータインタフェースパネルなどのリモートデバイスから調整できるようになります。ボタンコントロールを押すと、参照されている OCRMax 関数の [オートチューン] ダイアログが起動します。

注: [オートチューン] ダイアログは In-Sight ビジョンシステムがオンラインの場合は使用できません。

  • OCRMaxAutoTune の入力パラメータ
  • OCRMaxAutoTune の出力
  • 関連項目

OCRMaxAutoTune 関数の入力パラメータ

OCRMaxAutoTune 関数(

ラベル,

OCR最大

)

ラベル | スプレッドシートに表示される名前を指定します。
OCR最大 | OCRMax 関数の [image] データ構造体への参照を指定します。

OCRMaxAutoTune 関数の出力

戻り値 | [オートチューン] ダイアログが表示されている場合は値 1 を返し、そうでない場合は 0 を返します。
戻り値 | ラベル付きボタン [image] コントロール。

関連項目

  • [オートチューン] ダイアログ
  • OCRMax 関数
  • OCRMaxSettings 関数
  • OCRMax データアクセス関数
  • OCRMax 関数の設定方法
  • プロパティシートの使用方法


OCRMaxSettings 関数

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

OCRMax 関数のセグメント化、分類の詳細設定、フィールド化といった外部設定値。実行時に調整できます。この関数は設定値をプログラムで制御し、リモートデバイスからのパラメータの調整をサポートします。

  • OCRMaxSettings の入力パラメータ
  • OCRMaxSettings 関数の出力
  • 関連項目

OCRMaxSettings 関数の入力パラメータ

OCRMaxSettings 関数(

セグメント化.文字の極性,

セグメント化.文字幅のタイプ,

セグメント化.文字幅の最小値,

セグメント化.文字幅の最大値を使用,

セグメント化.文字幅の最大値,

セグメント化.文字の高さの最小値,

セグメント化.文字の高さの最大値を使用,

セグメント化.文字の高さの最大値,

セグメント化.最小文字アスペクト比を使用,

セグメント化.最小文字アスペクト比,

セグメント化.角度範囲,

セグメント化.スキュー範囲,

セグメント化.文字フラグメントマージモード,

セグメント化.文字フラグメントの最小オーバーラップ値,

セグメント化.最小文字内ギャップ値,

セグメント化.最小文字間ギャップ値,

セグメント化.最小文字フラグメントサイズ,

セグメント化.文字サイズの最小化,

セグメント詳細設定.正規化モード,

セグメント詳細設定.ストローク幅フィルタを使用,

セグメント詳細設定.境界フラグメントを無視,

セグメント詳細設定.2 値化しきい値,

セグメント詳細設定.文字フラグメントのコントラストしきい値,

セグメント詳細設定.メインラインまでの最大フラグメント距離,

セグメント詳細設定.セグメント解析モード,

セグメント詳細設定.最小ピッチ,

セグメント詳細設定.文字ピッチ位置,

セグメント詳細設定.文字のピッチタイプ,

分類の詳細設定.分類テンプレートサイズ幅,

分類の詳細設定.分類テンプレートサイズの高さ,

分類の詳細設定.文字のアスペクト比を保持,

分類の詳細設定.追加の文字検証をスキップ,

分類の詳細設定.画像前処理,

フィールド化.フィールド化していない文字を無視,

フィールド化.文字列長,

フィールド化.最大文字列長,

フィールド化.最小文字列長,

フィールド化.最初にフィールド化した最大インデックス値,

フィールド化.最後にフィールド化した最小インデックス値

)

セグメント化

セグメント分割の実行に使用されるパラメータ設定を指定します。

文字の極性

入力画像内の文字の極性を指定します。

注: 関数のパフォーマンスを改善するには、テキストの極性を指定します。

1 = 黒 (白い背景) | テキストの極性は、白い背景に黒い文字です。
2 = 白 (黒い背景) | テキストの極性は、黒い背景に白い文字です。
4 = 自動 (デフォルト) | この関数は、テキストと背景の極性を自動的に決定します。

文字幅のタイプ

フォントの文字幅の変動方法を指定します。これにより、文字フラグメントをマージするか、分割するかが決定されます。

注:文字幅は文字領域 (例: インクの境界ボックス) の幅です。ROI ではありません (ROI には通常、文字矩形のまわりのパディングも含まれます)。

1 = 自動 (デフォルト) | 文字の幅は不明です。このフォントの幅は固定、またはプロポーショナルである可能性があります。指定した最大文字幅よりも広い文字フラグメントは、関数によって決定された文字フラグメントの分割に最適な位置に基づき、個々の文字に分割されます。各文字の幅が同じになるとは限りません。
2 = 固定 | フォントの文字領域はすべて同じ幅をしています。指定した最大文字幅よりも広い文字フラグメントは、個々の文字に分割されます。各文字の幅は同じになります。
4 = 可変 | フォントの文字の文字領域の幅は一定ではない可能性があります。指定した最大文字幅よりも広い文字フラグメントは、関数によって決定された文字フラグメントの分割に最適な位置に基づき、個々の文字に分割されます。各文字の幅が同じになるとは限りません。

文字幅の最小値

文字領域の最小の幅をピクセル単位で指定します (1 ～ 1000、デフォルト = 3)。この値以上の幅を持つ文字がレポートの対象となります。この設定によって、背景ノイズまたはそのほかのテキスト以外の特徴をフィルタ処理することができます。

文字幅の最大値を使用

文字幅の最大値を制限するかどうかを指定します。この設定は、文字フラグメントを分割するか、マージするかを決定する場合に有効です。文字フラグメントを分割する必要がある場合は、[文字幅のタイプ] パラメータで使用する適切な方法を決定します。

0 = OFF (デフォルト) | この関数は、文字の文字領域の幅について、許容される最大値を考慮しません。
1 = ON | この関数は、文字領域の幅について、許容される最大値を考慮します。有効な場合、指定された値よりも広い幅を持つ文字は、幅が広すぎないように、いくつかに分割されます。

文字幅の最大値

文字の文字領域について、許容される最大の幅をピクセル単位で指定します (1 ～ 5000、デフォルト = 100)。

注:この設定は、[文字幅の最大値を使用] パラメータが有効化されている場合のみ使用可能です。

文字の高さの最小値

文字領域の最小の高さをピクセル単位で指定します (1 ～ 1000、デフォルト = 3)。この値以上の高さを持つ文字がレポートの対象となります。この設定によって、背景ノイズまたはそのほかのテキスト以外の特徴をフィルタ処理することができます。

文字の高さの最大値を使用

この関数で、文字の高さの最大値を有効にするかどうかを指定します。この値の使い方には 2 通りあります。この値は、まず、垂直方向に隣り合うノイズや文字が縦に並んだ行を拒否するなどのために行全体を検出するときに使用します。また、この値を上回る高さを持つ文字は、この高さに合わせてトリミングされます。

0 = OFF (デフォルト) | 文字の高さの最大値を考慮しません。
1 = ON | 文字の高さの最大値を考慮します。

文字の高さの最大値

文字の文字領域について、許容される最大の高さをピクセル単位で指定します (1 ～ 5000、デフォルト = 100)。

注:この設定は、[文字の高さの最大値を使用] パラメータが有効化されている場合のみ使用可能です。

最小文字アスペクト比を使用

文字のアスペクト比の最小許容可能値を考慮に入れるかどうかを指定します。アスペクト比は、文字列全体の高さ/文字列を囲む矩形の幅です。

0 = OFF | 文字のアスペクト比の最小許容可能値を考慮に入れません。
1 = ON (デフォルト) | 文字のアスペクト比の最小許容可能値を考慮に入れます。アスペクト比がこの値よりも小さい (幅が広すぎる) 文字は、複数のセグメントに分割されます。

最小文字アスペクト比

1 文字につき許容できる最小アスペクト比 (0 ～ 500、デフォルト = 80) を指定します。この設定値は、文字の行の高さ全体を使用した最大文字幅を間接的に設定する際に使用することができます。この最大幅は、行の高さを [最小文字アスペクト比] の値で割った値と同じになります。このパラメータで許可される幅よりも広い文字フラグメントはマージされず、分割されて、複数のフラグメントを形成します。この文字フラグメントは、幅が広すぎないように [文字幅のタイプ] パラメータによって制御されます。

注:この設定は、[Use Minimum Character Aspect Ratio] パラメータが有効化されている場合のみ使用可能です。

角度範囲

角度のサーチ範囲 (0 ～ 45、デフォルト = 0) を度単位で指定します。

注: テキスト行に角度の回転または傾きがある場合、その角度または傾きが各画像で一定の場合は、[領域] を設定してこれらのばらつきを補正します。0 を超える任意の値を指定すると、セグメントプロセスの処理時間が長くなります。

スキュー範囲

スキューのサーチ範囲 (0 ～ 45、デフォルト = 0) を度単位で指定します。

注: テキスト行に角度の回転または傾きがある場合、その角度または傾きが各画像で一定の場合は、[領域] を設定してこれらのばらつきを補正します。0 を超える任意の値を指定すると、セグメントプロセスの処理時間が長くなります。

文字フラグメントマージモード

分割された文字フラグメントを結合して文字を形成するときのマージ (結合) 方法を指定します。2 つの文字フラグメントを 1 文字の一部としてみなすためにオーバーラップする必要があるかどうか、または、間に水平ギャップのある文字フラグメントを 1 文字の一部としてみなすかどうかを決定します。

1 = 要オーバラップ (デフォルト) | 文字フラグメントは、[文字フラグメントの最小オーバーラップ値] パラメータの値を基準にして水平にオーバーラップする必要があります。
2 = 最小文字間ギャップ値に設定 | 文字の断片と断片の間に水平方向のギャップがある場合、これらの断片がマージされ、文字が形成されることがあります。[最小文字間ギャップ値] パラメータで定義された値未満のギャップを持つ 2 つの断片はマージされます。
4 = 最小文字間ギャップ値/最大文字間ギャップ値に設定 | 文字の断片と断片の間に水平方向のギャップがある場合、これらの断片がマージされ、文字が形成されることがあります。2 つの断片をマージするかどうかは、[最小文字間ギャップ値] パラメータと [最大文字内ギャップ値] パラメータで定義された値に基づいて判断されます。

文字フラグメントの最小オーバーラップ値

2 つの文字断片が同じ文字の一部とみなされるためには、この文字断片が相互に水平方向にオーバーラップしていなければなりませんが、その最小の割合を指定します (0 ～ 100、デフォルト = 0)。デフォルト値 (0) は 1 ピクセル以上オーバーラップする任意の 2 文字の断片をマージします。これよりも大きい値の場合、文字断片はより多くオーバーラップする必要があります。一部の文字のペアを水平方向に意図的にオーバーラップさせるアプリケーションや (カーニングとも呼ばれます)、最適化段階において回転や傾きを完全に修正できなかった場合は (通常、印刷が一定ではないため)、デフォルト値が必要になります。

最大文字内ギャップ値

損傷している文字であっても、1 つの文字の中で起こり得る水平方向のギャップの最大サイズをピクセル単位で指定します (0 ～ 1000、デフォルト = 5)。

注: 隣り合う文字間に発生するギャップが損傷した文字内に発生する可能性のあるギャップよりも常に広い、最も一般的なアプリケーションの場合は、[最小文字間ギャップ値] パラメータを [最大文字内ギャップ値] パラメータの値に 1 を足して設定します。例えば、文字の内部に水平ギャップが発生することのない場合は、[最大文字内ギャップ値] パラメータに 0 を設定し、[最小文字間ギャップ値] パラメータに 1 を設定します。

最小文字間ギャップ値

異なる文字に属するために、2 つの文字断片の間に必要な水平方向のギャップの最小サイズをピクセル単位で指定します (0 ～ 1000、デフォルト = 0)。このギャップは、ある文字の文字領域の右端から、その隣の文字の文字領域の左端までの距離です。2 つの断片の間のギャップがこの値よりも小さい場合、これらの断片は同じ文字の一部であるとみなされます。ただし、結合後の文字幅が広くなりすぎる場合は例外です ([文字幅の最大値] または [最小文字アスペクト比] パラメータの指定を参照)。

注: 隣り合う文字間に発生するギャップが損傷した文字内に発生する可能性のあるギャップよりも常に広い、最も一般的なアプリケーションの場合は、[最小文字間ギャップ値] パラメータを [最大文字内ギャップ値] パラメータの値に 1 を足して設定します。例えば、文字の内部に水平ギャップが発生することのない場合は、[最大文字内ギャップ値] パラメータに 0 を設定し、[最小文字間ギャップ値] パラメータに 1 を設定します。

最小文字フラグメントサイズ

前景 (つまり、テキスト) ピクセルの最小値を指定します (0 ～ 1000、デフォルト = 15)。前景のピクセル値がこの値を超えていれば、その文字断片は文字の一部であるとみなされます。この値を設定する際は、本物のテキスト断片を保持できるくらい小さい値に設定する必要がありますが、同時に、背景ノイズから小さな断片を除外できるくらい大きくします。ドットマトリックステキストや、ピリオドなどの小さい文字を含むテキストについては、小さい値が必要になります。文字が複数の小さな断片に分割されにくい文字で形成された、途切れのないストロークテキストの場合は、大きい値が必要になります。

文字サイズの最小値

前景 (つまり、テキスト) ピクセルの最小値を指定します (0 ～ 5000、デフォルト = 30)。前景のピクセル値がこの値以上である 2 値化文字がレポートの対象となり、ピクセル値が少ない文字は破棄されます。この設定によって、背景ノイズまたはそのほかのテキスト以外の特徴をフィルタ処理することができます。

セグメント詳細設定

セグメントプロセスに適用される追加パラメータを指定します。

正規化モード

画像の正規化に使用するモードを指定します。このモードは背景のばらつきを除去し、グレースケールの 256 の値 (0 ～ 255) をすべて使用します。

注: この設定は、登録時と実行時の両方で同じでなければなりません。登録後にこの設定を変更すると、分類で問題が発生する原因となる可能性があります。

1 = なし | 正規化は行われません。
2 = グローバル | ローカルなばらつきではなく、ROI 全体の情報を使用して、グローバルな正規化が実行されます。このオプションは背景色とテキストが ROI 全体を通して一定であり、高速モードのときに最適に機能します。
4 = ローカル (デフォルト) | 画像を正規化するために、ROI 内のローカルな文字領域に関する情報を使用して、ローカルな正規化を実行します。このオプションは背景の勾配を除去します。グローバルモードが機能しない場合に使用する必要があります。
8 = ローカル詳細設定 | 画像を正規化するために、ROI 内のローカルな文字領域に関する情報を使用して、背景だけではなく、前景のコントラストの調整を含むローカルな正規化を実行します。このオプションは背景の勾配を除去し、一定でないテキストのコントラストを調整します。3 つのオプションのうち、実行時間が最も長くかかります。

ストローク幅フィルタを使用

残りの画像と同じストローク幅を持たないものをすべて、正規化された画像から削除するかどうかを指定します。このオプションは、近くの文字と接続する可能性のある薄い線などのテキスト以外の特徴について、一部の種類を削除することができます。このオプションによって、2 値化しきい値を超えて偽のフラグメントを作成したり、近くの文字と連結したりする可能性のある、低コントラストの背景のばらつきを除去することもできます。ただし、テキストに一定のストローク幅がない場合や、テキストに大きな可変コントラスト (ストロークの一部が非常に薄いなど) がある場合は、このオプションを使用することによって問題が発生することがあります。

注: この設定は、登録時と実行時の両方で同じでなければなりません。登録後にこの設定を変更すると、分類で問題が発生する原因となる可能性があります。

0 = OFF | 画像にある残りの断片と同じストローク幅を持たないものをすべて、画像から削除しません。
1 = ON (デフォルト) | 画像にある残りの断片と同じストローク幅を持たないものをすべて、画像から削除します。

境界フラグメントを無視

関数が、ROI の境界線に接触する断片をすべて、完全に無視するかどうかを指定します。ラベルのエッジなど、ROI の範囲に含まれる可能性のあるテキスト以外の特徴については、このような断片を無視することが有用です。

注:断片が、文字領域の境界からテキストのメインラインまで伸びている場合、この断片は 1 つの文字とみなされます。このパラメータが有効化されているとき、除外されるテキストのメインラインまで断片が伸びていてはいけません。

0 = OFF (デフォルト) | 境界線の断片を無視しません。
1 = ON | 境界線の断片を無視します。

2 値化しきい値

正規化された画像において、テキストと背景の間で画像をバイナリ化するしきい値の計算に使用します。単位はパーセンテージ (0 ～ 100、デフォルト = 50) で指定します。例えば、デフォルト設定の 50% は約 128 (0 ～ 255 のグレースケール範囲で) の 2 値化しきい値を生成します。このとき、0 は白いテキスト上の黒と同じで、100 は黒いテキスト上の白と同じです。50% 未満の値を使用すると 2 値化しきい値が変更され、テキストがより少なく、背景がより広くなります。一方、50% より大きい値を使用すると、背景がより少なく、テキストがより多くなります。通常、デフォルト値は画像を正しく 2 値化しますが、背景テクスチャがある場合、またはそのほかの背景のばらつきがある場合は、この値を小さくすることで背景のばらつきを補正することができます。

注: この設定は、登録時と実行時の両方で同じでなければなりません。登録後にこの設定を変更すると、分類で問題が発生する原因となる可能性があります。

文字フラグメントのコントラストしきい値

正規化された画像のしきい値に対するコントラストの最小値を、断片全体のグレースケールレベルで指定します (0 ～ 255、デフォルト = 30)。断片のコントラストがこの値を超えていれば、その断片は文字の一部であるとみなされます。断片の各前景ピクセルは常にしきい値を満たすことを保証されますが、断片のすべてのピクセルがしきい値に非常に近いと、断片はテキストではなく、単にノイズとなる可能性が高くなります。値 0 では低コントラストの断片が拒否されるのを妨ぐことができます。

メインラインまでの最大フラグメント距離

テキストを貫通して、水平方向に伸びる「メインライン」から断片を垂直方向に削除する基準となる距離を文字の高さのパーセンテージとして指定します (0 ～ 1000、デフォルト = 0)。本来、文字は最適化された後に (角度方向および傾きを補正する段階)、水平の直線に沿って配置されることが予測されています。しかし、文字に「ジッタ」が見られることがあり、文字位置の縦方向に変動がある可能性があります。デフォルト設定では、これらの文字フラグメントは文字の「メインライン」に沿っていないため、拒否されてしまいます。このパラメータ設定を大きくすることによって、文字の「メインライン」に沿っていないフラグメントを保持することができます。

セグメント解析モード

文字の最適なセグメントを実行する文字解析モードのタイプを指定します。このパラメータは、グループステージ以外の追加の解析を実行するかどうかを決定します。

1 = 最小 | 基本のセグメント解析を実行します。グループステージ解析のみ実行します。
2 = 標準 (デフォルト) | 最適なセグメントを決定するために、文字の間隔を含め、行全体の追加の解析を実行します。有効になっている場合、[最小ピッチ値]、[文字のピッチタイプ]、[文字ピッチ位置] パラメータの影響を受けます。

最小ピッチ値

2 つの文字の間に発生する可能性のあるピッチの最小値をピクセル単位で指定します (0 ～ 1000、デフォルト = 0)。ピッチは [文字ピッチ位置] パラメータに基づいて計算されます。2 つの断片の間のピッチがこれよりも小さい場合、これらの断片は同じ文字の一部であるとみなされます。ただし、結合後の文字幅が広くなりすぎる場合は例外です（[文字幅の最大値] または [最小文字アスペクト比] パラメータの指定を参照）。

文字ピッチ位置

2 つの連続する文字間のピッチの測定方法を指定します。ピッチは、隣り合う文字の対応する点と点の間の (おおよその) 距離として定義されます。ある文字の末尾から隣の文字の始めまでの距離 (文字間ギャップ) ではありません。文字に異なる幅がある固定ピッチフォントでは、通常、適切なピッチメトリクスが使用されている場合のみ、ピッチは一定の値を持ちます。

注:[セグメント解析モード] パラメータが [最小] に設定されている場合、このパラメータは無効になります。

1 = 自動 (デフォルト) | 未知のメトリクスが使用されていることを示します。適切なピッチはその他のピッチ位置のいずれかである可能性もありますし、一定のピッチ位置がない可能性もあります (プロポーショナルピッチフォントの場合)。また、OCRMax 関数によって適切なピッチメトリクスが決定されます。
2 = 左－左 | ある文字の文字領域の左端から隣の文字の文字領域の左端までの距離を測定したピッチを指定します。 注: 「左」および「右」という用語は、ROI により定義された座標を基準にしています。つまり、「右」は正の X 方向です。
4 = 中央－中央 | ある文字の文字領域の中央から隣の文字の文字領域の中央までの距離を測定したピッチを指定します。
8 = 右－右 | ある文字の文字領域の右端から隣の文字の文字領域の右端までの距離を測定したピッチを指定します。 注: 「左」および「右」という用語は、ROI により定義された座標を基準にしています。つまり、「右」は正の X 方向です。

文字のピッチタイプ

連続する文字の文字間隔に 1 つの固定値を確保するか、特定の文字によって異なるのかを指定します。ピッチは、隣り合う文字の対応する点と点の間の (おおよその) 距離として定義されます。ある文字の末尾から隣の文字の始めまでの距離 (文字間ギャップ) ではありません。

注:[セグメント解析モード] パラメータが [最小] に設定されている場合、このパラメータは無効になります。

1 = 自動 (デフォルト)

ピッチタイプは不明だが、固定、またはプロポーショナルのどちらかで、可変ではないことを表します。OCRMax 関数によって最適なタイプが決定されます。

2 = 固定

ピッチが固定、つまり任意の 2 文字のピッチは一定であることを表します。たとえば、文字矩形の幅は関係ありません。このピッチは、[文字ピッチ位置] パラメータを基準に測定されます。

4 = 比例

ピッチがプロポーショナルである、つまり任意の 2 文字のピッチはその文字によって異なることを表します。例えば、2 つの小文字「i」の間の距離は、2 つの大文字「M」の間の距離よりもかなり少なくなります。

注:
  • ピッチの計測値は文字列全体を通して一定ではありませんが、通常、文字間ギャップはほぼ一定です (文字間ギャップとは、ある文字の文字領域の右端から、隣の文字の文字領域の左端までの距離です)。
  • 「左」および「右」という用語は、ROI により定義された座標を基準にしています。つまり、「右」は正の X 方向です。

8 = 可変

文字列全体で、文字から文字までのメトリックが一定ではなく (たとえば、文字の配置がばらばらである)、ピッチは固定でもプロポーショナルでもないことを表します。OCRMax 関数でピッチのタイプを特定することは推奨しません。

注: [変数] ピッチは [自動] とは異なります。[自動] は、ピッチは固定またはプロポーショナルのどちらかではあるが、不明であることを前提にしています。

分類の詳細設定

分類プロセスを調整するパラメータを指定します。登録文字と取り込んだ画像内の文字の相違に基づいて文字を分類する方法を指定します。

分類テンプレートサイズ幅

登録文字矩形と実行時文字矩形間の許容可能な X スケール係数を指定します (5 ～ 50、デフォルト = 10)。有効な場合は、スケール制約を満たすインスタンスのみが計算されます。

分類テンプレートサイズの高さ

登録文字矩形と実行時文字矩形間の許容可能な Y スケール係数を指定します (5 ～ 50、デフォルト = 18)。有効な場合は、スケール制約を満たすインスタンスのみが計算されます。

文字のアスペクト比を保持

実行時に展開された画像を再サンプリングする際にアスペクト比を維持するかどうかを指定します。

0 = OFF (デフォルト) | 実行時に展開された画像を再サンプリングする際にアスペクト比を維持しません。
1 = ON | 実行時に展開された画像を再サンプリングする際にアスペクト比を維持します。

追加の文字検証をスキップ

分類時に追加の文字検証を実行するかどうかを指定します。

0 = OFF | 分類時に追加の文字検証を実行します。これは、誤読 (文字を誤って許容するなど) の可能性を低減します。
1 = ON (デフォルト) | 分類時に追加の文字検証を実行しません。ただし、このオプションでは誤読が発生することがあります。

画像前処理

分類前に実行する画像処理関数を指定します。

0 = なし | 分類前に画像処理を実行しません。
1 = 正規化ヒストグラム (デフォルト) | ヒストグラムに基づいて画像を正規化します。
2 = 中央値を減算 | ローカルの近傍の中央値に基づいて減算します。
3 = 正規化ヒストグラム & 中央値を減算 | 分類時に正規化ヒストグラムと中央値の減算の両方の画像処理を実行します。 注: このオプションが選択されると、ヒストグラムの正規化が実行されてから中央値が減算されます。

フィールド化

[フィールド化] を使用して、文字列のさまざまな位置にあると予測される文字に関する情報を提供します。

フィールド化していない文字を無視

文字位置ごとに、文字のフィールド形式によって指定された文字のみを含めるように結果を制約するかどうかを指定します。有効な場合は、分類得点に関係なく、フォント内の他のすべての文字が無視されます。

0 = OFF (デフォルト) | 文字のフィールド形式に基づいて結果を制約しません。
1 = ON | 文字のフィールド形式に基づいて結果を制約します。

文字列長

フィールド形式を固定長モードまたは可変長モードのどちらで実行するかを指定します。

0 = 可変 | 可変長モードで動作します。
1 = 固定 (デフォルト) | 固定長モードで動作します。

最大文字列長

許容可能な最大文字数を指定します (0 ～ 100、デフォルト = 25)。

注: [文字数] パラメータが [固定] に設定されている場合、このパラメータは使用できません。

最小文字列長

許容可能な最小文字数を指定します (0 ～ 100、デフォルト = 1)。

注: [文字数] パラメータが [固定] に設定されている場合、このパラメータは使用できません。

最初にフィールド化した最大インデックス値

考慮対象となる、フィールド化の部分列を指定します。部分列はこのインデックス値を超えない位置で開始する必要があります (0 ～ 100、デフォルト = 100)。

注: [文字数] パラメータが [固定] に設定されている場合、このパラメータは使用できません。

最後にフィールド化した最小インデックス値

考慮対象となる、フィールド化の部分列を指定します。部分列はこのインデックス値を超えない位置で終了する必要があります (0 ～ 100、デフォルト = 0)

注: [文字数] パラメータが [固定] に設定されている場合、このパラメータは使用できません。

OCRMaxSettings 関数の出力

戻り値

読み取られた文字列を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • OCRMax 関数について
  • OCRMax 関数
  • OCRMax データアクセス関数
  • OCRMax 関数の設定方法
  • プロパティシートの使用方法
  • [オートチューン] ダイアログ
  • OCRMaxAutoTune 関数
  • TransOCRMaxToWorld 関数


[OCV/OCRフォントの登録] ダイアログ

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

[OCV/OCR フォントの登録] ダイアログを使用すると、フォントの文字モデルを追加、修正、または削除して、ユーザ登録フォントを作成することができます。このユーザ登録フォントは、TrainFont 関数に格納されます。このフォントは、ReadText 関数によるテキストの文字認識、または VerifyText 関数によるテキストの文字照合の際にそれぞれ使用されます。

注:
  • TrainFont、ReadText、VerifyText の各関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadText、TrainFont および VerifyText 関数の代わりに、OCRMax 関数を使用することを推奨します。OCRMax 関数には拡張性能機能が搭載されています。
  • フォントの各文字には最大 8 つのインスタンスを登録することができます。より多くの文字インスタンスを追加することによって、フォント内の対応する文字モデルの変形許容値が向上します。
  • フォントには最大 255 種類の文字モデルとともに特定の文字の 8 インスタンスを含むことができます。各モデルに文字ラベルが 1 つずつ割り当てられます。これらの制限のいずれかを超過した場合、In-Sight センサでは超過した文字モデルはすべて無視され、追加されません。
  • 文字形状の変動が小さい文字照合/認識アプリケーションでは、必要なインスタンスが 1 つで済む場合があります。文字形状の変動に対して大きな許容値が必要な場合には、必要な文字インスタンスの数も増加します。
  • ユーザインタフェースの言語が中国語または韓国語以外の値に設定されている場合、ラベルに中国語や韓国語の文字が含まれている文字インスタンスでは、[削除] や [ラベル変更] を含む OCV/OCR 操作は機能しません。ラベルに含まれている文字列に対応した言語にユーザインタフェースを変更してから、もう一度操作をやり直すか、またはラベルに英語の文字を使用してください。
  • 漢字などのマルチバイト文字のモデル名はサポートされていません。マルチバイト文字は登録できますが、文字モデルに指定する名前はシングルバイトの名前にする必要があります。

[フォントの登録] ダイアログを開く

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [ビジョンツール] リストを展開します。
  3. [文字照合/認識] ツールカテゴリを選択します。
  4. 関数リストから TrainFont 関数を選択して、[OK] ボタンを押すか、関数名をダブルクリックします。

  5. [フォントの登録] ダイアログが表示されます。

[画像] タブ

[画像] タブでは、フォントの登録に使用する画像を取得することができます。目的の画像がアクティブな画像として既にロードされている場合は、次のセクションに進んでください。それ以外の場合は、次のいずれかの方法で、有効な画像を得ることができます。

  • [ライブの開始]: センサをライブ表示モードにして、リアルタイム画像を表示します。必要な画像を取り込んだら、[ライブの停止] をクリックします。
  • [画像を開く]: [開く] ダイアログを表示します。このダイアログを使用して、In-Sight センサ、ローカル PC、またはネットワーク接続された PC から画像をロードできます。
  • [参照する画像の選択]: セル選択モードに切り替わり、アクティブジョブの [image] 構造体を参照できるようになります(スプレッドシートビューのみ)。
  • [基準画像]: ツールが検査を行うために使用する画像を定義します。画像フィルタリングツール、Color Blob または Color Blobs (1 ～ 10) Location Tool、Color Blob Area または Color Blobs Areas (1 ～ 10) Measurement Tool、Color Blobs Counting Tool の出力画像、またはフィルタされていない取り込み画像 (デフォルト設定) のいずれかから選択します。(EasyBuilder ビューのみ)

スプレッドシートビュー:

EasyBuilder ビュー:

[登録] タブ

[登録] タブでは、画像から文字を抽出して、各文字のモデルを作成することができます。

ヒント:
  • フォントを登録するときに画像フィルタを使用する場合は、文字照合/認識の際に使用するフィルタと同じフィルタを使用してください。同じフィルタを使用しないと、文字照合/認識の精度が低下します。
  • エンボス状態の文字は、そのフォントの黒/白に応じて 収縮 または 膨張 フィルタを適用し、文字ストロークの中心のエンボス部分を埋めておくと、パフォーマンスを上げることができます。
  1. わかりやすいフォント名を選択します。フォントに名前を付けると、スプレッドシートのジョブに複数の　 [image] 　データ構造体が含まれている場合に便利です。

注: GetFontName 関数を使用して、フォント名をスプレッドシートに返すことができます。

  2. 登録する文字が周囲の背景よりも明るい場合は、[極性] として [白 (黒い背景)] を選択します。登録する文字が周囲の背景よりも暗い場合は、[黒 (白い背景)] を選択します。

注: [フォントの追加] ボタンをクリックする前に、登録する文字の極性が正しく設定されていることを確認してください。文字モデルをフォントに追加した後に極性を変更することはできません。

  3. デフォルトでは、1 つ以上の文字インスタンスがフォントに既に存在していたとしても、すべての文字がフォントに追加されます。新しい文字のみをフォントに追加する場合は、[新しい文字のみを登録] をクリックします。
  4. 登録する文字を含む最初のテキスト行と一致する [文字列] を入力します。

  5. [領域] ボタンをクリックします。
  6. 登録する文字が囲まれるように、対話型グラフィックスの配置とサイズを指定してください。

  7. 領域内でダブルクリックすると、変更が確定します。
  8. [セグメント] ボタンをクリックします。指定された [文字列] に基づいて、[領域] 内の文字が個々の文字インスタンスに分割されます。
  9. 正しくセグメント化されていない文字が残っている場合は、[変更] ボタンをクリックして、個々の文字インスタンスの対話型グラフィックス領域を微調整します。不正確なセグメントを調整するには、セグメントの領域をクリックして、文字が適切に囲まれるように、この領域を配置し、サイズを変更します。すべてのセグメントが文字の周りに正しく配置されるまで、この手順を繰り返します。
  10. 文字のいずれかが正しくラベル付けされていない場合は、まず、指定された [文字列] が画像内の文字と一致することを確認します。文字列が正しい場合は、[ラベルの変更] ボタンをクリックします。誤ったラベルのついた文字をダブルクリックして [ラベルの変更] ダイアログを開きます。正しいラベルを入力して、[OK] をクリックします。
  11. 必要に応じて、[削除] ボタンをクリックし、セグメントを個別に削除します。
  12. すべての文字が正しくセグメント化、およびラベル付けされたら、[フォントの追加] ボタンをクリックします。選択したテキスト行内の各文字のインスタンスが、現在のフォントに追加されます。登録する文字が含まれているテキスト行それぞれについて、この手順を繰り返します。
注:
  • 文字をフォントに追加した後で、セグメントの修正、ラベル変更、削除を行うことはできません。
  • フォント登録にあたっては 1 文字ずつ追加せず、一度に複数の文字を登録するようにしてください。1 文字だけを追加した場合、文字列内の文字を読み取るときに重要な間隔情報がないことになります。1 文字だけを登録する必要がある場合は、次のような手順で登録してください。
    • 文字をセグメントした後、[修正] ボタンを押します。
    • 文字の両側にスペースができるように、文字ボックスの幅を調整します。図に示されているように、文字ボックスの左右の境界線が登録文字と隣の文字との中間になるようにします。

[フォント] タブ

[フォント] タブは、登録したフォントに含まれる文字モデルの表示および編集に使用します。ユーザフォントにはいくつかの文字モデルが含まれています。いくつかのモデル (「C」、「o」など) は、複数の文字インスタンスで構成されています。スペースや句読点を含むすべての文字が切り出され、文字モデルとして登録されます。ここで、すべての文字モデルを参照して、特定の文字モデルまたは文字インスタンスの削除、編集、名前変更、または有効化/無効化を行うことが可能です。[フォント] ツリーのルートレベル [image] を選択すると、各文字のモデルが表示されます。[フォント] ツリーの文字フォルダを選択すると、コンポジット文字モデル (* で示されます) と、モデルの作成に使用された登録文字のインスタンス (0 から始まるインデックス番号で示されます) が表示されます。登録文字の各インスタンスは、個別のサブフォルダに保存されます。

  1. [有効] チェックボックスは、このフォントで文字モデルが使用されるかどうか、また各文字のどのインスタンスがモデルの構築に使用されるかを指定します。デフォルトでは、このチェックボックスはすべての文字モデルについて有効化されています。文字モデル、または文字インスタンスを無効化するには、対象のモデルまたはインスタンスをハイライトし、チェックボックスを OFF にします。
注:
  • ある文字モデルの [有効] チェックボックスがオフになると、その文字のすべてのインスタンスが無効になります。
  • 無効にされた文字インスタンスは、文字照合/認識の実行時には文字モデルとして利用されません。
  2. 文字モデル、または文字インスタンスが正しくない場合は、誤ったラベルのついたモデルまたはインスタンスをハイライトし、[ラベルの変更] ボタンをクリックして、ラベルを訂正します。文字モデルを選択している場合、そのすべての文字インスタンスの名前を変更します。1 つの文字インスタンスが選択されている場合、このインスタンスのラベルのみが変更され、対応する文字モデルフォルダに移動されます。
  3. 文字モデル、または文字モデルから文字インスタンスを個別に削除するには、削除対象をハイライトし、[削除] ボタンをクリックします。

注: 文字モデルを削除すると、その文字のすべての登録インスタンスが消去され、復元することはできません。

  4. 選択した文字モデルや文字インスタンスのクローズアップを表示するには、[修正/表示] ボタンをクリックしてフォントエディタを開始します。文字モデルは編集できます。文字インスタンスは表示のみが可能です。編集された文字モデルには、[フォント] ツリーのフォルダの横に「*」が表示されます。

注: フォントエディタはむやみに使用しないでください。低品質なサンプルフォントを加工して登録するよりも、高品質なサンプルフォントで取り込んだ方が良い結果が得られます。

  5. 文字モデルに対して手動で行われた編集に満足できない場合は、[モデルの再構築] ボタンをクリックして、選択したフォント文字を再構築し、フォントエディタを使用して手動で行った編集をすべて削除することができます。
  6. フォントからすべての文字モデルとインスタンスを削除して最初からもう一度やり直すには、[すべて削除] ボタンをクリックします。

[相違度表] タブ

[相違度表] タブには、各文字モデルとほかのすべてのモデルを比較した一覧が表示され、その中で選択した 2 つの文字の違いが点数で表示されます。行見出しと列見出しは、文字が登録されたときに定義された文字ラベルを示します。2 つの文字の相違度が大きければ大きいほど、検査中にこれらの文字が誤認識される可能性が低くなります。このデータは、パフォーマンスに悪影響を与える可能性のある、登録フォントの弱点を示すため便利です。下の例では、「e」と「C」の文字モデルの相違度は 95 ときわめて高くなっています。これは、現在のフォントで、これら 2 つの文字が誤認識される可能性が非常に低いことを示しています。一方、「o」と「e」の文字モデルの相違度は 27 にすぎません。したがって、これら 2 つの文字は誤認識されやすいことを意味します。

  1. 表示する [得点付けモード] 相違度表として、[高速] または [高精度] を指定します。前述のように、相違度が高いほど、選択した 2 つの文字が検査中に誤認識される可能性が低くなります。

ヒント: 相違度表に表示される得点は、ReadText 関数や VerifyText 関数の [読み取りモード] パラメータで [高速] と [高精度] のどちらを選択すべきかを判断する際の目安となります。

  2. [右値以下を警告表示] フィールドに値を入力します。文字モデルの比較得点がこの相違値以下の場合は、すべて黄色でハイライトされます。これは、誤認識されやすい文字モデルのペアを示します。ハイライトする得点のしきい値を増減するには、↑/↓ボタンをクリックするか、値を入力します。[警告表示数] が更新され、得点が指定値以下である文字モデル比較の個数が表示されます。この個数は、[右値以下を警告表示] で指定したしきい値によって変化します。
  3. 文字モデルを隣り合わせに表示するには、黄色でハイライトされたペアをそれぞれクリックします。[選択された文字] フィールドには、比較中の各文字のモデルが表示されます。[相違度] には、選択した文字の「類似していない度合い」が表示されます。この比較によって、文字モデルが正しく登録されていなかったこと、文字モデルが登録されたときの画像状態がよくなかったこと、使用された文字の品質が低かったことなどが明らかになることがあります。

注: [フォント] タブで無効にされている文字は、相違度表には表示されません。

関連項目

OCV/OCR フォントの登録について

TrainFont 関数

ReadText 関数

VerifyText 関数


ReadText 関数

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

ユーザ登録フォントの文字モデルを使用して画像領域内のテキスト文字列を読み取ります。

注:
  • TrainFont、ReadText、VerifyText の各関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadText、TrainFont および VerifyText 関数の代わりに、OCRMax 関数を使用することを推奨します。OCRMax 関数には拡張性能機能が搭載されています。

ヒント:

  • テキスト文字列がすでにわかっている場合は、常に VerifyText 関数を使用します。テキスト文字列の読み取りがより速く、より正確に行われるようになります。
  • スピードの要求されないアプリケーションでは、スケール許容を ON にしてください。文字サイズのわずかな変化のために検出精度が大きく低下するのを防ぐことができます。
  • 文字列でない場所を誤って検出した場合、または、文字列がどこにも検出されなかった場合は、疑字背景を ON にして、再試行します。
  • 文字認識中に誤読が発生した場合は、読み取りモードを [高速] から [高精度] に切り替えます。[高精度] を選択した場合、文字と文字はより厳密に区別され、さらに正確な得点を上げることができます。それでも誤読が発生する場合は、登録フォントを開き、2 つの混同する可能性のある文字を調べます。それらの文字がうまく登録されていない可能性があります。
  • 常に同じ位置にスペースが入っているテキスト文字列を読み取っている場合は、フィールド文字列にスペースを追加します。

ReadText 関数の入力パラメータ

ReadText 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ,

フォント ,

フィールド文字列 ,

フィールド定義

アクセプトしきい値 ,

得点差しきい値 ,

チューン ,

照合モード ,

疑字背景 ,

スケール許容 ,

タイムアウト,

表示

)

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

領域

移動および回転可能な矩形の画像領域を指定します。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

フォント

登録フォントを含む [image] データ構造体へのセル参照。

フィールド文字列

文字列に含まれる文字数を指定します。フィールド文字列エントリには、(A～Z)、(a～z)、(0～9)、ハイフン（-）、ドット（.）、スペース（ ）など、[テキスト入力] ダイアログのすべての文字を使用できます。

フィールド文字列の各文字は、0 ～ 31 のインデックス付きフィールド位置に対応します。フィールド文字列には、読み取りを成功させたい文字列の文字と同じ数の位置が含まれている必要があります。デフォルトでは、フィールド文字列の各位置は、アスタリスク（*）か英数字の「ワイルドカード」で示されます。これは、文字列のどの位置でもすべての文字が有効であることを意味します。

ただし、フィールド文字列の個別の位置は、その位置に一部の文字しか想定されないように制限することができます。すると、対象外の文字は読み取り時に考慮されないため、全体的な性能と信頼性が向上します。

定義済みのフィールド文字列エントリは、次のとおりです。

フィールド文字列 エントリ | 説明 | 有効な文字
* | ワイルドカード | フォントに含まれる任意の登録文字です。
N | 数字 | 0123456789
A | 大文字の英字 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小文字の英字 | abcdefghijklmnopqrstuvwxyz
H | 16 進値（大文字の英字と数字） | 0123456789ABCDEF
h | 16 進値（小文字の英字と数字） | 0123456789abcdef
O | 8 進値 | 01234567

注:

  • フィールド文字列のある位置を特定の文字に制限する場合は、その文字を入力してください。文字はフォントに登録されている必要があります。また、[フィールド定義] パラメータを使用して再マップしない限り、上記の定義済み [フィールド文字列] エントリの文字を使用することはできません。
  • スペースを含む文字列を読み取るには、フィールド文字列にスペースを含めます。その位置の対応するフィールド文字列エントリがアスタリスク（*）の場合、ReadText 関数はスペースを読み取りません。

Closed フィールド文字列の例 1

フィールド文字列が「**********AN」の場合、1～10 番目のフィールド文字列位置ではフォントに含まれるすべての文字が有効です。ただし、11 番目の位置は、読み取り時に大文字の英字だけが想定されます。また、12 番目の位置は、数字だけが想定されます。

Closed フィールド文字列の例 2

フォントには、0～9 の数字と / だけが含まれます。フィールド文字列が「NN/NN/NN」の場合、1、2、4、5、7、および 8 番目の位置では数字だけが想定されています。また、3 および 6 番目の位置ではスラッシュ（/）だけが想定されています。

ただし、フィールド文字列が「NN/NN/AA」の場合は、フォントに英字が含まれていないため、#ERR が返されます。

フィールド定義

必要に応じ、[フィールド定義] 設定を使用して [フィールド文字列] のユーザ定義エントリを作成できます。このエントリがフィールド文字列に含まれると、このエントリの挿入位置で有効となる文字のリストが限定されます。

セミコロン（;）で区切ることによって、複数のフィールド定義を使用できます。

フィールド定義エントリのために示す文字は、フォントに含まれている必要があります。次に例を示します。#=123 は、ユーザ登録フォントに 1、2、3 が含まれる場合に有効です。ただし、#=123 は、フォントに 1、2、3 が含まれない場合は無効です。

注意: 定義済みのエントリ (*, A, a, N, H, h, O) をフィールド定義パラメータで使用すると、新しい定義で有効な文字のリストが再割り当てされます。

Closed フィールド定義の例 1

フィールド定義の値が「#=123;$=3456;%=789」で、フィールド文字列が「#$%*******」の場合、1 番目の位置で有効な文字は、1、2、または 3 だけです。2 番目の位置で有効な文字は、3、4、5、または 6 だけです。また、3 番目の位置では、7、8、または 9 だけが有効です。また、4～10 番目の位置ではフォントに含まれるすべての文字が有効です。

Closed フィールド定義の例 2

フィールド定義の値が「#=123;$=3456;%=789, A=A」で、フィールド文字列が「#$%******A,」の場合、1 番目の位置で有効な文字は、1、2、または 3 だけです。2 番目の位置で有効な文字は、3、4、5、または 6 だけです。また、3 番目の位置では、7、8、または 9 だけが有効です。また、4～9 番目の位置ではフォントに含まれるすべての文字が有効です。[フィールド定義]「A=A」は定義済みの [フィールド文字列] エントリを再マップするため、10 番目の位置では A だけが想定されています。

アクセプトしきい値

各文字の許容できる最低一致得点 (0 ～ 100、デフォルト = 70) を指定します。ReadText 関数はアクセプトしきい値未満の一致得点の文字を不合格とし、その文字列を不合格とします。

得点差しきい値

最高得点の文字と 2 番目の得点の文字の一致得点の間に必要な最小差（0～20、デフォルト = 0）。

2 番目に高い得点の文字を調べるには、次を使用してください。GetChar(テキスト, インデックス, 1)

2 番目に高い得点の文字の得点を調べるには、次を使用してください。GetScore(テキスト, インデックス, 1)

チューン

参照されている [image] データ構造体の文字モデルのスケールを 50　～　200% で調整します。一致得点は、文字モデルのサイズを読み取る文字のサイズに可能な限り近づけることによって最大になります。チューンは、文字モデルのサイズと読み取る文字のサイズの差が ±5% を超える場合にのみ実行してください。

チューンは大きな処理時間を必要とするため、1 回だけ実行するようにします。一度、チューンを ON にしてジョブを実行したら、後のジョブの処理時間を短縮するためにスプレッドシートを開いてチューンを OFF にしてください。

0 = OFF (デフォルト) | スケールの調整を行いません。
1 = ON | 一致得点が最大になるように、文字モデルのスケールを調整します。

照合モード

読み取り精度を向上させるために、高度なアルゴリズムを使用するかどうかを指定します。

注: 背景の状態によっては [高精度] よりも [高速] を選択したときに良好な結果を得られることがあります。アプリケーションに応じて選択してください。

ヒント: [高精度] を選択している場合は、得点が低く抑えられる傾向があるため、アクセプトしきい値を小さめに設定する必要があります。

0 = 高速（デフォルト） | 高度なアルゴリズムを使用しません。このアルゴリズムを使用する場合、デコード速度は向上する可能性がありますが、精度が劣る可能性があります。
1 = 高精度 | 高度なアルゴリズムを使用してデコードを行います。このアルゴリズムは、精度がより高くなっていますが、デコード速度は低下する可能性があります。

疑字背景

画像内のそのほかの特徴が、テキスト文字列と区別しづらい場合に指定します。この設定は、画像内のそのほかの特徴が誤って文字列の先頭と認識される場合には特に有効です。

0 = OFF (デフォルト) | 画像内にテキスト文字列と区別しづらい特徴が含まれない場合に指定します。
1 = ON | 画像内にテキスト文字列と区別しづらい特徴が含まれている場合に指定します。

スケール許容

文字サイズの小さなばらつきを補正するため ± 10% の許容値を指定します。

0 = OFF (デフォルト) | 文字スケールの小さなばらつきを認めません。
1 = ON | 文字スケールの小さなばらつきを認めます。

タイムアウト

関数が有効なテキスト文字列を検索する時間をミリ秒単位で指定します (0 ～ 30000)。この時間が経過すると、処理は中止され、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示

画像上の ReadText グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | ReadText 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 文字セグメントおよび対応するラベルが常に表示されます。
2 = 入力と結果のグラフィックス | 画像領域と文字セグメントおよび対応するラベルが常に表示されます。

ReadText 関数の出力

戻り値 | 読み取られた文字列を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | ReadText 関数をスプレッドシートに配置すると、結果テーブルが自動的に作成されます。

ReadText 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

文字列 | GetString(テキスト) | 参照されている [image] データ構造体のテキスト文字列を返します。
文字列合格 | GetPassed(テキスト) | 参照されている [image] データ構造体の文字列全体の合格/不合格ステータスを返します。
文字 | GetChar(テキスト, インデックス 0, [インデックス 1]) | 参照されている [image] データ構造体のインデックス付き文字を返します。オプションの「インデックス 1」パラメータが 1 の場合は、2 番目に高い得点の文字を返します。
得点 | GetScore(テキスト, インデックス 0, [インデックス 1]) | 参照されている [image] データ構造体のインデックス付き文字の一致得点 （0～100） を返します。オプションの「インデックス 1」パラメータが 1 の場合は、2 番目に高い得点の文字の得点を返します。
合格 | GetPassed(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の合格/不合格ステータスを返します。[インデックス] パラメータが指定されていない場合は、文字列全体の合格/不合格ステータスを返します。

テキストデータアクセス関数を使用して、次のデータ要素を取得できます。

角度 | GetAngle(テキスト) | データ構造体のテキスト文字列と [image] データ構造体の水平軸の間の角度を返します。
列 | GetCol(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の列座標 (ピクセル単位) を返します。
高さ | GetHigh(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の高さ (ピクセル単位) を返します。
行 | GetRow(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の行座標 (ピクセル単位) を返します。
幅 | GetWide(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の幅 (ピクセル単位) を返します。

関連項目

文字照合/認識ツールについて

新しいフォントの登録

文字照合/認識 (テキスト) データアクセス関数

プロパティシートの使用方法


TrainFont 関数

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

フォント文字を登録します。[関数の挿入] ダイアログから TrainFont を選択した場合、[OCV/OCR フォントの登録] ダイアログが自動的に表示されます。

注:TrainFont、ReadText、VerifyText の各関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

TrainFont 関数 (

画像 ,

表示

)

In-Sight のフォントについて

フォントは、画像から抽出された 1 つ以上の文字を使って「登録」された、最大 255 の文字モデルのセットです。登録フォントの各文字モデルにはラベルを割り当てる必要があります。

登録フォントは [image] データ構造体に保存されます。VerifyText は、テキスト文字列の文字、およびフォントに保存された既存の文字モデルを比較して、テキスト文字列の内容を検証します (OCV)。ReadText は、テキスト文字列の文字、およびフォントに保存された文字モデルを比較して、文字列を「読み取り」ます (OCR)。

注: 均一の文字サイズのフォントのみを登録してください。対応する文字セグメントのサイズも均一である必要があります。フォントサイズが異なる場合は、別の TrainFont 構造体を作成します。また、文字の間隔を学習できるように、文字をブロックとして登録します。

TrainFont 関数の入力パラメータ

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

表示

データ構造体がスプレッドシート内で選択されたときに適用する、画像上の TrainFont グラフィックスの表示モードを指定します。

注: この関数がスプレッドシートに挿入されたら、[表示] パラメータの値を数式バーで変更できます。

0 = 非表示 (デフォルト) | すべてのグラフィックスが非表示になります。
1 = データベースインスタンス | TrainFont 関数を含んだセルがスプレッドシート内でハイライト表示されたときに、登録モデルに関連付けられたデータベースインスタンスを表示します。
2 = 登録モデル | TrainFont 関数を含んだセルがスプレッドシート内でハイライト表示されたときに、登録モデルを表示します。

TrainFont 関数の出力

戻り値

文字モデルのデータベースを含んだ [image] データ構造体。

TrainFont 関数データアクセス関数

データアクセス関数を使用して、次のデータ要素を取得できます。

GetFontLabel(フォント, インデックス) | 参照元の [image] データ構造体からインデックス付き文字モデルのラベルを返します。
GetFontName(フォント) | 参照元の [image] データ構造体からフォントの名前を返します。
GetFontNumCharacter(フォント) | 参照元の [image] データ構造体の文字モデル数を返します。

関連項目

文字照合/認識ツールについて

新しいフォントの登録

文字照合/認識 (テキスト) データアクセス関数


VerifyText 関数

ビジョンツール → 文字照合/認識

In-Sight 関数リファレンス

画像領域内のテキスト文字列の文字を照合します。テキスト文字列の文字をユーザ登録フォントの文字モデルと比較します。また、混同する可能性のある文字と比較します。

注:
  • TrainFont、ReadText、VerifyText の各関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadText、TrainFont および VerifyText 関数の代わりに、OCRMax 関数を使用することを推奨します。OCRMax 関数には拡張性能機能が搭載されています。

ヒント:

  • スピードの要求されないアプリケーションでは、スケール許容を ON にしてください。文字サイズのわずかな変化のために検出精度が大きく低下するのを防ぐことができます。
  • 文字列でない場所を誤って検出した場合、または、文字列がどこにも検出されなかった場合は、疑字背景を ON にして、再試行します。
  • 文字照合中に誤読が発生した場合は、照合モードを [高速] から [高精度] に切り替えます。[高精度] を選択した場合、文字と文字はより厳密に区別され、さらに正確な得点を上げることができます。それでも誤読が発生する場合は、登録フォントを開き、2 つの混同する可能性のある文字を調べます。これらの文字はうまく登録されていない可能性があります。

VerifyText 関数の入力パラメータ

VerifyText 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ,

フォント ,

文字列 ,

アクセプトしきい値 ,

得点差しきい値 ,

チューン ,

照合モード ,

疑字背景 ,

スケール許容 ,

タイムアウト,

表示

)

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 行オフセット。
列 | 列オフセット。
角度 | 角度。

領域

移動および回転可能な矩形の画像領域を指定します。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

フォント

登録フォントを含む [image] データ構造体へのセル参照。

文字列

照合する文字列 (最大 100 文字)。

注: VerifyText 関数では、空白スペースが画像で文字と同じ幅を持っている場合、テキスト文字列内の空白スペースを照合します。

アクセプトしきい値

各文字の許容できる最低一致得点 (0 ～ 100、デフォルト = 90)を指定します。VerifyText 関数はアクセプトしきい値未満の一致得点の文字を不合格とし、その文字列を不合格とします。

得点差しきい値

最高得点の文字と 2 番目の得点の文字の一致得点の間に必要な最小差（0～20、デフォルト = 0）。

2 番目に高い得点の文字を調べるには、GetChar(テキスト, インデックス, 1) 関数を使用してください。

2 番目に高い得点の文字の得点を調べるには、GetScore(テキスト, インデックス, 1) 関数を使用してください。

チューン

参照されている [image] データ構造体の文字モデルのスケールを 50 ～ 200% で調整して画像の文字と対応させ、一致得点を最大にします。チューンは、文字モデルのサイズと読み取る文字のサイズの差が ±5% を超える場合にのみ選択してください。

0 = OFF (デフォルト) | スケールの調整を行いません。
1 = ON | 一致得点が最大になるように、文字モデルのスケールを調整します。

ヒント: チューンは大きな処理時間を必要とするため、1 回だけ実行するようにします。一度、チューンを ON にしてジョブを実行したら、後のジョブの処理時間を短縮するためにスプレッドシートを開いてチューンを OFF にしてください。

照合モード

読み取り精度を向上させるために、高度なアルゴリズムを使用するかどうかを指定します。

注: 背景の状態によっては [高精度] よりも [高速] を選択したときに良好な結果を得られることがあります。アプリケーションに応じて選択してください。

ヒント: [高精度] を選択している場合は、得点が低く抑えられる傾向があるため、アクセプトしきい値を小さめに設定する必要があります。

0 = 高速 (デフォルト) | 高度なアルゴリズムを使用しません。このアルゴリズムを使用する場合、デコード速度は向上する可能性がありますが、精度が劣る可能性があります。
1 = 高精度 | 高度なアルゴリズムを使用してデコードを行います。このアルゴリズムは、精度がより高くなっていますが、デコード速度は低下する可能性があります。

疑字背景

画像内のそのほかの特徴が、テキスト文字列と区別しづらい場合に指定します。この設定は、画像内のそのほかの特徴が誤って文字列の先頭と認識される場合には特に有効です。

0 = OFF (デフォルト) | 画像内にテキスト文字列と区別しづらい特徴が含まれない場合に指定します。
1 = ON | 画像内にテキスト文字列と区別しづらい特徴が含まれている場合に指定します。

スケール許容

文字サイズの小さなばらつきを補正するため ± 10% の許容値を指定します。

0 = OFF (デフォルト) | 文字スケールの小さなばらつきを認めません。
1 = ON | 文字スケールの小さなばらつきを認めます。

タイムアウト

関数が有効なテキスト文字列を検索する時間をミリ秒単位で指定します (0 ～ 30000)。この時間が経過すると、処理は中止され、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示

画像上の VerifyText グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | VerifyText 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 文字セグメントおよび対応するラベルが常に表示されます。
2 = 入力と結果のグラフィックス | 画像領域と文字セグメントおよび対応するラベルが常に表示されます。

VerifyText 関数の出力

戻り値 | 照合された文字列を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | VerifyText 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

VerifyText 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

文字列 | GetString(テキスト) | 参照されている [image] データ構造体のテキスト文字列を返します。
文字列合格 | GetPassed(テキスト) | 参照されている [image] データ構造体の文字列全体の合格/不合格ステータスを返します。
文字 | GetChar(テキスト, インデックス 0, [インデックス 1]) | 参照されている [image] データ構造体からインデックス付き文字を返します。オプションの [インデックス 1] パラメータが 1 の場合、[インデックス 0] パラメータで指定した文字とこの文字に最も似ている [image] データ構造体内の文字の一致得点の差が 10% 未満ならば、データ構造体内のこの文字を返します。
得点 | GetScore(テキスト, インデックス 0, [インデックス 1]) | 参照されている [image] データ構造体のインデックス付き文字の一致得点 (0 ～ 100) を返します。オプションの [インデックス 1] パラメータが 1 の場合、[インデックス 0] パラメータで指定した文字とこの文字に最も似ている [image] データ構造体内の文字の一致得点の差が 10% 未満ならば、データ構造体内のこの文字の一致得点を返します。
合格 | GetPassed(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の合格/不合格ステータスを返します。[インデックス] パラメータが指定されていない場合は、文字列全体の合格/不合格ステータスを返します。

次のテキストデータアクセス関数を使用して、そのほかのデータの取得ができます。

角度 | GetAngle(テキスト) | データ構造体のテキスト文字列と [image] データ構造体の水平軸の間の角度を返します。
列 | GetCol(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の列座標 (ピクセル単位) を返します。
コントラスト | GetContrast(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の前景と背景のコントラスト (グレースケール階調で、0 ～ 255) を返します。
高さ | GetHigh(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の高さ (ピクセル単位) を返します。
行 | GetRow(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の行座標 (ピクセル単位) を返します。
幅 | GetWide(テキスト, インデックス) | 参照されている [image] データ構造体のインデックス付き文字の幅 （ピクセル単位） を返します。

関連項目

  • 文字照合/認識ツールについて
  • 新しいフォントの登録
  • 文字照合/認識 (テキスト) データアクセス関数
  • プロパティシートの使用方法


パターンマッチ関数

ビジョンツール

In-Sight 関数リファレンス

In-Sightパターンマッチ関数登録されているパターンと最大の類似性を示す入力画像内の特徴を探します。この種のパターンマッチングは、「テンプレートマッチング」とも言います。このパターンマッチ関数ツールには次の関数があります。

PatMax RedLine™

PatMax® より最大 7 倍の早さで、5 メガピクセルの画像から登録された特徴を検出することができる、最新のパターンマッチングツールです。高解像度 In-Sight ビジョンシステムに適しています。

注: 次の関数は、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

  • FindPatMaxRedLine 関数: PatMax RedLine アルゴリズムを使用して、登録されたパターンとの一致を検出します。
  • TrainPatMaxRedline 関数: PatMax RedLine アルゴリズムを使用して、グレースケール画像からパターンを抽出して登録します。

PatMax RedLine Color

24 ビットカラー画像に登録されているカラーの特徴を、グレースケールに変換せずに探すことができる、唯一のカラーパターンマッチングツールです。

注:TrainPatMaxRedLineColor 関数と FindPatMaxRedLineColor 関数は、In-Sight ファームウェア 5.6.0 以上を実行している In-Sight 7000 Gen2 シリーズのカラービジョンシステムおよび In-Sight 8000 シリーズのカラービジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • FindPatMaxRedLineColor 関数: PatMax RedLine Color アルゴリズムを使用して、登録されているカラーパターンとのマッチを検出します。
  • TrainPatMaxRedLineColor 関数: PatMax RedLine Color アルゴリズムを使用して、カラー画像からカラーパターンを抽出して登録します。

PatMax®

特徴ベースの表現を使用する、高速かつ高精度のパターンマッチングツールです。

  • FindPatMaxPatterns 関数: PatMax アルゴリズムを使用して、登録されたパターンとのマッチを検出します。
  • TrainPatMaxPattern 関数: PatMax アルゴリズムを使用して、画像からパターンを抽出して登録します。

PatFind®

ピクセルグリッド表現に基づいた、パターンマッチングツールです。

  • FindPatterns 関数: グレースケールパターンの登録と配置を行います。
  • SortPatterns 関数: パターンマッチの位置をソートします。

パターン検出について

パターン検出では、採用された類似性測定基準の本質に応じて、特性の範囲を示すことができますが、基本概念は、程度の差はあっても実装に関係なく同じです。

パターン検出プロセスは、2 つのフェーズで構成されています。「登録」と「検出」です。登録フェーズでは、配置するパターンのサンプルを含んでいる領域を手動で特定して抽出し、登録パターンを作成します。検出フェーズでは、システムに提示された新しい画像で、指定した測定基準に従って最大の類似性を示す位置をサーチします。これらローカルのマッチ位置は降順の類似性でソートされ、指定した類似性の最低レベルを超える最高の反応が報告されます。

グレースケールとカラーの PatMax RedLine 関数

エッジ検出

TrainPatMaxRedLine および FindPatMaxRedLine 関数は、グレースケール画像上でのみ動作します。これらの関数がパターン抽出を実行すると、画像はグレースケール画像に変換されます。このプロセスでは、RBG 値の多数の組み合わせが同じグレースケールレベルに変換されることがあるため、エッジの特徴が一部消失することがあります。一方で、TrainPatMaxRedLineColor および FindPatMaxRedLineColor 関数は、変換を行わずに直接カラー画像を処理するので、多くの場合、より良好にエッジの特徴を検出します。

元の画像 (青い背景に赤いテキスト)
TrainPatMaxRedLine 関数 | TrainPatMaxRedLineColor 関数

上記の画像は、カラー画像をグレースケール画像に変換した後、エッジの特徴を完全に検出できなくなった極端な例を示しています (グレーのボックスは、登録時に PatMax RedLine 関数が表示しているものです)。この場合、グレースケール画像でエッジを検出することができないので、TrainPatMaxRedLine 関数は登録に失敗します。一方で、TrainPatMaxRedLineColor 関数は、問題なくエッジの特徴を検出し、特徴を正常に登録します。

注: PatMax RedLine Color 関数はグレースケール入力画像上では動作しません。この場合、このツールは #ERR を返します。グレースケールを適用するには、TrainPatMaxRedLine および FindPatMaxRedLine 関数を使用し続ける必要があります。

カラーマッチング

PatMax RedLine 関数の既存の機能 (例えば、回転、スケール、および XY のオーバーラップなどの許容) に加えて、PatMax RedLine Color の関数は、カラーを使用して最適一致を検出します。

PatMax RedLine Color | PatMax RedLine
グレーの背景で青いパーツを検出 | グレースケール画像でパターンを検出
任意の背景で青いパーツを検出 |
任意の背景で任意のカラーのマッチング形状をすべて検出 |


FindPatMaxPatterns 関数

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

登録されたパターンに基づいて、検出しようとする対象物の登録済み (内部) 幾何学記述 画像内の対象物を検出します。。FindPatMaxPatterns 関数 [image] 構造体から登録されたパターンに基づいて、画像内のパターンを検出します。

  • FindPatMaxPatterns の入力パラメータ
  • FindPatMaxPatterns の出力
  • FindPatMaxPatterns データアクセス関数
  • 関連項目

FindPatMaxPatterns 関数の入力パラメータ

FindPatMaxPatterns 関数 (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

サーチ領域.X,

サーチ領域.Y,

サーチ領域.高さ,

サーチ領域.幅,

サーチ領域.角度,

サーチ領域.カーブ,

外部領域,

パターン,

検出する数,

アクセプト,

コントラスト,

クラッタ,

領域外の特徴,

許容値.開始角度,

許容値.終了角度,

許容値.開始スケール,

許容値.終了スケール,

許容値.アスペクトレシオ,

許容値.開始アスペクト,

許容値.終了アスペクト,

オーバラップ設定.XY オーバラップ,

オーバラップ設定.角度オーバラップ,

オーバラップ設定.スケールオーバラップ,

オーバラップ設定.アスペクトオーバラップ,

タイムアウト,

アルゴリズム,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連するサーチ領域を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

サーチ領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

外部領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:

  • このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。
  • 高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。

パターン

このパラメータは、TrainPatMaxPattern 関数によって返される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

検出する数

返される一致したパターンの最大数を指定します (1 ～ 1024、デフォルト = 1)。

アクセプト

有効なインスタンスの最も低い得点である、アクセプトしきい値を指定します。一致する可能性がある得点は、アクセプトしきい値よりも大きな値である必要があります。得点がアクセプトしきい値よりも大きな値でない場合は、その一致した得点は返されません　(0 ～ 100、デフォルト = 50)。

コントラスト

有効なインスタンスの最も低いコントラストを指定します。一致する可能性があるコントラストは、コントラストしきい値よりも大きな値である必要があります。コントラストがコントラストしきい値よりも大きな値でない場合は、その一致したインスタンスは考慮されません (0 ～ 255、デフォルト = 10)。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

クラッタ

欠落している、またはふさがれているパターン特徴によって、レスポンス得点が減少するかどうかを指定します。

0 = OFF | クラッタの影響を得点に含めません。
1 = ON (デフォルト) | クラッタの影響を得点に含めます。

領域外の特徴

パターンレスポンス得点を劣化させることなく、サーチ領域の外側で検出可能なパターン特徴の割合 (%) を指定します　(0 ～ 100、デフォルト = 0)。

許容値

登録されたパターンに対して回転またはスケーリングされたパターンを検出するための設定を指定します。

開始角度

一致度のサーチを開始する角度を、半時計回りの度の単位で指定します　(-180 ～ 180、デフォルト = -15)。

終了角度

一致度のサーチを停止する角度を、半時計回りの度の単位で指定します　(-180 ～ 180、デフォルト = 15)。

開始スケール

一致度のサーチを開始するスケールを指定します　(1 ～ 10000、デフォルト = 100)。

終了スケール

一致度のサーチを停止するスケールを指定します (1 ～ 10000、デフォルト = 100)。

アスペクトレシオ

一致度検出を、均一スケールのみに制限するか、または均一スケールに加えて、X または Y のアスペクトレシオの変化を許容します。

注意: 開始アスペクトおよび終了アスペクトパラメータは、[均一なスケール変化] が選択されている場合は無効になります。

0 = 均一なスケール変化

1 = 均一および X のスケール変化

2 = 均一および Y のスケール変化

開始アスペクト

一致度のサーチを開始する最小スケール変化を、登録されたパターンの割合 (%) で指定します　(1 ～ 10000、デフォルト = 100)。

終了アスペクト

一致度のサーチを停止する最大スケール変化を、登録されたパターンの割合 (%) で指定します　(1 ～ 10000、デフォルト = 100)。

オーバラップ設定

相互にするパターンを検出する設定を、位置、回転、およびスケールに関して指定します。

XY オーバラップ

おおよそ同じ X、Y 位置にある、複数のしているパターン間の予想される位置の差を、登録されたパターンのサイズの割合 (%) で指定します　(0 ～ 100、デフォルト = 80)。

注: この値を高くすることによって、同じパターンが複数オーバラップしている一致部分を検出することができます。

角度オーバラップ

おおよそ同じ X、Y 位置にある、複数の回転されてオーバラップしているパターン間の予想される角度を指定します (0 ～ 360、デフォルト = 360)。

注:

  • 角度オーバラップパラメータは、開始角度および終了角度パラメータが同じ値である場合は、無効になります。
  • この値を高くすることによって、同じパターンが複数オーバラップしている一致部分を検出することができます。

スケールオーバラップ

おおよそ同じ X、Y 位置にある、複数のしているパターン間の予想される均一スケールの差を、登録されたパターンのサイズの割合 (%) で指定します　(1 ～ 10000、デフォルト = 140)。

注:

  • スケールオーバラップパラメータは、開始スケールおよび終了スケールパラメータが同じ値である場合は、無効になります。
  • この値を高くすることによって、同じパターンが複数オーバラップしている一致部分を検出することができます。

アスペクトオーバラップ

おおよそ同じ X、Y 位置にある、複数のしているパターン間の、予想されるアスペクトスケールの差を、登録されたパターンのサイズの割合 (%) で指定します　(1 ～ 10000、デフォルト = 140)。

注:

  • アスペクトオーバラップパラメータは、アスペクトレシオパラメータで均一なスケール変化が選択されている場合、または開始アスペクトおよび終了アスペクトパラメータの値が等しい場合は、無効になります。
  • この値を高くすることによって、同じパターンが複数オーバラップしている一致部分を検出することができます。

タイムアウト

この関数によるパターンのサーチ時間をミリ秒単位で指定します (0 ～ 30000)。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。
アルゴリズム

登録されたパターンに対して画像を処理するために使用されるアルゴリズムを指定します。

0 = PatMax | PatMax アルゴリズムは、PatQuick よりも高い精度を提供しますが、実行に要する時間はより長くなります。
1 = PatQuick | PatQuick アルゴリズムは、PatMax よりも精度は劣りますが、実行に要する時間は短縮されます。
2 = 登録されたパターン (デフォルト) | FindPatMaxPatterns 関数は、[パターン] パラメータで参照される TrainPatMaxPattern 関数の [アルゴリズム] パラメータに指定されたアルゴリズム (PatMax または PatQuick) を使用します。

表示

画像上のグラフィックスオーバーレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、FindPatMaxPatterns 関数すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 検出された各パターンに対して十字マークが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と検出された各パターンに対する十字マークは両方とも常に表示されます。
3 = すべて表示: 入力、結果、および一致特徴 | 入力画像領域、検出された各パターンに対する十字マーク、および PatMax 一致特徴が常に表示されます。 注: TrainPatMaxPattern 関数のアルゴリズムパラメータに対して PatQuick が選択されている場合は、一致特徴は表示されません。 緑の一致特徴 = 67 ～ 100 パーセントの一致 黄色の一致特徴 = 20 ～ 66 パーセントの一致 赤の一致特徴 = 20 パーセント未満の一致

FindPatMaxPatterns 関数の出力

戻り値

得点によってソートされたモデルとパターンレスポンスのリストを含む [image] データ構造体。入力パラメータが無効である場合、または一致パターンが検出されない場合は #ERR を返します。

結果

初めてFindPatMaxPatterns 関数セルに挿入すると、スプレッドシートに結果テーブルが作成されます

注: この関数のプロパティシートには、パターンを検出し易くするためのヒントとして、補助的な情報文字列が表示されます。表示される可能性のある情報文字列については、 Closed ここをクリックしてください。

  • [値] 低コントラストのために破棄された結果。
  • [値] より正確な結果を得るために破棄された結果。
  • [値] クラッタが多すぎるために破棄された結果。
  • 現在のパラメータ設定に対して、登録パターンに含まれる特徴が少なすぎます。

スプレッドシートに情報文字列を挿入するには、GetInfoString データアクセス関数を使用します。

FindPatMaxPatterns 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(パターン, インデックス) | パターン位置の行座標
列 | GetCol(パターン, インデックス) | パターン位置の列座標
角度 | GetAngle(パターン, インデックス) | パターン位置の角度
スケール | GetScale(パターン, インデックス) | 登録されたモデルと比較したパターンのサイズ (モデルサイズのパーセントで表示)
得点 | GetScore(パターン, インデックス) | パターンのレスポンス得点

関連項目

  • パターンマッチングツールについて
  • パターンデータアクセス関数
  • TrainPatMaxPattern 関数
  • プロパティシートの使用方法


FindPatMaxRedLine

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

登録されたパターンに基づいて、検出する対象物の登録済み (内部) 幾何学記述。 画像内の対象物を検出します。FindPatMaxRedLine [image] 構造体から登録されたパターンに基づいて、画像内のパターンを検出します。

注:
  • In-Sight ファームウェア 5.5.0 以降、この関数のアルゴリズムは、より正確な結果を返すように変更されており、一部の環境の実行時間を短縮します。
  • この変更により、In-Sight ファームウェア 5.5.0 以上で設定されたこの関数を含んだジョブを、ファームウェアバージョン 5.4.x 以前を実行する In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示され、この関数を含んだセルは #ERR の結果になります。
  • この関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • FindPatMaxRedLines の入力パラメータ
  • FindPatMaxRedLines の出力
  • FindPatMaxRedLines データアクセス関数
  • 関連項目

FindPatMaxRedLineの入力パラメータ

FindPatMaxRedLine(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

サーチ領域.X,

サーチ領域.Y,

サーチ領域.高さ,

サーチ領域.幅,

サーチ領域.角度,

サーチ領域.カーブ,

外部定義領域,

パターン,

検出する数,

アクセプトしきい値,

極性を無視,

精度モード,

クラッタ,

コントラストしきい値,

許容値.開始角度,

許容値.終了角度,

許容値.開始スケール,

許容値.終了スケール,

XY のオーバーラップ,

詳細設定.粗粒度パーセンテージの使用,

詳細設定.粗粒度アクセプトパーセンテージ,

タイムアウト,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連するサーチ領域を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

サーチ領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ (デフォルト = 320) | 領域の X 軸に沿った寸法。
幅 (デフォルト = 440) | 領域の Y 軸に沿った寸法。
角度 (デフォルト = 0) | フィクスチャ座標での角度。
カーブ (デフォルト = 0) | 領域の X 軸と反対側の境界線との間の角度変位。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、EditRegion、または Mask を含んだスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

パターン

このパラメータは、TrainPatMaxRedLine 関数によって返される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

検出する数

返される一致したパターンの最大数を指定します (1 ～ 1000、デフォルト = 1)。

アクセプトしきい値

有効なインスタンスの最も低い得点である、アクセプトしきい値を指定します。一致する可能性がある得点は、アクセプトしきい値よりも大きな値である必要があります。得点がアクセプトしきい値よりも大きな値でない場合は、その一致した得点は返されません　(0 ～ 100、デフォルト = 50)。

極性を無視

登録パターンに対して、色が反転した一致特徴を含む一致を検出可能かどうかを指定します。

0 = OFF (デフォルト) | 色が反転した特徴は一致しません。
1 = ON | 逆の極性に一致するエッジを考慮します。

極性を無視すると、PatMax が検出するパターンの種類が増加します。下記の図は、一致する極性とミスマッチの極性の例を示しています。PatMaxRedLine 関数で極性を無視するように設定した場合、図に示されているすべてのパターンが検出されます。PatMaxRedLine 関数で極性を考慮するように設定した場合は、下の行のパターンは検出されないことがあります。または、検出されても、上の行のパターンよりも低い得点が割り当てられる場合があります。

精度モード

精度/信頼性と実行速度の間のトレードオフを指定します。

0 = 低 | 精度/信頼性が低くなり、実行速度が速くなるように指定します。
1 = 高 (デフォルト) | 精度/信頼性が高くなり、実行速度が遅くなるように指定します。

クラッタ

欠落している、またはふさがれているパターン特徴によって、レスポンス得点が減少するかどうかを指定します。

0 = OFF (デフォルト) | クラッタの影響を得点に含めません。
1 = ON | クラッタの影響を得点に含めます。

コントラストしきい値

有効なインスタンスの最も低いコントラストを指定します。一致する可能性があるコントラストは、コントラストしきい値よりも大きな値である必要があります。コントラストがコントラストしきい値よりも大きな値でない場合は、その一致したインスタンスは考慮されません (0 ～ 100、デフォルト = 0)。FindPatMaxRedLineColor と FindPatMaxRedLine のコントラスト値は、登録パターン内の特徴とサーチ画像内の一致する特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ～100 となります。パターンコントラストが特徴のコントラストを超えた場合、報告されるコントラストは <100 となります。

注: FindPatMaxRedLineColor と FindPatMaxRedLine のコントラストは、FindPatMaxPatterns のコントラストとは異なります。FindPatMaxPatterns では、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。

許容値

登録されたパターンに対して回転またはスケーリングされたパターンを検出するための設定を指定します。

注: [許容値] はハードリミットです。つまり、指定した [許容値] の範囲外で検出された結果は、スプレッドシートには返されません。

開始角度 | 一致度のサーチを開始する角度を、半時計回りの度の単位で指定します (-180 ～ 180、デフォルト = -15)。
終了角度 | 一致度のサーチを停止する角度を、半時計回りの度の単位で指定します (-180 ～ 180、デフォルト = 15)。
開始スケール | 一致度のサーチを開始するスケールを指定します (1 ～ 10000、デフォルト = 100)。
終了スケール | 一致度のサーチを停止するスケールを指定します (1 ～ 10000、デフォルト = 100)。

XY のオーバーラップ

おおよそ同じ X、Y 位置にある、複数のオーバーラップしているパターン間の予想される位置の差を、登録されたパターンのサイズの割合 (%) で指定します　(0 ～ 100、デフォルト = 70)。

注: この値を高くすることによって、同じパターンが複数オーバーラップしている一致部分を検出することができます。

詳細設定

粗粒度パーセンテージの使用

粗粒度サーチフェーズで [粗粒度アクセプトパーセンテージ] の値を使用するよう設定するかどうかを指定します。

注: ほとんどの場合、この設定を有効にする必要はありません。

0 = OFF (デフォルト) | 粗粒度サーチフェーズで [アクセプトしきい値] の値のみが使用されます ([粗粒度アクセプトパーセンテージ] の値は無視されます)。
1 = ON | [粗粒度アクセプトパーセンテージ] パラメータを有効にして [アクセプトしきい値] の値からの偏差をパーセンテージで指定し、これを粗粒度サーチフェーズで使用します。

粗粒度アクセプトパーセンテージ

[アクセプトしきい値] の値からの偏差をパーセンテージで指定し、これを粗粒度サーチフェーズで使用します (0 ～ 100、デフォルト = 60)。[アクセプトしきい値] の値でインスタンスを効率的に絞り込めず、この関数がマッチを返さないか、または返されるマッチが多すぎる場合に、このパラメータが有用です。

Closed [粗粒度アクセプトパーセンテージ] の機能

FindPatMaxRedLine 関数は、最初に大きな特徴を使用して実行時の画像内で大まかなパターンマッチを検出し (粗粒度サーチフェーズ)、次に小さな特徴を使用してパターン位置を正確に判定します (微粒度サーチフェーズ)。両方のフェーズで、[アクセプトしきい値] の値を使用して検出されたインスタンスを絞り込みます。

正常フロー ([粗粒度パーセンテージの使用] = オフ)

めったにないことですが、粗粒度サーチフェーズで低い得点のインスタンスしか検出されなかったために、FindPatMaxRedLine 関数がマッチを返さないことがあります。この場合には、[アクセプトしきい値] の設定値を低くできますが、[アクセプトしきい値] の値を低くすると、返されるマッチが多すぎることがあります。

マッチを返さない、または返されるマッチが多すぎる
([粗粒度パーセンテージの使用] = オフ)

このような場合は、([粗粒度アクセプトパーセンテージ] 設定でアクセプトしきい値を粗粒度サーチフェーズ用に定義することができます。各サーチフェーズで異なるアクセプトしきい値を使用することによって、想定される結果が返されるようにすることができます。

想定される結果を返す ([粗粒度パーセンテージの使用] = オン)

タイムアウト

関数がパターンをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 5000、タイムアウトの無効化)。この時間が経過すると、処理は中止され、#ERR が返されます。

表示

画像上のグラフィックスオーバーレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でアクティブである場合を除き、FindPatMaxRedLineすべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 検出された各パターンに対して十字マークが常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と検出された各パターンに対する十字マークは両方とも常に表示されます。
3 = すべて表示: 入力、結果、および一致特徴 | 入力画像領域、検出された各パターンに対する十字マーク、および PatMax RedLine 一致特徴が常に表示されます。

FindPatMaxRedLine出力

戻り値 | 得点によってソートされたモデルとパターンレスポンスのリストを含む [image] データ構造体。入力パラメータが無効である場合、または一致パターンが検出されない場合は #ERR を返します。
結果 | 初めてFindPatMaxRedLineセルに挿入すると、スプレッドシートに結果テーブルが作成されます

FindPatMaxRedLineデータアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(パターン, インデックス) | パターン位置の行座標
列 | GetCol(パターン, インデックス) | パターン位置の列座標
角度 | GetAngle(パターン, インデックス) | パターン位置の角度
スケール | GetScale(パターン, インデックス) | 登録されたモデルと比較したパターンのサイズ (モデルサイズのパーセントで表示)
得点 | GetScore(パターン, インデックス) | パターンのレスポンス得点

関連項目

  • パターンマッチングツールについて
  • パターンデータアクセス関数
  • TrainPatMaxRedLine
  • プロパティシートの使用方法
Version: 5.6.0


FindPatMaxRedLineColor

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

登録されたパターンに基づいて、検出する対象物の登録済み (内部) 幾何学記述。 カラー画像内の対象物を検出します。FindPatMaxRedLineColor TrainPatMaxRedLineColor 関数の [image] 構造体から登録されたパターンに基づいて、カラー画像内のパターンを検出します。

注:

  • TrainPatMaxRedLineColor 関数と FindPatMaxRedLineColor 関数は、In-Sight ファームウェア 5.6.0 以上を実行している In-Sight 7000 Gen2 シリーズのカラービジョンシステムおよび In-Sight 8000 シリーズのカラービジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • グレースケール画像を使用する場合は、TrainPatMaxRedLine 関数と FindPatMaxRedLine 関数を使用する必要があります。グレースケール画像 (ColorToGreyscaleFilter の出力など) に対して TrainPatMaxRedLineColor 関数と FindPatMaxRedLineColor 関数を使用しようとすると、#ERR が返されます。
  • FindPatMaxRedLineColor 関数は TrainPatMaxRedLineColor 関数を参照する必要があります。別の関数 (TrainPatMaxRedLine 関数など) を参照すると、#ERR が返されます。
  • FindPatMaxRedLinesColor の入力パラメータ
  • FindPatMaxRedLinesColor の出力
  • FindPatMaxRedLinesColor データアクセス関数
  • パターンの得点とカラー得点
  • 関連項目

FindPatMaxRedLineColorの入力パラメータ

FindPatMaxRedLineColor(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

サーチ領域.X,

サーチ領域.Y,

サーチ領域.高さ,

サーチ領域.幅,

サーチ領域.角度,

サーチ領域.カーブ,

外部定義領域,

パターン,

検出する数,

アクセプトしきい値、パターン,

アクセプトしきい値、カラー,

精度モード,

クラッタ,

コントラストしきい値,

許容値.開始角度,

許容値.終了角度,

許容値.開始スケール,

許容値.終了スケール,

XY のオーバーラップ,

詳細設定.粗粒度パーセンテージの使用,

詳細設定.粗粒度アクセプトパーセンテージ,

タイムアウト,

グラフィックス表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

注: このパラメータはカラー画像を参照している必要があります。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連するサーチ領域を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

サーチ領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ (デフォルト = 320) | 領域の X 軸に沿った寸法。
幅 (デフォルト = 440) | 領域の Y 軸に沿った寸法。
角度 (デフォルト = 0) | フィクスチャ座標での角度。
カーブ (デフォルト = 0) | 領域の X 軸と反対側の境界線との間の角度変位。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、EditRegion、または Mask を含んだスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

パターン

このパラメータは、TrainPatMaxRedLineColor 関数によって返される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

検出する数

返される一致したパターンの最大数を指定します (1 ～ 1000、デフォルト = 1)。

アクセプトしきい値、パターン

有効なインスタンスの最も低い得点である、パターンのアクセプトしきい値を指定します。一致する可能性がある得点は、アクセプトしきい値よりも大きな値である必要があります。得点がアクセプトしきい値よりも大きな値でない場合は、その一致した得点は返されません　(0 ～ 100、デフォルト = 50)。

アクセプトしきい値、カラー

有効なインスタンスの最も低い得点である、カラーのアクセプトしきい値を指定します。一致する可能性がある得点は、アクセプトしきい値よりも大きな値である必要があります。得点がアクセプトしきい値よりも大きな値でない場合は、その一致した得点は返されません　(0 ～ 100、デフォルト = 85)。

照明に対する許容

これを有効にすると、照明の違いによって生じるカラーの変化で許容値が大きくなります。

注: TrainPatMaxRedLineColor 関数の [マッチカラー] パラメータが [マッチなし] に設定されている場合、このパラメータは無効になります。

0 = OFF (デフォルト)

1 = ON

Closed 照明に対する許容の例

カラーマッチは、非均一な照明および制御できない照明の変化の影響を受けやすくなっています。[照明に対する許容] パラメータを有効にすると、色の得点が照明のために登録されている色と異なる場合に、色の得点がより高くなります。つまり、同じ色か、わずかに暗い、または明るい色になります。

例えば、カプセル薬のパッケージで、照明は均一ではありません。左上隅にあるカプセル薬は、中央にあるカプセル薬より暗くなっています。

左上のカプセル薬を登録する場合、[照明に対する許容] オプションを有効にしないと、中央近くのカプセル薬は得点が低くなります。このパラメータを有効にすると、得点が増加してより多くのマッチが検出されます。

照明に対する許容 = オフ | 照明に対する許容 = オン

精度モード

精度/信頼性と実行速度の間のトレードオフを指定します。

0 = 低 | 精度/信頼性が低くなり、実行速度が速くなるように指定します。
1 = 高 (デフォルト) | 精度/信頼性が高くなり、実行速度が遅くなるように指定します。

クラッタ

欠落している、またはふさがれているパターン特徴によって、レスポンス得点が減少するかどうかを指定します。

0 = OFF (デフォルト) | クラッタの影響を得点に含めません。
1 = ON | クラッタの影響を得点に含めます。

コントラストしきい値

有効なインスタンスの最も低いコントラストを指定します。一致する可能性があるコントラストは、コントラストしきい値よりも大きな値である必要があります。コントラストがコントラストしきい値よりも大きな値でない場合は、その一致したインスタンスは考慮されません (0 ～ 100、デフォルト = 0)。FindPatMaxRedLineColor と FindPatMaxRedLine のコントラスト値は、登録パターン内の特徴とサーチ画像内の一致する特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ～100 となります。パターンコントラストが特徴のコントラストを超えた場合、報告されるコントラストは <100 となります。

注: FindPatMaxRedLineColor と FindPatMaxRedLine のコントラストは、FindPatMaxPatterns のコントラストとは異なります。FindPatMaxPatterns では、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。

許容値

登録されたパターンに対して回転またはスケーリングされたパターンを検出するための設定を指定します。

注: 許容値がハードリミットの場合、つまり、指定の許容値外で見つかった結果はスプレッドシートに返されません。

開始角度 | 一致度のサーチを開始する角度を、半時計回りの度の単位で指定します (-180 ～ 180、デフォルト = -15)。
終了角度 | 一致度のサーチを停止する角度を、半時計回りの度の単位で指定します (-180 ～ 180、デフォルト = 15)。
開始スケール | 一致度のサーチを開始するスケールを指定します (1 ～ 10000、デフォルト = 100)。
終了スケール | 一致度のサーチを停止するスケールを指定します (1 ～ 10000、デフォルト = 100)。

XY のオーバーラップ

おおよそ同じ X、Y 位置にある、複数のオーバーラップしているパターン間の予想される位置の差を、登録されたパターンのサイズの割合 (%) で指定します　(0 ～ 100、デフォルト = 70)。

注: この値を高くすることによって、同じパターンが複数オーバーラップしている一致部分を検出することができます。

詳細設定

粗粒度パーセンテージの使用

粗粒度サーチフェーズで [粗粒度アクセプトパーセンテージ] の値を使用するよう設定するかどうかを指定します。

注: ほとんどの場合、この設定を有効にする必要はありません。

0 = OFF (デフォルト) | 粗粒度サーチフェーズでは、[アクセプトしきい値、パターン] の値のみが使用されます ([粗粒度アクセプトパーセンテージ] の値は無視されます)。
1 = ON | [粗粒度アクセプトパーセンテージ] パラメータを有効にして [アクセプトしきい値、パターン] の値からの偏差をパーセンテージで指定し、これを粗粒度サーチフェーズで使用します。

粗粒度アクセプトパーセンテージ

[アクセプトしきい値、パターン] の値からの偏差をパーセンテージで指定し、これを粗粒度サーチフェーズで使用します (0 ～ 100、デフォルト = 60)。[アクセプトしきい値] の値でインスタンスを効率的に絞り込めず、この関数がマッチを返さないか、または返されるマッチが多すぎる場合に、このパラメータが有用です。

Closed [粗粒度アクセプトパーセンテージ] の機能

FindPatMaxRedLineColor 関数は、最初に大きな特徴を使用して実行時の画像内で大まかなパターンマッチを検出し (粗粒度サーチフェーズ)、次に小さな特徴を使用してパターン位置を正確に判定します (微粒度サーチフェーズ)。両方のフェーズで、[アクセプトしきい値、パターン] の値を使用して検出されたインスタンスを絞り込みます。

正常フロー ([粗粒度パーセンテージの使用] = オフ)

めったにないことですが、粗粒度サーチフェーズで低い得点のインスタンスしか検出されなかったために、FindPatMaxRedLineColor 関数がマッチを返さないことがあります。この場合には、[アクセプトしきい値、パターン] の設定値を低くできますが、[アクセプトしきい値、パターン] の値を低くすると、返されるマッチが多すぎることがあります。

マッチを返さない、または返されるマッチが多すぎる
([粗粒度パーセンテージの使用] = オフ)

このような場合は、([粗粒度アクセプトパーセンテージ] 設定でアクセプトしきい値を粗粒度サーチフェーズ用に定義することができます。各サーチフェーズで異なるアクセプタントしきい値のパターンを使用することによって、想定される結果が返されるようにすることができます。

想定される結果を返す ([粗粒度パーセンテージの使用] = オン)

タイムアウト

関数がパターンをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 5000、タイムアウトの無効化)。この時間が経過すると、処理は中止され、#ERR が返されます。

グラフィックス表示

画像上のグラフィックスオーバーレイの表示モードを指定します。

サーチ領域

[サーチ領域] が常に表示されます。

0 = OFF (デフォルト)

1 = ON

位置

パターンが検出された位置を示す十字線の図形が常に表示されます。

0 = OFF (デフォルト)

1 = ON

登録パターン

グラフィックスオーバーレイ

一致特徴

登録されているエッジの特徴が、常に緑の線で表示されます。

0 = OFF (デフォルト)

1 = ON

登録パターン

グラフィックスオーバーレイ

カラーマッチ

登録したマッチカラーをサンプル位置に表示します。サンプルは円で表示され、円のカラーおよび位置は登録カラーを示します。

注: TrainPatMaxRedLineColor 関数の [マッチカラー] パラメータが [マッチなし] に設定されている場合、このパラメータは無効になります。

0 = OFF (デフォルト)

1 = ON

登録パターン

グラフィックスオーバーレイ

FindPatMaxRedLineColor出力

戻り値 | 得点によってソートされたモデルとパターンレスポンスのリストを含む [image] データ構造体。入力パラメータが無効である場合、または一致パターンが検出されない場合は #ERR を返します。
結果 | 初めてFindPatMaxRedLineColorセルに挿入すると、スプレッドシートに結果テーブルが作成されます

FindPatMaxRedLineColorデータアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行

GetRow(パターン, インデックス)

パターン位置の行座標

列

GetCol(パターン, インデックス)

パターン位置の列座標

角度

GetAngle(パターン, インデックス)

パターン位置の角度

スケール

GetScale(パターン, インデックス)

登録されたモデルと比較したパターンのサイズ (モデルサイズのパーセントで表示)

得点

GetScore(パターン, インデックス)

パターンのレスポンス全体の得点 (0 ～ 100)

カラー得点

GetAngle(パターン, インデックス)

カラー得点の値 (0 ～ 100)

注: 参照先 TrainPatMaxRedLineColor の [カラーマッチ] パラメータが [マッチなし] に設定されている場合、GetColorScore 関数は 100.000 を返します。

[カラーマッチ] パラメータの選択項目 | 動作
0 = すべてのカラー (デフォルト) | ツールによって一致する特徴が検出されたことを前提に、計算されたスコアを返します。
1 = 選択カラー
2 = マッチなし | 100.000 を返します (ツールによって、カラーマッチスコアは計算されません)。

パターンの得点とカラー得点

FindPatMaxRedLineColor 関数によって 2 つの得点の値が自動的にスプレッドシートに挿入されます。[得点] と [カラー得点] です。[得点] は、「パターン」の得点を返し、検出されたパターンが登録されているパターンとどの程度似ているかを示します。これは色とは無関係です。[カラー得点] は、検出されたパターンの色が登録されている色とどの程度似ているかを示します。

[カラー得点] の値が低いと、[得点] の値には影響しません。次の例では、インデックスの 2 つのパターンが低い [カラー得点] を示していますが、[得点] の値は非常に高いままです。[得点] または [カラー得点] のいずれかが、その [アクセプトしきい値] ([アクセプトしきい値、パターン] または [アクセプトしきい値、カラー]) に該当する場合、このパターンはマッチとはみなされず、返されることはありません。

登録パターン

サーチ結果

関連項目

  • パターンマッチングツールについて
  • パターンデータアクセス関数
  • TrainPatMaxRedLineColor
  • プロパティシートの使用方法
Version: 5.6.0


FindPatterns 関数

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

FindPatterns 関数は 2 つの関数で構成されています。1 つはエリアベースまたはエッジベースのモデルパターンを抽出し、もう 1 つは、登録モデルを使ってサーチを実行します。

この関数によって登録する場合も検出する場合も、実行は、どのパラメータを更新したかによって決まります。どのモデルパラメータを更新してもモデルが返されます。画像、フィクスチャ、検索領域、またはほかのサーチパラメータを更新しても関数がサーチを開始します。

ヒント: 新しいモデルを誤って登録することを避けるには、2 つの個別の FindPatterns 関数を挿入します。1 つの関数はモデルの登録に使用し、無効にしておきます。もう 1 つの関数はパターンパラメータで最初の関数を参照してサーチします。

  • FindPatterns の入力パラメータ
  • FindPatterns の出力
  • FindPatterns データアクセス関数
  • 関連項目

FindPatterns 関数の入力パラメータ

FindPatterns 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

モデル領域.X ,

モデル領域.Y ,

モデル領域.高さ ,

モデル領域.幅 ,

モデル領域.角度 ,

モデル設定.モデルタイプ ,

モデル設定.粗さ ,

モデル設定.精度 ,

モデル設定.行オフセット ,

モデル設定.列オフセット ,

モデル設定.登録を強制 ,

モデル設定.パターン ,

サーチ領域.X ,

サーチ領域.Y ,

サーチ領域.高さ ,

サーチ領域.幅 ,

サーチ領域.角度 ,

検出する数 ,

角度範囲 ,

スケール許容 ,

しきい値: アクセプト ,

しきい値: コンフューズ ,

タイムアウト ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

モデルを定義して、フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を検出します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

モデル領域

モデルパターンの抽出に使用される矩形の画像領域を指定します。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

モデル設定

モデル登録パラメータを指定します。

モデルタイプ

エリアモデルまたはエッジモデル登録を指定します。

0 = エリアモデル | エリアモデル登録は、モデル領域からのグレースケールピクセル値の均一サンプリングに基づいてパターンを作成します。エリアモデルの類似性測定基準は、正規化されたグレースケール相関係数に基づいています。
1 = エッジモデル (デフォルト) | エッジモデル登録は、通常は対象物の境界線上で検出されるグレースケールの不連続に隣接するサンプリングポイントに基づいてパターンを作成します。エッジモデルの類似性測定基準は、正規化されたグレースケール相関に基づいています。 注: モデルを定義するために使用可能なポイントの最大数は 4096 です。

粗さ

登録されるモデルの最小の特徴のサイズを指定します。

0 = 高精度 | 最小の特徴のサイズは約 4 ピクセル
1 = 中程度 (デフォルト) | 最小の特徴のサイズは約 4 ～ 8 ピクセル
2 = 粗粒度 | 最小の特徴のサイズは約 8 ピクセル以上

精度

精度/信頼性と実行速度の間のトレードオフを指定します。

0 = 高精度 | 精度/信頼性が高くなり、実行速度が遅くなるように指定します。
1 = 中程度 (デフォルト) |
2 = 高速 | 精度/信頼性が低くなり、実行速度が速くなるように指定します。

行オフセット

モデルのローカル座標系で測定されたとおり、モデルの中心からレスポンスポイントへの行オフセットを指定します (-1199 ～ 1199、デフォルト = 0)。

列オフセット

モデルのローカル座標系で測定されたとおり、モデルの中心からレスポンスポイントへの列オフセットを指定します (-639 ～ 639、デフォルト = 0)。

登録を強制

スプレッドシート更新での自動モデル登録を有効または無効にします。登録を強制がオフであれば、モデル領域またはモデル設定が変更されたときにのみモデルが登録されます。ON の場合は、スプレッドシートが実行されるたびにモデルが再登録されます。

0 = OFF (デフォルト)
1 = ON

パターン

FindPatterns 関数が独自モデルを使用してサーチするか、別の FindPatterns 関数に含まれているモデルを使用してサーチするかを指定します。デフォルト値は 0 で、現在の FindPatterns 関数が独自のモデルを使用することを意味します。

また、パターンはほかの FindPatterns 関数によって登録されたローカルモデルをサーチに使用するように指定する [image] データ構造体も参照できます。この代替動作によって、スプレッドシート上の複数の PatFind サーチのインスタンスで 1 つのモデルを共有することが可能になります。

注: この動作はチェインしません。つまり、さらに別の PatFind モデルを参照している PatFind モデルを参照することはできません。

サーチ領域

パターンのサーチを実行する場所の定義に使用される、画像の領域を指定します。変換および回転が可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。

検出する数

返される一致したパターンの最大数を指定します (0 ～ 255、デフォルト = 1)。

注: 返すことができるパターンの最大数は 255 ですが、[モデル設定] パラメータがエッジモデルに設定されている場合は、そのほかの設定、特に [粗さ]、[精度]、および [スケール許容] によって、返されるパターン数は大幅に減少することがあります。より多くのパターンを検出する必要がある場合は、FindPatMaxPatterns 関数を使用することを推奨します。

角度範囲

パターンの回転に対する関数のプラス/マイナス方向の許容範囲を指定します (0 ～ 180、デフォルト = 15)。この関数は、指定された範囲外のパターンも検出しますが、精度が少し下がります。角度範囲を 0 より大きい値に設定すると、パターンを検出する速度が遅くなります。

スケール許容

パターンのスケール変化に対する関数の許容値を指定します。

0 = OFF (デフォルト) | スケール検索を無効にします。スケール検索が無効のときも、この関数は元のモデルサイズの約 ±10% の範囲内のパターンを検出しますが、不一致が増えるのでレスポンスが低下します。
1 = ON | スケール検索を有効にします。スケール検索が有効のとき、この関数は元のモデルサイズの ±10% の範囲で限定されたスケール調整を実行します。

しきい値: アクセプト

パターンレスポンスの最小一致得点を指定します (0 ～ 100、デフォルト = 50)。この関数は、アクセプトしきい値の制限を超えた、検出する数パターンのレスポンスを返します。

しきい値: コンフューズ

モデルの実際のインスタンスでない画像内パターンに対し、予測される最大パターンレスポンス得点を指定します (0 ～ 100、デフォルト = 70)。このサーチパラメータを設定すると、関数がどのパターンレスポンスを調査し、どのパターンを安全に無視できるかを知るのに有効です。このパラメータはコンフュージョンしきい値とも呼ばれます。

タイムアウト

この関数によるパターンのサーチ時間をミリ秒単位で指定します (0 ～ 30000、デフォルト = 5000)。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示

画像上の FindPatterns グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | FindPatterns 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 十字マークは、検出されたモデルのオフセット座標に常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と十字マークが常に表示されます。

FindPatterns 関数の出力

戻り値 | 得点によってソートされたモデルとパターンレスポンスのリストを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | FindPatterns 関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

FindPatterns 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(パターン, インデックス) | パターン位置の行座標
列 | GetCol(パターン, インデックス) | パターン位置の列座標
角度 | GetAngle(パターン, インデックス) | パターン位置の角度
スケール | GetScale(パターン, インデックス) | 登録されたモデルと比較したパターンのサイズ (モデルサイズのパーセントで表示)
得点 | GetScore(パターン, インデックス) | パターンのレスポンス得点

関連項目

  • パターンマッチングツールについて
  • パターンデータアクセス関数
  • プロパティシートの使用方法


SortPatterns 関数

SortPatterns 関数 |
ビジョンツール → パターンマッチ | In-Sight 関数リファレンス

画像内のパターンの位置でパターンをソートします。入力 [image] データ構造体内の各パターンについて、SortPatterns 関数は、指定された画像フィクスチャ座標系に対するパターンのレスポンスの位置を計算します。パターンは、X 座標、Y 座標、角度、角度絶対値、距離、またはグリッドのいずれか 1 つを基準にソートされます。ソートされたパターンは、新しい [image] データ構造体として返されます。

  • SortPatterns の入力パラメータ
  • SortPatterns の出力
  • SortPatterns データアクセス関数
  • 関連項目

SortPatterns 関数の入力パラメータ

SortPatterns 関数(

パターン ,

ソートする数 ,

ソート基準 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

ソート許容値 ,

表示

)

パターン

この引数は、FindPatMaxPatterns 関数または FindPatterns 関数によって返される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

ソートする数

ソートするパターンの最大数 (1 ～ 255、デフォルト = 1) を指定します。

ソート基準

ソートの方法を指定します。

0 = X (デフォルト) | x 軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。 Closed 例
1 = Y | y 軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。 Closed 例
2 = 角度 | フィクスチャ座標系の X 軸からパターンのレスポンス点とフィクスチャの原点により定義される線分までの角度 (0 ～ 360 度) を、距離の短いものから長いものの順 (降順) にソートします。 Closed 例
3 = 角度絶対値 | フィクスチャ座標系の x 軸からパターンのレスポンス点とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、距離の短いものから長いものの順 (降順) にソートします。 Closed 例
4 = 距離 | フィクスチャの原点からパターンのレスポンス点までの距離を、距離の短いものから長いものの順 (降順) にソートします。 Closed 例
5 = グリッド X | まず、フィクスチャの x 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に y 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。 注: SortPatterns 関数は、グリッド X が選択され、CalibrateImage 関数や TransPatternsToWorld 関数の出力などのワールド座標にキャリブレーションされた画像を関数が参照している場合には、#ERR を返します。グリッド X のソートは、ピクセル座標にのみ適用できます。ワールド座標を使用して [グリッド X] のソート方法を使用するには、SortPatterns 関数によって参照されている FindPatMaxPatterns 関数または FindPatterns 関数が、SortPatterns 関数によってピクセル座標でソートされた TransformImage 関数の出力を参照する必要があります。出力データは、その後、TransPatternsToWorld 関数を使用してワールド座標に変換できます。 Closed 例
6 = グリッド Y | まず、フィクスチャの y 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に x 軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。 注: SortPatterns 関数は、[グリッド Y] が選択され、CalibrateImage 関数や TransPatternsToWorld 関数の出力などのワールド座標にキャリブレーションされた画像を関数が参照している場合には、#ERR を返します。グリッド Y のソートは、ピクセル座標にのみ適用できます。ワールド座標を使用して [グリッド Y] のソート方法を使用するには、SortPatterns 関数によって参照されている FindPatMaxPatterns 関数または FindPatterns 関数が、SortPatterns 関数によってピクセル座標でソートされた TransformImage 関数の出力を参照する必要があります。出力データは、その後、TransPatternsToWorld 関数を使用してワールド座標に変換できます。 Closed 例

フィクスチャ

[フィクスチャ] 入力に対する参照パターンまたはビジョンツール関数の画像座標系の出力を定義します。フィクスチャに対する参照パターンを設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して参照されるパターンを確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット
角度 | 画像座標系での方位角

ソート許容値

グリッド X またはグリッド Y を使用してソートする場合に、検出されたパターンをパターングループに含むために必要な、登録パターン高さのサイズの割合 (%) (1% ～ 500%、デフォルト = 50%) を指定します。

注: このパラメータは [ソート基準] パラメータを [グリッド X] または [グリッド Y] のいずれかに設定した場合にのみ使用します。

表示

画像上の SortPatterns グラフィックスの表示モードを指定します。

0 = 非表示 (デフォルト) | SortPatterns 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 検出された各パターンに対して十字マークが常に表示されます。
3 = すべて表示: 入力、結果、および一致特徴 | 入力画像領域、検出された各パターンに対する十字マーク、および一致特徴が常に表示されます。 注: 一致特徴は、PatMax により登録されたパターンについてのみ表示されます。

SortPatterns 関数の出力

戻り値 | ソートされたパターンのレスポンス点を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | SortPatterns 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。 注: [ソートする数] パラメータの値が 0 より大きい場合、SortPatterns 関数は、 [image] データ構造体内の最初の 10 個のパターンに対応する最大 10 のエントリを含んでいる結果テーブルを自動的に挿入します。より多くのエントリを表示する場合は、最後の行をコピーし、追加の行を末尾に貼り付けることによりテーブルを拡張することができます。新しく貼り付けた行のインデックスの値を必ず繰り上げて、正しいパターンがインデックスされるようにしてください。

SortPatterns 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(パターン, インデックス) | パターン位置の行座標
列 | GetCol(パターン, インデックス) | パターン位置の列座標
角度 | GetAngle(パターン, インデックス) | パターン位置の角度
スケール | GetScale(パターン, インデックス) | 元のモデルに対するサイズの割合をパーセント単位で表したもの
得点 | GetScore(パターン, インデックス) | パターンのレスポンス得点

関連項目

  • パターンマッチングツールについて
  • パターンデータアクセス関数
  • プロパティシートの使用方法


TrainPatMaxPattern 関数

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

画像から検出するオブジェクトの登録済み (内部) 幾何学記述。 パターンを抽出して登録し、 FindPatMaxPatterns 関数で使用します。

  • TrainPatMaxPattern の概要
  • TrainPatMaxPattern の入力パラメータ
  • TrainPatMaxPattern の出力
  • TrainPatMaxPattern データアクセス関数
  • 関連項目

TrainPatMaxPattern 関数概要

PatMax® パターンは幾何図形特徴の集合です。ここで、各特徴は、ピクセル値が異なる 2 つの領域間の境界上の点です。TrainPatMaxPattern 関数TrainPatMaxPattern 関数でパターンを登録し、次に FindPatMaxPatterns 関数を使用して、画像内でそのパターンの 1 つ以上のインスタンスを検出します。PatMax は、マシンビジョンに利用可能なほかのパターン検出技術との差別化を図る、次の 3 つの重要な機能を提供します。

  • 外観が、回転、スケーリング、伸長された対象物の高速検出
  • 対象物のグレースケール値ではなく、形状に基づく検出技術
  • 非常に高い精度

PatMax がほかのパターン検出技術と異なる点は、回転またはスケーリングを効率的かつ高精度に行うことができないピクセルグリッド表現に基づいてはいないということです。その代わりに、PatMax では、パターンマッチングのための迅速かつ正確な変換が可能な特徴ベースの表現を使用します。

注: 登録済みの PatMax パターンを含むセルをハイライトすると、そのパターンの特徴が表示されます。これにより、このパターンを保持している TrainPatMaxPattern のプロパティシートを表示せずに、登録されているパターンを参照できます。

TrainPatMaxPattern 関数の入力パラメータ

TrainPatMaxPattern 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

パターン領域.X ,

パターン領域.Y ,

パターン領域.高さ ,

パターン領域.幅 ,

パターン領域.角度 ,

パターン領域.カーブ ,

外部定義領域 ,

パターン原点.行オフセット ,

パターン原点.列オフセット

パターン設定.アルゴリズム ,

パターン設定.融通性

パターン設定.極性を無視

パターン設定.感度

パターン設定.粗粒度

パターン設定.微粒度

登録画像の再使用

タイムアウト ,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

Row (デフォルト = 0) | 画像座標での行オフセット。
Column (デフォルト = 0) | 画像座標での列オフセット
Theta (デフォルト = 0) | 画像座標系での方位角

パターン領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、または EditRegion の各関数を含むスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:

  • このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。
  • 高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。

パターン原点

登録パターンの原点の行および列を、登録領域の中心からのオフセットとして指定します。

行オフセット | 登録パターンの中心からの行オフセットを指定します。
列オフセット | 登録パターンの中心からの列オフセットを指定します。

パターン設定

パターンの登録のための設定を指定します。

アルゴリズム

パターンの登録に使用するアルゴリズムを指定します。

0 = PatMax (デフォルト) | PatMax アルゴリズムは、PatQuick よりも高い精度を提供しますが、実行に要する時間はより長くなります。
1 = PatQuick | PatQuick アルゴリズムは、PatMax よりも精度は劣りますが、実行に要する時間は短縮されます。

融通性

周囲長の偏差の量を指定します (0 ～ 10、デフォルト = 0)。

0 = 許容しない

1 以上 = 柔軟な境界

極性を無視

登録パターンに対して、色が反転した一致特徴を含む一致を検出可能かどうかを指定します。

0 = OFF (デフォルト) | 色が反転した特徴は一致しません。
1 = ON | 色が反転した一致特徴を許容します。

感度

0 = 実装されていません

粗粒度

粗粒度をピクセル単位で指定します。粗粒度は、大きな特徴を検出して、画像内の大まかなパターン一致を実行時に迅速に検出するために使用されます (0 ～ 10、デフォルト = 0)。

注: 1.0 未満の値が指定された場合、[粗粒度] および [微粒度] の両方のパラメータ値が自動的に計算されます。

微粒度

微粒度をピクセル単位で指定します。微粒度は、小さな特徴を検出して、パターン位置を正確に判定するために使用されます (0 ～ 10、デフォルト = 0)。

注:

  • 1.0 未満の値が指定された場合、[粗粒度] および [微粒度] の両方のパラメータ値が自動的に計算されます。
  • 微粒度の値を粗粒度の値よりも大きくすることはできません。
登録画像の再使用

パターンを登録するために使用した画像を保存し、[パターン設定] パラメータが変更されたときに使用するかどうかを指定します。

0 = OFF (デフォルト)

現在の画像 ([画像] パラメータに指定された画像) がパターンの登録/再登録に使用されます。

1 = ON

1 つ以上の [パターンの設定] パラメータが変更された場合は、パターンを登録するために最初に使用された画像が、パターンの再登録に使用されます。最初に有効にした場合は、[画像] パラメータによって識別された画像がパターンの登録に使用され、画像のコピーがジョブに保存されます。それより後の [パターンの設定] パラメータへの変更は、格納された画像を使用して実行されます。

注:
  • ロードしているジョブがリリース 4.4.1 より前の In-Sight Explorer ファームウェアで作成されている場合、この機能を使用するには、パターンを In-Sight Explorer ファームウェア 4.4.1 以降で再登録する必要があります。古いリリースの In-Sight Explorer で登録されたパターンでこのパラメータが有効になっている場合、関数は #ERR を返します。このパラメータを使用するには、パターンを再登録する必要があります。
  • このパラメータが有効なときに、[フィクスチャ] 入力パラメータが変更され、[パターン領域] (または、[外部定義領域]) が移動または変更されると、関数は入力画像内の登録領域を調整し、新しい画像を保存して、パターンを再登録します。
  • [登録画像の再使用e] パラメータが On (有効) に変わったが、パターンがまだ登録されていない場合、パラメータが Off (無効) になり新しいパターンが登録されるまで、関数は #ERR を返します。

タイムアウト

関数が有効なパターンをサーチする時間をミリ秒単位で指定します (0 ～ 30000)。この時間が経過すると、処理は中止され、#ERR が返されます。値を 0 に設定すると設定値が無効になり、タイムアウトは適用されません。

表示

画像上のグラフィックスの表示モードをTrainPatMaxPattern 関数指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、TrainPatMaxPattern 関数グラフィックスは何も表示されません。
1 = 結果のグラフィックスのみ | 登録されたパターンの特徴が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域、パターンの原点、および登録された特徴が常に表示されます。 注: 登録された特徴の色 (緑、黄、赤) は、特徴の一致候補の品質を表しています。緑は品質が高いことを、赤は低いことを表します。すべての登録特徴が緑色になるまで粒度パラメータを調節する必要があります。または、より品質の高い画像を選択して、登録します。特徴 (エッジ) や画像コントラストがより明瞭であるほど高い結果が得られます。
3 = 全て表示: 入力、結果および登録画像 | 入力画像領域、パターンの原点、登録された特徴、および登録画像が常に表示されます。

TrainPatMaxPattern 関数の出力

戻り値

登録されたパターンを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。次の取り込みで新しいパターンを誤って登録することを避けるために、この関数はデフォルトで無効に設定されています。

結果

関数がTrainPatMaxPattern 関数初めてセルに挿入されると、登録状態が右隣のセルに自動的に表示されます。パターンを登録できない場合は #ERR が挿入されます。

注: この関数のプロパティシートには、パターンを登録し易くするためのヒントとして、補助的な情報文字列が表示されます。表示される可能性のある情報文字列については、 Closed ここをクリックしてください。

  • パターンに含まれるマッチ特徴が少なすぎることがあります。
  • 特徴の粒度を自動的に設定するのは困難です。
  • 手動で [粒度] を設定してください。登録画像の表示がぼやけているので、パターンが予想より正確でないことがあります。
  • 疎粒度の特徴が同じ方向であるために、パターン結果が不安定になることがあります。
  • 高精度な特徴が多いため、実行時間が長くなることがあります。手動で [粒度] を設定してください。
  • パターンに含まれる情報が不十分なため、角度またはスケールを正確に測定できないことがあります。

スプレッドシートに情報文字列を挿入するには、GetInfoString データアクセス関数を使用します。

TrainPatMaxPattern 関数データアクセス関数

1 つのデータアクセス関数がスプレッドシートに自動挿入されます。

Trained

GetTrained(パターン)

パターンを登録できた場合には 1、登録できなかった場合には 0 を返します。

関連項目

  • パターンマッチングツールについて
  • FindPatMaxPatterns 関数
  • パターンデータアクセス関数
  • プロパティシートの使用方法


TrainPatMaxRedLine

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

パターンを抽出してパターンとは、 登録します。 FindPatMaxRedLine 関数と共に使用するために、画像から検出する対象物の登録済み (内部) 幾何学記述です。

注:
  • In-Sight ファームウェア 5.5.0 以降、この関数のアルゴリズムは、より正確な結果を返すように変更されており、一部の環境の実行時間を短縮します。
  • この変更により、In-Sight ファームウェア 5.5.0 以上で設定されたこの関数を含んだジョブを、ファームウェアバージョン 5.4.x 以前を実行する In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示され、この関数を含んだセルは #ERR の結果になります。
  • この関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • 登録されたパターンは、デフォルトのパターン領域 (320 × 440) を使用する場合には約 1MB を消費しますが、登録済みのパターンのサイズに応じてパターンのサイズは大きく変わります。
  • TrainPatMaxRedLine の入力パラメータ
  • TrainPatMaxRedLine の出力
  • TrainPatMaxRedLine データアクセス関数
  • 関連項目

TrainPatMaxRedLineの入力パラメータ

TrainPatMaxRedLine(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

パターン領域.X,

パターン領域.Y,

パターン領域.高さ,

パターン領域.幅,

パターン領域.角度,

パターン領域.カーブ,

外部定義領域,

パターン原点.行オフセット,

パターン原点.列オフセット,

粗粒度自動選択,

微粒度自動選択,

粗粒度,

微粒度,

特徴しきい値,

登録画像の再使用,

タイムアウト,

表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

パターン領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ (デフォルト = 320) | 領域の X 軸に沿った寸法。
幅 (デフォルト = 440) | 領域の Y 軸に沿った寸法。
角度 (デフォルト = 0) | フィクスチャ座標での角度。
カーブ (デフォルト = 0) | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、EditRegion、または Mask を含んだスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

パターン原点

登録パターンの原点の行および列を、登録領域の中心からのオフセットとして指定します。

オフセット行 (デフォルト = 0) | 登録パターンの中心からの行オフセットを指定します。
オフセット列 (デフォルト = 0) | 登録パターンの中心からの列オフセットを指定します。

粗粒度自動選択

粗粒度サーチフェーズで使用する画像粒度を自動的に指定するかどうかを指定します。粗粒度は、大きな特徴を検出して、画像内の大まかなパターン一致を実行時に迅速に検出するために使用されます。0 = OFF 1 = ON (デフォルト)

微粒度自動選択

微粒度サーチフェーズで使用する画像粒度を自動的に指定するかどうかを指定します。微粒度は、小さな特徴を検出して、パターン位置を正確に判定するために使用されます。

0 = OFF

1 = ON (デフォルト)

粗粒度

粗粒度をピクセル単位で指定します。粗粒度は、大きな特徴を検出して、画像内の大まかなパターン一致を実行時に迅速に検出するために使用されます (1 ～ 30、デフォルト = 4)。

注: [粗粒度自動選択] パラメータはデフォルトで有効になっています。このパラメータを有効にするには [粗粒度自動選択] パラメータを無効にします。
微粒度

微粒度をピクセル単位で指定します。微粒度は、小さな特徴を検出して、パターン位置を正確に判定するために使用されます (1～10、デフォルト = 1)。

注:

  • [微粒度自動選択] パラメータはデフォルトで有効になっています。このパラメータを有効にするには [微粒度自動選択] パラメータを無効にします。
  • 微粒度の値を粗粒度の値よりも大きくすることはできません。
特徴しきい値

登録した特徴の最小コントラストを指定します。他の低コントラストの特徴を登録する場合、値を下げてください。無視するには、値を上げてください (1 ～ 100、20 = デフォルト)。
登録画像の再使用

パターンの登録に使用された画像を保存し、[パターンの設定] パラメータ ([パターン原点]、[粗粒度自動選択]、[微粒度自動選択]、[粗粒度]、[微粒度]、または [ノイズしきい値]) を変更するときに使用するかどうかを指定します。

0 = OFF (デフォルト)

現在の画像 ([画像] パラメータに指定された画像) がパターンの登録/再登録に使用されます。

1 = ON

最初にパターンの登録に使用された画像を使用して、[パターン原点]、[粗粒度自動選択]、[微粒度自動選択]、[粗粒度]、[微粒度]、および/または [ノイズしきい値] パラメータが変更された場合に、パターンを再登録します。最初に有効にした場合は、[画像] パラメータによって識別された画像がパターンの登録に使用され、画像のコピーがジョブに保存されます。、、、、、または [ノイズしきい値] パラメータに対するこの後の変更は、格納されている画像を使用して行われます。

注:
  • このパラメータが有効なときに、[フィクスチャ] 入力パラメータが変更され、[パターン領域] (または、[外部定義領域]) が移動または変更されると、関数は入力画像内の登録領域を調整し、新しい画像を保存して、パターンを再登録します。
  • [登録画像の再使用] パラメータが On (有効) に変わったが、パターンがまだ登録されていない場合、パラメータが Off (無効) になり新しいパターンが登録されるまで、関数は #ERR を返します。

タイムアウト

関数が有効なパターンをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0、タイムアウトの無効化)。この時間が経過すると、処理は中止され、#ERR が返されます。

表示

画像上のグラフィックスのTrainPatMaxRedLine表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、TrainPatMaxRedLineすべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 登録されたパターンの特徴が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域、パターンの原点、および登録された特徴が常に表示されます。
3 = 全て表示: 入力、結果および登録画像 | 入力画像領域、パターンの原点、登録された特徴、および登録画像が常に表示されます。

TrainPatMaxRedLineの出力

戻り値 | 登録されたパターンを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。次の取り込みで新しいパターンを誤って登録することを避けるために、この関数はデフォルトで無効に設定されています。
結果 | 初めてTrainPatMaxRedLine関数が初めてセルに挿入されると、登録状態が右隣のセルに自動的に表示されます。パターンを登録できない場合は #ERR が挿入されます。

TrainPatMaxRedLineデータアクセス関数

1 つのデータアクセス関数がスプレッドシートに自動挿入されます。

登録

GetTrained(パターン)

パターンを登録できた場合には 1、登録できなかった場合には 0 を返します。

関連項目

  • パターンマッチングツールについて
  • FindPatMaxRedLine
  • パターンデータアクセス関数
  • プロパティシートの使用方法


TrainPatMaxRedLineColor

ビジョンツール → パターンマッチ

In-Sight 関数リファレンス

パターンを抽出してパターンとは、 登録します。 FindPatMaxRedLineColor 関数と共に使用するために、カラー画像から検出する対象物の登録済み (内部) 幾何学記述です。

注:

  • TrainPatMaxRedLineColor 関数と FindPatMaxRedLineColor 関数は、In-Sight ファームウェア 5.6.0 以上を実行している In-Sight 7000 Gen2 シリーズのカラービジョンシステムおよび In-Sight 8000 シリーズのカラービジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • グレースケール画像を使用する場合は、TrainPatMaxRedLine 関数と FindPatMaxRedLine 関数を使用する必要があります。グレースケール画像 (ColorToGreyscaleFilter の出力など) に対して TrainPatMaxRedLineColor 関数と FindPatMaxRedLineColor 関数を使用しようとすると、#ERR が返されます。
  • FindPatMaxRedLineColor 関数は TrainPatMaxRedLineColor 関数を参照する必要があります。別の関数 (TrainPatMaxRedLine 関数など) を参照すると、#ERR が返されます。
  • TrainPatMaxRedLineColor の入力パラメータ
  • TrainPatMaxRedLineColor の出力
  • TrainPatMaxRedLineColor データアクセス関数
  • カラー選択
  • 関連項目

TrainPatMaxRedLineColorの入力パラメータ

TrainPatMaxRedLineColor(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

パターン領域.X,

パターン領域.Y,

パターン領域.高さ,

パターン領域.幅,

パターン領域.角度,

パターン領域.カーブ,

外部定義領域,

パターン原点.行オフセット,

パターン原点.列オフセット,

カラーマッチ

カラー選択

粗粒度自動選択,

微粒度自動選択,

粗粒度,

微粒度,

特徴しきい値,

登録画像の再使用,

タイムアウト,

グラフィックス表示

)

画像

データ構造体を含んだスプレッドシートセルを参照するように指定します。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

注: このパラメータはカラー画像を参照している必要があります。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット。
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

パターン領域

これは対象領域 (ROI) とも呼ばれ、解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ (デフォルト = 320) | 領域の X 軸に沿った寸法。
幅 (デフォルト = 440) | 領域の Y 軸に沿った寸法。
角度 (デフォルト = 0) | フィクスチャ座標での角度。
カーブ (デフォルト = 0) | 領域の X 軸と反対側の境界線との間の角度変位。

注:[フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部定義領域

このパラメータは、Annulus、Circle、Region、EditAnnulus、EditCircle、EditCompositeRegion、EditPolygon、EditRegion、または Mask を含んだスプレッドシートセルを参照できます。このパラメータを使用すると、関数は [領域] と [フィクスチャ] の設定を無視し、参照先領域で指定された画像領域を検査します。EditCompositeRegion 関数コントロールを参照している場合は、検査領域がさまざまな形状の混合となることがあります。合成領域内の各形状は、検査領域に対して加算または減算 (マスキング) されるように割り当てることができます。

注:このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

パターン原点

登録パターンの原点の行および列を、登録領域の中心からのオフセットとして指定します。

オフセット行 (デフォルト = 0) | 登録パターンの中心からの行オフセットを指定します。
オフセット列 (デフォルト = 0) | 登録パターンの中心からの列オフセットを指定します。
カラーマッチ

[パターン領域] に登録するカラーを指定します。

0 = すべてのカラー (デフォルト) | [パターン領域] ですべてのカラーをマッチさせるよう指定します。例えば、次の画像では、青 (オブジェクト) とグレー (背景) のカラーの両方が登録されます。 この結果、この関数を参照する FindPatMaxRedLineColor 関数は、グレーの背景に青いパターンを検出します。
1 = 選択カラー | [カラー選択] パラメータを使用して登録するカラーを指定します。例えば、次の図では、青色 (オブジェクト) のみを登録するよう選択することができます。 この結果、この関数を参照する FindPatMaxRedLineColor 関数は、任意の背景にある青いパターンをすべて検出します。
2 = マッチなし | カラーは登録されません。 この結果、この関数を参照する FindPatMaxRedLineColor 関数は、カラーまたは背景に関係なく、マッチするパターンをすべて検出します。

カラー選択

[カラー選択] ダイアログを使用して、登録するカラーを指定します。ジョブでボタンまたは数値を参照することができます。ゼロ以外の値はボタンを押したものとして扱われ、[カラー選択] ダイアログを開きます。

0 | [カラー選択] ボタンは押されません (デフォルト)。
1 | [カラー選択] ボタンが押されます。

注:

  • [カラー選択] パラメータが有効になるのは、[カラーマッチ] パラメータが [選択カラー] に設定されている場合だけです。
  • 詳細については、「カラー選択」セクションを参照してください。

粗粒度自動選択

粗粒度サーチフェーズで使用する画像粒度を自動的に指定するかどうかを指定します。粗粒度は、大きな特徴を検出して、画像内の大まかなパターン一致を実行時に迅速に検出するために使用されます。

0 = OFF

1 = ON (デフォルト)

微粒度自動選択

微粒度サーチフェーズで使用する画像粒度を自動的に指定するかどうかを指定します。微粒度は、小さな特徴を検出して、パターン位置を正確に判定するために使用されます。

0 = OFF

1 = ON (デフォルト)

粗粒度

粗粒度をピクセル単位で指定します。粗粒度は、大きな特徴を検出して、画像内の大まかなパターン一致を実行時に迅速に検出するために使用されます (1 ～ 30、デフォルト = 4)。

注: [粗粒度自動選択] パラメータはデフォルトで有効になっています。このパラメータを有効にするには [粗粒度自動選択] パラメータを無効にします。
微粒度

微粒度をピクセル単位で指定します。微粒度は、小さな特徴を検出して、パターン位置を正確に判定するために使用されます (1～10、デフォルト = 1)。

注:

  • [微粒度自動選択] パラメータはデフォルトで有効になっています。このパラメータを有効にするには [微粒度自動選択] パラメータを無効にします。
  • 微粒度の値を粗粒度の値よりも大きくすることはできません。
特徴しきい値

登録した特徴の最小コントラストを指定します。他の低コントラストの特徴を登録する場合、値を下げてください。無視するには、値を上げてください (1 ～ 100、20 = デフォルト)。
登録画像の再使用

パターンの登録に使用された画像を保存し、[パターンの設定] パラメータ ([パターン原点]、[粗粒度自動選択]、[微粒度自動選択]、[粗粒度]、[微粒度]) を変更するときに使用するかどうかを指定します。

0 = OFF (デフォルト)

現在の画像 ([画像] パラメータに指定された画像) がパターンの登録/再登録に使用されます。

1 = ON

最初にパターンの登録に使用された画像を使用して、[パターン原点]、[粗粒度自動選択]、[微粒度自動選択]、[粗粒度]、および/または [微粒度] パラメータが変更された場合に、パターンを再登録します。最初に有効にした場合は、[画像] パラメータによって識別された画像がパターンの登録に使用され、画像のコピーがジョブに保存されます。[パターン原点]、[粗粒度自動選択]、[微粒度自動選択]、[粗粒度]、または [微粒度] パラメータに対するこの後の変更は、格納されている画像を使用して行われます。

注:
  • このパラメータが有効なときに、[フィクスチャ] 入力パラメータが変更され、[パターン領域] (または、[外部定義領域]) が移動または変更されると、関数は入力画像内の登録領域を調整し、新しい画像を保存して、パターンを再登録します。
  • [登録画像の再使用] パラメータが On (有効) に変わったが、パターンがまだ登録されていない場合、パラメータが Off (無効) になり新しいパターンが登録されるまで、関数は #ERR を返します。

タイムアウト

関数が有効なパターンをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0、タイムアウトの無効化)。この時間が経過すると、処理は中止され、#ERR が返されます。

グラフィックス表示

画像上のグラフィックスのTrainPatMaxRedLineColor表示モードを指定します。

パターン領域

[パターン領域] および [パターン原点] が表示されます。

0 = OFF (デフォルト)

1 = ON

登録画像

登録されている画像が表示されます。

0 = OFF (デフォルト)

1 = ON

登録パターン

登録されているエッジの特徴が緑の線で表示されます。

0 = OFF (デフォルト)

1 = ON

カラーマッチ

登録したマッチカラーをサンプル位置に表示します。サンプルは円で表示され、円のカラーおよび位置は登録カラーを示します。

0 = OFF (デフォルト)

1 = ON

TrainPatMaxRedLineColorの出力

戻り値 | 登録されたパターンを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。次の取り込みで新しいパターンを誤って登録することを避けるために、この関数はデフォルトで無効に設定されています。
結果 | 初めてTrainPatMaxRedLineColor関数が初めてセルに挿入されると、登録状態が右隣のセルに自動的に表示されます。パターンを登録できない場合は #ERR が挿入されます。

TrainPatMaxRedLineColorデータアクセス関数

1 つのデータアクセス関数がスプレッドシートに自動挿入されます。

登録

GetTrained(パターン)

パターンを登録できた場合には 1、登録できなかった場合には 0 を返します。

カラー選択

[カラーマッチ] パラメータが [選択カラー] に設定されている場合は、[カラーの選択] ダイアログを使用して、[パターン領域] に登録するカラーを選択する必要があります。

  1. TrainPatMaxRedLineColor プロパティシートで [カラー選択] ボタンをクリックします。[カラーの選択] ダイアログおよびマジックワンドカーソルが表示されます。

  2. [パターン領域] で、カラーを登録する領域をクリックします。選択すると、選択した領域内が色付けされて移動枠線で囲まれます。

    注:

    • 複数の領域を選択するときには、[カラーの選択] ダイアログで [image] アイコンを有効にするか、Ctrl キーを押しながらその領域をクリックします。
    • 領域の選択を解除するときには、[カラーの選択] ダイアログで [image] アイコンを有効にするか、その領域をクリックします。
    • [パターン領域] の外側をクリックすると、選択した領域がすべて選択解除されます。

  3. [カラーの選択] ダイアログを使用して許容値を指定します。この値を調整するには、バーの内部をクリックするか、バーをドラッグします。マウスボタンを離すと、その許容値が適用されます。

    注: このツールで、クリックしたすべてのピクセル (= 入力ピクセル) を調べて、基本的な比較操作を実行します。比較結果が許容値以下の場合は、ピクセルが選択されます。許容値を 100% まで上げると、[パターン領域] 内のすべてのピクセルが選択されます。許容値を 0% に下げると、入力ピクセルの厳密な RBG 値であるピクセルのみが選択されます。

  4. 選択したカラーを受け入れる場合は、[OK] ボタンを押します。キャンセルする場合は、[キャンセル] ボタンをクリックします。

    ヒント: [ジョブの編集] ツールバーの [image] または [image] ボタンをクリックして、受け入れまたはキャンセルをすることもできます。

  5. 登録された TrainPatMaxRedLineColor プロパティシートが再度表示されます。

関連項目

  • パターンマッチングツールについて
  • FindPatMaxRedLineColor
  • パターンデータアクセス関数
  • プロパティシートの使用方法


幾何計測関数

In-Sight 関数リファレンス

幾何計測関数は、スプレッドシートのプログラマが、円、点、および線セグメントなどの標準の幾何的構造体間の距離を容易に計算できるようにします。

注: 幾何計測関数がワールド座標データを参照として使用している場合、作成されたグラフィックスは正しく表示されません。

  • Fit 関数: 点と線から幾何学的形状を構築します。
  • 計測関数: 円、点、および線セグメント間の距離と角度を計算します。


Fit 関数

幾何計測関数

In-Sight 関数リファレンス

Fit 関数は、点と線から幾何学的形状を構築します。

  • BoundingRectangle 関数: 指定した (インデックスで指定された) ブロブを囲む矩形を指定します。
  • CircleFromNPoints 関数: 3 つ以上の点から円を作成します。
  • LineFromNPoints 関数: 2 つ以上の点から線を作成します。
  • SegmentFromLines 関数: 終了点を平均して、新しい線セグメントを作成します。


BoundingRectangle 関数

BoundingRectangle 関数 |
幾何計測関数 → 幾何図形 | In-Sight 関数リファレンス

指定した (インデックスで指定された) ブロブを囲む矩形を指定します。この関数は、指定したの入力パラメータに基づいて、ブロブのすべての点を囲む矩形を検出します。

BoundingRectangle 関数(

ブロブ,

インデックス,

配置,

角度,

パディング.高さ,

パディング.幅,

表示

)

BoundingRectangle 関数の入力パラメータ

ブロブ

このパラメータは、ExtractBlobs、FindBlobs、または SortBlobs 関数によって返される有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

インデックス

構造体でのブロブのインデックスを指定します。

配置

検出された矩形の配置を指定します。サンプルについては、ここ Closed をクリックしてください。

0 = ブロブ座標フレーム (デフォルト) | 矩形がブロブの角度と同じ角度になるように指定します。 注: ブロブの角度は GetAngle 関数によって返すことができます。
1 = 画像座標フレーム | 角度 0° でブロブに最適な矩形を指定します。
2 = ユーザ座標フレーム | [角度] パラメータによって使用される角度で、ブロブに最適な矩形を指定します。

角度

外接する矩形の検出に適切な角度 (-360 ～ 360) を指定します。

パディング

ブロブと矩形の間のスペースの量をピクセル単位で指定します。

高さ | ブロブおよび矩形の上部と下部の間のスペースの量を、ピクセル単位で指定します (0 ～ ((画像の高さ÷ 2) - 1))。
幅 | ブロブおよび矩形の左側と右側の間のスペースの量を、ピクセル単位で指定します (0 ～ ((画像の幅÷ 2) - 1))。

表示

画像上のグラフィックスオーバレイのBoundingRectangle 関数表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、BoundingRectangle 関数すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 外接する矩形の領域が常に表示されます。

BoundingRectangle 関数の出力

戻り値 | インデックスで指定されたブロブから、外接する最適な矩形を定義する [image] データ構造体。入力パラメータのいずれかが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

BoundingRectangle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(領域) | 画像座標系での、領域の原点の行オフセット。
列 | GetCol(領域) | 画像座標系での、領域の原点の列オフセット。
高さ | GetHigh(領域) | 領域の X 軸に沿った寸法。
幅 | GetWide(領域) | 領域の Y 軸に沿った寸法。
角度 | GetAngle(領域) | 画像座標での角度。

関連項目

ブロブツールについて

ブロブデータアクセス関数

プロパティシートの使用方法


CircleFromNPoints 関数

CircleFromNPoints 関数 |
幾何・計測 → 幾何図形 | In-Sight 関数リファレンス

3 つ以上の入力点を使用して円をフィッテイングします。

CircleFromNPoints 関数 (

点行 0,

点列 0,

点行 1,

点列 1,

点行 2,

点列 2,

[...,

点行 N,

点列 N,

表示]

)

CircleFromNPoints 関数の入力パラメータ

点 0

1 番目の点の座標を指定します。

点行 0 | 1 番目の点の X 座標
点列 0 | 1 番目の点の Y 座標

点 1

2 番目の点の座標を指定します。

点行 1 | 2 番目の点の X 座標
点列 1 | 2 番目の点の Y 座標

点 2

3 番目の点の座標を指定します。

点行 2 | 3 番目の点の X 座標
点列 2 | 3 番目の点の Y 座標

点 3..N

オプションで、任意の追加点の座標を指定します。

点行 N | N 番目の点の X 座標
点列 N | N 番目の点の Y 座標

表示

常時表示されるグラフィックス項目を指定します。

0 = 非表示 | CircleFromNPoints 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックス項目が表示されません。
1 = 結果のグラフィックスのみ | 最適な円のグラフィックスが常に表示されます。入力点は、CircleFromNPoints 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合のみ表示されます。
2 = 入力と結果のグラフィックス | 最適な円と入力点が常に表示されます。

CircleFromNPoints 関数の出力

戻り値 | 最適な円の行、列、半径、およびシグマを含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

CircleFromNPoints 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(CircleFit) | 円の中心の X 座標
列 | GetCol(CircleFit) | 円の中心の Y 座標
半径 | GetRadius(CircleFit) | 円の半径
シグマ | GetSigma(CircleFit) | 点から円までの距離を点の数で除算した結果の二乗和平方根

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

距離 | GetDistance(CircleFit, Index) | インデックスで指定された点と、円の間の距離。この値が負である場合、点は円の内側にあります。インデックスで指定された点が無効の場合は、#ERR が返されます。
最大距離 | GetMaxDist(CircleFit) | 円と、円から最も遠い点との間の距離。この値が負である場合、点は円の内側にあります。
最大距離インデックス | GetMaxDistIndex(CircleFit) | 円から最も遠い点のインデックス
N 点使用 | GetNPointsUsed(CircleFit) | 円のフィッティングに使用された点の数


LineFromNPoints 関数

LineFromNPoints 関数 |
幾何・計測 → 幾何図形 | In-Sight 関数リファレンス

2 つ以上の入力点を使用して線を作成します。

LineFromNPoints 関数 (

点行 0,

点列 0,

点行 1,

点列 1,

[...

点行 N,

点列 N,

表示]

)

LineFromNPoints 関数の入力パラメータ

点 0

1 番目の点の座標を指定します。

点行 0 | 1 番目の点の X 座標
点列 0 | 1 番目の点の Y 座標

点 1

2 番目の点の座標を指定します。

点行 1 | 2 番目の点の X 座標
点列 1 | 2 番目の点の Y 座標

点 2..N

任意の追加点の座標を指定します。

点行 N | N 番目の点の X 座標
点列 N | N 番目の点の Y 座標

表示

常時表示されるグラフィックス項目を指定します。

0 = 非表示 | LineFromNPoints 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、すべてのグラフィックス項目が表示されません。
1 = 結果のグラフィックスのみ | 最適ラインのグラフィックスが常に表示されます。入力点は、LineFromNPoints 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合のみ表示されます。
2 = 入力と結果のグラフィックス | 最適ラインと入力点は常に表示されます。

LineFromNPoints 関数の出力

戻り値 | 2 つ以上の有効な点がデータに含まれる場合の [image] データ構造体。データに含まれる有効な点が 1 つ以下の場合、#ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

LineFromNPoints 関数データアクセス関数

スプレッドシートに自動挿入されて結果テーブルを作成するデータアクセス関数は次のとおりです。

行 0 | GetRow(LineFit, 0) | 始点の X 座標
列 0 | GetCol(LineFit, 0) | 始点の Y 座標
行 1 | GetRow(LineFit, 1) | 終点の X 座標
列 1 | GetCol(LineFit, 1) | 終点の Y 座標
カイ 2 乗 | GetChi2(LineFit) | 点から線への距離の二乗の合計

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

距離 | GetDistance(LineFit, インデックス) | インデックス付きの点と、線の間の距離
最大距離 | GetMaxDist(LineFit) | 線から最も遠い点
最大距離インデックス | GetMaxDistIndex(LineFit) | 線から最も遠い点のインデックス
N 点使用 | GetNPointsUsed(LineFit) | 線の計算に使用された点の数


SegmentFromLines 関数

SegmentFromLines 関数 |
幾何・計測 → 幾何図形 | In-Sight 関数リファレンス

2 つの入力ラインを平均化することで、新しい線分を計算します。この関数は、最初のラインの始点を 2 番目のラインの始点で平均化します。同様に、最初のラインの終点を 2 番目のラインの終点で平均化します。結果は、平均行セグメントになります。

SegmentFromLines 関数 (

ライン 0.X 0,

ライン 0.Y 0,

ライン 0.X 1,

ライン 0.Y 1,

ライン 1.X 0,

ライン 1.Y 0,

ライン 1.X 1,

ライン 1.Y 1,

表示

)

SegmentFromLines 関数の入力パラメータ

ライン 0

1 番目のラインの座標を指定します。

X 0 | 1 番目の線の始点の X 座標。
Y 0 | 1 番目のラインの始点の y 座標。
X 1 | 1 番目のラインの終点の x 座標。
Y 1 | 1 番目のラインの終点の y 座標。

ライン 1

2 番目のラインの座標を指定します。

X 0 | 2 番目のラインの始点の x 座標。
Y 0 | 2 番目のラインの始点の y 座標。
X 1 | 2 番目のラインの終点の x 座標。
Y 1 | 2 番目のラインの終点の y 座標。

表示

画像上にオーバレイするグラフィックスを指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、使用可能なグラフィックス項目が表示されません。
1 = 結果のグラフィックスのみ | 返されたデータ構造体に関連付けられたグラフィックス項目が常に表示されます。この関数がスプレッドシート内のアクティブセルである場合のみ、ほかのグラフィックス項目が表示されます。
2 = 入力と結果のグラフィックス | 返されたデータ構造体と入力画像領域に関連付けられたグラフィックス項目が常に表示されます。

SegmentFromLines 関数の出力

戻り値 | 平均線分を含んだ [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

SegmentFromLines 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(ライン, 0) | 始点の X 座標
列 0 | GetCol(ライン, 0) | 始点の Y 座標
行 1 | GetRow(ライン, 1) | 終点の X 座標
列 1 | GetCol(ライン, 1) | 終点の Y 座標

関連項目

幾何図形関数について

幾何計測関数について

構造体データアクセス関数

プロパティシートの使用方法


計測関数

幾何計測関数

In-Sight 関数リファレンス

計測関数は、円、点、および線の間の距離と角度を計算します。

  • BlobToBlob 関数: 2 つのブロブの境界間の最小距離または最大距離を計測します。
  • BlobToLine 関数: ブロブ境界と線との間の最小距離または最大距離を計測します。
  • BlobToPoint 関数: ブロブ境界と点との間の最小距離または最大距離を計測します。
  • BlobToRadian 関数: 指定した角度でのブロブ境界と点との間の距離を計測します。
  • CircleToCircle 関数: 2 つの円の間の最小距離を計算します。
  • LineToCircle 関数: 線と円の間の最小距離を計算します。
  • LineToLine 関数: 2 本の線の交差を計算します。
  • MidLineToMidLine 関数: 1 本の線セグメントの中間点と、もう 1 本の線セグメントの中間点との距離を計算します。
  • PointToCircle 関数: 点から円までの最小距離を計算します。
  • PointToLine 関数: 点から線までの最小距離を計算します。
  • PointToPoint 関数: 2 つの点の間の有向距離を計算します。
  • PointToPointAngle 関数: 2 つの点によって定義される角度を計算します。
  • PointToPointDistance 関数: 2 つの点の間の距離を計算します。


BlobToBlob 関数

BlobToBlob 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

2 つのブロブの境界間の最小距離または最大距離を計測します。

Closed 例

この例では、BlobToBlob 関数で 2 つのブロブの境界間の最小距離を計測しています。

  • BlobToBlob の入力パラメータ
  • BlobToBlob の出力
  • BlobToBlob データアクセス関数
  • 関連項目

BlobToBlob 関数の入力パラメータ

BlobToBlob 関数 (

ブロブ 0 ,

インデックス 0 ,

ブロブ 1 ,

インデックス 1 ,

検出する基準 ,

表示

)

ブロブ 0

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

インデックス 0

この引数は、 [image] データ構造体でゼロベースのインデックスを参照します。

ブロブ 1

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

インデックス 1

この引数は、 [image] データ構造体でゼロベースのインデックスを参照します。

検出する基準

距離の測定方法を指定します。

0 = 最小距離 | 2 つのブロブの境界の最も近い点の間の距離を検出します。 Closed 例
1 = 最大距離 | 2 つのブロブの境界の最も遠い点の間の距離を検出します。 Closed 例

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 2 つのブロブ間の最小距離または最大距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 2 つのブロブと、それらの間の線セグメントが常に表示されます。

BlobToBlob 関数の出力

戻り値 | ブロブと、別のブロブ境界上の最も近い点または最も遠い点との間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

BlobToBlob 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | [検出する基準] パラメータの設定に応じた、1 番目のブロブの境界上にある最も近い点または最も遠い点の X 座標。
列 0 | GetCol(Dist, 0) | [検出する基準] パラメータの設定に応じた、1 番目のブロブの境界上にある最も近い点または最も遠い点の Y 座標。
行 1 | GetRow(Dist, 1) | [検出する基準] パラメータの設定に応じた、2 番目のブロブの境界上にある最も近い点または最も遠い点の X 座標。
列 1 | GetCol(Dist, 1) | [検出する基準] パラメータの設定に応じた、2 番目のブロブの境界上にある最も近い点または最も遠い点の Y 座標。
角度 | GetAngle(Dist) | 1 番目のブロブと 2 番目のブロブの境界点の間の角度。
距離 | GetDistance(Dist) | 1 番目のブロブと 2 番目のブロブの境界点の間の距離。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


BlobToLine 関数

BlobToLine 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

ブロブ境界と線との間の最小距離または最大距離を計測します。

Closed 例

この例では、BlobToLine 関数で 2 番目のブロブの境界と線との間の最大距離を計測しています。

  • BlobToLine の入力パラメータ
  • BlobToLine の出力
  • BlobToLine データアクセス関数
  • 関連項目

BlobToLine 関数の入力パラメータ

BlobToLine 関数 (

ブロブ ,

インデックス ,

ライン.X 0 ,

ライン.Y 0 ,

ライン.X 0 ,

ライン.Y 0 ,

検出する基準 ,

表示

)

ブロブ

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

インデックス

この引数は、 [image] データ構造体でゼロベースのインデックスを参照します。

ライン

ラインの座標を指定します。

X 0 | ラインの最初の終点の X 座標。
Y 0 | ラインの最初の終点の Y 座標。
X 1 | ラインの 2 番目の終点の X 座標。
Y 1 | ラインの 2 番目の終点の Y 座標。

検出する基準

距離の測定方法を指定します。

0 = 最小距離 | ブロブの境界の最も近い点と線との間の距離を検出します。
1 = 最大距離 | ブロブの境界の最も遠い点と線との間の距離を検出します。

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブと線との間の最小距離または最大距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | ブロブと線、およびそれらの間の線セグメントが常に表示されます。

BlobToLine 関数の出力

戻り値 | 線と、ブロブ境界上の最も近い点または最も遠い点との間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

BlobToLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | ブロブ境界上の最も近い点または最も遠い点の X 座標。
列 0 | GetCol(Dist, 0) | ブロブ境界上の最も近い点または最も遠い点の Y 座標。
行 1 | GetRow(Dist, 1) | 線上の最も近い点または最も遠い点の X 座標。
列 1 | GetCol(Dist, 1) | 線上の最も近い点または最も遠い点の Y 座標。
角度 | GetAngle(Dist) | ブロブ境界点と線との間の角度。
距離 | GetDistance(Dist) | ブロブ境界点と線との間の距離。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


BlobToPoint 関数

BlobToPoint 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

ブロブ境界と点との間の最小距離または最大距離を計測します。

Closed 例

この例では、BlobToPoint 関数で 3 番目のブロブと点との間の最小距離を計測しています。

  • BlobToPoint の入力パラメータ
  • BlobToPoint の出力
  • BlobToPoint データアクセス関数
  • 関連項目

BlobToPoint 関数の入力パラメータ

BlobToPoint 関数 (

ブロブ ,

インデックス ,

点.X ,

点.Y ,

検出する基準 ,

表示

)

Blobs

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

インデックス

この引数は、 [image] データ構造体でゼロベースのインデックスを参照します。

点

点の座標を指定します。

X | 点の X 座標。
Y | 点の Y 座標。

検出する基準

距離の測定方法を指定します。

0 = 最小距離 | ブロブの境界の最も近い点と点との間の距離を検出します。
1 = 最大距離 | ブロブの境界の最も遠い点と点との間の距離を検出します。

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブと点との間の最小距離または最大距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | ブロブと点、およびそれらの間の線セグメントが常に表示されます。

BlobToPoint 関数の出力

戻り値 | 点と、ブロブ境界上の最も近い点または最も遠い点との間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

BlobToPoint 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | ブロブ境界上の最も近い点または最も遠い点の X 座標。
列 0 | GetCol(Dist, 0) | ブロブ境界上の最も近い点または最も遠い点の Y 座標。
行 1 | GetRow(Dist, 1) | 点の X 座標。
列 1 | GetCol(Dist, 1) | 点の Y 座標。
角度 | GetAngle(Dist) | ブロブ境界点と点との間の角度。
距離 | GetDistance(Dist) | ブロブ境界点と点との間の距離。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


BlobToRadian 関数

幾何計測関数 → 計測

In-Sight 関数リファレンス

指定した角度でのブロブ境界と点との間の距離を計測します。

Closed 例

この例では、BlobToRadian 関数を使用して、ユーザ指定の角度で 3 番目のブロブと点との間の距離を計測しています。

注: ユーザ指定の角度は、点がブロブと交差するように設定する必要があります。そうしないと、この関数は #ERR を返します。

  • BlobToRadian の入力パラメータ
  • BlobToRadian の出力
  • BlobToRadian データアクセス関数
  • 関連項目

BlobToRadian 関数の入力パラメータ

BlobToRadian 関数 (

ブロブ ,

インデックス ,

点.X ,

点.Y ,

点.角度 ,

表示

)

ブロブ

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

インデックス

この引数は、 [image] データ構造体でゼロベースのインデックスを参照します。

点

点の座標および交差の角度を指定します。

X | 点の X 座標。
Y | 点の Y 座標。
角度 | 点とブロブとの交差の角度。 注: 点とブロブ境界が平行である場合、この関数は #ERR を返します。点とブロブ境界は交差している必要があります。

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | ブロブと放射線との間の最小距離または最大距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | ブロブと放射線、およびそれらの間の線セグメントが常に表示されます。

BlobToRadian 関数の出力

戻り値 | 放射線と、ブロブ境界上の最も遠い点との間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

BlobToRadian 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | ブロブ境界上の最も遠い点の X 座標。
列 0 | GetCol(Dist, 0) | ブロブ境界上の最も遠い点の Y 座標。
行 1 | GetRow(Dist, 1) | [点] パラメータで指定された X 座標。
列 1 | GetCol(Dist, 1) | [点] パラメータで指定された Y 座標。
角度 | GetAngle(Dist) | ブロブ境界点と放射線の点との間の角度。
距離 | GetDistance(Dist) | ブロブ境界点と放射線の点との間の距離。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


CircleToCircle 関数

CircleToCircle 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

2 つの円の間の最小距離を計算します。2 つの円が交差している場合は、交差点が計算されて返されます。1 つの円がもう 1 つの円の内側にある場合は、計算される距離は負になります。

  • CircleToCircle の入力パラメータ
  • CircleToCircle の出力
  • CircleToCircle データアクセス関数
  • 関連項目

CircleToCircle 関数の入力パラメータ

CircleToCircle 関数 (

円 0.X ,

円 0.Y ,

円 0.半径 ,

円 1.X ,

円 1.Y ,

円 1.半径 ,

表示

)

円 0

1 番目の円の座標とサイズを指定します。

X | 1 番目の円の中心の X 座標
Y | 1 番目の円の中心の Y 座標
半径 | 1 番目の円の半径 (ピクセル単位)

円 1

2 番目の円の座標とサイズを指定します。

X | 2 番目の円の中心の X 座標
Y | 2 番目の円の中心の Y 座標
半径 | 2 番目の円の半径 (ピクセル単位)

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 2 つの円の間の最小距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 2 つの円と、それらの間の線セグメントが常に表示されます。

CircleToCircle 関数の出力

戻り値 | 1 番目の円上の点、2 番目の円上の点、点の間の距離、および有向距離の角度を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

CircleToCircle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | 交差していない場合は、1 番目の円上の点の X 座標。交差している場合は、交差の 1 番目の点の X 座標。
列 0 | GetCol(Dist, 0) | 交差していない場合は、1 番目の円上の点の Y 座標。交差している場合は、交差の 1 番目の点の Y 座標。
行 1 | GetRow(Dist, 1) | 交差していない場合は、2 番目の円上の点の X 座標。交差している場合は、交差の 2 番目の点の X 座標。
列 1 | GetCol(Dist, 1) | 交差していない場合は、2 番目の円上の点の Y 座標。交差している場合は、交差の 2 番目の点の Y 座標。
角度 | GetAngle(Dist) | 2 点間の角度
距離 | GetDistance(Dist) | 交差していない場合は点の間の距離。交差している場合は 0。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


LineToCircle 関数

LineToCircle 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

線と円の間の最小距離を計算します。

  • LineToCircle の入力パラメータ
  • LineToCircle の出力
  • LineToCircle 関数のデータアクセス関数
  • 関連項目

LineToCircle 関数の入力パラメータ

LineToCircle 関数 (

ライン.X 0 ,

ライン.Y 0 ,

ライン.X 1 ,

ライン.Y 1 ,

円.X ,

円.Y ,

円.半径 ,

表示

)

ライン

ラインの座標を指定します。

X 0 | ラインの最初の終点の X 座標。
Y 0 | ラインの最初の終点の Y 座標。
X 1 | ラインの 2 番目の終点の X 座標。
Y 1 | ラインの 2 番目の終点の Y 座標。

円

円の座標とサイズを指定します。

X | 円の中心の X 座標
Y | 円の中心の Y 座標
半径 | 円の半径 (ピクセル単位)

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 入力線と円の間の最小距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 入力線と円、およびそれらの間の線セグメントが常に表示されます。

LineToCircle 関数の出力

戻り値 | 線と円が交差していない場合、この関数は、線上の点、円上の点、点の間の距離、および有向距離の角度を含んでいる [image] データ構造体を返します。 線と円が交差している場合は、この関数は、交差上の 2 つの点、線セグメントの角度、および完全に 0 の距離を含んでいる [image] データ構造体を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

LineToCircle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | 交差していない場合は、1 番目の円上の点の X 座標。交差している場合は、交差の 1 番目の点の X 座標。
列 0 | GetCol(Dist, 0) | 交差していない場合は、1 番目の円上の点の Y 座標。交差している場合は、交差の 1 番目の点の Y 座標。
行 1 | GetRow(Dist, 1) | 交差していない場合は、2 番目の円上の点の X 座標。交差している場合は、交差の 2 番目の点の X 座標。
列 1 | GetCol(Dist, 1) | 交差していない場合は、2 番目の円上の点の Y 座標。交差している場合は、交差の 2 番目の点の Y 座標。
角度 | GetAngle(Dist) | 2 点間の角度
距離 | GetDistance(Dist) | 交差していない場合は点の間の距離。交差している場合は 0。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


LineToLine 関数

LineToLine 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

2 本の線の間にある交差の点と角度を計算します。線が交差していない場合は、その代わりに線の間の距離が計算されて返されます。

  • LineToLine の入力パラメータ
  • LineToLine の出力
  • LineToLine 関数のデータアクセス関数
  • 関連項目

LineToLine 関数の入力パラメータ

LineToLine 関数 (

ライン 0.X 0 ,

ライン 0.Y 0 ,

ライン 0.X 1 ,

ライン 0.Y 1 ,

ライン 1.X 0 ,

ライン 1.Y 0 ,

ライン 1.X 1 ,

ライン 1.Y 1 ,

表示

)

ライン 0 (Line 0)

1 番目の線セグメントの座標を指定します。

X 0 | 1 番目の線の始点の X 座標
Y 0 | 1 番目の線の始点の Y 座標
X 1 | 1 番目の線の終点の X 座標
Y 1 | 1 番目の線の終点の Y 座標

ライン 1 (Line 1)

2 番目の線セグメントの座標を指定します。

X 0 | 2 番目の線の始点の X 座標
Y 0 | 2 番目の線の始点の Y 座標
X 1 | 2 番目の線の終点の X 座標
Y 1 | 2 番目の線の終点の Y 座標

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 2 本の入力線の間の最小距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 入力線と、それらの間の線セグメントが常に表示されます。

LineToLine 関数の出力

戻り値 | 2 本の線が交差している場合、この関数は、交差の点、有向線セグメント間の角度、および 0 に等しい距離を含んでいる [image] データ構造体を返します。 2 本の線が交差していない場合は、この関数は、各線の点、線の間の距離、および有向線セグメント間の角度を含んでいる [image] データ構造体を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

LineToLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Dist, 0) | 交差している場合は、交差の点の X 座標。交差していない場合は、[Line 0] の始点の X 座標。
列 0 | GetCol(Dist, 0) | 交差している場合は、交差の点の Y 座標。交差していない場合は、[Line 0] の始点の Y 座標。
行 1 | GetRow(Dist, 1) | 交差している場合は、交差の点の X 座標。交差していない場合は、[Line 0] の始点に最も近い [Line 1] 上の点の X 座標。
列 1 | GetCol(Dist, 1) | 交差している場合は、交差の点の Y 座標。交差していない場合は、[Line 0] の始点に最も近い [Line 1] 上の点の Y 座標。
角度 | GetAngle(Dist) | 有向線セグメント間の角度。
距離 | GetDistance(Dist) | 線の間の距離。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


MidLineToMidLine 関数

MidLineToMidLine 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

1 本の線セグメントの中間点と、2 本目の線セグメントとの中間点との距離を計算します。

  • MidLineToMidLine の入力パラメータ
  • MidLineToMidLine の出力
  • MidLineToMidLine データアクセス関数
  • 関連項目

MidLineToMidLine 関数の入力パラメータ

MidLineToMidLine 関数 (

ライン 0.X 0 ,

ライン 0.Y 0 ,

ライン 0.X 1 ,

ライン 0.Y 1 ,

ライン 1.X 0 ,

ライン 1.Y 0 ,

ライン 1.X 1 ,

ライン 1.Y 1 ,

表示

)

ライン 0

1 番目の線セグメントの座標を指定します。

X 0 | 1 番目の線の始点の X 座標
Y 0 | 1 番目の線の始点の Y 座標
X 1 | 1 番目の線の終点の X 座標
Y 1 | 1 番目の線の終点の Y 座標

ライン 1

2 番目の線セグメントの座標を指定します。

X 0 | 2 番目の線の始点の X 座標
Y 0 | 2 番目の線の始点の Y 座標
X 1 | 2 番目の線の終点の X 座標
Y 1 | 2 番目の線の終点の Y 座標

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 2 本の線の交差を示す十字 (存在する場合)
2 = 入力と結果のグラフィックス | 2 本の入力線と、それらの交差を示す十字が常に表示されます。

MidLineToMidLine 関数の出力

戻り値 | 2 つの線セグメント間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

MidLineToMidLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(距離, 0) | 1 番目の中間点の X 座標
列 0 | GetCol(距離, 0) | 1 番目の中間点の Y 座標
行 1 | GetRow(距離, 1) | 2 番目の中間点の X 座標
列 1 | GetCol(距離, 1) | 2 番目の中間点の Y 座標
角度 | GetAngle(距離) | 2 つの中間点間の角度
距離 | GetDistance(距離) | 2 つの中間点間の距離

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


PointToCircle 関数

PointToCircle 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

点から円の最も近い点までの最小距離を計算します。点が円の内側にある場合は、距離は負の数値として報告されます。

  • PointToCircle の入力パラメータ
  • PointToCircle の出力
  • PointToCircle データアクセス関数
  • 関連項目

PointToCircle 関数の入力パラメータ

PointToCircle 関数 (

点.X ,

点.Y ,

円.X ,

円.Y ,

円.半径 ,

表示

)

点

原点として使用される点の座標を指定します。

X | 点の X 座標。
Y | 点の Y 座標。

円

円の座標とサイズを指定します。

X | 円の中心の X 座標
Y | 円の中心の Y 座標
半径 | 円の半径

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 点と円の間の最小距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 点と円、およびそれらの間の線セグメントが常に表示されます。

PointToCircle 関数の出力

戻り値 | 点と、円上の最も近い点との間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

PointToCircle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(距離, 0) | 点の X 座標。
列 0 | GetCol(距離, 0) | 点の Y 座標。
行 1 | GetRow(距離, 1) | 円上の最も近い点の X 座標。
列 1 | GetCol(距離, 1) | 円上の最も近い点の Y 座標。
角度 | GetAngle(距離) | 2 点間の角度
距離 | GetDistance(距離) | 2 点間の距離

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


PointToLine 関数

PointToLine 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

点から線までの最小距離を計算します。

Closed 例

この例では、PointToLine 関数で点と線との間の距離を計測しています。点は原点であり、線に対する原点の位置に基づいて角度が計算されます。

  • PointToLine の入力パラメータ
  • PointToLine の出力
  • PointToLine データアクセス関数
  • 関連項目

PointToLine 関数の入力パラメータ

PointToLine 関数 (

点.X ,

点.Y ,

ライン.X 0 ,

ライン.Y 0 ,

ライン.X 1 ,

ライン.Y 1 ,

表示

)

点

原点として使用される点の座標を指定します。

X | 点の X 座標。
Y | 点の Y 座標。

ライン

ラインの座標を指定します。

X 0 | ラインの最初の終点の X 座標。
Y 0 | ラインの最初の終点の Y 座標。
X 1 | ラインの 2 番目の終点の X 座標。
Y 1 | ラインの 2 番目の終点の Y 座標。

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 点と入力線の間の最小距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 点、入力線、およびそれらの間の線セグメントが常に表示されます。

PointToLine 関数の出力

戻り値 | 点と、線上の最も近い点との間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

PointToLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(距離, 0) | 点の X 座標。
列 0 | GetCol(距離, 0) | 点の Y 座標。
行 1 | GetRow(距離, 1) | 線上の最も近い点の X 座標。
列 1 | GetCol(距離, 1) | 線上の最も近い点の Y 座標。
角度 | GetAngle(距離) | 点と線との角度
距離 | GetDistance(距離) | 点と線との距離

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


PointToPoint 関数

PointToPoint 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

2 つの点の間の有向距離を計算します。

Closed 例

この例では、PointToPoint 関数で 2 つの点の間の距離を計測しています。終点に対する始点の位置に基づいて、角度が計算されます。

  • PointToPoint の入力パラメータ
  • PointToPoint の出力
  • PointToPoint データアクセス関数
  • 関連項目

PointToPoint 関数の入力パラメータ

PointToPoint 関数 (

点 0.X ,

点 0.Y ,

点 1.X ,

点 1.Y ,

表示

)

点 0

1 番目の点の座標を指定し、原点として使用します。

X | 1 番目の点の X 座標
Y | 1 番目の点の Y 座標

点 0

2 番目の点の座標を指定します。

X | 2 番目の点の X 座標
Y | 2 番目の点の Y 座標

表示

画像上の関数のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 2 つの入力点の間の最小距離を示す線セグメントが常に表示されます。
2 = 入力と結果のグラフィックス | 2 つの入力点と、それらの間の線セグメントが常に表示されます。

PointToPoint 関数の出力

戻り値 | 2 つの点の間の有向距離を含んでいる [image] データ構造体。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

PointToPoint 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(距離, 0) | 1 番目の点の X 座標
列 0 | GetCol(距離, 0) | 1 番目の点の Y 座標
行 1 | GetRow(距離, 1) | 2 番目の点の X 座標
列 1 | GetCol(距離, 1) | 2 番目の点の Y 座標
角度 | GetAngle(距離) | 2 点間の角度
距離 | GetDistance(距離) | 2 点間の距離

関連項目

  • 計測関数について
  • 幾何計測関数について
  • Dist データアクセス関数
  • プロパティシートの使用方法


PointToPointAngle 関数

PointToPointAngle 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

2 つの点の間の角度を計算します。

  • PointToPointAngle の入力パラメータ
  • PointToPointAngle の出力
  • 関連項目

PointToPointAngle 関数の入力パラメータ

PointToPointAngle 関数 (

点 0.X ,

点 0.Y ,

点 1.X ,

点 1.Y

)

点 0

1 番目の点の座標を指定し、原点として使用します。

X | 1 番目の点の X 座標
Y | 1 番目の点の Y 座標

点 1

2 番目の点の座標を指定します。

X | 2 番目の点の X 座標
Y | 2 番目の点の Y 座標

PointToPointAngle 関数の出力

戻り値

画像の行の軸に相対する、2 点間の角度を含んでいる値

注: 幾何計測カテゴリの他の大部分の計測関数とは異なり、PointToPointAngle 関数は [image] データ構造体または結果テーブルをスプレッドシートに挿入しません。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • プロパティシートの使用方法


PointToPointDistance 関数

PointToPointDistance 関数 |
幾何計測関数 → 計測 | In-Sight 関数リファレンス

2 つの点の間の距離を計算します。

  • PointToPointDistance の入力パラメータ
  • PointToPointDistance の出力
  • 関連項目

PointToPointDistance 関数の入力パラメータ

PointToPointDistance 関数 (

点 0.X ,

点 0.Y ,

点 1.X ,

点 1.Y

)

点 0

1 番目の点の座標を指定します。

X | 1 番目の点の X 座標
Y | 1 番目の点の Y 座標

点 1

2 番目の点の座標を指定します。

X | 2 番目の点の X 座標
Y | 2 番目の点の Y 座標

PointToPointDistance 関数の出力

戻り値

2 点間の距離を含んでいる値

注: 幾何計測カテゴリの他の大部分の計測関数とは異なり、PointToPointDistance 関数は [image] データ構造体または結果テーブルをスプレッドシートに挿入しません。

関連項目

  • 計測関数について
  • 幾何計測関数について
  • プロパティシートの使用方法


画面表示関数

In-Sight 関数リファレンス

画面表示関数を使用して、スプレッドシートを対話型コントロールを使ってカスタマイズし、In-Sight センサの実行時により情報が得られるデータ表示を実現します。画面表示関数は、次のカテゴリに分類されます。

  • オペレータ I/F 関数: 対話型グラフィックスコントロールをスプレッドシートに挿入します。
  • 表示関数: グラフィックス表示をスプレッドシートに挿入します。
  • 画像フィルタ関数: 画像上にオーバレイグラフィックスをプロットします。


オペレータ I/F 関数

画面表示関数

In-Sight 関数リファレンス

オペレータ I/F 関数では、スプレッドシートに対話型グラフィックス要素を挿入することによって、[関数の挿入] ダイアログやプロパティシートを使用することなく In-Sight のジョブの設定を簡単に変更できます。このコントロールには、アクセス権レベルが [フルアクセス] または [プロテクト] に設定されている場合にのみアクセス可能です。したがって、アクセス権レベルが [アクセス不可] に設定されている場合はアクセスできません。

オペレータ I/F には次の関数があります。

  • Authorize 関数: 承認を実行できるように、ラベル付きプッシュボタンコントロールをスプレッドシートに挿入します。
  • Button 関数: ラベル付きプッシュボタンコントロールを挿入します。
  • CheckBox 関数: ラベル付きチェックボックスコントロールを挿入します。
  • Dialog 関数: ラベル付きダイアログボックスコントロールを挿入します。
  • EditAnnulus 関数: ラベル付き対話型円環領域コントロールを挿入します。
  • EditCircle 関数: ラベル付き対話型円コントロールを挿入します。
  • EditCompositeRegion 関数: ラベル付き対話型合成領域コントロールを挿入します。
  • EditFloat 関数: 浮動小数点数編集コントロールを挿入します。
  • EditInt 関数: 整数編集コントロールを挿入します。
  • EditLine 関数: ラベル付き対話型線コントロールを挿入します。
  • EditMaskedRegion 関数: ラベル付き対話型領域コントロールを挿入します。
  • EditMultiGraphics 関数: 複数の対象領域の入力を編集できるように、ラベル付き対話型コントロールを挿入します。
  • EditPassword 関数: テキスト編集コントロールを挿入します。セキュリティの目的から、テキスト文字列はアスタリスクで表示されます。
  • EditPoint 関数: ラベル付き対話型点コントロールを挿入します。
  • EditPolygon 関数: ラベル付き対話型ポリゴン領域コントロールを挿入します。
  • EditPolylinePath 関数: ラベル付き対話型パス領域コントロールを挿入します。
  • EditRegion 関数: ラベル付き対話型領域コントロールを挿入します。
  • EditString 関数: テキスト編集コントロールを挿入します。
  • Link 関数: ラベル付きリンクコントロールを挿入します。
  • ListBox 関数: ドロップダウンリストコントロールを挿入します
  • MessageBox 関数: メッセージボックスコントロールを挿入します。
  • Select 関数: ラベル付き選択ボタンコントロールを挿入します。
  • Wizard 関数: ラベル付きウィザードコントロールを挿入します。

関連項目

画面表示関数について


Authorize 関数

Authorize 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

2 種類の承認を実行できるように、ラベル付きプッシュボタンコントロールをスプレッドシートに挿入します。「認証のみ」と「ダブルブラインド」です。認証のみを実行する場合は、ユーザ 1 (通常はオペレータ) が変更を加え、ユーザ 2 (通常はスーパバイザ) が変更内容を承認します。ダブルブラインドを実行する場合は、ユーザ 1 が変更を加え、ユーザ 2 はユーザ 1 によって加えられた変更を再入力する必要があります。承認結果は、監査メッセージによって追跡することができます。

Authorize 関数は、EditInt、EditFloat、および EditString 関数のコントロールをサポートしており、スプレッドシート、ダイアログ、EasyView、またはカスタムビューに追加できます。

注:
  • Authorize 関数のプロパティシートにアクセスするには、ボタンを右クリックして、[関数の編集] を選択します。
  • Authorize 関数を含むスプレッドシートの設定方法、承認の実行方法、および生成される監査メッセージの種類の詳細については、承認の実行のトピックを参照してください。
  • Authorize の入力パラメータ
  • Authorize の出力
  • 関連項目

Authorize 関数の入力パラメータ

Authorize 関数(

ラベル,

タイプ

レベル

セル参照

セル参照

)

ラベル

ボタンに表示される名前を指定します。

タイプ

承認の種類を指定します。

0 = なし (デフォルト) | 承認は実行されません。
1 = 認証のみ | ユーザ 2 がユーザ 1 によって加えられた変更を承認します。
2 = ダブルブラインド | ユーザ 2は、ユーザ 1 によってそれ以前に入力された値を正確に再入力します。

レベル

ユーザ 2 の最低限のアクセスレベルを指定します。

0 = なし (デフォルト) | 有効な In-Sight ログオン認証を持つユーザが承認を実行できます。ユーザ 1 は、自身のエントリの承認が許可されます。
1 = プロテクト | ユーザ 2 はユーザ 1 とは異なっており、プロテクトまたはフルの In-Sight アクセスレベルを保持している必要があります。
2 = フル | ユーザ 2 はユーザ 1 とは異なっており、フルの In-Sight アクセスレベルを保持している必要があります。

セル参照

承認が実行されるセル範囲の左上のセルを指定します。

セル参照

承認が実行されるセル範囲の右下のセルを指定します。
注:
  • セル範囲の最大サイズは、10 (幅) × 20 (高さ) です。
  • スプレッドシート内で承認を実行する場合は、両方の [セル参照] パラメータを指定する必要があります。
  • ダイアログ、カスタムビュー、または EasyView で承認を実行し、両方の [セル参照] パラメータが指定されていない (= 0) 場合、Authorize 関数はセル範囲としてダイアログ、カスタムビュー、または EasyView を使用します。この場合、ダイアログ、カスタムビュー、または EasyView 全体が [Authorize] ダイアログに表示されます (サポートされていないエディットコントロールは無効になります)。
  • 一方の [セル参照] パラメータが指定され、もう一方の [セル参照] パラメータが指定されていない場合は、#ERR が返されます。

Authorize 関数の出力

結果

承認を実行するラベル付きボタン [image] コントロール。

関連項目

  • 承認プロセス
  • [監査メッセージの設定] ダイアログ
  • シンボリックタグエディタ
  • Authorize データアクセス関数
  • オペレータ I/F 関数について
  • 画面表示関数について
  • プロパティシートの使用方法
Version: 5.6.0


Button 関数

Button 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

ラベル付きプッシュボタンコントロールをスプレッドシートに挿入します。オプションで、スプレッドシートのイベントのトリガの信号を送信するように、ボタンの押下を設定することができます。

Button 関数 (

名前 ,

トリガ

)

ヒント: Button 関数のプロパティシートにアクセスするには、ボタンを右クリックして、[関数の編集] を選択します。

注:
  • ボタンコントロールは、In-Sight ネイティブモードコマンドを介して EV SetCellValue コマンドを使用し、プログラム的に制御することができます。1 を入力するとボタンが押され、0 を入力するとボタンが放されます。ボタンを押した後に、ボタンを放すコマンドが送信されたことを確認します。送信されていないと、ボタンが押されたままのようになります。
  • ボタンをクリックすると、2 つのイベントが生成されます。ボタンを押すとボタンの状態は 0 から 1 に変化し、ボタンを放すと 1 から 0 に変化します。ボタンがソフトイベントを生成するように設定されている場合は、ボタンを押すと、イベントが一度だけトリガされます。

Button 関数の入力パラメータ

名前

テキスト文字列ラベルを指定します。この名前は、ボタン自体に表示されます。

トリガ

オプションで、ボタンが押されたときに発生するトリガ信号を指定します。

-1 = なし (デフォルト) | トリガ信号は送られません。
32 = 手動 | 手動トリガをかけます。
(80 ～ 87) = ソフト (0 ～ 7) | ソフトトリガイベント信号が送られます。

Button 関数の出力

戻り値 | ボタンが押されると 1 の値を、押されていない場合は 0 の値を返します。
結果 | ラベル付きボタン [image] コントロール。

Button 関数例

  1. セル A3 および が次のように設定されていると仮定します。

A3=Button("Test",-1)

A4=Count(A3,9999999,0,0)

スプレッドシートには次のように表示されます。

  2. セル A3 にあるボタンを押します。セル A4 がセル A3 を参照し、[テスト] ボタンが押された回数をカウントします。セル A4 内の値は、現在 1.000 となっています。

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


CheckBox 関数

CheckBox 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

ラベル付きチェックボックスコントロールをスプレッドシートに挿入します。

CheckBox 関数 (

名前

)

注: CheckBox 関数のプロパティシートにアクセスするには、CheckBox 関数を右クリックして [関数の編集] を選択します。

CheckBox 関数の入力パラメータ

名前

CheckBox 関数の隣に表示するテキスト文字列ラベルを指定します。

CheckBox 関数の出力

戻り値 | オフ (チェックされていない) の場合は 0 の値、オン (チェックされている) の場合は 1。
結果 | ラベル付きチェックボックス [image] コントロール。

CheckBox 関数例

スプレッドシートが次のように設定されています。

A3=CheckBox("On")

A4=A3

セル A4 はセル A3 を参照して、[On] チェックボックスのオン/オフを指定します。このチェックボックスをオフにすると、セル A4 に 0.000 の値が返されます。このチェックボックスをオンにすると、1.000 の値が返されます。

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


Dialog 関数

画面表示関数 → オペレータ I/F

In-Sight 関数リファレンス

ダイアログボックスコントロールをスプレッドシートに挿入します。ダイアログにはスプレッドシート上には表示されない特殊なセルが含まれます (400 行目から始まる)。ダイアログにはテキストや値、および選択したオペレータ I/F、数学、文字列操作、入出力、クロックド・データ、データ・アクセスなどの関数が含まれています。ダイアログは最大 20 個までスプレッドシートに挿入でき、Wizard 関数を使用して複数のダイアログを関連付けることができます。ダイアログの実行には、ユーザが手動で操作する場合と Select 関数が参照したときに自動的に実行させる場合の 2 つの方法があります。

Dialog 関数(

ラベル,

ダイアログタイトル,

高さ,

幅

)

注:

  • デフォルトでは、ジョブ内のすべての Dialog 関数に [キャンセル] ボタンが含まれます。Dialog 関数から [キャンセル] ボタンを除外するには、[Dialog 関数キャンセル表示] センサメニューオプションを無効にします。
  • Dialog 関数のプロパティシートにアクセスするには、ダイアログコントロールを右クリックして、[関数の編集] を選択します。
  • コピーしたダイアログコントロールを、複数のセルに貼り付けることはできません。
  • ダイアログを貼り付ける場合、すべてのセル参照は、絶対参照になります。
  • ダイアログを 1 つのジョブから別のジョブに貼り付けると、ダイアログコントロールはコピーされますが、ダイアログの内容はコピーされません。
  • グラフは Dialog 関数ではサポートされていません。
  • ダイアログ内のボタン ([OK]、[次へ]、[キャンセル] など) がダイアログ起動時のセルと同じ位置にある場合、マウスクリックを離すと、ダイアログ内でこのボタンがアクティブになります。また、1 つのセルでダイアログの高さを増減するか、セルをハイライトしてから Enter キーを押し、ダイアログを起動する方法もあります。

  • Dialog 関数のダイアログの [タイトル] パラメータが、ダイアログ内に編集可能な文字列値 (EditString、ListBox または Concatenate など) を含むセルを参照している場合 (必要に応じて GetString 関数を使用)、セルの値を変更すると、セルはただちに更新されて新しい値が表示されます。ただし、ダイアログのタイトルには古い値が表示されたままです。ダイアログのタイトルは、そのダイアログを再度開いたときに更新されます。また、モードが 1 (シーケンシャル) に設定された Wizard 関数によってダイアログが参照される場合、セルの文字列値を変更してもウィザードのメニューには古い値が表示されたままです。ウィザードのメニューは、そのウィザードを再度開いたときに更新されます。

Dialog 関数入力パラメータ

ラベル | スプレッドシートに表示される名前を指定します。
ダイアログタイトル | ダイアログのタイトルバーに表示される名前を指定します (最大 39 文字)。
高さ | ダイアログの高さをセルの数で指定します (1 ～ 20、デフォルト = 5)。
幅 | ダイアログの幅をセルの数で指定します (3 ～ 10、デフォルト = 5)。

Dialog 関数出力

戻り値 | ダイアログが表示される場合は 1、表示されない場合は 0 を返します。
結果 | ラベル付きダイアログ [image] コントロール。

Dialog 関数例

スプレッドシートが次のように設定されています。

A4 = Dialog("テスト","テストダイアログ",5,5)

セル A4 のダイアログ [image] コントロールをクリックすると、次のダイアログが表示されます。

テキストラベル、数値、式などを、スプレッドシートに挿入する場合と同様に、ダイアログに挿入することができます。

ダイアログのメニューバーのオプション

[ファイル] メニューオプション

セルのインポート

セルのエクスポート

ページ設定

印刷プレビュー

印刷

[編集] メニューオプション

元に戻す

やり直し

切り取り

コピー

貼り付け

クリア

検索

進む

セルのグラフィックス

領域の最大化

セル状態

[表示] メニュー

ツールバー (標準、フォーマット、ジョブの編集、数式バー)

グリッドライン

[挿入] メニュー

関数

絶対参照

相対参照

コメント

シンボリックタグ

[フォーマット] メニュー

セル

行 (行の高さ、自動調節)

列 (列の幅、自動調節)

ダイアログツールバーのボタン

ボタン | 機能
 | 印刷
 | 印刷プレビュー
 | 切り取り
 | コピー
 | 貼り付け
 | 元に戻す
 | やり直し
 | 検索
 | 太字
 | 斜体
 | 左揃え
 | 中央揃え
 | 右揃え
 | 小数点以下の桁数の増加
 | 小数点以下の桁数の縮小
 | 背景色
 | 前景色
 | 絶対参照
 | 相対参照
 | 関数の挿入
 | セルのグラフィックス
 | 領域の最大化
 | セル状態
 | コメント
 | シンボリックタグ
 | OK
 | キャンセル
 | 数式バー

関連項目

Link 関数

Select 関数

Wizard 関数

オペレータ I/F 関数について

プロパティシートの使用方法


EditAnnulus 関数

EditAnnulus 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型円環コントロールをスプレッドシートに挿入します。コントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで円環の位置とサイズを調整することができます。

EditAnnulus 関数 (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

移動,

サイズ,

名前,

表示

)

注:
  • EditAnnulus 関数のプロパティシートにアクセスするには、EditAnnulus コントロールを右クリックして [関数の編集] を選択します。
  • [外部定義領域] パラメータ (例えば ExtractBlobs 関数) が、[内半径] パラメータがゼロに設定されている EditAnnulus 関数を参照する場合、#ERR が返されることがあります。この状況では、EditAnnulus 関数ではなく EditCircle 関数を使用します。

EditAnnulus 関数の入力パラメータ

画像 このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力円環を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

移動

入力円環の位置を調整する機能を有効または無効にします。

0 = OFF | 円環を移動することはできません。
1 = ON (デフォルト) | 円環を移動することができます。

サイズ

入力円環の半径を調整する機能を有効または無効にします。

0 = OFF | 円環のサイズを変更することはできません。
1 = ON (デフォルト) | 円環のサイズを変更することができます。

注: 円環の内側の半径または外側の半径を調整することができます。

名前

スプレッドシート内の EditAnnulus コントロール要素のテキストラベルを指定します。

表示

画像上の EditAnnulus グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditAnnulus 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、円環は表示されません。
2 = 入力のグラフィックスのみ | 円環が常に表示されます。

EditAnnulus 関数の出力

結果

EditAnnulus [image] コントロールの右に隣接するセルに、自動的に結果テーブルが作成されます。

EditAnnulus 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(Annulus) | 画像座標系での、円環の中心の行オフセット
列 | GetCol(Annulus) | 画像座標系での、円環の中心の行オフセット
内側の半径 | GetRadius(Annulus, 0) | 円環の内側の半径
外側の半径 | GetRadius(Annulus, 1) | 円環の外側の半径


EditCircle 関数

EditCircle 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型円コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで円の位置とサイズを調整することができます。

EditCircle 関数 (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

移動,

サイズ,

名前,

表示

)

注: EditCircle 関数のプロパティシートにアクセスするには、EditCircle コントロールを右クリックして [関数の編集] を選択します。

EditCircle 関数の入力パラメータ

画像 このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力円を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

移動

入力円の位置を調整する機能を有効または無効にします。

0 = OFF | 円を移動することはできません。
1 = ON (デフォルト) | 円を移動することができます。

サイズ

入力円の半径を調整する機能を有効または無効にします。

0 = OFF | 円のサイズを変更することはできません。
1 = ON (デフォルト) | 円のサイズを変更することができます。

名前

スプレッドシート内の EditCircle コントロール要素のテキストラベルを指定します。

表示

画像上の EditCircle グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditCircle 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、円は表示されません。
2 = 入力のグラフィックスのみ | 円が常に表示されます。

EditCircle 関数の出力

結果

EditCircle [image] コントロールの右に隣接するセルに、自動的に結果テーブルが作成されます。

EditCircle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(領域) | 位置の X 座標。
列 | GetCol(領域) | 位置の Y 座標。
半径 | GetRadius(領域) | 円の半径


EditCompositeRegion 関数

EditCompositeRegion 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型合成領域コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで合成領域を変更することができます。合成領域は複数のサブ領域で構成することができます。円環、円、ポリゴン、または領域をサブ領域とすることができます。各サブ領域は、追加操作 (画像解析に含められる) または減算操作 (画像解析から除外される) です。減算操作は「マスキング」としても知られています。

EditCompositeRegion 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

サブ領域の追加,

サブ領域の削除,

サブ領域の編集

合成領域全体の移動,

回転,

名前,

表示

)

注:
  • EditCompositeRegion 関数のプロパティシートにアクセスするには、EditCompositeRegion コントロールを右クリックして [関数の編集] を選択します。
  • 最大 32 までのサブ領域を、合成領域に追加することができます。
  • 右 Closed クリックメニューが対話型グラフィックスモードの場合に使用でき、サブ領域の追加や削除、または選択したサブ領域の操作 (追加または減算) の変更を行うことができます。

[全般] タブ

[全般] タブを使用して、EditCompositeRegion 関数のパラメータを定義します。

EditCompositeRegion 関数の入力パラメータ

画像 | このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

サブ領域の追加

これをオンにすると、対話型グラフィックスモードでサブ領域を追加することができます。

サブ領域の削除

これをオンにすると、対話型グラフィックスモードでサブ領域を削除することができます。

サブ領域の編集

これをオンにすると、対話型グラフィックスモードでサブ領域を変更することができます。

合成領域全体の移動

これをオンにすると、対話型グラフィックスモードで合成領域全体を移動することができます。
回転 | これをオンにすると、対話型グラフィックスモードで合成領域全体を回転することができます。

名前

スプレッドシート内の EditCompositeRegion コントロール要素のテキストラベルを指定します。

表示

画像上の EditCompositeRegion グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditCompositeRegion 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、その合成領域は表示されません。
2 = 入力のグラフィックスのみ | 合成領域が常に表示されます。

[領域] タブ

[領域] タブでは、サブ領域の挿入、削除、および編集を行うことができます。円環、円、ポリゴン、または領域をサブ領域とすることができ、これらを使用して追加または減算操作を実行します。

[領域] タブの設定項目

  • [挿入]: 円環、円、ポリゴン、または領域のサブ領域を挿入することができます。
  • [削除]: ハイライトしたサブ領域をリストから削除します。
  • [上に移動]: ハイライトしたサブ領域をリストの上に移動します。
  • [下に移動]: ハイライトしたサブ領域をリストの下に移動します。

注: 合成領域は、リスト内でのサブ領域の順番に基づいて、順番に構築されます。

  • [サブ領域のプロパティ]: ハイライトしたサブ領域のプロパティを表示します。

EditCompositeRegion 関数の出力

結果

ラベル付きボタン [image] コントロール。

EditCompositeRegion 関数例

EditCompositeRegion プロパティシートを開く

  1. セル A2 を右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [グラフィックス] リストを展開します。
  3. [コントロール] ツールカテゴリを選択します。
  4. 関数リストから EditCompositeRegion 関数を選択して、[OK] ボタンを押すか、関数名をダブルクリックします。

  5. EditCompositeRegion プロパティシートが開きます。

[全般] タブ

  1. オプションで、[フィクスチャ] パラメータを展開して、[行]、[列]、および [角度] の値を指定します。フィクスチャに関連する合成領域を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して合成領域を確実に回転または移動できます。

  2. 対話型グラフィックスモードで許可するアクションを指定し (サブ領域の追加、削除、編集、および合成領域全体の移動と回転)、該当するチェックボックスをオンまたはオフにします ([サブ領域の追加]、[サブ領域の削除]、[サブ領域の編集]、[合成領域全体の移動]、および [回転])。
  3. オプションで、スプレッドシート内の EditCompositeRegion コントロール要素のテキストラベルの名前を指定します。
  4. いつオーバレイグラフィックスを表示するかを指定します。スプレッドシート内で EditCompositeRegion 関数を含むセルがハイライトされている場合を除いて、オーバレイグラフィックスを表示しない場合は、[表示] ドロップダウンリストから [非表示] を選択します。オーバレイグラフィックスを常に表示する場合は、[入力のグラフィックスのみ] を選択します。

[領域] タブ

  1. デフォルトでは、[領域] は自動的にサブ領域のリストに含まれます。例えば、円サブ領域が使用される場合に、[領域] をハイライトして [削除] ボタンをクリックします。

  2. [挿入] ドロップダウンリストから [円] を選択して、[円] サブ領域を追加します。
  3. [グラフィックスの編集] [image] ツールバーボタンをクリックして、サブ領域をグラフィカルに調整します。

注: 別の方法としては、サブ領域をハイライトして、手動で [円] プロパティを入力します。

  4. デフォルトでは、[円] は追加操作を使用しています。必要に応じて [円] を調整して、対象領域を覆うようにします。

  5. 画像領域内を右クリックして、[サブ領域の追加] → [円] をクリックし、2 番目の [円] サブ領域を追加します。

  6. デフォルトでは、2 番目の [円] は減算操作を使用しています。必要に応じて [円] を調整して、検査に含めない必要がある画像の部分をマスクします。

  7. 変更を受け入れる場合は、Enter キーを押します。画像上にグラフィックスが表示されますが、その位置は半透明のスプレッドシートの下です。変更をキャンセルする場合は、Esc キーを押します。変更を受け入れると、自動的に新しい値がプロパティシートに入力されます。
  8. この例では、ExtractBlobs 関数を使用して、マスクされていないサブ領域上でブロブ分析を実行します。ExtractBlobs 関数をセル A4 に挿入します。
  9. ExtractBlobs パラメータの設定[外部定義領域] パラメータで、EditCompositeRegion 関数を含んでいるセル A2 を指定します。ExtractBlobs 関数は、マスクされていない領域で検出されたブロブのみを探します。


EditFloat 関数

EditFloat 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

浮動小数点編集コントロールをスプレッドシートに挿入します。このコントロールは、他の対話型数値入力コントロールと同じように動作します。

EditFloat 関数 (

最小,

最大

)

注: EditFloat コントロールのプロパティシートにアクセスするには、コントロールを右クリックして、[関数の編集] を選択します。

EditFloat 関数の入力パラメータ

最小 | 編集ボックスコントロールが受け入れる最小値を指定します (-9999999 ～ 9999999、デフォルト = 0)。
最大 | 編集ボックスコントロールが受け入れる最大値を指定します (-9999999 ～ 9999999、デフォルト = 100)。

EditFloat 関数の出力

戻り値 | コントロールに入力した値。
結果 | EditFloat [image] コントロール。

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


EditInt 関数

EditInt 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

整数編集コントロールをスプレッドシートに挿入します。このコントロールは、他の In-Sight 対話型数値入力コントロールと同じように動作します。

EditInt 関数 (

最小 ,

最大

)

注: EditInt コントロールのプロパティシートにアクセスするには、コントロールを右クリックして、[関数の編集] を選択します。

EditInt 関数の入力パラメータ

最小 | 編集ボックスコントロールが受け入れる最小値を指定します (-9999999 ～ 9999999、デフォルト = 0)。
最大 | 編集ボックスコントロールが受け入れる最大値を指定します (-9999999 ～ 9999999、デフォルト = 255)。

EditInt 関数の出力

戻り値 | コントロールに入力した値。
結果 | EditInt [image] コントロール。

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


EditLine 関数

EditLine 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型線コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで線の位置とサイズを調整することができます。

EditLine 関数 (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

Move Point 0,

Move Point 1,

名前,

表示

)

注: EditLine 関数のプロパティシートにアクセスするには、EditLine コントロールを右クリックして [関数の編集] を選択します。

EditLine 関数の入力パラメータ

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

入力線を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

Move Point 0

入力点 0 の位置を調整する機能を有効または無効にします。

0 = OFF | 点 0 を移動することはできません。
1 = ON (デフォルト) | 点 0 を移動することができます。

Move Point 1

入力点 1 の位置を調整する機能を有効または無効にします。

0 = OFF | 点 1 を移動することはできません。
1 = ON (デフォルト) | 点 1 を移動することができます。

Name

スプレッドシート内の EditLine コントロール要素のテキストラベルを指定します。

Show

画像上の EditLine グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditLine 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、線は表示されません。
2 = 入力のグラフィックスのみ | 線が常に表示されます。

EditLine 関数の出力

結果

EditLine [image] コントロールの右に隣接するセルに、自動的に結果テーブルが作成されます。

EditLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Line,0) | 画像座標での、始点の行オフセット
列 0 | GetCol(Line,0) | 画像座標での、始点の列オフセット
行 1 | GetRow(Line,1) | 画像座標での、終点の行オフセット
列 1 | GetCol(Line,1) | 画像座標での、終点の列オフセット


EditMaskedRegion 関数

EditMaskedRegion 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

領域コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで合成領域を変更することができます。ROI 内のマスクされている領域を使用して、処理すべきでない画像の領域を指定します。

EditMaskedRegion 関数 の入力パラメータ

EditMaskedRegion 関数 の出力

EditMaskedRegion 関数対話型グラフィックスモード

EditMaskedRegion 関数マウスの操作

EditMaskedRegion 関数 関連項目

EditMaskedRegion (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

マスク追加,

マスク削除,

マスク編集

移動,

サイズ,

回転,

カーブ,

名前,

表示

)

注:
  • EditMaskedRegion 関数のプロパティシートにアクセスするには、EditMaskedRegion コントロールを右クリックして [関数の編集] を選択します。
  • 対話型グラフィックスモードでは右クリックメニューが使用可能であり、領域を追加または削除することができます。

EditMaskedRegion 関数の入力パラメータ

画像 | このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

マスク追加

これをオンにすると、対話型グラフィックスモードでマスクを追加することができます。

マスク削除

これをオンにすると、対話型グラフィックスモードでマスクを削除することができます。

マスク編集

これをオンにすると、対話型グラフィックスモードでマスクを編集することができます。

移動

これをオンにすると、対話型グラフィックスモードで合成領域全体を移動することができます。
サイズ | これをオンにすると、対話型グラフィックスモードで領域のサイズを変更することができます。
回転 | これをオンにすると、対話型グラフィックスモードで領域を回転することができます。
カーブ | これをオンにすると、対話型グラフィックスモードで領域を曲げることができます。

名前

スプレッドシート内の EditMaskedRegion コントロール要素のテキストラベルを指定します。

表示

画像上の EditMaskedRegion グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditMaskedRegion 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、その領域は表示されません。
2 = 入力のグラフィックスのみ | 領域が常に表示されます。

EditMaskedRegion 関数の出力

結果

EditRegion [image] コントロール。

EditMaskedRegion 関数対話型グラフィックスモード

項目 | コントロール | 説明
1 | サイズ変更可能な終点の境界 (x4) | 矩形領域の 4 つの角を定義します。終点の境界をクリックして、ROI をその角の 1 つからサイズ変更します。
2 | マスク | 画像解析を受けない画像の領域を定義します。ROI 内でマスクを移動して、サイズを変更することができます。合計 99 のマスクを ROI に追加することができます。マスクを追加すると、ROI の最初 (ほかにマスクが追加されていない場合)、または以前に追加されたマスクの後ろに追加されます。 注: マスクをオーバーラップさせることはできません。オーバーラップするように設定した場合には、自動的にピクセルバッファ 1 が挿入され、オーバーラップしないよう防ぎます。
3 | スキャン方向インジケータ (x2) | ROI で特徴をスキャンする方向を定義します。
4 | エッジ検出インジケータ | エッジ遷移を検出する ROI 内の領域を定義し、ROI への新しいマスクの追加も有効にします。
5 | 回転ハンドル | ROI を 360° 回転させることができます。
6 | 曲げハンドル | ROI を曲げて、円弧または円環の形状にすることができます。

EditMaskedRegion 関数マウスの操作

ROI のさまざまな部分にマウスカーソルを置くと、マウスカーソルが自動的に変換され、次のアクションが有効になります。

マウスアイコン | 説明
 | ROI を画像内の任意の位置にドラッグすることができます。
 | ROI のサイズを水平方向または垂直方向に変更することができます。マスクのサイズ変更にも使用することができます。
 | マウスカーソルの配置場所に応じて、2 つの別々のアクションを実行することができます。マウスカーソルを回転ハンドル上に配置すると、ROI をその現在の方向から 360° 回転させることができます。マウスカーソルを曲げハンドル上に配置すると、ROI の形状を円弧または円環に変更することができます。
 | ROI 内でマスクをドラッグすることができます。
 | マスクを ROI に追加したり、ROI から削除したりすることができます。このアイコンが表示されたら、マウスを右クリックして、次の 2 つの部分を含むメニューを開きます。[マスク追加] または [マスク削除] です。

関連項目

オペレータ I/F 関数について

画面表示関数について

InspectEdge 関数

Structures データアクセス

プロパティシートの使用方法


EditMultiGraphics 関数

EditMultiGraphics 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

オペレータ I/F (EditAnnulus、EditCircle、EditCompositeRegion、EditLine、EditMaskedRegion、EditPoint、EditPolygon、EditPolylinePath、EditRegion) 関数の変数リストを操作するため、対話型コントロールをスプレッドシートに挿入します。コントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで参照されているオペレータ I/F 関数のすべての位置を調整することができます。各オペレータ I/F 関数は個別に編集する必要があります (その他のオペレータ I/F 関数のグラフィックスオーバレイはすべて、表示されたままです)。

EditMultiGraphics 関数 (

画像,

名前,

ラベルの表示,

エディットコントロール 0,

エディットコントロール 1,

...

)

注:
  • 対話型グラフィックスモードに切り替えてオペレータ I/F 関数の対象領域を調整したら、[ジョブの編集] ツールバーにある [OK] ボタンを押すか、Enter キーを押して変更を受け入れます。変更を受け入れずに対話型グラフィックスモードを終了する場合は、[ジョブの編集] ツールバーの [キャンセル] ボタンを押します。
  • EditMultiGraphics 関数にはプロパティシートはなく、3 つのパラメータおよび既存のオペレータ I/F 関数を参照する引数の変数リストに基づいています。
  • セルに入力できるセルの長さの最大値は 255 文字です。255 を超える文字を使用して可変引数を指定すると、エラーメッセージが表示されます。文字列を使用して可変引数を指定する場合は、セル範囲を使用します。
  • EditMultiGraphics 関数は、その変数リストで、#ERR であるか条件的に無効の関数は無視し、編集可能なオペレータ I/F 関数のみを表示します。
  • 参照されているオペレータ I/F 関数のオーバレイグラフィックスを表示するには、常にオーバレイグラフィックスが表示されるように、参照されている関数の [表示] パラメータを設定します。それ以外の場合は、EditMultiGraphics 関数がハイライトされているか、オーバレイグラフィックスを含んでいる個々のセルがハイライトされている場合にのみ、オーバレイグラフィックスが表示されます。

EditMultiGraphics 関数の入力パラメータ

画像

このパラメータは、スプレッドシートで　 [image] 　データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

注: EditMultiGraphics 関数は、参照しているオペレータ I/F 関数と同じ画像参照を共有する必要があります。EditMultiGraphics 関数が参照しているオペレータ I/F 関数の 1 つ以上が同じ画像参照を共有していない場合には、#ERR 状態となります。

名前

スプレッドシート内の EditMultiGraphics コントロール要素のテキストラベルを指定します。

ラベルの表示

画像上の EditMultiGraphics ラベルの表示モードを指定します。

0 = 非表示 | EditMultiGraphics 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、ラベルは表示されません。
1 = 入力のグラフィックスのみ | ラベルが常に表示されます。
エディットコントロール 0

オペレータ I/F 関数のセル参照を指定します。EditMultiGraphics 関数は次のオペレータ I/F 関数をサポートしています。EditAnnulus、EditCircle、EditCompositeRegion、EditLine、EditMaskedRegion、EditPoint、EditPolygon、EditPolylinePath、および EditRegion。

注: 参照可能なオペレータ I/F 関数の最大数は、次のどのシナリオのいずれが先に実行されるかによって決まります。関数が受け入れられるセル参照の最大数 (255 参照)、またはセルの式の最大文字数 (255 文字) です。
エディットコントロール 1 オペレータ I/F 関数のセル参照を指定します。

EditMultiGraphics 関数の出力

結果

EditMultiGraphics [image] コントロール。サポート対象のオペレータ I/F 関数を含んでいないセルをこの関数が参照している場合、または EditMultiGraphics 関数の画像参照が、参照されているオペレータ I/F 関数の画像参照と一致しない場合には、#ERR が返されます。

関連項目

オペレータ I/F 関数

EditAnnulus 関数

EditCircle 関数

EditCompositeRegion 関数

EditLine 関数

EditMaskedRegion 関数

EditPoint 関数

EditPolygon 関数

EditPolylinePath 関数

EditRegion 関数


EditPassword 関数

EditPassword 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

テキスト編集コントロールをスプレッドシートに挿入します。セキュリティの目的から、入力されるテキスト文字列は常にアスタリスクで表示されます。EditPassword コントロールは、他の対話型テキスト入力ボックスと同じように機能します。

EditPassword 関数 (

最大文字列長

)

注:

  • EditPassword コントロールのプロパティシートにアクセスするには、この関数をスプレッドシートに挿入し、コントロールを右クリックして [関数の編集] を選択します。
  • このテキスト文字列では大文字と小文字が区別されます。
  • 表示されるアスタリスクの数は、Max String Length パラメータで指定された値と同じです。

EditPassword 関数の入力パラメータ

最大文字列長

編集ボックスコントロールが受け入れる最大文字列長 (文字数) を指定します (1 ～ 255、デフォルト = 8)。

EditPassword 関数の出力

戻り値 | このコントロールに入力されたテキスト文字列は、アスタリスクで表示されます。 注: アスタリスクのみが表示されますが、EditPassword 関数を参照しているセルでは、実際の文字列を受け取って表示します。
結果 | EditPassword コントロール。

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


EditPoint 関数

EditPoint 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型点コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで点の位置を調整することができます。

EditPoint 関数 (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

移動,

名前,

表示

)

注: EditPoint 関数のプロパティシートにアクセスするには、EditPoint コントロールを右クリックして [関数の編集] を選択します。

EditPoint 関数の入力パラメータ

画像 このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力点を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

移動

入力点の位置を調整する機能を無効または有効にします。

0 = OFF | 入力点を移動することはできません。
1 = ON (デフォルト) | 入力点を移動することができます。

名前

スプレッドシート内の EditPoint コントロール要素のテキストラベルを指定します。

表示

画像上の EditPoint グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditPoint 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、点は表示されません。
2 = 入力のグラフィックスのみ | 点が常に表示されます。

EditPoint 関数の出力

結果

EditPoint [image] コントロールの右に隣接するセルに、自動的に結果テーブルが作成されます。

EditPoint 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(Line) | 画像座標での行オフセット。
列 | GetCol(Line) | 画像座標での列オフセット。


EditPolygon 関数

EditPolygon 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型ポリゴンコントロールをスプレッドシートに挿入します。初めてセルに挿入したときに、関数のプロパティシートが表示されます。[点] タブに移動して [image] [グラフィックスの編集] メニューオプションを有効にし、対話型グラフィックスモードに切り替えます。

  • EditPolygon の入力パラメータ
    • EditPolygon の入力パラメータ - [全般] タブ
    • EditPolygon の入力パラメータ - [点] タブ
  • EditPolygon の出力

注: EditPolygon 関数を設定した後にそのプロパティシートにアクセスするには、 [image] データ構造体を右クリックして [関数の編集] を選択します。 データ構造体をダブルクリックして、表示を対話型グラフィックスモードに切り替え、そこでポリゴンをグラフィカルに変更します。

EditPolygon 関数の入力パラメータ

EditPolygon (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

Add Points,

Remove Points,

Move Points,

Move Entire Polygon,

スケール,

回転,

名前,

表示

)

[全般] タブ

画像

このパラメータは、スプレッドシートで　 [image] 　データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

入力ポリゴンを定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

Add Points

これをオンにすると、グラフィックス編集でポリゴンに点を追加することができます。

Remove Points

これをオンにすると、グラフィックス編集でポリゴンから点を削除することができます。

注: 点を削除するには、Shift キーを押しながら、削除する点をクリックします。

Move Points

これをオンにすると、グラフィックス編集でポリゴン内から点を移動することができます。

Move Entire Polygon

これをオンにすると、グラフィックス編集でポリゴン全体を移動することができます。

スケール

これをオンにすると、グラフィックス編集でポリゴンをスケーリングすることができます。

回転

これをオンにすると、グラフィックス編集でポリゴンを回転することができます。

名前

スプレッドシート内の EditPolygon コントロール要素のテキストラベルを指定します。

表示

画像上の EditPolygon グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditPolygon 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、ポリゴンは表示されません。
2 = 入力のグラフィックスのみ | ポリゴンが常に表示されます。

[点] タブ

EditPolygon 関数の [点] タブは、点の数およびそれらの行/列の位置を一覧表示する表で構成されており、表の右側にある [行] および [列] 編集コントロールを使用して、手動で指定することができます。[挿入] ボタンを押して点を追加します。

デフォルトでは、ポリゴン形状は 3 つの点で構成されます。4 つ以上の点がある場合は [削除] ボタンが有効になるので、これを使用してポリゴンから点を削除します。

EditPolygon の出力

結果

データ構造体。


EditPolylinePath 関数

EditPolylinePath 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型合成 1 次元ポリライン領域コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここでポリラインを変更することができます。

EditPolylinePath 関数の入力パラメータ

EditPolylinePath 関数の出力

EditPolylinePath 関数対話型グラフィックスモード

EditPolylinePath 関数マウスの操作

EditPolylinePath 関数右クリックコンテキストメニュー

EditPolylinePath 関数関連項目

EditPolylinePath (

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

セグメントの追加,

セグメントの削除,

セグメントの編集,

移動

サイズ,

回転,

名前,

表示

)

注:
  • EditPolylinePath 関数のプロパティシートにアクセスするには、EditPolylinePath コントロールを右クリックして [関数の編集] を選択します。
  • グラフィックス編集では右クリックメニューが使用可能であり、パスセグメントの追加およびパスセグメントの削除を行うことができます。
  • InspectEdgeForDefect 関数は、EditPolylinePath 関数を外部定義領域として使用する InspectEdge 関数と組み合わせて使用することはできません。
  • EditPolylinePath 関数では [領域の最大化] ボタンは無効になっています。

EditPolylinePath 関数の入力パラメータ

画像 | このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

セグメントの追加

これをオンにすると、対話型グラフィックスモードでポリラインに点を追加することができます。

セグメントの削除

これをオンにすると、対話型グラフィックスモードで点を削除することができます。
セグメントの編集 | これをオンにすると、対話型グラフィックスモードで点を移動することができます。

移動

これをオンにすると、対話型グラフィックスモードでポリラインパス全体を移動することができます。

サイズ

これをオンにすると、対話型グラフィックスモードでポリラインパス全体をスケーリングすることができます。
回転 | これをオンにすると、対話型グラフィックスモードでポリラインパス全体を回転することができます。

名前

スプレッドシート内の EditPolylinePath コントロール要素のテキストラベルを指定します。

表示

画像上の EditPolylinePath グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | EditPolylinePath 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、その合成領域は表示されません。
2 = 入力のグラフィックスのみ | 合成ポリラインパスが常に表示されます。

EditPolylinePath 関数の出力

結果

EditRegion [image] コントロール

EditPolylinePath 関数対話型グラフィックスモード

項目 | コントロール | 説明
1 | 終点 | ポリラインの最初と最後の点を定義します。三角形は、ポリラインパスの方向を示しています。
2 | スキャン方向インジケータ | ポリラインで特徴をスキャンする方向を定義します。
3 | ポリラインパス | ポリラインのプロットをグラフィカルに表示します。
4 | 回転ハンドル | ROI を 360° 回転させることができます。
5 | ポリラインパスの頂点 | ポリラインセグメントのパスを定義します。頂点をクリックして、ポリラインを配置します。

EditPolylinePath 関数マウスの操作

ROI のさまざまな部分にマウスカーソルを置くと、マウスカーソルが自動的に変換され、次のアクションが有効になります。

マウスアイコン | 説明
 | ROI 全体を画像内の任意の位置にドラッグすることができます。
 | ROI 全体を水平方向または垂直方向にスケーリングするか、ポリラインを囲む ROI を水平方向または垂直方向にスケーリングすることができます。
 | ROI 全体を現在の方向から 360° 回転することができます。
 | ROI 内でポリラインを移動することができます。
 | ポリラインパスに点を追加することができます。最大 99 個の点をポリラインに追加することができます。99 個の点がポリラインに追加されると、このオプションは無効になります。

EditPolylinePath 関数右クリックコンテキストメニュー

右クリックの位置 コンテキストメニュー
点上
  • 点を削除
  • 前の点を削除
  • 後の点を削除
エッジ上
  • 点の挿入

関連項目

オペレータ I/F 関数について

画面表示関数について

InspectEdge 関数

Structures データアクセス

プロパティシートの使用方法


EditRegion 関数

EditRegion 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

対話型グラフィックス領域コントロールをスプレッドシートに挿入します。このコントロールをクリックすると、表示が対話型グラフィックスモードに切り替わり、ここで領域のサイズ、位置、回転、および湾曲を調整することができます。

EditRegion 関数 (

画像,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

移動 ,

サイズ ,

回転 ,

屈曲 ,

名前 ,

表示

)

注: EditRegion コントロールのプロパティシートにアクセスするには、コントロールを右クリックして、[関数の編集] を選択します。

EditRegion 関数の入力パラメータ

画像 このパラメータは、 [image] データ構造体を含むスプレッドシートセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage　 [image] 　データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数や、座標補正関数により返された、そのほかの [image] データ構造体も参照することができます。

フィクスチャ

入力領域を定義する画像座標系を指定します。

行 | 画像座標での行オフセット
列 | 画像座標での列オフセット
角度 | 画像座標での角度

移動

入力領域の位置を調整する機能を有効または無効にします。

0 = OFF | 領域を移動することはできません。
1 = ON (デフォルト) | 領域を移動することができます。

サイズ

入力領域の高さと幅を調整する機能を有効または無効にします。

0 = OFF | 高さと幅を調整することはできません。
1 = ON (デフォルト) | 高さと幅を調整することができます。

回転

入力領域の方向を調整する機能を有効または無効にします。

0 = OFF | 領域を回転することはできません。
1 = ON (デフォルト) | 領域を回転することができます。

屈曲

入力領域の湾曲の調整機能を有効または無効にします。

0 = OFF | 湾曲を変更することはできません。
1 = ON (デフォルト) | 湾曲を変更することができます。

名前

スプレッドシート内の EditRegion コントロール要素のテキストラベルを指定します。

表示

画像上の EditRegion グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | EditRegion 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、その領域は表示されません。
2 = 入力のグラフィックスのみ | 領域が常に表示されます。

EditRegion 関数の出力

結果

EditRegion [image] コントロール、および右側に隣接するセルに作成される、対応する結果テーブル。

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(領域) | 位置の X 座標。
列 | GetCol(領域) | 位置の Y 座標。
高さ | GetHigh(領域) | 領域の高さ。
幅 | GetWide(領域) | 領域の幅。
角度 | GetAngle(領域) | 領域の方向。
カーブ | GetCurve(領域) | 領域の湾曲。

関連項目

オペレータ I/F 関数について

画面表示関数について

Structures データアクセス

プロパティシートの使用方法


EditString 関数

EditString 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

テキスト編集コントロールをスプレッドシートに挿入します。EditString コントロールは、他の対話型テキスト入力ボックスと同じように機能します。

EditString 関数 (

最大文字列長

)

注: EditString コントロールのプロパティシートにアクセスするには、コントロールを右クリックして、[関数の編集] を選択します。

EditString 関数の入力パラメータ

最大文字列長

編集ボックスコントロールが受け入れる最大文字列長 (文字数) を指定します (1 ～ 255、デフォルト = 8)。

EditString 関数の出力

戻り値 | このコントロールに入力されたテキスト文字列
結果 | EditString コントロール

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


Link 関数

Link 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

ラベル付きリンクコントロールをスプレッドシートに挿入します。リンクコントロールは、HTML ブラウザのハイパーテキストリンクと概念的に類似しており、ネットワークに接続された In-Sight デバイス上のさまざまなスプレッドシートのセル間を移動する、高速の方法が備えられています。リンクの実行には、ユーザが手動で入力する場合と、Select 関数が参照したときに自動的に実行させる場合の 2 つの方法があります。

Link 関数(

ラベル,

ホスト名,

ダイアログラベル / セル,

カーソル位置

)

注:

  • リンクコントロールのプロパティシートにアクセスするには、コントロールを右クリックして、[関数の編集] を選択します。
  • Link 関数を使用して別のシステムにログオンすると、ターゲットシステム上でジョブを処理するための合計実行時間が長くなることがあります。この実行時間が、取り込みトリガ間の時間に近くなるか、これを超えると、一部のトリガが失敗することがあります。

Link 関数の入力パラメータ

ラベル

スプレッドシートに表示されるリンクコントロールの名前。

ホスト名

リンクしようとしている In-Sight センサのネットワークのホスト名。同じスプレッドシート内の位置間にリンクを設定する場合は、このパラメータを空白にします。

注:

  • ネットワークでリンクを設定するときには、アクティブなユーザのユーザ名とパスワードが、リンク先である In-Sight センサの [ユーザリスト] にある既存のユーザ名およびパスワードと完全に一致する必要があります。
  • 無効なホスト名を指定した場合、最大 30 秒後に接続はタイムアウトします。

ダイアログラベル / セル

リンクを開く既存のダイアログまたはウイザードコントロール、あるいはリンク先のスプレッドシートの左上隅に表示するスプレッドシートのセルへの参照。ウィザードコントロールのラベルが指定されている場合、リンクコントロールを実行すると、自動的にウィザードの最初のダイアログが開きます。

カーソル位置

リンク先でハイライトされるセルへの参照。

  • [Dialog Label] パラメータがウィザードコントロールを参照すると、[Cursor Position] は無視されます。
  • [Dialog Label] が有効であるものの、[Cursor Position] に指定されたセル参照がそのダイアログに含まれていない場合は、リンクコントロールを実行すると引き続きダイアログが開きます。
  • [Dialog Label] を指定しないままにしているか、無効である場合は、リンクコントロールを実行すると、現在のスプレッドシートの [Cursor Position] に移動します (定義済みの場合)。
  • [Dialog Label] または [Cursor Position] のいずれも無効の場合は、リンクコントロールを実行すると、現在のスプレッドシートのセル A0 に移動します。

Link 関数の出力

戻り値

実行すると、指定されたリンクの位置に移動する、ラベル付きリンク [image] コントロール。

注: リンクコントロールが宛先の有効なダイアログまたはウィザードに移動した場合は、ダイアログ/ウィザードを閉じるか終了すると、元のポイントに戻ります。

Link 関数例

例 1A: 現在のスプレッドシートのセルへのリンク設定

例 1B: 現在のスプレッドシートのセルへのリンク設定

例 2: 現在のスプレッドシートのダイアログへのリンク設定

例 3: ネットワーク上のダイアログへのリンク設定

例 1A: 現在のスプレッドシートのセルへのリンク設定

  1. セル M2 には、次が格納されていると仮定します。

M2 = Link("Jump","","","A5")

「Jump」というラベルが付いたリンクコントロールがセル M2 に表示されています。

  2. リンクコントロールをクリックして、関数を実行します。ハイライトされたカーソルがセル A5 に移動します。スプレッドシートの現在のビューでセル A5 が表示されない場合は、必要に応じて自動的にスプレッドシートが位置を変えて、セル A5 が表示されるようにします。

例 1B: 現在のスプレッドシートのセルへのリンク設定

  1. セル A2 には、次が格納されていると仮定します。

A2 = Link("Jump","","J5","L9")

「Jump」というラベルが付いたリンクコントロールがセル A2 に表示されています。

  2. リンクコントロールをクリックして、関数を実行します。ハイライトされたカーソルがセル L9 に移動し、左上のセルは J5 となります。

例 2: 現在のスプレッドシートのダイアログへのリンク設定

  1. セル A2 には、次が格納されていると仮定します。

A2 = Link("Jump","","Step 1","")

「Jump」というラベルが付いたリンクコントロールがセル A2 に表示されています。

  2. リンクコントロールをクリックして、関数を実行します。現在のスプレッドシートで「Step 1」というラベルが付いたダイアログが開きます。このダイアログが存在しない場合は、リンクコントロールを実行しても何も起こりません。

例 3: ネットワーク上のダイアログへのリンク設定

  1. セル A2 には、次が格納されていると仮定します。

A2 = Link("Jump","is5100_020304","Step 1","")

「Jump」というラベルが付いたリンクコントロールがセル A2 に表示されています。

  2. リンクコントロールをクリックして、関数を実行します。このリンクコントロールを実行すると、「is5100_020304」という名前のリモート In-Sight ホストへの自動ログオンが開始され ([ユーザリスト] ダイアログで定義された権限によって許可されている場合)、ここで「Step 1」というラベルが付いたダイアログが開きます。

  3. [OK] または [キャンセル] ボタンを押してリモートシステム上のダイアログを閉じ、リンクコントロールを開始したシステムに戻ります。

注: ダイアログではなくリモートシステム上のウィザードをリンクが参照する場合は、[完了] または [キャンセル] ボタンを押した場合にのみ、開始システムへの接続が復元されます。

関連項目

オペレータ I/F 関数について

画面表示関数について

Select 関数

Dialog 関数

Wizard 関数

プロパティシートの使用方法


ListBox 関数

ListBox 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

ドロップダウンリストコントロールをスプレッドシートに挿入します

ListBox 関数(

"String0",

["String1"],

["String2"],

...

)

注: ListBox 関数は文字列の可変数を受け入れることができるため、この関数はプロパティシートによって設定されません。この関数はセル、または [ジョブの編集] ツールバーの数式バーで直接設定できます。

ListBox 関数の入力パラメータ

String0, 1, 2, ...

個別のテキスト文字列の可変長リスト。ユーザがドロップダウンリストから選択すると、それぞれ異なる値を返します。

ListBox 関数の出力

戻り値 | 選択した項目のインデックス番号 (ゼロベース) を表す値
結果 | ListBox [image] コントロール 注: リストから現在選択されているテキスト文字列は、GetString データアクセス関数を使用してアクセスすることもできます。

ListBox 関数例

スプレッドシートが次のように設定されています。

A3=ListBox("Item1","Item2","Item3")

A4=A3

セル A3 内の関数は、デフォルトの選択が [Item1] であるリストコントロールを作成します。Item 1 のインデックス値は 0 なので、セル A4 の値は 0.000 となります。

ユーザが [Item2] を選択した場合は、セル A4 の値は 1.000 になります。ユーザが [Item3] を選択した場合は、セル A4 の値は 2.000 になります。

ListBox 関数データアクセス関数

次のデータアクセス関数を使用して、そのほかのデータエレメントの取得ができます。

GetString 関数

GetString(ListBox)

テキスト文字列を返します。

関連項目

オペレータ I/F 関数について

画面表示関数について


MessageBox 関数

MessageBox 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

ユーザ定義のテキスト文字列を含んでいる「ポップアップ」メッセージボックスを表示します。

MessageBox 関数 (

タイトル ,

テキスト ,

ステータス ,

タイムアウト ,

ボタンラベル

)

注: メッセージボックスコントロールのプロパティシートにアクセスするには、コントロールを右クリックして [関数] を選択します。

MessageBox 関数の入力パラメータ

タイトル

メッセージボックスのタイトルバーに表示される名前

テキスト

表示するテキストメッセージ

ステータス

メッセージボックスを表示する条件式または値を含んでいるセルへの参照。参照されたセル内の値が 0 と評価されている間は、メッセージボックスは表示されません。参照されたセル内の値がゼロ以外の値である場合は常に、メッセージボックスが表示されます。

タイムアウト

ユーザ入力が受け取られなかった場合、メッセージボックスが閉じられるまでに、メッセージボックスが待機する時間の合計 (-1 ～ 9999999 ms、デフォルト = 5000)。[タイムアウト] を 0 または -1 に設定した場合、メッセージボックスは、ユーザ入力が受け取られるまで無期限に表示されます。

ボタンラベル

メッセージボックスの下部に表示するユーザ入力ボタンのタイプを指定します。ボタンを押すと、メッセージボックスは表示されなくなり、関数が値を返します。返される値は押されたボタンによって異なります。

0 = はい、いいえ (デフォルト) | [はい] をクリックすると、1.000 の値が返されます。[いいえ] をクリックすると、0.000 の値が返されます。
1 = OK、キャンセル | [OK] をクリックすると、1.000 の値が返されます。[キャンセル] をクリックすると、0.000 の値が返されます。
2 = クローズ | [クローズ] をクリックすると、1.000 の値が返されます。

MessageBox 関数の出力

戻り値

ユーザがボタンをクリックした場合は 0.000 または 1.000 の値、指定された [タイムアウト] 時間に達した場合は -1.000。入力パラメータが無効であれば #ERR を返します。

MessageBox 関数例

スプレッドシートが次のように設定されています。

A2=MessageBox("警告!","これはメッセージボックスの例です。",B2,5000,1)

B2=CheckBox("テスト")

セル B2 内のチェックボックスをオンにすると、セル A2 に定義されているメッセージボックスが自動的に表示されます。

[OK] をクリックすると、セル A2.に 1.000 の値が返されます。[キャンセル] をクリックすると、セル A2 に 0.000 の値が返されます。ユーザ入力が受け取られる前に 5000 ミリ秒の [タイムアウト] に達した場合は、セル A2 に -1.000 の値が返されます。

関連項目

オペレータ I/F 関数について

画面表示関数について

プロパティシートの使用方法


Select 関数

Select 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

Select 関数は、インデックス付きセル参照の変数リストから選択された、スプレッドシートのセルに含まれるオペレータ I/F 関数を実行します。

注: Select 関数はダイアログを含むセルへの可変数の参照を受け入れられるため、この関数はプロパティシートによって設定されません。この関数はセル、または [ジョブの編集] ツールバーの数式バーで直接設定できます。

Select 関数の入力パラメータ

Select 関数(

タイトル,

インデックス,

自動,

コントロール　0,

[コントロール　1],

[コントロール　2],

...

)

タイトル

スプレッドシートで、Select [image] コントロールの隣に表示される Select 関数の名前。

インデックス

セル参照の変数リストから実行されるコントロールの位置番号 (ゼロから始まる) を指定します。最初のセル参照はインデックス 0、2 番目はインデックス 1 のように続きます。

自動

Select 関数を自動（スプレッドシートの別のセルに入っている条件値に応じて）および手動で実行可能にするか、または手動でのみ実行可能にするかを指定します。

0 = 手動 | インデックス付きセルのオペレータ I/F 関数は、Select 関数のボタンが押されたときのみ実行されます。
1 = 手動またはプログラム | インデックス付きセルのオペレータ I/F 関数は、Select 関数のボタンが押されたときのみ、またはインデックスの値が変更された場合に自動的に実行されます。

コントロール　0、1、2、...

OCRMaxAutoTune 関数、Dialog 関数、Wizard 関数、Link 関数、Button 関数または Select 関数が含まれる必要がある、スプレッドシートのセルに対する参照の可変長リスト。

Select 関数の出力

結果

セル参照のインデックス付きリストからオペレータ I/F 関数を実行するラベル付き Select [image] コントロール。

関連項目

  • Dialog 関数
  • Link 関数
  • Wizard 関数
  • Button 関数
  • オペレータ I/F 関数について
  • 画面表示関数について


Wizard 関数

Wizard 関数 |
画面表示関数 → オペレータ I/F | In-Sight 関数リファレンス

スプレッドシートにウィザードコントロールを挿入します。ウィザードでは Dialog 関数を含んでいる 2 つ以上のセルを参照し、一度に 1 段階ずつ移動したり、ポップアップメニューからアクセスしたりできるようにしたダイアログの集合体を作成します。シーケンシャルモードでのウィザード操作の最終ダイアログには [終了] ボタンが含まれます。このボタンは、各ダイアログで行った設定変更を確定します。

Wizard 関数(

名前,

モード,

ダイアログ0,

ダイアログ1,

[ダイアログ2],

...

)

注:
  • Wizard 関数はダイアログを含んでいるセルへの可変数の参照を受け入れるため、この関数はプロパティシートによって設定されません。この関数はセル、または [ジョブの編集] ツールバーの数式バーで直接設定できます。

  • Dialog 関数のダイアログの [タイトル] パラメータが、ダイアログ内に編集可能な文字列値 (EditString、ListBox または Concatenate など) を含むセルを参照している場合 (必要に応じて GetString 関数を使用)、セルの値を変更すると、セルはただちに更新されて新しい値が表示されます。ただし、ダイアログのタイトルには古い値が表示されたままです。ダイアログのタイトルは、そのダイアログを再度開いたときに更新されます。また、モードが 1 (シーケンシャル) に設定された Wizard 関数によってダイアログが参照される場合、セルの文字列値を変更してもウィザードのメニューには古い値が表示されたままです。ウィザードのメニューは、そのウィザードを再度開いたときに更新されます。

Wizard 関数の入力パラメータ

名前

スプレッドシートに表示されるウィザードの名前。

モード

ウィザードがダイアログを開く際にポップアップメニューを使用するか、または順番に開くかを指定します。

0 = メニュー | ポップアップメニューのリストから、どの順序でもダイアログを開くことができます。
1 = シーケンシャル | Wizard 関数のパラメータリストでダイアログを含んでいるセルが参照される順序でダイアログを開きます。

ダイアログ0, 1, 2, ...

Dialog 関数を含んでいるスプレッドシートのセルを参照することによって、ウィザードに含めるダイアログを指定します。ダイアログを開く順序 (シーケンシャルモードの場合)、またはリスト (ポップアップメニューモードの場合) は、Wizard 関数のパラメータリストでセルが参照される順序によって定義されます。

Wizard 関数の出力

結果

ボタンを押して手動で実行する場合や Select 関数で自動的に実行する場合も、起動するウィザードはラベル付きのウィザード [image] コントロールになります。

Wizard 関数例

スプレッドシートが次のように設定されています。

A3=Dialog("Dialog1","Step 1",5,5)

A4=Dialog("Dialog2","Step 2",5,5)

A5=Dialog("Dialog3","Step 3",5,5)

A6=Wizard("ウィザードの例",1,A3,A4,A5)

セル A6 の Wizard 関数は、[モード] パラメータが 1 であるためシーケンシャルモードでアクセスされる セル A3、A4、および A5 を参照します。ウィザードを実行すると、「Dialog1」というラベルの付いたダイアログが最初に表示されます。ユーザは、[キャンセル] ボタンを押してウィザードを閉じるか、[次へ] ボタンを押してウィザードの次のダイアログへ進むことができます。最後の「Dialog3」ダイアログは次のように表示されます。

また、Wizard 関数の第 2 パラメータを 0 に変更すると、メニューモードでウィザードを起動することができます。

A6=Wizard("ウィザードの例",0,A3,A4,A5)

ここでウィザードを起動すると、起動するダイアログを選択するメニューが表示されます。

リストからダイアログを選択すると、[メニュー] ボタンが表示されます。このボタンをクリックすると、どのダイアログからでもメニューに戻ることができます (下図に Step 2 ダイアログの表示例を示します)。

関連項目

Dialog 関数

Select 関数

オペレータ I/F 関数について

画面表示関数について


表示関数

画面表示関数

In-Sight 関数リファレンス

次の関数は、グラフィックスをスプレッドシートに挿入します。

  • Chart 関数: スプレッドシートの行にあるストリップチャートの表示要素を挿入します。
  • ColorLabel 関数: 色付きのテキスト文字列と、オプションで色付きの背景を表示します。
  • MultiStatus 関数: シミュレートしている LED ステータスアレイを実装します。
  • Status 関数: シミュレートしているマルチカラーのステータス LED とテキストラベルを実装します。
  • StatusLight 関数: シミュレートしている LED ステータスライトをラベル付きで挿入します。ステータスライトとラベルの色は、両方ともユーザが指定できます


Chart 関数

Chart 関数 |
画面表示関数 → 表示 | In-Sight 関数リファレンス

スプレッドシートの行にあるストリップチャートの表示要素を挿入します。チャートのサイズを調整するには、行の高さを調整します。

注: チャートは Dialog 関数ではサポートされていません。

Chart 関数 (

イベント ,

値 ,

数 ,

名前 ,

範囲: 最小 ,

範囲: 最大

)

Chart 関数の入力パラメータ

イベント | 次の値のタイムをチャートに記録する更新イベントを指定します。このパラメータは、A0 (AcquireImage セル) か、 [image] または [image] 関数を含んでいるセルのいずれかへのセル参照である必要があります。
値 | チャートに記載する数値を指定します。このパラメータは、通常は、サイクルごとに更新する数値を含んでいるスプレッドシートのセルへの参照を含んでいます。(-9999999 ～ 9999999、デフォルト = 0)
数 | チャートに記載する値の数 (2 ～ 5000、デフォルト = 10) を指定します。
名前 | チャートに表示するテキスト文字列ラベルを指定します。
範囲: 最小 | チャートの垂直座標の最小値を指定します (-9999999 ～ 9999999、デフォルト = 0)。
範囲: 最大 | チャートの垂直座標の最大値を指定します (-9999999 ～ 9999999、デフォルト = 0)。

注: Range: Min および Range: Max を 0 に設定すると、チャートは入力値に従って継続的に垂直座標の範囲を拡大/縮小します。

関連項目

表示関数について

画面表示関数について

プロパティシートの使用方法


ColorLabel 関数

ColorLabel 関数 |
画面表示関数 → 表示 | In-Sight 関数リファレンス

カラーラベルの表示要素をスプレッドシートに挿入します。ラベルはセルを背景色で塗りつぶし、前景色にテキストを書き込みます。

ColorLabel 関数 (

名前,

前景色,

背景色

)

ColorLabel 関数の入力パラメータ

名前 | 前景に表示するテキスト文字列ラベルを指定します。
前景色 | 前景色を指定します。
背景色 | 背景色を指定します。

関連項目

表示関数について

画面表示関数について

プロパティシートの使用方法


MultiStatus 関数

MultiStatus 関数 |
画面表示関数 → 表示 | In-Sight 関数リファレンス

シミュレートした LED ステータスライトをスプレッドシートに挿入します。この関数は、コントロール値から指定されたビットを、2 色の状態がある単一の LED として表示します。

MultiStatus 関数 (

値 ,

開始ビット ,

ビット数 ,

逆の順序 ,

色 0 ,

色 1

)

MultiStatus 関数の入力パラメータ

値

コントロール値 (0 ～ 65535、デフォルト = 0) を指定します。

開始ビット

コントロール値の最初のビット (0 ～ 15、デフォルト = 0) を指定します。

ビット数

表示するビット数 (1 ～ 16、デフォルト = 10) を指定します。各ビットが 1 つの LED に対応します。

逆の順序

配列の最上位ビット (MSB) を表すビットを判定します。

0 = OFF (デフォルト) | 一番左のビットが MSB です。
1 = ON | 一番右のビットが MSB です。

色 0

「ゼロ」ビットを表すために使用される LED のカラーを設定します(0 ～ 16、デフォルト = 黄)。

色 1

「1」ビットを表すために使用される LED のカラーを設定します(0 ～ 16、デフォルト = 緑)。

MultiStatus 関数の例

スプレッドシートが次のように設定されています。

A1 = EditInt(0,255)

A2 = MultiStatus(A1,0,8,0,0,0)

セル A1 内の EditInt コントロールを増分すると、MultiStatus 関数が参照するセル (この場合は A1) の 2 進数表記を示します。

関連項目

表示関数について

画面表示関数について

プロパティシートの使用方法


Status 関数

Status 関数 |
画面表示関数 → 表示 | In-Sight 関数リファレンス

シミュレートした LED ステータスライトの表示要素をスプレッドシート内に挿入します。Status セルには、各色のテキストラベルとともに、指定の値が赤、黄、または緑の LED として表示されます。

Status 関数 (

ステータス ,

ラベル: 緑 ,

ラベル: 黄 ,

ラベル: 赤

)

Status 関数の入力パラメータ

ステータス

ステータスモニタ値を含んでいるセルを参照します。ステータスカラーとして知られるインジケータがモニタ値に応じて、次のように表示されます。

モニタ値 | ステータスカラー
< 0 | 赤
= 0 | 黄
> 0 | 緑

ラベル: 緑

ステータスが 0 より大きい場合に表示されるテキストを指定します。

ラベル: 黄

ステータスが 0 の場合に表示されるテキストを指定します。

ラベル: 赤

ステータスが 0 より小さい場合に表示されるテキストを指定します。

関連項目

表示関数について

画面表示関数について

プロパティシートの使用方法


StatusLight 関数

StatusLight 関数 |
画面表示関数 → 表示 | In-Sight 関数リファレンス

シミュレートした LED ステータスライトの表示要素をスプレッドシート内に挿入します。ステータスライトとラベルの色は、両方ともユーザが指定できます。StatusLight セルには、各色のテキストラベルとともに、指定の色の LED が表示されます。

StatusLight 関数(

ステータス,

ラベル: 正,

ラベル: ゼロ,

ラベル: 負,

色: 正,

色: ゼロ,

色: 負

)

StatusLight 関数の入力パラメータ

ステータス | ステータスモニタ値を含んでいるセルを参照します。
ラベル: 正 | ステータスが正の値の場合に表示されるテキストを指定します。
ラベル: ゼロ | ステータスが 0 の場合に表示されるテキストを指定します。
ラベル: 負 | ステータスが負の値の場合に表示されるテキストを指定します。
色: 正 | ステータスが正の値の場合に表示されるステータス LED カラーを指定します。(デフォルト = 緑)
色: ゼロ | ステータスがゼロの場合に表示されるステータス LED カラーを指定します。(デフォルト = 黄)
色: 負 | ステータスが負の値の場合に表示されるステータス LED カラーを指定します。(デフォルト = 赤)

例

セル A2 と B2 が次のように設定されていると仮定します。

A2=EditInt(-1,1)

B2=StatusLight($A$2,"合格","警告","不合格",8,9,7)

セル A2 に値 1 が含まれている場合、セル B2 は次を返します。
Version: 5.6.0


画像フィルタ関数

画面表示関数

In-Sight 関数リファレンス

画像フィルタ関数は、画像上にグラフィックスオーバレイをプロットします。

  • PlotArc 関数: 画像上に円弧セグメントをプロットします。
  • PlotCircle 関数: 画像上に円をプロットします。
  • PlotCompositeRegion 関数: 画像上に複合領域をプロットします。
  • PlotCross 関数: 画像上に十字をプロットします。
  • PlotData 関数: 構造体に格納されているグラフィックスをプロットします。
  • PlotLine 関数: 画像上に線セグメントをプロットします。
  • PlotPoint 関数: 画像上にポイントのクロスヘアをプロットします。
  • PlotPolygon 関数: 画像上にポリゴン形状をプロットします。
  • PlotRegion 関数: 画像上に領域のアウトラインをプロットします。
  • PlotString 関数: 画像上にテキスト文字列をプロットします。


PlotArc 関数

PlotArc 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

始点から終点まで反時計回りに、円弧セグメントを画像にプロットします。

  • PlotArc の入力パラメータ
  • PlotArc の出力
  • 関連項目

PlotArc 関数の入力パラメータ

PlotArc 関数 (

円弧.中心行 ,

円弧.中心列 ,

円弧.開始行 ,

円弧.開始列 ,

円弧.終了行 ,

円弧.終了列 ,

名前 ,

色 ,

表示

)

円弧

プロットする円弧の画像座標を指定します。

中心行 | 円弧の中心の行座標
中心列 | 円弧の中心の列座標
開始行 | 始点の行座標。
開始列 | 始点の列座標。
終了行 | 終点の行座標。
終了列 | 終点の列座標

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotArc 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotCircle 関数

PlotCircle 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上に円をプロットします。

  • PlotCircle の入力パラメータ
  • PlotCircle の出力
  • 関連項目

PlotCircle 関数の入力パラメータ

PlotCircle 関数 (

円.行 ,

円.列 ,

円.半径 ,

名前 ,

色 ,

表示

)

円

プロットする円の画像座標を指定します。

行 | 円の中心の行座標
列 | 円の中心の列座標
半径 | 円の半径

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotCircle 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotCompositeRegion 関数

PlotCompositeRegion 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上に合成領域のアウトラインをプロットします。

  • PlotCompositeRegion の入力パラメータ
  • PlotCompositeRegion の出力
  • 関連項目

PlotCompositeRegion 関数の入力パラメータ

PlotCompositeRegion 関数 (

合成領域,

名前,

色,

表示

)

合成領域

プロットする EditCompositeRegion、EditMaskedRegion、または EditPolylinePath 関数への参照を指定します。

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotCompositeRegion 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotCross 関数

PlotCross 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上に十字をプロットします。

  • PlotCross の入力パラメータ
  • PlotCross の出力
  • 関連項目

PlotCross 関数の入力パラメータ

PlotCross 関数 (

十字.行 ,

十字.列 ,

十字.角度 ,

十字.高さ ,

十字.幅 ,

名前 ,

色 ,

表示

)

十字

プロットする十字の画像座標を指定します。

行 | 十字の中心の行座標
列 | 十字の中心の列座標
角度 | 十字の方向
高さ | 十字の高さ
幅 | 十字の幅

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotCross 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotData 関数

PlotData 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

データ構造体に格納されているグラフィックスをすべてプロットします。

  • PlotData の入力パラメータ
  • PlotData の出力
  • 関連項目

注: Repeat 関数または RepeatUntil 関数と組み合わせてループを作成する場合、PlotData 関数はスプレッドシートの反復されるセルのループ外に配置する必要があります。

PlotData 関数の入力パラメータ

PlotData 関数 (

データ ,

)

データ

StoreData 関数によって返された [image] データ構造体への参照を指定します。

PlotData 関数の出力

戻り値

データ構造体に格納されているグラフィックスを含んでいる [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • スプレッドシートセルのルールの作成
  • Repeat 関数
  • RepeatUntil 関数
  • StoreData 関数
  • プロパティシートの使用方法


PlotLine 関数

PlotLine 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上に線セグメントをプロットします。

  • PlotLine の入力パラメータ
  • PlotLine の出力
  • 関連項目

PlotLine 関数の入力パラメータ

PlotLine 関数(

ライン.行 0 ,

ライン.列 0 ,

ライン.行 1 ,

ライン.列 1 ,

名前 ,

色 ,

表示 ,

始点修飾 ,

終点修飾

)

ライン

プロットする線の画像座標を指定します。

行 0 | 線の始点の行座標
列 0 | 線の始点の列座標
行 1 | 線の終点の行座標
列 1 | 線の終点の列座標

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

始点修飾

線の開始点の表示要素を指定します。

0 = なし (デフォルト)

1 = 矢印

終点修飾

線の終了点の表示要素を指定します。

0 = なし (デフォルト)

1 = 矢印

PlotLine 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotPoint 関数

PlotPoint 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上に点のクロスヘアをプロットします。

  • PlotPoint の入力パラメータ
  • PlotPoint の出力
  • 関連項目

PlotPoint 関数の入力パラメータ

PlotPoint 関数 (

点.行 ,

点.列 ,

名前 ,

色 ,

表示

)

点

プロットする点の画像座標を指定します。

行 | 点の行座標
列 | 点の列座標

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotPoint 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotPolygon 関数

PlotPolygon 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上にポリゴン領域のアウトラインをプロットします。

  • PlotPolygon の入力パラメータ
  • PlotPolygon の出力
  • 関連項目

PlotPolygon 関数の入力パラメータ

PlotPolygon 関数 (

合成領域 ,

名前 ,

色 ,

表示

)

合成領域

プロットする EditPolygon 関数への参照を指定します。

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotPolygon 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

注: ポリゴンの長さが約 4950 点を超過する場合、そのポリゴンはグラフィカルに表示されません。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotRegion 関数

PlotRegion 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上に領域のアウトラインをプロットします。

  • PlotRegion の入力パラメータ
  • PlotRegion の出力
  • 関連項目

PlotRegion 関数の入力パラメータ

PlotRegion 関数 (

領域.行 ,

領域.列 ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

名前 ,

色 ,

表示

)

領域

プロットする領域の画像座標を指定します。

行 | 領域の原点の行座標
列 | 領域の原点の列座標
高さ | 領域の高さ
幅 | 領域の幅
角度 | 領域の方向
カーブ | 領域の湾曲

名前

グラフィックとともに画像上に表示するテキストラベルを指定します。

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotRegion 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


PlotString 関数

PlotString 関数 |
画面表示関数 → グラフィックス | In-Sight 関数リファレンス

画像上にテキスト文字列をプロットします。

  • PlotString の入力パラメータ
  • PlotString の出力
  • 関連項目

ヒント: PlotString 関数をスプレッドシートに挿入した後、この関数のスプレッドシートセルをハイライトし、[セルのフォーマット] ダイアログを使用して PlotString セルおよびプロットしたテキスト文字列のフォント、フォントサイズ、およびフォントスタイルを設定します。

PlotString 関数の入力パラメータ

PlotString 関数(

文字列 ,

点.行 ,

点.列 ,

色 ,

表示

)

文字列

プロットするテキスト文字列を指定します。

点

プロットする文字列の画像座標を指定します。

行 | 文字列の行座標
列 | 文字列の列座標

色

プロットされたグラフィックの色 (デフォルト = 緑) を指定します。

表示

画像上のグラフィックスオーバレイの表示モードを指定します。

0 = OFF | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、グラフィックスは表示されません。
1 = ON (デフォルト) | グラフィックが常に表示されます。

PlotString 関数の出力

戻り値

グラフィックを含む [image] データ構造体。

関連項目

  • グラフィックス関数について
  • 画面表示関数について
  • プロパティシートの使用方法


数値演算関数

In-Sight 関数リファレンス

数値演算関数を使用して、標準の数学演算子、論理関数、統計関数、および三角関数を使用する数式を構築します。数値演算関数は、次のカテゴリに分類されます。

  • 論理関数: In-Sight スプレッドシートにブール代数および条件テストの機能を提供します。
  • ルックアップ関数: 値の範囲での最大値、最小値、またはインデック番号を検索し、行、列、および #ERR データを返します。複数の関数によるエラーの拡散を防止するため、#ERR セルが表示されないようにします。
  • 数学関数: 絶対値、べき乗、切り捨て、丸め、乱数の生成など、各種の数値演算関数を提供します。
  • 演算子関数: 関係演算子。=、<>、>、<、>=、<= などがあります。
  • 統計関数: 値のグループでの最大値、最小値、平均値、および標準偏差のデータを返します。
  • 三角関数: 正弦、余弦、正接、円周率、度、ラジアンの (および関連する) 関数を提供します。


論理演算関数

数値演算関数

In-Sight 関数リファレンス

論理演算関数は、In-Sight スプレッドシートにブール代数および条件テストの機能を提供します。ビットごとの関数はすべて、2 進数で表現した引数の各ビット位置に対応する論理演算を実行し、結果として求められた 2 進値を 10 進数形式で返します。 例えば、値 0 のビット 0 は値 1 のビット 0 と比較され、値 0 のビット 1 は値 1 のビット 1 と比較されます。複数の真/偽条件の結果を GUI 表示やディスクリート出力に組み合わせる場合は、ビットごとの関数を、MultiStatus 関数やディスクリート I/O 関数とともに使用すると特に有効です。

演算子 | シンボル
NOT | !
AND | &&
OR | ||
等しい | ==
等しくない | <> (または !=)

注:

  • 特定のスニペットがスプレッドシートに挿入されるとき、[ジョブの編集] ツールバーに表示される式に、!、&&、||、==、<>、>=、<=、!= などの文字が含まれる場合があります。

  • 空のセルまたは文字列を含むセルが引数のリストに存在する場合、AND と && 演算子は異なる機能を持ちます。

すべての論理演算関数において、次が適用されます。

  • FALSE = 0
  • TRUE = ゼロ以外の結果

関数

説明

And(値1, 値2, ...)

すべての値がゼロ以外の場合は 1 を返します (論理 AND [image] どちらの値も TRUE である場合の結果は TRUE です)。

注:

  • 引数が空のセルまたは文字列が含まれているセルを参照している場合、これらの値は無視されます。すべての引数が空のセルまたは文字列が含まれているセルを参照している場合は、#ERR が返されます。

  • 空のセルまたは文字列を含むセルが引数のリストに存在する場合、AND と && 演算子は異なる機能を持ちます。AND 関数は空のセルまたは文字列のみを含むセルを無視しますが、&& 演算子はこれらのセルを無視しません。セル A5 が空のセルの場合、関数 A5&&2 は 0 を返します。セル A5 に「a」などの文字列が含まれている場合、関数 A5&&2 は #ERR を返します。

Closed 例

  • And(45, -77) は 1 を返します。
  • And(65534, 0) は 0 を返します。
  • And(-3, -2, -1, 1, 2, 3) は 1 を返します。
  • And(-1, 0, 1) は 0 を返します。

BitAnd(値1, 値2, ...)

値のビットごとの AND を返します。

注: 下位 16 ビットのみを処理します。

Closed 例

BitAnd(45, 77) は 13 を返します。

45 = 0000 0000 0010 1101 (2 進数)、77 = 0000 0000 0100 1101 (2 進数)

And 演算子を使用して、これら 2 つの 16 ビット 2 進数の共通ビットを個別に比較した結果は 0000 0000 0000 1101 で、これを 10 進数で表すと 13 になります。

BitNot(値)

値をビットごとに反転させた結果を返します。

注: 下位 16 ビットのみを処理します。

Closed 例

BitNot(45) は 65490 を返します。

45 = 0000 0000 0010 1101 (2 進数)。 0 を 1、1 を 0 に反転した結果は 2 進数では 1111 1111 1101 0010 で、これを 10 進数で表すと 65490 になります。

BitOr(値1, 値2, ...)

値のビットごとの OR を返します。

注: 下位 16 ビットのみを処理します。

Closed 例

BitOr(45, 77) は 109 を返します。

45 = 0000 0000 0010 1101 (2 進数)、77 = 0000 0000 0100 1101 (2 進数)

Or 演算子を使用して、これら 2 つの 16 ビット 2 進数の共通ビットを個別に比較した結果は 0000 0000 0110 1101 で、これを 10 進数で表すと 109 になります。

BitXor(値1, 値2, ...)

値のビットごとの XOR (排他的 OR) を返します (論理 XOR [image] ビットの中の 1 つだけが TRUE のときに、結果が TRUE になります。 等しいビットが複数個存在する場合の結果は FALSE です)。

注: 下位 16 ビットのみを処理します。

Closed 例

BitXor (45, 77) は 96 を返します。

45 = 0000 0000 0010 1101 (2 進数)、77 = 0000 0000 0100 1101 (2 進数)

次のように、45 と 77 で共通ビットではないのは 0110 0000 のみです。

45 | 77 | ビット単位の XOR | XOR ビット
0 | 0 | 2 個の 0 ≥ XOR [image] FALSE | 0 (FALSE)
0 | 1 | 1 を 1 つのみ ≥ XOR [image] TRUE | 1 (TRUE)
1 | 0 | 1 を 1 つのみ ≥ XOR [image] TRUE | 1 (TRUE)
0 | 0 | 2 個の 0 ≥ XOR [image] FALSE | 0 (FALSE)
1 | 1 | 2 個の 1 ≥ XOR [image] FALSE | 0 (FALSE)
1 | 1 | 2 個の 1 ≥ XOR [image] FALSE | 0 (FALSE)
0 | 0 | 2 個の 0 ≥ XOR [image] FALSE | 0 (FALSE)
1 | 1 | 2 個の 0 ≥ XOR [image] FALSE | 0 (FALSE)

0110 0000 = 96 (10 進数)

If(条件, 値1, 値2)

条件がゼロ以外の場合は値1 を返し、条件がゼロの場合は値2 を返します。

注: 条件または引数が空のセルを参照している場合、それらはゼロ (FALSE) と解釈されます。

InRange(値, 開始, 終了)

Min(開始,終了) ≤ 値 ≤ 最大(開始,終了) の場合、TRUE を返します。

Not(値)

値がゼロ以外の場合は 0 を返し、値がゼロの場合は 1 を返します (論理 NOT)。

Closed 例

  • Not(-12345) は 0 を返します。
  • Not(3.14) は 0 を返します。
  • Not(2-1) は 0 を返します。
  • Not(1-1) は 1 を返します。

Or(値1, 値2, ...)

すべての値がゼロの場合は 0 を返し、ゼロ以外の値がある場合は 1 を返します (論理 OR [image] 値のいずれかが TRUE の場合、結果は TRUE です)。

Closed 例

  • Or(45, -77) は 1 を返します。
  • Or(-1, 0, 1) は 1 を返します。
  • Or(0, 1-1) は 0 を返します。

関連項目

数値演算関数について

[関数の挿入] ダイアログ


ルックアップ関数

ルックアップ関数 |
数値演算関数 | In-Sight 関数リファレンス

関数

説明

Choose(インデックス, 値0, [値1, ...])

可変長リストからインデックス付きの引数の値を返します。

Column(セル)

スプレッドシートのセルの列番号を返します。

注: 列 A = 0.0 および列 Z = 25.0

CountError(セル1, [セル2, ...])

1 つ以上のセルまたはセル範囲でのエラーの数を返します。

ErrFree(セルまたはセル範囲)

#ERR を空のセルに変換し、エラーの拡散を抑制します。

If(条件, 値1, 値2)

テストがゼロ以外の場合は「値1」を返し、テストがゼロの場合は「値2」を返します。

MaxI(値0, [値1, ...])

値の可変長リストから最大の「値」のインデックスを返します。

MinI(値0, [値1, ...])

値の可変長リストから最小の「値」のインデックスを返します。

NthMaxI(N, 値　0, [値　1, ...])

値の可変長リストから N 番目に大きい「値」のインデックスを返します。

NthMinI(N, 値　0, [値　1, ...])

値の可変長リストから N 番目に小さい「値」のインデックスを返します。

Row(セル)

スプレッドシートの「セル」の行番号を返します。

Switch(FindCase, デフォルト, ケース0, 値0, [ケース1, 値1, ...])

[FindCase] と一致する最初の「ケース」に対応する値を返します。インデックスで指定されたケースが FALSE の場合、指定された「デフォルト」値が返されます。式の中の複数の「ケース」が [FindCase] と一致する場合は、最初に一致したケースに対応する値が返されます。

Closed Switch 関数の例

A4 = Switch(A2,-1,2,"C",3,"B",A3,"A")

セル A2=2 の場合、セル A4 に返される値は C です。

セル A2=3 の場合、セル A4 に返される値は B です。

セル A2=5 の場合、セル A4 に返される値はデフォルトの -1 です。これは、式の中に [FindCase] に一致するケースがないからです。

注: テキスト文字列を必要とする関数の引数について、Switch または Choose 関数の場合は、直接文字列を入力することはできません。例えば、Len(If(...)) は無効です。この問題を解消するには、別々のセルに If、Switch、または Choose を配置して、そのセルへの参照を作成します。

関連項目

数値演算関数について

[関数の挿入] ダイアログ


演算

演算 |
数値演算関数 | In-Sight 関数リファレンス

使用方法 | 説明
Abs(値) | 値の絶対値を返します。
Exp(値) | e を指定した回数だけべき乗して返します。
Mod(値 1, 値 2) | 値 1 を値 2 で除算した余りを返します。
Power(基数, 指数) | 基数を指定した指数だけべき乗して返します。
Rand(イベント) | 入力イベントで乱数 (0.0 ～ 1.0) を返します。各イベントが新しい乱数をトリガします。 注: Rand 関数は、セル内で唯一の項目であることが必要です。
Round(値) | 最も近い整数に丸めた値を返します。
RoundDown(値) | 端数を切り捨てて、次に小さい整数にした値を返します。
RoundUp(値) | 端数を切り上げて、次に大きい整数にした値を返します。
Sqrt(値) | 値の平方根を返します。
Sum(値 1, [値 2, ...]) | 値の可変長リストの合計を返します。
Trunc(値) | 0 から整数までの間の切り捨てた値を返します。結果の値には分数は含まれていません。

関連項目

数値演算関数について

[関数の挿入] ダイアログ


演算子

演算子 |
数値演算関数 | In-Sight 関数リファレンス

注: 特定のスニペットがスプレッドシートに挿入されるとき、[ジョブの編集] ツールバーに表示される式に、!、&&、||、==、<>、>=、<=、!= などの文字が含まれる場合があります。これらの文字は、次の論理演算子および比較演算子の代替コードです。

演算子 | シンボル
NOT | !
AND | &&
OR | ||
等しい | ==
等しくない | <> (または !=)

演算子 | 説明
= | 等値
<> | 非等値
> | より大きい
< | 未満
>= | 以上
<= | 以下

関連項目

数値演算関数について

[関数の挿入] ダイアログ


統計関数

統計関数 |
数値演算関数 | In-Sight 関数リファレンス

関数 | 説明
ComputeStats 関数 | 参照値の統計を計算します。
Max(値 0, [値 1, ...]) | 値の可変長リストから最大値を返します。
Mean(値 0, [値 1, ...]) | 値の可変長リストの平均を返します。
Min(値 0, [値 1, ...]) | 値の可変長リストから最小値を返します。
NthMax(N, 値 0, [値 1, ...]) | 値の可変長リストから、N 番目に大きな値を返します。
NthMin(N, 値 0, [値 1, ...]) | 値の可変長リストから、N 番目に小さな値を返します。
SDev(値 0, 値 1, [値 2, ...]) | 値の可変長リストのバイアスを含めた標準偏差 (分母は N-1) を返します。
SDevUnbiased(値 0, 値 1, [値 2, ...]) | 値の可変長リストのバイアスを除外した標準偏差 (分母は N) を返します。

関連項目

数値演算関数について

[関数の挿入] ダイアログ


ComputeStats 関数

数値演算関数 → 統計

In-Sight 関数リファレンス

参照値の統計を計算します。

ComputeStats 関数 (

イベント,

値,

オフライン時にカウント,

イベントのリセット.手動,

イベントのリセット.オンライン,

イベントのリセット.ジョブを開く

)

ComputeStats 関数の入力パラメータ

イベント

カウンタを増分するイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体(デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

値

計算されるデータのソースを含んでいるセルへの必要な参照を指定します。参照されているセルがない場合、関数はすべての結果に対して #ERR を返します。

オフライン時にカウント

センサがオフラインの間に統計が計算されるかどうかを指定します。

0 = OFF | センサがオフラインの場合、統計を計算しません。
1 = ON (デフォルト) | センサがオフラインの場合、統計を計算します。

イベントのリセット

特定のイベントによって計算を強制的にリセットします。

手動

指定されたイベントが発生したときに計算をリセットするかどうかを指定します。このパラメータは、[リセット] ボタンを自動的に参照します。[リセット] ボタンは、関数が最初に作成されたときにスプレッドシートに挿入されます。

注: プロパティシート内でこのチェックボックスを手動で切り替えると、[リセット] ボタンへの参照は削除されます。[リセット] ボタンを使用するには、このパラメータが [リセット] ボタンを含むセルを参照している必要があります。

0 = OFF (デフォルト) | 指定されたイベントが発生しても、計算をリセットしません。
1 = ON | 指定されたイベントが発生すると、計算をリセットします。

オンライン

センサがオンラインになったときに計算をリセットするかどうかを指定します。

0 = OFF | センサがオンラインになったときに計算をリセットしません。
1 = ON (デフォルト) | センサがオンラインになったときに計算をリセットします。

ジョブを開く

ジョブがロードされたときに計算をリセットするかどうかを指定します。

0 = OFF | ジョブがロードされても、計算をリセットしません。
1 = ON (デフォルト) | ジョブがロードされると、計算をリセットします。

ComputeStats 関数の出力

戻り値 | 計算された統計を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | 初めてComputeStats 関数セルに挿入すると、スプレッドシート内に結果テーブルと [リセット] ボタンが作成されます。[リセット] ボタンをクリックすると、すべてのカウンタがゼロにリセットされます。

ComputeStats 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

最新 | GetLatest(Stats) | 最新の値。
最小 | GetMin(Stats) | 統計の計算に使用される最小値
最大 | GetMax(Stats) | 統計の計算に使用される最大値
平均 | GetMean(Stats) | 値の平均
合計 | GetSum(Stats) | 値の合計
標準偏差 | GetSDev(Stats) | 値の標準偏差
差異 | GetVariance(Stats) | 値の差異
範囲 | GetRange(Stats) | 最小値と最大値の間の範囲
エラー数 | GetErrorCount(Stats) | 参照値からのエラーの合計数
サンプル数 | GetNumSamples(Stats) | 計算に使用されるサンプルの合計数

関連項目

Count 関数

クロックドデータ関数について


三角関数

数値演算関数

In-Sight 関数リファレンス

関数 | 説明
ACos(値) | 値の逆余弦を度単位で返します。 注: -1 ≤ 値 ≤ 1
ASin(値) | 値の逆正弦を度単位で返します。 注: -1 ≤ 値 ≤ 1
ATan(値) | 値の逆正接を度単位 (±90) で返します。
ATan2(DY,DX) | ベクトルの逆正接 (x,y) = (DY,DX) を度単位 (±180) で返します。
Cos(角度) | 角度の余弦を度単位で返します。
Degrees(ラジアン) | 値がラジアン単位の場合、角度を度単位で返します。
Pi | 円周率 ≈ 3.142 の値を返します。
Radians(度) | 値が度単位の場合、角度をラジアン単位で返します。
Sin(角度) | 角度の正弦を度単位で返します。
Tan(角度) | 角度の正接を度単位で返します。

関連項目

数値演算関数について

[関数の挿入] ダイアログ


文字列操作関数

In-Sight 関数リファレンス

文字列操作関数は、スプレッドシートのインタフェースで表示するため、および In-Sight センサとリモートデバイス間の通信用に英数字データ文字列をフォーマットします。文字列操作関数は次の 2 つのカテゴリに分類されます。

  • バイナリ
  • 文字列

注: 文字列操作関数では、2 バイト文字はサポートされません。


バイナリ関数

バイナリ関数 |
文字列操作関数 | In-Sight 関数リファレンス

バイナリ関数は、TCPDevice 関数で使用するためにバイナリデータパケットをフォーマットします。これらの関数を使用して、Modbus TCP パケットを Modbus TCP サーバデバイスに送信できます。これらの関数を使用して Modbus パケットを送信している場合は、TCPDevice 関数の [パケットタイプ] パラメータを Modbus に設定する必要があります。

関数

説明
BGetDouble(Binary, Offset, [Byte/Word Order])

構造体中の倍精度浮動小数点の値を単精度の結果として返します。

Binary | BStringf 関数、TCPDevice 関数または QueryDevice 関数によって (それぞれ) 返される、 [image] 構造体 [image] または [image] 構造体を参照します。
Offset | バイト単位でオフセットを指定します。
Byte/Word Order | 関数によって読み込まれるワードおよびバイトのバイト順序を指定します。 0 = ビッグエンディアン (デフォルト) 1 = リトルエンディアン 2 = ビッグエンディアン (16 ビットワード変換使用) 3 = リトルエンディアン (16 ビットワード変換使用)

BGetFloat(Binary, Offset, [Byte/Word Order])

構造体中の浮動小数点の値を返します。

Binary | BStringf 関数、TCPDevice 関数または QueryDevice 関数によって (それぞれ) 返される、 [image] 、 [image] 、または [image] 構造体を参照します。
Offset | バイト単位でオフセットを指定します。
Byte/Word Order | 関数によって読み込まれるワードおよびバイトのバイト順序を指定します。 0 = ビッグエンディアン (デフォルト) 1 = リトルエンディアン 2 = ビッグエンディアン (16 ビットワード変換使用) 3 = リトルエンディアン (16 ビットワード変換使用)

BGetInt(Binary, Offset, Bytes, [Sign], [Byte/Word Order])

構造体中の整数値を返します。

Binary | BStringf 関数、TCPDevice 関数または QueryDevice 関数によって (それぞれ) 返される、 [image] 、 [image] 、または [image] 構造体を参照します。
Offset | バイト単位でオフセットを指定します。
Bytes | 1、2、または 4
Sign | 0 = 符号付き (デフォルト) 1 = 符号なし
Byte/Word Order | 関数によって読み込まれるワードおよびバイトのバイト順序を指定します。 0 = ビッグエンディアン (デフォルト) 1 = リトルエンディアン 2 = ビッグエンディアン (16 ビットワード変換使用) 3 = リトルエンディアン (16 ビットワード変換使用)

BGetString(Binary, Offset, Bytes, [Byte Swap])

構造体中の文字列を返します。

Binary | BStringf 関数、TCPDevice 関数または QueryDevice 関数によって (それぞれ) 返される、 [image] 、 [image] 、または [image] 構造体を参照します。
Offset | バイト単位でオフセットを指定します。
Bytes | 抽出される長さ
Byte Swap | 関数によって書き込まれるバイト順序を指定します。Modbus 実装のため、Modbus を介して PLC に読み取りまたは書き込みをする場合、文字列の隣り合うバイトを交換する必要があります。 注: この関数で使用するバイト交換は、ビッグエンディアンまたはリトルエンディアンのバイト交換とは関連しません。例えば、有効になっている場合は、[バイナリ] パラメータからの入力文字列が「BADC\0」(「0」は Null 値を終了する文字列) のとき、出力結果は「ABCD\0」となります。 0 = 文字列のバイトを交換しない (デフォルト) 1 = 文字列のバイトを交換

BLen(Binary)

バイナリ構造体の長さを返します。バイナリは、TCPDevice 関数または QueryDevice 関数によって (それぞれ) 返される、 [image] 構造体または [image] 構造体を参照する必要があります。

BStringf(Byte/Word Order, Format-String, Value1, [Value2, ...])

指定したフォーマットを使用して作成されたバイナリ文字列を含む [image] 構造体を返します。

Byte/Word Order

関数によって書き込まれるワードおよびバイトのバイト順序を指定します。

注: [バイト/ワードオーダ] パラメータは数字タイプのみに適用され、バイナリ構造体または文字列タイプのエンコーディングには影響しません。

0 = ビッグエンディアン (デフォルト)

1 = リトルエンディアン

2 = ビッグエンディアン (16 ビットワード変換使用)

3 = リトルエンディアン (16 ビットワード変換使用)

Format-String

使用できる書式文字列パラメータは次のとおりです。

パラメータ | 説明
%c | 1 バイト
%h | 2 バイト
%d | 4 バイト
%f | 4 バイト浮動小数点数
%e | 8 バイト浮動小数点数
%b | バイナリ構造体
%s | 文字列
%~s | 文字列はバイト変換される

注:

  • フォーマット文字列のパラメータには大文字と小文字の区別があります。
  • フォーマット文字列は引用符 (") で囲む必要があります。

Value

バイナリとしてエンコードする値の可変長リストを指定します (値 1, 値 2, ...)。値は、フォーマット文字列パラメータによって指定されたタイプに変換されます。

バイナリ関数例

この例では、SYSTEM0、SYSTEM1 と命名された 2 つの In-Sight システムを使用します。SYSTEM0 は Modbus クライアントで、SYSTEM1 は Modbus サーバです。

SYSTEM0 のスプレッドシートには次の関数が含まれています。

A2=TCPDevice("SYSTEM1",502,0,4,1000)

B2=QueryDevice($A$0,A2,0,0,0,0,0,6,0,3,20,4,0,1)

A3=BLen(B2)

A4=BGetInt(B2,9,2)

A5=BGetString(B2,10,1)

SYSTEM1 には次の値が含まれています。

F4=65

SYSTEM0 のスプレッドシートが実行されるときに、セル A2 の TCPDevice 関数は、SYSTEM1 と TCP/IP Modbus 接続を確立します。セル B2 の QueryDevice 関数は、SYSTEM1 に Modbus Read Multiple Registers コマンドを送り、セル F4 に含まれているデータが SYSTEM0 によって (バイナリフォーマットで) インポートされることを指定します。SYSTEM0 のスプレッドシートに返す結果は、次のようになります。

A3=11 (SYSTEM1 の Modbus サーバからインポートされたバイナリデータのパケット長)。

A4=65 (SYSTEM1 のセル F4 に含まれた整数値)。

A5="A" (文字列として変換されたセル F4 の整数値)。

注: この例では、TCPDevice 関数は、Modbus サーバである SYSTEM1 には使用しません。これは、In-Sight が Modbus コマンドを受信すると自動的に応答するためです。

前述の例で、SYSTEM0 によって送受信された実際のデータパケットは次のようになります。

コマンドパケット |  | 応答パケット
00 |  | 00 |
00 |  | 00 |
00 |  | 00 |
00 |  | 00 |
00 |  | 00 |
06 | 長さ (6 バイト) | 05 | 長さ (5 バイト)
00 |  | 00 |
03 | 関数 (Read Multiple Registers) | 03 | 関数 (Read Multiple Registers)
20 04 | Ref# (セルアドレス = F4) | 02 | バイト数 (2 バイト)
00 01 | ワード数 (0001) | 00 65 | 結果値 (00 65 十進法。Modbus にはビッグエンディアンを使用)

関連項目

文字列操作関数について

ストリング関数について

TCP/IP Modbus による通信

TCPDevice 関数

QueryDevice 関数


文字列関数

文字列操作関数

In-Sight 関数リファレンス

文字列関数は、In-Sight センサとリモートデバイス間で交わされる表示と通信のための英数字データをフォーマットします。

注:

  • [インデックス] パラメータはゼロベースです。つまり、文字列の最初の文字にはインデックス 0、2 番目の文字にはインデックス 1 というようにインデックスが割り当てられます。
  • セルの幅よりも 1 文字分幅が大きいテキスト文字列は切り捨てられることがあります。列の幅を増やすか、文字列に空白文字を追加すると、文字列全体が表示されます。

関数

説明

Code

文字列内の最初の文字の、ASCII コードに対応する整数値を返します。

Closed コードの例

セル A2 に英数字文字列「ABC123」が含まれている場合、関数 Code(A2) は、「A」の ASCII コード 65.000 を返します。

Concatenate(引数 1, [引数 2, 引数 3, ...])

複数の英数字テキスト文字列の連結を返します。数値の引数は自動的にテキストに変換されます。

注: In-Sight 2000-110/120/120C ビジョンセンサは、出力データとして合格/不合格データしか返さず、戻り値は 0 または 1 に変換されます。

Closed 連結の例

セル A2 に英数字文字列「A1B1」が含まれ、セル A3 に英数字文字列「C1D2」が含まれ、セル A4 に浮動小数点数 4.556 が含まれている場合、関数 Concatenate(A2,A3,A4) は「A1B1C1D24.556」を返します。
Encrypt(キー, 値, 出力形式)

結果データを暗号化し、暗号化された文字列を返します。詳細については、暗号化のトピックを参照してください。

Exact(テキスト 1, テキスト 2)

Text1 と Text 2 が同一の場合は 1 を返し、それ以外の場合は 0 を返します。

注: Exact は大文字と小文字を区別します。

Closed Exact の例

セル A2 に文字列「ABC123」が含まれ、セル A3 に文字列「ABC1234」が含まれている場合、Exact(A2,A3) は 0.000 を返します。

セル A2 に文字列「VISION」が含まれ、セル A3 に文字列「VISION」が含まれている場合、Exact(A2,A3) は 1.000 を返します。

Find(FindText, SrcText, [StartChar])

文字列テキスト 2 に含まれる文字列テキスト 1 のインデックス付き位置を返します。テキスト 1 の検索は、テキスト 2 内で任意で指定した StartChar 位置から開始されます。

注: Find は大文字と小文字を区別します。

Closed Find の例

セル A2 に文字列「123」が含まれ、セル A3 に文字列「ABC123」が含まれている場合、Find(A2,A3,2) は (ゼロベースの) インデックス値 3.000 を返します。

検索がインデックス 4 で開始されると、文字列全体「123」が文字列「ABC123」内で見つからないため、関数 Find(A2,A3,4) は -1.000 を返します。

FormatString(フォーマット文字列, [テキスト/値, ...])

「C」ライブラリの標準フォーマット文字列で構成されたテキスト文字列を返します。FormatString はほとんどのフォーマット文字列パラメータをサポートします。[FormatString] ダイアログを使って、この関数を In-Sight Explorer 内で自動的に設定します。

注:
  • FormatString を手動で編集することは推奨されません。
  • In-Sight 2000-110、2000-120、2000-120C ビジョンセンサは、出力データとして合格/不合格データしか返さず、戻り値は 0 または 1 に変換されます。

Left(テキスト, NumChars)

テキスト文字列の左端の文字 (NumChars) を返します。

Closed Left の例

セル A2 に英数字文字列「ABC123」が含まれている場合、関数 Left(A2,2) は文字列「AB」を返します。

Len(テキスト)

テキスト文字列の文字数 (バイト単位) を返します。

Closed Len の例

セル A2 に英数字文字列「ABC123」が含まれている場合、関数 Len(A2) は整数値 6.000を返します。

Lower(テキスト)

小文字に変換されたテキストを返します。

Closed Lower の例

セル A2 に英数字文字列「ABC123」が含まれている場合、関数 Lower(A2) は文字列「abc123」を返します。

Mid(テキスト, StartChar, NumChars)

英数字文字列内のインデックス付き StartChar 位置から始まるテキストを返します。返される文字数は、NumChars で指定した文字数です。

Closed Mid の例

セル A2 に英数字文字列「ABC123」が含まれている場合、関数 Mid(A2,2,2) は文字列「C1」を返します。

Replace(SrcText, StartChar, NumChars, NewText)

インデックス付き位置 StartChar で NewText によって変更された SrcText を返します。

Closed Replace の例

セル A2 に英数字文字列「ABC123」が含まれ、セル A3 に文字列「123」が含まれている場合、Replace(A2,0,3,A3) は文字列「123123」を返します。

Right(テキスト, NumChars)

テキスト文字列の右端の文字 (NumChars) を返します。

Closed Right の例

セル A2 に文字列「ABC123」が含まれている場合、Right(A2,2) は、「23」を返します。

Strcspn(SrcText, CharList)

CharList にも含まれている SrcText の最初の文字のインデックスを返します。CharList 内に SrcText の文字がない場合は、SrcText の長さを返します。

注: Strcspn は大文字と小文字を区別します。

Closed Strcspn の例

セル A2 に文字列「BLUE」が含まれ、セル A3 に文字「RED」が含まれている場合、Strcspn(A2,A3) は 3.000 のインデックス値を返します。これは、SrcText に含まれている CharList の最初の文字が「E」であるためです。

Stringf(フォーマット文字列, [テキスト/値, ...])

「C」ライブラリの標準フォーマット文字列で構成されたテキスト文字列を返します。

ヒント: FormatString 関数はほとんどのフォーマット文字列パラメータをサポートします。[FormatString] ダイアログを使用して、In-Sight Explorer 内でパラメータを自動的に設定します。

注:
  • In-Sight 2000-110/120/120C ビジョンセンサは、出力データとして合格/不合格データしか返さず、戻り値は 0 または 1 に変換されます。
  • フォーマット文字列は引用符 (") で囲む必要があります。
  • フォーマット文字列のパラメータには大文字と小文字の区別があります。
  • 文字列関数を使用する場合、バックスラッシュ「\」を使って、フォーマット制御文字が続くことを示します。バックスラッシュの後に制御文字 (「n」、「r」、または「t」) が続かない場合、バックスラッシュは無視されます。1 つのバックスラッシュを表示するには、2 つのバックスラッシュを入力する必要があります (例: Stringf("C:\\InSight2\\") = "C:\InSight2\")。
  • 印刷不可/制御コードの ASCII 文字は、シンボルまたは「ガベージ」テキストとして表示されます。

使用できるフォーマット文字列パラメータは次のとおりです。

%c

整数値に対応する ASCII 文字を返します。英数テキスト文字列が入力されると、最初の文字を返します。

Closed Stringf %c の例

セル A2 に整数値 65.000 が含まれている場合、Stringf("%c",A2) は、ASCII コード 65 に相当する文字「A」を返します。関数 Stringf("Value = %c",A2) は文字列「Value = A」を返します。

セル A2 に文字列「123ABC」が含まれている場合、Stringf("%c",A2) は文字「1」を返します。

%d

整数値を含む文字列を返します。

Closed Stringf %d の例

セル A2 に浮動小数点値「123.456」が含まれている場合、Stringf("%d",A2) は、数値文字列「123」を返します。関数 Stringf("Value = %d",A2) は英数字文字列「Value = 123」を返します。

セル A2 に文字列「ABC123」が含まれている場合、Stringf("%d",A2) は、文字「A」の ASCII コードである数値文字列「65」を返します。

%e

科学的表記法値を含む文字列を返します。小数点以下の桁数は、% と e パラメータの間に小数点 (.) と数値を入力して指定できます。

Closed Stringf %e の例

セル A2 に浮動小数点値「123.456」が含まれている場合、Stringf("%e",A2) は、数値文字列「1.234560e+02」を返します。小数点以下 1 つの数のみが指定されているため、関数 Stringf("%.1e",A2) は数値文字列「1.2e+02」を返します。

%f

浮動小数点値を含む文字列を返します。小数点以下の桁数は、% と f パラメータの間に小数点 (.) と数値を入力して指定できます。

Closed Stringf %f の例

セル A2 に浮動小数点値「123.456」が含まれている場合、Stringf("%f",A2) は、数値文字列「123.456001」を返します。小数点以下 1 つの数のみが指定されているため、関数 Stringf("%.1f",A2) は数値文字列「123.5」を返します。

%H

In-Sight センサの特定のホスト名を含んだ文字列を返します。

Closed Stringf %H の例

ホスト名が「is3k010203」の In-Sight センサ上のセルに関数 Stringf("Host Name: %H") が含まれている場合、この関数は英数字文字列「Host Name: is3k010203」を返します。

%I

In-Sight センサの特定の IP アドレスを含んだ文字列を返します。

Closed Stringf %I の例

IP アドレスが「198.232.26.1」の In-Sight センサ上のセルに関数 Stringf("IP Address: %I") が含まれている場合、この関数は英数字文字列「IP Address: 198.232.26.1」を返します。

%M

In-Sight センサの特定の MAC アドレスを含んだ文字列を返します。

Closed Stringf %M の例

MAC アドレスが「00-d0-24-01-02-03」の In-Sight センサ上のセルに関数 Stringf("MAC address: %M") が含まれている場合、この関数は英数字文字列「MAC Address: 00:d0:24:01:02:03」を返します。

%N

In-Sight センサの特定のシリアル番号を含んだ文字列を返します。

Closed Stringf %N の例

シリアル番号が「Z01020304」の In-Sight センサ上のセルに関数 Stringf("Serial Number: %N") が含まれている場合、この関数は英数字文字列「Serial Number: Z01020304」を返します。

%o

整数値の 8 進数値を含む文字列、または英数文字列の最初の文字を返します。

Closed Stringf %o の例

セル A2 に整数値 123.000 が含まれている場合、Stringf("%o",A2) は、整数 123 の 8 進数値である英数字文字列「173」を返します。セル A2 に文字列「ABC123」が含まれている場合、Stringf("%o",A2) は、文字「A」の 8 進数値である英数字文字列「101」を返します。

%s

英数字文字列が付加された文字列を返します。

Closed Stringf %s の例

セル A2 に文字列「ABC」が含まれている場合、Stringf("%s123",A2) は英数字文字列「ABC123」を返します。セル A2 に英数字文字列「123」が含まれている場合、Stringf("%s.450",A2) は、数値文字列「123.450」を返します。

%T

In-Sight センサの特定のモデルタイプを含んだ文字列を返します。

Closed Stringf %T の例

In-Sight 5400 センサ上のセルに関数 Stringf("Model Type: %T") が含まれている場合、関数は英数字文字列「Model Type: 5400」を返します。

%u

符号なし整数値を含む文字列を返します。

Closed Stringf %u の例

セル A2 に浮動小数点値「123.456」が含まれている場合、Stringf("%u",A2) は、数値文字列「123」を返します。関数 Stringf("Value = %u",A2) は英数字文字列「Value = 123」を返します。

セル A2 に文字列「ABC123」が含まれている場合、Stringf("%u",A2) は、文字「A」の ASCII コードである数値文字列「65」を返します。

%V

In-Sight センサの特定のファームウェアバージョンを含んだ文字列を返します。

Closed Stringf %V の例

ファームウェアバージョン 3.40.01 を実行する In-Sight センサ上のセルに関数 Stringf("Firmware Version: %V") が含まれている場合、この関数は英数字文字列「Firmware Version: 3.40.01 (475)」を返します。

%x または %X

整数値の 16 進数値を含んだ文字列、または英数字文字列の最初の文字を返します。

Closed Stringf %x の例

セル A2 に整数値 123.000 が含まれている場合、Stringf("%x",A2) は、整数 123 の 16 進数値である文字列「7b」を返します。セル A2 に文字列「ABC123」が含まれている場合、Stringf("%x",A2) は、文字「A」の 16 進数値である数字列「41」を返します。

以下のフォーマット文字列パラメータは主に、テキストのフォーマットに使用されます (例えば、関数 WriteSMTP でメールアドレスのテキストをフォーマットするなど)。

\x## | 16 進数 ## で指定された ASCII 文字をテキストに挿入します。 Closed Stringf \x## の例 セル A2 に Stringf("\x02123\x1bABC\x03456") が含まれている場合、セルには [image] ("<STX>123<ESC>ABC<ETX>456") が表示されます。
\n | 改行をテキストに挿入します。このパラメータは通常、\r (復帰改行) と一緒に使用されます。
\r | 復帰改行をテキストに挿入します。このパラメータは通常、\n (改行) と一緒に使用されます。
\t | tab をテキストに挿入します。

Strspn(SrcText, CharList)

CharList に含まれていない SrcText の最初の文字のインデックスを返します。SrcText のすべての文字が CharList 内にもある場合は、SrcText の長さを返します。

注: Strspn は大文字と小文字を区別します。

Closed Strspn の例

セル A2 に文字列「RED」が含まれ、セル A3 に文字「GREEN」が含まれている場合、Strspn(A2,A3) は 2.000 のインデックス値 (ゼロベース) を返します。これは、SrcText に含まれていない の最初の文字が「D」であるためです。

Strtol(IntegerText)

英数字文字列が始まる箇所で数値文字（10 進数、16 進数、8 進数） を整数に変換します。16 進数文字は「0x」で開始し、8 進数文字は「0」で開始する必要があります。

Closed Strtol の例

10 進値: セル A2 にテキスト文字列「123ABC」が含まれている場合、関数 Strtol(A2) は整数値 123.000を返します。

16 進値: セル A2 にテキスト文字列「0x123」が含まれている場合、Strtol(A2) は整数値 291.000を返します。

「A」と「B」は 16 進数文字なので、「0x12AB」 = 4,779.000 になります。

「G」は 16 進数文字ではないため、「0x12GB」 = 18.000 になります。

8 進値: セル A2 にテキスト文字列「0123ABC」が含まれている場合、Strtol(A2) は整数値 83.000を返します。

Substitute(SrcText, OldText, NewText, [インスタンス])

SrcText の OldText が出現するたびに NewText に置換することで作成されたテキスト文字列を返します。オプションのインスタンスインデックスを指定した場合、そのインスタンスのテキストだけが置換されます。

Closed Substitute の例

セル A2 にテキスト文字列「ABC123123」が含まれ、セル A3 に文字列「123」が含まれ、セル A4 に文字列「abc」が含まれている場合、Substitute(A2,A3,A4,1) は SrcText の 2 番目のインスタンス「123」を置換し、文字列「ABC123abc」を返します。

Token(テキスト, 区切り文字, インスタンス)

区切られた文字列の指定のインスタンスインデックス (出現) で見つかったテキストを返します。関数内の区切り文字は引用符 (") で囲む必要があります。

Closed Token の例

セル A2 にカンマ区切り文字列「A,B,C,1,2,3」が含まれている場合、C はテキスト内のインデックス 2 に位置しているので、Token(A2,",",2) は「C」を返します。

Trim(テキスト)

先頭のスペースと末尾のスペースが除去され、単語の間に 1 つのスペースだけがある (スペースがある場合) テキストが返されます。制御文字 (復帰改行、改行など) もすべて除去されます。

Closed Trim の例

セル A2 に文字列「 ABC 123 」が含まれている場合、Trim(A2) は、「ABC 123」を返します。

Upper(テキスト)

大文字に変換されたテキストを返します。

Closed Upper の例

セル A2 に英数字文字列「abc123」が含まれている場合、関数 Upper(A2) は文字列「ABC123」を返します。

Value(数値テキスト)

数値テキストの浮動小数点値を返します。後続の数値以外の文字は無視されます。

Closed Value の例

セル A2 に数値文字列「123.4」が含まれている場合、関数 Value(A2) は浮動小数点値 123.400を返します。

注: In-Sight セルでは、7 桁までの数値を入力できます。Value 関数が、8 桁以上の数値テキストを参照する場合、浮動小数点データ型の制限により、値が正確ではないことがあります。次に例を示します。

A2 = '68456668

A3 = Value(A2)

この場合、68456672.000 が返されます。

関連項目

  • 文字列操作関数について
  • Binary Text 関数
  • [関数の挿入] ダイアログ
Version: 5.6.0


座標補正関数

In-Sight 関数リファレンス

座標補正関数は、画像、フィクスチャ、およびワールド座標系の間で特徴の位置および距離を変換する補正関数です。

  • Calibrate 関数: ピクセルと 2 次元のワールド座標系との間で変換する補正について解決します。
  • Fixture 関数: フィクスチャとピクセル座標系との間で変換する補正について解決します。


Calibrate 関数

座標補正関数

In-Sight 関数リファレンス

キャリブレーションとは、ピクセルの計測値を、わかり易い実世界値に変換するプロセスです。このプロセスでは、2 次元 (2D) 変換によって、画像のピクセル座標の点をワールド座標へ数学的にマッピングします。画像のキャリブレーションが完了すると、ほかのビジョンツールは、そのキャリブレーションを入力として参照することで、結果をキャリブレーションされた単位 (実世界値) で報告できるようになります。

In-Sight Explorer では、3 つの異なるキャリブレーション方法、キャリブレーションを画像に関連付ける手段、および画像座標とワールド座標間で変換を行う 10 個の座標補正関数を提供しています。

  • Calibrate 関数: ユーザ指定の 4 つの点を使用して、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。線形および非線形歪みを補正します。
  • CalibrateAdvanced 関数: ユーザ指定の 1 ～ 32 個の点を使用して、ピクセル座標系とワールド座標系の間で変換を行うための 2D 変換を作成します。線形および非線形歪みを補正し、Calibrate 関数よりも高精度です (5 つ以上の点を使用)。
  • CalibrateGrid 関数: ユーザ設定可能なキャリブレーショングリッドパターンを使用して、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。線形、非線形、およびレンズ歪みを補正し、最も高い精度を提供します。
注:
  • Calibrate 関数、CalibrateAdvanced 関数、または CalibrateGrid 関数を使用する場合、物理セットアップと光学セットアップ (レンズ、センサ、およびセンサと取り込まれるシーンの間の物理的関係) はキャリブレーション操作とランタイム操作の両方で同一にする必要があります。このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。したがって、キャリブレートとランタイム画像の処理の両方で、同じセンサとレンズを使用することを推奨します。センサとレンズでは、元のセットアップおよびキャリブレーション設定を変更しないようにする必要があります。例えば、画像取り込みフォーマットの変更 (解像度の変更による) またはセンサの移動を行うと、ピクセルをワールド座標にマッピングする 2D 変換が不正になります。
  • In-Sight 5604 ラインスキャンビジョンシステムは、ピクセル座標でのみ動作します。In-Sight 5604 で実行されているジョブに Calibrate 関数が追加されていると、不正な結果がもたらされます。
  • CalibrateImage 関数: 構造体を [image] 構造体に関連付けます。これは、ほかのビジョンツールから参照することができます。
  • ExtractCalibration 関数: TransformImage 関数によって返される [image] 構造体に基づいて、ワールド座標への 2D 変換を作成します。
  • TransBlobsToWorld 関数: 構造体のピクセル座標をワールド座標に変換します。
  • TransEdgesToWorld 関数: 構造体のピクセル座標をワールド座標に変換します。
  • TransFixtureToWorld 関数: フィクスチャのピクセル座標をワールド座標に変換します。
  • TransformImage 関数: CalibrateGrid 関数に存在する歪みを補正する [image] 構造体を生成します。
  • TransInspEdgeDefectToWorld 関数: InspectEdgeForDefect [image] データ構造体のピクセル座標をワールド座標に変換します。
  • TransInspEdgeWidthToWorld 関数: InspectEdgeWidth [image] データ構造体のピクセル座標をワールド座標に変換します。
  • TransOCRMaxToWorld 関数: データ構造体のピクセル座標をワールド座標に変換します。
  • TransPatternsToWorld 関数: 構造体のピクセル座標をワールド座標に変換します。
  • TransPixelToWorld 関数: ピクセル座標からワールド座標に点を変換します。
  • TransSurfaceFlawToWorld 関数: 構造体のピクセル座標をワールド座標に変換します。
  • TransWorldToPixel 関数: ワールド座標をピクセル座標に変換します。

注意: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。


Calibrate 関数

Calibrate 関数 |
座標補正関数 → Calibrate 関数 | In-Sight 関数リファレンス

Calibrate 関数では、ユーザ指定の 4 つの点を使用して、ピクセル座標系とワールド座標系の間で変換を行うための 2D 変換を作成します。このプロセスで、Calibrate 関数は線形および非線形歪みを補正します。

Calibrate 関数 (

ピクセルポイント 0.行 ,

ピクセルポイント 0.列 ,

ワールドポイント 0.X ,

ワールドポイント 0.Y ,

ピクセルポイント 1.行 ,

ピクセルポイント 1. 列 ,

ワールドポイント 1.X ,

ワールドポイント 1.Y ,

ピクセルポイント 2.行 ,

ピクセルポイント 2. 列 ,

ワールドポイント 2.X ,

ワールドポイント 2.Y ,

ピクセルポイント 3.行 ,

ピクセルポイント 3. 列 ,

ワールドポイント 3.X ,

ワールドポイント 3.Y ,

表示

)

概要Calibrate 関数

Calibrate 関数では、ユーザ指定のポイントを 2 つの異なる座標系で表す必要があります。取り込む対象物はワールド座標系、対象物の画像はピクセル座標で表します。これを実行するには、Calibrate 関数でビジョンツールを使用して、画像から特徴を抽出する必要があります。次に、これらの特徴の位置をワールド座標とピクセル座標で入力します。

キャリブレーションフェーズでは、ワールド座標での位置が分かっている特徴を含んでいる画像が取り込まれます。ExtractBlobs、FindPatterns、または FindLine などのビジョンツールを使用して、画像内の特徴を探してピクセル座標で報告します。

注: ピクセル座標の原点は、常に左上のピクセルの左上の角です。

次に、ピクセル座標とワールド座標の両方を [ピクセルポイント] および [ワールドポイント] パラメータとして入力します。[ピクセルポイント] 座標では、ビジョンツールの行と列の値へのセル参照が使用されますが、[ワールドポイント] ワールド座標を表すには数値が使用されます。次に、ピクセル座標とワールド座標の間で 2D 変換が計算され、この変換を表す [image] 構造体が作成されます。

Calibrate 関数は次の変換も実行します。

  • 2 次元での平行移動
  • 3 本の軸まわりの回転
  • 2 次元でのスケーリング
  • 遠近歪み
  • パラレログラミングまたはスキュー
注:
  • Calibrate 関数、CalibrateAdvanced 関数、または CalibrateGrid 関数を使用する場合、物理セットアップと光学セットアップ (レンズ、センサ、およびセンサと取り込まれるシーンの間の物理的関係) はキャリブレーション操作とランタイム操作の両方で同一にする必要があります。このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。したがって、キャリブレートとランタイム画像の処理の両方で、同じセンサとレンズを使用することを推奨します。センサとレンズでは、元のセットアップおよびキャリブレーション設定を変更しないようにする必要があります。例えば、画像取り込みフォーマットの変更 (解像度の変更による) またはセンサの移動を行うと、ピクセルをワールド座標にマッピングする 2D 変換が不正になります。
  • In-Sight 5604 ラインスキャンビジョンシステムは、ピクセル座標でのみ動作します。In-Sight 5604 で実行されているジョブに Calibrate 関数が追加されていると、不正な結果がもたらされます。

Calibrate 関数の入力パラメータ

ピクセルポイント 0 to 3

ピクセルとワールドの関連付けのピクセル座標系を指定します。

行 | 画像の行座標。
列 | 画像の列座標。

ワールドポイント 0 to 3

ピクセルとワールドの関連付けのワールド座標系を指定します。

X | ワールド値での X 軸座標。
Y | ワールド値での Y 軸座標。

表示

画像上の Calibrate グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | Calibrate 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、4 つのキャリブレーションポイントは表示されません。
2 = 入力のグラフィックスのみ | 4 つのキャリブレーションポイントは常に表示されます。

Calibrate 関数の出力

戻り値

2 つの座標系間の変換を定義する係数を含んでいる [image] データ構造体

関連項目

CalibrateAdvanced 関数

CalibrateGrid 関数

CalibrateImage 関数

座標補正関数について

キャリブレーション関数について

プロパティシートの使用方法


CalibrateAdvanced 関数

CalibrateAdvanced 関数 |
座標補正関数 → Calibrate 関数 | In-Sight 関数リファレンス

CalibrateAdvanced 関数で、ユーザ指定の 1 ～ 32 個の点を使用して、ピクセル座標系とワールド座標系の間で変換を行うための 2D 変換を作成します。このプロセスで、CalibrateAdvanced 関数は線形および非線形の歪みを補正し、5 組以上のポイントペアを使用して、Calibrate 関数よりも高い精度を提供します。

CalibrateAdvanced 関数 (

ピクセルポイント 0.行 ,

ピクセルポイント 0.列 ,

ワールドポイント 0.X ,

ワールドポイント 0.Y ,

...,

ピクセルポイント 31.行 ,

ピクセルポイント 31.列 ,

ワールドポイント 31.X ,

ワールドポイント 31.Y

)

概要CalibrateAdvanced 関数

ちょうど Calibrate 関数と同じように、CalibrateAdvanced 関数でユーザ指定のポイントを 2 つの異なる座標系で表す必要があります。取り込む対象物はワールド座標系、対象物の画像はピクセル座標で表します。

さらに、Calibrate 関数のように、CalibrateAdvanced 関数ではビジョンツールを使用して、画像から特徴を抽出する必要があります。ただし、これら 2 つの関数の違いは、位置として使用できる特徴の数、およびこれらの特徴の位置をワールド座標とピクセル座標の両方で入力する方法です。CalibrateAdvanced 関数では、ポイントペアと呼ばれる、1 ～ 32 個のピクセルとワールド座標の組み合わせが可能であるのに対して、Calibrate 関数では 4 組のポイントペアが必要です。

CalibrateAdvanced 関数を使用すると、キャリブレーションフェーズで、ワールド座標での位置が分かっている 1 ～ 32 個の異なる特徴を含んでいる画像が取り込まれます。ExtractBlobs、FindPatterns、または FindLine などのビジョンツールを使用して、画像内の特徴を探してピクセル座標で報告します。

注: ピクセル座標の原点は、常に左上のピクセルの左上の角です。

次に、ピクセル座標とワールド座標の両方を引数として入力します。ピクセル座標の場合、ビジョンツールの [行] と [列] の値へのセル参照を使用できますが、ワールド座標を表すには、数値を入力することができます。次に、ワールド座標とピクセル座標の間で 2D 変換が計算され、この変換を表す [image] 構造体が作成されます。

注
  • CalibrateAdvanced 関数にはプロパティシートはありません。この関数は、何組かのポイントペアによって表される 1 ～ 32 個の可変引数に基づきます。例えば、CalibrateAdvanced 関数がスプレッドシートに挿入され、5 つの異なるブロブを報告した ExtractBlobs 関数を使用してシステムをキャリブレーションした場合、ピクセル座標は、報告された ExtractBlobs ツールの [行] と [列] の値へのセル参照として表されます。次に、特定のワールド座標の値に従ってワールド座標が設定され、次の式となります。CalibrateAdvanced($D$11,$D$12,0,0,$E$11,$E$12,2,0,$F$11,$F$12,2,2,$G$11,$G$12,0,2,$H$11,$H$12,1,2).
  • セルに入力できる最大文字数は 255 文字です。255 を超える文字を使用して可変引数を指定すると、エラーメッセージが表示されます。可変引数の指定に使用した文字列が 255 文字の制限を超える場合は、セル範囲を使用します。ワールド座標は、X および Y の値を直接セルに入力することによって、セル範囲に含めることもできます。例えば、セル範囲を使用して 32 組のポイントペアを指定する場合、次の式を使用することができます。CalibrateAdvanced(C11:F42)

CalibrateAdvanced 関数では次の変換を実行します。

  • 2 次元での変換 (1 組以上のポイントペアを使用)
  • 3 本の軸まわりの回転 (4 組以上のポイントペアを使用)
  • 2 次元でのスケーリング (2 組以上のポイントペアを使用)
  • 遠近歪み (4 組以上のポイントペアを使用)
  • パラレログラミングまたはスキュー (4 組以上のポイントペアを使用)
注:
  • Calibrate 関数、CalibrateAdvanced 関数、または CalibrateGrid 関数を使用する場合、物理セットアップと光学セットアップ (レンズ、センサ、およびセンサと取り込まれるシーンの間の物理的関係) はキャリブレーション操作とランタイム操作の両方で同一にする必要があります。このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。したがって、キャリブレートとランタイム画像の処理の両方で、同じセンサとレンズを使用することを推奨します。センサとレンズでは、元のセットアップおよびキャリブレーション設定を変更しないようにする必要があります。例えば、画像取り込みフォーマットの変更 (解像度の変更による) またはセンサの移動を行うと、ピクセルをワールド座標にマッピングする 2D 変換が不正になります。
  • In-Sight 5604 ラインスキャンビジョンシステムは、ピクセル座標でのみ動作します。In-Sight 5604 で実行されているジョブに Calibrate 関数が追加されていると、不正な結果がもたらされます。

CalibrateAdvanced 関数の入力パラメータ

ピクセルポイント 0-31

ピクセルとワールドの関連付けのピクセル座標系を指定します。

行 | 画像の行座標。
列 | 画像の列座標。

ワールドポイント 0-31

ピクセルとワールドの関連付けのワールド座標系を指定します。

X | ワールド値での X 軸座標。
Y | ワールド値での Y 軸座標。

CalibrateAdvanced 関数の出力

戻り値

2 つの座標系間の変換を定義する係数を含んでいる [image] データ構造体

関連項目

Calibrate 関数

CalibrateGrid 関数

CalibrateImage 関数

座標補正関数について

キャリブレーション関数について

プロパティシートの使用方法


CalibrateGrid 関数

CalibrateGrid 関数 |
座標補正関数 → Calibrate 関数 | In-Sight 関数リファレンス

CalibrateGrid 関数は、ユーザ設定可能なキャリブレーショングリッドパターンを使用して、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。また、CalibrateGrid 関数は、線形、非線形、およびレンズ歪みを補正し、Calibrate 関数の中で最も高い精度を実現します。

  • CalibrateGrid 関数について
  • [CalibrateGrid] ダイアログペインとコントロール
  • CalibrateGrid 関数の使用方法
  • CalibrateGrid の出力
  • 関連項目

概要CalibrateGrid 関数

CalibrateGrid 関数は、キャリブレーションドットグリッドパターンで検出されたドットまたはチェッカボードキャリブレーショングリッドパターンの頂点によって識別される点のセット間での 2D 変換を計算します。さらに、CalibrateGrid 関数は、画像の取り込みに使用されているレンズの放射歪みまたは遠近歪みを自動的に補正します。

注: 歪みのない画像上でビジョンツールを表示または利用する場合は、TransformImage 関数を使用します。

CalibrateGrid 関数を使用するには、関数をスプレッドシートの空白セルに挿入し、[CalibrateGrid] ダイアログの [セットアップ] ペインを表示します。キャリブレーションパターンは、CalibrateGrid の [セットアップ] ペインで設定します。

  • 使用するキャリブレーショングリッドパターンのタイプ
  • キャリブレーショングリッドパターンの間隔
  • 実世界のタイプ、物理測定単位
  • ポーズの数を 1 ～ 30 に設定

キャリブレーションプレートグリッドがない場合は、オプションで印刷することができます。次に [ポーズ] ペインを使用して、パターンの画像を取り込みます。画像が取り込まれると、CalibrateGrid 関数は可能な限り多くの特徴点を自動的に識別します。[キャリブレーション] ボタンをクリックすると、CalibrateGrid 関数は直ちにキャリブレーションの計算を開始し、特徴点の間隔に基づいた「キャリブレーション得点」を報告します。結果は、[結果] ペインに表示されます。

キャリブレーションの実行が完了すると、キャリブレーションデータは [CalibrateGrid] セルに格納されます。これによって、CalibrateGrid 関数を 1 つのジョブからコピーして別のジョブに貼り付けること、または [セルのエクスポート]、[セルのインポート] を使用して外部ファイルとしてエクスポートおよびインポートすることができるようになります。さらに、必要であれば、各ジョブに異なるキャリブレーションを設定することや、1 つのジョブに複数のキャリブレーションを設定することもできます。なお、キャリブレーション関数を引数として使用するほかの関数は、CalibrateGrid データ構造体を参照することができます。

注:
  • Calibrate 関数、CalibrateAdvanced 関数、または CalibrateGrid 関数を使用する場合、物理セットアップと光学セットアップ (レンズ、センサ、およびセンサと取り込まれるシーンの間の物理的関係) はキャリブレーション操作とランタイム操作の両方で同一にする必要があります。このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。したがって、キャリブレートとランタイム画像の処理の両方で、同じセンサとレンズを使用することを推奨します。センサとレンズでは、元のセットアップおよびキャリブレーション設定を変更しないようにする必要があります。例えば、画像取り込みフォーマットの変更 (解像度の変更による) またはセンサの移動を行うと、ピクセルをワールド座標にマッピングする 2D 変換が不正になります。
  • In-Sight 5604 ラインスキャンビジョンシステムは、ピクセル座標でのみ動作します。In-Sight 5604 で実行されているジョブに Calibrate 関数が追加されていると、不正な結果がもたらされます。

[CalibrateGrid] ダイアログペインとコントロール

[CalibrateGrid] ダイアログはキャリブレーション用の 3 つのペインで構成されます。

  • [セットアップ] ペイン
  • [ポーズ] ペイン
  • [結果] ペイン

[セットアップ] ペイン

コントロール 説明

グリッドタイプ

キャリブレーションの作成に使用するキャリブレーションパターンのタイプを指定します。[フィデューシャルつきチェッカボード]、[フィデューシャルなしチェッカボード]、[フィデューシャルつきドット]、または [フィデューシャルなしドット]

[フィデューシャルつきチェッカボード]

タイル頂点 (4 つのタイルの隅が接する点) は、特徴の位置の判定に使用されます。センサの表面に対する角度が 45 度以内になっていれば、頂点の位置を正確に検出することができます。また、グリッドの原点および実世界空間におけるグリッドの角度を識別するために、フィデューシャルマーカが提供されています。

注: チェッカボードの格子の幅は、少なくとも 15 ピクセルにする必要があります。

[フィデューシャルなしチェッカボード]

タイル頂点 (4 つのタイルの隅が接する点) は、特徴の位置の判定に使用されます。センサの表面に対する角度が 45 度以内になっていれば、頂点の位置を正確に検出することができます。また、原点は [グリッドの軸] を使用して設定する必要があります。

注: チェッカボードの格子の幅は、少なくとも 15 ピクセルにする必要があります。

[フィデューシャルつきドット]

チェッカボードのパターンと対比することで、視野全体での照明のばらつきおよび画像のノイズによる影響を少なくします。特徴の位置は、ドットの中心で決まります。ドットの位置は、センサの表面に対する角度が 30 度以内になっていれば検出することができます。また、グリッドの原点および実世界空間におけるグリッド角度を識別するため、さらにグリッド間隔を識別および設定するために、フィデューシャルマーカが提供されます。

注:
  • 画像内にあるドットの推奨されるピクセルの直径は、15 ～ 30 ピクセルの間です。最小値と最大値の範囲は、6 ～ 50 ピクセルです。ピクセルの直径が 50 を超えるドットまたは 6 未満のドットは、ツールによって検出されません。
  • [フィデューシャルつきドット] キャリブレーションパターンでは、キャリブレーションパターンの中に特別な識別コードがあります。このコードは、[グリッド間隔] フィールドおよび [単位] フィールドの値によって決まります。キャリブレーションパターンが画像として取り込まれると、キャリブレーションツールはこのパターンを読み込み、キャリブレーションパターンにあるコードに基づいて自動的に [グリッド間隔] フィールドと [単位] フィールドの値を設定します。実際のグリッドサイズと埋め込まれているコードが一致していない状況で、印刷された同じ [フィデューシャルつきドット] キャリブレーションパターンを使用する必要がある場合は、[グリッドタイプ] フィールドで [フィデューシャルなしドット] を選択し、[グリッド間隔] フィールドと [単位] フィールドに手動で値を入力します。その後、各ポーズに対して、[グリッドの軸] のフィールド ([原点の選択]、[X 軸の選択]、および [Y 軸の選択]) に値を入力します。コード化されたシンボルを自動的に挿入しない [フィデューシャルつきドット] キャリブレーションパターンを作成するには、単純に、[グリッド間隔] フィールドと [単位] フィールドの値を 15 個ある設定済みパターン以外の組み合わせに設定します。特別な識別コードを持つ 15 個の設定済みキャリブレーションパターンは、次のようになっています。
インチ単位 | ミリメートル単位
0.1 | 1
0.125 | 2
0.25 | 5
0.5 | 10
1 | 20
2 | 50
4 | 100
12 |

[フィデューシャルなしドット]

チェッカボードのパターンと対比することで、視野全体での照明のばらつきおよび画像のノイズによる影響を少なくします。特徴の位置は、ドットの中心で決まります。ドットの位置は、センサの表面に対する角度が 30 度以内になっていれば検出することができます。また、原点は [グリッドの軸] を使用して設定する必要があります。

注: 取り込まれた画像内でのドットの直径は、少なくとも 10 ピクセルになっている必要があります (ただし、推奨値は 15)。

[グリッド間隔]:

チェッカボードパターン内にある正方形のサイズ、またはドットグリッドパターン内にあるドットの中心から中心への距離のいずれかを指定します (0.0000001 ～ 9999999、デフォルト = 10.00)。

[単位]:

実世界の測定単位 ([ミクロン]、[ミリメートル] (デフォルト設定)、[センチメートル] または [インチ]) で、キャリブレーションはこの単位に基づいています。

[ポーズ数]:

キャリブレーションの完了に必要なポーズの数を指定します。1 つのキャリブレーションパターンで視野全体をカバーできない場合は、複数のポーズを使用する必要があります。このタイプのキャリブレーションでは、視野をカバーするために、キャリブレーションパターンはさまざまな物理的位置に配置されます。キャリブレーションパターンの各位置は、「ポーズ」と呼ばれます。CalibrateGrid 関数では、1 ～ 30 個のポーズを処理することができます。2 つ以上のポーズを選択した場合は、[ポーズ位置] のオプションが有効になります。これらのオプションは、ポーズ間におけるキャリブレーションパターンの予想される動きを指定するために使用します。

[レンズモデル]:

画像取得に使用されているレンズタイプに基づいて、歪み補正のタイプ ([放射歪み補正] または [遠近歪み補正]、デフォルト = [放射歪み補正]) を指定します。「放射歪み」とは、視野周辺部の倍率と、視野中央部の倍率が異なる光学レンズに生じる歪みのことです。放射歪みは、通常、視野の広いレンズでより深刻となります。例えば、広角レンズは、望遠レンズより深刻な放射歪みが発生する傾向があります。「遠近歪み」とは、取得されるシーンに対し、ビジョンシステムの光学軸が直角でない場合に発生する歪みのことです。

[グリッドの印刷]:

[グリッドの印刷] ボタンをクリックして、選択した [グリッドタイプ] を印刷します。

注: [グリッドの印刷] 機能は、高い精度を要求されない測定および検証を行う場合にのみ使用してください。高い精度と確度が要求されるアプリケーションには使用できません (高い精度と確度が要求されるアプリケーションには、正確に作成されたキャリブレーションパターンが必要になります)。

[ポーズ位置] - [自動] (デフォルト):

CalibrateGrid 関数による複数のポーズの設定方法を指定します (このオプションを有効にするには、[ポーズ数] パラメータに 2 よりも大きい値を設定する必要があります)。[自動] モードでは、ビジョンシステムでの光学キャリブレーション (遠近とレンズの歪みの修正) のみが可能です。[自動] モードを使用して、キャリブレーショングリッドの複数のビューをつなぎ合わせて最初のポーズビューの座標系にすると、入力が必要となるワールド座標値は、ポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートすることができます。

[ポーズ位置] - [ユーザ指定]:

CalibrateGrid 関数による複数のポーズの設定方法を指定します (このオプションを有効にするには、[ポーズ数] パラメータに 2 よりも大きい値を設定する必要があります)。[ユーザ指定] モードを使用して、ハンドアイキャリブレーションを実行することができます。このキャリブレーションタイプは、遠近とレンズの光学歪みを修正するためのデータを提供するだけでなく、画像座標空間からモーション座標空間へのカメラのキャリブレーションも行います。[ユーザ指定] モードをマルチビューキャリブレーションに使用すると、各ビューでモーションデバイスのポーズを手動で入力する必要があります。

[ポーズ] ペイン

コントロール 説明

[原点の位置 (ワールド座標系)]:

原点の X 位置と Y 位置をワールド座標で指定します。さらに、グリッドの軸の角度関係と実世界軸の間に不一致がある場合は、[角度] を指定することもできます。

注: [セットアップ] ペインで [ポーズ位置] を有効にして [ユーザ指定] モードを選択した場合、[原点の位置 (ワールド座標系)] を実際に使用して、キャリブレーションプレートの原点の位置と角度ではなく、モーションデバイスのモーションポーズを指定します。

[特徴点検出数]:

 キャリブレーションで使用する抽出された特徴点の総数を表示します。

[画像取り込み]:

画像の取り込み方法を指定します。

[トリガ]: | [トリガ] ボタンを手動でクリックして画像を取り込むように指定します。
[ライブビデオ]: | In-Sight ビジョンシステムがライブビデオモードに切り替わり、ビジョンシステムのフォーカスが調整されます。
[画像ファイルを開く]: | [開く] ダイアログを使用して画像をロードするように指定します。

[グリッドの軸]:

 フィデューシャルなしのキャリブレーションパターン ([フィデューシャルなしチェッカボード]、[フィデューシャルなしドット]) が選択されている場合は、キャリブレーションパターンのグリッドの軸を指定します。

[領域の調整]:

 対話型グラフィックスモードが開始され、キャリブレーションの対象領域を定義します。その対象領域内の特徴のみがキャリブレーションで使用されます。

特徴点テーブル:

画像から抽出された特徴点のピクセル行とピクセル列の座標のほかに、キャリブレーションパターンの位置が原点に対するグリッド座標 (X, Y) で表示されます。原点の値が変わると、常に X 座標と Y 座標が更新されます。抽出された特徴点は、各特徴の位置に緑色の「x」でグラフィカルに表示されます。テーブルから特徴点を選択、またはグラフィックス表示の特徴点をクリックすると、テーブルとグラフィックス表示の両方でその特徴点がハイライトされ、その座標がグラフィカルに表示されます。

[結果] ペイン

コントロール 説明

[特徴点の総数]:

キャリブレーションで使用する抽出された特徴点の総数を表示します。

[平均エラー]:

キャリブレーション中の平均エラーをピクセル単位で表示します。

[最大エラー]:

キャリブレーション中の最大エラーをピクセル単位で表示します。
キャリブレーションのグラフィック:

キャリブレーションをグラフィカル形式で表示します。

  • 非常によい = エラー <= 0.25
  • よい = 0.25 < エラー <= 0.5
  • やや悪い = 0.5 < エラー <= 2.0
  • 悪い = 2.0 < エラー <= 5.0
  • 非常に悪い = 5.0 < エラー

特徴点テーブル:

画像から抽出された特徴点のピクセル行とピクセル列の座標のほかに、キャリブレーションパターンの位置が原点に対するグリッド座標 (X, Y) で表示されます。原点の値が変わると、常に X 座標と Y 座標が更新されます。抽出された特徴点は、各特徴の位置に緑色の「x」でグラフィカルに表示されます。テーブルから特徴点を選択、またはグラフィックス表示の特徴点をクリックすると、テーブルとグラフィックス表示の両方でその特徴点がハイライトされ、その座標がグラフィカルに表示されます。

使用方法CalibrateGrid 関数

CalibrateGrid 関数を使用するプロセスは、次の手順で構成されています。

  • CalibrateGrid 関数の挿入
  • [セットアップ] ペインを使用したキャリブレーションパターンの設定
  • [グリッドの印刷] ダイアログを使用したキャリブレーションパターンの印刷
  • [ポーズ] ペインを使用したキャリブレーションパターンの画像の取得
  • [ポーズ] ペインでの原点の変更または設定 (オプション)
  • [グリッドの軸] を使用したフィデューシャルなしのキャリブレーションパターンの設定 (オプション)
  • [ポーズ] ペインを使用した複数のポーズの設定 (オプション)
  • [結果] ペインを使用したキャリブレーションの検証

CalibrateGrid 関数の挿入

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [座標補正] リストを展開します。
  3. 関数リストから CalibrateGrid 関数を選択して、[OK] ボタンを押します。

[セットアップ] ペインを使用したキャリブレーションパターンの設定

CalibrateGrid 関数を初めて挿入すると、[セットアップ] ペインが自動的に表示されます。

注: いずれかの [CalibrateGrid] ダイアログから [セットアップ] ダイアログに戻るには、ダイアログの左側にあるナビゲーションペインで単純に [セットアップ] を選択します。

  1. キャリブレーションパターンの設定を開始するには、[グリッドタイプ] パラメータからキャリブレーションパターンを選択します。
  2. [グリッド間隔] フィールドの値を設定します。この値は、チェッカボードパターン内にある正方形のサイズ、またはドットグリッドパターン内にあるドットの中心から中心への距離のいずれかを定義するために使用されます。
  3. [単位] フィールドの値を設定します。これは実世界の測定単位で、ワールド座標はこの単位に基づいています。

  4. キャリブレーションの完了に必要なポーズの数を決め、[ポーズ数] パラメータにその値を入力します。1 つのキャリブレーションパターンで視野全体をカバーできない場合は、複数のキャリブレーションパターンを使用する必要があります。このタイプのキャリブレーションでは、視野をカバーするために、キャリブレーションパターンはさまざまな物理的位置に配置されます。キャリブレーションパターンの各位置は、「ポーズ」と呼ばれます。CalibrateGrid 関数では、1 ～ 30 個のポーズを処理することができます。2 つ以上のポーズを選択した場合は、[ポーズ位置] のオプションが有効になります。これらのオプションは、ポーズ間におけるキャリブレーションパターンの予想される動きを指定するために使用します。

    デフォルト設定は [自動] になっています。この設定では、基本的にキャリブレーションパターンを自由に移動することができます。[自動] が選択されると、入力が必要となるワールド座標値はポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートされます。

    注: [自動] モードでは、ビジョンシステムでの光学キャリブレーション (遠近とレンズの歪みの修正) のみが可能です。

    モーションデバイスのモーション座標系との関係を確立するため、ハンドアイキャリブレーションを実行する場合は、[ユーザ指定] モードを選択します。各ビューでのモーションデバイスのポーズは、手動で入力する必要があります。キャリブレーションプレートとモーションデバイス間の (位置と方向の) 配置オフセットが分かっていないので、キャリブレーションプレートの元の位置を調べる必要はありません。

    注: [ユーザ指定] モードでは、光学キャリブレーションとモーションデバイスのキャリブレーションの両方が可能です。
  5. グリッドパターンを印刷する前に、[レンズモデル] ([放射歪み補正] または [遠近歪み補正]) を選択し、画像取得に使用されているレンズタイプに基づいて、歪み補正のタイプを定義します。「放射歪み」(デフォルト設定) とは、視野周辺部の倍率と、視野中央部の倍率が異なる光学レンズに生じる歪みのことです。放射歪みは、通常、視野の広いレンズでより深刻となります。例えば、広角レンズは、望遠レンズより深刻な放射歪みが発生する傾向があります。「遠近歪み」とは、取得されるシーンに対し、ビジョンシステムの光学軸が直角でない場合に発生する歪みのことです。

[グリッドの印刷] ダイアログを使用したキャリブレーションパターンの印刷

注: [グリッドの印刷] 機能は、高い精度を要求されない測定および検証を行う場合にのみ使用してください。高い精度と確度が要求されるアプリケーションには使用できません (高い精度と確度が要求されるアプリケーションには、正確に作成されたキャリブレーションパターンが必要になります)。

  1. キャリブレーションパターンの設定が完了したら、[グリッドの印刷] ボタンをクリックしてキャリブレーションパターンのコピーを印刷します。
  2. 印刷を実行する前に [ページ設定] ボタンをクリックし、[ページ設定] ダイアログを使用してキャリブレーションパターンを設定します。
  3. [印刷] ボタンをクリックして、[印刷] ダイアログを表示します。このダイアログから、キャリブレーションパターンの印刷を実行することができます。

[ポーズ] ペインを使用したキャリブレーションパターンの画像の取得

[セットアップ] ペインでのキャリブレーションパターンの設定が完了したら、ナビゲーションペインから [ポーズ] (または、複数のポーズを設定する場合は [ポーズ 1]) を選択します。[ポーズ] ペインが表示されます。

  1. キャリブレーション用画像の取り込みには、次の 3 つのオプションがあります。
  • トリガ
  • ライブビデオ
  • 画像ファイルを開く

注: 最も正確な結果を得るには、キャリブレーションパターンが視野全体で鮮明になるように焦点を調整します。また、特徴を処理する場合、CalibrateGrid 関数は特徴が白地に黒または黒地に白であるかどうかを判別しません。

  2. 画像の取り込みが完了すると、CalibrateGrid 関数は特徴点を自動的に抽出します。

  3. 抽出された各特徴を示すデータテーブルを表示するには、切り替えボタンをクリックします (テーブルを非表示にするにはボタンをもう一度クリック)。このテーブルには、画像から抽出された特徴点のピクセル行とピクセル列の座標のほかに、キャリブレーションパターンの位置が原点に対するグリッド座標 (X, Y) で表示されます。原点の値が変わると、常に X 座標と Y 座標が更新されます。抽出された特徴点は、各特徴の位置に緑色の「x」でグラフィカルに表示されます。テーブルから特徴点を選択、またはグラフィックス表示の特徴点をクリックすると、上の図のように、テーブルとグラフィックス表示の両方でその特徴点がハイライトされ、その座標がグラフィカルに表示されます。

新しい画像を取り込んだ場合または [ポーズ] ダイアログに戻った場合は常に、領域サイズの調整および特徴点の再抽出が行われ、結果表示も更新されます。デフォルトでは、画像全体が特徴点抽出に使用されます。[領域の調整] ボタンをクリックすると、対話型グラフィックスモードが開始されます。このモードでは、対象領域を定義し、その領域外にある画像部分を無視することができます。

[ポーズ] ペインでの原点の変更または設定 (オプション)

[セットアップ] ペインで [ポーズ位置] を有効にして [自動] モードを選択した場合、[原点の位置] フィールドを使用して、ワールド座標系で原点の X と Y の位置を指定します。さらに、グリッドの軸の角度関係と実世界軸の間に不一致がある場合は、[角度] フィールドを使用してその角度を入力することができます。例えば、原点が画像の隅にあるよりも対象物の中心にある方が便利な場合は、原点を変更することができます。キャリブレーションの原点位置は、[原点の位置 (ワールド座標系)] にある [X]、[Y]、および [角度] フィールドの値を調整することで変更できます。 ボタンをクリックして値を増減するか、または必要な数値を手動で入力します。[自動] が選択されると、入力が必要となるワールド座標値はポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートされます。

[セットアップ] ペインで [ポーズ位置] を有効にして [ユーザ指定] モードを選択した場合、[原点の位置 (ワールド座標系)] を実際に使用して、キャリブレーションプレートの原点の位置と角度ではなく、モーションデバイスのモーションポーズを指定します。[ユーザ指定] モードを使用してハンドアイキャリブレーションを実行し、モーションデバイスのモーション座標系との関係を確立します。各ビューでのモーションデバイスのポーズは、手動で入力する必要があります。キャリブレーションプレートとモーションデバイス間の (位置と方向の) 配置オフセットが分かっていないので、キャリブレーションプレートの元の位置を調べる必要はありません。

[グリッドの軸] を使用したフィデューシャルなしのキャリブレーションパターンの設定 (オプション)

使用するキャリブレーションパターンにフィデューシャルがない場合は、[グリッドの軸] にある設定を使用して原点および X 座標軸と Y 座標軸を定義する必要があります。[グリッドの軸] にある設定は、フィデューシャルのないキャリブレーションパターンを選択した場合にのみ利用可能になり表示されます。

  1. 画像の処理と特徴の抽出が完了したら、[原点の選択] ボタンをクリックします。

  2. これにより対話型グラフィックスモードが開始されます。このモードからハイライトされている点のいずれかをダブルクリックし、原点として選択します。

注: 抽出されたすべての特徴を原点にできるわけではありません。特徴点に 90 度離れている 2 つの隣接点が存在しない場合は、その特徴点を原点として選択することはできません。

  3. 原点の設定が完了すると、次の図のように、[スプレッドシートビュー] ウィンドウで原点がハイライトおよび表示され、データテーブルでは選択した原点座標が自動的にハイライトされます。

  4. 次に、[X 軸の選択] ボタンをクリックすると、対話型グラフィックスモードが開始されます。このモードからハイライトされている点のいずれかをダブルクリックし、X 軸として選択します。

  5. X 軸の設定が完了すると、次の図のように、[スプレッドシートビュー] ウィンドウで X 軸がハイライトおよび表示され、データテーブルでは選択した X 軸座標が自動的にハイライトされます。

  6. 次に、[Y 軸の選択] ボタンをクリックすると、再び対話型グラフィックスモードが開始されます。このモードからハイライトされている点のいずれかをダブルクリックし、Y 軸として選択します。

  7. Y 軸の設定が完了すると、次の図のように、[スプレッドシートビュー] ウィンドウで Y 軸がハイライトおよび表示され、データテーブルでは選択した Y 軸座標が自動的にハイライトされます。

  8. 最後に、原点、X 軸、および Y 軸の設定が完了したら、[キャリブレーション] ボタンをクリックして [結果] ペインに進み、キャリブレーションを終了するか、またはほかのポーズを設定する場合はナビゲーションペインで [ポーズ] を選択します。

[ポーズ] ダイアログを使用した複数のポーズの設定 (オプション)

[自動] モード:

1 つのキャリブレーションパターンで視野全体をカバーできない場合は、複数のキャリブレーションパターンを使用する必要があります。ここで説明する複数のポーズを扱う状況では、フィデューシャルつきのドットグリッドパターンが使用されています。

  1. ポーズ 1 の [原点の位置 (ワールド座標系)] を指定します。

    2. 注: [自動] が選択されると、入力が必要となるワールド座標値はポーズ 1 内にある原点のワールド座標のみになります。ほかのすべてのポーズは、フィデューシャルが検出されている限り、各ポーズの原点を指定しなくてもキャリブレートされます。

  2. ポーズ 1 に続くポーズごとに、新しい画像をロードするか、取り込む必要があります。
  3. すべてのポーズの設定が完了したら、[キャリブレーション] ボタンをクリックして [結果] ダイアログに進み、キャリブレーションを終了します。

[ユーザ指定] モード:

キャリブレーションのために、各ポーズ用に異なる物理的位置に配置されているパターンを含む複数のポーズが必要になることがあります。その場合、キャリブレーションシーケンスの中で、キャリブレーションパターンを複数の位置に正確に移動する必要があります。これはモーションデバイスを使用して行うこともできますが、モーションデバイス制御ソフトウェアは自動化に対応していません。したがって、モーションデバイスを使用する場合は、処理を進める前に、モーションデバイスコントローラによってモーションデバイスを手動で操作してそれぞれの新しいポーズに移動する必要があります。

  1. 各モーションポーズの [原点の位置 (ワールド座標系)] を指定します。モーションデバイスのポーズは、各ビューに手動で入力する必要があります。

    2. 注: [原点の位置 (ワールド座標系)] を [ユーザ指定] モードで実際に使用して、キャリブレーションプレートの原点の位置と角度ではなく、モーションデバイスのモーションポーズを指定します。キャリブレーションプレートとモーションデバイス間の (位置と方向の) 配置オフセットが分かっていないので、キャリブレーションプレートの元の位置を調べる必要はありません。

  2. ポーズ 1 に続くポーズごとに、追加の各ポーズの新しい画像を取り込む必要があります。
  3. すべてのポーズの設定が完了したら、[キャリブレーション] ボタンをクリックして [結果] ダイアログに進み、キャリブレーションを終了します。

[結果] ダイアログを使用したキャリブレーションの検証

[キャリブレーション] ボタンをクリックすると、CalibrateGrid 関数が最適な 2D 変換の計算を開始し、画面は自動的に [結果] ペインに切り替わります。[結果] ペインにはキャリブレーションの概要が表示されます。この概要には、検出された特徴点の総数、およびピクセル単位でキャリブレーションの平均エラーと最大エラーが示されます。エラーレベルの評価は、次のレート値を使用して、平均エラーに基づいて割り当てられます。

  • 非常によい = エラー <= 0.25
  • よい = 0.25 < エラー <= 0.5
  • やや悪い = 0.5 < エラー <= 2.0
  • 悪い = 2.0 < エラー <= 5.0
  • 非常に悪い = 5.0 < エラー

この評価は、キャリブレーション全体の「得点」と見ることができます。例えば、特徴点のグリッド上での間隔が不均等になっている場合は、得点が低くなります。また、複数ポーズのキャリブレーションで、ポーズ位置に [ユーザ指定] が選択されていると、ポーズの 1 つが正しく配置されなかった場合も得点が低くなります。

結果が許容可能であれば、[OK] ボタンをクリックしてキャリブレーションを終了します。キャリブレーションが正常に完了すると、スプレッドシートに [image] データ構造体が挿入されます。

CalibrateGrid 関数の出力

戻り値

2 つの座標系間の変換を定義する係数を含んでいる [image] データ構造体

関連項目

  • Calibrate 関数
  • CalibrateAdvanced 関数
  • ExtractCalibration 関数
  • TransformImage 関数
  • 座標補正関数について
  • キャリブレーション関数について
  • プロパティシートの使用方法
Version: 5.6.0


CalibrateImage 関数

CalibrateImage 関数 |
座標補正関数 → Calibrate 関数 | In-Sight 関数リファレンス

キャリブレーションを画像と関連付けます。

CalibrateImage 関数 (

画像,

キャリブレーション,

)

CalibrateImage 関数で、 [image] データ構造体を [image] データ構造体と関連付けて、新しい [image] データ構造体を作成します。その結果得られるデータ構造体は、参照されたキャリブレーションによって定義されたワールド座標にその結果を表示するため、他のビジョンツール関数によって参照することができます。

例えば、センサは CalibrateGrid などの座標補正関数を使用してキャリブレーションします。次に、CalibrateImage 関数を挿入し、[キャリブ] パラメータを、最近作成された CalibrateGrid 関数の [image] 構造体へのセル参照として設定します。次に、ExtractBlobs などの別のビジョンツールを使用してその [画像] パラメータを CalibrateImage 関数のデータ構造体へのセル参照として設定します。これによって、ExtractBlobs 座標はキャリブレーションされた画像のワールド座標となります。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

CalibrateImage 関数の入力パラメータ

画像 | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。
キャリブ | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

CalibrateImage 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注: データ構造体にある処理済みの画像領域の内容は、ジョブとともに保存されることはありません。

関連項目

Calibrate 関数

CalibrateAdvanced 関数

CalibrateGrid 関数

座標補正関数について

キャリブレーション関数について

プロパティシートの使用方法


ExtractCalibration 関数

座標補正 → キャリブレーション

In-Sight 関数リファレンス

ExtractCalibration 関数は、TransformImage 関数によって返された「歪みのない」画像に基づいて、ワールド座標で 2D 変換を作成し、NeighborFilter、PointFilter、または ScaleImage 関数によって出力された [image] データ構造体に含まれているキャリブレーションデータを取得します。ExtractCalibration 関数は、ExtractColor 関数によって出力される [image] データ構造体に含まれているキャリブレーションデータの抽出もサポートしています。

注: ExtractColor、NeighborFilter、PointFilter、および ScaleImage 関数を、ExtractCalibration 関数を使用して正常に動作させるため、これらの関数の画像パラメータを、 [image] データ構造体を返す関数を参照するように設定する必要があります。

ExtractCalibration 関数 (

画像,

)

概要ExtractCalibration 関数

TransformImage 関数を追加すると、自動的に ExtractCalibration 関数が挿入され、TransformImage 関数によって生成された画像で定義されたワールド座標に 2D 変換を関連付けます。TransformImage 関数によってその唯一の入力として生成された [image] データ構造体を使用して、ExtractCalibration 関数は [image] データ構造体を返し、このデータ構造体は、TransBlobsToWorld、TransEdgesToWorld、TransFixtureToWorld、TransPatternsToWorld、および TransPixelToWorld 関数のすべてまたはいずれかが TransformImage 関数によって生成された歪みのない画像で使用されていた場合に、参照として使用することができます。ExtractCalibration および TransformImage 関数は、CalibrateImage 関数を使用して関連付けることができます。

これとは別に、ExtractCalibration 関数をスプレッドシートに挿入して、その画像パラメータを NeighborFilter、PointFilter、または ScaleImage 関数によって出力された [image] データ構造体、または ExtractColor 関数によって出力された [image] データ構造体への参照として設定することができます。その後、ExtractCalibration 関数はこれらの関数に転送されているキャリブレーションデータを取得します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

ExtractCalibration 関数の入力パラメータ

画像

この引数は、NeighborFilter、PointFilter、ScaleImage、または TransformImage 関数によって作成される有効な [image] データ構造体、または ExtractColor 関数によって作成される有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。TransformImage 関数と組み合わせて自動的に挿入されると、デフォルトでは、参照されるセルは、TransformImage 関数によって返される [image] データ構造体を含んでいるセルであり、それ以外の場合、参照されるセルは AcquireImage 関数によって返される [image] データ構造体を含んでいる A0 です。

ExtractCalibration 関数の出力

戻り値

2 つの座標系間の変換を定義する係数を含んでいる [image] データ構造体

関連項目

TransformImage 関数

CalibrateGrid 関数

TransBlobsToWorld 関数

TransEdgesToWorld 関数

TransFixtureToWorld 関数

TransPatternsToWorld 関数

TransPixelToWorld 関数

座標補正関数について

キャリブレーション関数について

プロパティシートの使用方法


TransBlobsToWorld 関数

TransBlobsToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に [image] 構造体を変換します。指定のワールド座標系に対するブロブのオフセット、向き、面積を計算します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransBlobsToWorld の入力パラメータ
  • TransBlobsToWorld の出力
  • TransBlobsToWorld データアクセス関数
  • 関連項目

TransBlobsToWorld 関数の入力パラメータ

TransBlobsToWorld 関数(

キャリブレーション ,

ブロブ ,

変換する数

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
ブロブ | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
変換する数 | ワールド座標に変換する、元の [image] データ構造体からのブロブの数を指定します。(0 ～ 4096、デフォルト = 3)

TransBlobsToWorld 関数の出力

戻り値 | 変換されたブロブを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransBlobsToWorld 関数データアクセス関数

スプレッドシートに自動的に挿入されるデータアクセス関数は、FindBlobs 関数と SortBlobs 関数によって挿入されるものと同様になります。

関連項目

  • Calibrate 関数
  • ブロブツール
  • 座標補正関数について
  • プロパティシートの使用方法


TransEdgesToWorld 関数

TransEdgesToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に [image] 構造体を変換します。指定のワールド座標系に対するエッジのオフセットと向きを計算します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransEdgesToWorld の入力パラメータ
  • TransEdgesToWorld の出力
  • TransEdgesToWorld データアクセス関数
  • 関連項目

TransEdgesToWorld 関数の入力パラメータ

TransEdgesToWorld 関数(

キャリブレーション ,

エッジ ,

変換する数

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
エッジ | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
変換する数 | ワールド座標に変換する、元の [image] データ構造体からのエッジの数を指定します。(0 ～ 160、デフォルト = 3)

TransEdgesToWorld 関数の出力

戻り値 | 変換されたエッジを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransEdgesToWorld 関数データアクセス関数

スプレッドシートに自動的に挿入されるデータアクセス関数は、 [image] データ構造体のソートとペアリングに使用される関数で挿入されるものと同様になります。

関連項目

  • Calibrate 関数
  • エッジツール
  • 座標補正関数について
  • プロパティシートの使用方法


TransFixtureToWorld 関数

TransFixtureToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

フィクスチャのピクセル座標をワールド座標に変換します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransFixtureToWorld の入力パラメータ
  • TransFixtureToWorld の出力
  • 関連項目

TransFixtureToWorld 関数入力

TransFixtureToWorld 関数(

キャリブレーション ,

フィクスチャ,

表示

)

キャリブレーション

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

フィクスチャ

フィクスチャ座標系を指定します。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット。
角度 | 画像座標での角度。

表示

画像上の TransPixelToWorld グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | TransPixelToWorld 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、そのフィクスチャは表示されません。
2 = 入力のグラフィックスのみ | フィクスチャが常に表示されます。

TransFixtureToWorld 関数の出力

戻り値

変換されたフィクスチャを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • Calibrate 関数
  • キャリブレーション
  • CalibrateAdvanced 関数
  • CalibrateGrid 関数
  • CalibrateImage 関数
  • ExtractCalibration 関数
  • 座標補正関数について
  • Fixture 関数
  • プロパティシートの使用方法


TransformImage 関数

TransformImage 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

TransformImage は、CalibrateGrid 関数に存在する歪みを補正する [image] データ構造体を生成します。

注: この関数は、グレースケール画像のみを出力します。

  • TransformImage 関数の概要
  • TransformImage の入力パラメータ
  • TransformImage の出力
  • 関連項目

TransformImage 関数概要

TransformImage は、CalibrateGrid 関数から引数として参照される CalibrateGrid [image] データ構造体と [image] データ構造体を使って、 [image] データ構造体を生成します。この構造体は線形、非線形、およびレンズ歪みを補正して、CalibrateGrid 関数によって使用されている「歪みのない」バージョンの画像を返します。この新しい出力画像はピクセル単位に基づきますが、それと同時に、ExtractCalibration 関数がスプレッドシートに自動的に挿入されて、TransformImage 関数のキャリブレーションに基づく 2D 変換がワールド座標で作成されます。

Closed TransformImage 関数の実行前の画像:

Closed TransformImage 関数の実行後の画像:

注: TransformImage 関数がスプレッドシートに追加されたとき、指定の領域が変更されたとき、またはこの関数のジョブがロードされたときに生じるTransformImage 関数の登録の期間は、640×480 解像度のセンサでは 3 秒、1600×1200 解像度のセンサでは 30 秒かかることがあります。

TransformImage 関数の入力パラメータ

TransformImage 関数 (

画像,

キャリブレーション,

領域,

画像スケール,

原点,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

キャリブレーション

この引数は、CalibrateGrid 関数によって作成される有効な [image] データ構造体を含んだスプレッドシートのセルを参照している必要があります。

領域

これは対象領域 (ROI) とも呼ばれ、画像解析の対象となる画像の領域を表します。形状変更が可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。

画像スケール

変換後の画像が表示されるスケールを指定します。最小の設定値は 0.01、最大の設定値は 10.00、デフォルトの設定値は 1.0 です。

基準点

変換の原点基準点を指定します。

0 = 画像中央 (デフォルト) | 基準点は画像の中央になります。
1 = 領域の中央 | 基準点は ROI の中央になります。

表示

画像上のグラフィックスの表示モードをTransformImage 関数指定します。

0 = 非表示 | 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、TransformImage 関数グラフィックスは何も表示されません。
1 = 結果のグラフィックスのみ | 歪みのない画像が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域と歪みのない画像が常に表示されます。

TransformImage 関数の出力

戻り値

処理済みの画像を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。また、ExtractCalibration [image] データ構造体が自動的に挿入されて、TransformImage によって返された [image] データ構造体を基に、2D 変換がワールド座標で作成されます。

注: データ構造体にある処理済みの画像領域の内容は、ジョブとともに保存されることはありません。

関連項目

  • CalibrateGrid 関数
  • ExtractCalibration 関数
  • 座標補正関数について
  • キャリブレーション関数について
  • プロパティシートの使用方法


TransInspEdgeDefectToWorld 関数

TransInspEdgeDefectToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に InspectEdgeForDefect [image] データ構造体を変換します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransInspEdgeDefectToWorld の入力パラメータ
  • TransInspEdgeDefectToWorld の出力
  • 関連項目

TransInspEdgeDefectToWorld 関数の入力パラメータ

TransInspEdgeDefectToWorld 関数(

キャリブレーション ,

エッジ欠陥検査

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
エッジ欠陥検査 | このパラメータは、InspectEdgeForDefect 関数によって出力される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

TransInspEdgeDefectToWorld 関数の出力

戻り値

変換されたエッジを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • Calibrate 関数
  • InspectEdge ツールについて
  • 座標補正関数について
  • プロパティシートの使用方法


TransInspEdgeWidthToWorld 関数

TransInspEdgeWidthToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に InspectEdgeWidth [image] データ構造体を変換します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransInspEdgeWidthToWorld の入力パラメータ
  • TransInspEdgeWidthToWorld の出力
  • 関連項目

TransInspEdgeWidthToWorld 関数の入力パラメータ

TransInspEdgeWidthToWorld 関数(

キャリブレーション,

エッジ幅検査

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
エッジ幅検査 | このパラメータは、InspectEdgeWidth 関数によって出力される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

TransInspEdgeWidthToWorld 関数の出力

戻り値

変換されたエッジを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • Calibrate 関数
  • InspectEdge ツールについて
  • 座標補正関数について
  • プロパティシートの使用方法


TransOCRMaxToWorld 関数

TransOCRMaxToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に OCRMax 関数の [image] データ構造体を変換します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransOCRMaxToWorld の入力パラメータ
  • TransOCRMaxToWorld の出力
  • 関連項目

TransOCRMaxToWorld 関数の入力パラメータ

TransOCRMaxToWorld 関数(

キャリブレーション,

OCR最大

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
OCR最大 | このパラメータは、OCRMax 関数によって出力される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

TransOCRMaxToWorld 関数の出力

戻り値

変換された文字を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注: TransOCRMaxToWorld 関数によって返された [image] データ構造体は、フォントとして別の OCRMax 関数への参照として使用することはできません。また、標準の OCRMax 関数 [image] データ構造体として機能しません (例えば、結果グラフィックスを描画しません)。すべての OCRMax データアクセス関数は、TransOCRMaxToWorld 関数によって返された [image] データ構造体を使用して動作しますが、座標データを返すためだけに使用します。

関連項目

  • Calibrate 関数
  • OCRMax 関数
  • 座標補正関数について
  • プロパティシートの使用方法


TransPatternsToWorld 関数

TransPatternsToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に [image] 構造体を変換します。指定のワールド座標系に対するパターンのレスポンス点のオフセットと向きを計算します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransPatternsToWorld の入力パラメータ
  • TransPatternsToWorld の出力
  • TransPatternsToWorld データアクセス関数
  • 関連項目

TransPatternsToWorld 関数の入力パラメータ

TransPatternsToWorld 関数(

キャリブレーション ,

パターン ,

変換する数

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
パターン | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
変換する数 | ワールド座標に変換する、元の [image] データ構造体からのパターンの数を指定します。(0 ～ 100、デフォルト = 1)

TransPatternsToWorld 関数の出力

戻り値 | 変換されたパターンを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。 注: TransPatternsToWorld 関数が TransPatternsToFixture 関数によって参照されているときは、TransPatternsToWorld がワールド座標を出力する場合でも、TransPatternsToFixture 関数は引き続き、結果をピクセル座標で報告します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransPatternsToWorld 関数データアクセス関数

スプレッドシートに自動的に挿入されるデータアクセス関数は、 [image] データ構造体の検出とソートに使用される関数で挿入されるものと同様になります。

関連項目

  • Calibrate 関数
  • パターンマッチングツールについて
  • 座標補正関数について
  • プロパティシートの使用方法


TransPixelToWorld 関数

TransPixelToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

ピクセル座標からワールド座標に点を変換します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransPixelToWorld の入力パラメータ
  • TransPixelToWorld の出力
  • TransPixelToWorld データアクセス関数
  • 関連項目

TransPixelToWorld 関数の入力パラメータ

TransPixelToWorld 関数(

キャリブレーション ,

点.行 ,

点.列 ,

表示

)

キャリブレーション

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

点

点の座標を指定します。

行 | 点の行座標。
列 | 点の列座標。

表示

画像上の TransPixelToWorld グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | TransPixelToWorld 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、その点は表示されません。
2 = 入力のグラフィックスのみ | 点が常に表示されます。

TransPixelToWorld 関数の出力

戻り値 | 変換された点を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransPixelToWorld 関数データアクセス関数

スプレッドシートに自動挿入されて結果テーブルを作成するデータアクセス関数は次のとおりです。

X | GetRow(点) | 変換された点の X 座標。
Y | GetCol(点) | 変換された点の Y 座標。

関連項目

  • Calibrate 関数
  • Point 関数
  • 座標補正関数について
  • プロパティシートの使用方法


TransSurfaceFlawToWorld 関数

TransSurfaceFlawToWorld 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

画像座標からワールド座標に SurfaceFlaw 関数の [image] データ構造体を変換します。

注: ワールド座標系で報告されるビジョンツールの結果出力は、ほかのビジョンツールにおいてフィクスチャまたは領域の入力として使用することはできません。

  • TransSurfaceFlawToWorld の入力パラメータ
  • TransSurfaceFlawToWorld の出力
  • 関連項目

TransSurfaceFlawToWorld 関数の入力パラメータ

TransSurfaceFlawToWorld 関数 (

キャリブレーション ,

傷検査

)

キャリブレーション | このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。
傷検査 | この引数は、SurfaceFlaw 関数によって出力される有効な [image] データ構造体を含むスプレッドシートのセルを参照している必要があります。

TransSurfaceFlawToWorld 関数の出力

戻り値

変換された欠陥を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注:
  • 欠陥の周囲長を変換するには、参照される [image] データ構造体の出力に CalibrateGrid 関数を使用する必要があります。
  • Calibrate 関数または CalibrateAdvanced 関数を使用する場合、すべての周囲長の値はピクセル単位の座標で返されます。
  • 欠陥の真円度や明度の値は実世界値には変換されません。

関連項目

  • Calibrate 関数
  • 座標補正関数について
  • SurfaceFlaw 関数
  • 傷検出
  • プロパティシートの使用方法


TransWorldToPixel 関数

TransWorldToPixel 関数 |
座標補正 → キャリブレーション | In-Sight 関数リファレンス

ワールド座標からピクセル座標に点を変換します。

  • TransWorldToPixel の入力パラメータ
  • TransWorldToPixel の出力
  • TransWorldToPixel データアクセス関数
  • 関連項目

TransWorldToPixel 関数の入力パラメータ

TransWorldToPixel 関数(

キャリブレーション ,

点.X ,

点.Y ,

表示

)

キャリブレーション

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

点

点の座標を指定します。

X | ワールド X 座標。
Y | ワールド Y 座標。

表示

画像上の TransWorldToPixel グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | TransWorldToPixel 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、その入力点は表示されません。
1 = 結果のグラフィックスのみ | 入力点が常に表示されます。

TransWorldToPixel 関数の出力

戻り値 | 変換された点を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransWorldToPixel 関数データアクセス関数

スプレッドシートに自動挿入されて結果テーブルを作成するデータアクセス関数は次のとおりです。

Row | GetRow(点) | 変換された点の行座標。
Column | GetCol(点) | 変換された点の列座標。

関連項目

  • Calibrate 関数
  • Point 関数
  • 座標補正関数について
  • プロパティシートの使用方法


Fixture 関数

座標補正関数

In-Sight 関数リファレンス

Fixture 関数は、フィクスチャ座標系とピクセル座標系の間で座標補正を定義します。

  1. TransBlobsToFixture 関数: 構造体を画像座標からフィクスチャ座標に変換します。
  2. TransEdgesToFixture 関数: 構造体を画像座標からフィクスチャ座標に変換します。
  3. TransFixtureToPixel 関数: フィクスチャ座標をピクセル座標に変換します。
  4. TransPatternsToFixture 関数: データ構造体を画像座標からフィクスチャ座標に変換します。
  5. TransPixelToFixture 関数: ピクセル座標をフィクスチャ座標に変換します。


TransBlobsToFixture 関数

TransBlobsToFixture 関数 |
座標補正 → フィクスチャ | In-Sight 関数リファレンス

画像座標からフィクスチャ座標に [image] 構造体を変換します。指定のフィクスチャに対するブロブのオフセットと向きを計算します。

  • TransBlobsToFixture の入力パラメータ
  • TransBlobsToFixture の結果出力
  • TransBlobsToFixture データアクセス関数
  • 関連項目

TransBlobsToFixture 関数の入力パラメータ

TransBlobsToFixture 関数(

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

ブロブ ,

変換する数

)

フィクスチャ

フィクスチャ座標系を指定します。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット。
角度 | 画像座標での角度

ブロブ

データ構造体。このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

変換する数

フィクスチャ座標に変換する、元の [image] データ構造体からのブロブの数を指定します。(0 ～ 4096、デフォルト = 3)

TransBlobsToFixture 関数の出力

戻り値 | 変換されたブロブを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransBlobsToFixture 関数データアクセス関数

スプレッドシートに自動的に挿入されるデータアクセス関数は、FindBlobs 関数と SortBlobs 関数によって挿入されるものと同様になります。

関連項目

  • Fixture 関数
  • ブロブツール
  • 座標補正関数について
  • プロパティシートの使用方法


TransEdgesToFixture 関数

TransEdgesToFixture 関数 |
座標補正 → フィクスチャ | In-Sight 関数リファレンス

画像座標からフィクスチャ座標に [image] 構造体を変換します。指定のフィクスチャに対するエッジのオフセットと向きを計算します。

  • TransEdgesToFixture の入力パラメータ
  • TransEdgesToFixture の出力
  • TransEdgesToFixture データアクセス関数
  • 関連項目

TransEdgesToFixture 関数の入力パラメータ

TransEdgesToFixture 関数(

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

エッジ ,

変換する数

)

フィクスチャ

フィクスチャ座標系を指定します。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット。
角度 | 画像座標での角度。

エッジ

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

変換する数

フィクスチャ座標に変換する、元の [image] データ構造体からのエッジの数を指定します。(0 ～ 160、デフォルト = 3)

TransEdgesToFixture 関数の出力

戻り値 | 変換されたエッジを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransEdgesToFixture 関数データアクセス関数

スプレッドシートに自動的に挿入されるデータアクセス関数は、 [image] データ構造体のソートとペアリングに使用される関数で挿入されるものと同様になります。

関連項目

  • Fixture 関数
  • エッジツール
  • 座標補正関数について
  • プロパティシートの使用方法


TransFixtureToPixel 関数

TransFixtureToPixel 関数 |
座標補正 → フィクスチャ | In-Sight 関数リファレンス

フィクスチャ座標をピクセル座標に変換します。

  • TransFixtureToPixel の入力パラメータ
  • TransFixtureToPixel の結果出力
  • TransFixtureToPixel データアクセス関数
  • 関連項目

TransFixtureToPixel 関数の入力パラメータ

TransFixtureToPixel 関数(

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

点.X ,

点.Y ,

表示

)

フィクスチャ

フィクスチャ座標系を指定します。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット。
角度 | 画像座標での角度。

点

フィクスチャ座標での点の座標を指定します。

X | フィクスチャの原点からの点の行オフセット。
Y | フィクスチャの原点からの点の列オフセット。

表示

画像上の TransFixtureToPixel グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | TransFixtureToPixel 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、点は表示されません。
1 = 結果のグラフィックスのみ | 点は常に表示されます。

TransFixtureToPixel 関数の出力

戻り値 | 変換された点を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransFixtureToPixel 関数データアクセス関数

スプレッドシートに自動挿入されて結果テーブルを作成するデータアクセス関数は次のとおりです。

行 | GetRow(点) | 変換された点の行座標。
列 | GetCol(点) | 変換された点の列座標。

関連項目

  • Fixture 関数
  • Point 関数
  • 座標補正関数について
  • プロパティシートの使用方法


TransPatternsToFixture 関数

TransPatternsToFixture 関数 |
座標補正 → フィクスチャ | In-Sight 関数リファレンス

画像座標からフィクスチャ座標に [image] データ構造体を変換します。指定のフィクスチャに対するパターンのレスポンス点のオフセットと向きを計算します。

  • TransPatternsToFixture の入力パラメータ
  • TransPatternsToFixture の出力
  • TransPatternsToFixture データアクセス関数
  • 関連項目

TransPatternsToFixture 関数の入力パラメータ

TransPatternsToFixture 関数(

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

パターン ,

変換する数

)

フィクスチャ

フィクスチャ座標系を指定します。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット。
角度 | 画像座標での角度。

パターン

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。

注: TransPatternsToFixture 関数が、TransPatternsToWorld 関数によって返された [image] データ構造体を参照しているときは、TransPatternsToWorld がワールド座標を出力する場合でも、TransPatternsToFixture 関数は引き続き、結果をピクセル座標で報告します。

変換する数

フィクスチャ座標に変換する、元の [image] データ構造体からのパターンの数を指定します。(0 ～ 100、デフォルト = 1)

TransPatternsToFixture 関数の出力

戻り値 | 変換されたパターンを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransPatternsToFixture 関数データアクセス関数

スプレッドシートに自動的に挿入されるデータアクセス関数は、 [image] データ構造体の検出とソートに使用される関数で挿入されるものと同様になります。

関連項目

  • Fixture 関数
  • パターンマッチングツールについて
  • 座標補正関数について
  • プロパティシートの使用方法


TransPixelToFixture 関数

TransPixelToFixture 関数 |
座標補正 → フィクスチャ | In-Sight 関数リファレンス

フィクスチャ座標をピクセル座標に変換します。

  • TransPixelToFixture の入力パラメータ
  • TransPixelToFixture の出力
  • TransPixelToFixture データアクセス関数
  • 関連項目

TransPixelToFixture 関数の入力パラメータ

TransPixelToFixture 関数(

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

Point.Row ,

Point.Column ,

表示

)

フィクスチャ

フィクスチャ座標系を指定します。

行 | 画像座標での行オフセット。
列 | 画像座標での列オフセット。
角度 | 画像座標での角度。

点

ピクセル座標での点の座標を指定します。

行 | 画像の原点からの点の行オフセット。
列 | 画像の原点からの点の列オフセット。

表示

画像上の TransPixelToFixture グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | TransPixelToFixture 関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、点は表示されません。
2 = 入力のグラフィックスのみ | 点が常に表示されます。

TransPixelToFixture 関数の出力

戻り値 | 変換された点を含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

TransPixelToFixture 関数データアクセス関数

スプレッドシートに自動挿入されて結果テーブルを作成するデータアクセス関数は次のとおりです。

X | GetRow(点) | 変換された点の X 座標。
Y | GetCol(点) | 変換された点の Y 座標。

関連項目

  • Fixture 関数
  • Point 関数
  • 座標補正関数について
  • プロパティシートの使用方法


入出力関数

In-Sight 関数リファレンス

入出力関数は、In-Sight センサが Ethernet ネットワークまたはシリアルポート接続を経由してリモートデバイスと通信する方法を制御します。これらの関数は次のように分類されます。

  • BitStream 関数: WriteWaveformClocked 関数を使用して送信されるビットのリストを統合および収集します。
  • CombineOutputBuffers 関数: 複数の FormatOutputBuffer 関数の出力を、単一の [image] データ構造体に統合します。
  • Event 関数: 指定されたイベントトリガで画像を取り込み、スプレッドシートを更新します。
  • ExportData 関数: セルのデータを .cxd ファイルとしてエクスポートし、そのデータをその他のセンサ、FTP サーバ、またはローカルあるいはネットワークに接続された RAM ディスクの間で共有します。
  • ExternalLightControl 関数: In-Sight 76xx ～ 79xx ビジョンシステムの外部照明ケーブルに接続されている、外付けのストロボまたは連続照明デバイスの照明設定を行います。
  • FormatInputBuffer 関数: ReadCCLinkBitBuffer 関数、ReadCCLinkWordBuffer 関数、ReadDeviceNetBuffer 関数、ReadEIPBuffer 関数、ReadModbusBuffer 関数、または ReadProfinetBuffer 関数から受信されるデータのフォーマットを、ユーザが設定できるようにします。
  • FormatOutputBuffer 関数: WriteCCLinkBitBuffer 関数、WriteCCLinkWordBuffer 関数、WriteDeviceNetBuffer 関数、WriteEIPBuffer 関数、WriteModbusBuffer 関数、または WriteProfinetBuffer 関数に送信されるデータのフォーマットを、ユーザが設定できるようにします。
  • ImportData 関数: セルのデータを .cxd ファイルとして、その他のセンサ、FTP サーバ、またはローカルあるいはネットワークに接続された RAM ディスクからインポートします。
  • LocalStorage 関数: オンラインになっているときに、In-Sight ビジョンシステムに取り付けられている SD カードに、画像およびデータファイルを書き込みます。
  • IntegratedLightControl 関数: In-Sight 76xx ～ 79xx ビジョンシステムのフェースプレートの前面に接続された、統合照明アクセサリに関する照明設定を行います。
  • SetEvent 関数: 実行時に指定したイベントをトリガします。
  • ディスクリート I/O 関数: システムがオンラインになっているときに、In-Sight センサのパラレルディスクリート I/O チャネルの読み取りと書き込みを行います。
  • MachineStatus 関数: In-Sight センサの動作ステータス情報を格納します。
  • メッセージ関数: ネイティブモード接続を介して、In-Sight センサとの間でテキスト文字列の読み取りと書き込みを行います。
  • ネットワーク関数: ネットワーク上の他の TCP/IP デバイスと In-Sight センサとの間でデータを共有します。
  • シリアル I/O 関数: In-Sight センサのシリアルポートとの間で、データの読み取りと書き込みを行います。
  • 時間・タイマ関数: 現在の日付と時刻を返し、時間ベースのイベントをトリガします。
  • 波形関数: 出力波形パターンを作成し、ディスクリート出力ラインを介して送信します。
Version: 5.6.0


BitStream 関数

入出力関数

In-Sight 関数リファレンス

WriteWaveformClocked 関数を使用して送信されたビットのリストを収集します (最大 253 ビットを指定することができます)。

注:
  • BitStream 関数にはプロパティシートがありません。これはビットの変数リストに基づいており、行番号 (0 または 1)、セル参照、またはセルの範囲のいずれかで表されます。セルに入力できる最大文字数は 255 文字です。255 を超える文字を使用して可変引数を指定すると、エラーメッセージが表示されます。可変引数の指定に使用した文字列が 255 文字の制限を超える場合は、セル範囲を使用します。
  • ゼロ以外の数字はビット値 1 と解釈されます。

BitStream 関数(

ビット 0,

[ビット 1 ...]

)

BitStream 関数の入力パラメータ

ビット 0 | 最初のビットを指定します。
ビット 1 | 後続のビットを指定します。

BitStream 関数の出力

戻り値

ビットを含んでいる [image] データ構造体。次の場合には #ERR を返します。

  • 入力パラメータが無効である場合
  • ビットが負以外の数値として記録されている場合

関連項目

WriteWaveformClocked 関数

Waveform 関数

データアクセス入出力関数

Version: 5.6.0


CombineOutputBuffers 関数

入出力関数

In-Sight 関数リファレンス

複数の FormatOutputBuffer 関数の出力を単一の [image] データ構造体として単一の通信パケットで送信されるように設定することができます。

注: CombineOutputBuffers 関数は、要素のサイズに関係なく、最大 128 個の要素をサポートします。

CombineOutputBuffers 関数 (

フォーマットセル 1,

フォーマットセル 2,

フォーマットセル N

)

CombineOutputBuffers 関数の入力パラメータ

フォーマットセル 1 | FormatOutputBuffer 関数によって出力された、参照される [image] データ構造体を指定します。 注:Modbus TCP、EIP、または PROFINET 通信を使用している場合の出力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。
フォーマットセル 2 | FormatOutputBuffer 関数によって出力された、参照される [image] データ構造体を指定します。 注:Modbus TCP、EIP、または PROFINET 通信を使用している場合の出力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。
フォーマットセル N | FormatOutputBuffer 関数によって出力された、参照される [image] データ構造体を指定します。 注:Modbus TCP、EIP、または PROFINET 通信を使用している場合の出力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。

CombineOutputBuffers 関数の出力

戻り値

フォーマットされたデータを含む [image] データ構造体。次の場合には #ERR を返します。

  • 入力パラメータが無効である場合
  • 結合した FormatOutputBuffer 関数のサイズが 4,000 バイトを超えた場合

関連項目

FormatOutputBuffer 関数


ディスクリート I/O 関数

入出力関数

In-Sight 関数リファレンス

ディスクリート I/O 関数は、In-Sight ビジョンシステムのパラレルのディスクリート入出力の読み取りと書き込みを行います。

  • ReadDiscrete 関数: ディスクリート入力ポートから任意のビット幅のステータスを読み取ります。
  • WriteDiscrete 関数: ディスクリート出力ポートへ任意のビット幅でデータを書き込みます。

次のとおり、In-Sight ビジョンシステムごとに直接接続 (組み込み) 入力と出力の数は異なります。

In-Sight ビジョンシステム 直接 (組み込み) 入力1 直接接続 (組み込み) 出力
In-Sight Micro 1000 シリーズ なし

高速出力×2
ユーザ設定可能 LED×2 (緑×1、赤×1)
In-Sight 5000 シリーズ なし

高速出力×2
ユーザ設定可能 LED×2 (緑×1、赤×1)
In-Sight 70xx ～ 74xx シリーズ 汎用入力×3

高速出力×4
ユーザ設定可能 LED×2 (緑×1、赤×1)
In-Sight 76xx ～ 79xx シリーズ 汎用入力×3 (最大)2

高速出力×最大 42
ユーザ設定可能 LED×2 (緑×1 または赤×1)
In-Sight 8000 シリーズ なし

高速出力×2
ユーザ設定可能 LED×2 (緑×1、赤×1)

1In-Sight ビジョンシステムには、画像取り込み専用のトリガがビジョンシステム上に 1 つあります。詳細については、AcquireImage 関数のトピックのトリガパラメータを参照してください。また、In-Sight Explorer ソフトウェアに収録されているビジョンシステムのインストールガイドまたはリファレンスガイドも参照してください。

2ブレークアウトケーブル接続時、ビジョンシステムは双方向高速出力および汎用入力を、HS OUT 2 / IN 2 および HS OUT 3 / IN 3 で使用することができます。これらのラインはデフォルトで出力に設定されています。

I/O モジュールを使用してディスクリート入力および出力を追加できます。I/O モジュールのディスクリート入出力数は次の通りです。

I/O モジュール | サポート対象の In-Sight ビジョンシステム | ディスクリート入力ライン | ディスクリート出力ライン
CIO-1400 | In-Sight 5000 シリーズ (5604 を除く)、In-Sight 76xx ～ 79xx シリーズ1 | 汎用入力×7 | 汎用出力×6
CIO-MICRO23 | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 70xx ～ 79xx シリーズ、In-Sight Micro 8000 シリーズ | 汎用入力× 8 | 汎用出力× 8
CIO-MICRO-CC34 | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ (5705、5705C、5715 を除く)、In-Sight 70xx ～ 74xx シリーズ | 汎用入力× 8 | 汎用出力× 8
CIO-14505 | In-Sight 5000 シリーズ (5604、5705、5705C および 5715 を除く) | 汎用入力× 8 | 汎用出力× 8
CIO-14605 | In-Sight 5000 シリーズ (5604、5605、5705、5705C および 5715 を除く) | 汎用入力× 8 | 汎用出力× 8
CIO-WENET5 | In-Sight Micro 1000 シリーズ | 汎用入力× 8 | 汎用出力× 8

1 CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以上を使用している In-Sight 76xx ～ 79xx シリーズのビジョンシステムをサポートしています。このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。

2CIO-MICRO I/O モジュールは、ファームウェア 5.3.0 以上を搭載した In-Sight 5705、5705C、5715、In-Sight Micro 8000 シリーズのビジョンシステムをサポートします。

3CIO-MICRO-CC I/O モジュールは、In-Sight 76xx ～ 79xx シリーズのビジョンシステムをサポートしていません。

4CIO-MICRO および CIO-MICRO-CC I/O モジュールがサポートしているのは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズと 5400 シリーズのビジョンシステムです。モデルはタイプ番号 (821-xxxx-xx) で特定できます。このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。モデル、およびタイプ番号と不揮発性フラッシュメモリの一覧については、ここをクリックしてください。

5CIO-1450、CIO-1460 および CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。

注:

  • In-Sight 70xx ～ 74xx シリーズのビジョンシステムは、ブレークアウトケーブルと、CIO-MICRO または CIO-MICRO-CC I/O モジュールとの同時接続をサポートしています。
  • In-Sight 76xx ～ 79xx シリーズのビジョンシステムは、ブレークアウトケーブルと CIO-MICRO I/O モジュールとの同時接続をサポートしています。
  • In-Sight 7000 シリーズ (70xx ～ 79xx シリーズ) のビジョンシステムの内蔵入力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • In-Sight 70xx ～ 74xx シリーズの高速出力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight ビジョンシステムを使って、Opto 22、Wago、Sixnet などの他のベンダーが提供する標準イーサネット I/O ソリューションと通信して、実質的に無制限の数の I/O チャネルを提供することもできます。ただし、Modbus パケットタイプの通信用に設定された In-Sight TCPDevice 関数を使って、イーサネットベースの I/O をこれらのビジョンシステム上で設定する必要があります。
  • パルスディスクリート出力が CIO-1450 I/O モジュールから送信されるときには、パルス幅が指定より 10 ミリ秒長くなることがあります。
  • CIO-1460 I/O モジュールの電源を入れ直すと、ディスクリート出力は初期設定時に約 250 ミリ秒後に出力されます。

警告:

  • In-Sight 70xx ～ 74xx シリーズのビジョンシステムを CIO-MICRO または CIO-MICRO-CC I/O モジュールと接続する場合、I/O モジュールの I/O ポート (DB15) と TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON 端子はサポートされません。リモートデバイスからこれらの端子にリード線を接続しないでください。
  • In-Sight 76xx ～ 79xx シリーズのビジョンシステムをブレークアウトケーブルに接続する場合、CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。リモートデバイスからこれらの端子にリード線を接続しないでください。

関連項目

[ディスクリート I/O の設定] ダイアログ

ディスクリート出力詳細

I/O モジュールの設定

Version: 5.6.0


ReadCameraTrigger 関数

入出力関数 → ディスクリート I/O

In-Sight 関数リファレンス

In-Sight センサの画像取り込みトリガ入力の状態を読み取ります。

ReadCameraTrigger 関数 (

イベント

)

ReadCameraTrigger 関数の入力パラメータ

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

ReadCameraTrigger 関数の出力

戻り値

入力の状態を表す値。0 = OFF、1 = ON。

関連項目

入出力関数について


ReadDiscrete 関数

ReadDiscrete 関数 |
入出力関数 → ディスクリート I/O | In-Sight 関数リファレンス

ディスクリート入力ポートから任意のビット幅のステータスを読み取ります。

注:
  • この関数を有効にするには、In-Sight システムをオンラインにする必要があります。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

ReadDiscrete 関数の入力パラメータ

ReadDiscrete 関数(

イベント,

開始ビット,

ビット数

)

イベント

読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

開始ビット

読み取る範囲の最初のビットを指定します。

  • In-Sight 5000 シリーズおよび Micro シリーズ: (0 ～ 9、デフォルト = 0)
  • In-Sight 70xx ～ 74xx シリーズ: (0 ～ 13、デフォルト = 0)
  • In-Sight 76xx ～ 79xx シリーズおよび In-Sight 8000 シリーズ: (0 ～ 15、デフォルト = 0)

ビット数

読み取る範囲内のビット数を指定します。

  • In-Sight 5000 シリーズおよび Micro シリーズ: (1 ～ 10、デフォルト = 10)
  • In-Sight 70xx ～ 74xx シリーズ: (1 ～ 14、デフォルト = 10)
  • In-Sight 76xx ～ 79xx シリーズおよび In-Sight 8000 シリーズ: (1 ～ 16、デフォルト = 10)

ReadDiscrete 関数の出力

戻り値

読み取った正の整数値。入力パラメータが無効であれば #ERR を返します。

関連項目

WriteDiscrete 関数

入出力関数について

Version: 5.6.0


WriteDiscrete 関数

入出力関数 → ディスクリート I/O

In-Sight 関数リファレンス

ディスクリート出力ポートへ任意のビット幅でデータを書き込みます。

注:

  • この関数を有効にするには、In-Sight システムをオンラインにする必要があります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • WriteDiscrete 関数を含む In-Sight Explorer .JOB ファイルを CIO-1400 I/O モジュールが追加された In-Sight センサにロードする場合は、WriteDiscrete の開始ビットパラメータとビット数パラメータを変更し、I/O ラインの新しい構成を反映する必要があります。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

WriteDiscrete 関数の入力パラメータ

WriteDiscrete 関数(

イベント,

開始ビット,

ビット数,

値

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

開始ビット

書き込む範囲の最初のビットを指定します。

  • In-Sight 5000 シリーズおよび Micro 1000 シリーズ: (0 ～ 11、デフォルト = 0)
  • In-Sight 70xx ～ 74xx シリーズ: (0 ～ 13、デフォルト = 1)
  • In-Sight 76xx ～ 79xx シリーズおよび In-Sight 8000 シリーズ: (0 ～ 15、デフォルト = 0)

ビット数

書き込む範囲内のビット数を指定します。

  • In-Sight 5000 シリーズおよび Micro シリーズ: (1 ～ 12、デフォルト = 1)
  • In-Sight 70xx ～ 74xx シリーズ: (1 ～ 14、デフォルト = 1)
  • In-Sight 76xx ～ 79xx シリーズおよび In-Sight 8000 シリーズ: (1 ～ 16、デフォルト = 1)

値

書き込む正の整数値を指定します。

  • In-Sight 5000 シリーズおよび Micro シリーズ: (0 ～ 4095、デフォルト = 0)
  • In-Sight 70xx ～ 74xx シリーズ: (0 ～ 16383、デフォルト = 0)
  • In-Sight 76xx ～ 79xx シリーズおよび In-Sight 8000 シリーズ: (0 ～ 65535、デフォルト = 0)

WriteDiscrete 関数の出力

戻り値

書き込まれた値。入力パラメータが無効であれば #ERR を返します。

関連項目

ReadDiscrete 関数

入出力関数について

Version: 5.6.0


Event 関数

入出力関数

In-Sight 関数リファレンス

指定されたイベントトリガでスプレッドシートを更新します。Event 関数は、特定の入出力条件でのみスプレッドシートを更新する重要な依存関係として使用されます。

Event 関数(

トリガ,

手動

)

Event 関数の入力パラメータ

トリガ

In-Sight センサがオンライン時のイベントのトリガソースを指定します。

16 = 画像取り込みエラー | エラー: 画像取り込みミスが発生した場合、またはセンサとの接続が失われた場合に生成されます。 注: このトリガを使用するには、AcquireImage 関数のプロパティシートの [トリガ] パラメータを [カメラ] に設定しておく必要があります。
17 = ディスクリート I/O エラー | トラックパルスのオーバランが発生した場合、またはトラックパルスのキューがいっぱいである場合に生成されます。
18 = シリアルポート 0 エラー | 実装されていません。
19 = シリアルポート 1 エラー | 実装されていません。
20 = ワークシートエラー | ジョブの実行中に、#ERR が初めてセルに返されたときに生成されます。
21 = システムエラー | 実装されていません。
22 = ネットワークエラー | TCPDevice 関数または WriteResult 関数を使用したときに、これらの関数が低レベルのネットワークライブラリからソケットエラーを受信した場合、TCPDevice 関数を使用したときに、パケットを受信したがジョブの実行中だったので処理できなかった場合、あるいは WriteFTP 関数または WriteImageFTP 関数を使用したときに、ネットワークパラメータ設定 (ホスト名、ユーザ名、パスワードなど) が無効であった場合に生成されます。
32 = 手動 | センサをオンラインにして、手動トリガを開始したときに生成されます。
33 = オンライン/オフライン | In-Sight センサのオンライン/オフライン状態が切り替わったときに生成されます。
35 = ジョブを開く 完了 | ジョブのロード後に生成されます。
39 = 画像取り込みジョブ完了 | 取り込みを開始したジョブの実行の最後に生成されます。 注: このトリガを使用するには、AcquireImage 関数のプロパティシートの手動パラメータを有効にしておく必要があります。
49 ～ 60 = ディスクリート 0 ～ 11 | 対応するディスクレート入力がイベントトリガとして構成されているときに、指定された信号動作 (つまり、立ち上がりエッジ、立ち下がりエッジ、または両方) が発生した場合に生成されます。
64 = シリアルポート 0 | 実装されていません。
65 = シリアルポート 1 | シリアル ポートが [DeviceNet] または [テキスト] モードで構成されているときに、データがこのシリアルポートで受信された場合に生成されます。
135 = チューニングボタン | In-Sight 76xx ～ 79xx ビジョンシステムのチューニングボタンを押すと生成されます。
80 ～ 87 = ソフト 0 ～ 7 (デフォルト = ソフト 0) | SetEvent 関数、Button 関数、または Timer 関数、もしくは Set Event 関数または Set Event and Wait ネイティブモードコマンド、ソフトトリガが実行された場合に生成されます。

手動

In-Sight ビジョンシステムがオフラインのときにイベントがトリガされた場合に、手動でのトリガを発行するかどうかを指定します。

0 = OFF (デフォルト) | 手動でのトリガは発行されません。
1 = ON | 手動でのトリガが発行されます。

Event 関数の出力

戻り値

データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

入出力関数について

SetEvent 関数

Version: 5.6.0


ExportData 関数

ExportData 関数 |
入出力関数 | In-Sight 関数リファレンス

ExportData 関数は、スプレッドシートであらかじめ定められたイベントが、あるセルデータ (.CXD) ファイルのエクスポートを示しているときに、このファイルに、スプレッドシートのセル内のデータを自動的にエクスポートする関数です。この関数により、あるビジョンシステムの 1 つのセルに入っているデータが、ローカルまたはネットワークに接続された In-Sight ビジョンシステムのフラッシュメモリ、FTP を経由した中央サーバ、またはローカルもしくはネットワークに接続されたビジョンシステムの RAM ディスクまたは SD カードのいずれか 1 つにエクスポートされます。

ExportData 関数を使用して .CXD ファイルをエクスポートした場合、データは ExportData 関数の一部となり、編集できません。エクスポートした .CXD ファイルをクリックすると、エクスポートしたデータタイプに対応したプロパティシートではなく、ExportData 関数のプロパティシートが開きます。ExportData 関数は、次のデータタイプをエクスポートできます。DelayLine、CountPassFail、Calibrate、CalibrateAdvanced、FindPatterns、OCRMax、OCRMaxSettings、TrainPatMaxPattern、および TrainFont。

注: ExportData 関数では、PC 上のスニペットフォルダに .CXD ファイルをエクスポートすることはできません。

  • ExportData の入力パラメータ
  • ExportData の出力
  • ExportData 関数の例
  • 関連項目
警告:
  • ExportData 関数を使用してデータを書き込むと、ジョブがブロックされることがあります。つまり、ジョブの速度が低下し、ジョブの処理時間がトリガ期間よりも長くなった場合に、ビジョンシステムによってトリガがキューされたり、失敗したりすることがあります。
  • ローカルまたはネットワークに接続された In-Sight ビジョンシステムのフラッシュメモリへの書き込みに ExportData 関数を使用する場合、1 秒あたり 0.5 KB を超えるデータをフラッシュメモリに 16 回連続で書き込むと、警告が発せられ、ジョブの速度が低下しますので注意してください。この場合、データが欠落、または無視されることはありません。In-Sight ビジョンシステムのフラッシュメモリは、1 ページあたり約 100,000 回の書き込みで寿命となります。 したがって、ExportData 関数を使用する場合は、ビジョンシステムのフラッシュメモリを保護するための予防措置を講じておく必要があります。

ExportData 関数の入力パラメータ

ExportData 関数(

イベント,

ホスト名,

ユーザ名,

パスワード,

ファイル名,

セル

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体

注: データをフラッシュメモリに書き込んでいる最中に、イベントが [image] データ構造体に設定されると、#ERR が返されます。

  • 関数を含んでいるセル
  • Button 関数を含んでいるセル。

注: ExportData 関数のデフォルトイベントパラメータ設定が 0 で、この設定が 0 のままである場合、[Export] ボタンが ExportData セルの隣に作成されます。

ホスト名

ファイルが保存される場所を示します。 ファイルは、フラッシュメモリ経由でローカルまたはネットワークに接続されたビジョンシステム、FTP を経由した外部サーバ、またはローカルもしくはネットワークに接続されたビジョンシステムの RAM ディスクまたは SD カードに格納できます。

注:

  • [ホスト名] ドロップダウンには、In-Sight ビジョンシステムのホスト名やネットワーク上のエミュレータは表示されません。ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。
  • フラッシュメモリにデータをエクスポートする場合、[ホスト名] フィールドは空欄のまま（例: ""）にしておく必要があります。
  • インポート先に FTP サーバが指定されているときに、データ転送時にこの FTP サーバが使用できなかった場合、タイムアウトまで数秒かかります。タイムアウトした場合、In-Sight Explorer はビジョンシステムから切断されることがあります。

ユーザ名

ファイルの格納先ビジョンシステムまたはデバイスのファイルシステムにアクセスするユーザの名前を指定します。データをローカルビジョンシステムのフラッシュメモリ、RAM ディスク、または SD カードにエクスポートする場合は、このフィールドを空白のままにしておくことができます。

パスワード

ファイルの格納先ビジョンシステムまたはデバイスのファイルシステムへのアクセスに使用するパスワードを指定します。データをローカルビジョンシステムのフラッシュメモリ、RAM ディスク、または SD カードにエクスポートする場合は、このフィールドを空白のままにしておくことができます。

注: ホスト名、ユーザ名、およびパスワードパラメータは、インポート先が FTP の場合のみ必要です。

ファイル名

格納する情報の識別に使用されるファイルの名前を指定します。目的の場所に同じ名前のファイルがすでに存在する場合、既存のファイルは上書きされます。

  • RAM ディスクからエクスポートする場合、ファイル名の前に、"ramdisk/" を付けて指定する必要があります。例えば、"ramdisk/PartXPattern" と指定します。ここでは大文字と小文字は区別されません。
  • SD カードからエクスポートする場合、ファイル名の前に、"sdcard/" を付けて指定する必要があります。例えば、"sdcard/PartXPattern" と指定します。ここでは大文字と小文字は区別されません。

注: ファイル名に拡張子をつける必要はありません。 テキスト文字列に自動的に追加されます。異なるファイル名拡張子を指定した場合、#ERR が返されます。

セル

エクスポートされるセルを表します。GetString 参照など、ほかの構造体への参照がセルに含まれている場合、実際にこのセルに含まれている値がエクスポートされます。

ExportData 関数の出力

戻り値

FTP を経由した外部サーバ、ローカルまたはネットワークに接続された In-Sight ビジョンシステムのフラッシュメモリ、またはローカルもしくはネットワークに接続されたビジョンシステムの RAM ディスクまたは SD カードに格納可能な .CXD ファイルが作成されます。

注: ExportData 関数の結果として #ERR が返された場合、GetErrorString を使用して、原因を判定することができます。

次の 3 つの条件のうち 1 つが満たされた場合、ExportData 関数により .CXD ファイルがエクスポートされます。

  • ExportData 関数のプロパティシートの [OK] ボタンが押された。
  • イベントが受信された。
  • イベントパラメータが ON （または参照先のセルが 0 以外）のとき、ExportData の入力パラメータの 1 つが更新された。

注: ExportData 関数は、オフラインモードでも、データをエクスポートします。

ExportData 関数の例

ExportData(A8,"FTPServer1","operator1","","PartXPattern",H7)

セル A8 でイベントがトリガされた後、スプレッドシートが更新されるたびに、セル H7 にあるデータが、ファイル PartXPattern.cxd として、FTPServer1 に書き込まれます。ユーザ名は operator1 と指定されています。 また、パスワードは空白です。

EV ExportData(1,"","","","FindPatterns",F4)

  1. FindPatterns 関数がセル F4 に挿入されます。
  2. Telnet セッションが開かれ、Evaluate Native Mode コマンド、EV ExportData(1,"","","","FindPatterns",F4) が実行されます。セル F4 の FindPatterns 関数は、ファイル FindPatterns.cxd に書き込まれ、ローカルビジョンシステムのフラッシュメモリに保存されます。データはビジョンシステムに書き込まれるので、ユーザ名やパスワードは必要ありません。

関連項目

Event 関数

Import/Export Cells 関数

ImportData 関数

入出力関数について

Version: 5.6.0


ExternalLightControl

入出力関数

In-Sight 関数リファレンス

ユーザは、In-Sight 76xx ～ 79xx ビジョンシステムの LIGHT コネクタに接続されている外部ストロボまたは連続照明デバイスの照明の設定を行うことができます。

  • ExternalLightControlの入力パラメータ
  • ExternalLightControlの出力
  • 関連項目

ExternalLightControl(

イベント

外部照明の出力モード,

外部照明ストロボ光源,

輝度

)

注:

  • 外部照明は必ずビジョンシステムの LIGHT コネクタに接続し、[照明の設定] ダイアログで [外部] を選択する必要があります。[外部] を選択しないと、関数によって #ERR が返されます。
  • 関数ExternalLightControlがスプレッドシートに挿入されている場合は、[照明の設定] ダイアログで設定の変更を試みると、ダイアログで指定した設定がスプレッドシート関数によって上書きされます。
  • 1 つのジョブにExternalLightControl関数のインスタンスが複数存在する場合、外部照明では、最後に実行された関数のインスタンスによって指定された設定が使用されます。
  • In-Sight 76xx ～ 79xx シリーズのビジョンシステムでは、ビジョンシステムのフェースプレートへの組み込み照明アクセサリの接続、およびビジョンシステムの LIGHT コネクタへの外部照明の接続がサポートされますが、両方の照明器具を同時に使用することはできません。サポート対象アクセサリの完全な一覧については、『In-Sight® 7000 Gen2 Series Vision System Reference Guide』を参照してください。

ExternalLightControlの入力パラメータ

イベント

強制的な更新の原因となるイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。(デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値。
外部照明の出力モード

ビジョンシステムに接続されているストロボデバイスまたは連続照明デバイスのタイプを指定します。

0 = PNP (ソーシング) (デフォルト)

1 = NPN (シンキング)
ストロボ開始位置

ストロボ出力を開始する位置を指定します。

0 = 画像取り込み開始 (デフォルト)

1 = カメラトリガ
輝度 接続されたストロボデバイスの有効な照明輝度をパーセンテージで指定します。(0 ～ 100、デフォルト = 100)

ExternalLightControlの出力

戻り値

データ構造体。入力パラメータが無効で、外部照明がビジョンシステムに接続されていないか、または [照明の設定] ダイアログで [外部] が選択されていない場合は #ERR。

関連項目

入出力関数について

IntegratedLightControl

[照明の設定] ダイアログ

Version: 5.6.0


FormatInputBuffer 関数

入出力関数

In-Sight 関数リファレンス

ReadCCLinkBitBuffer 関数、ReadCCLinkWordBuffer 関数、ReadDeviceNetBuffer 関数、ReadEIPBuffer 関数、ReadDeviceNetBuffer 関数、ReadModbusBuffer 関数、ReadProfinetBuffer 関数、ReadMC 関数、および ReadUserDataBuffer 関数から受信したデータのフォーマットをユーザが設定することができます。

これを FormatInputBuffer 関数 [関数の挿入] ダイアログから選択すると、[フォーマット入力バッファ] ダイアログが自動的に表示されるので、これを使用して関数をプログラミングします。

FormatInputBuffer 関数の入力パラメータ

FormatInputBuffer 関数(

フォーマット

)

フォーマット

自動設定に使用されるデータタイプとエレメントのサイズ (単位はバイト) を指定します。

注:Modbus TCP、EIP、または PROFINET 通信を使用している場合の入力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、入力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、入力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。

FormatInputBuffer 関数の出力

戻り値

フォーマット後のデータを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • FormatOutputBuffer 関数
  • ReadCCLinkBitBuffer 関数
  • WriteCCLinkBitBuffer 関数
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkWordBuffer 関数
  • ReadDeviceNetBuffer 関数
  • WriteDeviceNetBuffer 関数
  • ReadEIPBuffer 関数
  • WriteEIPBuffer 関数
  • ReadDeviceNetBuffer 関数
  • ReadModbusBuffer 関数
  • WriteModbusBuffer 関数
  • ReadProfinetBuffer 関数
  • WriteProfinetBuffer 関数
  • ReadUserDataBuffer 関数
Version: 5.6.0


FormatOutputBuffer 関数

入出力関数

In-Sight 関数リファレンス

WriteCCLinkBitBuffer 関数、WriteCCLinkWordBuffer 関数、WriteDeviceNetBuffer 関数、WriteEIPBuffer 関数、WriteModbusBuffer 関数、WriteProfinetBuffer 関数、WriteMC 関数、および WriteResultsBuffer 関数に送信されるデータのフォーマットをユーザが設定することができます。

これをFormatOutputBuffer 関数 [関数の挿入] ダイアログから選択すると、[フォーマット出力バッファ] ダイアログが自動的に表示されるので、これを使用して関数をプログラミングします。

FormatOutputBuffer 関数の入力パラメータ

FormatOutputBuffer 関数(

WithErr,

フォーマット,

値1,

[値2,

...]

)

WithErr

入力エラーが発生している場合でも、関数が有効なバッファを返すかどうかを指定します。

0 = 入力エラーが発生している場合でも、データはバッファに入れられます (デフォルト)。

1 = 関数は、#ERR を返し、データはバッファに格納されません。

フォーマット

自動設定に使用されるデータタイプとエレメントのサイズ (単位はバイト) を指定します。

注:

  • Modbus TCP、EIP、または PROFINET 通信を使用している場合の出力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。

  • この関数では、数式に最大 248 文字を使用できます。16 ビット整数 1 つは 3 文字であるため、16 ビット整数を使用する場合、出力データの最大長は 140 バイトになります。この上限を超えた場合、関数から「Error String too long」が返されます。出力データが 140 バイトを超える場合は、CombineOutputBuffers 関数を使用します。

値

値の可変長リストを指定します。

FormatOutputBuffer 関数の出力

戻り値

フォーマット後のデータを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • FormatInputBuffer 関数
  • ReadCCLinkBitBuffer 関数
  • WriteCCLinkBitBuffer 関数
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkWordBuffer 関数
  • ReadDeviceNetBuffer 関数
  • WriteDeviceNetBuffer 関数
  • ReadEIPBuffer 関数
  • WriteEIPBuffer 関数
  • ReadDeviceNetBuffer 関数
  • ReadModbusBuffer 関数
  • WriteModbusBuffer 関数
  • ReadProfinetBuffer 関数
  • WriteProfinetBuffer 関数
  • WriteResultsBuffer 関数
  • CombineOutputBuffers 関数


ImportData 関数

ImportData 関数 |
入出力関数 | In-Sight 関数リファレンス

ImportData 関数は、スプレッドシートであらかじめ定められたイベントが、あるセルデータ (.CXD) ファイルのロードを示しているときに、このファイルをスプレッドシートに自動的に挿入する関数です。ImportData 関数を使用して、ExportData 関数でエクスポートされたデータ (.CXD ファイルとして格納済み) を一度に 1 セルずつ、次の場所からインポートします。ローカルまたはネットワークに接続された In-Sight センサのフラッシュメモリ、FTP を経由する中央サーバ、あるいはローカルまたはネットワークに接続されたセンサの RAM ディスクまたは SD カードです。

ImportData 関数を使用して .CXD ファイルをインポートした場合、データは ImportData 関数の一部となり、編集できません。 インポートした .CXD ファイルをクリックすると、インポートしたデータタイプに対応したプロパティシートではなく、ImportData 関数のプロパティシートが開きます。ImportData 関数は、次のデータタイプをインポートできます。DelayLine、CountPassFail、Calibrate と CalibrateAdvanced、FindPatterns、OCRMax と OCRMaxSettings、および TrainPatMaxPattern と TrainFont。

注: ImportData 関数は、PC 上の スニペット フォルダからは .CXD ファイルをインポートできません。

  • ImportData の入力パラメータ
  • ImportData 関数の出力
  • ImportData 関数の例
  • 関連項目

ImportData 関数の入力パラメータ

ImportData 関数(

イベント,

ホスト名,

ユーザ名,

パスワード,

ファイル名

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

ホスト名

ファイルの保存場所を示します。 ファイルは、フラッシュメモリ経由でローカルセンサ、FTP 経由で外部サーバ、またはローカルもしくはネットワークに接続されたセンサの RAM ディスクまたは SD カードに格納することができます。

注:

  • [ホスト名] ドロップダウンには、In-Sight ビジョンシステムのホスト名やネットワーク上のエミュレータは表示されません。ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。
  • フラッシュメモリ、RAM ディスク、または SD カードからデータをインポートする場合、[ホスト名] フィールドは空欄のまま (例: "") にしておく必要があります。インポート先に FTP サーバが指定されているときに、データ転送時にこの FTP サーバが使用できなかった場合、タイムアウトまで数秒かかります。 タイムアウトした場合、In-Sight Explorer はセンサから切断される可能性があります。

ユーザ名

ファイルの格納先センサまたはデバイスのファイルシステムにアクセスするユーザの名前を指定します。

パスワード

ファイルの格納先センサまたはデバイスのファイルシステムにアクセスするためのパスワードを指定します。

注: ホスト名、ユーザ名、およびパスワードパラメータは、インポート先が FTP の場合のみ必要です。

ファイル名

格納する情報の識別に使用されるファイルの名前を指定します。

  • RAM ディスクからインポートする場合、ファイル名の前に、"ramdisk/" を付けて指定する必要があります。 例えば、"ramdisk/PartXPattern" と指定します。 ここでは大文字と小文字は区別されません。
  • SD カードからインポートする場合、ファイル名の前に、"sdcard/" を付けて指定する必要があります。例えば、"sdcard/PartXPattern" と指定します。ここでは大文字と小文字は区別されません。

注: ファイル名に拡張子をつける必要はありません。 テキスト文字列に自動的に追加されます。異なるファイル名拡張子を指定した場合、#ERR が返されます。

ImportData 関数の出力

インポートされたデータは、エクスポートされたセルに含まれるデータのデータ構造に対応します。例えば、整数をインポートすると、セルには整数値が表示されます。また、 [image] 構造体をインポートすると、セルには [image] 構造体が表示されます。ただし、 [image] 構造体をダブルクリックすると、ImportData 関数のプロパティシートが表示されます。 構造体のプロパティシートではない点に注意してください。

次の 4 つの条件のうち 1 つが満たされた場合、ImportData 関数により .CXD ファイルがインポートされます。

  • ImportData プロパティシートの [OK] ボタンが押された。
  • イベントが受信された。
  • イベントパラメータが ON （または参照先のセルが 0 以外）のとき、ImportData の入力パラメータの 1 つが更新された。
  • ImportData 関数を使用しているジョブがロードされた。

注: ImportData 関数は、オフラインモードでも、データをインポートします。

ImportData 関数例

ImportData(A0,"192.168.0.100","admin","","PartXPattern")

この関数は、画像の取り込み後にスプレッドシートが更新されるたびに、IP アドレス 192.168.0.100 にあるサーバから、PartXPattern.cxd という名前のファイルとしてデータをインポートします。ユーザ名は admin と指定されています。 また、パスワードは空白です。

関連項目

Event 関数

ExportData 関数

セルのインポート/エクスポート

入出力関数について


IntegratedLightControl

入出力関数

In-Sight 関数リファレンス

ユーザは、In-Sight 76xx ～ 79xx ビジョンシステムのフェースプレートの前面に接続されている組み込み照明アクセサリの照明の設定を行うことができます。使用可能な関数の入力は、ビジョンシステムに接続されている照明デバイスのタイプ (In-Sight 照明アクセサリ、DataMan 標準照明アクセサリ、または DataMan 高出力照明アクセサリ) に応じて異なります。

  • In-Sight 照明の入力
  • DataMan 標準照明の入力
  • DataMan 高出力照明の入力
  • IntegratedLightControlの出力
  • 関連項目

注:

  • 照明アクセサリは必ずビジョンシステムのフェースプレートの前面に接続し、[照明の設定] ダイアログで [組み込み] を選択する必要があります。[組み込み] を選択しないと、関数によって #ERR が返されます。
  • 関数IntegratedLightControlがスプレッドシートに挿入されている場合は、[照明の設定] ダイアログで設定の変更を試みると、ダイアログで指定した設定がスプレッドシート関数によって上書きされます。
  • 1 つのジョブにIntegratedLightControl関数のインスタンスが複数存在する場合、照明アクセサリでは、最後に実行された関数のインスタンスによって指定された設定が使用されます。
  • In-Sight 76xx ～ 79xx シリーズのビジョンシステムでは、ビジョンシステムのフェースプレートへの組み込み照明アクセサリの接続、およびビジョンシステムの LIGHT コネクタへの外部照明の接続がサポートされますが、両方の照明器具を同時に使用することはできません。サポート対象アクセサリの完全な一覧については、『In-Sight® 7000 Gen2 Series Vision System Reference Guide』を参照してください。

In-Sight 照明の入力

IntegratedLightControl(

イベント,

上バンク,

右バンク,

左バンク,

下バンク,

未使用,

未使用,

未使用,

未使用,

輝度,

常に ON

)

イベント

強制的な更新の原因となるイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。(デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値。
上バンク

In-Sight 照明アクセサリには、4 つの LED バンクに分かれた 8 のLED が含まれています。

0 = LED バンクはオフ。

1 = LED バンクはオン。(デフォルト)
右バンク
左バンク
下バンク
未使用 サポートされていません。デフォルトでは 1 に設定されています。
未使用
未使用
未使用
輝度

照明アクセサリ LED バンクの実効輝度をパーセンテージとして指定します。 すべての LED バンクで共通の輝度値が共有され、輝度は 50% ～ 100% に制限されています。これは、すべての LED バンクで輝度が均等に分散されるようにするためです。(50% ～ 100%、デフォルト = 100%)

注:

  • この In-Sight 照明アクセサリには、明度、LED リングライト色、ビジョンシステムの解像度、取り込まれた行数によって左右される最大ストロボパルス幅があります。照明アクセサリは特定の露光時間の間、点灯します。露光時間が最大ストロボパルス幅を超過した場合、LED リングライトは最大ストロボパルス幅の間だけ点灯します。次に例を示します。

    LED リングライト色 | 明度 | 最大ストロボパルス幅 (ミリ秒)

    In-Sight 7600/7800/7900

    800×6001

    In-Sight 7600/7800/7900

    640×4801

    In-Sight 7801/7901

    1280×1024

    In-Sight 7802/7902

    1600×12001

    In-Sight 7802/7902

    800×600 (低照明モード)1

    In-Sight 7905

    2448×2048
    白 100% 0.314 0.232 0.704 1.022 1.022

    1.599
    50% 0.779 0.574 1.744 2.531 2.531

    3.961
    赤 100% 0.375 0.277 0.841 1.220 1.220

    1.847
    50% 1.083 0.799 2.426 3.519 3.519

    5.508
    赤外線 | 100% | 0.351 | 0.259 | 0.786 | 1.140 | 1.140 | 1.785
    50% | 0.857 | 0.632 | 1.921 | 2.787 | 2.787 | 4.361
    青 | 100% | 0.314 | 0.232 | 0.704 | 1.022 | 1.022 | 1.599
    50% | 0.765 | 0.564 | 1.713 | 2.485 | 2.485 | 3.889
    LED リングライト色 | 明度 | 最大ストロボパルス幅 (ミリ秒)

    In-Sight 7600C/7800C/7900C

    800×6001

    In-Sight 7600C/7800C/7900C

    640×4801

    In-Sight 7801C/7901C

    1280×1024

    In-Sight 7802C/7902C

    1600×12001

    In-Sight 7802C/7902C

    800×600 (低照明モード)1

    In-Sight 7905C

    2448×2048
    白 100% 0.314 0.232 0.704 1.022 1.022

    1.599
    50% 0.779 0.574 1.744 2.531 2.531

    3.961

    1解像度は、[画像の設定] ダイアログで設定できます。
  • 露光時間が最大ストロボパルス幅を超える場合、LED の効率性が低電流で増すため、輝度が低くなって画像がより明るくなることがあります。
常に ON 複数の取り込みの間に一貫した光レベルを提供するため、選択された LED バンクは常にオンになります。

0 = OFF

1 = ON (デフォルト)

DataMan 標準照明の入力

注:DataMan 標準照明アクセサリと高出力照明アクセサリは、In-Sight 7905 または 7905C ではサポートされません。

IntegratedLightControl(

イベント,

左バンク (内側),

左バンク (外側),

上バンク (内側),

上バンク (外側),

右バンク (内側),

右バンク (外側),

下バンク (内側),

下バンク (外側),

輝度,

常に ON

)

イベント

強制的な更新の原因となるイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。(デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値。
左バンク (内側)

DataMan 標準照明アクセサリには、8 つの LED バンクに分かれた 36 のLED が含まれています。

0 = LED バンクはオフ。

1 = LED バンクはオン。(デフォルト)
左バンク (外側)
上バンク (内側)
上バンク (外側)
右バンク (内側)
右バンク (外側)
下バンク (内側)
下バンク (外側)
輝度

照明アクセサリ LED バンクの実効輝度をパーセンテージとして指定します。 すべての LED バンクが共通の輝度値を共有します。(0% ～ 100%、デフォルト = 100%)
常に ON サポートされていません。デフォルトでは 0 に設定されています。

DataMan 高出力照明の入力

注:DataMan 標準照明アクセサリと高出力照明アクセサリは、In-Sight 7905 または 7905C ではサポートされません。

IntegratedLightControl(

イベント,

左バンク 1,

左バンク 2,

上バンク 1,

上バンク 2,

右バンク 1,

右バンク 2,

下バンク 1,

下バンク 2,

輝度,

常に ON

)

イベント

強制的な更新の原因となるイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。(デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値。
左バンク 1

DataMan 高出力照明アクセサリには 8 つの LED が含まれており、これらはすべて自身の LED バンクとして個別にアドレス指定が可能です。

0 = LED バンクはオフ。

1 = LED バンクはオン。(デフォルト)
左バンク 2
上バンク 1
上バンク 2
右バンク 1
右バンク 2
下バンク 1
下バンク 2
輝度 | サポートされていません。デフォルトでは 100 に設定されています。
常に ON | サポートされていません。デフォルトでは 0 に設定されています。

IntegratedLightControlの出力

戻り値

データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

入出力関数について

ExternalLightControl

[照明の設定] ダイアログ

Version: 5.6.0


マシンステータス関数

マシンステータス関数 |
入出力関数 | In-Sight 関数リファレンス

マシンステータス関数は、In-Sight センサの動作ステータス情報を格納します。

  • PushMSStack 関数: 各バッファの内容全体をマシンステータススタックのバッファにシフトします。
  • WriteMSStack 関数: スプレッドシートからユーザが指定した文字列を、マシンステータススタックの最初のバッファの動作ステータス情報に追加します。


PushMSStack 関数

PushMSStack 関数 |
入出力関数 → マシンステータス関数 | In-Sight 関数リファレンス

各バッファの内容全体をマシンステータススタックのバッファにシフトします。

PushMSStack 関数 (

イベント

)

ユーザが指定した情報を、マシンステータススタックのバッファ 0 の動作ステータス情報に追加するには、WriteMSStack 関数を使用します。スタックに保存されているデータにアクセスするには、GetMSBuffer コマンドをネイティブモード接続を経由して、またはマシンステータスポートから使用します。

注: スタックのすべてのバッファに情報が保存されると、バッファ 7 のデータが破棄されます。

PushMSStack 関数の入力パラメータ

イベント

動作ステータス情報をマシンステータススタックにシフトする、更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

PushMSStack 関数の出力

戻り値

データ構造体。入力イベントが無効であれば #ERR を返します。

関連項目

Event 関数

WriteMSStack 関数

ステータスビュー

入出力関数について


WriteMSStack 関数

入出力関数 → マシンステータス

In-Sight 関数リファレンス

スプレッドシートが更新されるたびに、ユーザが指定した文字列をスプレッドシートからマシンステータススタックのバッファ 0 の操作ステータス情報に付加します。

マシンステータススタックで各バッファの内容全体を次のバッファにシフトするには、PushMSStack 関数を使用します。スタックに保存されているデータにアクセスするには、ネイティブモード接続経由で、またはマシンステータスポートから GetMSBuffer コマンドを使用します。

WriteMSStack 関数 (

イベント,

文字列

)

注: この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。

WriteMSStack 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

文字列

文字列または文字列を含んでいるセルへの参照。文字列の最大長は 255 文字で、その中には、区切り文字 (例えば、カンマ (,)、セミコロン (;)、CRLF: 復帰改行 CRLFなど) として使われる文字が含まれます。ユーザ定義の XML タグも文字列に含めることができます。

WriteMSStack 関数の出力

戻り値

付加するテキストを含んでいる [image] データ構造体。入力された文字列が無効な場合は #ERR を返します。

関連項目

Event 関数

PushMSStack 関数

ステータスビュー

入出力関数について


メッセージ関数

メッセージ関数 |
入出力関数 | In-Sight 関数リファレンス

メッセージ関数は、ネイティブモード経由で In-Sight センサからテキスト文字列を読み取り、In-Sight センサへテキスト文字列を書き込みます。

  • ReadMessage 関数: Send Message コマンドを使用して、リモートネットワークホストまたはシリアルデバイスによって送信されたテキスト文字列を読み取ります。
  • WriteMessage 関数: ReadMessage 関数が実行されると必ず、テキスト文字列を書き出します。WriteMessage 関数は、ReadMessage 関数によって使用される同じ接続を経由して、文字列を出力します。


ReadMessage 関数

ReadMessage 関数 |
入出力関数 → メッセージ関数 | In-Sight 関数リファレンス

ネイティブモード接続を使用して、Send Message コマンドから文字列を読み取ります。この関数は、指定したイベントのそれぞれの出現時に、文字列を読み取ります。

ReadMessage 関数 (

Event

)

注: ネイティブモード接続がシリアルポートを経由している場合は、シリアルポートモードをネイティブに設定する必要があります。

ReadMessage 関数の入力パラメータ

Event

文字列を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

ReadMessage 関数の出力

戻り値

読み込むテキスト文字列を含んでいる [image] データ構造体。入力 [イベント] パラメータが無効な場合は #ERR を返します。

関連項目

Event 関数

WriteMessage 関数

シリアルポートのモード

入出力関数について


WriteMessage 関数

入出力関数 → メッセージ

In-Sight 関数リファレンス

スプレッドシートが更新されるたびに、テキスト文字列をネイティブモード接続経由で書き込みます。WriteMessage は、ReadMessage 関数によって使用される同じ接続経由で文字列を出力します。

WriteMessage 関数 (

イベント,

文字列

)

注:

  • ネイティブモード接続を確立するには、ReadMessage 関数をスプレッドシートに挿入する必要があります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。

WriteMessage 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

文字列

文字列または文字列を含んでいるセルへの参照。255 文字まで入力できます。

WriteMessage 関数の出力

戻り値

書き込む文字列を含んでいる [image] データ構造体。入力された文字列の値が無効な場合は #ERR を返します。

関連項目

Event 関数

ReadMessage 関数

シリアルポートのモード

入出力関数について


ネットワーク関数

入出力関数

In-Sight 関数リファレンス

ほとんどのネットワーク関数は、ネットワーク上の TCP/IP デバイスと In-Sight センサでデータを共有するために使用されます。通常のネットワーク関数に加え、FTP サーバ機能を使用してネットワークの記憶装置に自動的に画像の保存を可能にする WriteImageFTP 関数があります。

  • ClearResultsBuffer 関数: 指定したイベントの後、ファクトリプロトコルの結果バッファからバッファされた結果をクリアします。
  • GetByteCount 関数: FormatOutputBuffer、ReadCCLinkBitBuffer、ReadCCLinkWordBuffer、ReadEIPBuffer、ReadLatchedUserDataBuffer、ReadModbusBuffer、ReadProfinetBuffer、または ReadUserDataBuffer 関数に書き込まれたバイト数を返します。
  • GetConnectionStatus 関数: 指定されたプロトコルの接続ステータスを返します。
  • GetRemoteAddress 関数: UDP サーバが最後に受信したメッセージの送信元 IP アドレスを返します。
  • GetRemotePort 関数: UDP サーバが最後に受信したメッセージのクライアントのポート番号を返します。
  • Packet 関数: TCPDevice 関数によって読み出しまたは送信される、バイナリ文字列パケットフォーマットを定義します。
  • QueryDevice 関数: 指定した TCP/IP クライアントデバイスにデータを出力し、そのデバイスからの入力データを受信します。
  • ReadCCLinkBitBuffer 関数: CC-Link 通信を利用する三菱電機 PLC およびモーションコントローラ (MC) によって送信されたデータを読み取り (消費し) ます。
  • ReadCCLinkWordBuffer 関数: CC-Link 通信を利用する三菱電機 PLC/MC によって送信されたデータを読み取り (消費し) ます。
  • ReadDevice 関数: TCP/IP クライアントデバイスから In-Sight センサへデータをインポートします。
  • ReadEIP 関数: EtherNet/IP プロトコルを使用するクライアントによって生成されたデータを読み取り (消費し) ます。
  • ReadEIPBuffer 関数: リモートクライアントにより、EtherNet/IP プロトコルを使用して、FormatInputBuffer 関数の作成した、参照される [image] 構造体に送信されたデータを読み取り (消費し) ます。
  • ReadLatchedUserDataBuffer 関数: バッファ画像取り込みモードの場合に、FormatInputBuffer 関数に含まれているデータを読み取ります。
  • ReadMC 関数: SLMP 通信を利用する三菱電機 PLC/MC によって送信されたデータを読み取り (消費し) ます。
  • ReadModbusBuffer 関数: Modbus プロトコルを利用するリモートクライアントによって送信されたデータを読み取り (消費し) ます。
  • ReadProfinetBuffer 関数: リモートクライアントにより、Profinet プロトコルを使用して、FormatInputBuffer 関数の作成した、参照される [image] 構造体に送信されたデータを読み取り (消費し) ます。
  • ReadUserDataBuffer 関数: 現在有効なファクトリプロトコルのユーザデータフィールドのデータを読み取り (消費し) ます。
  • ReadResult 関数: ネットワークに接続された In-Sight センサ（「送信側」）から値をインポートします。
  • TCPDevice 関数: In-Sight スプレッドシートのセルを TCP/IP デバイス（クライアントまたはサーバ）として定義します。
  • UDPDevice 関数: UDP (User Datagram Protocol) を介してネットワーク接続された別のデバイスと通信するための単一の接続を定義します。
  • WriteCCLinkBitBuffer 関数: CC-Link 通信を利用する三菱電機 PLC/MC にデータを書き込みます。
  • WriteCCLinkWordBuffer 関数: CC-Link 通信を利用する三菱電機 PLC/MC にデータを書き込みます。
  • WriteDevice 関数: In-Sight センサから TCP/IP サーバデバイスにデータをエクスポートします。
  • WriteEIP 関数: EtherNet/IP プロトコルを使用して読み取る（消費する）クライアントデバイス用に、指定したパケット要求間隔（RPI）でデータを出力します。
  • WriteEIPBuffer 関数: EtherNet/IP プロトコルを使用して読み取る (消費する) クライアントデバイスで指定されたパケット要求間隔 (RPI) で、FormatOutputBuffer 関数の作成した、参照される [image] 構造体にデータを書き込みます。
  • WriteFTP 関数: ネットワーク上の FTP サーバの指定したファイルにテキスト文字列を追記します。
  • WriteImageFTP 関数: FTP サーバを使用している転送先のシステムへ現在の画像を転送します。
  • WriteImageSFTP 関数: SFTP サーバを使用している転送先のシステムへ現在の画像を転送します。
  • WriteMC 関数: SLMP 通信を利用する三菱電機 PLC/MC にデータを書き込みます。
  • WriteModbusBuffer 関数: FormatOutputBuffer 関数によって生成された、参照される [image] 構造体からデータを書き込み、Modbus プロトコルを使用して、リモートクライアントデバイスで使用できるようにします。
  • WriteProfinetBuffer 関数: Profinet プロトコルを使用して読み取る (消費する) クライアントデバイスで指定されたパケット要求間隔 (RPI) で、FormatOutputBuffer 関数の作成した、参照される [image] 構造体にデータを書き込みます。
  • WriteResult 関数: ネットワークに接続された In-Sight センサ（「受信側」）に値をエクスポートします。
  • WriteResultsBuffer 関数: FormatOutputBuffer 関数によって作成され、参照している [image] 構造体にデータを書き込みます。このデータは、有効なファクトリ通信プロトコルによってクライアントデバイスが読み取り (消費し) ます。
  • WriteSMTP 関数: SMTP サーバを介して電子メールメッセージを送信します。


ClearResultsBuffer 関数

ClearResultsBuffer 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

指定したイベントの後、ファクトリプロトコルの結果バッファからバッファされた結果をクリアします。関数が指定したイベントを受け取ると、次のことが起こります。

  • 結果バッファのキューに入れられた結果はすべて削除されます (結果バッファが有効な場合)。
  • 現在有効なファクトリプロトコルを介してレポートされた現在の結果はクリアされます (結果 ID、結果コード、およびすべての結果データを含む)。
  • Results Valid ビットはクリアされます。

ClearResultsBuffer 関数の実行後、WriteResultsBuffer 関数を使用して追加の結果をキューに入れることができます。

注: 結果バッファのクリア中は、ビジョンオブジェクトがロックされるため、ファクトリ通信プロトコルを介した In-Sight ビジョンシステムと PLC との間の通信は、結果のクリア操作が完了するまで遅くなります。

ClearResultsBuffer 関数 (

イベント

)

ClearResultsBuffer 関数の入力パラメータ

イベント

結果バッファからのデータのクリアをトリガするスプレッドシートイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

ClearResultsBuffer 関数の出力

戻り値

値 1。入力パラメータが無効な場合は #ERR が返されます。

ClearResultsBuffer 関数例

In-Sight ビジョンシステムがオフラインからオンラインに変わったときに、ClearResultsBuffer 関数を使用して PROFINET ファクトリ通信プロトコルの結果バッファをクリアします。

  1. 開始するため、PLC が結果バッファを有効にします。
  2. 次に、PLC が画像取り込みをトリガします。
  3. In-Sight ビジョンシステムは、画像を取り込み、WriteResultsBuffer 関数を使用して結果を結果バッファに送信することで応答します。
  4. PLC が別の画像取り込みをトリガします。
  5. 再び、In-Sight ビジョンシステムは、画像を取り込み、WriteResultsBuffer 関数を使用して結果を結果バッファに送信することで応答します。
  6. 何かが生産ラインで発生し、生産マシンをリセットする必要があります。
  7. PLC はスプレッドシート内でイベントをトリガし、In-Sight ビジョンシステムの状態をリセットします。

注: 2 通りの方法が考えられます。1 番目の方法では、PLC がオンライン → オフライン → オンラインといった移行をトリガし、ビジョンシステムの状態をリセットします。このシナリオでは、ClearResultsBuffer 関数をトリガするオンラインイベントを使用してスプレッドシートをプログラムする必要があります。2 番目の方法では、PLC がソフトイベントをトリガしてビジョンシステムの状態をリセットします。このシナリオでは、ソフトイベントがトリガされたときに ClearResultsBuffer 関数をトリガするイベント関数を使用してスプレッドシートをプログラムする必要があります。

  8. ビジョンシステムは、ClearResultsBuffer 関数を使用して結果バッファをクリアし、手順 5 でキューに入れられた結果はキューから削除されます。
  9. データ、結果コード、結果 ID を含め、結果の値はすべて 0 にリセットされます。

関連項目

Event 関数

入出力関数について


入出力関数

入出力関数 |
データアクセス | In-Sight 関数リファレンス

関数

説明
GetBinaryString(ビットストリーム)

データ構造体を 2 進数のリストとして返します。

注: 返される文字列は参照のみを目的としています。In-Sight ファームウェアは数値形式として 2 進数をサポートしていません。

GetBufferData(バッファ読み込み, インデックス)

、 [image] 、 [image] 、 [image] 、または [image] データ構造体のインデックス付きデータを返します。

注:
  • 、 [image] 、 [image] 、 [image] データ構造体は、ファームウェア 4.9.3 以前を実行している In-Sight ヴィジョンシステムのみでサポートされます。これらのデータ構造体は、In-Sight 5.1.0 以上のファームウェアを実行しているビジョンシステムではサポートされません。
  • ReadDeviceNet 関数のイベントパラメータは、Event 関数を含んでいるセルを参照し、この Event 関数のトリガパラメータは、ポートパラメータの値に応じて、シリアルポート 0 またはシリアルポート 1 を指定している必要があります。
GetByteCount(バッファ) | FormatOutputBuffer 関数に書き込まれたバイト数、あるいは ReadCCLinkBitBuffer、ReadCCLinkWordBuffer、ReadEIPBuffer、ReadLatchedUserDataBuffer、ReadModbusBuffer、ReadProfinetBuffer、または ReadUserDataBuffer 関数に読み込まれたバイト数を返します。

GetClock(時間, フォーマット文字列, [ローカル/GMT])

現在の日時を、Now 関数によって返される [image] データ構造体の、「C」ライブラリ標準フォーマット文字列を使用して構成される文字列として返します。

フォーマット文字列

日時を表示するフォーマットを指定します。デフォルトのフォーマット文字列は、「月/日/年　時:分:秒」で、これは次のように表されます。

%m/%d/%Y %H:%M:%S

次の変数を使用できます。

%m | 月
%d | 日
%Y | 年
%H | 時
%M | 分
%S | 秒
%3N | ミリ秒
%6N | マイクロ秒
%9N | ナノ秒
ローカル/GMT

0 = ローカル、サマータイム (デフォルト)

1 = GMT (UTC)

2 =ローカル、標準時
GetConnectionStatus(イベント, プロトコル)

指定された通信プロトコルの接続ステータスを返します。関数は、プロトコルが機能しているがアクティブな接続がない場合は 0 を返し、プロトコルが機能しておりアクティブな接続がある場合はアクティブな接続の数を返します。接続に失敗した場合は #ERR を返します。この場合、GetErrorCode 関数と GetErrorString 関数を使用してエラーの原因を判別できます。

イベントパラメータは、ネットワークエラーイベントをキャプチャするように設定された Event 関数、またはセル A0 内の AcquireImage 関数を参照している必要があります。

プロトコルパラメータは、ステータス更新をポーリングするプロトコルを定義するために使用されます。

  • 0 = EtherNet/IP
  • 1 = PROFINET
  • 2 = SLMP スキャナ
  • 3 = Modbus TCP サーバ
  • 4 = CC Link
  • 5 = DeviceNet
  • 6 = POWERLINK
  • 8 = CC-Link IE フィールド Basic
  • 100 = 現在有効な産業用ファクトリプロトコル

注: CC Link と DeviceNet はこの関数ではサポートされていません。CC Link か DeviceNet を選択すると「Argument Out of Range」エラーが返されます。

GetFilename(FTP)

データ構造体のファイル名を返します。
GetHexString(ビットストリーム)

データ構造体に含まれるビットを、標準「0x」プレフィックス付きの 16 進数文字列として返します。16 進数文字列は最上位ニブルが先頭にきます。

注意: ビット数が 4 の倍数でない場合は、右から左へビットがニブルに効率的にグループ化されるように最上位位置に 0 が埋められます。

Closed 例 - 16 進数値のパディング
ビット | パディングあり | 16 進数
1 | 1000 | 1
11 | 0011 | 3
111 | 0111 | 7
1111 | 1111 | F
1 1111 | 0001 1111 | 1F
11 1111 | 0011 1111 | 3F
111 1111 | 0111 1111 | 7F
1111 1111 | 1111 1111 | FF
GetNumBits(ビットストリーム) | データ構造体に含まれるビットの合計を返します。
GetNumWaveformsPending(イベント)

現在実行中、または実行のためにキューに入っている WriteWaveformPulseTrain 波形または WriteWaveformClocked 波形の合計を返します。現在実行中の波形がない場合は、0 を返します。この値が 0 に等しくなるとすぐに、新しい波形が実行されます。この値が 0 以外の場合、波形は、適用されている設定とキューの空き領域に応じてキューに入れられるか、または廃棄されます。

注: 単一の波形キューが存在するため、この関数は入力として WriteWaveformPulseTrain 関数または WriteWaveformClocked 関数を使用しません。代わりに、この関数はイベント (例えば、Button 関数や AcquireImage 関数) を使用して定期的に関数を更新します。
GetRemoteAddress(デバイス) | UDP サーバが受信した最新メッセージの送信元デバイスの IP アドレスを返します。デバイスパラメータには、UDPDevice 関数によって返された [image] データ構造体への参照を指定します。
GetRemotePort(デバイス) | UDP サーバが受信した最新メッセージの送信元デバイスのポート番号を返します。デバイスパラメータには、UDPDevice 関数によって返された [image] データ構造体への参照を指定します。

GetResult(結果, インデックス)

データ構造体のインデックス付きの値を返します。
Version: 5.6.0


Packet 関数

Packet 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

TCPDevice 関数によって読み出しまたは送信される、バイナリ文字列パケットのフォーマットを定義します。

Packet 関数 (

長さフィールド位置,

長さフィールドサイズ,

エンディアン,

長さの調整,

バッファサイズ,

フォーマット文字列

)

Packet 関数の入力パラメータ

長さフィールド位置

長さフィールドの位置 (0 ～ 4096) を指定します。

長さフィールドサイズ

長さフィールドに使用されるバイト数 (0、1、2、または 4) を指定します。

注: [長さフィールドサイズ] パラメータを 0 に設定すると、パケットは固定長になり、長さフィールドはパケットに書き込まれません。[長さフィールドサイズ] パラメータを 0 に設定する場合、[長さフィールド位置] パラメータも 0 に設定して、[長さの調整] パラメータにパケットに必要な長さを設定する必要があります。

エンディアン

バイトのシーケンスが格納される順序を指定します。

0 = ビッグエンディアン (デフォルト) | 最上位の値が最初に格納されるように指定します。
1 = リトルエンディアン | 最下位の値が最初に格納されるように指定します。

長さの調整

(長さフィールドで指定される) パケット長を調整するバイト数 (-4096 ～ 4096) を指定します。

バッファサイズ

データを格納するために割り当てられるメモリの量 (16 ～ 4096) を指定します。

フォーマット文字列

指定されたフォーマットを使用して文字列を作成します。

使用できる書式文字列パラメータは次のとおりです。

パラメータ | 説明
%c | 1 バイト
%h | 2 バイト
%d | 4 バイト
%f | 4 バイト浮動小数点数
%b | バイナリ構造体
%s | 文字列

Packet 関数の出力

戻り値

データ構造体。入力パラメータが無効であれば #ERR を返します。


QueryDevice 関数

QueryDevice 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

指定した TCP/IP サーバデバイスまたは UDP サーバデバイスへデータを書き込み、次にそのデバイスからデータを読み取ります。デバイスからの応答は、デバイスのタイムアウト制限に達する前に受け取る必要があります。

注: この関数の主な使用目的は、Modbus サーバからバイナリデータパケットを取得することです。

QueryDevice 関数の入力パラメータ

QueryDevice 関数 (

イベント,

デバイス,

データ

)

イベント

TCP/IP デバイスへのデータ書き込みをトリガする、スプレッドシートのイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

デバイス

構造体への参照です。TCPDevice 関数が生成した TCP/IP クライアント、または　UDPDevice 関数が返した [image] 構造体への参照である必要があります。

データ

TCP/IP または UDP デバイスに出力されるデータです。TCP/IP が実装されている場合、データタイプはデバイスの [パケットタイプ] (ASCII 文字列またはバイナリ Modbus コマンド) で指定されたタイプと同じである必要があります。UDP が実装されている場合、データタイプはデバイスの [バイナリパケット] パラメータ (バイナリデータパケットまたは文字列情報) で指定されたタイプと同じである必要があります。

QueryDevice 関数の出力

戻り値

データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • 入出力関数について
  • バイナリ関数
  • Event 関数
  • ReadDevice 関数
  • TCPDevice 関数
  • TCP/IP Modbus による通信
  • UDPDevice 関数
  • WriteDevice 関数


ReadCCLinkBitBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatInputBuffer 関数によって生成された、参照される [image] データ構造体からのデータを、イベントのトリガ時に、CC-Link プロトコルを使用している CC-Link ネットワークから読み取ります。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • この機能を有効にするには、In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されている必要があります。
  • In-Sight ビジョンシステムが CC-Link 経由で三菱電機 Automation Controller と通信するように設定されている場合、プロトコルはビジョンシステムと Automation Controller との間のデータ転送のみをサポートします。

ReadCCLinkBitBuffer 関数の入力パラメータ

ReadCCLinkBitBuffer 関数(

イベント,

バッファ

)

イベント

指定した [image] 構造体を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された [image] データ構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、256 バイトです。

ReadCCLinkBitBuffer 関数の出力

戻り値

読み取ったデータおよびフォーマットを含む [image] データ構造体。次の場合には #ERR を返します。

  • 入力パラメータが無効の場合
  • In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されていない場合
  • FormatInputBuffer 関数の項目が、[ビット] または [16 ビット整数] 以外のデータ型の場合

関連項目

  • 入出力関数について
  • CC-Link 経由での三菱電機 Automation Controller との通信
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkBitBuffer 関数
  • WriteCCLinkWordBuffer 関数
Version: 5.6.0


ReadCCLinkWordBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatInputBuffer 関数によって生成された、参照される [image] データ構造体からのデータを、イベントのトリガ時に、CC-Link プロトコルを使用している CC-Link ネットワークから読み取ります。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • この機能を有効にするには、In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されている必要があります。
  • In-Sight ビジョンシステムが CC-Link 経由で三菱電機 Automation Controller と通信するように設定されている場合、プロトコルはビジョンシステムと Automation Controller との間のデータ転送のみをサポートします。

ReadCCLinkWordBuffer 関数の入力パラメータ

ReadCCLinkWordBuffer 関数(

イベント,

バッファ

)

イベント

指定した [image] 構造体を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された [image] データ構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、256 バイトです。

ReadCCLinkWordBuffer 関数の出力

戻り値

読み取ったデータおよびフォーマットを含んでいる [image] データ構造体。次の場合には #ERR を返します。

  • 入力パラメータが無効の場合
  • In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されていない場合
結果 　データ構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

  • CC-Link 経由での三菱電機 Automation Controller との通信
  • ReadCCLinkBitBuffer 関数
  • WriteCCLinkBitBuffer 関数
  • WriteCCLinkWordBuffer 関数
  • 入出力関数について
Version: 5.6.0


ReadDevice 関数

ReadDevice 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

TCP/IP または UDP 接続を利用してネットワーク上の別のホストから、In-Sight ビジョンシステムへデータをインポートします。

注:
  • 2 つの In-Sight ビジョンシステム間で TCP/IP デバイス接続を確立するには、両方のデバイスをオンラインにする必要があります。
  • ReadDevice 関数を UDP を使用して通信するよう設定されている場合、バッファリングはありません。最後に受信したデータパケットが処理される前に別のデータパケットを受信した場合、新しいパケットが古いパケットに置き換えられます。

ReadDevice 関数の入力パラメータ

ReadDevice 関数(

デバイス

)

デバイス

TCPDevice 関数または UDPDevice 関数で作成された [image] データ構造体を含んでいるスプレッドシートのセルを参照します。

ReadDevice 関数の出力

戻り値

接続が確立されると、TCP/IP または　UDP クライアントからインポートされるデータを返します。有効な [image] データ構造体を含まないセルが参照された場合、または UDP メッセージのデフォルトバッファサイズ (256 バイト) より大きなメッセージを受信した場合は #ERR を返します。

関連項目

  • 入出力関数について
  • バイナリ関数
  • QueryDevice 関数
  • TCPDevice 関数
  • UDPDevice 関数
  • WriteDevice 関数


ReadEIP 関数

ReadEIP 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

EtherNet/IP プロトコルを使用するリモートクライアントによって送信されたデータを読み取り (消費し) ます。

注:

  • In-Sight 5.1.0 以降のファームウェアを搭載している In-Sight ビジョンシステムで、この関数を含んでいるジョブがロードされても、この関数は In-Sight 5.1.0 以降のファームウェアには存在しないので、エラーメッセージが表示されます。この関数は ReadUserDataBuffer 関数と置き換える必要があります。
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ビジョンシステムは、EtherNet/IP プロトコルを使用して同時に複数のデバイスと通信できますが、同時に複数の通信を確立することは推奨しません。
  • In-Sight ビジョンシステムは、明示的および非明示的な EtherNet/IP メッセージングをサポートしています。 Closed 例を参照。

    セル A4 の ReadEIP($A$0, "0d:4d:8s") は、2 つの 32 ビット整数とヌル終了文字列を PLC から読み取ります。

    GetBufferData($A$4, 0) は、最初の 32 ビット整数を表示します。

    GetBufferData($A$4, 1) は、2 番目の 32 ビット整数を表示します。

    GetBufferData($A$4, 2) は、文字列を表示します。

  • 詳細については、『Using EtherNet/IP with In-Sight Explorer and ControlLogix』を参照してください。

ReadEIP 関数の入力パラメータ

ReadEIP 関数(

イベント,

マッピング

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

マッピング

コロン文字 (:) で区切られた指定子のリストから構成されるデータマッピングを指定します。各指定子は、開始バイトとデータ型コードの 2 つの部分から構成されます。データ型コードは次のとおりです。

コード | データ型
i | 8 ビットの整数
il | 16 ビットの整数
d | 32 ビットの整数
f | 32 ビット浮動小数点数
s | テキスト文字列

例: データマッピング "0i:1f:5d:9s" の場合、最初のデータ項目 (オフセット 0) は 8 ビット整数を指定し、2 番目の項目 (オフセット 1) は 32 ビットの浮動小数点値を指定し、3 番目の項目 (オフセット 5) は 4 バイトの符号付き整数を指定し、パケットの残り (オフセット 9 以降) は文字列を指定します。

注: メジャーリビジョン 10 に付属の入力アセンブリインスタンス 12 を使用している場合、入力データの最大長は 488 バイトです。In-Sight メジャーリビジョン 4 に付属の入力アセンブリインスタンス 11 を使用している場合、入力データの最大長は 492 バイトです。

In-Sight アセンブリデータ構成 (非明示的メッセージング)

ReadEIP 関数の出力

戻り値 | クライアントによって送信されたデータを含む [image] データ構造体。入力パラメータが無効の場合か、クライアントからの接続が確立されていない場合は、#ERR が返されます。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

Event 関数

WriteEIP 関数

入出力関数について


ReadEIPBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

EtherNet/IP プロトコルを使用するリモートクライアントによって送信されたデータを読み取り (消費し) ます。参照される　 [image] 　構造体は FormatInputBuffer 関数によって作成されたもので、受信されたデータの認識方法を定義します。

  • ReadEIPBuffer の入力パラメータ
  • ReadEIPBuffer の出力
  • 関連項目

注:

  • In-Sight 5.1.0 以上のファームウェアを実行している In-Sight ビジョンシステムの場合、この関数を含んだジョブがロードされると、ReadUserDataBuffer 関数に自動的に置き換えられます ([プロトコル] パラメータは [デフォルト] に設定されます)。
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ビジョンシステムは、EtherNet/IP プロトコルを使用して同時に複数のデバイスと通信できますが、同時に複数の通信を確立することは推奨しません。
  • In-Sight ビジョンシステムは、明示的および非明示的な EtherNet/IP メッセージングをサポートしています。 Closed 例を参照。

    セル A4 の ReadEIP($A$0, "0d:4d:8s") は、2 つの 32 ビット整数とヌル終了文字列を PLC から読み取ります。

    GetBufferData($A$4, 0) は、最初の 32 ビット整数を表示します。

    GetBufferData($A$4, 1) は、2 番目の 32 ビット整数を表示します。

    GetBufferData($A$4, 2) は、文字列を表示します。

  • EtherNet/IP プロトコルを Rockwell ControlLogix PLC との間で使用する方法については、ここをクリックしてください。

ReadEIPBuffer 関数の入力パラメータ

ReadEIPBuffer 関数 (

イベント,

バッファ

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された、 [image] 　データ構造体への参照を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 入力データの最大長は、4,000 バイトです。In-Sight アセンブリデータ構成 (非明示的メッセージング)

ReadEIPBuffer 関数の出力

戻り値 | クライアントによって送信されたデータを含んでいる [image] データ構造体。無効な入力パラメータが含まれていた場合、またはクライアントからの接続が確立されていない場合は #ERR が返されます。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

  • Event 関数
  • WriteEIPBuffer 関数
  • ReadUserDataBuffer 関数
  • ReadEIP 関数
  • WriteEIP 関数
  • GetBufferData 関数
  • 入出力関数について


ReadLatchedUserDataBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

バッファ処理された画像取り込みを必要とするアプリケーションで使用する場合は、[ネットワークの設定] ダイアログで現在有効にされているファクトリ通信プロトコルの [User Data] フィールドに含まれるデータを読み取り (消費し)、画像取り込みトリガでデータを取得します。取得されたデータは、取り込まれた画像データとともに運ばれ、この関数を通じて、スプレッドシートに読み込まれます。参照される　 [image] 　構造体は FormatInputBuffer 関数によって作成されたもので、受信されたデータの認識方法を定義します。

  • ReadLatchedUserDataBuffer の入力パラメータ
  • ReadLatchedUserDataBuffer の出力
  • 関連項目

注: 定期的な接続で、有効にされている産業用プロトコルに基づくデータバッファへの書き込みが活発に行われていない場合、この関数は、最後にデータバッファへの書き込みを行ったプロトコルのデータを返します。

ReadLatchedUserDataBuffer 関数の入力パラメータ

ReadLatchedUserDataBuffer (

イベント,

バッファ,

プロトコル,

接続の検証,

バイト/ワードオーダ

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された、 [image] 　データ構造体への参照を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 入力データの最大長は、4,000 バイトです。

プロトコル

ユーザデータの読み取り元となるプロトコルを指定します。

0 = EtherNet/IP | EtherNet/IP が有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
1 = PROFINET | PROFINET が有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
2 = SLMP Scanner | SLMP スキャナが有効なファクトリ通信プロトコルであることを指定します。
3 = Modbus TCP Server | Modbus TCP サーバが有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェアバージョン 5.3.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。
8 = CC-Link IE Field Basic Bit | CC-Link IE Field Basic が有効なファクトリ通信プロトコルであることを指定し、RY ビット空間からユーザデータバッファを読み取ります。
9 = CC-Link IE Field Basic Word | CC-Link IE Field Basic が有効なファクトリ通信プロトコルであることを指定し、RWw ワードスペースからユーザデータバッファを読み取ります。
100 = 任意 (デフォルト) | 現在有効なファクトリ通信プロトコルが使用されるよう指定します ([ネットワーク設定] ダイアログから有効にします)。複数のプロトコルが有効になっている場合は、最初に有効になったプトロコルが使用されます。

接続の検証

この関数で接続の検証を行うかどうかを指定します。有効にされている場合、選択されたプロトコルでアクティブな周期接続が行われていないと、#ERR が返されます。

EtherNet/IP の場合、前回の再起動の後、非明示的な接続が確立されていない場合は、#ERR が返されることはありません。 非明示的なメッセージが使用されない場合は、#ERR が返されることなく、センサで明示的にデータを受信することができます。

バイト/ワードオーダ

関数によって読み込まれるワードとバイトのビット順序を指定します。

注: このパラメータは、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

0 = ビッグエンディアン (= Modbus のデフォルト)

最上位バイトが最初に格納され、以降のバイトが降順に格納されるように指定します。

1 = リトルエンディアン

最下位バイトが最初に格納され、以降のバイトが昇順に格納されるように指定します。

2 = ビッグエンディアン (ワード変換使用)

ビッグエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

3 = リトルエンディアン (ワード変換使用)

リトルエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

100 = デフォルト (選択解除された場合)

次のデフォルト設定が使用されます。

EtherNet/IP | リトルエンディアン
PROFINET | ビッグエンディアン
SLMP プロトコルスキャナ | リトルエンディアン
Modbus TCP サーバ | ビッグエンディアン
CC-Link IE フィールド Basic | リトルエンディアン

例

AB (1 ワードサイズの値): A = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | AB
リトルエンディアン | BA
ビッグエンディアン (ワード変換使用) | AB
リトルエンディアン (ワード変換使用) | BA

12AB (2 ワードサイズの値): 1 = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | 12 | AB
リトルエンディアン | BA | 21
ビッグエンディアン (ワード変換使用) | AB | 12
リトルエンディアン (ワード変換使用) | 21 | BA

ReadLatchedUserDataBuffer 関数の出力

戻り値 | クライアントによって送信されたデータを含む [image] データ構造体。不正な入力パラメータが含まれていた場合、クライアントからの接続が確立されていない場合、または接続の確立後、データバッファへの書き込みが行われていない場合には #ERR が返されます。
結果 | データ構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

  • 入出力関数について
  • Event 関数
  • ReadUserDataBuffer 関数
  • WriteResultsBuffer 関数
Version: 5.6.0


ReadMC 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

ReadMC 関数は、三菱電機 PLC およびモーションコントローラ (MC) への SLMP 接続を生成し、3E QnA 互換または 1E A 互換バイナリフレームを使用して Batch Read コマンドを送信し、PLC/MC からデータを受信します。

注: In-Sight ビジョンシステムが SLMP プロトコル経由で PLC/MC と通信するように設定されている場合、SLMP プロトコルはビジョンシステムと PLC/MC との間のデータ転送のみをサポートします。

ReadMC 関数(

イベント,

ホスト名,

ポート,

PLC シリーズ,

デバイスのアドレス,

タイムアウト,

バッファ

)

ReadMC 関数の入力パラメータ

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

ホスト名

データを読み取る三菱電機 PLC/MC の IP アドレスを指定します。

ポート

MELSEC EtherNet モジュール上で開く SLMP サーバの TCP ポート番号を 16 進数で指定します。

PLC シリーズ

データパケットがカプセル化されるメッセージフレームを指定します。

In-Sight ファームウェアバージョン 5.4.0 以降

0 = iQ-R/Q/L シリーズ (3E フレーム) | QnA 互換 3E フレームを使用して Batch Read コマンドを送信します。
1 = FX シリーズ (1E フレーム) | A 互換 1E フレームを使用して Batch Read コマンドを送信します。
2 = iQ-F シリーズ (3E フレーム) | QnA 互換 3E フレームを使用して Batch Read コマンドを送信します。

In-Sight ファームウェアバージョン 4.10.4 以降

0 = iQ-F/R/Q/L シリーズ (3E フレーム) | QnA 互換 3E フレームを使用して Batch Read コマンドを送信します。
1 = FX シリーズ (1E フレーム) | A 互換 1E フレームを使用して Batch Read コマンドを送信します。

デバイスのアドレス

三菱電機 PLC/MC のデータを読み取るメモリ位置を指定します。使用可能なデバイスアドレスとフォーマットは、PLC シリーズの入力に指定された PLC シリーズの種類 (iQ-F/R/Q/L シリーズまたは　FX シリーズ) によって異なります。

3E フレーム (iQ-R/Q/L シリーズ、iQ-F シリーズ、または iQ-F/R/Q/L シリーズ)

注: ZR (ファイルレジスタ) デバイスタイプは、iQ-F シリーズではサポートされていません。

デバイスのアドレス | 説明 | フォーマット
Xhhhhhh* | 入力リレー | ビット
Yhhhhhh | 出力リレー | ビット
Mdddddd* | 内部リレー | ビット
Ldddddd | ラッチリレー | ビット
Fdddddd | アナンシエータ | ビット
Bhhhhhh | リンクリレー | ビット
Ddddddd | データレジスタ | ワード
Whhhhhh | リンクレジスタ | ワード
Rdddddd | ファイルブロックレジスタ | ワード
ZRhhhhhh | ファイルレジスタ | ワード
TNdddddd | タイマ値 | ワード
CNdddddd | カウンタ値 | ワード
* 「hhhhhh」は 16 進数アドレス、「dddddd」は 10 進数アドレスです。

1E フレーム (FX シリーズ)

デバイスのアドレス | 説明 | フォーマット
Xoooooo* | 入力リレー | ビット
Yoooooo | 出力リレー | ビット
Mdddddd* | 内部リレー | ビット
Ddddddd | データレジスタ | ワード
Rdddddd | 拡張レジスタ | ワード
Sdddddd | 状態リレー | ビット
* 「oooooo」は 8 進数アドレス、「dddddd」は 10 進数アドレスです。

Timeout

この関数がデータ送信を試行する時間をミリ秒単位で指定します (5 ～ 30000、デフォルト = 1000 ms)。指定された時間が経過すると、実行は停止し、#ERR が返されます。

注: [タイムアウト] の時間がジョブに追加される可能性があります。読み取りおよび書き込みの両方の操作が失敗した場合、両方の操作の [タイムアウト] 値が加算されるため、ジョブに追加される時間は [タイムアウト] 値の 2 倍になります。

バッファ

FormatInputBuffer 関数によって作成された、参照される　 [image] 　構造体を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 選択された PLC シリーズが iQ-R/Q/L シリーズ、iQ-F シリーズ、または iQ-F/R/Q/L シリーズである場合、入力データの総最大長は 1920 バイトです。選択された PLC シリーズが FX シリーズである場合、入力データの総最大長は 128 バイトです。

ReadMC 関数の出力

戻り値 | 三菱電機 PLC/MC によって送信されたデータを含むデータ構造体。無効な入力パラメータが含まれていた場合、または三菱電機 PLC/MC からの接続が確立されていない場合は #ERR が返されます。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

Event 関数

WriteMC 関数

GetBufferData 関数

入出力関数について

Version: 5.6.0


ReadModbusBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

Modbus プロトコルを利用するリモートクライアントによって送信されたデータを読み取り (消費し) ます。参照される　 [image] 　構造体は FormatInputBuffer 関数によって作成されたもので、受信されたデータの認識方法を定義します。In-Sight ビジョンシステムに書き込みを行うリモートクライアントは、レジスタ 50000 ～ 50127 を使用する必要があります。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • さまざまな In-Sight ファームウェアバージョンで使用可能な Modbus TCP 実装については、「Modbus TCP Communications」を参照してください。

ReadModbusBuffer 関数の入力パラメータ

ReadModbusBuffer 関数(

イベント,

バッファ

バイト/ワードオーダ

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された、 [image] 　データ構造体への参照を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 入力データの最大長は、4,000 バイトです。

バイト/ワードオーダ

関数によって読み込まれるワードおよびバイトのビット順序を指定します。使用可能な値は次のとおりです。

  • ビッグエンディアン - 最上位の値が最初に格納されるように指定します。
  • リトルエンディアン - 最下位の値が最初に格納されるように指定します。
  • 16 ビットワードを含むビッグエンディアン - 最上位の値が最初に格納されるように指定します。
  • 16 ビットワードを含むビッグエンディアン - 最下位の値が最初に格納されるように指定します。

ReadModbusBuffer 関数の出力

戻り値 | クライアントによって送信されたデータを含んでいる [image] データ構造体。無効な入力パラメータが含まれていた場合、またはクライアントからの接続が確立されていない場合は #ERR が返されます。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

  • Event 関数
  • WriteModbusBuffer 関数
  • GetBufferData 関数
  • 入出力関数について


ReadProfinetBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

PROFINET プロトコルを利用するリモートクライアントによって送信されたデータを読み取り (消費し) ます。参照される　 [image] 　構造体は FormatInputBuffer 関数によって作成されたもので、受信されたデータの認識方法を定義します。

注:
  • In-Sight 5.1.0 以上のファームウェアを実行している In-Sight ビジョンシステムの場合、この関数を含んだジョブがロードされると、ReadUserDataBuffer 関数に自動的に置き換えられます ([プロトコル] パラメータは [デフォルト] に設定されます)。
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

ReadProfinetBuffer の入力パラメータ

ReadProfinetBuffer (

イベント,

バッファ

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された、 [image] 　データ構造体への参照を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 入力データの最大長は、4,000 バイトです。

ReadProfinetBuffer の出力

戻り値 | クライアントによって送信されたデータを含んでいる [image] データ構造体。無効な入力パラメータが含まれていた場合、またはクライアントからの接続が確立されていない場合は #ERR が返されます。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

  • Event 関数
  • 入出力関数について


ReadResult 関数

ReadResult 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

ある In-Sight センサ (送信側) のセルから別のセンサ (受信側) へ値をインポートします。いくつかの ReadResult 関数を使用して、複数の In-Sight スレーブセンサから、受信センサ上の単一のスプレッドシートに結果をインポートします。

ReadResult 関数 (

画像取り込み,

ホスト名,

タイムアウト

)

注:

  • 送信および受信 In-Sight センサはオンラインである必要があります。
  • WriteResult および ReadResult 関数の使用時には、ReadResult 関数を使用している In-Sight センサをネットワークトリガマスタとして構成し、WriteResult 関数を使用しているセンサをネットワークトリガスレーブとして構成することを強く推奨します。これによって結果を同期させることができるので、現在のトリガに反応してスレーブによって生成された結果をマスタが読み取ります。

ReadResult 関数の入力パラメータ

画像取り込み

セル A0 のデフォルトの [image] データ構造体への参照であり、画像取り込みトリガのソースを指定します。

ホスト名

結果を送信する In-Sight センサのネットワーク名を指定します。In-Sight の送信側には、受信側に送信する値を含んでいるセルを参照する、WriteResult 関数が含まれている必要があります。

注:

  • In-Sight の「受信側」センサのスプレッドシートに複数の ReadResult 関数が含まれている場合、各関数は「異なる」In-Sight の送信側のホスト名を参照する必要があります。つまり、受信側センサ 1 台のみが、送信側センサの WriteResult セルからデータを読み取ることができます。
  • 無効なホスト名を指定した場合、最大 30 秒後に接続はタイムアウトします。

タイムアウト

In-Sight の送信側センサが、In-Sight の受信側に結果を書き出すために待機する時間 (取り込み時間を含む) のミリ秒数(0 ～ 120000、0 はタイムアウトしません)。

ReadResult 関数の出力

戻り値 | 指定した In-Sight の送信側からインポートされた値を含んでいる [image] データ構造体。入力パラメータのいずれかが無効である場合、ネットワークエラーがある場合、または指定した [タイムアウト] 時間内に結果が受信されなかった場合は、#ERR が返されます。
結果 | ReadResult 関数が最初にセルに挿入されると、In-Sight の送信側センサからインポートされた最初の 4 つの結果を含んでいるテーブルが、自動的にスプレッドシートに作成されます。

スプレッドシートに自動挿入されて結果テーブルを作成する関数は次のとおりです。

GetResult(結果, インデックス)

データ構造体からインデックス付きの値を返します。この値は、In-Sight の送信側の WriteResult 関数でのセル参照の順番に従って、インデックスが付けられます。

注意: ReadResult 関数は、In-Sight の送信側からインポートされ、 [image] データ構造体に含まれている最初の 4 つの結果に対応する、結果テーブル内の 4 つのエントリを自動的に返します。このテーブルを拡張して、追加の結果を返すことができます。そのためには、テーブルからセルをコピーして空のセルに張り付け、追加の各結果のインデックス値を増分して返します。

ReadResult 関数の例

2 台の In-Sight センサ、送信側と受信側がネットワークに接続されていると仮定します。各センサのジョブを次のように設定します。

送信側:

A0 = AcquireImage(32,1,8,0,480,0,0,0,0,128,32,0,0,"","",0)

A1 = '画像取り込みの数:

A2 = '画像取り込みの数 × 2:

A3 = Timer("00:00:05",32)

A4 = WriteResult($A$0,$D$1,$D$2)

D1 = Count($A$0,9999999,0,0)

D2 = D1*2

AcquireImage セル (A0) はトリガ用に設定されています。セル A3 内の Timer 関数は、5 秒ごとに手動トリガを開始します。セル D1 には Count 関数が含まれており、画像取り込みの数を蓄積しますが、D2 は画像取り込みの数を 2 倍にします。最後に、セル A4 内の WriteResult 関数は、取り込みデータを受信側センサで使用できるようにします。

受信側:

A0 = AcquireImage(1,1,8,0,480,0,0,0,0,128,32,0,0,"","",0)

A1 = '画像取り込みの数:

A2 = '画像取り込みの数 × 2:

A4 = ReadResult($A$0,"Sender",0)

B4 = GetResult($A$4,0)

C4 = GetResult($A$4,1)

D1 = GetResult($A$4,0)

D2 = GetResult($A$4,1)

D4 = GetResult($A$4,2)

E4 = GetResult($A$4,3)

AcquireImage セル (A0) は連続的トリガ用に設定されています。セル A4 内の ReadResult 関数は、送信側の WriteResult 関数からデータを引き出します。情報が読み込まれている残りのセル (B4、C4、D1、D2、D4、E4) には GetResult 関数が含まれており、セル A4 内の [image] 構造体のゼロベースのインデックス指定を示しています。

両方のセンサをオンラインにすることで、ReadResult および WriteResult 関数が実行に移されていることを確認することができます。

20 秒後に、4 つの画像取り込みが発生しています。受信側センサは、送信側の値と同期したままになっています。送信側の WriteResult 関数は 2 つの値を渡しているだけなので、受信側のセル D4 および E4 は #ERR を返します。

関連項目

WriteResult 関数

入出力関数について


ReadUserDataBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

[ネットワークの設定] ダイアログで現在有効にされているファクトリ通信プロトコルの [User Data] フィールドに含まれるデータを読み取ります (消費します)。参照される　 [image] 　構造体は FormatInputBuffer 関数によって作成されたもので、受信されたデータの認識方法を定義します。

  • ReadUserDataBuffer の入力パラメータ
  • ReadUserDataBuffer の出力
  • 関連項目

注: 定期的な接続で、有効にされている産業用プロトコルに基づくデータバッファへの書き込みが活発に行われていない場合、この関数は、最後にデータバッファへの書き込みを行ったプロトコルのデータを返します。

ReadUserDataBuffer 関数の入力パラメータ

ReadUserDataBuffer (

イベント ,

バッファ ,

プロトコル ,

接続の検証,

バイト/ワードオーダ

)

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • Event 関数を含んでいるセル
  • Button 関数を含んでいるセル

バッファ

FormatInputBuffer 関数によって作成された、 [image] 　データ構造体への参照を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 入力データの最大長は、4,000 バイトです。

プロトコル

ユーザデータの読み取り元となるプロトコルを指定します。

注:
  • In-Sight 4.9.3 以前のファームウェアを搭載する In-Sight ビジョンシステムで、産業用イーサネットプロトコルが指定されていない場合は、デフォルトで Modbus TCP サーバプロトコルが使用されます。
  • モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

0 = EtherNet/IP | EtherNet/IP が有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。
1 = PROFINET | PROFINET が有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。
2 = SLMP スキャナ | SLMP スキャナが有効なファクトリ通信プロトコルであることを指定します。
3 = Modbus TCP サーバ | Modbus TCP サーバが有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェアバージョン 5.3.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。
8 = CC-Link IE Field Basic Bit | CC-Link IE Field Basic が有効なファクトリ通信プロトコルであることを指定し、RY ビット空間からユーザデータバッファを読み取ります。
9 = CC-Link IE Field Basic Word | CC-Link IE Field Basic が有効なファクトリ通信プロトコルであることを指定し、RWw ワードスペースからユーザデータバッファを読み取ります。
100 = デフォルト | 現在有効なファクトリ通信プロトコルが使用されるよう指定します ([ネットワーク設定] ダイアログから有効にします)。複数のプロトコルが有効になっている場合は、最初に有効になったプトロコルが使用されます。

接続の検証

この関数で接続の検証を行うかどうかを指定します。有効にされている場合、選択されたプロトコルでアクティブな周期接続が行われていないと、#ERR が返されます。

EtherNet/IP の場合、前回の再起動の後、非明示的な接続が確立されていない場合は、#ERR が返されることはありません。 非明示的なメッセージが使用されない場合は、#ERR が返されることなく、センサで明示的にデータを受信することができます。

バイト/ワードオーダ

関数によって読み込まれるワードとバイトのビット順序を指定します。

注: このパラメータは、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

0 = ビッグエンディアン (= Modbus のデフォルト)

最上位バイトが最初に格納され、以降のバイトが降順に格納されるように指定します。

1 = リトルエンディアン

最下位バイトが最初に格納され、以降のバイトが昇順に格納されるように指定します。

2 = ビッグエンディアン (ワード変換使用)

ビッグエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

3 = リトルエンディアン (ワード変換使用)

リトルエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

100 = デフォルト (選択解除された場合)

次のデフォルト設定が使用されます。

EtherNet/IP | リトルエンディアン
PROFINET | ビッグエンディアン
SLMP プロトコルスキャナ | リトルエンディアン
Modbus TCP サーバ | ビッグエンディアン
CC-Link IE フィールド Basic | リトルエンディアン

例

AB (1 ワードサイズの値): A = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | AB
リトルエンディアン | BA
ビッグエンディアン (ワード変換使用) | AB
リトルエンディアン (ワード変換使用) | BA

12AB (2 ワードサイズの値): 1 = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | 12 | AB
リトルエンディアン | BA | 21
ビッグエンディアン (ワード変換使用) | AB | 12
リトルエンディアン (ワード変換使用) | 21 | BA

ReadUserDataBuffer 関数の出力

戻り値 | クライアントによって送信されたデータを含む [image] データ構造体。不正な入力パラメータが含まれていた場合、クライアントからの接続が確立されていない場合、または接続の確立後、データバッファへの書き込みが行われていない場合には #ERR が返されます。
結果 | データ構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

  • 入出力関数について
  • Event 関数
  • ReadLatchedUserDataBuffer 関数
  • WriteResultsBuffer 関数


TCPDevice 関数

TCPDevice 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

In-Sight スプレッドシートのセルを TCP/IP デバイス (クライアントまたはサーバ) として定義します。この関数を定義すると、In-Sight ビジョンシステムとほかの TCP/IP デバイスとの接続が可能になり、ネットワークを介してデータを共有することができます。TCP/IP の接続が確立すると、ReadDevice 関数、WriteDevice 関数、および QueryDevice 関数を使用してデータを通信します。TCPDevice 関数が、ネットワークのほかの TCP/IP デバイスと通信を開始する場合、セルは TCP/IP クライアントとして動作します。TCPDevice 関数が、ネットワークにあるほかの TCP/IP デバイスからの受信を待機する場合は、セルは TCP/IP サーバとして動作します。

  • TCPDevice の入力パラメータ
  • TCPDevice の出力
  • TCPDevice 関数の例

注:

  • TCPDevice 関数は パケットを受信すると、イベントを発生させます。このイベントによって、スプレッドシートが更新されます。
  • 2 つの In-Sight ビジョンシステム間で TCP/IP デバイス接続を確立するには、両方のデバイスをオンラインにする必要があります。

TCPDevice 関数の入力パラメータ

TCPDevice 関数(

ホスト名,

ポート,

プロトコル,

パケット・タイプ,

タイムアウト,

終端記号

)

ホスト名

TCPDevice 関数が含まれているセルをクライアントにする場合は、接続を確立する TCP/IP サーバの名前を指定します。

注:

  • [ホスト名] ドロップダウンには、In-Sight ビジョンシステムのホスト名やネットワーク上のエミュレータは表示されません。ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。
  • ホスト名を指定しない場合 (デフォルトでは空文字)、セルは TCP/IP クライアントからの通信開始を待機するサーバになります。

ポート

TCP/IP デバイスとの間で接続を確立する TCP/IP サーバのポート番号です。ホスト名が指定された場合、入力されたポート番号はサーバ側にも割り当てる必要があります。ホスト名が指定されない (空文字の) 場合、このパラメータでこのデバイスに TCP/IP ポート番号が割り当てられます。

1 つのホストで、2 つの TCPDevice 関数が同じ TCP/IP ポート番号を共有することはできません。この場合、一方のデバイスは TCP/IP 接続を確立することができなくなります。例えば、同じ In-Sight スプレッドシートの 2 つのセルに TCPDevice 関数がデフォルトのポート番号として 3000 を指定した場合、どちらかのセルの 1 つのみが TCP/IP デバイスとして機能します。ポート番号の割り当ての重複を避けることは重要です。

注: 有効なポート番号は、In-Sight の通信に使用されるポートを除く、1 ～ 65535 の範囲で未使用の番号です。PC のサービスで予約されているポート番号との競合を避けるために、In-Sight エミュレータの設定では、必ず 3000 (デフォルト) 以降のポート番号を割り当ててください。

プロトコル

ネットワーク上の In-Sight ビジョンシステムとほかの TCP/IP デバイスとの間の通信に使用するネットワークプロトコルです。In-Sight ビジョンシステムでは、標準の TCP/IP プロトコルのみサポートしています。

0 = TCP/IP

パケットタイプ

In-Sight ビジョンシステムとほかの TCP/IP デバイスとの間で通信する文字列のデータフォーマットを定義します。

0 = 文字列 CR+LF (デフォルト) | ASCII フォーマットです。In-Sight ビジョンシステムから送信される際、ASCII 文字 13 (キャリッジリターン) と 10 (ラインフィード) が文字列データに付加されます。受信の際には、文字列データは CR+LF で終了します。
1 = 文字列 + CR (13) | ASCII フォーマットです。In-Sight ビジョンシステムから送信される際、ASCII 文字の 13 (キャリッジリターン) が文字列データに付加されます。受信の際には、文字列データは CR で終了します。
2 = 文字列 + LF (10) | ASCII フォーマットです。In-Sight ビジョンシステムから送信される際、ASCII 文字の 10 (ラインフィード) が文字列データに付加されます。受信の際には、文字列データは LF で終了します。
3 = 文字列 + ヌル文字 (0) | ASCII フォーマットです。In-Sight ビジョンシステムから送信される際、ASCII 文字の 0 (ヌル文字) が文字列データに追加されます。受信の際には、文字列データはヌル文字で終了します。
4 = Modbus | バイナリフォーマットです。文字列データは、Modbus プロトコルに準拠します。
6 = カスタム終端記号付き文字列 | ASCII フォーマットです。In-Sight ビジョンシステムから送信される際、指定した終端記号が文字列データに追加されます。受信の際には、文字列データは指定した終端機能で終了します。
7 = カスタム終端記号を持つバイナリ | バイナリフォーマットです。In-Sight ビジョンシステムから送信される際、指定した終端記号が文字列データに追加されます。受信の際には、文字列データは指定した終端機能で終了します。

注:

  • Modbus パラメータは、In-Sight ビジョンセンサが Modbus クライアントとして稼動する場合のみ適用されます。Modbus に関しては、Open Modbus/TCP Specification（外部リンク、インターネットへのアクセスが必要です。Modicon 発行）で定義されています。また、パケットタイプが Modbus に設定されている場合、ポートは、In-Sight 通信により予約されている 502 に設定されている必要があることにも注意してください。
  • 指定されたパケットタイプに関わらず、In-Sight ビジョンシステムでデータを受信する場合、文字列データは ASCII 文字の 0 (ヌル文字) で終了します。

タイムアウト

TCP/IP 接続の確立を試みてから中断するまでの待機時間をミリ秒単位 (100～15000、デフォルト = 1000) で指定します。このパラメータは、TCPDevice 関数がセルで TCP/IP クライアントとして定義されている場合のみ適用されます。

終端記号

[パケットタイプ] に [カスタム終端記号付き文字列] または [カスタム終端記号を持つバイナリ] が指定された場合に使用する ASCII 文字 (0 ～ 255) を指定します。

TCPDevice 関数の出力

戻り値 | データ構造体。入力パラメータが無効の場合か、タイムアウトの設定時間を超えた場合は、#ERR が返されます。 注: 1 つのジョブに挿入できる [image] 構造体の数は最大 12 個です。
結果 | 関数がセルに入力されると、右側の隣接したセルに追加の関数が自動的に挿入されます。関数が TCP/IP クライアントである場合は WriteDevice 関数で、TCP/IP サーバである場合は ReadDevice 関数です。

TCPDevice 関数例

SYSTEM0 という名前の In-Sight ホストビジョンシステムが、次のように設定されています。

A3=TCPDevice("SYSTEM1",3000,0,0,300)

B3=WriteDevice($A$0,A3,C3)

SYSTEM1 という名前の 2 番目のホストシステムには、TCP/IP サーバ機能が含まれており、次のように設定されています。

A4=TCPDevice("",3000,0,0,300)

B4=ReadDevice(A4)

2 つのシステムはオンラインの状態であるとします。SYSTEM0 上のセル $A$0 のデフォルトの画像が取得されると、セル A3 の TCP/IP クライアントは、SYSTEM1 上のセル A4 の TCP/IP サーバとポート 3000 で接続を確立します。接続後、SYSTEM0 上のセル B3 の WriteDevice 関数により、セル C3 のデータが SYSTEM1 上のセル B4 の ReadDevice 関数にエクスポートされます。

関連項目

  • バイナリ関数
  • TCP/IP Modbus による通信
  • ReadDevice 関数
  • WriteDevice 関数
  • QueryDevice 関数
Version: 5.6.0


UDPDevice 関数

UDPDevice 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

In-Sight スプレッドシートのセルを UDP デバイス (クライアントまたはサーバ) として定義します。この関数を定義すると、In-Sight ビジョンシステムとほかの UDP デバイスとの接続が可能になり、ネットワークを介してデータを共有することができます。UDP の接続が確立すると、ReadDevice 関数、WriteDevice 関数、および QueryDevice 関数を使用してデータを通信します。UDPDevice 関数が、ネットワークのほかの UDP デバイスと通信を開始する場合、セルは UDP クライアントとして動作します。UDPDevice 関数が、ネットワークにあるほかの UDP デバイスからの受信を待機する場合は、セルは UDP サーバとして動作します。

TCP に代わる User Datagram Protocol (UDP) はコネクションレス型通信トランスポート方法で、インターネットプロトコル経由でのメッセージ交換の際に限定的なサービスを提供します。TCP とは異なり、UDP では配信の確認や保証は行われません。また、パケットを順番どおりに並べることもありません。

UDPDevice 関数 (

ホスト名,

ポート,

タイムアウト,

バイナリーパケット

)

注:

  • UDPDevice 関数は パケットを受信すると、イベントを発生させます。このイベントによって、スプレッドシートが更新されます。
  • 2 つの In-Sight ビジョンシステム間で UDP デバイス接続を確立するには、両方のデバイスをオンラインにする必要があります。

UDPDevice 関数の入力パラメータ

ホスト名

UDPDevice 関数が含まれているセルをクライアントにする場合は、接続を確立する UDP サーバの名前を指定します。

注:

  • [ホスト名] ドロップダウンには、In-Sight ビジョンシステムのホスト名やネットワーク上のエミュレータは表示されません。ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。
  • ホスト名を指定しない場合 (デフォルトでは空の文字列) には、セルは UDP クライアントからの通信開始を待機するサーバになります。

ポート

UDP デバイスとの間で接続を確立する UDP サーバのポート番号です。ホスト名が指定された場合、入力されたポート番号はサーバ側にも割り当てる必要があります。ホスト名が指定されない (空の文字列である) 場合、このパラメータでこのデバイスに UDP/IP ポート番号が割り当てられます。

1 つのホストで、2 つの UDPDevice 関数が同じ UDP ポート番号を共有することはできません。この場合、一方のデバイスは UDP 接続を確立することができなくなります。例えば、1 つの In-Sight スプレッドシートの 2 つのセルにデフォルトのポート番号として「3000」を使用する UDPDevice 関数が入力されている場合、どちらか 1 つのセルのみが UDP デバイスとして機能します。ポート番号の割り当ての重複を避けることは重要です。

注: 有効なポート番号は、In-Sight の通信に使用されるポートを除く、1 ～ 65535 の範囲で未使用の番号です。PC のサービスで予約されているポート番号との競合を避けるために、In-Sight エミュレータの設定では、必ず 3000 (デフォルト) 以降のポート番号を割り当ててください。

タイムアウト

UDP 接続の確立を試みてから中断するまでの待機時間をミリ秒単位 (100 ～ 15000、デフォルト = 1000) で指定します。このパラメータは、UDPDevice 関数がセルで UDP クライアントとして定義されている場合のみ適用されます。
バイナリーパケット データをバイナリデータパケット、または文字列情報のどちらとして処理するかを指定します。デフォルトでは、このオプションは無効にされており、データは文字列情報として処理されます。

UDPDevice 関数の出力

戻り値 | データ構造体。入力パラメータが無効の場合か、タイムアウトの設定時間を超えた場合は、#ERR が返されます。 注: 1 つのジョブに挿入できる [image] 構造体の数は最大 12 個です。
結果 | 関数がセルに入力されると、右側の隣接したセルに追加の関数が自動的に挿入されます。関数が UDP クライアントである場合は WriteDevice 関数で、UDP サーバである場合は ReadDevice 関数です。

UDPDevice 関数例

以下の例は、次のように設定されている場合、UDPDevice 関数をどのように使用するのかを示します。応答を必要としない UDP クライアント、応答が必要な UDP クライアント、メッセージのみ受信する UDP サーバ、メッセージを受信して応答する UDP サーバ

応答を必要としない UDP クライアント

この設定では、UDP メッセージを UDP サーバデバイスに送信するように In-Sight ビジョンシステムを設定します。

設定

ジョブに UDPDevice 関数が追加され、この関数に対して有効な [ホスト名] および [ポート] パラメータが設定されます。UDPDevice 関数がクライアントとして動作することが決定されると、このジョブに WriteDevice 関数が自動的に追加されます。この WriteDevice 関数は有効な [イベント] パラメータを適用することによって設定されます。[デバイス] パラメータには、UDPDevice 関数によって出力される [image] データ構造体が設定されます (これは WriteDevice 関数がジョブに追加されたときに自動的に設定されます)。また、有効なバイナリデータパケットまたは文字列情報を出力するセルが参照されます。

実行

ビジョンシステムがオンラインである場合、WriteDevice 関数が有効なイベントを受信するたびに、UDP メッセージが送信されます。サーバからの応答は必要ないため、[タイムアウト] パラメータは必要ありません。

応答を必要とする UDP クライアント

この構成では、UDP メッセージを UDP サーバデバイスに送信し、[タイムアウト] パラメータに設定された期限が切れるまで、サーバデバイスからの応答を待機するように In-Sight ビジョンシステムを設定します。

設定

ジョブに UDPDevice 関数が追加され、この関数に対して有効な [ホスト名] および [ポート] パラメータが設定されます。次に、[タイムアウト] パラメータに適切なタイムアウト値を設定し、自動的に追加された WriteDevice 関数を設定します。それらの関数の設定後、QueryDevice 関数を追加し、その Event 関数を適切なイベントに設定し、[デバイス] パラメータを UDPDevice 関数と送信される適切なデータへの参照によって出力される [image] データ構造体に設定します。ジョブに UDPDevice 関数が追加され、この関数に対して有効な [ホスト名] および [ポート] パラメータが設定されます。UDPDevice 関数がクライアントとして動作することが決定されると、このジョブに WriteDevice 関数が自動的に追加されます。この WriteDevice 関数は有効な [イベント] パラメータを適用することによって設定されます。[デバイス] パラメータには、UDPDevice 関数によって出力される [image] データ構造体、および送信される適切なデータへの参照が設定されます。

実行

ビジョンシステムがオンラインである場合、QueryDevice 関数の [イベント] パラメータがトリガされるたびに UDP メッセージが送信されます。サーバからの応答を待っている間、このジョブのそのほかの関数が実行されます。サーバから応答が来ない場合、または [タイムアウト] パラメータの期間を過ぎてから応答を受信した場合はエラーが返されます。このエラーは、次のイベントによって新たな UDP メッセージの送信がトリガされたときにクリアされます。

メッセージを受信するだけの UDP サーバ

この構成では、UDP クライアントデバイスから UDP メッセージを受信するように In-Sight ビジョンシステムを設定します。

設定

ジョブに UDPDevice 関数が追加されます。[ホスト名] パラメータは空のままですが、[ポート] パラメータには有効な値が設定されます。UDPDevice 関数がサーバとして動作することが決定されると、このジョブに ReadDevice 関数が自動的に追加されます。この ReadDevice 関数は有効な [イベント] パラメータを適用することによって設定されます。[デバイス] パラメータには、UDPDevice 関数によって出力される [image] データ構造体が設定されます (これは ReadDevice 関数がジョブに追加されたときに自動的に設定されます)。

実行

ビジョンシステムがオンラインの場合、これはスプレッドシートのバックグラウンドで実行され、メッセージの送信を待機する UDP サーバとして動作します。メッセージを受信したサーバはスプレッドシートをトリガして ReadDevice 関数を実行し、着信データをこの関数に代入します。このメッセージはビジョンシステムの IP アドレスに直接送信することができ、またはネットワーク上にある複数のビジョンシステムにブロードキャストメッセージとして送信することもできます。

メッセージを受信し応答する UDP サーバ

この構成では、UDP クライアントデバイスから UDP メッセージを受信し、メッセージが正常に受信されたことを示す応答を送信するように In-Sight ビジョンシステムを設定します。

設定

2 つの UDPDevice 関数がジョブに追加されます。1 つめの UDPDevice 関数はサーバとして設定されます ([ホスト名] パラメータは空のままですが、[ポート] パラメータには有効な値が設定されます)。2 つめの UDPDevice 関数はクライアントとして設定されます。着信パケットのリモートアドレスの取得には、GetRemoteAddress 関数が使用されます。また、パケットを発行したリモートポートの取得には GetRemotePort 関数が使用されます。

実行

サーバの着信メッセージおよび発信メッセージの処理には、2 つの UDPDevice 関数が使用されます。メッセージを受信すると、このメッセージを実行し、処理するために、スプレッドシートがトリガされます。ジョブが応答を作成した場合、このイベントによって、応答パケットを送信するための WriteDevice 関数もトリガされます。着信パケットには IP アドレスとポート番号が含まれています。これらは、WriteDevice 関数によって、応答パケットの送信に使用されます。このメッセージはビジョンシステムの IP アドレスに直接送信することができ、またはネットワーク上にある複数のビジョンシステムにブロードキャストメッセージとして送信することもできます。

関連項目

バイナリ関数

ReadDevice 関数

WriteDevice 関数

QueryDevice 関数


WriteCCLinkBitBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatOutputBuffer 関数によって生成された、参照される [image] 構造体からのデータを、イベントのトリガ時に、CC-Link プロトコルを使用している CC-Link ネットワークに書き込みます。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • この機能を有効にするには、In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されている必要があります。
  • In-Sight ビジョンシステムが CC-Link 経由で三菱電機 Automation Controller と通信するように設定されている場合、プロトコルはビジョンシステムと Automation Controller との間のデータ転送のみをサポートします。

WriteCCLinkBitBuffer 関数の入力パラメータ

WriteCCLinkBitBuffer 関数 (

イベント,

バッファ

)

イベント

指定した [image] 構造体を書き込むイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

バッファ

FormatOutputBuffer 関数によって作成される [image] 構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、256 バイトです。

WriteCCLinkBitBuffer 関数の出力

戻り値

書き込んだ要素の数を返します。次の場合には #ERR を返します。

  • 入力パラメータが無効な場合。
  • In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されていない場合。
  • FormatOutputBuffer 関数の項目が、[ビット] または [16 ビット整数] 以外のデータ型の場合。

関連項目

  • 入出力関数について
  • CC-Link 経由での三菱電機 Automation Controller との通信
  • ReadCCLinkBitBuffer 関数
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkWordBuffer 関数


WriteCCLinkWordBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatOutputBuffer 関数によって生成された、参照される [image] 構造体からのデータを、イベントのトリガ時に、CC-Link プロトコルを使用している CC-Link ネットワークに書き込みます。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • この機能を有効にするには、In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されている必要があります。
  • In-Sight ビジョンシステムが CC-Link 経由で三菱電機 Automation Controller と通信するように設定されている場合、プロトコルはビジョンシステムと Automation Controller との間のデータ転送のみをサポートします。

WriteCCLinkWordBuffer 関数の入力パラメータ

WriteCCLinkWordBuffer 関数 (

イベント,

バッファ

)

イベント

指定した [image] データ構造体を書き込むイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

バッファ

FormatOutputBuffer 関数によって作成される [image] 構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、256 バイトです。

WriteCCLinkWordBuffer 関数の出力

戻り値

書き込んだ要素の数を返します。次の場合には #ERR を返します。

  • 入力パラメータが無効な場合。
  • In-Sight ビジョンシステムが In-Sight CIO-MICRO-CC I/O モジュールに接続されていない場合。

関連項目

  • 入出力関数について
  • CC-Link 経由での三菱電機 Automation Controller との通信
  • ReadCCLinkBitBuffer 関数
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkBitBuffer 関数


WriteDevice 関数

WriteDevice 関数 |
入出力関数 → ネットワーク | In-Sight 関数リファレンス

In-Sight ビジョンシステムから、TCP/IP または UDP 接続を使用して、ネットワーク上のほかのホストへデータをエクスポートします。

注: 2 つの In-Sight ビジョンシステム間で TCP/IP 接続を確立するには、両方のデバイスをオンラインにする必要があります。

WriteDevice 関数の入力パラメータ

WriteDevice 関数(

イベント,

デバイス,

データ 1,

[データ 2,

...]

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値を含むセル (ゼロ以外の数値は強制的に更新を実行します)。

デバイス

TCPDevice 関数または UDPDevice 関数で作成された [image] データ構造体を含んでいるスプレッドシートのセルを参照します。

データ 1, 2, ...

TCPDevice 関数で指定された TCP/IP サーバデバイスへエクスポートするデータを含むセルを参照します。TCPDevice 関数のデータのパケットタイプは、ASCII またはバイナリです。

WriteDevice 関数の出力

戻り値

指定したイベントが起動したときに、エクスポートされるデータを含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注:
  • フルの状態の TCP/IP バッファへの書き込み操作を行っている間に、参照している TCPDevice　関数で指定したタイムアウト時間を超過した場合は、#ERR が返されます。
  • UPD 通信はコネクションレスなので、UDP 通信を設定する際には、タイムアウト時間は必要ありません。

関連項目

  • バイナリ関数
  • Event 関数
  • ReadDevice 関数
  • QueryDevice 関数
  • TCPDevice 関数
  • UDPDevice 関数


WriteEIP 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

EtherNet/IP プロトコルを使用するリモートクライアントデバイスにデータを書き込みます。データは 1 つの RPI: パケット要求間隔 RPI内でクライアントデバイスに送信されます。RPI 間隔は、クライアントデバイスによって設定されます。

注:

  • In-Sight 5.1.0 以上のファームウェアを実行している In-Sight ビジョンシステムの場合、この関数を含んだジョブがロードされると、エラーメッセージが表示されます。この関数が In-Sight 5.1.0 以上のファームウェアにはないためです。この関数は WriteResultsBuffer 関数に置き換える必要があります。
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ビジョンシステムでは、EtherNet/IP プロトコルを使用して同時に複数のデバイスと通信できますが、暗黙的な双方向接続は一度に 1 つしか行えません。
  • In-Sight ビジョンシステムは、サーバとしてのみ使用できます。In-Sight センサがほかのデバイスへの接続を開始することはありません。アセンブリデータ構成は、クライアントデバイスで指定する必要があります。
  • スプレッドシートには複数の WriteEIP 関数を挿入しないでください。WriteEIP 関数が複数あると、フラッシュメモリバッファへの送信待ちデータが上書きされることがあります。
  • RPI 間隔が 10 ミリ秒未満の場合、一部のビジョンツールのパフォーマンスに影響する可能性があります。
  • In-Sight ビジョンシステムは、明示的および非明示的な EtherNet/IP メッセージングをサポートしています。 Closed 例を参照してください。

    セル A4 の ReadEIP($A$0, "0d:4d:8s") は、2 つの 32 ビット整数とヌル終了文字列を PLC から読み取ります。

    GetBufferData($A$4, 0) は、最初の 32 ビット整数を表示します。

    GetBufferData($A$4, 1) は、2 番目の 32 ビット整数を表示します。

    GetBufferData($A$4, 2) は、文字列を表示します。

  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • 詳細については、『Using EtherNet/IP with In-Sight Explorer and SLC 5/05』を参照してください。

WriteEIP 関数の入力パラメータ

WriteEIP 関数 (

イベント,

マップ仕様,

値 1,

[値 2,

...]

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

マップ仕様

コロン文字で区切られた指定子のリストから構成されるデータマッピングを指定します。各指定子は、開始バイトとデータ型コードの 2 つの部分から構成されます。サポートされている文字コードは、次のとおりです。

コード | データ型
i | 8 ビットの整数
il | 16 ビットの整数
d | 32 ビットの整数
f | 32 ビット浮動小数点数
s | テキスト文字列

例: "0i:1f:5d:9s" の場合、最初のデータ項目 (オフセット 0) は 8 ビット整数を指定し、2 番目の項目 (オフセット 1) は 32 ビットの浮動小数点値を指定し、3 番目の項目 (オフセット 5) は 4 バイトの符号付き整数を指定し、パケットの残り (オフセット 9 以降) は文字列を指定します。

注: 出力データの最大長は、492 バイトです。

値

MapSpec (値1, 値2, ...) と一致する値の可変長リストを指定します。

WriteEIP 関数の出力

戻り値

書き込まれたエレメントの数。入力パラメータが無効の場合、またはクライアントへの接続が確立されていない場合は、#ERR を返します。

関連項目

  • ReadEIP 関数
  • 入出力関数について


WriteEIPBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatOutputBuffer 関数によって作成された参照先の [image] 構造体から、EtherNet/IP プロトコルを使ってリモートクライアントデバイスにデータを書き込みます。データは 1 つのRPI: パケット要求間隔 RPI 内でクライアントに送信されます。RPI 間隔は、クライアントデバイスによって設定されます。

注:

  • In-Sight 5.1.0 以上のファームウェアを実行している In-Sight ビジョンシステムの場合、この関数を含んだジョブがロードされると、WriteResultsBuffer 関数に自動的に置き換えられます ([プロトコル] パラメータは [デフォルト] に設定されます)。
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ビジョンシステムでは、EtherNet/IP プロトコルを使用して同時に複数のデバイスと通信できますが、明示的な双方向接続は一度に 1 つしか行えません。
  • In-Sight ビジョンシステムは、サーバとしてのみ使用できます。In-Sight センサがほかのデバイスへの接続を開始することはありません。アセンブリデータ構成は、クライアントデバイスで指定する必要があります。
  • スプレッドシートには複数の WriteEIPBuffer 関数を挿入しないでください。WriteEIPBuffer 関数が複数あると、フラッシュメモリバッファへの送信待ちデータが上書きされることがあります。
  • RPI 間隔が 10 ミリ秒未満の場合、一部のビジョンツールのパフォーマンスに影響する可能性があります。
  • In-Sight ビジョンシステムは、明示的および非明示的な EtherNet/IP メッセージングをサポートしています。 Closed 例を参照してください。

    セル A4 の ReadEIP($A$0, "0d:4d:8s") は、2 つの 32 ビット整数とヌル終了文字列を PLC から読み取ります。

    GetBufferData($A$4, 0) は、最初の 32 ビット整数を表示します。

    GetBufferData($A$4, 1) は、2 番目の 32 ビット整数を表示します。

    GetBufferData($A$4, 2) は、文字列を表示します。

  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • 詳細については、『Using EtherNet/IP with In-Sight Explorer and ControlLogix』を参照してください。

WriteEIPBuffer 関数の入力パラメータ

WriteEIPBuffer 関数 (

イベント,

バッファ

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

バッファ

FormatOutputBuffer 関数によって作成される [image] 構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、4,000 バイトです。

WriteEIPBuffer 関数の出力

戻り値

書き込まれたエレメントの数。入力パラメータが無効の場合、またはクライアントへの接続が確立されていない場合は、#ERR を返します。

関連項目

  • ReadEIPBuffer 関数
  • ReadEIP 関数
  • WriteEIP 関数
  • 入出力関数について


WriteFTP 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

データファイルのファイルへの書き出し、または追記を行います。この関数は通常、データ結果のログ作成に使用されます。このログはファイルで参照できます。

  • WriteFTP の入力パラメータ
  • WriteFTP の出力
  • WriteFTP 関数の例
  • 関連項目

注:

  • WriteFTP 関数を使用するには、In-Sight ビジョンシステムをオンラインにする必要があります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21　含む) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。

  • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます (C:\ProgramData\Cognex\In-Sight\Emulators\x.x.x)。このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます (FTP ルートディレクトリ)。エミュレータディレクトリおよび FTP ルートディレクトリの詳細については、[オプション] ダイアログのトピック (エミュレーションパネル) を参照してください。

WriteFTP 関数の入力パラメータ

WriteFTP 関数 (

イベント,

ホスト名,

ユーザ名,

パスワード,

ファイル名,

データフォーマット,

文字列,

追記

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

ホスト名

ファイルの出力先になるネットワーク上のホスト名 (または IP アドレス) を指定します。出力先のシステムとしては、ネットワーク上の In-Sight エミュレータまたは FTP サーバとして認識されるデバイスがあります。

注:[ホスト名] ドロップダウンには、In-Sight ビジョンシステムのホスト名やネットワーク上のエミュレータは表示されません。ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

ユーザ名

出力先ホストの FTP サーバ用の有効なユーザ名です。このユーザ名は、ファイル出力元の In-Sight ビジョンシステムに登録されている必要はありません。

パスワード

出力先ホストの FTP サーバ用の有効なパスワードです。パスワードは最大 15 文字で、大文字と小文字の区別があります。

注:

  • セキュリティの目的から、入力されたパスワードは WriteFTP 関数のプロパティシートや数式バー内では、"*" の表示でマスクされます。
  • パスワードはジョブファイルでは暗号化されたフォーマットで保存されます。

ファイル名

ファイルの名前です。ロングファイル名がサポートされています。パスが指定されていない場合は、ファイルは出力先ホストにある FTP サーバのデフォルトディレクトリに出力されます。FTP サーバ上にそのファイルが存在しない場合は、WriteFTP 関数の初回実行時に自動的に作成されます。デフォルトのファイル名は InSight です。

注: ファイルを FTP ルートディレクトリに書き込む場合、ファイル名 は [オプション] ダイアログで指定した [FTP ルートディレクトリ] と完全に一致しなければなりません。ファイルも、FTP ルートディレクトリ内の任意のサブディレクトリに書き込むことができます (サブディレクトリはあらかじめ存在している必要があります)。

例えば、FTP ルートディレクトリが C:\temp で、ファイル名が「InSight」の場合は、ファイル名を「C:\temp\InSight」と指定する必要があります。「Jobs」サブディレクトリに書き込む場合、ファイル名は「C:\temp\Jobs\InSight」となります。「InSight」とのみ指定した場合、ファイルはデフォルトのエミュレータディレクトリに書き込まれます。

データフォーマット

ファイルのタイプです。各タイプに応じた拡張子が、自動的にファイル名に付加されます。

0 = テキスト | 標準 ASCII フォーマットのテキストファイル (.txt)。
1 = HTML (デフォルト) | 標準 HTML フォーマットのファイル (.htm)。
4 = XML | 標準 XML フォーマットのファイル (.xml)。
5 = CSV | 標準 CSV フォーマットのファイル (.csv)。

文字列

文字列または文字列を含むセルへの参照。255 文字まで入力できます。

注:

  • [データフォーマット] パラメータに HTML を指定した場合、テキスト文字列内で HTML タグを使用する必要があります。
  • 文字列を変更すると、書き込みや追記が行われます。

追記

データをファイルに出力する方法を指定します。

0 = OFF | ファイル内の既存のデータを上書きします。
1 = ON (デフォルト) | ファイルの最後にテキスト文字列を追記します。

WriteFTP 関数の出力

戻り値

データ構造体を返します。スプレッドシートが更新されるたびに、[文字列] パラメータに含まれているデータ文字列が出力先システムのファイルに出力されます。

出力先ホスト名、ユーザ名、パスワードなどの入力パラメータが無効な場合、またはファイルキューが満杯の場合、#ERR を返します。

注:

  • 出力データがキューに入れられると、その後、出力先ホストへの転送が失敗した場合でも #ERR は返されません。
  • WriteImageFTP 関数により生成されたネットワークエラー (無効なホスト名、ユーザ名、またはパスワード) を検出するには、スプレッドシートに独立した Event 関数を挿入し、トリガパラメータに「ネットワークエラー」を指定します。これにより、これらのエラーは、この Event 関数を参照した GetErrorString 関数、および GetErrorCode 関数で報告されます。別のネットワークエラーが報告されるまで、最後のエラーメッセージとエラーコードが保存され、返されます。

[データフォーマット] で HTML を指定した WriteFTP 関数をスプレッドシートに配置すると、次の情報が挿入されます。

Stringf 関数 | 「C」ライブラリの標準フォーマット文字列で構成されたテキスト文字列を返します。Stringf 関数のフォーマットは、指定されているファイルフォーマットによって異なります。
テキスト文字列 | このセルには、" Test string." というテキスト文字列が含まれます。
GetFilename 関数 | 右隣の WriteImageFTP 関数から出力される画像ファイルの名前を表示します。デフォルトでは、画像ファイルの名前は WriteFTP 関数のプロパティシートに入力したファイル名と同じ名前になり、数値カウンタが追記されます。
データ構造体 | WriteImageFTP 関数が配置され、 [image] データ構造体を返します。WriteImageFTP 関数のプロパティシートの上から 5 つ目までのパラメータ値は、元の WriteFTP パラメータと同じものが使用されます。 注: WriteFTP 関数のプロパティシートに後から変更を加えても、WriteImageFTP 関数のプロパティシートの内容は更新されません。

[データフォーマット] でテキストを指定した場合は、Stringf 関数だけがスプレッドシートに挿入されます。

WriteFTP 関数例

注: 例 1 では、WriteFTP 関数のプロパティシートで編集されたパラメータは、[ホスト名]、[ユーザ名]、および [パスワード] の 3 つだけです。例 2 では、[ホスト名]、[ユーザ名]、[パスワード]、および [データフォーマット] の 4 つのパラメータが編集されています。例 3 では、例 1 と同じパラメータが使用されていますが、自動的にスプレッドシートに挿入された関数が編集され、さらにほかの関数が追加されています。

WriteFTP の例 1:

A2 = WriteFTP($A$0,"FACTORYFLOOR-1","admin","*","InSight",1,B2,1)

B2 = Stringf("<LI><A HREF=%c%s%c>%s</A></LI>\r\n",34,D2,34,C2)

C2 = ' Test string.

D2 = GetFilename(E2)

E2 = WriteImageFTP($A$0,"FACTORYFLOOR-1","admin","*", $A$0,"InSight",999,0,0,0)

画像を取り込んだ後にスプレッドシートが更新されると、上記の式によって、セル C2 に含まれているテキスト文字列が、ホスト名 FACTORYFLOOR-1 のシステムにある InSight.htm ファイルの最後に追記されます。ユーザ名 admin とそのパスワードが FACTORYFLOOR-1 に登録されている必要があります。登録されていない場合は、スプレッドシートに #ERR が返されます。HTML ファイル内には、画像ファイル InSightxxx.bmp へのハイパーリンクが生成され、セル C2 に含まれている " Test string." というテキスト文字列が挿入されます。WriteImageFTP の [リセット] パラメータの値が OFF になっているため、1 番目のファイル名は InSight000.bmp、2 番目のファイル名は InSight001.bmp というように連続して出力されます。

Closed 例 1 のスプレッドシート表示例

WriteFTP の例 2:

A2 = WriteFTP($A$0,"FACTORYFLOOR-1","admin","*","InSight",0,B2,1)

B2 = Stringf("Test string.¥r¥n")

画像を取り込んだ後にスプレッドシートが更新されると、上記の式によって、セル C2 に含まれているテキスト文字列が、ホスト名 FACTORYFLOOR-1 のシステムにある InSight.txt ファイルの最後に追記されます。ユーザ名 admin とそのパスワードが FACTORYFLOOR-1 に登録されている必要があります。登録されていない場合は、スプレッドシートに #ERR が返されます。テキストファイル内には、" Test string." というテキスト文字列が挿入されます。

Closed 例 2 のスプレッドシート表示例

WriteFTP の例 3:

A2 = WriteFTP($A$0,"FACTORYFLOOR-1","admin","*","InSight",1,B2,1)

B2 = Stringf("<LI>%s</LI><BR>\r\n<IMG SRC=%c%s%c><BR><BR>\r\n",C2,34,D2,34)

C2 = Concatenate("Failure #",F2,".")

D2 = GetFilename(E2)

E2 = WriteImageFTP($A$0,"FACTORYFLOOR-1","admin","*", $A$0,"InSight",999,G2,0,0)

F2 = Count($A$0,999,G2,-1)

G2 = Button("Reset Counter", -1)

画像を取り込んだ後にスプレッドシートが更新されると、上記の式によって、セル C2 に含まれているテキスト文字列が、ホスト名 FACTORYFLOOR-1 のシステムにある InSight.htm ファイルの最後に追記されます。ユーザ名 admin とそのパスワードが FACTORYFLOOR-1 に登録されている必要があります。登録されていない場合は、スプレッドシートに #ERR が返されます。HTML ファイル内には、各画像に箇条書きの見出しが付けられて画像が表示されます。1 番目の見出しは "Failure #0."、2 番目の見出しは "Failure #1." というように連続して表示されます。WriteImageFTP の [リセット] パラメータの値が OFF になっているため、1　番目の画像ファイル名は InSight000.bmp、2 番目のファイル名は InSight001.bmp というように連続して出力されます。

Closed 例 3 のスプレッドシート表示例

Closed 出力された HTML ファイルの Internet Explorer での表示例

関連項目

  • WriteImageFTP 関数
  • 入出力関数について


WriteImageFTP 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

取り込み中の画像をネットワークの FTP サーバに出力します。画像ファイルとして、画像上にグラフィックスオーバレイを含めた SVG ファイルを作成することもできます。一般的には、検査に失敗した画像を自動保存するために使用します。

  • WriteImageFTP の入力パラメータ
  • WriteImageFTP の出力
  • WriteImageFTP 関数の例
  • 関連項目

注:

  • この関数では、画像ファイルと SVG ファイルを送信するために In-Sight ビジョンシステムがオンラインである必要があります。
  • In-Sight ビジョンシステムにリモートでログオンしている場合、関数を使用すると、画像取り込みごとに画面の画像が更新されないことがあります。
  • 関数を含む、メモリを多く使用するジョブが繰り返し実行されると、FTP コマンド「Get image.jpg」 (または .bmp) は失敗する場合があります。これは、ビジョンシステムのメモリが断片化されすぎるためです。ジョブの実行は正常に継続されます。
  • ビジョンシステムをオンラインにしているときに AcquireImage パラメータを変更すると、関数によって現在の画像が送信されます。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21　含む) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。
  • 保存された画像のデフォルト位置をエミュレータフォルダとして保持し、ディレクトリに 250 以上の画像ファイルの保存を許可する場合、ビジョンシステムはファームウェアの更新を実行することができなくなります。ディレクトリから画像ファイルを削除して、ファームウェアの更新機能を回復させます。

  • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます (C:\ProgramData\Cognex\In-Sight\Emulators\x.x.x)。このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます (FTP ルートディレクトリ)。エミュレータディレクトリおよび FTP ルートディレクトリの詳細については、[オプション] ダイアログのトピック (エミュレーションパネル) を参照してください。

WriteImageFTP 関数の入力パラメータ

WriteImageFTP 関数(

イベント,

ホスト名,

ユーザ名,

パスワード,

画像,

ファイル名,

最大追記値,

リセット,

データフォーマット,

グラフィックスオーバーレイの保存,

解像度,

Disable FTP Queuing

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル

注:デフォルトのイベント参照が削除された場合、この値はチェックボックスで置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

ホスト名

画像ファイルの出力先になるネットワーク上のホスト名 (または IP アドレス) を指定します。出力先のデバイスとしては、ネットワーク上の In-Sight エミュレータまたは FTP サーバとして動作するホストがあります。

注:
  • ホスト名を In-Sight エミュレータに設定すると、ファイルは C:\ProgramData\Cognex\In-Sight\Emulators\5.x.x に保存されます。
  • [ホスト名] ドロップダウンには、In-Sight ビジョンシステムのホスト名やネットワーク上のエミュレータは表示されません。ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。
  • 無効なホスト名を指定した場合、最大 30 秒後に接続はタイムアウトします。
  • 画像を FTP サーバに書き込むとき、[ホスト名] および [ユーザ名] に指定する名前の前後には、スペースを使用することはできません。[ホスト名] および [ユーザ名] パラメータに指定した名前の前後にスペースが含まれる場合、指定したサーバへの画像の書き込みに失敗します。

ユーザ名

出力先ホストの FTP サーバ用の有効なユーザ名です。このユーザ名は、画像ファイル出力元の In-Sight ビジョンシステムに登録されている必要はありません。

パスワード

出力先ホストの FTP サーバ用の有効なパスワードです。パスワードは最大 15 文字で、大文字と小文字の区別があります。

注:

  • セキュリティの目的から、入力されたパスワードはプロパティシートや数式バー内では、"*" の表示でマスクされます。
  • パスワードはジョブファイルでは暗号化されたフォーマットで保存されます。

画像

データ構造体を含むセルへの参照です。デフォルトの参照先は、セル A0 の [image] データ構造体です。

ファイル名

書き込む画像ファイルの名前です。[グラフィックスオーバレイ] パラメータが有効な場合は、SVG ファイルの名前も定義します。ロングファイル名がサポートされ、各ファイルが出力される時、それぞれのファイル名に数値カウンタが付加されます (数値カウンタの最大値は、[最大追記値] で指定します)。パスが指定されていない場合は、画像ファイルは出力先ホストにある FTP サーバのデフォルトディレクトリに出力されます。

注:ファイルを FTP ルートディレクトリに書き込む場合、ファイル名は [オプション] ダイアログで指定した [FTP ルートディレクトリ] と完全に一致しなければなりません。画像ファイルも、FTP ルートディレクトリ内の任意のサブディレクトリに書き込むことができます (サブディレクトリはあらかじめ存在している必要があります)。例えば、FTP ルートディレクトリが C:\temp で、ファイル名が「Failed」の場合は、ファイル名を「C:\temp\Failed」と指定する必要があります。「Images」サブディレクトリに書き込む場合、ファイル名は「C:\temp\Images\Failed」となります。「Failed」とのみ指定した場合、ファイルはデフォルトのエミュレータディレクトリに書き込まれます。

最大追記値

指定されたファイル名で出力する画像ファイルの最大数 (0 ～ 9999999、デフォルト = 999)。数値カウンタは指定されたファイル名の後ろに付加され、各画像ファイルが転送されるごとにカウンタは 1 つ増加します。カウンタが最大追記値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

数値カウンタの桁数は、最大追記値の桁数と等しくなります。例えば、最大追記値のデフォルト値 999 の場合は、ファイル名に 3 桁の数値が付加されます。0 が指定された場合は、ファイル名にカウンタは付加されません。

リセット

画像ファイルと SVG ファイルの両方に指定したファイル名に付加された数値カウンタを再開します。出力先のシステムに既にある画像ファイルと SVG ファイルは、同じ名前の新しいファイルで上書きされます。

0 = OFF (デフォルト) | 最大追記値まで、各画像ファイルが転送されるごとにカウンタを 1 つ増加します。
1 = ON | カウンタを 0 にリセットします。

データフォーマット

送信先のホストに書き出される画像のファイルフォーマットです。

0 = BMP (デフォルト) | Windows ビットマップフォーマット (拡張子は .bmp です)。
1 = JPEG | 標準エンコード JPEG フォーマット (拡張子は .jpg です)。

グラフィックスオーバーレイの保存

In-Sight ビジョンツール、幾何計測関数および画面表示関数でサポートされているオーバレイグラフィックスデータを含めた SVG ファイルを、各関数の [表示] パラメータでグラフィックスを表示するように設定された場合に、作成するかどうかを指定します。オーバレイグラフィックスは [セルのフォーマット] ダイアログで指定したフォーマットを使用します。SVG ファイルと画像ファイルを表示するには SVG ファイルタイプをサポートする Web ブラウザ (Microsoft Internet Explorer 9.0 など) で SVG ファイルを開きます。SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注:

  • 有効にすると、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • グラフィックスは Web ブラウザなどのサードパーティ製のアプリケーションによって表示されるため、オーバーレイグラフィックスデータは、ピクセル単位での正確な一致にはなりません。
  • In-Sight ファームウェアでは、SVG と画像ファイルの各ペアの転送を保証していません。In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。
  • In-Sight ファームウェア 5.6.0 以上を使用していて、関数の Host Name が In-Sight エミュレータに設定されている場合、svg ファイルはエミュレータのディレクトリ (C:\ProgramData\Cognex\In-Sight\Emulators\5.x.x) に保存され、[In-Sight のファイル] ペインに表示されます。In-Sight ファームウェア 5.5.x 以前を使用していて、関数の Host Name が In-Sight エミュレータに設定されている場合、svg ファイルはエミュレータのディレクトリに保存されますが、[In-Sight のファイル] ペインには表示されません。

0 = OFF (デフォルト) | 画像のみ転送されるように指定します。
1 = ON | 画像ファイルと SVG ファイルが転送されるように指定します。有効にすると、グラフィックスオーバーレイデータを含む SVG ファイルは画像に指定されたディレクトリに保存されます。Microsoft Internet Explorer 9.0 以降などの Web ブラウザを使用して、グラフィックスオーバーレイと画像を一緒に表示します。
解像度

画像がエクスポートされるときの画像解像度を指定します。

1 = フル (デフォルト) | 画像はフル解像度でエクスポートされます。
2 = ハーフ | 画像は半分の解像度でエクスポートされます。
3 = クォーター | 画像は 1/4 の解像度でエクスポートされます。
FTP キューを無効にする

FTP 転送の前に画像をキューに入れるかどうかを指定します。

0 = キュー (デフォルト) | この機能が有効な場合は、画像を破棄する前に、最大 1,000 回まで、5 ミリ秒ごとに FTP タスクキューへの画像の追加が試行されます。
1 = キューの無効化 | キューが無効化されている場合、一度に FTP タスクキューに追加されるのは、関数の各インスタンスからの画像 1 つのみです。それ以外の場合、画像は破棄され、FTP タスクキューへ再送信されません。

WriteImageFTP 関数の出力

戻り値

データ構造体を返します。スプレッドシートが更新されるたびに、指定された [image] データ構造体に含まれている画像データが出力先システムのファイルに出力されます。

出力先ホスト名、ユーザ名、パスワードなどの入力パラメータが無効な場合、または画像画像キューには、一度に 1 つの画像を含めることができます。WriteImageFTP を実行し、前の画像が送信される前に画像の送信を試みると、関数はエラーを返します。 キューが満杯の場合、#ERR を返します。★削除★

注:

  • 画像データがキューに入れられると、その後、出力先ホストへの転送が失敗した場合でも #ERR は返されません。
  • 関数により生成されたネットワークエラー (無効なホスト名、ユーザ名、またはパスワード) を検出するには、スプレッドシートに独立した Event 関数を挿入し、トリガパラメータに「ネットワークエラー」を指定します。これにより、これらのエラーは、この Event 関数を参照した GetErrorString 関数、および GetErrorCode 関数で報告されます。別のネットワークエラーが報告されるまで、最後のエラーメッセージとエラーコードが保存され、返されます。

WriteImageFTP 関数例

WriteImageFTP($A$0,"SYSTEM1","admin","*",$A$0,"\IMAGES\TEST",999,0,0,0,1,0)

画像を取り込んだ後にスプレッドシートが更新されると、上記の式によって、ネットワークにあるホスト名が SYSTEM1 の IMAGES ディレクトリにビットマップ画像が転送されます。ユーザ名が admin で、そのパスワードと IMAGES ディレクトリが SYSTEM1 に存在する必要があります。存在しない場合、スプレッドシートに #ERR が返されます。最初に転送されたファイルは、TEST000.BMP、2 番目が TEST001.BMP というように連続して出力されます。

注:検査で不合格となった画像のみを保存する方法としては、関数にセル状態を設定する手法が一般的です。

関連項目

  • WriteImageFTP 関数の設定
  • WriteFTP 関数
  • 入出力関数について


WriteImageSFTP 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

SSH プロトコルを使用して通信し、現在の画像をネットワークの SFTP サーバに書き込みます。画像ファイルとして、画像上にグラフィックスオーバレイを含めた SVG ファイルを作成することもできます。一般的には、検査に失敗した画像を自動保存するために使用します。

  • WriteImageSFTP の入力パラメータ
  • WriteImageSFTP の出力
  • WriteImageSFTP 関数の例
  • 関連項目
注:
  • この関数は、別の In-Sight ビジョンシステムまたはエミュレータへの画像転送には使用できません。ビジョンシステムは、SFTP ネットワーク上のクライアントとしてのみ動作します。
  • この関数では、画像ファイルと SVG ファイルを送信するために In-Sight ビジョンシステムがオンラインである必要があります。
  • In-Sight ビジョンシステムにリモートでログオンしている場合、関数を使用すると、画像取り込みごとに画面の画像が更新されないことがあります。
  • 関数を含む、メモリを多く使用するジョブが繰り返し実行されると、FTP コマンド「Get image.jpg」 (または .bmp) は失敗する場合があります。これは、ビジョンシステムのメモリが断片化されすぎるためです。ジョブの実行は正常に継続されます。
  • ビジョンシステムをオンラインにしているときに AcquireImage パラメータを変更すると、関数によって現在の画像が送信されます。
  • この関数を含むジョブを In-Sight Explorer 4.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 4.3.0 以上とのみ互換性を持ちます。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21　含む) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。

  • エミュレータフォルダは、C:\ProgramData\Cognex\In-Sight\Emulators\x.x.x に内にあります (Windows 7/Windows 10)。詳細については、「[オプション] ダイアログ (エミュレーションパネル)」のトピックを参照してください。

  • 保存された画像のデフォルト位置をエミュレータフォルダとして保持し、ディレクトリに 250 以上の画像ファイルの保存を許可する場合、ビジョンシステムはファームウェアの更新を実行することができなくなります。ディレクトリから画像ファイルを削除して、ファームウェアの更新機能を回復させます。

WriteImageSFTP 関数の入力パラメータ

WriteImageSFTP 関数(

イベント,

ホスト名,

ユーザ名,

パスワード,

画像,

ファイル名,

最大追記値,

リセット,

データフォーマット,

グラフィックスオーバーレイの保存,

解像度,

SFTP キューを無効にする

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル

注:デフォルトのイベント参照が削除された場合、この値はチェックボックスで置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

ホスト名

画像ファイルの出力先になるネットワーク上のホスト名 (または IP アドレス) を指定します。出力先のデバイスとしては、ネットワーク上の In-Sight エミュレータまたは FTP サーバとして動作するホストがあります。In-Sight ビジョンシステムは、SFTP ネットワーク上のクライアントとしてのみ動作します。WriteImageSFTP 関数は、別の In-Sight ビジョンシステムまたはエミュレータへの画像転送には使用できません。

注:

  • 無効なホスト名を指定した場合、最大 30 秒後に接続はタイムアウトします。
  • 画像を FTP サーバに書き込むとき、[ホスト名] および [ユーザ名] に指定する名前の前後には、スペースを使用することはできません。[ホスト名] および [ユーザ名] パラメータに指定した名前の前後にスペースが含まれる場合、指定したサーバへの画像の書き込みに失敗します。

ユーザ名

出力先ホストの SFTP サーバ用の有効なユーザ名です。このユーザ名は、画像ファイル出力元の In-Sight ビジョンシステムに登録されている必要はありません。

パスワード

出力先ホストの SFTP サーバ用の有効なパスワードです。パスワードは最大 15 文字で、大文字と小文字の区別があります。

注:

  • セキュリティの目的から、入力されたパスワードはプロパティシートや数式バー内では、"*" の表示でマスクされます。
  • パスワードはジョブファイルでは暗号化されたフォーマットで保存されます。

画像

データ構造体を含むセルへの参照です。デフォルトの参照先は、セル A0 の [image] データ構造体です。

ファイル名

書き込む画像ファイルの名前です。[グラフィックスオーバレイ] パラメータが有効な場合は、SVG ファイルの名前も定義します。ロングファイル名がサポートされ、各ファイルが出力される時、それぞれのファイル名に数値カウンタが付加されます (数値カウンタの最大値は、[最大追記値] で指定します)。パスが指定されていない場合は、画像ファイルは出力先ホストにある FTP サーバのデフォルトディレクトリに出力されます。

最大追記値

指定されたファイル名で出力する画像ファイルの最大数 (0 ～ 9999999、デフォルト = 999)。数値カウンタは指定されたファイル名の後ろに付加され、各画像ファイルが転送されるごとにカウンタは 1 つ増加します。カウンタが最大追記値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

数値カウンタの桁数は、最大追記値の桁数と等しくなります。例えば、最大追記値のデフォルト値 999 の場合は、ファイル名に 3 桁の数値が付加されます。0 が指定された場合は、ファイル名にカウンタは付加されません。

リセット

画像ファイルと SVG ファイルの両方に指定したファイル名に付加された数値カウンタを再開します。出力先のシステムに既にある画像ファイルと SVG ファイルは、同じ名前の新しいファイルで上書きされます。

0 = OFF (デフォルト) | 最大追記値まで、各画像ファイルが転送されるごとにカウンタを 1 つ増加します。
1 = ON | カウンタを 0 にリセットします。

データフォーマット

送信先のホストに書き出される画像のファイルフォーマットです。

0 = BMP (デフォルト) | Windows ビットマップフォーマット (拡張子は .bmp です)。
1 = JPEG | 標準エンコード JPEG フォーマット (拡張子は .jpg です)。

グラフィックスオーバーレイの保存

In-Sight ビジョンツール、幾何計測関数および画面表示関数でサポートされているオーバレイグラフィックスデータを含めた SVG ファイルを、各関数の [表示] パラメータでグラフィックスを表示するように設定された場合に、作成するかどうかを指定します。オーバレイグラフィックスは [セルのフォーマット] ダイアログで指定したフォーマットを使用します。SVG ファイルと画像ファイルを表示するには SVG ファイルタイプをサポートする Web ブラウザ (Microsoft Internet Explorer 9.0 など) で SVG ファイルを開きます。SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注:

  • 有効にすると、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • グラフィックスは Web ブラウザなどのサードパーティ製のアプリケーションによって表示されるため、オーバーレイグラフィックスデータは、ピクセル単位での正確な一致にはなりません。
  • In-Sight ファームウェアでは、SVG と画像ファイルの各ペアの転送を保証していません。In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。

0 = OFF (デフォルト) | 画像のみ転送されるように指定します。
1 = ON | 画像ファイルと SVG ファイルが転送されるように指定します。有効にすると、グラフィックスオーバーレイデータを含む SVG ファイルは画像に指定されたディレクトリに保存されます。Microsoft Internet Explorer 9.0 以降などの Web ブラウザを使用して、グラフィックスオーバーレイと画像を一緒に表示します。
解像度

画像がエクスポートされるときの画像解像度を指定します。

1 = フル (デフォルト) | 画像はフル解像度でエクスポートされます。
2 = ハーフ | 画像は半分の解像度でエクスポートされます。
3 = クォーター | 画像は 1/4 の解像度でエクスポートされます。
SFTP キューを無効にする

FTP 転送の前に画像をキューに入れるかどうかを指定します。

0 = キュー (デフォルト) | この機能が有効な場合は、画像を破棄する前に、最大 1,000 回まで、5 ミリ秒ごとに FTP タスクキューへの画像の追加が試行されます。
1 = キューの無効化 | キューが無効化されている場合、一度に FTP タスクキューに追加されるのは、関数の各インスタンスからの画像 1 つのみです。それ以外の場合、画像は破棄され、FTP タスクキューへ再送信されません。

WriteImageSFTP 関数の出力

戻り値

データ構造体を返します。スプレッドシートが更新されるたびに、指定された [image] データ構造体に含まれている画像データが出力先システムのファイルに出力されます。

出力先ホスト名、ユーザ名、パスワードなどの入力パラメータが無効な場合、または画像画像キューには、一度に 1 つの画像を含めることができます。WriteImageFTP を実行し、前の画像が送信される前に画像の送信を試みると、関数はエラーを返します。 キューが満杯の場合、#ERR を返します。★削除★

注:

  • 画像データがキューに入れられると、その後、出力先ホストへの転送が失敗した場合でも #ERR は返されません。
  • 関数により生成されたネットワークエラー (無効なホスト名、ユーザ名、またはパスワード) を検出するには、スプレッドシートに独立した Event 関数を挿入し、トリガパラメータに「ネットワークエラー」を指定します。これにより、これらのエラーは、この Event 関数を参照した GetErrorString 関数、および GetErrorCode 関数で報告されます。別のネットワークエラーが報告されるまで、最後のエラーメッセージとエラーコードが保存され、返されます。

WriteImageSFTP 関数例

WriteImageSFTP($A$0,"SYSTEM1","admin","*",$A$0,"\IMAGES\TEST",999,0,0,0,1,0)

画像を取り込んだ後にスプレッドシートが更新されると、上記の式によって、ネットワークにあるホスト名が SYSTEM1 の IMAGES ディレクトリにビットマップ画像が転送されます。ユーザ名が admin で、そのパスワードと IMAGES ディレクトリが SYSTEM1 に存在する必要があります。存在しない場合、スプレッドシートに #ERR が返されます。最初に転送されたファイルは、TEST000.BMP、2 番目が TEST001.BMP というように連続して出力されます。

注:検査で不合格となった画像のみを保存する方法としては、関数にセル状態を設定する手法が一般的です。

関連項目

  • WriteImageFTP 関数の設定
  • WriteFTP 関数
  • 入出力関数について
Version: 5.6.0


WriteMC 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

WriteMC 関数は、三菱電機 PLC およびモーションコントローラへの SLMP 接続を生成し、3E QnA 互換または 1E A 互換バイナリフレームを使用して Batch Write コマンドを送信し、PLC/MC へデータを書き込みます。

注: In-Sight ビジョンシステムが SLMP プロトコル経由で PLC/MC と通信するように設定されている場合、SLMP プロトコルはビジョンシステムと PLC/MC との間のデータ転送のみをサポートします。

WriteMC 関数(

イベント,

ホスト名,

ポート,

PLC シリーズ,

デバイスのアドレス,

タイムアウト,

バッファ

)

WriteMC 関数の入力パラメータ

イベント

データを読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル

ホスト名

データを書き込む三菱電機 PLC/MC の IP アドレスを指定します。

ポート

MELSEC イーサネットモジュール上で開く SLMP サーバのポート番号を指定します。

PLC シリーズ

データパケットがカプセル化されるメッセージフレームを指定します。

In-Sight ファームウェアバージョン 5.4.0 以上

0 = iQ-R/Q/L シリーズ (3E フレーム) | QnA 互換 3E フレームを使用して Batch Read コマンドを送信します。
1 = FX シリーズ (1E フレーム) | A 互換 1E フレームを使用して Batch Read コマンドを送信します。
2 = iQ-F シリーズ (3E フレーム) | QnA 互換 3E フレームを使用して Batch Read コマンドを送信します。

In-Sight ファームウェアバージョン 4.10.4 以上

0 = iQ-F/R/Q/L シリーズ (3E フレーム) | QnA 互換 3E フレームを使用して Batch Read コマンドを送信します。
1 = FX シリーズ (1E フレーム) | A 互換 1E フレームを使用して Batch Read コマンドを送信します。

デバイスのアドレス

データを書き込む三菱電機 PLC のメモリ位置を指定します。

タイムアウト

この関数がデータ送信を試行する時間をミリ秒単位で指定します (5 ～ 30000、デフォルト = 1000 ms)。指定された時間が経過すると、実行は停止し、#ERR が返されます。

バッファ

FormatOutputBuffer 関数によって生成された、参照される [image] 構造体を指定します。この構造体は受信されたデータの解釈方法を定義します。

注: 選択された PLC シリーズが iQ-R/Q/L シリーズ、iQ-F シリーズ、または iQ-F/R/Q/L シリーズである場合、入力データの総最大長は 1920 バイトです。選択された PLC シリーズが FX シリーズである場合、入力データの総最大長は 128 バイトです。

WriteMC 関数の出力

戻り値

書き込まれた要素の数。入力パラメータが無効であれば #ERR を返します。

関連項目

Event 関数

ReadMC 関数

GetBufferData 関数

入出力関数について

Version: 5.6.0


WriteModbusBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatOutputBuffer 関数によって生成された、参照先の [image] 構造体からデータを書き込み、Modbus プロトコルを使用して、リモートクライアントデバイスで使用できるようにします。In-Sight ビジョンシステムから読み取っているリモートクライアントの場合、このデータにアクセスするには、レジスタ 30010 ～ 30137 から読み取る必要があります。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • 各種 In-Sight ファームウェアバージョンで使用可能な Modbus TCP 実装については、「Modbus TCP 通信」を参照してください。

WriteModbusBuffer 関数の入力パラメータ

WriteModbusBuffer 関数(

イベント,

バッファ,

バイト/ワードオーダ

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

バッファ

FormatOutputBuffer 関数によって作成される [image] 構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、4,000 バイトです。

バイト/ワードオーダ

関数によって書き込まれるワードとバイトのビット順序を指定します。使用可能な値は次のとおりです。

  • ビッグエンディアン - 最上位の値が 32 ビットワードを使って最初に格納されるように指定します。
  • リトルエンディアン - 最下位の値が 32 ビットワードを使って最初に格納されるように指定します。
  • ビッグエンディアンと 16 ビットワード - 最上位の値が最初に格納されるように指定します。
  • ビッグエンディアンと 16 ビットワード - 最下位の値が最初に格納されるように指定します。

WriteModbusBuffer 関数の出力

戻り値

書き込まれたエレメントの数。入力パラメータが無効の場合、またはクライアントへの接続が確立されていない場合は、#ERR を返します。

関連項目

  • ReadModbusBuffer 関数
  • 入出力関数について


WriteProfinetBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

FormatOutputBuffer 関数によって作成された参照元の [image] 構造体から、リモート PROFINET IO クライアントデバイスにデータを書き込みます。

注:

  • In-Sight 5.1.0 以上のファームウェアを実行している In-Sight ビジョンシステムの場合、この関数を含んだジョブがロードされると、WriteResultsBuffer 関数に自動的に置き換えられます ([プロトコル] パラメータは [デフォルト] に設定されます)。
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight ビジョンシステムは、サーバとしてのみ使用できます。In-Sight センサがほかのデバイスへの接続を開始することはありません。
  • スプレッドシートには複数の WriteProfinetBuffer 関数を挿入しないでください。WriteProfinetBuffer 関数が複数あると、フラッシュメモリバッファへの送信待ちデータが上書きされることがあります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。

WriteProfinetBuffer の入力パラメータ

WriteProfinetBuffer (

イベント,

バッファ

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

バッファ

FormatOutputBuffer 関数によって作成される [image] データ構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、4,000 バイトです。

WriteProfinetBuffer の出力

戻り値

書き込まれたエレメントの数。入力パラメータが無効の場合、またはクライアントへの接続が確立されていない場合は、#ERR を返します。

関連項目

  • 入出力関数について


WriteResult 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

ある In-Sight センサ (送信者) のスプレッドシートの値を別のデバイス (受信者) にエクスポートします。

WriteResult 関数 (

イベント,

セル 1,

[セル 2 ,

...]

)

注:

  • ジョブあたり 1 つの WriteResult 関数だけが許可されます。1 つのジョブに複数の WriteResult 関数がある場合、1 つ以外のすべての関数が #ERR を返します。
  • 受信側デバイスで値をインポートするには、そのスプレッドシートに ReadResult 関数を含める必要があります。
  • 送信側デバイスと受信側デバイスの両方がオンライン状態になっている必要があります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • WriteResult 関数と ReadResult 関数を使用する場合は、ReadResult 関数を使用する In-Sight センサをマスタ側のネットワークトリガとして、WriteResult 関数を使用するセンサをスレーブ側のネットワークトリガとして設定することを強く推奨します。このように設定すると、結果が同期されるので、現在のトリガに応えてスレーブが生成した結果をマスタ側で読み取ることができます。

WriteResult 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

セル

送信側 In-Sight センサから受信側デバイスにエクスポートする値を含んだ 1 つ以上のスプレッドシートのセルを参照します。セルの参照順序によって、受信側デバイスの [image] データ構造体にある各値のインデックス位置が決まります。

WriteResult 関数の出力

戻り値

受信側 In-Sight センサに書き込まれる値を含んだ [image] データ構造体。入力パラメータのいずれかが無効な場合、#ERR を返します。

注: フルの状態の TCP/IP バッファへの書き込み操作を行っている間に、参照している ReadResult 関数で指定したタイムアウト時間を超過した場合は、#ERR が返されます。

WriteResult 関数の例

これらの 2 つの関数がどのように連携するのかの説明については、ReadResult 関数の例を参照してください。

関連項目

ReadResult 関数


WriteResultsBuffer 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

参照元の [image] データ構造体からのデータを書き込みます。データは FormatOutputBuffer 関数によって生成され、現在有効なファクトリ通信プロトコル ([ネットワークの設定] ダイアログで有効にする) に書き込まれます。この関数は、ファクトリ通信プロトコルの [Result Code] フィールドにも書き込みます。

  • WriteResultsBuffer の入力パラメータ
  • WriteResultsBuffer の出力
  • 関連項目

注: PROFINET 通信プロトコルが有効な場合に WriteResultsBuffer 関数を使用すると、バイトがスワップされます。

WriteResultsBuffer 関数の入力パラメータ

WriteResultsBuffer (

イベント ,

バッファ ,

結果コード ,

プロトコル,

バイト/ワードオーダ

)

イベント

ファクトリプロトコルへの結果の書き込みのきっかけとなるイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体。
  • Event 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

バッファ

FormatOutputBuffer 関数によって作成される [image] 構造体への参照を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: 出力データの最大長は、4,000 バイトです。

結果コード

In-Sight ビジョンシステムによる検査の結果を接続されているデバイスに伝えるために使用できる 16 ビットの整数を指定します。

プロトコル

ユーザデータの書き込み先となるプロトコルを指定します。

注: このパラメータは、In-Sight 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

0 = EtherNet/IP | EtherNet/IP が有効なファクトリ通信プロトコルであることを指定します。
1 = PROFINET | PROFINET が有効なファクトリ通信プロトコルであることを指定します。
2 = SLMP プロトコルスキャナ | SLMP スキャナが有効なファクトリ通信プロトコルであることを指定します。
3 = Modbus TCP サーバ | Modbus TCP サーバが有効なファクトリ通信プロトコルであることを指定します。 注: このプロトコルは、In-Sight ファームウェアバージョン 5.3.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。
8 = CC-Link IE フィールド Basic Bit | CC-Link IE フィールド Basic が有効なファクトリ通信プロトコルであることを指定し、結果バッファを RX ビット領域に書き込みます。
9 = CC-Link IE フィールド Basic Word | CC-Link IE フィールド Basic が有効なファクトリ通信プロトコルであることを指定し、結果バッファを RWr ワード領域に書き込みます。
100 = 任意 (デフォルト) | 現在有効なファクトリ通信プロトコルが使用されることを指定します ([ネットワークの設定] ダイアログで有効化)。複数のプロトコルが有効にされている場合は、最初に有効にされたプロトコルが使用されます。

バイト/ワードオーダ

関数によって読み込まれるワードとバイトのビット順序を指定します。

注: このパラメータは、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

0 = ビッグエンディアン (= Modbus のデフォルト)

最上位バイトが最初に格納され、以降のバイトが降順に格納されるように指定します。

1 = リトルエンディアン

最下位バイトが最初に格納され、以降のバイトが昇順に格納されるように指定します。

2 = ビッグエンディアン (ワード変換使用)

ビッグエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

3 = リトルエンディアン (ワード変換使用)

リトルエンディアンのバイトスタイルが適用され、Double ワード型のワードペアオーダが切り替わります。(16 ビットワード)

100 = デフォルト (選択解除された場合)

次のデフォルト設定が使用されます。

EtherNet/IP | リトルエンディアン
PROFINET | ビッグエンディアン
SLMP プロトコルスキャナ | リトルエンディアン
Modbus TCP サーバ | ビッグエンディアン
CC-Link IE フィールド Basic | リトルエンディアン

例

AB (1 ワードサイズの値): A = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | AB
リトルエンディアン | BA
ビッグエンディアン (ワード変換使用) | AB
リトルエンディアン (ワード変換使用) | BA

12AB (2 ワードサイズの値): 1 = 最上位バイト、B = 最下位バイト:

 | 着順
ビッグエンディアン (= デフォルト) | 12 | AB
リトルエンディアン | BA | 21
ビッグエンディアン (ワード変換使用) | AB | 12
リトルエンディアン (ワード変換使用) | 21 | BA

WriteResultsBuffer 関数の出力

戻り値

クライアントに送信されたデータを含んだ [image] データ構造体。

注: In-Sight ファームウェア 4.x.x 以前を実行している In-Sight ビジョンシステムに接続する場合、書き込まれたエレメントの数が返されます。入力パラメータが無効な場合、またはクライアントへの接続が確立されていない場合は、#ERR が返されます。

関連項目

  • 入出力関数について
  • ReadLatchedUserDataBuffer 関数
  • ReadUserDataBuffer 関数


WriteSMTP 関数

入出力関数 → ネットワーク

In-Sight 関数リファレンス

SMTP サーバを介して電子メールメッセージを送信します。

WriteSMTP 関数 (

イベント,

SMTP メールサーバ,

To,

Cc,

From,

件名,

重要度,

画像添付,

画像名,

画像フォーマット,

スクリーンキャプチャ,

メッセージテキスト,

メッセージテキスト,

メッセージテキスト,

メッセージテキスト

)

メッセージは画像を添付して送信できます。画像ファイルとして、画像上にグラフィックスオーバレイを含めた完全なスクリーンキャプチャを作成することもできます。

警告: 画像の連続取り込みなど、高頻度でトリガするイベントにこの関数を参照させないでください。メールサーバがメッセージで過負荷になることがあります。

注:

  • WriteSMTP 関数のセル状態は、イベントまたはボタン を参照する必要があります。
  • WriteSMTP 関数を使用するには、In-Sight センサをオンラインにする必要があります。
  • WriteSMTP 関数を含んだ、メモリを多く使用するジョブが繰り返し実行されると、FTP コマンド "Get image.jpg" (または .bmp) は失敗する場合があります。これは、In-Sight メモリが断片化されすぎるためです。ジョブの実行は正常に継続されます。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。

WriteSMTP 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

SMTP メールサーバ,

SMTP サーバのホスト名または IP アドレス。

注:

  • メッセージは MIME 1.0 形式で送信されます。実際の SMTP メールサーバの名前または IP アドレスを参照する必要があります。
  • DNS メール交換 (MX) のレコードルックアップはサポートされません。実際の SMTP メールサーバの名前または IP アドレスを参照する必要があります。
  • In-Sight センサに固定 IP アドレスが割り当てられている場合、デフォルトのゲートウェイとドメインの両方を適切に設定する必要があります。適切に設定しないと、WriteSMTP が電子メールを送信できないことがあります。
  • 無効なホスト名を指定した場合、最大 30 秒後に接続はタイムアウトします。

To

メッセージ受信者の電子メールアドレス。

Cc

別の受信者の電子メールアドレス。

From

メッセージの送信者。

注: To、Cc、From の値をフォーマット「user@domain」に含める必要があり、ドメインは有効である必要があります。

件名

メッセージの件名のテキスト。

重要度

メッセージの重要度。

0 = 低

1 = 標準 (デフォルト)

2 = 高

画像添付

添付ファイルとして画像を送信します。

画像名

添付ファイルのファイル名。デフォルトは「Image」です。

画像フォーマット

送信先のホストに書き出される画像のファイル形式。

0 = BMP (デフォルト) | Windows ビットマップフォーマット (拡張子は .bmp です)。
1 = JPEG | 標準エンコード JPEG フォーマット (拡張子は .jpg です)。

スクリーンキャプチャ

リモートホストに画像を出力する際に、グラフィックスオーバレイを付けるかどうかを指定します (In-Sight 3400 のみ)。

0 (OFF) = グラフィックスオーバレイなし (デフォルト)

1 (ON) = グラフィックスオーバレイを含む

メッセージテキスト

書き出すメッセージ本文のテキスト文字列、またはテキストを含んだセルへの参照を指定します。この関数では、4 つのセルを参照できます。各セルは最大 254 文字のテキストを保持できます。

WriteSMTP 関数の出力

戻り値

スプレッドシートが更新されるたびに、電子メールのメッセージを送信する [image] データ構造体。

WriteSMTP 関数例

WriteSMTP($A$0,"mailserver@yourdomain.com.","recipient@yourdomain.com","copy@yourdomain.com","from@yourdomain.com","Message",1,0,"Image",0,0,"Image Sent", "","","")

参照元のイベントがアクティブ化された後でスプレッドシートが更新されると、その都度、SMTP メールサーバ経由で電子メールメッセージが送信されます。

Closed サンプルの WriteSMTP プロパティシートを参照してください。

関連項目

Button 関数

Event 関数

セル状態

入出力関数について


シリアル I/O 関数

入出力関数

In-Sight 関数リファレンス

シリアル I/O 関数は、In-Sight センサのシリアルポートを介して、データの読み込みと書き出しを行います。

  • ReadSerial 関数: シリアルポートからセルにテキスト文字列を読み込みます。
  • ReadDeviceNet 関数: デバイスネットインタフェースモジュールにより送信されたデータをセルに読み込みます。
  • ReadDeviceNetBuffer 関数: In-Sight センサのシリアルポートに接続されたデバイスネットインタフェースモジュールによって送信されたデータを、FormatInputBuffer 関数によって作成された、参照される [image] 構造体に読み込みます。
  • WriteDeviceNet 関数: セルから、オプションのデバイスネットワークインタフェースモジュールにデータを書き込みます。
  • WriteDeviceNetBuffer 関数: FormatOutputBuffer 関数によって作成された、参照される [image] 構造体にデータを書き込みます。このデータは、In-Sight センサのシリアルポートに接続されたデバイスネットワークインタフェースモジュールによって読み込まれます。
  • WriteSerial 関数: テキスト文字列をセルからシリアルポートに出力します。
注:
  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
Version: 5.6.0


ReadDeviceNet 関数

ReadDeviceNet 関数 |
入出力関数 → シリアル I/O | In-Sight 関数リファレンス

In-Sight のシリアルポートに接続されている (オプションの) デバイスネットインタフェースモジュールからスプレッドシートセルにデータを読み込みます。

ReadDeviceNet 関数(

イベント,

ポート,

マッピング,

互換モード

)

注:

  • 選択されたシリアルポートは、DeviceNet通信用に設定されている必要があります。また、In-Sight センサをオンラインにする必要があります。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CIO-1450 I/O モジュールを使用する場合、シリアルパケットが (終了文字を含めて) 256 バイトよりも大きいと、In-Sight センサと I/O モジュール間でシリアル通信の消失が発生する可能性があります。シリアル通信の消失が発生した場合は、両方の電源を入れ直す必要があります。

  • ReadDeviceNet 関数には、サードパーティの RS-232 デバイスネットゲートウェイアダプタが必要です。この関数は従来のインストール環境で使用できます。ただし、最新のアプリケーションで使用する場合は、RS-232 デバイスネットゲートウェイコンバータを完全にテストして、そのアプリケーションでも使用できることを確認してください。

ReadDeviceNet 関数の入力パラメータ

イベント

データを読み取る更新イベントを指定します。データを返すためには、このパラメータは、Event 関数を含んでいるセルを参照する必要があります。Event の トリガパラメータにはシリアルポート 1 を指定し、手動パラメータは OFF のままにしておく必要があります。Event 関数は、ジョブの編集ツールバーに Event(65,0) として表示されます。

ポート

データを読み込むシリアルポート (0 または 1) を指定します。選択できるポートはアクティブな In-Sight センサで使用できるポートによって異なります。

マッピング

コロン文字 (:) で区切られた指定子のリストから構成されるデータマッピングを指定します。各指定子には次の 2 つの部分があります。(1) 開始バイトと、(2) データ型コードです。さまざまなデータ型コードを、次の表に示します。

コード | データ型
i | 8 ビットの整数
u | 8 ビット符号なし整数
il | 16 ビットの整数
ul | 16 ビット符号なし整数
f | 32 ビット浮動小数点数
s | テキスト文字列

例: データマッピング "0i:1f:5u:6s"　の場合、最初のデータ項目 (オフセット 0) はゼロ以外のときに画像取り込みトリガをかける 8 ビット整数を指定し、2 番目の項目 (オフセット 1) は浮動小数点値を指定し、3 番目の項目 (オフセット 5) は 1 バイトの符号なし整数を指定し、パケットの残り (オフセット 6 以降) は文字列を指定します。

注: データの長さは [DeviceNet モードの詳細設定] に指定されているデバイスネットのブロックサイズと一致している必要があります。

互換モード

In-Sight 1000 が In-Sight 3000 と同じ順序で入力バイトストリームを解釈するかどうかを指定します。ほかのすべての In-Sight モデルでは、このパラメータは無視されます。

ReadDeviceNet 関数の出力

戻り値 | デバイスネットインタフェースモジュールからスプレッドシートに読み込まれたデータを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

Event 関数

WriteDeviceNet 関数

シリアルポートのモード

入出力関数について

Version: 5.6.0


ReadDeviceNetBuffer 関数

入出力関数 → シリアル I/O

In-Sight 関数リファレンス

In-Sight センサのシリアルポートに接続されたデバイスネットインタフェースモジュールによって送信されたデータを読み込みます。参照される　 [image] 　構造体は FormatInputBuffer 関数によって作成されたもので、受信されたデータの認識方法を定義します。

ReadDeviceNetBuffer 関数(

イベント,

ポート,

バッファ

)

注:

  • 選択されたシリアルポートは、DeviceNet　通信用に設定されている必要があります。また、In-Sight センサをオンラインにする必要があります。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • CIO-1450 I/O モジュールを使用する場合、シリアルパケットが (終了文字を含めて) 256 バイトよりも大きいと、In-Sight センサと I/O モジュール間でシリアル通信の消失が発生する可能性があります。シリアル通信の消失が発生した場合は、両方の電源を入れ直す必要があります。
  • ReadDeviceNetBuffer 関数には、サードパーティの RS-232 デバイスネットゲートウェイアダプタが必要です。この関数は従来のインストール環境で使用できます。ただし、最新のアプリケーションで使用する場合は、RS-232 デバイスネットゲートウェイコンバータを完全にテストして、そのアプリケーションでも使用できることを確認してください。

ReadDeviceNetBuffer 関数の入力パラメータ

イベント | データを読み取る更新イベントを指定します。データを返すためには、このパラメータは、Event 関数を含んでいるセルを参照する必要があります。Event の トリガパラメータにはシリアルポート 1 を指定し、手動パラメータは OFF のままにしておく必要があります。Event 関数は、ジョブの編集ツールバーに Event(65,0) として表示されます。
ポート | データを読み込むシリアルポート (0 または 1) を指定します。選択できるポートはアクティブな In-Sight センサで使用できるポートによって異なります。
バッファ | FormatInputBuffer 関数によって作成された、参照される [image] 構造体を指定します。この構造体は受信されたデータの解釈方法を定義します。 注: データの長さは [DeviceNet モードの詳細設定] に指定されているデバイスネットのブロックサイズと一致している必要があります。

ReadDeviceNetBuffer 関数の出力

戻り値 | デバイスネットインタフェースモジュールからスプレッドシートに読み込まれたデータを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | 構造体内のデータには GetBufferData 関数を使用してアクセスします。

関連項目

Event 関数

WriteDeviceNetBuffer 関数

ReadDeviceNet 関数

WriteDeviceNet 関数

GetBufferData 関数

シリアルポートのモード

入出力関数について

Version: 5.6.0


ReadSerial 関数

ReadSerial 関数 |
入出力関数 → シリアル I/O | In-Sight 関数リファレンス

指定されたシリアルポートからセルにテキスト文字列を読み込みます。

  • ReadSerial の入力パラメータ
  • ReadSerial の出力
  • 関連項目

注:

  • 選択されたシリアルポートは、Text モードに設定されている必要があります。また、In-Sight ビジョンシステムをオンラインにする必要があります。
  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。
  • CIO-1450 I/O モジュールを使用する場合、シリアルパケットが (終了文字を含めて) 256 バイトよりも大きいと、In-Sight ビジョンシステムと I/O モジュール間でシリアル通信の消失が発生する可能性があります。シリアル通信の消失が発生した場合は、両方の電源を入れ直す必要があります。

ReadSerial 関数の入力パラメータ

ReadSerial 関数(

イベント,

ポート

)

イベント | データを読み取る更新イベントを指定します。データを返すためには、このパラメータは、Event 関数を含んでいるセルを参照する必要があります。Event の トリガパラメータにはシリアルポート 1 を指定し、手動パラメータは OFF のままにしておく必要があります。Event 関数は、ジョブの編集ツールバーに Event(65,0) として表示されます。
ポート | 読み込むシリアルポートを指定します。In-Sight ビジョンシステムは 1 しか指定できません。In-Sight エミュレータは 0 または 1 を指定できます。

ReadSerial 関数の出力

戻り値

読み込むテキスト文字列を含んでいる [image] データ構造体。入力パラメータが無効な場合は #ERR を返します。

関連項目

  • Event 関数
  • WriteSerial 関数
  • [シリアルポートの設定] ダイアログ
  • 入出力関数
Version: 5.6.0


WriteDeviceNet 関数

入出力関数 → シリアル I/O

In-Sight 関数リファレンス

セルから、In-Sight センサのシリアルポートに接続されたデバイスネットワークインタフェースモジュールにデータを書き込みます。

WriteDeviceNet 関数 (

イベント,

ポート,

マップ仕様,

互換性,

値 1,

[値 2,

...]

)

注:

  • 選択するシリアルポートは、デバイスネット通信に設定されている必要があります。
  • この関数を有効にするには、In-Sight センサをオンラインにする必要があります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • シリアルポートの内部バッファがいっぱいになると、WriteDeviceNet 関数は画像取り込みの実行とスプレッドシートの関数を中止します。WriteDeviceNet 関数は、バッファからデータが読み取られ、バッファが空になると、スプレッドシートの操作を再開します。
  • WriteDeviceNet 関数には、サードパーティの RS-232 デバイスネットゲートウェイアダプタが必要です。この関数は従来のインストール環境で使用できます。ただし、最新のアプリケーションで使用する場合は、RS-232 デバイスネットゲートウェイコンバータを完全にテストして、そのアプリケーションでも使用できることを確認してください。

WriteDeviceNet 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

ポート

書き込むシリアルポートを指定します。In-Sight センサは 1 しか指定できません。In-Sight エミュレータは 0 または 1 を指定できます。

マップ仕様

コロン文字 (:) で区切られた指定子のリストから構成されるデータマッピング (DataMap) を指定します。各指定子は、開始バイトとデータ型コードの 2 つの部分から構成されます。さまざまなデータ型コードを、次の表に示します。

コード | データ型
i | 8 ビットの整数
u | 8 ビット符号なし整数
il | 16 ビットの整数
ul | 16 ビット符号なし整数
f | 32 ビット浮動小数点数
s | テキスト文字列

例: "0i:1f:5u:6s "の場合、最初のデータ項目 (オフセット 0) はゼロ以外のときに画像取り込みトリガをかける 8 ビット整数を指定し、2 番目の項目 (オフセット 1) は浮動小数点値を指定し、3 番目の項目 (オフセット 5) は 1 バイトの符号なし整数を指定し、パケットの残り (オフセット 6 以降) は文字列を指定します。

注: データの長さは [DeviceNet モードの詳細設定] に指定されているデバイスネットのブロックサイズと一致している必要があります。

互換性

In-Sight 1000 が In-Sight 3000 と同じ順序で出力バイトストリームを送信するかどうかを指定します。ほかの In-Sight モデルでは、このパラメータは無視されます。

0 = 互換性オフ

1 = 互換性オン

値

MapSpec (値1, 値2, ...) と一致する値の可変長リストを指定します。

WriteDeviceNet 関数の出力

戻り値

入力パラメータが無効であれば #ERR を返します。

関連項目

Event 関数

ReadDeviceNet 関数

シリアルポートのモード

入出力関数について


WriteDeviceNetBuffer 関数

入出力関数 → シリアル I/O

In-Sight 関数リファレンス

FormatOutputBuffer　関数によって作成された参照 [image] 構造体からデータを書き込みます。このデータは、In-Sight センサのシリアルポートに接続されたデバイスネットワークインタフェースモジュールによって読み込まれます。

WriteDeviceNetBuffer 関数 (

イベント,

ポート,

バッファ

)

注:

  • 選択するシリアルポートは、デバイスネット通信に設定されている必要があります。
  • この関数を有効にするには、In-Sight センサをオンラインにする必要があります。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • WriteDeviceNet 関数には、サードパーティの RS-232 デバイスネットゲートウェイアダプタが必要です。この関数は従来のインストール環境で使用できます。ただし、最新のアプリケーションで使用する場合は、RS-232 デバイスネットゲートウェイコンバータを完全にテストして、そのアプリケーションでも使用できることを確認してください。

WriteDeviceNetBuffer 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値を含むセル (ゼロ以外の数値は強制的に更新を実行します)。

ポート

書き込むシリアルポートを指定します。In-Sight センサは 1 しか指定できません。In-Sight エミュレータは 0 または 1 を指定できます。

バッファ

FormatOutputBuffer 関数によって作成された、参照される [image] 構造体を指定します。この構造体には、自動的にフォーマットされたデータが含まれます。

注: データの長さは [DeviceNet モードの詳細設定] に指定されているデバイスネットのブロックサイズと一致している必要があります。

WriteDeviceNetBuffer 関数の出力

戻り値

入力パラメータが無効であれば #ERR を返します。

関連項目

Event 関数

ReadDeviceNetBuffer 関数

ReadDeviceNet 関数

WriteDeviceNet 関数

シリアルポートのモード

入出力関数について


WriteSerial 関数

入出力関数 → シリアル I/O

In-Sight 関数リファレンス

スプレッドシートが更新されると、指定されたシリアルポートにテキスト文字列を書き込みます。

  • WriteSerial の入力パラメータ
  • WriteSerial の出力
  • 関連項目

注:

  • 選択されたシリアルポートは、Text モードに設定されている必要があります。また、In-Sight ビジョンシステムをオンラインにする必要があります。
  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。
  • この関数を含むジョブを In-Sight Explorer 3.3.0 以上で保存した場合、このジョブは、In-Sight Explorer 3.3.0 以上とのみ互換性を持ちます。

WriteSerial 関数の入力

WriteSerial 関数 (

イベント,

ポート,

文字列

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

ポート

書き込むシリアルポートを指定します。In-Sight ビジョンシステムは 1 しか指定できません。In-Sight エミュレータは 0 または 1 を指定できます。

文字列

書き出すテキスト文字列または、文字列を含むセルへの参照を指定します。

WriteSerial 関数の出力

戻り値

書き込まれるテキスト文字列。入力パラメータが無効な場合は #ERR が返されます。

関連項目

  • ReadSerial 関数
  • Event 関数
  • シリアルポートのモード
  • 入出力関数について
Version: 5.6.0


SetEvent 関数

SetEvent 関数 |
入出力関数 | In-Sight 関数リファレンス

現在のジョブ実行の完了後に実行する Event 関数をキューに入れます。この関数は、AcquireImage 関数のソフトトリガのソースとしても使用することができます。

  • SetEvent の入力パラメータ
  • SetEvent の出力
  • SetEvent 関数の例
  • 関連項目
注:
  • In-Sight ビジョンシステムが格納できるキュー内の最大イベント数は 30 です。
  • Repeat 関数または RepeatUntil 関数を使用してセルの繰り返しの反復を作成する場合、SetEvent 関数は、反復されるセルの外に配置する必要があります。セルの中に配置すると、SetEvent 関数はキューに入れられる最大イベント数を超えてしまい、イベントトリガに失敗します。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

SetEvent 関数の入力パラメータ

SetEvent 関数 (

トリガ

)

トリガ

イベントのトリガ信号を指定します。

-1 = なし (デフォルト) | トリガ信号は送られません。
32 = 手動 | 手動トリガをかけます。
80 ～ 87 = ソフト 0 ～ 7 | ソフトトリガイベント信号が送られます。

SetEvent 関数の出力

戻り値

トリガの信号値。入力パラメータが無効の場合は #ERR が返されます。

SetEvent 関数例

SetEvent 関数は、条件付きで有効になるセル状態の機能を使用してスプレッドシート内のイベントをトリガするために使用することもできます。次の例では、別のスプレッドシートのセル状態から条件付きで有効または無効にする SetEvent 関数を使用して SetEvent 関数をトリガする方法を示します。この例では、スプレッドシートのセルをモニタし、0 と 1 の間で変化したかを判別します。これにより、SetEvent 関数を有効にするか、無効にするかを決定します。

  1. この例では、スプレッドシートを下図に示すとおりに設定します。

  2. A3 の「Logic Cell」は B3 の SetEvent 関数によってモニタされます。セル D3 の Count は変化の回数をモニタします。

  3. セル A3 が 1 から 0 に変わり、再び 1 に変わると、B3 の SetEvent 関数はソフトトリガイベントを発行し、D3 の Count が増分されます。

関連項目

  • 入出力関数について
  • Event 関数


時間・タイマ関数

入出力関数

In-Sight 関数リファレンス

時間関数は、In-Sight ビジョンシステムの内部時計を読み取り、指定された時間にスプレッドシートイベントのトリガをかけることができます。

注:
  • [日付/時刻の設定] ダイアログでは、センサの内部クロックをローカルまたはリモートのネットワークサーバの時刻に自動同期するための SNTP (Simple Network Time Protocol)、または IEEE 1588 (バージョン 2) 標準で定義されている CIP-Sync と PTP (Precision Time Protocol) のいずれを In-Sight ビジョンシステムが使用するかを設定します。In-Sight ビジョンシステムを PTP と併用する場合のセットアップと設定の詳細については、「時刻同期の設定」のトピックを参照してください。
  • CIP-Sync/PTP は In-Sight 7000 Gen2 シリーズのビジョンシステム、128MB の不揮発性フラッシュメモリを搭載し、ファームウェアバージョン 4.5.0 以上を実行している In-Sight 5000 シリーズビジョンシステムで使用できます。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステム、In-Sight 5705C ビジョンシステムは例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-2R) は CIP-Sync/PTP をサポートしています。
  • GetSystemTimeOffset 関数: データ構造体から抽出されたシステム時刻のオフセット値を返します。システム時刻のオフセットは、PTP が有効な場合のみ有効です。
  • GetTimeValue 関数: データ構造体を時刻値に変換します。時間の値は、PTP が有効な場合のみ有効です。
  • Now 関数: In-Sight センサの内部時計から日時を読み取ります。
  • Sleep 関数: ジョブの実行を一時停止します。
  • Timer 関数: 一定の間隔で、または毎日指定された時刻に、スプレッドシートイベントのトリガをかけます。


Now 関数

Now 関数 |
入出力関数 → 時間・タイマ | In-Sight 関数リファレンス

In-Sight センサの内部時計から日時を読み取ります。GetClock 関数は、現在の日付と時刻を表すようにフォーマットされたテキスト文字列を、スプレッドシートに挿入します。

Now 関数 (

イベント

)

注: [日付/時刻の設定] ダイアログは、センサの内部クロックをローカルまたはリモートのネットワークサーバの時刻に自動同期させるために、SNTP (Simple Network Time Protocol) を使用するように In-Sight センサを設定します。

Now 関数の入力パラメータ

イベント

日付と時刻を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

Now 関数の出力

戻り値 | 現在の日付と時刻を含んでいる [image] データ構造体。入力 [イベント] の値が無効な場合は #ERR を返します。
結果 | データアクセス関数、GetClock がスプレッドシートに自動挿入されます。

関連項目

Event 関数

Timer 関数

入出力関数について


Sleep 関数

時間・タイマ関数

In-Sight 関数リファレンス

指定した時間の間、ジョブの実行を一時停止します。

Sleep 関数 (

継続時間,

セル 11,

[セル 2],

...

)

Sleep 関数の入力パラメータ

継続時間 | ジョブの実行を一時停止する期間をミリ秒単位で指定します。(5 ～ 5000) 注: この関数を初めてスプレッドシートに挿入し、オンラインまたはオフラインであるかに関係なく、当該関数を更新するたびに実行されます。
セル | 参照先セルの可変長リストを指定します。セルの範囲が参照される場合は、最後のセルの更新後、ジョブは指定の期間一時停止されます。セルが更新されない場合、関数は実行されません。


Timer 関数

入出力関数 → 時間・タイマ

In-Sight 関数リファレンス

一定の間隔で、または毎日特定の時刻に、スプレッドシートイベントのトリガをかけます。デフォルトでは、In-Sight ビジョンシステムがオンラインである場合は、この関数は有効になります。

  • Timer の入力パラメータ
  • Timer の出力
  • 関連項目

注:
  • [日付/時刻の設定] ダイアログは、センサの内部クロックをローカルまたはリモートのネットワークサーバの時刻に自動同期させるために、SNTP (Simple Network Time Protocol) を使用するように In-Sight センサを設定します。
  • [セル状態] から Timer 関数を有効/無効にして、関数を開始または停止することができます。

  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

Timer 関数の入力パラメータ

Timer 関数(

時間,

トリガ

)

時間

時間の間隔または毎日の特定の時刻を指定する文字列です。

注: デフォルトの間隔は 1 分です。

Closed 時刻の例

"01:00:00"

1 時間ごとにトリガをかけます。

"0:10:00"

10 分ごとにトリガをかけます。

"0:01:00"

1 分ごとにトリガをかけます。

"0:00:10"

10 秒ごとにトリガをかけます。

"@8:00"

毎日午前 8 時 00 分にトリガをかけます。

"@8:30, 20:00"

毎日午前 8 時 30 分と午後 8 時 00 分にトリガをかけます。
注:
  • @ 記号を使用して具体的な時刻を指定すると、日付と時刻が [日付/時刻の設定] ダイアログで手動で設定されている場合、または SNTP サーバがオンの場合を除き、この関数は #ERR を返します。
  • [時刻] パラメータはセル参照にすることができます。その場合、参照先セルの時刻の先頭ににアポストロフィ (') を追加する必要があります。例えば、スプレッドシートを
    A2=Timer(B2,80)
    B2='00:01:00 のように設定できます。

トリガ

一定の間隔で、または毎日特定の時刻に発生させるトリガ信号を指定します。

番号 | トリガの種類
-1 = なし | トリガ信号は送られません。
32 = 手動 | 手動トリガをかけます。
80 ～ 87 = Soft 0 ～ Soft 7 | ソフトトリガ (0 ～ 7) 信号が送られます (デフォルト = ソフト 0)。

Timer 関数の出力

戻り値

データ構造体。入力パラメータが無効であれば #ERR を返します。

関連項目

  • Event 関数
  • Now 関数
  • 入出力関数について


波形関数

入出力関数

In-Sight 関数リファレンス

波形関数は [image] データ構造体を生成します。このデータ構造体は、1 つ以上の In-Sight ビジョンシステムのパラレルディスクリート出力ライン (内蔵高速出力、または [ディスクリート I/O 設定] ダイアログで選択および設定された Cognex I/O 拡張モジュールに生成された出力) が送信されるタイミングパターンです。

  • WriteWaveformPulseTrain 関数: 単一のディスクリート出力ラインで一連のパルスを開始します。
  • WriteWaveformClocked 関数: 2 つのディスクリート出力ラインを使って、一連のデータビットの時間を測定します。
Version: 5.6.0


WriteWaveformClocked 関数

入出力関数 → 波形

In-Sight 関数リファレンス

クロックとしての 1 つのディスクリート出力とデータ用の 2 番目の出力を使用して、一度に 1 ビット、データをクロックアウトするように要求し、クロックドデータを含んでいる [image] データ構造体を生成します。

WriteWaveformClocked の入力パラメータ

WriteWaveformClocked の出力

WriteWaveformClocked 関数の例

WriteWaveformClocked 関数の関連項目

WriteWaveformClocked 関数 (

イベント,

クロック出力,

データ出力,

クロック間隔,

データ有効エッジ,

キュー,

アイドル間隔,

ビット

)

注:

  • この関数を有効にするには、In-Sight システムをオンラインにする必要があります。
  • オンラインからオフラインに遷移すると、ただちに現在実行中の波形関数を停止し、キューに保存されている波形をすべて破棄します。In-Sight ビジョンシステムがオンラインのときのみ、波形が開始されます。
  • この関数のトリガ後、波形はバックグラウンドでサイクル完了まで継続されます。

WriteWaveformClocked 関数入力

イベント

波形を開始するイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

クロック出力

クロックとして使用する出力ラインを指定します。高速出力や、In-Sight ビジョンシステムのユーザ設定可能な LED、I/O モジュールを使用しての追加出力 (接続時のみ) など、すべてのディスクリート出力ラインを使用することができます。

注: 選択したディスクリート出力の　[種類]　パラメータを [波形] に設定していない場合、#ERR が返されます。#ERR の状態は、1 つまたは複数のセルを実行中のパラメータで参照したり、条件付きで有効にした実行中の式でセルを参照したり、関数に含まれるセルを修正したり、ジョブをロードしたりすることによって、波形関数を実行するまでクリアされません。

データ出力

ビットストリームの送信に使用する出力ラインを指定します。高速出力や、In-Sight ビジョンシステムのユーザ設定可能な LED、I/O モジュールを使用しての追加出力 (接続時のみ) など、すべてのディスクリート出力ラインを使用することができます。

注: 選択したディスクリート出力の　[種類]　パラメータを [波形] に設定していない場合、#ERR が返されます。#ERR の状態は、1 つまたは複数のセルを実行中のパラメータで参照したり、条件付きで有効にした実行中の式でセルを参照したり、関数に含まれるセルを修正したり、ジョブをロードしたりすることによって、波形関数を実行するまでクリアされません。
クロック間隔 | 各クロック出力サイクルの期間 (ミリ秒単位) を指定します (10 ～ 10000、デフォルト = 1000)。WriteWaveformClocked 関数のデューティサイクルは常に 50% です。つまり、クロックで経過する時間量は常に同じです。
データ有効エッジ

クロックの立ち上がりエッジまたは立ち下がりエッジで次のクロックを読み取るかをどうかを指定します。

0 = 立ち下がりエッジ (デフォルト) | 次のビットはクロックの立ち下がりエッジで読み取られます。
1 = 立ち上がりエッジ | 次のビットはクロックの立ち上がりエッジで読み取られます。
キュー

波形キューを有効にするか無効にするかを指定します。

0 = 無効 | キューを [無効] にしたときに、前の波形を実行している場合、#ERR を返します。
1 = 有効 (デフォルト) | キューを [有効] にしたときに、前の波形を実行している場合、新しい波形はキューに保存され、次に実行されます。

アイドル間隔

波形が完了してから次の波形が始まるまでの、アイドル状態の待ち時間を指定します (0～10000、デフォルト = 3)。
ビット | 送信するビットを含んでいる、BitStream 関数によって返される [image] データ構造体への参照を指定します。BitStream 関数では、253 ビット超を指定することはできません。

WriteWaveformClocked 関数出力

戻り値

クロックドデータを含んだ [image] データ構造体。入力パラメータが無効な場合は #ERR を返します。

WriteWaveformClocked 関数例

次の図は、この関数のパラメータを説明します。WriteWaveformClocked 関数★削除★この例ではどちらも、データビットは 3、アイドル間隔は 2 です。

Closed 図 1 -WriteWaveformClocked 関数Data Valid Edge を [立ち下がりエッジ] に設定した関数

Closed 図 2 -WriteWaveformClocked 関数Data Valid Edge を [立ち上がりエッジ] に設定した関数

注: 実際の出力時の電圧は、特定の出力および配線によって異なります。「NPN」または「シンク電流」で配線されている出力では、電圧レベルは上記の図とは逆となります。

関連項目

波形関数

BitStream 関数

入出力関数について

データアクセス入出力関数

Version: 5.6.0


WriteWaveformPulseTrain 関数

入出力関数 → 波形

In-Sight 関数リファレンス

指定のディスクリート出力ラインから送信される連続パルスを要求し、パルス登録データを含む [image] データ構造体を生成します。

  • WriteWaveformPulseTrain の入力パラメータ
  • WriteWaveformPulseTrain の出力
  • WriteWaveformPulseTrain 関数の例
  • WriteWaveformPulseTrain 関数の関連項目

注:

  • この関数を有効にするには、In-Sight システムをオンラインにする必要があります。
  • オンラインからオフラインに遷移すると、ただちに現在実行中の波形関数を停止し、キューに保存されている波形をすべて破棄します。In-Sight ビジョンシステムがオンラインのときのみ、波形が開始されます。
  • この関数のトリガ後、波形はバックグラウンドでサイクル完了まで継続されます。
  • ジョブ内の WriteWaveformPulseTrain 関数の数、または関数専用の出力ラインの数に関わらず、波形は一度に 1 つのみ生成することができます。

WriteWaveformPulseTrain 関数の入力

WriteWaveformPulseTrain 関数 (

イベント,

出力,

間隔,

デューティサイクル,

パルス極性,

キュー,

アイドル間隔,

パルス数

)

イベント

波形を開始するイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

出力

使用する出力ラインを指定します。高速出力や、In-Sight ビジョンシステムのユーザ設定可能な LED、I/O モジュールを使用しての追加出力 (接続時のみ) など、すべてのディスクリート出力ラインを使用することができます。

注: 選択したディスクリート出力の　[種類]　パラメータを [波形] に設定していない場合、#ERR が返されます。#ERR の状態は、1 つまたは複数のセルを実行中のパラメータで参照したり、条件付きで有効にした実行中の式でセルを参照したり、関数に含まれるセルを修正したり、ジョブをロードしたりすることによって、波形関数を実行するまでクリアされません。

間隔

パルス開始から次のパルス開始までの間の合計時間をミリ秒単位で指定します (10～10,000、デフォルト = 1000)。
デューティサイクル

パルスがアクティブ状態にある時間の割合 (パルス間隔の割合) を指定します (0～100%、デフォルト = 50%)。

注: 実際のデューティサイクルは、使用している In-Sight ビジョンシステムおよび I/O モジュールの限界から、設定している数値にできるだけ近い数値となります。また、[間隔] パラメータが最小値近くに設定されていると、デューティサイクルの精度がさらに下がります。
パルス極性

パルス極性を指定します。

0 = 高 (デフォルト) | パルスがアクティブなとき、出力ラインは強制的に HIGH になります。パルスがアクティブでないとき、出力は LOW に設定されます。
1 = 低 | パルスがアクティブなとき、出力ラインは強制的に LOW になります。パルスがアクティブでないとき、出力は HIGH に設定されます。
キュー

波形キューを有効にするか無効にするかを指定します。

0 = 無効 | キューを [無効] にしたときに、前の波形を実行している場合、#ERR を返します。
1 = 有効 (デフォルト) | キューを [有効] にしたときに、前の波形を実行している場合、新しい波形はキューに保存され、次に実行されます。

アイドル間隔

波形が完了してから次の波形が始まるまでの、アイドル状態の待ち時間を指定します (0～10000、デフォルト = 3)。
パルス数 パルス登録を構成するパルス総数を指定します (1～10000、デフォルト = 10)。

WriteWaveformPulseTrain 関数の出力

戻り値

パルス登録データを含む [image] データ構造体。入力パラメータが無効な場合は #ERR を返します。

WriteWaveformPulseTrain 関数例

次の図は、この関数のパラメータを説明します。WriteWaveformPulseTrain 関数★削除★この例ではどちらも、パルスは 3、アイドル間隔は 2 です。

Closed 図 1 -WriteWaveformPulseTrain 関数[パルス極性] を [高] に設定した関数

Closed 図 2 -WriteWaveformPulseTrain 関数[パルス極性] を [低] に設定した関数

注: 実際の出力時の電圧は、特定の出力および配線によって異なります。「NPN」または「シンク電流」で配線されている出力では、電圧レベルは上記の図とは逆となります。

関連項目

  • 波形関数
  • 入出力関数について
  • データアクセス入出力関数
Version: 5.6.0


クロックドデータ関数

In-Sight 関数リファレンス

クロックドデータ関数は、時間の経過に従ってセルからの値のストリームを格納します。指定したイベントがスプレッドシートを更新すると必ず、各関数は値のストリームから選択された単一の値を返します。

  • Accumulate 関数: 一定の間隔で値を蓄積します。
  • ClockedMax 関数: 指定した間隔の間、サンプリングされたストリームから最大値を返します。
  • ClockedMin 関数: 指定した間隔の間、サンプリングされたストリームから最小値を返します。
  • ClockedSum 関数: 指定した間隔の間、サンプリングされたストリームから値を合計します。
  • Count 関数: 無限の間隔でイベントの数をカウントします。
  • CountPassFail 関数: 指定された参照値の合格、不合格、およびイベント総数をカウントして返します。
  • DelayLine 関数: イベント信号で値が読み取られたシフトレジスタ配列を実装します。
  • Latch 関数: 指定したイベント時に入力値を格納します。
  • LatchImage 関数: 指定したイベント時に画像を格納します。
  • LatchString 関数: 指定したイベント時に英数字入力文字列を格納します。
  • Maximum 関数: 無限の間隔で入力データストリームの最大値をラッチします。
  • Minimum 関数: 無限の間隔で入力データストリームの最小値をラッチします。
  • Repeat 関数: 指定されたセルの実行を、指定された回数繰り返します。
  • RepeatUntil 関数: 終了条件が満たされるか、または繰り返し回数の上限に達するまで、指定したセルの実行を繰り返します。
  • StoreData 関数: セルの結果を格納します。
  • ShiftRegister 関数: 各イベント後にセルの値をバッファリングする、シフトレジスタ配列またはデータ「ストリーム」を実装します。


Accumulate 関数

クロックドデータ関数

In-Sight 関数リファレンス

無限の間隔で値を合計します。この関数は、指定したイベントのそれぞれの出現時にサンプリングされた、データストリームの整数を返します。

Accumulate 関数 (

イベント,

値,

リセット,

プリセット

)

Accumulate 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

注:Accumulate 関数指定したイベントに依存するその他の関数によって参照値が更新される前に、参照値の状態をバッファ処理します。

値

蓄積されるデータストリームのソースを含んでいるセルへの参照。

リセット

強制的にアキュムレータを [プリセット] の値にリセットします。

0 = OFF (デフォルト) | アキュムレータは指定された値を無期限に合計し続けます。
1 = ON | アキュムレータが即座にリセットされます。

プリセット

[リセット] をオンにしたときに、アキュムレータがリセットされる最小値を指定します。

Accumulate 関数の出力

戻り値

最後の「リセット」から一定時間内のデータストリームの総計を表す値。

関連項目

Event 関数

クロックドデータ関数について


ClockedMax 関数

クロックドデータ関数

In-Sight 関数リファレンス

無限の間隔で値のストリームをサンプリングし、その後その間隔中にストリームからサンプリングされた最大値を返します。

ClockedMax 関数 (

イベント,

値,

リセット,

プリセット

)

ClockedMax 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: 指定した Event 関数に依存するその他の関数によって参照値が更新される「前」に、参照値の状態をサンプリングする Maximum 関数とは異なり、ClockedMax 関数その他の関数によって参照値が更新された「後」に、参照値の状態をサンプリングします。

値

最小値の検索対象であるデータストリームのソースセルへの参照。(-9999999 ～ 9999999、デフォルト = 0)

リセット

強制的に内部レジスタを [プリセット] で指定された値にリセットします。

0 = OFF (デフォルト) | 現在のデータストリームで [値] のサンプリングを続行します。
1 = ON | 関数が返した最小値をリセットして、サンプリングの開始位置とする新しいデータストリームを開始します。

プリセット

関数のリセット後の最小値を指定します (-9999999 ～ 9999999、デフォルト = -9999999)。

ClockedMax 関数の出力

戻り値

[リセット] から現在までのデータストリームの最小値を表す値。

関連項目

Event 関数

ClockedMin 関数

Minimum 関数

Maximum 関数

クロックドデータ関数について


ClockedMin 関数

クロックドデータ関数

In-Sight 関数リファレンス

無限の間隔で値のストリームをサンプリングし、その後その間隔中にストリームからサンプリングされた最小値を返します。

ClockedMin 関数 (

イベント,

値,

リセット,

プリセット

)

ClockedMin 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: 指定した Event 関数に依存するその他の関数によって参照値が更新される「前」に、参照値の状態をサンプリングする Minimum 関数とは異なり、ClockedMin 関数その他の関数によって参照値が更新された「後」に、参照値の状態をサンプリングします。

値

最小値の検索対象であるデータストリームのソースセルへの参照 (-9999999 ～ 9999999、デフォルト = 0)。

リセット

強制的に内部レジスタを [プリセット] で指定された値にリセットします。

0 = OFF (デフォルト) | 現在のデータストリームで [値] のサンプリングを続行します。
1 = ON | 関数が返した最小値をリセットして、サンプリングの開始位置とする新しいデータストリームを開始します。

プリセット

関数のリセット後の最小値を指定します (-9999999 ～ 9999999、デフォルト = 9999999)。

ClockedMin 関数の出力

戻り値

[リセット] から現在までのデータストリームの最小値を表す値。

関連項目

Event 関数

ClockedMax 関数

Minimum 関数

Maximum 関数

クロックドデータ関数について


ClockedSum 関数

クロックドデータ関数

In-Sight 関数リファレンス

無限の間隔で値を合計します。この関数は、指定したイベントのそれぞれの出現時にサンプリングされた、データストリームの整数を返します。

ClockedSum 関数 (

イベント,

値,

リセット,

プリセット

)

ClockedSum 関数の入力パラメータ

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: 指定した Event 関数に依存するその他の関数によって参照値が更新される「前」に、参照値の状態を合計する Accumulate 関数とは異なり、ClockedSum 関数その他の関数によって参照値が更新された「後」に、参照値の状態を合計します。

値

蓄積されるデータストリームのソースを含んでいるセルへの参照 (-9999999 ～ 9999999、デフォルト = 1)。

リセット

強制的にアキュムレータを [プリセット] の値にリセットします。

0 = OFF (デフォルト) | アキュムレータは指定された値を無期限に合計し続けます。
1 = ON | アキュムレータが即座にリセットされます。

プリセット

[リセット] が ON の場合に、アキュムレータのリセット後の最小値を指定します (-9999999 ～ 9999999、デフォルト = 0)。

ClockedSum 関数の出力

戻り値

最後の「リセット」から一定時間内のデータストリームの総計を表す値。

関連項目

Event 関数

クロックドデータ関数について


Count 関数

Count 関数 |
クロックドデータ関数 | In-Sight 関数リファレンス

無限の間隔でイベントの数をカウントします。この関数は [プリセット] の値プラス最後のリセット以来発生したイベントの数を返します。

Count 関数 (

イベント,

最大値,

リセット,

プリセット

)

Count 関数の入力パラメータ

イベント

カウンタを増分する更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

最大値

カウンタが自動的にそれ自体を [プリセット] の最小値にリセットする前に、許可される最高の値を指定します。(デフォルト = 9999999)

リセット

強制的にカウンタを [プリセット] の値にリセットします。

0 = OFF (デフォルト) | カウンタがリセットされるまでに達することができる [最大値]。
1 = ON | [最大値] に達していなくても、即座にカウンタがリセットされます。

プリセット

カウンタが [最大値] に達した場合、または [リセット] がオンになっている場合に、カウンタをリセットした後の最小値。(デフォルト = 0)

Count 関数の出力

戻り値

この値は、[プリセット] の値プラス最後のリセット以来発生したイベントの数。

関連項目

Event 関数

クロックドデータ関数について


CountPassFail 関数

クロックドデータ関数

In-Sight 関数リファレンス

指定された参照値の合格、不合格、およびイベント総数をカウントして返します。

CountPassFail 関数 (

イベント,

値,

オフライン時にカウント,

イベントのリセット.手動,

イベントのリセット.オンライン,

イベントのリセット.ジョブを開く

)

CountPassFail 関数の入力パラメータ

イベント

カウンタを増分するイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体(デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

値

カウントされるデータストリームのソースを含んでいるセルへの必要な参照を指定します。参照されているセルがない場合、関数はすべての結果に対して #ERR を返します。増分されるカウンタ (Pass、Fail、または #ERR) は、次のように、返される値に基づいています。

PASS | 値 > 0
Fail | 値 = 0
#ERR | 値 < 0

オフライン時にカウント

センサがオフラインの間にカウンタが増分されるかどうかを指定します。

0 = OFF | センサがオフラインの場合、カウンタを増分させません。
1 = ON (デフォルト) | センサがオフラインの場合、カウンタを増分させます。

イベントのリセット

特定のイベントによってカウンタを強制的にリセットします。

手動

指定されたイベントが発生したときにカウンタをゼロにリセットするかどうかを指定します。このパラメータは、[リセット] ボタンを自動的に参照します。[リセット] ボタンは、関数が最初に作成されたときにスプレッドシートに挿入されます。

注: プロパティシート内でこのチェックボックスを手動で切り替えると、[リセット] ボタンへの参照は削除されます。[リセット] ボタンを使用するには、このパラメータが [リセット] ボタンを含むセルを参照している必要があります。

0 = OFF (デフォルト) | 指定されたイベントが発生しても、カウンタをリセットしません。
1 = ON | 指定されたイベントが発生すると、カウンタをリセットします。

オンライン

センサがオンラインにされたときに最初のイベントが発生すると、カウンタをゼロにリセットするかどうかを指定します。

0 = OFF | センサがオンラインにされても、最初のイベント発生後にカウンタをリセットしません。
1 = ON (デフォルト) | センサがオンラインにされると、最初のイベント発生後にカウンタをリセットします。

ジョブを開く

ジョブがロードされた場合にカウンタをゼロにリセットするかどうかを指定します。

0 = OFF | ジョブがロードされても、カウンタをリセットしません。
1 = ON (デフォルト) | ジョブがロードされると、カウンタをリセットします。

CountPassFail 関数の出力

戻り値 | 増分されたカウンタを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | 初めてCountPassFail 関数セルに挿入すると、スプレッドシート内に結果テーブルと [リセット] ボタンが作成されます。[リセット] ボタンをクリックすると、すべてのカウンタがゼロにリセットされます。

CountPassFail 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

合格 | GetPassCount(Count) | 合格の増分カウント。合格数は、返される値がゼロよりも大きい場合にカウントアップされます。
不合格 | GetFailCount(Count) | 不合格の増分カウント。不合格数は、返される値がゼロの場合にカウントアップされます。
エラー | GetErrorCount(Count) | エラーの増分カウント。エラー数は、返される値がゼロよりも小さい場合にカウントアップされます。
総数 | GetTotalCount(Count) | 合格、不合格、およびエラーの総数。

関連項目

Count 関数

クロックドデータ関数について


DelayLine 関数

クロックドデータ関数

In-Sight 関数リファレンス

各イベント後にセルの値をバッファリングする、シフトレジスタ配列またはデータ「ストリーム」を実装します。

DelayLine 関数 (

イベント,

値 ,

ステップ数,

リセット

)

注: リセット後に、読み込まれる最初の値がシフトレジスタに入力されます。

DelayLine 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

注: 指定した Event 関数に依存するその他の関数によって参照値が更新される前に、DelayLine 関数は参照値の状態をバッファ処理します。

値

ソースデータを含んでいるセルへの参照。

ステップ数

この関数の内部シフトレジスタ配列内の値の数を指定します。(デフォルト = 10)

リセット

以前に読み取った値の関数を強制的に完全消去します。リセット後、最初に読み取られた値がシフトレジスタを効率的に埋めます。

0 = OFF (デフォルト) | データストリームへの値の読み込みが続行されます。
1 = ON | データストリームからすべての値が完全消去されます。

DelayLine 関数の出力

戻り値 | データ構造体。この構造体には、指定された [値] に対する [リセット] から現在までの統計が含まれています。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

DelayLine 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

最後 | GetValue(ディレイ, インデックス) | 構造体に含まれている最後の数。
平均 | GetMean(ディレイ) | 構造体のすべての値の平均。
標準偏差 | GetSDev(ディレイ) | 構造体のすべての値の標準偏差。
最小 | GetMin(ディレイ) | 構造体に含まれている最小値。
最大 | GetMax(ディレイ) | 構造体に含まれている最大値。

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

数 | GetCount(ディレイ) | 構造体に含まれている値の数。
合計 | GetSum(ディレイ) | 構造体に含まれているすべての値の合計。

関連項目

Event 関数

クロックドデータ関数について


Latch 関数

Latch 関数 |
クロックドデータ関数 | In-Sight 関数リファレンス

指定したイベントでの入力値を格納 (ラッチ) します。

Latch 関数 (

イベント,

値

)

Latch 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

値

格納するデータを含んでいるセルへの参照。

Latch 関数の出力

戻り値

最後のイベントで格納された値

関連項目

Event 関数

クロックドデータ関数について


LatchImage 関数

LatchImage 関数 |
クロックドデータ関数 | In-Sight 関数リファレンス

指定したイベントでの画像を格納 (ラッチ) します。

  • LatchImage の入力パラメータ
  • LatchImage の出力
  • 関連項目

LatchImage 関数の入力パラメータ

LatchImage 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

イベント,

カラー化,

表示

)

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセットを指定します。
列 | 画像座標での列オフセットを指定します。
角度 | 画像座標での角度を指定します。

領域

これは対象領域 (ROI) とも呼ばれ、画像処理の対象となる画像の領域を指定します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、[領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

X | フィクスチャ座標での原点の X オフセットを指定します。
Y | フィクスチャ座標での原点の Y オフセットを指定します。
高さ | 領域の X 軸に沿った寸法を指定します。
幅 | 領域の Y 軸に沿った寸法を指定します。
角度 | フィクスチャ座標での角度を指定します。

注: [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

イベント

画像の格納先の更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

カラー化

カラー画像にのみ関係します。これを無効にすると、ラッチされた画像がグレースケールに変換されます (有効にした場合は、カラー画像のままです)。

0 = 無効 (デフォルト)

1 = 有効

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | 関数を含んでいるセルがスプレッドシート内のアクティブセルである場合を除き、使用可能なグラフィックス項目が表示されません。 注: 入力領域が変更されると、第 2 の領域が表示されて、指定された次のイベントでラッチが発生する位置を示します。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力のグラフィックスのみ | 入力画像領域と関連付けられているグラフィックス項目が常に表示されます。

LatchImage 関数の出力

戻り値

最後のイベントで格納された画像を含んでいる [image] データ構造体

関連項目

Event 関数

クロックドデータ関数について


LatchString 関数

LatchString 関数 |
クロックドデータ関数 | In-Sight 関数リファレンス

指定したイベントでの英数字入力文字列を格納 (ラッチ) します。

LatchString 関数 (

イベント,

"文字列"

)

LatchString 関数の入力パラメータ

イベント

文字列を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

文字列

格納する文字列を含んでいるセルへの参照。

LatchString 関数の出力

戻り値

最後のイベントで格納された文字列

関連項目

Event 関数

クロックドデータ関数について


Maximum 関数

クロックドデータ関数

In-Sight 関数リファレンス

無限の間隔で値のストリームをサンプリングし、その後その間隔中にストリームからサンプリングされた最大値を返します。

Maximum 関数 (

イベント,

値,

リセット,

プリセット

)

Maximum 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

注:Maximum 関数指定したイベントに依存するその他の関数によって参照値が更新される前に、参照値の状態をサンプリングします。

値

最大値の検索対象であるデータストリームのソースセルへの参照。

リセット

強制的に内部レジスタを [プリセット] で指定された値にリセットします。

0 = OFF (デフォルト) | 現在のデータストリームで「値」のサンプリングを続行します。
1 = ON | 関数が返した最大値をリセットして、サンプリングの開始位置とする新しいデータストリームを開始します。

プリセット

関数のリセット後の最大値を指定します (デフォルト = -9999999)。

Maximum 関数の出力

戻り値

最後に「リセット」が行われてから、データストリームでの最大値である値。

関連項目

Event 関数

クロックドデータ関数について


Minimum 関数

クロックドデータ関数

In-Sight 関数リファレンス

無限の間隔で値のストリームをサンプリングし、その後その間隔中にストリームからサンプリングされた最小値を返します。

Minimum 関数 (

イベント,

値,

リセット,

プリセット

)

Minimum 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

注:Minimum 関数指定したイベントに依存するその他の関数によって参照値が更新される前に、参照値の状態をサンプリングします。

値

最小値の検索対象であるデータストリームのソースセルへの参照。

リセット

強制的に内部レジスタを [プリセット] で指定された値にリセットします。

0 = OFF (デフォルト) | 現在のデータストリームで値のサンプリングを続行します。
1 = ON | 関数が返した最小値をリセットして、サンプリングの開始位置とする新しいデータストリームを開始します。

プリセット

関数のリセット後の最小値を指定します (デフォルト = 9999999)。

Minimum 関数の出力

戻り値

リセットから現在までのデータストリームの最小値を表す値。

関連項目

Event 関数

クロックドデータ関数について


Repeat 関数

クロックドデータ関数

In-Sight 関数リファレンス

指定されたセルの実行を、指定された回数繰り返します。

注: Repeat 関数または RepeatUntil 関数を使用してセルの繰り返しする反復を作成する場合、SetEvent 関数は、反復されるセルの外に配置する必要があります。SetEvent 関数を反復されるセルの中に入れると、SetEvent 関数がイベントトリガに失敗する可能性があります。

Repeat 関数の入力パラメータ

Repeat 関数 (

イベント,

繰り返しする反復,

繰り返しするセル

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル
  • 数値を含むセル。この数値が変化すると、イベントがトリガされます。

繰り返しする反復

実行する必要のある繰り返し回数 (0 ～ 5000) を指定します。

繰り返しするセル

繰り返しの対象となるセルへの参照を指定します。この参照は、セルの範囲、セル参照をカンマで区切って並べたリスト、またはこの 2 つの組み合わせである必要があります。

Repeat 関数の出力

戻り値

セルの繰り返しに関するデータを含む　 [image] データ構造体。

関連項目

  • クロックドデータ関数について
  • スプレッドシートセルのルールの作成
  • Event 関数
  • GetLoopCount 関数
  • GetLoopReset 関数
  • RepeatUntil 関数
  • StoreData 関数


RepeatUntil 関数

クロックドデータ関数

In-Sight 関数リファレンス

終了条件が満たされるか、または繰り返し回数の上限に達するまで、指定したセルの実行を繰り返します。

注: Repeat 関数または RepeatUntil 関数を使用してセルの繰り返しする反復を作成する場合、SetEvent 関数は、反復されるセルの外に配置する必要があります。SetEvent 関数を反復されるセルの中に入れると、SetEvent 関数がイベントトリガに失敗する可能性があります。

RepeatUntil 関数の入力パラメータ

RepeatUntil 関数 (

イベント,

終了条件,

最大反復,

繰り返しするセル

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] 　データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル
  • 数値を含むセル。この数値が変化すると、イベントがトリガされます。

終了条件

繰り返しの終了要件を定義するゼロ以外の値を指定します。

最大反復

実行する必要のある繰り返し回数の最大値 (0 ～ 5000) を指定します。

繰り返しするセル

繰り返しの対象となるセルへの参照を指定します。この参照は、セルの範囲、セル参照をカンマで区切って並べたリスト、またはこの 2 つの組み合わせである必要があります。

RepeatUntil 関数の出力

戻り値

セルの繰り返しに関するデータを含む [image] データ構造体。

関連項目

  • クロックドデータ関数について
  • スプレッドシートセルのルールの作成
  • Event 関数
  • GetLoopCount 関数
  • GetLoopReset 関数
  • Repeat 関数
  • StoreData 関数


ShiftRegister 関数

クロックドデータ関数

In-Sight 関数リファレンス

各イベント後にセルの値をバッファリングする、シフトレジスタ配列またはデータ「ストリーム」を実装します。

ShiftRegister 関数 (

イベント,

値 ,

ステップ数,

リセット

)

注: リセット後に、読み込まれる最初の値がシフトレジスタに入力されます。

ShiftRegister 関数の入力パラメータ

イベント

値を読み取る更新イベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: 指定の Event に依存する他の関数によって参照先の値が更新される前に、その値の状態をバッファするDelayLine 関数とは違い、ShiftRegister 関数参照元の値が他の関数によって更新されてから、その値の状態をバッファします。

値

ソースデータ (-9999999 ～ 9999999、デフォルト = 0) を含んでいるセルへの参照。

ステップ数

関数の内部シフトレジスタアレイの値の数を指定します (1 ～ 5000、デフォルト = 10)。

リセット

以前に読み取った値の関数を強制的に完全消去します。リセット後、最初に読み取られた値がシフトレジスタを効率的に埋めます。

0 = OFF (デフォルト) | データストリームへの値の読み込みが続行されます。
1 = ON | データストリームからすべての値が完全消去されます。

ShiftRegister 関数の出力

戻り値 | データ構造体。この構造体には、指定された [値] に対する [リセット] から現在までの統計が含まれています。
結果 | この関数が初めてセルに挿入されると、スプレッドシート内に結果テーブルが自動的に作成されます。

ShiftRegister 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

最後 | GetValue(ディレイ, インデックス) | 構造体に含まれている最後の数。
平均 | GetMean(ディレイ) | 構造体のすべての値の平均。
標準偏差 | GetSDev(ディレイ) | 構造体のすべての値の標準偏差。
最小 | GetMin(ディレイ) | 構造体に含まれている最小値。
最大 | GetMax(ディレイ) | 構造体に含まれている最大値。

次のデータアクセス関数を使用して、そのほかのデータの取得ができます。

Count 関数 | GetCount(ディレイ) | 構造体に含まれている値の数。
合計 | GetSum(ディレイ) | 構造体に含まれているすべての値の合計。

関連項目

Event 関数

DelayLine 関数

クロックドデータ関数について


StoreData 関数

クロックドデータ関数

In-Sight 関数リファレンス

Repeat 関数または RepeatUntil 関数と組み合わせて使用し、セルの結果を格納します。

  • StoreData の入力パラメータ
  • StoreData の出力
  • 関連項目
注:
  • Repeat 関数または RepeatUntil 関数と組み合わせてループを作成する場合、StoreData 関数はスプレッドシートの反復されるセルのループ内に配置する必要があります。
  • StoreData 関数は「先入れ先出し」方式でデータを格納します。つまり、新しい結果を格納する場合、この結果はバッファのインデックス 0 の位置に挿入され、既に格納されているそのほかの結果の位置はすべてバッファ内で 1 つシフトされます。
  • ジョブファイルの保存時、StoreData 関数が含むデータは格納されません。ジョブファイルに保存された StoreData 関数はすべて、このジョブを再ロードしたときに自動的にリセットされます。
  • 保存されたセルに入力画像への参照が含まれている場合、この入力画像は格納されず、GetValue 関数で参照すると、保存されたセル固有のグラフィックスのみ表示されます。
  • InspectEdge、InspectEdgeForDefect、InspectEdgePosition、InspectEdgeTrainBeadPath、または InspectEdgeWidth 関数を含むセルを参照した場合、領域グラフィックスには、エッジ検出インジケータの黄色の点線は表示されません。
  • BlobToBlob、BlobToLine、BlobToPoint、または BlobToRadian 関数を含むセルを参照した場合、これらの関数が外部参照しているブロブグラフィックスは表示されません。

StoreData 関数の入力パラメータ

StoreData 関数 (

イベント ,

データ,

ステップ数,

手動リセット,

オンラインリセット

)

イベント

指定したデータを読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル。

データ

結果の構造体を含んでいるセルへの参照を指定します。数値または文字列値を含むセルは、すべて参照することができます。

注: StoreData 関数は、Image functions、DetectFlaw、FlexFlawModel、ReadIDMax、TrainFlawModel、TrainPatMaxPattern、ValidateIDData、VerifyIDCode の各関数とは併用できません。

ステップ数

繰り返し回数を 1 ～ 5000 の範囲で指定します。

リセット

格納されているデータをリセットするイベントを指定します。

手動 | Button 関数を含むセルに基づいて値がリセットされるように指定します。
オンライン | In-Sight ビジョンシステムがオンラインになったときに、データがリセットされます。

StoreData 関数の出力

戻り値

データ構造体。この構造体には、指定された [データ] に対する [リセット] から現在までの結果のデータが含まれています。

関連項目

  • クロックドデータ関数について
  • スプレッドシートセルのルールの作成
  • Event 関数
  • PlotData 関数
  • Repeat 関数
  • RepeatUntil 関数


データアクセス関数

In-Sight 関数リファレンス

データアクセス (VDA含む) 関数は、次のカテゴリに分けられるデータ構造体、関数、およびそのほかのセル参照から個々の値を抽出します。

VDA カテゴリ | 参照される構造体および関数
Bead 関数 |
Blobs 関数 |
CircleFit 関数 |
クロックドデータ関数 |
カラー関数 1 | ,
カラーヒストグラム関数 1 |
オペレータ I/F 関数 | Authorize 関数、ListBox 関数
距離関数 |
エッジ関数 |
傷検出関数 |
フォント関数 |
GetErrorCode 関数 | 大半の構造体
GetErrorString 関数 | 大半の構造体
GetOnline 関数 |
ヒストグラム関数 |
ID コード関数 2 |
IDMax 関数 |
IDValidate 関数 |
IDVerify 関数 |
画像関数 |
入出力関数 | 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、
LineFit 関数 |
ラインスキャン関数 3 | Event 関数
OCRMax 関数 |
パターン関数 |
スクリプト関数 | Script 関数、Get 関数
統計関数 |
構造体関数 | 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、
文字列操作関数 |
時間・タイマ関数 | 、参照されるセル
ホワイトバランス関数 1 | Event 関数
1 カラービジョンシステムのみでサポートされます。 2 In-Sight ファームウェア 4.x.x を実行しているビジョンシステムのみでサポートされます。モデル一覧およびサポートされているファームウェアについては、ファームウェアバージョンを参照してください。 3 ラインスキャンビジョンシステムのみでサポートされます。
Version: 5.6.0


ビード

ビード |
データアクセス | In-Sight 関数リファレンス

BeadFind データアクセス関数

注:

BeadFind 関数の式はすべて、以下の規則に準拠します。

  • BeadFind = BeadFind 関数によって出力された [image] データ構造体
  • キャリパインデックス = -1、0 ～ N (参照するキャリパを決定します。-1 = 全体の平均を取得)
  • エッジ = 0 または 1 (参照するエッジを決定します。0 = 1 つめのエッジ、1 = 2 つめのエッジ)

  • ビードパスを登録する場合、返される値はビードパス候補から返される値とは異なることが多くなります。

関数 | 説明
GetBeadColor(ビード検出) | 背景色に対して、選択したビードパスまたは登録されているビードの色を返します (0 = 黒 (白い背景)、1 = 白 (黒い背景))。
GetBeadContrastThreshold(ビード検出) | 選択したビードパスの、計算されたコントラストしきい値を返します。
GetBeadCount(ビード検出) | 検出したビードパス候補の数を返します。ビードパスが検出されないか、「ビードパスの検出」が実行されない場合は、0 を返します。
GetBeadEdgeOffset(ビード検出, [キャリパインデックス], [エッジ]) | イデックス付きキャリパでのポリラインパスからの平均エッジオフセット (ピクセル単位)、または選択したビードパスに沿った平均エッジオフセットを返します。
GetBeadEnclosed(ビード検出) | 選択したビードパスが閉じた輪であるかどうかを返します (0 = ビードは閉じていません。1 = ビードが閉じています)。
GetBeadExtremeWidth(ビード検出, [極致]) 極致 = 0 または 1 (0 = 最小、1 = 最大) | 選択したビードパスの最小または最大の幅を含んでいるキャリパインデックスを返します。
GetBeadNumPoints(ビード検出) | 選択したビードパスで使用されている点の数を返します。
GetBeadPoint(ビード検出, [インデックス], [寸法]) インデックス = 0 ～ N (参照する頂点を指定します) 寸法 = 0 または 1 (0 = 頂点の X 座標、1 = 頂点の Y 座標) | 選択したビードパスの指定した点の X または Y 座標を返します。
GetBeadSearchWidth(ビード検出) | 選択したビードパスの、計算されたサーチ幅の半分を返します。
GetBeadSelected(ビード検出) | 選択したビードパスのインデックスを返します。
GetBeadTrained(ビード検出) | 選択したビードパスの、登録状態を返します (0 = 未登録、1 = 登録済み)。
GetBeadWidth(ビード検出, [キャリパインデックス]) | インデックスで指定されたキャリパでのビード幅、または選択したビードパスでの平均ビード幅を返します。
GetNumCalipers(ビード検出) | 選択したビードパスに使用されているキャリパの数を返します。

BeadInspect データアクセス関数

注:

Bead 関数の式はすべて、以下の規則に準拠します。

  • BeadInspect = BeadInspect 関数によって出力された [image] データ構造体
  • エッジ = 0 または 1 (参照するエッジを決定します。0 = 1 つめのエッジ、1 = 2 つめのエッジ、デフォルト = 0)
  • 形式 = 0 または 1 (使用する形式を決定します。0 = パーセント、および 1 = ピクセル。デフォルト = 0)
  • インデックス = 0 ～ 欠陥の数 -1 (参照する欠陥インデックスを決定します。デフォルト = 0)

  • インデックス* = -1 ～ 欠陥の数 -1 (参照する欠陥インデックスを決定します。-1 = [タイプ] パラメータに基づいて、すべての欠陥の中で最小値または最大値を持つ欠陥を検出し、欠陥のインデックス値を返します。デフォルト = 0)

  • キャリパの数 = 0 ～ キャリパ -1 (使用するキャリパの範囲を決定します。0 = 開始インデックスから最後のキャリパまでのすべてのキャリパを使用します。デフォルト = 0)

    • 注: 入力した [キャリパの数] の値が [キャリパ -1] よりも大きい場合、この値は、開始インデックスから残っているキャリパまで調整されます。

  • 開始インデックス = 0 ～ キャリパ -1 (開始するキャリパインデックスを決定します。デフォルト = 0)

関数名 | 説明

GetBeadDefectArea(ビード検査, [インデックス*], [タイプ])

タイプ (0 または 1、0 = 最小、1 = 最大、デフォルト = 0)

注: [タイプ] パラメータは、インデックスが -1 の場合にのみ有効です。

指定の欠陥に関して、登録ビードと比較したビードエリアの変化を返します。エリアが拡大している場合、返される値は正であり、エリアが縮小している場合は負です。

Closed 例:

登録ビードの幅が 20 で、検査対象のビード幅が 18 である場合、戻り値は -2 となります (キャリパ領域が 1 ピクセルの幅であることに基づいています)。

GetBeadDefectBoundAngle(ビード検査, [インデックス])

 指定のインデックスの欠陥を囲む境界ボックスの角度を返します。

GetBeadDefectBoundCol(ビード検査, [インデックス])

 指定のインデックスの欠陥を囲む境界ボックスの列座標を返します。

GetBeadDefectBoundHigh(ビード検査, [インデックス])

 指定のインデックスの欠陥を囲む境界ボックスの高さを返します。

GetBeadDefectBoundRow(ビード検査, [インデックス])

 指定のインデックスの欠陥を囲む境界ボックスの行座標を返します。

GetBeadDefectBoundWide(ビード検査, [インデックス])

 指定のインデックスの欠陥を囲む境界ボックスの幅を返します。

GetBeadDefectCaliperIndex(ビード検査, [インデックス], [タイプ])

タイプ (0 または 1、0 = 開始インデックス、1 = 終了インデックス、デフォルト = 0)

 指定の欠陥内の最初または最後キャリパのインデックスを返します。

GetBeadDefectCol(ビード検査, [インデックス], [タイプ])

タイプ (0 または 1、0 = 開始インデックス、0 = 終了インデックス、デフォルト = 0)

 指定のインデックスの欠陥を囲む境界ボックスの X 座標を返します。

GetBeadDefectContrast(ビード検査, [インデックス*], [タイプ], [エッジ])

タイプ (0 ～ 3、0 = 最小、1 = 最大、2 = 平均 (インデックスパラメータが -1 の場合は無効)、3 = 推奨 (インデックスパラメータが -1 の場合は無効)、デフォルト = 0)

 指定の欠陥について、最小、最大、平均、または推奨のコントラスト統計を返します。

GetBeadDefectCount(ビード検査, [タイプ])

タイプ (-1 ～ 9、デフォルト = 0)

-1 | 複数のタイプがある欠陥の数
0 | すべての欠陥
1 | カバレージ:最小 (アンダーフィル)
2 | カバレージ:最大 (オーバーフィル)
3 | 幅:最小 (狭すぎる)
4 | 幅:最大 (広すぎる)
5 | ステップの変化
6 | 両方のエッジがありません
7 | 第 1 エッジがありません
8 | 第 2 エッジがありません
9 | ビードを検出できません
 指定のタイプに対して検出された欠陥の数を返します。

GetBeadDefectCoverage(ビード検査, [インデックス*], [タイプ])

タイプ (0、1 または 2、0 = 最小、1 = 最大、2 = 平均 (インデックスパラメータが -1 の場合は無効)、デフォルト = 0)

注:
  • 欠陥ごとに推奨値は 1 つだけです。推奨値は、両方のエッジを固定する最大値です。これは、欠陥を除去するために [コントラストしきい値] パラメータに入力する値です。
  • タイプ = 3 の場合、[エッジ] パラメータは有効ではありません。
指定の欠陥について、最小、最大、または平均のコントラスト統計を返します。

GetBeadDefectEdgeOffset(ビード検査, [インデックス*], [タイプ], [エッジ], [形式])

タイプ (0 ～ 3、0 = 最小、1 = 最大、2 = 平均 (インデックスパラメータが -1 の場合は無効)、3 = 推奨 (インデックスパラメータが -1 の場合は無効)、デフォルト = 0)

注:
  • 欠陥ごとに推奨値は 1 つだけです。推奨値は、両方のエッジを固定する最大値です。これは、欠陥を除去するために [ビードエッジ位置の許容値] パラメータに入力する値です。
  • タイプ = 3 の場合、[エッジ] パラメータは有効ではありません。

指定の欠陥について、最小、最大、平均、または推奨のエッジオフセットを返します。

GetBeadDefectLength(ビード検査, [インデックス*], [タイプ])

タイプ (0 または 1、0 = 最小、1 = 最大、デフォルト = 0)

注: [タイプ] パラメータは、インデックスが -1 の場合にのみ有効です。

 指定の欠陥の長さ (ピクセル単位) を返します。

GetBeadDefectRow(ビード検査, [インデックス], [タイプ])

タイプ (0 または 1、0 = 開始インデックス、0 = 終了インデックス、デフォルト = 0)

 指定のインデックスの欠陥の Y 座標を返します。

GetBeadDefectStep(ビード検査, [インデックス**], [エッジ])

インデックス** (-1 ～ 欠陥の数 -1、-1 = 最大ステップ変化のパーセンテージによって欠陥を検出し、インデックス値を返します。デフォルト = 0)

 指定の欠陥について、最大ステップ変化統計を返します。

GetBeadDefectType(ビード検査, [インデックス], [形式*])

形式* (0 ～ 1、デフォルト = 0)
0 | 欠陥タイプを整数で表示します。この整数はバイナリ値に変換され、指定の欠陥に含まれているすべての欠陥タイプを表します。 Closed 例: タイプ = 133、 133 (10 進数) = 1000 0101 (バイナリ)。 位置チャートによると (左から右に読み取ります)、欠陥タイプを示す位置 1、 3、および 8 は、[カバレージ:最小 (アンダーフィル)]、[幅:最小 (狭すぎる)]、および [第 2 エッジがありません] です。
1 | 欠陥タイプを文字列形式で表示します。対応する位置は、0 または欠陥タイプを示す位置番号のいずれかです。 Closed 例: タイプ = 8000 0301。 位置チャートによると (左から右に読み取ります)、欠陥タイプを示す位置 1、 3、および 8 は、[カバレージ:最小 (アンダーフィル)]、[幅:最小 (狭すぎる)]、および [第 2 エッジがありません] です。
位置チャート:
1 | 2 | 3 | 4 | 5 | 6 | 7 | 8 | 9
カバレージ:最小 (アンダーフィル) | カバレージ:最大 (オーバーフィル) | 幅:最小 (狭すぎる) | 幅:最大 (広すぎる) | ステップの変化 | 両方のエッジがありません | 第 1 エッジがありません | 第 2 エッジがありません | ビードを検出できません
 指定した欠陥の分類タイプを返します。

GetBeadDefectWidth(ビード検査, [インデックス*], [タイプ], [形式])

タイプ (0、1 または 2、0 = 最小、1 = 最大、2 = 平均 (インデックスパラメータが -1 の場合は無効)、デフォルト = 0)

 指定した欠陥について、最小、最大、または平均のビード幅統計を返します。

GetBeadCaliperContrast(ビード検査, [タイプ], [エッジ], [開始インデックス], [キャリパの数])

Type (0、1、または 2、0 = 最小、1 = 最大、2 = 平均、デフォルト = 0)

 指定した欠陥について、最小、最大、または平均のビードコントラスト統計を返します。

GetBeadCaliperCoverage(ビード検査, [タイプ], [開始インデックス], [キャリパの数])

Type (0、1、または 2、0 = 最小、1 = 最大、2 = 平均、デフォルト = 0)

 キャリパの範囲について、最小、最大、または平均のビードのカバレージ統計を返します。

GetBeadCaliperEdgeOffset(ビード検査, [タイプ], [エッジ], [形式], [開始インデックス], [キャリパの数])

Type (0、1、または 2、0 = 最小、1 = 最大、2 = 平均、デフォルト = 0)

 キャリパの範囲について、最小、最大、または平均の登録パスからのビードオフセットを返します。

GetBeadCaliperMax(ビード検査, [タイプ], [エッジ], [開始インデックス], [キャリパの数])

Type (0 ～ 4、0 = カバレージ、1 = 幅、2 = ステップ、3 = コントラスト、4 = 移動距離)

注: Type = 0 または 1 の場合、Edge パラメータは有効ではありません。

指定したタイプの測定について、最大値を検出したキャリパのインデックスを返します。

注: 戻り値 -1 は、範囲内のすべてのキャリパがマスクエリア内にあることを示します。

GetBeadCaliperMin(ビード検査, [タイプ], [エッジ], [開始インデックス], [キャリパの数])

Type (0 ～ 4、0 = カバレージ、1 = 幅、2 = ステップ、3 = コントラスト、4 = 移動距離)

注: Type = 0 または 1 の場合、Edge パラメータは有効ではありません。

指定したタイプの測定について、最小値を検出したキャリパのインデックスを返します。

注: 戻り値 -1 は、範囲内のすべてのキャリパがマスクエリア内にあることを示します。

GetBeadCaliperWidth(ビード検査, [タイプ], [形式], [開始インデックス], [キャリパの数])

Type (0、1、または 2、0 = 最小、1 = 最大、2 = 平均、デフォルト = 0)

 キャリパの範囲について、最小、最大、または平均のビード幅統計を返します。

GetBeadCaliperStep(ビード検査, [タイプ], [エッジ], [開始インデックス], [キャリパの数])

Type (0、1、または 2、0 = 最小、1 = 最大、2 = 平均、デフォルト = 0)

 キャリパの範囲で、最小、最大、または平均のビードステップ変化の統計を返します。
GetNumCalipers(ビード検査) | BeadInspect 関数内のキャリパの数を返します。

ShowBeadCaliperGraphic(ビード検査, [タイプ], [表示], [開始インデックス], [キャリパの数])

タイプ (0 または 1、0 = 領域、1 = 最大、デフォルト = 0)

表示 (0 または 1、0 = グラフィックスを非表示、1 = グラフィックスを非表示、デフォルト = 0)

キャリパの範囲について、境界領域またはエッジグラフィックスを表示します。
Version: 5.6.0


Blobs 関数

Blobs 関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。[インデックス] (ゼロから始まる) は、構造体からインデックスされているブロブを決定します。インデックスを指定しない場合、インデックスはデフォルトでゼロとなります (つまり、最初のブロブが返されます)。

関数

説明

GetAngle(ブロブ, インデックス)

ROI の中心に対するブロブの重心の角度を返します。

GetArea(ブロブ, インデックス)

ブロブの面積 (ピクセル単位) を返します。

GetCol(ブロブ, インデックス)

ブロブの重心の X 座標 (列) を返します。

GetColor(ブロブ, インデックス)

ブロブの色の値 (0 = 黒、1 = 白) を返します。

GetElongation(ブロブ, インデックス)

指定されたブロブの伸長を返します。

GetHigh(ブロブ, インデックス)

インデックス付きブロブの高さを返します。

GetHoles(ブロブ, インデックス)

ブロブに含まれている穴の数を返します。

GetMaxCol(ブロブ, インデックス)

ブロブの最大列の値を返します。

GetMaxColRow(ブロブ, インデックス)

最大 (右端) 列座標での行座標を返します。

GetMaxRow(ブロブ, インデックス)

ブロブの最大行の値を返します。

GetMaxRowCol(ブロブ, インデックス)

最大 (下端) 行座標での列座標を返します。

GetMinCol(ブロブ, インデックス)

ブロブの最小 (左端) 列座標を返します。

GetMinColRow(ブロブ, インデックス)

最小 (左端) 列座標での行座標を返します。

GetMinRow(ブロブ, インデックス)

ブロブの最小行の値を返します。

GetMinRowCol(ブロブ, インデックス)

最小 (上端) 行座標での列座標を返します。

GetNFound(ブロブ)

指定された ROI 内で検出されたブロブの数を返します。

GetPerimeter(ブロブ, インデックス)

ブロブの周囲長 (ピクセル単位) を返します。

GetPolygon(ブロブ, インデックス, [表示])

指定のブロブの境界点を表す [image] データ構造体を返します。 データ構造体は、[外部領域] パラメータのある関数の入力として使用することができます。ブロブ領域内での画像処理の実行が可能となります。

注:
  • [表示] パラメータを任意で指定できます。0 (デフォルト) に設定すると、GetPolygon セルが選択されている場合にだけポリゴングラフィックスが表示されます。1 に設定すると、常に表示されます。
  • ポリゴンの長さが約 4950 点を超過する場合、そのポリゴンはグラフィカルに表示されません。

GetRow(ブロブ, インデックス)

ブロブの重心の Y 座標 (行) を返します。

GetScore(ブロブ, インデックス)

ブロブの得点値を返します。

GetSpread(ブロブ, インデックス)

ブロブの拡散の値を返します。

GetThresh(ブロブ)

ブロブの、手動で 2 値化されたしきい値、または最適化された値 (-1 で [自動] を指定した場合) のいずれかを返します。

GetWide(ブロブ, インデックス)

インデックス付きブロブの幅を返します。


CircleFit 関数

CircleFit 関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。

関数 | 説明
GetCol(サークルフィット) | 円の中心の Y 座標を返します。
GetDistance(サークルフィット, インデックス) | インデックス付きの点と円の間の距離を返します。値が負の場合、点は円の中にあります。インデックス付きの点が無効な場合、#ERR を返します。
GetMaxDist(サークルフィット) | 円と円から最も遠い点の間の距離を返します。値が負の場合、点は円の中にあります。
GetMaxDistIndex(サークルフィット) | 円から最も遠い点のインデックスを返します。
GetNPointsUsed(サークルフィット) | 円をフィッティングするために使われる点の数を返します。
GetRadius(サークルフィット) | 円の半径を返します。
GetRow(サークルフィット) | 円の中心の X 座標を返します。
GetSigma(サークルフィット) | 点から円への、点の数で割った距離の二乗の合計の平方根を返します。


クロックドデータ関数

クロックドデータ関数 |
データアクセス | In-Sight 関数リファレンス

注:
  • GetCount、GetMax、GetMean、GetMin、GetSDev、GetSum および GetValue 関数はそれぞれ、最初のパラメータとして [image] データ構造体を参照します。
  • GetErrorCount、GetFailCount、GetPassCount および GetTotalCount 関数では、返される値は参照される [image] 構造体から取得され、CountPassFail 関数の作成時にスプレッドシートに挿入されます。

関数

説明
GetCount(ディレイ) | 構造体のカウント値を返します。
GetErrorCount(カウント) | 構造体から増分エラー数を返します。エラー数は、返される値がゼロよりも小さい場合にインクリメントされます。
GetFailCount(カウント) | 構造体から増分不合格数を返します。不合格数は、値がゼロの場合にインクリメントされます。

GetLoopCount(ループ)

データ構造体に格納された、Repeat または RepeatUntil 関数によって実行される繰り返し反復の現在のインデックスを返します。

注: 正常な検査を確実に実行するには、ループの操作対象として選択したセルに GetLoopCount 関数を入れます。そうしない場合、関数は 1 度しか検査されず、ループと同期した更新は実行されません。

GetLoopReset(ループ)

データ構造体に格納された、Repeat または RepeatUntil 関数による繰り返し反復を最初に実行する前に 1 (TRUE) を返します。StoreData 関数のセルなど、ループ内にデータを保持する関数のデータのクリアにも使用することができます。

注: 正常な検査を確実に実行するには、ループの操作対象として選択したセルに GetLoopReset 関数を入れます。そうしない場合、関数は 1 度しか検査されず、ループと同期した更新は実行されません。
GetMax(ディレイ) | 構造体の最大値を返します。
GetMean(ディレイ) | 構造体の平均値を返します。
GetMin(ディレイ) | 構造体の最小値を返します。
GetPassCount(Count) | 構造体から増分合格数を返します。合格数は、値がゼロよりも大きい場合にインクリメントされます。

GetSDev(ディレイ)

構造体の標準偏差値を返します。

注: この計算は偏りのある標準偏差で、分母は N-1 です (不偏標準偏差では分母は N です)。

GetSum(ディレイ)

 構造体の合計値を返します。
GetTotalCount(カウント) | 構造体から、合格、不合格、およびエラーの総数を返します。

GetValue(ディレイ)

 構造体に格納されている値を返します。


カラー関数

カラー関数 |
カラーデータアクセス | In-Sight 関数リファレンス

注: 以下の各関数の場合、最初のパラメータが、カラーデータ構造を含んでいるセルを参照します。構造体の名前は、作成したカラーツールに従って付けられます。TrainExtractColor 関数は [image] データ構造体を作成し、TrainMatchColor 関数は [image] データ構造体を作成し、ExtractColor 関数と MatchColor 関数は [image] を作成します。GetColorLibraryName 関数を使用して、データ構造体を作成したツールを判別することができます。

関数 | 説明
GetActiveExtClrModelName(色, インデックス) | ExtractColor 関数のインデックス付きのアクティブなカラーモデルの名前を返します。
GetActiveMatchClrColorName(色, インデックス) | MatchColor 関数のインデックス付きのアクティブなカラー名を返します。
GetArea(色抽出) | 抽出された色の面積 (ピクセル数) を返します。 注: ファームウェアバージョン 5.3.0 以上を実行している In-Sight ビジョンシステムでサポートされます。
GetBlue(色) | MatchColor 関数の対象領域 (ROI) における平均的な色の青成分を返します。
GetColorLibraryName(色構造) | TrainExtractColor 関数、TrainMatchColor 関数、ExtractColor 関数、MatchColor 関数とともに動作します。TrainExtractColor 関数と TrainMatchColor 関数の場合、関数によって保存されたカラーライブラリの名前を返します。ExtractColor 関数と MatchColor 関数の場合、参照元の登録関数 (それぞれ、TrainExtractColor 関数または TrainMatchColor 関数など) の名前を返します。
GetConfidenceScore(色) | MatchColor 関数の現在の検査の信頼性得点を返します。信頼性得点 = ( s1 × (M - s2) - s2 × (M - s1)) / ( (M - s2) + (M - s1))。s1 は最高得点、s2 は 2 番目に高い得点、M は 1.01 に等しい定数です。信頼性得点が高いほど、最適一致が選択される可能性が高くなります。
GetExtClrColorModelState(色, カラーモデル名) | ExtractColor 関数の指定のカラーモデルの状態を返します。
GetExtClrModelByRank(色, ランク) | ExtractColor 関数の指定のピクセル計数ランクを持つカラーモデルのインデックスを返します。0 が最も高いランクで、n-1 が最も低いランクです。
GetGreen(色) | MatchColor 関数の (ROI) における平均的な色の緑成分を返します。
GetHue(色) | MatchColor 関数の (ROI) における平均的な色の色相成分を返します。
GetIntensity(色) | MatchColor 関数の (ROI) における平均的な色の明度成分を返します。
GetMatchClrColorByRank(色, ランク) | MatchColor 関数のランク (0 ～ n-1) に一致する色のインデックスを返します。ランクが 0 の色が最高得点を持っています。
GetMatchClrColorState(色, カラー名) | MatchColor 関数の指定の色の状態を返します。
GetMatchClrDistByIndex(色, インデックス) | MatchColor 関数のインデックス付きの色の距離を返します。
GetMatchClrDistByName(色, 名前) | MatchColor 関数の名前付きの色の距離を返します。
GetMatchClrScoreByIndex(色, インデックス) | MatchColor 関数のインデックス付きの色の得点を返します。
GetMatchClrScoreByName(色, 名前) | MatchColor 関数の名前付きの色の得点を返します。
GetNActiveExtClrModels(色) | 参照元の ExtractColor 関数のアクティブな参照元のカラーモデルの数を返します。
GetNActiveMatchClrColors(カラーライブラリ) | 参照元の MatchColor 関数のアクティブな参照元の色の数を返します。
GetNTrainExtClrModels(カラーライブラリ抽出) | TrainExtractColor 関数によって保存されたカラーモデルの数を返します。
GetNTrainMatchClrColors(カラーライブラリ) | TrainMatchColor 関数によって保存された色の数を返します。
GetOverallPixelCount(色) | ExtractColor 関数のアクティブな全カラーモデルの組み合わせであるピクセル計数を返します。
GetPixelCountByIndex(色, インデックス) | ExtractColor 関数のインデックス付きカラーモデルのピクセル計数を返します。
GetPixelCountByName(色, 名前) | ExtractColor 関数の名前付きカラーモデルのピクセル計数を返します。
GetRed(色) | MatchColor 関数の (ROI) における平均的な色の赤成分を返します。
GetSaturation(色) | MatchColor 関数の (ROI) における平均的な色の彩度成分を返します。
GetTrainExtClrModelName(カラーライブラリ抽出, インデックス) | ExtractColor 関数のインデックス付きのカラーモデルの名前を返します。
GetTrainMatchClrColorName(カラーライブラリ, インデックス) | MatchColor 関数のインデックス付きの保存されたカラー名を返します。
SetExtClrColorModelState(色, 有効化, カラーモデル名 1, [カラーモデル名 2,...]) | ExtractColor 関数で有効または無効にされたカラーモデルの数を返します。この関数が初めてスプレッドシートに挿入されたときには、そのセルの状態は無効になっています。Button 関数によって条件付きで有効にする必要があります。
SetMatchClrColorState(色, 有効化, カラー名 1, [カラー名 2,...]) | MatchColor 関数で有効または無効にされた色の数を返します。この関数が初めてスプレッドシートに挿入されたときには、そのセルの状態は無効になっています。Button 関数によって条件付きで有効にする必要があります。


カラーヒストグラム関数

カラーヒストグラム関数 |
カラーデータアクセス | In-Sight 関数リファレンス

関数

説明

GetValue(カラーヒストグラム, インデックス, [色])

データ構造体の指定された色のインデックス付きビン (0 ～ 255) に含まれる値を返します。

色は、ヒストグラムデータを取得する色成分を決定する任意のパラメータです。指定しない場合、このパラメータはデフォルト設定の 0 (赤) になります。

0 = 赤 | データ構造体から赤成分を選択します。
1 = 緑 | 構造体から緑成分を選択します。
2 = 青 | 構造体から青成分を選択します。
3 = 色相 | 構造体から色相成分を選択します。
4 = 彩度 | 構造体から彩度成分を選択します。
5 = 明度 | 構造体から明度成分を選択します。


オペレータ I/F 関数

オペレータ I/F 関数 |
データアクセス | In-Sight 関数リファレンス

注:
  • GetAuthorizeApprover 関数と GetAuthorizeDateTime 関数は、Authorize 関数セルを参照します。
  • GetAuthorizedValue 関数は、Authorize 関数によって参照されているサポートされるエディットコントロールセルを参照します。
  • GetString 関数は、ListBox 関数を含んでいるセルを参照します。

関数 | 説明
GetAuthorizeApprover(認証) | Authorize 関数のタイプが Authorize-Only または Double-Blind に設定されている場合は、最後に正常な認証を実行した承認者の名前を返します。タイプが None に設定されている場合は、新しい値を入力したユーザの名前を返します。
GetAuthorizeDateTime(認証) | 最後に正常な認証が実行された日付と時刻を返します。日付と時刻の形式: MM/DD/YYYY HH:MM:SS
GetAuthorizedValue(制御) | 参照されているエディットコントロールの値を返します。エディットコントロールが認証されていない場合は、現在の値を返します。 注:GetAuthorizedValue 関数は常に文字列タイプの値を返します。この関数の数値出力を別の関数への入力として使用するには、Value 関数を使用して文字列を数値に変換します。
GetString(リストボックス) | テキスト文字列を返します。ListBox 関数を含んでいるセルが参照されている場合、現在リストから選択されているテキスト文字列が返されます。


距離関数

距離関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。

関数 | 説明
GetAngle(距離, インデックス) | 角度の値を返します。
GetCol(距離, インデックス 1, インデックス 2) | 列の値を返します。
GetDistance(距離) | 距離の値を返します。
GetRow(距離, インデックス 1, インデックス 2) | 行の値を返します。


エッジ関数

エッジ関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。

関数 | 説明
GetAngle(エッジ, インデックス) | インデックス付きのエッジの角度を返します。
GetCol(エッジ, インデックス 1, インデックス 2) | インデックス付きエッジの指定された列の値を返します。インデックス 1 ではエッジ番号を選択し、インデックス 2 では点 (0 = 左端の点、1 = 右端の点、2 = 中点) を指定します。
GetContrast(エッジ) | 検出された前景と背景の平均コントラスト (グレースケール階調で、0～255) を返します。コントラストは黒→白の場合は正の値、白→黒の場合は負の値になります。 構造体は FindCircleMinMax 関数で作成されている必要があります。
GetEdgeDistance(エッジ) | 2 つのエッジ (エッジペア) 間の距離を返します。 構造体は Caliper 関数で作成されている必要があります。
GetMax(エッジ) | 最良エッジの最大偏差の半径を返します。 構造体は FindCircleMinMax 関数で作成されている必要があります。
GetMin(エッジ) | 最良エッジの最小偏差の半径を返します。 構造体は FindCircleMinMax 関数で作成されている必要があります。
GetNFound(エッジ) | 検出されたエッジの数を返します。
GetPosition(エッジ, インデックス) | エッジまたはエッジペアの中心の領域 X 位置を返します。 構造体は Caliper 関数で作成されている必要があります。
GetRadius(エッジ, インデックス) | インデックス付きカーブエッジの半径を返します。
GetRow(エッジ, インデックス 1, インデックス 2) | インデックス付きエッジの指定された行の値を返します。インデックス 1 ではエッジ番号を選択し、インデックス 2 では点 (0 = 上端の点、1 = 下端の点、2 = 中点) を指定します。
GetScore(エッジ, インデックス) | インデックス付きエッジの得点を返します。得点は、黒→白への遷移の場合は正の値、白→黒への遷移の場合は負の値になります (ただし、FindSegment および FindCircleMinMax では、得点は常に正の値です)。
GetSDev(エッジ) | 標準偏差の値を返します。 構造体は FindCircleMinMax 関数で作成されている必要があります。 注: この計算は偏りのある標準偏差で、分母は N-1 です (不偏標準偏差では分母は N です)。


傷検出関数

傷検出関数 |
データアクセス | In-Sight 関数リファレンス

関数 | 説明
GetNFound(傷検査) | 検出された傷の総数を返します。
GetTrained(傷モデルの登録) | TrainFlawModel 関数でモデルを登録できた場合には 1、登録できなかった場合には 0 を返します。
GetTotalFlawArea(傷検査) | SurfaceFlaw 関数で検出されたすべての欠陥の総面積を返します。
GetTotalFlawCount(傷検出, すべて/面積/エッジの欠落/余分なエッジ) | 指定されたタイプの欠陥の総数、またはすべての欠陥の総数を返します (すべて = -1、面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。
GetTotalFlawSize(傷検出, すべて/面積/エッジの欠落/余分なエッジ) | 特定の欠陥に分類されるピクセルの総数、または何らかの欠陥として分類されるピクセルの総数を返します (すべて = -1、面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。
GetFlawType(傷検出, インデックス) | 指定された欠陥のタイプを返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。
GetFlawSize(傷検出, 面積/エッジの欠落/余分なエッジ, インデックス) | 指定された欠陥に含まれるピクセルの数を返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。インデックス値の範囲は、欠陥の種類によって異なります (インデックス = 0 から GetTotalFlawCount によって返される総数 -1)。
GetFlawContrast(傷検出, 面積/エッジの欠落/余分なエッジ, インデックス) | 指定された欠陥のコントラスト値を返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。インデックス値の範囲は、欠陥の種類によって異なります (インデックス = 0 から GetTotalFlawCount によって返される総数 -1)。
GetFlawRow(傷検出, 面積/エッジの欠落/余分なエッジ, インデックス) | 指定された欠陥の境界ボックスの行座標を返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。インデックス値の範囲は、欠陥の種類によって異なります (インデックス = 0 から GetTotalFlawCount によって返される総数 -1)。
GetFlawCol(傷検出, 面積/エッジの欠落/余分なエッジ, インデックス) | 指定された欠陥の境界ボックスの列座標を返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。インデックス値の範囲は、欠陥の種類によって異なります (インデックス = 0 から GetTotalFlawCount によって返される総数 -1)。
GetFlawHigh(傷検出, 面積/エッジの欠落/余分なエッジ, インデックス) | 指定された欠陥の境界ボックスの高さを返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。インデックス値の範囲は、欠陥の種類によって異なります (インデックス = 0 から GetTotalFlawCount によって返される総数 -1)。
GetFlawWide(傷検出, 面積/エッジの欠落/余分なエッジ, インデックス) | 指定された欠陥の境界ボックスの幅を返します (面積 = 0、エッジの欠落 = 1、余分なエッジ = 2)。インデックス値の範囲は、欠陥の種類によって異なります (インデックス = 0 から GetTotalFlawCount によって返される総数 -1)。
GetMatchScore(Flex 傷モデル) | Flex アルゴリズム適用前のエッジ一致得点を示す得点を返します。
GetFlexScore(Flex 傷モデル) | Flex アルゴリズム適用後のエッジ一致得点を示す得点を返します。
Version: 5.6.0


フォント関数

フォント関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。

関数 | 説明
GetFontLabel(フォント, インデックス) | インデックス付き文字モデルのラベルを返します。
GetFontAllLabels(フォント) | フォント内の登録済み文字すべてのラベルのリストを返します。
GetFontName(フォント) | フォントの名前を返します。
GetFontNumCharacter(フォント) | 登録済み文字モデルの数を返します。


GetErrorCode 関数

データアクセス

In-Sight 関数リファレンス

GetErrorCode 関数大部分の構造体および関数から診断コードを返す、データアクセス関数です。

注: #ERR に対応するエラーコードがない場合、GetErrorCode 関数は -1 を返します。

の使用方法GetErrorCode 関数

一般的なシンタックスはGetErrorCode 関数次のとおりです。

   GetErrorCode(Structure)


GetErrorString 関数

データアクセス

In-Sight 関数リファレンス

GetErrorString 関数大部分の構造体および関数から診断情報を返す、データアクセス関数です。

の使用方法GetErrorString 関数

一般的なシンタックスはGetErrorString 関数次のとおりです。

   GetErrorString 関数(Structure)


GetOnline 関数

GetOnline 関数 |
データアクセス | In-Sight 関数リファレンス

In-Sight センサのオンライン状態を返します。

GetOnline 関数 (

イベント,

)

GetOnline 関数の入力パラメータ

イベント

指定されたイベントトリガでスプレッドシートを更新します。このパラメータは、[トリガ] パラメータが [オンライン/オフライン] に設定された、 [image] 関数を含んでいるセルへの参照である必要があります。

GetOnline 関数の出力

戻り値 | センサがオフラインの場合は 0.000 の値。センサがオンラインの場合は 1.000 の値。
結果 | 初めてこの関数をセルに挿入すると、[トリガ] パラメータが [オンライン/オフライン] に設定された [image] 関数が、自動的に隣接するセルに挿入されます。 注: 隣接するセルにすでにデータが含まれている場合は、警告メッセージが表示され、自動的に [image] 関数が隣接するセルに挿入されることはありません。

GetOnline 関数の例

  1. セル A2 を右クリックして [関数の挿入] をクリックし、[関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [データアクセス] リストを選択します。
  3. 右側のリストで、[GetOnline] をダブルクリックします。GetOnline プロパティシートが開きます。
  4. [OK] をクリックして、プロパティシートのデフォルト設定を受け入れます。[トリガ] パラメータが [オンライン/オフライン] に設定された [image] 関数が、自動的に隣接するセルに挿入されます。セル A2 は、センサがオフラインであることを示す 0.000 を返します。

注: 隣接するセルにすでにデータが含まれている場合は、警告メッセージが表示され、自動的に [image] 関数が隣接するセルに挿入されることはありません。

  5. センサをオンラインにします。セル A2 は、センサがオンラインであることを示す 1.000 を返しています。


ヒストグラム関数

ヒストグラム関数 |
データアクセス | In-Sight 関数リファレンス

関数 | 説明
GetArea(ヒストグラム抽出) | 抽出されたヒストグラムの面積 (ピクセル数) を返します。 注: ファームウェアバージョン 5.3.0 以上を実行している In-Sight ビジョンシステムでサポートされます。
GetValue(ヒストグラム, インデックス) | 指定された [image] データ構造体のインデックス付きビン (0 ～ 255) に含まれる値の数を返します。


ID コード関数

データアクセス

In-Sight 関数リファレンス

注:
  • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。
  • 返される値はすべて、参照される [image] 構造体から取得され、ReadIDCode 関数の作成時にスプレッドシートに挿入されます。

関数

説明

GetAngle(ID コード)

シンボルの角度を返します (PharmaCode、RSS-14 スタックド、RSS リミテッドを除く)。

注:

  • ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。
  • [アルゴリズム] パラメータを ON にする必要があります。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF のとき、角度が 0、90、180、270 度の ± 約 4 度以内である場合、それぞれ 0、90、180、270 度が返されます。

GetBarSkew(ID コード)

ポスタルバーコードのバーのスキューの平均を返します。

注:ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetBarSpace(ID コード)

ポスタルバーコードのバーの平均間隔を返します。

注:ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetBarWidth(ID コード)

ポスタルバーコードのバーの平均幅を返します。

GetCodeName(ID コード)

コード種類の名前を返します。このコード名は、プロパティシートに表示されるものと同じです。

GetCodeType(ID コード)

コード種類を返します。

GetCol(ID コード, [インデックス])

ポスタルシンボルの左上隅の列座標、または 2D シンボルのインデックス (0 ～ 3) 付きファインダパターン頂点の列 (y) 座標をピクセル単位で返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetColor(ID コード)

Data Matrix、QR コード、または PDF417 シンボルの前景色の値 (0 = 黒、1 = 白) を返します。

GetContrast(ID コード)

ポスタルバーコードの前景と背景のグレースケールでの平均コントラストを返します。

注:
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。
  • ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、GetContrast 関数は PDF417 コードに対して #ERR を返します。

GetDecodability(ID コード)

バーコードの最小デコード可能性を返します (RSS スタックドを除く)。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetDefect(ID コード)

平均バーコードコントラストに対する最大エレメント反射非均一性の割合を返します (RSS スタックドを除く)。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetECLevel(ID コード)

Data Matrix または PDF 417 コードの誤り訂正レベルを返します。

GetECMin(ID コード)

バーコード (RSS スタックドを除く) の連続するエレメント間の最小エッジレスポンスを返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetErrorCode(ID コード)

各情報文字列に対するエラーコードを返します。

Closed エラーコードとそれに対応する文字列

注: エラー文字列は、GetErrorString 関数によってスプレッドシートに挿入されます。

診断コード | 対応する情報文字列
00010000 | ビジョンツールエラーです。
00010001 | 無効な画像メモリです。
00010001 | 入力した領域が小さすぎます。
00010002 | 入力した領域が画像境界を超えています。
00019000 | IDMax ビジョンツールエラーです。
04010000 | ReadCompositeCode エラーです。
04010001 | 2D コンポーネントアドレスパターンを検出できません。
04010002 | 無効な 2D コンポーネント画像データが多すぎます。
04010003 | 2D コンポーネントシンボルバージョンを検出できません。
04010004 | 欠落している 2D コンポーネントアドレスパターンを埋めることができません。
04010005 | スキャンラインが無効な画像データを検出しました。
04010006 | スキャンラインが画像境界を超えています。
04010007 | 1D コンポーネントファインダパターンを検出できません。
04010008 | 無効な 1D コンポーネント画像データが多すぎます。
04010009 | 有効なコンポジットシンボルが見つかりません。 注: そのほかのシンボルすべてに対して、04020001 が返されます。
04010010 | 訂正の必要なシンボルエラーが多すぎます。
04010011 | 誤り訂正に失敗しました。
04010012 | 1D と 2D がデコード可能ですが、関連付けられていません。
04010013 | 自動コントラストしきい値計算に失敗しました。
04010014 | コントラスト感度が許容範囲を超えています。
04010015 | スキャンパラメータが許容範囲を超えています。
04020000 | ReadIDCode エラーです。
04020001 | 有効なシンボルが見つかりません。
04020002 | シンボルをデコードできませんでした。

GetErrorCount(ID コード)

2D シンボルで検出された、誤りのあるコードワードの数を返します。この値は、未使用誤り訂正を計算するために使用されます。

GetErrorString(ID コード)

シンボルのデコードに失敗した場合に診断情報を返します。

ReadIDCode のエラー文字列

GetFormat(ID コード)

ReadIDCode 関数の 2D シンボルのフォーマットを表す値を返します。

2D シンボルのフォーマット

GetGrade(ID コード, [ID コード])

コントラスト、変調、欠陥、デコード可能性のテストから受け取った最低グレードを基に、バーコードの全体的な品質のグレードを返します。ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。2 番目の [image] 構造体を、オプションのパラメータとして参照できます。

  • グレード A = 4.0
  • グレード B = 3.0
  • グレード C = 2.0
  • グレード D = 1.0
  • グレード F = 0.0

注: ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、GetGrade 関数は PDF417 コードに対して #ERR を返します。

Closed オプションの 2 番目の ID コードパラメータが使用される場合の戻り値

オプションの ID コードパラメータは、コンポジットシンボルをサポートします。コンポジットシンボルは、線形 1D シンボルの RSS バーコードコンポーネントと 2D CC-A\CC-B コンポジットコンポーネント (EAN/UCC 固有の MicroPDF417 の変形バージョン) の組み合わせです。オプションの ID コードパラメータが使用された場合は、次が返されます。

  • ReadIDCode 関数がデコードに失敗した場合、または [照合] パラメータが OFF の場合は、#ERR が返されます。
  • 2 つの [image] 構造体のデコードされたシンボルが両方とも 1D の場合、または両方とも 2D の場合、GetGrade は #ERR を返します。1 つの [image] 構造体は 1D シンボルを含み、もう 1 つの [image] 構造体は 2D シンボルを含む必要があります。
  • コンポジットシンボルの 2D コンポーネントを含む [image] 構造体が RSS CC-A\CC-B または PDF417 シンボルでない場合は、GetGrade は #ERR を返します。
  • コンポジットシンボルの 1D コンポーネントを含む [image] 構造体が RSS シンボルでない場合、GetGrade は、2 つの入力 ID コードのグレードのうちの低い方を返します。
  • コンポジットシンボルの 1D コンポーネントを含む [image] 構造体が RSS シンボルである場合、GetGrade は、コンポジットリンケージフラグを確認します。フラグが合格の場合 (つまり、1D と 2D のシンボルが結合されている場合)、2 つのグレードのうちの低い方を返します。フラグが不合格の場合 (つまり、1D と 2D のシンボルが結合されていない場合)、GetGrade は 0 を返します。

GetGridCols(ID コード)

2D シンボルに含まれている列数を返します。

GetGridRows(ID コード)

2D シンボルに含まれている行数を返します。

GetGrowth(ID コード)

2D シンボルの水平および垂直の印刷拡張が個別に計算され、低い方の得点が返されます。 印刷拡張テスト結果を返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetHigh(ID コード)

シンボルの高さを返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetLearned(ID コード)

シンボルのモデルが学習できた場合には 1 を返し、学習できなかった場合には 0 を返します。

GetLearnedGridCol(ID コード)

学習済みの QR コード、または Data Matrix シンボル内の列数を返します。

GetLearnedGridRow(ID コード)

学習済みの QR コード、または Data Matrix シンボル内の行数を返します。

GetMaxBarSkew(ID コード)

ポスタルバーコードのバーの最大スキューを返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetMaxBarWidth(ID コード)

ポスタルバーコードのバーの最大幅を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetMaxSpaceWidth(ID コード)

ポスタルバーコードのバーの最大間隔を返します。

注:ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetMinBarSkew(ID コード)

ポスタルバーコードのバーの最小スキューを返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetMinBarWidth(ID コード)

ポスタルバーコードのバーの最小幅を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetMinSpaceWidth(ID コード)

ポスタルバーコードのバーの最小間隔を返します。

注:ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetMirror(ID コード)

Data Matrix または QR コードシンボルの鏡像化の状態 (0 = 鏡像にしない、1 = 鏡像にする) を返します。

GetModulation(ID コード)

バーコード (RSS スタックドを除く) の平均コントラストに対する最小エッジレスポンス (ECMin) の割合を返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetNBars(ID コード)

ポスタルバーコードで検出されるバーの数を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetNonUniformity(ID コード)

2D シンボル (PDF417 シンボルを除く) の軸非均一性のテスト結果を返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetNumEdges(ID コード)

照合された RSS CC-A\CC-B シンボルコンポーネントの 1 つの有効なスキャンラインで検出されるエッジの総数を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数では、[アルゴリズム] パラメータを OFF にする必要があります。

GetQuietZonesCheck(ID コード)

シンボルの平均コントラストに対する、2D RSS CC-A\CC-B シンボルのクワイエットゾーンで検出される最大非均一性の割合を返します。ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数では、[アルゴリズム] パラメータを OFF にする必要があります。

GetRawStream(ID コード)

Code 128 シンボルの読み取りシンボルから、デコードされていないデータストリームを返します。

GetReflectanceDark(ID コード)

2D RSS CC-A\CC-B またはポスタルシンボルの最小 (暗) 反射を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetReflectanceLight(ID コード)

2D RSS CC-A\CC-B またはポスタルシンボルの最大 (明) 反射を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetResolution(ID コード)

ポスタルバーコードで最小 (最も狭い) エレメントの幅を返します。2D シンボルの場合、セルの平均サイズ (ピクセル単位) を返します。

GetRow(ID コード, [インデックス])

ポスタルシンボルの左上隅の行座標、または 2D シンボルのインデックス (0 ～ 3) 付きファインダパターン頂点の行 (y) 座標をピクセル単位で返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetSDevBarSkew(ID コード)

ポスタルバーコードのバーのスキューの標準偏差を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetSDevBarSpace(ID コード)

ポスタルバーコードのバーの間隔の標準偏差を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetSDevBarWidth(ID コード)

ポスタルバーコードのバーの幅の標準偏差を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetSDevContrast(ID コード)

ポスタルバーコードの前景と背景のグレーレベルでのコントラストの標準偏差を返します。

注:
  • この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • ReadIDCode 関数の [アルゴリズム] パラメータが OFF の場合、[照合] チェックボックスを ON にする必要があります。ReadIDCode 関数の [アルゴリズム] パラメータが ON の場合、この関数は VerifyIDCode 関数を参照する必要があります。

GetString(ID コード)

シンボル内でエンコードされている文字列を返します。

GetSymbologyIdentifier(ID コード)

ISO 15424 仕様に基づき、シンボルのタイプを 3 文字コードとして返します。

注: [アルゴリズム] パラメータを ON にする必要があります。

GetUnusedEC(ID コード)

2D シンボルの未使用誤り訂正テストの結果 (%) を返します。

GetWide(ID コード)

シンボルの幅を返します。

注: ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。


IDMax 関数

データアクセス

In-Sight 関数リファレンス

注: 返される値はすべて、参照元の [image] 構造体から取得され、 ReadIDMax 関数の作成時にスプレッドシートに挿入されます。 必要に応じてインデックスを使用して、ReadIDMax 関数の結果テーブルからインデックス付き文字列を参照することができます。

関数

説明

GetAngle(ID 最大,[インデックス])

シンボルの角度を返します (PharmaCode および DataBar シンボルを除く)。

注:ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetCodeName(ID 最大,[インデックス])

コード種類の名前を返します。このコード名は、ReadIDMax プロパティシートに表示されるものと同じです。

GetCodeType(ID 最大,[インデックス])

コード種類を返します。

Closed コード種類と対応するコード名を参照してください。

コード種類 | 対応するコード名
1 | Code 128
0 | Code 39
2 | ITF-14
7 | Pharmacode
3/4 | UPC/EAN
11 | Code 93
12 | Codabar
128 | Data Matrix
129 | QR Code
132 | PDF 417
9 | DataBar
10 | DataBar Limited
12 | DataBar Expanded
16 | EAN.UCC Composite
5 | POSTNET
6 | PLANET
14 | Japan Post
13 | Australia Post
8 | UPU
15 | Intelligent Mail Barcode

GetCol(ID 最大, [インデックス 1], [インデックス 2])

POSTNET、PLANET、またはポスタルシンボルの左上隅の列座標、または 2D シンボルのインデックス (0 ～ 3) 付きファインダパターン頂点の列 (y) 座標をピクセル単位で返します。2 番目のインデックスはインデックス付きシンボルを識別します。

注:ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetColor(ID 最大,[インデックス])

Data Matrix、QR コード、または PDF417 シンボルの前景色の値 (0 = 黒、1 = 白) を返します。

GetContrast(ID 最大,[インデックス])

バーコードの前景と背景のグレースケール値での平均コントラストを返します。これは、シンボルの最も暗いエレメントと最も明るいエレメント間のコントラスの尺度になります。高品質のシンボルの場合、シンボルの前景と背景間のコントラストの割合が高くなります。

  • グレード A (4.0) ≥ 70%
  • グレード B (3.0) ≥ 55%
  • グレード C (2.0) ≥ 40%
  • グレード D (1.0) ≥ 20%
  • グレード F (0.0) < 20%

GetDecodability(ID 最大,[インデックス])

バーコードの最小デコード可能性を返します (DataBar バーコードを除く)。印刷精度の尺度であるデコード可能性は、印刷プロセスで使われなかった使用可能な許容誤差の割合であるため、リーダで使用できます。各スキャンラインの文字ごとに、基準しきい値が計算され、モジュールの幅しきい値の尺度になります。各文字の最も幅のある狭いエレメントと最も狭い幅のエレメントがこのしきい値と比較されて、デコード可能性が決定されます。

  • グレード A (4.0) ≥ .62
  • グレード B (3.0) ≥ .50
  • グレード C (2.0) ≥ .37
  • グレード D (1.0) ≥ .20
  • グレード F (0.0) < .20

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。
GetDecoded(ID 最大,インデックス) | インデックスで指定された ID シンボルが検出されたかどうかを返します。検出されなかった場合は 0.0 を返し、検出された場合は 1.0 を返します。

GetDefect(ID 最大,[インデックス])

平均バーコードコントラストに対する最大エレメント反射非均一性の割合を返します (DataBar バーコードを除く)。これは、スペース内の無効なバーまたはスポットの数の尺度になります。

  • グレード A (4.0) ≤ .15
  • グレード B (3.0) ≤ .20
  • グレード C (2.0) ≤ .25
  • グレード D (1.0) ≤ .30
  • グレード F (0.0) > .30

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetECLevel(ID 最大,[インデックス])

Data Matrix または PDF 417 コードの誤り訂正レベルを返します。PDF 417 シンボルは、9 つの誤り訂正レベルをサポートし、徹底度は 0 が最も低く、8 が最も高くなっています。

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetECMin(ID 最大,[インデックス])

バーコード (DataBar バーコードを除く) の連続するエレメント間の最小エッジレスポンスを返します。最小エッジコントラストとも呼ばれる最小エッジレスポンスは、コードの最も質の低い (コントラストの量が最も小さい) エッジの最小コントラストの尺度です。反射率は最大が 100% で、最小は 0% という設定になっています。合格するには、コントラストの最小差が 15% 以上になる必要があります。15% に達さない場合、コードは最小エッジレスポンステストに不合格になります。

  • グレード A (4.0) = 合格
  • グレード F (0.0) = 不合格

注:ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetErrorCode(ID 最大,[インデックス])

各情報文字列に対するエラーコードを返します。

Closed エラーコードとそれに対応する文字列

注: エラー文字列は、GetErrorString 関数によってスプレッドシートに挿入されます。

診断コード | 対応する情報文字列
00010000 | ビジョンツールエラーです。
00010001 | 無効な画像メモリです。
00010001 | 入力した領域が小さすぎます。
00010002 | 入力した領域が画像境界を超えています。
00019000 | IDMax ビジョンツールエラーです。
04010000 | ReadCompositeCode エラーです。
04010001 | 2D コンポーネントアドレスパターンを検出できません。
04010002 | 無効な 2D コンポーネント画像データが多すぎます。
04010003 | 2D コンポーネントシンボルバージョンを検出できません。
04010004 | 欠落している 2D コンポーネントアドレスパターンを埋めることができません。
04010005 | スキャンラインが無効な画像データを検出しました。
04010006 | スキャンラインが画像境界を超えています。
04010007 | 1D コンポーネントファインダパターンを検出できません。
04010008 | 無効な 1D コンポーネント画像データが多すぎます。
04010009 | 有効なコンポジットシンボルが見つかりません。 注: そのほかのシンボルすべてに対して、04020001 が返されます。
04010010 | 訂正の必要なシンボルエラーが多すぎます。
04010011 | 誤り訂正に失敗しました。
04010012 | 1D と 2D がデコード可能ですが、関連付けられていません。
04010013 | 自動コントラストしきい値計算に失敗しました。
04010014 | コントラスト感度が許容範囲を超えています。
04010015 | スキャンパラメータが許容範囲を超えています。
04020000 | ReadIDMax エラー。
04020001 | 有効なシンボルが見つかりません。
04020002 | シンボルをデコードできませんでした。

GetErrorCount(ID 最大,[インデックス])

2D シンボルで検出された、誤りのあるコードワードの数を返します。この値は、未使用誤り訂正を計算するために使用されます。

GetErrorString(ID 最大,[インデックス])

シンボルのデコードに失敗した場合に診断情報を返します。

ReadIDMax のエラー文字列

GetFormat(ID 最大,[インデックス])

ReadIDMax 関数の 2D シンボルのフォーマットを表す値を返します。

2D シンボルのフォーマット

GetFound(ID 最大,インデックス) | インデックスで指定された ID シンボルが検出されたかどうかを返します。検出されなかった場合は 0.0 を返し、検出された場合は 1.0 を返します。

GetGrade(ID 最大)

コントラスト、変調、欠陥、デコード可能性のテストから受け取った最低グレードを基に、バーコードの全体的な品質のグレードを返します。

  • グレード A = 4.0
  • グレード B = 3.0
  • グレード C = 2.0
  • グレード D = 1.0
  • グレード F = 0.0

GetGridCols(ID 最大,[インデックス])

2D シンボルに含まれている列数を返します。

GetGridRows(ID 最大,[インデックス])

2D シンボルに含まれている行数を返します。

GetGrowth(ID 最大,[インデックス])

2D シンボルの水平および垂直の印刷拡張が個別に計算され、低い方の得点が返されます。 印刷拡張テストを返します。結果。このテストは、シンボルのセルのサイズにばらつきがあるかどうかを示します。例えば、一部のマーキング手法では、セルのサイズが増加し、シンボルの左側から右側に移動することは珍しくありません。高品質のシンボルはほとんどあるいはまったく印刷太りを見せません。印刷拡張テスト結果はほとんどの場合、非均一性テスト結果につながります。印刷太りによって、不適切な比率のシンボルになることがあるためです。

  • グレード A (4.0) ≥ -0.50 および ≤ 0.50
  • グレード B (3.0) ≥ -0.70 および ≤ 0.70
  • グレード C (2.0) ≥ -.85 および ≤ 0.85
  • グレード D (1.0) ≥ -1.00 および ≤ 1.00
  • グレード F (0.0) < -1.00 または > 1.00

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetHigh(ID 最大,[インデックス])

シンボルの高さを返します。

注:ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetLearned(ID 最大,[インデックス])

シンボルのモデルが登録された場合には 1 を返し、登録されなかった場合には 0 を返します。

GetLearnedGridCol(ID 最大,[インデックス])

登録済みの QR コード、または Data Matrix シンボル内の列数を返します。

GetLearnedGridRow(ID 最大,[インデックス])

登録済みの QR コード、または Data Matrix シンボル内の行数を返します。
GetLearnedSymbology(ID 最大) | 現在 ReadIDMax で学習された 1D シンボルを含んだ文字列を返します。

GetMirror(ID 最大,[インデックス])

Data Matrix または QR コードシンボルの鏡像化の状態 (0 = 鏡像にしない、1 = 鏡像にする) を返します。

GetModulation(ID 最大,[インデックス])

バーコード (RSS スタックドを除く) の平均コントラストに対する最小エッジレスポンス (ECMin) の割合を返します。このテストは、バーコード全体のコントラストの一貫性を測定します。

  • グレード A (4.0) ≥ .70
  • グレード B (3.0) ≥ .60
  • グレード C (2.0) ≥ .50
  • グレード D (1.0) ≥ .40
  • グレード F (0.0) < .40

注:ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetModuleSize(ID 最大,[インデックス])

2D モジュールのサイズを返します。

GetNonUniformity(ID 最大,[インデックス])

2D シンボル (PDF417 シンボルを除く) の軸の歪み度合いのテスト結果を返します。これは軸の歪み度合いとも呼ばれ、シンボルがグリッドサイズに対して正しい比率になっているかどうかの尺度になります。例えば、同じ数の行と列を持つシンボルが四角くない場合、非均一と見なされます。

  • グレード A (4.0) ≥ 0.06
  • グレード B (3.0) ≥ 0.08
  • グレード C (2.0) ≥ 0.10
  • グレード D (1.0) ≥ 0.12
  • グレード F (0.0) > 0.12

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetNumResults(ID 最大)

検出されたデコード済み結果の数を返します。

GetRawStream(ID 最大,[インデックス])

Code 128 シンボルの読み取りシンボルから、デコードされていないデータストリームを返します。

GetResolution(ID 最大,[インデックス])

ポスタルバーコードで最小 (最も狭い) エレメントの幅を返します。2D シンボルの場合、セルの平均サイズ (ピクセル単位) を返します。特に品質確認テストというわけではありませんが、解像度はシンボル内のエレメント (またはセル) の平均サイズをピクセル単位で測定します。シンボルの各タイプには、最小解像度の仕様があります。

  • Data Matrix: エレメントあたり 4 ピクセル
  • QR Code: エレメントあたり 4 ピクセル
  • PDF 417: エレメントあたり 3 ピクセル
  • EAN/UCC Composite: エレメントあたり 3 ピクセル

GetRow(ID 最大, [インデックス 1],[インデックス 2])

ポスタルシンボルの左上隅の行座標、または 2D シンボルのインデックス (0 ～ 3) 付きファインダパターン頂点の行 (y) 座標をピクセル単位で返します。2 番目のインデックスはインデックス付きシンボルを識別します。

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。

GetString(ID 最大,[インデックス])

インデックス付き結果から文字列を返します。[インデックス] が提供されない場合は、結果 0 を返します。

注: 文字列に NULL (0x00) が含まれている場合、自動的に文字を "<NUL>" に変換します。

GetStringIDMax(ID 最大,変換モード,[インデックス])

選択した変換モード (0 ～ 3、デフォルト = 1) を基準にしてインデックス付き結果から文字列を返します。この変換モードは印刷できない ASCII 文字の処理方法を指定します。

  • 変換モードを 0 に設定した場合、印刷不可の ASCII 文字は変換されません (未処理の文字列が返されます)。Unicode や Shift-JIS などのマルチバイト文字セットを出力する場合は、このモードが便利です。
  • 変換モードを 1 に設定すると、次の表を使用してすべての印刷できない ASCII 文字 (0-31, 127-255) を変換します。
0x00 | "<NUL>"
0x01 | "<SOH>"
0x02 | "<STX>"
0x03 | "<ETX>"
0x04 | "<EOT>"
0x05 | "<ENQ>"
0x06 | "<ACK>"
0x07 | "<BEL>"
0x08 | "<BS>"
0x09 | "<HT>"
0x0a | "<LF>"
0x0b | "<VT>"
0x0c | "<FF>"
0x0d | "<CR>"
0x0e | "<SO>"
0x0f | "<SI>"
0x10 | "<DLE>"
0x11 | "<DC1>"
0x12 | "<DC2>"
0x13 | "<DC3>"
0x14 | "<DC4>"
0x15 | "<NAK>"
0x16 | "<SYN>"
0x17 | "<ETB>"
0x18 | "<CAN>"
0x19 | "<EM>"
0x1a | "<SUB>"
0x1b | "<ESC>"
0x1c | "<FS>"
0x1d | "<GS>"
0x1e | "<RS>"
0x1f | "<US>"
0x7f | "<DEL>"
注: 表にない印刷不可の ASCII 文字は "<X>" に変換されます。この場合、X は 10 進数値です。
  • 変換モードを 2 に設定すると、CR (0x0d) と LF (0x0a) を除いたすべての印刷できない ASCII 文字を変換します。
  • 変換モードを 3 に設定すると、印刷不可のASCII文字は変換されません (未処理の文字列が返されます) が、null 文字は "<NUL>" に置換されます。

GetSymbologyGroup(ID 最大)

ReadIDMax ツールについて選択されたコードグループを返します (0 = Data Matrix、1 = QR コード、2 = 1D/スタックド、3 = ポスタル)。

GetSymbologyIdentifier(ID 最大,[インデックス])

ISO 15424 仕様に基づき、シンボルのタイプを 3 文字コードとして返します。

GetUnusedEC(ID 最大,[インデックス])

2D シンボルの未使用誤り訂正テストの結果 (%) を返します。このテストは、適切なデコードに使用する必要がないシンボルに含まれる誤り訂正の割合を測定します。高品質なシンボルは、誤り訂正を使わなくてもデコードできます。

  • グレード A (4.0) ≥ 0.62
  • グレード B (3.0) ≥ 0.50
  • グレード C (2.0) ≥ 0.37
  • グレード D (1.0) ≥ 0.25
  • グレード F (0.0) < 0.25

GetWide(ID 最大,[インデックス])

シンボルの幅を返します。

注: ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。
SetSymbolMinStringLength(ID 最大,シンボル,最小長)

参照元の IDMax (ID 最大) 構造体の指定されたシンボルの最小文字列長を設定します。Pharmacode(255) と Interleaved 2 of 5(73) のみをサポートします。
Version: 5.6.0


IDValidate 関数

データアクセス

In-Sight 関数リファレンス

注: 返される値はすべて、参照される [image] 構造体から取得され、ValidateIDData 関数の作成時にスプレッドシートに挿入されます。ValidateIDData 関数が ReadIDMax 関数を参照する場合、必要に応じてインデックスを使用して、ReadIDMax 関数の結果テーブルからインデックス付き文字列を参照することができます。

関数

説明

GetCAGECode(ID 有効,[インデックス])

DoD UID データ内の CAGE コードを返します。

GetCAGECodeID(ID 有効,[インデックス])

DoD UID データ内の CAGE コードを表す識別子を返します。

GetDataFormat(ID 有効, [インデックス])

データのエンコードに使用するフォーマットを返します。

GetDiagnosticCode(ID 有効,[インデックス])

診断コードを返します。

Closed 診断コードとそれに対応する診断情報文字列を参照してください。

診断コード | 診断情報文字列
04040000 | データが正常に検証されました。
04040001 | 無効なシンボルの識別子です。
04040003 | 無効なフィールド識別子です。
04040004 | 無効なアプリケーション識別子 (AI) です。
04040005 | 無効なデータ識別子 (DI) です。
04040006 | 無効なテキスト要素識別子 (TEI) です。
04040007 | 無効なフィールドデータです。
04040008 | 無効なフィールドセパレータです。
04040009 | データは ISO 15434 準拠ではありません。
04040010 | サポートされないフォーマットです。
04040011 | 無効なフォーマットコードです。
04040012 | ISO 15434 シンタックスは、このコードではサポートされません。
04040013 | フィールドは、このアプリケーションでは無効です。
04040014 | アプリケーションフィールドはサポートされていません。
04040015 | 無効なアプリケーションデータです。
04040016 | 複数のフォーマットが存在します。
04040017 | 重複するフィールドがあります。
04040018 | 無効な DoD UID コンストラクト #1 データです。
04040019 | 無効な DoD UID コンストラクト #2 データです。
04040020 | 無効な DoD UID データです。
04040021 | フォーマットトレーラ文字が欠落しています。
04040022 | メッセージトレーラ文字が欠落しています。

GetDiagnosticString(ID 有効,[インデックス])

診断情報文字列を返します。

Closed 診断情報文字列を参照してください。

診断情報文字列

データが正常に検証されました。

無効なシンボル識別子です。

無効なフィールド識別子です。

無効なアプリケーション識別子 (AI) です。

無効なデータ識別子 (DI) です。

無効なテキスト要素識別子 (TEI) です。

無効なフィールドデータです。

無効なフィールドセパレータです。

データは ISO 15434 準拠ではありません。

サポートされないフォーマットです。

無効なフォーマットコードです。

ISO 15434 シンタックスは、このコードではサポートされません。

フィールドは、このアプリケーションでは無効です。

アプリケーションフィールドはサポートされていません。

無効なアプリケーションデータです。

複数のフォーマットが存在します。

重複するフィールドがあります。

無効な DoD UID コンストラクト #1 データです。

無効な DoD UID コンストラクト #2 データです。

無効な DoD UID データです。

フォーマットトレーラ文字が欠落しています。

メッセージトレーラ文字が欠落しています。

GetFieldData(ID 有効, インデックス)

インデックス付きフィールド内でエンコードされているデータを返します。

GetFieldIdentifier(ID 有効, インデックス)

インデックス付きフィールド内でエンコードされているアプリケーション識別子 (AI) を返します。

Closed アプリケーション識別子 (AI) と対応する記述を参照してください。

アプリケーション識別子 | アプリケーション識別子の記述
00 | 出荷梱包シリアル番号 (SSCC)
01 | 国際取引商品コード (GTIN)
02 | 含まれている取引商品の GTIN
10 | バッチまたはロット番号
11 | 製造年月日
12 | 期日
13 | 包装年月日
15 | 品質保持期限日（賞味期限日）
1612 | 販売期限 (YYMMDD)
17 | 有効期限
20 | バリアント番号
21 | シリアル番号
22 | 二次データフィールド
240 | 他の商品識別子
241 | 顧客製品番号
242 | カスタム製品番号
250 | 部品参照番号（二次的なシリアル番号）
251 | 元の商品/原材料参照番号
253 | グローバル文書識別番号 (GDTI)
254 | GLN 拡張フィールド
25512 | クーポン識別番号 (GCN)
30 | 商品の数
310 | 正味重量、キログラム
311 | 長さ (1 次元)、メートル
312 | 幅、直径 (2 次元)、メートル
313 | 奥行き、厚さ、高さ (3 次元)、メートル
314 | 面積、平方メートル
315 | 実容量、リットル
316 | 実容量、立方メートル
320 | 正味重量、ポンド
321 | 長さ (1 次元)、インチ
322 | 長さ (1 次元)、フィート
323 | 長さ (1 次元)、ヤード
324 | 幅、直径 (2 次元)、インチ
325 | 幅、直径 (2 次元)、フィート
326 | 幅、直径 (2 次元)、ヤード
327 | 奥行き、厚さ、高さ (3 次元)、インチ
328 | 奥行き、厚さ、高さ (3 次元)、フィート
329 | 奥行き、厚さ、高さ (3 次元)、ヤード
330 | ロジスティック重量、キログラム
331 | 長さ (1 次元)、メートル
332 | 幅、直径 (2 次元)、メートル
333 | 奥行き、厚さ、高さ (3 次元)、メートル
334 | 面積、平方メートル
335 | ロジスティック容量、リットル
336 | ロジスティック容量、立方リットル
337 | 平方メートルあたりのキログラム
340 | ロジスティック重量、ポンド
341 | 長さ (1 次元)、インチ
342 | 長さ (1 次元)、フィート
343 | 長さ (1 次元)、ヤード
344 | 幅、直径 (2 次元)
345 | 幅、直径 (2 次元)
346 | 幅、直径 (2 次元)
347 | 奥行き、厚さ、高さ (3 次元)
348 | 奥行き、厚さ、高さ (3 次元)
349 | 奥行き、厚さ、高さ (3 次元)
350 | 面積、平方インチ
351 | 面積、平方フィート
352 | 面積、平方ヤード
353 | 面積、平方インチ
354 | 面積、平方フィート
355 | 面積、平方ヤード
356 | 正味重量、トロイオンス
357 | 正味重量 (または容量)、オンス
360 | 実容量、クオート
361 | 実容量、米ガロン
362 | ロジスティック容量、クオート
363 | ロジスティック容量、米ガロン
364 | 実容量、立方インチ
365 | 実容量、立方フィート
366 | 実容量、立方ヤード
367 | ロジスティック容量、立方インチ
368 | ロジスティック容量、立方フィート
369 | ロジスティック容量、立方ヤード
370 | 取引商品の数
390 | 適用される支払金額、現地通貨
391 | 適用される支払金額と ISO 通貨コード
392 | 適用される支払金額、単一通貨地域
393 | 適用される支払金額と ISO 通貨コード
400 | 顧客発注番号
401 | 委託販売番号
402 | 出荷識別番号
403 | 追跡コード
410 | グローバルロケーションナンバー (GLN)、出荷先 (納品先) コード
411 | グローバルロケーションナンバー (GLN)、請求先コード
412 | グローバルロケーションナンバー (GLN)、商品仕入先企業コード
413 | グローバルロケーションナンバー (GLN)、最終納品場所コード
414 | グローバルロケーションナンバー (GLN)、物理的位置のコード
415 | グローバルロケーションナンバー (GLN)、請求書発行者コード
420 | 宛先の郵便番号 (単一郵政組織内)
421 | 宛先の郵便番号 (ISO 国コード)
422 | 取引商品の原産国
423 | 一次加工国
424 | 加工国
425 | 分解・解体国
426 | 商品の一貫加工国コード
7001 | NATO ストック番号 (NSN)
7002 | UN/ECE 枝肉番号およびカット規格コード
7030-7039 | 加工者承認番号と ISO 国コード
71012 | 国家保険償還番号 - ドイツ IFA
71112 | 国家保険償還番号 - フランス CIP
71212 | 国家保険償還番号 - スペイン国家コード
71312 | 国家保険償還番号 - ブラジル ANVISA
8001 | ロール状商品の情報 (幅、長さ、芯の直径、方向、継ぎ目)
8002 | 携帯電話識別子
8003 | リターナブル資産識別コード (GRAI)
8004 | 資産管理識別コード (GIAI)
8005 | 計測単位あたりの価格
8006 | 商品構成部品の管理番号
8007 | 国際銀行口座番号 (IBAN)
8008 | 製造日時
801012 | 部品/構成品識別番号 (CPID)
801112 | 部品・パーツ識別シリアル番号 (CPID シリアル)
8018 | サービス提供者識別番号 (GSRN)
8020 | 支払伝票番号
8100 | GS1-128 クーポン拡張コード
8101 | GS1-128 クーポン拡張コード
8102 | GS1-128 クーポン拡張コード
90 | 貿易相手国間で相互に合意した情報
91 ～ 99 | 企業の内部使用データ
1GS1 General Specifications (GS1 仕様書) V14 に準拠する In-Sight ファームウェアバージョン 4.10.1 以上を実行している In-Sight Micro 1000 シリーズ、5000 シリーズ、および 70xx ～ 74xx シリーズのビジョンシステムでサポートされます。 2GS1 General Specifications (GS1 仕様書) V14 に準拠する In-Sight ファームウェア 5.4.0 以上でサポートされます。

GetAIDescription(ID コード, インデックス)

インデックス付きフィールド内でエンコードされているアプリケーション識別子 (AI) の記述を返します。

GetGTIN(ID 有効,[インデックス])

DoD UID データ内の GTIN (CAGE コード + CAGE コード内の元の部品番号) を返します。

GetGTINID(ID 有効,[インデックス])

DoD UID データ内の GTIN (CAGE コード + CAGE コード内の元の部品番号) を表す識別子を返します。

GetInvalidDataLength(ID 有効,[インデックス])

エラー内のデータ従属文字列の長さを返します。

GetInvalidDataPosition(ID 有効,[インデックス])

エラー内のデータ従属文字列の開始位置を返します。

GetNumDataFormats(ID 有効,[インデックス])

データのエンコードに使用されるフォーマットの数を返します。

GetNumFields(ID 有効,[インデックス])

データ内でエンコードされたフィールドの数を返します。

GetPartNum(ID 有効,[インデックス])

DoD UID データ内の部品番号を返します。

GetPartNumID(ID 有効,[インデックス])

DoD UID データ内の部品番号を表す識別子を返します。

GetSerialNum(ID 有効,[インデックス])

DoD UID データ内のシリアル番号を返します。

GetSerialNumID(ID 有効,[インデックス])

DoD UID データ内のシリアル番号を表す識別子を返します。

GetUID(ID 有効,[インデックス])

DoD UID データ内の UID を返します。

GetUIDID(ID 有効,[インデックス])

DoD UID データ内の UID を表す識別子を返します。

GetValid(ID 有効,[インデックス])

参照先データが有効かどうかを返します (0 = 無効、1 = 有効)。


IDVerify 関数

データアクセス

In-Sight 関数リファレンス

  • 汎用データアクセス関数
  • ISO 16022/18004 データアクセス関数
  • ISO 15415/AIM-DPM データアクセス関数
  • Cognex サプリメンタルデータアクセス関数
  • IAQG/AS-9132 データアクセス関数
  • 郵便番号データアクセス関数
注:
  • 返される値はすべて、参照元の [image] 構造体から取得され、VerifyIDCode 関数の作成時にスプレッドシートに挿入されます。
  • ReadIDCode 関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行する In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadIDCode 関数の代わりに ReadIDMax 関数を使用することを推奨します。ReadIDMax 関数には拡張性能機能が搭載されています。
  • VerifyIDCode 関数が ReadIDMax 関数を参照する場合、必要に応じてインデックスを使用して、ReadIDMax 関数の結果テーブルからインデックス付き文字列を参照することができます。
  • ReadIDMax 関数の場合、次の関数をサポートするために、[照合] パラメータを有効にする必要があります。
  • ReadIDCode 関数の場合、次の関数をサポートするために、[アルゴリズム] パラメータを参照元の ReadIDCode 関数で有効にする必要があります。これらの関数は、Data Matrix、QR コード、またはPOSTNET、PLANET、UPU 4-State、Australia Post 4-State、Japan Post 4-State、USPS OneCode
    4-State     ポスタル    のシンボルのみで使用できます。

汎用データアクセス関数

関数 説明

GetGrade(ID 照合,[インデックス])

選択した測定を基に、シンボルの全体的な品質のグレードを返します。

注: 複数の測定セット (ISO、IAQG9132、または Cognex) が VerifyIDCode 関数で有効になっている場合、GetGrade は、有効な測定の最低グレードを返します。

GetHigh(ID 照合,[インデックス])

シンボルの高さを返します。

GetWide(ID 照合,[インデックス])

シンボルの幅を返します。

GetRow(ID 照合,[インデックス])

バーコードの左上隅の行座標、または 2D シンボルのインデックス付き (0 ～ 3) ファインダパターン頂点の列座標をピクセル単位で返します。

注:
  • ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。
  • ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetCol(ID 照合,[インデックス])

バーコードの左上隅の列座標、または 2D シンボルのインデックス付き (0 ～ 3) ファインダパターン頂点の列座標をピクセル単位で返します。

注:
  • ReadIDMax 関数の [照合] チェックボックスを ON にする必要があります。
  • ReadIDCode 関数の [照合] チェックボックスを ON にする必要があります。

GetAngle(ID 照合,[インデックス])

シンボルの角度を返します。

Get2DModulation(ID 照合,[インデックス])

選択した測定方法で定義したシンボルの変調を返します。ISO 15415 または AIM-DPM 測定のいずれかを VerifyIDCode 関数で有効にする必要があります。

注: Data Matrix ECC 200 シンボルではないシンボルの場合、Get2DModulation は #ERR を返します。

  • グレード A = 4.0
  • グレード B = 3.0
  • グレード C = 2.0
  • グレード D = 1.0
  • グレード F = 0.0

GetNoReadString(ID 照合,[インデックス])

ReadIDCode の失敗に関する情報を提供するために、診断文字列を返します。照合されているコードの種類に応じて、グリッドサイズ、極性、解像度、ECC レベル、および場合によってはコードの種類も返されます。

Closed 診断情報文字列を参照してください。

診断情報文字列

シンボルが適切にデコードされました。

シンボルが検出されましたが、デコードできませんでした。

シンボルが検出されなかったか、デコードされませんでした。

ReadIDCode 操作がタイムアウトになりました。

デコードを試みているときに、センサがメモリ不足になりました。

ReadIDCode が予期せずに失敗しました。

VerifyIDCode に無効な ReadIDCode セル参照があります。

ReadIDCode に無効な画像セル参照があります。

[アルゴリズム] チェックボックスが ON のときには、No-Read 診断は Data Matrix または QR コードについてのみサポートされます。

ReadIDCode プロパティシートの [アルゴリズム] チェックボックスがオンになっていません。

GetNoReadStatus(ID 照合,[インデックス])

ReadIDCode の失敗に関する情報を提供するために、診断コードを返します。

Closed 診断コードとそれに対応する情報文字列

Data Matrix: 次の場合、すべての測定が計算されます。

診断コード | 対応するエラー文字列
04030000 | シンボルが適切にデコードされました。
04030001 | シンボルが検出されましたが、デコードできませんでした。

QR コード: 次の場合、ISO 15415 と IAQG-9132 を除くすべての測定が計算されます。

診断コード | 対応するエラー文字列
04030000 | シンボルが適切にデコードされました。
04030001 | シンボルが検出されましたが、デコードできませんでした。

これらの場合、Data Matrix または QR コードのいずれでも測定は使用できません。

診断コード | 対応するエラー文字列
04030002 | シンボルが検出されなかったか、デコードされませんでした。
04030003 | ReadIDCode 操作がタイムアウトになりました。
04030004 | デコードを試みているときに、センサがメモリ不足になりました。
04030005 | ReadIDCode が予期せずに失敗しました。
04030006 | VerifyIDCode に無効な ReadIDCode セル参照があります。
04030007 | ReadIDCode に無効な画像セル参照があります。
04030008 | [アルゴリズム] チェックボックスが ON のときには、No-Read 診断は Data Matrix または QR コードについてのみサポートされます。
04030009 | ReadIDCode プロパティシートの [アルゴリズム] チェックボックスがオンになっていません。

ISO 16022/18004 データアクセス関数

関数 説明

GetContrast(ID 照合,[インデックス])

ISO 15415 が選択された場合、シンボルコントラスト測定結果を返します。これは、前景と背景のグレースケール階調間の割合の差です。

  • グレード A (4.0): 0.70 ≤ x < 1.00
  • グレード B (3.0): 0.55 ≤ x < 0.70
  • グレード C (2.0): 0.40 ≤ x < 0.55
  • グレード D (1.0): 0.20 ≤ x < 0.40
  • グレード F (0.0): 0.00 ≤ x < 0.20

AIM-DPM (プロセス管理または契約適合性のいずれか) が選択された場合、シンボルコントラスト測定を返します。これは、明分布と暗分布の平均の間の差が明分布の平均の割合として計算されます。AIM-DPM 規格では、明分布が ± 8% の許容差範囲内で 78 パーセントになるように、画像を取り込む必要があります。

  • グレード A (4.0): 0.30 ≤ x < 1.00
  • グレード B (3.0): 0.25 ≤ x < 0.30
  • グレード C (2.0): 0.20 ≤ x < 0.25
  • グレード D (1.0): 0.15 ≤ x < 0.20
  • グレード F (0.0): 0.00 ≤ x < 0.15

GetGrowth(ID 照合,[インデックス])

2D シンボルの水平および垂直の印刷拡張が個別に計算され、低い方の得点が返されます。 印刷太り測定結果を返します。

  • グレード A (4.0): -0.50 ≤ x ≤ 0.50
  • グレード B (3.0): -0.70 ≤ x < -0.50 または 0.50 < x ≤ 0.70
  • グレード C (2.0): -0.85 ≤ x < -0.70 または 0.70 < x ≤ 0.85
  • グレード D (1.0): -1.00 ≤ x < -0.85 または 0.85 < x ≤ 1.00
  • グレード F (0.0): x < -1.00 または x > 1.00

GetGrowthHorizontal(ID 照合,[インデックス])

2D シンボルの水平寸法の印刷太りを返します。

  • グレード A (4.0): -0.50 ≤ x ≤ 0.50
  • グレード B (3.0): -0.70 ≤ x < -0.50 または 0.50 < x ≤ 0.70
  • グレード C (2.0): -0.85 ≤ x < -0.70 または 0.70 < x ≤ 0.85
  • グレード D (1.0): -1.00 ≤ x < -0.85 または 0.85 < x ≤ 1.00
  • グレード F (0.0): x < -1.00 または x > 1.00

GetGrowthVertical(ID 照合,[インデックス])

2D シンボルの垂直寸法の印刷太りを返します。

  • グレード A (4.0): -0.50 ≤ x ≤ 0.50
  • グレード B (3.0): -0.70 ≤ x < -0.50 または 0.50 < x ≤ 0.70
  • グレード C (2.0): -0.85 ≤ x < -0.70 または 0.70 < x ≤ 0.85
  • グレード D (1.0): -1.00 ≤ x < -0.85 または 0.85 < x ≤ 1.00
  • グレード F (0.0): x < -1.00 または x > 1.00

GetNonUniformity(ID 照合,[インデックス])

2D シンボルの軸の歪み度合い測定の結果を返します。

  • グレード A (4.0): 0.00 ≤ x ≤ 0.06
  • グレード B (3.0): 0.06 < x ≤ 0.08
  • グレード C (2.0): 0.08 < x ≤ 0.10
  • グレード D (1.0): 0.10 < x ≤ 0.12
  • グレード F (0.0): 0.12 < x ≤ 1.00

GetRefDecode(ID 照合,[インデックス])

シンボルが適切にデコードされたかどうかを示します。

  • グレード A (4.0): 1
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 0

GetUnusedEC(ID 照合,[インデックス])

2D シンボルの未使用誤り訂正測定の結果 (%) を返します。

  • グレード A (4.0): 0.62 ≤ x ≤ 1.00
  • グレード B (3.0): 0.50 ≤ x < 0.62
  • グレード C (2.0): 0.37 ≤ x < 0.50
  • グレード D (1.0): 0.25 ≤ x < 0.37
  • グレード F (0.0): 0.00 ≤ x < 0.25

ISO 15415/AIM-DPM データアクセス関数

関数 説明

Get2DModulation(ID 照合,[インデックス])

選択した測定方法で定義したシンボルの変調を返します。ISO 15415 または AIM-DPM 測定のいずれかを VerifyIDCode 関数で有効にする必要があります。

注: Data Matrix ECC 200 シンボルではないシンボルの場合、Get2DModulation は #ERR を返します。

  • グレード A = 4.0
  • グレード B = 3.0
  • グレード C = 2.0
  • グレード D = 1.0
  • グレード F = 0.0

GetContrast(ID 照合,[インデックス])

ISO 15415 が選択された場合、シンボルコントラスト測定結果を返します。これは、前景と背景のグレースケール階調間の割合の差です。

  • グレード A (4.0): 0.70 ≤ x < 1.00
  • グレード B (3.0): 0.55 ≤ x < 0.70
  • グレード C (2.0): 0.40 ≤ x < 0.55
  • グレード D (1.0): 0.20 ≤ x < 0.40
  • グレード F (0.0): 0.00 ≤ x < 0.20

AIM-DPM (プロセス管理または契約適合性のいずれか) が選択された場合、シンボルコントラスト測定を返します。これは、明分布と暗分布の平均の間の差が明分布の平均の割合として計算されます。AIM-DPM 規格では、明分布が ± 8% の許容差範囲内で 78 パーセントになるように、画像を取り込む必要があります。

  • グレード A (4.0): 0.30 ≤ x < 1.00
  • グレード B (3.0): 0.25 ≤ x < 0.30
  • グレード C (2.0): 0.20 ≤ x < 0.25
  • グレード D (1.0): 0.15 ≤ x < 0.20
  • グレード F (0.0): 0.00 ≤ x < 0.15

GetExtremeReflectance(ID 照合,[インデックス])

シンボルの ISO 15415 最大反射率を返します。ISO 15415 測定を VerifyIDCode 関数で有効にする必要があります。この測定は AIM-DPM 規格の一部ではありません。AIM-DPM が選択された場合は #ERR を返します。

  • グレード A (4.0): 1
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 0

GetFixedPatternDamage(ID 照合,[インデックス])

シンボルの固定パターン損傷測定を返します。ISO 15415 または AIM-DPM 測定のいずれかを VerifyIDCode 関数で有効にする必要があります。固定パターン損傷の測定方法は、ISO 15415 と AIM-DPM では異なります。

  • グレード A = 4.0
  • グレード B = 3.0
  • グレード C = 2.0
  • グレード D = 1.0
  • グレード F = 0.0

GetGridNonUniformity(ID 照合,[インデックス])

シンボルのグリッドの歪み度合いを返します。ISO 15415 または AIM-DPM 測定のいずれかを VerifyIDCode 関数で有効にする必要があります。

  • グレード A (4.0): x ≤ 0.38
  • グレード B (3.0): 0.38 < x ≤ 0.50
  • グレード C (2.0): 0.50 < x ≤ 0.63
  • グレード D (1.0): 0.63 < x ≤ 0.75
  • グレード F (0.0): x > 0.75

GetGrowth(ID 照合,[インデックス])

2D シンボルの水平および垂直の印刷拡張が個別に計算され、低い方の得点が返されます。 印刷太り測定結果を返します。15415 と AIM-DPM 双方で印刷太りをプロセス管理測定として分類します。両方とも、グレードマッピングを定義せず、シンボルのグレードの計算に使用しません。

注:

  • 印刷太りの測定方法と報告方法は、16022/18004 規格の場合とは異なります。 ISO-15415 と AIM-DPM は両方とも印刷太りを、測定済みセルサイズの標準からの平均偏差 (標準の割合) として測定します。 負の値は印刷ロスを表します。
  • 印刷太りはシンボルの水平および垂直寸法に沿って個別に測定され、GetGrowthHorizontal 関数と GetGrowthVertical 関数で返されます。GetGrowth は、水平および垂直方向の印刷太りの平均値を返します。

GetGrowthHorizontal(ID 照合,[インデックス])

2D シンボルの水平寸法の印刷太りを返します。

  • グレード A (4.0): -0.50 ≤ x ≤ 0.50
  • グレード B (3.0): -0.70 ≤ x < -0.50 または 0.50 < x ≤ 0.70
  • グレード C (2.0): -0.85 ≤ x < -0.70 または 0.70 < x ≤ 0.85
  • グレード D (1.0): -1.00 ≤ x < -0.85 または 0.85 < x ≤ 1.00
  • グレード F (0.0): x < -1.00 または x > 1.00

GetGrowthVertical(ID 照合,[インデックス])

2D シンボルの垂直寸法の印刷太りを返します。

  • グレード A (4.0): -0.50 ≤ x ≤ 0.50
  • グレード B (3.0): -0.70 ≤ x < -0.50 または 0.50 < x ≤ 0.70
  • グレード C (2.0): -0.85 ≤ x < -0.70 または 0.70 < x ≤ 0.85
  • グレード D (1.0): -1.00 ≤ x < -0.85 または 0.85 < x ≤ 1.00
  • グレード F (0.0): x < -1.00 または x > 1.00

GetNonUniformity(ID 照合,[インデックス])

2D シンボルの軸の歪み度合い測定の結果を返します。

  • グレード A (4.0): 0.00 ≤ x ≤ 0.06
  • グレード B (3.0): 0.06 < x ≤ 0.08
  • グレード C (2.0): 0.08 < x ≤ 0.10
  • グレード D (1.0): 0.10 < x ≤ 0.12
  • グレード F (0.0): 0.12 < x ≤ 1.00

GetRefDecode(ID 照合,[インデックス])

シンボルが適切にデコードされたかどうかを示します。

  • グレード A (4.0): 1
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 0

GetUnusedEC(ID 照合,[インデックス])

2D シンボルの未使用誤り訂正測定の結果 (%) を返します。

  • グレード A (4.0): 0.62 ≤ x ≤ 1.00
  • グレード B (3.0): 0.50 ≤ x < 0.62
  • グレード C (2.0): 0.37 ≤ x < 0.50
  • グレード D (1.0): 0.25 ≤ x < 0.37
  • グレード F (0.0): 0.00 ≤ x < 0.25

Cognex サプリメンタルデータアクセス関数

関数 説明

GetBkgdUniformity(ID 照合,[インデックス])

2D シンボル (クワイエットゾーンを含む) のグレースケール背景の非均一性を返します。クワイエットゾーンのグレースケール階調が非均一で、モジュールがバイナリデータビット 0 を表すシンボルは、高品質と見なされます。

  • グレード A (4.0): 0.9 ≤ x ≤ 1.0
  • グレード B (3.0): 0.8 ≤ x < 0.9
  • グレード C (2.0): 0.7 ≤ x < 0.8
  • グレード D (1.0): 0.6 ≤ x < 0.7
  • グレード F (0.0): 0.0 ≤ x < 0.6

GetCellSeparability(ID 照合,[インデックス])

バイナリデータビット 1 または 0 を表すモジュールの二峰性特性を返します。モジュールのグレースケール階調は、AIM リファレンスのデコードアルゴリズムで定義されたサンプリンググリッドから抽出されます。

  • グレード A (4.0): 0.75 ≤ x ≤ 1.00
  • グレード B (3.0): 0.60 ≤ x < 0.75
  • グレード C (2.0): 0.50 ≤ x < 0.60
  • グレード D (1.0): 0.40 ≤ x < 0.50
  • グレード F (0.0): 0.00 ≤ x < 0.40

GetFinderConfCon(ID 照合,[インデックス])

シンボルのパターン (タイミングパターンを含む) が AIM シンボルの仕様に適合する範囲の値を返します。特に、同色の隣接モジュールがどの程度きれいに実線を形成しているか、異なる色のモジュールが同じサイズかどうかを測定します。この測定の値が低い場合、AIM リファレンスのデコードアルゴリズムによるシンボルの位置特定ステップが成功する可能性が低くなります。この関数は、予測されるバイナリデータビット 0 または 1 を表す、ファインダパターン (タイミングパターンを含む) 内にあるモジュールの数の比率も測定します。

  • グレード A (4.0): 1.0
  • グレード B (3.0): 0.9 ≤ x < 1.0
  • グレード C (2.0): 0.8 ≤ x < 0.9
  • グレード D (1.0): 0.7 ≤ x < 0.8
  • グレード F (0.0): 0.0 ≤ x < 0.7

GetFinderConfDot(ID 照合,[インデックス])

ドット刻印されたシンボルのファインダパターンが AIM 仕様にどのくらい適合しているかを示す値を返します。

  • グレード A (4.0): 1.0
  • グレード B (3.0): 0.9 ≤ x < 1.0
  • グレード C (2.0): 0.8 ≤ x < 0.9
  • グレード D (1.0): 0.7 ≤ x < 0.8
  • グレード F (0.0): 0.0 ≤ x < 0.7

GetImageSharpness(ID 照合,[インデックス])

3x3 Sobel エッジ検出から取得したエッジ強度と画像コントラストを比較して、画像のエッジのシャープネス値を返します。シャープネス値が高い画像は、焦点がよく合っていて高品質と見なされます。

  • グレード A (4.0): 0.5 ≤ x ≤ 1.0
  • グレード B (3.0): 0.4 ≤ x < 0.5
  • グレード C (2.0): 0.3 ≤ x < 0.4
  • グレード D (1.0): 0.2 ≤ x < 0.3
  • グレード F (0.0): 0.0 ≤ x < 0.2

GetSymSeparability(ID 照合,[インデックス])

シンボルが画像全体の中で明瞭かどうかを示します。画像の最小および最大グレースケール階調の中間にグローバルしきい値があって、背景から明瞭に区別できるシンボルは、高品質と見なされます。

  • グレード A (4.0): 1
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 0

IAQG/AS-9132 データアクセス関数

関数 説明

GetIAQGOverallGrade(ID 照合,[インデックス])

GetPercDotOSFailGrade、GetPercDotPositionFailGrade、GetDistortionAngleGrade の最小限の抽出されたグレードを使って、IAQG 9132 仕様に従った全体的なシンボルのグレードを返します。

GetDistortionAngle(ID 照合,[インデックス])

シンボル X 軸と Y 軸の垂直からの偏差を度単位で返します。

  • グレード A (4.0): x ≤ 7.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): x > 7.0

GetDistortionAngleGrade(ID 照合,[インデックス])

角度の歪みの IAQG 9132 グレードを返します。

  • グレード A (4.0): x ≤ 7.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): x > 7.0

GetDotCenter(ID 照合,[インデックス])

シンボル内のセルの中央が、予測された位置にどのくらい適切に配置されたかを示す割合を返します。

注:この関数は、ドット刻印されたデータマトリックスシンボルを検証するときにだけ適用されます。

  • グレード A (4.0): 0.0 ≤ x ≤ 10.0
  • グレード B (3.0): 10.0 ≤ x < 20.0
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 20.0 ≤ x < 100.0

GetDotDiameter(ID 照合,[インデックス])

予測されたセルの直径の割合として、セルの直径の平均を返します。

注:この関数は、ドット刻印されたデータマトリックスシンボルを検証するときにだけ適用されます。

  • グレード A (4.0): 60.0 < x < 105.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 0.0 ≤ x ≤ 60.0 および 105.0 ≤ x ≤ 150.0

GetDotOvality(ID 照合,[インデックス])

予測されたセルのサイズの割合として、セルの幅と高さの平均的な差を返します。

注:この関数は、ドット刻印されたデータマトリックスシンボルを検証するときにだけ適用されます。

  • グレード A (4.0): 0.0 ≤ x < 20.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 20.0 ≤ x < 100.0

GetPercDotOSFail(ID 照合,[インデックス])

ドットのサイズまたは楕円率の範囲のいずれかから外れた、シンボル内の ON セルの割合を返します。

GetPercDotOSFailGrade(ID 照合,[インデックス])

ドットのサイズまたは楕円率の範囲から外れた ON セルの割合について IAQG 9132 グレードを返します。値が 2% を上回る場合、この測定は不合格 (0) グレードです。上回らない場合、合格 (4) です。

GetPercDotPositionFail(ID 照合,[インデックス])

位置の許容差範囲を超えた、シンボル内の ON セルの割合を返します。

GetPercDotPositionFailGrade(ID 照合,[インデックス])

位置の許容差範囲を超えた ON セルの割合について IAQG 9132 グレードを返します。

  • グレード A (4.0): 1
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 0

GetSDevDotCenter(ID 照合,[インデックス])

ドット位置のシフトエラーの標準偏差を返します。

注:この関数は、ドット刻印されたデータマトリックスシンボルを検証するときにだけ適用されます。

  • グレード A (4.0): 0.0 ≤ x < 20.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 20.0 ≤ x < 100.0

GetSDevDotDiameter(ID 照合,[インデックス])

すべてのセルの直径の標準偏差を返します。

注:この関数は、ドット刻印されたデータマトリックスシンボルを検証するときにだけ適用されます。

  • グレード A (4.0): 0.0 ≤ x < 20.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 20.0 ≤ x < 100.0

GetSDevDotOvality(ID 照合,[インデックス])

セルの幅と高さの間の標準偏差を返します。

注:この関数は、ドット刻印されたデータマトリックスシンボルを検証するときにだけ適用されます。

  • グレード A (4.0): 0.0 ≤ x < 20.0
  • グレード B (3.0): N/A
  • グレード C (2.0): N/A
  • グレード D (1.0): N/A
  • グレード F (0.0): 20.0 ≤ x < 100.0

郵便番号データアクセス関数

関数 | 説明
GetBarPitch(ID 照合,[インデックス]) | POSTNET、PLANET、UPU 4-State、Australia Post 4-State、Japan Post 4-State、USPS OneCode 4-State ポスタルバーコードのバーの平均ピッチを返します。
GetBarSkew(ID 照合,[インデックス]) | ポスタルバーコードのバーの平均スキューを返します。
GetBarSpace(ID 照合,[インデックス]) | ポスタルバーコードのバー間の平均間隔を返します。
GetBarVoid(ID 照合,[インデックス]) | ポスタルバーコードのバーの平均空間 (インクのない領域) を返します。
GetBarHeight(ID 照合,[インデックス]) | ポスタルバーコードのバーの指定された種類の平均高さを返します (インデックス入力値: 0 = ショート/タイミング、1 = アセンダ、2 = ディセンダ、3 = トール/フル)。
GetBarWidth(ID 照合,[インデックス]) | ポスタルバーコードのバーの平均幅を返します。
GetBaselineShift(ID 照合,[インデックス]) | ポスタルバーコードのベースラインからのバーの平均シフトを返します。
GetBGReflectance(ID 照合,[インデックス]) | 背景の平均反射率を返します。
GetClearanceBottom(ID 照合,[インデックス]) | コード下部に対する間隔 (クワイエットゾーン) を返します。 注:シンボルが適切にデコードされた場合にのみ有効です。
GetClearanceLeft(ID 照合,[インデックス]) | コード左に対する間隔 (クワイエットゾーン) を返します。 注:シンボルが適切にデコードされた場合にのみ有効です。
GetClearanceRight(ID 照合,[インデックス]) | コード右に対する間隔 (クワイエットゾーン) を返します。 注:シンボルが適切にデコードされた場合にのみ有効です。
GetClearanceTop(ID 照合,[インデックス]) | コード上部に対する間隔 (クワイエットゾーン) を返します。 注:シンボルが適切にデコードされた場合にのみ有効です。
GetContrast(ID 照合,[インデックス]) | シンボルコントラスト測定結果を返します。これは、前景と背景のグレースケール階調間の割合の差です。
GetMaxBarHeight(ID 照合,[インデックス]) | ポスタルバーコードのバーの指定された種類の最大高さを返します (インデックス入力値: 0 = ショート/タイミング、1 = アセンダ、2 = ディセンダ、3 = トール/フル)。
GetMaxBarPitch(ID 照合,[インデックス]) | ポスタルバーコードのバーの最大ピッチを返します。
GetMaxBarSkew(ID 照合,[インデックス]) | ポスタルバーコードのバーの最大スキューを返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMaxBarSpace(ID 照合,[インデックス]) | ポスタルバーコードのバー間の最大間隔を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMaxBarVoid(ID 照合,[インデックス]) | ポスタルバーコードのバーの最大空間 (インクのない領域) を返します。
GetMaxBarWidth(ID 照合,[インデックス]) | ポスタルバーコードのバーの最大幅を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMaxBaselineShift(ID 照合,[インデックス]) | ポスタルバーコードのベースラインからのバーの最大シフトを返します。
GetMaxBGReflectance(ID 照合,[インデックス]) | 背景の最大反射率を返します。
GetMaxContrast(ID 照合,[インデックス]) | (グレースケール階調における) 前景と背景間の最大コントラストを返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMaxOverInkSize(ID 照合,[インデックス]) | ポスタルバーコードのバーの最大オーバーインクサイズを返します。
GetMinBarHeight(ID 照合,[インデックス]) | ポスタルバーコードのバーの指定された種類の最低高さを返します (インデックス入力値: 0 = ショート/タイミング、1 = アセンダ、2 = ディセンダ、3 = トール/フル)。
GetMinBarPitch(ID 照合,[インデックス]) | ポスタルバーコードのバーの最小ピッチを返します。
GetMinBarSpace(ID 照合,[インデックス]) | ポスタルバーコードのバー間の最小間隔を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMinBarVoid(ID 照合,[インデックス]) | ポスタルバーコードのバーの最小空間 (インクのない領域) を返します。
GetMinBarWidth(ID 照合,[インデックス]) | ポスタルバーコードのバーの最小幅を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMinBarSkew(ID 照合,[インデックス]) | ポスタルバーコードのバーの最小スキューを返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMinBaselineShift(ID 照合,[インデックス]) | ベースラインからのバーの最小シフトを返します。
GetMinBGReflectance(ID 照合,[インデックス]) | 背景の最小反射率を返します。
GetMinContrast(ID 照合,[インデックス]) | (グレースケール階調における) 前景と背景間の最小コントラストを返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetMinOverInkSize(ID 照合,[インデックス]) | バーの最小オーバーインクサイズを返します。
GetModulation(ID 照合,[インデックス]) | ポスタルバーコードの平均コントラストに対する最小エッジレスポンス (ECMin) の比率を返します。
GetNBars(ID 照合,[インデックス]) | ポスタルバーコードで検出されるバーの数を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetOneBarBaselineShift(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーのベースラインシフトを返します。
GetOneBarBGReflectance(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの背景反射率を返します。
GetOneBarCol(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの列番号を返します。★削除★POSTNET と PLANET の場合、 2 State コードのバーの位置は、バーの下部エッジの中央になります。★削除★UPU 4-State、USPS OneCode 4-State、Japan Post 4-State、Australia Post 4-State の場合、 4 State コードのこれはバーの T エレメントの中央になります。
GetOneBarContrast(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーのコントラストを返します。
GetOneBarHeight(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの高さを返します。
GetOneBarOverInkSize(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーのオーバーインクサイズを返します。
GetOneBarPitch(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーのピッチを返します。
GetOneBarRow(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの行番号を返します。★削除★POSTNET と PLANET の場合、 2 State コードのバーの位置は、バーの下部エッジの中央になります。★削除★UPU 4-State、USPS OneCode 4-State、Japan Post 4-State、Australia Post 4-State の場合、 4 State コードのこれはバーの T エレメントの中央になります。
GetOneBarSkew(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーのスキューを返します。
GetOneBarSpace(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの間隔を返します。
GetOneBarType(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの種類を返します (出力値: 0 = ショート/タイミング、1 = アセンダ、2 = ディセンダ、3 = トール/フル)。 注: パラメータのインデックス値は、ポスタルバーコードの個々のバーを参照し、出力値は個々のバーの種類を示します。
GetOneBarVoid(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの空間を返します。
GetOneBarWidth(ID 照合, [インデックス]) | ポスタルバーコードのインデックス付きバーの幅を返します。
GetOverInkSize(ID 照合,[インデックス]) | ポスタルバーコードのバーの平均オーバーインクサイズを返します。
GetSDevBarHeight(ID 照合,[インデックス]) | ポスタルバーコードのバーの指定された種類の高さの標準偏差を返します (インデックス入力値: 0 = ショート/タイミング、1 = アセンダ、2 = ディセンダ、3 = トール/フル)。
GetSDevBarPitch(ID 照合,[インデックス]) | ポスタルバーコードのバーのピッチの標準偏差を返します。
GetSDevBarSkew(ID 照合,[インデックス]) | ポスタルバーコードのバーのスキューの標準偏差を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetSDevBarSpace(ID 照合,[インデックス]) | ポスタルバーコードのバーの間隔の標準偏差を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetSDevBarVoid(ID 照合,[インデックス]) | ポスタルバーコードのバーの空間 (インクのない領域) の標準偏差を返します。
GetSDevBarWidth(ID 照合,[インデックス]) | ポスタルバーコードのバーの幅の標準偏差を返します。 注: この関数は、In-Sight ファームウェア 4.x.x を実行している In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
GetSDevBaselineShift(ID 照合,[インデックス]) | ベースラインからのバーのシフトの標準偏差を返します。
GetSDevBGReflectance(ID 照合,[インデックス]) | 背景反射率の標準偏差を返します。
GetSDevOverInkSize(ID 照合,[インデックス]) | バーのオーバーインクサイズの標準偏差を返します。
GetVerifyDecoded(ID 照合,[インデックス]) | シンボルが適切にデコードされたかどうかの結果を返します (出力値: 0 = 不成功、1 = 成功)。
Version: 5.6.0


画像関数

画像関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。

関数

説明

GetArea(画像)

領域内の処理されるピクセルの数を返します。 構造体は FindCircleDefects 関数によって作成される必要があります。

GetBrightPixelCount(画像)

しきい値を上回るピクセルの数を返します。 構造体は FindCircleDefects 関数によって作成される必要があります。

GetCol(画像, インデックス)

開始列座標を返します。

GetDarkPixelCount(画像)

しきい値を下回るピクセルの数を返します。 構造体は FindCircleDefects 関数によって作成される必要があります。

GetExposure(画像)

最後に行われた画像取り込みで使用した、現在の露光時間パラメータの設定 (ミリ秒単位) を返します。GetExposure 関数は、セル A0 の AcquireImage 関数で作成された [image] データ構造体を参照する必要があります。

注: [自動露光] パラメータが有効な場合、GetExposure 関数は、ソフトウェアにより自動的に決定された露光時間を返します。

GetHigh(画像)

行の数を返します。

GetPixelValue(画像, フィクスチャ, 点)

指定された点のピクセルのグレー値を返します。

GetRegion(画像)

参照される画像フィルタ関数の領域座標を含む [image] データ構造体を返します。出力は [外部定義領域] パラメータをサポートしているビジョンツールの [外部定義領域] パラメータの参照として使用することができます。

GetRow(画像, インデックス)

開始行座標を返します。

GetString(画像)

In-Sight のスレーブ側が In-Sight のマスター側よりネットワークトリガを受信したときスレーブに送られる文字列を返します。マスターシステムのセル A0 にデフォルトで含まれている [image] データ構造体は、[マスターデータ] パラメータで指定されている文字列を含んでいる必要があります。

GetThresh(画像)

現在の 2 値化しきい値を返します。GetThresh 関数は、フィルタ関数 ([フィルタタイプ] を [2 値化]、[グレースケール距離]、または [シャープ] に設定する必要があります) または PointFilter 関数 ([2 値化] に [操作] を指定する必要があります) のいずれかによって作成された [image] データ構造体を参照する必要があります。

注:
  • フィルタ関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。
  • PointFilter 関数は、In-Sight ファームウェア 4.9.1 以前を実行している In-Sight ビジョンシステムだけで使用できます。

GetWide(画像)

列数を返します。


InspectEdge 関数

InspectEdge 関数 |
データアクセス | In-Sight 関数リファレンス

注:

次の関数はそれぞれ、最初のパラメータとして、データ構造体を参照します。構造体から何がインデックス付けされているかは、[インデックス] (ゼロから始まる) によって決まります。

InspectEdge 関数の式はすべて、以下の規則に準拠します。

  • InspectEdgeForDefect/Position/Width (エッジ欠損検査/位置/幅) = 指定された関数によって出力された [image] データ構造体
  • キャリパインデックス = 0 ～ N (キャリパの総数は、InspectEdgeForDefect/Position/Width 関数が参照している InspectEdge 関数によって出力されるキャリパ数と同じです)
  • エッジペアインデックス = 0 ～ 1 (参照する最適ラインを決定します。0 = 1 つめの最適ライン、1 = 2 つめの最適ライン)
  • エッジインデックス = 0 ～ N
  • 点インデックス = 0 ～ 1

関数 | 説明
GetCaliperAngle(エッジ検査, キャリパインデックス) | インデックス付きキャリパの角度を返します。
GetCaliperCol(エッジ検査, キャリパインデックス) | インデックス付きキャリパの列座標を返します。
GetCaliperHigh(エッジ検査, キャリパインデックス) | インデックス付きキャリパの高さを返します。
GetCaliperRow(エッジ検査, キャリパインデックス) | インデックス付きキャリパの行座標を返します。
GetCaliperWide(エッジ検査, キャリパインデックス) | インデックス付きキャリパの幅を返します。
GetDefectExtremumCaliper(エッジ欠損検査, 欠損インデックス, エッジペアインデックス, 最も近い点/最も遠い点) | 最適ラインから最も遠い点または最も近い点 (デフォルト = 0、0 = 最も近い、1 = 最も遠い) を含む指定された欠損内のキャリパインデックスを返します。
GetDefectFilterCount(エッジ欠損検査, エッジペアインデックス, 右/左) | 結果のデータセットからフィルタされた欠損の数を返します。フィルタの向き。右 = 1 (デフォルト)、左 = 2。
GetDefectGapBoundsAngle(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の角度を返します。欠陥 = 0、ギャップ = 1。
GetDefectGapBoundsCol(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の列座標を返します。欠陥 = 0、ギャップ = 1。
GetDefectGapBoundsCurve(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形のカーブを返します。欠陥 = 0、ギャップ = 1。
GetDefectGapBoundsHigh(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の高さを返します。欠陥 = 0、ギャップ = 1。
GetDefectGapBoundsRow(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の行座標を返します。欠陥 = 0、ギャップ = 1。
GetDefectGapBoundsWide(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス]) | 欠陥に外接する矩形の幅を返します。欠陥 = 0、ギャップ = 1。
GetDefectGapCaliperIndex(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ], [エッジペアインデックス], [欠損の開始/終了]) | 欠陥が始まるキャリパまたは終わるキャリパを返します。欠陥 = 0、ギャップ = 1、開始 = 0、終了 = 1。
GetDefectGapCount(エッジ欠損検査, [エッジペアインデックス], [欠損/ギャップ]) | 指定した内容に応じて、欠陥/ギャップの数を返します。欠陥 = 0、ギャップ = 1。
GetDefectGapExtremumValue(エッジ欠損検査/幅, [欠損/ギャップ/位置], [エッジペアインデックス], [最大/最小], [サイズ/領域/幅]) | 一連の欠損またはギャップの最大サイズまたは最小サイズ、領域、もしくは幅値を返します (欠損 = 0、ギャップ = 1、および位置 = 2。最大 = 0 および最小 = 1。サイズ = 0、領域 = 1、幅 = 2)。
GetDefectGapValue(エッジ欠損検査/幅, [欠損/ギャップインデックス], [欠損/ギャップ/位置], [エッジペアインデックス], [サイズ/領域/幅]) | 1 つのギャップのサイズ、領域、幅、あるいはすべてのギャップのサイズ、領域、または幅別の累計を返します (欠損 = 0、ギャップ = 1、および -1 = サイズ、領域、または幅別のすべてのギャップの合計。欠損 = 0、ギャップ = 1 、および位置 = 2。サイズ = 0、領域 = 1、幅 = 2)。
GetEdgeCol(エッジ欠損検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス]) | 参照したエッジの列座標を返します。
GetEdgeContrast(エッジ欠損検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス]) | インデックス付きキャリパエッジのコントラスト値を返します。
GetEdgeCount(エッジ欠損検査/位置, [キャリパインデックス]) | インデックス付きキャリパで検出されたエッジの数を返します。
GetEdgeFromCenter(エッジ欠損検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス]) | インデックス付きキャリパの指定されたエッジから ROI の中心までの距離を返します。
GetEdgeFromFit(エッジ欠損検査, [キャリパインデックス], [エッジペアインデックス]) | 参照したキャリパのエッジから最適ラインまでの距離を返します。欠陥 = 0、ギャップ = 1。
GetEdgeFromRegion(エッジ欠損検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス], [サーチ領域エッジ]) | サーチ領域からインデックス付きキャリパのインデックス付きエッジまでの距離を返します。
GetEdgePairCol(エッジ幅検査, キャリパインデックス, エッジペアインデックス) | インデックス付きキャリパ内で指定されたエッジペアの列座標を返します。
GetEdgePairCount(エッジ幅検査, キャリパインデックス) | インデックス付きキャリパ内のエッジペアの数を返します。
GetEdgePairRow(エッジ幅検査, キャリパインデックス, エッジペアインデックス) | インデックス付きキャリパ内で指定されたエッジペアの行座標を返します。
GetEdgePairWidth(エッジ幅検査, キャリパインデックス, エッジペアインデックス) | インデックス付きキャリパ内で指定されたエッジペアの幅を返します。エッジペアインデックスに 0 を指定すると、インデックス付きキャリパ内で最も得点の高いエッジペアのみが返されます。
GetEdgePosCol(エッジ位置検査, キャリパインデックス, エッジインデックス) | 指定したキャリパのエッジ位置の列座標を返します。
GetEdgePosContrast(エッジ位置検査, キャリパインデックス, エッジインデックス) | インデックス付きキャリパの指定されたエッジのコントラストを返します。
GetEdgePosFromCenter(エッジ位置検査, キャリパインデックス, エッジインデックス) | インデックス付きキャリパの指定されたエッジから ROI の中心までの距離を返します。
GetEdgePosFromFit(エッジ位置検査, キャリパインデックス) | インデックス付きキャリパのエッジから最適ラインまでの距離を返します。
GetEdgePosFromRegion(エッジ位置検査, キャリパインデックス, エッジインデックス, サーチ領域エッジ) | サーチ領域からインデックス付きキャリパのインデックス付きエッジまでの距離を返します。
GetEdgePosRow(エッジ位置検査, キャリパインデックス, エッジインデックス) | 指定したキャリパのエッジ位置の行座標を返します。
GetEdgePosScore(エッジ位置検査, キャリパインデックス, エッジインデックス) | インデックス付きキャリパの指定されたエッジの得点を返します。
GetEdgeRow(エッジ欠損検査, [キャリパインデックス], [エッジインデックス], [エッジペアインデックス]) | 参照したエッジの行座標を返します。
GetEdgeScore(検査, キャリパインデックス, エッジペアインデックス, エッジインデックス) | インデックス付きキャリパ内で検出された各エッジのエッジ得点を返します。
GetExtremePoints(エッジ欠損検査, [エッジペアインデックス], [近い/遠い]) | エッジが最適ラインから最も離れているキャリパのインデックスを返します (近い = 0、遠い = 1)。
GetExtremePosPoints(エッジ位置検査, サイド) | エッジがいずれかの側の最適ラインから最も離れているキャリパのインデックスを返します (近い = 0、遠い = 1)。または、[最適ライン] が [なし] に設定されている場合は、領域のいずれかのエッジに最も近い点を返します。
GetExtremeWidth(エッジ幅検査, 最も薄い/最も厚い) | 指定した極端な幅を含むキャリパのインデックスを返します (最薄 = 0 および最厚 = 1)。
GetFitEdgeAngle(エッジ欠損検査, [エッジペアインデックス]) | インデックス付きキャリパ内で指定されたエッジペアの角度を返します。
GetFitEdgeCenterCol(エッジ欠損検査, [エッジペアインデックス]) | 最適円の中心の列座標を返します。
GetFitEdgeCenterRow(InspectEdgeForIndex, 点インデックス) | 最適円の中心の行座標を返します。
GetFitEdgeCol(エッジ欠損検査, [エッジペアインデックス], [点インデックス]) | 指定した点の列座標を返します。
GetFitEdgePosAngle(エッジ位置検査) | 1 つめの点から計算した最適ラインの角度を返します。
GetFitEdgePosCenterCol(エッジ位置検査, 点インデックス) | 最適円の中心の列座標を返します。
GetFitEdgePosCenterRow(エッジ位置検査, 点インデックス) | 最適円の中心の行座標を返します。
GetFitEdgePosCol(エッジ位置検査, 点インデックス) | 最適直線の指定した点の列座標を返します。
GetFitEdgePosRadius(エッジ位置検査, 点インデックス) | 最適円の中心からの距離を返します。
GetFitEdgePosRow(エッジ位置検査, 点インデックス) | 最適直線の指定した点の行座標を返します。
GetFitEdgeRadius(エッジ欠損検査, [エッジペアインデックス]) | 選択されたエッジペアに対する最適円の中心からの距離を返します。
GetFitEdgeRow(エッジ欠損検査, [エッジペアインデックス], [点インデックス]) | 指定した点の行座標を返します。
GetIEFitError(エッジ欠損検査/位置, [エッジインデックス]) | インデックス付きの線または円に最適な線または円の精度のエラー値を返します。
GetNumCalipers(エッジ検査) | 指定された InspectEdge 関数に含まれるキャリパの総数を返します。
GetNumCalipersUsed(エッジ欠損検査/位置, [エッジペアインデックス]) | 最適ラインまたは最適円の構築に使用されるキャリパの数を返します。GetNumCalipers 関数から返される値に対してここで返された値を使用し、最適ラインまたは最適円の構築に使用されるキャリパの割合 (%) を決定します。必要に応じて、[エッジペアの検査] パラメータを有効化した InspectEdgeForDefect 関数を参照する場合、[第 1 エッジ] に使用するキャリパの数を返すには、[エッジペアインデックス] に 0 を指定し、[第 2 エッジ] に使用するキャリパの数を返すには、[エッジペアインデックス] に 1 を指定します。
GetTotalCount(エッジ検査/エッジ欠損検査/位置/幅) | 参照された InspectEdge、InspectEdgeForDefect、InspectEdgePosition、または InspectEdgeWidth 関数に対する結果の総数を返します。
GetWidth(エッジ幅検査, キャリパインデックス) | インデックス付きキャリパ内のエッジの幅を返します。インデックス付きキャリパ内でエッジが検出されなかった場合は 0 を返します。
GetWidthAverage(エッジ幅検査) | 参照される InspectEdgeWidth 関数からの平均幅の値を返します。最小/最大値の範囲外にギャップまたは欠陥があるエッジペアについては、平均値の計算に幅の値は使用されません。
GetWidthCaliperCount(エッジ幅検査, なし/あり, 実数/割合) | 欠損を含む、または含まないキャリパの数または割合 (%) を返します (なし = 0 およびあり = 1、実数 = 0 および割合 = 1)。
GetWidthCaliperExtremum(エッジ幅検査, なし/あり, 最小/最大) | 欠損を含む、または含まないキャリパの最小ブロックまたは最大ブロックを返します (なし = 0 およびあり = 1、最小 = 0 および最大 = 1)。
GetWidthCount(エッジ幅検査, 欠損/ギャップ) | 指定した欠陥またはギャップの総数を返します (欠陥 = 0、ギャップ = 1)。
GetWidthStdDev(エッジ幅検査) | 参照される InspectEdgeWidth 関数からの幅値の標準偏差を返します。最小/最大値の範囲外にギャップまたは欠陥があるエッジペアについては、標準偏差の計算に幅の値は使用されません。
GetWidthThresholdCount(エッジ幅検査, 上/下, 実数/割合) | 幅しきい値を上回るか、または下回る欠損の数を返します (上回る = 0 および下回る = 1、実数 = 0 および割合 = 1)。
GetWidthThresholdExtremum(エッジ幅検査, 上/下, 最小/最大, サイズ/領域/幅) | 幅しきい値を上回るか、または下回る最小もしくは最大の欠損のサイズ、領域、または幅の値を返します (上回る = 0 および下回る = 1。最小 = 0 および最大 = 1。サイズ = 0、領域 = 1、および幅 = 2)。
GetWidthTotalCaliperSize(エッジ幅検査, なし/あり) | 欠損のある、またはないすべてのキャリパのサイズの累計を返します (なし = 0 およびあり =1)。
GetWidthTotalDefectSize(エッジ幅検査, 上/下) | 幅しきい値を上回る、または下回るすべての欠損のサイズの累計を返します (上回る = 0 および下回る = 1)。
Version: 5.6.0


LineFit 関数

LineFit 関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。

関数 | 説明
GetChi2(ラインフィット) | 点から線への距離の二乗の合計を返します。
GetCol(ラインフィット, インデックス) | インデックス付きの点の Y 座標を返します。
GetDistance(ラインフィット, インデックス) | インデックス付きの点と線の間の距離を返します。
GetMaxDist(ラインフィット) | 線から最も遠い点を返します。
GetMaxDistIndex(ラインフィット) | 線から最も遠い点のインデックスを返します。
GetNPointUsed(ラインフィット) | 線の計算に使用された点の数を返します。
GetRow(ラインフィット, インデックス) | インデックス付きの点の X 座標を返します。


LineScan 関数

データアクセス

In-Sight 関数リファレンス

注: 特に断りのない限り、次の各関数では、イベントを参照して強制的に値を更新する必要があります。

Event 関数

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。
  • 数値を含むセル (ゼロ以外の数値は強制的に更新を実行します)。

関数 | 説明
GetImageBufferCount(画像) | 現在使用されているバッファの数を返します。
GetImageBufferOverrunCount(画像) | 画像バッファの不足のため、失われた画像取り込みの数を返します。このカウントは、センサがオンラインまたはオフラインに切り替わったとき、または LineScanStatReset 関数の実行時にリセットされます。
GetLineScanAcqEncoderSteps(画像) | 部分的に取り込まれた画像について、現在までに取り込んだステップ数 (ソフトウェアエンコーダの場合はマイクロ秒) を返します。画像取り込みを実行していない場合は 0 を返します。この統計情報は、システムが低速の場合に、ハードウェアエンコーダを設定する際に最も有効です。
GetLineScanAcqLineCount(画像) | 部分的に取り込まれた画像について、現在までに取り込んだライン数を返します。画像取り込みを実行していない場合は 0 を返します。この統計情報は、システムが低速の場合に、ハードウェアエンコーダを設定する際に最も有効です。
GetLineScanAcqStepsPerSec(画像) | 最後の画像取り込み周期での 1 秒あたりの平均ステップ数を返します。ソフトウェアエンコーダの場合は、常に 1000000.0 を返します。
GetLineScanAcqTime(画像) | 最後の画像取り込みに要した時間をミリ秒単位で返します。この時間は、トリガ信号の開始から最終行の終わりまでとして計測されます。
GetLineScanAcqTimeoutCount(画像) | エンコーダが画像取り込み時のタイムアウトによって画像取り込みを中断した回数を返します。このカウントは、センサがオンラインまたはオフラインに切り替わったとき、または LineScanStatReset 関数の実行時にリセットされます。
GetLineScanEncoderSteps(画像) | 最後にオンラインまたはオフラインに切り替わってからの、または最後に LineScanStatReset 関数を実行してからの、ステップ数 (ソフトウェアエンコーダの場合はマイクロ秒) を返します。この値は、約 40 億ステップを超えるとリセットされます。
GetLineScanExposureConflict(画像) | 現在の [ライン間隔] の値と [露光時間] の値との間に不整合がある場合は 1 を返し、それ以外の場合は 0 を返します。これは、ソフトウェアエンコーダのみに適用され、ハードウェアエンコーダでは常に 0 が返されます。この関数が 1 を返した場合、ラインのオーバランが発生している可能性があります。
GetLineScanFillLines(画像) | 画像内の黒で埋めたライン (ラインオーバランによってクリッピングされたか失われたライン) の数を返します。 注: GetLineScanFillLines は、セル A0 の AcquireImage 関数を参照している必要があります。
GetLineScanLineCount(画像) | 取り込んだラインの数を返します。このカウントは、センサがオンラインまたはオフラインに切り替わったとき、または LineScanStatReset 関数の実行時にリセットされます。
GetLineScanLineOverrunCount(画像) | エンコーダレートが大きすぎたために失われたラインの数を返します。このカウントは、センサがオンラインまたはオフラインに切り替わったとき、または LineScanStatReset 関数の実行時にリセットされます。
LineScanStatReset(イベント) | ラインスキャンの累積統計情報をリセットします。これは、オンラインイベントまたはオフラインイベントの発生時に、自動的に実行されます。
Version: 5.6.0


OCRMax 関数

データアクセス

In-Sight 関数リファレンス

注: 特に明記されていない限り、次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。Char_Index (ゼロから始まる) は、構造体からインデックスされている文字を決定します。

関数

説明

GetAngle(文字領域)

文字矩形の角度を返します。

GetAngle(OCR 最大, 文字インデックス)

文字領域の角度を返します。

GetChar(OCR 最大, 文字インデックス 0, [文字インデックス 1])

インデックス付き文字を返します。オプションの Char_Index1 パラメータが 1 の場合は、2 番目に高い得点の文字を返します。

GetCharConfused(OCR 最大, 文字インデックス*)

* オプション

オプションの Char_Index が指定されている場合は、インデックス付き文字のコンフュージョン状態 (曖昧な場合は 1.0、そうでない場合は 0.0) を返します。Char_Index が指定されていない場合は、文字列内のいずれかの文字がコンフュージョン状態である場合に 1.0、そうでない場合に 0.0 を返します。

GetCharFailedValidation(OCR 最大, 文字インデックス*)

* オプション

オプションの Char_Index が指定されている場合は、インデックス付き文字の検証状態 (検証に失敗した場合は 1.0、そうでない場合は 0.0) を返します。Char_Index が指定されていない場合は、文字列内のいずれかの文字が検証に失敗した場合に 1.0、そうでない場合に 0.0 を返します。

GetCharMisMatch(OCR 最大, 文字インデックス*)

* オプション

オプションの Char_Index が指定されている場合は、文字の不一致状態 (不一致とみなされた場合は 1.0、そうでない場合は 0.0) を返します。Char_Index が指定されていない場合は、文字列内のいずれかの文字が不一致の場合に 1.0、そうでない場合に 0.0 を返します。

GetCharacterRegion(OCR 最大, 文字インデックス, 表示)

インデックス付き文字の [image] データ構造体を返します。返される領域は、次の図に示すように、文字を完全に囲む可能な限り最小の矩形領域です。参照されている文字が (次の図に示す文字のように) 傾いていない場合、表示される文字領域と文字矩形は同一になります。

GetCharsTrained(OCR 最大)

登録されている文字をテキスト文字列として返します。

GetCol(文字領域)

文字矩形の左上隅を返します。

GetCol(OCR 最大, 文字インデックス, コーナーインデックス)

表示される文字領域の指定された隅の列座標を返します。

注: 文字が傾いていない場合は、文字矩形と表示される文字領域は同一となります。

GetFontName(OCR 最大)

参照されている OCRMax 関数からフォントの名前を返します。

GetHigh(文字領域)

文字矩形の高さを返します。

注: 文字矩形の高さと文字領域の高さは同一です。

GetHigh(OCR 最大, 文字インデックス)

文字領域の高さを返します。

注: 文字矩形の高さと文字領域の高さは同一です。

GetIgnoredCharacters(OCR 最大)

フィールドの形式化中に無視された、セグメンテーションされた文字の数を返します。

GetInternalSettings(OCR 最大)

参照先の OCRMax 関数から [image] データ構造体としてセグメントパラメータを返します。このパラメータは、ほかの OCRMax 関数の [外部設定] パラメータからの参照が可能です。ただし、次の操作を実行しない場合、[オートチューン] ダイアログは無効になります。

GetInternalSettings 関数の使用中に [オートチューン] ダイアログを有効なままにするには、少なくとも 2 つの OCRMax 関数 (OCRMax#1 と OCRMax#2) を使用する必要があります。

最初の OCRMax 関数 (OCRMax#1) の [外部設定] パラメータを 0 に設定して、オートチューンの機能を有効なまま維持します。次に、GetInternalSettings 関数を使用して、OCRMax#1 を参照します。

2 番目の OCRMax 関数 (OCRMax#2) の [外部設定] パラメータで GetInternalSettings を参照します。これにより、OCRMax#1 は自動調整することができ、結果が OCRMax#2 によって利用されます。

次に例を示します。

  • セル A1: OCRMax#1 with External Settings = 0
  • セル B1: GetInternalSettings (参照A1)
  • セル C1: OCRMax#2 with External Settings = B1

GetNumCharTrainedInstances(OCR 最大, 文字)

文字の登録インスタンスの数を返します (例: "a"、"B"、"1")。

GetPassed(OCR 最大, 文字インデックス)

インデックス付き文字の合格/不合格ステータスを返します。[インデックス] パラメータが指定されていない場合は、文字列全体の合格/不合格ステータスを返します。文字列のすべての文字が合格の場合にのみ、文字列全体が合格になります。

GetScore(OCR 最大, 文字インデックス 0, [文字インデックス 1])

インデックス付き文字の一致得点 (0 ～ 100) を返します。オプションの [インデックス　1] パラメータが 1 の場合は、2 番目に高い得点の文字の得点を返します。

GetRow(文字領域)

文字矩形の左上隅を返します。

GetRow(OCR 最大, 文字インデックス, コーナーインデックス)

文字領域の指定された隅の行座標を返します。

GetSize(OCR 最大, 文字インデックス)

インデックス付き文字のサイズをピクセル単位で返します。

GetString(OCR 最大)

参照されている OCRMax 関数によって読み取られたテキスト文字列を返します。

GetWide(文字領域)

文字矩形の幅を返します。

注: スキューが存在する場合、幅は文字領域の幅にスキューを補正するために必要な幅を加えた大きさになります。

GetWide(OCR 最大, 文字インデックス)

文字領域の幅を返します。


パターン関数

パターン関数 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。インデックス (ゼロから始まる) は、構造体からインデックスされているパターンを決定します。

関数

説明

GetAngle(パターン, [インデックス])

角度の値を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns、FindPatterns、SortPatterns の各関数と連携します。

GetClutter(パターン, [インデックス])

クラッタの登録パターンの一部ではない特徴。 スコアを返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns の各関数と連携します。

GetCol(パターン, [インデックス])

列の値を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns、FindPatterns、SortPatterns の各関数と連携します。

GetColorScore(パターン, [インデックス])

カラー得点の値 (0 ～ 100) を返します。この関数は、FindPatMaxRedLineColor のみと連携します。

注: 参照先 TrainPatMaxRedLineColor の [カラーマッチ] パラメータが [マッチなし] に設定されている場合、GetColorScore 関数は 100.000 を返します。

[カラーマッチ] パラメータの選択項目 | 動作
0 = すべてのカラー (デフォルト) | ツールによって一致する特徴が検出されたことを前提に、計算されたスコアを返します。
1 = 選択カラー
2 = マッチなし | 100.000 を返します (ツールによって、カラーマッチスコアは計算されません)。

GetContrast(パターン, [インデックス])

コントラストの値を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns の各関数と連携します。

  • FindPatMaxRedLineColor と FindPatMaxRedLine のコントラスト値は、登録パターン内の特徴とサーチ画像内の一致する特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ～100 となります。パターンコントラストが特徴のコントラストを超えた場合、報告されるコントラストは <100 となります。
  • FindPatMaxPatterns コントラストは、グレースケール階調で表した、サーチ ROI 内の絶対画像コントラストです。

GetCoverage(パターン, [インデックス])

カバレッジのパーセンテージを返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns の各関数と連携します。

GetErrorCode(パターン, [インデックス])

パターンに対するエラーコードを返します。この関数は Pattern Match 関数 (TrainPatMaxRedLineColor、FindPatMaxRedLineColor、TrainPatMaxRedLine、FindPatMaxRedLine、TrainPatMaxPattern、FindPatMaxPatterns、FindPatterns、および SortPatterns) と連携します。

Closed エラーコードとそれに対応する情報文字列

エラーコード | 対応する情報文字列
00000008 | 操作のタイムアウト時間を超過しました。

PatMax

エラーコード | 対応する情報文字列
07010000 | パターンに含まれるマッチ特徴が少なすぎることがあります。
07010001 | 特徴の粒度を自動的に設定するのは困難です。
07010100 | 手動で [粒度] を設定してください。登録画像の表示がぼやけているので、パターンが予想より正確でないことがあります。
07010102 | 疎粒度の特徴が同じ方向であるために、パターン結果が不安定になることがあります。
07010200 | 高精度な特徴が多いため、実行時間が長くなることがあります。手動で [粒度] を設定してください。
07010101 | パターンに含まれる情報が不十分なため、角度またはスケールを正確に測定できないことがあります。
07020300 | コントラストが低いため、結果は破棄されました。
07020301 | より正確な結果を得るため、結果は破棄されました。
07020302 | クラッタが多すぎるため、結果は破棄されました。
07020303 | 現在のパラメータ設定に対して、登録パターンに含まれる特徴が少なすぎます。
07030000 | エラー情報はありません。

PatMax RedLine (グレースケールとカラー)

エラーコード | 対応する情報文字列
07020306 | グレースケールの入力画像はサポートされていません。
07020307 | マッチカラーが登録されていません。
07010100 | 参照しているカラーマッチマスク画像のサイズが、入力領域と一致しません。
07020308 | 入力画像を登録できません。
07020309 | 高精度な特徴が多いため、実行時間が長くなることがあります。手動で [粒度] を設定してください。
07020310 | カラーパターンを登録できません。

GetFitError(パターン, [インデックス])

一致誤差の得点を返します。この関数は、FindPatMaxPatterns 関数のみと連携します。

GetGranCoarse(パターン)

粗粒度値を返します。この関数は、TrainPatMaxRedLineColor、TrainPatMaxRedLine、TrainPatMaxPattern と連携します。

GetGranFine(パターン)

微粒度値を返します。この関数は、TrainPatMaxRedLineColor、TrainPatMaxRedLine、TrainPatMaxPattern と連携します。

GetInfoCode(パターン, [インデックス])

情報文字列に対する診断コードを返します。この関数は、TrainPatMaxPattern 関数および FindPatMaxPatterns 関数と連携します。

Closed 診断コードとそれに対応する情報文字列

注: このツールは GetInfoString 関数を使って情報文字列をスプレッドシートに挿入します。

TrainPatMaxPattern 関数

診断コード | 対応する情報文字列
07010000 | パターンに含まれるマッチ特徴が少なすぎることがあります。
07010001 | 特徴の粒度を自動的に設定するのは困難です。
07010100 | 手動で [粒度] を設定してください。登録画像の表示がぼやけているので、パターンが予想より正確でないことがあります。
07010102 | 疎粒度の特徴が同じ方向であるために、パターン結果が不安定になることがあります。
07010200 | 高精度な特徴が多いため、実行時間が長くなることがあります。手動で [粒度] を設定してください。
07010101 | パターンに含まれる情報が不十分なため、角度またはスケールを正確に測定できないことがあります。
07030000 | エラー情報はありません。

FindPatMaxPatterns 関数

診断コード | 対応する情報文字列
07020300 | [値] 低コントラストのために破棄された結果。
07020301 | [値] より正確な結果を得るために破棄された結果。
07020302 | [値] クラッタが多すぎるために破棄された結果。
07020303 | 現在のパラメータ設定に対して、登録パターンに含まれる特徴が少なすぎます。

GetInfoString(パターン, [インデックス])

情報文字列を返します。この関数は、TrainPatMaxPattern 関数および FindPatMaxPatterns 関数と連携します。

GetNFound(パターン)

検出されたパターン一致の数を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns、FindPatterns、SortPatterns の各関数と連携します。

GetOutsideArea(パターン, [インデックス])

サーチ領域外で検出された一致パターンの領域の割合 (0 から 1 の段階で、0 はすべて内部、1 はすべて外部での検出) を返します。この関数は、FindPatMaxPatterns 関数のみと連携します。

GetOutsideFeatures(パターン, [インデックス])

サーチ領域外で検出された一致パターンの特徴の割合 (0 から 1 の段階で、0 はすべて内部、1 はすべて外部での検出) を返します。この関数は、FindPatMaxPatterns 関数のみと連携します。

GetRow(パターン, [インデックス])

行の値を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns、FindPatterns、SortPatterns の各関数と連携します。

GetScale(パターン, [インデックス])

登録パターンと比較した一致のサイズ (%) を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns、FindPatterns、SortPatterns の各関数と連携します。

GetScaleX(パターン, [インデックス])

登録パターンと比較した X 方向の一致のサイズ (%) を返します。この関数は、FindPatMaxPatterns 関数のみと連携します。

GetScaleY(パターン, [インデックス])

登録パターンと比較した Y 方向の一致のサイズ (%) を返します。この関数は、FindPatMaxPatterns 関数のみと連携します。

GetScore(パターン, [インデックス])

パターンのレスポンス得点の値を返します。この関数は、FindPatMaxRedLineColor、FindPatMaxRedLine、FindPatMaxPatterns、FindPatterns、SortPatterns の各関数と連携します。

GetTrained(パターン)

ツールが適切にパターンを学習した場合は 1 を返します。ツールが [image] 構造体からパターンを登録できない場合は、0 を返します。この関数は、 TrainPatMaxPattern、TrainPatMaxRedLine、TrainPatMaxRedLineColor、および FindPatterns と連携します。


Get

データアクセス関数 → スクリプト

In-Sight 関数リファレンス

Script 関数または別の Get 関数のいずれかによって出力された配列および/またはオブジェクトのプロパティを返します。

  • Get 関数の概要
  • Get の入力パラメータ
  • Get の出力
  • 関連項目

注: この関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

Get概要

Get 関数を使用して、Script 関数によって返されるオブジェクトのプロパティにアクセスします。最低でも 2 つの引数が必要です。Script 関数、またはオブジェクトや配列を返す別の Get 関数への参照と、オブジェクトのプロパティを示す文字列、またはサブオブジェクトのプロパティへのドットで区切られたパスのいずれかです。オプションで、配列を参照するときに、3 つめの引数がゼロベースの配列インデックスにアクセスするように指定することができます。

Get 関数の戻り値はプロパティ (つまり、インデックスで指定された配列要素) の値であり、次のタイプのいずれかとなります。

  • 数値
  • true (1) または false (0)
  • 文字列
  • データ構造体
  • 、 [image] 、 [image] 、 [image] 、または [image] データ構造体
  • 形状オブジェクト
  • 、または [image] データ構造体

注: Get 関数では null または undefined を返すことはサポートしていません。

Get 関数の例

この例では、セル B3 内の Script 関数に、オブジェクトを返す実行メソッドがあります。

Tool.prototype.run = function(n) {
  this.updateStats(n);
  return {
    total: this._total;
    stats: {
      avg: this._avg,
      range: {
        max: this._max,
        min: this._min
      },
      values: this._valueArray
    }
   };
};

次の Get 関数は、単純な数値を返します (戻り値が数値であることを前提とします)。

  • Get(B3, "total")
  • Get(B3, "stats.avg")
  • Get(B3, "stats.range.max")
  • Get(B3, "stats.range.min")

次の Get 関数は「range」サブオブジェクトを返します。この戻り値は、別の Script または Get 関数に渡すことができます。

  • Get(B3, "stats.range")

次の Get 関数は値配列から要素 37 を返します。

  • Get(B3, "stats.values", 37)

Getの入力パラメータ

Get(

Script/Get ,

オブジェクトプロパティと配列の両方またはいずれか ,

[配列インデックス]

)

Script/Get | または [image] データ構造体を返す Script 関数または別の Get 関数への参照を指定します。
オブジェクトプロパティと配列の両方またはいずれか | データ構造体のプロパティへの参照を、文字列 (プロパティの名前) やサブオブジェクトへのドットで区切られたパス、または [image] データ構造体のいずれかとして指定します。
[配列インデックス] | データ構造体が参照されるときに、配列のインデックスにオプションの引数を指定します。

Getの出力

戻り値

この関数の戻り値はプロパティ (つまり、インデックスで指定された配列要素) の値であり、次のタイプのいずれかを返します。

  • 数値
  • true (1) または false (0)
  • 文字列
  • データ構造体
  • 、 [image] 、 [image] 、 [image] 、または [image] データ構造体
  • 形状オブジェクト
  • または [image] データ構造体

注: この関数は、Script 関数から null、undefined、no return ステートメントを返すことはありません (空のオブジェクトと同じに扱われます)。

関連項目

  • スクリプト関数
  • [スクリプトの編集] ダイアログ
  • Script 関数


構造体

構造体 |
データアクセス | In-Sight 関数リファレンス

注: 次の関数の Structure 引数は、Annulus、Circle、Cross、Fixture、Line、Mask、Point、またはRegion 関数から返されたデータ構造体を参照する必要があります。次の説明で、各関数の有効な構造体を示します。

関数 | 説明
GetAngle(構造体, インデックス) | インデックス付きの [image] 、 [image] 、または [image] データ構造体から Angle の値を返します。
GetCol(構造体, インデックス 1, インデックス 2) | インデックス付きの [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、または [image] 構造体から Col の値を返します。
GetCurve(構造体) | インデックス付き [image] 構造体から Curve の値を返します。
GetHigh(構造体) | インデックス付き [image] または [image] 構造体から High の値を返します。
GetRadius(構造体, インデックス) | インデックス付き [image] または [image] 構造体から Radius の値を返します。
GetRow(構造体, インデックス 1, インデックス 2) | インデックス付きの [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、または [image] 構造体から Row の値を返します。
GetSegmentArea(マスク, インデックス) | 構造体からインデックス付きセグメントの面積を返します。または、インデックスが指定されていない場合は、セグメント 0 を返します。
GetSegmentX(マスク, インデックス) | 構造体からインデックス付きセグメントの X 座標を返します。または、インデックスが指定されていない場合は、セグメント 0 を返します。
GetSegmentY(マスク, インデックス) | 構造体からインデックス付きセグメントの Y 座標を返します。または、インデックスが指定されていない場合は、セグメント 0 を返します。
GetWide(構造体) | インデックス付き [image] または [image] 構造体から Wide の値を返します。


テキスト (文字照合/認識) 関数

データアクセス

In-Sight 関数リファレンス

注:
  • TrainFont、ReadText、VerifyText の各関数は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • レガシー関数である ReadText、TrainFont および VerifyText 関数の代わりに、OCRMax 関数を使用することを推奨します。OCRMax 関数には拡張性能機能が搭載されています。
  • 特に明記されていない限り、次の関数はそれぞれ、最初のパラメータとして、 [image] データ構造体を参照します。インデックス (ゼロから始まる) は、構造体からインデックスされている OCV/OCR 文字を決定します。

関数

説明

GetAngle(テキスト)

テキスト文字列と [image] データ構造体の水平軸の間の角度を返します。GetAngle 関数は、[インデックス] パラメータを無視します。

GetChar(テキスト, インデックス 0, [インデックス 1])

インデックス付き文字を返します。オプションの [インデックス 1] パラメータが 1 の場合は、2 番目に高い得点の文字を返します。オプションの　[インデックス 1] パラメータが 1 の場合は、2 番目に高い得点の文字を返します。VerifyText 関数では、2 つの文字の一致得点の差が 10% 未満の場合にのみ、2 番目の得点の文字を返します。

GetCol(テキスト, インデックス)

インデックス付き文字の列座標をピクセル単位で返します。

GetContrast(テキスト, インデックス)

インデックス付き文字の前景と背景のコントラスト (グレースケール階調で、0～255) を返します。インデックス付き文字が指定されていない場合は、文字列の最初の文字のコントラストを返します。

GetErrorCode(テキスト, インデックス)

各情報文字列に対する診断コードを返します。

Closed 診断コードとそれに対応する情報文字列

注: エラー文字列は、GetErrorString 関数によってスプレッドシートに挿入されます。

コード | 対応する文字列
00000011 | 無効な画像セル参照です。
00400000 | 無効なフォントセル参照です。
00400002 | 照合文字列の長さは 32 文字以内でなければなりません。
00400003 | 照合文字列が入力されていません。
00400004 | 照合文字列に登録されていない文字が含まれています。

GetErrorString(テキスト, インデックス)

エラー文字列を返します。

Closed エラー文字列

注: エラーコードは、GetErrorString 関数によってスプレッドシートに挿入されます。

コード | 対応する文字列
00000011 | 無効な画像セル参照です。
00400000 | 無効なフォントセル参照です。
00400002 | 照合文字列の長さは 32 文字以内でなければなりません。
00400003 | 照合文字列が入力されていません。
00400004 | 照合文字列に登録されていない文字が含まれています。

GetHigh(テキスト, インデックス)

インデックス付き文字の高さをピクセル単位で返します。

GetPassed(テキスト, インデックス)

インデックス付き文字の合格/不合格ステータスを返します。[インデックス] パラメータが指定されていない場合は、文字列全体の合格/不合格ステータスを返します。文字列のすべての文字が合格の場合にのみ、文字列全体が合格になります。

GetRow(テキスト, インデックス)

インデックス付き文字の行座標をピクセル単位で返します。

GetScore(テキスト, インデックス 0, [インデックス 1])

インデックス付き文字の一致得点 (0 ～ 100) を返します。オプションの [インデックス　1] パラメータが 1 の場合は、2 番目に高い得点の文字の得点を返します。 VerifyText 関数では、2 つの文字の一致得点の差が 10% 未満の場合にのみ、2 番目に高い得点の文字を返します。

GetString(テキスト)

テキスト文字列を返します。

GetWide(テキスト, インデックス)

インデックス付き文字の幅をピクセル単位で返します。


時間・タイマ関数

データアクセス

In-Sight 関数リファレンス

注: 値はすべて、参照された関数またはセルから返されます。

関数

説明

GetAllTime(画像)

画像の取り込みおよびジョブの実行に必要な時間をミリ秒単位で返します。入力値が無効であった場合は、#ERR が返されます。

注:

  • このパラメータはセル A0、つまり AcquireImage 関数により返される [image] データ構造体を含むセルを参照している必要があります。
  • 返される GetAllTime 値には、センサフィルムストリップの実行時間は含まれません。
  • GetAllTime 関数とステータスバーは、時間の計算方法が [ジョブのプロファイル] ダイアログ とは異なります。[ジョブのプロファイル] ダイアログでも結果グラフィックスの生成は考慮されます。
  • この関数を式で使用する場合、セルの位置に応じて異なる値が返されます。例えば、GetAllTime(A0) が 80 の場合、1*GetAllTime(A0) も 80 にする必要があります。ただし、1*GetAllTime(A0) がジョブの上部にある場合、他のツールの実行時間を含んでいない GetTime(A0) とほとんど同じ値を返します。1*GetAllTime(A0) がジョブの終わりにある場合、すべてのジョブ実行時間が含まれます。正しい値を返すには、GetAllTime(A0) 専用に個別のセルを作成し、式の中でそのセルに対するセル参照を使用します。例えば、GetAllTime(A0) をセル B2 内に作成する場合、1*B2 はセルの位置に関係なく、正しい値を返します。
  • [最大ビュー接続数] 設定を 2 以上に設定した場合、In-Sight ファームウェア 5.x.x を使ってビジョンシステムが返した GetAllTime 値は、In-Sight ファームウェア 4.x.x を使ってビジョンシステムが返した値より長くなります。画像の取り込みとジョブ実行時間に加えて、In-Sight ファームウェア 5.x.x を実行しているビジョンシステムが返した GetAllTime 値は、複数の表示更新時間を最終値に追加します。In-Sight ファームウェア 4.x.x を実行しているビジョンシステムの場合、この値は含まれません。

GetElapsedTime(画像)

2 回の連続した画像取り込みの間隔をミリ秒単位で返します。入力値が無効であった場合は、#ERR が返されます。

注: このパラメータはセル A0、つまり AcquireImage 関数により返される [image] データ構造体を含むセルを参照している必要があります。

GetExposureTimestamp(画像)

露光タイムスタンプを送信するために使用できる [image] データ構造体を返します (画像取り込みがトリガされ、In-Sight ビジョンシステムが露光を開始した日時の記録)。

注:

  • このパラメータはセル A0、つまり AcquireImage 関数により返される [image] データ構造体を含むセルを参照している必要があります。
  • タイムスタンプ値はすべての In-Sight ビジョンシステムでサポートされ、実際の露光時間に対して 200 マイクロ秒単位の精度です。

GetSystemTimeOffset(時刻)

データ構造体から抽出されたシステム時刻のオフセット値を返します。

注: システム時刻のオフセットは、PTP が有効な場合のみ有効です。In-Sight ビジョンシステムを PTP と併用する場合のセットアップと設定の詳細については、「時刻同期の設定」のトピックを参照してください。

GetTime(セル 1, [セル 2, ...])

セルの可変長リストの実行に必要な時間をミリ秒単位で返します。入力値が無効であった場合は、#ERR が返されます。複数のセルを選択した場合、実行時間の合計が返されます。

GetTimeValue(時刻)

データ構造体を時刻値に変換します。この関数は、FormatOutputBuffer 関数を介して、時間の 64 ビット表現をミリ秒単位で PLC に書き込むために使用します。

注: この関数は、PTP が有効な場合のみ有効です。In-Sight ビジョンシステムを PTP と併用する場合のセットアップと設定の詳細については、「時刻同期の設定」のトピックを参照してください。


ホワイトバランス

カラーデータアクセス

In-Sight 関数リファレンス

注: 次の各関数では、イベントを参照して強制的に値を更新する必要があります。

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含むセル A0 の [image] データ構造体
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル。
  • 数値を含むセル (ゼロ以外の数値は強制的に更新を実行します)。

関数 | 説明
GetBlueWhiteBalance(イベント) | 青成分の現在の WhiteBalance オフセット係数 (0 ～ 255) を返します。
GetGreenWhiteBalance(イベント) | 緑成分の現在の WhiteBalance オフセット係数 (0 ～ 255) を返します。
GetRedWhiteBalance(イベント) | 赤成分の現在の WhiteBalance オフセット係数 (0 ～ 255) を返します。
SetBlueWhiteBalance(イベント) | 青成分の WhiteBalance オフセット係数の値 (0 ～ 255) を返します。
SetGreenWhiteBalance(イベント) | 緑成分の WhiteBalance オフセット係数の値 (0 ～ 255) を返します。
SetRedWhiteBalance(イベント) | 赤成分の WhiteBalance オフセット係数の値 (0 ～ 255) を返します。
Version: 5.6.0


構造体関数

In-Sight 関数リファレンス

構造体関数はスプレッドシートのセルに含まれている値を組み合わせて、ほかの入力パラメータによって簡単に参照することができるグラフィックス、フィクスチャ、マスク、および領域を作成します。構造体の位置と形状の調整は、対話型グラフィックスモードとプロパティシートを使用することにより容易になります。構造体関数には次の関数があります。

  • Annulus 関数
  • Circle 関数
  • Cross 関数
  • フィクスチャ
  • ライン
  • Mask
  • Point 関数
  • Region 関数


Annulus 関数

Annulus 関数 |
構造体関数 | In-Sight 関数リファレンス

フィクスチャされた円環を作成します。

Annulus 関数 (

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

ドーナツ領域.X,

ドーナツ領域.Y,

ドーナツ領域.内側半径,

ドーナツ領域.外側半径,

表示

)

Annulus 関数の入力パラメータ

フィクスチャ

円環を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

ドーナツ領域

円環のサイズと位置を指定します。

X | フィクスチャ座標での X オフセット
Y | フィクスチャ座標での Y オフセット
内側半径 | 内側の半径
外側半径 | 外側の半径

注: フィクスチャおよび円環パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

表示

画像上の円環のグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 | Annulus 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、円環構造体のグラフィックスは表示されません。
2 = 入力のグラフィックスのみ | 円環構造体のグラフィックスが常に表示されます。

Annulus 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | Annulus 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Annulus 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(Annulus) | 画像座標系での、円環の中心の行オフセット
列 | GetCol(Annulus) | 画像座標系での、円環の中心の行オフセット
内側の半径 | GetRadius(Annulus, 0) | インデックスで指定された円環の内側の半径
外側の半径 | GetRadius(Annulus, 1) | インデックスで指定された円環の外側の半径


Circle 関数

構造体関数

In-Sight 関数リファレンス

フィクスチャされた円構造体を作成します。

Circle 関数 (

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

円.X ,

円.Y ,

円.半径 ,

表示

)

Circle 関数の入力パラメータ

フィクスチャ

円を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

円

円のサイズと位置をフィクスチャ座標で指定します。

X | 円の X オフセット
Y | 円の Y オフセット
半径 | 円の半径

注: フィクスチャおよび円パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

表示

画像上の円グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | Circle 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、円構造体のグラフィックスは表示されません。
2 = 入力のグラフィックスのみ | 円構造体のグラフィックスが常に表示されます。

Circle 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | Circle 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Circle 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(Circle) | 画像座標での、円の中心の行オフセット
列 | GetCol(Circle) | 画像座標での、円の中心の列オフセット
半径 | GetRadius(Circle) | 円の半径

関連項目

対話型グラフィックスモード

プロパティシート


Cross 関数

構造体関数

In-Sight 関数リファレンス

フィクスチャされた十字構造体を作成します。

Cross 関数 (

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

十字.X ,

十字.Y ,

十字.角度 ,

十字.高さ ,

十字.幅 ,

表示

)

Cross 関数の入力パラメータ

フィクスチャ

十字を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

十字

十字のサイズと位置をフィクスチャ座標で指定します。

X | 十字の X オフセット
Y | 十字の Y オフセット
角度 | 十字の方向
高さ | 十字の X 軸の寸法
幅 | 十字の Y 軸の寸法

注: フィクスチャおよび十字パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

表示

画像上の十字グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | Cross 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、十字構造体のグラフィックスは表示されません。
2 = 入力のグラフィックスのみ | 十字のグラフィックスが常に表示されます。

Cross 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | Cross 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Cross 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(Cross) | 十字の中心の行オフセットを、画像座標で返します。
列 | GetCol(Cross) | 十字の中心の列オフセットを、画像座標で返します。
角度 | GetAngle(Cross) | 十字の方向を返します。
高さ | GetHigh(Cross) | X 軸の寸法を返します。
幅 | GetWide(Cross) | Ｙ 軸の寸法を返します。

関連項目

対話型グラフィックスモード

プロパティシート


Fixture 関数

構造体関数

In-Sight 関数リファレンス

フィクスチャ構造体を作成します。

Fixture 関数 (

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

表示

)

Fixture 関数の入力パラメータ

フィクスチャ

フィクスチャを定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

表示

画像上のフィクスチャポイントのグラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | Fixture 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、フィクスチャポイントのグラフィックスは表示されません。
2 = 入力のグラフィックスのみ | フィクスチャポイントのグラフィックスが常に表示されます。

Fixture 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | Fixture 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Fixture 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(フィクスチャ) | フィクスチャの行オフセットを、画像座標で返します。
列 | GetCol(フィクスチャ) | フィクスチャの列オフセットを、画像座標で返します。
角度 | GetAngle(フィクスチャ) | 配向角を画像座標で返します。

関連項目

対話型グラフィックスモード

プロパティシート


Line 関数

構造体関数

In-Sight 関数リファレンス

フィクスチャされた線構造体を作成します。

Line 関数 (

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

ライン.X 0 ,

ライン.Y 0 ,

ライン.X 1 ,

ライン.Y 1 ,

表示

)

Line 関数の入力パラメータ

フィクスチャ

線を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

ライン

線の端点を指定します。

X 0 | 始点の X オフセット
Y 0 | 始点の Y オフセット
X 1 | 終点の X オフセット
Y 1 | 終点の X オフセット

注: フィクスチャおよび行パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

表示

画像上の線グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | Line 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、線構造体のグラフィックスは表示されません。
2 = 入力のグラフィックスのみ | 線構造体が常に表示されます。

Line 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | Line 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Line 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 0 | GetRow(Line, 0) | 画像座標での、始点の行オフセット
列 0 | GetCol(Line, 0) | 画像座標での、始点の列オフセット
行 1 | GetRow(Line, 1) | 画像座標での、終点の行オフセット
列 1 | GetCol(Line, 1) | 画像座標での、終点の列オフセット

関連項目

対話型グラフィックスモード

プロパティシート


Mask 関数

構造体関数

In-Sight 関数リファレンス

Mask 関数を使用して不規則な形状の 2 値化画像マスクを作成します。このマスクを使用して画像内の特定の領域をハイライトし (値 255 が割り当てられた「対象ピクセル」)、ほかの領域を検査対象から除外します (値 0 が割り当てられた「対象外ピクセル」)。この関数は SurfaceFlaw 関数の入力として使用することも、Flaw Detection 関数の FlexFlawModel 関数で Flex を適用することもできます。

  • Mask 関数の概要
  • Mask の入力パラメータ
  • Mask の出力
  • 関連項目

概要

画像マスクを使用して特定の特徴を検査対象から除去し、そのほかの領域をハイライトします。マスクは 2 ステップからなる内部処理で作成されます。最初のステップではエッジ検出とセグメンテーションを実行します。この間に入力画像は [平滑化係数] パラメータ設定に基づいて平滑化されます。平滑化された画像を使用すると、エッジ強調画像が内部で作成されます。

注: カラー画像のエッジ強調画像は 3 色すべてのチャネル (赤、緑、青) を基に計算されます。

次に、ブロブ解析を使用して、画像をエッジ変化に基づきセグメンテーションします。これはエッジ強調画像で実行されます。このとき、暗いブロブはセグメントに抽出され、インデックスおよびラベルが付けられます。[マスク生成] パラメータの [穴塗りつぶし最大サイズ]、[カーネルサイズ中央値] および [収縮マスク数] は、画像マスクの穴の塗りつぶし、境界の平滑化、狭いストリップの削除にそれぞれ使用することができます。[カーネルサイズ中央値] パラメータはエッジの平滑化およびストリップの削除に使用すると特に有効です。

この処理の 2 つ目のステップでは、画像マスクの生成に使用されるエッジまたはセグメントを選択します。デフォルトではエッジを使用して ([マスク方法] パラメータはデフォルトで [エッジマスク] に設定されます)、エッジ強調に基づいた画像マスクが生成されます。この画像マスクでは、エッジピクセルのみがマスクされ、そのほかのピクセルはすべて表示されます。このタイプのマスクは、ラベル、テキストまたはロゴを除外する場合に使用すると有用です。

また、[マスク方法] パラメータを [最大セグメント] または [選択したセグメント] のいずれかに設定してセグメントを使用することもできます。背景に 0、次に大きいセグメントに 1 のインデックスが付き、残りのセグメントはそれぞれのサイズに基づいてソートされます (画像内で色分けされ、インデックスが付けられます)。このタイプのマスクは、背景や画像内の大きな領域を遮断する場合に使用すると有用です。

関数を設定する場合は、[表示画像] パラメータを使用してセグメントを表示することができます。セグメントには数値のインデックスが付き、色分けされて表示されます (黒ピクセルはセグメントの一部ではなく、白ピクセルは最大セグメントの一部です)。

マスクが適切に設定されると、登録され、このマスクがモデルとして内部で保持されます。関数のプロパティシートが開いている間にいずれかのパラメータが変更されると、マスクは新しいパラメータ設定に再登録されます。

注:
  • マスクの対象範囲が画像から画像への動きを有する場合、マスクに [フィクスチャ] があることを確認してください。
  • パラメータの外部コントロールを許可するために、以下のパラメータのいずれかがスプレッドシートに 絶対参照として配置されている場合、以下のパラメータが変更されたときは、自動的にマスクモデルが再登録されます。マスク方法、平滑化係数、最小エッジコントラスト、最小セグメント面積、穴塗りつぶし最大サイズ、収縮マスク数、反転、カーネルサイズ中央値、または セグメントです。
  • パラメータの外部コントロールを許可するために [領域] パラメータが 絶対参照としてスプレッドシートに入力されている場合、パラメータが変更されたときは、[マスクを登録] ボタンを押してマスクモデルを再登録してください。関数のプロパティシートが開いている間に [領域] パラメータが変更されると、マスクモデルは自動的に再登録されます。

Mask 関数の入力パラメータ

Mask 関数 (

画像 ,

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

スケール ,

外部領域 ,

傷モデル参照 ,

セグメント化.平滑化係数 ,

セグメント化.最小エッジコントラスト ,

セグメント化.最小セグメント面積 ,

マスク生成.マスク方法 ,

マスク生成.セグメント ,

マスク生成.穴塗りつぶし最大サイズ ,

マスク生成.カーネルサイズ中央値 ,

マスク生成.収縮マスク数 ,

マスク生成.反転 ,

マスク生成.マスクを登録 ,

タイムアウト ,

表示画像,

表示

)

画像

このパラメータは有効な [image] データ構造体を含んでいるスプレッドシートのセルを参照している必要があります。デフォルトで参照されるセルは A0 で、このセルに AcquireImage 関数によって返される [image] データ構造体が含まれています。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 | 画像座標での行オフセットを指定します。
列 | 画像座標での列オフセットを指定します。
角度 | 画像座標での角度を指定します。

領域

これは対象領域 (ROI) とも呼ばれ、画像処理の対象となる画像の領域を指定します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、[領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。

注: パラメータの外部コントロールを許可するために [領域] パラメータが絶対参照としてスプレッドシートに入力されている場合、パラメータが変更されたときは、[マスクを登録] ボタンを押してマスクモデルを再登録してください。関数のプロパティシートが開いている間に [領域] パラメータが変更されると、マスクモデルは自動的に再登録されます。

X | フィクスチャ座標での原点の X オフセットを指定します。
Y | フィクスチャ座標での原点の Y オフセットを指定します。
高さ | 領域の X 軸に沿った寸法を指定します。
幅 | 領域の Y 軸に沿った寸法を指定します。
角度 | フィクスチャ座標での角度を指定します。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位

注: [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

スケール

マスクのサイズを、登録したフィクスチャサイズに対する割合 (%) で指定します (80 ～ 120、デフォルト = 100)。

注: 変化する [スケール] パラメータの影響を表示するには、コントロールをスプレッドシートにドラッグ & ドロップします。これにより EditInt 関数が作成され、自動的に [スケール] パラメータに対する絶対参照として分類されます。関数のプロパティシートが開いている間に [スケール] パラメータの値を変更すると、マスクが新しいスケール値で自動的に再登録され、パラメータの変更による影響がわかりにくくなります。

外部領域

オペレータ I/F 関数が入力されているスプレッドシートのセルへの参照を指定します。このパラメータを使用すると、Mask 関数は、[領域] と [フィクスチャ] の設定を無視し、参照先領域に指定された画像領域を検査します。

注: このパラメータが外部定義領域の参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部定義領域を参照します。

傷モデル参照

Flex アルゴリズムによって修正されたモデルデータを含み、FlexFlawModel 関数によって出力される [image] データ構造体を含んでいるセルへの参照を指定します。これにより、FlexFlawModel 関数の Flex アルゴリズムによる Flex をマスクに適用して、プロセスばらつきを考慮することができます。

セグメント化

関数がセグメンテーション解析を実行する方法を指定します。

平滑化係数 | エッジ検出を実行する前に適用する平滑化の量を指定します (0 ～ 31、デフォルト = 1)。平滑化を適用すると、グレースケール値を平均化し、急速な変化による影響を弱めます。
最小エッジコントラスト | エッジ検出に使用する最小コントラストを指定します (1 ～ 100、デフォルト = 10)。 注: このパラメータは[マスク方法] パラメータが [エッジマスク] に設定されている場合のみ有効になります。
最小セグメント面積 | 抽出する必要のあるセグメントの最小面積をピクセル単位で指定します (1 ～ 50000、デフォルト = 1000)。このパラメータはセグメントからノイズを除去する場合に有効です。 注: このパラメータは [マスク方法] パラメータを [最大セグメント] または [選択したセグメント] のいずれかに設定した場合に使用します。

マスク生成

マスクを構築する方法を指定します。

マスク方法

マスクを構築する基準として、エッジまたはセグメントを指定します。

0 = 最大セグメント | マスクの生成に最大セグメントを使用するように指定します。
1 = エッジマスク (デフォルト) | マスクの生成にエッジ強調を使用するように指定します。使用するエッジを決定するには、最小エッジコントラストを使用します。
2 = 選択したセグメント | マスクの生成にユーザーが選択したセグメントを使用するように指定します。使用するセグメントを指定するには、[セグメント] パラメータを使用します。

セグメント

マスクの生成に特定のセグメントを使用するように指定します。カンマ区切り文字列 (1,2,5,7 など) を入力し、特定のセグメントを選択します。

注:
  • このパラメータを有効にするには、[マスク方法] パラメータを [選択したセグメント] に設定する必要があります。
  • [表示画像] パラメータを [セグメント化した画像] に設定した場合、検出されたセグメントの番号を含んでいる文字列が、情報アイコンの横に表示されます。リストに表示されている最初の番号が選択されたセグメントであり、その後に検出された使用可能なセグメントが続きます。

穴塗りつぶし最大サイズ

穴を塗りつぶすために必要な (穴としてカウントされない) 最大サイズを指定します (0 ～ 10000、デフォルト = 0)。

注: [マスク方法] パラメータが [エッジマスク] に設定されている場合は、このパラメータは 0 に設定する必要があります。

カーネルサイズ中央値

マスク画像のエッジを平滑化するために使用するカーネルサイズ中央値を指定します (0 ～10、デフォルト = 0)。カーネルが常に奇数値で作成されるように、カーネルは (2N + 1) に基づいて構築されます。パラメータを 0 に設定すると、カーネルを使用しないように指定します。

収縮マスク数

生成された画像が収縮または膨張する回数を指定します (-100 ～ 100、デフォルト = 0)。負の値または正の値を使用できます。負の値は画像を膨張させます。パラメータを 0 に設定すると、収縮も膨張もしないように指定します。

反転

マスクを反転するかどうかを指定します (つまり、白を黒、黒を白)。

0 = OFF (デフォルト) | マスクは反転しません。
1 = ON | マスクは反転します。

マスクを登録

現在設定されているパラメータ設定でマスクが登録されるように指定します。

注: このパラメータをスプレッドシートに挿入して、再登録操作の外部コントロールを許可することもできます。このパラメータをスプレッドシートに入力すると、カスタムビューを使用して、外部デバイスで実行時にマスクを再登録することができます。

タイムアウト

マスクを計算する時間をミリ秒単位で指定します (0 ～ 30000、デフォルト = 0)。指定された時間が経過すると、実行は停止し、#ERR が返されます。

表示画像

この関数によって生成される出力画像のタイプを指定します。

0 = 入力画像 | 入力画像が表示されます。
1 = エッジ画像 | エッジ強調画像が表示されます。
2 = セグメント化した画像 | 色分けされ、数値のインデックスが付いたセグメント画像が表示されます。
3 = マスク画像 (デフォルト) | フィクスチャ入力を考慮した 2 値化マスク画像です。セグメンテーションとマスク生成処理の後に生成されます。ピクセル値 255 = 対象ピクセル、ピクセル値 0 = 対象外ピクセル

表示

画像の上に表示されるグラフィックスオーバレイを指定します。

0 = 非表示 (デフォルト) | Mask 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、入力画像領域は表示されません。
1 = 結果のグラフィックスのみ | 処理された画像が常に表示されます。
2 = 入力と結果のグラフィックス | 入力画像領域とマスクが常に表示されます。

Mask 関数の出力

戻り値

2 値化マスクを含んでいる [image] データ構造体。入力パラメータが無効であれば #ERR を返します。

注:
  • 画像は関数のデータ構造体に保存されません。
  • Mask 関数は誤った出力マスクを生成することがあり、次の条件では関数が #ERR 条件を返さないことがあります。最初に、[選択されたセグメント] の [マスク方法] を使用して、マスクが登録されます。次に、[領域] が、選択されたセグメントを含んでいない画像の領域に移動されます。関数が再登録されたら、新しい [領域] の位置および以前に登録されたマスクが表示されます。関数はエラー状態になりますが、#ERR は返しません。この問題を解消するには、関数のプロパティシートをもう一度開き、新しい領域内にあるセグメントを指定して、マスクを再登録します。

関連項目

  • 構造体データアクセス関数
  • 構造体関数
  • SurfaceFlaw 関数
  • FlexFlawModel 関数
  • プロパティシートの使用方法


Point 関数

構造体関数

In-Sight 関数リファレンス

フィクスチャされた点構造体を作成します。

Point 関数 (

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

点.X ,

点.Y ,

表示

)

Point 関数の入力パラメータ

フィクスチャ

点を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

点

点の位置をフィクスチャ座標で指定します。

X | 十字の X オフセット
Y | 十字の Y オフセット

注: フィクスチャおよび点パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

表示

画像上の点オーバレイグラフィックスの表示モードを指定します。

0 = 非表示 (デフォルト) | Point 関数を含んでいるセルがスプレッドシート上でハイライトされている場合を除き、点構造体は表示されません。
2 = 入力のグラフィックスのみ | 点構造体が常に表示されます。

Point 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | Point 関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Point 関数データアクセス関数

次のデータアクセス関数がスプレッドシートに自動挿入され、結果テーブルが作成されます。

行 | GetRow(点) | 画像座標での、点の行オフセット
列 | GetCol(点) | 画像座標での、点の列オフセット

関連項目

対話型グラフィックスモード

プロパティシート


Region 関数

構造体関数

In-Sight 関数リファレンス

フィクスチャ領域構造体を作成します。

Region 関数 (

フィクスチャ.行 ,

フィクスチャ.列 ,

フィクスチャ.角度 ,

領域.X ,

領域.Y ,

領域.高さ ,

領域.幅 ,

領域.角度 ,

領域.カーブ ,

表示

)

Region 関数の入力パラメータ

フィクスチャ

領域を定義する画像座標系を指定します。

行 | 行オフセット
列 | 列オフセット
角度 | 角度

領域

位置、サイズ、回転、曲率 (ドーナツ状セクタの場合) を指定します。領域は常に、フィクスチャの座標系内で定義されます。

X | フィクスチャ座標での原点の X オフセット。
Y | フィクスチャ座標での原点の Y オフセット。
高さ | 領域の X 軸に沿った寸法。
幅 | 領域の Y 軸に沿った寸法。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。

注: フィクスチャおよび領域パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

表示

画像上の領域グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | 領域関数を含んでいるセルがスプレッドシート内でハイライト表示されている場合を除き、領域構造体グラフィックスは表示されません。
2 = 入力のグラフィックスのみ | 領域構造体グラフィックスが常に表示されます。

Region 関数の出力

戻り値 | データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | 領域関数を初めてセルに挿入すると、スプレッドシート内に結果テーブルが自動的に作成されます。

Region 関数データアクセス関数

次のデータアクセス関数が、結果テーブルを作成するためにスプレッドシートに自動挿入されます。

行 | GetRow(領域) | 画像座標系での、領域の原点の行オフセット。
列 | GetCol(領域) | 画像座標系での、領域の原点の列オフセット。
高さ | GetHigh(領域) | 領域の X 軸に沿った寸法。
幅 | GetWide(領域) | 領域の Y 軸に沿った寸法。
角度 | GetAngle(領域) | 画像座標での角度。
カーブ | GetCurve(領域) | 領域の X 軸と反対側の境界線との間の角度変位。

関連項目

対話型グラフィックスモード

プロパティシート


スクリプト

In-Sight 関数リファレンス

In-Sight スクリプト関数を使用して、セル内に JavaScript ソースコードを作成してアクセスします。

  • Script: JavaScript コードを作成して編集し、ユーザが作成した ([スクリプトの編集] ダイアログで作成された) ソースコードを実行します。
  • Get: Script 関数によって返された配列および/またはオブジェクトのプロパティにアクセスするデータアクセス関数。
  • Script 関数の JavaScript ソースコードと API リファレンス: Script 関数用に JavaScript ソースコードを作成しているときに従うガイドラインの概要。

注: これらの関数は、In-Sight ファームウェア 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

In-Sight についてスクリプト関数

In-Sight Script 関数を使用してスクリプトを作成し、JavaScript ソースコードをセル内に格納すると、カスタム設計のソースコードをジョブの一部にすることができます。

  • 概要
  • In-Sight Explorer JavaScript サンプル
注: Script 関数は、基本的なプログラミングの原則に関する知識を必要とします。この概要のトピックに記載されている情報は、すでに基本的なプログラミングの原則を熟知しているユーザを対象としています。JavaScript プログラミング言語の詳細については、次を参考にしてください (インターネットへのアクセスが必要です)。
  • Mozilla JavaScript ガイド
  • Mozilla JavaScript 言語リファレンス
  • 『JavaScript: The Definitive Guide』(David Flanagan 著)

概要

In-Sight スクリプトでは、ダイナミックコンピュータプログラミング言語である JavaScript を使用します。スクリプトには、反復的な処理ルーチン、文字列の解析とフォーマッットの操作、検査とは別に実行されるスクリプトを処理するバックグラウンドイベント、カスタムグラフィックス、およびファイルシステム上に格納された共有 JavaScript モジュールを作成する機能が備えられています。

この概要は、JavaScript 言語を In-Sight アプリケーションで使用する場合の重要な側面を詳細に説明する簡潔なセクションとなっています。

  • 基本的な語彙構造
  • コメント
  • 変数
  • オブジェクトと配列
    • オブジェクトのプロパティ
    • プロパティシンタックス
    • オブジェクトのリテラルシンタックス
    • 配列
  • JavaScript ビルトインクラス
    • 数値
    • 文字列リテラル
  • 関数
    • 可変長引数関数
  • 式と演算子
  • 型の変換
    • typeof 演算子
  • if ステートメント
  • switch ステートメント
  • ループ
  • 例外
    • 例外のスロー
    • Try/Catch/Finally ブロック
  • 正規表現

基本的な語彙構造

In-Sight Explorer 内へ JavaScript を実装するには、欧州電子計算機工業会によって承認されているオープンスタンダードのバージョン 5 (ECMAScript 5 (ECMA5) としても知られています) に従います。ECMAScript 5 は Unicode 3 (またはそれ以降) の文字セット (UTF-8) を使用します。また、次の点で C、C++、C#、および Java シンタックスと似ています。

  • この言語は大文字と小文字の区別があり、言語キーワード、変数、関数の名前を必要とし、その他の識別子は一貫した大文字/小文字の設定を使用します。
  • 識別子を使用して変数および関数に名前を付けます。この名前の先頭は文字、アンダースコア (_)、またはドル記号 ($) である必要があります。数字は先頭では使用できません。
  • 複合ステートメントは中かっこ ({}) で囲みます。
  • 空白は無視されるので、コードをクリーンにフォーマットすることができ、読みやすく、理解しやすいものとなります。
  • セミコロン (;) でステートメントを区切ります。行の末尾ではオプションとなっていますが、ステートメントの末尾を明示的に区別することを強く推奨します。ステートメントが複数行に分割される場合は、セミコロンを省略することができます。ただし、JavaScript は常に改行をセミコロンとして解釈するので、return、break、または continue と、これらのキーワードの後の式との間には改行を挿入しないでください。

コメント

JavaScript でコメントを示すには、2 つのスタイルがあります。行の末尾の 2 つのスラッシュ (//) 以降の文字がコメントとなり、/* と */ の内側にある文字もコメントとして扱われます (/* JavaScript comments */)。

次の図は、コメントを示す 2 つのスタイルを表しています。

/* JavaScript コメント */
var x; // Java、C# および
       // C++ コメントのような外観
/*
* そしてこれらは複数行
* にわたって使用できる。
*/

変数

変数を使用して、オブジェクトまたは値のシンボリック名を定義し、そのシンボリック名で参照できるようにします。JavaScript には、プリミティブ型とオブジェクト型の 2 つの型があります。各変数はプリミティブな値 (数値、文字列、true/false、null、または undefined) またはオブジェクト (プリミティブでない値として定義されます) を参照します。

下記の例に示すように、変数は var キーワードで宣言されます。

            var aBc, zz32;
var q = "abc", r = 'def';
var p = true, q = false;

変数のスコープはグローバルまたは関数のいずれかです。グローバルスコープでは、変数は関数の外に宣言され、宣言される Script セルまたはモジュール内のすべてのコードに使用可能ですが、その他の Script セルまたはモジュール内のコードには使用できません。関数スコープでは、変数は関数内のどこにでも配置され、関数内でのみ使用可能です。

オブジェクトと配列

JavaScript では、プリミティブでない値はオブジェクトであると見なされます。プロパティに名前と値を含んでいる場合は、プリミティブな値または別のオブジェクトのいずれかである可能性があります。オブジェクトは、基本的には名前と値の順序付けされていないコレクションであり、配列は名前と値の順序付けされたコレクションです。

オブジェクトのプロパティ

JavaScript では、オブジェクトは動的に型指定されます。

  • 各オブジェクトはプロパティの辞書です。
  • 各プロパティは名前と値の組です。
  • プロパティは実行時に追加および削除されます。

プロパティはプロトタイプオブジェクトから継承されます。

  • 新しいオブジェクトはそれぞれ、そのプロトタイプのコピーです。
  • プロトタイプは独自のプロパティから次々に派生することができます。

プロパティシンタックス

JavaScript では、プロパティアクセスの定義に 2 つの型のシンタックスを使用します。プロパティの場合、次のシンタックスを最初に入れる必要があります (いずれの型にも該当、ドットの前後の式または角かっこは先に評価されます)。

  • ドット表記:
    • a.prop = 123;	// プロパティを追加
    • b = a.prop;	// 123
    • delete a.prop;	// プロパティを削除
    • c = a.prop;	// 未定義
  • 名前/文字列を含む角かっこ:
    • a ["break 1"] = 123	// プロパティを追加
    • b = a["break 1"];	// 123
    • nm = "break 1";		// 変数を使用可
    • c = a[nm];		// 123
    • delete a[nm]		// プロパティを削除

オブジェクトのリテラルシンタックス

新しいオブジェクトを作成するには、下記に示すように name:value の組のカンマで区切ったリストを使用します。

            var myrectangle = {
    width: 100, height: 50,
    "return": {a:1, b:2, c:3},
    getArea: function() {
       return this.width * this.height;
    }
};

配列

JavaScript では、配列はちょうど標準のオブジェクトのようですが、下記に示すように、数値のプロパティ名を使用します。

注: length プロパティは 1 + 一番大きな番号の要素です。

            var a = []; 	// 空
var b = [9.5, "Fred", true];
var c = b[1];	// "Fred"
var d = b["1"]	// "Fred"
var e = b[9]	// 未定義
b[4491] = 2;	// 1 つの要素を追加
b.newProperty = "hello"

JavaScript ビルトインクラス

次は JavaScript ビルトインクラスの例です。

  • 配列: sort, reverse, concat, slice, push, pop, shift, unshift
  • 演算: abs, min, max, sqrt, ceil, floor, sin, cos, tan, asin, acos, atan
  • 文字列: indexOf, match, replace, split, substring, toUpper, toLower, trim
  • 日付: new Date(), toString, add, subtract

数値

JavaScript では、すべての数値を IEEE 754 で定義された 64 ビット浮動小数点形式を使用して表します。JavaScript プログラムで数値が表示されている場合は、数値リテラルと呼ばれます。JavaScript で数値および数値リテラルを表す方法を次に示します。

  • 10 進法: 1、47、3.14、-24e-13
  • 16 進法: 0x7fff

文字列リテラル

JavaScript で使用される文字列リテラルの例を次に示します。

            "Hello I'm Fred"
'I am "Sam", I am'
"Hello\t\ "World\"\x0D\u000A"
"Hello \
big \
world" (EC5)

関数

関数は特殊な型のオブジェクトであり、これに関連付けられた実行可能コードを含んでおり、呼び出してコードを実行し、値を返すことができます関数は、配列のようにオブジェクトとは異なった動作をし、使用するための特殊な言語のシンタックスがあります。最も重要なこととして、関数は true の値であり、プログラムでは標準のオブジェクトのように扱うことができます。

関数は function キーワードを使用して定義し、引数および return はオプションです。次の書式は同等です。

            function  sum(x, y) {
  return x + y;
}
var sum = function (x, y) {
  return x + y;
}

可変長引数関数

JavaScript では、どの関数も可変数引数を取得することができます。引数キーワードは現在の関数の引数の配列です。これを次の例に示します。

            function sum() {
  var i, total = 0;
  for (i=0; i<arguments.length; i++) {
    total += (+arguments[i]);
  }
  return total;
}
var z = sum(1,2, "3.14");	// 6.14

式と演算子

JavaScript でよく使用される式と演算子を次に示します。

  • プライマリ: (x) x.y f(x,y,z) a[x]
  • 単項: +x -x !x ++x -x x++ x-- ~x32
  • 倍数詞: * / %
  • 付加: - + (+ は文字列の結合にも使用されます)
  • シフト32: << >> (符号拡張) >>> (ゼロ拡張)
  • リレーショナル: < > <= >= (文字列ではアルファベット順)
  • 等値: == != === !== (厳格な等式/不等式)
  • ビット32
    • AND: &
    • OR: |
    • XOR: ^
    • 条件付き AND: &&
    • 条件付き OR: ||
    • 条件付き if: ?:
  • 割り当て: = *= /= %= += -= &= ^= |= <<= >>= >>>=

型の変換

必要な場合には (および可能であれば) いつでも自動的に値が変換され、演算子は左結合的です。変換時に、次のような弱い等式ステートメントに留意してください。

            if ("4" == 2 * 2)	// true
if ("4" === 2 * 2)	// false

「False と思われる」値は false に変換され(undefined, null, 0, -0, NaN, "")、その他のすべての値は true に変換されます(if ("false") {…} // true)。

typeof 演算子

typeof 演算子はその演算数の方を識別する文字列を返します。

値 | typeof value ==
Null | "null"
未定義 | "undefined"
任意の数値 (NaN) | "number"
文字列 | "string"
True/False | "boolean"
任意の関数 | "function"
任意のオブジェクト | "object"

if ステートメント

JavaScript では、if ステートメントは C と同じシンタックスを使用します。

            if (x>0) {
  y = Math.Sqrt(x);
}
else if (x == 0) {
  y = 0;
}
else
  y = undefined;	// 中かっこはオプション
            // (ただし推奨される)

switch ステートメント

JavaScript では、switch ステートメントは C と似ていますが、文字列も使用することができます。

 switch (name) {
  case "Fred":
    processFredReport();
    break;
  case "Sam":
  case "Samantha":
    processSamReport();
    break;
  case 911: 	// "911" とも一致
    emergencyAlert ();
        // フォールスルー (推奨されない)
  default:
    return "Unable to process report!";
}

ループ

JavaScript ではループを作成するメソッドがいくつかあります。

  • For
    • for (var x = 0; x < 100; x++) {...}
  • While
    • while (!inputFile.isAtEnd()) {...}
  • Do While
    • do {...}while (foundItem==0);
  • For/in
    • for (var propName in myObject) {...}

注: プロパティの順序は保障されません。

  • Break
    • これを使用して閉じているループを終了します。
    • if (foundRecord) break;
  • Continue
    • これを使用して次のループイテレーションを開始します。
    • if (skipThisItem) continue;

例外

例外を使用して、例外的な条件またはエラーの発生を示します。スローによってエラー発生の信号が送信され、一方で、例外またはエラーを処理するために、try/catch/finally ステートメントが JavaScript によって使用されます。

例外のスロー

JavaScript で例外をスローする方法を次に示します。

            if (area <= 0) {
  throw new Error("area must be positive");
  --or--
  throw 'Invalid argument';
  --or--
  throw radius * 3.14;	// 通常は使用されないが合法
}

Try/Catch/Finally ブロック

try 句は、処理する例外を含んでいるコードのブロックを定義し、その後に catch または finally 句のいずれかが続きます。これら 2 つはオプションですが、try ブロックの後にこれらの句の少なくとも 1 つが続く必要があります。JavaScript で例外またはエラーを処理する方法を次に示します。

            try {
  sendAllOutput (stream);
}
catch (ex) {				// オプション (ただし 1 つは必要)
  console.log  (ex);
}
finally {				// オプション (ただし 1 つは必要)
  stream.close ();
}

正規表現

JavaScript でよく使用される正規表現の例を次に示します。

            var x1 = new RegExp("[a-z].*");
            var x2 = /[a-z].*/;

このテストメソッドはマッチに対して true を返します。

valid = x1.test(input);

exec メソッドは複数の結果を返します。

            var x3 = /Tool\d*;
while (r = x3.exec(text))
{
  console.log("Found" + r[0] +
    "at" + r.index +
    "now at" + x3.lastIndex);
}

In-Sight Explorer JavaScript サンプル

In-Sight Explorer 開発環境内で JavaScript の開発と実装を支援するため、ジョブのサンプルとスニペットが含まれています。これらは適切な機能のモデリングに使用できる例を備えています。

ジョブのサンプルとスニペットはコード内にコメントを含むように設計されており、コードを構築する方法と目的を詳細に示し、さらにサンプル内に含まれている対象とする機能について説明しています。

ジョブのサンプルは次のディレクトリに含まれています。C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Explorer 5.1.0\Sample Jobs\Spreadsheet\Scripting

スニペットは、パレットの [スニペット] タブにある [スクリプト] フォルダに含まれています。


スクリプト

スクリプト関数

In-Sight 関数リファレンス

[スクリプトの編集] ダイアログを使用して作成/編集した、ユーザ定義の JavaScript ソースコードを実行します。Script 関数には、動作を定義する JavaScript スクリプトコードが含まれており (.js ファイルとして保存および格納できます)、ソースコードでは個々の Script 関数の動作のみを定義します。例えば、ジョブに複数の Script 関数がある場合、1 つの Script 関数で定義された変数は、その特定の Script 関数用にのみ定義されており、ジョブのすべての Script 関数用ではありません。

  • Script の入力パラメータ
  • Script の出力
  • Script データアクセス関数
  • 関連項目
注:
  • この関数は、In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムだけで使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • 次の制限は、すべての Script 関数および指定したジョブで使用される外部スクリプトモジュールによって割り当てられたメモリに適用されます。

    • スクリプトのメモリに割り当てられる最大バイト数の制限は 4MB です。
    • スタックに割り当てられる最大バイト数の制限は 64KB です。
  • 不要なメモリの割り当てを避けるため、使用していないすべての関数をスクリプトから削除する必要があります (デフォルトのサンプルスクリプト内で使用されていない関数など)。例えば、文字列オブジェクトを生成してプロットする、サンプルの使用されていない draw 関数が含まれているスクリプトは、メモリおよび CPU サイクルを消費します。

  • 実行を無効にするようにセルに示す Script 関数の機能は、ジョブのロードに関しては明示的にその他のスプレッドシート関数とは異なります。通常は、その他のスプレッドシート関数は、関数の実行後に記録された最後の値を保持します。無効になっている関数を参照する関数は、記録された最後の値を返します。ただし、Script 関数はその内部実行メソッドの実行を必要とするため、無効になっている Script 関数をロードすると、Script データ構造体を表示しますが、Get 関数が特定の戻り値を期待しているものの、これは Script 関数が実行されなかったために返されていないので、Script データ構造体を参照する Get 関数は #ERR を返します。

  • Script 関数は Dialog 関数内ではサポートされていません。

スクリプトの入力パラメータ

スクリプト(

引数 1,

...,

引数 100

)

従来の In-Sight スプレッドシート関数とは異なり、Script 関数はさまざまな入力引数を取得することができます (1 ～ 100)。各引数は、次の値タイプのいずれかを生成するセル参照、リテラル値、または式である必要があります。

  • 数値
  • 文字列
  • イベント
  • 形状オブジェクト
  • データ構造体
  • 、 [image] 、 [image] 、 [image] 、または [image] データ構造体
  • または [image] データ構造体 (別の Script 関数から返されたもの)
注:
  • セル範囲が引数として指定されている場合、その範囲に含まれている個々のセル参照まで拡張されるので、セル範囲に含まれている引数と同数の引数が消費されます。
  • Script 関数の引数が、 [image] 、 [image] 、 [image] 、 [image] 、または [image] データ構造体を返している別のセルへの参照となっている場合、Script 関数に渡されるオブジェクトは、実行メソッドが返されるまでの間のみ使用できます。Script 関数は直接このオブジェクトを返し、これを Script 関数を含んでいるセルの結果値として使用できます。ただし、スクリプトがこのオブジェクトを内部に (例えば、その描画メソッドで使用して) 格納する場合は、実行メソッドが返された後、このオブジェクトは使用不能になり、そのメソッドのいずれかを呼び出そうとするとエラーになります。実行メソッドによって返されたスクリプトオブジェクトのプロパティなどの結果構造体をスクリプトが返す場合にも、以上のことが適用されます。例えば、基になるオブジェクトが有効でなくなるので、これらのプロパティのいずれかは Get 関数によって使用できなくなります。
  • In-Sight 5705 または 5705C ビジョンシステムの実行時に、math 演算に NaN または undefined の値が含まれていると、Script 関数は誤った結果を返すことがあります。

  • スクリプトの作成時に、下記の例に示すように入力引数を検証するコードを含めると、エラーを削減することができます。

                                        function Tool()
{
}
module.exports = Tool;
function isNumber(n) {
  if (n === undefined || n == null || isNaN(parseFloat(n)) || !isFinite(n))
    return false;
  return true;
}
Tool.prototype.run = function(x, y)
{
  if (!isNumber(x) || !isNumber(y)){
    throw new Error("Usage: Requires 2 numeric arguments");
  return +x + +y;
}

スクリプトの出力

戻り値

この関数は、次のタイプのいずれかの値を返します。

  • 数値
  • true (1) または false (0)
  • 文字列
  • データ構造体
  • 、 [image] 、 [image] 、 [image] 、または [image] データ構造体
  • 形状オブジェクト
  • オブジェクト
  • null、undefined、または no return ステートメント (空のオブジェクトと同じに扱われます)

この関数は、次のいずれかの条件の場合に #ERR を返します。

  • ソースコードが実行メソッドを含んでいない場合。
  • 引数の値のいずれかがサポートされていないタイプである場合。
  • コンストラクタが例外をスローする場合。

注: GetErrorString 関数を使用して、例外メッセージをソースコードに書き込んだ場合に、例外メッセージを取得することができます。すべての例外は、同じエラーコード (20000005) を返します。

スクリプトデータアクセス関数

Get 関数を使用して、Script 関数によって返されるオブジェクトのプロパティにアクセスします。

関連項目

  • スクリプト関数
  • Script 関数の JavaScript ソースコードと API リファレンス:
  • [スクリプトの編集] ダイアログ
  • Get 関数


Script 関数の JavaScript ソースコードと API リファレンス:

スクリプト関数

In-Sight 関数リファレンス

Script 関数用に JavaScript ソースコードを作成する場合、次のガイドラインに従う必要があります。In-Sight Explorer 内へ JavaScript を実装するには、欧州電子計算機工業会によって承認されているオープンスタンダードのバージョン 5 (ECMAScript 5 (ECMA5) としても知られています) に従います。

注:次の例の「Tool」関数名は任意の名前であり (Script 関数自体の操作には何も影響しない)、すべての In-Sight の例とサンプルスクリプトで使用されます。「Tool」関数名にはほかの名前を付けることができますが、Script 関数のソースコード全体を通じてその名前をずっと使い続ける必要があります。また、以下の例の中で「この」キーワードは、constructor 関数を使って作成、初期化された Tool オブジェクトを参照します。

  • コンストラクタ
  • Run メソッド
  • Draw メソッド
  • Save および Loadメソッド
  • タイムアウト
  • ファイルパス
  • Script モジュール
  • データ構造体の入力/出力
  • バイナリ構造体の入力/出力
  • 形状オブジェクト
  • Process オブジェクト
  • Console オブジェクト
  • ファイルシステムモジュール
  • 関連項目

コンストラクタ

JavaScript ソースコードで、ツールのコンストラクタを表す関数に相当する「module.exports」を設定する必要があります。この関数は引数なしで呼び出され、スクリプトのコンパイル後に、Tool オブジェクトのインスタンスを初期化します。

注:
  • 次の例の「Tool」関数名は任意の名前であり (Script 関数自体の操作には何も影響しない)、すべての In-Sight の例とサンプルスクリプトで使用されます。「Tool」関数名にはほかの名前を付けることができますが、Script 関数のソースコード全体を通じてその名前をずっと使い続ける必要があります。また、以下の例の中で「この」キーワードは、constructor 関数を使って作成、初期化された Tool オブジェクトを参照します。
  • In-Sight による JavaScript の実装に基づき、Script メソッド (constructor、run、save、load、draw) は、Script 関数を編集しているとき、または [スクリプトの編集] ダイアログを閉じているときに何度か呼び出されることがあります。例えば、[スクリプトの編集] ダイアログでスクリプトを作成した後、[OK] ボタンを押してスクリプトを保存すると、スクリプトが正しくコンパイルされていることを確認し、結果を返すために run メソッドが何度か実行されることがあるため、複数のメッセージが console.log に表示される場合があります。

次に例を示します。

            function Tool() {
  // ツールの状態を初期化
  this._partTotal = 0;
}
module.exports = Tool;

Run メソッド

Tool オブジェクトで「Run」メソッドを定義する必要があります。これは Script 関数が実行されると必ず呼び出され、呼び出されない場合、Script 関数は #ERR を返します。Script 関数の引数は、指定された順にスクリプトの Run メソッドに渡されます。

次の例は、Run メソッドの定義で推奨されるシンタックスを示しています。

Tool.prototype.run = function(a, b) {
  return "The average is" + (a+b)/2;
};
注:
  • JavaScript 関数はすべて可変個引数であるため、スクリプト内の Run メソッドで、Script 関数に渡される同じ番号の引数を宣言する必要はありません。Script 関数では、「引数」の配列を使用して引数の変数にアクセスすることもできます。
  • In-Sight による JavaScript の実装に基づき、Script メソッド (constructor、run、save、load、draw) は、Script 関数を編集しているとき、または [スクリプトの編集] ダイアログを閉じているときに何度か呼び出されることがあります。例えば、[スクリプトの編集] ダイアログでスクリプトを作成した後、[OK] ボタンを押してスクリプトを保存すると、スクリプトが正しくコンパイルされていることを確認し、結果を返すために run メソッドが何度か実行されることがあるため、複数のメッセージが console.log に表示される場合があります。

Run メソッドの戻り値

Run メソッドは、次の型の値のいずれかを返すことができます。

  • 数値
  • true (1) または false (0)
  • 文字列
  • データ構造体
  • 、 [image] 、 [image] 、 [image] 、または [image] データ構造体
  • オブジェクト
  • 配列
  • null、undefined、または no return ステートメント (空のオブジェクトと同じです)
注:
  • 数値または文字列が返された場合、Script 関数によって出力結果として数値または文字列が表示されます。
  • オブジェクトが返された場合は、Script 関数によって [image] データ構造体が表示されます。
  • 配列が返された場合は、Script 関数によって [image] データ構造体が表示されます。

Draw メソッド

Script 関数は「Draw」メソッドをサポートしており、Image 関数に似たグラフィックスをこの関数に生成させることができます。Draw メソッドには、グラフィックスコンテキストオブジェクトである引数が 1 つ指定されます。

注:
  • Draw メソッドはオプションであり、描画されているグラフィックスがない場合には省略することができます。
  • 例外が draw、save、または load メソッドでスローされると、その例外はコンソールに記録され、メソッドはその時点で終了します。ただしそのような場合、Script 関数は必ずしも #ERR を返すとは限りません。run メソッドの結果を返すか、run メソッドが例外をスローした場合またはコードをコンパイルできない場合は #ERR を返します。
  • In-Sight による JavaScript の実装に基づき、Script メソッド (constructor、run、save、load、draw) は、Script 関数を編集しているとき、または [スクリプトの編集] ダイアログを閉じているときに何度か呼び出されることがあります。例えば、[スクリプトの編集] ダイアログでスクリプトを作成した後、[OK] ボタンを押してスクリプトを保存すると、スクリプトが正しくコンパイルされていることを確認し、結果を返すために run メソッドが何度か実行されることがあるため、複数のメッセージが console.log に表示される場合があります。
  • draw メソッドには個別のタイムアウトがあり、デフォルトは 1000 ミリ秒です。この値は、EV SetSystemConfig ("Script.DrawTimeout", 1500) など、ネイティブモードコマンドで設定できます。このタイムアウトが役立つのは、例えば、アルゴリズムの問題を抱える実行時オーダ (無限ループが誤って含まれているものなど) が含まれる draw メソッドでスクリプトエディタが繰り返し使用されている場合です。例えば、長時間のタイムアウト 10000 ミリ秒が使用されたときに、In-Sight Explorer のタイムアウトが 6000 ミリ秒より短い場合、In-Sight Explorer の接続が継続可能になるため、In-Sight Explorer の接続タイムアウトと競合して、In-Sight ビジョンシステムの電源を入れ直すことが必要になる可能性があります。

次のメソッドを使用してグラフィックスを生成します。

  • plotArc(中心行, 中心列, 開始行, 開始列, 終了行, 終了列, 名前, 色 [,表示])
  • plotCircle(行, 列, 半径, 名前, 色 [,表示)
  • plotCross(行, 列, 角度, 高さ, 幅, 名前, 色 [,表示])
  • plotLine(行 0, 列 0, 行 1, 列 1, 名前, 色 [,表示] [,修飾開始] [,修飾終了])
  • plotPoint(行, 列, 名前, 色 [,表示])
  • plotRegion(行, 列, 高さ, 幅, 角度, カーブ, 名前, 色 [,表示])
注:
  • 角かっこで囲まれたパラメータはオプションです。

  • plotRegion メソッドは、表示パラメータ値を使用して操作できる追加のフラグを認識します。

    • [0x100]: 領域の周囲のみを、X/Y 軸ラベルなしでプロットします。
    • [0x200]: 塗りつぶされている (単色の) 領域を、X/Y 軸ラベルなしでプロットします。

    例えば、0x101 の表示パラメータ値を渡すと、領域が軸ラベルなしでプロットされ、常にプロットされます (つまり、セルが現在のセルであるかどうかには関係ありません)。同様に、0x201 の値を渡すと、単色の領域がプロットされます。

  • JavaScript のパラメータは Image 関数のパラメータと同じ意味を持っていますが、「color」パラメータは例外であり、24 ビットの RGB カラー値として 0xRRGGBB 形式で指定されます。例えば、16 進数の定数 0xFF8020 は、赤 =255、緑 =128、青 =32 と変換されます。カラー値は ここで見つけることができます。

形状の描画

上記のグラフィックスに加えて、「形状」を作成する Draw メソッドがあります。これは PlotPolygon および PlotCompositeRegion 関数に相当し、ここで「形状」はサポート対象の 形状オブジェクトのいずれかとすることができます。

  • plotShape(形状, 名前, 色 [,表示])

注: ポリゴンの長さが約 4950 点を超過する場合、そのポリゴンはグラフィカルに表示されません。

次の例は、Draw メソッドを定義する場合の正しいシンタックスを示しています。

Tool.prototype.draw = function(gr) {
  gr.plotPoint(this._foundRow, this._foundCol, "Found Feature", 0xFF00FF);
};

Save および Loadメソッド

Script 関数は「Save」および「Load」メソッドをサポートしており、この関数によってジョブの保存時にその内部状態をアーカイブして、ジョブのロード時にこの関数の状態を復元することができます。Save メソッドには引数は必要なく、保存する状態を含んでいるオブジェクトを返します。このオブジェクトはジョブファイルに格納され、ジョブのロード時に、関数の Load メソッド用の 1 つの引数としてこのオブジェクトが提供されます。

注:
  • Save および Load メソッドはオプションですが、このツールがジョブの状態を保存しない場合には省略することができます。

  • 例外が draw、save、または load メソッドでスローされると、その例外はコンソールに記録され、メソッドはその時点で終了します。ただしそのような場合、Script 関数は必ずしも #ERR を返すとは限りません。run メソッドの結果を返すか、run メソッドが例外をスローした場合またはコードをコンパイルできない場合は #ERR を返します。

  • In-Sight による JavaScript の実装に基づき、Script メソッド (constructor、run、save、load、draw) は、Script 関数を編集しているとき、または [スクリプトの編集] ダイアログを閉じているときに何度か呼び出されることがあります。例えば、[スクリプトの編集] ダイアログでスクリプトを作成した後、[OK] ボタンを押してスクリプトを保存すると、スクリプトが正しくコンパイルされていることを確認し、結果を返すために run メソッドが何度か実行されることがあるため、複数のメッセージが console.log に表示される場合があります。

次の例は、Save および Load メソッドを定義する場合の推奨されるシンタックスを示しています。

Tool.prototype.save = function() {
  return {total: this._total, avg: this._average};
};
Tool.prototype.load = function(saved) {
  this._total = saved.total;
  this._average = saved.avg;
};

タイムアウト

Script 関数によって呼び出される JavaScript の各メソッド (つまり、コンストラクタ、Run、Draw、Save、および Load メソッド) はタイムアウトしがちです。デフォルトでは、デフォルトのタイムアウトは 10 秒であり、デフォルトの粒度は 1 秒です (タイムアウトはミリ秒で指定され、最小値は 1、最大値は 60000 です。粒度もミリ秒で指定され、最小値は 1、最大値は 10000 です)。メソッドのいずれかで 10 秒を超える時間がかかった場合、そのメソッドは中断され、例外がスローされたかのような結果を示して、タイムアウトが発生したことを示すメッセージが表示されます。

注:
  • タイムアウトの目的は、スクリプトで意図せず無限ループが作成された場合に、In-Sight ビジョンシステムのロックを防止することです。それに対して、例えば FindPatMaxPatterns 関数の Timeout パラメータのように、関数に固有のタイムアウトを提供すると、ジョブの実行が許可される時間の長さが制限されます。この型の機能では、スクリプトで hrtime([time]) メソッドを使用して経過時間を定期的にチェックし、この関数を続行するかどうかを判断します。
  • Script 関数のタイムアウトは Native Mode コマンドを使用して変更でき、次の例ではタイウアウト 1 秒に設定しています。EV SetSystemConfig("Script.ToolTimeout",1000,1)。
  • Script 関数のタイムアウト粒度は Native Mode コマンドを使用して変更でき、次の例ではタイウアウト粒度を 5 秒に設定しています。EV SetSystemConfig("Script.TimeoutGranularity",5000,1).
  • draw メソッドには個別のタイムアウトがあり、デフォルトは 1000 ミリ秒です。この値は、EV SetSystemConfig ("Script.DrawTimeout", 1500) など、ネイティブモードコマンドで設定できます。このタイムアウトが役立つのは、例えば、アルゴリズムの問題を抱える実行時オーダ (無限ループが誤って含まれているものなど) が含まれる draw メソッドでスクリプトエディタが繰り返し使用されている場合です。例えば、長時間のタイムアウト 10000 ミリ秒が使用されたときに、In-Sight Explorer のタイムアウトが 6000 ミリ秒より短い場合、In-Sight Explorer の接続が継続可能になるため、In-Sight Explorer の接続タイムアウトと競合して、In-Sight ビジョンシステムの電源を入れ直すことが必要になる可能性があります。

ファイルパス

このトピックで説明している、ファイル名またはディレクトリパスを必要とする JavaScript 関数では、簡易名 (ローカルファイルシステム上のファイルを参照する場合) または URL (FTP サーバ上のファイルおよびディレクトリを参照する場合に FTP スキームを使用) を使用することができます。

URL を使用する場合、FTP URL 形式に従う必要があり、RFC 1738 で指定されています (ftp://<ユーザ>:<パスワード>@<ホスト>:<ポート>/<URL パス>)。

注: 「<ユーザ>:<パスワード>@」、「<パスワード>」、「<ポート>」、および「/<URL パス>」の一部またはすべての部分を除外することができます。

Script モジュール

すべての In-Sight JavaScript コードは、トップスコープのプライバシーが提供されるモジュールとしてロードされ、名前のないオブジェクトをその他のモジュールからインポートし、独自の API をエクスポートする機能を備えています。この形式は Script 関数に含まれている JavaScript コードのロードに使用し、外部スクリプトモジュールをファイルからロードする場合にも使用します。

注: このモジュールシステムは、CommonJS および NodeJS のモジュールをベースにしていますが、Cognex ではこれらのシステム用に設計されたモジュールとの互換性は保証していません。

次の例は、ソースコードのインポート方法を示しています。

            /*
このスクリプトは、標準形式の式の係数 a、b、c で指定された二次方程式のルートを返します。
*/
function Script() {

}
/*
これは必須ステートメントであり、スプレッドシートで Script 関数を呼び出せるようにして、このセルを初期化します。
*/
module.exports = Script;
  var quad = require('quadratic'); 	// モジュールをインポート
/*
これは二次式モジュールを使用可能にする場所です。
*/
Script.prototype.run = function() {
    var a = 1, b = 4, c = 2;
    return quad.roots(a,b,c); //モジュールを使用可能に
}

注: require() 関数が呼び出されるときに、指定した .js ファイルが読み取り不能である場合、require () 関数は「undefined」の値を返し、例外はスローしません。

グローバルスコープ

グローバルスコープモジュールはそのモジュールで一意です。つまり、モジュールで定義されている自由変数は、そのモジュールでのみ可視です。

「require」関数

モジュール内で、「require」は関数として動作する自由変数です。「require」関数はモジュール識別子を受け入れ、インポートされたモジュールでエクスポートされた API を返します。要求したモジュールが返されなかった場合は、「require」関数が「undefined」の値を返します。

「module」変数

モジュール内には自由変数があり、これはオブジェクトです。「module」オブジェクトは、モジュールのエクスポートされた API を表す「exports」プロパティを含んでおり、最初は空のオブジェクトとして設定されています。

モジュールでは、その API をエクスポートするため、デフォルトで作成されている「module.exports」オブジェクトにプロパティを単純に追加することができます。または、別のオブジェクトを API としてエクスポートするために、デフォルトで作成されている空のエクスポートオブジェクトを使用するのではなく、「module.exports」プロパティに新しいオブジェクトを割り当てることもできます。

「exports」変数

モジュールには「exports」と呼ばれる自由変数があり、「module.exports」の値を初期化します。

注: この変数は利便性のために提供されており、スクリプトで「module.exports」を指定しなくても、単純にプロパティを「exports」オブジェクトに追加することができます。

モジュール識別子

モジュール識別子は In-Sight ビジョンシステムのローカルファイルシステム上のファイルの名前、または FTP サーバ上のファイルの名前のいずれかであり、[ファイルパス] セクションで指定します。

注: この名前がファイル拡張子なしで指定されている場合、ファイルをロードしようとすると、自動的に「.js」拡張子がファイルに付加されます。

データ構造体の入力/出力

、 [image] 、 [image] 、 [image] 、または [image] データ構造体は、Script からの入力および出力の両方としてサポートされています。これらのデータ構造体は読み取り専用であり、JavaScript ソースコードで作成または変更することはできません。データ構造体のそれぞれは、特定のデータ構造体によってサポートされる対応するデータアクセス関数に対応するメソッドを表示しています。

例えば、 [image] データ構造体は次のメソッドをサポートしています。

  • blobs.getNFound() - 検出されたブロブの数を返します。
  • blobs.getAngle(index) - インデックス付きブロブの重心の角度を返します。
  • blobs.getArea(index) - インデックス付きブロブの面積 (ピクセル単位) を返します。

バイナリ構造体の入力/出力

BStringf または ReadDevice 関数によって返された [image] データ構造体、および GetBufferData 関数によって返された [image] データ構造体は、Script 関数への入力としてサポートされています。これらの構造体が JavaScript に渡されると、バイナリデータが JavaScript DataView オブジェクトにコピーされ、これを使用して個別のバイトの読み取り/書き込みを行ったり、Int32Array または Uint8Array などのさまざまな型の配列ビューを作成したりすることができます。Script 関数にはデータのコピーが与えられるので、この関数は DataView オブジェクトの内容を、元のソースデータに反映させずに保存または変更することができます。

JavaScript DataView、ArrayBuffer、またはその他の型の配列オブジェクトが JavaScript 関数によって返されると、そのデータは [image] データ構造体にコピーされます。これは、 [image] データ構造体を入力引数として受け入れるその他の In-Sight 関数 (WriteDevice 関数など) によって使用することができます。

注: Int32Array および Uint8Array は標準の JavaScript クラスです。詳細についてはリンクを参考にしてください (インターネットアクセスが必要です)。

次の例では [image] データ構造体を入力引数数として取得し、そのデータ構造体を 32 ビット浮動小数点の配列として表示して、新しい [image] データ構造体を返します。これには 64 ビット浮動小数点の値が逆の順序で含まれています。

 Tool.exports.run = function(data) {
  var input = new Float32Array(data.buffer);
  var output = new Float64Array(input.length);
  for (var i=0; i<output.length; ++i)
    output[output.length - i] = input[i];
  return output;
}

次の例は、PLC に送信される仮想的な 14 バイトのバイナリメッセージを、フォーマットして返す関数を示しています。この関数は自動的にゼロに初期化されるので、パディングフィールドに書き込む必要はありません。返された値は、スプレッドシートで 14 バイトの [image] データ構造体となります。

            // メッセージ形式:
// Byte padding[2]; /* ゼロで埋める。*/
// uint32 count; 	/* 32 ビット符号なし整数、ビッグエンディアンオーダー。*/
// double delay;	/* 64 バイトダブル、リトルエンディアンオーダー。*/
//
Tool.exports.run = function(count, delay) {
  var data = new DataView(new ArrayBuffer(14));
  data.setUint32(2, count);			 // デフォルトではビッグエンディアン
  data.setFloat64(6, delay, true);		// リトルエンディアン
  return data;
}

FormatOutputBuffer 関数

FormatOutputBuffer 関数は、「String」データ型を使用して [image] データ構造体の入力を受け入れます。これによって、Script 関数から返される [image] データ構造体を [image] データ構造体にコピーすることができます。バイナリバイトは直接コピーされ、Null 終了文字列として解釈されることはありません。

形状オブジェクト

形状オブジェクトは、Script 関数に引数として入力し (例えば、EditRegion 関数への参照を使用)、戻り値として出力することができます。形状オブジェクトは、「cognex」モジュールのメンバとして提供されているコンスラクタ関数を使用して作成されます。

形状オブジェクトの作成方法を次に示します。

            function Example()
{
}
var cognex = require('cognex');
module.exports = Example;

Example.prototype.run = function(x, y)
{
  var annulus = new cognex.Annulus(150, 250, 25, 45);
  var circle = new cognex.Circle(50, 250, 30);
  var fixture = new cognex.Fixture(230, 300, 45);
  var line = new cognex.Line(270, 530, 290, 50);
  var point = new cognex.Point(330, 500);
  var polygon = new cognex.Polygon();
  polygon.add(340,230);
  polygon.add(390,210);
  polygon.add(370,230);
  polygon.add(390,250);
  var region = new cognex.Region(440, 300, 40, 50, 30, 45);
  this.shapes = [annulus,circle,fixture,line,point,polygon,region];
  return this.shapes;
}

Example.prototype.draw = function(gr)
{
  this.shapes.forEach(function(shape) {gr.plotShape(shape, JSON.stringify(shape), 0xc0ffee*Math.random());});
}

Annulus 関数

Annulus コンストラクタ関数は次の引数を必要とし、オブジェクトは読み取り/書き込みプロパティを同じ名前で提供します。

  • row または x: X オフセット。
  • col または y: Y オフセット。
  • innerRadius: 内側の半径を定義します。
  • outerRadius: 外側の半径を定義します。

Circle 関数

Circle コンストラクタ関数は次の引数を必要とし、オブジェクトは読み取り/書き込みプロパティを同じ名前で提供します。

  • row または x: X オフセット。
  • col または y: Y オフセット。
  • radius: 半径を定義します。

Fixture 関数

Fixture コンストラクタ関数は次の引数を必要とし、オブジェクトは読み取り/書き込みプロパティを同じ名前で提供します。

  • row: 行オフセット
  • column: 列オフセット
  • theta: 角度

Line 関数

Line コンストラクタ関数は次の引数を必要とし、オブジェクトは読み取り/書き込みプロパティを同じ名前で提供します。

  • row0 または x0: 始点の X オフセット
  • col0 または y0: 始点の Y オフセット
  • row1 または x1: 終点の X オフセット
  • col1 または y1: 終点の Y オフセット

Point 関数

Point コンストラクタ関数は次の引数を必要とし、オブジェクトは読み取り/書き込みプロパティを同じ名前で提供します。

  • row または x: X オフセット。
  • col または y: Y オフセット。

Polygon 関数

Polygon コンストラクタ関数は引数を必要とせず、空のポリゴンを返します。ポリゴンオブジェクトは次のプロパティとメソッドを提供します。インデックス (n) が指定されている場合は、最初の点にゼロのインデックスがあります。

  • length: ポリゴン内の点の数を返します。
  • add(x,y): ポリゴンに新しい点を追加します。
  • clear(): ポリゴンからすべての点を削除します。
  • remove(n): ポリゴンから指定した点 (n) を削除します。
  • set(n,x,y): ポリゴンの点 (n) の座標を設定します。
  • row(n) or x(n): ポリゴンの点 (n) の行/X 座標を返します。
  • col(n) or y(n): ポリゴンの点 (n) の列/Y 座標を返します。

Region 関数

Region コンストラクタ関数は次の引数を必要とし、オブジェクトは読み取り/書き込みプロパティを同じ名前で提供します。

  • row または x: 原点の X オフセット。
  • col または y: 原点の Y オフセット。
  • high: 領域の X 軸寸法。
  • wide: 領域の Y 軸寸法。
  • angle: 角度 (度単位)。
  • curve: 領域の X 軸と反対側の境界線との間の角度変位。

Process オブジェクト

モジュール内で、自由変数「process」は次のメソッドでオブジェクトを返します。

uptime()

このメソッドは、システムの起動に続いて、秒数を浮動小数点値としてサブマイクロ秒の精度で返します。

注: この精度は、システムクロックの結晶および追加の要因に応じて決まるので、特定の精度が保証されているわけではありません。

メソッドの使用方法を次に示します。

            var start = process.uptime();
someTimeConsumingFunction();
var elapsedSeconds = process.uptime() - start;

hrtime([時間])

このメソッドは、現在の時間を高分解能のタプル配列で返します (秒、ナノ秒)。ここで、最初の要素は現在の秒の開始以来の秒を表す整数値、2 番目の要素はナノ秒を表す整数値です。このメソッドの主な用途は、間隔の合間の時間を計測することです。

注: この精度は、システムクロックの結晶および追加の要因に応じて決まるので、特定の精度が保証されているわけではありません。

このメソッドが引数なしで呼び出された場合、返される時間は In-Sight ビジョンシステムの起動時間に相対します。このメソッドが前回の hrtime() への呼び出しの結果によって呼び出された場合は、返される時間は前回の時間に対する時間差です。

メソッドの使用方法を次に示します。

            var start = process.hrtime();
someTimeConsumingFunction();
var diff = process.hrtime(start);
var elapsedSeconds = diff[0] + diff[1] / 1e+9

sleep(ms)

このメソッドで、Script 関数が指定されたミリ秒数の間スリープ状態になるように指定します。

注: スリープ期間が終了するまで Timeout が経過した場合、スリープ期間は中断されます。

memoryUsage()

このメソッドは次の 2 つのプロパティを含むオブジェクトを返します。

  • heapTotal: ヒープメモリの合計サイズを示します。
  • heapUsed: 現在使用されているヒープメモリの量を示します。

注: Script 関数が In-Sight エミュレータ上で実行を開始しているときには、これらのメソッドは使用できないヒープメモリの情報を返します。

Console オブジェクト

モジュール内で、自由変数「console」は次のメソッドでオブジェクトを提供します。[コンソール出力] ペインは、[スクリプトの編集] ダイアログのドッキング可能なコンポーネントであり、スプレッドシートビュー内のドッキング可能なウィンドウとしても使用できます ([表示] メニューから [スクリプトコンソール出力] オプションを選択します)。

console.log(メッセージ)

このメソッドは、メッセージを標準の文字で、[スクリプトの編集] ダイアログの [コンソール出力] ペインに出力します。

console.warn(メッセージ)

このメソッドは、メッセージを黄色背景に黒文字で、[スクリプトの編集] ダイアログの [コンソール出力] ペインに出力します。

console.error(メッセージ)

このメソッドは、メッセージを赤背景に黒文字で、[スクリプトの編集] ダイアログの [コンソール出力] ペインに出力します。

ファイルシステムモジュール

「fs」モジュールによって、Sight ビジョンシステムまたはエミュレータのローカルファイルシステム上のファイル、およびリモート FTP サーバ上のファイルにアクセスすることができます。

注: ファイルシステムモジュール内のすべてのメソッドは末尾が「Sync」となっており、それらが「synchronous (同期)」していることを示します。つまり、Script 関数内でこのスクリプトを実行しても、ファイル操作が完了するまでブロックされます。

このモジュールは次の必須関数を使用して取得されます。

 var fs = require("fs");

ファイルシステムオブジェクトは、次のメソッドを提供します。

注:
  • Script 関数で書かれたソースコードと、In-Sight ビジョンシステムおよびエミュレータでサポートされるファイルタイプとの間では、同じファイルタイプの表示がサポートされています (例えば、.txt、.htm、.xml、.js、.css、.rtf、および.json)。ただし、サードパーティーの FTP サーバにアクセスした場合、認証されているユーザはその他のファイルタイプの読み取り/書き込みを行うことができます。
  • 可能な FTP サーバ構成は多数あるため、ファイルシステムモジュールメソッドを使用する前に (特に appendFileSync。これは existsSync、readFileSync、および writeFileSync に依存するため)、対象とする FTP サーバおよびファイルパスをテストして、実装前にこれらの互換性と適合性を検証することを推奨します。例えば、「blind drop」FTP サーバ構成では、existsFileSync メソッドが既存のファイルに対して false を返すか、または readFileSync メソッドが失敗して、データが消失することがあります。
  • 次のファイルシステムへのアクセスは禁止されています。
    • proc.set
    • image.bmp
    • image2.bmp (グレースケールビジョンシステムにのみ適用可)
    • image4.bmp (グレースケールビジョンシステムにのみ適用可)
    • image.jpg
    • screen.bmp (エミュレータにのみ適用可)
    • screen.jpg (エミュレータにのみ適用可)
    • hosts.net
    • graphics.svg

appendFileSync(ファイル名, データ)

このメソッドでは、指定されたデータがある場合はファイルに付加し、ファイルがすでに存在しない場合は新しいファイルにデータを書き込みます。データパラメータが Uint8Array または DataView などの JavaScript 型の配列の場合は、バイナリデータとしてファイルに書き込まれ、それ以外の場合は、文字列に変換されて UTF-8 文字列としてファイルに書き込まれます。

existsSync(ファイル名)

指定したファイルが存在する場合、このメソッドは true を返します。

readFileSync(ファイル名 [,"binary"])

このメソッドは、ファイル全体の内容を読み取って返します。ファイルの内容は UTF-8 テキストとして読み取られ、文字列として返されます。オプションの「binary」引数を使用する場合は、ファイルの内容が DataView のバイナリデータとして返されます。次に例を示します。

var binaryData = fs.readFileSync('ftp://server/xyz.dat', "binary");

注: システムファイルを読み取ろうとすると、このメソッドは例外をスローします。

readdirSync(パス)

このメソッドはディレクトリの内容を読み取り、ファイル名の配列を返します。In-Sight ビジョンシステムまたはエミュレータのディレクトリの内容のみを読み取るには、空の文字列または「.」を指定し、FTP サーバのディレクトリの内容を読み取って、FTP URL のみを指定します。

注: このメソッドは In-Sight Explorer および In-Sight ファイルペインと一致しており、どのファイルを表示/非表示にするかという点ではビジョンシステムの FTP サーバと一致しています。認証されているユーザは、ファイル拡張子が原因で非表示になっている FTP ファイルの読み取りと書き込みを行うことができます。

statSync(パス)

このメソッドはファイルまたはディレクトリのステータスを受け取り、次のプロパティを含むオブジェクトを返します。

  • size: バイト単位でのファイルのサイズ。

注: ファイルが存在しない場合、この関数は、例外をスローするのではなく、size =0 のオブジェクトを返します。

unlinkSync(ファイル名)

このメソッドを使用してファイルを削除します。ただし、ファイルが存在しない場合は何も返しません。

writeFileSync(ファイル名, データ)

このメソッドはファイルの内容全体を書き込み、既存のファイルを上書きします (ファイルが存在しない場合は、ファイルが作成されます)。データパラメータが Uint8Array または DataView などの JavaScript 型の配列の場合は、バイナリデータとしてファイルに書き込まれ、それ以外の場合は、(文字列に変換されていない場合は) 文字列に変換されて UTF-8 文字列としてファイルに書き込まれます。

注: システムファイルに書き込もうとすると、このメソッドは例外をスローします。

関連項目

  • スクリプト関数
  • Script 関数
  • [スクリプトの編集] ダイアログ
  • Get 関数
Version: 5.6.0


フォーカス関数

In-Sight 関数リファレンス

フォーカス関数は、サポートされる In-Sight 7000 シリーズビジョンシステムのレンズを自動または手動で調整する手法を提供します。

フォーカス関数には次の関数があります。

  • EditFocusPosition 関数: レンズの焦点位置を制御します。
  • GetCurrentFocusPosition 関数: レンズの現在の焦点位置を返します。
Version: 5.6.0


EditFocusPosition 関数

EditFocusPosition 関数 |
フォーカス関数 | In-Sight 関数リファレンス

このEditFocusPosition 関数は、自動的にレンズの焦点を合わせたり、特定の焦点位置にレンズを移動したりすることで、サポートされている In-Sight 7000 シリーズビジョンシステムのレンズの焦点位置を制御します。

  • EditFocusPosition 関数の入力パラメータ
  • EditFocusPosition 関数の出力
  • 関数のEditFocusPosition 関数使用方法
  • 関連項目

注:
  • In-Sight 70xx ～ 74xx シリーズのビジョンシステムの場合、EditFocusPosition 関数M12 レンズ構成のビジョンシステムだけでこの関数を使用できます。In-Sight 76xx ～ 79xx シリーズのビジョンシステムの場合、EditFocusPosition 関数オートフォーカスアクセサリが取り付けられたビジョンシステムだけでこの関数を使用できます。
  • このEditFocusPosition 関数は、ビジョンシステムがオフラインの場合のみ動作します。
  • [オートフォーカス] および [フォーカスの保存] ボタンは、スプレッドシートビューおよび EasyBuilder ビューの両方に表示されるライブビデオモードからアクセスすることができます。

EditFocusPosition 関数の入力パラメータ

EditFocusPosition 関数(

最小焦点位置,

最大焦点位置,

画像,

オートフォーカス領域.X,

オートフォーカス領域.Y,

オートフォーカス領域.高さ,

オートフォーカス領域.幅,

オートフォーカス領域.角度,

オートフォーカス領域.カーブ,

オートフォーカスイベント,

オートフォーカスオフセット,

焦点位置値の設定,

焦点位置イベントの設定,

焦点位置とジョブの保存

ジョブロード時にオートフォーカスを実行

)
最小焦点位置

最小焦点位置値を指定します (0 ～ 100、デフォルト = 0)。

注:このパラメータは In-Sight 76xx ～ 79xx シリーズのビジョンシステムではサポートされません。
最大焦点位置

最大焦点位置値を指定します (0 ～ 100、デフォルト = 100)。

注:このパラメータは In-Sight 76xx ～ 79xx シリーズのビジョンシステムではサポートされません。
画像

AcquireImage 関数によって返される [image] データ構造体を含むセル A0 への参照を指定します。

注: このパラメータは他の [image] データ構造体を参照できますが、関数は AcquireImage [image] データ構造体のみを使用するように設計されています。
オートフォーカス領域

レンズの焦点を計算するために使用される領域のサイズと位置を指定します。

X | フィクスチャ座標での焦点領域の X オフセット。
Y | フィクスチャ座標での焦点領域の Y オフセット。
高さ | 焦点領域の高さ。
幅 | 焦点領域の幅。
角度 | フィクスチャ座標での角度。
カーブ | 領域の X 軸と反対側の境界線との間の角度変位。
オートフォーカスイベント

オートフォーカスをトリガするスプレッドシートイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • Event 関数を含むセル
  • Button 関数を含むセル
オートフォーカスオフセット

オートフォーカスの完了後に、レンズの位置に適用されるオフセットを指定します (0 -100 ～ 100、デフォルト = 0)。

注:このパラメータは In-Sight 76xx ～ 79xx シリーズのビジョンシステムではサポートされません。

焦点位置値の設定

焦点位置として使用する値またはセル参照を指定します。

  • In-Sight 70xx ～ 74xx シリーズ: 0 ～ 100、デフォルト = 0
  • In-Sight 76xx ～ 79xx シリーズ: 0 ～ 250、デフォルト = 0

焦点位置イベントの設定

指定された焦点位置の値へレンズを移動するスプレッドシートイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • Event 関数を含むセル
  • Button 関数を含むセル
焦点位置とジョブの保存

フォーカス位置データをジョブと一緒に保存し、ジョブがリロードされたときにレンズに適用するかどうかを指定します。チェックボックスをオンにすると、レンズは最後に保存された焦点位置に移動します。

注:[フォーカス位置をジョブに保存] チェックボックスと [ジョブロード時にオートフォーカスを実行] チェックボックスは相互に排他的であるため、両方のチェックボックスを同時にオンにすることはできません。
0 = OFF | レンズは移動せず、セルに現在の焦点位置が表示されます。
1 = ON (デフォルト) | レンズは最後に保存された焦点位置に移動します。
ジョブロード時にオートフォーカスを実行

ジョブがロードされたときに自動的にレンズの焦点を合わせるかどうかを指定します。

注:[フォーカス位置をジョブに保存] チェックボックスと [ジョブロード時にオートフォーカスを実行] チェックボックスは相互に排他的であるため、両方のチェックボックスを同時にオンにすることはできません。
0 = OFF (デフォルト) | ジョブがロードされたときに自動的にレンズの焦点を合わせません。
1 = ON | ジョブがロードされたときに自動的にレンズの焦点を合わせます。

EditFocusPosition 関数の出力

戻り値 | 現在の焦点位置値の設定の値。入力パラメータが無効な場合は #ERR が返されます。
結果 | 新しい画像を取り込み、表示されている画像を新たに取り込んだ画像で更新します。

関数のEditFocusPosition 関数使用方法

  • レンズの自動フォーカス
  • オートフォーカス位置の調整 (In-Sight 70xx ～ 74xx シリーズのみ)
  • レンズを特定の位置に設定
  • ライブビデオでのレンズの自動フォーカス

レンズの自動フォーカス

  1. 関数をEditFocusPosition 関数 スプレッドシートのセルに挿入します。

  2. プロパティシートで、EditFocusPosition 関数[OK] をクリックします。自動的に 2 つのセルがスプレッドシートに挿入されます。焦点位置値を調整する EditInt 関数、およびオートフォーカスをトリガする Button 関数です。

  3. [オートフォーカス] ボタンをクリックします。
  4. 画像が更新されるまで待機します。フォーカス位置の値が [オートフォーカス] ボタンの左側のセルに表示されます。
注: オートフォーカスはスプレッドシートビューと EasyBuilder ビューの両方のライブビデオからアクセスすることができます。

オートフォーカス位置の調整 (In-Sight 70xx ～ 74xx シリーズのみ)

  1. オートフォーカス完了後、EditFocusPosition 関数プロパティシートを開きます。
  2. [オートフォーカスオフセット] の値を調整し、[OK] をクリックします。
  3. フォーカスが合っているかどうかを確認します (特徴が最適化されているか、影が最小限かどうか、など)。フォーカスが合っていない場合、最適な位置になるまで値を再調整します。
注: [オートフォーカスオフセット] の値および元のオートフォーカス位置がジョブに保存され、ジョブをリロードした際にレンズに再適用されます。

レンズを特定の位置に設定

  1. 関数をEditFocusPosition 関数 スプレッドシートに挿入します。
  2. [フォーカス位置イベントの設定] パラメータに、Event 関数または Button 関数を含むセル参照を指定します。
  3. [フォーカス位置値の設定] パラメータに、フォーカス位置として使用する値またはセル参照を指定し、[OK] をクリックします。
  4. イベントが発生すると、レンズは指定の位置に移動し、フォーカス位置の値が [オートフォーカス] ボタンに隣接したセルに表示されます

ライブビデオでのレンズの自動フォーカス

  1. ビジョンシステムをオフラインにします。

  2. [ジョブの表示] ツールバーの [ライブビデオ] [image] ボタンをクリックして、ライブビデオモードに切り替えます。

    ヒント: ライブビデオモードで In-Sight 76xx ～ 79xx シリーズのビジョンシステムに接続した場合、[照明の設定] ダイアログを起動して、照明の設定を調整することもできます。

  3. [オートフォーカス] ボタンを押すか、検査対象の特徴の詳細がクリアで高コントラストになり、フォーカスメトリクス得点が許容可能になるまで [フォーカス位置] スライダを手動で調整します。[オートフォーカス] ボタンを押すと、オートフォーカスが完了するまで [フォーカス位置] スライダおよび [フォーカスの保存] ボタンと [フォーカスのリセット] ボタンは無効になります。完了すると、フォーカス位置の値が更新されて新しい画像が表示されます。

    • オプションで、[保存] ボタンをクリックして現在のフォーカス位置をデフォルトのフォーカス位置として保存すると、次回ビジョンシステムに電源を再投入して新しいジョブをロードしたときに、自動的にレンズがこの位置に移動します。
    • オプションで、[リセット] ボタンをクリックしてデフォルトのフォーカス位置をリセットします。
  4. [ライブビデオ] [image] ボタンを再度クリックして、ライブビデオモードを終了します。

関連項目

  • フォーカス関数
  • GetCurrentFocusPosition 関数
Version: 5.6.0


GetCurrentFocusPosition 関数

フォーカス関数

In-Sight 関数リファレンス

レンズの現在の焦点位置を返します。

注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムの場合、GetCurrentFocusPosition 関数M12 レンズ構成のビジョンシステムだけでこの関数を使用できます。In-Sight 76xx ～ 79xx シリーズのビジョンシステムの場合、GetCurrentFocusPosition 関数オートフォーカスアクセサリが取り付けられたビジョンシステムだけでこの関数を使用できます。

GetCurrentFocusPosition 関数の入力パラメータ

入力

説明

Event

データを読み取るスプレッドシートイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体(デフォルト)
  • 関数を含んでいるセル
  • Button 関数を含んでいるセル

GetCurrentFocusPosition 関数の出力

戻り値

イベントがトリガされた時点の現在の焦点位置値。現在位置を判別できない場合は、-1 を返します。

関連項目

フォーカス関数

EditFocusPosition 関数

Version: 5.6.0


In-Sight の通信環境

In-Sight 通信リファレンス

In-Sight ビジョンシステムは、Ethernet ネットワークまたはシリアルポート接続を介して、さまざまなプロトコルを使用して、外部デバイスと通信することができます。次の表に、In-Sight ビジョンシステムがサポートしているさまざまなプロトコルと、関連項目へのリンクを示します。

注: プロトコルと接続に従って通信する機能は、In-Sight ビジョンシステムのタイプと In-Sight ファームウェアのバージョンによって異なります。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

物理接続 プロトコル 関連項目

Ethernet

TCP/IP

  • TCPDevice 関数、QueryDevice 関数
  • ReadDevice 関数、WriteDevice 関数
  • AcquireImage 関数、WriteResult 関数、ReadResult 関数

Ethernet

TCP/IP Modbus

  • TCP/IP Modbus による通信について
  • TCPDevice 関数、ReadDevice 関数、WriteDevice 関数、QueryDevice 関数
  • Binary Text 関数
  • AnybusX-gateway
  • PROFIBUS ネットワーク上の Siemens PLC との通信
  • CC-Link ネットワーク上の三菱電機オートメーションコントローラとの Anybus ゲートウェイ経由での通信

Ethernet

ファイル転送プロトコル (FTP)

  • [FTP の設定] ダイアログ
  • [ログオン/ログオフ] ダイアログ
  • [保存] および [開く] ダイアログ
  • WriteFTP 関数、WriteImageFTP 関数、WriteImageSFTP 関数

Ethernet

SMTP

  • WriteSMTP 関数

Ethernet

EtherNet/IP (EIP)

  • ReadEIP 関数、WriteEIP 関数
  • ReadEIPBuffer 関数、WriteEIPBuffer 関数
  • ReadLatchedUserDataBuffer 関数、ReadUserDataBuffer 関数、WriteResultsBuffer 関数
  • EtherNet/IP による通信
  • EtherNet/IP オブジェクトモデル - In-Sight 5.x.x ファームウェア
  • EtherNet/IP オブジェクトモデル - In-Sight 4.x.x ファームウェア
  • Rockwell ControlLogix PLC　との通信
  • Rockwell SLC 5/05 PLC との通信

Ethernet

MELSEC

  • 三菱電機 MELSEC 通信プロトコル
  • SLMP スキャナのファクトリインタフェース
  • CC-Link IE フィールド Basicファクトリインタフェース
  • FormatInputBuffer 関数、FormatOutputBuffer 関数
  • ReadUserDataBuffer 関数、ReadLatchedUserDataBuffer 関数、WriteResultsBuffer 関数
  • CC-Link ネットワーク上の三菱電機オートメーションコントローラとの Anybus ゲートウェイ経由での通信
  • CC-Link ネットワーク上の三菱電機オートメーションコントローラとの In-Sight CIO-MICRO-CC 経由での通信
  • ReadCCLinkBitBuffer 関数、ReadCCLinkWordBuffer 関数、WriteCCLinkBitBuffer 関数、WriteCCLinkWordBuffer 関数

Ethernet

PROFINET

  • ReadProfinetBuffer 関数、WriteProfinetBuffer 関数
  • ReadUserDataBuffer 関数、ReadLatchedUserDataBuffer 関数、WriteResultsBuffer 関数
  • PROFINET による通信
  • PROFINET I/O モジュールリファレンス
  • PROFINET I/O モジュールリファレンス - In-Sight 5.x.x ファームウェア
  • PROFINET I/O モジュールリファレンス - In-Sight 4.x.xファームウェア
  • In-Sight ビジョンシステムでの PROFINET による通信
  • PROFINET 経由での In-Sight ビジョンシステム (5.x.x FW) によるデータ転送
  • PROFINET 経由での In-Sight ビジョンシステム (4.x.x FW) によるデータ転送
  • PROFINET - Siemens PLC でのレコードの使用

Ethernet

POWERLINK

  • POWERLINK 通信
  • POWERLINK ファクトリインタフェース

  • FormatInputBuffer 関数、FormatOutputBuffer 関数

  • ReadUserDataBuffer 関数、ReadLatchedUserDataBuffer 関数、WriteResultsBuffer 関数

Ethernet

ネイティブモード

  • ネイティブモードでの通信について
  • ネイティブモードコマンド

Ethernet

DataChannel による通信

  • DataChannel による通信について
  • SetWatch 関数

シリアル

Text モード

  • Text モードの詳細設定
  • [シリアルポートの設定] ダイアログ
  • ReadSerial 関数、WriteSerial 関数

シリアル

ネイティブモード

  • Native モードの詳細設定
  • [シリアルポートの設定] ダイアログ
  • ネイティブモードでの通信について
  • ネイティブモードコマンド
  • ReadSerial 関数、WriteSerial 関数

シリアル

DeviceNet

  • DeviceNet モードの詳細設定
  • [シリアルポートの設定] ダイアログ
  • ReadDeviceNet 関数、WriteDeviceNet 関数

シリアル

Motoman モード

  • Motoman 通信について
  • Motoman コマンド
  • [シリアルポートの設定] ダイアログ

シリアル

Kuka モード

  • Kuka 通信について


Anybus X-gateway

In-Sight 通信リファレンス

Anybus® X-gateway™ により、2 つの異なる産業用ネットワークプロトコルの間の通信を円滑に行い、それらのプロトコルでデータの送信や交換を行うことができます。Anybus X-gateway では、多目的通信ソリューションとして Ethernet インタフェースを利用し、産業用ネットワークプロトコルをサポートするとともに、Web および 電子メールの機能を提供します。

このモデルにおいて、TCP/IP Modbus 通信を使用する In-Sight センサは、異なるネットワーク (PROFIBUS や CCLink など) 上で PLC と通信し、データを交換することができます。Anybus X-gateway の Ethernet インタフェースは、入力バッファと出力バッファを使用して In-Sight センサと PLC の間でデータを交換します。これらのバッファには、次の図に示すように、TCP/IP Modbus ネットワークと PROFIBUS ネットワークを接続して、産業用ネットワークプロトコルを介してアクセスします。

  • 入力バッファ: 入力バッファには、PROFIBUS ネットワーク上で PLC から送信されたデータが保管されます。このデータは、TCP/IP Modbus ネットワーク上で In-Sight センサに送信されます。
  • 出力バッファ: 出力バッファには、TCP/IP Modbus ネットワーク上で In-Sight センサから送信されるデータが保管されます。このデータは、PROFIBUS ネットワーク上の PLC に送信されます。

関連項目

PROFIBUS ネットワーク上の Siemens PLC との通信

CC-Link ネットワーク上の三菱電機 PLC との通信


Anybus X-gateway 経由での CC-Link ネットワーク上の三菱電機 Automation Controller との通信

TCP/IP Modbus による通信

In-Sight 通信リファレンス

  • 概要
  • Anybus X-gateway のインストールと設定
  • CC-Link ネットワーク上の三菱電機オートメーションコントローラへの Anybus X-gateway の接続
  • TCP/IP Modbus 経由での In-Sight ビジョンシステムへの Anybus X-gateway の接続

注:CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

概要

In-Sight ビジョンシステムは、Anybus X-gateway と TCP/IP Modbus プロトコルを使用して、CC-Link ネットワーク上のデバイスと通信することができます。

このトピックでは、ゲートウェイのインストールおよび設定方法、オートメーションコントローラプログラミングソフトウェア (三菱電機 GX Developer) の設定方法、In-Sight ExplorerCC-Link ネットワーク上の三菱電機オートメーションコントローラと通信するための In-Sight Explorer のセットアップ方法について説明します。

下記の例は、次のコンポーネントを使用していることを前提に記述されています。

  • Anybus X-gateway および HMS Anybus IPconfig ソフトウェア
  • ファームウェアバージョン 3.41.00 以降を実行している In-Sight ビジョンシステム
  • CC-Link をサポートする三菱電機オートメーションコントローラ
  • 三菱電機 GX Developer プログラミングソフトウェア

Anybus X-gateway のインストールと設定

このセクションの手順では、Anybus X-gateway の Ethernet 部分のインストールおよび設定方法について説明します。手順では、次のコンポーネントを使用していることを前提にしています。

注: 詳細については、HMS Anybus-X のマニュアル (『Anybus-X Generic Gateway User Manual』、『Anybus-X Ethernet Network Interface Addendum』、『X-gateway Interface Addendum - CC-Link Slave Interface』) を参照してください。これらのマニュアルは、HMS の Web サイト (www.hms-networks.com) のサポートページで提供されています。

Anybus X-gateway のインストールおよび設定を行うには、以下の手順に従います。

  1. HMS のソフトウェアユーティリティである Anybus IPconfig をダウンロードしてインストールします。このユーティリティでは、HMS IP Configuration Protocol (HICP) を使用して、Anybus ベースの Ethernet インタフェースを簡単な方法で設定できます。
  2. Ethernet に接続した PC で、Anybus IPconfig を実行します。ネットワーク上で検出された Anybus ベースの Ethernet インタフェースとその IP アドレスが、すべてウィンドウに表示されます。
  3. Anybus X-gateway の CC-Link ステーションアドレススイッチを使用して、CC-Link ステーションアドレスを設定します。詳細については、『X-gateway Interface Addendum - CC-Link Slave Interface』を参照してください。
  4. 通信するオートメーションコントローラのボーレートに合わせて、Anybus X-gateway のボーレートスイッチを設定します。
  5. Anybus X-gateway ハードウェアを実際に取り付けて接続します。詳細については、Anybus X-gateway のマニュアルを参照してください。
  6. Anybus X-gateway ハードウェアを適切に取り付けて、すべてのケーブルを接続した後、Anybus X-gateway ハードウェアの電源を投入し、電源がオンになるまで 30 ～ 60 秒待ちます。Anybus-X Gateway ハードウェアの電源がオンになると、Ethernet LED 状態インジケータが緑色に点灯または点滅します。
  7. Anybus IPconfig ユーティリティで、[Scan] ボタンをクリックし、Anybus ベースの Ethernet インタフェースがすべて表示されているウィンドウを更新します。リストに、デフォルト IP アドレス 192.168.0.1 の Anybus X-gateway ハードウェアが新たに追加表示されます。
  8. Anybus X-gateway の設定を変更する必要がある場合は、リストで [Anybus X-gateway] をダブルクリックします。DHCP による IP アドレスまたは固定 IP アドレス、サブネットマスク、デフォルトゲートウェイ、および DNS サーバを割り当てるためのダイアログが表示されます。設定を完了したら、[Set] ボタンをクリックして続行します。
  9. 最後に、Anybus IPconfig ユーティリティで、[Scan] ボタンをクリックし、Anybus ベースの Ethernet インタフェースがすべて表示されているウィンドウを更新します。リストに、新しい IP アドレス (変更した場合) の Anybus X-gateway ハードウェアが表示されます。

CC-Link ネットワーク上の三菱電機オートメーションコントローラへの Anybus X-gateway の接続

Anybus X-gateway では、TCP/IP Modbus ネットワークと CC-Link データをやり取りし、In-Sight ビジョンシステムの入力と出力を三菱電機オートメーションコントローラのプロセッサメモリに送信することができます。これらの値は、確立後、CC-Link ネットワークの更新レートによって定義される間隔で同期されます。

TCP/IP Modbus 経由での In-Sight ビジョンシステムへの Anybus X-gateway の接続では、実際のデータがどのように転送されるかを説明しています。また、スニペットと詳細なサンプル設定を示しています。

詳細については、『Anybus-X Generic Gateway User Manual』と『Anybus-X CC-Link Slave Network Interface Addendum』を必要に応じて参照してください。これらのマニュアルは、HMS の Web サイト (www.hms-networks.com) でダウンロードすることができます。

Anybus X-gateway のほかに、Anybus Communicator も CC-Link のマスタまたはスレーブとして使用することができます。ここでは Anybus X-gateway を使用します。

CC-Link 通信の設定

Anybus X-gateway と三菱電機コントローラの間の CC-Link 接続を設定するには、最初に Anybus X-gateway をオートメーションコントローラと同じボーレートに設定し、コントローラと異なるステーション番号を指定する必要があります。スイッチは電源コネクタの横にあります。詳細については、Anybus のユーザマニュアルを参照してください。次の手順では、三菱電機 GX Developer ソフトウェアを使用して、オートメーションコントローラの設定を行います。

  1. GX Developer を開き、オートメーションコントローラのプロジェクトをロードします。

  2. オートメーションコントローラモジュールの設定を確認します。[パラメータ]、[PLC パラメータ] の順にダブルクリックし、[I/O 割り当て] タブを選択します。

    この例では、Q02(H) デバイスが 1 つ、Intelli デバイスが 1 つ、入力デバイスが 1 つ、出力デバイスが 1 つあります。ポイントの種類と数の詳細については、三菱電機のマニュアルを参照してください。
  3. CC-Link ネットワークを設定します。[パラメータ] の下の [ネットワークパラメータ] をダブルクリックして、[CC-Link] を選択します。

    PLC が [種類] の下の [マスタステーション] として選択されます。

    [リモートネット (Ver.1 モード)] は、Anybus X-gateway で使用される CC-Link バージョン 1.0 を指しています。Anybus Communicator を使用する場合は、バージョン 2.0 が選択されます。

    Anybus X-gateway が接続されている唯一のステーションであるため、[すべての接続数] は [1] に設定されます。
  4. 占有されるステーションを設定します。[ステーション情報] をダブルクリックします。次の画面が表示されます。

    オートメーションコントローラハンドシェークを設定できるようになります。これは、X-Gateway または Communicator でオートメーションコントローラからの応答が必要な場合のオプションの手順です。詳細については、HMS の Web サイトの『How to set up an Anybus Product with CC-Link and a Mitsubishi Automation Controller』を参照してください。
  5. オートメーションコントローラと相互通信できるように X-Gateway を設定します。PC と Gateway の config ポートの間をシリアルケーブルで接続し、Windows のハイパーターミナルを開きます ([スタート] → [アクセサリ] → [通信] → [ハイパーターミナル])。
  6. [ファイル] メニューで、[プロパティ] をクリックします。
  7. [接続先] タブの [接続方法] フィールドで該当する COM ポートを選択し、[設定] をクリックします。次の画像にある設定を使用します。

    接続して ESC キーを押し、メニューオプションを表示します。

    6 を押して、次の設定情報を入力します。この設定は、オートメーションコントローラの設定画面で入力した情報と一致している必要があります。

    デバイスを再起動します。システムの設定が完了しました。

TCP/IP Modbus 経由での In-Sight ビジョンシステムへの Anybus X-gateway の接続

このセクションでは、TCP/IP Modbus による通信を使用した In-Sight ビジョンシステムへの Anybus X-gateway の接続について説明します。

  • In-Sight Explorer での TCP/IP Modbus による通信の設定In-Sight Explorer
  • オートメーションコントローラから In-Sight ビジョンシステムへの CC-Link 経由でのデータの読み取り
  • In-Sight ビジョンシステムからオートメーションコントローラへの CC-Link 経由でのデータの書き込み

注: 詳細については、Open Modbus/TCP Specification (外部リンク。インターネットアクセスが必要。Modicon 発行) と InSightModbus.doc (Cognex サポート Web サイトで入手可能) を参照してください。

In-Sight Explorer での TCP/IP Modbus による通信の設定In-Sight Explorer

In-Sight ビジョンシステムでは TCP/IP Modbus クライアント機能が有効になっていますが、Anybus X-gateway が TCP/IP Modbus サーバ (スレーブ) として機能するため、このサーバ機能はこのモデルでは必要ありません。

  1. In-Sight Explorer で、In-Sight Explorer [In-Sight ネットワーク] ペインから設定される、In-Sight ビジョンシステムまたはエミュレータを選択します。
  2. [ファイル] メニューの [ジョブの新規作成] を選択し、ビジョンシステムまたはエミュレータに新規ジョブをロードします。
  3. [パレット]の [スニペット] タブを選択して、[Communication] フォルダを展開します。スプレッドシートで、In-Sight Explorerまず A2 を選択して [CCLinkGateway.cxd] をダブルクリックするか、ファイルをセル A2 にドラッグ & ドロップすることにより、CCLinkGateway.cxd ファイルをセル A2 にロードします。
  4. 新規ジョブを CCLinkGateway.job として、ビジョンシステムまたはエミュレータに保存します。
  5. セル A5 をダブルクリックし、Anybus X-gateway の IP アドレスを入力します (必要に応じて、HMS Anybus IPconfig ソフトウェアユーティリティを実行し、Anybus X-gateway の IP アドレスを取得します)。
  6. TCP/IP Modbus の通信では、In-Sight クライアント (マスタ) のジョブに TCPDevice 関数と QueryDevice 関数が存在している必要があります。TCPDevice 関数は、リモートデバイス間 (この場合は、Anybus X-gateway と In-Sight ビジョンシステム) のネットワーク接続を作成するときに使用します。QueryDevice 関数は、TCP/IP Modbus パケットの Modbus 関数コードコマンドを作成するときに使用します。CCLinkGateway.cxd ファイルでは、TCPDevice 関数が C5 に含まれ、2 つの QueryDevice 関数がセル B15 (読み取り要求用) とセル B28 (書き込み要求用) に含まれています。
  7. Anybus X-gateway は、QueryDevice 関数の以下の Modbus 関数コードをサポートしています。
関数コード | 関数名
3 | Read multiple registers
4 | Read input registers
6 | Write single register
7 | Read exception status
8 | Diagnostics
16 | Force multiple registers
22 | Mask write register
23 | Read/Write registers
  8. セル B15 の QueryDevice 関数をダブルクリックし、パラメータが次のように設定されていることを確認します。

注: Modbus パケット構造体の詳細については、『Modbus Implementation Guide』を参照してください。

パラメータ入力番号

パラメータ入力

名前

パラメータ入力値

説明

1

Event

$A$15

[イベント] ボタンへのセル参照。

2

Device

$C$5

セル C5 の TCPDevice 関数へのセル参照。

3

Data

0

Modbus ヘッダ、トランザクション ID、上位バイト = 0。

4

Data

0

Modbus ヘッダ、トランザクション ID、下位バイト = 0。

5

Data

0

Modbus ヘッダ、プロトコル ID、上位バイト = 0。

6

Data

0

Modbus ヘッダ、プロトコル ID、下位バイト = 0。

7

Data

0

フィールド長、上位バイト = 0。

8

Data

6

フィールド長、下位バイト = 6 (後続のバイト数)。

9

Data

0

単位 ID、使用しないバイト = 0。

10

Data

$C$12+3

Modbus 関数コードバイト。この例では、この入力は 3 または 4 になります。

注: Modbus 関数コードバイトが 3 にセットされている場合、In-Sight は保持レジスタ (TCP/IP Modbus 経由で書き込まれたデータ) を読み取ります。Modbus 関数コードバイトが 4 にセットされている場合、In-Sight は入力レジスタ (CC-Link 経由で書き込まれたデータ) を読み取ります。

11

Data

0

Modbus 参照アドレス、上位バイト = 0。

注: 入力レジスタは、アドレス 1000 から Read multiple registers (関数コード 3) を使用して、またはアドレス 0 から Read input registers (関数コード 4) を使用して読み取られる場合があります。

12

Data

$E$19

Modbus 参照アドレス、下位バイト = 4。最初の 4 バイトは「ビット領域」サイズの指定に使用される。この場合、最初の 4 バイトはデータ交換に使用することができず、占有されるステーションの番号のために予約済みです。

注: 入力レジスタは、アドレス 1000 から Read multiple registers (関数コード 3) を使用して、またはアドレス 0 から Read input registers (関数コード 4) を使用して読み取られる場合があります。

注: 詳細については、HMS Web サイト (www.hms-networks.com) のサポートページで提供されている『X-gateway Interface Addendum - CC-Link Slave Interface』のデータ交換の基本事項についての説明 (第 2-1 章) を参照してください。

13

Data

0

ワード (レジスタ) 数、上位バイト = 0。

14

Data

$B$8

ワード (レジスタ) 数、下位バイト = 0。

この例では、この入力は 1、2、3、4、6、8 のいずれかになります。
  9. Anybus X-gateway からの TCP/IP Modbus 応答パケットは、QueryDevice 関数のバイナリ構造体に格納されます。これらの戻り値は、In-Sight Explorer でIn-Sight Explorer BGetInt 関数によって読み取られます。この関数は、バイナリ構造体の特定のバイトからの整数値を返し、応答は以下のような形式になります。
バイト番号 | Modbus 応答 | 説明
バイト 7 | Modbus 関数コード | この例では、3 または 4。このコマンドが失敗すると、関数コードに 128 が追加されます (返される値は 131 または 132。セル E15 を参照してください)。
バイト 8 | バイト数 | この例では、2 レジスタ (ワード) = 4 バイト。セル E15 を参照してください。
バイト 9/10 | レジスタ 0 の値 | これらの値は 2 バイト形式です。CCLinkGateway.cxd ファイルで、セル D18 の BGetInt 関数がバイト 9 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 11/12 | レジスタ 1 の値 | これらの値は 2 バイト形式です。CCLinkGateway.cxd ファイルで、セル D19 の BGetInt 関数がバイト 11 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 13/14 | レジスタ 2 の値 | これらの値は 2 バイト形式です。CCLinkGateway.cxd ファイルで、セル D20 の BGetInt 関数がバイト 13 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 15/16 | レジスタ 3 の値 | これらの値は 2 バイト形式です。CCLinkGateway.cxd ファイルで、セル D21 の BGetInt 関数がバイト 15 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 17/18/19/20 | 浮動小数点数値を格納するレジスタ 3 および 4 の値 | これらの値は浮動小数点形式です。CCLinkGateway.cxd ファイルで、セル D22 の BGetInt 関数がバイト 17 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 21/22/23/24 | 文字列 (バイト配列) を格納するレジスタ 5、6、および 7 の値 | これらの値は文字列形式です。CCLinkGateway.cxd ファイルで、セル D23 の BGetInt 関数がバイト 21 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
  10. 書き込み要求用の QueryDevice 関数 (セル B28) は、要求パケットおよび応答パケットと同じ形式で書式設定されます。

オートメーションコントローラから In-Sight ビジョンシステムへの CC-Link 経由でのデータの読み取り

このモデルによって提供される例に従い、Anybus X-gateway の入力バッファは読み取られるデータソースです。このバッファには、TCP/IP Modbus 上の In-Sight ビジョンシステムが CC-Link ネットワーク上のオートメーションコントローラから要求したデータが保持されます。

  1. 「In-Sight Explorer In-Sight Explorer での TCP/IP Modbus による通信の設定In-Sight Explorer 」で作成したジョブを継続して使用します。
  2. CC-Link Configurator (GX Configurator-CC) を開きます。必要に応じ、GX Developer を使用して、三菱電機オートメーションコントローラにプロジェクトをダウンロードします。また、GX Developer を使用して、さらに複雑なデータ操作を行う場合があります。
  3. オートメーションコントローラシリーズとして、[QCPU-Q] を選択します。

  4. [オンライン] メニューから、[Remote station monitor/test] を選択します。

  5. [Remote station monitor/test] ダイアログを次のように設定します。

  6. [Batch monitor]、[Start monitor] の順にクリックします。
  7. [Present value change (RWw)] をクリックして、読み取り値の 16 進値と 10 進値を入力します。値は、In-Sight Explorer でリトルエンディアン表記で転送されている場合であっても、ビッグエンディアン表記でIn-Sight Explorer表示されます。

  8. CCLinkGateway.cxd ファイルのセル A8 で、レジスタの値として [8] (16 バイト) を選択します。
  9. セル C12 で、[Read Registers] のドロップダウンリストから、[Input Registers] を選択します。

  10. セル A15 の [Read] ボタンをクリックして、結果を更新します。セル D18 ～ D23 の値が変化して、CC-Link Configurator で入力した値が反映されるはずです。

In-Sight ビジョンシステムからオートメーションコントローラへの CC-Link 経由でのデータの書き込み

このモデルによって提供される例に従い、Anybus X-gateway の出力バッファは書き込まれるデータソースです。このバッファには、TCP/IP Modbus 上の In-Sight ビジョンシステムが CC-Link ネットワーク上のオートメーションコントローラに書き込むデータが保持されます。

  1. CCLinkGateway.cxd ファイルのセル A8 で、レジスタの値として [8] (16 バイト) を選択します。
  2. セル C12 で、[Read Registers] のドロップダウンリストから[Holding Registers] を選択します。これにより、In-Sight ジョブ内で書き込まれるのと同じレジスタからデータが読み取られます。
  3. 次に、アプリケーションに対する正しいデータタイプになるように、セル D31 ～ D36 の値を調整します。EditInt セルに値を入力します。セル D31 ～ D34 には 4 つの整数 (最小値は -32768、最大値は 32767 で、値はこの範囲内の有効な整数である必要があります) を、セル D35 には浮動小数点数値 (最小値は ±1.175495e-38、最大値は ±3.402823e+38 で、値はこの範囲内の有効な浮動小数点数値である必要があります) を、セル D36 には 4 バイトの文字列 (文字列は 4 文字を超えることができなくなりました) を入力します。

  4. セル A28 の [Write] ボタンをクリックし、In-Sight Explorer スプレッドシートからIn-Sight Explorerオートメーションコントローラに結果を書き込みます。

  5. セル A15 の [Read] ボタンをクリックします。セル D18 ～ D23 の値が変化し、セル D31 ～ 36 に入力した値が反映されるはずです。
  6. CC-Link Configurator (GX Configurator-CC) を開きます。必要に応じ、GX Developer を使用して、三菱電機オートメーションコントローラにプロジェクトをダウンロードします。また、GX Developer を使用して、さらに複雑なデータ操作を行う場合があります。
  7. オートメーションコントローラシリーズとして、[QCPU-Q] を選択します。

  8. [オンライン] メニューから、[Remote station monitor/test] を選択します。

  9. [Remote station monitor/test] ダイアログを次のように設定します。

  10. [Batch monitor]、[Start monitor] の順にクリックします。RWr モニタの下の値が、In-Sigth Explorer スプレッドシートで入力した値の 16 進値と 10 進値を反映するようにIn-Sight Explorer変更されます。値は、In-Sight Explorer でリトルエンディアン表記で転送されている場合であっても、ビッグエンディアン表記でIn-Sight Explorer表示されます。

関連項目

Anybus X-gateway

Version: 5.6.0


PROFIBUS ネットワーク上の Siemens PLC との通信

TCP/IP Modbus による通信

In-Sight 通信リファレンス

概要

Anybus X-gateway のインストールと設定

PROFIBUS ネットワーク上の Siemens PLC への Anybus X-gateway の接続

TCP/IP Modbus 経由での In-Sight ビジョンシステムへの Anybus X-gateway の接続

概要

In-Sight ビジョンシステムは、Anybus X-gateway と TCP/IP Modbus プロトコルを使用して、PROFIBUS ネットワーク上のデバイスと通信することができます。

このトピックでは、ゲートウェイのインストールおよび設定方法、PLC プログラミングソフトウェア (Siemens Step 7) の設定方法、PROFIBUS ネットワーク上の Siemens PLC と通信するための In-Sight Explorer のセットアップ方法について説明します。

下記の例は、次のコンポーネントを使用していることを前提に記述されています。

  • Anybus X-gateway および HMS Anybus IPconfig ソフトウェア
  • ファームウェアバージョン 3.41.00 以降を実行している In-Sight ビジョンシステム
  • Siemens S7-300 または S7-400 シリーズ PLC (PROFIBUS オプション)
  • Siemens Step 7 プログラミングソフトウェア

Anybus X-gateway のインストールと設定

このセクションの手順では、Anybus X-gateway の Ethernet 部分のインストールおよび設定方法について説明します。手順では、次のコンポーネントを使用していることを前提にしています。

注: 詳細については、HMS Anybus-X のマニュアル (『Anybus-X Generic Gateway User Manual』、『Anybus-X Ethernet Network Interface Addendum』、『Anybus-X PROFIBUS Slave Network Interface Addendum』) を参照してください。これらのマニュアルは、HMS の Web サイト (www.hms-networks.com) からダウンロードできます。

Anybus X-gateway のインストールおよび設定を行うには、以下の手順に従います。

  1. HMS のソフトウェアユーティリティである Anybus IPconfig をダウンロードしてインストールします。このユーティリティでは、HMS IP Configuration Protocol (HICP) を使用して、Anybus ベースの Ethernet インタフェースを簡単な方法で設定できます。
  2. Ethernet に接続した PC で、Anybus IPconfig を実行します。ネットワーク上で検出された Anybus ベースの Ethernet インタフェースとその IP アドレスが、すべてウィンドウに表示されます。
  3. Anybus X-gateway のロータリー PROFIBUS ノードアドレススイッチを使用して、PROFIBUS ノードアドレスを設定します。詳細については、『Anybus-X PROFIBUS Slave Network Interface Addendum』を参照してください。
  4. Anybus X-gateway ハードウェアを実際に取り付けて接続します。詳細については、Anybus X-gateway のマニュアルを参照してください。
  5. Anybus X-gateway ハードウェアを適切に取り付けて、すべてのケーブルを接続した後、Anybus X-gateway ハードウェアの電源を投入し、電源がオンになるまで 30 ～ 60 秒待ちます。Anybus-X Gateway ハードウェアの電源がオンになると、Ethernet LED 状態インジケータが緑色に点灯または点滅します。
  6. Anybus IPconfig ユーティリティで、[Scan] ボタンをクリックし、Anybus ベースの Ethernet インタフェースがすべて表示されているウィンドウを更新します。リストに、デフォルト IP アドレス 192.168.0.1 の Anybus X-gateway ハードウェアが新たに追加表示されます。
  7. Anybus X-gateway の設定を変更する必要がある場合は、リストで [Anybus X-gateway] をダブルクリックします。DHCP による IP アドレスまたは固定 IP アドレス、サブネットマスク、デフォルトゲートウェイ、および DNS サーバを割り当てるためのダイアログが表示されます。設定を完了したら、[Set] ボタンをクリックして続行します。
  8. 最後に、Anybus IPconfig ユーティリティで、[Scan] ボタンをクリックし、Anybus ベースの Ethernet インタフェースがすべて表示されているウィンドウを更新します。リストに、新しい IP アドレス (変更した場合) の Anybus X-gateway ハードウェアが表示されます。

PROFIBUS ネットワーク上の Siemens PLC への Anybus X-gateway の接続

このセクションでは、Siemens PLC と Anybus X-gateway の間の PROFIBUS 通信を接続および検証するための手順を示します。

Anybus X-gateway では、PROFIBUS ネットワークと TCP/IP Modbus ネットワークの間でデータをやり取りします。これにより In-Sight ビジョンシステムの入力と出力を Siemens PLC のプロセッサのメモリに送信することができます。これらの値は、確立後、PROFIBUS ネットワークの更新レートによって定義される間隔で同期されます。

注: 詳細については、HMS Anybus-X のマニュアル (『Anybus-X Generic Gateway User Manual』、『Anybus-X Ethernet Network Interface Addendum』、『Anybus-X PROFIBUS Slave Network Interface Addendum』) を参照してください。これらのマニュアルは、HMS の Web サイト (www.hms-networks.com) からダウンロードできます。

Anybus X-gateway との PROFIBUS 通信の設定

Siemens コントローラと Anybus X-gateway の間の PROFIBUS 接続をセットアップするには、まず、Siemens の HW Config ツールを使用して Anybus X-gateway をコントローラのハードウェア構成に追加する必要があります。

  1. SIMATIC マネージャを開き、PLC のプロジェクトをロードします。
  2. [SIMATIC 300] または [SIMATIC 400] ノードを選択してから、オブジェクトリストの [Hardware] ノードをダブルクリックします。

  3. Siemens の HW Config ツールが表示されます。PROFIBUS ノードをコントローラに追加するには、PROFIBUS システムがハードウェア構成図内に存在する必要があります。ハードウェア構成図に PROFIBUS:DP マスタシステムが存在しない場合は、以下の手順に従って追加します。
  1. ラック設定のコントローラのスロットで、DP または MPI/DP モジュールを見つけて、そのモジュールをダブルクリックします。
  2. [Properties] ダイアログの [Operating Mode] タブで [DP Master] ラジオボタンが選択されていることを、また [General] タブでインタフェースタイプが　[PROFIBUS] に設定されていることを確認します。
  3. デバイスのアドレスを変更する必要がある場合は、[Properties...] ボタンをクリックします。
  4. リストビューで [PROFIBUS] サブネットを選択し、[Properties...] ボタンをクリックします。必要な場合は、ネットワーク名を変更し、[Transmission Rate] と [Highest PROFIBUS Address] を変更します。
  5. [OK] ボタンをクリックして、このダイアログでの変更をすべて確定します。
  6. これで、PROFIBUS DP マスタシステムが図に表示されます。

  4. Anybus X-gateway を PROFIBUS ネットワークに初めて追加する場合は、HMS Industrial Networks AB Anybus-X Gateway GSD ファイルがインストールされている必要があります。このファイルの最新バージョンは、HMS の Web サイトからダウンロードするか、HMS に直接連絡して入手することができます。以下の手順を実行して Anybus-X Gateway GSD ファイルをインストールします。
  1. HW Config ツールのメニューから、[オプション] → [Install GSD Files (GSD ファイルのインストール)] を選択します。
  2. [Browse] ボタンを押し、HMS_1013.GSD ファイルが格納されている GSD フォルダを選択します。
  3. [Select All] ボタンを押してから、[Install] ボタンをクリックして Anybus X-gateway のハードウェア記述をインストールします。
  5. Anybus X-gateway デバイスを PROFIBUS ネットワークに追加するには、Hardware Catalog で [Anybus-S PROFIBUS DP-V1] ノードを参照します (ツリーで、[PROFINET DP] → [Additional Field Devices] → [General] ノードの順に選択してアクセスします)。Anybus-S PROFIBUS DP-V1 デバイスのインスタンスをハードウェア構成の PROFIBUS DP マスタシステムにドラッグします。

  6. PROFIBUS ノードのアドレスを、接続先の Anybus X-gateway デバイスのアドレスに設定します (Anybus X-gateway PROFIBUS ノードのアドレスは、Anybus X-gateway のロータリー PROFIBUS ノードアドレススイッチを使用して設定します)。
  7. これで、PROFIBUS:DP マスタシステムに Anybus X-gateway デバイスが指定されたアドレスで表示されます。
  8. デバイス名を変更するには、構成内のノードをダブルクリックし、[Designation] フィールドの値を新しい名前に変更します。

  9. 次に、入出力バイトの設定値を PROFIBUS ネットワークに応じて設定する必要があります。各ネットワークでの入出力に対する Anybus X-gateway のデフォルト設定は 20 バイト (10 ワード) です。PROFIBUS ネットワーク上の I/O バイトすべてにアクセスするように PLC を設定するには、まず、Hardware Catalog で [Anybus-S PROFIBUS DP-V1] ノードを展開します。Anybus-S PROFIBUS DP-V1 ノードで、[IN/OUT:8 words] モジュールを選択し、スロット 1 のグリッドにドラッグ & ドロップします。次に、[IN/OUT:2 words] モジュールを選択し、スロット 2 のグリッドにドラッグ & ドロップします。これで、PLC の 10 ワードが Anybus X-gateway で使用されるようにマップされます。

注: 20 I/O バイトのデフォルト設定の変更方法の詳細については、『Anybus-X Generic Gateway User Manual』の第 5 章を参照してください。

  10. Anybus X-gateway を PROFIBUS システムに追加した後は、HW Config ユーティリティを使用し、プロジェクトを保存して完了してから PLC にダウンロードすることができます。
  11. プロジェクトが PLC に正常にダウンロードされると、Anybus X-gateway では、ゲートウェイステータス LED と PROFIBUS オンラインステータス LED の両方が緑で点灯し、PROFIBUS PLC と正常に通信できることが示されます。

PROFIBUS 通信の検証

上記の手順に従うと、この時点で Anybus X-gateway が入出力デバイスとして Siemens プロジェクトに追加されます。このプロジェクトがコントローラにダウンロードされると、周期データ転送が開始されます。

PLC と Anybus X-gateway の間の I/O 接続が正しいことを検証するには、以下の手順を実行します。

  1. Siemens コントローラの [Operating Mode] を [Run] に設定します。
  2. HW Config ツールをオンラインモードで開きます。Anybus X-gateway がエラーなしで表示されます (エラーは、Anybus X-gateway のネットワークアイコンに赤い線を付けて示されます)。これは、PROFIBUS 接続が正常に確立されたことを意味します。

接続の確立

接続エラー
  3. PROFIBUS(1): DP マスタシステム (1) ネットワークの [Anybus X-gateway] ボックスをダブルクリックします。[General] タブに、ステータスが「OK」または「Module available and o.k.」のどちらかとして表示されます。
  4. HW Config ユーティリティで、Anybus X-gateway が選択された状態で [IN/OUT 8 words] モジュールを右クリックし、メニューから [Monitor/Modify] を選択します。

  5. [Monitor/Modify] ダイアログの [Run conditionally] サブセクションで [Monitor] チェックボックスをオンにします。ダイアログの右下に「RUNNING」というワードが表示されます。[Status value] 列には、[Address] 列のリストにある PIW 入力ワードのアドレスごとにステータスコードが返されます。

注: 詳細については、『Anybus-X PROFIBUS Slave Network Interface Addendum』の第 3 章を参照してください。

TCP/IP Modbus 経由での In-Sight ビジョンシステムへの Anybus X-gateway の接続

このセクションでは、TCP/IP Modbus による通信を使用した In-Sight ビジョンシステムへの Anybus X-gateway の接続について説明します。

  • In-Sight Explorer での TCP/IP Modbus による通信の設定
  • PLC から In-Sight ビジョンシステムへの PROFIBUS 経由でのデータの読み取り
  • In-Sight ビジョンシステムから PLC への PROFIBUS 経由でのデータの書き込み

注:
  • 詳細については、Open Modbus/TCP Specification (外部リンク。インターネットアクセスが必要。Modicon 発行) と InSightModbus.doc (Cognex サポート Web サイトで入手可能) を参照してください。
  • 以下のサンプルでは、Anybus X-gateway でのデフォルトの [Modbus/TCP Modbus Adress Mode] が [Enabled] になっている (デフォルト設定) と想定しています。この設定を [Modbus Address Mode Disabled] に変更する場合は、ProfibusGateway.cxd の Read Holding Registers 関数と Write Multiple Registers QueryDevice 関数を更新し、0 ではなく新しい登録アドレスの 1024 を反映させる必要があります。『X-Gateway Interface Addendum Ethernet Slave Interface』の第 5 章、5-1 から 5-4 ページを参照してください。

In-Sight Explorer での TCP/IP Modbus による通信の設定

In-Sight ビジョンシステムでは TCP/IP Modbus クライアント機能が有効になっていますが、Anybus X-gateway が TCP/IP Modbus サーバ (スレーブ) として機能するため、このサーバ機能はこのモデルでは必要ありません。

  1. In-Sight Explorer で、[In-Sight ネットワーク] ペインから設定する In-Sight ビジョンシステムまたはエミュレータを選択します。
  2. [ファイル] メニューの [ジョブの新規作成] を選択し、ビジョンシステムまたはエミュレータに新規ジョブをロードします。
  3. [パレット]の [スニペット] タブを選択して、[Communication] フォルダを展開します。まず A2 を選択して CCLinkGateway.cxd をダブルクリックするか、またはファイルをセル A2 にドラッグ & ドロップすることにより、In-Sight Explorer スプレッドシートの A2 セルに ProfibusGateway.cxd ファイルをロードします。
  4. ビジョンシステムまたはエミュレータに、新規ジョブを ProfibusGateway.job として保存します。
  5. セル A5 をダブルクリックし、Anybus X-gateway の IP アドレスを入力します (必要に応じ、HMS Anybus IPconfig ソフトウェアユーティリティを実行して、Anybus X-gateway の IP アドレスを取得します)。
  6. TCP/IP Modbus の通信では、In-Sight クライアント (マスタ) のジョブに TCPDevice 関数と QueryDevice 関数が存在している必要があります。TCPDevice 関数は、リモートデバイス間 (この場合は、Anybus X-gateway と In-Sight ビジョンシステム) のネットワーク接続を作成するときに使用します。QueryDevice 関数は、TCP/IP Modbus パケットの Modbus 関数コードコマンドを作成するときに使用します。ProfibusGateway.cxd ファイルでは、TCPDevice 関数が C5 に含まれ、2 つの QueryDevice 関数がセル B15 (読み取り要求用) とセル B27 (書き込み要求用) に含まれています。
  7. Anybus X-gateway は、QueryDevice 関数の以下の Modbus 関数コードをサポートしています。
関数コード | 関数名
3 | Read multiple registers
4 | Read input registers
6 | Write single register
7 | Read exception status
8 | Diagnostics
16 | Force multiple registers
22 | Mask write register
23 | Read/Write registers
  8. セル B15 の QueryDevice 関数をダブルクリックし、パラメータが次のように設定されていることを確認します。

パラメータ入力番号 | パラメータ入力 名前 | パラメータ入力値 | 説明
1 | Event | $A$15 | [イベント] ボタンへのセル参照。
2 | Device | $C$5 | セル C5 の TCPDevice 関数へのセル参照。
3 | Data | 0 | Modbus ヘッダ、トランザクション ID、上位バイト = 0。
4 | Data | 0 | Modbus ヘッダ、トランザクション ID、下位バイト = 0。
5 | Data | 0 | Modbus ヘッダ、プロトコル ID、上位バイト = 0。
6 | Data | 0 | Modbus ヘッダ、プロトコル ID、下位バイト = 0。
7 | Data | 0 | フィールド長、上位バイト = 0。
8 | Data | 6 | フィールド長、下位バイト = 6 (後続のバイト数)。
9 | Data | 0 | 単位 ID、使用しないバイト = 0。
10 | Data | $C$12+3 | Modbus 関数コードバイト。この例では、この入力は 3 または 4 になります。 注: Modbus 関数コードバイトが 3 にセットされている場合、In-Sight は保持レジスタ (TCP/IP Modbus 経由で書き込まれたデータ) を読み取ります。Modbus 関数コードバイトが 4 にセットされている場合、In-Sight は入力レジスタ (PROFIBUS 経由で書き込まれたデータ) を読み取ります。
11 | Data | 0 | Modbus 参照アドレス、上位バイト = 0。 注: 入力レジスタは、アドレス 1024 から Read multiple registers (関数コード 3) を使用して、またはアドレス 0 から Read input registers (関数コード 4) を使用して読み取られる場合があります。
12 | Data | 0 | Modbus 参照アドレス、下位バイト = 0。 注: 入力レジスタは、アドレス 1024 から Read multiple registers (関数コード 3) を使用して、またはアドレス 0 から Read input registers (関数コード 4) を使用して読み取られる場合があります。
13 | Data | 0 | ワード (レジスタ) 数、上位バイト = 0。
14 | Data | $B$8 | ワード (レジスタ) 数、下位バイト。この例では、この入力は 1、2、3、5、8 のいずれかになります。
  9. Anybus X-gateway からの TCP/IP Modbus 応答パケットは、QueryDevice 関数のバイナリ構造体に格納されます。これらの戻り値は、In-Sight Explorer で BGetInt 関数によって読み取られます。この関数は、バイナリ構造体の特定のバイトからの整数値を返し、応答は以下のような形式になります。
バイト番号 | Modbus 応答 | 説明
バイト 7 | Modbus 関数コード | この例では、3 または 4。このコマンドが失敗すると、関数コードに 128 が追加されます (返される値は 131 または 132。セル E15 を参照してください)。
バイト 8 | バイト数 | この例では、2 レジスタ (ワード) = 4 バイト。セル E15 を参照してください。
バイト 9/10 | レジスタ 0 の値 | これらの値は 2 バイト形式です。ProfibusGateway.cxd ファイルで、セル D18 の BGetInt 関数がバイト 9 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 11/12 | レジスタ 1 の値 | これらの値は 2 バイト形式です。ProfibusGateway.cxd ファイルで、セル D19 の BGetInt 関数がバイト 11 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 13/14 | レジスタ 2 の値 | これらの値は 2 バイト形式です。ProfibusGateway.cxd ファイルで、セル D20 の BGetInt 関数がバイト 13 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 15/16/17/18 | 浮動小数点数値を格納するレジスタ 3 および 4 の値 | これらの値は浮動小数点形式です。ProfibusGateway.cxd ファイルで、セル D21 の BGetInt 関数がバイト 15 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
バイト 19/20/21/22/23/24 | 文字列 (バイト配列) を格納するレジスタ 5、6、および 7 の値 | これらの値は文字列形式です。ProfibusGateway.cxd ファイルで、セル D22 の BGetInt 関数がバイト 19 のバイナリ値を読み取ります (ワード読み取りの下位バイト)。
  10. 書き込み要求用の QueryDevice 関数 (セル B27) は、要求パケットおよび応答パケットと同じ形式で書式設定されます。

PLC から In-Sight ビジョンシステムへの PROFIBUS 経由でのデータの読み取り

このモデルによって提供される例に従い、Anybus X-gateway の入力バッファは読み取られるデータソースです。このバッファには、TCP/IP Modbus ネットワーク上の In-Sight ビジョンシステムによって要求される PROFIBUS ネットワーク上の PLC からのデータが保持されます。

  1. 「In-Sight Explorer での TCP/IP Modbus による通信の設定」のセクションで作成した In-Sight Explorer ジョブを引き続き使用します。
  2. SIMATIC マネージャを開き、PLC のプロジェクトをロードします。必要に応じて、プロジェクトを Siemens コントローラにダウンロードし、[Operating Mode] を [Run] に設定します。
  3. SIMATIC Manager で、PLC を右クリックして [Variable Table] メニューから [Insert New Object] を選択することにより、新しい変数テーブルを作成します。新規テーブルに名前を付けて開きます。
  4. 以下のテーブルのようにして、5 つの項目をテーブルに追加します。
オフセット | アドレス | 表示形式
0 | PQW 385 | DEC
+2 | PQW 387 | DEC
+4 | PQW 389 | DEC
+6 | PQD 391 | FLOATING_POINT
+10 | PQD 395 | CHARACTER
+14 | PQD 399 | CHARACTER

注: アドレスは、出力アドレスが PQW 385 になっている [IN/OUT 8 words] で予測されます。[IN/OUT 8 words] モジュールで別の出力アドレスが使用されている場合は、指定されたオフセットが出力アドレスに適用されて正しい出力アドレスが返されます。

  5. SIMATIC Manager で、[PLC] → [Connect To] メニューから [ConfiguredCPU] を開きます。システムは、これでオンラインになり、変数テーブルに入力されたアドレスを監視します。
  6. 変数テーブルに追加した 5 つの項目の値を入力して、[Variable] メニューの [Activate Modify Values] を選択します。

  7. ビジョンシステムをオンラインに設定します。
  8. ProfibusGateway.cxd ファイルのセル A8 で、レジスタの値として [8] (16 バイト) を選択します。
  9. セル C12 で、[Read Registers] のドロップダウンリストから、[Input Registers] を選択します。

  10. セル A15 の [Read] ボタンをクリックして、結果を更新します。セル D18 ～ D22 の値は、変数テーブルに入力した値を反映して変更されます。

In-Sight ビジョンシステムから PLC への PROFIBUS 経由でのデータの書き込み

このモデルによって提供される例に従い、Anybus X-gateway の出力バッファは書き込まれるデータソースです。このバッファには、TCP/IP Modbus ネットワーク上の In-Sight ビジョンシステムによって PROFIBUS ネットワーク上の PLC に書き込まれるデータが保持されます。

  1. ProfibusGateway.cxd ファイルのセル A8 で、レジスタの値として [8] (16 バイト) を選択します。
  2. セル C12 で、[Read Registers] のドロップダウンリストから[Holding Registers] を選択します。これにより、In-Sight ジョブ内で書き込まれるのと同じレジスタからデータが読み取られます。
  3. 次に、アプリケーションに対する正しいデータタイプになるように、セル D30 ～ D34 の値を調整します。EditInt セルに値を入力します。セル D30 ～ D32 には 3 つの整数 (最小値は -32768、最大値は 32767 で、値はこの範囲内の有効な整数である必要があります) を、セル D33 には浮動小数点数値 (最小値は ±1.175495e-38、最大値は ±3.402823e+38 で、値はこの範囲内の有効な浮動小数点数値である必要があります) を、セル D34 には 6 バイトの文字列 (文字列は 4 文字を超えることができなくなりました) を入力します。

  4. セル A27 の [Write] ボタンをクリックし、In-Sight Explorer スプレッドシートから PLC に結果を書き込みます。

  5. セル A15 の [Read] ボタンをクリックします。セル D18 ～ D22 の値は、セル D30 ～ 34 に入力した値を反映して変更されます。
  6. SIMATIC マネージャを開き、PLC のプロジェクトをロードします。必要に応じて、プロジェクトを Siemens コントローラにダウンロードし、[Operating Mode] を [Run] に設定します。
  7. SIMATIC Manager で、PLC を右クリックして [Variable Table] メニューから [Insert New Object] を選択することにより、新しい変数テーブルを作成します。新規テーブルに名前を付けて開きます。
  8. 以下のテーブルのようにして、5 つの項目をテーブルに追加します。
オフセット | アドレス | 表示形式
0 | PIW 325 | DEC
+2 | PIW 327 | DEC
+4 | PIW 329 | DEC
+6 | PID 331 | FLOATING_POINT
+10 | PID 335 | CHARACTER
+14 | PIW 339 | CHARACTER

注: アドレスは、入力アドレスが PIW 325 になっている [IN/OUT 8 words] で予測されます。[IN/OUT 8 words] モジュールで別の入力アドレスが使用されている場合は、指定されたオフセットが入力アドレスに適用されて正しい出力アドレスが返されます。

  9. SIMATIC Manager で、[PLC] → [Connect To] メニューから [ConfiguredCPU] を開きます。システムは、これでオンラインになり、変数テーブルに入力されたアドレスを監視します。変数テーブルの値は、In-Sight Explorer スプレッドシートに入力した値を反映して変更されます。

注: Siemens S7 PLC は、Byte、Word、または DoubleWord としてのデータにアクセスすることにより、I/O-image から直接、1、2、または 4 バイトを一貫して読み取ることができます。ただし、1 つのデータ文字列で 4 バイトより多くを読み取る場合は、システム関数ブロック SFC14 と SFC15 を使用する必要があります。詳細については、HMS の Web サイト (www.hms-networks.com) のサポートページにある HMS のマニュアル『How to Configure an Anybus PROFIBUS Slave Module with a Siemens Step7 PLC 』のセクション 5.2.2 を参照してください。

関連項目

Anybus X-gateway

Version: 5.6.0


DataChannel による通信

In-Sight 通信リファレンス

In-Sight の DataChannel は、英数字のデータと画像を開発者独自のグラフィカルユーザインタフェース (GUI) アプリケーションに統合します。DataChannel によって、In-Sight ビジョンシステムを TCP/IP サーバとして使用し、GUI アプリケーションを TCP/IP クライアントとして使用することができます。この構成によって、画像とデータを In-Sight ビジョンシステムから PC に転送する高速で効率的なメカニズムが実現されます。

DataChannel への接続の確立

カスタム GUI アプリケーションで DataChannel を使用するには、次の手順に従ってください。

  1. In-Sight ビジョンシステムへの TCP 接続を開きます。

    注: DataChannel 用のデフォルトの TCP/IP ポート番号は 50000 です。別のポート番号を指定する必要がある場合は、ネイティブモードの Put Portnum コマンドを使用してください。

  2. クライアントからポートに接続します。

  3. 接続が確立したら、クライアントは有効なユーザ名とパスワードを使用してログインする必要があります。デフォルトのログインユーザ名は「admin」、パスワードは空白文字列です。In-Sight ビジョンシステムでは、ログインの画面は表示されません。ユーザ名とパスワードの両方の後にキャリッジリターン/ラインフィード (CRLF) を送信する必要があります。

    ユーザ名とパスワードのいずれかが 5 秒以内に In-Sight ビジョンシステムに送信されないか、無効である場合は、次のメッセージが表示され、接続は終了します。

    "<Prompt><Accept>Invalid Password</Accept></Prompt>" + CRLF

    ユーザ名とパスワードが有効な場合は、次のようなウェルカムメッセージが送信されます。

    "<Prompt><Accept>ok</Accept><DataSession>0</DataSession><OpcSession>0</OpcSession><ImageSession>0</ImageSession>
    <SystemType>22</SystemType><Screen><High>480</High><Wide>640</Wide><Color>0</Color></Screen>
    <ToolEnabledBits>FEF6FFFF300000000000000000000000</ToolEnabledBits></Prompt>" + CRLF

    注:
    • 高解像度 In-Sight ビジョンシステムにログオンした場合、High と Wide の値は、それぞれ 768 と 1024、または 1200 と 1600 です。
    • OpcSession は COGNEX 技術者のみが使用します。

    • Closed SystemType は、In-Sight ビジョンシステムのハードウェアタイプを示します。

      In-Sight モデル

      SystemType 出力

      In-Sight 5100

      16、17、19、22、36、44、48、52、102

      In-Sight 5100C

      24、61、109、111

      In-Sight 5110

      20、26、42、49

      In-Sight 5400

      14、40、41

      In-Sight 5400C

      33、109、111

      In-Sight 5403

      38

      In-Sight 5410

      21、37、47

      In-Sight 5413

      43

      In-Sight 5600

      53、118

      In-Sight 5603

      60、120

      In-Sight 5604

      88、114

      In-Sight 5605

      100

      In-Sight 5610

      67

      In-Sight 5613

      66

      In-Sight 5614

      98

      In-Sight 5615

      101
      In-Sight 5705 | 139
      In-Sight 5715 | 139
      In-Sight 5705C | 137

      In-Sight Micro 1020

      79

      In-Sight Micro 1050

      80

      In-Sight Micro 1100

      76

      In-Sight Micro 1100C

      87

      In-Sight Micro 1110

      81

      In-Sight Micro 1400

      77

      In-Sight Micro 1400C

      86、125
      In-Sight Micro 1402 | 127
      In-Sight Micro 1403

      78、124

      In-Sight Micro 1403C

      89、126
      In-Sight Micro 1410

      82
      In-Sight Micro 1412 | 127

      In-Sight Micro 1413

      83
      In-Sight Micro 1500 | 135

      In-Sight 7010

               129

      In-Sight 7010C

               133

      In-Sight 7020

               129
      In-Sight 7050 | 129
      In-Sight 7200 | 129
      In-Sight 7200C | 133
      In-Sight 7210 | 129
      In-Sight 7230 | 129
      In-Sight 7400 | 129
      In-Sight 7400C | 133
      In-Sight 7410 | 129
      In-Sight 7430 | 129
      In-Sight 7402 | 129
      In-Sight 7402C | 133
      In-Sight 7412 | 129
      In-Sight 7432 | 129
      In-Sight 7600 | 144
      In-Sight 7600C | 144
      In-Sight 7800 | 144
      In-Sight 7800C | 144
      In-Sight 7801 | 144
      In-Sight 7801C | 144
      In-Sight 7802 | 144
      In-Sight 7802C | 144
      In-Sight 7900 | 144
      In-Sight 7900C | 144
      In-Sight 7901 | 144
      In-Sight 7901C | 144
      In-Sight 7902 | 144
      In-Sight 7902C | 144
      In-Sight 7905 | 144
      In-Sight 7905C | 144
      In-Sight 8200 | 141
      In-Sight 8200C | 141
      In-Sight 8400 | 141
      In-Sight 8400C | 141
      In-Sight 8401 | 141
      In-Sight 8401C | 141
      In-Sight 8402 | 141
      In-Sight 8402C | 141
      In-Sight 8405 | 138

    • ToolEnabledBits は COGNEX 技術者のみが使用します。

    ユーザ名とパスワードが無効の場合、In-Sight は次のメッセージを送信して接続を閉じます。

    "<Prompt><Accept>Invalid Password</Accept></Prompt>" + CRLF

    In-Sight ビジョンシステムへのほかのアクティブなネットワーク接続がない場合は、最大 6 つの DataChannel 接続を同時に確立できます。既に 6 つのアクティブなネットワーク接続が存在する場合、In-Sight ビジョンシステムは次のメッセージを送信します。

    "<Prompt><Accept>Too many connections</Accept></Prompt>" + CRLF

  4. ログインに成功した後、クライアントは、DataChannel 経由で受信する情報のタイプを指定する必要があります。クライアントは、画像情報を受信する場合は「IMG」+CRLF、データを受信する場合は「DAT」+CRLF を送信する必要があります。スプレッドシートが更新されるたびに、画像またはデータが DataChannel 経由で送信されます。ログインと同様に、いずれかのコマンドが 5 秒以内に In-Sight ビジョンシステムに送信されなかった場合は、次のメッセージが表示され、接続は終了します。

    "<Prompt><Accept>Connection Closed</Accept></Prompt>" + CRLF

  5. データを送信するように接続が設定されている場合は、ネイティブモードの Put Watch コマンドを使用して出力セルを指定します。

    注:
    • In-Sight のスプレッドシートが変更された場合は常に、Put Watch コマンドを送信する必要があります。
    • DataChannel は、数値または文字列のデータが含まれている任意のセルをモニタできます。データ出力は、XML フォーマットで送信されます。データは、モニタ対象のセルが「評価」(計算) されるか、セル内の値が変更されたときのみ、そのセルから送信されます。定数値はほかのセルに依存しないので (ほかのセルの値が変化しても、定数セルの値は変化しません)、スプレッドシートへの挿入後、一度しか評価されません。セルの評価と依存関係の詳細については、ここをクリックしてください。
    • Put Watch コマンドを送信する代わりに、SetWatch 関数を In-Sight のスプレッドシートに挿入すると、情報を DataChannel に自動送信することができます。
    • AcqSeqNum の値は、データ出力を、対応する画像出力に一致させるために使用できます。スプレッドシートが、イベントによって、または手動トリガによって更新されると、2 サイクルが発生します。そのほかの取り込みトリガは、1 サイクルのみを出力します。2 サイクルが発生した場合、2 番目のサイクルは、データ出力を、対応する画像出力に一致させるために使用されます。

Closed Telnet クライアントによる DataChannel のテスト

  1. コマンドプロンプトを開きます。コマンドプロンプトから、Telnet クライアントを使用してビジョンシステムにログオンします。ログオンするときには、ホスト名または IP アドレスとポート番号 23 (予約済みのネイティブモードコマンドポート) を指定します。例: telnet is5100_010203 23

  2. Telnet クライアントから、次のコマンドを入力します。EV B0 1 Count($A$0,9999999,0,0)Count 関数が、デフォルトのパラメータを使用してセル B0 に挿入されます。

  3. Telnet クライアントから、次のコマンドを入力します。Put Watch B000 1

  4. コマンドプロンプトから、2 番目の Telnet セッションを開始して、In-Sight ビジョンシステムにログオンします。ログオンするときには、ホスト名または IP アドレスとポート番号 50000 (デフォルトの DataChannel ポート) を指定します。例: telnet is5100_010203 50000

  5. 2 番目の Telnet セッションから、「admin」と入力して、Enter キーを押します。もう一度 Enter キーを押して、空のパスワードを適用します。

  6. 2 番目の Telnet セッションから、「DAT」と入力して、Enter キーを押します。

  7. In-Sight ビジョンシステムで画像を一度取り込みます。2 番目の Telnet プログラムが受信したデータが表示されます。

Closed データ出力フォーマット

データ出力は、XML フォーマットで送信されます。 前述の例を使用した Telnet セッションからの出力の例を次に示します。In-Sight ビジョンシステムは、手動で 2 度トリガされました。

注: スプレッドシートが、イベントによって、または手動トリガによって更新されると、2 サイクルが発生します。そのほかの取り込みトリガは、1 サイクルのみを出力します。

Admin

******

<Prompt><Accept>ok</Accept><DataSession>0</DataSession><OpcSession>0</OpcSession><ImageSession>0</ImageSession>
<SystemType>22</SystemType><Screen><High>480</High><Wide>640</Wide><Color>0</Color></Screen>
<ToolEnabledBits>FEF6FFFF300000000000000000000000</ToolEnabledBits></Prompt>

dat

<Cycle AcqSeqNum="1">

</Cycle>

<Cycle AcqSeqNum="2">

<Cell Id="B0">

  <Float>1</Float>

</Cell>

</Cycle>

<Cycle AcqSeqNum="2">

</Cycle>

<Cycle AcqSeqNum="3">

<Cell Id="B0">

  <Float>2</Float>

</Cell>

</Cycle>

Closed 画像出力フォーマット

画像出力は、ヘッダと本体の 2 つの部分で構成されます。画像出力は常にビッグエンディアン形式のバイナリです (PC はリトルエンディアンなので、アプリケーションでエンディアン形式を変換する必要があります)。In-Sight はセル A0 からデフォルトの画像を送信し、常にフル画像を送信します。ヘッダの後に本体が続きます。本体は、row0 から始まる未処理のピクセルデータです。ピクセルデータにアクセスするには、アプリケーションはヘッダの「オフセット」値を使用する必要があります。画像データは、0,0 から始まる列 - 行順のピクセルで構成されています。 グレースケールビジョンシステムの場合、ピクセルは 8 ビットのグレースケール値です。カラービジョンシステムは、3 種類の画像 (0 = グレースケール画像、1 = ベイヤー画像、4 = 24 ビットカラー画像) のいずれかを出力するようにプログラムされています。

注: 24 ビットカラーイメージはピクセル 0,0 から行単位で転送されます。各ピクセルは、3 バイト (24 ビット) により表されます。先頭ビットは青、2 つめのビットは緑、3 つめのビットは赤です。

ヘッダのフォーマット:

unsigned integer 32 bits | Length; | // length of packet including raw img // data, excluding 'Length' itself.
unsigned integer 16 bits | Offset; | // offset from 'Ver' field to the raw image pixel data.
unsigned integer 16 bits | Ver; | // version = 0.
unsigned integer 16 bits | ImgHigh,ImgWide; | // original high x wide in pixels.
unsigned integer 16 bits | Row,Col; | // row & col of upper-left corner for // this page, in original image scale.
unsigned integer 16 bits | High,Wide; | // high & wide of this page in pixel.
unsigned integer 16 bits | Rsub, Csub; | // image sub-sampling rate.
unsigned integer 16 bits | CellRow,CellCol; | // cell-coordinates for the image.0.0 for cell A0.
unsigned integer 16 bits | RowIdx,ColIdx; | // interleaved index = 0.0 (for future use).
unsigned integer 32 bits | Color; | // RGB bits - should be 0 for greyscale, 1 for Bayer or 4 for 24-bit color.
unsigned integer 32 bits | AcqSeqNum; | // Acquisition Sequence Number
unsigned integer 32 bits | Rsrvd[1]; | // reserved.
signed character 8 bits | Tag[16]; | // optional tag string - null // terminated (for future use).


SetWatch

DataChannel による通信

In-Sight 通信リファレンス

スプレッドシートが更新されると、指定された範囲のセルの値を DataChannel に送信します。

シンタックス: SetWatch(Upper-Left-Cell,Lower-Right-Cell,Mode)

注: SetWatch 関数は、[Insert Function] ダイアログ内の関数リストには表示されないため、手入力する必要があります。

SetWatchの入力パラメータ

Upper-Left-Cell

セル範囲内の左端上側のセルを指定します。

Lower-Right-Cell

セル範囲内の左端下側のセルを指定します。

Mode

スプレッドシートの更新後に DataChannel にデータを送信するタイミングを指定します。

0 = 無効 | 関数を無効にします。
1 = 変更された場合 | スプレッドシートが変更された場合にのみデータを送信します。
2 = 常時 | データを常時送信します。

SetWatchの出力

戻り値

選択した Mode の値。


EtherNet/IP による通信

EtherNet/IP による通信

In-Sight 通信リファレンス

EtherNet/IP は、Rockwell ControlLogix および CompactLogix PLC によって使用されるアプリケーションレベルのプロトコルで、Ethernet の TCP/IP 層と UDP/IP 層の最上位に実装されます。共通の CIP (Control and Information Protocol) を通じて、ControlNet および DeviceNet とオブジェクトモデルを共有しています。

このプロトコルによって、Ethernet 経由でのデータと I/O 信号の転送が可能になります。

  • 非明示的メッセージと明示的メッセージ
  • In-Sight オブジェクトモデルと入出力アセンブリオブジェクト

非明示的メッセージと明示的メッセージ

EtherNet IP を使用した通信方法には、非明示的メッセージと明示的メッセージの 2 つの方法があります。In-Sight ビジョンシステムは、任意の時点において、1 つの I/O クライアント (ホストビジョンシステムと通信する PLC デバイス) からの明示的または非明示的メッセージをサポートします。

非明示的メッセージ 明示的メッセージ
  • タイムクリティカルなアプリケーション固有の I/O データを送信し、ポイントツーポイントまたはマルチキャストが可能です。
  • UDP/IP プロトコル層を使用します。
  • データは接続時に事前定義され、これによりランタイム中のノードの処理時間が最小化されます。
  • データフィールドにはリアルタイムデータのみが格納されます。
  • 低オーバヘッドの短いメッセージで、これによりタイムクリティカルなパフォーマンスを実現します。
  • ビジョン検査におけるツールからの測定データの受信は、非明示的メッセージが適している処理の一例です。
  • 受信側デバイスからの応答を必要とし、ポイントツーポイント通信します。
  • TCP/IP プロトコル層を使用します。
  • データフィールドでサービスパフォーマンスのプロトコル情報と命令の両方を伝達するメッセージ
  • ノードでは、各メッセージを解釈し、要求されたタスクを実行し、応答を生成する必要があります。この種類のメッセージは一般に、設定、診断、およびイベントデータの送信に使用されます。
  • 頻度の低い操作により適しています。

  • In-Sight Explorer ジョブの変更命令は、明示的メッセージが適している処理の一例です。

In-Sight オブジェクトモデルと入出力アセンブリオブジェクト

In-Sight オブジェクトモデルと入出力アセンブリオブジェクトのレイアウトおよび設定は、In-Sight ファームウェアに依存しています。

  • In-Sight 4.x.x ファームウエアの場合の EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト
  • In-Sight 5.x.x ファームウエアの場合の EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト

Requested Packet Interval (RPI)

Requested Packet Interval (RPI) により、コントローラと I/O モジュールの間で周期データパケットが交換される頻度が決まり、一般にはミリ秒単位で入力されます。センサは、最初の 15 ミリ秒間に 1 ～ 15 ミリ秒間隔で RPI 値を受け入れます。RPI 値が 15 より大きい場合、センサは 5 ミリ秒の増分で値を受け入れます。16 と 20 の間の値の場合、データは 20 ミリ秒の増分で交換されます。21 と 25 の間の値の場合、データは 25 ミリ秒の増分で交換されます。

これは、4.x および 5.x のファームウェアバージョンに適用されます。
Version: 5.6.0


EDS ファイルのインストール

EtherNet/IP による通信

In-Sight 通信リファレンス

エレクトロニックデータシート (EDS) は、ネットワーク上の In-Sight ビジョンシステムを識別するために Rockwell Software の RSLinx™ などのさまざまなネットワーク構成ツールによって使用されるテキストファイルです。インストール後、EDS ファイルは適切なソフトウェアにインポートされます。

この例では、Cognex EDS ファイルと Rockwell Software の RSLinx との統合手順を示します。RSLinx 内で In-Sight センサを正しく識別するには、以下の手順を実行します。

  1. [スタート] → [すべてのプログラム] → [Rockwell Software] → [RSLinx] → [ツール] → [EDS Hardware Installation Tool (EDS ハードウェアインストールツール)] をクリックします。

  2. [追加] をクリックします。

  3. [Register a directory of EDS files (EDS ファイルのディレクトリの登録)] を選択します。次に、[参照] ボタンをクリックして、In-Sight ソフトウェアのインストールディレクトリの EDS サブディレクトリに移動します。デフォルトの場所は、次のとおりです。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\EDS。[次へ] をクリックします。

  4. [次へ] をクリックします。

  5. [次へ] をクリックします。

  6. [次へ] をクリックします。

  7. [完了] をクリックします。

  8. [終了] をクリックしてハードウェアインストールツールを終了します。
Version: 5.6.0


EIP 明示的メッセージを使用したネイティブモードコマンドの送信

EIP 明示的メッセージを使用したネイティブモードコマンドの送信 (5.x.x)

5.x.x のファームウェアが実行されている In-Sight ビジョンシステムでは、ネイティブモードコマンドを送信する目的で PLC の読み取り/書き込み MSG 命令に組み込まれる PCCC コマンドをサポートしません。5.x.x が実行されているシステムでネイティブモードコマンドを送信するには、特に CIP 汎用メッセージタイプである MSG や EEM 命令の場合を含め、EIP 明示的メッセージを使用する必要があります。これにより、In-Sight ビジョンシステムのビジョンオブジェクト (0x78) に対して、サービス属性アクセス (get/set) とオブジェクト固有サービスアクセス (SendNativeCmd) を行うことができます。

3 種類の PLC プラットフォーム用にサンプルのラダーロジックラングファイルが用意されており、以下にそれらについて説明します。このトピックの情報は、これらのサンプルファイルに固有のものです。

動作の仕組み

SendNativeCmd サービスは、ネイティブモードコマンド文字列を In-Sight ビジョンシステムに送信します。SendNativeCmd (すなわち、LFJobName.job) の要求データには、そのネイティブモードコマンド文字列が含まれています。コマンドによって文字列での結果が返された場合、その応答データにはネイティブモードコマンドの文字列も含まれています。PLC 設定は PLC プラットフォームに応じて異なります。

サンプルラダーファイルのインストール後、次のコマンドが PLC 上の文字列ファイルに保存されます。

コマンド | ST ファイルアドレス | インデックス C5:0.ACC | 説明
SO0 | ST30:0 | 0 | 強制的に In-Sight をオフラインにする
GO | ST30:1 | 1 | オンラインにする ("0" を返す)
TFJobName-Stored.job | ST30:2 | 2 | ロードされたジョブが "JobName-Stored.job" という名前でフラッシュに保存され、アクティブジョブになる。このジョブにより、In-Sight Explorer でリフレッシュされると、ファイルリストが表示される。
GF | ST30:3 | 3 | アクティブジョブのファイル名 ("JobName-Stored.job") を返す。
LFJobName.job | ST30:4 | 4 | 前バージョンのジョブをロードする。
SO1 | ST30:5 | 5 | 強制的にオンラインにする (In-Sight Explorer に「オンライン」ステータスが表示される)
GO | ST30:6 | 6 | オンラインにする (1 を返す)

3 種類すべての PLC プラットフォームについて:

  • In-Sight ビジョンシステムに対する、そのインデックスと関連付けられたコマンドによるロジックインデックス。
  • すべてのサンプルの最初のラングで CopyNMCmdToSend ビットがセットされると、インデックスで保存されたネイティブモードコマンドが文字列ファイル (ST30) に書き込まれます。
  • コマンド文字列をコピーした後は、ビットがアンラッチされ、コマンド (MSG/EEM) が送信されます。ネイティブモードコマンドが応答を返す場合は、結果の文字列が返されます。命令が終了すると、文字列ファイルの要素インデックス (C5:0) が増分されます。
  • ラング 0 の CopyNMCmdToSend ビットが再びセットされ、次のネイティブモードコマンドが送信されます。
  • C5:0 インデックスは 7 (7 つのネイティブモードコマンドが送信されたことを意味する (インデックス 0 ～ 6)) に達するたびに増分されます。その後このインデックスは 0 にリセットされます。

PLC プラットフォームに固有の情報については、サンプルのラダーロジックラングファイルについてを参照してください。

サンプルの PLC ラダーロジックラングファイルのインストールと設定

サンプルのラダーロジックラングファイルは、以下の場所にあります。

  • In-Sight Explorer のインストールフォルダ: <In-Sight install folder> /Factory Protocol Description
  • Cognex テクニカルサポート Web サイト: https://support.cognex.com/en/downloads/detail/3551/1033/11。
  1. サンプルラングファイルを適切な場所にダウンロードしてコピーします。
  2. ご使用の PLC プラットフォームに関係する以下の指示に従います。
MicroLogix 1100 または SLC5/05 ControlLogix または CompactLogix
  1. RSLogix 500 で、新規または既存のプロジェクト (.RSS ファイル) を開きます。
  2. [Channel Configuration (チャネル設定)] ダイアログで、コントローラの [IP アドレス] と [サブネットマスク] を含め、チャネル 1 のイーサネット設定を行います。
  3. オフラインの間に、ラダーエディタでラングを右クリックし、[Paste from Library (ライブラリから貼り付け)] を選択します。
  4. サンプルラングファイルをコピーしたフォルダを参照します。SLC5/051100 を使用する場合は、[NativeModeCmds-ML1100.SLC] を選択します。MicroLogix 1100 を使用する場合は、[NativeModeCmds-ML1100.SLC] を選択します。
    [開く] をクリックします。[Import Configuration (設定のインポート)] ダイアログボックスが開きます。
  5. 新規プロジェクトの場合は、デフォルトの設定を使用します。既存プロジェクトの場合は、[ヘルプ] をクリックし、プロジェクトに適切な設定について調べます。
    終了したら、[OK] をクリックします。ラダーエディタには 3 つのラングが追加されます。
  6. ラング 2 で、MSG 命令の [Setup Screen (設定画面)] を開きます。[MultiHop] タブで、In-Sight ビジョンシステムの IP アドレスを入力します。
  7. ラングを有効性を確認するには、[編集] → [Verify File (ファイルの検証)] を選択します。エラーが検出されない場合は、ウィンドウ下部のステータスバーに次のメッセージが表示されます。「Verify has completed, no errors found. (検証が終了しました。エラーは見つかりませんでした。)」
    エラーが見つかった場合は、そのエラーを修正して再検証します。
  8. プロジェクトをダウンロードし、[PLC] を [Run Mode (実行モード)] にします。

  1. RSLogix 5000 で、新規または既存のプロジェクト (.ACD ファイル) を開きます。
  2. [イーサネット] ノードで、使用する In-Sight ビジョンシステムを追加します。
  3. オフラインの間に、ラダーエディタでラングを右クリックし、[Import Rungs (ラングのインポート)] を選択します。
  4. サンプルラングファイルをコピーしたフォルダを参照します。[NativeModeCmds-CLgx.L5X] を選択し、[開く] をクリックします。[Import Configuration (設定のインポート)] ダイアログボックスが開きます。
  5. [OK] をクリックします。ラダーエディタには 3 つのラングが追加されます。
  6. ラング 1 で、MSG 命令の楕円ボタンをクリックします。[Message Configuration (メッセージ設定)] ダイアログボックスが開きます。
  7. [通信] タブを選択します。
  8. Path フィールドで [参照] ボタンを選択して、[I/O Configuration (I/O 設定)] ツリーで自分の In-Sight ビジョンシステムを選択します。[OK] をクリックします。
  9. プロジェクトをダウンロードし、[PLC] を [Run Mode (実行モード)] にします。

    • サンプルのラダーロジックラングファイルについて

    以下に、PLC プラットフォーム別に整理して各ラングのロジックフローについての説明を示します。

    MicroLogix 1100

    ラング ロジックフローの説明

    0

    サマリ:

    このラングは、インデックス C5:0 に基づいて、ST30:0 ～ ST30:6 に保存されているネイティブモードコマンドの文字列を共通の場所である ST30:9 にコピーします。

    詳細:

    • ユーザが B3:0/1 ビット (CopyNMCmdToSend) をセットし、インデックスが増分されるたびに、それぞれインデックス (C5:0 ～ C5:6) に基づいて、その次のコマンドが文字列の共通の保存場所にコピーされます。COP 命令では、ファイル操作であるため、インデックスアドレス指定 (#) が使用されます。
    • 最後に、正しい COP 命令が実行されると、B3:0/1 ビットがアンラッチされ、B3:0/11 ビット (CopyNMCmdToCommonString) がセットされます。

    1

    サマリ:

    このラングにより、現在選択されているネイティブモードコマンド (一度に 2 つの ASCII 値) が整数 (N13) にコピーされ、整数ファイル内でバイトがスワップされます。

    詳細:

    • B3:0/11 ビット (CopyNMCmdToCommonString) がセットされるため、ST30:9.LEN (ネイティブモードコマンド文字列の長さ) が (MOV 命令を使用して) MSG 制御の MG12:0 制御ファイルの .ELE 要素にコピーされます。これにより、MSG 命令のバイトサイズ (送信) のバイト数が設定されます。この処理は、短いコマンドがコマンド文字列と一緒に送信される (S01) 場合に、確実に正しいデータが送信されるようにするために行われます。

    • ネイティブモードコマンドの文字列データが (MOV 命令を使用して) 一度に 2 バイトずつ、ワード 10 (N13:10) から始めて N13 ファイルに ASCII 文字としてコピーされます。この処理が必要なのは、MicroLogix 1100 では N ファイルタイプを使用する場合にのみ文字列データを送受信できるからです。コマンドの文字列長さがチェックされ、文字列内の正しいバイト数のみが N13 ワードにコピーされます。
    • コマンド文字列の全体がコピーされると、インデックス付きアドレス指定を使用して、N13 のすべてのワードが N13:10 から始めてバイトスワップされます。Length フィールドは一定にする必要があるため、ネイティブモードコマンド文字列の長さの半分と同じかそれ以上の長さにする必要があります (N13 ワードあたり 2 バイトのため)。例えば、最長文字列が 24 バイトの場合、長さは 12 ワード以上にする必要があります。
    • 次のラングで使用するため、B3:0/0 ビット (Send_NMCmd) がラッチされます。これが必要なのは、MSG 命令は数回のスキャンにおいて実行され、ビットがラッチされていないと有効ではなくなるからです。

    2

    サマリ:

    このラングは、2 つの MSG 命令のどちらかを使用してネイティブモードコマンドを送信し、

    1 が返された場合には結果ファイル (N11:0) をクリアして応答を保存します。

    詳細:

    • 最初の MSG 命令は、応答を返さないネイティブモードコマンドを送信するか、または偶数バイトの応答を送信するために使用されます。2 番目の MSG 命令は、応答データの 1 バイトのみを返すコマンドとして使用されます。

      注: MSG 命令に奇数バイトが含まれていると、MicroLogix ファームウェアで問題が発生します。In-Sight ビジョンシステムが奇数バイトで応答し、MicroLogix のセットアップで入力した [Size in Bytes (バイトサイズ] (受信) が偶数であるか、または数バイト長い場合、最後の奇数バイトは応答で返されません。[Size in Bytes (バイトサイズ)] は、期待される正確なバイト数に設定する必要があります。

      例えば、Get File コマンド (GF) を送信し、名前の長さが 15 文字のジョブが返されても、[Size in Bytes (バイトサイズ)] が 16 バイト以上に設定されている場合には、名前から "b" が欠落した状態でジョブ名が返されます。この状態は、1 バイトを返す Get Online コマンド (GO) の場合にも発生します。1 つの MSG 命令を 2 バイト以上に設定した場合、応答にバイトは含まれません。これが、2 つの MSG 命令が必要とされる理由です。つまり、MSG 命令は、ネイティブモードコマンドで使用されるインデックスに基づいて条件付きで実行するように設計されています。

    3

    サマリ:

    コマンドを送信すると、(返された場合には) 結果の文字列が N11 ファイルに保存され、読み取りやすいようにバイトがスワップされます。ネイティブモードコマンドを変更するためのインデックスも、7 に達するまで増分され、その後にリセットされます。

    詳細:

    • ラング 2 の MSG 命令の一方が完了し、インデックスが 3 になると、各ワードで受信データテーブルアドレス (N11) のバイトがスワップされ、ジョブ名の文字列が正しいバイト順になって読み取りやすくなります。
    • インデックスが増分され (CS5:0 カウンタで 0 ～ 6 の範囲)、すべてのコマンドが送信されると自動的に 0 にリセットされます。
    • Bit B3:0/0 ビットがアンラッチされ、ネイティブモードコマンドのサイクルが終了します。
    注: 必要に応じて、ラング 1 に似たラングを記述し、N11 ワード内の結果の文字列を共通の文字列ファイル (ST) 要素にコピーして、ロジックを見やすくて使いやすくすることができます。

    SLC 5/05

    ラング ロジックフローの説明

    0

    サマリ:

    このラングは、インデックス C5:0 に基づいて、ST30:0 ～ ST30:6 に保存されているネイティブモードコマンドの文字列を

    共通の場所である ST30:9 にコピーします。ユーザが B3:0/1 ビット (CopyNMCmdToSend) をセットし、インデックスが増分されるたびに、その次のコマンドが文字列の共通の保存場所にコピーされます。現在選択されているネイティブモードコマンドが整数ファイル (N7) にコピーされ、その後整数ファイル内でバイトスワップされます。

    詳細:

    • B3:0/1 ビットがセットされて、最初のネイティブモードコマンドが送信されます。このコマンドは次に、N7 ファイルのワード 10 (N7:10) から始まる共通の文字列の場所 ST60:9 にコピーされます。この処理が行われるのは、EEM 命令で文字列を送信することができないからです。文字列は間接的なインデックス付きアドレス指定を使用してコピーされるため、文字列構造 (LEN および DATA) は長さ 25 ワードで N7 にコピーされます。
    • N7:11 から始めて、N7 ファイルの各ワード内で 24 ワードがスワップされます (合計 48 バイト)。
    • B3:0/1 ビットがアンラッチされ、残りのラングの B3:0/0 ビットがラッチされます。

    1

    サマリ:

    このラングでは、ネイティブモードコマンドを含んだ EEM 命令 (EtherNet/IP 明示的メッセージ) が送信され、返された場合には応答を保存します。

    詳細:

    • B3:0/0 ビットがセットされて、EEM 命令が実行されます。ASCII データの 24 ワード (48 バイト) はネイティブモードコマンドを使用して書き込まれます。
    • コマンドの実行後にデータを受信すると、24 ワード (48 バイト) まではワード 1 (N717:1) から始めて N17 整数ファイルに保存されます。受信サイズは 24 ワードに設定され、実際の応答データを越えるデータは null 値になります。データを何も受信しない場合、N17:1 ～ N17:24 は null 値になります。

    2

    サマリ:

    ラング 1 の EEM 命令が終了すると、ネイティブモードコマンドの結果文字列と長さが N17 整数ファイルから ST30:10 結果文字列要素にコピーされます。ネイティブモードコマンドを変更するためのインデックスも、7 に達するまで増分され、その後にリセットされます。

    詳細:

    • DN ビットがセットされ、受信したバイト長さ (N59:4) が N17:0 内に移動されます。
    • 応答バイトが変換されるのは、インデックス 3 (Get File) のみが 1 バイトより長い文字列を返すため、N17 ファイルでワード 1 (N17:1) から始めてバイトをスワップする必要があるからです。この例では、N 17 ファイル内の 24 ワードがスワップされ、合計で 48 バイトになります。

      注: SWP 命令では、Length パラメータを定数でしか設定できないため、24 ワードが使用されていました。これは、このサンプルで返される文字列にとって必要以上の長さです。

    • N17 ファイル内の 25 ワードが、インデックス付きでアドレス指定された 1 つの COP 命令を使用して文字列 (ST30:10) にコピーされます。この方法は、2 つの命令を使用して一度に 2 バイトをコピーするよりも優れています。

    • カウンタインデックスは、最後のインデックス (6) に達するまで増分され、その後カウンターは 0 にリセットされます。

    • B3:0/0 ビットがアンラッチされます。

    ControlLogix/CompactLogix

    ラング ロジックフローの説明

    0

    サマリ:

    このラングは、文字列配列から文字列タグ SendNM_Cmd にネイティブモードコマンドと長さをコピーします。

    詳細:

    • CopyNMCmdToSend ビットがセットされます。
    • ネイティブモードコマンドは、共通の文字列の場所 (SendNM_Cmd) と要求長さの MSG 制御ブロック (msg_NMCmd) にコピーされます。
    • カウンタ (NMCmdIndx.ACC) をコマンドを保持している文字列配列 (NativeModeCmds) 内のインデックスとして使用して、文字列の ASCII 文字が共通の文字列の場所にコピーされます。(共通の文字列タグデータは MSG ソース要素で使用されます。)

    • CopyNMCmdToSend ビットがアンラッチされます。

    • 残りのラングで使用するため、send_NMCmd ビットがラッチされます。

    1

    サマリ: MSG 命令を使用してネイティブモードコマンドが送信され、返された場合には応答文字列が保存されます。

    詳細:

    • MSG 命令が有効にされます。ネイティブモードコマンドによって応答文字列が返される場合、そのデータは文字列 NM_Cmd_ResultString タグに保存されます。

    2

    サマリ: MSG が終了すると、ネイティブモードコマンドの結果の文字列長さが MSG で受信した長さに従って設定されます。ネイティブモードコマンドを変更するためのインデックスも、7 に達するまで増分され、その後リセットされます。

    詳細:

    • MSG が完了すると (DN ビットをセット)、受信したデータの長さ (受信した場合) が NMCmd_ResultString.LEN にコピーされます。これにより、長さが 82 バイト以内であれば、結果の文字列の終わりに邪魔な "$00" 文字が表示されなくなり、結果の文字列が読み取りやすくなります。NMCmdIndx カウントが 1 増分されます。

    • 7 つのコマンドが送信されると、NMCmdIndx カウントインデックスが 0 にリセットされます。
    • Send_NMCmd ビットがアンラッチされてサイクルが完了します。


Rockwell ControlLogix PLC　との通信

EtherNet/IP による通信

In-Sight 通信リファレンス

このセクションでは、Rockwell RSLogix 5000 ソフトウェアを使用して、EtherNet/IP ネットワーク上で In-Sight 2000 ビジョンシステムと ControlLogix または CompactLogix PLC の間のデータ送信を行う方法を説明します。

  • RSLogix 5000 との統合
  • EDS 生成プロファイルまたはアドオンプロファイル (AOP)

RSLogix 5000 との統合

非明示的接続の設定およびデータの送受信手順は、ビジョンシステムにインストールされている In-Sight ファームウェアバージョンと RSLogix 5000 ソフトウェアのバージョンによって異なります。

RSLogix 5000、バージョン 15 以降、アドオンプロファイル (AOP) バージョン 1.28 の使用

注: プロファイルのアドオンプロファイル (AOP) バージョン 1.28 を使用するには、まず RSLogix 5000 バージョン 15 以降をインストールする必要があります。このパージョンでは、次世代モデル (In-Sight 2000 シリーズのビジョンセンサ、In-Sight 57xx、In-Sight 8000 および In-Sight 76xx ～ 79xx シリーズのビジョンシステム) とともにレガシー In-Sight モデルに対して、AOP サポートを提供します。

RSLogix 5000、バージョン 15 ～ 19

RSLogix 5000、バージョン 20 以降、汎用または EDS 生成プロファイルを使用:

EDS 生成プロファイルまたはアドオンプロファイル (AOP)

EDS 生成プロファイル

エレクトロニックデータシート (EDS) は、ネットワーク上の In-Sight ビジョンシステムを識別するためにさまざまなネットワーク構成ツールによって使用されるテキストファイルです。任意の EtherNet/IP デバイスで EDS ファイルを使用できます。

In-Sight EDS ファイルは、In-Sight Explorer ソフトウェアとともに Factory Protocol Files フォルダにインストールされます。

インストール後、EDS ファイルは適切なソフトウェアにインポートされます。EDS または汎用モジュールの使用に関する詳細については、EDS 生成プロファイルを使用した接続の確立または汎用 ETHERNET-MODULE を使用した接続の確立を参照してください。

EDS のインストール情報については、「EDS ファイルのインストール」を参照してください。

アドオンプロファイル (AOP)

RSLogix 5000 ソフトウェアではアドオンプロファイル (AOP) を使用することができ、AOP により、Rockwell ControlLogix および CompactLogix PLC と通信するように EtherNet/IP が有効なデバイスを設定することができます。アドオンプロファイル (AOP) のユーザインタフェースにより、あらゆるチェック機能を使用して設定およびステータスデータに列挙された方法でアクセスできます。入力されたデータは、検証されて、選択が正しくて必要なセットアップと一貫性があることが確認されます。アドオンプロファイル (AOP) では、I/O および設定データの構造を認識し、RSLogix5000 でデバイスに割り当てられた名前を使用してタグを作成します。データを視覚的に区別するためにタグが完全に列挙され、すべてのデータがタグ名を使用して選択可能になります。

In-Sight アドオンプロファイル (AOP) のインストーラは、In-Sight のサポートサイトから入手できます。現行バージョンの 1.28 では、新しい次世代モデル (In-Sight シリーズのビジョンセンサ、In-Sight 8000 および In-Sight 76xx ～ 79xx シリーズのビジョンシステム) を含むすべての In-Sight ビジョンシステムがサポートされています。

詳細については、「アドオンプロファイル (AOP) のインストール」を参照してください。

注:

  • アドオンプロファイル (AOP) では、In-Sight 2000 シリーズのビジョンセンサ、In-Sight 57xx、In-Sight 76xx ～ 79xx、In-Sight 8000 シリーズのビジョンセンサのメジャーリビジョン 11、およびすべてのレガシーモデル (In-Sight 1000、In-Sight 5000 および In-Sight 70xx ～ 74xx) のメジャーリビジョン 12 がインストールされます。
  • アドオンプロファイル (AOP) バージョン 1.28 のメジャーリビジョン 12 は、レガシーモデルの TestRun ビットをサポートしています。
  • アドオンプロファイル (AOP) がインストールされている場合、In-Sight ビジョンシステムでは、EDS 生成のプロファイルが非表示にされます。
  • 最新の In-Sight アドオンプロファイル (AOP) には、以前のリビジョンからのコンテンツがすべて含まれており、既存のアプリケーションとの互換性は失われませんが、接続が確立されるかどうかは、アドオンプロファイル (AOP) の Major Revision フィールドに関連付けられています。
Version: 5.6.0


EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト - In-Sight 4.x.x ファームウェア

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

このトピックでは、In-Sight 4.x.x 以前のファームウェアが実行されている In-Sight ビジョンシステムの In-Sight オブジェクトモデルについて説明します。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  • In-Sight オブジェクトモデル
  • 入出力アセンブリオブジェクト

  • In-Sight 4.x.x ファームウェアのアップグレード時の入出力アセンブリの変更

  • ビジョンオブジェクトの属性
  • ビジョンオブジェクトのサービス
  • EtherNet/IP の関数
  • EtherNet/IP による通信

In-Sight オブジェクトモデル

EtherNet/IP ネットワークでは、In-Sight ビジョンシステムはサーバとして機能し、明示的および非明示的 I/O メッセージングの両方をサポートします。例えば、検査データを、明示的メッセージによって、または非明示的接続によって、クライアントに転送することができます。非明示的な接続は、画像取り込み、トリガ、およびスプレッドシートのイベントの制御に使用することもできます。

識別オブジェクト、Ethernet リンクオブジェクト、TCP/IP オブジェクト、およびそのほかの内部オブジェクトは、EtherNet/IP 仕様によって必須とされています。アセンブリオブジェクトのさまざまなインスタンスは、EtherNet/IP クライアントとアプリケーションデータを交換するために使用されます。ビジョンオブジェクトは、In-Sight ビジョンシステムに固有の情報を提供するために、In-Sight システムによって定義されます。これがどのように行われるかという詳細については、「ビジョンオブジェクトの属性とサービス」の節を参照してください。In-Sight ビジョンシステムによって提供される現在のオブジェクトモデルを下の図に示します。

  • アセンブリオブジェクト: アセンブリオブジェクトは、複数のオブジェクトの属性をバインドして、各オブジェクト間でのデータの送受信を 1 つの接続でできるようにします。アセンブリオブジェクトを使用すると、入力データまたは出力データをバインドすることができます。「入力」と「出力」という用語は、ネットワーク側から見た定義です。「入力」はネットワーク上にデータを生成し、「出力」はネットワークからデータを消費します。
  • 識別オブジェクト: このオブジェクトは、デバイスの識別情報とデバイスに関する全般情報を提供します。
  • Ethernet リンクオブジェクト: Ethernet リンクオブジェクトは、Ethernet 802.3 通信インタフェースについて、リンク固有のカウンタとステータス情報を保持します。
  • TCP/IP オブジェクト: TCP/IP オブジェクトは、デバイスの TCP/IP ネットワークインタフェース設定を照会 (可能な場合は設定も) するメカニズムを提供します。該当する項目の例としては、デバイスの IP アドレス、ネットワークマスク、ゲートウェイアドレスなどがあります。
  • ビジョンオブジェクト: ビジョンオブジェクトには、In-Sight ビジョンシステム固有のすべてのサービスと属性が含まれます。これには、画像取り込み、検査、ジョブの変更、および In-Sight Explorer スプレッドシートとの通信などが含まれます。

入出力アセンブリオブジェクト

入出力データの I/O アセンブリデータ属性の形式は、次のとおりです。

ファームウェアのバージョン | 入力アセンブリインスタンス | 出力アセンブリインスタンス
4.1.0 ～ 4.7.4 | 11 | 21
4.8.0 ～ 4.9.x | 12 | 21
4.10.x | 12 | 21
注:
  • Job Pass ブロック、Exposure Complete ブロックおよび Current Job ID (16 ビット整数) ブロックを含む入力アセンブリインスタンス 12 を使用する場合は、メジャーリビジョン 10 の In-Sight アドオンプロファイル (AOP) が RSLogix とともに PC にインストールされている必要があります。
  • EDS で作成されたプロファイルを使用する場合、入力アセンブリの最大サイズが 500 バイトであっても、EDS で作成されたプロファイルは最大 496 バイトの接続しか許可しません。
  • Rockwell RSLogix Studio 5000 バージョン 21 ～ 25 を使用している場合、In-Sight EDS で作成されたプロファイルのデフォルト入出力アセンブリサイズ (各 496 バイト) は編集できず、デフォルトの最大の入出力アセンブリサイズに戻されます。
  • Acquisition ID は画像取り込みの終了時に増加し、画像とともに検査サブシステムに移動します。検査が完了する前に、RPI に応じて PLC で更新することができます。Inspection ID は、Inspection Completed ビットがトグルするときに増分されます (このとき、Results Valid は high に設定され、Inspecting ビットは low に設定されます)。
  • In-Sight ファームウェアを In-Sight 4.9.x から 4.10.x にアップグレードする場合の入出力アセンブリテーブル間の違いについては、「入出力アセンブリの変更」のトピックを参照してください。

Closed I/O アセンブリデータ属性の形式 - In-Sight ファームウェアバージョン 4.10.x

入力アセンブリ　‐ インスタンス 12

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
12 | 0 | Online | Offline Reason |  |  | Missed Acq | Acquiring | Trigger Ack | Trigger Ready
 | 1 | Reserved | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | Inspecting
 | 2 | Reserved
 | 3 | Reserved |  | Test Run Ready | Job Pass | Exposure Complete | Reserved
 | 4 | Current Job ID (16 ビット整数)
 | 5
 | 6 | Acquisition ID (16 ビット整数)
 | 7
 | 8 | Inspection ID (16 ビット整数)
 | 9
 | 10 | Inspection Result Code (16 ビット整数)
 | 11
 | 12 | Inspection Results 0
 | ... |
 | 499 | Inspection Results 487

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6 ～ 4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 | Missed Acq | 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。
2 | Acquiring | Trigger ビットのセットによって、または外部ハードウェアトリガによって、In-Sight ビジョンシステムが画像を取り込み中であるときにセットされます。
1 | Trigger Ack | In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。
0 Trigger Ready

In-Sight ビジョンシステムが新しいトリガを受け入れられることを示します。このビットは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、ビジョンシステムが画像の取り込み中でないときに高くなります。

注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。

バイト 1

ビット | 名前 | 説明
7 | Reserved | 未使用。
6 | Command Failed (4.10.x) | このビットは 1 にセットされ、TestRun 実行または [ジョブを開く] を最後まで実行することに失敗したことが示されます。TestRun シーケンスが実行されるか、PLC/HMI によって新規のジョブがロードされるとクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。
5 | Command Completed (4.10.x) | このビットは、TestRun 実行または [ジョブを開く] が完了したことを示すためにトグルされます。 注: TestRun を設定せずにジョブで TestRun を実行しようとすると、CommandCompleted がトグルされ、CommandFailed がセットされます。TestRun は、TestRunReady がセットされていない場合には実行されません。
4 | Command Executing (4.10.x) | このビットは、TestRun または [ジョブを開く] が開始されると 1 にセットされます。TestRun 実行が完了するとクリアされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 | Results Valid | Inspection ID、Inspection Result、および Inspection Results フィールドが有効なときにセットされます。 注: このビットは、検査結果の読み取り準備ができていることを示します。
2 | Results Buffer Overrun | このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。 注: このビットは、Buffer Results Enable ビットが有効化/セットされていない場合に結果の読み取り準備ができていることを示します。
0 | Inspecting | このビットは、In-Sight ビジョンシステムがスプレッドシート関数を実行しているときにセットされます。

バイト 2

名前 | 説明
Reserved | 未使用。

バイト 3

ビット | 名前 | 説明
7 ～ 6 | Reserved | 未使用。
5 TestRun Ready (4.10.x)

このビットは、ビジョンシステムの TestRun 設定が有効な場合に 1 にセットされます。この信号は、TestRun の実行中に (TestRun イニシエータに関係なく) クリアされ、実行完了後に 1 に戻ります。

注:

  • このビットは、ビジョンシステムがオンラインかオフラインかどうかに関係なく信号として送信されます。

  • 外部デバイスによる TestRun の開始は、In-Sight ファームウェア 5.1.0 ～ 5.5.x が実行されているビジョンシステムではサポートされません。
4 Job Pass このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。

注:このビットを使用するには、メジャーリビジョン 10 以上を使用します。
3 Exposure Complete このビットは、In-Sight ビジョンシステムが露光完了すると High となり、画像取り込みトリガが与えられると Low となります。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。

注:このビットを使用するには、メジャーリビジョン 10 以上を使用します。
2 ～ 0 | Reserved | 未使用。

バイト 4 ～ 5

名前 | 説明
Current Job ID (16 ビット整数) | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 6 ～ 7

名前 | 説明
Acquisition ID (16 ビット整数) | この ID は、トリガソースに関係なく各画像取り込みが完了すると増分され、Acquisition とその Inspection Results を同期化するために使用できます。

バイト 8 ～ 9

名前 | 説明
Inspection ID (16 ビット整数) | この結果セットに関連付けられている取り込み ID。この値は、各検査サイクルの新しい結果が到着するたびに増加します。

バイト 10 ～ 11

名前 説明
Inspection Result Code (16 ビット整数) (4.10.x)

TestRun の最新の実行結果を示します。すべてのテストに合格すると、ビット 0 がセットされます。不合格のテストがあった場合、または TestRun を実行している間のセットアップまたはクリーンアップに問題があった場合、ビット 0 はクリアされます。

  • このフィールドは、TestRun が正常に実行された後にのみ有効になります。
  • このフィールドの結果は、TestRun なしのジョブがロードされた場合、別の TestRun ジョブが実行された場合、TestRun が進行中の場合、TestRun またはジョブが失敗した場合、または TestRun が中止された場合には無効化されることがあります。
  • ビジョンシステムが現在オンラインに設定されている場合、このフィールドの内容はスプレッドシートによって出力され、TestRun に関する意味はありません。

バイト 12 ～ 499

名前 説明
Inspection Results (0 ～ 487)

[スプレッドシートビュー] の WriteEIPBuffer 関数、または EasyBuilder GUI の [通信] の手順での [フォーマット出力データ] タブを介して In-Sight Explorer から書き込まれるデータです。

送信されるデータは、In-Sight Explorer GUI での表示どおりに書き込まれ、FormatOutputBuffer 関数 (スプレッドシート) または [フォーマット出力データ] タブ (EasyBuilder) で定義される順序と同じ順序で表示されます。

注: RSLogix 5000 は Inspection Results データアレイを受信すると、送信されたデータに複数のデータ型が含まれている (つまり、フォーマットされたデータに整数、浮動小数点、ビットが含まれている) かどうかに関係なく、1 つのデータ型をアレイ全体に割り当てます。したがって、送信されているデータにさまざまなデータ型が含まれる場合は、特定の結果 (最初に Inspection Results アレイのバイトオフセット、次にバイト単位の長さ) を、送信されているデータ型の予測を基に RSLogix の User-Defined Data Type にコピーします。詳細については、「例: In-Sight ビジョンシステムからの浮動小数点数値データの取得」を参照してください。

出力アセンブリ - インスタンス 21

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
21 | 0 | Force Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 2 | Command
 | 3
 | 4 | User Data 0
 | ... |
 | 495 | User Data 491

バイト 0

ビット | 名前 | 説明
7 Force Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6 ～ 5 | Reserved | 未使用。
4 | Execute Command (4.10.x) | セットされている場合、ビジョンシステムは Command フィールドで指定されているジョブ ID をロードします。TestRun を使用する場合は、この信号の立ち上がりエッジでコマンドが実行されて TestRun が開始されます。この信号は、Command Completed 信号がトグルされるまで high を維持する必要があります。この信号の立ち下がりエッジ (Command Complete の前) は、中止要求と解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。
2 | Buffer Results Enable | このビットをセットすると、ResultsValid ビットがセットされている間は、Inspection ID、Inspection Results および Inspection Results の各フィールドが一定に保たれます。Inspection Results Ack ビットをセットしてそれらのフィールドについて確認応答します。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって確認応答に応答します。Inspection Results Ack フィールドがクリアされると、Results Valid は、新しい結果が PLC に送信されるまでクリアされままになります。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。

  • AcquireImage 関数の Trigger パラメータが、ネットワーク、外部、または産業用イーサネットに設定されます。

    注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。
0 | Trigger Enable | このフィールドがセットされると、Trigger ビットによるトリガが有効になります。このフィールドをクリアすると、EtherNet/IP トリガメカニズムは無効になります。このビットは Ethernet/IP 経由で実行されるトリガにのみ影響し、その他のトリガモードにはまったく影響しません。

バイト 1

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 2 ～ 3

バイト | 名前 | 説明
2 ～ 3 | Command (4.10.x) | (missing or bad snippet)

バイト 4 ～ 495

バイト | 名前 | 説明
4 -495 | User Data (0 ～ 491) | このデータは、ReadEIPBuffer 関数によって In-Sight Explorer スプレッドシートに送信されます。バッファは、PLC の表示どおりに書き込まれ、ビットは、RSLogix 5000 の定義と同じ順序で表示されます。

Closed I/O アセンブリデータ属性の形式 - In-Sight ファームウェアバージョン 4.8.0 ～ 4.9.x

入力アセンブリ　‐ インスタンス 12

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
12 | 0 | Online | Offline Reason |  |  | Missed Acq | Acquiring | Trigger Ack | Trigger Ready
 | 1 | Reserved | Job Load Failed | Job Load Completed | Job Loading | Results Valid | Results Buffer Overrun | Inspection Completed | Inspecting
 | 2 | Reserved
 | 3 | Reserved |  |  | Job Pass | Exposure Complete | Reserved
 | 4 | Current Job ID (16 ビット整数)
 | 5
 | 6 | Acquisition ID (16 ビット整数)
 | 7
 | 8 | Inspection ID (16 ビット整数)
 | 9
 | 10 | Inspection Result (16 ビット整数)
 | 11
 | 12 | Inspection Results 0
 | ... |
 | 499 | Inspection Results 487

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6 ～ 4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 | Missed Acq | 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。
2 | Acquiring | Trigger ビットのセットによって、または外部ハードウェアトリガによって、In-Sight ビジョンシステムが画像を取り込み中であるときにセットされます。
1 | Trigger Ack | In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。
0 | Trigger Ready | In-Sight ビジョンシステムが新しいトリガを受け入れられることを示します。このビットは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、ビジョンシステムが画像の取り込み中でないときに高くなります。

バイト 1

ビット | 名前 | 説明
7 | Reserved | 未使用。
6 | Job Load Failed | このビットは、ジョブのロードの最後の試みが失敗したときにセットされます。次にジョブのロードが成功したときにクリアされます。 注: このビットは、EtherNet/IP を使用する PLC によってジョブのロードが開始された場合にのみ機能します。
5 | Job Load Completed | このビットは、ジョブロード操作の完了時にトグルされます。 注: このビットは、EtherNet/IP を使用する PLC によってジョブのロードが開始された場合にのみ機能します。
4 | Job Loading | このビットは、新規ジョブをロードするときにセットされます。 注: このビットは、EtherNet/IP を使用する PLC によってジョブのロードが開始された場合にのみ機能します。
3 | Results Valid | Inspection ID、Inspection Result、および Inspection Results フィールドが有効なときにセットされます。 注: このビットは、検査結果の読み取り準備ができていることを示します。
2 | Results Buffer Overrun | このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。 注: このビットは、Buffer Results Enable ビットが有効化/セットされていない場合に結果の読み取り準備ができていることを示します。
0 | Inspecting | このビットは、In-Sight ビジョンシステムがスプレッドシート関数を実行しているときにセットされます。

バイト 2

名前 | 説明
Reserved | 未使用。

バイト 3

ビット | 名前 | 説明
7 ～ 6 | Reserved | 未使用。
5 | Reserved | 未使用。
4 | Job Pass | このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。 注:このビットを使用するには、メジャーリビジョン 10 以上を使用します。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了すると High となり、画像取り込みトリガが与えられると Low となります。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。 注:このビットを使用するには、メジャーリビジョン 10 以上を使用します。
2 ～ 0 | Reserved | 未使用。

バイト 4 ～ 5

名前 | 説明
Current Job ID (16 ビット整数) | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 6 ～ 7

名前 | 説明
Acquisition ID (16 ビット整数) | この ID は、トリガソースに関係なく各画像取り込みが完了すると増分され、Acquisition とその Inspection Results を同期化するために使用できます。

バイト 8 ～ 9

名前 | 説明
Inspection ID (16 ビット整数) | この結果セットに関連付けられている取り込み ID。この値は、各検査サイクルの新しい結果が到着するたびに増加します。

バイト 10 ～ 11

名前 | 説明
Inspection Result (16 ビット整数) | この結果セットに関連付けられている成功/失敗コード。この値を設定することはできず、常に 0 です。

バイト 12 ～ 499

名前 説明
Inspection Results (0 ～ 487)

[スプレッドシートビュー] の WriteEIPBuffer 関数、または EasyBuilder GUI の [通信] の手順での [フォーマット出力データ] タブを介して In-Sight Explorer から書き込まれるデータです。

送信されるデータは、In-Sight Explorer GUI での表示どおりに書き込まれ、FormatOutputBuffer 関数 (スプレッドシート) または [フォーマット出力データ] タブ (EasyBuilder) で定義される順序と同じ順序で表示されます。

注: RSLogix 5000 は Inspection Results データアレイを受信すると、送信されたデータに複数のデータ型が含まれている (つまり、フォーマットされたデータに整数、浮動小数点、ビットが含まれている) かどうかに関係なく、1 つのデータ型をアレイ全体に割り当てます。したがって、送信されているデータにさまざまなデータ型が含まれる場合は、特定の結果 (最初に Inspection Results アレイのバイトオフセット、次にバイト単位の長さ) を、送信されているデータ型の予測を基に RSLogix の User-Defined Data Type にコピーします。詳細については、「例: In-Sight ビジョンシステムからの浮動小数点数値データの取得」を参照してください。

出力アセンブリ - インスタンス 21

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
21 | 0 | Force Offline | Reserved | Reserved | Initiate Job Load | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 2 | Job Load ID
 | 3
 | 4 | User Data 0
 | ... |
 | 495 | User Data 491

バイト 0

ビット | 名前 | 説明
7 Force Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6 ～ 5 | Reserved | 未使用。
4 Initiate
Job
Load (4.9.x 以上) 		セットされると、ビジョンシステムは Job Load ID フィールドで指定したジョブ ID をロードします。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。
2 | Buffer Results Enable (結果バッファ有効) | このビットをセットすると、ResultsValid ビットがセットされている間は、Inspection ID、Inspection Results および Inspection Results の各フィールドが一定に保たれます。Inspection Results Ack ビットをセットしてそれらのフィールドについて確認応答します。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack フィールドがクリアされると、Results Valid は、新しい結果が PLC に送信されるまでクリアされままになります。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されている。
0 | Trigger Enable (トリガ有効) | このフィールドがセットされると、Trigger ビットによるトリガが有効になります。このフィールドをクリアすると、EtherNet/IP トリガメカニズムは無効になります。このビットは Ethernet/IP 経由で実行されるトリガにのみ影響し、その他のトリガモードにはまったく影響しません。

バイト 1

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 2 ～ 3

バイト | 名前 | 説明
2 ～ 3 | Job Load ID (4.9.x 以前) | PLC によって Initiate Job Load ビットがセットされたときにロードされるジョブの ID 番号 (1 ～ 999)。

バイト 4 ～ 495

バイト | 名前 | 説明
4 ～ 495 | User Data (0 ～ 491) | このデータは、ReadEIPBuffer 関数によって In-Sight Explorer スプレッドシートに送信されます。バッファは、PLC の表示どおりに書き込まれ、ビットは、RSLogix 5000 の定義と同じ順序で表示されます。

注: In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

Closed I/O アセンブリデータ属性の形式 - In-Sight ファームウェアバージョン 4.1.0 ～ 4.7.4

入力アセンブリ　‐ インスタンス 11

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
11 | 0 | Online | Offline Reason |  |  | Missed Acq | Acquiring | Trigger Ack | Trigger Ready
 | 1 | Reserved | Job Load Failed | Job Load Completed | Job Loading | Results Valid | Results Buffer Overrun | Inspection Completed | Inspecting
 | 2 | Acquisition ID (16 ビット整数)
 | 3
 | 4 | Inspection ID (16 ビット整数)
 | 5
 | 6 | Inspection Result (16 ビット整数)
 | 7
 | 8 | Inspection Results 0
 | ... |
 | 499 | Inspection Results 491

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6 ～ 4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 | Missed Acq | 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。
2 | Acquiring | Trigger ビットのセットによって、または外部ハードウェアトリガによって、In-Sight ビジョンシステムが画像を取り込み中であるときにセットされます。
1 | Trigger Ack | In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。
0 | Trigger Ready | In-Sight ビジョンシステムが新しいトリガを受け入れられることを示します。このビットは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、ビジョンシステムが画像の取り込み中でないときに高くなります。

バイト 1

ビット | 名前 | 説明
7 | Reserved | 未使用。
6 | Job Load Failed | このビットは、ジョブのロードの最後の試みが失敗したときにセットされます。次にジョブのロードが成功したときにクリアされます。 注: このビットは、EtherNet/IP を使用する PLC によってジョブのロードが開始された場合にのみ機能します。
5 | Job Load Completed | このビットは、ジョブロード操作の完了時にトグルされます。 注: このビットは、EtherNet/IP を使用する PLC によってジョブのロードが開始された場合にのみ機能します。
4 | Job Loading | このビットは、新規ジョブをロードするときにセットされます。 注: このビットは、EtherNet/IP を使用する PLC によってジョブのロードが開始された場合にのみ機能します。
3 | Results Valid | Inspection ID、Inspection Result、および Inspection Results フィールドが有効なときにセットされます。 注: このビットは、検査結果の読み取り準備ができていることを示すために使用します。
2 | Results Buffer Overrun | このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。 注: このビットは、結果の読み取り準備ができていることを示すために使用します。データの読み取り時期を指定するには、ResultsValid を使用します。
0 | Inspecting | このビットは、In-Sight ビジョンシステムがスプレッドシート関数を実行しているときにセットされます。

バイト 2 ～ 3

名前 | 説明
Acquisition ID (16 ビット整数) | この ID は、トリガソースに関係なく各画像取り込みが完了すると増分され、Acquisition とその Inspection Results を同期化するために使用できます。

バイト 4 ～ 5

名前 | 説明
Inspection ID (16 ビット整数) | この結果セットに関連付けられている取り込み ID。この値は、各検査サイクルの新しい結果が到着するたびに増加します。

バイト 6 ～ 7

名前 | 説明
Inspection Result (16 ビット整数) | この結果セットに関連付けられている成功/失敗コード。この値を設定することはできず、常に 0 です。

バイト 8 ～ 499

名前 | 説明
Inspection Results (0 ～ 491) | In-Sight Explorer スプレッドシートの WriteEIPBuffer 関数または EasyBuilder の [Ethernet/IP による通信] タブによって設定された検査結果。バッファは、In-Sight スプレッドシートの表示どおりに書き込まれ、ビットは、FormatOutputBuffer 関数 (スプレッドシート) または [Format Outputs] タブ (EasyBuilder) の定義と同じ順序で表示されます。

出力アセンブリ - インスタンス 21

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
21 | 0 | Force Offline | Reserved | Reserved | Initiate Job Load | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 2 | Job Load ID
 | 3
 | 4 | User Data 0
 | ... |
 | 495 | User Data 491

バイト 0

ビット | 名前 | 説明
7 Force Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6 ～ 5 | Reserved | 未使用。
4 Initiate
Job
Load (4.9.x 以上) 		セットされると、ビジョンシステムは Job Load ID フィールドで指定したジョブ ID をロードします。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。
2 | Buffer Results Enable (結果バッファ有効) | このビットをセットすると、ResultsValid ビットがセットされている間は、Inspection ID、Inspection Results および Inspection Results の各フィールドが一定に保たれます。Inspection Results Ack ビットをセットしてそれらのフィールドについて確認応答します。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack フィールドがクリアされると、Results Valid は、新しい結果が PLC に送信されるまでクリアされままになります。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されている。
0 | Trigger Enable (トリガ有効) | このフィールドがセットされると、Trigger ビットによるトリガが有効になります。このフィールドをクリアすると、EtherNet/IP トリガメカニズムは無効になります。このビットは Ethernet/IP 経由で実行されるトリガにのみ影響し、その他のトリガモードにはまったく影響しません。

バイト 1

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 2 ～ 3

バイト | 名前 | 説明
2 ～ 3 | Job Load ID (4.9.x 以前) | PLC によって Initiate Job Load ビットがセットされたときにロードされるジョブの ID 番号 (1 ～ 999)。

バイト 4 ～ 495

バイト | 名前 | 説明
4 ～ 495 | User Data (0 ～ 491) | このデータは、ReadEIPBuffer 関数によって In-Sight Explorer スプレッドシートに送信されます。バッファは、PLC の表示どおりに書き込まれ、ビットは、RSLogix 5000 の定義と同じ順序で表示されます。

注: In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

I/O アセンブリデータ属性コンポーネントのマッピング

次の表に、In-Sight ビジョンシステムの I/O アセンブリデータ属性のマッピングを示します。

データコンポーネント名 | クラス |  | インスタンス数 | 属性
 | 名前 | 番号 |  | 名前 | 番号
Set Offline | Vision | 78 Hex | 1 | ForceOffline | 8
Trigger Enable | Vision | 78 Hex | 1 | AcqTriggerEnable | 9
Trigger | Vision | 78 Hex | 1 | AcqTrigger | 10
BufferResultsEnable | Vision | 78 Hex | 1 | BufferResultsEnable | 13
Soft Event N | Vision | 78 Hex | 1 | SoftTrigger bit N | 18
Online | Vision | 78 Hex | 1 | Online | 6
OfflineReason | Vision | 78 Hex | 1 | OfflineReason | 7
Trigger Ready Trigger Ack Exposure Complete Missed Acquisition | Vision | 78 Hex | 1 | AcqStatusRegister | 11
User Data | Vision | 78 Hex | 1 | User Data | 12
System Busy Inspection Completed Results Buffer Overrun Results Valid | Vision | 78 Hex | 1 | InspectionStatusRegister | 14
Inspection ID Inspection Data | Vision | 78 Hex | 1 | InspectionResults | 16

ビジョンオブジェクトの属性

このセクションでは、EtherNet/IP ビジョンオブジェクト内に存在するさまざまな属性とサービスについて説明します。

クラスコード: 78 Hex - このオブジェクトは、In-Sight 4.x.x 以前のファームウェアが実行されている In-Sight ビジョンシステムで実行可能なすべての操作をモデル化します。

インスタンス属性

属性 ID | アクセスルール | 名前 | データ型 | 属性の説明
6 | Get | Online | BOOL | 0 = オフライン 1 = オンライン
7 | Get | OfflineReason | BYTE | 0 = オンライン 1 = プログラミング 2 = ディスクリートオフライン 3 = 通信オフライン 4 ～ 255 = 予約済み
8 | Set | ForceOffline | BOOL | 1 = In-Sight ビジョンシステムをオフラインにします。
9 | Set | AcqTriggerEnable | BOOL | 0 = 取り込みトリガは無効です。Trigger Ack を 0 にリセットします。 1 = 取り込みトリガは有効です。
10 | Set | AcqTrigger | BOOL | AcqTriggerEnable が真のとき、In-Sight ビジョンシステムは AcqTrigger が 0 から 1 に変わると画像を取り込みます。
11 | Get | AcqStatusRegister | BYTE | ビット 0: Trigger Ready ビット 1: Trigger Ack ビット 2: Acquiring ビット 3: Missed Acquisition ビット 4 ～ 7: Reserved
12 | Set | UserData | BYTE 配列 | 検査への入力として使用できるユーザ定義データ。 注: In-Sight ファームウェア 4.x.x が実行されている In-Sight ビジョンシステムの場合、UserData 属性に書き込まれるデータは書き込まれるときに表示されます。
13 | Set | BufferResultsEnable | BOOL | ResultsBufferEnable が真のとき、ResultsAck 属性が真に設定されるまで、検査結果のバッファリングを有効にします。
14 | Get | InspectionStatusRegister | BYTE | ビット 0: Inspecting ビット 1: Inspection Completed ビット 2: Results Buffer Overrun ビット 3: Results Valid ビット 4: Job Loading ビット 5: Job Load Completed ビット 6: Job Load Failed ビット 7: Reserved
15 | Set | InspectionResultsAck | BOOL | クライアントが検査結果を受信したことを確認応答します。
16 | Get | InspectionResults | STRUCT of (の構造体) | 最後の検査結果。
 |  | InspectionID | UINT | 検査カウンタ。
 |  | Reserved | UINT | 予約済みフィールド。
 |  | InspectionResults | BYTE 配列 | 最後の検査結果。
18 | Set | SoftTrigger | BYTE | ビット 0: ソフトトリガ 0 ビット 1: ソフトトリガ 1 ビット 2: ソフトトリガ 2 ビット 3: ソフトトリガ 3 ビット 4: ソフトトリガ 4 ビット 5: ソフトトリガ 5 ビット 6: ソフトトリガ 6 ビット 7: ソフトトリガ 7
19 | Set | JobID | INT | 現在ロードされているジョブの ID 番号。または、現在のジョブに ID がない場合は -1。 この値を設定すると (0 ～ 999)、関連付けられた ID を持つジョブがロードされます。
20 | Set | JobName | STRING | 現在ロードされているジョブのファイル名、またはファイル名が不明な場合は空の文字列。 この値を設定すると、ファイル名が関連付けられているジョブがロードされます。

オンライン属性

オンライン属性は、In-Sight ビジョンシステムがオンラインまたはオフライン状態であることを示します。In-Sight ビジョンシステムがオフラインのときには、OfflineReason 属性を使用して、In-Sight ビジョンシステムがオフラインになっている原因を調べることができます。

OfflineReason 属性の値

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

ForceOffline 属性を使用すると、In-Sight ビジョンシステムをオフライン状態にできます。ForceOffline 属性を True に設定すると、In-Sight ビジョンシステムがそれ以外の理由なしでオフラインに保持されている場合には、OfflineReason 属性が通信オフラインに設定されます。

画像取り込み属性

注:ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

画像取り込み属性を使用することによって、画像を取り込むようにビジョンオブジェクトをトリガすることができます。ビジョンオブジェクトの画像取り込み属性をリセットするには、AcqTriggerEnable 属性が偽に設定されている必要があります。ただし、AcqStatusRegister が 0 の場合を除きます。この場合、AcqTriggerEnable 属性を真に設定して、ビジョンオブジェクト経由の取り込みを有効にすることができます。Acquisition Trigger がトリガを受け入れる準備ができると、AcqStatusRegister の Trigger Ready ビットがセットされます。

AcqTriggerEnable 属性が真に設定されている間、ビジョンオブジェクトは、AcqTrigger 属性が 0 から 1 に変わったことを検出するたびに、画像の取り込みを開始します。非明示的メッセージングによってこれを設定するときには、変更がビジョンオブジェクトによって確実に検出されるように、AcqStatusRegister の Trigger Ack ビットによって同じ値が検出されるまで、属性が変更状態に保たれる必要があります。

注: 明示的メッセージングを使用するときには、変更は常に検出されるので、この必要はありません。

画像取り込み時には、AcqStatusRegister の Trigger Ready ビットがクリアされて、Acquiring ビットがセットされます。画像取り込みが完了すると、Acquiring ビットはクリアされます。画像取り込みシステムが次の新しい画像取り込みを開始する準備ができると、Trigger Ready ビットが再びセットされます。

ほかの方法で画像取り込みがトリガされた場合、AcqStatusRegister の Exposure Complete ビットと Missed Acquisition ビットはアクティブなままになります。

検査結果属性

画像取り込みトリガの結果として取り込まれた画像は、検査のためにキューに入れられます。画像の検査の実行中は、InspectionStatusRegister の Inspecting ビットがセットされます。検査が完了すると、Inspecting ビットはクリアされ、Inspection Completed ビットがトグルされます。

ResultsBufferEnable 属性によって、ビジョンオブジェクトでの検査結果の取り扱い方が決まります。ResultsBufferEnable 属性が偽に設定された場合、検査結果は直ちに InspectionResults 属性に入れられます。

ResultsBufferEnable 属性が真に設定された場合は、InspectionResultsAck 属性を真に設定することによって確認応答されるまで、前の検査結果が InspectionResults 属性に入ったままになります。Results Valid ビットがクリアされたら、新しい結果を InspectionResults 属性に入れることができるようにするため、InspectionResultsAck 属性を偽に設定する必要があります。これを使用して、ビジョンオブジェクトとクライアントの間で結果を取得するためのハンドシェークを確立することができます。

InspectionStatusRegister の動作

検査ステータスレジスタビット | ビット名 | バッファリングが無効な場合の結果 | バッファリングが有効な場合の結果
0 | Inspecting | 画像を検査しているときにセットされます。 | 画像を検査しているときにセットされます。
1 | Inspection Completed | 検査の完了時にトグルされます。 | 検査の完了時にトグルされます。
2 | Results Buffer Overrun | 常にクリア。 | クライアントが前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。検査結果が正常にキューに入れられるとクリアされます。
3 | Results Valid | 検査が開始されるとクリアされ、検査が完了するとセットされます。 | 新しい結果が InspectionResults 属性に入れられるとセットされます。InspectionResultsAck 属性を真に設定することによって結果が確認応答されるまでセットされたままです。
4 | Job Pass* | 検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。 注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。 | 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。 注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
* Job Pass ビットは Major Revision 10 以降にのみ組み込まれています。

ジョブ属性

ビジョンオブジェクトは、JobID および JobName 属性を設定することによって、In-Sight ビジョンシステムの不揮発性フラッシュメモリに格納されたジョブをロードすることができます。ロードが失敗した場合は、セット操作も失敗します。

ビジョンオブジェクトのサービス

共通サービス

ビジョンオブジェクトは、次の共通サービスを提供します。

サービスコード | サービス名 | サービスの説明
05 Hex | Reset | ビジョンオブジェクトをリセットします。
0E Hex | Get_Attribute_Single | 指定された属性の内容を返します。
10 Hex | Set_Attribute_Single | 属性の値を変更します。

リセットサービス

リセットサービスは、ビジョンオブジェクトの画像取り込みトリガシステムをリセットし、無効にします。また、ビジョンオブジェクトの検査結果バッファリングシステムを無効にし、クリアします。

オブジェクト固有サービス

ビジョンオブジェクトは、次のオブジェクト固有サービスを提供します。

サービスコード | サービス名 | サービスの説明
32 Hex | Acquire | 1 回の画像取り込みをトリガします。
33 Hex | Reserved | 廃止。
34 Hex | SendNativeCmd | ネイティブモードコマンドを In-Sight ビジョンシステムに送信します。
35 Hex | GetInspectionResults | InspectionResults 属性を取得します。
36 Hex | Transfer User Data | データをユーザデータ保持バッファの一部に転送します。
37 Hex | Set User Data | ユーザデータ保持バッファをユーザデータフィールドにラッチして、In-Sight にユーザデータへのアクセス権を与えることを、ビジョンシステムに対して通知します。

画像取り込みサービス

ビジョンオブジェクトの画像取り込みサービスは、画像取り込みシステムが画像を取り込む準備ができていた場合、画像取り込みをトリガします。画像取り込みをトリガできなかった場合は、次に画像取り込みが成功するまで、AcqStatusRegister の Missed Acquisition ビットがセットされます。

コマンドが失敗した場合、Acquire Service はベンダー固有のエラーコード 1F を返します。

SendNativeCmd サービス

SendNativeCmd サービスは、ドキュメント化されている任意のネイティブモードコマンド文字列を In-Sight ビジョンシステムに送信します。SendNativeCmd の要求データは、In-Sight ビジョンシステムに送信されるネイティブモードコマンド文字列を含む必要があります。応答データはネイティブモードコマンドの文字列結果を含みます。

SendNativeCmd 要求データのフォーマット

名前 | 型 | 説明
Command | STRING | 処理されるネイティブモードコマンド。

SendNativeCmd 応答データのフォーマット

名前 | 型 | 説明
Result | STRING | ネイティブモードコマンドの文字列結果。

コマンドが失敗した場合、サービスは次のベンダー固有のエラーコードの 1 つを返します。

エラーコード | 説明 | ネイティブモード戻りコード
1 | 正しくないコマンドです。 | -
4 | 応答なし - システムはビジーです。 |
100 | Command Failed | 0
101 | コマンドを実行できません。 | -1
102 |  | -2
103 |  | -3
104 |  | -4
105 |  | -5
106 |  | -6

GetInspectionResults サービス

GetInspectionResults サービス (コード 0x35) は、ビジョンオブジェクトの InspectionResults 属性からデータを読み取ります。

GetInspectionResults 要求データのフォーマット

名前 | 型 | 説明
Size | UINT | 読み取る InspectionResults 属性のバイト数。
Offset | UINT | InspectionResults 属性へのオフセット。これは、InspectionResults 属性で読み取る最初のバイトを指定します。

GetInspectionResults 応答データのフォーマット

名前 | 型 | 説明
Data | BYTE 配列 | InspectionResults 属性のデータ。

Transfer User Data コマンド

このコマンドを使用して、データをユーザデータ保持バッファの一部に転送します。ユーザデータ保持バッファは、Set User Data コマンドが発行されたときにユーザデータフィールドにラッチされます。

要求フォーマット

名前 | 型 | 説明
Size | UINT | 書き込む User Data フィールドのバイト数。
Offset | UINT | User Data フィールドへのオフセット。
Data | BYTE 配列 | ユーザデータフィールドに書き込むユーザデータ。

Set User Data コマンド

PLC はこのコマンドを使用して、ユーザデータ保持バッファをユーザデータフィールドにラッチして、In-Sight にユーザデータへのアクセス権を与えることを、ビジョンシステムに対して通知します。

EtherNet/IP の関数

これらの関数は、In-Sight Explorer のスプレッドシートと (In-Sight 4.x.x 以前のファームウェアが実行されている) In-Sight ビジョンシステムの EtherNet/IP スタックとの間のデータの送受信に使用されます。

  • ReadEIP 関数
  • ReadEIPBuffer 関数
  • WriteEIP 関数
  • WriteEIPBuffer 関数

EtherNet/IP による通信

次の項目には、EtherNet/IP と In-Sight ビジョンシステムの設定と利用に関する情報と手順が記載されています。

  • In-Sight Firmware 4.x.x と Rockwell ControlLogix PLC
  • EtherNet/IP ネットワーク上の Rockwell SLC 5/05 PLC との通信
Version: 5.6.0


EtherNet/IP オブジェクトモデルと入出力アセンブリオブジェクト - In-Sight 5.x.x ファームウェア

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

このトピックでは、In-Sight 5.1.0 以降が実行されている In-Sight ビジョンシステムの In-Sight オブジェクトモデルについて説明します。

注:モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  • In-Sight オブジェクトモデル
  • 入出力アセンブリオブジェクト

  • In-Sight　5.x.x ファームウェアが実行されている In-Sight ビジョンシステムへの移行時の入出力アセンブリの変更

  • ビジョンオブジェクトの属性
  • ビジョンオブジェクトのサービス
  • EtherNet/IP の関数
  • EtherNet/IP による通信

In-Sight オブジェクトモデル

EtherNet/IP ネットワークでは、In-Sight ビジョンシステムはサーバとして機能し、明示的および非明示的 I/O メッセージングの両方をサポートします。例えば、検査データを、明示的メッセージによって、または非明示的接続によって、クライアントに転送することができます。非明示的な接続は、画像取り込み、トリガ、およびスプレッドシートのイベントの制御に使用することもできます。

識別オブジェクト、Ethernet リンクオブジェクト、TCP/IP オブジェクト、およびそのほかの内部オブジェクトは、EtherNet/IP 仕様によって必須とされています。アセンブリオブジェクトのさまざまなインスタンスは、EtherNet/IP クライアントとアプリケーションデータを交換するために使用されます。ビジョンオブジェクトは、In-Sight ビジョンシステムに固有の情報を提供するために、In-Sight システムによって定義されます。これがどのように行われるかという詳細については、「ビジョンオブジェクトの属性とサービス」の節を参照してください。In-Sight ビジョンシステムによって提供される現在のオブジェクトモデルを下の図に示します。

  • アセンブリオブジェクト: アセンブリオブジェクトは、複数のオブジェクトの属性をバインドして、各オブジェクト間でのデータの送受信を 1 つの接続でできるようにします。アセンブリオブジェクトを使用すると、入力データまたは出力データをバインドすることができます。「入力」と「出力」という用語は、ネットワーク側から見た定義です。「入力」はネットワーク上にデータを生成し、「出力」はネットワークからデータを消費します。
  • 識別オブジェクト: このオブジェクトは、デバイスの識別情報とデバイスに関する全般情報を提供します。
  • Ethernet リンクオブジェクト: Ethernet リンクオブジェクトは、Ethernet 802.3 通信インタフェースについて、リンク固有のカウンタとステータス情報を保持します。
  • TCP/IP オブジェクト: TCP/IP オブジェクトは、デバイスの TCP/IP ネットワークインタフェース設定を照会 (可能な場合は設定も) するメカニズムを提供します。該当する項目の例としては、デバイスの IP アドレス、ネットワークマスク、ゲートウェイアドレスなどがあります。
  • ビジョンオブジェクト: ビジョンオブジェクトには、In-Sight ビジョンシステム固有のすべてのサービスと属性が含まれます。これには、画像取り込み、検査、ジョブの変更、および In-Sight Explorer スプレッドシートとの通信などが含まれます。

入出力アセンブリオブジェクト

入出力データの I/O アセンブリデータ属性の形式は、次のとおりです。

ファームウェアのバージョン | 入力アセンブリ | 出力アセンブリ
 | インスタンス | インスタンス
5.1.0 以降 | 13 | 22

注:
  • EDS で作成されたプロファイルを使用する場合、入力アセンブリの最大サイズが 500 バイトであっても、EDS で作成されたプロファイルは最大 496 バイトの接続しか許可しません。
  • Rockwell RSLogix Studio 5000 バージョン 21 ～ 25 を使用している場合、In-Sight EDS で作成されたプロファイルのデフォルト入出力アセンブリサイズ (各 496 バイト) は編集できず、デフォルトの最大の入出力アセンブリサイズに戻されます。
  • Trigger Ack が生成されて PLC に送信されている場合、Acquition ID は画像取り込みの開始時に増分されます。Inspection ID は、Inspection Completed ビットがトグルするときに増分されます (このとき、Results Valid は high に設定され、Inspecting ビットは low に設定されます)。
  • In-Sight 4.x.x ファームウェアが実行されている In-Sight ビジョンシステムから 5.x.x ファームウェアが実行されているビジョンシステムにアップグレードする場合の入出力アセンブリテーブル間の違いについては、「入出力アセンブリの変更」のトピックを参照してください。

入力アセンブリ　‐ インスタンス 13

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
13 | 0 | Online | Offline Reason |  |  | Missed Acq | Reserved | Trigger Ack | Trigger Ready
 | 1 | Error | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 | 2 | Reserved | Reserved | Reserved (5.1.0 ～ 5.5.x) | Job Pass | Exposure Complete | Reserved | Reserved | Set User Data Ack
 |  |  |  | TestRun Ready (5.6.0 以降)
 | 3 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0
 | 4 | Error Code (16 ビット整数)
 | 5
 | 6 | Reserved (16 ビット整数)
 | 7
 | 8 | Current Job ID (16 ビット整数)
 | 9
 | 10 | Acquisition ID (16 ビット整数)
 | 11
 | 12 | Inspection ID (16 ビット整数)
 | 13
 | 14 | Inspection Result Code (16 ビット整数)
 | 15
 | 16 | Inspection Results 0
 | ... |
 | 499 | Inspection Results 483

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6 ～ 4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 | Missed Acq | 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。
2 | Reserved | 未使用。
1 | Trigger Ack | In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。また、Acquisition ID は、このビットの立ち上がりエッジにラッチできます。
0 Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。

バイト 1

ビット | 名前 | 説明
7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
6 | Command Failed (5.1.0 ～ 5.5.x) | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
 | Command Failed (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] に失敗したことを示すため 1 にセットされます。TestRun シーケンスが実行されるか、PLC/HMI によって新規のジョブがロードされるとクリアされます。In-Sight Explorer でジョブを変更しても、このビットは変わりません。
5 | Command Completed (5.1.0 ～ 5.5.x) | このビットは、[ジョブを開く] が完了したことを示すためにセットされます。コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。 注: Execute Command ビットが Low になると、カメラは Command Completed ビットをクリアします。
 | Command Completed (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] が完了したことを示すためにセットされます。 注: TestRun を設定せずにジョブで TestRun を実行しようとすると、Command Completed ビットと Command Failed ビットの両方がセットされます。TestRun を実行する前に、TestRun Ready ビットがセットされるのを待つ必要があります。
4 | Command Executing (5.1.0 ～ 5.5.x) | Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。 注: Command Executing は最大で 2 秒間オンになります。
 | Command Executing (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] が開始されると 1 にセットされます。TestRun の実行が完了すると、このビットはクリアされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 | Results Valid | Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。
2 | Results Buffer Overrun | このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。9 番目の検査と後続のすべての検査は、バッファに空きが生じるまで (結果が確認応答されたとき) 破棄されます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。 注: このビットは、結果の読み取り準備ができていることを示すために使用します。データの読み取り時期を指定するには、ResultsValid を使用します。
0 | System Busy | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

バイト 2

ビット | 名前 | 説明
7 ～ 6 | Reserved | 未使用。
5 | Reserved (5.1.0 ～ 5.5.x) | 未使用。
TestRun Ready (5.6.0 以降)

このビットは、ビジョンシステムの TestRun 設定が有効な場合に 1 にセットされます。この信号は、TestRun が (TestRun イニシエータに関係なく) 実行されるときにクリアされ、実行完了後に 1 に戻ります。

注:

  • このビットは、ビジョンシステムがオンラインかオフラインかどうかに関係なく信号として送信されます。

  • 外部デバイスによる TestRun の開始は、In-Sight ファームウェア 5.1.0 ～ 5.5.x が実行されているビジョンシステムではサポートされません。
4 Job Pass このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。
注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
2 ～ 1 | Reserved | 未使用。
0 | Set User Data Ack | このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。

バイト 3

ビット | 名前 | 説明
7 | Soft Event Ack 7 | これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
6 | Soft Event Ack 6
5 | Soft Event Ack 5
4 | Soft Event Ack 4
3 | Soft Event Ack 3
2 | Soft Event Ack 2
1 | Soft Event Ack 1
0 | Soft Event Ack 0

バイト 4 ～ 5

名前 説明
Error Code (16 ビット整数)

発生したエラーの 16 ビットの数値表現:

コード | Error | 説明
0x0000 | No Error | エラーは発生しませんでした。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされている間に Trigger ビットがセットされた場合、または AcquireImage 関数の Trigger パラメータが、外部、ネットワークまたは産業用イーサネットに設定された場合に発生します。
0x0101 | Trigger set while Offline | ビジョンシステムがオフラインの間に Trigger ビットが設定されるときに発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Excecuting ビットが High のままになっている場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムがオンラインの間に [ジョブを開く] コマンドが発行されるときに発生します。
0x0402 | Job load fail | PLC が値を書き込んでも (a 7 など)、a 7 を接頭辞とするジョブがない場合に発生します。

バイト 6 ～ 7

名前 | 説明
Reserved (16 ビット整数) | 未使用。

バイト 8 ～ 9

名前 | 説明
Current Job ID (16 ビット整数) | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 10 ～ 11

名前 | 説明
Acquisition ID (16 ビット整数) | この ID は、取り込みの開始時と Trigger Ack ビットがセットされると増分され、取り込みとその検査結果の同期に使用できます。

バイト 12 ～ 13

名前 | 説明
Inspection ID (16 ビット整数) | この結果セットに関連付けられている取り込み ID。

バイト 14 ～ 15

名前 | 説明
Inspection Result Code (16 ビット整数) (5.1.0 ～ 5.5.x) | 検査結果コードは、WriteResultsBuffer 関数の [結果コード] パラメータによって定義されます。
Inspection Result Code (16 ビット整数) (5.6.0 以降)

TestRun の最新の実行結果を示します。すべてのテストに合格すると、値が 0 になります。不合格のテストがあった場合、または TestRun 実行中のセットアップまたはクリーンアップに問題があった場合は、その障害を示す 0 以外の値が返されます。

  • このフィールドは、TestRun の実行が正常に完了した場合にのみ有効になります。
  • このフィールドの結果は、TestRun なしのジョブがロードされた場合、別の TestRun ジョブが実行された場合、TestRun が進行中の場合、TestRun の実行またはジョブを開くことに失敗した場合、または TestRun の実行が中止された場合には無効化されることがあります。

バイト 16 ～ 499

名前 説明
Inspection Results (0 ～ 483)

[スプレッドシートビュー] の WriteResultsBuffer 関数、または EasyBuilder GUI の [通信] の手順での [フォーマット出力データ] タブを介して In-Sight Explorer から書き込まれるデータです。

送信されるデータは、In-Sight Explorer GUI での表示どおりに書き込まれ、FormatOutputBuffer 関数 (スプレッドシート) または [フォーマット出力データ] タブ (EasyBuilder) で定義される順序と同じ順序で表示されます。

注:

  • RSLogix 5000 は Inspection Results データアレイを受信すると、送信されたデータに複数のデータ型が含まれている (つまり、フォーマットされたデータに整数、浮動小数点、ビットが含まれている) かどうかに関係なく、1 つのデータ型をアレイ全体に割り当てます。したがって、送信されているデータにさまざまなデータ型が含まれる場合は、特定の結果 (最初に Inspection Results アレイのバイトオフセット、次にバイト単位の長さ) を、送信されているデータ型の予測を基に RSLogix の User-Defined Data Type にコピーします。

    詳細については、「例: In-Sight ビジョンシステムからの浮動小数点数値データの取得」を参照してください。

  • Buffer Results Enable ビットがセットされていた場合、Inspection Results Ack ビットをパルス出力することによって確認応答されるまで、検査結果は変わりません。

I/O アセンブリデータ属性の形式 - 出力アセンブリ - インスタンス 22

インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
22 | 0 | Set Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Reserved
 | 2 | Reserved |  |  |  | Clear Exposure Complete | Clear Error | Reserved | Set User Data
 | 3 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 4 | Command
 | 5
 | 6 ..7 | Reserved
 | 8 | User Data 0
 | ... |
 | 495 | User Data 487

注: In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

バイト 0

ビット | 名前 | 説明
7 Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6 ～ 5 | Reserved | 未使用。
4 | Execute Command (5.1.0 ～ 5.5.x) | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。
Execute Command (5.6.0 以降) | セットすると、ビジョンシステムは、Command フィールドで指定されてているジョブ ID をロードするか、Job Load by Name コマンドを実行して User Data バッファにあるジョブ名をロードします。TestRun を使用する場合は、この信号の立ち上がりエッジでコマンドが実行されて TestRun が開始されます。この信号は、Command Completed 信号がトグルされるまで high を維持する必要があります。この信号の立ち下がりエッジ (Command Complete の前) は、中止要求と解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。その後、次の検査結果のセットが PLC に送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。結果のバッファ処理が無効になっている場合、Inspection Results Ack ビットをセットして、Results Valid ビットをクリアする必要があります。
2 | Buffer Results Enable | このビットがセットされると、Inspection ID、Inspection Result、Inspection Results フィールドは、Inspection Results Ack フィールドが確認応答してセットされるまで変化しません。最大 8 つの検査がビジョンシステムのバッファに保持されます。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack フィールドがクリアされて、PLC に送信される新しいルールセットがあるときには、Results Valid ビットはクリアされません。Inspection Results Ack ビットがクリアされて、PLC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。

  • AcquireImage 関数の Trigger パラメータが、ネットワーク、外部、または産業用イーサネットに設定されます。

    注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。
0 | Trigger Enable | このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

バイト 1

ビット | 名前 | 説明
7 ～ 0 | Reserved | 未使用。

バイト 2

ビット | 名前 | 説明
7 ～ 4 | Reserved | 未使用。
3 | Clear Exposure Complete | この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。
2 | Clear Error | このビットをセットすると、エラーシグナルとエラーコードシグナルがクリアされます。Clear Error ビットは、Error ビットがクリアされるまで [High] に維持する必要があります。エラーがキューに入れられた場合、このビットがクリアされると、エラーシグナルとエラーコードシグナルは、キューに入れられた次のエラーコードに対してセットされます。
1 | Reserved | 未使用。
0 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC から In-Sight ビジョンシステムへ通知します。

バイト 3

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 4 ～ 5

バイト | 名前 | 説明
4 ～ 5 | Command (5.1.0 ～ 5.5.x) | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。
 | Command (5.6.0 以降) | (missing or bad snippet)

バイト 6 ～ 7

バイト | 名前 | 説明
6 ～ 7 | Reserved | 未使用。

バイト 8 ～ 495

バイト | 名前 | 説明
8-495 | User Data (0 ～ 487) | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。バッファは、PLC の表示どおりに書き込まれ、ビットは、RSLogix 5000 の定義と同じ順序で表示されます。

I/O アセンブリデータ属性コンポーネントのマッピング

次の表に、In-Sight ビジョンシステムの I/O アセンブリデータ属性のマッピングを示します。

データ コンポーネント 名前 | クラス |  | インスタンス 番号 | 属性
 | 名前 | 番号 |  | 名前 | 番号
Set Offline | Vision | 78 Hex | 1 | SetOffline | 8
Trigger Enable | Vision | 78 Hex | 1 | AcqTriggerEnable | 9
Trigger | Vision | 78 Hex | 1 | AcqTrigger | 10
BufferResultsEnable | Vision | 78 Hex | 1 | BufferResultsEnable | 13
Soft Event N | Vision | 78 Hex | 1 | SoftTrigger bit N | 18
Online | Vision | 78 Hex | 1 | Online | 6
OfflineReason | Vision | 78 Hex | 1 | OfflineReason | 7
Trigger Ready Trigger Ack Exposure Complete Missed Acquisition | Vision | 78 Hex | 1 | AcqStatusRegister | 11
User Data | Vision | 78 Hex | 1 | User Data | 12
System Busy Inspection Completed Results Buffer Overrun Results Valid | Vision | 78 Hex | 1 | InspectionStatusRegister | 14
Inspection ID Inspection Data | Vision | 78 Hex | 1 | InspectionResults | 16

ビジョンオブジェクトの属性

このセクションでは、EtherNet/IP ビジョンオブジェクト内に存在するさまざまな属性とサービスについて説明します。

クラスコード: 78 Hex - このオブジェクトは、In-Sight フォームウェア 5.1.0 以降が実行されている In-Sight ビジョンシステムで実行可能なすべての操作をモデル化します。

インスタンス属性

属性 ID

アクセスルール

名前

データ型

属性の説明

6

Get

Online

BOOL

0 = オフライン

1 = オンライン

7

Get

OfflineReason

BYTE

0 = オンライン

1 = プログラミング

2 = ディスクリートオフライン

3 = 通信オフライン

4 ～ 255 = 予約済み

8

Set

SetOffline

BOOL

1 = In-Sight ビジョンシステムをオフラインにします。

9

Set

AcqTriggerEnable

BOOL

0 = 取り込みトリガは無効です。Trigger Ack を 0 にリセットします。

1 = 取り込みトリガは有効です。

10

Set

AcqTrigger

BOOL

AcqTriggerEnable が真のとき、In-Sight ビジョンシステムは AcqTrigger が 0 から 1 に変わると画像を取り込みます。

11

Get

AcqStatusRegister

BYTE

ビット 0: Trigger Ready

ビット 1: Trigger Ack

ビット 2: Exposure Complete

ビット 3: Missed Acquisition

ビット 4 ～ 7: Reserved

12

Set

UserData

BYTE 配列

検査への入力として使用できるユーザ定義データ。

注:

  • In-Sight ファームウェア 5.1.0 ～ 5.3.x が実行されている In-Sight ビジョンシステムの場合、UserData 属性に書き込まれるデータは、Set User Data サービスが実行されるまで表示されません。

  • In-Sight ファームウェア 5.4.x 以降が実行されており、User Data Holding Buffer Bypass が有効な In-Sight ビジョンシステムの場合は、UserData 属性に書き込まれるデータは書き込まれるときに表示されます。
  • ユーザデータ保持バッファバイパスは、グラフィカルユーザインタフェース (GUI) を介してのみ有効および無効にすることができます。

13

Set

BufferResultsEnable

BOOL

ResultsBufferEnable が真のとき、ResultsAck 属性が真に設定されるまで、検査結果のバッファリングを有効にします。

14

Get

InspectionStatusRegister

BYTE

ビット 0: System Busy

ビット 1: Inspection Completed

ビット 2: Results Buffer Overrun

ビット 3: Results Valid

ビット 4: Job Loading

ビット 5: Job Load Completed

ビット 6: Job Load Failed

ビット 7: Job Pass

15

Set

InspectionResultsAck

BOOL

クライアントが検査結果を受信したことを確認応答します。

16

Get

InspectionResults

STRUCT of (の構造体)

最後の検査結果。

InspectionID

UINT

検査カウンタ。

InspectionResultCode

UINT

WriteResultsBuffer 関数でセットされる検査結果コード。

InspectionResults

BYTE 配列

最後の検査結果。

18

Set

SoftTrigger

BYTE

ビット 0: ソフトトリガ 0

ビット 1: ソフトトリガ 1

ビット 2: ソフトトリガ 2

ビット 3: ソフトトリガ 3

ビット 4: ソフトトリガ 4

ビット 5: ソフトトリガ 5

ビット 6: ソフトトリガ 6

ビット 7: ソフトトリガ 7

19

Set

JobID

INT

現在ロードされているジョブの ID 番号。または、現在のジョブに ID がない場合は -1。

この値を設定すると (0 ～ 999)、関連付けられた ID を持つジョブがロードされます。

20

Set

JobName

STRING

現在ロードされているジョブのファイル名、またはファイル名が不明な場合は空の文字列。

この値を設定すると、ファイル名が関連付けられているジョブがロードされます。

21

Set

 ClearExposureComplete BOOL

Exposure Complete ビットをクリアします。このビットの立ち上がりエッジで Exposure Complete ビットがクリアされます。Clear Exposure Complete ビットがセットされている間に別の Exposure Complete 信号が送信されると、Exposure Complete ビットは Clear Exposure Complete ビットがクリアされるときにセットされます。

22

Set

SoftEventAck 0 ～ 7

BYTE

ビット 0 = ソフトトリガ確認応答 0

ビット 1 = ソフトトリガ確認応答 1

ビット 2 = ソフトトリガ確認応答 2

ビット 3 = ソフトトリガ確認応答 3

ビット 4 = ソフトトリガ確認応答 4

ビット 5 = ソフトトリガ確認応答 5

ビット 6 = ソフトトリガ確認応答 6

ビット 7 = ソフトトリガ確認応答 7

オンライン属性

オンライン属性は、In-Sight ビジョンシステムがオンラインまたはオフライン状態であることを示します。In-Sight ビジョンシステムがオフラインのときには、OfflineReason 属性を使用して、In-Sight ビジョンシステムがオフラインになっている原因を調べることができます。

OfflineReason 属性の値

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

SetOffline 属性を使用すると、In-Sight ビジョンシステムをオフライン状態にできます。SetOffline 属性を True に設定すると、In-Sight ビジョンシステムがそれ以外の理由なしでオフラインに保持されている場合には、OfflineReason 属性が通信オフラインに設定されます。

画像取り込み属性

注:ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

画像取り込み属性を使用することによって、画像を取り込むようにビジョンオブジェクトをトリガすることができます。ビジョンオブジェクトの画像取り込み属性をリセットするには、AcqTriggerEnable 属性が偽に設定されている必要があります。ただし、AcqStatusRegister が 0 の場合を除きます。この場合、AcqTriggerEnable 属性を真に設定して、ビジョンオブジェクト経由の取り込みを有効にすることができます。Acquisition Trigger がトリガを受け入れる準備ができると、AcqStatusRegister の Trigger Ready ビットがセットされます。

AcqTriggerEnable 属性が真に設定されている間、ビジョンオブジェクトは、AcqTrigger 属性が 0 から 1 に変わったことを検出するたびに、画像の取り込みを開始します。非明示的メッセージングによってこれを設定するときには、変更がビジョンオブジェクトによって確実に検出されるように、AcqStatusRegister の Trigger Ack ビットによって同じ値が検出されるまで、属性が変更状態に保たれる必要があります。

注: 明示的メッセージングを使用するときには、変更は常に検出されるので、この必要はありません。

In-Sight ビジョンシステムで画像取り込みを完了したタイミングを判別するには、Exposure Complete ビットと Clear Exposure Complete ビットを利用します。画像取り込みは、Exposure Complete 信号を明示的に確認応答することによって明示的に確認応答される必要があります。Clear Exposure Complete ビットが HIGH の間に Exposure Complete 信号が送信されると、Exposure Complete ビットは Clear Exposure Complete ビットが PLC によってクリアされるときにアサートされます。

この動作により、複数の Exposure Complete 信号が発生しても、信号が 1 つだけ送信された場合と同じ効果が得られ、このシナリオでエラーは報告されません。これにより PLC では、Exposure Complete 信号を検出することによって、画像取り込みがディスクリート入力からトリガされたタイミングを検出できます。

ほかの方法で画像取り込みがトリガされた場合、AcqStatusRegister の Exposure Complete ビットと Missed Acquisition ビットはアクティブなままになります。

検査結果属性

画像取り込みトリガの結果として取り込まれた画像は、検査のためにキューに入れられます。画像の検査の実行中は、InspectionStatusRegister の System Busy ビットがセットされます。検査が完了すると、System Busy ビットはクリアされ、Inspection Completed ビットがトグルされます。

ResultsBufferEnable 属性によって、ビジョンオブジェクトでの検査結果の取り扱い方が決まります。ResultsBufferEnable 属性が偽に設定された場合、検査結果は直ちに InspectionResults 属性に入れられます。

ResultsBufferEnable 属性が真に設定された場合は、InspectionResultsAck 属性を真に設定することによって確認応答されるまで、前の検査結果が InspectionResults 属性に入ったままになります。Results Valid ビットがクリアされたら、新しい結果を InspectionResults 属性に入れることができるようにするため、InspectionResultsAck 属性を偽に設定する必要があります。これを使用して、ビジョンオブジェクトとクライアントの間で結果を取得するためのハンドシェークを確立することができます。

InspectionStatusRegister の動作

Inspection

Status

Register

ビット

 ビット名 バッファリングが無効な場合の結果 バッファリングが有効な場合の結果
0

System Busy

 ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。 ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。 | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。
2 | Results Buffer Overrun | 常にクリア。 | クライアントが前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。検査結果が正常にキューに入れられるとクリアされます。
3 Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注:オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注: オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。
7 Job Pass 検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。

ジョブ属性

ビジョンオブジェクトは、JobID および JobName 属性を設定することによって、In-Sight ビジョンシステムの不揮発性フラッシュメモリに格納されたジョブをロードすることができます。ロードが失敗した場合は、セット操作も失敗します。

ビジョンオブジェクトのサービス

共通サービス

ビジョンオブジェクトは、次の共通サービスを提供します。

サービスコード | サービス名 | サービスの説明
05 Hex | Reset | ビジョンオブジェクトをリセットします。
0E Hex | Get_Attribute_Single | 指定された属性の内容を返します。
10 Hex | Set_Attribute_Single | 属性の値を変更します。

リセットサービス

リセットサービスは、ビジョンオブジェクトの画像取り込みトリガシステムをリセットし、無効にします。また、ビジョンオブジェクトの検査結果バッファリングシステムを無効にし、クリアします。

オブジェクト固有サービス

ビジョンオブジェクトは、次のオブジェクト固有サービスを提供します。

サービスコード | サービス名 | サービスの説明
32 Hex | Acquire | 1 回の画像取り込みをトリガします。
33 Hex | Reserved | 廃止。
34 Hex | SendNativeCmd | ネイティブモードコマンドを In-Sight ビジョンシステムに送信します。
35 Hex | GetInspectionResults | InspectionResults 属性を取得します。
36 Hex | Transfer User Data | データをユーザデータ保持バッファの一部に転送します。
37 Hex | Set User Data | ユーザデータ保持バッファをユーザデータフィールドにラッチして、In-Sight にユーザデータへのアクセス権を与えることを、ビジョンシステムに対して通知します。

画像取り込みサービス

ビジョンオブジェクトの画像取り込みサービスは、画像取り込みシステムが画像を取り込む準備ができていた場合、画像取り込みをトリガします。画像取り込みをトリガできなかった場合は、次に画像取り込みが成功するまで、AcqStatusRegister の Missed Acquisition ビットがセットされます。

コマンドが失敗した場合、Acquire Service はベンダー固有のエラーコード 1F を返します。

SendNativeCmd サービス

SendNativeCmd サービスは、ドキュメント化されている任意のネイティブモードコマンド文字列を In-Sight ビジョンシステムに送信します。SendNativeCmd の要求データは、In-Sight ビジョンシステムに送信されるネイティブモードコマンド文字列を含む必要があります。応答データはネイティブモードコマンドの文字列結果を含みます。

SendNativeCmd 要求データのフォーマット

名前 | 型 | 説明
Command | STRING | 処理されるネイティブモードコマンド。

SendNativeCmd 応答データのフォーマット

名前 | 型 | 説明
Result | STRING | ネイティブモードコマンドの文字列結果。

コマンドが失敗した場合、サービスは次のベンダー固有のエラーコードの 1 つを返します。

エラーコード | 説明 | ネイティブモード 戻りコード
1 | 正しくないコマンドです。 | -
4 | 応答なし - システムはビジーです。 |
100 | Command Failed | 0
101 | コマンドを実行できません。 | -1
102 |  | -2
103 |  | -3
104 |  | -4
105 |  | -5
106 |  | -6

GetInspectionResults サービス

GetInspectionResults サービス (コード 0x35) は、ビジョンオブジェクトの InspectionResults 属性からデータを読み取ります。

GetInspectionResults 要求データのフォーマット

名前 | 型 | 説明
Size | UINT | 読み取る InspectionResults 属性のバイト数。
Offset | UINT | InspectionResults 属性へのオフセット。これは、InspectionResults 属性で読み取る最初のバイトを指定します。

GetInspectionResults 応答データのフォーマット

名前 | 型 | 説明
InspectionResults | STRUCT of (の構造体) | 最後の検査結果。
InspectionID | UINT | 検査カウンタ。
InspectionResultCode | UINT | WriteResultsBuffer 関数でセットされる検査結果コード。
InspectionResults | BYTE 配列 | 最後の検査結果。

Transfer User Data コマンド

このコマンドを使用して、データをユーザデータ保持バッファの一部に転送します。ユーザデータ保持バッファは、Set User Data コマンドが発行されたときにユーザデータフィールドにラッチされます。

要求フォーマット

名前 | 型 | 説明
Size | UINT | 書き込む User Data フィールドのバイト数。
Offset | UINT | User Data フィールドへのオフセット。
データ | BYTE 配列 | ユーザデータフィールドに書き込むユーザデータ。

Set User Data コマンド

PLC はこのコマンドを使用して、ユーザデータ保持バッファをユーザデータフィールドにラッチして、In-Sight にユーザデータへのアクセス権を与えることを、ビジョンシステムに対して通知します。

この追加の User Data ハンドシェイクが必要ではなく、通信の動作が 4.x.x カメラでのアセンブリ IO の場合と同じ場合、User Data Command は次の方法でバイパス可能です。

  1. カメラにログオンします。
  2. メインメニューバーで、[センサ] → [ネットワークの設定] を選択します。

  3. [産業用イーサネットのプロトコル] セクションで [EtherNet/IP] を選択します。

  4. 選択した EtherNet/IP の横の有効な [設定] ボタンを選択します。

  5. [ユーザデータバイパスの有効化] チェックボックスをオンにします。

  6. ビジョンシステムを再起動します。

EtherNet/IP の関数

これらの関数は、In-Sight Explorer のスプレッドシートと EtherNet/IP スタックの間のデータの送受信に使用されます。

  • ReadUserDataBuffer 関数
  • ReadLatchedUserDataBuffer 関数
  • WriteResultsBuffer 関数
  • GetBufferData 関数

EtherNet/IP による通信

次のトピックには、EtherNet/IP と In-Sight ビジョンシステムの設定と利用に関する情報とそのための手順が記載されています。

  • EtherNet/IP ネットワーク上の Rockwell ControlLogix PLC との通信
Version: 5.6.0


入出力アセンブリの変更

EtherNet/IP による通信

In-Sight 通信リファレンス

このトピックでは、In-Sight ファームウェアを更新する場合、または In-Sight ビジョンシステムのプラットフォーム間を移動する場合に入出力アセンブリオブジェクトに加えられる変更内容をグラフィカルに示します。

  • In-Sight 4.x.x ファームウェアのアップグレード時の入出力アセンブリの変更
  • In-Sight　5.x.x ファームウェアが実行されている In-Sight ビジョンシステムへの移行時の入出力アセンブリの変更

In-Sight 4.x.x ファームウェアのアップグレード時の入出力アセンブリの変更

In-Sight　5.x.x ファームウェアが実行されている In-Sight ビジョンシステムへの移行時の入出力アセンブリの変更

注: ユーザデータ保持バッファバイパスは、グラフィカルユーザインタフェース (GUI) を介してのみ有効および無効にすることができます。


Rockwell ControlLogix PLC

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

以下のトピックでは、ControlLogix PLC と　(In-Sight 4.x.x ファームウェアを実行している) In-Sight ビジョンシステムの間の接続とデータ転送、および EtherNet/IP の非明示的メッセージを送受信する方法について説明します。

  • Rockwell ControlLogix PLC　との通信
  • 非明示的メッセージ
    • ユニキャスト非明示的接続の確立 - In-Sight　4.8.0 ～ 4.9.x ファームウェア
    • ユニキャスト非明示的接続の確立 - In-Sight　4.10.x ファームウェア
    • 例: 接続のセットアップ
    • 複数の PLC とのマルチキャスト非明示的接続の確立
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信
  • 明示的メッセージ
  • [時刻同期] タブ
Version: 5.6.0


ユニキャスト非明示的接続の確立

EtherNet/IP 通信 - In-Sight 4.8.0 ～ 4.9.x ファームウェア

In-Sight 通信リファレンス

ビジョンシステムに In-Sight 4.8.0 ～ 4.9.0 ファームウェアバージョンがインストールされている場合は、次の手順を実行して、In-Sight ビジョンシステムと EtherNet/IP ネットワーク上の ControlLogix または CompactLogix PLC の間でデータを転送する必要があります。

  1. アドオンプロファイル (AOP) バージョン 1.26.1 をインストールします。これにより Major Revision 10 がインストールされます。
  2. アドオンプロファイル (AOP) を使用して接続を確立します。
Version: 5.6.0


アドオンプロファイルのインストール

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

アドオンプロファイル (AOP) を使用して、RSLogix 5000 ソフトウェアが使用されるモジュールのタイプを認識できるようにし、特定のデフォルトパラメータを設定することによって、In-Sight ビジョンシステムと RSLogix 5000 との間の統合を簡素化します。

  1. In-Sight のサポートサイトから In-Sight アドオンプロファイル (AOP) をダウンロードします。http://www.cognex.com/support/InSight。
  2. インストールファイルを抽出し、MPSetup.exe ファイルをダブルクリックして RSLogix 5000 Module Profiles Setup を起動します。

  3. [次へ] を何回かクリックし、ほとんどの場合にデフォルトの選択を受け入れます。

  4. [完了] をクリックします。
Version: 5.6.0


アドオンプロファイルを使用した接続の確立

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

アドオンプロファイル (AOP) を使用して単一の ControlLogix PLC との非明示的メッセージング接続を確立するには、次の手順に従います。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. [I/O Configuration] ノードで、Ethernet モジュールを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  3. 次のダイアログが表示されたら、リストから使用中の In-Sight ビジョンシステムのモデルを選択します。このオプションは、アドオンプロファイル (AOP) をインストールすると表示されます。

  4. 選択を行うと、In-Sight ビジョンシステムの設定ダイアログが表示されます。

    注: [Time Sync] タブは、In-Sight 5000 シリーズビジョンシステムに接続しているときにのみ表示されます。

    次のフィールドを設定する必要があります。

    • [名前]: これは、汎用 EtherNet/IP デバイスに与えられる名前です。RSLogix 5000 で作成されるタグは、この名前に基づきます。一貫性を保つために、In-Sight ビジョンシステムの名前を使用することを推奨します。
    • [IP アドレス]: In-Sight ビジョンシステムの IP アドレス。
    • [ホスト名]: この設定は任意です。ネットワークに DNS (Domain Name Server) がある場合のみ、この設定を使用してください。
  5. In-Sight ビジョンシステムと PLC との間で転送するデータの量と型を設定するには、[変更] ボタンを使用します。[Change] ボタンを使用して、電子キー (Electronic Keying) を有効にすることもできます。

  6. (オプション) 電子キー操作は、必要に応じて [変更] ボタンを使用して無効にすることもできます。

    キー操作を無効にするには、次の手順に従います。[Module Definition (モジュール定義)] ダイアログで、リビジョン [10] を選択し、[Disable Keying (キー操作無効)] を選択します。次に [OK] をクリックします。

  7. 一般的な通信パラメータを確定した後、設定プロセスに関する手順は下の図に示します。

    次のフィールドを設定する必要があります。

    • [Requested Packet Interval (RPI)]: このフィールドは、RPI (Requested Packet Interval) を指定します。これは、非明示的メッセージング接続によるデータ交換の時間間隔 (ミリ秒単位) を定義します。

      注: In-Sight ファームウェアバージョン 3.30.00 以降では、RPI 値をジョブ実行時間より長くする必要がなくなりました。非明示的メッセージング接続はジョブ実行と非同期に実行するようになりました。ただし、RPI 時間が短いと (20ms 未満)、ビジョンジョブのパフォーマンスに悪影響を与えることがあります。最良の結果を得るためには、RPI 時間を、In-Sight ビジョンシステムがジョブ実行を完了してから PLC がデータを要求するまでの時間の半分以下に設定してください。
    • [Major Fault On Controller If Connection Fails While in Run Mode]: このオプションをオンにすると、コントローラは接続が失敗したときにメジャーフォールトを生成します。

    • [Inhibit Module]: このチェックボックスを ON にすると、PLC は In-Sight ビジョンシステムとの接続の確立を試みません。

      注: In-Sight ビジョンシステムが「スタンバイ」モードで動作を停止した場合は、モジュールを禁止して再度有効にすることによってそのモジュールを再び動作させることができます。

  8. ControlLogix にモジュールを追加すると、I/O ツリーは次のように表示されます。

  9. 続いて RSLogix 5000 により、デバイスに与えられた名前に基づいて In-Sight ビジョンシステムの入力および出力データにマップされるタグが作成されます。

    • [InSight_Top:I Scheduled Input]: 下の表に、In-Sight ビジョンシステムから PLC に送信されるデータを示します。

    • [InSight_Top:O Scheduled Output]: 以下の表に、EtherNet/IP クライアント (ControlLogix) から In-Sight ビジョンシステムに送信されるデータを示します。
Version: 5.6.0


ユニキャスト非明示的接続の確立

ユニキャスト非明示的接続の確立

EtherNet/IP 通信 - In-Sight 4.10.x ファームウェア

In-Sight 通信リファレンス

ビジョンシステムに In-Sight 4.10.x ファームウェアバージョンがインストールされている場合は、次の手順を実行して、In-Sight ビジョンシステムと EtherNet/IP ネットワーク上の ControlLogix または CompactLogix PLC の間でデータを転送する必要があります。

手順は、PLC のプログラムに使用されている RSLogix 5000 のバージョンと、TestRun が有効か無効かどうかに応じて異なります。

TestRun が有効化されアドオンプロファイルが以前にインストールされている

  1. 汎用 ETHERNET-MODULE を使用して接続を確立します。

TestRun が有効化されアドオンプロファイルがインストールされていない

  1. In-Sihgt Explorer ソフトウェアに組み込まれている EDS ファイルをインストールします。
  2. EDS 生成プロファイルを使用して接続を確立します。

TestRun が無効化されている

  1. キーを無効にした状態でアドオンプロファイルを使用して接続を確立します。
Version: 5.6.0


汎用 ETHERNET-MODULE を使用した接続の確立

EtherNet/IP 通信 - In-Sight 4.10.x および 5.x.x ファームウェア

In-Sight 通信リファレンス

このトピックでは、In-Sight 4.10.x または 5.x.x のファームウェアが実行されている In-Sight ビジョンシステムをバージョン 14 ～ 19 の RSLogix 5000 に統合する方法について説明します。RSLogix 5000 のこれらのバージョンは EDS ファイルをサポートしていないため、汎用の ETHERNET-MODULE を使用する必要があります。In-Sight Explorer には、.L5X ファイルが含まれています。このファイルを使用して、PLC コントローラのタグデータをユーザフレンドリーなプログラムタグ (TestRun と一緒に In-Sight 4.10.x または 5.x.x ファームウェアが実行されている In-Sight ビジョンシステム内の信号を表す) との間でコピーすることができます。

注: このトピックで使用するスクリーンキャプチャは RSLogix 5000 バージョン 16 から取得したものです。その他のバージョンの RSLogix 5000 のいくつかは、表示がやや異なることがあります。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. Ethernet Communications Card に接続を追加します。[I/O Configuration] ノードで、Ethernet Module の下にある [Ethernet] ノードを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  3. [Catalog] タブの [Select Module Type] ダイアログで、Communication Module Type Category Filter、Allen-Bradley を Module Type Vendor Filter として選択し、ETHERNET-MODULE (汎用 Ethernet モジュール) を選択してから、[Create] ボタンを押します。

  4. [New Module] ダイアログに以下を入力します。

    • In-Sight ビジョンシステムの名前および IP アドレス。

    • 接続パラメータ:

      • In-Sight 5.x.x ファームウェアが実行されている In-Sight ビジョンシステムの場合は、アセンブリオブジェクトセクションで、設定する必要があるアセンブリインスタンスを定義するを設定する必要があります。
      • In-Sight 4.x.x ファームウェアが実行されている In-Sight ビジョンシステムの場合は、アセンブリオブジェクトセクションで、設定する必要があるアセンブリインスタンスを定義するを設定する必要があります。

  5. ビジョンシステムを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造化データを作成することができます。

    1. メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。

    2. .L5X ファイルにナビゲートし、[Import...] ボタンをクリックします。

      • In-Sight 4.10.x ファームウェア、および RSLogix バージョン 14 ～ 16 を使用している場合は、InSightGenEth_12_CopyRung.L5X ファイルをインポートします。

      • In-Sight 4.10.x ファームウェア、および RSLogix バージョン 17 ～ 19 を使用している場合は、InSight_12_CopyRung.L5X ファイルをインポートします。
      • In-Sight 5.x.x ファームウェア、および RSLogix バージョン 14 ～ 16 を使用している場合は、InSightGenEth_11_CopyRung.L5X ファイルをインポートします。
      • In-Sight 4.x.x ファームウェア、および RSLogix バージョン 17 ～ 19 を使用している場合は、InSight_11_CopyRung.L5X ファイルをインポートします。

      ファイルは次の場所に格納されています。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      注: 使用するファイルの詳細については、「Rockwell ControlLogix PLC との通信」を参照してください。

  6. [Import Configuration] ダイアログを使用して、作成されたタグの名前を設定と一致するように変更します。

    1. ジェネリックな名前がついているタグの名前を変更する必要があります。X マークの付いている上の 2 ラインの名前を変更します。

    2. [Name] フィールドの空白をクリックすると矢印が表示され、デフォルトの [Name] 構造の変更オプションがドロップダウンに表示されます。

      リストには、手順 4 で指定した名前と一致する名前が含まれています (In-Sight ビジョンシステムの名前。この例の場合には IS5705 という名前が与えられているため、リストには IS5705:I と IS5705:O が含まれます)。

      これらのジェネリックな名前を、ドロップダウンのオプションと置き換えます。

    3. 下 2 ラインも同様に編集する必要があります。名前をクリックするとカーソルアイコンが表示されます。"_In" および "_Out" の前のテキストを、ジェネリックモジュール名あるいは簡単に識別できる名前に置き換えます (この例のビジョンシステムは 1 台だけなので、"MyCamera")。

      注: このインスタンスで与えられる名前は、I/O 設定に追加されるビジョンシステムごとに一意である必要があります。複数のビジョンシステムを配置する場合は、作成されるコピーラングの各インスタンスが特定のビジョンシステムを指し示すため、ビジョンシステムごとにこれらの手順を実行する必要があります。トラブルシューティングのためにも、簡単に識別できる名前を使用してください。

    4. すべてのタグの名前がデフォルト値から更新されたら、[OK] ボタンを押します。

  7. 追加したラングの下の Main Routine に新しいラングが追加されました (空のラングは削除可能です)。

  8. プロジェクトを PLC にダウンロードし、Run Mode にしてください。

  9. コピー命令付きのラングの実行後、新規タグが [Controller Tags] テーブルに作成されます 。

    この例では、IS5705:I タグと IS5705:O タグがビジョンシステムからの未処理の入出力アセンブリであり、MyCamera_In と MyCamera_Out には、Control および Status ブロックとともに User Data および Inspection Results アレイが含まれることになります。
Version: 5.6.0


EDS 生成プロファイルを使用した接続の確立

EtherNet/IP 通信 - In-Sight 4.10.x および 5.x.x ファームウェア

In-Sight 通信リファレンス

In-Sight Explorer には、.L5X ファイルが含まれています。このファイルを使用して、PLC コントローラのタグデータをユーザフレンドリーなプログラムタグ (TestRun と一緒に In-Sight 4.10.x または 5.x.x ファームウェアが実行されている In-Sight ビジョンシステム内の信号を表す) との間でコピーすることができます。

注:

  • EDS で作成されたプロファイルを使用する場合、入力アセンブリの最大サイズが 500 バイトであっても、EDS で作成されたプロファイルは最大 496 バイトの接続しか許可しません。
  • Rockwell RSLogix Studio 5000 バージョン 21 ～ 25 を使用している場合、In-Sight EDS で作成されたプロファイルのデフォルト入出力アセンブリサイズ (各 496 バイト) は編集できず、デフォルトの最大の入出力アセンブリサイズに戻されます。
  • バージョン 19 以前の Rockwell RSLogix Studio 5000 を使用する場合は、Cognex Corporation In-Sight ビジョンシステムの固有モジュールの代わりに、Allen-Bradley Generic ETHERNET-MODULE を使用する必要があります。汎用 ETHERNET-MODULE の追加と設定の詳細については、「汎用 ETHERNET-MODULE を使用した接続の確立」のトピックを参照してください。
  1. まだインストールしていない場合は、In-Sihgt Explorer ソフトウェアに組み込まれている EDS ファイルをインストールします。

  2. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  3. Ethernet Communications Card に接続を追加します。[I/O Configuration] ノードで、Ethernet Module の下にある [Ethernet] ノードを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  4. [Select Module Type] ダイアログで、PLC に接続される In-Sight ビジョンシステムのタイプを選択し、[Create] をクリックします。

    注: 新規 EDS ファイルをロードした後は、新しいモジュールタイプが表示され、適切なモジュールが選択されます。

  5. [New Module] ダイアログで、In-Sight ビジョンシステムの名前と IP アドレスを入力して [Change...] ボタンをクリックして接続のサイズを設定します。

  6. ビジョンシステムを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造化データを作成することができます。メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。.L5X ファイルにナビゲートし、[Import...] ボタンをクリックします。

    • In-Sight 4.10.x ファームウェアを使用する場合は、次の場所にインストールされる InSight_12_CopyRung.L5X ファイルをインポートします。

      C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

    • In-Sight 5.x.x ファームウェアを使用する場合は、次の場所にインストールされる InSight_11_CopyRung.L5X ファイルをインポートします。

      C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

  7. [Import Configuration] ダイアログで、[Tags] を選択し、作成されたタグの名前を設定と一致するように変更します。
    • In-Sight 4.10.x ファームウェアを使用する場合は、[InSight_12:I] タグと [InSight_12:O] タブをプロジェクトの接続コントローラタグに設定し、In-Sight ビジョンシステム接続に与えられた名前と一致するようにします。

    • In-Sight 5.x.x ファームウェアを使用する場合は、[InSight_11:I1] タグと [InSight_11:O1] タブをプロジェクトの接続コントローラタグに設定し、In-Sight ビジョンシステム接続に与えられた名前と一致するようにします。

  8. [Import Configuration] ダイアログの [OK] ボタンをクリックしてダイアログを閉じます。汎用接続データとインポートされるラングファイルに含まれる構造化データ型の間でデータをコピーするためのコピー命令が含まれるラングがプロジェクトに追加されます。

    ラダープログラムを記述する場合は、構造化データ変数の要素を参照してください。上記のコピーラングにより、構造化データインスタンスに、および構造化データインスタンスから EtherNet/IP 接続にデータが自動的に移動されます。ダウンロードして実行し、最初にデータをコピーするタグを取得します。それ以外の場合は、SINTS の配列がすべて表示されます。
Version: 5.6.0


キーを無効にした状態でのアドオンプロファイルを使用した接続の確立

EtherNet/IP 通信 - In-Sight 4.10.x ファームウェア

In-Sight 通信リファレンス

In-Sight Explorer には、InSight_12_CopyRung.L5X インポートファイルが含まれています。このファイルを使用して、PLC コントローラのタグデータをユーザフレンドリーなプログラムタグ (TestRun と一緒に In-Sight 4.10.x が実行されている In-Sight ビジョンシステム内の信号を表す) との間でコピーすることができます。インポートファイルでは、既存のアドオンプロファイル (AOP) 信号と新しい TestRun 信号の両方が含まれるユーザ定義データ型を定義します。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. Ethernet Communications Card に接続を追加します。[I/O Configuration] ノードで、Ethernet モジュールの下にある [Ethernet] ノードを選択し、アイコンを右クリックしてメニューから [New Module] を選択します。

  3. [Select Module Type] ダイアログで、PLC に接続される In-Sight ビジョンシステムのタイプを選択し、[Create] ボタンをクリックします。

  4. [New Module] ダイアログで、In-Sight ビジョンシステムの名前と IP アドレスを入力して [Change...] ボタンをクリックします。

  5. [Module Definition (モジュール定義)] ダイアログで、リビジョン 10 を選択し、[Disable Keying (キー操作無効)] を選択します。[OK] をクリックします。

  6. ビジョンシステムを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造化データを作成することができます。メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。InSight_12_CopyRung.L5X ファイルにナビゲートし、[Import...] ボタンをクリックします。

    注: InSight_12_CopyRung.L5X ファイルは次の場所にインストールされます。

    C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

  7. [Import Configuration] ダイアログで、[Tags] を選択し、作成されたタグの名前を設定と一致するように変更します。[InSight_12:I] タグと [InSight_12:O] タグをプロジェクトの接続コントローラタグに設定し、In-Sight ビジョンシステム接続に与えられた名前と一致するようにします。

  8. [Import Configuration] ダイアログの [OK] ボタンをクリックしてダイアログを閉じます。汎用接続データとインポートされるラングファイルに含まれる構造化データ型の間でデータをコピーするためのコピー命令が含まれるラングがプロジェクトに追加されます。

    ラダープログラムを記述する場合は、構造化データ変数の要素を参照してください。上記のコピーラングにより、構造化データインスタンスに、および構造化データインスタンスから EtherNet/IP 接続にデータが自動的に移動されます。新規追加されたカメラモジュールデータはコントローラタグに存在するということに注意することは重要です。ユーザ定義データインスタンスは、プログラムタグに存在します。ラダープログラムは、プログラムタグ内のユーザ定義データインスタンスのみを参照して記述してください。ダウンロードして実行し、最初にデータをコピーするタグを取得します。それ以外の場合は、SINTS の配列がすべて表示されます。
Version: 5.6.0


例: ControlLogix 接続の検証

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

I/O メッセージングのために、ControlLogix プロジェクトに In-Sight ビジョンシステムが入出力デバイスとして追加されました。このプロジェクトがコントローラにダウンロードされた後、I/O 接続が確立されます (ほかの I/O デバイスと同様ですが、[Inhibit Module] チェックボックスが [Offline] に設定されている場合を除きます)。接続が正常に確立されると、要求された RPI で周期的なデータ転送が開始されます。

適切な I/O 接続を確認するには、次の手順を実行します。

  1. オフラインのときに、「Rockwell ControlLogix PLC との通信」に記載されている、該当する「ユニキャスト暗黙的接続の確立」のトピックの ControlLogix の設定手順を実行します。
  2. プロジェクトを ControlLogix コントローラにダウンロードします。
  3. ダウンロードの完了時に、In-Sight ビジョンシステムに対応する I/O デバイスがエラーを示さなければ、I/O 接続が正常に完了したことを意味します。
  4. I/O データの正しい双方向転送を確認するには、In-Sight Explorer を通じて In-Sight ビジョンシステムに接続します。AcquireImage プロパティシートを開き、[トリガ] パラメータを [外部] または [産業用イーサネット] に設定します。ここで、ビジョンシステムをオンラインにします。

  5. RSLogix で、コントローラタグに移動し、次に示すように、TriggerEnable ビットの状態を 0 から 1 に変更し、EtherNet/IP を介した画像取り込みのトリガを有効にします。

  6. これを設定した後、Trigger ビットが 0 から 1 に変更されると、In-Sight ビジョンシステムは画像を取り込みます。

  7. 検査が完了すると、InspectionCompleted トグルビットの状態は、次のように変更されます。


複数の PLC とのマルチキャスト非明示的メッセージ接続の確立

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

複数の PLC に検査結果を送信する場合は、マルチキャスト非明示的メッセージング接続を確立できます。マルチキャスト接続によって、接続されているすべての PLC がデータを消費できますが、データを生成できるのは 1 つの PLC のみです。In-Sight ビジョンシステムと ControlLogix コントローラの間で EtherNet/IP 非明示的メッセージング接続をセットアップするには、最初に、In-Sight ビジョンシステムを ControlLogix I/O Configuration ツリーに設定する必要があります。

マルチキャスト非明示的メッセージング接続を確立するには、最初の PLC で次の手順を実行します。

  1. オフラインのときに、「Rockwell ControlLogix PLC との通信」に記載されている、該当する「ユニキャスト暗黙的接続の確立」のトピックのステップ 1 ～ 4 を実行します。
  2. In-Sight ビジョンシステムの設定ダイアログの [General] タブ:
    • 接続を「Input (Results Only)」に設定する必要があります。
    • ビジョンシステムのサイズおよびデータタイプの入力結果は、各接続で同一である必要があります。
    • (オプション) いずれかの PLC から In-Sight ビジョンシステムにデータを書き込む場合は、[Connection] を [Data] (PLC の書き込みのみの場合は [Bidirectional]) に設定します。In-Sight ビジョンシステムに書き込みできる ControlLogix コントローラは、一度に 1 つのみです。
  3. In-Sight ビジョンシステムの設定ダイアログの [Connection] タブ:
    • RPI 値は、各々の In-Sight ビジョンシステム接続で同じである必要があります。
Version: 5.6.0


アドオンプロファイル (AOP) を使用した接続の確立

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア/In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

アドオンプロファイル (AOP) を使用して単一の ControlLogix PLC との非明示的メッセージング接続を確立するには、次の手順に従います。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. [I/O Configuration] ノードで、Ethernet モジュールの下の Ethernet ノードを選択し、アイコンを右クリックして、メニューから [New Module (新規モジュール)] を選択します。

  3. [Select Module Type (モジュールタイプの選択)] ダイアログで、使用している In-Sight ビジョンシステムを選択します。このオプションは、アドオンプロファイルをインストールした後にのみ表示されます。

  4. In-Sight ビジョンシステムを選択した後に、[New Module (新規モジュール)] ダイアログが表示されます。

    注: [Time Sync (時刻同期)] タブは、In-Sight 5000 または In-Sight 76xx ～ 79xx シリーズのビジョンシステムを使用するときに表示されます。

    [全般] タブで、以下のフィールドに値を入力します。

    • [名前]: In-Sight ビジョンシステムの名前を入力します。RSLogix 5000 で作成されるタグはこの名前に基づいています。一貫性を保つため、In-Sight ビジョンシステムの名前を使用することを推奨します。
    • [IP アドレス]: In-Sight ビジョンシステムの IP アドレスを入力します。
    • [ホスト名]: (オプション) In-Sight ビジョンシステムのホスト名を入力します。この設定は、ネットワーク上に DNS (Domain Name Server) がある場合にのみ使用してください。

  5. [接続] タブで、以下のフィールドに値を入力します。

    • [Requested Packet Interval (RPI)]: このフィールドは、RPI (Requested Packet Interval) を指定します。これは、非明示的メッセージング接続によるデータ交換の時間間隔 (ミリ秒単位) を定義します。

      注: 最良の結果を得るため、RPI 時間は、In-Sight ビジョンシステムがジョブ実行を完了してから PLC がデータを要求するまでの時間の半分以下に設定してください。
    • [Major Fault On Controller If Connection Fails While in Run Mode]: このオプションをオンにすると、コントローラは接続が失敗したときにメジャーフォールトを生成します。

    • [Inhibit Module]: PLC が In-Sight ビジョンシステムとの接続の確立を試みることができないようにする場合にオンにします。

      注: In-Sight ビジョンシステムが「スタンバイ」モードで動作を停止した場合は、モジュールを禁止して再度有効にすることによってそのモジュールを再び動作させることができます。

  6. ControlLogix にモジュールを追加すると、I/O ツリーは次のように表示されます。

  7. 続いて RSLogix 5000 により、デバイスに与えられた名前に基づいて In-Sight ビジョンシステムの入出力データにマップされるタグが作成されます。

    • [is8xxx_AOP:I Scheduled Input]: 下の表に、In-Sight ビジョンシステムから PLC に送信されるデータを示します。

    • [is8xxx_AOP:O Scheduled Output]: 以下の表に、EtherNet/IP クライアント (ControlLogix) から In-Sight ビジョンシステムに送信されるデータを示します。
Version: 5.6.0


アドオンプロファイル (AOP) リビジョン 10 から現在のリビジョン 12 への更新

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

この手順により、アドオンプロファイル (AOP) リビジョン 10 を現在のリビジョン 12 に更新することができます。ここでは、アドオンプロファイル (AOP) 1.26 (リビジョン 10) がすでにインストールされていることを前提とします。

新しいアドオンプロファイル (AOP) バージョン 1.28 (リビジョン 12 をインストール) を使用するには、次の手順に従います。

注: 開始する前に、リビジョン間のアセンブリ IO の変更を確認してください。変更内容は、入出力アセンブリの変更セクションで強調して説明されています。
  1. アドオンプロファイル (AOP) バージョン 1.28 をインストールします。

  2. カメラモジュールのプロパティを開き、[Change...] ボタンを押します。

    注: 更新後、[Input Results from Sensor (センサーからの結果入力)] と [Output Data to Sensor (センサーへのデータ出力)] のデータ型が [DINT-8] にリセットされ、[Connection] タブの [RPI] 設定が [60ms] にリセットされます。[Change...] ボタンを押す前に [Module Properties] の設定を書き留めておくことをお勧めします。後でその情報が必要になります。

  3. [Revision (リビジョン)] ドロップダウンリストからリビジョン 12 を選択します。

  4. タグ内のエラーを修正します。

    注: IO アセンブリの更新があります。以下のリストにおいて、タグを使用するラング内のエラーは赤線で囲んで示されています。

    バージョン 10 のカメラ入力/出力タグ:

    バージョン 12 のカメラ入力/出力タグ:
Version: 5.6.0


In-Sight ビジョンシステムからのデータの取得

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

In-Sight Explorer スプレッドシートから ControlLogix PLC にデータを取得するためには、WriteEIPBuffer 関数を使用して、データが EtherNet/IP スタックにプッシュされる必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータバッファを取得し、それを In-Sight ビジョンシステムの EtherNet/IP 入力アセンブリ (ネットワークへの入力) のデータ領域に書き込みます。このデータは、次の RPI サイクルで PLC に転送されます。

このデータ領域への EIP バッファの書き込みはキューに入れられます。つまり、スプレッドシートの実行中に書き込みは行われず、スプレッドシートの実行の少し後に別のイベントとして実行されます。このため、検査は短時間で完了しますが、新しいバッファの書き込みは完了しません。

ResultsValid はデータの読み取り準備ができる前には高くならず、準備ができている場合にのみ高くなるため、この設定によって発生する可能性がある PLC ロジックのわずかなタイミングのずれに関する問題を回避するには、ResultsValid を使用してデータの読み取り時期を決定することが重要です。

  • 例: In-Sight ビジョンシステムからの 32 ビット整数データの取得
  • 例: In-Sight ビジョンシステムからの浮動小数点数値データの取得

例: In-Sight ビジョンシステムからの 32 ビット整数データの取得

以下の手順で、In-Sight ビジョンシステムから ControlLogix PLC に送信されるデータの書式設定の方法を説明します。

  1. まず、In-Sight Explorer を使用して、新規ジョブを作成します。
  2. [パレット] の [スニペット] タブから、次の 2 つのスニペットをスプレッドシートに追加します。[Acquisition] → [AcqCounter] および [Math & Logic] → [Random]
  3. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  4. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。Random スニペットの「Scaled random number」セルを選択します。
  6. [FormatOutputBuffer] ダイアログで、[データ型] プルダウンメニューを使用して、[データ型] を [32 ビット整数] に変更します。

  7. [FormatOutputBuffer] ダイアログの [追加] ボタンを再びクリックします。これでセル選択モードになります。AcqCounter スニペットのカウントセルを選択します。

  8. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  9. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、[ネットワーク] サブカテゴリをクリックし、WriteEIPBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  10. WriteEIPBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer [image] データ構造体へのセル参照として設定します。
  11. In-Sight ビジョンシステムをオンラインにします。

  12. データが RSLogix 5000 の Controller → Controller Tags ノードに表示されます。

    注: データ値を表示するには、RSLogix の [Monitor Tags] タブを選択する必要があります。

例: In-Sight ビジョンシステムからの浮動小数点数値データの取得

浮動小数点データ型または等しいサイズの複数のデータ型の混合を送信する必要がある場合は、ControlLogix でユーザ定義型を作成します。浮動小数点データを In-Sight ビジョンシステムの入力タグから、新たに作成されたユーザ定義型にコピーします。

以下の手順では、2 つのセルを浮動小数点数値としてコピーする方法を説明します。

  1. In-Sight ビジョンシステムをオフラインにします。
  2. 以前に作成した FormatOutputBuffer 関数を開きます。

  3. [FormatOutputBuffer] ダイアログから、[Data Type] プルダウンメニューを使用して、[Data Type] を [32 bit integer] から [32 bit floating point] に変更します。

    注: ビジョンシステムで使用されるデータタイプの一致は、必ずしも必要とは限りません。PLC でバッファの受信に使用されるデータタイプに関係なく、ビットはビジョンシステムの出力バッファから、FormatOutputBuffer または [Format Outputs] タブに表示されている順序どおりにコピーされます。

  4. In-Sight ビジョンシステムをオンラインに戻します。
  5. RSLogix で、オフラインモードにします。
  6. RSLogix で、[Data Types] → [User-Defined] フォルダを右クリックし、メニューから [New Data Type] を選択します。

  7. 新しいデータ型にわかり易い名前を付けて、2 つの浮動小数点数値を [Members:] リストに追加します。

  8. 次に、ユーザ定義データ型を使用して、新しいタグをプロジェクトの Controller Tags に追加します。

  9. 最後に、COP 命令を MainRoutine ラダーロジックプログラムに追加します。これは、InSight_Top:I.InspectionResults[0] タグから InSight_Top_Input タグにデータをコピーします。

    注: 長さフィールドは、出力にコピーする必要がある入力構造体の数です。この場合、入力構造体は 32 ビット浮動小数点数値であるため、COP コマンドは、ビジョンシステムの出力バッファから 64 ビットを PLC のユーザ定義型にコピーします。PLC の受信バッファで 16 ビット整数型 (INT) を使用する場合、同じ 64 ビットを取得するには、長さ 4 を使用します。また、8 ビット整数型 (SINT) を使用する場合、64 ビットすべてをコピーするには、長さ 8 を使用します。

  10. このプログラムが ControlLogix PLC にダウンロードされた後、In-Sight Explorer スプレッドシートの Random セルと Acquisition Counter セルが InSight_Top_Input タグに浮動小数点形式で表示されます。
Version: 5.6.0


In-Sight ビジョンシステムへのデータの送信

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

ControlLogix PLC から In-Sight Explorer スプレッドシートにデータを送信するためには、ReadEIPBuffer 関数を使用して、データが EtherNet/IP スタックからプルされる必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータフォーマットを取得し、EtherNet/IP 出力アセンブリ (ネットワークからの出力) のデータ領域からデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに入れます。このデータは、RPI サイクルごとに PLC から受信されます。対応するスプレッドシートのデータは、スプレッドシートが実行されたときのみ更新されます。

例: In-Sight ビジョンシステムへの 32 ビット整数データの送信

この例では、In-Sight Explorer 内に新規ジョブを作成した後、以下の手順を実行して、ControlLogix PLC が受信するデータを設定します。

  1. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  2. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、2 つの 32 ビット整数をリストに追加します。

  4. [OK] ボタンをクリックして、 [FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、[ネットワーク] サブカテゴリをクリックし、ReadEIPBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. ReadEIPBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer [image] データ構造体へのセル参照として設定します。
  7. FormatOutputBuffer 関数に追加されたフィールドに基づいて、Data Access 関数が自動的にスプレッドシートに追加されます。
  8. In-Sight ビジョンシステムをオンラインモードにします。

  9. RSLogix 5000 で、[Controller Tags] ダイアログを開き、InSight_Top:O.Data[1] および InSight_Top:O.Data[2] タグの値を変更します。In-Sight Explorer スプレッドシートの値も変更されます。

例: In-Sight ビジョンシステムへの浮動小数点数値データの送信

別のデータ型、例えば、32 ビット整数型以外の型や、データ型の混合を送信する必要がある場合、最も簡単な方法は、ContorlLogix でユーザ定義型を作成して、そのデータを In-Sight ビジョンシステムの出力タグから新しく作成したユーザ定義型にコピーすることです。以下の手順では、2 つのセルを浮動小数点数値としてコピーする方法を説明します。

  1. RSLogix で、オフラインモードにします。

  2. RSLogix で、[User-Defined] → [Data Types] フォルダを右クリックし、メニューから [New Data Type] を選択します。

  3. 新しいデータ型にわかり易い名前を付けて、2 つの浮動小数点数値を [Members:] リストに追加します。

  4. 次に、下記の例のように、ユーザ定義データ型を使用して、新しいタグをプロジェクトの Controller Tags に追加します。

  5. 最後に、COP 命令を MainRoutine ラダーロジックプログラムに追加します。これは、InSight_Top_Output タグから InSight_Top:O.Data[1] タグにデータをコピーします。

  6. In-Sight ビジョンシステムをオフラインにします。
  7. 以前に作成した FormatInputBuffer 関数を開き、両方の [Data Type] の値を [32 bit floating point] に変更します。
  8. In-Sight ビジョンシステムをオンラインに戻します。

  9. このプログラムが ControlLogix PLC にダウンロードされた後、InSight_Top_Output タグ内のデータは浮動小数点形式で表示されるようになります。
Version: 5.6.0


明示的メッセージ

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

非明示的メッセージと異なり、明示的メッセージは特定のデバイスに送信され、そのデバイスは常にそのメッセージへの返信で応答します。結果として、明示的メッセージは、あまり頻繁に発生しない操作に適しています。明示的メッセージは、In-Sight ビジョンシステムの EtherNet/IP ビジョンオブジェクトの属性の読み取りと書き込みに使用できます。これらの属性は、ジョブの変更、画像の取り込み、ネイティブモードコマンドの送信、および結果データの取得に使用されます。

例: ジョブの変更

ControlLogix PLC から In-Sight ビジョンシステムに送信される最も一般的な明示的メッセージは、ジョブを変更する命令です。明示的メッセージは、MSG 命令を使用して ControlLogix PLC から送信されます。以下の手順では、RSLogix で MSG 命令を追加して、In-Sight ビジョンシステム上のジョブを変更する方法を説明します。

  1. 次のタグを ControlLogix の [Controller Tags] ダイアログに追加します。

    注: この例では、ジョブ名の最大長が 30 文字であることを前提にしています。ジョブ名がこれより長い場合は、最も長いジョブ名に 2 文字を加えた文字数に等しい SINT 構造体の数が含まれるように、SetJobData バッファを拡張する必要があります。

  2. RSLogix 5000 プロジェクトに、次のようなラダーを作成します。

    注: このスニペットは、SetJobData バッファの最初の 2 バイトにジョブ名の長さをコピーし、同じバッファの 3 番目のバイト以降に文字列データをコピーして、そのバッファをビジョンシステムの JobName 属性に送信します。ジョブ名の末尾には、「.job」のファイル拡張子を追加してください。

    このラダーは、非明示的接続で Set Offline ビットを使用して、In-Sight ビジョンシステムをオフラインにします。ビジョンオブジェクトの JobName 属性は、ジョブを変更する前に In-Sight ビジョンシステムをオフラインにする必要があるためです。Set Offline ビットは、In-Sight ビジョンシステムが Online ビットを Low にするのを待って、新規ジョブ名を含むデータをセットアップし、MSG 命令を In-Sight ビジョンシステムに送信します。ジョブの変更が完了した後、TriggerSetJob タグの立ち下がりエッジによって、In-Sight ビジョンシステムはオンラインに戻ります。

  3. MSG 命令をセットアップするには、[InSight_SetJobMsg] ボタンをクリックします。[Message Configuration] ダイアログが表示されます。

    注: この例では、ジョブ名の最大長が 30 文字であることを前提にしています。ジョブ名がこれより長い場合は、最も長いジョブ名に 2 文字を加えた文字数に等しいソース長を入力する必要があります。

    次のフィールドを設定する必要があります。

    • [Message Type]: これは、送信されるメッセージのタイプです。ビジョンオブジェクトなど、ベンダー固有のオブジェクトにメッセージを送信するには、[CIP Generic] を選択します。
    • [Service Type]: これは、オブジェクトに送信されるサービスコードです。ビジョンオブジェクトの 1 つの属性を変更するには、[Set Attribute Single] を選択します。
    • [Service Code]: このフィールドによって、任意のタイプのサービスをオブジェクトに送信できます。事前定義のサービスタイプが選択されている場合、このフィールドは無効になります。
    • [Class]: これは、メッセージが送信されるクラスの識別子です。ビジョンオブジェクトの ID は Hex 78 です。
    • [Instance]: このフィールドは、メッセージの送信先オブジェクトのインスタンス番号を指定します。In-Sight ビジョンシステムの場合、ビジョンオブジェクトは 1 つのインスタンスしか持たないため、このフィールドは 1 に設定する必要があります。
    • [Attribute]: メッセージの送信先の属性番号。この場合、JobName 属性の ID は 14 Hex です。
    • [Source Element]: このフィールドは、メッセージとともに送信されるデータのソースを示します。JobName 属性の場合、2 バイトの長さのヘッダが付いた String を送信する必要があります。この文字列は、前の手順で作成されたラダーの COP および MOV 命令を使用して書式設定されました。新規ジョブ名を JobName 属性に送信するには、このフィールドを InSight_SetJobData に設定します。
    • [Source Length]: このフィールドは、オブジェクトに送信されるソース要素のバイト数を示します。この例では、ソース要素内のすべてのデータを送信する必要があるため、32 バイトに設定します。

  4. 次に、MSG 命令に対して、明示的メッセージの送信先デバイスを指定する必要があります。[Message Configuration] ダイアログの [Communication] タブをクリックして、[Browse] ボタンをクリックします。下の図に示されているように、[I/O Configuration] から In-Sight ビジョンシステムを選択します。

  5. プログラムを ControlLogix PLC にダウンロードすると、InSight_JobName および InSight_TriggerSetJob コントローラタグを使用することによって、現在のジョブを RSLogix と交換できるようになります。

    注: ジョブ名の末尾には、「.job」の拡張子を追加してください。
  6. Job Loading、Job Load Complete、および Job Load Failed ビットを使用して、ジョブのロードの可否を判定できます。
Version: 5.6.0


[時刻同期] タブ

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

In-Sight アドオンプロファイル　(AOP)、Major Revision 10 がインストールされ、In-Sight 5000 シリーズビジョンシステムが接続されている場合、[Module Properties] ウィンドウに [Time Sync] タブが表示され、グランドマスタクロックとビジョンシステムのローカルクロックに関する情報が表示されます。このタブは読み取り専用です。

注: 時刻同期 (CIP-Sync) の詳細については、「[日付/時刻の設定] ダイアログ」と「時刻同期を設定するには」を参照してください。


Rockwell ControlLogix PLC - In-Sight 5.x.x ファームウェア

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

このトピックでは、ControlLogix PLC を In-Sight ビジョンシステム (In-Sight 5.1.0 以降のファームウェアを実行) に接続する方法、および EtherNet/IP の非明示的メッセージを送受信する方法について説明します。

  • Rockwell ControlLogix PLC　との通信

  • 非明示的メッセージ
    • ユニキャスト非明示的接続の確立 - In-Sight　5.x.x ファームウェア

    • 例: 接続のセットアップ

    • 複数の PLC とのマルチキャスト非明示的接続の確立
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信
  • 明示的メッセージ
Version: 5.6.0


ユニキャスト非明示的接続の確立

ユニキャスト非明示的接続の確立

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

ビジョンシステムに In-Sight 5.x.x ファームウェアバージョンがインストールされている場合は、PLC のプログラムに使用されている RSLogix 5000 のバージョンに応じて次の手順を実行して、In-Sight ビジョンシステムと EtherNet/IP ネットワーク上の ControlLogix または CompactLogix PLC の間でデータを転送する必要があります。

RSLogix 5000、バージョン 14 ～ 19

  1. 汎用 ETHERNET-MODULE を使用して接続を確立します。

RSLogix 5000、バージョン 20 以降

  1. In-Sihgt Explorer ソフトウェアに組み込まれている EDS ファイルをインストールします。
  2. EDS 生成プロファイルを使用して接続を確立します。
Version: 5.6.0


例: ControlLogix 接続の検証

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

I/O メッセージングのために、ControlLogix プロジェクトに In-Sight ビジョンシステムが入出力デバイスとして追加されました。このプロジェクトがコントローラにダウンロードされた後、I/O 接続が確立されます (ほかの I/O デバイスと同様ですが、[Inhibit Module] チェックボックスが [Offline] に設定されている場合を除きます)。接続が正常に確立されると、要求された RPI で周期的なデータ転送が開始されます。

適切な I/O 接続を確認するには、次の手順を実行します。

  1. オフラインのときに、「Rockwell ControlLogix PLC との通信」に記載されている、該当する「ユニキャスト暗黙的接続の確立」のトピックの ControlLogix の設定手順を実行します。
  2. プロジェクトを ControlLogix コントローラにダウンロードします。
  3. ダウンロードの完了時に、In-Sight ビジョンシステムに対応する I/O デバイスがエラーを示さなければ、I/O 接続が正常に完了したことを意味します。
  4. I/O データの正しい双方向転送を確認するには、In-Sight Explorer を通じて In-Sight ビジョンシステムに接続します。AcquireImage プロパティシートを開き、[トリガ] パラメータを [産業用イーサネット] に設定します。ここで、ビジョンシステムをオンラインにします。

  5. RSLogix で、コントローラタグに移動し、次に示すように、TriggerEnable ビットの状態を 0 から 1 に変更し、EtherNet/IP を介した画像取り込みのトリガを有効にします。

  6. これを設定した後、Trigger ビットが 0 から 1 に変更されると、In-Sight ビジョンシステムは画像を取り込みます。

  7. 検査が完了すると、InspectionCompleted トグルビットの状態は、次のように変更されます。


複数の PLC とのマルチキャスト非明示的接続の確立

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

複数の PLC に検査結果を送信する場合は、マルチキャスト非明示的メッセージング接続を確立できます。マルチキャスト接続によって、接続されているすべての PLC がデータを消費できますが、データを生成できるのは 1 つの PLC のみです。In-Sight ビジョンシステムと ControlLogix コントローラの間で EtherNet/IP 非明示的メッセージング接続をセットアップするには、最初に、In-Sight ビジョンシステムを ControlLogix I/O Configuration ツリーに設定する必要があります。

マルチキャスト非明示的メッセージング接続を確立するには、最初の PLC で次の手順を実行します。

  1. オフラインのときに、「Rockwell ControlLogix PLC との通信」に記載されている、該当する「ユニキャスト暗黙的接続の確立」のトピックのステップ 1 ～ 4 を実行します。
  2. In-Sight ビジョンシステムの設定ダイアログの [General] タブ:
    • 接続を「Input (Results Only)」に設定する必要があります。
    • ビジョンシステムのサイズおよびデータタイプの入力結果は、各接続で同一である必要があります。
    • (オプション) いずれかの PLC から In-Sight ビジョンシステムにデータを書き込む場合は、[Connection] を [Data] (PLC の書き込みのみの場合は [Bidirectional]) に設定します。In-Sight ビジョンシステムに書き込みできる ControlLogix コントローラは、一度に 1 つのみです。

  3. In-Sight ビジョンシステムの設定ダイアログの [Connection] タブ:

    • RPI 値は、各々の In-Sight ビジョンシステム接続で同じである必要があります。
Version: 5.6.0


新規アドオンプロファイル (AOP) による以前にインストールされた EDS プロファイルの更新

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

この手順では、EDS ファイルを含む RSLogix プロジェクトで In-Sight ビジョンシステムが設定されていることを前提としています。

注: バージョン 14 以前の Rockwell RSLogix Studio 5000 を使用する場合は、Allen-Bradley 汎用 ETHERNET-MDULE を使用する必要があります。

  1. アドオンプロファイル (AOP) 1.28 をインストールします。

    アドオンプロファイル (AOP) カメラモジュールと交換する EDS 生成プロファイルカメラの名前と IP アドレスを書き留めます。この情報は後で必要になります。

  2. モジュールリストから EDS カメラを削除します (タグエラーが表示されます)。

    モジュールリストから EDS カメラを削除すると、コントローラタグが削除されます。これにより、ラダー内のタグが未定義タグとして残され、ラングに赤で X または e (エラーの場合) のマークが付きます。

  3. アドオンプロファイル (AOP) モジュールを使用してカメラを追加して戻し、削除したカメラと同じ名前および IP アドレスを使用します。アイコンがグレーの Rockwell Automation モジュールになります。

  4. EDS 生成カメラで必要とされるコピーラングを削除します。

    アドオンプロファイル (AOP) では、[Controller] → [Controller Tags] にモジュール定義タイプとコントローラタグが構造化データとして作成されるため、それらのコピーラングは不要になります。以前は、[Main Program] の下の非構造化データを構造化コントローラタグに移動するためにこれらのラングが必要でした。

    アドオンプロファイル (AOP) では、In-Sight から PLC にデータを送信する場合、In-Sight: In-Sight Name:I の入力コントローラタグにデータが表示されます。PLC から In-Sight にデータを送信する場合は、In-Sight: In-Sight Name: O の出力コントローラタグにデータが表示されます

  5. すべてのカメラタグを検索して置き換え、新しいタグ名でそれらのタグを更新します。

    さらに、構造化タグを検索して置き換えます。これらの参照名を、新規のカメラ名 In-Sight Name:I と In-Sight Name: O で置き換えます。

    EDS インストールラダーでは、ラングインポートから作成される insight11_in タグと insight11_out タグを使用します。これらのタグでは、制御とステータスの信号を細かくマップするユーザ定義タイプが使用されます。これらのラングは不要になったため、それらのタグを検索して In-Sight Name:I および In-Sight Name:O で置き換えます。タグ名と信号名のステータスおよび制御の部分は同じまま残されます。

    以下に、EDS プロファイルとアドオンプロファイル (AOP) によるビジョンシステムの設定例を示します。EDS プロファイルによって設定されたビジョンシステムの場合は各タグの終わりに数字の「1」が付加され、アドオンプロファイル (AOP) によって設定されたシステムの場合には付加されません。
Version: 5.6.0


In-Sight ビジョンシステムからのデータの取得

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

In-Sight Explorer スプレッドシートから ControlLogix PLC にデータを取得するためには、WriteResultsBuffer 関数を使用して、データが EtherNet/IP スタックにプッシュされる必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータバッファを取得し、それを In-Sight ビジョンシステムの EtherNet/IP 入力アセンブリ (ネットワークへの入力) のデータ領域に書き込みます。このデータは、次の RPI サイクルで PLC に転送されます。

このデータ領域への EtherNet/IP バッファの書き込みはキューに入れられます。つまり、スプレッドシートの実行中に書き込みは行われず、スプレッドシートの実行の少し後に別のイベントとして実行されます。このため、検査は短時間で完了しますが、新しいバッファの書き込みは完了しません。

ResultsValid はデータの読み取り準備ができる前には高くならず、準備ができている場合にのみ高くなるため、この設定によって発生する可能性がある PLC ロジックのわずかなタイミングのずれに関する問題を回避するには、ResultsValid を使用してデータの読み取り時期を決定することが重要です。

  • 例: In-Sight ビジョンシステムからの 32 ビット整数データの取得
  • 例: In-Sight ビジョンシステムからの浮動小数点数値データの取得

例: In-Sight ビジョンシステムからの 32 ビット整数データの取得

以下の手順で、In-Sight ビジョンシステムから ControlLogix PLC に送信されるデータの書式設定の方法を説明します。

  1. まず、In-Sight Explorer を使用して、新規ジョブを作成します。
  2. [パレット] の [スニペット] タブから、次の 2 つのスニペットをスプレッドシートに追加します。[Acquisition] → [AcqCounter] および [Math & Logic] → [Random]
  3. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  4. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。Random スニペットの「Scaled random number」セルを選択します。
  6. [FormatOutputBuffer] ダイアログで、[データ型] プルダウンメニューを使用して、[データ型] を [32 ビット整数] に変更します。

  7. [FormatOutputBuffer] ダイアログの [追加] ボタンを再びクリックします。これでセル選択モードになります。AcqCounter スニペットのカウントセルを選択します。

  8. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  9. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、[ネットワーク] サブカテゴリをクリックし、WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  10. WriteResultsBuffer 関数の [プロトコル] パラメータを EtherNet/IP に設定し、[バッファ] パラメータを、作成した FormatOutputBuffer [image] データ構造体へのセル参照として設定します。WriteResultsBuffer の [Result Code] パラメータの値を 3 に設定するか、整数データの任意のセルを参照します。
  11. In-Sight ビジョンシステムをオンラインにします。

  12. データが RSLogix 5000 の Controller → Controller Tags ノードに表示されます。

    注: データ値を表示するには、RSLogix の [Monitor Tags] タブを選択する必要があります。

例: In-Sight ビジョンシステムからの浮動小数点数値データの取得

浮動小数点データ型または等しいサイズの複数のデータ型の混合を送信する必要がある場合は、ControlLogix でユーザ定義型を作成します。浮動小数点データを In-Sight ビジョンシステムの入力タグから、新たに作成されたユーザ定義型にコピーします。

以下の手順では、2 つのセルを浮動小数点数値としてコピーする方法を説明します。

  1. In-Sight ビジョンシステムをオフラインにします。
  2. 以前に作成した FormatOutputBuffer 関数を開きます。

  3. [FormatOutputBuffer] ダイアログから、[Data Type] プルダウンメニューを使用して、[Data Type] を [32 bit integer] から [32 bit floating point] に変更します。

    注: ビジョンシステムで使用されるデータタイプの一致は、必ずしも必要とは限りません。PLC でバッファの受信に使用されるデータタイプに関係なく、ビットはビジョンシステムの出力バッファから、FormatOutputBuffer または [Format Outputs] タブに表示されている順序どおりにコピーされます。
  4. In-Sight ビジョンシステムをオンラインに戻します。
  5. RSLogix で、オフラインモードにします。

  6. RSLogix で、[Data Types] → [User-Defined] フォルダを右クリックし、メニューから [New Data Type] を選択します。

  7. 新しいデータ型にわかり易い名前を付けて、2 つの浮動小数点数値を [Members:] リストに追加します。

  8. 次に、ユーザ定義データ型を使用して、新しいタグをプロジェクトの Controller Tags に追加します。

  9. 最後に、COP 命令を MainRoutine ラダーロジックプログラムに追加します。これは、InSight_Top:I.InspectionResults[0] タグから InSight_Top_Input タグにデータをコピーします。

    注: 長さフィールドは、出力にコピーする必要がある入力構造体の数です。この場合、入力構造体は 32 ビット浮動小数点数値であるため、COP コマンドは、ビジョンシステムの出力バッファから 64 ビットを PLC のユーザ定義型にコピーします。PLC の受信バッファで 16 ビット整数型 (INT) を使用する場合、同じ 64 ビットを取得するには、長さ 4 を使用します。また、8 ビット整数型 (SINT) を使用する場合、64 ビットすべてをコピーするには、長さ 8 を使用します。

  10. このプログラムが ControlLogix PLC にダウンロードされた後、In-Sight Explorer スプレッドシートの Random セルと Acquisition Counter セルが InSight_Top_Input タグに浮動小数点形式で表示されます。
Version: 5.6.0


In-Sight ビジョンシステムへのデータの送信

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

ControlLogix PLC から In-Sight Explorer スプレッドシートにデータを送信するためには、ReadUserDataBuffer 関数を使用して、データが EtherNet/IP スタックからプルされる必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータフォーマットを取得し、EtherNet/IP 出力アセンブリ (ネットワークからの出力) のデータ領域からデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに入れます。このデータは、RPI サイクルごとに PLC から受信されます。対応するスプレッドシートのデータは、スプレッドシートが実行されたときのみ更新されます。

例: In-Sight ビジョンシステムへの 32 ビット整数データの送信

この例では、In-Sight Explorer 内に新規ジョブを作成した後、以下の手順を実行して、ControlLogix PLC が受信するデータを設定します。

  1. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  2. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、2 つの 32 ビット整数をリストに追加します。

  4. [OK] ボタンをクリックして、 [FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして、[関数の挿入] を選択します。画面左側の [入出力] カテゴリを展開し、[ネットワーク] サブカテゴリをクリックし、ReadUserDataBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. ReadUserDataBuffer 関数の [プロトコル] パラメータを EtherNet/IP に設定し、[バッファ] パラメータを、作成した FormatOutputBuffer [image] データ構造体へのセル参照として設定します。
  7. FormatOutputBuffer 関数に追加されたフィールドに基づいて、Data Access 関数が自動的にスプレッドシートに追加されます。
  8. In-Sight ビジョンシステムをオンラインモードにします。
  9. RSLogix 5000 で、[Controller Tags] ダイアログを開き、InSight_Top:O.Data[0] および InSight_Top:O.Data[1] タグの値を変更します。

  10. User Data ハンドシェークが必要かどうかを判断します。User Data バイパスが有効な場合、データの交換は 4.xx カメラの交換をコピーします。User Data バイパスが有効ではない場合 (デフォルト状態)、この新規ビットにより、PLC と In-Sight の間のデータ交換に追加のハンドシェークが追加されます。スプレッドシートのデータを表示するには、追加の手順を実行する必要があります。

    1. カメラの [ネットワークの設定] ダイアログで [ユーザデータバイパスの有効化] が有効になっている場合、In-Sight Explorer スプレッドシートの値が直ちに更新されます。

    2. カメラの [ネットワークの設定] ダイアログで [ユーザデータバイパスの有効化] が有効になっていない場合:

      1. User Data タグを設定します。SetUserData ビットは名前付きタグ (この例では InSight_Top:O.Control.SetUserData) です。

      2. User Data Ack ビットを受信したら、上の User Data タグをクリアします。SetUserDataAck ビットは名前付きタグ (この例では InSIght_Top:I.Status. SetUserDataAck) です。

例: In-Sight ビジョンシステムへの浮動小数点数値データの送信

別のデータ型、例えば、32 ビット整数型以外の型や、データ型の混合を送信する必要がある場合、最も簡単な方法は、ContorlLogix でユーザ定義型を作成して、そのデータを In-Sight ビジョンシステムの出力タグから新しく作成したユーザ定義型にコピーすることです。以下の手順では、2 つのセルを浮動小数点数値としてコピーする方法を説明します。

  1. RSLogix で、オフラインモードにします。

  2. RSLogix で、[User-Defined] → [Data Types] フォルダを右クリックし、メニューから [New Data Type] を選択します。

  3. 新しいデータ型にわかり易い名前を付けて、2 つの浮動小数点数値を [Members:] リストに追加します。

  4. 次に、下記の例のように、ユーザ定義データ型を使用して、新しいタグをプロジェクトの Controller Tags に追加します。

  5. 最後に、COP 命令を MainRoutine ラダーロジックプログラムに追加します。これは、InSight_Top_Output タグのデータを InSight_Top:O.UserData[0] タグと InSight_Top:O.UserData[1] タグにコピーします。

  6. In-Sight ビジョンシステムをオフラインにします。
  7. 以前に作成した FormatInputBuffer 関数を開き、両方の [Data Type] の値を [32 bit floating point] に変更します。
  8. In-Sight ビジョンシステムをオンラインに戻します。
  9. このプログラムが ControlLogix PLC にダウンロードされた後、InSight_Top_Output タグ内のデータは浮動小数点形式で表示されるようになります。

  10. User Data ハンドシェークが必要かどうかを判断します。User Data バイパスが有効な場合、データの交換は 4.xx カメラの交換をコピーします。User Data バイパスが有効ではない場合 (デフォルト状態)、この新規ビットにより、PLC と In-Sight の間のデータ交換に追加のハンドシェークが追加されます。スプレッドシートのデータを表示するには、追加の手順を実行することが必要になります。

    1. カメラの [ネットワークの設定] ダイアログで [ユーザデータバイパスの有効化] が有効になっている場合 (チェックボックスがオン)、In-Sight Explorer スプレッドシートの値が直ちに更新されます。

    2. カメラの [ネットワークの設定] ダイアログで [ユーザデータバイパスの有効化] が有効になっていない場合　(デフォルト状態がオフ):

      1. User Data タグを設定します。SetUserData ビットは名前付きタグ (この例では InSight_Top:O.Control.SetUserData) です。

      2. User Data Ack ビットを受信したら、上の User Data タグをクリアします。SetUserDataAck ビットは名前付きタグ (この例では InSight_Top:I.Status. SetUserDataAck) です。
Version: 5.6.0


明示的メッセージ - In-Sight ファームウェア 5.x.x

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

非明示的メッセージと異なり、明示的メッセージは特定のデバイスに送信され、そのデバイスは常にそのメッセージへの返信で応答します。結果として、明示的メッセージは、あまり頻繁に発生しない操作に適しています。明示的メッセージは、In-Sight ビジョンシステムの EtherNet/IP ビジョンオブジェクトの属性の読み取りと書き込みに使用できます。これらの属性は、ジョブの変更、画像の取り込み、ネイティブモードコマンドの送信、および結果データの取得に使用されます。

例: ジョブの変更

ControlLogix PLC から In-Sight ビジョンシステムに送信される最も一般的な明示的メッセージは、ジョブを変更する命令です。明示的メッセージは、MSG 命令を使用して ControlLogix PLC から送信されます。以下の手順では、RSLogix で MSG 命令を追加して、In-Sight ビジョンシステム上のジョブを変更する方法を説明します。

  1. 次のタグを ControlLogix の [Controller Tags] ダイアログに追加します。

    注: この例では、ジョブ名の最大長が 30 文字であることを前提にしています。ジョブ名がこれより長い場合は、最も長いジョブ名に 2 文字を加えた文字数に等しい SINT 構造体の数が含まれるように、SetJobData バッファを拡張する必要があります。

  2. RSLogix 5000 プロジェクトに、次のようなラダーを作成します。

    注: このスニペットは、SetJobData バッファの最初の 2 バイトにジョブ名の長さをコピーし、同じバッファの 3 番目のバイト以降に文字列データをコピーして、そのバッファをビジョンシステムの JobName 属性に送信します。ジョブ名の末尾には、「.job」のファイル拡張子を追加してください。

    このラダーは、非明示的接続で Set Offline ビットを使用して、In-Sight ビジョンシステムをオフラインにします。ビジョンオブジェクトの JobName 属性は、ジョブを変更する前に In-Sight ビジョンシステムをオフラインにする必要があるためです。Set Offline ビットは、In-Sight ビジョンシステムが Online ビットを Low にするのを待って、新規ジョブ名を含むデータをセットアップし、MSG 命令を In-Sight ビジョンシステムに送信します。ジョブの変更が完了した後、TriggerSetJob タグの立ち下がりエッジによって、In-Sight ビジョンシステムはオンラインに戻ります。

  3. MSG 命令をセットアップするには、[InSight_SetJobMsg] ボタンをクリックします。[Message Configuration] ダイアログが表示されます。

    注: この例では、ジョブ名の最大長が 30 文字であることを前提にしています。ジョブ名がこれより長い場合は、最も長いジョブ名に 2 文字を加えた文字数に等しいソース長を入力する必要があります。

    次のフィールドを設定する必要があります。

    • [Message Type]: これは、送信されるメッセージのタイプです。ビジョンオブジェクトなど、ベンダー固有のオブジェクトにメッセージを送信するには、[CIP Generic] を選択します。
    • [Service Type]: これは、オブジェクトに送信されるサービスコードです。ビジョンオブジェクトの 1 つの属性を変更するには、[Set Attribute Single] を選択します。
    • [Service Code]: このフィールドによって、任意のタイプのサービスをオブジェクトに送信できます。事前定義のサービスタイプが選択されている場合、このフィールドは無効になります。
    • [Class]: これは、メッセージが送信されるクラスの識別子です。ビジョンオブジェクトの ID は Hex 78 です。
    • [Instance]: このフィールドは、メッセージの送信先オブジェクトのインスタンス番号を指定します。In-Sight ビジョンシステムの場合、ビジョンオブジェクトは 1 つのインスタンスしか持たないため、このフィールドは 1 に設定する必要があります。
    • [Attribute]: メッセージの送信先の属性番号。この場合、JobName 属性の ID は 14 Hex です。
    • [Source Element]: このフィールドは、メッセージとともに送信されるデータのソースを示します。JobName 属性の場合、2 バイトの長さのヘッダが付いた String を送信する必要があります。この文字列は、前の手順で作成されたラダーの COP および MOV 命令を使用して書式設定されました。新規ジョブ名を JobName 属性に送信するには、このフィールドを InSight_SetJobData に設定します。
    • [Source Length]: このフィールドは、オブジェクトに送信されるソース要素のバイト数を示します。この例では、ソース要素内のすべてのデータを送信する必要があるため、32 バイトに設定します。

  4. 次に、MSG 命令に対して、明示的メッセージの送信先デバイスを指定する必要があります。[Message Configuration] ダイアログの [Communication] タブをクリックして、[Browse] ボタンをクリックします。下の図に示されているように、[I/O Configuration] から In-Sight ビジョンシステムを選択します。

  5. プログラムを ControlLogix PLC にダウンロードすると、InSight_JobName および InSight_TriggerSetJob コントローラタグを使用することによって、現在のジョブを RSLogix と交換できるようになります。

    注: ジョブ名の末尾には、「.job」の拡張子を追加してください。
  6. Command Executing ビット (最大で 2 秒間オンにすることが可能) と Command Failed ビットを使用して、ジョブが正常にロードされたかどうかを判断できます。
Version: 5.6.0


RSLogix PLC から非明示的にジョブを開く場合の例

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

  1. Set Offline ビットをハイ (High) にセットすることにより、In-Sight ビジョンセンサをオフラインにします。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

  2. ジョブ ID をコマンドブロックのバイト 4 および 5 に設定します。センサに保存されているジョブの名前は、ジョブ ID 番号 (0-999) から始まる必要があります。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

    バイト 4 ～ 5

    バイト | 名前 | 説明
    4 ～ 5 | Command | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。

  3. コマンドブロックの Execute Command ビットをセットします。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

    バイト 0

    ビット | 名前 | 説明
    7 Set Offline

    このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
    6 ～ 5 | Reserved | 未使用。
    4 | Execute Command | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。

  4. Execute Command ビットと Offline ビットをクリアするまでに、Command Complete がセットされるまで待ちます。Command が正常に完了しなかった場合は、Command Failed ビットもセットされます。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    13 0 Online

    Offline

    Reason

    Missed

    Acq

             Reserved

    Trigger

    Ack

    Trigger

    Ready
    1 Error

    Command

    Failed

    Command

    Completed

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    2 Reserved Reserved Reserved

    Job

    Pass

    Exposure

    Complete

             Reserved Reserved

    Set User

    Data Ack
    3

    Soft

    Event

    Ack 7

    Soft

    Event

    Ack 6

    Soft

    Event

    Ack 5

    Soft

    Event

    Ack 4

    Soft

    Event

    Ack 3

    Soft

    Event

    Ack 2

    Soft

    Event

    Ack 1

    Soft

    Event

    Ack 0
    4 | Error Code (16 ビット整数)
    5
    6 | Reserved (16 ビット整数)
    7
    8 | Current Job ID (16 ビット整数)
    9
    10 | Acquisition ID (16 ビット整数)
    11
    12 | Inspection ID (16 ビット整数)
    13
    14 | Inspection Result Code (16 ビット整数)
    15
    16 | Inspection Results 0
    ...
    499 | Inspection Results 483

    バイト 1

    ビット | 名前 | 説明
    7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
    6 | Command Failed | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
    5 Command Completed

    このビットは、[ジョブを開く] が完了したことを示すためにセットされます。コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。
Version: 5.6.0


RSLogix PLC から名前によってジョブを開く

EtherNet/IP による通信

In-Sight 通信リファレンス
注: 名前によってジョブを開く機能は、In-Sight ファームウェア 5.5.0 以降が実行されている In-Sight ビジョンシステムでのみ使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  1. Set Offline ビットをハイ (High) にセットすることにより、カメラをオフラインにします。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

  2. コマンドブロックのバイト 4 と 5 に Job Load by Name コマンドを書き込みます。Job Load by Name コマンドの値は 0x4000 です。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

    バイト 4 ～ 5

    バイト | 名前 | 説明
    4 ～ 5 | Command | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。

  3. コマンドブロックのバイト 8 ～ 495 (UserData) にジョブ名を書き込みます。ジョブ名は null で終了する必要があります (バイト内のジョブ名の直後に 0 を付加する必要があります)。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

  4. コマンドブロックの Execute Command ビットをセットします。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    22 0 Set Offline Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

             Reserved

    Set User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0
    4 | Command
    5
    6 ..7 | Reserved
    8 | User Data 0
    ...
    495 | User Data 487

    バイト 0

    ビット | 名前 | 説明
    7 Set Offline

    このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
    6 ～ 5 | Reserved | 未使用。
    4 | Execute Command | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。

  5. Execute Command ビットと Offline ビットをクリアする前に、Command Complete または Command Failed がセットされるのを待ちます。

    インスタンス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
    13 0 Online

    Offline

    Reason

    Missed

    Acq

             Reserved

    Trigger

    Ack

    Trigger

    Ready
    1 Error

    Command

    Failed

    Command

    Completed

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    2 Reserved Reserved Reserved

    Job

    Pass

    Exposure

    Complete

             Reserved Reserved

    Set User

    Data Ack
    3

    Soft

    Event

    Ack 7

    Soft

    Event

    Ack 6

    Soft

    Event

    Ack 5

    Soft

    Event

    Ack 4

    Soft

    Event

    Ack 3

    Soft

    Event

    Ack 2

    Soft

    Event

    Ack 1

    Soft

    Event

    Ack 0
    4 | Error Code (16 ビット整数)
    5
    6 | Reserved (16 ビット整数)
    7
    8 | Current Job ID (16 ビット整数)
    9
    10 | Acquisition ID (16 ビット整数)
    11
    12 | Inspection ID (16 ビット整数)
    13
    14 | Inspection Result Code (16 ビット整数)
    15
    16 | Inspection Results 0
    ...
    499 | Inspection Results 483

    バイト 1

    ビット | 名前 | 説明
    7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
    6 | Command Failed | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
    5 Command Completed コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。
    注: Execute Command ビットが Low になると、カメラは Command Completed ビットをクリアします。
Version: 5.6.0


Rockwell SLC 5/05 PLC との通信

EtherNet/IP による通信

In-Sight 通信リファレンス

  • 概要
  • 必須コンポーネント
  • RSLogix 500 の使用
  • メッセージ (MSG) 命令
  • MSG 命令の設定画面
  • MSG 命令を使用したデータの受信
  • SLC5/05 からのネイティブモードコマンドの送信
  • メッセージ命令の結果

概要

このセクションでは、In-Sight ビジョンシステムと PLC 間における PCCC (PC3) 通信の設定についての概要を示します。この例では Allen-Bradley SLC5/05 と Rockwell 500 ソフトウェアを使用します。

注: In-Sight ファームウェア 5.1.0 以降が実行されている In-Sight ビジョンシステムでは、EtherNet/IP PCCC 通信をサポートしていません。

必須コンポーネント

  • ファームウェアバージョン 2.2 ～ 4.9.1 が実行されている In-Sight ビジョンシステム
  • Rockwell RSLogix 500 プログラミングソフトウェア (バージョン 4.5 以降)
  • RSLogix500 をサポートする対応するファームウェアがインストールされている Allen-Bradley SLC5/05 コントローラ

RSLogix 500 の使用

  1. RSLogix 500 ソフトウェアプログラムから .RSS ファイルを開き、[Channel Configuration (チャンネル設定)] ダイアログ ([プロジェクトフォルダ] → [Controller Folder (コントローラフォルダ)] → [Channel Configuration (チャンネル設定)]) を開きます。

  2. Allen-Bradley SLC では 2 つのチャンネルを設定できます。チャンネル 1 (Ethernet) とチャンネル 0 (DF1 全二重 - シリアル) です。[Chan.1 - System (チャンネル 1 - システム)] タブをクリックします。
  3. 必要に応じてチャンネル 1 (Ethernet) を設定します。適切な設定についてはネットワーク管理者に問い合わせてください。

注: PLC と In-Sight ビジョンシステムでの IP/Subnet/Gateway パラメータが正しいことを検証します。

  4. 必要に応じて [タイムアウト] を設定します。

注: 接続タイムアウトと応答タイムアウトはミリ秒単位、非アクティブ状態は秒単位です。これらのパラメータにより、要求を送受信するときにシステムによって後で使用される Message Timeout パラメータの値が決まります。([Msg Connection Timeout (メッセージ接続タイムアウト)] + [Msg Reply Timeout (メッセージ応答タイムアウト)] + 5 ミリ秒 = [Msg Timeout (メッセージタイムアウト)])

メッセージ (MSG) 命令

アプリケーション内でメッセージ命令を設定できるようになりました。メッセージ作成のための拡張指示については、RSLogix 500 のドキュメントを参照してください。

メッセージ (MSG) 命令内では次の設定パラメータを設定することができます。

  • Type: Peer-To-Peer。変更できません。
  • Read/Write: In-Sight ビジョンシステムで実行する機能を選択します。[Read] を選択すると DataMan からデータが取得され、[Write] を選択すると DataMan にデータが送信されます。
  • Target Device: In-Sight ビジョンシステムと通信するには [PLC5] を選択します。これによって SLC が使用する通信プロトコルを指定します。In-Sight ビジョンシステムの動作は ControlLogix コントローラの動作によく似ています (Rockwell のマニュアル 13862 を参照)。
  • [Local/Remote (ローカル/リモート)]: In-Sight ビジョンシステムが SLC と同じネットワーク上にあることを示すには [Local] を選択します。[Remote] を選択すると、別のネットワーク上にある In-Sight と通信することが SLC に指示されます。リモート通信では、セカンダリネットワークへのゲートウェイとして機能する別のデバイスを通じてメッセージを直接送信する必要があります。通常、Allen-Bradley ControlLogix コントローラがその役割を果たします(ゲートウェイを介してほかのネットワーク上のデバイスのアドレスを指定する方法については、Rockwell のドキュメントを参照してください)。
  • Control Block: これは MSG 命令でデータ (IP アドレス、メッセージタイプなど) を格納するために使用する一時整数ファイルです。通常、送信されるユーザデータではありません。
  • Control Block Length: これは MSG 命令によって自動的に計算されます。
  • Setup Screen: 「Setup Screen」を選択すると、[Message Instruction Setup (メッセージ命令の設定)] ダイアログが開きます。

MSG 命令の設定画面

[MSG Instruction Setup (メッセージ命令の設定)] 画面では次の設定パラメータを設定することができます。

[全般] タブ

[This Controller (このコントローラ)] セクション:

  • [Communication Command (通信コマンド)]: 最初の画面 (MSG 命令画面) で選択されたコマンド (READ/WRITE) と同じである必要があります。
  • [Data Table Address (データテーブルアドレス)]: これは SLC でデータの書き込み先 (READ) または送信元 (WRITE) になるデータファイルの場所です (MSG 命令画面と同様)。このインスタンス 'F8:0' において、'F' は浮動小数点値ファイルを、'8' はファイル番号 8 を、'0' はそのファイルへのオフセット (この場合は 0 番目の要素から始まります) を示します。次の図に、RSLogix 500 メイン画面からアクセスする浮動小数点値テーブルの例を示します。

  • [Size in Elements (要素のサイズ)]: これは、送信する要素 (または個々のデータ) の数です。この例では、2 つの要素　(3.14　および 78.87) が送信されます。
  • [Channel (チャンネル)]: SLC の設定によって異なります。SLC では、チャンネル 1 は Ethernet ポートです。

[Target Device (ターゲットデバイス)] セクション:

  • [Message Timeout (メッセージのタイムアウト)]: In-Sight ビジョンシステムが応答することができる適切な時間の長さを選択します。In-Sight がこの時間内に応答しない場合、MSG 命令はエラー終了します。この画面からは、このパラメータを変更することはできません。[Message Timeout (メッセージのタイムアウト)] は、[Channel 1 setup (チャンネル 1 の設定)] ダイアログで入力したパラメータによって決まります (「RSLogix 500 の使用」の手順 4 を参照)。
  • [Data Table Address (データテーブルアドレス)]: これは、データの読み取り/書き込みが行われる In-Sight ビジョンシステム上の場所です。このインスタンス 'F8:1' において、'F' は浮動小数点型 (real) のデータを、'8' は In-Sight が無視することを示します。(データは常に入力アセンブリに書き込まれ、出力アセンブリから読み取られます)。'1' は、READ または WRITE が実行されているかどうかに基づいて異なる意味を持ちます。

WRITE が発生している場合、'1' は、入力アセンブリのデータ部分への実際のデータバイトオフセットを示します。READ が発生している場合、'1' は要素を示します。次に例を示します。メッセージが READ であった場合は、'F8:2' によって 3 番目の要素 (SLC のインデックスはゼロから始まるため、':2' は 3 番目の要素を指します) を読み取るよう指示されます。これは、(READ では In-Sight の出力アセンブリからデータを取得するため) 出力アセンブリからの浮動小数点型の要素です。メッセージが WRITE であった場合は、'F8:12' により、入力アセンブリのデータ部分の 12 番目のバイトに浮動小数点値を書き込むよう指示されます。WRITE は、データの書き込みを開始するアセンブリの実際のバイトを示し、READ は実際のデータ要素を示します。

注: ST10:0 の宛先アドレスは、ネイティブモードコマンドを In-Sight ビジョンシステムに送信する場合に使用されます。文字列またはほかのデータ型を In-Sight に送信するには、ST10:0 以外の宛先アドレスを使用します。

  • [Local/Remote (ローカル/リモート)]: アプリケーションに応じて、[ローカル] または [リモート] に設定されます。
  • MultiHop (マルチホップ): この設定は以前に入力した情報によって異なります。In-Sight 通信を正常に行うため、この時点では [YES(あり)] にする必要があります。

[MultiHop] タブ

[MultiHop] タブは、In-Sight システムのアドレスとコントローラの場所を識別するために使用されます。In-Sight ビジョンシステムへの通信を経路指定するため、両方の情報を指定する必要があります。前述のとおり、In-Sight ビジョンシステムは、PC3 の通信時に ControlLogix モジュールとして動作します。

MSG 命令を使用したデータの受信

次の例では、In-Sight スプレッドシートに、MapSpec の値が '0f:4f:8il:10il:12il' の WriteEIP 関数が格納されたセルがあることを前提としています。

例:

RSLogix500 の MSG 命令では、ターゲットデバイスのデータテーブルアドレスが 'N8:2' (DTA = 'N8:2') になっており、3 つの要素 (n = 3) を要求しています。

MSG 命令において、'N' は整数が転送されることを、'2' は MapSpec の 3 番目の項目から始まることを示しています。

注: すべての MapSpec パラメータはゼロから始まります。

In-Sight ビジョンシステムは、MapSpec (8il) の 3 番目の項目のデータと、それに続く 10il と 12 il のデータ (3 要素、すべて整数) で応答します。

例:

DTA = 'F8: 1' n = 2

応答は 4f (MapSpec の 2 番目の項目) のデータとなり、In-Sight は 8il と 10il でのすべてのデータを組み合わせて 2 番目の浮動小数点値を生成しようと試みます。連続する類似の要素 (2 浮動小数点値、42 整数、13 文字など) のみを要求可能です。

例:

DTA = 'F8: 0' n = 2

応答は 0f と 4f (2 要素、どちらも浮動小数点値) のデータになります。

例:

DTA = 'N8: 3' n = 2

応答は 10il と 12il (2 要素、どちらも整数) のデータになります。この例では、同じ型の連続する要素を取得できるようにしています。

SLC5/05 からのネイティブモードコマンドの送信

  1. 必要に応じて SLC5/05 を設定します。
  2. ネイティブモードコマンドを格納する文字列テーブルを作成します。

  3. 必要なネイティブモードコマンドの文字列をデータファイルに追加します。

  4. 新しいメッセージ (MSG) 命令をラダーロジックに追加し、次の例のように設定します。

  5. [MSG Setup (MSG 設定)] 画面で次のように設定します。

このコントローラ (SLC) | パラメータ | 説明
[Data Table Address (データテーブルアドレス)]: | ST10:1 | 前に作成した文字列テーブル (ST) からの最初の要素
[Size in Elements (要素のサイズ)]: | 1 | 常に 1 に設定します。PCCC MSG で同時に送信できる文字列は 1 つ (従って 1 つのコマンド) のみです。
[Channel (チャンネル)]: | 1 | コントローラの Ethernet チャンネルに設定します。
ターゲットデバイス (In-Sight センサ) | パラメータ | 説明
[Message Timeout (メッセージのタイムアウト)]: | ([Channel Configuration (チャンネル設定)] ダイアログから)
[Data Table Address (データテーブルアドレス)]: | ST10:0 | これは宛先アドレスです。ネイティブモードコマンドの場合は常に ST10:0 になります。
  6. [MultiHop] タブをクリックし、必要に応じて設定します。

例: この例では、In-Sight ビジョンシステムの宛先 IP アドレスのみを設定する必要があります。

  7. すべて設定し終えたら、MSG ウィンドウを閉じます。
  8. ラダーロジックを保存してコントローラにダウンロードし、オンラインでコントローラを実行モードに設定します。
  9. メッセージをトリガして In-Sight ビジョンシステムに送信します。

メッセージ命令の結果

命令への入力が high に設定されると、メッセージ命令の有効化 (EN) ビットが 1 に設定されます。ネイティブモードコマンドを受信して正常に実行したことを In-Sight が応答すると、Done (DN) ビットが 1 にセットされます。エラー (ER) ビットが有効になった (1 に設定された) 場合、メッセージ命令に問題が発生したことを示します。エラーが発生した場合、MSG 命令の設定画面をクリックします。エラーコードはウィンドウ下部に表示されます。以下の表にエラーコードのリストを示します。

エラーコード

エラーコード | 説明 | ネイティブモード戻りコード
00 | 成功 - エラーなし | 1
10 | 不正なコマンドまたはフォーマット | 0
EE | コマンドを実行できません。 | -2、-4、または -5
D9 | ユーザ指定のタイムアウト前に応答を受信しなかった | 該当なし
F2 | 無効なパラメータまたは無効なデータ | -1

Version: 5.6.0


WriteImageFTP 関数の設定

In-Sight 関数リファレンス

WriteImageFTP 関数は、取り込んだ画像をネットワークの FTP サーバに出力します。一般的には、検査に失敗した画像を自動保存するために使用します。

  1. スプレッドシートに WriteImageFTP 関数を挿入して、WriteImageFTP 関数のプロパティシートを開きます。以下のパラメータを設定します。残りのパラメータについてはデフォルトの設定を使用しています。

    • ホスト名では、ご使用の PC の名前を選択します (ご使用の PC 名が表示されない場合は、ここをクリックしてください)。

      注:In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます (C:\ProgramData\Cognex\In-Sight\Emulators\x.x.x)。このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます (FTP ルートディレクトリ)。エミュレータディレクトリおよび FTP ルートディレクトリの詳細については、[オプション] ダイアログのトピック (エミュレーションパネル) を参照してください。

    • FTP サーバにログオンするためのユーザ名とパスワードを入力します。In-Sight Explorer ソフトウェアには、FTP サーバが組み込まれています。この FTP サーバは、In-Sight Explorer を開くと実行します。In-Sight Explorer の FTP サーバを使用する場合、デフォルトのユーザ名は admin であり、デフォルトのパスワードは未設定です。

    • 画像ファイルのファイル名を入力します。

      注:ファイルを FTP ルートディレクトリに書き込む場合、ファイル名は [オプション] ダイアログで指定した [FTP ルートディレクトリ] と完全に一致しなければなりません。画像ファイルも、FTP ルートディレクトリ内の任意のサブディレクトリに書き込むことができます (サブディレクトリはあらかじめ存在している必要があります)。例えば、FTP ルートディレクトリが C:\temp で、ファイル名が「Failed」の場合は、ファイル名を「C:\temp\Failed」と指定する必要があります。「Images」サブディレクトリに書き込む場合、ファイル名は「C:\temp\Images\Failed」となります。「Failed」とのみ指定した場合、ファイルはデフォルトのエミュレータディレクトリに書き込まれます。

  2. パラメータを設定したら、[OK] をクリックして、プロパティシートを閉じます。
  3. ビジョンシステムをオンラインにします。
  4. ビジョンシステムをトリガします。取り込んだ各画像について、指定したホストにビットマップまたは Jpg ファイルが保存されます。

FTP 問題のトラブルシューティング

  • In-Sight ビジョンシステムをオンラインにする必要があります。オフラインモードでは WriteImageFTP 関数は実行されず、画像が送信されません。
  • インターネット接続のファイアウォールは無効にする必要があります。詳細については、ファイアウォールのトピックを参照してください。
  • IIS (Internet Information Services) がインストールされている場合は、IIS でポート 21 が使用されていないことを確認してください。ポート 21 が使用されている場合は、22 などの未使用のポートに変更してください。
  • ローカル PC の名前が [ホスト名] ドロップダウンリストに表示されない場合は、PC の IP アドレスを手動で入力します。

FAQ

Q: 同じネットワーク上で複数の FTP サーバを稼働させることはできますか？

A: はい。 同じネットワークに、In-Sight Explorer が実行されている PC を複数配置できます。しかし、いずれかの FTP 関数を使用している間は、同じ PC 上で、同じ FTP ポート番号 21 を使用する FTP サーバを複数実行することはできません。

Q: 画像をローカル PC 以外の場所にも保存することはできますか？

A: はい。 FTP サーバがインストールされている別の PC がある場合は、その PC を保存場所として選択できます。 In-Sight Explorer ソフトウェアは FTP サーバとみなされることに注意してください。サードパーティ製の FTP サーバを使用する場合は、In-Sight Explorer を閉じる必要があります。ほかの FTP サーバが実行されていない場合は、In-Sight Explorer が実行されている必要があります。ホスト名が In-Sight Explorer に表示されない場合や、サードパーティ製の FTP サーバを使用する場合は、WriteImageFTP ダイアログで PC の IP アドレスを指定する必要があります。

Q: FTP 関数を使用するときには、In-Sight Explorer を開く必要がありますか？

A: はい。 In-Sight Explorer は、実質的には FTP サーバとして機能します。In-Sight Explorer が実行されていない場合は、サードパーティ製の FTP サーバが実行されている必要があります。

Q: In-Sight Explorer がファイル転送で使用するポートの番号は何番ですか？

A: In-Sight Explorer はファイル転送 (FTP) にポート 21 を使用します。In-Sight Explorer のほかにポート 21 を使用しているアプリケーションがあると、WriteImageFTP 関数は正常に実行されません。IT 部門に問い合わせ、すべてのファイアウォールとウィルス対策ソフトウェアを無効にするか、または 21 番以外のポートを使用するように設定してください。


三菱電機 MELSEC 通信プロトコル

三菱電機の通信

In-Sight 通信リファレンス

In-Sight ビジョンシステムは、3 種類の MELSEC 通信プロトコルによる三菱電機 MELSEC Q シリーズ、L シリーズ、FX シリーズオートメーションコントローラとの通信に対応しています。

注意:In-Sight Explorer GUI では、「オートメーションコントローラ」と同じ意味の「プログラマブルロジックコントローラ/モーションコントローラ (PLC/MC)」という用語が使用されています。

In-Sight ビジョンシステムは以下の 3 つの方法により、三菱電機 MELSEC オートメーションコントローラと通信することができます。

  • CC-Link
  • CC-Link IE Field Basic
  • SLMP
  • SLMP スキャナ

また、SLMP スキャナプロトコルを使用する iQ Sensor Solution 用に In-Sight ビジョンシステムを設定することもできます。

  • iQ Sensor Solution

CC-Link

In-Sight CIO-MICRO-CC I/O モジュールを使用すると、CC-Link ネットワーク上のオートメーションコントローラと In-Sight ビジョンシステムの間の通信を容易に行うことができます。この接続ではデータ同期のみがサポートされ、オートメーションコントローラからビジョンシステムにコマンド (「trigger」、「change job」、「Online/Offline」など) を送信する手段は組み込まれていません。CC-Link V1 ネットワークでは最大 112 ビットおよび 16 ワードの入力および出力データがサポートされます。また、1 つのステーションの占有および 1 ～ 8 サイクル間での使用に対応しています。CC-Link V2 ネットワークでは最大 1008 ビットおよび 128 ワードの入力および出力データがサポートされます。また、1 つ ～ 4 つのステーションの占有および 1 ～ 8 サイクル間での使用に対応しています。CC-Link ネットワーク上のビジョンシステムとオートメーションコントローラの間で CIO-MICRO-CC I/O モジュールを経由してデータを通信するには、ReadCCLinkBitBuffer、ReadCCLinkWordBuffer、WriteCCLinkBitBuffer、WriteCCLinkWordBuffer の各関数を使用します。

注: CC-Link は In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用できます。 In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムではご使用いただけません。詳細については、ファームウェアのバージョントピックをご参照ください。

CC-Link IE フィールドネットワーク Basic

CC-Link IE フィールド Basicは、イーサネットデバイスを三菱電機シーケンサに統合するよう設計されたプロトコルです。既存の　SLMP (MC Protocol) とは対照的に、シーケンサがマスタとして動作し、標準の UDP メッセージングを介してスレーブデバイスと通信します。 通信は、各方向に 1 局当たり 64 ビットのデータと 32 16 ビットワードのデータをサポートし、各スレーブは 4 局をサポートします。 データは、セットアップツール (GXWorks 2/3) を介してコントローラメモリにマッピングされます。

プロトコルを ON にし、ビジョンシステムをシーケンサ上に設定後、シーケンサは要求/応答メカニズムを介してビジョンシステムとの周期的通信を開始します。

SLMP

基本的な Seamless Message Protocol (SLMP) 接続では、オートメーションコントローラと In-Sight ビジョンシステムの間でのデータ交信をサポートしています。SLMP 接続では、オートメーションコントローラからビジョンシステムにコマンド (「trigger」、「change job」、「Online/Offline」など) を送信する手段は組み込まれていません。SLMP 接続を介して In-Sight コマンドを実行するには、In-Sight のネイティブモード文字列コマンドを使用し、オートメーションコントローラにてプログラミングする必要があります。SLMP 接続は、オートメーションコントローラによって発行される In-Sight コマンドで制御を行わないアプリケーションや、既にネイティブモード文字列コマンドで動作するように設計されたアプリケーションとの互換性を持たせる場合に最適です。

SLMP スキャナ

SLMP スキャナ接続は、オートメーションコントローラと In-Sight ビジョンシステムの間でのデータ交信をサポートしています。SLMP スキャナ接続では、コントロールおよびステータスレジスタを直接指定し、オートメーションコントローラからビジョンシステムのコマンドを発行するためのコントロールおよびステータスチャネルも提供しています。SLMP スキャナ接続では、コントロールおよびステータスチャネルには含まれていないより高度なネイティブモード文字列コマンドの送受信を行うための専用コマンドチャネルが備えられています。SLMP スキャナ接続は、オートメーションコントローラによって発行されるビジョンシステムコマンドを使用するアプリケーションに最適です。この場合、ネイティブモードコマンドを使用する既存のアプリケーションと互換性を持たせる必要はありません。

このトピックでは、In-Sight ビジョンシステムにおける、In-Sight Explorer を使用した SLMP スキャナの設定および使用方法について説明します。EasyBuilder 開発環境内で SLMP スキャナを使用する方法の詳細については、パレットの [ヘルプ] タブを参照してください。

注意:SLMP スキャナ接続は、In-Sight Explorer のファームウェアバージョン 4.5.0 以上、および In-Sight Explorer のソフトウェアバージョン 4.5.0 以上でのみサポートされています。

iQ Sensor Solution

三菱電機 iQ Sensor Solution は、GX Works2 ソフトウェアで SLMP スキャナプロトコルを介して In-Sight ビジョンシステムを制御できるようにする、ファクトリプロトコルです。

このトピックでは、ネットワーク上の In-Sight ビジョンシステムの検出、ビジョンシステムの SLMP スキャナパラメータ設定の読み取り/書き込み、GX Works 2 からのビジョンシステムステータスのモニタの方法について説明します。

注意:　iQ Sensor Solution は、In-Sight Explorer ファームウェアバージョン 4.x.x でサポートされています。

関連項目

  • CC-Link ネットワーク上の三菱電機オートメーションコントローラとの Anybus X-gateway 経由での通信
  • CC-Link ネットワーク上の三菱電機オートメーションコントローラとの In-Sight CIO-MICRO-CC 経由での通信
  • CC-Link IE フィールド Basic 上での三菱電機オートメーションコントローラとの通信
  • CC-Link IE フィールド Basic ファクトリインターフェイス
  • SLMP 通信で使用するための In-Sight ビジョンシステムの設定
  • SLMP スキャナ通信で使用するための In-Sight ビジョンシステムの設定
  • SLMP スキャナのファクトリインタフェース
  • iQ Sensor Solution 経由での三菱電機 L シリーズオートメーションコントローラとの通信


CC-Link ネットワーク上の三菱電機オートメーションコントローラとの In-Sight CIO-MICRO-CC I/O モジュール経由での通信

三菱電機の通信

In-Sight 通信リファレンス

このトピックでは、三菱電機 CC-Link 通信プロトコルの概要を説明します。また、In-Sight CIO-MICRO-CC I/O モジュールを使用して、In-Sight ビジョンシステムを三菱電機 Q シリーズオートメーションコントローラと連携する方法を説明します。CC-Link の指定ケーブルを使用して、CIO-MICRO-CC I/O モジュールとビジョンシステムをオートメーションコントローラに直接接続し、CC-Link 通信のエンドポイント設定またはミッドスパン設定のいずれかで使用することができます。デバイスの接続とインストールの詳細については、ソフトウェアに付属の『In-Sight® CIO-MICRO および CIO-MICRO-CC I/O モジュール日本語版インストールガイド』をIn-Sight Explorer参照してください。

注:CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以上を実行している In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

CC-Link プロトコル通信で使用するための In-Sight ビジョンシステムの設定

このセクションでは、CC-Link 通信を使用して、In-Sight ビジョンシステムを三菱電機 Q シリーズオートメーションコントローラに接続する方法を説明します。CIO-MICRO-CC I/O モジュールは、In-Sight ビジョンシステムと三菱電機 Q シリーズオートメーションコントローラの間のゲートウェイとして動作します。In-Sight ビジョンシステムと三菱電機オートメーションコントローラの間の CC-Link プロトコル接続を作成するには、ReadCCLinkBitBuffer 関数、ReadCCLinkWordBuffer 関数、WriteCCLinkBitBuffer 関数、および WriteCCLinkWordBuffer 関数を使用します。

  • CC-Link 通信で使用するための In-Sight CIO-MICRO-CC の設定
  • In-Sight ビジョンシステムから三菱電機オートメーションコントローラへのデータの取得
  • 三菱電機オートメーションコントローラから In-Sight ビジョンシステムへのデータの送信

CC-Link 通信で使用するための In-Sight CIO-MICRO-CC の設定

CC-Link 通信のセットアップは、CIO-MICRO-CC I/O モジュールと三菱電機 Q シリーズオートメーションコントローラの CC-Link 接続を使用して行います。これらの手順では、In-Sight ビジョンシステムと CIO-MICRO-CC I/O モジュールがオートメーションコントローラに接続され、In-Sight Explorer で CC-Link 通信で使用するための設定を行うことができるようになっていることを前提にしています。

  1. [In-Sight ネットワーク] ペインから、目的の In-Sight ビジョンシステムを選択して接続します。
  2. [センサ] メニューから、[CC-Link の設定] を選択し、[CC-Link の設定] ダイアログを起動します。
  3. [CC-Link の設定] ダイアログに目的の CIO-MICRO-CC I/O モジュールが表示されていない場合は、[I/O モジュール] ボタンを押して [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。
  4. [CC-Link の設定] ダイアログで、接続されている三菱電機 Q シリーズオートメーションコントローラに合うように設定を行います。
  5. [OK] を押して、[CC-Link の設定] ダイアログを閉じます。

In-Sight ビジョンシステムから三菱電機オートメーションコントローラへのデータの取得

In-Sight Explorer スプレッドシートから三菱電機オートメーションコントローラにデータを取得するには、WriteCCLinkBitBuffer (合格/不合格データなど) 関数と WriteCCLinkWordBuffer (整数値、浮動小数点数値、文字列データなど) 関数を使用して、データを転送する必要があります。各関数は、FormatOutputBuffer 関数によって作成されたデータの個々のバッファを取り、そのデータを CIO-MICRO-CC I/O モジュールの CC-Link メモリバッファに書き込みます。このデータは、次の更新サイクルの際に転送されます。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. この FormatOutputBuffer 関数は、ワードデータ (整数値、浮動小数点数値、文字列データなど) の送信に使用します。
  3. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これにより、セル選択モードが開始されます。三菱電機オートメーションコントローラに転送する整数値、浮動小数点数値、文字列データを選択します。
  4. 送信する追加データがある場合は、FormatOutputBuffer ダイアログで、[追加] ボタンをクリックします。これで再びセル選択モードになります。転送する追加データを選択します。
  5. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  6. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteCCLinkWordBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  7. WriteCCLinkWordBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  8. 別の FormatOutputBuffer 関数を追加します。この関数は、ビットデータ (合格/不合格データなど) の送信に使用します。
  9. 手順 3 の指示に従います。FormatOutputBuffer 関数を設定する場合は、[データ型] パラメータが [ビット] に設定されていることを確認します。
  10. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  11. WriteCCLinkBitBuffer 関数をスプレッドシートに追加します。
  12. WriteCCLinkBitBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。

三菱電機オートメーションコントローラから In-Sight ビジョンシステムへのデータの送信

三菱電機オートメーションコントローラから In-Sight Explorer スプレッドシートにデータを送信するには、ReadCCLinkBitBuffer (有効化/無効化関数など) 関数と ReadCCLinkWordBuffer (整数値、浮動小数点数値、文字列データなど) 関数を使用して、CIO-MICRO-CC I/O モジュールからデータを転送する必要があります。これらの関数は、FormatInputBuffer 関数内で作成された書式設定済みデータを取り、対応する CIO-MICRO-CC I/O モジュールのメモリ領域を読み取ります。その後、このデータを書式設定して In-Sight Explorer スプレッドシートに挿入します。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. この FormatInputBuffer 関数は、ワードデータ (整数値、浮動小数点数値、文字列データなど) の受信に使用します。
  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。
  4. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadCCLinkWordBuffer 関数をダブルクリックしてスプレッドシートに挿入します。
  6. ReadCCLinkWordBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. 別の FormatInputBuffer 関数を追加します。この関数は、ビットデータ (有効化/無効化関数など) の受信に使用します。
  8. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、ビットデータタイプを追加します。
  9. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  10. ReadCCLinkBitBuffer 関数をスプレッドシートに追加します。
  11. ReadCCLinkBitBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  12. 関数が実装されたら、In-Sight ビジョンシステムをオンラインにして設定をテストします。

関連項目

  • ReadCCLinkBitBuffer 関数
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkBitBuffer 関数
  • WriteCCLinkWordBuffer 関数
Version: 5.6.0


CC-Link IE フィールドネットワーク Basic を介しての三菱電機オートメーションコントローラとの通信

Mitsubishi の通信

In-Sight 通信リファレンスe

CC-Link IE フィールド Basicは、イーサネットデバイスを三菱電機シーケンサに統合するよう設計されたプロトコルです。既存の　SLMP (MC Protocol) とは対照的に、シーケンサがマスタとして動作し、標準の UDP メッセージングを介してスレーブデバイスと通信します。 通信は、各方向に 1 局当たり 64 ビットのデータと 32 16 ビットワードのデータをサポートし、各スレーブは 4 局をサポートします。 データは、セットアップツール (GXWorks 2/3) を介してコントローラメモリにマッピングされます。

プロトコルを ON にし、ビジョンシステムをシーケンサ上に設定後、シーケンサは要求/応答メカニズムを介してビジョンシステムとの周期的通信を開始します。

In-Sight ビジョンシステムを CC-Link IE フィールド Basic プロトコル用に設定するには

このセクションでは、CC-Link 通信を使用して In-Sight ビジョンシステムに接続し、三菱 Q シリーズシーケンサに接続する方法について説明します。

CC-Link IE Field Basic を有効にする

注:
  • EasyBuilder から CC-Link IE フィールド Basic を有効にする方法については、EasyBuilder ヘルプをご参照ください (通信 > .デバイスの設定 > 三菱電機社製デバイスと通信するには > CC-Link IE フィールド Basic)。
  • CC-Link IE フィールド Basic についての詳細は、三菱電機社の『CC-Link IE フィールド Basic リファレンスマニュアル』をご参照ください。

In-Sight Explorer

  1. In-Sight Explorer を開き、In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから、[ネットワークの設定] ダイアログを開きます。
  3. ダイアログの [産業用イーサネットプロトコル] グループボックスから、 [CC-Link IE フィールド Basic] を選択します。
  4. In-Sight ビジョンシステムを再起動します。再起動後、CC Link IE Field Basic プロトコルが有効になります。

三菱 GX Works 2

  1. 三菱 GX Works 2 ソフトウェアを開き、In-Sight ビジョンシステムに接続します。

  2. [内蔵 Ethernet ポート設定] タブをクリックし、[CC-Link IE フィールド Basic Setting] ボタンをクリックします。

  3. [CC-Link IE フィールド Basic] チェックボックスを ON にします。

  4. [Network Configuration Setting] ボタンをクリックし、[CC-Link IE フィールド Basic Configuration] ダイアログを開きます。

  5. ビジョンシステムをリンクスキャンリストに追加し、ビジョンシステムをスキャンする局数 (1-4) を選択します。

  6. 設定の変更を OK します。

  7. 同期された CC-Link IE フィールド Basic のレジスタの保存に使用する PLC メモリを選択します。

  8. ダイアログのすべてのパラメータを OK し、プロジェクトをオートメーションコントローラにダウンロードします。

  9. PLC の再起動後、CC-Link IE フィールド Basic 上でビジョンシステムをスキャンするようになります。

画像取り込みトリガを受信するための In-Sight ビジョンシステムの設定

  1. AcquireImage 関数のプロパティシートを開きます。
  2. [トリガ] パラメータを [産業用イーサネット] に設定します。
  3. In-Sight ビジョンシステムをオンラインにします。
  4. In-Sight ビジョンシステムは、RY ブロックの Trigger Enable および Trigger ビットを直接操作したり、RX ビットブロックのTrigger Ready、Trigger Ack および Missed Acq ビットをモニタリングしたりすることによって、トリガすることができます。

注意: CC-Link IE フィールドネットワーク Basic のファクトリインターフェイストピックには、In-Sight ビジョンシステムの入出力を処理メモリにマッピングするための情報が詳細に示されています。ただし、ブロックのレイアウトは、In-Sight ビジョンシステムに搭載されている In-Sight ファームウェアのバージョンによって異なります。

In-Sight ビジョンシステムからのデータの取得

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  2. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。シーケンサに転送されるデータを選択します。
  3. 送信する追加データがある場合は、[FormatOutputBuffer] ダイアログで、[追加] ボタンをクリックします。これで再びセル選択モードになります。転送する追加データを選択します。
  4. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. WriteResultsBuffer 関数の [プロトコル] パラメータを 8 = CC-Link IE フィールド Basic ビット または 9 = CC-Link IE フィールド Basic ワードに設定し、[バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. 必要に応じて、結果コードパラメータをスプレッドシートのセルへのセル参照として設定し、検査結果を含む結果コードを取得します。

In-Sight ビジョンシステムへのデータの送信

注意: In-Sight ビジョンシステムをトリガして MELSEC シーケンサからユーザデータを読み取るためには、RY Block ブロックの Set User Data ビットをシーケンサからトリガする必要があります。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。
  3. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. ReadUserDataBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  6. ReadUserDataBuffer 関数の [プロトコル] パラメータを 8 = CC-Link IE フィールド Basic ビット または 9 = CC-Link IE フィールド Basic ワードに設定し、[バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. 関数が実装されたら、In-Sight ビジョンシステムをオンラインにして、設定をテストします。

関連項目

  • ReadLatchedUserDataBuffer
  • ReadUserDataBuffer
  • WriteResultsBuffer
Version: 5.6.0


CC-Link IE フィールドネットワーク Basic のファクトリインターフェイス

Mitsubishi の通信

In-Sight 通信リファレンス

このトピックでは、In-Sight ビジョンシステムと CC-Link IE フィールド Basic の通信について説明します。

  • ポート
  • 信号のレイアウト

ポート

CC-Link IE Field Basic プロトコルは、2 つの UDP ポート上で動作します。

ポート | 説明
61450 | 周期的な要求/応答メッセージ
61451 | NodeSearch および IPAddressSet メッセージ
45237 | ベース SLMP メッセージ (GetCommunicationSetting)

信号のレイアウト

定義済みデータブロックを使用すると、ビジョンシステムがシーケンサとの間でデータの読み取り、および書き込みを行う場所を制御することができます。アプリケーションの設定を用意にするために、コマンド機能に必要なさまざまなコントロールおよびステータスビットは連続したブロックにグループ化され、これらを同時に処理することができます。ビジョンシステムとシーケンサ間の相互の設定をする場合は、データの各ブロックに対して開始アドレスとデバイスタイプを選択する必要があります。

ブロック | アドレス | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
RY | 0 | 0 | Set Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 8 | 1 | Reserved
 | 16 | 2 | Reserved |  |  |  | Clear Exposure Complete | Clear Error | Reserved | Set User Data
 | 24 | 3 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
 | 32..63* | 4..7 | User Data (Bit Area)
 | *ただし、局占有により 255 点まで可能
RWw | 0 | 0..1 | Command
 | 1..31* | 2..63 | User Data
 | *ただし、局占有により 127 点まで可能
RX | 0 | 0 | Online | Offline Reason |  |  | Missed Acq | Reserved | Trigger Ack | Trigger Ready
 | 8 | 1 | Error | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 | 16 | 2 | Reserved |  |  | Job Pass | Exposure Complete | Reserved |  | Set User Data Ack
 | 24 | 3 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0
 | 32..63* | 4..7 | Inspection Results (Bit Area)
 | *ただし、局占有により 255 点まで可能
RWr | 0 | 0..1 | Current Job ID
 | 1 | 2..3 | Error Code
 | 2 | 4..5 | Acquisition ID
 | 3 | 6..7 | Inspection ID
 | 4 | 8..9 | Inspection Result Code
 | 5..31* | 10..63 | Inspection Results
 | *ただし、局占有により 127 点まで可能

注: RY および RX では、各局ごとに 64 ビットのデータを使用できます。RWw および RWr では、各局ごとに 32 16-ビットワードをサポートします。In-Sight は　1、2、3 、4 、8 または 16 局構成をサポートしますが、現在使用可能な PLC 　は、局数を 4 までに制限しています。信号は第 1 局の一部のみを占有します。

 | RY | RWw | RX | RWr
1 局 | 64 ビット | 32 ワード | 64 ビット | 32 ワード
2 局 | 128 ビット | 64 ワード | 128 ビット | 64 ワード
3 局 | 192 ビット | 96 ワード | 192 ビット | 96 ワード
4 局 | 256 ビット | 128 ワード | 256 ビット | 128 ワード

RY ブロック

バイト 0

ビット | 名前 | 説明
7 Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6-5 | Reserved | 使用されません。
4 | Execute Command | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC/MC が Inspect Count、Inspection Result Code、および Inspection Results データを受信したことを確認応答します。 その後、次の検査結果のセットが PLC/MC に送信されます。 Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。
2 | Buffer Results Enable | このビットがセットされると、Inspection Count、Inspection Result Code、および Inspection Results フィールドは、Inspection Results Ack ビットがセットされて確認応答されるまで変化しません。 最大 8 つの検査が In-Sight ビジョンシステムのバッファに保持されます。 ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。 Inspection Results Ack ビットがクリアされて、PLC/MC に送信される新しい結果セットがあるときには、Results Valid ビットはクリアされません。 Inspection Results Ack ビットがクリアされて、PLC/MC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • [トリガ] パラメータが [ネットワーク]、[外部] または [産業用イーサネット] に設定されている。
注:
  • [トリガ] パラメータは、スプレッドシートビューでは AcquireImage 関数、EasyBuilder では [画像の設定] アプリケーションステップで設定することができます。
  • トリガが PLC/MC から送信される場合、[産業用イーサネット] トリガタイプを使用してください。
0 | Trigger Enable | このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

バイト 1

ビット | 名前 | 説明
7-0 | Reserved | 使用されません。

バイト 2

ビット | 名前 | 説明
7-4 | Reserved | 使用されません。
3 | Clear Exposure Complete | この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。
2 | Clear Error | このビットをセットすると、エラーシグナルとエラーコードシグナルがクリアされます。Clear Error ビットは、Error ビットがクリアされるまで [High] に維持する必要があります。エラーがキューに入れられた場合、このビットがクリアされると、エラーシグナルとエラーコードシグナルは、キューに入れられた次のエラーコードに対してセットされます。
1 | Reserved | 使用されません。
0 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC/MC から In-Sight ビジョンシステムへ通知します。

バイト 3

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

バイト 4..7

ビット | 名前 | 説明
7-0 | User Data (ビットエリア) | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

RWw ブロック

バイト 0..1

ビット | 名前 | 説明
7-0 | Command | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。

バイト 2..63

ビット | 名前 | 説明
7-0 | User Data | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

RX ブロック

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6-4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 Missed Acq 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

Note: Trigger ビットが設定されているが、ビジョンシステムがオフラインの場合、Missed Acq および Trigger Ack もセットされます。
2 | Reserved | 使用されません。
1 Trigger Ack In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。また、Acquisition ID は、このビットの立ち上がりエッジにラッチできます。

Note: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。
0 Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

Note: トリガが PLC/MC から送信される場合、[産業用イーサネット] トリガタイプを使用してください。

バイト 1

ビット | 名前 | 説明
7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
6 | Command Failed | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
5 Command Completed コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。

注: Command Executing ビットが Low になった場合、ビジョンシステムは Command Completed ビットをクリアします。
4 | Command Executing | Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注意: オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。
2 Results Buffer Overrun

このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC/MC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。 最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。9 番目の検査と後続のすべての検査は、バッファに空きが生じるまで (結果が確認応答されたとき) 破棄されます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。
0 System Busy

ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

バイト 2

ビット | 名前 | 説明
7-5 | Reserved | 使用されません。
4 Job Pass
注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
2 - 1 | Reserved | 使用されません。
0 | Set User Data Ack | このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。

バイト 3

ビット | 名前 | 説明
7 | Soft Event Ack 7 | これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
6 | Soft Event Ack 6
5 | Soft Event Ack 5
4 | Soft Event Ack 4
3 | Soft Event Ack 3
2 | Soft Event Ack 2
1 | Soft Event Ack 1
0 | Soft Event Ack 0

バイト 4..7

ビット | 名前 | 説明
7-0 | Inspection Results (ビットエリア) | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

RWr ブロック

バイト 0..1

名前 | 説明
Current Job ID | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 2..3

名前 説明
Error Code

発生したエラーを 16 ビットで表します。

コード | エラー | 説明
0x0000 | No Error | 発生したエラーを 16 ビットで表します。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされるか、または AcquireImage 関数の [トリガ] パラメータが [外部]、[ネットワーク] または [産業用イーサネット] に設定されているときに、Trigger ビットがセットされると発生します。
0x0101 | Trigger set while Offline | ビジョンシステムオフライン中に、Trigger ビットがセットされると発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Executing ビットが HIGH の場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムオンライン中に、Job Load コマンドが発行されたときに発生します。

バイト 4..5

名前 | 説明
Acquisition ID | この ID は、取り込みの開始時と Trigger Ack ビットがセットされると増分され、取り込みとその検査結果の同期に使用できます。

バイト 6..7

名前 | 説明
Inspection ID | この結果セットに関連付けられている取り込み ID。

バイト 8..9

名前 | 説明
Inspection Result Code | 検査結果コードは、WriteResultsBuffer 関数の [結果コード] パラメータによって定義されます。

バイト 10..63

名前 | 説明
Inspection Results | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。
Version: 5.6.0


SLMP 通信で使用するための In-Sight ビジョンシステムの設定

三菱電機の通信

In-Sight 通信リファレンス

この節では、三菱電機 MELSEC Q シリーズおよび FX シリーズオートメーションコントローラへの SLMP 通信を使用して、In-Sight ビジョンシステムに接続する方法について説明します。ReadMC 関数と WriteMC 関数は、In-Sight ビジョンシステムと MELSEC オートメーションコントローラの間の SLMP 通信を作成するために使用され、3E QnA 互換または 1E A 互換バイナリフレームを使用して Batch Read/Write コマンドを送信し、オートメーションコントローラとのデータの送受信を行います。

注意:SLMP が三菱電機 MELSEC FX シリーズ (1E フレーム)Ethernet モジュールに割り当てられているとき、使用可能なポートと最大接続数はモジュールのモデルタイプ (FX3U-ENET または FX3U-ENET-L) によって異なります。詳細については、該当するモジュールのマニュアルを参照してください。

  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの読み取り
  • 関連項目

In-Sight ビジョンシステムからのデータの取得

In-Sight Explorer スプレッドシートからのデータを MELSEC オートメーションコントローラで取得するには、WriteMC 関数を使用して、データを転送する必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り、そのデータをオートメーションコントローラの設定済みメモリ位置に書き込みます。このデータは、次の更新サイクルの際に転送されます。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。オートメーションコントローラに転送されるデータを選択します。
  3. 送信する追加データがある場合は、[FormatOutputBuffer] ダイアログで、[追加] ボタンをクリックします。これで再びセル選択モードになります。転送する追加データを選択します。
  4. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteMC 関数をダブルクリックして、スプレッドシートに挿入します。
  6. WriteMC 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. オートメーションコントローラ設定に対する WriteMC 関数のホスト名、ポート、PLC シリーズ、およびデバイスアドレスのパラメータを設定します。

In-Sight ビジョンシステムへのデータの読み取り

MELSEC オートメーションコントローラから In-Sight Explorer スプレッドシートにデータを送信するためには、ReadMC 関数を使用して、データをオートメーションコントローラから読み取る必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータ形式を取得し、読み取るオートメーションコントローラのメモリ位置を判別します。その後、このデータを書式設定して In-Sight Explorer スプレッドシートに挿入します。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。
  3. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadMC 関数をダブルクリックして、スプレッドシートに挿入します。
  5. ReadMC 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  6. オートメーションコントローラ設定に対する ReadMC 関数のホスト名、ポート、PLC シリーズ、およびデバイスアドレスのパラメータを設定します。
  7. 関数が実装されたら、In-Sight ビジョンシステムをオンラインにして、設定をテストします。

関連項目

  • FormatInputBuffer 関数
  • FormatOutputBuffer 関数
  • ReadMC 関数
  • WriteMC 関数


SLMP スキャナ通信で使用するための In-Sight ビジョンシステムの設定

三菱電機の通信

In-Sight 通信リファレンス

このトピックでは、三菱電機 MELSEC Q シリーズおよび FX シリーズオートメーションコントローラへの SLMP スキャナ通信を使用して、In-Sight ビジョンシステムを接続する方法について説明します。SLMP スキャナを使用すると、In-Sight ビジョンシステムの入力および出力を MELSEC オートメーションコントローラのプロセスメモリにマップすることができます。これらの値は、確立後、SLMP スキャナ通信の更新レートパラメータ設定によって定義される間隔で同期されます。

注意:
  • In-Sight ビジョンシステムの入力および出力のプロセスメモリへのマップの詳細については、「SLMP スキャナのファクトリインタフェース」で説明されています。
  • 三菱電機 MELSEC Q シリーズオートメーションコントローラは、ファームウェアのバージョンが 4.5.0 以降の In-Sight ビジョンシステムでサポートされています。
  • 三菱電機 MELSEC FX シリーズオートメーションコントローラは、ファームウェアのバージョンが 4.7.0 以降の In-Sight ビジョンシステムでサポートされています。

  • SLMP スキャナが MELSEC FX シリーズ (1E フレーム)Ethernet モジュールに割り当てられているとき、使用可能なポートと最大接続数はモジュールのモデルタイプ (FX3U-ENET または FX3U-ENET-L) によって異なります。詳細については、該当するモジュールのマニュアルを参照してください。

    モデルタイプ 使用可能なポート 最大
    接続数
    FX3U-ENET | すべてのポート (C1 ～ C8) | 4
    FX3U-ENET-L | C3 および C4 | 2
  • SLMP スキャナ通信の確立
  • 画像取り込みトリガを受信するための In-Sight ビジョンシステムの設定
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信
  • 関連項目

SLMP スキャナ通信の確立

In-Sight ビジョンシステムと SLMP スキャナ通信を確立するためには、In-Sight ビジョンシステムの [ネットワークの設定] ダイアログを使用して、SLMP スキャナが有効になるようにビジョンシステムを設定しておく必要があります。有効にした後、[SLMP スキャナ設定] ダイアログを使用して、MELSEC オートメーションコントローラへの接続を設定し、デバイスアドレスおよびさまざまなデータブロックのサイズを定義します。

  1. In-Sight Explorer を開き、該当する In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから [ネットワークの設定] ダイアログを開きます。
  3. ダイアログの [リアルタイムイーサネットプロトコル] セクションで [SLMP スキャナ] を選択し、[設定] ボタンを押して [SLMP スキャナ設定] ダイアログを起動します。
  4. [SLMP スキャナ設定] ダイアログの [設定] タブを使用して、三菱電機オートメーションコントローラとの接続を確立するのに必要な接続情報を定義します。
  5. [SLMP スキャナ設定] ダイアログの [デバイスのアドレス指定] タブを使用して、デバイスのアドレス、およびオートメーションコントローラと通信するさまざまなデータブロックのサイズを定義します。

注意:In-Sight ビジョンシステムの入力および出力のプロセスメモリへのマップの詳細については、「SLMP スキャナのファクトリインタフェース」で説明されています。

  6. In-Sight ビジョンシステムを再起動し、電源の再投入後に SLMP スキャナサービスを有効にします。

画像取り込みトリガを受信するための In-Sight ビジョンシステムの設定

In-Sight ビジョンシステムを三菱電機オートメーションコントローラと統合すると、MELSEC オートメーションコントローラから画像を取り込むためにビジョンシステムをトリガできるようになります。AcquireImage 関数の [トリガ] パラメータを [ネットワーク] に設定すると、SLMP スキャナ通信が有効になっている場合に、オートメーションコントローラでビジョンシステムをトリガすることができます。

  1. AcquireImage 関数のプロパティシートを開きます。
  2. [トリガ] パラメータを [ネットワーク] に設定します。
  3. In-Sight ビジョンシステムをオンラインにします。
  4. In-Sight ビジョンシステムは、Control and Status レジスタの Network Trigger Enable および Network Trigger ビットを直接操作することによりトリガできます。また Acquisition Status レジスタの Network Trigger Ready、Trigger Ack、Acquiring、および Missed Acq ビットをモニタリングすることによりトリガできます。

In-Sight ビジョンシステムからのデータの取得

In-Sight Explorer スプレッドシートから MELSEC オートメーションコントローラでデータを取得するためには、WriteResultsBuffer 関数を使用して、データが SLMP スキャナスタックにプッシュされる必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り、そのデータを MELSEC オートメーションコントローラの設定済みデータテーブルに書き込みます。このデータは、次の更新サイクルの際に転送されます。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。MELSEC オートメーションコントローラに転送されるデータを選択します。
  3. 送信する追加データがある場合は、FormatOutputBuffer ダイアログで、[追加] ボタンをクリックします。これで再びセル選択モードになります。転送する追加データを選択します。
  4. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. WriteResultsBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. WriteResultsBuffer 関数の [プロトコル] パラメータを 2 = SLMP スキャナにセットします。
  8. オプションで、[Result Code] パラメータを、検査結果の結果コードを取得するためのスプレッドシート内のセルへのセル参照としてセットします。

In-Sight ビジョンシステムへのデータの送信

MELSEC オートメーションコントローラから In-Sight Explorer スプレッドシートにデータを送信するためには、ReadUserDataBuffer 関数を使用して、データを SLMP スキャナスタックからプルする必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータ形式を取り、MELSEC オートメーションコントローラから受信したデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに挿入します。

注意:In-Sight ビジョンシステムをトリガして MELSEC オートメーションコントローラからユーザデータを読み取るためには、ビジョンコントロールビットブロックの Set User Data ビットをオートメーションコントローラからトリガする必要があります。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。
  3. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. ReadUserDataBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  6. 関数が実装されたら、In-Sight ビジョンシステムをオンラインにして、設定をテストします。

関連項目

  • ReadLatchedUserDataBuffer 関数
  • ReadUserDataBuffer 関数
  • WriteResultsBuffer 関数
  • SLMP スキャナのファクトリインタフェース


SLMP スキャナのファクトリインタフェース

SLMP 通信

In-Sight 関数リファレンス

SLMP スキャナはコマンド/応答ベースのプロトコルであり、接続された In-Sight ビジョンシステムから読み取り/書き込みコマンドが送信されます。 またビジョンシステムは、コントロールビットが変化したかどうかを判別するために、定期的な間隔で PLC/MC に読み取り要求を送信する必要があります。 このプロセスは「ポーリング」と呼ばれ、ポーリングサイクルが定義されています。

三菱通信プロトコルでは、In-Sight ビジョンシステムからの情報がデータブロックに結合され、ビジョンシステムと PLC/MC の間で転送されます。 この手法においては、ビットタイプのデータは PLC/MC のビットレジスタに格納され、ワードタイプのデータは PLC/MC のワードレジスタに格納されます。 この実装のため、データブロック内ではビットデータはワードデータには結合されず、これらのデータ項目は PLC/MC 内で個別にアドレス指定することができます。

In-Sight ビジョンシステムに搭載されているファームウェアのバージョンによって、データブロックの設定・定義は異なります。

  • SLMP スキャナファクトリインターフェイス - In-Sight 4.x.x ファームウェア
  • SLMP スキャナファクトリインターフェイス - In-Sight 5.x.x ファームウェア
Version: 5.6.0


SLMP スキャナのファクトリインタフェース　In-Sight 4.x.x ファームウェア

SLMP 通信

In-Sight 関数リファレンス

  • SLMP スキャナの操作
  • SLMP スキャナのファクトリインタフェース
  • SLMP スキャナのポーリング

SLMP スキャナの操作

SLMP スキャナはコマンド/応答ベースのプロトコルであり、In-Sight ビジョンシステムから送信されます。またビジョンシステムは、コントロールビットが変化したかどうかを判別するために、定期的な間隔で三菱電機オートメーションコントローラに読み取り要求を送信する必要があります。このプロセスは「ポーリング」と呼ばれ、ポーリングサイクルが定義されています。

三菱電機通信プロトコルでは、In-Sight ビジョンシステムからの情報がデータブロックに結合され、ビジョンシステムとオートメーションコントローラの間で転送されます。この手法においては、ビットタイプのデータはオートメーションコントローラのビットレジスタに格納され、ワードタイプのデータはオートメーションコントローラのワードレジスタに格納されます。この実装のため、データブロック内ではビットデータはワードデータには結合されず、これらのデータ項目はオートメーションコントローラ内で個別にアドレス指定することができます。

定義済みデータブロック

定義済みデータブロックを使用すると、ビジョンシステムがオートメーションコントローラとの間でデータの読み取り、および書き込みを行う場所を制御することができます。アプリケーションの設定をするために、コマンド機能に必要なさまざまなコントロールおよびステータスビットは連続したブロックにグループ化され、これらを同時に処理することができます。ビジョンシステムとオートメーションコントローラ間の相互の設定をする場合は、データの各ブロックに対して開始アドレスとデバイスタイプを選択する必要があります。

ビジョンコントロールビットブロック

ビジョンコントロールビットブロックは、オートメーションコントローラが開始する動作に対して、ビットタイプを持つすべての信号を定義します。ビジョンコントロールビットブロックは 32 ビットで、一部のビットは将来の実装用に予約済みです。

ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Set Offline | 予約済み |  | Initiate Job Load | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
ビット 15 | ビット 14 | ビット 13 | ビット 12 | ビット 11 | ビット 10 | ビット 9 | ビット 8
予約済み
ビット 23 | ビット 22 | ビット 21 | ビット 20 | ビット 19 | ビット 18 | ビット 17 | ビット 16
予約済み |  |  |  | Clear Exposure Complete | 予約済み | Initiate String Cmd | Set User Data
ビット 31 | ビット 30 | ビット 29 | ビット 28 | ビット 27 | ビット 26 | ビット 25 | ビット 24
Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0

ビジョンステータスビットブロック

ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Online | Offline Reason |  |  | Missed Acq | Acquiring | Trigger Ack | Trigger Ready
ビット 15 | ビット 14 | ビット 13 | ビット 12 | ビット 11 | ビット 10 | ビット 9 | ビット 8
General Fault | Job Load Failed | Job Load Complete | Job Loading | Results Valid | Results Buffer Overrun | Inspection Completed | Inspecting
ビット 23 | ビット 22 | ビット 21 | ビット 20 | ビット 19 | ビット 18 | ビット 17 | ビット 16
予約済み |  |  | Job Pass | Exposure Complete | String Cmd Error | String Cmd Ack | Set User Data Ack
ビット 31 | ビット 30 | ビット 29 | ビット 28 | ビット 27 | ビット 26 | ビット 25 | ビット 24
Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0

注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。

出力ワードブロック

ワード 0 | ワード 1 | ワード 2 | ワード 3 | ワード 4 | ワード 5 ..N
Current Job ID | Acquisition ID | Inspection ID | Inspection Result Code | Inspection Result Length | Inspection Results

入力ワードブロック

ワード 0 | ワード 1 | ワード 2 ..N
Job Load ID | User Data Length | User Data

文字列コマンドワードブロック

ワード 0 | ワード 1 ..N
Length | String Command

文字列コマンド結果ワードブロック

ワード 0 | ワード 1 | ワード 2 ..N
Result Code | Length | String Command Result

SLMP スキャナのファクトリインタフェース

これらのモジュールを使用することによって、In-Sight ビジョンシステムの各種サブシステムへのアクセスが可能になります。

  • Acquisition
  • Inspection
  • Job Management
  • Soft Events
  • String Commands

Acquisition

Acquisition のコントロールおよびステータスビットを使用すると、オートメーションコントローラは、In-Sight ビジョンシステムで画像取り込みをトリガして、画像取り込み完了時期を判別し、ビジョンシステムをオフラインステータスにして画像取り込みトリガを受け入れないようにすることができます。

  • Acquisition Control:　In-Sight ビジョンシステムの画像取り込みとオンライン/オフラインステータスを制御します。

ビット

名前

説明

0

Trigger Enable

このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

1

Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • AcquireImage 関数の [トリガ] パラメータが [ネットワーク] または [外部] に設定されている。
2 Clear Exposure Complete

この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。

3 ～ 6

予約済み

使用されません。

7

Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
  • Acquisition Status:　In-Sight ビジョンシステムの画像取り込みとオンライン/オフラインステータスを示します。

ビット

名前

説明

0

Trigger

Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Network Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク] または [外部] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

1

Trigger Ack

In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。

2

Acquiring

画像取り込み方法に関係なく、In-Sight ビジョンシステムが現在画像を取り込んでいるときにセットされます。

3

Missed Acq

画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

4 ～ 6

Offline Reason

このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

7

Online

このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。

8 ～ 23

Exposure Complete

このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
  • Acquisition ID: In-Sight ビジョンシステムによる特定の画像取り込みと検査結果を一致させます。
バイト数 | 名前 | 説明
0 ～ 1 | Acquisition ID | この ID は現在の画像取り込みに関連付けられています。Network Trigger ビットを使用して画像取り込みされ、Trigger Ack 信号がアサートされると、この ID が Acquisition ID に設定されます。

一般的な画像取り込みシーケンス

注意: ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

In-Sight ビジョンシステムは、Acquisition Control レジスタの Network Trigger Enable および Network Trigger ビットを直接操作することにより画像取り込みが行えます。また Acquisition Status レジスタの Network Trigger Ready、Trigger Ack、Acquiring、および Missed Acq ビットにより画像取り込み状況をモニタリングすることができます。

最初の起動時には、Network Trigger Enable ビットは偽であり、トリガを有効にするには真に設定する必要があります。ビジョンシステムがトリガを受け入れる準備ができると、Acquisition Status レジスタの Network Trigger Ready ビットが真に設定されます。

Network Trigger Enable および Network Trigger Ready ビットが真である間、Trigger ビットが 0 から 1 に変化するのをビジョンシステムは見ており、それが確認されると画像取り込みが開始されます。Acquisition Status レジスタの Trigger Ack ビットが同じ状態値になるまで、Trigger ビットを新しい状態で保持する必要があります (これは、ビジョンシステムが変化を確実に確認するために必要なハンドシェークです)。

画像取り込み時には、Acquisition Status レジスタの Network Trigger Ready ビットがクリアされて、Acquiring ビットが真に設定されます。画像取り込みが完了すると、Acquiring ビットはクリアされます。ビジョンシステムが新しい画像取り込みを開始する準備ができると、Network Trigger Ready ビットが再度真に設定されます。

トリガメカニズムを強制的にリセットするには、Acquisition Status レジスタが 0 になるまで Network Trigger Enable ビットを偽に設定します。Network Trigger Enable ビットを真に設定すると、画像取り込みが再度有効になります。

Closed 例: 一般的な画像取り込みシーケンス

Closed 例: 検査シーケンスより高速な画像取り込み

Inspection

検査ステータスおよびコントロールモジュールを使用すると、オートメーションコントローラは、In-Sight ビジョンシステムのビジョン処理部分をモニタして新しい結果が有効になる時期を判別し、ビジョンシステムが新しい結果をキューに入れるように要求することができます。

  • Inspection Control:　ジョブの実行と検査結果の処理を制御します。
ビット | 名前 | 説明
0 | Buffer Results Enable | このビットがセットされると、Inspection Count、Inspection Result Code、および Inspection Results フィールドは、Inspection Results Ack ビットがセットされて確認応答されるまで変化しません。最大 8 つの検査が In-Sight ビジョンシステムのバッファに保持されます。ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack ビットがクリアされて、オートメーションコントローラに送信される新しい結果セットがあるときには、Results Valid ビットはクリアされません。Inspection Results Ack ビットがクリアされて、オートメーションコントローラに送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、オートメーションコントローラが Inspection Count、Inspection Result Code、および Inspection Results データを受信したことを確認応答するように、オートメーションコントローラによってセットされます。その後、次の検査結果のセットがオートメーションコントローラに送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。
2 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、オートメーションコントローラから In-Sight ビジョンシステムへ通知します。
3 ～ 7 | 予約済み | 使用されません。
  • Inspection Status:　ジョブの実行と検査結果のステータスを示します。
ビット | 名前 | 説明
0 | Inspecting | このビットは、In-Sight ビジョンシステムがジョブを実行しているときにセットされます。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。
2 | Results Buffer Overrun | このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによってオートメーションコントローラが確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されて、バッファ内の 8 番目の検査に上書きされたときにセットされます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
3 | Results Valid | Inspection Count、Inspection Result、および Inspection Results フィールドが有効なときにセットされます。
4 ～ 6 | 予約済み | 使用されません。
7 | 予約済み | General Fault ビット用に予約済みです。
  • User Data:このデータは、ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用して、In-Sight スプレッドシートに読み込むことができます。
バイト | 名前 | 説明
0 ～ 1 | User Data Option | ユーザデータとともに渡される 16 ビットフィールド。将来の使用に備えて予約済みです。
2 ～ 3 | User Data Length | ユーザデータフィールドの長さ。
4 ～ 1920 | User Data | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。
  • Inspection Results:　これは、WriteResultsBuffer 関数を使用して、In-Sight スプレッドシートから書き込まれたデータです。Inspection Control モジュールの Buffer Results Enable ビットがセットされていた場合、Inspection Results Ack ビットをパルス出力することによって確認応答されるまで、検査結果は変わりません。
バイト | 名前 | 説明
0 ～ 1 | Inspection ID | この結果セットに関連付けられている取り込み ID。
2 ～ 3 | Inspection Result Code | 現在は使用されていません。常に 0 です。
4 ～ 5 | Inspection Results Length | 検査結果データの長さ。
6 ～ 1914 | Inspection Results | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

検査/結果シーケンス

In-Sight ビジョンシステムによって取り込まれた画像は、処理のためにキューに入れられます。ビジョンシステムが画像を処理している間、Inspection Status レジスタの Inspecting ビットがセットされます。ビジョンシステムが画像の処理を終了すると、Inspecting ビットがクリアされ、Inspection Completed ビットが立ちます。

Inspection Control レジスタの Buffer Results Enable ビットによって、ビジョンシステムでの検査結果の取り扱い方が決まります。Buffer Results Enable ビットが偽に設定された場合、検査結果は直ちに Inspection Results レジスタに入ります。また、Results Valid ビットが真に設定されます。Buffer Results Enable ビットが真に設定されると、新しい結果がキューに入れられます。以前の検査結果は、オートメーションコントローラによって確認応答されるまで Inspection Results レジスタに入ったままであり、Inspection Results Ack ビットが真に設定されます。Results Valid ビットがクリアされると、オートメーションコントローラは Inspection Results Ack ビットを偽に戻す必要があります。これで、キューに入れられた結果を Inspection Results レジスタに入れることができます (これは、オートメーションコントローラが結果を確実に受信するために必要なハンドシェークです)。

検査ステータスレジスタの動作

ビット | ビット名 | バッファリングが無効な場合の結果 | バッファリングが有効な場合の結果
0 | Inspecting | 検査の完了時にトグルされます。 | 検査の完了時にトグルされます。
1 | Inspection Complete | 検査の完了時に切り替えられます。 | 検査の完了時に切り替えられます。
2 | Results Buffer Overflow | 0 に設定されたままです。 | オートメーションコントローラが前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。結果バッファがオーバフローします。検査結果が正常にキューに入れられたときにクリアされます。
3 | Results Valid | 新しい結果が Inspection Results レジスタに入れられたときにセットされます。Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。 | 新しい結果が Inspection Results レジスタに入れられたときにセットされます。Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。

結果バッファリング

検査結果用のキューを有効にする必要があります。有効にした場合、オートメーションコントローラが有限個の検査データ結果を読み取るまでキューに入れておくことができます。これは、システムの複数の部分 (外部オートメーションコントローラを含む) の速度が短時間に低下した場合に、データの流れを滑らかにするのに有効な機能です。

通常、結果が送信される速度より検査を実行する速度の方が速い場合、バッファリングありとバッファリングなしの間の大きな相違点は、破棄される結果を判別するかどうかということです。バッファリングが有効でない場合は最新の結果が保持され、以前の結果はオートメーションコントローラが読み取ることができず失われます。原則的に、最新の結果によって以前の結果が上書きされるだけです。バッファリングが有効である (さらに、キューがいっぱいである) 場合は、結果キューに空きができるまで最新の結果が破棄されます。

Closed 例: 結果オーバフローシーケンス

Job Management

Current Job ID フィールドモジュールは、In-Sight ビジョンシステムの現在のジョブ ID を示します。現在のジョブに ID がない場合は、65535 になります。ジョブをロードするには、Set Offline ビットを使用してオートメーションコントローラがビジョンシステムをオフラインに設定する必要があります。次に、Job Load ID フィールドが該当するジョブの ID に設定され、Initiate Job Load ビットがセットされます。Job Load Complete ビットが High になると、Initiate Job Load ビットがリセットされます。

  • Job Control:Initiate Job Load ビットを Job Load ID フィールドと連動して使用し、ビジョンシステムでジョブのロード操作を開始します。
ビット | 名前 | 説明
0 | Initiate Job Load | セットされると、ビジョンシステムは Job Load ID フィールドで指定したジョブ ID をロードします。
  • Job Status: ジョブのロード操作のステータスを示します。
ビット | 名前 | 説明
0 | Job Loading | このビットは、このプロトコルを通してジョブのロードが開始されたときにセットされます。
1 | Job Load Complete | このビットは、このプロトコルによって開始されたジョブのロード操作の完了時にトグルされます。
2 | Job Load Failed | このビットは、ジョブのロードの最後の試みが失敗したときにセットされます。SLMP スキャナプロトコルがジョブのロードを開始し、ロードに成功するとクリアされます。
  • Job Load ID: オートメーションコントローラが Initiate Job Load ビットと連動して使用することによって、ビジョンシステムでジョブのロード操作を開始します。
バイト | 名前 | 説明
0 ～ 1 | Job Load ID | オートメーションコントローラによって Initiate Job Load ビットがセットされたときにロードされるジョブの ID 番号 (1 ～ 999)。
  • Current Job ID: オートメーションコントローラに現在ロードされているジョブの ID 番号を報告するために、ビジョンシステムが使用します。
バイト | 名前 | 説明
0 | Current Job ID | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

Soft Events

オートメーションコントローラはソフトイベントを使用して、ジョブの特定の動作をトリガすることができます。各ソフトイベントには、トリガとそれに関連付けられている確認応答ビットがあります。トリガビットの立ち上がりエッジによって、In-Sight ビジョンシステムは、ソフトイベントに関連付けられている動作を処理します。ソフトイベントの開始時に、ビジョンシステムは Soft Event Ack ビットを High に設定します。このビットは、オートメーションコントローラが Trigger ビットをリセットして、ソフトイベントに関連付けられている動作の処理が完了するまで High のまま保持されます。ソフトイベントをトリガできない場合は、General Fault ビットが High に設定されます。このビットは、イベントが正常にトリガされるまで High のまま保持されます。

注意: In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

  • Soft Event Control: スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0

  • Soft Event Status: これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0

String Commands

In-Sight ビジョンシステムのネイティブモード通信に基づく、デバイス相互通信の文字列コマンドをサポートします。ネイティブモードコマンドを使用すると、特にコントロールビットを介してコマンドを発行できない場合に有効で、オートメーションコントローラからビジョンシステムに文字列スタイルのコマンドを発行することができます。この節では、ビジョンシステムに文字列コマンドを開始するときに使用される一般的なインタフェース、およびビジョンシステムからの応答の取得方法を定義します。

  • String Command Control:ビジョンシステムでネイティブモード通信を開始します。
ビット | 名前 | 説明
0 | Initiate String Cmd | このビットがセットされると、String Command フィールドからデータが読み取られ、文字列コマンドが実行されます。コマンドの読み取り時には、String Cmd Ack ビットがセットされます。このビットは、ビジョンシステムがコマンドを確実に受信するために、String Cmd Ack ビットをセットするまで High のまま保持する必要があります。
  • String Command Control Data:ネイティブモードコマンドを定義します。
バイト数 | 名前 | 説明
0 ～ 1 | Command Data Length | ネイティブモードコマンドの長さ。
2 ～ 1920 | String Command | ビジョンシステムによって処理されるネイティブモードコマンド。
  • String Command Status: ネイティブモードコマンド文字列のステータスを示します。
ビット | 名前 | 説明
0 | String Cmd Ack | このビットは、ビジョンシステムがコマンドの処理を完了して、コマンドに対する応答を生成したときにセットされます。ビジョンシステムによってこのビットがセットされると、オートメーションコントローラは安全に文字列コマンド応答データを読み取ることができます。オートメーションコントローラが Initiate String Cmd ビットをクリアした後で、このビットがリセットされます。オートメーションコントローラは、Initiate String Cmd ビットをクリアして String Cmd Ack ビットが Low 状態に戻ってから、新しいコマンドを開始する必要があります。
1 | String Cmd Error | このビットは、前の文字列コマンドの結果がエラーコードを返したかどうかを示します。
  • String Command Response Data:ネイティブモードコマンド文字列のステータスコード。
バイト数 | 名前 | 説明
0 ～ 1 | Response Result Code | ネイティブモードコマンドの応答コード。コマンドが成功したか失敗したかを、このコードで判別することができます。 注意:すべてのネイティブモードコマンドはここで確認できます。各コマンドは正常に実行された場合、1 を返します。失敗した場合、各コマンドに固有のエラーコードがあります。エラーコードの詳細については、各ネイティブモードコマンドのトピックを参照してください。
2 ～ 3 | Response Length | ネイティブモードコマンドの応答データの長さ (バイト単位)。
4 ～ 1920 | Response Data | ネイティブモードコマンドの結果文字列。コマンドによって返されるデータの ASCII 文字列表記です。

SLMP スキャナのポーリング

SLMP スキャナはコマンド/応答ベースのプロトコルであり、In-Sight ビジョンシステムから送信されます。またビジョンシステムは、コントロールビットが変化したかどうかを判別するために、定期的な間隔でオートメーションコントローラに読み取り要求を送信する必要があります。このプロセスは「ポーリング」と呼ばれ、ポーリングサイクルが定義されています。

ポーリングサイクル

すべてのポーリングサイクルの最初には、オートメーションコントローラからビジョンコントロールビットブロックが読み取られます。次に、ビジョンシステムは、コントロールブロック内のビットの状態変化を順番に処理します。一部の状態変化では、オートメーションコントローラとの追加の通信 (Job ID または User Data フィールドの読み取り、ステータスブロックの書き込みなど) が必要です。これらの要求は、1 つのキューに入れられます。ポーリングメカニズムは、キュー内の項目がなくなるかまたはポーリング間隔を超えるまで、これらの要求を順番に処理します。ポーリングサイクルが完了すると、サイクルは繰り返されません。

注意:
  • 前のサイクルでキューに入れられたにもかかわらず処理されていない通信項目は、次のサイクル時に最初に処理されます。サイクルの最初にキュー内にいくつかの項目があるときには、次のポーリングサイクルの処理によって遅延が発生することがある場合でも、各ポーリングサイクルでキュー内の少なくとも 1 つの項目が常に処理されます。
  • [SLMP スキャナ設定] ダイアログ内の [ポーリング間隔 (ms)] パラメータを使用すると、ポーリングサイクルの間隔を定義することができます。

ブロック通信

下の表では、ビジョンコントロールビットブロック内のステータスビットの変化に応じて、In-Sight ビジョンシステムが実行する操作を定義します。

ブロック | 読み取り/書き込みが行われる場合 | 操作
ビジョンコントロールビットブロック | ユーザが指定した定期的な間隔で読み取ります。 | Acquisition Trigger Soft Event ほかのブロックの読み取りまたは書き込み
ビジョンステータスビットブロック | 最初に接続が確立されて、新しいステータスが使用可能なときに書き込まれます。 |
入力ワードブロック | 新しい検査結果が使用可能であるか、またはジョブ変更が発生したときに書き込まれます。 |
出力ワードブロック | Set User Data ビットが 0 から 1 に変化したか、または Initiate Job Load ビットが 0 から 1 に変化したときに読み取られます。 | User Data フィールドの読み取り後、User Data Ack ビットをセットします。
文字列コマンドワードブロック | Initiate String Command ビットが 0 から 1 に変化したときに読み取られます。 | 文字列コマンドを処理します。
文字列コマンド結果ブロック | 新しい文字列コマンド結果が使用可能なときに書き込まれます。 | 文字列コマンド結果ワードブロックの書き込み後、String Cmd Ack ビットをセットします。

一般的なシーケンス図

次の図は、画像取り込みおよび検査サイクルをトリガするオートメーションコントローラに対応する、In-Sight ビジョンシステムの一般的な動作を示しています。
Version: 5.6.0


SLMP スキャナファクトリインターフェイス - In-Sight 5.x.x ファームウェア

SLMP 通信

In-Sight 関数リファレンス

このトピックでは、In-Sight 5.1.0 以降のファームウェアを搭載する In-Sight ビジョンシステムにおける SLMP スキャナ通信を説明します。

  • SLMP スキャナのオペレーション
  • 定義済みデータブロック
  • 三菱電機シーケンサで使用可能なデバイスとデバイス範囲
  • GX Works 上のエラー

SLMP スキャナのオペレーション

SLMP プロトコルスキャナはコマンド/応答ベースのプロトコルであり、In-Sight ビジョンシステムから送信されます。またビジョンシステムは、コントロールビットが変化したかどうかを判別するために、定期的な間隔で PLC に読み取り要求を送信する必要があります。 このプロセスは「ポーリング」と呼ばれ、ポーリングサイクルが定義されています。

  • ポーリングサイクル
  • 一般的なシーケンス図
  • 一般的な画像取り込みシーケンス
  • 一般的な検査シーケンス
  • 一般的なジョブ管理シーケンス
  • 一般的なソフトイベントシーケンス
  • 一般的な文字列コマンドシーケンス

ポーリングサイクル

すべてのポーリングサイクルの最初には、PLC/MC からビジョンコントロールビットブロックが読み取られます。 次に、ビジョンシステムは、コントロールブロック内のビットの状態変化を順番に処理します。 一部の状態変化では、PLC/MC との追加の通信 (Job ID または User Data フィールドの読み取り、ステータスブロックの書き込みなど) が必要です。 これらの要求は、1 つのキューに入れられます。 ポーリングメカニズムは、キュー内の項目がなくなるかまたはポーリング間隔を超えるまで、これらの要求を順番に処理します。 ポーリングサイクルが完了すると、サイクルは繰り返されません。

注:
  • 前のサイクルでキューに入れられたにもかかわらず処理されていない通信項目は、次のサイクル時に最初に処理されます。 サイクルの最初にキュー内にいくつかの項目があるときには、次のポーリングサイクルの処理によって遅延が発生することがある場合でも、各ポーリングサイクルでキュー内の少なくとも 1 つの項目が常に処理されます。
  • [SLMP スキャナの設定] ダイアログ内の [ポーリング間隔 (ms)] パラメータを使用すると、ポーリングサイクルの間隔を定義することができます。

ブロック通信

下の表では、ビジョンコントロールビットブロック内のステータスビットの変化に応じて、In-Sight ビジョンシステムが実行する操作を定義します。

ブロック | 読み取り/書き込みが行われる場合 | 操作
ビジョンコントロールビットブロック | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。 | Acquisition Trigger Soft Event ほかのブロックの読み取りまたは書き込み
ビジョンステータスビットブロック | 最初に接続が確立されて、新しいステータスが使用可能なときに書き込まれます。 |
入力ワードブロック | 新しい検査結果が使用可能であるか、またはジョブ変更が発生したときに書き込まれます。 |
出力ワードブロック | Set User Data ビットが 0 から 1 に変化したか、または Execute Command ビットが 0 から 1 に変化したときに読み取られます。 | User Data フィールドの読み取り後、User Data Ack ビットをセットします。
文字列コマンドワードブロック | Initiate String Command ビットが 0 から 1 に変化したときに読み取られます。 | 文字列コマンドを処理します。
文字列コマンド結果ブロック | 新しい文字列コマンド結果が使用可能なときに書き込まれます。 | 文字列コマンド結果ワードブロックの書き込み後、String Cmd Ack ビットをセットします。

一般的なシーケンス図

次の図は、画像取り込みおよび検査サイクルをトリガする PLC/MC に対応する、In-Sight ビジョンシステムの一般的な動作を示しています。

一般的な画像取り込みシーケンス

注: In-Sight ビジョンシステムを、ネイティブモード コマンドを介して PLC/MC から画像取り込みをトリガするよう設定する場合、SetEvent および Wait 関数を使用し、Event コードを 8 (SW8) にすることが推奨されます。 この設定により、ビジョンシステムは画像取り込みおよび検査が完了するのを待ってから、PLC/MC に『完了』応答を送信します。また、以前の検査結果は PLC/MC に送信されません。 ビジョンシステムからの『完了』応答は、検査結果の読み取りを送信する、条件付きの PLC ロジックを作成するのにも使用できます。

In-Sight ビジョンシステムは、ビジョンコントロールブロックの Trigger Enable および Trigger ビットを直接操作することにより画像取り込みが行えます。またビジョンコントロールブロックの Trigger Ready、Trigger Ack、Acquiring、および Missed Acq ビットにより画像取り込み状況をモニタリングすることができます。

最初の起動時には、Trigger Enable ビットは偽であり、トリガを有効にするには真に設定する必要があります。 ビジョンシステムがトリガを受け入れる準備ができると、Trigger Ready ビットが真に設定されます。

Trigger Enable および Trigger Ready ビットが真である間、Trigger ビットが 0 から 1 に変化するのをビジョンシステムが認識するたびに、画像取り込みが開始されます。 Trigger Ack ビットが同じ状態値になるまで、Trigger ビットを新しい状態で保持する必要があります (これは、ビジョンシステムが変化を確実に確認するために必要なハンドシェークです)。

画像取り込みの間、ビジョンステータスブロックのTrigger Ready ビットはクリアされます。 画像取り込みの最後に Exposure Complete ビットが設定されます。このビットは、Clear Exposure Complete ビットによってのみクリアできます。

トリガメカニズムを強制的にリセットするには、ビジョンステータスブロックが 0 になるまで、Trigger Enable ビットを偽に設定します。 Trigger Enable ビットを真に設定すると、画像取り込みが再度有効になります。

Closed 例: 一般的な画像取り込みシーケンス

Closed 例: 検査シーケンスより高速な画像取り込み

一般的な検査シーケンス

ビジョンステータスブロックおよびビジョンコントロールブロックを使用すると、PLC/MC は、In-Sight ビジョンシステムのビジョン処理部分をモニタして新しい結果が有効になる時期を判別し、ビジョンシステムが新しい結果をキューに入れるように要求することができます。

検査/結果シーケンス

In-Sight ビジョンシステムによって取り込まれた画像は、処理のためにキューに入れられます。 ビジョンシステムが画像を処理している間、System Busy ビットが設定されます。 ビジョンシステムが画像の処理を終了すると、System Busy ビットがクリアされ、Inspection Completed ビットが立ちます。

ビジョンシステムでの検査結果の取り扱い方は、Buffer Results Enable ビットによって決定されます。 Buffer Results Enable ビットが偽に設定された場合、検査結果は直ちに出力ワードブロックに入れられ、Results Valid ビットが真に設定されます。 Buffer Results Enable ビットが真に設定されると、新しい結果がキューに入れられます。 以前の検査結果は、PLC/MC によって確認応答されるまで出力ワードブロックに入ったままであり、Inspection Results Ack ビットが真に設定されます。 Results Valid ビットがクリアされると、PLC/MC は Inspection Results Ack ビットを偽に戻す必要があります。これで、キューに入れられた結果を出力ワードブロックに入れることができます (これは、PLC/MC が結果を確実に受信するために必要なハンドシェークです)。

ビジョンステータスブロックの動作

ビット | ビット名 | バッファリングが無効な場合の結果 | バッファリングが有効な場合の結果
0 | System Busy | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。 | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。
1 | Inspection Complete | 検査の完了時に切り替えられます。 | 検査の完了時に切り替えられます。
2 | Results Buffer Overflow | 0 に設定されたままです。 | PLC/MC が前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。結果バッファがオーバフローします。 検査結果が正常にキューに入れられたときにクリアされます。
3 | Results Valid | 新しい結果が出力ワードブロックに入れられたときにセットされます。 Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。 | 新しい結果が出力ワードブロックに入れられたときにセットされます。 Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。

結果バッファリング

検査結果用のキューを有効にする必要があります。 有効にした場合、PLC/MC が有限個の検査データ結果を読み取るまでキューに入れておくことができます。 これは、システムの複数の部分 (外部 PLC/MC を含む) の速度が短時間に低下した場合に、データの流れをスムーズに滑らかにするのに有効な機能です。

通常、結果が送信される速度より検査を実行する速度の方が速い場合、バッファリングありとバッファリングなしの間の大きな相違点は、破棄される結果を判別するかどうかということです。 バッファリングが有効でない場合は最新の結果が保持され、以前の結果は PLC/MC が読み取ることができず失われます。 原則的に、最新の結果によって以前の結果が上書きされるだけです。 バッファリングが有効である (さらに、キューがいっぱいである) 場合は、結果キューに空きができるまで最新の結果が破棄されます。

Closed 例: 結果オーバフローシーケンス

一般的なジョブ管理シーケンス

Current Job ID フィールドモジュールは、In-Sight ビジョンシステムの現在のジョブ ID を示します。現在のジョブに ID がない場合は、65535 になります。 ジョブをロードするには、Set Offline ビットを使用して PLC/MC がビジョンシステムをオフラインに設定する必要があります。 次に、Command フィールドが該当するジョブの ID に設定され、Execute Command ビットがセットされます。 Command Completed ビットが High になると、Execute Command ビットがリセットされます。

一般的なソフトイベントシーケンス

PLC/MC はソフトイベントを使用して、ジョブの特定の動作をトリガすることができます。 各ソフトイベントには、トリガとそれに関連付けられている確認応答ビットがあります。 トリガビットの立ち上がりエッジによって、In-Sight ビジョンシステムは、ソフトイベントに関連付けられている動作を処理します。 ソフトイベントの開始時に、ビジョンシステムは Soft Event Ack ビットを High に設定します。 このビットは、PLC/MC が Trigger ビットをリセットして、ソフトイベントに関連付けられている動作の処理が完了するまで High のまま保持されます。 ソフトイベントをトリガできない場合は、General Fault ビットが High に設定されます。このビットは、イベントが正常にトリガされるまで High のまま保持されます。

注: In-Sight Explorer または VisionView アプリケーションが検査をモニタリングするジョブ設置環境下で、ジョブがソフトイベント (Timer 関数など) によってスプレッドシートイベントをトリガする場合、画像取り込みサイクル完了直後にトリガすると、画像検査に遅延が発生することがあります。 ジョブファイルが大きい場合 (ジョブロジックに追加して、パターンマッチ、傷検査 や InspectEdge ツールなど、多くのビジョンツールが含まれている場合)、In-Sight Explorer または VisionView を更新する必要があるため、ディスプレイの更新がキューに入るまで、画像が検査できないことがあります。 正確なタイミングが必要とされるアプリケーションでは、更新により PASS/FAIL 結果の決定が遅延し、検査処理中の次のステーションへの結果送信が遅延する可能性があります。 したがって、こういったアプリケーション環境では、検査の遅延を防ぐため、ソフトイベントを使用しないことを推奨します。

一般的な文字列コマンドシーケンス

In-Sight ビジョンシステムのネイティブモード通信に基づく、デバイス相互通信の文字列コマンドをサポートします。 ネイティブモードコマンドを使用すると、特にコントロールビットを介してコマンドを発行できない場合に、PLC/MC からビジョンシステムに文字列スタイルのコマンドを発行することができます。

SLMP 定義済みデータブロック

定義済みデータブロックを使用すると、ビジョンシステムが PLC/MC との間でデータの読み取り、および書き込みを行う場所を制御することができます。 アプリケーションの設定をするために、コマンド機能に必要なさまざまなコントロールおよびステータスビットは連続したブロックにグループ化され、これらを同時に処理することができます。 ビジョンシステムと PLC/MC 間の相互の設定をする場合は、データの各ブロックに対して開始アドレスとデバイスタイプを選択する必要があります。

  • ビジョンコントロールブロック
  • ビジョンステータスブロック
  • 出力ワードブロック
  • 入力ワードブロック
  • 文字列コマンドワードブロック
  • 文字列コマンド結果ワードブロック

ブロック | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
ビジョン コントロール | 0 | Set Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Reserved
 | 2 | Reserved |  |  |  | Clear Exposure Complete | Clear Error | Initiate String Command | Set User Data
 | 3 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
ビジョン ステータス | 0 | Online | Offline Reason |  |  | Missed Acq | Reserved | Trigger Ack | Trigger Ready
 | 1 | Error | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 | 2 | Reserved |  |  | Job Pass | Exposure Complete | String Command Error | String Command Ack | Set User Data Ack
 | 3 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0
出力 ワード | 0..1 | Current Job ID
 | 2..3 | Error Code
 | 4..5 | Acquisition ID
 | 6..7 | Inspection ID
 | 8..9 | Inspection Result Code
 | 10.. | Inspection Results
入力 ワード | 0..1 | Command
 | 2..3 | Reserved
 | 4.. | User Data
文字列 コマンド ワード | 0..1 | String Command Length
 | 2.. | String Command
文字列 コマンド 結果 ワード | 0..1 | Result Code
 | 2..3 | String Command Result Length
 | 4.. | String Command Result

ビジョンコントロールブロック

バイト 0

ビット | 名前 | 説明
7 Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6-5 | Reserved | 使用されません。
4 | Execute Command | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC/MC が Inspect Count、Inspection Result Code、および Inspection Results データを受信したことを確認応答します。 その後、次の検査結果のセットが PLC/MC に送信されます。 Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。
2 | Buffer Results Enable | このビットがセットされると、Inspection Count、Inspection Result Code、および Inspection Results フィールドは、Inspection Results Ack ビットがセットされて確認応答されるまで変化しません。 最大 8 つの検査が In-Sight ビジョンシステムのバッファに保持されます。 ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。 Inspection Results Ack ビットがクリアされて、PLC/MC に送信される新しい結果セットがあるときには、Results Valid ビットはクリアされません。 Inspection Results Ack ビットがクリアされて、PLC/MC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • [トリガ] パラメータが [ネットワーク]、[外部] または [産業用イーサネット] に設定されている。
注:
  • [トリガ] パラメータは、スプレッドシートビューでは AcquireImage 関数、EasyBuilder では [画像の設定] アプリケーションステップで設定することができます。
  • トリガが PLC/MC から送信される場合、[産業用イーサネット] トリガタイプを使用してください。
0 | Trigger Enable | このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

バイト 1

ビット | 名前 | 説明
7-1 | Reserved | 使用されません。

バイト 2

ビット | 名前 | 説明
7-4 | Reserved | 使用されません。
3 | Clear Exposure Complete | この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。
2 | Clear Error | このビットをセットすると、エラーシグナルとエラーコードシグナルがクリアされます。Clear Error ビットは、Error ビットがクリアされるまで [High] に維持する必要があります。エラーがキューに入れられた場合、このビットがクリアされると、エラーシグナルとエラーコードシグナルは、キューに入れられた次のエラーコードに対してセットされます。
1 | Initiate String Command | このビットがセットされると、String Command フィールドからデータが読み取られ、文字列コマンドが実行されます。 コマンドの読み取り時には、String Cmd Ack ビットがセットされます。 このビットは、ビジョンシステムがコマンドを確実に受信するために、String Cmd Ack ビットをセットするまで High のまま保持する必要があります。
0 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC/MC から In-Sight ビジョンシステムへ通知します。

バイト 3

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

ビジョンステータスブロック

バイト 0

ビット | 名前 | 説明
7 | Online | ここのビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6-4 Offline Reason

このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 Missed Acq

画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

注: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。
2 | Reserved | 使用されません。
1 Trigger Ack

In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。また、Acquisition ID は、このビットの立ち上がりエッジにラッチできます。

注: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。
0 Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注: トリガが PLC/MC から送信される場合、[産業用イーサネット] トリガタイプを使用してください。

バイト 1

ビット | 名前 | 説明
7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
6 | Command Failed | ビットが 1 にセットされ、Job Load に失敗し完了まで実行できなかったことを示します。 PLC/HMI により新しいジョブがロードされると、クリアされます。 In-Sight Explorer により新しいジョブがロードされた場合は、変更はありません。 このビットは、常に Command Completed の前にセットされます。
5 Command Completed コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。

注: Execute Command ビットが Low の場合、ビジョンシステムは Command Completed ビットをクリアします。
4 | Command Executing | Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注: オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。
2 Results Buffer Overrun

このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC/MC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。 最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。9 番目の検査と後続のすべての検査は、バッファに空きが生じるまで (結果が確認応答されたとき) 破棄されます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。 Inspection Count、Inspection Result Code、Inspection Results、Job Pass ビットが PLC に送信された後、トグルされることを保証します。
0 System Busy

ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

バイト 2

ビット | 名前 | 説明
7-5 | Reserved | 使用されません。
4 Job Pass

このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。

注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
2 | String Command Error | このビットは、前の文字列コマンドの結果がエラーコードを返したかどうかを示します。
1 | String Command Ack | このビットは、ビジョンシステムがコマンドの処理を完了して、コマンドに対する応答を生成したときにセットされます。 ビジョンシステムによってこのビットがセットされると、PLC/MC は安全に文字列コマンド応答データを読み取ることができます。 PLC/MC が Initiate String Cmd ビットをクリアした後で、このビットがリセットされます。 PLC/MC は、Initiate String Command ビットをクリアして String Command Ack ビットが Low 状態に戻ってから、新しいコマンドを開始する必要があります。
0 | Set User Data Ack | このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。

バイト 3

ビット | 名前 | 説明
7 | Soft Event Ack 7 | これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
6 | Soft Event Ack 6
5 | Soft Event Ack 5
4 | Soft Event Ack 4
3 | Soft Event Ack 3
2 | Soft Event Ack 2
1 | Soft Event Ack 1
0 | Soft Event Ack 0

出力ワードブロック

バイト 0 - 1

名前 | 説明
Current Job ID | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

バイト 2 - 3

名前 説明
Error Code

発生したエラーを 16 ビットで表します。

コード | エラー | 説明
0x0000 | No Error | エラーは起こりませんでした。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされるか、または AcquireImage 関数の [トリガ] パラメータが [外部]、[ネットワーク] または [産業用イーサネット] に設定されているときに、Trigger ビットがセットされると発生します。
0x0101 | Trigger set while Offline | ビジョンシステムオフライン中に、Trigger ビットがセットされると発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Executing ビットが HIGH の場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムオンライン中に、Job Load コマンドが発行されたときに発生します。

バイト 4 - 5

名前 | 説明
Acquisition ID | この ID は、取り込みの開始時と Trigger Ack ビットがセットされると増分され、取り込みとその検査結果の同期に使用できます。

バイト 6 - 7

名前 | 説明
Inspection ID | この結果セットに関連付けられている取り込み ID。

バイト 8 - 9

名前 | 説明
Inspection Result Code | 検査結果コードは、WriteResultsBuffer 関数の [結果コード] パラメータによって定義されます。

バイト 10 - 1914

名前 | 説明
Inspection Results | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

入力ワードブロック

バイト 0 - 1

名前 説明
コマンド

これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。

注: ジョブロード時に無効なジョブ ID が指定されていると (例えば、05.job。05.job は接続中の In-Sight ビジョンシステムに存在しない)、以前のジョブの代わりに、新規の空のジョブがロードされます。

バイト 2 - 3

名前 | 説明
Reserved | 使用されません。

バイト4 - 1920

名前 | 説明
User Data | 。ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

文字列コマンドワードブロック

バイト 0 - 1

名前 | 説明
String Command Length | ネイティブモードコマンドの長さ。

バイト 2 - 1920

名前 | 説明
String Command | ビジョンシステムによって処理されるネイティブモードコマンド。

文字列コマンド結果ワードブロック

バイト 0 - 1

名前 | 説明
Result Code | ネイティブモードコマンド用応答コード。コマンドが成功したか失敗したかどうかを決定するのに使用できます。 注: ネイティブモードコマンドの一覧はここで見ることができます。コマンドは、成功の場合、1 を返します。しかし、失敗の場合に返されるエラーコードは、各コマンドによって異なります。 エラーコードについては、ネイティブモードコマンドの各トピックをご参照ください。

バイト 2 - 3

名前 | 説明
String Command Result Length | ネイティブモードコマンドの Response Data の長さ (バイト単位) 。

バイト 4 -

名前 | 説明
String Command Result | ネイティブモードコマンドの結果文字列。コマンドによって返されるデータは、ASCII 文字列です。

三菱電機シーケンサで使用可能なデバイスとデバイス範囲

三菱電機シーケンサで SLMP スキャナ通信を行う場合の、使用可能なデバイスと範囲を下記に示します。

シーケンサ：iQ-R/Q/L シリーズ

コントロールビットブロック／ステータスビットブロック

デバイス名 | デバイス範囲
X, Y, B, W | 0～FFFF (16進数)
M, L, F, D, R, ZR | 0～65535

入力ワードブロック／出力ワードブロック／コマンドワードブロック／コマンド結果ワードブロック

デバイス名 | デバイス範囲
D, R, ZR, TN, CN | 0～65535
W | 0～FFFF (16進数)

シーケンサ：iQ-F シリーズ

コントロールビットブロック／ステータスビットブロック

デバイス名 | デバイス範囲
X, Y | 0～177777 (8進数)
M, F, D | 0～65535

入力ワードブロック／出力ワードブロック／コマンドワードブロック／コマンド結果ワードブロック

デバイス名 | デバイス範囲
D | 0～65535

シーケンサ：FX シリーズ

コントロールビットブロック／ステータスビットブロック

デバイス名 | デバイス範囲
X, Y | 0～177777 (8進数)
M, D, R, S | 0～65535

入力ワードブロック／出力ワードブロック／コマンドワードブロック／コマンド結果ワードブロック

デバイス名 | デバイス範囲
D, R, TN, CN | 0～65535

GX Works 上のエラー

[モニタ情報] のエラーコード

GXWorks の [センサ・機器モニタ Ethernet 構成] ダイアログ、[モニタ情報] セクションに表示されるエラーコードを、次の表に示します。

エラーコード | 説明
0 | SLMP 稼働中/接続しています
1 | SLMP に接続中です
3 | SLMP 障害 (エラーの詳細が取得できない場合に表示される、デフォルトのエラーコード)
7 | エラー: ステータスブロック
8 | エラー: コントロールブロック
9 | エラー: 出力ブロック
10 | エラー: 入力ブロック
11 | エラー: コマンドブロック
12 | エラー: 結果ブロック
13 | SLMP プロトコルが稼働していません
14 | プロトコル保留中。プロトコルを変更した場合、センサ再起動後にプロトコルが有効になります。
Version: 5.6.0


iQ Sensor Solution 経由での三菱電機 L シリーズオートメーションコントローラとの通信

三菱電機の通信

In-Sight 通信リファレンス

  • 概要
  • GX Works2 での In-Sight ビジョンシステムの検出
  • SLMP スキャナパラメータの読み取りと書き込み
  • In-Sight ビジョンシステムのステータスのモニタ
  • 関連項目

概要

このトピックでは、iQ Sensor Solution を In-Sight ビジョンシステム用に設定し、ビジョンシステムと三菱電機オートメーションコントローラの間で GX Works2 を使用してデータを転送する方法について説明します。このトピック中の例は、以下のコンポーネントが使用されていることを前提に記述されています。

  • ファームウェアバージョン 4.x.x を実行可能な In-Sight ビジョンシステム

  • 三菱電機 iQ-R、Q、L または iQ-F シリーズ (3E フレーム) オートメーションコントローラ

    注意: FX シリーズ (1E フレーム) はサポートされていません。

  • 三菱電機 GX Works2 ソフトウェア (SWnDNC-GXW2-E) バージョン 1.492 以降
  • In-Sight Explorer 4.x.x に付属の Cognex In-Sight プロファイル言語パッケージ (英語 = CognexInsight_en.ipar、日本語 = CognexInsight_ja.ipar)
注意:
  • iQ Sensor Solution は、In-Sight ファームウェアバージョン 4.x.x を搭載した In-Sight ビジョンシステムでのみサポートされています。
  • 三菱電機 iQ Sensor Solution の詳細については、三菱電機の『iQ Sensor Solution リファレンスマニュアル』を参照してください。

三菱電機 iQ Sensor Solution

三菱電機 iQ Sensor Solution は、GX Works2 ソフトウェアで SLMP スキャナプロトコルを介して In-Sight ビジョンシステムを制御できるようにする、ファクトリプロトコルです。iQ Sensor Solution を使用して、GX Works2 でネットワーク上のビジョンシステムの検出、ビジョンシステムの SLMP スキャナパラメータ設定の読み取り/書き込み、ビジョンシステムのステータスのモニタを行うことができます。

注意:GX Works2 の詳細については、『GX Works2 オペレーティングマニュアル』を参照してください。

GX Works2 での In-Sight ビジョンシステムの検出

以下の手順は、In-Sight ビジョンシステムがこれまで SLMP スキャナ用に設定されておらず、サポートされる三菱電機オートメーションコントローラと同じ Ethernet サブネットに接続されていることを前提にしています。

  1. GX Works2 を起動します。

  2. GX Works2 で新規プロジェクトを作成します。

  3. [ツール] メニューの [プロファイル登録] を選択します。[プロファイル登録] ウィンドウが開きます。

  4. Cognex In-Sight プロファイル言語パッケージ (英語 = CognexInsight_en.ipar、日本語 = CognexInsight_ja.ipar) に移動し、[登録] をクリックします。

    注意:デフォルトでは、Cognex In-Sight プロファイル言語パッケージは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 4.9.x\Factory Protocol Description\ESPP にインストールされています。

  5. プロジェクトビューで、[パラメータ] → [PC パラメータ] を選択します。[L パラメータ設定] ウィンドウが表示されます。

  6. [内蔵 Ethernet ポート設定] タブを選択します。

  7. [Set Open Setting in Ethernet Configuration] チェックボックスをオンにします。次のメッセージが表示されます。

  8. [はい] をクリックします。[オープン設定] ボタンが、[Ethernet 構成設定] ボタンに変化します。

  9. [Ethernet 構成設定] ボタンをクリックします。[Ethernet 構成 (内蔵 Ethernetポート)] ウィンドウが表示されます。

  10. [Ethernet 構成] → [オンライン] → [接続機器の自動検出] を選択します。次のメッセージが表示されます。

  11. メッセージを読んで、[はい] をクリックします。[Ethernet 構成] ウィンドウに、実際のシステム設定が反映されます。

  12. [設定を反映して閉じる] を選択します。[Ethernet 構成] ウィンドウの設定が保存され、システム設定が完了します。
注意:
  • 接続済みデバイスの自動検出後、[Ethernet 構成設定] ウィンドウには最大 16 個の In-Sight ビジョンシステムが (IP アドレスの昇順に) 表示されます。
  • [接続機器の自動検出] ボタンを押したとき、ネットワーク内のビジョンシステムが iQSS 互換ではない場合、そのビジョンシステムは [Ethernet 構成] ウィンドウに表示されません。ビジョンシステムが iQSS 互換であっても、あらかじめ GX Works2 にプロファイルが追加されていない場合は、「プロファイルのないモジュールが検出されました」と表示されます。
  • 実際のシステム設定でビジョンシステムが検出された場合
  • システム設定内にエラーが存在する場合、接続済みデバイスの自動検出の実行後、[出力] ウィンドウにエラー情報が表示されます。[出力] ウィンドウでエラーをダブルクリックすると、エラーの対象先にジャンプしてエラーを修正できます。
  • トラブルシューティングの詳細については、三菱電機の『iQ Sensor Solution リファレンスマニュアル』を参照してください。

In-Sight ビジョンシステムへの通信設定の反映

IP アドレスなどの通信設定を、In-Sight ビジョンシステムに反映することができます。この機能は、ビジョンシステムの設定を追加、削除、または変更した後に実行します。

  1. GX Works2 で、[Ethernet 構成] ウィンドウを開きます (このウィンドウの表示については、「GX Works2 での In-Sight ビジョンシステムの検出」の節を参照してください)。
  2. 対象の In-Sight ビジョンシステムを選択して、通信設定を行います。

  3. デバイスマップ領域で、対象のビジョンシステムを右クリックします。

  4. [オンライン] → [Communication Setting Reflection of Ethernet Device] を選択します。これにより、選択したビジョンシステムに通信設定が反映されます。

SLMP スキャナパラメータの読み取りと書き込み

注意:SLMP スキャナパラメータの詳細については、SLMP スキャナパラメータの節を参照してください。

  1. GX Works2 で、[Ethernet 構成設定] ウィンドウを開きます(このウィンドウの表示については、「GX Works2 での In-Sight ビジョンシステムの検出」の節を参照してください)。

  2. デバイスマップ領域で、対象の In-Sight ビジョンシステムを右クリックします。

  3. [オンライン] → [Ethernet 機器のパラメータ処理] を選択します。[Ethernet 機器のパラメータ処理] ウィンドウが表示されます。

パラメータの読み取り

  1. ビジョンシステムのパラメータを読み取るには、[Method selection] ドロップダウンリストから、「パラメータの読み取り」を選択します。
  2. 読み取るパラメータのチェックボックスがオンになっていることを確認します。
  3. [実行] ボタンをクリックします。「読み取り値」列に、ビジョンシステムのパラメータ値が表示されます。

パラメータの書き込み

  1. ビジョンシステムのパラメータを書き込むには、[Method selection] ドロップダウンリストから、「パラメータの書き込み」を選択します。
  2. 書き込むパラメータのチェックボックスがオンになっていることを確認します。
  3. 「書き込み値」列に値を入力します。
  4. [実行] ボタンをクリックします。これにより、新しいパラメータ値がビジョンシステムに書き込まれます。

SLMP スキャナパラメータ

ID | 名前 | タイプ | サイズ (バイト) | 説明 | 対応する In-Sight Explorer の GUI
1　(4.x.x) | SLMP Scanner Enable1 | バイト | 1 | ビジョンシステムの SLMP スキャナサービスを有効にします。0 = 無効 (デフォルト)、1 以上 = 有効。 | [ネットワークの設定] ダイアログ
2 Controller Type 列挙 1 通信する三菱電機 PLC/MC のタイプを指定します。[iQ-R/F/Q/L シリーズ (3E Frame)]、[iQ-F シリーズ (3E Frame)] または [FX Series (1E Frame)]1。デフォルト = [iQ-R/F/Q/L Series (3E Frame)]。
 [SLMP スキャナ設定] ダイアログ
([設定] タブ)
3 | Controller IP Address | 文字列 | In-Sight ビジョンシステムが接続する PLC/MC の IP アドレスを指定します。
4 | Controller Port | ワード | 2 | PLC/MC が使用する SLMP/MC プロトコルチャネルの TCP ポート番号を 10 進値 (1 ～ 65535) 形式で指定します (デフォルト = 12288 ([Dec]))。
5 | SLMP Timeout | ワード | 2 | PLC/MC から MC プロトコルメッセージへの応答用のタイムアウトをミリ秒単位で指定します (5 ～ 30000、デフォルト = 1000)。
6 | SLMP Poll Interval | ワード | 2 | PLC/MC 上のビジョンコントロールブロックの連続するポーリング間の時間をミリ秒単位で指定します (5 ～ 30000、デフォルト = 1000)。
7 SLMP Control Address 文字列
ビジョンコントロールデータブロックの PLC/MC 先頭アドレス。

iQ-R/Q/L シリーズ: なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、L - ラッチリレー、F - アナンシエータ、B - リンクリレー、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ

iQ-F シリーズ: なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、F - アナンシエータ、D - データレジスタ
[SLMP スキャナ設定] ダイアログ
([デバイスのアドレス指定] タブ)
8 SLMP Status Address 文字列
ビジョンステータスデータブロックの PLC/MC 先頭アドレス。

iQ-R/Q/L シリーズ: なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、L - ラッチリレー、F - アナンシエータ、B - リンクリレー、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ

iQ-F シリーズ: なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、F - アナンシエータ、D - データレジスタ
9 SLMP Input Address 文字列
検査結果データブロックの PLC/MC 先頭アドレス。

iQ-R/Q/L シリーズ: なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ

iQ-F シリーズ: なし (デフォルト)、D - データレジスタ
10 SLMP Input Size ワード 2
PLC/MC と通信されるデータブロックのサイズを指定します。
2 つのデバイス2 + 入力データ長 (ワード単位) (最大: 960 ワード)
11 SLMP Output Address 文字列
ユーザデータブロックの PLC/MC 先頭アドレス。

iQ-R/Q/L シリーズ: なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ

iQ-F シリーズ: なし (デフォルト)、D - データレジスタ
12 SLMP Output Size ワード 2
PLC/MC と通信されるデータブロックのサイズを指定します。
5 つのデバイス3 + 出力データ長 (ワード単位) (最大: 960 ワード)
13 SLMP Command Address 文字列
コマンド文字列の PLC/MC 開始アドレス。

iQ-R/Q/L シリーズ: なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ

iQ-F シリーズ: なし (デフォルト)、D - データレジスタ
14 SLMP Command Size ワード 2
PLC/MC と通信されるデータブロックのサイズを指定します。
0 ～ 960 (デフォルト = 0)
15 SLMP Command Result Address 文字列
コマンド結果データの PLC/MC 開始アドレス。

iQ-R/Q/L シリーズ: なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ

iQ-F シリーズ: なし (デフォルト)、D - データレジスタ
16 SLMP Command Result Size ワード 2
PLC/MC と通信されるデータブロックのサイズを指定します。
0 ～ 960 (デフォルト = 0)

1 [FX Series (1E Frame)] は iQ Sensor Solution ではサポートされません。

2 2 つのデバイス (4 バイト/2 ワード) は、[Job Load ID] と [User Length] で使用します。

3 5 つのデバイス (10 バイト/5 ワード) は、[Job ID]、[Acquisition ID]、[Inspection ID]、[Inspection Result Code]、[Inspection Result Length] で使用します。

In-Sight ビジョンシステムのステータスのモニタ

  1. GX Works2 を起動して、当該のネットワークが設定されているプロジェクトを開きます。
  2. [診断] メニューの [センサ・機器モニタ] を選択します。[Module Selection (センサ・機器モニタ)] ウィンドウが表示されます。

  3. [OK] をクリックします。[センサ・機器モニタ] ウィンドウに、内蔵 Ethernet ポート内蔵 LCPU に接続されているビジョンシステムのステータスが表示されます。

  4. 「デバイスのリスト」または「デバイスマップ領域」から、目的のビジョンシステムを選択します。[モニタ情報] ウィンドウに、ビジョンシステムのステータスが表示されます。

    注意:[Ethernet 構成] ウィンドウでは、一度に 1 つのビジョンシステムのみをモニタすることができます。

関連項目

SLMP スキャナ

[ネットワークの設定] ダイアログ


Motoman 通信

In-Sight 通信リファレンス

Motoman MRC、MRC-II、および XRC ロボットコントローラは、複雑ですが非常に強力なエラーチェックプロトコルを使用して、RS-232 シリアルポート経由で他のデバイスと通信します。Motoman シリアル通信用に設定すると、In-Sight センサはこのプロトコルを認識して、Motoman コントローラから受信したコマンドに応答できるようになります。

Motoman モードは、In-Sight のネイティブモード通信の拡張モードです。Motoman ロボットコントローラは、RS-232 ポートを介して数値テキストのみを送信します。In-Sight の標準ネイティブモードコマンドを送信することはできません。その代わりに、Motoman コントローラは、ネイティブモードコマンドの数値表現に必要に応じて追加パラメータを付加したものを In-Sight に送信する必要があります

Motoman モードは ネイティブモードに基づいているため、In-Sight のジョブをネイティブモードで開発してテストした後は、実際のロボットコントローラが In-Sight センサに接続されている場合のみ Motoman モードに切り替えることができます。ジョブにその他の変更を加える必要はありません。

Motoman 通信用に In-Sight センサを設定するには

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。
  2. [シリアルポートの設定] ダイアログで、[モード] ドロップダウンリストを開き、[Motoman] を選択します。

これで In-Sight センサは、Motoman コントローラの標準のシリアルポート設定をデフォルトとして使用するようになります。ただし、コントローラが別の設定を使用する場合には、Motoman コントローラと同じシリアルポート設定を使用するように In-Sight を設定します。

注:
  • コントローラは、DCI モードで通信するように設定する必要があります。In-Sight からホストモードで動作している Motoman ロボットコントローラに対して開始される通信は、現時点ではサポートされていません。
  • Motoman コントローラでフロー制御を「なし」に指定するとしても、In-Sight では、Motoman コントローラとの通信時に、「ハードウェア」によるフロー制御 (ハードウェアハンドシェーク) が必要です。
  • この時点では、Motoman XRC コントローラのみがテスト済みです。

関連項目

以下のトピックでは、In-Sight と Motoman ロボットコントローラの間の通信について詳細に説明されています。

  • Motoman コマンド
  • Motoman の例


Motoman コマンド

Motoman モードの通信

In-Sight 通信リファレンス

Motoman ロボットコントローラは、データとコマンドを送信するか、またはデータを受信することにより、コントローラ自体と In-Sight センサの間のすべてのデータ通信を開始します。In-Sight と Motoman コントローラの間の通信は、コントローラから開始される 2 コマンド手順を使用して行われます。

ロボットコントローラから In-Sight センサにコマンドまたはデータを送信するには

4 つの Motoman SAVEV コマンドが使用されます。

  • 最初の SAVEV では、コマンドが格納されている Motoman 変数のインデックスを指定します。
  • 2 番目の SAVEV では、コマンド番号と、必要な場合にはセルアドレスを指定します。
  • 3 番目の SAVEV では、コマンドのパラメータが格納されている Motoman 変数のインデックスを指定します。
  • 4 番目の SAVEV では、コマンド番号に付加するパラメータを指定します。

In-Sight センサからロボットコントローラにデータを取得するには

直後に LOADV コマンドが続く 3 つの SAVEV コマンドが使用されます。

  • 最初の SAVEV では、コマンドが格納されている Motoman 変数のインデックスを指定します。
  • 2 番目の SAVEV では、コマンド番号と、必要な場合にはセルアドレスを指定します。
  • 3 番目の SAVEV では、In-Sight から送信される結果データが格納される Motoman 変数のインデックスを指定します。
  • LOADV によりデータが送信されます。

Motoman コマンド

Motoman モードでは、9 つのネイティブモードコマンドがサポートされます。ロボットコントローラのプログラマは、すべてのコマンドを Motoman の「D」変数として送信する必要があります。サポートされるコマンドと対応する Motoman モードのリストを以下の表に示します。

ネイティブモードコマンド | 対応する Motoman モード
Set Job (SJ) | 100000
Get Job (GJ) | 200000
Set Online (SO) | 300000
Get Online (GO) | 400000
Set Event (SE) | 500000
Set Integer (SI) | 600000
Set Float (SF) | 700000
Set String (SS) | 800000
Get Value (GV) | 900000

コマンド SJ、GJ、SO、GO、SE では、コマンドを完全に指定するために必要な追加のパラメータはありません。したがって、100000 ～ 199999 の間の値はすべての SJ コマンドを表し、200000 ～ 299999 の間の値はすべて GJ コマンドを表し、以下同様です。

コマンド SI、SF、SS、GV では、コマンドの一部として送信されるパラメータを明示する (特に、In-Sight スプレッドシートの 1 つのセルへの参照として) 必要があります。ただし、Motoman ロボットコントローラは英文字を送信しないため、適切な In-Sight セルの列参照は数値で指定する必要があります。列番号は 01000 から 26000 の数字で指定しますが、このとき、01000 は列「A」を、02000 は列「B」を示し、以下同様です (例、26000 は列「Z」を示す)。行番号は現状のまま追加されてセルアドレスを完成させます。

完全な Motoman 同等のネイティブモードコマンドは常に 100000 を超える数字になるため、ロボットコントローラによって送信されるすべてのコマンドは Motoman の D 変数として保存される必要があります。

完全な Motoman モードコマンドは以下のようにして構成されます。

ロボットコントローラの D 値コマンド = N + CC + RRR

    • N はネイティブモードと「同等」{100000 ～ 900000}
    • CC は列番号と「同等」(01000 ～ 26000)
    • RRR は行番号です。

Motoman コマンドの例

アクティブな In-Sight スプレッドシートジョブのセル B123 から値を取得するコマンドは、ネイティブモードで GVB123 として記述されます。Motoman ロボットコントローラから発行される同等のコマンドは、902123 ( 900000 + 02000 + 123 ) です。

その他の Motoman コマンドの例


Motoman コマンドの例

Motoman モードの通信

In-Sight 通信リファレンス

以下に、対応する各ネイティブモードコマンドの機能を複製するために必要な Motoman コマンドシーケンスの例を示します。それぞれの例において、Motoman 変数 D001 はコマンドを保持するために使用され、Motoman 変数 B000 は D001 を指し示すインデックスを保持するために使用され、Motoman 変数 B001 は送信パラメータまたは受信データを保持する Motoman 変数を指し示すインデックスを保持するために使用されます。

Motoman コマンドの例

In-Sight センサのスロット #13 のジョブをアクティブ化します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SJ13 | 0001 SET B000 1 0002 SET D001 100000 0003 SET B001 2 0004 SET B002 13 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV B002
 | Motoman の B 変数 B002 はジョブ番号パラメータを保持します。

アクティブな In-Sight ジョブのジョブ番号を受け取ります。

ネイティブモードコマンド | Motoman コマンドシーケンス
GJ | 0001 SET B000 1 0002 SET D001 200000 0003 SET B001 3 0004 SAVEV B000 0005 SAVEV D001 0006 SAVEV B001 0007 LOADV B003
 | Motoman の B 変数 B003 は、アクティブな In-Sight ジョブの番号 (0 ～ 19) を保持します。

In-Sight をオンラインに設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SO1 | 0001 SET B000 1 0002 SET D001 300000 0003 SET B001 4 0004 SET B004 1 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV B004
 | Motoman の B 変数 B004 はパラメータを保持します。In-Sight をオフラインに設定するには、SET B004 0 と指定します。

In-Sight センサのオンライン/オフライン状態を取得します。

ネイティブモードコマンド | Motoman コマンドシーケンス
GO | 0001 SET B000 1 0002 SET D001 400000 0003 SET B001 5 0004 SAVEV B000 0005 SAVEV D001 0006 SAVEV B001 0007 LOADV B005
 | Motoman の B 変数 B005 はオンライン/オフライン状態 (1 または 0) を保持します。

「Soft 7」として指定されているアクティブな In-Sight ジョブでイベントをトリガします。

ネイティブモードコマンド | Motoman コマンドシーケンス
SE7 | 0001 SET B000 1 0002 SET D001 500000 0003 SET B001 6 0004 SET B006 7 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV B006
 | Motoman の B 変数 B006 はイベント番号パラメータを保持します。

アクティブな In-Sight ジョブのセル A13 に格納されている EditInt 関数の値を整数値 69 に設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SIA013 69 | 0001 SET B000 1 0002 SET D001 601013 0003 SET B001 7 0004 SET I007 69 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV I007
 | Motoman の I 変数 I007 には、整数パラメータが保存されます。

アクティブな In-Sight ジョブのセル B14 に格納されている EditFloat 関数の値を　double (または real) 値 3.142 に設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SFB014 3.142 | 0001 SET B000 1 0002 SET D001 702014 0003 SET B001 8 0004 SET R008 3.142 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV R008
 | Motoman の R 変数 R008 には、double または real パラメータが格納されます。

アクティブな In-Sight ジョブのセル C15 に格納されている EditString 関数の値を文字列 (または P 変数)「1.1,2.2,3.3,4.4,5.5,6.6,00」に設定します。

ネイティブモードコマンド | Motoman コマンドシーケンス
SSC015 1.1,2.2,3.3,4.4,5.5,6.6,00 | 0001 SET B000 1 0002 SET D001 803015 0003 SET B001 9 0004 SET P009 1.1, 2.2, 3.3, 4.4, 5.5, 6.6, 00 0005 SAVEV B000 0006 SAVEV D001 0007 SAVEV B001 0008 SAVEV P009
 | Motoman の P 変数 P009 には、P 変数パラメータが保存されます。

注: In-Sight ジョブでは、Token$ 関数を使用して P 変数の値を解析する必要があります。

アクティブな In-Sight ジョブのセル C15 に格納されている文字列 (上記の例で設定) を取得し、結果を指定された Motoman 変数に代入します。

ネイティブモードコマンド | Motoman コマンドシーケンス
GVC015 | 0001 SET B000 1 0002 SET D001 903015 0003 SET B001 10 0004 SAVEV B000 0005 SAVEV D001 0006 SAVEV B001 0007 LOADV P010
 | Motoman の P 変数 P10 には「1.1,2.2,3.3,4.4,5.5,6.6,00」が格納されます。

アクティブな In-Sight ジョブのセルに格納されている値を取得し、結果を指定された Motoman 変数に代入します。要求されたデータは、コントローラプログラムの Motoman 変数によって示される指定されたデータ型 (整数または浮動小数点) に適合するようにフォーマットされます。

注: 数値が格納されている In-Sight のセルは、ネイティブモードコマンド GV によって要求されると、セルに整数または浮動小数点値が含まれるかどうかに関係なく、小数点以下 3 桁にフォーマットされた浮動小数点値を返します。

ネイティブモードコマンド

Motoman コマンドシーケンス

GVD016

0001 SET B000 1
0002 SET D001 904016
0003 SET B001 11
0004 SAVEV B000
0005 SAVEV D001
0006 SAVEV B001
0007 LOADV I011

この例では、1 つの I 変数 (整数) が要求されています。したがって、

  1. セル D016 に格納されている値が 123 の場合、Motoman の I 変数 I011 には「123」が格納されます。
  2. セル D016 に格納されている値が 123.555 の場合も、Motoman の I 変数 I011 に「123」が格納されます。

注: Motoman モードコマンドでは、浮動小数点値を整数に変換する場合に丸め込み処理は実行されず、小数点以下の部分は単に切り捨てられます。必要に応じて数学的丸め込み関数を実行し、In-Sight の浮動小数点値を Motoman の整数変数に伝達するかどうかは、ユーザに任されています。

ネイティブモードコマンド

Motoman コマンドシーケンス

GVE017

0001 SET B000 1
0002 SET D001 905017
0003 SET B001 12
0004 SAVEV B000
0005 SAVEV D001
0006 SAVEV B001
0007 LOADV R012

この例では、1 つの R 変数 (real) が要求されています。したがって、

  1. セル E017 に格納されている値が 123 の場合、Motoman の R 変数 R012 には「123.000」が格納されます。
  2. セル E017 に格納されている値が 123.555 の場合、Motoman の R 変数 R012 には「123.555」が格納されます。


ネイティブモードでの通信

In-Sight 通信リファレンス

ネイティブモードのプロトコルについて

ネイティブモードの基本シンタックス

ネイティブモードの拡張シンタックス

ネイティブモードのコマンドを使用して In-Sight センサとシリアルポート経由で通信するには

ネイティブモードのコマンドを使用して In-Sight センサと Telnet 経由で通信するには

ネイティブモードコマンドのリスト

ネイティブモードのプロトコルについて

In-Sight のネイティブモードのプロトコルは ASCII プロトコルであり、次のいずれからも In-Sight センサを制御することができます。

  • PC 上で動作しているカスタムアプリケーションプログラム
  • 標準シリアル通信をサポートしているリモートホスト
  • Ethernet ネットワークを介する Telnet

ネイティブモードのプロトコルは、基本と拡張の 2 組のコマンドに分けられます。ネイティブモードの基本コマンドは、2 つの文字、パラメータ (必要な場合)、および終端記号で構成されます。ネイティブモードの拡張コマンドには、追加の関数やコマンドが含まれます。コマンドは大文字と小文字が区別されません。Telnet 接続を使用してネイティブモードのコマンドを送信するときの終端記号は、CR + LF (ASCII 文字 13 + 10) です。シリアルポートを介してネイティブモードのコマンドを使用する場合は、[Native モードの詳細設定] ダイアログで、ほかの終端記号を指定することもできます。デフォルトの終端記号は CR (ASCII 文字 13) です。

ネイティブモードのコマンドがリモートから In-Sight センサに発行されると、In-Sight センサはコマンドを処理して、最後に終端記号が付いた ASCII 文字列を応答として返します。値を設定 (set) するコマンドは、「成功」の場合は 1 を返し、「コマンドが認識されない」場合は 0 を返し、「失敗」の場合は負の数を返します。値を取得 (get) するコマンドは、コマンドによって、異なるさまざまな値を返します。

注:

  • ネイティブモードコマンドのサブセットは、(一般的な Control and Information Protocol CIPメッセージを許可する) 任意の PLC から明示的メッセージを使用して EtherNet/IP 接続を介して送信可能です。
  • In-Sight 2000 シリーズのビジョンセンサには次の制限事項があります。
    • 次のネイティブモードの基本コマンドは In-Sight 2000 シリーズのビジョンセンサではサポートされません。Read Image (RI)、Write Image (WI)、Set Integer (SI)、Set Float (SF)、Set Region (SR)、Set String (SS)、Set Event (SE)、Set Event and Wait (SW)、Send Message (SM)。
    • Get Value (GV) コマンドはシリアルネイティブの場合にのみサポートされます。
    • ネイティブモードの拡張コマンドは、特に注記がない限り、In-Sight 2000 シリーズのビジョンセンサではサポートされません。
    • In-Sight 2000-110、2000-120、および 2000-120C のビジョンセンサで可能なのは、Pass/Fail データを返すことだけです。数値データの取得を試みると、無効な許可 (-6) エラーが返されます。

ネイティブモードの基本シンタックス

ネイティブモードの基本コマンドの一般的なシンタックスは、次のとおりです。

[コマンド] [パラメータ] [終端記号]

[コマンド] は、2 文字で構成されます。一部のネイティブモードコマンドは、オプションの [パラメータ] を取ります。

ネイティブモードの基本コマンドは、[終端記号] で終了します。Telnet 接続を使用してネイティブモードのコマンドを送信するときの終端記号は、CR + LF (ASCII 文字 13 + 10) です。シリアルポートを介してネイティブモードのコマンドを使用する場合は、[Native モードの詳細設定] ダイアログで、ほかの終端記号を指定することもできます。デフォルトの終端記号は CR (ASCII 文字 13) です。

ネイティブモードの基本コマンドでは、大文字と小文字は区別されません。パラメータ間にスペースは存在しません。

注:

  • ジョブに対して実行されるネイティブモードコマンド (Write Job、Delete Job など) は、主に下位互換性を目的としています。
  • ネイティブモードのファイル転送コマンドでは、標準の 16 ビット CRC (Cyclical Redundancy Check 周期冗長検査) チェックサムが使用されます。

ネイティブモードの拡張シンタックス

ネイティブモードの拡張コマンドの一般的なシンタックスは、次のとおりです。

[コマンド 1] [コマンド 2] [入力パラメータ] [終端記号]

[コマンド 1] は、3 つのネイティブモード拡張コマンド (Get、Put、EV) のいずれかです。[コマンド 2] は、どのデータを [コマンド 1] に基づいて送信、受信、または実行するかを示す、セカンダリコマンドです。[入力パラメータ] は、オプションの補足情報をコマンドに提供します。

ネイティブモードの拡張コマンドは、[終端記号] で終了します。Telnet 接続を使用してネイティブモードのコマンドを送信するときの終端記号は、CR + LF (ASCII 文字 13 + 10) です。シリアルポートを介してネイティブモードのコマンドを使用する場合は、[Native モードの詳細設定] ダイアログで、ほかの終端記号を指定することもできます。デフォルトの終端記号は CR (ASCII 文字 13) です。

ネイティブモードの拡張コマンドでは、大文字と小文字は区別されません。特定の入力パラメータ間にはスペースが存在することに注意してください。

ネイティブモードのコマンドを使用して In-Sight センサとシリアルポート経由で通信するには

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。
  2. [シリアルポートの設定] ダイアログで、[モード] ドロップダウンリストから [Native] を選択します。
  3. In-Sight センサと同じポート設定を使用するように、リモートのシリアル装置を設定します。

注: シリアルポート経由でネイティブモードコマンドを使用する場合、[シリアルポートの設定] ダイアログから [Native モードの詳細設定] ダイアログを開いて、別の終端記号を指定することができます。

ネイティブモードのコマンドを使用して In-Sight センサと Telnet 経由で通信するには

Telnet は、Microsoft Windows に組み込まれているクライアントであり、In-Sight のネイティブモードコマンドを使用して、センサとのリモート通信を行うことができます。

  1. リモートホストで、Telnet クライアントアプリケーションを起動します。
  2. Telnet アプリケーションで、In-Sight センサのホスト名または IP アドレスを指定して、In-Sight センサに接続します。接続に成功すると、「Welcome to In-Sight(tm)」というメッセージが表示され、一緒にハードウェアセンサタイプ (例えば、5100, 5400C) とセッション番号が表示されます。
  3. In-Sight センサの有効なユーザ名とパスワードを入力します。入力するユーザ名とパスワードは、そのセンサのユーザリストに登録されている必要があります。ログオンが成功すると、「User Logged In」というメッセージが表示されます。

Telnet 接続をテストするには、Telnet のプロンプトに対して、ネイティブモードの Get Value コマンド「gva000」を入力します。接続が確立されていた場合、コマンドは 1 を返し、その後に In-Sight センサのスプレッドシートのセル A0 の値 #画像が表示されます。

(リモートホスト上で実行させるための) カスタムアプリケーションを作成して、Telnet のログオンプロセスとネイティブモードデータの送受信を自動化することが可能です。

注:

  • デフォルトでは、Telnet 経由で接続された場合、デフォルトのタイムアウトはありません。タイムアウト値を設定するには、Put Timeout コマンドを使用します。
  • Telnet クライアントアプリケーションでは、通常、セキュリティの目的から、パスワードはエコーバックされません。
  • UNIX ベースのプラットフォームから Telnet を使用して In-Sight センサにログオンする場合、Telnet コマンドラインは次のフォーマットである必要があります。

> telnet <host> <port>

<host> は、In-Sight センサのホスト名または IP アドレスであり、<port> は、リモートの Telnet ポート (通常は 23) です。ポート番号を指定すると、UNIX のユーザ名とパスワードの認証が無効になり、UNIX システムによってユーザ名とパスワードの入力が求められます。


ネイティブモードコマンド

In-Sight 通信リファレンス

ネイティブモードの基本コマンド

ネイティブモードの拡張コマンド

ネイティブモードの基本コマンド

ファイルおよびジョブコマンド

  • Load File: (LF) In-Sight ビジョンシステムのフラッシュメモリから、指定したジョブをロードして、アクティブジョブにします。
  • Store File: (TF) ビジョンシステムのフラッシュメモリに現在のジョブを保存します。
  • Read File: (RF) ビジョンシステムのフラッシュメモリからジョブを読み取ります。
  • Write File: (WF) ビジョンシステムのフラッシュメモリへジョブを送信します。
  • Delete File: (DF) 指定したジョブまたはセルデータ (.cxd) ファイルをビジョンシステムのフラッシュメモリから削除します。
  • Get File: (GF) ビジョンシステム上のアクティブなジョブのファイル名を返します。
  • Set Job: (SJ) ビジョンシステムのフラッシュメモリにあるジョブスロットの 1 つからジョブをロードし、それをアクティブジョブにします。
  • Store Job: (TJ) ビジョンシステムのフラッシュメモリにある指定されたスロットに現在のジョブを保存します。
  • Read Job: (RJ) 指定した In-Sight ジョブスロットからジョブを読み取ります。
  • Write Job: (WJ) ビジョンシステムのフラッシュメモリにある指定されたジョブスロットへジョブを送信します。
  • Delete Job: (DJ) In-Sight システムのフラッシュメモリ内の指定したスロットからジョブを削除します。
  • Get Job: (GJ) 現在ロードされているジョブの ID 番号を取得します。

画像コマンド

  • Read BMP: (RB) 現在の画像をビジョンシステムから外部デバイスへ ASCII 16 進フォーマットで送信します。
  • Read Image: (RI) 現在の画像をビジョンシステムから外部デバイスへ ASCII 16 進フォーマットで送信します。
  • Write BMP: (WB) 外部デバイスからビジョンシステムに画像データを送信します。
  • Write Image: (WI) 外部デバイスからビジョンシステムに画像データを送信します。

設定コマンドおよびセルの値コマンド

  • Get Value: (GV) 指定されたセルまたはシンボリックタグの値を返します。
  • Set Integer: (SI) 指定されたセルまたはシンボリックタグに整数値を設定します。
  • Set Float: (SF) 指定されたセルまたはシンボリックタグに浮動小数点値を設定します。
  • Set Region: (SR) EditRegion セルまたはシンボリックタグの値を設定します。
  • Set String: (SS) 指定されたセルまたはシンボリックタグに文字列値を設定します。
  • Get Info: (GI) In-Sight ビジョンシステムに関するシステム情報を返します。
  • Read Settings: (RS) ビジョンシステムのシステム設定データを読み取ります。
  • Write Settings: (WS) 外部デバイスからビジョンシステムにシステム設定データを送信します。
  • Store Settings: (TS) ビジョンシステムの設定を proc.set ファイルに保存します。
  • Set IP Address Lock: (SL) ビジョンシステムの IP アドレスが無許可で変更されることを防ぎます。
  • Get IP Address Lock: (GL) ビジョンシステム上の IP アドレスのセキュリティステータスを返します。

実行およびオンラインコマンド

  • Set Online: (SO) ビジョンシステムをオンラインモードまたはオフラインモードに設定します。
  • Get Online: (GO) ビジョンシステムをオンライン状態に戻します。
  • Set Event: (SE) 指定したイベントをトリガします。
  • Set Event and Wait: (SW) 指定したイベントをトリガして、コマンドが完了してからレスポンスを返します。
  • Reset System: (RT) ビジョンシステムをリセットします (ビジョンシステムの電源を物理的に入れなおすことに似ています)。
  • Send Message: (SM) 文字列をネイティブモード接続経由でスプレッドシートに送信します。スプレッドシートのイベントをトリガすることもできます。

ネイティブモードの拡張コマンド

  • Get: In-Sight ビジョンシステムとそのスプレッドシートから情報を受信するために使用されます。
  • Put: ビジョンシステムとそのスプレッドシートへ情報を送信するために使用されます。

Evaluate

Evaluate: (EV) In-Sight 関数を実行したり、In-Sight のスプレッドシートに数式を挿入したりします。情報の取得や、In-Sight ビジョンシステムの変更に使用されます。

注: In-Sight 関数は EV コマンドとともに使用できます。次に上げるコマンドは、EV コマンドを使用して実行される最も一般的な関数の一部です。

  • GetCellName: 指定されたシンボリックタグ名のセルの位置、または指定されたセルのシンボリックタグ名を返します。
  • GetCellValue: 指定されたシンボリックタグまたはスプレッドシートのセルの内容を XML フォーマットで返します。
  • GetDeEnergizeOutputs: [ディスクリート　I/O の設定] ダイアログで設定された [オフライン時に出力の電源を切る] の設定を返します。
  • GetDiagnosticLog: In-Sight ビジョンシステムのエラーを診断するために使用する情報のログを返します。
  • GetDiscreteInput: [ディスクリート I/O の設定] ダイアログで設定された情報を返します。
  • GetDiscreteOutput: [ディスクリート I/O の設定] ダイアログで設定された情報を返します。
  • GetDiscreteOutputDelay: [ディスクリート I/O の設定] ダイアログで設定された遅延設定を返します。
  • GetEasyBuilderTag: 指定したシンボリックタグ名またはセル位置の EasyBuilder タグを返します。
  • GetEIPSingleAttribute: In-Sight EtherNet/IP のクラスおよびインスタンス属性を返します。
  • GetFTPSettings: [FTP の設定] ダイアログで設定された情報を返します。
  • GetHostTable: [In-Sight のホストテーブル] ダイアログに含まれる情報を返します。
  • GetMSBuffer: マシンステータススタック内の 8 つのインデックス付きバッファ (ゼロで始まります) の 1 つに格納されたマシンステータスデータを返します。
  • GetNetwork: [ネットワークの設定] ダイアログで設定された情報を返します。
  • GetSerialPort: [シリアルポートの設定] ダイアログで設定された情報を返します。
  • GetStartup: [スタートアップ] ダイアログで設定された情報を返します。
  • GetSystemConfig: システム情報を返すさまざまなコマンド。
  • GetUserList: [ユーザリスト] ダイアログで設定された情報を返します。
  • SetCellName: 指定されたセルのシンボリックタグ名を設定します。
  • SetCellValue: 特定のセルの値に EasyBuilder タグを追加します。
  • SetDeEnergizeOutputs: [ディスクリート I/O の設定] ダイアログの [オフライン時に出力の電源を切る] 設定を行います。
  • SetDiscreteInput: [ディスクリート I/O の設定] ダイアログでの設定を行います。
  • SetDiscreteOutput: [ディスクリート I/O の設定] ダイアログおよび [出力の詳細設定] ダイアログの設定を行います。
  • SetDiscreteOutputDelay: [出力詳細] ダイアログでの遅延設定を行います。
  • SetEditRegion: EditRegion 関数を含むセルの設定を行います。
  • SetEIPSingleAttribute: In-Sight EtherNet/IP のクラスおよびインスタンス属性を設定します。
  • SetFavorHostTable: [In-Sight のホストテーブル] の [ホストテーブルを DNS より優先する] オプションを有効または無効にします。
  • SetFTPSettings: [FTP の設定] ダイアログの設定を行います。
  • SetHostTable: [In-Sight のホストテーブル] ダイアログの設定を行います。
  • SetNetwork: [ネットワークの設定] ダイアログの設定を行います。
  • SetSerialPort: [シリアルポートの設定] ダイアログの設定を行います。
  • SetStartup: [スタートアップ] ダイアログの設定を行います。
  • SetSystemConfig: システムパラメータを設定するさまざまなコマンド。


Load File

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

指定されたジョブを In-Sight ビジョンシステムのフラッシュメモリ (RAM ディスクまたは SD カード) からロードし、アクティブジョブにします。

シンタックス: LF[Filename]

注:

  • In-Sight ビジョンシステムはオフラインになっている必要があります。
  • RAMDisk フォルダに格納されているジョブファイルをロードする場合のシンタックスは、LFRAMDisk/[Filename] です。例えば、ビジョンシステムの RAMDisk フォルダに格納されているファイル「Product.job」をロードするには、次のコマンドを発行します。「LFRAMDisk/Product.job」。
  • SD Card フォルダに格納されているジョブファイルをロードする場合のシンタックスは、LFSDCARD/[Filename] です。例えば、ビジョンシステムの SD Card フォルダに格納されているファイル「Product.job」を読み取るには、次のコマンドを発行します。「LFSDCARD/Product.job」。
  • [ジョブサーバの設定] ダイアログを使用すると、In-Sight ビジョンシステムの In-Sight ジョブファイルをホストする FTP サーバを設定できます。これにより、PLC やロボットコントローラなどの別のデバイスでは、LF および TF ネイティブモードコマンドを介して場所を指定することなくジョブを変更することができます。

Load Fileの入力パラメータ

入力 | 説明
Filename | ジョブの名前。このコマンドは、.JOB ファイル拡張子があってもなくても実行されます。

Load Fileの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ファイル名が見つかりません。
-2 | ジョブでのロードに失敗しました。ビジョンシステムがオンラインか、またはファイルが見つかりませんでした。
-4 | ロードするジョブが見つからなかったか、ビジョンシステムがメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Load File例

In-Sight ビジョンシステムで「Product」をアクティブジョブとしてロードするには、次のコマンドを発行します。LFProduct.job

In-Sight センサは、ジョブが正常にロードされてアクティブにされたことを示す 1 を返すことによって応答します。

関連項目

Store File

Read File

Write File

Delete File

Get File


Store File

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

現在のジョブを、In-Sight ビジョンシステムのフラッシュメモリ (RAM ディスクまたは SD カード) に保存します。

シンタックス: TF[Filename]

注:

  • [オンラインでもジョブを保存] チェックボックスがオンの場合、[フル] または [プロテクト] レベルのアクセス権を持つユーザは、オンライン中にジョブを保存できます。[オンラインでもジョブを保存] チェックボックスがオフの場合、ジョブを保存するには、ビジョンシステムはオフラインでなければなりません。

  • 現在のジョブファイルを指定したファイル名でビジョンシステムの RAMDisk フォルダに保存するシンタックスは、TFRAMDisk/[Filename] です。例えば、ビジョンシステムの RAMDisk フォルダに「Test.job」を保存するには、次のコマンドを発行します。「TFRAMDisk/Test.job」。
  • 現在のジョブファイルを指定したファイル名でビジョンシステムの SD Card フォルダに保存するシンタックスは、TFSDCARD/[Filename] です。例えば、ビジョンシステムの SD Card フォルダに格納されているファイル「Test.job」を保存するには、次のコマンドを発行します。「TFSDCARD/Test.job」。
  • [ジョブサーバの設定] ダイアログを使用して、In-Sight ビジョンシステムの In-Sight ジョブファイルをホストする FTP サーバを設定します。これにより、PLC やロボットコントローラなどの別のデバイスでは、LF および TF ネイティブモードコマンドを介し、場所を指定することなくジョブを変更することができます。

Store Fileの入力パラメータ

入力 | 説明
Filename | ジョブの名前。ファイル拡張子は、.JOB である必要があります。

Store Fileの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ファイル名が見つかりません。
-2 | ジョブの保存に失敗したか、ビジョンシステムがオンラインになっているか、またはファイルが見つからなかったため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Store File例

現在のジョブに「TEST」という名前を付けて In-Sight ビジョンシステムのフラッシュメモリに保存するには、次のコマンドを発行します。TFTest.job

In-Sight ビジョンシステムは、現在のジョブが正常に保存されたことを示す 1 を返すことによって応答します。

関連項目

Load File

Read File

Write File

Delete File

Get File


Read File

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

指定された In-Sight のフラッシュメモリ (RAM ディスクまたは SD カード) からジョブを読み取ります。

シンタックス: RF[Filename]

注:
  • RAMDisk フォルダに格納されているジョブファイルを読み取る場合のシンタックスは、RFRAMDisk/[Filename] です。例えば、ビジョンシステムの RAMDisk フォルダに格納されているファイル「Model.job」を読みとるには、次のコマンドを発行します。「RFRAMDisk/Model.job」。
  • SD Card フォルダに格納されているジョブファイルを読み取る場合のシンタックスは、RFSDCARD/[Filename] です。例えば、ビジョンシステムの SD Card フォルダに格納されているファイル「Model.job」を読み取るには、次のコマンドを発行します。「RFSDCARD/Model.job」。

Read Fileの入力パラメータ

入力 | 説明
Filename | ジョブの名前。このコマンドは、.JOB ファイル拡張子があってもなくても実行されます。

Read Fileの出力

戻り値

ステータスコード。その後に行の終端文字と、ジョブデータの行が続きます。

ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ジョブのファイル名が見つかりません。
-2 | 指定された名前で保存されたジョブは存在しないか、またはジョブデータが無効なため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

ジョブデータの行の設定は次のとおりです。

Name | 1 行目にはジョブ名が含まれています。
Size | 2 行目には、ジョブのサイズ (バイト単位) の整数値が含まれています。
Data | 実際のジョブデータは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、ジョブデータのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Read File例

In-Sight ビジョンシステムに保存されているジョブ「Model.job」に関する情報を受け取るには、次のコマンドを発行します。RFModel.job

Read File コマンドを発行した後、telnet ウィンドウに出力される 1 行目はステータスコード (1) です。その後に、ジョブ名 (Model.job) とバイト単位のサイズ　(826)、およびジョブデータ (ASCII 16 進フォーマット) が続きます。 最後に、4 バイトの ASCII 16 進チェックサムが最後の行 (8767) に表示されます。

注: RF コマンドによって報告されるサイズは、データの ASCII 16 進エンコードのため、In-Sight ビジョンシステム上の実際の .JOB ファイルサイズのバイト数の 2 倍になります。

関連項目

Load File

Store File

Write File

Delete File

Get File


Write File

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

ジョブを、In-Sight ビジョンシステムのフラッシュメモリ (RAM ディスクまたは SD カード) に送信します。

シンタックス: WF

[Filename]

[Size]

[Data]

[Checksum]

注:

  • In-Sight ビジョンシステムはオフラインになっている必要があります。
  • ビジョンシステムの RAMDisk フォルダに格納されているジョブファイルを送信するには、ファイル名に RAMDisk フォルダのパスを含める必要があります。例えば、「RAMDisk/NewModel.job」。
  • ビジョンシステムの SD Card フォルダに格納されているジョブファイルを送信するには、ファイル名に SD Card フォルダのパスを含める必要があります。例えば、「SDCARD/NewModel.job」。

Write Fileの入力パラメータ

このコマンドは別個の行で送信され、その後にジョブデータの行が続きます。ジョブデータは、Read File コマンドから受け取るデータの正確なコピーである必要があります。ジョブデータの行の設定は次のとおりです。

入力 | 説明
Filename | ジョブの名前。このコマンドは、.JOB ファイル拡張子があってもなくても実行されます。
Size | 2 行目には、ジョブのサイズ (バイト単位) の整数値が含まれています。
Data | 実際のジョブデータは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、ジョブデータのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Write Fileの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | ジョブを書き込むことができなかったか、ジョブデータが無効です。
-3 | チェックサムに失敗しました。チェックサムがジョブデータと一致しません。
-4 | In-Sight ビジョンシステムのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Write File例

ジョブデータをジョブ「NewModel.job」に書き込むには、次のコマンドを発行します。WF。Write File コマンドを発行した後、最初に入力するのはジョブ名 (NewModel.job) で、その後にバイト単位のサイズ (826) を続けて入力します。 次に、ジョブファイルの各 ASCII 16 進バイトを入力します。 最後に、4 バイトの ASCII 16 進チェックサム (8767) を最後の行に入力します。

In-Sight ビジョンシステムは、ビジョンシステムのフラッシュメモリにジョブが正常に送信されたことを示す 1 を返すことによって応答します。

注:

  • ビジョンシステムにそのジョブファイルがすでに存在する場合、既存のジョブデータは上書きされます。
  • ビジョンシステムにそのジョブファイルがまだ存在しない場合は、指定した名前を付けて新しいジョブファイルが作成されます。

関連項目

Load File

Store File

Read File

Delete File

Get File


Delete File

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

指定したジョブ またはセルデータ (.cxd) ファイルを In-Sight ビジョンシステムのフラッシュメモリ (RAM ディスクまたは SD カード) から削除します。

シンタックス: DF[Filename]

注:

  • In-Sight ビジョンシステムはオフラインになっている必要があります。
  • ビジョンシステムの RAMDisk フォルダに格納されているジョブまたは CXD ファイルを削除する場合のシンタックスは、DFRAMDisk/[Filename] です。例えば、ビジョンシステムの RAMDisk フォルダに格納されているファイル「Test.job」を削除するには、次のコマンドを発行します。「DFRAMDisk/Test.job」。
  • ビジョンシステムの SD Card フォルダに格納されているジョブまたは CXD ファイルを削除する場合のシンタックスは、DFSDCARD/[Filename] です。例えば、ビジョンシステムの SD Card フォルダに格納されているファイル「Test.job」を削除するには、次のコマンドを発行します。「DFSDCARD/Test.job」。

Delete Fileの入力パラメータ

入力 | 説明
Filename | ジョブ または .CXDファイルの名前。ファイル拡張子は、.JOB または .CXD にする必要があります。

Delete Fileの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ファイル名が見つかりません。
-2 | ファイルを削除できないか、ビジョンシステムがオンラインになっているか、指定した名前のファイルが存在しないか、またはジョブデータが無効なため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Delete File例

例: ジョブファイルを削除する

例: .CXD ファイルを削除する

例: ジョブファイルを削除する

In-Sight ビジョンシステムからジョブ「Test.job」を削除するには、次のコマンドを発行します。DFTest.job

In-Sight ビジョンシステムは、続く行にステータスコード 1 を表示して応答し、ジョブが正常に削除されたことを示します。

例: .CXD ファイルを削除する

In-Sight ビジョンシステムの RAMDisk フォルダから「FindPatterns.cxd」を削除するには、次のコマンドを発行します。DFRAMDisk/FindPatterns.cxd

In-Sight ビジョンシステムは、続く行にステータスコード 1 を表示して応答し、.CXD ファイルが正常に削除されたことを示します。

関連項目

Load File

Store File

Read File

Write File

Get File


Get File

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight ビジョンシステム　(RAM ディスクまたは SD カード) 上のアクティブジョブのファイル名を返します。

シンタックス: GF

注:

  • このコマンドを正常に実行できるようにするには、まずアクティブジョブを保存しておく必要があります。
  • ビジョンシステムの RAMDisk フォルダにアクティブジョブが保存される場合、Get File の出力には RAMDisk フォルダが含まれます。例えば、アクティブジョブ「Test.job」がビジョンシステムの RAMDisk フォルダが保存される場合は、Get File コマンドにより「RAMDisk/Test.job」が返されます。
  • アクティブジョブがビジョンシステムの SD Card フォルダに保存される場合、Get File の出力には SD Card フォルダのパスが含まれます。例えば、アクティブジョブ「Test.job」がビジョンシステムの SD Card フォルダに保存される場合は、Get File コマンドにより「SDCARD/Test.job」が返されます。

Get Fileの入力パラメータ

なし。

Get Fileの出力

戻り値

ステータスコード。その後にファイル名が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | アクティブジョブが保存されていないので、コマンドを実行できませんでした。

Get File例

In-Sight ビジョンシステム上の保存済みアクティブジョブには「Test.job」という名前が付けられます。 アクティブジョブのファイル名を返すには、次のコマンドを発行します。GF

In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。次の行にアクティブジョブのファイル名 (Test.job) が表示されます。

注:

  • そのアクティブジョブがリモートの In-Sight ビジョンシステムからロードされた場合、ファイル名は次のフォーマットで表示されます。FTP://HostName/filename。
  • アクティブジョブが PC からドラッグ & ドロップされた (ただし、センサに保存されなかった) 場合、ファイル名は .job フォーマットで表示されます。

関連項目

Load File

Store File

Read File

Write File

Delete File

Version: 5.6.0


Set Job

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサのフラッシュメモリにあるジョブスロットの 1 つからジョブをロードし、それをアクティブジョブにします。

シンタックス: SJ[ID]

注:

  • In-Sight センサはオフラインになっている必要があります。
  • このコマンドは、In-Sight ビジョンシステムのフラッシュメモリに保存されたジョブに対してのみ機能します。設定済みのジョブサーバ、または In-Sight ビジョンシステムに取り付けられた SD カードにジョブを保存すると、このコマンドは機能しません。
  • ジョブ ID 番号の機能を使用するには、ロードするジョブが数値 0 ～ 999 の接頭辞を付けて保存されている必要があります。

Set Jobの入力パラメータ

入力 | 説明
ID | ロードするジョブの ID 番号 (0 ～ 999)。

Set Jobの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ID が 0 未満か、または整数ではありません。
-2 | ジョブのロードに失敗したか、センサがオンラインになっているか、またはファイルが見つからなかったため、コマンドを実行できませんでした。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Job例

In-Sight ビジョンシステムで「85Test.job」をアクティブジョブとしてロードするには、次のコマンドを発行します。SJ85

In-Sight センサは、ジョブが正常にロードされてアクティブにされたことを示す 1 を返すことによって応答します。

関連項目

Store Job

Read Job

Write Job

Delete Job

Get Job


Store Job

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサ上のフラッシュメモリ内の指定したジョブスロットに現在のジョブを保存します。

シンタックス: TJ[ID][Name]

注:

  • [オンラインでもジョブを保存] チェックボックスがオンの場合、[フル] または [プロテクト] レベルのアクセス権を持つユーザは、オンライン中にジョブを保存できます。[オンラインでもジョブを保存] チェックボックスがオフの場合、ジョブを保存するには、ビジョンシステムはオフラインでなければなりません。

  • このコマンドは、In-Sight ビジョンシステムのフラッシュメモリに保存されたジョブに対してのみ機能します。設定済みのジョブサーバ、または In-Sight ビジョンシステムに取り付けられた SD カードにジョブを保存すると、このコマンドは機能しません。
  • ジョブ ID 番号機能を使用するには、ジョブに数値 0 ～ 999 の接頭辞を付けて保存する必要があります。

Store Jobの入力パラメータ

入力 | 説明
ID | ジョブ ID 番号 (0～999)。
Name | ジョブの名前。コマンドは、.JOB ファイル拡張子があってもなくても実行されます。

Store Jobの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ジョブ ID 番号が無効であるか、整数ではありません。
-2 | センサがオンラインであるため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Store Job例

現在のジョブに「Test」という名前を付けて In-Sight センサのスロット 0 に保存するには、次のコマンドを発行します。TJ00Test.job

In-Sight センサは、1 を返すことにより、現在のジョブが正常に保存されたことを示します。

関連項目

Set Job

Read Job

Write Job

Delete Job

Get Job


Read Job

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

指定した In-Sight ジョブスロットからジョブを読み取ります。

シンタックス: RJ[ID]

Read Jobの入力パラメータ

入力 | 説明
ID | ジョブ ID 番号 (0～999)。

Read Jobの出力

戻り値

ステータスコード。その後に行の終端文字と、ジョブデータの行が続きます。

ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ジョブ ID 番号が許容範囲 (0 ～ 999) 外です。
-2 | ジョブを読み取ることができなかったか、ジョブスロットが空になっているため、コマンドを実行できませんでした。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

ジョブデータの行の設定は次のとおりです。

名前 | 1 行目にはジョブ名が含まれています。
サイズ | 2 行目には、ジョブのサイズ (バイト単位) の整数値が含まれています。
データ | 実際のジョブデータは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、ジョブデータのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Read Job の例

In-Sight ビジョンシステムに保存されている「85Test.job」という名前のジョブに関する情報を受け取るには、次のコマンドを発行します。RJ85

Read Job コマンドを発行した後、telnet ウィンドウに出力される 1 行目はステータスコード (1) です。その後に、ジョブ名 (85Test.job) とバイト単位のサイズ　(826)、およびジョブデータ (ASCII 16 進フォーマット) が続きます。最後に、4 バイトの ASCII 16 進チェックサムが最後の行 (5384) に表示されます。

注: RJ コマンドによって報告されるサイズは、データの ASCII 16 進エンコードのため、In-Sight センサ上の実際の .JOB ファイルサイズのバイト数の 2 倍になります。

関連項目

Set Job

Store Job

Write Job

Delete Job

Get Job


Write Job

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサのフラッシュメモリの指定された In-Sight ジョブスロットにジョブを送信します。

シンタックス: WJ[ID]

[Filename]

[Size]

[Data]

[Checksum]

注:

  • In-Sight センサはオフラインになっている必要があります。
  • このコマンドは、In-Sight ビジョンシステムのフラッシュメモリに保存されたジョブに対してのみ機能します。設定済みのジョブサーバ、または In-Sight ビジョンシステムに取り付けられた SD カードにジョブを保存すると、このコマンドは機能しません。

Write Jobの入力パラメータ

このコマンドと ID は別個の行で送信され、その後にジョブデータの行が続きます。ジョブデータは、Read Job コマンドから受け取るデータの正確なコピーである必要があります。

入力 | 説明
ID | ジョブ ID 番号 (0～999)。

ジョブデータの行の設定は次のとおりです。

入力 | 説明
Name | 1 行目にはジョブ名が含まれています。
Size | 2 行目には、ジョブのサイズ (バイト単位) の整数値が含まれています。
Data | 実際のジョブデータは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、ジョブデータのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Write Jobの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ジョブ ID 番号が許容範囲 (0 ～ 999) 外です。
-2 | ジョブを書き込むことができなかったか、ジョブデータが無効です。
-3 | チェックサムに失敗しました。チェックサムがジョブデータと一致しません。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Write Job の例

ジョブデータを「86Test.job」という名前のジョブに書き込むには、次のコマンドを発行します。WJ86

コマンドを発行した後、ジョブ名 (Test.job) を入力し、その後にバイト単位のサイズ (826) を続けて入力します。 次に、ジョブファイルの各 ASCII 16 進バイトを入力します。 最後に、4 バイトの ASCII 16 進チェックサム (5384) を最後の行に入力します。

In-Sight センサは、センサのフラッシュメモリにジョブが正常に送信されたことを示す 1 を返すことによって応答します。

注:

  • センサにそのジョブファイルがすでに存在する場合、既存のジョブデータは上書きされます。
  • センサにそのジョブファイルがまだ存在しない場合は、指定した名前を付けて新しいジョブファイルが作成されます。
  • サイズは、データの ASCII 16 進エンコードのため、In-Sight センサ上の実際の .JOB ファイルサイズのバイト数の 2 倍になります。

関連項目

Set Job

Store Job

Read Job

Delete Job

Get Job


Delete Job

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサのフラッシュメモリ内の指定したスロットからジョブを削除します。

シンタックス: DJ[ID]

注:

  • In-Sight センサはオフラインになっている必要があります。
  • このコマンドは、In-Sight ビジョンシステムのフラッシュメモリに保存されたジョブに対してのみ機能します。設定済みのジョブサーバ、または In-Sight ビジョンシステムに取り付けられた SD カードにジョブを保存すると、このコマンドは機能しません。

Delete Jobの入力パラメータ

入力 | 説明
ID | ジョブ ID 番号 (0～999)。

Delete Jobの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | ジョブ ID 番号が許容範囲 (0 ～ 999) 外です。
-2 | ジョブを削除できなかったか、センサがオンラインになっているか、またはジョブスロットが空になっているため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Delete Job例

In-Sight センサのスロット 0 からジョブ「Test.job」を削除するには、次のコマンドを発行します。DJ00Test.job

In-Sight センサは、続く行にステータスコード 1 を表示して応答し、ジョブが正常に削除されたことを示します。

関連項目

Store Job

Set Job

Read Job

Write Job

Get Job

Version: 5.6.0


Get Job

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサ上のアクティブなジョブの ID を返します。

シンタックス: GJ

注:

  • ジョブ ID 番号の機能を使用するには、ロードするジョブが数値 0 ～ 999 の接頭辞を付けて保存されている必要があります。
  • このコマンドを正常に実行するためには、数値の接頭辞を付けてアクティブジョブを保存しておく必要があります。ジョブがドラッグ＆ドロップされたものである場合、ファイル名に数値の接頭辞が付いていなければ、このコマンドは正常に実行されません。
  • Motoman 通信を使用して Get Job コマンドを発行すると、ステータスデータは返されますが、結果データは返されません。Get Job コマンドの代わりに Get File コマンドを使用するか、スプレッドシートの別のセルにジョブ ID 番号を入力し、Get Value コマンドを使用します。

Get Jobの入力パラメータ

なし。

Get Jobの出力

戻り値

ステータスコード。その後にアクティブジョブの整数値の ID が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | アクティブジョブが保存されていないか、数値の接頭辞が付いていないため、コマンドを実行できませんでした。

Get Job の例

アクティブジョブのファイル名を返すには、次のコマンドを発行します。GJ

In-Sight センサは、1 で応答して、コマンドが正常に実行されたことを示します。アクティブジョブの名前は、「85.JOB」です。

関連項目

Store Job

Set Job

Read Job

Write Job

Delete Job


Read BMP

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

現在の画像を、ASCII 16 進フォーマット (80 文字/行でフォーマット) で、In-Sight センサからリモートデバイスに送信します。バイナリに変換すると、結果のデータは標準の BMP 画像フォーマットになります。

シンタックス: RB

注: Read BMP コマンドを実行することは、Read Image コマンドを実行するのと同じです。

Read BMPの入力パラメータ

なし。

Read BMPの出力

戻り値

ステータスコード。その後に行の終端文字と、画像データの行が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

画像データ行の設定は次のとおりです。

Size | 2 行目には、画像のサイズ (バイト単位) の整数値が含まれています。
Image | 実際の画像データは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、画像データのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Read BMP例

In-Sight センサから現在の画像を (ASCII 16 進フォーマット) で読み取るには、次のコマンドを発行します。RB

In-Sight センサは最初、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。次の行には、バイト単位のサイズ (3436) と、それに続いて画像データ (ASCII 16 進フォーマット) が含まれています。

注: 実際の画像データのほとんどは、明確化のため、先のグラフィックから省略されています。

最後に、4 バイトの ASCII 16 進数チェックサム (E213) が返されます。

関連項目

Write BMP


Read Image

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

現在の画像を、ASCII 16 進フォーマット (80 文字/行でフォーマット) で、In-Sight センサからリモートデバイスに送信します。バイナリに変換すると、結果のデータは標準の BMP 画像フォーマットになります。

シンタックス: RI

注: Read Image コマンドを実行することは、Read BMP コマンドを実行するのと同じです。

Read Imageの入力パラメータ

なし。

Read Imageの出力

戻り値

ステータスコード。その後に行の終端文字と、画像データの行が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

画像データ行の設定は次のとおりです。

Size | 2 行目には、画像のサイズ (バイト単位) の整数値が含まれています。
Image | 実際の画像データは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、画像データのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Read Image の例

In-Sight センサから現在の画像を (ASCII 16 進フォーマット) で読み取るには、次のコマンドを発行します。RI

In-Sight センサは最初、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。次の行には、バイト単位のデータサイズ (3436) と、それに続いて画像データ (ASCII 16 進フォーマット) が含まれています。

注: 実際の画像データのほとんどは、明確化のため、先のグラフィックから省略されています。

最後に、4 バイトの ASCII 16 進数チェックサム (E213) が返されます。

関連項目

Write Image


Write BMP

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

リモートデバイスから In-Sight センサに画像データを送信します。

シンタックス: WB

[Size]

[Image]

[Checksum]

注:

  • In-Sight センサはオフラインになっている必要があります。
  • Write BMP コマンドを実行することは、Write Image コマンドを実行するのと同じです。

Write BMPの入力パラメータ

このコマンドは別個の行で送信され、その後に画像データの行が続きます。画像データは、Read BMP コマンドを使用して送信されるデータの正確なコピーである必要があります。画像データ行の設定は次のとおりです。

入力 | 説明
Size | 画像ファイルのサイズ (バイト単位) の整数値。
Image | 実際の画像データは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、画像データのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Write BMPの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | 画像を書き込むことができなかったか、画像データが無効です。
-3 | チェックサム に失敗しました。チェックサムが画像データと一致しません。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Write BMP の例

システムの設定をセンサに送信するには、次のコマンドを発行します。WB。Write BMP コマンドを発行した後、最初に入力するのはバイト単位のサイズ (3436) です。 次に、画像データの各 ASCII 16 進バイトを入力します。 最後に、4 バイトの ASCII 16 進チェックサム (E213) を最後の行に入力します。

注: 実際の画像データのほとんどは、明確化のため、先のグラフィックから省略されています。

In-Sight センサは、画像データが正常にセンサに送信されたことを示す 1 を返すことによって応答します。

関連項目

Read BMP


Write Image

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

リモートデバイスから In-Sight センサに画像データを送信します。

シンタックス: WI

[Size]

[Image]

[Checksum]

注:

  • In-Sight センサはオフラインになっている必要があります。
  • Write Image コマンドを実行することは、Write BMP コマンドを実行するのと同じです。

Write Imageの入力パラメータ

このコマンドは別個の行で送信され、その後に画像データの行が続きます。画像データは、Read Image コマンドを使用して送信されるデータの正確なコピーである必要があります。画像データ行の設定は次のとおりです。

入力 | 説明
Size | 画像ファイルのサイズ (バイト単位) の整数値。
Image | 実際の画像データは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされています。各行は終端文字で終わります。
CheckSum | 最後の行には、画像データのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Write Imageの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | 画像を書き込むことができなかったか、画像データが無効です。
-3 | チェックサムに失敗しました。チェックサムが画像データと一致しません。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Write Image の例

システムの設定をセンサに送信するには、次のコマンドを発行します。WI

Write Image コマンドを発行した後、最初に入力するのはバイト単位のサイズ (3436) です。 次に、画像データの各 ASCII 16 進バイトを入力します。最後に、4 バイトの ASCII 16 進チェックサム (E213) を最後の行に入力します。

注: 実際の画像データのほとんどは、明確化のため、先のグラフィックから省略されています。

In-Sight センサは、画像データが正常にセンサに送信されたことを示す 1 を返すことによって応答します。

関連項目

Read Image


Get Value

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

指定したシンボリックタグの内容 (EasyBuilder フィクスチャ出力、EasyBuilder の位置決めツールまたは検査ツールの結果、ジョブデータなど) を返します。

シンタックス:GV["Symbolic Tag"]

Get Valueの入力パラメータ

入力 | 説明
"Symbolic Tag" | シンボリックタグ (位置決めツールまたは検査ツールの結果、またはジョブデータ ("Job.Robot.FormatString." や "Job.FormatString" など)) のシンボリックタグの名前。

Get Valueの出力

戻り値

ステータスコード。その後に行の終端文字と、指定したシンボリックタグに格納されている値が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | "Symbolic Tag" が無効です。
-2 | コマンドを実行することができませんでした。

注: 数値を含むシンボリックタグは、Get Value コマンドによって要求されると、ツールの結果やジョブデータに整数または浮動小数点値が含まれるかどうかに関係なく、小数点以下 3 桁にフォーマットされた浮動小数点値を返します。シンボリックタグに非印字文字 (Structure など) が含まれる場合は、シャープ文字 (#) で非印字文字が置き換えられます。ツール結果またはジョブデータが空の場合は、null 文字列が送信されます。

Get Value例

EasyBuilder (In-Sight ビジョンシステム)

Get Value コマンドを送信することにより、シンボリックタグに格納されているデータ (EasyBuilder の位置決めツールまたは検査ツールの結果やジョブデータなど) を返すことができます。

  1. ユーザのジョブが、三菱ロボットコントローラと通信するように設定されていると想定します。

  2. Get Value Native Mode コマンドを使用して In-Sight ビジョンシステムからデータ文字列を取得する必要があります。次の telnet クライアントウィンドウに示すように、コマンド GVJob.Robot.FormatString を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 と、フォーマットされた文字列でデータを返すことによって応答します。

EasyBuilder (In-Sight 2000 シリーズのビジョンセンサ)

In-Sight 2000 シリーズのビジョンセンサがシリアルネイティブと通信するように設定されている場合は、Get Value コマンド GVJob.FormatString を送信することによって EasyBuilder の位置決めツールまたは検査ツールの結果などのデータを返すことができます。

位置決めツールまたは検査ツールから返されるデータ型は、In-Sight 2000 シリーズのモデルによって決まります。

 | モデル | 返される結果
位置決めツール | In-Sight 2000 シリーズのビジョンセンサ、2000-23M を除く | 合格/不合格のみ (0 = False、1 = True)
 | In-Sight 2000-23M | 制限なし
検査ツール | In-Sight 2000-110、120 および 120C ビジョンセンサ | 合格/不合格のみ (0 = False、1 = True)
 | In-Sight 2000-130 および 130C | 寸法測定ツールと計数ツール: 結果値 その他のツール: 合格/不合格のみ (0 = False、1 = True)
 | In-Sight 2000-23M | 制限なし
  1. [通信] アプリケーションステップに移動します。[デバイスの追加] をクリックし、[シリアルネイティブ] を選択します。

  2. [フォーマット出力文字列] タブで、[フォーマット文字列] をクリックします。[フォーマット文字列] ダイアログで、返す項目を追加します。この例では、ダイアログで次のように設定します。

  3. [Set Serial Port Settings　(シリアルポートの設定)] タブを設定します。
  4. In-Sight ビジョンセンサをオンラインにします。

  5. 次のコマンドを発行します。次の telnet クライアントウィンドウに示す GVJob.FormatString

  6. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 と、フォーマットされた文字列でデータを返す (Brightness_1.Pass = True、Circle_1.Pass = True、Pixels_1.Fail = False、Distance_1.Distance = 307.532898) ことによって応答します。

スプレッドシートビュー

指定されたセルに格納されている値を返します。

シンタックス:GV[Column][Row]

Get Valueの入力パラメータ

入力 | 説明
列 | 取得するセル値の列文字 (A ～ Z)。
行 | 取得するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。

Get Valueの出力

戻り値

ステータスコード。その後に行の終端文字と、指定したセルに格納されている値が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | コマンドを実行することができませんでした。

注: 数値が格納されている In-Sight のセルは、Get Value コマンドによって要求されると、セルに整数または浮動小数点値が含まれるかどうかに関係なく、小数点以下 3 桁にフォーマットされた浮動小数点値を返します。セルに非印字文字 (Structure など) が格納されている場合は、シャープ文字 (#) で非印字文字が置き換えられます。セルが空の場合は、null 文字列が送信されます。

Get Value例

  1. セル A1、B0、および B1 が次のような内容であると仮定します。

A1 = 4.000

B0 = EditInt(0,10)

B1 = EditFloat(0,10)

現在 A1 には値 4 が格納されており、B0 には値 5 が格納されており、B1 には値 3.230 が格納されています。スプレッドシートには次のように表示されます。

さまざまな GV コマンドを発行すると次のような結果になります。


Set Integer

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

EasyBuilder の位置決めツールまたは検査ツールのパラメータ、あるいはジョブデータなどの、シンボリックタグの整数値を指定した整数値に設定します。パラメータまたはジョブデータは整数データタイプである必要があります。

シンタックス: SI["Name"][Space][Int]

Set Integerの入力パラメータ

入力 | 説明
"Name" | 設定する位置決めツールまたは検査ツールパラメータ (例: "Pattern_1.Model_Type") あるいは EasyBuilder ジョブデータ (例: "Job.External_Reset_Counters") の名前。
Space | "name" と整数値を切り離す空白スペース。
Int | 設定する整数値。

Set Integerの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | EasyBuilder の "Name" が無効か、整数データタイプではありません。
-2 | コマンドを実行することができなかったか、指定した整数値がコントロールの有効範囲外です。例えば、指定した名前は有効なデータタイプのコントロールを含んでいません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Integer例

例 1: 整数値を含むパラメータ値を変更する

例 2: チェックボックスを含むパラメータをオフまたはオンにする

例 3: ドロップダウンリストの選択を変更する

例 1: 整数値を含むパラメータ値を変更する

新しい整数値を含む Set Integer コマンドを送信することによって、位置決めツールまたは検査ツールパラメータ、あるいはジョブデータの整数値を設定することができます。

  1. ジョブにパターン位置決めツールが含まれ、パターン位置決めツールの現在の [タイムアウト] パラメータが、デフォルトの 5000 ミリ秒に設定されていると仮定します。

  2. このパラメータの設定を Set Integer ネイティブモードコマンドを使用して変更します。次の telnet クライアントウィンドウに示すように、コマンド SIPattern_1.Timeout 500 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [タイムアウト] パラメータは、5000 から 500 に正常に変更されました。

例 2: チェックボックスを含むパラメータをオフまたはオンにする

Set Integer コマンドを使用して値 1 (有効) または 0 (無効) を送信することにより、ツールのチェックボックスパラメータを有効または無効にすることができます。

  1. ジョブにパターン位置決めツールが含まれ、パターン位置決めツールの現在の [スケール許容] パラメータが、デフォルトの無効 (オフ) に設定されていると仮定します。

  2. このパラメータの設定を、特定のパーツに基づき、プログラムで有効または無効に変更します。次の telnet クライアントウィンドウに示すように、コマンド SIPattern_1.Scale_Tolerance 1 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [スケール許容] パラメータは、無効 (オフ) から有効 (オン) に正常に変更されました。

例 3: ドロップダウンリストの選択を変更する

Set Integer コマンドを使用して必要な選択を示す整数を送信することにより、ツールのドロップダウンメニューリストパラメータの選択を変更することができます。ドロップダウンメニュー内の項目は、ListBox コントロールに対応しており、整数値 (ゼロから始まります) が割り当てられています。Set Integer ネイティブモードコマンドを使用して、ドロップダウンメニューを含んでいるパラメータに別の値を割り当てることによって、リストから別の値を「選択」することができます。

  1. ジョブにブロブ計数ツールが含まれ、ブロブ計数ツールの [ブロブの色] パラメータが、デフォルトの [任意]/2 に設定されていると仮定します。

  2. このパラメータの設定を、特定の製品パーツに基づき、プログラムで [黒]/0 または [白]/1 に変更します。次の telnet クライアントウィンドウに示すように、コマンド SIBlobs_1.Blob_Color 1 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [ブロブの色] パラメータは、[任意]/2 から [白]/1 に正常に変更されました。

スプレッドシートビュー

セルに含まれているコントロールを指定した整数値に設定します。コントロールは、EditInt、Checkbox、または ListBox タイプである必要があります。

シンタックス: SI[Column][Row][Int]

Set Integerの入力パラメータ

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000～399)。
Int | 設定する整数値。

Set Integerの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効か、または整数ではありませんでした。
-2 | コマンドを実行することができなかったか、指定した整数値がコントロールの有効範囲外です。例えば、指定したセルは有効なタイプのコントロールを含んでいません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Integer例

例 1: EditInt コントロールの値を変更する

例 2: CheckBox コントロールの状態を切り替える

例 3: ListBox コントロール内の選択を変更する

例 1: EditInt コントロールの値を変更する

セル A2 の EditInt コントロールを整数値 8 に設定するコマンドは、SIA0028 です。

  1. セル A2 には、次が格納されていると仮定します。

A2 = EditInt(0,10)

A2 に現在含まれている値は 3 です。 スプレッドシートには次のように表示されます。

  2. Set Integer ネイティブモードコマンドを使用して、A2 内の値を 8 に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SIA0028 を発行します。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。スプレッドシート内の EditInt コントロールは、3 から 8 に正常に変更されました。

例 2: CheckBox コントロールの状態を切り替える

Set Integer コマンドを使用し、チェックボックスのあるセルに値 1 (有効) または 0 (無効) を送信することによって、CheckBox コントロールを有効または無効にすることができます。

  1. セル B2、D2、および E2 に次のような値が格納されていると仮定します。

B2 = CheckBox("Draw circle")

D2 = 'Check box integer value =

E2 = $B$2

次に示すように、チェックボックスは現在オフになっています。

注: セル E2 は、CheckBox コントロールの整数値を報告するだけです。

  2. Set Integer ネイティブモードコマンドを使用して、このチェックボックスを選択するには、次の Telnet クライアントウィンドウに示すように、コマンド SIB0021 を発行します。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。チェックボックスが選択されました。

CheckBox コントロールの新しい整数値を反映して、セル E2 は 0 から 1 に変更されました。

例 3: ListBox コントロール内の選択を変更する

ListBox コントロール内の各項目には、整数値 (ゼロから始まります) が割り当てられます。Set Integer ネイティブモードコマンドを使用して、ListBox コントロールを含んでいるセルに別の値を割り当てることによって、リストから別の値を「選択」することができます。

  1. セル B2、C2、および D2 に次のような値が格納されていると仮定します。

B2 = ListBox("Red", "Orange", "Yellow", "Green", "Blue", "Indigo", "Violet")

C2 = ' Integer List Value =

D2 = $B$2

ListBox コントロールは、現在 Yellow に設定されています。これは、次のスプレッドシートに示すように、整数値 2 に対応します。

注: セル D2 は、セル B2 の整数値を報告するだけです。

  2. Set Integer ネイティブモードコマンドを使用して、現在のリスト選択を Blue に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SIB0024 を発行します。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。スプレッドシート内のリスト選択は、Yellow から Blue に変更されました。

ListBox コントロールの新しい整数値を反映して、セル D2 は 2 から 4 に変更されました。


Set Float

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

EasyBuilder の位置決めツールまたは検査ツールのパラメータ、あるいはジョブデータなどのシンボリックタグの浮動小数点値を、指定した浮動小数点値に設定します。シンボリックタグは、浮動小数点データ型である必要があります。

シンタックス: SF["Symbolic Tag"][Space][Float]

Set Floatの入力パラメータ

入力 | 説明
"Symbolic Tag" | 設定するシンボリックタグ (位置決めツールまたは検査ツールのパラメータ (例: "Pattern_1.Horizontal_Offset") あるいは EasyBuilder ジョブデータ (例: "Acquistion.Exposure_Time")) の名前。
Space | 浮動小数点値から "Symbolic Tag" を切り離す空白スペース。
Float | 設定する浮動小数点数 (小数点文字 (.) を含む)。

Set Floatの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | "Symbolic Tag" が無効か、または指定した値に浮動小数点数が含まれていません。
-2 | コマンドを実行することができなかったか、指定した浮動小数点値がコントロールの有効範囲外です。例えば、指定した名前は有効なデータタイプのコントロールを含んでいません。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Float例

新しい整数値を含む Set Float コマンドを送信することによって、位置決めツールまたは検査ツールのパラメータ、あるいはジョブデータの浮動小数点値を設定することができます。

  1. ジョブにパターン位置決めツールが含まれており、そのツールの現在の [水平オフセット] パラメータ設定がデフォルトの 0.000 に設定されていると仮定します。

  2. このパラメータの設定を Set Float ネイティブモードコマンドを使用して変更します。次の telnet クライアントウィンドウに示すように、コマンド SFPattern_1.Horizontal_Offset 100.302 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [水平オフセット] パラメータは、0.000 から 100.302 に正常に変更されました。

スプレッドシートビュー

セルに格納されている編集ボックスコントロールを、指定された浮動小数点値に設定します。編集ボックスコントロールのタイプは EditFloat にする必要があります。

シンタックス: SF[Column][Row][Float]

Set Floatの入力パラメータ

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。
Float | 設定する浮動小数点数 (小数点文字 (.) を含む)。

Set Floatの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効か、または指定した値に浮動小数点数が含まれていません。
-2 | コマンドを実行することができませんでした。例えば、指定したセルに編集ボックスコントロールが格納されていないか、編集ボックスコントロールが EditFloat 関数によって作成されませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Float例

セル A2 に格納されている編集ボックスを浮動小数点値 7.2 に設定するコマンドは、SFA0027.2 です。

  1. セル A2 には、次が格納されていると仮定します。

A2 = EditFloat(0,10)

A2 に現在格納されている値は 3.5 です。 スプレッドシートには次のように表示されます。

  2. Set Float ネイティブモードコマンドを使用してこの値を 7.2 に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SFA0027.2 を発行します。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。EditFloat コントロールは、3.5 から 7.2 に正常に変更されました。


Set Region

ネイティブモードの基本コマンド

In-Sight 通信リファレンス
  • EasyBuilder ビュー
  • スプレッドシートビュー

EasyBuilder ビュー

シンボリックタグに含まれている、EasyBuilder の位置決めツールまたは検査ツールの領域などの領域を設定します。ツールの領域には、EditRegion 関数の編集領域コントロールを含める必要があります。

シンタックス: SR["Symbolic Tag"][Space][Row][Space][Col][Space][High][Space][Wide][Space][Angle][Space][Curve]

Set Regionの入力パラメータ

入力 | 説明
"Symbolic Tag" | 位置決めツールまたは検査ツールの名前 ("Edge_1.Region" など)。
Space | 浮動小数点値から "name" を切り離す空白スペース。
Row | 画像座標での原点の X オフセット。
Space | 次の値と値を切り離す空白スペース。
Col | 画像座標での原点の Y オフセット。
Space | 次の値と値を切り離す空白スペース。
High | 領域の X 軸に沿った寸法。
Space | 次の値と値を切り離す空白スペース。
Wide | 領域の Y 軸に沿った寸法。
Space | 次の値と値を切り離す空白スペース。
Angle | 画像座標での角度。
Space | 次の値と値を切り離す空白スペース。
Curve | 領域の X 軸と反対側の境界線との間の角度変位。

Set Regionの出力

領域 | 1 | コマンドは正常に実行されました。
 | 0 | 認識されないコマンドが送信されました。
 | -1 | "Symbolic Tag" が無効です。
 | -2 | "Symbolic Tag" に編集領域コントロールが含まれていないか、または編集領域コントロールが EditRegion 関数によって作成されなかったため、コマンドを実行できませんでした。
 | -6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Region例

EasyBuilder の位置決めツールまたは検査ツールの領域は、新しい領域の位置、寸法、向き、形状を含む Set Region コマンドを送信することによって設定できます。

  1. ジョブにエッジ位置決めツールが含まれ、ツールの領域が現在別の位置にあり、寸法、向きおよび形状が異なると仮定します。

  2. Set Region ネイティブモードコマンドを介して、ツールの領域設定を移動し、向きを変更します。次の telnet クライアントウィンドウに示すように、コマンド SREdge_1.Region 192.000 119.000 167.000 20 0.5 0 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。

スプレッドシートビュー

セルに格納されている編集領域コントロールを設定します。編集領域コントロールは、EditRegion 関数である必要があります。

シンタックス: SR[Column][Row][Row][Space][Col][Space][High][Space][Wide][Space][Angle][Space][Curve]

Set Regionの入力パラメータ

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。
Row | 画像座標での原点の X オフセット。
Space | 次の値と値を切り離す空白スペース。
Col | 画像座標での原点の Y オフセット。
Space | 次の値と値を切り離す空白スペース。
High | 領域の X 軸に沿った寸法。
Space | 次の値と値を切り離す空白スペース。
Wide | 領域の Y 軸に沿った寸法。
Space | 次の値と値を切り離す空白スペース。
Angle | 画像座標での角度。
Space | 次の値と値を切り離す空白スペース。
Curve | 領域の X 軸と反対側の境界線との間の角度変位。

Set Regionの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | 指定したセルに編集領域コントロールが含まれていないか、または編集領域コントロールが EditRegion 関数によって作成されなかったため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Region例

セル A2 に格納されている編集領域を新しい位置と寸法に設定するコマンド。

  1. セル A2 には、次が格納されていると仮定します。A2 = EditRegion($A$0,0,0,0,1,1,1,1,"Region",0)

    スプレッドシートには次のように表示されます。

  2. Set Region ネイティブモードコマンドを使用して領域の位置と寸法を変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SRA002437.0 581.2 333.12 441 2 2.3 を発行します。

    In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。
Version: 5.6.0


Set String

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

EasyBuilder の検査ツールのパラメータなどのシンボリックタグの文字列を指定した文字列に設定します。パラメータは文字列データ型にする必要があります。

シンタックス: SS["Symbolic Tag"][Space][String]

Set Stringの入力パラメータ

入力 | 説明
"Symbolic Tag" | 位置決めツールまたは検査ツールの結果のシンボリックタグ名 ("Text_1.Match_String" など)
Space | 設定する文字列から "name" を切り離す空白スペース。
String | 設定する文字列。

Set Stringの出力

戻り値 | 1 | コマンドは正常に実行されました。
 | 0 | 認識されないコマンドが送信されました。
 | -1 | "Symbolic Tag" が無効です。
 | -2 | 入力文字列が EditString 関数で指定した最大文字列の長さより長いか、セルに EditString 関数が格納されていません。
 | -6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set String例

文字認識または ID コードの読み取り検査ツールの文字列は、新規ストリングが指定されている Set String コマンドを送信することによって設定できます。

  1. ジョブに文字認識識別ツールが含まれており、そのツールの現在の [マッチ文字列] パラメータの設定がデフォルトの ABC であると仮定します。

  2. このとき、このパラメータの設定を Set String ネイティブモードコマンドを使用して変更するとします。次の telnet クライアントウィンドウに示すように、コマンド SIText_1.Match_String 604 を発行します。

  3. In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。ツールの [マッチ文字列] パラメータは、ABC から 604 に正常に変更されました。

スプレッドシートビュー

セルに格納されている編集ボックスコントロールを、指定された文字列に設定します。編集ボックスコントロールのタイプは EditString にする必要があります。

シンタックス: SS[Column][Row][String]

Set Stringの入力パラメータ

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000～399)。
String | 設定する文字列。

Set Stringの出力

戻り値 | 1 | コマンドは正常に実行されました。
 | 0 | 認識されないコマンドが送信されました。
 | -1 | セル ID が無効です。
 | -2 | 入力文字列が EditString 関数で指定した最大文字列の長さより長いか、セルに EditString 関数が格納されていません。
 | -6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set String例

  1. セル B2 には、次が格納されていると仮定します。

B2 = EditString(20)

EditString コントロールには現在、Before SS というテキストが含まれています。スプレッドシートには次のように表示されます。

  2. Set String ネイティブモードコマンドを使用してこのテキストを After SS に変更するには、次の Telnet クライアントウィンドウに示すように、コマンド SSB002After SS を発行します。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。EditString コントロールは、Before SS から After SS に正常に変更されました。


Get Info

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight ビジョンシステムのシステム情報を返します。

シンタックス: GI

Get Infoの入力パラメータ

なし。

Get Infoの出力

戻り値

ステータスコード。その後にシステム情報が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。

システム情報には次の情報が含まれます。

Serial Number | In-Sight ビジョンシステムのシリアル番号。
Application Version | In-Sight ビジョンシステムの現在のファームウェアのバージョン。
Monitor Version | In-Sight ビジョンシステムのモニタのバージョン。
MAC Address | In-Sight ビジョンシステムの MAC アドレス。
Date of Build | In-Sight ビジョンシステムのファームウェアのビルドを作成した日付。

Get Info例

In-Sight ビジョンシステムについてのシステム情報を表示するには、次のコマンドを発行します。GI

ビジョンシステムは、まず、1 を返すことにより、コマンドが正常に実行されたことを示します。以下の行には、システム情報が報告されます。
Version: 5.6.0


Read Settings

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサからシステム設定データを読み取ります。システム設定データは proc.set ファイルの内容で構成されており、ASCII 16 進フォーマットでエンコードされています。

シンタックス: RS

Read Settingsの入力パラメータ

なし。

Read Settingsの出力

戻り値

ステータスコード。その後に行の終端文字と、設定データの行が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | 設定を読み取ることができませんでした。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

設定データの行は次のとおりです。

Size | 1 行目には、設定データのサイズ (バイト単位) の整数値が含まれています。
Settings | 設定データは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされます。各行は終端文字で終わります。
CheckSum | 最後の行には、システムの設定データのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Read Settings例

In-Sight センサからシステム設定データを読み取るには、次のコマンドを発行します。RS

In-Sight センサは最初、コマンドが正常に実行されたことを示す 1 を返すことによって応答します。次の行 (4246) は、伝達されるデータ量 (バイト単位) を表します。最後に、システム設定データが送信され、その後にデータのチェックサム (9A67) が続きます。

注:

  • 実際の画像データのほとんどは、明確化のため、先のグラフィックから省略されています。
  • RS コマンドによって報告されるサイズは、データの ASCII 16 進エンコードのため、proc.set ファイルのバイト数の 2 倍になります。

関連項目

Write Settings

Store Settings


Write Settings

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

リモートデバイスから In-Sight センサにシステム設定データを送信します。

シンタックス: WS

[Size]

[Settings]

[Checksum]

注: In-Sight センサはオフラインになっている必要があります。

Write Settingsの入力パラメータ

このコマンドは別個の行で送信され、その後に設定データの行が続きます。設定データは、Read Setting コマンドから受け取るデータの正確なコピーである必要があります。

設定データの行は次のとおりです。

入力 | 説明
Size | 1 行目には、設定のサイズ (バイト単位) の整数値が含まれています。
Settings | 設定データは、80 文字/行でフォーマットされた ASCII 16 進数値としてエンコードされます。各行は終端文字で終わります。
CheckSum | 最後の行には、システムの設定データのチェックサムとして 4 バイトの ASCII 16 進数が含まれています。

Write Settingsの出力

戻り値

ステータスコードの後に、行の終端文字が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | 設定を保存できませんでした。
-3 | チェックサムに失敗しました。チェックサムが設定データと一致しません。
-4 | In-Sight センサのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Write Settings の例

システムの設定をセンサに送信するには、次のコマンドを発行します。WS

Write Settings コマンドを発行した後、最初に入力するのはバイト単位のサイズ (4246) です。 次に、システム設定の各 ASCII 16 進バイトを入力します。 最後に、4 バイトの ASCII 16 進チェックサム (9A67) を最後の行に入力します。

In-Sight ビジョンシステムは、ステータスコード 1 を返すことにより、コマンドが正常に実行されたことを示します。

注:
  • 実際の画像データのほとんどは、明確化のため、先のグラフィックから省略されています。
  • サイズは、データの ASCII 16 進エンコードのため、proc.set ファイルのバイト数の 2 倍になります。

関連項目

Read Settings

Store Settings


Store Settings

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサの設定を proc.set ファイルに保存します。

シンタックス: TS

Store Settingsの入力パラメータ

なし。

Store Settingsの出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | センサがオンラインであるため、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Store Settings の例

センサの設定を proc.set ファイルに保存するには、次のコマンドを発行します。TS

In-Sight ビジョンシステムは、ステータスコード 1 を返すことにより、コマンドが正常に実行されたことを示します。

関連項目

Read Settings

Write Settings


Set IP Address Lock

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサの IP アドレスが無許可で変更されないようにします。

シンタックス: SL[Int]

Set IP Address Lockの入力パラメータ

入力

説明

Int

0 | IP アドレスをロック解除します
1 | IP アドレスをロックします

Set IP Address Lockの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | Int に指定された値が範囲外か、または有効な整数ではありません。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set IP Address Lock の例

センサの IP アドレスをロックするには、次のコマンドを発行します。SL1

In-Sight センサは、IP アドレスが正常にロックされたことを示すステータスコード 1 を返すことによって応答します。

関連項目

Get IP Address Lock


Get IP Address Lock

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサ上の IP アドレスのセキュリティステータスを返します。IP アドレスに対する無権限での変更を防止するには、Set IP Address Lock コマンドを使用します。

シンタックス:GL

Get IP Address Lockの入力パラメータ

なし。

Get IP Address Lockの出力

戻り値

0 | IP アドレスはロックされていません。
1 | IP アドレスはロックされています。
-2 | コマンドを実行することができませんでした。

Get IP Address Lock の例

センサ上の IP アドレスのセキュリティステータスを返すには、次のコマンドを発行します。GL

In-Sight センサは、IP アドレスはロックされていないことを示す 0 を返すことによって応答します。

関連項目

Set IP Address Lock


Set Online

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサをオンラインモードまたはオフラインモードに設定します。

シンタックス: SO[Int]

注:
  • In-Sight Explorer ユーザインタフェースで手動により、またはディスクリート入力信号によりセンサがオフラインに設定されている場合は、このコマンドによって In-Sight センサをオンラインモードにすることはできません。
  • In-Sight Explorer アプリケーションは、Set Online コマンドを In-Sight センサに送信して、バックアップやリストアなどの管理機能を実行します。

Set Onlineの入力パラメータ

入力

説明

Int

0 | In-Sight センサをオフラインに設定します。
1 | In-Sight センサをオンラインに設定します。

Set Onlineの出力

戻り値 | 1 | コマンドは正常に実行されました。
 | 0 | 認識されないコマンドが送信されました。
 | -1 | Int に指定された値が範囲外か、または有効な整数ではありません。
 | -2 | コマンドを実行することができませんでした。
 | -5 | 通信フラグは正常でしたが、In-Sight Explorer ユーザインタフェースで手動により、またはディスクリート I/O 信号によりセンサがオフラインに設定されているため、センサがオンラインになりませんでした。
 | -6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Online例

例 1: In-Sight センサをオンラインモードに設定する

例 2: In-Sight センサをオフラインモードに設定する

例 1: In-Sight センサをオンラインモードに設定する

In-Sight センサをオンラインモードに設定するには、次のコマンドを発行します。SO1

In-Sight センサは、センサが正常にオンラインになったことを示すステータスコード 1 を返すことによって応答します。

例 2: In-Sight センサをオフラインモードに設定する

In-Sight センサをオフラインモードに設定するには、次のコマンドを発行します。SO0

In-Sight センサは、センサが正常にオフラインになったことを示すステータスコード 1 を返すことによって応答します。
Version: 5.6.0


Get Online

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサのオンライン状態を返します。

シンタックス: GO

Get Onlineの入力パラメータ

なし。

Get Onlineの出力

戻り値

0 | In-Sight センサは現在オフラインです。
1 | In-Sight センサは現在オンラインです。

Get Online例

In-Sight センサのオンライン状態を終了するには、次のコマンドを発行します。GO

In-Sight センサは、センサが現在オフラインになっていることを示す 0 を返すことによって応答します。


Set Event

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

ネイティブモードのコマンドを使用して、スプレッドシート内の指定したイベントをトリガします。

  • SetEvent の入力パラメータ
  • SetEvent の結果出力
  • SetEvent の例

注:
  • ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。SetEvent 関数を PLC/モーションコントローラで使用して画像取り込みをトリガする場合、検査結果も読み取られていない場合にのみ使用してください。それ以外の場合に使用すると、画像取り込みと検査が同期されません。ビジョンシステムは画像が取り込まれるとすぐ、検査完了前に応答を返します。
  • In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

Set Eventの入力パラメータ

シンタックス: SE[Int]

入力

説明

Int

設定するイベントコード。

(0 ～ 7) | ソフトトリガ (ソフト 0、ソフト 1、...、ソフト 7) を指定します。
8 | 画像を取り込み、スプレッドシートを更新します。このオプションでは、AcquireImage 関数の [トリガ] パラメータを、[外部]、[手動]、または [ネットワーク] に設定する必要があります。

Set Eventの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 番号が範囲外 (0 ～ 8 以外) であるか、整数ではありません。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Event例

SetEvent 関数を使用して、スプレッドシート内のイベントをネイティブモードコマンドでトリガします。

イベント 0 (ソフト 0) をトリガするコマンドは SE0 です。

  1. セル A2 および A3 には、次が格納されていると仮定します。

A2 = Event(80,0)

A3 = Count($A$2,9999,0,0)

スプレッドシートには次のように表示されます。

  2. Telnet クライアントを使用して、連続した 4 つの Set Event コマンドを発行します。

SE0 が送信されるたびに、セル A3 のカウンタが 1 ずつ増加されます。


Set Event and Wait

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

指定したイベントをトリガして、コマンドが完了してから応答を返します。

注:
  • In-Sight ビジョンシステムはオンラインになっている必要があります。
  • ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

Set Event and Waitの入力パラメータ

シンタックス: SW[Int]

入力

説明

Int

設定するイベントコード。

(0 ～ 7) | ソフトトリガ (ソフト 0、ソフト 1、...、ソフト 7) を指定します。
8 | 画像を取り込み、スプレッドシートを更新します。このオプションでは、AcquireImage 関数の [トリガ] パラメータを、[外部]、[手動]、または [ネットワーク] に設定する必要があります。

Set Event and Waitの出力

戻り値

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 番号が範囲 (0 ～ 8) 外か、または整数ではありません。
-2 | コマンドを実行できなかったか、センサがオフラインです。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Set Event and Wait例

イベント 0 (ソフト 0) をトリガするコマンドは SW0 です。コマンドが完了するまで、応答は送信されません。

  1. セル A2 および A3 には、次が格納されていると仮定します。

A2 = Event(80,0)

A3 = Count($A$2,9999,0,0)

スプレッドシートには次のように表示されます。

  2. センサをオンラインにします。Telnet クライアントを使用して、連続した 4 つの Set Event & Wait コマンドを発行します。

SW0 が送信されるたびに、セル A3 のカウンタが 1 ずつ増加されます。


Reset System

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

In-Sight センサをリセットします。このコマンドは、センサの電源を物理的に再投入するのに似ています。

シンタックス: RT

Reset Systemの入力パラメータ

なし。

Reset Systemの出力

戻り値

ステータスコード。その後に行の終端文字と、設定データの行が続きます。次のステータスコードのみが返されます。

-6

ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Reset System の例

In-Sight センサをリセットするには、次のコマンドを発行します。RT

In-Sight センサが正常にリセットされ、ステータスコードは何も返されません。


Send Message

ネイティブモードの基本コマンド

In-Sight 通信リファレンス

文字列をネイティブモード接続経由で In-Sight のスプレッドシートに送信します。スプレッドシートのイベントをトリガすることもできます。

シンタックス: SM"String"[Int]

Send Messageの入力パラメータ

入力

説明

"String"

設定する文字列。

注: 文字列は引用符で囲む必要があります。

Int

設定するイベントコード。

注: これはオプションのパラメータです。

(0 ～ 7) | ソフトトリガを指定します (ソフト 0、ソフト 1、...、ソフト 7)。
8 | 画像を取り込み、スプレッドシートを更新します。このオプションでは、AcquireImage 関数の [トリガ] パラメータを、[外部] または [手動] に設定する必要があります。

Send Messageの出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 番号が範囲 (0 ～ 8) 外か、または整数ではありません。
-2 | コマンドを実行できなかったか、センサがオフラインです。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Send Message の例

例: テキスト文字列を送信する

例: 文字列を送信して、スプレッドシートイベントをトリガする

例: テキスト文字列を送信する

  1. セル A2 および A3 には、次が格納されていると仮定します。

A2 = Event(80,0)

A3 = ReadMessage(A2)

スプレッドシートには次のように表示されます。

  2. センサをオンラインにします。Telnet クライアントを使用して、In-Sight センサに Set Event コマンドを発行します。文字列「Test」を送信するコマンドは、SM"Test" です。イベント 0 (ソフト 0) をトリガするコマンドは SE0 です。

セル A3 の ReadMessage 関数によって「Test」と表示されます。

例: 文字列を送信して、スプレッドシートイベントをトリガする

  1. セル A2 および A3 には、次が格納されていると仮定します。

A2 = Event(80,0)

A3 = ReadMessage(A2)

スプレッドシートには次のように表示されます。

  2. センサをオンラインにします。Telnet クライアントを使用して、In-Sight センサに Send Message コマンドを発行します。「Test」という文字列を送信し、イベント 0 (ソフト 0) をトリガするコマンドは、SM"Test"0 です。

  3. センサをオフラインにします。セル A3 の ReadMessage 関数によって「Test」と表示されます。


Get

ネイティブモードの拡張コマンド - Get

In-Sight 通信リファレンス

In-Sight ビジョンシステムおよびそのスプレッドシートから情報を取得するために、次の 3 つのコマンドが、ネイティブモードの拡張コマンドである Get と組み合わせて使用されます。

  • Get Connections
  • Get Expr [列][行]
  • Get Filelist

シンタックス: Get [コマンド]

注: Get とコマンドの間、およびコマンドと入力パラメータの間にはスペースが必要です。

Get Connections

In-Sight ビジョンシステムの現在の接続情報を返します。

シンタックス: Get Connections

Get Connections の入力

なし。

Get Connections の出力

戻り値
  • ステータスコード。ステータスコードは次のとおりです。
1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができませんでした。
-6 | パラメータが無効か、長さが 15 バイトを超えています。
  • ビジョンシステムに現在ログオンしているユーザ数。
  • ビジョンシステムに現在ログオンしているユーザ名。
  • 各ユーザの FTP 読み取り/書き込み権限、アクセスレベル、および Java アプレット接続の 16 進表記。FTP 読み取り/書き込み権限、アクセスレベル、および Java アプレット接続は、次のとおりです。
0x01 | 読み取り
0x02 | 書き込み
0x08 | アクセスレベルが「プロテクト」のユーザは、ビジョンシステムの操作モードをオンラインとオフラインの間で切り替えることができません。
0x10 | フル
0x20 | プロテクト
0x40 | ロック
0x80 | Java アプレット接続
  • 各ユーザのビジョンシステムのホスト名と IP アドレス (16 進数)。

Get Connections の例

ビジョンシステムの接続設定を取得するには、次のコマンドを発行します。Get Connections

In-Sight ビジョンシステムは、まず、ステータスコード (1) と、その後の、In-Sight ビジョンシステムにログオンしているユーザ数 (2) で応答します。次に、各ユーザの接続情報が表示されます。最初のユーザ admin のアクセスの 16 進表記は 0x13 です。この表記は、ユーザに適用される FTP 読み取り/書き込み権限とアクセスレベル (前の表を参照) を合計することによって求められます。この例では、admin はフルアクセス (0x10) + FTP 読み取り権限 (0x01) + FTP 書き込み権限 (0x02) = 0x13 を持っています。ユーザ admin は、現在、FACTORYFLOOR-1 という名前のビジョンシステムに接続されています。FACTORYFLOOR-1 の IP アドレスは 192.168.0.1 です。このアドレスを 16 進で表すと、C0A80001 になります。

第 2 のユーザ (monitor) の接続情報は、同様に次の行に示されています。

Get Expr

列および行アドレスにより指定したセルに含まれているパラメータまたは値と、そのセルの状態を返します。

シンタックス: Get Expr [列][行]

注: 指定したセルが空白の場合は、ステータスコードの後の 2 つの出力行は空白になります。

Get Expr の入力

入力 | 説明
列 | 設定するセル値の列文字 (A ～ Z)。
行 | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。

Get Expr の出力

戻り値
  • ステータスコード。ステータスコードは次のとおりです。
1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができませんでした。
  • 指定したセルに含まれるパラメータまたは値。
  • 指定したセルの状態。
0 | セルは無効です。
1 | セルは有効です。

Get Expr の例

セル A0 に含まれている AcquireImage 関数によって返されるパラメータを取得するには、次のコマンドを発行します。Get Expr A000

コマンド Get Expr A000 を発行すると、In-Sight ビジョンシステムは、ステータスコード (1) で応答し、その後に、セル A0 に含まれる式が続きます。最後に、セルの状態 (1) が表示されます。

Get Filelist

In-Sight ビジョンシステムのメモリに格納されているファイルの数と各ファイル名を返します。

シンタックス: Get Filelist

注:

  • ビジョンシステム上で RAM ディスクフォルダが有効になっている場合は、「RAMDisk」というフォルダ名が Get Filelist の出力に含まれます。
  • Get Filelist ネイティブモードコマンドを使用して RAM ディスクフォルダからファイルリストを取得することはできません。RAM ディスクフォルダのファイルリストを取得するには、代わりに Closed FTP プロトコルを使用してください。FTP コマンドの CD (change directory) はサポートされません。

Get Filelist の入力

なし。

Get Filelist の出力

戻り値

ステータスコードの後に、メモリに格納されているファイルの数と各ファイル名が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができませんでした。

Get Filelist の例

In-Sight ビジョンシステムに格納されているファイルの数とリストを取得するには、次のコマンドを発行します。Get Filelist

コマンド Get Filelist を発行すると、In-Sight ビジョンシステムは、ステータスコード (1) で応答し、その後に、メモリに存在するファイルの数 (13) が続きます。最後に、各ファイルのファイル名が表示されます。


Put

ネイティブモードの拡張コマンド - Put

In-Sight 通信リファレンス

シンタックス: Put [command] [input parameters]

概要Put

In-Sight ビジョンシステムとそのスプレッドシートに情報を送信するため、次のコマンドがネイティブモードの拡張コマンドである Put と組み合わせて使用されます。

  • Put Live [Int]
  • Put Portnum [Int]
  • Put Timeout [Int]
  • Put Update
  • Put Watch [Column][Row][Int]
  • Put XML [Int]

注: Put とコマンドの間、およびコマンドと入力パラメータの間 (入力パラメータがある場合) にはスペースが必要です。

Put Live

ライブ取り込みモードのオン/オフを切り替えます。

シンタックス: Put Live [Int]

注: Put Live コマンドを使用する場合は、ビジョンシステムがオフラインになっている必要があります。

Put Live の入力パラメータ

入力 | 説明
Int | 0 = ライブ取り込みモードを無効にします。 1 = ライブ取り込みモードを有効にします。

Put Live の結果出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができなかったか、またはビジョンシステムがオフラインです。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Put Live の例

ビジョンシステムをライブ取り込みモードにするには、次のコマンドを発行します。Put Live 1

In-Sight ビジョンシステムは、ビジョンシステムが正常にライブ取り込みモードになったことを示すステータスコード 1 を返すことによって応答しました。

ビジョンシステムのライブ取り込みモードを終了するには、次のコマンドを発行します。Put Live 0

In-Sight ビジョンシステムは、ビジョンシステムが正常にライブ取り込みモードでなくなったことを示すステータスコード 1 を返すことによって応答しました。

Put Portnum

ネットワークを介してデータまたは画像を転送するために In-Sight ビジョンシステムが使用するポートを指定します。

シンタックス: Put Portnum [Int]

注:

  • Portnum コマンドは、別のデバイスが指定されたポートに接続できるようになる前に実行する必要があります。
  • ポート番号が変更されると、In-Sight OPC サーバは無効になります。
  • In-Sight 2000 シリーズのビジョンセンサでは、この拡張ネイティブモードコマンドをサポートしておらず、実行すると -2 を返します。

Put Portnum の入力パラメータ

入力 | 説明
Int | ポート番号を指定します。 (1 ～ 65535) 注: 有効なポート番号は、In-Sight の通信に使用されるポートを除いた 1 ～ 65535 の範囲の未使用の番号です。

Put Portnum の結果出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができなかったか、またはビジョンシステムがオフラインです。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Put Portnum の例

ネットワーク上でのデータまたは画像の転送に使用するポートとして 3001 を指定するには、次のコマンドを発行します。Put Portnum 3001

In-Sight ビジョンシステムは、ポート番号が正常に 3001 に変更されたことを示すステータスコード 1 を返すことによって応答しました。

Put Timeout

アクティビティなしでクライアントからのポート接続が開いた状態のまま残される時間 (ミリ秒) を指定します。In-Sight ビジョンシステムは、指定された時間内にクライアントから何もメッセージを受信しない場合、そのポートを閉じます。

シンタックス: Put Timeout [Int]

注: In-Sight ビジョンシステムが再起動されると、タイムアウトはデフォルト設定 (0 ミリ秒) にリセットされます。

Put Timeout の入力パラメータ

入力 | 説明
Int | 0* または -1 | タイムアウトしません。
 | (1 ～ 9999999) | アクティビティなしでポート接続が開いた状態のまま残される期間 (ミリ秒)。
* はデフォルト値を示します。 |  |

Put Timeout の結果出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Put Timeout の例

タイムアウトを 30000 ミリ秒に指定するには、次のコマンドを発行します。Put Timeout(30000)

In-Sight ビジョンシステムは、タイムアウトが正常に 30000 に変更されたことを示すステータスコード 1 を返すことによって応答しました。

Put Update

GUI (スプレッドシート、セルグラフィックスおよび画像表示) を更新します。

シンタックス: Put Update [Int]

Put Update の入力パラメータ

入力 | 説明
Int | 1 = GUI (セルグラフィックスおよび画像表示) を更新します。

Put Update の結果出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Put Update の例

GUI を更新するには、次のコマンドを発行します。Put Update 1

In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示すステータスコード 1 を返すことによって応答しました。

Put Watch

指定されたセルが更新されるごとに、そのセルに格納されている値を返します。Put Watch コマンドは、出力セルを指定し、DataChannel を使用してデータを送信するために使用できます。

シンタックス: Put Watch [Column][Row][Int]

注:
  • Put Watch コマンドによる情報の送信先ポートを指定するには、Put Put Portnum コマンドを実行する必要があります。
  • In-Sight 2000 シリーズのビジョンセンサでは、この拡張ネイティブモードコマンドをサポートしておらず、実行すると -2 を返します。

Put Watch の入力パラメータ

入力 | 説明
Column | 設定するセル値の列文字 (A ～ Z)。
Row | 設定するセル値の行番号。行番号は、3 桁で構成されている必要があります (000 ～ 399)。
Int | 0 = セル値の出力を無効にする 1 = 変更された場合にのみセル値の出力を有効にする 2 = すべての画像取り込みでセル値の出力を有効にする

Put Watch の結果出力

戻り値

ステータスコード。その後に行の終端文字と、指定したセルに格納されている値が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

Put Watch の例

セルの内容が更新された場合にのみセル A0 から情報を受信するには、次のコマンドを発行します。Put Watch A000

In-Sight ビジョンシステムは、コマンドが正常に実行されたことを示すステータスコード 1 を返すことによって応答しました。

Put XML

ネイティブモードコマンドの出力結果が XML でフォーマットされるようにするかどうかを指定します。

シンタックス: Put XML [Int]

Put XML の入力パラメータ

入力 | 説明
Int | 0 = XML フォーマットを無効にする (デフォルト) 1 = レガシー XML フォーマットを有効にする 2 = 厳密な XML フォーマットを有効にする

Put XML の結果出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | 入力が無効か、長さが 15 バイトを超えています。

Put XML の例

次の例では、標準的な出力が、レガシー XML 有効出力および厳密な XML 有効出力と比較されています。

Put XML 0

出力結果の XML フォーマットを無効にするには、次のコマンドを発行します。Put XML 0In-Sight ビジョンシステムは、XML が正常に無効化されたことを示す 1 を返すことによって応答します。次に、Get Filelist コマンドを発行します。

Put XML 1

出力結果のレガシー XML フォーマットを有効にするには、以下のコマンドを発行します。Put XML 1In-Sight ビジョンシステムは、適切な XML フォーマットを使用し、レガシー XML が正常に有効化されたことを示す 1 を返すことによって応答します。次に、Get Filelist コマンドを発行します。応答はレガシー XML フォーマットになります。

Put XML 2

出力結果の厳密な XML フォーマットを有効にするには、以下のコマンドを発行します。Put XML 2In-Sight ビジョンシステムは、適切な XML フォーマットを使用し、1 を返して応答します。次に、Get Filelist コマンドを発行します。応答は厳密な XML フォーマット (例えば、FileName ID 値が引用符で囲まれます) になります。


Evaluate

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

In-Sight 関数を実行するとともに、In-Sight のスプレッドシートに数式を挿入します。Evaluate は、In-Sight ビジョンシステムから情報を取得したり、In-Sight ビジョンシステムに変更を加えたりするコマンドを実行します。

シンタックス: EV [command]

注:

  • Evaluate コマンドを使用してデータ構造体を返す In-Sight 関数を実行することはできませんが、このような関数を In-Sight のスプレッドシートに挿入することは可能です。
  • Evaluate コマンドを使用して In-Sight システム設定に加えられる変更は一時的なものです。In-Sight ビジョンシステムを再起動すると、変更はすべて失われます。設定を proc.set ファイルに保存するには、Store Settings コマンドを使用してください。

Evaluateの入力パラメータ

Command

サポートされている任意の In-Sight 関数、つまり関数の適切な文字列、および一般的なコマンド。

注: 引用符で囲まれている入力 (GetSystemConfig の "DHCPTimeout" など) は、In-Sight ビジョンシステムに送信する際に引用符で囲む必要があります。

Evaluate の結果出力

戻り値
  • ステータスコード。 ステータスコードは次のとおりです。
1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-4 | In-Sight ビジョンシステムのメモリ不足です。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。
  • 後続の出力に含まれる文字数 (バイト単位)。
  • 式の結果 (XML フォーマット、ステータスコードが 1 の場合のみ表示されます)。

注: 式の結果は、実行されるコマンドによって異なります。

Evaluate の例

例: Evaluate コマンドを使用して In-Sight の数式をスプレッドシートのセルにリモートで挿入する

例: Evaluate コマンドと In-Sight 関数を使用して In-Sight ビジョンシステムから情報を取得する

例: Evaluate コマンドを使用して In-Sight のネットワーク設定を取得する

例: Evaluate コマンドを使用して In-Sight の特定の設定を変更する

例: Evaluate コマンドを使用して In-Sight の数式をスプレッドシートのセルにリモートで挿入する

Evaluate コマンドを使用して In-Sight の数式をスプレッドシートのセルにリモートで挿入するための一般的なシンタックスは、次のとおりです。

シンタックス: EV [Column][Row] [Cell state] [Formula]

Evaluate の入力

Column

設定するセル値の列文字 (A ～ Z)。

Row

設定するセル値の行番号 (0 ～ 399)。

Cell state

指定したセルの現在の状態 (0 = 無効、1 = 有効)。

注:

  • セル状態は別のセルを (絶対または相対) 参照することもあります。参照されるセルが空白の場合、セル状態は 0 になります。
  • テキストラベル付きのコントロール関数を、セル状態が無効と指定されたスプレッドシートに挿入した場合、GUI にはコントロールに関連付けられたグラフィックスのみが表示されます。スプレッドシート内でセル状態が変更されない限り、テキストラベルはスプレッドシートに表示されません。

数式

数式を作成するための値、関数、引数、および演算子の組み合わせ。

例 A: 基本関数をリモートで挿入する

  1. スプレッドシートが次のように設定されていると仮定します。
     A3 = 3
    A4 = 4
    A5 = 5
    A6 = 6

リモート接続を使用して、In-Sight スプレッドシートに数式を挿入することができます。

  2. Telnet クライアントから In-Sight ビジョンシステムにログオンしているときに、次のコマンドを入力します。EV A8 1 Sum(1,2,A3:A6)

In-Sight は、ステータスコード (1) と、その後に XML データのバイト数 (0) を続けて返して応答します。この Evaluate コマンドにより、数式 Sum(1,2,A3:A6) がセル A8 に挿入されます。

注: Sum スプレッドシート関数によって返される実際の結果 21 は、この Evaluate コマンドによって XML データとしては返されません。この結果を取得するには、代わりに Get Value コマンドを使用してください。

例 B: プロパティシートを使用して関数をリモートで挿入する

プロパティシートから選択したパラメータを含む関数も、スプレッドシートにリモートで挿入できます。Telnet クライアントから、次のコマンドを入力します。EV A2 1 ExtractBlobs($A$0,0,0,0,40,276,381,450,0,0,8,-1,0,0,2,1,100,100000,0)

次の画像に示すように、In-Sight ビジョンシステムは、ステータスコード (1) と、返された XML データのサイズ (0) で応答します。

ExtractBlobs 関数は、スプレッドシートのセル A2 に正常に挿入されました。

例: Evaluate コマンドと In-Sight 関数を使用して In-Sight ビジョンシステムから情報を取得する

シンタックス: EV [command]

  1. In-Sight スプレッドシートのセル A2 に ReadIDCode 関数から取得された [image] データ構造体が含まれていると仮定します。デコードされた文字列は、隣のセルに次のように返されます。

    A2 = ReadIDCode($A$0,0,0,0,156.798,216.083,178.964,179.119,0,128,0,1,3,0,0,0,0,15,0,2,1,0,0,6,0,0,0)

  2. 次のように、Telnet クライアントを使用して In-Sight ビジョンシステムにログオンし、EV GetString(A2) と入力します。

In-Sight ビジョンシステムは、ステータスコード 1 を返して、コマンドが正常に実行されたことを示します。次の行では、36 バイトの XML データが返されたことが報告され、最後の行には、XML で書式設定された式の結果が含まれています。

例: Evaluate コマンドを使用して In-Sight のネットワーク設定を取得する

シンタックス: EV [command]

Telnet クライアントから In-Sight ビジョンシステムにログオンしているときに、EV GetNetwork() と入力して、システムのネットワーク設定を取得します。Telnet クライアントの出力は、次の画像に示されています。

In-Sight ビジョンシステムは、ステータスコード 1 を返すことにより、コマンドが正常に実行されたことを示します。次の行には、その後に続く XML データのサイズ (552 バイト) が含まれています。残りの行は、返された実際の XML データで構成されています。

例: Evaluate コマンドを使用して In-Sight の特定の設定を変更する

この例では、In-Sight 5100 ビジョンシステムの FTP 設定のうち、アイドルタイムアウト、読み取りタイムアウト、接続リトライ、ローカルポート、リモートポート、およびパッシブ転送を設定します。Telnet クライアントから In-Sight ビジョンシステムにログオンしているときに、次のコマンドを発行します。EV SetFTPSettings(120,120,1,21,21,0)

Telnet クライアントの出力は、次の画像に示されています。

In-Sight ビジョンシステムは、ステータスコード 1 を返すことによって、コマンドが正常に実行されたことを示します。次の 18 は、その後に続く XML 出力バイト数を表しています。最後に、実際の XML データが示されています。
Version: 5.6.0


GetCellName

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

指定されたシンボリックタグ名のセルの位置、または指定されたセルのシンボリックタグ名を返します。

シンタックス: EV GetCellName("Name")

GetCellNameの入力パラメータ

入力 | 説明
"Name" | シンボリックタグの名前 (Distance_1.Distance など) やセルの場所 (A4 など)。名前は引用符で囲む必要があります。

GetCellNameの出力

戻り値

ステータスコード。その後に文字数とセルの名前またはセル参照が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetCellName例

シンボリックタグ名

セル B116 のシンボリックタグ名を取得するには、次のコマンドを発行します。EV GetCellName("B116")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返します。文字数 (バイト単位) の後にはシンボリックタグ名が続きます。

シンボリックタグ名のセルの場所

シンボリックにタグ付けされた距離寸法測定ツールの結果のセルの場所を取得するには、次のコマンドを発行します。EV GetCellName("Distance_1.Distance")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にはセルの場所が続きます。
Version: 5.6.0


GetCellValue

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

指定したシンボリックタグ (EasyBuilder フィクスチャ出力、EasyBuilder の位置決めツールまたは検査ツールの結果、スプレッドシートなど) の内容を XML フォーマットで返します。

注: ジョブが英語以外の言語で作成および設定されており、[オプション] ダイアログの [ユーザインタフェース] パネルで [英語シンボリックタグを EasyBuilder で使用] オプションが有効 (チェックボックスがオン) になっている場合、このオプションを有効にする前に作成されたシンボリックタグ参照はすべて英語名バージョンに更新される必要があります。

シンタックス: EVGetCellValue("Symbolic Tag")

GetCellValueの入力パラメータ

入力 | 説明
"Symbolic Tag" | 位置決めツールまたは検査ツールの結果などのシンボリックタグの名前 ("Distance_1.Distance"など) またはセル参照 (A4 など)。自動生成された EasyBuilder のフィクスチャ出力データの場合、名前は、通信 アプリケーションステップで選択した [デバイス] と [プロトコル] に応じて、"Job.Robot.FormatString" と "Job.FormatString" のどちらかにする必要があります。名前は引用符で囲む必要があります。

GetCellValueの出力

戻り値

ステータスコード。その後に文字数とセルの内容 (整数、浮動小数点値、またはテキスト文字列) が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetCellValue例

EasyBuilder

正確な位置決めが必要とされるロボットガイダンスアプリケーションのフィクスチャデータ、または 位置決めツールまたは検査ツールの結果を取得するには:

正確な位置決めが必要とされるロボットガイダンスアプリケーションのフィクスチャ例

発行可能なコマンドは、通信の手順で選択した [デバイス] と [プロトコル] に応じて、EV GetCellValue("Job.Robot.FormatString") と EV GetCellValue("Job.FormatString") の 2 つです。

EV GetCellValue("Job.Robot.FormatString") は次の状況で使用します。

  • [デバイス] の選択が [Robot] になっている。
  • [デバイス] の選択が [その他] になっており、[プロトコル] で [シリアル Kuka] と [シリアル Motoman] のどちらかが選択されている。

EV GetCellValue("Job.FormatString") は次の状況で使用します。

  • [デバイス] の選択が [その他] になっており、[プロトコル] で、[イーサネットネイティブ]、[シリアルネイティブ]、[シリアルテキスト] または [TCP/IP] が選択されている。

EV GetCellValue("Job.Robot.FormatString")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。

EV GetCellValue("Job.FormatString")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。

位置決めツールまたは検査ツールの結果例

次の例は、距離寸法ツールの結果を取得するコマンドを発行する場合を示しています。

EV GetCellValue("Distance_1.Distance")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。

スプレッドシート

スプレッドシートの特定のセルの値を取得するには、次のコマンドを発行します。

EV GetCellValue("A52")

このコマンドを発行すると次の結果になります。

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。文字数 (バイト単位) の後にセルの値 (整数、浮動小数点、またはテキスト文字列) が続きます。
Version: 5.6.0


GetDeEnergizeOutputs

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ディスクリート　I/O の設定] ダイアログで設定された [オフライン時に出力の電源を切る] の設定を返します。

シンタックス: EVGetDeEnergizeOutputs()

GetDeEnergizeOutputsの入力パラメータ

なし。

GetDeEnergizeOutputsの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetDeEnergizeOutputs例

[オフライン時に出力の電源を切る] 設定を取得するには、次のコマンドを発行します。EV GetDeEnergizeOutputs()

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、[オフライン時に出力の電源を切る] 設定が返されます。
Version: 5.6.0


GetDiagnosticLog

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

In-Sight ビジョンシステムのエラーを診断するために使用する情報のログを返します。

シンタックス: EVGetDiagnosticLog()

GetDiagnosticLogの入力パラメータ

なし。

GetDiagnosticLogの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetDiagnosticLog例

In-Sight Micro 1100 ビジョンシステムと、CIO-MICRO、CIO-MICRO-CC、または CIO-WENET Ethernet I/O モジュールの間の接続ステータスの診断ログを取得するには、次のコマンドを発行します。EV GetDiagnosticLog()

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (446) を続けて返して応答します。最後に、診断ログが返されます。
Version: 5.6.0


GetDiscreteInput

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ディスクリート I/O の設定] ダイアログで設定された情報を返します。

シンタックス: EVGetDiscreteInput()

GetDiscreteInputの入力パラメータ

なし。

GetDiscreteInputの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetDiscreteInput例

[ディスクリート I/O の設定] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetDiscreteInput()

注: 最初の XML タグ内の Count は、ディスクリート入力の数を表しています。各ディスクリート入力には、Line ID (ゼロから始まる) が割り当てられます。

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (43) を続けて返して応答します。最後に、[ディスクリート入力設定] ダイアログで設定された情報が返されます。
Version: 5.6.0


GetDiscreteOutput

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ディスクリート I/O の設定] ダイアログで設定された情報を返します。

シンタックス: EVGetDiscreteOutput()

GetDiscreteOutputの入力パラメータ

なし。

GetDiscreteOutputの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetDiscreteOutput例

[ディスクリート I/O の設定] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetDiscreteOutput()

注: 最初の XML タグ内の Count は、ディスクリート出力の数を表しています。各ディスクリート出力には、Line ID (ゼロから始まる) が割り当てられます。

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (635) を続けて返して応答します。最後に、[ディスクリート I/O の設定] ダイアログで設定された情報が返されます。
Version: 5.6.0


GetDiscreteOutputDelay

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[出力設定] ダイアログで設定された遅延設定を返します。

シンタックス: EVGetDiscreteOutputDelay(LineID,[Model])

GetDiscreteOutputDelayの入力パラメータ

入力 | 説明
LineID | 出力ライン番号。
IOModule | IOModule は、特定の I/O モジュールタイプのディスクリート出力遅延を返すために使用することができるオプションのパラメータです。 0 = 直接接続 I/O または CIO-1350 1 = CIO-1450 および CIO-1460 2 = CIO-1400 3 = CIO-MICRO および CIO-MICRO-CC

GetDiscreteOutputDelayの出力

出力 説明
型 0 = なし

1 = 画像取り込み遅延

2 = トリガ後の時間
遅延
  • Type = 0 の場合、Delay は無視されて 0 にされます。
  • Type = 1 の場合、Delay は、出力ラインが信号パルスを受信した後に出力を遅延させる、画像取り込みまたはトラックパルスの数 (0 ～ 1000) を返します。この値が 0 の場合、In-Sight ビジョンシステムでは、WriteDiscrete 関数を評価するとすぐに出力ラインを更新します。この値が 0 よりも大きい場合、出力ラインは常にパルス出力されます。
  • Type = 2 の場合、Delay は、出力が発信されるまでの時間 (0 ～ 10000 ミリ秒) を返します。

GetDiscreteOutputDelay例

CIO-MICRO I/O モジュールのライン 3 の遅延設定を取得するには、次のコマンドを発行します。EV GetDiscreteOutputDelay(3,3)

In-Sight ビジョンシステムは、ステータスコード (1) と、その後にバイト単位の文字数 (87) を続けて返して応答します。最後に、[タイプ] (トリガ後の時間) と [遅延] (250 ミリ秒) が返されます。
Version: 5.6.0


GetEasyBuilderTag

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

指定したシンボリックタグ名またはセル位置の EasyBuilder タグを返します。

シンタックス: EVGetEasyBuilderTag("Name")

GetEasyBuilderTagの入力パラメータ

入力 | 説明
"Name" | シンボリックタグまたはセルの場所の名前。入力がシンボリックタグの場合は、引用符で囲む必要があります。入力がセルの場所の場合、引用符は任意です。

GetEasyBuilderTagの出力

戻り値

ステータスコード。その後に EasyBuilder タグの名前が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。

GetEasyBuilderTag例

シンボリックタグ名

Acquistion.Frames_Per_Second シンボリックタグに関連付けられた EasyBuilder タグを返すには、次のコマンドを発行します。EV GetEasyBuilderTag("Acquisition.Frames_Per_Second")

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返します。文字数は 34 (単位はバイト) です。最後に、結果が XML フォーマットで返されます。

セルの場所

セル F11 の EasyBuilder タグを返すには、次のコマンドを発行します。EV GetEasyBuilderTag(F11)

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返します。文字数は 34 (単位はバイト) です。最後に、結果が XML フォーマットで返されます。
Version: 5.6.0


GetEIPSingleAttribute

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

In-Sight EtherNet/IP のクラスおよびインスタンス属性を返します。

シンタックス: EVGetEIPSingleAttribute(Image Event,Class,Instance,Attribute)

注: GetEIPSingleAttribute ネイティブモードコマンドは、ファームウェアのバージョンが 3.1.0 ～ 3.2.5 のセンサでのみサポートされています。ファームウェアバージョン 3.3.0 以降のセンサの場合、非明示的接続がタイムアウトになると、センサは非明示的接続とセッションを自動的に削除します。

GetEIPSingleAttributeの入力パラメータ

入力 | 説明
Image Event | スプレッドシートの参照セル A0.画像イベントがトリガされると、スプレッドシートセルが更新されます。
Class | Control and Information Protocol クラスに割り当てる 10 進識別子。
Instance | 参照されるインスタンスの 10 進値。
Attribute | 属性の 10 進識別子。

GetEIPSingleAttributeの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

結果は以下のとおりです。

値 | 0 | タイムアウト状態に遷移
 | 1 | 自動削除

GetEIPSingleAttribute例

In-Sight EtherNet/IP クラスとインスタンス属性を返すには、次のコマンドを発行します。EV GetEIPSingleAttribute(A0,5,0,12)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、値 (1) が返されます。
Version: 5.6.0


GetExternalLightMode

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

In-Sight 70xx ～ 74xx シリーズのビジョンシステムに接続されている外部ストロボデバイスのタイプを返します。

シンタックス: EVGetExternalLightMode()

GetExternalLightModeの入力パラメータ

なし。

GetExternalLightModeの出力

ステータスコード

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。
OutputMode
0 | 無効
1 | PNP (ソース)
2 | NPN (シンク)

GetExternalLightMode例

ビジョンシステムに接続されている外部ストロボデバイスのタイプを返すには、次のコマンドを発行します。EV GetExternalLightMode()

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最終的には、OutputMode (2) が返されます。これは、このビジョンシステムが NPN (シンキング) 外部ストロボデバイスに接続されていることを示します。
Version: 5.6.0


GetFTPSettings

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[FTP の設定] ダイアログで設定された情報を返します。

シンタックス: EVGetFTPSettings()

GetFTPSettingsの入力パラメータ

なし。

GetFTPSettingsの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetFTPSettings例

[FTP の設定] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetFTPSettings()

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (223) を続けて返して応答します。最後に、[FTP の設定] ダイアログで設定された情報が返されます。


GetHostTable

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[In-Sight のホストテーブル] ダイアログに含まれる情報を返します。

シンタックス: EVGetHostTable()

GetHostTableの入力パラメータ

なし。

GetHostTableの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetHostTable例

[In-Sight のホストテーブル] ダイアログに含まれる情報を取得するには、次のコマンドを発行します。EV GetHostTable()

注: 最初の XML タグの Count は、ホストテーブル内のホスト数を表しています。

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (173) を続けて返して応答します。最後に、[In-Sight のホストテーブル] ダイアログで設定された情報が返されます。


GetMSBuffer

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

マシンステータススタック内の 8 つのインデックス付きバッファ (ゼロから始まる) の 1 つに格納されたマシンステータスデータを返します。インデックスが 0 の場合は、現在のマシンステータスが返されます。

シンタックス: EVGetMSBuffer(Index)

注:In-Sight 2000 シリーズのビジョンセンサでは、この拡張ネイティブモードコマンドをサポートしておらず、実行すると -2 を返します。

GetMSBufferの入力パラメータ

入力 | 説明
Index | 値を返すバッファを識別 (0 ～ 7) します。

GetMSBufferの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetMSBuffer例

マシンステータススタック内のバッファ 0 に保存されているマシンステータスデータを取得するには、次のコマンドを発行します。EV GetMSBuffer(0)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (582) を続けて返して応答します。最後に、マシンステータスデータが返されます。

注:
  • <BootTime> に指定される日時は、[SNTP サービスを使用する] チェックボックスがオンで、SNTP サーバが配置されている場合、In-Sight デバイスで電源が入れ直された後にのみ現在日時になります。
  • GetMSBuffer コマンドは、マシンステータスポートにアクセスすることによって EV プレフィックスなしで使用できます。


GetNetwork

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ネットワークの設定] ダイアログで設定された情報を返します。

シンタックス: EVGetNetwork()

GetNetworkの入力パラメータ

なし。

GetNetworkの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetNetwork例

[ネットワークの設定] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetNetwork

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (552) を続けて返して応答します。最後に、[ネットワークの設定] ダイアログで設定された情報が返されます。この例では、センサが DHCP サーバによって起動時に動的に設定されます。UseDHCP 入力が 0 に設定されている場合は、静的 IP 割り当ての設定が使用されます。


GetSerialPort

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[シリアルポートの設定] ダイアログで設定された情報を返します。有効なシリアルポート (1) を指定する必要があります。

シンタックス: EVGetSerialPort(Port)

GetSerialPortの入力パラメータ

入力 | 説明
Port | 返されるシリアルポートのデータを指定します。

GetSerialPortの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetSerialPort例

[シリアルポートの設定] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetSerialPort(1)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (477) を続けて返して応答します。最後に、[シリアルポートの設定] ダイアログで設定された情報が返されます。

注: [モード] を 1 (未使用) に設定すると、GetSerialPort によりモード出力として -1 が返されます。


GetStartup

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[スタートアップ] ダイアログで設定された情報を返します。

シンタックス: EVGetStartup()

GetStartupの入力パラメータ

なし。

GetStartupの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetStartup例

[スタートアップ] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetStartup()

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (79) を続けて返して応答します。最後に、[スタートアップ] ダイアログで設定された情報が返されます。


GetSystemConfig

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

次のパラメータは、GetSystemConfig Evaluate ネイティブモードコマンドと組み合わせて、システム情報を返すために使用されます。

  • アクティブセル制限
  • DHCP タイムアウト
  • Telnet ポート
  • ネットワークサポートリンクモード
  • ネットワーク要求リンクモード
  • 有効なサービス
  • 内部温度

アクティブセル制限

[アクティブセル制限] ダイアログで設定された使用可能なスプレッドシートセルの数を返します。

シンタックス: EVGetSystemConfig("ActiveCellLimit")

入力パラメータ

入力 | 説明
"ActiveCellLimit" | アクティブセルの制限、セル単位(2048 ～ 10400)

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

In-Sight ビジョンシステムまたはビジョンシステムのアクティブセルの制限を取得するには、次のコマンドを発行します。EVGetSystemConfig("ActiveCellsLimit")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、33) で応答します。最後に、現在の制限 (6144)、続いて最小 (2048) と最大 (8192) 範囲のアクティブセルの制限範囲が返されます。

DHCP タイムアウト

[ネットワークの設定] ダイアログで設定された DHCP タイムアウト情報を返します。

シンタックス: EVGetSystemConfig("DHCPTimeout")

入力パラメータ

入力 | 説明
"DHCPTimeout" | In-Sight ビジョンシステムが DHCP 用に設定されているときに、DHCP サーバが有効な IP アドレスで応答するのをビジョンシステムが待つ時間 (5 ～ 180 秒、デフォルト = 60)。DHCP サーバからの応答待ち時間がタイムアウトすると、ネットワーク通信は中断されます。ビジョンシステムは電源を入れ直すまでネットワークへの再接続を試みません。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

[ネットワーク設定] ダイアログで設定された DHCP タイムアウト情報を取得するには、次のコマンドを発行します。EVGetSystemConfig("DHCPTimeout")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、21) で応答します。最後に、DHCP タイムアウト情報 (30) が返されます。

Telnet ポート

[ネットワークの設定] ダイアログで設定された Telnet ポート情報を返します。

シンタックス: EVGetSystemConfig("TelnetPort")

入力パラメータ

入力 | 説明
"TelnetPort" | アクティブな In-Sight ビジョンシステム (通信を待っている TCP/IP サーバ) がリモートデバイス (通信を開始する TCP/IP クライアント) からの要求を待ち受ける Telnet ポート。 有効なポート割り当ては、1 ～ 65535 の未使用の番号ですが、21、68、80、502、1069、1070、1212、2222、44818、および 50000 (In-Sight 通信のために予約済み) を除きます。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

[ネットワーク設定] ダイアログで設定された Telnet ポート情報を取得するには、次のコマンドを発行します。EVGetSystemConfig("TelnetPort")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、23) で応答します。最後に、Telnet ポート情報 (23) が返されます。

ネットワークサポートリンクモード

[ネットワーク設定] ダイアログで設定された、ビジョンシステムによってサポートされる Ethernet リンクスピードとデュープレックスモード (全二重または半二重) を返します。

シンタックス: EVGetSystemConfig("Network.SupportedLinkModes")

入力パラメータ

入力 | 説明
"Network.SupportedLinkModes" | ビジョンシステムによってサポートされる Ethernet リンクスピードとデュープレックスモード。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

結果

結果 | 説明
0 | オートネゴシエーション
100 | 10 Mbps 半二重
101 | 10 Mbps 全二重
102 | 100 Mbps 半二重
103 | 100 Mbps 全二重
104 | 1000 Mbps 全二重

注:[1000 Mbps 全二重] オプションは、1000 Mbps イーサネット速度をサポートするビジョンシステムだけで使用できます。In-Sight 5600 シリーズのビジョンシステムの場合、128MB 以上の不揮発性フラッシュメモリを搭載したモデルだけで使用できます。

例

ビジョンシステムでサポートされるリンクスピードとデュープレックスモードを取得するには、次のコマンドを発行します。EVGetSystemConfig("Network.SupportedLinkModes")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、36) で応答します。最後に、サポートされる Ethernet リンクスピードとデュープレックスモードが返されます。

ネットワーク要求リンクモード

[ネットワーク設定] ダイアログで設定された、ビジョンシステムの現在の Ethernet リンクスピードとデュープレックスモード (全二重または半二重) を返します。

シンタックス: EVGetSystemConfig("Network.RequestedLinkMode")

入力パラメータ

入力 | 説明
"Network.RequestedLinkMode" | ビジョンシステムの現在の Ethernet リンクスピードとデュープレックスモード。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

結果

結果 | 説明
0 | オートネゴシエーション*
100 | 10 Mbps 半二重
101 | 10 Mbps 全二重
102 | 100 Mbps 半二重
103 | 100 Mbps 全二重
104 | 1000 Mbps 全二重
* はデフォルト値を示します。

注:[1000 Mbps 全二重] オプションは、1000 Mbps イーサネット速度をサポートするビジョンシステムだけで使用できます。In-Sight 5600 シリーズのビジョンシステムの場合、128MB 以上の不揮発性フラッシュメモリを搭載したモデルだけで使用できます。

例

ビジョンシステムの現在のリンクスピードを取得するには、次のコマンドを発行します。EVGetSystemConfig("Network.RequestedLinkMode")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、現在のリンクスピードが返されます。

有効なサービス

[ネットワークの設定] ダイアログで設定されたプロトコルサービス情報を返します。

注: EtherNet/IP サービスと PROFINET サービスは相互に排他的であるため、両方のサービスを同時に有効にすることはできません。

シンタックス: EVGetSystemConfig("ServicesEnabled")

入力パラメータ

入力 | 説明
"ServicesEnabled" | ビジョンシステムで現在有効なサービス。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | アクティブジョブが保存されていないので、コマンドを実行できませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

結果は以下のとおりです。

戻り値は 10 進数で、バイナリ値から変換されます。

サービス | バイナリ | 10 進値
iQSS | 01000000 | 64
POWERLINK 注: ファームウェアバージョン 4.x.x を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムのみでサポートされます。 | 00100000 | 32
SLMP スキャナ | 00010000 | 16
Precision Time Protocol (IEEE 1588 PTP) | 00001000 | 8
PROFINET | 00000100 | 4
EtherNet/IP | 00000010 | 2
Modbus Server | 00000001 | 1
なし | 00000000 | 0

複数のサービスが有効になっている場合は、返された 10 進数値をバイナリ値に変換し、有効なサービスを判別できます。 Closed 例

次のコマンドを発行します。EVGetSystemConfig("ServicesEnabled")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効なサービス (5) が返されます。有効なサービスを判別するには、10 進数値をバイナリ値に変換します。

5 = 101

バイナリ値に基づいて、ビジョンシステムで Modbus および ProfiNET サービスが有効化されていることが分かります。

サービス | PROFINET | EtherNet/IP | Modbus
バイナリ | 1 | 0 | 1

例

[ネットワーク設定] ダイアログで設定されたプロトコルサービス情報を取得するには、次のコマンドを発行します。EV GetSystemConfig("ServicesEnabled")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効なサービス (2) が返され、EtherNet/IP サービスが有効化されていることが示されます。

内部温度

In-Sight 76xx ～ 79xx シリーズと In-Sight 8000　シリーズのビジョンシステムの内部温度 (摂氏) を返します。

シンタックス: EVGetSystemConfig("Internal.Temperature")

入力パラメータ

入力 | 説明
"Internal.Temperature" | ビジョンシステムの内部温度 (摂氏)。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

結果

ビジョンシステムの内部温度 (摂氏) を返します。

例

ビジョンシステムの現在の内部温度を取得するには、次のコマンドを発行します。EVGetSystemConfig("Internal.Temperature")

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、23) で応答します。最後に、現在の温度 (摂氏) が返されます。
Version: 5.6.0


GetUserList

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ユーザリスト] ダイアログで設定された情報を返します。

シンタックス: EVGetUserList()

GetUserListの入力パラメータ

なし。

GetUserListの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

GetUserList結果

Name ユーザ名を返します。

Access

ユーザのアクセスレベルを返します。

0 | フル
1 | プロテクト
2 | ロック
View

ユーザがログオンしたときに、カスタムビューが表示されるかどうかを返します。

0 | カスタム
1 | 標準 (スプレッドシートビュー、またはEasyBuilder ビューが表示されます)。

Read

ユーザの FTP 読み取り権限の有無を返します。

0 | 無
1 | 有

Write

ユーザの FTP 書き込み権限の有無を返します。

0 | 無
1 | 有

SaveJobOnline

ユーザのオンライン中のジョブ保存の可否を返します。

0 | 無効
1 | 有効

GetUserList例

[ユーザリスト] ダイアログで設定された情報を取得するには、次のコマンドを発行します。EV GetUserList()

注: 最初の XML タグの Count は、ユーザリスト内のユーザ数を表しています。

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (568) を続けて返して応答します。最後に、[ユーザリスト] ダイアログで設定された情報が返されます。

関連項目

[ユーザリスト] ダイアログ


SetCellName

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

指定したセルのシンボリックタグ名を設定し、必要に応じてシンボリックタグを OPC チャネル経由で In-Sight OPC サーバに送信できます。または、監査メッセージサーバへの監査メッセージを生成します。

シンタックス: EV SetCellName(Cell,"Name",[Mode])

SetCellNameの入力パラメータ

入力 | 説明
Cell | セル参照 (例: A4)。
"Name" | シンボリックタグ名として使用するテキスト文字列。名前は引用符で囲む必要があります。
Mode | モードの入力は省略できます。 0 = 出力を無効にします。 2 = OPC チャネル経由でシンボリックタグを送信します。 8 = シンボリックタグを使用して監査メッセージサーバへの監査メッセージを生成します。 10 = OPC チャネル経由でシンボリックタグを送信し、シンボリックタグを使用して監査メッセージサーバへの監査メッセージを生成します。 注: 監査メッセージを生成するには、[監査メッセージを有効にする] チェックボックスをオンにする必要があります。

SetCellNameの出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetCellName例

シンボリックタグ名 "Width" をセル B60 に割り当てるには、次のコマンドを発行します。EV SetCellName(B60,"Width")

In-Sight センサは、コマンドが正常に実行されたことを示す 1 を返します。文字数は 18 (単位はバイト) です。最後に、結果が XML フォーマットで返されます。
Version: 5.6.0


SetCellValue

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

特定のセルの値に EasyBuilder タグを追加します。

注: In-Sight 2000 シリーズのビジョンセンサは、この拡張ネイティブモードコマンドをサポートしておらず、-2 を返します。

シンタックス: EV SetCellValue("Name",Value,[Mode])

SetCellValueの入力パラメータ

入力 | 説明
"Name" | そのセル用に使用されている EasyBuilder タグ名。名前は引用符で囲む必要があります。
Value | セルで使用される、整数、浮動小数点値、テキスト文字列などの値。この関数は、"Name" の入力で指定されているセルが EditInt、EditFloat または EditString 関数ではない場合、または値のデータ型が対応していない場合には、#ERR を返します。
Mode | モードの入力は省略できます。 0 = 出力を無効にします。名前付き値は、OPC データのアクセスと交換では有効化されません。 1 = セルの値が変更されるときに有効化される出力。 2 = 出力を有効にします。名前付き値は、OPC データのアクセスと交換で有効化されます。

SetCellValueの出力

戻り値

ステータスコード。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-1 | セル ID が無効です。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetCellValue例

距離寸法測定ツールの [Minimum Distance (最小距離寸法)] を設定するには、EasyBuilder タグの名前に「Distance_1.Minimum」を付加してセル A116 に格納し、次のコマンドを発行します。EV SetCellValue("Distance_1.Minimum",62)

In-Sight センサは、コマンドが正常に実行されたことを示す 1 で応答します。コマンドが正常に実行されたことの 2 番目の確認として、文字数 (バイト単位) と <Float>1</Float> が続きます。
Version: 5.6.0


SetDeEnergizeOutputs

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ディスクリート I/O の設定] ダイアログの [オフライン時に出力の電源を切る] 設定を行います。

注:[オフライン中は出力を OFF にする] チェックボックスが ON で、CIO-MICRO または CIO-MICRO-CC I/O の出力ラインが [ライフライン] 信号タイプに設定されている場合、接続中のビジョンシステムがオフラインでもラインは HIGH となります。

シンタックス: EVSetDeEnergizeOutputs(DeEnergizeOutputs,WriteProcSet)

SetDeEnergizeOutputsの入力パラメータ

入力 | 説明
DeEnergizeOutputs | 0= 無効* 1 = 有効
WriteProcSet | 0* = 設定は、proc.set ファイルに保存されず、In-Sight センサの電源を入れ直すと失われます。 1 = 設定は、proc.set ファイルに保存され、In-Sight ビジョンシステムの電源を入れ直しても保持されます。
* はデフォルト値を示します。

SetDeEnergizeOutputsの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetDeEnergizeOutputs例

オフラインのときに出力の電源を切るようにセンサを設定するには、次のコマンドを発行します。EV SetDeEnergizeOutputs(1,1)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、値 (1) が返されます。
Version: 5.6.0


SetDiscreteInput

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ディスクリート I/O の設定] ダイアログで入力の設定を行います。

シンタックス: EVSetDiscreteInput(LineID,"Name",Type,Signal)

注:
  • このコマンドを実行する際には、In-Sight システムはオフラインになっている必要があります。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。

  • Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetDiscreteInputの入力パラメータ

入力 | 説明
LineID | In-Sight 2000 シリーズ: (0) ブレークアウトケーブルに接続されている場合。
In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight Micro 8000 シリーズ: (0 ～ 7) サポートされている I/O モジュールに接続されている場合。

In-Sight 70xx ～ 74xx シリーズ:

  • (1 ～ 3)、直接接続 I/O に接続されている場合。

  • (0 ～ 7 および 9 ～ 11)、サポートされている I/O モジュールに接続されている場合。

In-Sight 76xx ～ 79xx シリーズ:

  • (0 ～ 3)、直接接続 I/O に接続されている場合。
  • (1 ～ 7)、CIO-1400 I/O モジュールに接続されている場合。
  • (0 ～ 7)、CIO-MICRO I/O モジュールに接続されている場合。
"Name"

入力ラインの名前。

注: 入力する "Name" は、引用符で囲む必要があります。
Type | 0 = ユーザデータ*

1 = イベントトリガ (1= In-Sight 2000 シリーズのビジョンセンサを使用する場合にカウンタをリセットします)
2 = ジョブ ID 番号 (In-Sight 2000 ではサポートされていません)
3 = オンライン/オフライン
4 = 画像取り込みトリガ (In-Sight 2000 シリーズセンサおよび CIO-1400 ではサポートされていません)
5 = ジョブを開く (In-Sight 2000 ではサポートされていません)

8 = シリアル受信 (直接接続 I/O のみ。LineID = 1 の場合のみ有効)

注:
  • [シリアル受信] は、In-Sight Explorer 4.7.1 以上が搭載されている In-Sight 70xx ～ 74xx シリーズビジョンシステムに接続し、In-Sight 4.7.1 以上のファームウェアを使用している場合のみ使用可能です。
  • SetDiscreteInput コマンドが発行され、入力ライン 1 がシリアル受信に設定された場合、ビジョンシステムは出力ライン 1 がシリアル送信に設定されているかどうかを判別します。設定されていない場合、入力ライン 1 は一時的にこのラインのデフォルトの入力タイプにリセットされます。SetDiscreteOutput コマンドが発行され、出力ライン 1 がシリアル送信に設定された場合、入力ライン 1 は自動的にシリアル受信に設定されます。

9 = ジョブ変更 (パルス)

注: ジョブ変更 (パルス) は、In-Sight 5.2.3 以降のファームウェアが実行されている In-Sight 2000 シリーズのビジョンセンサに接続されている場合にのみ使用できます。
Signal

0 = 立ち上がりエッジ*

1 = 立ち下がりエッジ

2 = 両方のエッジ
* はデフォルト値を示します。

注: [オンライン / オフライン]、[画像取り込みトリガ]、および [ジョブを開くスイッチ] 入力タイプを、同時に複数の入力ラインで使用することはできません。

SetDiscreteInputの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetDiscreteInput例

以下の設定を行うには

LineID: 4

"Name": Line 4

Type: ジョブ ID 番号

Signal: 立ち上がりエッジ

次のコマンドを発行します。 EV SetDiscreteInput(4,"LINE4",2,0)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、結果が XML フォーマットで返されます。
Version: 5.6.0


SetDiscreteOutput

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ディスクリート I/O の設定] ダイアログおよび [出力の詳細設定] ダイアログの設定を行います。

シンタックス: EVSetDiscreteOutput(LineID,"Name",Type,Pulse,PulseLen,Delay)

注:
  • このコマンドを実行する際には、In-Sight ビジョンシステムはオフラインになっている必要があります。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight ビジョンシステムを CIO-1400 または CIO-1450 I/O モジュールとともに使用する場合、シリアルポート経由でディスクリート出力設定を変更するために、SetDiscreteOutput または SetDiscreteOutputDelay コマンドを使用しないでください。使用した場合、ビジョンシステムが応答しなくなる場合があります。変更を行う場合、または Telnet 経由でコマンドを送信するには、[ディスクリート I/O 設定] ダイアログと [出力詳細] ダイアログを使用します。

  • Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetDiscreteOutputの入力パラメータ

入力 | 説明
LineID

In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight Micro 8000 シリーズ:

  • (0、1、4、5)、直接接続 I/O に接続されている場合。
  • (0 ～ 11) サポートされる I/O モジュールに接続されている場合。

In-Sight 70xx ～ 74xx シリーズ:

  • (0、1、4、5)、直接接続 I/O に接続されている場合。
  • (0 ～ 13) サポートされる I/O モジュールに接続されている場合。

In-Sight 76xx ～ 79xx シリーズ:

  • (0 ～ 5)、直接接続 I/O に接続されている場合。
  • (0 ～ 9) サポートされる I/O モジュールに接続されている場合。
"Name"

出力ラインの名前。

注: 入力する "Name" は、引用符で囲む必要があります。
Type | 0 = ユーザ用*

1 = 高
2 = 低
3 = 画像取り込み開始
4 = 画像取り込み終了
5 = ジョブ完了
6 = システムビジー
7 = ジョブを開く - 完了
8 = ジョブを開く - エラー
9 = ERR: 画像取り込み失敗
10 = ERR: トラックオーバラン
11 = ERR: トラックキューフル
12 = オンライン/オフライン

13 = ストロボ

  • In-Sight Micro 1000 シリーズ: LineID = 1 (直接接続 I/O では HSOUT 1) または LineID = 9 (CIO-MICRO、CIO-MICRO-CC、および CIO-WENET では HSOUT 1) の場合のみ有効。
  • In-Sight 5000 シリーズ: LineID = 1 (直接接続 I/O / CIO-1350 または CIO-1400 では HSOUT 1) または LineID = 9 (CIO-1450、CIO-1460、CIO-MICRO または CIO-MICRO-CC では HSOUT 1) の場合のみ有効。
  • In-Sight 70xx ～ 74xx シリーズ: LineID = 0 (直接接続 I/O では HSOUT 0) または LineID = 8 (CIO-MICRO または CIO-MICRO-CC では HSOUT 0) の場合のみ有効。
  • In-Sight 76xx ～ 79xx シリーズ: LineID = 1 (直接接続 I/O または CIO-1400 では HSOUT 1) または LineID = 9 (CIO-MICRO では HSOUT 1) の場合のみ有効。
  • In-Sight 8000 シリーズ: LineID = 1 (直接接続 I/O は HSOUT 1) または LineID = 9 (CIO-MICRO では HSOUT 1) の場合のみ有効。
14 = I/O モジュールスタンバイ (CIO-1450 および CIO-1460 のみ。LineID = 0 ～ 7 の場合のみ有効)
15 = 照明制御 (CIO-1460 のみ。LineID = 9 の場合のみ有効)
17 = ライフライン (CIO-MICRO および CIO-MICRO-CC のみ)
18 = Waveform

20 = シリアル送信 (直接接続 I/O のみ。LineID = 1 の場合のみ有効)

注:

  • [シリアル送信] は、In-Sight Explorer 4.7.1 以上が搭載されている In-Sight 70xx ～ 74xx シリーズビジョンシステムに接続し、In-Sight 4.7.1 以上のファームウェアを使用している場合のみ使用可能です。
  • SetDiscreteOutput コマンドが発行され、出力ライン 1 がシリアル送信に設定された場合、ビジョンシステムは入力ライン 1 がシリアル受信に設定されているかどうかを判別します。設定されていない場合、出力ライン 1 は一時的にこのラインのデフォルトの出力タイプにリセットされます。SetDiscreteInput コマンドが発行され、入力ライン 1 がシリアル受信に設定された場合、出力ライン 1 は自動的にシリアル送信に設定されます。
24 = ジョブの PASS/FAIL セル
Pulse

0 = レベル出力

注: Type が 13 (Strobe) に設定され、Pulse が 0 に設定されている場合、[ストロボ/照明制御のトリガ] 設定は [立ち上がりエッジ] に設定されます。

1 = パルス出力

注: Type が 13 (Strobe) に設定され、Pulse が 1 に設定されている場合、[ストロボ/照明制御のトリガ] 設定は [立ち下がりエッジ] に設定されます。
PulseLen

出力パルスの持続時間。

ビジョンシステム/ビジョンセンサ | 最小パルス幅 | 最大パルス幅 | デフォルトのパルス幅
汎用出力1 | 高速出力
In-Sight Micro 1000 シリーズ (1402、1412、1500 を除く) | 10 ミリ秒 | 10 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
In-Sight Micro 1402、1412、1500 | 10 ミリ秒 | 1 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
In-Sight 5000 シリーズ | 10 ミリ秒 | 10 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
In-Sight 70xx ～ 74xx シリーズ | 10 ミリ秒 | 1 ミリ秒 | 1000 ミリ秒 | 10 ミリ秒
In-Sight 76xx ～ 79xx シリーズ | 10 ミリ秒 | 1 ミリ秒2 | 1000 ミリ秒 | 10 ミリ秒
In-Sight 8000 シリーズ | 10 ミリ秒 | 1 ミリ秒2 | 1000 ミリ秒 | 10 ミリ秒

1CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用しているときに、汎用出力の最小パルス幅は [I/O モジュールの設定] ダイアログの [更新間隔] 設定によって制限されます。例えば、[I/O モジュールの設定] ダイアログの [更新間隔] が 20ms に設定されている場合、最小パルス幅は 30ms 以下に設定することはできません。

21 ミリ秒の最小パルス幅は、In-Sight ファームウェアバージョン 5.5.0 以上を使用している場合にだけサポートされます。より前のバージョンのファームウェアを使用している場合、最小パルス幅は 10 ミリ秒です。
Delay

(0 ～ 1000)
* はデフォルト値を示します。

SetDiscreteOutputの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetDiscreteOutput例

例 1: [ジョブを開く - 完了] タイプ設定

以下の設定を行うには

LineID: 3

"Name": "LINE3"

Type: ジョブを開く - 完了

Pulse: レベル出力

PulseLen: 250 ms

Delay: 50

次のコマンドを発行します。EV SetDiscreteOutput(3,"LINE3",7,0,250,50)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、結果が XML フォーマットで返されます。

例 2: [ストロボタイプ] 設定

[ストロボタイプ] の設定を行うには:

LineID: 1

"Name": "LINE1"

Type: ストロボ

[ストロボ/照明制御のトリガ]: 立ち上がりエッジ

PulseLen: 10 ms

Delay: 50

次のコマンドを発行します。EV SetDiscreteOutput(1,"LINE1",13,0,10,50)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、結果が XML フォーマットで返されます。

注: [ストロボ開始位置] を設定するには、SetSystemConfig ネイティブモードコマンドを使用します。
Version: 5.6.0


SetDiscreteOutputDelay

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[出力詳細] ダイアログでの遅延設定を行います。

シンタックス: EVSetDiscreteOutputDelay(LineID,Type,[Delay],[[WriteProcSet],[IOModule]])

注:

  • SetDiscreteOutputDelay コマンドの後に SetDiscreteOutput コマンドが発行されると、SetDiscreteOutputDelay 設定が上書きされます。

  • In-Sight ビジョンシステムを CIO-1400 または CIO-1450 I/O モジュールとともに使用する場合、シリアルポート経由でディスクリート出力設定を変更するために、SetDiscreteOutput または SetDiscreteOutputDelay コマンドを使用しないでください。使用した場合、ビジョンシステムが応答しなくなる場合があります。変更を行う場合、または Telnet 経由でコマンドを送信するには、[ディスクリート I/O 設定] ダイアログと [出力詳細] ダイアログを使用します。

SetDiscreteOutputDelayの入力パラメータ

入力 | 説明
LineID | 変更される出力ライン番号。
Type 0 = なし

1 = 画像取り込み遅延

2 = トリガ後の時間
Delay
  • Type = 0 の場合、Delay は無視されて 0 にされます。
  • Type = 1 の場合、Delay は、出力ラインが信号パルスを受信した後に出力を遅延させる、画像取り込みまたはトラックパルスの数 (0 ～ 1000) です。この値が 0 の場合、In-Sight ビジョンシステムでは、WriteDiscrete 関数を評価するとすぐに出力ラインを更新します。この値が 0 よりも大きい場合、出力ラインは常にパルス出力されます。
  • Type = 2 の場合、Delay は、出力が発信されるまでの待機時間 (0 ～ 10000 ミリ秒) です。

WriteProcSet

WriteProcSet はオプションのパラメータです。

0 = 設定は、proc.set ファイルに保存されず、ビジョンシステムの電源を入れ直すと失われます。

1 = 設定は、proc.set ファイルに保存され、ビジョンシステムの電源を入れ直しても保持されます。

IOModule

IOModule は、特定の I/O モジュールタイプのディスクリート出力遅延を設定するために使用することができるオプションのサブパラメータです。

0 = 直接接続 I/O / CIO-1350

1 = CIO-1450 および CIO-1460

2 = CIO-1400

3 = CIO-MICRO および CIO-MICRO-CC

SetDiscreteOutputDelayの出力

戻り値

ステータスコード。その後にバイト単位の文字数が続きます。ステータスコードは次のとおりです。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetDiscreteOutputDelay例

以下の設定を行うには

Line ID: 3

Type: トリガ後の時間

Delay: 250 ms

WriteProcSet: 1

IOModule: CIO-MICRO

次のコマンドを発行します。EV SetDiscreteOutputDelay(3,2,250,1,3)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、結果が XML フォーマットで返されます。
Version: 5.6.0


SetEditRegion

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

EditRegion 関数が格納されるセルの設定を行います。セルには EditRegion 関数がすでに格納されている必要があります。SetEditRegion によって作成されることはありません。

シンタックス: EVSetEditRegion(Cell,Row,Column,High,Wide,Angle,Curve)

SetEditRegionの入力パラメータ

入力

説明

Cell

列 | (A ～ Z) 設定するセル値の列文字。
行 | (0 ～ 599) 設定するセル値の行番号。

Row

フィクスチャ座標の原点の行オフセット。

Column

フィクスチャ座標の原点の列オフセット。

High

領域の X 軸に沿った寸法。

注: この値を負の数にすることはできません。

Wide

領域の Y 軸に沿った寸法。

注: この値を負の数にすることはできません。

Angle

フィクスチャ座標での角度。

Curve

領域の X 軸と反対側の境界線との間の角度変位。

SetEditRegionの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetEditRegion例

  1. EditRegion 関数をデフォルト設定でセル A3 に挿入します。セル A3 には、次が格納されていると仮定します。

A3 = EditRegion(0,0,0,1,1,1,1,"",0)

対応する結果テーブルと一緒に、EditRegion [image] コントロールが右側の隣接セルに作成されます。

  2. Telnet クライアントを使用して、次のコマンドを発行します。EV SetEditRegion(A3,100,100,250,250,0,0)

EditRegion の結果テーブルが更新され、SetEditRegion の入力値が反映されます。


SetEIPSingleAttribute

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

In-Sight EtherNet/IP のクラスおよびインスタンス属性を設定します。

シンタックス: EVSetEIPSingleAttribute(Class,Instance,Attribute,Value)

注: SetEIPSingleAttribute ネイティブモードコマンドは、ファームウェアのバージョンが 3.1.0 ～ 3.2.5 のセンサでのみサポートされています。ファームウェアバージョン 3.3.0 以降のセンサの場合、非明示的接続がタイムアウトになると、センサは非明示的接続とセッションを自動的に削除します。

SetEIPSingleAttributeの入力パラメータ

入力 | 説明
Class | Control and Information Protocol クラスに割り当てられる識別子。
Instance | 参照されるインスタンスの値。 注: クラスの属性を変更する場合は、Instance を 0 にする必要があります。
Attribute | 変更される属性の識別子。
Value | 属性に割り当てる値。

サポートされるパラメータ:

Class | Instance | Attribute | Value | 説明
5 | 0 | 12 | 0 = タイムアウト状態に遷移* 1 = 自動削除 | Watchdog_timeout_action: すべての新しい接続のクラスウォッチドッグタイムアウト時の動作を定義します。
* はデフォルト値を示します。

SetEIPSingleAttributeの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetEIPSingleAttribute例

[EIP I/O ウォッチドッグタイムアウト時の動作] を [自動削除] に設定するには、次のコマンドを発行します。EV SetEIPSingleAttribute(5,0,12,1)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、値 (1) が返されます。


SetExternalLightMode

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

In-Sight 70xx ～ 74xx シリーズのビジョンシステムに接続されている外部ストロボデバイスのタイプを指定します。

シンタックス: EVSetExternalLightMode(OutputMode)

SetExternalLightModeの入力パラメータ

入力 | 説明
OutputMode | 0 = 無効 1 = PNP (ソーシング)* 2 = NPN (シンキング)
WriteProcSet | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。*
* はデフォルト値を示します。

SetExternalLightModeの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetExternalLightMode例

NPN (シンキング) 外部ストロボデバイスがビジョンシステムに接続されていることを指定し、設定を proc.set ファイルに保存するには、次のコマンドを発行します。EV SetExternalLightMode(2,1)

ビジョンシステムは、コマンドが正常に実行されたことを示すステータスコード (1) に続けて、文字数 (18) をバイト単位で返します。最後に、浮動小数点値 (0) が返されます。
Version: 5.6.0


SetFavorHostTable

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[In-Sight のホストテーブル] の [ホストテーブルを DNS より優先する] オプションを有効または無効にします。

シンタックス: EVSetFavorHostTable(FavorHostTable)

注:Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetFavorHostTableの入力パラメータ

入力 | 説明
FavorHostTable | 0 = 無効* 1 = 有効
* はデフォルト値を示します。

SetFavorHostTableの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetFavorHostTable例

[ホストテーブルを DNS より優先する] オプションを有効にするには、次のコマンドを発行します。EV SetFavorHostTable(1)

SetFavorHostTable コマンドを発行すると、In-Sight センサはステータスコード (1) で応答し、その後にバイト単位の文字数 (18) が続きます。最後に、結果が XML フォーマットで返されます。


SetFTPSettings

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[FTP の設定] ダイアログの設定を行います。

シンタックス: EVSetFTPSettings(IdleTimeout,ReadTimeout,ConnectionRetry,LocalPort,RemotePort,Passive)

注:Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetFTPSettingsの入力パラメータ

入力 | 説明
IdleTimeout | (0 ～ 10000)、120*
ReadTimeout | (0 ～ 10000)、120*
ConnectionRetry | (1 ～ 10)、1*
LocalPort | (1 ～ 65535)、21*
RemotePort | (1 ～ 65535)、21*
Passive | 0 = 無効* 1 = 有効
* はデフォルト値を示します。

SetFTPSettingsの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetFTPSettings例

以下の設定を行うには

IdleTimeout: 180

ReadTimeout: 180

ConnectionRetry: 1

LocalPort: 21

RemotePort: 21

Passive: 0

次のコマンドを発行します。 EV SetFTPSettings(180,180,1,21,21,0)

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、結果が XML フォーマットで返されます。


SetHostTable

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[In-Sight のホストテーブル] ダイアログの設定を行います。

シンタックス: EVSetHostTable(HostID,"Name","IPAddress")

注:Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetHostTableの入力パラメータ

入力 | 説明
HostID | (0 ～ 31) テーブルの最初のホスト名 = 0、 テーブルの 2 番目のホスト名 = 1、 ... 順に最大 31 まで。
"Name" | In-Sight センサのホスト名。
"IPAddress" | In-Sight センサの IP アドレス。

SetHostTableの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetHostTable例

例 1: ホストテーブルエントリを追加する

例 2: ホストテーブルエントリを編集する

例 1: ホストテーブルエントリを追加する

ホスト名「PRODUCTION1」、IP アドレス「192.168.1.1」のセンサをホストテーブルの最初のエントリとして追加するには、次のコマンドを発行します。EV SetHostTable(0,"PRODUCTION1","192.168.1.1")

ホスト名「PRODUCTION2」、IP アドレス「192.168.1.3」のセンサをホストテーブルの 2 番めのエントリとして追加するには、次のコマンドを発行します。EV SetHostTable(1,"PRODUCTION2","192.168.1.3")。

例 2: ホストテーブルエントリを編集する

2 番目のホストテーブルエントリの IP アドレスを編集するには、次のコマンドを発行します。EV SetHostTable(1,"PRODUCTION2","192.168.1.2")


SetNetwork

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[ネットワークの設定] ダイアログの設定を行います。

シンタックス: EVSetNetwork(UseDHCP,"HostName","IPAddress","SubnetMask","DefaultGateway","DNSServer","DomainName")

注:Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetNetworkの入力パラメータ

入力 | 説明
UseDHCP | 0 = 無効 1 = 有効
"HostName" | In-Sight センサのホスト名。
"IPAddress" | In-Sight センサの IP アドレス。
"SubnetMask" | The In-Sight センサのサブネットマスク。
"DefaultGateway" | In-Sight センサのデフォルトゲートウェイ。
"DNSServer" | ゲートウェイホストの IP アドレス。
"DomainName" | In-Sight センサのネットワークドメイン。

注: IPAddress、SubnetMask、DefaultGateway、DNSServer、および DomainName パラメータは、GetNetwork コマンドからの戻り値に示されているように、現在のフィールドではなく固定フィールドを変更します。

SetNetworkの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetNetwork例

以下の設定を行うには

UseDHCP: 0

"HostName": is5100_010203

"IPAddress": 192.168.0.1

"SubnetMask": 255.255.255.0

"DefaultGateway": 192.168.0.254

"DNSServer": 192.168.0.2

"DomainName": yourdomain.com

次のコマンドを発行します。 EV SetNetwork(0,"is5100_010203","192.168.0.1","255.255.255.0","192.168.0.254","192.168.0.2","yourdomain.com")

In-Sight センサは、ステータスコード (1) と、その後にバイト単位の文字数 (18) を続けて返して応答します。最後に、結果が XML フォーマットで返されます。


SetSerialPort

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[シリアルポートの設定] ダイアログの設定を行います。

シンタックス: EVSetSerialPort(SerialPortNum,Mode,BaudRate,DataBits,StopBits,Parity,Handshake,InputPacketSize,OutputPacketSize,
InputTerminator,OutputTerminator,FixedInputMode,FixedInputLength,DeviceNetTrigger)

注:
  • In-Sight システムはオフラインになっている必要があります。
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。
  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。

  • Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetSerialPortの入力パラメータ

入力 | 説明
SerialPortNum | 1
Mode | 1 = 未使用 (閉じた状態) 6 = テキスト 7 = ネイティブ* 8 = DeviceNet 9 = Motoman 10 = Kuka
BaudRate | 1200 2400 4800 9600 19200 38400 57600 115200*
DataBits | 4 = 7 データビット 8 = 8 データビット
StopBits | 1 = 1 ストップビット* 4 = 2 ストップビット*
Parity | 256 = なし* 512 = 奇数 1024 = 偶数
Handshake | 0 = なし* 1 = ハードウェア 2 = Xon/Xoff
InputPacketSize (DeviceNet のみ) | (1 ～ 255)、1*
OutputPacketSize (DeviceNet のみ) | (1 ～ 255)、1*
InputTerminator (テキストおよびネイティブのみ) | (1 ～ 255)、13*
OutputTerminator (テキスおよびネイティブのみ) | -1 = CRLF 0 = 終端記号なし (1 ～ 255)、13*
FixedInputMode (テキストおよびネイティブのみ) | 0= 無効* 1 = 有効
FixedInputLength (テキストおよびネイティブのみ) | (1 ～ 255)、1*
DeviceNetTrigger (DeviceNet のみ) | 0 = 無効 1 = 有効*
* はデフォルト値を示します。

SetSerialPortの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetSerialPort例

以下の設定を行うには

SerialPortNum: 1

Mode: 7

BaudRate: 115200

DataBits: 8

StopBits: 1

Parity: 256

Handshake: 0

InputPacketSize: 0

OutputPacketSize: 0

InputTerminator: 13

OutputTerminator: 13

FixedInputMode: 0

FixedInputLength: 0

DeviceNetTrigger: 1

次のコマンドを発行します。EV SetSerialPort(1,7,115200,8,1,256,0,0,0,13,13,0,0,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、結果が XML フォーマットで返されます。
Version: 5.6.0


SetStartup

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

[スタートアップ] ダイアログの設定を行います。

シンタックス: EVSetStartup("JobName",Online)

注:Store Settings (TS) ネイティブモードコマンドを使用して proc.set ファイルに変更を保存します。proc.set ファイルに保存しないと、In-Sight ビジョンシステムの電源を入れ直したときに変更が失われます。

SetStartupの入力パラメータ

入力 | 説明
"JobName" | 起動時に自動的にロードするジョブの名前。
Online | 0= オフライン開始* 1= オンライン開始
* はデフォルト値を示します。

SetStartupの出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

SetStartup例

起動時にジョブ「Sorting.job」をロードして、オンラインモードで起動するようにセンサを設定するには、次のコマンドを発行します。EV SetStartup("Sorting.job",1)

In-Sight センサは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、結果が XML フォーマットで返されます。


SetSystemConfig

ネイティブモードの拡張コマンド - Evaluate

In-Sight 通信リファレンス

次のパラメータは、SetSystemConfig Evaluate ネイティブモードコマンドと組み合わせて、システムパラメータを設定するために使用されます。

注: 引用符で囲まれている入力は、In-Sight ビジョンシステムに送信する際に引用符で囲む必要があります。

  • アクティブセル制限
  • DHCP タイムアウト
  • Telnet ポート
  • ネットワーク要求リンクモード
  • ライブ画像
  • オンライン画像
  • 有効なサービス
  • 監査有効化設定
  • 監査IP設定
  • トリガタイムスタンプ
  • 画像バッファを増加
  • ExtractBlobs メモリ割り当ての調整
  • デフォルトのフォーカス位置
  • 開始ストロボ位置
  • PulseJobChangeTiming

アクティブセル制限

[アクティブセル制限] ダイアログ内の使用可能なスプレッドシートセルの数を設定します。

シンタックス: EVSetSystemConfig("ActiveCellLimit",Limit,WriteProcSet)

入力パラメータ

入力 | 説明
"ActiveCellLimit" | [アクティブセル制限] ダイアログの設定を参照します。
制限 (Limit) | アクティブセルの制限、セル単位(2048 ～ 10400)、6144* 注: In-Sight 5000 ビジョンシステムのアクティブセルの制限は 4,096 セルで、変更できません。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

アクティブセル制限を 8,192 に指定するには、次のコマンドを発行します。EV SetSystemConfig("ActiveCellsLimit",8192,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、制限が設定されたことを示す 1、または制限が設定されていないことを示す 0 のどちらかの結果コードが返されます。変更を有効にするには、In-Sight ビジョンシステムの電源を入れ直す必要があります。

DHCP タイムアウト

[ネットワークの設定] ダイアログの [DHCP タイムアウト] の設定を行います。

シンタックス: EVSetSystemConfig("DHCPTimeout",Timeout,WriteProcSet)

入力パラメータ

入力 | 説明
"DHCPTimeout" | [DHCP タイムアウト] 設定を参照します。
タイムアウト | (5 ～ 180)、60*
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

30 秒の DHCP タイムアウトを指定するには、次のコマンドを発行します。EVSetSystemConfig("DHCPTimeout",30,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[DHCP タイムアウト] 設定 (30) が返されます。

Telnet ポート

[ネットワークの設定] ダイアログの [Telnet ポート] の設定を行います。

シンタックス: EVSetSystemConfig("TelnetPort",Port,WriteProcSet)

入力パラメータ

入力 | 説明
"TelnetPort" | [Telnet ポート] 設定を参照します。
ポート (Port) | (1 ～ 65535)、23*
プロシージャセットの書き込み (WriteProcSet) | 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。 |

注:

  • 有効なポート割り当ては、1 ～ 65535 の未使用の番号ですが、21、68、80、502、1069、1070、1212、2222、44818、および 50000 (In-Sight 通信のために予約済み) を除きます。
  • [Telnet ポート] 設定を有効にするには、ビジョンシステムを再起動する必要があります。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

Telnet ポート 2000 を指定するには、次のコマンドを発行します。EVSetSystemConfig("TelnetPort",2000,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[Telnet ポート] 設定 (2000) が返されます。

ネットワーク要求リンクモード

[ネットワークの設定] ダイアログで [リンクスピード] の設定を行います。このコマンドの発行後は、ビジョンシステムを再起動して変更を有効にする必要があります。

警告:指定のリンク速度をサポートするようにネットワークデバイスが設定されていない場合、ビジョンシステムにアクセスすることはできません。ビジョンシステムのイーサネット設定に合わせてネットワークデバイスのイーサネット設定を行ってください。

シンタックス: EVSetSystemConfig("Network.RequestedLinkMode",LinkSpeed,WriteProcSet)

入力パラメータ

入力 | 説明
"Network.RequestedLinkMode" | [リンクスピード] 設定を参照します。
リンクスピード (LinkSpeed) | 0 = オートネゴシエーション* 100 = 10 Mbps 半二重 101 = 10 Mbps 全二重 102 = 100 Mbps 半二重 103 = 100 Mbps 全二重 104 = 1000 Mbps 全二重
プロシージャセットの書き込み (WriteProcSet) | 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。

注:
  • [1000 Mbps 全二重] オプションは、1000 Mbps イーサネット速度をサポートするビジョンシステムだけで使用できます。In-Sight 5600 シリーズのビジョンシステムの場合、128MB 以上の不揮発性フラッシュメモリを搭載したモデルだけで使用できます。
  • GetSystemConfig コマンドを使って、ビジョンシステムでサポートされるリンク速度とデュプレックスモードを決定します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

100 Mbps 全二重を使用するようビジョンシステムを設定するには、次のコマンドを発行します。EVSetSystemConfig("Network.RequestedLinkMode",103,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、現在のリンクスピード (103) が返されます。

ライブ画像

[画像の設定] ダイアログで [ライブ取り込み] の設定を行います。

シンタックス: EVSetSystemConfig("LiveImage",Resolution,MaxFrameRate)

入力パラメータ

入力 | 説明
"LiveImage" | [ライブ画像] 設定を参照します。
解像度 | 1 = フル 0 または 2 = ハーフ* 3 = クォーター
最大フレームレート (MaxFrameRate) | (0.016 ～ 100)、0*
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

ハーフ解像度のライブ画像を最大レート 0.064 フレーム/秒で使用するようにビジョンシステムを設定するには、次のコマンドを発行します。EVSetSystemConfig("LiveImage",1,0.064)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[ライブ取り込み] 設定 (1 0.064) が返されます。

オンライン画像

[画像の設定] ダイアログで [オンライン解像度] の設定を行います。

シンタックス: EVSetSystemConfig("OnlineImage",Resolution,MaxFrameRate)

入力パラメータ

入力 | 説明
"OnlineImage" | [オンライン画像] 設定を参照します。
解像度 | 0 = 最適* 1 = フル 2 = ハーフ 3 = クォーター
最大フレームレート (MaxFrameRate) | (0.016 ～ 100)、0*
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

ハーフ解像度のオンライン画像を最大レート 0.064 フレーム/秒で使用するようにビジョンシステムを設定するには、次のコマンドを発行します。EVSetSystemConfig("OnlineImage",2,0.064)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、18) で応答します。最後に、[ライブ取り込み] 設定 (2 0.064) が返されます。

有効なサービス

[ネットワークの設定] ダイアログの [プロトコルサービス] の設定を行います。

注: EtherNet/IP サービスと PROFINET サービスは相互に排他的であるため、両方のサービスを同時に有効にすることはできません。

シンタックス: EVSetSystemConfig("ServicesEnabled",Services,Mask)

入力パラメータ

入力

説明

"ServicesEnabled"

[プロトコルサービス] 設定を参照します。

サービス (Services)

ビジョンシステム上で有効にするすべてのサービスを指定します。サービス (Services) パラメータは、10 進値に変換されるバイナリ値です。

サービス | バイナリ | 10 進値
iQSS | 01000000 | 64
POWERLINK 注: ファームウェアバージョン 4.x.x を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムのみでサポートされます。 | 00100000 | 32
SLMP スキャナ | 00010000 | 16
Precision Time Protocol (IEEE 1588 PTP) | 00001000 | 8
PROFINET | 00000100 | 4
EtherNet/IP | 00000010 | 2
Modbus Server | 00000001 | 1
なし | 00000000 | 0

複数のサービスを有効にするには、有効にするサービスのバイナリ値を求めて、それを 10 進値に変換します。 Closed 例

現在、有効になっているサービスはなく、Modbus および PROFINET サービスを有効にする必要があるとします。

  1. サービスの有効化に使用するバイナリ値を求めます。

    サービス

    PROFINET

    EtherNet/IP

    Modbus

    バイナリ

    1

    0

    1

  2. バイナリ値を 10 進値に変換します。

    101 = 5

  3. サービスの変更に使用するバイナリ値を求めます。

    サービス

    PROFINET

    EtherNet/IP

    Modbus

    バイナリ

    1

    0

    1

  4. バイナリ値を 10 進値に変換します。これによって、マスク (Mask) パラメータ値が得られます。

    101 = 5

  5. 次のコマンドを発行します。EV SetSystemConfig("ServicesEnabled",5,5)

    In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (5) が返されます。

マスク (Mask)

ビジョンシステム上で変更するサービスを指定します。マスク (Mask) パラメータは、10 進値に変換されるバイナリ値です。

サービス | バイナリ | 10 進値
iQSS | 01000000 | 64
POWERLINK 注: ファームウェアバージョン 4.x.x を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムのみでサポートされます。 | 00100000 | 32
SLMP スキャナ | 00010000 | 16
Precision Time Protocol (IEEE 1588 PTP) | 00001000 | 8
PROFINET | 00000100 | 4
EtherNet/IP | 00000010 | 2
Modbus Server | 00000001 | 1
なし | 00000000 | 0

複数のサービスを変更するには、変更するサービスのバイナリ値を求めて、それを 10 進値に変換します。 Closed 例

現在、有効になっているサービスは、PROFINET サービスだけです。EtherNet/IP サービスを有効にして、PROFINET サービスを無効にする必要があるとします。EtherNet/IP サービスを有効にするだけなので、サービス (Service) パラメータは 2 であることがわかります。

  1. サービスの変更に使用するバイナリ値を求めます。これによって、マスク (Mask) パラメータ値が得られます。

    サービス

    PROFINET

    EtherNet/IP

    Modbus

    バイナリ

    1

    1

    0

  2. バイナリ値を 10 進値に変換します。

    110 = 6

  3. 次のコマンドを発行します。EV SetSystemConfig("ServicesEnabled",2,6)

    In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (2) が返されます。

* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

1 つのサービスを有効にして変更するには

現在、有効になっているサービスはなく、PROFINET サービスを有効にする必要があるとします。次のコマンドを発行します。EVSetSystemConfig("ServicesEnabled",4,4)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (4) が返されます。

すべてのサービスを無効にする

すべてのサービスを無効にするので、サービス (Services) パラメータは 0 であることがわかります。

  1. サービスの変更に使用するバイナリ値を求めます。

    サービス

    PROFINET

    EtherNet/IP

    Modbus

    バイナリ

    1

    1

    1

  2. バイナリ値を 10 進値に変換します。これによって、マスク (Mask) パラメータ値が得られます。

    111 = 7

  3. 次のコマンドを発行します。EVSetSystemConfig("ServicesEnabled",0,7)

    In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、有効になったサービス (0) が返されます。

監査有効化設定

アクティブなビジョンシステムの自動監査メッセージを有効または無効にします。また、監査メッセージが生成されるイベントのタイプを指定します。

シンタックス: EVSetSystemConfig("AuditEnableSettings",Enabled,SystemEvents,TaggedCells,SystemSettings,WriteProcSet)

入力パラメータ

入力 | 説明
"AuditEnableSettings" | [監査有効化 (Audit Enable)] 設定を参照します。
有効 (Enabled) | 0* = アクティブなビジョンシステムの自動監査メッセージを無効にします。 1 = アクティブなビジョンシステムの自動監査メッセージを有効にします。
システムイベント (SystemEvents) | 0 = 無効。 1* = In-Sight のシステムイベントが発生した場合 (ビジョンシステムのログオン/ログオフ、ジョブのロードまたは保存、オンラインモードからオフラインモードへの遷移、システムの起動、およびファームウェア更新) に、監査メッセージが生成されます。
タグ付きセル (TaggedCells) | 0 = 無効。 1* = In-Sight Explorer、カスタムアプリケーション、VisionView、または PLC を使用して、シンボリックタグ付きセルを編集する (例えば、セルの数式または対話型コントロールの値を変更する場合) と、監査メッセージが生成されます。
システム設定 (SystemSettings) | 0 = 無効。 1* = システム設定 (proc.set ファイルに保存されている設定) を変更すると、監査メッセージが生成されます。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

システム設定値が変更され、その設定値が proc.set ファイルに保存されたときにアクティブなビジョンシステムの監査メッセージの生成を有効にするには、次のメッセージを発行します。EVSetSystemConfig("AuditEnableSettings",1,0,0,1,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

監査IP設定

監査メッセージサーバの IP アドレスおよび TCP/IP ポートを指定します。

シンタックス: EVSetSystemConfig("AuditIPSettings","IPAddress",Port,WriteProcSet)

入力パラメータ

入力 | 説明
"AuditIPSettings" | [監査 IP (Audit IP)] 設定を参照します。
"IPAddress" | 監査メッセージサーバの IP アドレスを指定します。
ポート (Port) | 監査メッセージサーバの TCP/IP ポートを指定します。(デフォルト = 5753) 注: 有効なポート番号は、In-Sight 通信のために予約されているポートを除いて、1 ～ 65535 の未使用の任意の番号です。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

監査メッセージサーバの IP アドレスおよび TCP/IP ポートを指定して、設定を proc.set ファイルに保存するには、次のコマンドを発行します。EVSetSystemConfig("AuditIPSettings","192.168.0.13",5753,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

トリガタイムスタンプ

In-Sight ビジョンシステムが CIP-Sync および Precision Time Protocol (PTP) 経由で通信するように設定されている場合、PLC からタイムスタンプが書き込まれるユーザデータフィールドのオフセットをシステム構成変数 "EIP.TriggerTimestampInputOffset" に設定するには、SetSystemConfig コマンドを使用します。

シンタックス: EVSetSystemConfig("Eip.TriggerTimestampInputOffset",Offset)

入力パラメータ

入力 | 説明
"Eip.TriggerTimestampInputOffset" | 64 ビットのタイムスタンプをマイクロ秒単位でキャプチャするための EtherNet/IP 入力アセンブリへのオフセットと、それに続けてビジョンシステムのトリガに使用される 64 ビットのシステム時間オフセットをマイクロ秒単位 (合計 16 バイト) で設定します。
オフセット (Offset) | オフセット (0 ～ 500) を指定します。この設定を無効にするには、この変数を -1 に設定します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

画像バッファを増加

ビジョンシステムの解像度と RAM サイズに基づいて、In-Sight ビジョンシステムに割り当てられる画像バッファのデフォルト数を増やすことができます。このコマンドの実行後、変更を有効化するには、ビジョンシステムの電源を入れ直す必要があります。

シンタックス: EVSetSystemConfig("StartupImageBuffers",NumberofBuffers,WriteProcSet)

入力パラメータ

入力 | 説明
"StartupImageBuffers" | 起動時にビジョンシステムに割り当てられる画像バッファの数を設定します。
バッファの数 (NumberofBuffers) | ビジョンシステムに割り当てられるバッファの数を設定します。 注: バッファの数 (NumberofBuffers) が 0 に設定されている場合、バッファ数のデフォルト値が使用されます。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。 |

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

ExtractBlobs メモリ割り当ての調整

ExtractBlobs 関数に対するメモリを手動で割り当てられるようにします。この設定を使用する場合、指定する値は ExtractBlobs 関数の対象領域 (ROI) 内にあるピクセル数の半分以下でなければなりません。

警告: Adjust ExtractBlobs Memory Allocation 設定は、メモリ不足のため、ExtractBlobs 関数が #ERR を返した場合のみ適用されます。この関数にメモリを割り当てるときは控えめにしてください。ExtractBlobs 関数にメモリを割り当てすぎると、In-Sight ビジョンシステム全体でメモリの問題を引き起こす場合があります。

シンタックス: EVSetSystemConfig("ExtractBlobsMemory",k)

入力パラメータ

入力 | 説明
"ExtractBlobsMemory" | ExtractBlobs 関数の起動時にビジョンシステムに割り当てられるメモリの量を設定します。
k | ExtractBlobs 関数の使用時にビジョンシステムに割り当てられるメモリの量を指定します。k の値は、使用する ROI のサイズおよび画像の品質によって異なります。小さめの値から初めて、少しずつ増やします。例えば、ROI <= 640 × 480 で、斑点のある画像では、値は 8,000 から始めて、1,000 ずつ増やします。ROI <= 1600 × 1200 の場合は 32,000 から始めて 1,000 ずつ増やします。ROI <= 2448 × 2048 の場合は 128,000 から始めて 1,000 ずつ増やしていきます。 注: ExtractBlobs のデフォルトのメモリ割り当てに戻すには 0 を入力します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

デフォルトのフォーカス位置

In-Sight 7000 シリーズのビジョンシステムがビジョンシステムの proc.set ファイルにフォーカスの位置を保存できるようにします。

シンタックス: EVSetSystemConfig("DefaultFocusPosition",Position,Apply,WriteProcSet)

注: DefaultFocusPosition 関数は、フォーカス位置の値を保存するためにのみ使用されます。レンズを移動することはありません。

入力パラメータ

入力 | 説明
"DefaultFocusPosition" | 起動時にビジョンシステムにより使用されるデフォルトのフォーカス位置を設定します。
位置 (Position) | デフォルトのフォーカス位置 (0 ～ 100) を指定します。この設定を無効にするには、この変数を -1 に設定します。
適用 (Apply) | 0* = In-Sight ビジョンシステムの電源を入れ直した後に設定が適用されます。 1 = 直ちに設定が適用されます。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

ストロボ開始位置

[出力詳細] ダイアログで [ストロボ開始位置] の設定を行います。

シンタックス: EVSetSystemConfig("StrobeStartPosition",Position,WriteProcSet)

注: [ストロボ/証明制御のトリガ] の設定を行うには、SetDiscreteOutput ネイティブモードコマンド (例 2 を参照) を使用します。

入力パラメータ

入力 | 説明
"StrobeStartPosition" | ストロボを開始するタイミングを指定します。
位置 (Position) | 0* = 画像取り込み開始。ストロボは、In-Sight ビジョンシステムが画像取り込みを開始するときにパルス出力します。In-Sight 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。 1 = カメラトリガ。ストロボは、カメラトリガイベントを受信するとパルス出力します。In-Sight 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。 2 = すべての行を露光。ストロボは、すべてのピクセル行が露光されたときにのみパルス出力します。In-Sight 8405 ビジョンシステムでのみサポートされています。 注:In-Sight 8405 ビジョンシステムでストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、「ローリングシャッターの操作」を参照してください。
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。In-Sight ビジョンシステムの電源を入れ直すと、設定は失われます。* 1 = 設定は proc.set ファイルに保存されます。In-Sight ビジョンシステムの電源を入れ直しても、設定は保持されます。
* はデフォルト値を示します。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

In-Sight ビジョンシステムが画像取り込みを開始するときにストロボが作動するように指定するには、次のコマンドを発行します。EVSetSystemConfig("StrobeStartPosition",0,1)

In-Sight ビジョンシステムは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

PulseJobChangeTiming

ジョブ変更 (パルス) 信号タイプとして設定されている場合に、In-Sight 2000 シリーズのセンサでのジョブをディスクリート入力ライン 0 を介して変更する場合の入力パルスの幅を指定します。ジョブ変更は、パルス幅の異なる入力パルスを検出することによって開始されます。このパルスは外部デバイス (PLC など) によって生成され、In-Sight 2000 センサに送信されます。まず、外部デバイスから開始パルスを生成します。次に、外部デバイスから、パルス間にギャップのあるカウントパルスを発行します。最後に、外部デバイスから停止パルスを発行します。すべてのパルスおよびパルスギャップが指定のパルス長にマッチすると、ジョブ変更リクエストに成功し、ジョブがセンサにロードされます。これらの条件に 1 つでも満たない場合 (パルスまたはパルスギャップのタイミングが正しくない場合)、ジョブ変更リクエストに失敗し、ジョブ変更は起こりません。

シンタックス: EVSetSystemConfig("PulseJobChangeTiming",StartPulse,StopPulse,CountPulse,PulseGap,Tolerance,WriteProcSet)

入力パラメータ

入力 | 説明
"PulseJobChangeTiming" | ジョブ変更 (パルス) のタイミングを指定します。
開始パルスの幅 (StartPulseWidth) | 開始パルスの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 20 ± 1 ミリ秒)
停止パルスの幅 (StopPulseWidth) | 停止パルスの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 20 ± 1 ミリ秒)
カウントパルスの幅 (CountPulseWidth) | カウントパルスの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 10 ± 1 ミリ秒)
パルスギャップの幅 (PulseGapWidth) | パルスギャップの幅を指定します。 1 ミリ秒 ～ 22000 ミリ秒 (デフォルト = 10 ± 1 ミリ秒)
許容値 (Tolerance) | パルス幅の許容値を指定します。 > 0 ミリ秒
プロシージャセットの書き込み (WriteProcSet) | 0 = 設定は proc.set ファイルに保存されません。設定は In-Sight センサの電源を入れ直すと失われます。 1 = 設定は、proc.set ファイルに保存され、In-Sight ビジョンシステムの電源を入れ直しても保持されます。
* はデフォルト値を示します。
注: EV SetSystemConfig("PulseJobChangeTiming") を発行すると、現在のパルス幅値が返されます。

出力

戻り値

ステータスコード。その後に結果の文字数 (バイト単位) と結果 (XML フォーマット) が続きます。

1 | コマンドは正常に実行されました。
0 | 認識されないコマンドが送信されました。
-2 | コマンドを実行することができませんでした。
-6 | ユーザはコマンドを実行するためのフルアクセスのアクセス権を持っていません。

例

パルス幅値を指定する

パルスジョブ変換タイミングを指定して設定を proc.set ファイルに保存するには、次のコマンドを発行します。

EV SetSystemConfig("PulseJobChangeTiming",15000,15000,10000,1000,100,1)

In-Sight センサは、ステータスコード (1) とその後の文字数 (バイト単位、20) で応答します。最後に、結果が XML フォーマットで返されます。

現在のパルス幅値を取得する

現在のパルス幅値を取得するには、次のコマンドを発行します。EV SetSystemConfig("PulseJobChangeTiming")

In-Sight センサは、ステータスコード (1) とその後の文字数 (バイト単位、45) で応答します。最後に、結果が XML フォーマットで返されます。
Version: 5.6.0


Modbus TCP による通信

In-Sight 通信リファレンス

Modbus は、産業用オートメーションシステム用に Modicon によって開発されたシリアルクライアント/サーバプロトコルです。最も古い産業用標準手法の 1 つで、産業用プロトコルとモニタリングデバイスの間でディスクリートおよびアナログ I/O 情報とレジスタデータを送信する場合に使用します。

In-Sight には、複数層の Modbus TCP (Ethernet 上で動作する TCP インタフェースを含む Modbus プロトコル) が実装されており、使用可能な実装は、In-Sight ビジョンシステム/センサで実行されているファームウェアのバージョンに応じてさまざまです。各実装の詳細な情報については、以下の表を参照してください。

  • サポートされるファームウェアバージョン
  • Modbus TCP のコマンド (5.3.0 以降)
  • TCP/IP Modbus のコマンド (4.x.x 以前)

サポートされるファームウェアバージョン

注:モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

Modbus TCP の実装 | ファームウェアバージョン 4.x.x 以前 | ファームウェアバージョン 5.1.0 ～ 5.2.x | ファームウェアバージョン5.3.0 以降
Modbus TCP サーバ (5.3.0 以降)- スプレッドシートおよび EasyBuilder 1 関連項目 - [ネットワークの設定] および [Modbus TCP サーバの設定] ダイアログ - Modbus TCP ファクトリインタフェース (5.3.0 以降) - Modbus 通信で使用するための In-Sight ビジョンシステムの設定 (5.3.0 以降) | サポートされていません | サポートされていません | サポート
TCPDevice (クライアントおよびサーバ) - スプレッドシートのみ 関連項目 - TCPDevice 関数 - Anybus X-gateway の関連項目 (PROFIBUS ネットワーク上の Siemens PLC との通信) | サポート | サポート | サポート
ダイレクトセルアクセス 関連項目 - Modbus Reference Number の例 | サポート | サポートされていません | サポートされていません
入力バッファと出力バッファを使用する ReadModbusBuffer 関数と WriteModbusBuffer 関数 (サーバのみ) - スプレッドシートおよび EasyBuilder 1 関連項目 ‐ [ネットワークの設定] ダイアログ - ReadModbusBuffer 関数と WriteModbusBuffer 関数 | サポート | サポートされていません | ReadUserDataBuffer 関数と WriteResultsBuffer 関数で置き換え
1 詳細については、「EasyBuilder のヘルプ」を参照してください。

Modbus TCP のコマンド (5.3.0 以降)

注: この Modbus TCP 実装の詳細については、「Modbus TCP - In-Sight ファームウェアバージョン 5.3.0 以降」のトピックを参照してください。

コード | 説明 | アドレス領域
0x01 | Read Coils この関数コードは、リモートデバイスで 1 ～ 2000 の連続したコイルの状態を読み取るために使用されます。このコマンドは、ビジョンシステム/センサからデータを読み取るために PLC によって使用されます。 | コイル
0x05 | Write Single Coil この関数コードは、リモートデバイスで単一出力コイルを ON または OFF のいずれかに書き込むために使用されます。このコマンドは、ビジョンシステム/センサにデータを書き込むために PLC によって使用されます。 | コイル
0x0F | Write Multiple Coils この関数コードは、リモートデバイスで 1 ～ 1968 の一連のコイル ON または OFF のいずれかに書き込むために使用されます。このコマンドは、ビジョンシステム/センサにデータを書き込むために PLC によって使用されます。 | コイル
0x02 | Read Discrete Inputs この関数は、リモートデバイスで 1 ～ 2000 の連続したディスクリート入力の状態を読み取るために使用されます。このコマンドは、ビジョンシステム/カメラからデータを読み取るために PLC によって使用されます。 | ディスクリート入力
0x03 | Read Holding Registers この関数は、リモートデバイスで 1 ～ 125 の保持レジスタの連続したブロックの内容を読み取るために使用されます。このコマンドは、ビジョンシステム/センサからデータを読み取るために PLC によって使用されます。 | 保持レジスタ
0x10 | Write Multiple Registers この関数コードは、リモートデバイスで 1 ～ 123 の連続したレジスタを書き込むために使用されます。このコマンドは、ビジョンシステム/センサにデータを書き込むために PLC によって使用されます。 | 保持レジスタ
0x04 | Read Input Registers この関数コードは、リモートデバイスで 1 ～ 125 の連続した入力レジスタを読み取るために使用されます。このコマンドは、ビジョンシステム/センサからデータを読み取るために PLC によって使用されます。 | 入力レジスタ

TCP/IP Modbus のコマンド (4.x.x)

以下の Modbus コマンドがサポートされています。

Read Multiple Registers (Modbus 関数コード 03)

In-Sight スプレッドシートの複数のセルから値を読み取ります。値は、16 ビット整数として返されます。セルのいずれかに整数以外の値が格納されていると、エラーコード 02 (ILLEGAL DATA ADDRESS) が返されます。

注: WriteModbusBuffer 関数を使用する場合、In-Sight ビジョンシステムから読み取りを行うリモートクライアントは、レジスタ 30010 ～ 30137 を使用する必要があります。

Reference Number | 読み取るセルを定義します。Modbus Reference Number の上位 6 ビット (ビット 15 ～ 10) によってセルの列 (A ～ Z) が定義され、下位 10 ビット (ビット 9 ～ 0) によってセルの行 (0 ～ 399) が定義されます。 Modbus Reference Number の例
Word Count | 読み取られるセルの数を定義します。セルが複数ある場合、返される値は Reference Number によって定義されるセルから始まり、列ごとに増分されます。メッセージにより、現在行にある残りの列よりも多くの値が要求されると、サーバは開始行の下の最初のセルから値の読み取りを続けます。

Closed Read Multiple Registers の例

例: Read Multiple Registers - In-Sight スプレッドシートの 3 つのセル (G273 ～ G275) からデータを読み取ります。

Modbus 要求を受け取ると、In-Sight はセル G273 ～ G275 に格納されているデータを返します。

バイト | 値 (10 進数) | 説明
0 | 0 | Modbus ヘッダ
1 | 0
2 | 0
3 | 0
4 | 0
5 | 6 | 後続バイト
6 | 0 | ユニット ID
7 | 3 | Modbus 関数コード (Read Multiple Registers の場合は 03)
8 | 25 | Modbus Reference Number (In-Sight スプレッドシートのセル参照)
9 | 17
10 | 0 | セル数 (開始セルを含む)
11 | 3

Write Multiple Registers (Modbus 関数コード 16)

EditInt 関数が格納されている In-Sight スプレッドシートのセルにデータを書き込みます。セルのいずれかに EditInt 関数が格納されていないと、エラーコード 02 (ILLEGAL DATA ADDRESS) が返されます。

注: ReadModbusBuffer 関数を使用する場合、In-Sight ビジョンシステムへの書き込みを行うリモートクライアントは、レジスタ 50000 ～ 50127 を使用する必要があります。

Reference Number | 書き込むセルを定義します。Modbus Reference Number の最初の 6 ビット (ビット 15 ～ 10) によってセルの列 (A ～ Z) が定義され、最後の 10 ビット (ビット 9 ～ 0) によってセルの行 (0 ～ 399) が定義されます。 Modbus Reference Number の例
Word Count | スプレッドシートに書き込まれるセルの数を定義します。セルが複数ある場合、書き込まれる値は Reference Number によって定義されるセルから始まり、列ごとに増分されます。メッセージにより、現在行にある残りの列よりも多くの値が書き込まれると、サーバは開始行の下の最初のセルへの値の書き込みを続けます。

Closed Write Multiple Registers の例

例: Write Multiple Registers - In-Sight スプレッドシートのセル E9 への書き込み。

スプレッドシートで、データを受け入れるセル E9 に EditInt 関数を作成します。Modbus コマンドが送信されると、セル E9 には値 65 が格納されます。

バイト | 値 (10 進数) | 説明
0 | 0 | Modbus ヘッダ
1 | 0
2 | 0
3 | 0
4 | 0
5 | 9 | 後続バイト
6 | 0 | ユニット ID
7 | 16 | Modbus 関数コード (Write Multiple Registers の場合は 16)
8 | 16 | Modbus Reference Number (In-Sight スプレッドシートのセル参照)
9 | 9
10 | 0 | セル数 (開始セルを含む)
11 | 1
12 | 2 | バイト数
13 | 00 | データ
14 | 65

Write Coil (Modbus 関数コード 05)

In-Sight スプレッドシートでイベントを開始します。Coil 0 ～ 7 に 0 以外の値を書き込むと、スプレッドシートで Soft Event 0 ～ 7 がトリガされます。Coil 8 に 0 以外の値を書き込むと、画像取り込みがトリガされます。Coil 番号が有効範囲 (0 ～ 8) 内に入っていないと、エラーコード 02 (ILLEGAL DATA ADDRESS) が返されます。

Closed Write Coil の例

例: Write Coil - In-Sight での画像取り込みのトリガ。

バイト | 値 (10 進数) | 説明
0 | 0 | Modbus ヘッダ
1 | 0
2 | 0
3 | 0
4 | 0
5 | 6 | 後続バイト
6 | 0 | ユニット ID
7 | 5 | Modbus 関数コード (Write Coil の場合は 05)
8 | 0 | Coil 番号*
9 | 8
10 | 255 | ON。リモートデバイス出力は ON (255) と OFF (0) のいずれかです。
11 | 0 | 常時 0

* Coil はバイト 8 および 9 を使用して示されます。

Coil 番号 | バイト 8 の値 (10 進数) | バイト 9 の値 (10 進数) | 説明
0 | 0 | 0 | ソフトトリガ 0 を指定
1 | 0 | 1 | ソフトトリガ 1 を指定
2 | 0 | 2 | ソフトトリガ 2 を指定
3 | 0 | 3 | ソフトトリガ 3 を指定
4 | 0 | 4 | ソフトトリガ 4 を指定
5 | 0 | 5 | ソフトトリガ 5 を指定
6 |  | 6 | ソフトトリガ 6 を指定
7 | 0 | 7 | ソフトトリガ 7 を指定
8 | 0 | 8 | In-Sight カメラで新しい画像を撮影します。新しい画像が取り込まれると、In-Sight は毎回、スプレッドシートを評価して値を更新します。 画像を取り込み、スプレッドシートを更新します。このオプションでは、AcquireImage 関数の [トリガ] 引数を、[外部] または [手動] に設定する必要があります。

関連項目

  • バイナリ関数
  • TCPDevice 関数
  • PROFIBUS ネットワーク上の Siemens PLC との通信
  • CC-Link ネットワーク上の三菱電機 PLC との通信
  • Anybus X-gateway
Version: 5.6.0


Modbus TCP 通信で使用するための In-Sight ビジョンシステムの設定

Modbus TCP による通信

In-Sight 通信リファレンス

このトピックでは、ファームウェアバージョン 5.3.0 以降が実行されている In-Sight ビジョンシステムを Modbus TCP 通信を使用して PLC に接続する方法を説明します。

注:
  • このトピックでは、ファームウェアバージョン 5.3.0 以降が実行されている In-Sight ビジョンシステム/センサでの Modbus TCP による通信について説明します。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • さまざまな In-Sight ファームウェアバージョンで使用可能な Modbus TCP 実装については、「Modbus TCP による通信」を参照してください。
  • 「Modbus TCP ファクトリインタフェース (5.3.0 以降)」では、In-Sight ビジョンシステムの入力および出力のプロセスメモリへのマップについて詳細に説明されています。
  • Modbus TCP による通信の確立
  • 画像取り込みトリガを受信するための In-Sight ビジョンシステムの設定
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信
  • 関連項目

Modbus TCP による通信の確立

In-Sight ビジョンシステムとの Modbus TCP による通信を確立できるようにするには、In-Sight ビジョンシステムの [ネットワークの設定] ダイアログを使用して、Modbus TCP サーバを有効にするように設定する必要があります。有効になったら、[Modbus TCP サーバの設定] ダイアログを使用して PLC への接続を設定します。

  1. In-Sight Explorer を開き、該当する In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから [ネットワークの設定] ダイアログを開きます。
  3. ダイアログの [産業用イーサネットプロトコル] セクションで [Modbus TCP サーバ] を選択し、[設定] ボタンを押して [Modbus TCP サーバの設定] ダイアログを起動します。
  4. [最大接続数] および [アイドルタイムアウト] コントロールを設定します。
  5. In-Sight ビジョンシステムを再起動します。Modbus TCP サーバサービスは電源の再投入時に有効になります。

画像取り込みトリガを受信するための In-Sight ビジョンシステムの設定

ビジョンシステムをトリガして PLC から画像を取り込むことが可能です。AcquireImage 関数の [トリガ] パラメータを [産業用イーサネット] に設定すると、PLC では、Modbus TCP サーバ通信が有効になっている場合にビジョンシステムをトリガすることができます。

  1. AcquireImage 関数のプロパティシートを開きます。
  2. [トリガ] パラメータを [産業用イーサネット] に設定します。
  3. In-Sight ビジョンシステムをオンラインにします。

  4. In-Sight ビジョンシステムは、ビジョンコントロールブロックの Trigger Enable および Trigger ビットを直接操作するか、ビジョンステータスブロックの Trigger Ready、Trigger Ack、および Missed Acq ビットを監視することによってトリガすることが可能です。

    注: 「Modbus TCP ファクトリインタフェース (5.3.0 以降)」のトピックでは、In-Sight ビジョンシステムの入力および出力のプロセスメモリへのマップについて詳細に説明されています。

In-Sight ビジョンシステムからのデータの取得

In-Sight Explorer のスプレッドシートから PLC にデータを取得するためには、WriteResultsBuffer 関数を使用してデータを Modbus TCP スタックにプッシュする必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り込み、そのデータを Modbus TCP スタックに書き込みます。その後 PLC では、Modbus TCP の読み取りコマンドでデータを読み取ることができます。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。[出力データの選択] ダイアログで、出力するデータ項目を選択します。
  3. 送信する追加データがある場合は、FormatOutputBuffer ダイアログで、[追加] ボタンをクリックします。転送する追加のデータを選択します。
  4. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. WriteResultsBuffer 関数の [プロトコル] パラメータを [3 = Modbus TCP サーバ] に設定し、[バッファ] パラメータを、作成した FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. オプションで、[Result Code] パラメータを、検査結果の結果コードを取得するためのスプレッドシート内のセルへのセル参照としてセットします。

In-Sight ビジョンシステムへのデータの送信

PLC から In-Sight Explorer のスプレッドシートにデータを送信するためには、ReadUserDataBuffer 関数を使用してデータを Modbus TCP スタックからプルする必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータフォーマットを取り、PLC から受信したデータを読み取り、そのデータを書式設定して In-Sight Explorer のスプレッドシートに取り込みます。

注: In-Sight ビジョンシステムをトリガして PLC からユーザデータを読み取るためには、ビジョンコントロールブロックの Set User Data ビットを PLC からトリガする必要があります。

  1. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  2. [FormatInputBuffer] ダイアログで、[追加] ボタンをクリックし、適切なデータ項目をリストに追加します。
  3. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. ReadUserDataBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。

  6. ReadUserDataBuffer 関数の [プロトコル] パラメータを [3 = Modbus TCP サーバ] に設定します。

  7. 関数が実装されたら、In-Sight ビジョンシステムをオンラインにして設定をテストします。

関連項目

  • サポートされるファームウェアバージョン
  • Modbus TCP ファクトリインタフェース (5.3.0 以降)
  • [ネットワークの設定] ダイアログ
  • [Modbus TCP サーバの設定] ダイアログ
  • WriteResultsBuffer 関数
  • FormatOutputBuffer 関数
  • ReadUserDataBuffer 関数
  • FormatInputBuffer 関数


Modbus TCP ファクトリインタフェース (5.3.0 以降)

Modbus TCP

In-Sight 関数リファレンス

このトピックでは、ファームウェアバージョン 5.3.0 以降が実行されている In-Sight ビジョンシステム/センサを使用する場合の Modbus TCP 通信プロトコルについて説明します。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  • Medbus TCP データブロック
  • Medbus TCP アドレスマップ
  • サポートされる Medbus のコマンド

Medbus TCP データブロック

定義済みデータブロックを使用すると、ビジョンシステムが PLC/MC との間でデータの読み取りと書き込みを行う場所を制御できます。アプリケーションの設定をするために、コマンド機能に必要なさまざまなコントロールおよびステータスビットは連続したブロックにグループ化され、これらを同時に処理することができます。

  • ビジョンコントロールブロック
  • ビジョンステータスブロック
  • 出力ブロック
  • 入力ブロック
  • 文字列コマンドブロック
  • 文字列コマンド結果ブロック

ブロック | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
ビジョン コントロール | 0 | Set Offline | Reserved |  | Execute Command | Inspection Results Ack | Buffer Results Enable | Trigger | Trigger Enable
 | 1 | Reserved
 | 2 | Reserved |  |  |  | Clear Exposure Complete | Clear Error | Initiate String Command | Set User Data
 | 3 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
ビジョン ステータス | 0 | Online | Offline Reason |  |  | Missed Acq | Reserved | Trigger Ack | Trigger Ready
 | 1 | Error | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 | 2 | Reserved |  |  | Job Pass | Exposure Complete | String Command Error | String Command Ack | Set User Data Ack
 | 3 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0

ブロック | ワード |
入力 | 0 | Command
 | 1 ～ 2000 | User Data
出力 | 0 | Current Job ID
 | 1 | エラーコード
 | 2 | Acquisition ID
 | 3 | Inspection ID
 | 4 | Inspection Result Code
 | 5 ～ 2004 | Inspection Results
文字列 コマンド | 0 | String Command Length
 | 1 ～ 960 | String Command
文字列 コマンド 結果 | 0 | Result Code
 | 1 | String Command Result Length
 | 2 ～ 961 | String Command Result

ビジョンコントロールブロック

バイト 0

ビット | 名前 | 説明
7 Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。
6 ～ 5 | Reserved | 未使用。
4 | Execute Command | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。
3 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection Count、Inspection Result Code、および Inspection Results データを受信したことを確認応答するように、PLC によってセットされます。その後、次の検査結果のセットが PLC に送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。
2 | Buffer Results Enable | このビットがセットされると、Inspection Count、Inspection Result Code、および Inspection Results フィールドは、Inspection Results Ack ビットがセットされて確認応答されるまで変化しません。最大 8 つの検査が In-Sight ビジョンシステムのバッファに保持されます。ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack ビットがクリアされて、PLC に送信される新しい結果セットがあるときには、Results Valid ビットはクリアされません。Inspection Results Ack ビットがクリアされて、PLC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。

  • AcquireImage 関数の Trigger パラメータが、外部、ネットワーク、または産業用イーサネットに設定されます。

    注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。
0 | Trigger Enable | このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

バイト 1

ビット | 名前 | 説明
7 ～ 1 | Reserved | 未使用。

バイト 2

ビット | 名前 | 説明
7 ～ 4 | Reserved | 未使用。
3 | Clear Exposure Complete | この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。
2 | Clear Error | このビットをセットすると、エラーシグナルとエラーコードシグナルがクリアされます。Clear Error ビットは、Error ビットがクリアされるまで [High] に維持する必要があります。エラーがキューに入れられた場合、このビットがクリアされると、エラーシグナルとエラーコードシグナルは、キューに入れられた次のエラーコードに対してセットされます。
1 | Initiate String Command | このビットがセットされると、String Command フィールドからデータが読み取られ、文字列コマンドが実行されます。コマンドの読み取り時には、String Cmd Ack ビットがセットされます。このビットは、ビジョンシステムがコマンドを確実に受信するために、String Cmd Ack ビットをセットするまで High のまま保持する必要があります。
0 | Set User Data | このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC から In-Sight ビジョンシステムへ通知します。

バイト 3

ビット | 名前 | 説明
7 | Soft Event 7 | スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。
6 | Soft Event 6
5 | Soft Event 5
4 | Soft Event 4
3 | Soft Event 3
2 | Soft Event 2
1 | Soft Event 1
0 | Soft Event 0

ビジョンステータスブロック

バイト 0

ビット | 名前 | 説明
7 | Online | このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。
6 ～ 4 Offline Reason このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。
Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。
3 Missed Acq 画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

注: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。
2 | Reserved | 未使用。
1 Trigger Ack In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。また、Acquisition ID は、このビットの立ち上がりエッジにラッチできます。

注: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。
0 Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。

バイト 1

ビット | 名前 | 説明
7 | Error | このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
6 | Command Failed | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
5 | Command Completed | コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。
4 | Command Executing | Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
3 Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注:オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。
2 Results Buffer Overrun

このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。9 番目の検査と後続のすべての検査は、バッファに空きが生じるまで (結果が確認応答されたとき) 破棄されます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。
1 | Inspection Completed | このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。
0 System Busy

ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

バイト 2

ビット | 名前 | 説明
7 ～ 5 | Reserved | 未使用。
4 Job Pass このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。
注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
3 | Exposure Complete | このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
2 | String Command Error | このビットは、前の文字列コマンドの結果がエラーコードを返したかどうかを示します。
1 | String Command Ack | このビットは、ビジョンシステムがコマンドの処理を完了して、コマンドに対する応答を生成したときにセットされます。ビジョンシステムによってこのビットがセットされると、PLC は安全に文字列コマンド応答データを読み取ることができます。PLC が Initiate String Command ビットをクリアした後で、このビットがリセットされます。PLC は、Initiate String Command ビットをクリアして String Command Ack ビットが Low 状態に戻ってから、新しいコマンドを開始します。
0 | Set User Data Ack | このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。

バイト 3

ビット | 名前 | 説明
7 | Soft Event Ack 7 | これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。
6 | Soft Event Ack 6
5 | Soft Event Ack 5
4 | Soft Event Ack 4
3 | Soft Event Ack 3
2 | Soft Event Ack 2
1 | Soft Event Ack 1
0 | Soft Event Ack 0

出力ブロック

注: [フォーマット出力バッファ] ダイアログで定義したデータは、出力ブロックの「Inspection Results」フィールド (ワード 5 ～ 2000) に表示されます。

ワード 0

名前 | 説明
Current Job ID | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

ワード 1

名前 説明
エラーコード

発生したエラーの 16 ビットの数値表現:

コード | Error | 説明
0x0000 | No Error | エラーは発生しませんでした。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされている間に Trigger ビットが設定された場合、または AcquireImage 関数の Trigger パラメータが、外部、ネットワークまたは産業用イーサネットに設定された場合に発生します。
0x0101 | Trigger set while Offline | ビジョンシステムがオフラインの間に Trigger ビットが設定されるときに発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Excecuting ビットが High のままになっている場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムがオンラインの間に [ジョブを開く] コマンドが発行されるときに発生します。

ワード 2

名前 | 説明
Acquisition ID | この ID は、取り込みの開始時と Trigger Ack ビットがセットされると増分され、取り込みとその検査結果の同期に使用できます。

ワード 3

名前 | 説明
Inspection ID | この結果セットに関連付けられている取り込み ID。

ワード 4

名前 | 説明
Inspection Result Code | 検査結果コードは、WriteResultsBuffer 関数の [結果コード] パラメータによって定義されます。

ワード 5 ～ 2004

名前 | 説明
Inspection Results | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

入力ブロック

注: [フォーマット出力バッファ] ダイアログで定義したデータは、入力ブロックの「User Data」フィールド (ワード 1 ～ 2000) に表示されます。

ワード 0

名前 | 説明
Command | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。 注: ジョブのロードを試みるときに無効なジョブ ID が指定される (例えば、接続されている In-Sight ビジョンシステムに 05.job が存在しないのに 05.job が指定される) と、前のジョブをロードする代わりに新しい空白ジョブがロードされます。

ワード 1 ～ 2000

名前 | 説明
User Data | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

文字列コマンドブロック

ワード 0

名前 | 説明
String Command Length | ネイティブモードコマンドの長さ。

ワード 1 ～ 960

名前 | 説明
String Command | ビジョンシステムによって処理されるネイティブモードコマンド。

文字列コマンド結果ブロック

ワード 0

名前 | 説明
Result Code | ネイティブモードコマンドの応答コード。コマンドが成功したか失敗したかを、このコードで判別することができます。 注: すべてのネイティブモードコマンドはここで確認できます。各コマンドは正常に実行された場合、1 を返します。失敗した場合、各コマンドに固有のエラーコードがあります。エラーコードの詳細については、各ネイティブモードコマンドのトピックを参照してください。

ワード 1

名前 | 説明
String Command Result Length | ネイティブモードコマンドの応答データの長さ (バイト単位)。

ワード 2 ～ 961

名前 | 説明
String Command Result | ネイティブモードコマンドの結果文字列。コマンドによって返されるデータの ASCII 文字列表記です。

Medbus TCP アドレスマップ

注:
  • ビジョンコントロールブロック、ビジョンステータスブロック、出力ブロックおよび文字列コマンド結果ブロックは、2 つの別々の場所にマップされます。二重マッピングする理由は、PLC によってはアドレス空間の保持レジスタ部にしかアクセスできないからです (つまり、それらの PLC では、関数コードの 3 と 6 のみがサポートされます)。二重マッピングにより、保持レジスタにしかアクセスできない PLC でも、すべての信号とデータに正常にアクセスすることができます。ただし、全関数コードセットをサポートする PLC は、それぞれの最適なアドレスマップの場所にあるこれらのブロックにアクセスできます。最適なブロックの場所と保持レジスタの場所の一方にアクセスする必要があり、両方にアクセスすることはできない点に注意してください。
  • Modbus TCP プロトコルでは、本来、アドレス指定でゼロから始まるオフセットを使用します。以下のアドレスマップ図は、ゼロから始まるオフセットを使用するブロックの場所を示しています。PLC で Schneider フォームのアドレス指定を使用する場合は、マップアドレスに示されているゼロから始まるオフセットをベース Schneider アドレスに単に追加します。例えば、Schneider フォームのアドレス指定を使用して「入力ブロック」にアクセスするには、保持レジスタの Schneider ベースアドレス (400000) に「入力ブロック」のオフセット (2000) を追加する必要があります。したがって、Schneider フォームでは、入力ブロックが 402000 から始まります。

Modbus TCP は 4 つの明確なアドレス空間をサポートしています。空間には、2 つのビットアドレス空間と 2 つのワード (16 ビット) アドレス空間があります。

  • コイル: ビットタイプのアドレス空間。PLC からの出力、ビジョンシステム/センサへの入力
  • ディスクリート入力: ビットタイプのアドレス空間。PLC への入力、ビジョンシステム/センサからの出力
  • 保持レジスタ: ワードタイプのアドレス空間。ビジョンシステム/センサからの入出力両方
  • 入力レジスタ: ワードタイプのアドレス空間。PLC への入力、ビジョンシステム/センサからの出力
ブロック名 | アドレス領域 | オフセット | Schneider フォームアドレス指定 | 数量
ビジョンコントロール | コイル | 0 | 000000 ～ 000031 | 1 ～ 32
 | 保持レジスタ | 0 | 400000 ～ 400001 | 1 ～ 2
ビジョンステータス | ディスクリート入力 | 0 | 100000 ～ 100031 | 1 ～ 32
 | 保持レジスタ | 100 | 400100 ～ 400101 | 1 ～ 2
入力 | 保持レジスタ | 2000 | 402000 ～ 404000 | 1 ～ 2001
出力 | 保持レジスタ | 7000 | 407000 ～ 409004 | 1 ～ 2005
 | 入力レジスタ | 2000 | 302000 ～ 304004 | 1 ～ 2005
文字列コマンド | 保持レジスタ | 1000 | 401000 ～ 401999 | 1 ～ 1000
文字列コマンド結果 | 入力レジスタ | 1000 | 301000 ～ 301999 | 1 ～ 1000
 | 保持レジスタ | 6000 | 406000 ～ 406999 | 1 ～ 1000

アドレス (000000)
コイル読み取り/書き込み
(0x01、0x05、0x0F) 		アドレス (100000)
ディスクリート入力読み取り
(0x02) 		アドレス (400000)
保持読み取り/書き込み
(0x03、0x10) 		アドレス (300000)
入力レジスタ読み取り
(0x04)

サポートされる Medbus TCP のコマンド

コード | 説明 | アドレス領域
0x01 | Read Coils この関数コードは、リモートデバイスで 1 ～ 2000 の連続したコイルの状態を読み取るために使用されます。このコマンドは、ビジョンシステム/センサからデータを読み取るために PLC によって使用されます。 | コイル
0x05 | Write Single Coil この関数コードは、リモートデバイスで単一出力コイルを ON または OFF のいずれかに書き込むために使用されます。このコマンドは、ビジョンシステム/センサにデータを書き込むために PLC によって使用されます。 | コイル
0x0F | Write Multiple Coils この関数コードは、リモートデバイスで 1 ～ 1968 の一連のコイル ON または OFF のいずれかに書き込むために使用されます。このコマンドは、ビジョンシステム/センサにデータを書き込むために PLC によって使用されます。 | コイル
0x02 | Read Discrete Inputs この関数は、リモートデバイスで 1 ～ 2000 の連続したディスクリート入力の状態を読み取るために使用されます。このコマンドは、ビジョンシステム/カメラからデータを読み取るために PLC によって使用されます。 | ディスクリート入力
0x03 | Read Holding Registers この関数は、リモートデバイスで 1 ～ 125 の保持レジスタの連続したブロックの内容を読み取るために使用されます。このコマンドは、ビジョンシステム/センサからデータを読み取るために PLC によって使用されます。 | 保持レジスタ
0x10 | Write Multiple Registers この関数コードは、リモートデバイスで 1 ～ 123 の連続したレジスタを書き込むために使用されます。このコマンドは、ビジョンシステム/センサにデータを書き込むために PLC によって使用されます。 | 保持レジスタ
0x04 | Read Input Registers この関数コードは、リモートデバイスで 1 ～ 125 の連続した入力レジスタを読み取るために使用されます。このコマンドは、ビジョンシステム/センサからデータを読み取るために PLC によって使用されます。 | 入力レジスタ
Version: 5.6.0


Modbus Reference Number の例

TCP/IP Modbus による通信

In-Sight 通信リファレンス

注: ダイレクトセルアクセスは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

Modbus デバイスから In-Sight スプレッドシート内のセルを参照するには、次のようにしてセルを 2 バイトの Modbus Reference Number に変換する必要があります。

上位 6 ビット (ビット 11 ～ 15) = 列 (A ～ Z)

下位 10 ビット (ビット 0 ～ 10) = 行 (0 ～ 399)

例 1: セル G273 を参照するため、Reference Number は次のように変換されます。

  1. セルの列と行を 10 進数に変換します。

G = 06 {A = 0, B = 1, C = 2, ..., X = 23, Y = 24, Z = 25}

273 = 273

  2. 10 進数をバイナリに変換します (右から左に読み取り)。

注: 列のバイナリ数が 6 ビットではない場合、または行のバイナリ数が 10 ビットではない場合、最終データ型での残りのビットは (バイトの上位端に向かって) すべて 0 にセットする必要があります。

G = 06 = 000110 (6 ビット)

273 = 273 = 0100010001 (10 ビット)

ビット

15

14

13

12

11

10

9

8

7

6

5

4

3

2

1

0

0

0

0

1

1

0

0

1

0

0

0

1

0

0

0

1
  3. これにより 16 ビットのワードが形成され、2 つの 8 ビット値に分離されます。

000110 01 00010001

  4. これら 2 つの 8 ビット値をそれぞれの 10 進数値に変換します。

000110 01 = 25

00010001 = 17

  5. これで、ハイバイト (10 進数で 25) とローバイト (10 進数で 17) の参照番号が得られます。

例 2: セル N23 を参照するため、Reference Number は次のように変換されます。

  1. セルの列と行を 10 進数に変換します。

N = 13

23 = 23

  2. 10 進数をバイナリに変換します (右から左に読み取り)。

N = 13 = 001101

23 = 23 = 0000010111

ビット

15

14

13

12

11

10

9

8

7

6

5

4

3

2

1

0

0

0

1

1

0

1

0

0

0

0

0

1

0

1

1

1
  3. これにより 16 ビットのワードが形成され、2 つの 8 ビット値に分離されます。

001101 00 00010111

  4. これら 2 つの 8 ビット値をそれぞれの 10 進数値に変換します。

001101 00 = 52

00010111 = 23

  5. これで、ハイバイト (10 進数で 52) とローバイト (10 進数で 23) の参照番号が得られます。

例 3: セル Z399 を参照するため、Reference Number は次のように変換されます。

  1. セルの列と行を 10 進数に変換します。

Z = 25

399 = 399

  2. 10 進数をバイナリに変換します (右から左に読み取り)。

N = 25 = 011001

399 = 399 = 0110001111

ビット

15

14

13

12

11

10

9

8

7

6

5

4

3

2

1

0

0

1

1

0

0

1

0

1

1

0

0

0

1

1

1

1
  3. これにより 16 ビットのワードが形成され、2 つの 8 ビット値に分離されます。

011001 01 10001111

  4. これら 2 つの 8 ビット値をそれぞれの 10 進数値に変換します。

011001 01 = 101

10001111 = 143

  5. これで、ハイバイト (10 進数で 101) とローバイト (10 進数で 143) の参照番号が得られます。

関連項目

TCP/IP Modbus による通信

バイナリ関数

TCPDevice 関数


Modbus TCP ファクトリインタフェースを使用して名前によってジョブを開く

Modbus TCP

In-Sight 通信リファレンス
注: 名前によってジョブを開く機能は、In-Sight ファームウェア 5.5.0 以降が実行されている In-Sight ビジョンシステムでのみ使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  1. Set Offline ビットをハイ (High) にセットすることにより、カメラをオフラインにします。

    ブロック | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    ビジョン

    コントロール

             0

    Set

    Offline

             Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

    Initiate

    String

    Command

    Set

    User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0

    ビジョン

    ステータス

             0 Online Offline Reason

    Missed

    Acq

             Reserved

    Trigger

    Ack

    Trigger

    Ready
    1 Error

    Command

    Failed

    Command

    Completed

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    2 Reserved

    Job

    Pass

    Exposure

    Complete

    String

    Command

    Error

    String

    Command

    Ack

    Set

    User

    Data

    Ack
    3

    Soft

    Event

    Ack 7

    Soft

    Event

    Ack 6

    Soft

    Event

    Ack 5

    Soft

    Event

    Ack 4

    Soft

    Event

    Ack 3

    Soft

    Event

    Ack 2

    Soft

    Event

    Ack 1

    Soft

    Event

    Ack 0

    ビジョンコントロールブロック

    バイト 0

    ビット 名前 説明
    7 Set Offline

    このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。

  2. 入力ブロックのワード 0 に Job Load by Name コマンドを書き込みます。Job Load by Name コマンドの値は 0x4000 です。

    ブロック | ワード

    入力

             0 Command
    1 ～ 2000 | User Data

    出力

             0 Current Job ID
    1 | エラーコード
    2 | Acquisition ID
    3 | Inspection ID
    4 | Inspection Result Code
    5 ～ 2004 | Inspection Results

    String

    Command

             0 String Command Length
    1 ～ 960 | 文字列コマンド

    String

    Command

    Result

             0 Result Code
    1

    String Command Result Length
    2 ～ 961 | 文字列コマンド結果

    入力ブロック

    ワード 0

    名前 | 説明
    Command | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。

  3. 入力ブロックのワード 1 ～ 2000 (UserData) にジョブ名を書き込みます。ジョブ名は null で終了する必要があります (バイト内のジョブ名の直後に 0 を付加する必要があります)。

    ブロック | ワード

    入力

             0 Command
    1 ～ 2000 | User Data

    出力

             0 Current Job ID
    1 | エラーコード
    2 | Acquisition ID
    3 | Inspection ID
    4 | Inspection Result Code
    5 ～ 2004 | Inspection Results

    String

    Command

             0 String Command Length
    1 ～ 960 | 文字列コマンド

    String

    Command

    Result

             0 Result Code
    1

    String Command Result Length
    2 ～ 961 | 文字列コマンド結果

    入力ブロック

    ワード 1 ～ 2000

    名前 | 説明
    User Data | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

  4. ビジョンコントロールブロックの Execute Command ビットをセットします。

    ブロック | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    ビジョン

    コントロール

             0

    Set

    Offline

             Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

    Initiate

    String

    Command

    Set

    User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0

    ビジョン

    ステータス

             0 Online Offline Reason

    Missed

    Acq

             Reserved

    Trigger

    Ack

    Trigger

    Ready
    1 Error

    Command

    Failed

    Command

    Completed

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    2 Reserved

    Job

    Pass

    Exposure

    Complete

    String

    Command

    Error

    String

    Command

    Ack

    Set

    User

    Data

    Ack
    3

    Soft

    Event

    Ack 7

    Soft

    Event

    Ack 6

    Soft

    Event

    Ack 5

    Soft

    Event

    Ack 4

    Soft

    Event

    Ack 3

    Soft

    Event

    Ack 2

    Soft

    Event

    Ack 1

    Soft

    Event

    Ack 0

    ビジョンコントロールブロック

    バイト 0

    ビット | 名前 | 説明
    4 | Execute Command | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。

  5. Execute Command ビットと Offline ビットをクリアする前に、Command Complete または Command Failed がセットされるのを待ちます。

    ブロック | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    ビジョン

    コントロール

             0

    Set

    Offline

             Reserved

    Execute

    Command

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

             Trigger

    Trigger

    Enable
    1 | Reserved
    2 Reserved

    Clear

    Exposure

    Complete

    Clear

    Error

    Initiate

    String

    Command

    Set

    User

    Data
    3

    Soft

    Event

    7

    Soft

    Event

    6

    Soft

    Event

    5

    Soft

    Event

    4

    Soft

    Event

    3

    Soft

    Event

    2

    Soft

    Event

    1

    Soft

    Event

    0

    ビジョン

    ステータス

             0 Online Offline Reason

    Missed

    Acq

             Reserved

    Trigger

    Ack

    Trigger

    Ready
    1 Error

    Command

    Failed

    Command

    Completed

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    2 Reserved

    Job

    Pass

    Exposure

    Complete

    String

    Command

    Error

    String

    Command

    Ack

    Set

    User

    Data

    Ack
    3

    Soft

    Event

    Ack 7

    Soft

    Event

    Ack 6

    Soft

    Event

    Ack 5

    Soft

    Event

    Ack 4

    Soft

    Event

    Ack 3

    Soft

    Event

    Ack 2

    Soft

    Event

    Ack 1

    Soft

    Event

    Ack 0

    ビジョンステータスブロック

    バイト 1

    ビット | 名前 | 説明
    6 | Command Failed | このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
    5 Command Completed コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。

    カメラは、Execute Command ビットが low になると Command Completed ビットをクリアします。
    4 | Command Executing | Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
Version: 5.6.0


POWERLINK 通信

B&R 通信

In-Sight 通信リファレンス
  • POWERLINK および In-Sight ビジョンシステム
  • POWERLINK 通信で使用するために In-Sight ビジョンシステムを設定
  • 関連項目

注:
  • POWERLINK は、In-Sight のファームウェアバージョン 4.7.2 以上、および In-Sight Explorer のソフトウェアバージョン 4.7.2 以上を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムでのみサポートされています。ファームウェアバージョン 5.1.0 以上ではサポートされません。
  • POWERLINK は、In-Sight 70xx ～ 74xx シリーズのカラービジョンシステム　(In-Sight 7010C、In-Sight 7200C、In-Sight 7400C、In-Sight 7402C) ではサポートされません。
  • In-Sight ビジョンシステムは、B&R Automation Studio バージョン 3.090 以降、および Automation Runtime バージョン 3.08 以降でのみサポートされています。

POWERLINK および In-Sight ビジョンシステム

  • 概要
  • POWERLINK サイクル
  • 非同期データ転送
  • In-Sight ビジョンシステムの理想的な MTU とサイクル時間設定
  • POWERLINK ネットワークゲートウェイおよび In-Sight ビジョンシステム

概要

POWERLINK は、時間が重要なシステムで使用される産業用イーサネットプロトコルです。POWERLINK Ethernet プロトコルは、PLC や産業用 PC などの管理ノード (MN) を使用して、Ethernet 帯域幅を固定時間サイクル (200 ～ 10000 µs) に分割します。In-Sight ビジョンシステムなど、ネットワークで稼動しているもう 1 つのデバイスは、制御ノード (CN) として動作し、MN からのメッセージに対応したデータの送信のみ許可されています。

各サイクルの間、MN は各 CN 宛てのデータを作成し、CN はそれぞれ、ネットワーク上のほかのデバイス宛てのデータで応答します。このデータは等時性メッセージング (決定論が保証されたメッセージング) を使用したノードと非同期メッセージング (決定論の保証されていないメッセージング) を使用したノードの間で送信されます。ネットワーク上のデバイスがすべて同期された後、MN により非同期期間が開始され、1 つのデバイスがネットワーク上で標準 TCP/IP トラフィックを送信できるようになります。

注: デバイスがネットワーク帯域幅を競合することはないので、POWERLINK ノードをまとめて接続する場合に遅延を軽減するには、スイッチではなくリピーターハブを使用します。

POWERLINK ネットワークのデバイスはすべて、ノード ID 番号 (1 ～ 240) で識別されます。MN のノード ID は常に 240で、CN はノード ID 1 ～ 239 のいずれかを持ちます。このノード ID 番号は固定 IP サブネット 192.168.100.<NodeID> と組み合わせられます。これは、ネットワーク上の各デバイスに、POWERLINK ネットワーク内の固定 IP アドレスを割り当てます。この IP アドレスは、POWERLINK ネットワークの外側にあるほかのデバイスと通信するために使用することもできます。

注:
  • POWERLINK を有効にしたビジョンシステムを POWERLINK ネットワークから切断し、通常のイーサネットネットワークに切り替える場合、イーサネット通信がロックアップし、帯域幅が 1Mbps に制限されることがあります。通常のイーサネットネットワークを使用している場合、ジョブを編集するには、POWERLINK 通信を無効にしてください。
  • POWERLINK ネットワーク上の In-Sight ビジョンシステムが In-Sight Explorer に接続されている場合に、PLC にダウンロードを試みたり、PLC のソフトウェア再起動を試みたりすると、ビジョンシステムを In-Sight Explorer に接続できなくなることがあります。PLC に変更を加えたり再起動したりする前に、ビジョンシステムを In-Sight Explorer から切断することが推奨されます。この問題が発生した場合、In-Sight Explorer に再度接続するには、ビジョンシステムに電源を再投入してください。

POWERLINK サイクル

POWERLINK ネットワークは、「サイクル」(200 ～ 10000 µs) と呼ばれる固定タイムスライスに分割されます。各サイクルには、等時性メッセージ送信、および非同期メッセージ送信 (時間が許せば) の期間が含まれます。各サイクルのはじめに、MN はサイクルの開始 (SoC) メッセージをネットワークにブロードキャストし、サイクルの等時性フェーズが始まることを知らせます。SoC メッセージの送信後、MN はそのサイクルについて設定された CN それぞれにポーリング要求 (PReq) を送信します。各 CN はポーリング応答 (PRes) メッセージで応答します。PReq および PRes メッセージは、ネットワーク上にデータを作成するために使用されます。

POWERLINK ネットワークでは、CN はクロストラフィック通信を実行できます。つまり、最初に MN を通過しなくても互いにプロセスデータを交換できます。このタイプの設定では、1 つの PLC を POWERLINK MN にすることができます。もう 1 つの PLC は CN として動作し、In-Sight ビジョンシステムの画像取り込みを制御します。In-Sight ファームウェアは、MN 以外に 2 つの CN からのクロストラフィック通信をサポートし、各ノードから最大 100 バイトのデータを受信することができます。

注: クロストラフィックサポートには、In-Sight 4.8.0 以降のファームウェアが必要です。

CN データが送信されるたびに、MN は非同期の開始 (SoA) メッセージをネットワークに送信し、サイクルの非同期フェーズの開始を知らせます。この間、1 つのノード (SoA フレームに含まれるデータにより示されるもの) がネットワークへの送信を許可されるパケットは 1 つです。このノードに、そのサイクル期間の容量以上のデータがある場合、この送信は複数のサイクルの非同期フェーズに拡散されます。

非同期データ転送

In-Sight ビジョンシステムにとって、POWERLINK ネットワークの非同期データ送信機能は非常に重要です。非同期フェーズは次のタスクを実行するために使用されます。

  • を使用したビジョンシステムの設定とモニタIn-Sight Explorer
  • オンライン状態での In-Sight Explorerまたは Cognex VisionView への画像とデータの転送
  • WriteImageFTP 関数を使用して FTP サーバに画像を送信

POWERLINK ネットワークの設定のうち非同期データスループットに最大の影響を持つものは、最大送信単位 (MTU) 設定とサイクル時間の 2 つです。

MTU

POWERLINK ネットワークの非同期パケットに対する MTU の範囲は 300 ～ 1500 バイトです。デフォルトでは、B&R PLC は MTU を 300 バイトに設定します。デフォルトの MTU を増やすには、非同期データ送信の各サイクルで、さらに時間を確保する必要があります。例えば、MTU では、非同期データ送信のために 27 µs の確保が要求されますが、最大サイズ (1500 バイト) の場合は 123 µs 必要です。

注: 非同期パケットトランスファ用の MTU 値が、POWERLINK ネットワークで使用されている MTU 値と同じ値でない場合、TCP/IP 通信は正常に機能しません。

サイクル時間

サイクル時間も非同期データ送信を制限します。POWERLINK ネットワークは、1 サイクルにつき、非同期パケットを 1 つだけ送信するように設定されているため、サイクル時間を短縮すると、ネットワークで送信できる非同期パケットの数が増えます。最も一般的な POWERLINK ネットワーク設定の 1 つのサイクル時間は 400 µs です。これは 1 秒間に 2500 サイクル、つまり 1 秒間に送信できる非同期フレームの数は 2500 になります。

In-Sight ビジョンシステムの理想的な MTU とサイクル時間設定

POWERLINK はデータ送信、特に非同期の部分を Ethernet に依存しているため、POWERLINK ネットワークで使用できる帯域幅全体を計算する方法を理解することは、最適なパフォーマンスの確立には重要な決定因子です。この帯域幅全体は POWERLINK ネットワークの非同期送信を通じて通信するすべての CN で共有されます。

POWERLINK ネットワークで使用できる帯域幅全体は、一般に次の式で計算されます。

  • 帯域幅 (Mbps) = MTU × 8 ÷ サイクル時間 (µs)

Cognex では、POWERLINK ネットワーク上の In-Sight ビジョンシステムに対する最適な設定は、MTU 1500 バイト、サイクル時間 400 µs であると決定しました。MTU のサイズが大きく減少したり、サイクル時間が増加したりすると、前セクションに記載されている 3 つの箇条書き項目について、パフォーマンスが大幅に低下します。サイクル時間の計算については、B&R Automation Studio アプリケーションに用意されている B&R Microsoft Excel スプレッドシート (powerlink_cycletime_calculations.xls) をご利用ください。

注:

次の In-Sight アプリケーションパラメータは、接続のパフォーマンスに影響を与える場合があります。

  • フル画像の取り込みやフル解像度画像の送信および記録など、取り込まれた画像および画像の更新設定。限られた帯域幅環境の中で、目標は画像の取得レートを削減することです。このためには、部分的な取り込みが行われるように AcquireImage 関数の [取り込み開始行] および [行数] パラメータを設定し、[記録/再生のオプション] ダイアログの [記録] タブで、[画像の解像度] パラメータを [ハーフ] または [クォーター] に設定します。必要に応じて、この方法で設定を行い、バックグラウンドサービス用の帯域幅を増やします。
  • WriteImageFTP または WriteImageSFTP 関数を使用して画像を送信すると、画像解像度の設定に関係なく、 で使用できる帯域幅が削減されますIn-Sight Explorer。

  • POWERLINK サイクル時間が 500µs 未満に設定されている場合、使用できる User Data チャネルは 16 に制限され、Inspection Results は 24 に制限されます。サイクル時間設定が低すぎる場合や、送信するデータの設定が多すぎる場合は、POWERLINK 接続が失敗します。

POWERLINK ネットワークゲートウェイおよび In-Sight ビジョンシステム

B&R PLC は、POWERLINK ネットワーク上のデバイスと、標準 Ethernet ポートを通じて接続されたデバイスの間の TCP/IP トラフィック用ゲートウェイとして動作することができます。In-Sight Explorerには、[In-Sight ネットワーク] ペインに POWERLINK ネットワークを追加する機能があります。[エクスプローラリモートサブネットリスト] ダイアログ ([システム] メニューからアクセス可能) を使用して、POWERLINK ネットワークを追加し、サブネット情報を設定することができます。この設定後、[In-Sight ネットワーク] ペインには、POWERLINK サブネットの In-Sight ビジョンシステムが表示されるようになります。

POWERLINK 通信で使用するために In-Sight ビジョンシステムを設定

このセクションでは、POWERLINK 通信を使用して、B&R PLC を In-Sight ビジョンシステムに接続する方法を説明します。

  • In-Sight ビジョンシステムでの POWERLINK 通信の有効化
  • In-Sight ビジョンシステムへの周期接続の確立
  • AcquireImage の [トリガ] パラメータの設定
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信
  • In-Sight ネットワークへの POWERLINK ネットワークの追加
  • In-Sight ビジョンシステムでの POWERLINK 通信の無効化
注:
  • これらの手順では、POWERLINK ネット経由での送信準備の整ったデータを含むジョブが In-Sight ビジョンシステムにロードされていることを前提にしています。
  • アプリケーション開発では、工場ラインに設置されている In-Sight ビジョンシステムに直接接続することを推奨します。これにより画像の更新速度が速くなるため、焦点の調節や画像の位置揃え、アプリケーションのセットアップがしやすくなります。アプリケーションの開発が完了したら、ジョブを保存してから、POWERLINK を有効化し、リモートサブネットを追加します。このリモートサブネットでは、In-Sight Explorer将来のトラブルシューティングやアプリケーションの追加開発のために、 からビジョンシステムをモニタできます。

In-Sight ビジョンシステムでの POWERLINK 通信の有効化

In-Sight ビジョンシステムを POWERLINK ネットワークに配置するには、まず、In-Sight ビジョンシステムの [ネットワークの設定] ダイアログを使用して、POWERLINK が有効になるようにビジョンシステムを設定する必要があります。

注: これらの手順では、POWERLINK ネットワークが既に動作していて、ほかのデバイスもこのネットワークにあり、かつ MN が B&R PLC であることを前提にしています。

  1. POWERLINK ネットワークに配置する In-Sight ビジョンシステムを、 が実行されている PC に直接接続しますIn-Sight Explorer。
  2. を開き、In-Sight Explorer目的の In-Sight ビジョンシステムに接続します。
  3. [センサ] メニューから [ネットワークの設定] ダイアログを開きます。
  4. ダイアログの [産業用イーサネットプロトコル] セクションで [POWERLINK] を選択し、[設定] ボタンをクリックして [POWERLINKの設定] ダイアログを開きます。
  5. [POWERLINKの設定] ダイアログは、In-Sight ビジョンシステムのノード ID を定義するために使用されます。
  6. メッセージプロンプトが表示されたら、In-Sight ビジョンシステムを再起動し、電源の再投入後に POWERLINK プロトコルを有効にします。
  7. ビジョンシステムを PC から外し、POWERLINK ネットワークに接続します。

In-Sight ビジョンシステムへの周期接続の確立

In-Sight ビジョンシステムを POWERLINK ネットワークに統合しやすくするために、Cognex は Automatic Studio へのインポート用 In-Sight-7000.xdd ファイル (0000031D_In-Sight-7000.xdd) を作成しました。In-Sight-7000.xdd ファイルは、POWERLINK ネットワーク経由でデータを送信しやすくするために、In-Sight ビジョンシステムから POWERLINK マスターノードへのネットワークインタフェースを記述したものです。

  1. Automation Studio の [ツール] メニューにアクセスし、[Import Fieldbus Device] オプションを選択します。
  2. In-Sight Explorer 4.7.1 に含まれている .xdd ファイル (例えば、C:\Program Files\Cognex\In-Sight\In-Sight Explorer 4.7.1\XDD) に移動し、ファイル (0000031D_In-Sight-7000.xdd) をインポートします。

  3. In-Sight-7000.xdd ファイルのインポート後、In-Sight ビジョンシステムを POWERLINK ネットワークに追加し、ノード ID を割り当てる必要があります。

    注: Automation Studio へのサードパーティデバイスの追加に関する具体的な情報については、B&R Automation Studio ヘルプの Explorer POWERLINK ヘルプコンテンツを参照してください。

  4. In-Sight ビジョンシステムの追加が正常に終了したら、POWERLINK ネットワークへ周期的に送信されるチャネルを有効化します。In-Sight ビジョンシステムとの通信が確立されたら、[Cyclic transmission] の値を [Write] (ビジョンシステムへ出力) または [Read] (ビジョンシステムから入力) に設定し、このチャネルのデータを送信します。

  5. 有効化されたチャネルも、システム変数にマップすることができます。

    注: コントロールブロックやステータスブロックなど、ビットレベルのデータには、倍精度整数名にビット位置指定子を追加してアクセスする必要があります。このリリースでは、ビット変数を直接マッピングすることはできません。

  6. 適切に設定されたプロジェクトは B&R PLC にダウンロードされ、その後、PLC は In-Sight ビジョンシステムを使用して、データの周期転送を開始します。
  7. In-Sight ビジョンシステムが正常に動いていることを確認するには、Automation Studio の Monitor モードに入り、ビジョンシステムの I/O マッピングを開いて、ModuleOK チャネルが TRUE であることを確認します。

AcquireImage の [トリガ] パラメータの設定

In-Sight ビジョンシステムを POWERLINK ネットワークに統合すると、POWERLINK ネットワークで画像を取り込むためにビジョンシステムをトリガできるようになります。AcquireImage 関数の [トリガ] パラメータを [産業用イーサネット] に設定すると、POWERLINK が有効化されるときにハードウェア支援のトリガモードが有効化されます。

  1. AcquireImage 関数のプロパティシートを開きます。
  2. [トリガ] パラメータを [産業用イーサネット] に設定します。
  3. In-Sight ビジョンシステムをオンラインにします。
  4. In-Sight ビジョンシステムのトリガを行うには、Inspection Control オブジェクトの [コントロール] フィールドにある Trigger Enable と Trigger ビットを直接操作するか、Inspection Status オブジェクトの [ステータス] 構造体にある Trigger Ready、Trigger Ack、Acquiring、および Missed Acq ビットをモニタします。
  5. Automation Studio で、Inspection Control チャネルから Trigger Enable ビットを True に設定し、Trigger ビットを False から True に切り替えます。また、Trigger Ready ビットは True に設定します。

In-Sight ビジョンシステムからのデータの取得

In-Sight Explorer スプレッドシートからのデータを B&R PLC で取得するには、WriteResultsBuffer 関数を使用して、データを POWERLINK ネットワークに書き込む必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り、そのデータを B&R PLC の設定済みデータテーブルに書き込みます。その後、このデータはサイクル時間に関係なく、最大 4 ms おきに同期され、次の更新サイクル中に送信されます。

以下の手順に従って、In-Sight ビジョンシステムから B&R PLC に送信されるデータの書式設定の方法を説明します。

  1. まず、In-Sight Explorer を使用して、新規ジョブを作成します。
  2. [パレット] の [スニペット] タブから、次の 2 つのスニペットをスプレッドシートに追加します。[Acquisition] → [AcqCounter] および [Math & Logic] → [Random]
  3. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。Random スニペットの「Scaled random number」セルを選択します。

  6. [FormatOutputBuffer] ダイアログの [追加] ボタンを再びクリックします。これでセル選択モードになります。AcqCounter スニペットのカウントセルを選択します。

  7. [OK] ボタンを押して、[FormatOutputBuffer] ダイアログを閉じます。
  8. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  9. WriteResultsBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  10. In-Sight ビジョンシステムをオンラインにします。
  11. In-Sight ビジョンシステムが正常に動いていることを確認するには、Automation Studio の Monitor モードに入り、ビジョンシステムの I/O マッピングを開いて、ModuleOK チャネルが TRUE であることを確認します。

In-Sight ビジョンシステムへのデータの送信

B&R PLC から In-Sight Explorer スプレッドシートにデータを送信するためには、ReadUserDataBuffer 関数を使用して、データを POWERLINK プロトコルスタックからプルする必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータ形式を取り、B&R PLC から受信したデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに入れます。In-Sight ビジョンシステムをトリガして B&R PLC からユーザデータを読み取るためには、コントロールブロックの Set User Data ビットを PLC からトリガする必要があります。

例: In-Sight ビジョンシステムへのデータの送信

この例では、In-Sight Explorer 内に新規ジョブを作成した後、以下の手順を実行して、B&R PLC が受信するデータを設定します。

  1. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。

    注: 連続トリガモードは、デモンストレーションのみを目的としています。連続トリガモードでは、ビジョンシステムはできる限り多くの画像を取り込み、PLC からイベントが開始されると、PLC からビジョンシステムへのデータ転送を直ちに観察できます。ランタイム操作のためにビジョンシステムを導入する準備ができたら、画像取り込みトリガのソースに基づいて、[トリガ] パラメータを再設定する必要があります。

  2. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。

  4. [OK] ボタンを押して、[FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックしてから、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、その関数をスプレッドシートに挿入します。
  6. ReadUserDataBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. FormatInputBuffer 関数に追加されたフィールドに基づいて、データアクセス関数が自動的にスプレッドシートに追加されます。
  8. In-Sight ビジョンシステムをオンラインにします。
  9. Automation Studio の Monitor モードに入り、データを強制的に UserData フィールドに入れて、In-Sight ビジョンシステムが正常に動作していることを確認します。
  10. Inspection Control オブジェクトの [コントロール] フィールドで Set User Data ビットを設定します。
  11. Inspection Control オブジェクトの [コントロール] フィールドで「Set User Data」ビットの設定を解除します。ビジョンシステムは連続トリガモードになっているため、画像を取り込み、データ転送を観察することができます。

In-Sight ネットワークへの POWERLINK ネットワークの追加

[In-Sight Network] ペインに POWERLINK ネットワークを追加するには、次の手順に従って操作します。

  1. [システム] メニューで、[リモートサブネット] をクリックします。
  2. [エクスプローラリモートサブネットリスト] ダイアログで [追加] ボタンをクリックして、[サブネットの追加] ダイアログを開きます。
  3. 追加されるサブネットにわかり易い名前を付け、[名前] フィールドに入力します。
  4. [IP アドレス] フィールドの IP アドレスは、POWERLINK ネットワーク用に PLC でプログラミングされた "POWERLINK NAT subnet" IP アドレスと一致する必要があります。
  5. [マスク] フィールドに「255.255.255.0」と入力します。
  6. ネットワークインフラストラクチャが POWERLINK ネットワークへルーティングできない場合、[Use Custom Gateway] オプションをチェックし、[ゲートウェイ] フィールドに標準 Ethernet ネットワークの PLC の IP アドレスを設定します。これにより、PC のルーティングテーブルにリモートサブネットへの経路が確立されます。
  7. [OK] ボタンをクリックして、変更を確定し、[サブネットの追加] ダイアログを閉じます。
  8. 新たに設定されたリモートサブネットが [Explorer Remote Subnet List] ダイアログに表示されます。[OK] ボタンを押して、ダイアログを閉じます。
  9. POWERLINK ネットワークが [In-Sight ネットワーク] ペインに表示されるようになります。

In-Sight ビジョンシステムでの POWERLINK 通信の無効化

POWERLINK ネットワークで動作するように設定された In-Sight ビジョンシステムを無効化するには、次の手順に従って操作します。

  1. In-Sight Explorer が実行されている PC から、In-Sight ビジョンシステムを使用可能な Ethernet ポートの 1 つに接続し、PC で DHCP に設定します。
  2. [システム] メニューで、[センサ/デバイスをネットワークに追加] をクリックします。
  3. [センサ/デバイスをネットワークに追加] ダイアログで、目的の In-Sight ビジョンシステムを選択し、[DHCP で IP アドレスを自動的に取得する] オプションを選択して、[適用] ボタンをクリックします。
  4. 設定が正常に変更されたことを示すメッセージの後、指定したビジョンシステムが [In-Sight ネットワーク] ペインに表示されます。
  5. スプレッドシート または EasyBuilder 開発環境のいずれかで、ビジョンシステムへの接続を開きます。
  6. [センサ] メニューで、[ネットワークの設定] をクリックし、[ネットワークの設定] ダイアログを開きます。
  7. [産業用イーサネットプロトコル] で [なし] を選択し、[OK] ボタンをクリックします。
  8. ビジョンシステムを再起動して、変更を適用します。

関連項目

  • POWERLINK ファクトリインタフェース
  • ReadLatchedUserDataBuffer 関数
  • ReadUserDataBuffer 関数
  • WriteResultsBuffer 関数
Version: 5.6.0


POWERLINK ファクトリインタフェース

POWERLINK プロトコル通信

In-Sight 関数リファレンス

  • POWERLINK ファクトリインタフェース
  • POWERLINK/In-Sight ビジョンシステムの I/O マッピング
  • POWERLINK/In-Sight ビジョンシステムでの LED の動作

POWERLINK ファクトリインタフェース

注:POWERLINK は、In-Sight のファームウェアバージョン 4.7.2 以上、および In-Sight Explorer のソフトウェアバージョン 4.7.2 以上を実行している In-Sight 70xx ～ 74xx シリーズのビジョンシステムでのみサポートされています。ファームウェアバージョン 5.1.0 以上ではサポートされません。

等時性フェーズでは、POWERLINK マスターノードと In-Sight ビジョンシステムの間をやりとりされるデータは 5 つのデータチャネルに編成されます。次に説明するチャネルは、等時性フェーズで POWERLINK ネットワークを通じた周期転送のために、Process Data オブジェクト (PDO) にマップすることができます。POWERLINK ファクトリインタフェースのチャネルには、特定の In-Sight ビジョンシステムデータバッファへの通信パスが用意されています。これは、データ交換やビジョンシステムジョブの管理、取り込み、検査制御、およびステータスデータに使用されます。

  • Inspection Control オブジェクト (0x2000)
  • Inspection Status オブジェクト (0x2001)
  • Inspection Results (0x2010)
  • Inspection Results データ (0x2011)
  • User Data (0x2021)

Inspection Control オブジェクト (0x2000)

Inspection Control オブジェクトは事前定義された倍精度整数値で、ビジョンシステムのトリガ、ビジョンシステムのジョブファイルの変更、Soft Events の開始などの一般的な In-Sight ビジョンシステムコマンドを、PLC が発行できるようにいたします。

インデックス | 名前 | 型 | アクセス | 注意
1 | Control | 32 ビットの整数 | RW | 32 ビットの [コントロール] フィールドは、コントロール構造体にマップされます。この構造体については、後述のコントロール構造体の表で説明します。
2 | JobLoadID | 16 ビットの整数 | RW | PLC によって Initiate Job Load ビットがセットされたときにロードされるジョブの ID 番号 (1 ～ 999)。

コントロール構造体

Inspection Control オブジェクトの [コントロール] フィールドが周期転送用に設定されているとき、コントロール構造体の個々のビットへは PLC からアクセスできます。

注: 現在のリリースでは、[コントロール] フィールドは、DWORD としてのみ表示されています (ビットごとにラベルはついていません)。

ビット 名前 説明

0

Trigger Enable

このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

1

Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。

  • AcquireImage 関数の [トリガ] パラメータが [産業用イーサネット] に設定されている。

    注: [トリガ] パラメータの [ネットワーク] または [外部] 設定も使用できますが、さらに遅延が長くなります。

2

Buffer Results Enable

このビットがセットされると、Inspection Count、Inspection Result Code、および Inspection Results フィールドは、Inspection Results Ack ビットがセットされて確認応答されるまで変化しません。最大 8 つの検査が In-Sight ビジョンシステムのバッファに保持されます。ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack ビットがクリアされて、PLC に送信される新しい結果セットがあるときには、Results Valid ビットはクリアされません。Inspection Results Ack ビットがクリアされて、PLC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。

3

Inspection Results Ack

Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection Count、Inspection Result Code、および Inspection Results データを受信したことを確認応答するように、PLC によってセットされます。その後、次の検査結果のセットが PLC に送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。

4

Initiate Job Load

セットされると、ビジョンシステムは Job Load ID フィールドで指定したジョブ ID をロードします。

注: In-Sight ビジョンシステムがオンラインの間は、Initiate Job Load ビットを設定しないでください。ビジョンシステムをオフラインにしてから、Initiate Job Load の開始を設定します。オンラインのうちに設定すると、Job Load Failed ビットが設定されません。

5 ～ 6

Reserved

将来の実装に備えて予約済みです。

7

Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。

8 ～ 15

Reserved

 将来の実装に備えて予約済みです。

16

Set User Data

このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC から In-Sight ビジョンシステムへ通知します。

17 ～ 18

Reserved

 将来の実装に備えて予約済みです。

19

Clear Exposure Complete

この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。

20 ～ 23

Reserved

 将来の実装に備えて予約済みです。

24 ～ 31

Soft Event 0 ～ 7

スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。

Inspection Status オブジェクト (0x2001)

Inspection Status オブジェクトも事前定義された倍精度整数ブロックで、Trigger Ready、Inspecting、Inspection Complete など In-Sight ビジョンシステムのステータスを PLC に通知し、エラーステータス、オンライン/オフラインステータス、画像取り込みミスなどの詳しい診断情報を提供します。

インデックス | 名前 | 型 | アクセス | 注意
1 | Status | 32 ビットの整数 | R | 32 ビットの [コントロール] フィールドは、ステータス構造体にマップされます。この構造体については、後述のステータス構造体の表で説明します。
2 | CurrentJobID | 16 ビットの整数 | R | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。
3 | AcquisitionID | 16 ビットの整数 | R | この ID は現在の画像取り込みに関連付けられています。Trigger ビットを使用して画像取り込みされ、Trigger Ack 信号がアサートされると、この ID が Acquisition ID に設定されます。

ステータス構造体

Inspection Control オブジェクトの [ステータス] フィールドが周期転送用に設定されているとき、ステータス構造体の個々のビットへは PLC からアクセスできます。

注: 現在のリリースでは、[コントロール] フィールドは、DWORD としてのみ表示されています (ビットごとにラベルはついていません)。

ビット 名前 説明

0

Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Network Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注: [トリガ] パラメータの [ネットワーク] または [外部] 設定も使用できますが、さらに遅延が長くなります。

1

Trigger Ack

In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。

2

Acquiring

画像取り込み方法に関係なく、In-Sight ビジョンシステムが現在画像を取り込んでいるときにセットされます。

3

Missed Acq

画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

4 ～ 6

Offline Reason

このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

7

Online

このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。

8

Inspecting

このビットは、In-Sight ビジョンシステムがジョブを実行しているときにセットされます。

9

Inspection Completed

このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。

10

Results Buffer Overrun

 このフィールドは、Buffer Results Enable ビットがセットされていて、Inspection Results Ack ビットをセットすることによって PLC が確認応答しなかったために In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されて、バッファ内の 8 番目の検査に上書きされたときにセットされます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。

11

Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注:オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。

12

Job Loading

このビットは、このプロトコルを通してジョブのロードが開始されたときにセットされます。

13

Job Load Complete

このビットは、このプロトコルによって開始されたジョブのロード操作の完了時にトグルされます。

14

Job Load Failed

 このビットは、ジョブのロードの最後の試みが失敗したときにセットされます。MN がジョブのロードを開始し、ロードに成功するとクリアされます。

15

Reserved

 将来の実装に備えて予約済みです。

16

Set User Data Ack

 このコマンドは、ビジョンシステムにて消費される User Data フィールドを保持バッファに転送する必要がある場合に、PLC から In-Sight ビジョンシステムへ通知します。

17 ～ 18

Reserved

 将来の実装に備えて予約済みです。

19

Exposure Complete

このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。
20 Job Pass

このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。

21 ～ 23

 Reserved 将来の実装に備えて予約済みです。

24 ～ 31

 Soft Event Ack 0 ～ 7

これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。

Inspection Results (0x2010)

Inspection Results は、Acquisition ID および Inspection Results データブロックにあるデータの長さを提供します。

インデックス | 名前 | 型 | アクセス | 注意
1 | InspectionID | 32 ビットの整数 | R | この結果セットに関連付けられている取り込み ID。
2 | InspectionResultCode | 16 ビットの整数 | R | 現在は使用されていません。常に 0 です。
3 | InspectionResultLength | 16 ビットの整数 | R | 検査結果データの長さ。

Inspection Results データ (0x2011)

Inspection Results Data チャネルは設定可能な一連のレジスタで、ビジョン検査から PLC へのデータ通信に使用されます。例えば、PLC から、総合的な「Pass/Fail」結果、1 つの測定の結果、部品のX、Y、および角度と位置、またはバーコードの結果を求められることがあります。このデータは、Inspection Results Data チャネル経由で送信されます。

インデックス | 名前 | 型 | アクセス | 注意
1 ～ 64 | InspectionResultsNN | 32 ビットの整数 | R | WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

User Data (0x2021)

User Data チャネルは設定可能な一連のレジスタで、PLC から In-Sight ビジョンシステムへの値の送信に使用されます。例えば、許容値の設定を PLC からビジョンシステムに送信し、ある部品を検査するときに、適切な許容値が適用されます。

また、User Data チャネルを使用して、32 ビット整数値を User Data Block に書き込んだり、Process Data Object に割り当てて周期転送に使用することもできます。

インデックス | 名前 | 型 | アクセス | 注意
1 ～ 64 | UserDataNN | 32 ビットの整数 | RW | ReadUserDataBuffer または ReadLatchedUserDataBuffer 関数を使用してスプレッドシートに読み取ることができるデータバッファ。

POWERLINK/In-Sight ビジョンシステムのマッピング

ここで説明するモジュールを使用して、In-Sight ビジョンシステムの各種サブシステムへのアクセスが可能になります。

  • 一般的な画像取り込みシーケンス
  • 検査/結果シーケンス
  • 結果のバッファリング
  • Soft Events

一般的な画像取り込みシーケンス

In-Sight ビジョンシステムのトリガを行うには、Inspection Control オブジェクトの [コントロール] フィールドにある Trigger Enable と Trigger ビットを直接操作するか、Inspection Status オブジェクトの [ステータス] 構造体にある Trigger Ready、Trigger Ack、Acquiring、および Missed Acq ビットをモニタします。

Automation Studio で、Inspection Control チャネルから Trigger Enable ビットを True に設定し、Trigger ビットを False から True に切り替えます。また、Trigger Ready ビットは True に設定します。

In-Sight ビジョンシステム取り込みシーケンスの例

最初の起動時には、Trigger Enable ビットは偽であり、トリガを有効にするには真にセットする必要があります。ビジョンシステムがトリガを受け入れる準備ができると、Inspection Control オブジェクトにある [コントロール] フィールドの Trigger Ready ビットが真に設定されます。

Trigger Enable および Trigger Ready ビットが真である間、Trigger ビットが偽から真に変化するのをビジョンシステムが認識するたびに、画像取り込みが開始されます。Inspection Status オブジェクトのステータス構造体の Trigger Ack ビットが偽に変わるまで、Trigger ビットをそのままの状態で保持する必要があります (これは、ビジョンシステムが変化を確実に確認するために必要なハンドシェークです)。

画像取り込み時には、Inspection Control オブジェクトにある [コントロール] フィールドの Trigger Ready ビットがクリアされて、Acquiring ビットが真に設定されます。画像取り込みが完了すると、Acquiring ビットはクリアされ、Trigger Ready ビットが再度、真に設定されます。これは、ビジョンシステムが新しい画像取り込みを開始する準備ができたことを示しています。

トリガメカニズムを強制的にリセットするには、Acquisition Status レジスタが真になるまで Trigger Enable ビットを偽に設定します。Trigger Enable ビットを真に設定すると、画像取り込みが再度有効になります。

Closed 例: 一般的な画像取り込みシーケンス

Closed 例: 検査シーケンスより高速な画像取り込み

検査/結果シーケンス

In-Sight ビジョンシステムによって取り込まれた画像は、処理のためにキューに入れられます。ビジョンシステムが画像を処理している間、ステータス構造体の Inspecting ビットが設定されます。ビジョンシステムが画像の処理を終了すると、Inspecting ビットがクリアされ、Inspection Completed ビットがトグルされます。

ビジョンシステムでの検査結果の取り扱い方は、コントロール構造体の Buffer Results Enable ビットによって決定されます。Buffer Results Enable ビットが偽に設定された場合、検査結果は直ちにコントロール構造体に入れられ、Results Valid ビットが真に設定されます。Buffer Results Enable ビットが真に設定されると、新しい結果がキューに入れられます。以前の検査結果は、PLC によって Inspection Results Ack ビットが真に設定され、結果の受領が確認されるまで、コントロール構造体に残ります。Results Valid ビットがクリアされると、PLC は Inspection Results Ack ビットを偽に戻す必要があります。これで、キューに入れられた結果をステータス構造体に入れることができます (これは、PLC が結果を確実に受信するために必要なハンドシェークです)。

検査ステータス信号の動作

ビット名 | バッファリングが無効な場合の結果 | バッファリングが有効な場合の結果
Inspecting | 画像を処理しているときにセットされます。 | 画像を処理しているときにセットされます。
Inspection Complete | 画像処理の完了時にトグルされます。 | 画像処理の完了時にトグルされます。
Results Buffer Overflow | 0 に設定されたままです。 | PLC が前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。結果バッファがオーバフローします。検査結果が正常にキューに入れられたときにクリアされます。
Results Valid | 新しい結果が Inspection Results および Inspection Results Data チャネルに入れられたときに設定されます。Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。 | 新しい結果が Inspection Results および Inspection Results Data チャネルに入れられたときに設定されます。Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。
Job Pass | 検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。 注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。 | 新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。 注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。

結果のバッファリング

検査結果用のキューを有効にする必要があります。有効にした場合、PLC が有限個の検査データ結果を読み取るまでキューに入れておくことができます。これは、システムの複数の部分 (外部 PLC を含む) の速度が短時間に低下した場合に、データの流れを滑らかにするのに有効な機能です。

通常、結果が送信される速度より検査を実行する速度の方が速い場合、バッファリングありとバッファリングなしの間の大きな相違点は、破棄される結果を判別するかどうかということです。バッファリングが有効でない場合は最新の結果が保持され、以前の結果は PLC が読み取ることができず失われます。原則的に、最新の結果によって以前の結果が上書きされるだけです。バッファリングが有効である (さらに、キューがいっぱいである) 場合は、結果キューに空きができるまで最新の結果が破棄されます。

Closed 例: 結果オーバフローシーケンス

ソフトイベント

PLC から In-Sight ビジョンシステムへのデータ送信に加えて、ジョブ固有の動作を制御するために、ソフトイベントを送信できます。個々のソフトイベントには、トリガ (Inspection Control オブジェクトのビット 24 ～ 31) および確認応答ビット (Inspection Status オブジェクトのビット 24 ～ 31) が関連付けられています。トリガビットの立ち上がりエッジによって、In-Sight ビジョンシステムは、ソフトイベントに関連付けられている動作を処理します。ソフトイベントの開始時に、ビジョンシステムは Soft Event Ack ビットを High に設定します。このビットは、PLC が Trigger ビットをリセットして、ソフトイベントに関連付けられている動作の処理が完了するまで High のまま保持されます。ソフトイベントをトリガできない場合は、General Fault ビットが High に設定されます。このビットは、イベントが正常にトリガされるまで High のまま保持されます。

Closed 例 - ソフトイベントのトリガ

注:In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

POWERLINK/In-Sight ビジョンシステムでの LED の動作

POWERLINK 対応 In-Sight ビジョンシステムを使用するときには、ビジョンシステムの LED を使用して、POWERLINK 固有の最新動作ステータスの更新を通知することができます。ユーザ 1 LED (赤) は POWERLINK エラー LED、ユーザ 2 LED (緑) は POWERLINK ステータス LED です。これらの状態は [ディスクリート I/O の設定] ダイアログで変更できません。

注: ユーザ 1 LED は、ビジョンシステムが POWERLINK ネットワークのノードとして、このネットワークでエラー状態を検知したときにオンになり、正常な動作に戻ったときにオフになります。

ユーザ 2 LED の状態 | LED の動作 | 説明
LED オフ | 常にオフ | POWERLINK を初期化しています。
LED の点滅 | 10Hz で点滅 | POWERLINK は基本 Ethernet モードです (ネットワークで POWERLINK マスターノードが検出されていません)。
LED 1 回ずつ点灯 | 短く 1 回点灯 (200ms) し、長く 1 回消灯 (1000ms) | ビジョンシステムは POWERLINK ネットワークでマスターノードを検出しましたが、等時性通信は検出されませんでした。
LED 2 回ずつ点灯 | 短く 2 回点灯し、長く 1 回消灯 | POWERLINK ネットワークが等時性通信を開始しましたが、このビジョンシステムは参加するように設定されていません。
LED 3 回ずつ点灯 | 短く 3 回点灯し、長く 1 回消灯 | ノードデバイスの設定が完了し、マスタノードからの等時性通信開始の信号を待っています。
LED オン | 常時点灯。 | ノードデバイスは POWERLINK ネットワーク上で通信しています。
LED が点滅 | 2.5Hz で点滅 | POWERLINK ノードはエラーのため停止しています。
Version: 5.6.0


PROFINET による通信

PROFINET による通信

In-Sight 通信リファレンス

分散 I/O (リモート I/O) は PROFINET IO で接続されています。この設定では、PROFIBUS の I/O ビューが保持され、フィールドデバイスからのユーザデータが周期的にコントロールシステムのプロセスモデルに転送されます。

PROFINET IO は、挿入場所 (スロット) と I/O チャネル (サブスロット) のグループで構成されるデバイスモデルを記述します。フィールドデバイスの技術的特性は、XML 形式の GSD (General Station Description) ファイルに記載されています。

PROFINET IO では、次の 3 種類のデバイスが区別されます。

  • IO コントローラ: 自動制御プログラムが実行されるコントローラ。
  • IO デバイス: 遠隔で割り当てられるフィールドデバイスで、IO コントローラに割り当てられるもの。
  • IO スーパーバイザ: コミッショニングおよび診断機能を実行するプログラミングデバイス (PC)。

PROFINET IO のエンジニアリングプロセスは、PROFIBUS と同様です。すなわち、コンフィギュレーション時に、分散化フィールドバスが 1 つ以上の制御システムに割り当てられます。I/O デバイスは、GSD ファイルの内容に基づいて、実際のシステム拡張に応じて構成されます。同時に、I/O デバイスは、統合され、適切にパラメータ化され、PROFINET のトポロジーとして構成されます (1)。

エンジニアリングプロセスの完了後、拡張データが IO コントローラにロードされます (2)。IO コントローラは、IO デバイスとのデータ交換を独自に引き継ぎます (3)。

In-Sight システムは、一度に 2 つのコントローラ (またはスーパーバイザ) からの PROFINET IO 接続をサポートします。下記の手順では、PROFINET IO を使用して In-Sight ビジョンシステムと Siemens PLC の間でデータを転送する方法を示しています。

関連項目

  • In-Sight ビジョンシステムでの PROFINET による通信
  • PROFINET 経由での In-Sight ビジョンシステムによるデータ転送 - In-Sight 4.x.x ファームウェア
  • PROFINET 経由での In-Sight ビジョンシステムによるデータ転送 - In-Sight 5.x.x ファームウェア
  • Siemens PLC でのレコードの使用
  • PROFINET I/O モジュールリファレンス
  • PROFINET I/O モジュールリファレンス - In-Sight 4.x.xファームウェア
  • PROFINET I/O モジュールリファレンス - In-Sight 5.x.x ファームウェア
Version: 5.6.0


In-Sight ビジョンシステムでの PROFINET による通信

PROFINET による通信

In-Sight 通信リファレンス

このセクションでは、PROFINET IO 通信を使用して Siemens 製 PLC を In-Sight ビジョンシステムに接続する方法について説明します。PROFINET IO を使用すると、In-Sight ビジョンシステムの入力および出力を Siemens PLC のプロセスメモリにマップすることができます。これらの値は、確立後、PROFINET IO システムの更新レートによって定義される間隔で同期されます。

このセクションで示す例は、次のコンポーネントを使用していることを前提に記述されています。

  • Siemens S7-300 または S7-400 シリーズ PLC (PROFINET オプション)
  • Siemens Step 7 プログラミングソフトウェア バージョン 5.3 (SP3 以降)

接続の設定手順は、In-Sight ビジョンシステムで実行されている In-Sight ファームウェアのバージョンに応じて異なります。

  • PROFINET 経由での In-Sight ビジョンシステムによるデータ転送 - In-Sight 4.x.x ファームウェア
  • PROFINET 経由での In-Sight ビジョンシステムによるデータ転送 - In-Sight 5.x.x ファームウェア
Version: 5.6.0


PROFINET 経由での In-Sight ビジョンシステムによるデータ転送 - In-Sight 4.x.x ファームウェア

PROFINET による通信

In-Sight 通信リファレンス

このトピックでは、In-Sight 4.x.x ファームウェアが実行されている In-Sight ビジョンシステム、および Siemens PLC との間で行われるデータ転送について説明します。

  • In-Sight ビジョンシステムでの PROFINET 通信の有効化
  • 接続のセットアップ
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信

In-Sight ビジョンシステムでの PROFINET 通信の有効化

In-Sight ビジョンシステムと PROFINET 通信を確立するためには、In-Sight ビジョンシステムの [ネットワークの設定] を使用して、PROFINET が有効になるようにビジョンシステムを設定しておく必要があります。

  1. In-Sight Explorer を開き、In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから [ネットワークの設定] ダイアログを開きます。

  3. ダイアログの [プロトコルサービス] セクションで、[PROFINET] を選択し、[PROFINET Settings (PROFINET 設定)] ダイアログを使用して、Siemens PLC の場合のように [設定] ボタンを押してビジョンシステムの [ステーション名] を有効化して設定します。

    注: [ステーション名] を設定しないと、PLC ではホスト名を参照しますが、サポートされない文字がサポートされる文字に PROFINET プロトコルによって変換されるため、そのホスト名はビジョンシステムのホスト名と同一ではない可能性があります。

  4. [ネットワークの設定] ダイアログに戻り、[OK] を押します。
  5. In-Sight ビジョンシステムを再起動すると、電源の再投入後 PROFINET サービスが有効になります。

接続のセットアップ

In-Sight ビジョンシステムと Siemens コントローラの間の PROFINET I/O 接続をセットアップするには、最初に、Siemens の HW Config ツールを使用して、In-Sight ビジョンシステムをコントローラのハードウェア構成に追加する必要があります。

  1. SIMATIC マネージャを開き、PLC のプロジェクトをロードします。

  2. [SIMATIC 300] または [SIMATIC 400] ノードを選択して、オブジェクトリストの [Hardware] ノードをダブルクリックします。

  3. HW Config (ハードウェア設定) ツールが表示されます。PROFINET IO ノードをコントローラに追加するには、PROFINET IO システムがハードウェア設定ダイアグラムに存在する必要があります。PROFINET IO システムがハードウェア設定ダイアグラムに存在しない場合、次の操作を行います。

    • CPU 上の PROFINET IO インタフェースにサブネットアドレスが割り当てられていることを確認してください。これを検証するには、CPU 上の PROFINET IO モジュールをダブルクリックします。PROFINET IO モジュールの [Networked] ステータスが [No] になっている場合は、[Properties] ボタンをクリックして、新しいサブネットを追加します。
    • CPU 上の PROFINET IO インタフェースがサブネットに割り当てられたら、PROFINET　IO システムをハードウェア構成図に追加します。そのためには、PLC コンフィグレーションの PROFINET IO モジュールを右クリックして、[Insert PROFINET IO System] を選択します。

  4. これが PROFINET ネットワークに追加される初めての In-Sight ビジョンシステムである場合は、In-Sight GSD ファイル (弊社支給のバージョン 2.3) をインストールする必要があります。In-Sight GSD ファイルをインストールするには、次の手順で行います。

    • HW Config ツールのメニューから、[オプション] → [Install GSD Files (GSD ファイルのインストール)] を選択します。
    • [参照] ボタンを押し、次の場所から GSD フォルダを選択します。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.0\Factory Protocol Description\GSD
    • [Select All (すべて選択)] ボタンを押し、続いて [Install (インストール)] ボタンをクリックして、ハードウェア記述をインストールします。

    In-Sight ビジョンシステムを PROFINET ネットワークに追加するには、Hardware Catalog の In-Sight ノードを参照して ([PROFINET IO] → [Additional Field Devices] → [Sensors] → [Cognex Vision Sensors])、In-Sight ビジョンシステムのインスタンスをハードウェア構成内の PROFINET IO システムにドラッグします。

  5. デバイス名を、接続接続されている In-Sight ビジョンシステムの正確な名前に設定します。

    注: In-Sight ビジョンシステムの名前にアンダースコアが使用されていた場合は、ビジョンシステムの名前を PROFINET に入力するときに、アンダースコアをハイフンに置き換える必要があります。例えば、In-Sight Explorer でのカメラの名前が「Camera_Top」の場合は、PROFINET では「Camera-Top」に変更する必要があります。

  6. これで、In-Sight ビジョンシステムが PROFINET IO システム上のデバイスとして表示され、特定の PROFINET IO 実装によってサポートされる In-Sight ビジョンシステムの各種モジュールも表示されます。

    注:In-Sight ビジョンシステムを PROFINET IO システム上のデバイスに追加したら、PLC によって新しい IP アドレスがビジョンシステムに割り当てられないようにするには、ビジョンシステムの [プロパティ] ダイアログの [IP アドレスを IO コントローラ経由で割り当てる] チェックボックスをオフにします。[プロパティ] ダイアログを開いてチェックボックス (デフォルトでオンになっています) をオフにするには、ビジョンシステムデバイスをダブルクリックするか、または右クリックして [オブジェクトのプロパティ] を選択します。

    Closed ヒント: Siemens Step 7 ソフトウェアを使用して PLC を設定する場合は、ここをクリックします。

    Siemens Step 7 ソフトウェアは、In-Sight GSD ファイル内の各モジュールの定義に基づいて、In-Sight ビジョンシステム用に追加された各モジュールにデフォルトの I/O アドレスを割り当てます (上の図を参照)。これらの I/O アドレスのいくつかまたはすべてを変更することができます。ディスクリートビットデータを細かく決定するモジュール (画像取り込み制御とステータス、検査制御とステータス、およびソフトイベント制御) はすべて、PLC の画像処理入力および出力メモリ領域内のアドレスに割り当てる必要があります。Siemens S7 シリーズ PLC の最新のファームウェアを使用すると、このメモリ領域のサイズを変更することができます (デフォルトのサイズは 256 バイトです。I0.0 ～ I255.7、Q0.0 ～ Q255.7)。設定機能がない以前のファームウェアやモデル (Siemens PLC のドキュメントを参照) ではサイズは固定されており、通常 256 バイトです。上の図からもわかるように、各ディスクリートビットデータモジュールは 0 から始まる I/O アドレスにマップされており、バイト/ワードモジュールは、PLC の画像処理入力および出力メモリ領域のすぐ上から始まるアドレス (256 以上) に割り当てられます。

    一般的なユースケースでは、下の図に示されるような構成になっています。つまり、Step 7 ソフトウェアの割り当てより隣接しているブロック内に各 In-Sight ビジョンシステムの I/O アドレスが割り当てられています。PLC ロジックが新しい I/O ビットアドレスにアクセスするためには、Step 7 ソフトウェアの HW 設定で PLC (CPU) のプロパティを開いて、ダイアログの [Cycle/Clock Memory] タブの [Size of the process-image input area] と [Size of the process-image output area] に移動します。例では、入力および出力領域のサイズは 912 に変更されています。これは、ビジョンシステム用の PLC の I および Q アドレスを使用して、In-Sight ビジョンシステムのディスクリートビットデータにアクセス可能にするためです。これらの画像処理サイズを変更しないと、ビット値の読み取りや書き込みが正しく行われません。ただし、バイト/ワード値は正しく更新されます。これらの画像処理サイズが変更された場合に必要になる追加のメモリオーバヘッドについては、Siemens PLC のドキュメントを参照してください。

    In-Sight ビジョンシステムの使用可能なモジュールのすべてが、自動的にハードウェア構成に追加されます。これらのモジュールによって、In-Sight ビジョンシステムの各種サブシステムへのアクセスが可能になります。デフォルトの UserData および InspectionResults モジュールのサイズは 64 バイトです。モジュールのサイズを変更するためには、リストからモジュールを削除して、[Catalog] ツリー内の [In-Sight Data Modules] フォルダにある適切なサイズのモジュールをリストの [Slot] にドラッグします。

  7. HW Config ユーティリティで In-Sight ビジョンシステムを PROFINET システムに追加した後、PROFINET IO システムのプロパティウィンドウを開いて、周期転送率を調整することができます。このためには、ハードウェア構成図の [PROFINET IO System] をダブルクリックします。周期更新時間は、PROFINET IO システム全体について、または各デバイスについて設定することができます。

    注: 更新時間をデフォルト値の 1ms のままにした場合、PLC が In-Sight ビジョンシステムに接続されているときに、ビジョンツールのパフォーマンスが大幅に低下することがあります。パフォーマンスの低下を緩和するには、周期更新時間を 8ms または 16ms に変更します。

例: 接続のセットアップ

この例では、In-Sight ビジョンシステムが Siemens プロジェクトの入出力デバイスとして追加されていることを前提としています。プロジェクトがコントローラにダウンロードされた後、要求した更新時間で、周期データ転送が開始されます。適切な I/O 接続を確認するには、次の手順を実行します。

  1. オフラインのときに、「接続のセットアップ」のセクションに記載されている Siemens の構成手順を実行します。
  2. 完成したプロジェクトを Siemens コントローラにダウンロードして、[Operating Mode] を [Run] に設定します。
  3. オンラインで、HW Config ツールを開きます。In-Sight ビジョンシステムのエラーが表示されなければ、I/O 接続は正常に完了しています。
  4. In-Sight ビジョンシステムと Siemens コントローラの間の I/O データの正しい双方向転送を確認するには、In-Sight Explorer を使用して In-Sight ビジョンシステムに接続します。In-Sight ビジョンシステムのスプレッドシートビューから、AcquireImage プロパティシートを開き、[トリガ] パラメータを [外部] または [産業用イーサネット] に設定します。次に、ビジョンシステムをオンラインにします。

  5. HW Config ツールから、In-Sight ビジョンシステムを選択し、[Acquisition Control Module] を右クリックして、[Monitor/Modify] を選択します。

  6. 次に、入力ビット 0 を [false] から [true] に変更します。これによって、Acquisition Trigger Enable ビットが有効になります。

  7. このビットをセットすると、入力ビット 1 (Acquisition Trigger) が false から true に変更されたときに、In-Sight ビジョンシステムは画像を取り込みます。
  8. Inspection Status モジュールの [Monitor/Modify] ウィンドウで、[Run conditionally] チェックボックスが [Monitor] についてオンになっていた場合、手順 7 を繰り返すと、検査の完了時に Inspection Completed ビット (ビット 1) の状態が変化することがわかります。

In-Sight ビジョンシステムからのデータの取得

In-Sight 4.x.x ファームウェアが実行されている In-Sight ビジョンシステムの In-Sight Explorer スプレッドシートから Siemens PLC にデータを取得するためには、WriteProfinetBuffer 関数を使用してデータを PROFINET スタックにプッシュする必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り込み、そのデータを PROFINET Inspection Results モジュールの検査結果領域に書き込みます。このデータは、次の更新サイクルの際に転送されます。

例: In-Sight ビジョンシステムからのデータの取得

以下の手順に従って、In-Sight ビジョンシステムから Siemens PLC に送信されるデータの書式設定の方法を説明します。

  1. まず、In-Sight Explorer を使用して、新規ジョブを作成します。
  2. [パレット] の [スニペット] タブから、次の 2 つのスニペットをスプレッドシートに追加します。[Acquisition] → [AcqCounter] および [Math & Logic] → [Random]
  3. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. データの最初の 4 バイトは自動的に PROFINET バッファに追加され、これによって InspectionID と InspectionResultCode が (16 ビットの整数として) 定義されますが、これらは FormatOutputBuffer リストには表示されません。
  6. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。Random スニペットの「Scaled random number」セルを選択します。

  7. [FormatOutputBuffer] ダイアログの [追加] ボタンを再びクリックします。これでセル選択モードになります。AcqCounter スニペットのカウントセルを選択します。

  8. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  9. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteProfinetBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  10. WriteProfinetBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  11. In-Sight ビジョンシステムをオンラインにします。
  12. Simatic Manager で、ご使用の PLC を右クリックし、[Insert New Object] メニューから [Variable Table] を選択して、新しい変数テーブルを作成します。新しい変数テーブルを開きます。

  13. テーブルに 2 つの項目を追加します。

    オフセット

    アドレス

    表示形式

    説明

    0

    PID 257

    FLOATING_POINT

    乱数

    +4

    PID 261

    DEC

    Acquisition ID

    注: 各アドレスは、Inspection Results モジュールが入力アドレス 253 にあることを前提としています (モジュールの最初の 4 バイトは、Inspection ID と Inspection Result Code 用です)。Inspection Results モジュールが別のアドレスにある場合は、指定したオフセットを入力アドレスに適用して、正しいアドレスに設定してください。

  14. Simatic Manager で、[PLC] → [Connect To] メニューから [Configured PLC] を開き、[Variable] メニューから [Monitor] を選択します。表示される値は、In-Sight Explorer スプレッドシートに表示されている値と同じになります。

In-Sight ビジョンシステムへのデータの送信

Siemens PLC から In-Sight Explorer スプレッドシートにデータを送信するためには、ReadProfinetBuffer 関数を使用して、データが PROFINET スタックからプルされる必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータ形式を取り、PROFINET User Data モジュールのデータ領域からデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに入れます。このデータは、更新サイクルごとに、PLC から受信されます。

例: In-Sight ビジョンシステムへのデータの送信

この例では、In-Sight Explorer 内に新規ジョブを作成した後、以下の手順を実行して、Siemens PLC が受信するデータを設定します。

  1. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  2. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。

  4. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックしてから、右側のペインで ReadProfinetBuffer 関数をダブルクリックし、その関数をスプレッドシートに挿入します。
  6. ReadProfinetBuffer 関数の [バッファ] パラメータを、作成したばかりの FormatInputBuffer 関数の　 [image] 　データ構造体へのセル参照として設定します。
  7. FormatInputBuffer 関数に追加されたフィールドに基づいて、データアクセス関数が自動的にスプレッドシートに追加されます。
  8. In-Sight ビジョンシステムをオンラインにします。
  9. Simatic Manager で、ご使用の PLC を右クリックし、[Insert New Object] メニューから [Variable Table] を選択して、新しい変数テーブルを作成します。新しい変数テーブルを開きます。

  10. テーブルに 2 つの項目を追加します。

    オフセット

    アドレス

    表示形式

    0

    PQD 257

    FLOATING_POINT

    +4

    PQD 261

    DEC

    注: 各アドレスは、User Data モジュールが出力アドレス 257 にあることを前提としています。User Data モジュールが別のアドレスにある場合は、指定したオフセットを出力アドレスに適用して、正しいアドレスに設定してください。

  11. Simatic Manager で、[PLC] → [Connect To] → [Configured PLC] メニューをクリックします。

  12. 変数テーブルに追加した 2 つの項目の値を入力して、[Variable] メニューの [Activate Modify Values] を選択します。

  13. In-Sight Explorer スプレッドシートの値が、入力した値に変更されます。
Version: 5.6.0


PROFINET 経由での In-Sight ビジョンシステムによるデータ転送 - In-Sight 5.x.x ファームウェア

PROFINET による通信

In-Sight 通信リファレンス

このトピックでは、In-Sight 5.1.0 以降のファームウェアが実行されている In-Sight ビジョンシステム、および Siemens PLC との間で行われるデータ転送について説明します。

  • In-Sight ビジョンシステムでの PROFINET 通信の有効化
  • 接続のセットアップ
  • In-Sight ビジョンシステムからのデータの取得
  • In-Sight ビジョンシステムへのデータの送信

In-Sight ビジョンシステムでの PROFINET 通信の有効化

In-Sight ビジョンシステムと PROFINET 通信を確立するためには、In-Sight ビジョンシステムの [ネットワークの設定] を使用して、PROFINET が有効になるようにビジョンシステムを設定しておく必要があります。

  1. In-Sight Explorer を開き、In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから [ネットワークの設定] ダイアログを開きます。

  3. ダイアログの [プロトコルサービス] セクションで、[PROFINET] を選択し、[PROFINET Settings (PROFINET 設定)] ダイアログを使用して、Siemens PLC の場合のように [設定] ボタンを押してビジョンシステムの [ステーション名] を有効化して設定します。

    注: [ステーション名] を設定しないと、PLC ではホスト名を参照しますが、サポートされない文字がサポートされる文字に PROFINET プロトコルによって変換されるため、そのホスト名はビジョンシステムのホスト名と同一ではない可能性があります。

  4. [ネットワークの設定] ダイアログに戻り、[OK] を押します。
  5. In-Sight ビジョンシステムを再起動すると、電源の再投入後 PROFINET サービスが有効になります。

接続のセットアップ

In-Sight ビジョンシステムと Siemens コントローラの間の PROFINET I/O 接続をセットアップするには、最初に、Siemens の HW Config ツールを使用して、In-Sight ビジョンシステムをコントローラのハードウェア構成に追加する必要があります。

  1. SIMATIC マネージャを開き、PLC のプロジェクトをロードします。

  2. [SIMATIC 300] または [SIMATIC 400] ノードを選択して、オブジェクトリストの [Hardware] ノードをダブルクリックします。

  3. HW Config (ハードウェア設定) ツールが表示されます。PROFINET IO ノードをコントローラに追加するには、PROFINET IO システムがハードウェア設定ダイアグラムに存在する必要があります。PROFINET IO システムがハードウェア設定ダイアグラムに存在しない場合、次の操作を行います。

    • CPU 上の PROFINET IO インタフェースにサブネットアドレスが割り当てられていることを確認してください。これを検証するには、CPU 上の PROFINET IO モジュールをダブルクリックします。PROFINET IO モジュールの [Networked] ステータスが [No] になっている場合は、[Properties] ボタンをクリックして、新しいサブネットを追加します。
    • CPU 上の PROFINET IO インタフェースがサブネットに割り当てられたら、PROFINET　IO システムをハードウェア構成図に追加します。そのためには、PLC コンフィグレーションの PROFINET IO モジュールを右クリックして、[Insert PROFINET IO System] を選択します。

  4. これが PROFINET ネットワークに追加される初めての In-Sight ビジョンシステムである場合は、In-Sight GSD ファイル (弊社支給のバージョン 2.3) をインストールする必要があります。In-Sight GSD ファイルをインストールするには、次の手順で行います。

    • HW Config ツールのメニューから、[オプション] → [Install GSD Files (GSD ファイルのインストール)] を選択します。
    • [参照] ボタンを押し、次の場所から GSD フォルダを選択します。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.0\Factory Protocol Description\GSD
    • [Select All (すべて選択)] ボタンを押し、続いて [Install (インストール)] ボタンをクリックして、ハードウェア記述をインストールします。

    In-Sight ビジョンシステムを PROFINET ネットワークに追加するには、Hardware Catalog の In-Sight ノードを参照して ([PROFINET IO] → [Additional Field Devices] → [Sensors] → [Cognex Vision Sensors])、In-Sight ビジョンシステムのインスタンスをハードウェア構成内の PROFINET IO システムにドラッグします。

  5. デバイス名を、接続接続されている In-Sight ビジョンシステムの正確な名前に設定します。

    注: In-Sight ファームウェア 5.x.x を反映するデバイスを確実に選択します。これらのデバイスには、デバイス名に付加されるファームウェアバージョンが含まれています (例えば、上記の In-Sight 54XX51XX)。このファームウェアバージョンがデバイス名に付加されていないデバイスでは、In-Sight 4.x.x ファームウェアが実行されています。

    注: In-Sight ビジョンシステムの名前にアンダースコアが使用されていた場合は、ビジョンシステムの名前を PROFINET に入力するときに、アンダースコアをハイフンに置き換える必要があります。例えば、In-Sight Explorer でのカメラの名前が「Camera_Top」の場合は、PROFINET では「Camera-Top」に変更する必要があります。

  6. これで、In-Sight ビジョンシステムが PROFINET IO システム上のデバイスとして表示され、特定の PROFINET IO 実装によってサポートされる In-Sight ビジョンシステムの各種モジュールも表示されます。

    注:In-Sight ビジョンシステムを PROFINET IO システム上のデバイスに追加したら、PLC によって新しい IP アドレスがビジョンシステムに割り当てられないようにするには、ビジョンシステムの [プロパティ] ダイアログの [IP アドレスを IO コントローラ経由で割り当てる] チェックボックスをオフにします。[プロパティ] ダイアログを開いてチェックボックス (デフォルトでオンになっています) をオフにするには、ビジョンシステムデバイスをダブルクリックするか、または右クリックして [オブジェクトのプロパティ] を選択します。
    Closed ヒント: Siemens Step 7 ソフトウェアを使用して PLC を設定する場合は、ここをクリックします。

    Siemens Step 7 ソフトウェアは、In-Sight GSD ファイル内の各モジュールの定義に基づいて、In-Sight ビジョンシステム用に追加された各モジュールにデフォルトの I/O アドレスを割り当てます (上の図を参照)。これらの I/O アドレスのいくつかまたはすべてを変更することができます。ディスクリートビットデータを細かく決定するモジュール (画像取り込み制御とステータス、検査制御とステータス、およびソフトイベント制御) はすべて、PLC の画像処理入力および出力メモリ領域内のアドレスに割り当てる必要があります。Siemens S7 シリーズ PLC の最新のファームウェアを使用すると、このメモリ領域のサイズを変更することができます (デフォルトのサイズは 256 バイトです。I0.0 ～ I255.7、Q0.0 ～ Q255.7)。設定機能がない以前のファームウェアやモデル (Siemens PLC のドキュメントを参照) ではサイズは固定されており、通常 256 バイトです。上の図からもわかるように、ディスクリートビットデータモジュールは 0 から始まる I/O アドレスにマップされています。また、バイト/ワードモジュールは、PLC の画像処理入力および出力メモリ領域のすぐ上から始まるアドレス (256 以上) に割り当てられます。

    一般的なユースケースでは、下の図に示されるような構成になっています。つまり、Step 7 ソフトウェアの割り当てより隣接しているブロック内に各 In-Sight ビジョンシステムの I/O アドレスが割り当てられています。PLC ロジックが新しい I/O ビットアドレスにアクセスするためには、Step 7 ソフトウェアの HW Config で PLC (CPU) のプロパティを開いて、ダイアログの [Cycle/Clock Memory] タブの [Size of the process-image input area] と [Size of the process-image output area] に移動します。例では、入力および出力領域のサイズは 912 に変更されています。これは、ビジョンシステム用の PLC の I および Q アドレスを使用して、In-Sight ビジョンシステムのディスクリートビットデータにアクセス可能にするためです。これらの画像処理サイズを変更しないと、ビット値の読み取りや書き込みが正しく行われません。ただし、バイト/ワード値は正しく更新されます。これらの画像処理サイズが変更された場合に必要になる追加のメモリオーバヘッドについては、Siemens PLC のドキュメントを参照してください。

    In-Sight ビジョンシステムの使用可能なモジュールのすべてが、自動的にハードウェア構成に追加されます。これらのモジュールによって、In-Sight ビジョンシステムの各種サブシステムへのアクセスが可能になります。デフォルトの UserData および InspectionResults モジュールは、64 バイトのサイズです。モジュールのサイズを変更するためには、リストからモジュールを削除して、[Catalog] ツリー内の [In-Sight Data Modules] フォルダにある適切なサイズのモジュールをリストの [Slot] にドラッグします。

  7. HW Config ユーティリティで In-Sight ビジョンシステムを PROFINET システムに追加したら、周期転送率を調整することができます。転送率を調整するには、ビジョンシステムをダブルクリックして、更新時間を 16 ms 秒以内の値に設定します。更新時間をデフォルト値の 1ms のままにした場合、PLC が In-Sight ビジョンシステムに接続されているときに、ビジョンツールのパフォーマンスが大幅に低下することがあります。パフォーマンスの低下を緩和するには、周期更新時間を 8ms または 16ms に変更します。

例: 接続のセットアップ

この例では、In-Sight ビジョンシステムが Siemens プロジェクトの入出力デバイスとして追加されていることを前提としています。プロジェクトがコントローラにダウンロードされた後、要求した更新時間で、周期データ転送が開始されます。適切な I/O 接続を確認するには、次の手順を実行します。

  1. オフラインのときに、「接続のセットアップ」のセクションに記載されている Siemens の構成手順を実行します。
  2. 完成したプロジェクトを Siemens コントローラにダウンロードして、[Operating Mode] を [Run] に設定します。
  3. オンラインで、HW Config ツールを開きます。In-Sight ビジョンシステムのエラーが表示されなければ、I/O 接続は正常に完了しています。
  4. In-Sight ビジョンシステムと Siemens コントローラの間の I/O データの正しい双方向転送を確認するには、In-Sight Explorer を使用して In-Sight ビジョンシステムに接続します。In-Sight ビジョンシステムのスプレッドシートビューから、AcquireImage プロパティシートを開き、[トリガ] パラメータを [外部] または [産業用イーサネット] に設定します。次に、ビジョンシステムをオンラインにします。

  5. HW Config ツールから、In-Sight ビジョンシステムを選択し、[Acquisition Control Module] を右クリックして、[Monitor/Modify] を選択します。

  6. 次に、入力ビット 0 を [false] から [true] に変更します。これによって、Acquisition Trigger Enable ビットが有効になります。

  7. このビットをセットすると、In-Sight ビジョンシステムは、入力ビット 1 (Acquisition Trigger) が false から true に変更されるときにはいつでも画像を取り込みます。
  8. Inspection Status モジュールの [Monitor/Modify] ウィンドウで、[Run conditionally] チェックボックスが [Monitor] についてオンになっていた場合、手順 7 を繰り返すと、検査の完了時に Inspection Completed ビット (ビット 1) の状態が変化することがわかります。

In-Sight ビジョンシステムからのデータの取得

In-Sight 5.1.0 以降のファームウェアが実行されている In-Sight ビジョンシステムの In-Sight Explorer スプレッドシートから Siemens PLC にデータを取得するためには、WriteResultsBuffer 関数を使用してデータを PROFINET スタックにプッシュする必要があります。この関数は、FormatOutputBuffer 関数によって作成されたデータのバッファを取り込み、そのデータを PROFINET Inspection Results モジュールの検査結果領域に書き込みます。このデータは、次の更新サイクルの際に転送されます。

例: In-Sight ビジョンシステムからのデータの取得

以下の手順に従って、In-Sight ビジョンシステムから Siemens PLC に送信されるデータの書式設定の方法を説明します。

  1. まず、In-Sight Explorer を使用して、新規ジョブを作成します。
  2. [パレット] の [スニペット] タブから、次の 2 つのスニペットをスプレッドシートに追加します。[Acquisition] → [AcqCounter] および [Math & Logic] → [Random]
  3. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  4. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatOutputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  5. データの最初の 4 バイトは自動的に PROFINET バッファに追加され、これによって InspectionID と InspectionResultCode が (16 ビットの整数として) 定義されますが、これらは FormatOutputBuffer リストには表示されません。
  6. [FormatOutputBuffer] ダイアログの [追加] ボタンをクリックします。これでセル選択モードになります。Random スニペットの「Scaled random number」セルを選択します。

  7. [FormatOutputBuffer] ダイアログの [追加] ボタンを再びクリックします。これでセル選択モードになります。AcqCounter スニペットのカウントセルを選択します。

  8. [OK] ボタンをクリックして、[FormatOutputBuffer] ダイアログを閉じます。
  9. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで WriteResultsBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  10. WriteResultsBuffer 関数の [プロトコル] パラメータを [PROFINET に設定し、[バッファ] パラメータを、作成した FormatOutputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  11. In-Sight ビジョンシステムをオンラインにします。
  12. Simatic Manager で、ご使用の PLC を右クリックし、[Insert New Object] メニューから [Variable Table] を選択して新しい変数テーブルを作成し、そのテーブルを開きます。

  13. テーブルに 4 つの項目を追加します。

    オフセット

    アドレス

    表示形式

    説明

    0

    PID 257

    FLOATING_POINT

    乱数

    +4

    PID 261

    DEC

    Acquisition ID

    注: 各アドレスは、Inspection Results モジュールが入力アドレス 253 にあることを前提としています (モジュールの最初の 4 バイトは、Inspection ID と Inspection Result Code 用です)。Inspection Results モジュールが別のアドレスにある場合は、指定したオフセットを入力アドレスに適用して、正しいアドレスに設定してください。

  14. Simatic Manager で、[PLC] → [Connect To] メニューから [Configured PLC] を開き、[Variable] メニューから [Monitor] を選択します。表示される値は、In-Sight Explorer スプレッドシートに表示されている値と同じになります。

In-Sight ビジョンシステムへのデータの送信

Siemens PLC から In-Sight Explorer スプレッドシートにデータを送信するためには、ReadUserDataBuffer 関数を使用して、データが PROFINET スタックからプルされる必要があります。この関数は、FormatInputBuffer 関数内で作成されたデータ形式を取り、PROFINET User Data モジュールのデータ領域からデータを読み取って、このデータを書式設定して In-Sight Explorer スプレッドシートに入れます。このデータは、更新サイクルごとに、PLC から受信されます。

例: In-Sight ビジョンシステムへのデータの送信

この例では、In-Sight Explorer 内に新規ジョブを作成した後、以下の手順を実行して、Siemens PLC が受信するデータを設定します。

  1. AcquireImage セルを開いて、[トリガ] パラメータを [連続] に設定します。
  2. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで FormatInputBuffer 関数をダブルクリックして、スプレッドシートに挿入します。

  3. [FormatInputBuffer] ダイアログの [追加] ボタンをクリックして、32 ビットの浮動小数点数と 32 ビットの整数をリストに追加します。

  4. [OK] ボタンをクリックして、[FormatInputBuffer] ダイアログを閉じます。
  5. 空白のセルを右クリックして [関数の挿入] を選択し、[関数の挿入] ダイアログを開きます。左側のペインで [入出力] カテゴリをクリックし、その後、右側のペインで ReadUserDataBuffer 関数をダブルクリックして、スプレッドシートに挿入します。
  6. ReadUserDataBuffer 関数の [プロトコル] パラメータを [PROFINET に設定し、[バッファ] パラメータを、作成した FormatInputBuffer 関数の [image] データ構造体へのセル参照として設定します。
  7. FormatInputBuffer 関数に追加されたフィールドに基づいて、データアクセス関数が自動的にスプレッドシートに追加されます。
  8. In-Sight ビジョンシステムをオンラインにします。
  9. Simatic Manager で、ご使用の PLC を右クリックし、[Insert New Object] メニューから [Variable Table] を選択して新しい変数テーブルを作成し、そのテーブルを開きます。

  10. 送信されるユーザデータ用に 2 つと、SetUserData および SetUserDataAck 用に残りの 2 つで、4 つの項目をテーブルに追加します。

    オフセット

    アドレス

    表示形式

    0

    PQD 257

    FLOATING_POINT

    +4

    PQD 261

    DEC
    Q1.2 | BOOL
    I4.7 | BOOL

    注: 各アドレスは、User Data モジュールが出力アドレス 257 にあることを前提としています。User Data モジュールが別のアドレスにある場合は、指定したオフセットを出力アドレスに適用して、正しいアドレスに設定してください。

  11. Simatic Manager で、[PLC] → [Connect To] → [Configured PLC] メニューをクリックします。
  12. 変数テーブルに追加した 4 つの項目の値を入力して、[Variable] メニューの [Activate Modify Values] を選択します。

  13. 値を入力したら、SetUserData ビットをセットし、SetUserDataAck ビットがセットされるまで待ってから、SetUserData ビットをクリアします。

  14. In-Sight Explorer スプレッドシートの値が、入力した値に変更されます。
Version: 5.6.0


PROFINET IO モジュールを使用して名前によりジョブを開く

PROFINET 通信

In-Sight 通信リファレンス
注: 名前によってジョブを開く機能は、In-Sight ファームウェア 5.5.0 以降が実行されている In-Sight ビジョンシステムでのみ使用できます。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  1. Set Offline ビットをハイ (High) にセットすることにより、カメラをオフラインにします。

    モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    Acquisition

    Control

             0x101 0

    Set

    Offline

             Reserved

    Clear

    Exposure

    Complete

             Trigger

    Trigger

    Enable

    Acquisition

    Status

             0x201 0 Online Offline Reason

    Missed

    Acq

    Exposure

    Complete

    Trigger

    Ack

    Trigger

    Ready
    1..2 | Acquisition ID

    Inspection

    Control

             0x102 0

    Clear

    Error

             Reserved

    Execute

    Command

    Set User

    Data

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

    Inspection

    Status

             0x203 0

    Set User

    Data Ack

    Command

    Failed

    Command

    Complete

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    1 Error Reserved Reserved

    Job

    Pass
    2..3 | エラーコード

    Command

    Control

    Input

             0x107 0..1 Command (16 ビット)

    Command

    Control

    Output

             0x107 0..1 Current Job ID (16 ビット)

    Soft Event

    Control Input

             0x106 0

    Soft Event

    7

    Soft Event

    6

    Soft Event

    5

    Soft Event

    4

    Soft Event

    3

    Soft Event

    2

    Soft Event

    1

    Soft Event

    0

    Soft Event

    Control Output

             0x106 0

    Soft Event

    Ack 7

    Soft Event

    Ack 6

    Soft Event

    Ack 5

    Soft Event

    Ack 4

    Soft Event

    Ack 3

    Soft Event

    Ack 2

    Soft Event

    Ack 1

    Soft Event

    Ack 0

    User Data

    0x301(16)

    0x302(32)

    0x303(64)

    0x304(128)

    0x305(254)

             0.. User Data

    Inspection Results

    0x401(16)

    0x402(32)

    0x403(64)

    0x404(128)

    0x405(250)

             0..1 Inspection ID
    2..3 | Inspection Results Code
    4.. | Inspection Results

    Acquisition Control モジュール

    ビット

    名前

    説明

    7

    Set Offline

    このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。

  2. Command Control Input モジュールのバイト 0 と 1 に Job Load by Name コマンドを書き込みます。Job Load by Name コマンドの値は 0x4000 です。

    モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    Acquisition

    Control

             0x101 0

    Set

    Offline

             Reserved

    Clear

    Exposure

    Complete

             Trigger

    Trigger

    Enable

    Acquisition

    Status

             0x201 0 Online Offline Reason

    Missed

    Acq

    Exposure

    Complete

    Trigger

    Ack

    Trigger

    Ready
    1..2 | Acquisition ID

    Inspection

    Control

             0x102 0

    Clear

    Error

             Reserved

    Execute

    Command

    Set User

    Data

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

    Inspection

    Status

             0x203 0

    Set User

    Data Ack

    Command

    Failed

    Command

    Complete

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    1 Error Reserved Reserved

    Job

    Pass
    2..3 | エラーコード

    Command

    Control

    Input

             0x107 0..1 Command (16 ビット)

    Command

    Control

    Output

             0x107 0..1 Current Job ID (16 ビット)

    Soft Event

    Control Input

             0x106 0

    Soft Event

    7

    Soft Event

    6

    Soft Event

    5

    Soft Event

    4

    Soft Event

    3

    Soft Event

    2

    Soft Event

    1

    Soft Event

    0

    Soft Event

    Control Output

             0x106 0

    Soft Event

    Ack 7

    Soft Event

    Ack 6

    Soft Event

    Ack 5

    Soft Event

    Ack 4

    Soft Event

    Ack 3

    Soft Event

    Ack 2

    Soft Event

    Ack 1

    Soft Event

    Ack 0

    User Data

    0x301(16)

    0x302(32)

    0x303(64)

    0x304(128)

    0x305(254)

             0.. User Data

    Inspection Results

    0x401(16)

    0x402(32)

    0x403(64)

    0x404(128)

    0x405(250)

             0..1 Inspection ID
    2..3 | Inspection Results Code
    4.. | Inspection Results

    Command Control Input モジュール

    バイト | 名前 | 説明
    0 ～ 1 | Command | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。

  3. ジョブ名を User Data モジュールに書き込みます。ジョブ名は null で終了する必要があります (バイト内のジョブ名の直後に 0 を付加する必要があります)。

    モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    Acquisition

    Control

             0x101 0

    Set

    Offline

             Reserved

    Clear

    Exposure

    Complete

             Trigger

    Trigger

    Enable

    Acquisition

    Status

             0x201 0 Online Offline Reason

    Missed

    Acq

    Exposure

    Complete

    Trigger

    Ack

    Trigger

    Ready
    1..2 | Acquisition ID

    Inspection

    Control

             0x102 0

    Clear

    Error

             Reserved

    Execute

    Command

    Set User

    Data

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

    Inspection

    Status

             0x203 0

    Set User

    Data Ack

    Command

    Failed

    Command

    Complete

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    1 Error Reserved Reserved

    Job

    Pass
    2..3 | エラーコード

    Command

    Control

    Input

             0x107 0..1 Command (16 ビット)

    Command

    Control

    Output

             0x107 0..1 Current Job ID (16 ビット)

    Soft Event

    Control Input

             0x106 0

    Soft Event

    7

    Soft Event

    6

    Soft Event

    5

    Soft Event

    4

    Soft Event

    3

    Soft Event

    2

    Soft Event

    1

    Soft Event

    0

    Soft Event

    Control Output

             0x106 0

    Soft Event

    Ack 7

    Soft Event

    Ack 6

    Soft Event

    Ack 5

    Soft Event

    Ack 4

    Soft Event

    Ack 3

    Soft Event

    Ack 2

    Soft Event

    Ack 1

    Soft Event

    Ack 0

    User Data

    0x301(16)

    0x302(32)

    0x303(64)

    0x304(128)

    0x305(254)

             0.. User Data

    Inspection Results

    0x401(16)

    0x402(32)

    0x403(64)

    0x404(128)

    0x405(250)

             0..1 Inspection ID
    2..3 | Inspection Results Code
    4.. | Inspection Results

  4. Inspection Control モジュールの Execute Command ビットをセットします。

    モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    Acquisition

    Control

             0x101 0

    Set

    Offline

             Reserved

    Clear

    Exposure

    Complete

             Trigger

    Trigger

    Enable

    Acquisition

    Status

             0x201 0 Online Offline Reason

    Missed

    Acq

    Exposure

    Complete

    Trigger

    Ack

    Trigger

    Ready
    1..2 | Acquisition ID

    Inspection

    Control

             0x102 0

    Clear

    Error

             Reserved

    Execute

    Command

    Set User

    Data

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

    Inspection

    Status

             0x203 0

    Set User

    Data Ack

    Command

    Failed

    Command

    Complete

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    1 Error Reserved Reserved

    Job

    Pass
    2..3 | エラーコード

    Command

    Control

    Input

             0x107 0..1 Command (16 ビット)

    Command

    Control

    Output

             0x107 0..1 Current Job ID (16 ビット)

    Soft Event

    Control Input

             0x106 0

    Soft Event

    7

    Soft Event

    6

    Soft Event

    5

    Soft Event

    4

    Soft Event

    3

    Soft Event

    2

    Soft Event

    1

    Soft Event

    0

    Soft Event

    Control Output

             0x106 0

    Soft Event

    Ack 7

    Soft Event

    Ack 6

    Soft Event

    Ack 5

    Soft Event

    Ack 4

    Soft Event

    Ack 3

    Soft Event

    Ack 2

    Soft Event

    Ack 1

    Soft Event

    Ack 0

    User Data

    0x301(16)

    0x302(32)

    0x303(64)

    0x304(128)

    0x305(254)

             0.. User Data

    Inspection Results

    0x401(16)

    0x402(32)

    0x403(64)

    0x404(128)

    0x405(250)

             0..1 Inspection ID
    2..3 | Inspection Results Code
    4.. | Inspection Results

    Inspection Control モジュール

    ビット

    名前

    説明
    3 Execute Command

    設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。

  5. Execute Command ビットと Offline ビットをクリアする前に、Command Complete または Command Failed がセットされるのを待ちます。

    モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0

    Acquisition

    Control

             0x101 0

    Set

    Offline

             Reserved

    Clear

    Exposure

    Complete

             Trigger

    Trigger

    Enable

    Acquisition

    Status

             0x201 0 Online Offline Reason

    Missed

    Acq

    Exposure

    Complete

    Trigger

    Ack

    Trigger

    Ready
    1..2 | Acquisition ID

    Inspection

    Control

             0x102 0

    Clear

    Error

             Reserved

    Execute

    Command

    Set User

    Data

    Inspection

    Results

    Ack

    Buffer

    Results

    Enable

    Inspection

    Status

             0x203 0

    Set User

    Data Ack

    Command

    Failed

    Command

    Completed

    Command

    Executing

    Results

    Valid

    Results

    Buffer

    Overrun

    Inspection

    Completed

    System

    Busy
    1 Error Reserved Reserved

    Job

    Pass
    2..3 | エラーコード

    Command

    Control

    Input

             0x107 0..1 Command (16 ビット)

    Command

    Control

    Output

             0x107 0..1 Current Job ID (16 ビット)

    Soft Event

    Control Input

             0x106 0

    Soft Event

    7

    Soft Event

    6

    Soft Event

    5

    Soft Event

    4

    Soft Event

    3

    Soft Event

    2

    Soft Event

    1

    Soft Event

    0

    Soft Event

    Control Output

             0x106 0

    Soft Event

    Ack 7

    Soft Event

    Ack 6

    Soft Event

    Ack 5

    Soft Event

    Ack 4

    Soft Event

    Ack 3

    Soft Event

    Ack 2

    Soft Event

    Ack 1

    Soft Event

    Ack 0

    User Data

    0x301(16)

    0x302(32)

    0x303(64)

    0x304(128)

    0x305(254)

             0.. User Data

    Inspection Results

    0x401(16)

    0x402(32)

    0x403(64)

    0x404(128)

    0x405(250)

             0..1 Inspection ID
    2..3 | Inspection Results Code
    4.. | Inspection Results

    Inspection Status モジュール

    ビット

    名前

    説明

    4

    Command Executing

    Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。

    5

    Command Completed

    コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。

    注: Execute Command ビットが Low になると、カメラは Command Completed ビットをクリアします。

    6

    Command Failed

    このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
Version: 5.6.0


PROFINET IO モジュールリファレンス

PROFINET 通信

In-Sight 関数リファレンス

このセクションのトピックでは、PROFINET IO モジュールのリファレンステーブルについて説明します。PROFINET を介して公開されるモジュールレイアウトは、In-Sight ビジョンシステムで実行されている In-Sight ファームウェアに応じて異なります。

  • PROFINET I/O モジュールリファレンス - In-Sight 5.x.x ファームウェア
  • PROFINET I/O モジュールリファレンス - In-Sight 4.x.x ファームウェア
Version: 5.6.0


PROFINET IO モジュールリファレンステーブル - In-Sight 4.x.x ファームウェア

PROFINET 通信

In-Sight 関数リファレンス

このトピックでは、PROFINET IO モジュールリファレンステーブルと、GSD ファイルのバージョン 2.3 と組み合わせて In-Sight 4.x.x ファームウェアが実行されている In-Sight ビジョンシステムのテーブルに格納されている信号について説明します。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  • PROFINET I/O モジュールリファレンステーブルとモジュールの説明
  • PROFINET タイミング図 - バッファリングありとバッファリングなし

PROFINET IO モジュールリファレンステーブルとモジュールの説明

  • PROFINET IO モジュールリファレンステーブル - In-Sight ファームウェアバージョン 4.10.x
  • PROFINET IO モジュールリファレンステーブル - In-Sight ファームウェアバージョン 4.9.x 以前
    • Acquisition Control モジュール
    • Acquisition Status モジュール
    • Inspection Control モジュール
    • Inspection Status モジュール
    • Job Control Input/Output モジュール
    • Soft Event Control Input モジュール
    • User Data モジュール
    • Inspection Results モジュール

PROFINET IO モジュールリファレンステーブル - In-Sight ファームウェアバージョン 4.10.x

モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Acquisition Control | 0x101 | 0 | Set Offline | Reserved |  |  |  |  | Trigger | Trigger Enable
Acquisition Status | 0x201 | 0 | Online | Offline Reason |  |  | Missed Acq | Acquiring | Trigger Ack | Trigger Ready
 |  | 1..2 | Acquisition ID
Inspection Control | 0x102 | 0 | Reserved |  |  |  | Execute Command | Set User Data | Inspection Results Ack | Buffer Results Enable
Inspection Status | 0x202 | 0 | Set User Data Ack | Command Failed | Command Complete | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | Inspecting
 |  | 1 | Reserved |  |  |  |  |  | TestRun Ready | Job Pass
Job Control Input | 0x103 (デフォルト) | 0 | Job Load ID (8 ビット) (デフォルト) 注: TestRun は 8 ビットモジュールではサポートされません。デフォルトでは、8 ビットモジュールがロードされます。TestRun を使用するには、8 ビットモジュールを手動で削除し、16 ビットモジュールで置き換える必要があります。
Command Control Input | 0x107 | 0..1 | Command (16 ビット) (missing or bad snippet)
Job Control Output | 0x103 (デフォルト) | 0 | Current Job ID (8 ビット) (デフォルト)
Command Control Output | 0x107 | 0..1 | Current Job ID (16 ビット)
Soft Event Control Input | 0x105 | 0 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
User Data | 0x301(16) 0x302(32) 0x303(64) 0x304(128) 0x305(254) | 0.. | User Data
Inspection Results | 0x401(16) 0x402(32) 0x403(64) 0x404(128) 0x405(250) | 0..1 | Inspection ID
 |  | 2..3 | Inspection Result Code
 |  | 4.. | Inspection Results

PROFINET IO モジュールリファレンステーブル - In-Sight ファームウェアバージョン 4.9.x 以前

モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Acquisition Control | 0x101 | 0 | Set Offline | Reserved |  |  |  |  | Trigger | Trigger Enable
Acquisition Status | 0x201 | 0 | Online | Offline Reason |  |  | Missed Acq | Acquiring | Trigger Ack | Trigger Ready
 |  | 1..2 | Acquisition ID
Inspection Control | 0x102 | 0 | Reserved |  |  |  |  | Set User Data | Inspection Results Ack | Buffer Results Enable
Inspection Status | 0x202 | 0 | Set User Data Ack | Job Load Failed | Job Load Complete | Job Loading | Results Valid | Results Buffer Overrun | Inspection Completed | Inspecting
 |  | 1 | Reserved |  |  |  |  |  |  | Job Pass
Job Control Input | 0x103 | 0 | Job Load ID (8 ビット)
Job Control Output | 0x103 | 0 | Current Job ID (8 ビット)
Soft Event Control Input | 0x105 | 0 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
User Data | 0x301(16) 0x302(32) 0x303(64) 0x304(128) 0x305(254) | 0.. | User Data
Inspection Results | 0x401(16) 0x402(32) 0x403(64) 0x404(128) 0x405(250) | 0..1 | Inspection ID
 |  | 2..3 | Inspection Result Code
 |  | 4.. | Inspection Results

Acquisition Control モジュール

Acquisition Control モジュールと Acquisition Status モジュールのビットにより、PLC では、In-Sight ビジョンシステムで画像取り込みをトリガし、画像取り込みが完了した時期を判別し、ビジョンシステムをオフラインステータスにして画像取り込みトリガを受け入れないようにすることができます。

In-Sight ビジョンシステムの画像取り込みとオンライン/オフラインステータスを制御します。

ビット 名前 説明

0

Trigger Enable

このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

1

Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • AcquireImage 関数の [トリガ] パラメータは [ネットワーク] または [外部] に設定されます。

2 ～ 6

Reserved

未使用。

7

Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。

Acquisition Status モジュール

In-Sight ビジョンシステムの画像取り込みとオンライン/オフラインステータスを示します。

ビット 名前 説明

0

Trigger Ready

In-Sight ビジョンシステムが新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、ビジョンシステムが画像の取り込み中でないときに真になります。

1

Trigger Ack

In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。

2

Acquiring

In-Sight ビジョンシステムが画像を取り込み中であるときにセットされます。セットされる Trigger ビットによって、または外部トリガによってセットされます。

3

Missed Ack

In-Sight ビジョンシステムが画像取り込みトリガをミスしたときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

4 ～ 6

Offline Reason

このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

7

Online

このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。

8 ～ 23

Acquisition ID

この ID は、トリガソースに関係なく各画像取り込みが完了すると増分され、Acquisition とその Inspection Results を同期化するために使用できます。

一般的な画像取り込みシーケンス

注:ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

In-Sight ビジョンシステムは、Acquisition Control モジュールの Trigger Enable および Trigger ビットを直接操作するか、または Acquisition Status モジュールの Trigger Ready、Trigger Ack、Acquiring および Missed Acq ビットをモニタすることによってトリガできます。

最初の起動時には、Trigger Enable ビットは偽であり、トリガを有効にするには真にセットする必要があります。ビジョンシステムでトリガを受け入れる準備ができると、Acquisition Status モジュールの Trigger Ready ビットが真にセットされます。

Trigger Enable および Trigger Ready ビットが真である間は、Trigger ビットが 0 から 1 に変化するのがビジョンシステムで認識されるごとに、画像取り込みが開始されます。Acquisition Status モジュールの Trigger Ack ビットが同じ状態値になるまで、Trigger ビットを新しい状態で保持する必要があります (これは、ビジョンシステムが変化を確実に確認するために必要なハンドシェークです)。

画像の取り込み中、Acquisition Status モジュールの Trigger Ready ビットがクリアされ、Acquiring ビットが真にセットされます。画像取り込みが完了すると、Acquiring ビットがクリアされ、ビジョンシステムで新しい画像取り込みを開始する準備ができるとすぐに Trigger Ready ビットが再び真にセットされます。

トリガメカニズムを強制的にリセットするには、Acquisition Status モジュールが 0 になるまで Trigger Enable ビットを偽にセットします。Trigger Enable ビットを真に設定すると、画像取り込みが再度有効になります。

Inspection Control モジュール

Inspection Status モジュールと Inspection Control モジュールにより、PLC では、In-Sight ビジョンシステムのビジョン処理部分をモニタして新しい結果が出力される時期を判別し、新しい結果をキューに入れるようにビジョンシステムに要求できます。

ジョブの実行と検査結果の処理を制御します。

ビット | 名前 | 説明

0

Buffer Results Enable

このビットがセットされると、Inspection ID、Inspection Result、Inspection Results フィールドは、Inspection Results Ack フィールドが確認応答してセットされるまで変化しません。最大 8 つの検査がビジョンシステムのバッファに保持されます。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack フィールドがクリアされ、PLC に送信される新しいルールセットが存在する場合、Results Valid ビットはクリアされなくなります。Inspection Results Ack ビットがクリアされ、ビジョンシステムのバッファに PLC に送信される結果がほかにはなくなると、Results Valid ビットはクリアされたままになります。

1

Inspection Results Ack

Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。その後、次の検査結果のセットが PLC に送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。
2 Set User Data

この信号の立ち上がりエッジでユーザデータ保持バッファがユーザデータフィールドにラッチされ、ビジョンシステムにユーザデータへのアクセス権が付与されます。ビジョンシステムがコマンドを受信したことを保証するには、Inspection Status モジュールで Set User Data Ack ビットがアサートされるまで、PLC でこのビットが high に保持される必要があります。Profinet Write Record コマンドを使用して、ユーザデータ保持バッファに書き込むことができます。PROFINET 接続で User Data モジュールが設定されている場合に Set User Data 信号がアサートされると、モジュールアラームがアサートされます。
3 Execute Command (4.10.x)

TestRun を使用する場合は、この信号の立ち上がりエッジでコマンドが実行されて TestRun が開始されます。信号は Command Completed 信号がトグルされるまで high に維持される必要があります。この信号の立ち下がりエッジ (Command Complete の前) は、中止要求と解釈されます。

注: TestRun は 16 ビットの Job Control モジュールでのみサポートされます。8 ビットモジュールが使用され、Execute Command 信号によってコマンドが実行されて TestRun が起動すると、Command Failed 信号が発信され、Command Complete 信号がトグルしてエラーが示されます。
Reserved (4.9.x 以前) | 未使用。

4 ～ 7

Reserved

未使用。

Inspection Status モジュール

ジョブの実行と検査結果のステータスを示します。

ビット | 名前 | 説明

0

Inspecting

このビットは、In-Sight ビジョンシステムがジョブを実行しているときにセットされます。

1

Inspection Completed

このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが有効なときにセットされます。

2

Results Buffer Overrun

このフィールドは、Buffer Results Enable ビットがセットされ、PLC が結果を確認応答しないで代わりに Inspection Results Ack ビットをセットしたために、In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されて、バッファ内の 8 番目の検査に上書きされたときにセットされます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。

3

Results Valid

Inspection Count、Inspection Result Code、Inspection Results の各フィールドが有効なときにセットされます。

4

 Command Executing (4.10.x)

このビットは、TestRun または [ジョブを開く] が開始されると 1 にセットされます。TestRun 実行が完了するとクリアされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。

注: 8 ビットモジュールを使用する場合は、JobID がビジョンシステムに書き込まれるとすぐに [ジョブを開く] 操作が実行されます。16 ビットモジュールを使用する場合は、Execute Command の信号が発信されるまで [ジョブを開く] 操作は実行されません。

Job Loading (4.9.x 以前)

このビットは、新規ジョブをロードするときにセットされます。

注: このビットは、PROFINET を使用する PLC によってジョブのロードが開始された場合にのみ機能します。

5

 Command Completed (4.10.x)

このビットは、TestRun 実行または [ジョブを開く] が完了したことを示すためにトグルされます。

注: TestRun を設定せずにジョブで TestRun を実行しようとすると、CommandCompleted がトグルされ、CommandFailed がセットされます。TestRun は、TestRunReady がセットされていない場合には実行されません。

Job Load Complete (4.9.x 以前)

このビットは、ジョブロード操作の完了時にトグルされます。

注: このビットは、PROFINET を使用する PLC によってジョブのロードが開始された場合にのみ機能します。

6

 Command Failed (4.10.x) このビットは 1 にセットされ、TestRun 実行または [ジョブを開く] を最後まで実行することに失敗したことが示されます。TestRun シーケンスが実行されるか、PLC/HMI によって新規のジョブがロードされるとクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。

Job Load Failed (4.9.x 以前)

このビットは、ジョブのロードの最後の試みが失敗したときにセットされます。次にジョブのロードが成功したときにクリアされます。

注: このビットは、PROFINET を使用する PLC によってジョブのロードが開始された場合にのみ機能します。

7

Set User Data Ack

このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。
8 Job Pass このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。

注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
9 TestRun Ready (4.10.x)

このビットは、ビジョンシステムの TestRun 設定が有効な場合に 1 にセットされます。この信号は、TestRun の実行中に (TestRun イニシエータに関係なく) クリアされ、実行完了後に 1 に戻ります。

注: このビットは、ビジョンシステムがオンラインかオフラインかどうかに関係なく信号として送信されます。
Reserved (4.9.x 以前) | 未使用。
10 ～ 15 | Reserved | 未使用。

検査/結果シーケンス

In-Sight ビジョンシステムによって取り込まれた画像は、処理のためにキューに入れられます。ビジョンシステムが画像を処理している間、Inspection Status モジュールの Inspecting ビットがセットされます。ビジョンシステムが画像の処理を終了すると、Inspecting ビットがクリアされ、Inspection Completed ビットがトグルされます。

Inspection Control モジュールの Buffer Results Enable ビットによって、ビジョンシステムでの検査結果の取り扱い方が決まります。Buffer Results Enable ビットが偽にセットされると、検査結果は直ちに Inspection Results モジュールに格納され、Results Valid ビットが真にセットされます。Buffer Results Enable ビットが真に設定されると、新しい結果がキューに入れられます。PLC は、確認応答する結果がまだある場合、Inspection Results Ack ビットと Results Valid ビットを真にセットします。Results Valid ビットがクリアされると、PLC は Inspection Results Ack ビットを偽に戻す必要があります。これで、キューに入れられた結果を Inspection Results モジュールに格納することができます (これは、PLC が結果を確実に受信するために必要なハンドシェークです)。

Inspection Status モジュールの動作

ビット | ビット名 | バッファリングが無効な場合の結果 | バッファリングが有効な場合の結果
0 | Inspecting | このビットは、In-Sight ビジョンシステムがジョブを実行しているときにセットされます。 | このビットは、In-Sight ビジョンシステムがジョブを実行しているときにセットされます。
1 | Inspection Complete | 検査の完了時に切り替えられます。 | 検査の完了時に切り替えられます。
2 | Results Buffer Overflow | 0 に設定されたままです。 | PLC が前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。結果バッファがオーバフローします。検査結果が正常にキューに入れられたときにクリアされます。
3 | Results Valid | 新しい結果が Inspection Results モジュールに格納されたときにセットされます。Inspection Results Ack ビットを真にセットすることによって結果が確認応答されるまでセットされたままになります。 | 新しい結果が Inspection Results モジュールに格納されたときにセットされます。Inspection Results Ack ビットを真にセットすることにより、結果が確認応答されるまでセットされたままになります。

結果のバッファリング

検査結果用のキューを有効にする必要があります。有効にした場合、PLC が有限個の検査データ結果を読み取るまでキューに入れておくことができます。これは、システムの複数の部分 (外部 PLC を含む) の速度が短時間に低下した場合に、データの流れを滑らかにするのに有効な機能です。

通常、結果が送信される速度より検査を実行する速度の方が速い場合、バッファリングありとバッファリングなしの間の大きな相違点は、破棄される結果を判別するかどうかということです。バッファリングが有効でない場合は最新の結果が保持され、以前の結果は PLC が読み取ることができず失われます。原則的に、最新の結果によって以前の結果が上書きされるだけです。バッファリングが有効である (さらに、キューがいっぱいである) 場合は、結果キューに空きができるまで最新の結果が破棄されます。

Job Control Input/Output モジュール

このモジュールの入力バイトは、In-Sight ビジョンシステムの現在のジョブ ID (Job ID のデフォルトのプレフィックスは 0 で、ジョブは変更されないことを示します) を示すか、現在のジョブに ID がない場合は 255 になります。In-Sight ビジョンシステムがオフラインのときに出力バイトを設定すると、同じ ID のジョブがロードされます。有効なジョブ ID 番号は、1 ～ 254 です。

注:

  • 255 のジョブ ID 接頭辞は使用しないでください。ジョブ ID 接頭辞のないジョブが In-Sight Explorer によってロードされたときに、255 の入力バイトが PLC に返されます。したがって、ジョブ ID 接頭辞が 255 のジョブがロードされた場合や、ジョブ ID 接頭辞のないジョブがロードされた場合にわかりにくくなります。

  • In-Sight 4.10.x ファームウェアが実行されている In-Sight ビジョンシステムの場合は、TestRun をサポートするため、16 ビットの Control Input/Output モジュールが追加されます。デフォルトでは、8 ビットモジュールがロードされます。TestRun を使用するには、8 ビットモジュールを手動で削除し、16 ビットモジュールで置き換える必要があります。

  • 16 ビットの Job Control モジュールを使用する場合、有効なジョブ ID は 255 を除く 0 ～ 999 の範囲の数字です。

ソフトイベント制御モジュール

スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。

注: In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

User Data モジュール

このデータは、ReadProfinetBuffer 関数を使用して、In-Sight スプレッドシートから読み取ることができます。

Inspection Results モジュール

これは、WriteProfinetBuffer 関数を使用して、In-Sight スプレッドシートから書き込まれるデータです。Inspection Control モジュールの Buffer Results Enable ビットがセットされていた場合、Inspection Results Ack ビットをパルス出力することによって確認応答されるまで、検査結果は変わりません。

バイト

名前

説明

0 ～ 1

Inspection ID

この結果セットに関連付けられている取り込み ID。

2 ～ 3

 Inspection Result Code (4.10.x)

TestRun の最新の実行結果を示します。すべてのテストに合格すると、ビット 0 がセットされます。不合格のテストがあった場合、または TestRun を実行している間のセットアップまたはクリーンアップに問題があった場合、ビット 0 はクリアされます。

  • このフィールドは、TestRun が正常に実行された後にのみ有効になります。
  • このフィールドの結果は、TestRun なしのジョブがロードされた場合、別の TestRun ジョブが実行された場合、TestRun が進行中の場合、TestRun またはジョブが失敗した場合、または TestRun が中止された場合には無効化されることがあります。
  • カメラが現在オンラインに設定されている場合、このフィールドの内容はスプレッドシートによって出力され、TestRun に関する意味はありません。

Inspection Result Code (4.9.x 以前)

現在は使用されていません。常に 0 です。

4 ～ 253

Inspection Results

WriteProfinetBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

PROFINET タイミング図 - バッファリングありとバッファリングなし

次のタイミング図は、画像取り込み制御、検査制御、画像取り込みステータス、検査ステータス、および検査結果の関係を示しています。

PROFINET での画像取り込みと検査のタイミング図 (バッファリング無効)

PROFINET での画像取り込みと検査のタイミング図 (バッファリング有効)
Version: 5.6.0


PROFINET IO モジュールリファレンステーブル - In-Sight 5.x.x ファームウェア

PROFINET 通信

In-Sight 関数リファレンス

このトピックでは、PROFINET IO モジュールリファレンステーブルと、GSD ファイルのバージョン 2.3 と組み合わせて In-Sight 5.1.0 以降のファームウェアが実行されている In-Sight ビジョンシステムのテーブルに格納されている信号について説明します。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

  • PROFINET I/O モジュールリファレンステーブルとモジュールの説明
  • PROFINET タイミング図 - バッファリングありとバッファリングなし

PROFINET IO モジュールリファレンステーブルとモジュールの説明

  • Acquisition Control モジュール
  • Acquisition Status モジュール
  • Inspection Control モジュール
  • Inspection Status モジュール
  • Command Control Input モジュール
  • Command Control Output モジュール
  • Soft Event Control Input モジュール
  • Soft Event Control Output モジュール
  • User Data モジュール
  • Inspection Results モジュール
モジュール | ID | バイト | ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Acquisition Control | 0x101 | 0 | Set Offline | Reserved |  |  |  | Clear Exposure Complete | Trigger | Trigger Enable
Acquisition Status | 0x201 | 0 | Online | Offline Reason |  |  | Missed Acq | Exposure Complete | Trigger Ack | Trigger Ready
 |  | 1..2 | Acquisition ID
Inspection Control | 0x102 | 0 | Clear Error | Reserved |  |  | Execute Command | Set User Data | Inspection Results Ack | Buffer Results Enable
Inspection Status | 0x203 | 0 | Set User Data Ack | Command Failed | Command Completed | Command Executing | Results Valid | Results Buffer Overrun | Inspection Completed | System Busy
 |  | 1 | Error | Reserved |  |  |  | Reserved | Reserved (5.1.0 ～ 5.5.x) | Job Pass
 |  |  |  |  |  |  |  |  | TestRun Ready (5.6.0 以降)
 |  | 2..3 | エラーコード
Command Control Input | 0x107 | 0..1 | Command (16 ビット)
Command Control Output | 0x107 | 0..1 | Current Job ID (16 ビット)
Soft Event Control Input | 0x106 | 0 | Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0
Soft Event Control Output | 0x106 | 0 | Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0
User Data | 0x301(16) 0x302(32) 0x303(64) 0x304(128) 0x305(254) | 0.. | User Data
Inspection Results | 0x401(16) 0x402(32) 0x403(64) 0x404(128) 0x405(250) | 0..1 | Inspection ID
 |  | 2..3 | Inspection Results Code
 |  | 4.. | Inspection Results

Acquisition Control モジュール

Acquisition Control モジュールと Acquisition Status モジュールのビットにより、PLC では、In-Sight ビジョンシステムで画像取り込みをトリガし、画像取り込みが完了した時期を判別し、ビジョンシステムをオフラインステータスにして画像取り込みトリガを受け入れないようにすることができます。

ビット

名前

説明

0

Trigger Enable

このフィールドは、Trigger ビット経由でトリガできるようにするために設定されます。このビットをクリアすると、ネットワークトリガメカニズムが無効になります。

1

Trigger

このビットをセットすると、次の条件が満たされた場合に取り込みがトリガされます。

  • In-Sight ビジョンシステムがオンラインである。
  • Trigger Enable ビットがセットされている。
  • AcquireImage 関数の [トリガ] パラメータが、[外部] または [産業用イーサネット] に設定されます。

    • 注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。

2

Clear Exposure Complete

この信号が High のときは、Exposure Complete ステータスはリセットのままです。この信号が Low に設定されると、次の露光完了時に Exposure Complete ステータスが High に設定されます。

3 ～ 6

Reserved

未使用。

7

Set Offline

このビットがセットされると、このビットが再びクリアされるまで、In-Sight ビジョンシステムはオフラインになります。

Acquisition Status モジュール

ビット

名前

説明

0

Trigger Ready

In-Sight ビジョンシステムが、Trigger ビットを介して新しいトリガを受け入れられることを示します。このフィールドは、ビジョンシステムがオンラインであり、Trigger Enable ビットがセットされ、AcquireImage 関数の [トリガ] パラメータが [ネットワーク]、[外部]、または [産業用イーサネット] に設定されて、ビジョンシステムが現在画像を取り込んでいないときに真になります。

注: トリガが PLC から送られてきたら、[産業用イーサネット] トリガタイプを使用する必要があります。

1

Trigger Ack

In-Sight ビジョンシステムが Trigger ビットのセットによってトリガされたことを示します。このビットは、Trigger ビットがクリアされるまでセットされたままです。また、Acquisition ID は、このビットの立ち上がりエッジにラッチできます。

注: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。

2

Exposure Complete

このビットは、In-Sight ビジョンシステムが露光完了するとセットされ、Clear Exposure Complete ビットでリセットされます。このビットは、Clear Exposure Complete 信号が High に設定されると Low に保持されます。

3

Missed Ack

画像取り込み方法に関係なく、In-Sight ビジョンシステムが画像取り込みに失敗したときにセットされます。画像取り込みが正常にトリガされるとクリアされます。

注: Trigger ビットがセットされたが、ビジョンシステムがオフラインになっている場合、Missed Acq ビットと Trigger Ack ビットの両方がセットされます。

4 ～ 6

Offline Reason

このフィールドは、In-Sight ビジョンシステムがオフラインである原因を示すために使用される 3 ビットのフィールドです。

Offline Reason | 名前 | 説明
0 | Online | ビジョンシステムはオンラインです。
1 | Programming | ビジョンシステムのジョブが変更されています。
2 | Discrete Offline | ディスクリート信号によって、ビジョンシステムがオフラインになっています。
3 | Comm.Offline | 通信プロトコルによって、ビジョンシステムがオフラインになっています。
注: 複数のデバイスから In-Sight ビジョンシステムはオフラインにできます。このフィールドでは最小限のチャネルステータスを返します。

7

Online

このビットは、In-Sight ビジョンシステムがオンラインのときにセットされ、ビジョンシステムがオフラインのときにクリアされます。ビジョンシステムがオフラインのときには、Offline Reason フィールドを調べて、原因を判断してください。

8 ～ 23

Acquisition ID

この ID は、取り込みの開始時と Trigger Ack ビットがセットされると増分され、取り込みとその検査結果の同期に使用できます。

一般的な画像取り込みシーケンス

注:ネイティブモード コマンドによる、PLC/モーションコントローラからの取り込みトリガを許可するように、In-Sight ビジョンシステムを設定する場合は、SetEvent and Wait 関数を利用して、イベントコードを 8 (SW8) に設定することを推奨します。これによって、ビジョンシステムは、画像取り込みと検査の両方が完了してから「完了」レスポンスを PLC/モーションコントローラに送り返すようになるため、前の検査結果が PLC/モーションコントローラに送信されることはなくなります。ビジョンシステムからの「完了」レスポンスを使用して、検査結果の読み取り要求を送信する条件付き PLC ロジックを作成することもできます。

In-Sight ビジョンシステムは、Acquisition Control モジュールの Trigger Enable および Trigger ビットを直接操作するか、または Acquisition Status モジュールの Trigger Ready、Trigger Ack および Missed Acq ビットをモニタすることによってトリガできます。

最初の起動時には、Trigger Enable ビットは偽であり、トリガを有効にするには真にセットする必要があります。ビジョンシステムでトリガを受け入れる準備ができると、Acquisition Status モジュールの Trigger Ready ビットが真にセットされます。

Trigger Enable および Trigger Ready ビットが真である間は、Trigger ビットが 0 から 1 に変化するのがビジョンシステムで認識されるごとに、画像取り込みが開始されます。Acquisition Status モジュールの Trigger Ack ビットが同じ状態値になるまで、Trigger ビットを新しい状態で保持する必要があります (これは、ビジョンシステムが変化を確実に確認するために必要なハンドシェークです)。

画像の取り込み中、Acquisition Status モジュールの Trigger Ready ビットがクリアされます。Exposure Complete ビットは画像取り込みの終了時にセットされ、Clear Exposure Complete ビットによってのみクリアできます。

トリガメカニズムを強制的にリセットするには、Acquisition Status モジュールが 0 になるまで Trigger Enable ビットを偽にセットします。Trigger Enable ビットを真に設定すると、画像取り込みが再度有効になります。

Inspection Control モジュール

Inspection Status モジュールと Inspection Control モジュールにより、PLC では、In-Sight ビジョンシステムのビジョン処理部分をモニタして新しい結果が出力される時期を判別し、新しい結果をキューに入れるようにビジョンシステムに要求できます。

ビット | 名前 | 説明
0 | Buffer Results Enable | このビットがセットされると、Inspection ID、Inspection Result、Inspection Results フィールドは、Inspection Results Ack フィールドが確認応答してセットされるまで変化しません。最大 8 つの検査がビジョンシステムのバッファに保持されます。In-Sight ビジョンシステムは、Results Valid ビットをクリアすることによって、確認応答に応答します。Inspection Results Ack フィールドがクリアされて、PLC に送信される新しいルールセットがあるときには、Results Valid ビットはクリアされません。Inspection Results Ack ビットがクリアされて、PLC に送信される結果がビジョンシステムのバッファにそれ以上ない場合には、Results Valid ビットはクリアされたままです。
1 | Inspection Results Ack | Buffer Results Enable ビットがセットされると、Inspection Results Ack ビットは、PLC が Inspection ID、Inspection Result、および Inspection Results データを受信したことを確認応答します。その後、次の検査結果のセットが PLC に送信されます。Inspection Results Ack ビットがクリアされると、ビジョンシステムは Results Valid ビットをセットします (バッファが空でなかった場合)。結果のバッファ処理が無効になっている場合、Inspection Results Ack ビットをセットして、Results Valid ビットをクリアする必要があります。
2 | Set User Data | この信号の立ち上がりエッジでユーザデータ保持バッファがユーザデータフィールドにラッチされ、ビジョンシステムにユーザデータへのアクセス権が付与されます。ビジョンシステムがコマンドを受信したことを保証するには、Inspection Status モジュールで Set User Data Ack ビットがアサートされるまで、PLC でこのビットが high に保持される必要があります。Profinet Write Record コマンドを使用して、ユーザデータ保持バッファに書き込むことができます。PROFINET 接続で User Data モジュールが設定されている場合に Set User Data 信号がアサートされると、モジュールアラームがアサートされます。
3 | Execute Command (5.1.0 ～ 5.5.x) | 設定した場合、ビジョンシステムは、[コマンド] フィールドで指定されたジョブ ID をロードするか、[名前を基準にしたジョブのロード] コマンドを実行して、ユーザデータバッファで指定されたジョブ名をロードします。[コマンド完了] シグナルに切り替わるまで、シグナルは [High] のまま維持する必要があります。このシグナルの立ち下がりエッジ ([コマンド完了] の前の場合) は、停止リクエストとして解釈されます。
 | Execute Command (5.6.0 以降) | セットすると、ビジョンシステムは、Command フィールドで指定されてているジョブ ID をロードするか、Job Load by Name コマンドを実行して User Data バッファにあるジョブ名をロードします。TestRun を使用する場合は、この信号の立ち上がりエッジでコマンドが実行されて TestRun が開始されます。この信号は、Command Completed 信号がトグルされるまで high を維持する必要があります。この信号の立ち下がりエッジ (Command Complete の前) は、中止要求と解釈されます。
4 ～ 6 | Reserved | 未使用。
7 | Clear Error | このビットをセットすると、エラーシグナルとエラーコードシグナルがクリアされます。Clear Error ビットは、Error ビットがクリアされるまで [High] に維持する必要があります。エラーがキューに入れられた場合、このビットがクリアされると、エラーシグナルとエラーコードシグナルは、キューに入れられた次のエラーコードに対してセットされます。

Inspection Status モジュール

ビット

名前

説明

0

System Busy

ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。

1

Inspection Completed

このビットは、検査の完了時にトグルされます。Inspection Count、Inspection Result Code、Inspection Results、または Job Pass の各ビットが PLC に送信された後、確実に切り替えられます。

2

Results Buffer Overrun

このフィールドは、Buffer Results Enable ビットがセットされ、PLC が結果を確認応答しないで代わりに Inspection Results Ack ビットをセットしたために、In-Sight ビジョンシステムが検査結果のセットを破棄したときにセットされます。最大 8 つの検査がビジョンシステムのバッファに保持されるため、このビットは、9 番目の検査がバッファに追加されたときにセットされます。9 番目の検査と後続のすべての検査は、バッファに空きが生じるまで (結果が確認応答されたとき) 破棄されます。有効な検査が発生して、前の検査が上書きされない限り、このビットはクリアされません。

3

Results Valid

Inspection Count ビット、Inspection Result Code ビット、Inspection Results ビット、または Job Pass ビットがセットされたときにセットします。Inspection Results Ack ビットがセットされるとクリアされます。

注: オーバーラップモード時のジョブの処理を有効にした場合は、Buffer Results Enable ビットを有効/セットするか、Inspection Completed ビットを使って検査結果をラッチします。

4

Command Executing (5.1.0 ～ 5.5.x)

Job Load が開始されると、このビットは 1 にセットされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。
Command Executing (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] が開始されると 1 にセットされます。TestRun の実行が完了すると、このビットはクリアされます。Command Completed ビットと Command Failed ビットは、このビットの立ち下がりエッジの前にセットされます。

5

Command Completed (5.1.0 ～ 5.5.x)

コマンドが完了すると、Command Executing ビットが Low になり、Execute Command ビットがまだ High の場合、Command Completed ビットがセットされます。コマンドが完了しなかった場合、Command Failed ビットもセットされます。

注: Execute Command ビットが Low になると、カメラは Command Completed ビットをクリアします。
Command Completed (5.6.0 以降)

このビットは、TestRun 実行または [ジョブを開く] が完了したことを示すためにセットされます。

注: TestRun を設定せずにジョブで TestRun を実行しようとすると、Command Completed ビットと Command Failed ビットの両方がセットされます。TestRun を実行する前に、TestRun Ready ビットがセットされるのを待つ必要があります。

6

Command Failed (5.1.0 ～ 5.5.x)

このビットは 1 にセットされて、Job Load の実行に失敗して完了できなかったことを示します。新しいジョブが PLC/HMI によってロードされると、ビットがクリアされます。In-Sight Explorer によってジョブが変更されても、このビットは変わりません。このビットは常に、Command Completed ビットがセットされるより前にセットされます。
Command Failed (5.6.0 以降) | このビットは、TestRun 実行または [ジョブを開く] に失敗したことを示すため 1 にセットされます。TestRun シーケンスが実行されるか、PLC/HMI によって新規のジョブがロードされるとクリアされます。In-Sight Explorer でジョブを変更しても、このビットは変わりません。

7

Set User Data Ack

このビットは、Set User Data コマンドの完了に確認応答するためにセットされます。
8 Job Pass このビットは、最後のジョブが [ジョブの PASS/FAIL セルの設定] ダイアログの設定に合格するとセットされます。このビットはジョブが合格しないとクリアされます。

注: ジョブの PASS ビッドの動作は結果バッファリングが無効か有効かによって異なります。
バッファリングが無効 バッファリングが有効
検査が完了したときに [ジョブの PASS/FAIL] のセルが合格を示すとセットされます。そうでない場合は、クリアされたままです。

注: Inspection Completed ビットが立つ前のジョブ PASS ビットは有効です。

新しい結果が InspectionResults 属性に挿入され、[ジョブの PASS/FAIL] のセルがその結果に対して合格を示すとセットされます。そうでない場合は、クリアされたままです。InspectionResultsAck 属性を真に設定することによって結果が確認応答され、ビットがクリアされるまで、状態は変化しません。

注: Results Valid ビットがセットされる前のジョブ PASS ビットは有効です。
9 | Reserved (5.1.0 ～ 5.5.x) | 未使用。
TestRun Ready (5.6.0 以降)

このビットは、ビジョンシステムの TestRun 設定が有効な場合に 1 にセットされます。この信号は、TestRun が (TestRun イニシエータに関係なく) 実行されるときにクリアされ、実行完了後に 1 に戻ります。

注:

  • このビットは、ビジョンシステムがオンラインかオフラインかどうかに関係なく信号として送信されます。

  • 外部デバイスによる TestRun の開始は、In-Sight ファームウェア 5.1.0 ～ 5.5.x が実行されているビジョンシステムではサポートされません。
10 ～ 14 | Reserved | 未使用。
15 Error

このビットはエラーが発生するとセットされます。これは [エラーコード] フィールドで定義されています。
16 ～ 31 エラーコード

発生したエラーの 16 ビットの数値表現:

コード | Error | 説明
0x0000 | No Error | エラーは発生しませんでした。
0x0100 | Trigger set while disabled | Trigger Enable ビットがクリアされている間に Trigger ビットがセットされた場合、または AcquireImage 関数の Trigger パラメータが、外部、ネットワークまたは産業用イーサネットに設定された場合に発生します。
0x0101 | Trigger set while Offline | ビジョンシステムがオフラインの間に Trigger ビットが設定されるときに発生します。
0x0400 | Already Executing Error | Execute Command ビットがセットされ、Excecuting ビットが High のままになっている場合に発生します。
0x0401 | Job load requested while Online | ビジョンシステムがオンラインの間に [ジョブを開く] コマンドが発行されるときに発生します。

検査/結果シーケンス

In-Sight ビジョンシステムによって取り込まれた画像は、処理のためにキューに入れられます。ビジョンシステムが画像を処理している間、Inspection Status モジュールの System Busy ビットがセットされます。ビジョンシステムが画像の処理を終了すると、System Busy ビットがクリアされ、Inspection Completed ビットがトグルされます。

Inspection Control モジュールの Buffer Results Enable ビットによって、ビジョンシステムでの検査結果の取り扱い方が決まります。

Buffer Results Enable ビットが偽にセットされると、検査結果は直ちに Inspection Results モジュールに格納され、Results Valid ビットが真にセットされます。結果のバッファリングが無効な場合は、Inspection Results Ack ビットをセットして Results Valid ビットをクリアする必要があります。

Buffer Results Enable ビットが真に設定されると、新しい結果がキューに入れられます。PLC が Inspection Results Ack ビットをセットし、確認応答する結果がまだある場合には、これによって Results Valid ビットが真にセットされます。Results Valid ビットがクリアされると、PLC は Inspection Results Ack ビットを偽に戻す必要があります。これで、キューに入れられた結果を Inspection Results モジュールに格納することができます (これは、PLC が結果を確実に受信するために必要なハンドシェークです)。

Inspection Status モジュールの動作

ビット | ビット名 | バッファリングが無効な場合の結果 | バッファリングが有効な場合の結果
0 | System Busy | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。 | ビジョンシステムがジョブを実行しているとき、ジョブをロードしているとき、またはユーザ入力に応答しているときにセットされます。
1 | Inspection Complete | 検査の完了時に切り替えられます。 | 検査の完了時に切り替えられます。
2 | Results Buffer Overflow | 0 に設定されたままです。 | PLC が前の結果に確認応答しなかったために、検査結果をキューに入れることができなかったときにセットされます。結果バッファがオーバフローします。検査結果が正常にキューに入れられたときにクリアされます。
3 | Results Valid | 新しい結果が Inspection Results モジュールに格納されたときにセットされます。Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。 | 新しい結果が Inspection Results モジュールに格納されたときにセットされます。Inspection Results Ack ビットを真に設定することによって結果が確認応答されるまでセットされたままです。

結果のバッファリング

検査結果用のキューを有効にする必要があります。有効にした場合、PLC が有限個の検査データ結果を読み取るまでキューに入れておくことができます。これは、システムの複数の部分 (外部 PLC を含む) の速度が短時間に低下した場合に、データの流れを滑らかにするのに有効な機能です。

通常、結果が送信される速度より検査を実行する速度の方が速い場合、バッファリングありとバッファリングなしの間の大きな相違点は、破棄される結果を判別するかどうかということです。バッファリングが有効でない場合は最新の結果が保持され、以前の結果は PLC が読み取ることができず失われます。原則的に、最新の結果によって以前の結果が上書きされるだけです。バッファリングが有効である (さらに、キューがいっぱいである) 場合は、結果キューに空きができるまで最新の結果が破棄されます。

Command Control Input モジュール

Current Job ID フィールドモジュールは、In-Sight ビジョンシステムの現在のジョブ ID を示します。現在のジョブに ID がない場合は、65535 になります。ジョブをロードするため、PLC では、Set Offline ビットを使用してビジョンシステムをオフラインに設定する必要があります。次に、Command フィールドが該当するジョブの ID に設定され、Execute Command ビットがセットされます。Command Completed ビットがセットされると、Execute Command ビットがリセットされます。

バイト | 名前 | 説明
0 ～ 1 | Command (5.1.0 ～ 5.5.x) | これは、ロードするジョブのジョブ ID 番号 (0 ～ 999) を示すため、または [名前を基準にしたジョブのロード] コマンド (0x4000) を指定するために使用される 16 ビットの整数です。[コマンド実行] ビットが PLC によって設定されると、ジョブロードが実行されます。[コマンド] フィールドは、[コマンド実行] シグナルの立ち上がりエッジと [コマンド完了] シグナルの立ち上がりエッジとの間で一定に保つ必要があります。そうしないと、結果が不確定になります。[名前を基準にしたジョブのロード] コマンドを使用する場合、[コマンド実行] ビットが設定される前にジョブ名をユーザデータバッファに転送する必要があります。
 | Command (5.6.0 以降) | (missing or bad snippet)

Command Control Output モジュール

バイト | 名前 | 説明
0 ～ 1 | Current Job ID | ビジョンシステムで現在実行中のジョブの ID 番号を示す 16 ビット整数。または、現在のジョブに ID 番号がない場合は 65535。このフィールドは、ジョブ変更の方法に関係なく、ビジョンシステムでジョブが変更されたときに更新されます。

Soft Event Control Input モジュール

スプレッドシートのソフトイベントのトリガを可能にします。これらのビットをセットすると、スプレッドシート内の関連するソフトイベントがトリガされます。

ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Soft Event 7 | Soft Event 6 | Soft Event 5 | Soft Event 4 | Soft Event 3 | Soft Event 2 | Soft Event 1 | Soft Event 0

注:In-Sight Explorer または VisionView アプリケーションが検査をモニタするジョブ設置環境では、ジョブがスプレッドシートイベントのトリガをかけるソフトイベント (Timer 関数として設定) に依存する場合、画像取り込みサイクルの完了直前にトリガがかけられると、画像の検査が遅延することがあります。ジョブファイルが大きい場合 (つまり、追加されたジョブのロジックに加えて、ファイルにパターンマッチ、傷検出 エッジ検査ツールなど多くのビジョンツールが含まれる)、In-Sight Explorer または VisionView に必要な更新により、表示の更新がキューに入れられるまで画像の検査が妨げられます。正確なタイミングを必要とするアプリケーションでは (10 ミリ秒による測定など)、この更新により合格/不合格の結果を決定するのが遅れるため、検査プロセスでの次のステーション (PLC またはモーションコントローラなど) への結果の転送も遅延します。こうしたアプリケーション環境では、検査の遅延を避けるために、ソフトイベントを使用しないことを推奨します。

PLC はソフトイベントを使用して、ジョブの特定の動作をトリガすることができます。各ソフトイベントには、トリガとそれに関連付けられている確認応答ビットがあります。トリガビットの立ち上がりエッジによって、In-Sight ビジョンシステムは、ソフトイベントに関連付けられている動作を処理します。ソフトイベントの開始時に、ビジョンシステムは Soft Event Ack ビットを High に設定します。このビットは、PLC が Trigger ビットをリセットして、ソフトイベントに関連付けられている動作の処理が完了するまで High のまま保持されます。ソフトイベントをトリガできない場合は、General Fault ビットが High に設定されます。このビットは、イベントが正常にトリガされるまで High のまま保持されます。

Soft Event Control Output モジュール

これらのビットは、Soft Event コマンドが受信されたことを示すために使用されます。

ビット 7 | ビット 6 | ビット 5 | ビット 4 | ビット 3 | ビット 2 | ビット 1 | ビット 0
Soft Event Ack 7 | Soft Event Ack 6 | Soft Event Ack 5 | Soft Event Ack 4 | Soft Event Ack 3 | Soft Event Ack 2 | Soft Event Ack 1 | Soft Event Ack 0

User Data モジュール

このデータは、GetBufferData 関数と ReadProfinetBuffer 関数を使用して、In-Sight Explorer スプレッドシートから読み取ることができます。

Inspection Results モジュール

これは、WriteResultsBuffer 関数を使用して、In-Sight スプレッドシートから書き込まれたデータです。Inspection Control モジュールの Buffer Results Enable ビットがセットされていた場合、Inspection Results Ack ビットをパルス出力することによって確認応答されるまで、検査結果は変わりません。

バイト

名前

説明

0 ～ 1

Inspection ID

この結果セットに関連付けられている取り込み ID。

2 ～ 3

Inspection Result Code (5.1.0 ～ 5.5.x)

検査結果コードは、WriteResultsBuffer 関数の [結果コード] パラメータによって定義されます。
Inspection Result Code (5.6.0 以降)

TestRun の最新の実行結果を示します。すべてのテストに合格すると、値が 0 になります。不合格のテストがあった場合、または TestRun 実行中のセットアップまたはクリーンアップに問題があった場合は、その障害を示す 0 以外の値が返されます。

  • このフィールドは、TestRun の実行が正常に完了した場合にのみ有効になります。
  • このフィールドの結果は、TestRun なしのジョブがロードされた場合、別の TestRun ジョブが実行された場合、TestRun が進行中の場合、TestRun の実行またはジョブを開くことに失敗した場合、または TestRun の実行が中止された場合には無効化されることがあります。

4 ～ 253

Inspection Results

WriteResultsBuffer 関数を使用してスプレッドシートから書き出された検査結果データ。

PROFINET タイミング図 - バッファリングありとバッファリングなし

次のタイミング図は、画像取り込み制御、検査制御、画像取り込みステータス、検査ステータス および検査結果の各レジスタ間の関係を示しています。

PROFINET での画像取り込みと検査のタイミング図 (バッファリング無効)

注: 検査結果は次の検査が完了するまで上書きされませんが、結果は Results Valid ビットがセットされている間に PLC によって処理する必要があります。

PROFINET での画像取り込みと検査のタイミング図 (バッファリング有効)
Version: 5.6.0


PROFINET - Siemens PLC でのレコードの使用

PROFINET による通信

In-Sight 通信リファレンス

  • Read Record と Write Record コマンド
  • In-Sight ビジョンシステム上でのジョブの変更
  • DWord の STATUS 出力で Write/Read Record メッセージから返されるエラー情報 (ERROR ビットが 1 にセット)

Read Record と Write Record コマンド

PROFINET は、In-Sight ビジョンシステムと通信する 2 番目の方法として、Read Record および Write Record コマンドを使用した通信もサポートしています。これらのコマンドは、In-Sight ビジョンシステムのメモリの特定の領域に明示的に書き込みを行います。Read Record および Write Record コマンドは、特定のデバイスに送信され、そのデバイスはそのメッセージに対する応答を常に返します。結果として、Read Record および Write Record コマンドは、あまり頻繁には行われない操作に適しています。

In-Sight ビジョンシステムでは、次の Record コマンドがサポートされています。

インデックス | 説明
1 | ジョブ名
10 | Inspection ID + Inspection Result Code + Inspection Result バイト 0 ～ 995
11 | Inspection Result バイト 996 ～ 1995
12 | Inspection Result バイト 1996 ～ 2995
13 | Inspection Result バイト 2996 ～ 3995
14 | Inspection Result バイト 3996 ～ 3999
30 | User Data バイト 0 ～ 999
31 | User Data バイト 1000 ～ 1999
32 | User Data バイト 2000 ～ 2999
33 | User Data バイト 3000 ～ 3999

注:
  • レコード 10 ～ 13 は読み取り専用レコードです。このデータは、Inspection ID、Inspection Result Code、および Inspection Results データを含む Inspection Results モジュールと同じフォーマットです。これらのレコードに書き込みを試みると、アクセス拒否を示すエラーコード 0xB6 が返されます。

  • レコード 30 ～ 33 は読み取り/書き込みレコードです。「WRREC」(SFB53) を使用して User Data レコードを書き込む場合は、バッファを保持している User Data からスプレッドシートの ReadUserData 関数へのデータの書き込み信号を発信するため、Inspection Control モジュールの Set User Data ビット (ビット 2) も使用する必要があります。最初に User Data レコードを書き込み、次に Set User Data ビットをセットします。

    User Data モジュールを含む周期接続が確立されている場合に PLC がこのレコード範囲に書き込みを試みると、状態の競合が発生したことを示すエラーコード 0xB5 が生成されます。大量のデータを転送する必要があるアプリケーションでは、周期接続の User Data モジュールか、または User Data Write Record コマンドが使用されます。両方を同時に使用することはできません。

  • Siemens CP 343-1 モジュールを PROFINET I/O コントローラとして使用し、FB52 - PNIO READ OR WRITE RECORD を使用してデータのレコードを読み取り/書き込みしている場合、各読み取り/書き込みレコードデータの最初の 480 バイトのみが転送されます。
  • In-Sight ビジョンシステムが PROFINET IO ネットワーク経由で通信するように設定され、レコード 30 ～ 33 へのユーザデータの書き込みが成功した場合、ユーザデータの読み取りを試行すると、レコード 30 ～ 33 が異常な結果を返します。

In-Sight ビジョンシステム上でのジョブの変更

In-Sight ビジョンシステムと Siemens PLC の間で Read Record および Write Record コマンドを使用して行われる最も一般的な操作は、ジョブの変更です。Siemens PLC 内では、これらのコマンドは「WRREC」(SFB 53) および「RDREC」(SFB 52) ブロックを使用して送信されます。

以下の手順では、「WRREC」ブロックを追加することによって、In-Sight ビジョンシステム上の現在のジョブを変更する方法を説明します。

  1. PLC プロジェクトのシンボルテーブルを開きます (Simatic Manager プロジェクトの [S7 Program] ツリーノードにあります)。
  2. 次のシンボルをプロジェクトに追加します。

シンボル

アドレス

データ型

説明

LoadJob

M 124.1

BOOL

LoadJob コマンドをトリガします。

LoadJobBusy

M 124.2

BOOL

LoadJob コマンドの実行中は真。

LoadJobDone

M 124.3

BOOL

LoadJob コマンドが成功した場合に真。

LoadJobErr

M 124.4

BOOL

LoadJob コマンドが失敗した場合に真。
  3. OB1 メインプログラムブロックを開き、[View] メニューから [LAD] を選択して、エディタをラダーモードに設定します。
  4. 関数ツリーからブロックをドラッグして、WRREC コールをラダーネットワークに追加します。このブロックは、[Libraries] → [Standard Library] → [System Function Blocks] → [DP] ノードにあります。
  5. 下の図のようにラダーロジックを追加して、ラングを完成します。

  6. 関数ブロック内の ID パラメータは、コマンドの送信先である In-Sight モジュールの診断アドレスに相当する 16 進値に設定する必要があります。これは、HW Config ツールのモジュールリストにあります。この例では、診断アドレスは 2044 (16 進値では 7FC) です。
  7. プロジェクトを PLC にダウンロードして、PLC を Run モードにします。
  8. PLC プロジェクトの変数テーブルを開きます。次のエントリを変数テーブルに追加します。

アドレス

シンボル

データ型

M 124.1

LoadJob

BOOL

M 124.2

LoadJobBusy

BOOL

M 124.3

LoadJobDone

BOOL

M 124.4

LoadJobErr

BOOL

MD 128

CHARACTER

MD 132

CHARACTER

MD 136

CHARACTER

MD 140

CHARACTER

MD 144

CHARACTER
  9. [Variable] メニューから [Monitor] を選択して、モニタリングを有効にします。
  10. In-Sight Explorer を使用して、ビジョンシステムをオフラインにします。
  11. 変数テーブルの MD 128 ～ MD 147 エントリに、ロードするジョブの名前を入力します。ジョブ名の最後の文字の後にヌル文字 ($0) を入力する必要があります。

  12. ジョブ名を入力した後、[Modify value] 列の「LoadJob」行に「true」と入力します。
  13. 次に、[Valuable] メニューから [Activate Modify Values] を選択して、値を PLC のメモリにコミットします。
  14. 指定したジョブがロードされて、In-Sight Explorer に表示され、LoadJobDone 変数に「true」と表示されます。

DWord の STATUS 出力で Write/Read Record メッセージから返されるエラー情報 (ERROR ビットが 1 にセット)

STATUS 出力パラメータには、有用なエラー診断情報が含まれます。

以下の表に、STATUS パラメータで返される値の説明を示します。これらの値は、バイト配列 [1...4] として解釈されます。

エラー情報の構造は、次のとおりです。

フィールド要素:

名前:

説明

STATUS[1]

Function_Num
  • エラーがなかった場合、B#16#00。
  • DPV1-PDU の関数 ID。エラーの場合、B#16#80 は OR 結合されます。DPV1 プロトコル要素が使用されなかった場合は、B#16#C0。

STATUS[2]

Error_Decode

エラー ID の場所。

STATUS[3]

Error_Code_1

エラー ID

STATUS[4]

Error_Code_2

製造元固有のエラー ID 拡張。

STATUS[2] の値は、次のとおりです。

Error_Decode

(B#16#...)

ソース

説明

00 ～ 7F

CPU

エラーも警告もありません。

80

DPV1

IEC 61158-6 によるエラー。

81 ～ 8F

CPU

B#16#8x は、SFB の n 番目のコールパラメータのエラーを示します。

FE、FF

DP プロファイル

プロファイル固有のエラー。

STATUS[3] の値は、次のとおりです。

Error_Decode

(B#16#...)

Error_Code_1

(B#16#...)

DVP1 による説明

説明

00

00

エラーも警告もありません。

70

00

予約済み、拒否

初期コール。アクティブなデータレコード転送はありません。

01

予約済み、拒否

初期コール。データレコード転送が開始されました。

02

予約済み、拒否

中間コール。データレコード転送は既にアクティブです。

80

90

予約済み、成功

無効な論理開始アドレス。

92

予約済み、成功

ANY ポインタに対して違法な型。

93

予約済み、成功

ID または F_ID によってアドレス指定された DP コンポーネントは設定されていません。

95

追加の割り込み情報をフェッチするときの H システムのエラー (外部 DP インタフェースを介してローカルまたは分散 I/O 層で追加割り込み情報をフェッチするときには、このエラーは「グループエラー」として出力されます)。

注: 接続中または更新中は、追加割り込み情報が一時的に使用できなくなることがあります。

96

H システムでマスタとリザーブのスイッチオーバが発生し、前のマスタ CPU が STOP モードになりました。その時点で、OB の処理中でした。SFB 54 は、OB 開始情報、管理情報、ヘッダ情報、または追加割り込み情報を提供できません。SFC 6「RD_SINFO」は、OB 開始情報を読み出します。SFC 13「DPNRM_DG」は、OB 4x、55、56、57、82、および 83 について、影響を受けた DP スレーブの現在の診断フレームを同期して読み取ります (OB 開始情報からのアドレス情報)。

A0

読み取りエラー

モジュールの読み取り時に否定的確認応答。

A1

書き込みエラー

モジュールの書き込み時に否定的確認応答。

A2

モジュール失敗

層 2 の DP プロトコルエラー。

A3

予約済み、成功

A4

予約済み、成功

バス通信が中断されました。

A5

予約済み、成功

A7

予約済み、成功

DP スレーブまたはモジュールが占有されています (一時的エラー)。

A8

バージョン不一致

DP スレーブまたはモジュールが互換性のないバージョンを報告しています。

A9

サポートされない機能

機能が DP スレーブまたはモジュールによってサポートされていません。

AA ～ AF

ユーザ固有

DP スレーブまたはモジュールは、アプリケーションの製造元固有のエラーを報告しています。DP スレーブまたはモジュールの製造元のマニュアルを参照してください。

B0

無効なインデックス

モジュール内に未知のデータレコード。違法なデータレコード番号 3256。

B1

書き込み長エラー

RECORD パラメータで指定された長さが正しくありません。SFB54 では、AINFO に長さエラー。

B2

無効なスロット

構成されたスロットは空です。

B3

タイプの不一致

実際のモジュールタイプが、指定されたモジュールタイプに一致しません。

B4

無効な領域

DP スレーブまたはモジュールは、無効な領域へのアクセスを報告しています。

B5

ステータスの不一致

DP スレーブまたはモジュールの準備ができていません。

B6

アクセス拒否

DP スレーブまたはモジュールがアクセスを拒否しています。

B7

無効な範囲

DP スレーブまたはモジュールは、パラメータまたは値の範囲が無効であることを報告しています。

B8

無効なパラメータ

DP スレーブまたはモジュールは、無効なパラメータを報告しています。

B9

無効なタイプ

DP スレーブまたはモジュールは、無効なタイプを報告しています。

BA ～ BF

ユーザ固有

DP スレーブまたはモジュールは、アクセス時に製造元固有のエラーを報告しています。DP スレーブまたはモジュールの製造元のマニュアルを参照してください。

C0

読み取り制約の不一致

モジュールにはデータレコードがありますが、読み取りデータはまだありません。

C1

書き込み制約の不一致

モジュールの同じデータレコードに対する前の書き込み要求が、モジュールによってまだ処理されていません。

C2

リソースビジー

モジュールは、CPU の最大ジョブ数を処理中です。

C3

リソース使用不能

必要な操作リソースが現在、占有されています。

C4

内部一時エラー。ジョブを実行できませんでした。ジョブを繰り返してください。このエラーが頻繁に発生する場合は、工場の電気干渉の原因を調べてください。

C5

DP スレーブまたはモジュールを使用できません。

C6

優先度クラスのキャンセルのため、データレコード転送はキャンセルされました。

C7

DP マスタがウォームまたはコールドリスタートされたため、ジョブはキャンセルされました。

C8 ～ CF

DP スレーブまたはモジュールは、製造元固有のリソースエラーを報告しています。DP スレーブまたはモジュールの製造元のマニュアルを参照してください。

Dx

ユーザ固有

DP スレーブ固有。DP スレーブの説明を参照してください。

81

00 ～ FF

初期コールパラメータのエラー (SFB54 では MODE)。

00

違法な操作モード。

82

00 ～ FF

2 番目のコールパラメータのエラー。

:

:

:

88

00 ～ FF

8 番目のコールパラメータのエラー (SFB54 では TINFO)。

01

正しくない ID シンタックス。

23

数量フレームを超えているか、ターゲット領域が小さすぎます。

24

正しくない ID 範囲。

32

DB/DI 番号がユーザ範囲外です。

3A

DB/DI 番号が、ID 領域 DB/DI について NULL であるか、指定された DB/DI が存在しません。

89

00 ～ FF

9 番目のコールパラメータのエラー (SFB54 では AINFO)。

01

正しくない ID シンタックス。

23

数量フレームを超えているか、ターゲット領域が小さすぎます。

24

正しくない ID 範囲。

32

DB/DI 番号がユーザ範囲外です。

3A

DB/DI 番号が、ID 領域 DB/DI について NULL であるか、指定された DB/DI が存在しません。

8A

00 ～ FF

10 番目のコールパラメータのエラー。

:

:

:

8F

00 ～ FF

15 番目のコールパラメータのエラー。

FE、FF

00 ～ FF

プロファイル固有のエラー。

DPV1 エラーでは、DP マスタは STATUS[4] データを CPU と SFB の両方にわたします。DPV1 エラーがなかった場合、この値は 0 に設定されますが、SFB52 (読み取りレコード) では、以下の例外があります。

  • MLEN が RECORD のターゲット領域の長さより大きかった場合、STATUS[4] は RECORD のターゲット領域の長さを含みます。
  • 実際のデータレコード長が MLEN より小さく、MLEN が RECORD のターゲット領域の長さより小さかった場合、STATUS[4] は MLEN に等しくなります。
  • STATUS[4] が 255 より大きく、255 に設定しなければならなかった場合、STATUS[4] は 0 になります。
Version: 5.6.0


ネットワーク接続

In-Sight Explorer GUI リファレンス

In-Sight センサは、DHCP サーバが稼働している既存のネットワーク上にインストールするように工場出荷時に設定されています。ネットワークケーブルを接続して電源を入れると、DHCP サーバが In-Sight センサを自動的に検出し、設定を行い、デフォルトのホスト名でネットワークに追加します。既存のネットワークにセンサをインストールするときには、DHCP サーバが使用可能かどうか、ネットワーク管理者に問い合わせてください。

注: DHCP サーバのネットワークにセンサを追加したら、センサで DHCP を無効にし、固定 IP アドレスを割り当てることを強く推奨します。

センサで DHCP サーバを使用しない場合、または In-Sight センサを PC に直接接続する場合は、[センサ/デバイスをネットワークに追加] ダイアログを使用して、センサとの接続を確立します。このインストールでは、Microsoft Windows でのネットワーク設定の変更が必要になることもあります。

センサとの通信が確立されてセンサにログオンできるようになれば、[ネットワークの設定] ダイアログを使用してセンサのネットワーク設定を行ったり、変更したりすることもできます。

複数のサブネットに In-Sight センサが存在する場合は、In-Sight のホストテーブルを使用して異なるサブネットワーク上の In-Sight センサどうしが通信できるようにし、Explorer のホストテーブルを使用して In-Sight Explorer が異なるサブネット上の In-Sight センサと通信できるようにします。Explorer のホストテーブルで定義されているセンサは、[In-Sight ネットワーク] ペインと [In-Sight のファイル] ペインに表示されます。

センサのメンテナンスのため、[バックアップ] ダイアログを使用してネットワーク設定のアーカイブコピーを PC 上のハードディスクに保存し、[レポート作成] ダイアログを使用して HTML または XML ベースの出力ファイルを生成し、ネットワーク上のセンサおよびエミュレータのネットワーク設定のドキュメントを作成できます。

関連項目

ネットワークのトラブルシューティング

Version: 5.6.0


PC のネットワーク設定 (非 DHCP)

ハウツー

このセクションでは、非 DHCP ネットワーク上の In-Sight ソフトウェアが実行されている In-Sight センサに接続するための Microsoft® Windows® ネットワークの設定方法について説明します。以下に示す手順およびダイアログの例は、カテゴリ表示が有効になっている Windows　7/Windows 10 に固有のものです。

注: ネットワーク管理者に問い合わせ、ネットワークで DHCP サーバが使用されているかどうか確認してください。

Microsoft Windows　7/Windows 10 のネットワーク設定

  1. [スタート] をクリックして、[コントロール パネル] ショートカットをクリックし、[コントロール パネル] を開きます。
  2. [ネットワークと共有センター] アイコンをクリックして [ネットワークと共有センター] ウィンドウを開き、左側のペインで、[アダプターの設定の変更] をクリックして [ネットワーク接続] ウィンドウを開きます。
  3. [ローカルエリア接続] アイコンを右クリックし、[プロパティ] をクリックして [ローカル エリアの接続プロパティ] ダイアログを開きます。(管理者のパスワードまたは確認を求められた場合は、パスワードを入力するか、確認を行います)。

  4. [ネットワーク] タブを選択します。
  5. ダイアログの [この接続は次の項目を使用します] の部分で、[インターネット プロトコル バージョン 4 (TCP/IPv4)] チェックボックスをオンにするか、[インターネット プロトコル バージョン 6 (TCP/IPv6)] チェックボックスをオンにします。
  6. [インターネット プロトコル バージョン 4 (TCP/IPv4)] または [インターネット プロトコル バージョン 6 (TCP/IPv6)] のどちらかをハイライト表示し、[プロパティ] をクリックして [インターネット プロトコル バージョン x (TCP/IPvx) のプロパティ] ダイアログを開きます。
  7. 開いた [インターネット プロトコル バージョン x (TCP/IPvx) のプロパティ] ダイアログに応じて、次のように操作します。
    • [インターネット プロトコル バージョン 4 (TCP/IPv4) のプロパティ]: [次の IP アドレスを使う] ラジオボタンをクリックします。グレーアウトされていた [IP アドレス]、[サブネット マスク] および [デフォルト ゲートウェイ] の各フィールドが有効になります。
    • [インターネット プロトコル バージョン 6 (TCP/IPv6) のプロパティ]: [次の IPv6 アドレスを使う] ラジオボタンをクリックします。グレーアウトされていた [IPv6 アドレス]、[サブネット プレフィックスの長さ] および [デフォルト ゲートウェイ] の各フィールドが有効になります。

  9. 適切な IP アドレスを入力します。
  10. 適切なサブネットマスクまたはサブネットプレフィックスの長さを入力します。
    • [インターネット プロトコル バージョン 4 (TCP/IPv4) のプロパティ]: サブネットマスクにより、システムの IP アドレスのネットワークを表す部分と、ホストを表す部分を定義します。IP アドレスのネットワーク部分は同じサブネットのすべてのホストにおいて共通しており、残りは各ホスト固有です。
    • [インターネット プロトコル バージョン 6 (TCP/IPv6) のプロパティ]: サブネットプレフィックスの長さは、アドレスの左側から数えて、(IP アドレスのネットワーク部を表す) 共有初期ビットの数に関してサブネットマスクを定義するための方法の 1 つです。例えば、サブネット マスク 255.0.0.0 には共有初期ビットが 8 個 (255 のバイナリ表記は 11111111) 含まれており、サブネットプレフィックスの長さは /8 として表現できます。

注: ネットワーク管理者に問い合わせて、優先 DNS サーバと代替 DNS サーバを確認してください。

  11. [OK] をクリックして [インターネット プロトコル バージョン x (TCP/IPvx) のプロパティ] ダイアログを閉じます。
  12. [閉じる] をクリックして [ローカル エリアの接続プロパティ] ダイアログを閉じます。
Version: 5.6.0


リンクローカル IP アドレス

リンクローカル IP アドレス (APIPA: Automatic Private IP Address とも呼ぶ) は、固有の動的/静的 IP アドレスを直ちに割り振ることができない時に、自動で一時的に有効な IP アドレスを充てることを目的にしています。リンクローカル IP アドレスは 169.254.0.0/16 の範囲で振られます。

リンクローカル機能は、イーサネット設定をサポートし、ファームウェア 4.1.0 以上を実行する In-Sight デバイスのみで使用できます。In-Sight デバイスは必要に応じてリンクローカル IP アドレスを自身に割り当てることで、設定を行わなくても PC またはネットワークに接続できるように、または接続を維持できるようにします。リンクローカル IP アドレスが使用される例は次のとおりです。

  • 新しいデバイスを固定ネットワークに接続する場合。
  • 新しいデバイスを PC または VisionView に直接接続する場合。
  • デバイスを固定 IP アドレスで固定ネットワークに接続し、IP アドレスがすでに取得されている場合。
  • DHCP サーバがダウンしたときに、動的 IP アドレスでデバイスへの接続を維持する場合。
  • DHCP ネットワークから固定ネットワークにデバイスを移動する場合。
注:
  • 新しい In-Sight イーサネットデバイスは、DHCP サーバのある既存のネットワークに設置できるよう工場出荷時に設定されています。
  • ルータはリンクローカル IP アドレスとデータのやり取りを行うことができないため、[センサ/デバイスをネットワークに追加] ダイアログで動的または固定 IP アドレスに置き換えることを強く推奨します。


ネットワークのトラブルシューティング

In-Sight Explorerトラブルシューティング

In-Sight Explorer ソフトウェアのインストール

センサの初期設定

別のネットワークへのセンサの移行

PC がセンサとは別のサブネットにある

PC に直接接続されているセンサに接続できない

ハブまたはスイッチに直接接続されているセンサに接続できない

In-Sight センサが [In-Sight ネットワーク] ペインに表示されない

ローカルエミュレータに接続できない

In-Sight Explorer によって検出される PC の IP アドレスが正しくない

IP アドレスとサブネットマスクに 2 桁しか入力できない

使用可能なポート

センサのファームウェアをアップデートできない

ファイルを転送できない

センサに書き込めない

重要: センサの設定を工場出荷時のデフォルトにリセットすると、[センサ/デバイスをネットワークに追加] ダイアログによって、proc.set ファイルが上書きされます。

In-Sight Explorer ソフトウェアのインストール

  • PC に In-Sight ソフトウェアをインストールするときには、ローカルの管理者権限があることを確認してください。
  • すべてのファイアウォールとウィルス対策ソフトウェアを無効にしてください。

センサの初期設定

IP アドレスを割り当てます。

In-Sight センサは、工場出荷時には DHCP が有効になっています。ご使用のネットワークに DHCP サーバがない場合は、[センサ/デバイスをネットワークに追加] ダイアログを使用して、センサに固定 IP アドレスを割り当ててください。

注: DHCP は、ネットワークに DHCP サーバがある場合のみ使用してください。既存のネットワークにセンサをインストールするときには、DHCP サーバが使用可能かどうか、ネットワーク管理者に問い合わせてください。

別のネットワークへのセンサの移行

すべてのセンサをセットアップした後で、IP アドレスを新しいネットワーク用に変更する必要がある場合 (生産ラインに設置する場合など) は、[センサ/デバイスをネットワークに追加] ダイアログを使用して、センサのネットワーク設定を変更してください。

注: センサの IP アドレス変更作業は、変更前のネットワーク上で実施する必要があります。

PC がセンサとは別のサブネットにある

センサが、In-Sight Explorer を実行している PC とは異なるサブネット上で動作するように設定されている場合は、センサのホスト名と IP アドレスを Explorer のホストテーブルに入力しないと、そのセンサは [In-Sight ネットワーク] に表示されません。

PC に直接接続されているセンサに接続できない

正しい種類のネットワークケーブルを使用していることを確認します。

In-Sight 5000 シリーズのほとんどのセンサはネットワークケーブルの極性自動検出機能を備えているため、センサと PC を直接接続する際に、ストレートケーブルまたはクロスケーブルのどちらを使用しても構いません。自動検出機能を持たないセンサの場合は、クロスケーブルを使用するか、ストレートケーブルとクロスカプラを併用する必要があります。ご使用のセンサの正しい接続方法を調べるには、センサの背面の製品番号ラベルを確認してください。製品番号が P/N 800-5828 の場合、センサには自動検出機能がありません。

PC がネットワークに接続されていることを確認します。

センサのネットワークケーブルを PC のネットワークカードに接続すると、画面右下の通知領域にネットワーク接続アイコンが表示されます。ネットワーク接続アイコンが表示されない場合は、ネットワークケーブルがしっかりと挿入されていて、良好な状態であることを確認してください。

PC の Microsoft メディア検出機能を無効にします。

ネットワークインタフェースがリンク状態であるかどうかを自動的に検知するメディア検出機能が有効な場合、In-Sight センサとの通信が正しく行えないことがあります。ハブまたはスイッチを使用するか、PC のメディア検出機能を無効にすることを推奨します。詳細については、Microsoft サポート技術情報 239924 を参照してください。

ハブまたはスイッチに直接接続されているセンサに接続できない

注: ネットワークの形成にはスイッチを使用することを推奨します。

  • ネットワークケーブルと電源ケーブルがスイッチに正しく接続されていて、良好な状態であることを確認します。ネットワークケーブルをスイッチのイーサネットポートに挿入すると、緑色のライトが点灯して、そのポートで接続されたことを示します。
  • センサ背面の 24VDC LED と ENET LED が点灯していることを確認します。
  • ポートブロッキングやフィルタリングなど、ネットワークスイッチのオプション機能が有効になっていないことを確認します。

In-Sight センサが [In-Sight ネットワーク] ペインに表示されない

注:
  • 次の各手順を完了した後、[表示] メニューの [更新] をクリックして、[In-Sight ネットワーク] を更新してください。
  • 次の方法で問題が解決しない場合は、[センサ/デバイスをネットワークに追加] ダイアログを使用して、センサのネットワーク設定の再設定を行ってください。

センサに電源が供給されていることと、ネットワーク通信が機能していることを確認します。

電源ケーブルとイーサネットケーブルがセンサにしっかりと接続されていることを確認します。センサが電力を受け取っていることと、ネットワーク接続が検出されていることを確認するには、センサ背面の 24VDC LED と ENET LED が点灯していることを確認してください。

センサの IP アドレスが正しく設定されていることを確認します。

デフォルトの Microsoft ネットワークの基本の IP アドレスは、192.168.0.x です。x は 1 ～ 254 の番号です。0 と 255 は予約されているので使用しないでください。

センサのサブネットマスクが正しく設定されていることを確認します。

IP アドレスが 192.168.0.x の場合、デフォルトのサブネットマスクは 255.255.255.0 です。サブネットマスク中の 255 が設定されたオクテットは、すべてのデバイスで同じ値を共有しなければならないことを意味します。また、サブネットマスク中の 0 が設定されたオクテットは、デバイスごとに異なる値を使用しなければならないことを意味します。例えば、255.255.255.0 のサブネットマスクを使用するとき、PC の IP アドレスが 192.168.1.24 でセンサの IP アドレスが 192.168.0.98 の場合、3 番目のオクテットが一致しないため PC はセンサを自動認識できません。

センサの IP アドレスに ping して、センサがネットワーク上で認識されているかどうかを確認します。

コマンドプロンプトを開いて、センサの IP アドレスに ping を打ちます。例えば、IP アドレスが 192.168.0.1 のセンサに ping を発行するには、ping 192.168.0.1 というコマンドを入力します。Request timed out というメッセージが表示された場合、指定した IP アドレスはネットワーク上で検出されないことを意味します。

注: センサの電源を切って、ほかのデバイスが同じ IP アドレスを使用していないかどうか確認しなければならない場合があります。IP アドレスは、ネットワーク上で一意でなければなりません。

ローカルエミュレータに接続できない

Error 6003: エミュレータを起動できませんでした。

エラーメッセージの詳細

In-Sight Explorer によって検出される PC の IP アドレスが正しくない

  1. In-Sight Explorer を開きます。
  2. エミュレータに接続します。
  3. [センサ] メニューから [ネットワークの設定] を選択します。
  4. エミュレータの IP アドレスを確認します。
  • IP アドレスが 127.0.0.1 の場合、ネットワークカードが故障している可能性があります。
  • IP アドレスが正しくない場合、In-Sight Explorer が別のネットワークカード (無線 LAN カードなど) を検出した可能性があります。In-Sight Explorer は、PC の起動時に使用されたネットワークカードの IP アドレスを使用します。PC に複数のネットワークカードが装着されている場合は、ネットワークカードのバインド順を変更しなければならないことがあります。In-Sight は、リストの最初にある IP アドレスを使用します。
Closed Windows 7/Windows 10 でカテゴリ表示を有効にして、ネットワークカードのバインド順を変更するには
  1. [スタート] をクリックして、[コントロール パネル] ショートカットをクリックします。
  2. [ネットワークと共有センター] アイコンをクリックします。[ネットワークと共有センター] ウィンドウが開きます。
  3. 左側にあるペインで、[アダプタの設定の変更] をクリックします。
  4. <ALT> キーを押して、[詳細] メニューを表示します。[詳細] メニューの [詳細設定] をクリックします(管理者のパスワードまたは確認を求められた場合は、パスワードを入力するか、確認を行います)。
  5. [アダプタとバインド] タブを選択します。
  6. ダイアログの [接続] 部分で、変更の対象となる接続を選択します。
  7. ダイアログの [<接続名> のバインド] 部分で、移動する必要のあるネットワークカードを選択し、矢印ボタンを使用してネットワークカードをリストの一番上へ移動します。
  8. [OK] をクリックしてダイアログを閉じます。

IP アドレスとサブネットマスクに 2 桁しか入力できない

これは、PC の画面設定の影響です。

Closed Windows 7/Windows 10 を使用し、カテゴリ表示で修正を行うには
  1. [スタート] をクリックして、[コントロール パネル] ショートカットをクリックします。
  2. [個人設定] アイコンをクリックします。[個人設定] ウィンドウが開きます。
  3. 左側にあるペインで、[ディスプレイ] をクリックします(管理者のパスワードまたは確認を求められた場合は、パスワードを入力するか、確認を行います)。[ディスプレイ] ウィンドウが開きます。
  4. [小 - 100% (既定)] オプションが選択されていることを確認します (小 - 100% = 96 DPI)。
  5. [OK] をクリックしてダイアログを閉じます。
  6. DPI スケールを変更した場合は、PC を再起動します。

使用可能なポート

有効なポート番号は、In-Sight 通信のために予約されているポートを除いて、1 ～ 65535 の未使用の任意の番号です。PC のサービスで予約されているポート番号との競合を避けるために、In-Sight エミュレータの設定では、必ず 3000 (デフォルト) 以降のポート番号を割り当ててください。

センサのファームウェアをアップデートできない

ほとんどのファームウェアアップデート問題は、ファイアウォールに原因があります。すべてのファイアウォールが無効になっていることを確認してください。

ファイルを転送できない

別のアプリケーションが FTP ポートを制御していないかどうか確認します。

  1. In-Sight Explorer を閉じます。
  2. コマンドプロンプトを開いて、netstat -a というコマンドを入力します。
  3. ポート 21 でリスンしているアクティブな TCP 接続 (例: 「TCP 0.0.0.0:21」) を見つけます。これで、何らかのアプリケーション (FTP サーバなど) がデフォルトの FTP ポート 21 を使用していることがわかることがあります。その場合は、そのアプリケーションを停止するか、ポート番号を変更する必要があります。

ポート 21 を使用している可能性のある一般的なアプリケーションは、Windows のインターネットインフォメーションサービス (IIS) です。IIS がこのポートを使用していないことを Windows 7/Windows 10 で確認するには、次の手順に従って操作します。

Closed Windows 7/Windows 10 で、カテゴリ表示が有効な場合:
  1. [スタート] をクリックして、[コントロール パネル] ショートカットをクリックし、[コントロール パネル] を開きます。
  2. [管理ツール] アイコンをクリックします。
  3. [インターネット インフォメーション サービス (IIS) マネージャ] アイコンをダブルクリックします。(管理者のパスワードまたは確認を求められた場合は、パスワードを入力するか、確認を行います)。
  4. [インターネット インフォメーション サービス (IIS) マネージャ] ウィンドウで、ローカルコンピュータを展開します。
  5. [FTP サイト] ディレクトリを展開します。
  6. デフォルトの FTP サイトを右クリックし、[プロパティ] をクリックします。
  7. TCP ポートが 21 ではないことを確認します。21 の場合は、22 など未使用のポートに変更します。

センサに書き込めない

これは、ネットワーク内の変更によって発生することがあります。デバイスに ping を打つことはできても、WriteDevice または WriteImageFTP 関数ではデバイスに書き込めない場合があります。

  • ネットワーク上の DNS (Domain Name System) サーバがデバイスのホスト名を解決できていない可能性があります。その可能性があるときには、ホスト名の代わりに IP アドレスを入力してみてください。
  • WriteImageFTP 関数を設定するときには、ユーザ名とパスワードを入力して、FTP サーバにログオンします。In-Sight Explorer ソフトウェアには、FTP サーバが組み込まれています。この FTP サーバは、In-Sight Explorer が起動され、エミュレータが有効にされている場合に機能します。In-Sight Explorer の FTP サーバを使用する場合、デフォルトのユーザ名は admin であり、デフォルトのパスワードは未設定です。

関連項目

#ERR

エラーメッセージ

ファイアウォール

WriteImageFTP 関数の設定方法

Version: 5.6.0


ファイアウォール

In-Sight Explorer トラブルシューティング

多くのネットワークトポロジでは、ネットワーク上のさまざまなデバイスとやり取りするデータの種類を制御するために、ファイアウォールが実装されています。デフォルトの設定では、一部のファイアウォールで、In-Sight Explorer の動作とネットワークの In-Sight センサの検出が妨げられる場合があります。企業のファイアウォールによって保護されている場合、またはインターネットに接続していない場合は、Windows のファイアウォールを無効にすることができます。

  • In-Sight ポート

  • Microsoft Windows ファイアウォール設定

    • Windows 7/Windows 10

In-Sight ポート

In-Sight の通信には次のポートが使用されます。

ポート番号 | サービス
TCP 21 | FTP
TCP 23 | Telnet
UDP 68 | DHCP (In-Sight ビジョンシステムのみ)
TCP 80 | HTTP
TCP 502 | Modbus
TCP 1069 | In-Sight プロトコル
UDP 1069 | In-Sight Discovery
TCP 1070 | [マシンステータス] データ
TCP 1212 | アップグレードポート (PC のみ)
UDP 2222 | EtherNet/IP
TCP 5753 | 監査メッセージサーバ
TCP 44818 | EtherNet/IP
TCP 50000 | DataChannel

Microsoft Windows ファイアウォール設定

In-Sight Explorer および In-Sight OPC Server は Windows ファイアウォールプログラムの例外一覧に自動的に追加されません。Windows ファイアウォールプログラムがアプリケーションの一部をブロックしたことを示す警告ダイアログが表示される場合があります。プログラムを追加するには、警告ダイアログからアクセスを許可するか、以下を Windows ファイアウォールの例外一覧に手動で追加します。In-Sight Explorer については、次のアプリケーションを追加します。

  • [Program Files]\Cognex\In-Sight\In-Sight Explorer 5.x.x\In-Sight Explroer.exe

  • [Program Files]\Cognex\In-Sight\Emulators\x.x.x\In-Sight.exe

    注: Emulators フォルダ内には、4.x.x および 5.x.x の 2 つのサブディレクトリがあります。4.x.x ビジョンシステムに接続している場合、4.x.x サブディレクトリの In-Sight.exe ファイルが使用されます。5.x.x ビジョンシステムに接続している場合、5.x.x サブディレクトリの In-Sight.exe ファイルが使用されます。

In-Sight OPC サーバについては、次のアプリケーションを追加します。

  • [Program Files]\Cognex\In-Sight\In-Sight OPC Server 5.x.x\OpcInsight.exe

Windows 7/Windows 10

Windows のファイアウォールを無効にするには、次の設定を行います。

  1. [スタート] メニューで [コントロールパネル]、[システムとセキュリティ]、[Windows ファイアウォール] の順にクリックします。
  2. [通知設定の変更] をクリックします。
  3. 各 [Windows ファイアウォールを無効にする (推奨されません)] ラジオボタンを選択します。
  4. [OK] ボタンをクリックして、選択を確定します。

必要に応じて、以下の手順を実行して、外部機器からローカル PC のエミュレータに接続できるようにし、In-Sight ビジョンシステムを FTP サーバとして有効化して、Telnet サービスを使用可能にします。

  1. [スタート] メニューで [コントロールパネル]、[システムとセキュリティ]、[Windows ファイアウォール] の順にクリックします。
  2. [Windows ファイアウォールを介したプログラムまたは機能を許可する] をクリックします。
  3. [設定の変更] ボタンをクリックします。
  4. [別のプログラムの許可...] ボタンをクリックします。
  5. [参照...] ボタンをクリックして、In-Sight.exe 実行可能ファイルに移動します。デフォルトでは、このファイルは C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 4.6.0\Emulator\In-Sight.exe にあります。
  6. [参照] ダイアログで [開く] をクリックします。
  7. [プログラムの追加] ダイアログの [追加] ボタンをクリックします。
  8. [許可されたプログラムおよび機能] の表で、In-Sight.exe を使用するドメインに対応するチェックボックスをオンにします。
  9. [OK] をクリックします。
Version: 5.6.0


外部 FTP サーバを使用する In-Sight Explorer の設定

In-Sight 関数リファレンス

In-Sight Explorer では、内部 FTP サーバを使用して、In-Sight ビジョンシステムから In-Sight Explorer アプリケーションにファイル情報を転送します。ただし、代わりに外部のサードパーティ FTP サーバを使用するオプションも用意されています。この設定にする場合は、In-Sight Explorer のデフォルトの内部 FTP サーバを無効にし、使用中のネットワークで動作するように外部 FTP サーバを設定します。

  • 内部 In-Sight Explorer FTP サーバの無効化
  • EasyBuilder での外部 FTP サーバ情報の設定
  • スプレッドシートからの外部 FTP サーバの設定

内部 In-Sight Explorer FTP サーバの無効化

  1. [システム] メニューで、[オプション] を選択して [オプション] ダイアログボックスを開きます。

  2. [エミュレーション] を選択し、[エミュレータを使用する] チェックボックスをオフにして、[OK] をクリックします。

  3. ユーザプロンプトで [はい] をクリックして FTP サーバを無効にします。

注:

  • In-Sight Explorer から In-Sight ビジョンシステムにファイルを転送するには、ホスト名、ユーザ名およびパスワード (外部サーバで設定する場合) を指定して外部 FTP サーバを設定する必要があります。また、読み取りおよび書き込みのためのサーバの設定も行う必要があります。
  • 内部の In-Sight Explorer FTP サーバは、外部の FTP サーバを起動する前に無効にしてください。

EasyBuilder での外部 FTP サーバ情報の設定

  1. [通信] グループボックスの [FTP] を選択します。
  2. [画像] タブが、設定ペインに自動的に表示されます (デフォルト)。

  3. [追加] ボタンを押してエントリを追加し、[画像] および [設定] タブにある画像転送のパラメータを設定します。

    注: 1 つのジョブには、複数の画像エクスポート操作を追加できます。

  4. [設定] タブで、外部 FTP サーバのホスト情報を入力します。
    1. [ホスト名]、[ユーザ名]、[パスワード]、および [接続タイプ] を入力します。
    2. パラメータを設定したら、[OK] をクリックします。

  5. In-Sight ビジョンシステムをオンラインにします。画像転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時には画像は転送できません。

  6. ビジョンシステムの画像取り込みをトリガします。取り込まれた画像ごとに、画像ファイル ([ファイルフォーマット] パラメータに応じて、BMP または JPG) がエクスポートされ、[ホスト名] パラメータで指定したホストに保存されます。

スプレッドシートからの外部 FTP サーバの設定

  1. スプレッドシートでセルを選択します。

  2. [関数] タブに移動し、関数 (WriteFTP、WriteImageFTP など) を挿入してそのプロパティシートを開きます。
  3. プロパティシートで次のパラメータを設定します。
    1. [ホスト名]、[ユーザ名]、[パスワード] (設定されている場合)、および [ファイル名] を入力します。
    2. パラメータを設定したら、[OK] をクリックします。
  4. ビジョンシステムをオンラインに切り替えて、外部 FTP サーバ経由でのファイル転送を実行します。
  5. ビジョンシステムをトリガします。取り込まれた各画像は、指定したホストに保存されます。

注:

  • 外部 FTP サーバでファイルを転送するには、ビジョンシステムがオンラインになっている必要があります。
  • In-Sight Explorer と選択したビジョンシステムの間のファイル転送を円滑に実行するには、外部 FTP サーバが稼働している必要があります。


BeadFind および BeadInspect 関数の使用

方法

このトピックでは、BeadFind および BeadInspect 関数がどのように機能するか、さらにこれらの関数を設定する基本手順の概要を説明します。

注:
  • BeadFind および BeadInspect 関数は、In-Sight ファームウェア 5.5.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。
  • BeadFind 関数と BeadInspect 関数はカラー画像をサポートしていません。カラー画像がロードされると、自動的にグレースケール画像に変換されます。
  • 概要

  • BeadFind 関数の設定

  • BeadInspect 関数の設定
  • BeadInspect 関数の実行
  • 関連項目

概要

BeadFind および BeadInspect 関数の操作には、設定時および実行時という 2 つのフェーズがあります。次の図は、BeadFind および BeadInspect 関数の基本的なワークフローについて説明しています。

BeadFind 関数

BeadFind 関数は、次の手順で構成されています。

  1. ビードサンプルの位置の選択

    2. BeadFind 関数をスプレッドシートに挿入した後、[ビードサンプルの位置] の赤い円の図形を、ビード上のスポットに移動します。円の図形がビードの両側を覆うようにします。

  2. ビードパス候補の検出

    3. [ビードパスの検出] ボタンをクリックします。BeadFind 関数によって、指定されたサンプルの位置からビードパス候補の検出が自動的に開始されます。

  3. 最適なビードパスの選択

    4. 検出が完了したら、検出されたビードパス候補を表示して、最適なビードパスを選択することができます。

  4. ビードパスの編集 (オプション)

    検出されたビードパスが最適でない場合は、必要に応じて選択したビードパスを変更します。

  5. 選択したビードパスの登録

    6. [ビードパスの登録] ボタンをクリックして、選択したビードパスを登録します。

BeadInspect 関数

BeadFind 関数を使用してサンプルビードを検出して登録したら、BeadInspect 関数を使用してビードの解析基準を精緻化し、セットアップ時にビードの欠陥を識別するための測定ルールを作成します。実行時に、ビードパスが登録済みのモデルと比較されて、ビードに欠陥またはギャップがあるかどうか調べられます。

BeadInspect プロパティシートでビードの解析基準を参照する場合、疑似欠陥を取り除くためのパラメータ調整には 2 つの手法があり、[全般] タブで直接パラメータを調整するか、または [欠陥] タブのそれぞれの欠陥の隣にある [修正] ボタンを使用してツールのヒントを受け入れます。

それぞれのビードの検査について、BeadInspect 関数は欠陥の合計数を返し、欠陥の詳細が表形式で表示されます。デフォルトでは、自動的に最初の 10 個の欠陥が表に含められます。この表を拡大すると、より多くの欠陥を表示することができます。さらに、関連するその他のデータアクセス関数を使用すると、BeadInspect 関数で生成されたデータに関して独自の処理と解析を実行するための追加情報を取集することができます。

BeadFind 関数の設定

  1. サンプル画像をジョブにロードします。

    サンプル画像要件:
    • BeadFind および BeadInspect 関数は、パーツ上のビード特徴が強調された高コントラストの画像を使用して最適に機能します。
    • BeadFind ツールの設定に使用するサンプル画像には、欠陥のない、既知の良好なビードが含まれている必要があります。
  2. BeadFind 関数をスプレッドシートに挿入します。

  3. [ビードサンプルの位置] を選択して [グラフィックスの編集] [image] ボタンをクリックします。

    ビードサンプルの位置を設定するためのヒント:

    • ビードサンプルの位置は、ビード全体の典型であるビードセクションに配置してください。

    • ビードサンプルの位置は、ノイズのないビードの直線部分に配置してください。
    • 穴またはパーツのエッジ近くにあるビードサンプルの位置を選択しないでください。
    • ビードパスの一部が見つかった場合は、サンプル円のサイズを調整したり、ビードパスが現在トレースされていない位置へビードサンプルの位置を移動したりしてから、再度ビードを探してください。
    • ビードの幅が著しく異なる場合は、ビードの中間的な幅のセクションを、ビードサンプルの位置として選択してみてください。

  4. 対話型グラフィックスモードで、赤い円をビード上にドラッグして、ビードサンプルの位置を設定します。

    赤い円は、ビード全体の典型であるビードのセクションに配置する必要があり、赤い円はビードの両方のエッジを囲んでいる必要があります。ビードサンプルの位置を設定したら、Enter キーまたは [image] をクリックしてプロパティシートに戻ります

  5. [ビードパスの検出] ボタンをクリックします。

    検出されたビードパス候補が青く表示され、検出されたビードパスの数が [ビードパスの検出] ボタンの右側に表示されます。

    ヒント: ビードが見づらい場合は、[フォーマット] → [セルのフォーマット] を選択して、[グラフィックス] タブで [線の幅] を調整します。

  6. [選択したビードパス] ボックスで番号を選択して、ビードパス候補を確認します。

    次の例では、5 つのビードパス候補が検出され、番号 3 のビードパスが選択されたビードパスとなっています。

  7. (オプション) 選択したビードが最適でない場合は、必要に応じて [ビードパスの編集] ボタンをクリックしてビードパスを変更します。

    ポリラインのさまざまな部分にマウスカーソルを置くと、マウスカーソルが自動的に変換され、次のアクションが有効になります。

    マウスアイコン 説明 右クリックコンテキストメニュー

    ポリライン上の点を選択します。選択された点は緑色にハイライトされます。この点は、マウスカーソルをドラッグして移動したり、Delete キーまたは右クリックコンテキストメニューを使用して削除したりすることができます。
    • 点を削除
    • ここにポリラインを開く

    ポリラインパス上にマウスカーソルを置きます。選択された位置は緑色にハイライトされます。点を追加するには、マウスをクリックするか右クリックコンテキストメニューを使用します。
    • 点の挿入
    • ここにポリラインを開く

    複数の点を選択するには、これらの点を覆うようにボックスを描画します。選択された点は緑色にハイライトされます。点を選択したら、マウスカーソルをドラッグして移動したり、Delete キーまたは右クリックコンテキストメニューを使用して削除したりすることができます。
    • 点を削除

  8. ビードパスを選択して変更したら、[ビードパスの登録] ボタンをクリックしてビードパスを登録します。登録済みのビードパスは緑色で表示されます。

  9. [OK] をクリックして BeadFind ツールを終了します。
注: プロパティシートを閉じると、選択したビードパスのみが保存されます。検出されたその他のビードパス、およびこれらのビードパスに行われた編集は破棄されます。

BeadInsepct 関数の設定

  1. BeadInsepct 関数をスプレッドシートに挿入します。
  2. プロパティシート内で [BeadFind] パラメータをクリックします。Ctrl + Shift + A キーを押すか、絶対参照 [image] ボタンをクリックして、BeadFind パラメータおよびセル参照を、以前に作成された BeadFind データに設定します。その後 [OK] をクリックします。

  3. BeadInspect をセルに挿入すると、欠陥が 0 の結果テーブルがスプレッドシート内に作成されます。

    注: 登録ビードは、定義上は良好なビードです。したがって、BeadInspect 関数の初期パラメータは、参照された BeadFind 関数の結果に基づいて自動的に設定され、登録ビードパスの検査時に確実に欠陥が検出されないようにします。

  4. 登録画像をジョブにロードします。

    画像がロードされると、自動的に結果テーブルは最新の検査結果で更新されます。

  5. 欠陥を見直します。

    BeadInspect のプロパティシートを開き、[欠陥] タブに移動して欠陥を見直します。デフォルトでは、欠陥リストは欠陥インデックスでグループ化されています。

    次の画像は、登録画像内で検出された 8 つのビードの欠陥の概要を表しています。このビードは欠陥が 1 つだけあるビードとして定義されています (欠陥 5)。検出されたその他の欠陥は疑似欠陥であり、検査中には無視する必要があります。BeadInspect のパラメータは、設定時に調整して疑似欠陥を除去し、今後の検査時に疑似欠陥が特定されないようにする必要があります。

    注: 下記のビードの例は、デモンストレーションのみを目的としています。

    欠陥タイプと関連パラメータ:

    欠陥タイプ | 関連パラメータ | 説明

    狭すぎる

    ビード幅:最小 (%)

             狭すぎるセクションについてビードを検査するために使用されます。

    幅が広すぎる

             ビード幅:最大 (%) 広すぎるセクションについてビードを検査するために使用されます。

    アンダーフィル

    ビードのカバレージ:最小(%)

             ビードのセクションに適用された素材が少なすぎる場合のアンダーフィルの欠陥を検査するために使用されます。

    オーバーフィル

    ビードのカバレージ:最大(%)

             ビードのセクションに適用された素材が多すぎる場合のオーバーフィルの欠陥を検査するために使用されます。
    ステップの変化 | ビードのエッジステップ:最大(%) | ビードエッジに沿った突起またはノッチを検査するために使用されます。粗いまたは不均一なエッジを含むビードでは、許容値を上げるためにより高い [ビードのエッジステップ最大] 値を使用します。なめらかなエッジを含むビードでは、より低いビードステップ値を使用します。

    第 1 エッジがありません

    第 2 エッジがありません

    両方のエッジがありません

    コントラストしきい値

             欠落しているエッジの欠陥を検査するために使用されます。コントラストしきい値より低いコントラストのビードエッジは、欠陥として識別されます。
    ビードエッジ位置の許容値 (%) | ビードエッジ位置の変更を検査するために使用されます。ビードエッジ位置の許容値を外れたビードエッジは検出されません。

  6. BeadInspect のパラメータを調整して疑似欠陥を除去します。

    疑似欠陥は、[欠陥] タブで [修正] ボタンを使用して自動的に修正されるようにするか、[全般] タブで欠陥に関連付けられているパラメータを手動で調整することができます。

    Closed [エッジ塗りつぶしを実行] オプションを使用した欠落エッジ欠陥の修正
    注: [エッジ塗りつぶしを実行] オプションは、[第 1 エッジがありません] および [第 2 エッジがありません] の欠陥タイプの場合にのみ機能します。両方のエッジがない場合には使用できません。

    1. 欠陥リストから [欠陥 0] を選択します。欠陥を選択すると、画像内の欠陥の位置まで画像がパンおよびズームされます。

    2. [修正] ボタンをクリックして、示されたメニューから [エッジ塗りつぶしを実行] を選択します。

    3. シアンのボックスが描画されて、画像内の塗りつぶし領域を示します。

    4. 欠陥が修正されると、欠陥リストテーブルから [欠陥 0] が削除されます。

    Closed パラメータの更新オプションを使用した欠陥の修正

    1. 欠陥リストから [欠陥 2] を選択します。

      ビードのこのセクションでは 3 種類の欠陥が報告されています。[第 1 エッジがありません]、[狭すぎる]、および [アンダーフィル] です。

    2. [修正] ボタンをクリックして、示されたメニューから [更新 ビードエッジ位置の許容値 (%)] を選択します。

      • [第 1 エッジがありません] に関連付けられているパラメータは、[ビードエッジ位置の許容値 (%)] です。実際に報告されている値は 40 であり、[全般] タブに表示されている、[ビードエッジ位置の許容値 (%)] の指定された値 33 を上回っています。
      • この欠陥は、[ビードエッジ位置の許容値 (%)] の値を 33 から 40 に更新することで修正することができます。

    3. [修正] ボタンを押すと、[ビードエッジ位置の許容値 (%)] の値が自動的に 40 に更新され、エッジが検出されるようになります。

    4. この欠陥タイプが修正されると、[欠陥 2] リストから削除されます。

    5. [欠陥 2] リストで次の欠陥を選択します。

    6. [修正] ボタンをクリックして、示されたメニューから [更新 ビード幅:最小 (%)] を選択します。

      • [第 1 エッジがありません] に関連付けられているパラメータは、[ビード幅:最小 (%)] です。実際に報告されている値は 52.3 であり、[全般] タブに表示されている、[ビード幅:最小 (%)] の指定された値 79 を下回っています。
      • この欠陥は、[ビード幅:最小 (%)] の値を 79 から 52 に下げることで修正することができます。

    7. [修正] ボタンを押すと、[全般] タブの [ビード幅:最小 (%)] の値が自動的に更新され、同じエッジセクションが欠陥として識別されないようになります。

    8. [欠陥 2] リストに残っている最後の欠陥を選択します。

    9. [修正] ボタンをクリックして、示されたメニューから [更新 ビードのカバレージ:最小 (%)] を選択します。

      • [第 1 エッジがありません] に関連付けられているパラメータは、[ビードのカバレージ:最小 (%)] です。実際に報告されている値は 52 であり、[全般] タブに表示されている、[ビードのカバレージ:最小 (%)] の指定された値 76 を下回っています。
      • この欠陥は、[ビード幅:最小 (%)] の値を 76 から 52 に下げることで修正することができます。

    10. [修正] ボタンを押すと、[全般] タブの [ビードのカバレージ:最小 (%)] の値が自動的に更新され、同じエッジセクションが欠陥として識別されないようになります。
    11. [欠陥 2] リストの欠陥タイプがすべて修正されると、欠陥リストテーブルから [欠陥 2] が削除されます。

    Closed 欠陥タイプ別の欠陥のグループの修正

    それぞれの欠陥を個別に修正する代わりに、欠陥タイプ別に欠陥のグループを修正することもできます。

    1. BeadInspect のプロパティシートを開き、[欠陥] タブに移動します。 ボタンをクリックして、欠陥タイプ別に欠陥リストをグループ化します。

      この例では、欠陥 1 と 6 が同じ欠陥タイプで報告されており、関連パラメータは [ビードのカバレージ:最大 (%)] です。予測される [ビードのカバレージ:最大 (%)] の値は 134 ですが、実際に報告されている欠陥 1 と 6 の [ビードのカバレージ:最大 (%)] の値は、157.7 と 140 です。

    2. 両方の欠陥を修正するには、[全般] タブに移動して、[ビードのカバレージ:最大 (%)] の値を 158 に更新します。

    3. 値が更新されると、[オーバーフィル] 欠陥タイプ全体が欠陥リストテーブルから削除されます。

    Closed [検出エリアの編集] の使用

    [ビードパスの登録] が BeadFind 関数で実行されると、マスクおよびエッジ塗りつぶしエリアが自動的に計算され、ビード検出画像に追加されます。

    事前設定されている検出エリアの編集、検査からマスクできる新しい検出エリアの追加、またはエッジの塗りつぶしを実行するには、[全般] タブの [検出エリアの編集] ボタンをクリックします。

    マスクエリアを追加するには:

    注: マスクエリアは注意して使用してください。エリアがマスクされている場合、今後の検査では無視され、マスクされているエリア内の欠陥は報告されません。
    1. メニューから [マスクエリア] を選択します。

    2. ビードパス上で、マスクエリアを作成する位置を選択します。

    3. マスクエリアを作成する点をドラッグします。

    4. 必要に応じて、マスクエリアを調整するいずれか一方の点を移動します。

    マスクエリアを削除するには:

    1. メニューから [マスクエリアを削除] を選択します。

    2. 削除するマスクエリアを選択します。

    3. 選択したエリア内のマスクが削除されます。

    エッジ塗りつぶしエリアを追加するには:

    注: [エッジ塗りつぶしエリア] オプションは、[第 1 エッジがありません] および [第 2 エッジがありません] の欠陥タイプの場合にのみ機能します。このオプションは、両方のエッジがない場合には使用できません。
    1. メニューから [エッジ塗りつぶし] を選択します。

    2. ビードパスの 1 つ (赤いポリライン) で、エッジ塗りつぶしエリアを作成する位置を選択します。

    3. エッジ塗りつぶしエリアを作成する点をドラッグします。

    4. 必要に応じて、エッジ塗りつぶしエリアを調整するいずれか一方の点を移動します。

    エッジ塗りつぶしエリアを削除するには:

    1. メニューから [エッジ塗りつぶしを削除] を選択します。

    2. 削除するエッジ塗りつぶしエリアを選択します。

    3. 選択したエリア内で塗りつぶされているエッジが削除されます。

  7. すべての疑似欠陥が除去されると、この例では欠陥リストテーブルに表示されている欠陥は 1 つだけになります。

  8. [OK] をクリックして BeadInspect スプレッドシートを終了します。
  9. 次の画像をロードし、必要なビードインスタンスがすべて登録されるまで手順 5 ～ 8 を繰り返します。
  10. ジョブを保存します。

検査の設定値の精緻化

検査のパフォーマンスを最適にする最良の方法は、良好なビードおよび不良なビードの両方があるパーツなど、実際のパーツの画像を多数使用することです。これらのビードの画像は、実行時に発生する可能性のあるすべてのビードインスタンスの典型となるはずです。これによって、エッジ塗りつぶしエリアやマスクエリアを必要に応じて使用するなど、検査の設定値を精緻化することができます。

パフォーマンスの検証

BeadFind および BeadInspect 関数を設定した後、BeadInspect 関数が期待通りに機能することを検証することが重要です。BeadInspect 関数をこれまでの画像および新しい画像セットすべてで再実行し、すべての欠陥が正しく識別され、疑似欠陥が報告されないことを確認するよう推奨します。

BeadFind および BeadInspect 関数の実行

実行時に、In-Sight ビジョンシステムはオンラインになり、ジョブによって定義されているとおりに画像を取り込みます。画像が取り込まれると、自動的にビードが検出されて、登録されているビードモデルと比較されます。この結果はデータアクセス関数を介して出力され、BeadInspect の [欠陥] タブにビードの欠陥に関する追加情報が表示されます。

関連項目

  • BeadFind および BeadInspect 関数について
  • BeadFind
  • BeadInspect
  • データアクセス関数


Caliper ツールの使用

In-Sight Explorer 関数リファレンス

Caliper ツールを使用するには、以下の手順を実行する必要があります。

  1. [Caliper] ダイアログを開く
  2. Caliper ツールの入力の設定
  3. 画像領域の設定
  4. コントラストの得点付け方法の設定
  5. サイズの得点付け方法の設定
  6. またがる得点付け方法の設定
  7. 位置得点付け方法の設定

この例では、Caliper ツールを使用して、ハイコントラストで画像領域の中心近くにあり、画像領域の中心にまたがり、エッジ距離が予期される距離に近くなっているエッジペアを検出します。

1. [Caliper] ダイアログを開く

  1. スプレッドシートの空のセルを右クリックし、[関数の挿入] を選択して [関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [ビジョンツール] リストを展開します。
  3. [エッジ] ツールカテゴリを選択します。
  4. 関数リストから Caliper 関数を選択して、[OK] ボタンを押すか、関数をダブルクリックします。

  5. [Caliper] ダイアログが表示されます。

2.Caliper ツールの入力の設定

  1. [エッジモード] を [エッジペア] に設定します。
  2. この例では、[第 1 エッジ] 極性を [黒→白] に設定します。
  3. [第 2 エッジ] 極性を [白→黒] に設定します。
  4. [エッジ距離] をエッジペアのエッジ間の予期される距離に設定します。
  5. [表示] を [入力と結果のグラフィックス] に変更します。
  6. [OK] ボタンをクリックします。

3.画像領域の設定

  1. 先にスプレッドシートに挿入した Caliper エッジ構造体を右クリックします。
  2. [セルのグラフィック] を選択します。
  3. 検査するエッジペアが領域内に入るまで領域を調整します。
  4. 領域内をダブルクリックしてスプレッドシートに戻ります。

4.コントラストの得点付け方法の設定

  1. スプレッドシートで Caliper エッジ構造体をダブルクリックします。
  2. [得点付け方法] タブをクリックすると、デフォルトのコントラスト得点付け方法エディタが表示されます。
  3. 上部スライダを予期されるエッジコントラスト (以下の図に示すように、エッジペアの平均値) の下に設定します。ほかのスライダを調整して、要求に適合する得点計算を作成できます。ここに示す設定では、平均コントラストが 84 より大きいすべてのエッジペアに 100 得点が与えられ、ゼロに近づくにつれて得点が下がります。
  4. [OK] をクリックします。
  5. エッジペアの得点を確認してください。得点を左右するのは、コントラスト得点付け方法のみです。

5.サイズの得点付け方法の設定

  1. スプレッドシートで Caliper エッジ構造体をダブルクリックします。
  2. [得点付け方法] タブをクリックします。
  3. [Add Scoring Function (得点付け関数の追加)] ドロップダウンリストで [サイズ] を選択し、[追加] ボタンをクリックします。サイズ得点付け方法エディタが表示されます。
  4. ここでは、予期されるエッジサイズとの差にのみ焦点を当て、サイズが [エッジ距離] 設定より大きいか小さいかは考えません。[左右対称モードを使用する] チェックボックスをオンにします。
  5. 差が 5 ピクセルのエッジペアの得点が 100 となり、差が 25 ピクセルまで増加するにつれて得点が減少し、25 ピクセルの差で得点がゼロとなるようにスライダを調整します。
  6. [OK] ボタンをクリックします。
  7. エッジペアの得点を確認してください。これで得点は、コントラストの幾何平均とサイズの得点付け方法に依存して決まるようになります。

6.またがる得点付け方法の設定

  1. スプレッドシートで Caliper エッジ構造体をダブルクリックします。
  2. [得点付け方法] タブをクリックします。
  3. [Add Scoring Function (得点付け関数の追加)] ドロップダウンリストで [またがる] を選択し、[追加] ボタンをクリックします。編集可能なパラメータが存在しないことを示すメッセージが表示されます。
  4. [Caliper]　ダイアログは開いたままにします。

エッジペアが画像領域の中心にまたがる場合、またがる得点付け方法による得点は 100 となり、またがらない場合は 0 になります。

これで得点は、コントラストの幾何平均、またがるおよびサイズ得点付け方法に依存して決まるようになります。

7.位置得点付け方法の設定

  1. [Add Scoring Function (得点付け関数の追加)] ドロップダウンリストで [位置] を選択し、[追加] ボタンをクリックします。位置得点付け方法エディタが表示されます。
  2. ここでは、画像領域内のエッジペアの中心位置のみに焦点を当てます。スケーリングは不要とします。[中心エッジ] と [中心領域] が選択されていることを確認します。
  3. 中心の 5 ピクセル内のエッジペアの得点が高くなり、エッジペアが 20 ピクセルまで遠のくにつれて得点が減少し、20 ピクセルの位置で得点がゼロとなるようにスライダを調整します。
  4. [OK] ボタンをクリックします。
  5. エッジペアの得点を確認してください。これで得点は、コントラストの幾何平均とサイズの得点付け方法に依存して決まるようになります。

この例での得点は、コントラスト、サイズ、位置およびまたがる得点の幾何平均 (コントラスト得点 X サイズ得点 X 位置得点 X またがる得点の四乗根) です。

関連項目

Caliper ツール


ExtractColor ツールの使用

In-Sight Explorer 関数リファレンス

カラーを抽出するには、以下の手順に従う必要があります。

  1. [ExtactColor の登録] ダイアログを開く
  2. カラーモデルの追加
  3. カラーモデルでのカラーの追加と減算
  4. カラー許容値の調整
  5. 複数のカラーモデルの使用
  6. 画像マーキング
  7. ExtractColor 関数の追加

この例では、TrainExtractColor 関数と ExtractColor 関数を使用し、ピクセル計数に基づいて画像内のオブジェクトが赤いリンゴなのかまたはオレンジなのかを判別します。

1. [ExtactColor の登録] ダイアログを開く

  1. スプレッドシートの空のセルを右クリックし、[関数の挿入] を選択して [関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [ビジョンツール] リストを展開します。
  3. [カラー] ツールカテゴリを選択します。
  4. 関数リストから TrainExtractColor 関数を選択して、[OK] ボタンをクリックするか、関数をダブルクリックします。

  5. [ExtractColor の登録] ダイアログが表示されます。

2.カラーモデルの追加

カラーモデルはカラーの集合体であり、画像内のオブジェクトと背景の定義に使用されます。各カラーモデルは 3D カラー空間を表し、この空間内で、取り込むオブジェクトカラーと背景色の RGB 値を追加または減算します。複数のカラーモデルを使用する場合、カラーモデルは結果においてランク付けされます。

  1. [カラーモデル] の下の [New Model (新しいモデル)] をクリックします。新しいカラーモデルがデフォルト名の [Model_1] として [ライブラリ] に追加されます。
  2. 必要に応じて、最初に追加するときにカラーモデル名を変更します。カラーモデル名は、モデル名をハイライト表示して [ライブラリ] リストの上の名前変更ボタン [image] 　をクリックすることによって、いつでも変更できます。
  3. カラーモデルは、必要に応じて、ハイライト表示して削除 [image] ボタンをクリックすることによって削除できます。

3.カラーモデルでのカラーの追加と減算

  1. カラーモデルの名前をクリックすることにより、変更するカラーモデルを選択します。
  2. ダイアログの [登録] セクションで、カラーの定義に使用する対象領域 (ROI) の形状 (領域、円、円環、ポリゴン、またはフリーハンド) を選択します。この例では、[Circle ROI　(円 ROI)] を使用します。
  3. [加色の作成] ボタンをクリックして対話型グラフィックスモードに入り、追加する RGB 値が含まれるように円 ROI の画像内での位置を決めます。

  4. ROI を設定したら、[ジョブの編集] ツールバーで [OK] ボタンをクリックします。カラーモデルに追加されるカラーには、定義した ROI 内でのピーク RGB 値が含まれています。
  5. カラーモデルには含めないカラーが何かある場合は、上記のプロセスを繰り返し行い、今度は [新しいカラーの減算] をクリックします。この例では、影と白い背景が減算されます。
  6. 上下の領域を使用して、カラーモデルでのカラーの処理順序を変更します。検査に適用される最初のカラーがリストの最初に表示されます。

4.カラー許容値の調整

画像マーキングは、検出されているオブジェクトの量を示します。感度は、ダイアログの [カラー許容値] セクションで [暗]、[名]、[Highlights (ハイライト)]、および [色相] を使用することによって増減できます。

[暗] | [暗] 設定を大きくすると、Black(0,0,0) に向かってカラーに空間が追加されます。
[明] | [明] 設定を大きくすると、White (255,255,255,0) に向かってカラーに空間が追加されます。
[Highlights (ハイライト)] | [Highlights (ハイライト)] 設定を大きくすると、White (255,255,255,0) に向かって初期カラー位置からカラーに空間が追加されます。
[色相] | [色相] 設定を大きくすると、カラー空間での 3 次元の初期カラーの 3D「ボックス」が増大します。

[カラー許容値] に変更があると、リンゴ画像で検出されるピクセル数が増加します。

5.複数のカラーモデルの使用

  1. 2 番目のカラーモデルをライブラリに追加します。最初のカラーモデルでは、赤いリンゴの画像で検出される赤ピクセルの数を数えます。2 番目のカラーモデルは、オレンジの画像でピクセルを検出するように設定されます。
  2. カラー (領域、円、円環、ポリゴン、またはフリーハンド) の定義に使用する ROI を選択します。この例では、[Circle ROI　(円 ROI)] を使用します。
  3. [加色の作成] ボタンをクリックして対話型グラフィックスモードに入り、追加する RGB 値が含まれるように円 ROI の画像内での位置を決めます。この例では、オレンジのカラーが一様ではなく、円内にその大部分を収めます。
  4. ROI を設定したら、[ジョブの編集] ツールバーで [OK] ボタンをクリックします。
  5. 最後に、オレンジの大部分がハイライト表示されるまで [カラー許容値] 設定を調整します。

6.画像マーキング

ダイアログの下部にある [Image Marking (画像マーキング)] ボタンにより、カラーとカラーモデルを追加するときに画像内でハイライト表示する部分を設定できます。選択する設定は、ライブラリ内でアクティブな (ハイライト表示した) カラーモデルに適用されます。

グループ全体 | 画像内のカラーモデルのカラーすべてがマーキングされます。
選択カラーまで | 3 つのリストのいずれかで 2 番目のカラーを選択すると、画像で最初と 2 番目のカラーがマーキングされます。
選択カラーのみ | 画像内の選択されたカラーのみがマーキングされます。

7.ExtractColor 関数の追加

  1. [TrainExtractColor] ダイアログで [OK] ボタンをクリックします。
  2. スプレッドシートの空のセルを右クリックし、[関数の挿入] を選択して [関数の挿入] ダイアログを開きます。
  3. [関数の挿入] ダイアログの左側で、ツールカテゴリの [ビジョンツール] リストを展開します。
  4. [カラー] ツールカテゴリを選択します。
  5. 関数リストから ExtractColor 関数を選択して、[OK] ボタンをクリックするか、その関数をダブルクリックします。
  6. ExtractColor プロパティシートが表示されます。

  7. [Extract Color Library (カラーライブラリの抽出)] パラメータに、TrainExtractColor 関数によって返される [image] データ構造体へのセル参照を挿入します。このセルには、ExtractColor 関数で使用されるカラーモデルが格納されています。
  8. このパラメータを設定したら、[OK] ボタンをクリックしてプロパティシートを閉じます。
  9. リンゴ画像の結果を以下に示します。

  10. オレンジ画像の結果を以下に示します。

この例では、検査により、関連付けられているモデルのピクセル数に基づいて、画像内の果物がリンゴとオレンジのどちらなのかを判別できます。

関連項目

TrainExtractColor ツール

ExtractColor ツール


MatchColor ツールの使用

In-Sight Explorer 関数リファレンス

カラーを照合するには、以下の手順に従う必要があります。

  1. [TrainMatchColor] ダイアログを開く
  2. カラーの追加
  3. MatchColor 関数の追加

この例では、MatchColor ツールを使用して、画像内にカラーが存在するかどうかを判別します。

1. [MatchColor の登録] ダイアログを開く

  1. スプレッドシートの空のセルを右クリックし、[関数の挿入] を選択して [関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [ビジョンツール] リストを展開します。
  3. [カラー] ツールカテゴリを選択します。
  4. 関数リストから TrainMatchColor 関数を選択して、[OK] ボタンをクリックするか、その関数をダブルクリックします。

  5. [MatchColor の登録] ダイアログが表示されます。

2.カラーの追加

  1. ダイアログの [登録] セクションで、カラーの定義に使用する対象領域 (ROI) の形状 (領域、円、円環、ポリゴン、またはフリーハンド) を選択します。この例では、[Circle ROI　(円 ROI)] を使用します。
  2. [加色の作成] ボタンをクリックして対話型グラフィックスモードに入り、追加するカラーが含まれるように円 ROI の画像内での位置を決めます。

  3. ROI を設定したら、[ジョブの編集] ツールバーで [OK] ボタンをクリックします。ライブラリに追加されるカラーには、定義した ROI 内でのすべてのカラーの平均が含まれています。この例の場合、次に設定する緑と青が類似しているため、許容値設定の暗限界と明限界はそれぞれ 0.9 と 1.2 に設定されます。
    4. [暗] | [カラー空間] を [RGB] に設定した場合、[暗] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比例的に低くなります。[カラー空間] が [HSI] に設定されている場合、[暗] の範囲を拡大すると、登録される色の明度が小さくなります。
[明] | [カラー空間] を [RGB] に設定した場合、[明] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比例的に高くなります。[カラー空間] が [HSI] に設定されている場合、[明] の範囲を拡大すると、登録される色の明度が大きくなります。
  4. ほかの赤および青のカラーでこのプロセスを繰り返し行います。青と赤の明許容値と暗許容値は、0.9 と 1.4 に設定されます。

  5. カラーが最終処理されたら、[TrainMatchColor] ダイアログで [OK] ボタンをクリックしてダイアログを閉じます。

3.MatchColor 関数の追加

  1. スプレッドシートの空のセルを右クリックし、[関数の挿入] を選択して [関数の挿入] ダイアログを開きます。
  2. [関数の挿入] ダイアログの左側で、ツールカテゴリの [ビジョンツール] リストを展開します。
  3. [カラー] ツールカテゴリを選択します。
  4. 関数リストから MatchColor 関数を選択して、[OK] ボタンをクリックするか、その関数をダブルクリックします。
  5. MatchColor プロパティシートが表示されます。

  6. [カラーライブラリ] パラメータに、TrainMatchColor 関数によって返される [image] データ構造体へのセル参照を挿入します。このセルには、MatchColor 関数で使用されるカラーライブラリが格納されています。
  7. このパラメータを設定したら、[OK] ボタンをクリックしてプロパティシートを閉じます。
  8. 緑の画像の結果を以下に示します。

  9. 青の画像の結果を以下に示します。

  10. 赤の画像の結果を以下に示します。

この例では、検査により、色距離得点に基づいてカラー (緑、青、または赤) が判別されます。

関連項目

TrainMatchColor ツール

MatchColor ツール


OCRMax 関数の設定

ハウツー

OCRMax 関数は、入力として対象領域 (ROI) を使用し、セグメンテーションと呼ばれるプロセスを通して 1 行のテキストを個々の文字の画像に分割します。このトピックでは、この関数の動作方法 (登録時と実行時の両方) およびセグメンテーションを適切に実行するために [セグメント] パラメータを最適に設定する方法について説明します。

  • OCRMax 関数の使用方法

    • 登録画像のロード
    • OCRMax 関数の登録
  • OCRMax 関数の実行
  • セグメンテーションの概要

  • セグメンテーションプロセス

    • 行の最適化
    • 正規化
    • 2 値化
    • フラグメント化
    • グループ化
    • 解析

  • 実行時における最適なパフォーマンスの実現

    • 推奨される文字および領域のサイズ
    • セグメンテーション速度の向上
  • 関連項目

OCRMax 関数の使用方法

OCRMax 関数の操作には、登録時および実行時という 2 つのフェーズがあります。

  • 登録時の処理には、読み取り対象文字の複数の画像のロード、画像からの文字の抽出、文字のセグメンテーション、および文字の登録済みフォントデータベースの作成があります。
  • 実行時の処理には、In-Sight ビジョンシステムのオンラインへの移行、画像の取り込み、および登録済みフォントデータベースに基づいた文字の抽出と分類があります。

登録画像のロード

  1. [画像] メニューから [記録/再生のオプション] を選択します。
  2. [記録/再生のオプション] ダイアログは、自動的に [再生] タブが表示された状態で開きます。表示されていない場合は、[再生] タブをクリックします。
  3. [再生フォルダ] セクションで [参照] ボタンをクリックし、[フォルダの参照] ダイアログを表示します。登録画像が含まれているディレクトリに移動し、[OK] ボタンを押して続行します。
  4. [再生フォルダ] には指定したディレクトリが表示されます。[画像カウント] はこのディレクトリに保存されている画像の数を示しています。[記録/再生のオプション] ダイアログの [OK] ボタンをクリックして、続行します。

OCRMax 関数の登録

  1. 最初の登録画像をロードします。
  2. OCRMax 関数をスプレッドシートに挿入します。
  3. [全般] タブから、[領域] パラメータをダブルクリックして対話型グラフィックモードに移行し、読み取り対象のテキスト行の上に関数の ROI を配置します。対象領域の設定時には、必ず角回転とスキューの両方またはどちらかを考慮してください。
  4. この関数では、[セグメント] タブでのデフォルト設定に基づいて、関数によって文字と判断されたテキストの周囲に文字領域が自動的に作成されます。

  5. この関数によってテキストの周囲に文字領域が正しく描画されていない場合は、次の 2 つのオプションから選択できます。
  • [オートチューニング] ダイアログを使用して、最適なセグメンテーション設定を OCRMax 関数に自動的に計算させます。[オートチューニング] ダイアログでは、セグメンテーションフェーズと登録フェーズを 1 つの手順にまとめています。[オートチューニング] ダイアログのトピックの説明に従って、フォントデータベースを正しくセグメンテーションして登録します。
  • [セグメント] タブに移動して、個々の文字領域内にテキストが正しく囲まれるまでパラメータを手動で調整します。セグメンテーションプロセスに従って、登録前に画像データベース内のすべての文字を正しくセグメンテーションします。

セグメンテーション後の手動による登録

  1. テキストがセグメンテーションされると、いつでも文字を登録しフォントに追加できます。
  2. 最初の登録画像をリロードします。
  3. [フォントの登録] タブへ移動し、登録するテキスト文字列を正確に入力して、[登録] ボタンをクリックします。

注: フォントデータベースが作成されたら、[新規文字をフォントに追加] および [個々の文字をフォントに追加] オプションを使用して、追加文字をフォントに追加できます。

  4. 文字は、関数の [image] データ構造体に追加され格納されます。
  5. 次の登録画像をロードし、必要な文字インスタンスがすべて登録されるまで手順 2 ～ 5 を繰り返します。

OCRMax 関数の実行

OCRMax 関数をオンラインにする前に、関数が実行時に ROI 内のテキストを単に読み取るだけなのか、または正しい文字列を読み取って確認するようにプログラムされるのかに応じて、関数の検査モードを設定します。実行時に、In-Sight ビジョンシステムはオンラインになり、ジョブによって定義されているとおりに画像を取り込みます。画像が取り込まれると、画像内のテキスト文字列は [セグメント] パラメータに基づいて自動的にセグメンテーションされ、登録済みインスタンスと比較されます。関数の結果は、OCRMax データアクセス関数を介して出力され、[結果] タブには文字に関する追加情報が表示されます。

実行時に最適な処理を行うために、登録時と実行時で使用するパラメータ設定は同じにしてください。ただし、新しい画像セットでエラーが発生したために、パラメータを調整する必要が生じることがあります。パラメータを変更しても、既に正しく登録された文字の外観がほとんど変わらない場合、再登録は不要です。ただし、パラメータを変更すると、以前に登録した文字が影響を受ける場合は、再登録が必要です。パラメータを変更しても文字領域に影響を与えることはありませんが、一部のパラメータでは影響を与える場合もあります。

登録後に次のパラメータのいずれかを変更すると、再登録が必要になる場合があります。

  • 正規化モード
  • ストローク幅フィルタを使用
  • 2 値化しきい値

次のパラメータでは、文字に変更が加えられてしまう (トリミング、分割など) ため、再登録が必要になることがあります。

  • 文字幅の最大値
  • 最小文字アスペクト比
  • 文字の高さの最大値

次のパラメータでは、角度とスキューの両方またはどちらかの値が変更されてしまうため、再登録が必要になることがあります (以前、文字に多少不正確なスキューが存在しており、後に文字を適切にデスキューするために [スキュー範囲] パラメータを増加させた場合など)。

  • 角度範囲
  • スキュー範囲
  • 検査領域の回転

セグメンテーションの概要

OCRMax 関数は、6 段階のプロセスを通して光学式文字認識を実行します。

  1. 行の最適化: ROI を配置して、テキスト行の位置、角度、およびスキューを決定します。OCRMax 関数は、この入力画像を取得して、文字の行が水平でスキューがなくなるように画像を修正します。
  2. 正規化: ROI 内のテキスト行を正規化します。これにより、単一のしきい値を使用して画像を 2 値化することができます。
  3. 2 値化: 正規化した画像をテキストと背景に 2 値化するためのしきい値を決定します。
  4. フラグメント化: 関数では次に、2 値化された画像に対してブロブ解析を実行し、文字フラグメントを作成します。
  5. グループ化: 文字フラグメントをグループ化して、文字を作成します。
  6. 解析: 必要に応じて、追加の解析を実行し、最終的な文字を作成する前に最適なグループ化を行います。

セグメンテーションプロセス

次のリストは、OCRMax パラメータとそのパラメータが影響を与えるプロセスの手順を示しており、さらにプロセスの各手順におけるトラブルシューティングの情報についても説明しています。

ヒント: 文字が正しくセグメンテーションされていない場合は、[診断の表示] パラメータを利用して、受け入れた/拒否した文字および文字フラグメントに関するグラフィックのフィードバックを有効にします。さらに、[診断] タブを使用して、調整が必要なパラメータを判別します。

行の最適化

  • 領域
  • 文字の極性
  • 角度範囲
  • スキュー範囲

テキスト行の回転とスキューを決定する処理は、[検査領域の回転]、および [角度範囲] と [スキュー範囲] パラメータで指定した値によって影響を受けます。テキスト行の回転やスキューが画像内で均一なアプリケーションでは、[文字の極性]、[角度範囲]、および [スキュー範囲] の値を関数に計算させるより、高速かつ正確に指定することができます。

トラブルシューティング

行の最適化段階での目的は、文字の行の角度とスキューの値を正確に決定することです。OCRMax 関数は、領域の上に領域が配置されると、関数がデフォルトの [セグメント] パラメータに基づいて文字が含まれていると判断した領域の周囲に自動的に文字領域を作成します。[領域] 内での文字領域の外観が予期したものと異なる場合は、画像内で角度とスキューの両方またはどちらかが正しくなるまで [角度範囲] と [スキュー範囲] を調整します。文字を登録する前に、文字が必要な角度とスキューの両方またはどちらかに対して適切に調整されている状態になるように、必ず角度とスキューを調整してください。

[領域] に、ラベルエッジなどの無関係な強い特徴が含まれている場合、角度とスキューの両方またはどちらかに対する OCRMax 関数の計算値が不正確になることがあります。このため、[領域] にはテキスト行のみが含まれるようにしてください。

正規化

  • 正規化モード
  • ストローク幅フィルタを使用

正規化された画像では、グレースケール値 128 が黒値と白値の間の事実上のしきい値です。例えば、[文字の極性] が [黒 (白い背景)] の場合、128 より小さいグレースケール値はテキストを示し、128 以上のグレースケール値は背景を示します。ただし、グレースケールのしきい値は 2 値化の段階で変更することができます。

注: 正規化された画像の外観は [文字の極性] の影響を受けません。例えば、正規化された画像内の暗ピクセルは、テキストの極性が [黒 (白い背景)] であるか [白 (黒い背景)] であるかに関係なく、正規化された画像内では黒になります。

トラブルシューティング

正規化段階での目的は、単一の 2 値化しきい値により、[領域] 内の画像領域を処理して 2 値化し (テキストと背景に分割)、正規化された画像を作成することです。正規化された画像 ([出力画像グラフィックス] パラメータを [正規化された画像] に設定することで表示可能) では、テキストの極性 ([黒 (白い背景)] または [白 (黒い背景)]) に応じて、テキストがすべて均一な黒で背景が均一な白、またはその逆で表示されます。また、2 値化された画像 ([出力画像グラフィックス] パラメータを [2 値化された画像] に設定することで表示可能) を表示すると、正規化された画像の精度を決定するのに有効です。背景の重要な領域がテキストとして間違って 2 値化されている場合、問題となるのはたいてい正規化の段階です (ただし、2 値化の段階に関連している場合もあります)。

背景がほとんど均一に表示されており、テキストのコントラストも均一である場合は、デフォルトの [グローバル] の [正規化モード] オプションが適切に動作しています。背景の外観にばらつきが存在する場合、例えば、一方の側がもう片方の側より暗い、または上部が下部より明るいなどの場合は、[ローカル] または [ローカル詳細設定] のいずれかの [正規化モード] オプションを試してください。テキスト自体のコントラストが異常な場合、例えば、一部の文字がほかの文字より顕著に薄い場合は、[ローカル詳細設定] オプションが必要になります。ただし、[ローカル詳細設定] オプションは、背景のノイズを拡大してしまうことがあります (スポット、斑点など)。[ローカル詳細設定] がテキストを定義する以上にノイズを拡大してしまう場合は、代わりに [ローカル] オプションを試してください。

[正規化モード] パラメータのほかに、[ストローク幅フィルタを使用] パラメータも正規化された画像に影響を与えます。[ストローク幅フィルタを使用] は、テキストの残りの部分より大幅に狭いストロークを除去します。このようなストロークは、たいていの場合単なるノイズです。また、このパラメータは、一般的な低コントラストの背景のばらつきも除去します。ただし、このパラメータが、実際のテキストストローク間違って除去してしまう場合もあります。このような場合は、無効にする必要があります。通常、この問題は、文字のストローク幅が異なるか、または文字の一部が文字のほかの部分よりも薄い (つまり、コントラストが低い) 場合に発生します。

最後に、[文字の極性] も正規化に影響を与えます。通常、OCRMax アルゴリズムによりテキストの正しい極性を決定できますが、可能な場合は極性を設定することを推奨します。文字の極性が間違っている場合、テキストが含まれている [領域] 内にあるテキスト以外の特徴により影響を受けることがあります。テキスト以外の特徴を除外するために [領域] を配置し直して再設定することにより、問題を修正する必要があります。

2 値化

  • 文字の極性
  • 2 値化しきい値

2 値化において正規化された画像にしきい値を適用するのは、黒 (0) (背景) と白 (255) という 2 つのグレースケール値のみを持つ画像を生成するためです。

注: 正規化された画像とは異なり、2 値化された画像は [文字の極性] によって影響を受けます。2 値化された画像では、テキストは常に白です。

トラブルシューティング

2 値化段階での目的は、正規化された画像を 2 値化することにより、テキストを示す特徴に対してグレースケール値 255 を、背景を示す特徴に対してグレースケール値 0 を割り当てることです (指定した [文字の極性] とは無関係です)。生成された画像は、2 値化された画像です ([出力画像グラフィックス] パラメータを [2 値化された画像] に設定することで表示可能)。2 値化は、[2 値化しきい値] パラメータを使用して、正規化された画像に単一のしきい値を適用するだけの処理です。

2 値化された画像を反転して表示すると (つまり、テキストにグレースケール値 0 を、背景に 255 を割り当てる)、テキストの極性が正しくなくなります。これは、[文字の極性] パラメータの設定に誤りがある場合に発生し、[自動] 設定により極性が誤って判別されたか、または実際は黒地に白なのに [黒 (白い背景)] に設定されています (逆の場合もあります)。テキストの極性が誤って判定されるのは、多くの場合、領域にテキスト以外の特徴が含まれているか、領域が文字の上部と下部の両方またはどちらかに接触しているからです。これらの場合には、通常、それらの特徴が除外されるように領域を再配置するだけで問題が解決します。

2 値化された画像の極性が適切でも、含まれているテキストが多すぎるかまたは少なすぎる場合は、[2 値化しきい値] を調整します。パラメータを小さくするとテキストとして認識される画像が減少し、大きくするとテキストとして認識される画像が増加します。最も一般的なのは、背景テクスチャまたはノイズが顕著である場合には、[2 値化しきい値] をデフォルト値の 50 より低く設定することです。

デフォルト値より低くする場合の一般的な値は 40 と 30 です。通常は、25 未満の設定が必要になることはなく、また、50 より大きな値にすることが必要になるのは非常にまれです。値を変更した結果改善がみられても、問題が完全に解決されない場合は、さらに細かく調整した値 (32.5 など) を試してください。場合によっては、値をわずか 0.1 変更しただけでも有効な場合もあります。

注: [2 値化しきい値] は、0 ～ 255 (グレースケール範囲) の範囲で整数のしきい値に変換されたパーセンテージです。256 分の 1 よりも小さい変化分の値では、差異は生じません。

また、2 値化された画像に関する一部の問題は、実際には正規化された画像に関する問題の場合があることにも注意してください。詳細については、「正規化」のセクションを参照してください。ただし、背景の大きいブロックがテキストとして 2 値化された場合は、たいてい [正規化モード] パラメータの設定が間違っている場合で (特に、[グローバル] オプションを使用している場合)、また [2 値化しきい値] とは関係なく、テキストの断片が背景として 2 値化された場合は、たいてい [ストローク幅フィルタを使用] パラメータを有効にしている場合です。

さらに、ノイズの小さな斑点がテキストとして 2 値化されていることもよくあります。このような斑点は、フラグメント化段階で除去することができます。

フラグメント化

  • 最小文字フラグメントサイズ
  • 文字フラグメントのコントラストしきい値
  • 境界フラグメントを無視
  • メインラインまでの最大フラグメント距離

入力として 2 値化された画像を使用すると、ブロブ解析の 1 形態として、連結されているピクセルのセットからフラグメントが形成されます。連結されているピクセルの各セットは、1 つのフラグメントであるとみなされます。フラグメントは、事実上 1 つにグループ化されて文字を形成するため、単なるノイズまたはテキスト以外の特徴を示すフラグメントを除去するという点においてこの段階は重要になります。

ヒント: 最終的な文字が小さすぎる場合や、文字が欠落している場合は、[出力画像グラフィックス] パラメータを [2 値化された画像] に設定してください。2 値化された画像内でフラグメントが欠落している箇所が存在する場合 (つまり、白である場合) は、上記のさまざまなパラメータを試してください (一方で、グループ化段階のパラメータ、[文字サイズの最小値]、[文字幅の最小値]、および [文字の高さの最小値] を調整すると、文字全体が破棄される場合もあります)。

トラブルシューティング

フラグメント化段階での目的は、以前に 2 値化したテキストピクセルが実際にテキストピクセルであるかどうかを判別することです。2 値化された画像は、連結性解析 (ブロブ解析とも呼ばれます) を使用して処理され、連結されたフラグメント (つまり、ブロブ) を形成します。フラグメント化段階では、各フラグメントを維持するか除去するかを決定します。維持されたフラグメントは、文字の形成に使用されます。

[診断の表示] パラメータを使用して文字領域を詳細に表示することにより、維持または除去するフラグメントを判別することができる場合があります。同様に、[診断] タブでデータを確認して、維持または除去するフラグメントを判別します。

フラグメントが除去されることがあるのは、小さすぎる場合、コントラストが低すぎる場合、[領域] の境界と交差している場合、または文字のメインラインの外側にある場合 (つまり、上または下に寄りすぎている) です。前述の 1 つ以上の理由により特定のフラグメントが除去されることがあるため、複数のパラメータを調整する必要があります。問題となるのは、テキストの断片が除去されることがある一方で、ノイズの断片がテキストとして 2 値化されてしまう場合があることです。通常は、いずれの問題の場合も、この段階でパラメータを適切に設定することにより処理することができます。

注: フラグメントが含まれている文字全体が小さい場合 (ピリオドやコロンなどの場合)、問題は次のグループ化の段階にあるかもしれません。このような場合、文字領域が小さすぎる文字を指定してしまうというよりはむしろ、文字全体が欠落してしまいます。特に重要なことであるため繰り返して説明すると、ある画像で結果を 1 つに固定するようにパラメータを設定しても、別の画像では結果が適切になるとは限らないということです。例えば、ある画像でノイズの断片を除去するために [最小文字フラグメントサイズ] パラメータを大きくしたとしても、別の画像では実際のピリオドやコロンが除去されてしまうことがあるということです。

小さいテキストのフラグメントが除去された場合は、そのフラグメントを維持するために [最小文字フラグメントサイズ] パラメータを小さくすることを試みてください。ピクセルの数とは、2 値化された画像内で連結されているピクセルの数です。同様に、ノイズの小さい断片が維持されている場合は、パラメータの値を大きくしてみてください。

[領域] の境界に接触しているテキストフラグメント (つまり、1 つ以上のピクセルが、2 値化された画像のちょうど上部、下部、左側、または右側にある) が除去された場合、そのフラグメントを維持するためには [境界フラグメントを無視] パラメータを無効にします。同様に、[領域] の境界に接触しているノイズの断片が維持された場合、その断片を除去するためには [境界フラグメントを無視] パラメータを有効にします。

文字領域が短すぎる場合 (つまり、文字の上部と下部の両方またはどちらかが切り取られた場合)、全体的に問題となるのは、文字の上部と下部の両方またはどちらかにあるフラグメントが、残りの文字のメインラインの外側にあるために除去されたかもしれないということです。こういう状況が発生するのは主に、印刷が垂直方向に多少不規則である場合 (印刷された一部の文字の高さが高すぎるかまたは低すぎる)、または印刷がずれている場合 (例えば、大部分のテキストは直線上に位置しているが、行の片方の端にある文字が連続して低くまたは高く印刷されている) です。このような場合は、該当するメインラインの外側にあるフラグメントを含めるために [メインラインまでの最大フラグメント距離] パラメータを大きくすることを試みてください。[診断の表示] パラメータをオンにして、文字の周囲のメインラインの配置をグラフで表示します。この距離は、メインラインからの推定される高さのパーセンテージとして指定します。このため、除去されたフラグメントの高さが維持されたそのほかのフラグメントより多少高い場合は、2 または 5% など比較的小さい値に設定してみてください。メインラインから遠く離れたフラグメントが除去されている場合 (例えば、テキストの行が大文字で始まり、次に小文字がある場合などに発生することがあります) は、30% など大きい値に設定してみてください。

最後に、テキストフラグメントが除去されたが、前述の 3 つの状況のいずれにも該当しない場合、フラグメントが除去されたのはコントラストが低いためです。フラグメントを維持するために、[文字フラグメントのコントラストしきい値] パラメータの値を小さくしてください。フラグメントのコントラストは、2 値化しきい値として使用されている値を基準として、正規化された画像内のグレースケール値を使用して測定されます。例えば、[2 値化しきい値] パラメータが 50 に設定されている場合、この 2 値化しきい値はグレースケール値の 128 に相当します。正規化された画像内にあるフラグメントのすべてのピクセルの値が 100 である場合、そのフラグメントのコントラストは 128 になります。

グループ化

  • 文字フラグメントマージモード (1)
  • 文字フラグメントの最小オーバラップ値 (1)
  • 最小文字間ギャップ値 (1)
  • 最大文字内ギャップ値 (1)
  • 文字サイズの最小値 (4)
  • 文字幅の最小値 (4)
  • 文字の高さの最小値 (4)
  • 文字の高さの最大値 (3)
  • 文字幅の最大値 (1, 2)
  • 最小文字アスペクト比 (1, 2)
  • 文字幅のタイプ (2)

フラグメント化の段階で維持された文字フラグメントはすべて、グループ化されて文字を形成します。単純で一色のストロークフォント (このフォントは、細かい断片には分割されません) のアプリケーションでは、各文字は単一の文字フラグメントから構成されています。ドットマトリックステキストが組み込まれているアプリケーションでは、各文字に複数の文字フラグメントが含まれています。

注: 次の解析の段階は、グループ化の段階でマージされなかった文字フラグメントをマージするために使用することもできます。例えば、実際は 2 つである文字が単一の文字として報告されている場合、その理由を特定するためにグループ化と解析の両方の段階のパラメータを調整する必要があります。このシナリオでは、最初に解析段階の [セグメント解析モード] パラメータを　[最小] に設定するのが有効です。これにより、グループ化段階のパラメータが変更されなくなります。

グループ化の段階は、次の 4 つのタイプの操作から構成されています (パラメータのリストは、パラメータに影響を与える操作タイプを示すようにコード化された番号です)。

  1. 2 つ以上の文字フラグメントをマージして 1 つの文字を形成します。
  2. 1 つの文字フラグメントまたは 1 グループの文字フラグメントを 2 つ以上の別の文字フラグメントに分割します。
  3. 1 つの文字フラグメントを垂直方向または水平方向にトリミングして 1 つの小さい文字フラグメントを作成します。
  4. 文字フラグメントのグループを破棄します。

トラブルシューティング

グループ化段階での目的は、個別のフラグメントを取得して、そのフラグメントをマージすることと別々に分割することの両方またはどちらかにより、グループ化して文字全体を形成することです。同様に、この段階では、フラグメントのセットをまとめて破棄する場合もあります。グループ化段階の結果は、文字を形成しているマーク (ドットピン、インクジェットなど) を囲む文字領域としてグラフで表示されます。

注: 次の解析段階でもグループ化を実行できますが、重要な違いは、この 2 つの手順でプロセスを実行する方法です。グループ化の段階では、グループ化は「ローカル」ベースで決定されますが (つまり、近接したフラグメントを基にしている)、解析の段階でのグループ化は「グローバル」ベースで決定されます (つまり、全体として、すべてのフラグメントを基にしている)。

マージ: 1 つ以上のフラグメントを単一の文字にマージするには、フラグメントの水平方向の配置、特にフラグメントのオーバラップが存在するかどうか、フラグメント間にギャップが存在するかどうか、およびオーバラップまたはギャップの大きさ (存在する場合) を調べます。マージ操作では、文字幅の最大値を超える文字は生成されません。

フラグメントのマージ方法に影響を与える主なパラメータは、[文字フラグメントマージモード] パラメータです。このパラメータを [要オーバラップ] に設定すると、フラグメントをマージするために 1 ピクセル以上 ([文字フラグメントの最小オーバラップ値] パラメータの設定に応じて異なります) 水平方向にオーバラップさせる必要があります。通常この設定は、文字を「字詰めする」場合に有効です。例えば、文字「AV」は、「A」の右端の部分が「V」の左端の部分にオーバラップするように印刷されることがあります。このパラメータを [最小文字間ギャップ値に設定] か [最小文字間ギャップ値/最大文字内ギャップ値に設定] のいずれかに設定すると、水平方向のギャップにより文字のペアごとに分割されます。

ドットマトリックス印刷では、ドットがオーバラップするのではなく少なくとも明確に分離されていれば、[最小文字間ギャップ値に設定] か [最小文字間ギャップ値/最大文字内ギャップ値に設定] のいずれかを使用するのが有効です。これにより、OCRMax 関数は、2 文字間に存在するギャップ (文字間ギャップ) と単一文字のドット間に存在するギャップ (文字内ギャップ) を区別することができます。理想的には、文字間ギャップ値がすべて文字内ギャップ値より大きければ、[最小文字間ギャップ値に設定] の設定値を別の 2 文字間に存在する最小のギャップ値に設定して使用することができます。

分割: 幅の広い単一のフラグメントを 1 つ以上の別の文字に分割するには、[文字幅の最大値] パラメータを使用して、単一の文字で許可される文字幅の最大値を指定します (つまり、フォント内で最大幅を持つ文字の幅です。英数字フォントの場合、通常は「M」または「W」がこれに相当します)。指定した最大幅より幅が広いフラグメントは、最大幅にトリミングされるか、またはそれぞれが最大幅を超えない複数の断片に分割されます。通常、幅の広いフラグメントが形成されるのは、2 つ以上の文字がお互いに非常に近接している場合か、または 2 つ以上の文字がノイズやテキスト以外のストロークによって連結されている場合です。

文字幅の最大値を間接的に設定するには、[最小文字アスペクト比を使用] パラメータを有効にして、[最小文字アスペクト比] パラメータを設定します。この値を設定すると、幅は [最小文字アスペクト比] の値で除算した線の高さと等しくなります (線の高さを確認するには、[診断] タブを表示して、[合格した文字]、[除外した文字] の [最小値]、および [高さ] の [最大値] で返される値を調べます)。[最小文字アスペクト比] および [文字幅の最大値] パラメータの両方を有効にすると、使用される幅の値は小さくなります。

文字の分割方法は、[文字幅のタイプ] パラメータに応じて異なります。このパラメータを [固定] に設定すると、幅の広いフラグメントがほぼ同じサイズの断片に分割されます (この設定は、文字がすべて同じ幅を持つと想定される場合に適しています)。このパラメータを [変数] または [自動] に設定すると、OCRMax 関数によって、サイズが同じか同じではない断片への最適な分割方法が決まります (この設定は、プロポーショナルテキストでは一般的なように、文字ごとにフォント幅が異なる場合に適しています)。

トリミング: 文字やフラグメントの高さが高すぎる場合はトリミングすることができます。通常、この操作は、ノイズまたはテキスト以外のストロークが文字の上部や下部に連結されている場合に実行します。垂直方向のトリミングを有効にするには、[文字の高さの最大値を使用] パラメータをアクティブにして、[文字の高さの最大値] パラメータで適切な値を指定します。ただし、すべてのテキストが直線上に印刷されているわけではない場合には、問題が発生することがあります。このような状況では、[文字の高さの最大値] パラメータの値を、文字の実際の高さよりも大きい値まで増加させる必要があります (ただし、まだ理想的な結果にはなりません)。

破棄: フラグメントを破棄するプロセスは、おそらくグループ化段階のさまざまな操作の中で最も簡単に対応できる操作です。一連のフラグメントをグループ化したが、2 値化されたピクセルの幅、高さ、または総数が小さすぎる場合、そのセット全体が破棄されることがあります。このため、実際には文字であるのに完全に破棄されてしまっている場合は、[文字幅の最小値]、[文字の高さの最小値]、および [文字サイズの最小値] の各パラメータのすべてまたはいずれかを、文字が維持されるまで小さくしてください。同様に、テキスト以外の何らかの特徴が文字として間違って報告されている場合は、前述のパラメータの 1 つ以上を、テキスト以外の特徴が破棄されるまで大きくしてください。

解析

  • セグメント解析モード
  • 最小ピッチ値
  • 文字のピッチタイプ
  • 文字ピッチ位置

グループ化の段階では、個々のフラグメントから一連の文字フラグメントを形成しますが、たいていの場合、これらのセットが最終的な正しい文字になります。ただし、文字を正しくセグメンテーションするために、さらに高度な解析が必要になる場合があります。特に、文字間の距離が、文字の個別の断片間の距離を超えない程度である場合です (例えば、ドットマトリックス印刷におけるドットなど)。そのほかのケースでは、グループ化段階のパラメータよりも解析段階のパラメータを使用する方が、正確なセグメンテーションを簡単に実行できる場合があります。

トラブルシューティング

解析段階での目的は、いくつかのフラグメントに基づいた「ローカルな」情報ではなく、ROI 内のすべてのフラグメントに関する「グローバルな」情報に基づいて、フラグメントをグループ化して文字を形成することです。[セグメント解析モード] パラメータのデフォルトの設定は [標準] で、これは「グローバル」解析に適用されます。一方、[最小] 設定では「ローカル」解析のみが実行され、これはグループ化段階に相当します。

注: 解析段階は常に、個々の文字が別の断片として表示されてしまう使用例に関係しています。例えば、テキストがドットマトリックスであるか、またはスクラッチにより文字が分割されているなどの場合です。それぞれの文字が常に単一の断片として表示されるようなアプリケーションでは、[セグメント解析モード] を [最小] に設定することができます。また、この設定は、文字が複数の断片として表示されているが、文字間のギャップが常に文字内のギャップより大きい場合にも使用することができます。このシナリオでも、[文字フラグメントマージモード] パラメータを [最小文字間ギャップ値に設定] に設定します。

この段階に関連する最も一般的な問題は、2 つ以上の文字が単一の文字として報告される場合です。この問題は、[セグメント解析モード] パラメータを [最小] に設定するだけで処理できる場合があります。ただし、[標準] オプションが必要な場合、この問題に対処するには通常、文字の幅と間隔の両方またはどちらかに関して 1 つ以上の制約事項を指定します。

2 つ以上の文字がマージされるのを防ぐには、[文字幅の最大値] パラメータと [最小文字アスペクト比] パラメータの両方またはどちらかを使用して、文字幅の最大値を小さくします。これらの方法の詳細については、グループ化の段階を参照してください。

また、[最小ピッチ値] パラメータを使用して、2 つの文字間のピッチを設定することもできます。ピッチは、[文字のピッチタイプ] および [文字ピッチ位置] パラメータの指定に従って、2 つの文字の対応する部分間の距離として測定されます。

[文字のピッチタイプ] および [文字ピッチ位置] パラメータを設定するのは有効なことですが、通常は必要ありません。このガイドラインにおける 1 つの例外は、[文字のピッチタイプ] パラメータが [自動] に設定されていると、OCRMax 関数では、固定ピッチのフォントには適切な選択でも、プロポーショナルピッチのフォントには不適切な選択が行われることです。特に、この関数は、幅の狭い 2 つの文字を誤って 1 つにグループ化してしまう場合があります。パラメータを [比例] に設定すると、この特定の問題は解決します。

実行時における最適なパフォーマンスの実現

通常、OCR アプリケーションのパフォーマンスは、読み取り率、つまり正しく読み取られた文字のパーセンテージによって判断されます。

注: 一部のアプリケーションでは、読み間違い (誤った受け入れ) の方が読み落とし (誤った拒否) より不都合であるとして、読み取り率を計算することが推奨される場合があります。同様に、アプリケーションによっては、正しい文字の数ではなく、正しい文字列の数として、読み取り率が計算されます。ただし、パラメータを最適化するプロセスは、いずれの場合でも同じです。

最適な読み取り率を実現する最も効果的な方法は、実際の部品 (良品と不良品の両方を含む) の画像を数多く取り込んで、その画像を手動でグレード付けしてから (例えば、作業者が画像を確認して、後の検証作業で参照できるように正確なテキストをテキストファイルに入力するなど)、評価対象の各パラメータセットについてデータベース全体にわたって読み取り率を計算することです。さらに、可能な場合は、登録時に各文字に対して1 ～ 4 つのインスタンスを使用します。

高読み取り率のルール

次に、高読み取り率を実現するための一般的なルールを示します。

  • 画像の数が多くなるほど読み取り率は向上します。
  • アプリケーションで必要な読み取り率が高ければ高いほど、目的の読み取り率を実現して検証するために必要な画像が増えます。
  • 1 つのガイドラインとして、総文字数 (読み取り率を定義する際に文字列が重要になる場合は、総文字列数) をエラー率の計算で必要になる場合と比較して、最低 10 倍使用するようにしてください。ただし、フォントを登録するために使用する文字は数に含めないでください。例えば、目標の読み取り率が 99% である場合、理想的には、100 文字あたり 1 文字だけ誤った文字が含まれていることになります (この場合、読み取り率を計算するのに必要な文字数は 10*100 = 1,000 です)。目標の読み取り率が 99.9% である場合は、最低 10,000 文字を使用してください。
  • さらに最低限のガイドラインは、それぞれのタイプの文字に対して前述の文字数を使用することです。通常、このガイドラインが必要になるのは、実験の結果、特定のタイプの文字がそのほかの文字よりも読み取りに失敗し易いことが判明した場合のみです(または、問題となるこれらの文字のインスタンスが十分に存在する場合です)。例えば、文字のセットに 0 ～ 9 の数字が含まれており、目標の読み取り率が 99% である場合、理想的には、各数字に対して 1,000 個の画像が存在している必要があります。

推奨される文字および領域のサイズ

次に、文字のセグメンテーションで最適な結果を実現するために従う必要がある一般的なガイドラインを示します。

文字のサイズ

理想的には、あるフォントで大きい文字 (例えば、「M」) に対して、約 20 ～ 40 ピクセルの高さにする必要があります。大きい文字に対して約 8 ～ 10 ピクセルよりも低い高さにした場合、セグメンテーションは動作しますが、その後の分類が困難になります。大きい文字に対して 40 ピクセルを超える高さにすると、一般的にセグメンテーションの速度が必要以上に遅くなり、読み取り率に関してもメリットはありません。

文字が推奨される値よりも大きく表示され、処理時間が問題となる場合、最適なアプローチは、In-Sight ビジョンシステムとレンズの位置のいずれかまたは両方を移動させて、文字を小さくすることです。このオプションが実現できない場合は、別の手段として、平滑化とサブサンプリングを使用して画像サイズを縮小します (例えば、NeighborFilter 関数で [操作] パラメータをローパスに設定)。ただし、文字が水平方向に近接している場合は、文字を小さくすると文字間のギャップにブレが生じるため、文字を元のサイズで使用する必要があります。

文字のストローク幅

理想的には、各文字のストローク幅 (または、ドットマトリックス印刷ではドットの直径) を最低 3 ピクセル (できれば 4 ピクセル) にする必要があります。さらに大きいストローク幅も許容可能です。

領域のサイズ

[領域] は常に、読み取り対象のすべての文字を完全に囲んでいる必要がありますが、同時にテキストの周囲には多少の背景も含まれています。可能な場合は、テキストの余分の行やラベルエッジなど、強調されている特徴は含めないでください。

理想的には、[領域] は、右側と左側は最も幅の広い文字 (例えば、「M」) の最低半分の幅の分だけ拡大されており、同時に上部と下部は最低 1 ストロークの幅の分だけ拡大されている必要があります。

また、[領域] は、画像領域全体にわたって拡大することができるため、テキストの位置が変動して簡単にはフィクスチャされないアプリケーションで実行可能なソリューションになります。ただし、著しい背景ノイズや無関係な特徴が存在する場合は、[領域] を小さくして、ノイズや特徴がテキストとしてセグメンテーションされる可能性を減らすのが適切なオプションです。

セグメンテーション速度の向上

OCRMax 関数の処理時間に影響を与える主な要因は、[領域] のサイズと文字のサイズです。さらに、一部の [セグメント] パラメータは処理時間に多大な影響を与えますが、読み取り率を大幅に減少させることなく高速なオプションを選択することが可能な場合あります。

領域および文字のサイズ

一般的に、セグメンテーションプロセスの処理時間は、[領域] および文字のサイズとともに増加します。[領域] を使用する際にかなり詰めて文字を囲むと、セグメンテーションが高速になります。同様に、文字を小さくしても (つまり、In-Sight ビジョンシステムの位置/光学系を移動させるか、または画像をサブサンプリングする)、セグメンテーションが高速になります。

速度に影響を与えるパラメータ

次のパラメータはセグメンテーションの速度に多大な影響を与えますが、一部のアプリケーションでは、読み取り率を許容できないほど低下させることなく高速な設定を選択することが可能です。

  • 文字の極性: [自動] パラメータ設定を使用すると、OCRMax 関数は、時間をかけてテキストの正しい極性を決定します。大部分のアプリケーションでは、テキストの極性は常に均一です。極性を指定すると ([黒 (白い背景)] または [白 (黒い背景)] のいずれか)、関数が高速に実行されます。
  • 角度範囲とスキュー範囲: これらのパラメータのいずれかまたは両方にゼロ以外の数値を指定すると、OCRMax 関数は、時間をかけてテキストの正しい角度/スキューを決定します。複数の画像内のテキストの角度とスキューの両方またはどちらかが常に均一であるか、または [領域] がフィクスチャできる場合、これらのパラメータでゼロ以外の値を設定するよりも [領域] を設定してこれらの値を指定する方が適切です。ただし、この操作ができない場合は、可能な限り小さい値を使用してみてください。
  • 正規化モード: 一連の操作が大幅に異なる速度で実行されます。操作の実行速度は、[なし]、[グローバル]、[ローカル]、[ローカル詳細設定] の順に最高から最低になります。
  • ストローク幅フィルタを使用: テキスト以外の幅の狭いストロークまたは低コントラストの背景のばらつきを除去するためにこのパラメータを設定します。ただし、実行に長時間を要することがあります。このパラメータを無効にすると、OCRMax 関数の実行が高速になります。
  • セグメント解析モード: このパラメータをデフォルトの [標準] 設定ではなく [最小] に設定すると、関数の実行が高速になります。ただし、大部分のアプリケーションでは、速度の変化は比較的小さくなります。

関連項目

  • OCRMax 関数について
  • [オートチューン] ダイアログ
  • OCRMaxSettings 関数
  • OCRMax データアクセス関数
  • TransOCRMaxToWorld 関数
  • プロパティシートの使用方法


DeviceNet ゲートウェイへの接続

ハウツー

この例の目的は、HMS Anybus X-gateway を使用して DeviceNet ファクトリ通信ネットワーク上のデータにアクセスする方法を示すことです。このトピックでは、ゲートウェイのインストールおよび設定の方法、デバイスに通信を許可するようにネットワーク (RSNetworks) を設定する方法、および In-Sight Explorer ジョブを作成してゲートウェイにデータを送信する方法を説明します。以下の例では、ユーザが次のハードウェアとソフトウェアを使用していることを前提としています。

注:DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」を参照してください。

  • ファームウェアバージョン 3.41.00 以降が実行されている In-Sight ビジョンシステム
  • Anybus X-gateway Modbus/TCP-to-DeviceNet Adapter
  • DeviceNet Scanner Card を搭載した Rockwell PLC
  • Rockwell RSNetWorx および RSLogix 5000 Software

Anybus X-gateway のインストールと設定

このセクションの手順では、Anybus X-gateway の Ethernet 部分のインストールおよび設定方法について説明します。

注: 詳細については、HMS Anybus-X のマニュアル (『Anybus-X Generic Gateway User Manual』、『Anybus-X Ethernet Network Interface Addendum』、『Anybus-X PROFIBUS Slave Network Interface Addendum』) を参照してください。これらのマニュアルは、HMS の Web サイト (www.hms-networks.com) からダウンロードできます。

  1. HMS のソフトウェアユーティリティである Anybus IPconfig をダウンロードしてインストールします。このユーティリティでは、Anybus ベースの Ethernet インタフェースを簡単に設定することができる HMS IP Configuration Protocol (HICP) を使用します。
  2. Ethernet に接続した PC で、Anybus IPconfig を実行します。ネットワーク上で検出された Anybus ベースの Ethernet インタフェースとその IP アドレスが、すべてウィンドウに表示されます。
  3. Anybus X-gateway で MAC ID ディップスイッチを使用して、DeviceNet MAC ID アドレスを設定します。詳細については、『Anybus-X DeviceNet Slave Network Interface Addendum』を参照してください。Anybus X-gateway ハードウェアを実際に取り付けて接続します。詳細については、Anybus X-gateway のマニュアルを参照してください。
  4. Anybus X-gateway ハードウェアを適切に取り付けて、すべてのケーブルを接続した後、Anybus X-gateway ハードウェアの電源を投入し、電源がオンになるまで 30 ～ 60 秒待ちます。Anybus-X Gateway ハードウェアの電源がオンになると、Ethernet LED 状態インジケータが緑色に点灯または点滅します。
  5. Anybus IPconfig ユーティリティで、[Scan] ボタンをクリックし、Anybus ベースの Ethernet インタフェースがすべて表示されるウィンドウの表示を更新します。リストに、デフォルト IP アドレス 192.168.0.1 の Anybus X-gateway ハードウェアが新たに追加表示されます。
  6. Anybus X-gateway の設定を変更する必要がある場合は、リストで [Anybus X-gateway] をダブルクリックします。DHCP による IP アドレスまたは固定 IP アドレス、サブネットマスク、デフォルトゲートウェイ、および DNS サーバを割り当てるためのダイアログが表示されます。設定を完了したら、[Set] ボタンをクリックして続行します。
  7. 最後に、Anybus IPconfig ユーティリティで、[Scan] ボタンをクリックし、Anybus ベースの Ethernet インタフェースをすべて表示するウィンドウの表示を更新します。リストに、新しい IP アドレス (変更した場合) の Anybus X-gateway ハードウェアが表示されます。

DeviceNet ネットワーク上の Rockwell PLC への Anybus X-gateway の接続

このセクションでは、Rockwell PLC と Anybus X-gateway の間の DeviceNet 通信を接続および検証するための手順を示します。Anybus X-gateway により、Modbus/TCP ネットワークと DeviceNet ネットワークの間のデータ交換が許可され、これにより入出力データを Rockwell PLC に送信できるようになります。Rockwell PLC と Anybus X-gateway の間の DeviceNet 接続を設定するには、RSNetWorx を使用してコントローラのハードウェア構成にそのゲートウェイを追加する必要があります。

  1. DeviceNet の RSNetWorx を開きます。

注: Anybus-Gateway を初めて使用する場合は、エレクトロニックデータシート (EDS) をインストールする必要があります。HMS の Web サイトから EDS ファイルをダウンロードします。

  2. [ツール] メニューで、EDS ウィザードを選択して EDS ファイルをインストールします。[次へ] をクリックして [Register an EDS file (EDS ファイルの登録)] を選択し、[次へ] を選択します。ダウンロードした EDS のパスを追加し、[次へ] をクリックします。
  3. [ネットワーク] メニューで [オンライン] を選択します。これにより、スキャナで設定したボーレートでネットワーク全体がスキャンされ、接続されているノードのすべてがリストに表示されます。
  4. 1756-DNB (ほかの接続されたスキャナ) をダブルクリックします。これにより、スキャナの設定を示したウィンドウが開きます。
  5. [Scanlist] タブを選択します。オフライン設定をスキャナにダウンロードするか、またはスキャナの現在の設定をアップロードするかを尋ねるプロンプトが表示されます。[アップロード] を選択します。
  6. Scanlist にデバイスを追加するには、[Available Devices (使用可能なデバイス)] で [Anybus-S] をハイライト表示し、右矢印をクリックしてスキャナに追加します。

  7. デバイスを追加したら、[Edit I/O Parameters (I/O パラメータの編集)] を選択します。I/O のタイプとサイズを設定するためのウィンドウが表示されます。ポーリングオプションをオンにし、入出力サイズを 20 バイトに設定します。ポーリングレートを「スキャンごと」に設定して、入手可能になったらデータを取得します。
  8. 入出力のデータ量が正しいことを確認します。[入力] タブと [出力] タブを選択して、以下のグラフィックスと比較します。

  9. [ファイル] → [名前を付けて保存] をクリックし、その設定を InSightExample.dnt として保存します。

注: 20 バイトという入出力サイズの値はデフォルト設定です。このサイズが必要とする値ではない場合は、『Anybus X-gateway ユーザマニュアル』を参照してこの設定値を調整してください。マニュアルは、HMS の Web サイト (www.hms-network.com) からダウンロードできます。

TCP/IP Modbus 経由での In-Sight ビジョンシステムへの Anybus X-gateway の接続

このセクションでは、TCP/IP Modbus による通信を使用した In-Sight ビジョンシステムへの Anybus X-gateway の接続について説明します。

  • In-Sight Explorer での TCP/IP Modbus による通信の設定
  • PLC から In-Sight ビジョンシステムへの DeviceNet 経由でのデータの読み取り
  • In-Sight ビジョンシステムから PLC への DeviceNet 経由でのデータの書き込み

注: 詳細については、www.modbus.org で Modicon 発行の『Open Modbus/TCP Specification』、および www.cognex.com/support/files/In-Sight/Modbus.zip に格納されている InSightModbus.doc を参照してください。

In-Sight Explorer での TCP/IP Modbus による通信の設定

In-Sight ビジョンシステムでは TCP/IP Modbus クライアント機能が有効になっていますが、Anybus X-gateway が TCP/IP Modbus サーバ (スレーブ) として機能するため、このサーバ機能はこのモデルでは必要ありません。

  1. In-Sight Explorer の [In-Sight のネットワーク] ペインで、設定する In-Sight ビジョンシステムまたはエミュレータを選択します。
  2. [ファイル] メニューの [ジョブの新規作成] を選択し、ビジョンシステムまたはエミュレータに新規ジョブをロードします。
  3. [パレット] で [スニペット] タブを選択し、[Communications] フォルダを展開します。まず A2 を選択して DeviceNetGateway.cxd をダブルクリックするか、またはファイルをセル A2 にドラッグ & ドロップすることにより、In-Sight Explorer スプレッドシートの A2 セルに DeviceNetGateway.cxd ファイルをロードします。
  4. ビジョンシステムまたはエミュレータに、新規ジョブを DeviceNetGateway.job として保存します。
  5. セル A5 をダブルクリックし、Anybus X-gateway の IP アドレスを入力します (必要に応じ、HMS Anybus IPconfig ソフトウェアユーティリティを実行して、Anybus X-gateway の IP アドレスを取得します)。
  6. TCP/IP Modbus の通信では、In-Sight クライアント (マスタ) のジョブに TCPDevice 関数と QueryDevice 関数が存在している必要があります。TCPDevice 関数は、リモートデバイス間 (この場合は、Anybus X-gateway と In-Sight ビジョンシステム) のネットワーク接続を作成するときに使用します。QueryDevice 関数は、TCP/IP Modbus パケットの Modbus 関数コードコマンドを作成するときに使用します。DeviceNetbusGateway.cxd ファイルでは、セル C5 に TCPDevice 関数が 1 つ格納されており、読み取り要求用のセル B15 と書き込み要求用のセル B27 には QueryDevice 関数が 1 つずつ、合わせて 2 つの関数が格納されています。
  7. Anybus X-gateway は、QueryDevice 関数で以下の Modbus 関数コードをサポートしています。
関数コード | 関数名
3 | Read multiple registers
4 | Read input registers
6 | Write single register
7 | Read exception status
8 | Diagnostics
16 | Force multiple registers
22 | Mask write register
23 | Read/Write registers
  8. セル B15 の QueryDevice 関数をダブルクリックし、パラメータが次のように設定されていることを確認します。

注: Modbus パケット構造体の詳細については、Modbus 発行の『Modbus Implementation Guide』を参照してください。

パラメータ入力番号 | パラメータ入力名 | パラメータ入力値 | 説明
1 | Event | $A$15 | [イベント] ボタンへのセル参照。
2 | Device | $C$5 | セル C5 の TCPDevice 関数へのセル参照。
3 | Data | 0 | Modbus ヘッダ、トランザクション ID、上位バイト = 0。
4 | Data | 0 | Modbus ヘッダ、トランザクション ID、下位バイト = 0。
5 | Data | 0 | Modbus ヘッダ、プロトコル ID、上位バイト = 0。
6 | Data | 0 | Modbus ヘッダ、プロトコル ID、下位バイト = 0。
7 | Data | 0 | フィールド長、上位バイト = 0。
8 | Data | 6 | フィールド長、下位バイト = 6 (後続のバイト数)。
9 | Data | 0 | 単位 ID、使用しないバイト = 0。
10 Data $C$12+3

Modbus 関数コードバイト。この例では、この入力は 3 または 4 になります。

注: Modbus 関数コードバイトが 3 にセットされている場合、In-Sight は保持レジスタ (TCP/IP Modbus 経由で書き込まれたデータ) を読み取ります。Modbus 関数コードバイトが 4 にセットされている場合、In-Sight は入力レジスタ (DeviceNet 経由で書き込まれたデータ) を読み取ります。
11 Data 0

Modbus 参照アドレス、上位バイト = 0。

注: 入力レジスタは、アドレス 1000 から Read multiple registers (関数コード 3) を使用して、またはアドレス 0 から Read input registers (関数コード 4) を使用して読み取られる場合があります。
12 Data 0

Modbus 参照アドレス、下位バイト = 0。

注: 入力レジスタは、アドレス 1000 から Read multiple registers (関数コード 3) を使用して、またはアドレス 0 から Read input registers (関数コード 4) を使用して読み取られる場合があります。
13 | Data | 0 | ワード (レジスタ) 数、上位バイト = 0。
14 | Data | $B$8 | ワード (レジスタ) 数、下位バイト。この例では、この入力は 1、2、3、5、8 のいずれかになります。
  9. Anybus X-gateway からの TCP/IP Modbus 応答パケットは、QueryDevice 関数のバイナリ構造体に格納されます。これらの戻り値は、In-Sight Explorer で BGetInt 関数によって読み取られます。この関数は、バイナリ構造体の特定のバイトからの整数値を返し、応答は以下のような形式になります。
バイト番号 | Modbus 応答 | 説明
7 | Modbus 関数コード | この例では、3 または 4。このコマンドが失敗すると、関数コードに 128 が追加されます (返される値は 131 または 132。セル E15 を参照してください)。
8 | バイト数 | この例では、2 レジスタ (ワード) = 4 バイト。セル E15 を参照してください。
9/10 | レジスタ 0 の値 | これらの値は 2 バイト形式です。DeviceNetGateway.cxd ファイルでは、セル D18 の BGetInt 関数により、バイト 9 (ワード読み取りの下位バイト) のバイナリ値が読み取られます。
11/12 | レジスタ 1 の値 | これらの値は 2 バイト形式です。DeviceNetGateway.cxd ファイルでは、セル D19 の BGetInt 関数により、バイト 11 (ワード読み取りの下位バイト) のバイナリ値が読み取られます。
13/14 | レジスタ 2 の値 | これらの値は 2 バイト形式です。DeviceNetGateway.cxd ファイルでは、セル D20 の BGetInt 関数により、バイト 13 (ワード読み取りの下位バイト) のバイナリ値が読み取られます。
15/16 | レジスタ 3 の値 | これらの値は 2 バイト形式です。DeviceNetGateway.cxd ファイルでは、セル D21 の BGetInt 関数により、バイト 15 (ワード読み取りの下位バイト) のバイナリ値が読み取られます。
17/18/19/20 | 浮動小数点数値を格納するレジスタ 4 および 5 の値 | これらの値は浮動小数点形式です。DeviceNetGateway.cxd ファイルでは、セル D22 の BGetInt 関数により、バイト 17 (ワード読み取りの下位バイト) のバイナリ値が読み取られます。
21/22/23/24/25/26 | 文字列 (バイト配列) を格納するレジスタ 6、7、および 8 の値 | これらの値は文字列形式です。DeviceNetGateway.cxd ファイルでは、セル D23 の BGetInt 関数により、バイト 21 (ワード読み取りの下位バイト) のバイナリ値が読み取られます。
  10. 書き込み要求用の QueryDevice 関数 (セル B27) は、要求パケットおよび応答パケットと同じ形式で書式設定されます。

PLC から In-Sight ビジョンシステムへの DeviceNet 経由でのデータの読み取り

このモデルによって提供される例に従い、Anybus X-gateway の入力バッファは読み取られるデータソースです。このバッファには、TCP/IP Modbus ネットワーク上の In-Sight ビジョンシステムによって要求される DeviceNet ネットワーク上の PLC からのデータが保持されます。

  1. 「In-Sight Explorer での TCP/IP Modbus による通信の設定」のセクションで作成した In-Sight Explorer ジョブを引き続き使用します。
  2. RSLogix を開き、PLC のプロジェクトをロードします。
  3. I/O Configuration フォルダで、DeviceNet モジュール (この例では 1756-DNB) を右クリックし、[プロパティ] を選択します。

  4. [RSNetWorx] タブをクリックし、前のセクションで作成した設定ファイルを追加します。[OK] をクリックします。

  5. コイルをラダープログラムに追加して、実行モードで DeviceNet スキャナを設定します。

  6. RSLogix で、[Data Types] → [User-Defined] フォルダを右クリックし、メニューから [New Data Type] を選択します。
  7. データ型に AnyBusData という名前を付けます。そのデータ型のメンバで、次の値を配置します。
  • 4 つの整数
  • 1 つの実数
  • ASCII として表示される SINT[6] の配列

  8. ユーザ定義データ型 (この例では InSightData) を使用して、新しいタグをプロジェクトの Controller Tags に追加します。
  9. 最後に、COP 命令を Main Routine　ラダーロジックプログラムに追加して、DeviceNet バッファ (Local:1:0.Data[0]) から InSightData タグにデータをコピーします。

  10. 更新したプロジェクトをコントローラにロードし、オンラインに切り替えて、実行モードで起動します。
  11. [InsightData] タグで、各項目の値を入力します。
  12. In-Sight ビジョンシステムをオンラインにします。
  13. DeviceNetGateway.cxd ファイルのセル A8 で、レジスタの値として [9] (18 バイト) を選択します。
  14. セル NC で、[Read Registers] のドロップダウンリストから、[Input Registers] を選択します。

  15. セル A15 の [Read] ボタンをクリックして、結果を更新します。セル D18 ～ D23 の値は、Controller Tags で入力した値を反映するように変更されます。

In-Sight ビジョンシステムから PLC への DeviceNet 経由でのデータの書き込み

このモデルによって提供される例に従い、Anybus X-gateway の出力バッファは書き込まれるデータソースです。このバッファには、TCP/IP Modbus ネットワーク上の In-Sight ビジョンシステムによって DeviceNet ネットワーク上の PLC に書き込まれるデータが保持されます。

  1. ProfibusGateway.cxd ファイルのセル A8 で、レジスタの値として「8」 (16 バイト) を選択します。
  2. セル C12 で、[Read Registers] のドロップダウンリストから[Holding Registers] を選択します。これにより、In-Sight ジョブ内で書き込まれるのと同じレジスタからデータが読み取られます。
  3. 次に、アプリケーションに対する正しいデータタイプになるように、セル D30 ～ D34 の値を調整します。セル D31 ～ D34 に格納されている 3 つの整数について、EditInt セルに値を入力します (値は、範囲が -32768 ～ 32767 で、この範囲内の有効な整数である必要があります)。セル D35 には浮動小数点値 (値は、範囲が ±1.175495e-38 ～ ±3.402823e+38 で、この範囲内の有効な浮動小数点値である必要があります) を入力し、セル D36 には 6 バイトの文字列 (文字列の長さは 6 文字/バイト以下) を入力します。

  4. セル A27 の [Write] ボタンをクリックし、In-Sight Explorer スプレッドシートから PLC に結果を書き込みます。
  5. RSLogix で、前のプロジェクトを開き、別のラングを追加して、ゲートウェイから InSightData タグにデータを書き込みます。

  6. 更新したプロジェクトをコントローラにロードし、オンラインに切り替えて、実行モードで起動します。
  7. [Controller tags (コントローラタグ)] を開き、InSightData タグで作成したユーザに対する変更をモニタします。
Version: 5.6.0


ロボット通信 - ABB ロボットコントローラ

ロボット通信

In-Sight 通信リファレンス
  • 概要
  • 必要なハードウェア
  • 必要なソフトウェア
  • シリアル通信
  • Ethernet 通信
  • トラブルシューティング

概要

このトピックでは、In-Sight ビジョンシステムから ABB ロボットコントローラに接続し、データを転送する手順の概要を説明します。このトピックでは、ロボットコントローラは、画像取り込みとデータ転送を制御するデバイスを指しています。 一般に、In-Sight ネイティブモードコマンドを使用するロボットコントローラは、画像を取り込み、処理するようにビジョンシステムをトリガし、その後、ビジョンシステムに特定のデータを要求します。データは、シリアル通信または Ethernet 通信を使用して転送できます。

必要なハードウェア

  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)

  • シリアル通信の場合、I/O モジュール、ブレークアウトケーブル (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)。

    注:
    • シリアルベースのロボット通信がブレークアウトケーブルでサポートされていますが (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)、セットアップが容易なので I/O モジュールを推奨します。
    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • DB9 シリアルケーブルまたは Ethernet ケーブル
  • PC
  • ABB ロボットコントローラ (IRC5、S4Cplus、または S4P+)
  • PC インタフェース (Ethernet 通信用に推奨)
  • ビジョンシステムインタフェース (シリアル通信用)

必要なソフトウェア

  • Cognex In-Sight Explorer バージョン 3.3.0 以降
  • Cognex In-Sight ファームウェアバージョン 3.3.0 以降
  • ABB RAPID プログラミング言語

シリアル通信

ロボットコントローラの RAPID コード

MODULE VISION

 ! DATA DECLARATIONS

  PERS num nXOffs:=0;

     PERS num nYOffs:=0;

  PERS num nAngle:=0;

  VAR string stReceived;

  VAR iodev ComChannel;

  PERS tooldata tGripper:=[TRUE,[0,0,0],[0,0,0,1]],

  [5,[0,0,],[1,0,0,0],0,0,0]];

  PERS tooldata tVision:=[TRUE,[[0,0,0],[0,0,0,1]],

  [5,[0, 0, 0],[1,0,0,0],0,0,0]];

  CONST robtarget pHome:=[[0,0,0],[0,0,0,1],

  [-2,0,1,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]];

  CONST robtarget pVisionPos:=[[0,0,0],[0,0,0,1],

  [-2,0,-1,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]];

  PROC Main()

    MoveL pHome,v1000,fine,tVision;

    GetVisionData;

    MoveL Reltool(pVisionPos,nXOffs,nYOffs,0\Rz:=nAngle),v500,

    fine,tGripper;

    WaitTime 3;

    MoveL pHome,v1000,fine,tVision;

  ENDPROC

  PROC GetVisionData()

    VAR string XData:="";

    VAR string YData:="";

    VAR string AngleData:="";

    VAR num NumCharacters:=9;

    VAR bool bOK;

    nXOffs:=0;

    nYOffs:=0;

    nAngle:=0;

    Close ComChannel;

    Open "COM2", ComChannel \Append\Bin;

    ClearIOBuff ComChannel;

    WaitTime\InPos, 0.5;

    ! Instruction In-Sight to Acquire an Image

    ! and not return until complete

    WriteStrBin ComChannel, "sw8\0D";

    CheckStatus;

    ! Get the value in cell C7

    WriteStrBin ComChannel, "gvc007\0D";

    CheckStatus;

    ! Read the X-offset

    XData:= ReadStrbin (ComChannel, NumCharacters \Time:=5);

    ! Read the Y-offset

    YData:= ReadStrbin (ComChannel, NumCharacters \Time:=5);

    ! Read the Angle-offset

    AngleData:= ReadStrbin (ComChannel, NumCharacters \Time:=5);

    !Closes Serial Channel "COM2"

    Close ComChannel;

    !Convert String Data To Numerical Data

    bOK:=StrToVal(XData,nXOffs);

    bOK:=StrToVal(YData,nYOffs);

    bOK:=StrToVal(AngleData,nAngle);

  ENDPROC

  PROC CheckStatus()

    stReceived:=ReadStrBin(ComChannel,1\Time:=5);

    IF stReceived<>"1" THEN

      TPErase;

      TPWrite "Vision Error!";

    Stop;

  ENDIF

  ClearIOBuff ComChannel;

  ENDPROC

ENDMODULE

In-Sight シリアルポートの設定

ビジョンシステムに接続している間 (ビジョンシステムはオフライン) に、次の手順に従ってください。

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。

  2. [I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。[OK] ボタンをクリックして [I/O モジュールの設定] ダイアログを閉じ、[シリアルポートの設定] ダイアログに戻ります。

    3. 注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように設定されている場合、ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

  3. [シリアルポートの設定] ダイアログで、次のプロパティを設定します。

    • [ビット/秒]: 115200
    • [データビット]: 8 (CIO-1400 を使用する場合のデフォルト設定)
    • [ストップビット]: 1 (CIO-1400 を使用する場合のデフォルト設定)
    • [パリティ]: なし
    • [フロー制御]: なし
    • [モード]: Native
    • [固定長の入力]: 無効
    • [入力終端記号]: 13
    • [出力終端記号]: 13
  4. ダイアログで、ビジョンシステムに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されていることを確認します。
  5. [OK] をクリックします。

In-Sight ジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    • トリガ = 外部
    • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、パレット の [スニペット] タブから、[Communication] → [Robots] → [ABB.cxd] スニペットをスプレッドシートに挿入します。
  6. 次のように座標セル参照を定義します。
    • X: C6 をダブルクリック、C2 をダブルクリック
    • Y: D6 をダブルクリック、D2 をダブルクリック
    • 角度: E6 をダブルクリック、E2 をダブルクリック
  7. [手動トリガ] アイコンを数回クリックし、ExtractBlobs 関数からのデータが変化していることを確認します。
  8. ジョブを保存します。
  9. ビジョンシステムをオンラインにします。

Ethernet 通信

ロボットコントローラの設定

次のコードの例は、IP アドレス 192.168.0.1 の In-Sight ビジョンシステムに接続しているコントローラを示しています。ビジョンシステムの IP アドレスを確認するには、In-Sight Explorer の [In-Sight ネットワーク] ツリーでビジョンシステム名を右クリックして、[プロパティ] を選択します。

ロボットコントローラの RAPID コード

MODULE VISION

  ! DATA DECLARATIONS

  PERS num nXOffs:=0;

  PERS num nYOffs:=0;

  PERS num nAngle:=0;

  VAR string stReceived;

  VAR socketdev ComSocket;

  PERS tooldata tGripper:=[TRUE,[0,0,0],[0,0,0,1]],

  [5,[0,0,],[1,0,0,0],0,0,0]];

  PERS tooldata tVision:=[TRUE,[[0,0,0],[0,0,0,1]],

  [5,[0, 0, 0],[1,0,0,0],0,0,0]];

  CONST robtarget pHome:=[[0,0,0],[0,0,0,1],

  [-2,0,1,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]];

  CONST robtarget pVisionPos:=[[0,0,0],[0,0,0,1],

  [-2,0,-1,0],[9E+09,9E+09,9E+09,9E+09,9E+09,9E+09]];

  PROC Main()

    ConnectToInSight ;

    MoveL pHome,v1000,fine,tVision;

    GetVisionData;

    MoveL Reltool(pVisionPos,nXOffs,nYOffs,0\Rz:=nAngle),v500,

    fine,tGripper;

    WaitTime 3;

    MoveL pHome,v1000,fine,tVision;

    GetVisionData;

    MoveL Reltool(pVisionPos,nXOffs,nYOffs,0\Rz:=nAngle),v500,

    fine,tGripper;

    WaitTime 3;

    MoveL pHome,v1000,fine,tVision;

    SocketClose ComSocket;

  ENDPROC

  PROC GetVisionData()

    VAR string XData:="";

    VAR string YData:="";

    VAR string AngleData:="";

    VAR num NumCharacters:=9;

    VAR bool bOK;

    nXOffs:=0;

    nYOffs:=0;

    nAngle:=0;

    status := SocketGetStatus(ComSocket);

    IF status <> SOCKET_CONNECTED THEN

      TPErase;

      TPWrite "Vision Sensor Not Connected";

      Return;

    ENDIF

    ! Instruct In-Sight to Acquire an Image

    ! and not return until complete

    SocketSend ComSocket \Str:="sw8\0d\0a";

    CheckStatus;

    SocketReceive ComSocket \Str:=stReceived;

    ! Get the value in cell C7

    SocketSend ComSocket \Str:="gvc007\0d\0a";

    ! Read the data

    SocketReceive ComSocket \Str:=stReceived;

    ! Parse the data string

    XData:= StrPart(stReceived, 3, NumCharacters);

    YData:= StrPart(stReceived, NumCharacters, NumCharacters);

    AngleData:= StrPart(stReceived, 2*NumCharacters, NumCharacters);

    !Convert String Data To Numerical Data

    bOK:=StrToVal(XData,nXOffs);

    bOK:=StrToVal(YData,nYOffs);

    bOK:=StrToVal(AngleData,nAngle);

    SocketClose ComSocket;

  ENDPROC

  PROC CheckStatus()

    SocketReceive ComSocket \Str:=stReceived;

    IF stReceived <> "1\0d\0a" THEN

      TPErase;

      TPWrite "Vision Error!";

      Stop;

    ENDIF

  ENDPROC

  PROC ConnectToInSight()

    var num found:=0;

    var num length:=0;

    SocketCreate ComSocket;

    SocketConnect ComSocket, "192.168.0.1", 23;

  SocketReceive ComSocket \Str:=stReceived;

    Length:=strlen(stReceived);

    found:=strmatch(stReceived,1,"User:");

    IF found = length+1 THEN

      TPErase;

      TPWrite "Vision Login Error (User Prompt)";

      Stop;

    ENDIF

    ! Send the Username

    SocketSend ComSocket \Str:="admin\0d\0a";

    SocketReceive ComSocket \Str:=stReceived;

    IF stReceived <> "Password: " THEN

      TPErase;

      TPWrite "Vision Login Error (Password Prompt)";

      Stop;

    ENDIF

    ! Send Password

    SocketSend ComSocket \Str:="\0d\0a";

    SocketReceive ComSocket \Str:=stReceived;

    IF stReceived <> "User Logged In\0d\0a" THEN

      TPErase;

      TPWrite "Vision Login Error (Final Login)";

      Stop;

    ENDIF

  ENDPROC

ENDMODULE

In-Sight ジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
  • トリガ = 外部
  • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、パレット の [スニペット] タブから、[Communication] → [Robots] → [ABB.cxd] スニペットをスプレッドシートに挿入します。
  6. 次のように座標セル参照を定義します。
  • X: C6 をダブルクリック、C2 をダブルクリック
  • Y: D6 をダブルクリック、D2 をダブルクリック
  • 角度: E6 をダブルクリック、E2 をダブルクリック
  7. [手動トリガ] アイコンを数回クリックし、ExtractBlobs 関数からのデータが変化していることを確認します。
  8. ジョブを保存します。
  9. ビジョンシステムをオンラインにします。

トラブルシューティング

ハイパーターミナルとのシリアル接続

In-Sight シリアルポートの設定

ビジョンシステムに接続している間 (ビジョンシステムはオフライン) に、次の手順に従ってください。

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。

  2. [I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。[OK] ボタンをクリックして [I/O モジュールの設定] ダイアログを閉じ、[シリアルポートの設定] ダイアログに戻ります。

    注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように設定されている場合、ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

  3. [シリアルポートの設定] ダイアログで、次のプロパティを設定します。

    • [ビット/秒]: 115200
    • [データビット]: 8 (CIO-1400 を使用する場合のデフォルト設定)
    • [ストップビット]: 1 (CIO-1400 を使用する場合のデフォルト設定)
    • [パリティ]: なし
    • [フロー制御]: なし
    • [モード]: Native
    • [固定長の入力]: 無効
    • [入力終端記号]: 13
    • [出力終端記号]: 13
  4. ダイアログで、ビジョンシステムに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されていることを確認します。
  5. [OK] をクリックします。

テストジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    • トリガ = 外部
    • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、「FindBlobs」と入力して Enter キーを押します (この時点で、FindBlobs プロパティシートが表示されます)。
  6. ブロブパラメータについてはセル B2 を参照します。
  7. [OK] をクリックします。
  8. [手動トリガ] アイコンを数回クリックし、データが変化していることを確認します。
  9. ビジョンシステムをオンラインにします。

In-Sight ビジョンシステムへの接続

  1. Windows で、[スタート] → [すべてのプログラム] → [アクセサリ] → [通信] → [ハイパーターミナル] をクリックします。
  2. 新しい接続を生成します ([ファイル] → [新しい接続])。
    • [ポート名]: COM1
    • [ビット/秒]: 115200
    • [データビット]: 8
    • [パリティ]: なし
    • [ストップビット]: 1
    • [フロー制御]: なし
  3. [ファイル] → [プロパティ] → [設定] をクリックします。
    • [エミュレーション]: ANSI
    • [ASCII 設定] の表示を見やすくするため次のように設定します。
      • 行末に改行文字を付ける
      • ローカル エコーする
      • 着信データに改行文字を付ける
      • 右端で折り返す
  4. [接続] をクリックします。
  5. ビジョンシステムのユーザ名とパスワードを入力します (デフォルトのユーザ名は「admin」、パスワードは空白)。
  6. 「User Logged In」と表示されます。
  7. 「SW8」と入力し、Enter キーを押します (手動トリガが実行され、画像が変化します)。
  8. 「GVC004」と入力し、Enter キーを押します (セル C4 に保存されている値が取得されます)。

Telnet による Ethernet 接続の確認

テストジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    • トリガ = 外部
    • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、「FindBlobs」と入力して Enter キーを押します (この時点で、FindBlobs プロパティシートが表示されます)。
  6. ブロブパラメータについてはセル B2 を参照します。
  7. [OK] をクリックします。
  8. [手動トリガ] アイコンを数回クリックし、データが変化していることを確認します。
  9. ビジョンシステムをオンラインにします。

In-Sight ビジョンシステムへの接続

  1. Windows で、[スタート] → [ファイル名を指定して実行] をクリックします。
  2. [ファイル名を指定して実行] ウィンドウで、次のように入力します。telnet < センサの IP アドレス > (例: telnet 10.27.80.66)
  3. [OK] をクリックします。
  4. ビジョンシステムのユーザ名とパスワードを入力します (デフォルトのユーザ名は「admin」、パスワードは空白)。
  5. 「User Logged In」と表示されます。
  6. 「SW8」と入力し、Enter キーを押します (手動トリガが実行され、画像が変化します)。
  7. 「GVC004」と入力し、Enter キーを押します (セル C4 に保存されている値が取得されます)。
  8. telnet セッションを切断するには、Ctrl + ] キーを押します。
  9. 「quit」と入力し、ウィンドウを閉じます。
Version: 5.6.0


ロボット通信 - DENSO ロボットコントローラ

ロボット通信

In-Sight 通信リファレンス
  • 概要
  • 必要なハードウェア
  • 必要なソフトウェア
  • DENSO の設定

概要

このトピックでは、In-Sight ビジョンシステムから DENSO ロボットコントローラに接続し、データを転送する手順の概要を説明します。このトピックでは、ロボットコントローラは、画像取り込みとデータ転送を制御するデバイスを指しています。 一般に、In-Sight ネイティブモードコマンドを使用するロボットコントローラは、画像を取り込み、処理するようにビジョンシステムをトリガし、その後、ビジョンシステムに特定のデータを要求します。

必要なハードウェア

  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)

  • シリアル通信の場合、I/O モジュール、ブレークアウトケーブル (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)。

    注:
    • シリアルベースのロボット通信がブレークアウトケーブルでサポートされていますが (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)、セットアップが容易なので I/O モジュールを推奨します。
    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • RS-232 シリアルケーブル (ヌルモデム) または Ethernet ケーブル (クロスタイプ)
  • PC
  • DENSO ロボットコントローラ (RC-5 または RC-7 バージョン)
  • PC インタフェース (In-Sight 設定用に推奨)
  • ビジョンシステムインタフェース (シリアル通信用)

必要なソフトウェア

  • Cognex In-Sight Explorer バージョン 3.3.0 以降

    注: ビジョンシステムの IP アドレスを確認するには、In-Sight Explorer の [In-Sight ネットワーク] ペインでビジョンシステム名を右クリックし、[プロパティ] を選択します。

  • Cognex In-Sight ファームウェアバージョン 3.3.0 以降
  • DENSO ロボットコントローラ (RC-5 または RC-7)
  • DENSO Wincaps II シミュレーションソフトウェア (オプション)

DENSO の設定

Ethernet 接続には、クロスタイプの Ethernet ケーブルを使用します。

  1. DENSO コントローラの IP アドレスを設定します。
  2. ティーチペンダントのトップ画面から、次の手順を実行します。
    • [F6 Set]、[F5 Set Com]、[F4 Address] を押します。
    • 変更する項目を選択し、[F5 Change] を押します。

    • 必要な IP アドレスを入力して、[OK] をクリックします。この例では、コントローラの IP アドレスとして 192.168.0.1 を使用します。

      注: プログラムコードの入力方法の詳細については、『DENSO Owner's Manual』CD の「Setting Up Manual」の第 5 章「Editing a program in manual mode」を参照してください。

    • DENSO ロボットをキャリブレーションします。

DENSO RC-5 または RC-7 コントローラでの新規プログラムの生成

  1. ティーチペンダントを手動モードに切り替えます。
  2. ティーチペンダントのトップ画面から、次の手順を実行します。
    • [F1 Program] を押します。
    • [F1 New Program] を押します。
    • ダイアログボックスが表示され、新規プログラムを生成するか確認を求められます。[OK] を押します。
    • 新規プログラムの名前を入力し、[OK] を押します。この例では、名前として PRO1 を使用します。

  3. PRO1 に次のサンプルコードを入力します。

    注: プログラムコードの入力方法の詳細については、『DENSO Owner's Manual』CD の「Setting Up Manual」の第 5 章「Editing a program in manual mode」を参照してください。

    • サンプルコードは 4 軸 DENSO ロボット用で、次のことを前提としています。
      • P1 は、ビジョンシステムによって検出される「ピックポイント」となります。
      • IO104 は、アームツールの端にあるグリッパをアクティブにします。
      • アプローチ高さとデパート高さはそれぞれ 75mm です。
      • ピックポイントの「Z」高さは変わりません。

    '!TITLE "PRO1"

    PROGRAM PRO1

    TAKEARM

    SPEED 100

    FLUSH #4

    INPUT #4, F1, F2, F3

    DELAY 100

    LETX P1 = F1

    LETY P1 = F2

    LETT P1 = F2

    APPROACH P, P1 75

    MOVE L, @E P1

    SET IO104

    DELAY 75

    DEPART L, 100

サンプルプログラムの保存とアクティブ化

  1. サンプルプログラムを入力したら、[F6 Save] を押します。
  2. [OK] を押して、入力したプログラムを保存します。
  3. プログラムリストで [PRO1] を選択します。
  4. [F12 Config] を押します。
  5. [Make the specified program active] を選択し、[OK] を押します。
  6. [OK] を押して、コンパイルを開始します。

  7. [OK] を押して、「local variable initialized」エラーに肯定応答します。

    注: 詳細については、『DENSO Owner's Manual』CD の「Beginners Guide」の第 2.1 章「Creating a program」を参照してください。

In-Sight ビジョンシステムとの通信を確立した後、このプログラムを実行すると、DENSO コントローラにデータが入力され、新しいピック位置に移動します。プロジェクトのビジョンシステム部分の設定については、In-Sight のマニュアルを参照してください。
Version: 5.6.0


ロボット通信 - FANUC ロボットコントローラ

ロボット通信

In-Sight 通信リファレンス
  • 概要
  • シリアル通信
  • Ethernet 通信
  • In-Sight ビジョンシステムインタフェースによる通信
  • トラブルシューティング

概要

このトピックでは、In-Sight ビジョンシステムから FANUC ロボットコントローラに接続し、データを転送する手順の概要を説明します。このトピックでは、ロボットコントローラは、画像取り込みとデータ転送を制御するデバイスを指しています。一般に、In-Sight ネイティブモードコマンドを使用するロボットコントローラは、画像を取り込み、処理するようにビジョンシステムをトリガし、その後、ビジョンシステムに特定のデータを要求します。データは、シリアル通信または Ethernet 通信を使用して転送できます。

シリアル通信

このセクションでは、シリアル接続を介して FANUC ロボットコントローラと In-Sight ビジョンシステム間の通信を確立するための手順について説明します。

  • 要件
  • KAREL ロボットコントローラコード
  • In-Sight シリアルポートの設定
  • In-Sight ジョブの設定

要件

必要なハードウェア

  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)
  • シリアル通信の場合、I/O モジュール、ブレークアウトケーブル (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)。

    注:
    • シリアルベースのロボット通信がブレークアウトケーブルでサポートされていますが (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)、セットアップが容易なので I/O モジュールを推奨します。
    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • DB9 シリアルケーブル
  • PC
  • FANUC ロボットコントローラ (RJ2 または RJ3)
  • K-Floppy ケーブル (DB25 - DB9)
  • ヌルモデムアダプタ (DB9 - DB9)

必要なソフトウェア

  • Cognex In-Sight Explorer バージョン 3.3 以降
  • Cognex In-Sight Explorer ファームウェアバージョン 3.3 以降
  • FANUC KAREL® プログラミング言語

KAREL ロボットコントローラコード

VAR

  file_var     :FILE

  Status       :STRING[4]

  xs           :STRING[9]

  ys           :STRING[9]

  angles       :STRING[9]

  x            :REAL

  y            :REAL

  angle        :REAL

BEGIN

-- Connect to In-Sight

OPEN FILE file_var ('RW', 'P2:')

-- Instruction In-Sight to Acquire an Image

-- (wait for a response)

WRITE file_var ('sw8',CHR(13))

-- Read status

READ file_var (status::1::0)

IF status <> '1' THEN

  WRITE TPDISPLAY('sw8 Failed',CR)

  RETURN

ENDIF

CLR_IO_STAT(file_var)

-- Get the value in cell C7

WRITE file_var ('gvc007',CHR(13))

-- Read status

READ file_var (status::1::0)

IF status <> '1' THEN

  WRITE TPDISPLAY('gvc007 Failed',CR)

  RETURN

ENDIF

CLR_IO_STAT(file_var)

-- Read the data

-- This will split the information at the quotations "'".

-- Example String '10.5''9.8''15.9'

READ file_var (xs::0::2, ys::0::2, angles::0::2, CR)

-- Convert the data

CNV_STR_REAL(xs, x)

CNV_STR_REAL(ys, y)

CNV_STR_REAL(angles, angle)

-- Remove comment for testing

-- WRITE TPDISPLAY('X:',x,CR,'Y:',y,CR,'R',Angle,CR)

--

-- Use Vision Data

--

-- Close the connection

CLOSE FILE file_var

In-Sight シリアルポートの設定

ビジョンシステムに接続している間 (ビジョンシステムはオフライン) に、次の手順に従ってください。

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。

  2. [I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。[OK] ボタンをクリックして [I/O モジュールの設定] ダイアログを閉じ、[シリアルポートの設定] ダイアログに戻ります。

    注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように設定されている場合、ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

    [シリアルポートの設定] ダイアログで、次のプロパティを設定します。

    • [ビット/秒]: 19200
    • [データビット]: 8 (CIO-1400 を使用する場合のデフォルト設定)
    • [ストップビット]: 1 (CIO-1400 を使用する場合のデフォルト設定)
    • [パリティ]: なし
    • [フロー制御]: なし
    • [モード]: Native
    • [固定長の入力]: 無効
    • [入力終端記号]: 13
    • [出力終端記号]: 0
    • ダイアログで、ビジョンシステムに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されていることを確認します。
  3. [OK] をクリックします。

In-Sight ジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
  • トリガ = 外部
  • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、パレット の [スニペット] タブから、[Communication] → [Robots] → [FANUC.cxd] スニペットをスプレッドシートに挿入します。
  6. 次のように座標セル参照を定義します。
  • X: C6 をダブルクリック、C2 をダブルクリック
  • Y: D6 をダブルクリック、D2 をダブルクリック
  • 角度: E6 をダブルクリック、E2 をダブルクリック
  7. [手動トリガ] アイコンを数回クリックし、ExtractBlobs 関数からのデータが変化していることを確認します。
  8. ジョブを保存します。
  9. ビジョンシステムをオンラインにします。

Ethernet 通信

このセクションでは、Ethernet 通信を介して FANUC ロボットコントローラと In-Sight ビジョンシステム間の通信を設定するための 2 つのオプションについて説明します。

  • TCP/IP
    • 要件
    • KAREL ロボットコントローラの設定
    • KAREL ロボットコントローラコード
    • In-Sight ジョブの設定
  • EtherNet/IP
    • 要件
    • EtherNet/IP の設定
    • TPP ロボットコントローラの設定
    • TPP ロボットコントローラコード
    • In-Sight ビジョンシステムとロボットコントローラのキャリブレーション
    • In-Sight ジョブの設定と部品の登録
    • EIPInSightJobIOConfiguration

TCP/IP

このセクションでは、TCP/IP を介して FANUC ロボットコントローラと In-Sight ビジョンシステム間の通信を設定する方法について説明します。

要件

必要なハードウェア
  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)
  • Ethernet ケーブル
  • PC
  • FANUC ロボットコントローラ (RJ2 または RJ3)
必要なソフトウェア
  • Cognex In-Sight Explorer バージョン 3.3 以降
  • Cognex In-Sight Explorer ファームウェアバージョン 3.3 以降
  • FANUC KAREL プログラミング言語

KAREL ロボットコントローラの設定

ソケットメッセージングオプションを設定する

設定対象のタグを、ネットワーク上の別のデバイスで使用できるように設定することはできません。

クライアントタグの設定

  1. コントローラをコールドスタートします。
    • ティーチペンダントで、Shift + RESET キーを押し続けます。または、オペレータパネルで RESET キーを押し続けます。
    • ティーチペンダントで Shift + RESET キーを押したまま (または、オペレータパネルで RESET キーを押したまま)、オペレータの ON ボタンを押します。
    • すべてのキーを離します。
  2. ティーチペンダントで、[MENUS] を押します。
  3. [SETUP] を選択します。
  4. F1 キー ([TYPE]) を押します。
  5. [Host Comm] を選択します。
  6. F4 キー ([SHOW]) を押します。
  7. [Clients] を選択します。

  8. カーソルを、ソケットメッセージング用に設定するタグに移動し、F3 キーを押します。次のような画面が表示されます。

    SETUP Tags
    Tag C3:

    ****************
    1 Comment:

    SM
    2 Protocol name:

    *****
    3 Port name:

    *************************
    4 Mode:

    UNDEFINED
    Current

    ********
    State:

    ****************************
    5 Remote:

    192.168.0.1
    6 Path:

    ****************************
    Startup

    OFF
    7 State:

    15 min
    8 Remote:

    9 Path:

    Options

    10 Error Reporting:

    11 Inactivity Timeout:

  9. カーソルを [Protocol name] に移動し、F4 キー ([CHOICE]) を押します。
  10. [SM] を選択します。
  11. カーソルを [Startup State] に移動し、F4 キー ([CHOICE]) を押します。
  12. [Start] を選択して、Enter キーを押します。
  13. [Remote] を選択して、Enter キーを押します。
  14. ソケットメッセージングに使用するリモートホストサーバを入力し、F2 キー ([ACTION]) を押します。

  15. [DEFINE] を選択します。

    注: DNS を使用していない場合は、ホストエントリテーブルにリモートホストとその IP アドレスを追加する必要があります。

システム変数の設定 (クライアントタグ)

  1. [MENUS] を押します。
  2. [NEXT] を選択します。
  3. [SYSTEM] を選択し、F1 キー ([TYPE]) を押します。
  4. [Variables] を選択します。
  5. カーソルを [$HOSTC_CFG] に移動し、Enter キーを押します。

  6. 前のセクション「タグの設定」で選択したタグに対応する構造体にカーソルを移動します。例えば、タグ S3 を設定する場合は、以下の画面に示すように、カーソルを構造体要素 [3] に移動します。

    SYSTEM Variables
    $HOSTS_CFG
    1 [1] | HOST_CFG_T
    2 [2] | HOST_CFG_T
    3 [3] | HOST_CFG_T
    4 [4] | HOST_CFG_T
    5 [5] | HOST_CFG_T
    6 [6] | HOST_CFG_T
    7 [7] | HOST_CFG_T
    8 [8] | HOST_CFG_T

  7. Enter キーを押します。次のような画面が表示されます。

    SYSTEM Variables
    $HOSTS_CFG[3]
    1 $COMMENT | *uninit*
    2 $PROTOCOL | 'SM'
    3 $PORT | *uninit*
    4 $OPER | 3
    5 $STATE | 3
    6 $MODE | *uninit*
    7 $REMOTE | *uninit*
    8 $REPERRS | FALSE
    9 $TIMEOUT | 15
    10 $PATH | *uninit*
    11 $STRT_PATH | *uninit*
    12 $STRT_REMOTE | *uninit*
    13 $USERNAME | *uninit*
    14 $PWRD_TIMOUT | 0
    15 $SERVER_PORT | 23
  8. カーソルを [$SERVER_PORT] に移動します。ソケットメッセージングに使用する TCP/IP サーバポートの名前を入力します。
  9. これで、クライアントタグを KAREL プログラムで使用できます。

KAREL ロボットコントローラコード

次のコードの例は、IP アドレス 192.168.0.1 の In-Sight ビジョンシステムに接続しているコントローラを示しています。ビジョンシステムの IP アドレスを確認するには、In-Sight Explorer の [In-Sight ネットワーク] ペインでビジョンシステム名を右クリックして、[プロパティ] を選択します。

PROGRAM eComm

VAR

  file_var : FILE

  tmp_int  : INTEGER

  mp_str   : STRING[128]

  status   : INTEGER

  entry    : INTEGER

  try      : INTEGER

  statuss      :STRING[1]

  xs           :STRING[9]

  ys           :STRING[9]

  angles       :STRING[9]

  x            :REAL

  y            :REAL

  angle        :REAL

BEGIN

  WRITE TPDISPLAY(CR,CR,CR,CR,CR,CR,CR,CR,CR,CR,CR,CR,CR,CR,CR)

  SET_FILE_ATR(file_var, ATR_IA)

  -- Connect the tag

  WRITE TPDISPLAY('Connecting...',CR)

  MSG_DISCO('C3:', status)

  MSG_CONNECT('C3:',status)

  OPEN FILE file_var('rw','C3:')

  -- Read the In-Sight Welcome message

  WRITE TPDISPLAY('Logging In',CR)

  mp_str =''

  READ file_var(mp_str)

  WRITE TPDISPLAY(mp_str,CR)

  -- Read User: prompt

  READ file_var(mp_str::6::0)

  IF UNINIT(mp_str) THEN

    mp_str = ''

  ENDIF

  WRITE TPDISPLAY(mp_str,CR)

  IF (mp_str <>'User: ') THEN

    WRITE TPDISPLAY('User Failed',CR)

    --Error

    RETURN

  ENDIF

  --Send User Name

  WRITE file_var('admin',CHR(13),CHR(10))

  -- Read Password prompt

  mp_str =''

  READ file_var(mp_str::10::0)

  IF UNINIT(mp_str) THEN

    mp_str = ''

  ENDIF

  WRITE TPDISPLAY(mp_str,CR)

  IF (mp_str <>'Password: ') THEN

    WRITE TPDISPLAY('Password Failed',CR)

    --Error

    RETURN

  ENDIF

  --Send Password

  WRITE file_var('',CHR(13),CHR(10))

  -- Read Login Response

  mp_str =''

  READ file_var(mp_str)

  IF UNINIT(mp_str) THEN

    mp_str = ''

  ENDIF

  WRITE TPDISPLAY(mp_str,CR)

  IF (mp_str <> 'User Logged In') THEN

    WRITE TPDISPLAY('Log In Failed',CR)

    --Error

    RETURN

  ENDIF

  -- Instruction In-Sight to Acquire an Image

  -- (wait for a response)

  WRITE TPDISPLAY('Trigger',CR)

  WRITE file_var ('sw8',CHR(13),CHR(10))

  -- Read Status

  READ file_var (statuss)

  IF statuss <> '1' THEN

    WRITE TPDISPLAY('sw8 Failed',CR)

    RETURN

  ENDIF

  -- Get the value in cell C7

  WRITE TPDISPLAY('Get Value C7',CR)

  WRITE file_var ('gvc007',CHR(13),CHR(10))

  -- Read Status

  READ file_var (statuss)

  IF statuss <> '1' THEN

    WRITE TPDISPLAY('gvc007 Failed',CR)

    RETURN

  ENDIF

  -- Read the data

  -- This will split the information at the quotations "'".

  -- Example String '10.5''9.8''15.9'

  READ file_var (xs::0::2, ys::0::2, angles::0::2, CR)

  --Disconnect Socket

  MSG_DISCO('C3:', status)

  -- Convert the data

  CNV_STR_REAL(xs, x)

  CNV_STR_REAL(ys, y)

  CNV_STR_REAL(angles, angle)

  WRITE TPDISPLAY('X:',x,CR,'Y:',y,CR,'R',Angle,CR)

END eComm

In-Sight ジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    1. トリガ = 外部
    2. 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、パレット の [スニペット] タブから、[Communication] → [Robots] → [FANUC.Communications] スニペットをスプレッドシートに挿入します。
  6. 次のように座標セル参照を定義します。
    1. X: C6 をダブルクリック、C2 をダブルクリック
    2. Y: D6 をダブルクリック、D2 をダブルクリック
    3. 角度: E6 をダブルクリック、E2 をダブルクリック
  7. [手動トリガ] アイコンを数回クリックし、ExtractBlobs 関数からのデータが変化していることを確認します。
  8. ジョブを保存します。
  9. ビジョンシステムをオンラインにします。

EtherNet/IP

このセクションでは、EtherNet/IP (EIP) を介して FANUC ロボットコントローラと In-Sight ビジョンシステム間の通信を設定する方法について説明します。この設定シナリオの例では、ロボットコントローラは、画像取り込みとその後のビジョンシステムからのデータ転送を制御するデバイスを指しています。一般に、ロボットコントローラは、X、Y、および角度データの画像を取り込み、処理するようにビジョンシステムをトリガします。EtherNet/IP 通信は、ビジョンシステムをトリガし、データをロボットコントローラに送信するのに使用されます。また、16 ビットデジタル入力ラインは、2D 部品の位置を転送するのに使用されます。

注:
  • 負の浮動小数点数値は入力ラインを介して送信することはできません。すべての数値はビジョンシステムで 10 を乗算され、その後ロボットコントローラで 10 で除算されます。
  • このセクションで使用される I/O 設定は 1 つの例であり、実際の I/O 設定とは異なる場合があります。EtherNet/IP はラック 89 を使用しますが、スロットの場所は取り付けによって変わる場合があります。この例では、ラック 89 とスロット 1 を使用します。

要件

必要なハードウェア
  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)
  • Ethernet ケーブル
  • PC
  • FANUC ロボットコントローラ (R-30iA™)
必要なソフトウェア
  • In-Sight Explorer バージョン 4.8 以降
  • In-Sight Explorer ファームウェアバージョン 4.8 以降
  • FANUC ソフトウェア R540 EtherNet/IP I/O スキャナ
  • FANUC ティーチペンダントプログラミング (TPP)

EtherNet/IP の設定

  1. ロボットコントローラと通信する In-Sight ビジョンシステムに接続します。
  2. [センサ] メニューから、[ネットワークの設定] を選択して [ネットワークの設定] ダイアログを開きます。

  3. [産業用イーサネットプロトコル] を [EtherNet/IP] に設定します。

TPP ロボットコントローラの設定

  1. FANUC R540 EtherNet/IP I/O スキャナソフトウェアを起動します。
  2. [MENU] を押します。
  3. I/O を選択します。

  4. F1 キー ([TYPE]) を押して、[EtherNet/IP] を選択します。下のような画面が表示されます。

    EtherNet/IP List(Rack 89) 1/32
    説明 | TYP | 有効 | ステータス | スロット
    Connection1 | ADP | FALSE | OFFLINE | 1
    Connection2 | ADP | FALSE | OFFLINE | 2
    Connection3 | ADP | FALSE | OFFLINE | 3
    Connection4 | ADP | FALSE | OFFLINE | 4
    Connection5 | ADP | FALSE | OFFLINE | 5
    Connection6 | ADP | FALSE | OFFLINE | 6
    Connection7 | ADP | FALSE | OFFLINE | 7
    Connection8 | ADP | FALSE | OFFLINE | 8
    Connection9 | ADP | FALSE | OFFLINE | 9
    ConnectionA | ADP | FALSE | OFFLINE | 10
    ConnectionB | ADP | FALSE | OFFLINE | 11
    ConnectionC | ADP | FALSE | OFFLINE | 12
    ConnectionD | ADP | FALSE | OFFLINE | 13
    ConnectionE | ADP | FALSE | OFFLINE | 14
    ConnectionF | ADP | FALSE | OFFLINE | 15
    ConnectionG | ADP | FALSE | OFFLINE | 16
    ConnectionH | ADP | FALSE | OFFLINE | 17
    ConnectionI | ADP | FALSE | OFFLINE | 18
    ConnectionJ | ADP | FALSE | OFFLINE | 19
    ConnectionK | ADP | FALSE | OFFLINE | 20

  5. 適切な接続を選択して、名前を変更します。システムが正常に接続されたら、表に次のように設定が反映されます。

    EtherNet/IP List(Rack 89) 1/32
    説明 | TYP | 有効 | ステータス | スロット
    COGNEX | SCN | TRUE | RUNNING | 1
    Connection2 | ADP | FALSE | OFFLINE | 2
In-Sight ビジョンシステム EtherNet/IP I/O の設定
In-Sight Micro 1000 シリーズビジョンシステム In-Sight 5100/5400/5600 シリーズビジョンシステム In-Sight 5705/5705C シリーズビジョンシステム In-Sight 70xx/74xx シリーズビジョンシステム In-Sight 76xx/79xx シリーズビジョンシステム In-Sight 8000 シリーズビジョンシステム
  • IP アドレス: ビジョンシステムの IP アドレスをここに挿入します
  • ベンダ ID: 678
  • デバイスのタイプ: 100
  • 製品コード: 260
  • 入力サイズ (ワード): 64
  • 出力サイズ (ワード): 64
  • RPI (ミリ秒): 32
  • アセンブリインスタンス (入力): 12
  • アセンブリインスタンス (出力): 21
  • 設定インスタンス: 0
  • IP アドレス: ビジョンシステムの IP アドレスをここに挿入します
  • ベンダ ID: 678
  • デバイスのタイプ: 100
  • 製品コード: 257
  • 入力サイズ (ワード): 64
  • 出力サイズ (ワード): 64
  • RPI (ミリ秒): 32
  • アセンブリインスタンス (入力): 12
  • アセンブリインスタンス (出力): 21
  • 設定インスタンス: 0
  • IP アドレス: ビジョンシステムの IP アドレスをここに挿入します
  • ベンダ ID: 678
  • デバイスのタイプ: 100
  • 製品コード: 273
  • 入力サイズ (ワード): 64
  • 出力サイズ (ワード): 64
  • RPI (ミリ秒): 32
  • アセンブリインスタンス (入力): 13
  • アセンブリインスタンス (出力): 22
  • 設定インスタンス: 0
  • IP アドレス: ビジョンシステムの IP アドレスをここに挿入します
  • ベンダ ID: 678
  • デバイスのタイプ: 100
  • 製品コード: 265
  • 入力サイズ (ワード): 64
  • 出力サイズ (ワード): 64
  • RPI (ミリ秒): 32
  • アセンブリインスタンス (入力): 12
  • アセンブリインスタンス (出力): 21
  • 設定インスタンス: 0
  • IP アドレス: ビジョンシステムの IP アドレスをここに挿入します
  • ベンダ ID: 678
  • デバイスのタイプ: 100
  • 製品コード: 276
  • 入力サイズ (ワード): 64
  • 出力サイズ (ワード): 64
  • RPI (ミリ秒): 32
  • アセンブリインスタンス (入力): 13
  • アセンブリインスタンス (出力): 22
  • 設定インスタンス: 0
  • IP アドレス: ビジョンシステムの IP アドレスをここに挿入します
  • ベンダ ID: 678
  • デバイスのタイプ: 100
  • 製品コード: 274
  • 入力サイズ (ワード): 64
  • 出力サイズ (ワード): 64
  • RPI (ミリ秒): 32
  • アセンブリインスタンス (入力): 13
  • アセンブリインスタンス (出力): 22
  • 設定インスタンス: 0
入力の定義
名前 | 信号のタイプ | 信号のラベル | 装置のマップ
DI_Trig_Ready | DI | Trigger Ready | 0
DI_Trig_Ack | DI | Trigger Ack | 1
DI_Acquiring | DI | Acquiring | 2
DI_Miss_Ack | DI | Missed Acquisition | 3
GI_Offline_Reason | GI | Offline Reason | 4 ~ 6
DI_Online | DI | Online | 7
DI_Inspecting | DI | Inspecting | 8
DI_Inspect_Comp | DI | Inspection Completed | 9
DI_Buffer_Overrun | DI | Results Buffer Overrun | 10
DI_Results_Valid | DI | Results Valid | 11
DI_Job_Loading | DI | Job Loading | 12
DI_Load_Comp | DI | Job Load Completed | 13
DI_Load_Fail | DI | Job Load Failed | 14
GI_Reserved | GI | Reserved | 15 ～ 23
GI_Reserved2 | GI | Reserved | 24 ～ 26
DI_ExposureComp | DI | Exposure Completed | 27
DI_JobPass | DI | Job Pass | 28
GI_Reserved3 | GI | Reserved | 29 ～ 31
GI_CurrentJobID | GI | Current Job ID | 32 ～ 47
GI_AcquisitionID | GI | Ack ID | 48 ～ 64
GI_InspectionID | GI | Inspection ID | 65 ～ 80
GI_InspectionResult | GI | Inspection Result | 81 ～ 96
GI_X_Position | GI | User Data Input 0 | 97 ～ 112
GI_Y_Position | GI | User Data Input 1 | 113 ～ 128
GI_Angle | GI | User Data Input 2 | 129 ～ 144
DI_X_Negative | DI |  | 145
DI_Y_Negative | DI |  | 146
DI_A_Negative | DI |  | 147
サンプル

下に、ロボットコントローラのデジタル入力設定のサンプルを示します。EtherNet/IP はラック 89 で、スロットは EtherNet/IP 設定セクションの接続番号です。ビットは 1 から開始します。

注: これは、設定のサンプルです。ロボットの設定では、ラック 89、スロット 1 が必要になります。

番号 | 範囲 | ラック | スロット | 開始 | ステータス
1 | DI[ 1- 80] | 0 | 0 | 0 | UNASG
2 | DI[ 81- 88] | 48 | 1 | 21 | ACTIV
3 | DI[ 89- 100] | 0 | 0 | 0 | UNASG
4 | DI[ 101-120] | 48 | 1 | 1 | ACTIV
5 | DI[ 121-124] | 89 | 1 | 1 | ACTIV
6 | DI[ 125-133] | 89 | 1 | 8 | ACTIV
7 | DI[ 134-585] | 89 | 1 | 145 | ACTIV
出力の定義
名前 | 信号のタイプ | 信号のラベル | 装置のマップ
DO_Trig_Enable | DO | Trigger Enable | 0
DO_Trigger | DO | Trigger | 1
DO_Results_Enable | DO | Buffer Results Enable | 2
DO_Results_Ack | DO | Inspection Results Ack | 3
 | DO | Reserved | 4
 | DO | Reserved | 5
 | DO | Reserved | 6
DO_Set_Offline | DO | Set Offline | 7
DO_SE0 | DO | Soft Event 0 | 8
DO_SE1 | DO | Soft Event 1 | 9
DO_SE2 | DO | Soft Event 2 | 10
DO_SE3 | DO | Soft Event 3 | 11
DO_SE4 | DO | Soft Event 4 | 12
DO_SE5 | DO | Soft Event 5 | 13
DO_SE6 | DO | Soft Event 6 | 14
DO_SE7 | DO | Soft Event 7 | 15
DO_Reserved | GO | Reserved | 16 ～ 31
DO_UserData_000 | GO | User Data 0 | 32 ～ 39
DO_UserData_001 | GO | User Data 1 | 40 ～ 47
サンプル

下に、ロボットコントローラのデジタル出力設定のサンプルを示します。

注: これは、設定のサンプルです。ロボットの設定では、ラック 89、スロット 1 が必要になります。

番号 | 範囲 | ラック | スロット | 開始 | ステータス
1 | DO[ 1- 80] | 0 | 0 | 0 | UNASG
2 | DO[ 81- 84] | 48 | 1 | 21 | ACTIV
3 | DO[ 85- 100] | 0 | 0 | 0 | UNASG
4 | DO[ 101-120] | 48 | 1 | 1 | ACTIV
5 | DO[ 121-184] | 89 | 1 | 1 | ACTIV
6 | DO[ 185-256] | 89 | 1 | 65 | ACTIV
7 | DO[ 257-616] | 89 | 1 | 153 | ACTIV

グループ I/O の設定
GI# | ラック | スロット | 開始ポイント | 番号ポイント
1 | 89 | 1 | 5 | 3
2 | 89 | 1 | 33 | 16
3 | 89 | 1 | 49 | 16
4 | 89 | 1 | 65 | 16
5 | 89 | 1 | 81 | 16
6 | 89 | 1 | 97 | 16
7 | 89 | 1 | 113 | 16
8 | 89 | 1 | 129 | 16

# SIM VALUE | 7/64
GI[ 1]U | 0 [GI_Offline_Reas]
GI[ 2]U | 56 [GI_CurrentJob_ID ]
GI[ 3]U | 56 [GI_Ack_ID ]
GI[ 4]U | 56 [GI_Inspect_ID ]
GI[ 5]U | 0 [GI_Inspect ]
GI[ 6]U | 2426 [GI_X_Position ]
GI[ 7]U | 3208 [GI_Y_Position ]
GI[ 8]U | 242 [GI_Angle ]

TPP ロボットコントローラコード

次のサンプルコードは、In-Sight ビジョンシステムをトリガして、グループ入力データ、および X、Y、角度データを取得する方法を示しています (値が負であるかどうかがチェックされます)。I/O の値は、ロボット I/O の設定に応じて異なる場合があります。

注: このコードで取得されるのは、部品の実際のオフセットではなく、部品の検出位置です。

1: DO[121:DO_Trigger_Enable]=ON

2: WAIT DI[121:DI_Trigger_Ready]=ON

3: DO[122:DO_Trigger]=ON

4:

5: WAIT DI[122:DI_Trigger_Ack]=ON

6: DO[122:DO_Trigger]=OFF

8:

9: IF DI[127:DI_Inspect_Complete]= OFF,JMP LBL[2]

10:

11: LBL[1]

12: WAIT DI[127:DI_Inspect_Complete] =OFF

13: JMP LBL[3]

14:

15: LBL[2]

16: WAIT DI[127:DI_Inspect_Complete]=ON

17:

18: LBL[3]

19:

20: R[2:X Position]=GI[6:GI_X_Position]

21: R[2:X Position]=R[2:X Position]/10

22:

23: IF DI[145:X_Negative]=OFF,JMP LBL[4]

24: R[2:X Position]=R[2:X Position]*(-1)

25:

26: LBL[4]

27:

28: R[3:Y Position]=GI[7:GI_Y_Position]

29: R[3:Y Position]=R[3:Y Position]/10

30: IF DI[146:Y_Negative]=OFF,JMP LBL[5]

31:

32: R[3:Y Position]=R[3:Y Position]*(-1)

33:

34: LBL[5]

35:

36: R[4:Angle]=GI[8:GI_Angle]

37: R[4:Angle]=R[4:Angle]/10

38:

39: IF DI[147:A_Negative]=OFF,JMP LBL[6]

40:

41: R[4:Angle]=R[4:Angle]*(-1)

42:

43: LBL[6]

44:L @P[1] 50mm/sec FINE

45:

46:

47:

48: PR[1,1]=R[2:X Position]

49: PR[1,2]=R[3:Y Position]

50:

51: PR[1,6]=PR[1,6]+R[4:Angle]

52:

53:L PR[1] 50mm/sec FINE

54: WAIT .50(sec)

55: PR[1,6]=47.002

56:

57:L @P[1] 100mm/sec FINE

注: PR[1] の値は、最初に選択された位置と同じにする必要があります。こうすることにより、Z の高さおよび RX、RY の値を正しく設定することができます。

In-Sight ビジョンシステムとロボットコントローラのキャリブレーション

高精度チェッカボードキャリブレーションプレートを使用して、In-Sight ビジョンシステムから得られた結果を、ピクセルから実世界の測定単位にキャリブレーションすることは非常に重要です。このセクションでは、ビジョンシステムとロボットの間のキャリブレーションプロセスに関して重要になる点について説明します。

注: キャリブレーションプロセスの設定方法に関する詳細な手順については、CalibrateGrid 関数のトピックを参照してください。キャリブレーションプレートの詳細については、弊社営業窓口にお問い合わせください。

キャリブレーションを設定する際には、ビジョンシステムの視野 (FOV) にキャリブレーションプレートを配置します。キャリブレーションプレートがビジョンシステムの FOV 全体を覆っていることを確認してください。FOV 全体を覆うことができない場合は、複数のポーズ (例えば、複数の画像を取り込むなど) を使用する必要があります。

ロボットのユーザフレームの使用

ロボットのユーザフレームを作成するには、次の 2 つの方法を使用することができます。CalibrateGrid 関数を使用して原点を割り当てるか、または手動で原点を割り当てる方法です。

CalibrateGrid の原点

下の画像は、CalibrateGrid 関数により原点を自動的に割り当てる方法を示しています。原点は、+X および +Y 軸上の 2 つの赤い十字が交わる点に配置されます。この方法でロボットのユーザフレームを設定すると、ロボットのユーザフレームの原点 (0,0) が CalibrateGrid 関数の原点 (0,0) と同じになります。

手動による原点の割り当て

下の画像は、原点を左下隅、つまり +X が下の右方向および +Y が左の上方向になるように手動で割り当てる方法を示しています。この場合、緑の十字の X、Y 位置を、CalibrateGrid 関数の [ポーズ] ペインに手動で入力する必要があります。

In-Sight ジョブの設定と部品の登録

In-Sight ビジョンシステムをキャリブレーションしたら、次はジョブを実行するための残りの設定を行います。

ビジョンシステムが外部トリガを受け入れるように設定する必要があります。EasyBuilder ビューの [画像の設定] アプリケーションステップで、[トリガ] パラメータを [外部] に設定します。

次に、PatMax パターンモデルを使用して、部品を検出します。EasyBuilder ビューの [位置決め] アプリケーションステップに移動し、[PatMax パターン位置決めツール] を追加して部品を検出します。次に、[検査] アプリケーションステップに移動し、3 つの [演算 & ロジックツール] を追加して X、Y、および角度の絶対値を乗算し、値の端数を切り上げます。追加したこの 3 つの [演算 & ロジックツール] は、出力値が負であるか正であるかを判別するのにも使用できます。

注: 位置決めツールと検査ツールの設定および使用方法の詳細については、EasyBuilder ビューの [パレット] の [ヘルプ] タブを参照してください。

In-Sight ジョブの I/O 設定

ツールを設定して結果が返されたら、次の手順はその結果をロボットコントローラに出力することです。EasyBuilder ビューで、[通信] アプリケーションステップに移動します。[デバイスの追加] ボタンをクリックして、[デバイス] として [ロボット] を、[メーカー] として [FANUC] を、[プロトコル] として [EtherNet IP Robot (EtherNet IP ロボット)] を選択し、[OK] ボタンをクリックします。デバイスが追加されている場合、EasyBuilder は、フィクスチャを定義し、フィクスチャを表すデータ文字列を生成する、位置決めツールまたは検査ツールがあるかどうかジョブを自動的にサーチします。

[フォーマット出力データ] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。出力バッファ文字列が表示され、それとともにメッセージサイズも参照用にバイト単位で表示されます。

注: [通信] アプリケーションステップの設定および使用方法の詳細については、EasyBuilder ビューの [パレット] の [ヘルプ] タブを参照してください。

In-Sight ビジョンシステムインタフェースによる通信

センサインタフェースオプションを使用するには、PREMOSYS の Web サイト (http://www.premosys.com) からサードパーティのプロトコルコンバータを入手する必要があります。このコンバータは、FANUC のセンサインタフェースのシリアルフロー制御プロトコルを処理します。

  • 要件
  • ロボットコントローラのティーチペンダントコード
  • In-Sight シリアルポートの設定
  • In-Sight ジョブの設定

要件

必要なハードウェア

  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)
  • シリアル通信の場合、I/O モジュール、ブレークアウトケーブル (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)。

    注:
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • PREMOSYS プロトコルコンバータ VE0010
  • PC
  • FANUC ロボットコントローラ (RJ2 または RJ3)
  • シリアルケーブル (DB25 - DB25)
  • In-Sight と VE0010 の接続用ケーブル (VE0010 のマニュアルを参照)

必要なソフトウェア

  • Cognex In-Sight Explorer バージョン 3.3 以降
  • Cognex In-Sight Explorer ファームウェアバージョン 3.3 以降
  • FANUC センサインタフェースオプション

ロボットコントローラのティーチペンダントコード

   1:  R[20:MEASURE_CNTR_CAM]=0    ;

   2:  R[2:ALARM CODE]=0    ;

   3:  LBL[9] ;

   4:  !REGISTER CHOICE ;

   5:  R[51:REGISTER_CHOICE]=5    ;

   6:  R[6:INTERMEDIATE_CALC]=R[51:REGISTER_CHOICE]*65536    ;

   7:  R[1:SEND_CAM]=R[50:PRODUCT_CHOICE]+256    ;

   8:  R[1:SEND_CAM]=R[1:SEND_CAM]+1    ;

   9:  R[1:SEND_CAM]=R[1:SEND_CAM]+R[6:INTERMEDIATE_CALC]    ;

  10:  R[5:REC_ACK]=0    ;

  11:  SEND R[1:SEND_CAM] ;

  12:  RCV R[5:REC_ACK] LBL[1] TIMEOUT,LBL[1] ;

  13:  R[20:MEASURE_CNTR_CAM]=R[20:MEASURE_CNTR_CAM]+1    ;

  14:  JMP LBL[2] ;

  15:  !Measurement I/O ;

  16:  LBL[2] ;

  17:  IF R[5:REC_ACK]=1,JMP LBL[3] ;

  18:  !Measurement Not OK ;

  19:  IF R[20:MEASURE_CNTR_CAM]=1,JMP LBL[9] ;

  20:  IF R[20:MEASURE_CNTR_CAM]=2,JMP LBL[10] ;

  21:  LBL[10] ;

  22:  !In-Sight TO ROBOT ;

  23:  IF R[5:REC_ACK]=2 OR R[5:REC_ACK]=3 OR R[5:REC_ACK]=6,JMP LBL[4] ;

  24:  !ROBOT TO In-Sight ;

  25:  IF R[5:REC_ACK]=4 OR R[5:REC_ACK]=5 OR R[5:REC_ACK]=8 OR

    :  R[5:REC_ACK]=9,JMP LBL[5] ;

  26:  !POSITION IS Not OK ;

  27:  IF R[5:REC_ACK]=12,JMP LBL[6] ;

  28:  LBL[4:Alarm Code 1] ;

  29:  R[2:ALARM CODE]=4    ;

  30:  JMP LBL[3] ;

  31:  LBL[5:Alarm Code 2] ;

  32:  R[2:ALARM CODE]=5    ;

  33:  JMP LBL[3] ;

  34:  LBL[6:Alarm Code 3] ;

  35:  R[2:ALARM CODE]=6    ;

  36:  JMP LBL[3] ;

  37:  LBL[3:End] ;

In-Sight シリアルポートの設定

ビジョンシステムに接続している間 (ビジョンシステムはオフライン) に、次の手順に従ってください。

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。

  2. [シリアルポートの設定] ダイアログで、次のプロパティを設定します。

    • [ビット/秒]: 4800
    • [データビット]: 8
    • [ストップビット]: 1
    • [パリティ]: なし
    • [フロー制御]: なし
    • [モード]: Native
    • [固定長の入力]: 無効
    • [入力終端記号]: 13
    • [出力終端記号]: 13
  3. [OK] をクリックします。

In-Sight ジョブの設定

VE0010 プロトコルコンバータに付属のサンプルを使用します。

トラブルシューティング

  • ハイパーターミナルとのシリアル接続
  • Telnet による Ethernet 接続の確認

ハイパーターミナルとのシリアル接続

In-Sight シリアルポートの設定

ビジョンシステムに接続している間 (ビジョンシステムはオフライン) に、次の手順に従ってください。

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。

  2. [I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、I/O モジュールを設定します。[OK] ボタンをクリックして [I/O モジュールの設定] ダイアログを閉じ、[シリアルポートの設定] ダイアログに戻ります。

    注:In-Sight 70xx ～ 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように設定されている場合、ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

  3. [シリアルポートの設定] ダイアログで、次のプロパティを設定します。

    • [ビット/秒]: 115200
    • [データビット]: 8 (CIO-1400 を使用する場合のデフォルト設定)
    • [ストップビット]: 1 (CIO-1400 を使用する場合のデフォルト設定)
    • [パリティ]: なし
    • [フロー制御]: なし
    • [モード]: Native
    • [固定長の入力]: 無効
    • [入力終端記号]: 13
    • [出力終端記号]: 13
  4. ダイアログで、ビジョンシステムに物理的に接続されている I/O モジュールの横に「(接続済み)」というメッセージが表示されていることを確認します。
  5. [OK] をクリックします。

テストジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    • トリガ = 外部
    • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、「FindBlobs」と入力して Enter キーを押します (この時点で、FindBlobs プロパティシートが表示されます)。
  6. ブロブパラメータについてはセル B2 を参照します。
  7. [OK] をクリックします。
  8. [手動トリガ] アイコンを数回クリックし、データが変化していることを確認します。
  9. ビジョンシステムをオンラインにします。

In-Sight ビジョンシステムへの接続

  1. Windows で、[スタート] → [すべてのプログラム] → [アクセサリ] → [通信] → [ハイパーターミナル] をクリックします。
  2. 新しい接続を生成します ([ファイル] → [新しい接続])。
    • [ポート名]: COM1
    • [ビット/秒]: 115200
    • [データビット]: 8
    • [パリティ]: なし
    • [ストップビット]: 1
    • [フロー制御]: なし
  3. [ファイル] → [プロパティ] → [設定] をクリックします。
    • [エミュレーション]: ANSI
    • [ASCII 設定] の表示を見やすくするため次のように設定します。
      • 行末に改行文字を付ける
      • ローカル エコーする
      • 着信データに改行文字を付ける
      • 右端で折り返す
  4. [接続] をクリックします。
  5. ビジョンシステムのユーザ名とパスワードを入力します (デフォルトのユーザ名は「admin」、パスワードは空白)。
  6. 「User Logged In」と表示されます。
  7. 「SW8」と入力し、Enter キーを押します (手動トリガが実行され、画像が変化します)。
  8. 「GVC004」と入力し、Enter キーを押します (セル C4 に保存されている値が取得されます)。

Telnet による Ethernet 接続の確認

テストジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    • トリガ = 外部
    • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、「FindBlobs」と入力して Enter キーを押します (この時点で、FindBlobs プロパティシートが表示されます)。
  6. ブロブパラメータについてはセル B2 を参照します。
  7. [OK] をクリックします。
  8. [手動トリガ] アイコンを数回クリックし、データが変化していることを確認します。
  9. ビジョンシステムをオンラインにします。

In-Sight ビジョンシステムへの接続

  1. Windows で、[スタート] → [ファイル名を指定して実行] をクリックします。
  2. [ファイル名を指定して実行] ウィンドウで、次のように入力します。telnet < センサの IP アドレス > (例: telnet 10.27.80.66)
  3. [OK] をクリックします。
  4. ビジョンシステムのユーザ名とパスワードを入力します (デフォルトのユーザ名は「admin」、パスワードは空白)。
  5. 「User Logged In」と表示されます。
  6. 「SW8」と入力し、Enter キーを押します (手動トリガが実行され、画像が変化します)。
  7. 「GVC004」と入力し、Enter キーを押します (セル C4 に保存されている値が取得されます)。
  8. telnet セッションを切断するには、Ctrl + ] キーを押します。
  9. 「quit」と入力し、ウィンドウを閉じます。
Version: 5.6.0


Kuka 通信

ロボット通信 - KUKA ロボットコントローラ

In-Sight 通信リファレンス

KUKA ロボットは、品質検証からオブジェクトや位置検出、ピックアンドプレースアプリケーションまで、多数のアプリケーションで In-Sight ビジョンシステムを統合することができます。

  • KUKA Serial


ロボット通信 - Kawasaki ロボットコントローラ

ロボット通信

In-Sight 通信リファレンス
  • 概要
  • 必要なハードウェア
  • 必要なソフトウェア
  • In-Sight の設定
  • ロボットコントローラの設定

概要

このトピックでは、In-Sight ビジョンシステムから Kawasaki ロボットコントローラに接続し、データを転送する手順の概要を説明します。このトピックでは、ロボットコントローラは、画像取り込みとデータ転送を制御するデバイスを指しています。 一般に、(Telnet またはシリアル RS-232 を介して) In-Sight ネイティブモードコマンドを使用するロボットコントローラは、画像を取り込んで処理するようにセンサにトリガしてから、そのセンサに特定のデータを要求します。 データは、シリアル通信か Ethernet 通信を使用して転送できますが、Kawasaki では Ethernet TCP/IP 通信の使用を推奨しています。

必要なハードウェア

  • In-Sight ビジョンシステム (In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 7000 シリーズ、または In-Sight 8000 シリーズのビジョンシステム)

  • シリアル通信の場合、I/O モジュール、ブレークアウトケーブル (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)。

    注:
    • シリアルベースのロボット通信がブレークアウトケーブルでサポートされていますが (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)、セットアップが容易なので I/O モジュールを推奨します。
    • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
    • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
    • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • PC
  • D コントローラ 1QN (Ethernet オプションで使用) または C コントローラ 1HA (Ethernet オプションで使用)
  • Ethernet 接続対応ケーブル (100Base-T)
  • センサインタフェース (シリアル通信用)

必要なソフトウェア

  • Cognex In-Sight Explorer バージョン 3.3.1 以降
  • Cognex In-Sight ファームウェアバージョン 3.3.1 以降
  • Kawasaki AS プログラミング言語

In-Sight の設定

Kawasaki ロボットコントローラに接続してデータを転送するように In-Sight ビジョンシステムを設定するには、ビジョンシステムの [ネットワークの設定] で設定を行ってロボットコントローラと通信し、位置データを抽出するジョブを構築します。Kawasaki ロボットコントローラと通信するように In-Sight ビジョンシステムを設定すると、ビジョンシステムはサーバとして動作します。ロボットコントローラが値を取得するための要求を送信すると (GetValue - TCP_SEND)、ビジョンシステムはその要求を処理してセル値で応答します。ロボットコントローラはデータを受信し (TCP_RECEIVE)、データを使用可能なフォーマットにデコードします。

In-Sight ネットワークの設定

  1. [センサ] メニューから [ネットワークの設定] を選択します。
  2. [ネットワークの設定] ダイアログで、[DHCP サーバの使用] チェックボックスをオフにします。
  3. [IP アドレス] パラメータに、ビジョンシステムの IP アドレス (この例では 192.168.0.12) を入力します。
  4. [Telnet ポート] パラメータを [10,000] に設定します。
  5. [OK] をクリックして、[ネットワークの設定] ダイアログを閉じます。

In-Sight ジョブの設定

  1. [ファイル] メニューから、新規ジョブを作成します。
  2. AcquireImage プロパティシート (セル A0 をダブルクリック) で、次のパラメータを設定します。
    • トリガ = 外部
    • 手動 = ON
  3. セル A2 を選択し、「ExtractBlobs」と入力して Enter キーを押します (この時点で、ExtractBlobs プロパティシートが表示されます)。
  4. [OK] をクリックします (パラメータはすべて、デフォルト設定値のままになります)。
  5. セル A4 を選択し、パレット の [スニペット] タブから、[Communication] → [Robots] → [General.cxd] スニペットをスプレッドシートに挿入します。
  6. 次のように座標セル参照を定義します。
    • X: C6 をダブルクリック、C2 をダブルクリック
    • Y: D6 をダブルクリック、D2 をダブルクリック
    • 角度: E6 をダブルクリック、E2 をダブルクリック
  7. [手動トリガ] アイコンを数回クリックし、ExtractBlobs 関数からのデータが変化していることを確認します。
  8. ジョブを保存します。
  9. センサをオンラインにします。

ロボットコントローラの設定

コード例は、IP アドレスが 192.168.0.12 の In-Sight ビジョンシステムに接続しているコントローラを示しています。 In-Sight Explorer からビジョンシステムの IP アドレスを確認するには、[In-Sight ネットワーク] ツリーでビジョンシステム名を右クリックし、[プロパティ] を選択します。

.PROGRAM cognex()

;POINT FRAME1 is the part frame, where frame1 is calculated using

;the FRAME command: POINT FRAME1=FRAME(f.origin,f.x1,f.xy,f.origin)

;The coordinates are assumed to be received from the vision system in the part frame

$termchk=$CHR(13)+$CHR(10)

.ret1=-1

.ret1a=-1

.ret1a1=-1

.ret1b=-1

.ret1b1=-1

.ret1bc=-1

.ret2=-1

CALL tcp_open(10000); sock_id1 = CAMERA

IF sock_id1<0 THEN

RETURN

END

$receive=""

CALL tcp_recv(.ret1a,$receive)

IF .ret1a<0 GOTO quit

.$str = "admin"+$CHR(13)+$CHR(10)

CALL tcp_send(.ret1a1,.$str)

IF .ret1a1<0 GOTO quit

$receive = ""

CALL tcp_recv(.ret1b,$receive)

IF .ret1b<0 GOTO quit

$receive = ""

CALL tcp_recv(.ret1c,$receive)

IF .ret1c<0 GOTO quit

.$str = "GVA002"+$CHR(13)+$CHR(10)

CALL tcp_send(.ret1,.$str)

IF .ret1<0 GOTO quit

$receive = ""

CALL tcp_recv(.ret2,$receive)

IF .ret2<0 GOTO quit

$response = $receive

$ok = $DECODE($response,$termchk,0)

ok = VAL($ok)

IF ok <>1 GOTO quit

$response = $RIGHT($response,LEN($response)-4)

$response = $LEFT($response,LEN($response)-5)

$x = $DECODE($response,",",0)

x = VAL($x)

$temp = $DECODE($response,",",1)

$y = $DECODE($response,",",0)

y = VAL($y)

$temp = $DECODE($response,",",1)

o = VAL($response)

PRINT x,y,o

POINT pick = frame1 + TRANS(x,y,o)

HOME

LAPPRO pick, 100

LMOVE pick

CLAMP 1

LDEPART 100

HOME

quit:

CALL tcp_close

.END

.PROGAM tcp_close()

ret = 0

TCP_CLOSE ret,sock_id1

IF ret<0 THEN

PRINT "TCP_CLOSE error id = ",sock_id1

ELSE

PRINT "TCP_CLOSE OK id = ",sock_id1

END

.END

.PROGRAM tcp_open(.port)

tout_open = 60

ip[1] = 192

ip[2] = 168

ip[3] = 0

ip[4] = 12

port = .port

.er_count = 0

connect:

TIMER (2) = 0

TCP_CONNECT sock_id1,port,ip[1],tout_open

IF sock_id1<0 THEN

IF .er_count>=5 THEN

PRINT "Client Communication with Cognex has failed"

GOTO forgetit

ELSE

.er_count = .er_count+1

PRINT "TCP_CONNECT error id = ",sock_id1," error count = ",.er_count

GOTO connect

END

ELSE

PRINT "TCP_CONNECT OK id = ",sock_id1," with timep = ",TIMER(2)

END

forgetit:

RETURN

.END

.PROGRAM tcp_recv(.ret,$receive)

.ret = 0

.eret = -99

tout_rec = 60

max_length = 255

.$receive = ""

.num = 0

TCP_RECV .eret,sock_id1,.#recv_buff[1],.num,tout_rec,max_length

TIMER(3) = 0

IF .eret<0 THEN

PRINT "TCP_RECV error in RECV",.eret

PRINT ".num = ",.num

.ret = -1

ELSE

IF .num>0 THEN

IF .num*max_length<=255 THEN

PRINT "TCP_RECV OK in RECV",.eret

PRINT "Number of array elements = ",.num

FOR .j = 1 TO .num

.$receive = .$receive + .#recv_buf[.j]

PRINT "len(.$recv_buf[",.j,"] = ",LEN(.$recv_buf[.j])

PRINT ".$receive = ",.$receive

END

ELSE

.ret = -1

PRINT "String too long"

PRINT .$recv_buf[1]

END

ELSE

PRINT "Invalid response"

.ret = -1

END

.END

.PROGRAM tcp_send(.ret,.$data)

.$send_buf[1] = .$data

.buf_n = 1

.ret = 1

tout = 60

TCP_SEND .sret,sock_id1,.$send_buf[1],.buf_n,tout

IF .sret<0 THEN

.ret = -1

PRINT "TCP SEND error in SEND",.sret

ELSE

PRINT "TCP_SEND OK in SEND",.sret

PRINT "Sent string = ",$send_buf[1]

END

.END
Version: 5.6.0


承認の実行

ハウツー

製造環境によっては、バッチの切り替えを完了して製造の再開が許可される前に承認プロセスを実行するのが一般的です。承認プロセスの期間中、品質または製造のスーパーバイザは多くの場合に、オペレータが正しいバッチ情報を入力したことを確認 (認証のみ) したり、オペレータが以前入力したのと同一のバッチ情報を入力 (タブルブラインド) したりするよう求められます。

Authorize 関数は、これらの承認プロセスを実行するために使用できます。認証のみを実行する場合は、オペレータ (ユーザ 1) が変更を加え、スーパーバイザ (ユーザ 2) が変更内容を承認します。ダブルブラインドを実行する場合は、ユーザ 1 が変更を加え、ユーザ 2 はユーザ 1 によって加えられた変更を再入力する必要があります。承認結果は、多くの場合に監査メッセージによって追跡されます。

このトピックでは、Authorize 関数を含むスプレッドシートの設定方法、承認プロセスの実行方法、および承認を監査メッセージによって追跡する際に生成される監査メッセージの種類について説明します。

  • スプレッドシートの設定
  • 承認プロセス
  • 監査メッセージ

スプレッドシートの設定

  1. スプレッドシートが次のように設定されています。

    A2 = Authorize("Change Batch",1,1,A4,A6)

    A4 = EditInt(0,255)

    A5 = EditFloat(0,100)

    A6 = EditString(8)

  2. VisionView® アプリケーションを使用して承認を実行する場合は、サンプルジョブをカスタムビューに追加します。[カスタムビューの設定] ダイアログの [セル範囲] で、Authorize 関数のセル (A2) と参照先セル (A4、A5、および A6) を含む領域を選択します。

    注: サンプルジョブを EasyView に追加するには、Authorize 関数のセル (A2) と参照先セル (A4、A5、および A6) のシンボリックタグを挿入し、[シンボリックタグエディタ] ダイアログで各シンボリックタグの [EasyView] チェックボックスをオンにします。

  3. 承認の結果が監査メッセージによって追跡される場合は、Authorize 関数のセル (A2) のシンボリックタグを挿入して、[シンボリックタグエディタ] ダイアログでそのシンボリックタグの [監査メッセージ] チェックボックスをオンにします。続いて、[監査メッセージの設定] ダイアログで [監査メッセージを有効にする] チェックボックスと [タグ付きセル変更時] チェックボックスをオンにし、必要に応じてダイアログ内のその他の設定値を設定します。

  4. 参照先セル (A4、A5、および A6) には、値が承認されているかどうかに関係なく、オペレータが最後に入力した値が表示されます。必要に応じて、GetAuthorizedValue 関数を使用して、最後に承認された値をスプレッドシートで表示することができます。例えば、参照先セル (A4、A5、および A6) の最後に承認された値を表示するには、スプレッドシートを次のように設定します。

    C4 = GetAuthorizedValue(A4)

    C5 = GetAuthorizedValue(A5)

    C6 = GetAuthorizedValue(A6)

    注:

    • GetAuthorizedValue 関数は常に文字列タイプの値を返します。この関数の数値出力を別の関数への入力として使用するには、Value 関数を使用して文字列を数値に変換します。

    • GetAuthorizeApprover および GetAuthorizeDateTime 関数を使用して、承認された値のほかに、最後に正常に実行された承認の承認者 (ユーザ 2) の名前と日時をスプレッドシートに表示することもできます。

承認プロセス

  1. ユーザ 1 は、エディットコントロールを押して、新しい値を手動で入力します。
注:
  • ユーザ 1 は、ロックアクセスレベルの場合、エディットコントロールを変更できません。
  • ユーザ 2 はユーザ 1 と異なり、十分なログオン権限 (最低限のアクセスレベルは [レベル] パラメータで定義されます) が付与されている必要があります。選択されたレベルが [なし] の場合は、同じユーザがログオンして新しい値を承認することが許可されます。

  2. すべての新しい値の入力後、ユーザ 1 は [Change Batch] ボタンを押します。[認証ログオン] ダイアログが表示されます。

注: ボタンの名前は、[ラベル] パラメータによって設定されます。

  3. ユーザ 2 は、[ユーザ名] および [パスワード] フィールドに正しいユーザ名とパスワードを入力して、In-Sight Explorer にログオンします。ユーザ 2 が正常にログオンすると、[認証] ダイアログが表示されます。[認証] ダイアログは承認の種類 (認証のみまたはダブルブラインド) によって異なります。
  • 認証のみを実行している場合は、ユーザ 1 が入力した新しい値が [Authorize] ダイアログに表示され、ユーザ 2 にはダイアログ内の値の変更は許可されません (すべてのエディットコントロールが無効になります)。ユーザ 2 が、新しい値が正しいと判断し、[Authorize] ボタンをクリックすると、変更は承認されます。ユーザ 2 が、新しい値は誤りであると判断し、[キャンセル] をクリックした場合、変更は承認されません。

  • ダブルブラインドを実行している場合は、ユーザ 1 が入力した新しい値は [Authorize] ダイアログ内で非表示となり (最後に承認された値が表示されます)、Authorize 関数によってサポートされていないエディットコントロールはすべて無効になります。ユーザ 2 は、エディットコントロールを押して、新しい値を手動で再入力します。すべての新しい値を入力後、ユーザ 2 が [Authorize] ボタンをクリックすると、変更が承認されます。ユーザ 2 が [キャンセル] をクリックすると、変更は承認されません。

注: ユーザ 2 が誤った値を 1 つ以上入力し、承認に失敗した場合は、[認証] ダイアログが再度表示されます。この場合は、ユーザ 2 が入力した値がダイアログに表示されます。ユーザ 2 は、ダブルブラインド承認を再試行する場合は、正常な承認を得るためにユーザ 1 の値を再入力する必要があります。

  4. [Authorize] ボタンをクリックすると、承認の結果を監査メッセージで追跡している場合には監査メッセージが生成されます (オプション)。
  5. 正常に承認されると、GetAuthorizedValue 関数によって返された値が更新され、最後に承認された値が表示されます (オプション)。

監査メッセージ

監査メッセージの種類は、承認の種類と承認の結果 (成功または失敗) によって異なります。[キャンセル] を押すと、監査メッセージは生成されません。

認証のみ

ユーザ 2 が [Authorize] ダイアログで [Authorize] ボタンを押すと、次のそれぞれについて監査メッセージが生成されます。

  • ユーザ 1 による変更。監査メッセージには、ユーザ 1 の名前、エディットコントロールのシンボリックタグ、コントロールの古い値、およびコントロールの新しい値が含まれています。
  • 成功ステータスとユーザ 2 の名前。

注: 認証のみが選択されており、ユーザ 2 が [認証] ボタンをクリックする場合、承認は常に成功します。

ダブルブラインド

ユーザ 2 が [Authorize] ダイアログで [Authorize] ボタンを押すと、次のそれぞれについて監査メッセージが生成されます。

承認が成功した場合:

  • ユーザ 1 による変更。監査メッセージには、ユーザ 1 の名前、エディットコントロールのシンボリックタグ、コントロールの古い値、およびコントロールの新しい値が含まれています。
  • 成功ステータスとユーザ 2 の名前。

承認が失敗した場合:

  • 失敗ステータスとユーザ 2 の名前。

なし

承認の種類として [なし] が選択されている場合、承認は実行されません。ただし、ユーザがラベル付きプッシュボタン (サンプルジョブの [Change Batch] ボタン) を押すと、次のそれぞれについて監査メッセージが生成されます。

  • ユーザによって加えられた変更。監査メッセージには、ユーザの名前、エディットコントロールのシンボリックタグ、コントロールの古い値、およびコントロールの新しい値が含まれます。
  • 成功ステータスとユーザの名前。

注: [なし] が選択されており、ラベル付きボタンが押された場合は、常に成功ステータスが生成されます。


NodeLock 関数を使用した In-Sight ジョブの保護

In-Sight 関数リファレンス

このトピックでは、ネットワークに接続された指定の In-Sight システムでのみ実行されるようにジョブを制限する方法と、無許可のユーザが NodeLock スプレッドシート関数を使用してジョブを変更できないようにする方法について説明します。NodeLock 関数では、In-Sight ファームウェアバージョン 2.10 以降を使用して、ジョブファイルの暗号化と圧縮も実行されます。この関数は、スプレッドシートビューへのアクセス権が付与されているビジョンシステムでのみ使用できます。

警告: NodeLock 関数を有効にする前に、別のファイル名でジョブのバックアップコピーを作成してください。NodeLock 関数が有効になると、ジョブを編集できなくなります。

特定の MAC アドレスが指定されている NodeLock 関数がスプレッドシートに挿入されている場合、そのジョブは必要に応じて何度でも保存することができますが、([開く] ダイアログから) 一度ロードすると編集できなくなります。NodeLock 関数がプレースホルダとして必要な場合は、MAC アドレスを指定せずに (null 文字列で) 関数を挿入してください。例えば、「NodeLock("")」と指定します。ジョブを保護する準備ができたら、有効な MAC アドレスを追加します。また、2 番目の NodeLock 関数を MAC アドレスなしで挿入して、NodeLock 関数を一時的に無効にすることもできます。ジョブを保護する準備ができたら、スプレッドシートから 2 番目の NodeLock 関数を削除します。

NodeLock 関数をスプレッドシートに挿入するには:

  1. スプレッドシートビューを開いている間に、関数を挿入する空のセルをハイライト表示します。

  2. 空のセルに「nodelock」と入力し、続いて開き括弧、二重引用符で囲んだシステムの MAC アドレス、および閉じ括弧の順に入力して数式を完成させます。数式の形式は、nodelock("MAC アドレス") となります。次に例を示します。

    注: MAC アドレスの形式には 12 個の 16 進数文字による文字列が含まれています。

    複数の MAC アドレスを関数に入力することができます。各 MAC アドレスを二重引用符で囲み、コンマで区切ってください。次に例を示します。

    注: NodeLock() 関数は、MAC アドレスの形式が正しい場合にはスプレッドシートに「1」を返し、形式に誤りがあるか空 (null 文字列) の場合には「＃ERR」を返します。

    警告: NodeLock 関数で指定されている MAC アドレスの中に使用している In-Sight システム上の MAC アドレスが含まれていない場合、そのジョブは実行されず、システムにロードしても編集することはできません。

NodeLock 関数は、有効な場合、ユーザ名に設定されているアクセス許可に関係なく、強制的にジョブがプロテクトモードで実行されるようにします。オペレータ I/F 関数を使用して数式に入力される値は、ジョブと一緒に保存できます。
Version: 5.6.0


画像歪みを補正するための画像のキャリブレーションと変換

ハウツー

In-Sight ビジョンシステムは、設置環境によって、レンズなど特定の設定条件によって引き起こされた歪みや遠近歪みを含む画像を取り込むことがあります。レンズによっては、樽型歪みまたは糸巻型歪みのパターンが生成される場合があり、これによって、実世界の直線が画像内では曲線に見えてしまうことがあります。遠近歪みは、In-Sight ビジョンシステムを検査領域に対して垂直に取り付けることができない場合に生じます。このような状況では、画像内の特徴が、視野内の位置に応じて引き延ばされたように表示され、不正確な結果となることがあります。

In-Sight ビジョンシステムには、これらの非線形歪みおよび遠近歪みを補正するためのキャリブレーション関数のセットが用意されています。

キャリブレーション関数を使用して、次の 2 つの目的のために In-Sight ビジョンシステムの光学系を「キャリブレーション」することができます。

  • In-Sight ビジョンシステムにより、(画像を「変換する」ことによって) 光学歪みを補正し、非常に正確な計測値を返す。
  • In-Sight ビジョンシステムが、ピクセル単位を、ミリメートルやインチなどの実世界の測定単位に変換する。

In-Sight ビジョンシステムをキャリブレーションすることにより、画像の周辺部にある対象物をより正確に検出し、In-Sight ビジョンシステムを検査面に対して最大 45 度の角度で取り付けることができるなど、設置の自由度を高めることができます。

例の概要

このトピックでは、レンズ歪みと遠近歪みを補正するために、CalibrateGrid 関数と TransformImage 関数を使用して画像をキャリブレーションおよび変換する方法を示します。また、この例では、キャリブレーションされて変換された出力を参照して、ほかの In-Sight ビジョンツール関数、特に TrainPatMaxPattern、FindPatMaxPatterns、および FindCircle の各関数のパフォーマンスを最適化する方法も示します。

アプリケーション

ロボットによるピックアンドプレース操作のために、ガスケットの形状をパターンとして使用して、視野内のガスケットを検出します。部品を検出し、その位置をミリメートル単位で報告した後、ガスケットの最大の穴の半径をミリメートル単位で計測し、部品が指定された公差内であることを確認します。設置環境の物理条件によって、In-Sight ビジョンシステムは検査面に対して 30 度の角度で取り付ける必要があり、これによって遠近歪みが生じています。

このアプリケーションでは、次のステップを実行します。

  1. サンプルアプリケーションと画像をロードする
  2. 画像をキャリブレーションする
  3. 画像を変換する
  4. ビジョンツールを設定し結果を変換する
  5. アプリケーションをテストする

サンプルアプリケーションと画像をロードする

実際のアプリケーションでは、In-Sight ビジョンシステムを取り付け、接続し、部品または対象物の画像を取り込む必要があります。この例の目的に合わせて、このアプリケーションをシミュレートするためのサンプルのジョブと画像を示します。

開始するには、サンプルキャリブレーションジョブとそれに対応する画像をロードする必要があります。

  1. ローカルエミュレータまたは In-Sight ビジョンシステムにログオンします。
  2. [ファイル] メニューから [ジョブを開く] を選択し、[開く] ダイアログから、In-Sight Explorer スプレッドシートの [Sample Jobs] ディレクトリの [Calibration] フォルダ (Windows 7/Windows 10 の場合: C:\Users\Public\Public Documents\Cognex\In-Sight\In-Sight Explorer x.x.x\Sample Jobs\Spreadsheet\Calibration) に移動して、[CalibGrid_TransformImage.job] ファイルを選択します。
  3. ジョブをロードしたら、対応するサンプル画像をロードする必要があります。[画像] メニューから [記録/再生のオプション] を選択します。
  4. [記録/再生のオプション] ダイアログは、自動的に [再生] タブが表示された状態で開きます。表示されていない場合は、[再生] タブをクリックします。
  5. [再生フォルダ] セクションで [参照] ボタンをクリックし、[フォルダの参照] ダイアログを表示します。[Sample Jobs] → [Spreadsheet] ディレクトリに移動し、[Calibration] フォルダを選択します。[OK] ボタンをクリックして続行します。
  6. [再生フォルダ] には指定したディレクトリが表示されます。[画像カウント] はこのディレクトリに保存されている画像の数を示しています。[記録/再生のオプション] ダイアログの [OK] ボタンをクリックして、続行します。

画像をキャリブレーションする

In-Sight ビジョンシステムにおいて、キャリブレーションとは、画像領域を「マッピング」して、画像内の特徴と、既知の実世界の測定単位との関係を確立することです。このプロセスでは、線形および非線形の歪みを補正し、画像のピクセル単位と実世界の測定単位との間の 2D 変換を生成します。

In-Sight ビジョンシステムでのキャリブレーションに使用する関数には、Calibrate、CalibrateAdvanced、および CalibrateGrid の 3 つがあり、それぞれ精度が異なります。

注: Calibrate 関数と CalibrateAdvanced 関数は、画像内でユーザが指定した、4 点 (Calibrate の場合) または最大 9 個の点 (CalibrateAdvanced の場合) を使用し、検査対象物の実世界の計測値に関連付けます。これらの関数は、線形および非線形の歪みのみを補正します。

CalibrateGrid 関数は、ドットまたは正方形のチェッカボードによるグリッドパターン画像を取り込むことで、画像領域の「マップ」を生成します。この関数は、グリッド内で検出された特徴 (ドットまたは正方形の交点) を、ユーザが指定したグリッドパターンのグリッド間隔に関連付けます。このプロセスによって、非常に正確な計算が可能になり、それを使用して歪んだ特徴を正しい形状に変換することができます。

CalibrateGrid 関数を設定する

  1. CalibrateGrid 関数によって返された [image] データ構造体を含むセルを選択し、そのセルをダブルクリックして、[CalibrateGrid] ダイアログを開きます。
  2. [CalibrateGrid] ダイアログのナビゲーションペインで [セットアップ] をクリックし、CalibrateGrid の [セットアップ] ダイアログを開きます。[グリッドタイプ] パラメータを [フィデューシャルつきドット] に、[グリッド間隔] パラメータを [25] に、[単位] パラメータを [ミリメートル] に、さらに、[ポーズ数] パラメータを [1] に設定します。

注: 部品または対象物の検査に大きな視野が必要な場合、または画像が大幅に歪んでいる場合は、キャリブレーションの精度を高めるために、複数のポーズを使用することを検討してください。

  3. ナビゲーションペインから [ポーズ] を選択し、キャリブレーションに使用する画像を取り込みます。このアプリケーションの場合は、[画像ファイルを開く] ボタンをクリックし、[Sample Jobs] → [Spreadsheet] ディレクトリから [CalibrationGrid.bmp] ファイルをロードします。
  4. 画像がロードされると、CalibrateGrid 関数は自動的に画像を処理し、検出した特徴点の数を報告します。[キャリブレーション] ボタンをクリックして続行します。
  5. キャリブレーションデータが [image] データ構造体に取得されます。この構造体には、歪みの補正とピクセルの実世界単位への変換との両方に必要なデータが含まれ、ほかの In-Sight ビジョンツールから参照できます。

画像を変換する

次の手順では、TransformImage 関数を追加して、In-Sight ビジョンツールで参照できる歪みのない画像を生成します。CalibrateGrid 関数は、画像の「マップ」を生成するために使用される数学的計算を含む [image] データ構造体を返します。TransformImage 関数は、この [image] データ構造体を利用して、補正計算に使用する [image] データ構造を生成し、歪みのない画像を返します。

TransformImage 関数を設定する

  1. TransformImage 関数によって返された [image] データ構造体を含むセルを選択し、プロパティシートを開きます。
  2. [キャリブレーション] パラメータは、CalibrateGrid 関数によって返される [image] データ構造体への絶対セル参照として設定します。そのほかのパラメータはデフォルト設定のままにします。
  3. [OK] ボタンをクリックして、TransformImage プロパティシートを閉じます。
  4. TransformImage 関数によって返された [image] データ構造体を含むセルをシングルクリックすると、歪みのない画像が表示されます。この構造体は遠近歪みを補正し、例えば、楕円形に対して円形を生成します。
  5. TransformImage 関数が生成されると、ExtractCalibration 関数も自動的に生成され、スプレッドシートに挿入されます。ExtractCalibration 関数は、変換された画像のピクセル値と CalibrateGrid 関数に対して指定された実世界の単位とのキャリブレーションを含む [image] データ構造体を返します。

ビジョンツールを設定し結果を変換する

このアプリケーションでは、ガスケットが視野内のランダムな位置に現れることがあるため、ロボットによってピックする前に、画像内で検出してから、正しく製造されていることを確認する必要があります。これには、ガスケットの位置をミリメートル単位で返し、ガスケット内の最大の穴の半径もミリメートル単位で返す必要があります。

画像をキャリブレーションし変換する前では、ガスケットの形状と最大の穴は視野内のガスケットの位置によって異なり、結果はピクセル単位で返されます。CalibrateGrid 関数と TransformImage 関数を使用して、歪みの影響が補正され、キャリブレーションされた結果が返されました。これで In-Sight ビジョンツールは、ツールによって返される歪みのないキャリブレーション画像を参照するように設定されます。

検査の設定

ビジョンツールを設定するには、関数をインストールし、検査を実行するようにリンクする必要があります。このアプリケーションでは、画像によって視野内での対象物の位置が異なるため、フィクスチャを使用する必要があります。また、このフィクスチャは、位置データをロボットに渡すという目的でも使用します。

  • TrainPatMaxPattern 関数を設定する
  • FindPatMaxPatterns 関数を設定する
  • FindCircle 関数を設定する
  • 結果を変換する

注: In-Sight ビジョンツール間のさまざまな依存関係を表示するには、[ジョブの監査] ツールバーを使用します。

TrainPatMaxPattern 関数を設定する

TrainPatMaxPattern 関数は、FindPatMaxPatterns 関数によって参照されるモデルパターンを生成します。ガスケットの形状をモデルとして使用します。

  1. [記録/再生] ツールバーを使用して、画像 Gasket_01.bmp をロードします。
  2. TrainPatMaxPattern 関数によって返された [image] データ構造体を含むセルを選択し、プロパティシートを開きます。
  3. [画像] パラメータは、TransformImage 関数によって出力される [image] データ構造体への絶対セル参照として設定します。これにより、TrainPatMaxPattern 関数で常に歪みのない画像が参照されるようになります。
  4. プロパティシートのツールバーで、[グラフィックスの編集] ボタンをクリックして対話型グラフィックスモードに切り替え、[パターン領域] パラメータの対象領域を調整します。ガスケットの形状を過不足なく囲むように、対象領域を設定します。領域をダブルクリックして、変更を受け入れ、対話型グラフィックスモードを終了します。
  5. [OK] ボタンをクリックして、TrainPatMaxPattern 関数のプロパティシートを閉じます。
  6. これで、モデルパターンが確立されました。

FindPatMaxPatterns 関数を設定する

FindPatMaxPatterns 関数は、TrainPatMaxPattern 関数によって確立されたモデルパターンに基づいて視野内で部品を検出するために使用します。

  1. FindPatMaxPatterns 関数によって返された [image] データ構造体を含むセルを選択し、プロパティシートを開きます。
  2. [画像] パラメータは、TransformImage 関数によって出力される [image] データ構造体への絶対セル参照として設定します。これにより、FindPatMaxPatterns 関数で常に歪みのない画像が参照されるようになります。
  3. ガスケットが画像内の任意の場所に現れるため、[サーチ領域] パラメータを、画像全体を囲むように設定します。
  4. [パターン] パラメータは、TrainPatMaxPattern 関数によって返される [image] データ構造体への絶対セル参照として設定します。
  5. ガスケットの一部が画像領域から外れる可能性があるため、[領域外の特徴] パラメータを 15 に設定します。
  6. 画像内でガスケットが回転していることがあるため、[開始角度] パラメータを [-90] に、[終了角度] パラメータを [90] に設定します。
  7. そのほかのパラメータはすべて、デフォルト設定値のままにします。
  8. [OK] ボタンをクリックして、FindPatMaxPatterns 関数のプロパティシートを閉じます。

FindCircle 関数を設定する

FindCircle 関数を使用して、ガスケット内の最大穴の半径を算定します。

  1. FindCircle 関数によって返された [image] データ構造体を含むセルを選択し、プロパティシートを開きます。
  2. [画像] パラメータは、TransformImage 関数によって出力される [image] データ構造体への絶対セル参照として設定します。これにより、FindCircle 関数で常に歪みのない画像が参照されるようになります。
  3. [フィクスチャ] パラメータは、FindPatMaxPatterns 関数の [行]、[列]、および [角度] の出力への絶対参照として設定されています。これにより、FindCircle 関数の [ドーナツ領域] が FindPatMaxPatterns 関数によって返される検出パターンに対して相対的に移動するようにしています。
  4. プロパティシートのツールバーで、[グラフィックスの編集] ボタンをクリックして対話型グラフィックスモードに切り替え、[ドーナツ領域] パラメータの対象領域を調整します。ドーナツ領域の位置をガスケットの最大の穴に合わせ、外側の半径がガスケットの最大の穴より多少大きく、内側の半径が外側の半径のおよそ半分になるように、対象領域を設定します。領域をダブルクリックして、変更を受け入れ、対話型グラフィックスモードを終了します。
  5. [極性] パラメータを [白→黒] に設定します。ドーナツ領域では、サーチ領域が内側の半径から外側の半径へ向かって検査され、ガスケットは「黒」、背景は「白」になります。エッジ極性を指定すると、検索が高速になります。
  6. サーチ速度を上げるため、[検出する基準] パラメータを [最大円] に設定します。
  7. そのほかのパラメータはすべて、デフォルト設定値のままにします。
  8. [OK] ボタンをクリックして、FindCircle 関数のプロパティシートを閉じます。

結果を変換する

FindPatMaxPatterns 関数と FindCircle 関数はどちらも、結果をピクセル単位で返しますが、ロボットと検査にはミリメートル単位の結果が必要です。さらに、ガスケットは視野内のランダムな位置や向きで現れる可能性があるため、フィクスチャを使用して、In-Sight ビジョンツールのサーチ領域を画像内で正確に位置決めする必要があり、そのため結果をピクセル単位で返す必要があります。

例えば、FindCircle 関数では FindPatMaxPatterns の出力がピクセル単位になっている必要があります。FindPatMaxPatterns 関数によって返された [行]、[列]、[角度] の値は、FindCircle 関数でフィクスチャの入力として使用され、画像内の対象領域 (ROI) の位置を示します。

これを解決するため、TransPatternsToWorld 関数と TransEdgesToWorld 関数を使用して、FindPatMatPatterns 関数と FindCircle 関数のピクセル単位の結果を実世界の単位であるミリメートルに変換します。これによって、TransPatternsToWorld 関数と TransEdgesToWorld 関数によって返された値が出力され、FindCircle 関数は引き続き FindPatMaxPatterns 関数によって返されたピクセル値をフィクスチャとして使用できます。

注: フィクスチャが不要な場合は、CalibrateImage 関数を使用して、ツールのピクセル単位の結果を実世界の単位に変換できます。

TransPatternsToWorld 関数を設定する

TransPatternsToWorld 関数は、FindPatMaxPatterns 関数によって返されたピクセル単位の結果を実世界の測定単位に変換します。

  1. TransPatternsToWorld 関数によって返された [image] データ構造体を含むセルを選択し、プロパティシートを開きます。
  2. [キャリブ] パラメータは、ExtractCalibration 関数によって返される [image] データ構造体に含まれるキャリブレーションデータへの絶対セル参照として設定します。ExtractCalibration 関数には、変換された画像のピクセル単位と CalibrateGrid 関数で指定された実際の単位との間のキャリブレーションが含まれています。
  3. [パターン] パラメータは、FindPatMaxPatterns 関数によって返される [image] データ構造体への絶対セル参照として設定します。
  4. [変換する数] パラメータはデフォルト設定のままにします。
  5. [OK] ボタンをクリックして、TransPatternsToWorld 関数のプロパティシートを閉じます。
  6. これで、TransPatternsToWorld 関数によって返される結果は、実世界の単位、この場合はミリメートルで表示されます。

TransEdgesToWorld 関数を設定する

TransEdgesToWorld 関数は、FindCircle 関数によって返されるピクセル単位の結果を実世界の測定単位に変換します。

  1. TransEdgesToWorld 関数によって返された [image] データ構造体を含むセルを選択し、プロパティシートを開きます。
  2. [キャリブ] パラメータは、ExtractCalibration 関数によって返される [image] データ構造体に含まれるキャリブレーションデータへの絶対セル参照として設定します。ExtractCalibration 関数には、変換された画像のピクセル単位と CalibrateGrid 関数で指定された実際の単位との間のキャリブレーションが含まれています。
  3. [エッジ] パラメータは、FindCircle 関数によって返される [image] データ構造体への絶対参照として設定します。
  4. [変換する数] パラメータを [1] に設定します。
  5. [OK] ボタンをクリックして、TransEdgesToWorld 関数のプロパティシートを閉じます。
  6. これで、TransEdgesToWorld 関数によって返される結果は、実世界の単位、この場合はミリメートルで表示されます。

アプリケーションをテストする

遠近歪みの影響についての理解を深めるため、TrainPatMaxPattern 関数、FindPatMaxPatterns 関数、および FindCircle 関数を開き、それぞれの [画像] パラメータを [A0] に設定して、修正されていない画像を表示します。

次に、TrainPatMaxPattern 関数のモデルパターンを歪んだ画像に対して調整します。

その後、[記録/再生] ツールバーを使用して、画像を順に表示し、パターン検出とガスケットの穴のサイズ測定が困難であることを確認します。

最後に、それぞれの関数の [画像] パラメータを TransformImage 関数によって返された [image] データ構造体に設定し直し、ツールが各画像に対して正常に実行されることを確認します。

検査結果の例

次の表に、遠近歪みの補正における CalibrateImage 関数と TransformImage 関数の効果を示します。

検査結果 | 歪んだ画像 | 歪みのない画像
Gasket_00.bmp (登録パターン画像)
パターンの得点 | 99.997 | 99.997
半径 (ミリメートル) | 16.666 | 20.573
Gasket_01.bmp
 | 57.27 | 99.954
 | 18.109 | 20.694
Gasket_02.bmp
 | 54.576 | 99.954
 | 18.302 | 20.723
Gasket_03.bmp
 | 0 | 99.997
 | #ERR | 20.765
Gasket_04.bmp
 | 86.539 | 99.912
 | 17.615 | 20.641
Gasket_05.bmp
 | 66.928 | 99.997
 | 18.047 | 20.669
Gasket_06.bmp
 | 0 | 98.815
 | #ERR | 20.507
Gasket_07.bmp
 | 57.133 | 99.826
 | 18.267 | 20.770
Gasket_08.bmp
 | 0 | 98.070
 | #ERR | 20.633
Gasket_09.bmp
 | 0 | 99.933
 | #ERR | 20.777
平均半径 (ミリメートル) | 17.834 | 20.664
標準偏差 | 0.622 | 0.089

関連項目

  • CalibrateGrid 関数
  • TransformImage 関数
  • TrainPatMaxPattern 関数
  • FindPatMaxPatterns 関数
  • FindCircle 関数
  • TransPatternsToWorld 関数
  • TransEdgesToWorld 関数
Version: 5.6.0


時刻同期の設定

ハウツー

このトピックでは、IEEE 1588 (バージョン 2) 規格で定義されている CIP-Sync および PTP (Precision Time Protocol) を使用して、非決定性 Ethernet 上で In-Sight ビジョンシステムと外部デバイス (PLC など) の間でイベントを同期するように In-Sight ビジョンシステムを設定する方法について説明します。

  • In-Sight ビジョンシステムでの CIP-Sync の有効化
  • ローカルクロック情報
  • 画像取り込みのタイムスタンプを返す
  • PLC へのタイムスタンプの送信
  • EtherNet/IP を介したタイムスタンプを使用した In-Sight ビジョンシステムのトリガ
注:
  • CIP-Sync/PTP は In-Sight 7000 Gen2 シリーズのビジョンシステム、128MB の不揮発性フラッシュメモリを搭載し、ファームウェアバージョン 4.5.0 以上を実行している In-Sight 5000 シリーズビジョンシステムで使用できます。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステム、In-Sight 5705C ビジョンシステムは例外で、CIP-Sync をサポートしていません。In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-2R) は CIP-Sync/PTP をサポートしています。
  • In-Sight ビジョンシステムで CIP-Sync と PTP を有効にする前に、ビジョンシステムがインストールされている環境に事前に PTP が実装されている必要があります。
  • 時刻同期を有効にすると、ジョブ実行時間全体に 2 ～ 2.5% の処理時間が追加されます。
  • In-Sight のタイムスタンプの精度は、8 ナノ秒です。
  • 「Trigger at Time X」機能を使用しており、ネットワークが同じ CIP-Sync および PTP 規格で設定されている場合は、設定時刻の ± 5 マイクロ秒以内にトリガが発生します。それ以外の場合、設定時刻から最長で 100 マイクロ秒以内にトリガが発生します (最悪の場合のシナリオ)。

In-Sight ビジョンシステムでの CIP-Sync の有効化

  1. [センサ] メニューから、[日付/時刻の設定] を選択し、[日付/時刻の設定] ダイアログを起動します。

  2. [時刻同期] セクションで [時刻同期を使用する] チェックボックスをオンにします。
  3. ビジョンシステムの電源を入れ直して、PTP の使用を開始し、ビジョンシステムの日付と時刻の設定をマスタと同期します。
  4. [同期の詳細設定] ボタンを選択して、PTP スタックの現在のステータスに関する情報を表示します。

ローカルクロック情報

グランドマスタクロック (マスタシステムの時刻) に大きな変化があった場合でも、In-Sight ビジョンシステムが継続して適切に動作するようにするため、ローカルクロックは 100ns 分解能の常時稼働 64 ビット自走タイマとして実装されます。オフセットは、ローカルクロックとマスタクロックの間で維持され、PTP を介して同期化されます。PTP は、マスタクロックのチックレートと一致するように自走タイマのチックレートを調整するためにも使用されます。

ローカルクロックの現在値を返すには、Now 関数を使用します。Now 関数は、ローカルクロックの現在値と、ローカルクロックとマスタクロック間の現在のシステム時刻オフセットを取り込みます。時間・タイマデータアクセス関数を使用して、現在時刻のフィールドを返します。

画像取り込みのタイムスタンプを返す

In-Sight ビジョンシステムで、カメラトリガ入力を使用した画像取り込みがトリガされた場合は、GetExposureTimestamp 関数を使用して、画像露光の開始時間を取り込んで、返すことができます。この関数は、ほかの 時間・タイマデータアクセス関数で処理できる [image] データ構造体を返します。

PLC へのタイムスタンプの送信

PLC に送信されるデータを設定する場合は、[フォーマット出力バッファ] ダイアログを使用してデータを追加および送信できます。符号なし、4 倍精度整数値を示す「uq」フォーマット指定子を持つ 64 ビット整数のデータ型を使用します。フォーマット出力バッファは、4 倍精度整数値でタイムスタンプを PLC に送信することができます。

上記の例では、セル E10 に、GetExposureTimestamp 関数の出力を参照する GetTimeValue 関数が含まれます。セル E9 には、Now 関数を参照する GetTimeValue 関数が含まれます。セル 25 ～ 28 にはビジョンツールのデータが格納されます。

EtherNet/IP を介したタイムスタンプを使用した In-Sight ビジョンシステムのトリガ

In-Sight ビジョンシステムでは、非明示的な EtherNet/IP 接続を使用してビジョンシステムにタイムスタンプを送信することで、画像取り込みをトリガすることができます。

この設定を行うには:

  1. AcquireImage 関数の [トリガ] パラメータを [タイムスタンプ] に設定します。
  2. 8 バイトデータをトリガタイムスタンプとして解釈するように EtherNet/IP モジュールの入力アセンブリを設定します。その設定を行うには、SetSystemConfig 関数を使用して、システム構成変数「EIP.TriggerTimestampInputOffset」を、PLC からタイムスタンプが書き込まれることになるユーザデータフィールドのオフセットに設定します。例えば、次の関数を In-Sight ジョブファイルに追加すると、トリガタイムスタンプフィールドがユーザデータフィールドの最初の 8 バイトとして有効になります。
    • SetSystemConfig("EIP.TriggerTimestampInputOffset", 0)

トリガ設定を無効にするには、変数を 0 ～ -1 の値に設定します。

注:

  • タイムスタンプは最初の 8 バイトを占有し、時刻のオフセットは 2 番目の 8 バイトを占有し、スプレッドシート用の任意のユーザデータは時刻のオフセットの後に続きます。

EtherNet/IP を使用して PLC から新しいタイムスタンプを受け取ると、In-Sight ビジョンシステムは、そのタイムスタンプによってトリガされた後に画像を取り込みます。タイムスタンプが過去のものである場合、すなわち到達すべきときより 1 時間以上前の場合は、TimeTriggerFault が発行され、「EIP.TriggerTimstampFaults」カウントがインクリメントされます。


Web HMI の設定

方法

このトピックでは、Web ブラウザで Web HMI アプリケーションを設定して開く方法を説明します。

  1. In-Sight Explorer を起動して、ビジョンシステムまたはセンサに接続します。

  2. [センサ] メニューで、[HMI の設定] を選択します。

    1. Web HMI サーバを有効にするには、[サーバの有効化] チェックボックスをオンにします。

    2. デフォルト値と異なる場合には、[HMI の設定] ダイアログでその他の設定を指定します。

      注: 詳細については、[HMI の設定] ダイアログのトピックを参照してください。

    3. [OK] をクリックしてダイアログを閉じます。

      注: HMI の設定を有効にするには、ビジョンシステムまたはセンサを再起動する必要があります。

  3. 必要に応じて、In-Sight Explorer 内で EasyView を作成し、ボタン、チェックボックス、ツールの結果、Web HMI への対話型グラフィックコントロールを追加し、ユーザが直接 Web HMI からジョブに対して簡単な変更を加えることができるようにします。

    • スプレッドシートビューで EasyView を作成する

    • EasyBuilder ビューで EasyView を作成する

      詳細については、EasyBuilder のヘルプファイルで「EasyView の設定」のトピックを参照してください。

  4. Web HMI アプリケーションのビューを設定します。Web HMI アプリケーションに表示されるビューと、Web HMI アプリケーションで [表示切り替え] をクリックしたときのビューの順序をカスタマイズできます。

    1. [編集] メニューで、[HMI ビューの選択] を選択します。

    2. Web HMI アプリケーションで表示する [ビュー] を選択します。

    3. [上へ] または [下へ] ボタンを使用して、[表示切り替え] ボタンが押されたときのビューの順序を指定します。Web HMI アプリケーションを開くと、[HMI ビューの選択] ダイアログのリストで最初のビューがデフォルトのビューとして表示されます。

      注:
      • Web HMI アプリケーションでは、[現在の画像と最後に FAIL した画像 (水平)]、[現在の画像と最後に FAIL した画像 (垂直)]、および [画像とグラフィックおよびカスタムビュー] の各オプションはサポートされていません。
      • [実行モード] ビューを切り換えるには、まず [HMI の設定] ダイアログで [ビュー選択の許可] オプションを有効にする必要があります。
      • [HMI ビューの選択] ダイアログに EasyView のオプションが表示されるようにするには、まず In-Sight Explorer 内で EasyView を作成し、ジョブと一緒に保存する必要があります。

  5. Web HMI アプリケーションを開きます。

    Web HMI アプリケーションを開くため、2 つのオプションが用意されています。

    オプション 1: Web アドレスを Web ブラウザに入力する

    1. Web ブラウザを開きます。サポートされる Web ブラウザ: Google Chrome™ ブラウザ、バージョン 64 以降、および Internet Explorer、バージョン 11 以降。

    2. Web ブラウザのアドレスバーに、選択したビジョンシステムまたはセンサの IP アドレスとポート番号を入力します。Web アドレスのシンタックス: http://<IP アドレス>:<ポート>/

    オプション 2: [ウェブブラウザビューを開く] オプションを使用する

    1. [In-Sight ネットワーク] ペインで、選択したビジョンシステムまたはセンサを右クリックします。

    2. [ウェブブラウザビューを開く] をクリックして、選択したビジョンシステムおよびセンサの Web HMI アプリケーションのデフォルトのブラウザを開きます。

  6. ビジョンシステムまたはセンサにログオンします。

    プロンプトが表示された場合は、ユーザ名とパスワードを入力してビジョンシステムまたはセンサにログオンします。

  7. (オプション) 標準ビュー接続で Web HMI にアクセスします。

    1 つの In-Sight ビジョンシステムまたはセンサは、標準ビュー接続では 1 つのアプリケーションにのみ接続できます。In-Sight Explorer と Web HMI アプリケーションの両方が同じビジョンシステムまたはセンサに接続されている場合、In-Sight Explorer アプリケーションは常に標準ビュー接続モードになり、Web HMI アプリケーションはロックアクセスレベルのビュー専用接続モードになります。

    標準ビュー接続の Web HMI にアクセスするには、In-Sight Explorer でビジョンシステムまたはセンサの接続を切断する必要があります。ビジョンシステムまたはセンサの接続が切断されると、Web HMI アプリケーションは自動的に標準ビュー接続モードに変更されます。

    注: ビジョンシステムまたはセンサを In-Sight Explorer から切断した後、Web HMI アプリケーションが標準ビュー接続モードに変更されるまでには、最大で 30 秒の時間がかかります。

関連項目

EasyView の設定

HMI の設定

HMI ビューの選択

ウェブブラウザビューを開く

Web HMI 表示

Version: 5.6.0


スプレッドシートセルのループの作成

ハウツー

特定のアプリケーションにおいては、1 回の画像取り込みおよびジョブ実行の間に、関数のアクションを複数回繰り返して実行することが必要になる場合があります。この手法でアプリケーションを構築すると、数百、ときには数千のスプレッドシートセルを実行することが必要になります。ただし、In-Sight ジョブでは、代わりにセルのループを使用して、スプレッドシート内のプログラミング空間を節約し、処理し易いスプレッドシートセルのブロックを作成するように構築することができます。

クロックドデータ関数 (Repeat、RepeatUntil、StoreData) は、一連のセルをグループ化して、特定の期間繰り返して実行するために使用されます。

例の概要

このトピックでは、Repeat、RepeatUntil、および StoreData 関数を使用して、ループ (指定した期間スプレッドシートセルを繰り返して実行すること) を構築する方法について説明します。また、この例では、そのほかの In-Sight ビジョンツール、特に ExtractBlobs、SortBlobs、および Caliper 関数を使用して対象となる特徴を識別し、その高さおよび幅が公差内かどうかを検査する方法についても説明します。さらに、このアプリケーションでは、検査に関する要素およびピンコネクタに関する統計データをグラフィカルに表示するカスタムビューも使用します。

アプリケーション

ピンコネクタの高さおよび幅が公差内であるかを検査します。ピンコネクタの位置を検出してその数をカウントしたら、各ピンコネクタをピクセル単位で測定して、指定した公差内にあることを確認します。セルの繰り返しループを組み込んだ場合、このジョブで必要なスプレッドシートセルは 50 個未満ですみますが、ループを組み込まない場合、同じジョブで何千ものスプレッドシートセルをプログラムする必要が生じます。

このアプリケーションでは、次の手順を実行します。

  1. サンプルアプリケーションと画像をロードする
  2. ピンコネクタをカウント、検出、および測定する
  3. ループを構築する
  4. カスタムビューを表示する

サンプルアプリケーションと画像をロードする

実際のアプリケーションでは、In-Sight ビジョンシステムを取り付け、接続し、部品または対象物の画像を取り込む必要があります。この例の目的に合わせて、このアプリケーションをシミュレートするためのサンプルのジョブと画像を示します。

開始するには、サンプルルーピングジョブとそれに対応する画像をロードする必要があります。

  1. ローカルエミュレータまたは In-Sight ビジョンシステムにログオンします。
  2. [ファイル] メニューから [ジョブを開く] を選択し、[開く] ダイアログから、In-Sight Explorer スプレッドシートの [Sample Jobs] ディレクトリの [Looping] フォルダ内の [Demo Connector Pin Inspection] フォルダ (Windows 7/Windows 10 の場合: C:\Users\Public\Public Documents\Cognex\In-Sight\In-Sight Explorer x.x.x\Sample Jobs\Spreadsheet\Looping\Demo Connector Pin Inspection) に移動し、[demo connector pin inspection.job] ファイルを選択します。
  3. ジョブをロードしたら、対応するサンプル画像をロードする必要があります。[画像] メニューから [記録/再生のオプション] を選択します。
  4. [記録/再生のオプション] ダイアログは、自動的に [再生] タブが表示された状態で開きます。表示されていない場合は、[再生] タブをクリックします。
  5. [再生フォルダ] セクションで [参照] ボタンをクリックし、[フォルダの参照] ダイアログを表示します。[Sample Jobs] → [Spreadsheet] → [Looping] ディレクトリに移動し、[Demo Connector Pin Inspection] フォルダを選択します。[OK] ボタンをクリックして続行します。
  6. [再生フォルダ] には指定したディレクトリが表示されます。[画像カウント] はこのディレクトリに保存されている画像の数を示しています。[記録/再生のオプション] ダイアログの [OK] ボタンをクリックして、続行します。

ピンコネクタをカウント、検出、および測定する

このアプリケーションの最初の手順は、ピンコネクタを識別して検出することです。これを実行するには、ブロブビジョンツール、ExtractBlobs、および SortBlobs を使用します。最初に ExtractBlobs 関数により、画像を検査して各ピンコネクタの数 (検査ごとにほぼ 204 個) と位置を判別し、次に SortBlobs 関数を使用して、各ピンコネクタの位置を、フィクスチャを基準として決定します。

ピンコネクタの数をカウントして特定したら、Caliper 関数を使用して測定を行い、各ピンコネクタの幅と高さをピクセル単位で判別します。Caliper 関数によって返されたデータを使用して、ピンコネクタが 0.500 公差内にあるかどうかを計算するためのスプレッドシートの論理を構築します。

このセクションでは、次の手順について説明します。

  1. ブロブビジョンツールを設定する
  2. 水平方向および垂直方向の Caliper エッジビジョンツールを設定する
  3. スプレッドシートの論理を構築する

ヒント: [ジョブの監査] を有効にして、ジョブ内のセルの依存関係をグラフィカルに表示します。

ブロブビジョンツールを設定する

  1. セル A6 の ExtractBlobs 関数によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、ExtractBlobs 関数のプロパティシートを開きます。
  2. [領域] パラメータを画像領域全体に設定します。これは、位置が画像間で変化し、フィクスチャが不要なためです (ブロブ解析は、高速な画像処理技術の 1 つでもあります)。
  3. [ソートする数] パラメータを [500] に設定します。ツールのパフォーマンスを向上させるには、この数値を [250] まで小さくします。
  4. パフォーマンスをさらに高めるには、[ブロブの色] パラメータを [白] に、[背景色] パラメータを [黒] に設定します。
  5. また、[最小面積] パラメータを [10] に、[最大面積] パラメータを [100] に設定します。これにより、画像に表示される余分な対象物がピンコネクタとして分類されなくなります。
  6. [OK] ボタンをクリックして、ExtractBlobs プロパティシートを閉じます。
  7. 次に、セル A7 の SortBlobs 関数によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、SortBlobs 関数のプロパティシートを開きます。
  8. [ブロブ] パラメータを、セル A6 の ExtractBlobs 関数によって返された [image] データ構造体への絶対参照として設定します。
  9. [ソートする数] パラメータを [250] に設定します。
  10. [ソート基準] パラメータを [グリッド - フィクスチャ原点からX、次にY] に設定します。
  11. [OK] ボタンをクリックして、SortBlobs プロパティシートを閉じます。

水平方向および垂直方向の Caliper エッジビジョンツールを設定する

  1. セル G13 の Caliper 関数 (Caliper 水平方向) によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、Caliper 関数のプロパティシートを開きます。
  2. [フィクスチャ] パラメータは、セル E13 と F13 への絶対参照として設定します。これらのセルは、ピンコネクタの行および列ピクセル座標の SortBlobs 関数と、ループでの位置に基づいて検査するインデックス付きピンコネクタを決定する GetLoopCount 関数による結果の出力です。
  3. [領域] パラメータを、ピンコネクタの右下の幅の周囲に設定します。
  4. [エッジモード] パラメータを [エッジペア] に設定します。つまり、最初のエッジをピンコネクタの左側に、2 番目のエッジをピンコネクタの右側に設定します。
  5. [エッジ距離] パラメータを [9] に設定します。この値は、ピンコネクタの幅の最大ピクセル距離です。
  6. [OK] ボタンをクリックして、水平方向の Caliper 関数のプロパティシートを閉じます。
  7. 次に、セル L13 の Caliper 関数 (Caliper 垂直方向) によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、Caliper 関数のプロパティシートを開きます。
  8. [フィクスチャ] パラメータもまた、セル E13 と F13 への絶対参照として設定します。これらのセルは、ピンコネクタの行および列ピクセル座標の SortBlobs 関数と、ループでの位置に基づいて検査するインデックス付きピンコネクタを決定する GetLoopCount 関数による結果の出力です。
  9. [領域] パラメータを、ピンコネクタの右下の高さの周囲に設定します。
  10. [エッジモード] パラメータを [エッジペア] に設定します。つまり、最初のエッジをピンコネクタの上部に、2 番目のエッジをピンコネクタの下部に設定します。
  11. [エッジ距離] パラメータを [8] に設定します。この値は、ピンコネクタの高さの最大ピクセル距離です。
  12. [OK] ボタンをクリックして、水平方向の Caliper 関数のプロパティシートを閉じます。

スプレッドシートの論理を構築する

  1. 各 Caliper 関数に対して GetEdgeDistance 関数を使用し、Caliper 関数によって返されたエッジペア間の距離を抽出します。
  2. InRange 関数を使用して、GetEdgeDistance 関数によって返された距離が EditInt 関数 (スプレッドシートのカスタムビューコントロールセクションで、標準の幅、高さ、および許容値を定義) で定義された範囲内にあるかどうかを計算します。
  3. Stringf 関数を使用して、浮動小数点数値が含まれているテキスト文字列を出力します。小数点以下 2 桁のみを表示します。
  4. 2 つの PlotLine 関数を使用して、Caliper 関数によって返された検出済みエッジを描画します。また、必要な場合は PlotString 関数を使用して、Stringf 関数によって出力された欠陥情報を描画します。

ループを構築する

スプレッドシートセルのループを構築する機能がない場合、204 個のピンコネクタすべてをカウント、ソート、および測定するプロセスには 408 個の Caliper 関数 (それぞれ、高さ用と幅用) と、GetRow、GetCol、および PlotLine 関数に関連付けられている 204 個の検出済みピンコネクタすべてに対して SortBlobs 関数によって返された 1 つの表を設定する必要があります。ルーピングを使用すると、スプレッドシートをプログラムするのに必要な領域が削減され、さらに構築するのに必要な時間と複雑さも削減されます。

ループの作成には、内部ループの繰り返し手順ごとのデータの格納、およびループ内に累積された検査データのグラフィカルな表示という処理が含まれています。検査時には、Caliper 関数が出力したエッジが PlotLine 関数によって描画され、必要に応じて、PlotString 関数によってエラーメッセージが生成されます。繰り返し行われる検査ごとにすべてのグラフィカルな要素を取り込むには、StoreData 関数を PlotLine および PlotString 関数と関連付け、さらにループを構築するセル内に StoreData 関数を配置します。

この例では、PlotLine 関数が検査ごとのグラフィカルなデータを StoreData 関数に出力し、StoreData 関数がその出力結果をピンコネクタごとに蓄積して格納します。StoreData 関数がない場合は、最後に検査されたピンコネクタのみが表示されます。StoreData 関数は、蓄積されたデータをループの最後で PlotData 関数に出力し、PlotData 関数がループで蓄積されたデータからグラフィックを生成します。

このセクションでは、次の手順について説明します。

  1. PlotLine、PlotString、および StoreData 関数を設定する
  2. Repeat および GetLoopCount 関数を設定する
  3. PlotData 関数を設定する

ヒント: [ジョブの監査] を有効にして、ジョブ内のセルの依存関係をグラフィカルに表示します。

PlotLine、PlotString、および StoreData 関数を設定する

  1. セル J13 の PlotLine 関数 (Caliper 水平方向) によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、PlotLine 関数のプロパティシートを開きます。
  2. [ライン] パラメータは、エッジデータアクセス関数 (GetRow および GetCol) を使用して、Caliper 関数からエッジデータを抽出し、ピンコネクタの水平方向のエッジをグラフィカルに描画するように、行座標と列座標の内側で動的引数を使用して構築されています。
  3. 同様に、かなりシンプルですが、[カラー] パラメータも動的引数によって構築されています。このパラメータの引数は、セル I13 への結果出力 (Caliper 関数の結果に応じて 0 (エッジなし) と 1 (エッジあり) に変化します) を使用して、表示されている色が赤であるか緑であるかを判別します。
  4. [表示] パラメータはセル J1 への絶対セル参照であり、セル J1 はカスタムビューに線を表示するかどうかを制御する CheckBox 関数です。
  5. 水平方向および垂直方向の Caliper に対する追加の PlotLine および PlotString 関数はそれぞれ、同じ方法で構築されます。
  6. セル K13 の StoreData 関数 (Caliper 水平方向) によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、StoreData 関数のプロパティシートを開きます。
  7. [イベント] パラメータは、セル A0 (AcquireImage 関数が含まれている) の [image] データ構造体への絶対セル参照です。この関数は、画像が取り込まれるたびに実行されます。
  8. [データ] パラメータは、セル J13 の PlotLine 関数によって返された [image] データ構造体へのセル参照であり、StoreData 関数は、ループの実行時に PlotLine 関数によって出力されたグラフィカルな表示データをすべて取り込みます。
  9. [ステップ数] パラメータは、セル D6 内の GetNFound ブロブデータアクセス関数への絶対セル参照であり、この関数は ExtractBlobs 関数で検出されたブロブの総数を抽出します。この数値により、StoreData 関数がデータを蓄積する回数が決定されます。
  10. 水平方向および垂直方向の Caliper に対する追加の StoreData 関数はそれぞれ、同じ方法で構築されます。
  11. 最後に、セル R13 の PlotCircle 関数によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、PlotCircle 関数のプロパティシートを開きます。この関数は、不合格のピンコネクタの上に円を描画するのに使用されます。
  12. [円] パラメータは、2 つのエッジデータアクセス関数 (GetRow および GetCol) を使用して、Caliper 関数からエッジデータを抽出して 2 で除算し、描画される円の行/列座標を推定する (必要な場合) ように、行および列座標の内側で動的引数を使用して構築されています。
  13. [表示] パラメータは、2 つの数値演算関数を利用する動的引数を使用して、円を描画するかどうかを決定します。
  14. セル S13 の StoreData 関数によって返された [image] データ構造体を選択します。この StoreData 関数はセル R13 の PlotCircle 関数によって出力されたデータを取り込むように設定されます。

Repeat および GetLoopCount 関数を設定する

  1. セル B13 の Repeat 関数によって返された [image] データ構造体を選択します。Repeat 関数は、セルまたは [ジョブの編集] ツールバーの数式バー上で直接設定されます。 データ構造体を選択すると、Repeat 関数の数式が [ジョブの編集] ツールバーの数式バーに表示されます。
  2. [イベント] パラメータは、セル A0 (AcquireImage 関数が含まれている) の [image] データ構造体への絶対セル参照です。この関数は、画像が取り込まれるたびに実行されます。
  3. [繰り返しする反復] パラメータは、セル D6 内の GetNFound ブロブデータアクセス関数への絶対セル参照であり、この関数は ExtractBlobs 関数で検出されたブロブの総数を抽出します。この数値により、関数を実行する回数が決定されます。
  4. [繰り返しするセル] パラメータは、D13 ～ S15 のセルをカプセル化するように設定されます。
  5. セル D13 に含まれている GetLoopCount 関数を選択します。この関数はループのカウントを保持して、インデックスを付けられたどのピンコネクタが検査されているのかを判別します。
  6. セル E13 (GetRow)　および F13 (GetCol)　の「ブロブの結果」出力結果は、位置に関して SortBlobs 関数を、インデックスに関して GetLoopCount 関数を参照するように構築されます。

PlotData 関数を設定する

  1. セル A19 の PlotData 関数によって返された [image] データ構造体を選択し、そのセルをダブルクリックして、PlotData 関数のプロパティシートを開きます。
  2. [データ] パラメータを、セル K13 の StoreData 関数によって返された [image] データ構造体への相対参照として設定します。PlotData 関数は、StoreData 関数に格納されているデータに基づいてグラフィカルな表示を生成します。
  3. ループに含まれている各 StoreData 関数は、関連する PlotData 関数を使用して、ループ時に蓄積されたグラフィックを描画します。

カスタムビューを表示する

カスタムビューの表示は、ジョブ実行時のオペレータとの対話用に作成されます。オペレータは、場合によってはこの機能を使用して、標準の幅または高さの値、許容値、および特定の結果を描画または表示するかどうかを調整することができます。

また、オペレータはコントロール関数 (EditInt や CheckBox 関数など) を使用して、実行時に簡単にジョブと対話することができます。

このセクションでは、次の手順について説明します。

  1. カスタムビューでコントロールを設定する
  2. カスタムビューの表示を設定する

ヒント: [ジョブの監査] を有効にして、ジョブ内のセルの依存関係をグラフィカルに表示します。

カスタムビューでコントロール関数を設定する

  1. セル G1 で EditInt 関数を選択します。
  2. この EditInt 関数とセル G2、H1、および H2 の EditInt 関数は、セル I13 および N13 の InRange 入力パラメータとして使用されます。これらのコントロール関数は、GetEdgeDistance 関数によって返された距離が公差内であるかどうかを計算します。
  3. セル J1 で CheckBox 関数を選択します。
  4. この CheckBox 関数は、セル J13 および J14 の PlotLine の入力パラメータとして使用されます。このコントロール関数は、Caliper 関数の水平方向の結果を表示するかどうかを決定します。
  5. セル J2 で CheckBox 関数を選択します。
  6. この CheckBox 関数は、セル O13 と O14 の PlotLine の入力パラメータとして使用されます。このコントロール関数は、Caliper 関数の垂直方向の結果を表示するかどうかを決定します。
  7. セル N1 で CheckBox 関数を選択します。
  8. この CheckBox 関数は、セル R13 の PlotCircle の入力パラメータとして使用されます。このコントロール関数は、欠陥のあるピンコネクタの上に赤色の円を表示するかどうかを決定します。
  9. セル N2 で CheckBox 関数を選択します。
  10. この CheckBox 関数は、セル J15 および O15 の PlotString の入力パラメータとして使用されます。このコントロール関数は、Caliper 関数の値を数値テキスト文字列として表示するかどうかを決定します。

カスタムビューの表示を設定する

  1. [編集] メニューから、[カスタムビューの設定] を選択します。これにより、[カスタムビューの設定] ダイアログが表示されます。
  2. 「カスタムビューでコントロール関数を設定する」のセクションの説明に従って、コントロール関数を囲むように [セルの範囲] を定義します。
  3. [移動/サイズ変更] ボタンをクリックして対話型グラフィックモードに移行し、画像内でコントロール関数を配置する場所を決定します。
  4. [OK] ボタンをクリックして、[カスタムビューの設定] ダイアログを閉じます。
  5. [表示] メニューから [カスタムビュー] を選択し、カスタムビューのユーザインタフェースを表示します。これは、ジョブ実行時にオペレータが対話に使用するユーザインタフェースです。
  6. 実行時をシミュレートするには、[記録/再生] ツールバーから [再生] ボタンをクリックします。これにより、再生フォルダ内の画像の再生が開始され、実行時のジョブの実行状態がシミュレートされます。
Version: 5.6.0


In-Sight 70xx ～ 74xx シリーズビジョンシステムでのシリアル通信の有効化

ハウツー

In-Sight 70xx ～ 74xx シリーズビジョンシステムでシリアル通信を有効にするためのオプションとして、次の 2 つが用意されています。

  • ブレークアウトケーブル
  • CIO-MICRO　または CIO-MICRO-CC I/O モジュール
注:
  • インストール手順の詳細と配線の詳細については、『In-Sight® 7000 Series Vision System Installation Manual』を参照してください。
  • ハードウェアフロー制御が必要な場合は、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用する必要があります。
  • シリアルデータを送受信するためには、ビジョンシステムがオンラインである必要があります。

オプション 1: ブレークアウトケーブル

In-Sight 70xx ～ 74xx シリーズのビジョンシステムは、ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンを使用してシリアルデバイスに直接接続することができます。ビジョンシステムがブレークアウトケーブルに接続されている場合 (I/O モジュールには接続されていない)、ビジョンシステムでは、ディスクリートとシリアルの間で双方向の入力と出力を行うことができます。

  • 入力 Line 1 は、[シリアル受信] または汎用入力として設定することができます。
  • 出力 Line 1 は、[シリアル送信] または高速出力として設定することができます。
注:
  • 入力 Line 1 が汎用入力として設定されているか、または出力 Line 1 が高速出力として設定されている場合、[シリアルポートの設定] ダイアログのコントロールは有効なままになります。シリアルポートがアクティブではないことを示す視覚的な表示はありません。
  • 入力 Line 1 で [シリアル受信] が選択されている場合には、出力 Line 1 で自動的に [シリアル送信] が選択され、その逆の場合も同様に動作します。さらに、入力 Line 1 に対してそのほかの入力タイプが選択されている場合、この Line は汎用入力として設定され、出力 Line 1 はこの Line に対するデフォルトの出力タイプを使用して、自動的に高速出力に再設定されます。逆の場合も同様です。

以下の手順では、次のことを前提としています。

  • ビジョンシステムが適切にインストールされている。
  • ビジョンシステムにブレークアウトケーブルが接続されている。
  • ブレークアウトケーブルがシリアルデバイスに接続されている。

  • I/O モジュールには接続されていない。

    注:インストール手順の詳細と配線の詳細については、『In-Sight® 7000 Series Vision System Installation Manual』を参照してください。

EasyBuilder ビュー

  1. In-Sight Explorer を起動して、ビジョンシステムにログオンします。
  2. [入力/出力] アプリケーションステップに移動します。
    1. 接続済みモジュールとして直接接続 I/O がリストされていることを確認します。リストされていない場合は、[I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、直接接続 I/O に接続します。
    2. Line 1 に対して、[エッジタイプ] ドロップダウンリストから [シリアル受信] を選択します。
  3. [入力/出力] アプリケーションステップに移動します。
    1. Output Line 1 について、指定した信号タイプとして [シリアル送信] が選択されていることを確認します。
  4. [通信] アプリケーションステップに移動します。
    1. 新しいデバイスを追加する場合は、[デバイスの追加] ボタンをクリックし、デバイスの設定を行います。既存のデバイスを編集する場合は、[通信] グループボックスでそのデバイスをハイライトして [デバイスの編集] ボタンをクリックします。
    2. [シリアルポートの設定] タブを選択して、シリアル通信を設定します。

スプレッドシートビュー

  1. In-Sight Explorer を起動して、ビジョンシステムにログオンします。
  2. [センサ] メニューから、[ディスクリート I/O の設定] ダイアログを開きます。
    1. 接続済みモジュールとして直接接続 I/O がリストされていることを確認します。リストされていない場合は、[I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、直接接続 I/O に接続します。
    2. Input Line 1 について、[タイプ] ドロップダウンリストから [シリアル受信] を選択します。[OK] をクリックしてダイアログを閉じます。
    3. Output Line 1 について、指定したタイプが [シリアル送信] であることを確認します。[OK] をクリックしてダイアログを閉じます。
  3. [シリアルポートの設定] ダイアログを開き、シリアル通信の設定を行います。[OK] をクリックしてダイアログを閉じます。

オプション 2: CIO-MICRO または CIO-MICRO-CC I/O モジュール

In-Sight 70xx ～ 74xx シリーズのビジョンシステムは、ブレークアウトケーブルと、CIO-MICRO または CIO-MICRO-CC I/O モジュールとの同時接続をサポートしています。 In-Sight 70xx ～ 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように設定されている場合、ブレークアウトケーブルの RS-232 TRANSMIT ピンと RS-232 RECEIVE ピンは無効です。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

以下の手順では、次のことを前提としています。

  • ビジョンシステムが適切にインストールされている。
  • ビジョンシステムに、ブレークアウトケーブルが接続されている (電源、取り込みトリガ、および I/O の供給のみが目的)。

  • I/O モジュールの RS-232 OUT　ポート (DB9) がシリアルデバイスに接続されている。

    警告:In-Sight 70xx ～ 74xx シリーズのビジョンシステムを CIO-MICRO または CIO-MICRO-CC I/O モジュールと接続する場合、I/O モジュールの I/O ポート (DB15) と TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1、HS COMMON 端子はサポートされません。リモートデバイスからこれらの端子にリード線を接続しないでください。
    注:
    • In-Sight 70xx ～ 74xx シリーズの高速出力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
    • インストール手順の詳細と配線の詳細については、『In-Sight® 7000 Series Vision System Installation Manual』を参照してください。

EasyBuilder ビュー

  1. In-Sight Explorer を起動して、ビジョンシステムにログオンします。
  2. [通信] アプリケーションステップに移動します。
    1. 接続済みモジュールとして [CIO-MICRO]　または [CIO-MICRO-CC] がリストされていることを確認します。リストされていない場合は、[I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、適切な I/O モジュールに接続します。
    2. 新しいデバイスを追加する場合は、[デバイスの追加] ボタンをクリックし、デバイスの設定を行います。既存のデバイスを編集する場合は、[通信] グループボックスでそのデバイスをハイライトして [デバイスの編集] ボタンをクリックします。
    3. [シリアルポートの設定] タブを選択して、シリアル通信を設定します。

スプレッドシートビュー

  1. In-Sight Explorer を起動して、ビジョンシステムにログオンします。

  2. [センサ] メニューから、[シリアルポートの設定] ダイアログを開きます。
    1. 接続済みモジュールとして [CIO-MICRO]　または [CIO-MICRO-CC] がリストされていることを確認します。リストされていない場合は、[I/O モジュール] ボタンをクリックして [I/O モジュールの設定] ダイアログを開き、適切な I/O モジュールに接続します。
    2. シリアル設定を行います。[OK] をクリックしてダイアログを閉じます。

関連項目

  • [シリアルポートの設定] ダイアログ
  • [ディスクリート I/O の設定] ダイアログ
  • [I/O モジュールの設定] ダイアログ
Version: 5.6.0


CIO-WENET の接続

ハウツー

CIO-WENET I/O モジュールはイーサネット経由で In-Sight Micro 1000 シリーズのビジョンシステムに接続し、8 つのデジタル入力と 8 つのデジタル出力を提供します。工場出荷時の IP アドレス設定は 192.168.0.1 で、多くの場合、デバイスを使用できるようにするには、この設定を変更する必要があります。

注:
  • CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。
  • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。
  • 電源接続
  • IP アドレスの割り当て
  • I/O 接続

電源接続

警告: 不適切な供給電圧を使用すると、システム障害の原因となる可能性があります。

CIO-WENET への電源供給には、24V (-15%/+20%) の電源接続を使用します。この電力をほかのモジュールやデバイスへジャンパすることができます。一般的な設定では、CIO-WENET への電源供給には ACC-24I を使用します。この場合、電源から CIO-WENET 電源接続へ電力をジャンパします。

IP アドレスの割り当て

CIO-WENET は出荷時にデフォルトの IP アドレス (192.168.0.1) とサブネットマスク (255.255.0.0) が設定されています。ご使用の構成で、これらの設定が適切でない場合は、次の手順に従って、bootp サーバをインストールし、デバイスに IP アドレスを割り当てます。

  1. CIO-WENET で使用する IP アドレスを決定します。この値を記録し、安全な場所に保管します。
  2. Ethernet クロスオーバケーブルを使用して、192.168.xxx.xxx サブネットの IP アドレス (例: 192.168.0.4) を持つ PC にこのデバイスを直接接続します。192.168.0.1 は使用しないでください。
  3. 接続した PC でブラウザを開き、192.168.0.1 にアクセスします。Web ベースの Wago 管理ページが表示されます。
  4. ページの左側にあるナビゲーションリストで [TCP/IP] をクリックします。
  5. ユーザ名に「admin」、パスワードに「wago」と入力し、[OK] ボタンをクリックします。
  6. デフォルトの IP アドレスをデバイスに割り当てた IP アドレスに変更します。
  7. 必要に応じて、[サブネットマスク] を変更します。
  8. [SUBMIT] ボタンをクリックします。
  9. CIO-WENET の電源を切り、PC から切断します。
  10. 標準のイーサネットケーブルを使用して、CIO-WENET をネットワークに接続します。
  11. デバイスの電源を投入し、ネットワークに接続された PC のブラウザを使用して、このデバイスにアクセスし、Web 管理ページを表示します。

注: bootp サーバを使用して、デバイスの IP アドレスを変更することもできます。このサーバは、In-Sight Explorer 4.1.0 以上の CD-ROM に入っています。通常、bootp プロトコルは CIO-WENET では無効化されています。有効化されている場合、IP アドレスを割り当てるための bootp サーバが使用できない限り、このデバイスは電源を投入しても動作しません。bootp サーバを使用する場合は、まず、ブラウザからデバイスの Web ベースの Wago 管理ページを使用して、bootp プロトコルを有効化する必要があります。

[I/O モジュールの設定] ダイアログを使用して、In-Sight Explorer 内で使用する I/O モジュールを設定します。I/O モジュールを設定したら、必要に応じてディスクリート入力ラインおよび出力ラインを設定することができます。

I/O 接続

  • 750-403 デジタル入力モジュールは、デジタルフィールドデバイス (ビジョンシステム、スイッチなど) から制御信号を受信します。各モジュールは 2 ～ 3 導体デバイスで、モジュール 1 つにつき 4 つ (DI 1 ～ 4)、合計 8 つの入力チャネルがあります。
  • 750-504 デジタル出力モジュールは、デジタルフィールドデバイスへ制御信号を送信します。モジュール 1 つにつき 4 つ (D0 1 ～ 4)、合計 8 つの出力チャネルがあります。

関連項目

[I/O モジュールの設定] ダイアログ

[ディスクリート I/O の設定] ダイアログ

Version: 5.6.0


ローリングシャッターの操作

ハウツー

In-Sight 8405 ビジョンシステムには、画像線センサの露光を制御するための電子的なローリングシャッターが搭載されています。ビジョンシステムで画像取り込みトリガを受信すると、画像最上部の最初のピクセル行から始めて、画像最下部の最後のピクセル行に至るまで、ピクセル行が順番に露光されます。各ピクセル行は同じ時間露光されますが、各行の露光開始時刻は異なり、隣接する各行はオーバラップして露光されます。すべての行が露光されると、全画像の取り込みが完了し、ピクセル行がリセットされます。次の画像取り込みが開始されると、指定した露光時間の間、ピクセル行が再び読み出されます。

In-Sight 8405 ビジョンシステムの場合、[Row Reset (行のリセット)] 時間と [Row Readout (行の読み出し)] 時間は 36.38µ 秒です。次の数式を使用して、[Total Reset (総リセット)]、[Total Image Readout (全画像読み出し)]、[Total Runtime (総ランタイム)] を算出します。

タイミング | 数式
Total Reset (総リセット) | Row Reset (行のリセット) x (行数 -1)
Total Image Readout (全画像読み出し) | (Row Readout (行の読み出し) x 行数) + 360µ 秒
Total Runtime (総ランタイム) | 露光時間 + Total Image Readout (全画像読み出し)

注:
  • 最適な画質を確保するには、画像取り込みの間、その部分が静止している必要があります。
  • 電子的なローリングシャッター動作のため、ライブビデオモードの場合には「ローリングライン」効果を見て確認できます。

出力の設定

ビジョンシステムの高速出力は、任意で、[画像取り込み開始] または [画像取り込み終了] の信号タイプとして設定できます。[画像取り込み開始] として設定されている場合は、最初のピクセル行が露光されるときに信号がパルス出力され、[画像取り込み終了] として設定されている場合には、[Total Image Readout (全画像読み出し)] の完了時にパルス出力されます。これらの信号のパルス幅は、[出力詳細] ダイアログで指定します。

ストロボを使用する場合は、システムの HS OUT 1 ラインを [ストロボ] 信号タイプとして設定可能です。[ストロボ] として設定されている場合、[出力詳細] の　[ストロボ開始位置] は [すべての行を露光] に固定され、すべてのピクセル行が露光されると、[Strobe Width (ストロボ幅)] の期間、出力信号がパルス出力されます。

In-Sight 8405 ビジョンシステムの場合、[Row Reset (行のリセット)] 時間は 36.38µ 秒です。次の数式を使用して、[Time to Strobe Start (ストロボ開始までの時間)] と [Strobe Width (ストロボ幅)] を算出します。

タイミング | 数式
Time to Strobe Start (ストロボ開始までの時間) | (Row Reset (行のリセット) x 行数) + 946µ 秒
Strobe Width (ストロボ幅) | 露光時間 - Time to Strobe Start (ストロボ開始までの時間)

注: In-Sight 8405 でストロボを使用する場合は、露光時間を [Time to Strobe Start (ストロボ開始までの時間)] より長くし、ストロボがパルス出力されるときにすべてのピクセル行が確実に露光されるようにする必要があります。
Version: 5.6.0


PC、USB ドライブ、FTP サーバへの画像の保存

ハウツー

In-Sight® ビジョンシステムで取り込んだ画像は、いくつかの方法で PC や保存場所に保存できます。このトピックでは、必要な機能、保存される情報、保存場所、設定方法について説明することによって各方法を比較し、ご使用のアプリケーションに最適なオプションを決定できるようにします。

注: 画像を保存すると、ほかのタスクで使用できるメモリの量が減少するため、In-Sight ビジョンシステムのパフォーマンスに影響する場合があります。

  • PC、USB ドライブ、FTP サーバへの画像の保存
  • 関連項目

PC、USB ドライブ、FTP サーバへの画像の保存

In-Sight ビジョンシステムの画像は、主に 4 つの方法で保存することができます。

方法 | 必要な機能 | 保存場所 | 保存される画像
記録/再生 | - In-Sight ビジョンシステム - In-Sight Explorer - PC | PC | 画像は、自動的に振り分けて Good/Bad フォルダに保存可能です。
In-Sight Explorer センサフィルムストリップ |  |  | 画像は、[PC に保存] ボタンをクリックして保存します。
VisionView フィルムストリップ | - In-Sight ビジョンシステム - In-Sight Explorer - VisionView - USB ドライブまたは FTP サーバ | USB ドライブまたは FTP サーバ* | 画像は、[保存] ボタンをクリックして保存します。 失敗した画像は自動的に保存可能です。
WriteImageFTP 関数 | - In-Sight ビジョンシステム - In-Sight Explorer - FTP サーバ | FTP サーバ** | 画像はイベントがトリガされるときに保存されます。 また、グラフィックオーバーレイデータを含む SVG ファイルも保存可能です。
* 画像はネットワーク共有先に保存可能です。 ** In-Sight エミュレータを FTP サーバとして使用する場合、画像は PC に保存されます。

記録/再生

必要な機能

  • In-Sight Explorer が PC で実行されており、ターゲットの In-Sight ビジョンシステムに接続されている必要があります。

保存される情報

  • 画像はジョブの PASS/FAIL ステータスに基づいて自動的に振り分けられ、「Good」または「Bad」フォルダに保存されます。

保存場所

  • 画像は PC に保存されます。デフォルトフォルダの場所は、次のとおりです。

    • Windows 7/Windows 10: C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x\RecordPlayback\

    画像は、ビジョンシステムのホスト名に基づいて自動的に作成されるサブディレクトリ内に保存されます。

    注: フォルダの場所は、[記録/再生のオプション] ダイアログの [記録フォルダ] フィールドで指定できます。

設定方法

  1. [画像] メニューから、[記録/再生のオプション] ダイアログを開きます。
  2. [記録] タブをクリックして、記録の設定を行います。
  3. 成功画像と失敗画像を自動的に振り分けるには、以下のオプションを選択します。
    • [EasyBuilder ビュー]: [PASS/FAIL の振り分け] グループボックスで PASS/FAIL を振り分け (Good/Bad フォルダに記録し) ます
    • [スプレッドシートビュー]: [監視セルによる振り分け] グループボックスで値を振り分け (Good/Bad フォルダに記録し) ます

    成功画像と失敗画像が記録されると、指定した記録フォルダの場所に「Good」および「Bad」フォルダが自動的に作成されます。

  4. [画像] メニューで [記録] を選択します。これで、ビジョンシステムで取り込まれた画像は指定した記録フォルダに保存されるようになります。
ヒント: 画像は、In-Sight Explorer の PC フィルムストリップを使用して、ジョブの全体的な PASS/FAIL ステータスに基づいて自動的に振り分け、「Good」または「Bad」フォルダに保存することもできます。PC フィルムストリップの詳細については、以下のハイパーリンクをクリックしてください。
  • [EasyBuilder ビュー]: 「フィルムストリップ」のトピックの「記録の設定」および「画像の記録」のセクション。
  • [スプレッドシートビュー]: 「フィルムストリップ」のトピックの「記録/再生の設定」および「画像の記録」のセクション。

In-Sight Explorer センサフィルムストリップ

注: In-Sight Explorer には、PC フィルムストリップとセンサフィルムストリップの 2 つのフィルムストリップオプションがあります。PC フィルムストリップはシンプルな記録/再生機能ですが、センサフィルムストリップでは、画像とジョブの情報がビジョンシステムに保存されます。詳細については、フィルムストリップのトピックを参照してください。

必要な機能

  • In-Sight Explorer が PC で実行されており、ターゲットの In-Sight ビジョンシステムに接続されている必要があります。

保存される情報

  • センサフィルムストリップに表示されるすべての画像は、[PC に保存] ボタンをクリックして保存できます。
  • 画像を自動的に保存することはできません。

保存場所

  • 画像は PC に保存されます。デフォルトフォルダの場所は、次のとおりです。

    • Windows 7/Windows 10: C:\ProgramData\Cognex\In-Sight\In-Sight Explorer x.x.x\Sensor Images

    注: フォルダの場所は、[センサフィルムストリップの設定] ダイアログの [保存フォルダ] フィールドで指定できます。

設定方法

「フィルムストリップ」のトピックの以下のセクションで説明されている手順に従います。

  • [EasyBuilder ビュー]: 「センサの設定」および「ビジョンシステムから PC への画像の保存」のトピック
  • [スプレッドシートビュー]: 「センサの設定」および「ビジョンシステムから PC への画像の保存」のトピック

VisionView フィルムストリップ

必要な機能

  • VisionView アプリケーション。
  • USB ドライブまたは FTP サーバ。画像を FTP サーバに保存する場合は、画像を受信する、VisionView アプリケーションから接続可能な FTP サーバがネットワーク上で実行されている必要があります。
  • In-Sight ビジョンシステムのセンサフィルムストリップの設定を行うための In-Sight Explorer。

保存される情報

  • VisionView フィルムストリップに表示されるすべての画像は、[保存] ボタンをクリックして保存できます。
  • 検査で不合格になるか、取り込み画像が何もない場合は、フィルムストリップ画像を bitmap ファイルとして自動的に保存できます。

保存場所

  • 画像は USB ドライブか FTP サーバに保存されます。保存場所は VisionView で指定可能です。画像は、センサの表示名に基づいて自動的に作成されるサブディレクトリ内に保存されます。

    注: 表示名は VisionView で設定できます。

設定方法

VisionView でフィルムストリップを使用するには、In-Sight Explorer のセンサフィルムストリップとともに、VisionView のフィルムストリップを有効にする必要があります。

  1. In-Sight Explorer で、フィルムストリップを有効にします。

  2. In-Sight Explorer のセンサフィルムストリップの設定を行います。詳細については、「In-Sight Explorer のセンサフィルムストリップ方法」の「設定方法」セクションを参照してください。

    注: 画像の保存場所は VisionView で設定されているため、[保存フォルダ] フィールドで指定する必要はありません。

  3. VisionView の [Filmstrip Options (フィルムストリップオプション)] 画面で、要件に応じてフィルムストリップの設定を行います ([Setup Mode (設定モード)] → [Screen Layout (画面レイアウト)] → [Filmstrip Options (フィルムストリップオプション)])。
  4. [Filmstrip Options (フィルムストリップオプション)] 画面で、[編集] をクリックして [Location for Saving Images (画像の保存場所)] 画面を開きます。

  5. 画像を USB ドライブに保存する場合は、[USB ドライブ] タブを選択して USB ドライブのディレクトリを指定します。

    注: VisionView オペレータインタフェースパネル、VisionView VGA および Windows CE ベースの HMI パネルでは、古い画像に上書きされるまでに、最大 800 枚の画像を保存することができます。

  6. 画像を FTP サーバに保存する場合は、[Storage Location (保存フォルダ)] タブを選択して FTP の場所を指定します。そのサーバに必要なログオン情報も指定します。

    注: 画像はネットワーク共有先 (共有フォルダ) に保存可能です。この場合は、[Storage Location (保存フォルダ)] タブを使用して必要な設定を行います。

  7. VisionView で、ビジョンシステムに接続して画像の取り込みを開始します。失敗画像を自動的に保存するように設定されている場合は、USB ドライブ/保存フォルダに失敗画像が表示され始めます。

注: 詳細については、「VisionView ヘルプ」ファイルを参照してください。

WriteImageFTP 関数

必要な機能

  • ネットワーク経由で In-Sight ビジョンシステムからアクセス可能な FTP サーバ。

保存される情報

  • イベントがトリガされるときに、画像が FTP サーバに書き込まれます。
  • また、グラフィックオーバーレイデータを含む SVG ファイルを画像と同じディレクトリに保存可能です。

保存場所

  • WriteImageFTP 関数の Host Name パラメータで指定されている FTP サーバ。

設定方法

  1. ビジョンシステムからアクセスできるように FTP サーバを設定します。

  2. 「WriteImageFTP 関数の設定」のトピックで説明されている手順に従ってください。

    注:
    • In-Sight Explorer FTP サーバでは、ディレクトリを作成できません。[ファイル名] パラメータで既存のディレクトリを指定する必要があります。
    • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます (C:\ProgramData\Cognex\In-Sight\Emulators\x.x.x)。このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます (FTP ルートディレクトリ)。エミュレータディレクトリおよび FTP ルートディレクトリの詳細については、[オプション] ダイアログのトピック (エミュレーションパネル) を参照してください。
    • ファイルを FTP ルートディレクトリに書き込む場合、ファイル名は [オプション] ダイアログで指定した [FTP ルートディレクトリ] と完全に一致しなければなりません。画像ファイルも、FTP ルートディレクトリ内の任意のサブディレクトリに書き込むことができます (サブディレクトリはあらかじめ存在している必要があります)。例えば、FTP ルートディレクトリが C:\temp で、ファイル名が「Failed」の場合は、ファイル名を「C:\temp\Failed」と指定する必要があります。「Images」サブディレクトリに書き込む場合、ファイル名は「C:\temp\Images\Failed」となります。「Failed」とのみ指定した場合、ファイルはデフォルトのエミュレータディレクトリに書き込まれます。
    • 一般に、bitmap 形式 (BMP) で画像を保存するほうが速く処理されます。bitmap 形式の画像はサイズが大きくなりますが、圧縮の時間がかかりません。
    • EasyBuilder でも FTP サーバに画像を書き込むことができます。詳細については、「EasyBuilder ヘルプ」の「FTP を介してデータおよび画像を転送するには」のトピック ([通信] → [FTP を介して画像を転送するには]) を参照してください。

関連項目

記録/再生のオプション

フィルムストリップ

WriteImageFTP 関数

WriteImageFTP 関数の設定

Version: 5.6.0


スタートアップ時のカスタムビューのロード

ハウツー

In-Sight Explorer は、[カスタムビュー] でジョブファイルを自動的にロードし、アプリケーションの起動時に特定のユーザがログオンされるようにカスタマイズすることができます。起動時にカスタムビューを自動的にロードするには、以下の手順に従います。

注: スプレッドシートのカスタムビューは、アクセスレベルが「プロテクト」または「ロック」のユーザがセンサにログオンすると必ず表示されます。

  1. ロードするジョブファイルを指定します。

a. カスタムビューで、ジョブファイルを作成して保存します。

b. [センサ] メニューで、[スタートアップ] を選択して [スタートアップ] ダイアログを開きます。

c. [ジョブ] ドロップダウンメニューで、起動時に自動でロードするジョブファイルを選択します。

[OK] をクリックして [スタートアップ] ダイアログを閉じます。

  2. カスタムビューのデフォルトユーザを設定します。

a. [センサ] メニューで、[ユーザリスト] を選択して [ユーザリスト] ダイアログを開きます。

b. リストで、ユーザをハイライト表示します。

c. [編集] をクリックして [ユーザ] ダイアログを開きます。

d. [ログオン時にカスタムビューを表示] チェックボックスをオンにします。

e. [OK] をクリックして [ユーザ] ダイアログを閉じます。もう一度 [OK] をクリックして [ユーザリスト] ダイアログを閉じます。

  3. デフォルトのログオンユーザを設定します。

注: デフォルトのログオンユーザは、上記の [ユーザリスト] ダイアログで指定したユーザと同じにする必要があります。

a. [システム] メニューから、[オプション] ダイアログを開きます。

b. [スタートアップ] をハイライト表示して、[スタートアップ] パネルを表示します。

c. In-Sight Explorer の起動時に自動的にログオンするユーザの [ユーザ名] を入力します。

d. [スタートアップユーザ名] の [パスワード] を入力します。そのユーザにパスワードが割り当てられていない場合、[パスワード] フィールドは空白のままにしてください。


トラブルシューティング

In-Sight Explorer リファレンス

#ERR

エラーメッセージ

ファイアウォール

ネットワークのトラブルシューティング


#ERR

In-Sight Explorer トラブルシューティング

#ERR の意味

#ERR セルのトラブルシューティングの方法

#ERR を無視してエラーの拡散を止める方法

#ERR の意味

#ERR を表示するセルは、そのセルが関数を正常に実行できなかったことを示しています。一般的には、無効な入力パラメータが原因です。 #ERR 状態は、ビジョンアプリケーションの通常の操作によって発生することもあれば、スプレッドシートの論理そのものに含まれるエラーによって発生することもあり、さまざまなことが要因となります。 一般に、次の場合に #ERR が発生します。

  1. 算術演算の基本的なエラー

セル A4 = A3/A2 で、セル A2 が 0 の場合、セル A4 の関数は「ゼロによる除算」エラーを生成します。

  2. 領域グラフィックスエラー: 領域が画像の範囲外へ移動

PatFind などの位置決めツールを使用して、ほかのビジョンツールの位置をフィクスチャするとき、ビジョンツールの領域の一部が画像の範囲外に出てしまうことがあります。 この場合、ビジョンツールは、ビジョンツールの有効な結果構造体を返さずに #ERR を報告します。

  3. 「Get」関数のエラー: ビジョンツールが結果を生成しない

ExtractBlobs ツールとともに GetRow 関数を使用する場合、状況によっては、ExtractBlobs ツールで予想される数のブロブを確認できないことがあります。 このような状況で画像から目的のブロブを検出できなかった場合、GetRow 関数は #ERR を報告します。

  4. 通信エラー: データを送信できない

WriteImageFTP セルや WriteDevice セルは、スプレッドシートが実行されるたびに、データを In-Sight センサから別のコンピュータに自動的に送信します。 クライアントコンピュータで問題が発生し、データを受信できない場合、In-Sight センサの出力バッファがいっぱいになることがあります。 出力バッファのオーバフロー (データを格納できない状態) が発生すると、これらのセルは #ERR を報告します。

#ERR セルのトラブルシューティングの方法

ほとんどの #ERR 状態はエラー文字列を返します。エラー文字列が生成されている場合、#ERR を含むセルにマウスを合わせると、エラー文字列が表示されます。また、赤い感嘆符 ( [image]) がプロパティシートに表示された場合は、その赤い感嘆符にマウスを合わせるとエラー文字列が表示されます。エラー文字列をスプレッドシート上で取得するには、GetErrorString 関数を使用します。各エラー文字列には個別の診断コード番号が割り当てられています。診断コードは、GetErrorCode 関数で取得できます。最もよく返されるエラー文字列を確認するには、 Closed ここをクリックしてください。

汎用エラー文字列

診断コード | 対応する情報文字列
00000000 | システムエラーです。
00000001 | メモリ不足のため、操作を完了できません。
00000003 | 入力した引数が間違っています。
00000004 | 入力した引数は範囲外です。
00000005 | 入力した引数の型は互換性がありません。
00000009 | 前のセルでジョブがタイムアウトしたため、セルは実行されませんでした。

汎用ビジョンツールのエラー文字列

診断コード | 対応する情報文字列
00010000 | ビジョンツールエラーです。
00010001 | 無効な画像メモリです。
00010001 | 入力した領域が小さすぎます。
00010002 | 入力した領域が画像境界を超えています。

ReadIDCode 関数のエラー文字列

診断コード | 対応する情報文字列
00019000 | IDMax ビジョン処理エラーです。
04010000 | ReadCompositeCode エラーです。
04010001 | 2D コンポーネントアドレスパターンを検出できません。
04010002 | 無効な 2D コンポーネント画像データが多すぎます。
04010003 | 2D コンポーネントシンボルバージョンを検出できません。
04010004 | 欠落している 2D コンポーネントアドレスパターンを埋めることができません。
04010005 | スキャンラインが無効な画像データを検出しました。
04010006 | スキャンラインが画像境界を超えています。
04010007 | 1D コンポーネントファインダパターンを検出できません。
04010008 | 無効な 1D コンポーネント画像データが多すぎます。
04010009 | 有効なシンボルが見つかりません。
04010010 | 訂正の必要なシンボルエラーが多すぎます。
04010011 | 誤り訂正に失敗しました。
04010012 | 1D と 2D がデコード可能ですが、関連付けられていません。
04010013 | 自動コントラストしきい値計算に失敗しました。
04010014 | コントラスト感度が許容範囲を超えています。
04010015 | スキャンパラメータが許容範囲を超えています。
04020000 | ReadIDCode エラーです。
04020001 | 有効なシンボルが見つかりません。
04020002 | シンボルをデコードできませんでした。
04030001 | シンボルが検出されましたが、デコードできませんでした。
04030002 | シンボルが検出されなかったか、デコードされませんでした。
04030003 | ReadIDCode 操作がタイムアウトになりました。
04030004 | デコードを試みているときに、センサがメモリ不足になりました。
04030005 | ReadIDCode が予期せずに失敗しました。
04030006 | VerifyIDCode に無効な ReadIDCode セル参照があります。
04030007 | ReadIDCode に無効な画像セル参照があります。
04030008 | [アルゴリズム] チェックボックスが ON のときには、No-Read 診断はデータマトリックスまたは QR コードについてのみサポートされます。
04030009 | ReadIDCode プロパティシートの [アルゴリズム] チェックボックスがオンになっていません。

VerifyIDCode 関数および ValidateIDCode 関数のエラー文字列

診断コード | 対応する情報文字列
04040001 | シンボルの識別子エラー。
04040002 | パターンマッチに失敗しました。
04040003 | 無効なフィールド識別子です。
04040004 | 無効なアプリケーション識別子 (AI) です。
04040005 | 無効なデータ識別子 (DI) です。
04040006 | 無効なテキスト要素識別子 (TEI) です。
04040007 | 無効なフィールドデータです。
04040008 | 無効なフィールドセパレータです。
04040009 | データは ISO 15434 準拠ではありません。
04040010 | サポートされないフォーマットです。
04040011 | 無効なフォーマットコードです。
04040012 | ISO 15434 シンタックスは、このコードではサポートされません。
04040013 | フィールドは、このアプリケーションでは無効です。
04040014 | アプリケーションフィールドはサポートされていません。
04040015 | 無効なアプリケーションデータです。
04040016 | 複数のフォーマットが存在します。
04040017 | 重複するフィールドがあります。
04040018 | 無効な DoD UID コンストラクト #1 データです。
04040019 | 無効な DoD UID コンストラクト #2 データです。
04040020 | 無効な DoD UID データです。
04040021 | フォーマットトレーラ文字が欠落しています。
04040022 | メッセージトレーラ文字が欠落しています。

ImportData/ExportData 関数のエラー文字列

診断コード | 対応する情報文字列
05030000 | ファイル名がありません。
05030001 | ユーザ名がありません。
05030002 | ファイルタイプが .CXD ではありません。
05030003 | ファイル名が長すぎます。
05030004 | メモリ割り当てエラーです。
05030006 | ローカルフラッシュメモリがエクスポート先として指定された場合、AcquireImage を ExportData のイベントにすることはできません。
05030007 | サポートされないデータタイプです。
05030008 | データがファイルにありません。
05030009 | データ解析エラーです。
05030010 | サポートされないデータタイプです。
05030011 | ファイル操作エラーです。

PatMax の情報およびエラー文字列

診断コード | 対応する情報文字列
07010000 | パターンに含まれるマッチ特徴が少なすぎることがあります。
07010001 | 特徴の粒度を自動的に設定するのは困難です。
07010100 | 手動で [粒度] を設定してください。登録画像の表示がぼやけているので、パターンが予想より正確でないことがあります。
07010102 | 疎粒度の特徴が同じ方向であるために、パターン結果が不安定になることがあります。
07010200 | 高精度な特徴が多いため、実行時間が長くなることがあります。手動で [粒度] を設定してください。
07010101 | パターンに含まれる情報が不十分なため、角度またはスケールを正確に測定できないことがあります。
07020300 | コントラストが低いため、結果は破棄されました。
07020301 | より正確な結果を得るため、結果は破棄されました。
07020302 | クラッタが多すぎるため、結果は破棄されました。
07020303 | 現在のパラメータ設定に対して、登録パターンに含まれる特徴が少なすぎます。
07030000 | エラー情報はありません。

汎用エラー文字列

診断コード | 対応する情報文字列
09990100 | 対応付けデータのサイズはゼロです。
09990101 | ビューで指定したポイントが 9 未満です。
09990102 | 無限にマップします。
09990103 | 無効なポイント構成です。
09990104 | 固有パラメータの検索に失敗しました。
09990500 | 内部 CalibrateGrid エラーです。

ComputeStats 関数のエラー文字列

診断コード | 対応する情報文字列
03040700 | 関数の入力値が無効です。

畳み込みフィルタのエラー文字列

診断コード | 対応する情報文字列
03210002 | 行と列の数は 1 ～ 10 の範囲でなければなりません。
03210004 | カーネル値は -9999 ～ 9999 の範囲でなければなりません。

注: #ERR に対応するエラー文字列がない場合、GetErrorCode 関数は -1 を返します。

エラー文字列を返さない #ERR については、エラーとなっているセル関数の各パラメータを調べることによって、#ERR の原因を究明することができます。 数式内のセル参照を調べて、それらの値を確認してください。 複雑なジョブの場合は、いくつかの参照や入れ子型の参照を追跡する必要が生じる場合もあります。

画像取り込み関数の一部の機能 (部分取り込み、照明制御など) は、エミュレータではサポートされていません。In-Sight センサ上でこれらの機能を使用したジョブを作成し、そのジョブをエミュレータにロードすることは可能ですが、このとき、セル A0 の AcquireImage 関数が #ERR を報告することがあります。

#ERR を無視してエラーの拡散を防止する方法

ExtractBlobs ツールにより検出された複数のブロブの合計面積を計算するケースを考えて見ましょう。GetArea 関数を使用して、ブロブ構造体から個々のブロブの面積を取得します。 ブロブが検出されないと、GetArea 関数は正常に実行されませんが、アプリケーションでは正常な状況である場合があります。

Cell | 関数 | 説明
A1 | ExtractBlobs([パラメータ]) | ブロブを抽出して、 [image] 構造体を返します。
B1 | GetArea(A1,0) | ブロブ 0 の面積を返します。
B2 | GetArea(A1,1) | ブロブ 1 の面積を返します。
B3 | GetArea(A1,2) | ブロブ 2 の面積を返します。
B4 | Sum(B1:B3) | ブロブの総面積を計算します。
ExtractBlobs 関数が 3 つ以上のブロブを検出できないと、1 つ以上の GetArea セルが #ERR を報告するために、数式 Sum(B1:B3) は、#ERR を報告します。このエラー状態を無視するには、次の ErrFree 関数を使用します。
B4 | Sum(ErrFree(B1:B3)) | ブロブの総面積を計算します。

ErrFree 関数を使用すると #ERR が 0 に置き換えられます。したがって、この Sum の入力パラメータに含まれる #ERR の値はすべて 0 として処理されます。
Version: 5.6.0


エラーメッセージ

In-Sight Explorerトラブルシューティング

詳細と可能な解決方法については、次のいずれかのエラーを選択してください。

Error: 参照深度の最大値を超えています。

Error 3000: <番号> は正しい値ではありません。

Error 5000: セグメントが検出されませんでした。

Error 5001: フォントに登録された文字数が最大値に達しています。

Error 5100: 入力した In-Sight ホスト名は既に存在します。

Error 5101: このホスト名は使用できません。

Error 5102: このホスト名は使用できません。

Error 5106: この IP アドレスは使用できません。

Error 5107: IP アドレスは既に定義されています。

Error 5200: パスワードが間違っています。

Error 5201: 入力したユーザ名は既に存在します。

Error 5300: <ホスト名> を再起動できません。

Error 5301: <ホスト名> の再起動の際にエラーが発生しました。

Error 5302: <ホスト名> へのネイティブモード接続を確立できません。

Error 5400: 未知の接続エラーです。

Error 5401: 接続が拒否されました。

Error 5402: 不正なユーザ名またはパスワードです。

Error 5403: 不正なユーザ名またはパスワードです。

Error 5404: <ホスト名> に接続できません。

Error 5405: 内部の接続/切断エラーです。

Error 5406: バージョンが一致しませんでした。

Error 5407: <ユーザ名> に合わせてアクセス権レベルを調整する必要があります。

Error 5408: ユーザ <ユーザ名> は既にこのシステムにローカル接続しています。

Error 5409: <ホスト名> からのユーザ <ユーザ名> は既にこのシステムにリモート接続しています。

Error 5410: ドラッグ & ドロップリストには有効なファイルがありません。

Error 5500: 画像をファイル <ファイル名> に保存できません。

Error 5501: ジョブをファイル「ファイル名」に保存できません。

Error 5502: エミュレータ上のファイル名 image.bmp、image.jpg、screen.bmp または screen.jpg に保存できません。

Error 5503: <フォルダ名> という名前の新しいフォルダを作成できませんでした。

Error 5504: <フォルダ名> という名前のフォルダは既に存在します。

Error 5506: 画像ファイル <ファイル名> を開くことができません。

Error 5507: ジョブファイル <ファイル名> を開くことができません。

Error 5600: IP アドレス <IP アドレス> を持つデバイスがネットワーク上に検出されました。

Error 5700: 数式が複雑すぎます。

Error 5701: 数式が不正です。

Error 5800: 未知のネイティブモード応答です。

Error 5801: 未知のネイティブモードコマンドです。

Error 5802: コマンドを実行できる権限を持っていません。

Error 5803: ネイティブモードコマンドエラーです。

Error 6000: レイアウトを回復できません。

Error 6001: UDP ポート 1069 を開くことができません。

Error 6002: エミュレータを停止できませんでした。

Error 6003: エミュレータを起動できませんでした。

Error 6004: レポートを書き込むことができませんでした。

Error 6005: スタイルシート <ファイル名> をコピーできませんでした。

Error 6006: リリースノート <ファイル名> を表示できませんでした。

Error 6007: <ホスト名> からディレクトリを取得できません。

Error 6008: <ホスト名> へのリンクを確立できませんでした。

Error 6010: ファイル <ファイル名> をバックアップできません。

Error 6011: <ホスト名> のバックアップディレクトリを作成できません。

Error 6012: <ホスト名> への FTP セッションを閉じるときに例外が発生しました。

Error 6015: <ホスト名> のバックアップディレクトリが見つかりません。

Error 6016: <ファイル名> の削除は許可されていません。

Error 6017: <ファイル名> を削除する際にエラーが発生しました。

Error 6018: <ファイル名> をコピーする際にエラーが発生しました。

Error 6019: <ファイル名> のコピーは許可されていません。

Error 6020: In-Sight センサ <ホスト名> はオンラインのままです。

Error 6021: <ホスト名> のオンラインステータスを検出できません。

Error 6022: <ホスト名> のオンラインステータスを設定できません。

Error 6023: <ホスト名> のオフラインステータスを確認できません。

Error 6024: <ホスト名> をバックアップできません。

Error 6025: <ホスト名> のオンラインステータスをリストアできません。

Error 6027: <ホスト名> の再起動がタイムアウトになりました。

Error 6028: <ホスト名> の再起動の際にエラーが発生しました。

Error 6030: <ホスト名> から設定を読み取ることができません。

Error 6031: <ホスト名> からネットワーク設定を取得できません。

Error 6032: <ファイル名> に設定を書き込むことができません。

Error 6033: <ファイル名> にネットワーク設定を書き込むことができません。

Error 6034: <ホスト名> にネットワーク設定を保存することができません。

Error 6035: 不正なホスト名が検出されました。

Error 6036: このホスト名は使用できません。

Error 6037: ホスト名は既に定義されています。

Error 6038: 不正な IP アドレスが検出されました。

Error 6039: この IP アドレスは使用できません。

Error 6040: IP アドレスは既に定義されています。

Error 6041: セキュリティキーが無効です。

Error 6042: レジストリを書き込む際にエラーが発生しました。

Error 6043: エミュレータに接続できませんでした。

Error 6044: Options.xml ファイルの書き出しに失敗しました。

Error 6046: <ホスト名> のバックアップディレクトリを作成できません。

Error 6047: In-Sight センサがネットワーク上で検出されず、オフラインプログラミングライセンスが入力されていなかったため、エミュレータは起動しませんでした。

Error 6304: ディレクトリ <ホスト名> を開くことができません。

Error 6308: <ホスト名> のバックアップディレクトリが見つかりません。

Error 6421: <ホスト名> に接続できません。

Error 6441: <ホスト名> のバックアップディレクトリが見つかりません。

Error 7001: 未知のエラーです。

Error 7003: ホスト <ホスト名> に接続できませんでした。

Error 7700: 入力したアカウントはネットワーク上のどの In-Sight ビジョンセンサに対するフルアクセス権限も持っていません。

Error 7705: IP アドレス <IP アドレス> は既存の In-Sight ビジョンセンサの IP アドレスと競合しています。

Error 7706: IP アドレス <IP アドレス> はネットワーク上に既に存在する別のデバイスと競合しています。

Error 7707: IP アドレス <IP アドレス> は別の In-Sight ビジョンセンサで使用する IP アドレスと競合しています。

Error 7708: ホスト名 <ホスト名> は既存の In-Sight ビジョンセンサのホスト名と競合しています。

Error 7709: ホスト名 <ホスト名> は別の In-Sight ビジョンセンサで使用するホスト名と競合しています。

Error 7711: 設定時に I/O エラーが発生しました。

Error 7712: 設定が失敗しました。

Error 7713: In-Sight ビジョンセンサはオンラインでは設定できません。

Error 7714: ビジョンセンサはオンラインです。設定されませんでした。

Error 7715: In-Sight ビジョンセンサをオフラインにすることができませんでした。

Error 7718: 検証が失敗しました。

Error 7719: 設定が中断されました。

Error 7720: 不正なホスト名が検出されました。

Error 7721: 不正な IP アドレスが検出されました。

Error 7722: 無効な DHCP 設定が検出されました。

Error 7723: 無効な DNS サーバが検出されました。

Error 7724: 無効なデフォルトゲートウェイサーバが検出されました。

Error 7725: 無効なサブネットマスクが検出されました。

Error 7726: 無効なドメインが検出されました。

Error 7727: 不正なユーザ名またはパスワードです。

Error 7728: In-Sight ビジョンセンサに接続できませんでした。

Error 7729: In-Sight ビジョンセンサは正常に再起動されませんでした。

Error 7731: このデバイスではネットワーク設定を行えませんでした。

Error 7740: 選択したネットワークインタフェースが接続されていません。

Error 7741: 選択したネットワークインタフェースは現在 DHCP を使用しています。

Error 7742: 選択したネットワークインタフェースは現在 DHCP を使用しており、0.0.0.0 という IP アドレスを持っています。 この手順を継続するには、ネットワークインタフェースで固定 IP アドレスを再設定する必要があります。

Error: 参照深度の最大値を超えています。

セル参照チェーンに含まれる参照の最大値は 256 セルで、このエラーは、参照チェーンが 256 を上回ったときに表示されます。このエラーは、インデックス番号を作成するときによく発生します (例: B0=0; B1=B0+1; B2=B1+1; B3=B2+1...B255=B254+1; B256=B255+1; B257=B256+1 → エラーがトリガされます)。このエラーを回避するには、参照チェーンにブレイクをハードコーディングします (例: B0=0; B1=B0+1; B2=B1+1; B3=B2+1...B199=B198+1; B200=200 → ハードコーディングされた上限。この結果、参照深度が 56 残るため、チェーンに追加されるほかのセルはこれを使用できます。その後、チェーンを再開します。B201=B200+1...B255=B254+1; B256=B255+1; B257=B256+1 → エラーはトリガされません)。

Error 3000: <番号> は正しい値ではありません。

Explorer のホストテーブルのエントリが持つ IP アドレスの最初のオクテットは、1 ～ 223 である必要があります。また、4 番目のオクテットは、1 ～ 254 である必要があります。0.5.2.8 や 10.40.6.255 などの IP アドレスは使用できません。

Error 5000: OCV セグメントが検出されませんでした。

In-Sight Explorer は、定義されている領域に文字インスタンスを検出できませんでした。[OCV/OCR フォントの登録] ダイアログボックスで極性 ([黒 (白い背景)] または [白 (黒い背景)]) が正しく設定されていることと、必要な文字の周囲をサーチ領域が正しく囲んでいることを確認してください。

Error 5001: フォントに登録された文字数が最大値に達しています。

TrainFont 関数には最大 64 種類の文字を登録できます。新しいモデルを追加する前に、既存の不要なモデルを削除してください。

Error 5100: 入力した In-Sight ホスト名は既に存在します。

既に存在するホストを In-Sight ホストテーブルに追加しようとしました。ほかの名前を指定してください。

Error 5101: このホスト名は使用できません。

ホスト名は必須であり、空白にすることはできません。ホストの名前を選択してください。

Error 5102: このホスト名は使用できません。

無効なホスト名を使用して Explorer のホストテーブルを定義しようとしました。一部のホスト名はシステム専用であり、ホストテーブル名には使用できません。ほかの名前を指定してください。

Error 5106: この IP アドレスは使用できません。

無効な IP アドレスを持つホストを In-Sight ホストテーブルに追加しようとしました。ほかの IP アドレスを指定してください。

Error 5107: IP アドレスは既に定義されています。

既存のホストテーブルエントリに登録済みの IP アドレスを持つホストを In-Sight ホストテーブルに追加しようとしました。ほかの IP アドレスを指定してください。

Error 5201: 入力したユーザ名は既に存在します。

In-Sight のユーザ名は一意である必要があります。既存のユーザと同じ名前で新しいユーザを入力しようとすると、Error 5201 が表示されます。

Error 5302: <ホスト名> へのネイティブモード接続を確立できません。

<ホスト名> のネイティブモードチャネルが In-Sight Explorer への応答を停止しました。センサを再起動して、操作をやり直してください。

Error 5403: 不正なユーザ名またはパスワードです。

別のユーザが既にセンサにログオンしている場合に、有効なユーザ名と間違ったパスワードでセンサにログオンしようとすると、Error 5403 が表示されることがあります。

Error 5404: <ホスト名> に接続できません。

In-Sight Explorer が <ホスト名> への 1069 番ポート経由の TCP ソケットを作成できない場合、Error 5404 が発生します。

このエラーは通常、ファイアウォールによって TCP ソケットの作成が妨げられたか、Windows が適切なネットワークインタフェースカード (NIC) ではなく別の NIC でアクセスしようとして発生します。

一般に、Windows から <ホスト名> への Telnet または FTP 接続を確立できる場合は、In-Sight Explorer によって、センサへの TCP ソケットを作成することができます。

Windows のコマンドプロンプトで、「telnet aaa.bbb.ccc.ddd 1069」 (aaa.bbb.ccc.ddd は <ホスト名> の IP アドレス) と入力してください。Telnet でそのポートへのソケット接続を作成できない場合は、In-Sight Explorer でも作成することはできません。

LMHOSTS に関する注意:

NetBIOS 名前解決用に Microsoft Windows 内の LMHOSTS ファイルを使用しており、異なるサブネットでの通信用にネットワーク設定を最近変更した場合は、LMHOSTS ファイルを調べて、<ホスト名> が適切な IP アドレスに割り当てられていることを確認してください。

Error 5405: 内部の接続/切断エラーです。

In-Sight Explorer は、ウィンドウのタイトルバーに示されているセンサと通信ができなくなりました。センサが起動されており、ネットワーク上で正常に通信していることを確認してください。必要に応じて、センサの電源を入れ直してください。

Error 5406: バージョンが一致しませんでした。

異なるバージョンの In-Sight Explorer または PC Host で作成されたジョブファイルをロードすると、バージョン不一致エラーまたは警告が表示されることがあります。ジョブファイルを保存し直すと、バージョン情報が更新されます。

バージョンスタンプが一致しません。ジョブは <バージョンスタンプ番号> で、センサは <バージョンスタンプ番号> です。ロードを続行しますか？

ロードしようとしているジョブと、ロード先の In-Sight ビジョンシステム/エミュレータとの間でバージョンスタンプが一致しません。このエラーは、ある In-Sight ソフトウェアまたはファームウェアを使用して作成したジョブを、異なるバージョンを使用してロードしようとする場合に発生します。

この警告は、ジョブとビジョンシステムの互換性の問題については表示しません。そのような互換性の問題がある可能性を注意喚起することを意図しています。この警告の後にジョブのロードに失敗したことに関するほかのエラーメッセージが表示されない場合、ビジョンシステム/エミュレータには互換性があるため、これ以上の操作は必要ありません。エラーメッセージが表示される場合は、このジョブファイルを修正して、ビジョンシステム/エミュレータで実行するファームウェアとの完全な互換性を確保する必要があります。

Error 5501: ジョブをファイル <ファイル名> に保存できません。

Error 5501 は、次のエラーメッセージとともに表示されます。

オンライン中はジョブファイルを保存できません
アクティブな In-Sight センサがオンラインのときに、ジョブファイルを保存しようとしました。[フル] または [プロテクト] アクセス権を持つ場合、センサをオフラインにするか、または [ユーザ] ダイアログで [Allow Online Job Save] チェックボックスをオンにしてから、操作をやり直します。このエラーは、ローカルエミュレータを無効にしようとするときに、[オプション] ダイアログで表示されることがあります。

Error 5507: ジョブファイル <ファイル名> を開くことができません。

Error 5507 は、次のエラーメッセージとともに表示されます。

アクセスは拒否されました
このメッセージは、ファイル名に中国語または韓国語の文字が含まれ、In-Sight Explorer の [言語] ([システム] → [オプション] → [言語]) が [中国語] または [韓国語] にそれぞれ設定されていない場合に、Windows エクスプローラからスプレッドシートにジョブファイルをドラッグ & ドロップしたときに表示されることがあります。ファイル名に応じた適切な [言語] を In-Sight Explorer に設定してから再起動し、操作をやり直してください。

Error 5700: 数式が複雑すぎます。

1 つの式で使用できる関数、引数、および演算子の最大数は、全体で 254 です。関数の引数がセルの範囲にある場合、その範囲内の各セルは 1 つの引数としてカウントされます。

例えば、Sum(1,2,A3:A6) という数式は、1 つの関数 (Sum) と 6 つの引数 (1、2、A3、A4、A5、A6) によって構成されています。つまり、この数式では、使用可能な 254 の要素のうちの 7 つを使用しています。

Error 5701: 数式が不正です。

Error 5701 は、数式をスプレッドシートのセルまたは数式バーに入力するときに、数式のいずれかの部分に修正の必要がある場合に表示されます。図のように、無効な構文は赤色でハイライトされます。赤色のテキストが表示されずに Error 5701 だけが表示された場合:

  • 関数名が完全に入力されていないか、その関数に必要なすべての引数が提供されていない可能性があります。
  • 関数が 254 以上の引数を参照している可能性があります。1 つの式で使用できる引数の最大数は 253 です。関数の引数がセルの範囲にある場合、その範囲内の各セルは 1 つの引数としてカウントされます。例えば、「Sum(C1:C254)」は、この関数が範囲 (C1:C254) 内の 254 の引数を参照しているため、このエラーメッセージが表示されます。詳細については、Error 5700 を参照してください。

ヒント: Ctrl+Shift+F キーを押すと、数式エディタが表示され、現在の数式を編集できます。

Error 6000: レイアウトを回復できません。

In-Sight Explorer を起動すると、In-Sight Explorer は、アプリケーションのルートフォルダにある options.xml ファイルからの起動レイアウトのロードを試みます。起動レイアウトで定義されているホストが、ネットワーク上に検出されない場合、このエラーが表示されます。

Error 6000 は、起動レイアウトが保存された後に、問題のセンサまたはエミュレータのホスト名が変更されていると発生します。この問題は、次の手順で [レイアウトを保存する] をもう一度実行すると解決します。

  1. In-Sight Explorer の起動時に自動ログオンさせたい In-Sight センサにログオンします。
  2. 必要に応じて、ビューの表示レイアウト (タイル表示または単一の最大表示) を調整します。
  3. [システム] メニューの [表示レイアウトを保存] をクリックします。

Error 6001: UDP ポート 1069 を開くことができません。

In-Sight Explorer は、UDP ポート 1069 を開いて、TCP/IP ネットワーク上の In-Sight センサと通信します。一部の PC アプリケーション (Microsoft Outlook や Microsoft IIS Admin サービスなど) は、ランダムな UDP ポートを開きます。これによって、In-Sight Explorer の動作が妨げられることがあります。次のエラーメッセージが表示される場合は、

Error 6001: UDP ポート 1069 を開くことができません。In-Sight Explorer はネットワーク上の In-Sight センサを検出することができません。[OK] をクリックして続行します。

すべてのアプリケーションを閉じて、In-Sight Explorer を再起動してください。ほかのすべてのアプリケーションを閉じてもこのエラーメッセージが表示される場合は、PC を再起動してから In-Sight Explorer を起動してください。In-Sight Explorer をインストールすると、そのほかの Windows アプリケーションがこれらのポートを使用できないようにするためのレジストリエントリが作成されますが、このレジストリエントリは PC を再起動するまで有効になりません。

Error 6003: エミュレータを起動できませんでした。

アプリケーションの起動時に、[In-Sight ネットワーク] のツリーに表示された In-Sight センサやエミュレータと通信できない場合、このエラーが表示されることがあります。このエラーは、Explorer のホストテーブルで定義されているホストが、ネットワークでアクセスできない場合に起動レイアウトに含まれていると発生します。

<ホスト名> で示されている In-Sight センサまたはエミュレータの電源が入っており、ネットワークで通信できることを確認してください。このセンサが Explorer のホストテーブルのエントリである場合は、ホストテーブルのエントリの IP アドレスが、ネットワーク設定で定義されている <ホスト名> の実際の IP アドレスと一致することを確認してください。

Error 6003 は、Internet Information Services (IIS) Admin サービスが Windows の [コントロールパネル] で起動している場合に表示されることもあります。このサービスが動作している場合は停止して、In-Sight Explorer を再起動してください。IIS Admin サービスは、In-Sight Explorer が起動した「後」に再起動させることができます。

Error 6003 は Error 6001 とともに表示される場合があり、Error 6001 の解決手順で問題が解決することもあります。

Error 6004: レポートを書き込むことができませんでした。<ファイル名>

In-Sight Explorer は、<ファイル名> をディスクに書き込むことができませんでした。ドライブが存在し、レポートファイルを書き込むための十分な空き容量があることを確認してください。<ファイル名> がネットワークドライブを指している場合は、ドライブが接続されており、そのドライブへの書き込みアクセス権があることを確認してください。

Error 6007: <ホスト名> からディレクトリを取得できません。

In-Sight Explorer は、<ホスト名> からファイルディレクトリ情報を取得できませんでした。このフォルダに含まれる、ファイルを表示する権限が、ユーザアカウントにない可能性があります。<ファイル名> のローカル FTP ポートが、[オプション] ダイアログで指定されている Explorer の FTP ポートと一致していることを確認してください。

Error 6008: <ホスト名> へのリンクを確立できませんでした。

In-Sight Explorer は、アクセス先ホストにリンクできませんでした。ホストがダウンしているか、メッセージが表示されたときに、リンクを完了しないことを選択している可能性があります。

接続が拒否されました: 接続

In-Sight Explorer は、現在 [In-Sight ネットワーク] で選択されているセンサと通信できません。[表示] メニューで [更新] を選択して、[In-Sight ネットワーク] の表示を更新してください。それでもセンサにアクセスできない場合は、センサの電源を入れ直して、操作をやり直してください。

パスワードが間違っていました。ログインできません。

現在のユーザは、<ホスト名> のファイルを表示するためのアクセス権を持っていません。このセンサに保存されているファイルを表示できるアクセス権を持つ、別のユーザとしてログオンして、操作をやり直してください。

Error 6010: ファイル <ファイル名> をバックアップできません。

Error 6010 は、次のエラーメッセージとともに表示されます。

ファイルが見つかりません

<ファイル名> は、In-Sight ファイルシステムに対して無効である可能性があります。ファイル名に記号や特殊文字が含まれていないことを確認してください。ファイル名を変更して、操作をやり直してください。

Error 6011: <ホスト名> のバックアップディレクトリを作成できません。

[システム] メニューで、[オプション] をクリックします。[バックアップディレクトリ] が有効なフォルダ名であり、このフォルダに Windows エクスプローラからアクセスできることを確認してください。

In-Sight センサのフラッシュメモリ空き容量が不足しているためにファイルを保存できないとき

このエラーは、In-Sight ファイルシステムに対してファイル名が長すぎたり、ファイルサイズが大きすぎてコピー先センサに保存できなかったりすると、表示されることがあります。次のパスにあるバックアップディレクトリを確認してください。

<ISE dir>\Backups\<ホスト名>

ここで <ISE dir> は、In-Sight Explorer がインストールされているフォルダです。また <ホスト名> は、コピー先 In-Sight センサの名前です。<ファイル名> は最大 251 文字 (拡張子を除く) です。コピー先センサに多数のファイルが保存されている場合は、ほかのファイルを削除して、リストア操作をやり直してください。または、[In-Sight のファイル] ペインや Windows エクスプローラを使用して、ファイルを手動でコピーしてください。

エミュレータ上のファイルをリストアしているとき

エミュレータのリストアを試みているときに、ファイル (image1A.bmp、image1B.bmp、image2A.bmp など) が読み取り専用の場合、このエラーが発生します。読み取り専用属性を削除してから、リストア操作をやり直してください。

Error 6015: <ホスト名> のバックアップディレクトリが見つかりません。

In-Sight Explorer は、<ホスト名> のバックアップフォルダを確認できませんでした。バックアップフォルダが次のパスに格納されていることを確認してください。

<InSight2>\Backups

ここで <InSight2> は、In-Sight Explorer がインストールされているフォルダです。バックアップはセンサのホスト名と同じ名前のサブフォルダとして格納されます。このフォルダが移動または削除されたり、フォルダの名前が変更されたりしていないか確認してください。バックアップディレクトリの命名方法の詳細については、Error 6046 を参照してください。

Error 6016: <ファイル名> の削除は許可されていません。

In-Sight ファイルシステム内の一部のファイルはセンサの動作に不可欠であるため、削除できません。次のファイルは、In-Sight センサやエミュレータから削除できません。

  • proc.set
  • image.bmp
  • image.jpg
  • screen.bmp
  • screen.jpg

Error 6017: <ファイル名> を削除する際にエラーが発生しました。

In-Sight Explorer は、In-Sight システムから <ファイル名> を削除できませんでした。ファイルが読み取り専用でないことを確認してください。

ファイルがリモートで削除された可能性があります。ファイルを選択し、F5 キーを押して、[In-Sight のファイル] ペインを更新してください。

Error 6018: <ファイル名> をコピーする際にエラーが発生しました。

In-Sight Explorer は、<ファイル名> をコピー先 In-Sight センサにコピーできませんでした。Error 6018 とともに、次のメッセージが表示される場合があります。

転送に失敗しました - メモリが不足しています

ファイルを転送するために必要なフラッシュメモリ空き容量が不足している可能性があります。いくつかのファイルを削除してから、ファイルをコピーし直してください。

書き込みの権限がありません

上書きしようとしたファイルは、読み取り専用でした。アクセス制限を解除して、コピーし直してください。

ファイルが見つかりません

コピーしようとしたファイルが、コピー元センサに存在しませんでした。[In-Sight のファイル] ペインを更新して (F5 キー)、コピー元センサにファイルが存在することを確認してください。

ファイルのドラッグ & ドロップ操作に問題があります

問題 #1: 英語版のオペレーティングシステムで、韓国語または中国語の文字を含むファイル名を Windows エクスプローラから [In-Sight のファイル] ペインにドラッグ & ドロップすると、Error 6018 が発生します。

問題 #2: 韓国語版のオペレーティングシステムでは、Windows エクスプローラから [In-Sight のファイル] ペインにドラッグ & ドロップできるのは韓国語または英語の文字を含むファイル名だけです。そのほかの文字では Error 6018 が発生します。

問題 #3: 中国語版のオペレーティングシステムでは、Windows エクスプローラから [In-Sight のファイル] ペインにドラッグ & ドロップできるのは中国語または英語の文字を含むファイル名だけです。そのほかの文字では Error 6018 が発生します。

回避策:

  • [ジョブを開く] ダイアログ ([ファイル] → [ジョブを開く]) を使用して、ファイルをロードします。
  • ファイル名には英語の文字を使用します。

Error 6019: <ファイル名> のコピーは許可されていません。

一部のファイル (proc.set など) は非常に重要なネットワーク設定を含むため、別のセンサに単純にコピーすることはできません。

Error 6035: ホスト名が不正です。

Error 6035 は、新しいホストを Explorer のホストテーブルに追加する際に、[ホスト名] フィールドが空白のままになっていると表示されます。ホスト名を入力して、[OK] をクリックしてください。

Error 6036: このホスト名は使用できません。

Error 6036 は、Explorer のホストテーブルのエントリにあるホスト名を PC と同じ名前に設定しようとすると表示されます。ほかのホスト名を指定して、[OK] をクリックしてください。

Error 6037: ホスト名は既に定義されています。

Explorer のホストテーブルに追加しようとしたホスト名は、既にホストテーブルに存在します。ほかのホスト名を指定して、[OK] をクリックしてください。

Error 6038: IP アドレスが不正です。

一部の IP アドレス (0.0.0.0 など) は、Explorer のホストテーブルのエントリには使用できません。有効な IP アドレスを指定してください。

Error 6039: この IP アドレスは使用できません。

Error 6039 は、新しいホストを Explorer のホストテーブルに追加する際に、[IP アドレス] フィールドが空白のままになっていると表示されます。一部の IP アドレス (ルックバックアドレスの 127.x.x.x など) は、Explorer のホストテーブルのエントリには使用できません。有効な IP アドレスを指定してください。

Error 6040: IP アドレスは既に定義されています。

1 つの IP アドレスは、Explorer のホストテーブルにある 1 つのホストテーブルエントリにのみ、対応することができます。同じ IP アドレスで 2 つ目のセンサを追加しようとすると、Error 6040 が表示されます。

Error 6041: セキュリティキーが無効です。

[オプション] ダイアログに入力したオフラインプログラミングキーは無効です。弊社の販売代理店または弊社テクニカルサポートに連絡して、有効なキーを入手してください。

Error 6042: レジストリを書き込む際にエラーが発生しました。

Error 6042 は、管理者権限を持たないユーザとして Windows にログオンしている場合に、オフラインプログラミングキーを入力したときに表示されることがあります。 Windows からログオフして、管理者として PC にログオンし直してください。 その後、操作をやり直してください。

Error 6044: Options.xml ファイルの書き出しに失敗しました。

In-Sight Explorer は、オプションファイルを保存できませんでした。options.xml (In-Sight Explorer のインストールフォルダにあります) が読み取り専用になっていないことと、別のアプリケーションで開かれていないことを確認してください。

Error 6046: <ホスト名> のバックアップディレクトリを作成できません。

In-Sight Explorer では、センサ名ごとに最大 256 のバックアップを作成することができます。これ以上のバックアップを作成しようとすると、Error 6046 が表示されることがあります。新しいインクリメンタルバックアップ (sensor.002 や sensor.003 など) は、フォルダ内で一番大きな番号が付けられているバックアップに基づいて作成されます。

例えば、IS3K という名前の In-Sight センサのバックアップを既に 100 個作成している場合、バックアップディレクトリには IS3K、IS3K.001、IS3K.002、...、IS3K.099 という名前のフォルダが作成されています。IS3K.099 が存在する限り、次に作成されるバックアップは、(ほかのすべてのバックアップが削除されていても) IS3K.100 に格納されます。

Error 6046 を解決するには、Windows エクスプローラでバックアップディレクトリを参照して、<ホスト名> の大きな番号が付いたバックアップを削除してください。または、バックアップを別のフォルダに移動してください。ただし、In-Sight Explorer がバックアップをリストアするには、バックアップしたファイルがバックアップディレクトリに存在する必要があるので注意してください。

Error 6047: In-Sight センサがネットワーク上で検出されず、オフラインプログラミングライセンスが入力されていなかったため、エミュレータは起動しませんでした。

Error 6047 は、オフラインプログラミングキーが入力されていない状態で、かつ、In-Sight センサがネットワーク上で検出されなかった場合に表示されます。このエラーは、アクティブなネットワーク接続がない場合に発生することがあります。ネットワーク上にセンサが検出されない場合、このキーが入力されていないとローカルエミュレータは起動しません。

Error 6304: ディレクトリ <ホスト名> を開くことができません。

In-Sight Explorer は、<ホスト名> でバックアップを実行できませんでした。[オプション] ダイアログで適切なバックアップディレクトリが定義されていることと、そのディレクトリが読み取り専用になっていないことを確認してください。

Error 6308: <ホスト名> のバックアップディレクトリが見つかりません。

<ホスト名> のリストア操作を実行しようとしましたが、In-Sight Explorer は、このセンサのバックアップファイルを確認できませんでした。[オプション] ダイアログで定義されているバックアップディレクトリが適切であることと、<ホスト名> のバックアップが保存されているフォルダを適切に指定していることを確認してください。

Error 6421: <ホスト名> に接続できません。

このエラーは、バックアップからセンサをリストアしようとすると表示されることがあります。このセンサにアクセスする権限が、ユーザアカウントにない可能性があります。また、In-Sight センサの電源が入っていることと、ネットワークケーブルが適切に接続されていることを確認してください。

Error 6441: <ホスト名> のバックアップディレクトリが見つかりません。

バックアップされていないセンサをリストアしようとしたか、PC からそのセンサのバックアップフォルダにアクセスできませんでした。<ホスト名> でのバックアップ操作が既に実行されていることと、[オプション] ダイアログで適切なバックアップディレクトリが定義されていることを確認してください。

Error 7003: ホスト <ホスト名> に接続できませんでした。

In-Sight Explorer は、<ホスト名> への接続を確立できませんでした。Error 7003 は、次のエラーメッセージとともに表示されることがあります。

<ホスト名> からのユーザ <ユーザ名> は既にこのシステムにリモート接続しています。

操作を完了するには、[はい] をクリックして、ログオンからやり直してください。

Error 7708: ホスト名 <ホスト名> は既存の In-Sight ビジョンセンサのホスト名と競合しています。

既に存在するホストを Explorer のホストテーブルに追加しようとしました。ほかの名前を指定してください。

Error 7712: 設定が失敗しました。

[センサ/デバイスをネットワークに追加] ダイアログは、In-Sight センサを適切に設定できませんでした。詳細なトラブルシューティング情報については、ダイアログで Error 7712 の後に表示されるエラーメッセージを参照してください。

Error 7718: 検証が失敗しました。

[センサ/デバイスをネットワークに追加] ダイアログを使用して設定しようとしたネットワーク設定は適用できませんでした。固有のトラブルシューティング情報については、ダイアログで Error 7718 の後に表示されるエラーメッセージを参照してください。

Error 7719: 設定が中断されました。

[センサ/デバイスをネットワークに追加] ダイアログで、1 つまたは複数の In-Sight センサの設定を終了することを選択しました。

Error 7720: 不正なホスト名が検出されました。

Error 7720 は、新しいホストを Explorer のホストテーブルに追加する際に、[ホスト名] フィールドが空白のままになっていると表示されます。ホスト名を入力して、[OK] をクリックしてください。

Error 7721: 不正な IP アドレスが検出されました。

指定した IP アドレスを In-Sight センサに割り当てることができませんでした。[センサ/デバイスをネットワークに追加] ダイアログでこのエラーメッセージが表示された場合は、In-Sight センサに IP Address Lock が設定されていないか確認してください。IP Address Lock が設定されていると、センサの IP アドレスは変更できません。Telnet セッションでセンサに SL0 を発行すると、IP Address Lock が解除されます(注: この設定を変更するには、フルアクセス権限を持つユーザとしてログオンする必要があります)。

Error 7728: In-Sight ビジョンセンサに接続できませんでした。

[センサ/デバイスをネットワークに追加] ダイアログは、In-Sight センサとの通信を確立できませんでした。センサの電源が入っていることと、ネットワーク接続がアクティブであることを確認してください。詳細なトラブルシューティングのヒントについては、Error 5404 を参照してください。

Error 7731: このデバイスではネットワーク設定を行えませんでした。

詳細なトラブルシューティング情報については、ダイアログで Error 7731 の後に表示される注意を参照してください。

また、このデバイスが PC と同じ物理サブネットに接続され、電源が入っていることも確認します。デバイスへのイーサネットケーブル接続もすべて確認してください。

それでも問題が解決されない場合は、デバイスを PC に直接接続し、デバイスの電源を一度切ってから、再び入れてください。


In-Sight® Explorer 5.6.1 リリースノート

© Copyright 1999-2018 Cognex Corporation. All rights reserved.

Revision: 5.6.1.4, 09/14/2018

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題

注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Microsoft® Windows® スタートメニューから、更新されたドキュメンテーションにアクセスするには、次のステップに従ってください。

  1. 管理者権限を持って PC にログオンします。
  2. 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。 デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。

  • 1.8GHz 動作の Intel® Celeron® 1000M プロセッサ (または同等品)
  • 2GB の RAM 空き容量
  • 4GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

PC ハードウェア要件

推奨されるハードウェア要件とは、同時に 4 台までの In-Sight ビジョンシステムを接続している PC を指します。

  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 8GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Microsoft Windows 10 Professional (64 ビット)
  • Microsoft Windows 7 Professional、サービスパック 1 (64 ビット)
  • Microsoft Windows Server 2016

In-Sight Explorer はそのほかの Windows オペレーティングシステムにもインストール可能で、動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 中国語 (簡体字)
  • 英語
  • フランス語
  • ドイツ語
  • 日本語
  • 韓国語
  • スペイン語 (ヨーロッパ系)

サポートしているファームウェアバージョン

In-Sight Explorer 5.6.1 には、次のファームウェアバージョンが含まれています。

  • In-Sight 5.6.1
  • In-Sight 5.2.2
  • In-Sight 4.10.5

以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、 サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。 モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

In-Sight ファームウェア 5.6.1

  • In-Sight 2000 シリーズビジョンセンサ
  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight 7000 Gen2 シリーズビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム
  • In-Sight 9902L ラインスキャンビジョンシステム

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 4.10.5

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム (In-Sight 7000 Gen2 シリーズビジョンシステムを除く)

Microsoft .NET Framework 4.5

In-Sight ソフトウェアには、Microsoft .NET Framework 4.5 が必要です。 システムに検出されない場合、自動的にインストールされます。

新しい機能

新しい機能 | ファームウェアバージョン
In-Sight 9902L ラインスキャンビジョンシステムに新たに対応しました。 | 5.6.1

[画像取り込み期間] パラメータが、[AcquireImage] プロパティシートに追加されました。[クリップ] モードを [黒く塗りつぶし] または [ラインスキャンラインの間引き] に設定した場合に、いつ画像取り込みを終了するかを指定します。 このパラメータは、In-Sight 9902L ラインスキャンビジョンシステムでのみサポートされています。

 5.6.1

In-Sight 9902L ラインスキャンビジョンシステムに接続している場合に、[ラインスキャンの設定] ダイアログに次の機能が追加されました。

  • [画像最大高] ドロップダウンに、[12288] および [16384] のオプションが含まれるようになりました。標準のエリア画像の高さを増やすことができます。
  • 1K 解像度 (低照明モード) チェックボックスが追加されました。 ON にすると、標準のエリア画像が 1024 ピクセル幅に減少し、照明感度が向上します。
 5.6.1

ライブ画像取り込みおよびオンライン画像用の [1/8] 画像解像度オプションが、次の機能に追加されました。

  • [画像の設定] ダイアログボックスの [ライブ画像] 解像度および [オンライン] 解像度ドロップダウンリスト。
  • [記録再生のオプション] ダイアログボックス内、[記録] タブの [画像の解像度] ドロップダウンリスト。
  • [オプション] ダイアログボックス内、[記録] パネルの [画像の解像度] ドロップダウンリスト。
  • EV SetSystemConfig("LiveImage",解像度,最大フレームレート) および EV SetSystemConfig("OnlineImage",解像度,最大フレームレート) 拡張ネイティブモードコマンドが、1/8 解像度オプションをサポートするようになりました。1/8 解像度オプションのパラメータ値は 4 になります。
注: [1/8] 解像度オプションは、カラービジョンシステムではサポートされていません。
 5.6.1

PLC から (EtherNet/IP 接続を介し) ビジョンシステムに送信する、時間ベースのトリガのスケジューリングサポートが複数、追加されました。 ビジョンシステムは、PLC が送信する実際のトリガの 100 マイクロ秒以内に PLC トリガに応答することができます。 この機能は、IEEE 1588 (バージョン 2) 規格で定義されている CIP-Sync および Precision Time Protocol (PTP) を使用する In-Sight 7000 Gen2 シリーズおよび In-Sight 9902L ビジョンシステムでサポートされています。

  • EV SetSystemConfig("Eip.TriggerTimestampInputOffset",オフセット) 拡張ネイティブモードコマンドが更新されました。ビジョンシステムのトリガに使用する EtherNet/IP 出力アセンブリにオフセットを設定することができます。 In-Sight ファームウェアバージョン 5.6.1 以降を実装するビジョンシステムでは、64 ビットのシステムタイムオフセットをマイクロ秒単位で取得した後、64 ビットのタイムスタンプをマイクロ秒単位で取得します。
  • EV SetSystemConfig("Eip.TriggerTimestampNumInputs",タイムスタンプ) 拡張ネイティブモードコマンドが追加されました。1 つの PLC ユーザデータパケットからの複数のタイムスタンプに対し、ビジョンシステムが同時に処理できる数を設定することができます。 PLC は 1 つのユーザパケットにつき最大 4 つまでのタイムスタンプトリガを送信することができます。
  • EV SetSystemConfig("Eip.TriggerTimestampMaxQueueLength",タイムスタンプ) 拡張ネイティブモードが追加されました。ビジョンシステムが同時に保存できるタイムスタンプの最大数を設定することができます。 ビジョンシステムは、キューに最大 10 までのタイムスタンプを保存することができます。
  • EV SetSystemConfig("Eip.TriggerTimestampOverrideWindowUs",マイクロ秒) 拡張ネイティブモードが追加されました。ビジョンシステムに設定されているタイムスタンプを PLC から上書きする際に、保留中の PLC タイムスタンプの設定範囲をマイクロ秒単位で設定することができます。
  • EV SetSystemConfig("Eip.TriggerTimestampLegacyMode",トリガモード) 拡張ネイティブモードが追加されました。レガシーモード (1 つのタイムスタンプユーザデータフォーマットおよびトリガ) を有効にします。 4.5.0 - 4.10.x ファームウェアを実装したビジョンシステムから、5.6.1 移行のファームウェアを実装したビジョンシステムに移行する際に、既存の PLC ロジックを再使用する場合、このコマンドを発行してください。
 5.6.1

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。 5.x.x リリースノートは『In-Sight® Explorer ヘルプファイル』(英語版) でもご覧いただけます。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正 | ファームウェアバージョン
81197 | センサフィルムストリップのキューのサイズを、最大数の画像をビジョンシステムに保存するように設定している場合、ビジョンシステムをオンラインにし、フィルムストリップのキューから画像を選択しても、スプレッドシートのセルは変更されなくなりました。 以前は、スプレッドシートのセルの内容が、消去されてしまうことがありました。 | 5.6.1
79668 | In-Sight 2000 シリーズカラービジョンセンサが Web HMI に接続され、なおかつ画像を可能な限り高速で取得している場合でも、トリガ速度に影響がしなくなりました。 以前は、トリガ速度が大幅に下がることがありました。 | 5.6.1
79073 | HMI サーバを有効にした In-Sight 2000 ビジョンセンサを高トラフィックネットワークを介し HMI に接続している場合に発生していた、安定性の問題を解決しました。 以前は、ビジョンセンサが不応答になったり、ネットワークから切断されることがあり、電源を再投入する必要がありました。 | 5.6.1
43186 | In-Sight 2000 ビジョンセンサを接続し、[通信] アプリケーションステップでシリアルテキスト、シリアルネイティブ、TCP/IP または UDP デバイスを設定している場合、[FormatString] ダイアログボックスに出力文字列が正しく表示されるようになりました。 以前は、[FormatString] ダイアログボックスは #ERR を表示していました。 | 5.6.1

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
81464

AcquireImage の [クリップボード] または [画像取り込み期間] パラメータの値を In-Sight 9902L ラインスキャンビジョンシステムのオンライン中にプログラミングによって変更する場合、ビジョンシステムをオフラインにすると、変更は有効になりません。

回避策: ビジョンシステムをオフラインにした後にパラメータ値を更新するには、手動で画像を取得してください。

 5.6.1
79652 | ファームウェアバージョン 5.6.0 を搭載した In-Sight 2000 シリーズビジョンシステムでは、ビュー接続数 (In-Sight Explorer、VisionView または Web HMI) は最大 2 となります。 | 5.6.1
79345 | Web HMI が使用されている場合、PROFINET サイクリック I/O を 8ms 以上で実行しないでください。 | 5.6.1
48478 | In-Sight 5.6.0 ファームウェアが搭載された In-Sight ビジョンシステムに多数の ReadIDMax 関数を使用したジョブがロードされている場合、ビジョンシステム上で使用可能なメモリより多くのメモリが必要となることがあります。 その場合、使用可能なメモリを超過した ReadIDMax 関数は #ERR を返してしまいます。 例えば、100 以上の ReadIDMax 関数を使用したジョブが In-Sight 8405 ビジョンシステムにロードされている場合、この問題が発生する可能性があります。 | 5.6.1
45581 | CIP-Sync/PTP に設定した In-Sight 7600/7800 ビジョンシステムでは、トランスパレントクロックスイッチによる 1588 同期の正確性が、マスターからのオフセットより 10µs 以上大きくなることがあります。 | 5.6.1
42550 | In-Sight Track & Trace ジョブは、5.1.0 以降のファームウェアを搭載した In-Sight モデルではサポートされていません。 | 5.6.1
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.6.1
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.5


In-Sight® Explorer 5.6.1 リリースノート

In-Sight® Explorer 5.6.0 リリースノート

© Copyright 1999-2018 Cognex Corporation. All rights reserved.

Revision: 5.6.0.6, 05/25/2018

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題

注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows® スタートメニューから、更新されたドキュメンテーションにアクセスするには、次のステップに従ってください。

  1. 管理者権限を持って PC にログオンします。
  2. イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 1.8GHz 動作の Intel® Celeron® 1000M プロセッサ (または同等品)
  • 2GB の RAM 空き容量
  • 4GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、同時に 4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 8GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Microsoft® Windows® 10 Professional (64 ビット)
  • Microsoft Windows 7 Professional、サービスパック 1 (64 ビット)
  • Microsoft Windows Server 2016

In-Sight Explorer はそのほかの Windows オペレーティングシステムにもインストール可能で、動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

サポートしているファームウェアバージョン

In-Sight Explorer 5.6.0 には、次のファームウェアバージョンが含まれています。

  • In-Sight 5.6.0
  • In-Sight 5.2.2
  • In-Sight 4.10.5

以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

In-Sight ファームウェア 5.6.0

  • In-Sight 2000 シリーズビジョンセンサ
  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight 7000 Gen2 シリーズビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 4.10.5

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム (In-Sight 7000 Gen2 シリーズビジョンシステムを除く)

Microsoft .NET Framework 4.5

In-Sight ソフトウェアには、Microsoft .NET Framework 4.5 が必要です。 システムに検出されない場合、自動的にインストールされます。

新しい機能

新しい機能 | ファームウェアバージョン
In-Sight 2000-110、2000-120、2000-120C、2000-130 および 2000-130C ビジョンセンサモデルに新たに対応しました。オートフォーカス機能を持つリキッドレンズを装備しています。 | 5.5.0
In-Sight 7900 および 7902 ビジョンシステムモデルに新たに対応しました。 | 5.5.0
In-Sight 7900、7900C、7901、7901C、7902、7902C、7905 および 7905C ビジョンシステムモデルに新たに対応しました。 | 5.6.0
Web HMI 機能が追加されました。ジョブデータ (画像、グラフィックスコントロール、PASS/FAIL データ等) へのアクセスが可能で、ウェブベースのヒューマンマシンインターフェース (HMI) を介し、ビジョンシステムまたはセンサとやり取りすることができます。 | 5.6.0

EasyBuilder [通信] アプリケーションステップに、次の機能が追加されました。

  • FTP サーバまたはオンライン中の In-Sight 7000 Gen2 ビジョンシステムに搭載された SD カードに、データファイルをエクスポートできるようになりました。
  • FTP サーバまたはオンライン中の In-Sight 7000 Gen2 ビジョンシステムに搭載された SD カード上のファイルに、データ文字列を追記することができるようになりました。
 5.6.0

[In-Sight のネットワーク] ペインに次の機能が追加されました。

  • In-Sight デバイス (ビジョンシステム、ビジョンセンサ、エミュレータおよびホストテーブル) のモデル、IP アドレス、MAC アドレスおよびファームウェアバージョン情報を表示、非表示することができるようになりました。
  • In-Sight デバイスをグループ化することができるようになりました。
  • [フィルタ] テキストボックスおよび [適用] ボタンを使用し、複数のトークンを用いて In-Sight デバイスをフィルタすることができるようになりました。
注: これらの変更により、SD カードおよび RAM ディスクフォルダが [In-Sight のネットワーク] ペインに表示されなくなりました。 これらのフォルダを表示するには、[In-Sight のファイル] ペインをご使用ください。
 5.6.0 & 4.10.5

新しいカラーパターンマッチツール、PatMax RedLine™ Color が導入されました。24 ビットカラー画像上で登録された特徴を、グレースケールに変換せずに検出します。 PatMax RedLine Color は、TrainPatMaxRedLineColor および FindPatMaxRedLineColor (ビジョンツール > パターンマッチ) の 2 つの関数からなります。 TrainPatMaxRedLineColor 関数はパターンを登録し、FindPatMaxRedLineColor 関数は画像内の 1 つあるいは複数のパターンインスタンスを検出するのに使用されます。

 5.6.0
In-Sight 2000-130 および 2000-130C ビジョンセンサのパターン位置決めツールおよびパターン有無判定ツールが、PASS/FAIL ステータスに加え、パターンの得点を返すようになりました。 | 5.6.0
[In-Sight のホストテーブル] ダイアログに、[センサタイプ] コントロールが追加されました。[In-Sight のネットワーク] ペインに表示する In-Sight のモデルを選択することが出来ます。 | 5.6.0 & 4.10.5

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。 5.x.x リリースノートは『In-Sight Explorer ヘルプファイル』(英語版) でもご覧いただけます。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正 | ファームウェアバージョン
N/A | PLC などの外部デバイスから EtherNet/IP または PROFINET 通信を介し、TestRun を開始することができるようになりました。 EtherNet/IP および PROFINET ファクトリ通信プロトコルも更新され、ビジョンシステム上の TestRun を信号によって操作することができるようになりました。 | 5.6.0
77914 | ファームウェアバージョン 4.10.x を搭載した In-Sight ビジョンシステムで、LatchString 関数が条件付きで有効にされている場合に、メモリーリークが発生する問題を解決しました。 | 4.10.5
77750 | In-Sight 2000 シリーズビジョンセンサのパターン位置決めツールおよびパターン有無判定ツールから、自動タイムアウトのオプションが削除されました。 | 5.6.0
46620 | 部分的に取得した画像がロードされたときに、GreysScaleDistance 関数により In-Sight ビジョンシステムまたはエミュレータが応答しなくなる問題を解決しました。 | 5.6.0 & 4.10.5

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
79668 | In-Sight 2000 シリーズカラービジョンセンサが Web HMI に接続され、なおかつ画像を可能な限り高速で取得している場合、トリガ速度が大幅に下がることがあります。 | 5.6.0
79652 | ファームウェアバージョン 5.6.0 を搭載した In-Sight 2000 シリーズビジョンシステムでは、ビュー接続数 (In-Sight Explorer、VisionView または Web HMI) は最大 2 となります。 | 5.6.0
79345 | Web HMI が使用されている場合、PROFINET サイクリック I/O を 8ms 以上で実行しないでください。 | 5.6.0
79073

HMI サーバを有効にした In-Sight 2000 ビジョンセンサを高トラフィックネットワークを介し HMI に接続している場合、安定性の問題が発生し不応答状態になったり、ネットワークから切断されたりすることが報告されています。 こういった条件下では、ビジョンセンサおよび HMI を隔離されたネットワークに移動するか、またはビジョンセンサを直接 HMI に接続してください。

回避策: ビジョンセンサに電源を再投入してください。

 5.6.0
78064

ファームウェアバージョン 5.6.0 を搭載した In-Sight 8000 シリーズビジョンシステムまたは In-Sight 2000 シリーズビジョンセンサをファームウェアバージョン 5.5.x 以前にダウングレードする場合、英語以外のファイルがビジョンシステム/センサから削除されてしまうことがあります。 ダウングレード前に [バックアップ] ダイアログを使用してファイルを手動でバックアップしても、ダウングレード後、ファイルはリストアされません。

回避策: 英語以外のファイルをリストアするには、次の方法を行ってください。

  • In-Sight Explorer 5.6.0 を使用してファームウェアをダウングレードする場合、[ファームウェアアップデート] ダイアログ ([システム] > [アップデートファームウェア]) 内、[新しいバージョン] コラムのドロップダウンを使用して、使用するファームウェアバージョンを選択します。
  • In-Sight Explorer 5.5.x 以前を使用してファームウェアをダウングレードする場合、ファームウェアアップデートプロセスを 2 度行ってください。 2 度目のファームウェアアップデートプロセスで、英語以外のファイルがビジョンシステム/センサにリストアされます。
 5.5.x 以前
48636 | In-Sight 5.5.0 以降のファームウェアが搭載された状態で出荷された In-Sight 7600/7800 シリーズビジョンシステムを、In-Sight 5.4.1 以前のファームウェアにダウングレードした場合、電源再投入後、再起動まで約 4 分間かかることがあります。 | 5.4.1 以前
48478 | In-Sight 5.6.0 ファームウェアが搭載された In-Sight ビジョンシステムに多数の ReadIDMax 関数を使用したジョブがロードされている場合、ビジョンシステム上で使用可能なメモリより多くのメモリが必要となることがあります。その場合、使用可能なメモリを超過した ReadIDMax 関数は #ERR を返してしまいます。 例えば、100 以上の ReadIDMax 関数を使用したジョブが In-Sight 8405 ビジョンシステムにロードされている場合、この問題が発生する可能性があります。 | 5.6.0
45581 | CIP-Sync/PTP に設定した In-Sight 7600/7800 ビジョンシステムでは、トランスパレントクロックスイッチによる 1588 同期の正確性が、マスターからのオフセットより 10µs 以上大きくなることがあります。 | 5.6.0
43186 | In-Sight 2000 シリーズビジョンセンサ接続時、[通信] アプリケーションステップで、シリアルテキスト、シリアルネイティブ、TCP/IP または UDP デバイスを設定する際に、[FormatString] ダイアログの [出力文字列] ボックスに #ERR が表示されます。 出力文字列を参照するには、[OK] をクリックしてダイアログを閉じてください。その後、[フォーマット出力文字列] タブに出力文字列が正しく表示されます。 | 5.6.0
42550 | In-Sight Track & Trace ジョブは、5.1.0 以降のファームウェアを搭載した In-Sight モデルではサポートされていません。 | 5.6.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.6.0
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.5


In-Sight® Explorer 5.5.0 リリースノート

© Copyright 1999-2017 Cognex Corporation. All rights reserved.

Version: 5.5.0.8, 11/20/2017

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 1.8GHz 動作の Intel® Celeron® 1000M プロセッサ (または同等品)
  • 2GB の RAM 空き容量
  • 4GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、同時に 4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 8GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Microsoft® Windows® 10 Professional (64 ビット)
  • Windows® 7 Professional サービスパック 1 (64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかの Windows オペレーティングシステムにもインストール可能で、動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム/センサ

サポートしているファームウェアバージョン

In-Sight Explorer 5.5.0 には、In-Sight 5.5.0、In-Sight 5.2.2 および In-Sight 4.10.4 の 3 種類のファームウェアバージョンが含まれています。 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

In-Sight ファームウェア 5.5.0

  • In-Sight 2000 シリーズビジョンセンサ
  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight 7600/7800 シリーズビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 4.10.4

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム (In-Sight 7600/7800 シリーズビジョンシステムを除く)

Microsoft .NET Framework 4.5

In-Sight ソフトウェアには、Microsoft .NET Framework 4.5 が必要です。 システムに検出されない場合、自動的にインストールされます。

新しい機能

新しい機能 | ファームウェアバージョン
In-Sight 7600C、7800C、7801C、7802C、8200C、8400C、8401C および 8402C カラービジョンシステムに新たに対応しました。 | 5.5.0
In-Sight 2000 Mini ビジョンセンサモデル (In-Sight 2000-110 Mini、2000-120 Mini、2000-120C Mini、2000-130 Mini および 2000-130C Mini) に新たに対応しました。オートフォーカス機能を持つリキッドレンズを装備しています。 | 5.5.0
In-Sight 2000-23M ビジョンセンサに新たに対応しました。位置決めツール、有無判定ツール、寸法測定ツール、計数ツール、幾何・計測ツール、演算 & ロジックツール、プロットツール、キャリブレーションツールなどの、EasyBuilder の拡張ツールセットを使用することができます。 | 5.5.0
BeadFind および BeadInspection 関数 (ビジョンツール > エッジ検査) が追加されました。接着剤ビード検査アプリケーションに使用します。 | 5.5.0

In-Sight 2000 シリーズビジョンセンサの新機能:

  • EasyBuilder ピクセル計数およびカラーピクセル計数有無判定ツールに [詳細の表示] トグルボタンが追加されました。 カウントされたピクセルを EasyBuilder の画像エリアに常に表示するかどうかを定義したり、VisionView 上でカウントされたピクセルを表示するかどうかを定義したりすることができます。
  • EasyBuilder の [画像の設定] アプリケーションステップが、タブ付きのインターフェースになりました。
  • EasyBuilder の [画像の設定] アプリケーションステップに、[フォーカス] タブが追加されました。 オートフォーカスなどのフォーカス設定を行うことができます (In-Sight 2000 Mini ビジョンセンサのみ)。

  • EasyBuilder の [画像の設定] アプリケーションステップに、[キャリブレーションタイプ] ドロップダウンが追加されました。[FOV (幅)] または [インポート] オプションを選択し、検査ツールをピクセルから実単位に変換またはキャリブレートします。

    注: [キャリブレーションタイプ] および [FOV (幅)] オプションは、In-Sight 2000-130/130C および 2000-23M ビジョンセンサでのみ使用できます。 [インポート] オプションは、In-Sight 2000-23M ビジョンセンサでのみ使用できます。
  • グループ演算＆ロジックツールをサポートするようになりました。このツールは、位置決めおよび検査ツールをグループ化します。その結果、ツール実行は連結され、グループ内のツールは有効ステータスを共有します (In-Sight 2000-130 および 2000-130C ビジョンセンサのみ)。

  • 複数の独立した位置決めツールのフィクスチャをジョブ内でサポートするようになりました (In-Sight 2000-130 および 2000-130C ビジョンセンサのみ)。

    注: In-Sight 2000-110、2000-120 および 2000-120C ビジョンセンサでは、サポートするフィクスチャは、1 つのみです。
  • シリアルネイティブ通信プロトコルに対し、Get Value (GV) ベーシックネイティブモードコマンドをサポートするようになりました。
 5.5.0

In-Sight 7600/7800 シリーズビジョンシステムの SD カードに次の新機能が追加されました:

  • WriteLocal および WriteImageLocal 関数 (入出力 > LocalStorage) が追加されました。検査データや画像をオンライン中に SD カードに書き込みます。
  • EasyBuilder の [通信] アプリケーションステップから、SD カードに画像を転送する機能が追加されました。
  • [バックアップ] および [リストア] ダイアログに [SD カードを使用] オプションが追加されました。 [選択してリストア] ダイアログに [SD カード] および [バックアップセット] オプションが追加されました。
 5.5.0
EasyBuilder ビューにおいて、[登録の入力] コントロールが、パターン/パターン (1-10) 位置決めツール、パターン有無判定ツールおよびパターン計数ツールに追加されました。 入力ラインを介してモデルパターンを登録することができます。 | 5.5.0

In-Sight 5.5.0 ファームウェアを搭載したビジョンシステムで、センサフィルムストリップが、PASS/FAIL の結果をフィルムストリップ内で別々に表示するようになりました。 [センサフィルムストリップの設定] ダイアログが更新され、[キュー] ドロップダウンに [成功/失敗結果を分ける] オプションが追加されました。 このオプションを選択すると、

  • [センサフィルムストリップの設定] ダイアログの PASS 結果および FAIL 結果コントロールが ON になり、ビジョンシステムに保存される PASS/FAIL 結果の数を指定することができます。
  • フィルムストリップに PASS 結果および FAIL 結果ボタンが表示され、このボタンをトグルしてフィルムストリップに PASS/FAIL 結果を表示することができます。
 5.5.0
EtherNet/IP および PROFINET 通信を使用して、ファイル名によってジョブをロードする機能が追加されました。 以前は、PLC からジョブ ID を使用してジョブをロードすることしかできませんでした。 | 5.5.0
EasyBuilder の [ジョブの保存] アプリケーションステップの [スタートアップのオプション] グループボックスに、[スタートアップ] ダイアログを開くボタンが追加されました。 | 5.5.0 & 4.10.4

[スタートアップ] ダイアログに次の機能が追加されました。

  • [スタートアップ時にジョブをロード] チェックボックスが追加されました。接続中のビジョンシステムや、接続中の In-Sight 7600/7800 シリーズビジョンシステムにインストールされた SD カードまたはエミュレータに保存されたジョブから、スタートアップジョブを選択することができます。

  • [スタートアップ時にリモートからジョブをロード] チェックボックスが追加されました。ジョブサーバに保存されたジョブからスタートアップジョブを選択することができます。

    注: [ジョブサーバの設定] ダイアログで [ジョブサーバの有効化] を ON に設定した場合のみ、このチェックボックスは表示されます。
  • [オンライン] チェックボックスが、[起動時にオンラインモードにする] チェックボックスに名称変更されました。 チェックボックスを ON にすると、In-Sight ビジョンシステムはオンラインモードで起動します。
 5.5.0 & 4.10.4

[センサデバイスをネットワークに追加] ダイアログに、[すべて表示] および [新規を表示] ラジオボタンが追加されました。

  • [新規を表示] が選択されている場合 (デフォルト)、サブネット上で無効なネットワーク設定がされている In-Sight デバイスのみがダイアログに表示されます。 また、このダイアログが開いている時に In-Sight デバイスに電源が再投入されると、そのデバイスはリストに追加されます。
  • [すべて表示] が選択されている場合、サブネット上に検出されたすべての In-Sight デバイスが表示されます。
 5.5.0 & 4.10.4
対話型グラフィックスモード時に、動作を取り消すことができるようになりました。 最後の動作を取り消すには、[標準] ツールバーの [取り消し] ボタンをクリックするか、CTRL+Z キーボードショートカットを使用してください。 | 5.5.0 & 4.10.4

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。 5.x.x リリースノートは『In-Sight Explorer ヘルプファイル』(英語版) でもご覧いただけます。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正 | ファームウェアバージョン

47602

47414

スプレッドシートビューで、TrainMatchColor 関数および GetSaturation カラービジョンデータアクセス関数が、正しい HSI 彩度値 (0～255) を返すようになりました。 EasyBuilder ビューで、カラーツールが、正しい HSI 彩度値 (0～255) を返すようになりました。 以前は、181 を超える非常に飽和度の高い画像でも、0～181 の間で HSI 彩度値が返されていました。

注: この関数またはツールを含むジョブが In-Sight ファームウェアバージョン 5.4.x 以前で作成され、In-Sight ファームウェアバージョン 5.5.0 を搭載したビジョンシステムにロードされた場合、正しい HSI 彩度値を返すよう、カラーを再登録する必要があります。
 5.5.0

47535

ExtractColor 関数が改善されました。

  • ExtractColor 関数のスピードが改善されました。
  • ExtractColor 関数の[出力画像] パラメータのデフォルト値が [バイナリ画像] となり、バイナリのグレースケール画像が出力されるようになりました。 以前は、デフォルト値が [マークした画像] で、マークした画像を出力したため、処理時間が長くかかっていました。
 5.5.0

46771

ExtractColorHistogram 関数が改善されました。 この変更は、以前のファームウェアバージョンと互換性があります。

  • ExtractColorHistogram 関数のスピードおよび処理が改善されました。
  • ExtractColorHistogram 関数が、正しい HSI 値を返すようになりました。 以前は、画像の彩度の値が 255 以下の場合でも、彩度の値が誤って 255 の値で返されていました。
  • ExtractColorHistogram 関数の [HSI] パラメータが [カラーモード] に名称変更されました。
  • ExtractColorHistogram 関数の [カラーモード] パラメータに次の変更が追加されました。
    • HSI のパフォーマンスを最適化するため、新たに [HSI] パラメータ (カラーモード = 2) が追加されました。 このオプションを選択すると、各入力ピクセルの色相、彩度および明度の要素が計算され、ヒストグラムとして表示されます。
    • [HSI] パラメータが [RGB+HSI] に名称変更されました (カラーモード =1)。
    • [RGB] (カラーモード = 0) を選択すると、色相、彩度、明度ビジョンデータアクセス関数は #ERR を返します。 [HSI] (カラーモード = 2) を選択すると、赤、緑、青ビジョンデータアクセス関数は #ERR を返します。
注: この関数を含むジョブが In-Sight ファームウェアバージョン 5.4.x 以前で作成され、In-Sight ファームウェアバージョン 5.5.0 を搭載したビジョンシステムにロードされた場合、以前のファームウェアバージョンと比較して、領域の X、Y、高さおよび幅ピクセル値、平均 RGB 結果が多少異なる可能性があります。
 5.5.0
43237 | In-Sight 7600/7800 シリーズおよび In-Sight 8000 シリーズビジョンシステムにおいて、高速出力でサポートされているパルス幅が、1ms～1000ms になりました。 以前は、サポートされているパルス幅は10ms～1000ms でした。 | 5.5.0

32797

32781

32761

32639

PatMax RedLineTM が改善されました。

  • FindPatMaxRedLine 関数が改善され、オーバーラップ結果をより正確に検出することができるようになりました。 この変更により、ツールの XY オーバーラップパラメータの値が慎重に調整されているジョブでは、このパラメータを再調整してください。
  • 次の関数およびツールが改善され、フィクスチャされたサーチ領域に対するタイムペナルティがなくなり、検査サイクル時間が短縮されました。 さらに、[極性を無視] を ON にしたり、視野内に複数のマッチがある場合に、マッチが低くても、より正確なスコアを提供するようになりました。
    • スプレッドシートの FindPatMaxRedLine および TrainPatMaxRedLine 関数。
    • EasyBuilder 位置決めツール: PatMax RedLine Pattern および PatMax RedLine パターン (1-10).
    • EasyBuilder 検査ツール: PatMax RedLine パターン有無判定ツール、PatMax RedLine パターン計数ツール、PatMax RedLine パターン (1-10) 識別ツール。
注: In-Sight ファームウェア 5.5.0 で作成されたこの関数またはツールを含むジョブが、In-Sight ファームウェアバージョン 5.4.x 以前 を搭載したビジョンシステムにロードされた場合、エラーメッセージが表示され、この関数を含むセルに #ERR が表示されます。
 5.5.0
N/A | EditPolygon および EditPolylinePath 関数 (画面表示 > オペレータI/F) が変更され、ポリライン編集を簡単に行うことができるようになりました。 | 5.5.0

32542

EasyBuilder サンプルジョブが、ファームウェアバージョン 5.5.0 以降を搭載したビジョンシステムまたはビジョンセンサでサポートされるようになりました。

  • EasyBuilder 5.x.x サンプルジョブのデフォルトロケーション:

    C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Explorer 5.5.0\Sample Jobs\EasyBuilder\5x

  • EasyBuilder 4.x.x サンプルジョブのデフォルトロケーション:

    C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Explorer 5.5.0\Sample Jobs\EasyBuilder\4x

 5.5.0
31638 | PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更し、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようとした場合に、正常に接続が確立されるようになりました。 | 5.5.0
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択した場合に、アドレスマップファイルが破損する不具合が解決されました。

 4.10.4
26990 | 三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行した場合に、エラーコード C05C が正しく発行されない不具合が解決されました。 | 4.10.4

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
48636 | In-Sight 5.5.0 ファームウェアが搭載された状態で出荷された In-Sight 7600/7800 シリーズビジョンシステムを、In-Sight 5.4.1 以前のファームウェアにダウングレードした場合、電源再投入後、再起動まで約 4 分間かかることがあります。 | 5.4.1 以前
48478 | In-Sight 5.5.0 ファームウェアが搭載された In-Sight ビジョンシステムに多数の ReadIDMax 関数を使用したジョブがロードされている場合、ビジョンシステム上で使用可能なメモリより多くのメモリが必要となることがあります。その場合、使用可能なメモリを超過した ReadIDMax 関数は #ERR を返してしまいます。 例えば、100 以上の ReadIDMax 関数を使用したジョブが In-Sight 8405 ビジョンシステムにロードされている場合、この問題が発生する可能性があります。 | 5.5.0
46914 | EasyBuilder ジョブを In-Sight 4.7.3 以前のファームウェアを使用して作成し、In-Sight 5.x.x ファームウェアを搭載したビジョンシステムにロードした場合、ジョブ内のシンボリックタグが削除されることがあります。 | 5.1.0 以降
45581 | CIP-Sync/PTP に設定した In-Sight 7600/7800 ビジョンシステムでは、トランスパレントクロックスイッチによる 1588 同期の正確性が、マスターからのオフセットより 10µs 以上大きくなることがあります。 | 5.5.0
43186 | In-Sight 2000 シリーズビジョンセンサ接続時、[通信] アプリケーションステップで、シリアルテキスト、シリアルネイティブ、TCP/IP または UDP デバイスを設定する際に、[FormatString] ダイアログの [出力文字列] ボックスに #ERR が表示されます。 出力文字列を参照するには、[OK] をクリックしてダイアログを閉じてください。その後、[フォーマット出力文字列] タブに出力文字列が正しく表示されます。 | 5.5.0
42550 | In-Sight Track & Trace ジョブは、5.1.0 以降のファームウェアを搭載した In-Sight モデルではサポートされていません。 | 5.5.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.5.0
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.4
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.5.0


In-Sight® Explorer 5.4.1 リリースノート

© Copyright 1999-2017 Cognex Corporation. All rights reserved.

バージョン: 5.4.1.11, 05/23/2017

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Microsoft® Windows® 10 Professional (64 ビット)
  • Windows® 7 Professional サービスパック 1 (64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはテストされておらず、サポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

サポートしているファームウェアバージョン

In-Sight Explorer 5.4.1 には、In-Sight 4.10.4、In-Sight 5.2.2 および In-Sight 5.4.1 の 3 種類のファームウェアバージョンが含まれています。 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

In-Sight ファームウェア 4.10.4

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム (In-Sight 7600/7800 シリーズビジョンシステムを除く)

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 5.4.1

  • In-Sight 2000 シリーズビジョンセンサ
  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight 7600/7800 シリーズビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。 システムに検出されない場合、自動的にインストールされます。

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。 5.x.x リリースノートは『In-Sight Explorer ヘルプファイル』(英語版) でもご覧いただけます。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正 | ファームウェアバージョン
41201

EasyBuilder ビューの [通信] アプリケーションステップで、通信プロトコルが最大 2 つまで追加できるようになりました。 2 つのプロトコルを追加する場合、TCP/IP または UDP プロトコルを他のプロトコルに併せて追加することができます。 以前は、EasyBuilder ビューでは、1 つのプロトコルのみ追加可能でした。

 5.4.1
46302 | WriteResultsBuffer 関数 (入出力関数 > ネットワーク)、ReadUserDataBuffer 関数 (入出力関数 > ネットワーク) および ReadLatchedUserDataBuffer 関数 (入出力関数 > ネットワーク) が更新され、EtherNet/IP、PROFINET および SLMP スキャナプロトコルの [バイト/ワードオーダ] パラメータをサポートするようになりました。 以前は、 [バイト/ワードオーダ] パラメータは Modbus TCP サーバでのみサポートされていました。 | 5.4.1
46381

EasyBuilder ビューの [通信] アプリケーションステップで、EtherNet/IP、PROFINET および SLMP スキャナプロトコルの [フォーマット入力データ] および [フォーマット出力データ] タブに次の変更が追加されました。

  • [データ型] ドロップダウンが更新され、[バイト変換文字列] オプションが追加されました。
  • [ハイバイト/ローバイト] および [ハイワード/ローワード] チェックボックスが追加されました。

以前は、これらのオプションは、Modbus TCP サーバでのみサポートされていました。

 5.4.1

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
45581 | CIP-Sync/PTP に設定した In-Sight 7600/7800 ビジョンシステムでは、トランスパレントクロックスイッチによる 1588 同期の正確性が、マスターからのオフセットより 10µs 以上大きくなることがあります。 | 5.4.1
43186 | In-Sight 2000 シリーズビジョンセンサ接続時、[通信] アプリケーションステップで、シリアルテキスト、シリアルネイティブ、TCP/IP または UDP デバイスを設定する際に、[FormatString] ダイアログの [出力文字列] ボックスに #ERR が表示されます。 出力文字列を参照するには、[OK] をクリックしてダイアログを閉じてください。その後、[フォーマット出力文字列] タブに出力文字列が正しく表示されます。 | 5.4.1
42550 | In-Sight Track & Trace ジョブは、5.1.0 以降のファームウェアを搭載した In-Sight モデルではサポートされていません。 | 5.4.1
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.4.1
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。 あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.4.1
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.4.1
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.4.1
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。 例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.4.1
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.4
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.4
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。 オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.4


In-Sight® Explorer 5.4.0 リリースノート

© Copyright 1999-2017 Cognex Corporation. All rights reserved.

Version: 5.4.0.21, 05/04/2017

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Microsoft® Windows® 10 Professional (64 ビット)
  • Windows® 7 Professional サービスパック 1 (64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはテストされておらず、サポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

サポートしているファームウェアバージョン

In-Sight Explorer 5.4.0 には、In-Sight 4.10.4、In-Sight 5.2.2 および In-Sight 5.4.0 の 3 種類のファームウェアバージョンが含まれています。 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

In-Sight ファームウェア 4.10.4

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム (In-Sight 7600/7800 シリーズビジョンシステムを除く)

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 5.4.0

  • In-Sight 2000 シリーズビジョンセンサ
  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight 7600/7800 シリーズビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。 システムに検出されない場合、自動的にインストールされます。

新しい機能

新しい機能 | ファームウェアバージョン
このリリースでは、In-Sight 7600、7800、7801 および 7802 ビジョンシステムに新たに対応しました。 In-Sight 7600/7800 シリーズビジョンシステムは、C マウントまたは S マウントレンズを使用することができます。 また、標準および拡張レンズカバー、S マウントオートフォーカスアクセサリ、In-Sight 照明アクセサリ、DataMan 照明アクセサリなどといった、幅広いアクセサリ構成をサポートしています。 更に、CIO-MICRO および CIO-1400 I/O モジュールや、CIP Sync/1588 をサポートし、ジョブファイルおよび画像保存用の SD カードがインストールされた状態で出荷されます。 | 5.4.0
スプレッドシートビュー: [ディスクリート入力設定] および [ディスクリート出力設定] ダイアログが 1 つにまとめられ、[ディスクリート I/O の設定] ダイアログになりました。 | 5.4.0 & 4.10.4
スプレッドシートビュー: [ジョブの PASS/FAIL セル] 出力信号タイプは、In-Sight 7600/7800 シリーズビジョンシステム接続時のみに使用できます。 この設定が選択された場合、指定のジョブ PASS/FAIL セルの現在のステータスに基づき、ビジョンシステムの PASS/FAIL LED およびインジケータリングが、緑 (PASS) または赤 (FAIL) に点灯します。 | 5.4.0
EasyBuilder ビュー: [入力] および [出力] アプリケーションステップが 1 つにまとめられ、[入力/出力] アプリケーションステップになりました。 | 5.4.0
EasyBuilder ビュー: [ジョブの PASS/FAIL セル] 出力信号タイプが追加されました。In-Sight 7600/7800 シリーズビジョンシステム接続時のみに使用できます。 現在のジョブ全体の PASS/FAIL ステータスに基づき、ビジョンシステムの PASS/FAIL LED およびインジケータリングが、緑 (PASS) または赤 (FAIL) に点灯します。 | 5.4.0
双方向 I/O サポートをビジョンシステムに追加しました。入力または出力に設定した信号をサポートします。 | 5.4.0
[三色 LED] オプションを [出力詳細] ダイアログに追加しました。In-Sight 7600/7800 シリーズビジョンシステムの三色の LED ラインの動作を設定します。 | 5.4.0
[外部照明の設定] ダイアログが、[照明の設定] ダイアログに名称変更されました。 | 5.4.0 & 4.10.4
EasyBuilder ビュー: [照明の設定] ボタンが [画像の設定] アプリケーションステップに追加されました。 In-Sight 7600/7800 シリーズビジョンシステム接続時のみに使用できます。 クリックすると、[照明の設定] ダイアログが開き、装着済の組み込みデバイスまたは外部照明デバイスを設定することができます。 | 5.4.0
[照明の設定] ダイアログが更新され、In-Sight 7600/7800 シリーズビジョンシステムをサポートするようになりました。 ダイアログの内容は、ビジョンシステム (In-Sight 7000 シリーズまたは In-Sight 7600/7800 シリーズ) や、接続されている照明アクセサリのタイプによって異なります。 | 5.4.0
IntegratedLightControl 関数 (入出力) が追加されました。In-Sight 7600/7800 シリーズビジョンシステムのフェースプレートに接続された In-Sight および DataMan 組み込み照明アクセサリを設定します。 | 5.4.0
ExternalLightControl 関数 (入出力) が追加されました。In-Sight 7600/7800 シリーズビジョンシステムの Light コネクタに接続された外部照明アクセサリを設定します。 | 5.4.0
Event 関数 (入出力) が更新され、[チューニングボタン] パラメータが追加されました。 このパラメータを選択した場合、In-Sight 7600/7800 シリーズビジョンシステムの Tune ボタンを押すと、スプレッドシートが更新されます。 | 5.4.0
EditFocusPosition および GetCurrentFocusPosition 関数 (フォーカス関数) が更新され、In-Sight 7600/7800 シリーズビジョンシステムをサポートするようになりました。 | 5.4.0
ライブビデオモードに、[リセット] ボタンが追加されました。オートフォーカスアクセサリがインストールされた In-Sight 7000 シリーズまたは In-Sight 7600/7800 シリーズビジョンシステム接続時に使用できます。 このボタンをクリックすると、デフォルトのフォーカス位置がリセットされます。 | 5.4.0 & 4.10.4
SurfaceFX 関数 (ビジョンツール > 画像フィルタ) が追加されました。照明およびソフトウェアのアルゴリズムを使用して、高コントラストの画像を生成し、パーツの 3D 特徴を強調します。 表面の背景からノイズ/クラッタを取り除き、凹凸状の特徴/欠陥を分離します。 高コントラスト画像の取得後、OCRMax、RedLine、Blob および InspectEdge などのビジョンツールを使用して、検査を実行することができます。 | 5.4.0
Encrypt 関数 (文字列操作 > ストリング関数) が追加されました。結果データをユーザ指定のキーを用いて暗号化します。 暗号化したデータを In-Sight 関数またはネイティブモードコマンドなどを使用して PC や外部デバイスに送信し、復号化アプリケーションを用いてデータを復元します。 注: Cognex In-Sight Encryption サンプルアプリケーションを使用して、キーを作成したりデータを復号化することができます。 | 5.4.0

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。 5.x.x リリースノートは『In-Sight Explorer ヘルプファイル』(英語版) でもご覧いただけます。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正 | ファームウェアバージョン
39213

三菱 PLC/モーションコントローラのドロップダウンが更新され、iQ-F シリーズ (3E フレーム) コントローラ専用のオプションが新たに追加されました。 以前は、iQ-F シリーズを使用する場合、このコントローラがサポートするデバイスは他の 3E フレームコントローラとは異なるにも関わらず、[iQ-F/R/Q/L シリーズ (3E フレーム)] オプションをドロップダウンから選択する必要がありました。

影響するドロップダウンは以下の通りです。

  • コントローラタイプ - [SLMP スキャナ設定] ダイアログ
  • コントローラタイプ - SLMP デバイスおよび SLMP スキャナデバイスの [設定] タブ (EasyBuilder 通信アプリケーションステップ)
  • PLC シリーズ - ReadMC および WriteMC プロパティシート
 5.4.0
N/A | GetStringIDMax (データ・アクセス > IDMax) が修正され、新しい変換モード (0 および 3) が追加されました。 モード 0 は、印刷不可のASCII文字を変換しません (未処理の文字列を返します)。 モード 3 は、印刷不可のASCII文字を変換しません (未処理の文字列を返します) が、null 文字は "<NUL>" に置換されます。 | 5.4.0 & 4.10.4
31905 | In-Sight 2000 シリーズビジョンセンサおよび In-Sight Micro 8000 シリーズビジョンシステム接続時の [リンクスピード] ネットワーク設定に関しての問題が修正されました。 以前は、他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用していました。 | 5.4.0
36100 | [ピクセル計数メータおよび PASS 範囲] スライダーバーの最小/最大制限範囲ハンドルに関しての問題が修正されました。 以前は、ツールがポリゴン領域を使用している場合、ハンドルが検査のたびに左右にシフトしていました。 | 5.4.0
37342

GetAIDescription 関数 (データ・アクセス > GetAIDescription) および GetFieldIdentifier 関数 (データ・アクセス > GetFieldIdentifier) が更新され、次の GS1 アプリケーション識別子 (AI) をサポートするようになりました。

  • 16: 販売期限 (YYMMDD)
  • 255: クーポン識別番号 (GCN)
  • 710: 国家保険償還番号 - ドイツ IFA
  • 711: 国家保険償還番号 - フランス CIP
  • 712: 国家保険償還番号 - スペイン国家コード
  • 713: 国家保険償還番号 - ブラジル ANVISA
  • 80101: 部品・パーツ識別番号(CPID)
  • 80111: 部品・パーツ識別シリアル番号(CPID シリアル)
 5.4.0

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
45581 | CIP-Sync/PTP に設定した In-Sight 7600/7800 ビジョンシステムでは、トランスパレントクロックスイッチによる 1588 同期の正確性が、マスターからのオフセットより 10µs 以上大きくなることがあります。 | 5.4.0
44771 | In-Sight 2000-130/130C ビジョンセンサを 5.4.0 から 5.3.0 にダウングレードすると、センサの解像度が 800 x 600 (画像拡大モード) に設定されます。 解像度を変更するには、[システム] メニューから [画像の設定] ダイアログを開き、[解像度] を 640 x 480 に変更してください。 | 5.4.0
43186 | In-Sight 2000 シリーズビジョンセンサ接続時、[通信] アプリケーションステップで、シリアルテキスト、シリアルネイティブ、TCP/IP または UDP デバイスを設定する際に、[FormatString] ダイアログの [出力文字列] ボックスに #ERR が表示されます。 出力文字列を参照するには、[OK] をクリックしてダイアログを閉じてください。その後、[フォーマット出力文字列] タブに出力文字列が正しく表示されます。 | 5.4.0
42550 | In-Sight Track & Trace ジョブは、5.1.0 以降のファームウェアを搭載した In-Sight モデルではサポートされていません。 | 5.4.0
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.4.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。 あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.4.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.4.0
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.4.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。 例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.4.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。 例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.4.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.4.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。 例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。 しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.4.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.4.0 & 4.10.4
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。 ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.4.0 & 4.10.4
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。 ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。.

 5.4.0 & 4.10.4
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.4
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。 逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.4
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.4
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。 オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.4


In-Sight® Explorer 5.３.0 リリースノート

© Copyright 1999-2016 Cognex Corporation. All rights reserved.

Version: 5.3.0.9, 11/29/2016

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight Explorer は、次のオペレーティングシステムで動作することを確認しています。

  • Microsoft® Windows® 10 Professional (64 ビット)
  • Windows® 7 Professional サービスパック 1 (64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはテストされておらず、サポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

サポートしているファームウェアバージョン

In-Sight Explorer 5.3.0 には、In-Sight 4.10.3、In-Sight 5.2.2 および In-Sight 5.3.0 の 3 種類のファームウェアバージョンが含まれています。 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

In-Sight ファームウェア 4.10.3

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 5.3.0

  • In-Sight 2000 シリーズビジョンセンサ
  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。 システムに検出されない場合、自動的にインストールされます。

新しい機能

In-Sight Explorer

新しい機能
In-Sight 2000-120C および 2000-130C カラービジョンセンサを新たにサポートするようになりました。
In-Sight 5.3.0 ファームウェアを搭載した In-Sight 2000 シリーズビジョンセンサが、In-Sight CIO-1400 I/O モジュールをサポートするようになりました。
In-Sight 5.3.0 ファームウェアを搭載した In-Sight 5705、5705C、5715 および In-Sight 8000 シリーズビジョンシステムが、In-Sight CIO-MICRO I/O モジュールをサポートするようになりました。

In-Sight 5.3.0 ファームウェアを搭載した In-Sight ビジョンシステムが、Modbus TCP サーバプロトコルをサポートするようになりました ([ネットワークの設定] ダイアログ、産業用イーサネットプロトコル)。

注: Modbus TCP サーバプロトコルは、In-Sight 4.10.3 以前のファームウェアを搭載した In-Sight ビジョンシステムでもサポートされていますが、Modbus TCP サーバ 5.3.0 の実装は、4.x.x の実装とは異なります。 詳細については、英語版 In-Sight Explorer ヘルプファイルの「Modbus TCP Communications 」トピックをご参照ください。
三菱 MELSEC iQ-F および iQ-R シリーズコントローラをサポートするようになりました ([SLMP スキャナの設定] ダイアログ)。

次のベーシックネイティブモードコマンドが In-Sight 2000 シリーズビジョンセンサでサポートされるようになりました。

  • ファイル & ジョブコマンド: Load File (LF)、Store File (TF)、Read File (RF)、Write File (WF)、Delete File (DF)、Get File (GF)、Set Job (SJ)、Store Job (TJ)、Read Job (RJ)、Write Job (WJ)、Delete Job (DJ)、Get Job (GJ)
  • 画像コマンド: Read BMP (RB)、Write BMP (WB)
  • 設定 & セルの値コマンド: Get Info (GI)、Read Settings (RS)、Write Settings (WS)、Store Settings (TS)、Set IP Address Lock (SL)、Get IP Address Lock (GL)
  • 実行 & オンラインコマンド: Set Online (SO)、Get Online (GO)、Reset System (RT).

In-Sight 4.10.3 ファームウェアを搭載した In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズおよび In-Sight 7000 シリーズビジョンシステムにおいて、センサフィルムストリップが、PASS/FAIL の結果をフィルムストリップ内で別々に表示するようになりました。 [センサフィルムストリップの設定] ダイアログが更新され、[キュー] ドロップダウンに [成功/失敗結果を分ける] オプションが追加されました。 このオプションを選択すると、

  • [センサフィルムストリップの設定] ダイアログの PASS 結果および FAIL 結果コントロールが ON になり、ビジョンシステムに保存される PASS/FAIL 結果の数を指定することができます。
  • フィルムストリップに PASS 結果および FAIL 結果ボタンが表示され、このボタンをトグルしてフィルムストリップに PASS/FAIL 結果を表示することができます。

EasyBuilder

新しい機能

次の機能が In-Sight 2000 シリーズカラービジョンセンサに追加されました。

  • カラーピクセル計数有無判定検査ツールが追加されました。検査対象領域内から、指定されたカラーを検出するのに使用します。
  • [ホワイトバランス領域] および [ホワイトバランスの設定] ボタンが [画像の設定] アプリケーションステップに追加されました。画像内の不正確なカラーキャスト (色かぶり) を取り除きます。

次の機能が In-Sight 2000-130 および 2000-130C ビジョンセンサに追加されました。

  • [FOV (幅)] コントロールが [画像の設定] アプリケーションステップに追加されました。距離および円の直径寸法測定検査ツールの結果を、実単位に変換します。

    注: 角度結果寸法測定検査ツールは角度の値を返します。
  • 寸法測定および計数検査ツールが、PASS/FAIL ステータス以外にも、数値の結果を返すようになりました。

In-Sight 5.3.0 ファームウェアを搭載した In-Sight ビジョンシステム/センサが、Modbus TCP サーバプロトコルをサポートするようになりました。

注: Modbus TCP サーバプロトコルは、In-Sight 4.10.3 以前のファームウェアを搭載した In-Sight ビジョンシステムでもサポートされています。
三菱 MELSEC iQ-F および iQ-R シリーズコントローラをサポートするようになりました ([通信] アプリケーションステップ)。

[形状] コントロール ([合成領域]、[モデル] および [サーチ] タブ) および [領域の変更] 右クリックオプション (画像中の [合成領域]、[モデル] および [サーチ領域] を右クリックすると表示されます) が追加されました。これより選択中の領域 (矩形、円、円環、ポリゴン) の形状を変更することができます。 この機能は次のツールでサポートされています。

注: [形状] コントロールは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  • 合成領域:
    • 位置決めツール: ブロブ、ブロブ (1-10)、カラーブロブ、カラーブロブ (1-10)
    • 有無判定ツール: 輝度、コントラスト、ピクセル計数、カラーピクセル計数、ブロブ、カラーブロブ
    • 寸法測定ツール: ブロブ面積、ブロブ面積 (1-10), カラーブロブ面積、カラーブロブ面積 (1-10)
    • 計数ツール: ブロブ、カラーブロブ
    • 識別ツール: カラー、カラーモデル
    • 欠陥検出ツール: 傷検査
  • モデルおよびサーチ領域:
    • 位置決めツール: PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10)、PatMax パターン (1-10)
    • 有無判定ツール: PatMax RedLine パターン、PatMax パターン
    • 計数ツール: PatMax RedLine パターン、PatMax パターン
    • 識別ツール: PatMax RedLine パターン (1-10)、PatMax パターン (1-10)

4.10.3 ファームウェアを搭載した In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズおよび In-Sight 7000 ビジョンシステムにおいて、センサフィルムストリップがフィルムストリップ内で PASS/FAIL 結果を別々に表示するようになりました。 [フィルムストリップ] アプリケーションステップが更新され、[キュー] ドロップダウンに [成功/失敗結果を分ける] オプションが追加されました。 このオプションを選択すると、

  • [フィルムストリップ] アプリケーションステップの PASS 結果および FAIL 結果コントロールが ON になり、ビジョンシステムに保存される PASS/FAIL 結果の数を指定することができます。
  • フィルムストリップに PASS 結果および FAIL 結果ボタンが表示され、このボタンをトグルしてフィルムストリップに PASS/FAIL 結果を表示することができます。

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。 5.x.x リリースノートは『In-Sight Explorer ヘルプファイル』(英語版) でもご覧いただけます。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正
40635 | リモートサブネット上の、固定 IP アドレスが付与された In-Sight 2000 ビジョンセンサに接続できるようになりました。 以前は、センサがサブネット上にある場合、DHCP で設定された場合のみ接続することができました。
35848 & 36340 | [SLMP スキャナの設定] ダイアログに、誤ったステータスメッセージ (“Connection has not been established” または “ERR String index: -1” ) が表示される不具合が修正されました。
N/A

5.3.0 ファームウェアを搭載している In-Sight ビジョンシステムにおいて、ReadUserDataBuffer、ReadLatchedUserDataBuffer および WriteResultsBuffer 関数が変更されました。

  • [プロトコル] パラメータを介し、[Modbus TCP サーバ] プロトコルをサポートするようになりました。
  • [バイト/ワードオーダ] パラメータが追加されました。 このパラメータは、[Modbus TCP サーバ] プロトコルが選択されたときのみ有効です。
43088 | In-Sight 2000 シリーズビジョンセンサが、[画像バッファ] ダイアログをサポートするようになりました ([センサ] メニュー > [画像バッファ])。 高速のアプリケーションでは、画像バッファの数を増やすことによって、画像取り込みトリガをミスする可能性を低くすることができます。
N/A | EasyBuilder が修正され、すべてのアプリケーションステップにおいて、[結果] タブがデフォルトで表示されるようになりました。
N/A | ビジョンシステムがオフライン時にヒストグラムを表示していた EasyBuilder ツールにおいて、ビジョンシステムがオンライン時にもヒストグラムが表示されるようになりました。
N/A | [連続トリガ] オプション ([画像] メニュー) が、In-Sight 8000 シリーズビジョンシステムおよび In-Sight 5705 and 5705C ビジョンシステムで使用できるようになりました。 以前は、このオプションは 2000 シリーズビジョンセンサでのみ使用可能でした。
N/A | [TCP/IP] および [UDP] プロトコル ([通信] アプリケーションステップ) がすべての In-Sight 2000 シリーズビジョンセンサモデルでサポートされるようになりました。 以前は、[TCP/IP] および [UDP] プロトコルは、In-Sight 2000-110 および 2000-120 ビジョンセンサではサポートされていませんでした。
N/A | [±10% スケール許容] ボタン (パターン位置決めツールおよびパターン有無判定ツール) がすべての In-Sight 2000 シリーズビジョンセンサモデルでサポートされるようになりました。 以前は、このボタンは In-Sight 2000-110 ビジョンセンサでは使用できませんでした。
N/A

EasyBuilder が修正され、In-Sight 2000 シリーズビジョンセンサにおいて、すべてのアプリケーションステップでピクセル計数およびカラーピクセル計数ツールの結果のグラフィックスが表示されるようになりました。

注: ビジョンセンサがオンラインの場合、選択されたピクセル計数またはカラーピクセル計数の結果のグラフィックスが表示されます。 ビジョンセンサがオフラインの場合、すべてのピクセル計数またはカラーピクセル計数ツールが表示されます。
41507 | [リアルタイムイーサネット] トリガオプション (AcquireImage プロパティシートおよび [画像の設定] アプリケーションステップ) が、[産業用イーサネット] に名称変更されました。 [ネットワークの設定] ダイアログの [リアルタイムイーサネット] グループボックスも、[産業用イーサネット] に名称変更されました。
N/A | [SLMP スキャナの設定] ダイアログの、[Q/L シリーズ (3E フレーム)] コントローラタイプが、[iQ-F/R/Q/L シリーズ (3E フレーム)] に名称変更されました。 EasyBuilder の [通信] アプリケーションステップ、[Q/L シリーズ (3E フレーム)] コントローラタイプも、[iQ-F/R/Q/L シリーズ (3E フレーム)] に名称変更されました。
42667

次の [画像の設定] コントロール/オプションが名称変更されました。

  • [目標輝度] コントロールが、[画像の目標輝度] に名称変更されました。
  • [照明制御モード] の [露光制御]、[常に ON]、[無効] オプションが、[ON (露光)]、[ON (連続)]、[OFF] に名称変更されました。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | 影響するファームウェアバージョン
43098

5.2.3 以前のファームウェアバージョンを搭載した In-Sight 2000 シリーズビジョンセンサで保存されたジョブをロードしたとき、露光時間設定の範囲により最大照明輝度が上がり、以前より明るい画像が取り込まれます。

  • 解像度 640x480: 露光時間 3.5ms～8.2ms
  • 解像度 640x480、画像拡大モード: 露光時間: 1.8ms～4.9ms
  • 解像度 640x480、画像拡大モード: 露光時間: 2.2ms～5.1ms
 5.3.0
42511

モノクロームの In-Sight 2000 シリーズビジョンセンサを手動露光で使用している場合、露光時間の設定に関わらず、取り込まれる画像は以前のファームウェアバージョンより、わずかに明るくなります。 画像の輝度の変更に影響を受けやすいアプリケーションでは、[画像の設定] アプリケーションステップで、[露光時間] の値を最大 180 ms下げ、以前のファームウェアバージョンの画像の輝度と同等にしてください。

注: 自動露光を使用している場合、[露光時間] は画像取り込みごとに調整されるため、この変更は影響ありません。
 5.3.0
43186 | In-Sight 2000 シリーズビジョンセンサ接続時、[通信] アプリケーションステップで、シリアルテキスト、シリアルネイティブ、TCP/IP または UDP デバイスを設定する際に、[FormatString] ダイアログの [出力文字列] ボックスに #ERR が表示されます。 出力文字列を参照するには、[OK] をクリックしてダイアログを閉じてください。その後、[フォーマット出力文字列] タブに出力文字列が正しく表示されます。 | 5.3.0
42550 | In-Sight Track & Trace ジョブは、5.1.0 以降のファームウェアを搭載した In-Sight モデルではサポートされていません。 | 5.3.0
36100 | ピクセル計数ツールがポリゴン領域を使用しているとき、[ピクセル計数メータおよび PASS 範囲] スライダーバーの最小/最大制限範囲ハンドルが、検査のたびに左右にシフトします。 このとき、最小/最大制限値は変更されず、検査結果に影響はありません。 | 5.3.0
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.3.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。 あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.3.0
31905 | In-Sight 2000 シリーズビジョンセンサおよび In-Sight Micro 8000 シリーズビジョンシステムでは、[リンクスピード] ネットワーク設定を指定することができません。 他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用します。 | 5.3.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.3.0
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.3.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。 例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.3.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。 例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.3.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.3.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。 例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。 しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.3.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.3.0 & 4.10.3
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。 ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.3.0 & 4.10.3
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。 ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。

 5.3.0 & 4.10.3
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.3
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。 逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.3
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.3
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。 オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.3


In-Sight® Explorer 5.2.4 リリースノート

© Copyright 1999-2016 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Windows® 7 Professional サービスパック 1 (32 および 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 4.10.2

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム

In-Sight Firmware 5.2.0 PR1

  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 5.2.4

  • In-Sight 2000 シリーズビジョンセンサ

サポートしているファームウェアバージョン

In-Sight Explorer 5.2.4 には、In-Sight 4.10.2、5.2.0 PR1、In-Sight 5.2.2 および In-Sight 5.2.4 の 4 種類のファームウェアバージョンが含まれています。 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。 システムに検出されない場合、自動的にインストールされます。

新しい機能

EasyBuilder

新しい機能

入力アプリケーションステップに [ジョブ変更 (パルス)] 信号タイプが追加されました。In-Sight 2000 シリーズのセンサにジョブファイルをロードします。 [ジョブ変更 (パルス)] 信号タイプを使用するには、ジョブ名が 0～31 の数字で始まるジョブが (例: 1PinInspection.job) 1 つ以上、センサに保存されている必要があります。
In-Sight 2000 シリーズセンサおよび In-Sight Micro 8000 シリーズビジョンシステムが、VisionView® 1.6.7 ソフトウェア/ファームウェアおよび EasyView をサポートするようになりました。VisionView に表示されるデータをカスタマイズします。

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正
35809 | In-Sight 5705、5705C または 8405 センサのジョブに EasyView が含まれる場合に、EasyView が VisionView に正しく表示されるようになりました。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
36100 | ピクセル計数ツールがポリゴン領域を使用しているとき、[ピクセル計数メータおよび PASS 範囲] スライダーバーの最小/最大制限範囲ハンドルが、検査のたびに左右にシフトします。 このとき、最小/最大制限値は変更されず、検査結果に影響はありません。 | 5.2.4
35848 & 36340 | [SLMP スキャナの設定] ダイアログに、接続が正常に確率された場合でも、誤ったステータスメッセージ (“Connection has not been established” または “ERR String index: -1” ) が表示されることがあります。 | 5.2.4
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.2.4 & 5.2.0 PR1
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。 あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.2.4 & 5.2.0 PR1
31905 | In-Sight 2000 シリーズビジョンセンサおよび In-Sight Micro 8000 シリーズビジョンシステムでは、[リンクスピード] ネットワーク設定を指定することができません。 他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用します。 | 5.2.4 & 5.2.0 PR1
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.2.0 PR1
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.2.0 PR1
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。 例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.2.0 PR1
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。 例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.2.0 PR1
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.2.0 PR1
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。 例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。 しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.2.0 PR1
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.2.0 PR1 & 4.10.2
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。 ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.2.0 PR1 & 4.10.2
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。 ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。

 5.2.0 PR1 & 4.10.2
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.2
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。 逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.2
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.2
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。 オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.2


In-Sight® Explorer 5.2.3 リリースノート

© Copyright 1999-2016 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この説では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight Explorer は、次のオペレーティングシステムで動作することを確認しています。

  • Windows® 7 Professional サービスパック 1 (32 ビットおよび 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 4.10.2

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.0 PR1

  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.2

  • In-Sight Advantage Engine

In-Sight ファームウェア 5.2.3

  • In-Sight 2000 シリーズビジョンセンサ

サポートしているファームウェアバージョン

In-Sight Explorer 5.2.3 には、In-Sight 4.10.2、In-Sight 5.2.0 PR1、In-Sight 5.2.2 および 5.2.3 の 4 種類のファームウェアバージョンが含まれています。以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に動作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。システムに検出されない場合、自動的にインストールされます。

新しい機能

EasyBuilder

新しい機能

入力アプリケーションステップに [ジョブ変更 (パルス)] 信号タイプが追加されました。In-Sight 2000 シリーズのセンサにジョブファイルをロードします。[ジョブ変更 (パルス)] 信号タイプを使用するには、ジョブ名が 0～31 の数字で始まるジョブが (例: 1PinInspection.job) 1 つ以上、センサに保存されている必要があります。
In-Sight 2000 シリーズセンサおよび In-Sight Micro 8000 シリーズビジョンシステムが、VisionView® 1.6.7 ソフトウェア/ファームウェアおよび EasyView をサポートするようになりました。VisionView に表示されるデータをカスタマイズします。

修正点

注:

  • 以前のリリースの変更内容については、以前のリリースノートを参照してください。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正
35809 | In-Sight 5705、5705C または 8405 センサのジョブに EasyView が含まれる場合に、EasyView が VisionView に正しく表示されるようになりました。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | 影響するファームウェアバージョン
36100 | ピクセル計数ツールがポリゴン領域を使用しているとき、[ピクセル計数メータおよび PASS 範囲] スライダーバーの最小/最大制限範囲ハンドルが、検査のたびに左右にシフトします。このとき、最小/最大制限値は変更されず、検査結果に影響はありません。 | 5.2.3
35848 & 36340 | 接続に成功したにも関わらず、[SLMP スキャナの設定] ダイアログに誤ったステータスメッセージ (“Connection has not been established” または “ERR String index: -1” ) が表示されることがあります。 | 5.2.3
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.2.3 & 5.2.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.2.3 & 5.2.0
31905 | In-Sight 2000 シリーズビジョンセンサおよび In-Sight Micro 8000 シリーズビジョンシステムでは、[リンクスピード] ネットワーク設定を指定することができません。他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用します。 | 5.2.3 & 5.2.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.2.0
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.2.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.2.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.2.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.2.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.2.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.2.0 & 4.10.2
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.2.0 & 4.10.2
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。.

 5.2.0 & 4.10.2
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.2
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.2
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.2
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.2


In-Sight® Explorer 5.2.2 リリースノート

© Copyright 1999-2016 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer ソフトウェアについて説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。 In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。 次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight ソフトウェアは、次のオペレーティングシステムで動作することを確認しています。

  • Windows® 7 Professional サービスパック 1 (32 および 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 4.10.2

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.0

  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 5.2.1

  • In-Sight 2000 シリーズビジョンセンサ

サポートしているファームウェアバージョン

In-Sight Explorer 5.2.2 には、In-Sight 4.10.2、In-Sight 5.2.0 および In-Sight 5.2.1 の 3 種類のファームウェアバージョンが含まれています。 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。 最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。 システムに検出されない場合、自動的にインストールされます。

ライセンス

In-Sight Explorer は、完全版とトライアル版の 2 種類のパッケージで配布されています。 完全版は全機能を使用でき、使用期限が設定されていません。 トライアル版は、30 日間使用でき、期限を過ぎると使用できなくなります。 なお、完全版では、ご使用のネットワークに In-Sight ビジョンシステムが存在しない状態で、In-Sight Explorer のエミュレーションモードを使用するには、オフラインプログラミングキーが必要になります。

新しい機能

注: 次の新機能は、In-Sight ファームウェアバージョン 4.10.2 を搭載した In-Sight ビジョンシステムとともに In-Sight Explorer 5.2.2 を使用したときのみ、使用可能です。

In-Sight Explorer

新しい機能
GetPolygon 関数が追加されました。 この関数は、[外部領域] パラメータを持つ関数の入力として使用可能なデータ構造体を返します。これにより、ブロブ境界内の画像処理が可能となります。

修正点

注:

  • この節では、In-Sight ファームウェアバージョン 4.10.2 を搭載した In-Sight ビジョンシステムとともに In-Sight Explorer 5.2.2 を使用したときの、変更点および修正点について説明します。 以前のリリースの変更内容については、以前のリリースノートを参照してください。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# | 変更/修正
32578 | In-Sight 5600 ビジョンシステムに接続し、AcquireImage 関数の [照明制御モード] パラメータが [常時点灯] に設定されている場合、装着した照明リング上の LED が常に点灯するようになりました。 以前は、[常時点灯] に設定されてた場合、装着した照明リング上の LED は指定した露光時間のみ点灯していました。
36198 | In-Sight 7000 シリーズが DHCP ネットワークを介し PC に 直接接続されている場合、ビジョンシステムがネットワークに正常に常時接続されるようになりました。 以前は、ファームウェアバージョン 4.9.3 が搭載されたビジョンシステムが DHCP 接続を介し PC に直接接続されていた場合、ビジョンシステムが無反応となり、ネットワークに接続しなくなっていました。
37313 | UNIX スタイル FTP LIST が改善され、ディレクトリ名を正しく解析し、ファイル名が In-Sight Explorer の [開く] または [名前を付けて保存] ダイアログに正しく表示されるようになりました。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | ファームウェアバージョン
36100 | ピクセル計数ツールがポリゴン領域を使用しているとき、[ピクセル計数メータおよび PASS 範囲] スライダーバーの最小/最大制限範囲ハンドルが、検査のたびに左右にシフトします。 このとき、最小/最大制限値は変更されず、検査結果に影響はありません。 | 5.2.1
35848 & 36340 | [SLMP スキャナの設定] ダイアログに、接続が正常に確率された場合でも、誤ったステータスメッセージ (“Connection has not been established” または “ERR String index: -1” ) が表示されることがあります。 | 5.2.1
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.2.1 & 5.2.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。 あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.2.1 & 5.2.0
31905 | In-Sight 2000 シリーズビジョンセンサおよび In-Sight Micro 8000 シリーズビジョンシステムでは、[リンクスピード] ネットワーク設定を指定することができません。 他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用します。 | 5.2.1 & 5.2.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。 この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.2.0
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.2.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。 例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.2.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。 例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.2.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.2.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。 例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。 しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.2.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.2.0 & 4.10.2
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。 ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.2.0 & 4.10.2
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。 ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。.

 5.2.0 & 4.10.2
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.2
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。 逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.2
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.2
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。 オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.2


In-Sight® Explorer 5.2.1 リリースノート

© Copyright 1999-2016 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer 5.2.1 について説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この説では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight Explorer は、次のオペレーティングシステムで動作することを確認しています。

  • Windows® 7 Professional サービスパック 1 (32 ビットおよび 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorer はそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 5.2.1

  • In-Sight 2000 シリーズビジョンセンサ

In-Sight ファームウェア 5.2.0

  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 4.10.1

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム

サポートしているファームウェアバージョン

In-Sight Explorer 5.2.1 には、In-Sight 5.2.1、In-Sight 5.2.0 および 4.10.1 の 3 種類のファームウェアバージョンが含まれています。In-Sight ファームウェア 5.2.0 または 4.10.1 を搭載した In-Sight ビジョンシステムは、5.2.1 の新機能をサポートしません。また、In-Sight 5.2.1 にアップグレードすることもできません。

In-Sight 4.10.1/5.2.1 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。システムに検出されない場合、自動的にインストールされます。

ライセンス

In-Sight Explorer 5.2.0 は、完全版とトライアル版の 2 種類のパッケージで配布されています。完全版は全機能を使用でき、使用期限が設定されていません。トライアル版は、30 日間使用でき、期限を過ぎると使用できなくなります。なお、完全版では、ご使用のネットワークに In-Sight ビジョンシステムが存在しない状態で、In-Sight Explorer のエミュレーションモードを使用するには、オフラインプログラミングキーが必要になります。

新しい機能

注: 次の新機能は、In-Sight ファームウェアバージョン 5.2.1 を搭載した In-Sight ビジョンシステムとともに In-Sight Explorer 5.2.1 を使用したときのみ、使用可能です。

In-Sight Explorer

新しい機能
このリリースでは、In-Sight 2000 シリーズビジョンセンサ (2000-110、2000-120 および 2000-130 モデル) に新たに対応しました。
[連続トリガ] オプションを [画像] メニューに追加しました。連続して画像を取得することにより、使用中のアプリケーションがライブ画像に対し、期待通りに動作しているかどうかを確認することができます。

EasyBuilder ビュー

新しい機能

In-Sight 2000 シリーズビジョンセンサ接続時、次のアプリケーションステップにシンプルなユーザインタフェースが表示されるようになりました。

  • 画像の設定
  • 位置決め (パターンツール)
  • 検査 (輝度、コントラスト、パターンおよびピクセル計数有無判定ツール、ロジック演算 & ロジックツール)

修正点

注:

  • この節では、In-Sight ファームウェアバージョン 5.2.1 を搭載した In-Sight ビジョンセンサとともに In-Sight Explorer 5.2.1 を使用したときの、変更点および修正点について説明します。以前のリリースの変更内容については、以前のリリースノートを参照してください。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
変更/修正

ライブビデオ機能に、次の変更が加えられました。

  • [ライブビデオ] オプションが [画像] メニューおよびジョブディスプレイツールバーに追加されました。ライブビデオモードを、どの EasyBuilder アプリケーションステップでも有効にすることができます。以前は、[ライブビデオ] オプションは [画像の設定] アプリケーションステップでのみ使用可能でした。
  • ライブビデオモードでも、[画像の設定] アプリケーションステップの画像取り込みパラメータを変更することができるようになりました。以前は、ライブビデオモードでは、すべての画像取り込みパラメータは無効になっていました。
  • [画像] メニューおよびジョブディスプレイツールバーで表示される、ライブビデオのアイコンが変更されました。
[スタートアップ] オプションを EasyBuilder ビューの [センサ] メニューに追加しました。[位置決め] および [検査] アプリケーションステップを除く、EasyBuilder アプリケーションでスタートアップ設定を行うことができるようになりました。以前は、[スタートアップ] オプションは、[ジョブの保存] アプリケーションステップでのみ設定することができました。
EasyBuilder ロジックまたは演算検査ツールが追加されたときに、クロスヘアが画像エリアに表示されなくなりました。以前は、ツール名 (ロジック_1 など) の他にクロスヘアが表示され、画像エリア内でツール名を動かすには、クロスヘアをドラッグしなければなりませんでした。
[位置決め] および [検査] アプリケーションステップの [フィルタ] サーチボックスの名前が、[フィルタ] サーチボックスに変更されました。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# 問題 影響するファーム
ウェアバージョン
37985 | ピクセル計数ツールがポリゴン領域を使用しているとき、[ピクセル計数メータおよび PASS 範囲] スライダーバーの最小/最大制限範囲ハンドルが、検査のたびに左右にシフトします。このとき、最小/最大制限値は変更されず、検査結果に影響はありません。 | 5.2.1
35848 & 36340 | 接続に成功したにも関わらず、[SLMP スキャナの設定] ダイアログに誤ったステータスメッセージ (“Connection has not been established” または “ERR String index: -1” ) が表示されることがあります。 | 5.2.1
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムまたはビジョンセンサではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.2.1 & 5.2.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムまたはビジョンセンサのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムまたはビジョンセンサを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムまたはビジョンセンサを再起動してください。あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムまたはビジョンセンサを再起動するようにメッセージが表示されます。

 5.2.1 & 5.2.0
31905 | In-Sight 2000 シリーズビジョンセンサおよび In-Sight Micro 8000 シリーズビジョンシステムでは、[リンクスピード] ネットワーク設定を指定することができません。他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用します。 | 5.2.1 & 5.2.0
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.2.0
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.2.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.2.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.2.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.2.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.2.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.2.0 & 4.10.1
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.2.0 & 4.10.1
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。.

 5.2.0 & 4.10.1
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.1
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.1
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.1
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.1


In-Sight® Explorer 5.4.1 リリースノート

In-Sight® Explorer 5.2.0 リリースノート

© Copyright 1999-2015 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer 5.2.0 について説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題
注: 最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation です。

システム要件

この節では、In-Sight Explorer ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight Explorer は、次のオペレーティングシステムで動作することを確認しています。

  • Windows® 7 Professional サービスパック 1 (32 ビットおよび 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorerはそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 5.2.0

  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight Micro 8000 シリーズビジョンシステム

In-Sight ファームウェア 4.10.1

  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight 7000 シリーズビジョンシステム

サポートしているファームウェアバージョン

In-Sight Explorer 5.2.0 には、In-Sight 5.2.0 および 4.10.1 の 2 種類のファームウェアバージョンが含まれています。In-Sight ファームウェア 4.10.1 を搭載した In-Sight ビジョンシステムは、5.2.0 の新機能をサポートしません。また、In-Sight 5.1.0 以降にアップグレードすることもできません。

In-Sight 4.10.1/5.2.0 以前のファームウェアを搭載している In-Sight ビジョンシステムは正常に操作することもありますが、サポートされていない機能があり、また十分にテストが行われていません。最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、最新バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5

ソフトウェアをインストールする前に、Microsoft .NET Framework 4.5 をインストールする必要があります。システムに検出されない場合、自動的にインストールされます。

ライセンス

In-Sight Explorer 5.2.0 は、完全版とトライアル版の 2 種類のパッケージで配布されています。完全版は全機能を使用でき、使用期限が設定されていません。トライアル版は、30 日間使用でき、期限を過ぎると使用できなくなります。なお、完全版では、ご使用のネットワークに In-Sight ビジョンシステムが存在しない状態で、In-Sight Explorer のエミュレーションモードを使用するには、オフラインプログラミングキーが必要になります。

新しい機能

In-Sight Explorer

新しい機能 | 影響するファームウェア バージョン
このリリースでは、In-Sight 8200、8400、8401 および 8402 ビジョンシステムに新たに対応しました。 | 5.2.0

EasyBuilder ビュー

新しい機能 影響するファームウェア
バージョン

PatMax RedLine™ ツールを位置決めおよび検査アプリケーションに追加しました。

  • 位置決めツール: PatMax RedLine パターンおよび PatMax RedLine パターン (1-10)
  • 検査ツール: PatMax RedLine パターン有無判定ツール、PatMax RedLine 計数ツールおよび PatMax RedLine パターン (1-10) 識別ツール
 5.1.0 & 5.2.0
ロジックツールを検査アプリケーションステップに追加しました。標準ブール値ロジック演算子を使用して、PASS/FAIL データを処理する数式を作成することができます。 N/A

[フィルタ] サーチボックスを位置決めおよび検査アプリケーションステップに追加しました。ツールを動的にフィルタすることができます。

 N/A

スプレッドシートビュー

新しい機能 | 影響するファームウェア バージョン
DetectBlobs 関数 (ビジョンツール > ブロブ) を追加しました。画像内のブロブを検出し、そのデータを抽出します。この関数は、 ExtractBlobs より新しいアルゴリズムを使用してします。 | 5.2.0

修正点

注:

  • この節では、In-Sight Explorer 5.2.0 の変更点および修正点について説明します。以前のリリースの変更内容については、以前のリリースノートを参照してください。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
CR# 変更/修正 影響するファームウェア
バージョン
N/A | ImageMath 関数 (ビジョンツール > 画像フィルタ) が更新され、新しいアルゴリズムを使用するようになりました。この変更により、[表示行] および [表示列] パラメータが関数に追加されました。また、[結果の配置]、[詳細設定オプション] パラメータおよび [AND]、[OR]、[XOR] オプション ([フィルタ種類] パラメータ) が関数から削除されました。 | 5.2.0
N/A | ExtractHistogram 関数 (ビジョンツール > ヒストグラム) が更新され、新しいアルゴリズムを使用するようになりました。この変更により、パフォーマンスが向上する可能性があります。 | 5.2.0
35259

ジャンボイーサネットフレームサイズをサポートするように PC のネットワークアダプタを設定している場合でも、In-Sight Explorer と In-Sight Micro 8405 ビジョンシステムの接続を確立/維持することができるようになりました。以前は、ジャンボイーサネットフレームサイズをサポートするよう PC のネットワークアダプタを設定していた場合、TCP 接続の確立中、In-Sight Micro 8405 ビジョンシステムは、誤った最大セグメントサイズを報告していました。その結果、8405 ビジョンシステムに接続ができない (または接続が切断される) ことがありました。

 5.2.0
N/A | [ジョブサーバの設定] ダイアログが更新され、[ディレクトリ] フィールドが追加されました。ジョブの保存またはロードで使用する FTP サーバのディレクトリ (またはディレクトリパス) を指定します。[ディレクトリ] フィールドは、エミュレータが FTP サーバとして指定されている場合、サポートされません。 | 5.2.0 & 4.10.1
N/A | [ネットワークの設定] ダイアログが更新され、[現在のスピード] フィールドが含まれるようになりました。現在のイーサネットリンクスピードおよびデュープレックスモード (全二重または半二重) を表示します。 | 5.2.0 & 4.10.1
35679 | In-Sight® Explorer ヘルプ (英語版) のイーサネット通信トピックが更新され、EDS 作成プロファイルまたはアドオンプロファイルを使用した、Rockwell ControlLogix PLC への接続方法が含まれるようになりました。ビジョンシステムにインストールされた In-Sight ファームウェアバージョンごとに、接続方法が説明されます。 | 5.2.0 & 4.10.1
N/A | ReadIDMax 関数 (ビジョンツール > ID) および EasyBuilder 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールが更新され、1D/スタックドシンボルに [拡張 UPC-E] チェックボックスが追加されました。 | 4.10.1
N/A | In-Sight ファームウェアバージョン 4.10.1 を搭載する In-Sight Micro 1000 シリーズ、5000 シリーズおよび 7000 シリーズビジョンシステムが、GS1 General Specification (GS1 仕様書) に対応するようになりました。 | 4.10.1
N/A

GetAIDescription 関数 (データ・アクセス > GetAIDescription) および GetFieldIdentifier 関数 (データ・アクセス > GetFieldIdentifier) が更新され、次の GS1 アプリケーション識別子 (AI) をサポートするようになりました。

  • 16: 販売期限 (YYMMDD)
  • 255: クーポン識別番号 (GCN)
  • 710: 国家保険償還番号 - ドイツ IFA
  • 711: 国家保険償還番号 - フランス CIP
  • 712: 国家保険償還番号 - スペイン国家コード
  • 713: 国家保険償還番号 - ブラジル ANVISA
  • 80101: 部品・パーツ識別番号(CPID)
  • 80111: 部品・パーツ識別シリアル番号(CPID シリアル)
 4.10.1

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | 影響するファームウェアバージョン
35828 | ビジョンシステムが産業用イーサネット通信プロトコルを介してトリガされた場合、ジョブに WriteResultsBuffer 関数が含まれているときのみ JobPass 信号が出力されます。この問題は、EasyBuilder アプリケーションでは発生しません。 | 5.2.0
31905 | In-Sight Micro 8000 シリーズビジョンシステムでは、[リンクスピード] ネットワーク設定を指定することができません。他のオプションが選択されても、イーサネットの最速スピードおよびネットワークデバイスがサポートするデュープレックスモードを決定する際に、ビジョンシステムは常に [オートネゴシエーション] オプションを使用します。 | 5.2.0
31717 | In-Sight Micro 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.2.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムを再起動してください。あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムを再起動するようにメッセージが表示されます。

 5.2.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.2.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.2.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.2.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.2.0
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムではサポートされていません。ただし、ツールに互換性がある場合正常にロードできることもあります。 | 5.2.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.2.0 & 4.10.1
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、 正しい場所に戻そうとしても、その状態から変更することができません。ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.2.0 & 4.10.1
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。.

 5.2.0 & 4.10.1
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.10.1
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。逆に、日本語版の GX Works2 で作成された PLC プロジェクトを 英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.1
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.1
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.1


In-Sight® Explorer 5.1.1 リリースノート

© Copyright 1999-2015 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer 5.1.1 について説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題

最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.1\Documentation です。

システム要件

この説では、In-Sight Explorer 5.1.1 ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、In-Sight の処理負荷が低い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight Explorer は、次のオペレーティングシステムで動作することを確認しています。

  • Windows 7 Professional サービスパック 1 (32 ビットおよび 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorerはそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 5.1.1

  • In-Sight 8405 ビジョンシステム

In-Sight ファームウェア 5.1.0

  • In-Sight 5705 および 5705C ビジョンシステム

In-Sight ファームウェア 4.10.0

  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 7000 シリーズビジョンシステム

注:

  • In-Sight ファームウェア 4.10.0 を搭載した In-Sight ビジョンシステムは、5.1.1 新機能をサポートしません。また、In-Sight 5.1.0 以降にアップグレードすることもできません。
  • In-Sight Explorer 5.1.1 は、In-Sight ファームウェア 4.10.0 を搭載した、不揮発性フラッシュメモリ容量 64MB 未満のビジョンシステムをサポートしていません。

旧バージョンのファームウェアに対するサポート

In-Sight Explorer 5.1.1 には、In-Sight 5.1.0、In-Sight 5.1. および 4.10.0 の、3 種類のファームウェアバージョンが含まれています。In-Sight 4.9.3 以前のファームウェアを搭載している In-Sight ビジョンシステムも、In-Sight Explorer 5.1.1 で正常に操作することができます。しかし、バージョン 4.10.0 より古いファームウェアについては十分にテストが行われていません。最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、同一バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプの「Firmware Versions」 (ファームウェアバージョンのトピック) をご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.1\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5

In-Sight Explorer 5.1.1 には、Microsoft .NET Framework 4.5 が必要です。システムに検出されない場合、自動的にインストールされます。

ライセンス

In-Sight Explorer 5.1.1 は、完全版とトライアル版の 2 種類のパッケージで配布されています。完全版は全機能を使用でき、使用期限が設定されていません。トライアル版は、30 日間使用でき、期限を過ぎると使用できなくなります。なお、完全版では、ご使用のネットワークに In-Sight ビジョンシステムが存在しない状態で、In-Sight Explorer のエミュレーションモードを使用するには、オフラインプログラミングキーが必要になります。

新しい機能

In-Sight Explorer の拡張機能

  • In-Sight ファームウェアバージョン 4.10.0 を搭載している In-Sight ビジョンシステムにおいて、EtherNet/IP または PROFINET 通信等を介し、PLC などの外部デバイスから TestRun を開始することができるようになりました。EtherNet/IP および PROFINET ファクトリ通信プロトコルが修正され、In-Sight ファームウェアバージョン 4.10.0 を搭載しているビジョンシステム上で、信号による TestRun 機能の制御をサポートするようになりました。

修正点

注:

  • この説では、In-Sight Explorer 5.1.1 の変更点および修正点について説明します。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。

  • In-Sight Explorer には、ファームウェアバージョン 5.1.1、5.1.0 および 4.x.x 最新バージョン 4.10.0 の、3 種類のファームウェアバージョンが含まれています。ファームウェアアップデート時、インストールされるバージョンは、ビジョンシステムのモデルタイプによって決定されます。そのモデルタイプがサポートしている最終バージョンのみに、ビジョンシステムをアップグレードすることができます。例えば、In-Sight Micro 1000 シリーズビジョンシステムは、ファームウェアバージョン 4.10.0 のみにアップグレードすることが可能で、5.1.0 以降にはアップグレードすることはできません。

    注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプの「Firmware Versions」 (ファームウェアバージョンのトピック) をご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.1\Documentation\Help\Help_ISE_EN.chm です。
  • SetSymbolMinStringLength 関数が変更され、短い Pharmacode シンボルの読み取りができるようになりました。以前は、3 文字以下の Pharmacode シンボルを読み取ることができませんでした。

以前のリリースの変更内容については、以前のリリースノートを参照してください。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# | 問題 | 影響するファームウェアバージョン
31717 | In-Sight 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.1.1
35259

TCP 接続の確立中、In-Sight 8405 ビジョンシステムは、誤った最大セグメントサイズを報告します。その結果、ジャンボイーサネットフレームサイズをサポートするよう PC のネットワークアダプタを設定している場合に、In-Sight Explorer から In-Sight 8405 ビジョンシステムに接続ができない (または接続が切断される) 可能性があります。

回避策: 接続が切断されるのを防ぐため、デフォルトの Ethernet MTU (最大転送単位) 1500 バイトを使用するよう、PC のネットワークアダプタを設定してください。

 5.1.1
31638

PROFINET 用に設定した In-Sight ビジョンシステムのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムを再起動してください。あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムを再起動するようにメッセージが表示されます。

 5.1.1 & 5.1.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.1.1 & 5.1.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されることがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.1.1 & 5.1.0
32642

EtherNet/IP 通信で Rockwell RSLogix Studio 5000 バージョン 21～24 を使用している場合、In-Sight EDS で作成されたプロファイルのデフォルト入出力アセンブリサイズ (各 496 バイト) を編集することができません。

回避策: デフォルトサイズを編集する必要がある場合、汎用イーサネットモジュールを使用して設定してください。更新された In-Sight アドオンプロファイル (AOP) が Cognex サポートサイトにポストされたら、最新バージョンをダウンロードして、 EDS ファイルまたは汎用イーサネットモジュールの代わりに使用してください。

 5.1.1 & 5.1.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.1.1 & 5.1.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識する場合があります。例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.1.1 & 5.1.0
32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 以降を搭載したビジョンシステムではサポートされていません。ただし、ツールに互換性がある場合正常にロードできることもあります。 | 5.1.1 & 5.1.0
32821

In-Sight 5.1.x ファームウェア上でサポートされていない PointFilter や NeighborFilter 関数を含むジョブのロードを試みた場合、その関数が [セルのフォーマット] ダイアログの [保護] タブを使用してパスワード保護されている場合、ジョブのロードに失敗します。

回避策: In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムにジョブをロードして、ジョブを修正してください。パスワード保護されたセルへのアクセスやセルの削除についての詳細は、In-Sight Explorer オンラインヘルプのライセンストピックをご参照ください。

 5.1.1 & 5.1.0
32253

カラーの In-Sight ビジョンシステムに接続している時に、[記録再生のオプション] ダイアログで画像を 16 ビット JPEG で記録するように設定しても、24 ビットカラーで画像が記録されます。

回避策: 16 ビットカラーで画像を記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。

 5.1.1、5.1.0 & 4.10.0
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.1.1、5.1.0 & 4.10.0
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF にしようとしたり、正しい場所に戻そうとしても、その状態から変更することができません。turning the toolbars on or off, or attempting to move them to the correct location). ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.1.1、5.1.0 & 4.10.0
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。

 5.1.1、5.1.0 & 4.10.0
32479

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入してください。
 4.10.0
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失します。This issue also occurs if the process is reversed, i.e. 逆に、日本語版の GX Works2 で作成された PLC プロジェクトを英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.10.0
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.10.0

21041

POWERLINK ネットワーク上の In-Sight ビジョンシステムが In-Sight Explorer に接続されている場合に、PLC にダウンロードを試みたり、PLC のソフトウェア再起動を試みたりすると、ビジョンシステムを In-Sight Explorer に接続できなくなることがあります。

回避策: PLC に変更を加えたり再起動したりする前に、ビジョンシステムを In-Sight Explorer から切断してください。この問題が発生した場合、In-Sight Explorer に再度接続するには、ビジョンシステムに電源を再投入してください。

 4.10.0
26990

三菱 iQ Sensor Solution に In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.10.0
21234

In-Sight ビジョンシステムを POWERLINK 上ネットワークで使用する場合の制限は、次の通りです。The following known limitations apply:

  • 非同期パケットトランスファ用の MTU 値が、POWERLINK ネットワークで使用されている MTU 値と同じ値でない場合、TCP/IP 通信は正常に機能しません。
  • POWERLINK を有効にしたビジョンシステムを POWERLINK ネットワークから切断し、通常のイーサネットネットワークに切り替える場合、イーサネット通信がロックアップし、帯域幅が 1Mbps に制限されることがあります。通常のイーサネットネットワークを使用している場合、ジョブを編集するには、POWERLINK 通信を無効にしてください。
 4.10.0


In-Sight® Explorer 5.1.0 リリースノート

© Copyright 1999-2015 Cognex Corporation. All rights reserved.

概要

本書は In-Sight® Explorer 5.1.0 について説明します。本書は次のトピックから構成されています。

  • システム要件
  • 新しい機能
  • 修正点
  • 既知の問題

最新のリリースノートやドキュメンテーション (各国語版も含む) は、In-Sight オンラインサポートセンターでダウンロードできます。In-Sight Explorer ユーザインタフェースおよび Windows スタートメニューから、更新されたドキュメンテーションにアクセスするには、まず管理者権限を持って PC にログオンする必要があります。次に、イントールディレクトリ内の適切なロケーションにダウンロードしたドキュメンテーションをコピーします。デフォルトのロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.0\Documentation です。

システム要件

この説では、In-Sight Explorer 5.1.0 ソフトウェアのシステム要件について説明します。

PC ハードウェア要件

最小要件

注: ハードウェアの最小要件とは、プロダクションスピードが遅い環境で、解像度の低い In-Sight ビジョンシステムを 1 台だけ接続している PC を指します。
  • 2GHz 動作の Intel® Pentium® 4プロセッサ (または同等品)
  • 1GB の RAM 空き容量
  • 2GB のハードディスク空き容量
  • 24 ビットカラーで解像度 1024✕768 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのイーサネットネットワークインタフェースカード (100Mbps 以上)

推奨要件

注: 推奨されるハードウェア要件とは、4 台までの In-Sight ビジョンシステムを接続している PC を指します。
  • 2.7GHz 動作の Intel® Core™ i7 プロセッサ (または同等品)
  • 4GB の RAM 空き容量
  • 2.5GB のハードディスク空き容量
  • 32 ビットカラーで解像度 1920✕1080 の表示が可能なビデオカード。画面の DPI 設定は 96 DPI に設定します。
  • In-Sight ビジョンシステムに接続するためのギガビット・イーサネットネットワークインタフェースカード

オペレーティングシステム要件

In-Sight Explorer は、次のオペレーティングシステムで動作することを確認しています。

  • Windows 7 Professional サービスパック 1 (32 ビットおよび 64 ビット)
  • Windows Server 2008 R2 サービスパック 1 (64 ビット)

In-Sight Explorerはそのほかのオペレーティングシステムでも動作することがありますが、前述の要件を満たさないシステムはサポート対象外です。

言語サポート

  • 英語
  • 日本語
  • フランス語
  • ドイツ語
  • スペイン語 (ヨーロッパ系)
  • 韓国語
  • 中国語 (簡体字)

サポートしている In-Sight ビジョンシステム

In-Sight ファームウェア 5.1.0

  • In-Sight 5705 および 5705C ビジョンシステム
  • In-Sight 8405 ビジョンシステム

In-Sight ファームウェア 4.9.3

  • In-Sight 5000 シリーズビジョンシステム (In-Sight 5705 および 5705C ビジョンシステムを除く)
  • In-Sight Micro 1000 シリーズビジョンシステム
  • In-Sight 7000 シリーズビジョンシステム

注:

  • In-Sight ファームウェア 4.9.3 を搭載した In-Sight ビジョンシステムは、5.1.0 新機能をサポートしません。また、In-Sight 5.1.0 にアップグレードすることもできません。
  • In-Sight Explorer 5.1.0 は、In-Sight ファームウェア 4.9.3 を搭載した、不揮発性フラッシュメモリ容量 64MB 未満のビジョンシステムをサポートしていません。

旧バージョンのファームウェアに対するサポート

In-Sight Explorer 5.1.0 には、In-Sight 5.1.0 および 4.9.3 の、2 種類のファームウェアバージョンが含まれています。In-Sight 4.9.2 以前のファームウェアを搭載している In-Sight ビジョンシステムも、In-Sight Explorer 5.1.0 で正常に操作することができます。しかし、バージョン 4.7.0 より古いファームウェアについては十分にテストが行われていません。最適なパフォーマンスを得るには、In-Sight Explorer ソフトウェアおよびファームウェアは、同一バージョンを使用してください。

注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.0\Documentation\Help\Help_ISE_EN.chm です。

Microsoft .NET Framework 4.5.0

In-Sight Explorer 5.1.0 には、Microsoft .NET Framework 4.5.0 が必要です。システムに検出されない場合、自動的にインストールされます。

ライセンス

In-Sight Explorer 5.1.0 は、完全版とトライアル版の 2 種類のパッケージで配布されています。完全版は全機能を使用でき、使用期限が設定されていません。トライアル版は、30 日間使用でき、期限を過ぎると使用できなくなります。なお、完全版では、ご使用のネットワークに In-Sight ビジョンシステムが存在しない状態で、In-Sight Explorer のエミュレーションモードを使用するには、オフラインプログラミングキーが必要になります。

新しい機能

注: 次の新機能は、In-Sight ファームウェアバージョン 5.1.0 を搭載した In-Sight ビジョンシステムとともに In-Sight Explorer 5.1.0 を使用したときのみ、使用可能です。In-Sight ファームウェア 4.9.3 を搭載した In-Sight ビジョンシステムは、5.1.0 の新機能をサポートしません。また、In-Sight 5.1.0 にアップグレードすることもできません。

In-Sight Explorer の拡張機能

このリリースでは、EasyBuilder およびスプレッドシート開発環境に新しい機能が追加されました。次の新機能は、両方の開発環境に含まれています。

  • このリリースでは、In-Sight 5605 ビジョンシステムの上位機種である In-Sight 5705 ビジョンシステムと、In-Sight 5705C カラービジョンシステムに対応しました。
  • このリリースでは、In-Sight 8405 ビジョンシステムに対応しました。

  • In-Sight 5.1.0 ファームウェアを搭載した新しい In-Sight ビジョンシステムをサポートするため、EtherNet/IP、PROFINET および三菱 SLMP スキャナのファクトリ通信プロトコルを更新しました。EtherNet/IP プロトコルには 2 つの新しい入出力アセンブリ (インスタンス 13 および 22)、PROFINET プロトコルには新しいモジュールレイアアウトが追加され、SLMP スキャナには新しいデータブロックが追加されました。

    注: In-Sight 5.1.0 ファームウェアを搭載した新しい In-Sight ビジョンシステムは、EtherNet/IP PCCC、CC-Link、iQSS, Modbus TCP サーバおよび POWERLINK をサポートしていません。

  • In-Sight Explorer に、現在のバージョン (5.1.0) と、4.x.x 最新バージョン (4.9.3) の、2 種類のファームウェアバージョンが含まれるようになりました。ファームウェアアップデート時、インストールされるバージョンは、ビジョンシステムのモデルタイプによって決定されます。そのモデルタイプの最後サポートバージョンのみに、ビジョンシステムをアップグレードすることができます。例えば、In-Sight Micro 1000 シリーズビジョンシステムは、ファームウェアバージョン 4.9.3 のみにアップグレードすることが可能で、5.1.0 にはアップグレードすることはできません。また、In-Sight ファームウェアアップデート時、ファームウェアアップデート (FUP) キーおよび In-Sight エミュレータは不要になりました。

    注: モデル一覧およびサポートされているファームウェアバージョンについては、英語版 In-Sight Explorer オンラインヘルプのファームウェアバージョントピックをご参照ください。英語版 In-Sight Explorer オンラインヘルプのデフォルトロケーションは、C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.1.0\Documentation\Help\Help_ISE_EN.chm です。
  • In-Sight Explorer に、現在のバージョン (5.1.0) と、4.x.x 最新バージョン (4.9.3) の、2 種類のエミュレータが含まれるようになりました。エミュレーションモデルを標準 (デフォルト)、In-Sight 8405、In-Sight 5705 または In-Sight 5705 に設定すると、5.1.0 新機能をすべて含む 5.1.0 エミュレータが立ち上がります。それ以外のモデルに設定すると、5.1.0 新機能を含まない 4.9.3 エミュレータが立ち上がります。

EasyBuilder® ビュー

新しいツール

  • フィルタ画像フィルタツールが、検査ステップに追加されました。このツールは多目的フィルタで、低コントラスト画像や画像内の特徴を強調するのに使用される、カラーまたはグレースケール出力画像を生成します。

ツールの強化

EasyBuilder ビューの強化

スプレッドシートビュー

新しく追加された関数

次の関数は、In-Sight Explorer スプレッドシートビューを使用している場合にのみ利用可能です。

  • Script 関数 (スクリプト) が追加されました。[スクリプトの編集] ダイアログで作成/編集した、ユーザ定義の JavaScript ソースコードを実行します。Script 関数には、個々の Script 関数の動作を定義した、ユーザ作成の JavaScript ソースコードが含まれています。
  • 新しいパターンマッチツール、PatMax RedLine™ が導入されました。PatMax® より最大 7 倍の早さで、5 メガピクセルの画像から、登録された特徴を検出します。PatMax RedLine は、TrainPatMaxRedLine および FindPatMaxRedLine (ビジョンツール > パターンマッチ) の 2 つの関数からなります。TrainPatMaxRedLine 関数はパターンを登録し、FindPatMaxRedLine 関数は画像内の 1 つあるいは複数のパターンインスタンスを検出するのに使用されます。
  • Filter 関数 (ビジョンツール > 画像フィルタ) が追加されました。この関数は多目的フィルタで、低コントラスト画像や画像内の特徴を強調するのに使用する、カラーまたはグレースケール出力画像を生成します。
  • Get 関数 (データ・アクセス > スクリプト) が追加されました。Script 関数または Get 関数から返されたオブジェクトプロパティにアクセスします。
  • GetPolygon 関数 (データ・アクセス > ブロブ) が追加されました。指定ブロブの境界点を示す、ポリゴンデータ構造体を返します。ポリゴンデータ構造体は、[外部領域] パラメータのある関数の入力として使用することができます。ブロブ領域内でのさらなる画像処理の実行が可能となります。

  • GetSystemConfig(“Internal.Temperature”) 拡張ネイティブモードコマンドが追加されました。In-Sight 8405 ビジョンシステムの内部温度を取得します。

関数の機能拡張

スプレッドシートビューの機能拡張

修正点

注:

  • この節では、In-Sight ファームウェアバージョン 5.1.0 を搭載した In-Sight ビジョンシステムとともに In-Sight Explorer 5.1.0 を使用したときの、変更点および修正点について説明します。
  • Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、Change Request 番号 (CR#) が付与されています。
  • EtherNet/IP、PROFINET および SLMP スキャナプロトコルから、Acquiring ビットが削除され、Exposure Complete および Exposure Complete Ack ビットが追加されました。また、Inspecting ビットが System Busy ビットに置き換わりました。ジョブロード信号 (Initiate Job Load、Job Loading、Job Load Completed、Job Load Failed および Job Load ID) が数値のコマンド実行信号 (Execute Command, Command Executing, Command Completed, Command Failed and Command) に置き換わりました。
  • GetBufferData、ReadUserDataBuffer、ReadLatchedUserDataBuffer および WriteResultsBuffer 関数が修正され、プロトコルパラメータを介して EtherNet/IP、PROFINET および SLMP スキャナプロトコルをサポートするようになりました。これらの関数は、In-Sight 5.1.0 ファームウェアがサポートするファクトリ通信プロトコルに対して使用してください。
  • 2 種類のファームウェアバージョン (4.9.3 および 5.1.0) をサポートするため、ファームウェアインストールディレクトリが変更されました。新しいロケーションは次の通りです。
    • [ProgramData]\Cognex\Firmware\In-Sight\4.9.3
    • [ProgramData]\Cognex\Firmware\In-Sight\5.1.0
  • 2 種類のエミュレータタイプ (4.9.3 および 5.1.0) をサポートするため、エミュレータディレクトリが変更されました。新しいロケーションは次の通りです。
    • [Program Files]\Cognex\In-Sight\Emulators\4.9.3\In-Sight.exe
    • [Program Files]\Cognex\In-Sight\Emulators\5.1.0\In-Sight.exe
    注: エミュレーションモデルを標準 (デフォルト)、In-Sight 8405、In-Sight 5705 または In-Sight 5705 カラーに設定すると、5.1.0 フォルダ内のエミュレータ (In-Sight.exe) が使用されます。それ以外のモデルに設定すると、4.9.3 フォルダ内のエミュレータが使用されます。
  • 2 種類のエミュレータタイプ (4.9.3 および 5.1.0) をサポートするため、エミュレータワーキングディレクトリが変更されました。新しいロケーションは次の通りです。
    • [ProgramData]\Cognex\In-Sight\Emulators\4.9.3
    • [ProgramData]\Cognex\In-Sight\Emulators\5.1.0

    注:

    • In-Sight Explorer のインストールロケーションに関わらず、上記のワーキングディレクトリが使用されます。
    • 5.1.0 エミュレータを使用する場合、ジョブおよび画像は、5.1.0 ディレクトリに保存されます。4.9.3 エミュレータを使用する場合、ジョブおよび画像は、4.9.3 ディレクトリに保存されます。ジョブまたは画像をエミュレータに保存した後にエミュレータタイプを変更した場合、[開く] ダイアログからジョブまたは画像を開こうとしても、そのジョブまたは画像はダイアログに表示されません。
    • 5.1.0 エミュレータ上で、WriteFTP、WriteImageFTP または WriteImageSFTP 関数を使用してエミュレータにファイルを書き込む場合、5.1.0 ディレクトリに書き込まれます。4.9.3 エミュレータ上で、WriteFTP、WriteImageFTP または WriteImageSFTP 関数を使用してエミュレータにファイルを書き込む場合、4.9.3 ディレクトリに書き込まれます。
  • [ファームウェアアップデート] ダイアログが変更になりました。
    • サーチボックスが追加され、名前、モデルおよびバージョン列の情報を元に、ビジョンシステムを動的にフィルタすることができるようになりました。
    • ビジョンシステムの名前の隣に、チェックボックスが追加されました。アップデートする In-Sight ビジョンシステムを選択する際に、ON にします。以前は、アップデートするビジョンシステムを選択する場合、ハイライトする必要がありました。
    • [強制アップデート] チェックボックスが追加されました。このチェックボックスを ON にすると、ビジョンシステムをオフラインにし、ビジョンシステムから他のユーザをログオフし、バックアップエラーを無視することによって、強制的にファームウェアアップデートプロセスを完了させます。以前は、ビジョンシステムがオンラインだったり、ビジョンシステムに他のユーザがログオンしていたり、バックアップエラーが発生した場合、ファームウェアアップデートプロセスは中断されていました。また、これらの問題が発生した場合、手動で解決する必要がありました。
    • [バックアップおよびリストアの無効化] チェックボックスが追加されました。このチェックボックスを ON にすると、ファームウェアアップデート時にファイルはバックアップ、リストアされません。以前は、バックアップおよびリストア操作は必ず実行され、バックアップ操作に失敗した場合、ファームウェアアップデートプロセスは中断されていました。
    • [ファームウェアアップデート] ダイアログは、I/O モジュールのファームウェア、および In-Sight ホストテーブルを使用して異なるネットワーク (サブネット) に追加した In-Sight ビジョンシステムのファームウェアをアップデートするサービスを終了しました。

  • [I/O モジュールの設定] ダイアログから、CIO-MICRO または CIO-MICRO-CC の設定時に表示されていた [ファームウェアアップデート] ボタンが削除されました。

  • [出力詳細] ダイアログの [ストロボ開始位置] ドロップダウンが更新され、[すべての行を露光] オプションが追加されました。In-Sight 8405 ビジョンシステムで使用することができます。
  • SetSystemConfig(“StrobeStartPosition”) 拡張ネイティブモードコマンドが更新され、[すべての行を露光] パラメータ値が追加されました。In-Sight 8405 ビジョンシステムで使用することができます。
  • OCRMax 関数 (ビジョンツール > 文字照合/認識) が更新され、[登録モード] のデフォルト設定が、[新規文字をフォントに追加] に変更されました。以前は、 [登録モード] はデフォルトで [すべての文字をフォントに追加] に設定されてたため、この設定が未変更の場合、文字を登録するたびに OCRMax 関数のパフォーマンスが遅くなっていました。(CR# 31893)
  • GetGrainCoarse および GetGrainFine 関数 (データ・アクセス > パターン) が、GetGranCoarse および GetGranFine 関数に名称変更されました。
  • [システム] メニューの [レイアウトを保存する] が、[表示レイアウトを保存] に名称変更されました。(CR# 27774)
  • PointFilter、NeighborFilter、ReadIDCode、ReadText および VerifyText 関数のサポートを終了しました。
  • In-Sight ファームウェア 5.1.0 を搭載した In-Sight ビジョンシステムは、VisionView ではサポートされていません。(CR# 32841)
  • EasyBuilder パレットヘルプが変更され、各アプリケーションステップのホームトピックのみが含まれるようになりました。ホームトピック内のリンクをクリックすると、EasyBuilder オンラインヘルプが開き、リンクしたトピックが表示されます。

以前のリリースの変更内容については、以前のリリースノートを参照してください。

既知の問題

注: Cognex テクニカルサポートを介して報告された既知の問題を追跡しやすくするために、該当する場合に Change Request 番号 (CR#) が付与されています。
CR# 問題 影響する
ファームウェアバージョン
31717 | In-Sight 8405 ビジョンシステムは、画像取り込みの際、標準の画像方向のみをサポートします。また、AcquireImage プロパティシートの [画像方向] パラメータは無効になっています。 | 5.1.0
31638

PROFINET 用に設定した In-Sight ビジョンシステムのホスト名を [センサ/デバイスをネットワークに追加] ダイアログを使用して変更した場合、そのビジョンシステムを PROFINET に再接続しようと試みても、接続を確立することができません。

回避策: ホスト名を変更した後、ビジョンシステムを再起動してください。あるいは、[ネットワークの設定] ダイアログを使用して、ビジョンシステムのホスト名を変更してください。この場合、設定変更を有効にするため、ビジョンシステムを再起動するようにメッセージが表示されます。

 5.1.0
32781 | FindPatMaxRedLine 関数の [XY オーバラップ] 設定が無視されることがあります。例えば、僅かに重なりあっている 2 つのターゲットをサーチする場合、[XY オーバラップ] の設定に関わらず、マッチは 1 つしか検出されないことがあります。 | 5.1.0
32751

FindPatMaxRedLine 関数の [極性を無視] 設定によっては、登録画像とは逆の極性がサーチ画像に含まれている場合、予期せぬ結果が返されることがあります。例えば、登録画像とは逆の極性を持つ黒い背景に、マッチが誤って検出されてしまうことがあります。

回避策: [極性を無視] を ON にする必要がある場合、[微粒度] 設定を 1 に設定するか、角度/スケール許容値の幅を広げてください。

 5.1.0
32642

EtherNet/IP 通信で Rockwell RSLogix Studio 5000 バージョン 21～24 を使用している場合、In-Sight EDS で作成されたプロファイルのデフォルト入出力アセンブリサイズ (各 496 バイト) を編集することができません。

回避策: デフォルトサイズを編集する必要がある場合、汎用イーサネットモジュールを使用して設定してください。更新された In-Sight アドオンプロファイル (AOP) が Cognex サポートサイトにポストされたら、最新バージョンをダウンロードして、 EDS ファイルまたは汎用イーサネットモジュールの代わりに使用してください。

 5.1.0
31706

TCPDevice、UDPDevice、WriteFTP、WriteImageFTP、ImportData、ExportData および List プロパティリスト内の [ホスト名] ドロップダウンリストに、ネットワーク上の In-Sight ビジョンシステムまたはエミュレータのホスト名が表示されません。

回避策: ターゲットのビジョンシステム/エミュレータの IP アドレスを [ホスト名] フィールドに手動で入力してください。

 5.1.0
30814

シンボリックタグ名がセル名と同じフォーマットで、その値が 32766 以上の場合、In-Sight Explorer は有効なシンボリックタグ名を無効と認識してしまうことがあります。例えば、拡張ネイティブモードコマンド EV SetCellName(B3,"A32767") を発行したときに、コマンドは正常に実行され、シンボリックタグ "A32767" がセル B3 に挿入されます。しかし、In-Sight Explorer から [シンボリックタグエディタ] ダイアログを開くと、シンボリックタグ名エラーがセル B3 に表示されます。

回避策: シンボリックタグ名には、セル名またはセル名と同じフォーマットを使用しないでください。

 5.1.0
32592, 32542 | EasyBuilder サンプルジョブは、ファームウェアバージョン 5.1.0 を搭載したビジョンシステムではサポートされていません。ただし、ツールに互換性がある場合、正常にロードできることもあります。 | 5.1.0
32821

In-Sight 5.1.0 ファームウェア上でサポートされていない PointFilter や NeighborFilter 関数を含むジョブのロードを試みた場合、その関数が [セルのフォーマット] ダイアログの [保護] タブを使用してパスワード保護されている場合、ジョブのロードに失敗してしまいます。

回避策: In-Sight 4.9.x ファームウェアを搭載した In-Sight ビジョンシステムにジョブをロードして、ジョブを修正してください。パスワード保護されたセルへのアクセスやセルの削除についての詳細は、In-Sight Explorer オンラインヘルプのライセンストピックをご参照ください。

 5.1.0
31339 | 対話型グラフィックスモードに入ると、表示画像がわずかにシフトします。例えば、EditPoint 関数をクリックすると、スプレッドシートオーバレイが非表示となり、わずかにシフトした対話型グラフィックスが表示されます。 | 5.1.0
32253

カラーの In-Sight ビジョンシステムに接続している時に、[記録再生のオプション] ダイアログで画像を 16 ビット JPEG で記録するように設定しても、24 ビットカラーで画像が記録されてしまいます。

回避策: 16 ビットカラーで記録する必要がある場合、ビットマップファイル (*.bmp) で画像を記録してください。

 5.1.0 および 4.9.3
28320

角度やカーブのある領域を使用して設定した SurfaceFlaw 関数で、[歪みのない画像] チェックボックスを ON にし、[表示] パラメータを [入力と結果のグラフィックス] に設定した場合、赤いオーバレイグラフィックスのみ表示されます。

回避策: このようなアプリケーションでは、[表示] パラメータを [結果のグラフィックスのみ] に設定して、補正画像およびグラフィックスを表示してください。

 5.1.0 および 4.9.3
28114

複数のスプレッドシートビューに接続した状態で In-Sight Explorer を数日間実行し続けた場合、ツールバーが誤った場所に表示されることがあります。この場合、スプレッドシートビューのツールバーの表示を ON/OFF しようとしたり、正しい場所に戻そうとしても、その状態から変更することができません。ツールバーおよびメニューは機能しますが、再配置することができません。

回避策: ツールバーの位置を変更するには、In-Sight Explorer を一度閉じてから再起動してください。その際、Windows タスク マネージャを使用して強制的にアプリケーションを終了する必要があります。

 5.1.0 および 4.9.3
27205

高い精度が要求されるアプリケーションで、FindPatMaxPatterns 関数が TrainPatMaxPattern 関数によって返されたパターンを検出するようにジョブを作成した時に、この 2 つの関数がサーチ・登録に異なる外部領域を使用する場合、1 ピクセル未満の誤差が報告されることがあります。ただし、どちらかの関数が角度やカーブのある外部領域を参照している場合、報告されるピクセルの誤差は 1 ピクセルより大きくなる可能性があります。

回避策: ジョブを作成する際に、FindPatMaxPatterns および TrainPatMaxPattern 関数が同一の外部領域を参照してサーチ・登録するか、ツール内部の領域を使用してサーチ・登録するように設定してください。.

 5.1.0 および 4.9.3
15993

ReadIDMax 関数の実行時間が、指定されたタイムアウト時間を超えることがあります。

回避策: 超過分を考慮してタイムアウト時間を小さく設定してください。

 5.1.0 および 4.9.3
32513

POWERLINK ネットワーク接続中に In-Sight ビジョンシステムのファームウェアをアップデートすると、コード 13710 が表示され、ビジョンシステムに電源を再投入しファイルをリストアする必要が発生します (ファームウェアは正常にアップデートされます)。

回避策: ビジョンシステムのファームウェアをアップデートする前に、次の手順に従って操作してください。

  1. ビジョンシステムを POWERLINK ネットワークから切断し、In-Sight Explorer を開いている PC と同じサブネット上のネットワークポートにビジョンシステムを接続します。
  2. ビジョンシステムに電源を再投入します。
  3. イーサネットモードでビジョンシステムのファームウェアをアップデートしてください。
  4. ビジョンシステムを POWERLINK ネットワークに戻します。
  5. ビジョンシステムに電源を再投入します。
 4.9.3
26990

三菱 iQ センサソリューションに In-Sight ビジョンシステムを接続しているときに、オンラインモードのビジョンシステムにパラメータ設定 (Set Parameter や Set IP など) を実行しても、エラーコード C05C が正しく発行されません。

回避策: オンラインモードのビジョンシステムに対してパラメータ設定を実施しないでください。オンライン時に設定を変更しようとすると本来は書き込み処理が中止されたことを示すエラーコード C05C が発行されるべきですが、本バージョンでは発行されません。

 4.9.3
27377

英語版の GX Works2 で作成されたプロジェクトをシーケンサにダウンロードし、日本語版の GX Works2 にアップロードすると、In-Sight 5000 および In-Sight 7000 シリーズビジョンシステムのアイコンおよび詳細情報が消失してしまいます。逆に、日本語版の GX Works2 で作成されたP LC プロジェクトを英語版の GX Works2 にアップロードしても、同様の問題が発生します。

回避策: PLC プロジェクトは、常に同一言語の GX Works2 で操作するようにしてください。

 4.9.3
27483

EasyBuilder ビューの [通信] アプリケーションステップで SLMP スキャナプロトコルの編集中に、[フォーマット入出力] タブを使用して変更を加え、[通信] アプリケーションステップを離れた後で、[編集] メニューの [通信の変更の取り消し] を選択すると、アドレスマップファイルが破損します。

回避策: [編集] メニューの [通信の変更の取り消し] を選択せず、手動で必要な変更を行ってください。

 4.9.3
21242

POWERLINK ネットワーク上の In-Sight ビジョンシステムが In-Sight Explorer に接続されている場合に、PLC にダウンロードを試みたり、PLC のソフトウェア再起動を試みたりすると、ビジョンシステムを In-Sight Explorer に接続できなくなることがあります。

回避策: PLC に変更を加えたり再起動したりする前に、ビジョンシステムを In-Sight Explorer から切断してください。この問題が発生した場合、In-Sight Explorer に再度接続するには、ビジョンシステムに電源を再投入してください。

 4.9.3
21234

In-Sight ビジョンシステムを POWERLINK 上ネットワークで使用する場合の制限は、次の通りです。

  • 非同期パケットトランスファ用の MTU 値が、POWERLINK ネットワークで使用されている MTU 値と同じ値でない場合、TCP/IP 通信は正常に機能しません。
  • POWERLINK を有効にしたビジョンシステムを POWERLINK ネットワークから切断し、通常のイーサネットネットワークに切り替える場合、イーサネット通信がロックアップし、帯域幅が 1Mbps に制限されることがあります。通常のイーサネットネットワークを使用している場合、ジョブを編集するには、POWERLINK 通信を無効にしてください。
 4.9.3


用語集

In-Sight Explorer リファレンス

次の表では、このヘルプで使用されている専門用語が定義されています。

用語 | 定義

アクティブセル

スプレッドシート内で現在ハイライトされているセルです。図を参照してください。

アクティブな In-Sight ビジョンシステム

現在ジョブを編集中の In-Sight ビジョンシステムです。このビジョンシステムはスプレッドシート内に「フォーカス」を持っています。フォーカスは通常、アクティブセルによって示されます。

アクティブなジョブ

In-Sight ビジョンシステムのメモリに現在ロードされているジョブファイルです。

ブロブ

黒の背景上の白いしみ、白いコンベヤベルト上の黒いネジなど、暗い色または明るい色の連続したピクセルのグループです。すぐに見つかる特徴の 1 つでもあり、ブロブの特徴の形状とサイズはばらつきがありますが、角度方向の値は限定されます。

セルデータファイル

セルデータファイル (*.CXD) には、スプレッドシートのセルデータが格納されます。スプレッドシートのセルまたはセルのグループは、.CXD ファイルにエクスポートされます。.CXD ファイルは次のいずれかの場所に格納することができます。その場所は、FTP 経由でセントラルサーバ、ローカルやリモートの In-Sight ビジョンシステムまたはエミュレータ、ローカルやリモートの In-Sight ビジョンシステムまたはエミュレータの [RAMDisk] フォルダ、またはローカル PC 上の [スニペット] フォルダです。 なお、格納されているセルデータは、前述の任意の場所からスプレッドシートへインポートすることができます。

.CXD ファイルのエクスポートおよびインポートには、いくつかの方法があります。.CXD ファイルは、[Export Cells] ダイアログ、ExportData 関数または [スニペット] ダイアログを使用してエクスポートすることができます。また、.CXD ファイルは、[セルのインポート] ダイアログ、ImportData 関数、[スニペット] ダイアログ、またはパレットからドラッグアンドドロップしたスニペットを使用してインポートすることができます。

文字インスタンス (OCV/OCR)

OCV/OCR モデルを作成するために、入力に使用されるグレースケールパターンです。

文字モデル (OCV/OCR)

フォントのコンポジット文字で、その文字のすべての登録インスタンスを考慮に入れることによって形成されます。

コード

1D バーコード、2D データマトリックスコード、および英数字データ文字列を含むシンボルです。

Col

(列)

In-Sight ビジョンシステムピクセル座標系の X 方向を定義します。

Closed 例

EasyBuilder タグ

EasyBuilder ビューの情報を提供します。詳細については、EasyBuilder ジョブおよびスプレッドシートの項目を参照してください。

EasyView タグ

EasyView 作成に使用されるデータを含むセルの表示に使用するシンボリックタグです。VisionView に表示します。

エッジ

水平方向、垂直方向、円形、またはカーブしている明るいピクセルと暗いピクセルの間の変化領域です。エッジは、部品の端、回路基板上のピン、ネジのネジ山、ビンの底、バネのコイルなどに相当します。これらの種類の特徴は、一般にすばやく簡単に検出できます。

Explorer ホストテーブル

Explorer ホストテーブルによって、In-Sight Explorer は、異なるサブネットの In-Sight ビジョンシステムと通信できます。このホストテーブルで定義されているビジョンシステムは、[In-Sight ネットワーク]、1 つまたは複数の In-Sight ビジョンシステムでファイル操作を実行するダイアログ ([保存]/[開く]、[スニペット]、[セルのインポート]/[セルのエクスポート]、[バックアップ]、[リストア]、[クローン作成]、[ファームウェアアップデート] など) に表示されます。

注: In-Sight ホストテーブルに含まれるいずれかのビジョンシステムが DHCP を使用するように設定されている場合、ビジョンシステムの IP アドレスが変更されると、ホストテーブルエントリが無効になることがあります。ホストテーブルで定義されるどのビジョンシステムについても、固定 IP アドレスを設定することを強く推奨します。

特徴

(対象の特徴)

マシンビジョンでは、特徴とは「画像内の対象物」を指し、画像内で検出されるさまざまな種類の特徴に対してビジョン検査が設計されます。

ファームウェア

ファームウェアは、物理的な In-Sight ビジョンシステム内で動作するソフトウェアコードです。適切なファームウェア更新ファイル (*.UPD) を In-Sight エミュレータからロードすることによって、ビジョンシステムは、最新バージョンのファームウェアに更新できます。ファームウェアの更新手順を参照してください。

フィクスチャ

フィクスチャは、ビジョンツールの出力で、他のビジョンツールの基準点となり、行、列、および角度の座標値を備えます。フィクスチャを選択する場合、画像内の部品を見て、どの種類のフィクスチャが最もすばやく簡単に認識できるかを判断し、そのフィクスチャが部品の各画像に存在することを確認します。その後、フィクスチャの種類に基づき、適切なビジョンツールを選択して特徴を定義します。検査時に特徴がフィクスチャとして使用されると、In-Sight ビジョンシステムは最初にその特徴を検索します。特徴が検出されると、その特徴の位置は他のビジョンツールの基準点となります。他のビジョンツールは、フィクスチャされた特徴の位置に基づいて検査を実行します。

注:
  • 対象部分がビジョンシステムから見てどの画像でも正確に同じ位置に存在する場合、フィクスチャは不要です。
  • 1 つ以上のフィクスチャを作成しジョブの中で使用できます。フィクスチャは相互にリンクできます。

HOSTS.NET

ビジョンシステムの In-Sight ホストテーブルエントリを含む仮想ファイルです。HOSTS.NET は、システムファイルであり、削除することはできません。

画像

(画像ファイル)

In-Sight ビジョンシステムによって取り込んだ画像は、.BMP または .JPG ファイルとして PC に保存できます。これらのファイルは、その後、ジョブテストで使用するために、In-Sight ビジョンシステムまたはエミュレータによってロードされます。In-Sight ビジョンシステムは、画像 (image.bmp) を 1 つしか保管できません。画像のコピーを永続的に保存する場合は、画像を PC のハードディスクに保存する必要があります。画像ファイルは、[In-Sight ネットワーク] または Microsoft Windows エクスプローラからドラッグアンドドロップ操作によって開くことができます。

IMAGE.BMP

In-Sight ビジョンシステムに表示されるアクティブな画像データを含む仮想ファイルです。IMAGE.JPG と同じです。IMAGE.BMP は、システムファイルであり、削除できないことに注意してください。

IMAGE.JPG

In-Sight ビジョンシステムに表示されるアクティブな画像データを含む仮想ファイルです。IMAGE.BMP と同じです。IMAGE.JPG は、システムファイルであり、削除できないことに注意してください。

In-Sight エミュレータ

(エミュレータ)

(In-Sight オフラインエミュレータ)

In-Sight エミュレータは、[オプション] ダイアログで選択されているエミュレーションモードに応じて、さまざまなタイプの In-Sight ビジョンシステムの動作をエミュレートできるオフラインプログラミングソフトウェアです。エミュレータには、In-Sight ビジョンシステムと同じように、[In-Sight ネットワーク] からアクセスできます。

In-Sight ホストテーブル

In-Sight ホストテーブルには、リモートホストの固定 IP アドレスが定義されています。それぞれ異なるサブネットにある複数の In-Sight ビジョンシステムが互いに通信する必要がある場合、この定義は必須です。In-Sight ビジョンシステムは、TCPDevice、WriteImageFTP、WriteSMTP などの関数で通信する際にホストテーブルを使用します。

注: In-Sight ホストテーブルに含まれるいずれかのビジョンシステムが DHCP を使用するように設定されている場合、ビジョンシステムの IP アドレスが変更されると、ホストテーブルエントリが無効になることがあります。ホストテーブルで定義されるどのビジョンシステムについても、固定 IP アドレスを設定することを強く推奨します。

In-Sight ビジョンシステム

(In-Sight センサ)

(In-Sight ビジョンセンサ)

In-Sight ビジョンシステムは、画像を取り込むためのデジタルグレースケールまたはカラーカメラとそれらをデジタル化する CCD チップ、プログラムされた画像解析を実行する PC プロセッサ、および結果をレポートしたり、ロボットや PLC などの他のデバイスとの間でメッセージを送受信したりする入出力ハードウェアと通信リンクから構成されます。Cognex 製ビジョンシステム全製品のリストについては、弊社のウェブサイト http://www.cognex.com/ProductsServices/VisionSystems/ を参照してください。

ジョブ

(ジョブファイル)

ジョブファイル (*.JOB) は、マシンビジョンの特定のタスクを実行するように設定されています。In-Sight ビジョンシステムでは、ジョブファイルの容量は、使用可能なフラッシュメモリの容量に制限されます。In-Sight エミュレータ (PC 上で動作) のファイル容量は、PC のハードディスクのサイズに基づきます。ジョブファイルは、In-Sight FTP サーバだけでなく、非 In-Sight FTP サーバからでも In-Sight ビジョンシステムにロードできます。アクティブなジョブファイルの名前は、そのファイルが過去に 1 回でも保存されていれば、タイトルバーに表示されます。ジョブファイルは、[In-Sight のファイル] 一覧または Microsoft Windows エクスプローラから、ドラッグアンドドロップ操作によって開くこともできます。

OCR

Optical Character Recognition (光学文字認識) の略で、未知の文字を読み取り、その結果を文字モデルとパターンマッチングして文字を「認識」し、認識した文字を文字列として転送するプロセスです。

「文字照合/認識関数の概要」を参照してください。

OCV

Optical Character Verification (光学文字照合) の略で、既知の文字を読み取り、その結果を文字モデルとパターンマッチングして、予想される文字列が存在したかどうかを「照合」するプロセスです。

「文字照合/認識関数の概要」を参照してください。

オフラインプログラミングキー

In-Sight Explorer がネットワークで In-Sight ビジョンシステムを検出しない場合、In-Sight ジョブを In-Sight のオフラインのエミュレータ環境でローカルに設定するために、[オプション] ダイアログでオフラインプログラミングキーを入力する必要があります。

詳細については、「ソフトウェアの登録」を参照してください。

OPC タグ

OPC チャネルを使用して通信するデータを含むセルを表示するのに使用されるシンボリックタグです。

パターン

パターンには、反復する形状の単純なグループから、ロゴやラベルなどの複雑な構成までさまざまなものが含まれます。パターンは、最も信頼性の高い種類の特徴であり、最大範囲の位置の回転、移動、スケールのばらつきが許容されますが、一般に検査には最も長い時間がかかります。

PC Host

In-Sight PC Host は、以前から使用されている In-Sight ビジョンシステム用プログラミングソフトウェアです。In-Sight Explorer は、PC Host の機能をエミュレータとして備えており、In-Sight ジョブのオフラインプログラミングおよびテストを実行できます。

proc.set

In-Sight ビジョンシステムの設定は、proc.set ファイルに保存されます。このファイルには、次の情報が含まれています。ネットワーク構成、シリアルポート設定、ユーザリストデータ、In-Sight ホストテーブルエントリ、スタートアップオプション、および日付/時刻の設定ダイアログ

注: proc.set は、システムファイルであり、削除することはできません。

ROI

Region of Interest (対象領域) の略です。検査する画像の領域を定義します。

行

In-Sight ビジョンシステムピクセル座標系の Y 方向を定義します。

Closed 例

シンボリックタグ

位置決めまたは検査ツール結果、ジョブデータおよびパラメータ制御 (例: Blobs_1.Pass_Count など) といった、EasyBuilder ビューやそのほかのデバイスとの通信に使用されるデータを含むセルの表示に使用します。また、OPC チャネルから In-Sight OPC サーバに転送して、監査メッセージサーバに監査メッセージを生成するか、または EasyView の作成に使用できるデータを含むセルの表示にも使用します。これにより、Cognex VisionView デバイスでのデータの表示方法をカスタマイズし、データがオペレータによって編集可能かどうかを決定することができます。

テキスト

英数字 (ABC、123 など) のテキスト文字列です。
VisionView アプリケーション | Cognex VisionView® アプリケーションソフトウェアは VisionView オペレータインタフェースパネル、VisionView VGA、PC または Windows CE ベースの HMI パネルに導入することができます。VisionView アプリケーションソフトウェアを使用して複数のビジョンシステムに接続し、工場フロアのオペレータにビジョンシステムが取り込んだ画像や、重要な合格/不合格データを表示することができます。
Version: 5.6.0


テクニカルサポート

In-Sight Explorer リファレンス

参照ドキュメンテーション

インターネットリソース

電話によるサポート

修理および返品

参照ドキュメンテーション

このヘルプファイルに加え、次の製品ドキュメントリソースを参照すると In-Sight ビジョンシステム、およびそのインタフェースについてさらに深い知識を習得できます。

  • 『In-Sight Micro シリーズビジョンシステム リファレンスガイド』
  • 『In-Sight 2000 シリーズビジョンシステム リファレンスガイド』
  • 『In-Sight 5000 シリーズビジョンシステム リファレンスガイド』
  • 『In-Sight 7000 シリーズビジョンシステム インストールガイド』
  • 『In-Sight 7000 Gen2 シリーズビジョンシステム リファレンスガイド』
  • 『In-Sight 8000 シリーズビジョンシステム リファレンスガイド』
  • 『In-Sight CIO-MICRO および CIO-MICRO-CC I/O モジュール インストールガイド』
  • 『Model 1460 I/O 拡張モジュールのインストールガイドとリファレンス』
  • 『Model 1450 I/O 拡張モジュールのインストールガイドとリファレンス』
  • 『Model 1400 I/O 拡張モジュールのインストールガイドとリファレンス』

インターネットリソース

In-Sight サポート(http://www.cognex.com/support/InSight) では、ユーザの皆様の In-Sight に関する問題にお答えしております。サポートセンターでは、次のリソースを提供しております。

  • In-Sight ソフトウェアおよびファームウェアのダウンロード
  • 最新版ドキュメント、および機構図面
  • トレーニング
  • Cognex ナレッジベース: http://help.cognex.com または http://help.cognex.com/m (モバイルデバイスから)
  • E メールサポートリスト
  • パーツおよびアクセサリのオンラインカタログ
  • 事例提示

電話によるサポート

製品ドキュメントやオンラインサポートでも In-Sight に関する問題が解決できない場合は、弊社テクニカルサポートに電話でご相談ください。

  • 米国:　+1-508-650-4100
  • 日本:　+81-3-4579-5835
  • フランス:　+33 (0)1 4777 1550
  • イギリス:　+44 (0)1908 206000
  • ドイツ:　+49 (0) 7 21 / 66 39 - 0
  • イタリア:　+39 (0)267471200

修理および返品

電子メール: ckk_support@cognex.com


ソフトウェアの登録

In-Sight Explorer リファレンス

オフラインプログラミングキー

In-Sight Explorer がネットワークで In-Sight ビジョンシステムを検出しない場合、In-Sight ジョブを In-Sight のオフラインのエミュレータ環境でローカルに設定するために、[オプション] ダイアログでオフラインプログラミングキーを入力する必要があります。

注:
  • いずれかのバージョンの PC Host 用のオフラインプログラミングラインセンスを購入済みの場合は、これらのライセンスを、In-Sight Explorer 用の有効なオフラインプログラミングキーとして使用できます。
  • オフラインプログラミングキーをまだ入力していない場合に、In-Sight Explorer を起動すると、Error 6001 または Error 6047 が表示されることがあります。
Version: 5.6.0


法律上の注意

In-Sight Explorer リファレンス

著作権

本ドキュメントで説明しているソフトウェアは、ライセンスの下で作成されており、本ページに記されている著作権を明記したライセンスに基づいた許可なしに、使用したり複写したりすることはできません。本ソフトウェア、本書、あるいはそれらのコピーをライセンスの保有者以外に提供することはできません。本ソフトウェアのあらゆる権利は Cognex Corporation あるいは権限を有する第三者に帰属します。Cognex Corporation は、当社の供給によらない装置上での本ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本ソフトウェアの商業性、非侵害または特定目的に対する適合性に関して、明示的にも黙示的にも一切の保証を行いません。

本ドキュメントで説明している Cognex 製ソフトウェアのソースプログラムのコピーもすべて、Cognex Corporation のみの所有物です。ソースプログラムは、セキュリティ保護されたバージョンコントロールシステムに保存され、このソフトウェアの開発に直接関与する Cognex の技術担当者だけにアクセスが制限されています。ソースプログラムが第三者と共有されたことはありません。

本ドキュメントの内容は、予告なしに変更することがあります。内容の変更について、Cognex Corporation はいかなる責任も負いません。本ドキュメントあるいは関連ソフトウェアにおける誤りについて、Cognex Corporation はいかなる責任も負いません。

本書で例として使用されている企業名、人名およびデータは、特に断りがない限り架空のものです。本書のいかなる部分も、Cognex Corporation の書面による許諾なく複製すること、手段・方法・目的を問わず電子的または機械的に転載すること、他のメディアに変換すること、および他の言語に翻訳することを禁じます。

Copyright © 1999 -2019

Cognex Corporation

All Rights Reserved

特許

Cognex の提供するハードウェアおよびソフトウェアの一部は、下記のウェブサイトに示す米国およびその他の国の特許、または出願中の特許で保護されています。http://www.cognex.com/patents

商標

下記は Cognex Corporation の登録商標です。

  • Cognex
  • Cognex Vision for Industry
  • In-Sight
  • EasyBuilder
  • VisionView
  • The In-Sight "crosshair" logo
  • OCRMax
  • PatFind
  • PatMax
  • PatQuick

下記は Cognex Corporation の商標です。

  • The Cognex logo
  • TestRun
  • PatMax RedLine

そのほかの製品名および企業名は、各所有者に帰属する商標です。
Version: 5.6.0


Cognex Connect

In-Sight の通信環境

Cognex Connect™ を使用すると、In-Sight ビジョンシステムを既存の FA システムに統合できます。Cognex Connect™ には、ビジョンシステムで使用可能な通信機能が用意されています。PLC またはロボットコントローラに In-Sight を直接接続している場合やネットワークに接続している PC または HMI から複数の In-Sight ビジョンシステムを管理している場合、Cognex Connect は、In-Sight と工場フロアに置かれているすべての機器の間に、シームレスで信頼性の高い通信リンクを保ちます。設定インタフェースを備えているため、ネットワークに接続している PC から複数のビジョンシステムを制御することができます。また、ユーザは、企業内に設置してあるファイルサーバにデータおよび画像を転送し、ユーザ独自のオペレーティングインターフェースを作成することによりデータや画像を表示することができます。

Cognex Connectは、開発環境である EasyBuilder もしくはスプレッドシートのツールとして、下記の制御機器および通信機器機器用としてサポートしています。

· PLC | Cognex Connect は、オープンスタンダードな産業用 Ethernet 通信プロトコル (SLMP、EtherNet/IP、PROFINET など) をサポートしています。そのため、さまざまな PLC (三菱電機、Rockwell、Siemens など) に問題なく接続することができます。
· PC または HMI | Cognex Connect は、OPC サーバ、Active X ディスプレイコントロール、および標準の TCP/IPEthernet 通信プロトコルをサポートしています。
ロボット | 設定済みドライバ、汎用のテンプレート、およびサンプルコードは、ABB、Denso、Fanuc、Kawasaki、Kuka、Motoman、および Staubli で製造されたロボットで使用できます。三菱電機、Adept、Epson、およびほかの製造元のロボットとの通信もサポートしています。
フィールドバス | Cognex Connect は、CC-Link、DeviceNet、PROFIBUS などの標準をすべてサポートしています。

すべての In-Sight モデルで、一連の Cognex Connect 通信機能がサポートされています。Cognex Connect の詳細については、www.cognex.com/connect を参照してください。
Version: 5.6.0


非明示的メッセージ

EtherNet/IP 通信 - In-Sight 4.x.x ファームウェア

In-Sight 通信リファレンス

EtherNet/IP 非明示的メッセージングを使用すると、In-Sight ビジョンシステムの入力および出力を ControlLogix または CompactLogix PLC のタグにマップすることができます。これらの値は、確立後、RPI (Requested Packet Interval) によって定義される間隔で同期されます。RPI の間隔を過ぎるたび、PLC はビジョンシステムのステータスレジスタを更新し、ビジョンシステムが PLC のステータスレジスタを更新することを要求します。

次の図に、EtherNet/IP を使用した Ethernet ベースの I/O を示します。

注: この情報については、「EtherNet/IP オブジェクトモデル - In-Sight 4.x.x ファームウェア」のトピックで詳しく説明されています。

EtherNet/IP ビジョンオブジェクトは、In-Sight センサ内のさまざまなサブシステムのステータスと、In-Sight Explorer スプレッドシートからの着信データと発信データを追跡します。

入力アセンブリと出力アセンブリは、EtherNet/IP ビジョンオブジェクトのさまざまなフィールドをマップします。

  • 入力アセンブリは、PLC に送信される In-Sight ビジョンシステムのデータ値の集合です (PLC 入力)。
  • 出力アセンブリは、In-Sight ビジョンシステムが PLC から受信するデータ値の集合です (PLC 出力)。

EtherNet/IP 非明示的メッセージング接続があった場合、これらの値はクライアント上で RPI 間隔で更新されます。また、クライアントが EtherNet/IP 非明示的メッセージング接続を介して値を更新した場合、これらの変更は In-Sight センサの各種サブシステムに反映され、それに応じて In-Sight センサは応答します。

In-Sight ビジョンシステムと ControlLogix コントローラの間で EtherNet/IP 非明示的メッセージング接続をセットアップするには、最初に、In-Sight ビジョンシステムを ControlLogix I/O Configuration ツリーに設定する必要があります。ラックの Ethernet モジュールに対応するノードに、汎用 Ethernet モジュールを I/O デバイスとして追加する必要があります。
Version: 5.6.0


非明示的メッセージ

EtherNet/IP 通信 - In-Sight 5.x.x ファームウェア

In-Sight 通信リファレンス

EtherNet/IP 非明示的メッセージングを使用すると、In-Sight ビジョンシステムの入力および出力を ControlLogix または CompactLogix PLC のタグにマップすることができます。これらの値は、確立後、RPI (Requested Packet Interval) によって定義される間隔で同期されます。RPI の間隔を過ぎるたび、PLC はビジョンシステムのステータスレジスタを更新し、ビジョンシステムが PLC のステータスレジスタを更新することを要求します。

次の図に、EtherNet/IP を使用した Ethernet ベースの I/O を示します。

注: この情報については、「EtherNet/IP オブジェクトモデル - In-Sight 5.x.x ファームウェア」のトピックで詳しく説明されています。

EtherNet/IP ビジョンオブジェクトは、In-Sight センサ内のさまざまなサブシステムのステータスと、In-Sight Explorer スプレッドシートからの着信データと発信データを追跡します。

入力アセンブリと出力アセンブリは、EtherNet/IP ビジョンオブジェクトのさまざまなフィールドをマップします。

  • 入力アセンブリは、PLC に送信される In-Sight ビジョンシステムのデータ値の集合です (PLC 入力)。
  • 出力アセンブリは、In-Sight ビジョンシステムが PLC から受信するデータ値の集合です (PLC 出力)。

EtherNet/IP 非明示的メッセージング接続があった場合、これらの値はクライアント上で RPI 間隔で更新されます。また、クライアントが EtherNet/IP 非明示的メッセージング接続を介して値を更新した場合、これらの変更は In-Sight センサの各種サブシステムに反映され、それに応じて In-Sight センサは応答します。

In-Sight ビジョンシステムと ControlLogix コントローラの間で EtherNet/IP 非明示的メッセージング接続をセットアップするには、最初に、In-Sight ビジョンシステムを ControlLogix I/O Configuration ツリーに設定する必要があります。ラックの Ethernet モジュールに対応するノードに、汎用 Ethernet モジュールを I/O デバイスとして追加する必要があります。
Version: 5.6.0


ロボット通信 - Kuka ロボットコントローラ - シリアル

In-Sight 通信リファレンス

Kuka ロボットコントローラは、複雑ではあっても非常に強力なエラーチェックプロトコルを使用して、RS-232 シリアルポート経由でほかのデバイスと通信します。Kuka シリアル通信用に設定すると、In-Sight ビジョンシステムはこのプロトコルを認識して、Kuka コントローラから受信したコマンドに応答できるようになります。

Kuka モードは、In-Sight のネイティブモード通信の拡張です。Kuka モードは ネイティブモードに基づくので、In-Sight のジョブをネイティブモードで開発してテストした後、実際のロボットコントローラが In-Sight ビジョンシステムに接続されている場合のみ Kuka モードに切り替えることができます。ジョブにその他の変更を加える必要はありません。

注:
  • In-Sight ビジョンシステムと通信するには、Kuka ロボットは P3964R モードである必要があります。また、後述のように、ビジョンシステムの [シリアルポートの設定] で、[モード] として Kuka が選択されている必要があります。
  • In-Sight ビジョンシステムは、Kuka のデフォルトのプロトコル設定 (すなわち、トランザクションにおいて、Kuka ロボットの優先度が高く、In-Sight ビジョンシステムの優先度が低い設定) を使用するように設定されています。
  • シリアルベースのロボット通信がブレークアウトケーブルでサポートされていますが (In-Sight 5000 シリーズまたは In-Sight 7000 シリーズのみ)、セットアップが容易なので I/O モジュールを推奨します。
  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • In-Sight 70xx ～ 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。詳細については、「In-Sight 70xx ～ 74xx ビジョンシステムのシリアル通信を有効にするには」を参照してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。
  • CIO-WENET イーサネット I/O モジュールはシリアル通信をサポートしていません。

Kuka 通信用に In-Sight ビジョンシステムを設定するには

  1. [センサ] メニューで、[シリアルポートの設定] をクリックします。
  2. [シリアルポートの設定] ダイアログで、[モード] ドロップダウンリストを開いて、[Kuka] を選択します。

これで、In-Sight ビジョンシステムは、Kuka コントローラの標準のシリアルポート設定をデフォルトとして使用するようになります。ただし、コントローラが別の設定を使用する場合には、Kuka コントローラと同じシリアルポート設定を使用するように、In-Sight を設定してください。

注: Kuka KR C2 および KR C2 Edition 2005 ロボットコントローラがサポートされます。

Kuka コマンド

データおよびコマンドを送信する際も、データを受信する際も、Kuka ロボットコントローラは、In-Sight ビジョンシステムとの間のすべてのデータ通信をネイティブモードコマンドを使用して開始します。

Kuka モードでは、次のネイティブモードコマンドがサポートされます。

ネイティブモードコマンド | シンタックス
Get Job | GJ
Get Online | GO
Get Value | GV
Load File | LF[Filename]
Set Event | SE[整数]
Store File | TF[Filename]
Set Float | SF[列][行][浮動小数点数]
Set Integer | SI[列][行][整数]
Set Job | SJ[ID]
Set Online | SO[整数]
Set String | SS[列][行][文字列]
Version: 5.6.0


In-Sight 監査メッセージサーバのデモ

In-Sight Explorer GUI リファレンス

In-Sight 監査メッセージサーバのデモでは、ネットワーク上で監査メッセージが 1 つ以上のビジョンシステムから受信される方法について説明しています。監査メッセージは、タイムスタンプが付けられた XML フォーマットのデータレコードです。これには、システムパラメータ、ユーザログオン、およびほかのシステムイベントへの変更点が含まれています。

注:
  • In-Sight 監査メッセージサーバのデモアプリケーションは、デモンストレーションとテストの目的で使用され、設置の目的では使用されません。
  • Visual Studio 2008 プロジェクトには、監査メッセージサーバ用のサンプルコードが含まれており、次のディレクトリにインストールされています。
    • Windows 7/Windows 10: C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Sample Projects x.x.x\C# v2008\Audit Message Server

    このサンプルでは、監査メッセージがファイルに記録されますが、必要に応じて、準拠データベースまたは監査証跡ロギングシステム用に監査メッセージを収集して XML データを変換するように変更することができます。

In-Sight 監査メッセージサーバのデモの使用法

監査メッセージの方式

In-Sight 監査メッセージサーバのデモの使用法

  1. Windows の [スタート] メニューから In-Sight 監査メッセージサーバのデモを起動します (デフォルトの場所は、C:\Program Files\Cognex\In-Sight\In-Sight Audit Message Server Demo x.x.x です)。

  2. サーバアドレスは PC の IP アドレスです。PC で複数のネットワーク IP アドレスが使用できる場合は、監査メッセージサーバに対して別の IP アドレスを選択することができます。[Select] ボタンをクリックして PC で使用できる IP アドレスを表示し、リストから監査メッセージサーバ用の IP アドレスを選択します。
  3. [Use local time for message] ボックスをオンにして、監査メッセージに PC の日時でタイムスタンプを付けます。こうすることによって、ネットワーク上の In-Sight ビジョンシステムが、SNTP サーバを使用するように設定されていないか、または SNTP サーバが使用できなくなった場合でも、そのビジョンシステムから受信したすべての監査メッセージに正確なタイムスタンプが付けられます。
  4. [追加] ボタンをクリックして、[Add Audit Message Port] ダイアログを開きます。1024 と 65535 の間で未使用の TCP/IP ポートを入力します (デフォルトは 5753)。これは、In-Sight ビジョンシステムから監査メッセージを収集するために、データベースまたは監査証跡ロギングソフトウェアが接続されるポートです。複数のビジョンシステムが、同じ監査メッセージポートにメッセージを送信することができます。または、複数の監査メッセージポートを追加し、監査メッセージング用に設定された各ビジョンシステムに対して 1 つのポートを使用することができます。

注: 次の TCP/IP ポートは、使用できる範囲内にあります。ただし、このポートは In-Sight で予約済みであるため、入力できません。1069 (In-Sight プロトコル)、1070 (マシンステータスデータ)、1212 (アップグレードポート)、2222 および 44818 (EtherNet/IP)、50000 (DataChannel)。

  5. [Log to File] ボックスをオンにします。プロンプトが出たら、ログファイルのファイル名を入力します (ファイルの拡張子は .txt または .log)。前のステップで複数の TCP/IP ポートを追加した場合は、ポートごとにログファイルを作成します。
  6. [In-Sight Audit Message Settings] ダイアログを設定します。
  7. [Start] ボタンをクリックします。監査メッセージサーバおよびビジョンシステムの監査メッセージの設定を正しく行うと、監査メッセージのデモアプリケーションに最初の監査メッセージが表示されます。

監査メッセージの方式

Closed 監査メッセージの XML 方式:

関連項目

[監査メッセージの設定] ダイアログ

Version: 5.6.0


オートチューン

In-Sight Explorer GUI リファレンス

[オートチューン] ダイアログは OCRMax 関数と連動して使用します。オートチューンレコードを生成してオートチューンモデルを作成することで、OCRMax 関数のセグメンテーションパラメータを設定し、フォントデータベースを登録します。オートチューンレコードには、画像、登録文字列、ユーザが確認済みの画像内の文字位置が含まれます。オートチューンモデルには、1 つ以上のオートチューンレコードと、オートチューンレコードに含まれるすべての画像の最適なセグメント設定が含まれます。

  • 概要
  • [オートチューン] ダイアログを表示するには
  • [オートチューン] ダイアログのタブと設定項目
  • [オートチューン] ダイアログの使用法
  • 関連項目

注:
  • In-Sight ビジョンシステムがオンラインになっている場合、[オートチューン] ダイアログは使用できません。
  • このパラメータが OCRMaxSettings 関数または GetInternalSettings 関数への参照として設定されている場合、[オートチューン] ダイアログは使用できません ([オートチューン] ダイアログを有効にするには、このパラメータを 0 に設定する必要があります)。GetInternalSettings 関数との関連で [オートチューン] ダイアログを有効にする方法については、「GetInternalSettings」関数を参照してください。
  • [オートチューン] ダイアログを使用する場合、セグメンテーションのチューニングは In-Sight ビジョンシステム上ではなく、In-Sight エミュレータ上で実行することを推奨します。OCRMax 関数のオートチューンアルゴリズムは大量の計算リソースを要するため、ビジョンシステム上よりもエミュレータ上で実行した方がパフォーマンスが向上します。
  • フォントデータベースを登録し、[オートチューン] ダイアログを使用して文字をセグメンテーションする場合は、文字の表示状態が最も良い画像の処理から開始し (画質が最も良い画像を最初に使用し)、表示状態の良いものから悪いものへと順番に処理することを推奨します。また、実行時に出現することが想定されるばらつきがすべて表れている画像を含めてください。これによって、OCRMax 関数のオートチューンアルゴリズムによるチューニングが成功しやすくなります。
  • オートチューンアルゴリズムは、+/- 5 度以上傾いている ROI 内のテキストに対しては機能しません。このシナリオでは、ROI をフィクスチャして角度範囲内のテキストに合わせて調整するか、[角度範囲] パラメータを 5 より大きい値に設定して、オートチューンアルゴリズムの計算にこの値を使用するようにします。
  • 文字がオーバーラップしている場合、オートチューンアルゴリズムは機能しません。オーバーラップしている文字は手動でセグメンテーションし、分類してください。
  • OCRMaxAutoTune 関数を使用することにより、VisionView オペレータインタフェースパネルなどの外部デバイスを使用して、[オートチューン] ダイアログに外部からアクセスすることができます。

概要

[オートチューン] ダイアログを実行すると、文字が正しくセグメンテーションされ、分類されているかを検証するため、各画像が調査されます。文字が正しくセグメンテーションされていない場合、OCRMax 関数のオートチューンアルゴリズムは、現在の画像 (オートチューンレコード) と以前登録された画像 (オートチューンモデル) をセグメンテーションする最適なセグメンテーションパラメータを計算します。画像の登録数が増えるほど、OCRMax 関数のオートチューンアルゴリズムの信頼性と正確性が向上します。満足な結果が得られたら、[オートチューン] ダイアログを閉じ、新しい セグメンテーションパラメータを適用します。フォントデータベースは新たに登録された文字で更新されます。

[オートチューン] ダイアログには、セグメンテーションパラメータを手動でチューニングする場合に比べて、主に 2 つの利点があります。

  1. 画像に必要なサイクルは、2 回 (1 回目にセグメンテーションパラメータをチューニングし、2 回目に登録する) ではなく、1 回だけです。
  2. 読み取り精度は、チューニングプロセス中に取得されるセグメンテーションパラメータによって文字が自動的に登録されることによって向上します。

[オートチューン] ダイアログを表示するには

OCRMax プロパティシートから、[オートチューン] ボタンを押します。

[オートチューン] ダイアログのタブと設定項目

[オートチューン] ダイアログは、[オートチューン]、[設定]、[記録]、[フォント] の 4 つタブで構成されています。

これらのタブのほかに、次の設定項目を含むツールバーがあります。

  • [リセット]:[セグメント] タブのパラメータがデフォルト設定にリセットされ、フォント情報がクリアされ、この関数に関連するオートチューンレコード (.rec) ファイルが削除されるように指定します。
  • [開く]: [開く] ダイアログを起動します。このダイアログを使用して、以前保存したオートチューンモデル (.REC ファイルなど) に移動します。デフォルトでは、[オートチューン] ダイアログには、最後に保存されたオートチューンモデルが自動的にロードされます。
  • [名前を付けて保存]: [名前を付けて保存] ダイアログを起動します。このダイアログを使用して、オートチューンモデル (.REC ファイルなど) を保存および格納するディレクトリに移動します。デフォルトでは、オートチューンモデルは接続されている In-Sight デバイス (エミュレータまたは In-Sight ビジョンシステム。どちらが接続されているか、ジョブの開発に使用されたかによります) 上のメモリに保存されます。

  • [領域の編集]: 対話型グラフィックモードを起動します。このモードを使用して、OCRMax の対象領域を変更することができます。

    注: 参照される OCRMax 関数の [領域] パラメータがセル参照または数式によって定義されている場合、[領域の編集] 設定項目は無効になります。

  • [最初の画像]: 再生フォルダ ([記録/再生のオプション] ダイアログで設定します) に保存されている最初の画像に移動します。
  • [前の画像]: 再生フォルダに保存されている前の画像に移動します。
  • [次の画像]: 再生フォルダに保存されている次の画像に移動します。
  • [最後の画像]: 再生フォルダに保存されている最後の画像に移動します。
  • [画像を開く]: [画像を開く] ダイアログを起動します。このダイアログを使用して、画像ディレクトリに移動します。
  • [ライブビデオ]: ライブビデオモードに切り替えます。In-Sight ビジョンシステムから連続的に画像を取り込み、表示領域に表示します。このオプションは、ビジョンシステムに接続しているときのみ使用できます。

オートチューン

[オートチューン] タブでは、登録するテキスト文字列の入力、自動または手動での文字セグメンテーションの有効化、フォントデータベースへの文字の追加を行います。

  • [Text] フィールド: 登録するテキスト文字列を指定します。文字列にスペースが含まれている場合、キーボードのスペースキーを使用して入力します。
  • [セグメントの修正 (自動)]: OCRMax 関数で、文字領域を作成し、さまざまな組み合わせのセグメンテーションパラメータを使用して、正しい文字数が検出されるまで自動的にセグメンテーションを試行します。
  • [セグメントの修正 (手動)]: 対話型グラフィックモードで文字領域のサイズと位置を個別に編集することにより、文字領域を手動で調整します。その後、OCRMax 関数が文字領域の形状と位置に基づいて、最適なセグメンテーションパラメータを計算します。
  • [文字登録のみ]: [Text] フィールドに指定したテキストを登録し、フォントに追加します。セグメンテーションパラメータの調整は行いません。

設定

[設定] タブでは、OCRMax 関数のオートチューニングアルゴリズムの設定を行います。

  • [結果数]: 生成する候補結果の最大数 (1 ～ 9,999,999、デフォルト = 30) を指定します。

    注: In-Sight ビジョンシステムに接続している場合、最大 15 件のオートチューンモデルの結果を生成することができます。

  • [パラメータステップ]: 各セグメンテーションパラメータの試行の最大繰り返し回数 (1 ～ 100、デフォルト = 5) を指定します。

    注: 繰り返し回数を多くするほど、オートチューンプロセスの完了までの時間が長くなります。

  • [ファイル名の自動保存]: .REC ファイルの名前を指定します。デフォルト名は「ocrs_{cell}.rec」です (名前を指定する場合、ファイルパスまたは拡張子を追加しないでください)。ファイル名の最大長は 255 文字で、英数字とアンダースコアのみを使用できます。[OK] ボタンを押して [オートチューン] ダイアログを閉じると、自動的に .REC ファイルが In-Sight ビジョンシステムのメモリにエクスポートされます。その後、[オートチューン] ダイアログを再び開いたとき、自動的に .REC ファイルがインポートされます。

    注: .REC ファイルを特定の場所に保存する、または特定の場所からロードするには、[オートチューン] ダイアログのツールバーの設定項目の [開く] オプションと [名前を付けて保存] オプションを使用します。

  • [パラメータのロック]: [パラメータのロック] ダイアログを起動します。このダイアログでは、[オートチューン] ダイアログで最適なセグメンテーションパラメータ (オートチューンプロセスの開始前に設定します) を計算するときに変更しない OCRMax パラメータを指定します。

    Closed [パラメータのロック] ダイアログ

    注: スプレッドシート内のセル参照として作成されたパラメータは、自動的にロックされ無効になります。

記録

[記録] タブには、オートチューンレコードのリストが表示されます。オートチューンレコードには、画像、登録テキスト文字列、ユーザが確認済みの画像内の文字位置が含まれます。

  • テーブル: 登録に使用される画像の名前、登録されるテキスト文字列、セグメントおよび文字が検証済みであるかどうかが表示されます。

  • [記録の表示]: 有効にするレコードを選択してこのボタンを押すと、[オートチューン結果] ダイアログが起動します。このダイアログには以前登録した文字領域が表示され、その下に現在のオートチューン結果が表示されます。現在の結果による文字のセグメンテーションが登録済みの結果よりも適切である場合、[記録を現在の結果に置き換える] ボタンを押して、以前登録された文字領域を現在のオートチューン結果で上書きします。

    Closed [オートチューン結果] ダイアログ

  • [記録の削除]: レコードを選択してこのボタンを押すと、そのレコードがリストから削除されます。

    注: レコードの削除が完了するまでに、しばらく時間がかかる場合があります。

フォント

[フォント] タブには、登録された文字とそのインスタンスが読み取り専用で表示されます。

[オートチューン] ダイアログの使用法

以下のすべての手順は、登録する文字が含まれているサンプル画像のデータベースが作成され、ディレクトリに配置されていることを前提にしています。また、スプレッドシートに OCRMax 関数が挿入されていることも前提にしています。

[オートチューン] ダイアログを使用した OCR アプリケーションの文字の登録およびセグメンテーションプロセスは、以下により構成されます。

  • 登録画像のロード
  • 自動文字セグメンテーションによる画像の登録
  • 手動文字セグメンテーションによる画像の登録
  • 文字識別の修正

登録画像のロード

  1. 画像をロードします。[画像] メニューから [記録/再生のオプション] を選択します。
  2. [記録/再生のオプション] ダイアログは、自動的に [再生] タブが表示された状態で開きます。表示されていない場合は、[再生] タブをクリックします。
  3. [再生フォルダ] セクションで [参照] ボタンをクリックし、[フォルダの参照] ダイアログを表示します。登録画像が含まれているディレクトリに移動し、[OK] ボタンを押して続行します。
  4. [再生フォルダ] には指定したディレクトリが表示されます。[画像カウント] はこのディレクトリに保存されている画像の数を示しています。[記録/再生のオプション] ダイアログの [OK] ボタンをクリックして、続行します。
  5. [再生フォルダ] ディレクトリを指定すると、[オートチューン] ダイアログツールバーの [最初の画像]、[前の画像]、[次の画像]、[最後の画像] の各ボタンを使用して、画像に移動することができます。

自動文字セグメンテーションによる画像の登録

  1. [オートチューン] ダイアログでは、デフォルトで、[オートチューン] タブが表示されます。[Text] フィールドに、登録するテキスト文字列を入力します。
  2. [オートチューン] ダイアログのツールバーの [領域の編集] ボタンを押して対話型グラフィックスモードに切り替え、読み取るテキスト行の上に OCRMax 関数の対象領域を配置します。対象領域の設定時には、必ず角回転とスキューの両方またはどちらかを考慮してください。
  3. 関数は、関数が [セグメント] タブのデフォルト設定に基づいて文字であると判断したテキストの周囲に自動的に文字領域を作成します。
  4. [セグメンテーションの修正 (自動)] ボタンを押すと、OCRMax 関数を使用して、セグメンテーションパラメータを自動的に調整することができます。

  5. OCRMax 関数が文字をセグメンテーションした後、[自動セグメントの結果] ダイアログに結果のリストが表示されます。

  6. 結果を確認し、どの結果が最も適切に文字をセグメンテーションしているかを判断します。リストで結果を選択すると、画像内の文字領域が更新されます。必要に応じて、[結果の編集] ボタンを押して対話型グラフィックスモードに切り替え、文字の周囲の文字領域を手動で調整します。
  7. 最適な結果が決まったら、リストから結果を選択し、[OK] ボタンを押して、[自動セグメントの結果] ダイアログを閉じます。
  8. 新しいオートチューンレコードが作成され、新しい文字領域で画像が更新されます。フォントも新しく登録された文字で更新されます。
  9. 次の画像をロードして、手順 1 ～ 8 を繰り返します。
  10. すべての登録画像を使用したら、[OK] ボタンを押して、[オートチューン] ダイアログを閉じます。

手動文字セグメンテーションによる画像の登録

  1. [オートチューン] ダイアログでは、デフォルトで、[オートチューン] タブが表示されます。[Text] フィールドに、登録するテキスト文字列を入力します。
  2. [オートチューン] ダイアログのツールバーの [領域の編集] ボタンを押して対話型グラフィックスモードに切り替え、読み取るテキスト行の上に OCRMax 関数の対象領域を配置します。対象領域の設定時には、必ず角回転とスキューの両方またはどちらかを考慮してください。
  3. 関数は、関数が [セグメント] タブのデフォルト設定に基づいて文字であると判断したテキストの周囲に自動的に文字領域を作成します。
  4. [セグメンテーションの修正 (手動)] ボタンを押して、対話型グラフィックモードに切り替えます。
  5. 必要に応じて、文字領域の位置とサイズを手動で編集します。
  6. すべての文字領域のサイズと位置を必要に応じて再指定した後、[ジョブの編集] ツールバーの [OK] ボタンを押して、対話型グラフィックスモードを終了します。
  7. [オートチューン] ダイアログが再び表示され、新しいオートチューンレコードが作成され、新しい文字領域で画像が更新されます。フォントも新しく登録された文字で更新されます。
  8. 次の画像をロードして、手順 1 ～ 8 を繰り返します。
  9. すべての登録画像を使用したら、[OK] ボタンを押して、[オートチューン] ダイアログを閉じます。

文字識別の修正

このオプションは、画像のセグメンテーションは正しく行われているが、文字が正しく識別されていない場合に使用します。

  1. [オートチューン] ダイアログでは、デフォルトで、[オートチューン] タブが表示されます。[Text] フィールドに、登録するテキスト文字列を入力します。
  2. [文字登録のみ] ボタンを押します。

  3. 新しく登録された文字によってフォントが更新され、新しいオートチューンレコードが作成されます。

    注: 「Incorrect Auto-Tune Record text string in the Auto-Tune Model (オートチューンモデル内に記録されたオートチューンレコードテキスト文字列が正しくありません)」というエラーメッセージが表示された場合、このエラーメッセージは、分類が異なる点を除いて別のオートチューンレコードと同一のオートチューンレコードが追加されたことを示します。例えば、1 つ目のオートチューンレコードで数字の「0」が文字の「O」として分類され、2 つ目のオートチューンレコードで正しく数字の「0」として分類された場合、このエラーが発生します。このエラーが発生した場合は、[記録] タブに移動し、オートチューンレコードに対して指定されたテキスト文字列が正しいことを確認します。

関連項目

  • OCRMax 関数
  • OCRMaxAutoTune 関数
  • OCRMaxSettings 関数
  • OCRMax 関数の設定方法
Version: 5.6.0


バッチ実行

In-Sight Explorer GUI リファレンス

[バッチ実行] ダイアログでは、TestRun で使用する複数の In-Sight ジョブファイルのロードと、単一操作としてのテストの実行を行います。

  • [バッチ実行] ダイアログを表示するには
  • [バッチ実行] ダイアログの設定項目
  • 関連項目

[バッチ実行] ダイアログを表示するには

  1. [パレット] の [TestRun] タブで、[TestRun] ツールバーの [バッチ実行] ボタンを押します。

[バッチ実行] ダイアログの設定項目

  • [選択中のジョブ] テーブル: チェックボックス、ジョブ名、ディレクトリの位置、TestRun の実行中および完了後のジョブのステータス (成功/失敗) が表示されます。
  • [ジョブの追加]: このボタンを押すと、[選択] ダイアログが起動します。このダイアログを使用して、1 つ以上のジョブやディレクトリを選択します。ディレクトリを選択すると、ディレクトリ内のすべての .job ファイルが追加されます。
  • [削除]: ジョブを選択してこのボタンを押すと、ジョブがリストから削除されます。
  • [すべて削除]: リスト内のジョブをすべて選択して削除します。
  • [ジョブのロード]: テーブルからジョブを選択してこのボタンを押すと、接続されている In-Sight エミュレータまたはビジョンシステムにそのジョブがロードされます。
  • [すべてを含む]: このボタンを押すと、テーブル内のすべてのジョブをバッチ実行に自動的に含めることができます。
  • [すべてを除外]: このボタンを押すと、テーブル内のすべてのジョブのバッチ実行を自動的に無効にすることができます。
  • [レポートロケーション]: バッチ実行レポートログのディレクトリの場所を表示します。
    • 注: [レポートロケーション] が FTP サーバを使用するように設定されている場合は、ホスト名の後にスラッシュを使用する必要があります。
    • 正: ftp://10.28.127.73/
    • 誤: ftp://10.28.127.73
  • [参照]: このボタンを押すと、[開く] ダイアログが起動します。このダイアログを使用して、バッチ実行レポートログを保存するディレクトリの場所を指定します。
  • [レポート名]: バッチ実行レポートログの名前を表示します。
  • [権限]: このボタンを押すと、[権限] ダイアログが起動します。このダイアログでは、ジョブが保存されているフォルダにアクセスするためのユーザ認証を入力します (必要な場合)。このユーザ認証は、TestRun セットアップの [画像データベースフォルダ] のステップで入力する内容と一致している必要があります。
  • [日付 & 時間をレポート名に含める]: バッチ実行レポートログファイル名に、日付と時間を付加するかどうかを指定します。有効にすると、名前とファイルフォーマットの間に日付/タイムスタンプが挿入されます。例えば、レポートの名前が「MyReport」でファイルフォーマットが XML の場合、レポート名は「MyReport.20121011_082345.xml」のようになります。
  • [レポートフォーマット]: バッチ実行レポートのファイルフォーマットを指定します (プレーンテキスト、XML、または HTML。デフォルト = XML)。
  • [実行]: このボタンを押すと、バッチ TestRun 処理が開始します。ジョブを 1 つ以上選択し、レポートロケーションと作成レポート名を指定しなければ、[実行] ボタンは有効になりません。[実行] ボタンを押すと、[選択中のジョブ] テーブルの [ステータス] 列に、テスト実行の進行状況が表示されます。
  • [閉じる]: このボタンを押すと、ダイアログが終了します。

関連項目

  • TestRun EasyBuilder ビュー
  • TestRun スプレッドシートビュー


[CC-Link IE フィールド Basic の設定] ダイアログ

In-Sight Explorer GUI Reference

[CC-Link IE フィールド Basic の設定] ダイアログを使用して、In-Sight ビジョンシステムを CC-Link IE フィールド Basic プロトコル を介し、三菱電機社シーケンサと通信するように設定することができます。

[CC-Link IE フィールド Basic の設定] ダイアログを表示するには

  • [ネットワークの設定] ダイアログから、[CC-Link IE フィールド Basic] オプションを有効にし、[設定] ボタンをクリックします。

[CC-Link IE フィールド Basic の設定] ダイアログのコントロール

  • ユーザデータバイパスの有効化: このチェックボックスを ON にすると、キャッシュされたデータをバイパスし、生のユーザーデータを直接読み取ることができます。 CC-Link IE フィールド Basic プロトコルでは、このチェックボックスを ON にすると、RY20～3F [User Data(Bit Area)]、RWw1～1F (User Data) のデータをビジョンセンサに反映させることができます。
    • OFF (デフォルト): RY10 (Set User Data)を OFF → ON にしないと反映されない。
    • ON: RY10 (Set User Data) を OFF → ON しなくても反映される。

注意: データブロックの詳細については、CC-Link IE フィールドネットワーク Basic のファクトリインターフェイストピックをご参照ください。


[フォーマット入出力バッファ] ダイアログ

入出力関数

In-Sight Explorer GUI リファレンス

[FormatInputBuffer] ダイアログと [FormatOutputBuffer] ダイアログを使用して、FormatInputBuffer 関数と FormatOutputBuffer 関数のデータを自動的に設定し、フォーマットされたデータを含む [image] 構造体を返します。

データは、一般に PLC との間で送受信され、使用される通信のタイプに応じて一部の入出力関数でも使用することができます。プロトコルによっては、データにパディングして (すなわち、必要なデータの間に未使用データを追加して)、データが PLC のデータ配置と一致するようにする必要があります。EtherNet/IP プロトコルの場合、RSLogix は、ユーザ定義のデータ型を 4 バイト境界にパディングします ([FormatOutputBuffer] ダイアログでは 4 バイト境界へのデータの配置をサポートしません)。Inspection Results データ配列を受信すると、RSLogix 5000 は、送信されたデータに複数のデータ型 (整数、浮動小数点数、ビット) が含まれていたかどうかに関係なく、配列全体に単一のデータ型を割り当てます。結果に異なるデータ型が含まれている場合は、送信されることが予期されるデータ型に基づいて、Inspection Results 配列にバイトオフセットをコピーし、RSLogix のユーザ定義のデータ型にバイト単位の長さをコピーする必要があります。

サポートされる産業用イーサネットプロトコルの 1 つを介してパッケージ化データを送信する場合は、プロトコルベンダのドキュメントを参照してプロトコルのデータ配置とパッキング動作を決定します。

[FormatInputBuffer] ダイアログを表示するには

  1. スプレッドシートの空白のセルを選択します。
  2. [挿入] メニューで、[式] をクリックします。
  3. [関数の挿入] ダイアログで、[入出力] カテゴリを展開します。
  4. 右側のリストで、[FormatInputBuffer] をダブルクリックします。

[FormatInputBuffer] ダイアログの設定項目

  • [データ型]: 自動的に設定するデータの型を指定します。

  • [エレメントごとのバイト数]: 選択したデータ型が [文字列] または [バイト順序反転文字列] の場合、データのサイズをバイト単位で指定します。そのほかのデータ型のサイズはすべて固定で編集できません。[エレメントごとのバイト数] フィールドには、最大 4,000 バイトを入力することができます。ただし、最大入力長を超えた場合、プロトコルでは読み取ることはできません。入力データが制限を超えた場合、プロトコルはその一部しか読み取ることができません。

    注:

    • Modbus TCP、EIP、または PROFINET 通信を使用している場合の入力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、入力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、入力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。

    • メッセージの総サイズが 4,000 バイトを超えた場合は、#ERR が返されます。

    データ型 | サイズの範囲 (バイト数)
    ビット* | 1 ビット
    8 ビット整数

    1
    8 ビット符号なし整数

    1
    16 ビット整数

    2
    16 ビット符号なし整数

    2
    32 ビット整数

    4
    32 ビット浮動小数点数

    4
    文字列
    • Modbus TCP、EIP、または PROFINET = 1 ～ 4000 (ワードベースのプロトコルの場合は 1 ～ 2000)。
    • SLMP または SLMP スキャナで iQ-R/Q/L シリーズまたは iQ-F シリーズ = 1 ～ 1920 (ワードベースのプロトコルの場合は 1 ～ 960 ワード)。
    • SLMP または SLMP スキャナで FX シリーズ = 1 ～ 128 (ワードベースのプロトコルの場合は 1 ～ 64 ワード)。
    • そのほかのすべての通信方法 = 1 ～ 256 (ワードベースのプロトコルの場合は 1 ～ 128 ワード)。
    バイト順序反転文字列
    • Modbus TCP、EIP、または PROFINET = 1 ～ 4000 (ワードベースのプロトコルの場合は 1 ～ 2000)。
    • SLMP または SLMP スキャナで iQ-R/Q/L シリーズまたは iQ-F シリーズ = 1 ～ 1920 (ワードベースのプロトコルの場合は 1 ～ 960 ワード)。
    • SLMP または SLMP スキャナで FX シリーズ = 1 ～ 128 (ワードベースのプロトコルの場合は 1 ～ 64 ワード)。
    • そのほかのすべての通信方法 = 1 ～ 256 (ワードベースのプロトコルの場合は 1 ～ 128 ワード)。

    *[ビット] データタイプは、SLMP および CC-Link 通信の場合のみ使用可能です。
  • [追加]: リストにデータ型を追加します。
  • [削除]: ハイライトしたデータ型をリストから削除します。
  • [上に移動]: ハイライトしたデータ型をリストの上に移動します。そのデータ型が既にリストの最初の場合、[上に移動] ボタンはグレーアウトされます。
  • [下に移動]: ハイライトしたデータ型をリストの下に移動します。そのデータ型が既にリストの最後の場合、[下に移動] ボタンはグレーアウトされます。

[フォーマット出力バッファ] ダイアログを表示するには

  1. スプレッドシートの空白のセルを選択します。
  2. [挿入] メニューで、[式] をクリックします。
  3. [関数の挿入] ダイアログで、[入出力] カテゴリを展開します。
  4. 右側のリストに表示された FormatOutputBuffer をダブルクリックします。

[フォーマット出力バッファ] ダイアログの設定項目

  • [セル範囲]: 選択した [データ型] の値を含む参照セル (またはセル範囲) を指定します。

注: 各データ型は有効な値を含むセルを参照する必要があります。そうでない場合、ダイアログは #ERR を返します。

  • [データ型]: 自動的に設定するデータの型を指定します。

  • [エレメントごとのバイト数]: 選択したデータ型が [文字列] または [バイト順序反転文字列] の場合、データのサイズをバイト単位で指定します。そのほかのデータ型のサイズはすべて固定で編集できません。[エレメントごとのバイト数] フィールドには、最大 4,000 バイトを入力することができます。ただし、最大出力長を超えた場合、プロトコルでは書き込むことはできません。出力データが制限を超えた場合、プロトコルはその一部しか書き込むことができません。

    注:

    • Modbus TCP、EIP、または PROFINET 通信を使用している場合の出力データの最大長は 4,000 バイトです。SLMP または SLMP スキャナを使用しているときに、[iQ-R/Q/L シリーズ] または [iQ-F シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 1,920 バイトです。SLMP または SLMP スキャナを使用しているときに、[FX シリーズ] で [コントローラタイプ] が選択されている場合、出力データの最大長は 128 バイトです。そのほかのすべての通信方法では最大長は 256 バイトです。

    • メッセージの総サイズが 4,000 バイトを超えた場合は、#ERR が返されます。
    • 16 ビット整数 1 つは 3 文字であるため、16 ビット整数を使用する場合、出力データの最大長は 140 バイトになります。この上限を超えた場合、関数から「Error String too long」が返されます。出力データが制限を超える場合は、CombineOutputBuffers 関数を使用します。

    データ型 | サイズの範囲 (バイト数)
    ビット* | 1 ビット
    8 ビット整数 | 1
    8 ビット符号なし整数 | 1
    16 ビット整数 | 2
    16 ビット符号なし整数 | 2
    32 ビット整数 | 4
    64 ビット整数 | 8
    32 ビット浮動小数点数 | 4
    文字列
    • Modbus TCP、EIP、または PROFINET = 1 ～ 4000 (ワードベースのプロトコルの場合は 1 ～ 2000)。
    • SLMP または SLMP スキャナで iQ-R/Q/L シリーズまたは iQ-F シリーズ = 1 ～ 1920 (ワードベースのプロトコルの場合は 1 ～ 960 ワード)。
    • SLMP または SLMP スキャナで FX シリーズ = 1 ～ 128 (ワードベースのプロトコルの場合は 1 ～ 64 ワード)。
    • そのほかのすべての通信方法 = 1 ～ 256 (ワードベースのプロトコルの場合は 1 ～ 128 ワード)。
    バイト順序反転文字列
    • Modbus TCP、EIP、または PROFINET = 1 ～ 4000 (ワードベースのプロトコルの場合は 1 ～ 2000)。
    • SLMP または SLMP スキャナで iQ-R/Q/L シリーズまたは iQ-F シリーズ = 1 ～ 1920 (ワードベースのプロトコルの場合は 1 ～ 960 ワード)。
    • SLMP または SLMP スキャナで FX シリーズ = 1 ～ 128 (ワードベースのプロトコルの場合は 1 ～ 64 ワード)。
    • そのほかのすべての通信方法 = 1 ～ 256 (ワードベースのプロトコルの場合は 1 ～ 128 ワード)。
    *[ビット] データタイプは、SLMP および CC-Link 通信の場合のみ使用可能です。
  • [メッセージサイズ (バイト)]: 総メッセージサイズ (バイト単位) を表示します。
  • [追加]: 1 つ以上のセルを参照するセル選択モードを呼び出します。ダイアログを開いたままでセルを選択できます。
  • [削除]: ハイライトしたデータ型をリストから削除します。ハイライトされた項目がない場合、[削除] ボタンは使用できません。
  • [上に移動]: ハイライトしたデータ型をリストの上に移動します。そのデータ型が既にリストの最初の場合、[上に移動] ボタンはグレーアウトされます。
  • [下に移動]: ハイライトしたデータ型をリストの下に移動します。そのデータ型が既にリストの最後の場合、[下に移動] ボタンはグレーアウトされます。

Closed FormatOutputBuffer の例

  1. セル A2、A3、および A4 が次のような内容であるとします。

A2 = EditInt(0,255)

A3 = EditFloat(0,100)

A4 = EditString(8)

スプレッドシートには次のように表示されます。

  2. FormatOutputBuffer 関数をセル C2 に挿入します。[フォーマット出力バッファ] ダイアログが自動的に開きます。

  3. [追加] ボタンをクリックして、適切なデータを含むセルを参照します。例えば、セル A2 をハイライトします。

  4. Enter キーを押して、参照セルの選択を適用し、[フォーマット出力バッファ] ダイアログに戻ります。参照したセルがダイアログのリストに表示されています。
  5. [追加] ボタンをクリックして、さらにセル参照を追加します。リスト内の既存の項目の [データ型] を変更したり、削除したり、並べ替えたりすることができます。

  6. [OK] をクリックしてダイアログを閉じ、スプレッドシートに戻ります。 　データ構造体が返されます。

関連項目

  • FormatInputBuffer 関数
  • ReadCCLinkBitBuffer 関数
  • WriteCCLinkBitBuffer 関数
  • ReadCCLinkWordBuffer 関数
  • WriteCCLinkWordBuffer 関数
  • ReadDeviceNetBuffer 関数
  • WriteDeviceNetBuffer 関数
  • ReadEIPBuffer 関数
  • WriteEIPBuffer 関数
  • ReadDeviceNetBuffer 関数
  • ReadModbusBuffer 関数
  • WriteModbusBuffer 関数
  • ReadProfinetBuffer 関数
  • WriteProfinetBuffer 関数
  • ReadUserDataBuffer 関数
  • WriteResultsBuffer 関数
  • CombineOutputBuffers 関数
Version: 5.6.0


[FormatString] ダイアログ

文字列操作関数

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

[FormatString] ダイアログを使用して、位置決めツールおよび検査ツールのデータを選択してフォーマットし、ロボットコントローラなどのリモートデバイスに送信可能な出力文字列を生成します。ロボットの文字列を設定する ([通信] アプリケーションステップの [通信] グループボックスで、[デバイス] を [ロボット] に設定するか、[プロトコル] を [シリアル Kuka] または [シリアル Motoman] に設定する) 場合、[FormatString] ダイアログでは、ジョブで生成されたフィクスチャ出力が自動で選択されます。

[FormatString] ダイアログ内では、参照されたそれぞれのツール結果が個々の項目としてリストに表示されます。各項目は、ラベル、データ型、小数点以下の桁数、固定幅およびパッドを割り当てることによってフォーマットできます。項目をフォーマットするためには、まずリストでハイライト表示する必要があります。出力文字列全体は、先行テキスト、終端テキスト、終端記号および区切り文字を追加することによってフォーマットできます。

注:
  • 順番に並んでいない複数のアイテムをまとめてフォーマットするには、CTRL キーを押したまま各アイテムを順番にハイライト表示してください。
  • 順番に並んでいる複数のアイテムをまとめてフォーマットするには、SHIFT キーを押したままリストの最初のアイテムをハイライト表示し、次に最後のアイテムをハイライト表示します。

[FormatString] ダイアログの設定項目

  • [先行テキスト]: 出力文字列プレフィックス。文字列の最大長は 30 文字です。
  • [終端テキスト]: 出力文字列サフィックス。文字列の最大長は 30 文字です。
  • [終端記号]: 選択した終端文字を出力文字列に付加します。
    • [なし]: 出力文字列に終端文字は付加されません。
    • [Line Feed (ラインフィード (LF))]: 出力文字列にラインフィードを付加します。
    • [Carriage Return (CR) (キャリッジリターン (CR))]: 出力文字列にキャリッジリターンを付加します。
    • [Carriage Return and Line Feed (CR+LF)　(キャリッジリターンとラインフィード (CR+LF))]: 出力文字列にキャリッジリターンとラインフィードを付加します。
  • [Use Delimiter (区切り文字の使用)]: デフォルトで有効にされ、項目が区切られます。文字列の最大長は 1 文字です。
    • [標準]: 標準の区切り文字 (カンマ、スペース、タブ、セミコロンまたはアンダースコア) を選択できます。
    • [その他]: 1 文字のカスタム区切り文字を入力できます。
  • [追加]: [出力データの選択] ダイアログが開きます。このダイアログには、ジョブに追加されたすべての位置決めおよび検査ツールからのデータが表示されます。適切な結果を選択すると、[FormatString] ダイアログにより、選択した結果ごとに項目が 1 つ返されて作成されます。
  • [削除]: 項目リストからハイライト表示した項目を削除します。ハイライト表示の項目がない場合、[削除] ボタンは無効になります。
  • [上に移動]: ハイライト表示した項目をリストの上方に移動します。項目がリストの先頭にある場合、このボタンは無効になります。
  • [下に移動]: ハイライト表示した項目をリストの下方に移動します。項目がリストの末尾にある場合、このボタンは無効になります。
  • [ラベル]: 各項目には、その項目を識別するラベルを付けることができます。文字列の最大長は 12 文字です。
  • [ラベルを含める]: 有効にすると、項目のラベルが項目の文字列よりも前に置かれて出力文字列に含められます。
  • [データ型]: [FormatString] ダイアログでは、参照された結果の内容に基づいて、項目ごとにデータ型が自動的に判別されます。
    • [整数]: 整数値を含む文字列を返します。
    • [Unsigned Integer (符号なし整数)]: 符号なし整数値を含む文字列を返します。
    • [Integer (hex) (整数 (hex))]: 整数値の 16 進数値を含む小文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (HEX) (整数 (HEX))]: 整数値の 16 進数値を含む大文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (Octal) (整数 (8 進数))]: 整数値の 8 進数値を含む文字列、または英数文字列の最初の文字を返します。
    • [浮動小数点]: 浮動小数点値を含む文字列を返します。
    • [Scientific Notation (科学的表記法)]: 科学的表記法値を含む文字列を返します。
    • [文字]: 整数値に対応する ASCII 文字を返します。英数テキスト文字列が入力されると、最初の文字を返します。
    • [文字列]: 整数値を含む文字列を返します。
  • [Decimal Places　(小数点以下の桁数)]: 浮動小数点または科学的表記法のデータ型の小数点以下の桁数を選択します。(0 ～ 6、デフォルト = 6)。
  • [固定幅]: 各項目の文字列を固定幅として設定可能です。
    • [フィールド幅]: 各項目の文字列に含める最小文字数を指定します。(1 ～ 30、デフォルト = 8)。
    • [Pad (パディング)]: 項目の文字列の文字数が指定された [フィールド幅] より少ない場合は、次のいずれかの方法でパディングされます。
      • [Leading Spaces (先行スペース)]: 先行スペースを挿入して右揃えします。
      • Trailing Spaces (末尾スペース)]: 末尾スペースを挿入して左揃えします。
      • [Leading Zero (先行ゼロ)]: 先行ゼロを挿入して右揃えします。

  • [出力文字列]: 出力文字列を表示します。現在ハイライト表示された項目に対応する文字が太字で表示されます。 合計文字数が表示されます。シンタックス: <Leading Text (optional)><Label (optional)><Item0><Delimiter (optional)><Item1><Delimiter (optional)>...<Terminator>

スプレッドシートビュー

[FormatString] ダイアログを使用することで、参照されたセルデータを簡単にフォーマットし、リモートデバイスに送信可能な出力文字列を生成できます。[FormatString] ダイアログ内では、参照されたそれぞれのセルが個々の項目としてリストに表示されます。各項目は、ラベル、データ型、小数点以下の桁数、固定幅およびパッドを割り当てることによってフォーマットできます。項目をフォーマットするためには、まずリストでハイライト表示する必要があります。出力文字列全体は、先行テキスト、終端テキスト、終端記号および区切り文字を追加することによってフォーマットできます。

注:
  • 順番に並んでいない複数のアイテムをまとめてフォーマットするには、CTRL キーを押したまま各アイテムを順番にハイライト表示してください。
  • 順番に並んでいる複数のアイテムをまとめてフォーマットするには、SHIFT キーを押したままリストの最初のアイテムをハイライト表示し、次に最後のアイテムをハイライト表示します。

[FormatString] ダイアログを表示するには

  1. スプレッドシートの空白のセルを選択します。
  2. [挿入] メニューで、[式] をクリックします。
  3. [関数の挿入] ダイアログで、[テキスト] カテゴリを展開します。
  4. 右側のペインで、FormatString をダブルクリックします。

[FormatString] ダイアログの設定項目

  • [先行テキスト]: 出力文字列プレフィックス。文字列の最大長は 30 文字です。
  • [終端テキスト]: 出力文字列サフィックス。文字列の最大長は 30 文字です。
  • [終端記号]: 選択した終端文字を出力文字列に付加します。
    • [なし]: 出力文字列に終端文字は付加されません。
    • [Line Feed (ラインフィード (LF))]: 出力文字列にラインフィードを付加します。
    • [Carriage Return (CR) (キャリッジリターン (CR))]: 出力文字列にキャリッジリターンを付加します。
    • [Carriage Return and Line Feed (CR+LF)　(キャリッジリターンとラインフィード (CR+LF))]: 出力文字列にキャリッジリターンとラインフィードを付加します。
  • [Use Delimiter (区切り文字の使用)]: 有効にすると、項目が区切られます。文字列の最大長は 1 文字です。
    • [標準]: 標準の区切り文字 (カンマ、スペース、タブ、セミコロンまたはアンダースコア) を選択できます。
    • [その他]: 1 文字のカスタム区切り文字を入力できます。
  • [追加]: 1 つ以上のセルを参照するセル選択モードを呼び出します。セルを選択すると、このダイアログにより、選択したセルごとに項目が 1 つ返されて作成されます。
  • [削除]: 項目リストからハイライト表示した項目を削除します。ハイライト表示の項目がない場合、[削除] ボタンは無効になります。
  • [上に移動]: ハイライト表示した項目をリストの上方に移動します。項目がリストの先頭にある場合、このボタンは無効になります。
  • [下に移動]: ハイライト表示した項目をリストの下方に移動します。項目がリストの末尾にある場合、このボタンは無効になります。
  • [ラベル]: 各項目には、その項目を識別するラベルを付けることができます。文字列の最大長は 12 文字です。
  • [ラベルを含める]: 有効にすると、項目のラベルが項目の文字列よりも前に置かれて出力文字列に含められます。
  • [セル]: 各項目には式が 1 つ含まれています。式のほとんどはセル参照です。式内のセル参照は、スプレッドシート内のグラフィックスと一致するように色分けされます。

ヒント: [セル] テキストボックスにカーソルを合わせ F4 を押すと、4 つのセル参照タイプが順に切り替わります。

  • [データ型]: [FormatString] ダイアログでは、参照されたセルの内容に基づいて、項目ごとにデータ型が自動的に判別されます。
    • [整数]: 整数値を含む文字列を返します。
    • [Unsigned Integer (符号なし整数)]: 符号なし整数値を含む文字列を返します。
    • [Integer (hex) (整数 (hex))]: 整数値の 16 進数値を含む小文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (HEX) (整数 (HEX))]: 整数値の 16 進数値を含む大文字の文字列、または英数文字列の最初の文字を返します。
    • [Integer (Octal) (整数 (8 進数))]: 整数値の 8 進数値を含む文字列、または英数文字列の最初の文字を返します。
    • [浮動小数点]: 浮動小数点値を含む文字列を返します。
    • [Scientific Notation (科学的表記法)]: 科学的表記法値を含む文字列を返します。
    • [文字]: 整数値に対応する ASCII 文字を返します。英数テキスト文字列が入力されると、最初の文字を返します。
    • [文字列]: 整数値を含む文字列を返します。
  • [Decimal Places　(小数点以下の桁数)]: 浮動小数点または科学的表記法のデータ型の小数点以下の桁数を選択します。(0 ～ 6、デフォルト = 6)。
  • [固定幅]: 各項目の文字列を固定幅として設定可能です。
    • [フィールド幅]: 各項目の文字列に含める最小文字数を指定します。(1 ～ 30、デフォルト = 8)。
    • [Pad (パディング)]: 項目の文字列の文字数が指定された [フィールド幅] より少ない場合は、次のいずれかの方法でパディングされます。
      • [Leading Spaces (先行スペース)]: 先行スペースを挿入して右揃えします。
      • Trailing Spaces (末尾スペース)]: 末尾スペースを挿入して左揃えします。
      • [Leading Zero (先行ゼロ)]: 先行ゼロを挿入して右揃えします。
  • [出力文字列]: 出力文字列を表示します。現在ハイライト表示された項目に対応する文字が太字で表示されます。 合計文字数が表示されます。シンタックス: <Leading Text (optional)><Label (optional)><Item0><Delimiter (optional)><Item1><Delimiter (optional)>...<Terminator>

Closed FormatString 関数の例

以下の例では、ExtractBlobs 関数を使用して、画像の特徴の位置と角度を検索します。 FormatString 関数では、このデータを参照して、リモートデバイスに送信可能な出力文字列を返します。

  1. DetectBlobs 関数をセル A3 に挿入します。 　データ構造体が返されます。
  2. FormatString 関数をセル A5 に挿入します。[FormatString] ダイアログが自動的に開きます。

  3. [追加] ボタンをクリックして、適切なデータを含むセルを参照します。例えば、 [image] データ構造体で返されるセル C3、D3、E3 をハイライト表示します。

  4. Enter キーを押して、参照セルの選択を適用し、[FormatString] ダイアログに戻ります。参照されたセルがダイアログのリストに項目として表示されます。リストの既存の項目を追加、削除、並べ替えすることができます。
  5. [Leading Text (先行テキスト)] テキストボックスに、「ABC」と入力します。
  6. [Leading Text (末尾テキスト)] テキストボックスに、「XYZ」と入力します。
  7. [終端記号] ドロップダウンリストから、[CR+LF] を選択します。
  8. [区切り文字] チェックボックスをオンにします。
  9. [Standard Delimiter (標準区切り文字)] ドロップダウンリストから、[スペース] を選択します。

  10. リストの先頭の項目をハイライト表示し、セル C3 を参照します。[ラベル] テキストボックスに、([行] スプレッドシートのセルに対応する)「X」と入力します。
  11. リストの　2 番目の項目をハイライト表示し、セル D3 を参照します。[ラベル] テキストボックスに、([Col (列)] スプレッドシートのセルに対応する)「Y」と入力します。
  12. リストの　3 番目の項目をハイライト表示し、セル E3 を参照します。[ラベル] テキストボックスに、([角度] スプレッドシートのセルに対応する)「Angle」と入力します。
  13. SHIFT キーを押さえたままで、リストの最初の項目を選択してからリストの最後の項目を選択します。すべての項目がハイライト表示され、一度にフォーマット可能になります。
  14. [ラベルを含める] チェックボックスをオンにします。
  15. [データ型] が [浮動小数点] になっていることを確認します。
  16. [Decimal Places (小数点以下の桁数)] 入力ボックスに、「3」と入力します。
  17. [固定幅] チェックボックスをオンにします。
  18. [固定幅] テキストボックスに、「8」と入力します。
  19. [Pad (パディング)] ドロップダウンリストから、[先行ゼロ] を選択します。

  20. [OK] をクリックして [FormatString] ダイアログを閉じ、スプレッドシートに戻ります。セル A5 に出力文字列が表示されます。

関連項目

FormatString 関数

Stringf


[SLMP スキャナ設定] ダイアログ

In-Sight Explorer GUI リファレンス

[SLMP スキャナ設定] ダイアログでは、三菱電機 PLC およびモーションコントローラ (MC) と通信する In-Sight ビジョンシステムを設定します。

[SLMP スキャナ設定] ダイアログを表示するには

  1. [ネットワークの設定] ダイアログで [産業イーサネットプロトコル] の [SLMP スキャナ] オプションをオンにして、[設定] ボタンを押します。

[SLMP スキャナ設定] ダイアログの [設定] および [デバイスのアドレス指定] タブの設定項目

[設定] タブ

[設定] タブは、In-Sight ビジョンシステムと三菱電機 PLC/MC の間の接続を確立するのに必要な接続情報を設定するために使用されます。

注: 三菱電機 ネットワーク設定の詳細については、『MELSEC Communication Protocol Reference Manual』を参照してください。

  • [コントローラタイプ]: 三菱シーケンサのタイプを指定します。選択肢は、iQ-R/Q/L シリーズ (3E フレーム)、iQ-F シリーズ (3E フレーム) または FX シリーズ (1E フレーム) です。デフォルトでは、iQ-R/Q/L シリーズ (3E フレーム) が選択されます。

    注: iQ-F シリーズ (3E フレーム) オプションは、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
  • [IP アドレス]: In-Sight ビジョンシステムの接続先の PLC の IP アドレスを指定します。

  • [ポート番号]: PLC が使用する SLMP チャネルの TCP ポート番号を 10 進数 (Dec: 1 ～ 65535) 形式または 16 進数 (HEX: 1 ～ FFFF) 形式で指定します (デフォルト = 12288 ([Dec]))。

    注:
    • この値は、三菱電機 PLC/MC の [SLMP Port] で指定した [Host Port] の設定に一致している必要があります。
    • [ポート番号] の形式は、In-Sight Explorer を閉じたときに 10 進値 ([10 進数]) にリセットされます。
  • [タイムアウト (ms)]: PLC から SLMP メッセージへの応答用のタイムアウトをミリ秒単位で指定します (5 ～ 30000、デフォルト = 1000)。
  • [ポーリング間隔 (ms)]: PLC 上のビジョンコントロールブロックの連続するポーリング間の時間をミリ秒単位で指定します (5 ～ 30000、デフォルト = 1000)。
  • [リモートステーションに接続]: デフォルトでは、このチェックボックスはオフにされています。この場合、In-Sight ビジョンシステムは、入力した IP アドレスで指定した Ethernet モジュールを使用して、直接 PLC/MC に接続されています。
    • このチェックボックスがオンで、[コントローラタイプ] として [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] が選択されている場合、[ネットワーク番号]、[PC 番号] および [書込み先モジュール] の設定項目が有効になります。
    • このチェックボックスがオンで、[コントローラタイプ] で [FX シリーズ (1E フレーム)] を選択されている場合、[PC 番号] 設定項目が有効になります。
  • [ネットワーク番号]: 通信を行うのに使用する SLMP ネットワーク番号を指定します (0 ～ 239、デフォルト = 0、0 = ローカルネットワーク)。

  • [PC 番号 (16 進数)]: 指定した処理先モジュールのネットワーク上のステーション ID を 16 進値で指定します (0x1 ～ 0x78 = CC-Link IE フィールドネットワークアダプタ上のステーション、0x7E = CC-Link IE フィールドネットワーク上のマスタステーション、0xFF = ローカルステーションへの直接接続、デフォルト = 0xFF)。

  • [書込み先モジュール]: ビジョンシステムの接続先のデバイスモジュールの ID (0x3FF = ローカルステーション、0x3D0 = 制御システム CPU、0x3D1 = スタンバイシステム CPU、0x3D2 = システム A CPU、0x3D3 = システム B CPU、0x3E0 = CPU 1、0x3E1 = CPU 2、0x3E2 = CPU 3、0x3E3 = CPU 4、デフォルト = 0x3FF)。
  • [リセット] ボタン: [リセット] ボタンを押すと、値がすべてデフォルト設定値にリストアされます。
  • [テスト接続] ボタン: [テスト接続] ボタンは、In-Sight ビジョンシステムと三菱電機 PLC の間の SLMP 経由の「テスト」接続を確立するために使用されます。[テスト接続] ボタンを押すと接続が開始され、接続を確立する試行が実行されます。30 秒後、タイムアウトになるまでに接続が確立されないか、またはエラー状態になった場合は、SLMP によってエラーを報告するエラーメッセージが表示されます。

注: [SLMP スキャナ設定] ダイアログで値を変更したにもかかわらず、ビジョンシステムで SLMP が有効にならない場合は、ビジョンシステムを再起動して SLMP を有効にする必要があることを示すメッセージが表示されます。この場合は、ビジョンシステムを再起動して SLMP を有効にする必要があります。

[デバイスのアドレス指定] タブ

[デバイスのアドレス指定] タブは、PLC/MC のデバイスアドレス、および In-Sight ビジョンシステムから三菱電機 PLC/MC に通信されるさまざまなデータブロックのサイズを設定するために使用されます。[デバイスタイプ] およびデータブロックサイズは、[設定] タブで定義する、[コントローラタイプ] (iQ-F/R/Q/L シリーズ] または [FX シリーズ]) によって異なります。

  • [名前] 列: PLC/MC との間で通信されるデータブロックの名前を指定します (読み取り専用)。
  • [選択中のデバイス] 列: データブロックの読み取りまたは書き込みに使用される PLC デバイスを指定します。使用可能な PLC/MC デバイスは次のとおりです。
    • iQ-R/Q/L シリーズ: X - 入力リレー、Y - 出力リレー、M - 内部リレー、L - ラッチリレー、F - アナンシエータ、B - リンクリレー、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ。
    • iQ-F シリーズ: X - 入力リレー、Y - 出力リレー、M - 内部リレー、F - アナンシエータ、D - データレジスタ。
    • FX シリーズ: X - 入力リレー、Y - 出力リレー、M - 内部リレー、D - データレジスタ、R - 拡張レジスタ、S - ステートリレー。
  • [オフセット] 列: データブロックの読み取りまたは書き込みに使用されるデバイステーブルのオフセットを指定します。オフセット値は、[選択中のデバイス] のタイプにより、10 進数、16 進数または 8 進数で入力します。
    • iQ-R/Q/L シリーズ

      • [10 進値]: M - 内部リレー、L - ラッチリレー、F - アナンシエータ、D - データレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ。

      • [16 進値]: X - 入力リレー、Y - 出力リレー、B - リンクリレー、W - リンクレジスタ。
    • iQ-F シリーズ

      • [10 進値]: M - 内部リレー、F - アナンシエータ、D - データレジスタ。

      • [8 進値]: X - 入力リレー、Y - 出力リレー。
    • FX シリーズ
      • [10 進値]: M - 内部リレー、D - データレジスタ、R - 拡張レジスタ、S - ステートリレー。
      • [8 進値]: X - 入力リレー、Y - 出力リレー。
  • [デバイス数] 列: PLC/MC と通信されるデータブロックのサイズを指定します。サイズは、PLC/MC「デバイス」で使用される単位で表されます (ワードまたはビットのいずれか)。固定サイズでないデータブロック、または参照した FormatInputBuffer または FormatOutputBuffer 関数によってサイズが自動的に設定されるデータブロックの場合にのみ設定可能です。[入力ブロック]、[出力ブロック]、[コマンド]、[コマンド結果] の最大データサイズは、選択した [コントローラタイプ] ([iQ-R/Q/L シリーズ]、[iQ-F シリーズ] または [FX シリーズ]) に応じて異なります。

iQ-R/Q/L シリーズ

名前 | 選択中のデバイス | オフセット | デバイス数 | 説明
コントロール | なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、L - ラッチリレー、F - アナンシエータ、B - リンクリレー、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ | 0 ～ | 32 (読み取り専用) | ビジョンコントロールの PLC 先頭アドレス。
ステータス | なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、L - ラッチリレー、F - アナンシエータ、B - リンクリレー、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ |  | 32 (読み取り専用) | ビジョンステータスの PLC 先頭アドレス。
入力ブロック | なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ |  | 2 つのデバイス1 + 入力データ長 (ワード単位) (最大: 960 ワード) | 検査結果の PLC 先頭アドレス。
出力ブロック | なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ |  | 5 つのデバイス2 + 出力データ長 (ワード単位) (最大: 960 ワード) | ユーザデータの PLC 先頭アドレス。
コマンド | なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ |  | 0 ～ 960 (デフォルト = 0) | コマンド文字列の PLC 先頭アドレス。
コマンド結果 | なし (デフォルト)、D - データレジスタ、W - リンクレジスタ、R - ファイルブロックレジスタ、ZR - ファイルレジスタ |  | 0 ～ 960 (デフォルト = 0) | コマンド結果データの PLC 先頭アドレス。
1 2 つのデバイス (4 バイト/2 ワード) は、[Job Load ID] と [User Length] で使用します。 2 5 つのデバイス (10 バイト/5 ワード) は、[Job ID]、[Acquisition ID]、[Inspection ID]、[Inspection Result Code]、[Inspection Result Length] で使用します。

iQ-F シリーズ

名前 | 選択中のデバイス | オフセット | デバイス数 | 説明
コントロール | なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、F - アナンシエータ、D - データレジスタ。 | 0 ～ | 32 (読み取り専用) | ビジョンコントロールの PLC 先頭アドレス。
ステータス | なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、F - アナンシエータ、D - データレジスタ。 |  | 32 (読み取り専用) | ビジョンステータスの PLC 先頭アドレス。
入力ブロック | なし (デフォルト)、D - データレジスタ |  | 2 つのデバイス1 + 入力データ長 (ワード単位) (最大: 960 ワード) | 検査結果の PLC 先頭アドレス。
出力ブロック | なし (デフォルト)、D - データレジスタ |  | 5 つのデバイス2 + 出力データ長 (ワード単位) (最大: 960 ワード) | ユーザデータの PLC 先頭アドレス。
コマンド | なし (デフォルト)、D - データレジスタ |  | 0 ～ 960 (デフォルト = 0) | コマンド文字列の PLC 先頭アドレス。
コマンド結果 | なし (デフォルト)、D - データレジスタ |  | 0 ～ 960 (デフォルト = 0) | コマンド結果データの PLC 先頭アドレス。
1 2 つのデバイス (4 バイト/2 ワード) は、[Job Load ID] と [User Length] で使用します。 2 5 つのデバイス (10 バイト/5 ワード) は、[Job ID]、[Acquisition ID]、[Inspection ID]、[Inspection Result Code]、[Inspection Result Length] で使用します。

FX シリーズ

名前 | 選択中のデバイス | オフセット | デバイス数 | 説明
コントロール | なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、D - データレジスタ、R - 拡張レジスタ、S - ステートリレー | 0 ～ | 32 (読み取り専用) | ビジョンコントロールの PLC 先頭アドレス。
ステータス | なし (デフォルト)、X - 入力リレー、Y - 出力リレー、M - 内部リレー、D - データレジスタ、R - 拡張レジスタ、S - ステートリレー |  | 32 (読み取り専用) | ビジョンステータスの PLC 先頭アドレス。
入力ブロック | なし (デフォルト)、D - データレジスタ、R - 拡張レジスタ |  | 2 つのデバイス1 + 入力データ長 (ワード単位) (最大: 64 ワード) | 検査結果の PLC 先頭アドレス。
出力ブロック | なし (デフォルト)、D - データレジスタ、R - 拡張レジスタ |  | 5 つのデバイス2 + 出力データ長 (ワード単位) (最大: 64 ワード) | ユーザデータの PLC 先頭アドレス。
コマンド | なし (デフォルト)、D - データレジスタ、R - 拡張レジスタ |  | 0 ～ 64 (デフォルト = 0) | コマンド文字列の PLC 先頭アドレス。
コマンド結果 | なし (デフォルト)、D - データレジスタ、R - 拡張レジスタ |  | 0 ～ 64 (デフォルト = 0) | コマンド結果データの PLC 先頭アドレス。
1 2 つのデバイス (4 バイト/2 ワード) は、[Job Load ID] と [User Length] で使用します。 2 5 つのデバイス (10 バイト/5 ワード) は、[Job ID]、[Acquisition ID]、[Inspection ID]、[Inspection Result Code]、[Inspection Result Length] で使用します。

注:
  • データブロックの [選択中のデバイス] パラメータが [なし] に設定されている場合、PLC との間でデータブロックは通信されません。
  • 入力および出力データブロックは、コントロールおよびステータスワードデータでインライン通信されるため、TN および CN タイプのデバイスはサポートされていません。
  • iQ-R/Q/L シリーズと iQ-F シリーズでは、現在使用することができるフレームフォーマットのほとんどを処理できます (3E フレーム)。ただし、FX シリーズでは、最初の世代のプロトコルメッセージフレーム (1E フレーム) のみを処理することができます。このため、1 パケット内で送信可能なデータ量は制限されます。

最大データサイズ

iQ-R/Q/L シリーズと iQ-F シリーズ | FX シリーズ
バッチ読み取りビット数 | 7904 ビット | 256 ビット
バッチ読み取りワード数 | 960 ワード | 64 ワード
バッチ書き込みビット数 | 7904 ビット | 160 ビット
バッチ書き込みワード数 | 690 ワード | 64 ワード

関連項目

SLMP 通信

ネットワークのトラブルシューティング


[Modbus TCP サーバの設定] ダイアログ

In-Sight Explorer GUI リファレンス

[Modbus TCP サーバの設定] ダイアログでは、Modbus/TCP サーバとして動作するように In-Sight を設定します。

[Modbus TCP サーバの設定] ダイアログを表示するには

  • [ネットワークの設定] ダイアログで、[Modbus TCP サーバ] オプションを有効にして、[設定] ボタンを押します。

注: [ユーザデータバイパスの有効化] オプションは、In-Sight ファームウェア 5.4.0 以上を実行している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

[Modbus TCP サーバの設定] ダイアログの設定項目

  • [最大接続数]: ビジョンシステムがサポートする、最大同時接続可能数を指定します (1 ～ 6、デフォルト = 4)。
  • [アイドルタイムアウト]: 最後に発行された Modbus/TCP 要求をクライアントのサーバが受信してから、そのセッションがアイドル状態と宣言されるまでの時間を指定します (0 ～ 3600 秒、デフォルト = 120 秒)。Modbus/TCP サーバは、500ms おきに接続セッションをすべてチェックして、アイドルタイムに達したセッションがあるかどうかを決定します。アイドル状態のセッションに対し、Modbus/TCP サーバは、ソケットを閉じるコマンドを発行し、アイドル状態のセッションに割り当てられたリソースを再要求します。
  • [ユーザデータバイパスの有効化]: キャッシュデータをバイパスして、生ユーザデータを直接読み取る場合は、このチェックボックスをオンにします。デフォルトでは、この設定は無効になっています。


[POWERLINK の設定] ダイアログ

[センサ] メニュー

In-Sight Explorer GUI リファレンス

POWERLINK 産業用イーサネットプロトコルを設定する際に、In-Sight ビジョンシステムが POWERLINK 通信で使用する [ノード ID] を設定します。

  • [POWERLINK の設定] ダイアログの表示
  • [POWERLINK の設定] ダイアログの設定項目
  • 関連項目

[POWERLINK の設定] ダイアログの表示

  1. [産業用イーサネットプロトコル] グループボックスの [ネットワークの設定] ダイアログで、[POWERLINK] を選択します。
  2. これによって、[POWERLINK] の右側にある [設定] ボタンが有効になります。
  3. [設定] ボタンをクリックして、[POWERLINK の設定] ダイアログを起動します。

[POWERLINK の設定] ダイアログの設定項目

  • [ノード ID]: POWERLINK ネットワーク上にある In-Sight ビジョンシステムのノード ID を指定します (1 ～ 239。デフォルト = 1)。POWERLINK ネットワーク上にあるすべてのデバイスは、ノード ID で識別されます。この ID を固定 ID サブネットと結合し (192.168.100<NodeID>)、ネットワーク上の各デバイスに対して POWERLINK ネットワーク内の固定 IP アドレスを指定します。

ノード ID を POWERLINK ネットワークの NAT IP アドレスと組み合わせて使用することによって、POWERLINK ネットワークの外側にあるほかのデバイスと通信することができます。例えば、デフォルトの NAT IP アドレスは 192.168.101.0 です。ノード ID が 26 である In-Sight ビジョンシステムと通信するには、NAT IP アドレスをノード ID と結合して 192.168.101.26 とします。

関連項目

  • POWERLINK 通信
  • POWERLINK ファクトリインタフェース


[PROFINET の設定] ダイアログ

In-Sight Explorer GUI リファレンス

[PROFINET の設定] ダイアログでは、Siemens PLC と通信する In-Sight ビジョンシステムを設定します。

[PROFINET の設定] ダイアログを表示するには

  1. [ネットワークの設定] ダイアログで、PROFINET の [産業用イーサネットプロトコル] が有効な状態で、[設定] ボタンを押します。

注: [ユーザデータバイパスの有効化] オプションは、In-Sight ファームウェア 5.4.0 以上を実行している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、「ファームウェアバージョン」をご参照ください。

[PROFINET の設定] ダイアログの設定項目

  • [PROFINET ステーション名を有効にする]: このチェックボックスの設定により、PROFINET プロトコルでビジョンシステムのホスト名またはステーション名が使用されるかどうかが決まります。デフォルトでは、この設定はオフになっています。
  • ステーション名: PROFINET プロトコルで使用するビジョンシステムの名前を指定します。ステーション名の最大長は 239 文字です。ステーションの [ステーション名] フィールドのシンタックスは、次のルールに従う必要があります。
  • 1 つのラベル、またはピリオド (.) で区切られた複数のラベル。
  • 全長が 1 ～ 239 文字の範囲である。
  • ラベルの長さは合計で 1 ～ 63 字。
  • ラベルの文字は a ～ z、0 ～ 9 で構成。
  • 頭文字がハイフンマイナス記号 (-) のラベルは不可。
  • 最後の文字がハイフンマイナス記号 (-) のラベルは不可。
  • 最初のラベルを「port-xyz」または「port-xyz-abcde」(ただし、a ～ e、x ～ z の各文字は 0 ～ 9 の数字) で開始することは不可。
  • 「n.n.n.n」形式 (ただし、n = 0 ～ 999) のステーション名は不可。
  • RFC 3490 が適用される場合、ラベルは「xn-」のみで開始。
  • [ユーザデータバイパスの有効化]: キャッシュデータをバイパスし、未処理のユーザデータを直接読み取るには、このチェックボックスをオンにします。デフォルトでは、この設定はオフになっています。

関連項目

ネットワークのトラブルシューティング

PROFINET - ネットワーク上の Siemens PLC との通信

PROFINET I/O モジュールリファレンス

PROFINET - Siemens PLC でのレコードの使用


[Run As (ファイル名を指定して実行)] ダイアログ

In-Sight Explorer GUI リファレンス

[Run As (ファイル名を指定して実行)] ダイアログにより、標準ユーザは、管理者権限を必要とするレジストリの特定の領域に書き込むことができます。Windows に標準ユーザとしてログインしている場合は、そのレジストリに書き込むことはできません。ただし、In-Sight Explorer の使用時は、オフラインプログラミングキーを入力したり、[Windows のログオン時に In-Sight Explorer を起動する] オプションを変更したりするときに、レジストリへの書き込みが必要となります。そのような場合にユーザアカウント制御 (UAC) が無効になっていると、[Run As (ファイル名を指定して実行)] ダイアログが表示され、そのダイアログに管理者の資格情報を入力することによってレジストリに書き込むことができます。

注:
  • 以下の条件下では、オフラインプログラミングキーの入力や [Windows のログオン時に In-Sight Explorer を起動する] オプションの変更を試みると Windows の [Run As (ファイル名を指定して実行)] ダイアログが表示されます。管理者認証を指定して、操作を続行します。
    • Windows 7/ Windows　10 を使用しており、標準ユーザとして Windows にログインし、ユーザアカウント制御 (UAC) が有効になっている。
  • Windows 7/Windows 10 を使用しており、Windows に管理者としてログインし、ユーザアカウント制御 (UAC) が有効になっている場合に、オフラインプログラミングキーの入力や [Windows のログオン時に In-Sight Explorer を起動する] オプションの変更を試みると、[Allow/Deny (許可/拒否)] ダイアログが表示されます。[Deny (拒否)] を選択して操作を続行します。
  • 次のデフォルトのフォルダの場所が新しい場所に移動され、標準ユーザがアクセスできるようになります (これらのフォルダは、In-Sight Explorer 4.5.0 以降の [スタート] メニューからもアクセス可能になっています)。

    • フォルダ | In-Sight Explorer 4.4.x 以前 | In-Sight Explorer 4.5.0 以降
サンプルジョブ | C:\Program Files\Cognex\In-Sight\In-Sight Explorer x.x.x\Sample Jobs | Windows 7/Windows 10: C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Explorerx.x.x
サンプルプロジェクト | C:\Program Files\Cognex\In-Sight\In-Sight Explorer x.x.x\Sample Projects | Windows 7/Windows 10: C:\Users\Public\Documents\Cognex\In-Sight Sample Projects x.x.x

[Run As (ファイル名を指定して実行)] ダイアログの設定項目

  • [ドメイン]: ネットワークドメインを指定します。
  • [ユーザー名]: 管理者のユーザ名を指定します。
  • [パスワード]: ユーザ名に対応するパスワードを指定します。

注: 有効な管理者の資格情報が入力されると、In-Sight Explorer が終了するまでステータスが有効になります。
Version: 5.6.0


MapSpec

コロン文字 (:) で区切られた指定子のリストから構成されるデータマッピングを指定します。各指定子は、開始バイトとデータ型コードの 2 つの部分から構成されます。さまざまなデータ型コードを、次の表に示します。

コード | データ型
i | 8 ビットの整数
u | 8 ビット符号なし整数
il | 16 ビットの整数
ul | 16 ビット符号なし整数
d | 32 ビット符号なし整数
f | 32 ビット浮動小数点数
s | テキスト文字列


基本色

関数の引数として色を使用する場合は、目的の色に対応するインデックス番号を入力します。

インデックス | カラー名 | (R,G,B) | サンプル
0 | デフォルト |  |
1 | 暗い赤 | (128,0,0) |
2 | 暗い緑 | (0,128,0) |
3 | 暗い黄色 | (128,128,0) |
4 | 暗い青 | (0,0,128) |
5 | 暗い赤紫 | (128,0,128) |
6 | 暗い水色 | (0,128,128) |
7 | 赤 (IGM デフォルト) | (255,0,0) |
8 | 緑 | (0,255,0) |
9 | 黄 | (255,255,0) |
10 | 青 | (0,0,255) |
11 | 赤紫 | (255,0,255) |
12 | 水色 | (0,255,255) |
13 | 暗い灰色 | (128,128,128) |
14 | 灰色 | (192,192,192) |
15 | 黒 | (0,0,0) |
16 | 白 | (255,255,255) |


Acquire

In-Sight センサで新しい画像をスナップします。新しい画像が取り込まれると、In-Sight は毎回、スプレッドシートを評価して値を更新します。

「AcquireImage」関数のトピックを参照


アクティブセル

アクティブ セルは、スプレッドシート内で現在ハイライトされているセルです。

例: 次のスプレッドシートでは、B2 がアクティブセルであり、黒い枠で囲まれています。 アクティブな列 (B) とアクティブな行 (2) の両方のヘッダがオレンジ色でハイライトされて、アクティブセルのアドレスを示しています。


ドーナツ状

円やリングのような形状です。


バーコードエレメント

エレメントとは、バーコードのバーまたはスペースのいずれかを指します。


ベイヤーパターン

白黒画像センサに感色性を加える一般的な技法は、カラーモザイクフィルタをセンサの上に適用する方法です。ほとんどの場合、3 原色の赤/緑/青 (RGB) パターンが使用されます。In-Sight カラーセンサは、RGB カラーモザイクフィルタパターンとしてベイヤーパターンを使用します。ベイヤーパターンでは、各ピクセルが特定のパターンと特定のカラーフィルタで覆われます。以下に示すように、ピクセル総数の半分が緑 (G) で、総数の 1/4 が赤 (R) と青 (B) の両方に割り当てられます。

各カラーピクセルは、3 つ (赤、緑、青) の個別の色成分で構成されます。各ピクセルの欠けている色は、それぞれの場所の周囲のピクセルを使って補間されます。例えば、ピクセルに緑のフィルタがかけられた場合、緑成分の値はわかりますが、赤成分と青成分の値については、赤のフィルタがかけられた周囲のピクセルと青のフィルタがかけられた周囲のピクセルの平均値から計算する必要があります。ソフトウェアが実行する補間により、不明な 2 つの色成分の各ピクセルには 0 ～ 255 の値が割り当てられます。次の例では、1 つのピクセルに対し、3 つすべての色成分の値がどのように計算されるのかを示します。

ピクセル G1 の各色成分の値は次のようになります。

  • 赤成分の値 =
  • 緑成分の値 = G1 の値 = 218
  • 青成分の値 =

この例の場合、ピクセル G1 の RGB 成分の値は (80,218,45) になります。

各ピクセルに出力値が割り当てられると、ピクセル B2 の各色成分の値は次のようになります。

  • 赤成分の値 =
  • 緑成分の値 =
  • 青成分の値 = B2 の値 = 60

この例の場合、ピクセル B2 の RGB 成分の値は (240,220,60) になります。


ブロブ - 面積の例

ブロブの面積の例

ブロブの面積は、ブロブ内のピクセルの数を数えて計算されます。 次の図に示す、拡大したブロブについて考えてみましょう。

ピクセルを数えると、このブロブには 8 ピクセルの面積があることがわかります。


ブロブ - 重心の例

重心 (ブロブ)

ブロブの重心は、ブロブの平衡点を表します。均一素材のシートがブロブの形状に切り取られた場合、ブロブが平衡をとるポイントは重心です。ブロブの重心は実際には、ブロブ自体の中にない場合があります。

次の図に示す黒い領域が、ExtractBlobs 関数で特定されたブロブだとします。赤い点は、ブロブの重心を表します。

重心の x 座標と y 座標はそれぞれ、GetCol および GetRow ビジョンデータアクセス関数によって返されます。


ブロブ - 周囲長の例

ブロブの周囲長の例

次に示す、面積が 8 ピクセルの拡大したブロブについて考えてみましょう。

ブロブの周囲長は、ブロブ内のピクセルごとに、外部ピクセルエッジの数を数えて計算されます。 この場合、ブロブには 12 の外部エッジがあって周囲長を形成しています。


キャリブレーションの精度

キャリブレーションの精度は、次を含む要因の数によって左右されます。

  • 検査されているオブジェクトのパーツ: エッジはなめらかなのが最適であり、荒いエッジは精度を損ないます。
  • 印刷/作成されたキャリブレーショングリッドの質: 標準インクジェットまたはレーザプリンタで印刷されたキャリブレーショングリッドは精度を低下させます。
  • レンズの品質: テレセントリックの特性を備えた高品質なレンズは最高の結果を出し、最小限の修正しか必要としません。
  • In-Sight ビジョンシステムの取り付け方: 振動のあるところにビジョンシステムを取り付けると、少しずつ位置がずれることがあります。
  • 画像の質: 画像のゲインが多すぎると、ピクセルにジッタが生じ、画像が露出過多だと精度が低下します。
  • ビジョンツールの精度: エッジツールは 0.25 (1/4) ピクセルまで、PatMax ツールは 0.025 (1/40) ピクセルまでの精度を発揮します。

これらの問題を集積させると、精度が非常に低下します。これらの問題は蓄積される傾向にあり、相互に相殺されることはめったにありません。検査されているパーツが平らで、エッジが非常に良好に定義されている場合は、0.10 (1/10) ピクセルの精度が実現します。システムの精度を判断する唯一の方法は、システムをテストすることです。


キャリブレーションに関するガイドライン

画像のキャリブレーション時に考慮すべきその他の重要な要因を以下に挙げます。

  • キャリブレーション時に、In-Sight ビジョンシステムとレンズ間のセットアップ、センサおよび取り込まれるシーンの間の物理的関係をキャリブレーション操作とランタイム操作の両方で同一にする必要があります。このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。したがって、キャリブレートとランタイム画像の処理の両方で、同じセンサとレンズを使用することを推奨します。
  • センサとレンズでは、元の物理的なセットアップとキャリブレーション設定を維持する必要があります。例えば、画像取り込みフォーマットの変更 (解像度の変更による) またはセンサの移動を行うと、ピクセルをワールド座標にマッピングする 2D 変換が不正になります。
  • 最高度の精度を達成し、画像の最大領域をキャリブレートするには、画像領域がグリッドパターンに十分に覆われるようにします。最小 10 行と 7 列のドットまたはグリッドインデックス、または 100 以上の特徴の入力を取得することを目標とします。
  • 視野が大きい画像の場合は、より小さくて扱いやすいキャリブレーションプレートを使って、視野全体の複数のポーズが画像全体をキャリブレートできるようにします。
  • 歪みが大きい画像の場合は、複数のポーズを使ってキャリブレーション済み参照をより多く取得して、キャリブレーションの精度を高めます。
  • 安定した均一な照明を維持します。
  • キャリブレーショングリッドを、検査対象オブジェクトと同じ平面に配置します。例えば、3D オブジェクトを調べている場合に、オブジェクトの上部を検査するときには、キャリブレーショングリッドを同じ高さにする必要があります。

キャリブレーショングリッドの種類の選択 - ドットとチェッカボード:

ドットのグリッド

  • 0.05 (1/20) ピクセルまでの比較的高い精度。
  • 30°の遠近歪みまで許容。
  • ノイズと不安定な照明に対する許容度が非常に高い。
  • 各ドットは直径 10 ～ 50 ピクセルにする必要がある (15 ピクセル以上のドットで、より正確な結果を得られる)。

チェッカボード

  • 0.025 (1/40) ピクセルまでの最高度の精度。
  • 45°の遠近歪みまで許容。
  • ノイズと不安定な照明に対する許容度が高い。
  • 正方形の幅は少なくとも 15 ピクセルにする。


セル

A セルは、列の文字と行番号で識別される、スプレッドシート内の位置です。例えば、セル A2 は列 A と行 2 が交差するところに位置します。


色成分

ピクセルの色成分

各カラーピクセルは、3 つの個別の色成分で構成されます。これらの成分は、赤、緑、青 (RGB) の組み合わせ、または色相、彩度、明度 (HSI) で表すことができます。RGB と HSI 双方のピクセルの各成分は、値 0 ～ 255 に変換されます。

RGB 色は、赤、緑、青の階調をさまざまな比率で組み合わせることで作られます。その組み合わせによってピクセルごとに固有の色が生まれます。以下に例を示します。

上に示す「ピクセル」の RGB 成分の値は (255,0,0) | 上に示す「ピクセル」の RGB 成分の値は (0,255,0) | 上に示す「ピクセル」の RGB 成分の値は (0,0,255)

上に示す「ピクセル」の RGB 成分の値は (200,0,0) | 上に示す「ピクセル」の RGB 成分の値は (150,0,0) | 上に示す「ピクセル」の RGB 成分の値は (85,0,0)

HSI の場合、色の色相は、電磁波スペクトルの可視領域内におけるその位置に相当します。

色相を数値に変換する処理は、色相環を作ることで行われます。色相環では、スペクトルのすべての色相が環状に配置されます。特定の色相は、その色相が色相環に配置される角度を割り当てることで指定されます。次の図に、色相環を示します。

注: 色相値の範囲は、範囲 0 ～ 255 になります。

色の彩度は、色がグレーまたは白と混ざり合う度合いです。完全な飽和色は純色です。色が白 (またはグレー) と混ざり合うほど、その色の飽和度は薄まります。次の図に、1 つの色相における彩度の範囲を示します。

色の明度は、その輝度の尺度です。色の明度は、色を構成する赤、緑、青の成分の平均値として定義されます。色相、彩度、明度の混合によって、ピクセルごとに適正な色が生まれます。以下に例を示します。

上に示す「ピクセル」の HSI 成分の値は (0,255,85) | 上に示す「ピクセル」の HSI 成分の値は (85,255,85) | 上に示す「ピクセル」の HSI 成分の値は (170,255,85)


連続したリスト項目

リスト項目は相互に隣接している場合、連続した状態になっています。


畳み込みカーネル

カーネルのピクセル高さと幅は、[行数] と [列数] で調整します。

カーネルの調整:

  1. 評価中のピクセルを表す、ハイライトされたボックスを選択します。そのピクセルの明度 (-255 ～ +255) にかけ合わせる値を入力します。
  2. 次に、隣接するピクセルを表すボックスを選択します。この位置のピクセルに掛け合わせる値を入力します。例えば、現在のピクセルのすぐ右隣にあるピクセルの明度に 2 を掛けるには、中央のボックスのすぐ右隣にあるボックスに 2 を入力します。
  3. 手順 2 と 3 を繰り返して、すべてのピクセルを演算します。すべてのボックスに値を入力する必要はありません。


DHCP サーバ

動的ホスト構成プロトコル (DHCP: Dynamic Host Configuration Protocol) サーバ

イーサネットの設定をサポートする In-Sight デバイスの起動時に、DHCP (動的ホスト構成プロトコル) を使用するかどうかを決定します。DHCP サーバがローカルネットワーク上で実行されている場合にだけ、このオプションを選択します。このチェックボックスまたはボタンを選択しない場合、[ネットワーク設定] ダイアログまたは [センサ/デバイスをネットワークに追加] ダイアログの値が TCP/IP の設定に使われます。

注: [ネットワーク設定] ダイアログで [DHCP サーバの使用] チェックボックスを有効にする場合は、DHCP タイムアウトを指定できます。DHCP サーバが指定の時間内に応答しない場合、ネットワークのサポートが有効でなくてもセンサが起動します。

製造環境では固定 IP アドレスを使用します。そうすると、ローカルネットワークで DHCP サーバが不要になり、断続的な DHCP トラフィックを防止できます。


DNS サーバ

ドメインネームサービス (DNS) サーバ

同一ネットワーク上のホストデバイスは一意の IP アドレス番号を持ちますが、アドレスの共通部分は同一ドメイン (例えば、「yourdomain.com」) 上のすべてのホストが共有しています。この番号は覚えにくいことがあるため、通常はそれぞれのホストに IP アドレスの「別名」としてホスト名が割り当てられています。DNS サーバは、このホスト名を、ネットワーク上で認識可能な IP アドレスに変換します。

例えば、IP アドレスが 192.168.1.2 の In-Sight センサに「PRODUCTION2」という名前を付けた場合、DNS サーバは、PRODUCTION2 が実際には指定されたアドレスの In-Sight ホストを指すことを認識しています。[DNS サーバ] フィールドでは、指定したドメイン内のホスト名から IP アドレスへの変換を解決するために問い合わせるホスト (の IP アドレス) を指定します。


ドメイン

ドメインについて

ドメインは、IP アドレスの共通部分を共有する、ネットワーク上のデバイスのグループです。完全修飾ドメイン名 (FQDN) は、ホスト名とドメイン名 (トップレベルドメインを含む) で構成されています。例えば、www.yourdomain.com は完全修飾ドメイン名であり、「www」がホスト、「yourdomain」がセカンドレベルドメイン、「.com」がトップレベルドメインです。

In-Sight センサの FQDN は、ローカルネットワークの一部ではない In-Sight センサまたは In-Sight エミュレータを介して設定またはモニタする必要があります。[ネットワーク設定] ダイアログまたは [センサ/デバイスをネットワークに追加] ダイアログの [ドメイン名] フィールドに入力した文字列は、[ホスト名] フィールドに入力した文字列に付加されて、FQDN が作成されます。

[DHCP サーバの使用] チェックボックスを選択すると、ドメインのフィールドには影がかかり、DHCP サーバによって割り当てられた値が表示されます。

FQDN の例

yourdomain.com という名前のローカルドメインについて考えてみます。

In-Sight センサのホスト名が is5100_010203 である場合、参照する FQDN はis5100_010203.yourdomain.com になります。


動的 IP アドレス

DHCP サーバが使用可能である場合、イーサネット設定に対応する In-Sight デバイスが IP アドレスを動的に取得するように設定できます。 この場合、In-Sight イーサネットデバイスは自動的にリクエストを送信し、ネットワーク設定 (IP アドレス、DNS サーバ、サブネットマスク、ゲートウェイ、ドメイン名など) を受け取ることができます。デバイスが多数存在する場合はたいてい、デバイスごとにネットワーク設定を手動で行うよりもこの設定が好まれます。断続的な DHCP トラフィックを防止するため、初期設定後にデバイスの DHCP を無効にして静的 IP アドレスを割り当てることを強く推奨します。


サブ領域の順序

適切な順序のサブ領域一覧

  1. [追加] 操作を使って領域を挿入します。
  2. [減算] 操作を使って円を挿入します。
  3. [追加] 操作を使って、2 つ目の小さい領域を挿入します。対象領域から除外される画像の部分が円でマスキングされ、マスキングされない小さい領域が対象領域内にあります。

不適切な順序のサブ領域一覧

  1. [追加] 操作を使って領域を挿入します。
  2. [追加] 操作を使って、2 つ目の小さい領域を挿入します。
  3. [減算] 操作を使って円を挿入します。円全体がマスキングされます。円と領域は対象領域から除外されます。


EtherNet/IP

EtherNet/IP は、イーサネットと TCP/IP プロトコルの上に実装されるアプリケーションレベルのプロトコルであり、イーサネットを介した産業環境でのデータ転送を実現します。EtherNet/IP プロトコルの詳細については、http://www.odva.org にアクセスしてください。


ファインダ頂点

ファインダパターン頂点

2D データマトリックスシンボル

データマトリックスシンボルの場合、ファインダパターン頂点は、シンボルの 4 隅のセルそれぞれの中心にモジュールとも呼ばれるセルは単一の正方形で、黒または白のいずれかになります。例えば、10×10 のシンボルは、100 の黒と白のセルで構成されます。1 つのセルは、1 ビットのデータに相当します。 配置されています。2 つの実線の交差は「L 境界線」を形成します。登録中、L のコーナーは左下隅の向きになります。ポイント 0 はシンボルの左上隅のセル、ポイント 1 は左下隅 (実線が交差する箇所)、ポイント 2 は右下隅、ポイント 3 は右上隅のセルです。

2D データマトリックスシンボル上のポイント位置については、 Closed ここをクリックしてください。

2D QR シンボル

QR シンボルの場合、ファインダパターン頂点は、シンボルの 4 隅のセルそれぞれの中心に配置されています。シンボル上の Closed 3 つの位置検出パターンが「L」字型を形成します。登録中、L のコーナーは左上隅の向きになります。ポイント 0 はシンボルの右上隅のセル、ポイント 1 は左上隅 (中間の位置検出パターンが「L」のコーナーを形成)、ポイント 2 は左下隅、ポイント 3 は右下隅のセルです。

2D QR シンボル上のポイント位置については、 Closed ここをクリックしてください。

1D バーコード

バーコードの場合、ファインダパターン頂点は、シンボルの 4 隅のセルそれぞれの中心に配置されています。ポイント 0 は左上隅のセル、ポイント 1 は左下隅、ポイント 2 は右下隅、ポイント 3 は右上隅です。

1D バーコード上のポイント位置については、 Closed ここをクリックしてください。


FTP

ファイル転送プロトコル (FTP)

In-Sight センサには統合型 FTP クライアント/サーバがあるので、FTP プロトコルを使って他のセンサとファイルをネットワーク上で共有することができます。[保存] と [開く] のダイアログは FTP クライアントとして機能し、ネットワーク上の FTP サーバとの接続を確立して、ジョブ、画像、ファームウェア更新ファイルを転送できます。

In-Sight センサへの FTP 接続は、ネットワーク上の非 In-Sight ホストから開始することもできます (その場合、In-Sight センサは FTP サーバとして機能します)。これは、In-Sight センサの proc.set ファイル (.SET) を保存する唯一の方法です。この設定ファイルを他の In-Sight センサにロードすることで、設定の複製を行うことができます。

In-Sight センサへのログオンプロセスと FTP コマンドの実行の両方を自動化するカスタムアプリケーションを、リモートホストでの実行に対応するように作成できます。

注:
  • PC で実行できるのは、1 つの FTP サーバだけです。In-Sight センサとの適切な FTP 通信を実現するには、ローカル PC で実行されている可能性のあるサードパーティの FTP サーバをすべて閉じます。
  • In-Sight センサがオンラインのときに、ファイルを保存またはロードしようとすると、In-Sight センサの性能が低下することがあります。
  • In-Sight 5600 センサでの FTP を使ったファイル転送は、他のセンサの場合よりも動作が遅くなることがあります。

In-Sight センサは標準 FTP コマンドをサポートします。次の表に、よく使用されるコマンドを示します。

FTP コマンド | 説明
open [Address] | リモートホストと In-Sight センサ間の FTP 接続を確立します。
help | 使用可能な FTP コマンドの一覧を表示します。
help [Command] | 個々の FTP コマンドに関する情報を表示します。
dir | 現在、In-Sight センサに保存されているファイルの一覧を表示します。
prompt | 複数のコマンドが使用されると、Y/N のプロンプトを切り替えます。prompt のデフォルト設定はオンです。
get [File Name] | In-Sight システムからファイルをダウンロードして、リモートホストにある FTP クライアントのデフォルトのディレクトリに保存します。1
mget [File Names] | In-Sight センサから複数のファイルをダウンロードして、リモートホストにある FTP クライアントのデフォルトのディレクトリに保存します。1、2
put [File Name] | リモートホストにある FTP クライアントのデフォルトのディレクトリから In-Sight センサにファイルをアップロードします。1
mput [File Names] | リモートホストにある FTP クライアントのデフォルトのディレクトリから In-Sight システムに複数のファイルをアップロードします。1、2
del | In-Sight センサから指定のファイルを削除します。
mdel | In-Sight センサから複数のファイルを削除します。3
disconnect | リモートホストと In-Sight センサ間の FTP 接続を切断し、FTP コマンドプロンプトに画面を戻します。 注: In-Sight センサは、一度に最大 2 つの FTP 接続に対応できます。
quit | リモートホストと In-Sight センサ間の FTP 接続を切断し、DOS コマンドプロンプトに画面を戻します。
1 FTP は、プロンプトや警告を表示せずに、転送されているファイルの既存のコピーを置き換えます。 2 複数のファイルを指定する場合は、「*」のワイルドカード文字 (つまり、*.job) を使います。転送するファイルごとに Y または N で答えるようにメッセージが表示されます。 3 複数のファイルを指定する場合は、「*」のワイルドカード文字 (つまり、*.job) を使います。削除するファイルごとに Y または N で答えるようにメッセージが表示されます。

例 1: In-Sight センサとリモートホスト間の FTP 接続の確立

  1. In-Sight センサの IP アドレスを特定します。

注: [In-Sight Explorer について] ダイアログには、In-Sight ネットワーク内の全デバイスの IP アドレスが表示されます。

  2. リモートホストで、FTP アプリケーションを起動します。Microsoft Windows の場合、DOS コマンドプロンプトウィンドウを開いて、「FTP」と入力します。
  3. FTP コマンドプロンプトで、「open Address」と入力します。Address はステップ 1 で取得した IP アドレスです。接続に成功すると、「220 In-Sight (R) 5100 Release 3.40.00 (2240) ready (is5100_010203)」のようなメッセージが表示されます。
  4. ユーザプロンプトで、In-Sight センサのユーザリストにあるユーザ名を入力します。ユーザ名が許可されると、「331 User Name OK, need password」というメッセージが表示されます。
  5. パスワードプロンプトで、ユーザ名に対応するパスワードを入力します。パスワードが許可されると、「230 User UserName logged in」というメッセージが表示されます。

Closed 例 1 のコマンドプロンプトの出力を参照

例 2: FTP を使った In-Sight センサ設定の保存とロード:

In-Sight センサ設定は、proc.set ファイルに保存されます。このファイルには、シリアルポート、ディスクリート入力/出力、ユーザリスト、スタートアップパラメータ (ユーザおよびジョブ)、日付/時刻の設定の設定の詳細が含まれています。

注: In-Sight センサがオンラインのときに、proc.set ファイルを In-Sight センサにコピーすることはできません。

In-Sight センサから FTP クライアントに設定ファイルを保存するには、次の手順を実行します。

  1. 例 1 の手順のとおりに、In-Sight センサへの FTP 接続を確立します。
  2. ログオンしたら、次のコマンドを実行します。

get proc.set

ファイルが適切に転送されたかどうかを確認するには、FTP クライアントにあるデフォルトのローカルディレクトリ内の proc.set を調べます。

注: FTP プロンプトで LCD コマンドを実行すると、デフォルトのローカルディレクトリが表示されます。

FTP クライアントから In-Sight センサに設定ファイルをロードするには、次の手順を実行します。

  1. 例 1 の手順のとおりに、In-Sight センサへの FTP 接続を確立します。
  2. ログオンしたら、次のコマンドを実行します。

put proc.set

このコマンドを実行すると、プロンプトや警告が表示されることなく、ターゲット In-Sight センサの現在の設定ファイルが上書きされるので注意してください。ファイルが適切にロードされると、ターゲット In-Sight センサが再起動されます。ターゲット In-Sight センサに適用されないファイルの設定はすべて、ターゲットシステム上で破棄されます。

Closed 例 2 のコマンドプロンプトの出力を参照


ゲートウェイ:

ゲートウェイは、ローカルサブネット上のデバイスから別のサブネット上のデバイスにデータパケットをルーティングするデバイスです。In-Sight デバイスが別のサブネット上のデバイスと通信する必要がある場合、[デフォルトゲートウェイ] フィールドにゲートウェイデバイスのアドレスを入力します。その必要がない場合は、このフィールドを空白のままにします。


フォントエディタ

フォントエディタでは、フォント文字の個々のインスタンスを編集できます。現在選択されている文字モデルのインスタンスがフォントエディタに表示されます。次のボタンを 1 回クリックすると、よく使用するタスクにアクセスできます。

注: バイナリ文字モデルだけを編集できます。グレースケール文字インスタンスは読み取り専用です。

文字インスタンスをアクティブフォントに保存します。文字を保存せずに編集し続けると、選択した文字を変更するとき、またはダイアログを終了するときに、変更を保存 (または破棄) するようメッセージが表示されます。

最後の操作を取り消します。

最後の操作をやり直します。

標準 (ポインタ) アイコンを選択した場合、マウスを画像でスクロールすると、ピクセルごとのグレースケール値が返されます。

領域拡大: 画像領域周囲に点線状の矩形が生成されて、その部分が拡大表示されます。ユーザが定義した矩形がズームされ、画像領域全体が囲まれます。矩形を生成する際、カーソルの初期位置が矩形の中心になります。最大ズームに達すると、拡大領域は無効になります。Ctrl キーを押しながら左クリックして [image] カーソルをドラッグすることで、領域を定義します。ボタンを離すと、領域が拡大表示されます。終了するには、Ctrl キーを離します。カーソルが標準 [image] カーソルに戻ります。

拡大表示した画像をパン: Shift キーと Ctrl キーを押しながらマウスを左クリックして、 [image] カーソルをドラッグします。終了するには、Shift キーと Ctrl キーを離します。カーソルが標準 [image] カーソルに戻ります。

続いて描画操作を実行するには、ピクセルをクリックして色 (黒または白) を選択します。値を選択すると、モードが自動的に前の描画選択 (「薄い」または「濃い」) に自動的に変わります。選択した色は、選択したラジオボタン ([黒で描画] または [白で描画] のいずれか) で示されます。

注: 画像領域外での選択は無視されます。

Eyedropper で選択した色を使って、1 ピクセル幅の線を描きます。

Eyedropper で選択した色を使うか、または [黒で描画] か [白で描画] を選択して、3 ピクセル幅の線を描きます。

拡大レベルを上げます。

拡大レベルを下げます。

表示倍率を 1:1 に設定します。画像の 1 ピクセルに対して PC ディスプレイの 1 ピクセルで表示します。

ウィンドウ内に画像全体が表示されるように自動調整します。画像は、スプレッドシートの下で画像全体が表示される最大限の大きさに自動調整されます。画像のアスペクト比は維持されます。このため、画像の周囲にグレーの余白が表示される場合があります。

操作を取り消します。


暗黙的メッセージ

In-Sight アセンブリデータ構成 (非明示的メッセージング)

入力アセンブリ

クラス | 0x04
インスタンス | 0x01
サイズ | 132 バイト (33 個の 32 ビットの単語)

データ構成

バイト 0 ～ 3 (4 バイト) - 将来の使用に備えて予約済み。

バイト 4 ～ 132 (128 バイト) - スプレッドシートデータ (ユーザ定義可能)。

出力アセンブリ

クラス | 0x04
インスタンス | 0x02
データサイズ | 132 バイト (33 個の 32 ビットの単語)

データ構成

バイト 0 ～ 2 (3 バイト)

バイト 3 (1 バイト)

バイト 4 ～ 132 (128 バイト)

注: 最小パケット要求間隔 (RPI) は 10 ミリ秒 (データのみ)、および 40 ミリ秒 ([AcquireImage] プロパティシートのデフォルト設定を使って、取得トリガバイトが含まれる場合) です。


In-Sight ポート

In-Sight の通信には次のポートが使用されます。

ポート番号 | サービス
TCP 21 | FTP
TCP 23 | Telnet
UDP 68 | DHCP (In-Sight ビジョンシステムのみ)
TCP 80 | HTTP
TCP 502 | Modbus
TCP 1069 | In-Sight プロトコル
UDP 1069 | In-Sight Discovery
TCP 1070 | [マシンステータス] データ
UDP 2222 | EtherNet/IP
TCP 5753 | 監査メッセージサーバ
UDP 45237 | 基本 SLMP メッセージ (GetCommunicationSetting)
TCP 44818 | EtherNet/IP
UDP 44818 | EtherNet/IP
UDP 45237 | iQ センサソリューション
TCP 50000 | DataChannel
UDP 61450 | CC-Link IE フィールド Basic: 周期的な要求/応答メッセージ
UDP 61451 | CC-Link IE フィールド Basic: NodeSearch メッセージと IPAddressSet メッセージ


インターネットプロトコル

インターネットプロトコル (IP) アドレス

ネットワーク上のホストを一意に識別する IP アドレス。IP アドレスは、3 つのタイプ (クラス) のいずれかに属します。クラスは一般に、サブネットの数、これらのサブネット上で稼働するホストの数によって決まります。

ネットワーククラス | ネットワーク (またはサブネット) の最大数 | ホストの最大数
A | 127 | 16,000,000
B | 16,000 | 65,000
C | 2,000,000 | 254

ネットワーク上の他のすべてのホストと同様に、In-Sight センサに割り当てられた IP アドレスは、既存のネットワーク上で有効なアドレス方式に準拠する必要があります。ネットワークで使われているアドレス方式については、ネットワーク管理者に問い合わせてください。

ネットワークが特に In-Sight 用に作成されている場合、ユーザはネットワーククラスを選択し、IP アドレスを適宜割り当てる必要があります。次の IP アドレス方式を使用できます。

ネットワーククラス | IP アドレス範囲 | デフォルトサブネットマスク
A | 10.0.0.1 ～ 10.255.255.254 | 255.0.0.0
B | 172.16.0.1 ～ 172.31.255.254 | 255.255.240.0
C | 192.168.0.1 ～ 192.168.255.254 | 255.255.0.0

ほとんどの In-Sight ユーザはクラス C ネットワークを設定する必要があります。


補間

補間は、次の式を使った、ピクセルの赤、緑、青 (RGB) 成分の加重平均です。

補間値 = 0.25×R + 0.50×G + 0.25×B


I/O モジュール

I/O モジュールサポート

次の I/O モジュールは、In-Sight ビジョンシステムでの使用がサポートされています。

I/O モジュール | サポート対象の In-Sight ビジョンシステム | ディスクリート入力ライン | ディスクリート出力ライン
CIO-1400 | In-Sight 5000 シリーズ (5604 を除く)、In-Sight 76xx ～ 79xx シリーズ1 | 汎用入力×7 | 汎用出力×6
CIO-MICRO23 | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 70xx ～ 79xx シリーズ、In-Sight Micro 8000 シリーズ | 汎用入力× 8 | 汎用出力× 8
CIO-MICRO-CC34 | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ (5705、5705C、5715 を除く)、In-Sight 70xx ～ 74xx シリーズ | 汎用入力× 8 | 汎用出力× 8
CIO-14505 | In-Sight 5000 シリーズ (5604、5705、5705C および 5715 を除く) | 汎用入力× 8 | 汎用出力× 8
CIO-14605 | In-Sight 5000 シリーズ (5604、5605、5705、5705C および 5715 を除く) | 汎用入力× 8 | 汎用出力× 8
CIO-WENET5 | In-Sight Micro 1000 シリーズ | 汎用入力× 8 | 汎用出力× 8

1 CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以上を使用している In-Sight 76xx ～ 79xx シリーズのビジョンシステムをサポートしています。このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。

2CIO-MICRO I/O モジュールは、ファームウェア 5.3.0 以上を搭載した In-Sight 5705、5705C、5715、In-Sight Micro 8000 シリーズのビジョンシステムをサポートします。

3CIO-MICRO-CC I/O モジュールは、In-Sight 76xx ～ 79xx シリーズのビジョンシステムをサポートしていません。

4CIO-MICRO および CIO-MICRO-CC I/O モジュールがサポートしているのは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズと 5400 シリーズのビジョンシステムです。モデルはタイプ番号 (821-xxxx-xx) で特定できます。このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。モデル、およびタイプ番号と不揮発性フラッシュメモリの一覧については、ここをクリックしてください。

5CIO-1450、CIO-1460 および CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。


ListSelections

リスト選択のヒント

In-Sight ネットワークおよび In-Sight Explorer 内の多くのダイアログでは、ファイルまたは In-Sight センサをリストから選択する必要があります。リストから項目を選択する方法はさまざまです。

操作 | マウス | キーボード | サンプル結果
リストから項目を 1 つ選択する。 | 項目をクリックします。 | リストが表示されるまで Tab キーを押し続けます。上向き/下向き矢印キーを使って、リストの項目をハイライト表示します。 |
リストから複数の非連続項目を選択する。 | Ctrl キーを押しながら、リストから複数の項目をクリックします。 | リストが表示されるまで Tab キーを押し続けます。上向き/下向き矢印キーを使って、選択したい最初の項目をハイライト表示します。 Ctrl キーを押し続けます。上向き/下向き矢印キーを使って、次の項目をハイライト表示します。Ctrl キーを押しながらスペースキーを押して、リストの後続の項目の選択を切り替えます。 |
リストから複数の連続項目を選択する。 | 連続した範囲の最初の項目をクリックします。Shift キーを押しながら、連続した範囲内で選択したい最後の項目をクリックします。 | リストが表示されるまで Tab キーを押し続けます。上向き/下向き矢印キーを使って、範囲内の最初の項目をハイライト表示します。Shift キーを押しながら、上向き/下向き矢印キーを使って、リスト内のハイライト表示した範囲を拡大します。 |


輝度

輝度は明度と概念上、密接な関係にあり、特定の領域から放射または反射される光の量の尺度になります。

マシンビジョンアプリケーションにおける輝度は、次の式を使って、ピクセルの赤、緑、青 (RGB) 成分から計算されるグレースケール値です。

RGB 輝度値 = 0.299×R + 0.587×G + 0.114×B


MAC アドレス

メディアアクセス制御 (MAC) アドレス

MAC アドレスは、ネットワークの特定のノードを識別するハードウェアアドレスです。各 In-Sight センサには、一意の MAC アドレスが割り当てられています。このアドレスは変更できません。In-Sight センサの MAC アドレスを特定するには、センサに貼られたシリアル番号ラベルを調べてください。または、In-Sight Explorer 内から [In-Sight Explorer について] ダイアログを開きます。

MAC アドレスの例: 00-d0-24-01-02-03


マシンステータスポート

In-Sight マシンステータスポートは、ポート 1070 での TCP/IP 接続です。この接続により、ユーザ名とパスワードでログインしなくても、In-Sight システムのマシンステータスデータにリモートクライアントからアクセスできます。この読み取り専用ポートから実行する場合、EV プレフィックスなしで GetMSBuffer コマンドを使うことができます。接続は 15 秒後にタイムアウトします。ポート 1070 に対して最大 5 つの同時接続を行うことができます。


MicroPDF417 バリアント

MicroPDF417 シンボルの EAN/UCC 固有のバリアントが、CC-A コンポジットシンボルの 2D コンポーネントとして使用されます。詳細については、AIM International (外部リンク、インターネットアクセスが必要) が公開している『International Symbology Specification - EAN/UCC Composite Symbology™ (ITS/99-002)』の「Section 8」を参照してください。この仕様によると、RSS ファミリコンポーネントの上に表示できる CC-A のバージョンが制限されます。

  1. RSS-14 Stacked または RSS-14 Stacked Omnidirectional リニアコンポーネントは、2 列の CC-A コンポーネントのみにリンクできます。
  2. RSS Limited リニアコンポーネントは、3 列の CC-A コンポーネントのみにリンクできます。
  3. RSS-14 および RSS-14 Truncated リニアコンポーネントは、4 列の CC-A コンポーネントのみにリンクできます。
  4. RSS Expanded リニアコンポーネントは、4 列の CC-A コンポーネントのみにリンクできます。2D コンポジットコンポーネントにリンクする場合、RSS Expanded Stacked リニアコンポーネントには、その最上行に少なくとも 4 つのシンボル文字が含まれる必要があります。


MIME

多目的インターネットメール拡張仕様 (MIME: Multipurpose Internet Mail Extensions)

非 ASCII メッセージをインターネット経由で送信できるようにフォーマットする仕様。


モニタのバージョン

In-Sight Monitor は主に、In-Sight センサのトラブルシューティングに使用します。「セーフモード」を使用すると、すべての設定パラメータをリセットして In-Sight を起動できます。これにより、I/O、スタートアップ、カスタマイズなどの In-Sight センサの現在の「設定」が元の値に戻されるので注意してください。その際、プロンプトや警告は表示されません。「診断」と「サーバモード」は Cognex 技術者のみが使用するものであり、弊社テクニカルサポートの指示がない限り、アクセスしないでください。[In-Sight の起動] でシステムの In-Sight ソフトウェアが起動します。


ネイティブモードおよび EIP

次のネイティブモードコマンドは、(一般的な Control and Information Protocol CIP：メッセージを許可する) 任意の PLC から、明示的メッセージングを使用して EtherNet/IP 接続経由で送信できます。

  • Delete File
  • Get File
  • Get Online
  • Get Value
  • Load File
  • Set Event
  • Set Float
  • Set Integer
  • Set Online
  • Set String
  • Store File


ネイティブモードのチェックサム

周期冗長検査 (CRC: Cyclical Redundancy Check)

ネイティブモードのファイル転送コマンドでは、標準の 16 ビットの周期冗長検査 (CRC: Cyclical Redundancy Check) チェックサムが使用されます。 CRC を計算するアルゴリズムが続きます。 この例の変数 CRC は符号なしの 16 ビットで、入力バイトは 8 ビットです。

1.CRC を 0 に設定します。

2.次のバイトをデータストリームから取得します。

3.CRC の最上位ビットと入力バイトをテストし、以下を実行します。

これらが同等である場合は、CRC を 1 つ左にずらします。

1 つのビットが 0 でもう一方が 1 の場合、CRC を 1 つ左にずらし、XOR を 4129 で計算します。

4.入力バイトを 1 つ左にずらします。

5.入力バイトを 8 回ずらさなかった場合は、ステップ 3 に進みます。

6.データストリームにバイトが残っている場合は、ステップ 2 に進みます。

このアルゴリズムの理論的説明については、『Numerical Recipes in C:The Art of Scientific Computing』(Press, William H 他Cambridge, MA: Cambridge University Press、1992 年刊、896-901) を参照してください。 1
一度に CRC の 1 ビットを計算する C 関数は次のようになります。

rt CalculateCRC(char* buffer, int size)

{

  unsigned short cword = 0;

  unsigned short ch;

  int i,j;

  for (i = 0; i < size; i++) {

    ch = buffer[i] << 8;

    for (j = 0; j < 8; j++) {

      if ((ch & 0x8000) ^ (cword & 0x8000)) {

        cword = (cword <<= 1) ^ 4129;

      }

      else {

        cword <<= 1;

      }

      ch <<= 1;

    }

  }

  return cword;

}


非連続リスト項目

リスト項目は相互に隣接していない場合、非連続の状態になっています。


ポップアップウィンドウの例

ポップアップウィンドウを閉じる方法は 2 つあります。

  • ポップアップウィンドウ外でクリックする
  • グラフィック (上記の Cognex のロゴなど) で占められていない、ポップアップウィンドウの内部でクリックする


ファイルへの印刷

ファイルへの印刷このダイアログでは、プリンタの代わりにファイルに印刷できます。ディレクトリを指定しない場合、In-Sight Explorer 実行可能ファイルが格納されているディレクトリにファイルが保存されます。


プロパティシート - 複数パラメータの例

一部のプロパティシートのパラメータは、次に示すモデル領域のように、わかりやすくグループ化されています。


ReadIDCode のエラー文字列

ID のエラー文字列

GetErrorString ビジョンデータアクセス関数を使用すると、ReadIDMax 関数で返される [image] データ構造、または ReadIDCode 関数で返される [image] 構造のいずれかから次のエラーリストを抽出できます。

  • システムエラーです。
  • ヒープメモリが不足しています。
  • ビジョンツールエラーです。
  • 無効な画像バッファです。
  • 無効な領域サイズです。
  • 領域が画像境界を超えています。
  • ReadIDMax エラー。
  • ReadIDCode エラーです。
  • 行アドレスパターンを検出できません。
  • 行アドレスパターン (RAP) メモリ制限を超えています。
  • CC-A シンボルバージョンを検出できません。
  • 欠落している RAP ポイントを埋めることができません。
  • 無効なスキャンラインが検出されました。
  • スキャンラインが画像境界を超えています。
  • 半値パターンを検出できません。
  • 半値メモリ制限を超えています。
  • 有効なシンボルが見つかりません。
  • 訂正の必要なシンボルエラーが多すぎます。
  • リード・ソロモンのエラー訂正に失敗しました。
  • 自動コントラストしきい値計算に失敗しました。
  • コントラスト感度が許容範囲を超えています。


レポートファイルの種類

HTML を出力ファイルの種類として選択すると、事前定義された HTML フォーマットを含んだ内部スタイルシートが使用されます。HTML レポートの Web ブラウザ出力を以下に示します。

XML を選択すると、In-Sight Explorer により、In-Sight センサのレポートが XML 形式で出力されます。レポートのコードを見ると、XML の階層型の性質を確認できます。

<?xml version="1.0" encoding="utf-8" standalone="yes" ?>

<In-SightReport title="In-Sight Report" date="6/27/2005" time="2:46:26 PM">

  <In-Sight Name="is5100_020304">

    <MACAddress>00-d0-24-02-03-04</MACAddress>

    <SerialNumber>Z44200031</SerialNumber>

    <FirmwareVersion>2.80.00 (568)</FirmwareVersion>

    <MonitorVersion>2.00</MonitorVersion>

    <Settings>

      <Network>

        <UseDHCP>True</UseDHCP>

        <HostName>is5100_020304</HostName>

        <Current>

          <IPAddress>192.168.0.115</IPAddress>

          <SubnetMask>255.255.255.0</SubnetMask>

          <DefaultGateway>192.168.0.254</DefaultGateway>

          <DNSServer>192.168.0.2</DNSServer>

          <DomainName>yourdomain.com</DomainName>

       </Current> >

...


結果テーブル

EasyBuilder ビューの [ジョブの実行] ステップで表示可能な結果テーブルには、アクティブジョブの各ツールに関する情報が表示されるので、ジョブが実行されているときにツールをモニタまたはトラブルシューティングすることができます。

結果表にはツールごとに、PASS/FAIL ステータス、ツールアイコン、名前、種類、結果、PASS の総数と FAIL の総数、ツールの実行に必要な経過時間 (ミリ秒単位) が表示されます。

注: [結果] 列には、次の結果が表示されます。
In-Sight モデル | 結果
In-Sight 2000-110、2000-120 & 2000-120C ビジョンセンサ | PASS/FAIL ステータス
In-Sight 2000-130 & 2000-130C ビジョンセンサ | 寸法測定および計数検査ツール: 標準の結果 (数値データ) その他のツール (位置決めツールを含む): PASS/FAIL ステータス
In-Sight ビジョンシステムと In-Sight 2000-23M ビジョンセンサ | 標準の結果

また、テーブルでツールを選択すると、選択されたツール (オレンジ色でハイライト表示されているもの) とそのジョブのそのほかのツールの依存関係が表示されるので、ツールの不具合が他のツールの不具合に関係しているかどうかを判断することができます。ツールが別のツールを参照しているときには依存関係が存在します。1 つの依存関係は、参照元と参照先の 2 つの部分から構成されます。これらは線で結ばれています。参照元とはデータのソース (入力を提供するツール) のことで、円で表されます。参照先とはデータのディスティネーション (出力を受け取るツール) のことで、矢印で表されます。青い依存関係グラフィックスは選択したツールが参照先であることを、緑色のグラフィックスは選択したツールが参照元であることを示します。

テーブルの簡略版が [パレット] の [結果] タブに表示されます。[ジョブの実行] と [結果] タブの両方でテーブル内のツールを右クリックすると、そのツールを編集できます。


RightClickMenu

右クリックメニュー
  • [切り取り]: 選択したセルを切り取ります。多くの場合、[貼り付け] と組み合わせて使用されます。
  • [コピー]: 選択されているセルをクリップボードにコピーします。多くの場合、[貼り付け] と組み合わせて使用されます。
  • [貼り付け]: クリップボードに切り取りまたはコピーされたセルを貼り付けます。
  • [挿入]: 選択した行数または列数だけ、行または列を挿入します。行全体または列全体を選択しなければ、[挿入] ダイアログを開いて、セル、行、または列を挿入できます。
  • [削除]: 選択した行または列を削除します。行全体または列全体を選択しなければ、[削除] ダイアログを開いて、セル、行、または列を削除できます。
  • [コンテンツのクリア]: 選択したセルのコンテンツをクリアします (すべて、フォーマット、コンテンツ、コメントまたはシンボリックタグ、アクセス許可)。
  • [関数の挿入]: [関数の挿入] ダイアログを開いて、関数をアクティブセルに挿入します。このオプションは、アクティブセルが関数を含んでいない場合のみ使用可能です。
  • [関数の編集]: アクティブセルにプロパティシートが関連付けられた関数が含まれている場合、プロパティシートが開きます。そうでない場合は、[関数の挿入] ダイアログが開きます。このオプションは、アクティブセルに関数が含まれている場合のみ使用可能です。
  • [絶対参照を挿入]: 絶対参照をアクティブセルに挿入します。
  • [相対参照を挿入]: 相対参照をアクティブセルに挿入します。
  • [コメントの挿入]: [コメントの編集] ダイアログを開いて、アクティブセルに新しいコメントを挿入します。このオプションは、アクティブセルがコメントを含んでいない場合のみ使用可能です。
  • [コメントの編集]: [コメントの編集] ダイアログを開いて、アクティブセルの既存のコメントを編集します。このオプションは、アクティブセルにコメントが含まれている場合のみ使用可能です。
  • [シンボリックタグの挿入]: [シンボリックタグエディタ] ダイアログを開いて、アクティブセルに新しいシンボリックタグを挿入します。このオプションは、アクティブセルがシンボリックタグを含んでいない場合のみ使用可能です。
  • [シンボリックタグの編集]: シンボリックタグエディタを開いて、アクティブセルの既存のシンボリックタグを編集します。このオプションは、アクティブセルにシンボリックタグが含まれている場合のみ使用可能です。
  • [セルのグラフィック]: 対話型グラフィックスモードに切り替えて、セルグラフィックスを編集します。このオプションは、関連するセルグラフィックスを持つ関数がアクティブセルに含まれている場合にのみ使用できます。
  • [セル状態]: [セル状態] ダイアログを開いて、セルの実行を明示的に有効または無効にしたり、参照セルの値に基づいて条件付きで有効または無効にしたりします。
  • [ジョブの PASS/FAIL]: [ジョブの PASS/FAIL セルの設定] ダイアログを開いて、数値の結果を含むセルをモニタし、ジョブ全体の成功/失敗ステータスを判定します。ジョブのステータスは、センサからの出力として、Cognex VisionView などそのほかのアプリケーションへ送信することができます。
  • [カスタムビューの設定]: [カスタムビューの設定] ダイアログを開いて、スプレッドシートの [カスタムビュー] プロパティを設定します。
  • [EasyView の設定]: [EasyView の設定] ダイアログを開いて、VisionView のデータの表示方法をカスタマイズします。
  • [フォーマット]:
    • [セルのフォーマット]: [セルのフォーマット] ダイアログを開いて、選択したセルの数値、配置、フォント、および保護を設定します。
    • [行の高さ]: [行の高さ] ダイアログを開いて、スプレッドシートの 1 行または複数の行の高さを調整します。
    • [列の幅]: [列の幅] ダイアログを開いて、スプレッドシートの 1 列または複数の列の幅を調整します。
    • [非表示]: 選択した行または列を非表示にします。
    • [再表示]: 選択されている行または列の間にある非表示の行または列を表示します。
  • [スニペット]:
    • [インポート]: [スニペット] ダイアログを開いて、.CXD ファイルで保存されたスニペットをスプレッドシートにインポートします。このデータファイルは、PC の Snippets フォルダからロードすることができます。
    • [エクスポート]: [スニペット] ダイアログを開いて、.CXD ファイルで保存されたスニペットを PC の Snippets フォルダにエクスポートします。
  • [セルのインポート]: .CXD ファイルのセルデータをスプレッドシートにインポートします。
  • [セルのエクスポート]: .CXD ファイルのセルデータをエクスポートします。


ロボットコントローラ

ロボットコントローラは、データの取り込みと転送を制御するデバイスです。一般に、In-Sight ネイティブモードコマンドを使用するロボットコントローラは、画像を取り込み、処理するようにビジョンシステムをトリガし、その後、ビジョンシステムに特定のデータを要求します。典型的な通信のやり取りは次のようになります。

ロボットコントローラコード
  1. In-Sight ビジョンシステムに接続します。
  2. Set Event and Wait (SW8) ネイティブモードコマンドを使って、画像取り込みをトリガします。
  3. Get Value (GV) ネイティブモードコマンドを使って、特定の In-Sight スプレッドシートセルの文字列を取得します。
  4. 必要に応じてデータを読み取り、文字列を解析します。
  5. データを適切なデータ型に変換し、ロボット位置レジスタを埋め込みます。
In-Sight コード
  1. ビジョンシステムのセル A0 (AcquireImage プロパティシート) で、トリガパラメータに対して [外部] を選択します。
  2. In-Sight ビジョンツールを設定してパーツの位置を決めます。
  3. 必要に応じて [FormatString] ダイアログまたは FormatString 関数を使って、データをフォーマットします。
  4. このデータが保存されるセルの位置をメモして、ロボットの GV ネイティブモードコマンドを使って、このデータを In-Sight ビジョンシステムから取得できるようにします。
スニペット

スニペットは、スプレッドシートビューのときに使用できます。特定の通信スニペットが多くのロボットメーカー用に作成されています。特定のロボットが見つからない場合は、

汎用ロボットスニペットの General.cxd を変更すると、ほとんどのロボットと通信できます。


RSS シンボル

省スペースシンボル (RSS: Reduced Space Symbology) のシンボル

RSS シンボルは、コンポジットシンボルのリニアコンポーネントとして使用されます。詳細については、AIM International が公開している『International Symbology Specification - EAN/UCC Composite Symbology™ (ITS/99-002)』の「Section 7.2」を参照してください。この仕様によると、RSS ファミリコンポーネントの上に表示できる CC-A のバージョンが制限されます。

  1. RSS-14 Stacked リニアコンポーネントは、2 列の CC-A コンポーネントのみにリンクできます。
  2. RSS Limited リニアコンポーネントは、3 列の CC-A コンポーネントのみにリンクできます。
  3. RSS-14 リニアコンポーネントは、4 列の CC-A コンポーネントのみにリンクできます。


スキャンライン

1D シンボルの場合、バーコードはスキャンラインと呼ばれるラインに分割されます。これらのラインは、バーの向きに対して垂直になります。 2D シンボルの場合、スキャンラインはシンボルの各行を交差します。 スキャン反射率プロファイルは、各スキャンラインに対して測定されます。これらはすべての検証計算に使用されます。

詳細については、International Standards Organization (ISO/IEC) が公開している『Bar Code Print Quality Test Specification』 (P/N ISO/IEC-15416)、American National Standards Institute (ANSI) が公開している『Bar Code Print Quality Guideline』 (P/N ANSI X3.182-1900)、または ヨーロッパ標準化委員会 (CEN) が公開している『specification EN1635』を参照してください。


SMTP

簡易メール転送プロトコル (SMTP: Simple Mail Transfer Protocol)

サーバ間の電子メールメッセージを送信するためのプロトコルです。


SNTP

簡易ネットワークタイムプロトコル (SNTP: Simple Network Time Protocol)

In-Sight センサの日付と時刻をリモートサーバの日付と時刻に同期するためのプロトコルで、日付と時刻の信頼できる最新情報を維持します。


構造体

構造体とは、複数の値を 1 つのセルに格納する「コンテナ」であり、通常、画像または画像から抽出された特徴を指します。構造体内の各値は、対応するデータアクセス関数を使ってセルに返すことができます。例えば、AcquireImage 関数は画像を取り込んで、画像構造体の内部に格納します。GetPixelValue は、画像構造体に格納された指定のピクセルのグレースケール値を返します。


サブネットマスク

サブネットマスクについて

実際の IP アドレスは、2 つのアドレス (ネットワークアドレスとホストアドレス) の組み合わせです。サブネットマスクによって、IP アドレスのどの部分がネットワークを表し、どの部分がホストを表すのかを定義します。IP アドレスのネットワーク部分は同じサブネットのすべてのホストにおいて共通しており、残りは各ホスト固有です。

サブネットマスクには 3 つの種類 (クラス) があります。ネットワークにおける個々のサブネットのクラスは、次の表に示すように、IP アドレスのうちでネットワーク部分を表すために使用されるビット数と、ホストアドレス部分を表すために使用されるビット数によって定義されます。

クラス | サブネットマスク | ネットワークアドレス | ホストアドレス
A | 255.0.0.0 | 8 ビット | 24 ビット
B | 255.255.0.0 | 16 ビット | 16 ビット
C | 255.255.255.0 | 24 ビット | 8 ビット

例えば、ネットワーク接続された、IP アドレスが 192.168.0.1 の In-Sight ホストシステムを考えてみます。最初の 3 つの数字 (192.168.0) によって 24 ビットのネットワークアドレスが識別され、末尾の数字 (1) がネットワーク上の In-Sight ホストの 8 ビットアドレスである場合、このホストのサブネットマスクは 255.255.255.0 です。


Popup_UserDataHoldingBuffer

ユーザデータ保持バッファ

ユーザデータ保持バッファは、Transfer User Data サービスを使って PLC から書き込まれたユーザデータの一時保存場所です。このバッファを使って、ビジョンシステムへの大規模データ転送を作成して、大規模転送中のデータの整合性を確実に保つことができます。Transfer User Data サービスを実行すると、In-Sight スプレッドシートは Set User Data サービスが実行されるまでデータを読み取れなくなります。そのサービスを実行すると、In-Sight スプレッドシートですべての転送済みデータにアクセスできます。このメカニズムにより、[In-Sight] スプレッドシートは常に、一貫したデータにアクセスします。


ホワイトバランス

ホワイトバランスは、画像の中心部に 100×100 領域の赤、緑、青 (RGB) チャネルのヒストグラムを生成します。各チャネルのピーク応答が検出されます。ビン数が最小の 2 つのチャネルが、カラーテーブルの作成に使う表示倍率を取得するために最大のビン数に分割されます。これらのテーブルは、画像が取り込まれるたびに参照されます。ホワイトバランス設定はジョブとともに保存され、最初の画像がそのジョブによって取り込まれると有効になります (ジョブのロード時には有効になりません)。


[ホワイトバランス] ボタン

[AcquireImage] プロパティシート下部に表示されている [ホワイトバランス] ボタンの図です (In-Sight センサの色のみ)。


XML

拡張マークアップ言語 (XML: Extensible Markup Language)

拡張マークアップ言語は、HTML に似た Web 文書作成言語です。HTML が主にテキストとグラフィックスの用途を対象としているのに対し、XML は自動的に処理できる系統的なデータのグループを格納するカスタマイズ性の高い標準方式を作成するために開発されました。

XML 形式の技術的な詳細については、http://www.w3.org/XML にアクセスしてください。


Encrypt

Encrypt |
文字列操作関数 → 文字列 | In-Sight 関数リファレンス

Blowfish と CBC (暗号ブロック連鎖) を使用して、Encrypt 関数によって結果データをユーザ定義のキーを用いて暗号化することができます。次に、暗号化したデータを In-Sight 関数またはネイティブモードコマンドなどを使用して PC や外部デバイスに送信し、復号化アプリケーションを用いてデータを復元します。

注:
  • Encrypt 関数は、In-Sight 5.4.0 以降のファームウェアを搭載した In-Sight ビジョンシステムでサポートされています。
  • Encrypt 関数には文字数の制限はありません。ただし、暗号化された文字列を PC やリモートデバイスに送信するために使用する In-Sight 関数には、255 文字の制限があり、#ERR を返します (暗号化された文字列は常に暗号化前の初期結果データよりも長いことに注意してください)。文字制限の詳細については、それぞれの In-Sight 関数のトピックを参照してください。
  • Cognex In-Sight Encryption サンプルアプリケーションは、キーの生成および復号化に使用することができます。
  • 暗号化/復合化のメカニズムの詳細については、サンプルコードを参照してください (C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Sample Projects 5.x.x)。
  • Encrypt の入力パラメータ
  • Encrypt の出力
  • Encrypt 関数の例
  • Cognex In-Sight Encryption サンプルアプリケーション
  • 関連項目

Encryptの入力パラメータ

Encrypt(

キー (Base 64)

値

出力フォーマット

)

キー (Base64)

結果データの暗号化に使用されるキー (文字列、Base64 エンコード)。受信者は同じキーを使用してデータを復合化します。

注: 非管理者ユーザに対してこのキーを不可視化するには、EditPassword を使用します。

値

 暗号化する結果データ (文字列)。

出力フォーマット

暗号化されたデータをエンコードする方法を選択します。

0 = Base64 (デフォルト) | 暗号化されたデータを Base64 を使用してエンコードします。
1 = Hex | 暗号化されたデータを Hex を使用してエンコードします。

Encryptの出力

結果

 暗号化された文字列を返します。

Encrypt例

この例では、ReadIDMax 関数によってデコードされたバーコード結果を暗号化してから、暗号化された結果を TCPDevice および WriteDevice 関数を使用してデータを復号化する PC に送信します。

  1. ReadIDMax 関数を挿入してバーコードをデコードします。結果文字列が自動的にスプレッドシートに挿入されます。

  2. EditPassword 関数を挿入します。結果文字列の暗号化に使用するキーを入力します。

    注: Cognex In-Sight Encrypt Generator サンプルアプリケーションを使用して、キーを生成することができます。詳細については、「サンプルアプリケーション」セクションを参照してください。

  3. Encrypt 関数を挿入し、プロパティシートを次のように設定します。
    • キー (Base64): EditPassword セルを参照します。

    • 値: ReadIDMax の結果文字列セルを参照します。

      注: 結果文字列でフォーマットが必要な場合、FormatString を使用してこの関数を参照します。

    • 出力フォーマット: 必要なエンコーディング方法を選択します (Base64 または Hex)。
  4. 暗号化された文字列が自動的にスプレッドシートに挿入されます。これで、暗号化されたバーコード結果を PC に出力する準備ができました。

  5. TCPDevice 関数を挿入し、デフォルト値を使用して TCP サーバをポート 3000 上に作成します。

    注: 自動的に追加された ReadDevice セルは削除します。

  6. WriteDevice 関数を挿入します。
    • イベント: A0 に設定します。
    • デバイス: TCPDevice セルを参照します (手順 5)。
    • データ: Encrypt セルを参照します (手順 3)。

  7. In-Sight ビジョンシステムをオンラインにします。telnet に接続して、ホスト名または IP アドレスおよびポート番号 (例えば、C:\ telnet is8402_010203 3000) を指定し、ビジョンシステムをトリガします。

    それぞれの取り込みが終わると、暗号化されたデータが転送されます。

  8. 暗号化された文字列を、復号化アプリケーションを使用して復合化します。復号化のときに、EditPassword セルにキーを入力する必要があります (手順2)。

    注: Cognex In-Sight Encrypt サンプルアプリケーションを使用して、暗号化された文字列を復合化することができます。詳細については、「サンプルアプリケーション」セクションを参照してください。

Cognex In-Sight Encryption サンプルアプリケーション

このサンプルアプリケーションは次の場所にあります。C:\Users\Public\Documents\Cognex\In-Sight\In-Sight Sample Projects 5.x.x

キー生成サンプル

このサンプルアプリケーションは、Base64 形式でキーを生成します。ランダムキーを生成するか、ユーザが入力したテキストに基づいてキーを生成するかを選択することができます。

復合化サンプル

このサンプルアプリケーションで、In-Sight Encrypt 関数を使用して暗号化されたメッセージを復合化します。

関連項目

  • ReadIDMax 関数
  • EditPassword 関数
  • FormatString 関数
  • TCPDevice 関数
  • WriteDevice 関数


GetFormat の値

GetFormat の値 |
ID コード関数 | In-Sight 関数リファレンス

次の表は、ReadIDMax または ReadIDCode 関数で、2D シンボルのフォーマットを表す値を一覧表示しています。

  • ECC 200 すべての 2D シンボルのフォーマットを表す値
  • ECC 0 ～ ECC 140 のすべての 2D シンボルのフォーマットを表す値
  • RSS-CCA シンボルのフォーマットを表す値
  • QR コードの 2D シンボルのフォーマットを表す値

注: PDF 417 2D シンボルに関しては、常にゼロが返されます。

ECC 200 すべての 2D シンボルのフォーマットを表す値

値 | 行数 | 列数
0 | 10 | 10
1 | 12 | 12
2 | 14 | 14
3 | 16 | 16
4 | 18 | 18
5 | 20 | 20
6 | 22 | 22
7 | 24 | 24
8 | 26 | 26
9 | 32 | 32
10 | 36 | 36
11 | 40 | 40
12 | 44 | 44
13 | 48 | 48
14 | 8 | 18
15 | 8 | 32
16 | 12 | 26
17 | 12 | 36
18 | 16 | 36
19 | 16 | 48

ECC 0 ～ ECC 140 のすべての 2D シンボルのフォーマットを表す値

値 | 行数 | 列数
20 | 9 | 9
21 | 11 | 11
22 | 13 | 13
23 | 15 | 15
24 | 17 | 17
25 | 19 | 19
26 | 21 | 21
27 | 23 | 23
28 | 25 | 25
29 | 27 | 27
30 | 29 | 29
31 | 31 | 31
32 | 33 | 33
33 | 35 | 35
34 | 37 | 37
35 | 39 | 39
36 | 41 | 41
37 | 43 | 43
38 | 45 | 45
39 | 47 | 47
40 | 49 | 49

RSS-CCA シンボルのフォーマットを表す値

値 | 行数 | 列数
0 | 5 | 2
1 | 6 | 2
2 | 7 | 2
3 | 8 | 2
4 | 9 | 2
5 | 10 | 2
6 | 12 | 2
7 | 3 | 4
8 | 4 | 4
9 | 4 | 5
10 | 4 | 6
11 | 4 | 7
12 | 4 | 3
13 | 5 | 3
14 | 6 | 3
15 | 7 | 3
16 | 8 | 3

QR コードの 2D シンボルのフォーマットを表す値

値 | 行数 | 列数
0 | 21 | 21
1 | 25 | 25
2 | 29 | 29
3 | 33 | 33
4 | 37 | 37
5 | 41 | 41
6 | 45 | 45
7 | 49 | 49
8 | 53 | 53
9 | 57 | 57
10 | 61 | 61
11 | 65 | 65
12 | 69 | 69
13 | 73 | 73
14 | 77 | 77
15 | 81 | 81
16 | 85 | 85
17 | 89 | 89
18 | 93 | 93
19 | 97 | 97
20 | 101 | 101
21 | 105 | 105
22 | 109 | 109
Version: 5.6.0


GetNFound 関数

データアクセス

In-Sight 関数リファレンス

GetNFound 関数次の構造体で検出された項目の数を返すデータアクセス関数です。

  • ブロブ
  • エッジ
  • 傷
  • パターン

の使用方法GetNFound 関数

一般的なシンタックスはGetNFound 関数次のとおりです。

   GetNFound 関数(Structure)

ここで Structure は、 [image] 、 [image] 、 [image] 、または [image] データ構造体を含んでいるセルへの参照です。


GetRow 関数

データアクセス

In-Sight 関数リファレンス

GetRow 関数次のデータ構造体から行座標 (Y 座標) を読み込むために使用されるデータアクセス関数です。

  • ブロブ
  • CircleFit 関数
  • 距離関数
  • エッジ
  • ID コード関数
  • IDMax 関数
  • 画像フィルタ関数
  • LineFit 関数
  • パターン関数
  • 構造体 (円環、円、十字、フィクスチャ、線、点、および領域)
  • テキスト (文字照合/認識) 関数

の使用方法GetRow 関数

一般的なシンタックスはGetRow 関数次のとおりです。

   GetRow 関数(Structure、Index1, [Index2])

ここで、Structure は、次のデータ構造体を含むセルへの参照です。 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、 [image] 、または [image] 。

Index1 (オプション) は、参照する構造体で、アクセスの対象となる要素を指定します。

Index2 (オプション) は端点 (0 または 1) ( [image] のみ)、あるいはインデックス付きシンボル ( [image] のみ) を指定します。


GetString 関数

データアクセス

In-Sight 関数リファレンス

GetString 関数次の構造体または関数から情報を返すデータアクセス関数です。

  • オペレータ I/F 関数
  • ID コード関数
  • 画像フィルタ関数
  • テキスト (文字照合/認識) 関数

の使用方法GetString 関数

一般的なシンタックスはGetString 関数次のとおりです。

   GetString 関数(Structure)

ここで、Structure は、 [image] 、 [image] 、 [image] データ構造体を含んでいるセルへの参照です。


GetValue 関数

データアクセス

In-Sight 関数リファレンス

GetValue 関数次の構造体から情報を返すデータアクセス関数です。

  • カラーヒストグラム
  • 遅延
  • ヒストグラム

の使用方法GetValue 関数:

一般的なシンタックスはGetValue 関数次のとおりです。

   GetValue 関数(Structure, [Index], [Color])

ここで Structure は、 [image] 、 [image] 、または [image] データ構造体を含んでいるセルへの参照です。

Index は、オプションでヒストグラムの値 ( [image] および [image] のみ) をカウントする階層を指定します。

Color は、オプションでヒストグラムデータ ( [image] のみ) を引き出すために使用されている色成分を判定します。


InspectEdgeTrainBeadPath 関数

InspectEdgeTrainBeadPath 関数 |
ビジョンツール → エッジ検査 | In-Sight 関数リファレンス

InspectEdgeTrainBeadPath 関数は、エッジを基準とするビード特徴の中心を検出するために使用され、検出されたビードパスをトレースしたポリラインを作成します。このツールで作成されたポリラインパスを、InspectEdgeWidth 関数など、そのほかの InspectEdge 関数で入力として使用して、ビードに位置的な欠陥、幅の欠陥、またはギャップがないかどうかを判断することができます。

  • InspectEdgeTrainBeadPath 関数の概要
  • InspectEdgeTrainBeadPath の入力パラメータ
  • InspectEdgeTrainBeadPath の出力
  • InspectEdgeTrainBeadPath 関数の関連項目

InspectEdgeTrainBeadPath 関数 概要

ビードパスは連続するエッジのペアで、異なるピクセル値を持つ 2 つの領域間の境界を定義します (このパスは必ずしもループではありません)。一般に、ビードパスはインクや糊のついている部分や溶接の継ぎ目のことで、その幅や厚み、および位置によって定義されます。InspectEdgeTrainBeadPath 関数を、ほかの InspectEdge 関数とともに使用して、画像ごとにビードパスが異なる場合のビードの追跡アプリケーションで適用したり、ビードパスが常に同じ位置にあるかどうかの検証を行ったりすることができます。

ビードの追跡アプリケーションでは、InspectEdgeTrainBeadPath 関数を InspectEdge 関数の 1 つや InspectEdgeWidth 関数とともに使用して、ビードパスが濃くも薄くもなく、常に一定のパターンで配置されていることを検証できます。これらの関数はビードに沿ったパスを定義するマルチセグメントラインを作成し、濃すぎたり、薄すぎたりする領域や、欠落した領域がビードパスにないかどうかを判断します。

位置を基準にしたビード追跡アプリケーションでは、同じ関数を使用して、ビードパスが常に同じ場所に同じ濃度で存在するかどうか、パスに位置のばらつきはないかどうかを検証することができます。

注意: どちらのアプリケーションで使用する場合でも、InspectEdgeTrainBeadPath 関数を InspectEdge 関数の [外部領域またはパス] パラメータへの入力として使用する必要があります。また、InspectEdgeWidth 関数は、InspectEdge のパラメータで、InspectEdge 関数が出力した [image] データ構造体を参照する必要があります。

InspectEdgeTrainBeadPath 関数の入力パラメータ

InspectEdgeTrainBeadPath 関数(

画像,

フィクスチャ.行,

フィクスチャ.列,

フィクスチャ.角度,

領域.X,

領域.Y,

領域.高さ,

領域.幅,

領域.角度,

領域.カーブ,

外部領域またはパス,

キャリパ.高さ,

キャリパ.繰り返しオフセット値,

キャリパ.初期オフセット値,

最小コントラスト,

エッジ幅,

全キャリパに適合,

エッジ方向の検出,

第 1 エッジ,

第 2 エッジ,

エッジ得点.得点しきい値,

エッジ得点.エッジ規則,

エッジ得点.コントラスト上限,

エッジ得点.ペアサイズ,

登録,

キャリパグラフインデックス,

表示

)

画像

このパラメータは、スプレッドシートで [image] データ構造体を含むセルを参照する必要があります。デフォルトでは、このパラメータは、AcquireImage [image] データ構造体を含むセル A0 を参照しています。また、このパラメータは、ビジョンツールのグラフィックス関数によって返された、そのほかの [image] データ構造体も参照できます。

フィクスチャ

フィクスチャ入力、またはビジョンツール関数の画像座標系の出力に関連する対象領域 (ROI) を定義します。フィクスチャに関連する ROI を設定すると、フィクスチャが回転または移動した場合に、フィクスチャに対応して ROI を確実に回転または移動できます。

デフォルト設定は画像の左上隅で、(0, 0, 0) になります。

行 (デフォルト = 0) | 画像座標での行オフセット
列 (デフォルト = 0) | 画像座標での列オフセット
角度 (デフォルト = 0) | 画像座標系での方位角

領域

これは対象領域 (ROI) とも呼ばれ、エッジ解析の対象となる画像の領域を表します。変換および回転可能な矩形の画像領域を作成します。このパラメータを選択して、プロパティシートのツールバーにある [領域の最大化] ボタンを押すと、画像全体が対象になるように領域が自動的に拡張されます。黄色の点線は、エッジを検出する方向を示しています。

X | フィクスチャ座標での原点の X オフセット
Y | フィクスチャ座標での原点の Y オフセット
高さ | 領域の X 軸に沿った寸法
幅 | 領域の Y 軸に沿った寸法
角度 | フィクスチャ座標での角度
カーブ | 領域の X 軸と反対側の境界線との間の角度変位

注意: [フィクスチャ] および [領域] パラメータは、画像の範囲内で定義されている必要があります。画像の範囲内で定義されていない場合、この関数は #ERR を返します。

外部領域またはパス

Annulus 関数、Region 関数、EditAnnulus 関数、EditMaskedRegion 関数、EditPolylinePath 関数 または EditRegion 関数を含むスプレッドシートセルへの参照を指定します。このパラメータを使用すると、InspectEdge ツールは、[領域] と [フィクスチャ] の設定を無視し、参照先領域に指定された画像領域を検査します。

注意:
  • このパラメータが外部領域またはパスの参照として設定されている場合に、この関数の内部領域を使用するには、セル参照に値 0 を入力し、このパラメータを手動で 0 に設定する必要があります。それ以外の場合、この関数は引き続き外部領域またはパスを参照します。
  • InspectEdge 関数の [外部領域またはパス] パラメータが EditPolylinePath を参照している場合、InspectEdge 関数を InspectEdgeForDefect 関数または InspectEdgePosition 関数の参照として使用することはできません。これらの関数は #ERR を返します。

キャリパ

検出可能な欠陥やギャップのサイズを定義するために使用する ROI 内のキャリパ配列を指定します。検出可能な欠陥またはギャップのサイズは、検出可能なエッジの数によって決定されます。検出可能なエッジの数は、エッジに沿って配置されたキャリパの数によって決まります。InspectEdge セルがハイライトされているか、[表示] パラメータが [すべて表示] に設定されている場合、キャリパは ROI 内で赤い矩形として表示され、キャリパ内で検出されたエッジは緑色で表示されます。

注意: 検査する欠陥のタイプに応じて、キャリパをオーバラップして配置することができます。ただし、ROI に適用されるキャリパ数が増えるほど、関数の実行時間は長くなります。

高さ | 検査方向に沿って解析されるキャリパあたりのピクセル数を指定します。有効な範囲は、1 から In-Sight ビジョンシステムの画像の幅までです。デフォルト値は 5 です。
繰り返しオフセット値 | 各キャリパの開始間のピクセル数を指定します。有効な範囲は、0 から In-Sight ビジョンシステムの画像の幅までです。デフォルト値は 5 です。[全キャリパに適合] が有効な場合を除き、最後のキャリパは領域の終わりにオーバラップすることがあります。
初期オフセット値 | 領域内の最初のキャリパのオフセットを指定します。有効な範囲は、0 から In-Sight ビジョンシステムの画像の幅までです。デフォルト値は 0 です。

最小コントラスト

エッジとみなされるグレースケールコントラストの最小変化値を指定します (1 ～ 255、デフォルト = 5)。インデックス付きキャリパごとに、青色で描画されたコントラストグラフが画像上に表示されます。グラフ内の値は、0 ～ 100 の値に自動的にスケール変更されます。このパラメータの適用時にこのグラフを使用すると、値を適切に調整できます。

Closed 例 - グラフの [最小コントラスト] パラメータ

エッジ幅

エッジ変化が起きるピクセル距離を指定します (1 ～ 領域の幅、デフォルト = 3)。この設定値は、エッジが抽出される前のグレースケールプロジェクションのフィルタ処理に使用されるピクセル演算子の大まかなサイズです。この設定値を使用して、画像からノイズをフィルタします。

全キャリパに適合

すべてのキャリパを ROI 内に配置するかどうかを指定します。

0 = OFF (デフォルト) | 関数が [キャリパ繰り返しオフセット値] パラメータおよび [初期オフセット値] パラメータに厳密に従うように指定します。この場合、キャリパが ROI を覆ってしまうことがあります。
1 = ON | ROI 内にすべてのキャリパを確実に配置するために、関数が [キャリパ繰り返しオフセット値] パラメータおよび [初期オフセット値] パラメータを自動的に再計算するように指定します。
エッジ方向の検出

エッジを検出する方向を指定します。

0 = 左→右 | ROI の左から右に向かってエッジを検出します。 Closed 例
1 = 右→左 | ROI の右から左に向かってエッジを検出します。 Closed 例
3 = 内→外 (デフォルト) | ROI の中心から ROI の上の境界および下の境界に向かってエッジを検出します (検出されたエッジの順序は、ROI の「X」矢印とは反対の方向の順になります)。 Closed 例 注意: このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
2 = 外→内 | ROI の上下の境界から ROI の中心に向かってエッジを検出します (検出されたエッジの順序は、ROI の「X」矢印とは反対の方向の順になります)。 Closed 例 注意: このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
第 1 エッジ

[エッジ方向の検出] パラメータに従って、検出された最初のエッジのコントラスト変化を指定します。

1 = 黒→白 | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 (デフォルト) | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは、黒→白または白→黒のいずれかに変化します。
第 2 エッジ

[エッジ方向の検出] パラメータに従って、検出された 2 番目のエッジのコントラスト変化を指定します。

1 = 黒→白 (デフォルト) | エッジは、黒ピクセルから白ピクセルに変化します。
2 = 白→黒 | エッジは、白ピクセルから黒ピクセルに変化します。
3 = 任意 | エッジは、黒→白または白→黒のいずれかに変化します。
エッジ得点

指定した基準をエッジが満たすかどうかを判別するために使用する、エッジ得点モードを指定します。

得点しきい値

得点付けのしきい値を指定します。この値 (0 ～ 100、デフォルト = 10) より小さい得点のエッジはフィルタで除去されます。

エッジ規則

得点を計算するときに最も重要になるエッジのタイプを指定します。

1 = 最初のエッジ | 検出された最初のエッジに注目します。
2 = エッジ強度 | 最強のコントラスト変化を持つエッジに注目します。
3 = 最初のエッジ/エッジ強度 | 最初に検出され、最強のコントラスト変化を持つエッジに注目します。
4 = エッジペアサイズ (デフォルト) | 最大サイズのエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
5 = 最初のエッジ/エッジペアサイズ | 検出された最初のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
6 = エッジ強度/エッジペアサイズ | 変化が最強のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。
7 = 最初のエッジ/エッジ強度/エッジペアサイズ | 変化が最強の最初のエッジペアに注目します。このオプションを有効にするには、[エッジペアの検査] パラメータを ON にしておく必要があります。

コントラスト上限

エッジとみなすエッジコントラスト変化の上限 (2 ～ 255、デフォルト = 255) を指定します。この値を超えるエッジコントラスト変化を持つエッジの得点は、すべて同じ最高得点になります。このパラメータを有効にするには、[エッジ規則] パラメータを、[エッジ強度]、[最初のエッジ/エッジ強度]、[エッジ強度/エッジペアサイズ]、[最初のエッジ/エッジ強度/エッジペアサイズ] のいずれかに設定しておく必要があります。
ペアサイズ 最高得点を記録するエッジペアサイズを指定します (有効な範囲は、In-Sight ビジョンシステムの画像幅の 1 ～ 3 倍。デフォルト = 5)。このパラメータが有効な場合、この値の上下で検出されたエッジペアはこの値に比例して得点付けされます。例えば、[ペアサイズ] が 10 に設定されており、値が 8 と値が 14 の 2 つのエッジペア候補が検出された場合は、値 8 のエッジペアが選択されます。これは、2 番目のエッジペアより [ペアサイズ] に近いためです。このパラメータを有効にするには、[エッジ規則] パラメータを [エッジペアサイズ]、[最初のエッジ/エッジペアサイズ]、[エッジ強度/エッジペアサイズ]、または [最初のエッジ/エッジ強度/エッジペアサイズ] のいずれかに設定しておく必要があります。
登録

ツールの登録モードを指定します。

0 = OFF | この関数が登録を行わないように指定します。
1 = ON (デフォルト) | この関数が登録を行うように指定します。

キャリパグラフインデックス

表示するキャリパを指定します (デフォルト = 0)。

表示

画像上の InspectEdge グラフィックスオーバレイの表示モードを指定します。

0 = 非表示 (デフォルト) | InspectEdgeTrainBeadPath 関数を含んでいるセルがスプレッドシート内でハイライトされている場合を除き、すべてのグラフィックスが表示されません。
1 = 結果のグラフィックスのみ | 登録された EditPolylinePath 関数および検出されたエッジペアポイントグラフが常に表示されます。
2 = 結果グラフィックスとキャリパ詳細の表示。 | 登録された EditPolylinePath 関数と 1 つのキャリパがエッジ候補とともに常に表示され、さらに、キャリパグラフが常に表示されます。
3 = 結果グラフィックス、キャリパ詳細およびエッジ候補を表示します。 | 登録された EditPolylinePath 関数と 1 つのキャリパがエッジ候補とともに常に表示され、さらに、キャリパグラフとすべてのキャリパのエッジ候補すべてが常に表示されます。
4 = 結果グラフィックス、すべてのエッジ候補およびキャリパを表示します。 | 登録された EditPolylinePath 関数と 1 つのキャリパがエッジ候補とともに常に表示され、さらに、キャリパグラフ、すべてのキャリパのエッジ候補すべて、およびキャリパすべてが常に表示されます。
5 = すべて表示: 入力と結果のグラフィックス | 入力グラフィックス、登録された EditPolylinePath 関数、1 つのキャリパがエッジ候補とともに常に表示され、さらに、キャリパグラフ、すべてのキャリパのエッジ候補すべて、およびキャリパすべてが常に表示されます。

InspectEdgeTrainBeadPath 関数の出力

戻り値 | 画像内で検出されたエッジとキャリパ数を含む [image] データ構造体。入力パラメータが無効であれば #ERR を返します。
結果 | ROI 内のキャリパの数。

関連項目

  • InspectEdge ツールについて
  • InspectEdge 関数のデータアクセス関数
  • InspectEdge 関数
  • InspectEdgeForDefect 関数
  • InspectEdgePosition 関数
  • InspectEdgeWidth 関数
  • プロパティシートの使用方法


LocalStorage 関数

LocalStorage 関数 |
入出力関数 | In-Sight 関数リファレンス

LocalStorage 関数により、オンラインの間に、画像ファイルとデータファイルが In-Sight ビジョンシステムに取り付けられた SD カードのファイルに書き込まれます。

  • WriteImageLocal: オンラインの間に、In-Sight ビジョンシステムに取り付けられた SD カードに現在の画像を書き込みます。
  • WriteLocal: オンラインの間に、In-Sight ビジョンシステムに取り付けられた SD カードのファイルにデータファイルを書き込むか、データ文字列を追記します。


Stats 関数

Stats 関数 |
データアクセス | In-Sight 関数リファレンス

注: 返される値はすべて、参照される [image] 構造体から取得され、ComputeStats 関数の作成時にスプレッドシートに挿入されます。

関数 | 説明
GetLatest(統計) | 統計情報の計算に使用する最新の値を返します。
GetMax(統計) | 統計情報の計算に使用する最大値を返します。
GetMean(統計) | 値の平均を返します。
GetMin(統計) | 統計情報の計算に使用する最小値を返します。
GetErrorCount(統計) | 参照先の値からのエラー総数を返します。
GetNumSamples(統計) | 計算に使うサンプルの総数を返します。
GetRange(統計) | 最小値と最大値の間の範囲を返します。
GetSDev(統計) | 値の標準偏差を返します。
GetSum(統計) | 値の合計を返します。
GetVariance(統計) | 値の差異を返します。


WriteImageLocal

入出力関数 → LocalStorage

In-Sight 関数リファレンス

オンラインの間に、In-Sight ビジョンシステムに取り付けられた SD カードに現在の画像を書き込みます。画像ファイルとして、画像上にグラフィックスオーバーレイを含めた SVG ファイルを作成することもできます。一般的には、検査に失敗した画像を自動保存するために使用します。

  • WriteImageLocal の入力パラメータ
  • WriteImageLocal の出力
  • WriteImageLocal 関数の例
  • 関連項目
注:
  • この関数では、画像ファイルと SVG ファイルを送信するために In-Sight ビジョンシステムがオンラインである必要があります。
  • In-Sight ビジョンシステムにリモートでログオンしている場合、関数を使用すると、画像取り込みごとに画面の画像が更新されないことがあります。
  • ビジョンシステムをオンラインにしているときに AcquireImage パラメータを変更すると、関数によって現在の画像が送信されます。

WriteImageLocalの入力パラメータ

WriteImageLocal(

イベント,

画像,

ファイル名,

最大追記値,

リセット,

データフォーマット,

グラフィックスオーバーレイの保存,

解像度

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)。
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル

注:デフォルトのイベント参照が削除された場合、この値はチェックボックスで置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

画像

データ構造体を含むセルへの参照です。デフォルトの参照先は、セル A0 の [image] データ構造体です。

ファイル名

書き込む画像ファイルの名前です。[グラフィックスオーバーレイ] パラメータが有効な場合は、SVG ファイルの名前も定義します。ロングファイル名がサポートされ、各ファイルが出力される時、それぞれのファイル名に数値カウンタが付加されます (数値カウンタの最大値は、[最大追記値] で指定します)。

最大追記値

指定されたファイル名で出力する画像ファイルの最大数 (0 ～ 9999999、デフォルト = 999)。数値カウンタは指定されたファイル名の後ろに付加され、各画像ファイルが転送されるごとにカウンタは 1 つ増加します。カウンタが最大追記値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

数値カウンタの桁数は、最大追記値の桁数と等しくなります。例えば、最大追記値のデフォルト値 999 の場合は、ファイル名に 3 桁の数値が付加されます。0 が指定された場合は、ファイル名にカウンタは付加されません。

リセット

画像ファイルと SVG ファイルの両方に指定したファイル名に付加された数値カウンタを再開します。出力先のシステムに既にある画像ファイルと SVG ファイルは、同じ名前の新しいファイルで上書きされます。

0 = OFF (デフォルト) | 最大追記値まで、各画像ファイルが転送されるごとにカウンタを 1 つ増加します。
1 = ON | カウンタを 0 にリセットします。

データフォーマット

送信先のホストに書き出される画像のファイルフォーマットです。

0 = BMP (デフォルト) | Windows ビットマップフォーマット (拡張子は .bmp です)。
1 = JPEG | 標準エンコード JPEG フォーマット (拡張子は .jpg です)。

グラフィックスオーバーレイの保存

In-Sight ビジョンツール、幾何計測関数および画面表示関数でサポートされているオーバレイグラフィックスデータを含めた SVG ファイルを、各関数の [表示] パラメータでグラフィックスを表示するように設定された場合に、作成するかどうかを指定します。オーバレイグラフィックスは [セルのフォーマット] ダイアログで指定したフォーマットを使用します。SVG ファイルと画像ファイルを表示するには SVG ファイルタイプをサポートする Web ブラウザ (Microsoft Internet Explorer 9.0 など) で SVG ファイルを開きます。SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注:

  • 有効にすると、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • グラフィックスは Web ブラウザなどのサードパーティ製のアプリケーションによって表示されるため、オーバーレイグラフィックスデータは、ピクセル単位での正確な一致にはなりません。
  • In-Sight ファームウェアでは、SVG と画像ファイルの各ペアの転送を保証していません。In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。

0 = OFF (デフォルト) | 画像のみ転送されるように指定します。
1 = ON | 画像ファイルと SVG ファイルが転送されるように指定します。有効にすると、グラフィックスオーバーレイデータを含む SVG ファイルは画像に指定されたディレクトリに保存されます。Microsoft Internet Explorer 9.0 以降などの Web ブラウザを使用して、グラフィックスオーバーレイと画像を一緒に表示します。
解像度

画像がエクスポートされるときの画像解像度を指定します。

1 = フル (デフォルト) | 画像はフル解像度でエクスポートされます。
2 = ハーフ | 画像は半分の解像度でエクスポートされます。
3 = クォーター | 画像は 1/4 の解像度でエクスポートされます。

WriteImageLocalの出力

戻り値

データ構造体を返します。スプレッドシートが更新されるたびに、指定された [image] データ構造体に含まれている画像データが出力先システムのファイルに出力されます。

いずれかのパラメータが無効な場合、SD カードが取り付けられていないかいっぱいになっている場合、または SD カードが取り付けられていても適正にフォーマットされていない場合は、#ERR が返されます。

WriteImageLocal例

WriteImageLocal($A$0,$A$0,"Image",999,0,0,0,1)

画像を取り込んだ後にスプレッドシートが更新された場合にはいつでも、上記の式によって、In-Sight ビジョンシステムに取り付けられている SD カードにビットマップ画像ファイルが書き込まれます。最初に転送されたファイルは、Image000.BMP、2 番目が Image001.BMP というように連続して出力されます。

注:検査で不合格となった画像のみを保存する方法としては、関数にセル状態を設定する手法が一般的です。

関連項目

  • WriteLocal
  • 入出力関数について


WriteLocal

入出力 → LocalStorage

In-Sight 関数リファレンス

In-Sight ビジョンシステムに取り付けられた SD カードのファイルにデータファイルを書き込むか、データ文字列を追記します。この関数は通常、データ結果のログ作成に使用されます。このログはファイルで参照できます。

  • WriteLocal の入力パラメータ
  • WriteLocal の出力
  • WriteLocal 関数の例
  • 関連項目

注: WriteLocal 関数を使用するには、In-Sight ビジョンシステムをオンラインにする必要があります。

WriteLocalの入力パラメータ

WriteLocal (

イベント,

ファイル名,

データフォーマット ,

文字列 ,

追記

)

イベント

指定した値を読み取るイベントを指定します。このパラメータは、次のいずれかを参照している必要があります。

  • AcquireImage 関数を含んでいるセル A0 の [image] データ構造体 (デフォルト)
  • 関数を含んでいるセル。
  • Button 関数を含んでいるセル。

注: デフォルトのイベント参照が削除された場合、この値はチェックボックスによって置き換えられます。イベントとして別のセルを参照した場合、この関数は、参照されたセルに基づき、条件に従って実行されます。このチェックボックスが ON の場合、関数への入力が更新されると、関数は必ず実行されます。

ファイル名

ファイルの名前です。ロングファイル名がサポートされています。FTP サーバ上にそのファイルが存在しない場合は、WriteFTP 関数の初回実行時に自動的に作成されます。デフォルトのファイル名は InSight です。

データフォーマット

ファイルのタイプです。各タイプに応じた拡張子が、自動的にファイル名に追記されます。

0 = テキスト | 標準 ASCII フォーマットのテキストファイル (.txt)。
1 = HTML (デフォルト) | 標準 HTML フォーマットのファイル (.htm)。
4 = XML | 標準 XML フォーマットのファイル (.xml)。
5 = CSV | 標準 CSV フォーマットのファイル (.csv)。

文字列

文字列または文字列を含むセルへの参照。255 文字まで入力できます。

注:

  • [データフォーマット] パラメータに HTML を指定した場合は、テキスト文字列内で HTML タグを使用する必要があります。
  • 文字列を変更すると、書き込みや追記が行われます。

追記

データをファイルに出力する方法を指定します。

0 = OFF | ファイル内の既存のデータを上書きします。
1 = ON (デフォルト) | ファイルの最後にテキスト文字列を追記します。

WriteLocalの出力

戻り値

スプレッドシートが更新されたときにはいつでも、[文字列] パラメータに含まれているデータ文字列を In-Sight ビジョンシステムに取り付けられている SD カードのファイルに書き込む [image] データ構造体。

いずれかのパラメータが無効な場合、SD カードが取り付けられていないかいっぱいになっている場合、または SD カードが取り付けられていても適正にフォーマットされていない場合は、#ERR が返されます。

WriteLocal例

WriteLocal($A$0,"InSight",0,"Test String",1)

画像を取り込んだ後にスプレッドシートが更新された場合にはいつでも、上記の式によって、In-Sight ビジョンシステムに取り付けられている SD カードに txt ファイルが書き込まれます。テキストファイル内に、"Test String" というテキストメッセージが書き込まれます。

関連項目

  • WriteImageLocal
  • 入出力関数について


スプレッドシートのセルの実行と参照の編集

ユーザインタフェース

In-Sight Explorer GUI リファレンス

スプレッドシートは、セルのブロック操作、セルの編集、セルの参照、関数の挿入などの標準の操作と機能はほかのスプレッドシートアプリケーションに似ています。スプレッドシートは、400 行 (0 ～ 399) と 26 列 (A ～ Z) に配列されたセルのテーブルで編成され、個々のセルは、列文字と行番号によって識別されます。例えば、セル A2 は A 列と 2 行が交差する場所です。

スプレッドシートは、一度に 1 つのセルが設定されます。各セルのコンテンツは数式として定義され、セルに挿入された情報は、単一の数値であっても、複雑なビジョン処理関数であっても、数式の一部とみなされます。セルをハイライトすると、セルが黒い枠で囲まれ、セル内の情報が [ジョブの編集] ツールバーの数式バーに表示されます。セルをクリックすると、そのセルが自動的にアクティブセルになります。

注: スプレッドシートを右クリックすると、ショートカットメニューが表示され、さまざまなスプレッドシート操作を実行することができます。

  • セルの実行順序
  • スプレッドシートへの情報の入力
  • スプレッドシートセルの編集
  • 関連項目

セルの実行順序

ほかのほとんどの標準スプレッドシートと同じように、In-Sight スプレッドシートのセルの実行順序はセルの関数間の関連性と依存関係に基づいて動的に決定されます。In-Sight スプレッドシートでは、第一に依存関係に基づいたセルの評価、第二にスプレッドシート内におけるセルの位置によってセルの実行順序が決定されます。

  • セルの依存関係
  • セルの実行順序
  • セルの実行順序の例外
  • 実行がトリガされる条件

セルの依存関係

次の例では、セル B2 および A3 の値が A2 の値に直接依存しています。セル A4 は A3 を参照するため、A2 に間接的に依存します。A2 の値が変更されると、B2 および A3 の値に引き続き、A4 の値も再評価される必要があります。内部実行ツリーが自動的に作成され、セルの依存関係が追跡されます。このツリーはシステムがオフラインのときに、スプレッドシートが変更されるたびに再構築されます。

例 1: シンプルな依存関係ツリー

A2 = 1

A3 = A2+1

A4 = A3+1

B2 = A2+2

[ジョブのプロファイル] ダイアログで、この例の実行ツリーを確認できます。

セルの値または数式が変更されると、In-Sight スプレッドシートはツリー内のセルを特定し、再評価する必要のあるセルを決定します。この例では、A2 の値が変更された場合、依存するすべてのセル (B2、A3、および A4) を再評価する必要があります。ただし、セル B2 の数式が変更された場合、B2 に依存するセルはないため、ほかのセルを更新する必要はありません。

セルの実行順序

依存関係が評価されると、セルはスプレッドシート内のそれぞれの位置によって評価されます。セルは行座標で (左から右に) ソートされ、次に列座標で (上から下に) ソートされます。前述の例では、セル A2 が最初に実行され、次にセル B2、A3、A4 の順に実行されます。同じ行に 2 つのセルが存在する場合、最も左側にあるセルが最初に実行されます。

プロファイラで、セル A2 が最初に実行され、次にセル B2、A3、そして最後に A4 が実行されることを確認できます。

セルの実行順序の例外

通常のセルの実行順序における例外を以下に示します。

  • ReadResult および WriteResult 関数
  • クロックド関数
  • 依存関係のないセル参照の関数

ReadResult および WriteResult 関数は、スプレッドシート内の位置にかかわらず、実行ツリーの最下部近くに配置されます。ReadResult はスレーブの WriteResult から返されるデータを待機するため、データを待機して時間を無駄にすることのないように、この関数はジョブの最後に実行されます。WriteResult も、システムで次のトリガを取得する準備ができている状態にするため、ジョブの終盤に実行されます。

実行ツリーで、クロックド関数はほかのセルの古いデータにアクセスする必要があるため、ツリーの最上部に常に配置されます。

一部の関数はセル参照を引数として受け取りますが、依存関係を確立しません。参照されたセルの行座標を返す Row 関数は、そのような関数の 1 つです。例えば、Row(A4) は、A4 の値が変わった場合でも、常に 4 を返します。

例 3: 実行順序の例外

次の ReadResult 関数が例 1 のスプレッドシートに追加されました。

A1 = ReadResult($A$0,"SYSTEM1",1000)

プロファイラで、セル A1 はスプレッドシートの上部にあるにもかかわらず、実行ツリーの最後にあることが確認できます。

次に、クロックドデータ関数が追加されます。

A5 = Accumulate($A$0,0,0,0)

セル A5 はデータが含まれるほかのセルよりも下にあるにもかかわらず、実行ツリーの最上部にあることに注意してください。

実行がトリガされる条件

セルは次の場合に実行されます。

  • 依存関係があるセルが変更された場合。
  • AcquireImage トリガ、シリアルデータ、および TCPDevice への受信パケットなど、外部イベントが発生した場合。
  • オペレータ I/F (ボタン、チェックボックス、EditInt など) がスプレッドシートイベントトリガの信号を発した場合。

ほとんどのビジョンツール関数は、セル A0 の AcquireImage 関数に直接または間接的に依存します。新しい画像が取り込まれるたびに、これらの関数が実行され、新しい値を返します。また、画像の取り込み、またはほかのスプレッドシートイベントがトリガされると、スプレッドシートは更新されます。

スプレッドシートへの情報の入力

マシンビジョンアプリケーションは、数式を組み立てて、それをスプレッドシートのセルに挿入することによって設定されます。数式には、数値、テキスト、別のセルへの絶対参照または相対参照、あるいは特定のパラメータがある関数の 4 種類のデータを含めることができます。

  • セルに数値を挿入する
  • セルにテキストを挿入する
  • セルにセル参照を挿入する
  • セルに関数を挿入する

注: In-Sight のスプレッドシートは、最大 4,096 のアクティブセルを含むことができます。それ自身が複数のビジョンデータアクセス関数を挿入する関数 (FindBlobs など) をスプレッドシートに挿入すると、スプレッドシートが制限を超えようとすることがあります。この場合、警告ダイアログは表示されませんが、4,096 の制限を超えるセルは挿入されません。

セルに数値を挿入する

空白のセルを選択して、数値 (例えば、26) を入力します。

セルにテキストを挿入する

空白のセルを選択して、アポストロフィ (') キーを押します。先頭にアポストロフィの付いたテキストは、数式ではなくテキストラベルとしてアクティブセルに挿入されます。

セルにセル参照を挿入する

セルにセル参照を挿入するには、4 つの異なる方法があります。

  • 空白のセルをダブルクリックした後、参照先のセルをクリックします (これは相対参照を生成します。絶対参照を生成するには、Shift キーを押しながらクリックします)。

  • 空白のセルを選択した後、手動で参照先のセル名を入力します (これは相対参照を生成します。絶対参照を生成するには、文字と数字の前に $ 記号を入力します [例: $C$3])。

  • 空白のセルを選択した後、Ctrl+Shift+A または Ctrl+Shift+R キーを押すと、それぞれ絶対または相対セル参照が挿入されて、セル選択モードになります。
  • 空白のセルを選択した後、[ジョブの編集] ツールバーの [絶対参照] [image] または [相対参照] [image] ボタンをクリックして、セル選択モードに切り替えます。

セルに関数を挿入する

セルに関数を挿入するには、6 つの異なる方法があります。

  • パレットから空白のセルに関数をドラッグします。関連するプロパティシートが関数にある場合には、プロパティシートが自動的に開きます。
  • 空白のセルを選択し、[パレット] 内の関数をダブルクリックします。関連するプロパティシートが関数にある場合には、プロパティシートが自動的に開きます。
  • 空白のセルを選択し、[ジョブの編集] ツールバーの [式] [image] ボタンをクリックします。[関数の挿入] ダイアログが開きます。
  • 空白のセルを選択し、Enter キーまたは等号キーを押します。次に、↑または↓キーを押します。関数ボックスが表示され、関数を入力または選択することができます。Tab キーまたは Enter キーを押して、関数ボックスを閉じます。

  • 空白のセルを選択し、手動で関数の名前を入力して、Enter キーを押すか、または手動で左括弧を入力します。関連するプロパティシートが関数にある場合には、プロパティシートが自動的に開きます。

  • 空白のセルを選択し、数式バーに手動で関数の名前を入力して、Enter キーを押すか、または手動で左括弧を入力します。関連するプロパティシートが関数にある場合には、プロパティシートが自動的に開きます。

注: 可変長の引数リストを持つ関数 (Wizard や WriteEIP など) には、プロパティシートがありません。

数式の確定またはキャンセル

新しい数式または値を確定するには、次のいずれかを実行します。

  • Enter キーを押します。
  • [ジョブの編集] ツールバーの [OK] [image] ボタンをクリックします。

新しい数式または値をキャンセルし、前の式に戻すには、次のいずれかを実行します。

  • Esc キーを押します。
  • [ジョブの編集] ツールバーの [キャンセル] [image] ボタンをクリックします。

テキストが赤色でハイライトされている場合は、修正しないと確定できないエラーが数式に含まれています。

ツールチップとヘルプ情報

ツールチップは、スプレッドシートと数式バーの両方で使用できます。シンタックスを参照するには、関数の括弧内をクリックしてください。

ヒント: カーソルが関数の括弧内にあるときに F1 キーを押すと、その関数の外部ヘルプ項目が表示されます。

数式バーの使用

数式バーは、[ジョブの編集] ツールバーに含まれています。数式バーには、次の 3 つの情報が表示されます。

  • アクティブセル (E4)
  • アクティブセルに含まれている数式または値 (442)
  • アクティブセルのセル状態情報 (if $A$4)

数式バー内をクリックして必要な変更を加えるだけで、アクティブセル内の数式、値、またはラベルを直接編集できます。関数の括弧内をクリックすると、ツールチップが表示され、シンタックスを確認できます。

スプレッドシートセルの編集

個々のセルに含まれる数式を編集するだけでなく、セルを切り取り、コピー、貼り付け、または削除したり、セルのフォーマットを調整したりできます。

注:
  • スプレッドシートを右クリックすると、ショートカットメニューが表示され、さまざまなスプレッドシート操作を実行することができます。
  • カット & ペースト操作時にエラーが発生した場合、また操作を停止するために [キャンセル] ボタンを押した場合も、切り取ったセルの内容が失われることがあります。この場合は、[元に戻す] (Ctrl+Z) を使用すると、切り取ったセルの内容が復元されます。

数値およびテキストの編集

Enter キーまたは等号キーを押して、アクティブセルの数値またはテキストを編集します。数値またはテキストに単純に上書きすることもできますが、この方法では、前の数値またはテキストが消去されます。

セル参照の編集

セル参照を変更する場合は、セル参照を挿入する場合と同じ手順で変更してください。

関数の編集

関数はプロパティシート (使用可能な場合) またはスプレッドシートで編集できます。

  • 関数にプロパティシートが関連付けられている場合、アクティブセルで Enter キーまたは等号キーを押すと、自動的に関数のプロパティシートが開きます。
  • F2 キーを押すと、プロパティシートではなく、アクティブセルで関数を編集することができます。

↑または↓キーを押すと、数式の下に関数ボックスが表示されます。数式内のカーソルの位置を移動するには、←または→キーを使用します。

注: カーソルの位置に基づいて、数式内の特定の式に対して有効な関数だけが関数ボックスに表示されます。

別の関数を選択するには、必要な関数を入力するか、または選択します。Tab キーまたは Enter キーを押して、関数ボックスを閉じます。

関連項目

  • セル選択モード
  • セル参照 - 相対/絶対
  • [セル状態] ダイアログ
  • [プロファイラ] ダイアログ


メニューバー

グラフィカルユーザインタフェース

In-Sight Explorer GUI リファレンス

EasyBuilder ビュー

スプレッドシートビュー

EasyBuilder ビュー

注意:EasyBuilder ビューがアクティブでないとき、このメニューの一部またはすべてが利用できない場合があります。

メニューバーは、次のメニューで構成されています。

  • [ファイル] メニュー:新しいジョブを作成したり、ジョブまたは画像を開いたり、保存したりすることができます。印刷前にジョブの結果テーブルをプレビューし、結果テーブルを印刷し、EasyBuilder を終了します。
  • [編集] メニュー:操作の取り消し、やり直し、また選択したツールのグラフィックスに対する編集操作の実行、領域の最大化を行います。
  • [表示] メニュー:次の項目の表示/非表示を切り替えて、EasyBuilder の GUI をカスタマイズします。[In-Sight のネットワーク] ペイン、[In-Sight のファイル] ペイン、パレット、ツールバー、フィルムストリップ。使用可能な EasyBuilder のアプリケーションステップへに移動したり、スプレッドシートビューに切り替えたりすることもできます。
  • [画像] メニュー:新しい画像の取り込み、ライブビデオ画像の表示、画像の記録と再生、画像の表示倍率の調整、画像の回転、および画像の露光過多・過少ピクセルのハイライトのオン/オフを行います。
  • [センサ] メニュー:アクティブな In-Sight ビジョンシステムのオンライン状態を切り替えます。アクティブな In-Sight ビジョンシステムの設定を構成します。これには、ネットワーク設定、日付と時刻の設定、ホストテーブルの設定、FTP 設定、外部照明の設定、表示画像の設定、および画像バッファ設定が含まれます。また、TestRun テストの設定と実行、ビジョンシステムのメモリ割り当ての設定、セル保護ライセンスの管理、ビジョンシステムのリセットを行うこともできます。
  • [システム] メニュー:EasyBuilder にログオンまたはログオフします。レポートの作成、ファイルのバックアップ、ファイルのリストア、クローン、ファームウェアの更新など、1つ以上の In-Sight ビジョンシステムに対してファイル操作を実行します。[センサ/デバイスをネットワークに追加] ダイアログを使用して、TCP/IP ネットワーク上で通信するように、または PC と直接通信するように、新規または既存の In-Sight ビジョンシステムまたはデバイスを設定できます。セキュリティレベルを設定したり、サブネット上のほかのデバイスと通信したり、現在のジョブレイアウトを保存したり、EasyBuilder GUI のオプション設定を行ったりします。
  • [ウィンドウ] メニュー:EasyBuilder ビュー、スプレッドシートビュー、センサのステータスビューを表示します。画面上のビューの表示レイアウトを設定し、複数のビューが同時に表示されるように並べて表示したり、重ねて表示したりします。
  • [ヘルプ] メニュー:EasyBuilder のバージョンやビルド情報の表示、およびオンラインヘルプ、In-Sight のサポートサイト、In-Sight ソフトウェアのリリースノートへのアクセスを提供します。

スプレッドシートビュー

注意:スプレッドシートビューがアクティブでないとき、このメニューの一部またはすべてが利用できない場合があります。

メニューバーは、次のメニューで構成されています。

  • [ファイル] メニュー:新しいジョブを開始したり、ジョブまたは画像を開いたり、保存したりします。また、セルデータをスプレッドシートにインポートしたり、スプレッドシートからエクスポートしたりすることができます。ジョブの保護、印刷前のジョブのプレビュー、ジョブの印刷、In-Sight Explorer の終了を行います。
  • [編集] メニュー:操作を取り消したり、やり直したりします。スプレッドシートのセルに対してブロック編集操作を実行したり、スプレッドシートの要素を消去します。スプレッドシートの検索、または特定のジョブのセクションへ直接移動します。セルの状態を設定し、対話型グラフィックスを操作したり、領域を最大化します。カスタムビューを設定したり、または既存のカスタムビュー設定を変更したりします。EasyView のカスタマイズ、または既存の EasyView 設定の変更を行います。
  • [表示] メニュー:次の項目の表示/非表示を切り替えて、In-Sight Explorer の GUI をカスタマイズします。[In-Sight のネットワーク] ペイン、[In-Sight のファイル] ペイン、パレット、ツールバー、フィルムストリップ、カスタムビュー、スプレッドシートオーバレイ、スプレッドシートの関数に関連付けられているオーバーレイグラフィックス。また、スプレッドシートの表示倍率を増減したり、ジョブ内のセルの依存関係をトレースすることもできます。
  • [挿入] メニュー:スプレッドシートのセルに、ビジョンツール、数式、数値、絶対または相対参照、コメントなどのオブジェクトを配置します。スプレッドシートに空白のセル、行、列を挿入したり、シンボリックタグを配置したりします。
  • [フォーマット] メニュー:セルのフォーマット、行および列パラメータ (高さ、幅、表示/非表示など) を設定します。
  • [画像] メニュー:新しい画像の取り込み、ライブビデオ画像の表示、画像の記録と再生、画像の表示倍率の調整、画像の回転、および画像の露光過多・過少ピクセルのハイライトのオン/オフ、スプレッドシートオーバレイの透明度の調整を行います。
  • [センサ] メニュー:アクティブな In-Sight ビジョンシステムのオンライン状態を切り替えます。アクティブな In-Sight ビジョンシステムの設定を構成します。これには、ネットワーク設定、日付と時刻の設定、ホストテーブルの設定、FTP 設定、シリアルポート設定、CC-Link の設定、ディスクリート I/O の設定、外部照明の設定、監査メッセージの設定、ラインスキャンの設定、スタートアップ設定、ユーザアクセス設定、 表示画像の設定、画像バッファの設定、センサフィルムストリップの設定、RAM ディスクフォルダの設定、アクティブセル制限の設定、およびジョブの成功/失敗設定が含まれます。また、スプレッドシートのセルの処理時間のプロファイル、TestRun テストの設定および実行、Dialog 関数での [キャンセル] ボタンの設定、セル保護ライセンスの管理、およびビジョンシステムのリセットも行えます。
  • [システム] メニュー:In-Sight Explorer にログオンまたはログオフします。レポートの作成、ファイルのバックアップ、ファイルのリストア、クローン、ファームウェアの更新など、1つ以上の In-Sight ビジョンシステムに対してファイル操作を実行します。[センサ/デバイスをネットワークに追加] ダイアログを使用して、TCP/IP ネットワーク上で通信するように、新規または既存の In-Sight ビジョンシステムを設定できます。セキュリティレベルを設定したり、サブネット上のほかのデバイスと通信したり、現在のスプレッドシートのレイアウトを保存したり、In-Sight Explorer GUI のオプション設定を行ったりします。ジョブの全体的な成功/失敗を決定するセルを選択し、モニタします。これは VisionView などのほかのアプリケーションへの入力として使用できます。
  • [ウィンドウ] メニュー:EasyBuilder ビュー、スプレッドシートビュー、またはセンサのステータスビューを表示します。画面上の In-Sight ビューの表示レイアウトを設定し、複数の In-Sight ビジョンシステムが同時に表示されるように並べて表示したり、重ねて表示したりします。
  • [ヘルプ] メニュー:In-Sight Explorer のバージョンやビルド情報の表示、およびオンラインヘルプ、In-Sight のサポートサイト、In-Sight ソフトウェアのリリースノートへのアクセスを提供します。