Establecer conexión

Bienvenido a EasyBuilder®, que proporciona un método paso a paso para la creación de aplicaciones o tareas de visión artificial. El paso Establecer conexión se utiliza para conectar con sistemas de visión In-Sight, sensores de visión In-Sight y/o emuladores, así como para configurar sus ajustes, y para iniciar el proceso de construcción de la tarea.

  • Conexión a un sistema de visión In-Sight, a sensores de visión o a un emulador
  • Inicio o apertura de una tarea de EasyBuilder
Notas:
  • Mientras esté editando su tarea, guarde su trabajo periódicamente presionando CTRL+S. Si se activa la casilla de verificación Permitir guardado del trabajo en línea del diálogo Usuario, los usuarios con acceso Completo o Protegido pueden guardar tareas mientras se encuentren en línea. Si la casilla Permitir guardado del trabajo en línea está desactivada, para poder guardar tareas el sistema de visión deberá estar sin conexión.
  • En función de su nivel de acceso, de la tarea que se esté ejecutando en ese momento o de si está conectado a un sistema de visión o emulador, algún paso de la aplicación de EasyBuilder puede estar deshabilitado.

Ayuda de EasyBuilder

El archivo de ayuda de EasyBuilder está disponible en dos formatos: Ayuda de Palette y Ayuda en línea. La ayuda de EasyBuilder Palette aparece en la ficha Ayuda de la paleta. La ayuda en línea de EasyBuilder es un sistema de ayuda en formato CHM con funciones de búsqueda. Para abrir el archivo de ayuda en línea de EasyBuilder, presione la tecla F1 del teclado, haga clic en el botón Ayuda [image] de la ficha Ayuda de Palette o seleccione Ayuda de EasyBuilder en el menú Ayuda.

Notas:
  • El archivo de ayuda de EasyBuilder contiene enlaces al archivo de ayuda de In-Sight Explorer. Al hacer clic en estos enlaces del archivo de ayuda de EasyBuilder Palette, se abre el archivo de ayuda en línea de In-Sight Explorer en el tema correspondiente. Sin embargo, si se hace clic en estos enlaces del archivo de ayuda en línea de EasyBuilder, en lugar de acceder al archivo de ayuda en línea de In-Sight Explorer se abre el tema correspondiente en el mismo archivo de ayuda en línea de EasyBuilder. Para volver a los temas de ayuda de EasyBuilder, haga clic en el botón Atrás.
  • Cuando se ejecutan búsquedas desde la ficha Buscar del archivo de ayuda en línea de EasyBuilder, también se obtienen resultados del archivo de ayuda de In-Sight Explorer.


Conexión a un sensor o emulador In-Sight

El cuadro de grupo Seleccionar un sensor o emulador In-Sight enumera los sistemas, sensores y emuladores de visión In-Sight disponibles. Solo puede conectarse un sistema/sensor o emulador de visión a la vez; la información del sistema/sensor de visión (nombre, modelo, etc.) se mostrará en el cuadro de grupo Información del sensor.

Si no está conectado al sistema/sensor o emulador de visión pertinente de la lista, realice una de las siguientes acciones:

  • Haga doble clic en el sistema/sensor o emulador de visión pertinente de la lista.
  • Seleccione el sistema/sensor o emulador de visión pertinente de la lista y haga clic en el botón Conectar.

Haga clic en el botón Desconectar si quiere interrumpir la conexión con el sensor o emulador al que está conectado.

El panel de ajustes contiene otros controles para:

  • Agregar un sensor a la lista
  • Cambiar el modo de emulador local
Notas:
  • Si otro usuario ya ha iniciado sesión en el sistema, sensor o emulador de visión en cuestión, aparecerá un mensaje de advertencia. Haga clic en Sí para desconectar al otro usuario del sistema de destino y continuar con el proceso de inicio de sesión. Haga clic en No para cancelar el intento de inicio de sesión y volver a EasyBuilder.
  • Si no está autorizado para conectarse al sistema, sensor o emulador de visión en cuestión, aparecerá el cuadro de diálogo Iniciar/cerrar sesión.
  • Si tienen dificultades para conectarse al sistema/sensor de visión y a la red, puede que el problema sea su tarjeta de red.
  • Al conectarse a sistemas/sensores de visión In-Sight, la disponibilidad de determinadas herramientas de ubicación e inspección se basa en el tipo de modelo.


Conexión a un sensor que no aparece en la lista

Si el sensor deseado está conectado físicamente a la red local pero no aparece en la lista, haga clic en el botón Actualizar o Agregar, dependiendo de los ajustes de red del sensor.

  • El botón Actualizar actualiza la lista para que muestre todos los sensores In-Sight conectados a la subred local. Los ajustes de red de estos sensores son compatibles con la subred, lo que permite comunicarse con ellos.
  • El botón Agregarabre el cuadro de diálogo Agregar sensor/dispositivo a la red, que permite a los usuarios con acceso "completo" reconfigurar los ajustes de red de los sensores de la red local incompatibles con la subred local. Una vez corregida su configuración, los sensores se agregan automáticamente a la subred y están listos para comunicarse con ellos.

Si el sensor deseado se encuentra en otra subred, abra el menú Sistema y seleccione Tabla de equipos de Explorer para abrir el cuadro de diálogo Configuración de la tabla de equipos de Explorer.


Cambio del modo de emulador local

  1. En el cuadro de grupo Seleccionar un sensor o emulador In-Sight seleccione el emulador deseado de la lista haciendo clic sobre él.
  2. Pulse el botón Emulador para abrir el diálogo Opciones del emulador, que incluye todos los sistemas de visión In-Sight compatibles y las herramientas que están disponibles en esos sensores.
  3. Seleccione el modelo del sensor In-Sight que se emulará desde la lista desplegable Modelo. La opción Estándar está seleccionada de forma predeterminada. Estándar proporciona la funcionalidad central que se encuentra en la mayoría de los sensores de visión In-Sight, con una resolución de imagen de 640 x 480.
  4. Después de efectuar su selección, haga clic en el botón Aceptar para cambiar su ajuste de emulación.

Nota: Después de hacer clic en el botón Aceptar hay una retardo debido a que EasyBuilder se desconecta del emulador anterior e inicia el nuevo emulador.


Inicio o apertura de una tarea de EasyBuilder

Closed Inicio de una tarea nueva:
  1. Asegúrese de que el sistema de visión no esté en línea.
  2. Haga clic en el botón Nueva tarea del cuadro de grupo Cargar tarea o presione las teclas CTRL+N; los dos métodos abren el cuadro de diálogo Nueva tarea.
  3. En el cuadro de diálogo Nueva tarea, haga clic en Sí para borrar todos los datos de la tarea actual. (Si desea guardar los datos, haga clic en No en el cuadro de diálogo, presione las teclas CTRL+S y complete el proceso de "guardar" antes de iniciar una tarea nueva).

El nombre de la tarea nueva no se mostrará en el campo Tarea actual: del cuadro de grupo Información del sensor hasta que no se guarde y asigne nombre a la tarea.

Closed Apertura de una tarea actual:
  1. Asegúrese de que el sistema de visión no esté en línea.
  2. Haga clic en el botón Nueva tarea del cuadro de grupo Cargar tarea o presione las teclas CTRL+O; los dos métodos abren el cuadro de diálogo Abrir.
  3. En este cuadro de diálogo, vaya a la tarea.
  4. Haga doble clic en la tarea o selecciónela y haga clic en Abrir.
  5. Aparece el cuadro de diálogo Cargar archivo; en él haga clic en Sí para borrar todos los datos de la tarea actual. (Si desea guardar los datos, haga clic en No en el cuadro de diálogo, presione las teclas CTRL+S y complete el proceso de "guardar" antes de abrir una tarea).

En el campo Tarea actual, se muestra el nombre de la tarea que se ha abierto.

Notas:
  • Los archivos de tarea creados en los sensores de visión In-Sight de la serie 2000 no son compatibles con los creados en ningún otro modelo de In-Sight.
  • Un sistema de visión "Solo EasyBuilder" no puede abrir tareas de EasyBuilder que se hayan editado en la vista de hoja de cálculo.
  • EasyBuilder no puede modificar tareas creadas en la vista de hoja de cálculo de In-Sight Explorer. Si se abre una tarea de hoja de cálculo, los pasos de la aplicación restantes quedan desactivados. No obstante, puede trabajar con la tarea en el entorno de In-Sight Explorer si hace clic en Hoja de cálculo del menú Vista de EasyBuilder.
  • Si se creó una tarea de EasyBuilder usando el firmware 4.7.3 o anterior de In-Sight y esta se ha cargado en un sistema de visión que utilice el firmware 5.x.x, puede que se supriman las etiquetas simbólicas (etiquetas de EasyBuilder) de la tarea.


Configurar imagen

El paso Configurar imagen se utiliza para adquirir o cargar una imagen, establecer los ajustes de adquisición del sensor In-Sight y, si su aplicación requiere resultados en unidades del mundo real, por ejemplo, milímetros o pulgadas, puede calibrar las coordenadas de píxeles de la imagen.

  • Adquisición o carga de una imagen
  • Adaptación de los ajustes de adquisición

  • Calibración de la imagen en unidades del mundo real (sistemas de visión In-Sight)

    Nota: En este tema se describe la función de calibración cuando se conecta a un sistema de visión In-Sight. Si se conecta a un sensor de visión In-Sight 2000-130/130C o 2000-23M, consulte la sección Campo de visión (anchura) de Ajustes de imagen.


Adquisición o carga de una imagen

El cuadro de grupo Adquirir/cargar imagen permite adquirir al instante una imagen del sensor de visión, mostrar vídeo en directo desde el sensor de visión o cargar imágenes adquiridas con anterioridad desde un PC.

Sensores de visión In-Sight de la serie 2000

  • Adquisición o carga de una imagen

Sistemas de visión In-Sight

  • Adquisición o carga de una imagen


Adquisición o carga de una imagen

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a sistemas de visión In-Sight, consulte Adquisición o carga de una imagen.

Closed Disparador

El botón Disparador se utiliza para adquirir una sola imagen del sensor de visión. Haga clic en el botón Disparador para adquirir una sola imagen. Alternativamente, puede usar la tecla F5 del teclado o hacer clic en el botón [image] de la barra de herramientas de EasyBuilder (Disparador debe haberse establecido en Manual).

Closed Vídeo en vivo

El botón Vídeo en vivo activa el sensor de visión para que transmita imágenes, lo que permite ajustar el foco de la lente conectada al sensor de visión, así como ajustar la apertura de la lente para conseguir el brillo óptimo de la imagen. Su aplicación funcionará de forma óptima cuando sus imágenes estén claramente enfocadas y la luminosidad esté equilibrada para maximizar el contraste.

Notas:
  • Alternativamente, puede acceder al modo de vídeo en directo seleccionando Vídeo en vivo en el menú Imagen o haciendo clic en el botón [image] de la barra de herramientas de EasyBuilder. Estas opciones de vídeo en directo están disponibles en todos los pasos de la aplicación.
  • Puede configurar los ajustes de Exposición manual/automática, Exposición (ms), Exposición óptima, Modo de control de luz y Modo de magnificación de imagen mientras está en el modo de vídeo en vivo.

La métrica de enfoque proporcionada bajo la imagen le ayuda a determinar una puntuación de enfoque de imagen, la cual indica hasta qué punto la imagen, o una región de la imagen, incluye las características resolubles mínimas en una "escena".

Notas:

  • Si se encuentra conectado al sensor de visión de la serie In-Sight 2000, los valores de métrica de enfoque Mínimo, Máximo y Enfoque estarán ocultos.
  • La métrica de enfoque se puede desactivar haciendo clic en el icono Métrica del foco [image] de la barra de herramientas de EasyBuilder en el modo de vídeo en vivo. Alternativamente, puede seleccionar Métrica del foco en el menú Ver.
Closed Ajuste del enfoque
  1. Haga clic en el botón Vídeo en vivo. Alternativamente, puede hacer clic en el botón [image] de la barra de herramientas de EasyBuilder.

Nota: El sensor de visión debe estar sin conexión.

  2. Si utiliza el sensor de visión In-Sight de la serie 2000 Mini, puede enfocar la lente automáticamente mediante el botón de autoenfoque. De manera alternativa, puede ajustar el enfoque manualmente mediante el control deslizante Distancia de enfoque (%), de modo que los detalles de las características a inspeccionar sean claros y estén muy contrastados.
  3. Si utiliza otro sensor de visión de la serie In-Sight 2000, ajuste manualmente el módulo de luz conectado al sensor de visión para que los detalles de las características sean claros y estén muy contrastados.
  4. Cuando esté satisfecho con la calidad de la imagen, vuelva a hacer clic en el botón Vídeo en vivo.
Closed Ajuste de la luminosidad
  1. Haga clic en el botón Vídeo en vivo. Alternativamente, puede hacer clic en el botón [image] de la barra de herramientas de EasyBuilder.

  2. En la barra de herramientas de EasyBuilder, haga clic en Mostrar Informacion de brillo para activarlos. Las áreas de la imagen que son demasiado oscuras se resaltan en azul, mientras que las áreas de la imagen resaltadas en rojo están demasiado saturadas (demasiado claras).

    Nota: Alternativamente, puede seleccionar Mostrar información de brillo en el menú Imagen para habilitar los comentarios sobre el brillo.

  3. Puede ajustar la luminosidad de la imagen con uno de los métodos siguientes:
  • Ajuste manualmente la apertura de la lente conectada al sensor de visión hasta que las áreas rojas y azules queden reducidas al mínimo.
  • Ajuste el control deslizante Exposición hasta que las áreas rojas y azules queden reducidas al mínimo. Para obtener más información, consulte Exposición.
  • Seleccione Exposición automática. Para obtener más información, consulte Exposición automática.

  4. Cuando esté satisfecho con la calidad de la imagen, vuelva a hacer clic en el icono Mostrar Informacion de brillo [image] para desactivar la visualización.

    Nota: Alternativamente, puede seleccionar Mostrar información de brillo en el menú Imagen para desactivar los comentarios sobre el brillo.

Closed Cargar imágenes desde un PC

El botón Cargar imágenes desde PC abre el cuadro de diálogo Opciones de grabación/reproducción, que se utiliza para configurar los ajustes de grabación y reproducción de los sensores de visión y emuladores. Después de configurar los ajustes del diálogo, puede grabar las imágenes adquiridas en la carpeta de grabación y reproducir las imágenes adquiridas guardadas en la carpeta de reproducción del PC.

Notas:
  • Para la supervisión y la depuración en tiempo de ejecución, puede almacenar las imágenes en el sensor de visión en lugar de en el PC; utilice el paso Aplicación de película para configurar los ajustes de sensores.
  • Al grabar imágenes en color en el PC, se guardan como imágenes de 16 bits, no de 24 bits. Si necesita utilizar las imágenes en color para comprobar herramientas de colores, puede exportarlas a través de FTP (agregando un dispositivo FTP en el paso de aplicación Comunicación) para guardar las imágenes con toda la profundidad de colores.
Closed Ficha Reproducir

Una vez configurados los ajustes de la ficha Reproducción, cuando haga clic en el botón Reproducir (en la película PC), se enviarán las imágenes almacenadas en la carpeta de reproducción del PC al sensor de visión y la tarea se ejecutará en relación con la imagen que se esté reproduciendo. De forma predeterminada, la carpeta de reproducción se refiere a la carpeta de tareas de ejemplo de EasyBuilder.

Closed Ficha Grabar

Una vez configurados los ajustes de la ficha Grabación, cuando haga clic en el botón Grabar (de la barra de herramientas de EasyBuilder) y se adquieran las imágenes, las imágenes de aceptación y rechazo se grabarán y guardarán en la carpeta de grabación del PC. Puede guardar las imágenes desde un sensor de visión con o sin conexión a cualquier carpeta que tenga privilegios de “escritura”. En el PC se pueden guardar hasta 10.000 imágenes.


Adquisición o carga de una imagen

El cuadro de grupo Adquirir/Cargar imagen le permite adquirir de forma instantánea una imagen a partir del sistema de visión, visualizar un vídeo en directo desde el sistema de visión o cargar imágenes que se han adquirido previamente desde un PC.

Closed Disparador

El botón Disparador se utiliza para adquirir una única imagen del sistema de visión. Pulse el botón Disparador para adquirir una única imagen. De manera alternativa, puede utilizar el botón F5 de su teclado o pulsar el botón [image] de la barra de herramientas EasyBuilder (el control disparador del grupo Editar ajustes de adquisición debe configurarse como Manual).

Closed Vídeo en directo

El botón Vídeo en directo activa el sistema de visión para que transmita imágenes sin tener que adquirirlas, lo que le permite ajustar el foco de la lente conectada al sistema de visión, así como compensar la exposición y el brillo. Su aplicación funcionará óptimamente cuando sus imágenes se enfoquen de manera precisa y el brillo se equilibre para maximizar el contraste.

La métrica de enfoque proporcionada bajo la imagen le ayuda a determinar una puntuación de enfoque de imagen, la cual indica hasta qué punto la imagen, o una región de la imagen (que se define mediante el botón Región del foco), incluye las características resolubles mínimas en una "escena" (es decir, el objeto y su fondo, tal como se captura en la imagen).

Notas:
  • Para proporcionar datos relevantes, la puntuación de métrica de enfoque se debe comparar con otra puntuación de métrica de enfoque de exactamente la misma escena (las escenas serán idénticas).
  • La métrica de enfoque puede desactivarse pulsando el icono Métrica de enfoque [image], en la barra de herramientas EasyBuilder, si está en modo Vídeo en directo.
Closed Ajuste del enfoque
Closed Sistemas de visión In-Sight serie 5000 , In-Sight serie Micro, In-Sight serie 7000 e In-Sight serie 8000 con lente de montura C
  1. Pulse el botón Vídeo en directo. De manera alternativa, pulse el botón [image] de la barra de herramientas EasyBuilder.

Nota: El sistema de visión debe estar sin conexión.

  2. Ajuste manualmente el anillo de enfoque de la lente conectada al sistema de visión de forma que los detalles de las características a inspeccionar sean claros y estén muy contrastados y que la puntuación de la métrica de enfoque sea aceptable.
  3. Una vez esté satisfecho con la calidad de su imagen y su puntuación, pulse de nuevo el botón Vídeo en directo.
  4. Se mostrará la última imagen que se haya adquirido después de pulsar el botón Vídeo en directo.
Closed Sistemas de visión In-Sight de la serie 7000 con lente M12 de autoenfoque.

Nota: Para los sistemas de visión In-Sight de las series 70xx - 74xx, los Controles de enfoque solo están disponibles para los sistemas de visión que se ejecuten en In-Sight Explorer 4.7.3 o versiones posteriores y en el firmware In-Sight 4.7.3 o versiones posteriores.

  1. Pulse el botón Vídeo en directo. De manera alternativa, pulse el botón [image] de la barra de herramientas EasyBuilder.

Nota: El sistema de visión debe estar sin conexión.

  2. Pulse el botón Autoenfoque o ajuste manualmente el control deslizante para la posición de enfoque de forma que los detalles de las características a inspeccionar sean claros y estén muy contrastados y que la puntuación de la métrica de enfoque sea aceptable.

Nota: Cuando se pulsa el botón Autoenfoque, se deshabilitarán el control deslizante para la posición de enfoque y el botón Guardar enfoque.

  3. Después de pulsar el botón Autoenfoque, se actualizará el valor de la posición de enfoque y aparecerá una nueva imagen.
  4. Una vez esté satisfecho con la calidad de su imagen y su puntuación, pulse el botón Guardar enfoque. Se guardará la posición actual del enfoque como posición de enfoque predeterminada. La lente se moverá automáticamente a dicha posición la próxima vez que se active el sistema de visión.
Closed Ajuste del brillo
  1. Pulse el botón Vídeo en directo. De manera alternativa, pulse el botón [image] de la barra de herramientas EasyBuilder.
  2. Desde la barra de herramientas EasyBuilder, pulse Comentarios sobre el brillo. Las áreas de la imagen que sean demasiado oscuras se resaltan en azul, mientras que las áreas de la imagen resaltadas en rojo tienen demasiada luz.
  3. Puede ajustar el brillo de una imagen mediante uno de los siguientes métodos:
  • Ajuste manualmente la apertura de la lente conectada al sistema de visión hasta que las áreas de la imagen en rojo y azul se minimicen.
  • En el cuadro de grupo Editar ajustes de adquisición, aumente el control de Exposición hasta que las áreas de la imagen en rojo y azul se minimicen.
  • En el cuadro de grupo Editar ajustes de adquisición, active el control de exposición automático del sistema de visión seleccionando Disparo continuo o Disparo único desde el menú desplegable Autoexposición. Disparo continuo activa el ajuste automático de la exposición del sistema de visión en función de las condiciones de iluminación, para cada adquisición de imagen. Disparo único ajusta la exposición del sistema de visión basándose en la primera adquisición de imagen; los ajustes de exposición se mantendrán para todas las adquisiciones subsiguientes.
  4. Una vez esté satisfecho con la calidad de su imagen, pulse de nuevo el botón Comentarios sobre el brillo [image] para desactivar la visualización.
Closed Carga de imágenes desde un PC

El botón Cargar imágenes desde un PC inicia el cuadro de diálogo Opciones de grabación/reproducción, que se utiliza para configurar los ajustes de grabación y reproducción en sistemas de visión y emuladores individuales. Tras configurar los ajustes del cuadro de diálogo, puede grabar imágenes adquiridas en la Carpeta de grabación y volver a reproducir las imágenes adquiridas almacenadas en la Carpeta de reproducción, que se encuentra en el PC.

Notas:
  • Para la supervisión y la depuración en tiempo de ejecución, las imágenes pueden almacenarse en el sistema de visión en lugar de en el PC: utilice el paso de aplicación Película para configurar los Ajustes del sensor.
  • Al grabar imágenes en color en el PC, se guardan como imágenes de 16 bits, no de 24 bits. Si necesita utilizar las imágenes en color para comprobar herramientas de colores, puede exportarlas a través de FTP (agregando un dispositivo FTP en el paso de aplicación Comunicación) para guardar las imágenes con toda la profundidad de colores.
Closed Ficha Reproducción

Una vez se han configurado los ajustes de la ficha Reproducción, cuando pulsa el botón Reproducción (en la película PC), las imágenes almacenadas en la Carpeta de reproducción del PC se envían al sistema de visión y la tarea se ejecuta a pesar de que la imagen se vuelve a reproducir. De forma predeterminada, la carpeta de reproducción hace referencia a la carpeta de tareas de ejemplo de EasyBuilder.

Nota: De forma predeterminada, la carpeta Playback se refiere a la carpeta EasyBuilder Sample Jobs. Las tareas de ejemplo de EasyBuilder demuestran claramente la utilidad de las opciones de grabación y reproducción. Con las opciones de grabación y reproducción se pueden procesar cíclicamente una serie de imágenes capturadas con anterioridad, proporcionando información instantánea sobre los resultados de la herramienta y permitiendo configurar rápidamente los umbrales y límites.

Closed Ficha Grabación

Una vez se han configurado los ajustes de la ficha Grabación, cuando pulsa el botón Grabación (en la barra de herramientas EasyBuilder) y se adquieren las imágenes, las imágenes de aceptación y rechazo se graban y se almacenan en la Carpeta de grabación del PC. Puede guardar las imágenes desde un sistema de visión con o sin conexión a cualquier carpeta que tenga privilegios de "escritura". En el PC podrá guardar hasta 10.000 imágenes.


Adaptación de los ajustes de adquisición

El paso de aplicación Configurar imagen permite ajustar los controles del disparador de adquisición, compensar la exposición y el brillo, y controlar las luces de los sistemas de visión In-Sight.

Sensores de visión In-Sight de la serie 2000

  • Ajustes de imagen

Sistemas de visión In-Sight

  • Controles de disparador
  • Controles de exposición
  • Controles de transferencia del sensor de imágenes
  • Controles de luz
  • Equilibrio de blancos
  • Región del foco
  • Controles de enfoque
  • Ajustes de luz
  • Ajustes de exploración por líneas


Ajustes de imagen

Nota: En este tema se describe la interfaz de usuario cuando se conecta a un sensor de visión In-Sight de la serie 2000. Si se conecta a sistemas de visión In-Sight, consulte la sección Sistemas de visión In-Sight de Adaptación de los ajustes de adquisición.

Disparador

Los controles del disparador Tipo, Retardo e Intervalo permiten personalizar cómo y cuándo se adquiere una imagen y se realizará la inspección.

Closed Tipo

El menú desplegable permite especificar el origen del disparador de adquisición de imágenes cuando el sensor de visión In-Sight está en línea.

Cámara | Habilita la adquisición de imágenes en un margen de aumento detectado en la entrada dedicada del disparador de adquisición del sensor.
Continuo (valor predeterminado) | Habilita la adquisición de imágenes "sobre la marcha" (tan rápidamente como sea posible).
Manual | Habilita la adquisición de imágenes al presionar F5. Nota: Puede disparar el sensor manualmente si presiona el botón DIS del sensor de visión.
Ethernet industrial | Habilita el disparo desde un protocolo Ethernet industrial, por ejemplo, EtherNet/IP, PROFINET o SLMP Scanner.
Closed Retardo (ms)

El control permite especificar un retardo en milisegundos (0 a 10.000) entre la hora en que se recibe el disparador y la hora en que el sensor de visión In-Sight inicia la adquisición. El tipo de disparo debe establecerse en Cámara.

Notas:
  • El retardo es preciso al milisegundo, más o menos el tiempo de exposición máximo de la línea, que es 64 microsegundos.
  • Si Comienzo de adquisición es el tipo de señal especificado en el paso Entradas/Salidas, las salidas se demorarán según el tiempo especificado.
Closed Intervalo (ms)

El control permite especificar un intervalo entre adquisiciones en milisegundos (0 a 10.000; el valor predeterminado es 0) cuando el control Tipo se ha establecido en Continuo.

Nota: Este retardo depende del tiempo que la tarea tarda en procesar la imagen. Por ejemplo, si el intervalo se ajusta en 500 milisegundos, el sensor de visión In-Sight adquirirá una imagen cada 500 milisegundos, siempre que la tarea finalice su tratamiento de la imagen dentro del plazo de 500 milisegundos. En caso contrario, el sensor de visión In-Sight adquirirá una imagen tan pronto como termine de procesar la imagen.

Focus (sensores de visión In-Sight 2000 con autoenfoque solamente)

La ficha Focus se utiliza para controlar la posición de enfoque de la lente en los sensores de visión compatibles con In-Sight de la serie 2000 con función de Autoenfoque, mediante el enfoque automático de la lente o el desplazamiento de la lente a una posición de enfoque específica.

Closed Región de autoenfoque

Especifica qué región de la imagen se utilizará cuando la lente se enfoque automáticamente. Pulse el botón Región de autoenfoque para configurar la región.

Closed Botón Autoenfoque

Enfoca la lente automáticamente para maximizar la nitidez de la imagen dentro de la región.

Closed Autoenfoque al cargar tarea
  • Desactivado (=predeterminado): La distancia de enfoque actual (%) se guardará con la tarea.
  • Activado: El sensor de visión enfocará la lente automáticamente cuando la tarea se cargue.
Closed Distancia de enfoque (%)

Ajusta manualmente la posición de enfoque (0 - 100 %. Valor predeterminado: lentes de 6,2 mm = 66 %, lentes de 16 mm = 69,2 %). Cuanto intente enfocar un objeto situado cerca del sensor de visión, mueva el controlador hacia la izquierda (hacia el 0 %). Cuanto intente enfocar un objeto situado lejos del sensor de visión, mueva el controlador hacia la derecha (hacia el 100 %). Puede mover el controlador independientemente del estado del modo de vídeo en vivo.

Nota: El 0 % representa el plano de enfoque más cercano posible. Por ejemplo, cuando un objeto se encuentra muy cerca del sensor de visión, verá un 0 %. El 100 % representa el plano de enfoque más alejado soportado, que es básicamente el "enfoque de infinito".

Iluminación

Nota: En determinadas circunstancias, la iluminación del sensor de visión In-Sight de la serie 2000 Mini con autoenfoque puede ser más oscura que la de otros sensores de visión In-Sight de la serie 2000.

Closed Exposición automática

Determina la exposición de forma automática después de cada adquisición. Esta opción ayuda a compensar las condiciones de iluminación no homogéneas, como reflejos de superficies metálicas brillantes, sombras variables y cambios en la iluminación del fondo. La exposición automática está desactivada de forma predeterminada.

Closed Exposición manual

Establece un valor de exposición fijo que se utilizará en cada adquisición de imagen. La exposición manual está activada de forma predeterminada. Para desactivarla, active Exposición automática.

Closed Brillo objetivo de la imagen

Permite especificar el nivel de brillo que desee (0 - 100; valor predeterminado = 50) mediante el ajuste del controlador o la introducción de un valor en el cuadro de edición correspondiente. El valor es un porcentaje de los píxeles de la región de exposición que pueden estar saturados (es decir, el blanco).

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Closed Exposición (mseg)

El control Exposición determina la duración de la exposición al adquirir una imagen (0,000 - 1000,000; valor predeterminado = 0,250). Cuanto mayor sea el valor de exposición, más clara será la imagen adquirida. Este control está desactivado si se ha seleccionado Exposición automática.

Closed Intensidad de la luz
Nota: Los sensores de visión In-Sight de la serie 2000 Mini no admite la barra de desplazamiento de intensidad de luz.

Permite especificar la intensidad real de los LED en porcentaje [(0 - 100); valor predeterminado = 70; desactivado = 0] mediante el ajuste del controlador o la introducción de un valor en el cuadro de edición correspondiente. La intensidad de la luz se guardará con la tarea.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

El fondo azul muestra el valor máximo de intensidad de la luz disponible para los ajustes actuales. El valor máximo de intensidad de la luz varía según los otros ajustes de la imagen, por ejemplo, Brillo objetivo de la imagen, Exposición, Altura del área de la imagen o Modo de magnificación de imagen.

Nota: Al pasar el ratón sobre el control deslizante se muestra el valor máximo.

Closed Botón Región de exposición (Definir región)

Define la región que se usará al calcular la exposición de forma automática.

  1. Haga clic en el botón Región de exposición.
  2. Sitúe la región alrededor del área de la imagen que utilizará el sensor para determinar la exposición automática que se va a usar para la imagen que se adquiera a continuación.
  3. Haga clic en el botón Aceptar.

Ahora, la región se calculará de forma automática según el brillo del área de la imagen dentro de la región de exposición. Por ejemplo, si el área de la imagen dentro de la región de exposición es más clara que el resto de la imagen, la imagen que se adquiera a continuación será más oscura.

Definir región de exposición | Siguiente imagen adquirida

Nota: Haga clic en Restablecer región predeterminada para restablecer el ajuste predeterminado.

Closed Exposición óptima

Optimiza el valor de exposición de forma automática. Se utilizará el mismo valor de exposición para todas las adquisiciones de imágenes posteriores.

Closed Modo de control de luz

On (Exposición) permite que la lámpara anular solo esté activada mientras dure la exposición (valor predeterminado). Si está desactivada (Off), la lámpara se apagará y el sensor dependerá de la iluminación ambiental (sala).

Equilibrio de blancos (solo sensores de visión In-Sight 2000 en color)

Closed Región de equilibrio de blancos y Establecer equilibrio de blancos

Quita las tonalidades de color de una imagen en color mediante el cálculo de los valores de rojo, verde y azul (RGB) de la imagen y la corrección de estos. Como resultado, los elementos que son blancos en el mundo real, por ejemplo, aparecerán blancos en la imagen.

Al crear una tarea nueva estará activado el equilibrio de blancos realizado más recientemente. El ajuste del equilibrio de blancos se guarda con la tarea y se restaurará cuando dicha tarea se cargue.

Notas:
  • Es necesario configurar el ajuste de equilibrio de blancos durante el uso de la exposición manual.

  • Para garantizar la reproducción más precisa del color de la imagen, se recomienda realizar el equilibrio de blancos después de haber efectuado amplios ajustes de la intensidad de la luz.

  1. Enfoque el sensor de visión In-Sight en un objeto de prueba plano, por ejemplo, una hoja de papel blanco mate, y ajuste los controles de iluminación para asegurarse de que la imagen no esté sobreexpuesta.

  2. Haga clic en Región de equilibrio de blancos e incluya una región de la imagen que solo contenga píxeles claros y ningún "punto conflictivo".

    Nota: Haga clic en Restablecer región predeterminada para restablecer e incluir toda la imagen.

  3. Haga clic en Establecer equilibrio de blancos. Todas las adquisiciones de imágenes posteriores utilizarán este ajuste.
Imagen antes del equilibrio de blancos | Equilibrio de blancos realizado | Imagen después del equilibrio de blancos

Imagen

Closed Altura del área de la imagen

Define el número de filas o líneas de imagen que deben adquirirse para reducir el tiempo de adquisición de imagen cuando la zona de interés se limita siempre a la misma franja de líneas dentro de la imagen. Puede definir los valores moviendo los controladores izquierdo (Fila inicial) derecho (Fila final) o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Modelo In-Sight | Resolución | Valor de Fila inicial | Valor de Fila final
2000-110 2000-110 Mini | 640 x 480 | 0 - 479 (valor predeterminado = 0) | 0 - 479 (valor predeterminado = 479)
2000-120 y 2000-120C 200-120 Mini y 2000-120C Mini | 640 x 480 | 0 - 479 (valor predeterminado = 0) | 0 - 479 (valor predeterminado = 479)
2000-1301 y 2000-130C1 2000-130 Mini 1 y 2000-130C Mini1 | 640 x 480 (valor predeterminado) | 0 - 479 (valor predeterminado = 0) | 0 - 479 (valor predeterminado = 479)
 | 800 x 600 | 0 - 599 (valor predeterminado = 0) | 0 - 599 (valor predeterminado = 599)
2000-23M1 | 640 x 480 | 0 - 479 (valor predeterminado = 0) | 0 - 479 (valor predeterminado = 479)
 | 800 x 600 (valor predeterminado) | 0 - 599 (valor predeterminado = 0) | 0 - 599 (valor predeterminado = 599)
1La resolución se puede configurar en el cuadro de diálogo Ajustes de imagen.
Closed Modo de magnificación de imagen

Habilita el modo de magnificación de imagen. Si se ha activado, el campo de visión (CV) se reduce en un 50 %, mientras que la resolución óptica se aumenta en un 200 %.

Modelo In-Sight | Resolución | Modo de magnificación de imagen
2000-110 2000-110 Mini | 640 x 480 | Incompatible
2000-120 y 2000-120C 2000-120 Mini y 2000-120C Mini | 640 x 480 | Se puede habilitar y deshabilitar
2000-1301 y 2000-130C1 2000-130 Mini1 y 2000-130C Mini1 | 640 x 480 (valor predeterminado) | Se puede habilitar y deshabilitar
 | 800 x 600 | Siempre habilitado
2000-23M1 | 640 x 480 | Se puede habilitar y deshabilitar
 | 800 x 600 (valor predeterminado) | Siempre habilitado
1La resolución se puede configurar en el cuadro de diálogo Ajustes de imagen.

Modo de magnificación de imagen Deshabilitada | Modo de magnificación de imagen Habilitado
Closed Tipo de calibración

Le permite convertir o calibrar las herramientas de inspección de píxeles a unidades de medida del mundo eral. Existen dos opciones: Campo de visión o Importar.

Notas:

  • La opción Campo de visión solo está disponible en los sensores de visión In-Sight 2000-130, 2000-130C, 2000-130 Mini, 2000-130C Mini y 2000-23M.
  • La opción Importar solo está disponible en el sensor de visión In-Sight 2000-23M.
Closed Campo visual

Convierte los resultados de las herramientas de medición de píxeles a unidades de medida del mundo real (milímetros, centímetros y/o pulgadas).

Campo de visión (anchura) = 640 píxeles o 125 milímetros
  1. Seleccione Campo de visión (ancho) en el menú desplegable Tipo de calibración.
  2. Seleccione la unidad de medida del mundo real que se va a usar (milímetros, centímetros y/o pulgadas) en el menú desplegable. Píxeles está seleccionado de forma predeterminada y el valor no puede cambiarse.
  3. Mida la anchura del campo de visión con la mayor precisión posible en la unidad de medida seleccionada y, a continuación, introduzca el valor medido.

  4. Se aplicará inmediatamente la conversión del resultado de la medición. Por ejemplo, si Campo de visión (anchura) tiene ajustado el valor 125 milímetros y la distancia medida entre los dos márgenes es de 490 píxeles, se devolverá 95,703 mm como resultado de la medición.

    Nota: A continuación constan la fórmula y el cálculo real utilizados en el ejemplo:
    • Campo de visión (unidades del mundo real) / Campo de visión (píxeles) * Medición (píxeles) = Resultados (unidades del mundo real)
    • 125/640*490 = 95,703mm
Closed Importar

La opción Importar tipo de calibración se utiliza para cargar un archivo de calibración que ha sido creado por la herramienta de calibración Punto N y ha sido exportado en el sistema de archivos locales del sensor de visión In-Sight. El archivo de calibración importado calibra automáticamente la tarea actual tan pronto como se ha cargado.

Nota: Antes de seleccionar la opción Importar como Tipo de calibración, añada y configure la herramienta de calibración Punto N, y, a continuación, exporte el archivo de calibración en el sistema de archivos locales del sensor de visión In-Sight.

La herramienta de calibración Punto N crea una transformación de 2D para pasar de píxel a un sistema de coordenadas del mundo real. La herramienta realiza las transformaciones siguientes:

  • Traducción en dos dimensiones (utilizando 2 o más pares de puntos).
  • Rotación en torno a tres ejes (utilizando 4 o más pares de puntos).
  • Escalado en dos dimensiones (utilizando 2 o más pares de puntos).
  • Distorsión de perspectiva (utilizando 4 o más pares de puntos).
  • Distorsión de paralelogramo o deformación (utilizando 4 o más pares de puntos).

Modo de utilización

  1. Seleccione Importar en el menú desplegable Tipo de calibración.
  2. EasyBuilder examinará automáticamente su tarea para buscar cualquier archivo de calibración generado por la herramienta de calibración Punto N, y cargará el archivo de calibración. Si ha creado más de un archivo de calibración, seleccione el archivo deseado en el menú desplegable Nombre de archivo.
  3. En el menú desplegable Unidades, seleccione las unidades del mundo real que definen la calibración: micras, milímetros (predeterminado), centímetros o pulgadas.
  4. La calibración se aplicará tan pronto como se seleccione esta opción y se configuren los valores.


Controles de disparador

Los controles del disparador Disparador, Retardo de disparador y Intervalo del disparador permiten personalizar cómo y cuándo se adquiere una imagen.

  • Disparador: define el origen del disparador de adquisición de imágenes cuando sistema de visión está en línea.

    • Cámara (predeterminado): Habilita la adquisición de imágenes en un margen de aumento detectado en la entrada dedicada del disparador de adquisición del sistema de visión.
    • Continuo: Habilita la adquisición de imágenes "sobre la marcha" (tan rápidamente como sea posible).

    • Externo: Habilita la adquisición de imágenes al recibir un comando serie o en el flanco ascendente aplicado a un bit de entrada discreto configurado como disparador de adquisición.

      Nota:

      • Pueden alcanzarse mayores velocidades de disparo utilizando la entrada del disparador de adquisición integrada en el sistema de visión (ajustando el parámetro "Disparador" a Cámara) en lugar de activar el sistema de visión con una línea de entrada de uso general configurada como disparador de adquisición (ajustando el parámetro "Disparador" a Externo).
      • Si el parámetro "Disparador" está ajustado a Externo y se pierde alguna adquisición, el sistema de visión no enviará la salida ERR: Adquisición perdida. La señal ERR: Adquisición perdida solo puede realizarse con el parámetro "Disparador" ajustado a Cámara.
    • Manual: Habilita la adquisición de imágenes al presionar F5.
    • Ethernet industrial: Habilita el disparo desde un protocolo Ethernet industrial, por ejemplo, EtherNet/IP, POWERLINK, Profinet o SLMP Scanner.
    • Marca de tiempo: Permite la adquisición de imagen cuando se envía un disparador con marca de tiempo al sistema de visión desde un PLC por EtherNet/IP. La opción Marca de tiempo solo se admite en los siguientes sistemas de visión:
      • Sistemas de visión In-Sight de la serie 7000 Gen2

      • Sistemas de visión In-Sight 5000 con memoria flash no volátil de 128 MB que ejecuten una versión de firmware 4.5.0 o superior

        Nota: No son compatibles los sistemas de visión In-Sight 5605 (tipo de hardware 821-0032-1R), In-Sight 5705 y 5705C.
      • Sistemas de visión de exploración por líneas In-Sight 9902L

  • Retardo de disparador: especifica un retardo en milisegundos (0 a 10.000) entre la hora en que se recibe el disparador y la hora en que el sistema de visión inicia la adquisición.

    Nota:

    • El control Disparador debe establecerse en Cámara o Red para habilitar esta funcionalidad.
    • El retardo es preciso al milisegundo solicitado, más o menos el tiempo de exposición máximo de la línea que es 64 microsegundos.
    • Si Comienzo de adquisición o Estrobo es el tipo de señal especificado en el paso Entradas/Salidas, las salidas se demorarán según el tiempo especificado.

  • Intervalo del disparador: especifica un intervalo entre adquisiciones (0 a 10.000 milisegundos; predeterminado = 500) cuando el control Disparador está ajustado en Continuo.

    Nota: Este retardo depende del tiempo que la tarea tarda en procesar la imagen. Por ejemplo, si el intervalo del disparador se ajusta en 5.000 milisegundos, el sistema de visión adquirirá una imagen cada 5.000 milisegundos, siempre que la tarea finalice su tratamiento de la imagen dentro del plazo de 5.000 milisegundos. En caso contrario, el sistema de visión In-Sight adquirirá una imagen tan pronto como termine de procesar la imagen.


Controles de exposición

Los controles de exposición permiten personalizar la aplicación para mejorar la iluminación no homogénea y equilibrar la luminosidad con el fin de maximizar el nivel de detalle de las características en su inspección.

Closed Exposición

El control Exposición permite especificar el tiempo de exposición. Cuando el sistema de visión In-Sight recibe una señal de disparador, se integra luz en la matriz de sensores de imagen durante el tiempo especificado.

Nota:

  • Cuando se está conectado a un sistema de visión de exploración por líneas In-Sight 5604, 5614 o 9902L, el tiempo de exposición se define en microsegundos.

  • Aunque técnicamente la exposición se puede ajustar a 0, el tiempo de exposición depende del sistema de visión In-Sight empleado, y un valor de exposición igual a 0 adoptará por defecto el tiempo de exposición mínimo (en milisegundos o microsegundos) correspondiente al sistema de visión seleccionado.

Modelo In-Sight | Resolución | Tipo de sensor | Tiempo de exposición (ms)
In-Sight Micro 1020, 1050, 1100, 1110, 1100C, 1400, 1410, 1400C | 640 x 480 | CCD, global shutter | 0,016 a 1000
In-Sight Micro 1402, 1412 | 1280 x 1024 | CMOS, global shutter | 0,016 a 950
In-Sight Micro 1403, 1413, 1403C | 1600 x 1200 | CCD, global shutter | 0,052 a 1000
In-SightMicro 15001 | 640 x 480 | CMOS, global shutter | 0,004 a 500
 | 800 x 600 | CMOS, global shutter | 0,005 a 500
In-Sight 2000-110, 2000-120, 2000-120C, 2000-130, 2000-130C，2000-110 Mini, 2000-120 Mini, 2000-120C Mini, 2000-130 Mini, 2000-130C Mini, 2000-23M1 | 640 x 480 | CMOS, global shutter | 0,001 a 1000
In-Sight 2000-130, 2000-130C, 2000-130 Mini, 2000-130C Mini, 2000-23M1 | 800 x 600 | CMOS, global shutter | 0,001 a 1000
In-Sight 5100, 5110, 5100C, 5400, 5410, 5400C, 5600, 5610 | 640 x 480 | CCD, global shutter | 0,016 a 1000
In-Sight 5403, 5413, 5603, 5613 | 1600 x 1200 | CCD, global shutter | 0,027 a 1000
In-Sight 5604 y 5614, exploración por líneas2 | 1024 x 1 | CCD, global shutter | 1,33 µs a 1000 µs
In-Sight 5605, 5615, 5705, 5715 | 2448 x 2048 | CCD, global shutter | 0,014 a 1000
In-Sight 5705C | 2448 x 2048 | CCD, global shutter | 0,016 a 1000
In-Sight 7010, 7010C, 7020, 7050, 7200, 7210, 7230, 7200C, 7400, 7410, 7430, 7400C | 800 x 600 | CMOS, global shutter | 0,016 a 950
In-Sight 7402, 7412, 7432, 7402C | 1280 x 1024 | CMOS, global shutter | 0,016 a 950
In-Sight 7600, 7600C, 7800, 7800C, 7900, 7900C1 | 800 x 600 | CMOS, global shutter | 0,014 a 550
 | 640 x 480 | CMOS, global shutter | 0,014 a 520
In-Sight 7801, 7801C, 7901, 7901C | 1280 x 1024 | CMOS, global shutter | 0,017 a 750
In-Sight 7802, 7802C, 7902, 7902C1 | 1600 x 1200 | CMOS, global shutter | 0,020 a 940
 | 800 x 600 (modo de poca luz) | CMOS, global shutter | 0,020 a 940
In-Sight 7905, 7905C | 2448 x 2048 | CMOS, global shutter | 0,021 a 1000
In-Sight 8200, 8200C, 8400, 8400C | 640 x 480 | CMOS, global shutter | 0,014 a 520
In-Sight 8401, 8401C | 1280 x 1024 | CMOS, global shutter | 0,0174 a 750
In-Sight 8402, 8402C | 1600 x 1200 | CMOS, global shutter | 0,020 a 940
In-Sight 84053 | 2592 x 1944 | CMOS, rolling shutter | 0,032 a 1000
In-Sight 9902L, exploración por líneas2 | 2048 x 1 | CMOS, global shutter | 2,00 µs a 1000 µs
 | 1024 x 1
1La resolución se puede configurar en el cuadro de diálogo Ajustes de imagen. 2La Resolución 1K (modo de poca luz) y la Altura máxima de la imagen pueden configurarse en el cuadro de diálogo Ajustes de exploración por líneas. 3 Si se usa una luz estroboscópica con el sistema In-Sight 8405, se recomienda que la exposición mínima sea de 72 ms para una captura de imágenes de fotograma completo a fin de garantizar que se expongan todas las filas de píxeles cuando la luz estroboscópica es pulsatoria. Consulte Operación de efecto persiana para obtener más información.
Closed Autoexposición

El control Autoexposición permite que el sistema de visión determine automáticamente la exposición. Este control ayuda a compensar las condiciones de iluminación no homogéneas, como reflejos de superficies metálicas brillantes, sombras desplazándose y cambios en la iluminación del fondo.

  • Continuo: activa el ajuste automático de la exposición del sistema de visión en función de las condiciones de iluminación, para cada adquisición de imagen.

    Nota: El tiempo entre adquisiciones aumenta en el modo Continuo.
  • Disparo único: Disparo único ajusta la exposición del sistema de visión basándose en la primera adquisición de imagen; los ajustes de exposición se mantendrán para todas las adquisiciones subsiguientes.
    • Primera adquisición: si el sistema de visión está sin conexión, se utiliza la primera adquisición para determinar la exposición, y el valor de exposición obtenido se almacena hasta que se desactive Disparo único. Si no se ha producido ninguna adquisición mientras el sistema de visión ha permanecido sin conexión, al ponerlo en línea se utiliza la primera adquisición para determinar la exposición.
    • Adquisiciones subsiguientes: el sistema de visión adquirirá la imagen utilizando el valor de exposición calculado en la primera adquisición.

    Nota:

    • Si el sistema de visión o el sensor de visión no admite esta función, no se mostrará.
    • La selección de otro modo de autoexposición restaurará el valor de exposición. Después de haberse restablecido el valor de exposición, se utilizará la primera adquisición para determinar un nuevo valor de exposición.
Closed Botón Región de exposición

Define la región que se usará al calcular la exposición de forma automática.

Nota: Para habilitar esta funcionalidad, debe seleccionarse Continuo o Disparo único en el menú desplegable Autoexposición.
  1. Haga clic en el botón Región de exposición.
  2. Sitúe la región alrededor del área de la imagen que utilizará el sensor para determinar la exposición automática que se va a usar para la imagen que se adquiera a continuación.
  3. Haga clic en el botón Aceptar.

Ahora, la región se calculará de forma automática según el brillo del área de la imagen dentro de la región de exposición. Por ejemplo, si el área de la imagen dentro de la región de exposición es más clara que el resto de la imagen, la imagen que se adquiera a continuación será más oscura.

Definir región de exposición | Siguiente imagen adquirida
Closed Tiempo de exposición máximo

Permite especificar el tiempo de exposición máximo utilizado al determinar la exposición apropiada.

Closed Brillo objetivo de la imagen

Permite especificar el nivel de luminosidad deseado (0 a 100).

Nota: Para habilitar esta funcionalidad, debe seleccionarse Continuo o Disparo único en el menú desplegable Autoexposición.


Controles de transferencia del sensor de imágenes

Los controles de transferencia del sensor de imágenes permiten definir en qué fila del sensor de imágenes (CCD o CMOS) comenzará a ser transferida la imagen, y cuántas filas del sensor de imágenes se utilizarán para construir la imagen.

Los sistemas de visión In-Sight capturan todas las imágenes utilizando restablecimiento asíncrono y exploración progresiva; los sistemas de visión In-Sight de escala de grises producen imágenes de 8 bits, mientras que los sistemas de visión In-Sight de color producen imágenes de 24 bits. El proceso de adquisición de la imagen comienza aproximadamente a los 250 µs para todos los sistemas de visión, y se ejecuta de este modo:

  1. El sensor de imágenes integra luz durante el tiempo especificado en los controles de exposición.
  2. La imagen acumulada en el sensor de imágenes se transfiere, fila por fila, a un registro de desplazamiento en serie.
  3. Por cada fila transferida, el sistema de visión cronometra el registro de desplazamiento, píxel por píxel, desde el sensor de imágenes.
  4. La transferencia comienza por la Fila inicial y se ejecuta en la Cantidad de filas especificada.
Closed Fila inicial

Define la primera fila que se transferirá del sensor de imágenes a la memoria del sistema de visión In-Sight:

Resolución | Valores válidos para la Fila inicial
640 x 480 | 0 a 479
800 x 600 | 0 a 599
1024 x 768 | 0 a 767
1280 x 1024 | 0 a 1023
1600 x 1200 | 0 a 1199
2448 x 2048 | 0 a 2047
2592 x 1944 | 0 a 1943
Closed Número de filas

Define el número de filas que se transferirán a la memoria del sistema de visión In-Sight:

Resolución | Cantidad de filas válida
640 x 480 | 1 a 480
800 x 600 | 1 a 600
1024 x 768 | 1 a 768
1280 x 1024 | 1 a 1024
1600 x 1200 | 1 a 1200
2448 x 2048 | 1 a 2048
2592 x 1944 | 1 a 1944

Nota: Si tiene previsto conectarse a un emulador y desea ver las imágenes procedentes de un sistema de visión In-Sight que había adquirido imágenes con los parámetros de adquisición de imágenes parciales habilitados, configure los parámetros Fila inicial y Cantidad de filas del emulador con los mismos ajustes que los del sistema de visión In-Sight.


Controles de luz

Los controles de luz permiten configurar bancos y anillos de luz LED para sistemas de visión In-Sight.

Nota: Para habilitar esta funcionalidad, debe seleccionarse Continuo o Disparo único en el menú desplegable Autoexposición.

Closed Modo de control de luz (solo In-Sight de la serie 5000 e In-Sight de las series 70xx - 74xx)

El modo de control de luz especifica si la lámpara anular de un sistema de visión In-Sight de las series 5000 o 70xx - 74xx estará activada únicamente mientras dure la exposición indicada o si estará activada constantemente. On (Exposición) permite que la lámpara anular solo esté activada mientras dure la exposición. On (Continuo) permite que la lámpara anular esté activada siempre, lo que reduce el efecto estroboscópico al mantener encendidos los LED al 50 % de intensidad cuando no se está exponiendo ninguna imagen.

Closed Control de luz (solo In-Sight de la serie 5000)

Controla hasta cuatro (4) bancos de luz LED en el sistema de visión In-Sight.

Closed Ejemplo: Sistema de visión In-Sight de la serie 5000 con lámpara anular

  • Horizontal habilita los dos bancos de LED horizontales.
  • Vertical habilita los dos bancos de LED verticales.
  • Todo habilita los bancos de LED horizontales y verticales.
Closed Intensidad de luz (solo In-Sight de las series 70xx - 74xx)

Controla la intensidad real de los LED. La intensidad de la luz se guardará con la tarea.

  • Sistema de visión In-Sight de las series 70xx - 74xx: 0 a 100; valor predeterminado = 1; Desactivado = 0.
Closed Ganancia (solo In-Sight de la serie 7000)

Controla la ganancia de la fase de amplificación que precede al convertidor analógico-digital.

Modelo In-Sight | Ajustes de ganancia
Series 70xx - 74xx | 0 a 7; valor predeterminado = 0
7600, 7600C, 7800, 7800C, 7801, 7801C, 7802, 7802C , 7900, 7900C, 7901, 7901C, 7902, 7902C | 0 a 6; valor predeterminado = 0
7905, 7905C | 0 a 255; valor predeterminado = 60.


Equilibrio de blancos (solo sistemas de visión In-Sight en color)

Nota: En este tema se describe la función de equilibrio de blancos cuando se conecta a un sistema de visión In-Sight en color. Si se conecta a un sensor de visión In-Sight de la serie 2000 en color, consulte la sección Equilibrio de blancos de Ajustes de imagen.

El botón Equilibrio de blancos, que solo está disponible para sistema de visión In-Sight en color y emuladores habilitados para color, quita las tonalidades de color de una imagen en color mediante el cálculo de los valores de rojo, verde y azul (RGB) de la imagen y la corrección conforme a las tablas de colores guardadas en la tarea de In-Sight. Como resultado, los elementos que son blancos en el mundo real, por ejemplo, aparecerán blancos en la imagen.

Imagen antes del equilibrio de blancos | Equilibrio de blancos realizado | Imagen después del equilibrio de blancos

Las tablas de colores se crean mediante la adquisición de una imagen de una referencia "neutra" (es decir, una que tenga valores RGB idénticos, por ejemplo, 18-18-18), al tiempo que se garantiza que la imagen no se acerque a la saturación (255-255-255). Después de pulsar el botón Equilibrio de blancos, EasyBuilder genera un histograma de cada canal de color (rojo, verde y azul) y "ecualiza" los valores de los colores considerando el valor superior como base de referencia y dividiéndolo entre cada valor de color para producir factores de escala, que entonces se usan para crear las tablas de colores (por ejemplo, un RGB de 200-100-50 que ofrecerá factores de escala de 1-2-4).

Las tablas de colores para los ajustes del sistema de visión actual se guardan en el archivo de la tarea. Para asegurarse de que se aplique la información de equilibrio de blancos adecuada, cargue el trabajo antes de cargar o adquirir una imagen.

Para usar la funcionalidad Equilibrio de blancos:

  1. Enfoque el sensor In-Sight en un objeto de prueba plano, por ejemplo, una hoja de papel blanco con texto negro, y establezca el brillo objetivo de la imagen en consecuencia.

    Nota: El botón Región de equilibrio de blancos sirve para especificar la región que se utilizará para calcular el equilibrio de blancos de la imagen. Pulse el botón Región de equilibrio de blancos para especificar la región.

  2. En lugar del objeto plano con texto, inserte otro objeto, por ejemplo, una hoja de papel blanco vacía. El segundo objeto debe ajustarse al campo de visión del mismo modo que el objeto original.

  3. Pulse el botón Equilibrio de blancos.

  4. Ahora, EasyBuilder guardará estos ajustes en el archivo de la tarea y todas las adquisiciones de imágenes posteriores utilizarán ese ajuste de equilibrio de color.

    Nota: En los sistemas de visión en color In-Sight, el ajuste de equilibrio de blancos se guarda en un archivo de tarea y no en el propio sistema de visión In-Sight. Al crear una tarea nueva, tendrá que repetir estos pasos para aplicar los ajustes del equilibrio de blancos a dicho archivo de tarea. EasyBuilder no permite que los ajustes de equilibrio de blancos permanezcan en el sistema de visión.


Región del foco

El botón Región del foco se utiliza para especificar la región de la imagen que se utilizará para calcular el foco de la imagen para la métrica de foco del Modo en vivo. Presione el botón Región del foco para configurar la región.


Controles de enfoque

Los controles de enfoque se utilizan para controlar la posición de enfoque de las lentes en los sistemas de visión In-Sight de la serie 7000 compatibles, mediante el enfoque automático de la lente o el desplazamiento de la lente a una posición de enfoque específica.

Notas:
  • Para los sistemas de visión In-Sight de las series 70xx - 74xx, los Controles de enfoque solo están disponibles para los sistemas de visión que se ejecuten en In-Sight Explorer 4.7.3 o versiones posteriores y en el firmware In-Sight 4.7.3 o versiones posteriores.
  • Los controles de enfoque solo funcionan cuando el sistema de visión se encuentra sin conexión.
  • También es posible acceder a los botones Autoenfoque y Guardar enfoque desde el modo de vídeo en vivo tanto en la vista de hoja de cálculo como en la vista EasyBuilder.

Closed Controles de enfoque

Define si los controles de enfoque deben habilitarse. Por defecto, si un sensor tiene una posición de enfoque predeterminada válida, los controles de enfoque se habilitarán; si la posición de enfoque no se ha establecido, no se habilitarán los controles de enfoque.

Closed Botón Autoenfoque

Enfoca la lente automáticamente para maximizar la nitidez de la imagen dentro de la región.

Closed Compensación de autoenfoque (solo In-Sight de las series 70xx - 74xx)

Define el desplazamiento que debe aplicarse a la posición (-100 a 100; preajuste = 0) de la lente una vez completado el autoenfoque.

Nota: Este ajuste solo se admite en los sistemas de visión In-Sight de las series 76xx - 79xx.
Closed Posición de enfoque

Mueve la lente a una determinada posición de enfoque y adquiere una nueva imagen.

  • In-Sight de las series 70xx - 74xx: 0 - 100; valor predeterminado = 0.
  • In-Sight de las series 76xx - 79xx: 0 - 250; valor predeterminado = 0.
Closed Guardar posición de enfoque con la tarea

Define si la posición de enfoque se guardará con la tarea y se aplicará a la lente cuando se vuelva a cargar la tarea. De forma predeterminada, la casilla de verificación Guardar posición de enfoque con la tarea está activada.


Controles de exploración por líneas

Los controles de exploración por líneas permiten configurar los ajustes del sistema de visión de exploración por líneas In-Sight 5604 o 9902L. El sistema de visión de exploración por líneas monta una imagen fila por fila, según el objeto avanza por debajo de él. Este método permite generar imágenes completas y "desenvueltas" de objetos cilíndricos e imágenes rebanadas continuas de una superficie. Utilizando un codificador proporcionado por el usuario, el sistema de visión de exploración por líneas puede proporcionar imágenes de alta precisión aunque la velocidad del objeto sea variable.

Nota:

  • Para poder habilitar estos controles, es necesario estar conectado a un sistema de visión de exploración por líneas In-Sight 5604 o 9902L.
  • Para poder configurar estos ajustes, el usuario debe tener su nivel de acceso definido como "Acceso completo".
  • El sistema de visión de exploración por líneas debe estar sin conexión.

  • Disparador: define el origen del disparador de adquisición de imágenes cuando el sistema de visión de exploración por líneas está en línea.

    • Cámara (predeterminado): Habilita la adquisición de imágenes en un margen de aumento detectado en la entrada dedicada del disparador de adquisición del sistema de visión.
    • Continuo: Habilita la adquisición de imágenes "sobre la marcha" (tan rápidamente como sea posible).

    • Externo: Habilita la adquisición de imágenes al recibir un comando serie o en el flanco ascendente aplicado a un bit de entrada discreto configurado como disparador de adquisición.

      Nota:

      • Pueden alcanzarse mayores velocidades de disparo utilizando la entrada del disparador de adquisición integrada en el sistema de visión (ajustando el parámetro "Disparador" a Cámara) en lugar de activar el sistema de visión con una línea de entrada de uso general configurada como disparador de adquisición (ajustando el parámetro "Disparador" a Externo).
      • Si el parámetro "Disparador" está ajustado a Externo y se pierde alguna adquisición, el sistema de visión no enviará la salida ERR: Adquisición perdida. La señal ERR: Adquisición perdida solo puede realizarse con el parámetro "Disparador" ajustado a Cámara.
    • Manual: Habilita la adquisición de imágenes al presionar F5.
    • Ethernet industrial: Habilita el disparo desde un protocolo Ethernet industrial, por ejemplo, EtherNet/IP, POWERLINK, Profinet o SLMP Scanner.
    • Marca de tiempo: Permite la adquisición de imagen cuando se envía un disparador con marca de tiempo al sistema de visión desde un PLC por EtherNet/IP. La opción Marca de tiempo solo se admite en los siguientes sistemas de visión:
      • Sistemas de visión In-Sight de la serie 7000 Gen2

      • Sistemas de visión In-Sight 5000 con memoria flash no volátil de 128 MB que ejecuten una versión de firmware 4.5.0 o superior

        Nota: No son compatibles los sistemas de visión In-Sight 5605 (tipo de hardware 821-0032-1R), In-Sight 5705 y 5705C.
      • Sistemas de visión de exploración por líneas In-Sight 9902L

  • Retardo de línea (líneas): define el número de líneas a retardar entre el momento de dispararse la cámara y el comienzo de adquisición de la imagen.

    Nota: Para habilitar este control, el parámetro Disparador debe ajustarse a Cámara.
  • Intervalo del disparador: define, en milisegundos, un intervalo entre adquisiciones cuando el control Disparador está configurado en Continuo (0 a 10.000 milisegundos; predeterminado = 500). Este retardo depende del tiempo que la tarea tarda en procesar la imagen. Por ejemplo, si el intervalo del disparador se configura en 5.000 milisegundos, el sistema de visión In-Sight adquiere una imagen cada 5.000 milisegundos, siempre que la tarea finalice su tratamiento de la imagen dentro del plazo de 5.000 milisegundos. En caso contrario, el sistema In-Sight adquiere una imagen tan pronto como termine de procesar la imagen.

  • Exposición (µs): define el tiempo de exposición en microsegundos (0 a 1.000 µs; predeterminado = 8 µs). Cuando el sistema de visión recibe una señal de disparador, durante el tiempo especificado se introduce luz en la matriz CCD de exploración por líneas.

    Nota:

    • En el caso del 5604, aunque técnicamente este parámetro se puede poner en 0, cualquier valor inferior a 1,33 µs causará una exposición de 1,33 µs, sea cual sea el valor definido en Exposición.
    • En el caso del 9902L, aunque técnicamente este parámetro se puede poner en 0, cualquier valor inferior a 2,00 µs causará una exposición de 2,00 µs, sea cual sea el valor definido en Exposición.
  • Tipo de disparador de líneas: define el tipo de codificador: Codificador de software o Codificador de hardware. Para poder habilitar este control, debe estar conectado a un dispositivo In-Sight 5604 o 9902L. Este control está deshabilitado para emuladores de exploración por líneas.
    • Codificador de hardware: especifica que se utilizarán el ajuste Pasos por línea y un codificador de hardware externo para activar los disparadores de líneas. Un codificador de hardware es un dispositivo que digitaliza la posición del objeto y proporciona una transición de señal cada vez que el objeto se mueve en una dirección o a una distancia especificada. In-Sight 5604 e In-Sight 9902L admiten dos tipos de codificadores de hardware: Sencillo y Cuadratura. Esto puede especificarse en el cuadro de diálogo Ajustes de exploración por líneas.
    • Codificador de software (predeterminado): especifica que el ajuste Tiempo entre líneas se utilizará como reloj para activar los disparadores de líneas a intervalos predefinidos. Un codificador de software es una emulación informática de un codificador de hardware que adquiere líneas con una cadencia definida. Este método se utiliza principalmente para configuración e identificación de averías, ya que es vulnerable a los cambios en la velocidad del objeto (aceleración de baja frecuencia y vibración de alta frecuencia) que podrían provocar artefactos verticales en la imagen.
  • Número de líneas: define el número de líneas que se adquirirán para generar una imagen desde el sistema de visión de exploración por líneas.
    • De forma predeterminada, el In-Sight 5604 produce imágenes de área estándar con una resolución de 1024 x 2048 píxeles. El ancho no puede ajustarse. Si desea especificar la altura máxima de la imagen, puede pulsar el botón Configuración del codificador para abrir el cuadro de diálogo Ajustes de exploración por líneas. El valor de Número de líneas puede oscilar entre 1 y la altura máxima de la imagen.
    • De forma predeterminada, el In-Sight 9902L produce imágenes de área estándar con una resolución de 2048 x 4096 píxeles. Si desea especificar la anchura y la altura máxima de la imagen, puede pulsar el botón Configuración del codificador para abrir el cuadro de diálogo Ajustes de exploración por líneas. Si se selecciona la casilla de verificación Resolución 1K (modo de poca luz), el ancho se reduce a 1024, aumentando la sensibilidad luminosa. El valor de Número de líneas puede oscilar entre 1 y la altura máxima de la imagen.
    Modelo In-Sight | Resolución | Mínimo | Máximo | Predeterminado
    In-Sight 5604 | 1024 x 1 | 1 | 8192 | 2048
    In-Sight 9902L | 2048 x 1 | 1 | 16384 | 4096
    1024 x 1

    Nota:

    • Para evitar fallos de disparadores de imágenes, si desea adquirir imágenes de objetos giratorios, el valor de Número de líneas deberá ser inferior al número de filas entre los disparadores de dos cuadros cualesquiera.
    • Aunque técnicamente este parámetro se puede ajustar a 1, cualquier valor menor de 8 causará un fallo de adquisición de imagen.

  • Pasos por línea: cuando el Tipo de disparador de líneas está configurado en Codificador de hardware, define el número de pasos de codificador por cada línea de la imagen. Cuando se utiliza un codificador de hardware de cuadratura, un "paso" equivale a un ciclo completo de señal (o señales) del codificador. En codificadores de hardware de línea única, esto equivale a dos transiciones de señales, mientras que en codificadores de hardware de cuadratura equivale a cuatro transiciones.

    Modelo In-Sight | Pasos por línea
    In-Sight 5604 | 0,250 a 256.000; valor predeterminado = 40.000
    In-Sight 9902L | 0.250 a 8191.000; valor predeterminado = 40.000

    Nota:

    • Para codificadores de hardware de línea única, el valor de Pasos por línea debe incrementarse en 0,5, mientras que para codificadores de hardware de cuadratura debe incrementarse en 0,25.
    • En el caso del 5604, para evitar fallos de disparadores de líneas, el valor de Pasos por línea debe configurarse de modo que el tiempo más breve entre dos líneas cualesquiera sea 21,47 µs mayor que el ajuste Exposición (con un valor mínimo de 1,33 µs).
    • En el caso del 9902L, para evitar fallos de disparadores de líneas, el valor de Pasos por línea debe configurarse de modo que el tiempo más breve entre dos líneas cualesquiera sea 3 µs mayor que el ajuste Exposición o 15 µs, el que sea más grande.
    Closed Cronograma del codificador de hardware de pasos por línea

  • Tiempo entre líneas (µs): Cuando el Tipo de disparador de líneas está configurado en Codificador de software, define el tiempo, en microsegundos, por cada línea de la imagen.

    Modelo In-Sight | Tiempo entre líneas
    In-Sight 5604 | 21.000 a 1000000.000; valor predeterminado = 40.000
    In-Sight 9902L | 21.000 a 1000000.000; valor predeterminado = 40.000
    Emulador In-Sight | 10.000 a 1000000.000; valor predeterminado = 40.000

    Nota:

    • En el caso del 5604, para evitar fallos de disparadores de líneas, el valor de Tiempo entre líneas debe configurarse de modo que el tiempo más breve entre dos líneas cualesquiera sea 21,47 µs mayor que el ajuste Exposición (con un valor mínimo de 1,33 µs).
    • En el caso del 9902L, para evitar fallos de disparadores de líneas, el valor de Tiempo entre líneas debe configurarse de modo que el tiempo más breve entre dos líneas cualesquiera sea 3 µs mayor que el ajuste Exposición o 15 µs, el que sea más grande.
  • Modo de recorte: define una acción cuando se recibe un disparador de adquisición de imágenes pero todavía no se ha adquirido el número de líneas especificado.
    • Sin recortes (predeterminado): especifica que el disparador de imagen será ignorado y que se generará un evento "Error de adquisición".
    • Relleno negro: Especifica que las líneas restantes se rellenarán con píxeles negros y que se iniciará inmediatamente una nueva imagen. No se generará el evento "Error de adquisición".

    • Reducir líneas de imagen: especifica que la imagen actual se reducirá al tamaño del número de filas adquiridas actualmente y que se iniciará de inmediato una nueva imagen.

    Nota:

    • Si selecciona la opción Relleno negro o Reducir líneas de imagen:
      • Ponga el tipo de disparador en Cámara para recortar correctamente las imágenes. Con cualquier otro tipo de disparador, si este se activa mientras se está adquiriendo una imagen, no se recorta dicha imagen y se pierde el disparador.
      • Si se envía el comando del modo nativo "Set Event" (Definir evento) para desencadenar una adquisición y el disparador llega mientras se está adquiriendo una imagen, la imagen actual no se recorta y el disparador se pierde.
    • Para aplicaciones que requieren una elevada precisión de control de tiempos, seleccione la opción Reducir líneas de imagen. O, si se utiliza la opción Relleno negro, mantenga el relleno por debajo de unos cientos de líneas.
      • En el caso del 5604, la opción Relleno negro requiere unos 2 µs por línea de relleno (es decir, 0,2 milisegundos por cada 100 líneas).
      • En el caso del 9902L, la opción Relleno negro requiere unos 3 µs por línea de relleno (es decir, 0,3 milisegundos por cada 100 líneas).
  • Duración de adquisición: especifica cuándo finalizar la adquisición de imagen si el parámetro Modo de recorte está configurado en Relleno negro o en Reducir líneas de imagen. Esta opción solo funciona con el sistema de visión In-Sight 9902L cuando el tipo de disparador seleccionado es Cámara.
    • 0 = Siguiente disparador (predeterminado): la adquisición de la imagen comienza en el margen inicial del pulso del disparador y acaba al principio de la siguiente señal de disparador.
    • 1 = Fin de disparador: la adquisición de la imagen comienza en el margen inicial del pulso del disparador y acaba en el margen final del pulso del disparador. La adquisición de la imagen se completa cuando:
      • Se ha adquirido el número de líneas especificado, aunque no haya llegado el margen inicial del pulso del disparador.

      • Llega el margen final del pulso y termina la adquisición antes de que se haya adquirido el número de líneas especificado.

        Nota: Cuando se selecciona Fin de disparador, se aplica el parámetro Demora a la adquisición.


Ajustes de exploración por líneas

El cuadro de diálogo Ajustes de exploración por líneas permite configurar los ajustes del codificador de sistemas de visión de exploración por líneas 5604 y 9902L, así como mostrar información de diagnóstico para el sistema de visión.

Nota: Al utilizar un codificador de cuadratura por hardware, si el sistema de visión comienza a adquirir una imagen y el codificador indica que se está moviendo en la dirección opuesta y rebasa el principio del disparador del cuadro, la imagen resultante queda incorrectamente montada y no puede utilizarse. Si esto ocurre, deje el sistema de visión sin conexión cuando el codificador de cuadratura señale que está invirtiendo su dirección. Luego, vuelva a poner el sistema de visión en línea cuando el codificador indique que reanuda su dirección anterior.

  • Altura máxima de la imagen: especifica el número máximo de filas utilizadas para generar la imagen, así como el número máximo de búferes de imágenes para sistemas de visión de exploración por líneas:

    Sistema de visión Altura máxima de la imagen
    In-Sight 5604

    2048 (predeterminado)

    4096

    8192
    In-Sight 9902L

    2048

    4096 (predeterminado)

    8192

    12288

    16384

    Nota:

    • Cada vez que se modifica el ajuste Altura máxima de la imagen de un sistema de visión de exploración por líneas, este debe reiniciarse, operación que borra todos los archivos de tareas y de ajustes de la memoria flash no volátil. Antes de continuar, guarde o haga una copia de seguridad de su tarea.
    • El número predeterminado de búferes de imágenes que se asignan al sistema de visión durante el inicio depende del tamaño de RAM y la resolución del sistema de visión. Si se ajusta la altura máxima de la imagen, puede aumentar o disminuir el número máximo de búferes de imágenes a disposición del sistema de visión. Si es necesario, use el cuadro de diálogo Búferes de imágenes para modificar el número de búferes de imágenes que se asignan al sistema de visión durante el inicio.

    • Al usar un sistema de visión de exploración por líneas, el ancho de la región para una ubicación o para herramientas de inspección tiene un límite máximo. Si necesita establecer un valor más alto para el ancho de la región, deberá acceder a la Vista de hoja de cálculo y bien introducir manualmente el valor de la región en la barra de fórmulas o bien crear una función de estructura o controles separada y referenciarla en lugar del parámetro Región de la herramienta.

      Sistema de visión | Resolución | Altura máxima de la imagen | Ancho máximo en hoja de propiedades
      In-Sight 5604 | 1024 x 1 | 8192 | 3072
      In-Sight 9902L 2048 x 1

      8192 y superior

               6144
      1024 x 1 | 4096 y superior | 3072
  • Codificador de hardware
    Nota: Para modificar la Dirección o Tipo de codificador, el parámetro Tipo de disparador de líneas, del paso de aplicación Configurar imagen, debe ponerse en Codificador de hardware, el sistema de visión de exploración por líneas debe estar sin conexión y el usuario debe contar con acceso completo.

    • Tipo de codificador: especifica el tipo de codificador de hardware utilizado para disparar las adquisiciones de líneas: Sencillo (valor predeterminado) y Cuadratura.

      Nota:

      • Si Tipo de codificador se establece en Sencillo, el codificador de línea única debe conectarse a la primera entrada del codificador; la conexión del cable a la segunda entrada no tiene ningún efecto.
      • Los codificadores de cuadratura proporcionan información de dirección y requieren dos entradas de alta velocidad.

    • Dirección: especifica qué dirección debe considerarse como dirección de avance del codificador de cuadratura: Positiva (ajuste predeterminado) o Negativa. El sistema de visión de exploración por líneas utiliza la Dirección para determinar la dirección de funcionamiento correcta. Los pasos en la dirección opuesta se consideran no válidos y provocan la anulación del cuadro actual.

      Nota: Este control se deshabilita cuando el Tipo de codificador está configurado en Sencillo.
  • Diagnóstico
    • Recuento del codificador: muestra el número de pasos del codificador de hardware (o los microsegundos en el caso de un codificador de software).
    • Recuento de líneas: muestra el total acumulado de líneas adquiridas desde la última puesta a cero de los contadores.
    • Recuento de saturaciones de líneas: muestra el número de líneas perdidas por velocidades excesivas del codificador.
    • Recuento de saturaciones de búfer: muestra el número de veces que el sistema de visión de exploración por líneas se quedó sin búferes de imágenes.
    • Cuadros por segundo: muestra el número de cuadros adquiridos por segundo.

    • Pasos por segundo: muestra el número de pasos procedentes del codificador de hardware externo por segundo.

      Nota: Cuando se utiliza un codificador de software, este valor corresponde al número de microsegundos por segundo.

    • Botón Restablecer: pone a cero todas las estadísticas de diagnóstico.

      Nota: Todas las estadísticas de diagnóstico se ponen a cero cuando el sistema de visión de exploración por líneas se conecta ("en línea") o se desconecta ("sin conexión").
  • Resolución 1K (modo de poca luz): proporciona mayor sensibilidad luminosa con una resolución reducida. Esta opción solo funciona con el sistema de visión In-Sight 9902L.


Calibración de la imagen en unidades del mundo real

Nota: En este tema se describe la función de calibración cuando se conecta a un sistema de visión In-Sight. Si se conecta a un sensor de visión In-Sight 2000-130/130C o 2000-23M, consulte la sección Campo de visión (anchura) de Ajustes de imagen.

El cuadro de grupo Calibrar imagen en unidades del mundo real permite calibrar los resultados de las herramientas de ubicación y de inspección, mostrando sus resultados en unidades de medida del mundo real (micras, milímetros, centímetros y/o pulgadas), en lugar de valores de píxeles.

En los sistemas de visión In-Sight, la calibración se refiere al proceso de "correspondencia" (o "mapeado") del área de la imagen, que establece una relación entre las características de la imagen y unidades de medida conocidas del mundo real. En este proceso, se utiliza una transformación bidimensional (2D) para establecer matemáticamente una correspondencia entre los puntos de coordenadas de píxeles de una imagen y coordenadas del mundo real. Una vez calibrada una imagen, las herramientas de ubicación y de inspección comunican sus resultados en unidades calibradas (del mundo real).

Para calibrar un sistema de visión In-Sight existen seis tipos distintos de calibraciones, con diferentes grados de precisión: Escala X/Y, Margen a margen, X/Y margen a margen, Círculo, Cuadrícula, Importar o 9 puntos.

Para asignar una calibración a la tarea, seleccione una opción de calibración en el menú desplegable Tipo de calibración:

  • Ninguno (predeterminado)
  • Escala X/Y
  • Margen a margen
  • X/Y margen a margen
  • 9 puntos
  • Círculo
  • Cuadrícula
  • Importar
Notas:
  • Las opciones de calibración Escala X/Y, Margen a margen, X/Y margen a margen, Círculo, Importar y 9 puntos utilizan entre 1 y 16 puntos definidos por el usuario en la imagen para asociarlos a otras tantas medidas del mundo real de los objetos inspeccionados. Estas opciones de calibración sólo compensan distorsiones lineales y no lineales. Para obtener el máximo grado de exactitud, utilice la opción de calibración Cuadrícula.
  • Cuando se utiliza el ajuste predeterminado Ninguno como Tipo de calibración, todos los resultados de herramientas se indican en coordenadas de píxeles.
  • Active la casilla de verificación Orientación clásica para ver sus resultados calibrados alineados con las coordenadas (Y/X) tradicionales de la vista de hoja de cálculo.
  • Al aplicar una calibración, las configuraciones física y óptica (lente, sistema de visión y relación física entre el sistema de visión y la escena adquirida) deben ser iguales tanto para la calibración como para el funcionamiento en tiempo de ejecución. El sistema debe recalibrarse si se altera cualquiera de estas posiciones. Por lo tanto, se recomienda utilizar la misma combinación de sistema de visión y lente tanto para calibrar como para procesar las imágenes en tiempo de ejecución. El sistema de visión y la lente también deben conservar sus ajustes originales de configuración y calibración. Por ejemplo, si cambia el formato de adquisición (variando la resolución) o mueve el sistema de visión, se invalidará la transformación bidimensional (2D) que establece la correspondencia entre píxeles y coordenadas del mundo real.


Tipos de calibración Escala X/Y, Margen a margen, X/Y margen a margen y Círculo

Las opciones de calibración Escala X/Y, Margen a margen, X/Y margen a margen y Círculo se utilizan en aplicaciones de inspección de piezas u objetos, siempre que se conozca la medida del mundo real de dicha pieza u objeto.

Nota: Las opciones de calibración de escala no tienen en cuenta la distorsión de la lente, por lo que, para obtener el mayor grado de exactitud posible, conviene asegurarse de que el sensor In-Sight esté montado perpendicularmente a la superficie inspeccionada. De no ser así, considere utilizar la calibración de rejilla para suprimir la distorsión y calibrar más exactamente su imagen.

Closed Escala X/Y

Utilizado cuando se conocen los valores de escala X e Y para calcular una calibración simple.

Nota: Esta opción no tiene en cuenta la distorsión.

  1. Seleccione Escala X/Y en el menú desplegable Tipo de calibración.
  2. En el menú desplegable Unidades, seleccione las unidades del mundo real (Micras, Milímetros, Centímetros o Pulgadas).
  3. En el parámetro Escala horizontal, introduzca el valor de escala horizontal (0 a 9.999.999)
  4. En el parámetro Escala vertical, introduzca el valor de escala vertical (0 a 9.999.999).
  5. La calibración se aplicará tan pronto como se seleccione esta opción y se configuren los valores.
Closed Margen a margen

Utilizado cuando se conoce la distancia entre dos características de margen.

  1. Seleccione Margen a margen en el menú desplegable Tipo de calibración.
  2. Presione el botón Seleccionar márgenes; EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso).
  3. Primero haga clic en una de las características inteligentes disponibles para seleccionarla. En ese momento, su color cambiará a magenta y una línea partirá desde esa característica.
  4. A continuación, seleccione la segunda característica inteligente.

Nota: Si EasyBuilder no encuentra automáticamente las características que desea utilizar, no desactive la casilla de verificación Características inteligentes y no sitúe la región sobre la característica que desee definir en su lugar.

  5. Presione el botón Aceptar para definir sus características.
  6. En el menú desplegable Unidades, seleccione las unidades del mundo real (Micras, Milímetros, Centímetros o Pulgadas).
  7. En el campo Dimensión, introduzca la medida del mundo real conocida correspondiente a la característica.
  8. Presione el botón Calibrar para concluir el proceso de calibración. Los resultados de las herramientas de ubicación y de inspección aparecerán en unidades del mundo real.
Closed X/Y margen a margen

Utilizado cuando se conoce la distancia entre dos pares de márgenes. uno en la dirección horizontal y otro en la dirección vertical. Combinando la medida y la dimensión horizontales con las correspondientes verticales se crean dos escalas independientes.

  1. Seleccione X/Y Margen a margen en el menú desplegable Tipo de calibración.
  2. Presione el botón Definir medida horizontal; EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso).
  3. Primero haga clic en una de las características inteligentes disponibles para seleccionarla. En ese momento, su color cambiará a magenta y una línea partirá desde esa característica.
  4. A continuación, seleccione la segunda característica inteligente.

Nota: Si EasyBuilder no encuentra automáticamente las características que desea utilizar, no desactive la casilla de verificación Características inteligentes y no sitúe la región sobre la característica que desee definir en su lugar.

  5. Presione el botón Aceptar para definir sus características.
  6. Presione el botón Definir medida vertical; EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso).
  7. Primero haga clic en una de las características inteligentes disponibles para seleccionarla. En ese momento, su color cambiará a magenta y una línea partirá desde esa característica.
  8. A continuación, seleccione la segunda característica inteligente.
  9. Presione el botón Aceptar para definir sus características.
  10. En el menú desplegable Unidades, seleccione las unidades del mundo real (Micras, Milímetros, Centímetros o Pulgadas).
  11. En el campo Dimensión horizontal, introduzca la dimensión horizontal del mundo real conocida correspondiente a la característica.
  12. En el campo Dimensión vertical, introduzca la dimensión vertical del mundo real conocida correspondiente a la característica.
  13. Presione el botón Calibrar para concluir el proceso de calibración. Los resultados de las herramientas de ubicación y de inspección aparecerán en unidades del mundo real.
Closed Círculo

Utilizado cuando se conoce el diámetro de una característica circular.

  1. Seleccione Círculo en el menú desplegable Tipo de calibración.
  2. Presione el botón Seleccionar círculo; EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso).
  3. Seleccione una característica inteligente de entre las características disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).

Nota: Si EasyBuilder no encuentra automáticamente las características que desea utilizar, no desactive la casilla de verificación Características inteligentes y no sitúe la región sobre la característica que desee definir en su lugar.

  4. Presione el botón Aceptar para definir su característica.
  5. En el menú desplegable Unidades, seleccione las unidades del mundo real (Micras, Milímetros, Centímetros o Pulgadas).
  6. En el campo Dimensión, introduzca la medida del mundo real conocida correspondiente a la característica.
  7. Presione el botón Calibrar para concluir el proceso de calibración. Los resultados de las herramientas de ubicación y de inspección aparecerán en unidades del mundo real.


Tipo de calibración de 9 puntos

La opción de calibración de 9 puntos resulta útil en aplicaciones de robótica en las que se necesita crear un espacio de coordenadas correcto para el robot. Esta opción de calibración emplea un objetivo circular, según se ilustra debajo. Lo ideal es que la placa de calibración esté compuesta de nueve objetivos espaciados uniformemente, formando una cuadrícula. Para poder iniciar el proceso de calibración, deben conocerse las distancias horizontal y vertical entre los objetivos.

Notas:
  • El objetivo situado en el centro de los nueve objetivos se considerará como origen (0,0) del sistema de coordenadas del robot.
  • El espaciado entre objetivos horizontales debe ser homogéneo e idéntico. Lo mismo también es aplicable a la distancia entre objetivos en sentido vertical. Por el contrario, no es necesario que la distancia entre objetivos horizontales y verticales sea igual.
  • Cada objetivo debe tener un diámetro circular mínimo de 25 píxeles.
Closed Ejemplo - Objetivo único

Closed Ejemplo - Nueve objetivos

Nota: Las coordenadas no deben estar presentes en la imagen real. Solo se incluyen con fines ilustrativos.

Nota: La opción de calibración de 9 puntos no tiene en cuenta la distorsión de la lente, por lo que, para obtener el mayor grado de exactitud posible, conviene asegurarse de que el sensor In-Sight esté montado perpendicularmente a la superficie inspeccionada.

Antes de iniciar el proceso de calibración, capture una imagen de la placa de calibración con los nueve objetivos espaciados uniformemente.

  1. Seleccione 9 puntos en el menú desplegable Tipo de calibración.

  2. Pulse el botón Editar modelo y configure la región de manera que englobe el objetivo central. A continuación, pulse el botón OK . Cuando configure la región alrededor del objetivo, asegúrese de que haya al menos 3 o 4 píxeles en blanco entre el borde exterior del círculo y la región. Intentar también centrar la región sobre el objetivo todo lo posible.

    Closed Ejemplo

  3. Una vez configurado el modelo, EasyBuilder detectará automáticamente todos los objetivos en la imagen y mostrará una cruz verde sobre los objetivos detectados.

Nota: Si se detecta la marca fiducial del objetivo, pero no se detecta el círculo que rodea a dicha marca, aparecerá una cruz roja. Para resolver el problema, vuelva a entrenar el modelo o adquiera una nueva imagen.

  4. En el menú desplegable Unidades, seleccione las unidades del mundo real (Micras, Milímetros, Centímetros o Pulgadas).
  5. En el campo Dimensión X, introduzca la medida real de la distancia horizontal entre dos objetivos en la misma fila (medida desde el centro de cada objetivo).
  6. En el campo Dimensión Y, introduzca la medida real de la distancia vertical entre dos objetivos en la misma columna (medida desde el centro de cada objetivo).
  7. Presione el botón Calibrar para concluir el proceso de calibración. Los resultados de las herramientas de ubicación y de inspección aparecerán en unidades del mundo real.


Calibración de la cuadrícula

En su entorno productivo, el sistema de visión In-Sight puede capturar imágenes que presenten distorsiones inducidas por ciertas condiciones de configuración, como distorsiones de lentes y de perspectivas. Algunas lentes pueden producir patrones de distorsión radial que deforman las líneas en forma de barril o de almohadilla, haciéndolas parecer curvadas en la imagen, cuando en el mundo real son rectas. La distorsión de la perspectiva se produce cuando un sistema de visión In-Sight no puede montarse en posición perpendicular con respecto al área de la inspección. En estas situaciones, las características de la imagen pueden aparecer estiradas u oblongas, dependiendo de su ubicación dentro del campo de visión, generando resultados inexactos.

La opción Calibración de la cuadrícula genera un "mapa" del área de la imagen adquiriendo la imagen de un patrón de cuadrícula, bien sea de puntos o de cuadrados de tablero de ajedrez. A continuación, esta opción relaciona las características encontradas en la cuadrícula (los puntos o las intersecciones de los cuadrados) con el espaciamiento de cuadrícula definido por el usuario en el patrón de cuadrícula. Este proceso crea un cálculo de alta precisión que se puede utilizar para transformar características distorsionadas a su forma correcta.

La calibración de un sistema de visión In-Sight permite localizar con mayor precisión objetos en los márgenes de imágenes y proporciona mayor flexibilidad de montaje, incluyendo la posibilidad de montar el sistema de visión In-Sight hasta a 45° con respecto a la superficie de inspección.

Sugerencia: Si su aplicación requiere Calibración de la cuadrícula, puede utilizar la herramienta de filtrado de imágenes "Transformar" para ver los resultados libres de distorsión y hacer que otras herramientas de inspección hagan referencia a la salida de la Imagen de herramienta.

  1. Seleccione Cuadrícula en el menú desplegable Tipo de calibración.
  2. Presione el botón Calibración para abrir el cuadro de diálogo CalibrateGrid.


Importar tipo de calibración

Importar tipo de calibración se utiliza para cargar un archivo de calibración creado por una herramienta de calibración Punto N o Punto N secuencial y exportado al sistema de archivos local del sistema de visión In-Sight. El archivo de calibración importado calibra automáticamente la tarea actual tan pronto como se ha cargado.

Nota: Antes de seleccionar Importar como Tipo de calibración, agregue y configure una herramienta de calibración Punto N o Punto N secuencial y exporte el archivo de calibración al sistema de archivos local del sistema de visión In-Sight.

Las herramientas de calibración Punto N y Punto N secuencial crean una transformación bidimensional (2D) para realizar conversiones entre coordenadas de píxeles y del mundo real. En este proceso, las herramientas detectan la distorsión lineal y no lineal, y ofrecen un grado de exactitud más alto que los métodos de calibración Escala X/Y, Margen a margen, X/Y margen a margen o Círculo si se utilizan cinco o más pares de puntos. La herramienta realiza las transformaciones siguientes:

  • Traducción en dos dimensiones (utilizando 2 o más pares de puntos).
  • Rotación en torno a tres ejes (utilizando 4 o más pares de puntos).
  • Escalado en dos dimensiones (utilizando 2 o más pares de puntos).
  • Distorsión de perspectiva (utilizando 4 o más pares de puntos).
  • Distorsión de paralelogramo o deformación (utilizando 4 o más pares de puntos).
Closed Importación
  1. Seleccione Importar en el menú desplegable Tipo de calibración.
  2. EasyBuilder examinará automáticamente su tarea en busca de cualquier archivo de calibración generado por una herramienta de calibración Punto N o Punto N secuencial, y cargará el archivo de calibración. Si existe más de un archivo de calibración, seleccionará el que usted elija en el menú desplegable Nombre de archivo.
  3. En el menú desplegable Unidades, seleccione las unidades de medida del mundo real que definen la calibración: Micras, Milímetros (predeterminado), Centímetros o Pulgadas.
  4. La calibración se aplicará tan pronto como se seleccione esta opción y se configuren los valores.


Detectar pieza

Las herramientas de ubicación se utilizan para definir una característica en la imagen que proporciona datos de posición. Las herramientas de ubicación crean un elemento que se utiliza para localizar una pieza en la imagen de forma rápida y confiable, incluso si la pieza que se está inspeccionando gira o aparece en diferentes ubicaciones en la imagen.

Notas:
  • Si su tarea no requiere datos de posición o la pieza se presentará al sensor In-Sight en la misma ubicación en cada imagen, vaya al apartado Inspeccionar pieza.
  • Los sensores de visión In-Sight 2000-110 y 120/120C le permiten añadir solo un elemento a una tarea.
  • Agregación, eliminación y edición de herramientas de ubicación
  • Elección de una herramienta de ubicación

  • Creación de vínculos entre las herramientas de ubicación y de inspección

    Nota: Los sensores de visión In-Sight de la serie 2000 no admiten la ficha Vínculos.

Las herramientas de ubicación informan de los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight 2000-110 y 2000-120/120C | Solo estado de aceptación/rechazo
Sensor de visión In-Sight 2000-130/130C | Herramienta de ubicación de patrón: Estado de aprobado/rechazado y puntuación de patrón Otras herramientas de ubicación: Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar (datos de posición* y estado de aceptación o rechazo)
* La herramienta informa de los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.


Agregación, eliminación y edición de herramientas de ubicación

Closed Agregación de una herramienta

Para añadir una herramienta a su tarea, selecciónela en el grupo Agregar herramienta y presione el botón Agregar o haga doble clic en la herramienta. Se le pedirá que defina la característica en la imagen, ya sea mediante selecciones de características inteligentes de EasyBuilder, el ajuste de los gráficos de la región en la imagen o el posicionamiento de gráficos de referencia geométrica.

Una vez definida inicialmente su función, puede efectuar el ajuste fino de los controles de la herramienta ajustando los diversos parámetros.

Nota: Puede buscar herramientas de forma dinámica si utiliza el cuadro de búsqueda Herramienta.

Closed Eliminación de una herramienta

Para eliminar una herramienta de su tarea, simplemente elija uno de los siguientes métodos:

  • Seleccione la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta) y presione la tecla Suprimir del teclado.
  • Seleccione la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta) y presione el icono Suprimir de la barra de herramientas Estándar.
  • En la tabla Resultados, haga clic con el botón derecho en la herramienta (situada en la ficha Resultados de la paleta) y elija la opción Eliminar del menú.
Closed Edición de una herramienta

Para editar una herramienta desde cualquier paso de EasyBuilder, elija uno de los siguientes métodos:

  • Haga doble clic en la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta).
  • Haga clic con el botón derecho en la herramienta de la tabla Resultados y seleccione la opción Ir a esta herramienta y editar en el menú.

Para editar una herramienta desde los pasos Localizar pieza o Inspeccionar pieza, simplemente elija uno de los siguientes métodos:

  • Seleccione el gráfico de región de la herramienta en la imagen.
  • Haga doble clic en la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta).
  • Haga clic con el botón derecho en la herramienta de la tabla Resultados y seleccione la opción Ir a esta herramienta y editar en el menú.
  • Haga doble clic en la herramienta en la tabla de resultados del paso de aplicación Ejecutar tarea.
Notas:
  • Si su sistema de visión In-Sight permite acceder al entorno de programación de la hoja de cálculo de In-Sight Explorer, aparecerá la opción del menú contextual Ir a esta herramienta en la hoja de cálculo. Se recomienda acceder al entorno de programación de la hoja de cálculo solo si se está familiarizado con este entorno y se comprende su funcionamiento. Antes de continuar, consulte los temas de la ayuda en línea sobre tareas y hoja de cálculo de EasyBuilder de In-Sight Explorer.
  • Las herramientas se pueden reorganizar en la tabla Resultados arrastrando y soltando las herramientas en el orden deseado. Esto puede hacerse tanto en la tabla Resultados de tareas ejecutadas como en la tabla Resultados de Palette, y se reflejará en ambas tablas. La clasificación mediante la técnica “arrastrar y soltar” solo se habilita al seleccionar la columna Orden de las herramientas y gráficos de dependencias (esta columna está seleccionada por defecto). Para invertir el orden, seleccione de nuevo la columna. La función de reorganización de la lista se desactivará si la tarea se aproxima o supera el límite de tamaño de la tarea.

Nota: Si la tarea no dispone de espacio suficiente para añadir más herramientas, salga de los pasos Localizar o Inspeccionar pieza y seleccione Límite de tamaño de la tarea en el menú Sensor. En el cuadro de diálogo, ajuste el tamaño de la tarea para que puedan añadirse más herramientas. Para ajustar el límite de tamaño de la tarea de un sistema de visión In-Sight, es necesario apagar y encender el sistema de visión, operación que borrará todos los archivos de tareas y de configuración en la memoria flash no volátil. Antes de continuar, guarde o haga una copia de seguridad de su tarea.


Características

En máquina de visión, las características se denominan "objetos de interés de la imagen" y las inspecciones visuales se diseñan teniendo en cuenta los tipos de características encontrados en la imagen.

En el paso Detectar pieza, los tipos de características son:

Closed Márgenes

Zonas lineales de transición entre píxeles claros y oscuros. Los márgenes pueden ser objetos tales como los extremos de una pieza, los contactos de una placa de circuitos o los filetes de una rosca. Los márgenes son uno de los tipos de características más rápidamente detectables durante una inspección, pero cuando se utilizan como elemento deben moverse en una sola dirección (horizontal o vertical) y presentar un contraste elevado.

Closed Ejemplo de elemento de margen

En este ejemplo, los ambientadores de aire no aparecen en la misma ubicación en cada imagen; aparecen en el mismo plano vertical, pero se desplazan horizontalmente. Se utilizan como elementos dos herramientas de ubicación de márgenes; el que está a la izquierda localiza el margen exterior de la carcasa inferior del aplicador y orienta las regiones de las otras herramientas de inspección hacia el lado izquierdo, mientras que el que está a la derecha orienta las herramientas hacia la derecha.

Closed Círculos

Los círculos son esencialmente márgenes, zonas definidas por una transición entre píxeles claros y oscuros que definen su contorno geométrico. También es uno de los tipos de características más rápidamente reconocibles, siempre que presente un contraste elevado; sin embargo, los círculos no proporcionan ningún dato de orientación angular cuando se utilizan como elemento.

Closed Ejemplo de elemento de círculo

En este ejemplo se utilizan dos elementos. El primer elemento, una herramienta de ubicación de blobs, localiza el exterior del tubo, mientras que el segundo elemento, una herramienta de ubicación de círculos, identifica la forma circular básica del tubo dentro del blob encontrado. Por requisitos de la aplicación, la longitud de los tornillos viene determinada por las distancias medidas desde un punto relativo a una forma encontrada, que debe ser uniforme.

Closed Patrones

Un patrón puede ser cualquier cosa, desde un simple grupo de formas repetitivas hasta configuraciones más complejas, como logotipos o etiquetas. Los patrones son el tipo de característica más confiable para utilizar como elemento, permitiendo el rango más amplio de variaciones posicionales de rotación, movimiento y escalado, pero generalmente son los que más tiempo requieren para su inspección.

Closed Ejemplo de elemento de patrón

En este ejemplo, el código 2D aparece en cada imagen en ubicaciones y orientaciones diferentes. Se utiliza una herramienta de ubicación de patrones PatMax para crear un elemento y orientar la búsqueda de la herramienta de identificación Leer códigos de ID. Se utiliza la herramienta de ubicación de patrones PatMax porque es capaz de identificar patrones complejos y al mismo tiempo procesar una amplia variedad de ubicaciones, orientaciones y escalas.

Closed Blobs

Un grupo de píxeles oscuros o claros conectados, como una mancha de pintura blanca sobre un fondo negro o un tornillo negro sobre una cinta transportadora blanca. En términos de velocidad de detección, los blobs se encuentran entre los márgenes y los patrones y admiten una mayor variación de formas y tamaños de las características de blob que un patrón, pero tienen un valor de orientación angular limitado cuando se utilizan como elemento.

Closed Ejemplo de elemento de blob

En este ejemplo se utilizan dos elementos porque las características inspeccionadas (los tornillos) se encuentran dentro de un objeto (el tubo), cuya orientación y ubicación vertical y horizontal pueden variar entre imágenes sucesivas. Los contornos del tubo crean una forma irregular, por lo que se utiliza una herramienta de ubicación de blobs para generar un elemento que sitúe el tubo dentro del campo de visión.


Regiones

Las regiones definen el área de la imagen en la que la herramienta de ubicación o de inspección ejecutará su operación. También se denomina "región de interés".

Las herramientas de ubicación y de inspección de EasyBuilder utilizan diversos tipos de regiones, dependiendo del tipo de herramienta utilizada. EasyBuilder utiliza los siguientes tipos de regiones:

  • Rectángulo
  • Círculo
  • Espacio anular
  • Polígono


Regiones anulares

Las regiones anulares se utilizan para definir características de márgenes circulares. La región anular tiene un radio interior y otro exterior, lo que permite definir características de márgenes circulares e ignorar el centro del círculo.

Closed Acciones del ratón en regiones anulares

 | Controles | Descripción
1 | Mover | Al situar el puntero del ratón entre los radios interior y exterior, el icono se transforma automáticamente para permitir arrastrar la región a cualquier punto dentro de la imagen.
2 | Redimensionar | Al situar el puntero del ratón sobre el radio interior o exterior de la región anular, el icono se transforma automáticamente para permitir redimensionar dicho radio (los radios interior y exterior deben redimensionarse independientemente).
Closed Dirección de exploración en regiones anulares

Las regiones anulares buscan características circulares desde el radio interior hacia el radio exterior.

Closed Códigos de colores en regiones anulares

 | Descripción
1 | Una región anular recién añadida y no seleccionada.
2 | Una región anular seleccionada, no confirmada.
3 | Una región anular seleccionada, configurada y aceptada.
4 | Una región anular no seleccionada, configurada y aceptada.
5 | Una región anular seleccionada, configurada y rechazada.
6 | Una región anular no seleccionada, configurada y rechazada.


Regiones circulares

Las regiones circulares permiten definir características circulares. La región circular abarca todo lo que se encuentra dentro del círculo. Para definir una característica circular ignorando el centro del círculo, utilice una región de espacio anular.

Closed Acciones del ratón en regiones circulares

 | Controles | Descripción
1 | Mover | Al situar el puntero del ratón dentro de la región, el icono se transforma automáticamente para permitir arrastrar la región a cualquier punto dentro de la imagen.
2 | Redimensionar | Al situar el puntero del ratón sobre el límite de la región circular, el puntero se transforma automáticamente y permite arrastrar la región para redimensionarla.
Closed Dirección de exploración de región circular

Regiones circulares busca características desde el centro del círculo hacia el radio exterior.

Closed Códigos de colores de regiones circulares

 | Descripción
1 | Una región circular recién añadida y no seleccionada.
2 | Una región circular seleccionada y no confirmada.
3 | Una región circular seleccionada, configurada y aceptada.
4 | Una región circular no seleccionada, configurada y aceptada.
5 | Una región circular seleccionada, configurada y rechazada.
6 | Una región circular no seleccionada, configurada y rechazada.


Regiones poligonales

Las regiones poligonales permiten definir características irregulares generando un contorno a partir de segmentos de líneas. Usted debe configurar la región poligonal con el contorno deseado.

Closed Leyenda de la región poligonal

 | Controles | Descripción
1 | Límite de punto final redimensionable | Define los tres puntos finales iniciales de la región poligonal (en una región poligonal se pueden crear hasta 100 puntos). Haga clic en un límite de punto final para redimensionar la región desde una de sus esquinas.
2 | Controlador de rotación | Permite girar la región 360°.
Closed Acciones del ratón en regiones poligonales

Al situar el puntero del ratón sobre diversas partes de la región, se transformará automáticamente y habilitará las acciones siguientes:

Icono del ratón | Descripción
 | Permite arrastrar toda la región poligonal a cualquier lugar de la imagen.
 | Permite escalar toda la región horizontal o verticalmente.
 | Permite rotar toda la región 360° desde su orientación actual.
 | Permite mover uno de los puntos redimensionables de punto final de la región poligonal.
 | Permite agregar un punto redimensionable de punto final a la región poligonal.
Closed Dirección de exploración de la región poligonal

 | Controles | Descripción
1 | Parte superior | Indica que la exploración se efectuará en sentido horizontal.
2 | Lateral | Indica que la exploración se efectuará en sentido vertical.
Closed Códigos de color de la región poligonal

 | Descripción
1 | Una región poligonal recientemente agregada y no seleccionada.
2 | Una región poligonal seleccionada y no confirmada.
3 | Una región poligonal seleccionada, configurada y aceptada.
4 | Una región poligonal no seleccionada, configurada y aceptada.
5 | Una región poligonal seleccionada, configurada y rechazada.
6 | Una región poligonal no seleccionada, configurada y rechazada.


Regiones rectangulares

Las regiones rectangulares son el medio más común de definir una inspección. Pueden redimensionarse en segmentos de arco o en regiones anulares para adaptarlas a su aplicación particular.

Closed Leyenda de región rectangular

 | Controles | Descripción
1 | Límite de punto final redimensionable (x4) | Define las cuatro esquinas de la región rectangular. Haga clic en un límite de punto final para redimensionar la región desde una de sus esquinas.
2 | Indicador de dirección de exploración (x2) | Define en qué dirección la región rectangular buscará características.
3 | Controlador de doblado | Permite doblar la región rectangular para transformarla en un arco o darle forma anular.
4 | Controlador de rotación | Permite girar la región 360°.
Closed Acciones del ratón en regiones rectangulares

 | Controles | Descripción
1 | Mover | Si coloca el cursor del ratón dentro de la región, el icono de dicho cursor se transforma automáticamente y permite arrastrar la región a cualquier lugar de la imagen.
2 | Curvar | Si coloca el cursor sobre el controlador de curva, el icono del cursor del ratón se transforma automáticamente y permite remodelar la región rectangular para convertirla en una forma de arco o anular. A continuación puede cambiar el tamaño de los cuatro lados de la forma para convertirla en una forma circular, por ejemplo.
3 | Cambiar el tamaño | Si coloca el cursor sobre cualquiera de los cuatro límites del extremo o punto terminal, o bien a lo largo de cualquiera de los cuatro lados, el icono del cursor del ratón se transforma automáticamente y permite arrastrar la región para cambiar su tamaño.
4 | Girar | Si coloca el cursor sobre el controlador de giro, el icono del cursor del ratón se transforma automáticamente y permite girar la región 360° respecto a su orientación actual.
Closed Dirección de exploración en regiones rectangulares

 | Controles | Descripción
1 | Parte superior | Indica que la exploración se efectuará en sentido horizontal.
2 | Lateral | Indica que la exploración se efectuará en sentido vertical.
Closed Códigos de colores en regiones rectangulares

 | Descripción
1 | Una región rectangular recientemente añadida y no seleccionada.
2 | Una región rectangular seleccionada y no confirmada.
3 | Una región rectangular seleccionada, configurada y aceptada.
4 | Una región rectangular no seleccionada, configurada y aceptada.
5 | Una región rectangular seleccionada, configurada y rechazada.
6 | Una región rectangular no seleccionada, configurada y rechazada.


Elemento

Las herramientas de ubicación en el paso Detectar pieza crean una salida conocida como elemento (“fixture”), que actúa como punto de referencia para otras herramientas de inspección visual.

A la hora de crear un elemento, observe su pieza en la imagen y determine qué tipo de característica – un patrón, margen, círculo o blob – puede reconocerse con mayor rapidez y facilidad y aparecerá en todas las imágenes de la pieza. Seguidamente, basándose en el tipo de característica en su pieza, seleccione una herramienta de ubicación apropiada para definir dicha característica.

Si se utiliza una característica como elemento durante una inspección, el sensor In-Sight primero buscará dicha característica. Cuando la haya localizado, su posición se utilizará como punto de referencia para las demás herramientas de inspección visual, que utilizan la posición de la característica para orientar sus regiones.

Closed Ejemplo - Tarea con un elemento de patrón

Closed Ejemplo - Tarea sin un elemento

Notas:
  • No se precisa un elemento si la pieza se va a presentar al sensor In-Sight en la misma ubicación exacta en cada imagen.
  • En una tarea se puede crear y utilizar más de un elemento. Los elementos se pueden interconectar.
  • Las siguientes herramientas de inspección producen un elemento que puede ser utilizado por otras herramientas: herramienta de presencia/ausencia de márgenes, herramienta de presencia/ausencia de patrones PatMax, herramienta de presencia/ausencia de patrones, herramienta de identificación "Leer código de ID", herramienta de identificación de patrones PatMax, herramienta de identificación de patrones, herramienta de medición de ángulos, herramienta de medición de distancias, herramienta de medición de concentricidad de círculos, herramienta de medición de diámetros de círculos, herramienta de geometría "Punto a punto: Punto medio" y herramienta de geometría "Círculo a partir de N puntos".


Elección de una herramienta de ubicación

Examine la pieza y determine qué tipo de elemento (o elementos) cumple los requisitos de su aplicación.

  • Patrón PatMax RedLine™
  • Patrón PatMax®
  • Patrón
  • Patrones PatMax RedLine™ (1-10)
  • Patrones PatMax® (1-10)
  • Patrones (1-10)
  • Margen
  • Intersección de márgenes
  • Blob
  • Blobs (1-10)
  • Blob de color
  • Blobs de color (1-10)
  • Círculo
  • Calcular elemento


Herramientas de ubicación - Patrón PatMax RedLine, Patrón PatMax, Patrones PatMax RedLine (1-10) y Patrones PatMax (1-10)

Notas:
  • A partir del firmware de In-Sight 5.5.0 y posteriores, el algoritmo de la herramienta se ha modificado para obtener resultados más precisos y reducir el tiempo de ejecución en determinadas circunstancias.
  • Debido a esta modificación, aparecerá un mensaje de error si intenta cargar una tarea en la que esta herramienta esté configurada con el firmware de In-Sight 5.5.0 o posterior en un sistema de visión In-Sight con una versión de firmware 5.4.x o anterior.
  • La herramienta de ubicación de patrón PatMax RedLine y la herramienta de ubicación de patrones PatMax RedLine (1-10) solo están disponibles en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de ubicación de patrón PatMax RedLine, herramienta de ubicación de patrón PatMax, herramienta de ubicación de patrones PatMax RedLine (1-10) y herramienta de ubicación de patrones PatMax (1-10) se utilizan para localizar la posición de las características de patrón mediante el algoritmo PatMax RedLine o PatMax y según una representación entrenada de dicho patrón (que se denomina Modelo). Las herramientas Patrón PatMax RedLine y Patrón PatMax se utilizan para localizar un único patrón, mientras que las herramientas Patrones PatMax RedLine (1-10) y Patrones PatMax (1-10) se utilizan para localizar hasta 10 patrones.

Nota: La herramienta informa de las coordenadas X,Y en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Estas herramientas son útiles en aplicaciones que requieren un posicionamiento preciso, como las aplicaciones de robótica guiadas por visión. Las herramientas también resultan muy útiles como elementos para otras herramientas de visión al orientar su búsqueda en la imagen.

  1. Configuración de la herramienta de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10)
    1. Selección de una característica de patrón
    2. Patrones PatMax RedLine, Patrones PatMax y Patrones
  2. Ajuste de los parámetros de las herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10)
  3. Uso de las propiedades de entrada/salida de las herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10)


Configuración de las herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10)

Una vez agregada la herramienta, deberá seleccionar el tipo de regiones y configurarlas para definir su patrón (la región Modelo), y en qué lugar de la imagen se encontrará el modelo (la región de Búsqueda).

  1. En el menú desplegable Modelo, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Después coloque la región Modelo sobre el patrón que se utilizará como modelo de entrenamiento; asegúrese de que la región Modelo cubra únicamente las características importantes del patrón.Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.
  2. En el menú desplegable Buscar, seleccione el tipo de región: Rectángulo (predeterminado), Círculo, Espacio anular o Polígono. A continuación, sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.

  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  4. La región Modelo se reemplazará por el icono [image], que indica la ubicación y la orientación angular del patrón encontrado.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Selección de una característica de patrón

A la hora de elegir el patrón que se utilizará en su inspección, tenga en cuenta los siguientes criterios para asegurarse los mejores resultados:

  • El patrón debe estar continuamente presente en cada imagen.
  • El patrón de contener tantas características únicas y continuamente presentes como sea posible, y las características que componen el patrón deben ser coherentes entre sí tanto en su apariencia como en su geometría, así como estar claramente definidas.
  • A ser posible, elija un patrón más grande; generalmente, los patrones grandes presentan características más distintivas que hacen posible una detección más constante y precisa.


Patrones PatMax RedLine, Patrones PatMax y Patrones

Nota: La herramienta de ubicación de patrón PatMax RedLine y la herramienta de ubicación de patrones PatMax RedLine (1-10) solo están disponibles en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

Las herramientas Patrones PatMax RedLine, Patrones PatMax y Patrones localizan modelos de patrones entrenados y ofrecen la máxima precisión de entre todas las herramientas de ubicación e inspección. Sin embargo, las herramientas Patrones PatMax RedLine y Patrones PatMax son más potentes que la herramienta Patrones al contabilizar más cambios de las condiciones de iluminación y la posición del patrón. Asimismo, ofrecen un reconocimiento superior de los cambios de escala y rotación del patrón, de la oclusión de elementos del patrón y de cambios del aspecto del patrón debidos a variaciones de iluminación.

La principal diferencia entre los patrones PatMax RedLine y los patrones PatMax es la velocidad; el patrón PatMax RedLine utiliza el algoritmo de coincidencia de patrones más reciente y puede localizar características entrenadas en una imagen de 5 megapíxeles hasta 7 veces más rápido que los patrones PatMax. Por lo tanto, la herramienta Patrones PatMax RedLine es ideal para sistemas de visión de alta resolución.

La herramienta Patrones es (en la mayoría de los casos) más rápida que la herramienta PatMax, pero ciertas situaciones requieren la precisión y fiabilidad de la versión PatMax RedLine o PatMax:

  • Cuando las variaciones de iluminación y los reflejos son difíciles de controlar. Por ejemplo, las piezas metálicas pueden reflejar la luz en direcciones aleatorias.
  • Cuando el patrón que se inspecciona presenta formas o sombras similares en comparación con algo situado en el fondo o si otros objetos de la imagen se solapan con el patrón o lo ocultan parcialmente.
  • Cuando se desea reconocer con precisión un tipo de patrón frente a otros patrones similares.
  • Cuando las condiciones del entorno de la implementación son demasiado difíciles para que la herramienta Patrones pueda funcionar de forma coherente y fiable.


Ajuste de los parámetros de las herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10) consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Fichas Modelo y Buscar
  • Ficha Imagen entrenada
  • Ficha Tabla

Nota: La ficha Tabla solo está habilitada en las herramientas de ubicación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) .

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección que se utilizará en la configuración de resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Patron_1" (si se trata de la primera herramienta de patrones agregada a la tarea; de lo contrato, se incrementará, es decir, "Patron_2", "Patron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - ficha Ajustes

Closed Número a buscar

Define el número de instancias del patrón Modelo que se desea detectar (1-10; valor predeterminado = 1). La mayoría de las aplicaciones sólo requieren un único elemento. No obstante, pueden localizarse múltiples instancias del patrón Modelo, lo cual resulta útil en aplicaciones cuyas imágenes contienen más de una pieza u objeto. El tiempo de ejecución de la herramienta aumenta con el número de instancias entrenadas que deba identificar.

Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Umbral de contraste

Define el contraste mínimo aceptable que debe estar presente en el patrón encontrado; el contraste de un patrón encontrado debe ser mayor que el valor de Umbral de contraste para que se considere una instancia válida. El valor predeterminado para el patrón o los patrones PatMax RedLine es 0 y el rango de parámetros válido es 0-100. El valor predeterminado para el patrón o los patrones PatMax es 10 y el rango de parámetros válido es 0-255. Un valor de Umbral de contraste bajo se utiliza para imágenes de bajo contraste, mientras que un valor de Umbral de contraste alto se utiliza para imágenes de alto contraste.

Nota: El contraste del patrón o los patrones PatMax RedLine es la medición "relativa" del cambio de contraste entre las características del patrón entrenado y las características coincidentes en la imagen de búsqueda, en porcentaje. Por lo tanto, si el contraste de las características es similar o más alto en relación con el contraste del patrón, el contraste comunicado será ~100. Si el contraste de las características es más bajo que el contraste del patrón, el contraste comunicado será <100. El contraste del patrón o los patrones PatMax RedLine es diferente del contraste del patrón o los patrones PatMax, que es el contraste "absoluto" de la imagen del ROI buscado, en nivel de escala de grises.

Closed Tolerancia de rotación

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define el porcentaje de escalado admisible (variaciones de tamaño) entre el patrón encontrado y el patrón Modelo (0-50; valor predeterminado = 0). El valor es un porcentaje positivo o negativo, p. ej., un valor de 5 permitirá que la herramienta encuentre patrones que están entre el 95 % y el 105 % del tamaño del patrón Modelo. Cuanto mayor sea el rango admisible de variación de escala del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Modo Buscar

Define el modo de búsqueda utilizado para entrenar y reconocer patrones, PatMax o PatQuick. La opción PatMax está seleccionada de forma predeterminada. PatMax ofrece mayor precisión que PatQuick, pero requiere más tiempo de ejecución, mientras que PatQuick ofrece menor precisión que PatMax, pero requiere menos tiempo de ejecución.

Closed Puntuación estricta

Define si las características ocluidas del patrón encontrado o las que faltan en él repercutirán o no en la puntuación (valor predeterminado = desactivado). Cuando se aplica la opción Puntuación estricta (activada), se reducirá la puntuación del patrón encontrado si hay características del patrón ausentes o bloqueadas.

Closed Ignorar polaridad

Define si los patrones encontrados pueden contener características de coincidencia de colores invertidos, con respecto al patrón Modelo (ajuste predeterminado = desactivado, desmarcado). Con la opción Ignorar polaridad aplicada (activada, marcada), los patrones en los que se detecten características de colores invertidos, tales como negro/blanco frente a blanco/negro en el patrón Modelo, se clasificarán como coincidencias con el patrón Modelo.

Closed Ordenar por

Define cómo se clasifican los patrones encontrados, por Puntuación (el valor predeterminado), X o Y. Si se selecciona Puntuación, los patrones encontrados se clasificarán en función de su puntuación; el patrón con la puntuación más elevada aparecerá el primero en la lista e irá seguido de los patrones subsiguientes en orden descendente. Si se selecciona X, los patrones encontrados se clasificarán en función de su distancia del eje X, desde el más cercano al más lejano, en orden descendente. Si se selecciona Y, los patrones encontrados se clasificarán en función de su distancia del eje Y, desde el más cercano al más lejano, en orden descendente.

Closed Desviación horizontal

Define una posición de desviación horizontal (medida en píxeles) desde el centro del patrón encontrado, con respecto al patrón Modelo entrenado. Esto permite asignar coordenadas alejadas del centro del patrón Modelo, lo que resulta útil para definir puntos de referencia en aplicaciones robóticas guiadas por visión artificial.

Closed Desviación vertical

Define una posición de desviación vertical (medida en píxeles) desde el centro del patrón encontrado, con respecto al patrón Modelo entrenado. Esto permite asignar coordenadas alejadas del centro del patrón Modelo, lo que resulta útil para definir puntos de referencia en aplicaciones robóticas guiadas por visión artificial.

Closed Tiempo de espera
Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo. Este parámetro se establece de forma predeterminada en 5000.
Closed Resultado

Visualiza las coordenadas X,Y del centro del patrón encontrado y su orientación angular, así como su puntuación comparativa con respecto al patrón Modelo. Si se aplicara una desviación horizontal y/o vertical, las coordenadas X,Y se ajustarían en función de las cantidades especificadas en los campos de desviación.

Nota: Si el parámetro Número a buscar se establece con un valor superior a 1, el Resultado mostrado siempre será el patrón encontrado con la puntuación más alta, salvo que el parámetro Ordenar por se haya ajustado a X o a Y.

Notas:
  • Las herramientas de ubicación de patrón PatMax RedLine y patrones PatMax RedLine (1-10) no incluyen el parámetro Modo Buscar.
  • Los parámetros Número a buscar y Ordenar por solo se admiten en las herramientas de ubicación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) .


Herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - fichas Modelo y Buscar

Las fichas Modelo y Buscar sirven para configurar la región compuesta de las regiones Modelo y Buscar de la herramienta. Las regiones compuestas sirve son una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • En la ficha Modelo, las regiones compuestas solo se activan tras pulsar el botón Región modelo.
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Herramientas de ubicación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - ficha Tabla

La tabla creada en la ficha Tabla publica los resultados de los patrones encontrados:

Closed Índice

Se refiere al orden de los patrones encontrados; 1 a 10 (en EasyBuilder, el orden numérico se basa en 0=1).

Closed X

Hace referencia al centro de la coordenada X del patrón encontrado. Si se ha aplicado una desviación horizontal, la coordenada X se ajustará en función de la cantidad especificada.

Closed Y

Hace referencia al centro de la coordenada Y del patrón encontrado. Si se ha aplicado una desviación vertical, la coordenada Y se ajustará en función de la cantidad especificada.

Closed Ángulo

Hace referencia al ángulo del patrón encontrado con relación al patrón modelo.

Closed Puntuación

Indica en qué medida el patrón encontrado se asemeja al patrón modelo.

Closed Escala

Hace referencia a la escala del patrón encontrado.


Uso de las propiedades de entrada/salida de las herramientas de ubicación de patrón PatMax RedLine, patrón PatMax, patrones PatMax RedLine (1-10) y patrones PatMax (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Umbral_Contraste | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Nuevo_Entrenamiento_Externo | I | X | Entrada/Salida
Buscar_Modo1 | I | X | X | Entrada/Salida
Desplazamiento_Horizontal | FP | X | X | Entrada/Salida
Ignorar_Polaridad | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Tolerancia_Rotacion | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Puntuacion_Estricta | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Desplazamiento_Vertical | FP | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X | Salida
Recuento_Rechazos | I | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.Puntuacion | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Elemento.Escala | FP | X | X | Salida
Aceptacion | I | X | Salida
Recuento_Aceptaciones | I | X | X | Salida
Patrones | S | X | X | Salida
Resultado | S | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Modelo | A | X | X
Entrenar | A | X | X
Buscar | A | X | X
Numero_A_Buscar2 | I | X | X | Entrada/Salida
Ordenar_Por2 | I | X | X | Entrada/Salida
Elemento1-9.Angulo2,3 | FP | X | X | Salida
Elemento1-9.Puntuacion2,3 | FP | X | X | Salida
Elemento1-9.X2,3 | FP | X | X | Salida
Elemento1-9.Y2,3 | FP | X | X | Salida
Elemento1-9.Escala2,3 | FP | X | X | Salida
Numero_Encontrado2 | FP | X | X | Salida

1 Esta propiedad de herramienta solo está disponible en las herramientas de ubicación de patrón PatMax y patrones PatMax (1-10).

2 Estas propiedades de herramienta solo están disponibles en las herramientas de ubicación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10).

3 Elemento 1-9 se refiere a las diez iteraciones de las salidas del elemento (es decir, Elemento1, Elemento2, Elemento3, etc.) correspondiente a las herramientas de ubicación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10).


Herramientas de ubicación - Patrón y Patrones (1-10)

La herramienta de ubicación de patrón y la herramienta de ubicación de patrones (1-10) se utilizan para localizar la posición de las características de patrón mediante el algoritmo PatFind® y según una representación entrenada de dicho patrón (que se denomina Modelo). La herramienta Patrón se utiliza para localizar un único patrón, mientras que la herramienta Patrones (1-10) se utiliza para localizar hasta 10 patrones.

La herramienta de ubicación de patrón y la herramienta de ubicación de patrones (1-10) son útiles en aplicaciones que requieren un posicionamiento preciso, como las aplicaciones de robótica guiadas por visión. Las herramientas también resultan muy útiles como elementos para otras herramientas de visión al orientar su búsqueda en la imagen.

Nota: El sensor de visión In-Sight de la serie 2000 no es compatible con la herramienta de ubicación Patrones (1-10).

  1. Configuración de la herramienta de ubicación de patrón y patrones (1-10)
    1. Selección de una característica de patrón
    2. Patrones PatMax RedLine, Patrones PatMax y Patrones
  2. Ajuste de los parámetros de la herramienta de ubicación de patrón y patrones (1-10)
  3. Uso de las propiedades de entrada/salida de la herramienta de ubicación de patrón y patrones (1-10)

La herramienta comunica los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight 2000-110 y 2000-120/120C | Solo estado de aceptación/rechazo
Sensor de visión In-Sight 2000-130/130C | Estado de aprobado/rechazado y puntuación de patrón
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Coordenadas X/Y*, orientación angular, puntuación y estado de aceptación o rechazo
* La herramienta informa de las coordenadas X,Y en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.


Configuración de las herramientas de ubicación Patrón y Patrones (1-10)

Cuando haya agregado la herramienta, deberá configurar las regiones de la imagen que definirán su patrón (la región Modelo), y dónde se encontrará el patrón en la imagen (la región de Búsqueda).

  1. Sitúe la región Modelo sobre el patrón que se utilizará como patrón de entrenamiento; asegúrese de que la región Modelo cubra solamente las características importantes del patrón.

  2. Sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.

Nota: Las regiones Modelo y Búsqueda no se pueden doblar para formar un arco o un anillo.

  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  4. La región Modelo será reemplazada por el icono [image], indicando la ubicación y orientación angular del patrón encontrado.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de las herramientas de ubicación Patrón y Patrones (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Nota: El sensor de visión In-Sight de la serie 2000 no es compatible con la herramienta de ubicación Patrones (1-10).

Sistemas de visión In-Sight

Los paneles de ajustes de las herramientas de ubicación Patrón y Patrones (1-10) constan de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Imagen entrenada
  • Ficha Tabla

Nota: La fichaTabla solo está habilitada para la herramienta de ubicación Patrones (1-10).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de ubicación Patrón

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a los sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de las herramientas de ubicación Patrón y Patrones (1-10).

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Closed Indicador de aceptaciones/rechazos

Muestra un círculo verde [image] o un rectángulo rojo [image] para indicar el éxito o el fallo en cada caso.

Closed Tolerancia de rotación

Define en qué medida se puede girar el patrón encontrado desde la posición del modelo entrenado sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 45°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta. El controlador izquierdo establece la tolerancia de rotación negativa y el controlador derecho, la tolerancia de rotación positiva. Puede ajustar la tolerancia de rotación moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Closed Medidor de localización de piezas

El medidor de localización de piezas muestra si la herramienta ha encontrado correctamente la característica y establece el umbral de aceptación mínimo. Puede establecer de forma manual el valor mínimo del umbral de aceptación (0 - 100; valor predeterminado = 50) mediante el ajuste del controlador o la introducción de un valor en el cuadro de edición correspondiente.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Si el medidor supera el umbral, la herramienta considerará que ha encontrado esa pieza y el medidor cambia a color verde. Si es inferior al umbral, considerará que no ha encontrado la pieza y el medidor desaparece. Si la herramienta detecta cosas que no son piezas o si detecta una característica errónea, mueva el controlador hacia la derecha. Si la herramienta no detecta algunas piezas, mueva el controlador hacia la izquierda (o cree una región modelo nueva). Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

ACEPTACIÓN
RECHAZO

Nota: Al pasar el ratón sobre el control deslizante se muestra los valores de resultado y de umbral.

Closed Tolerancia de escala de ± 10 %

Define si la herramienta permite o no una variación de tamaño de ±10 % entre el patrón encontrado y el patrón modelo.

Patrón entrenado | Patrón encontrado: +10 % | Patrón encontrado: -10%
Desactivado (valor predeterminado) | (Rechazo) | (Rechazo)
Activado | (Aceptación) | (Aceptación)
Closed Usar tiempo de espera manual

Define si se aplica o no el ajuste de tiempo de espera.

  • Desactivado (valor predeterminado): el tiempo de espera está deshabilitado (no hay tiempo de espera).

  • Activado: el tiempo de espera está habilitado (no hay tiempo de espera). Puede definir de forma manual el valor de tiempo de espera en milisegundos (0 a 30000) mediante el cuadro de edición.

    Nota: Si este valor se ajusta a 0, el ajuste se desactivará y el tiempo de espera no se aplicará.
Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Nombre

Define el nombre de su herramienta de inspección. El nombre predeterminado es "Patron_1" (si es la primera herramienta Patrón añadida a la tarea; de lo contrario, se incrementará, p. ej., "Patron_2", "Patron_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Entrenar entrada

Define si se entrena o no un patrón Modelo sobre una línea de entrada (el ajuste predeterminado es "Off": deshabilitado).

  • Entrada: Entrena un patrón Modelo sobre una línea de entrada. La línea de entrada seleccionada se utilizará como señal de entrenamiento.

    Notas:
    • Esta opción no aparecerá si el sistema de visión In-Sight no dispone de entradas discretas (por ejemplo, el sistema de visión In-Sight de la serie 8000 utiliza E/S directa).
    • El tipo de señal de la línea de entrada seleccionada debe estar fijado en Disparador de evento en el paso de aplicación Entradas/Salidas.
    • El entrenamiento de un patrón Modelo utilizará la imagen más reciente que haya adquirido el sensor/sistema de visión. No es necesario volver a lanzar el sensor/sistema de visión para el entrenamiento.
    • Para obtener más información, consulte Entradas: Entrenamiento de un patrón Modelo sobre una línea de entrada
Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Región modelo

La imagen es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Herramientas de ubicación de patrón y de patrones (1-10) - ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección que se utilizará en la configuración de resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Patron_1" (si se trata de la primera herramienta de patrones agregada a la tarea; de lo contrato, se incrementará, es decir, "Patron_2", "Patron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de ubicación de patrón y de patrones (1-10) - Ficha Ajustes

Closed Entrenar entrada

Define si se entrena o no un patrón Modelo sobre una línea de entrada (el ajuste predeterminado es "Off": deshabilitado).

  • Entrada: Entrena un patrón Modelo sobre una línea de entrada. La línea de entrada seleccionada se utilizará como señal de entrenamiento.

    Notas:
    • Esta opción no aparecerá si el sistema de visión In-Sight no dispone de entradas discretas (por ejemplo, el sistema de visión In-Sight de la serie 8000 utiliza E/S directa).
    • El tipo de señal de la línea de entrada seleccionada debe estar fijado en Disparador de evento en el paso de aplicación Entradas/Salidas.
    • El entrenamiento de un patrón Modelo utilizará la imagen más reciente que haya adquirido el sensor/sistema de visión. No es necesario volver a lanzar el sensor/sistema de visión para el entrenamiento.
    • Para obtener más información, consulte Entradas: Entrenamiento de un patrón Modelo sobre una línea de entrada
Closed Número a buscar

Define el número de instancias del patrón Modelo que se desea detectar (1-10; valor predeterminado = 1). La mayoría de las aplicaciones sólo requieren un único elemento. No obstante, pueden localizarse múltiples instancias del patrón Modelo, lo cual resulta útil en aplicaciones cuyas imágenes contienen más de una pieza u objeto. El tiempo de ejecución de la herramienta aumenta con el número de instancias entrenadas que deba identificar.

Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Tolerancia de rotación

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define el porcentaje de escalado admisible (variaciones de tamaño con un margen de ±10%) entre el patrón encontrado y el patrón Modelo. De forma predeterminada, este ajuste está desactivado (sin marcar), por lo que se deshabilitan los ajustes de la escala. En este modo de operación, la herramienta todavía encontrará patrones que se encuentren en un rango de ±10%, pero la puntuación de la característica se reducirá según aumente el porcentaje de la escala.

Closed Ordenar por

Define la forma en que se clasificarán los patrones, Puntuación (predeterminado), X o Y. Si se selecciona Puntuación, los patrones encontrados se clasificarán en función de su puntuación, el patrón con la puntuación más elevada aparecerá el primero en la lista e irá seguido de los patrones subsiguientes en orden descendente. Si se selecciona X, los patrones encontrados se clasificarán en función de su distancia del eje X, desde el más cercano al más lejano, en orden descendente. Si se selecciona Y, los patrones encontrados se clasificarán en función de su distancia del eje Y, desde el más cercano al más lejano, en orden descendente.

Closed Desviación horizontal

Define una posición de desviación horizontal (medida en píxeles) desde el centro del patrón encontrado, con respecto al patrón Modelo entrenado. Esto permite asignar coordenadas alejadas del centro del patrón Modelo, lo que resulta útil para definir puntos de referencia en aplicaciones robóticas guiadas por visión artificial.

Closed Desviación vertical

Define una posición de desviación vertical (medida en píxeles) desde el centro del patrón encontrado, con respecto al patrón Modelo entrenado. Esto permite asignar coordenadas alejadas del centro del patrón Modelo, lo que resulta útil para definir puntos de referencia en aplicaciones robóticas guiadas por visión artificial.

Closed Tipo de modelo

Define cómo la herramienta debe construir el patrón Modelo, Modelo de área o Modelo de margen (predeterminado). Modelo de área crea el patrón Modelo a partir de un muestreo de uniformidad de los valores de escala de grises contenidos en la región Modelo. Modelo de margen crea el patrón Modelo basándose en los márgenes detectados (transiciones entre claro y oscuro) de la característica del patrón dentro de la región Modelo.

Closed Precisión

Define cómo la herramienta evaluará el compromiso entre exactitud/fiabilidad frente a velocidad de ejecución; Exacto, Medio (preajuste) y Rápido. Exacto prioriza la precisión y la fiabilidad, reduciendo la velocidad de ejecución, Rápido favorece la velocidad de ejecución a costa de la precisión y fiabilidad, mientras que Mediano es un equilibrio entre las dos primeras opciones.

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo.

Closed Resultado

Visualiza las coordenadas X,Y del centro del patrón encontrado y su orientación angular, así como su puntuación comparativa con respecto al patrón Modelo. Si se aplicara una desviación horizontal y/o vertical, las coordenadas X,Y se ajustarían en función de las cantidades especificadas en los campos de desviación.

Nota: Si el parámetro Número a buscar se establece con un valor superior a 1, el Resultado mostrado siempre será el patrón encontrado con la puntuación más alta, salvo que el parámetro Ordenar por se haya ajustado a X o a Y.

Nota: La herramienta de ubicación de patrones PatMax no contiene los parámetros Número a buscar ni Ordenar por.


Herramienta de ubicación de patrones (1-10) - ficha Tabla

La tabla creada en la ficha Tabla publica los resultados de los patrones encontrados:

Closed Índice

Se refiere al orden de los patrones encontrados: 1 a 10 (el orden numérico en EasyBuilder asume que 0=1).

Closed X

Se refiere al centro de la coordenada X del patrón encontrado.

Closed Y

Se refiere al centro de la coordenada Y del patrón encontrado.

Closed Ángulo

Se refiere al ángulo del patrón encontrado con respecto al patrón Modelo.

Closed Puntuación

Indica el grado de similitud del patrón encontrado con respecto al patrón Modelo.


Herramientas de ubicación de patrón y de patrones (1-10) - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de las herramientas de ubicación Patrón y Patrones (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | Entrada
Precisión | I |  | Entrada
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Entrenamiento_Externo | I |  | Entrada
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Elemento.Puntuacion* | FP | X | Salida
Desplazamiento_Horizontal | FP |  | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Modelo | A | X |
Tipo_Modelo | I |  | Entrada
Aceptacion | I |  | Salida
Recuento_Aceptaciones | I | X |
Resultado | S | X |
Tolerancia_Rotacion | I | X | Entrada
Escala_Tolerancia | I | X | Entrada
Buscar | A | X |
Estado | I | X |
Tiempo de espera | I | X | Entrada
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |
Entrenar | A | X |
Desplazamiento_Vertical | FP |  | Entrada
*Sensores de visión In-Sight 2000-130/130C solamente

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | Entrada/Salida
Precisión | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Entrenamiento_Externo | I |  | Entrada/Salida
Desplazamiento_Horizontal | FP | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Tipo_Modelo | I | X | Entrada/Salida
Tolerancia_Rotacion | I | X | Entrada/Salida
Escala_Tolerancia | I | X | Entrada/Salida
Tiempo de espera | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Desplazamiento_Vertical | FP | X | Entrada/Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | I |  | Salida
Recuento_Rechazos | I | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.Puntuacion | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptacion | I |  | Salida
Recuento_Aceptaciones | I | X | Salida
Patrones | S | X | Salida
Resultado | S | X | Salida
Estado | I | X | Salida
Herramienta_Estado_Habilitado | I | X | Salida
Modelo | A | X |
Buscar | A | X |
Entrenar | A | X |
Entrenar_Entrada | I | X | Entrada/Salida
Elemento.Angulo | FP | X | Salida
Elemento.Puntuacion | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Precisión | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Entrenamiento_Externo | I | X |  | Entrada/Salida
Desplazamiento_Horizontal | FP | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Tipo_Modelo | I | X | X | Entrada/Salida
Tolerancia_Rotacion | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Tiempo de espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Desplazamiento_Vertical | FP | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  | Salida
Recuento_Rechazos | I | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.Puntuacion | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptacion | I | X |  | Salida
Recuento_Aceptaciones | I | X | X | Salida
Patrones | S | X | X | Salida
Resultado | S | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Numero_A_Buscar1 | I | X | X | Entrada/Salida
Ordenar_Por1 | I | X | X | Entrada/Salida
Modelo | A | X | X |
Buscar | A | X | X |
Entrenar | A | X | X |
Entrenar_Entrada | I | X | X | Entrada/Salida
Elemento1-9.Angulo1,2 | FP | X | X | Salida
Elemento1-9.Puntuacion1,2 | FP | X | X | Salida
Elemento1-9.X1,2 | FP | X | X | Salida
Elemento1-9.Y1,2 | FP | X | X | Salida
Numero_Encontrado1 | I | X | X |
1 Estas propiedades de herramienta solo están disponibles en la herramienta de ubicación de patrones PatMax (1-10). 2 Elemento 1-9 se refiere a las diez iteraciones de las salidas del elemento (es decir, Elemento1, Elemento2, Elemento3, etc.) correspondiente a la herramienta de ubicación de patrones PatMax (1-10).


Herramientas de ubicación - Margen

La herramienta de ubicación Margen se utiliza para localizar características de margen lineal en el ámbito de los parámetros especificados.

La herramienta de ubicación Margen es una de las herramientas rápidas con la capacidad de reconocer características de margen con mucha más rapidez que una herramienta de ubicación Patrón. Esta herramienta también es útil como un elemento para otras herramientas de visión cuando la característica de margen tiene un contraste alto, se desplaza solo en una dirección (horizontal o vertical) y no experimenta ningún giro más allá de 10°.

  1. Configuración de la herramienta de ubicación Margen
  2. Ajuste de los parámetros de la herramienta de ubicación Margen
  3. Uso de las propiedades de entrada/salida de la herramienta de ubicación Margen

La herramienta comunica los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Coordenadas X,Y del punto medio del margen encontrado*, orientación angular y estado de aceptación y rechazo.
* La herramienta informa de las coordenadas X,Y en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.


Configuración de la herramienta de ubicación Margen

Una vez añadida la herramienta, deberá configurar la característica de margen que se utilizará como elemento:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Seleccione un margen de entre las características disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).
  3. Confirme la selección presionando el botón Aceptar (presione el botón Cancelar si prefiere no añadir la herramienta a la tarea). EasyBuilder creará automáticamente una región de margen alrededor de la característica de margen e insertará un icono [image], que indica la ubicación y orientación angular del círculo encontrado.

Nota: La región en torno al margen detectado se puede rotar o redimensionar según sea necesario.

  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de ubicación Edge

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta Ubicación de márgenes consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de ubicación Margen - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Margen_1" (si se trata de la primera herramienta de Margen agregada a la tarea; de lo contrario, se incrementará, es decir, "Margen_2", "Margen_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de ubicación de márgenes - Ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un "ajuste inteligente" que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta (su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable).

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Las flechas de dirección de exploración de la región indican en qué dirección EasyBuilder explorará en busca del margen. Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar por

Define cómo la herramienta debe discriminar los márgenes encontrados cuando hay múltiples márgenes presentes (valor predeterminado = Mejor puntuación).

  • Mejor puntuación = La característica de margen que tenga el margen mejor definido (el contraste más alto).
  • Primer margen = La característica de margen más cercana al comienzo de la dirección de exploración de la región.
  • Último margen = La característica de margen más alejada del comienzo de la dirección de exploración de la región.
Closed Rango de ángulos

Define la cantidad máxima de traslación angular que el margen encontrado puede experimentar (0-10°; valor predeterminado = 10°). Cuanto mayor sea la variación angular admisible, más tiempo de ejecución necesitará la herramienta.

Closed Resultado

Muestra las coordenadas X/Y del punto medio del margen encontrado, así como su orientación angular.


Herramienta de ubicación Margen - Gráfico

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta de ubicación Margen

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Rango_Angulos | I |  | Entrada
Descripción | S | X | Entrada
Contraste_Margen | I |  | Entrada
Transicion_Margen | I |  | Entrada
Ancho_Margen | I |  | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Buscar_Por | I |  | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Rango_Angulos | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Buscar_Por | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Márgenes | S | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Región | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Rango_Angulos | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Buscar_Por | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Márgenes | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región | A | X | X |


Herramientas de ubicación - Intersección de márgenes

La herramienta de ubicación Intersección de márgenes se utiliza para identificar el punto de intersección de dos características de margen.

  1. Configuración de la herramienta de ubicación Intersección de márgenes
  2. Ajuste de los parámetros de la herramienta de ubicación Intersección de márgenes
  3. Uso de las propiedades de entrada/salida de la herramienta de ubicación Intersección de márgenes

La herramienta comunica los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Coordenadas X,Y del punto de intersección*, el ángulo de bisección entre los dos márgenes y el estado de aceptación o rechazo.
* La herramienta informa de las coordenadas X,Y en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.


Configuración de la herramienta de ubicación Intersección de márgenes

Una vez agregada la herramienta, deberá definir las características de los márgenes que se intersecarán:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la característica de margen que intersecará.
  4. Una vez seleccionada la segunda característica, EasyBuilder determinará automáticamente el punto de intersección de las líneas e insertará un icono [image] para indicar el punto de intersección y la orientación del punto encontrado. EasyBuilder también insertará automáticamente una herramienta de presencia/ausencia Margen por cada característica de margen no definida previamente.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de ubicación Intersección de márgenes

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de ubicación Intersección de márgenes consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará para configurar los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Intersect_1" (cuando se trata de la primera herramienta de ubicación Intersección de márgenes o Círculo-línea o de la primera herramienta de geometría Intersección de línea añadida a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta añadida, es decir, "Intersect_2", "Intersect_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de ubicación Intersección de márgenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de ubicación - Blob y Blobs (1-10)

La herramienta de ubicación Blob y la herramienta de ubicación Blobs (1-10) localizan las características de blobs que cumplen los parámetros especificados. La herramienta comunica las coordenadas X,Y del centroide del blob encontrado, así como el ángulo del centroide del blob. La herramienta Blob permite localizar un único blob, mientras que la herramienta Blobs (1-10) permite localizar hasta 10 blobs que cumplan los criterios de inspección.

Nota: La herramienta comunica las coordenadas X,Y en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

El funcionamiento de las herramientas de ubicación Blob y Blobs (1-10) se encuentra entre el de las herramientas de márgenes y círculos y el de las herramientas de patrones, siendo incluso capaz de localizar características de blobs más rápidamente que una herramienta de ubicación Patrón. Sin embargo, generalmente necesita más tiempo de ejecución que las herramientas de márgenes o de círculos. Estas herramientas son útiles como elementos para otras herramientas de visión, por ejemplo cuando se desea asociar la inspección a una forma o contorno inclasificable, por ejemplo una mancha de pintura negra sobre fondo blanco, o cuando las variaciones de formas superan los límites admisibles por las herramientas de patrones.

  1. Configuración de las herramientas de ubicación Blob y Blobs (1-10)
  2. Ajuste de los parámetros de las herramientas de ubicación Blob y Blobs (1-10)
  3. Uso de las propiedades de entrada/salida de las herramientas de ubicación Blob y Blobs (1-10)


Configuración de las herramientas de ubicación Blob y Blobs (1-10)

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región donde espere que aparezcan los blobs. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Cuando seleccione un blob como elemento, elija uno que se encuentre aproximadamente en el mismo lugar en todas las imágenes.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez aceptada la región, aparecerá un icono [image] sobre el centroide del blob para indicar la ubicación y orientación de la característica encontrada.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de las herramientas de ubicación Blob y Blobs (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Los paneles de ajustes de la herramienta de ubicación Blob y Blobs (1-10) constan de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Tabla
  • Ficha Histograma
  • Ficha Región compuesta

Nota: La fichaTabla solo está disponible para la herramienta de ubicación Blobs (1-10).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramientas de ubicación Blob y Blobs (1-10) - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Blob_1" (si se trata de la primera herramienta de blob agregada a la tarea; de lo contrario, se incrementará, es decir, "Blob_2", "Blob_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de ubicación Blob y Blobs (1-10) - ficha Ajustes

Closed Modo Umbral

Define el modo de determinación del valor de escala de grises utilizado para separar blobs del fondo. Con la opción "Auto" activada (ajuste predeterminado), cada vez que se adquiere una imagen la herramienta se ajusta a los cambios de luminosidad que se producen entre imágenes sucesivas. Si selecciona Manual, deberá introducir el valor y ajustarlo manualmente.

Closed Umbral de blob

Define el valor de escala de grises utilizado para separar blobs del fondo (0 - 255, si está habilitado). De forma predeterminada, este control está desactivado. Para activarlo, es necesario ajustar Modo de umbral a Manual. Utilice el Histograma para definir el valor óptimo para su aplicación.

Closed Color de blob

Define el color del blob (Negro, Blanco o Cualquiera; valor predeterminado = Cualquiera).

  • Cualquiera = No hay ningún requisito para el color del blob.
  • Negro = Devuelve solamente los blobs por debajo del Umbral de blob.
  • Blanco = Devuelve solamente los blobs por encima del Umbral de blob.
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado – No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado – Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que se intersecan, siempre que cumplan los demás criterios.
Closed Área mínima

Define una restricción de área mínima, en número de píxeles (0 a 900000; valor predeterminado = 100), para todos los blobs detectados; sólo se reconocerán blobs con un área mayor que el área mínima.

Closed Área máxima

Define una restricción de área máxima, en número de píxeles (0 a 900000; valor predeterminado = 100000), para todos los blobs detectados; sólo se reconocerán blobs con un área menor que el área máxima.

Closed Ignorar ángulo

Define si debe registrarse o no la orientación angular del centroide del blob (valor predeterminado = activado, marcado).

Nota: Generalmente, los blobs proporcionan un valor de orientación angular limitado, por lo que este parámetro está activado de forma predeterminada.

Closed Número a buscar

Define el número de blobs que deben detectarse (1 a 10; predeterminado = 1). La mayoría de aplicaciones sólo requieren un único elemento. Sin embargo, pueden localizarse múltiples blobs, lo cual resulta útil en aplicaciones cuyas imágenes contienen más de una pieza u objeto. El tiempo de ejecución de la herramienta aumenta con el número de blobs que la herramienta deba identificar.

Closed Ordenar por

Define cómo la herramienta medirá y clasificará los blobs encontrados (Área, Fila, Columna, Cuadrícula: Fila, luego columna desde el elemento, Cuadrícula: Columna, luego fila desde el elemento, Distancia desde el origen del elemento, Rotación en sentido antihorario desde el eje de fila del elemento, Distancia angular; predeterminado = Área):

  • Área = Ordena por los tamaños de las áreas de los blobs encontrados, de grande a pequeña.
  • Fila = Ordena por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Columna = Ordena por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Fila, luego columna desde el elemento = Ordena por distancias primero a lo largo del eje de fila de la imagen del elemento, y luego por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Columna, luego fila desde el elemento = Ordena por distancias primero a lo largo del eje de columna de la imagen del elemento, y luego por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Distancia desde el origen del elemento = Ordena por distancias desde el origen del elemento al centroide del blob, en orden descendente, de menor a mayor distancia.
  • Rotación en sentido antihorario desde el eje de fila del elemento = Ordena por los ángulos (0 a 360°) medidos desde el eje de fila de la imagen del elemento hasta el segmento de línea definido por el centroide del blob y el origen del elemento, en orden descendente, de menor a mayor distancia.
  • Distancia angular = Ordena por los ángulos absolutos (-180 a 180°) medidos desde el eje de fila de la imagen del elemento hasta un segmento de línea definido por el centroide del blob y el origen del elemento, de menor a mayor distancia.
Closed Resultado

Visualiza las coordenadas X,Y y el ángulo (comunicado siempre como 90° salvo que la casilla de verificación Ignorar ángulo esté desmarcada) del centroide del blob encontrado, así como su puntuación.

Nota: Si el parámetro Número a buscar se establece con un valor superior a 1, el Resultado mostrado siempre será el patrón encontrado con la puntuación más alta, salvo que el parámetro Ordenar por se haya ajustado a X o a Y.

Nota: La herramienta de ubicación Blob no contiene el parámetro Número a buscar.


Herramienta de ubicación Blobs (1-10) - Tabla

Notas:
  • La herramienta de ubicación Blob no ofrece la ficha Tabla; ésta sólo está disponible para la herramienta de ubicación Blobs (1-10).
  • Cuando el parámetro Ordenar por se ajusta a cualquier otra opción distinta de Área, se agregan a la tabla las columnas Fila de píxeles y Columna de píxeles. Fila de píxeles y Columna de píxeles reflejan las coordenadas de la imagen en la cuadrícula bidimensional del sensor de imágenes del sistema de visión In-Sight (las filas y columnas de la matriz), y son los valores intercambiados (Y/X) de las coordenadas del mundo real (X/Y).

  • Con la opción Orientación clásica activada en el cuadro de grupo Calibrar imagen en unidades del mundo real del paso Configurar imagen, las coordenadas X e Y estarán en el mismo espacio de coordenadas que las coordenadas de la imagen (Y/X).

Nota:

La ficha Tabla publica los resultados de los blobs encontrados, dependiendo del parámetro Número a buscar indicado en la ficha Ajustes:

Closed Índice

Se refiere al orden de los blobs encontrados, basándose en el parámetro Ordenar por de la ficha Ajustes; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Y

Devuelve la coordenada Y del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Ángulo

Devuelve el ángulo del centroide del blob encontrado, con respecto al centro de la región.

Closed Área

Devuelve el área del blob encontrado (medido en píxeles).

Closed Fila de píxeles

Devuelve la coordenada (X) de la fila de la imagen correspondiente al centroide del blob encontrado.

Closed Columna de píxeles

Devuelve la coordenada (Y) de la columna de la imagen correspondiente al centroide del blob encontrado.


Herramientas de ubicación Blob y Blobs (1-10) - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramientas de ubicación Blob y Blobs (1-10) - Histograma

El histograma muestra una representación gráfica de los valores de escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • La línea vertical azul indica el umbral que se usa para separar la región de la imagen por píxeles blancos y negros; los valores a la izquierda de la línea se consideran negros y los valores a la derecha de ella se consideran blancos.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de las herramientas de ubicación Blob y Blobs (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color_Blob | I | X | X | Entrada/Salida
Umbral_Blob | I | X | X | Entrada/Salida
Limite | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Ignorar_Angulo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Area_Maxima | FP | X | X | Entrada/Salida
Area_Minima | FP | X | X | Entrada/Salida
Ordenar_Por | I | X | X | Entrada/Salida
Modo_Umbral | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Area | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.Encontrado | I | X | X | Entrada/Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A |  | X |
Numero_A_Buscar1 | I | X | X | Entrada/Salida
Area_Blob1 | FP | X | X | Salida
Area_Blob1-91 | FP | X | X | Salida
Elemento1-9.Angulo1 | FP | X | X | Salida
Elemento1-9.Encontrado1 | I | X | X | Salida
Elemento1-9.X1 | FP | X | X | Salida
Elemento1-9.Y1 | FP | X | X | Salida
Numero_Encontrado1 | FP | X | X | Salida
1 Estas propiedades de herramienta solo están disponibles con la herramienta de ubicación Blobs (1-10).


Herramientas de ubicación - Blob de color y Blobs de color (1-10)

Las herramientas de ubicación Blob de color y Blobs de color (1-10) localizan las características de blobs de color que cumplen los parámetros especificados. Las herramientas comunican las coordenadas X,Y y el ángulo del centroide del blob encontrado. La herramienta Blob de color se utiliza para localizar un solo blob, mientras que la herramienta Blobs de color (1-10) permite localizar hasta 10 blobs que cumplen los criterios de inspección.

Nota: La herramienta comunica las coordenadas X,Y en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

Las herramientas Blob de color y Blobs de color (1-10) hacen referencia a una biblioteca entrenada de modelos de colores y luego determinan el número de píxeles presentes en la región que coinciden con los modelos de colores seleccionados y entrenados en la biblioteca entrenada. A continuación, la herramienta genera una imagen binaria de salida en escala de grises, en la que cada píxel que coincide con un modelo de colores activo se ajusta a blanco (255), mientras que los demás píxeles se ajustan a negro (0). Usando esta imagen de salida binaria, la herramienta busca en la imagen las características de blob creadas por los modelos de colores activos.

  1. Configuración de las herramientas de ubicación Blob de color y Blobs de color (1-10)
  2. Ajuste de los parámetros de las herramientas de ubicación Blob de color y Blobs de color (1-10)
  3. Uso de las propiedades de entrada/salida de las herramientas de ubicación Blob de color y Blobs de color (1-10)


Configuración de las herramientas de ubicación Blob de color y Blobs de color (1-10)

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región donde espere que aparezcan los blobs. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Cuando seleccione un blob como elemento, elija uno que se encuentre aproximadamente en el mismo lugar en todas las imágenes.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:

  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.

  • Si previamente se añadió otra herramienta de color y desea utilizar una biblioteca de colores existente y los correspondientes modelos de colores entrenados, abra la ficha Ajustes, seleccione la biblioteca de colores deseada y después active los modelos de colores deseados activando las casillas correspondientes en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).

  5. Una vez aceptada la región, aparecerá un icono [image] sobre el centroide del blob para indicar la ubicación y orientación de la característica encontrada.

  6. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  7. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de las herramientas de ubicación Blob de color y Blobs de color (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Los paneles de ajustes de las herramientas de ubicación Blobs de color y Blobs de color (1-10) constan de las fichas siguientes:

  • Ficha General
  • Ficha Ajustes
  • Ficha Biblioteca de colores
  • Ficha Tabla
  • Ficha Región compuesta

Nota: La ficha Tabla sólo se activa para la herramienta de ubicación de blobs de color (1-10).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de ubicación de blobs de color - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "BlobColor_1" (si se trata de la primera herramienta de blob de color agregada a la tarea; de lo contrario, se incrementará, es decir, "BlobColor_2", "BlobColor_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de ubicación Blob de color y Blobs de color (1-10) - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"
Closed Área mínima

Define una restricción de área mínima, en número de píxeles (0 a 900000; valor predeterminado = 100), para todos los blobs detectados; sólo se reconocerán blobs con un área mayor que el área mínima.

Closed Área máxima

Define una restricción de área máxima, en número de píxeles (0 a 900000; valor predeterminado = 100000), para todos los blobs detectados; sólo se reconocerán blobs con un área menor que el área máxima.

Closed Ignorar ángulo

Define si debe registrarse o no la orientación angular del centroide del blob (valor predeterminado = activado, marcado).

Nota: Generalmente, los blobs proporcionan un valor de orientación angular limitado, por lo que este parámetro está activado de forma predeterminada.

Closed Número a buscar

Define el número de blobs de color que deben detectarse (1 a 10; predeterminado = 1). La mayoría de aplicaciones sólo requieren un único elemento. Sin embargo, pueden localizarse múltiples blobs, lo cual resulta útil en aplicaciones cuyas imágenes contienen más de una pieza u objeto. El tiempo de ejecución de la herramienta aumenta con el número de blobs que la herramienta deba identificar.

Nota: Este control sólo está disponible para la herramienta de ubicación de blobs de color (1-10).

Closed Ordenar por

Define cómo la herramienta medirá y clasificará los blobs encontrados (Área, Fila, Columna, Cuadrícula: Fila, luego columna desde el elemento, Cuadrícula: Columna, luego fila desde el elemento, Distancia desde el origen del elemento, Rotación en sentido antihorario desde el eje de fila del elemento, Distancia angular; predeterminado = Área):

  • Área = Ordena por los tamaños de las áreas de los blobs encontrados, de grande a pequeña.
  • Fila = Ordena por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Columna = Ordena por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Fila, luego columna desde el elemento = Ordena por distancias primero a lo largo del eje de fila de la imagen del elemento, y luego por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Columna, luego fila desde el elemento = Ordena por distancias primero a lo largo del eje de columna de la imagen del elemento, y luego por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Distancia desde el origen del elemento = Ordena por distancias desde el origen del elemento al centroide del blob, en orden descendente, de menor a mayor distancia.
  • Rotación en sentido antihorario desde el eje de fila del elemento = Ordena por los ángulos (0 a 360°) medidos desde el eje de fila de la imagen del elemento hasta el segmento de línea definido por el centroide del blob y el origen del elemento, en orden descendente, de menor a mayor distancia.
  • Distancia angular = Ordena por los ángulos absolutos (-180 a 180°) medidos desde el eje de fila de la imagen del elemento hasta un segmento de línea definido por el centroide del blob y el origen del elemento, de menor a mayor distancia.
Closed Resultado

Visualiza las coordenadas X,Y y el ángulo (comunicado siempre como 90° salvo que la casilla de verificación Ignorar ángulo esté desmarcada) del centroide del blob encontrado, así como su puntuación.


Herramientas de ubicación Blob de color y Blobs de color (1-10) - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramienta de ubicación de blobs de color (1-10) - ficha Tabla

Notas:
  • La herramienta de ubicación de blobs de color no ofrece la ficha Tabla; sólo está disponible para la herramienta de ubicación de blobs de color (1-10).
  • Cuando el parámetro Ordenar por se ajusta a cualquier otra opción distinta de Área, se agregan a la tabla las columnas Fila de píxeles y Columna de píxeles. Fila de píxeles y Columna de píxeles reflejan las coordenadas de la imagen en la cuadrícula bidimensional del sensor de imágenes del sistema de visión In-Sight (las filas y columnas de la matriz), y son los valores intercambiados (Y/X) de las coordenadas del mundo real (X/Y).

  • Con la opción Orientación clásica activada en el cuadro de grupo Calibrar imagen en unidades del mundo real del paso Configurar imagen, las coordenadas X e Y estarán en el mismo espacio de coordenadas que las coordenadas de la imagen (Y/X).

La ficha Tabla publica los resultados de los blobs encontrados, dependiendo del parámetro Número a buscar indicado en la ficha Ajustes:

Closed Índice

Se refiere al orden de los blobs encontrados, basándose en el parámetro Ordenar por de la ficha Ajustes; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Y

Devuelve la coordenada Y del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Ángulo

Devuelve el ángulo del centroide del blob encontrado, con respecto al centro de la región.

Closed Área

Devuelve el área del blob encontrado (medido en píxeles).

Closed Fila de píxeles

Devuelve la coordenada (X) de la fila de la imagen correspondiente al centroide del blob encontrado.

Closed Columna de píxeles

Devuelve la coordenada (Y) de la columna de la imagen correspondiente al centroide del blob encontrado.


Herramientas de ubicación Blob de color y Blobs de color (1-10) - Biblioteca

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Uso de las propiedades de entrada/salida de las herramientas de ubicación Blob de color y Blobs de color (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite | I | X | X | Entrada/Salida
Biblioteca_Colores | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Habilitar_Aplicar_Modelo_Externo | I | X |  | Entrada/Salida
Ignorar_Angulo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Area_Maxima | FP | X | X | Entrada/Salida
Area_Minima | FP | X | X | Entrada/Salida
Habilitar_Modelo | I | X | X | Entrada/Salida
Habilitar_Seleccionar_Modelo | I | X | X | Entrada/Salida
Ordenar_Por | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Factor_Suavizado | I | X | X | Entrada/Salida
Mostrar_Imagen_Original | I | X | X | Entrada/Salida
Area | FP | X | X | Salida
Blobs | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A | X | X |
Habilitar_Aplicar_Modelo | A | X | X |
Numero_A_Buscar1 | I | X | X | Entrada/Salida
Area1-91 | FP | X | X | Salida
Elemento1-9.Angulo1 | FP | X | X | Salida
Elemento1-9.X1 | FP | X | X | Salida
Elemento1-9.Y1 | FP | X | X | Salida
Numero_Encontrado1 | FP | X | X | Salida
1 Estas propiedades de herramienta solo están disponibles con la herramienta de ubicación Blobs de color (1-10).

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_Evento | A | X | X | Entrada/Salida
Entrenar_Modelo | S | X | X | Entrada/Salida
Entrenar_Operacion | I | X | X | Entrada/Salida
Entrenar_Procedimiento | I | X | X |
Entrenar_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite_Mas_Oscuro | FP | X | X | Entrada/Salida
Limite_Mas_Claro | FP | X | X | Entrada/Salida
Entrenar_Color | S | X | X | Entrada/Salida
Entrenar_Evento | A | X | X |
Entrenar_Region | A | X | X |


Herramientas de ubicación - Círculo

La herramienta de ubicación Círculo se utiliza para localizar una característica circular en el ámbito de los parámetros especificados.

La herramienta de ubicación Círculo es una de las herramientas rápidas con la capacidad de reconocer características de margen con mucha más rapidez que una herramienta de ubicación Patrón. Estas herramientas también son útiles como elementos para otras herramientas de visión cuando se inspeccionan objetos circulares o bien una pieza o un objeto que no gira.

  1. Configuración de la herramienta de ubicación Círculo
  2. Ajuste de los parámetros de la herramienta de ubicación Círculo
  3. Uso de las propiedades de entrada/salida de la herramienta de ubicación Círculo

La herramienta comunica los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Coordenadas X,Y del círculo encontrado (su centro), diámetro* y estado de aceptación o rechazo.
* La herramienta informa de las coordenadas X,Y y el diámetro en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.


Configuración de la herramienta de ubicación Círculo

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá su margen circular:

  1. Sitúe la región circular sobre la característica de margen circular; asegúrese de redimensionarla para hacerla coincidir en tamaño y dimensiones con la característica circular. A la hora de seleccionar un círculo como elemento, asegúrese de que esté presente aproximadamente en la misma ubicación en cada imagen y de que tenga un contraste elevado entre los píxeles claros y oscuros.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. EasyBuilder creará automáticamente una región de margen anular alrededor de la característica de margen circular e insertará un icono [image] indicando la ubicación y orientación angular del círculo encontrado.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de ubicación Circle

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de ubicación Circle consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de ubicación Círculo - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Circulo_1" (si se trata de la primera herramienta de Círculo agregada a la tarea; de lo contrario, se incrementará, es decir, "Circulo_2", "Circulo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de ubicación Círculo - Ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen circular encontrado (1-100; valor predeterminado = un "ajuste inteligente" que disminuye automáticamente hasta que se detecta un margen circular). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta (su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable).

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Las regiones anulares buscan transiciones de margen entre la región anular interior y la región anular exterior; para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar por

Define cómo la herramienta debe discriminar los márgenes circulares encontrados cuando hay múltiples márgenes circulares presentes (valor predeterminado = Mejor puntuación).

  • Mejor puntuación = Se elegirá la característica de margen circular que tenga el margen mejor definido (cuyos niveles de contraste y brillo sean más altos).
  • Círculo más pequeño = Se elegirá la característica de margen circular que tenga el menor diámetro.
  • Círculo más grande = Se elegirá la característica de margen circular que tenga el mayor diámetro.
Closed Resultado

Muestra el diámetro y las coordenadas X,Y del círculo encontrado (comunicado desde su centro).


Herramienta de ubicación Círculo - Gráfico

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta de ubicación Círculo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Contraste_Margen | I |  | Entrada
Transicion_Margen | I |  | Entrada
Ancho_Margen | I |  | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Buscar_Por | I |  | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Buscar_Por | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Espacio_Anular | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Buscar_Por | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Espacio_Anular | A | X | X |


Herramientas de ubicación - Calcular elemento

La herramienta de ubicación Calcular elemento se utiliza para calcular la ubicación de un elemento basándose en expresiones matemáticas relacionadas con las salidas de otras herramientas de ubicación y/o de inspección. La herramienta comunica las coordenadas X, Y y el ángulo del elemento calculado.

Notas:
  • La herramienta comunica las coordenadas X,Y en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.
  • Si esta herramienta se utiliza conjuntamente con Calibración de la cuadrícula, pueden obtenerse resultados inexactos si el valor del ángulo en la calibración cambia. En tales casos, puede utilizarse en su lugar Margen a margen, Circular o una calibración importada.

La herramienta de ubicación Calcular elemento se utiliza cuando se desea utilizar los datos de puntos, líneas o ángulos específicos generados por herramientas de ubicación y/o de inspección para calcular un elemento; por ejemplo, si desea construir un elemento a partir de dos márgenes, de su punto de intersección y del ángulo resultante de la bisección. En este caso, se podrían utilizar herramientas de presencia/ausencia Margen para definir los márgenes, mientras que una herramienta de geometría Ángulo de bisección define los valores X, Y y Ángulo. A continuación, la herramienta de ubicación Calcular elemento utiliza los datos de salida de la herramienta de geometría Ángulo de bisección como entradas para las expresiones X (Bisect_1.Point.X), Y (Bisect_1.Point.Y) y Ángulo (Bisect_1.Angle).

  1. Configuración de la herramienta de ubicación Calcular elemento
  2. Ajuste de los parámetros de la herramienta de ubicación Calcular elemento
  3. Uso de las propiedades de entrada/salida de la herramienta de ubicación Calcular elemento


Configuración de la herramienta de ubicación Calcular elemento

Una vez agregada la herramienta, deberá generar la expresión para los valores X, Y y ángulo.

Nota: Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas. Antes de agregar esta herramienta, ensamble las demás herramientas de ubicación y/o de inspección que se utilizarán como entradas de esta herramienta; de lo contrario, no podrá construir expresiones hasta que haya añadido y configurado las herramientas de ubicación y/o de inspección necesarias. Después podrá regresar a esta herramienta.

  1. Genere cada expresión seleccionando y después introduciendo las funciones matemáticas de la parte izquierda del panel de ajustes y/o los valores (datos de herramienta y tarea) de la parte derecha. Para introducir una función o un valor en el editor de fórmulas de expresiones, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o el valor o presione el botón Insertar.
  2. Una vez generadas las tres expresiones, la herramienta insertará un icono [image] en la imagen que indica la ubicación y orientación del elemento calculado.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de ubicación Calcular elemento

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de ubicación Calcular elemento consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Fichas X, Y y Ángulo

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de ubicación Calcular elemento - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Elemento_1" (si se trata de la primera herramienta de Calcular elemento agregada a la tarea; de lo contrario, se incrementará, es decir, "Elemento_2", "Elemento_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de ubicación Calcular elemento - ficha Ajustes

Closed Resultado

Muestra las coordenadas X,Y calculadas y los valores angulares.

Closed Color

Especifica el color de la ubicación calculada del elemento: Valor predeterminado (= Verde), Rojo oscuro, Verde oscuro, Amarillo oscuro, Azul oscuro, Magenta oscuro, Cian oscuro, Rojo, Verde, Amarillo, Azul, Magenta, Cian, Gris oscuro, Gris, Negro o Blanco.


Herramienta de ubicación Calcular elemento - fichas X, Y y Ángulo

Las fichas X, Y y Ángulo se utilizan para generar las fórmulas matemáticas que definirán las coordenadas X, Y y de ángulo del elemento.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de ubicación Calcular elemento

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Inspeccionar pieza

El paso Inspeccionar pieza se utiliza para ensamblar y configurar las herramientas de inspección que se usarán para generar la tarea. Examine la pieza o el objeto que se va a inspeccionar y determine qué tipos de funciones se prestan mejor a los requisitos de su aplicación y qué herramientas de inspección son las más adecuadas para solucionar el problema.

  • Agregar, eliminar y editar herramientas de inspección de piezas
  • Elección de herramientas de inspección de piezas

  • Creación de vínculos entre las herramientas de ubicación y de inspección

    Nota: Los sensores de visión In-Sight de la serie 2000 no admiten la ficha Vínculos.

Las herramientas de inspección devuelven los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight 2000-110 y 2000-120/120C | Solo estado de aceptación/rechazo
Sensores de visión In-Sight 2000-130/130C | Herramientas de inspección de medición y recuento: Resultados estándar (datos numéricos) Herramienta de presencia/ausencia de patrones: Estado de aprobado/rechazado y puntuación de patrón Otras herramientas: Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar


Agregación, eliminación y edición de herramientas de inspección de piezas

Closed Agregación de una herramienta

Para añadir una herramienta a su tarea, selecciónela en el grupo Agregar herramienta y presione el botón Agregar o haga doble clic en la herramienta. Se le pedirá que defina la característica en la imagen, ya sea mediante selecciones de características inteligentes de EasyBuilder, el ajuste de los gráficos de la región en la imagen o el posicionamiento de gráficos de referencia geométrica.

Una vez definida inicialmente su función, puede efectuar el ajuste fino de los controles de la herramienta ajustando los diversos parámetros.

Nota: Puede buscar herramientas de forma dinámica si utiliza el cuadro de búsqueda Herramienta.

Closed Eliminación de una herramienta

Para eliminar una herramienta de su tarea, simplemente elija uno de los siguientes métodos:

  • Seleccione la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta) y presione la tecla Suprimir del teclado.
  • Seleccione la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta) y presione el icono Suprimir de la barra de herramientas Estándar.
  • En la tabla Resultados, haga clic con el botón derecho en la herramienta (situada en la ficha Resultados de la paleta) y elija la opción Eliminar del menú.
Closed Edición de una herramienta

Para editar una herramienta desde cualquier paso de EasyBuilder, elija uno de los siguientes métodos:

  • Haga doble clic en la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta).
  • Haga clic con el botón derecho en la herramienta de la tabla Resultados y seleccione la opción Ir a esta herramienta y editar en el menú.

Para editar una herramienta desde los pasos Localizar pieza o Inspeccionar pieza, simplemente elija uno de los siguientes métodos:

  • Seleccione el gráfico de región de la herramienta en la imagen.
  • Haga doble clic en la herramienta en la tabla Resultados (situada en la ficha Resultados de la paleta).
  • Haga clic con el botón derecho en la herramienta de la tabla Resultados y seleccione la opción Ir a esta herramienta y editar en el menú.
  • Haga doble clic en la herramienta en la tabla de resultados del paso de aplicación Ejecutar tarea.
Notas:
  • Si su sistema de visión In-Sight permite acceder al entorno de programación de la hoja de cálculo de In-Sight Explorer, aparecerá la opción del menú contextual Ir a esta herramienta en la hoja de cálculo. Se recomienda acceder al entorno de programación de la hoja de cálculo solo si se está familiarizado con este entorno y se comprende su funcionamiento. Antes de continuar, consulte los temas de la ayuda en línea sobre tareas y hoja de cálculo de EasyBuilder de In-Sight Explorer.
  • Las herramientas se pueden reorganizar en la tabla Resultados arrastrando y soltando las herramientas en el orden deseado. Esto puede hacerse tanto en la tabla Resultados de tareas ejecutadas como en la tabla Resultados de Palette, y se reflejará en ambas tablas. La clasificación mediante la técnica “arrastrar y soltar” solo se habilita al seleccionar la columna Orden de las herramientas y gráficos de dependencias (esta columna está seleccionada por defecto). Para invertir el orden, seleccione de nuevo la columna. La función de reorganización de la lista se desactivará si la tarea se aproxima o supera el límite de tamaño de la tarea.

Nota: Si la tarea no dispone de espacio suficiente para añadir más herramientas, salga de los pasos Localizar o Inspeccionar pieza y seleccione Límite de tamaño de la tarea en el menú Sensor. En el cuadro de diálogo, ajuste el tamaño de la tarea para que puedan añadirse más herramientas. Para ajustar el límite de tamaño de la tarea de un sistema de visión In-Sight, es necesario apagar y encender el sistema de visión, operación que borrará todos los archivos de tareas y de configuración en la memoria flash no volátil. Antes de continuar, guarde o haga una copia de seguridad de su tarea.


Características

En máquina de visión, las características se denominan "objetos de interés de la imagen" y las inspecciones visuales se diseñan teniendo en cuenta los tipos de características encontrados en la imagen.

En el paso Inspeccionar pieza, los tipos de características son:

Closed Márgenes

Áreas de transición entre píxeles claros y oscuros, tanto en dirección horizontal como vertical, o circular o en arco. Los márgenes pueden ser objetos tales como los extremos de una pieza, los contactos de una placa de circuitos, los filetes de una rosca, los fondos de botellas o la espiral de un muelle. Generalmente, estos tipos de características son los más rápidos y fáciles de detectar.

Closed Ejemplo de márgenes

Closed Círculos, líneas y puntos

Referencias geométricas estándar, que se pueden utilizar para calcular medidas.

Closed Ejemplo de círculos, líneas y puntos

Closed Patrones

Un patrón puede ser cualquier cosa, desde un simple grupo de formas repetitivas hasta configuraciones más complejas, como logotipos o etiquetas. Se trata del tipo de característica más fiable, permitiendo el rango más amplio de variaciones posicionales de rotación, movimiento y escalado, pero generalmente son los que más tiempo requieren para su inspección.

Closed Ejemplo de patrones

Closed Blobs

Un grupo de píxeles oscuros o claros conectados, como una mancha de pintura blanca sobre un fondo negro o un tornillo negro sobre una cinta transportadora blanca. También es una de las características más rápidas de encontrar y permite variaciones en la forma y el tamaño de las características del blob, pero tiene un valor de orientación angular limitado.

Closed Ejemplo de blobs

Closed Texto

Cadenas de texto alfanuméricas.

Closed Ejemplo de texto

Closed Códigos

Códigos de barras 1D y símbolos y códigos de matriz 2D que contienen cadenas de datos alfanuméricos.

Closed Ejemplo de códigos

Closed Reborde

Un reborde es un par de márgenes continuo, aunque no necesariamente cerrado, que define el límite entre dos regiones de diferentes valores de píxeles, con un valor de ancho que los define. Por ejemplo, un cordón de metal soldado, un rastro de adhesivo o de material sellante se denominan trayectorias de "reborde".

Closed Ejemplo de reborde


Creación de vínculos entre herramientas de ubicación y de inspección

Una vez incluidas herramientas de ubicación y/o de inspección en una tarea, las propiedades de las mismas (es decir, los parámetros de entrada y los resultados de salida) se pueden entrelazar en la ficha Vínculos de la Paleta. La ficha Vínculos permite utilizar el resultado de salida de una herramienta como parámetro de entrada de otra herramienta.

Closed Uso de la ficha Vínculos

La ficha Vínculos de la Paleta muestra una vista en árbol de todas las herramientas de ubicación y/o de inspección cargadas actualmente en la tarea. Las propiedades de las herramientas (los parámetros de entrada y los resultados de salida) aparecen referenciados con una etiqueta simbólica, que es una referencia simbólica a los valores contenidos en ellos. El valor tiene asociado un tipo de datos (que puede ser Acción, Coma flotante, Número entero o Cadena).

Las propiedades de las herramientas se dividen en propiedades de entrada y de salida, y sólo se pueden establecer vínculos desde propiedades de salida hacia propiedades de entrada. Mientras que las propiedades de salida se pueden asociar a varias propiedades de entrada individuales, una propiedad de entrada sólo puede tener asociada una propiedad de salida.

Para seleccionar qué propiedades de herramientas deben mostrarse y pueden configurarse en la ficha Vínculos, haga clic con el botón derecho en una propiedad de herramienta para abrir el cuadro de diálogo Seleccionar propiedades. El cuadro de diálogo Seleccionar propiedades contiene una lista en árbol de todas las herramientas utilizadas en la tarea, con todas sus propiedades de herramientas asociadas, tanto de entrada como de salida. Si desea personalizar qué propiedades de herramientas deben mostrarse en la ficha Vínculos, selecciónelas (utilice los botones Agregar/Quitar para agregar selecciones múltiples, o bien para anularlas después de haberlas seleccionado).

Closed Controles de la ficha Vínculos
Controles de la ficha Vínculos
Abre todas las propiedades de herramientas contenidas en la tarea.
Cierra todas las propiedades de herramientas contenidas en la tarea.

Presione para conmutar entre tres opciones de visualización de propiedades de herramientas:

  • Ajuste predeterminado: Sólo muestra las propiedades de herramientas seleccionadas en el menú Seleccionar propiedades.
  • Mostrar propiedades estándar: Muestra un subconjunto menor de propiedades de herramientas, ocultando automáticamente las propiedades Description, Include_In_Job_Pass, Error_Count, Execution_Time, Fail_Count, Pass_Count, Tool_Enabled_Status e Invert.
  • Mostrar todas las propiedades: Muestra todas las propiedades de herramientas.

Presione para conmutar entre tres opciones de ordenación:

  • Ajuste predeterminado: Muestra las herramientas en el orden en el que fueron añadidas a la tarea, comenzando por la primera herramienta añadida a la lista.
  • Orden alfabético: Muestra las herramientas por sus nombres, en orden alfabético ascendente.
  • Orden de dependencia: Muestra las herramientas basándose en sus dependencias, con las propiedades de Entrada situadas encima de las propiedades de Salida.
Notas:
  • Si se elimina de la tarea una herramienta que tenga vínculos hacia otras herramientas, los vínculos también se eliminarán automáticamente.
  • Si se copia y se pega en la tarea una herramienta que tiene asociadas propiedades tanto de entrada como de salida, sólo se conservarán las propiedades de entrada.
Closed Creación de vínculos entre herramientas

Existen dos formas de establecer vínculos entre propiedades de salida y de entrada de herramientas: arrastrando el nodo de propiedad de salida hasta el nodo de propiedad de entrada correspondiente, o bien haciendo clic con el botón derecho en la propiedad de entrada y seleccionando la propiedad de salida correspondiente desde el menú contextual Vínculo desde.

Nota: Al emplear el método de arrastrar y soltar para vincular propiedades, aparecerá un icono de acceso directo y una línea de color azul marino con flecha acompañará al cursor. El cursor mostrará un icono de bloqueo si la propiedad no puede ser vinculada.

Una vez asociadas las propiedades de herramientas, el parámetro de propiedad Entrada adoptará el color gris para indicar que queda inaccesible y mostrará un icono de vínculo [image] a su derecha. Al desplazar el puntero del ratón sobre el icono del vínculo, aparecerá en pantalla un mensaje de la herramienta indicando el origen del vínculo, mientras que haciendo clic con el botón derecho en el icono del vínculo se abrirá un menú contextual para desligar el vínculo.

Nota: Para deshacer un vínculo creado, presione el botón Deshacer en la barra de herramientas de EasyBuilder (o presione CTRL+Z).

Closed Eliminación de vínculos entre herramientas

Los vínculos entre propiedades de entrada y de salida pueden anularse seleccionando la propiedad que tenga asociado el vínculo de entrada y pulsando la tecla SUPRIMIR, o bien usando el menú contextual del botón derecho y seleccionando "Desconectar".

Nota: Para deshacer la anulación de un vínculo, presione el botón Deshacer en la barra de herramientas de EasyBuilder (o presione CTRL+Z).

Closed Ejemplo
Closed Vínculo de una herramienta de identificación Leer códigos de ID a una herramienta de identificación Leer texto

Una herramienta de identificación Leer texto permite verificar si el texto devuelto por una herramienta de identificación Leer códigos de ID es correcto. La herramienta Leer texto está configurada con el parámetro Cadena coincidente previsto y el parámetro Modo ajustado a Verificar. Vinculando el resultado de salida Cadena de la herramienta Leer códigos de ID al parámetro de entrada Match_String de la herramienta Leer texto, la herramienta de lectura de textos comprobará si el código inspeccionado por la herramienta Leer códigos de ID contiene el texto correcto.


Regiones

Las regiones definen el área de la imagen en la que la herramienta de ubicación o de inspección ejecutará su operación. También se denomina "región de interés".

Las herramientas de ubicación y de inspección de EasyBuilder utilizan diversos tipos de regiones, dependiendo del tipo de herramienta utilizada. EasyBuilder utiliza los siguientes tipos de regiones:

  • Rectángulo
  • Círculo
  • Espacio anular
  • Polígono
  • Región enmascarada
  • Trayectoria de polilínea


Regiones enmascaradas

Las regiones enmascaradas se utilizan para definir un área de la imagen que se someterá a análisis de márgenes. Esta región se utiliza en combinación con matrices Calibre para la detección precisa de márgenes.

Closed Leyenda de la región enmascarada

Controles | Descripción
1 | Límite de punto final redimensionable (x4) | Define las cuatro esquinas de la región rectangular. Haga clic en un límite de punto final para redimensionar la región desde una de sus esquinas.
2 Máscara

Define el área de la imagen que NO se someterá al análisis de imágenes. La máscara se puede mover y redimensionar dentro de la región. Se pueden añadir hasta 99 máscaras a una región. Cuando se añade una máscara, se incluye al principio de la región (siempre que no se hayan añadido otras máscaras), o a continuación de la máscara añadida anteriormente.

Nota: Las máscaras no deben solaparse. Si se configuran solapándose, se insertará automáticamente un búfer de 1 píxel para evitar que se superpongan.
3 | Indicador de dirección de exploración (x2) | Define en qué dirección buscará características la región enmascarada.
4 | Indicador de detección de márgenes | Define el área dentro de la región en la que se detectarán transiciones de márgenes; también permite añadir nuevas máscaras a la región.
5 | Controlador de rotación | Permite girar la región 360°.
6 | Controlador de doblado | Permite doblar la región rectangular para transformarla en un arco o darle forma anular.
Closed Acciones del ratón en regiones enmascaradas

Al situar el puntero del ratón sobre diversas partes de la región, se transformará automáticamente y habilitará las acciones siguientes:

Icono del ratón | Descripción
 | Permite arrastrar toda la región enmascarada a cualquier lugar de la imagen.
 | Permite escalar toda la región horizontal o verticalmente; también se utiliza para redimensionar la máscara.
 | Permite dos acciones separadas, dependiendo de la posición del puntero del ratón. Al situar el puntero del ratón sobre el controlador de rotación, se puede girar la región hasta 360° con respecto a su orientación actual. Al situar el puntero del ratón sobre el controlador de doblado, se puede transformar el contorno de la región en un arco o un anillo para permitir la detección de características de márgenes circulares.
 | Permite arrastrar la máscara dentro de la región.
 | Permite añadir o eliminar una máscara en la región. Cuando aparezca este icono, haga clic con el botón derecho del ratón para abrir un menú con estas dos opciones: Agregar máscara o Eliminar máscara.


Regiones de trayectorias de polilíneas

Las regiones de trayectorias de polilíneas se utilizan para definir un área de la imagen que se someterá a análisis de márgenes. Esta región se utiliza en combinación con matrices de Calibre para la detección precisa de márgenes.

Notas:
  • Durante la edición gráfica se dispone de un menú contextual que permite añadir o eliminar segmentos de trayectorias.
  • El botón Maximizar región de la barra de herramientas de EasyBuilder queda desactivado para la región de trayectorias de polilíneas.
Closed Leyenda de la región de trayectorias de polilíneas

 | Controles | Descripción
1 | Vértices de trayectorias de polilíneas (x3) | Define la trayectoria de los segmentos de polilíneas. Para posicionar polilíneas, haga clic en uno de sus vértices.
2 | Indicador de dirección de exploración (x2) | Define en qué dirección la región de trayectorias de polilíneas buscará características.
3 | Trayectoria de polilínea | Muestra gráficamente el trazado de la polilínea.
4 | Controlador de rotación | Permite girar la región 360°.
Closed Acciones del ratón en regiones de trayectorias de polilíneas

Al situar el puntero del ratón sobre diversas partes de la región, se transformará automáticamente y habilitará las acciones siguientes:

Icono del ratón | Descripción
 | Permite arrastrar toda la región de trayectorias de polilíneas a cualquier lugar de la imagen.
 | Permite escalar toda la región horizontal o verticalmente; también se utiliza para redimensionar la máscara.
 | Permite rotar la región 360° desde su orientación actual.
 | Permite mover la trayectoria de polilínea dentro de la región.
 | Permite añadir un punto a la trayectoria de polilínea. Se pueden añadir hasta 99 puntos a una polilínea. Esta opción se desactiva una vez que se han añadido 99 puntos a una polilínea.


Selecciones inteligentes de EasyBuilder

Las selecciones inteligentes ("Smart Selections") de EasyBuilder - características inteligentes ("Smart Features"), límites inteligentes ("Smart Limits") y ajustes inteligentes ("Smart Settings") - ayudan a acelerar el despliegue de su aplicación al calcular automáticamente los valores inteligentes predeterminados de los umbrales basándose en los requisitos de la herramienta y de su aplicación.

Nota: Cuando desarrolle aplicaciones en EasyBuilder, utilice una imagen de "Aceptación" de su pieza u objeto para que EasyBuilder pueda determinar los umbrales predeterminados apropiados para su aplicación.

  • Características inteligentes
  • Límites inteligentes
  • Ajustes inteligentes


Características inteligentes

Ciertas herramientas de ubicación y de inspección extraen automáticamente las características relevantes de su imagen, basándose en la herramienta seleccionada, para permitir realizar selecciones "apuntar y clic" de las características adecuadas para la inspección.

Al añadir una de estas herramientas a la tarea, la herramienta examina automáticamente su imagen y determina qué características cumplen los requisitos de la herramienta. Por ejemplo, la herramienta de ubicación Edge sólo devuelve características horizontales o verticales de márgenes, mientras que las herramientas de medición Diámetro de círculos y Concentricidad de círculos sólo devuelven características circulares.

Closed Ejemplo
Closed Características inteligentes - Márgenes

Closed Características inteligentes - Círculos

Si una característica no se ha definido previamente, aparecerá resaltada en color azul claro, mientras que las características existentes (tales como patrones, centroides de blobs, distancias, márgenes o círculos definidos por otras herramientas de detección de piezas o de inspección de piezas) se resaltarán en verde.

Closed Ejemplo

Características inteligentes - recién detectadas y definidas anteriormente

Simplemente haga clic en la característica que desee utilizar e EasyBuilder creará automáticamente la región apropiada si aún no se ha definido ninguna.

Nota: Si la característica deseada no aparece como selección de características inteligentes, elija uno de los siguientes procedimientos:
  • Elija una de las características inteligentes disponibles y coloque su región creada automáticamente sobre la característica que desee utilizar en su lugar. A continuación, ajuste los parámetros de la herramienta hasta que la característica deseada se detecte correctamente.
  • En primer lugar, defina la característica que desee utilizar con una herramienta de presencia/ausencia o de geometría apropiada. A continuación, vuelva a añadir la herramienta y seleccione su característica definida.


Límites inteligentes

Las herramientas de inspección de piezas con una ficha Límites de rango determinan automáticamente los límites Máximo y Mínimo.

Nota: Para obtener los mejores resultados al utilizar herramientas con límites inteligentes ("Smart Limits"), comience por entrenar las herramientas en su imagen de "Aceptación".

Cuando se añade una herramienta con una ficha Límite de rango a una tarea, la herramienta examina automáticamente la imagen y determina los límites máximo y mínimo apropiados a partir de los requisitos de la herramienta. Por ejemplo, los Límites de rango Máximo y Mínimo de las herramientas de medición de distancias y de ángulos son un ±5% del valor de la distancia y del ángulo, respectivamente, mientras que los límites de rango de las herramientas de recuento vienen determinados por el número de características detectadas en la imagen inicial.


Ajustes inteligentes

Las herramientas Ubicación de piezas e Inspección de piezas que definen círculos y márgenes incrementan automáticamente el parámetro Contraste hasta que se encuentra una característica de margen, lo que permite definir rápidamente umbrales basándose en los requisitos de su aplicación.

Nota: Para obtener los mejores resultados al utilizar herramientas con límites inteligentes ("Smart Limits"), comience por entrenar las herramientas en su imagen de "Aceptación".

Cuando se añade una herramienta de ubicación o de inspección de círculos o de márgenes a una tarea, la herramienta examina automáticamente la imagen y determina el ajuste Contraste apropiado, reduciéndolo en dos niveles para establecer el umbral. El ajuste Contraste predeterminado es 25, y el mínimo es 5.


Elección de herramientas de inspección de piezas

Las herramientas de inspección de piezas se agrupan por tipos de inspecciones:

Closed Herramientas de presencia/ausencia

Las herramientas de presencia/ausencia determinan si una característica está presente o ausente en la imagen.

  • Luminosidad
  • Contraste
  • Patrón PatMax RedLine
  • Patrón PatMax
  • Patrón
  • Recuento de píxeles
  • Recuento de píxeles de color
  • Blob
  • Blob de color
  • Margen
  • Círculo
  • Nitidez
Closed Herramientas de medición

Las herramientas de medición se utilizan para medir distancias, diámetros, ángulos y las áreas de características de la imagen.

  • Distancia
  • Ángulo
  • Área de blob
  • Áreas de blobs (1-10)
  • Área de blob de color
  • Áreas de blobs de color (1-10)
  • Diámetro de círculos
  • Concentricidad de círculos
  • Medir radio
  • Puntos mín./máx.
Closed Herramientas de recuento

Las herramientas de recuento se utilizan para contar los tipos de características contenidos en una imagen.

  • Blobs
  • Blobs de color
  • Márgenes
  • Pares de márgenes
  • Patrones PatMax RedLine
  • Patrones PatMax
  • Patrones
Closed Herramientas de identificación

Las herramientas de identificación se utilizan para identificar y verificar códigos y símbolos 1D y 2D, texto alfanumérico, características de patrones y colores en la imagen.

  • Leer código 1D
  • Leer códigos 1D (1-20)
  • Leer código 2D
  • Leer códigos 2D (1-20)
  • Leer código postal
  • Leer códigos de ID*
  • Leer texto*
  • Leer texto (OCRMax)
  • Patrones PatMax RedLine (1-10)
  • Patrones PatMax (1-10)
  • Patrones (1-10)
  • Color
  • Modelo de colores

* Las herramientas Leer códigos de ID y Leer texto son herramientas heredadas de sistemas antiguos e incompatibles con los sistemas In-Sight Explorer 4.7.0 y posteriores.

Closed Herramientas de geometría

Las herramientas de geometría se utilizan para crear referencias geométricas en la imagen, que pueden utilizar otras herramientas de inspección, como herramientas de matemáticas & lógica y herramientas de medición.

  • Punto a punto: Línea
  • Punto a punto: Punto medio
  • Punto a punto: Dimensión
  • Línea perpendicular
  • Intersección de línea
  • Ángulo de bisección
  • Línea a partir de N puntos
  • Círculo a partir de N puntos
  • Intersección círculo-línea
  • Punto definido por el usuario
  • Línea definida por el usuario
  • Encuadre de círculo
  • Encuadre de línea
Closed Herramientas de matemáticas & lógica

Las herramientas de matemáticas & ógica se utilizan para enlazar herramientas mediante condiciones basándose en los datos de herramientas y tareas, ejecutar operaciones matemáticas con los resultados de la herramienta, procesar estadísticas de herramientas, agrupar herramientas y crear pasos para el orden de las operaciones.

  • Matemáticas
  • Lógica
  • Tendencia
  • Estadísticas
  • Grupo
  • Secuencia
  • Calcular punto
  • Variables
Closed Herramientas de trazado

Las herramientas de trazado permiten calcular los gráficos contenidos en la imagen mediante expresiones matemáticas.

  • Trazar arco
  • Trazar círculo
  • Trazar cruz
  • Trazar línea
  • Trazar punto
  • Trazar región
  • Trazar cadena
Closed Herramientas de filtrado de imágenes

Las herramientas de filtrado de imágenes se utilizan para mejorar una imagen completa o parcial con el fin de analizarla.

  • Filtro
  • Vecino
  • Corrección de escenas
  • Punto
  • Color a escala de grises
  • Color a binario
  • Transformar
  • Comparar
Closed Herramientas de calibración

Las herramientas de calibración se utilizan para construir un archivo de calibración que se puede compartir entre tareas.

  • Punto N
  • Punto secuencial N
Closed Herramientas de detección de defectos

Las herramientas de detección de defectos permiten determinar si una pieza u objeto se ha producido con algún defecto, como una grieta, una encrespadura, una abolladura, un hueco, una mella o un rasguño.

  • Defecto superficial
  • Margen
  • Par de márgenes
  • Ancho de margen
  • Buscador de rebordes
  • Rastreador de rebordes

Nota: Para que se activen las versiones de color de las herramientas de ubicación e inspección, el usuario debe estar conectado a un sistema de visión de color In-Sight o a un emulador.


Herramientas de presencia/ausencia - Brillo

La herramienta de presencia/ausencia Brillo determina si una característica está presente o ausente según un valor medio de escala de grises (es decir, el brillo) de los píxeles en la región y comunica dicho valor.

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar

La herramienta de presencia/ausencia Brillo es útil en situaciones en que una característica de una pieza correcta es mucho más oscura o clara que la característica de una pieza incorrecta. Los aumentos y las disminuciones del brillo de una característica son un buen indicador de la presencia o ausencia de una pieza u objeto. Por ejemplo, puede medir rápidamente si un tapón de rosca de color claro está presente o ausente por el brillo en una región.

  1. Configuración de la herramienta de presencia/ausencia Brillo
    1. Selección de una característica
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Brillo
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Brillo


Configuración de la herramienta de presencia/ausencia Brillo

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen para aislar su característica:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione la región sobre la característica y asegúrese de que los límites de la región cubran la característica. Los límites deben configurarse de manera que solo incluyan la característica que desea medir. Si la región es mayor que la característica, los resultados pueden ser imprecisos porque también se calcularán los píxeles del fondo. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que la característica se encuentre aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Selección de una característica

A la hora de elegir una característica para utilizar en la inspección, tenga en cuenta los siguientes criterios para asegurarse los mejores resultados:

  • Si no está utilizando un elemento, asegúrese de que la característica se encuentre más o menos en la misma ubicación en cada imagen o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.
  • La herramienta de luminosidad es útil en aplicaciones en las que, si la característica inspeccionada está presente, está formada por un único valor de escala de grises (por ejemplo, negro), y lo contrario si la característica está ausente.
Closed Ejemplo


Ajuste de los parámetros de la herramienta de presencia/ausencia Brillo

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Sistemas de visión In-Sight

El panel de ajustes de la herramienta de presencia/ausencia Brillo consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango
  • Ficha Histograma
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de presencia/ausencia Brillo

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de la herramienta de presencia/ausencia Brillo.

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Closed Indicador de aceptaciones/rechazos

Muestra un círculo verde [image] o un rectángulo rojo [image] para indicar el éxito o el fallo en cada caso.

Closed Control deslizante Rango de medición y aceptación de brillo

Establece los niveles mínimos y máximos de brillo. Puede establecer los valores de forma manual moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

  • Controlador izquierdo: Establece el límite medio de escala de grises mínimo aceptable (0 - 255).
  • Controlador derecho: Establece el límite medio de escala de grises máximo aceptable (0 - 255).
  • Indicador de resultados: Muestra el valor medio de escala de grises de los píxeles en la región. Si el indicador se encuentra entre los controladores izquierdo y derecho, la herramienta obtiene una aceptación y el indicador de resultados es de color verde. De lo contrario, la herramienta obtiene un rechazo y el indicador de resultados es de color rojo.
ACEPTACIÓN
RECHAZO

Nota: Al pasar el ratón sobre el control deslizante se muestra el resultado y los valores de rango de aceptación.

Closed Botón Automático

Establece automáticamente los límites de rango como el resultado más reciente de la herramienta, +/- un 10 % del valor máximo del resultado de la herramienta. Por ejemplo, si el valor máximo del resultado de la herramienta es 255 y el resultado más reciente de la herramienta es 150, el límite mínimo del rango se establecerá en 125 (=150 - 25) y el límite máximo del rango, en 175 (=150 + 25) al hacer clic en el botón Automático.

Closed Invertir resultado

Con esta opción habilitada, la herramienta obtiene un rechazo si el resultado se encuentra dentro de los límites del rango. (Valor predeterminado = Desactivado)

Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Nombre

Define el nombre de la herramienta de brillo. El nombre predeterminado es "Brillo_1" (si es la primera herramienta Patrón añadida a la tarea, de lo contrario se incrementará, p. ej., "Brillo_2", "Brillo_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Elemento

Selecciona un elemento para la herramienta. El botón Elemento cambia a color naranja cuando se ha habilitado el control de elemento.

Nota: Este control solo puede habilitarse si ya se ha añadido otra herramienta que defina un elemento.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia Luminosidad - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Brillo_1" (si se trata de la primera herramienta de brillo agregada a la tarea; de lo contrario, se incrementará, es decir, "Brillo_2", "Brillo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Presencia/ausencia de luminosidad - ficha Límites de rango

Closed Mínimo

Define el valor medio aceptable mínimo de la escala de grises (0 a 255); a herramienta creará un ajuste predeterminado de "límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Luminosidad

Indica el valor de escala de grises medio de los píxeles encontrados en la región (0 a 255); los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Closed Máximo

Define el valor medio aceptable máximo de la escala de grises (0 a 255); a herramienta creará un ajuste predeterminado de "límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de presencia/ausencia Brillo - ficha Histograma

La ficha Histograma muestra una representación del histograma de los valores en la escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • Las tres líneas verticales azules indican los valores en la escala de grises de los píxeles de Mínimo, Brillo y Máximo respectivamente.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Herramienta de presencia/ausencia Brillo - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Brillo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Luminosidad | FP | X |
Region_Compuesta | A | X |
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I | X | Entrada
Máximo | FP | X | Entrada
Mínimo | FP | X | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Luminosidad | FP | X | Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | I |  | Salida
Recuento_Rechazos | I | X | Salida
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X | Salida
Estado | I | X | Salida
Herramienta_Estado_Habilitado | I | X | Salida
Region_Compuesta | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Luminosidad | FP | X | X | Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  | Salida
Recuento_Rechazos | I | X | X | Salida
Aceptación | I | X |  | Salida
Recuento_Aceptaciones | I | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Region_Compuesta | A |  | X |


Herramientas de presencia/ausencia - Contraste

La herramienta de presencia/ausencia Contraste determina si una característica está presente o ausente según el valor de contraste (la diferencia entre el valor medio de escala de grises superior al umbral y el valor medio de escala de grises inferior al umbral) entre las características de los píxeles en la región, y comunica ese valor.

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar

La herramienta de presencia/ausencia Contraste es útil en situaciones en que la característica en una pieza correcta tiene áreas oscuras y/o claras muy diferenciadas en relación con las de una pieza incorrecta. Por ejemplo, al verificar la presencia de una impresión oscura en una etiqueta blanca.

  1. Configuración de la herramienta de presencia/ausencia Contraste
    1. Selección de una característica
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Contraste
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Contraste


Configuración de la herramienta de presencia/ausencia Contraste

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen para aislar su característica:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione la región sobre la característica y asegúrese de que los límites de la región cubran la característica. Los límites deben configurarse de manera que solo incluyan la característica que desea medir. Si la región es mayor que la característica, los resultados pueden ser imprecisos porque también se calcularán los píxeles del fondo. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que la característica se encuentre aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Selección de una característica

A la hora de elegir una característica para utilizar en la inspección, tenga en cuenta los siguientes criterios para asegurarse los mejores resultados:

  • Si no está utilizando un elemento, asegúrese de que la característica se encuentre más o menos en la misma ubicación en cada imagen o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.
  • La herramienta de contraste es útil en aplicaciones en las que la característica inspeccionada contiene una mezcla de valores de escala de grises cuando está presente, y un conjunto uniforme de valores de escala de grises cuando está ausente.
  • Si su aplicación requiere una diferenciación más sutil entre las diferencias de luminosidad y de contraste, utilice la herramienta Recuento de píxeles, que es más precisa al calibrar esas diferencias que la herramienta de contraste.
Closed Ejemplo


Ajuste de los parámetros de la herramienta de presencia/ausencia Contraste

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Sistemas de visión In-Sight

El panel de ajustes de la herramienta de presencia/ausencia Contraste consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango
  • Ficha Histograma
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de presencia/ausencia Contraste

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de la herramienta de presencia/ausencia Contraste.

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Closed Indicador de aceptaciones/rechazos

Muestra un círculo verde [image] o un rectángulo rojo [image] para indicar el éxito o el fallo en cada caso.

Closed Control deslizante Rango de medición y aceptación de contraste

Establece los niveles mínimos y máximos de contraste. Puede establecer los valores de forma manual moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

  • Controlador izquierdo: Establece el límite medio de escala de grises mínimo aceptable (0 - 255).
  • Controlador derecho: Establece el límite medio de escala de grises máximo aceptable (0 - 255).
  • Indicador de resultados: Muestra el valor medio de escala de grises de los píxeles en la región. Si el indicador se encuentra entre los controladores izquierdo y derecho, la herramienta obtiene una aceptación y el indicador de resultados es de color verde. De lo contrario, la herramienta obtiene un rechazo y el indicador de resultados es de color rojo.
ACEPTACIÓN
RECHAZO

Nota: Al pasar el ratón sobre el control deslizante se muestra el resultado.

Closed Botón Automático

Establece automáticamente los límites de rango como el resultado más reciente de la herramienta, +/- un 10 % del valor máximo del resultado de la herramienta. Por ejemplo, si el valor máximo del resultado de la herramienta es 255 y el resultado más reciente de la herramienta es 150, el límite mínimo del rango se establecerá en 125 (=150 - 25) y el límite máximo del rango, en 175 (=150 + 25) al hacer clic en el botón Automático.

Closed Invertir resultado

Con esta opción habilitada, la herramienta obtiene un rechazo si el resultado se encuentra dentro de los límites del rango. (Valor predeterminado = Desactivado)

Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Closed Nombre

Define el nombre de la herramienta de inspección. El nombre predeterminado es "Contraste_1" (si es la primera herramienta Patrón añadida a la tarea, de lo contrario se incrementará, p. ej., "Contraste_2", "Contraste_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Elemento

Selecciona un elemento para la herramienta. El botón Elemento cambia a color naranja cuando se ha habilitado el control de elemento.

Nota: Este control solo puede habilitarse si ya se ha añadido otra herramienta que defina un elemento.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia Contraste - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Contraste_1" (si se trata de la primera herramienta de contraste agregada a la tarea; de lo contrario, se incrementará, es decir, "Contraste_2", "Contraste_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Presencia/ausencia de contraste - ficha Límites de rango

Closed Máximo

Define el valor máximo de contraste admisible (0 a 255); la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Contraste

Indica la diferencia entre los valores medios de escala de grises encontrados en la región mayores y menores que el umbral "inteligente" creado por la herramienta; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el valor mínimo de contraste admisible (0 a 255); la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de presencia/ausencia Contraste - ficha Histograma

La ficha Histograma muestra una representación del histograma de los valores en la escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • Las tres líneas verticales azules indican el valor medio en la escala de grises inferior al umbral, el umbral y el valor medio en la escala de grises superior al umbral respectivamente.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Herramienta de presencia/ausencia Contraste - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Contraste

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Region_Compuesta | A | X |
Contraste | FP | X |
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I | X | Entrada
Máximo | FP | X | Entrada
Mínimo | FP | X | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Contraste | FP | X | Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | I |  | Salida
Recuento_Rechazos | I | X | Salida
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X | Salida
Estado | I | X | Salida
Herramienta_Estado_Habilitado | I | X | Salida
Region_Compuesta | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Contraste | FP | X | X | Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  | Salida
Recuento_Rechazos | I | X | X | Salida
Aceptación | I | X |  | Salida
Recuento_Aceptaciones | I | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Region_Compuesta | A |  | X |


Herramientas de presencia/ausencia - Patrón PatMax RedLine y Patrón PatMax

Notas:
  • A partir del firmware de In-Sight 5.5.0 y posteriores, el algoritmo de la herramienta se ha modificado para obtener resultados más precisos y reducir el tiempo de ejecución en determinadas circunstancias.
  • Debido a esta modificación, aparecerá un mensaje de error si intenta cargar una tarea en la que esta herramienta esté configurada con el firmware de In-Sight 5.5.0 o posterior en un sistema de visión In-Sight con una versión de firmware 5.4.x o anterior.
  • La herramienta de ubicación de patrón PatMax RedLine y la herramienta de ubicación de patrones PatMax RedLine (1-10) solo están disponibles en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de patrón PatMax RedLine y la herramienta de presencia/ausencia de patrones PatMax se utilizan para determinar la presencia o ausencia de una característica del patrón mediante el algoritmo PatMax RedLine o PatMax y según una representación entrenada de dicho patrón (que se denomina Modelo).

Estas herramientas son útiles en situaciones en que la característica en una pieza correcta tiene un patrón reconocible que no está presente en las piezas incorrectas o viceversa. Por ejemplo, si intenta verificar si un patrón de la cabeza de un tornillo Philips está presente en un montaje mecánico.

  1. Configuración de la herramienta de presencia/ausencia de patrón PatMax RedLine y patrón PatMax
    1. Patrón PatMax RedLine, Patrón PatMax frente a Patrón
    2. Selección de una característica de patrón
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia de patrón PatMax RedLine y patrón PatMax
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia de patrón PatMax RedLine y patrón PatMax


Configuración de las herramientas de presencia/ausencia de patrón PatMax RedLine y patrón PatMax

Una vez agregada la herramienta, deberá seleccionar el tipo de regiones y configurarlas para definir su patrón (la región Modelo), y en qué lugar de la imagen se encontrará el modelo (la región de Búsqueda).

  1. En el menú desplegable Modelo, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Después coloque la región Modelo sobre el patrón que se utilizará como modelo de entrenamiento; asegúrese de que la región Modelo cubra únicamente las características importantes del patrón.Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.
  2. En el menú desplegable Buscar, seleccione el tipo de región: Rectángulo (predeterminado), Círculo, Espacio anular o Polígono. A continuación, sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.
  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Patrón PatMax RedLine, Patrón PatMax y Patrón

Nota: La herramienta de presencia/ausencia de patrón PatMax RedLine solo está disponible en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

Las herramientas Patrones PatMax RedLine, Patrones PatMax y Patrones localizan modelos de patrones entrenados y ofrecen la máxima precisión de entre todas las herramientas de ubicación e inspección. Sin embargo, las herramientas Patrones PatMax RedLine y Patrones PatMax son más potentes que la herramienta Patrones al contabilizar más cambios de las condiciones de iluminación y la posición del patrón. Asimismo, ofrecen un reconocimiento superior de los cambios de escala y rotación del patrón, de la oclusión de elementos del patrón y de cambios del aspecto del patrón debidos a variaciones de iluminación.

La principal diferencia entre los patrones PatMax RedLine y los patrones PatMax es la velocidad; el patrón PatMax RedLine utiliza el algoritmo de coincidencia de patrones más reciente y puede localizar características entrenadas en una imagen de 5 megapíxeles hasta 7 veces más rápido que los patrones PatMax. Por lo tanto, la herramienta Patrones PatMax RedLine es ideal para sistemas de visión de alta resolución.

La herramienta Patrones es (en la mayoría de los casos) más rápida que la herramienta PatMax, pero ciertas situaciones requieren la precisión y fiabilidad de la versión PatMax RedLine o PatMax:

  • Cuando las variaciones de iluminación y los reflejos son difíciles de controlar. Por ejemplo, las piezas metálicas pueden reflejar la luz en direcciones aleatorias.
  • Cuando el patrón que se inspecciona presenta formas o sombras similares en comparación con algo situado en el fondo o si otros objetos de la imagen se solapan con el patrón o lo ocultan parcialmente.
  • Cuando se desea reconocer con precisión un tipo de patrón frente a otros patrones similares.
  • Cuando las condiciones del entorno de la implementación son demasiado difíciles para que la herramienta Patrones pueda funcionar de forma coherente y fiable.


Ajuste de los parámetros de la herramienta de presencia/ausencia de patrón PatMax RedLine y patrón PatMax

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de presencia/ausencia de patrón PatMax RedLine y patrón PatMax consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Fichas Modelo y Buscar
  • Ficha Imagen entrenada

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de presencia/ausencia de patrón PatMax RedLine y patrón PatMax - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección que se utilizará en la configuración de resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Patron_1" (si se trata de la primera herramienta de patrones agregada a la tarea; de lo contrato, se incrementará, es decir, "Patron_2", "Patron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de presencia/ausencia de patrón PatMax RedLine y patrón PatMax - ficha Ajustes

Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Umbral de contraste

Define el contraste mínimo aceptable que debe estar presente en el patrón encontrado; el contraste de un patrón encontrado debe ser mayor que el valor de Umbral de contraste para que se considere una instancia válida. El valor predeterminado para el patrón o los patrones PatMax RedLine es 0 y el rango de parámetros válido es 0-100. El valor predeterminado para el patrón o los patrones PatMax es 10 y el rango de parámetros válido es 0-255. Un valor de Umbral de contraste bajo se utiliza para imágenes de bajo contraste, mientras que un valor de Umbral de contraste alto se utiliza para imágenes de alto contraste.

Nota: El contraste del patrón o los patrones PatMax RedLine es la medición "relativa" del cambio de contraste entre las características del patrón entrenado y las características coincidentes en la imagen de búsqueda, en porcentaje. Por lo tanto, si el contraste de las características es similar o más alto en relación con el contraste del patrón, el contraste comunicado será ~100. Si el contraste de las características es más bajo que el contraste del patrón, el contraste comunicado será <100. El contraste del patrón o los patrones PatMax RedLine es diferente del contraste del patrón o los patrones PatMax, que es el contraste "absoluto" de la imagen del ROI buscado, en nivel de escala de grises.

Closed Tolerancia del ángulo

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define el porcentaje de escalado admisible (variaciones de tamaño) entre el patrón encontrado y el patrón Modelo (0-50; valor predeterminado = 0). El valor es un porcentaje positivo o negativo, p. ej., un valor de 5 permitirá que la herramienta encuentre patrones que están entre el 95 % y el 105 % del tamaño del patrón Modelo. Cuanto mayor sea el rango admisible de variación de escala del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Modo Buscar

Define el modo de búsqueda utilizado para entrenar y reconocer patrones, PatMax o PatQuick. La opción PatMax está seleccionada de forma predeterminada. PatMax ofrece mayor precisión que PatQuick, pero requiere más tiempo de ejecución, mientras que PatQuick ofrece menor precisión que PatMax, pero requiere menos tiempo de ejecución.

Closed Puntuación estricta

Define si las características ocluidas del patrón encontrado o las que faltan en él repercutirán o no en la puntuación (valor predeterminado = desactivado). Cuando se aplica la opción Puntuación estricta (activada), se reducirá la puntuación del patrón encontrado si hay características del patrón ausentes o bloqueadas.

Closed Ignorar polaridad

Define si los patrones encontrados pueden contener características de coincidencia de colores invertidos, con respecto al patrón Modelo (ajuste predeterminado = desactivado, desmarcado). Con la opción Ignorar polaridad aplicada (activada, marcada), los patrones en los que se detecten características de colores invertidos, tales como negro/blanco frente a blanco/negro en el patrón Modelo, se clasificarán como coincidencias con el patrón Modelo.

Closed Invertir
Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Tiempo de espera
Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo. Este parámetro se establece de forma predeterminada en 5.000.
Closed Resultado

Muestra el resultado de la herramienta: Presente si se detectó la característica de patrón y una puntuación que indica en qué medida el patrón encontrado se asemeja al patrón modelo; No presente si no se detectó o si se detectó más de una ocurrencia del patrón. Presente equivale a un valor booleano de 1 (Aceptación); No presente equivale a un valor booleano de 0 (Rechazo).

Nota: El patrón o patrones PatMax RedLine no incluye el parámetro Modo Buscar.


Herramientas de presencia/ausencia de patrón PatMax RedLine y patrón PatMax - fichas Modelo y Buscar

Las fichas Modelo y Buscar sirven para configurar la región compuesta de las regiones Modelo y Buscar de la herramienta. Las regiones compuestas sirve son una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • En la ficha Modelo, las regiones compuestas solo se activan tras pulsar el botón Región modelo.
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramientas de presencia/ausencia de patrón PatMax RedLine y patrón PatMax - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de las herramientas de presencia/ausencia de patrón PatMax RedLine y patrón PatMax

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Tolerancia_Angulo | I | X | X | Entrada/Salida
Umbral_Contraste | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Nuevo_Entrenamiento_Externo | I | X |  | Entrada/Salida
Buscar_Modo1 | I | X | X | Entrada/Salida
Ignorar_Polaridad | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Puntuacion_Estricta | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Patrones | S | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Escala | FP | X | X | Salida
Modelo | A | X | X |
Buscar | A | X | X |
Entrenar | A | X | X |
1 Esta propiedad de herramienta solo está disponible en la herramienta de presencia/ausencia de patrones PatMax.


Herramientas de presencia/ausencia - Patrones

La herramienta Presencia/ausencia de patrones se utiliza para determinar la presencia o ausencia de una característica de patrón basándose en una representación entrenada de ese patrón (llamada modelo).

La herramienta Presencia/ausencia de patrones es útil cuando la característica de una pieza correcta tiene un patrón reconocible que no está presente en las piezas incorrectas, o viceversa. Por ejemplo, para verificar si un montaje mecánico contiene o no un tornillo con cabeza Philips.

  1. Configuración de la herramienta de presencia/ausencia de patrones
    1. Selección de una característica de patrón
    2. Comparación de las herramientas Patrones y Patrones PatMax
  2. Ajuste de los parámetros de la herramienta Presencia/ausencia de patrones
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia de patrones

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensor de visión In-Sight 2000-110 y 2000-120/120C | Solo estado de aceptación/rechazo
Sensor de visión In-Sight 2000-130/130C | Estado de aprobado/rechazado y puntuación de patrón
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar


Configuración de la herramienta de presencia/ausencia Patrón

Cuando haya agregado la herramienta, deberá configurar las regiones de la imagen que definirán su patrón (la región Modelo), y dónde se encontrará el patrón en la imagen (la región de Búsqueda).

  1. Sitúe la región Modelo sobre el patrón que se utilizará como patrón de entrenamiento; asegúrese de que la región Modelo cubra solamente las características importantes del patrón.
  2. Sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.

Nota: Las regiones Modelo y Búsqueda no se pueden doblar para formar un arco o un anillo.

  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de presencia/ausencia Patrón

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Sistemas de visión In-Sight

El panel de ajustes de la herramienta de presencia/ausencia Patrón consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Imagen entrenada

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de presencia/ausencia Patrón

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a los sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de la herramienta de presencia/ausencia Patrón.

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Closed Indicador de aceptaciones/rechazos

Muestra un círculo verde [image] o un rectángulo rojo [image] para indicar el éxito o el fallo en cada caso.

Closed Tolerancia de rotación

Define en qué medida se puede girar el patrón encontrado desde la posición del modelo entrenado sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 45°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta. El controlador izquierdo establece la tolerancia de rotación negativa y el controlador derecho, la tolerancia de rotación positiva. Puede ajustar la tolerancia de rotación moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Closed Medidor de localización de piezas

El medidor de localización de piezas muestra si la herramienta ha encontrado correctamente la característica y establece el umbral de aceptación mínimo. Puede establecer de forma manual el valor mínimo del umbral de aceptación (0 - 100; valor predeterminado = 50) mediante el ajuste del controlador o la introducción de un valor en el cuadro de edición correspondiente.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Si el medidor supera el umbral, la herramienta considerará que ha encontrado esa pieza y el medidor cambia a color verde. Si es inferior al umbral, considerará que no ha encontrado la pieza y el medidor desaparece. Si la herramienta detecta cosas que no son piezas o si detecta una característica errónea, mueva el controlador hacia la derecha. Si la herramienta no detecta algunas piezas, mueva el controlador hacia la izquierda (o cree una región modelo nueva). Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

ACEPTACIÓN
RECHAZO

Nota: Al pasar el ratón sobre el control deslizante se muestra los valores de resultado y de umbral.

Closed Invertir resultado

Con esta opción habilitada, la herramienta obtiene un rechazo si el resultado se encuentra dentro de los límites del rango. (Valor predeterminado = Desactivado)

Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Closed Tolerancia de escala de ± 10 %

Define si la herramienta permite o no una variación de tamaño de ±10 % entre el patrón encontrado y el patrón modelo.

Patrón entrenado | Patrón encontrado: +10 % | Patrón encontrado: -10%
Desactivado (valor predeterminado) | (Rechazo) | (Rechazo)
Activado | (Aceptación) | (Aceptación)
Closed Usar tiempo de espera manual

Define si se aplica o no el ajuste de tiempo de espera.

  • Desactivado (valor predeterminado): el tiempo de espera está deshabilitado (no hay tiempo de espera).

  • Activado: el tiempo de espera está habilitado (no hay tiempo de espera). Puede definir de forma manual el valor de tiempo de espera en milisegundos (0 a 30000) mediante el cuadro de edición.

    Nota: Si este valor se ajusta a 0, el ajuste se desactivará y el tiempo de espera no se aplicará.
Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Nombre

Define el nombre de su herramienta de inspección. El nombre predeterminado es "Patron_1" (si es la primera herramienta Patrón añadida a la tarea; de lo contrario, se incrementará, p. ej., "Patron_2", "Patron_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Elemento

Selecciona un elemento para la herramienta. El botón Elemento cambia a color naranja cuando se ha habilitado el control de elemento.

Nota: Este control solo puede habilitarse si ya se ha añadido otra herramienta que defina un elemento.

Closed Entrenar entrada

Define si se entrena o no un patrón Modelo sobre una línea de entrada (el ajuste predeterminado es "Off": deshabilitado).

  • Entrada: Entrena un patrón Modelo sobre una línea de entrada. La línea de entrada seleccionada se utilizará como señal de entrenamiento.

    Notas:
    • Esta opción no aparecerá si el sistema de visión In-Sight no dispone de entradas discretas (por ejemplo, el sistema de visión In-Sight de la serie 8000 utiliza E/S directa).
    • El tipo de señal de la línea de entrada seleccionada debe estar fijado en Disparador de evento en el paso de aplicación Entradas/Salidas.
    • El entrenamiento de un patrón Modelo utilizará la imagen más reciente que haya adquirido el sensor/sistema de visión. No es necesario volver a lanzar el sensor/sistema de visión para el entrenamiento.
    • Para obtener más información, consulte Entradas: Entrenamiento de un patrón Modelo sobre una línea de entrada
Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Región modelo

La imagen es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Herramienta de presencia/ausencia Patrón - ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección que se utilizará en la configuración de resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Patron_1" (si se trata de la primera herramienta de patrones agregada a la tarea; de lo contrato, se incrementará, es decir, "Patron_2", "Patron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia Patrón - Ficha Ajustes

Closed Entrenar entrada

Define si se entrena o no un patrón Modelo sobre una línea de entrada (el ajuste predeterminado es "Off": deshabilitado).

  • Entrada: Entrena un patrón Modelo sobre una línea de entrada. La línea de entrada seleccionada se utilizará como señal de entrenamiento.

    Notas:
    • Esta opción no aparecerá si el sistema de visión In-Sight no dispone de entradas discretas (por ejemplo, el sistema de visión In-Sight de la serie 8000 utiliza E/S directa).
    • El tipo de señal de la línea de entrada seleccionada debe estar fijado en Disparador de evento en el paso de aplicación Entradas/Salidas.
    • El entrenamiento de un patrón Modelo utilizará la imagen más reciente que haya adquirido el sensor/sistema de visión. No es necesario volver a lanzar el sensor/sistema de visión para el entrenamiento.
    • Para obtener más información, consulte Entradas: Entrenamiento de un patrón Modelo sobre una línea de entrada
Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Tolerancia de rotación

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define la tolerancia de la herramienta para las modificaciones en la escala del patrón, dentro de un ±10% del tamaño del patrón entrenado. De forma predeterminada, este ajuste está desactivado (sin marcar), por lo que se deshabilitan los ajustes de la escala. En este modo de operación, la herramienta todavía encontrará patrones que se encuentren en un rango de ±10%, pero la puntuación de la característica se reducirá según aumente el porcentaje de la escala.

Closed Invertir resultado
Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Tipo de modelo

Define cómo la herramienta debe construir el patrón Modelo, Modelo de área o Modelo de margen (predeterminado). Modelo de área crea el patrón Modelo a partir de un muestreo de uniformidad de los valores de escala de grises contenidos en la región Modelo. Modelo de margen crea el patrón Modelo basándose en los márgenes detectados (transiciones entre claro y oscuro) de la característica del patrón dentro de la región Modelo.

Closed Precisión

Define cómo la herramienta evaluará el compromiso entre exactitud/fiabilidad frente a velocidad de ejecución; Exacto, Medio (preajuste) y Rápido. Exacto prioriza la precisión y la fiabilidad, reduciendo la velocidad de ejecución, Rápido favorece la velocidad de ejecución a costa de la precisión y fiabilidad, mientras que Mediano es un equilibrio entre las dos primeras opciones.

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo.

Closed Resultado

Muestra el resultado de la herramienta: Presente si se detectó la característica de patrón y una puntuación que indica en qué medida el patrón encontrado se asemeja al patrón modelo; No presente si no se detectó o si se detectó más de una ocurrencia del patrón. Presente equivale a un valor booleano de 1 (Aceptación); No presente equivale a un valor booleano de 0 (Rechazo).


Herramienta Presencia/ausencia de patrones - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia de patrones

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | Entrada
Precisión | I |  | Entrada
Tolerancia_Angulo | I | X | Entrada
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Entrenamiento_Externo | I |  | Entrada
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I | X | Entrada
Modelo | A | X |
Tipo_Modelo | I |  | Entrada
Aceptacion | I |  | Salida
Recuento_Aceptaciones | I | X |
Resultado | S | X |
Escala_Tolerancia | I | X | Entrada
Puntuación* | FP | X | Salida
Buscar | A | X |
Estado | I | X |
Tiempo de espera | I | X | Entrada
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |
Entrenar | A | X |
*Sensores de visión In-Sight 2000-130/130C solamente

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | Entrada/Salida
Precisión | I | X | Entrada/Salida
Tolerancia_Angulo | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Entrenamiento_Externo | I |  | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Tipo_Modelo | I | X | Entrada/Salida
Escala_Tolerancia | I | X | Entrada/Salida
Tiempo de espera | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | I |  | Salida
Recuento_Rechazos | I | X | Salida
Aceptacion | I |  | Salida
Recuento_Aceptaciones | I | X | Salida
Patrones | S | X | Salida
Resultado | S | X | Salida
Estado | I | X | Salida
Herramienta_Estado_Habilitado | I | X | Salida
Modelo | A | X |
Buscar | A | X |
Entrenar | A | X |
Entrenar_Entrada | I | X | Entrada/Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Precisión | I | X | X | Entrada/Salida
Tolerancia_Angulo | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Entrenamiento_Externo | I | X |  | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Tipo_Modelo | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Tiempo de espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  | Salida
Recuento_Rechazos | I | X | X | Salida
Aceptacion | I | X |  | Salida
Recuento_Aceptaciones | I | X | X | Salida
Patrones | S | X | X | Salida
Resultado | S | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Modelo | A | X | X |
Buscar | A | X | X |
Entrenar | A | X | X |
Entrenar_Entrada | I | X | X | Entrada/Salida


Herramientas de presencia/ausencia - Recuento de píxeles

La Herramienta de presencia/ausencia Recuento de píxeles determina si una característica está presente o ausente tomando como referencia el número de píxeles blancos y negros de la región, y comunica este valor.

La herramienta calcula el valor de umbral óptimo de la escala de grises (de 0 a 255) que divide la imagen en píxeles blancos y negros y, más tarde, cuenta los píxeles que se encuentran por encima y por debajo de ese umbral (dependiendo de los ajustes establecidos).

La herramienta de presencia/ausencia Recuento de píxeles es útil en situaciones en que se necesita determinar si una característica está presente o ausente según el número de píxeles blancos o negros en una región. Por ejemplo, al verificar que se haya dispensado la cantidad correcta de soldadura alrededor de un cable de circuito impreso o al verificar la presencia de una cadena de texto de inyección de tinta completo en una etiqueta.

  1. Configuración de la herramienta de presencia/ausencia Recuento de píxeles
    1. Selección de una característica
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Recuentos de píxeles
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Recuento de píxeles

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar


Configuración de la herramienta de presencia/ausencia Recuento de píxeles

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen para aislar su característica:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione la región sobre la característica y asegúrese de que los límites de la región cubran la característica. Los límites deben configurarse de manera que solo incluyan la característica que desea medir. Si la región es mayor que la característica, los resultados pueden ser imprecisos porque también se calcularán los píxeles del fondo. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que la característica se encuentre aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Selección de una característica

A la hora de elegir una característica para utilizar en la inspección, tenga en cuenta los siguientes criterios para asegurarse los mejores resultados:

  • Si no está utilizando un elemento, asegúrese de que la característica se encuentre más o menos en la misma ubicación en cada imagen o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.
  • La herramienta Recuento de píxeles es útil en aplicaciones en las que la característica inspeccionada contiene una mezcla de valores de escala de grises cuando está presente, y un conjunto uniforme de valores de escala de grises cuando está ausente.
  • La herramienta Recuento de píxeles puede distinguir diferencias sutiles en luminosidad y contraste, y es más exacta al calibrar esas diferencias que las herramientas de presencia/ausencia de luminosidad o de contraste.
Closed Ejemplo


Ajuste de los parámetros de la herramienta de presencia/ausencia Recuento de píxeles

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Sistemas de visión In-Sight

El panel de ajustes de la herramienta de presencia/ausencia Recuento de píxeles consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Histograma
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de presencia/ausencia Recuentos de píxeles

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a los sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de la herramienta de presencia/ausencia Recuento de píxeles .

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Closed Indicador de aceptaciones/rechazos

Muestra un círculo verde [image] o un rectángulo rojo [image] para indicar el éxito o el fallo en cada caso.

Closed Selector de píxeles

Define cómo segmenta la herramienta la imagen en áreas de píxeles blancos y píxeles negros. La herramienta cuenta de manera predeterminada los píxeles negros, y estos se resaltan en amarillo en la región.

Imagen original

Color de píxel = Negro seleccionado

El controlador de la izquierda fija el valor de umbral bajo (0 - 255), y el controlador de la derecha fija el valor de umbral alto (0 - 255). Puede establecer los valores de forma manual moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Para contar los píxeles blancos, pulse [image]. Ahora los píxeles blancos se resaltarán en amarillo en la región seleccionada.

Color de píxel = Blanco seleccionado
Closed Botón Automático

Establece automáticamente los límites de rango como el resultado más reciente de la herramienta, +/- un 10 % del valor máximo del resultado de la herramienta. Por ejemplo, si el valor máximo del resultado de la herramienta es 255 y el resultado más reciente de la herramienta es 150, el límite mínimo del rango se establecerá en 125 (=150 - 25) y el límite máximo del rango, en 175 (=150 + 25) al hacer clic en el botón Automático.

Closed Medidor de contador de píxeles y rango de aceptación

Define el número aceptable de píxeles en la región. Los controladores establecen el número máximo y mínimo de píxeles blancos y negros que deben contarse dentro de los límites del rango para aceptar la herramienta.

ACEPTACIÓN
RECHAZO

Si el resultado se encuentra entre los controladores de la izquierda y la derecha, la herramienta se acepta y aparece un borde verde alrededor del medidor. De lo contrario, la herramienta no se rechaza y aparece un borde rojo alrededor del medidor.

Puede establecer los valores de forma manual moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Nota: Al pasar el ratón sobre el control deslizante se muestra el resultado (el número de píxeles encontrados en la región) y los valores de rango de aceptación.

Closed Invertir resultado

Con esta opción habilitada, la herramienta obtiene un rechazo si el resultado se encuentra dentro de los límites del rango. (Valor predeterminado = Desactivado)

Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Closed Mostrar detalles

Define si los píxeles contados se muestran siempre o no en el área de la imagen (resaltada en amarillo).

Consejo: Para visualizar los píxeles contados en VisionView, seleccione el nombre simbólico Show_Details en EasyView en el paso de aplicación Comunicación y compruebe la casilla de verificación Show_Details en la aplicación VisionView. Para más información sobre cómo se muestran los datos en VisionView, véase Configuración de EasyView.

  • On ( [image] = valor predeterminado): los píxeles contados siempre se muestran en el área de imagen a menos que se edite otra ubicación o herramienta de inspección.

  • Off ( [image]): los píxeles contados se muestran en el área de imagen solamente si se está editando esta herramienta.

Closed Inversión de píxeles seleccionados

Modifica el color de los píxeles que se van a contar, Negro [image] o Blanco [image] (valor predeterminado = Negro).

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Nombre

Define el nombre de su herramienta de inspección. El nombre predeterminado es "Pixeles_1" (si es la primera herramienta Patrón añadida a la tarea; de lo contrario, se incrementará, p. ej., "Pixeles_2", "Pixeles_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Elemento

Selecciona un elemento para la herramienta. El botón Elemento cambia a color naranja cuando se ha habilitado el control de elemento.

Nota: Este control solo puede habilitarse si ya se ha añadido otra herramienta que defina un elemento.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia Recuento de píxeles - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección, que se utilizará en la configuración de los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "Pixeles_1" (cuando se agrega la primera herramienta Recuento de píxeles a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Pixeles_2", "Pixeles_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia de recuento de píxeles - ficha Ajustes

Closed Modo de umbral

Define el modo de determinar el valor de la escala de grises que segmenta la región de la imagen en píxeles negros y blancos. Si se selecciona Automático (valor predeterminado = Automático), la herramienta creará un ajuste inteligente predeterminado basado en la imagen cada vez que se adquiera una imagen, con un ajuste constante de los cambios de brillo de imagen a imagen. Si se selecciona Manual, el usuario introduce y ajusta los dos valores de umbral manualmente.

Closed Umbral bajo

Define el valor de escala de grises que separa los píxeles negros de los blancos(0 - 255 cuando está activado). Si el valor de Umbral alto es ≥ valor de Umbral bajo, los píxeles blancos se definen como Umbral bajo ≤ valor ≤ Umbral alto; si Umbral alto < Umbral bajo, los píxeles blancos se definen como valor ≤ Umbral alto o Umbral bajo ≤ valor. De forma predeterminada, el control está desactivado y, para habilitarlo, es necesario establecer el Modo de umbral en Manual. Utilice el gráfico de la ficha Histograma para establecer un valor óptimo para su aplicación.

  • Umbral bajo ≤ Umbral alto: Todo lo que se encuentre entre los umbrales se considera "Blanco", indistintamente del valor de escala de grises real. Todo lo que se encuentre fuera de los umbrales se considera "Negro", indistintamente del valor de escala de grises real.
  • Umbral alto ≤ Umbral bajo: Todo lo que se encuentre entre los umbrales se considera "Negro", indistintamente del valor de escala de grises real. Todo lo que se encuentre fuera de los umbrales se considera "Blanco", indistintamente del valor de escala de grises real.
Closed Umbral alto

Define el valor de escala de grises que separa los píxeles negros de los blancos(0 - 255 cuando está activado). Si el valor de Umbral alto es ≥ valor de Umbral bajo, los píxeles blancos se definen como Umbral bajo ≤ valor ≤ Umbral alto; si Umbral alto < Umbral bajo, los píxeles blancos se definen como valor ≤ Umbral alto o Umbral bajo ≤ valor. De forma predeterminada, el control está desactivado y, para habilitarlo, es necesario establecer el Modo de umbral en Manual. Utilice el gráfico de la ficha Histograma para establecer un valor óptimo para su aplicación.

  • Umbral bajo ≤ Umbral alto: Todo lo que se encuentre entre los umbrales se considera "Blanco", indistintamente del valor de escala de grises real. Todo lo que se encuentre fuera de los umbrales se considera "Negro", indistintamente del valor de escala de grises real.
  • Umbral alto ≤ Umbral bajo: Todo lo que se encuentre entre los umbrales se considera "Negro", indistintamente del valor de escala de grises real. Todo lo que se encuentre fuera de los umbrales se considera "Blanco", indistintamente del valor de escala de grises real.
Closed Polaridad

Define el color de los píxeles que se van a contar, Negro o Blanco (valor predeterminado = Blanco).


Herramienta Presencia/ausencia de recuentos de píxeles - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de píxeles en la región; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Píxeles

Indica el número de píxeles encontrados en la región (el valor puede variar de 0 al área máxima de la región); los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número mínimo admisible de píxeles en la región; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de presencia/ausencia Recuento de píxeles - ficha Histograma

La ficha Histograma muestra una representación del histograma de los valores en la escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • La línea vertical azul indica el umbral que se usa para separar la región de la imagen por píxeles blancos y negros; los valores a la izquierda de la línea se consideran negros y los valores a la derecha de ella se consideran blancos.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Herramienta de presencia/ausencia Recuento de píxeles - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Recuento de píxeles

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Region_Compuesta | A | X |
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Umbral_Alto | I | X | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I | X | Entrada
Umbral_Bajo | I | X | Entrada
Máximo | I | X | Entrada
Mínimo | I | X | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Píxeles | I | X |
Polaridad | I | X | Entrada
Mostrar_Detalles | I | X | Entrada
Estado | I | X |
Modo_Umbral | I | X | Entrada
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | I | X | Entrada/Salida
Mínimo | I | X | Entrada/Salida
Polaridad | I | X | Entrada/Salida
Umbral_Bajo | I | X | Entrada/Salida
Umbral_Alto | I | X | Entrada/Salida
Modo_Umbral | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | I |  | Salida
Recuento_Rechazos | I | X | Salida
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X | Salida
Píxeles | I | X | Salida
Estado | I | X | Salida
Herramienta_Estado_Habilitado | I | X | Salida
Region_Compuesta | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Polaridad | I | X | X | Entrada/Salida
Umbral_Bajo | I | X | X | Entrada/Salida
Umbral_Alto | I | X | X | Entrada/Salida
Modo_Umbral | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  | Salida
Recuento_Rechazos | I | X | X | Salida
Aceptación | I | X |  | Salida
Recuento_Aceptaciones | I | X | X | Salida
Píxeles | I | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Region_Compuesta | A |  | X |


Herramientas de presencia/ausencia - Recuento de píxeles de color

La herramienta de presencia/ausencia - Recuento de píxeles de color determina si una característica está presente o ausente en función del número de píxeles que coinciden con los colores entrenados en la tabla de colores (sensores de visión en color In-Sight de la serie 2000) o con los modelos de colores entrenados en la biblioteca (sistemas de visión en color In-Sight) que están presentes en la región y comunica ese valor.

Nota: Cuando la herramienta está conectada al sensor de visión In-Sight de la serie 2000, solo informa del estado de aceptación o rechazo.

  1. Configuración de la herramienta de presencia/ausencia Recuento de píxeles de color
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Recuento de píxeles de color
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Recuento de píxeles de color


Configuración de la herramienta de presencia/ausencia Recuento de píxeles de color

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen para aislar su característica:

Sensores de visión en color In-Sight de la serie 2000

Sistemas de visión en color In-Sight

Sensores de visión en color In-Sight de la serie 2000

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione la región sobre la característica y asegúrese de que los límites de la región cubran la característica. Los límites deben configurarse de manera que solo incluyan la característica que desea medir. Si la región es mayor que la característica, los resultados pueden ser imprecisos porque también se calcularán los píxeles del fondo. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que la característica se encuentre aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez que haya configurado la región, tendrá que entrenar los ajustes de color de la herramienta.

    Nota: De forma predeterminada, la herramienta dará como resultado un rechazo al completar las selecciones de color.

  4. Pulse el botón Entrenar colores. Se muestra el panel de contexto de entrenamiento de colores.
  5. Para añadir colores, haga clic en [image].
  6. Mueva el cursor al área de la imagen. Se mostrará un ampliador de imagen en el panel de contexto como ayuda para encontrar el color.

  7. Haga clic para seleccionar el color que desee. Después de hacer clic, el color se añade a la tabla de colores de abajo y todos los píxeles de la región que coincidan con el color seleccionado se volverán amarillos.

    Antes de añadir un color Selección del color Después de añadir un color
  8. Repita los pasos 6 y 7 hasta que la tabla de colores contenga todos los colores necesarios.
  9. Para restar colores, haga clic en [image] y repita los pasos del 6 al 8.
  10. Haga clic en el botón Finalizar selección de color para volver al panel de contexto general.
  11. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  12. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otros dispositivos externos.

Sistemas de visión en color In-Sight

La herramienta de presencia/ausencia Recuento de píxeles de color remite a una biblioteca de modelos de colores entrenados y, a continuación, determina el número de píxeles presentes en la región que coinciden con los modelos de colores seleccionados y entrenados de la biblioteca. Después, la herramienta crea una imagen de salida binaria en escala de grises, en la que cada píxel que coincide con un modelo de colores activo se establece en Blanco (255) y todos los demás píxeles se establecen en Negro (0). Mediante esta imagen de salida binaria, la herramienta busca entonces la imagen y registra el número de píxeles que coinciden con los modelos de colores activos.

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione la región sobre la característica y asegúrese de que los límites de la región cubran la característica. Los límites deben configurarse de manera que solo incluyan la característica que desea medir. Si la región es mayor que la característica, los resultados pueden ser imprecisos porque también se calcularán los píxeles del fondo. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que la característica se encuentre aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de la característica.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:

  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.

  • Si anteriormente se había añadido otra herramienta de color y desea utilizar una biblioteca de colores existente y sus modelos de colores entrenados, vaya a la ficha Ajustes y seleccione la biblioteca de colores que desee; a continuación, active los modelos de colores pertinentes marcándolos en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de presencia/ausencia Recuento de píxeles de color

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Sistemas de visión In-Sight

El panel de ajustes de la herramienta de presencia/ausencia Recuento de píxeles de color consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Biblioteca de colores
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de presencia/ausencia Recuento de píxeles de color

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a los sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de la herramienta de presencia/ausencia Recuento de píxeles .

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Panel de contexto general

Closed Indicador de aceptaciones/rechazos

Muestra un círculo verde [image] o un rectángulo rojo [image] para indicar el éxito o el fallo en cada caso.

Closed Entrenar colores

Abre el panel de contexto de entrenamiento de colores.

Closed Mosaicos de colores

Muestra los primeros 5 colores entrenados añadidos por el botón Seleccionar colores a añadir [image] en el panel de contexto de entrenamiento de colores. Puede ir al panel de contexto de entrenamiento de colores haciendo clic en un mosaico de color.

Closed Medidor de contador de píxeles y Rango de aceptación

Define el número aceptable de píxeles en la región. Los controladores establecen el número máximo y mínimo de píxeles que deben contarse dentro de los límites del rango para aceptar la herramienta.

ACEPTACIÓN
RECHAZO

Si el resultado se encuentra entre los controladores de la izquierda y la derecha, la herramienta se acepta y aparece un borde verde alrededor del medidor. De lo contrario, la herramienta no se rechaza y aparece un borde rojo alrededor del medidor.

Puede establecer los valores de forma manual moviendo los controladores o introduciendo valores en los cuadros de edición correspondientes.

Sugerencia: También puede mover el controlador con las teclas de FLECHA (ARRIBA, ABAJO, DERECHA e IZQUIERDA).

Nota: Al pasar el ratón sobre el control deslizante se muestra el resultado (el número de píxeles encontrados en la región) y los valores de rango de aceptación.

Closed Botón Automático

Establece automáticamente los límites de rango como el resultado más reciente de la herramienta, +/- un 10 % del valor máximo del resultado de la herramienta. Por ejemplo, si el valor máximo del resultado de la herramienta es 255 y el resultado más reciente de la herramienta es 150, el límite mínimo del rango se establecerá en 125 (=150 - 25) y el límite máximo del rango, en 175 (=150 + 25) al hacer clic en el botón Automático.

Closed Invertir resultado

Con esta opción habilitada, la herramienta obtiene un rechazo si el resultado se encuentra dentro de los límites del rango. (Valor predeterminado = Desactivado)

Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Closed Mostrar detalles

Define si los píxeles contados se muestran siempre o no en el área de la imagen (resaltada en amarillo).

Consejo: Para visualizar los píxeles contados en VisionView, seleccione el nombre simbólico Show_Details en EasyView en el paso de aplicación Comunicación y compruebe la casilla de verificación Show_Details en la aplicación VisionView. Para más información sobre cómo se muestran los datos en VisionView, véase Configuración de EasyView.

  • On ( [image] = valor predeterminado): los píxeles contados siempre se muestran en el área de imagen a menos que se edite otra ubicación o herramienta de inspección.

  • Off ( [image]): los píxeles contados se muestran en el área de imagen solamente si se está editando esta herramienta.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Nombre

Define el nombre de su herramienta de inspección. El nombre predeterminado es "PixelesColor_1" (si es la primera herramienta Patrón añadida a la tarea, de lo contrario se incrementará, p. ej., "PixelesColor_2", "PixelesColor_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Elemento

Selecciona un elemento para la herramienta. El botón Elemento cambia a color naranja cuando se ha habilitado el control de elemento.

Nota: Este control solo puede habilitarse si ya se ha añadido otra herramienta que defina un elemento.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Panel de contexto de entrenamiento de colores

Closed Botones Seleccionar colores a añadir y Seleccionar colores a restar

  • Seleccionar colores a añadir: Añada "colores a añadir" a la tabla de colores. Los colores seleccionados con este botón se incluirán al determinar el número de píxeles presentes en la región. Después de seleccionar el color que desee añadir, todos los píxeles que coincidan con el color seleccionado se volverán amarillos.

    Nota: Los primeros 5 colores seleccionados con este botón se mostrarán como "mosaicos de colores" en el panel de contexto general.

    Antes de añadir un color Después de añadir un color
  • Seleccionar colores a restar: Añada "colores a restar" a la tabla de colores. Los colores seleccionados con este botón se excluirán al determinar el número de píxeles en la región.

Una vez que haya hecho clic en el botón Seleccionar colores a añadir o Seleccionar colores a restar y mueva el cursor al área de la imagen, se mostrará un ampliador de imagen en el panel de contexto que le ayudará a encontrar el color que quiera seleccionar.

Ampliador de imagen
Closed Tabla de colores

  • Color: Muestra los colores añadidos con los botones Seleccionar colores a añadir y Seleccionar colores a restar.

    Nota: Al pasar el ratón sobre el control deslizante se muestran los valores RGB.

  • Tolerancia: Define el ajuste de tolerancia del color (0 - 10; valor predeterminado = 2). Puede aumentar o reducir la tolerancia para incluir más o menos matices del color entrenado.

    Nota: Al pasar el ratón sobre el control deslizante se muestra el valor de tolerancia.

    Imagen original

    Tolerancia = 0,5

            Tolerancia = 2 (valor predeterminado) Tolerancia = 7
  • Operaciones:
    • Modificar para restar color: El color se resalta en amarillo en la región y se incluye al determinar el número de píxeles presentes en la región. Este botón permite alternar; haga clic en él para cambiar a restar color.
    • Modificar para añadir color: El color se excluye al determinar el número de píxeles en la región. Este botón permite alternar; haga clic en él para cambiar a añadir color.

    • Subir/Bajar: Cambia el orden de las operaciones de los colores en la tabla. La operación de color se ejecutará de arriba abajo.

    • Eliminar color: Elimina el color de la tabla.
Closed Ignorar brillo

Si está activada la casilla de verificación Ignorar brillo (valor predeterminado), se contará un mayor número de píxeles que son más oscuros o más claros que los colores entrenados. Esto puede ayudar a mejorar el rendimiento de la herramienta si la intensidad de la imagen no es uniforme en todo el campo de visión. Sin embargo, si se van a contar los píxeles negros y/o blancos además de los colores entrenados, esta opción debe estar desactivada.

Closed Finalizar selección de color

Vuelve al panel de contexto general.

Ejemplos de operaciones de color

Closed Ejemplos

En este ejemplo, quiere seleccionar las tizas "azules" y "verdes" de la imagen.

Ejemplo 1

  1. Seleccione el "azul" y el "verde" en la imagen con el botón Seleccionar colores a añadir [image].

    Imagen original Seleccionar "Azul (añadir) " y "Verde (añadir)"

  2. Como resultado, también se resaltan parcialmente las tizas moradas porque estos colores (azul, verde y morado) son muy parecidos. El "morado" viene del "azul" (consulte la imagen siguiente); si selecciona un color azul (o cian oscuro), también se seleccionarán colores similares del morado.

  3. Ahora quiere restar el "morado" de la imagen. Seleccione el "morado" del área resaltada de la tiza morada con el botón Seleccionar colores a restar [image].

    Seleccionar "Morado (restar)"
  4. Ya tiene correctamente seleccionadas las tizas azules y verdes.

Ejemplo 2

En este ejemplo, también quiere seleccionar las tizas "azules" y "verdes" de la imagen; sin embargo, puede que no consiga el resultado que desea debido a que el orden las operaciones de color es diferente.

  1. Seleccione el "azul" en la imagen con el botón Seleccionar colores a añadir [image].

  2. Seleccione el "morado" con el botón Seleccionar colores a restar [image].

    Seleccionar "Azul (añadir) " y "Morado (restar)"

  3. Seleccione el "azul" en la imagen con el botón Seleccionar colores a añadir [image].

    Seleccionar "Verde (añadir)"
  4. Como resultado, se resaltan parcialmente las tizas moradas porque el "verde" y el "morado" son muy parecidos. Si selecciona un color verde, también se seleccionarán colores similares del morado.
  5. Para quitar el "morado" de la imagen, baje la operación del morado a la parte inferior con el botón Bajar [image]. También puede añadir la segunda operación del morado utilizando el botón Seleccionar colores a restar [image] después del "verde".


Herramienta de presencia/ausencia Recuento de píxeles de color - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección, que se utilizará en la configuración de los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "Pixeles_1" (cuando se agrega la primera herramienta Recuento de píxeles a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Pixeles_2", "Pixeles_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia de recuentos de píxeles de color - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"


Herramienta de presencia/ausencia de recuentos de píxeles de color - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de píxeles en la región; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Píxeles

Indica el número de píxeles encontrados en la región (el valor puede variar de 0 al área máxima de la región); los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número mínimo admisible de píxeles en la región; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de presencia/ausencia de recuentos de píxeles de color - ficha Biblioteca de colores

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Herramienta de presencia/ausencia Recuento de píxeles de color - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Recuento de píxeles de color

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión en color In-Sight de la serie 2000

Nota: OPC no se admite en los sensores de visión en color In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Biblioteca_Colores | I |  | Entrada
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Habilitar_Aplicar_Modelo_Externo | I |  | Entrada
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Máximo | I |  | Entrada
Mínimo | I |  | Entrada
Habilitar_Modelo | I |  | Entrada
Habilitar_Seleccionar_Modelo | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Mostrar_Detalles | I | X | Entrada
Mostrar_Imagen_Original | I |  | Entrada
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sistemas de visión en color In-Sight

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Biblioteca_Colores | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Habilitar_Aplicar_Modelo_Externo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Habilitar_Modelo | I | X | X | Entrada/Salida
Habilitar_Seleccionar_Modelo | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Mostrar_Imagen_Original | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Píxeles | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A | X | X |
Habilitar_Aplicar_Modelo | A | X | X |

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_Evento | A | X | X | Entrada/Salida
Entrenar_Modelo | S | X | X | Entrada/Salida
Entrenar_Operacion | I | X | X | Entrada/Salida
Entrenar_Procedimiento | I | X | X |
Entrenar_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite_Mas_Oscuro | FP | X | X | Entrada/Salida
Limite_Mas_Claro | FP | X | X | Entrada/Salida
Entrenar_Color | S | X | X | Entrada/Salida
Entrenar_Evento | A | X | X |
Entrenar_Region | A | X | X |


Herramientas de presencia/ausencia - Blob

La herramienta de presencia/ausencia Blob determina si una característica de blob está presente o ausente. Si se detecta el blob, la herramienta comunica "Presente" y el resultado de la herramienta es Aceptación. Si no se detecta ningún blob, o si el blob detectado se encuentra fuera de los límites especificados, el resultado de la herramienta es Rechazo.

La herramienta de presencia/ausencia Blob es una de las herramientas más rápidas, capaz de detectar características de blobs mucho más rápidamente que una herramienta de presencia/ausencia Patrón. Esta herramienta es útil para verificar la presencia o ausencia de una característica compuesta de píxeles adyacentes. Por ejemplo, para verificar la presencia o ausencia de un orificio taladrado en una pieza metálica.

  1. Configuración de la herramienta de presencia/ausencia Blob
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Blob
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Blob


Configuración de la herramienta de presencia/ausencia Blob

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los blobs; asegúrese de que los límites de la región cubran tanto los blobs como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los blobs se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de presencia/ausencia Blob

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de presencia/ausencia Blob consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Histograma
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de presencia/ausencia Blob - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Blob_1" (si se trata de la primera herramienta de blob agregada a la tarea; de lo contrario, se incrementará, es decir, "Blob_2", "Blob_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Presencia/ausencia de blobs - ficha Ajustes

Closed Modo de umbral

Define el modo de determinación del valor de escala de grises utilizado para separar blobs del fondo. Con la opción "Auto" activada (ajuste predeterminado), cada vez que se adquiere una imagen la herramienta se ajusta a los cambios de luminosidad que se producen entre imágenes sucesivas. Si selecciona Manual, deberá introducir el valor y ajustarlo manualmente.

Closed Umbral de blob

Define el valor de escala de grises utilizado para separar blobs del fondo (0 - 255, si está habilitado). De forma predeterminada, este control está desactivado. Para activarlo, es necesario ajustar Modo de umbral a Manual. Utilice el gráfico para definir el valor óptimo para su aplicación.

Closed Color de blob

Define el color del blob (Negro, Blanco o Cualquiera; valor predeterminado = Cualquiera).

  • Cualquiera = No hay ningún requisito para el color del blob.
  • Negro = Devuelve solamente los blobs por debajo de Umbral de blob.
  • Blanco = Devuelve solamente los blobs por encima de Umbral de blob.
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado – No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado – Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que se intersecan, siempre que cumplan los demás criterios.
Closed Área mínima

Define una restricción de área mínima, en número de píxeles (0 a 900000; valor predeterminado = 100), para todos los blobs detectados; sólo se reconocerán blobs con un área mayor que el área mínima.

Closed Área máxima

Define una restricción de área máxima, en número de píxeles (0 a 900000; valor predeterminado = 100000), para todos los blobs detectados; sólo se reconocerán blobs con un área menor que el área máxima.

Closed Resultado

Muestra el resultado de la herramienta: Presente si se detectó la característica de blob; No presente si no se detectó o si el blob encontrado estaba fuera de los límites especificados. Presente equivale a un valor boleano de 1 (Aceptación); No presente equivale a un valor boleano de 0 (Rechazo).

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.


Herramienta de presencia/ausencia Blob - ficha Histograma

El histograma muestra una representación gráfica de los valores de escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • La línea vertical azul indica el umbral que se usa para separar la región de la imagen por píxeles blancos y negros; los valores a la izquierda de la línea se consideran negros y los valores a la derecha de ella se consideran blancos.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Herramienta de presencia/ausencia Blob - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Blob

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color_Blob | I | X | X | Entrada/Salida
Umbral_Blob | I | X | X | Entrada/Salida
Limite | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Area_Maxima | FP | X | X | Entrada/Salida
Area_Minima | FP | X | X | Entrada/Salida
Modo_Umbral | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A |  | X |


Herramientas de presencia/ausencia - Blob de color

La herramienta de presencia/ausencia Blob de color determina si una característica de blob está presente o ausente.

La herramienta Blob de color primero establece una referencia a una biblioteca entrenada de modelos de colores y luego determina el número de píxeles presentes en la región que coinciden con los modelos de colores seleccionados y entrenados de la biblioteca. A continuación, la herramienta genera una imagen binaria de salida en escala de grises, en la que cada píxel que coincide con un modelo de colores activo se ajusta a blanco (255), mientras que los demás píxeles se ajustan a negro (0). Usando esta imagen de salida binaria, la herramienta busca en la imagen las características de blob creadas por el Modelo de colores activo.

  1. Configuración de la herramienta de presencia/ausencia Blob de color
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Blob de color
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Blob de color


Configuración de la herramienta de presencia/ausencia Blob de color

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los blobs; asegúrese de que los límites de la región cubran tanto los blobs como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los blobs se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:
  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.
  • Si previamente se añadió otra herramienta de color y desea utilizar una biblioteca de colores existente y los correspondientes modelos de colores entrenados, abra la ficha Ajustes, seleccione la biblioteca de colores deseada y después active los modelos de colores deseados activando las casillas correspondientes en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de la herramienta de presencia/ausencia Blob de color

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de presencia/ausencia Blob de color consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Biblioteca de colores
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de presencia/ausencia Blob de color - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección, que se utilizará en la configuración de los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "Pixeles_1" (cuando se agrega la primera herramienta Recuento de píxeles a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Pixeles_2", "Pixeles_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia de blobs de color - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado – No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado – Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que se intersecan, siempre que cumplan los demás criterios.
Closed Área mínima

Define una restricción de área mínima, en número de píxeles (0 a 900000; valor predeterminado = 100), para todos los blobs detectados; sólo se reconocerán blobs con un área mayor que el área mínima.

Closed Área máxima

Define una restricción de área máxima, en número de píxeles (0 a 900000; valor predeterminado = 100000), para todos los blobs detectados; sólo se reconocerán blobs con un área menor que el área máxima.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Resultado

Muestra el resultado de la herramienta: Presente si se detecta la característica de blob; No presente si no se detecta o si el blob encontrado se encontraba fuera de los límites especificados. Presente equivale a un valor booleano de 1 (Aceptación); No presente equivale a un valor booleano de 0 (Rechazo).


Herramienta de presencia/ausencia Blob de color - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramienta de presencia/ausencia de blobs de color - Biblioteca de colores

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Blob de color

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite | I | X | X | Entrada/Salida
Biblioteca_Colores | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Habilitar_Aplicar_Modelo_Externo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Area_Maxima | FP | X | X | Entrada/Salida
Area_Minima | FP | X | X | Entrada/Salida
Habilitar_Modelo | I | X | X | Entrada/Salida
Habilitar_Seleccionar_Modelo | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Factor_Suavizado | I | X | X | Entrada/Salida
Mostrar_Imagen_Original | I | X | X | Entrada/Salida
Blobs | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A | X | X |
Habilitar_Aplicar_Modelo | A | X | X |

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_Evento | A | X | X | Entrada/Salida
Entrenar_Modelo | S | X | X | Entrada/Salida
Entrenar_Operacion | I | X | X | Entrada/Salida
Entrenar_Procedimiento | I | X | X |
Entrenar_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite_Mas_Oscuro | FP | X | X | Entrada/Salida
Limite_Mas_Claro | FP | X | X | Entrada/Salida
Entrenar_Color | S | X | X | Entrada/Salida
Entrenar_Evento | A | X | X |
Entrenar_Region | A | X | X |


Herramientas de presencia/ausencia - Margen

La herramienta de presencia/ausencia Margen se utiliza para determinar la presencia o ausencia de características de margen lineal incluidas en el ámbito de los parámetros especificados.

La herramienta de presencia/ausencia Margen es una de las herramientas rápidas con la capacidad de reconocer características de margen con mucha más rapidez que una herramienta de presencia/ausencia Patrón.

  1. Configuración de la herramienta de presencia/ausencia Margen
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Margen
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Margen

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar


Uso de la herramienta de presencia/ausencia Margen

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen para aislar su característica:

  1. Sitúe la región de línea a lo largo de la característica de margen.
Closed Ejemplo

Posicionamiento de la región de línea a lo largo de la característica de margen.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. EasyBuilder creará automáticamente una región de margen alrededor de la característica de margen seleccionada.
Closed Ejemplo

Región creada automáticamente.

  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta Presencia/ausencia de márgenes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta Ubicación de márgenes consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de presencia/ausencia Margen - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Margen_1" (si se trata de la primera herramienta de Margen agregada a la tarea; de lo contrario, se incrementará, es decir, "Margen_2", "Margen_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Presencia/ausencia de márgenes - ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un ajuste inteligente que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta - su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable.

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar por

Define cómo la herramienta debe discriminar los márgenes encontrados cuando hay múltiples márgenes presentes (valor predeterminado = Mejor puntuación).

  • Mejor puntuación = La característica de margen que tenga el margen más contrastado.
  • Primer margen = La característica de margen más cercana al comienzo de la dirección de exploración de la región.
  • Último margen = La característica de margen más alejada del comienzo de la dirección de exploración de la región.
Closed Rango de ángulos

Define la cantidad máxima de traslación angular que el margen encontrado puede experimentar (0-10°; valor predeterminado = 10°). Cuanto mayor sea la variación angular admisible, más tiempo de ejecución necesitará la herramienta.

Closed Resultado

Muestra el resultado de la herramienta: Presente si se detectó la característica de margen; No presente si no se detectó o si el margen encontrado estaba fuera de los límites especificados. Presente equivale a un valor booleano de 1 (Aceptación); No presente equivale a un valor booleano de 0 (Rechazo).

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.


Herramienta de presencia/ausencia Margen - Gráfico

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Margen

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Rango_Angulos | I |  | Entrada
Descripción | S | X | Entrada
Contraste_Margen | I |  | Entrada
Transicion_Margen | I |  | Entrada
Ancho_Margen | I |  | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Buscar_Por | I |  | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Rango_Angulos | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Buscar_Por | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Márgenes | S | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Región | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Rango_Angulos | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Buscar_Por | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Márgenes | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región | A | X | X |


Herramientas de presencia/ausencia - Círculo

La herramienta de presencia/ausencia Círculo se utiliza para determinar la presencia o ausencia de características de margen circular incluidos en el ámbito de los parámetros especificados.

La Herramienta de ubicación Círculo es una de las herramientas rápidas con la capacidad de reconocer características de margen con mucha más rapidez que una herramienta de presencia/ausencia Patrón.

  1. Configuración de la herramienta de presencia/ausencia Círculo
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Círculo
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Círculo

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar


Configuración de la herramienta de presencia/ausencia Círculo

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen para aislar su característica:

  1. Sitúe y configure la región circular directamente sobre la característica de margen circular; asegúrese de redimensionarla para hacerla coincidir en tamaño y dimensiones con la característica circular.
Closed Ejemplo

Posicionamiento de la región circular sobre una característica

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. EasyBuilder creará automáticamente una región de margen anular alrededor de la característica de margen circular.
Closed Ejemplo

Región anular alrededor de una característica de margen circular

  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta Presencia/ausencia de círculos

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta Presencia/ausencia de círculos consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta Presencia/ausencia de círculos - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Circulo_1" (si se trata de la primera herramienta de Círculo agregada a la tarea; de lo contrario, se incrementará, es decir, "Circulo_2", "Circulo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Presencia/ausencia de círculos - ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un "ajuste inteligente" que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta (su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable).

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar por

Define cómo la herramienta debe discriminar los márgenes circulares encontrados cuando hay múltiples márgenes circulares presentes (valor predeterminado = Mejor puntuación).

  • Mejor puntuación = Se elegirá la característica de margen circular que tenga el mayor contraste.
  • Círculo más pequeño = Se elegirá la característica de margen circular que tenga el menor diámetro.
  • Círculo más grande = Se elegirá la característica de margen circular que tenga el mayor diámetro.
Closed Resultado

Muestra el resultado de la herramienta: Presente si se detectó la característica de margen circular; No presente si no se detectó o si el margen circular encontrado estaba fuera de los límites especificados.Presente equivale a un valor booleano de 1 (Aceptación); No presente equivale a un valor booleano de 0 (Rechazo).

Closed Invertir resultado
Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.


Herramienta de presencia/ausencia Círculo - Gráfico

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Círculo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Contraste_Margen | I |  | Entrada
Transicion_Margen | I |  | Entrada
Ancho_Margen | I |  | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Buscar_Por | I |  | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Buscar_Por | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Radio.Circulo | FP | X | Salida
Circulo.X | FP | X | Salida
Circulo.Y | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Espacio_Anular | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Buscar_Por | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Radio.Circulo | FP | X | X | Salida
Circulo.X | FP | X | X | Salida
Circulo.Y | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Espacio_Anular | A | X | X |


Herramientas de presencia/ausencia - Nitidez

La herramienta de presencia/ausencia Nitidez determina si una imagen está enfocada correctamente, basándose en la puntuación de nitidez de la imagen dentro de la región. La herramienta calcula una medida del foco relativo de una imagen de entrada, como parte del proceso iterativo para reenfocar la lente del sistema de visión In-Sight.

La puntuación de nitidez de la imagen indica en qué grado la región contenida en la imagen incluye las características resolubles más pequeñas de una "escena" (es decir, el objeto y su fondo, capturados en la imagen).

  1. Configuración de la herramienta de presencia/ausencia Nitidez
  2. Ajuste de los parámetros de la herramienta de presencia/ausencia Nitidez
  3. Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Nitidez


Configuración de la herramienta de presencia/ausencia Nitidez

Una vez añadida la herramienta, deberá configurar la región en la imagen:

  1. Sitúe la región dentro de la imagen de modo que abarque las piezas importantes de la "escena" (es decir, el objeto y su fondo). Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si usted no está utilizando un elemento, asegúrese de que la escena medida se encuentre en el mismo lugar en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez añadida la herramienta, la puntuación de nitidez de la imagen debe compararse con otra puntuación de nitidez de la misma escena (es decir, con el mismo objeto y fondo, con el sistema de visión In-Sight en la misma orientación y posición, con la misma iluminación, etc.). Una única puntuación de nitidez de la imagen no aporta suficiente información sobre la nitidez absoluta de la región de la imagen.
  4. Vaya al paso Configurar imagen y active el modo Vídeo en vivo. Vuelva a enfocar la lente del sistema de visión In-Sight, asegurándose de que no se haya modificado nada en la escena.
  5. Salga del modo Vídeo en vivo. La herramienta calculará una nueva puntuación de nitidez de la imagen.
  6. Compare la nueva puntuación con la anterior; cuanto mayor sea la puntuación, más nítido será el enfoque.
  7. Repita los pasos 4 y 5 hasta que el enfoque sea aceptable.

Nota: Si el enfoque sigue siendo inaceptable, plantéese la posibilidad de cambiar la lente, ajustar la distancia entre la lente y el objeto u otro parámetro de adquisición de imágenes en el paso de la aplicación Configurar imagen.


Ajuste de los parámetros de la herramienta de presencia/ausencia Nitidez

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de presencia/ausencia Nitidez consta de las fichas siguientes:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de presencia/ausencia Nitidez - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Nitidez_1" (si se trata de la primera herramienta de nitidez agregada a la tarea; de lo contrario, se incrementará, es decir, "Nitidez_2", "Nitidez_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de presencia/ausencia Nitidez - ficha Límites de rango

Closed Máximo

Define el máximo valor admisible de nitidez de la imagen; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Nitidez

Indica la puntuación de nitidez de la imagen en la región; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o se encuentren entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el mínimo valor promedio admisible de nitidez de la imagen; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de presencia/ausencia Nitidez

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Suavidad | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Nitidez | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región_compuesta | A | X | X |


Herramientas de medición - Distancia

La herramienta de medición Distancia calcula la distancia entre cualesquiera dos características de entrada y comunica la distancia calculada.

Nota: La herramienta informa de las coordenadas X e Y en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensores de visión 2000-130/130C y 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de medición Distancia es útil en situaciones en que se necesita calibrar con precisión una pieza u objeto. Por ejemplo, para determinar la distancia entre los extremos de una pieza o la distancia de centro a centro entre dos orificios.

  1. Configuración de la herramienta de medición Distancia
  2. Ajuste de los parámetros de la herramienta de medición Distancia
  3. Uso de las propiedades de entrada/salida de la herramienta de medición Distancia


Configuración de la herramienta de medición Distancia

Una vez agregada la herramienta, deberá definir las características a medir:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la segunda característica.
  4. Una vez seleccionada la segunda característica, EasyBuilder calculará automáticamente la distancia entre las características. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta Medición de distancias

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la Herramienta Medición de distancias consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de medición Distancia - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Distancia_1" (si se trata de la primera herramienta de distancia agregada a la tarea; de lo contrario, se incrementará, es decir, "Distancia_2", "Distancia_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Medición de distancias - ficha Ajustes

Closed Medición

Especifica cómo se calculará la distancia entre dos características de márgenes: Punto medio a línea (ajuste predeterminado, que mide la distancia perpendicular entre los segmentos de márgenes) o Punto medio a punto medio.

Nota: Este control sólo está habilitado al medir la distancia de al menos una característica de margen; en caso contrario, la distancia se calcula automáticamente de la manera siguiente:
  • Círculo a línea: Mide desde el centro del círculo a la intersección perpendicular de una característica de margen o línea de referencia.
  • Punto a línea: Mide desde el punto de la intersección perpendicular de una característica de margen o línea de referencia.
  • Círculo a punto: Mide desde el centro del círculo al punto.
  • Círculo a círculo: Mide desde el centro de un círculo al centro de otro.
  • Punto a punto: Mide desde los dos puntos.

Un punto se refiere a una característica previamente definida, a un blob, círculo, margen, patrón o punto, y se reconoce como sigue:

  • Blob: Mide desde las coordenadas X,Y del centroide del blob.
  • Círculo: Mide desde las coordenadas X,Y del centro del círculo.
  • Margen: Mide desde las coordenadas X,Y del punto medio del margen.
  • Patrón: Mide desde las coordenadas de origen X,Y del patrón modelo.
  • Punto: Mide desde las coordenadas X,Y del punto.


Herramienta Medición de distancias - ficha Límites de rango

Closed Máximo

Define el valor máximo de distancia admisible; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Distancia

Indica la distancia medida actual entre ambas características; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica medidas en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor mínimo de distancia admisible; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de medición Distancia

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Distancia | FP | X | Salida
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Máximo | FP |  | Entrada
Tipo_Medición | I |  | Entrada
Mínimo | FP |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Tipo_Medición | I | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Distancia | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Tipo_Medición | I | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Distancia | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de medición - Ángulo

La herramienta de medición Ángulo calcula el ángulo entre dos características de ángulo.

La herramienta de medición Ángulo es útil, por ejemplo, en situaciones en que se necesita calibrar con precisión una pieza u objeto.

  1. Configuración de la herramienta de medición Ángulo
  2. Ajuste de los parámetros de la herramienta de medición Ángulo
  3. Uso de las propiedades de entrada/salida de la herramienta de medición Ángulo


Configuración de la herramienta de medición Ángulo

Una vez agregada la herramienta, deberá definir las características de entrada a medir.

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la segunda característica.
  4. Después de seleccionar la segunda característica, EasyBuilder calculará automáticamente el ángulo entre las características y dibujará un gráfico en la imagen indicando dónde se intersecan los dos márgenes y se está midiendo el ángulo. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta Medición de ángulos

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la Herramienta Medición de ángulos consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de medición Ángulo - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Ángulo_1" (si se trata de la primera herramienta de ángulo agregada a la tarea; de lo contrario, se incrementará, es decir, "Ángulo_2", "Ángulo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Medición de ángulos - ficha Límites de rango

Closed Máximo

Define el valor máximo de ángulo admisible; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Distancia

Indica el ángulo medido actual entre ambas características; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica las coordenadas X,Y en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor mínimo de ángulo admisible; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de medición Ángulo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Ángulo | FP | X | Salida
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Máximo | FP |  | Entrada
Mínimo | FP |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Ángulo | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Ángulo | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de medición - Área de blob y Áreas de blobs (1-10)

La herramienta de medición Área de blob y la herramienta de medición Áreas de blobs (1-10) miden el área de la característica de blob más grande encontrada y comunican el tamaño del blob más grande. La herramienta Área de blob se utiliza para medir un único blob, mientras que la herramienta Áreas de blobs (1-10) permite medir hasta 10 blobs.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Las herramientas de medición Área de blob y Áreas de blobs (1-10) resultan útiles, por ejemplo, para calibrar el área prevista de una característica o para detectar obstrucciones en orificios.

  1. Configuración de las herramientas de medición Área de blob y Áreas de blobs (1-10)
  2. Ajuste de los parámetros de las herramientas de medición Área de blob y Áreas de blobs (1-10)
  3. Uso de las propiedades de entrada/salida de las herramientas de medición Área de blob y Áreas de blobs (1-10)


Configuración de las herramientas de medición Área de blob y Áreas de blobs (1-10)

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los blobs; asegúrese de que los límites de la región cubran tanto los blobs como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los blobs se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de las herramientas de medición Área de blob y Áreas de blobs (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

Los paneles de ajustes de la herramienta de medición Área de blob y Áreas de blobs (1-10) constan de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Tabla
  • Ficha Histograma
  • Ficha Región compuesta
Notas:
  • La ficha Histograma no se mostrará si falla la herramienta.
  • La fichaTabla solo está habilitada para la herramienta de medición Áreas de blobs (1-10).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramientas de medición Área de blob y Áreas de blobs (1-10) - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Blob_1" (si se trata de la primera herramienta de blob agregada a la tarea; de lo contrario, se incrementará, es decir, "Blob_2", "Blob_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de medición de área de blob y de áreas de blobs (1-10) - ficha Ajustes

Closed Modo de umbral

Define el modo de determinación del valor de escala de grises utilizado para separar blobs del fondo. Con la opción "Auto" activada (ajuste predeterminado), cada vez que se adquiere una imagen la herramienta se ajusta a los cambios de luminosidad que se producen entre imágenes sucesivas. Si selecciona Manual, deberá introducir el valor y ajustarlo manualmente.

Closed Umbral de blob

Define el valor de escala de grises utilizado para separar blobs del fondo (0 - 255, si está habilitado). De forma predeterminada, este control está desactivado. Para activarlo, es necesario ajustar Modo de umbral a Manual. Utilice el Histograma para definir el valor óptimo para su aplicación.

Closed Color de blob

Define el color del blob (Negro, Blanco o Cualquiera; valor predeterminado = Cualquiera).

  • Cualquiera = No hay ningún requisito para el color del blob.
  • Negro = Devuelve solamente los blobs por debajo del Umbral de blob.
  • Blanco = Devuelve solamente los blobs por encima del Umbral de blob.
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado – No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado – Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que intersecan, siempre que cumplan los demás criterios.
Closed Límite de área mínima

Define una restricción de área mínima, en número de píxeles (0 a -900.000; valor predeterminado = 50), para detectar blobs; sólo se reconocerán blobs con un área mayor que el Límite de área mínima.

Nota: El parámetro Mínimo de la ficha Límite de rango determina si la herramienta se acepta o se rechaza, mientras que el parámetro Límite de área mínima determina si se informa o no de los blobs.

Closed Límite de área máxima

Define una restricción de área máxima, en número de píxeles (0 a -900.000; valor predeterminado = 307.200), para detectar blobs; sólo se reconocerán blobs con un área menor que el Límite de área máxima.

Nota: El parámetro Máximo de la ficha Límite de rango determina si la herramienta se acepta o se rechaza, mientras que el parámetro Límite de área máxima determina si se informa o no de los blobs.

Closed Número a buscar

Define el número de blobs que deben detectarse (1 a 10; predeterminado = 1). La mayoría de aplicaciones sólo requieren un único elemento. Sin embargo, pueden localizarse múltiples blobs, lo cual resulta útil en aplicaciones cuyas imágenes contienen más de una pieza u objeto. El tiempo de ejecución de la herramienta aumenta con el número de blobs que la herramienta deba identificar.

Closed Ordenar por

Define cómo la herramienta medirá y clasificará los blobs encontrados (Área, Fila, Columna, Cuadrícula: Fila, luego columna desde el elemento, Cuadrícula: Columna, luego fila desde el elemento, Distancia desde el origen del elemento, Rotación en sentido antihorario desde el eje de fila del elemento, Distancia angular; predeterminado = Área):

  • Área = Ordena por los tamaños de las áreas de los blobs encontrados, de grande a pequeña.
  • Fila = Ordena por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Columna = Ordena por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Fila, luego columna desde el elemento = Ordena por distancias primero a lo largo del eje de fila de la imagen del elemento, y luego por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Columna, luego fila desde el elemento = Ordena por distancias primero a lo largo del eje de columna de la imagen del elemento, y luego por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Distancia desde el origen del elemento = Ordena por distancias desde el origen del elemento al centroide del blob, en orden descendente, de menor a mayor distancia.
  • Rotación en sentido antihorario desde el eje de fila del elemento = Ordena por los ángulos (0 a 360°) medidos desde el eje de fila de la imagen del elemento hasta el segmento de línea definido por el centroide del blob y el origen del elemento, en orden descendente, de menor a mayor distancia.
  • Distancia angular = Ordena por los ángulos absolutos (-180 a 180°) medidos desde el eje de fila de la imagen del elemento hasta un segmento de línea definido por el centroide del blob y el origen del elemento, de menor a mayor distancia.

Nota: La herramienta Medición de áreas de blobs no contiene el parámetro Número a buscar.


Herramientas de medición de área de blob y de áreas de blobs (1-10) - ficha Límites de rango

Closed Máximo

Define el valor aceptable máximo del valor del área del blob; la herramienta creará un ajuste predeterminado del "límite inteligente" basado en su imagen, que puede personalizar para adaptarse a las necesidades de su aplicación.

Closed Área de blobs

Indica el área de blob medida actualmente; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica medidas en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor aceptable mínimo del valor del área de blob; la herramienta creará un ajuste predeterminado del "límite inteligente" basado en su imagen, que puede personalizar para adaptarse a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de medición de áreas de blobs (1-10) - Tabla

Notas:
  • La herramienta de medición de blobs no ofrece la ficha Tabla; ésta sólo está disponible para la herramienta de medición de blobs (1-10).
  • Cuando el parámetro Ordenar por se ajusta a cualquier otra opción distinta de Área, se agregan a la tabla las columnas Fila de píxeles y Columna de píxeles. Fila de píxeles y Columna de píxeles reflejan las coordenadas de la imagen en la cuadrícula bidimensional del sensor de imágenes del sistema de visión In-Sight (las filas y columnas de la matriz), y son los valores intercambiados (Y/X) de las coordenadas del mundo real (X/Y).

  • Con la opción Orientación clásica activada en el cuadro de grupo Calibrar imagen en unidades del mundo real del paso Configurar imagen, las coordenadas X e Y estarán en el mismo espacio de coordenadas que las coordenadas de la imagen (Y/X).

La ficha Tabla publica los resultados de los blobs encontrados, dependiendo del parámetro Número a buscar indicado en la ficha Ajustes:

Closed Índice

Se refiere al orden de los blobs encontrados, basándose en el parámetro Ordenar por de la ficha Ajustes; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed Área

Devuelve el área del blob encontrado (medido en píxeles).

Closed X

Devuelve la coordenada X del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Y

Devuelve la coordenada Y del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Ángulo

Devuelve el ángulo del centroide del blob encontrado, con respecto al centro de la región.

Closed Error

Devuelve los resultados de error que puedan haberse detectado para los blobs encontrados.

Closed Fila de píxeles

Devuelve la coordenada (X) de la fila de la imagen correspondiente al centroide del blob encontrado.

Closed Columna de píxeles

Devuelve la coordenada (Y) de la columna de la imagen correspondiente al centroide del blob encontrado.


Herramientas de medición Área de blob y Áreas de blobs (1-10) - Histograma

El histograma muestra una representación gráfica de los valores de escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • La línea vertical azul indica el umbral que se usa para separar la región de la imagen por píxeles blancos y negros; los valores a la izquierda de la línea se consideran negros y los valores a la derecha de ella se consideran blancos.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Herramientas de medición Área de blob y Área de blobs (1-10) - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de las herramientas de medición Área de blob y Áreas de blobs (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color_Blob | I | X | X | Entrada/Salida
Umbral_Blob | I | X | X | Entrada/Salida
Limite | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Maximo | FP | X | X | Entrada/Salida
Minimo | FP | X | X | Entrada/Salida
Limite_Maximo_Area | FP | X | X | Entrada/Salida
Limite_Minimo_Area | FP | X | X | Entrada/Salida
Ordenar_Por | I | X | X | Entrada/Salida
Modo_Umbral | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Area_Blob | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Numero_A_Buscar 1 | I | X | X | Entrada/Salida
Area_Blob1-9 1 | FP | X | X | Salida
Numero_Encontrado 1 | FP | X | X | Salida
Region_Compuesta | A |  | X |
1 Estas propiedades de herramienta solo están disponibles con la herramienta de medición Áreas de blobs (1-10).


Herramientas de medición - Área de blob de color y Áreas de blob de color (1-10)

Las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) miden el área de la característica de blob más grande encontrada y comunican el tamaño de dicho blob. La herramienta Área de blob de color se utiliza para medir un solo blob, mientras que la herramienta Áreas de blob de color (1-10) permite medir hasta 10 blobs.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Las herramientas Área de blob de color y Áreas de blobs de color (1-10) hacen referencia a una biblioteca entrenada de Modelos de colores y luego determinan el número de píxeles presentes en la región que coinciden con los Modelos de colores seleccionados y entrenados en la biblioteca. A continuación, la herramienta genera una imagen binaria de salida en escala de grises, en la que cada píxel que coincide con un modelo de colores activo se ajusta a blanco (255), mientras que los demás píxeles se ajustan a negro (0). Usando esta imagen de salida binaria, la herramienta busca en la imagen las características de blob creadas por el Modelo de colores activo.

  1. Configuración de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10)
  2. Ajuste de los parámetros de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10)
  3. Uso de las propiedades de entrada/salida de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10)


Configuración de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10)

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los blobs; asegúrese de que los límites de la región cubran tanto los blobs como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los blobs se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:

  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.

  • Si previamente se añadió otra herramienta de color y desea utilizar una biblioteca de colores existente y los correspondientes modelos de colores entrenados, abra la ficha Ajustes, seleccione la biblioteca de colores deseada y después active los modelos de colores deseados activando las casillas correspondientes en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) consta de las fichas siguientes:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Biblioteca de colores
  • Ficha Tabla
  • Ficha Región compuesta

Nota: La ficha Tabla sólo se activa para la herramienta de medición de áreas Blobs de color (1-10).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "AreasBlobColor_1" (si se trata de la primera herramienta de área de blob de color agregada a la tarea; de lo contrario, se incrementará, es decir, "AreasBlobColor_2", "AreasBlobColor_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado – No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado – Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que se intersecan, siempre que cumplan los demás criterios.
Closed Ordenar por

Define cómo la herramienta medirá y clasificará los blobs encontrados (Área, Fila, Columna, Cuadrícula: Fila, luego columna desde el elemento, Cuadrícula: Columna, luego fila desde el elemento, Distancia desde el origen del elemento, Rotación en sentido antihorario desde el eje de fila del elemento, Distancia angular; predeterminado = Área):

  • Área = Ordena por los tamaños de las áreas de los blobs encontrados, de grande a pequeña.
  • Fila = Ordena por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Columna = Ordena por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Fila, luego columna desde el elemento = Ordena por distancias primero a lo largo del eje de fila de la imagen del elemento, y luego por distancias a lo largo del eje de columna de la imagen, en orden descendente, de menor a mayor distancia.
  • Cuadrícula: Columna, luego fila desde el elemento = Ordena por distancias primero a lo largo del eje de columna de la imagen del elemento, y luego por distancias a lo largo del eje de fila de la imagen, en orden descendente, de menor a mayor distancia.
  • Distancia desde el origen del elemento = Ordena por distancias desde el origen del elemento al centroide del blob, en orden descendente, de menor a mayor distancia.
  • Rotación en sentido antihorario desde el eje de fila del elemento = Ordena por los ángulos (0 a 360°) medidos desde el eje de fila de la imagen del elemento hasta el segmento de línea definido por el centroide del blob y el origen del elemento, en orden descendente, de menor a mayor distancia.
  • Distancia angular = Ordena por los ángulos absolutos (-180 a 180°) medidos desde el eje de fila de la imagen del elemento hasta un segmento de línea definido por el centroide del blob y el origen del elemento, de menor a mayor distancia.
Closed Número a buscar

Define el número de blobs que deben detectarse (1 a 10; predeterminado = 1). El tiempo de ejecución de la herramienta aumenta con el número de blobs que la herramienta deba identificar.

Nota: Este control sólo está disponible para la Herramienta de medición de áreas de blobs de color (1-10).


Herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) - ficha Límites de rango

Closed Máximo

Define el valor aceptable máximo del valor del área del blob; la herramienta creará un ajuste predeterminado del "límite inteligente" basado en su imagen, que puede personalizar para adaptarse a las necesidades de su aplicación.

Closed Área de blob

Indica el área de blob medida actualmente; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica medidas en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor aceptable mínimo del valor del área de blob; la herramienta creará un ajuste predeterminado del "límite inteligente" basado en su imagen, que puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) - ficha Biblioteca

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Herramienta de medición de áreas de blobs de color (1-10) - ficha Tabla

Notas:
  • La herramienta de medición de áreas de blobs de color no ofrece la ficha Tabla, que sólo está disponible en la herramienta de medición de áreas de blobs de color (1-10).
  • Cuando el parámetro Ordenar por se ajusta a cualquier otra opción distinta de Área, se agregan a la tabla las columnas Fila de píxeles y Columna de píxeles. Fila de píxeles y Columna de píxeles reflejan las coordenadas de la imagen en la cuadrícula bidimensional del sensor de imágenes del sistema de visión In-Sight (las filas y columnas de la matriz), y son los valores intercambiados (Y/X) de las coordenadas del mundo real (X/Y).

  • Con la opción Orientación clásica activada en el cuadro de grupo Calibrar imagen en unidades del mundo real del paso Configurar imagen, las coordenadas X e Y estarán en el mismo espacio de coordenadas que las coordenadas de la imagen (Y/X).

La ficha Tabla publica los resultados de los blobs encontrados, dependiendo del parámetro Número a buscar indicado en la ficha Ajustes:

Closed Índice

Se refiere al orden de los blobs encontrados, basándose en el parámetro Ordenar por de la ficha Ajustes; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed Área

Devuelve el área del blob encontrado (medido en píxeles).

Closed X

Devuelve la coordenada X del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Y

Devuelve la coordenada Y del centroide del blob encontrado. La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades del mundo real en Configurar imagen.

Closed Ángulo

Devuelve el ángulo del centroide del blob encontrado, con respecto al centro de la región.

Closed Error

Devuelve los resultados de error que puedan haberse detectado para los blobs encontrados.

Closed Fila de píxeles

Devuelve la coordenada (X) de la fila de la imagen correspondiente al centroide del blob encontrado.

Closed Columna de píxeles

Devuelve la coordenada (Y) de la columna de la imagen correspondiente al centroide del blob encontrado.


Herramientas de medición Área de blob de color y Áreas de blobs de color (1-10) - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite | I | X | X | Entrada/Salida
Biblioteca_Colores | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Habilitar_Aplicar_Modelo_Externo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Maximo | FP | X | X | Entrada/Salida
Minimo | FP | X | X | Entrada/Salida
Habilitar_Modelo | I | X | X | Entrada/Salida
Habilitar_Seleccionar_Modelo | I | X | X | Entrada/Salida
Ordenar_Por | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Factor_Suavizado | I | X | X | Entrada/Salida
Mostrar_Imagen_Original | I | X | X | Entrada/Salida
Area_Blob | FP | X | X | Salida
Blobs | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A | X | X |
Habilitar_Aplicar_Modelo | A | X | X |
Area_Blob1-9 1 | FP | X | X | Salida
Numero_Encontrado 1 | FP | X | X | Salida
Numero_A_Buscar 1 | I | X | X | Entrada/Salida
1 Estas propiedades de herramienta solo están disponibles con la herramienta de medición Áreas de blobs de color (1-10).

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_Evento | A | X | X | Entrada/Salida
Entrenar_Modelo | S | X | X | Entrada/Salida
Entrenar_Operacion | I | X | X | Entrada/Salida
Entrenar_Procedimiento | I | X | X |
Entrenar_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite_Mas_Oscuro | FP | X | X | Entrada/Salida
Limite_Mas_Claro | FP | X | X | Entrada/Salida
Entrenar_Color | S | X | X | Entrada/Salida
Entrenar_Evento | A | X | X |
Entrenar_Region | A | X | X |


Herramienta de medición - Diámetro de círculo

La herramienta de medición Diámetro de círculo mide el diámetro de una característica circular.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensores de visión 2000-130/130C y 2000-23M) en el paso de aplicación Configurar imagen.

  1. Configuración de la herramienta de medición Diámetro de círculo
  2. Ajuste de los parámetros de la herramienta de medición Diámetro de círculo
  3. Uso de las propiedades de entrada/salida de la herramienta de medición Diámetro de círculo


Configuración de la herramienta de medición Diámetro de círculo

Una vez añadida la herramienta, deberá seleccionar la característica de entrada a medir:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Seleccione una característica inteligente de entre las características disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).
  3. Confirme su selección presionando el botón Aceptar (para deshacer la acción, presione el botón Cancelar).
  4. Una vez confirmada la característica, EasyBuilder calculará automáticamente el diámetro de la misma. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta Medición de diámetros de círculos

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta Medición de diámetros de círculos consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de medición Diámetro de círculo - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Circulo_1" (si se trata de la primera herramienta de Círculo agregada a la tarea; de lo contrario, se incrementará, es decir, "Circulo_2", "Circulo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Medición de diámetros de círculos - ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un ajuste inteligente que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta (su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable).

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar por

Define cómo la herramienta debe discriminar los márgenes circulares encontrados cuando hay múltiples márgenes circulares presentes (valor predeterminado = Mejor puntuación).

  • Mejor puntuación = Se elegirá la característica de margen circular que tenga el margen mejor definido (cuyos niveles de contraste y brillo sean más altos).
  • Círculo más pequeño = Se elegirá la característica de margen circular que tenga el menor diámetro.
  • Círculo más grande = Se elegirá la característica de margen circular que tenga el mayor diámetro.


Herramienta Medición de diámetros de círculos - ficha Límites de rango

Closed Máximo

Define el valor de diámetro máximo admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Diámetro

Indica el diámetro medido actual de la característica de margen circular encontrada; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor de diámetro mínimo admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de medición Diámetro de círculo - Gráficos

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta de medición Diámetro de círculo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Diámetro | FP | X | Salida
Contraste_Margen | I |  | Entrada
Transicion_Margen | I |  | Entrada
Ancho_Margen | I |  | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Buscar_Por | I |  | Entrada
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Máximo | FP |  | Entrada
Mínimo | FP |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Buscar_Por | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Radio.Circulo | FP | X | Salida
Circulo.X | FP | X | Salida
Circulo.Y | FP | X | Salida
Diámetro | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Espacio_Anular | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Buscar_Por | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Radio.Circulo | FP | X | X | Salida
Circulo.X | FP | X | X | Salida
Circulo.Y | FP | X | X | Salida
Diámetro | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Espacio_Anular | A | X | X |


Herramienta de medición - Concentricidad de círculos

La herramienta de medición de la concentricidad de círculos se utiliza para medir la distancia entre los centros de dos características circulares.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

Esta herramienta se puede utilizar, por ejemplo, para verificar que una etiqueta circular está centrada en un tapón circular o para medir la concentricidad de un agujero de fregadero mecanizado.

  1. Configuración de la herramienta de medición Concentricidad de círculos
  2. Ajuste de los parámetros de la herramienta de medición Concentricidad de círculos
  3. Uso de las propiedades de entrada/salida de la herramienta de medición Concentricidad de círculos


Configuración de la herramienta de medición Concentricidad de círculos

Una vez añadida la herramienta, deberá definir las características de entrada (características circulares o círculos de referencia) que se utilizarán para generar la medida de concentricidad de círculos:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la segunda característica.
  4. Una vez seleccionada la segunda característica, EasyBuilder calculará automáticamente la distancia entre las características. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de medición de concentricidad de círculos

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de medición de concentricidad de círculos consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de medición Concentricidad de círculos - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Concentricidad_1" (si se trata de la primera herramienta de concentricidad de círculos agregada a la tarea; de lo contrario, se incrementará, es decir, "Concentricidad_2", "Concentricidad_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de medición de concentricidad de círculos - ficha Límites de rango

Closed Distancia

Indica la distancia medida actual entre los centros de las dos características de márgenes circulares encontradas; los valores que coincidan exactamente con 0 o con el ajuste Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica medidas en píxeles, salvo que la imagen se hubiese calibrado en unidades reales en Configurar imagen.

Closed Máximo

Define el valor máximo de distancia admisible; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los límites de rango.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los límites de rango.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de medición Concentricidad de círculos

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Distancia | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Distancia | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de medición - Medir radio

La herramienta de medición para medir el radio se utiliza para definir una característica de margen curvado y formar una línea y un punto de referencia para representar el eje de la curva. La herramienta informa del radio de la curva.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

  1. Configuración de la herramienta de medición Medir radio
  2. Ajuste de los parámetros de la herramienta de medición Medir radio
  3. Uso de las propiedades de entrada/salida de la herramienta de medición Medir radio


Uso de la herramienta de medición Medir radio

Una vez añadida la herramienta, deberá configurar la región de la imagen que definirá su característica de margen curvo:

  1. Sitúe la región sobre la característica de margen curvo.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. A continuación, EasyBuilder calcula automáticamente el radio de la curva y construye una línea y un punto de referencia que representen el eje de la curva.
  4. Con la herramienta configurada inicialmente, cargue varias imágenes y ajuste los parámetros de la herramienta según convenga para compensar los rangos de variaciones previstos.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de medición Medir radio

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de medición Medir radio consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de medición Medir radio - ficha General

Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Curve_1" (cuando se añade la primera herramienta de medición Medir radio a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta añadida, es decir, "Curve_2", "Curve_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de medición Medir radio - ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un ajuste inteligente que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta - su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable.

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar por

Define cómo la herramienta debe discriminar los márgenes encontrados cuando hay múltiples márgenes presentes (valor predeterminado = Mejor puntuación).

  • Mejor puntuación = La característica de margen que tenga el margen más contrastado.
  • Primer margen = La característica de margen más cercana al comienzo de la dirección de exploración de la región.
  • Último margen = La característica de margen más alejada del comienzo de la dirección de exploración de la región.


Herramienta de medición Medir radio - ficha Límites de rango

Closed Máximo

Define el valor de radio máximo admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Radio (unidades)

Indica el radio medido actual de la característica de margen curvo encontrada; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor de radio mínimo admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de medición Medir radio

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Buscar_Por | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Radio.Circulo | FP | X | Salida
Circulo.X | FP | X | Salida
Circulo.Y | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Radio | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Región | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Buscar_Por | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Radio.Circulo | FP | X | X | Salida
Circulo.X | FP | X | X | Salida
Circulo.Y | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Radio | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región | A | X | X |


Herramientas de medición - Puntos mín./máx.

La herramienta de medición Puntos mín./máx. mide la posición de los márgenes y determina qué puntos de los mismos se encuentran más cerca y más lejos del margen encontrado o de la región que define dicho margen. La herramienta utiliza matrices Calibre de análisis de márgenes para localizar con precisión las características de márgenes. Una vez identificado el margen, la herramienta construye una línea o un círculo (dependiendo de si la característica de margen contiene o no una curva) con el mejor ajuste posible sobre la característica de margen. La herramienta comunica los puntos del margen más cercanos y más alejados de la línea o del círculo de mejor ajuste.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de medición Puntos mín./máx. resulta útil para asegurarse de que una pieza u objeto no contiene ninguna característica de margen que se desvíe de su posición prevista. Por ejemplo, si desea asegurarse de que el filo de una cuchilla no contenga mellas, abolladuras ni estrías.

  1. Configuración de la herramienta de medición Puntos mín./máx.
  2. Ajuste de la herramienta de medición Puntos mín./máx.
  3. Uso de las propiedades de entrada/salida de la herramienta de medición Puntos mín./máx.


Configuración de la herramienta de medición Puntos mín./máx.

Después de agregar la herramienta, deberá configurar la región enmascarada en la imagen sobre la característica de margen que desee inspeccionar:

  1. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, al tiempo que se excluye el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Márgenes, Puntuación de márgenes y Encuadre y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la línea o el círculo con el mejor ajuste posible. A la hora de realizar la configuración inicial de la herramienta, utilice una imagen que contenga la característica de margen ideal. Las adquisiciones de imágenes subsiguientes contendrán candidatos a márgenes que serán examinados para determinar si existen desviaciones tales como defectos o espacios.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de medición Puntos mín./máx.

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de medición Puntos mín./máx. consta de las fichas siguientes:

  • Ficha General
  • Ficha Márgenes
  • Ficha Puntuación de márgenes
  • Ficha Adaptar

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de medición Puntos mín./máx. - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "PuntosMinMax_1" (si se trata de la primera herramienta de medición de puntos mín./máx. agregada a la tarea; de lo contrario, se incrementará, es decir, "PuntosMinMax_2", "PuntosMinMax_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de medición Puntos mín./máx. - ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra todos los márgenes detectados en la región y los marca en color verde oscuro. Es posible ajustar los parámetros Tamaño del calibre, Espaciado del calibre, Ancho del margen y Contraste mínimo según convenga para aislar los márgenes deseados.

También puede ver todos los calibres activando el parámetro Mostrar todos los calibres.

Esta ficha también permite seleccionar y ajustar la región.

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de medición Puntos mín./máx. - ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra con pequeños círculos coloreados todos los candidatos a márgenes encontrados dentro de la región (que puede seleccionarse y ajustarse), así como el resultado de la línea o del círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Ajustes los parámetros para aislar los candidatos a márgenes deseados.

También se muestran todos los defectos y espacios detectados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha o Derecha a izquierda; preajuste = Izquierda a derecha).

Closed Transiciones de márgenes

Define la transición de los márgenes (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Herramienta de medición Puntos mín./máx. - ficha Encuadre

Al seleccionar la ficha Encuadre, la herramienta mostrará todos los candidatos a márgenes que se encuentran dentro de la región y la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes se indican con pequeños círculos.

Closed Encuadre de línea

Define el tipo de línea de mejor ajuste (Ninguno, Encuadre de línea recta, Encuadre de línea circular, Encuadre automático o Región; preajuste = Encuadre automático) que se construirá a partir de los márgenes que se encuentren.

  • Si selecciona Ninguno, la herramienta no creará una línea con el mejor ajuste posible, y la posición de los márgenes encontrados se medirá con respecto al centro de la región.
  • Si selecciona Encuadre de línea recta, la herramienta creará una línea con el mejor ajuste posible a partir de los márgenes detectados, y la posición de los márgenes encontrados se medirá con respecto a la línea de mejor ajuste.
  • Si selecciona Encuadre de línea circular, la herramienta creará una línea circular con el mejor ajuste posible a partir de los márgenes detectados, y la posición de los márgenes encontrados se medirá con respecto a la línea de mejor ajuste.
  • Si selecciona Encuadre automático, la herramienta creará automáticamente una línea recta o circular con el mejor ajuste posible a partir de los márgenes detectados, y la posición de los márgenes encontrados se medirá con respecto a la línea de mejor ajuste.
  • Si selecciona Región, la herramienta creará automáticamente una línea recta o circular con el mejor ajuste posible a partir de los márgenes detectados, y la posición de los márgenes encontrados se medirá con respecto al lado de la región.
Closed Filtrar objetos exteriores

Define si la herramienta eliminará puntos de la recta de mejor ajuste que se encuentren más allá de la distancia definida por el parámetro Filtro de encuadre de distancia (de forma predeterminada, este parámetro está desactivado).

Closed Filtro de encuadre de distancia

Define la distancia (1 - 1920; preajuste = 2), en píxeles, a la que debe encontrarse un margen con respecto a la línea de mejor ajuste original para ser utilizada en el cálculo de reencuadre. Este parámetro sirve para impedir que los defectos afecten al encuadre de línea.

Nota: Para poder utilizar este parámetro, primero debe activarse el parámetro Filtrar objetos exteriores.

Closed Distancia del filtro del punto más alejado

Define la distancia del objeto exterior (1 - 1920; preajuste = 1000) más allá de la cual no se utilizan márgenes para determinar las distancias mínima y y máxima; cualquier margen que supere este valor será ignorado.

Closed Volver a puntuar

Define si los márgenes detectados volverán a ser puntuados para asegurarse de que los márgenes descartados inicialmente fueron filtrados correctamente (de forma predeterminada, este parámetro está activado).

Closed Volver a encuadrar

Define si la herramienta se reajustará a la línea con el mejor ajuste posible después de volver a puntuar los márgenes (de forma predeterminada, este parámetro está activado).

Nota: La precisión de la herramienta será mayor con este parámetro habilitado, aunque a costa de aumentar el tiempo de procesamiento.

Closed Resultado

Muestra la línea con el mejor ajuste posible en la imagen y comunica la ubicación de los puntos más cercanos y más lejanos de la línea de mejor ajuste.


Uso de las propiedades de entrada/salida de la herramienta de medición Puntos mín./máx.

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Transición | I | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Filtrar_Objetos_Exteriores | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Ajustar_Distancia_Filtro | I | X | X | Entrada/Salida
Distancia_Filtro_Punto_Más_Alejado | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Encuadre_Línea | I | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Reajustar | I | X | X | Entrada/Salida
Repuntuar | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Círculo.Radio | FP | X | X | Salida
Círculo.X | FP | X | X | Salida
Círculo.Y | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Línea.Fin_X | FP | X | X | Salida
Línea.Fin_Y | FP | X | X | Salida
Línea.Principio_X | FP | X | X | Salida
Línea.Principio_Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Punto1.X | FP | X | X | Salida
Punto1.Y | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región_Enmascarada | A | X | X |


Herramientas de recuento - Blobs

La herramienta Recuento de blobs cuenta el número de apariciones de características de blob presentes en una región de la imagen.

La herramienta Recuento de blobs es una de las más rápidas, siendo capaz de localizar características de blob mucho más deprisa que una herramienta Presencia/ausencia de patrones. Esta herramienta resulta útil para muchas aplicaciones de recuento, como verificar el número correcto de contactos de un conector o contar el número de trozos de chocolate en una galleta.

  1. Configuración de la herramienta Recuento de blobs
  2. Ajuste de los parámetros de la herramienta Recuento de blobs
  3. Uso de las propiedades de entrada/salida de la herramienta Recuento de blobs


Configuración de la herramienta de recuento Blobs

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

Nota: Si opta por utilizar blobs para la inspección, intente seleccionar blobs que tengan un contraste alto entre los píxeles claros y los oscuros.

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los blobs; asegúrese de que los límites de la región cubran tanto los blobs como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los blobs se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de recuento Blobs

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de recuento Blobs consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Histograma
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de recuento de Blobs - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Blob_1" (si se trata de la primera herramienta de blob agregada a la tarea; de lo contrario, se incrementará, es decir, "Blob_2", "Blob_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Recuento de blobs - ficha Ajustes

Closed Modo de umbral

Define el modo de determinación del valor de escala de grises utilizado para separar blobs del fondo. Con la opción "Auto" activada (ajuste predeterminado), cada vez que se adquiere una imagen la herramienta se ajusta a los cambios de luminosidad que se producen entre imágenes sucesivas. Si selecciona Manual, deberá introducir el valor y ajustarlo manualmente.

Closed Umbral de blob

Define el valor de escala de grises utilizado para separar blobs del fondo (0 - 255, si está habilitado). De forma predeterminada, este control está desactivado. Para activarlo, es necesario ajustar Modo de umbral a Manual. Utilice el gráfico para definir el valor óptimo para su aplicación.

Closed Color de blob

Define el color del blob (Negro, Blanco o Cualquiera; valor predeterminado = Cualquiera).

  • Cualquiera = No hay ningún requisito para el color del blob.
  • Negro = Devuelve solamente los blobs por debajo de Umbral de blob.
  • Blanco = Devuelve solamente los blobs por encima de Umbral de blob.
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado - No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado - Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que se intersecan, siempre que cumplan los demás criterios.
Closed Área mínima

Define una restricción de área mínima, en número de píxeles (0 a 900000; valor predeterminado = 100), para todos los blobs detectados; sólo se reconocerán blobs con un área mayor que el área mínima.

Closed Área máxima

Define una restricción de área máxima, en número de píxeles (0 a 900000; valor predeterminado = 100000), para todos los blobs detectados; sólo se reconocerán blobs con un área menor que el área máxima.


Herramienta Recuento de blobs - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de blobs a detectar; la herramienta creará un ajuste predeterminado de Límites inteligentes basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Recuento de blobs

Comunica el número actual de blobs detectados (los blobs contados en la imagen parten de un orden numérico en el que 0 = 1); los valores que coinciden exactamente con los ajustes Mínimo y Máximo, o que se encuentran entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número máximo admisible de blobs a detectar; la herramienta creará un ajuste predeterminado de Límites inteligentes basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de recuento Blobs - ficha Histograma

El histograma muestra una representación gráfica de los valores de escala de grises de los píxeles en la región.

  • El eje X del gráfico representa el número total de los valores en la escala de grises (0 a 255 o 256 tonalidades de gris en total).
  • El eje Y del gráfico representa el número de píxeles en un determinado valor en la escala de grises, y la escala se establece mostrando el valor en la escala de grises con el mayor número de píxeles.
  • La línea vertical azul indica el umbral que se usa para separar la región de la imagen por píxeles blancos y negros; los valores a la izquierda de la línea se consideran negros y los valores a la derecha de ella se consideran blancos.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Herramienta de recuento Blobs - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de recuento Blobs

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color_Blob | I | X | X | Entrada/Salida
Umbral_Blob | I | X | X | Entrada/Salida
Limite | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Maximo | I | X | X | Entrada/Salida
Area_Maxima | FP | X | X | Entrada/Salida
Minimo | I | X | X | Entrada/Salida
Area_Minima | FP | X | X | Entrada/Salida
Modo_Umbral | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Blobs | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A |  | X |


Herramientas de recuento - Blobs de color

La herramienta Recuento de blobs de color cuenta el número de apariciones de características de blobs presentes en una región de la imagen.

La herramienta Recuento de blobs de color es una de las herramientas más rápidas, capaz de localizar las características de blob mucho más deprisa que una herramienta Presencia/ausencia de patrones. Esta herramienta resulta útil para muchas aplicaciones de recuento, como verificar el número correcto de contactos de un conector o contar el número de trozos de chocolate en una galleta.

  1. Configuración de la herramienta Recuento de blobs de color
  2. Ajuste de los parámetros de la herramienta Recuento de blobs de color
  3. Uso de las propiedades de entrada/salida de la herramienta Recuento de blobs de color


Configuración de la herramienta Recuento de blobs de color

Después de seleccionar la herramienta, deberá elegir el tipo de región y después configurarlo en la imagen donde espere detectar las características de blog:

  1. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los blobs; asegúrese de que los límites de la región cubran tanto los blobs como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los blobs se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:

  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.

  • Si previamente se añadió otra herramienta de color y desea utilizar una biblioteca de colores existente y los correspondientes modelos de colores entrenados, abra la ficha Ajustes, seleccione la biblioteca de colores deseada y después active los modelos de colores deseados activando las casillas correspondientes en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de recuento de blobs de color

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de recuento de blobs de color consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Biblioteca de colores
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de recuento Blobs de color - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Blob_1" (si se trata de la primera herramienta de blob agregada a la tarea; de lo contrario, se incrementará, es decir, "Blob_2", "Blob_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de recuento de blobs de color - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"
Closed Límite

Define una de dos maneras de administrar blobs que intersecan el límite de la región de blobs (valor predeterminado = desactivado, desmarcado):

  • Desmarcado – No incluye blobs que intersecan el límite de la región; es decir, el blob debe encontrarse íntegramente dentro de la región a detectar.
  • Marcado – Incluye blobs que intersecan el límite de la región; es decir, se detectan blobs que se intersecan, siempre que cumplan los demás criterios.
Closed Área mínima

Define una restricción de área mínima, en número de píxeles (0 a 900000; valor predeterminado = 100), para todos los blobs detectados; sólo se reconocerán blobs con un área mayor que el área mínima.

Closed Área máxima

Define una restricción de área máxima, en número de píxeles (0 a 900000; valor predeterminado = 100000), para todos los blobs detectados; sólo se reconocerán blobs con un área menor que el área máxima.


Herramienta de recuento de blobs de color - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de blobs a detectar; la herramienta creará un ajuste predeterminado de Límites inteligentes basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Recuento de blobs

Comunica el número actual de blobs detectados (los blobs contados en la imagen parten de un orden numérico en el que 0 = 1); los valores que coinciden exactamente con los ajustes Mínimo y Máximo, o que se encuentran entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número máximo admisible de blobs a detectar; la herramienta creará un ajuste predeterminado de Límites inteligentes basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de recuento de blobs de color - ficha Biblioteca de colores

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Herramienta de recuento Blobs de color - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de recuento Blobs de color

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite | I | X | X | Entrada/Salida
Biblioteca_Colores | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Habilitar_Aplicar_Modelo_Externo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Maximo | I | X | X | Entrada/Salida
Area_Maxima | FP | X | X | Entrada/Salida
Minimo | I | X | X | Entrada/Salida
Area_Minima | FP | X | X | Entrada/Salida
Habilitar_Modelo | I | X | X | Entrada/Salida
Habilitar_Seleccionar_Modelo | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Factor_Suavizado | I | X | X | Entrada/Salida
Mostrar_Imagen_Original | I | X | X | Entrada/Salida
Recuento_Blobs | FP | X | X | Salida
Blobs | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A | X | X |
Habilitar_Aplicar_Modelo | A | X | X |

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_Evento | A | X | X | Entrada/Salida
Entrenar_Modelo | S | X | X | Entrada/Salida
Entrenar_Operacion | I | X | X | Entrada/Salida
Entrenar_Procedimiento | I | X | X |
Entrenar_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite_Mas_Oscuro | FP | X | X | Entrada/Salida
Limite_Mas_Claro | FP | X | X | Entrada/Salida
Entrenar_Color | S | X | X | Entrada/Salida
Entrenar_Evento | A | X | X |
Entrenar_Region | A | X | X |


Herramienta de recuento - Márgenes

La herramienta de recuento Márgenes cuenta el número de características de margen presentes en una región de la imagen.

Esta herramienta es útil, por ejemplo, en el recuento del número de roscas que tiene un tornillo o el recuento del número de galletas de una bandeja.

  1. Configuración de la herramienta de recuento Márgenes
  2. Ajuste de los parámetros de la herramienta de recuento Márgenes
  3. Uso de las propiedades de entrada/salida de la herramienta de recuento Márgenes


Uso de la herramienta Recuento de márgenes

Una vez añadida la herramienta, deberá configurar la región de la imagen que definirá dónde deben detectarse los márgenes:

  1. Sitúe y configure la región sobre el área de características de márgenes y asegúrese de que los límites de la región cubran los márgenes y sus posibles ubicaciones. Preste especial atención a las flechas de dirección de exploración en la región para asegurarse de que la región esté colocada de forma que se optimice la detección de sus márgenes deseados.

Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los márgenes se encuentren más o menos en la misma ubicación en cada imagen o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta Recuento de márgenes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la Herramienta Recuento de márgenes consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de recuento Márgenes - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Margenes_1" (si se trata de la primera herramienta agregada a la tarea que define un margen; de lo contrario, se incrementará, es decir, "Margenes_2", "Margenes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Recuento de márgenes - ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un "ajuste inteligente" que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de detección de márgenes de la herramienta (su capacidad de discriminar entre la característica y el fondo; utilice este ajuste en combinación con el gráfico de la herramienta para definir un rango aceptable).

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transiciones de márgenes

Define la transición del margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Rango de ángulos

Define la cantidad máxima de traslación angular que el margen encontrado puede experimentar (0-10°; valor predeterminado = 10°). Cuanto mayor sea la variación angular admisible, más tiempo de ejecución necesitará la herramienta.


Herramienta Recuento de márgenes - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de márgenes a detectar; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Márgenes

Comunica el número actual de márgenes detectados (los márgenes contados en la imagen parten de un orden numérico en el que 0 = 1); los valores que coinciden exactamente con los ajustes "Mínimo" y "Máximo", o que se encuentran entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número mínimo admisible de márgenes a detectar; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de recuento Márgenes - Gráfico

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta de recuento Márgenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Rango_Angulos | I |  | Entrada
Descripción | S | X | Entrada
Contraste_Margen | I |  | Entrada
Recuento_Margenes | I | X | Salida
Transicion_Margen | I |  | Entrada
Ancho_Margen | I |  | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Máximo | I |  | Entrada
Mínimo | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Rango_Angulos | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Contraste_Margen | I | X | Entrada/Salida
Transicion_Margen | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | I | X | Entrada/Salida
Mínimo | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Margenes | I | X | Salida
Márgenes | S | X | Salida
Recuento_Errores | I | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Región | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Rango_Angulos | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Contraste_Margen | I | X | X | Entrada/Salida
Transicion_Margen | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Margenes | I | X | X | Salida
Márgenes | S | X | X | Salida
Recuento_Errores | I | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región | A | X | X |


Herramientas de recuento - Pares de márgenes

La herramienta Recuento de pares de márgenes cuenta el número de instancias (apariciones) de pares de márgenes lineales presentes en una región de la imagen.

La herramienta Recuento de pares de márgenes se diferencia de la herramienta Recuento de márgenes en que la herramienta Recuento de pares de márgenes permite definir una distancia prevista entre pares de márgenes, resultando útil, por ejemplo, en aplicaciones como contar el número de dientes de un engranaje o contar el número de conductores en un chip.

  1. Configuración de la herramienta Recuento de pares de márgenes
  2. Ajuste de la herramienta Recuento de pares de márgenes
  3. Uso de las propiedades de entrada/salida de la herramienta Recuento de pares de márgenes


Configuración de la herramienta Recuento de pares de márgenes

Una vez añadida la herramienta, deberá configurar la región de la imagen que definirá dónde deben detectarse los márgenes:

  1. Sitúe y configure la región sobre el área de características de márgenes y asegúrese de que los límites de la región cubran los márgenes y sus posibles ubicaciones.

La dirección de exploración de la región, los parámetros de la ficha Ajustes y los límites de rango configurados juegan un papel importante en la determinación del número de pares de márgenes que se detectan:

Closed Ejemplo 1

Closed Ejemplo 2

Closed Ejemplo 3

Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los márgenes se encuentren más o menos en la misma ubicación en cada imagen o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de recuento Pares de márgenes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de recuento Pares de márgenes consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Gráfico

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de recuento Pares de márgenes - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "ParesMargenes_1" (si se trata de la primera herramienta de recuento de pares de márgenes agregada a la tarea; de lo contrario, se incrementará, es decir, "ParesMargenes_2", "ParesMargenes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Recuento de pares de márgenes - ficha Ajustes

Closed Contraste de márgenes

Define la puntuación mínima admisible del contraste del margen encontrado (1-100; valor predeterminado = un ajuste inteligente que disminuye automáticamente hasta que se detecta un margen). Este ajuste determina la sensibilidad de la detección de márgenes de la herramienta, su capacidad de discriminar entre la característica y el fondo.

Nota: Si se configura este parámetro en 0, puede que la herramienta halle bordes inesperados.
Closed Transición del primer margen

Define la transición del primer margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Transición del segundo margen

Define la transición del segundo margen (Oscuro a claro, Claro a oscuro o Ambos; valor predeterminado = Ambos). Para aumentar la exactitud y velocidad, especifique el tipo de transición.

Closed Ancho de margen

Define la distancia en píxeles (1 - 50; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Rango de ángulos

Define la cantidad máxima de traslación angular que el margen encontrado puede experimentar (0-10°; valor predeterminado = 10°). Cuanto mayor sea la variación angular admisible, más tiempo de ejecución necesitará la herramienta.

Closed Distancia mínima

Define una distancia mínima, en número de píxeles (0 a 900000; predeterminado = 10), entre los márgenes de todos los pares de márgenes detectados; sólo se reconocerán los pares de márgenes cuya distancia sea mayor que Distancia mínima.

Closed Distancia máxima

Define una distancia máxima, en número de píxeles (0 a 900000; predeterminado = 50), entre los márgenes de todos los pares de márgenes detectados; sólo se reconocerán los pares de márgenes cuya distancia sea menor que Distancia máxima.


Herramienta Recuento de pares de márgenes - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de pares de márgenes a detectar; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Pares de márgenes

Comunica el número actual de pares de márgenes detectados (los pares de márgenes contados en la imagen parten de un orden numérico en el que 0 = 1); los valores que coinciden exactamente con los ajustes "Mínimo" y "Máximo", o que se encuentran entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número mínimo admisible de pares de márgenes a detectar; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramienta de recuento Pares de márgenes - Gráfico

El gráfico es una representación del primer derivado de los valores de escala de grises contenidos en la región; los picos y los valles representan las transiciones de margen principales.

En el caso de las herramientas que detectan márgenes (herramientas Margen y Círculo), el eje Puntuación es la medida del grado de coincidencia del margen encontrado con los parámetros definidos:

  • Una puntuación positiva indica que la transición del margen es de oscuro a claro.
  • Una puntuación negativa indica que la transición del margen es de claro a oscuro.
  • Una puntuación de cero indica que no se ha detectado ningún margen.

El eje Desviación se refiere al eje que define la función de margen; 0 representa el inicio del límite de la región y los otros valores representan el ancho máximo (en píxeles) de la región. El ápice de los picos o valles a lo largo del eje Desviación indica la posición del margen encontrado.

Nota: El gráfico se mostrará independientemente del estado en línea/sin conexión y el estado de aprobación/rechazo de la herramienta. No obstante, si la herramienta falla, puede que el gráfico no se actualice.


Uso de las propiedades de entrada/salida de la herramienta Recuento de pares de márgenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Angle_Range | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Edge_Contrast | I | X | X | Entrada/Salida
First_Edge_Transition | I | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Maximum_Distance | FP | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Minimum_Distance | FP | X | X | Entrada/Salida
Second_Edge_Transition | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Edge_Count | FP | X | X | Salida
Edge_Pair_Count | FP | X | X | Salida
Edge_Pairs | S | X | X | Salida
Márgenes | S | X | X | Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Región | A | X | X |


Herramientas de recuento - Patrones PatMax RedLine y Patrones PatMax

Notas:
  • A partir del firmware de In-Sight 5.5.0 y posteriores, el algoritmo de la herramienta se ha modificado para obtener resultados más precisos y reducir el tiempo de ejecución en determinadas circunstancias.
  • Debido a esta modificación, aparecerá un mensaje de error si intenta cargar una tarea en la que esta herramienta esté configurada con el firmware de In-Sight 5.5.0 o posterior en un sistema de visión In-Sight con una versión de firmware 5.4.x o anterior.
  • La herramienta de recuento de patrones PatMax RedLine solo está disponible en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de patrones PatMax RedLine y la herramienta de recuento de patrones PatMax se utilizan para contar las instancias de una característica del patrón mediante el algoritmo PatMax RedLine o PatMax y según una representación entrenada de dicho patrón (que se denomina Modelo).

Estas herramientas son útiles, por ejemplo, en aplicaciones como el recuento del número de pernos de un montaje mecánico o el recuento del número de viales de una bandeja.

  1. Configuración de la herramienta de recuento de patrones PatMax RedLine y patrones PatMax
    1. Patrones PatMax RedLine, patrones PatMax y patrones
    2. Selección de una característica de patrón
  2. Ajuste de los parámetros de la herramienta de recuento de patrones PatMax RedLine y patrones PatMax
  3. Uso de las propiedades de entrada/salida de la herramienta de recuento de patrones PatMax RedLine y patrones PatMax


Configuración de las herramientas de recuento de patrones PatMax RedLine y patrones PatMax

Una vez agregada la herramienta, deberá seleccionar el tipo de regiones y configurarlas para definir su patrón (la región Modelo), y en qué lugar de la imagen se encontrará el modelo (la región de Búsqueda).

  1. En el menú desplegable Modelo, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Después coloque la región Modelo sobre el patrón que se utilizará como modelo de entrenamiento; asegúrese de que la región Modelo cubra únicamente las características importantes del patrón.Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.
  2. En el menú desplegable Buscar, seleccione el tipo de región: Rectángulo (predeterminado), Círculo, Espacio anular o Polígono. A continuación, sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.
  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Patrones PatMax RedLine, Patrones PatMax y Patrones

Nota: La herramienta de recuento de patrones PatMax RedLine solo está disponible en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

Las herramientas Patrones PatMax RedLine, Patrones PatMax y Patrones localizan modelos de patrones entrenados y ofrecen la máxima precisión de entre todas las herramientas de ubicación e inspección. Sin embargo, las herramientas Patrones PatMax RedLine y Patrones PatMax son más potentes que la herramienta Patrones al contabilizar más cambios de las condiciones de iluminación y la posición del patrón. Asimismo, ofrecen un reconocimiento superior de los cambios de escala y rotación del patrón, de la oclusión de elementos del patrón y de cambios del aspecto del patrón debidos a variaciones de iluminación.

La principal diferencia entre los patrones PatMax RedLine y los patrones PatMax es la velocidad; el patrón PatMax RedLine utiliza el algoritmo de coincidencia de patrones más reciente y puede localizar características entrenadas en una imagen de 5 megapíxeles hasta 7 veces más rápido que los patrones PatMax. Por lo tanto, la herramienta Patrones PatMax RedLine es ideal para sistemas de visión de alta resolución.

La herramienta Patrones es (en la mayoría de los casos) más rápida que la herramienta PatMax, pero ciertas situaciones requieren la precisión y fiabilidad de la versión PatMax RedLine o PatMax:

  • Cuando las variaciones de iluminación y los reflejos son difíciles de controlar. Por ejemplo, las piezas metálicas pueden reflejar la luz en direcciones aleatorias.
  • Cuando el patrón que se inspecciona presenta formas o sombras similares en comparación con algo situado en el fondo o si otros objetos de la imagen se solapan con el patrón o lo ocultan parcialmente.
  • Cuando se desea reconocer con precisión un tipo de patrón frente a otros patrones similares.
  • Cuando las condiciones del entorno de la implementación son demasiado difíciles para que la herramienta Patrones pueda funcionar de forma coherente y fiable.


Ajuste de los parámetros de las herramientas de recuento de patrones PatMax RedLine y patrones PatMax

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de recuento de patrones PatMax RedLine y patrones PatMax consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Fichas Modelo y Buscar
  • Ficha Imagen entrenada

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de recuento de patrones PatMax RedLine y patrones PatMax - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección que se utilizará en la configuración de resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Patron_1" (si se trata de la primera herramienta de patrones agregada a la tarea; de lo contrato, se incrementará, es decir, "Patron_2", "Patron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de recuento de patrones PatMax RedLine y patrones PatMax - ficha Ajustes

Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Umbral de contraste

Define el contraste mínimo aceptable que debe estar presente en el patrón encontrado; el contraste de un patrón encontrado debe ser mayor que el valor de Umbral de contraste para que se considere una instancia válida. El valor predeterminado para el patrón o los patrones PatMax RedLine es 10 y el rango de parámetros válido es 0-100. El valor predeterminado para el patrón o los patrones PatMax es 10 y el rango de parámetros válido es 0-255. Un valor de Umbral de contraste bajo se utiliza para imágenes de bajo contraste, mientras que un valor de Umbral de contraste alto se utiliza para imágenes de alto contraste.

Nota: El contraste del patrón o los patrones PatMax RedLine es la medición "relativa" del cambio de contraste entre las características del patrón entrenado y las características coincidentes en la imagen de búsqueda, en porcentaje. Por lo tanto, si el contraste de las características es similar o más alto en relación con el contraste del patrón, el contraste comunicado será ~100. Si el contraste de las características es más bajo que el contraste del patrón, el contraste comunicado será <100. El contraste del patrón o los patrones PatMax RedLine es diferente del contraste del patrón o los patrones PatMax, que es el contraste "absoluto" de la imagen del ROI buscado, en nivel de escala de grises.

Closed Tolerancia del ángulo

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define el porcentaje de escalado admisible (variaciones de tamaño) entre el patrón encontrado y el patrón Modelo (0-50; valor predeterminado = 0). El valor es un porcentaje positivo o negativo, p. ej., un valor de 5 permitirá que la herramienta encuentre patrones que están entre el 95 % y el 105 % del tamaño del patrón Modelo. Cuanto mayor sea el rango admisible de variación de escala del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Modo Buscar

Define el modo de búsqueda utilizado para entrenar y reconocer patrones, PatMax o PatQuick. La opción PatMax está seleccionada de forma predeterminada. PatMax ofrece mayor precisión que PatQuick, pero requiere más tiempo de ejecución, mientras que PatQuick ofrece menor precisión que PatMax, pero requiere menos tiempo de ejecución.

Closed Puntuación estricta

Define si las características ocluidas del patrón encontrado o las que faltan en él repercutirán o no en la puntuación (valor predeterminado = activado). Cuando se aplica la opción Puntuación estricta (activada), se reducirá la puntuación del patrón encontrado si hay características del patrón ausentes o bloqueadas.

Closed Ignorar polaridad

Define si los patrones encontrados pueden contener características de coincidencia de colores invertidos, con respecto al patrón Modelo (ajuste predeterminado = desactivado, desmarcado). Con la opción Ignorar polaridad aplicada (activada, marcada), los patrones en los que se detecten características de colores invertidos, tales como negro/blanco frente a blanco/negro en el patrón Modelo, se clasificarán como coincidencias con el patrón Modelo.

Closed Tiempo de espera
Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo. Este parámetro se establece de forma predeterminada en 5.000.

Nota: El patrón o patrones PatMax RedLine no incluye el parámetro Modo Buscar.


Herramientas de recuento de patrones PatMax RedLine y patrones PatMax - ficha Límites de rango

Closed Máximo

Define el número máximo aceptable de patrones que detectar; la herramienta creará un ajuste predeterminado "Límite inteligente" en función de su imagen y puede personalizarlo para que se adapte a las necesidades de su aplicación.

Closed Patrones

Comunica el número actual de patrones detectados (los patrones contados en la imagen se basan en un orden numérico, donde 0 = 1); los valores que quedan exactamente en los ajustes Mínimo y Máximo o entre ambos se clasifican como aceptados.

Closed Mínimo

Define el número mínimo aceptable de patrones que detectar; la herramienta creará un ajuste predeterminado "Límite inteligente" en función de su imagen y puede personalizarlo para que se adapte a las necesidades de su aplicación.

Closed Invertir

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Herramientas de recuento de patrones PatMax RedLine y patrones PatMax - fichas Modelo y Buscar

Las fichas Modelo y Buscar sirven para configurar la región compuesta de las regiones Modelo y Buscar de la herramienta. Las regiones compuestas sirve son una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • En la ficha Modelo, las regiones compuestas solo se activan tras pulsar el botón Región modelo.
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramientas de recuento de patrones PatMax RedLine y patrones PatMax - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de las herramientas de recuento de patrones PatMax RedLine y patrones PatMax

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Tolerancia_Angulo | I | X | X | Entrada/Salida
Umbral_Contraste | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Nuevo_Entrenamiento_Externo | I | X |  | Entrada/Salida
Buscar_Modo1 | I | X | X | Entrada/Salida
Ignorar_Polaridad | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Puntuacion_Estricta | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Recuento_Patrones | FP | X | X | Salida
Patrones | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Escala | FP | X | X | Salida
Modelo | A | X | X |
Buscar | A | X | X |
Entrenar | A | X | X |
1 Esta propiedad de herramienta solo está disponible en la herramienta de recuento de patrones PatMax.


Herramientas de recuento - Patrones

La herramienta de recuento Patrones se utiliza para contar las instancias de una característica de patrón según una representación entrenada de dicho patrón (llamada un modelo).

La herramienta de recuento Patrones es útil, por ejemplo, en aplicaciones como el recuento del número de pernos de un montaje mecánico o el recuento del número de viales de una bandeja.

  1. Configuración de la herramienta de recuento Patrones
    1. Comparación de las herramientas Patrones y Patrones PatMax
    2. Selección de una característica de patrón
  2. Ajuste de los parámetros de la herramienta Recuento de patrones
  3. Uso de las propiedades de entrada/salida de la herramienta de recuento Patrones


Configuración de la herramienta Recuento de patrones

Cuando haya agregado la herramienta, deberá configurar las regiones de la imagen que definirán su patrón (la región Modelo), y dónde se encontrará el patrón en la imagen (la región de Búsqueda).

  1. Sitúe la región Modelo sobre el patrón que se utilizará como patrón de entrenamiento; asegúrese de que la región Modelo cubra solamente las características importantes del patrón.
  2. Sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.

Nota: Las regiones Modelo y Búsqueda no se pueden doblar para formar un arco o un anillo.

  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de recuento de patrones

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de recuento de patrones consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Límites de rango
  • Ficha Imagen entrenada

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de recuento Patrones - Ficha General

Closed Nombre de herramienta

Define el nombre de su herramienta de inspección que se utilizará en la configuración de resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Patron_1" (si se trata de la primera herramienta de patrones agregada a la tarea; de lo contrato, se incrementará, es decir, "Patron_2", "Patron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de recuento Patrones - Ficha Ajustes

Closed Entrenar entrada

Define si se entrena o no un patrón Modelo sobre una línea de entrada (el ajuste predeterminado es "Off": deshabilitado).

  • Entrada: Entrena un patrón Modelo sobre una línea de entrada. La línea de entrada seleccionada se utilizará como señal de entrenamiento.

    Notas:
    • Esta opción no aparecerá si el sistema de visión In-Sight no dispone de entradas discretas (por ejemplo, el sistema de visión In-Sight de la serie 8000 utiliza E/S directa).
    • El tipo de señal de la línea de entrada seleccionada debe estar fijado en Disparador de evento en el paso de aplicación Entradas/Salidas.
    • El entrenamiento de un patrón Modelo utilizará la imagen más reciente que haya adquirido el sensor/sistema de visión. No es necesario volver a lanzar el sensor/sistema de visión para el entrenamiento.
    • Para obtener más información, consulte Entradas: Entrenamiento de un patrón Modelo sobre una línea de entrada
Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Tolerancia de rotación

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define la tolerancia de la herramienta para las modificaciones en la escala del patrón, dentro de un ±10% del tamaño del patrón entrenado. De forma predeterminada, este ajuste está desactivado (sin marcar), por lo que se deshabilitan los ajustes de la escala. En este modo de operación, la herramienta todavía encontrará patrones que se encuentren en un rango de ±10%, pero la puntuación de la característica se reducirá según aumente el porcentaje de la escala.

Closed Tipo de modelo

Define cómo la herramienta debe construir el patrón Modelo, Modelo de área o Modelo de margen (predeterminado). Modelo de área crea el patrón Modelo a partir de un muestreo de uniformidad de los valores de escala de grises contenidos en la región Modelo. Modelo de margen crea el patrón Modelo basándose en los márgenes detectados (transiciones entre claro y oscuro) de la característica del patrón dentro de la región Modelo.

Closed Precisión

Define cómo la herramienta evaluará el compromiso entre exactitud/fiabilidad frente a velocidad de ejecución; Exacto, Medio (preajuste) y Rápido. Exacto prioriza la precisión y la fiabilidad, reduciendo la velocidad de ejecución, Rápido favorece la velocidad de ejecución a costa de la precisión y fiabilidad, mientras que Mediano es un equilibrio entre las dos primeras opciones.

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo.


Herramienta Recuento de patrones - ficha Límites de rango

Closed Máximo

Define el número máximo admisible de patrones a detectar; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Patrones

Comunica el número actual de patrones detectados (los patrones contados en la imagen parten de un orden numérico en el que 0 = 1); los valores que coinciden exactamente con los ajustes "Mínimo" y "Máximo", o que se encuentran entre ellos, se clasifican como Aceptación.

Closed Mínimo

Define el número mínimo admisible de patrones a detectar; la herramienta creará un ajuste predeterminado de "Límite inteligente" basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.


Herramienta Recuento de patrones - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de la herramienta de recuento Patrones

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I |  | Entrada
Precisión | I |  | Entrada
Tolerancia_Angulo | I |  | Entrada
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Entrenamiento_Externo | I |  | Entrada
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I |  | Entrada
Máximo | I |  | Entrada
Mínimo | I |  | Entrada
Tipo_Modelo | I |  | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Recuento_Patrones | I | X | Salida
Escala_Tolerancia | I |  | Entrada
Estado | I | X |
Tiempo de espera | I |  | Entrada
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | Entrada/Salida
Precisión | I | X | Entrada/Salida
Tolerancia_Angulo | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Entrenamiento_Externo | I |  | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | I | X | Entrada/Salida
Mínimo | I | X | Entrada/Salida
Tipo_Modelo | I | X | Entrada/Salida
Escala_Tolerancia | I | X | Entrada/Salida
Tiempo de espera | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Recuento_Patrones | I | X | Salida
Patrones | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Modelo | A | X |
Buscar | A | X |
Entrenar | A | X |
Entrenar_Entrada | I | X | Entrada/Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Precisión | I | X | X | Entrada/Salida
Tolerancia_Angulo | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Entrenamiento_Externo | I |  |  | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Tipo_Modelo | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Tiempo de espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Recuento_Patrones | I | X | X | Salida
Patrones | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Modelo | A | X | X |
Buscar | A | X | X |
Entrenar | A | X | X |
Entrenar_Entrada | I | X | X | Entrada/Salida


/ Herramientas de identificación - Leer código 1D y Leer códigos 1D (1-20)

Las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20) descodifican y/o verifican códigos de barras 1D y/o apilados mediante el algoritmo ReadIDMax®. Si los códigos se descodifican correctamente y el código estaba dentro de los límites de umbral especificados, las herramientas envían la información descodificada y una señal de aceptación.

La herramienta de identificación Leer código 1D permite leer y/o verificar un único código dentro de la región, mientras que la herramienta de identificación Leer códigos 1D (1-20) se utiliza para leer y/o verificar hasta 20 códigos dentro de la región.

  1. Configuración de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20)
  2. Ajuste de los parámetros de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20)
  3. Uso de las propiedades de entrada/salida de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20)


/ Configuración de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20)

Una vez añadida la herramienta, deberá configurar la región en la imagen:

  1. Para la herramienta de identificación Leer código 1D, sitúe la región sobre el código o símbolo y asegúrese de que los límites de la región cubran todo el código o símbolo. Para la herramienta de identificación Leer códigos 1D (1-20), sitúe la región sobre el área en la que espera que aparecerán los códigos o símbolos y asegúrese de que los límites de la región abarquen todos los códigos o símbolos que desea descodificar. Para aumentar la velocidad de ejecución de la herramienta, intente crear regiones más pequeñas, ya que la inspección de las regiones de gran tamaño tarda más tiempo.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, deberá definir parámetros enFicha Ajustes:
  1. El parámetro Modo, que define la modalidad operativa de la herramienta: Leer o Cadena coincidente (el modo predeterminado es Leer).
  2. Para la herramienta de identificación Leer códigos 1D (1-20) también deberá definir el parámetro Número máximo de resultados, que define el número de códigos/símbolos a descodificar (preajuste = 1).
  4. La herramienta dibujará un cuadro de contorno no editable alrededor del código o símbolo descodificado, e insertará un icono [image] para indicar el elemento creado a partir del código o símbolo descodificado.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


/ Ajuste de los parámetros de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20) consta de las fichas siguientes:

  • Ficha General
  • Ficha Ajustes
  • Ficha 1D
  • Ficha Apilado
  • Ficha Resultados
  • Tabla
Notas:
  • La ficha Resultados solo se activa con la herramienta de identificación Leer código 1D.
  • Tabla solo se activa con la herramienta de identificación Leer códigos 1D (1-20).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


/ Herramientas de identificación Leer código 1D y Leer códigos 1D (1-20) - Fichas General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "CodigoID_1" (si se trata de la primera herramienta de identificación Leer código 1D, Leer códigos 1D (1-20), Leer código 2D, Leer códigos 2D (1-20) o Leer código postal agregada a la tarea; de lo contrario, se incrementará, es decir, "CodigoID_2", "CodigoID_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


/ Herramientas de identificación Leer código 1D y Leer códigos 1D (1-20) - fichas Ajustes

Closed Máximo de resultados

Define el número máximo de códigos/símbolos a leer (1 - 20; preajuste = 1).

Nota: Si el valor Número máximo de resultados supera al número de códigos/símbolos del campo de visión (FOV), la herramienta seguirá buscando el número de códigos/símbolos especificado. Si el número de códigos/símbolos contenidos en el FOV variase, puede reducirse el tiempo de ejecución de la herramienta ajustando el valor del parámetro Tiempo de espera.

Closed Entrenado

Muestra si la herramienta ha sido entrenada con respecto a un determinado código o símbolo; muestra 1 si la herramienta ha sido entrenada, y 0 si no lo ha sido.

Closed Entrenar

Entrena un modelo del código o símbolo leído; la información entrenada se conserva hasta que se presione el botón Desentrenar. Para reentrenar un código o símbolo, presione el botón Desentrenar y luego el botón Entrenar con el nuevo código o símbolo presente. El entrenamiento se utiliza para mejorar la velocidad y el rendimiento de la herramienta, enseñando a la herramienta qué tipo de código o símbolo debe descodificar. Cuando utilice la herramienta de identificación Leer códigos 1D (1-20) o Leer códigos 2D (1-20) para entrenar, configure la región en torno a un solo código o símbolo antes de presionar el botón Entrenar. Una vez entrenado el código o símbolo, puede ajustar la región para seguir buscando múltiples códigos o símbolos en el campo de visión (FOV). El entrenamiento solo funciona con un único código o símbolo de la región; si presiona el botón Entrenar habiendo múltiples códigos o símbolos en la región, será imposible determinar qué código o símbolo se entrenará. Antes del entrenamiento, asegúrese de seleccionar los tipos de código correctos en las fichas 1D y Apilado.

Closed Desentrenar

Deshace el entrenamiento de un modelo de código o símbolo entrenado. Para reentrenar un código o símbolo, presione el botón Desentrenar y luego el botón Entrenar con el nuevo código presente.

Closed Modo

Define el modo operativo de la herramienta (Leer o Cadena coincidente; preajuste = Leer).

  • Leer = Se utiliza cuando la información contenida en el código o símbolo es desconocida. La herramienta descodificará automáticamente la información contenida en el código o símbolo y visualizará la información descodificada en el parámetro Cadena.
  • Cadena coincidente= Se utiliza para verificar la presencia y legibilidad de un código o símbolo conocido. La herramienta descodificará la información contenida en códigos o símbolos y la comparará con la información introducida en el parámetro Cadena coincidente.
Closed Cadena coincidente

Define la cadena prevista a leer (habilitado sólo cuando el parámetro Modo está ajustado a Cadena coincidente). Introduzca la información que espere que la herramienta descodifique.

Nota: La cadena coincidente se puede introducir desde otro dispositivo. Al ejecutar la tarea, la herramienta de identificación puede leer la cadena de texto desde el dispositivo de entrada y compararla con el código o símbolo de identificación reconocido. La herramienta generará un rechazo y el campo Cadena coincidente mostrará TRIG hasta que se introduzca la Cadena coincidente desde el dispositivo externo.

Closed Modo coincidente

Define si todos los códigos/símbolos descodificados en la región deben coincidir con la cadena definida en el parámetro Cadena coincidente a entregar. Para activar esta opción, debe configurarse el parámetro Cadena coincidente.

  • Todos coinciden = Todos los códigos/símbolos descodificados deben coincidir con la cadena definida en el parámetro Cadena coincidente.
  • Cualquiera coincide = Al menos uno de los códigos/símbolos descodificados debe coincidir con la cadena definida en el parámetro Cadena coincidente.
Closed Suma de comprobación

Define si el código/símbolo debe ser validado para garantizar la fiabilidad mediante un algoritmo de detección de errores (de forma predeterminada, este ajuste está desactivado). La suma de verificación solo es aplicable a los códigos o símbolos que contengan algoritmos de suma de verificación opcionales; cada código o símbolo tiene su propio algoritmo de suma de verificación único. El tipo de suma de verificación que se utilice dependerá del tipo de código/símbolo seleccionado.

Nota: Los códigos de barras Code 128, Code 93, RSS, UPC y EAN se validan con una suma de verificación independientemente de la selección de parámetros. Si el ajuste Suma de verificación está activado para cualquier otro código de barras y no hay ninguna suma de verificación codificada, la lectura fallará.

Closed Modo de ordenación

Define el orden de presentación de los resultados (Ninguno, De arriba abajo, Izquierda a derecha, Alfabético o Longitud de cadena; preajuste = Ninguno).

  • Ninguno = Ordena por los primeros resultados descodificados. Los resultados no descodificados aparecerán a continuación de los resultados descodificados.
  • De arriba abajo = Ordena por valores ascendentes de la coordenada X de los elementos.
  • Izquierda a derecha = Ordena por valores ascendentes de la coordenada Y de los elementos.
  • Alfabético = Ordena los resultados alfabéticamente.
  • Longitud de cadena = Ordena los resultados según las longitudes de las cadenas (comenzando por la más corta hasta la más larga).
  • Fila = Ordena los resultados agrupando los símbolos en filas y clasificándolos de izquierda a derecha dentro de cada fila.
  • Columna = Ordena los resultados agrupando los símbolos en columnas y clasificándolos de arriba abajo dentro de cada columna.
Closed Permitir símbolos 1D idénticos

Define si la herramienta debe o no descodificar todos los símbolos de la región, incluso si son idénticos. Dos símbolos se consideran idénticos si tienen la misma longitud, tipo de simbología y cadena descodificada (de forma predeterminada, este ajuste está desactivado).

Closed Verificar

Define si se realizarán o no las pruebas de calidad de impresión (este ajuste está desactivado de forma predeterminada).

Closed Ampliar UPC-E

Define si el símbolo descodificado devuelve la cadena UPC-E de 6 dígitos o la cadena equivalente UPC-A de 11 dígitos (esta opción está activada de forma predeterminada).

Nota: El parámetro Ampliar UPC-E solo es compatible en sistemas de visión In-Sight Micro de la serie 1000, In-Sight de la serie 5000 e In-Sight de las series 70xx - 74xx con la versión de firmware 4.10.1 y superior.

Closed Tiempo_Espera

Define el tiempo, en milisegundos (0 a 30000, preajuste = 0), durante el que la herramienta buscará un código o símbolo válido antes de detenerse y generar un rechazo.

Closed Número descodificado

Muestra el número de códigos/símbolos descodificados.

Nota: Los parámetros Máximo de resultados, Modo coincidente , Modo de ordenación, Permitir símbolos 1D idénticos y Número descodificado solo están disponibles en la herramienta de identificación Leer códigos 1D (1-20).


/ Herramientas de identificación Leer código 1D y Leer códigos 1D (1-20) - ficha 1D

Esta ficha define qué códigos o símbolos se intentarán descodificar. De forma predeterminada todos los tipos de códigos o símbolos están activados. Se pueden seleccionar y leer varias simbologías.

Closed Código 128

Define si la herramienta intentará o no realizar la lectura de códigos 128.

Closed Código 39

Define si la herramienta intentará o no realizar la lectura de códigos 39 (también conocidos como códigos 3 de 9 y BC39).

Closed Intercalado 2 de 5

Define si la herramienta intentará o no realizar la lectura de códigos ITF-14.

Closed Pharmacode

Define si la herramienta intentará o no realizar la lectura de códigos Pharmacode.

Closed UPC/EAN

Define si la herramienta intentará o no realizar la lectura de códigos UPC (Universal Product Code, código de producto universal) y EAN (European Article Numbering, número de artículo europeo). UPC admite códigos de barras UPC de la versión A (versión normal) y de la versión E (versión con supresión de ceros) UPC, así como codificaciones adicionales de dos y cinco caracteres. EAN admite códigos de barras EAN-8 y EAN-13, así como codificaciones adicionales de dos y cinco caracteres.

Closed Código 93

Define si la herramienta intentará o no realizar la lectura de códigos 93.

Closed Codabar

Define si la herramienta intentará o no realizar la lectura códigos Codabar (también conocidos como códigos USD-4 y código 2 de 7).


/ Herramientas de identificación Leer código 1D y Leer códigos 1D (1-20) - fichas Apilado

Esta ficha define qué códigos o símbolos se intentarán descodificar. De forma predeterminada todos los tipos de códigos o símbolos están activados. Se pueden seleccionar y leer varias simbologías.

Closed PDF 417

Define si la herramienta intentará una lectura según PDF 417.

Closed DataBar

Define si la herramienta intentará una lectura según DataBar.

Closed DataBar Limited

Define si la herramienta intentará una lectura según DataBar Limited.

Closed DataBar Expanded

Define si la herramienta intentará una lectura según DataBar Expanded.

Closed EAN.UCC Compuesto

Define si la herramienta intentará una lectura según EAN.UCC Composite.


Herramienta de identificación Leer código 1D - ficha Resultados

La ficha Resultados muestra la siguiente información sobre el código o símbolo descodificado:

Closed Cadena

Devuelve la cadena contenida en el código o símbolo descodificado.

Closed Simbología

Devuelve el tipo de símbología descodificado.

Closed Grado

Devuelve el grado asignado al código o símbolo descodificado.


Herramienta de identificación Leer códigos 1D (1-20) - Tabla

La Tabla comunica la siguiente información sobre cada código o símbolo descodificado:

Closed Índice

Se refiere al orden del código o símbolo descodificado, según el parámetro Modo de ordenación; 1 a 20 (el orden numérico de EasyBuilder asume que 0=1).

Closed Cadena

Devuelve la cadena contenida en el código o símbolo descodificado.

Closed Simbología

Devuelve el tipo de símbología descodificado.

Closed X

Devuelve la coordenada X del elemento correspondiente al código o símbolo descodificado.

Closed Y

Devuelve la coordenada Y del elemento correspondiente al código o símbolo descodificado.

Closed Ángulo

Devuelve el ángulo de salida del elemento correspondiente al código/símbolo descodificado.

Closed Grado

Devuelve el grado asignado al código o símbolo descodificado.


/ Uso de las propiedades de entrada/salida de las herramientas de identificación Leer código 1D y Leer códigos 1D (1-20)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Suma_Comprobacion | I | X | X | Entrada/Salida
Codabar | I | X | X | Entrada/Salida
Codigo_128 | I | X | X | Entrada/Salida
Codigo_39 | I | X | X | Entrada/Salida
Codigo_93 | I | X | X | Entrada/Salida
DataBar | I | X | X | Entrada/Salida
DataBar_Expandido | I | X | X | Entrada/Salida
DataBar_Limitado | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
EAN.UCC_Compuesto | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Interleaved_2_of_5 | I | X | X | Entrada/Salida
Cadena_Coincidente | S | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
PDF_417 | I | X | X | Entrada/Salida
Pharmacode | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Permitir_Simbolos_1D_Identicos | I | X | X | Entrada/Salida
UPC_EAN | S | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | S | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Elemento1-19.Angulo* | FP | X | X | Salida
Elemento1-19.X* | FP | X | X | Salida
Elemento1-19.Y* | FP | X | X | Salida
Calificacion | FP | X | X | Salida
Calificacion1-19* | FP | X | X | Salida
Numero_Descodificado | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Cadena | S | X | X | Salida
Cadena1-19* | S | X | X | Salida
Simbologia | S | X | X | Salida
Simbologia1-19* | S | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Entrenado | FP | X | X | Salida
Region | A |  | X |
Entrenar | A |  | X |
Desentrenar | A |  | X |

Nota: * denota una entrada únicamente disponible para la herramienta de identificación Leer códigos 1D (1-20).


/ Herramientas de identificación - Leer código 2D y Leer códigos 2D (1-20)

Las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20) descodifican y/o verifican simbologías QR Code y/o Data Matrix mediante el algoritmo ReadIDMax®. Si los códigos se descodifican correctamente y el código estaba dentro de los límites especificados, las herramientas envían la información descodificada y una señal de aceptación.

La herramienta de identificación Leer código 2D permite leer y/o verificar un único símbolo dentro de la región, mientras que la herramienta de identificación Leer códigos 2D (1-20) se utiliza para leer y/o verificar hasta 20 símbolos dentro de la región.

  1. Configuración de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20)
  2. Ajuste de los parámetros de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20)
  3. Uso de las propiedades de entrada/salida de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20)


/ Configuración de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20)

Una vez añadida la herramienta, deberá configurar la región en la imagen:

  1. Para la herramienta de identificación Leer código 2D, sitúe la región sobre el código o símbolo y asegúrese de que los límites de la región cubran todo el código o símbolo. Para la herramienta de identificación Leer códigos 2D (1-20), sitúe la región sobre el área en la que espera que aparecerán los códigos o símbolos y asegúrese de que los límites de la región abarquen todos los códigos o símbolos que desea descodificar. Para aumentar la velocidad de ejecución de la herramienta, intente crear regiones más pequeñas, ya que la inspección de las regiones de gran tamaño tarda más tiempo.

Nota: Al leer códigos 2D, es importante permitir una "zona tranquila" entre el código y la región. La "zona tranquila" implica una separación mínima de 3 píxeles entre el margen del código y la región que define el código.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, deberá definir parámetros enFicha Ajustes:
  1. El parámetro Grupo de simbología, que define el tipo de simbología, Data Matrix o QR Code (la simbología predeterminada es Data Matrix.
  2. El parámetro Modo, que define la modalidad operativa de la herramienta: Leer o Cadena coincidente (el modo predeterminado es Leer).
  3. Para la herramienta de identificación Leer códigos 2D (1-20) también deberá definir el parámetro Número máximo de resultados, que define el número de códigos/símbolos a descodificar (preajuste = 1).
  4. La herramienta dibujará un cuadro de contorno no editable alrededor del código o símbolo descodificado, e insertará un icono [image] para indicar el elemento creado a partir del código o símbolo descodificado.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


/ Ajuste de los parámetros de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20) consta de las fichas siguientes:

  • Ficha General
  • Ficha Ajustes
  • Ficha Resultados
  • Tabla
Notas:
  • La ficha Resultados solo se habilita con la herramienta de identificación Leer código 2D.
  • La tabla solo se habilita con la herramienta de identificación Leer códigos 2D (1-20).

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


/ Herramientas de identificación Leer código 2D y Leer códigos 2D (1-20) - Fichas General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "CodigoID_1" (si se trata de la primera herramienta de identificación Leer código 1D, Leer códigos 1D (1-20), Leer código 2D, Leer códigos 2D (1-20) o Leer código postal agregada a la tarea; de lo contrario, se incrementará, es decir, "CodigoID_2", "CodigoID_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


/ Herramientas de identificación Leer código 2D y Leer códigos 2D (1-20) - fichas Ajustes

Closed Grupo de simbología

Define el tipo de simbología (Matriz de datos o Código QR; valor predeterminado = Matriz de datos) para intentar la descodificación.

Nota: Si se selecciona Código QR, la herramienta intentará descodificar todos los tipos de código QR (Modelo QR 1/2, Micro QR y modelo QR 1/2).

Closed Máximo de resultados

Define el número máximo de códigos/símbolos a leer (1 - 20; preajuste = 1).

Nota: Si el valor Número máximo de resultados supera al número de códigos/símbolos del campo de visión (FOV), la herramienta seguirá buscando el número de códigos/símbolos especificado. Si el número de códigos/símbolos contenidos en el FOV variase, puede reducirse el tiempo de ejecución de la herramienta ajustando el valor del parámetro Tiempo de espera.

Closed Entrenado

Muestra si la herramienta ha sido entrenada con respecto a un determinado código o símbolo; muestra 1 si la herramienta ha sido entrenada, y 0 si no lo ha sido.

Closed Entrenar

Entrena un modelo del código o símbolo leído; la información entrenada se conserva hasta que se presione el botón Desentrenar. Para reentrenar un código o símbolo, presione el botón Desentrenar y luego el botón Entrenar con el nuevo código o símbolo presente. El entrenamiento se utiliza para mejorar la velocidad y el rendimiento de la herramienta, enseñando a la herramienta qué tipo de código o símbolo debe descodificar. Cuando utilice la herramienta de identificación Leer códigos 1D (1-20) o Leer códigos 2D (1-20) para entrenar, configure la región en torno a un solo código o símbolo antes de presionar el botón Entrenar. Una vez entrenado el código o símbolo, puede ajustar la región para seguir buscando múltiples códigos o símbolos en el campo de visión (FOV). El entrenamiento solo funciona con un único código o símbolo de la región; si presiona el botón Entrenar habiendo múltiples códigos o símbolos en la región, será imposible determinar qué código o símbolo se entrenará. Antes de entrenar, asegúrese de haber seleccionado el grupo de simbología correcto (Matriz de datos o QR) en el parámetro Grupo de simbología.

Closed Desentrenar

Deshace el entrenamiento de un modelo de código o símbolo entrenado. Para reentrenar un código o símbolo, presione el botón Desentrenar y luego el botón Entrenar con el nuevo código presente.

Closed Perspectiva

Define los ajustes de descodificación (Sin perspectiva, Perspectiva o Entrenar perspectiva; valor predeterminado = Sin perspectiva) para simbologías de matriz de datos. Para activar este parámetro, el parámetro Grupo de simbología debe establecerse en Matriz de datos.

  • Sin perspectiva = Descodifica los símbolos de matriz de datos que no tienen distorsión de la perspectiva.
  • Perspectiva = Descodifica los símbolos de matriz de datos con distorsión de la perspectiva; la distorsión de la perspectiva se calcula de forma independiente durante el entrenamiento del modelo en tiempo de ejecución.
  • Entrenar perspectiva = Descodifica los símbolos de matriz de datos con una distorsión de la perspectiva conocida. La perspectiva se entrena junto con otros atributos al utilizar un modelo entrenado de un símbolo. En tiempo de ejecución, el símbolo se busca en un espacio en el que la distorsión de la perspectiva en la imagen de entrada se compensa mediante los atributos entrenados. Esta opción requiere que el símbolo de tiempo de ejecución se coloque en el mismo plano que el del símbolo de entrenamiento. La opción permite descodificar varios símbolos dañados con una distorsión de la perspectiva conocida.

Sugerencia: Se recomienda montar el sistema de visión In-Sight de manera que el ángulo de incidencia (el ángulo entre el eje óptico del sensor y el vector normal del plano en el que se presenta el símbolo) no sea mayor que 40 grados y la resolución del símbolo sea de al menos 5 píxeles por celda.

Closed Modo

Define el modo operativo de la herramienta (Leer o Cadena coincidente; preajuste = Leer).

  • Leer = Se utiliza cuando la información contenida en el código o símbolo es desconocida. La herramienta descodificará automáticamente la información contenida en el código o símbolo y visualizará la información descodificada en el parámetro Cadena.
  • Cadena coincidente= Se utiliza para verificar la presencia y legibilidad de un código o símbolo conocido. La herramienta descodificará la información contenida en códigos o símbolos y la comparará con la información introducida en el parámetro Cadena coincidente.
Closed Cadena coincidente

Define la cadena prevista a leer (habilitado sólo cuando el parámetro Modo está ajustado a Cadena coincidente). Introduzca la información que espere que la herramienta descodifique.

Nota: La cadena coincidente se puede introducir desde otro dispositivo. Al ejecutar la tarea, la herramienta de identificación puede leer la cadena de texto desde el dispositivo de entrada y compararla con el código o símbolo de identificación reconocido. La herramienta generará un rechazo y el campo Cadena coincidente mostrará TRIG hasta que se introduzca la Cadena coincidente desde el dispositivo externo.

Closed Modo coincidente

Define si todos los códigos/símbolos descodificados en la región deben coincidir con la cadena definida en el parámetro Cadena coincidente a entregar. Para activar esta opción, debe configurarse el parámetro Cadena coincidente.

  • Todos coinciden = Todos los códigos/símbolos descodificados deben coincidir con la cadena definida en el parámetro Cadena coincidente.
  • Cualquiera coincide = Al menos uno de los códigos/símbolos descodificados debe coincidir con la cadena definida en el parámetro Cadena coincidente.
Closed Modo de ordenación

Define el orden de presentación de los resultados (Ninguno, De arriba abajo, Izquierda a derecha, Alfabético o Longitud de cadena; preajuste = Ninguno).

  • Ninguno = Ordena por los primeros resultados descodificados. Los resultados no descodificados aparecerán a continuación de los resultados descodificados.
  • De arriba abajo = Ordena por valores ascendentes de la coordenada X de los elementos.
  • Izquierda a derecha = Ordena por valores ascendentes de la coordenada Y de los elementos.
  • Alfabético = Ordena los resultados alfabéticamente.
  • Longitud de cadena = Ordena los resultados según las longitudes de las cadenas (comenzando por la más corta hasta la más larga).
  • Fila = Ordena los resultados agrupando los símbolos en filas y clasificándolos de izquierda a derecha dentro de cada fila.
  • Columna = Ordena los resultados agrupando los símbolos en columnas y clasificándolos de arriba abajo dentro de cada columna.
Closed Verificar

Define si se realizarán o no las pruebas de calidad de impresión (este ajuste está desactivado de forma predeterminada).

Closed Permitir resultados binarios

Define si la función descodificará o no como hex ASCII los símbolos DataMatrix codificados como datos binarios de base 256 (este ajuste está desactivado de forma predeterminada).

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30000; valor predeterminado = 5000), durante el que la herramienta buscará un código o símbolo válido antes de que se detenga la ejecución y el resultado de la herramienta sea un rechazo.

Closed Número descodificado

Muestra el número de códigos/símbolos descodificados.

Nota: Los parámetros Máximo de resultados, Modo coincidente , Modo de ordenación y Número descodificado solo están disponibles en la herramienta de identificación Leer códigos 2D (1-20).


Herramienta de identificación Leer código 2D - Ficha Resultados

La ficha Resultados muestra la siguiente información sobre el código o símbolo descodificado:

Closed Cadena

Devuelve la cadena contenida en el código o símbolo descodificado.

Closed Símbolos

Devuelve el tipo de símbología descodificado.

Closed Grado

Devuelve el grado asignado al código o símbolo descodificado.


Herramienta de identificación Leer códigos 2D (1-20) - Tabla

La Tabla comunica la siguiente información sobre cada código o símbolo descodificado:

Closed Índice

Se refiere al orden del código o símbolo descodificado, según el parámetro Modo de ordenación; 1 a 20 (el orden numérico de EasyBuilder asume que 0=1).

Closed Cadena

Devuelve la cadena contenida en el código o símbolo descodificado.

Closed Simbologia

Devuelve el tipo de símbología descodificado.

Closed X

Devuelve la coordenada X del elemento correspondiente al código o símbolo descodificado.

Closed Y

Devuelve la coordenada Y del elemento correspondiente al código o símbolo descodificado.

Closed Ángulo

Devuelve el ángulo de salida del elemento correspondiente al código/símbolo descodificado.

Closed Calificacion

Devuelve el grado asignado al código o símbolo descodificado.


/ Uso de las propiedades de entrada/salida de las herramientas de identificación Leer código 2D y Leer códigos 2D (1-20)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Modo_correspondencia* | I | X | X | Entrada/Salida
Cadena_Coincidente | S | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Número_Máximo_Resultados* | I | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Perspectiva | I | X | X | Entrada/Salida
Modo_Ordenación* | I | X | X | Entrada/Salida
Grupo_Simbología | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Verificar | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Ángulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Elemento1-19.Ángulo* | FP | X | X | Salida
Elemento1-19.X* | FP | X | X | Salida
Elemento1-19.Y* | FP | X | X | Salida
Grado | FP | X | X | Salida
Grado1-19 | FP | X | X | Salida
Número_Descodificado | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Cadena | S | X | X | Salida
Cadena1-19 | S | X | X | Salida
Simbología | S | X | X | Salida
Simbología1-19 | S | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Entrenado | FP | X | X | Salida
Región | A | X | X |
Entrenar | A | X | X |
Desentrenar | A | X | X |

Nota: * indica una entrada solo disponible para la herramienta de identificación Leer códigos 2D (1-20).


Herramientas de identificación - Leer códigos de ID

La herramienta de identificación Leer códigos de ID descodifica y comprueba automáticamente la información contenida en códigos de barras 1D y en símbolos de matriciales 2D.

  1. Configuración de la herramienta de identificación Leer códigos de ID
    1. Códigos de ID reconocidos
  2. Ajuste de los parámetros de la herramienta de identificación Leer códigos de ID
  3. Uso de las propiedades de entrada/salida de la herramienta de identificación Leer códigos de ID


Configuración de la herramienta de identificación Leer códigos de ID

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo en la imagen:

  1. Sitúe la región sobre el área en la que espera que el código o símbolo aparecerá y asegúrese de que los límites de la región cubran la totalidad de dicho código o símbolo. Para aumentar la velocidad de ejecución de la herramienta, intente crear regiones más pequeñas, ya que la inspección de las regiones de gran tamaño tarda más tiempo.

Nota: Al leer códigos 2D, es importante permitir una "zona tranquila" entre el código y la región. La "zona tranquila" implica una separación mínima de 3 píxeles entre el margen del código y la región que define el código.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez confirmada la región, deberá definir el modo de operación: Leer o Hacer coincidir cadena (el modo predeterminado es Leer). Este ajuste se configura en la ficha Ajustes.
  4. La herramienta recordará el tipo de código y lo buscará al ejecutarse. Si el tipo de código cambia, presione el botón Aprender en la ficha Ajustes para que la herramienta identifique el nuevo tipo de código y en adelante busque ese tipo de código.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Códigos de identificación reconocidos

La herramienta de identificación Leer códigos de ID reconoce los siguientes tipos de códigos y símbolos:

    Code 39 | Code 128
Código I2of5 | UPC
EAN | PharmaCode
POSTNET | PLANET
RSS-14 & Stacked | RSS Limited
Codabar (NW-7) | Code 93
UPU 4-State | Australia Post 4-State
Japan Post 4-State | USPS OneCode 4-State
Data Matrix | QR
RSS CC-A | RSS CC-B
PDF 417 |


Ajuste de los parámetros de la herramienta de identificación Leer códigos de ID

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación Leer códigos de ID consta de cuatro fichas:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Leer códigos de ID - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección, que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "CodigoID_1" (si se trata de la primera herramienta de identificación Leer códigos de ID agregada a la tarea; de lo contrario, se incrementará, es decir, "CodigoID_2", "CodigoID_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de identificación Leer códigos de ID - ficha Ajustes

Closed Botón Aprender

Define un nuevo tipo de código o símbolo. El botón Aprender se utiliza cuando se presenta un nuevo código o símbolo a la herramienta. Después de presentar el nuevo código o símbolo a la herramienta, presione el botón Aprender y la herramienta intentará descifrarlo automáticamente. Una vez descodificado correctamente el nuevo tipo de código o símbolo, en adelante la herramienta leerá o verificará sólo los códigos o símbolos de ese tipo.

Closed Código

Muestra el tipo de código o símbolo descodificado.

Closed Modo

Define el modo operativo de la herramienta: Leer o Cadena coincidente.

Leer (el modo predeterminado) se utiliza cuando la información contenida en el código o símbolo es desconocida. La herramienta descodificará automáticamente la información contenida en el código o símbolo y visualizará la información descodificada en el parámetro Cadena.

Hacer coincidir cadena se utiliza para verificar la presencia y legibilidad de un código de barras o símbolo conocido. La herramienta descodificará la información contenida en códigos de barras o símbolos y la comparará con la información introducida en el parámetro Cadena coincidente.

Nota: La herramienta tiene dos estados: aceptación o rechazo. Cuando el control Modo de la herramienta está definido como Cadena coincidente, la herramienta devuelve un rechazo en dos situaciones diferentes: cuando la lectura falla o cuando la lectura es correcta pero la información descodificada no coincide con la cadena de texto introducida en el parámetro Cadena coincidente.

En este último caso, la herramienta devuelve los datos no coincidentes (Diferencia y Recuento de diferencias), que pueden utilizarse en EasyView y en otros dispositivos de comunicación en el paso de aplicación Comunicación. Los datos no coincidentes se pueden seleccionar en cualquiera de los diálogos Seleccionar elementos de EasyView, Seleccionar etiquetas OPC o Seleccionar datos de entrada/salida.

Los datos no coincidentes permiten al usuario determinar si la herramienta no puede leer el código, o si éste puede leerse pero la información descifrada no coincide con la Cadena coincidente definida. Por ejemplo, si la herramienta no puede leer el código, puede deberse a un problema en el proceso de impresión de etiquetas o en la configuración del sistema de visión. Si el código se lee correctamente pero la información descifrada no coincide con la Cadena coincidente definida, podría imprimirse la etiqueta incorrecta.

Closed Cadena coincidente

Define la cadena prevista a leer (habilitado sólo cuando el parámetro Modo está ajustado a Cadena coincidente). Introduzca la información que espere que la herramienta descodifique.

Nota: La cadena coincidente se puede introducir desde otro dispositivo. Al ejecutar la tarea, la herramienta de identificación puede leer la cadena de texto desde el dispositivo de entrada y compararla con el código de identificación reconocido. La herramienta Leer códigos de ID generará un rechazo y el campo Hacer coincidir cadena mostrará TRIG hasta que se introduzca la cadena de coincidencia desde el dispositivo externo.

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará códigos antes de detenerse y devolver un rechazo.

Closed Cadena

Muestra la información descodificada.


Uso de las propiedades de entrada/salida de la herramienta de Identificación Leer códigos de ID

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Match_String | S | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Tiempo de espera | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Code | S | X | X | Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
ID | S | X | X | Salida
Diferencia | FP | X | X | Salida
Mismatch_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Cadena | S | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Región | A | X | X |


Herramientas de identificación - Color

La herramienta de identificación Color permite, a partir de una biblioteca de colores entrenados, determinar qué color coincide mejor con el de la imagen.

Esta herramienta es útil, por ejemplo, en aplicaciones en las que se desea garantizar que en la línea de producción se encuentre el producto correcto, basándose en el color de una pieza o de un objeto, o reconocer qué producto se está procesando para comunicar esa información a otros dispositivos de la planta de producción.

  1. Configuración de la herramienta de identificación Color
  1. Componentes del color de un píxel
  2. Ajuste de los parámetros de la herramienta de identificación Color
  3. Uso de las propiedades de entrada/salida de la herramienta de identificación Color


Configuración de la herramienta Identificación de colores

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo en la imagen:

  1. En el menú desplegable Modelo, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los colores; asegúrese de que los límites de la región cubran tanto los colores como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los colores se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de los colores.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Colores apropiados:
  • Si ésta es la primera vez que ha agregado una Herramienta de identificación de colores, primero deberá definir las bibliotecas de colores y sus correspondientes colores.
  • Si anteriormente se añadió otra herramienta de identificación de colores y usted desea utilizar una Biblioteca de colores existente junto con sus Color(es) entrenado(s), abra la ficha Ajustes, seleccione la Biblioteca de colores deseada y active el Color deseado marcándolo en la ficha Biblioteca.
  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los colores que contiene.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Componentes del color de un píxel

Cada color consta de tres componentes de color individuales. Estos componentes se pueden representar como combinaciones de rojo, verde y azul (RGB), o matiz, saturación e intensidad (HSI). Tanto en RGB como en HSI, cada componente de un píxel se convierte a un valor entre 0 y 255.

Closed RGB

Los colores RGB se crean combinando diferentes proporciones de rojo (255, 0, 0), verde (0, 255, 0) y azul (0, 0, 255). La combinación produce un color específico para cada píxel.

Closed HSI

En HSI, el matiz de un color corresponde a su posición dentro de la porción visible del espectro de radiaciones electromágneticas.

La saturación de un color es el grado de mezcla del color con gris o blanco. Un color completamente saturado es puro; según se va mezclando con gris o con blanco, su saturación disminuye.

La intensidad de un color es una medida de su luminosidad. La intensidad de un color se define como el valor medio de los componentes rojo, verde y azule que lo componen. La mezcla resultante de matiz, saturación e intensidad produce el color correcto para cada píxel.

Closed Valores comparativos de RGB y HSI

Valores RGB = 255, 0, 0

Valores HSI = 0, 255, 85

Valores RGB = 0, 255, 0

Valores HSI = 85, 255, 85

Valores RGB = 0, 0, 255

Valores HSI = 170, 255, 85


Ajuste de los parámetros de la herramienta Identificación de colores

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación de colores consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Tabla
  • Ficha Biblioteca
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Color - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "IDColores_1" (si se trata de la primera herramienta de identificación de colores agregada a la tarea; de lo contrario, se incrementará, es decir, "IDColores_2", "IDColores_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de identificación de colores - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de MatchColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de MatchColor. Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de correspondencias de colores. Cada Biblioteca de colores puede contener hasta 100 Colores distintos, que se componen de los valores RGB/HIS del objeto inspeccionado.

Closed Espacio de colores

Define qué valores utilizará la herramienta en su cálculo comparativo: RGB (predeterminado) o HSI. Cada píxel de color consta tres componentes separados. Estos componentes se representan como combinaciones de rojo, verde y azul (RGB), o matiz, saturación e intensidad (HSI). Tanto RGB como HSI convierten cada componente de un píxel en un valor entre 0 y 255.

Closed Modo

Define el modo operacional de la herramienta: Identificar (predeterminado) o Correspondencia.

  • Identificar: Se utiliza cuando los colores de la imagen son desconocidos. La herramienta determinará qué Modelo de colores coincide mejor con los colores de la imagen y ordenará y categorizará los resultados basándose en sus recuentos de píxeles y, si hay múltiples, en los Modelos de colores activos en la Biblioteca de colores seleccionada.
  • Correspondencia: Permite verificar si un Modelo de colores esperado está presente en la imagen. La herramienta procesará la imagen y determinará si los colores que contiene coinciden o no con los esperados del Modelo de colores, en el parámetro Correspondencia de colores.
Closed Correspondencia de colores

Define el Color que se esperaba detectar. Este campo sólo está disponible si el parámetro Modo se ajusta a Correspondencia. Introduzca el nombre del Color que espera detectar en el campo.

Closed Aceptar umbral

Define el grado de semejanza que debe existir entre el Color y el Color encontrado (0-100; predeterminado = 90).

Closed Resultado

Muestra el nombre del Color encontrado.


Herramienta Identificación de colores - ficha Tabla

La ficha Tabla muestra una lista de sólo lectura de los Colores encontrados, clasificada por su rango y puntuación de las 10 mejores coincidencias.

Closed Rango

Muestra una graduación numérica de los Colores que mejor cumplen los criterios de inspección, entre 1 y 10.

Closed Nombre del color

Muestra los nombres de los Colores encontrados.

Closed Puntuación

Muestra la puntuación del Color encontrado.


Herramienta de identificación de colores - ficha Biblioteca de colores

Closed Nombre del color

Muestra una lista de sólo lectura de los Colores contenidos en la Biblioteca de correspondencias de colores seleccionada. Los Colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al Nombre del color.

Nota: De forma predeterminada, todo Color ya existente en una Biblioteca de correspondencias de colores se activa automáticamente en el momento de agregar por primera vez una herramienta. Los Colores deben desactivarse manualmente por cada herramienta que haga referencia a la Biblioteca de colores seleccionada. Si aún no se ha entrenado ningún Color para la Biblioteca de colores seleccionada, esta lista estará vacía.

Closed RGB

Muestra una lista de sólo lectura de los valores RGB promedio de los Colores contenidos en la Biblioteca de correspondencias de colores seleccionada.

Closed HSI

Muestra una lista de sólo lectura de los valores HSI promedio de los Colores contenidos en la Biblioteca de correspondencias de colores seleccionada.


Herramienta de identificación Color - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta Identificación de colores

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Accept_Threshold | I | X | X | Entrada/Salida
Color_Enable | I | X | X | Entrada/Salida
Color_Enable_Select | I | X | X | Entrada/Salida
Color_Library | I | X | X | Entrada/Salida
Color_Space | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
External_Color_Enable_Apply | I | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Match_Color | I | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Azul | FP | X | X | Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Verde | FP | X | X | Salida
Matiz | FP | X | X | Salida
Intensity | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Rojo | FP | X | X | Salida
Resultado | S | X | X | Salida
Saturación | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Color_Enable_Apply | A | X | X |
Región_compuesta | A | X | X |

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_evento | A | X | X | Entrada/Salida
Train_Model | S | X | X | Entrada/Salida
Train_Operation | I | X | X | Entrada/Salida
Train_Procedure | I | X | X |
Train_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Darker_Limit | FP | X | X | Entrada/Salida
Lighter_Limit | FP | X | X | Entrada/Salida
Train_Color | S | X | X | Entrada/Salida
Entrenar_evento | A | X | X |
Train_Region | A | X | X |


Herramientas de identificación - Leer código postal

La herramienta de identificación Leer código postal descodifica y/o verifica un único símbolo postal apilado ("Postal Stacked Symbol") dentro de una región mediante el algoritmo ReadIDMax®. Si el código o símbolo se descodifica correctamente y estaba dentro de los límites especificados, la herramienta envía la información descodificada y una señal de aceptación.

  1. Configuración de la herramienta de identificación Leer código postal
  2. Ajuste de los parámetros de la herramienta de identificación Leer código postal
  3. Uso de las propiedades de entrada/salida de la herramienta de Identificación Leer código postal


Configuración de la herramienta de identificación Leer código postal

Una vez añadida la herramienta, deberá configurar la región en la imagen:

  1. Sitúe la región sobre el código o símbolo y asegúrese de que los límites de la región lo abarquen íntegramente. Para aumentar la velocidad de ejecución de la herramienta, intente crear regiones más pequeñas, ya que la inspección de las regiones de gran tamaño tarda más tiempo.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, deberá definir parámetros enFicha Ajustes: El parámetro Modo, que define la modalidad operativa de la herramienta: Leer o Cadena coincidente (el modo predeterminado es Leer).
  4. La herramienta dibujará un cuadro de contorno no editable alrededor del código o símbolo descodificado, e insertará un icono [image] para indicar el elemento creado a partir del código o símbolo descodificado.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de identificación Leer código postal

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación Leer código postal consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Postal
  • Ficha Resultados

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Leer código postal - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "CodigoID_1" (si se trata de la primera herramienta de identificación Leer código 1D, Leer códigos 1D (1-20), Leer código 2D, Leer códigos 2D (1-20) o Leer código postal agregada a la tarea; de lo contrario, se incrementará, es decir, "CodigoID_2", "CodigoID_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de identificación Leer código postal - Ficha Ajustes

Closed Entrenado

Muestra si la herramienta ha sido entrenada con respecto a un determinado código o símbolo; muestra 1 si la herramienta ha sido entrenada, y 0 si no lo ha sido.

Closed Entrenar

Entrena un modelo del código o símbolo leído; la información entrenada se conserva hasta que se presione el botón Desentrenar. Para reentrenar un código o símbolo, presione el botón Desentrenar y luego el botón Entrenar con el nuevo código o símbolo presente. El entrenamiento se utiliza para mejorar la velocidad y el rendimiento de la herramienta, enseñando a la herramienta qué tipo de código o símbolo debe descodificar. Cuando utilice la herramienta de identificación Leer códigos 1D (1-20) o Leer códigos 2D (1-20) para entrenar, configure la región en torno a un solo código o símbolo antes de presionar el botón Entrenar. Una vez entrenado el código o símbolo, puede ajustar la región para seguir buscando múltiples códigos o símbolos en el campo de visión (FOV). El entrenamiento solo funciona con un único código o símbolo de la región; si presiona el botón Entrenar habiendo múltiples códigos o símbolos en la región, será imposible determinar qué código o símbolo se entrenará. Antes del entrenamiento, asegúrese de seleccionar los tipos de códigos correctos en la ficha Postal.

Closed Desentrenar

Deshace el entrenamiento de un modelo de código o símbolo entrenado. Para reentrenar un código o símbolo, presione el botón Desentrenar y luego el botón Entrenar con el nuevo código presente.

Closed Modo

Define el modo operativo de la herramienta (Leer o Cadena coincidente; preajuste = Leer).

  • Leer = Se utiliza cuando la información contenida en el código o símbolo es desconocida. La herramienta descodificará automáticamente la información contenida en el código o símbolo y visualizará la información descodificada en el parámetro Cadena.
  • Cadena coincidente= Se utiliza para verificar la presencia y legibilidad de un código o símbolo conocido. La herramienta descodificará la información contenida en códigos o símbolos y la comparará con la información introducida en el parámetro Cadena coincidente.
Closed Cadena coincidente

Define la cadena prevista a leer (habilitado sólo cuando el parámetro Modo está ajustado a Cadena coincidente). Introduzca la información que espere que la herramienta descodifique.

Nota: La cadena coincidente se puede introducir desde otro dispositivo. Al ejecutar la tarea, la herramienta de identificación puede leer la cadena de texto desde el dispositivo de entrada y compararla con el código o símbolo de identificación reconocido. La herramienta generará un rechazo y el campo Cadena coincidente mostrará TRIG hasta que se introduzca la Cadena coincidente desde el dispositivo externo.

Closed Modo de correspondencia

Define si todos los códigos/símbolos descodificados en la región deben coincidir con la cadena definida en el parámetro Cadena coincidente a entregar. Para activar esta opción, debe configurarse el parámetro Cadena coincidente.

  • Todos coinciden = Todos los códigos/símbolos descodificados deben coincidir con la cadena definida en el parámetro Cadena coincidente.
  • Cualquiera coincide = Al menos uno de los códigos/símbolos descodificados debe coincidir con la cadena definida en el parámetro Cadena coincidente.
Closed Verificar

Define si se realizarán o no las pruebas de calidad de impresión (este ajuste está desactivado de forma predeterminada).

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30000, preajuste = 0), durante el que la herramienta buscará un código o símbolo válido antes de detenerse y generar un rechazo.

Closed Omnidireccional

Define si la herramienta debe intentar buscar el código de barras mediante el modo omnidireccional (la opción predeterminada es que esta configuración esté inhabilitada). Esta configuración especifica la dirección en que se proyectan las líneas de barrido (en los símbolos 1D, el código de barras se divide en un máximo de 10 líneas situadas a espacios iguales, denominadas líneas de barrido, que trazan un recorrido perpendicular a las barras) dentro de la región, con objeto de detectar todos los elementos presentes en el código de barras. Como mínimo, una línea de barrido debe proyectarse a través de cada elemento del código de barras para que la descodificación sea satisfactoria. Cuando está inhabilitada esta opción, las líneas de barrido se proyectan en una región para detectar un código de barras paralelo a la región. Cuando está habilitada esta opción, las líneas de barrido se proyectan a diferentes ángulos para detectar códigos de barras que estén girados respecto a la región.


Herramienta de identificación Leer código postal - ficha Postal

Esta ficha define qué códigos o símbolos se intentarán descodificar. De forma predeterminada todos los tipos de códigos o símbolos están activados. Se pueden seleccionar y leer varias simbologías.

Closed POSTNET

Define si la herramienta intentará una lectura según POSTNET.

Closed PLANET

Define si la herramienta intentará una lectura según PLANET.

Closed Japan Post

Define si la herramienta intentará una lectura según Japan Post.

Closed Australia Post

Define si la herramienta intentará una lectura según Australia Post.

Closed UPU

Define si la herramienta intentará una lectura según UPU.

Closed Código de barras IM ("Intelligent Mail Barcode")

Define si la herramienta intentará una lectura según Intelligent Mail Barcode.


Herramienta de identificación Leer código postal - ficha Resultados

La ficha Resultados muestra la siguiente información sobre el código o símbolo descodificado:

Closed Cadena

Devuelve la cadena contenida en el código o símbolo descodificado.

Closed Simbología

Devuelve el tipo de símbología descodificado.

Closed Grado

Devuelve el grado asignado al código o símbolo descodificado.


Uso de las propiedades de entrada/salida de la herramienta de Identificación Leer código postal

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Australia_Post | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Intelligent_Mail_Barcode | I | X | X | Entrada/Salida
Cadena_Coincidente | S | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
PLANET | I | X | X | Entrada/Salida
POSTNET | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
UPU | I | X | X | Entrada/Salida
Verificar | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Ángulo | S | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Grado | FP | X | X | Salida
Número_Descodificado | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Cadena | S | X | X | Salida
Simbología | S | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Entrenado | FP | X | X | Salida
Región | A | X | X |
Entrenar | A | X | X |
Desentrenar | A | X | X |


Herramientas de identificación - Leer texto (OCRMax)

La herramienta de identificación Leer texto (OCRMax) permite, una vez entrenados y creados los tipos de letra definidos por el usuario, leer y/o verificar cadenas de texto dentro de una región.

La herramienta de identificación Leer texto (OCRMax) realiza un reconocimiento óptico de caracteres (OCR) basado en un proceso de segmentación y clasificación. Primero se ejecuta la segmentación, consistente en técnicas de umbral que permiten identificar las áreas de la imagen que parecen contener líneas de texto. Una vez dividido el texto en caracteres, éstos se entrenan y almacenan en una base de datos de tipos de letra. La clasificación se produce en tiempo de ejecución y consiste en "leer" cualquier texto detectado tras ejecutar la función de segmentación. El proceso consiste en comparar las imágenes de los caracteres segmentados con los caracteres entrenados en la base de datos de tipos de letra.

  1. Configuración de la herramienta de identificación Leer Texto (OCRMax)
  2. Ajuste de los parámetros de la herramienta de identificación Leer texto (OCRMax)
  3. Uso de las propiedades de entrada/salida de la herramienta de identificación Leer texto (OCRMax)


Configuración de la herramienta de identificación Leer Texto (OCRMax)

El funcionamiento de la herramienta de identificación Leer texto (OCRMax) consta de dos fases: tiempo de entrenamiento y tiempo de ejecución.

  • En tiempo de entrenamiento, se cargan múltiples imágenes con los caracteres a leer, los cuales se extraen de la imagen y se segmentan para generar una base de datos de tipos de letra entrenados a partir de dichos caracteres.
  • En tiempo de ejecución, el sistema de visión In-Sight pasa al estado en línea, adquiere las imágenes y extrae y clasifica los caracteres consultando la base de datos de tipos de letra entrenados.

Nota: Antes de empezar a configurar la herramienta, cargue las imágenes del entrenamiento. A la hora de entrenar una base de datos de tipos de letra, Cognex recomienda iniciar el proceso con las imágenes que contengan un mayor número de caracteres con el aspecto deseado (dicho de otro modo, utilizando primero las mejores imágenes), dejando para el final las imágenes de peor calidad.

Closed Entrenamiento de la herramienta de identificación Leer Texto (OCRMax)
  1. Cargue la primera imagen a entrenar.
  2. Añada la herramienta de identificación Leer texto (OCRMax) al trabajo.
  3. Una vez añadida la herramienta, deberá configurar la región en la imagen. Sitúe la región de la herramienta sobre la línea de texto a leer:
  • El eje X de la región debe ser paralelo a la línea base del texto, mientras que el eje Y debe ser paralelo a los trazos verticales de los caracteres; en ausencia de inclinación, el eje Y será perpendicular al eje X.
  • La dirección positiva del eje X corresponde a la dirección de lectura.
  • La región solo debe contener una línea de texto para leer y algo de fondo circundante. El fondo puede ser ruidoso y contener gradientes o sombreados significativos.
  • En imágenes con texto claramente impresas y con poco ruido, la región puede ser significativamente mayor que la línea de texto.
  • En imágenes ruidosas, la región debería estar relativamente ajustada a la línea de texto.
  • Como regla aproximada, a ser posible, la región debe superar en anchura por todos los lados a la línea de texto en al menos la mitad del ancho de caracteres (salvo que un borde fuese tan grande que abarcase otras características dentro de la región).
Notas:
  • La línea base del texto puede contener cualquier ángulo (0-360) en la imagen, siempre que la región esté aproximadamente orientada al mismo ángulo.
  • La región no debería contener ningún otro elemento significativo de la imagen, salvo la línea de texto. Por ejemplo, la región no debería contener parcialmente una línea diferente de texto cercano ni el borde de una etiqueta.
  • Si la región está curvada, la herramienta desenvolverá automáticamente la imagen en una región de salida enderezada con una etiqueta "Posición de la región curvada", que puede recolocarse en la imagen con fines de visualización.
  4. La herramienta creará automáticamente regiones de caracteres alrededor del "texto" que detecte como caracteres basándose en los ajustes predeterminados de la ficha Segmentación.

  5. Si la función no dibuja correctamente las regiones de los caracteres alrededor del texto, existen dos alternativas:
  • Utilice el diálogo Sintonización automática y deje que la herramienta de identificación Leer texto (OCRMax) calcule automáticamente los ajustes de segmentación óptimos. El diálogo Sintonización automática combina las fases de segmentación y entrenamiento en un único paso. Para segmentar y entrenar correctamente una base de datos de tipos de letra, siga las instrucciones del diálogo Sintonización automática.
  • Abra la ficha Segmentación y ajuste los parámetros hasta que el texto quede correctamente encerrado dentro de las regiones de caracteres individuales. Ejecute el proceso de segmentación para segmentar correctamente todos los caracteres de la base de datos de imágenes antes del entrenamiento.
Notas:
  • Para imágenes ruidosas en las que resulte difícil leer el texto, los parámetros de la ficha Avanzados pueden resultar útiles para compensar las condiciones difíciles.
  • Si hay espacios entre caracteres, abra la ficha Espacios y ajuste los parámetros para compensar dichos espacios.
Closed Entrenamiento manual de la herramienta de identificación Leer Texto (OCRMax) después de la segmentación

Una vez segmentado el texto, los caracteres están listos para ser entrenados y añadidos al tipo de letra. Primero, seleccione una base de datos de fuentes en la ficha Ajustes y seleccione una fuente en el parámetro Biblioteca de fuentes.

  • Si está creando una nueva fuente Personalizada, abra la ficha Entrenamiento, introduzca la cadena de texto exacta que desee entrenar y presione el botón Entrenar todos. Los caracteres se añadirán y almacenarán en la fuente personalizada seleccionada.

Para añadir caracteres adicionales a una fuente personalizada ya existente, adquiera o cargue otra imagen que contenga los caracteres a entrenar. Si fuese necesario, vuelva a configurar la región y los parámetros Segmentación para asegurarse de que los caracteres sean segmentados correctamente, y luego presione los botones Entrenar nuevos o Entrenar seleccionados en la ficha Entrenamiento.

Nota: Las fuentes personalizadas se pueden exportar o importar como archivos de datos OCRMax (*.ocm) desde la ficha Entrenamiento.

  • Si está utilizando una fuente predefinida OCRA o OCRB, simplemente sitúe la región de la herramienta sobre el texto a leer, y la herramienta segmentará automáticamente los caracteres contenidos en la región basándose en ajustes de los parámetros Segmentación y Avanzado.

Nota: Las fuentes predefinidas OCRA y OCRB no son editables.

Closed Funcionamiento en tiempo de ejecución

Cuando la herramienta disponga de una base de datos de tipos de letra entrenados, estará lista para pasar al tiempo de ejecución.

  1. Ajuste el Modo de inspección en tiempo de ejecución de la herramienta, que determina si la herramienta se limitará a leer texto dentro de su región o si debe leer y verificar si se ha leído la cadena correcta.
  2. En tiempo de ejecución, el sistema de visión In-Sight se pondrá en línea y adquirirá imágenes según se haya definido en la tarea. En el momento de adquirir una imagen, la cadena de texto de la imagen se segmenta automáticamente de acuerdo con los parámetros de segmentación y los caracteres se comparan con sus muestras entrenadas.


Ajuste de los parámetros de la herramienta de identificación Leer texto (OCRMax)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación Leer texto (OCRMax) consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Segmentación
  • Ficha Opciones avanzadas
  • Ficha Espacios
  • Ficha Longitud variable
  • Ficha Entrenamiento
  • Ficha Campos
  • Ficha Diagnósticos
  • Ficha Resultados

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Leer texto (OCRMax) - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección, que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Texto_1" (si se trata de la primera herramienta de identificación Leer texto (OCRMax) agregada a la tarea; de lo contrario, se incrementará, es decir, "Texto_2", "Texto_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de identificación Leer texto (OCRMax) - ficha Ajustes

Closed Biblioteca de fuentes

Define una referencia a la base de datos de fuentes para la herramienta. Seleccione entre cuatro fuentes predefinidas (OCRA o OCRB, blanco sobre negro o negro sobre blanco), o cree una base de datos de fuentes personalizada entrenando caracteres (por cada tarea se pueden crear hasta ocho bases de datos personalizadas).

Nota: Las cuatro fuentes OCRA y OCRB son de solo lectura y no se pueden volver a entrenar, eliminar ni cambiar de nombre.

  • Para seleccionar una de las fuentes predefinidas, basta con situar la región de la herramienta sobre el texto que se desea leer para que la herramienta segmente automáticamente los caracteres contenidos en la región.
  • Para seleccionar una fuente personalizada, siga los pasos descritos en el tema Configuración de la herramienta de identificación Leer Texto (OCRMax) cuando cree por primera vez la base de datos de fuentes personalizada. Al modificar una fuente personalizada ya existente, cualquier otra herramienta Leer texto (OCRMax) que esté utilizando la misma fuente personalizada también se verá afectada.
Closed Modo de inspección

Define el modo operativo de la herramienta: Leer (predeterminado) o Leer/Verificar.

  • Leer: La herramienta intentará leer los caracteres de la región basándose en las instancias entrenadas de esos caracteres.
  • Leer/Verificar: La herramienta intentará leer primero los caracteres de la región basándose en las instancias entrenadas de los mismos. A continuación, compruebe si los caracteres leídos corresponden a la cadena de texto especificada en el parámetro Cadena coincidente.
Closed Cadena coincidente

Define la cadena de texto que debe coincidir en el modo de inspección Leer/Verificar.

Closed Umbral de aceptación

Define la puntuación de coincidencia mínima aceptable (0 a 100, predeterminado = 80) de cada carácter. Cualquier carácter con una puntuación de coincidencia inferior al Umbral de aceptación generará un rechazo.

Closed Umbral de confusión

Define la diferencia mínima requerida entre las puntuaciones de coincidencia del carácter con la puntuación más alta y del carácter con la segunda puntuación más alta (0 a 40; predeterminado = 0).

Closed Utilizar submuestreo

Define si se debe activarse o no el submuestreo de imágenes, que reduce la resolución del carácter para aumentar la velocidad de lectura de la función.

Closed Tiempo_Espera

Define el tiempo, en milisegundos (0 a 30000, predeterminado = 5000), durante el que la herramienta buscará caracteres antes de detener la ejecución y comunicar un rechazo. Si este valor se ajusta a 0, el ajuste se desactivará y el tiempo de espera no se aplicará.

Closed Mostrar caracteres

Define si deben mostrarse o no los caracteres y sus regiones en los otros Pasos de la aplicación, o solo en los pasos Localizar pieza e Inspeccionar pieza (esta opción está activada de forma predeterminada).

Closed Posición de la etiqueta del carácter

Define dónde se posicionarán las etiquetas del carácter con respecto a la región de caracteres: Sobre el carácter (predeterminado), A la derecha del carácter, Debajo del carácter o A la izquierda del carácter.


Herramienta de identificación Leer texto (OCRMax) - ficha Segmentación

La ficha Segmentación permite establecer y modificar los ajustes de segmentación de los caracteres contenidos en la región. Los valores y ajustes predeterminados generalmente permiten leer la mayoría del texto. Sin embargo, en casos más difíciles puede ser necesario ajustar algunos parámetros. Estos casos suelen resolverse especificando una anchura de carácter mínimo, una anchura máxima y/o un paso entre caracteres mínimo (es decir, la distancia entre caracteres sucesivos, como por ejemplo desde el borde izquierdo de un carácter hasta el borde izquierdo del siguiente). En casos difíciles y para acelerar la creación de la base de datos de tipos de letra, utilice el botón Sintonización automática para abrir el diálogo Sintonización automática y permitir que la herramienta calcule automáticamente los ajustes de segmentación óptimos.

Closed Directrices de segmentación
  • Resulta difícil segmentar imágenes que contienen fondos con texturas intensas o con tanto ruido que los caracteres se mezclen con el fondo.
  • La región debería contener exclusivamente los caracteres a leer, sin ninguna característica ajena intensa (claramente identificable), como otros caracteres o bordes de etiquetas.
  • Siempre que dos caracteres se toquen, probablemente sea necesario ajustar los parámetros. Cuando entran en contacto caracteres de anchura fija, pueden compensarse especificando la anchura de dichos caracteres. Sin embargo, resulta más problemático si los caracteres que se tocan contienen fuentes proporcionales, ya que algunos podrían procesarse correctamente, pero no todos.
  • En los casos de líneas de texto cortas (por ejemplo, con tres caracteres o menos), o relativamente cortas pero con una gran cantidad de ruido, resulta conveniente especificar el Rango de ángulos para ayudar a que la función compense correctamente la incertidumbre inherente a la hora de determinar la orientación de una línea corta de texto.
  • Todos los caracteres de una línea de caracteres deben tener la misma orientación e inclinación.
  • Para impresiones de matriz de puntos bien diferenciadas (por ejemplo, cuyos puntos no se tocan), puede ser necesario ajustar parámetros como Tamaño mínimo de los fragmentos de caracteres para segmentar correctamente los caracteres.
  • La anchura de trazo de los caracteres debe ser de al menos dos píxeles.
  • El tamaño mínimo de los caracteres grandes (generalmente alfanuméricos) es de 8 x 8 píxeles. El tamaño mínimo de los caracteres pequeños (p. ej. de los puntos) es de 2 x 2 píxeles.
Closed Sintonización automática

Abre el diálogo Sintonización automática, que se utiliza con la herramienta de identificación Leer texto (OCRMax) para configurar los parámetros de segmentación de la herramienta y entrenar una base de datos de tipos de letra mediante la generación de registros de sintonización automática a fin de crear el modelo correspondiente. Cada registro de sintonización automática consta de una imagen, de la cadena de entrenamiento y de la ubicación (verificada por el usuario) de los caracteres contenidos en la imagen. El modelo de sintonización automática consta de al menos un registro y de los ajustes que mejor segmenten las imágenes contenidas en los registros de sintonización automática.

Notas:
  • A la hora de utilizar el cuadro de diálogo Sintonización automática, Cognex recomienda que la sintonización de la segmentación se lleve a cabo en un emulador In-Sight, en lugar de hacerlo en un sistema de visión In-Sight. El algoritmo de sintonización automática de la herramienta Leer texto (OCRMax) consume una gran cantidad de recursos computacionales. El rendimiento es mayor cuando se utiliza el emulador en lugar de un sistema de visión.
  • A la hora de entrenar una base de datos de tipos de letra y de utilizar el diálogo de sintonización automática para segmentar los caracteres, Cognex recomienda iniciar el proceso con las imágenes que contengan un mayor número de caracteres con el aspecto deseado (dicho de otro modo, utilizando primero las mejores imágenes), dejando para el final las imágenes más complicadas. De esta forma, el algoritmo de sintonización automática de la herramienta Leer texto (OCRMax) realizará mejor su cometido.
Closed Polaridad de caracteres

Define la polaridad de los caracteres de la imagen de entrada: Negro sobre blanco, Blanco sobre negro o Automático (predeterminado).

Nota: Para mejorar el rendimiento de la herramienta, defina la polaridad del texto.

  • Negro sobre blanco: La polaridad del texto equivale a texto negro sobre fondo blanco.
  • Blanco sobre negro: La polaridad del texto equivale a blanco sobre fondo negro.
  • Automática: La herramienta determina automáticamente la polaridad del texto y del fondo.
Closed Tipo anchura caracteres

Define la variación esperada de las anchuras de los caracteres en el tipo de letra: Automático (predeterminado), Fijo o Variable.

Nota: La anchura de caracteres equivale a la del rectángulo de un carácter, no de la región.

  • Automática: La anchura de los caracteres es desconocida. La fuente puede ser de anchura fija o proporcional.
  • Fija: Todos los rectángulos de caracteres de la fuente tienen la misma anchura.
  • Variable: Los caracteres con esta fuente pueden tener rectángulos de caracteres con diferentes anchuras.
Closed Anchura mínima de los caracteres

Define la anchura mínima, en píxeles (1 - 1000, predeterminado = 3), del rectángulo que un carácter debe tener para ser comunicado.

Closed Altura mínima de los caracteres

Define la altura mínima, en píxeles (1 - 1000, predeterminado = 3), del rectángulo que un carácter debe tener para ser comunicado.

Closed Usar la anchura máxima de los caracteres

Define si la herramienta debe tener en cuenta la anchura máxima permitida del rectángulo de un carácter (la opción predeterminada es que el parámetro esté desactivado).

Nota: Si se activa esta opción, los caracteres cuya anchura supere el valor especificado se dividirán en segmentos con anchuras parciales admisibles.

Closed Anchura máxima de los caracteres

Define la anchura máxima, en píxeles (1 - 5000, predeterminado = 100), del rectángulo que un carácter debe tener para ser comunicado.

Closed Usar la altura máxima de los caracteres

Define si la herramienta debe tener en cuenta la altura máxima permitida del rectángulo de un carácter (la opción predeterminada es que el parámetro esté desactivado).

Nota: Este valor se utiliza de dos maneras: en primer lugar, permite detectar la línea en bruto, por ejemplo, para rechazar el ruido adyacente vertical y/u otras líneas de caracteres verticales adyacentes. En segundo lugar, los caracteres individuales cuya altura supere este valor se ajustarán para cumplir este requisito de altura.

Closed Altura máxima de los caracteres

Define la altura máxima, en píxeles (1 - 5000, predeterminado = 100), del rectángulo que un carácter debe tener para ser comunicado.

Closed Usar la relación de aspecto mínima de los caracteres

Define si la función tendrá en cuenta la relación de aspecto mínima admisible de un carácter, donde la relación de aspecto está definida como la altura de la línea completa de caracteres dividida por la anchura del rectángulo del carácter (por defecto, este parámetro está habilitado).

Nota: Con esta opción activada, los caracteres cuya relación de aspecto sea menor que este valor (es decir, cuya anchura sea excesiva) se dividirán en segmentos parciales de tamaños admisibles.

Closed Relación de aspecto mínima de los caracteres

Define la relación de aspecto mínima permitida de un carácter (0 a 500, predeterminado = 80).

Closed Rango de ángulos

Define el rango de búsqueda ángel, en grados (0 a 45; predeterminado = 0).

Nota: Cualquier valor superior a 0 aumentará el tiempo de ejecución del proceso de segmentación.

Closed Rango inclinación

Define el rango de búsqueda de inclinación, en grados (0 a 45; predeterminado = 0).

Nota: Cualquier valor superior a 0 aumentará el tiempo de ejecución del proceso de segmentación.

Closed Mostrar diagnósticos

Define si deben mostrarse datos de diagnóstico gráficos en la imagen. Con esta opción activada, se generarán regiones en torno a los caracteres conservados (verde), los caracteres rechazados (rojo), los fragmentos conservados (cian), los fragmentos rechazados (amarillo), la línea principal del texto (azul) y la línea principal extendida del texto (magenta).


Herramienta de identificación Leer texto (OCRMax) - ficha Opciones avanzadas

Closed Modo de combinación de fragmentos de caracteres

Define cómo la herramienta debe combinar fragmentos de caracteres al formar éstos durante la segmentación: Requerir solapamiento (preajuste), Definir el espacio mínimo entre caracteres o Definir el espacio mínimo entre caracteres/máximo dentro de un carácter.

  • Requerir solapamiento: Para poder combinarlos, los fragmentos de caracteres deben solaparse horizontalmente en al menos un píxel.
  • Definir el espacio mínimo entre caracteres: Los fragmentos de caracteres separados entre sí horizontalmente se pueden combinar para formar caracteres. Se combinarán cualesquiera dos fragmentos cuya separación sea inferior al valor definido en el parámetro "Espacio mínimo entre caracteres".
  • Definir el espacio mínimo entre caracteres/máximo dentro de un carácter: Los fragmentos de caracteres separados entre sí horizontalmente se pueden combinar para formar caracteres. La decisión de fusionar dos fragmentos se basará ​en los valores definidos en los parámetros Espacio mínimo entre caracteres y Espacio máximo dentro de un carácter.
Closed Solapamiento mínimo entre fragmentos de caracteres

Define la fracción mínima (0 - 100; preajuste = 0) del solapamiento en la dirección X necesario entre dos fragmentos de un carácter para que dichos fragmentos sean considerados parte del mismo carácter.

Closed Espacio máximo dentro de un carácter

Define el tamaño máximo, en píxeles (0 - 1000; preajuste = 5), del espacio que puede haber dentro de un carácter, incluso aunque esté dañado.

Closed Espacio mínimo entre caracteres

Define la separación mínima, en píxeles (0 - 1000; preajuste = 0), que puede haber entre dos caracteres. La separación se mide desde el borde derecho del rectángulo de un carácter hasta el borde izquierdo del rectángulo del siguiente carácter. Si la separación entre dos fragmentos no alcanza este valor, los fragmentos deben considerarse como parte del mismo carácter, a menos que el carácter combinado resulte escesivamente ancho (según especifican los parámetros Anchura máxima de los caracteres y/o Relación de aspecto mínima de los caracteres).

Closed Tamaño mínimo de los fragmentos de caracteres

Define el número mínimo de los píxeles de primer plano (es decir, texto) (0 - 1000; preajuste = 15) que un fragmento debe tener para considerar su posible inclusión en un carácter. Un fragmento de carácter es un objeto binario grande ("blob") en la imagen binarizada.

Closed Tamaño mínimo de los caracteres

Define el número mínimo de los píxeles de primer plano (es decir, texto) (0 - 5000; preajuste = 30) que un carácter debe tener para que sea comunicado.

Closed Modo de normalización

Define el modo utilizado para normalizar la imagen: Ninguno, Global, Local o Local avanzado (preajuste).

Nota: Este ajuste debe ser idéntico tanto para el entrenamiento como para el tiempo de ejecución. Modificarlo después del entrenamiento puede causar problemas de clasificación.

  • Ninguno: No se ejecutará ninguna normalización.
  • Global: Se ejecuta una normalización global utilizando la información de toda la región, no las variaciones locales.
  • Local: Se ejecuta una normalización local, utilizando información sobre cada rectángulo de carácter local contenido en la región, para normalizar la imagen.
  • Local avanzada: Se ejecuta una normalización local, utilizando información sobre cada rectángulo de carácter local contenido en la región, para normalizar la imagen, incluyendo ajustes no solo para el fondo, sino también el contraste del primer plano.
Closed Usar filtro de anchura del trazo

Define si se deben eliminar o no de una imagen normalizada todos los elementos que no tengan la misma anchura de trazo que el resto de la imagen (por defecto, este ajuste está activado). Este ajuste resulta útil, por ejemplo, cuando los caracteres parecen estar interconectados por rayas finas de ruido. Sin embargo, con este ajuste también se pueden borrar caracteres reales indebidamente si las anchuras de trazos son irregulares.

Nota: Este ajuste debe ser idéntico tanto para el entrenamiento como para el tiempo de ejecución. Modificarlo después del entrenamiento puede causar problemas de clasificación.

Closed Ignorar fragmentos de bordes

Define si la función ignorará completamente los fragmentos que toquen cualquier borde de la región (por defecto, esta opción está desactivada). Ignorar esos fragmentos puede ser útil para objetos no textuales, como bordes de etiquetas, que puedan encontrarse dentro de la región.

Nota: Si un fragmento se extiende desde el borde del rectángulo de un carácter hasta la línea principal del texto, el fragmento será considerado como un carácter. Cuando este parámetro esté habilitado, el fragmento no deberá alcanzar la línea principal del texto que se desee excluir.

Closed Umbral de binarización

Define un modificador de porcentaje (0 - 100; preajuste = 50) en el rango utilizado para calcular en la imagen normalizada el umbral de binarización que binariza la imagen entre el primer plano y el fondo.

Closed Umbral de contraste de fragmento de caracteres

Define el contraste mínimo [en niveles de escala de grises de la imagen normalizada (0 - 255; preajuste = 30)] que un fragmento debe tener con respecto al umbral de binarización para que se considere su posible inclusión en un carácter.

Closed Distancia máxima del fragmento a la línea principal

Define la distancia, en píxeles (0 - 1000, preajuste = 0), que un fragmento puede desplazarse de la "línea principal" que atraviesa horizontalmente el texto.

Closed Modo de análisis de segmentación

Define el modo de análisis de caracteres a ejecutar para determinar la segmentación óptima de caracteres: Mínimo o Estándar (preajuste).

  • Mínimo: Ejecuta una segmentación simple, de acuerdo con los parámetros de Segmentación.
  • Estándar: Ejecuta un análisis de la línea en su conjunto, incluyendo el espaciado entre caracteres, para determinar la segmentación óptima.
Closed Paso mínimo

Define el paso mínimo, en píxeles (0 - 1000; preajuste = 0), que puede haber entre dos caracteres, calculado a partir del parámetro Espaciado de caracteres. Si el paso entre dos fragmentos es menor, éstos deben considerarse como parte del mismo carácter, a menos que el carácter combinado resulte escesivamente ancho (según especifican los parámetros Anchura máxima de los caracteres y/o Relación de aspecto mínima de los caracteres). Por "paso entre caracteres" se entiende la distancia entre puntos (aproximadamente) correspondientes de caracteres adyacentes, no como la distancia entre el final de un carácter y el comienzo del siguiente (denominada espaciado entre caracteres).

Closed Posición del paso entre caracteres

Define cómo se medirá el paso entre caracteres: Automático (preajuste) , izquierda a izquierda, centro a centro o derecha a derecha.

Notas:
  • Si el parámetro Modo de análisis de segmentación se ajusta a Mínimo, este parámetro se desactivará.
  • Los términos "izquierda" y "derecha" se refieren al eje de coordenadas definido por la región, es decir, "derecha" equivale a la dirección X positiva.
  • Automático: Especifica que se está utilizando una métrica desconocida. El paso entre caracteres adecuado puede ser cualquiera de las otras posiciones de paso. De lo contrario, no habrá una posición de paso constante (como puede ser el caso de una fuente proporcional).
  • Izquierda a izquierda: Especifica que el paso entre caracteres se mide como la distancia desde el lado izquierdo del rectángulo de un carácter hasta el lado izquierdo del rectángulo del carácter adyacente.
  • Centro a centro: Especifica que el paso entre caracteres se mide como la distancia desde el centro del rectángulo de un carácter hasta el centro del rectángulo del carácter adyacente.
  • Derecha a derecha: Especifica que el paso entre caracteres se mide como la distancia desde el lado derecho del rectángulo de un carácter hasta el lado derecho del rectángulo del carácter adyacente.
Closed Tipo de paso entre caracteres

Define la métrica utilizada para definir el espaciado entre caracteres. Automático (preajuste), Fijo, Proporcional o Variable.

Nota: Si el parámetro Modo de análisis de segmentación se ajusta a Mínimo, este parámetro se desactivará.

  • Automático: Especifica que el tipo de paso es desconocido, pero se espera que sea fijo o proporcional, no variable.
  • Fijo: Especifica que el paso es fijo, lo que significa que el paso entre cualquier par de caracteres es constante. Es decir, que es independiente de la anchura de los rectángulos de caracteres. El paso se mide con respecto al parámetro Posición del paso entre caracteres.
  • Proporcional: Especifica que el paso es proporcional, es decir, que el paso entre cualquier par de caracteres depende de esos caracteres en particular.

Notas:
  • Aunque ninguna medición del paso entre caracteres es constante a lo largo de una cadena, generalmente la separación entre caracteres, que es la distancia desde la parte derecha del rectángulo de un carácter hasta el lado izquierdo del rectángulo del carácter adyacente, es más o menos constante.
  • Los términos "izquierda" y "derecha" se refieren al eje de coordenadas definido por la región, es decir, "derecha" equivale a la dirección X positiva.
  • Variable: Especifica que ninguna métrica de distancia entre caracteres es constante a lo largo de una cadena, es decir, que la ubicación de caracteres es errática y que el paso entre caracteres no es fijo ni proporcional.

Nota: Un paso entre caracteres Variable es diferente de Auto, ya que Auto asume que el campo es fijo o proporcional, pero que no es conocido.

Closed Omitir validación adicional de caracteres

Define si la herramienta ejecutará una validación de caracteres adicional durante la clasificación (por defecto, este parámetro está desactivado). Si se desactiva, la herramienta ejecutará una validación de caracteres adicional durante la clasificación, reduciendo las probabilidades de errores de lectura (es decir, las falsas aceptaciones de caracteres).

Closed Gráfico de imagen de salida

Define el tipo de imagen de salida que debería mostrarse: Imagen de entrada (preajuste), Imagen normalizada o Imagen binarizada.

  • Imagen de entrada: Se mostrará la imagen de entrada activa.
  • Imagen normalizada: Se mostrará la versión normalizada de la imagen.
  • Imagen binarizada: Se mostrará la versión binarizada de la imagen.


Herramienta de identificación Leer texto (OCRMax) - ficha Espacios

La ficha Espacios permite especificar cómo la herramienta debe tratar los espacios entre caracteres, si procede. La herramienta de identificación Leer texto (OCRMax) procesa espacios entre caracteres, clasificándolos como caracteres espaciadores definidos por el usuario.

Closed Buscar espacios

Define cómo la herramienta gestionará la inserción de caracteres espaciadores en los espacios entre otros caracteres: Ninguno (preajuste), Insertar un solo espacio o Insertar varios espacios.

  • Ninguno: La herramienta nunca insertará un carácter de espacio, sea cual sea el tamaño del espacio entre caracteres.
  • Insertar un solo espacio: La herramienta insertará un espacio único carácter espaciador, sea cual sea el tamaño del espacio entre caracteres.
  • Insertar varios espacios: La herramienta insertará un número x (cero o más) de caracteres espaciadores por cada espacio entre caracteres.
Closed Modo de puntuación de espacios

Define cómo la función calculará las puntuaciones de los espacios: Puntuar siempre 100 (preajuste) o Puntuación basada en confusión.

  • Puntuar siempre 100: Los caracteres espaciadores siempre recibirán una puntuación de 100.
  • Puntuación basada en confusión: La puntuación de un carácter espaciador se basa en la fracción de píxeles que forman parte del fondo, un espacio que consista enteramente de píxeles de fondo recibirá una puntuación de 100.
Closed Ancho mínimo de espacio

Define el ancho mínimo de un carácter espaciador, en píxeles (0 - 1000; preajuste = 10).

Closed Ancho máximo de espacio

Define el ancho máximo de un carácter espaciador, en píxeles (0 - 1000; preajuste = 100).


Herramienta de identificación Leer texto (OCRMax) - ficha Longitud variable

La ficha Longitud variable proporciona información sobre los caracteres que se espera encontrar en diferentes posiciones de la cadena.

Nota: Estos parámetros solo se utilizan si los parámetros de la ficha Campos están activados y configurados.

Closed Longitud de cadena

Define si la detección de campos se ejecutará en el modo de longitud fija (predeterminado) o de longitud variable.

  • Variable: La herramienta funcionará en el modo de longitud variable.
  • Fija: La herramienta funcionará en el modo de longitud fija.
Closed Longitud máxima de cadena

Define la longitud de cadena máxima admisible (0 - 100, preajuste = 15).

Nota: Este parámetro permanece desactivado mientras el parámetro Longitud de cadena esté ajustado a Fija.

Closed Longitud mínima de cadena

Define la longitud de cadena mínima admisible (0 - 100, preajuste = 5).

Nota: Este parámetro permanece desactivado mientras el parámetro Longitud de cadena esté ajustado a Fija.

Closed Máximo último índice predefinido

Define las subsecuencias de detección de campos a considerar, que deben comenzar en una posición no mayor que este valor de índice (0 - 100, preajuste = 100).

Nota: Este parámetro permanece desactivado mientras el parámetro Longitud de cadena esté ajustado a Fija.

Closed Mínimo último índice predefinido

Define las subsecuencias de detección de campos a considerar, que deben finalizar en una posición no menor que este valor de índice (0 - 100, preajuste = 0).

Nota: Este parámetro permanece desactivado mientras el parámetro Longitud de cadena esté ajustado a Fija.


Herramienta de identificación Leer texto (OCRMax) - ficha Entrenamiento

La ficha Entrenamiento permite entrenar, ver, cambiar el nombre y eliminar caracteres. La ficha está dividida en dos grupos: Entrenamiento, donde se definen los parámetros de entrenamiento de caracteres, y Caracteres, donde se administran las fuentes entrenadas.

Notas:
  • La ficha Entrenamiento permite ajustar la región y actualizar los gráficos de segmentación (rectángulos de caracteres) según se va modificando la región.
  • No se admiten nombres de caracteres de alfabetos "multibyte" (por ejemplo, Kanji). Aunque se pueden entrenar caracteres multibyte, el nombre que se les asigne debe estar compuesto por caracteres de un solo byte.
Closed Controles de entrenamiento

Nota: Antes de poder entrenarlos, los caracteres deben estar correctamente segmentados.

  • Cadena de entrenamiento: La cadena de texto a entrenar. El número de caracteres contenidos en el cuadro de texto Cadena de entrenamiento debe coincidir con el número de caracteres segmentados. Se puede entrenar un máximo de 50 caracteres.
  • Entrenar todos: Indica que deben entrenarse todos los caracteres de la región. Los caracteres que se prevé entrenar se introducen en el cuadro de texto Cadena de entrenamiento antes de presionar el botón Entrenar todos. El número de caracteres contenidos en el cuadro de texto Cadena de entrenamiento debe coincidir con el número de caracteres segmentados.
  • Entrenar nuevos: Indica que solo deben entrenarse los caracteres nuevos de la región. Los caracteres que se prevé entrenar se introducen en el cuadro de texto Cadena de entrenamiento antes de presionar el botón Entrenar. El número de caracteres contenidos en el cuadro de texto Cadena de entrenamiento debe coincidir con el número de caracteres segmentados.
  • Entrenar seleccionados: Indica que deben entrenarse determinados caracteres de la región. Al activar esta opción se desactiva el cuadro de texto Cadena de entrenamiento y el botón Entrenar seleccionados abrirá el cuadro de diálogo Añadir los caracteres seleccionados a la fuente. Este cuadro de diálogo contiene una imagen "no envuelta" de la región, con una etiqueta y cuadros de introducción de texto bajo cada uno de los caracteres segmentados. La etiqueta es el símbolo actualmente asociado a ese carácter (un símbolo de interrogación "?" indica un carácter desconocido o no entrenado). Debajo de la etiqueta aparece un cuadro de texto. Introduzca una etiqueta por cada carácter segmentado en el cuadro de texto. Para no entrenar caracteres, deje el cuadro de texto vacío. Para cerrar el cuadro de diálogo, presione el botón Entrenar.
Closed Controles de caracteres

Después del entrenamiento, todos los caracteres entrenados se mostrarán en el árbol, donde se les asignará una carpeta y una etiqueta, y se agruparán (si los caracteres tienen etiquetas coincidentes).

  • Para mostrar todos los caracteres del tipo de letra en el panel de la derecha, seleccione la carpeta raíz "Fuente". Los caracteres se mostrarán como iconos con una etiqueta debajo.
  • Seleccione una carpeta de un carácter para mostrar todas las instancias entrenadas de ese carácter en el panel de la derecha. Los caracteres se mostrarán como iconos con una etiqueta debajo.
  • Para mostrar un carácter, seleccione una instancia entrenada del mismo, ampliada con zoom para rellenar el panel de la derecha.

Sugerencia: Si se proporcionan a la herramienta múltiples instancias entrenadas de cada carácter a leer durante la ejecución, la función distinguirá mejor los tipos de caracteres similares. Sin embargo, entrenar varias instancias de un mismo carácter tiene ventajas y desventajas. La ventaja de entrenar múltiples instancias consiste en que cabe esperar un mejor rendimiento de clasificación, sobre todo al leer textos fácilmente confundibles (por ejemplo, 8 y B). Las desventajas de entrenar varias instancias son: aumento del tiempo de ejecución de la función, posible disminución de las puntuaciones de fiabilidad, ya que con múltiples instancias de entrenamiento no solo mejorará la puntuación más alta, sino también la segunda más alta, lo que podría entrenar caracteres incorrectos.

  • Importar: Abre el cuadro de diálogo Abrir, que permite importar una fuente guardada como archivo de datos OCRMax (*.ocm).
  • Exportar: Abre el cuadro de diálogo Guardar como, que permite guardar un archivo de datos OCRMax (*.ocm).
  • Cambiar nombre: Elija esta opción después de seleccionar un elemento para cambiar su nombre. Se puede cambiar el nombre de cualquier elemento contenido en el árbol o en el panel de lista del lado derecho.

Nota: Si cambia el nombre de un grupo de caracteres, se asignará una nueva etiqueta a todos los caracteres del grupo. Si cambia el nombre de un solo carácter, se asignará una nueva etiqueta a dicho carácter único seleccionado; el carácter se transferirá a otro grupo del árbol, o a uno nuevo.

  • Eliminar: Elija esta opción después de seleccionar un elemento para quitarlo de la fuente. Se puede cambiar el nombre de cualquier elemento contenido en el árbol o en el panel de lista del lado derecho.

Nota: Si elimina la carpeta Fuente, también se eliminará la fuente; todos los caracteres se eliminarán. Si se elimina un grupo de caracteres, también se eliminarán todos los caracteres cuya etiqueta coincida con la etiqueta del grupo eliminado.


Herramienta de identificación Leer texto (OCRMax) - ficha Campos

La ficha Campos permite crear y editar gráficamente los parámetros Cadena del campo y Definiciones de campos de la herramienta de identificación Leer texto (OCRMax). Los valores resultantes se insertan en la herramienta como cadenas literales.

La detección de campos permite verificar y corregir cadenas, devolviendo el conjunto de cadenas con las mejores coincidencias. La detección de campos tiene dos usos principales:

  • Verificación de los resultados del reconocimiento óptico de caracteres (OCR), consistente en determinar si la cadena devuelta es correcta o no se ajusta a los parámetros Cadena del campo y Definiciones de campos.
  • Corrección de los resultados del OCR, consistente en determinar si la cadena devuelta no se encuentra en la lista de resultados aceptables para intentar encontrar una cadena aceptable para el campo que esté más próximo a la cadena devuelta.

Un uso típico de la detección de campos es cuando la cadena contiene caracteres de prefijo y/o de sufijo. En este caso, la detección de campos permite ignorar esos caracteres de prefijo/sufijo. En este caso, Cadena del campo y Definiciones de campos determinan el desplazamiento de la posición de la cadena dentro de la región.

Closed Cadena de caracteres predefinidos

Especifica el número de caracteres contenidos en la cadena de caracteres. La Cadena de campo puede contener cualquier carácter alfanumérico detectado en el cuadro de diálogo de introducción de texto, es decir, (A - Z), (a - z), (0 - 9), guiones (-), puntos (.) y espacios ( ).

Cada carácter de Cadena del campo corresponde a una posición en el campo indexado entre 0 y 31. Cadena del campo debe contener al menos tantas posiciones como caracteres necesita la cadena para que su lectura sea aprobada (es decir, si hay 10 caracteres pero Cadena del campo solo especifica 9 caracteres, se devolverán los 9 que mejor coincidan. Sin embargo, si hay 8 caracteres y Cadena del campo define 9 caracteres, la función devolverá un n.º de error "#ERR"). De forma predeterminada, cada posición de la Cadena del campo se representa con un carácter de asterisco (*), llamado "comodín" alfanumérico. Esto significa que cualquier carácter es válido en cualquier posición de la cadena.

Sin embargo, cualquier posición de la Cadena del campo se puede limitar a un subconjunto de caracteres. Esto aumenta el rendimiento y la fiabilidad generales, ya que durante las lecturas no se considerarán los caracteres que no puedan aparecer en una posición determinada.

La entradas predefinidas de Cadena del campo son:

Cadena del campo Entrada | Descripción | Caracteres válidos
* | Comodín | Cualquier carácter entrenado en la fuente.
N | Numérico | 0123456789
A | Alfabético en mayúscula | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | Alfabético en minúscula | abcdefghijklmnopqrstuvwxyz
H | Hexadecimal, alfabético en mayúscula y numérico | 0123456789ABCDEF
h | Hexadecimal, alfabético en minúscula y numérico | 0123456789abcdef
O | Octal | 01234567

Notas:

  • Para restringir una posición de una Cadena del campo a un único carácter, introduzca éste. El carácter debe haber sido entrenado en la fuente y no puede ser una de las entradas predefinidas de Cadena del campo indicadas anteriormente, salvo que se haya reasignado mediante el parámetro Definiciones de campos.
  • Para leer una cadena que contiene un espacio, incluya el espacio en Cadena del campo. ReadText no leerá un espacio si en esa posición la correspondiente entrada Cadena del campo es un asterisco (*).
Closed Ejemplo 1 de cadena de un campo

Si Cadena del campo es **********AN, cualquier carácter de la fuente será válido en las primeras 10 posiciones de Cadena del campo. Sin embargo, en la 11ª posición solo se considerarán caracteres alfabéticos en mayúsculas durante la lectura. En la 12ª posición solo se considerarán caracteres numéricos.

Closed Ejemplo 2 de cadena de un campo

La fuente solo contiene los caracteres numéricos 0-9 y /. Si Cadena del campo es NN/NN/NN, solo se considerarán caracteres numéricos en las posiciones primera y segunda, cuarta y quinta, séptima y octava. La barra inclinada (/) solo se considerará en las posiciones tercera y sexta.

Sin embargo, si Cadena del campo es NN/NN/AA, la lectura devolvería un número de error, ya que la fuente no contiene caracteres alfabéticos.

Closed Ignorar caracteres no predefinidos

Define si en cada posición de carácter deben limitarse los resultados para que solo figuren los caracteres especificados por la detección de campos del carácter. Si se activa esta opción, todos los demás caracteres de la fuente se ignorarán, independientemente de su puntuación de clasificación.

Closed Definición de campo

Opcionalmente, los ajustes Definiciones de campos permiten crear entradas definidas por el usuario para la Cadena del campo. Si se incluyen en Cadena del campo, estas entradas restringen la lista de caracteres válidos en las posiciones en las que se insertan. Existen varias definiciones de campos predefinidas, y se puede añadir otras definidas por el usuario. Las definiciones predefinidas se muestran en texto gris y no se pueden borrar ni editar, solo activar o desactivar. Las definiciones definidas por el usuario se muestran en texto negro y se pueden añadir, borrar o editar. Para añadir una definición de campo, presione el botón Añadir nuevo, y luego asigne un icono y una definición al carácter.

Los caracteres mostrados en la entrada Definiciones de campos deben estar contenidos en la fuente. Por ejemplo: #=123 es válida si 1, 2 y 3 están incluidas en la fuente entrenada por el usuario. Sin embargo, #=123 sería inválida si 1, 2 y 3 no están incluidos en la fuente.

Nota: Si se utiliza una de las entradas predefinidas (*, A, a, N, H, h, O) en el parámetro Definiciones de campos, se reasignará la lista de caracteres válidos en la nueva definición.

Closed Ejemplo 1 de definiciones de campos

Si el valor de Definiciones de campos es #=123;$=3456;%=789, y Cadena del campo es #$%*******, los únicos caracteres que serán válidos en la primera posición serán 1, 2 o 3. Los únicos caracteres válidos en la segunda posición serán 3, 4, 5 o 6. En la tercera posición, solo 7, 8 y 9 serán válidos. En las posiciones cuarta a décima se admite cualquier carácter de la fuente.

Closed Ejemplo 2 de definiciones de campos

Si el valor de Definiciones de campos es #=123;$=3456;%=789, A=A y Cadena del campo es #$%******A, los únicos caracteres que serán válidos en la primera posición serán 1, 2 o 3. Los únicos caracteres válidos en la segunda posición serán 3, 4, 5 o 6. En la tercera posición, solo 7, 8 y 9 serán válidos. En las posiciones cuarta a novena se admite cualquier carácter de la fuente. En la décima posición solo se admitirá el carácter A, ya que Definición del campo A=A reasigna la entrada Cadena del campo predefinida.


Herramienta de identificación Leer texto (OCRMax) - ficha Diagnósticos

La ficha Diagnósticos muestra información sobre cómo la herramienta Leer texto (OCRMax) segmenta los caracteres contenidos en la región. Estos datos pueden resultar útiles para determinar qué parámetros y en qué medida deben ajustarse cuando los caracteres y/o fragmentos de caracteres no se estén segmentando correctamente. Utilice esta ficha junto con el parámetro Mostrar diagnósticos para una representación gráfica de los datos de diagnóstico.

Closed Ángulo de la línea principal

Muestra el resultado de la orientación angular de las regiones de caracteres en relación con la región, en grados.

Closed Inclinación de caracteres

Muestra el resultado de la inclinación angular de las regiones de caracteres en relación con la región, en grados.

Closed Espacio entre caracteres

Muestra los valores mínimo y máximo de los espacios medidos entre caracteres, en píxeles.

Closed Espacio dentro de caracteres

Muestra los valores mínimo y máximo del espacio interior de caracteres, en píxeles.

Closed Espaciado de caracteres

Muestra los valores mínimo y máximo medidos de la inclinación de los caracteres, en píxeles.

Closed Tamaño del fragmento aceptado

Muestra los tamaños mínimo y máximo medidos en los fragmentos aceptados, en píxeles.

Closed Contraste del fragmento aceptado

Muestra los contrastes mínimo y máximo medidos en los fragmentos aceptados, en porcentajes.

Closed Distancia del fragmento aceptado a la línea principal (%)

Muestra la distancia Y máxima de todos los fragmentos aceptados, como porcentaje de la altura de la línea principal.

Closed Tamaño del fragmento rechazado

Muestra los tamaños mínimo y máximo medidos en los fragmentos rechazados, en píxeles.

Closed Contraste del fragmento rechazado

Muestra los contrastes mínimo y máximo medidos en los fragmentos rechazados, en porcentajes.

Closed Distancia del fragmento rechazado a la línea principal (%)

Muestra la distancia Y máxima de todos los fragmentos rechazados, como porcentaje de la altura de la línea principal.

Closed Anchura del carácter aceptado

Muestra los tamaños mínimo y máximo de anchura medidos en los caracteres aceptados, en píxeles.

Closed Altura del carácter aceptado

Muestra los tamaños mínimo y máximo de altura medidos en los caracteres aceptados, en píxeles.

Closed Tamaño del carácter aceptado

Muestra los tamaños mínimo y máximo medidos en los caracteres aceptados, en píxeles.

Closed Anchura del carácter rechazado

Muestra los tamaños mínimo y máximo de anchura medidos en los caracteres rechazados, en píxeles.

Nota: Si no hay caracteres rechazados, aparecerá #ERR.

Closed Altura del carácter rechazado

Muestra los tamaños mínimo y máximo de altura medidos en los caracteres rechazados, en píxeles.

Nota: Si no hay caracteres rechazados, aparecerá #ERR.

Closed Tamaño del carácter rechazado

Muestra los tamaños mínimo y máximo medidos en los caracteres rechazados, en píxeles.

Nota: Si no hay caracteres rechazados, aparecerá #ERR.


Herramienta de identificación Leer texto (OCRMax) - ficha Resultados

Closed Car.

Muestra el carácter leído en esa posición.

Closed Estado

Muestra el estado (Lectura errónea, Lectura correcta, Omitido, Confuso, No coincidencia, No coincidencia confusa, No leído o Error de validación) del carácter leído.

  • Lectura errónea: Ningún carácter se ha puntuado lo suficientemente por encima del Umbral de aceptación para considerarse una lectura correcta.
  • Lectura correcta: La herramienta ha leído correctamente el carácter en esa posición.
  • Omitido: Si está habilitada la alineación y se especifica una cadena de campo que es más corta que la cadena leída por la función, los caracteres del principio o final de la cadena se segmentarán (en amarillo) pero no se incluirán en el resultado General. Por ejemplo, si la definición de alineación es ABC y la cadena leída por la función es "12ABC34", se omitirá "1234".
  • Confuso: La herramienta ha identificado un carácter cuya puntuación es suficientemente alta para resultar en una lectura correcta (superior al valor del parámetro Umbral de aceptación); sin embargo, un carácter diferente ha conseguido una puntuación muy parecida (dentro del valor del parámetro Umbral de confusión), de modo que la herramienta no confía en haber elegido el carácter correcto [Confuso = (Puntuación primaria - Puntuación secundaria)/Umbral de confusión].
  • No coincidencia: La herramienta ha encontrado un carácter que no coincide con la alineación, cuya puntuación es mucho mayor que la de cualquiera de los caracteres que no coinciden con la alineación. Es probable que el carácter que no coincide con la alineación se imprimiera en esta posición. Para que se devuelva este estado, debe haberse habilitado el parámetro Alineación.
  • No coincidencia confusa: La función ha encontrado un carácter que cumple los dos requisitos, Confuso y No coincidencia.
  • Error de validación: Si está desactivado el parámetro Omitir validación de caracteres adicionales, la función analizará los caracteres por medio de un paso de validación adicional para garantizar que la función no genere lecturas erróneas.
Closed Puntuación

Muestra una puntuación que mide el grado de coincidencia del carácter leído con el carácter entrenado en la base de datos de tipos de letra.

Closed Confusión

Muestra el siguiente carácter que mejor coincide.

Closed Puntuación de confusión

Muestra una medida acerca de la certeza que tiene la función en cuanto a la coincidencia elegida en comparación con la siguiente mejor coincidencia.


Uso de las propiedades de entrada/salida de la herramienta de identificación Leer texto (OCRMax)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | FP | X | X | Entrada/Salida
Rango_Angulos | FP | X | X | Entrada/Salida
Umbral_Binarizacion | I | X | X | Entrada/Salida
Umbral_Contraste_Fragmento_Caracter | FP | X | X | Entrada/Salida
Modo_Combinacion_Fragmento_Caracter | I | X | X | Entrada/Salida
Posicion_Etiqueta_Caracter | I | X | X | Entrada/Salida
Posicion_Espaciado_Caracteres | I | X | X | Entrada/Salida
Tipo_Espaciado_Caracteres | I | X | X | Entrada/Salida
Polaridad_Caracteres | I | X | X | Entrada/Salida
Tipo_Anchura_Caracteres | I | X | X | Entrada/Salida
Borrar_Fuente | A | X | X |
Umbral_Confusion | FP | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Borrado_Externo | I | X | X | Entrada/Salida
Entrenamiento_Externo | I | X | X | Entrada/Salida
Rechazo | I | X | X | Salida
Recuento_Rechazos | I | X | X | Salida
Definiciones_Campos | S | X | X | Entrada/Salida
Cadena_Campo | S | X | X | Entrada/Salida
Buscar_Espacios | I | X | X | Entrada/Salida
Biblioteca_Fuentes | I | X | X | Entrada/Salida
Ignorar_Fragmentos_Bordes | I | X | X | Entrada/Salida
Ignorar_Caracteres_Sin_Campos | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Modo_Inspeccion | I | X | X | Entrada/Salida
Cadena_Coincidente | S | X | X | Entrada/Salida
Max_Espacio_Entre_Caracteres | I | X | X | Entrada/Salida
Maxima_Altura_Caracteres | I | X | X | Entrada/Salida
Maxima_Anchura_Caracteres | I | X | X | Entrada/Salida
Maxima_Distancia_Fragmento_A_Linea_Principal | FP | X | X | Entrada/Salida
Maximo_Ultimo_Indice_Con_Campo | I | X | X | Entrada/Salida
Maxima_Longitud_Cadena | I | X | X | Entrada/Salida
Min_Espacio_Entre_Caracteres | I | X | X | Entrada/Salida
Minima_Relacion_Aspecto_Caracteres | I | X | X | Entrada/Salida
Minimo_Solapamiento_Fragmentos_Caracteres | FP | X | X | Entrada/Salida
Minima_Altura_Caracteres | I | X | X | Entrada/Salida
Minimo_Tamano_Caracteres | I | X | X | Entrada/Salida
Minima_Anchura_Caracteres | I | X | X | Entrada/Salida
Minimo_Primer_Indice_Con_Campo | I | X | X | Entrada/Salida
Minimo_Espaciado | I | X | X | Entrada/Salida
Minima_Longitud_Cadena | I | X | X | Entrada/Salida
Modo_Normalizacion | I | X | X | Entrada/Salida
OCRMax | S | X | X | Salida
Salida_Imagen_Grafica | I | X | X | Entrada/Salida
Aceptacion | I | X | X | Salida
Recuento_Aceptaciones | I | X | X | Salida
Region | A | X | X |
Longitud_Resultado | I | X | X | Salida
Modo_Analisis_Segmentacion | I | X | X | Entrada/Salida
Rango_Distorsion | FP | X | X | Entrada/Salida
Maxima_Anchura_Espacio | I | X | X | Entrada/Salida
Minima_Anchura_Espacio | I | X | X | Entrada/Salida
Modo_Puntuacion_Espacio | I | X | X | Entrada/Salida
Estado | I | X | X | Salida
Cadena | S | X | X | Salida
Longitud_Cadena | I | X | X | Entrada/Salida
Tiempo de espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Entrenar | A | X | X |
Dialogo_Entrenamiento | S |  | X | Salida
Modo_Entrenamiento | I | X | X | Entrada/Salida
Entrenamiento_Cadena | S | X | X | Entrada/Salida
Usar_Maxima_Altura_Caracteres | I | X | X | Entrada/Salida
Usar_Maxima_Anchura_Caracteres | I | X | X | Entrada/Salida
Usar_Minima_Relacion_Aspecto_Caracteres | I | X | X | Entrada/Salida
Usar_Filtro_Anchura_Trazo | I | X | X | Entrada/Salida
Usar_Submuestreo | I | X | X | Entrada/Salida

Nota: Cuando acceda a la propiedad Dialogo_Entrenamiento en la aplicación VisionView®, aparecerá como un botón, incluso aunque el tipo de datos aparezca como "String" (cadena de texto).


Herramientas de identificación - Leer texto

La herramienta de identificación Leer texto se utiliza para leer y/o verificar cadenas de texto alfanumérico mediante modelos de caracteres entrenados.

Nota: A partir de In-Sight Explorer 4.7.0 y versiones posteriores, la herramienta de identificación Leer texto solo está disponible en sistemas de visión In-Sight que no admitan OCRMax y no está disponible en sistemas de visión In-Sight con la versión 5.1.0 y posteriores del firmware de In-Sight.

  1. Configuración de la herramienta de identificación Leer Texto
    1. Selección del texto a leer
  2. Ajuste de los parámetros de la herramienta de identificación Leer texto
  3. Uso de las propiedades de entrada/salida de la herramienta de identificación Leer texto


Configuración de la herramienta de identificación Leer Texto

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo en la imagen:

  1. Sitúe la región sobre el texto y asegúrese de que los límites de la región cubran el texto (consulte el tema Selección del texto a leer para más información). Para acelerar el funcionamiento de la herramienta, intente crear regiones más pequeñas; cuanto mayor sea la región, más tiempo necesitará la herramienta para realizar su inspección.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez aceptada la región, deberá definir el modo de operación (Leer, Verificar o Leer y verificar) elegir el tipo de letra (OCR-A Negro sobre blanco, OCR-A Blanco sobre negro, OCR-B Negro sobre blanco, OCR-B Blanco sobre negro o Personalizado) y especificar el número de caracteres del parámetro Cadena de campo o Hacer coincidir cadena en la ficha Ajustes, dependiendo del modo.
  • Si seleccionó Leer como modo de operación y un tipo de letra OCR-A u OCR-B, especifique el número de caracteres del parámetro Cadena de campo y presione el botón Sintonizar para establecer la escala apropiada.
  • Si seleccionó Verificar o Leer y verificar como modo de operación y un tipo de letra OCR-A u OCR-B, especifique el número de caracteres del parámetro Hacer coincidir cadena y presione el botón Sintonizar para establecer la escala apropiada.

Nota: Si utiliza cualquier fuente OCR-A u OCR-B, los caracteres en la imagen deben tener una altura de 15 a 60 píxeles. Presione el botón Sintonizar para escalar correctamente sus caracteres. Si el tamaño de sus caracteres es inferior a 15 píxeles o superior a 60, deberá crear una fuente personalizada.

  • Si seleccionó Personalizado como tipo de Fuente, primero presione el botón Entrenar fuente y cree una biblioteca de tipos de letras. Una vez creada su biblioteca de tipos de letra, seleccione el modo de operación y especifique el número de caracteres en el parámetro Cadena de campo (para el modo Leer), o bien introduzca el número de caracteres del parámetro Hacer coincidir cadena (para el modo Verificar o Leer y verificar).
  • Se pueden utilizar hasta cuatro tipos de letra personalizados (por ejemplo, “Personalizado_1,” “Personalizado_2,” “Personalizado_3” y “Personalizado_4”) dentro de una misma tarea. Un tipo de letra entrenado se puede compartir entre herramientas de identificación Leer texto si se añade a la tarea más de un tipo de letra personalizado.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Creación de un tipo de letra personalizado

  1. Para definir un tipo de letra personalizado, haga clic en la ficha Ajustes y presione el botón Entrenar fuente. Se abrirá el cuadro de diálogo Entrenar fuente, donde podrá configurar el texto de su aplicación.

Nota: Puede utilizar hasta cuatro tipos de letra personalizados (por ejemplo, “Personalizado_1,” “Personalizado_2,” “Personalizado_3” y “Personalizado_4”) en una misma tarea.

  2. En la ficha Entrenamiento, introduzca un nombre personalizado de su fuente, si procede (esto es especialmente útil si tiene más de una biblioteca de fuentes).
  3. Ajuste la Polaridad de sus caracteres: si los caracteres a entrenar son más claros que el fondo circundante, seleccione en Claro sobre oscuro. En caso contrario, elija Oscuro sobre claro.

Nota: Asegúrese de ajustar la Polaridad de caracteres correcta antes de hacer clic en Agregar a fuente; Polaridad no se puede modificar después de haber agregado modelos de caracteres a la fuente.

  4. Introduzca la cadena de texto prevista. Asegúrese de que las mayúsculas y minúsculas de la cadena de texto prevista coincida con la de los caracteres modelo y añada espacios a la cadena prevista si el modelo contiene espacios.
  5. Cuando haya introducido su cadena de texto, haga clic en el botón Segmento. Asegúrese de que cada carácter tenga una región y un identificador individuales; si no fuese así, utilice Graduaciones de segmento para realizar lo siguiente:
  • Presione el botón Modificar para ajustar la región circundante a una instancia determinada del carácter.
  • Presione el botón Cambiar etiqueta para asignar un nuevo nombre a una instancia del carácter.
  • Presione el botón Eliminar para eliminar una instancia del carácter.
  6. Cuando esté satisfecho con la identificación de sus caracteres, haga clic en el botón Agregar fuente. Ahora su fuente contendrá instancias por cada carácter identificado en su Cadena prevista.
  7. Ahora su fuente contendrá varios modelos de caracteres, que pueden contener múltiples instancias. Todos los caracteres, incluyendo espacios y signos de puntuación, son segmentados y se les asignan modelos de caracteres.
  8. Ahora puede examinar sus modelos de caracteres y agregar, eliminar, editar, cambiar el nombre o habilitar/desactivar cualquier modelo de carácter o instancia del carácter en particular.

Nota: Si se añade más de un tipo de letra personalizado a una tarea, un tipo de letra entrenado se puede compartir entre herramientas de identificación Leer texto.

  9. Cuando esté satisfecho con su fuente entrenada, presione el botón Aceptar.


Selección del texto a leer

Siguiendo estas directrices y consideraciones, podrá alcanzar resultados coherentes:

Closed Fuentes
  • Utilice fuentes especiales diseñadas para aplicaciones OCR/OCV.
  • Asegúrese de que los caracteres tengan una anchura mínima de 5 píxeles por trazo. El objetivo es que los caracteres ocupen tanto de la imagen como sea posible. Cuantos más píxeles por carácter, mayor la exactitud de la herramienta, aunque su ejecución también será más lenta.
  • Si su imagen contiene múltiples tipos de fuentes, utilice una herramienta de identificación Leer texto por cada tipo de fuente.
  • Si su imagen contiene múltiples tamaños de fuentes, utilice una herramienta de identificación Leer texto por cada tamaño.
Closed Fuentes OCR/OCV especializadas

Closed Modelos e instancias de caracteres
  • Utilice caracteres de alta resolución para crear Modelos de caracteres claros y diferenciados.
  • Una sola herramienta de identificación Leer texto admite hasta 255 modelos de caracteres, y cada modelo de carácter se basa en hasta 8 instancias entrenadas de ese modelo de carácter. Si entrena instancias adicionales de un modelo de carácter, aumentará la tolerancia de la herramienta a variaciones del modelo de carácter. Si su aplicación no tolera mucha variación, entrene sus modelos de carácter utilizando exclusivamente un ejemplo único y fiable. Si su aplicación debe tolerar variaciones, entrene el modelo de carácter contra tantas instancias como sea posible.
  • Cuando entrene instancias de un modelo de carácter, asegúrese de que la impresión de los caracteres sea tan uniforme y constante como sea posible, ya que cambios dramáticos en la forma y el tamaño de un carácter producen modelos de carácter pobres y susceptibles de fallos en tiempo de ejecución.
Closed Ejemplos de entrenamiento de instancias

Instancias de entrenamiento correctas de un modelo de carácter.

Instancias de entrenamiento incorrectas de un modelo de carácter.


Ajuste de los parámetros de la herramienta de identificación Leer texto

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación Leer texto consta de cuatro fichas:

  • Ficha General
  • Ficha Ajustes
  • Tabla Modelo de carácter

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Leer texto - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección, que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Texto_1" (si se trata de la primera herramienta de identificación Leer texto agregada a la tarea; de lo contrario, se incrementará, es decir, "Texto_2", "Texto_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de identificación Leer texto - ficha Ajustes

Closed Botón Entrenar fuente

Abre el cuadro de diálogo Entrenar fuente, que permite definir y editar fuentes (Modelos de caracteres y sus instancias).

Closed Modo

Define el modo operativo de la herramienta: Leer, Verificar o Leer y verificar.

  • Leer: La herramienta descodifica la cadena de texto basándose en los Modelos de carácter entrenados. La cadena de texto descodificada debe coincidir con el número de caracteres definido en el parámetro Cadena de campo.
  • Verificar: La herramienta descodifica la cadena de texto basándose en la cadena de texto definida en el parámetro Hacer coincidir cadena.
  • Leer y verificar: La herramienta descodifica la cadena de texto y la compara con la cadena definida en el parámetro Hacer coincidir cadena. Para que sea clasificada como Aceptación, la cadena de texto descifrada debe coincidir con la cadena definida en el parámetro Hacer coincidir cadena.

Nota: La herramienta tiene dos estados: aceptación o rechazo. Cuando el control Modo de la herramienta está definido como Verificar o como Leer y verificar, la herramienta devuelve un rechazo en dos situaciones diferentes: cuando la lectura falla o cuando la lectura es correcta pero la información descodificada no coincide con la cadena de texto introducida en el parámetro Cadena coincidente.

En este último caso, si está seleccionado el modo Leer y verificar, la herramienta devuelve los datos no coincidentes (Diferencia y Recuento de diferencias), que pueden utilizarse en EasyView y en otros dispositivos de comunicación en el paso de aplicación Comunicación. Los datos no coincidentes se pueden seleccionar en cualquiera de los diálogos Seleccionar elementos de EasyView, Seleccionar etiquetas OPC o Seleccionar datos de entrada/salida.

Los datos no coincidentes permiten al usuario determinar si la herramienta no puede leer el texto, o si éste puede leerse pero no coincide con la Cadena coincidente definida. Por ejemplo, si la herramienta no puede leer el texto, puede deberse a un problema en el proceso de impresión de texto o en la configuración del sistema de visión. Si el texto se lee correctamente pero no coincide con la Cadena coincidente definida, podría imprimirse el texto incorrecto.

Closed Fuente

Define el tipo de fuente. Puede seleccionar un tipo de fuente predefinido (OCR-A u OCR-B, blanco-sobre-negro o negro-sobre-blanco), o crear una fuente Personalizada entrenando Modelos de carácter.

Nota: Puede utilizar hasta cuatro tipos de letra personalizados (por ejemplo, “Personalizado_1,” “Personalizado_2,” “Personalizado_3” y “Personalizado_4”) en una misma tarea.

Closed Cadena de campo

Define el número de caracteres contenidos en la cadena de texto para una operación Leer. Cada carácter en Cadena de campo corresponde a una posición indexada entre 0 y 31 (el número máximo de caracteres). El número de posiciones en una cadena de campo debe ser igual al número de caracteres en la cadena de texto.

Una entrada "Cadena de campo" puede contener texto en mayúsculas o minúsculas, números, guiones, puntos y espacios . De forma predeterminada, cada posición en la cadena de campo se representa como "*" ("comodín" alfanumérico), que indica que en ese lugar de la cadena de texto puede aparecer cualquier carácter.

Pueden definirse posiciones individuales en la cadena de campo para que la herramienta sólo considere un subconjunto de caracteres posibles en dicha posición, aumentando el rendimiento total y la confiabilidad de la herramienta.

Entrada en Cadena de campo | Descripción | Caracteres válidos
* | Comodín | Cualquier carácter entrenado en la fuente.
N | Numérico | 0123456789
A | Alfabético en mayúscula | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | Alfabético en minúscula | abcdefghijklmnopqrstuvwxyz
H | Hexadecimal, alfabético en mayúscula y numérico | 0123456789ABCDEF
h | Hexadecimal, alfabético en minúscula y numérico | 0123456789abcdef
O | Octal | 01234567
Closed Cadena coincidente

Define la cadena prevista para leer (habilitado sólo cuando el parámetro Modo está ajustado a Verificar o a Leer y verificar). Introduzca la información que espere que la herramienta descodifique.

Nota: La cadena coincidente se puede introducir desde otro dispositivo. Al ejecutar la tarea, la herramienta de identificación puede leer la cadena de texto desde el dispositivo de entrada y compararla con el texto reconocido. La herramienta Leer texto generará un rechazo y el campo Hacer coincidir cadena mostrará TRIG hasta que se introduzca la cadena de coincidencia desde el dispositivo externo.

Closed Botón Sintonizar

Calcula la diferencia de escala (50% a 200%) entre los modelos de carácter entrenados de la biblioteca de fuentes con respecto los caracteres de la imagen. El botón Sintonizar sólo debe utilizarse cuando la diferencia entre el tamaño de los modelos de carácter y los caracteres en la cadena de texto supere ±5%.

Closed Umbral de aceptación

Define la puntuación mínima aceptable (0-100; predeterminado = 70) para cada carácter contenido en la cadena de texto. Si cualquiera carácter de la cadena de texto se encuentra por debajo del umbral de aceptación, el resultado de toda la cadena de texto será un fallo.

Closed Modo de lectura

Define el modo del algoritmo de lectura de texto: Velocidad o Precisión. El modo Velocidad (Modo de lectura predeterminado) es más eficaz con imágenes de buena calidad y contraste que requieren una velocidad de ejecución elevada por parte de la herramienta, mientras que el modo Precisión es más eficaz con imágenes más difíciles, de menor contraste que no requieran que la herramienta se ejecute rápidamente.

Closed Diferencia de aceptación

Define el valor mínimo aceptable de la diferencia necesaria entre las puntuaciones más alta y segunda más alta de un carácter (0-20; predeterminado = 0). Si una puntuación de diferencia es igual o menor que el valor de Diferencia de aceptación, el resultado de toda la cadena de texto será un fallo.

Closed Fondo confuso

Corrige la confusión de características adicionales en la imagen con la cadena de texto (de forma predeterminada, esta opción está desactivada). Con la opción Fondo confuso habilitada, el tiempo de ejecución de la herramienta aumenta ligeramente. Esta opción resulta especialmente útil cuando se confunden otras características de la región con el principio de la cadena de texto.

Closed Tolerancia de la escala

Permite variaciones en escala del carácter (de forma predeterminada, esta opción está desactivada).

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará texto antes de detenerse y devolver un rechazo.

Closed Resultado

Muestra la información descodificada o verificada de la cadena de texto.


Herramienta de identificación Leer texto - tabla Modelo de carácter

Closed Índice

Indica la posición del carácter en la cadena de texto.

Closed Carácter

Muestra el Carácter modelo con la puntuación más alta (es decir, el Carácter modelo que mejor coincide con el carácter de la cadena de texto).

Closed Puntuación

Indica el nivel de confianza en el Carácter modelo con la puntuación más alta. Si el valor devuelto es igual o menor que el valor del Umbral de aceptación, el resultado de toda la cadena de texto será un fallo.

Closed Aceptado

Indica si el carácter resultó aceptado o rechazado, dependiendo de si los valores en las columnas Puntuación y Diferencia de caracteres son iguales o menores (Rechazo), o mayores (Aceptación), que los parámetros Umbral de aceptación y Diferencia de aceptación, respectivamente.

Closed 2º carácter

Muestra el Carácter modelo con la segunda puntuación más alta (es decir, el Carácter modelo que presenta la segunda mejor coincidencia con el carácter de la cadena de texto).

Closed 2ª puntuación

Indica el nivel de confianza en el Carácter modelo con la segunda puntuación más alta.

Closed Diferencia de caracteres

Muestra la diferencia entre las puntuaciones más alta y segunda más alta. Si el valor devuelto es igual o menor que el parámetro Diferencia de aceptación, el resultado de toda la cadena de texto será un fallo.


Uso de las propiedades de entrada/salida de la herramienta de identificación Leer texto

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Accept_Threshold | I | X | X | Entrada/Salida
Confusing_Background | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Difference_Accept | I | X | X | Entrada/Salida
Field_String | S | X | X | Entrada/Salida
Fuente | I | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Match_String | S | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Read_Mode | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Tiempo de espera | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Diferencia | FP | X | X | Salida
Mismatch_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Región | A | X | X |
Sintonizar | A | X | X |


Herramientas de identificación - Patrones PatMax RedLine (1-10) y Patrones PatMax (1-10)

Notas:
  • A partir del firmware de In-Sight 5.5.0 y posteriores, el algoritmo de la herramienta se ha modificado para obtener resultados más precisos y reducir el tiempo de ejecución en determinadas circunstancias.
  • Debido a esta modificación, aparecerá un mensaje de error si intenta cargar una tarea en la que esta herramienta esté configurada con el firmware de In-Sight 5.5.0 o posterior en un sistema de visión In-Sight con una versión de firmware 5.4.x o anterior.
  • La herramienta de identificación de patrones PatMax RedLine solo está disponible en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de patrones PatMax RedLine y la herramienta de identificación de patrones PatMax se utilizan para entrenar las apariciones de características del patrón mediante los algoritmos PatMax RedLine o PatMax y, a continuación verificar o identificar la aparición concreta de las características del patrón en la imagen.

Estas herramientas son útiles, por ejemplo, en aplicaciones en las que desea asegurarse de que el producto que pasa por la línea de producción sea el correcto, sobre la base de un logotipo, una etiqueta o una pieza, o bien para reconocer el producto que se está procesando y comunicar esa información a otros dispositivos de la planta de fabricación.

  1. Configuración de la herramienta de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10)
    1. Patrones PatMax RedLine, patrones PatMax y patrones
    2. Selección de una característica de patrón
  2. Ajuste de los parámetros de la herramienta de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10)
  3. Uso de las propiedades de entrada/salida de la herramienta de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10)


Configuración de las herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10)

Una vez agregada la herramienta, deberá seleccionar el tipo de regiones y configurarlas para definir su patrón (la región Modelo), y en qué lugar de la imagen se encontrará el modelo (la región de Búsqueda).

Las herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) permiten crear una biblioteca de hasta 10 patrones Modelo diferentes. Cada patrón Modelo se debe entrenar utilizando una imagen distinta; la herramienta busca en la imagen los patrones entrenados diferentes, pero no reconocerá múltiples instancias de un mismo patrón en la imagen.

  1. En el menú desplegable Modelo, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Después coloque la región Modelo sobre el patrón que se utilizará como modelo de entrenamiento; asegúrese de que la región Modelo cubra únicamente las características importantes del patrón.Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. En el menú desplegable Buscar, seleccione el tipo de región: Rectángulo (predeterminado), Círculo, Espacio anular o Polígono. A continuación, sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezca el patrón. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.

  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea). La región Modelo será reemplazada por un contorno verde del patrón entrenado.

  4. Para definir otro patrón Modelo, cargue o adquiera una imagen nueva con un patrón nuevo, seleccione un patrón sin entrenar en la tabla (marcado como "No entrenado" en la columna Entrenado) y presiones el botón Región modelo; repita los pasos del 1 al 3.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Patrón PatMax RedLine, Patrón PatMax y Patrón

Nota: La herramienta de identificación de patrones PatMax RedLine solo está disponible en sistemas de visión In-Sight que dispongan de la versión 5.2.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

Las herramientas Patrones PatMax RedLine, Patrones PatMax y Patrones localizan modelos de patrones entrenados y ofrecen la máxima precisión de entre todas las herramientas de ubicación e inspección. Sin embargo, las herramientas Patrones PatMax RedLine y Patrones PatMax son más potentes que la herramienta Patrones al contabilizar más cambios de las condiciones de iluminación y la posición del patrón. Asimismo, ofrecen un reconocimiento superior de los cambios de escala y rotación del patrón, de la oclusión de elementos del patrón y de cambios del aspecto del patrón debidos a variaciones de iluminación.

La principal diferencia entre los patrones PatMax RedLine y los patrones PatMax es la velocidad; el patrón PatMax RedLine utiliza el algoritmo de coincidencia de patrones más reciente y puede localizar características entrenadas en una imagen de 5 megapíxeles hasta 7 veces más rápido que los patrones PatMax. Por lo tanto, la herramienta Patrones PatMax RedLine es ideal para sistemas de visión de alta resolución.

La herramienta Patrones es (en la mayoría de los casos) más rápida que la herramienta PatMax, pero ciertas situaciones requieren la precisión y fiabilidad de la versión PatMax RedLine o PatMax:

  • Cuando las variaciones de iluminación y los reflejos son difíciles de controlar. Por ejemplo, las piezas metálicas pueden reflejar la luz en direcciones aleatorias.
  • Cuando el patrón que se inspecciona presenta formas o sombras similares en comparación con algo situado en el fondo o si otros objetos de la imagen se solapan con el patrón o lo ocultan parcialmente.
  • Cuando se desea reconocer con precisión un tipo de patrón frente a otros patrones similares.
  • Cuando las condiciones del entorno de la implementación son demasiado difíciles para que la herramienta Patrones pueda funcionar de forma coherente y fiable.


Ajuste de los parámetros de las herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de las herramientas de identificación patrones PatMax RedLine (1-10) y patrones PatMax (1-10) consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes
  • Fichas Modelo y Buscar
  • Ficha Tabla

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección, que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "IDProducto_1" (si se trata de la primera herramienta de identificación de patrones PatMax agregada a la tarea; de lo contrario, se incrementará, es decir, "IDProducto_2", "IDProducto_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - ficha Ajustes

Closed Modo

Define el modo operativo de la herramienta: Identificar o Verificar.

Identificar (el modo predeterminado) se utiliza cuando el patrón que se está inspeccionando es desconocido. La herramienta examinará automáticamente la imagen (basándose en sus regiones), determinará qué patrón de la biblioteca de patrones entrenados se está visualizando y comunicará esta información en el parámetro Resultado.

Verificar se utiliza para verificar si está presente el patrón correcto. La herramienta examinará la imagen en busca del patrón especificado y comparará el patrón encontrado con el patrón especificado en el parámetro Patrón.

Closed Patrón

Define qué patrón entrenado debe verificarse (para habilitar este ajuste, Modo debe estar ajustado a Verificar). Elija entre los patrones entrenados.

Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 65). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Umbral de contraste

Define el contraste mínimo aceptable que debe estar presente en el patrón encontrado; el contraste de un patrón encontrado debe ser mayor que el valor de Umbral de contraste para que se considere una instancia válida. El valor predeterminado para el patrón o los patrones PatMax RedLine es 0 y el rango de parámetros válido es 0-100. El valor predeterminado para el patrón o los patrones PatMax es 10 y el rango de parámetros válido es 0-255. Un valor de Umbral de contraste bajo se utiliza para imágenes de bajo contraste, mientras que un valor de Umbral de contraste alto se utiliza para imágenes de alto contraste.

Nota: El contraste del patrón o los patrones PatMax RedLine es la medición "relativa" del cambio de contraste entre las características del patrón entrenado y las características coincidentes en la imagen de búsqueda, en porcentaje. Por lo tanto, si el contraste de las características es similar o más alto en relación con el contraste del patrón, el contraste comunicado será ~100. Si el contraste de las características es más bajo que el contraste del patrón, el contraste comunicado será <100. El contraste del patrón o los patrones PatMax RedLine es diferente del contraste del patrón o los patrones PatMax, que es el contraste "absoluto" de la imagen del ROI buscado, en nivel de escala de grises.

Closed Tolerancia del ángulo

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define el porcentaje de escalado admisible (variaciones de tamaño) entre el patrón encontrado y el patrón Modelo (0-50; valor predeterminado = 0). El valor es un porcentaje positivo o negativo, p. ej., un valor de 5 permitirá que la herramienta encuentre patrones que están entre el 95 % y el 105 % del tamaño del patrón Modelo. Cuanto mayor sea el rango admisible de variación de escala del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Diferencia aceptada

Define la diferencia admisible en las puntuaciones que pueden existir entre el patrón encontrado y cualquiera de los patrones Modelo entrenados (0-20; predeterminado = 0). Este valor es la diferencia entre las puntuaciones de cualesquiera dos patrones Modelo entrenados; por ejemplo, un valor de 5 garantizará que la herramienta encuentre patrones cuya puntuación sea por lo menos 5 puntos mayor que la puntuación de cualquier otro patrón Modelo.

Closed Modo Buscar

Define el modo de búsqueda utilizado para entrenar y reconocer patrones, PatMax o PatQuick. La opción PatMax está seleccionada de forma predeterminada. PatMax ofrece mayor precisión que PatQuick, pero requiere más tiempo de ejecución, mientras que PatQuick ofrece menor precisión que PatMax, pero requiere menos tiempo de ejecución.

Closed Puntuación estricta

Define si las características ocluidas del patrón encontrado o las que faltan en él repercutirán o no en la puntuación (valor predeterminado = desactivado). Cuando se aplica la opción Puntuación estricta (activada), se reducirá la puntuación del patrón encontrado si hay características del patrón ausentes o bloqueadas.

Closed Tiempo de espera
Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo. Este parámetro se establece de forma predeterminada en 1.000.
Closed Resultado

Muestra el nombre del patrón identificado.

Nota: El patrón o patrones PatMax RedLine no incluye el parámetro Modo Buscar.


Herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - fichas Modelo y Buscar

Las fichas Modelo y Buscar sirven para configurar la región compuesta de las regiones Modelo y Buscar de la herramienta. Las regiones compuestas sirve son una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • En la ficha Modelo, las regiones compuestas solo se activan tras pulsar el botón Región modelo.
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10) - ficha Tabla

La ficha Tabla consta de la tabla de patrones entrenados y de miniaturas de las imágenes de los patrones entrenados.

Closed Ficha Tabla

Nombre: Este campo define el nombre del patrón entrenado. Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular

Entrenado: Este campo indica si un patrón se ha entrenado o no. El campo comunicará "Entrenado" si el patrón se ha entrenado y "No entrenado" si no se ha entrenado.

Puntuación: Este campo informa de la puntuación del patrón entrenado que se ha encontrado.

Notas:
  • Para suprimir un patrón desde la herramienta, abra la ficha Tabla, haga clic con el botón derecho en el patrón y seleccione la opción Suprimir en el menú.
  • El panel de ajustes Tabla tiene tres opciones de Vista: Iconos grandes, Detalles (predeterminado) y Mosaico. Para seleccionar otra opción de visualización para el panel de ajustes, haga clic con el botón derecho en cualquier punto de la Tabla y seleccione la opción deseada en el submenú Vista.
Closed Botón Región modelo

Este botón inicia el entrenamiento de patrones.

Closed Botón Cambiar nombre

Seleccione un patrón entrenado en la tabla y presione este botón para cambiar el nombre del patrón por un nombre que se asocie a su aplicación en particular.

Closed Miniatura Imagen entrenada

La imagen que se muestra debajo del botón Región modelo es una miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de las herramientas de identificación de patrones PatMax RedLine (1-10) y patrones PatMax (1-10)

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Tolerancia_Angulo | I | X | X | Entrada/Salida
Umbral_Contraste | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Aceptar_Diferencia | I | X | X | Entrada/Salida
Buscar_Modo1 | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Patrón | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Puntuacion_Estricta | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Modelo | A | X | X
Buscar | A | X | X
Elemento1-9.Angulo2 | FP | X | X | Salida
Elemento1-9.Puntuacion2 | FP | X | X | Salida
Elemento1-9.X2 | FP | X | X | Salida
Elemento1-9.Y2 | FP | X | X | Salida
Elemento1-9.Escala2 | FP | X | X | Salida
Elemento1-9.Encontrado2 | FP | X | X | Salida

1 Esta propiedad de herramienta solo está disponible en la herramienta de identificación de patrones PatMax (1-10).

2 Elemento 1-9 se refiere a las diez iteraciones de las salidas del elemento (es decir, Elemento1, Elemento2, Elemento3, etc.).


Herramientas de identificación - Patrones

La herramienta Identificación de patrones se utiliza para entrenar características de patrones y luego verificar o detectar las apariciones de esas características de patrones en la imagen.

Esta herramienta es útil, por ejemplo, en aplicaciones en las que se desea garantizar que en la línea de producción se encuentre el producto correcto, basándose en un logotipo, una etiqueta o una pieza, o reconocer qué producto se está procesando para comunicar esa información a otros dispositivos de la planta de producción.

  1. Configuración de la herramienta de identificación Patrones
    1. Comparación de las herramientas Patrones PatMax y Patrones
    2. Selección de una característica de patrón
  2. Ajuste de los parámetros de la herramienta Identificación de patrones
  3. Uso de las propiedades de entrada/salida de la herramienta Identificación de patrones


Configuración de la herramienta de Identificación de patrones

Cuando haya agregado la herramienta, deberá configurar las regiones de la imagen que definirán su patrón (la región Modelo), y dónde se encontrará el patrón en la imagen (la región de Búsqueda).

La herramienta Identificación de patrones (1-10) permite crear una biblioteca de hasta 10 patrones Modelo distintos. Cada patrón Modelo se debe entrenar utilizando una imagen distinta; la herramienta busca en la imagen los patrones entrenados diferentes, pero no reconocerá múltiples instancias de un mismo patrón en la imagen.

  1. Sitúe la región Modelo sobre el patrón que se utilizará como patrón de entrenamiento inicial; asegúrese de que la región Modelo cubra solamente las características importantes del patrón.
  2. Sitúe la región Búsqueda de modo que cubra las áreas de la imagen en las que usted espere que aparezcan los patrones. Para acelerar el funcionamiento de la herramienta, intente crear regiones Búsqueda más pequeñas; cuanto mayor sea la región Búsqueda, más tiempo necesitará la herramienta para realizar su inspección.

Nota: Las regiones Modelo y Búsqueda no se pueden doblar para formar un arco o un anillo.

  3. Presione el botón Aceptar para confirmar las regiones (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea). La región Modelo será reemplazada por un contorno verde del patrón entrenado.
  4. Para definir otro patrón Modelo, cargue o adquiera una nueva imagen con un nuevo patrón, seleccione un producto no entrenado en la Tabla (marcado como "No entrenado" en la columna Entrenado), presione el botón Región modelo y repita los pasos 1 a 3.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de identificación de patrones (1-10)

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación de patrones (1-10) consta de cuatro fichas:

  • Ficha General
  • Ficha Ajustes
  • Ficha Tabla

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Patrones - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección, que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "IDPatron_1" (si se trata de la primera herramienta de identificación de patrones agregada a la tarea; de lo contrario, se incrementará, es decir, "IDPatron_2", "IDPatron_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta Identificación de patrones - pestaña Ajustes

Closed Modo

Define el modo operativo de la herramienta: Identificar o Verificar.

Identificar (el modo predeterminado) se utiliza cuando el patrón que se está inspeccionando es desconocido. La herramienta examinará automáticamente la imagen (basándose en sus regiones), determinará qué patrón de la biblioteca de patrones entrenados se está visualizando y comunicará esta información en el parámetro Resultado.

Verificar se utiliza para verificar si está presente el patrón correcto. La herramienta examinará la imagen en busca del patrón especificado y comparará el patrón encontrado con el patrón especificado en el parámetro Patrón.

Closed Patrón

Define qué patrón entrenado debe verificarse (para habilitar este ajuste, Modo debe estar ajustado a Verificar). Elija entre los patrones entrenados.

Closed Umbral de aceptación

Define el grado de semejanza que debe existir entre el patrón Modelo y el patrón encontrado (0-100; valor predeterminado = 50). Todos los patrones encontrados por encima o en número igual al valor de este ajuste se consideran patrones encontrados. Esta herramienta se ejecuta más rápidamente cuanto mayor sea el valor de este ajuste, lo que también implica que el grado de semejanza entre el Modelo y el patrón encontrado debe ser mayor. Cuanto menor sea este valor, mayor será la probabilidad de obtener resultados menos exactos, lo que, por ejemplo, puede ocasionar la detección de patrones similares pero no iguales que el patrón Modelo.

Closed Tolerancia de rotación

Define cuántos grados puede estar rotado el patrón encontrado desde la posición del patrón Modelo sin que deje de reconocerse como patrón válido (± 0-180°; valor predeterminado = 15°). Cuanto mayor sea el rango admisible de variación rotacional del patrón, mayor será el tiempo de ejecución de la herramienta.

Closed Tolerancia de la escala

Define la tolerancia de la herramienta a los cambios en la escala del patrón, dentro de un rango de ±10% del tamaño del patrón entrenado. De forma predeterminada, este ajuste está desactivado, lo que desactiva los ajustes de escala. En este modo de operación, la herramienta seguirá encontrando los patrones que se encuentren dentro de un rango de ±10%, pero la puntuación de la característica disminuirá según aumente el porcentaje de escala.

Closed Diferencia aceptada

Define la diferencia admisible en las puntuaciones que pueden existir entre el patrón encontrado y cualquiera de los patrones Modelo entrenados (1-20; predeterminado = 0). Este valor es la diferencia entre las puntuaciones de cualesquiera dos patrones Modelo entrenados; por ejemplo, un valor de 5 garantizará que la herramienta encuentre patrones cuya puntuación sea por lo menos 5 puntos mayor que la puntuación de cualquier otro patrón Modelo.

Closed Tipo de modelo

Define cómo la herramienta debe construir el patrón Modelo, Modelo de área o Modelo de margen (predeterminado). Modelo de área crea el patrón Modelo a partir de un muestreo de uniformidad de los valores de escala de grises contenidos en la región Modelo. Modelo de margen crea el patrón Modelo basándose en los márgenes detectados (transiciones entre claro y oscuro) de la característica del patrón dentro de la región Modelo.

Closed Precisión

Define cómo la herramienta evaluará el compromiso entre exactitud/fiabilidad frente a velocidad de ejecución; Exacto, Medio (preajuste) y Rápido. Exacto prioriza la precisión y la fiabilidad, reduciendo la velocidad de ejecución, Rápido favorece la velocidad de ejecución a costa de la precisión y fiabilidad, mientras que Mediano es un equilibrio entre las dos primeras opciones.

Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30.000), durante el que la herramienta buscará patrones antes de detenerse y devolver un rechazo.

Closed Resultado

Muestra el nombre del patrón identificado.


Herramienta de identificación de patrones (1-10) - ficha Tabla

La ficha Tabla contiene la tabla de muestras de patrones entrenados, así como imágenes en miniatura de los patrones entrenados.

Closed Ficha Tabla

Nombre: Este campo define el nombre del patrón entrenado. Personalice su herramienta asignándola un nombre relacionado con su aplicación en particular.

Entrenado: Este campo indica si un patrón ha sido entrenado o no. El campo indicará "Entrenado" si el patrón ha sido entrenado y "No entrenado" en caso contrario.

Puntuación: Este campo indica la puntuación del patrón encontrado y entrenado.

Notas:
  • Para suprimir un patrón desde la herramienta, abra la ficha Tabla, haga clic con el botón derecho en el patrón y seleccione la opción Suprimir en el menú.
  • El panel de ajustes Tabla tiene tres opciones de Vista: Iconos grandes, Detalles (predeterminado) y Mosaico. Para seleccionar otra opción de visualización para el panel de ajustes, haga clic con el botón derecho en cualquier punto de la Tabla y seleccione la opción deseada en el submenú Vista.
Closed Botón Región modelo

Este botón inicia el entrenamiento de patrones.

Closed Botón Cambiar nombre

Seleccione un patrón entrenado en la tabla y presione este botón para cambiar el nombre del patrón y asignarle un nombre asociado a su aplicación en particular.

Closed Miniatura de la imagen entrenada

La imagen visualizada debajo del botón Región modelo es una miniatura del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar el patrón Modelo.


Uso de las propiedades de entrada/salida de la herramienta Identificación de patrones

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Umbral_Aceptacion | I | X | X | Entrada/Salida
Precision | I | X | X | Entrada/Salida
Tolerancia_Angulo | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Aceptar_Diferencia | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Tipo_Modelo | I | X | X | Entrada/Salida
Patrón | I | X | X | Entrada/Salida
Escala_Tolerancia | I | X | X | Entrada/Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Modelo | A | X | X |
Buscar | A | X | X |


Herramientas de identificación - Modelo de colores

La herramienta de identificación Modelos de colores se utiliza para determinar, a partir de una biblioteca de modelos de colores, qué modelo de colores coincide mejor con los colores de la imagen, devolviendo el nombre del modelo de colores coincidente.

La herramienta Modelo de colores establece primero una referencia a una biblioteca entrenada de modelos de colores y luego determina el número de píxeles presentes en la región que coinciden con los modelos de colores seleccionados y entrenados de la biblioteca. Dependiendo del modo de operación de la herramienta, es decir, Identificar (ajuste predeterminado) o Correspondencia, la herramienta devuelve el nombre del Modelo de colores que mejor cumple los criterios de inspección. La herramienta también genera una imagen binaria de salida en escala de grises, en la que cada píxel que coincide con un modelo de colores activo se ajusta a blanco (255), mientras que los demás píxeles se ajustan a negro (0).

  1. Configuración de la herramienta de identificación Modelo de colores
  2. Ajuste de los parámetros de la herramienta de identificación de modelos de colores
  3. Uso de las propiedades de entrada/salida de la herramienta de identificación Modelo de colores


Configuración de la herramienta de identificación Modelo de colores

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo en la imagen:

  1. En el menú desplegable Modelo, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los colores; asegúrese de que los límites de la región cubran tanto los colores como sus posibles ubicaciones. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los colores se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de los colores.

    Nota: Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:

  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.

  • Si previamente se añadió otra herramienta de color y desea utilizar una biblioteca de colores existente y los correspondientes modelos de colores entrenados, abra la ficha Ajustes, seleccione la biblioteca de colores deseada y después active los modelos de colores deseados activando las casillas correspondientes en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de identificación de modelos de colores

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de identificación de modelos de colores consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Tabla
  • Ficha Biblioteca de colores
  • Ficha Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de identificación Modelo de colores - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "IdentificaciónModeloColores_1" (si se trata de la primera herramienta de identificación de modelo de colores agregada a la tarea; de lo contrario, se incrementará, es decir, "IdentificaciónModeloColores_2", "IdentificaciónModeloColores_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de identificación de modelos de colores - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"
Closed Modo

Define el modo operacional de la herramienta: Identificar (predeterminado) o Correspondencia.

  • Identificar: Se utiliza cuando los colores de la imagen son desconocidos. La herramienta determinará qué Modelo de colores coincide mejor con los colores de la imagen y ordenará y categorizará los resultados basándose en sus recuentos de píxeles y, si hay múltiples, en los Modelos de colores activos en la Biblioteca de colores seleccionada.
  • Correspondencia: Permite verificar si un Modelo de colores esperado está presente en la imagen. La herramienta procesará la imagen y determinará si los colores que contiene coinciden o no con los esperados del Modelo de colores, en el parámetro Correspondencia de colores.
Closed Correspondencia de colores

Define el Modelo de colores que se esperaba detectar. Este campo sólo está disponible si el parámetro Modo se ajusta a Correspondencia. Introduzca el nombre del Modelo de colores que se espera detectar en el campo.

Closed Recuento mínimo de píxeles

Define el umbral mínimo de recuento de píxeles (0 a 9.999.999; predeterminado = 1000) para determinar si un Modelo de colores debe considerarse como coincidencia o no. Por ejemplo, si en el Modo de identificación el umbral se ajusta a 1.000, todos los Modelos de colores que devuelvan recuentos de píxeles inferiores a 1.000 se excluirán automáticamente; en Modo de correspondencia, si el Modelo de colores esperado generase menos de 1.000 píxeles coincidentes, la herramienta devolvería un Rechazo.

Closed Resultado

Muestra el nombre del Modelo de colores encontrado.


Herramienta de identificación de modelos de colores - Biblioteca de colores

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Herramienta de identificación de modelos de colores - ficha Tabla

La ficha Tabla muestra una lista de sólo lectura de los Modelos de colores encontrados, clasificada por su rango y puntuación de las 10 mejores coincidencias.

Closed Rango

Muestra una graduación numérica de los Modelos de colores que mejor cumplen los criterios de inspección, entre 1 y 10.

Closed Nombre

Muestra los nombres de los Modelos de colores encontrados.

Closed Recuento de píxeles

Muestra el recuento de píxeles de los Modelos de colores encontrados.


Herramienta de identificación Modelo de colores - ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.

Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de identificación Modelo de colores

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Biblioteca_Colores | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Color_Coincidente | S | X | X | Entrada/Salida
Recuento_Minimo_Pixeles | I | X | X | Entrada/Salida
Modo | I | X | X | Entrada/Salida
Habilitar_Modelo | I | X | X | Entrada/Salida
Habilitar_Seleccionar_Modelo | I | X | X | Entrada/Salida
Mostrar_Imagen_Original | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region_Compuesta | A | X | X |
Habilitar_Aplicar_Modelo | A | X | X |

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_Evento | A | X | X | Entrada/Salida
Entrenar_Modelo | S | X | X | Entrada/Salida
Entrenar_Operacion | I | X | X | Entrada/Salida
Entrenar_Procedimiento | I | X | X |
Entrenar_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Limite_Mas_Oscuro | FP | X | X | Entrada/Salida
Limite_Mas_Claro | FP | X | X | Entrada/Salida
Entrenar_Color | S | X | X | Entrada/Salida
Entrenar_Evento | A | X | X |
Entrenar_Region | A | X | X |


Herramientas de geometría - Punto a punto: Línea

La herramienta de geometría Punto a punto: línea forma una línea de referencia entre dos características de entrada (puntos, orígenes de elemento o el centro de características circulares) e informa de las coordenadas X e Y de los dos puntos finales de la línea formada.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

  1. Configuración de la herramienta de geometría Punto a punto: Línea
  2. Ajuste de los parámetros de la herramienta de geometría Punto a punto: Línea
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Punto a punto: Línea


Configuración de la herramienta de geometría Punto a punto: Línea

Una vez añadida la herramienta, deberá definir las características de entrada (puntos, los orígenes de los elementos o el centro de características circulares) que se utilizarán para construir la línea de referencia:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la segunda característica.
  4. Una vez seleccionada la segunda característica, EasyBuilder construirá automáticamente una línea entre las características. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Punto a punto: Línea

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Punto a punto: Línea consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Line_1" (cuando se trata de la primera herramienta añadida a la tarea que define una línea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Line_2", "Line_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Punto a punto: Línea

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Punto a punto: Punto medio

La herramienta de geometría Punto a punto: punto medio calcula el punto medio entre dos características de entrada (puntos, orígenes de elemento o el centro de características circulares) y forma una línea de referencia entre las dos características e informa del ángulo de punto medio relativo al elemento e informa de las coordenadas X e Y del punto medio.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

  1. Configuración de la herramienta de geometría Punto a punto: Punto medio
  2. Ajuste de los parámetros de la herramienta de geometría Punto a punto: Punto medio
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Punto a punto: Punto medio


Configuración de la herramienta de geometría Punto a punto: Punto medio

Una vez añadida la herramienta, deberá definir las características de entrada (puntos, los orígenes de los elementos o el centro de características circulares) que se utilizarán para construir la línea de referencia:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).

  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.

  3. A continuación, seleccione la segunda característica.

  4. Una vez seleccionada la segunda característica, EasyBuilder construirá automáticamente una línea entre las características y colocará un [image] en la ubicación del punto medio. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Punto a punto: Punto medio

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Punto a punto: Punto medio consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Point_1" (cuando se trata de la primera herramienta añadida a la tarea que define un punto. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Point_2", "Point_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Punto medio

Comunica las coordenadas X,Y del punto medio entre las dos características de entrada, así como la orientación angular del punto medio en relación al elemento.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Punto a punto: Punto medio

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Punto a punto: Dimensión

La Punto a punto: Punto a punto: dimensión calcula la distancia entre los puntos medios de dos características de entrada (puntos, orígenes de elemento o el centro de características circulares), con relación a un margen o una línea, forma una línea de referencia para representar la distancia calculada e informa de la distancia calculada.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría Punto a punto: dimensión es útil si necesita calibrar la precisión de la alineación de un ensamblado.

  1. Configuración de la herramienta de geometría Punto a punto: Dimensión
  2. Ajuste de los parámetros de la herramienta de geometría Punto a punto: Dimensión
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Punto a punto: Dimensión


Configuración de la herramienta de geometría Punto a punto: Dimensión

Una vez añadida la herramienta, deberá definir las características de entrada (puntos, los orígenes de los elementos o el centro de características circulares) que se utilizarán para construir la línea de referencia:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la segunda característica.
  4. Una vez seleccionada la segunda característica, EasyBuilder volverá a examinar automáticamente la imagen y le proporcionará una selección de características inteligentes de márgenes o líneas que se pueden utilizar como línea de referencia para la medición. Seleccione una característica de margen o de línea a la que hacer referencia.
  5. En ese momento, EasyBuilder proyectará, desde los puntos medios de las características, líneas de referencia perpendiculares al margen o a la línea de referencia, y calculará la distancia basándose en la relación entre las líneas de referencia perpendiculares proyectadas y el margen o línea de referencia que se haya seleccionado. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  6. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  7. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Punto a punto: Dimensión

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Punto a punto: Dimensión consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de geometría Punto a punto: Dimensión - ficha General

Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Dimension_1" (cuando se trata de la primera herramienta de geometría Punto a punto: Dimensión añadida a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta añadida, es decir, "Dimension_2", "Dimension_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de geometría Punto a punto: Dimensión - ficha Límites de rango

Closed Máximo

Define el valor de distancia máxima admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Distancia

Comunica la distancia medida actual entre las líneas de referencia perpendiculares proyectadas de los puntos medios de las dos características, en relación al margen o a la línea de referencia; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor de distancia mínima admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de geometría Punto a punto: Dimensión

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Distancia | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Distancia | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Línea perpendicular

La herramienta de geometría para la línea perpendicular forma una línea de referencia perpendicular a otra característica de línea o margen e informa de las coordenadas X e Y de los puntos finales de la línea de referencia formada.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

  1. Configuración de la herramienta de geometría Línea perpendicular
  2. Ajuste de los parámetros de la herramienta de geometría Línea perpendicular
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Línea perpendicular


Configuración de la herramienta de geometría Línea perpendicular

Una vez añadida la herramienta, deberá definir qué línea perpendicular a la línea o característica de margen desea buscar:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. De entre las características disponibles, seleccione la línea o característica de margen haciendo clic en ella. En ese momento, EasyBuilder determinará automáticamente el punto de intersección de la línea perpendicular a la línea o característica de margen seleccionada, e insertará una línea de referencia para definirla, así como una herramienta de presencia/ausencia de márgenes por cualquier característica de margen no definida previamente.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Línea perpendicular

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la Herramienta de geometría Línea perpendicular consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Line_1" (cuando se trata de la primera herramienta añadida a la tarea que define una línea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Line_2", "Line_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Línea perpendicular

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Intersección de líneas

La herramienta de geometría para la intersección de líneas se utiliza para identificar el punto donde se cruzan dos características de margen y/o líneas de referencia e informa de las coordenadas X e Y del punto de intersección.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

  1. Configuración de la herramienta de geometría Intersección de líneas
  2. Ajuste de los parámetros de la herramienta de geometría Intersección de líneas
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Intersección de líneas


Configuración de la herramienta de geometría Intersección de línea

Después de agregar la herramienta, deberá definir las características de margen y/o las líneas que se intersecarán.

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la línea o característica de margen que intersecará.
  4. Una vez seleccionada la segunda característica, EasyBuilder determinará automáticamente el punto de intersección de las líneas e insertará un punto para definir la intersección. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Intersección de línea

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Intersección de línea consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Intersect_1" (cuando se trata de la primera herramienta de geometría Círculo-línea o Intersección de línea añadida a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta añadida, es decir, "Intersect_2", "Intersect_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Intersección de líneas

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Ángulo de bisección

La herramienta de geometría para el ángulo de bisección forma una línea de referencia que representa el ángulo de bisección entre dos características o líneas de margen e informa del ángulo de bisección y de las coordenadas X e Y de los puntos finales de la línea formada.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría para el ángulo de bisección es útil en aquellas situaciones en las que desea identificar el ángulo de bisección entre las características de su pieza y utilizar el ángulo de bisección como punto de referencia para otras medidas, por ejemplo.

  1. Configuración de la herramienta de geometría Ángulo de bisección
  2. Ajuste de los parámetros de la herramienta de geometría Ángulo de bisección
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Ángulo de bisección


Configuración de la herramienta de geometría Ángulo de bisección

Una vez añadida la herramienta, deberá definir las características o líneas de márgenes que se utilizarán para construir la línea de referencia de la bisección:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. En primer lugar, seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).
  3. A continuación, seleccione mediante un clic el segundo margen o línea que definirá el área a bisecar.
  4. En ese momento, EasyBuilder construirá automáticamente una línea de referencia a partir de las líneas o características de margen seleccionadas. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Ángulo de bisección

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Ángulo de bisección consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Bisect_1" (cuando se trata de la primera herramienta de geometría Ángulo de bisección añadida a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta añadida, es decir, "Bisect_2", "Bisect_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Ángulo de bisección

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Ángulo | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Ángulo | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Línea a partir de N puntos

La herramienta de geometría para línea a partir de N puntos forma una línea de referencia que realiza un encuadre de entre 2 a 10 características de entrada (puntos, orígenes de elemento o el centro de características circulares) e informa de las coordenadas X e Y de los puntos finales de la línea formada.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría para línea a partir de N puntos resulta útil en aquellas situaciones en las que necesita crear una línea de referencia sin las diversas características existentes en la imagen.

  1. Configuración de la herramienta de geometría Línea a partir de N puntos
  2. Ajuste de los parámetros de la herramienta de geometría Línea a partir de N puntos
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Línea a partir de N puntos


Configuración de la herramienta de geometría Línea a partir de N puntos

Una vez añadida la herramienta, deberá definir las características de entrada (puntos, los orígenes de los elementos o el centro de características circulares) que se utilizarán para construir la línea de referencia:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. En primer lugar, seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).
  3. A continuación, seleccione las demás características que se utilizarán para definir la línea. Se pueden seleccionar entre un mínimo de dos y un máximo de diez características.
  4. Después de seleccionar todas las características deseadas, presione el botón Aceptar (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  5. A continuación, EasyBuilder construye automáticamente una línea de referencia a partir de las características de entrada seleccionadas. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  6. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  7. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Línea a partir de N puntos

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Línea a partir de N puntos consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Line_1" (cuando se trata de la primera herramienta añadida a la tarea que define una línea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Line_2", "Line_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Línea a partir de N puntos

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Círculo a partir de N puntos

La herramienta de geometría para círculo a partir de N puntos forma un círculo de referencia a partir de 3 a 10 características de entrada (puntos, orígenes de elemento o el centro de características circulares) e informa del diámetro del círculo formado.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría para círculo a partir de N puntos resulta útil en aquellas situaciones en las que necesita crear un círculo de referencia sin las características existentes en la imagen.

  1. Configuración de la herramienta de geometría Círculo a partir de N puntos
  2. Ajuste de los parámetros de la herramienta de geometría Círculo a partir de N puntos
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Círculo a partir de N puntos


Configuración de la herramienta de geometría Círculo a partir de N puntos

Una vez añadida la herramienta, deberá definir las características de entrada (puntos, los orígenes de los elementos o el centro de características circulares) que se utilizarán para construir el círculo de referencia:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. En primer lugar, seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).
  3. A continuación, seleccione las demás características que se utilizarán para definir el círculo. Se pueden seleccionar entre un mínimo de tres y un máximo de diez características.
  4. Después de seleccionar todas las características deseadas, presione el botón Aceptar (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  5. A continuación, EasyBuilder construye automáticamente un círculo de referencia a partir de las características de entrada seleccionadas. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  6. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  7. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Círculo a partir de N puntos

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Círculo a partir de N puntos consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de geometría Círculo a partir de N puntos - ficha General

Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Circle_1" (cuando se trata de la primera herramienta añadida a la tarea que define un círculo. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Circle_2", "Circle_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de geometría Círculo a partir de N puntos - ficha Límites de rango

Closed Máximo

Define el valor de diámetro máximo admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Diámetro

Indica el diámetro medido actual del círculo generado; los valores que coincidan exactamente con los ajustes Mínimo y Máximo, o que se encuentren entre ellos, se clasifican como Aceptación.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Closed Mínimo

Define el valor de diámetro mínimo admisible; la herramienta creará un ajuste predeterminado de Límite inteligente basándose en su imagen, que usted puede personalizar para adaptarlo a las necesidades de su aplicación.

Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.


Uso de las propiedades de entrada/salida de la herramienta de geometría Círculo a partir de N puntos

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Máximo | FP | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Radio.Circulo | FP | X | Salida
Circulo.X | FP | X | Salida
Circulo.Y | FP | X | Salida
Diámetro | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Máximo | FP | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Radio.Circulo | FP | X | X | Salida
Circulo.X | FP | X | X | Salida
Circulo.Y | FP | X | X | Salida
Diámetro | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Intersección círculo-línea

La herramienta de geometría para la intersección círculo-línea es útil para identificar los puntos en un círculo en donde una línea intersecciona el círculo e informa de las coordenadas X e Y de los puntos de intersección de la línea en el círculo.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría para la intersección círculo-línea es útil en aquellas situaciones en las que desea verificar si la alineación entre una característica del círculo y una característica de margen es correcta, por ejemplo.

  1. Configuración de la herramienta de geometría Intersección círculo-línea
  2. Ajuste de los parámetros de la herramienta de geometría Intersección círculo-línea
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Intersección círculo-línea


Configuración de la herramienta de geometría Intersección círculo-línea

Una vez añadida la herramienta, deberá definir la característica de círculo y de margen o la línea que intersecarán el círculo:

  1. Una vez agregada la herramienta, EasyBuilder examinará su imagen y le proporcionará una selección de las características inteligentes que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde).
  2. Primero seleccione una característica circular haciendo clic en ella. En ese momento, su color cambiará a fucsia y una línea partirá desde esa característica.
  3. A continuación, seleccione la línea o característica de margen que intersecará el círculo
  4. Una vez seleccionada la segunda característica, EasyBuilder determinará automáticamente los puntos de intersección del círculo y la línea, e insertará dos puntos para definir la intersección. EasyBuilder también insertará una herramienta de presencia/ausencia de márgenes o una herramienta de presencia/ausencia de círculos por cualquier característica no definida previamente (dependiendo de la herramienta y del tipo de característica).
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Intersección de círculo-línea

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Intersección de círculo-línea consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Intersect_1" (cuando se trata de la primera herramienta de geometría Círculo-línea o Intersección de línea añadida a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta añadida, es decir, "Intersect_2", "Intersect_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Invertir resultado

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Intersección círculo-línea

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Punto1.X | FP | X | Salida
Punto1.Y | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Punto1.X | FP | X | X | Salida
Punto1.Y | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de geometría - Punto definido por el usuario

La herramienta de geometría para el punto definido por el usuario le permite trazar la posición de un punto de referencia en cualquier lugar dentro de la imagen e informa de las coordenadas X e Y de los puntos.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría para el punto definido por el usuario es útil si desea determinar una medición en función de un punto de referencia que no es una característica de la pieza u objeto que se está inspeccionando.

Nota: El punto de la herramienta también se puede utilizar como elemento para otras herramientas, aunque el punto no ofrece ninguna información angular.

  1. Configuración de la herramienta de geometría Punto definido por el usuario
  2. Ajuste de los parámetros de la herramienta de geometría Punto definido por el usuario
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Punto definido por el usuario


Configuración de la herramienta de geometría Punto definido por el usuario

  1. Una vez añadida la herramienta, aparecerá un gráfico de punto de mira de color fucsia en la imagen.
  2. Sitúe el gráfico de punto de mira en el lugar deseado de la imagen y presione el botón Aceptar para confirmar su posición.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.

  4. Si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.

    Nota: El punto de la herramienta también se puede utilizar como elemento para otras herramientas, aunque el punto no ofrece ninguna información angular.


Ajuste de los parámetros de la herramienta de geometría Punto definido por el usuario

Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

El panel de ajustes de la herramienta de geometría Punto definido por el usuario consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Point_1" (cuando se trata de la primera herramienta añadida a la tarea que define un punto. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Point_2", "Point_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Sugerencia: Para obtener los mejores resultados, compruebe la herramienta y ajuste sus parámetros para compensar lo mejor posible las posibles variaciones que puedan surgir al ejecutarla. EasyBuilder ofrece dos cómodos métodos:


Uso de las propiedades de entrada/salida de la herramienta de geometría Punto definido por el usuario

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Punto | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Punto | A | X | X |


Herramientas de geometría - Línea definida por el usuario

La herramienta de geometría para la línea definida por el usuario le permite trazar la posición de una línea de referencia en cualquier lugar dentro de la imagen e informa de las coordenadas X e Y de los puntos finales de la línea.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de geometría para la línea definida por el usuario es útil si desea determinar una medición en función de una línea de referencia que no es una característica de la pieza u objeto que se está inspeccionando.

  1. Configuración de la herramienta de geometría Línea definida por el usuario
  2. Ajuste de los parámetros de la herramienta de geometría Línea definida por el usuario
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Línea definida por el usuario


Configuración de la herramienta de geometría Línea definida por el usuario

  1. Una vez añadida la herramienta, aparecerá una línea de color fucsia en la imagen.
  2. Sitúe la línea en el lugar deseado de la imagen y presione el botón Aceptar para confirmar.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de geometría Línea definida por el usuario

Una vez definidas y aceptadas las entradas de la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de geometría Línea definida por el usuario consta de los siguientes elementos:

Closed Ficha General
Closed Nombre de la herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (entradas, salidas y comunicación); el nombre predeterminado es "Line_1" (cuando se trata de la primera herramienta añadida a la tarea que define una línea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, "Line_2", "Line_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Línea

Comunica las coordenadas X,Y de los puntos finales del segmento de la línea generada.

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Uso de las propiedades de entrada/salida de la herramienta de geometría Línea definida por el usuario

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Línea | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Línea | A | X | X |


Herramientas de geometría - Encuadre de círculo

La herramienta de geometría Encuadre de círculo construye un círculo con el mejor ajuste posible a partir de los márgenes detectados. La herramienta utiliza matrices Calibre de análisis de márgenes para localizar con precisión las características de márgenes. Una vez identificado el margen, la herramienta construye un círculo con el mejor ajuste posible sobre la característica de margen. A continuación, la herramienta comunica el radio del círculo con el mejor ajuste posible y su punto central.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de geometría Encuadre de círculo es útil para asegurarse de que su pieza u objeto mantenga el mismo contorno. Esta herramienta puede crear un círculo de ajuste más exacto, aunque de forma más lenta, que la herramienta de geometría Círculo a partir de N puntos, por ejemplo.

  1. Configuración de la herramienta de geometría Encuadre de círculo
  2. Ajuste de la herramienta de geometría Encuadre de círculo
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Encuadre de círculo


Configuración de la herramienta de geometría Encuadre de círculo

Después de agregar la herramienta, deberá configurar la región enmascarada en la imagen sobre la característica de margen que desee inspeccionar:

  1. Sitúe y configure la región anular enmascarada dentro de la imagen sobre la característica de margen; puede ajustar tanto el radio exterior como el radio interior del anillo para asegurar la detección correcta de los márgenes. Al posicionar y configurar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, pero también de excluir el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Márgenes, Puntuación de márgenes y Encuadre y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la línea o el círculo con el mejor ajuste posible.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de la herramienta de geometría Encuadre de círculo

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de geometría Encuadre de círculo consta de los siguientes elementos:

  • Ficha General
  • Ficha Márgenes
  • Ficha Puntuación de márgen
  • Ficha Adaptación

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de geometría Encuadre de círculo - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "EncuadreCirculo_1" (si se trata de la primera herramienta de geometría de encuadre de círculo agregada a la tarea; de lo contrario, se incrementará, es decir, "EncuadreCirculo_2", "EncuadreCirculo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de geometría Encuadre de círculo - Ficha Encuadre

Al seleccionar la ficha Encuadre, la herramienta mostrará todos los candidatos a márgenes que se encuentran dentro de la región y el círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar el círculo con el mejor ajuste posible. Los candidatos a márgenes se indican con pequeños círculos coloreados.

Closed Filtrar objetos exteriores

Define si la herramienta eliminará o no los puntos de la recta de mejor ajuste que se encuentren más allá de la distancia definida por el parámetro Filtro de encuadre de distancia (de forma predeterminada, este parámetro está activado).

Closed Filtro de encuadre de distancia

Define la distancia (1 - 1920; preajuste = 2), en píxeles, a la que debe encontrarse un margen con respecto a la línea de mejor ajuste original para ser utilizada en el cálculo de reencuadre. Este parámetro sirve para impedir que los defectos afecten al encuadre de línea.

Nota: Para poder utilizar este parámetro, primero debe activarse el parámetro Filtrar objetos exteriores.

Closed Distancia del filtro del punto más alejado

Define la distancia del objeto exterior (1 - 1920; preajuste = 1000) más allá de la cual no se utilizan márgenes para determinar las distancias mínima y y máxima; cualquier margen que supere este valor será ignorado.

Closed Volver a puntuar

Define si los márgenes detectados volverán a ser puntuados para asegurarse de que los márgenes descartados inicialmente fueron filtrados correctamente (de forma predeterminada, este parámetro está activado).

Closed Volver a encuadrar

Define si la herramienta se reajustará a la línea con el mejor ajuste posible después de volver a puntuar los márgenes (de forma predeterminada, este parámetro está activado).

Nota: La precisión de la herramienta será mayor con este parámetro habilitado, aunque a costa de aumentar el tiempo de procesamiento.

Closed Resultado

Muestra la línea con el mejor ajuste en la imagen e indica el radio y el punto dentral del círculo con el mejor ajuste.


Herramienta de geometría Encuadre de círculo - ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra todos los márgenes detectados en la región y los marca en color verde oscuro. Es posible ajustar los parámetros Tamaño del calibre, Espaciado del calibre, Ancho del margen y Contraste mínimo según convenga para aislar los márgenes deseados.

También puede ver todos los calibres activando el parámetro Mostrar todos los calibres.

Esta ficha también permite seleccionar y ajustar la región.

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de geometría Encuadre de círculo - ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra con pequeños círculos coloreados todos los candidatos a márgenes encontrados dentro de la región (que puede seleccionarse y ajustarse), así como el resultado de la línea o del círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Ajustes los parámetros para aislar los candidatos a márgenes deseados.

También se muestran todos los defectos y espacios detectados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha o Derecha a izquierda; preajuste = Izquierda a derecha).

Closed Transiciones de márgenes

Define la transición de los márgenes (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Uso de las propiedades de entrada/salida de la herramienta de geometría Encuadre de círculo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Transición | I | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Filtrar_Objetos_Exteriores | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Ajustar_Distancia_Filtro | I | X | X | Entrada/Salida
Distancia_Filtro_Punto_Más_Alejado | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Reajustar | I | X | X | Entrada/Salida
Repuntuar | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Círculo.Radio | FP | X | X | Salida
Círculo.X | FP | X | X | Salida
Círculo.Y | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región_Enmascarada | A | X | X |


Herramientas de geometría - Encuadre de línea

La herramienta de geometría Encuadre de línea construye una línea con el mejor ajuste posible a partir de los márgenes detectados. La herramienta utiliza matrices Calibre de análisis de márgenes para localizar con precisión las características de márgenes. Una vez identificado el margen, la herramienta construye una línea con el mejor ajuste posible sobre la característica de margen. A continuación, la herramienta comunica las coordenadas X/Y de los puntos de principio y fin del segmento de línea.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de geometría Encuadre de línea es útil para asegurarse de que su pieza u objeto mantenga el mismo contorno. Esta herramienta puede crear una línea de ajuste más exacto, aunque de forma más lenta, que la herramienta de geometría Línea a partir de N puntos, por ejemplo.

  1. Configuración de la herramienta de geometría Encuadre de línea
  2. Ajuste de la herramienta de geometría Encuadre de línea
  3. Uso de las propiedades de entrada/salida de la herramienta de geometría Encuadre de línea


Configuración de la herramienta de geometría Encuadre de línea

Después de agregar la herramienta, deberá configurar la región enmascarada en la imagen sobre la característica de margen que desee inspeccionar:

  1. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, al tiempo que se excluye el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Márgenes, Puntuación de márgenes y Encuadre y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la línea o el círculo con el mejor ajuste posible.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de la herramienta de geometría Encuadre de línea

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de geometría Encuadre de línea consta de los siguientes elementos:

  • Ficha General
  • Ficha Márgenes
  • Ficha Puntuación de márgen
  • Ficha Adaptación

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de geometría Encuadre de línea - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "EncuadreLinea_1" (si se trata de la primera herramienta de geometría de encuadre de línea agregada a la tarea; de lo contrario, se incrementará, es decir, "EncuadreLinea_2", "EncuadreLinea_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de geometría Encuadre de línea - Ficha Encuadre

Al seleccionar la ficha Encuadre, la herramienta mostrará todos los candidatos a márgenes que se encuentran dentro de la región y la línea con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea con el mejor ajuste posible. Los candidatos a márgenes se indican con pequeños círculos coloreados.

Closed Filtrar objetos exteriores

Define si la herramienta eliminará o no los puntos de la recta de mejor ajuste que se encuentren más allá de la distancia definida por el parámetro Filtro de encuadre de distancia (de forma predeterminada, este parámetro está activado).

Closed Filtro de encuadre de distancia

Define la distancia (1 - 1920; preajuste = 2), en píxeles, a la que debe encontrarse un margen con respecto a la línea de mejor ajuste original para ser utilizada en el cálculo de reencuadre. Este parámetro sirve para impedir que los defectos afecten al encuadre de línea.

Nota: Para poder utilizar este parámetro, primero debe activarse el parámetro Filtrar objetos exteriores.

Closed Distancia del filtro del punto más alejado

Define la distancia del objeto exterior (1 - 1920; preajuste = 1000) más allá de la cual no se utilizan márgenes para determinar las distancias mínima y y máxima; cualquier margen que supere este valor será ignorado.

Closed Volver a puntuar

Define si los márgenes detectados volverán a ser puntuados para asegurarse de que los márgenes descartados inicialmente fueron filtrados correctamente (de forma predeterminada, este parámetro está activado).

Closed Volver a encuadrar

Define si la herramienta se reajustará a la línea con el mejor ajuste posible después de volver a puntuar los márgenes (de forma predeterminada, este parámetro está activado).

Nota: La precisión de la herramienta será mayor con este parámetro habilitado, aunque a costa de aumentar el tiempo de procesamiento.

Closed Resultado

Muestra la línea con el mejor ajuste en la imagen e indica las coordenadas X/Y de los puntos de principio y fin del segmento de línea.


Herramienta de geometría Encuadre de línea - ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra todos los márgenes detectados en la región y los marca en color verde oscuro. Es posible ajustar los parámetros Tamaño del calibre, Espaciado del calibre, Ancho del margen y Contraste mínimo según convenga para aislar los márgenes deseados.

También puede ver todos los calibres activando el parámetro Mostrar todos los calibres.

Esta ficha también permite seleccionar y ajustar la región.

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de geometría Encuadre de línea - ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra con pequeños círculos coloreados todos los candidatos a márgenes encontrados dentro de la región (que puede seleccionarse y ajustarse), así como el resultado de la línea o del círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Ajustes los parámetros para aislar los candidatos a márgenes deseados.

También se muestran todos los defectos y espacios detectados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha o Derecha a izquierda; preajuste = Izquierda a derecha).

Closed Transiciones de márgenes

Define la transición de los márgenes (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Uso de las propiedades de entrada/salida de la herramienta de geometría Encuadre de línea

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Transición | I | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Filtrar_Objetos_Exteriores | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Ajustar_Distancia_Filtro | I | X | X | Entrada/Salida
Distancia_Filtro_Punto_Más_Alejado | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Reajustar | I | X | X | Entrada/Salida
Repuntuar | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Línea.Fin_X | FP | X | X | Salida
Línea.Fin_Y | FP | X | X | Salida
Línea.Principio_X | FP | X | X | Salida
Línea.Principio_Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región_Enmascarada | A | X | X |


Herramientas de matemáticas y lógica - Matemáticas

La herramienta de matemáticas y lógica Matemáticas permite construir una fórmula matemática para procesar datos de herramientas y tareas con operadores matemáticos y lógicos, y con funciones estadísticas y trigonométricas estándar.

La herramienta de matemáticas y lógica Matemáticas resulta útil para agregar los recuentos de defectos de dos herramientas o devolver el promedio de herramientas de medición, por ejemplo.

  1. Configuración de la herramienta de matemáticas y lógica Matemáticas
  2. Ajuste de los parámetros de la herramienta de matemáticas y lógica Matemáticas
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas y lógica Matemáticas


Configuración de la herramienta de matemáticas & lógica Matemáticas

Nota: Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas. Antes de agregar esta herramienta, ensamble las demás herramientas de ubicación y/o de inspección que se utilizarán como entradas de esta herramienta; de lo contrario, no podrá construir expresiones hasta que haya añadido y configurado las herramientas de ubicación y/o de inspección necesarias. Después podrá regresar a esta herramienta.

Una vez agregada la herramienta, deberá generar la expresión.

  1. Genere la expresión seleccionando y después introduciendo las funciones matemáticas de la parte izquierda del panel de ajustes y los valores (datos de herramienta y tarea) de la parte derecha. Para introducir una función o un valor en el editor de fórmulas de expresiones, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o el valor o presione el botón Insertar.
  2. Una vez generada la expresión, defina los límites de rango mediante haciendo clic en la ficha Límites de rango. De forma predeterminada, el Máximo se establece en 9.999.999 y el Mínimo en -9.999.999, lo que permite personalizar los límites según las necesidades de su aplicación.

Nota: Si el resultado de la expresión devuelve una cadena de texto, se desactivarán los límites Máximo y Mínimo.

  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas y lógica para matemáticas

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica para matemáticas consta de los siguientes elementos:

  • Ficha General
  • Ficha Límites de rango
  • Expresión

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Matemáticas - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Mat_1" (si se trata de la primera herramienta de matemáticas & lógica Matemáticas agregada a la tarea; de lo contrario, se incrementará, es decir, "Mat_2", "Mat_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas & lógica Matemáticas - Expresión

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.

Sugerencia: Para determinar si una cadena de texto coincide con otra, utilice la función Exacto. La función If se utiliza para comparar valores; EasyBuilder devuelve un error cuando la función If intenta comparar cadenas.
Ejemplo:
  • La cadena de texto utilizada por una herramienta de identificación Leer códigos de ID necesita ser comparada con una cadena que está siendo leída por una herramienta de identificación Leer texto para asegurarse de que coinciden. En la expresión podría construirse la fórmula siguiente: Exact(IDCode_1.Cadena,Text_1.Resultado).
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Herramienta de matemáticas & lógica Matemáticas - ficha Límites de rango

Closed Máximo

Establece el número máximo aceptable para la fórmula; de forma predeterminada, la herramienta asigna un máximo de 9.999.999. Debe personalizar este valor para su aplicación.

Closed Resultado

Comunica el resultado de la expresión; los valores que quedan exactamente en los ajustes Mínimo y Máximo o entre ambos se clasifican como aceptados.

Closed Mínimo

Establece el número mínimo aceptable para la fórmula; de forma predeterminada, la herramienta asigna un mínimo de -9.999.999. Debe personalizar este valor para su aplicación.

Closed Invertir

Define si la lógica de aceptación/rechazo de la herramienta debe invertirse (predeterminado = desactivado):

  • Desactivado: se aplican los resultados estándar, es decir, el resultado de la herramienta es una aceptación si se detecta la característica y cae dentro de los ajustes especificados.
  • Activado: invierte los resultados, es decir, el resultado de la herramienta es un rechazo si la característica se detecta y cae dentro de los ajustes especificados.
Closed Botón Establecer límites

Define los límites basándose en los ajustes de Límites inteligentes. Este botón resulta útil cuando se ha modificado un parámetro y es necesario ajustar los límites, o cuando se ha añadido la herramienta y no se ha definido ningún límite.

Nota: Si el resultado de la expresión devuelve una cadena de texto, se desactivarán los límites Máximo y Mínimo.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas y lógica Matemáticas

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Herramienta_Habilitada | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Mínimo | FP | X | Entrada/Salida
Resultado | FP | X | Salida
Máximo | FP | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Herramienta_Estado_Habilitado | I | X | Salida
Aceptación | I |  | Salida
Rechazo | I |  | Salida
Estado | I | X | Salida
Recuento_Aceptaciones | I | X | Salida
Recuento_Rechazos | I | X | Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Mínimo | FP | X | X | Entrada/Salida
Resultado | FP | X | X | Salida
Máximo | FP | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Aceptación | I | X |  | Salida
Rechazo | I | X |  | Salida
Estado | I | X | X | Salida
Recuento_Aceptaciones | I | X | X | Salida
Recuento_Rechazos | I | X | X | Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida


Herramientas de matemáticas & lógica - Lógica

La herramienta de matemáticas & lógica Lógica permite generar una fórmula para procesar los datos de aceptaciones y rechazos de herramientas mediante operadores lógicos booleanos estándar.

  1. Configuración de la herramienta de matemáticas & lógica Lógica
  2. Ajuste de los parámetros de la herramienta de matemáticas & lógica Lógica
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Lógica

La herramienta devuelve los siguientes resultados:

Modelos In-Sight | Resultados
Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M | Solo estado de aceptación/rechazo
Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar


Configuración de la herramienta de matemáticas & lógica Lógica

Nota: Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas. Antes de agregar esta herramienta, ensamble las demás herramientas de ubicación y/o de inspección que se utilizarán como entradas de esta herramienta; de lo contrario, no podrá construir expresiones hasta que haya añadido y configurado las herramientas de ubicación y/o de inspección necesarias. Después podrá regresar a esta herramienta.

Una vez agregada la herramienta, deberá generar la expresión. El cuadro de texto Expresión se utiliza para generar una fórmula lógica de resultados de aceptaciones y rechazos de herramientas.

Sensores de visión In-Sight de la serie 2000

  1. Genere la expresión mediante la adición del resultado de aceptaciones y rechazos de la herramienta. Para introducir el resultado de aceptaciones y rechazos en el editor de fórmulas de expresiones, seleccione el resultado y haga doble clic en él o presione el botón Insertar.
  2. Una vez generada la expresión, si lo desea invierta la lógica de aceptación/rechazo de la herramienta.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar los resultados.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.

Sistemas de visión In-Sight

  1. Genere la expresión mediante la adición del resultado de aceptaciones y rechazos de la herramienta. Para introducir el resultado de aceptaciones y rechazos en el editor de fórmulas de expresiones, seleccione el resultado y haga doble clic en él o presione el botón Insertar.
  2. Una vez generada la expresión, invierta si lo desea la lógica de aceptación/rechazo en la ficha Ajustes.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar los resultados.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas & lógica Lógica

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

Sensores de visión In-Sight de la serie 2000

  • Cuadro de grupo Editar herramienta

Sistemas de visión In-Sight

El panel de ajustes de la herramienta de matemáticas & lógica Lógica consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Expresión

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Ajuste de los parámetros de la herramienta de matemáticas & lógica Lógica

Nota: En este tema se describe la interfaz de usuario cuando está conectada a un sensor de visión In-Sight de la serie 2000. Si está conectada a sistemas de visión In-Sight, consulte la sección Sistema de visión In-Sight de Ajuste de los parámetros de la herramienta de matemáticas & lógica Lógica.

Closed Expresión

El cuadro de texto Expresión se utiliza para generar una fórmula lógica de resultados de aceptaciones y rechazos de herramientas. Utilice el árbol de símbolos de datos de tareas y de herramientas para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en ellos o bien resaltándolos y presionando el botón Insertar.

Nota: Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.

Closed Árbol de símbolos de datos de tareas y de herramientas

El árbol de símbolos de datos de tareas y de herramientas contiene la salida de resultados de aceptación y rechazo de la herramienta por ubicación y/o por herramientas de inspección. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede añadir símbolos a la expresión mediante uno de estos dos métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Insertar

El botón Insertar se utiliza para colocar símbolos en la expresión. Seleccione el símbolo que desee y presione el botón Insertar para agregar el símbolo a la expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis, AND, OR y NOT

Los botones Abrir paréntesis, Coma, Cerrar paréntesis, AND, OR y NOT se utilizan para generar fórmulas. Presione el botón pertinente para agregarlo a la fórmula.

Closed Botón Eliminar

El botón Eliminar se utiliza para eliminar las palabras o los símbolos resaltados de la expresión. Resalte la palabra o el símbolo que desee y presione Eliminar.

Closed Invertir resultado

Con esta opción habilitada, la herramienta obtiene un rechazo si el resultado se encuentra dentro de los límites del rango. (Valor predeterminado = Desactivado)

Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Aceptación/rechazo | (Invertir) | Aceptación/rechazo
Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Nombre

Define el nombre de la herramienta de inspección. El nombre predeterminado es "Logica_1" (si es la primera herramienta de matemáticas & lógica Lógica añadida a la tarea, de lo contrario se incrementará, p. ej., "Logica_2", "Logica_3", etc.).

Closed Habilitado:

Define si se debe ejecutar o no la herramienta de inspección y cuándo (el ajuste predeterminado es "Activar").

  • Seleccione "Desactivar" si desea deshabilitar la herramienta.
  • Seleccione una línea de entrada si desea que la herramienta se asocie a una determinada línea de entrada discreta donde pueda activarse o desactivarse (una señal alta, 1, significa "Activar" y una señal baja, 0, significa "Desactivar"). La conexión de una herramienta con una entrada permite que un sistema de control, como PLC, pueda determinar qué herramientas se deben ejecutar y cuándo.
Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas & lógica Lógica - ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección. El nombre predeterminado es "Logica_1" (si es la primera herramienta de matemáticas & lógica Lógica añadida a la tarea, de lo contrario se incrementará, p. ej., "Logica_2", "Logica_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas & lógica Lógica - Expresión

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para generar una fórmula lógica de resultados de aceptaciones y rechazos de herramientas. Utilice el árbol de símbolos de datos de tareas y de herramientas para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en ellos o bien resaltándolos y presionando el botón Insertar.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Árbol de símbolos de datos de tareas y de herramientas

El árbol de símbolos de datos de tareas y de herramientas contiene la salida de resultados de aceptación y rechazo de la herramienta por ubicación y/o por herramientas de inspección. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Insertar

El botón Insertar se utiliza para colocar símbolos en la expresión. Seleccione el símbolo que desee y presione el botón Insertar para agregar el símbolo a la expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis, AND, OR y NOT

Los botones Abrir paréntesis, Coma, Cerrar paréntesis, AND, OR y NOT se utilizan para generar fórmulas. Presione el botón pertinente para agregarlo a la fórmula.

Closed Botón Eliminar

El botón Eliminar se utiliza para eliminar las palabras o los símbolos resaltados de la expresión. Resalte la palabra o el símbolo que desee y presione Eliminar.


Herramienta de matemáticas & lógica Lógica - ficha Ajustes

Closed Resultado

Comunica el resultado de la expresión.

Closed Invertir

Define si el resultado de aceptaciones y rechazos debe invertirse:

  • Desactivado (predeterminado): El resultado de aceptaciones/rechazos no se invierte.
  • Activado: El resultado de aceptaciones/rechazos se invierte.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Lógica

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Rechazo | I |  | Salida
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I |  | Entrada
Invertir | I | X | Entrada
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X |
Resultado | FP | X |
Estado | I | X |
Herramienta_Habilitada | I | X | Entrada
Herramienta_Estado_Habilitado | I | X |

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Recuento_Errores | I | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | I |  | Salida
Recuento_Rechazos | I | X | Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Invertir | I | X | Entrada/Salida
Aceptación | I |  | Salida
Recuento_Aceptaciones | I | X | Salida
Resultado | FP | X | Salida
Estado | I | X | Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Herramienta_Estado_Habilitado | I | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  | Salida
Recuento_Rechazos | I | X | X | Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Aceptación | I | X |  | Salida
Recuento_Aceptaciones | I | X | X | Salida
Resultado | FP | X | X | Salida
Estado | I | X | X | Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Herramienta_Estado_Habilitado | I | X | X | Salida


Herramientas de matemáticas & lógica - Tendencia

La herramienta de matemáticas & lógica Tendencia devuelve estadísticas de desviación máxima, mínima, media (promedio), de ejemplo y estándar para un valor de ubicación o de herramienta de inspección o una línea de entrada para un determinado número de ejemplos antes de la restauración.

La herramienta de matemáticas & lógica Tendencia es útil si desea acumular información estadística sobre el resultado de una determinada herramienta durante un período de ejecuciones de tarea para analizar su proceso de fabricación, por ejemplo.

  1. Configuración de la herramienta de matemáticas & lógica Tendencia
  2. Ajuste de los parámetros de la herramienta de matemáticas & lógica Tendencia
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Tendencia


Configuración de la herramienta de matemáticas y lógica Tendencia

Una vez agregada la herramienta, deberá definir el valor a procesar y configurar los parámetros de la herramienta.

  1. Configure los ajustes de la ficha General para adaptarlos a su aplicación.
  2. Haga clic en la ficha Ajustes para definir un valor para el cual acumular estadísticas; después de agregar la herramienta, EasyBuilder examinará su aplicación y listará los valores que se pueden referenciar en el parámetro Último valor. Seleccione un valor y configure los demás parámetros de la ficha.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas y lógica para tendencias

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica para variables consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Tabla
  • Ficha Valor

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Tendencia - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Tendencia_1" (si se trata de la primera herramienta de matemáticas & lógica Tendencia agregada a la tarea; de lo contrario, se incrementará, es decir, "Tendencia_2", "Tendencia_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas y lógica para tendencias - ficha Ajustes

Closed Último valor

Define qué valor computará la herramienta; la selección predeterminada es "No definido", es decir, no acumular ninguna estadística. Para acumular estadísticas correspondientes a esa herramienta o valor de entrada, seleccione un valor devuelto por una herramienta o entrada en la tarea.

Closed Muestras máximas

Define el número máximo de muestras a utilizar durante la acumulación de estadísticas para la herramienta; de forma predeterminada, se utilizan 100 muestras. El número de muestras puede extenderse de un mínimo de 10 a un máximo de 5.000. Una vez que la herramienta alcanza su número máximo de muestras, los valores más antiguos se van descartando según se acumulan los nuevos.

Closed Pantalla

Define qué valor computado se mostrará: Último valor, Mínimo, Máximo, Promedio o StdDev (desviación típica). La selección predeterminada es Último valor.

Closed Resultado

Muestra el valor computado actual definido en el parámetro Visualización.

Closed Botón Restablecer

Pone a cero la acumulación de datos.

Closed Restablecimiento en línea

Define si la herramienta restablecerá automáticamente la acumulación de datos cada vez que el sistema de visión In-Sight se ponga en línea; de forma predeterminada, este ajuste está desactivado, por lo que el restablecimiento deberá efectuarse manualmente.

Closed Restablecimiento de carga de tareas

Define si la herramienta restablecerá automáticamente la acumulación de datos cada vez que el sistema de visión In-Sight cargue la tarea que contiene la herramienta; de forma predeterminada, este ajuste está desactivado, por lo que el restablecimiento deberá efectuarse manualmente.


Herramienta de matemáticas y lógica para tendencias - ficha Valor

Muestra una representación gráfica del valor.


Herramienta de matemáticas y lógica para tendencias - ficha Tabla

La tabla de la herramienta de matemáticas y lógica para tendencias muestra los resultados acumulados para el valor definido en el parámetro Último valor, por el número de muestras definidas en el parámetro Muestras máximas de la ficha Ajustes.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Tendencia

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Visualización | I | X | Entrada/Salida
Restablecimiento_Externo | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Restablecimiento_Carga_Tarea | I | X | Entrada/Salida
Ejemplos_Max | I | X | Entrada/Salida
Restablecimiento_En_Linea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Diagrama | C1 | X |
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Ultimo_Valor | FP | X | Salida
Máximo | FP | X | Salida
Promedio | FP | X | Salida
Mínimo | FP | X | Salida
Numero_De_Muestras | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | FP | X | Salida
Estado | FP | X | Salida
Dis_Est | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Restablecimiento | A | X |
1 La herramienta de matemáticas & Lógica Tendencia incluye un tipo de datos adicional, Diagrama (C), que hace referencia al diagrama generado en la ficha Valor.

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Visualización | I | X | X | Entrada/Salida
Restablecimiento_Externo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Restablecimiento_Carga_Tarea | I | X | X | Entrada/Salida
Ejemplos_Max | I | X | X | Entrada/Salida
Restablecimiento_En_Linea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Diagrama | C1 | X | X |
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Ultimo_Valor | FP | X | X | Salida
Máximo | FP | X | X | Salida
Promedio | FP | X | X | Salida
Mínimo | FP | X | X | Salida
Numero_De_Muestras | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | FP | X | X | Salida
Estado | FP | X | X | Salida
Dis_Est | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Restablecimiento | A | X | X |
1 La herramienta de matemáticas & Lógica Tendencia incluye un tipo de datos adicional, Diagrama (C), que hace referencia al diagrama generado en la ficha Valor.


Herramientas de matemáticas & lógica - Estadísticas

La herramienta de matemáticas & lógica Estadísticas devuelve estadísticas de desviación máxima, mínima, media (promedio), de ejemplo y estándar para un valor de ubicación o de herramienta de inspección o una línea de entrada.

La herramienta de matemáticas & lógica Estadísticas es útil si desea acumular información estadística sobre el resultado de una determinada herramienta para analizar su proceso de fabricación, por ejemplo.

  1. Configuración de la herramienta de matemáticas & lógica Estadísticas
  2. Ajuste de los parámetros de la herramienta de matemáticas & lógica Estadísticas
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Estadísticas


Configuración de la herramienta de matemáticas y lógica Estadísticas

Una vez agregada la herramienta, deberá definir el valor a procesar y configurar los parámetros de la herramienta.

  1. Configure los ajustes de la ficha General para adaptarlos a su aplicación.
  2. Haga clic en la ficha Ajustes para definir un valor para el cual acumular estadísticas; después de agregar la herramienta, EasyBuilder examinará su aplicación y listará los valores que se pueden referenciar en el parámetro Último valor. Seleccione un valor y configure los demás parámetros de la ficha.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas y lógica para estadísticas

Una vez agregada la herramienta, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica para estadísticas consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Tabla

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Estadísticas - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Estad_1" (si se trata de la primera herramienta de matemáticas & lógica Estadísticas agregada a la tarea; de lo contrario, se incrementará, es decir, "Estad_2", "Estad_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas y lógica para estadísticas - ficha Ajustes

Closed Último valor

Define qué valor computará la herramienta; la selección predeterminada es "No definido", es decir, no acumular ninguna estadística. Para acumular estadísticas correspondientes a esa herramienta o valor de entrada, seleccione un valor devuelto por una herramienta o entrada en la tarea.

Closed Pantalla

Define qué valor computado se mostrará: Último valor, Mínimo, Máximo, Promedio o StdDev (desviación típica). La selección predeterminada es Último valor.

Closed Resultado

Muestra el valor computado actual definido en el parámetro Visualización.

Closed Contar en modo sin conexión

Define si los resultados deben incluir adquisiciones que se produzcan cuando el sistema de visión In-Sight se encuentre sin conexión; de forma predeterminada, este ajuste está activado, por lo que se acumulan estadísticas cuando el sistema de visión está sin conexión. Desactive la casilla de verificación para acumular estadísticas sólo cuando el sistema de visión In-Sight se encuentre en línea.

Closed Botón Restablecer

Pone a cero la acumulación de datos.

Closed Restablecimiento en línea

Define si la herramienta restablecerá automáticamente la acumulación de datos cada vez que el sistema de visión In-Sight se ponga en línea; de forma predeterminada, este ajuste está desactivado, por lo que el restablecimiento deberá efectuarse manualmente.

Closed Restablecimiento de carga de tareas

Define si la herramienta restablecerá automáticamente la acumulación de datos cada vez que el sistema de visión In-Sight cargue la tarea que contiene la herramienta; de forma predeterminada, este ajuste está desactivado, por lo que el restablecimiento deberá efectuarse manualmente.


Herramienta de matemáticas y lógica para estadísticas - Tabla

La tabla de la herramienta de matemáticas y lógica para estadísticas muestra los resultados acumulados para el valor definido en el parámetro Último valor de la ficha Ajustes.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Estadísticas

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Recuento_Sin_Conexion | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Visualización | I | X | Entrada/Salida
Restablecimiento_Externo | I |  | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Restablecimiento_Carga_Tarea | I | X | Entrada/Salida
Restablecimiento_En_Linea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Ultimo_Valor | FP | X | Salida
Máximo | FP | X | Salida
Promedio | FP | X | Salida
Mínimo | FP | X | Salida
Numero_De_Muestras | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | FP | X | Salida
Estado | FP | X | Salida
Dis_Est | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Restablecimiento | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Recuento_Sin_Conexion | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Visualización | I | X | X | Entrada/Salida
Restablecimiento_Externo | I | X |  | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Restablecimiento_Carga_Tarea | I | X | X | Entrada/Salida
Restablecimiento_En_Linea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Ultimo_Valor | FP | X | X | Salida
Máximo | FP | X | X | Salida
Promedio | FP | X | X | Salida
Mínimo | FP | X | X | Salida
Numero_De_Muestras | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | FP | X | X | Salida
Estado | FP | X | X | Salida
Dis_Est | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Restablecimiento | A |  | X |


Herramientas de matemáticas y lógica - Herramienta Grupo

La herramienta de matemáticas y lógica Grupo combina las herramientas de ubicación y/o de inspección en un grupo y crea un estado de habilitación compartido entre las herramientas del grupo, vinculando su ejecución.

La herramienta de matemáticas y lógica Grupo es útil cuando se utilizan varias herramientas para determinar si una determinada característica del producto produce una aceptación, para tareas que requieren múltiples adquisiciones o tareas que contienen un gran número de herramientas, por ejemplo.

  1. Configuración de la herramienta de matemáticas y lógica Grupo
  2. Ajuste de los parámetros de la herramienta de matemáticas y lógica Grupo
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas y lógica Grupo


Configuración de la herramienta de matemáticas y lógica Grupo

Nota: Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas. Antes de agregar esta herramienta, ensamble las demás herramientas de ubicación y/o de inspección que se utilizarán como entradas de esta herramienta; de lo contrario, no podrá construir expresiones hasta que haya añadido y configurado las herramientas de ubicación y/o de inspección necesarias. Después podrá regresar a esta herramienta.

Una vez agregada la herramienta, deberá definir qué herramientas formarán parte del grupo.

  1. Una vez agregada la herramienta, EasyBuilder examinará su tarea y enumerará todas las herramientas de su tarea que aparecen en la columna izquierda de la ficha Grupo de herramientas.
  2. Seleccione las herramientas que desee tener en el grupo (para seleccionar individualmente varias herramientas, mantenga presionada la tecla Ctrl; para seleccionar una serie de herramientas consecutivas, mantenga presionada la tecla MAYÚS), y presione el botón Agregar.
  3. Cuando haya completado su grupo, puede seleccionar la ficha Habilitar expresión, en la que podrá construir una expresión personalizada que proporcione la lógica necesaria para controlar la ejecución del grupo. De forma predeterminada, Expresión tiene asignado el valor 1, lo que significa que el grupo siempre está habilitado.
  4. Con la herramienta configurada inicialmente, cargue varias imágenes y ajuste los parámetros de la herramienta según convenga para compensar los rangos de variaciones previstos.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas y lógica para grupos

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica para grupos consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Grupo de herramientas
  • Ficha Habilitar expresión

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Grupo - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Grupo_1" (si se trata de la primera herramienta de matemáticas & lógica Grupo agregada a la tarea; de lo contrario, se incrementará, es decir, "Grupo_2", "Grupo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Nota: Si ha configurado la ficha Habilitar expresión para utilizar una expresión, el parámetro Herramienta habilitada se debe fijar en "Expresión" para que funcione correctamente.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas y lógica para grupos - ficha Ajustes

Closed ID de grupo

El número ID de grupo se utiliza para indicar un fallo cuando fallan las herramientas de la herramienta de matemáticas y lógica para grupos. La herramienta de matemáticas y lógica para grupos devuelve 0 cuando la herramienta equivale a una aceptación, y el número de ID del grupo cuando la herramienta equivale a un rechazo. La ID de grupo abarca de 1 a 9.999.999; de forma predeterminada, la ID de grupo es 10, y no se incrementa al agregar una nueva herramienta de matemáticas y lógica para grupos.


Herramienta de matemáticas y lógica para grupos - ficha Grupo de herramientas

La ficha Grupo de herramientas permite agregar y quitar herramientas en la herramienta de matemáticas y lógica para grupos seleccionada.

La lista del lado izquierdo muestra las herramientas no incluidas en el grupo, mientras que la del lado derecho muestra las herramientas incluidas. De forma predeterminada, la lista del lado derecho está vacía.

Closed Botón Agregar

Al seleccionar una herramienta en el lado izquierdo se habilita el botón Agregar.

  • Las herramientas se pueden agregar individualmente seleccionando una herramienta y presionando el botón Agregar.
  • Para seleccionar varias herramientas no consecutivas, mantenga presionada la tecla Ctrl, resalte las herramientas individualmente y luego presione el botón Agregar.
  • Para seleccionar varias herramientas consecutivas en una lista, mantenga presionada la tecla MAYÚS, resalte la primera herramienta y luego la última herramienta, y presione el botón Agregar.
Closed Botón Eliminar

Al seleccionar una herramienta en el lado derecho, se habilita el botón Eliminar.

  • Las herramientas se pueden quitar individualmente seleccionando una herramienta y presionando el botón Eliminar.
  • Para seleccionar varias herramientas no consecutivas, mantenga presionada la tecla Ctrl, resalte las herramientas individualmente y luego presione el botón Eliminar .
  • Para seleccionar varias herramientas consecutivas en una lista, mantenga presionada la tecla MAYÚS, resalte la primera herramienta y luego la última herramienta, y presione el botón Eliminar .
Notas:
  • Una herramienta sólo puede pertenecer a una herramienta de matemáticas y lógica para grupos. Para poder agregar una herramienta desde una herramienta de matemáticas y lógica para grupos a otra herramienta de matemáticas y lógica para grupos, primero se debe quitar de la primera herramienta de matemáticas y lógica para grupos antes de poder añadirla a la otra herramienta de matemáticas y lógica para grupos.
  • Una herramienta de matemáticas y lógica para grupos no puede contener otra herramienta de matemáticas y lógica para grupos.
  • Al copiar y pegar una herramienta de matemáticas y lógica para grupos, también se copiarán y pegarán todas las herramientas incluidas ella.
  • Al eliminar una herramienta de matemáticas y lógica para grupos primero se solicitará su confirmación; al eliminar una herramienta de matemáticas y lógica para grupos se eliminan todas las herramientas incluidas en ella. Si no desea que se eliminen las herramientas del grupo, deberá quitarlas del grupo antes de eliminar la herramienta de matemáticas y lógica para grupos.


Herramienta de matemáticas y lógica para grupos - ficha Habilitar expresión

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

La ficha Habilitar expresión se utiliza para construir una fórmula matemática que determine la ejecución de la herramienta; de forma predeterminada, Expresión tiene el valor 1, lo que significa que la herramienta siempre se ejecutará asociada a un disparador de adquisición. Para activar este control, el control Herramienta habilitada de la ficha General se debe ajustar a Expresión.

Sensores de visión In-Sight 2000-130/130C

Closed Expresión

El cuadro de texto Expresión se utiliza para generar una fórmula lógica de resultados de aceptaciones y rechazos de herramientas. Utilice el árbol de símbolos de datos de tareas y de herramientas para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en ellos o bien resaltándolos y presionando el botón Insertar.

Nota: Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.

Closed Árbol de símbolos de datos de tareas y de herramientas

El árbol de símbolos de datos de tareas y de herramientas contiene la salida de resultados de aceptación y rechazo de la herramienta por ubicación y/o por herramientas de inspección. Los datos de tareas y de herramientas son referencias simbólicas a los valores que contienen. Puede añadir símbolos a la expresión mediante uno de estos dos métodos:

  • Desplegar el árbol, seleccionar la referencia simbólica deseada y presionar el botón Ins.
  • Desplegar el árbol y hacer doble clic en la referencia simbólica deseada.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Insertar se utiliza para colocar símbolos en la expresión. Seleccione el símbolo que desee y presione el botón Insertar para agregar el símbolo a la expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis, AND, OR y NOT

Los botones Abrir paréntesis, Coma, Cerrar paréntesis, AND, OR y NOT se utilizan para generar fórmulas. Presione el botón pertinente para agregarlo a la fórmula.

Closed Botón Eliminar

El botón Eliminar se utiliza para eliminar las palabras o los símbolos resaltados de la expresión. Resalte la palabra o el símbolo que desee y presione Eliminar.

Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M

Nota: Para asociar la ejecución de una herramienta de matemáticas y lógica para grupos y de una herramienta de matemáticas y lógica para secuencias, la expresión de la herramienta de matemáticas y lógica para grupos se debe ajustar a la herramienta de matemáticas y lógica para secuencias (por ejemplo, "Sequence_1.Current_Step=1") y el control Herramienta habilitada de la ficha General se debe ajustar a Expresión.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Grupo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensores de visión In-Sight de la serie 2000, salvo el sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en los sensores de visión In-Sight de la serie 2000.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada
Tiempo_Ejecucion | FP | X |
Recuento_Rechazos | I | X |
Incluir_En_Pasada_Tarea | I | X | Entrada
Recuento_Aceptaciones | I | X |
Estado | I | X |
Herramienta_Habilitada | I | X |
Herramienta_Estado_Habilitado | I | X | Entrada
Rechazo | I |  | Salida
Aceptación | I |  | Salida

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
ID_Grupo | I | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Codigo_Fallo | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
ID_Grupo | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Codigo_Fallo | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de matemáticas y lógica - Secuencia

La herramienta de matemáticas y lógica Secuencia define el número de pasos de las tareas que precisan múltiples adquisiciones de imágenes o etapas del proceso de ensamblaje; esta herramienta se utiliza conjuntamente con la herramienta de matemáticas y lógica Grupo para controlar la ejecución secuencial de las herramientas del grupo.

La herramienta de matemáticas y lógica Secuencia resulta útil para sincronizar la adquisición de imágenes o la ejecución de herramientas de inspección basándose en la secuencia de su proceso de ensamblaje o fabricación. Por ejemplo, si está fabricando una pieza y desea inspeccionarla durante las distintas etapas de su ensamblaje para decidir si conviene o no continuar, basándose en los resultados de una determinada secuencia del proceso de ensamblaje.

  1. Configuración de la herramienta de matemáticas y lógica Secuencia
  2. Ajuste de los parámetros de la herramienta de matemáticas y lógica Secuencia
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas y lógica Secuencia


Configuración de la herramienta de matemáticas y lógica Secuencia

Una vez agregada la herramienta, deberá configurar los parámetros de la herramienta.

  1. Configure los ajustes de la ficha General para adaptarlos a su aplicación.
  2. Haga clic en la ficha Ajustes y configure los parámetros para adaptarlos a su aplicación.

Nota: Para asociar la ejecución de una herramienta de matemáticas y lógica Grupo y de una herramienta de matemáticas y lógica Secuencia, la Expresión de la herramienta de matemáticas y lógica Grupo se debe construir utilizando el símbolo del paso actual (Current_Step) de la herramienta de matemáticas y lógica Secuencia, es decir: Group_1.Enable=Sequence_1.Current_Step=1

  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas y lógica para secuencias

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica para secuencias consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Secuencia - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Paso_1" (si se trata de la primera herramienta de matemáticas & lógica Secuencia agregada a la tarea; de lo contrario, se incrementará, es decir, "Paso_2", "Paso_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas y lógica para secuencias - ficha Ajustes

Closed Pasos

Define el número de pasos controlados por la herramienta; de forma predeterminada, se utilizan 4 pasos.

Closed Botón Restablecer paso

Vuelve a poner a 0 la secuencia y la reinicia comenzando por el paso inicial de la siguiente adquisición.

Closed Paso siguiente habilitado

Define si el parámetro Paso siguiente será controlado o no por un dispositivo externo; de forma predeterminada, este ajuste está desactivado, siendo incontrolable por un dispositivo externo. Con este parámetro activado, el número de paso enviado a la herramienta desde el dispositivo externo pasará a ser el Paso actual en la siguiente adquisición. En esta configuración los pasos no necesitan ejecutarse secuencialmente, pudiendo omitirse algunos en función del número de paso que se introduzca (por ejemplo, si el número de pasos fuese 6 y la herramienta se encontrase actualmente en el paso 2 al recibir 5 como Paso siguiente, se omitirían los pasos 3 y 4).

Closed Paso siguiente

Define qué paso debe comenzar el paso siguiente en la secuencia; de forma predeterminada, es 1. Este control sólo puede habilitarse si el parámetro Paso siguiente habilitado está activado. Para restablecer la herramienta desde un dispositivo externo, como un PLC o un panel de interfaz de operador de VisionView®, active la casilla de verificación Paso siguiente habilitado y configure el tipo de dato Next_Step del parámetro Paso siguiente en el paso Comunicaciones.

Closed Paso actual

Comunica el paso activo; de forma predeterminada, se muestra 1.000 como definición del paso actual.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas y lógica Secuencia

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
External_Reset | I | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Next_Step | I | X | X | Entrada/Salida
Next_Step_Enabled | I | X | X | Entrada/Salida
Pasos | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Current_Step | FP | X | X | Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Reset_Step | A | X | X |


Herramientas de matemáticas & lógica - Calcular punto

La herramienta de matemáticas & lógica Calcular punto se utiliza para calcular un punto en la imagen en función de las expresiones matemáticas relacionadas con las salidas de otras herramientas de Ubicación y/o Inspección, y a la que otras herramientas pueden hacer referencia. La herramienta informa de las coordenadas X e Y del punto calculado.

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.

La herramienta de matemáticas & lógica Calcular punto es útil si desea identificar mediante programación un punto en la imagen que puede ser referenciado por otras herramientas, frente a un punto estático definido gráficamente en la imagen, como la herramienta de geometría para el punto definido por el usuario. Por ejemplo, si desea que el punto se sitúe en la imagen en función del resultado de una función matemática o del resultado de una determinada herramienta, como el punto medio de un margen encontrado por una Herramienta de presencia/ausencia Margen, la herramienta de matemáticas & lógica Calcular punto se puede formar para utilizar los resultados de la herramienta como entradas para calcular el punto, y la ubicación del punto en las modificaciones de la imagen para reflejar la salida de las herramientas referenciadas. El punto calculado también lo pueden utilizar las herramientas de matemáticas & lógica Matemáticas para tomar decisiones lógicas adicionales según el punto.

  1. Configuración de la herramienta de matemáticas & lógica Calcular punto
  2. Ajuste de los parámetros de la herramienta de matemáticas & lógica Calcular punto
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Calcular punto


Configuración de la herramienta de matemáticas & lógica Calcular punto

Nota: Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas. Antes de agregar esta herramienta, ensamble las demás herramientas de ubicación y/o de inspección que se utilizarán como entradas de esta herramienta; de lo contrario, no podrá construir expresiones hasta que haya añadido y configurado las herramientas de ubicación y/o de inspección necesarias. Después podrá regresar a esta herramienta.

Una vez agregada la herramienta, deberá generar la expresión para los valores X e Y.

  1. Genere cada expresión seleccionando y después introduciendo las funciones matemáticas de la parte izquierda del panel de ajustes y/o los valores (datos de herramienta y tarea) de la parte derecha. Para introducir una función o un valor en el editor de fórmulas de expresiones, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o el valor o presione el botón Insertar.
  2. Una vez generadas las expresiones, la herramienta insertará un icono de punto en la imagen que indica la ubicación del punto calculado.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de matemáticas y lógica Calcular matemática del punto

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica Calcular punto consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Fichas X e Y

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Calcular punto - icha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Punto_1" (si se trata de la primera herramienta de matemáticas & lógica Calcular punto agregada a la tarea; de lo contrario se incrementará, es decir, "Punto_2", "Punto_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular..

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas y lógica Calcular matemática del punto - ficha Ajustes

Closed Resultado

Muestra el resultado de las Expresiones X e Y calculadas.


Herramienta de matemáticas & lógica Calcular punto - fichas X, Y

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Las fichas X e Y se utilizan para generar las fórmulas matemáticas que definirán las coordenadas X e Y del punto.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Calcular punto

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Rechazo | FP |  | Salida
Aceptación | FP |  | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Descripción | S | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Recuento_Rechazos | FP | X | Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Recuento_Aceptaciones | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Rechazo | FP | X |  | Salida
Aceptación | FP | X |  | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Descripción | S | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Recuento_Rechazos | FP | X | X | Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Recuento_Aceptaciones | FP | X | X | Salida


Herramientas de matemáticas y lógica - Variables

La herramienta de matemáticas y lógica Variables define valores de número entero, coma flotante o cadena de texto que se pueden introducir en la tarea desde un dispositivo externo; estos valores pueden ser referenciados después por otras herramientas de ubicación o de inspección, o por dispositivos externos tales como un PLC o un panel de interfaz de operador de VisionView®.

La herramienta de matemáticas y lógica Variables es útil cuando se desea introducir un valor en una herramienta de ubicación o de inspección desde un dispositivo externo, como un PLC, o como valor en una expresión de una herramienta de matemáticas y lógica Matemáticas o Grupo. Por ejemplo, si en una aplicación quería introducir una cadena de texto para una herramienta de identificación Leer texto, un valor entero para controlar el número de blobs buscados por una herramienta Recuento de blobs o un valor de coma flotante como parte de la fórmula de ejecución de una herramienta de matemáticas y lógica Grupo, estos valores se pueden crear en la herramienta de matemáticas y lógica Variables y luego referenciarse simbólicamente desde las demás herramientas, o desde el paso Comunicaciones.

  1. Configuración de la herramienta de matemáticas y lógica Variables
  2. Ajuste de los parámetros de la herramienta de matemáticas y lógica Variables
  3. Uso de las propiedades de entrada/salida de la herramienta de matemáticas y lógica Variables


Configuración de la herramienta de matemáticas & lógica Variables

Una vez agregada la herramienta, deberá definir los valores que se utilizarán como variables de entrada.

  1. Configure los ajustes en la ficha General para adaptarlos a su aplicación.
  2. En el panel de ajustes, junto a la ficha General, se encuentra la tabla de variables de entrada. Presione el botón Agregar booleano si se trata de un valor lógico booleano; presione el botón Agregar entero si el valor es un entero; presione el botón Agregar coma flotante si se trata de un valor de coma flotante; presione el botón Agregar cadena si el valor es una cadena de texto.
  3. Una vez agregadas las variables de entrada, puede personalizarlas para adaptarlas a su aplicación específica.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.

  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.

    Nota: Para quitar una variable de la lista, marque la casilla de verificación junto a la variable y después presione el botón Eliminar (debe haberse marcado la casilla de verificación para activar el botón Eliminar).


Ajuste de los parámetros de la herramienta de matemáticas y lógica para variables

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de matemáticas y lógica para variables consta de los siguientes elementos:

  • Ficha General
  • Tabla Variables de entrada

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de matemáticas & lógica Variables - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Variables_1" (si se trata de la primera herramienta de matemáticas & lógica Variables agregada a la tarea; de lo contrario, se incrementará, es decir, "Variables_2", "Variables_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de matemáticas y lógica para variables - Tabla Variables de entrada

La tabla Variables de entrada de la herramienta de matemáticas y lógica para variables se utiliza para agregar, modificar y eliminar variables de entrada. Se pueden crear hasta 32 variables de entrada por cada herramienta de matemáticas y lógica para variables.

Closed Botón Agregar booleano

Pulse el botón Agregar booleano si se trata de un valor lógico booleano; la opción predeterminada es que se agregue el booleano 0 (marque la casilla de la derecha para definir el valor booleano en 1) y el nombre asignado es Boolean0 (si es el primer valor booleano agregado a la herramienta; en caso contrario, el número va incrementando a "Boolean1", "Boolean2", etc.). Personalice su valor asignándole un nombre relacionado con su aplicación en particular.

Closed Botón Agregar número entero

Presione el botón Agregar número entero si su valor es un número entero; de forma predeterminada, el número entero agregado es 0 y el nombre asignado es "Integer0" (si se trata del primer número entero añadido a la herramienta. Con cada nuevo número añadido, el valor del sufijo se incrementará, es decir, "Integer1", "Integer2", etc.). Personalice su valor asignándole un nombre relacionado con su aplicación en particular. Los números enteros pueden abarcar de 9.999.999 a -9.999.999.

Closed Botón Agregar coma flotante

Presione el botón Agregar coma flotante si su valor es un número de coma flotante; de forma predeterminada, el número de coma flotante agregado es 0 y el nombre asignado es "Float0" (si se trata del primer número de coma flotante añadido a la herramienta. Con cada nuevo número añadido, el valor del sufijo se incrementará, es decir, "Float1", "Float2", etc.). Personalice su valor asignándole un nombre relacionado con su aplicación en particular. Los números de coma flotante pueden abarcar de 9.999.999 a -9.999.999.

Closed Botón Agregar cadena

Presione el botón Agregar cadena si su valor es una cadena de texto; de forma predeterminada, el cuadro de texto aparece vacío y el nombre asignado es "String0" (si se trata de la primera cadena de texto añadida a la herramienta. Con cada nueva cadena añadida, el valor del sufijo se incrementará, es decir, "String1", "String2", etc.). Personalice su valor asignándole un nombre relacionado con su aplicación en particular. Las cadenas de texto pueden tener hasta 32 caracteres.

Closed Botón Eliminar

Presione el botón Eliminar para borrar un valor de la tabla. Para quitar una variable de la lista, active la casilla de verificación que hay a la izquierda de la variable y presione el botón Eliminar (para habilitar el botón Eliminar, esta casilla de verificación debe estar habilitada).


Uso de las propiedades de entrada/salida de la herramienta de matemáticas & lógica Variables

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Descripción | S | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Rechazo | FP |  | Salida
Aceptación | FP |  | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Recuento_Rechazos | FP | X | Salida
Float0 | FP | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Integer0 | I | X | Entrada/Salida
Recuento_Aceptaciones | FP | X | Salida
String0 | S | X | Entrada/Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Rechazo | FP | X |  | Salida
Aceptación | FP | X |  | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Recuento_Rechazos | FP | X | X | Salida
Float0 | FP | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Integer0 | I | X | X | Entrada/Salida
Recuento_Aceptaciones | FP | X | X | Salida
String0 | S | X | X | Entrada/Salida


Herramientas de trazado - Trazar arco

La Herramienta de trazado Trazar arco se utiliza para trazar un gráfico de arco en la imagen tomando como base expresiones matemáticas que definen los valores Centro X, Centro Y, Radio, Inicio Ángulo y Extensión del arco. La herramienta traza el gráfico en la imagen y devuelve los valores que definen el arco.

  1. Configuración de la herramienta de trazado Trazar arco
  2. Ajuste de los parámetros de la herramienta de trazado Trazar arco
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar arco

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.


Configuración de la herramienta de trazado Trazar arco

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar arco

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar arco consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Fichas de expresión X central, Y central, Radio, Ángulo inicial y Rango

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar arco - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Arco_1" (si se trata de la primera herramienta de Trazar arco agregada a la tarea; de lo contrario, se incrementará, es decir, "Arco_2", "Arco_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra los valores X, Y, Alto, Radio, Inicio Ángulo y Extensión del arco.


Herramienta de trazado Trazar arco - fichas Expresión de X central, Y central, radio, ángulo inicial y extensión

La herramienta de trazado Trazar arco consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X central, Y central, radio, ángulo inicial y extensión. Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar arco

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Arco.Radio | FP | X | Salida
Arco.Extension | FP | X | Salida
Inicio.Arco_Angulo | FP | X | Salida
Arco.X | FP | X | Salida
Arco.Y | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Arco.Radio | FP | X | X | Salida
Arco.Extension | FP | X | X | Salida
Inicio.Arco_Angulo | FP | X | X | Salida
Arco.X | FP | X | X | Salida
Arco.Y | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de trazado - Trazar círculo

La Herramienta de trazado Trazar círculo se utiliza para trazar un gráfico de círculo en la imagen tomando como base expresiones matemáticas que definen los valores X, Y y Radio del círculo. La herramienta traza el gráfico en la imagen y devuelve los valores que definen el círculo.

  1. Configuración de la herramienta de trazado Trazar círculo
  2. Ajuste de los parámetros de la herramienta de trazado Trazar círculo
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar círculo

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.


Configuración de la herramienta de trazado Trazar círculo

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar círculo

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar círculo consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Fichas de expresión X, Y y Radio

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar círculo - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Circulo_1" (si se trata de la primera herramienta de Trazar círculo agregada a la tarea; de lo contrario, se incrementará, es decir, "Circulo_2", "Circulo_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra los valores X, Y y Radio del círculo.


Herramienta de trazado Trazar círculo - fichas Expresión de X, Y y radio

La herramienta de trazado Trazar círculo consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X, Y y radio. Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar círculo

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Radio.Circulo | FP | X | Salida
Circulo.X | FP | X | Salida
Circulo.Y | FP | X | Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Radio.Circulo | FP | X | X | Salida
Circulo.X | FP | X | X | Salida
Circulo.Y | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de trazado - Trazar cruz

La Herramienta de trazado Trazar cruz se utiliza para trazar un gráfico de cruz en la imagen tomando como base expresiones matemáticas que definen los valores X, Y y Ángulo de la cruz. La herramienta traza el gráfico en la imagen y devuelve los valores que definen la cruz.

  1. Configuración de la herramienta de trazado Trazar cruz
  2. Ajuste de los parámetros de la herramienta de trazado Trazar cruz
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar cruz
Notas:
  • La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.
  • El resultado de la Herramienta de trazado Trazar cruzo puede utilizarse como un Elemento para otras herramientas.


Configuración de la herramienta de trazado Trazar cruz

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar cruz

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar cruz consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Fichas de expresión X, Y y Ángulo

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar cruz - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Cruz_1" (si se trata de la primera herramienta de Trazar cruz agregada a la tarea; de lo contrario, se incrementará, es decir, "Cruz_2", "Cruz_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra los valores X, Y y Ángulo de la cruz.


Herramienta de trazado Trazar cruz - fichas expresión de X, Y y ángulo

La herramienta de trazado Trazar cruz consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X, Y y ángulo Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar cruz

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Elemento.Angulo | FP | X | Salida
Elemento.X | FP | X | Salida
Elemento.Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Elemento.Angulo | FP | X | X | Salida
Elemento.X | FP | X | X | Salida
Elemento.Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de trazado - Trazar línea

La Herramienta de trazado Trazar línea se utiliza para trazar un gráfico de línea en la imagen tomando como base expresiones matemáticas que definen valores Inicio X, Inicio Y, Fin X y Fin Y de la línea. La herramienta traza el gráfico en la imagen y devuelve los valores que definen los valores de inicio y fin de la línea.

  1. Configuración de la herramienta de trazado Trazar línea
  2. Ajuste de los parámetros de la herramienta de trazado Trazar línea
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar línea

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.


Configuración de la herramienta de trazado Trazar línea

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar línea

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar línea consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Fichas de expresión X inicial, Y inicial, X final e Y final

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar línea - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Linea_1" (si se trata de la primera herramienta de Trazar línea agregada a la tarea; de lo contrario, se incrementará, es decir, "Linea_2", "Linea_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra los valores de inicio y de fin de X e Y de la línea.


Herramienta de trazado Trazar línea - fichas Expresión de X inicial, Y inicial, X final e Y final

La herramienta de trazado Trazar línea consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X inicial, Y inicial, X final e Y final. Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar línea

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Fin.Linea_X | FP | X | Salida
Fin.Linea_Y | FP | X | Salida
Inicio.Linea_X | FP | X | Salida
Inicio.Linea_Y | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Fin.Linea_X | FP | X | X | Salida
Fin.Linea_Y | FP | X | X | Salida
Inicio.Linea_X | FP | X | X | Salida
Inicio.Linea_Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de trazado - Trazar punto

La Herramienta de trazado Trazar punto se utiliza para trazar un gráfico de punto en la imagen tomando como base expresiones matemáticas que definen los valores X e Y del punto. La herramienta traza el gráfico en la imagen y devuelve los valores que definen el punto.

  1. Configuración de la herramienta de trazado Trazar punto
  2. Ajuste de los parámetros de la herramienta de trazado Trazar punto
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar punto

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.


Configuración de la herramienta de trazado Trazar punto

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar punto

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar punto consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Fichas de expresión X e Y

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar punto - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Punto_1" (si se trata de la primera herramienta de Trazar punto agregada a la tarea; de lo contrario, se incrementará, es decir, "Punto_2", "Punto_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra los valores X e Y del punto.


Herramienta de trazado Trazar punto - fichas Expresión de X e Y

La herramienta de trazado Trazar punto consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X e Y Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar punto

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Punto.X | FP | X | Salida
Punto.Y | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Punto.X | FP | X | X | Salida
Punto.Y | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de trazado - Trazar región

La Herramienta de trazado Trazar región se utiliza para trazar el gráfico de una región en la imagen tomando como base expresiones matemáticas que definen los valores X, Y, Alto, Ancho, Ángulo y Curva de la región. La herramienta traza el gráfico en la imagen y devuelve los valores que definen la ubicación, forma y tamaño de la región.

  1. Configuración de la herramienta de trazado Trazar región
  2. Ajuste de los parámetros de la herramienta de trazado Trazar región
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar región

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.


Configuración de la herramienta de trazado Trazar región

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar región

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar región consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Fichas de expresión X, Y, Altura, Anchura, Ángulo y Curva

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar región - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Region_1" (si se trata de la primera herramienta de Trazar región agregada a la tarea; de lo contrario, se incrementará, es decir, "Region_2", "Region_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra los valores X, Y, Alto, Ancho, Ángulo y Curva de la región.


Herramienta de trazado Trazar región - fichas Expresión de X, Y, altura, anchura, ángulo y curva

La herramienta de trazado Trazar región consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X, Y, altura, anchura, y curva. La ficha Expresión de X define la ubicación del primer vértice de la región; la ficha Expresión de Y define el otro vértice de la región; la ficha Expresión de Altura define la dimensión de la región a lo largo del eje X positivo; la ficha Expresión de anchura define la dimensión de la región a lo largo del eje Y positivo; la ficha Expresión de ángulo define el ángulo de la región en grados del eje X positivo al primer margen de la región; y la ficha Expresión de curva define el ángulo en grados entre los dos márgenes laterales de la región. Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar región

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de trazado - Trazar cadena

La Herramienta de trazado Trazar cadena se utiliza para trazar un gráfico de cadena de texto en la imagen tomando como base expresiones matemáticas que definen la cadena y sus valores de ubicación X e Y. La herramienta traza el gráfico en la imagen y devuelve los valores que definen la ubicación X/Y de la cadena.

  1. Configuración de la herramienta de trazado Trazar cadena
  2. Ajuste de los parámetros de la herramienta de trazado Trazar cadena
  3. Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar cadena

Nota: La herramienta devuelve los resultados en píxeles, a menos que la imagen se haya calibrado en unidades del mundo real (sistemas de visión In-Sight) o se utilice el control Campo de visión (anchura) (sensor de visión In-Sight 2000-23M) en el paso de aplicación Configurar imagen.


Configuración de la herramienta de trazado Trazar cadena

Cuando haya agregado la herramienta, deberá construir las expresiones que definirán el gráfico.

  1. Genere las expresiones matemáticas a utilizar para definir el gráfico eligiendo y luego introduciendo las funciones matemáticas del lado izquierdo del panel de ajustes y los valores (datos de herramientas y tareas) del lado derecho. Para introducir una función o un valor en el editor de fórmulas de la expresión, seleccione la función o el valor y presione la tecla Intro, haga doble clic en la función o presione el botón Ins.
  2. Una vez que haya generado las expresiones que definirán el gráfico trazado en la imagen, EasyBuilder procesará los datos y creará el gráfico.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de trazado Trazar cadena

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de trazado Trazar cadena consta de los siguientes elementos:

  • Fichas General y Ajustes
  • Ficha Expresión

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de trazado Trazar cadena - Fichas General y Ajustes

Closed Ficha General
Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Cadena_1" (si se trata de la primera herramienta de Trazar cadena agregada a la tarea; de lo contrario, se incrementará, es decir, "Cadena_2", "Cadena_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.

Closed Ficha Ajustes
Closed Resultado

Informa del resultado de las Fichas Expresión de la herramienta; muestra la cadena y sus valores X e Y.

Closed Color

Define el color del gráfico mostrado; el color predeterminado es el color utilizado actualmente por las demás herramientas de la tarea.

Closed Nombre de la fuente

Define el tipo de letra que se utilizará en el gráfico de la cadena; el valor predeterminado es Ariel.

Closed Estilo de la fuente

Define el estilo (normal, cursiva, negrita o negrita cursiva) de la fuente utilizada en el gráfico de la cadena; el valor predeterminado es Normal.

Closed Tamaño de la fuente

Define el tamaño de la fuente utilizada en el gráfico de la cadena; el valor predeterminado está fijado en 9 puntos.


Herramienta de trazado Trazar cadena - fichas Expresión de X, Y y cadena

La herramienta de trazado Trazar cadena consta de las siguientes fichas de expresión (que comparten todas los mismos controles) para generar el gráfico de trazado: Fichas Expresión de X, Y y cadena. Si alguna de las fichas de expresión se encuentra en estado de error (#ERR), el gráfico no será trazado en la imagen y se generará un mensaje de error indicando qué ficha(s) de expresión han sufrido dicho error.

Nota: Estos controles aparecen desactivados cuando el sistema de visión In-Sight está en línea.

Closed Expresión

El cuadro de texto Expresión se utiliza para construir una fórmula matemática que procesa resultados y datos de herramientas. Introduzca los datos tecleando el nombre de la función matemática o los datos de la tarea o herramienta, o bien utilice el árbol de herramientas de visión, el árbol de matemáticas, el árbol de textos o el árbol de acceso a datos de visión del lado izquierdo y el árbol de símbolos de datos de tareas y de herramientas del lado derecho para ensamblar la fórmula. Puede introducir elementos haciendo doble clic en los artículos o bien seleccionándolos y presionando el botón Ins.

Notas:
  • Si Expresión se refiere a una herramienta que ha sido eliminada, la referencia será reemplazada automáticamente por "Job.MissingArg" en la fórmula. La herramienta devolverá un rechazo hasta que se corrija la referencia.
  • A la hora de generar fórmulas, EasyBuilder no analiza correctamente los nombres de las herramientas que comienzan con una dirección de celda (por ejemplo A3_MiHerramienta o P10_HerramientaOrdenacion). Si necesita crear expresiones para esas herramientas, cambie el nombre de la herramienta antes de crear la fórmula.
Closed Herramientas de visión

El árbol de herramientas de visión contiene funciones de márgenes adicionales que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Margen, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Margen y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones matemáticas

El árbol de funciones matemáticas contiene funciones matemáticas que le permiten construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Matemáticas, seleccionar la función deseada y presionar el botón Ins.
  • Despliegar el árbol Matemáticas y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Árbol de funciones de texto

El árbol de funciones de texto contiene funciones que permiten formatear datos alfanuméricos para funciones de visualización y comunicación, y que puede utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol Texto, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol Texto y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.

Nota: La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.

Closed Acceso a datos de visión

El árbol de acceso a datos de visión contiene datos adicionales que no están disponibles de forma predeterminada y que se pueden utilizar para construir su Expresión. Existen tres métodos para agregar funciones a la expresión:

  • Desplegar el árbol de acceso a datos de visión, seleccionar la función deseada y presionar el botón Ins.
  • Desplegar el árbol de acceso a datos de visión y hacer doble clic en la función deseada.
  • Teclear el nombre de la función deseada directamente en el cuadro de texto de la expresión.
Notas:
  • La lista de funciones disponibles depende de la posición del cursor en Expresión. Si el cursor se encuentra en una posición de la expresión que impida la inclusión de una función matemática, las funciones correspondientes no estarán disponibles hasta que el cursor se sitúe en una posición en la que sí pueda incluirse.
  • EasyBuilder sólo admite funciones de acceso a datos de visión de Blobs, Márgenes y Patrones.
Closed Árbol de símbolos de datos de tareas y de herramientas

El Árbol de símbolos de datos de tareas y de herramientas contiene la salida de datos por Ubicación y/o Herramientas de inspección, así como líneas de Entrada y datos de tarea como, por ejemplo, los parámetros de adquisición de imágenes. Los datos de tareas y herramientas son referencias simbólicas a los valores que contienen. Puede agregar símbolos a la expresión mediante uno de estos tres métodos:

  • Expandir el árbol, seleccionar la referencia simbólica pertinente y presionar el botón Insertar.
  • Expandir el árbol y hacer doble clic en la referencia simbólica pertinente.
  • Mediante un teclado, escribir el nombre de la referencia simbólica pertinente directamente en el cuadro de texto de la expresión.

Nota: La lista de símbolos disponibles está supeditada a la colocación del cursor en la expresión. Si el cursor se encuentra en la expresión en una ubicación que prohíba agregar un símbolo, esos símbolos no estarán disponibles hasta que el cursor no esté en una ubicación en la que se puedan agregar.

Closed Botón Ins

El botón Ins permite incorporar funciones matemáticas y símbolos a la expresión. Para agregar la función o el símbolo a la expresión, seleccione la función matemática o el símbolo deseado y presione el botón Ins.

Nota: Este control opera conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; el botón Ins se activará siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.

Closed Botones Abrir paréntesis, Coma, Cerrar paréntesis

Los botones Abrir paréntesis, Coma y Cerrar paréntesis se utilizan para construir fórmulas matemáticas. Presione el botón apropiado para incluirlo en su fórmula.

Nota: Estos controles operan conjuntamente con el árbol de funciones matemáticas y con el árbol de símbolos de datos de tareas y de herramientas; los botones se activarán siempre que el elemento seleccionado en cualquier lista pueda introducirse en la posición correspondiente del cursor en el cuadro de texto Expresión.


Uso de las propiedades de entrada/salida de la herramienta de trazado Trazar cadena

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Color | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Resultado | S | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida


Herramientas de filtrado de imágenes - Filtro

Nota: Esta herramienta solo está disponible en sistemas de visión In-Sight que ejecuten la versión 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de filtrado de imágenes filtra una región de la imagen con técnicas de perfeccionamiento de imágenes locales y generales; genera una imagen de herramienta a la que pueden hacer referencia otras herramientas de ubicación o de inspección.

La herramienta de filtrado de imágenes Filtro es una herramienta multiuso y genera una imagen de salida en color o escala de grises que se utiliza para mejorar las imágenes con poco contraste y/o exponer características en una imagen. Esta herramienta ayuda a destacar las características deseadas y a minimizar las características no deseadas en la mayoría de los casos. Si se utiliza eficazmente, esta herramienta logra que las aplicaciones de inspección sean más confiables y reproducibles.

La herramienta de filtrado de imágenes Filtro ofrece una gran variedad de técnicas de perfeccionamiento de imágenes locales y generales; la técnica de perfeccionamiento de imágenes se define mediante la selección de un tipo de filtro.

  1. Configuración de la herramienta de filtrado de imágenes Filtro
  2. Ajuste de los parámetros de la herramienta de filtrado de imágenes Filtro
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Filtro


Configuración de la herramienta de filtrado de imágenes Filtro

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes Filtro

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes Filtro consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Filtro - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Filtro_1" (si se trata de la primera herramienta de filtrado de imágenes agregada a la tarea; en caso contrario, se incrementará, es decir, "Filtro_2", "Filtro_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes Filtro - ficha Ajustes

Closed Tipo de filtro

Define la técnica de perfeccionamiento de imágenes que se aplicará a la región. El resultado de la técnica de perfeccionamiento de imágenes se actualizará automáticamente en la región.

Nota: Para obtener información más detallada sobre cada tipo de filtro, consulte el tema Filtro.

Tipo de filtro | Descripcion
Binarizar (valor predeterminado)

Filtra la imagen sobre la base de un umbral de escala de grises para blanco (255) o negro (0); genera una imagen en la que los valores de píxeles de entrada iguales o superiores al valor de umbral son blancos y los valores por debajo del umbral son negros.

Nota: Cuando se utilice una imagen de entrada en color, la imagen de salida será una imagen en escala de grises.
Bottom Hat

Filtra todo excepto las características oscuras cuyo tamaño sea inferior al tamaño de filtro; genera una imagen que muestra las características oscuras como píxeles claros sobre un fondo oscuro.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Recorte

Filtra la imagen mediante comparación del valor de escala de grises de cada píxel por separado con un valor de escala de grises mínimo y máximo; genera una imagen en la que los extremos del espectro de escala de grises se eliminan, de modo que las características sean más uniformes.
Cerrar

Filtra las características oscuras cuyo tamaño sea menor que el tamaño de filtro; genera una imagen con un nivel de brillo general ligeramente aumentado.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Dilatación

Aumenta las características claras y reduce las características oscuras; genera una imagen con zonas mayores de píxeles claros. Este filtro es útil para eliminar manchas oscuras.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Magnitud del margen

Filtra las características oscuras y las claras; genera una imagen donde los márgenes se representan como píxeles claros. Esta operación considera los márgenes de orientación diagonal y es más lenta que la operación "Degradado completo".

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Ecualizar | Filtra sobre la base de una ecualización del histograma donde se actualizan los valores de escala de grises más frecuentes para crear una distribución más equilibrada; genera una imagen con el contraste aumentado.
Erosión

Aumenta las características oscuras y reduce las características claras; genera una imagen con zonas mayores de píxeles oscuros. Este filtro es útil para eliminar manchas claras.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Rellenar orificios oscuros | Los píxeles oscuros rodeados de píxeles claros se convierten en píxeles claros; genera una imagen en la que los orificios oscuros están rellenos.
Rellenar orificios claros | Los píxeles claros rodeados de píxeles oscuros se convierten en píxeles oscuros; genera una imagen en la que los orificios claros están rellenos.
Degradado completo | Filtra las características de margen vertical y horizontal; genera una imagen donde los márgenes de orientación vertical y horizontal se representan mediante píxeles claros. Esta operación no considera los márgenes de orientación diagonal pero es más rápida que la operación "Magnitud del margen".
Degradado horizontal | Filtra las características de margen horizontal; genera una imagen donde los márgenes de orientación horizontal se representan mediante píxeles claros.
Degradado vertical | Filtra las características de margen vertical; genera una imagen donde los márgenes de orientación vertical se representan mediante píxeles claros.
Distancia de escalas de grises

Filtra sobre la base del valor de escala de grises de cada píxel de salida como la diferencia entre el valor de escala de grises de cada píxel de entrada y el nivel de umbral; genera una imagen donde, por ejemplo, si el valor de píxel de entrada es 100 y el umbral es 25, el valor del píxel de salida es 75.
Paso alto

Filtra las características de margen y suprime las demás características; genera una imagen donde se mejoran los márgenes con relación a las zonas con un degradado de escala de grises más uniforme.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Invertir | Filtra sobre la base de una inversión de la escala de grises de los valores de píxeles; genera una imagen que es un "negativo" de la imagen de entrada.
Mediana local

Especifica una operación que calcula el valor de la mediana de los valores de píxeles en la vecindad del núcleo y, a continuación, utiliza ese resultado como el valor de píxeles de la imagen de salida.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Normalización mediana local

Especifica un medio para restar el fondo de una imagen; esta operación resta la mediana local de la imagen de entrada de dicha imagen de entrada, desplaza el resultado hacia la derecha por el valor de uno y, a continuación, suma 128 para generar el valor de píxeles de salida.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Paso bajo

Filtra las características de margen y desenfoca el margen con otras características; genera una imagen donde los márgenes están "suavizados" o desenfocados.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Máx. (Top Hat / Bottom Hat)

Especifica una operación que utiliza el máximo de las operaciones Top Hat y Bottom Hat.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Abrir

Filtra las características claras cuyo tamaño sea menor que el tamaño de filtro; genera una imagen con un nivel de brillo general ligeramente reducido.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Densidad óptica

Filtra sobre la base de una inversión de los valores de píxeles en una escala logarítmica; genera una imagen que revela la densidad de los objetos y las características al medir la cantidad de luz que pasa a través de ellos. Las características y los objetos más densos se representan mediante píxeles más claros en la imagen de salida.
Enfocar

Especifica una operación de "nitidez" que se utiliza para mejorar los márgenes. La operación evalúa el contraste entre los píxeles adyacentes y aumenta el contraste si el contraste es alto. Una diferencia de contraste grande entre los píxeles adyacentes suele representar un margen; no obstante, esta operación no debe utilizarse para localizar márgenes. Los efectos que tendrá la operación dependen del contenido y la resolución de la imagen.

  • El parámetro Ganancia especifica la intensidad del enfoque e indica al filtro que omita una determinada cantidad de diferencia entre los píxeles durante el enfoque, de modo que las zonas con textura ligera no se enfoquen en exceso.
Estirar | Filtra mediante un escalado lineal o un "estiramiento" de los valores de escala de grises; genera una imagen con el contraste aumentado.
Rango del umbral

Filtra sobre la base de un umbral binario (blanco y negro) que compara cada píxel de entrada con dos valores de umbral (mínimo y máximo) para determinar si el píxel de salida es blanco o negro; genera una imagen en la que, si el valor de píxel de entrada es igual o supera el mínimo o el máximo, el píxel de salida es blanco y, si el valor de píxel de entrada se encuentra dentro del mínimo o del máximo, el píxel de salida es negro.
Top Hat

Filtra todo excepto las características claras cuyo tamaño sea inferior al tamaño de filtro; genera una imagen que muestra las características claras como píxeles claros sobre un fondo oscuro.

Nota: Esta operación habilita los parámetros Filas del núcleo y Columnas del núcleo. El núcleo debe haberse generado a partir de valores enteros impares.
Closed Filas del núcleo

Especifica el número de filas (1–25; valor predeterminado = 3) del núcleo. Un núcleo es una matriz rectangular de números que define la vecindad o el entorno de procesamiento para las operaciones que se realizan en la ubicación de cada píxel de una imagen Los valores de escala de grises de los vecinos de un píxel definen el valor de escala de grises de esa ubicación de píxel en la imagen de salida.

Notas:

  • El núcleo no está ponderado.

  • El núcleo debe haberse generado a partir de valores enteros impares. Un núcleo atípico es de 3 x 3, pero el tamaño es arbitrario.

Este parámetro se habilita cuando Tipo de filtro se ajusta a uno de los siguientes parámetros:

  • Bottom Hat
  • Cerrar
  • Dilatación
  • Magnitud del margen
  • Erosión
  • Paso alto
  • Mediana local
  • Normalización mediana local
  • Paso bajo
  • Máx. (Top Hat / Bottom Hat)
  • Abrir
  • Top Hat
Closed Columnas del núcleo

Especifica el número de columnas (1–25; valor predeterminado = 3) del núcleo. Un núcleo es una matriz rectangular de números que define la vecindad o el entorno de procesamiento para las operaciones que se realizan en la ubicación de cada píxel de una imagen Los valores de escala de grises de los vecinos de un píxel definen el valor de escala de grises de esa ubicación de píxel en la imagen de salida.

Notas:

  • El núcleo no está ponderado.

  • El núcleo debe haberse generado a partir de valores enteros impares. Un núcleo atípico es de 3 x 3, pero el tamaño es arbitrario.

Este parámetro se habilita cuando Tipo de filtro se ajusta a uno de los siguientes parámetros:

  • Bottom Hat
  • Cerrar
  • Dilatación
  • Magnitud del margen
  • Erosión
  • Paso alto
  • Mediana local
  • Normalización mediana local
  • Paso bajo
  • Máx. (Top Hat / Bottom Hat)
  • Abrir
  • Top Hat
Closed Modo de umbral

Define si la herramienta determinará o no un nivel de umbral automáticamente cuando el tipo de filtro está ajustado a Binarizar, Distancia de escalas de grises o Rango del umbral.

  • Manual: Habilita el parámetro Umbral para especificar manualmente los niveles de umbral.
  • Automático (predeterminado):
    • Cuando el tipo de filtro está ajustado a Binarizar, la herramienta calcula automáticamente un nivel de umbral en función de los valores de escala de grises dentro de la región especificada.
    • Cuando el tipo de filtro está ajustado a Distancia de escalas de grises, la herramienta calculará automáticamente un nivel de umbral en función de la mediana del valor de escala de grises dentro de la región especificada.
    • Cuando el tipo de filtro está ajustado a Rango del umbral, se aplica automáticamente lo siguiente:
      • Si los valores de píxeles son menores que el ajuste del parámetro Mín. o los valores de píxeles son mayores que el ajuste del parámetro Máx., los valores de píxeles se establecerán como fondo.
      • Si los valores de píxeles se encuentran dentro de los ajustes de los parámetros Mín. y Máx., los valores de píxeles se establecerán como primer plano.
Closed Umbral

Especifica los niveles de umbral (0 a 255; valor predeterminado = 128) cuando el tipo de filtro está ajustado a Binarizar, Distancia de escalas de grises o Rango del umbral.

Closed Mín.

Especifica el valor mínimo de la escala de grises (0–255; valor predeterminado = 128) cuando el tipo de filtro está ajustado a Recortar, Estirar o Rango del umbral.

Closed Máx.

Especifica el valor máximo de la escala de grises (0–255; valor predeterminado = 128) cuando el tipo de filtro está ajustado a Recortar, Estirar o Rango del umbral.

Closed Ganancia

Especifica un valor de ganancia (0 a 10; valor predeterminado = 1) cuando el tipo de filtro está ajustado a Enfocar. Este parámetro especifica la intensidad del enfoque que se llevará a cabo mediante el control de la cantidad de mejora de contraste de los márgenes. Los píxeles en torno a un margen se llevan a sus valores mínimos o máximos para crear un aspecto más nítido del margen.

Closed Suavidad

Especifica el valor de suavidad (1 a 4; valor predeterminado = 1) del núcleo gausiano cuando el tipo de filtro está ajustado a Enfocar. La suavidad controla la desviación estándar del núcleo gausiano; unos valores de suavidad más altos tienen como consecuencia una "apertura" mayor de la operación de suavizado, lo que ayuda a enfocar las características.

Notas:
  • Gausiano hace referencia a una curva acampanada que se aplica como media ponderada a los píxeles en la región de interés (ROI).


Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Filtro

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Region | A |  | X |
Herramienta_Habilitada | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Tipo_Filtro | I | X | X | Entrada/Salida
Filas_Nucleo | I | X | X | Entrada/Salida
Columnas_Nucleo | I | X | X | Entrada/Salida
Umbral | I | X | X | Entrada/Salida
Modo_Umbral | I | X | X | Entrada/Salida
Mín. | I | X | X | Entrada/Salida
Máx. | I | X | X | Entrada/Salida
Ganancia | FP | X | X | Entrada/Salida
Suavidad | I | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Aceptacion | I | X |  | Salida
Rechazo | I | X |  | Salida
Estado | I | X | X | Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Recuento_Aceptaciones | I | X | X | Salida
Recuento_Rechazos | I | X | X | Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida


Herramientas de filtrado de imágenes - Punto

Nota: Esta herramienta solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de filtrado de imágenes Punto filtra una región de la imagen con una técnica de perfeccionamiento de imágenes "global" píxel a píxel, por ejemplo, umbrales, inversión, ecualización, recorte o estiramiento; genera una imagen de herramienta a la que pueden hacer referencia otras herramientas de ubicación o de inspección.

Las operaciones de perfeccionamiento de imágenes "globales" suponen la asignación de un valor de escala de grises al píxel de salida sobre la base de los valores individuales de escala de grises de los píxeles en la región de la herramienta.

La herramienta de filtrado de imágenes Punto resulta útil en situaciones en las que se necesita mejorar una zona de la imagen a fin de detectar mejor una característica para la inspección, por ejemplo, el recorte de zonas activas de una superficie para leer mejor los caracteres OCR o para estirar las características de una pieza y obtener una mejora de contraste.

  1. Configuración de la herramienta de filtrado de imágenes Punto
  2. Ajuste de los parámetros de la herramienta de filtrado de imágenes Punto
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Punto


Configuración de la herramienta de filtrado de imágenes Filtro de puntos

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Herramientas de filtrado de imágenes y herramientas de color - Imagen de herramienta

Las herramientas de filtrado de imágenes (Filtro, Vecino, Punto, Corrección de escenas, Color a escala de grises, Color a binario, Transformar y Comparar) y las herramientas de colores (herramientas de ubicación Blob de color y Blobs de color (1-un10), Recuento de píxeles de color y las herramientas de presencia/ausencia Blob de color, las herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), la herramienta de recuento Blobs de color, la herramienta de identificación Modelo de colores o la herramienta de filtrado de imágenes Color a binario) generan una imagen que se puede utilizar como entrada de imagen de herramienta de las herramientas de ubicación y de inspección.

El ajuste Imagen de herramienta se encuentra en la ficha General de todas las herramientas que aceptan imágenes distintas de la imagen de adquisición después de añadir a la tarea una herramienta que emite una Imagen de herramienta, o como opción de menú desplegable en el panel de ajustes Instrucciones al agregar una herramienta después de haber agregado una herramienta que emite Imagen de herramienta.

Cuando el parámetro Imagen de herramienta de una herramienta de ubicación o de inspección se define como herramienta que emite una Imagen de herramienta (recuerde que una herramienta de filtrado de imágenes también puede, a su vez, utilizar otra herramienta de filtrado de imágenes como entrada), dichas herramientas ejecutan su inspección utilizando la imagen filtrada, y sus regiones deben permanecer siempre dentro de los límites de la herramienta que emite la región Imagen de herramienta.

Para asignar el parámetro Imagen de la herramienta a una herramienta de filtrado de imágenes, primero agregue una herramienta de filtrado de imágenes; a continuación, regrese a la ficha General de la herramienta anterior y asigne el parámetro Imagen de la herramienta a la herramienta de filtrado de imágenes recién creada.

Nota: Después de agregar a una tarea una herramienta de filtrado de imágenes o de color que emite una imagen de herramienta, cada vez que se agrega una nueva herramienta que admite una imagen que no sea la imagen de adquisición, se pedirá al usuario que defina la imagen de entrada de la herramienta en el cuadro de grupo Instrucciones del panel de ajustes. La selección predeterminada es la imagen actual recién adquirida y no filtrada.


Ajuste de los parámetros de la herramienta de filtrado de imágenes "Filtro de puntos"

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes "Filtro de puntos" consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Fichas Antes/Después

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Punto - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Filtro_1" (si se trata de la primera herramienta de filtrado de imágenes agregada a la tarea; en caso contrario, se incrementará, es decir, "Filtro_2", "Filtro_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes Punto - ficha Ajustes

Closed Operacion

Define la técnica de perfeccionamiento de imágenes que se aplicará a la región. El resultado de la técnica de perfeccionamiento de imágenes se actualizará automáticamente en la región.

Operación | Descripcion
Binarizar (valor predeterminado) | Filtra la imagen sobre la base de un umbral de escala de grises para blanco (255) o negro (0); genera una imagen en la que los valores de píxeles de entrada iguales o superiores al valor de umbral son blancos y los valores por debajo del umbral son negros.
Recorte | Filtra la imagen mediante comparación del valor de escala de grises de cada píxel por separado con un valor de escala de grises mínimo y máximo; genera una imagen en la que los extremos del espectro de escala de grises se eliminan, de modo que las características sean más uniformes.
Ecualizar | Filtra sobre la base de una ecualización del histograma donde se actualizan los valores de escala de grises más frecuentes para crear una distribución más equilibrada; genera una imagen con el contraste aumentado.
Distancia de escalas de grises | Filtra sobre la base del valor de escala de grises de cada píxel de salida como la diferencia entre el valor de escala de grises de cada píxel de entrada y el nivel de umbral; genera una imagen donde, por ejemplo, si el valor de píxel de entrada es 100 y el umbral es 25, el valor del píxel de salida es 75.
Invertir | Filtra sobre la base de una inversión de la escala de grises de los valores de píxeles; genera una imagen que es un "negativo" de la imagen de entrada.
Rango del umbral | Filtra sobre la base de un umbral binario (blanco y negro) que compara cada píxel de entrada con dos valores de umbral (mínimo y máximo) para determinar si el píxel de salida es blanco o negro; genera una imagen en la que, si el valor de píxel de entrada es igual o supera el mínimo o el máximo, el píxel de salida es blanco y, si el valor de píxel de entrada se encuentra dentro del mínimo o del máximo, el píxel de salida es negro.
Densidad óptica | Filtra sobre la base de una inversión de los valores de píxeles en una escala logarítmica; genera una imagen que revela la densidad de los objetos y las características al medir la cantidad de luz que pasa a través de ellos. Las características y los objetos más densos se representan mediante píxeles más claros en la imagen de salida.
Estirar | Filtra mediante un escalado lineal o un "estiramiento" de los valores de escala de grises; genera una imagen con el contraste aumentado.
Closed Mínimo

Define el valor mínimo de la escala de grises (0 a 255) para las operaciones Recorte y Rango del umbral. Este control solo está habilitado si se selecciona una de las dos operaciones.

Closed Máximo

Define el valor máximo de la escala de grises (0 a 255) para las operaciones Recorte y Rango del umbral. Este control solo está habilitado si se selecciona una de las dos operaciones.

Closed Modo de umbral

Define el modo de determinar el valor de la escala de grises que segmenta la región de la imagen en píxeles negros y blancos cuando la operación está ajustada a Binarizar, Distancia de escalas de grises o Rango del umbral. Si se selecciona Automático (valor predeterminado = Automático), la herramienta creará un ajuste inteligente basado en la imagen cada vez que se adquiera una imagen, con un ajuste constante de los cambios de brillo de imagen a imagen. Si se selecciona Manual, el usuario introduce y ajusta el valor manualmente.

Closed Umbral

Define el valor de la escala de grises que separa los píxeles negros de los píxeles blancos (0 - 255 si está habilitado) para las operaciones Binarizar, Distancia de escalas de grises y Rango del umbral; los valores de píxeles que queden por debajo del umbral se clasifican como negros y los valores de píxeles que queden por encima de él se clasifican como blancos. De forma predeterminada, el control está desactivado y, para habilitarlo, es necesario ajustar el modo Rango del umbral a Manual. Utilice el gráfico para ajustar un valor óptimo para su aplicación.


Herramienta de filtrado de imágenes "Filtro de puntos" - ficha Ajustes

Las fichas Antes/Después representan en forma de histograma los valores de escala de grises correspondientes a los píxeles de la región. La ficha Antes muestra el histograma del área de la imagen antes de ser procesada y la ficha Después muestra el histograma del área una vez procesada.

  • El eje X del gráfico representa el número total de valores de la escala de grises (0 a 255, o 256 tonos de gris totales).
  • El eje Y del gráfico representa el número de píxeles en un valor de escala de grises dado, y la escala se establece visualizando el valor de escala de grises con el mayor número de píxeles.
  • La línea verde vertical indica el umbral que se está utilizando para separar la región de la imagen en píxeles blancos y negros; los valores a la izquierda de la línea se consideran negro y los valores a la derecha se consideran blanco.


Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Filtro de puntos

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Máximo | I | X | X | Entrada/Salida
Mínimo | I | X | X | Entrada/Salida
Operación | I | X | X | Entrada/Salida
Umbral | I | X | X | Entrada/Salida
Threshold_Mode | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida


Herramientas de filtrado de imágenes - Vecino

Nota: Esta herramienta solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de filtrado de imágenes Vecino filtra una región de la imagen con una técnica de perfeccionamiento de imágenes "vecinas o adyacentes" píxel a píxel, por ejemplo, contracción, ampliación, relleno, suavizado o perfeccionamiento de márgenes; genera una imagen de herramienta a la que pueden hacer referencia otras herramientas de ubicación o de inspección.

Las operaciones de perfeccionamiento de imágenes "vecinas" suponen la asignación de un valor de escala de grises al píxel de salida sobre la base de los valores de escala de grises de los píxeles "vecinos" en la región de la herramienta. El tamaño de la "vecindad" viene determinado por los parámetros para filtrar filas y columnas.

La herramienta de filtrado de imágenes Vecino resulta útil en situaciones en las que se necesita mejorar una zona de la imagen a fin de detectar mejor una característica para la inspección, por ejemplo, la disminución del resplandor de una superficie metálica para leer mejor un código de impresión por puntos o para ampliar el extremo claro del espectro de la escala de grises y eliminar manchas oscuras durante la lectura de caracteres OCR.

  1. Configuración de la herramienta de filtrado de imágenes Vecino
  2. Ajuste de los parámetros de la herramienta de filtrado de imágenes Vecino
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Vecino


Configuración de la herramienta de filtrado de imágenes Filtro vecino

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes "Filtro vecino"

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes "Filtro vecino" consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Vecino - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Filtro_1" (si se trata de la primera herramienta de filtrado de imágenes agregada a la tarea; en caso contrario, se incrementará, es decir, "Filtro_2", "Filtro_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes "Filtro vecino" - ficha Ajustes

Closed Operación

Define la técnica de perfeccionamiento de imágenes que se aplicará a la región. El resultado de la técnica de perfeccionamiento de imágenes se actualizará automáticamente dentro de la región.

Operación | Descripción
Bot Hat (el cierre de la imagen menos la imagen) | Filtra todo menos las características oscuras menores que el Tamaño del filtro; emite una imagen que muestra las características oscuras como píxeles claros sobre un fondo oscuro.
Cerrar | Filtra las características oscuras menores que el Tamaño del filtro; emite una imagen con un nivel total de luminosidad ligeramente aumentado.
Dilatar | Aumenta las características claras y reduce las características oscuras; emite una imagen con áreas más grandes de píxeles claros. Este filtro es útil para eliminar puntos o motas oscuros.
Magnitud del margen | Filtra características claras y oscuras; emite una imagen con los márgenes representados como píxeles claros. Esta operación detecta los márgenes orientados diagonalmente y es más lenta que la operación "Degradado completo".
Erosionar | Aumenta las características oscuras y reduce las características claras; emite una imagen con áreas más grandes de píxeles oscuros. Este filtro es útil para eliminar puntos o motas claros.
Rellenar agujeros oscuros | Los píxeles oscuros rodeados por píxeles claros se convierten en píxeles claros; emite una imagen con los agujeros oscuros rellenados.
Rellenar agujeros claros | Los píxeles claros rodeados por píxeles oscuros se convierten en píxeles oscuros; emite una imagen con los agujeros claros rellenados.
Degradado vertical | Filtra características de márgenes verticales; emite una imagen cuyos márgenes orientados verticalmente se representan mediante píxeles claros.
Degradado horizontal | Filtra características de márgenes horizontales; emite una imagen cuyos márgenes orientados horizontalmente se representan mediante píxeles claros.
Degradado completo | Filtra características de márgenes verticales y horizontales; emite una imagen cuyos márgenes orientados vertical y horizontalmente se representan mediante píxeles claros. Esta operación no tiene en cuenta los márgenes orientados diagonalmente, pero es más rápida que la operación "Magnitud del margen".
Paso alto | Filtra características de márgenes, suprimiendo otras características; emite una imagen con márgenes perfeccionados con respecto a las áreas que tienen un degradado de escala de grises más consistente.
Paso bajo (predeterminado) | Filtra características de márgenes y emborrona el margen con otras características; emite una imagen con los márgenes "suavizados" o emborronados.
Abrir | Filtra las características claras menores que el Tamaño del filtro; emite una imagen con un nivel total de luminosidad ligeramente reducido.
Top Hat (imagen menos la apertura de la imagen) | Filtra todo menos las características claras menores que el Tamaño del filtro; emite una imagen que muestra las características claras como píxeles claros sobre un fondo oscuro.
Closed Filtrar filas

Especifica el tamaño de la vecindad de procesamiento de imágenes en dirección horizontal.

Closed Filtrar columnas

Especifica el tamaño de la vecindad de procesamiento de imágenes en dirección vertical.


Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Filtro vecino

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Filter_Columns | I | X | X | Entrada/Salida
Filter_Rows | I | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Operación | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Región | A | X | X |


Herramientas de filtrado de imágenes - Corrección de escenas

Nota: Esta herramienta solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

La herramienta de filtrado de imágenes Corrección de escenas filtra una región de la imagen con una técnica de perfeccionamiento de imágenes "píxel a píxel adyacente" denominada "intensidad media"; genera una imagen de herramienta referenciable por otras herramientas de ubicación o de inspección.

La técnica de perfeccionamiento de imágenes "intensidad media" filtra las imágenes en función de la intensidad de los píxeles situados dentro de la vecindad de procesamiento, definida por los parámetros Número de filas y Número de columnas. Este filtro simula la eliminación de sombras e iluminación desigual de una imagen, comparando el valor de intensidad de cada píxel con la intensidad media de los píxeles existentes dentro de la vecindad de procesamiento. Las áreas de la imagen que presentan poca o ninguna variación se representarán en gris neutro, independientemente de su intensidad original. Los píxeles más oscuros que los circundantes aparecerán sombreados en un color más oscuro que el gris neutro, dependiendo de cuánto más oscuros sean que sus píxeles adyacentes. De igual modo, los píxeles que sean más claros que sus píxeles adyacentes aparecerán sombreados con un color más claro que el gris neutro. Los márgenes y las transiciones muy marcadas se mantendrán, como ocurre con la operación "high-pass".

La herramienta de filtrado de imágenes Corrección de escenas es útil para aplicaciones de iluminación desigual o sombreados en la imagen.

  1. Configuración de la herramienta de filtrado de imágenes Corrección de escenas
  2. Ajuste de los parámetros de la herramienta de filtrado de imágenes Corrección de escenas
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Corrección de escenas


Configuración de la herramienta de filtrado de imágenes Corrección de escenas

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes Corrección de escenas

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes Corrección de escenas consta de las siguientes fichas:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Corrección de escenas - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Filtro_1" (si se trata de la primera herramienta de filtrado de imágenes agregada a la tarea; en caso contrario, se incrementará, es decir, "Filtro_2", "Filtro_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes Corrección de escenas - ficha Ajustes

Closed Número de filas

Define el tamaño de la vecindad de procesamiento de imágenes (1-Altura máxima de la imagen, preajuste = 11) en la dirección horizontal.

Notas:
  • El valor máximo queda definido por el tamaño máximo del área de imagen del sistema de visión In-Sight (p. ej. 640 x 480, 1024 x 768 o 1600 x 1200).
  • Solo se pueden utilizar valores impares para definir el tamaño de la vecindad de procesamiento de imágenes. Si se introduce un valor par, se redondeará automáticamente hacia abajo.
Closed Número de columnas

Define el tamaño de la vecindad de procesamiento de imágenes (1-Ancho máximo de la imagen, preajuste = 11) en la dirección vertical.

Notas:
  • El valor máximo queda definido por el tamaño máximo del área de imagen del sistema de visión In-Sight (p. ej. 640 x 480, 1024 x 768 o 1600 x 1200).
  • Solo se pueden utilizar valores impares para definir el tamaño de la vecindad de procesamiento de imágenes. Si se introduce un valor par, se redondeará automáticamente hacia abajo.
Closed Tiempo de espera

Define el tiempo, en milisegundos (0 a 30000, preajuste = 0), durante el que la herramienta calculará la intensidad de la imagen antes de detenerse y generar un rechazo. Para desactivar el parámetro, ajústelo a 0.


Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Corrección de escenas

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripcion | S | X | X | Entrada/Salida
Filtras_Columnas | I | X | X | Entrada/Salida
Filtrar_Filas | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Operacion | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptacion | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Region | A | X | X |


Herramientas de filtrado de imágenes - Color a escala de grises

La herramienta de filtrado de imágenes Color a escala de grises filtra una región de la imagen convirtiendo cada píxel de color existente en la región a un valor de la escala de grises, basándose en la operación especificada; genera una Imagen de herramienta a la que se puede hacer referencia desde otras herramientas de ubicación o de inspección.

La herramienta Color a escala de grises convierte cada píxel de color existente en la región a un valor de escala de grises basándose en un filtro simple con un parámetro de color: "puro" rojo, verde o azul (RGB); matiz, saturación o intensidad (HSI), luminancia o interpolación del promedio ponderado de componentes RGB.

  1. Configuración de la herramienta de filtrado de imágenes Color a escala de grises
  2. Ajuste de los parámetros de la herramienta de filtrado de imágenes Color a escala de grises
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Color a escala de grises


Configuración de la herramienta de filtrado de imágenes Color a escala de grises

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes de color a escala de grises

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes de color a escala de grises consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Color a escala de grises - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "FiltroColor_1" (si se trata de la primera herramienta de color a binario agregada a la tarea; de lo contrario, se incrementará, es decir, "FiltroColor_2", "FiltroColor_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes de color a escala de grises - ficha Ajustes

Closed Operación
Operación | Descripción
Luminancia (ajuste predeterminado) | Emite una imagen de la luminancia. Conceptualmente, la luminancia está estrechamente relacionada con la intensidad, ya que es una medida de la cantidad de luz emitida o reflejada desde un área determinada; cuanta más luz emite un píxel en la imagen de entrada, más clara es su apariencia en la imagen de salida.
Rojo | Emite una imagen que filtra todos los componentes del píxel salvo el rojo (255,0,0). Cuanto más alto sea el valor rojo del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida.
Verde | Emite una imagen que filtra todos los componentes del píxel salvo el verde (0,255,0). Cuanto más alto sea el valor verde del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida.
Azul | Emite una imagen que filtra todos los componentes del píxel salvo el azul (0,0,255). Cuanto más alto sea el valor azul del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida.
Matiz | Emite una imagen que filtra todos los componentes del píxel salvo el matiz. Cuanto más alto sea el valor de matiz del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida.
Saturación | Emite una imagen que filtra todos los componentes del píxel salvo la saturación. Cuanto más alto sea el valor de saturación del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida.
Intensidad | Emite una imagen que filtra (excluye) todos los componentes del píxel salvo la intensidad, y permite determinar la intensidad media de los componentes RGB del píxel. Cuanto más alto sea el valor de intensidad del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida.
Interpolación | Emite un filtro de la imagen utilizando la interpolación, un promedio ponderado de los componentes rojo, verde y azul (RGB) de un píxel. Como con la operación de intensidad, el resultado permite filtrar excluyendo todos los componentes del píxel salvo el de intensidad. Cuanto más alto sea el valor de intensidad del píxel en la imagen de entrada, más clara será su apariencia en la imagen de salida. Sin embargo, la interpolación determina el promedio ponderado de intensidad de los componentes RGB, y es un filtro de conversión no estándar.


Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Color a escala de grises

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Operación | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Región | A | X | X |


Herramientas de filtrado de imágenes - Color a binario

La herramienta de filtrado de imágenes de color a binario filtra una región de la imagen convirtiendo a blanco los píxeles que coinciden con un modelo de colores activo, y el resto de píxeles a negro; genera una imagen de herramienta a la que se puede hacer referencia desde otra ubicación u otras herramientas de inspección.

La herramienta Color a binario establece primero una referencia a una biblioteca entrenada de modelos de colores y luego determina el número de píxeles presentes en la región que coinciden con los modelos de colores seleccionados y entrenados de la biblioteca. A continuación, la herramienta genera una imagen binaria de salida en escala de grises, en la que cada píxel que coincide con un modelo de colores activo se ajusta a blanco (255), mientras que los demás píxeles se ajustan a negro (0).

  1. Configuración de la herramienta de filtrado de imágenes Color a Binario
  2. Ajuste de los parámetros de la herramienta de filtrado de imágenes de color a binario
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Color a binario


Configuración de la herramienta de filtrado de imágenes Color a Binario

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez configurada la región de búsqueda, deberá configurar la Biblioteca de colores de la herramienta y activar los Modelo de colores apropiados:

  • Si se trata de la primera vez que se añade una herramienta de color, (herramientas de ubicación Blob de color y Blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario) primero deberá definir las bibliotecas de colores y sus modelos de colores.

  • Si previamente se añadió otra herramienta de color y desea utilizar una biblioteca de colores existente y los correspondientes modelos de colores entrenados, abra la ficha Ajustes, seleccione la biblioteca de colores deseada y después active los modelos de colores deseados activando las casillas correspondientes en la ficha Biblioteca.

  • De forma predeterminada, la herramienta generará automáticamente un rechazo mientras no se haya definido una biblioteca de colores. Si se ha definido una biblioteca de colores, la herramienta la utilizará automáticamente y activará todos los modelos de colores que contiene.

  4. Una vez definidos los modelos de colores y las bibliotecas de colores, la herramienta procesará la imagen. Todos los píxeles dentro de la región de búsqueda que coincidan con los modelos de colores seleccionados se volverán de color blanco (255), mientras que los píxeles que no coincidan con los modelos de colores seleccionados se mostrarán de color negro (0).

  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes de color a binario

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes de color a binario consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Biblioteca de colores

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Color a binario - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "FiltroColor_1" (si se trata de la primera herramienta de color a binario agregada a la tarea; de lo contrario, se incrementará, es decir, "FiltroColor_2", "FiltroColor_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes de color a binario - ficha Ajustes

Closed Entrenar color

Abre el diálogo Entrenamiento de ExtractColor, utilizado para definir los modelos de colores de la biblioteca de colores seleccionada.

Closed Biblioteca de colores

Define a qué Biblioteca de colores se referirá la herramienta. En la lista desplegable, seleccione qué Biblioteca de colores desea modificar y pulse el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor. Cada Biblioteca de colores puede contener hasta 100 Modelos de colores distintos, compuestos por Colores individuales.

Las tareas de EasyBuilder pueden contener hasta 5 Bibliotecas de colores, que se pueden compartir entre las herramientas siguientes:

  • Herramienta de ubicación "Blob de color"
  • Herramienta de ubicación "Blobs de color (1-10)"
  • Herramienta de presencia/ausencia "Recuento de píxeles de color"
  • Herramienta de medición "Área de blob de color"
  • Herramienta de medición "Áreas de blobs de color (1-10)"
  • Herramienta de recuento "Blobs de color"
  • Herramienta de identificación "Modelos de colores"
  • Herramienta de filtrado de imágenes "Color a binario"


Herramienta de filtrado de imágenes de color a binario - ficha Biblioteca de colores

Closed Lista de modelos de colores

Muestra una lista de sólo lectura de los modelos de colores contenidos en la biblioteca de colores seleccionada. Los modelos de colores se activan y desactivan marcando o desmarcando la casilla de verificación situada junto al nombre del modelo de colores.

Closed Tabla de colores

Muestra una tabla ordenada de sólo lectura de los colores contenidos en el modelo de colores seleccionado.

Closed Nombre del color

Muestra los nombres de los colores contenidos en el modelo de colores seleccionado.

Closed RGB

Muestra los valores RGB de los colores contenidos en el modelo de colores seleccionado.

Closed Operación

Muestra la operación (Sumar o Restar) de los colores contenidos en el modelo de colores seleccionado.


Uso de las propiedades de entrada/salida de la herramienta de filtrado de imágenes Color a binario

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nota: Al agregar una herramienta de color (herramientas de ubicación Blob de color y Blobs de color (1-10), herramientas de presencia/ausencia Recuento de píxeles de color y Blob, herramientas de medición Área de blob de color y Áreas de blobs de color (1-10), herramienta de recuento Blobs de color, herramienta de identificación Modelo de color o herramienta de filtrado de imágenes Color a binario), los nombres de las bibliotecas de colores definidas se mostrarán automáticamente y sus propiedades podrán incluirse como selecciones de OPC, EasyView o de datos de entrada/salida.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Color_Library | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
External_Model_Enable_Apply | I | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Modelo_Habilitar | I | X | X | Entrada/Salida
Model_Enable_Select | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Model_Enable_Apply | A | X | X |
Región | A | X | X |

Propiedades de ExtractColorLibrary_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Entrenar_evento | A | X | X | Entrada/Salida
Train_Model | S | X | X | Entrada/Salida
Train_Operation | I | X | X | Entrada/Salida
Train_Procedure | I | X | X |
Train_Region | A | X | X |

Propiedades de MatchColorLibrar_1-5

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Darker_Limit | FP | X | X | Entrada/Salida
Lighter_Limit | FP | X | X | Entrada/Salida
Train_Color | S | X | X | Entrada/Salida
Entrenar_evento | A | X | X |
Train_Region | A | X | X |


Herramientas de filtrado de imágenes - Transformar

La herramienta de filtrado Transformar imagen filtra la distorsión lineal, no lineal y/o de lentes de una región de la imagen y aplica la transformación entre unidades del mundo real y píxeles calibrados por Calibración de la cuadrícula en el paso Configurar imagen; genera una imagen de herramienta a la que se puede hacer referencia desde otras herramientas de ubicación y de inspección.

La herramienta de filtrado Transformar imagen trabaja conjuntamente con Calibración de la cuadrícula en el paso Configurar imagen para compensar y corregir distorsiones ópticas y devolver mediciones de gran precisión, así como para convertir unidades de píxeles en unidades de medida del mundo real, como milímetros o pulgadas. Esta herramienta y la Calibración de la cuadrícula permiten localizar más exactamente objetos en los márgenes de imágenes y proporcionan mayor flexibilidad de montaje, incluyendo la posibilidad de montar el sistema de visión In-Sight hasta a 45° con respecto a la superficie de inspección.

  1. Configuración de la herramienta de filtrado Transformar imagen
  2. Ajuste de los parámetros de la herramienta de filtrado Transformar imagen
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado Transformar imagen


Configuración de la herramienta de filtrado Transformar imagen

Nota: Antes de agregar esta herramienta, asegúrese de haber calibrado la imagen mediante Calibración de la cuadrícula en el paso Configurar imagen.

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes "Transformar"

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes "Transformar" consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Transformar - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Transformar_1" (si se trata de la primera herramienta de filtrado de imágenes Transformar agregada a la tarea; en caso contrario, se incrementará, es decir, "Transformar_2", "Transformar_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes "Transformar" - ficha Ajustes

Closed Escala de la imagen

Define la escala con la que se muestra la imagen transformada (0.01 a 10; valor predeterminado = 1.0).

Closed Centro de referencia

Define el punto de referencia del origen para la transformación; Centro de la imagen (predeterminado), que define el punto de referencia como el centro de la imagen, o Centro de la región, que define el punto de referencia como el centro de la región.

Closed Mostrar imagen

Define si se mostrará la imagen transformada en lugar de la imagen adquirida. De forma predeterminada, este parámetro está activado, y la imagen transformada se mostrará siempre.

Nota: Otras herramientas de ubicación y de inspección pueden seguir realizando sus inspecciones en imágenes adquiridas, sin necesidad de aplicar el filtro de transformación. Sin embargo, las correspondientes superposiciones gráficas pueden aparecer fuera de contexto en relación con la imagen transformada que se está mostrando. Estas superposiciones gráficas de la herramienta pueden ocultarse en Ejecutar tarea desactivando la opción Mostrar gráfico de la herramienta.


Uso de las propiedades de entrada/salida de la herramienta de filtrado Transformar imagen

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Margen_Rango | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Comparación_Píxeles | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Comparar | A | X | X |
Región | A | X | X |
Entrenar | A | X | X |


Herramientas de filtrado de imágenes - Comparar

La herramienta de filtrado Comparación de imágenes filtra una imagen comparándola con una imagen de la plantilla para generar una imagen de salida en escala de grises, en la que cada píxel representa la diferencia normalizada; genera una Imagen de herramienta a la que se puede hacer referencia desde otra ubicación o desde otras herramientas de inspección.

El proceso de mejora de imágenes por comparación funciona estableciendo correspondencias entre los píxeles de la imagen de la plantilla y los de la imagen de entrada, que seguidamente se comparan para generar una imagen de salida en escala de grises, en la cual los píxeles que no coinciden con la imagen de la plantilla se muestran como píxeles blancos.

La herramienta de filtrado Comparación de imágenes es útil para detectar defectos en piezas y objetos durante el proceso de fabricación. Por ejemplo, la herramienta de filtrado Comparación de imágenes se entrena con una pieza u objeto libre de defectos y luego compara esta imagen entrenada con cada imagen recién adquirida. A continuación, otras herramientas adicionales, como la herramienta de recuento de blobs, efectúan su inspección de la imagen de herramienta emitida por la herramienta de filtrado Comparación de imágenes, invirtiendo la lógica de la herramienta de recuento de blobs para que la herramienta comunique una aceptación si no cuenta ningún blob y comunique un rechazo en caso contrario.

  1. Configuración de la herramienta de filtrado Comparación de imágenes
  2. Ajuste de los parámetros de la herramienta de filtrado Comparación de imágenes
  3. Uso de las propiedades de entrada/salida de la herramienta de filtrado Comparación de imágenes


Configuración de la herramienta de filtrado Comparación de imágenes

Después de agregar la herramienta, deberá configurar la región de la imagen que definirá el área de la imagen que desee mejorar.

Nota: La herramienta funciona mejor en imágenes con poco o ningún ruido de fondo. Asegúrese de que las imágenes sean casi idénticas, es decir, de que la pieza u objeto se encuentre en la misma ubicación y de que el defecto, cuando aparezca, sea evidente y grande. Si la imagen contiene ruido, utilice una herramienta de filtrado de imágenes "Filtro de puntos" configurada para la operación Binarizar con el fin de eliminar la diferenciación de escala de grises en la imagen.

  1. Coloque la región de manera que los límites sólo abarquen el área de la imagen que desea filtrar: si la región contiene áreas que no deben filtrarse, pueden producirse resultados inexactos. Para acelerar el funcionamiento de la herramienta, cree regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que el área de la imagen a filtrar se encuentre más o menos en la misma ubicación en cada imagen.
  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de filtrado de imágenes por comparación

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de filtrado de imágenes por comparación consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Ficha Imagen entrenada

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de filtrado de imágenes Comparar - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Filtro_1" (si se trata de la primera herramienta de filtrado de imágenes agregada a la tarea; en caso contrario, se incrementará, es decir, "Filtro_2", "Filtro_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de filtrado de imágenes por comparación - ficha Ajustes

Closed Comparación de píxeles

Define el tipo de comparación de píxeles que se ejecutará al establecer la correspondencia entre la plantilla y la imagen de entrada: Vecino más cercano o Bilineal.

Vecino más cercano (el ajuste predeterminado) ejecuta una operación de correspondencia entre imágenes comparando cada píxel de la plantilla con su píxel más cercano en la imagen de entrada para calcular la diferencia normalizada entre ambos en la escala de grises. Este método de correspondencia de imágenes es más rápido, pero menos exacto.

Bilineal ejecuta una operación de correspondencia entre imágenes comparando cada píxel de la plantilla con un promedio ponderado (que representa el valor en la escala de grises de los cuatro píxeles más cercanos a la imagen de entrada) con el fin de calcular la diferencia normalizada de cada píxel en la escala de grises. Este método de correspondencia de imágenes es más exacto, pero también más lento.

Closed Rango de margen

Define el número de píxeles que se tolerará alrededor de un margen durante la comparación de imágenes (0-24; predeterminado = 3). Cuanto más alto sea este número, menor será la probabilidad de que los márgenes imperfectos se representen como diferencias en la imagen de salida.


Herramienta de filtrado de imágenes por comparación - ficha Imagen entrenada

La imagen visualizada en la ficha Imagen entrenada es una imagen en miniatura de la imagen del patrón Modelo. Presione el botón Región modelo para cambiar el tamaño o mover la región Modelo. A continuación, presione el botón Entrenar para volver a entrenar la imagen de la plantilla Modelo.


Uso de las propiedades de entrada/salida de la herramienta de filtrado Comparación de imágenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Descripción | S | X | X | Entrada/Salida
Imagen_Escala | FP | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Referencia_Centro | I | X | X | Entrada/Salida
Mostrar_Imagen | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Región | A | X | X |


Herramientas de detección de defectos - Defecto superficial

La herramienta de detección de defectos superficiales permite detectar pequeños defectos en base a variaciones de intensidad de los píxeles. Esta herramienta está diseñada para detectar defectos tales como rasguños, muescas, desgarros, manchas o astillas, tanto en escala de grises como en color.

La herramienta de detección de defectos superficiales está diseñada para detectar regiones con variaciones de intensidad y de color. La herramienta utiliza primero una operación interna de filtrado para resaltar los márgenes y las áreas con variaciones repentinas de color o de escala de grises, para luego aplicar el análisis de blobs con el fin de determinar si hay defectos presentes. La herramienta resulta ideal para aplicaciones en las que el área a inspeccionar de las piezas debe ser uniforme, de manera que cualquier cambio repentino en su intensidad se considera como defecto.

Si es necesario, la herramienta de defectos superficiales también dispone de una máscara de imagen para destacar las áreas de la imagen sujetas a inspección, excluyendo las demás áreas.

  1. Configuración de la herramienta de detección de defectos superficiales
    1. Configuración de la máscara de la herramienta de detección de defectos superficiales
  2. Ajuste de los parámetros de la herramienta de detección de defectos superficiales
  3. Uso de las propiedades de entrada/salida de la herramienta de detección de defectos superficiales


Configuración de la herramienta de detección de defectos Defecto superficial

La configuración de esta herramienta consiste en establecer los umbrales que se utilizarán para determinar la presencia o ausencia de defectos. Antes de comenzar, conviene cargar una base de datos con imágenes de la pieza a inspeccionar (en sus dos estados de aprobación y de rechazo). Para ello, cargue las imágenes desde un PC.

  1. Para comenzar, cargue una imagen de la pieza en su estado libre de errores. A continuación, añada la herramienta de defectos superficiales.

  2. Configure la región en la imagen. En el menú desplegable Tipo de región, seleccione el tipo de región: Rectángulo (valor predeterminado), Círculo, Espacio anular o Polígono. Posicione y configure la región de la imagen donde espere que aparezcan los defectos; asegúrese de que los límites de la región cubran tanto los defectos como sus posibles ubicaciones.

    Notas:
    • Para acelerar el funcionamiento de la herramienta, intente crear regiones pequeñas, ya que las regiones de gran tamaño tardan más tiempo en ser inspeccionadas. Si no está utilizando un elemento, asegúrese de que los defectos se encuentren aproximadamente en el mismo lugar en todas las imágenes o de que la región tenga un tamaño suficiente para contener el movimiento previsto de las características.
    • Después de añadir la herramienta, puede cambiar el tipo de región si hace clic con el botón derecho en la imagen y selecciona la forma que desee en la opción Modificar región por.
  3. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  4. Con la pieza en su estado libre de errores, ajuste los parámetros de la herramienta de manera que la herramienta no comunique ningún defecto. Utilice el parámetro Imagen visualizada en la ficha Candidatos a defectos para presentar información visual sobre cómo los ajustes de parámetros pueden influir en los resultados de la herramienta. Para comenzar, ajuste el parámetro Imagen visualizada a Candidatos a defectos, de manera que los defectos detectados queden encerrados en un recuadro rojo.

Nota: También puede crear una máscara para resaltar las zonas de la imagen destinadas a la inspección, excluyendo las demás zonas. Las máscaras son muy útiles para configurar un proceso de inspección que contenga textos, etiquetas u otras características que deban ignorarse.

  5. A la hora de ajustar los parámetros, comience por la región de la herramienta para asegurarse de que la región de interés (ROI) abarque correctamente el área por inspeccionar: no contiene características extrañas, como por ejemplo etiquetas, bordes de caracteres o logotipos. Si la inspección incluirá el borde de una pieza, la región debe situarse en paralelo al mismo (aplique el mismo principio a las regiones circulares, situando el arco de la región circular en paralelo al margen de la pieza).
  6. A continuación, intente ajustar los parámetros Factor de muestreo y Factor de suavizado. Aumente el parámetro "Muestreo" cuando quiera detectar defectos de degradado bajo o defectos grandes con poco contraste. Para evitar pequeños defectos falsos, aumente el parámetro "Factor de suavizado".
  7. Después de ajustar los parámetros, utilice las opciones de los parámetros Tipo de detección, Tamaño de detección y Eje de detección. Para la mayoría de aplicaciones, el parámetro Tipo de detección puede ajustarse a Rápido, con un Tamaño de detección de 1. Para aplicaciones con defectos claros, defectos oscuros o defectos claros y oscuros, ajuste el parámetro Tamaño de detección a un tamaño mayor que el radio del defecto a detectar. Si la región ha sido configurada para ser paralela a un margen, Eje de detección debe configurarse para estar en paralelo a Región.
  8. A continuación, ajuste los parámetros Área mínima de defectos, Área máxima de defectos y Contraste mínimo.
  9. Una vez que la herramienta consigue inspeccionar correctamente la pieza en su estado libre de errores, cargue una imagen de esa misma pieza con un defecto. Repita el proceso de ajuste de los parámetros hasta que la herramienta identifique correctamente los defectos deseados. Cargue otras imágenes de la pieza con defectos y ajuste los parámetros según sea necesario hasta que se identifiquen correctamente todos los defectos.
  10. Una vez identificados los defectos, vuelva a cargar las imágenes de la pieza en su estado libre de errores y asegúrese de que siga inspeccionándose correctamente como libre de errores. La herramienta estará lista para inspecciones en tiempo de ejecución desde el momento en que esté configurada correctamente.
  11. Por último, si lo desea, utilice las propiedades de entrada/salida de la herramienta para compartir datos de esta con otras herramientas y/o dispositivos externos.


Configuración de la máscara de la herramienta de detección de defectos superficiales

Una vez añadida la herramienta de detección de defectos superficiales, puede crear una máscara interna para resaltar áreas de inspección y excluir las demás áreas.

  1. Abra la ficha Máscara y active la casilla Habilitar máscara para activar la máscara.
  2. Defina cómo se generará la máscara: el segmento más grande o márgenes. De forma predeterminada, se utilizan márgenes (el parámetro Método de enmascaramiento está preajustado a Máscara de márgenes) para generar una máscara de imagen en función de la magnitud del margen. Con esta máscara de imagen solo se enmascaran los píxeles de los márgenes. Todos los demás píxeles se mostrarán. Si elige el segmento más grande, el área de características a inspeccionar será el mayor segmento, excluyendo el fondo de la inspección.
  3. Asigne al parámetro Enmascarar imagen visualizada el tipo de máscara que desee generar para destacar las características de la máscara, mostrando los segmentos indexados y codificados con colores.
  4. Comience por ajustar el parámetro Factor de suavizado de la máscara para asegurarse de que los márgenes de la imagen sean resaltados correctamente.
  5. A continuación, ajuste los parámetros Tamaño máximo de relleno de orificios pequeños, Tamaño medio de núcleo y Recuento de erosiones de la máscara. Permiten rellenar orificios, suavizar bordes y/o eliminar bandas estrechas en la máscara de la imagen, respectivamente. Si desea seleccionar Máscara de márgenes, deberá ajustar a 0 el parámetro Tamaño máximo de relleno de orificios pequeños.
  6. Una vez que la máscara resalte correctamente las características deseadas y excluya las demás, presione el botón Entrenar para establecer la máscara.

Nota: Todos los cambios de parámetros, salvo la región, actualizarán la máscara y forzarán su nuevo entrenamiento. Cuando cambie la posición o las dimensiones de la región, presione el botón Entrenar para actualizar la máscara en consecuencia.


Ajuste de los parámetros de la herramienta de detección de defectos superficiales

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de detección de defectos superficiales consta de las fichas siguientes:

  • Ficha General
  • Ficha Máscara
  • Ficha Detección de defectos
  • Fichas Estadísticas, Defectos y Región compuesta

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de detección de defectos Defecto superficial - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "DefectoSuperficial_1" (si se trata de la primera herramienta de detección de defecto superficial agregada a la tarea; de lo contrario, se incrementará, es decir, "DefectoSuperficial_2", "DefectoSuperficial_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de detección de defectos superficiales - pestaña Máscara

Closed Habilitar máscara

Define si se utilizará la máscara (preajuste = desactivado).

Closed Entrenar máscara

Define que la máscara será entrenada con los ajustes de los parámetros configurados actualmente.

Closed Método de enmascaramiento

Define cómo la herramienta construirá la máscara (Segmento más grande o Máscara de márgenes; preajuste = Máscara de márgenes).

  • Segmento más grande: La herramienta utilizará el segmento más grande para generar la máscara.
  • Máscara de márgenes: La herramienta utilizará márgenes para generar la máscara (el parámetro Contraste mínimo de un margen determina qué márgenes se utilizarán).
Closed Enmascarar imagen visualizada

Define la imagen de salida a mostrar (Imagen de entrada, Imagen de margen, Imagen segmentada o Máscara de imagen, preajuste = Máscara de imagen).

  • Imagen de entrada: Se mostrará la imagen actualmente adquirida.
  • Imagen de margen: Se mostrará una imagen de la magnitud del margen.
  • Imagen segmentada: Se mostrará una imagen segmentada y codificada en colores.
  • Imagen de máscara: Se mostrará (tras contabilizar la entrada de elementos) la imagen de máscara binaria, creada después del proceso de generación de la segmentación y de la máscara. Valores de píxeles de 255 = Tener en cuenta los píxeles. Valores de píxeles de 0 = Ignorar los píxeles.

Nota: Esta imagen solo se presenta con fines de visualización y no se puede utilizar como entrada para otra función.

Closed Factor de suavizado de la máscara

Define el factor sigma (0 a 100, preajuste = 1) utilizado para suavizar la imagen.

Closed Contraste mínimo de un margen

Define el contraste mínimo (1 a 100; preajuste = 10) utilizado para detectar márgenes.

Nota: Este parámetro solo se activa si el parámetro "Método de enmascaramiento" se ajusta a "Máscara de márgenes".

Closed Tamaño mínimo de un segmento

Define el área mínima (1 a 50000; preajuste = 1000), en píxeles, que un segmento debe tener para ser extraído.

Closed Tamaño máximo de relleno de orificios

Define el tamaño máximo (0 a 1000; preajuste = 0) que un pequeño orificio debe tener para ser rellenado (no se cuenta como orificio).

Closed Tamaño medio de núcleo

Define el tamaño medio del núcleo (0 a 50000; preajuste = 0) que se utilizará para suavizar los márgenes de la imagen de máscara.

Closed Recuento de erosiones de la máscara

Define el número de veces (-100 a 100, preajuste = 0) que la imagen generada será erosionada. Este valor puede ser negativo o positivo. Los valores negativos dilatan la imagen.

Closed Invertir

Define si la máscara se debe invertir o no, es decir, blanco para negro, p negro para blanco.


Herramienta de detección de defectos Defecto superficial - ficha Detección de defectos

Closed Tipo de detección

Define el tipo de procesamiento de imágenes a aplicar a la imagen con el fin de determinar la presencia de defectos (Rápido, Defectos claros, Defectos oscuros o Defectos claros y oscuros; preajuste = Rápido).

  • Rápido: Esta opción es ideal para detectar transiciones de intensidad similares a bordes en una superficie, como rayazos o arañazos. Aplica una operación de erosión-dilatación que resalta el borde de un defecto. Es la que se ejecuta más rápidamente. Sin embargo, solo comunica el perímetro del defecto, no su área.
  • Defectos claros: Esta opción es ideal para detectar defectos claros, similares a "blobs", sobre un fondo oscuro, así como para detectar defectos en función del tamaño de su área en píxeles. Utiliza una operación de filtrado "top hat", que filtra todo menos las propiedades claras cuyo tamaño sea inferior al valor del parámetro "Tamaño de detección", con el fin de detectar posibles defectos.
  • Defectos oscuros: Esta opción es ideal para detectar defectos oscuros, similares a "blobs", sobre un fondo claro, así como para detectar defectos en función del tamaño de su área en píxeles. Utiliza una operación de filtrado "bottom hat", que filtra todo menos las propiedades oscuras cuyo tamaño sea inferior al valor del parámetro "Tamaño de detección".
  • Defectos claros y oscuros: Esta opción es ideal para detectar defectos similares a "blobs", tanto claros como oscuros, así como para detectar defectos en función del tamaño de su área en píxeles. Utiliza operaciones "bottom hat" y "top hat" y el resultado máximo de ambas.

Nota: Si el tipo de operación de detección de defectos seleccionado es Defectos claros, Defectos oscuros o Defectos claros y oscuros, el parámetro Tamaño de detección debe ajustarse al tamaño del defecto más grande que se detecte.

Closed Imagen visualizada

Define la imagen de salida que se va a mostrar (Imagen de entrada, Imagen muestreada, Candidatos a defectos o Imagen defectuosa; valor predeterminado = Imagen defectuosa).

  • Imagen de entrada: Se mostrará la imagen actualmente adquirida.
  • Imagen muestreada: Se mostrará la imagen suavizada y muestreada. Si se ha utilizado una región angular o curvada como entrada, se mostrará la versión transformada y enderezada además de los efectos suavizado y muestreado.
  • Candidatos a defectos: Se mostrarán los defectos potenciales. Los defectos potenciales aparecen resaltados contra el fondo.
  • Imagen defectuosa: Se mostrarán los defectos. Los defectos se dibujan en blanco, mientras que las demás áreas aparecerán en negro. Esta opción de visualización incluirá defectos que queden fuera de los límites de los defectos definidos (Área mínima de defectos y Área máxima de defectos).

Nota: Esta imagen solo se presenta con fines de visualización y no se puede utilizar como entrada para otra función.

Closed Factor de muestreo

Define la magnitud del muestreo (1-99999; preajuste = 1) de la imagen de entrada, lo que reduce su resolución. Aunque el muestreo reduce el tiempo de ejecución de la herramienta, lo hace a costa de la precisión. A la hora de determinar el valor de muestreo adecuado, el valor 1 indica ningún muestreo, es decir, que la imagen de entrada se utilizará con resolución completa. Cuanto mayor sea el valor, menores serán la resolución y la precisión y mayores los tiempos de ejecución.

Closed Suavizado automático

Define si la función determinará el factor de suavizado óptimo para aplicar al suavizado de la imagen (preajuste = desactivado). En general, el mejor rendimiento se obtiene si se permite a la función seleccionar el factor de suavizado óptimo.

Nota: El parámetro Suavizado automático está desactivado por defecto. Para habilitar el parámetro, se debe ajustar el parámetro Factor de muestreo a un valor mayor que 1. Si ajusta el parámetro Factor de muestreo con un valor mayor que 1 y no desea el suavizado automático, desactive el parámetro y defina el valor apropiado con el parámetro Factor de suavizado.

Closed Factor de suavizado

Define el factor (0 a 99999; preajuste = 0) de suavizado de la imagen. Para determinar el valor óptimo, comience con un valor similar al especificado en el parámetro "Factor de muestreo". Para no especificar ningún suavizado, asigne el valor 0.

Nota: Este parámetro se desactiva al activar el parámetro "Suavizado automático". Si activa el parámetro Suavizado automático, ajuste el parámetro Factor de muestreo a un valor mayor que 1 y desactive el parámetro Suavizado automático. Ahora se puede incrementar el parámetro Factor de suavizado.

Closed Eje de detección

Define el eje en el que detectar defectos potenciales (X, Y, X e Y; preajuste = X e Y).

Closed Tamaño de detección

Define el tamaño de la vecindad de detección (1-99999; preajuste = 1), en píxeles. Este parámetro se utiliza para establecer la vecindad de procesamiento, o núcleo, que se utilizará con el parámetro Operación de detección de defectos. Para todas las operaciones de detección de defectos distintas de Rápida, el valor del tamaño debe ser al menos igual que el largo o el ancho de los defectos a detectar.

Closed Contraste mínimo del defecto

Define el umbral de intensidad (1 a 255, preajuste = 20) utilizado para detectar defectos. Para que un defecto sea detectado, su intensidad deberá diferenciarse del fondo en la magnitud de este valor.

Closed Área mínima de defectos

Define el tamaño mínimo (1-99999, preajuste = 30), en píxeles, de los defectos a detectar.

Nota: Este valor se expresa siempre en píxeles, incluso aunque la tarea haya sido calibrada para utilizar unidades de medida reales en el paso Configurar imagen.

Closed Área máxima de defectos

Define el tamaño máximo (1-99999, preajuste = 99999), en píxeles, de los defectos a detectar.

Nota: Este valor se expresa siempre en píxeles, incluso aunque la tarea haya sido calibrada para utilizar unidades de medida reales en el paso Configurar imagen.

Closed Tiempo_Espera

Define el tiempo, en milisegundos (0 a 30.000; preajuste = 5000), durante el que la herramienta buscará defectos antes de detenerse y devolver un rechazo.

Closed Defectos totales

Muestra el recuento total de defectos detectados.


Herramienta de detección de defectos superficiales - fichas Estadísticas, Defectos y Región compuesta

Closed Ficha Estadísticas

La ficha Estadísticas muestra el número total de defectos y sus tamaños acumulados.

Closed Ficha Defectos

La tabla de la ficha Defectos muestra los primeros 10 defectos detectados, ordenados, de mayor a menor, por sus áreas. La tabla indica la ubicación del defecto en la imagen (coordenadas X/Y), el área, el perímetro, la redondez y la intensidad.

Closed Ficha Región compuesta

La ficha Región compuesta sirve para configurar una región compuesta, una colección de subregiones (Rectángulo, Espacio anular, Círculo o Polígono) que se pueden Sumar a la región (la región se incluirá en el análisis de imagen) o Restar de la región (la región se excluirá del análisis de la imagen; también se denomina "enmascaramiento").

Notas:
  • Se puede utilizar un máximo de 32 regiones para construir una región compuesta.
  • Dispone de un menú contextual mientras interactúa con la región en la imagen; este permite cambiar la forma de una subregión seleccionada o cambiar la Operación (Sumar o Restar) de una subregión seleccionada.
Closed Tabla Región compuesta

Muestra el tipo de subregión o subregiones que forman la región compuesta, así como su Operación (Sumar o Restar). Seleccione una subregión para activar los botones Eliminar, Subir o Bajar. Al pulsar el botón Eliminar se quita la subregión seleccionada de la lista; al pulsar el botón Subir se sube la subregión seleccionada en la lista; y al pulsar el botón Bajar se baja la subregión seleccionada en la lista.

Nota: La región compuesta se construye en función de su secuencia de subregiones en la lista. Si coloca las subregiones y su operación de suma o de resta en un orden específico, algunas partes de la imagen pueden resaltarse, mientras que otras áreas se omiten. La imagen siguiente muestra un ejemplo de cómo ordenar correctamente las subregiones para excluir una parte de la imagen al tiempo que se enfocan otras áreas. En el primer conjunto, se configura un rectángulo con una operación de suma y, a continuación, se coloca en el centro un círculo con una operación de resta. Después se configura un rectángulo más pequeño con una operación de suma en el centro del círculo. El círculo excluye parte de la imagen, mientras que el rectángulo más pequeño añade o suma de nuevo una parte del área de la imagen al análisis de la imagen. En el segundo conjunto, el rectángulo más pequeño se añade antes que el círculo y el círculo enmascara el rectángulo más pequeño excluyéndolo del análisis de la imagen.
Closed Forma

Muestra la forma de la subregión seleccionada (Rectángulo, Círculo, Espacio anular o Polígono). Para cambiar la forma, seleccione el tipo de región que desee en el menú desplegable.

Closed Operación

Define la acción de la subregión seleccionada dentro de la región: Sumar o Restar. Sumar indica que la subregión se incluirá en el análisis de la imagen, mientras que Restar indica que la subregión se excluirá del análisis de la imagen (también se denomina "enmascaramiento").

Closed Rectángulo

Inserta una subregión de rectángulo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Espacio anular

Inserta una subregión de espacio anular en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Círculo

Inserta una subregión de círculo en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.

Closed Polígono

Inserta una subregión de polígono en la región compuesta. Configure la forma y el tamaño de la región según sea necesario.


Uso de las propiedades de entrada/salida de la herramienta de detección de defectos superficiales

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Suavizado_Automatico | I | X | X | Entrada/Salida
Region_Compuesta | A |  | X |
Tamano_Cumulativo_Defectos | FP | X | X | Entrada/Salida
Descripcion | S | X | X | Entrada/Salida
Eje_Deteccion | I | X | X | Entrada/Salida
Tamano_Deteccion | I | X | X | Entrada/Salida
Imagen_Visualizada | I | X | X | Entrada/Salida
Habilitar_Mascara | I | X | X | Entrada/Salida
Recuento_Erosiones_Mascaras | I | X | X | Entrada/Salida
Recuento_Errores | I | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Rechazo | I | X |  |
Recuento_Rechazos | I | X | X | Salida
Tipo_Deteccion | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Invertir | I | X | X | Entrada/Salida
Enmascarar_Imagen_Visualizada | I | X | X | Entrada/Salida
Metodo_Enmascaramiento | I | X | X | Entrada/Salida
Factor_Suavizado_Mascara | I | X | X | Entrada/Salida
Maxima_Area_Defecto | FP | X | X | Entrada/Salida
Maximo_Tamano_Relleno_Orificio | I | X | X | Entrada/Salida
Tamano_Medio_Kernel | I | X | X | Entrada/Salida
Contraste_Minimo | I | X | X | Entrada/Salida
Contraste_Minimo_Margen | I | X | X | Entrada/Salida
Area_Minima_Defecto | FP | X | X | Entrada/Salida
Tamano_Minimo_Segmento | I | X | X | Entrada/Salida
Aceptacion | I | X |  |
Recuento_Aceptaciones | I | X | X | Salida
Factor_Muestreo | I | X | X | Entrada/Salida
Factor_Suavizado | I | X | X | Entrada/Salida
Estado | I | X | X | Salida
Tiempo_Espera | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Herramienta_Estado_Habilitado | I | X | X | Salida
Total_Defectos | S | X | X | Salida
Entrenar_Mascara | A |  | X |


Herramientas de detección de defectos: Margen

La herramienta de detección de defectos de márgenes genera una línea o un círculo con el mejor ajuste posible, utilizando matrices Calibre de análisis de márgenes para detectar con precisión las características de márgenes. Una vez identificado el margen, la herramienta construye una línea o un círculo con el mejor ajuste posible (dependiendo de si la característica de margen contiene una curva o no) sobre la característica de margen, determina si éste contiene desviaciones, como defectos o espacios, y comunica el número de defectos y/o espacios hallados.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de detección de defectos de márgenes resulta útil para asegurarse de que una pieza u objeto no contiene ninguna característica de margen con desviaciones, como defectos o espacios. Por ejemplo, para determinar si el exterior de la pieza o del objeto mantiene la misma forma y no contiene pequeñas abolladuras o mellas.

  1. Configuración de la herramienta de detección de defectos de márgenes
  2. Ajuste de los parámetros de la herramienta de detección de defectos de márgenes
  3. Uso de las propiedades de entrada/salida de la herramienta de detección de defectos de márgenes


Configuración de la herramienta de detección de defectos de márgenes

Después de agregar la herramienta, deberá configurar la región enmascarada en la imagen sobre la característica de margen que desee inspeccionar:

  1. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, al tiempo que se excluye el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Márgenes, Puntuación de márgenes, Encuadre, Defectos y Espacios y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la línea o el círculo con el mejor ajuste posible. A la hora de realizar la configuración inicial de la herramienta, utilice una imagen que contenga la característica de margen ideal. Las adquisiciones de imágenes subsiguientes contendrán candidatos a márgenes que serán examinados para determinar si existen desviaciones tales como defectos o espacios.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de detección de defectos de márgenes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de detección de defectos de márgenes consta de los siguientes elementos:

  • Ficha General
  • Ficha Márgenes
  • Ficha Puntuación de márgen
  • Ficha Adaptación
  • Defectos Tab
  • Espacios Tab
  • Fichas de Defectos y Espacios

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de detección de defectos Margen - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "DefectoMargenes_1" (si se trata de la primera herramienta de detección de defecto de márgenes agregada a la tarea; de lo contrario, se incrementará, es decir, "DefectoMargenes_2", "DefectoMargenes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de detección de defectos de márgenes - Ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra todos los márgenes detectados en la región y los marca en color verde oscuro. Es posible ajustar los parámetros Tamaño del calibre, Espaciado del calibre, Ancho del margen y Contraste mínimo según convenga para aislar los márgenes deseados.

También puede ver todos los calibres activando el parámetro Mostrar todos los calibres.

Esta ficha también permite seleccionar y ajustar la región.

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos de márgenes - Ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra con pequeños círculos coloreados todos los candidatos a márgenes encontrados dentro de la región (que puede seleccionarse y ajustarse), así como el resultado de la línea o del círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Ajustes los parámetros para aislar los candidatos a márgenes deseados.

También se muestran todos los defectos y espacios detectados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha o Derecha a izquierda; preajuste = Izquierda a derecha).

Closed Transiciones de márgenes

Define la transición de los márgenes (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Herramienta de detección de defectos de márgenes - Ficha Adaptación

Al seleccionar la ficha Encuadre, la herramienta mostrará todos los candidatos a márgenes que se encuentran dentro de la región y la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes se indican con pequeños círculos coloreados.

Esta ficha también permite seleccionar y ajustar la región.

Closed Filtrar objetos exteriores

Define si la herramienta eliminará o no los puntos de la recta de mejor ajuste que se encuentren más allá de la distancia definida por el parámetro Filtro de encuadre de distancia (de forma predeterminada, este parámetro está activado).

Closed Filtro de encuadre de distancia

Define la distancia (1 - 1920; preajuste = 2), en píxeles, a la que debe encontrarse un margen con respecto a la línea de mejor ajuste original para ser utilizada en el cálculo de reencuadre. Este parámetro sirve para impedir que los defectos afecten al encuadre de línea.

Nota: Para poder utilizar este parámetro, primero debe activarse el parámetro Filtrar objetos exteriores.

Closed Distancia del filtro del punto más alejado

Define la distancia del objeto exterior (1 - 1920; preajuste = 1000) más allá de la cual no se utilizan márgenes para determinar las distancias mínima y y máxima; cualquier margen que supere este valor será ignorado.

Closed Volver a puntuar

Define si los márgenes detectados volverán a ser puntuados para asegurarse de que los márgenes descartados inicialmente fueron filtrados correctamente (de forma predeterminada, este parámetro está activado).

Closed Volver a encuadrar

Define si la herramienta se reajustará a la línea con el mejor ajuste posible después de volver a puntuar los márgenes (de forma predeterminada, este parámetro está activado).

Nota: La precisión de la herramienta será mayor con este parámetro habilitado, aunque a costa de aumentar el tiempo de procesamiento.


Herramienta de detección de defectos de márgenes - Ficha Defectos

Al seleccionar la ficha Defectos, la herramienta mostrará el resultado de la línea o del círculo con el mejor ajuste posible, así como los defectos o espacios detectados. Por "defectos" se entienden las desviaciones de márgenes con respecto a la línea o al círculo con el mejor ajuste.

Esta ficha también permite seleccionar y ajustar la región.

Closed Distancia mínima

Especifica que cualquier distancia (0,001 - 1920; preajuste = 4), en píxeles, desde el margen y desde la línea o círculo de mejor ajuste que no supere este valor no se considerará como defecto.

Closed Distancia máxima

Especifica que cualquier distancia (0,001 - 1920; preajuste = 1000), en píxeles, desde el margen y desde la línea o círculo de mejor ajuste que supere este valor no se considerará como defecto.

Closed Tamaño habilitado

Define si la herramienta informará sobre defectos de tamaño (que expresan la longitud a lo largo del margen); de forma predeterminada, este parámetro está habilitado.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Tamaño mínimo

Define el tamaño mínimo de un defecto (0,001 - 1920; preajuste = 10), en píxeles; las desviaciones continuas de la línea o del círculo con el mejor ajuste posible que sean inferiores a este valor no se consideran defectos.

Closed Tamaño máximo

Define el tamaño máximo de un defecto (0,001 - 1920; preajuste = 1000), en píxeles; las desviaciones continuas de la línea o del círculo con el mejor ajuste posible que sean superiores a este valor no se consideran defectos.

Closed Área habilitada

Define si la herramienta informará sobre defectos en el área; de forma predeterminada, este parámetro está deshabilitado. Los defectos del área representan la longitud a lo largo de la línea o del círculo con el mejor ajuste posible, así como la distancia a la que se encuentra el margen defectuoso de dicha línea o de dicho círculo.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Área mín.

Define el defecto de área mínimo (0,001 - 1000000; preajuste = 10), en píxeles; un área menor que este valor no se considera como defecto.

Closed Área máx.

Define el defecto de área máximo (0,001 - 1000000; preajuste = 1000000), en píxeles; un área mayor que este valor no se considera como defecto.

Closed Filtro de defectos

Define si se deben filtrar o no los defectos en función de su posición respecto al encuadre de línea (Sin filtro, Ignorar los defectos a la izquierda del encuadre de línea, Ignorar los defectos a la derecha del encuadre de línea; valor predeterminado = Sin filtro).


Herramienta de detección de defectos de márgenes - Ficha Espacios

Al seleccionar la ficha Espacios, la herramienta muestra el resultado de la línea o del círculo con el mejor ajuste posible, así como los defectos o espacios detectados. Los "espacios" se definen como desviaciones del margen con respecto a la línea o al círculo con el mejor ajuste.

Esta ficha también permite seleccionar y ajustar la región.

Closed Buscar espacios

Define si la herramienta informará sobre espacios en el margen encontrado; de forma predeterminada, este parámetro está activado.

Closed Espacio mínimo

Define el espacio mínimo (0,001 - 1920; preajuste = 3), en píxeles; los espacios menores que este valor no se consideran espacios.

Closed Espacio máximo

Define el espacio máximo (0,001 - 1920; preajuste = 1000), en píxeles; los espacios mayores que este valor no se consideran espacios.

Closed Ignorar espacios finales

Define si la herramienta informará sobre espacios detectados al principio o al final de la región; de forma predeterminada, este parámetro está desactivado.

Closed Resultado

Muestra el número total de defectos, espacios y espacios detectados.


Herramienta de detección de defectos de márgenes - Fichas de Defectos y Espacios

Las fichas de tablas Defectos y Espacios comunican los primeros 10 defectos o espacios detectados, por orden de posición a lo largo del margen.

Closed Índice

Se refiere al orden de los defectos/espacios encontrados, clasificados por posición a lo largo del margen; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Y

Devuelve la coordenada Y (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Área

Devuelve el área del rectángulo delimitador del defecto o espacio.

Closed Tamaño

Devuelve el tamaño (longitud) del defecto/espacio a lo largo del margen.

Closed Calibres

Devuelve el rango de calibres que abarca el defecto o espacio.

Closed Unidades/píxeles calibrados

Define si la tabla muestra los resultados en coordenadas del mundo real (Unidades calibradas) o en píxeles (Píxeles).

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.


Uso de las propiedades de entrada/salida de la herramienta de detección de defectos de márgenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Área_Habilitada | I | X | X | Entrada/Salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Transición | I | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Filtrar_Objetos_exteriores | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Buscar_Espacios | I | X | X | Entrada/Salida
Ajustar_Distancia_Filtro | I | X | X | Entrada/Salida
Distancia_Filtro_Punto_Más_alejado | I | X | X | Entrada/Salida
Ignorar_Espacios_Finales | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Área_Máx | FP | X | X | Entrada/Salida
Distancia_Máx | FP | X | X | Entrada/Salida
Tamaño_Máx | FP | X | X | Entrada/Salida
Espacio_Máximo | FP | X | X | Entrada/Salida
Área_Mínima | FP | X | X | Entrada/Salida
Distancia_Mín | FP | X | X | Entrada/Salida
Tamaño_Mín | FP | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Espacio_Mínimo | FP | X | X | Entrada/Salida
Reajustar | I | X | X | Entrada/Salida
Repuntuar | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Tamaño_Habilitado | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Círculo.Radio | FP | X | X | Salida
Círculo.X | FP | X | X | Salida
Círculo.Y | FP | X | X | Salida
Defectos | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Espacios | FP | X | X | Salida
InspectEdgeForDefect | S | X | X | Salida
Línea.Fin_X | FP | X | X | Salida
Línea.Fin_Y | FP | X | X | Salida
Línea.Principio_X | FP | X | X | Salida
Línea.Principio_Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Total_Defectos | FP | X | X | Salida
Región_Enmascarada | A | X | X |


Herramientas de detección de defectos - Par de márgenes

La herramienta de detección de defectos de pares de márgenes genera un par de líneas o de círculos con el mejor ajuste posible, utilizando matrices Calibre de análisis de márgenes para detectar con precisión las características de márgenes. Una vez identificados los márgenes, la herramienta construye un par de líneas o de círculos con el mejor ajuste posible (dependiendo de si la característica de margen contiene una curva o no) sobre las características de márgenes para determinar si éstos contienen desviaciones, como defectos o espacios, y comunica el número de defectos y/o espacios hallados.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de detección de defectos de pares de márgenes resulta útil para asegurarse de que una pieza u objeto no contiene ninguna característica de margen con desviaciones, como defectos o espacios. Por ejemplo, para determinar si la pieza o el objeto tiene márgenes que conservan su forma y asegurarse de que no haya abolladuras ni mellas en los mismos.

  1. Configuración de la herramienta de detección de defectos de pares de márgenes
  2. Ajuste de los parámetros de la herramienta de detección de defectos de pares de márgenes
  3. Uso de las propiedades de entrada/salida de la herramienta de detección de defectos de pares de márgenes


Configuración de la herramienta de detección de defectos de pares de márgenes

Después de agregar la herramienta, deberá configurar la región enmascarada en la imagen sobre la característica de margen que desee inspeccionar:

  1. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, al tiempo que se excluye el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  1. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  2. Una vez confirmada la región, seleccione las diversas fichas, Márgenes, Puntuación de márgenes, Encuadre, Defectos y Espacios y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la línea o el círculo con el mejor ajuste posible. A la hora de realizar la configuración inicial de la herramienta, utilice una imagen que contenga la característica de margen ideal. Las adquisiciones de imágenes subsiguientes contendrán candidatos a márgenes que serán examinados para determinar si existen desviaciones tales como defectos o espacios.
  3. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  4. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de detección de defectos de pares de márgenes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de detección de defectos de pares de márgenes consta de las fichas siguientes:

  • Ficha General
  • Ficha Márgenes
  • Ficha Puntuación de márgen
  • Ficha Adaptación
  • Ficha Defectos
  • Ficha Espacios
  • Ficha de Margen 0 defectos, Margen 1 defectos y Espacio

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de detección de defectos Par de márgenes - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "DefectoParesMargenes_1" (si se trata de la primera herramienta de detección de defecto de márgenes agregada a la tarea; de lo contrario, se incrementará, es decir, "DefectoParesMargenes_2", "DefectoParesMargenes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de detección de defectos de pares de márgenes - Ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra todos los márgenes detectados en la región y los marca en color verde oscuro. Es posible ajustar los parámetros Tamaño del calibre, Espaciado del calibre, Ancho del margen y Contraste mínimo según convenga para aislar los márgenes deseados.

También puede ver todos los calibres activando el parámetro Mostrar todos los calibres.

Esta ficha también permite seleccionar y ajustar la región.

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos de pares de márgenes - Ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra con pequeños círculos coloreados todos los candidatos a márgenes encontrados dentro de la región (que puede seleccionarse y ajustarse), así como el resultado de la línea o del círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Ajustes los parámetros para aislar los candidatos a márgenes deseados.

También se muestran todos los defectos y espacios detectados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha, Derecha a izquierda, Centro afuera o De fuera adentro; preajuste = Izquierda a derecha).

Closed Transición Margen0

Define la transición del primer margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Transición Margen1

Define la transición del segundo margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Tamaño del par

Define si el par de márgenes detectado con el tamaño más parecido al parámetro Tamaño del par debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está desactivado).

Closed Tamaño del par

Define el tamaño del par de márgenes con el que se obtiene la puntuación más alta (1 - 1920; preajuste = 5). Con este parámetro activado, los pares de márgenes detectados cuyo valor sea superior o inferior a éste puntuarán en proporción al valor que tengan. Por ejemplo, si el tamaño del par es de 10 y se detectan dos candidatos a pares de márgenes, uno con un valor de 8 y otro de 14, se seleccionaría el par de márgenes con el valor de 8 por estar más cerca del límite que el segundo par de márgenes. El parámetro Regla: Tamaño de par debe estar activado para poder activar este parámetro.

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Herramienta de detección de defectos de pares de márgenes - Ficha Adaptación

Al seleccionar la ficha Encuadre, la herramienta mostrará todos los candidatos a márgenes que se encuentran dentro de la región y la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes se indican con pequeños círculos coloreados.

Esta ficha también permite seleccionar y ajustar la región.

Closed Filtrar objetos exteriores

Define si la herramienta eliminará o no los puntos de la recta de mejor ajuste que se encuentren más allá de la distancia definida por el parámetro Filtro de encuadre de distancia (de forma predeterminada, este parámetro está activado).

Closed Filtro de encuadre de distancia

Define la distancia (1 - 1920; preajuste = 2), en píxeles, a la que debe encontrarse un margen con respecto a la línea de mejor ajuste original para ser utilizada en el cálculo de reencuadre. Este parámetro sirve para impedir que los defectos afecten al encuadre de línea.

Nota: Para poder utilizar este parámetro, primero debe activarse el parámetro Filtrar objetos exteriores.

Closed Distancia del filtro del punto más alejado

Define la distancia del objeto exterior (1 - 1920; preajuste = 1000) más allá de la cual no se utilizan márgenes para determinar las distancias mínima y y máxima; cualquier margen que supere este valor será ignorado.

Closed Volver a puntuar

Define si los márgenes detectados volverán a ser puntuados para asegurarse de que los márgenes descartados inicialmente fueron filtrados correctamente (de forma predeterminada, este parámetro está activado).

Closed Volver a encuadrar

Define si la herramienta se reajustará a la línea con el mejor ajuste posible después de volver a puntuar los márgenes (de forma predeterminada, este parámetro está activado).

Nota: La precisión de la herramienta será mayor con este parámetro habilitado, aunque a costa de aumentar el tiempo de procesamiento.


Herramienta de detección de defectos de pares de márgenes - Ficha Defectos

Al seleccionar la ficha Defectos, la herramienta mostrará el resultado de la línea o del círculo con el mejor ajuste posible, así como los defectos o espacios detectados. Por "defectos" se entienden las desviaciones de márgenes con respecto a la línea o al círculo con el mejor ajuste.

Esta ficha también permite seleccionar y ajustar la región.

Closed Distancia mínima

Especifica que cualquier distancia (0,001 - 1920; preajuste = 4), en píxeles, desde el margen y desde la línea o círculo de mejor ajuste que no supere este valor no se considerará como defecto.

Closed Distancia máxima

Especifica que cualquier distancia (0,001 - 1920; preajuste = 1000), en píxeles, desde el margen y desde la línea o círculo de mejor ajuste que supere este valor no se considerará como defecto.

Closed Tamaño habilitado

Define si la herramienta informará sobre defectos de tamaño (que expresan la longitud a lo largo del margen); de forma predeterminada, este parámetro está habilitado.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Tamaño mínimo

Define el tamaño mínimo de un defecto (0,001 - 1920; preajuste = 10), en píxeles; las desviaciones continuas de la línea o del círculo con el mejor ajuste posible que sean inferiores a este valor no se consideran defectos.

Closed Tamaño máximo

Define el tamaño máximo de un defecto (0,001 - 1920; preajuste = 1000), en píxeles; las desviaciones continuas de la línea o del círculo con el mejor ajuste posible que sean superiores a este valor no se consideran defectos.

Closed Área habilitada

Define si la herramienta informará sobre defectos en el área; de forma predeterminada, este parámetro está deshabilitado. Los defectos del área representan la longitud a lo largo de la línea o del círculo con el mejor ajuste posible, así como la distancia a la que se encuentra el margen defectuoso de dicha línea o de dicho círculo.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Área mín.

Define el defecto de área mínimo (0,001 - 1000000; preajuste = 10), en píxeles; un área menor que este valor no se considera como defecto.

Closed Área máx.

Define el defecto de área máximo (0,001 - 1000000; preajuste = 1000000), en píxeles; un área mayor que este valor no se considera como defecto.

Closed Filtro de defectos

Define si se deben filtrar o no los defectos en función de su posición respecto al encuadre de línea (Sin filtro, Ignorar los defectos a la izquierda del encuadre de línea, Ignorar los defectos a la derecha del encuadre de línea; valor predeterminado = Sin filtro).


Herramienta de detección de defectos de pares de márgenes - Ficha Espacios

Al seleccionar la ficha Espacios, la herramienta muestra el resultado de la línea o del círculo con el mejor ajuste posible, así como los defectos o espacios detectados. Los "espacios" se definen como desviaciones del margen con respecto a la línea o al círculo con el mejor ajuste.

Esta ficha también permite seleccionar y ajustar la región.

Closed Buscar espacios

Define si la herramienta informará sobre espacios en el margen encontrado; de forma predeterminada, este parámetro está activado.

Closed Espacio mínimo

Define el espacio mínimo (0,001 - 1920; preajuste = 3), en píxeles; los espacios menores que este valor no se consideran espacios.

Closed Espacio máximo

Define el espacio máximo (0,001 - 1920; preajuste = 1000), en píxeles; los espacios mayores que este valor no se consideran espacios.

Closed Ignorar espacios finales

Define si la herramienta informará sobre espacios detectados al principio o al final de la región; de forma predeterminada, este parámetro está desactivado.

Closed Resultado

Muestra el número total de defectos, espacios y espacios detectados.


Herramienta de detección de defectos de pares de márgenes - Fichas de tablas Margen 0 defectos, Margen 1 defectos y Espacios

Las fichas de tablas Margen 0 defectos, Margen 1 defectos y Espacios comunican los primeros 10 defectos o espacios detectados, por orden de posición a lo largo del borde. Margen 0 se refiere al primer margen del par detectado, mientras que Margen 1 se refiere al segundo margen.

Closed Índice

Se refiere al orden de los defectos/espacios encontrados, clasificados por posición a lo largo del margen; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Y

Devuelve la coordenada Y (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Área

Devuelve el área del rectángulo delimitador del defecto o espacio.

Closed Tamaño

Devuelve el tamaño (longitud) del defecto/espacio a lo largo del margen.

Closed Calibres

Devuelve el rango de calibres que abarca el defecto o espacio.

Closed Unidades/píxeles calibrados

Define si la tabla muestra los resultados en coordenadas del mundo real (Unidades calibradas) o en píxeles (Píxeles).

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.


Uso de las propiedades de entrada/salida de la herramienta de detección de defectos de pares de márgenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Área_Habilitada | I | X | X | Entrada/Salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Margen0_Transición | I | X | X | Entrada/Salida
Margen1_Transición | I | X | X | Entrada/Salida
Filtrar_Objetos_Exteriores | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Buscar_Espacios | I | X | X | Entrada/Salida
Ajustar_Distancia_Filtro | I | X | X | Entrada/Salida
Distancia_Filtro_Punto_Más_alejado | I | X | X | Entrada/Salida
Ignorar_Espacios_Finales | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Área_Máx | FP | X | X | Entrada/Salida
Distancia_Máx | FP | X | X | Entrada/Salida
Tamaño_Máx | FP | X | X | Entrada/Salida
Espacio_Máximo | FP | X | X | Entrada/Salida
Área_Mínima | FP | X | X | Entrada/Salida
Distancia_Mín | FP | X | X | Entrada/Salida
Tamaño_Mín | FP | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Espacio_Mínimo | FP | X | X | Entrada/Salida
Par_Tamaño | I | X | X | Entrada/Salida
Reajustar | I | X | X | Entrada/Salida
Repuntuar | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Tamaño_Par | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Tamaño_Habilitado | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Círculo.Radio | FP | X | X | Salida
Círculo.X | FP | X | X | Salida
Círculo.Y | FP | X | X | Salida
Círculo1.Radio | FP | X | X | Salida
Círculo1.X | FP | X | X | Salida
Círculo1.Y | FP | X | X | Salida
Defectos | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Espacios | FP | X | X | Salida
InspectEdgeForDefect | S | X | X | Salida
Línea.Fin_X | FP | X | X | Salida
Línea.Fin_Y | FP | X | X | Salida
Línea.Principio_X | FP | X | X | Salida
Línea.Principio_Y | FP | X | X | Salida
Línea1.Fin_X | FP | X | X | Salida
Línea1.Fin_Y | FP | X | X | Salida
Línea1.Principio_X | FP | X | X | Salida
Línea1.Principio_Y | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Total_Defectos | FP | X | X | Salida
Región_Enmascarada | A | X | X |


Herramientas de detección de defectos - Ancho de márgenes

La herramienta de detección de defectos de ancho de márgenes mide y comprueba si el grosor de un par de márgenes se encuentra dentro de los límites de tolerancia. La herramienta utiliza matrices Calibre de análisis de márgenes para localizar con precisión las características de márgenes, con el fin de determinar si hay desviaciones en éstos, como defectos o espacios, y comunica el número de defectos y/o de espacios encontrados.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de detección de defectos de ancho de márgenes resulta útil para asegurarse de que una pieza u objeto no contiene ninguna característica de margen con desviaciones, como defectos o espacios. Por ejemplo, para determinar si un cordón de soldadura tiene siempre la anchura adecuada.

  1. Configuración de la herramienta de detección de defectos de ancho de márgenes
  2. Ajuste de los parámetros de la herramienta de detección de defectos de ancho de márgenes
  3. Uso de las propiedades de entrada/salida de la herramienta de detección de defectos de ancho de márgenes


Configuración de la herramienta de detección de defectos de ancho de márgenes

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen sobre la característica de margen que desee inspeccionar:

  1. En el menú desplegable Tipo de región, seleccione su región: Región enmascarada o Trayectoria de polilínea. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, al tiempo que se excluye el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Márgenes, Puntuación de márgenes, Objetos exteriores, Defectos y Espacios y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos. A la hora de realizar la configuración inicial de la herramienta, utilice una imagen que contenga la característica de margen ideal. Las adquisiciones de imágenes subsiguientes contendrán candidatos a márgenes que serán examinados para determinar si existen desviaciones tales como defectos o espacios.

Nota: Opcionalmente, la herramienta creará una línea o un círculo con el mejor ajuste posible si se activa el parámetro Volver a puntuar de la ficha Objetos exteriores.

  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de detección de defectos de ancho de márgenes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de detección de defectos de ancho de márgenes consta de las fichas siguientes:

  • Ficha General
  • Ficha Márgenes
  • Ficha Puntuación de márgenes
  • Ficha Objetos exteriores
  • Ficha Defectos
  • Ficha Espacios
  • Fichas de tablas de defectos de ancho y de espacios

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de detección de defectos Ancho de margen - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "AnchoMargenes_1" (si se trata de la primera herramienta de detección de defecto de ancho de márgenes agregada a la tarea; de lo contrario, se incrementará, es decir, "AnchoMargenes_2", "AnchoMargenes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Tipo de región

Define el tipo de región (Región enmascarada o Trayectoria de polilíneas; el valor predeterminado es la región enmascarada) que utilizará la herramienta para detectar las características del margen.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de detección de defectos de ancho de márgenes - Ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra todos los márgenes detectados en la región y los marca en color verde oscuro. Es posible ajustar los parámetros Tamaño del calibre, Espaciado del calibre, Ancho del margen y Contraste mínimo según convenga para aislar los márgenes deseados.

También puede ver todos los calibres activando el parámetro Mostrar todos los calibres.

Esta ficha también permite seleccionar y ajustar la región.

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos de ancho de márgenes - Ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra todos los candidatos a márgenes encontrados, marcándolos con pequeños círculos coloreados dentro de la región (que puede seleccionarse y ajustarse). Ajuste los parámetros para aislar los candidatos a margen deseados.

Nota: Opcionalmente, la herramienta creará una línea o un círculo con el mejor ajuste posible si se activa el parámetro Volver a puntuar de la ficha Objetos exteriores.

También se mostrarán los defectos y espacios detectados, al igual que los anchos mínimo y máximo de los márgenes, marcados con líneas amarillas.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha, Derecha a izquierda, Centro afuera o De fuera adentro; preajuste = Izquierda a derecha).

Closed Transición Margen0

Define la transición del primer margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Transición Margen1

Define la transición del segundo margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Límite superior del contraste

Define el límite superior de la transición de contraste (2 - 255; preajuste = 255) que un margen debe cumplir para ser considerado como tal; los márgenes con una transición de contraste superior a este valor tendrán la misma puntuación máxima.

Closed Regla:Tamaño del par

Define si el par de márgenes detectado con el tamaño más parecido al parámetro Tamaño del par debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está desactivado).

Closed Tamaño del par

Define el tamaño del par de márgenes con el que se obtiene la puntuación más alta (1 - 1920; preajuste = 5). Con este parámetro activado, los pares de márgenes detectados cuyo valor sea superior o inferior a éste puntuarán en proporción al valor que tengan. Por ejemplo, si el tamaño del par es de 10 y se detectan dos candidatos a pares de márgenes, uno con un valor de 8 y otro de 14, se seleccionaría el par de márgenes con el valor de 8 por estar más cerca del límite que el segundo par de márgenes. El parámetro Regla: Tamaño de par debe estar activado para poder activar este parámetro.

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Herramienta de detección de defectos de ancho de márgenes - Ficha Objetos exteriores

Al seleccionar la ficha Objetos exteriores, la herramienta mostrará todos los candidatos a márgenes que se encuentran dentro de la región y la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes representan los posibles márgenes a considerar a la hora de generar la línea o el círculo con el mejor ajuste posible. Los candidatos a márgenes se indican con pequeños círculos coloreados.

Esta ficha también permite seleccionar y ajustar la región.

También se mostrarán los defectos y espacios detectados, al igual que los anchos mínimo y máximo de los márgenes, marcados con líneas amarillas.

Closed Volver a puntuar

Define si la herramienta se reajustará a la línea con el mejor ajuste posible después de volver a puntuar los márgenes (de forma predeterminada, este parámetro está desactivado).

Nota: La precisión de la herramienta será mayor con este parámetro habilitado, aunque a costa de aumentar el tiempo de procesamiento.

Closed Encuadre de línea

Define el tipo de línea de mejor ajuste (Ajuste automático, Ajuste de línea recta o Ajuste de línea circular; valor predeterminado = Ajuste automático) que debe construirse a partir de los márgenes detectados.

Nota: Para poder utilizar este parámetro, debe activarse el parámetro Volver a puntuar.

Closed Filtrar objetos exteriores

Define si la herramienta eliminará puntos de la recta de mejor ajuste que se encuentren más allá de la distancia definida por el parámetro Filtro de encuadre de distancia (de forma predeterminada, este parámetro está desactivado).

Closed Filtro de encuadre de distancia

Define la distancia (1 - 1920; preajuste = 2), en píxeles, a la que debe encontrarse un margen con respecto a la línea de mejor ajuste original para ser utilizada en el cálculo de reencuadre. Este parámetro sirve para impedir que los defectos afecten al encuadre de línea.

Nota: Para poder utilizar este parámetro, primero debe activarse el parámetro Filtrar objetos exteriores.


Herramienta de detección de defectos de ancho de márgenes - Ficha Defectos

Al seleccionar la ficha Defectos, la herramienta muestra (con líneas amarillas) los grosores mínimo y máximo del par de márgenes detectado, así como los posibles defectos o espacios detectados.

Esta ficha también permite seleccionar y ajustar la región.

Closed Anchura mín.

Especifica que no se considerará como defecto cualquier distancia de anchura (0,001 - 1920; preajuste = 3), en píxeles, entre los pares de márgenes detectados cuyo valor sea inferior a este valor.

Closed Anchura máx.

Especifica que no se considerará como defecto cualquier distancia de anchura (0,001 - 1920; preajuste = 1000), en píxeles, entre los pares de márgenes detectados cuyo valor sea superior a este valor.

Closed Tamaño habilitado

Define si la herramienta informará sobre defectos de tamaño (que expresan la longitud a lo largo del margen); de forma predeterminada, este parámetro está habilitado.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Tamaño mínimo

Define el tamaño mínimo de un defecto (0,001 - 1920; preajuste = 10), en píxeles; las desviaciones continuas de la línea o del círculo con el mejor ajuste posible que sean inferiores a este valor no se consideran defectos.

Closed Tamaño máximo

Define el tamaño máximo de un defecto (0,001 - 1920; preajuste = 1000), en píxeles; las desviaciones continuas de la línea o del círculo con el mejor ajuste posible que sean superiores a este valor no se consideran defectos.

Closed Área habilitada

Define si la herramienta informará sobre defectos en el área; de forma predeterminada, este parámetro está deshabilitado. Los defectos del área representan la longitud a lo largo de la línea o del círculo con el mejor ajuste posible, así como la distancia a la que se encuentra el margen defectuoso de dicha línea o de dicho círculo.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Área mín.

Define el defecto de área mínimo (0,001 - 1000000; preajuste = 10), en píxeles; un área menor que este valor no se considera como defecto.

Closed Área máx.

Define el defecto de área máximo (0,001 - 1000000; preajuste = 1000000), en píxeles; un área mayor que este valor no se considera como defecto.


Herramienta de detección de defectos de ancho de márgenes - Ficha Espacios

Al seleccionar la ficha Espacios, la herramienta mostrará el resultado de la línea o del círculo con el mejor ajuste posible (si está activado), así como los defectos o espacios detectados. Los "espacios" se definen como desviaciones del margen con respecto a la línea o al círculo con el mejor ajuste.

Esta ficha también permite seleccionar y ajustar la región.

Closed Buscar espacios

Define si la herramienta informará sobre espacios en el margen encontrado; de forma predeterminada, este parámetro está activado.

Closed Espacio mínimo

Define el espacio mínimo (0,001 - 1920; preajuste = 3), en píxeles; los espacios menores que este valor no se consideran espacios.

Closed Espacio máximo

Define el espacio máximo (0,001 - 1920; preajuste = 1000), en píxeles; los espacios mayores que este valor no se consideran espacios.

Closed Ignorar espacios finales

Define si la herramienta informará sobre espacios detectados al principio o al final de la región; de forma predeterminada, este parámetro está desactivado.

Closed Resultado

Muestra el número total de defectos, espacios y espacios detectados.


Herramienta de detección de defectos de ancho de márgenes - Fichas de tablas Defectos y Espacios

Las fichas de tablas Defectos de ancho y Espacios comunican los primeros 10 defectos o espacios detectados, por orden de posición a lo largo del margen.

Closed Índice

Se refiere al orden de los defectos/espacios encontrados, clasificados por posición a lo largo del margen; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Y

Devuelve la coordenada Y (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Área

Devuelve el área del rectángulo delimitador del defecto o espacio.

Closed Tamaño

Devuelve el tamaño (longitud) del defecto/espacio a lo largo del margen.

Closed Calibres

Devuelve el rango de calibres que abarca el defecto o espacio.

Closed Unidades/píxeles calibrados

Define si la tabla muestra los resultados en coordenadas del mundo real (Unidades calibradas) o en píxeles (Píxeles).

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.


Uso de las propiedades de entrada/salida de la herramienta de detección de defectos de ancho de márgenes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Área_Habilitada | I | X | X | Entrada/Salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Contraste_Límite_Superior | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Margen0_Transición | I | X | X | Entrada/Salida
Margen1_Transición | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Buscar_Espacios | I | X | X | Entrada/Salida
Ignorar_Espacios_Finales | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Área_Máx | FP | X | X | Entrada/Salida
Tamaño_Máx | FP | X | X | Entrada/Salida
Ancho_Máx | FP | X | X | Entrada/Salida
Espacio_Máximo | FP | X | X | Entrada/Salida
Área_Mínima | FP | X | X | Entrada/Salida
Tamaño_Mín | FP | X | X | Entrada/Salida
Ancho_Mín | FP | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Espacio_Mínimo | FP | X | X | Entrada/Salida
Par_Tamaño | I | X | X | Entrada/Salida
Tipo_Región | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Tamaño_Par | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Tamaño_Habilitado | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Defectos | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Espacios | FP | X | X | Salida
InspectEdgeWidth | S | X | X | Salida
Ancho_Máximo | FP | X | X | Salida
Ancho_Mínimo | FP | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Total_Defectos | FP | X | X | Salida
Región_Enmascarada | A | X | X |
Ruta_de_polilínea | A | X | X |


Herramientas de detección de defectos - Buscador de rebordes

La herramienta de detección de defectos Buscador de rebordes identifica una característica de reborde (definida por un par de márgenes), independientemente del contorno, detectando el centro del reborde y creando una región que permite inspeccionar el ancho del reborde. La herramienta utiliza matrices Calibre de análisis de márgenes para localizar con precisión las características de márgenes. Una vez identificada la característica de reborde, la herramienta traza éste y comunica cualquier rebasamiento de las tolerancias de su grosor como defectos o como espacios.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de detección de defectos Buscador de rebordes resulta muy útil para identificar y verificar el grosor de una característica de reborde, como una gota de pegamento, que aparece aleatoriamente en el campo de visión (FOV).

  1. Configuración de la herramienta de detección de defectos Buscador de rebordes
  2. Ajuste de los parámetros de la herramienta de detección de defectos Buscador de rebordes
  3. Uso de las propiedades de entrada/salida de la herramienta de detección de defectos Buscador de rebordes


Configuración de la herramienta de detección de defectos Buscador de rebordes

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen sobre la característica de margen que desee inspeccionar:

  1. En el menú desplegable Tipo de región, seleccione su región: Región enmascarada o Trayectoria de polilínea. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, al tiempo que se excluye el ruido innecesario o no deseado de la región.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Buscar reborde, Márgenes, Puntuación de márgenes, Defectos y Espacios y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la polilínea correcta. A la hora de realizar la configuración inicial de la herramienta, utilice una imagen que contenga la característica de margen ideal. Las adquisiciones de imágenes subsiguientes contendrán candidatos a márgenes que serán examinados para determinar si existen desviaciones tales como defectos o espacios.
  4. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  5. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de detección de defectos Buscador de rebordes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de detección de defectos Buscador de rebordes consta de las fichas siguientes:

  • Ficha General
  • Buscar reborde
  • Ficha Márgenes
  • Ficha Puntuación de márgenes
  • Ficha Defectos
  • Ficha Espacios
  • Fichas de tablas de estadísticas, defectos de ancho y espacios

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de detección de defectos Buscador de rebordes - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "BuscadorRebordes_1" (si se trata de la primera herramienta de detección de defecto de buscador de rebordes agregada a la tarea; de lo contrario, se incrementará, es decir, "BuscadorRebordes_2", "BuscadorRebordes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Tipo de región

Define el tipo de región utilizado para definir el área de la imagen que se somete a análisis: Región enmascarada (preajuste) o Trayectoria de polilínea.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de detección de defectos Buscador de rebordes - Ficha Buscar reborde

Al seleccionar la ficha Buscar reborde, la herramienta presenta gráficos relacionados con la localización de la característica de reborde. La herramienta mostrará todos los márgenes detectados, marcados en color verde oscuro; los candidatos a márgenes (indicados como pequeños círculos coloreados) dentro de la región (que puede ser seleccionada y ajustada), y la ubicación del reborde como polilínea azul.

Los parámetros se pueden ajustar para aislar los márgenes y los candidatos a márgenes deseados que se utilizarán para construir la trayectoria de polilínea que define el contorno de la característica de reborde.

Closed Buscar tamaño del calibre del reborde

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección para encontrar la característica de reborde (1 - 639; preajuste = 8).

Closed Buscar espaciamiento del calibre del reborde

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Buscar ancho del margen del reborde

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Buscar contraste mínimo del reborde

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Buscar dirección del margen del reborde

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha, Derecha a izquierda, Centro afuera o De fuera adentro; preajuste = Izquierda a derecha).

Closed Buscar transición del Margen0 del reborde

Define la transición del primer margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Buscar transición del Margen1 del reborde

Define la transición del segundo margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Buscar regla del reborde:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Buscar regla del reborde:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Buscar reborde: Límite superior de contraste

Define el límite superior de la transición de contraste (2 - 255; preajuste = 255) que un margen debe cumplir para ser considerado como tal; los márgenes con una transición de contraste superior a este valor tendrán la misma puntuación máxima.

Closed Buscar regla del reborde:Tamaño del par

Define si el par de márgenes detectado con el tamaño más parecido al parámetro Tamaño del par debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está desactivado).

Closed Buscar umbral de puntuación del reborde

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.

Closed Buscar calibres de rebordes

Muestra el número total de calibres en la región.

Closed Buscar índice del calibre del reborde

Define el calibre individual a aislar y visualizar.

Closed Buscar reborde: Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos Buscador de rebordes - Ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra en color azul la ubicación de la trayectoria del reborde, en verde todos los márgenes detectados y en aguamarina los calibres que definen la trayectoria de polilínea generada a partir de la ubicación de la trayectoria del reborde. Los calibres de color aguamarina sólo se pueden ajustar mediante el parámetro Ancho de polilínea.Es posible ajustar los parámetros Ancho de polilínea, Tamaño del calibre, Espaciado del calibre y Contraste mínimo según convenga para aislar los márgenes deseados.

Closed Ancho de polilínea

Define el ancho de los Calibres utilizados para definir la polilínea (1 - 1920; preajuste = 25).

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos Buscador de rebordes - Ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra como pequeños círculos coloreados todos los candidatos a márgenes detectados dentro de la región, los márgenes detectados se indican en color verde oscuro, la ubicación del reborde como polilínea azul, los anchos mínimo y máximo del reborde como líneas amarillas, y finalmente también los defectos o espacios encontrados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha, Derecha a izquierda, Centro afuera o De fuera adentro; preajuste = De fuera adentro).

Closed Transición Margen0

Define la transición del primer margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Transición Margen1

Define la transición del segundo margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Límite superior del contraste

Define el límite superior de la transición de contraste (2 - 255; preajuste = 255) que un margen debe cumplir para ser considerado como tal; los márgenes con una transición de contraste superior a este valor tendrán la misma puntuación máxima.

Closed Regla:Tamaño del par

Define si el par de márgenes detectado con el tamaño más parecido al parámetro Tamaño del par debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está desactivado).

Closed Tamaño del par

Define el tamaño del par de márgenes con el que se obtiene la puntuación más alta (1 - 1920; preajuste = 5). Con este parámetro activado, los pares de márgenes detectados cuyo valor sea superior o inferior a éste puntuarán en proporción al valor que tengan. Por ejemplo, si el tamaño del par es de 10 y se detectan dos candidatos a pares de márgenes, uno con un valor de 8 y otro de 14, se seleccionaría el par de márgenes con el valor de 8 por estar más cerca del límite que el segundo par de márgenes. El parámetro Regla: Tamaño de par debe estar activado para poder activar este parámetro.

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Herramienta de detección de defectos Buscador de rebordes - Ficha Defectos

Al seleccionar la ficha Defectos, la herramienta mostrará gráficos relacionados con la identificación y/o clasificación de los errores presentes en la pieza o en el objeto. La herramienta muestra la ubicación del reborde como polilínea azul, los grosores mínimo y máximo del reborde como líneas amarillas, así como los defectos y espacios que se detecten.

Closed Anchura mín.

Especifica que no se considerará como defecto cualquier distancia de anchura (0,001 - 1920; preajuste = 3), en píxeles, entre los pares de márgenes detectados cuyo valor sea inferior a este valor.

Closed Anchura máx.

Especifica que no se considerará como defecto cualquier distancia de anchura (0,001 - 1920; preajuste = 1000), en píxeles, entre los pares de márgenes detectados cuyo valor sea superior a este valor.

Closed Tamaño habilitado

Define si la herramienta informará sobre defectos de tamaño (que expresan la longitud a lo largo del margen); de forma predeterminada, este parámetro está habilitado.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Tamaño mínimo

Define el tamaño mínimo de un defecto (0,001 - 1920; preajuste = 3), en píxeles; las desviaciones continuas de la polilínea inferiores a este valor no se consideran defectos.

Closed Tamaño máximo

Define el tamaño máximo de un defecto (0,001 - 1920; preajuste = 1000), en píxeles; las desviaciones continuas de la polilínea superiores a este valor no se consideran defectos.

Closed Área habilitada

Define si la herramienta informará sobre defectos en el área; de forma predeterminada, este parámetro está habilitado. Los defectos del área representan la longitud a lo largo de la polilínea y a qué distancia se encuentra el margen defectuoso de la polilínea.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Área mín.

Define el defecto de área mínimo (0,001 - 1000000; preajuste = 10), en píxeles; un área menor que este valor no se considera como defecto.

Closed Área máx.

Define el defecto de área máximo (0,001 - 1000000; preajuste = 1000000), en píxeles; un área mayor que este valor no se considera como defecto.


Herramienta de detección de defectos Buscador de rebordes - Ficha Espacios

Al seleccionar la ficha Espacios, la herramienta muestra gráficos relacionados con la identificación y/o clasificación de los errores presentes en la pieza o en el objeto. La herramienta muestra la ubicación del reborde como polilínea azul, los grosores mínimo y máximo del reborde como líneas amarillas, así como los defectos y espacios detectados.

Closed Buscar espacios

Define si la herramienta informará sobre espacios en el margen encontrado; de forma predeterminada, este parámetro está deshabilitado.

Closed Espacio mínimo

Define el espacio mínimo (0,001 - 1920; preajuste = 3), en píxeles; los espacios menores que este valor no se consideran espacios.

Closed Espacio máximo

Define el espacio máximo (0,001 - 1920; preajuste = 1000), en píxeles; los espacios mayores que este valor no se consideran espacios.

Closed Ignorar espacios finales

Define si la herramienta informará sobre espacios detectados al principio o al final de la región; de forma predeterminada, este parámetro está desactivado.

Closed Resultado

Muestra el número total de defectos, espacios y espacios detectados.


Herramienta de detección de defectos Buscador de rebordes - Fichas de tablas de estadísticas, defectos de ancho y espacios

La ficha de tabla Estadísticas registra los datos de funcionamiento de la herramienta durante determinado período de tiempo. Las fichas de tablas Defectos de ancho y Espacios comunican los primeros 10 defectos o espacios.

Closed Índice

Se refiere al orden de los defectos/espacios encontrados, clasificados por posición a lo largo del margen; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Y

Devuelve la coordenada Y (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Área

Devuelve el área del rectángulo delimitador del defecto o espacio.

Closed Tamaño

Devuelve el tamaño (longitud) del defecto/espacio a lo largo del margen.

Closed Calibres

Devuelve el rango de calibres que abarca el defecto o espacio.

Closed Unidades/píxeles calibrados

Define si la tabla muestra los resultados en coordenadas del mundo real (Unidades calibradas) o en píxeles (Píxeles).

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.


Uso de las propiedades de entrada/salida de la herramienta de detección de defectos Buscador de rebordes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Área_Habilitada | I | X | X | Entrada/Salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Contraste_Límite_Superior | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Margen0_Transición | I | X | X | Entrada/Salida
Margen1_Transición | I | X | X | Entrada/Salida
Buscar_Reborde_Calibre_Índice | I | X | X | Entrada/Salida
Buscar_Reborde_Calibre_Tamaño | I | X | X | Entrada/Salida
Buscar_Reborde_Calibre_Espaciado | I | X | X | Entrada/Salida
Buscar_Reborde_Contraste_Límite_Superior | I | X | X | Entrada/Salida
Buscar_Reborde_Margen_Dirección | I | X | X | Entrada/Salida
Buscar_Reborde_Margen_Anchura | I | X | X | Entrada/Salida
Buscar_Reborde_Margen0_Transición | I | X | X | Entrada/Salida
Buscar_Reborde_Margen1_Transición | I | X | X | Entrada/Salida
Buscar_Reborde_Contraste_Mínimo | I | X | X | Entrada/Salida
Buscar_Reborde_Par_Tamaño | I | X | X | Entrada/Salida
Buscar_Reborde_Regla_Primer_Margen | I | X | X | Entrada/Salida
Buscar_Reborde_Regla_Par_Tamaño | I | X | X | Entrada/Salida
Buscar_Reborde_Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Buscar_Reborde_Umbral_Puntuación | I | X | X | Entrada/Salida
Buscar_Reborde_Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Buscar_Espacios | I | X | X | Entrada/Salida
Ignorar_Espacios_Finales | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Área_Máx | FP | X | X | Entrada/Salida
Tamaño_Máx | FP | X | X | Entrada/Salida
Ancho_Máx | FP | X | X | Entrada/Salida
Espacio_Máximo | FP | X | X | Entrada/Salida
Área_Mínima | FP | X | X | Entrada/Salida
Tamaño_Mín | FP | X | X | Entrada/Salida
Ancho_Mín | FP | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Espacio_Mínimo | FP | X | X | Entrada/Salida
Par_Tamaño | I | X | X | Entrada/Salida
Anchura_Polilínea | I | X | X | Entrada/Salida
Tipo_Región | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Tamaño_Par | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Tamaño_Habilitado | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Calibres.Rechazos.Acumulados | FP | X | X | Salida
Calibres.Rechazos.El_Más_grande | FP | X | X | Salida
Calibres.Rechazos.Porcentaje | FP | X | X | Salida
Calibres.Rechazos.El_Más_pequeño | FP | X | X | Salida
Calibres.Aceptaciones.Acumulados | FP | X | X | Salida
Calibres.Aceptaciones.El_Más_grande | FP | X | X | Salida
Calibres.Aceptaciones.Porcentaje | FP | X | X | Salida
Calibres.Aceptaciones.El_Más_pequeño | FP | X | X | Salida
Defectos.Recuento | FP | X | X | Salida
Defectos.Acumulados | FP | X | X | Salida
Defectos.El_Más_grande | FP | X | X | Salida
Defectos.Ancho_Excesivo.Acumulados | FP | X | X | Salida
Defectos.Ancho_Excesivo.El_Más_grande | FP | X | X | Salida
Defectos.Ancho_Excesivo.Porcentaje | FP | X | X | Salida
Defectos.Ancho_Excesivo.El_Más_pequeño | FP | X | X | Salida
Defectos.El_Más_pequeño | FP | X | X | Salida
Defectos.Ancho_Insuficiente.Acumulados | FP | X | X | Salida
Defectos.Ancho_Insuficiente.El_Más_grande | FP | X | X | Salida
Defectos.Ancho_Insuficiente.Porcentaje | FP | X | X | Salida
Defectos.Ancho_Insuficiente.El_Más_pequeño | FP | X | X | Salida
Recuento_Calibres | FP | X | X | Salida
Defectos | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Buscar_Reborde_Calibres | FP | X | X | Salida
Espacios.Recuento | FP | X | X | Salida
Espacios.Acumulados | FP | X | X | Salida
Espacios.El_Más_grande | FP | X | X | Salida
Espacios.El_Más_pequeño | FP | X | X | Salida
InspectEdgeWidth | S | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Total_Recuento_Defectos | FP | X | X | Salida
Región_Enmascarada | A | X | X |
Ruta_Polilínea | A | X | X |


Herramientas de detección de defectos - Rastreador de rebordes

La herramienta de detección de defectos Rastreador de rebordes inspecciona la ubicación, el contorno y la anchura de una característica de reborde (definida por un par de márgenes). A partir de un modelo de márgenes de una característica de reborde creado por el usuario, la herramienta utiliza matrices Calibre de análisis de márgenes para localizar con precisión las características de márgenes. Una vez creado el modelo de características de reborde, al ejecutar la herramienta, ésta compara las características de rebordes de las imágenes adquiridas con el modelo de reborde y determina si éste se encuentra en la posición correcta y si presenta desviaciones, como defectos o espacios, comunicando el número de defectos y/o de espacios encontrados.

Notas:
  • La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.
  • Todos los valores de entrada se expresan en píxeles, independientemente de que la herramienta esté calibrada en unidades reales.

La herramienta de detección de defectos Rastreador de rebordes resulta muy útil para asegurarse de que una característica de reborde, como un cordón de soldadura, se encuentra en el mismo lugar y no sufre variaciones de forma ni de grosor.

  1. Configuración de la herramienta de detección de defectos Rastreador de rebordes
  2. Ajuste de los parámetros de la herramienta de detección de defectos Rastreador de rebordes
  3. Uso de las propiedades de entrada/salida de la herramienta de detección de defectos Rastreador de rebordes


Configuración de la herramienta de detección de defectos Rastreador de rebordes

Cuando haya agregado la herramienta, deberá seleccionar el tipo de región y luego configurarlo dentro de la imagen sobre la característica de margen que desee inspeccionar:

  1. En el menú desplegable Tipo de región, seleccione su región: Región enmascarada o Trayectoria de polilínea. Posicione y configure la región dentro de la imagen sobre la característica de margen. Al posicionar la región, asegúrese de que los márgenes discurran en paralelo a la dirección de búsqueda de la región y de que la región abarque tanta cantidad de la característica de margen como sea posible, pero también de excluir el ruido innecesario o no deseado de la región. A la hora de realizar la configuración inicial de la herramienta, utilice una imagen que contenga la característica de margen ideal. Las adquisiciones de imágenes subsiguientes contendrán candidatos a márgenes que serán examinados para determinar si existen desviaciones tales como defectos o espacios.

Nota: La línea amarilla discontinua dentro de la Región enmascarada define el área de la región en la que se detectarán las transiciones de márgenes.

  2. Presione el botón Aceptar para confirmar la región (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  3. Una vez confirmada la región, seleccione las diversas fichas, Entrenar reborde, Márgenes, Puntuación de márgenes, Defectos, Espacios y Posición, y ajuste los parámetros y la región según convenga para garantizar que la herramienta detecte los candidatos a márgenes correctos y cree la polilínea correcta.
  4. Una vez ajustados correctamente la región y los parámetros, abra la ficha Entrenar reborde y pulse el botón Entrenar para crear el modelo de márgenes de reborde. Las adquisiciones de imágenes subsiguientes serán comparadas con el modelo de márgenes de reborde entrenado.
  5. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las variaciones y los rangos previsibles.
  6. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de detección de defectos Rastreador de rebordes

Después de haber situado la región de la herramienta, puede optimizar la herramienta para su aplicación.

El panel de ajustes de la herramienta de detección de defectos Rastreador de rebordes consta de las fichas siguientes:

  • Ficha General
  • Entrenar reborde
  • Ficha Márgenes
  • Ficha Puntuación de márgenes
  • Ficha Defectos
  • Ficha Espacios
  • Ficha Posición
  • Fichas de tablas de estadísticas, defectos de ancho, espacios y defectos de posición

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de detección de defectos Rastreador de rebordes - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "RastreadorRebordes_1" (si se trata de la primera herramienta de detección de defectos de rastreador de rebordes agregada a la tarea; de lo contrario, se incrementará, es decir, "RastreadorRebordes_2", "RastreadorRebordes_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Imagen de herramienta

Define qué imagen utilizará la herramienta para realizar su inspección; la imagen no filtrada, adquirida (ajuste predeterminado) o la imagen emitida por una herramienta de filtrado de imágenes o por una herramienta de color (herramientas de ubicación de blob de color y de blobs de color (1-10), Recuento de píxeles de color y herramientas de presencia/ausencia de blobs de color, herramientas de medición del área de un blob de color y de áreas de blobs de color (1-10), herramienta de recuento de blobs de color, herramienta de identificación de modelos de colores o herramienta de filtrado de imágenes de color a binario). Este control sólo está activado si se ha agregado una herramienta de filtrado de imágenes o una herramienta de color.

Closed Elemento de la herramienta

Define un elemento para la herramienta. Este control sólo está habilitado si previamente ya se añadió otra herramienta de definición de un elemento.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Tipo de región

Define el tipo de región utilizado para definir el área de la imagen que se somete a análisis: Región enmascarada (preajuste) o Trayectoria de polilínea.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de detección de defectos Rastreador de rebordes - Ficha Entrenar reborde

Al seleccionar la ficha Entrenar reborde, la herramienta presenta gráficos relacionados con la localización de la característica de reborde. La herramienta mostrará todos los candidatos a márgenes encontrados dentro de la región (e indicados mediante pequeños círculos coloreados), así como la ubicación del reborde como polilínea azul. La región se puede ajustar.

Closed Botón Entrenar

Define el modelo de márgenes de reborde. El botón Entrenar se utiliza al configurar un modelo de márgenes de reborde. Pulse el botón Entrenar después de configurar los parámetros de la herramienta y la región para acentuar las características relevantes del modelo de márgenes de reborde. Una vez entrenado el modelo de márgenes de reborde, la herramienta comparará la característica de reborde en las imágenes adquiridas con el modelo de márgenes de reborde entrenado para determinar si existen desviaciones, como defectos o espacios.

Nota: La herramienta producirá un rechazo hasta que el modelo de márgenes de reborde haya sido entrenado.

Closed Entrenar tamaño del calibre del reborde

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección para encontrar la característica de reborde (1 - 639; preajuste = 8).

Closed Entrenar espaciado del calibre del reborde

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Entrenar ancho del margen del reborde

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Entrenar contraste mínimo del reborde

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Entrenar dirección del margen del reborde

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha, Derecha a izquierda, Centro afuera o De fuera adentro; preajuste = Izquierda a derecha).

Closed Entrenar transición del Margen0 del reborde

Define la transición del primer margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Entrenar transición del Margen1 del reborde

Define la transición del segundo margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Entrenar regla del reborde:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Entrenar regla del reborde:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Entrenar reborde: Límite superior de contraste

Define el límite superior de la transición de contraste (2 - 255; preajuste = 255) que un margen debe cumplir para ser considerado como tal; los márgenes con una transición de contraste superior a este valor tendrán la misma puntuación máxima.

Closed Entrenar regla del reborde:Tamaño del par

Define si el par de márgenes detectado con el tamaño más parecido al parámetro Tamaño del par debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está desactivado).

Closed Entrenar umbral de puntuación del reborde

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.

Closed Entrenar calibres del reborde

Muestra el número total de calibres en la región.

Closed Entrenar índice del calibre del reborde

Define el calibre individual a aislar y visualizar.

Closed Entrenar reborde: Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos Rastreador de rebordes - Ficha Márgenes

Al seleccionar la ficha Márgenes, la herramienta muestra en color azul la ubicación de la trayectoria del reborde, en verde todos los márgenes detectados y en aguamarina los calibres que definen la trayectoria de polilínea generada a partir de la ubicación de la trayectoria del reborde. Los calibres de color aguamarina sólo se pueden ajustar mediante el parámetro Ancho de polilínea.Es posible ajustar los parámetros Ancho de polilínea, Tamaño del calibre, Espaciado del calibre y Contraste mínimo según convenga para aislar los márgenes deseados.

Closed Ancho de polilínea

Define el ancho de los Calibres utilizados para definir la polilínea (1 - 1920; preajuste = 25).

Closed Tamaño del calibre

Define el número de píxeles por calibre que deberán analizarse a lo largo de la dirección de inspección (1 - 639; preajuste = 5).

Closed Espaciado de calibres

Define la distancia, en píxeles, entre el final de un calibre y el principio del siguiente calibre (-1 - 639; preajuste = 0).

Closed Ancho de margen

Define la distancia en píxeles (1 - 10; preajuste = 3) a la que se produce una transición de márgenes. Este ajuste permite filtrar el ruido de la imagen.

Closed Contraste mínimo

Define la transición mínima de contraste de escala de grises (1 - 255; preajuste = 10) para ser considerada un margen.

Closed Recuento de calibres

Muestra el número total de calibres en la región.

Closed Índice de calibre

Define el calibre individual a aislar y visualizar.

Closed Mostrar todos los calibres

Define si todos los calibres de la región deben mostrarse permanentemente; de forma predeterminada, los calibres están ocultos.


Herramienta de detección de defectos Rastreador de rebordes - Ficha Puntuación de márgenes

Al seleccionar la ficha Puntuación de márgenes, la herramienta muestra como pequeños círculos coloreados todos los candidatos a márgenes detectados dentro de la región, los márgenes detectados se indican en color verde oscuro, la ubicación del reborde como polilínea azul, los anchos mínimo y máximo del reborde como líneas amarillas, y finalmente también los defectos o espacios encontrados.

Closed Dirección de búsqueda de márgenes

Define la dirección en la que la herramienta intentará detectar los márgenes, con respecto a la región (Izquierda a derecha, Derecha a izquierda, Centro afuera o De fuera adentro; preajuste = De fuera adentro).

Closed Transición Margen0

Define la transición del primer margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Transición Margen1

Define la transición del segundo margen detectado (Oscuro a claro, Claro a oscuro o Cualquiera; preajuste = Cualquiera). Para aumentar la exactitud y la velocidad, especifique el tipo de transición.

Closed Regla:Primer margen

Define si el primer margen detectado debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Regla:Margen más marcado

Define si el margen con la transición de contraste más marcada debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está activado).

Closed Límite superior del contraste

Define el límite superior de la transición de contraste (2 - 255; preajuste = 255) que un margen debe cumplir para ser considerado como tal; los márgenes con una transición de contraste superior a este valor tendrán la misma puntuación máxima.

Closed Regla:Tamaño del par

Define si el par de márgenes detectado con el tamaño más parecido al parámetro Tamaño del par debe recibir la máxima prioridad al determinar si un candidato a margen cumple los criterios para ser considerado como tal (de forma predeterminada, este ajuste está desactivado).

Closed Tamaño del par

Define el tamaño del par de márgenes con el que se obtiene la puntuación más alta (1 - 1920; preajuste = 5). Con este parámetro activado, los pares de márgenes detectados cuyo valor sea superior o inferior a éste puntuarán en proporción al valor que tengan. Por ejemplo, si el tamaño del par es de 10 y se detectan dos candidatos a pares de márgenes, uno con un valor de 8 y otro de 14, se seleccionaría el par de márgenes con el valor de 8 por estar más cerca del límite que el segundo par de márgenes. El parámetro Regla: Tamaño de par debe estar activado para poder activar este parámetro.

Closed Umbral de puntuación

Define un umbral de puntuación para filtrar y excluir los márgenes cuyas puntuaciones (0 - 255; preajuste = 10) sean inferiores a este valor.


Herramienta de detección de defectos Rastreador de rebordes - Ficha Defectos

Al seleccionar la ficha Defectos, la herramienta mostrará gráficos relacionados con la identificación y/o clasificación de los errores presentes en la pieza o en el objeto. La herramienta muestra la ubicación del reborde como polilínea azul, los grosores mínimo y máximo del reborde como líneas amarillas, así como los defectos y espacios que se detecten.

Closed Anchura mín.

Especifica que no se considerará como defecto cualquier distancia de anchura (0,001 - 1920; preajuste = 3), en píxeles, entre los pares de márgenes detectados cuyo valor sea inferior a este valor.

Closed Anchura máx.

Especifica que no se considerará como defecto cualquier distancia de anchura (0,001 - 1920; preajuste = 1000), en píxeles, entre los pares de márgenes detectados cuyo valor sea superior a este valor.

Closed Tamaño habilitado

Define si la herramienta informará sobre defectos de tamaño (que expresan la longitud a lo largo del margen); de forma predeterminada, este parámetro está habilitado.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Tamaño mínimo

Define el tamaño mínimo de un defecto (0,001 - 1920; preajuste = 10), en píxeles; las desviaciones continuas de la polilínea inferiores a este valor no se consideran defectos.

Closed Tamaño máximo

Define el tamaño máximo de un defecto (0,001 - 1920; preajuste = 1000), en píxeles; las desviaciones continuas de la polilínea superiores a este valor no se consideran defectos.

Closed Área habilitada

Define si la herramienta informará sobre defectos en el área; de forma predeterminada, este parámetro está habilitado. Los defectos del área representan la longitud a lo largo de la polilínea y a qué distancia se encuentra el margen defectuoso de la polilínea.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Área mín.

Define el defecto de área mínimo (0,001 - 1000000; preajuste = 10), en píxeles; un área menor que este valor no se considera como defecto.

Closed Área máx.

Define el defecto de área máximo (0,001 - 1000000; preajuste = 1000000), en píxeles; un área mayor que este valor no se considera como defecto.


Herramienta de detección de defectos Rastreador de rebordes - Ficha Posición

Al seleccionar la ficha Posición, la herramienta mostrará gráficos relacionados con la identificación y/o clasificación de los errores de posición de la pieza o del objeto. La herramienta mostrará la última ubicación entrenada del reborde en forma de polilínea azul, los grosores mínimo y máximo del reborde como líneas amarillas, así como los defectos y/o espacios detectados.

Closed Defectos de posición habilitados

Define si se informará sobre defectos de posición (de forma predeterminada, este parámetro está habilitado).

Closed Distancia mínima de defectos de posición

Define el valor mínimo (0,001 a 1920; preajuste = 3), en píxeles, que un candidato a margen puede estar alejado del centro del modelo de márgenes del reborde sin que se considere un error.

Closed Tamaño de defectos de posición habilitado

Define si también deben aplicarse criterios de tamaño para definir los errores de posición (de forma predeterminada, este parámetro está habilitado). Los errores de tamaño se indican a lo largo del margen.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Tamaño mínimo de defectos de posición

Define el tamaño mínimo de un defecto (0,001 - 1920; preajuste = 3), en píxeles; las desviaciones continuas de la polilínea inferiores a este valor no se consideran defectos.

Closed Tamaño máximo de defectos de posición

Define el tamaño máximo de un defecto (0,001 - 1920; preajuste = 1000), en píxeles; las desviaciones continuas de la polilínea superiores a este valor no se consideran defectos.

Closed Área de defectos de posición habilitada

Define si la herramienta informará sobre defectos en el área; de forma predeterminada, este parámetro está habilitado. Los defectos del área representan la longitud a lo largo de la polilínea y a qué distancia se encuentra el margen defectuoso de la polilínea.

Nota: Si tanto Habilitado por tamaño como Habilitado por área están ajustados a Activado, sólo se mostrarán los defectos que incumplan ambas condiciones.

Closed Área mínima de defectos de posición

Define el defecto de área mínimo (0,001 - 1000000; preajuste = 10), en píxeles; un área menor que este valor no se considera como defecto.

Closed Área máxima de defectos de posición

Define el defecto de área máximo (0,001 - 1000000; preajuste = 1000000), en píxeles; un área mayor que este valor no se considera como defecto.

Closed Resultado

Muestra el número total de defectos, espacios y/o errores de posición detectados.


Herramienta de detección de defectos Rastreador de rebordes - Fichas de tablas de estadísticas, defectos de ancho, espacios y defectos de posición

La ficha de tabla Estadísticas registra los datos de funcionamiento de la herramienta durante determinado período de tiempo. Las fichas de tablas Defectos de ancho, Espacios y Defectos de posición comunican los primeros 10 defectos/espacios y errores de posición.

Closed Índice

Se refiere al orden de los defectos/espacios encontrados, clasificados por posición a lo largo del margen; 1 a 10 (el orden numérico de EasyBuilder asume que 0=1).

Closed X

Devuelve la coordenada X (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Y

Devuelve la coordenada Y (si se ha seleccionado Unidades calibradas y la imagen fue calibrada durante el paso Configurar imagen, porque de lo contrario comunica los valores de píxeles) del rectángulo delimitador del defecto o espacio.

Closed Área

Devuelve el área del rectángulo delimitador del defecto o espacio.

Closed Tamaño

Devuelve el tamaño (longitud) del defecto/espacio a lo largo del margen.

Closed Calibres

Devuelve el rango de calibres que abarca el defecto o espacio.

Closed Unidades/píxeles calibrados

Define si la tabla muestra los resultados en coordenadas del mundo real (Unidades calibradas) o en píxeles (Píxeles).

Nota: La herramienta comunica los resultados en píxeles, salvo que la imagen se haya calibrado en unidades reales en Configurar imagen.


Herramienta de detección de defectos Rastreador de rebordes - Ficha Espacios

Al seleccionar la ficha Espacios, la herramienta muestra gráficos relacionados con la identificación y/o clasificación de los errores presentes en la pieza o en el objeto. La herramienta muestra la ubicación del reborde como polilínea azul, los grosores mínimo y máximo del reborde como líneas amarillas, así como los defectos y espacios detectados.

Closed Buscar espacios

Define si la herramienta informará sobre espacios en el margen encontrado; de forma predeterminada, este parámetro está activado.

Closed Espacio mínimo

Define el espacio mínimo (0,001 - 1920; preajuste = 3), en píxeles; los espacios menores que este valor no se consideran espacios.

Closed Espacio máximo

Define el espacio máximo (0,001 - 1920; preajuste = 1000), en píxeles; los espacios mayores que este valor no se consideran espacios.

Closed Ignorar espacios finales

Define si la herramienta informará sobre espacios detectados al principio o al final de la región; de forma predeterminada, este parámetro está desactivado.

Closed Resultado

Muestra el número total de defectos, espacios y espacios detectados.


Uso de las propiedades de entrada/salida de la herramienta de detección de defectos Rastreador de rebordes

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Área_Habilitada | I | X | X | Entrada/Salida
Calibre_Índice | I | X | X | Entrada/Salida
Calibre_Tamaño | I | X | X | Entrada/Salida
Calibre_Espaciado | I | X | X | Entrada/Salida
Contraste_Límite_Superior | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Margen_Anchura | I | X | X | Entrada/Salida
Margen0_Transición | I | X | X | Entrada/Salida
Margen1_Transición | I | X | X | Entrada/Salida
Buscar_Margen_Dirección | I | X | X | Entrada/Salida
Buscar_Espacios | I | X | X | Entrada/Salida
Ignorar_Espacios_Finales | I | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Área_Máx | FP | X | X | Entrada/Salida
Área_Máx_Defecto_Posición | FP | X | X | Entrada/Salida
Área_Máx_Defecto_Tamaño | FP | X | X | Entrada/Salida
Tamaño_Máx | FP | X | X | Entrada/Salida
Ancho_Máx | FP | X | X | Entrada/Salida
Espacio_Máximo | FP | X | X | Entrada/Salida
Área_Mínima | FP | X | X | Entrada/Salida
Área_Mín_Defecto_Posición | FP | X | X | Entrada/Salida
Distancia_Mín_Defecto_Posición | FP | X | X | Entrada/Salida
Tamaño_Mín_Defecto_Posición | FP | X | X | Entrada/Salida
Tamaño_Mín | FP | X | X | Entrada/Salida
Ancho_Mín | FP | X | X | Entrada/Salida
Contraste_Mínimo | I | X | X | Entrada/Salida
Espacio_Mínimo | FP | X | X | Entrada/Salida
Par_Tamaño | I | X | X | Entrada/Salida
Anchura_Polilínea | I | X | X | Entrada/Salida
Área_Defecto_Posición_Habilitada | I | X | X | Entrada/Salida
Tamaño_Defecto_Posición_Habilitado | I | X | X | Entrada/Salida
Defectos_Posición_Habilitados | I | X | X | Entrada/Salida
Tipo_Región | I | X | X | Entrada/Salida
Regla_Primer_Margen | I | X | X | Entrada/Salida
Regla_Tamaño_Par | I | X | X | Entrada/Salida
Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Umbral_Puntuación | I | X | X | Entrada/Salida
Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Tamaño_Habilitado | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
Entrenar_Reborde_Calibre_Índice | I | X | X | Entrada/Salida
Entrenar_Reborde_Calibre_Tamaño | I | X | X | Entrada/Salida
Entrenar_Reborde_Calibre_Espaciado | I | X | X | Entrada/Salida
Entrenar_Reborde_Contraste_Límite_Superior | I | X | X | Entrada/Salida
Entrenar_Reborde_Margen_Dirección | I | X | X | Entrada/Salida
Entrenar_Reborde_Margen_Anchura | I | X | X | Entrada/Salida
Entrenar_Reborde_Margen0_Transición | I | X | X | Entrada/Salida
Entrenar_Reborde_Margen1_Transición | I | X | X | Entrada/Salida
Entrenar_Reborde_Contraste_Mínimo | I | X | X | Entrada/Salida
Entrenar_Reborde_Tamaño_Par | I | X | X | Entrada/Salida
Entrenar_Reborde_Regla_Primer_Margen | I | X | X | Entrada/Salida
Entrenar_Reborde_Regla_Par_Tamaño | I | X | X | Entrada/Salida
Entrenar_Reborde_Regla_Margen_Más_Marcado | I | X | X | Entrada/Salida
Entrenar_Reborde_Umbral_Puntuación | I | X | X | Entrada/Salida
Entrenar_Reborde_Mostrar_Todos_Calibres | I | X | X | Entrada/Salida
Recuento_Calibres | FP | X | X | Salida
Calibres.Rechazos.Recuento | FP | X | X | Salida
Calibres.Rechazos.Acumulados | FP | X | X | Salida
Calibres.Rechazos.El_Más_grande | FP | X | X | Salida
Calibres.Rechazos.Porcentaje | FP | X | X | Salida
Calibres.Rechazos.El_Más_Pequeño | FP | X | X | Salida
Calibres.Aceptaciones.Recuento | FP | X | X | Salida
Calibres.Aceptaciones.Acumulados | FP | X | X | Salida
Calibres.Aceptaciones.El_más_grande | FP | X | X | Salida
Calibres.Aceptaciones.Porcentaje | FP | X | X | Salida
Calibres.Aceptaciones.El_más_pequeño | FP | X | X | Salida
Defectos.Recuento | FP | X | X | Salida
Defectos.Acumulados | FP | X | X | Salida
Defectos.El_Más_Grande | FP | X | X | Salida
Defectos.Ancho_Excesivo.Recuento | FP | X | X | Salida
Defectos.Ancho_Excesivo.Acumulados | FP | X | X | Salida
Defectos.Ancho_Excesivo.El_Más_Grande | FP | X | X | Salida
Defectos.Ancho_Excesivo.Porcentaje | FP | X | X | Salida
Defectos.Ancho_Excesivo.El_Más_Pequeño | FP | X | X | Salida
Defectos.El_Más_Pequeño | FP | X | X | Salida
Defectos.Ancho_Insuficiente.Recuento | FP | X | X | Salida
Defectos.Ancho_Insuficiente.Acumulados | FP | X | X | Salida
Defectos.Ancho_Insuficiente.El_Más_Grande | FP | X | X | Salida
Defectos.Ancho_Insuficiente.Porcentaje | FP | X | X | Salida
Defectos.Ancho_Insuficiente.El_Más_Pequeño | FP | X | X | Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecución | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Espacios.Recuento | FP | X | X | Salida
Espacios.Acumulados | FP | X | X | Salida
Espacios.El_Más_Grande | FP | X | X | Salida
Espacios.El_Más_Pequeño | FP | X | X | Salida
InspectEdgeWidth | S | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Posición.Recuento | FP | X | X | Salida
Posición.Acumuladas | FP | X | X | Salida
Posición.LaMásGrande | FP | X | X | Salida
Posición.LaMásPequeña | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Total_Recuento_Defectos | FP | X | X | Salida
Región_Enmascarada | A | X | X |
Ruta_Polilínea | A | X | X |
Entrenar | A | X | X |


Herramientas de calibración - Punto N

La herramienta de calibración Punto N se utiliza para construir un archivo de calibración a partir de 2 a 16 características de entrada y de sus correspondientes coordenadas del mundo real asociadas. Este archivo de calibración se puede exportar y aplicar como un Tipo de calibración en el paso Configurar imagen y utilizar en otras tareas.

Consejo: Después de construir la calibración, se recomienda guardar el archivo de tarea. Para calibraciones posteriores, basta con cargar la tarea de calibración, adquirir la imagen y autoexportar el archivo de calibración actualizado a todas las tareas que hagan referencia a este archivo de calibración.

Esta herramienta es útil cuando se dispone de una pieza u objeto de dimensiones del mundo real conocidas, como las que proceden de dibujos CAD, y se desea aplicar esos valores como calibración. En este tipo de aplicación, el sistema de visión In-Sight adquiere una imagen de la pieza u objeto y asocia los valores del mundo real a las coordenadas de píxeles de la imagen. Una vez almacenado en el sistema de archivos local del sistema de visión, permite aplicar la calibración resultante a otras tareas.

  1. Configuración de la herramienta de calibración Punto N
  2. Ajuste de los parámetros de la herramienta de calibración Punto N
  3. Uso de las propiedades de entrada/salida de la herramienta de calibración Punto N
Notas:
  • Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas para definir los puntos de calibración. Antes de agregar esta herramienta, ensamble las herramientas de ubicación y/o de inspección necesarias que serán utilizadas como entradas.
  • Cuando utilice una herramienta de calibración de punto N o secuencial de punto N, la configuración física y óptica (lente, sistema de visión y relación física entre el sistema de visión y la escena adquirida) debe ser igual tanto durante la calibración como durante el funcionamiento en tiempo de ejecución. El sistema debe recalibrarse si se altera cualquiera de estas posiciones. Por lo tanto, se recomienda utilizar la misma combinación de sistema de visión y lente tanto para calibrar como para procesar las imágenes en tiempo de ejecución. El sistema de visión y la lente también deben conservar sus ajustes originales de configuración y calibración. Por ejemplo, si cambia el formato de adquisición (variando la resolución) o mueve el sistema de visión, se invalidará la transformación bidimensional (2D) que establece la correspondencia entre píxeles y coordenadas del mundo real.


Configuración de la herramienta de calibración Punto N

Consejo: Después de construir la calibración, se recomienda guardar el archivo de tarea. Para calibraciones posteriores, basta con cargar la tarea de calibración, adquirir la imagen y autoexportar el archivo de calibración actualizado a todas las tareas que hagan referencia a este archivo de calibración.

Una vez añadida la herramienta, deberá definir las características de entrada (puntos, los orígenes de los elementos o el centro de características circulares) que se utilizarán para construir la calibración:

  1. Una vez añadida la herramienta, EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes (puntos, los orígenes de los elementos o el centro de características circulares) que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde). EasyBuilder insertará automáticamente una herramienta de presencia/ausencia de círculos para cualquier característica circular no definida previamente.

  2. En primer lugar, seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).

  3. A continuación, seleccione las demás características que se utilizarán para definir la calibración. Se pueden seleccionar entre un mínimo de 2 y un máximo de 16 características.

  4. Después de seleccionar todas las características deseadas, presione el botón Aceptar (presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).

  5. Una vez agregada correctamente la herramienta y definidas las características de entrada, deberá definir los valores de medida del mundo real para cada característica de entrada. En la Tabla de puntos, seleccione un punto e introduzca los valores de medición asociados en los campos Coordenada real X y Coordenada real Y, bien tecleándolos manualmente o mediante los controles de incremento/decremento.
  6. Guardar el archivo de tarea.
  7. Presione el botón Exportar de la ficha Ajustes para colocar el archivo de calibración en el sistema de archivos local del sistema de visión In-Sight. Esto permitirá seleccionar la calibración como opción Importar en el ajuste Tipo de calibración del paso Configurar imagen.
  8. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  9. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de calibración Punto N

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la herramienta de calibración Punto N secuencial consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Tabla de puntos

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de calibración Punto N - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Configurar una imagen, Entradas/Salidas y Comunicación); el nombre predeterminado es "Calib_1" (si se trata de la primera herramienta de calibración agregada a la tarea; de lo contrario, se incrementará, es decir, "Calib_2", "Calib_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de calibración Punto N - ficha Ajustes

Closed Nombre de archivo

Define el nombre del archivo de calibración (el nombre predeterminado es Predeterminado).

Closed Nombre completo

Muestra el nombre completo del archivo de calibración que aparece en el paso Configurar imagen al configurar el Tipo de calibración como Importar. Para que pueda aparecer en el paso Configurar imagen, el archivo debe haberse exportado previamente.

Closed Exportar

Exporta el archivo de calibración al sistema de archivos local del sistema de visión In-Sight.

Closed Exportación automática

Define si el archivo de calibración debe o no exportarse de forma automática al activarse el primer disparador después de haber cargado el archivo de tarea o de haber adquirido una imagen. Si la opción está habilitada (activada), la herramienta exportará su archivo de calibración automáticamente al activarse el primer disparador después de haber cargado el archivo de tarea o de haber adquirido una imagen (esta opción está deshabilitada o desactivada de forma predeterminada).

Nota: Si está activada la exportación automática, el archivo de tarea que contiene los datos de calibración debe guardarse para que se pueda exportar el archivo de calibración. Si después de guardar el archivo de tarea no aparece el archivo de calibración en el panel de archivos de In-Sight, haga clic en otro sistema de visión In-Sight o en un emulador y vuelva para seleccionar el sistema de visión pertinente. Ahora debería aparecer el archivo.


Herramienta de calibración Punto N - Tabla de puntos

La Tabla de coordenadas de píxeles y reales se utiliza para visualizar y definir los valores de las coordenadas reales para la calibración.

Closed Punto

Muestra una lista indexada de sólo lectura de los puntos encontrados, de 1 a 16 (para ordenaciones numéricas, EasyBuilder asume que 0=1).

Closed Fila de píxeles

Muestra la ubicación de la fila del píxel del punto (X).

Closed Columna de píxeles

Muestra la coordenada (X) de la columna de imagen del punto.

Closed Coordenada real X

Muestra el valor de la coordenada del mundo real (X) del punto.

Closed Coordenada real Y

Muestra el valor de la coordenada del mundo real (Y) del punto.

Closed Coordenada real X

Define el valor de la coordenada del mundo real (X) correspondiente al punto seleccionado.

Closed Coordenada real Y

Define el valor de la coordenada del mundo real (Y) correspondiente al punto seleccionado.

Closed Seleccionar puntos

Habilita la selección de características de entrada como puntos. Cuando presione este botón, EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes (puntos, los orígenes de los elementos o el centro de características circulares) que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde). Seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).


Uso de las propiedades de entrada/salida de la herramienta de calibración Punto N

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Sensor de visión In-Sight 2000-23M

Nota: OPC no se admite en el sensor de visión In-Sight 2000-23M.

Nombre simbólico | Tipo de datos | EasyView | Datos de entrada/salida
Auto_Exportacion | I | X | Entrada/Salida
Descripción | S | X | Entrada/Salida
Exportacion_Externa | I | X | Entrada/Salida
Nombre_Archivo | S | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | Entrada/Salida
Herramienta_Habilitada | I | X | Entrada/Salida
World_Point0-15.X | FP | X | Entrada/Salida
World_Point0-15.Y | FP | X | Entrada/Salida
Recuento_Errores | FP | X | Salida
Tiempo_Ejecucion | FP | X | Salida
Exportacion_Completa | FP | X | Salida
Rechazo | FP |  | Salida
Recuento_Rechazos | FP | X | Salida
Nombre_Completo | S | X | Salida
Aceptación | FP |  | Salida
Recuento_Aceptaciones | FP | X | Salida
Pixel_Point0-15.X | FP | X | Salida
Pixel_Point0-15.Y | FP | X | Salida
Estado | FP | X | Salida
Herramienta_Estado_Habilitado | FP | X | Salida
Exportación | A | X |

Sistemas de visión In-Sight

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Auto_Exportacion | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
Exportacion_Externa | I | X | X | Entrada/Salida
Nombre_Archivo | S | X | X | Entrada/Salida
Incluir_En_Pasada_Tarea | I | X | X | Entrada/Salida
Herramienta_Habilitada | I | X | X | Entrada/Salida
World_Point0-15.X | FP | X | X | Entrada/Salida
World_Point0-15.Y | FP | X | X | Entrada/Salida
Recuento_Errores | FP | X | X | Salida
Tiempo_Ejecucion | FP | X | X | Salida
Exportacion_Completa | FP | X | X | Salida
Rechazo | FP | X |  | Salida
Recuento_Rechazos | FP | X | X | Salida
Nombre_Completo | S | X | X | Salida
Aceptación | FP | X |  | Salida
Recuento_Aceptaciones | FP | X | X | Salida
Pixel_Point0-15.X | FP | X | X | Salida
Pixel_Point0-15.Y | FP | X | X | Salida
Estado | FP | X | X | Salida
Herramienta_Estado_Habilitado | FP | X | X | Salida
Exportación | A | X | X |


Herramientas de calibración - Punto N secuencial

La herramienta de calibración Punto N secuencial se utiliza para construir un archivo de calibración a partir de una característica de entrada y de sus correspondientes coordenadas del mundo real asociadas, a lo largo de una secuencia de adquisiciones de imágenes. Este archivo de calibración se puede exportar y aplicar como un Tipo de calibración en el paso Configurar imagen y utilizar en otras tareas.

Consejo: Después de construir la calibración, se recomienda guardar el archivo de tarea. Para calibraciones posteriores, basta con cargar la tarea de calibración, adquirir la imagen y autoexportar el archivo de calibración actualizado a todas las tareas que hagan referencia a este archivo de calibración.

Esta herramienta es útil cuando se está calibrando un sistema de visión In-Sight y un sistema de coordenadas de un robot. En este tipo de aplicación, el controlador del robot presenta un objeto al sistema de visión en diversas ubicaciones, una por cada adquisición de imagen. Con cada adquisición, se añade un punto a la tabla de calibración. Una vez que el robot ha visitado cada ubicación y se ha guardado cada punto, puede exportarse el archivo de calibración y guardarse el archivo de tarea.

  1. Configuración de la herramienta de calibración Punto N secuencial
  2. Ajuste de los parámetros de la herramienta de calibración Punto N secuencial
  3. Uso de las propiedades de entrada/salida de la herramienta de calibración Punto N secuencial
Notas:
  • Esta herramienta requiere utilizar otras herramientas de ubicación y/o de inspección como entradas para definir los puntos de calibración. Antes de agregar esta herramienta, ensamble las herramientas de ubicación y/o de inspección necesarias que serán utilizadas como entradas.
  • Cuando utilice una herramienta de calibración de punto N o secuencial de punto N, la configuración física y óptica (lente, sistema de visión y relación física entre el sistema de visión y la escena adquirida) debe ser igual tanto durante la calibración como durante el funcionamiento en tiempo de ejecución. El sistema debe recalibrarse si se altera cualquiera de estas posiciones. Por lo tanto, se recomienda utilizar la misma combinación de sistema de visión y lente tanto para calibrar como para procesar las imágenes en tiempo de ejecución. El sistema de visión y la lente también deben conservar sus ajustes originales de configuración y calibración. Por ejemplo, si cambia el formato de adquisición (variando la resolución) o mueve el sistema de visión, se invalidará la transformación bidimensional (2D) que establece la correspondencia entre píxeles y coordenadas del mundo real.


Configuración de la herramienta de calibración Punto N secuencial

Consejo: Después de construir la calibración, se recomienda guardar el archivo de tarea. Para calibraciones posteriores, basta con cargar la tarea de calibración, adquirir la imagen y autoexportar el archivo de calibración actualizado a todas las tareas que hagan referencia a este archivo de calibración.

Una vez añadida la herramienta, deberá definir la característica de entrada (el punto, el origen de un elemento o el centro de una característica circular) que se utilizará para construir la calibración:

  1. Una vez añadida la herramienta, EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes (puntos, los orígenes de los elementos o el centro de características circulares) que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde). EasyBuilder insertará automáticamente una herramienta de presencia/ausencia de círculos para cualquier característica circular no definida previamente.
  2. Seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).
  3. Después de seleccionar la característica deseada, presione el botón Aceptar (o presione el botón Cancelar si prefiere no agregar la herramienta a la tarea).
  4. En la ficha Ajustes, defina el parámetro Número de puntos especificando cuántos puntos/adquisiciones definirán la calibración.
  5. Desplace el controlador del robot a la siguiente ubicación y adquiera una imagen del punto en su nueva ubicación. Continúe este proceso hasta que se hayan adquirido todos los puntos.
  6. Una vez se hayan agregado correctamente los puntos, deberá definir los valores de medición reales de los puntos. En la Tabla de puntos, seleccione un punto e introduzca los valores de medición asociados en los campos Coordenada real X y Coordenada real Y, bien tecleándolos manualmente o mediante los controles de incremento/decremento.
  7. Presione el botón Exportar de la ficha Ajustes para colocar el archivo de calibración en el sistema de archivos local del sistema de visión In-Sight. Esto permitirá seleccionar la calibración como opción Importar en el ajuste Tipo de calibración del paso Configurar imagen.
  8. Una vez efectuada la configuración inicial de la herramienta, cargue varias imágenes y ajuste los parámetros de la herramienta según sus necesidades para compensar las posibles variaciones previstas.
  9. Por último, si lo desea, utilice las propiedades Entrada/Salida de la herramienta para compartir datos de ésta con otras herramientas y/o dispositivos externos.


Ajuste de los parámetros de la herramienta de calibración secuencial del punto N

Una vez agregada la herramienta a su tarea, puede comenzar la personalización y el ajuste fino de ésta para adaptarla a los requisitos particulares de su aplicación.

El panel de ajustes de la Herramienta de calibración Punto N secuencial consta de los siguientes elementos:

  • Ficha General
  • Ficha Ajustes
  • Tabla de puntos

Sugerencia: Pruebe la tarea con ayuda de TestRun. TestRun realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. Así podrá comprobar si la tarea se comporta según lo esperado o si es necesario reajustar determinados parámetros para tolerar las variaciones admisibles.


Herramienta de calibración Punto N secuencial - Ficha General

Closed Nombre de herramienta

Define el nombre de la herramienta de inspección que se utilizará en la configuración de los resultados (Entradas/Salidas y Comunicación); el nombre predeterminado es "Calib_1" (si se trata de la primera herramienta de calibración agregada a la tarea; de lo contrario, se incrementará, es decir, "Calib_2", "Calib_3", etc.). Personalice su herramienta asignándole un nombre relacionado con su aplicación en particular.

Closed Herramienta habilitada

Define si la herramienta de inspección debe ejecutarse y, en caso afirmativo, cuándo debe hacerlo (el ajuste predeterminado es “Activado”). Seleccione "OFF" si desea inhabilitar la herramienta; seleccione "Expresión" si desea condicionar la ejecución de la herramienta al resultado de una expresión (este control sólo está habilitado para herramientas que proporcionan un parámetro Expresión); o seleccione "Entrada" si desea asociar la herramienta a una determinada línea de entrada discreta, donde se puede activar o desactivar (una señal alta, 1, significa activada; una señal baja, 0, significa desactivada). La asociación de la herramienta a una entrada permite al sistema de control, por ejemplo un PLC, determinar qué herramientas deben ejecutarse.

Closed Incluir en aceptación de tarea

Define si el estado de aceptación o rechazo de la herramienta debe incluirse en el estado de aceptación o rechazo de la tarea; de forma predeterminada, está activado y se incluirá en el estado de aceptación o rechazo de la tarea. Desactive esta casilla de verificación para mantener el estado de aceptación o rechazo de la herramienta independiente del de la otra herramienta de la tarea. Este control debe desactivarse si se prevé que una herramienta generará un rechazo; por ejemplo, si se utilizan dos herramientas de identificación de patrones PatMax para determinar si una pieza es derecha o izquierda, es previsible que cada vez una de las herramientas genere un rechazo. Esta situación daría como resultado que la tarea produciría un rechazo cada vez que se ejecutase, sea cual sea el lado de la pieza identificado, con la casilla de verificación activada.

Closed Tiempo de ejecución (ms)

Visualiza el tiempo, en milisegundos, que la herramienta necesitó para ejecutar su inspección. Este tiempo puede variar dependiendo de la complejidad de la escena, de la posición de la característica dentro de la imagen y de la magnitud de variación permitida en los parámetros.

Closed Descripción

Comentario que describe la finalidad de la herramienta (de forma predeterminada, este campo está en blanco). Pueden utilizarse hasta 255 caracteres alfanuméricos o 127 caracteres de idiomas asiáticos.


Herramienta de calibración secuencial del punto N - ficha Ajustes

Closed Número de puntos

Define el número de puntos a adquirir (2 a 16; predeterminado = 12).

Closed Restablecer

Pone a cero el contador de adquisiciones.

Closed Restablecimiento en línea

Define si el contador de adquisiciones debe ponerse a cero cuando el sistema de visión In-Sight pasa al modo en línea. De forma predeterminada, esta opción está desactivada.

Closed Restablecimiento de carga de tareas

Define si el contador de adquisiciones debe ponerse a cero cuando se carga el archivo de tarea. De forma predeterminada, esta opción está activada.

Closed Nombre de archivo

Define el nombre del archivo de calibración (el nombre predeterminado es Predeterminado).

Closed Nombre completo

Muestra el nombre completo del archivo de calibración que aparece en el paso Configurar imagen al configurar el Tipo de calibración como Importar. Para que pueda aparecer en el paso Configurar imagen, el archivo debe haberse exportado previamente.

Closed Exportar

Exporta el archivo de calibración al sistema de archivos local del sistema de visión In-Sight.

Closed Exportación automática

Define si el archivo de calibración debe o no exportarse de forma automática al activarse el primer disparador después de haber cargado el archivo de tarea o de haber adquirido una imagen. Si la opción está habilitada (activada), la herramienta exportará su archivo de calibración automáticamente al activarse el primer disparador después de haber cargado el archivo de tarea o de haber adquirido una imagen (esta opción está deshabilitada o desactivada de forma predeterminada).

Nota: Si está activada la exportación automática, el archivo de tarea que contiene los datos de calibración debe guardarse para que se pueda exportar el archivo de calibración. Si después de guardar el archivo de tarea no aparece el archivo de calibración en el panel de archivos de In-Sight, haga clic en otro sistema de visión In-Sight o en un emulador y vuelva para seleccionar el sistema de visión pertinente. Ahora debería aparecer el archivo.

Closed Resultado

Muestra el estado de aceptación o rechazo de la herramienta.


Herramienta de calibración secuencial del punto N - Tabla de puntos

La Tabla de coordenadas de píxeles y reales se utiliza para visualizar y definir los valores de las coordenadas reales para la calibración.

Closed Punto

Muestra una lista indexada de sólo lectura de los puntos encontrados, de 1 a 16 (para ordenaciones numéricas, EasyBuilder asume que 0=1).

Closed Fila de píxeles

Muestra la ubicación de la fila del píxel del punto (X).

Closed Columna de píxeles

Muestra la coordenada (X) de la columna de imagen del punto.

Closed Coordenada real X

Muestra el valor de la coordenada del mundo real (X) del punto.

Closed Coordenada real Y

Muestra el valor de la coordenada del mundo real (Y) del punto.

Closed Coordenada real X

Define el valor de la coordenada del mundo real (X) correspondiente al punto seleccionado.

Closed Coordenada real Y

Define el valor de la coordenada del mundo real (Y) correspondiente al punto seleccionado.

Closed Seleccionar puntos

Habilita la selección de características de entrada como puntos. Cuando presione este botón, EasyBuilder examinará su imagen y proporcionará una selección de las características inteligentes (puntos, los orígenes de los elementos o el centro de características circulares) que haya detectado automáticamente (resaltadas en color azul verdoso), así como cualquier característica que usted haya definido anteriormente con otra herramienta (resaltada en verde). Seleccione una de las características inteligentes disponibles haciendo clic en ella (en ese momento, su color cambiará a fucsia).


Uso de las propiedades de entrada/salida de la herramienta de calibración secuencial del punto N

La tabla siguiente muestra las propiedades de herramientas (parámetros de entrada y resultados de salida), listadas por nombre simbólico, tipo de datos y en función de si la propiedad se puede utilizar para comunicaciones OPC, como elementos de EasyView y como datos de entrada y/o de salida para dispositivos externos.

Closed Nombre simbólico

Los nombres simbólicos de las propiedades de herramientas no se pueden modificar, y van precedidos del parámetro Nombre de la herramienta cuando se utilizan en comunicaciones externas (p. ej. "Blobs_1.Boundary" como parámetro de entrada del límite de una herramienta de ubicación Blobs (1-10)).

Closed Tipo de datos

Existen cuatro tipos de datos: Acción (A = "Action"), Coma flotante (FP = "Floating Point"), Número entero (I = "Integer") y Cadena (S = "String").

  • Acción: Se refiere a un parámetro de entrada que fuerza una acción, como una región o un botón (p. ej. el botón Entrenar fuente en el panel Ajustes de la herramienta de identificación Leer Texto).
  • Coma flotante: Se refiere a un valor de coma flotante (p. ej. 335,264, que es el valor de coma flotante del resultado de la salida de Fixture.X de una herramienta de ubicación Patrón).
  • Número entero: Se refiere a un número entero (p. ej., 4, que es el valor entero utilizado para establecer el parámetro de entrada Número a buscar de una herramienta de ubicación Blobs (1-10)).
  • Cadena: Se refiere a un valor de cadena (p. ej., (857.9,666.6) diámetro = 144.4, que es la cadena de resultado de salida de una herramienta de ubicación Círculo).
Closed OPC

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar etiquetas OPC del paso de la aplicación Comunicaciones.

Closed EasyView

Indica si la propiedad de la herramienta se incluye en el diálogo Seleccionar elementos de EasyView del paso de la aplicación Comunicaciones.

Closed Datos de entrada/salida

Indica si la propiedad de la herramienta se incluye en los diálogos Seleccionar datos de entrada (entrante) o Seleccionar datos de salida (saliente), al configurar las comunicaciones con un dispositivo externo, tal como un PLC o robot, en el paso de la aplicación Comunicaciones.

Nombre simbólico | Tipo de datos | OPC | EasyView | Datos de entrada/salida
Auto_Export | I | X | X | Entrada/Salida
Descripción | S | X | X | Entrada/Salida
External_Export | I | X | X | Entrada/Salida
External_Reset | I | X | X | Entrada/Salida
File_Name | S | X | X | Entrada/Salida
Include_In_Job_Pass | I | X | X | Entrada/Salida
Job_Load_Reset | I | X | X | Entrada/Salida
Number_Of_Points | I | X | X | Entrada/Salida
Online_Reset | I | X | X | Entrada/Salida
Tool_Enabled | I | X | X | Entrada/Salida
World_Point0-15.X | FP | X | X | Entrada/Salida
World_Point0-15.Y | FP | X | X | Entrada/Salida
Error_Count | FP | X | X | Salida
Execution_Time | FP | X | X | Salida
Export_Complete | FP | X | X | Salida
Rechazada | FP | X |  | Salida
Fail_Count | FP | X | X | Salida
Full_Name | S | X | X | Salida
Aceptación | FP | X |  | Salida
Pass_Count | FP | X | X | Salida
Pixel_Point0-15.X | FP | X | X | Salida
Pixel_Point0-15.Y | FP | X | X | Salida
Resultado | S | X | X | Salida
Estado | FP | X | X | Salida
Tool_Enabled_Status | FP | X | X | Salida
Exportar | A | X | X |
Restablecer | A | X | X |


Entradas/Salidas

El paso Entradas/Salidas se utiliza para definir los ajustes de las líneas de entrada y de salida discretas de los sistemas de visión In-Sight y los módulos de E/S compatibles. Puede personalizar el nombre de la línea, definir el tipo de la señal, seleccionar la transición de margen y los resultados de la herramienta de la señal y forzar entradas o salidas para probar su aplicación.

  • Configuración de líneas de entrada y salida
    • Configuración del módulo de E/S
    • Número de líneas de entrada y salida
    • Líneas de entrada y salida predeterminadas
    • Controles del cuadro de diálogo Detalles de salida
  • Entradas: carga de un archivo de tarea
  • Entradas: activación y desactivación de herramientas de ubicación e inspección
  • Entradas: disparo de adquisición de imagen
  • Entradas: entrenamiento de un patrón Modelo sobre una línea de entrada
  • Salidas: señalización de una adquisición de imagen fallida
  • Salidas: disparo de una luz para la adquisición de imágenes
  • Salidas: ajuste de una línea según el resultado de una herramienta de ubicación o de inspección
Notas:
  • Este paso de la aplicación está desactivado cuando se utiliza un emulador.
  • Antes de configurar líneas de entrada o de salida, anote si su dispositivo de salida es PNP (emisor de corriente) o NPN (receptor de corriente) y asegúrese de que el dispositivo esté conectado correctamente al sensor In-Sight o al módulo de E/S. Para obtener más información, consulte el manual de instalación correspondiente al sensor o módulo de E/S In-Sight.


Configuración de líneas de entrada y salida

  1. De forma opcional, pulse el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S. Configure el módulo de E/S y presione el botón Aceptar para cerrar el cuadro de diálogo Configuración del módulo de E/S. En el momento de establecerse la primera conexión correcta entre el sistema de visión y el módulo de entrada/salida, en la lista aparecerá el mensaje "(conectado)" junto al módulo de E/S correspondiente. Una vez establecida una conexión correcta con un módulo de expansión de E/S, puede comenzar a adaptar las líneas a los requisitos particulares de su aplicación.
  2. Seleccione la línea de entrada o de salida que desea configurar. El número de entradas y salidas accesibles varía según el modelo In-Sight utilizado y el módulo de E/S aplicable. Para obtener más información, consulte este tema.
  3. In-Sight de las series 76xx - 79xx solamente: Si la línea admite una E/S bidireccional, seleccione Entrada o Salida en el menú desplegable Dirección.
  4. Puede personalizar la línea predeterminada Nombre si introduce un nombre nuevo específico para su aplicación. El nombre puede incluir hasta 15 bytes, únicamente como referencia; no cambia la funcionalidad de la línea y no puede hacerse referencia.

  5. A continuación, defina un tipo de señal para la línea de entrada seleccionada. Cada línea se puede configurar para una de las siguientes funciones:

    Tipo de señal de entrada Descripción
    Información de usuario

    Línea de entrada de uso general; se utiliza para activar o desactivar las herramientas de ubicación e inspección.

    Poner a cero contadores

    Pone a cero los contadores de EasyBuilder (Tarea.Recuento_Rechazos, Tarea.Recuento_Inspecciones, Tarea.Recuento_Aceptaciones, <Herramienta>.Recuento_Errores, <Herramienta>.Recuento_Rechazos y <Herramienta>.Recuento_Aceptaciones).

    Nota:

    • Este tipo de señal solo funciona cuando el sistema de visión se encuentra en línea.
    • Solo se puede configurar una línea de entrada para poner a cero los contadores.
    • Cuando se crea una tarea nueva después de haber definido una de las líneas de entrada con Poner a cero contadores, la tarea nueva revierte automáticamente la línea de entrada a Disparador de evento (en blanco si se utiliza el sensor de visión In-Sight de la serie 2000).

    Disparador de evento

    Dispara un evento siguiendo la lógica creada en la vista de hoja de cálculo. Para que un disparador de evento actualice la hoja de cálculo, esta debe contener una estructura de eventos con sus parámetros de disparador configurados para este número de línea de entrada discreta.

    Nota:

    • Este tipo de señal solo funciona cuando el sistema de visión se encuentra en línea.
    • Esta opción necesita acceso a la vista de hoja de cálculo, salvo cuando se utiliza para entrenar un patrón Modelo sobre una línea de entrada.

    Número de identificación de tarea

    Proporciona un bit de un número de identificación de tarea, que se carga cuando el estado de una línea de entrada diferente con un tipo de conmutador de carga de tarea se encuentra en la posición activado.

    Nota:

    • Para poder utilizar la función Número de identificación de tarea, la tarea que se cargará debe estar guardada con un prefijo numérico del 0 al 127.
    • El bit menos significativo del número de identificación de tarea corresponde a la línea de entrada discreta con el número más bajo del módulo de E/S.

    En línea/Sin conexión*

    Fuerza el sistema de visión al estado Sin conexión o En línea (BAJO (0) = sin conexión y ALTO (1) = en línea).

    Nota: Si el tipo de señal se establece como en línea, el sistema de visión puede seguir sin conexión si se ajustó como sin conexión manualmente en la interfaz de usuario de In-Sight Explorer o si se ejecutó un comando Poner en línea del modo nativo, SO0, para pasar el sistema de visión al estado Sin conexión.

    Disparador de adquisición*
    (No se admite en los sensores In-Sight de la serie 2000 ni en CIO-1400)

    Dispara el sistema de visión para que adquiera una imagen.

    Nota:

    • Para utilizar la entrada Disparador de adquisición, el parámetro Disparador del cuadro de grupo Editar ajustes de adquisición debe estar establecido en Externo y una línea de señal debe estar conectada físicamente a la entrada del sistema de visión In-Sight.
    • Pueden alcanzarse mayores velocidades de disparo utilizando la entrada del disparador de adquisición integrada en el sistema de visión (ajustando el parámetro "Disparador" a Cámara) en lugar de activar el sistema de visión con una línea de entrada de uso general configurada como disparador de adquisición (ajustando el parámetro "Disparador" a Externo).
    • Si el parámetro "Disparador" está ajustado a Externo y se pierde alguna adquisición, el sistema de visión no enviará la salida ERR: Adquisición perdida. La señal ERR: Adquisición perdida solo puede realizarse con el parámetro "Disparador" ajustado a Cámara.

    Conmutador de carga de tarea*

    En la posición ACTIVADO lee todas las líneas de número de identificación de tarea y carga la tarea especificada.

    Nota: El sistema de visión debe estar sin conexión.

    Cambio de tarea (mediante pulso)

    (Solo se admite en sensores In-Sight de la serie 2000 que utilizan E/S directa)

    Inicia un cambio de tarea en función de la detección de los pulsos de entrada que se diferencia por la anchura de los pulsos. Un dispositivo externo (como un PLC) genera los pulsos y estos se envían al sensor In-Sight 2000. Primero, el dispositivo externo emite un pulso inicial. Después, el dispositivo externo emite pulsos de recuento con un espacio entre cada pulso de recuento. Por último, el dispositivo externo emite un pulso de parada.

    Tipo de pulso | Longitud de pulso
    Pulso inicial | 20 ms (± 2 ms)
    Pulso de recuento | 10 ms (± 1 ms)
    Espacio entre pulsos | 10 ms (± 1 ms)
    Pulso de parada | 20 ms (± 2 ms)

    Si todos los pulsos y los espacios entre pulsos coinciden con las longitudes de pulso especificadas, la solicitud de cambio de tarea se considera correcta y la tarea se carga en el sensor. Si falla alguna de las condiciones (es decir, un pulso incorrecto o una duración del espacio entre pulsos incorrecta), la solicitud de cambio de tarea se rechaza y no se produce ningún cambio de tarea.

    Nota:

    • Este tipo de señal solo funciona cuando el sensor de visión se encuentra en línea.
    • Para usar la función Cambio de tarea (mediante pulso), al menos se debe haber guardado una tarea y con un prefijo numérico de 0 a 31, en el formato de Nºnombrearchivotarea.job (por ejemplo, 1InspeccionPin.job). El número de pulsos de recuento emitidos debe corresponder con el prefijo numérico de la tarea que se va a cargar.
    • El comando del modo nativo SetSystemConfig("PulseJobChangeTiming") puede utilizarse para configurar las anchuras de pulso del pulso inicial, el pulso de recuento, el espacio entre pulsos y el pulso de parada.
    • También puede configurar una línea de salida discreta como un tipo Carga de tarea satisfactoria o Carga de tarea satisfactoria para pulsar la salida e informar del éxito o fallo de la solicitud de cambio de tarea.

    Recepción serie
    (solo E/S directa)

    Configura esta línea como una línea de recepción en serie.

    Nota:

    • El tipo de señal solo está disponible si se conecta un sistema de visión In-Sight de las series 70xx - 74xx con In-Sight Explorer 4.7.1 o versiones posteriores y si se utiliza el firmware In-Sight 4.7.1 o versiones posteriores.
    • Este tipo de señal solo es válido para la línea de entrada 1 cuando se selecciona E/S directa.
    • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
    • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE del cable de conexión estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.
    * Este Tipo de señal de entrada no se puede utilizar simultáneamente en más de una línea de entrada.
  6. Seleccione un Tipo de margen para la línea de entrada seleccionada, que controla la sensibilidad de la línea de entrada frente a las transiciones de margen.
    • Margen de aumento: Cambia el estado de la línea de entrada en el flanco anterior de un pulso.
    • Margen de caída: Cambia el estado de la línea de entrada en el margen de caída de un pulso.
    • Ambos márgenes: Cambia el estado de la línea de entrada en los márgenes de entrada y descendente de un pulso. Esta opción solo está disponible cuando el Tipo de señal seleccionado es Disparador de evento.

  7. A continuación, defina un tipo de señal para la línea de salida seleccionada. Cada línea se puede configurar para una de las siguientes funciones:

    Tipo de señal de salida | Descripción
    Resultado de la tarea (predeterminado) | Permite controlar el estado de esta línea de salida en función del resultado de la herramienta de ubicación o de inspección. Puede ser pulsatoria o fija.
    Alto | Fuerza la salida a ALTA (1).
    Bajo | Fuerza la salida a BAJA (0).
    Comienzo de adquisición

    Indica que el sistema de visión ha iniciado una adquisición. Siempre es pulsatoria.

    Nota: En el sistema de visión In-Sight 8405, la señal Comienzo de adquisición es pulsatoria cuando se expone la primera fila de píxeles. Consulte Operación de efecto persiana para obtener más información.
    Final de adquisición

    Señala el final de adquisición del sistema de visión. Siempre es pulsatoria.

    Nota: En el sistema de visión In-Sight 8405, la señal Final de adquisición es pulsatoria cuando se haya completado la lectura total de la imagen. Consulte Operación de efecto persiana para obtener más información.
    Tarea completada | Indica cada vez que EasyBuilder ha finalizado una actualización. Siempre es pulsatoria.
    Sistema ocupado | ALTA ALTA cuando el sistema de visión está ejecutando una tarea o respondiendo a la introducción de información por parte de un usuario; BAJA cuando el sistema de visión está inactivo.
    Carga de tarea satisfactoria | Indica que ha finalizado correctamente una tarea. Siempre es pulsatoria.
    Falla en la carga de tarea | Indica un fallo en la carga de una tarea. Siempre es pulsatoria.
    ERROR: Adquisición fallida

    Indica que se ha recibido un disparador de adquisición antes de enviar una señal Final de adquisición o que no había disponible ningún búfer de imagen para la adquisición de imágenes cuando se recibió el disparador de adquisición. Siempre es pulsatoria.

    Nota: El parámetro Disparador del cuadro de grupo Editar ajustes de adquisición del paso Configurar imagen debe estar ajustado a Cámara para poder utilizar la salida ERR: Adquisición fallida.
    ERROR: Seguimiento sobrepasado | Indica que EasyBuilder emitió una señal de salida discreta demorada algún tiempo después de lo esperado. Siempre es pulsatoria.
    ERROR: Cola de seguimiento completa | Indica que EasyBuilder emitió una salida discreta retardada para una línea donde se había programado anteriormente una salida diferente en ese mismo momento. Siempre es pulsatoria.
    En línea/Sin conexión | ALTA (1) cuando el sistema de visión está en línea; BAJA (0) cuando el sistema de visión está sin conexión.
    Estrobo | El margen de aumento o de caída de la señal se puede utilizar para accionar una luz estroboscópica.
    Control de luz
    (Solo CIO-1460)     		El margen de aumento o de caída de la señal se puede utilizar para accionar una luz.
    Espera de módulo de E/S
    (CIO-1450 y CIO-1460 solamente)

    Activado significa que el módulo de E/S ha detectado un error de comunicación entre el sistema de visión y el módulo de E/S y está intentando restablecer la comunicación. La línea se apaga cuando el módulo de E/S detecta que se ha corregido el estado de error.

    Nota: Este tipo de salida solo es válido para las líneas 0 - 7 al configurar el módulo CIO-1450 o CIO-1460.
    Lifeline
    (solo CIO-MICRO y CIO-MICRO-CC)     		ALTA cuando el sistema de visión In-Sight Micro está conectado activamente al CIO-MICRO o CIO-MICRO-CC. BAJA cuando falla la conexión con el sistema de visión.
    Forma de onda

    Habilita una función Waveform, WriteWaveformPulseTrain o WriteWaveformClocked en la hoja de cálculo para controlar el estado de esta línea de salida.

    Nota: Esta opción requiere disponer de acceso a la vista de hoja de cálculo.
    Transmisión serie

    Configura la línea como línea de transmisión en serie.

    Nota:

    • El tipo de señal solo está disponible si se conecta un sistema de visión In-Sight de las series 70xx - 74xx con In-Sight Explorer 4.7.1 o versiones posteriores y si se utiliza el firmware In-Sight 4.7.1 o versiones posteriores.
    • Este tipo de señal solo es válido para la línea de salida 1 cuando se selecciona E/S directa.
    • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
    • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE del cable de conexión estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.
    Tarea aprobada/rechazada (solamente In-Sight de las series 76xx - 79xx e In-Sight 9902L) | Si está seleccionado, el LED de aceptación/rechazo del sistema de visión y el indicador anular se iluminan en verde (aceptación) o en rojo (rechazo) según el estado actual del estado general de Aceptaciones/Rechazos.
  8. Pulse el botón Detalles para abrir el cuadro de diálogo Detalles de salida correspondiente a la línea de salida seleccionada, siempre que existan ajustes detallados para el Tipo de señal de salida especificado.

  9. Opcionalmente, marque la casilla de verificación Desactivar salidas si está desconectado para desactivar las salidas cuando el sistema de visión esté sin conexión.

    Nota: Si está activada la casilla de verificación Desactivar salidas si está desconectado y el módulo de E/S CIO-MICRO o CIO-MICRO-CC tiene una línea de salida configurada como un tipo de señal LifeLine, la línea continuará ALTA cuando el sistema de visión se deje sin conexión.
  10. Opcionalmente, utilice la opción Forzar para probar y depurar su aplicación, antes o después de la implementación. La opción Forzar sustituye los ajustes definidos de la línea, lo que le permite "forzar" la activación de una línea de entrada o de salida para probar el resultado mientras que el sensor In-Sight esté con conexión.
    1. Seleccione la línea para la que desea realizar pruebas.
    2. Fije el ajuste Forzar como Activado. Esta acción "forzará" la línea para que realice su acción configurada.
    3. Ponga el sistema de visión en línea e inicie el sistema de visión.

    4. Una vez han finalizado las pruebas de la línea, ponga el sistema de visión fuera de línea y fije el ajuste Forzar como Desactivado o Nada.

    Nota:

    • Para las líneas de salida, la funcionalidad Forzar no genera una salida real. Solo cambia el valor de una salida que se produciría de no ser así.
    • Si simplemente quiere probar la conexión eléctrica de la línea de salida, es mejor establecer la línea de salida en "ALTA" o "BAJA" en lugar de utilizar Forzar y, a continuación, poner el sistema de visión en línea. Esto mantendrá la señal de salida alta o baja mientras el sistema de visión esté conectado en el modo en línea. Puede utilizar después un multímetro para determinar si la trayectoria eléctrica funciona según lo previsto.
  11. Todos los cambios efectuados en estos ajustes se guardan automáticamente en el sistema de visión (no en el archivo de tarea .job) al salir del paso.


Configuración del módulo de E/S

Closed Configuración de CIO-1400, CIO-1450 o CIO-1460
  1. Conéctese a un sistema de visión compatible desde In-Sight Explorer.
  2. Abra el cuadro de diálogo Configuración del módulo de E/S.
  3. Seleccione CIO-1400, CIO-1450 o CIO-1460 en la lista desplegable Seleccionar módulo de E/S.
  4. Haga clic en Aceptar para cerrar el cuadro de diálogo.
Closed Configuración de CIO-MICRO o CIO-MICRO-CC
  1. Conéctese a un sistema de visión compatible desde In-Sight Explorer.
  2. Abra el cuadro de diálogo Configuración del módulo de E/S.
  3. Seleccione CIO-MICRO o CIO-MICRO-CC en la lista desplegable Seleccionar módulo de E/S.
  4. Seleccione el módulo de E/S adecuado en la lista desplegable Conectar a.

Nota: Si el nombre de equipo del módulo de E/S no se muestra en la lista, seleccione <Conectar mediante dirección IP> e introduzca la dirección IP del módulo de E/S de forma manual.

  5. En el campo Tiempo de actualización, especifique el intervalo de tiempo necesario para la sincronización de entrada y salida (1 ms - 500 ms; valor predeterminado = 20 ms) entre el sistema de visión In-Sight Micro y el módulo de E/S CIO-MICRO o CIO-MICRO-CC.

Nota: Si el exceso de latencia de la señal de salida fuera un problema, reduzca el valor de Tiempo de actualización. No obstante, reduzca el valor de Tiempo de actualización lo menos posible para su aplicación; al reducir el valor de Tiempo de actualización puede aumentar el tiempo de ejecución de tareas.

  6. También puede hacer clic en el botón Cambiar configuración... para configurar los ajustes de red del módulo de E/S.
    • El servidor DHCP configura los módulos de E/S CIO-MICRO y CIO-MICRO-CC de In-Sight de forma dinámica al iniciar. Se puede asignar un nombre de equipo nuevo, pero todos los demás campos del cuadro de diálogo están desactivados.

Nota: Si no hay ningún servidor DHCP disponible, el módulo de E/S agota el tiempo de espera y se enlaza a una dirección IP local de vínculo.

  • Se puede usar una dirección IP estática para los módulos CIO-MICRO y CIO-MICRO-CC si se desactiva la casilla de verificación Utilizar servidor DHCP y se establecen los ajustes adecuados en los campos Dirección IP, Máscara de subred, Puerta de enlace predeterminada, Servidor DNS y Nombre de dominio.
  7. Haga clic en Aceptar para cerrar el cuadro de diálogo.
Closed Configuración de CIO-WENET

Para poder configurar el módulo de E/S CIO-WENET en In-Sight Explorer, antes debe asignar una dirección IP al módulo. Una vez asignada la dirección IP al módulo, este se puede configurar en In-Sight Explorer:

  1. Conéctese a un sistema de visión compatible desde In-Sight Explorer.
  2. Abra el cuadro de diálogo Configuración del módulo de E/S.
  3. Seleccione CIO-WENET en la lista desplegable Seleccionar módulo de E/S.
  4. En el campo Dirección IP, especifique la dirección IP que haya asignado previamente al módulo CIO-WENET.
  5. En el campo Tiempo de actualización, especifique el intervalo de tiempo necesario para la sincronización de entrada y salida (1 ms - 500 ms; valor predeterminado = 20 ms) entre el sistema de visión In-Sight Micro y el módulo de E/S CIO-WENET.
Notas:
  • Si el exceso de latencia de la señal de salida fuera un problema, reduzca el valor de Tiempo de actualización. No obstante, reduzca el valor de Tiempo de actualización lo menos posible para su aplicación; al reducir el valor de Tiempo de actualización puede aumentar el tiempo de ejecución de tareas.
  • En el caso del módulo CIO-WENET, el tiempo de sincronización es 3 ms más largo que el Tiempo de actualización.
  6. Haga clic en Aceptar para cerrar el cuadro de diálogo.


Número de líneas de entrada y salida

El número de salidas directas (integradas) varía de la siguiente manera, dependiendo del sistema de visión In-Sight utilizado:

Sistema de visión In-Sight | Entradas directas (integradas) | Salidas directas (integradas)
In-Sight Micro de la serie 1000 | Nada | 2 salidas de alta velocidad 2 LED configurables por el usuario (1 verde, 1 rojo)
In-Sight de la serie 2000 | 1 entrada de uso general | 4 salidas de alta velocidad 2 LED configurables por el usuario (1 verde o rojo, 1 amarillo)
In-Sight de la serie 5000 | Nada | 2 salidas de alta velocidad 2 LED configurables por el usuario (1 verde, 1 rojo)
In-Sight de las series 70xx - 74xx | 3 entradas de uso general | 4 salidas de alta velocidad 2 LED configurables por el usuario (1 verde, 1 rojo)
In-Sight de las series 76xx - 79xx | Hasta 3 entradas de uso general2 | Hasta 4 salidas de alta velocidad 2 LED configurables por el usuario (1 verde o rojo, 1 rojo)
In-Sight de la serie 8000 | Nada | 2 salidas de alta velocidad 2 LED configurables por el usuario (1 verde, 1 rojo)
In-Sight 9902L | 1 entrada de uso general | 2 salidas de alta velocidad 2 LED configurables por el usuario (1 verde o rojo, 1 rojo)

Nota:

  • Los sistemas de visión In-Sight tienen una entrada de disparador de adquisición dedicado en el sistema de visión. Para obtener más información, consulte el manual de instalación del sistema de visión incluido con el software In-Sight Explorer.
  • Si se conecta el cable de conexión, el sistema de visión In-Sight de las series 76xx - 79xx admite salidas de alta velocidad bidireccionales y entradas de uso general para HS OUT 2 / IN 2 y HS OUT 3 / IN 3. Estas líneas se configuran como salidas de forma predeterminada.

El módulo de E/S permite proporcionar entradas y salidas discretas adicionales. El número de entradas y salidas discretas varía según el módulo de E/S aplicable, de la siguiente manera:

Módulo de E/S | Sistema de visión In-Sight compatible | Entradas discretas | Salidas discretas
CIO-1400 | In-Sight de la serie 5000 (excepto 5604), In-Sight de la serie 2000, In-Sight de las series 76xx - 79xx | 7 entradas de uso general | 6 salidas de uso general
CIO-MICRO | In-Sight Micro de la serie 1000, In-Sight de la serie 5000, In-Sight de la serie 70xx - 79xx, In-Sight de la serie 8000 | 8 entradas de uso general | 8 salidas de uso general
CIO-MICRO-CC | In-Sight Micro de la serie 1000, In-Sight de la serie 5000 (excepto 5705, 5705C y 5715), In-Sight de las series 70xx - 74xx | 8 entradas de uso general | 8 salidas de uso general
CIO-1450 | In-Sight de la serie 5000 (excepto 5604, 5705, 5705C y 5715) | 8 entradas de uso general | 8 salidas de uso general
CIO-1460 | In-Sight de la serie 5000 (excepto 5604, 5605, 5705, 5705C y 5715) | 8 entradas de uso general | 8 salidas de uso general
CIO-WENET | In-Sight Micro de la serie 1000 | 8 entradas de uso general | 8 salidas de uso general

Notas:

  • El módulo de E/S CIO-1400 admite sensores de visión In-Sight de la serie 2000 con versiones de firmware 5.3.0 y superiores.
  • El módulo de E/S CIO-1400 admite el sistema de visión In-Sight de las series 76xx - 79xx con In-Sight Explorer 5.4.0 y versiones superiores. Si se conecta al sistema de visión con una versión anterior de In-Sight Explorer, conéctese al módulo de E/S CIO-1400 y configure las líneas de E/S. No se conservarán las modificaciones.
  • El módulo de E/S CIO-MICRO admite sistemas de visión In-Sight 5705, 5705C, 5715 e In-Sight de la serie 8000 con versiones de firmware 5.3.0 y superiores.
  • Los módulos de E/S CIO-MICRO y CIO-MICRO-CC son compatibles con los sistemas de visión In-Sight de las series 5100 y 5400 con al menos 128 MB de memoria flash no volátil. Los modelos se pueden identificar mediante el número de tipo (821-xxxx-xx). El número de tipo se encuentra en la etiqueta adherida al sistema de visión. Para ver una lista completa de modelos junto con el número de tipo y la memoria flash no volátil, haga clic aquí.
  • Los módulos CIO-1450, CIO-1460 y CIO-WENET I/O son obsoletos y ya no están disponibles para la compra; sin embargo, dichos módulos continúan admitiéndose en In-Sight Explorer por compatibilidad con versiones anteriores.


Líneas de entrada y salida predeterminadas

Closed In-Sight Micro de la serie 1000

Nota:

  • HS OUT 0 y HS OUT 1 son salidas de alta velocidad integradas, directamente desde el sistema de visión.
  • El sistema de visión admite el tipo de señal estroboscópica para la línea HSOUT 1.

E/S directa

Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
4 | LED verde
5 | LED rojo

CIO-MICRO o CIO-MICRO-CC

Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verde
11 | LED rojo

CIO-WENET

Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verde
11 | LED rojo
Closed In-Sight de la serie 2000

Nota:

  • IN 0 es una entrada integrada, directamente desde el sensor de visión.

  • HS OUT 0, HS OUT 1, HS OUT 2 y HS OUT 3 son salidas de alta velocidad integradas, directamente desde el sensor de visión.

  • El sensor de visión admite el tipo de señal estroboscópica para la línea HSOUT 1.
  • Salida de un único LED con ambos estados, rojo y verde, que se puede configurar.

E/S directa

Entrada | Nombre
0 | IN 0
Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
2 | HSOUT 2
3 | HSOUT 3
4 | LED verde
 | LED rojo
5 | LED amarillo

CIO-1400

Entrada | Nombre
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
 | Línea 5
5 | Línea 6
7 | Línea 7
8 | LED verde
9 | LED rojo
10 | LED amarillo
11 | Deshabilitada
12 | Deshabilitada
Closed In-Sight de la serie 5000

CIO-1400

Entrada | Nombre
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | LED verde
9 | LED rojo

CIO-1450

Nota: Cuando se envían salidas discretas pulsantes desde el módulo de E/S CIO-1450, el ancho de pulso puede ser 10 milisegundos mayor que lo especificado.
Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verde
11 | LED rojo

CIO-1460

Nota: Cuando se realiza un ciclo de energía en un módulo de E/S CIO-1460, las salidas discretas pueden disparar durante aproximadamente 250 microsegundos durante el inicio.
Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verde
11 | LED rojo
12 | Deshabilitada
13 | Deshabilitada

CIO-MICRO/CIO-MICRO-CC

Nota:

  • El módulo de E/S CIO-MICRO admite sistemas de visión In-Sight 5705, 5705C, 5715 e In-Sight de la serie 8000 con versiones de firmware 5.3.0 y superiores.
  • Los módulos de E/S CIO-MICRO y CIO-MICRO-CC son compatibles con los sistemas de visión In-Sight de las series 5100 y 5400 con al menos 128 MB de memoria flash no volátil. Los modelos se pueden identificar mediante el número de tipo (821-xxxx-xx). El número de tipo se encuentra en la etiqueta adherida al sistema de visión. Para ver una lista completa de modelos junto con el número de tipo y la memoria flash no volátil, haga clic aquí.
Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verde
11 | LED rojo
Closed In-Sight de las series 70xx - 74xx

Notas:

  • Los sistemas de visión In-Sight de las series 70xx - 74xx admiten la conexión simultánea del cable de conexión y del módulo E/S CIO-MICRO o CIO-MICRO-CC.
  • IN 1, IN 2 e IN 3 son entradas integradas, directamente del sistema de visión. Las entradas directas (integradas) en los sistemas de visión In-Sight de las series 7000 (70xx - 79xx) solo se admiten si el sistema de visión está conectado con el cable de conexión.
  • HS OUT 0, HS OUT 1, HS OUT 2 y HS OUT 3 son salidas de alta velocidad integradas, directamente desde el sistema de visión. Las salidas de alta velocidad en los sistemas de visión In-Sight de las series 70xx - 74xx solo se admiten si el sistema de visión está conectado con el cable de conexión.
  • El sistema de visión admite el tipo de señal estroboscópica para la línea HSOUT 0.
  • Si conecta un dispositivo estroboscópico externo al cable de luz externa de un sistema In-Sight de las series 70xx - 74xx, use el cuadro de diálogo Ajustes de luz para configurar los parámetros de la luz externa.
  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE del cable de conexión estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.

E/S directa

Entrada | Nombre
1 | IN 1/Recepción serie
2 | IN 2
3 | IN 3
Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1/Transmisión serie
2 | HSOUT 2
3 | HSOUT 3
4 | LED verde
5 | LED rojo

CIO-MICRO/CIO-MICRO-CC

Nota:

  • Cuando el sistema de visión está conectado al cable de conexión y se ha establecido una conexión de Ethernet con un módulo de E/S CIO-MICRO:
    • No se admiten los terminales TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 y HS COMMON ni el puerto de E/S (DB15) del módulo de E/S. No conecte los cables de alimentación de los dispositivos remotos a estos terminales.
    • No se admite el puerto de E/S (DB15) del módulo de E/S. No conecte nada a este puerto.
    • Se desactivan los contactos RS-232 TRANSMIT y RS-232 RECEIVE del cable de conexión. El puerto RS-232 OUT (tipo DB9) del módulo de E/S permite conectarse a un dispositivo serie.
Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
9 | IN 1
10 | IN 2
11 | IN 3
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | HSOUT 2
11 | HSOUT 3
12 | LED verde
13 | LED rojo
Closed In-Sight de las series 76xx - 79xx

Nota:

  • El sistema de visión In-Sight de las series 76xx - 79xx admite la conexión simultánea del cable de conexión y del módulo de E/S CIO-MICRO. Para conocer las configuraciones de E/S de hardware, consulte Configuraciones de E/S de hardware de In-Sight 7000 Gen2.
  • IN 1, IN 2 e IN 3 son entradas integradas, directamente del sistema de visión. Las entradas directas (integradas) en los sistemas de visión In-Sight de las series 7000 (70xx - 79xx) solo se admiten si el sistema de visión está conectado con el cable de conexión.
  • HS OUT 0, HS OUT 1, HS OUT 2 y HS OUT 3 son salidas de alta velocidad integradas, directamente desde el sistema de visión.
  • El sistema de visión admite el tipo de señal estroboscópica para la línea HSOUT 1.
  • Si conecta un dispositivo estroboscópico externo al cable de luz externa de un sistema In-Sight de las series 76xx - 79xx o si conecta un accesorio de iluminación a la placa frontal del sistema de visión, use el cuadro de diálogo Ajustes de luz para configurar los parámetros de la luz externa.

E/S directa

Nota: El sistema de visión In-Sight admite salidas de alta velocidad bidireccionales y entradas de uso general para IN 2 / HS OUT 2 y IN 3 / HS OUT 3. Estas líneas se configuran como salidas de forma predeterminada.
Entrada | Dirección | Nombre
1 | Entrada fija | IN 1
2 | Entrada | IN 2
3 | Entrada | IN 3
Salida | Dirección | Nombre
0 | Salida fija | HSOUT 0
1 | Salida fija | HSOUT 1
2 | Salida | HSOUT 2
3 | Salida | HSOUT 3
4 | Salida fija | LED Aceptaciones/Rechazos
5 | Salida fija | LED Error

CIO-1400

Nota:

  • Estando conectado al módulo de E/S CIO-1400, no se admiten las líneas IN 1, IN 2, IN 3, HS OUT 2 y HS OUT 3 del sistema de visión.
  • El módulo de E/S CIO-1400 admite el sistema de visión In-Sight de las series 76xx - 79xx con In-Sight Explorer 5.4.0 y versiones superiores. Si se conecta al sistema de visión con una versión anterior de In-Sight Explorer, conéctese al módulo de E/S CIO-1400 y configure las líneas de E/S. No se conservarán las modificaciones.
Entrada | Nombre
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | LED Aceptaciones/Rechazos
9 | LED Error

CIO-MICRO

Nota:

  • Cuando el sistema de visión In-Sight de las series 76xx - 79xx está conectado al cable de conexión y se ha establecido una conexión de Ethernet con un módulo de E/S CIO-MICRO:
    • El sistema de visión In-Sight admite salidas de alta velocidad bidireccionales y entradas de uso general para IN 2 / HS OUT 2 y IN 3 / HS OUT 3. Estas líneas se configuran como salidas de forma predeterminada.
    • No se admiten los terminales TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 y HS COMMON módulo de E/S CIO-MICRO. No conecte los cables de alimentación de los dispositivos remotos a estos terminales.
    • Se desactivan los contactos RS-232 TRANSMIT y RS-232 RECEIVE del cable de conexión. El puerto RS-232 OUT (tipo DB9) del módulo de E/S permite conectarse a un dispositivo serie.
  • Cuando el sistema de visión In-Sight de las series 76xx - 79xx está conectado con el módulo de E/S CIO-MICRO a través del cable del módulo E/S:
    • Las líneas IN 1, IN 2, IN 3, HS OUT 2 y HS OUT 3 del sistema de visión se muestran en el cuadro de diálogo Opciones de E/S discreta, pero no se admiten; solo se admiten si el sistema de visión está conectado al cable de conexión.
    • TRIGGER+, TRIGGER-, HS OUT 0, HS OUT 1 y HS COMMON están conectados a través de los terminales del módulo de E/S CIO-MICRO.
    • No se admiten accesorios de iluminación conectados a la placa frontal del sistema de visión ni al conector LIGHT. Si se conectan estos accesorios, debe usarse el cable de conexión para alimentar con corriente al sistema de visión y establecerse una conexión con el módulo de E/S solo a través de Ethernet.
Entrada | Dirección | Nombre
0 | Entrada fija | Línea 0
1 | Entrada fija | Línea 1
2 | Entrada fija | Línea 2
3 | Entrada fija | Línea 3
4 | Entrada fija | Línea 4
5 | Entrada fija | Línea 5
6 | Entrada fija | Línea 6
7 | Entrada fija | Línea 7
9 | Entrada fija | IN 1
10 | Entrada | IN 2
11 | Entrada | IN 3
Salida | Dirección | Nombre
0 | Salida fija | Línea 0
1 | Salida fija | Línea 1
2 | Salida fija | Línea 2
3 | Salida fija | Línea 3
4 | Salida fija | Línea 4
5 | Salida fija | Línea 5
6 | Salida fija | Línea 6
7 | Salida fija | Línea 7
8 | Salida fija | HSOUT 0
9 | Salida fija | HSOUT 1
10 | Salida | HSOUT 2
11 | Salida | HSOUT 3
12 | Salida fija | LED Aceptaciones/Rechazos
13 | Salida fija | LED Error
Closed In-Sight de la serie 8000

Nota:

  • HS OUT 0 y HS OUT 1 son salidas de alta velocidad integradas, directamente desde el sistema de visión.
  • El sistema de visión admite el tipo de señal estroboscópica para la línea HSOUT 1.
  • Si se usa una luz estroboscópica con el sistema In-Sight 8405, se recomienda que la exposición mínima sea de 72 ms para una captura de imágenes de fotograma completo a fin de garantizar que se expongan todas las filas de píxeles cuando la luz estroboscópica es pulsatoria. Consulte Operación de efecto persiana para obtener más información.

E/S directa

Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
4 | LED verde
5 | LED rojo

CIO-MICRO

Entrada | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
Salida | Nombre
0 | Línea 0
1 | Línea 1
2 | Línea 2
3 | Línea 3
4 | Línea 4
5 | Línea 5
6 | Línea 6
7 | Línea 7
8 | HSOUT 0
9 | HSOUT 1
10 | LED verde
11 | LED rojo
Closed Sistema de visión de exploración por líneas In-Sight 9902L

Nota:

  • IN 1 es una entrada integrada, directamente desde el sistema de visión.
  • HS OUT 0 y HS OUT 1 son salidas de alta velocidad integradas, directamente desde el sistema de visión.
  • El sistema de visión admite el tipo de señal estroboscópica para la línea HSOUT 1.
  • Si se usa una luz estroboscópica con el sistema de visión de exploración por líneas In-Sight 9902L:
    • La luz estroboscópica debe utilizar una configuración de cableado PNP y el Disparador de control luz/estrobo debe ponerse en Margen de aumento.
    • Cuando el sistema de visión recibe un disparador de adquisición, la línea de salida envía un pulso y la luz estroboscópica parpadea durante el tiempo de exposición. Una vez completada la exposición, debe haber un mínimo de 100 µs antes de que se reciba el siguiente disparador de adquisición o la luz estroboscópica podría no funcionar bien.

E/S directa

Entrada | Nombre
1 | IN 1
Salida | Nombre
0 | HSOUT 0
1 | HSOUT 1
4 | LED Aceptaciones/Rechazos
5 | LED Error


Controles del cuadro de diálogo Detalles de salida

  • Pulso: Cuando esta casilla de verificación se encuentra activada, la salida será pulsatoria. Desactive esta casilla de verificación para obtener una salida de estado estacionario. La salida debe ser pulsatoria cuando la demora de adquisición sea superior a 0.

  • Longitud de pulso (ms): Duración de un pulso de salida.

    Sistema de visión/Sensor de visión | Longitud mínima de pulso | Longitud máxima de pulso | Longitud predeterminada de pulso
    SALIDA DE USO GENERAL | Salida de alta velocidad
    In-Sight de la serie 1000 (excepto 1402, 1412 y 1500) | 10 ms | 10 ms | 1000 ms | 10 ms
    In-Sight Micro 1402, 1412 y 1500 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight de la serie 2000 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight de la serie 5000 | 10 ms | 10 ms | 1000 ms | 10 ms
    In-Sight de las series 70xx - 74xx | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight de las series 76xx - 79xx | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight de la serie 8000 | 10 ms | 1 ms | 1000 ms | 10 ms
    In-Sight 9902L | N/A | 1 ms | 1000 ms | 10 ms

    Nota:

    • Cuando se utiliza el módulo de E/S CIO-MICRO o CIO-MICRO-CC con sistemas de visión compatibles, la duración mínima de pulso de las salidas de uso general está limitada por el ajuste "Tiempo de actualización" del cuadro de diálogo Configuración del módulo de E/S. Por ejemplo, si el ajuste "Tiempo de actualización" es de 20 ms, la longitud mínima del pulso no puede ser inferior a 30 ms. Para más información, consulte el cuadro de diálogo Configuración del módulo de E/S.
    • En el caso de los sistemas de visión de las series 76xx - 79xx y 8000 de In-Sight, la longitud mínima de pulso de 1 ms solo es compatible con la versión de firmware 5.5.0 o superior de In-Sight. Si utiliza una versión anterior del firmware, la longitud mínima de pulso será 10 ms.

  • Demora de adquisición (N): Especifica la cantidad de pulsos de adquisición o de seguimiento (0 a 1000) para demorar la salida después de que una línea de salida reciba un pulso de señal. Si la demora de adquisición = 0, el sistema de visión In-Sight actualiza la línea de salida inmediatamente al evaluar la tarea EasyBuilder. Si el retardo de adquisición es mayor que 0, la línea de salida siempre es pulsatoria.

    Nota: Retardo de adquisición y Tiempo después del disparador no se pueden utilizar simultáneamente, sino individualmente. Es decir, si se activa Retardo de adquisición, se desactivará Tiempo después del disparador, y viceversa.

  • Tiempo después del disparador (ms): Cuando esta casilla está activada, la salida se disparará al transcurrir el tiempo especificado (0 a 10000 ms).

    Nota: Retardo de adquisición y Tiempo después del disparador no se pueden utilizar simultáneamente, sino individualmente. Es decir, si se activa Retardo de adquisición, se desactivará Tiempo después del disparador, y viceversa.

  • Disparador de estrobo/control de luz: El margen de aumento o de caída de la señal se puede utilizar para accionar una luz estroboscópica o un control de luz.
    • Configuración NPN: Si se ha establecido Flanco ascendente, la señal es ALTA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es BAJA. Si se ha establecido Flanco descendente, la señal es BAJA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es ALTA. Siempre es pulsatoria durante la exposición. El tiempo de exposición debe ser 0,50 ms mayor que la duración de la luz estroboscópica pulsatoria especificada en el dispositivo estroboscópico externo.

    • Configuración PNP: Si se ha establecido Flanco ascendente, la señal es BAJA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es ALTA. Si se ha establecido Flanco descendente, la señal es ALTA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es BAJA. Siempre es pulsatoria durante la exposición. El tiempo de exposición debe ser 0,50 ms mayor que la duración de la luz estroboscópica pulsatoria especificada en el dispositivo estroboscópico externo.

      Nota:

      • En los sistemas de visión In-Sight de las series 5600, 5705, 5705C, 5715 y 9902L, se invierte el comportamiento estroboscópico (es decir, en configuraciones de cableado NPN, los márgenes de aumento y caída se comportan como en una configuración PNP).
      • Si se usa una luz estroboscópica con el sistema de visión de exploración por líneas In-Sight 9902L:
        • La luz estroboscópica debe utilizar una configuración de cableado PNP y el Disparador de control luz/estrobo debe ponerse en Margen de aumento.
        • Cuando el sistema de visión recibe un disparador de adquisición, la línea de salida envía un pulso y la luz estroboscópica parpadea durante el tiempo de exposición. Una vez completada la exposición, debe haber un mínimo de 100 µs antes de que se reciba el siguiente disparador de adquisición o la luz estroboscópica podría no funcionar bien.
  • Posición inicial de la luz estroboscópica: Especifica si la luz estroboscópica debe ser pulsatoria. Esta opción no la admite el sistema de visión In-Sight 9902L.
    • Comienzo de adquisición: Especifica que la luz estroboscópica pulsará cuando el sistema de visión In-Sight empiece con la adquisición. Compatible con todos los modelos de sistemas de visión excepto en el sistema de visión In-Sight 8405.
    • Disparador de cámara: Especifica que la luz estroboscópica pulsará al recibir un evento del disparador de cámara. Compatible con todos los modelos de sistemas de visión excepto en el sistema de visión In-Sight 8405.

    • Todas las filas expuestas: Especifica que la luz estroboscópica solo pulsará cuando se expongan todas las filas de píxeles. Únicamente compatible con el sistema de visión In-Sight 8405.

      Nota: Si se usa una luz estroboscópica con el sistema In-Sight 8405, se recomienda que la exposición mínima sea de 72 ms para una captura de imágenes de fotograma completo a fin de garantizar que se expongan todas las filas de píxeles cuando la luz estroboscópica es pulsatoria. Consulte Operación de efecto persiana para obtener más información.

  • LED tricolor: Configura el comportamiento de las líneas de LED tricolor. (Desactivado/Verde, Desactivado/Rojo, Rojo/Verde; predeterminado = Desactivado/Verde) Esta opción solo está disponible si la línea admite los LED tricolor.

    Nota: Esta opción es compatible con los sistemas de visión de las series 76xx - 79xx de In-Sight para el LED de aceptaciones/rechazos, pero no está disponible si el tipo de señal seleccionado es Aceptaciones/Rechazos.


Entradas: Carga de un archivo de tarea

Sensores de visión In-Sight de la serie 2000

Para usar esta funcionalidad, al menos se debe haber guardado una tarea y con un prefijo numérico de 0 a 31, en el formato de Nºnombrearchivotarea.job (por ejemplo, 2InspeccionPin.job).

  1. Seleccione la línea de entrada 0 y establezca Tipo de señal en Cambio de tarea (mediante pulso).

  2. Para cargar 2InspeccionPin.job en el sensor, un dispositivo externo (como un PLC) emite una serie de pulsos para el sensor In-Sight 2000.

    Tipo de pulso | Longitud de pulso
    Pulso inicial | 20 ms (± 2 ms)
    Pulso de recuento | 10 ms (± 1 ms)
    Espacio entre pulsos | 10 ms (± 1 ms)
    Pulso de parada | 20 ms (± 2 ms)
    1. El dispositivo externo emite un pulso inicial seguido de un espacio entre pulsos.
    2. El dispositivo externo emite después tres pulsos de recuento. Hay un espacio entre cada pulso de recuento y un espacio después del último pulso de recuento. El número de pulsos de recuento emitidos debe corresponder con el prefijo numérico de la tarea que se va a cargar (p. ej., hacen falta dos pulsos de recuento para cargar 2PinInspection.job).
    3. El dispositivo externo emite un pulso de parada. Si todos los pulsos y los espacios entre pulsos coinciden con la longitud de pulso especificada, la solicitud de cambio de tarea se considera correcta y 2InspeccionPin.job se carga en el sensor. Si falla alguna de las condiciones (es decir, un pulso incorrecto o una duración del espacio entre pulsos incorrecta), la solicitud de cambio de tarea se rechaza y no se produce ningún cambio de tarea.

    Notas:

    • El comando del modo nativo SetSystemConfig("PulseJobChangeTiming") puede utilizarse para configurar las anchuras de pulso del pulso inicial, el pulso de recuento, el espacio entre pulsos y el pulso de parada.
    • También puede configurar una línea de salida discreta como un tipo Carga de tarea satisfactoria o La carga de tarea ha fallado para pulsar la salida e informar del éxito o fallo de la solicitud de cambio de tarea. Si no se utilizan las longitudes de pulso de entrada especificadas, la salida no se pulsará para indicar un fallo de carga de la tarea.

Sistemas de visión In-Sight

Para utilizar esta funcionalidad, debe tener al menos una tarea guardada y las tareas que se vayan a cargar deben haberse guardado con un prefijo numérico del 0 al 127, p. ej., 1InspeccionPin.job.

  1. Seleccione una línea de entrada para configurarla y establezca Tipo de señal en Conmutador de carga de tarea. El archivo de tarea que se carga se indica mediante el estado (0 o 1) de cualquiera de las otras líneas de entrada establecidas en Número de identificación de tarea.
  2. Establezca el Tipo de señal de al menos otra línea de entrada en Número de identificación de tarea.
  3. Una entrada establecida en Número de identificación de tarea representa un bit de un número binario. Las entradas de línea subsiguientes establecidas en Número de identificación de tarea representan bits adicionales del número binario. El número binario completo representa el prefijo numérico (# decimal) de un archivo de tarea guardado con el siguiente formato: Nºnombrearchivotarea.job.

Ejemplo 1

Tres entradas discretas se establecen en Número de identificación de tarea y representan un número binario de 3 bits. Si los estados de las tres entradas son 0,1 y 0 respectivamente, el número binario 010 indica que se va a cargar un archivo de tarea con el prefijo 2 (010 en formato decimal).

Ejemplo 2

Tiene tres archivos de tarea distintos llamados 3inspeccion.job, 6inspeccion.job y 9inspeccion.job. Quiere especificar que debe cargarse el archivo .job llamado 6inspeccion.job cuando el sensor reciba una señal ALTA de un PLC. La entrada discreta 1 se utiliza actualmente como disparador de adquisición de imagen.

  1. Conecte la línea de entrada 1 al PLC.
  2. Establezca el Tipo de señal de la línea de entrada 1 en Conmutador de carga de tarea.
  3. Puesto que el rango de prefijos de nombre de archivo de tarea va de 3 a 9, tendrá que establecer 4 entradas en Número de identificación de tarea. (9 es 1001 en formato binario.)

  4. Si los estados de las líneas de número de identificación de tarea son 1, 1, 0 y 0 respectivamente (6 es 1100 en formato binario) y el estado de la línea de entrada 2 es ALTO (1), se cargará la tarea llamada 6inspeccion.job.

    Nota: Si el sensor In-Sight tiene más de una tarea almacenada con el mismo prefijo numérico, se cargará el archivo con el orden alfanumérico más alto.


Entradas: Activación y desactivación de herramientas de ubicación e inspección

Las herramientas de ubicación e inspección pueden tener su ejecución vinculada a una línea de entrada. Si se vincula la herramienta a una entrada, un sistema de control, como un PLC, puede determinar las herramientas que deben ejecutarse.

  1. Seleccione una línea de entrada y establezca Tipo de señal en Información de usuario.
  2. Vaya a la herramienta de ubicación o de inspección que quiera controlar y acceda al control Herramienta habilitada de la herramienta. En la lista desplegable, seleccione el número de entrada que definió en el paso anterior.
  3. Ahora, el sistema de control puede activar o desactivar la herramienta (una señala ALTA (1) significa activada; una señal BAJA (0) significa desactivada).


Entradas: Disparo de adquisición de imagen

Para configurar el sistema de visión In-Sight para que pueda recibir un disparo de adquisición a través de una línea de entrada de un PLC, un ojo fotoeléctrico u otro dispositivo, siga estos pasos.

  1. Haga clic en el paso Configurar imagen.

  2. En el cuadro de grupo Editar ajustes de adquisición, seleccione Externo del menú desplegable Disparador.

    Notas:
    • El sensor de visión In-Sight de la serie 2000 no admite disparador externo.
    • Pueden alcanzarse mayores velocidades de disparo utilizando la entrada del disparador de adquisición integrada en el sistema de visión (ajustando el parámetro "Disparador" a Cámara) en lugar de activar el sistema de visión con una línea de entrada de uso general configurada como disparador de adquisición (ajustando el parámetro "Disparador" a Externo).
    • Si el parámetro "Disparador" está ajustado a Externo y se pierde alguna adquisición, el sistema de visión no enviará la salida ERR: Adquisición perdida. La señal ERR: Adquisición perdida solo puede realizarse con el parámetro "Disparador" ajustado a Cámara.
  3. Vuelva al paso Entradas/salidas.

  4. Seleccione una línea de entrada y establezca Tipo de señal en Disparador de adquisición.

    Nota: El módulo de E/S CIO-1400 no admite el disparador de adquisición.
  5. Establezca el Tipo de flanco de la señal en Flanco ascendente o Flanco descendente.
  6. Conecte los cables del dispositivo de entrada a la entrada del disparador en un cable de conexión del sistema de visión In-Sight o en un módulo de E/S. Para obtener más información, consulte el manual de instalación correspondiente al módulo de E/S o al sistema de visión In-Sight.


Entradas: Entrenamiento de un patrón Modelo sobre una línea de entrada

Para configurar su sistema de visión In-Sight con el objetivo de que entrene un patrón Modelo sobre una línea de entrada, complete los siguientes pasos.

  1. En la herramienta de Ubicación de patrón/patrones (1 - 10), la herramienta Presencia/ausencia de patrones o la herramienta Recuento de patrones, seleccione una línea de entrada para usar como señal de entrenamiento a partir de la lista desplegable Entrenar entrada.

    Nota: Al conectarse a un sistema de visión In-Sight o al sensor de visión In-Sight 2000-23M, la lista desplegable Entrenar entrada se incluirá en la ficha Ajustes.

  2. Vuelva al paso de aplicación Entradas/Salidas.
  3. Fije el tipo de señal de la línea de entrada seleccionada en Disparador de evento.
  4. Defina el tipo de margen de la señal como Margen ascendente, Margen descendente o Ambos márgenes.

  5. Ponga el sistema/sensor de visión In-Sight en línea.

    Nota: El entrenamiento de un patrón Modelo utilizará la imagen más reciente que haya adquirido el sensor o el sistema de visión. No es necesario volver a lanzar el sensor/sistema de visión para el entrenamiento.

  6. Los márgenes del tipo seleccionado iniciará la formación de un patrón Modelo.


Salidas: Señalización de una adquisición de imagen fallida

Para señalizar una adquisición de imagen fallida:

  1. Haga clic en el paso Configurar imagen.
  2. En el cuadro de grupo Editar ajustes de adquisición, seleccione Cámara del menú desplegable Disparador.
  3. Vuelva al paso Entradas/salidas.
  4. Seleccione una línea de salida y establezca Tipo de señal en Final de adquisición. Especifique la longitud de pulso pulsando el botón Detalles.
  5. Seleccione otra línea de salida y establezca Tipo de señal en ERROR: Adquisición fallida. Ello indica que se ha recibido un disparador de adquisición antes de enviar una señal Final de adquisición o que no había disponible ningún búfer de imagen para la adquisición de imágenes cuando se recibió el disparador de adquisición.
  6. Especifique la longitud de pulso pulsando el botón Detalles.


Salidas: Disparo de una luz para la adquisición de imágenes

Closed Disparo de una luz estroboscópica

El margen de aumento o de caída de la señal se puede utilizar para accionar una luz estroboscópica.

Para enviar una señal que dispare una luz estroboscópica:

  1. Defina los ajustes del disparador de adquisición en el paso Configurar imagen. Asegúrese de que el tiempo de exposición sea 0,50 ms mayor que la duración de la luz estroboscópica pulsatoria especificada en el dispositivo de iluminación externo.
  2. Ajuste el tipo de señal de la línea de salida en Estrobo.
  3. Pulse el botón Detalles y especifique si es el Flanco ascendente o el Flanco descendente de la señal el que debe disparar la luz estroboscópica.
    • Configuración NPN: Si se ha establecido Flanco ascendente, la señal es ALTA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es BAJA. Si se ha establecido Flanco descendente, la señal es BAJA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es ALTA. Siempre es pulsatoria durante la exposición. El tiempo de exposición debe ser 0,50 ms mayor que la duración de la luz estroboscópica pulsatoria especificada en el dispositivo estroboscópico externo.

    • Configuración PNP: Si se ha establecido Flanco ascendente, la señal es BAJA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es ALTA. Si se ha establecido Flanco descendente, la señal es ALTA cuando está siendo expuesto el sensor de imágenes; de lo contrario, la señal es BAJA. Siempre es pulsatoria durante la exposición. El tiempo de exposición debe ser 0,50 ms mayor que la duración de la luz estroboscópica pulsatoria especificada en el dispositivo estroboscópico externo.

      Nota:

      • En los sistemas de visión In-Sight de las series 5600, 5705, 5705C, 5715 y 9902L, se invierte el comportamiento estroboscópico (es decir, en configuraciones de cableado NPN, los márgenes de aumento y caída se comportan como en una configuración PNP).
      • Si se usa una luz estroboscópica con el sistema de visión de exploración por líneas In-Sight 9902L:
        • La luz estroboscópica debe utilizar una configuración de cableado PNP y el Disparador de control luz/estrobo debe ponerse en Margen de aumento.
        • Cuando el sistema de visión recibe un disparador de adquisición, la línea de salida envía un pulso y la luz estroboscópica parpadea durante el tiempo de exposición. Una vez completada la exposición, debe haber un mínimo de 100 µs antes de que se reciba el siguiente disparador de adquisición o la luz estroboscópica podría no funcionar bien.
  4. Especifique la posición inicial de la luz estroboscópica. Esta opción no la admite el sistema de visión In-Sight 9902L.
    • Comienzo de adquisición: Especifica que la luz estroboscópica pulsará cuando el sistema de visión In-Sight empiece con la adquisición. Compatible con todos los modelos de sistemas de visión excepto en el sistema de visión In-Sight 8405.
    • Disparador de cámara: Especifica que la luz estroboscópica pulsará al recibir un evento del disparador de cámara. Compatible con todos los modelos de sistemas de visión excepto en el sistema de visión In-Sight 8405.
    • Todas las filas expuestas: Especifica que la luz estroboscópica solo pulsará cuando se expongan todas las filas de píxeles. Únicamente compatible con el sistema de visión In-Sight 8405.

Nota:

  • El sistema de visión In-Sight y el dispositivo de iluminación deben estar conectados a la misma tierra para que el dispositivo de iluminación funcione correctamente.
  • Los sistemas de visión In-Sight Micro de la serie 1000, In-Sight de la serie 2000, In-Sight de la serie 5000 (salvo el 5604), In-Sight de las series 76xx - 79xx, In-Sight de la serie 8000 y In-Sight 9902L admiten el tipo de señal estroboscópica para la línea HSOUT 1.
  • El sistema de visión In-Sight de las series 70xx - 74xx admite el tipo de señal estroboscópica para la línea HSOUT 0.
  • En el sistema de visión In-Sight 8405, la posición inicial de la luz estroboscópica está fijada en Todas las filas expuestas y la señal de salida es pulsatoria únicamente durante el tiempo en el que se exponen todas las filas de píxeles. Si se usa una luz estroboscópica con el sistema In-Sight 8405, se recomienda que la exposición mínima sea de 72 ms para una captura de imágenes de fotograma completo a fin de garantizar que se expongan todas las filas de píxeles cuando la luz estroboscópica es pulsatoria. Consulte Operación de efecto persiana para obtener más información.
Closed Disparo de una luz externa (solo CIO-1460)

El margen de aumento o de caída de la señal se puede utilizar para accionar o disparar una luz externa.

Para enviar una señal con el fin de disparar una luz externa:

  1. Inicie sesión en el sistema de visión In-Sight de la serie 5000 y conéctese a un módulo de E/S CIO-1460.
  2. Defina los ajustes del disparador de adquisición en el paso Configurar imagen. Asegúrese de que el tiempo de exposición sea 0,50 ms mayor que la duración de la luz estroboscópica pulsatoria especificada en el dispositivo de iluminación externo.
  3. Ajuste el tipo de señal de HSOUT 1 a Control de luz.
  4. Pulse el botón Detalles y especifique si es el Flanco ascendente o el Flanco descendente de la señal el que debe disparar la luz estroboscópica.

Notas:

  • El sistema de visión In-Sight y el dispositivo de iluminación deben estar conectados a la misma tierra para que el dispositivo de iluminación funcione correctamente.
  • Este tipo de salida solo es válido para la salida de alta velocidad, Línea 1 (HSOUT 1) si se configura el módulo de E/ CIO-1460 para el sistema de visión In-Sight de la serie 5000.


Salidas: Ajuste de una línea según el resultado de una herramienta de ubicación o de inspección

Para enviar una señal basada en el resultado de una herramienta de ubicación o inspección:

  1. Seleccione una línea de salida y establezca Tipo de señal en Resultado de la tarea.
  2. En la lista desplegable Resultado de la tarea, seleccione un resultado de la herramienta para emitirlo. Los resultados de la herramienta enumerados (p. ej., Texto_1, Patrón_1, etc.) representan una aceptación/rechazo para la herramienta individual. Los resultados de la tarea son una aceptación/rechazo acumulativa para todas las herramientas. La señal será ALTA (1) si el resultado de la herramienta es una aceptación y BAJA (0) si es un rechazo.
  3. Pulse el botón Detalles para especificar la longitud del pulso y el retardo de la adquisición. Si no se indican estos ajustes, la señal no se pulsará.


Comunicación

El paso Comunicación se utiliza para definir los resultados de inspección para el acceso e intercambio abierto de datos (OPC), para configurar una EasyView para el panel de interfaz del operador VisionView®, para exportar imágenes a través de FTP o a la tarjeta SD y para definir los ajustes de red y de comunicación serie de los sistemas de visión In-Sight, permitiéndoles comunicar datos hacia y desde otros dispositivos, como un robot, un autómata programable (PLC) o un controlador de movimiento (MC).

  • Compartir datos a través de OPC Server

    Nota: El sensor de visión In-Sight de la serie 2000 no admite OPC Server.

  • Configuración de EasyView
  • Exportar imágenes o datos a través de FTP
    • Imágenes
    • Datos

  • Exportar imágenes o datos a la tarjeta SD

    Nota: Esta característica solamente se admite en los sistemas de visión In-Sight en los que se ha instalado la tarjeta SD.

    • Imágenes
    • Datos
  • Agregar y editar dispositivos

Notas:

  • Para habilitar el paso Comunicación, el sensor In-Sight debe estar sin conexión.
  • Puede configurar y guardar los protocolos de comunicación de su tarea utilizando un emulador y luego cargarlos en un sistema de visión In-Sight para su implementación durante la ejecución. Sin embargo, los protocolos ProfiNET y CC-Link no se pueden simular en el emulador, a pesar de que se puedan seleccionar. Estos protocolos requieren que los protocolos de comunicación de tareas se desarrollen y se guarden en un sistema de visión In-Sight conectado a la red ProfiNET o CC-Link.

Protocolos compatibles

Se pueden añadir hasta dos protocolos a una tarea. Al añadir dos protocolos, puede agregar un protocolo "primario" y un protocolo "secundario". Por ejemplo, después de agregar el protocolo SLMP Scanner (primario), vuelva a hacer clic en el botón Agregar dispositivo y añada el protocolo TCP/IP (secundario).

Nota: No es posible añadir dos protocolos "primarios" ni dos protocolos "secundarios" a una tarea.

Firmware de In-Sight, versión 4.x.x

 | Primario o Secundario | Micro de la serie 1000 | Serie 5000 (excepto 5705 y 5705C) | Series 70xx - 74xx
CC-Link | Primario | X | X | X
Ethernet Native | Primario | X | X | X
Robot nativo Ethernet | Primario | X | X | X
Cadena nativa de Ethernet | Primario | X | X | X
EtherNet/IP | Primario | X | X | X
Servidor Modbus TCP | Primario | X | X | X
POWERLINK | Primario |  |  | X
PROFINET | Primario | X | X | X
Kuka serie | Primario | X | X | X
Motoman serie | Primario | X | X | X
Serie nativo | Primario | X | X | X
Robot nativo serie | Primario | X | X | X
Cadena nativa serie | Primario | X | X | X
Texto serie | Primario | X | X | X
SLMP | Primario | X | X | X
SLMP Scanner | Primario | X | X | X
TCP/IP | Secundario | X | X | X
UDP | Secundario | X | X | X

Firmware de In-Sight, versión 5.x.x

 | Primario o Secundario | Serie 2000 | 5705 y 5705C | Series 76xx - 79xx | Serie 8000
Ethernet Native | Primario |  | X | X | X
Ethernet Native Robot | Primario |  | X | X | X
Ethernet Native String | Primario |  | X | X | X
EtherNet/IP | Primario | X | X | X | X
Servidor Modbus TCP | Primario | X | X | X | X
PROFINET | Primario | X | X | X | X
Serial Kuka | Primario |  | X | X | X
Serial Motoman | Primario |  | X | X | X
Serial Native | Primario | X (básico) | X | X | X
Serial Native Robot | Primario |  | X | X | X
Serial Native String | Primario |  | X | X | X
Serial Text | Primario | X | X | X | X
SLMP | Primario | X | X | X | X
SLMP Scanner | Primario | X | X | X | X
TCP/IP | Secundario | X | X | X | X
UDP | Secundario | X | X | X | X


Compartir datos a través de OPC Server

Si su aplicación consta de otros dispositivos que utilizan un OPC Server para comunicarse, puede habilitar los resultados de inspección (o los datos de entrada) para que se expongan en un OPC Server.

Notas:
  • El sensor de visión In-Sight de la serie 2000 no admite OPC Server.
  • Para habilitar esta funcionalidad, debe estar instalado el software In-Sight OPC Server. Consulte el archivo de ayuda de In-Sight OPC Server para obtener más información.

Para habilitar los datos para el intercambio en un OPC Server:

  1. En el cuadro de grupo Comunicaciones, seleccione OPC.
  2. En la sección Etiquetas OPC seleccionadas, pulse el botón Añadir para abrir el cuadro de diálogo Seleccionar etiquetas OPC.
  3. El cuadro de diálogo Seleccionar etiquetas OPC contiene los datos de cualquier herramienta de ubicación o de inspección que se haya añadido a la tarea y los resultados generales de tareas. En el cuadro de diálogo, seleccione los datos adecuados que desee habilitar.
  4. Una vez seleccionados los datos que desee, haga clic en el botón Aceptar para aceptar los cambios. Las etiquetas OPC se muestran ahora en la sección Etiquetas OPC seleccionadas.


Configuración de EasyView

Si utiliza la aplicación HMI, puede crear una EasyView para personalizar el modo en que se muestran los datos y determinar si el operador puede editarlos. Para empezar, cree la EasyView en EasyBuilder y guárdela con la tarea del sensor. Después, obtenga una vista previa de la EasyView mediante la aplicación VisionView PC Demo o la aplicación de HMI web para asegurarse de que esté configurada correctamente.

Para configurar una EasyView:

  1. En el cuadro de grupo Comunicaciones, seleccione EasyView.
  2. En la sección Elementos de EasyView seleccionados, presione el botón Añadir para abrir el cuadro de diálogo Seleccionar elementos de EasyView.
  3. El cuadro de diálogo Seleccionar elementos de EasyView contiene los datos de cualquier herramienta de ubicación o de inspección que se haya añadido a la tarea, así como ajustes de adquisición y de tarea. En el cuadro de diálogo, seleccione los datos de herramientas adecuados que desee incluir en la EasyView, ya sea resaltando los elementos pertinentes y presionando después el botón Añadir o marcando la casilla de verificación EasyView del elemento.
Notas:
  • Para seleccionar varios elementos no consecutivos, mantenga presionada la tecla CTRL y resalte los elementos.
  • Para seleccionar varios elementos consecutivos, mantenga pulsada la tecla MAYÚS, resalte el primer elemento y, a continuación, el último elemento de la lista.
  4. Una vez seleccionados los datos de herramientas que desee, haga clic en el botón Aceptar para aceptar los cambios. Los datos de herramientas se muestran ahora en la sección Elementos de EasyView seleccionados.
Notas:
  • Para seleccionar varios elementos no consecutivos, mantenga presionada la tecla CTRL y resalte los elementos.
  • Para seleccionar varios elementos consecutivos, mantenga pulsada la tecla MAYÚS, resalte el primer elemento y, a continuación, el último elemento de la lista.
  5. Después de haber añadido los datos de herramientas, tiene la opción de activar la casilla de verificación Editable para permitir que el operador modifique los datos de herramientas en VisionView.

Nota: Los datos de herramientas deben tener permisos de lectura y escritura para que sean editables en VisionView.

  6. Opcionalmente, pulse el botón Insertar etiqueta para crear una etiqueta de encabezado. Las etiquetas son una forma útil de agrupar datos de herramientas.
  7. El Título es el nombre que se muestra de la aplicación HMI. Puede modificar el Título predeterminado haciendo clic en el campo Título de los datos de herramientas o la etiqueta e introduciendo un nombre descriptivo. Pulse la tecla INTRO o haga clic fuera del campo Título para confirmar el cambio; pulse la tecla ESC para cancelar el cambio.
  8. Cambie el orden de visualización de los datos de herramientas y/o etiquetas seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
  9. Guarde el archivo de tarea.

Nota: Los ajustes de EasyView también se guardarán automáticamente en el sensor In-Sight al salir del paso Comunicación.

  10. Para obtener una vista previa de cómo se mostrará la EasyView, inicie la aplicación VisionView PC Demo la HMI web.

    Nota: Si VisionView PC Demo está instalada en su equipo, el directorio de instalación predeterminado es: C:/Program Files/Cognex/VisionView/PC Demo x.x.x. Si VisionView PC Demo no está instalada en su equipo, puede descargar la aplicación en el sitio web de asistencia de VisionView.

  11. Una vez iniciada la aplicación VisionView PC Demo o la HMI web, desconéctese del sensor en el paso Establecer conexión.

  12. Si utiliza la HMI web, puede ver una lista previa de la EasyView en el panel de EasyView.

    Si usa VisionView PC Demo, añada el sensor a la lista Sensores seleccionados, acceda al Modo de ejecución y haga clic en el botón Cambiar vista para obtener una vista previa de la EasyView.

Notas:
  • Para ver una vista previa de una EasyView, primero debe habilitar las opciones de EasyView en el cuadro de diálogo Selección de vistas de HMI.
  • La aplicación VisionView PC Demo tiene un tiempo de espera automático de cuarenta y cinco minutos. Para adquirir una versión con licencia que ofrece la funcionalidad completa y no agota el tiempo de espera, instale el software VisionView PC que está disponible en el sitio web de asistencia de VisionView.
  • La apariencia y el funcionamiento de la aplicación VisionView PC Demo son ligeramente distintos de los del panel de interfaz de operador de VisionView.
  • Para obtener una vista previa de la EasyView tras haber iniciado sesión en un emulador, antes debe añadir manualmente el emulador a la lista Sensores seleccionados en la aplicación VisionView.


Exportar imágenes a través de FTP

Puede configurar su sistema de visión In-Sight para exportar imágenes a un servidor FTP de la red. Esto permite almacenar las imágenes adquiridas (dependiendo de un estado de aceptación/rechazo de una herramienta o tarea) en otro dispositivo para su archivado. A continuación, estas imágenes se pueden revisar para diagnosticar los problemas que puedan haber surgido durante el proceso de producción.

Para configurar una conexión FTP:

  1. En el cuadro de grupo Comunicaciones, seleccione FTP.
  2. Seleccione la ficha Imagen.
  3. Pulse el botón Agregar para añadir una entrada y configurar los parámetros de exportación de imágenes.

Nota: Se puede agregar a una tarea más de una operación de exportación de imágenes.

  4. Seleccione la ficha Ajustes y configure los ajustes del servidor FTP.
  5. Ponga el sistema de visión In-Sight en línea. El sistema de visión debe estar en línea para poder ejecutarlo; en caso contrario, no se exportará ninguna imagen.
  6. Dispare el sistema de visión para adquirir imágenes. Por cada imagen adquirida se exporta un archivo de imagen (BMP o JPG, en función del parámetro Formato de archivo) y se almacena en el host especificado en el parámetro Nombre de host.

Notas:

  • Cuando se establezca Condición de transferencia en Nada (valor predeterminado), se exportará un archivo de imagen cada vez que se adquiera una nueva imagen. Cuando se establezca Condición de transferencia en Nada, se exportará un archivo de imagen cada vez que se produzca el evento especificado. Por ejemplo, si Condición de transferencia está fijada en Tarea.Rechazo, se exportará un archivo de imagen que se almacenará en el servidor FTP cada vez que se rechace la tarea.
  • Cuando se utiliza el emulador de In-Sight como un servidor FTP, los archivos se escriben de forma predeterminada en la carpeta del emulador ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x). Además de en este directorio, los archivos pueden escribirse en una ubicación definida por el usuario (Directorio FTP autorizado). Para obtener más información sobre el directorio FTP autorizado, consulte el tema Cuadro de diálogo Opciones (panel Emulación).

Ficha Imagen

Proporciona parámetros para definir la imagen exportada, su formato, así como cuándo y a dónde debe exportarse la imagen.

Closed Casilla de verificación activada

Define si la operación de exportación de imágenes está operativa o no (de forma predeterminada, está activada), y si se mostrará o no como elemento de EasyView (por ejemplo, WriteImageFTP_1.Herramienta_Habilitada), que se puede visualizar en el panel de la interfaz de operador de VisionView y es editable por el operador.

Nota: Para habilitar la opción, active la casilla Habilitar en la tabla. Este es el único parámetro que puede configurar en la tabla.

Closed Nombre

Define el nombre de su operación de exportación de imágenes, que puede utilizarse para configurar los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "WriteImageFTP_1" (cuando se agrega la primera herramienta de exportación de imágenes a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, “WriteImageFtp_2”, “WriteImageFtp_3”, etc.). Personalice la operación dándole un nombre relacionado, por ejemplo, con su condición de transferencia.

Closed Condición de transferencia

Define cuándo deben enviarse los datos al servidor FTP, por ejemplo, cuándo una determinada herramienta obtiene una aceptación o un rechazo, o cuándo se recibe una entrada. La selección predeterminada es Nada, que garantiza que se exportarán los datos cada vez se adquiera una imagen, siempre que la casilla de verificación Habilitado esté activada. Si la casilla de verificación Habilitado está desactivada, o si la herramienta referida está desactivada, la operación de exportación no se ejecutará.

Closed Dispositivo

Define el servidor FTP, configurado en la ficha Ajustes, que recibirá los datos exportados. El ajuste predeterminado es Dispositivo 1.

Closed Formato de archivo

Define el formato de archivo de la imagen exportada: BMP (formato de mapa de bits de Windows) o JPG (formato JPEG codificado estándar). El ajuste predeterminado es BMP.

Closed Tamaño de la imagen

Define la resolución de la imagen exportada: Completa, Media o Cuarta. La opción Completa está seleccionada de forma predeterminada.

Closed Incluir gráficos

Define si se debe crear un archivo SVG que contendrá datos gráficos superpuestos para herramientas de ubicación y de inspección compatibles. Para ver el archivo SVG y el archivo de imagen, abra el archivo SVG con un navegador web que admita el tipo de archivo SVG (como Internet Explorer 9.0 de Microsoft). El archivo SVG contiene un enlace interno hacia la imagen adquirida y asociada a dicho archivo. Al abrir el archivo SVG, el navegador sigue este enlace para abrir y mostrar la imagen adquirida junto con los gráficos superpuestos.

Notas:
  • Para habilitar la opción, active la casilla de verificación Incluir gráficos en el cuadro de grupo del lado derecho. La casilla de verificación Incluir gráficos de la tabla es de solo lectura.
  • Con esta opción activada, el archivo SVG utilizará el nombre especificado en el parámetro Nombre de archivo.
  • Cuando el parámetro Nombre de host de la ficha Ajustes se ha establecido en un emulador de In-Sight, los archivos svg se guardan en el directorio del emulador ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) y se muestran en el panel Archivos In-Sight.
  • Si se configura una herramienta de ubicación y/o de inspección para ocultar sus gráficos superpuestos modificando las opciones de herramientas en el cuadro de diálogo Opciones de visualización de resultados, no se emitirán los gráficos SVG. De forma predeterminada, todas las herramientas muestran sus gráficos superpuestos.
  • Debido a que la representación gráfica corre a cargo de una aplicación de otro fabricante, como por ejemplo un navegador web, los datos de superposición gráfica no coincidirán exactamente píxel por píxel.
  • El firmware de In-Sight no garantiza la transmisión de cada pareja de archivo SVG y de imagen. Si el sistema de visión In-Sight se sobrecarga, puede ocurrir que suprima la transmisión del archivo SVG, del archivo de imagen o de ambos para garantizar que no se pierdan inspecciones ni adquisiciones de imágenes.
Closed Vista previa del nombre de archivo

Previsualiza el nombre del archivo de imagen a exportar; el nombre predeterminado es Image999. El nombre de archivo se puede personalizar configurando los siguientes parámetros: Nombre de archivo predeterminado, Añadir enlace, Añadir sello de fecha y hora y Añadir contador.

Notas:
  • Defina al menos un parámetro para el archivo de imagen. Si el campo Nombre de archivo predeterminado está en blanco y las casillas de verificación Añadir enlace, Añadir sello de fecha y hora y Añadir contador están desactivadas, la operación de exportación de archivos fallará.
  • El orden de los parámetros no se puede cambiar.
  • Cuando el parámetro Añadir mostrador está habilitado, en la vista previa del nombre de archivo siempre aparece el valor máximo del contador.
Closed Nombre de archivo predeterminado

Define el nombre del archivo de imagen que se exporta; el nombre predeterminado es "Image". Se admiten nombres de archivo largos.

Closed Añadir enlace

Define si la herramienta seleccionada será vinculada y añadida al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada.

Notas:
  • La operación de exportación de archivos fallará si la herramienta seleccionada está vinculada a una cadena que contiene alguno de los siguientes caracteres no válidos: <, >, :, ", /, \, |, ? o *.
  • La casilla de verificación Añadir enlace aparecerá inaccesible cuando EasyBuilder no pueda encontrar ninguna herramienta vinculable.
  • Si se elimina de la tarea la herramienta vinculada, la casilla de verificación Añadir enlace se inhabilitará automáticamente.
  • Si activa la casilla de verificación Añadir enlace, no seleccione Indefinido en la lista desplegable, ya que se pueden producir resultados no definidos.
Closed Añadir sello de fecha y hora

Define si se añadirá un sello de fecha y hora al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada. Si se activa, en la lista desplegable se podrá seleccionar uno de los siguientes formatos de fecha y hora preconfigurados: MMDDAA, AAAAMMDD_HHMMSS, DDMMAA_HHMMSS, MM-DD-AAAA_HH.MM.SS, HHMMSS, AAMMDD_HHMMSS o AADDMM_HHMMSS.

Nota: Puede configurar los ajustes de fecha y hora del sistema de visión In-Sight en el cuadro de diálogo Ajustes de fecha/hora.

Closed Añadir contador

Define si se añadirá o no un contador al nombre del archivo de imagen para exportar (preajuste = activado). Si se activa, se puede especificar el valor máximo del contador (0 a 9999999; preajuste = 999). Los contadores se incrementan con cada archivo de imagen exportado. El contador se restablece automáticamente cuando se alcanza el Valor máximo; los archivos de imagen existentes se sobrescribirán con los nuevos archivos de igual nombre.

Closed Botón Agregar

Añade una nueva operación de exportación a la lista.

Closed Botón Quitar

Quita una operación de exportación de la lista. Solo se puede quitar una operación de exportación cada vez.

Closed Botón de puesta a cero de todos los contadores

Restablece a 000 el valor añadido en la lista al nombre de archivo de imagen con cada operación de exportación de una imagen.

Ficha Ajustes

La ficha Ajustes proporciona parámetros para definir dos dispositivos de destino. El dispositivo de destino puede ser un emulador de In-Sight o cualquier otro equipo que actúe como servidor FTP en la red.

Closed Nombre de host

Define el nombre de equipo (o la dirección IP) del servidor FTP del dispositivo de destino.

Notas:
  • Si se especifica un nombre de host no válido, la conexión puede tardar hasta 30 segundos en cancelarse por tiempo de espera.

  • Al introducir un nombre de equipo o de usuario, no añada espacios antes ni después. Si el nombre especificado como nombre de host o de usuario va precedido o seguido de un espacio, la operación de exportación de imágenes no podrá escribir la imagen en el servidor especificado.

  • Si dispone de otro PC con un servidor FTP ya instalado, puede seleccionarlo como ubicación de almacenamiento. Observe que el software In-Sight Explorer es considerado como servidor FTP. Si está utilizando un servidor FTP de otro fabricante, debe cerrar In-Sight Explorer. Si no hay ningún otro servidor FTP activo, In-Sight Explorer debe estar ejecutándose. Si utiliza un servidor FTP de otro fabricante, debe indicar la dirección IP del PC en el parámetro Nombre de equipo.
  • El número de puerto de la conexión del servidor FTP se puede cambiar adjuntando el nombre de equipo (o la dirección IP) con dos puntos (:) y el nuevo número de puerto. Por ejemplo, si el nombre de equipo actual era PRODUCTION1, para cambiar el número de puerto predeterminado (21) al puerto 34, debe cambiarse el parámetro Nombre de equipo a: PRODUCTION1:34.
Closed Nombre de usuario

Define el nombre de usuario válido para el servidor FTP del dispositivo de destino (no debe tener más de 255 caracteres). Este nombre no debe existir en el sistema de visión In-Sight que está exportando el archivo de imagen o los datos.

Closed Contraseña

Define la contraseña válida para el servidor FTP del dispositivo de destino. La contraseña distingue entre mayúsculas y minúsculas, y su longitud no puede ser superior a 20 caracteres.

Notas:
  • Por seguridad, la contraseña introducida se enmascara con "*" en el campo.
  • La contraseña se guardará en forma cifrada en el archivo de tareas.
Closed Tipo de conexión

Define el tipo de conexión para la exportación de imágenes: FTP estándar (selección predeterminada), FTP seguro o Mitsubishi GOT. FTP seguro es un protocolo de transmisión seguro para aplicaciones SFTP, mientras que Mitsubishi GOT permite visualizar imágenes en un terminal Mitsubishi GOT.

Nota: Si el parámetro Tipo de conexión está ajustado a Mitsubishi GOT, asegúrese de que el parámetro Formato de archivo, de la ficha Imágenes, esté ajustado a JPG para obtener los mejores resultados de visualización.

Closed Botón Ajustes FTP

Abre el cuadro de diálogo Ajustes FTP.

Nota: En redes dedicadas locales de In-Sight, en las que todas las conexiones FTP se producen entre sistemas de visión In-Sight, generalmente no es necesario modificar los ajustes predeterminados. Sin embargo, si se necesitan conexiones FTP entre sistemas de visión In-Sight y otros servidores de red, o entre sistemas de visión pertenecientes a redes distintas, tal vez tenga que modificar los ajustes predeterminados del FTP.

Closed Último error de red

Muestra la causa del error al detectar uno durante una operación de exportación de imágenes. Para que este campo se actualice, debe producirse un evento especificado en la ficha Archivo - Condición de transferencia, p. ej., al disparar una imagen, o debe ponerse en línea el sistema de visión In-Sight.


Exportar un archivo de datos o adjuntar una cadena de datos a un archivo a través de FTP

Puede configurar su sistema de visión In-Sight para que exporte un archivo de datos o adjunte una cadena de datos a un archivo FTP en la red. Use esta función para registrar resultados de datos que vea en un archivo.

Para configurar una conexión FTP:

  1. En el cuadro de grupo Comunicaciones, seleccione FTP.
  2. Seleccione la ficha Archivo.
  3. Pulse el botón Agregar para añadir una entrada y configurar los parámetros de exportación.

Nota: Puede agregar a una tarea más de una operación de exportación.

  4. Seleccione la ficha Ajustes y configure los ajustes del servidor FTP.
  5. Ponga el sistema de visión In-Sight en línea. El sistema de visión debe estar en línea para poder ejecutarlo; en caso contrario, no se exportarán datos.
  6. Dispare el sistema de visión. Por cada disparador, se exporta un archivo de datos o se adjunta una cadena de datos a un archivo y se almacena en el servidor FTP especificado en la ficha Ajustes.

Notas:

  • Cuando se establezca Condición de transferencia en Nada (valor predeterminado), se exportará un archivo de datos o se adjuntará una cadena de datos a un archivo cada vez que se adquiera una nueva imagen. Cuando se establezca Condición de transferencia en una opción que no sea Nada, se exportará un archivo de datos o se adjuntará una cadena de datos a un archivo cada vez que se produzca el evento especificado. Por ejemplo, si Condición de transferencia está fijada en Tarea.Rechazo, se exportará un archivo de datos o se adjuntará una cadena de datos a un archivo, que se almacenará en el servidor FTP cada vez que se rechace la tarea.
  • Cuando se utiliza el emulador de In-Sight como un servidor FTP, los archivos se escriben de forma predeterminada en la carpeta del emulador ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x). Además de en este directorio, los archivos pueden escribirse en una ubicación definida por el usuario (Directorio FTP autorizado). Para obtener más información sobre el directorio FTP autorizado, consulte el tema Cuadro de diálogo Opciones (panel Emulación).

Ficha Archivo

Proporciona parámetros para definir los datos exportados, su formato, así como cuándo y adónde deben exportarse los datos.

Closed Casilla de verificación activada

Define si la operación de exportación de datos está operativa o no (de forma predeterminada, está activada), y si se mostrará o no como elemento de EasyView (por ejemplo, WriteLocal_1.Herramienta_Habilitada), que se puede visualizar en el panel de la interfaz de operador de VisionView y es editable por el operador.

Nota: Para habilitar la opción, active la casilla Habilitar en la tabla. Este es el único parámetro que puede configurar en la tabla.

Closed Nombre

Define el nombre de su operación de exportación de datos, que puede utilizarse para configurar los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "WriteFTP_1" (cuando se agrega la primera herramienta de exportación de imágenes a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, “WriteFtp_2”, “WriteFtp_3”, etc.). Personalice la operación dándole un nombre relacionado, por ejemplo, con su condición de transferencia.

Closed Condición de transferencia

Define cuándo deben enviarse los datos al servidor FTP, por ejemplo, cuándo una determinada herramienta obtiene una aceptación o un rechazo, o cuándo se recibe una entrada. La selección predeterminada es Nada, que garantiza que se exportarán los datos cada vez se adquiera una imagen, siempre que la casilla de verificación Habilitado esté activada. Si la casilla de verificación Habilitado está desactivada, o si la herramienta referida está desactivada, la operación de exportación no se ejecutará.

Closed Dispositivo

Define el servidor FTP, configurado en la ficha Ajustes, que recibirá los datos exportados. El ajuste predeterminado es Dispositivo 1.

Closed Tipo de archivo

Define el formato del archivo exportado: texto, HTML (valor predeterminado), XML o CSV.

Closed Tipo de escritura (sobrescribir o adjuntar)

Determina la forma en que los datos se escriben en el archivo.

  • Sobrescribir: sobrescribe los datos existentes en el archivo.
  • Adjuntar (valor predeterminado): añade la cadena de datos al final del archivo.
Closed Botón Contenido de archivo/Cadena de formato

Determina los datos escritos en el archivo usando el cuadro de diálogo Cadena de formato.

Closed Vista previa del nombre de archivo

Previsualiza el nombre del archivo que se exporta; el nombre predeterminado es Image999. Puede personalizar el nombre de archivo configurando los siguientes parámetros: Nombre de archivo predeterminado, Añadir enlace y Añadir sello de fecha y hora.

Notas:
  • Defina al menos un parámetro para el archivo. Si el campo Nombre de archivo predeterminado está en blanco y las casillas de verificación Añadir enlace, Añadir sello de fecha y hora están desactivadas, fallará la operación de exportación de archivos.
  • El orden de los parámetros no se puede cambiar.
Closed Nombre de archivo predeterminado

Define el nombre del archivo que se exporta; el nombre predeterminado es "File". Se admiten nombres de archivo largos.

Closed Añadir enlace

Define si la herramienta seleccionada será vinculada y añadida al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada.

Notas:
  • La operación de exportación de archivos fallará si la herramienta seleccionada está vinculada a una cadena que contiene alguno de los siguientes caracteres no válidos: <, >, :, ", /, \, |, ? o *.
  • La casilla de verificación Añadir enlace aparecerá inaccesible cuando EasyBuilder no pueda encontrar ninguna herramienta vinculable.
  • Si se elimina de la tarea la herramienta vinculada, la casilla de verificación Añadir enlace se inhabilitará automáticamente.
  • Si activa la casilla de verificación Añadir enlace, no seleccione Indefinido en la lista desplegable, ya que se pueden producir resultados no definidos.
Closed Añadir sello de fecha y hora

Define si se añadirá un sello de fecha y hora al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada. Si se activa, en la lista desplegable se podrá seleccionar uno de los siguientes formatos de fecha y hora preconfigurados: MMDDAA, AAAAMMDD_HHMMSS, DDMMAA_HHMMSS, MM-DD-AAAA_HH.MM.SS, HHMMSS, AAMMDD_HHMMSS o AADDMM_HHMMSS.

Nota: Puede configurar los ajustes de fecha y hora del sistema de visión In-Sight en el cuadro de diálogo Ajustes de fecha/hora.

Closed Botón Agregar

Añade una nueva operación de exportación a la lista.

Closed Botón Quitar

Quita una operación de exportación de la lista. Solo se puede quitar una operación de exportación cada vez.

Ficha Ajustes

La ficha Ajustes proporciona parámetros para definir dos dispositivos de destino. El dispositivo de destino puede ser un emulador de In-Sight o cualquier otro equipo que actúe como servidor FTP en la red.

Closed Nombre de host

Define el nombre de equipo (o la dirección IP) del servidor FTP del dispositivo de destino.

Notas:
  • Si se especifica un nombre de host no válido, la conexión puede tardar hasta 30 segundos en cancelarse por tiempo de espera.

  • Al introducir un nombre de equipo o de usuario, no añada espacios antes ni después. Si el nombre especificado como nombre de host o de usuario va precedido o seguido de un espacio, la operación de exportación de imágenes no podrá escribir la imagen en el servidor especificado.

  • Si dispone de otro PC con un servidor FTP ya instalado, puede seleccionarlo como ubicación de almacenamiento. Observe que el software In-Sight Explorer es considerado como servidor FTP. Si está utilizando un servidor FTP de otro fabricante, debe cerrar In-Sight Explorer. Si no hay ningún otro servidor FTP activo, In-Sight Explorer debe estar ejecutándose. Si utiliza un servidor FTP de otro fabricante, debe indicar la dirección IP del PC en el parámetro Nombre de equipo.
  • El número de puerto de la conexión del servidor FTP se puede cambiar adjuntando el nombre de equipo (o la dirección IP) con dos puntos (:) y el nuevo número de puerto. Por ejemplo, si el nombre de equipo actual era PRODUCTION1, para cambiar el número de puerto predeterminado (21) al puerto 34, debe cambiarse el parámetro Nombre de equipo a: PRODUCTION1:34.
Closed Nombre de usuario

Define el nombre de usuario válido para el servidor FTP del dispositivo de destino (no debe tener más de 255 caracteres). Este nombre no debe existir en el sistema de visión In-Sight que está exportando el archivo de imagen o los datos.

Closed Contraseña

Define la contraseña válida para el servidor FTP del dispositivo de destino. La contraseña distingue entre mayúsculas y minúsculas, y su longitud no puede ser superior a 20 caracteres.

Notas:
  • Por seguridad, la contraseña introducida se enmascara con "*" en el campo.
  • La contraseña se guardará en forma cifrada en el archivo de tareas.
Closed Tipo de conexión

Define el tipo de conexión para la exportación de imágenes: FTP estándar (selección predeterminada), FTP seguro o Mitsubishi GOT. FTP seguro es un protocolo de transmisión seguro para aplicaciones SFTP, mientras que Mitsubishi GOT permite visualizar imágenes en un terminal Mitsubishi GOT.

Nota: Si el parámetro Tipo de conexión está ajustado a Mitsubishi GOT, asegúrese de que el parámetro Formato de archivo, de la ficha Imágenes, esté ajustado a JPG para obtener los mejores resultados de visualización.

Closed Botón Ajustes FTP

Abre el cuadro de diálogo Ajustes FTP.

Nota: En redes dedicadas locales de In-Sight, en las que todas las conexiones FTP se producen entre sistemas de visión In-Sight, generalmente no es necesario modificar los ajustes predeterminados. Sin embargo, si se necesitan conexiones FTP entre sistemas de visión In-Sight y otros servidores de red, o entre sistemas de visión pertenecientes a redes distintas, tal vez tenga que modificar los ajustes predeterminados del FTP.

Closed Último error de red

Muestra la causa del error al detectar uno durante una operación de exportación de imágenes. Para que este campo se actualice, debe producirse un evento especificado en la ficha Archivo - Condición de transferencia, p. ej., al disparar una imagen, o debe ponerse en línea el sistema de visión In-Sight.


Exportar imágenes a una tarjeta SD

Puede configurar su sistema de visión In-Sight para exportar imágenes a la tarjeta SD instalada en el sistema de visión In-Sight. Esto permite almacenar las imágenes adquiridas (dependiendo de un estado de aceptación/rechazo de una herramienta o tarea) para su archivado. A continuación, estas imágenes se pueden revisar para diagnosticar los problemas que puedan haber surgido durante el proceso de producción.

Nota: Esta característica solamente se admite en los sistemas de visión In-Sight en los que se ha instalado la tarjeta SD.

Para enviar imágenes a la tarjeta SD:

  1. En el cuadro de grupo Comunicaciones, seleccione Tarjeta SD.
  2. Seleccione la ficha Imagen.
  3. Pulse el botón Agregar para añadir una entrada y configurar los parámetros de exportación de imágenes.

Nota: Se puede agregar a una tarea más de una operación de exportación de imágenes.

  4. Ponga el sistema de visión In-Sight en línea. El sistema de visión debe estar en línea para poder ejecutarlo; en caso contrario, no se exportará ninguna imagen.

  5. Dispare el sistema de visión para adquirir imágenes. Por cada imagen adquirida se exporta un archivo de imagen (BMP o JPG, dependiendo del parámetro Formato de archivo) y se almacena en la tarjeta SD instalada en el sistema de visión.

    Nota: Cuando se establezca Condición de transferencia en Nada (= valor predeterminado), se exportará un archivo de imagen cada vez que se adquiera una nueva imagen. Cuando se establezca Condición de transferencia en Nada, se exportará un archivo de imagen cada vez que se produzca el evento especificado. Por ejemplo, si Condición de transferencia está fijada en Tarea.Rechazo, se exportará un archivo de imagen que se almacenará en la tarjeta SD cada vez que se rechace la tarea.

Controles

Closed Casilla de verificación activada

Define si la operación de exportación de imágenes está operativa o no (de forma predeterminada, está activada), y si se mostrará o no como elemento de EasyView (por ejemplo, WriteImageLocal_1.Herramienta_Habilitada), que se puede visualizar en el panel de la interfaz de operador de VisionView y es editable por el operador.

Nota: Para habilitar la opción, active la casilla Habilitar en la tabla. Este es el único parámetro que puede configurar en la tabla.

Closed Nombre

Define el nombre de su operación de exportación de imágenes, que puede utilizarse para configurar los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "WriteImageLocal_1" (cuando se agrega la primera herramienta de exportación de imágenes a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, “WriteImageLocal_2”, “WriteImageLocal_3”, etc.). Personalice la operación dándole un nombre relacionado, por ejemplo, con su condición de transferencia.

Closed Condición de transferencia

Define cuándo debe enviarse la imagen a la tarjeta SD, por ejemplo, cuando una determinada herramienta obtiene una aceptación o un rechazo, o cuando se recibe una entrada. La selección predeterminada es Nada, que garantiza que se exportará una imagen cada vez se adquiera una imagen, siempre que la casilla de verificación Habilitado esté activada. Si la casilla de verificación Habilitado está desactivada, o si la herramienta referida está desactivada, la operación de exportación de la imagen no se ejecutará.

Nota: Si la condición de transferencia de una determinada operación de exportación de imágenes se produce con una frecuencia elevada, por ejemplo con cada adquisición de una imagen, la cola de imágenes del sistema de visión In-Sight podría llenarse e impedir tanto la ejecución de otras operaciones de exportación de imágenes como la transferencia de algunas imágenes.

Closed Formato de archivo

Define el formato de archivo de la imagen exportada: BMP (formato de mapa de bits de Windows) o JPG (formato JPEG codificado estándar). El ajuste predeterminado es BMP.

Closed Tamaño de la imagen

Define la resolución de la imagen exportada: Completa, Media o Cuarta. La opción Completa está seleccionada de forma predeterminada.

Closed Incluir gráficos

Define si se debe crear un archivo SVG que contendrá datos gráficos superpuestos para herramientas de ubicación y de inspección compatibles. Para ver el archivo SVG y el archivo de imagen, abra el archivo SVG con un navegador web que admita el tipo de archivo SVG (como Internet Explorer 9.0 de Microsoft). El archivo SVG contiene un enlace interno hacia la imagen adquirida y asociada a dicho archivo. Al abrir el archivo SVG, el navegador sigue este enlace para abrir y mostrar la imagen adquirida junto con los gráficos superpuestos.

Notas:
  • Para habilitar la opción, active la casilla de verificación Incluir gráficos en el cuadro de grupo del lado derecho. La casilla de verificación Incluir gráficos de la tabla es de solo lectura.
  • Con esta opción activada, el archivo SVG utilizará el nombre especificado en el parámetro Nombre de archivo.
  • Cuando el parámetro Nombre de host de la ficha Ajustes se ha establecido en un emulador de In-Sight, los archivos svg se guardan en el directorio del emulador ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) y se muestran en el panel Archivos In-Sight.
  • Si se configura una herramienta de ubicación y/o de inspección para ocultar sus gráficos superpuestos modificando las opciones de herramientas en el cuadro de diálogo Opciones de visualización de resultados, no se emitirán los gráficos SVG. De forma predeterminada, todas las herramientas muestran sus gráficos superpuestos.
  • Debido a que la representación gráfica corre a cargo de una aplicación de otro fabricante, como por ejemplo un navegador web, los datos de superposición gráfica no coincidirán exactamente píxel por píxel.
  • El firmware de In-Sight no garantiza la transmisión de cada pareja de archivo SVG y de imagen. Si el sistema de visión In-Sight se sobrecarga, puede ocurrir que suprima la transmisión del archivo SVG, del archivo de imagen o de ambos para garantizar que no se pierdan inspecciones ni adquisiciones de imágenes.
Closed Vista previa del nombre de archivo

Previsualiza el nombre del archivo de imagen a exportar; el nombre predeterminado es Image999. El nombre de archivo se puede personalizar configurando los siguientes parámetros: Nombre de archivo predeterminado, Añadir enlace, Añadir sello de fecha y hora y Añadir contador.

Notas:
  • Defina al menos un parámetro para el archivo de imagen. Si el campo Nombre de archivo predeterminado está en blanco y las casillas de verificación Añadir enlace, Añadir sello de fecha y hora y Añadir contador están desactivadas, la operación de exportación de archivos fallará.
  • El orden de los parámetros no se puede cambiar.
  • Cuando el parámetro Añadir mostrador está habilitado, en la vista previa del nombre de archivo siempre aparece el valor máximo del contador.
Closed Nombre de archivo predeterminado

Define el nombre del archivo de imagen que se exporta; el nombre predeterminado es "Image". Se admiten nombres de archivo largos.

Closed Añadir enlace

Define si la herramienta seleccionada será vinculada y añadida al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada.

Notas:
  • La operación de exportación de archivos fallará si la herramienta seleccionada está vinculada a una cadena que contiene alguno de los siguientes caracteres no válidos: <, >, :, ", /, \, |, ? o *.
  • La casilla de verificación Añadir enlace aparecerá inaccesible cuando EasyBuilder no pueda encontrar ninguna herramienta vinculable.
  • Si se elimina de la tarea la herramienta vinculada, la casilla de verificación Añadir enlace se inhabilitará automáticamente.
  • Si activa la casilla de verificación Añadir enlace, no seleccione Indefinido en la lista desplegable, ya que se pueden producir resultados no definidos.
Closed Añadir sello de fecha y hora

Define si se añadirá un sello de fecha y hora al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada. Si se activa, en la lista desplegable se podrá seleccionar uno de los siguientes formatos de fecha y hora preconfigurados: MMDDAA, AAAAMMDD_HHMMSS, DDMMAA_HHMMSS, MM-DD-AAAA_HH.MM.SS, HHMMSS, AAMMDD_HHMMSS o AADDMM_HHMMSS.

Nota: Puede configurar los ajustes de fecha y hora del sistema de visión In-Sight en el cuadro de diálogo Ajustes de fecha/hora.

Closed Añadir contador

Define si se añadirá o no un contador al nombre del archivo de imagen para exportar (preajuste = activado). Si se activa, se puede especificar el valor máximo del contador (0 a 9999999; preajuste = 999). Los contadores se incrementan con cada archivo de imagen exportado. El contador se restablece automáticamente cuando se alcanza el Valor máximo; los archivos de imagen existentes se sobrescribirán con los nuevos archivos de igual nombre.

Closed Botón Agregar

Añade una nueva operación de exportación a la lista.

Closed Botón Quitar

Quita una operación de exportación de la lista. Solo se puede quitar una operación de exportación cada vez.

Closed Botón de puesta a cero de todos los contadores

Restablece a 000 el valor añadido en la lista al nombre de archivo de imagen con cada operación de exportación de una imagen.


Exportar un archivo de datos o adjuntar una cadena de datos a un archivo en una tarjeta SD

Puede configurar su sistema de visión In-Sight para que exporte un archivo de datos o adjunte una cadena de datos a un archivo en la tarjeta SD. Use esta función para registrar resultados de datos que vea en un archivo.

Nota: Esta característica solamente se admite en los sistemas de visión In-Sight en los que se ha instalado la tarjeta SD.

Para exportar datos o adjuntar una cadena de datos a un archivo en la tarjeta SD:

  1. En el cuadro de grupo Comunicaciones, seleccione Tarjeta SD.
  2. Seleccione la ficha Archivo.
  3. Pulse el botón Agregar para añadir una entrada y configurar los parámetros en la ficha Archivo.

Nota: Puede agregar a una tarea más de una operación de exportación.

  4. Ponga el sistema de visión In-Sight en línea. El sistema de visión debe estar en línea para poder ejecutarlo; en caso contrario, no se exportarán datos.

  5. Dispare el sistema de visión. Por cada disparador, se exporta un archivo de datos o se adjunta una cadena de datos a un archivo y se almacena en la tarjeta SD instalada en el sistema de visión.

    Nota: Cuando se establezca Condición de transferencia en Nada (valor predeterminado), se exportará un archivo de datos o se adjuntará una cadena de datos a un archivo cada vez que se adquiera una nueva imagen. Cuando se establezca Condición de transferencia en una opción que no sea Nada, se exportará un archivo de datos o se adjuntará una cadena de datos a un archivo cada vez que se produzca el evento especificado. Por ejemplo, si Condición de transferencia está fijada en Tarea.Rechazo, se exportará un archivo de datos o se adjuntará una cadena de datos a un archivo, que se almacenará en la tarjeta SD cada vez que se rechace la tarea.

Controles

Closed Casilla de verificación activada

Define si la operación de exportación de datos está operativa o no (de forma predeterminada, está activada), y si se mostrará o no como elemento de EasyView (por ejemplo, WriteLocal_1.Herramienta_Habilitada), que se puede visualizar en el panel de la interfaz de operador de VisionView y es editable por el operador.

Nota: Para habilitar la opción, active la casilla Habilitar en la tabla. Este es el único parámetro que puede configurar en la tabla.

Closed Nombre

Define el nombre de su operación de exportación de datos, que puede utilizarse para configurar los resultados Entradas/Salidas y Comunicación; el nombre predeterminado es "WriteLocal_1" (cuando se agrega la primera herramienta de exportación de imágenes a la tarea. La parte numérica del nombre se incrementará a partir de la segunda herramienta agregada, es decir, “WriteLocal_2”, “WriteLocal_3”, etc.). Personalice la operación dándole un nombre relacionado, por ejemplo, con su condición de transferencia.

Closed Condición de transferencia

Define cuándo deben enviarse los datos a la tarjeta SD, por ejemplo, cuando una determinada herramienta obtiene una aceptación o un rechazo, o cuando se recibe una entrada. La selección predeterminada es Nada, que garantiza que se exportarán los datos cada vez se adquiera una imagen, siempre que la casilla de verificación Habilitado esté activada. Si la casilla de verificación Habilitado está desactivada, o si la herramienta referida está desactivada, la operación de exportación no se ejecutará.

Closed Tipo de archivo

Define el formato del archivo exportado: texto, HTML (valor predeterminado), XML o CSV.

Closed Tipo de escritura (sobrescribir o adjuntar)

Determina la forma en que los datos se escriben en el archivo.

  • Sobrescribir: sobrescribe los datos existentes en el archivo.
  • Adjuntar (valor predeterminado): añade la cadena de datos al final del archivo.
Closed Botón Contenido de archivo/Cadena de formato

Determina los datos escritos en el archivo usando el cuadro de diálogo Cadena de formato.

Closed Vista previa del nombre de archivo

Previsualiza el nombre del archivo que se exporta; el nombre predeterminado es Image999. Puede personalizar el nombre de archivo configurando los siguientes parámetros: Nombre de archivo predeterminado, Añadir enlace y Añadir sello de fecha y hora.

Notas:
  • Defina al menos un parámetro para el archivo. Si el campo Nombre de archivo predeterminado está en blanco y las casillas de verificación Añadir enlace, Añadir sello de fecha y hora están desactivadas, fallará la operación de exportación de archivos.
  • El orden de los parámetros no se puede cambiar.
Closed Nombre de archivo predeterminado

Define el nombre del archivo que se exporta; el nombre predeterminado es "File". Se admiten nombres de archivo largos.

Closed Añadir enlace

Define si la herramienta seleccionada será vinculada y añadida al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada.

Notas:
  • La operación de exportación de archivos fallará si la herramienta seleccionada está vinculada a una cadena que contiene alguno de los siguientes caracteres no válidos: <, >, :, ", /, \, |, ? o *.
  • La casilla de verificación Añadir enlace aparecerá inaccesible cuando EasyBuilder no pueda encontrar ninguna herramienta vinculable.
  • Si se elimina de la tarea la herramienta vinculada, la casilla de verificación Añadir enlace se inhabilitará automáticamente.
  • Si activa la casilla de verificación Añadir enlace, no seleccione Indefinido en la lista desplegable, ya que se pueden producir resultados no definidos.
Closed Añadir sello de fecha y hora

Define si se añadirá un sello de fecha y hora al nombre del archivo de imagen para exportar. De forma predeterminada, esta casilla de verificación está desactivada. Si se activa, en la lista desplegable se podrá seleccionar uno de los siguientes formatos de fecha y hora preconfigurados: MMDDAA, AAAAMMDD_HHMMSS, DDMMAA_HHMMSS, MM-DD-AAAA_HH.MM.SS, HHMMSS, AAMMDD_HHMMSS o AADDMM_HHMMSS.

Nota: Puede configurar los ajustes de fecha y hora del sistema de visión In-Sight en el cuadro de diálogo Ajustes de fecha/hora.

Closed Botón Agregar

Añade una nueva operación de exportación a la lista.

Closed Botón Quitar

Quita una operación de exportación de la lista. Solo se puede quitar una operación de exportación cada vez.


Configuración de dispositivo

Para intercambiar datos con otros dispositivos, como robots o autómatas programables PLC/MC, primero deben definirse los ajustes de red y de comunicación serie del sensor In-Sight.

  • Comunicación con un PLC o controlador de movimiento
  • Comunicación con un robot
  • Comunicación con dispositivos Mitsubishi
  • Comunicación a través de Modbus TCP
  • Comunicación a través de TCP/IP
  • Comunicación a través de UDP
  • Comunicación a través de POWERLINK
  • Introducción de datos para las herramientas de identificación
  • Formateo de los datos de salida

Nota: Si en EasyBuilder la salida de una herramienta de ubicación o de inspección no es válida, el búfer de datos de salida contendrá el valor predeterminado para esa herramienta. Por ejemplo, si una herramienta de ubicación de patrones no encuentra un patrón coincidente, los datos X e Y de esa herramienta no serán válidos y adoptarán el valor predeterminado 0, que se pondrá en la salida. A la hora de configurar un dispositivo para enviar datos de salida, se recomienda que además de enviar los resultados de una herramienta, también se envíe el estado de aceptación/rechazo de ésta para asegurarse de que los datos de la herramienta son válidos. Para cambiar el valor predeterminado en el búfer de salida cuando el resultado de una herramienta no sea válido, envíe los siguientes comandos del modo nativo de In-Sight: Para datos, EV SetSystemConfig("FormatOutputBufferErrData",-1111), donde "-1111" representa un error conocido; para cadenas de salida, EV SetSystemConfig("FormatOutputBufferErrString","Error"), donde "Error" representa la cadena de error.

Protocolos compatibles

Se pueden añadir hasta dos protocolos a una tarea. Al añadir dos protocolos, puede agregar un protocolo "primario" y un protocolo "secundario". Por ejemplo, después de agregar el protocolo SLMP Scanner (primario), vuelva a hacer clic en el botón Agregar dispositivo y añada el protocolo TCP/IP (secundario).

Nota: No es posible añadir dos protocolos "primarios" ni dos protocolos "secundarios" a una tarea.

Firmware de In-Sight, versión 4.x.x

 | Primario o Secundario | Micro de la serie 1000 | Serie 5000 (excepto 5705 y 5705C) | Series 70xx - 74xx
CC-Link | Primario | X | X | X
Ethernet Native | Primario | X | X | X
Robot nativo Ethernet | Primario | X | X | X
Cadena nativa de Ethernet | Primario | X | X | X
EtherNet/IP | Primario | X | X | X
Servidor Modbus TCP | Primario | X | X | X
POWERLINK | Primario |  |  | X
PROFINET | Primario | X | X | X
Kuka serie | Primario | X | X | X
Motoman serie | Primario | X | X | X
Serie nativo | Primario | X | X | X
Robot nativo serie | Primario | X | X | X
Cadena nativa serie | Primario | X | X | X
Texto serie | Primario | X | X | X
SLMP | Primario | X | X | X
SLMP Scanner | Primario | X | X | X
TCP/IP | Secundario | X | X | X
UDP | Secundario | X | X | X

Firmware de In-Sight, versión 5.x.x

 | Primario o Secundario | Serie 2000 | 5705 y 5705C | Series 76xx - 79xx | Serie 8000
Ethernet Native | Primario |  | X | X | X
Ethernet Native Robot | Primario |  | X | X | X
Ethernet Native String | Primario |  | X | X | X
EtherNet/IP | Primario | X | X | X | X
Servidor Modbus TCP | Primario | X | X | X | X
PROFINET | Primario | X | X | X | X
Serial Kuka | Primario |  | X | X | X
Serial Motoman | Primario |  | X | X | X
Serial Native | Primario | X (básico) | X | X | X
Serial Native Robot | Primario |  | X | X | X
Serial Native String | Primario |  | X | X | X
Serial Text | Primario | X | X | X | X
SLMP | Primario | X | X | X | X
SLMP Scanner | Primario | X | X | X | X
TCP/IP | Secundario | X | X | X | X
UDP | Secundario | X | X | X | X


Comunicación con un PLC o controlador de movimiento

Para comunicar con un PLC/MC, primero realice lo siguiente:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC o Controlador de movimiento en la lista desplegable Dispositivo.
  3. En la lista desplegable Fabricante, seleccione el fabricante del PLC/MC. Si el fabricante de su PLC/MC no aparece, elija Otro.

  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones. La lista contiene los protocolos de comunicaciones que ofrezca el fabricante seleccionado.

    Nota: DeviceNet solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

  5. Pulse el botón Aceptar.
  6. Opcionalmente, vuelva a hacer clic en el botón Agregar dispositivo para añadir un protocolo "secundario" adicional a la tarea. Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.

Una vez que haya habilitado estos ajustes, configure las fichas que se mostrarán en el panel de ajustes.

Protocolos de PLC o de controlador de movimiento disponibles

Nota: Consulte Configuración de dispositivo para ver una lista completa de los protocolos admitidos.

  • Modbus TCP Server
  • CC-Link
  • SLMP
  • SLMP Scanner
  • EtherNet/IP
  • PROFINET
  • DeviceNet


Comunicación a través de Modbus TCP

El sensor In-Sight puede actuar como un servidor Modbus para otros dispositivos Modbus TCP conectados en red.

Para configurar el sensor In-Sight como un servidor Modbus:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC u Otro en la lista desplegable Dispositivo.

Nota: Si selecciona PLC, seleccione el fabricante de su PLC u Otro en la lista desplegable Fabricante para habilitar Servidor Modbus TCP como una opción en la lista desplegable Protocolo.

  3. Seleccione Servidor Modbus TCP en la lista desplegable Protocolo.
  4. Pulse el botón Aceptar.
  5. De forma predeterminada, en primer lugar aparece Formatear datos de salida. Los controles de ambas fichas son idénticos y quedan habilitados después de haber agregado los datos.

  6. Pulse el botón Agregar para abrir el cuadro de diálogo Seleccionar datos de entrada o Seleccionar datos de salida (según la ficha que se haya seleccionado). Los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección agregada a su tarea, así como los resultados totales de esta (solo salida). En el cuadro de diálogo, seleccione los datos que desee exponer a través de Modbus y pulse el botón Aceptar.

  7. Una vez añadidos los datos, estos aparecen en la tabla y permiten ver el nombre, el tipo de datos, el tamaño, el valor y el número de registro inicial de los datos seleccionados (los comandos Lectura y Escritura del cliente Modbus hacen referencia a este número, que es el que define qué señal se encuentra en qué registro). A la derecha de la tabla hay una ventana de vista previa de registros de Modbus, que muestra cómo se formatean los datos en los registros de Modbus.

  8. Puede personalizar el tipo de datos predeterminado si selecciona un tipo de datos diferente en la lista desplegable Tipo de datos.

Notas:
  • Si selecciona Cadena o Cadena de intercambio de bytes en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras.
  • La implementación de EasyBuilder del protocolo Modbus TCP no es compatible con tipos de datos de bit, de 8 bits o sin firmar.

  9. También puede personalizar el orden de bytes de los datos de tipo flotante o enteros de 32 bits si especifica bytes bajos primero en lugar de bytes altos primero mediante la desactivación de la casilla de verificación Bytes altos/bytes bajos (está desactivada de forma predeterminada). Puede personalizar el orden de relevancia de bytes de los datos de tipo flotante o enteros de 32 bits si especifica bytes menos significativos primero en lugar de bytes más significativos primero mediante la desactivación de la casilla de verificación Bytes más significativos/bytes menos significativos (está desactivada de forma predeterminada). Todos los cambios se actualizarán en la ventana de vista previa de los registros de Modbus.

Nota: Cualquier cambio realizado en el orden de los bytes o en el de la relevancia de los bytes repercutirán en todas las señales de datos de las fichas Formatear datos de salida y Formatear datos de entrada.

  10. Puede cambiar el orden de los datos que va a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
  11. Una vez que haya acabado de configurar el sistema de visión In-Sight, deberá configurar el cliente Modbus para enviar los comandos Lectura y Escritura; estos se enviarán al sistema de visión In-Sight para leer/escribir los datos.

Nota: Opcionalmente, vuelva a hacer clic en el botón Agregar dispositivo para añadir un protocolo "secundario" adicional a la tarea. Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.


Comunicaciones CC-Link

Nota: CC-Link solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

El protocolo CC-Link se utiliza para transferir datos hacia y desde los sistemas de visión In-Sight conectados al módulo de E/S CIO-Micro-CC de In-Sight y un PLC o controlador de movimiento (MC) de Mitsubishi. Las comunicaciones CC-Link se establecen entre la conexión CC-link en el módulo de E/S CIO-Micro-CC de In-Sight y la conexión CC-Link en el PLC/MC de Mitsubishi.

Nota: Para habilitar la comunicación CC-Link, el sistema de visión In-Sight debe estar conectado al módulo de E/S CIO-Micro-CC de In-Sight.

Para configurar un sistema de visión In-Sight de forma que se comunique con un PLC/MC de Mitsubishi a través de CC-Link, primero se deben ajustar los parámetros de la ficha Ajustes de CC-Link y, a continuación, se deben configurar los datos que se transferirán hacia y desde el PLC/MC de Mitsubishi y el sistema de visión In-Sight.

  • Configuración de la ficha Ajustes de CC-Link
  • Configuración de las fichas de datos de bits/palabras de entrada y de las fichas de datos de bits/palabras de salida


Comunicaciones SLMP

El protocolo SLMP permite intercambiar datos con PLC/MC de Mitsubishi y con sistemas de visión In-Sight.

En primer lugar, configure los parámetros de la ficha Ajustes de SLMP, que definen el tipo de controlador, la dirección IP, el número de puerto y los registros de origen y de destino del PLC/MC de Mitsubishi, así como información sobre el tiempo de espera.

A continuación, configure las fichas Formatear datos de salida y Formatear datos de entrada para definir los datos de herramienta o de tarea que se transferirán hacia y desde el PLC/MC.

  • Configuración de la ficha Ajustes de SLMP
  • Configuración de las fichas Formatear datos de salida y Formatear datos de entrada


Comunicaciones con SLMP Scanner

SLMP Scanner permite intercambiar datos con PLC y controladores de movimiento de Mitsubishi y con sistemas de visión In-Sight.

En primer lugar, configure los parámetros de la ficha Ajustes, en la que se definen los datos de conexión necesarios para establecer una conexión con el PLC/MC de Mitsubishi.

A continuación, configure la ficha Direccionamiento de dispositivos, que define la dirección del dispositivo PLC y el tamaño de los diferentes bloques de datos que deben comunicarse al PLC/MC.

Por último, configure las fichas Formatear datos de salida y Formatear datos de entrada para definir los datos de herramienta o de tarea que se transferirán hacia y desde el PLC/MC.

  • Configuración de la ficha Ajustes de SLMP Scanner
  • Configuración de la ficha Direccionamiento de dispositivos de SLMP Scanner
  • Configuración de las fichas Formatear datos de salida y Formatear datos de entrada de SLMP Scanner


Opciones de puerto serie de DeviceNet

EasyBuilder utiliza automáticamente los ajustes de puerto serie predeterminados del controlador DeviceNet. Si su controlador utiliza otros ajustes, haga clic en la ficha Ajustes del puerto serie y configure el sistema de visión In-Sight para que utilice los mismos ajustes de puerto serie. Los ajustes del puerto serie se guardarán en el sistema de visión In-Sight en el momento de salir del paso Comunicación.

Notas:
  • DeviceNet solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.
  • La configuración de DeviceNet requiere un convertidor ajeno de puerta de enlace "RS-232 a DeviceNet" ("RS-232-to-DeviceNet Gateway"). Estos ajustes sirven para instalaciones heredadas y no deben utilizarse en aplicaciones nuevas salvo que se compruebe exhaustivamente que el convertidor de puerta de enlace "RS-232 a DeviceNet" es adecuado para la aplicación.

  • Las opciones de puerto serie varían según el modelo de In-Sight y el módulo de E/S aplicable; si está conectado a un módulo de E/S compatible, pulse primero el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S y configure el módulo de E/S.

  • Los sistemas de visión In-Sight Micro de la serie 1000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO o CIO-MICRO-CC.

  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE de la fuente de alimentación y del cable de conexión de E/S estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.
  • Los sistemas de visión In-Sight de la serie 8000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO.

  • El módulo de E/S CIO-WENET no permite la comunicación serie.


Comunicación con un robot

En las aplicaciones robóticas dirigidas por visión artificial, EasyBuilder acelera el desarrollo examinando automáticamente su aplicación y formateando los datos de salida con un elemento (o la salida de otra herramienta de ubicación o inspección que devuelva datos de posición) en un formato específico Fabricante/Protocolo. Una vez formateada la cadena, el controlador del robot puede solicitar los datos enviando un único comando del modo nativo de In-Sight, que devuelve todos los datos formateados en la cadena.

Para comunicar con un controlador de robot, primero realice lo siguiente:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione Robot en la lista desplegable Dispositivo.
  3. En la lista desplegable Fabricante, seleccione el fabricante del robot. Si el fabricante de su robot no aparece, elija Otro.
  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones. La lista contiene los protocolos de comunicaciones que ofrezca el fabricante seleccionado.
  5. Pulse el botón Aceptar.
  6. Opcionalmente, vuelva a hacer clic en el botón Agregar dispositivo para añadir un protocolo "secundario" adicional a la tarea. Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.

Una vez habilitados estos ajustes, puede definir los datos.

  • Comunicaciones Ethernet nativas del robot
  • Comunicaciones serie nativas del robot
  • Comunicaciones serie de Kuka del robot
  • Comunicaciones serie de Motoman del robot
  • Comunicaciones IP Ethernet nativas del robot (controladora de robots FANUC)


Comunicaciones Ethernet nativas del robot

Nota: Estos pasos sólo son pertinentes si se seleccionó Robot como Dispositivo y Ethernet Nativo se seleccionó como Protocolo en el cuadro de grupo Configuración de dispositivo.

  1. Después de seleccionar Ethernet nativo en Protocolo, EasyBuilder buscará automáticamente en su tarea cualquier herramienta de ubicación o de inspección que defina un elemento y generará una cadena de datos representando dicho elemento.
  2. En la ficha Formatear cadena de salida, cualquier herramienta que genere un elemento aparecerá en la lista desplegable Nombre de posición. Si su tarea sólo contiene una herramienta que devuelva datos de posición, ésta se seleccionará de forma predeterminada. En caso contrario, seleccione en la lista desplegable Nombre de posición la herramienta cuya cadena de salida desee enviar. Se visualizarán la cadena formateada y el número de caracteres en la cadena, con fines de referencia.
  3. Una vez formateada la cadena, el controlador del robot puede solicitar los datos enviando el comando del modo nativo de In-Sight, EV GetCellValue ("Job.Robot.FormatString"). EV GetCellValue ("Job.Robot.FormatString") devuelve todos los datos formateados en la cadena con un solo comando.

Nota:Si aún no ha definido un elemento en su tarea, o si desea crear una cadena personalizada o personalizar el formato de su cadena, presione el botón Formato personalizado… para abrir el cuadro de diálogo FormatString. Este cuadro de diálogo permite añadir otra cadena, modificar las cadenas existentes y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y establecer el orden deseado haciendo clic en los botones Subir y Bajar. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.


Comunicaciones serie nativas del robot

Nota: Estos pasos solo son aplicables si se selecciona Robot como Dispositivo y Serial Native como Protocolo en la sección Comunicación.

  1. Después de seleccionar Serie nativo en Protocolo, EasyBuilder buscará automáticamente en su tarea cualquier herramienta de ubicación o de inspección que defina un elemento y generará una cadena de datos representando dicho elemento.
  2. En la ficha Formatear cadena de salida, cualquier herramienta que genere un elemento aparecerá en la lista desplegable Nombre de posición. Si su tarea solo contiene una herramienta que devuelva datos de posición, ésta se seleccionará de forma predeterminada. En caso contrario, seleccione en la lista desplegable Nombre de posición la herramienta cuya cadena de salida desee enviar. Se visualizarán la cadena formateada y el número de caracteres en la cadena, con fines de referencia.
  3. Si fuese necesario, haga clic en la ficha Opciones de puerto serie para definir los ajustes de comunicaciones serie. EasyBuilder determinará automáticamente el protocolo del modo serie basándose en las selecciones de Configuración de dispositivo. Los ajustes del puerto serie se guardan en el sistema de visión al salir del paso Comunicación.
Notas:

  • Las opciones de puerto serie varían según el modelo de In-Sight y el módulo de E/S aplicable; si está conectado a un módulo de E/S compatible, pulse primero el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S y configure el módulo de E/S.

  • Los sistemas de visión In-Sight Micro de la serie 1000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO o CIO-MICRO-CC.

  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE de la fuente de alimentación y del cable de conexión de E/S estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.
  • Los sistemas de visión In-Sight de la serie 8000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO.

  • El módulo de E/S CIO-WENET no permite la comunicación serie.
  4. Una vez formateada la cadena, el controlador del robot puede solicitar los datos enviando el comando del modo nativo de In-Sight, EV GetCellValue ("Job.Robot.FormatString"). EV GetCellValue ("Job.Robot.FormatString") devuelve todos los datos formateados en la cadena con un solo comando.

Nota: Si aún no ha definido un elemento en su tarea, o si desea crear una cadena personalizada o personalizar el formato de su cadena, presione el botón Formato personalizado… para abrir el cuadro de diálogo FormatString. Este cuadro de diálogo permite añadir otra cadena, modificar las cadenas existentes y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y establecer el orden deseado haciendo clic en los botones Subir y Bajar. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.


Comunicaciones serie de Kuka del robot

Los controladores de robots Kuka se comunican con otros dispositivos a través de puertos serie RS-232, utilizando un protocolo de comprobación de errores complejo pero muy estable. Si se configura para comunicaciones serie de Kuka, el sistema de visión In-Sight entiende este protocolo y puede responder a los comandos que recibe del controlador Kuka.

Notas:
  • Para poder comunicarse con un sistema de visión In-Sight, el robot Kuka debe estar en el modo P3964R y el sistema de visión debe estar en el modo Kuka serie, según se describe más abajo.
  • Los sistemas de visión In-Sight están configurados para utilizar los ajustes predeterminados del protocolo Kuka (es decir, el robot Kuka tiene alta prioridad y el sistema de visión tiene baja prioridad para transacciones).

  1. Después de seleccionar Kuka serie en Protocolo, EasyBuilder buscará automáticamente en su tarea cualquier herramienta de ubicación o de inspección que defina un elemento y generará una cadena de datos representando dicho elemento. Cualquier herramienta que genere un elemento aparecerá en la lista desplegable Nombre de posición. Si su tarea solo contiene una herramienta que devuelva datos de posición, ésta se seleccionará de forma predeterminada. En caso contrario, seleccione en la lista desplegable Nombre de posición la herramienta cuya cadena de salida desee enviar. Se visualizarán la cadena formateada y el número de caracteres en la cadena, con fines de referencia. También se incluye el campo Ubicación codificada, que muestra los datos que el controlador de robot Kuka consulta para generar el comando del modo nativo de In-Sight: GV[Ubicación codificada].

Nota: Si aún no ha definido un elemento en su tarea, o si desea crear una cadena personalizada o personalizar el formato de su cadena, presione el botón Formato personalizado… para abrir el cuadro de diálogo FormatString. Este cuadro de diálogo permite añadir otra cadena, modificar las cadenas existentes y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y establecer el orden deseado haciendo clic en los botones Subir y Bajar. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.

  2. EasyBuilder utiliza automáticamente los ajustes de puerto serie predeterminados del controlador Kuka. Si su controlador utiliza otros ajustes, haga clic en la ficha Ajustes del puerto serie y configure el sistema de visión para que utilice los mismos ajustes de puerto serie. Los ajustes del puerto serie se guardarán en el sistema de visión al salir del paso Comunicación.
Notas:
  • Se admiten controladores de robots Kuka KR C2 y KR C2 Edition 2005.

  • Las opciones de puerto serie varían según el modelo de In-Sight y el módulo de E/S aplicable; si está conectado a un módulo de E/S compatible, pulse primero el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S y configure el módulo de E/S.

  • Los sistemas de visión In-Sight Micro de la serie 1000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO o CIO-MICRO-CC.

  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE de la fuente de alimentación y del cable de conexión de E/S estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.
  • Los sistemas de visión In-Sight de la serie 8000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO.

  • El módulo de E/S CIO-WENET no permite la comunicación serie.
  3. El controlador de robots Kuka inicia todas las comunicaciones de datos con el sistema de visión enviando comandos del modo nativo de In-Sight. El comando GV[Ubicación codificada] devolverá la cadena configurada en estos pasos y deberá utilizarse con todas las tareas desarrolladas en EasyBuilder.

Kuka serie es una extensión de las comunicaciones en modo nativo de In-Sight. Dado que Kuka serie está basado en el modo nativo, pueden desarrollarse tareas del sistema de visión In-Sight en el modo nativo, pero posteriormente es posible cambiar a Kuka serie solo cuando el controlador de robots esté realmente conectado al sistema de visión. No es necesario realizar ningún otro cambio en las tareas.

Closed Comandos del modo nativo de In-Sight para comunicaciones serie de Kuka:
Comando del modo nativo | Sintaxis
Get Job (Obtener tarea) | GJ
Get Online (Poner en línea) | GO
Get Value (Obtener valor) | GV[Ubicación codificada]
Get Value (Obtener valor) | GV[Nombre simbólico]
Load File (Cargar archivo) | LF[nombre de archivo]
Set Event (Definir evento) | SE[entero]
Store File (Guardar archivo) | TF[nombre de archivo]
Set Float (Definir flotante) | SF[Nombre simbólico][Valor flotante]
Set Integer (Definir entero) | SI[Nombre simbólico][Valor entero]
Definir tarea | SJ[ID]
Set Online (Poner en línea) | SO[Valor entero]
Set String (Definir cadena) | SS[Nombre simbólico][Cadena]


Comunicaciones serie de Motoman del robot

Los controladores de robots de Motoman MRC, MRC-II y XRC se comunican con otros dispositivos a través de puertos serie RS-232, utilizando un protocolo de comprobación de errores complejo, pero muy estable. Si se configura para comunicaciones serie de Motoman, el sistema de visión In-Sight entiende este protocolo y puede responder a los comandos que recibe del controlador Motoman.

Notas:
  • El controlador de Motoman debe configurarse para comunicar en modo DCI. Por el momento no es posible iniciar comunicaciones de un sistema de visión In-Sight a un controlador de robots Motoman en modo host.
  • Aunque los controladores Motoman especifican el valor "Ninguno" para el control de flujo, los sistemas de visión In-Sight requieren el control de flujo "Hardware" (establecimiento de comunicación por hardware) para comunicarse con un controlador Motoman.
  • Solo se han puesto a prueba los controladores XRC de Motoman.
  • Dado que Motoman serie está basado en el modo nativo, pueden desarrollarse tareas de In-Sight en el modo nativo, y posteriormente cambiar a Motoman serie solo cuando el controlador de robots esté realmente conectado al sistema de visión. No es necesario realizar ningún otro cambio en las tareas.

  1. Después de seleccionar Motoman serie en Protocolo, EasyBuilder buscará automáticamente en su tarea cualquier herramienta de ubicación o de inspección que defina un elemento y generará una cadena de datos representando dicho elemento.

Nota: Si aún no ha definido un elemento en su tarea, o si desea crear una cadena personalizada o personalizar el formato de su cadena, presione el botón Formato personalizado… para abrir el cuadro de diálogo FormatString. Este cuadro de diálogo permite añadir otra cadena, modificar las cadenas existentes y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y establecer el orden deseado haciendo clic en los botones Subir y Bajar. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.

  2. En la ficha Formatear cadena de salida, cualquier herramienta que genere un elemento aparecerá en la lista desplegable Nombre de posición. Si su tarea solo contiene una herramienta que devuelva datos de posición, ésta se seleccionará de forma predeterminada. En caso contrario, seleccione en la lista desplegable Nombre de posición la herramienta cuya cadena de salida desee enviar. Se visualizarán la cadena formateada y el número de caracteres en la cadena, con fines de referencia.
  3. El campo Ubicación codificada muestra los datos CC + RRR que el controlador de robots Motoman utiliza para obtener datos de un sistema de visión.
  4. EasyBuilder utiliza automáticamente los ajustes de puerto serie predeterminados del controlador Motoman. Si su controlador utiliza otros ajustes, haga clic en la ficha Ajustes del puerto serie y configure el sistema de visión para que utilice los mismos ajustes de puerto serie. Los ajustes del puerto serie se guardarán en el sistema de visión al salir del paso Comunicación.
Notas:

  • Las opciones de puerto serie varían según el modelo de In-Sight y el módulo de E/S aplicable; si está conectado a un módulo de E/S compatible, pulse primero el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S y configure el módulo de E/S.

  • Los sistemas de visión In-Sight Micro de la serie 1000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO o CIO-MICRO-CC.

  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Si el sistema de visión In-Sight de las series 70xx - 74xx está configurado para su uso con el módulo E/S CIO-MICRO o CIO-MICRO-CC, los contactos RS-232 TRANSMIT y RS-232 RECEIVE de la fuente de alimentación y del cable de conexión de E/S estarán deshabilitados. Utilice el puerto RS-232 OUT (DB9) del módulo E/S para conectarse a un dispositivo serie.
  • Los sistemas de visión In-Sight de la serie 8000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO.

  • El módulo de E/S CIO-WENET no permite la comunicación serie.
  5. El controlador de robots Motoman inicia todas las comunicaciones de datos con el sistema de visión enviando comandos del modo nativo de In-Sight. El comando GV[Ubicación codificada] devolverá la cadena configurada en estos pasos y deberá utilizarse con todas las tareas desarrolladas en EasyBuilder.

Motoman serie es una extensión de las comunicaciones en modo nativo de In-Sight. Los controladores de robots Motoman solo envían texto numérico a través de sus puertos RS-232; no se pueden enviar comandos del modo nativo estándar de In-Sight. En lugar de ello, el controlador de Motoman debe enviar al sistema de visión una representación numérica de los comandos del modo nativo, con los parámetros adicionales necesarios.

Para más información sobre comandos específicos de Motoman, consulte los temas siguientes:

  • Comandos de Motoman
  • Ejemplos de comandos de Motoman


Comunicaciones IP Ethernet nativas del robot (FANUC)

Los sistemas de visión In-Sight se pueden configurar de manera que se comuniquen con un controlador de robot FANUC a través de EtherNet/IP (EIP).

  1. Después de seleccionar Robot como dispositivo, FANUC como fabricante y Ethernet IP Robot como protocolo, EasyBuilder buscará automáticamente en su tarea cualquier herramienta de ubicación o de inspección que definan un elemento y generará una cadena de datos que representará dicho elemento.

    Notas:
    • Para configurar las comunicaciones Ethernet IP Robot para un controlador FANUC robot, seleccione FANUC en la lista desplegable de fabricantes. Si selecciona Otro en la lista desplegable de fabricantes, EasyBuilder mostrará el panel de ajustes Ethernet/IP de otros dispositivos.
    • Si se utiliza el protocolo “Ethernet Native Robot” o “Serial Native Robot” para comunicarse con un controlador FANUC robot, consulte respectivamente el tema Comunicaciones Ethernet nativas del robot o Comunicaciones serie nativas del robot.
  2. En la pestaña Formatear datos de salida, cualquier herramienta que genere un elemento aparecerá en la lista desplegable Nombre de posición. Si su tarea solo contiene una herramienta que devuelva datos de posición, ésta se seleccionará de forma predeterminada. En caso contrario, seleccione en la lista desplegable Nombre de posición la herramienta cuya cadena de salida desee enviar. Como referencia, se mostrarán la cadena del búfer de salida y el tamaño del mensaje en bytes.

Nota: Para obtener más información sobre el controlador FANUC Robot, consulte el tema Comunicaciones del Robot - Controlador FANUC Robot.


Comunicación con dispositivos Mitsubishi

Closed Comunicación con un PLC o controlador de movimiento ("Motion Controller" o MC) de Mitsubishi

Para establecer una comunicación con un PLC o MC de Mitsubishi, primero realice lo siguiente:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC en la lista desplegable PLC / Controlador de movimiento.
  3. En la lista desplegable Fabricante, seleccione Mitsubishi.

  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones: CC-Link, SLMP o SLMP Scanner.

    Nota: CC-Link solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

  5. Pulse el botón Aceptar.
  6. Opcionalmente, vuelva a hacer clic en el botón Agregar dispositivo para añadir un protocolo "secundario" adicional a la tarea. Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.

Cuando haya habilitado estos ajustes, podrá configurar los ajustes para establecer comunicación con dispositivos PLC o MC de Mitsubishi:

  • CC-Link
  • SLMP
  • SLMP Scanner

Nota: Si se configura un sistema de visión In-Sight para que se comunique con un PLC/MC a través del protocolo SLMP, SLMP Scanner o CC-Link, estos protocolos solo admitirán transferencias de datos entre el sistema de visión y el PLC/MC.

Closed Comunicación con un robot de Mitsubishi

Para comunicarse con un robot de Mitsubishi, primero haga lo siguiente:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione Robot en la lista desplegable Dispositivo.
  3. En la lista desplegable Fabricante, seleccione Mitsubishi.
  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones: Cadena nativa de Ethernet o Cadena nativa serie.
  5. Pulse el botón Aceptar.
  6. Opcionalmente, vuelva a hacer clic en el botón Agregar dispositivo para añadir un protocolo "secundario" adicional a la tarea. Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.

Una vez activados estos ajustes, puede configurar los datos que se comunicarán entre el sistema de visión In-Sight y el robot:

  • Configuración de las comunicaciones de cadenas nativas Ethernet de Mitsubishi
  • Configuración de las comunicaciones de cadenas nativas serie de Mitsubishi


Configuración de la ficha Ajustes de CC-Link

La ficha Ajustes de CC-Link se utiliza para configurar el módulo de E/S CIO-Micro-CC de In-Sight para la comunicación en la red CC-Link.

Nota: Si no está conectado a un módulo de E/S CIO-Micro-CC de In-Sight, todos los controles permanecerán desactivados hasta que se haya establecido esta conexión.

Closed Habilitar

Determina si la interfaz de CC-Link en el módulo de E/S CIO-Micro-CC de In-Sight estará habilitada o deshabilitada. De forma predeterminada, está seleccionada la casilla de verificación Habilitar y la interfaz de CC-Link en el módulo de E/S CIO-Micro-CC de In-Sight está habilitada. Si fuera necesario, elimine la selección de la casilla de verificación Habilitar para diagnosticar y depurar su conexión CC-Link.

Closed Versión

Define la compatibilidad de especificación CC-Link, V1 o V2. De forma predeterminada, está seleccionada V1.

Closed Velocidad de transmisión

Define la velocidad de transmisión CC-Link de la red CC-Link, 10M, 5M, 2.5M, 625k, 156k. De forma predeterminada, está seleccionada 10M.

Closed Número de estación

Define el número de estación del esclavo CC-Link, de 1 a 64. De forma predeterminada, está seleccionado 1.

Nota: Los valores asignados en los parámetros Número de estación y Número de estaciones no puede exceder de 64.

Closed Número de estaciones

Determina el número de estaciones que el módulo de E/S CIO-Micro-CC de In-Sight ocupa en la red CC-Link, de1 a 4. De forma predeterminada, está seleccionado 1.

Nota: Los valores asignados en los parámetros Número de estación y Número de estaciones no puede exceder de 64.

Closed Ciclos de extensión

Define el número de ciclos de extensión que el módulo de E/S CIO-Micro-CC de In-Sight utiliza en la red CC-Link, 1X (deshabilitado), 2X, 4X, o 8X. La opción 1X (deshabilitado) está seleccionada de forma predeterminada.

Nota: Esta opción sólo está disponible si el parámetro Versión se ajusta a V2.

Closed Entradas

Muestra la cantidad de bits y palabras disponibles en los búferes de bits y palabras de entrada respectivamente.

Para determinar el número de bits disponibles en el búfer de entrada:

  • Si el parámetro Versión está ajustado a V1: 32 x (Número de estaciones)-16
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está ajustado a 1X (deshabilitado): 32 x (Número de estaciones)-16
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está habilitado: 32 x (Número de estaciones) x (Ciclos de extensión) - 16 x (Ciclos de extensión) - 16

Para determinar el número de palabras disponibles en el búfer de entrada:

  • Si el parámetro Versión está ajustado a V1: 4 x (Número de estaciones)
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está ajustado a 1X (deshabilitado): 4 x (Número de estaciones)
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está habilitado: 4 x (Número de estaciones) x (Ciclos de extensión)
Closed Salidas

Muestra la cantidad de bits y palabras disponibles en los búferes de bits y palabras de salida respectivamente.

Para determinar el número de bits disponibles en el búfer de salida:

  • Si el parámetro Versión está ajustado a V1: 32 x (Número de estaciones)-16
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está ajustado a 1X (deshabilitado): 32 x (Número de estaciones)-16
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está habilitado: 32 x (Número de estaciones) x (Ciclos de extensión) - 16 x (Ciclos de extensión) - 16

Para determinar el número de palabras disponibles en el búfer de salida:

  • Si el parámetro Versión está ajustado a V1: 4 x (Número de estaciones)
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está ajustado a 1X (deshabilitado): 4 x (Número de estaciones)
  • Si el parámetro Versión está ajustado a V2 y el parámetro Ciclos de extensión está habilitado: 4 x (Número de estaciones) x (Ciclos de extensión)


Configuración de las fichas de datos de bits/palabras de entrada y de las fichas de datos de bits/palabras de salida

Tras configurar la ficha Ajustes de CC-Link, deberá configurar las fichas Datos de bits de entrada, Datos de palabras de entrada, Datos de bits de salida y Datos de palabras de salida, las cuales se utilizan para definir qué datos de la tarea o herramienta se transferirán desde y hacia el PLC/MC de Mitsubishi y el sistema de visión In-Sight mediante la red CC-Link.

Closed Configuración de la ficha Datos de bits de entrada

La ficha Datos de bits de entrada se utiliza para asociar desplazamientos de bits a tipos de datos boleanos que devuelven los resultados de la herramienta de Ubicación o de Inspección, los datos de adquisición o las Entradas. Puede definir un máximo de 32 entradas por tarea.

  1. Haga clic en la ficha Datos de bits de entrada para iniciar la configuración de los datos que se transferirán del PLC/MC al sistema de visión In-Sight.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de entrada, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición y Entradas. Seleccione los datos que desea que se transfieran desde el PLC/MC al sistema de visión In-Sight y pulse el botón Aceptar.
  3. Una vez ha añadido los datos, estos aparecen en la tabla y permiten ver la dirección del dispositivo, el nombre de la entrada y el tipo, tamaño y valor de los datos.
  4. Puede cambiar el orden de los datos que va a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
Closed Configuración de la ficha Datos de palabras de entrada

La ficha Datos de palabras de entrada se utiliza para definir entradas en el sistema de visión In-Sight que devuelven los resultados de la herramienta de Ubicación o de Inspección, los datos de adquisición o las Entradas. Puede definir un máximo de 32 entradas por tarea.

Nota: El número de palabras no puede exceder el límite establecido por los parámetros configurados en la ficha Ajustes de CC-Link.

  1. Haga clic en la ficha Datos de palabras de entrada para iniciar la configuración de los datos que se transferirán del PLC/MC al sistema de visión In-Sight.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de entrada, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición y Entradas. Seleccione los datos que desea que se transfieran desde el PLC/MC al sistema de visión In-Sight y pulse el botón Aceptar.
  3. Una vez ha añadido los datos, estos aparecen en la tabla y permiten ver la dirección del dispositivo (el principio de la dirección es el desplazamiento de campo, en palabras), el nombre de la entrada y el tipo, tamaño y valor de los datos.
  4. Puede personalizar el tipo de datos predeterminado si selecciona un tipo de datos diferente en la lista desplegable Tipo de datos.

Notas:
  • Si selecciona Cadena en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras (con un máximo de 128).
  • La implementación de EasyBuilder de CC-Link no es compatible con tipos de datos de 8 bits o sin firmar.

  5. Puede cambiar el orden de los datos que va a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
Closed Configuración de la ficha Datos de bits de salida

La ficha Datos de bits de salida se utiliza para asociar desplazamientos de bits a tipos de datos boleanos que devuelven los resultados de la herramienta de Ubicación o de Inspección, los datos de adquisición o los resultados de la tarea. Puede definir al menos 64 salidas por tarea (pueden añadirse más, el límite depende del tamaño de la tarea).

  1. Haga clic en la ficha Datos de bits de salida para iniciar la configuración de los datos que se transferirán del sistema de visión In-Sight al PLC/MC.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de salida, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición o resultados totales de la tarea. Seleccione los datos que desea que se transfieran desde el sistema de visión In-Sight al PLC/MC y pulse el botón Aceptar.

Nota: Los datos de la Tarea.Recuento_Inspecciones se añaden automáticamente y de manera predeterminada a la tabla de datos de salida. Este símbolo advierte al PLC/MC que el sistema de visión In-Sight ha adquirido una nueva imagen y que ha llegado un nuevo conjunto de resultados de inspección. Este símbolo puede eliminarse si no es necesario para la aplicación.

  3. Una vez ha añadido los datos, estos aparecen en la tabla y permiten ver el nombre, el tipo, tamaño y valor de los datos, así como el número de registro inicial de los datos seleccionados. A la derecha de la tabla hay una ventana de vista previa de registros, que muestra cómo se formatean los datos en los registros de PLC/MC.
  4. Puede cambiar el orden de los datos que va a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
Closed Configuración de la ficha Datos de palabras de salida

La ficha Datos de palabras de salida se utiliza para definir salidas del sistema de visión In-Sight que devuelven los resultados de la herramienta de Ubicación o de Inspección, los datos de adquisición o los resultados de tarea. Puede definir al menos 32 salidas por tarea (pueden añadirse más, el límite depende del tamaño de la tarea).

  1. Haga clic en la ficha Datos de bits de salida para iniciar la configuración de los datos que se transferirán del sistema de visión In-Sight al PLC/MC.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de salida, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición o resultados totales de la tarea. Seleccione los datos que desea que se transfieran desde el sistema de visión In-Sight al PLC/MC y pulse el botón Aceptar.

Nota: Los datos de la Tarea.Recuento_Inspecciones se añaden automáticamente y de manera predeterminada a la tabla de datos de salida. Este símbolo advierte al PLC/MC que el sistema de visión In-Sight ha adquirido una nueva imagen y que ha llegado un nuevo conjunto de resultados de inspección. Este símbolo puede eliminarse si no es necesario para la aplicación.

  3. Una vez ha añadido los datos, estos aparecen en la tabla y permiten ver el nombre, el tipo, tamaño y valor de los datos, así como el número de registro inicial de los datos seleccionados (el principio de la dirección es el desplazamiento de campo, en palabras). A la derecha de la tabla hay una ventana de vista previa de registros, que muestra cómo se formatean los datos en los registros de PLC/MC.
  4. Puede personalizar el tipo de datos predeterminado si selecciona un tipo de datos diferente en la lista desplegable Tipo de datos.

Notas:
  • Si selecciona Cadena en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras (con un máximo de 128).
  • La implementación de EasyBuilder de CC-Link no es compatible con tipos de datos de 8 bits o sin firmar.

  5. Puede cambiar el orden de los datos que va a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.


Configuración de la ficha Ajustes de SLMP

La ficha Ajustes de SLMP permite configurar el tipo de controlador, la dirección IP del PLC/MC, el número de puerto TCP, los tiempos de espera y las ubicaciones de los registros de origen y de destino del PLC/MC.

Closed Tipo de controlador

Define el tipo de PLC o MC de Mitsubishi con el que comunicarse: Series iQ-R/Q/L (fotograma 3E), Series iQ-F (fotograma 3E) o Serie FX (fotograma 1E). Valor predeterminado = Series iQ-R/Q/L (fotograma 3E).

Nota: La opción Series iQ-F (fotograma 3E) no está disponible en los sistemas de visión In-Sight que ejecuten firmware de la versión 4.x.x de In-Sight.
Closed Dirección IP

Define la dirección IP del PLC/MC de Mitsubishi. Introduzca la dirección IP del PLC/MC de Mitsubishi que se conectará al sistema de visión In-Sight.

Closed Puerto del host

Define el número de puerto TCP, en formato decimal (Dec) o hexadecimal (Hex), del PLC/MC de Mitsubishi (1 - 65535 en Dec, 1 – 0xFFFF en Hex; valor predeterminado = 12288 en Dec).

Notas:
  • Este valor debe coincidir con el ajuste de Puerto del host que se haya establecido en el Puerto SLMP del PLC/MC de Mitsubishi.
  • El formato del número de puerto del equipo se restablecerá a decimal (Dec) en el momento de cerrar In-Sight Explorer.
Closed Tiempo de espera (ms)

Define el tiempo de espera (de 5 a 30.000 milisegundos; el valor predeterminado es 1.000 ms) tanto para las operaciones de lectura como para las de escritura.

Nota: Este parámetro podría prolongar la duración de la tarea; si las operaciones de lectura y escritura fallasen, el tiempo añadido a la tarea sería el doble del valor indicado en Tiempo de espera, puesto que se sumarían los tiempos de espera de ambas operaciones.

Closed Dispositivo de origen
Closed Dirección de dispositivo de datos de entrada

Define qué registro de dispositivo del PLC/MC de Mitsubishi se debe leer:

Tipo de dispositivo para la serie iQ-R/Q/L (fotograma 3E)

Tipo de dispositivo | Formato
X - Relé de entrada | Bit
Y - Relé de salida | Bit
M - Relé interno | Bit
L - Relé de cerrojo | Bit
F - Anunciador | Bit
B - Relé de vínculos | Bit
D - Registro de datos | Palabra
W - Registro de vínculos | Palabra
R - Registro del bloque de archivos | Palabra
ZR - Registro de archivos | Palabra
TN - Valor del temporizador | Palabra
CN - Valor del contador | Palabra

Tipo de dispositivo para la serie iQ-F (fotograma 3E)

Tipo de dispositivo | Formato
X - Relé de entrada | Bit
Y - Relé de salida | Bit
M - Relé interno | Bit
F - Anunciador | Bit
D - Registro de datos | Palabra

Tipo de dispositivo para la serie FX (fotograma 1E)

Tipo de dispositivo | Formato
X - Relé de entrada | Bit (oct)
Y - Relé de salida | Bit (oct)
M - Relé interno | Bit
D - Registro de datos | Palabra
TN - Valor del temporizador | Palabra
CN - Valor del contador | Palabra
R - Registro de extensión | Palabra
S - Relé de estado | Bit

Nota: El Formato del Tipo de dispositivo determina qué tipo de selección de Tipo de datos estará disponible en la ficha Formatear búfer de entrada. Si el Formato de Tipo de dispositivo es Bit, entonces las ficha Formatear búfer de entrada solo permitirá la introducción de datos de tipo bit.

Closed Desplazamiento

Parte numérica de la tabla de datos del PLC/MC que define el lugar donde comenzará la lectura.

Closed Dispositivo de destino
Closed Dirección de dispositivo de datos de salida

Define el registro de dispositivo del PLC/MC de Mitsubishi hacia el que se debe leer:

Tipo de dispositivo para la serie iQ-R/Q/L (fotograma 3E)

Tipo de dispositivo | Formato
X - Relé de entrada | Bit
Y - Relé de salida | Bit
M - Relé interno | Bit
L - Relé de cerrojo | Bit
F - Anunciador | Bit
B - Relé de vínculos | Bit
D - Registro de datos | Palabra
W - Registro de vínculos | Palabra
R - Registro del bloque de archivos | Palabra
ZR - Registro de archivos | Palabra
TN - Valor del temporizador | Palabra
CN - Valor del contador | Palabra

Tipo de dispositivo para la serie iQ-F (fotograma 3E)

Tipo de dispositivo | Formato
X - Relé de entrada | Bit
Y - Relé de salida | Bit
M - Relé interno | Bit
F - Anunciador | Bit
D - Registro de datos | Palabra

Tipo de dispositivo para la serie FX (fotograma 1E)

Tipo de dispositivo | Formato
X - Relé de entrada | Bit (oct)
Y - Relé de salida | Bit (oct)
M - Relé interno | Bit
D - Registro de datos | Palabra
TN - Valor del temporizador | Palabra
CN - Valor del contador | Palabra
R - Registro de extensión | Palabra
S - Relé de estado | Bit

Nota: El Formato del Tipo de dispositivo determina qué tipo de selección de Tipo de datos estará disponible en la ficha Formatear búfer de salida. Si el Formato de Tipo de dispositivo es Bit, entonces las ficha Formatear búfer de salida solo permitirá la introducción de datos de tipo bit.

Closed Desplazamiento

Parte numérica de la tabla de datos del PLC/MC que define el lugar donde comenzará la escritura.


Configuración de las fichas Formatear datos de salida y Formatear datos de entrada (SLMP)

Tras configurar la ficha Ajustes de SLMP, deberá configurar las fichas Formatear datos de entrada y Formatear datos de salida, las cuales se utilizan para definir qué datos de tarea o herramienta se transferirán desde y hacia el PLC/MC de Mitsubishi y el sistema de visión In-Sight.

Closed Configuración de la ficha Formatear datos de entrada

La ficha Formatear datos de entrada se utiliza para definir las entradas en el sistema de visión In-Sight. Se puede definir un máximo de 32 entradas por tarea.

  1. Haga clic en la ficha Formatear datos de entrada para iniciar la configuración de los datos que se transferirán del PLC/MC al sistema de visión In-Sight.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de entrada, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición y Entradas. Seleccione los datos que desea que se transfieran desde el PLC/MC al sistema de visión In-Sight y pulse el botón Aceptar.

Nota: El ajuste Dispositivo fuente de la ficha Ajustes de SLMP influye en el tipo de datos que pueden añadirse. Si el ajuste Dispositivo fuente está configurada para un dispositivo de bits, para cada dirección de bits podrá añadir tipos de datos boleanos y asignarlos a un bit determinado. Si el ajuste Dispositivo fuente está configurada para un dispositivo de palabras, podrá configurar el Tipo de datos y la dirección inicial será la Dirección del dispositivo de datos de entrada y el desplazamiento de campo, en palabras.

  3. Cuando haya añadido sus datos, éstos aparecerán en la tabla, mostrando la dirección de dispositivo, nombre de la entrada y su tipo, tamaño y valor de datos.
  4. Puede personalizar el tipo de datos predeterminados seleccionando un tipo diferente de datos en la lista desplegable Tipo de datos.

Notas:
  • Las selecciones de Tipo de datos dependerán del ajuste Dispositivo fuente en la ficha Ajustes de SLMP. Si el ajuste Dispositivo fuente está configurada para un dispositivo de bits, la lista desplegable Tipo de datos solo incluirá la opción Bit. Si el ajuste Dispositivo fuente está configurada para un dispositivo de palabras, la lista desplegable Tipo de datos incluirá las siguientes opciones: Bit, 16 bits enteros, 16 bits enteros no identificados, 32 bits enteros, 32 bits flotantes yCadena.
  • Si selecciona Cadena en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras. Cuando el tipo de controlador seleccionado es Series iQ-R/Q/L (fotograma 3E) o Series iQ-F (fotograma 3E), el tamaño máximo total de los mensajes es de 960 palabras. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, el tamaño máximo total del mensaje es de 64 palabras.
  • Cuando se ha seleccionado Serie iQ-R/F/L(fotograma 3E) o Serie iQ-F (fotograma 3E) como tipo de controlador, la longitud máxima de los datos de entrada es de 1920 bytes. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, la longitud máxima de los datos de entrada es de 128 bytes. El tamaño de los datos de entrada se muestra en el campoTamaño del mensaje (bytes).
  • El botón Restablecer tipos de datos restaura todos los tipos de datos con sus ajustes predeterminados.
  • La implementación de EasyBuilder del protocolo SLMP no es compatible con tipos de datos de 8 bits o sin firmar.

  5. Puede modificar el orden de los datos que se enviarán o recibirán seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado.
Closed Configuración de la ficha Formatear datos de salida

La ficha Formatear datos de salida se utiliza para definir las salidas desde el sistema de visión In-Sight. Se pueden definir hasta 128 salidas por tarea.

  1. Haga clic en la ficha Formatear datos de salida para iniciar la configuración de los datos que se transferirán del sistema de visión In-Sight al PLC/MC.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de salida, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición o resultados totales de la tarea. Seleccione los datos que desea que se transfieran desde el PLC/MC al sistema de visión In-Sight y pulse el botón Aceptar.

Notas:
  • Los datos de la Tarea.Recuento_Inspecciones se añaden automáticamente y de manera predeterminada a la tabla de datos de salida. Este símbolo advierte al PLC/MC que el sistema de visión In-Sight ha adquirido una nueva imagen y que ha llegado un nuevo conjunto de resultados de inspección. Este símbolo puede eliminarse si no es necesario para la aplicación.
  • El ajuste Dispositivo de destino de la ficha Ajustes de SLMP influye en el tipo de datos que pueden añadirse. Si el ajuste Dispositivo de destino está configurada para un dispositivo de bits, para cada dirección de bits podrá añadir tipos de datos boleanos y asignarlos a un bit determinado. Si el ajuste Dispositivo de destino está configurada para un dispositivo de palabras, podrá configurar el Tipo de datos y la dirección inicial será la Dirección del dispositivo de datos de salida y el desplazamiento de campo, en palabras.

  3. Una vez ha añadido los datos, estos aparecen en la tabla y permiten ver el nombre, el tipo, tamaño y valor de los datos, así como el número de registro inicial de los datos seleccionados. A la derecha de la tabla hay una ventana de vista previa de registros, que muestra cómo se formatean los datos en los registros de PLC/MC.
  4. Puede personalizar el tipo de datos predeterminados seleccionando un tipo diferente de datos en la lista desplegable Tipo de datos.

Notas:
  • Las selecciones de Tipo de datos dependerán del ajuste Dispositivo de destino en la ficha Ajustes de SLMP. Si el ajuste Dispositivo de destino está configurada para un dispositivo de bits, la lista desplegable Tipo de datos solo incluirá la opción Bit. Si el ajuste Dispositivo de destino está configurada para un dispositivo de palabras, la lista desplegable Tipo de datos incluirá las siguientes opciones: Bit, 16 bits enteros, 16 bits enteros no identificados, 32 bits enteros, 32 bits flotantes yCadena.
  • Si selecciona Cadena en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras. Cuando el tipo de controlador seleccionado es Series iQ-R/Q/L (fotograma 3E) o Series iQ-F (fotograma 3E), el tamaño máximo total de los mensajes es de 960 palabras. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, el tamaño máximo total del mensaje es de 64 palabras.
  • Cuando se ha seleccionado Serie iQ-R/Q/L (fotograma 3E) o Serie iQ-F (fotograma 3E) como tipo de controlador , la longitud máxima de los datos de salida es de 1920 bytes. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, la longitud máxima de los datos de salida es de 128 bytes. El tamaño de los datos de salida se muestra en el campoTamaño del mensaje (bytes).
  • El botón Restablecer tipos de datos restaura todos los tipos de datos con sus ajustes predeterminados.
  • La implementación de EasyBuilder del SLMP no es compatible con tipos de datos de 8 bits o sin firmar.

  5. Puede modificar el orden de los datos que se enviarán o recibirán seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado.


Configuración de la ficha Ajustes (SLMP Scanner)

La ficha Ajustes de SLMP Scanner permite definir los datos necesarios para establecer una conexión con el PLC/MC de Mitsubishi.

Closed Tipo de controlador

Define el tipo de PLC o MC de Mitsubishi con el que comunicarse: Series iQ-R/Q/L (fotograma 3E), Series iQ-F (fotograma 3E) o Serie FX (fotograma 1E). Valor predeterminado = Series iQ-R/Q/L (fotograma 3E).

Nota: La opción Series iQ-F (fotograma 3E) no está disponible en los sistemas de visión In-Sight que ejecuten firmware de la versión 4.x.x de In-Sight.
Closed Dirección IP

Define la dirección IP del PLC/MC de Mitsubishi. Introduzca la dirección IP del PLC/MC de Mitsubishi que se conectará al sistema de visión In-Sight.

Closed Puerto del host

Define el número de puerto TCP, en formato decimal (Dec) o hexadecimal (Hex), del PLC/MC de Mitsubishi (1 - 65535 en Dec, 1 – 0xFFFF en Hex; valor predeterminado = 12288 en Dec).

Notas:
  • Este valor debe coincidir con el ajuste de Puerto del host que se haya establecido en el Puerto SLMP del PLC/MC de Mitsubishi.
  • El formato del número de puerto del equipo se restablecerá a decimal (Dec) en el momento de cerrar In-Sight Explorer.
Closed Tiempo de espera (ms)

Define el tiempo de espera (de 5 a 30.000 milisegundos; el valor predeterminado es 1.000 ms) tanto para las operaciones de lectura como para las de escritura.

Nota: Este parámetro podría prolongar la duración de la tarea; si las operaciones de lectura y escritura fallasen, el tiempo añadido a la tarea sería el doble del valor indicado en Tiempo de espera, puesto que se sumarían los tiempos de espera de ambas operaciones.

Closed Intervalo de consulta (ms)

Define el tiempo (5 a 30.000 milisegundos; valor predeterminado = 1000 ms) entre consultas sucesivas del bloque Vision Control del PLC/MC de Mitsubishi.

Closed Conexión a estación remota
  • Cuando esta casilla de verificación está activada y el tipo de controlador seleccionado es Series iQ-R/Q/L (fotograma 3E) o Series iQ-F (fotograma 3E) los controles Número de red, Número de PC y Módulo de destino están activados.
  • Cuando esta casilla de verificación está activada y Serie FX (fotograma 1E) es el tipo de controlador seleccionado, el control Número de PC está activado.

De forma predeterminada, la casilla de verificación está desactivada y el sistema de visión In-Sight está directamente conectado al PLC/MC a través de un módulo Ethernet especificado por la dirección IP introducida.

Closed Número de red

Define el número de red del protocolo SLMP (entre 0 y 239; preajuste = 0 = red local) a utilizar para comunicarse. Este control se activa cuando se activa la casilla de verificación Conexión a estación remota.

Closed Número de PC (hex)

Define el identificador de estación en la red especificada del módulo de destino, en formato hexadecimal. Este control se activa cuando se activa la casilla de verificación Conexión a estación remota.

Hex | Descripción
0xFF (valor predeterminado) | Conexión directa a la estación local.
0x7E | Estación maestra en el campo CC-Link IE.
0x1 - 0x78 | Estación del adaptador de red del campo CC-Link IE.
Closed Módulo de destino

Define el identificador de módulo del dispositivo al que conectarse. Este control se activa cuando se activa la casilla de verificación Conexión a estación remota.

Tipo de módulo
03ff - Estación local (valor predeterminado)
0x3d0 - CPU del sistema de control
0x3d1 - CPU del sistema de standby
0x3d2 - CPU del sistema A
0x3d3 - CPU del sistema B
0x3e0 - CPU 1
0x3e1 - CPU 2
0x3e2 - CPU 3
0x3e3 - CPU 4
Closed Botón Restablecer

Restablece todos los ajustes predeterminados.

Closed Botón Comprobar conexión

Inicia la conexión con el PLC/MC de Mitsubishi para realizar pruebas.


Configuración de la ficha Direccionamiento de dispositivos (SLMP Scanner)

La ficha Direccionamiento de dispositivos de SLMP Scanner permite definir las direcciones del dispositivo PLC/MC y los tamaños de los diferentes bloques de datos que deben comunicarse al PLC/MC. El tipo de dispositivo y el tamaño de los bloques de datos pueden variar dependiendo del tipo de controlador (serie iQ-R/Q/L, serie iQ-F o serie FX) definido en la ficha Ajustes.

Closed Nombre

Nombre del bloque de datos que puede comunicarse desde o hacia el PLC/MC de Mitsubishi.

Closed Dispositivo seleccionado

Define el dispositivo PLC/MC de Mitsubishi que debe utilizarse para leer o escribir en el bloque de datos. La lista desplegable ofrece las siguientes opciones:

Tipo de dispositivo para la serie iQ-R/Q/L

Tipo de dispositivo | Formato
X - Relé de entrada* | Bit
Y - Relé de salida* | Bit
M - Relé interno* | Bit
L - Relé de cerrojo* | Bit
F - Anunciador* | Bit
B - Relé de vínculos* | Bit
D - Registro de datos | Palabra
W - Registro de vínculos | Palabra
R - Registro del bloque de archivos | Palabra
ZR - Registro de archivos | Palabra
*Admisible solo en los bloques de datos Control y Estado.

Tipo de dispositivo para la serie iQ-F

Tipo de dispositivo | Formato
X - Relé de entrada* | Bit
Y - Relé de salida* | Bit
M - Relé interno* | Bit
F - Anunciador* | Bit
D - Registro de datos | Palabra
*Admisible solo en los bloques de datos Control y Estado.

Tipo de dispositivo para la serie FX

Tipo de dispositivo | Formato
X - Relé de entrada* | Bit
Y - Relé de salida* | Bit
M - Relé interno* | Bit
D - Registro de datos | Palabra
R - Registro de extensión | Palabra
S - Relé de estado* | Bit
*Admisible solo en los bloques de datos Control y Estado.

Notas:
  • Si se selecciona Nada, no se comunicará el bloque de datos.
  • No se admiten los dispositivos Valor de tiempo ni Valor del contador.
Closed Desplazamiento

Define el desplazamiento dentro de la tabla de dispositivos que debe utilizarse para leer o escribir en el bloque de datos. El valor del desplazamiento debe indicarse en formato decimal, hexadecimal u octal, dependiendo del tipo de Dispositivo seleccionado.

Tipo de dispositivo para la serie iQ-R/Q/L

Tipo de dispositivo | Valor
X - Relé de entrada* | Hex
Y - Relé de salida* | Hex
M - Relé interno* | Decimal
L - Relé de cerrojo* | Decimal
F - Anunciador* | Decimal
B - Relé de vínculos* | Hex
D - Registro de datos | Decimal
W - Registro de vínculos | Hex
R - Registro del bloque de archivos | Decimal
ZR - Registro de archivos | Decimal
*Admisible solo en los bloques de datos Control y Estado.

Tipo de dispositivo para la serie iQ-F

Tipo de dispositivo | Valor
X - Relé de entrada* | Oct
Y - Relé de salida* | Oct
M - Relé interno* | Decimal
F - Anunciador* | Decimal
D - Registro de datos | Decimal
*Admisible solo en los bloques de datos Control y Estado.

Tipo de dispositivo para la serie FX

Tipo de dispositivo | Valor
X - Relé de entrada* | Oct
Y - Relé de salida* | Oct
M - Relé interno* | Decimal
D - Registro de datos | Decimal
R - Registro de extensión | Decimal
S - Relé de estado* | Decimal
*Admisible solo en los bloques de datos Control y Estado.

Closed Número de dispositivos

Define el tamaño del bloque de datos que se comunica con el PLC/MC de Mitsubishi. El tamaño se especifica en unidades de "dispositivos" PLC/MC (palabras o bits). El tamaño máximo de los datos para el bloque de entrada, el bloque de salida, el comando y los resultados del comando varía dependiendo del tipo de controlador seleccionado (serie iQ-R/Q/L, serie iQ-F o serie FX).

Nombre del bloque | Número de dispositivos
 | Serie iQ-R/Q/L y serie iQ-F | Serie FX
Control | 32 bits (solo lectura)
Estado | 32 bits (solo lectura)
Bloque de entrada | 4 + longitud de los datos de entrada (máximo: 960 palabras) | 4 + longitud de los datos de entrada (máximo: 64 palabras)
Bloque de salida | 12 + longitud de los datos de salida (máximo: 960 palabras) | 12 + longitud de los datos de salida (máximo: 64 palabras)
Comando | 0 - 960 palabras | 0 - 64 palabras
Resultado del comando | 0 - 960 palabras | 0 - 64 palabras

Nota: Las series iQ-R/Q/L y iQ-F reconocen la mayoría de los formatos de fotogramas de mensajes disponibles actualmente (fotograma 3E). Sin embargo, la serie FX solo reconoce la primera generación del fotograma de mensajes de protocolo (fotograma 1E), y la cantidad de datos que se pueden transmitir por paquete es limitada.

Tamaño máximo de los datos

Serie iQ-R/Q/L y serie iQ-F | Serie FX
Bits leídos del lote | 7904 bits | 256 bits
Palabras leídas del lote | 960 palabras | 64 palabras
Bits de escritura del lote | 7904 bits | 160 bits
Palabras escritas del lote | 690 palabras | 64 palabras
Closed Descripción

Descripción textual del bloque de datos.


Configuración de las fichas Formatear datos de salida y Formatear datos de entrada (SLMP Scanner)

Tras configurar las fichas Ajustes y Direccionamiento de dispositivos, deberá configurar las fichas Formatear datos de entrada y Formatear datos de salida, las cuales se utilizan para definir qué datos de tarea o herramienta se transferirán desde y hacia el PLC/MC de Mitsubishi y el sistema de visión In-Sight.

Closed Configuración de la ficha Formatear datos de entrada

La ficha Formatear datos de entrada se utiliza para definir las entradas en el sistema de visión In-Sight. Se puede definir un máximo de 32 entradas por tarea.

  1. Haga clic en la ficha Formatear datos de entrada para iniciar la configuración de los datos que se transferirán del PLC/MC al sistema de visión In-Sight.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de entrada, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición y Entradas. Seleccione los datos que desea que se transfieran desde el PLC/MC al sistema de visión In-Sight y pulse el botón Aceptar.
  3. Cuando haya añadido sus datos, éstos aparecerán en la tabla, mostrando la dirección de dispositivo, nombre de la entrada y su tipo, tamaño y valor de datos.
  4. Puede personalizar el tipo de datos predeterminados seleccionando un tipo diferente de datos en la lista desplegable Tipo de datos.

Notas:
  • Si selecciona Cadena o Cadena de intercambio de bytes en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras.
  • Cuando se ha seleccionado Serie iQ-R/Q/L (fotograma 3E) o Serie iQ-F (fotograma 3E) como tipo de controlador, el tamaño máximo total del mensaje es de 960 palabras. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, el tamaño máximo total del mensaje es de 64 palabras.
  • Cuando se ha seleccionado Serie iQ-R/Q/L (fotograma 3E) o Serie iQ-F (fotograma 3E) como tipo de controlador, la longitud máxima total de los datos de entrada es de 1920 bytes. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, la longitud máxima total de los datos de entrada es de 128 bytes. El tamaño de los datos de entrada se muestra en el campoTamaño del mensaje (bytes).
  • El botón Restablecer tipos de datos restaura todos los tipos de datos con sus ajustes predeterminados.
  • La implementación de EasyBuilder de SLMP Scanner no es compatible con tipos de datos de 8 bits.

  5. También puede personalizar el orden de bytes si especifica bytes bajos primero en lugar de bytes altos primero mediante la desactivación de la casilla de verificación Bytes altos/bytes bajos (está desactivada de forma predeterminada para todos los protocolos, excepto PROFINET). Puede personalizar el orden de relevancia de bytes si especifica bytes menos significativos primero en lugar de bytes más significativos primero mediante la desactivación de la casilla de verificación Bytes más significativos/bytes menos significativos (está desactivada de forma predeterminada).

    Nota: Cualquier cambio realizado en el orden de los bytes o en el de la relevancia de los bytes repercutirán en todas las señales de datos de las fichas Formatear datos de salida y Formatear datos de entrada.

  6. Puede modificar el orden de los datos que se enviarán o recibirán seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado.

Closed Configuración de la ficha Formatear datos de salida

La ficha Formatear datos de salida se utiliza para definir las salidas desde el sistema de visión In-Sight. Se pueden definir hasta 128 salidas por tarea.

  1. Haga clic en la ficha Formatear datos de salida para iniciar la configuración de los datos que se transferirán del sistema de visión In-Sight al PLC/MC.
  2. Pulse el botón Añadir para iniciar el cuadro de diálogo Seleccionar datos de salida, que contiene datos de la tarea, como cualquier herramienta de Ubicación o de Inspección agregada a su tarea, datos de adquisición o resultados totales de la tarea. Seleccione los datos que desea que se transfieran desde el PLC/MC al sistema de visión In-Sight y pulse el botón Aceptar.
  3. Una vez ha añadido los datos, estos aparecen en la tabla y permiten ver el nombre, el tipo, tamaño y valor de los datos, así como el número de registro inicial de los datos seleccionados. A la derecha de la tabla hay una ventana de vista previa de registros, que muestra cómo se formatean los datos en los registros de PLC/MC.
  4. Puede personalizar el tipo de datos predeterminados seleccionando un tipo diferente de datos en la lista desplegable Tipo de datos.

Notas:
  • Si selecciona Cadena o Cadena de intercambio de bytes en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (palabras) y puede especificar la longitud de la cadena mediante la selección del número correcto de palabras.
  • Cuando se ha seleccionado Serie iQ-R/Q/L (fotograma 3E) o Serie iQ-F (fotograma 3E) como tipo de controlador, el tamaño máximo total del mensaje es de 960 palabras. Cuando se ha seleccionado Serie FX (fotograma 1E) como tipo de controlador, el tamaño máximo total del mensaje es de 64 palabras.
  • Cuando se ha seleccionado Serie iQ-R/Q/L (fotograma 3E) o Serie iQ-F (fotograma 3E) como tipo de controlador, la longitud máxima total de los datos de salida es de 1920 bytes. Cuando Serie FX (fotograma 1E) es el tipo de controlador seleccionado, la longitud máxima total de los datos de salida es de 128 bytes. El tamaño de los datos de salida se muestra en el campoTamaño del mensaje (bytes).
  • El botón Restablecer tipos de datos restaura todos los tipos de datos con sus ajustes predeterminados.
  • La implementación de EasyBuilder de SLMP Scanner no es compatible con tipos de datos de 8 bits.

  5. También puede personalizar el orden de bytes si especifica bytes bajos primero en lugar de bytes altos primero mediante la desactivación de la casilla de verificación Bytes altos/bytes bajos (está desactivada de forma predeterminada para todos los protocolos, excepto PROFINET). Puede personalizar el orden de relevancia de bytes si especifica bytes menos significativos primero en lugar de bytes más significativos primero mediante la desactivación de la casilla de verificación Bytes más significativos/bytes menos significativos (está desactivada de forma predeterminada). Todos los cambios se actualizarán en la ventana de vista previa.
  6. Puede modificar el orden de los datos que se enviarán o recibirán seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado.


Configuración de las comunicaciones de robots con cadenas Ethernet nativas de Mitsubishi

Los datos procedentes de tareas de EasyBuilder, como los resultados de herramientas o de tareas individuales, se pueden comunicar con un controlador de robot. Una vez seleccionados los datos y formateados como cadena, el controlador del robot puede solicitarlos enviando un único comando del modo nativo de In-Sight, GetValue (GVJob.Robot.FormatString), que devuelve todos los datos formateados en la cadena.

Para formatear sus datos como cadena para las comunicaciones en modo nativo:

Nota: Para poder habilitar estos controles, el sistema de visión In-Sight debe estar sin conexión.

  1. Presione el botón Agregar para abrir el cuadro de diálogo Seleccionar datos de salida, que contiene los datos de cualesquiera herramientas de ubicación o de inspección que haya añadido a su tarea, así como datos adicionales de la tarea, como los de adquisición y los datos de entrada.
  2. En el cuadro de diálogo Seleccionar datos de salida, seleccione los datos que desee que se envíen desde el sistema de visión In-Sight y presione el botón Aceptar. Se pueden seleccionar hasta 40 elementos de datos para una cadena.
  3. Una vez agregados los datos, el orden de envío de éstos puede modificarse seleccionando un elemento en la lista y haciendo clic en los botones Subir y Bajar para definir el orden deseado. También se pueden eliminar elementos no deseados utilizando el botón Quitar.
  4. Si alguno de los elementos de datos corresponde al tipo Coma flotante, se activará el control Decimales, que permite definir el número de decimales para los valores de coma flotante (0-6; predeterminado = 3).
  5. En la ventana situada a la derecha de la lista de datos se muestra la cadena formateada, así como la longitud de la cadena (número de caracteres que contiene), como referencia. Se inserta automáticamente una coma para delimitar los valores dentro de la cadena.
  6. Una vez formateada la cadena, el controlador del robot puede solicitar la cadena de datos enviando un único comando del modo nativo de In-Sight, GetValue (GVJob.Robot.FormatString).


Configuración de las comunicaciones de robots con cadenas serie nativas de Mitsubishi

Los datos procedentes de tareas de EasyBuilder, como los resultados de herramientas o de tareas individuales, se pueden comunicar con un controlador de robot. Una vez seleccionados los datos y formateados como cadena, el controlador del robot puede solicitarlos enviando un único comando del modo nativo de In-Sight, GetValue (GVJob.Robot.FormatString), que devuelve todos los datos formateados en la cadena.

Para formatear sus datos como cadena para las comunicaciones en modo nativo:

Nota: Para poder habilitar estos controles, el sistema de visión In-Sight debe estar sin conexión.

  1. Presione el botón Agregar para abrir el cuadro de diálogo Seleccionar datos de salida, que contiene los datos de cualesquiera herramientas de ubicación o de inspección que haya añadido a su tarea, así como datos adicionales de la tarea, como los de adquisición y los datos de entrada.
  2. En el cuadro de diálogo Seleccionar datos de salida, seleccione los datos que desee que se envíen desde el sistema de visión In-Sight y presione el botón Aceptar. Se pueden seleccionar hasta 40 elementos de datos para una cadena.
  3. Una vez agregados los datos, el orden de envío de éstos puede modificarse seleccionando un elemento en la lista y haciendo clic en los botones Subir y Bajar para definir el orden deseado. También se pueden eliminar elementos no deseados utilizando el botón Quitar.
  4. Si alguno de los elementos de datos corresponde al tipo Coma flotante, se activará el control Decimales, que permite definir el número de decimales para los valores de coma flotante (0-6; predeterminado = 3).
  5. En la ventana situada a la derecha de la lista de datos se muestra la cadena formateada, así como la longitud de la cadena (número de caracteres que contiene), como referencia. Se inserta automáticamente una coma para delimitar los valores dentro de la cadena.
  6. Una vez formateada la cadena, el controlador del robot puede solicitar la cadena de datos enviando un único comando del modo nativo de In-Sight, GetValue (GVJob.Robot.FormatString).
  7. Si fuese necesario, haga clic en la ficha Opciones de puerto serie para definir los ajustes de comunicaciones serie. EasyBuilder determinará automáticamente el protocolo del modo serie basándose en las selecciones de Configuración de dispositivo. Los ajustes del puerto serie se guardan en el sistema de visión In-Sight al salir del paso Comunicación.
Notas:

  • Las opciones de puerto serie varían según el modelo de In-Sight y el módulo de E/S aplicable; si está conectado a un módulo de E/S compatible, pulse primero el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S y configure el módulo de E/S.

  • Los sistemas de visión In-Sight Micro de la serie 1000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO o CIO-MICRO-CC.

  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Los sistemas de visión In-Sight de la serie 8000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO.

  • El módulo de E/S CIO-WENET no permite la comunicación serie.


Comunicación a través de TCP/IP

Los sensores In-Sight se pueden configurar para actuar como dispositivos cliente TCP/IP, abriendo una conexión entre el sensor In-Sight y otro dispositivo TCP/IP para compartir datos a través de la red. Una vez establecida la conexión TCP/IP, EasyBuilder iniciará la comunicación con otro dispositivo TCP/IP existente en la red.

Para configurar un sensor In-Sight para dar servicio a un dispositivo cliente TCP/IP:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione Otro en la lista desplegable Dispositivo.
  3. Seleccione TCP/IP en la lista desplegable Protocolo.
  4. Pulse el botón Aceptar.
  5. Haga clic en la ficha Ajustes TCP/IP y en el campo Nombre de equipo del servidor introduzca el nombre del dispositivo de servicio TCP/IP al cual desea conectarse.
  6. En el campo Puerto, introduzca el número de puerto del servidor TCP/IP en el que se establecerá la conexión entre los dispositivos TCP/IP. El número de puerto introducido también se debe asignar en el servidor.

Nota: una asignación de puerto válida es cualquier número no utilizado entre 1 y 65535, salvo los puertos utilizados para las comunicaciones de In-Sight. Para prevenir posibles conflictos con los puertos reservados para servicios del PC, los usuarios de emuladores In-Sight deben asignar siempre números de puerto del 3000 (predeterminado) en adelante.

  7. Introduzca en el campo Tiempo de espera el número de milisegundos (100 a 15000; preajuste = 1000) que el sistema debe esperar a que se establezca la conexión TCP/IP antes de cancelar el intento de conexión.
  8. En la lista desplegable Terminador, seleccione una cadena con terminador personalizado para especificar un carácter ASCII (0 a 255).
Closed Descripciones de terminadores personalizados de cadenas
Terminador | Descripción
Cadena CR+LF (predeterminado) | Se añadirán a la cadena de datos los caracteres ASCII 13 (retorno de carro) y 10 (alimentación de línea).
Cadena CR (13) | Se añadirá a la cadena de datos el carácter ASCII 13 (retorno de carro).
Cadena LF (10) | Se añadirá a la cadena de datos el carácter ASCII 10 (alimentación de línea).
Cadena Nullchar (0) | Se añadirá a la cadena de datos el carácter ASCII 0 (carácter nulo).
  9. Una vez establecidos los ajustes TCP/IP, haga clic en la ficha Formatear cadena de salida para seleccionar y formatear los datos a transmitir.
Nota: El protocolo TCP/IP es un protocolo "secundario" y puede añadirse a una tarea además de un protocolo "primario". Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.


Comunicación a través de UDP

Un sistema de visión In-Sight se puede configurar para actuar como un servidor UDP o un dispositivo cliente estableciendo una conexión entre el sistema de visión In-Sight y otro dispositivo UDP para compartir datos a través de la red.

El Protocolo de Datagramas de Usuario (UDP), una alternativa al protocolo TCP, es un método de transporte y de comunicación sin conexión que ofrece una cantidad limitada de servicio cuando se intercambian mensajes mediante el protocolo de Internet. A diferencia del protocolo TCP, UDP no admite ni garantiza el envío, y tampoco proporciona paquetes de secuencias.

Para configurar un sistema de visión como cliente o dispositivo servidor para el servicio UDP:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione Otro en la lista desplegable Dispositivo.
  3. Seleccione UDP en la lista desplegable Protocolo.
  4. Pulse el botón Aceptar.
  5. Ahora deberá configurar la ficha Ajustes de UDP y seleccionar una cadena de entrada (si es necesario) y una cadena de salida (si es necesario).
Closed Ficha Ajustes de UPD
Closed Modo

Define si el sistema de visión se configurará como cliente o como servidor (cliente, cliente con respuesta, servidor o servidor con respuesta; valor predeterminado = cliente). En el paradigma de comunicación UPD, un cliente es un sistema que accede a un servicio remoto desde otro sistema (o servidor) informático a través de una red, y un servidor es un dispositivo conectado que gestiona solicitudes de datos desde otros dispositivos conectados.

  • Cliente: El sistema de visión transmite datos al servidor seleccionado.
  • Cliente con respuesta: El sistema de visión transmite datos al servidor seleccionado y, más tarde, espera en función del límite de tiempo especificado en el parámetro Tiempo de espera a un mensaje de respuesta del servidor.
  • Servidor: El sistema de visión transmite datos como el servidor seleccionado.
  • Servidor con respuesta: El sistema de visión recibe datos como el servidor seleccionado y, más tarde, envía un mensaje de respuesta de vuelta al dispositivo cliente.
Closed Nombre de equipo del servidor

Define el nombre de equipo o la dirección IP del servidor UDP. Si el parámetro Modo está definido como Servidor o Servidor con respuesta, este parámetro se deshabilitará.

Closed Puerto

Define el número de puerto de comunicación entre el servidor UDP y el dispositivo UDP. Si el sistemas de visión In-Sight está configurado como un Servidor y se ha introducido un Nombre de equipo del servidor, el parámetro Puerto asigna el número de puerto al dispositivo. Si el sistema de visión está configurado como Cliente, el número de puerto debe ser el mismo que el del servidor UDP.

Closed Tiempo de espera

Define el período de tiempo (de 100 a 15.000; valor predeterminado = 1000), en milisegundos, necesario para recibir una respuesta del dispositivo servidor cuando se envía un mensaje desde el dispositivo cliente.

Nota: El parámetro Tiempo de espera solo se habilita cuando el parámetro Modo se fija como Cliente con respuesta.

Closed Ficha Cadena de entrada

La ficha Cadena de entrada le permite definir una cadena que es una entrada desde otro dispositivo a una cadena de entrada de la herramienta EasyBuilder, como por ejemplo el parámetro Cadena coincidente de la herramienta de identificación Leer códigos de ID, Leer código 1D, Leer códigos 1D (1-20), Leer código 2D, Leer códigos 2D (1-20), Leer código postal o Leer texto, en el paso Inspeccionar pieza.

Nota: La ficha Cadena de entrada está deshabilitada si el parámetro Modo está fijado como Cliente.

Closed Nombre de entrada

Desde el menú desplegable, seleccione la tarea o la propiedad de herramienta de Easybuilder que se establecerá como entrada.

Nota: Para introducir una cadena de texto desde un dispositivo externo, como un PLC o un PC, con el fin de utilizarla con una herramienta de identificación, consulte el tema: Introducción de datos para las herramientas de identificación.

Closed Formatear cadena de salida

La ficha Formatear cadena de salida le permite definir los datos que se envían al servidor UDP cuando el parámetro Modo está configurado como Cliente, Cliente con respuesta o Servidor con respuesta.

Nota: La ficha Formatear cadena de salida está deshabilitada si el parámetro Modo está fijado como Servidor.

Closed Formatear cadena
  1. Desde la ficha Formatear cadena de salida, haga clic en el botón Formatear cadena para abrir el cuadro de diálogo Cadena de formato, que permite añadir, personalizar y modificar el orden de los datos enviados.
  2. En el cuadro de diálogo Cadena de formato, presione el botón Agregar para abrir el cuadro de diálogo Seleccionar datos de salida.
  3. Los cuadros de diálogo Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección incluida en su tarea, así como los resultados totales de ésta. En el cuadro de diálogo, seleccione los datos que desee enviar desde el sensor In-Sight y presione el botón Aceptar.
  4. Una vez seleccionados sus datos en el cuadro de diálogo Seleccionar datos de salida, volverá a aparecer el cuadro de diálogo FormatString.
  5. Puede modificar las cadenas y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.
  6. Ahora que la cadena está formateada, los datos de salida se enviarán tan pronto como el sensor termine de ejecutar la tarea.
Nota: El protocolo UDP es un protocolo "secundario" y puede añadirse a una tarea además de un protocolo "primario". Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.


Comunicación a través de POWERLINK

Nota: Este protocolo solo está disponible en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no está disponible en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

Los sistemas de visión In-Sight se pueden configurar de manera que se comuniquen con la red POWERLINK.

Para comunicar a través de POWERLINK, primero realice lo siguiente:

  1. Vaya al paso de aplicación Comunicación. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC en la lista desplegable Dispositivo.
  3. Seleccione B&R en la lista desplegable Fabricante.
  4. Seleccione POWERLINK en la lista desplegable Protocolo.
  5. Pulse el botón Aceptar.

Una vez habilitados estos ajustes, pueden configurarse las fichas Ajustes y Formatear entrada/salida.

  • Closed Ficha Ajustes de POWERLINK

    Habilitado: Habilita POWERLINK en el sistema de visión In-Sight (valor predeterminado = desactivado).

    ID de nodo: Define el Id. de nodo (1-239; valor predeterminado = 1) para el sistema de visión In-Sight en la red POWERLINK. Este control se habilita cuando se ha activado la casilla de verificación Habilitado. El Id. de nodo junto con la dirección IP NAT de la red POWERLINK puede utilizarse para la comunicación con otros dispositivos externos a la red POWERLINK. Por ejemplo, la dirección IP NAT es 192.168.101.0. Para comunicarse con un sistema de visión In-Sight con un Id. de nodo 26, combine la dirección IP NAT con el Id. de nodo: 192.168.101.26.

    Nota: Se debe reiniciar el sistema In-Sight para habilitar el protocolo POWERLINK.

  • Ficha Formatear entrada/salida
Notas:
  • Para obtener más información sobre la configuración de POWERLINK en un sistema de visión, consulte los temas de POWERLINK en la ayuda de In-Sight Explorer.
  • Opcionalmente, vuelva a hacer clic en el botón Agregar dispositivo para añadir un protocolo "secundario" adicional a la tarea. Para más información, consulte la sección Protocolos admitidos en Configuración de dispositivo.


Introducción de datos para las herramientas de identificación

Para introducir una cadena de texto desde un dispositivo externo, como un PLC o un PC, con el fin de utilizarla con una herramienta de identificación, siga estos pasos:

  1. Añada una herramienta de identificación Leer códigos de ID, Leer código 1D, Leer códigos 1D (1-20), Leer código 2D, Leer códigos 2D (1-20), Leer código postal o Leer texto en el paso Inspeccionar pieza.
  2. En la ficha Ajustes de las herramientas Leer códigos de ID, Leer código 1D, Leer códigos 1D (1-20), Leer código 2D, Leer códigos 2D (1-20) o Leer código postal, establezca el Modo en Cadena coincidente; para la herramienta Leer texto, establezca el Modo en Verificar o Leer y verificar.
  3. Seleccione el paso de aplicación Comunicación.
  4. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  5. En el cuadro de grupo Configuración de dispositivo, seleccione Otro en la lista desplegable Dispositivo.
  6. Seleccione Texto serie en la lista desplegable Protocolo.
  7. Pulse el botón Aceptar.
  8. Haga clic en la ficha Cadena de entrada.
  9. En la lista desplegable Nombre de entrada, seleccione la entrada Cadena coincidente de la herramienta deseada. EasyBuilder examinará automáticamente su tarea e incluirá todas las entradas de Cadena coincidente de las herramientas definidas en la tarea.
  10. Haga clic en la ficha Opciones de puerto serie y defina los ajustes para su aplicación, si fuese necesario.
Notas:

  • Las opciones de puerto serie varían según el modelo de In-Sight y el módulo de E/S aplicable; si está conectado a un módulo de E/S compatible, pulse primero el botón Módulo de E/S para abrir el cuadro de diálogo Configuración del módulo de E/S y configure el módulo de E/S.

  • Los sistemas de visión In-Sight Micro de la serie 1000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO o CIO-MICRO-CC.

  • Hay dos opciones para habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx: usar el cable de conexión o usar el módulo E/S CIO-MICRO o CIO-MICRO-CC. Si se conecta el cable de conexión (y no existe ninguna otra conexión con el módulo E/S), el sistema de visión permite una línea de entrada discreta y una línea de salida discreta para que se configure como Recepción serie y Transmisión serie, respectivamente. Para más información, consulte Cómo habilitar la comunicación serie para el sistema de visión In-Sight de las series 70xx - 74xx.
  • Los sistemas de visión In-Sight de la serie 8000 solo admiten la comunicación serie si están conectados al módulo de E/S CIO-MICRO.

  • El módulo de E/S CIO-WENET no permite la comunicación serie.
  11. Haga clic en la ficha Formatear cadena de salida y presione Cadena de formato para abrir el cuadro de diálogo Cadena de formato, que permite seleccionar y formatear los resultados de la herramienta.

Nota: La opción Leer códigos de ID o Leer texto tendrá como resultado un rechazo y el campo Cadena coincidente mostrará TRIG hasta que la cadena coincidente se reciba desde el dispositivo externo.

  12. En el cuadro de diálogo FormatString, presione el botón Agregar para abrir el cuadro de diálogo Seleccionar datos de salida.
  13. Los cuadros de diálogo Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección incluida en su tarea, así como los resultados totales de ésta. En el cuadro de diálogo, seleccione los datos que desee enviar desde el sensor In-Sight y presione el botón Aceptar.
  14. Una vez seleccionados sus datos en el cuadro de diálogo Seleccionar datos de salida, volverá a aparecer el cuadro de diálogo FormatString.
  15. Puede modificar las cadenas y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.
  16. Ahora que la cadena está formateada, los datos de salida se enviarán tan pronto como el sensor termine de ejecutar la tarea.
  17. Una vez el sensor In-Sight esté en línea, la herramienta recibirá la cadena de entrada e intentará leer y/o verificarla en la imagen.


Formateo de cadenas de salida

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, de la lista desplegable Dispositivo, seleccione Otro.
  3. En la lista desplegable Protocolo, seleccione Ethernet nativo, Serie nativo, Texto serie o TCP/IP.
  4. En la ficha Formatear cadena de salida, haga clic en el botón Cadena de formato para abrir el cuadro de diálogo FormatString, en el que podrá agregar, personalizar y modificar el orden de los datos enviados.
  5. En el cuadro de diálogo FormatString, presione el botón Agregar para abrir el cuadro de diálogo Seleccionar datos de salida.
  6. Los cuadros de diálogo Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección incluida en su tarea y los resultados totales de la tarea. En el cuadro de diálogo, seleccione los datos que desee enviar desde el sensor In-Sight y presione el botón Aceptar.
  7. Una vez seleccionados sus datos en el cuadro de diálogo Seleccionar datos de salida, volverá a aparecer el cuadro de diálogo FormatString.
  8. Puede modificar las cadenas y/o cambiar el orden de los datos a enviar seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden deseado. Cuando haya terminado de modificar las cadenas, presione el botón Aceptar.
  9. Ahora que la cadena está formateada, los datos de salida se enviarán tan pronto como el sensor termine de ejecutar la tarea.


Comunicaciones con PLC de Rockwell ControlLogix

Esta sección describe cómo transferir datos entre un sistema de visión In-Sight y un PLC ControlLogix o CompactLogix por una red EtherNet/IP usando el software Rockwell RSLogix 5000.

Paso 1: Configuración del sistema de visión In-Sight en la estructura de E/S de RSLogix

Paso 2: Configuración de Configuración del sistema de visión In-Sight para comunicaciones con PLC


Configuración del sistema de visión In-Sight en la estructura de E/S de RSLogix

Integración con RSLogix 5000

Los pasos para configurar una conexión implícita y transferir datos depende de la versión del firmware instalada en el sensor de visión y de la versión del software RSLogix 5000.

Encontrará más detalles en el tema Comunicaciones con PLC de Rockwell ControlLogix.


Integración de sistemas de visión In-Sight en RSLogix 5000 v14-16

Este tema trata la integración de sistemas de visión In-Sight que ejecuten In-Sight 5.2.0 o posterior en RSLogix 5000, versión 14-16. Estas versiones de RSLogix 5000 no admiten los archivos EDS y tiene que usar en su lugar un MÓDULO ETHERNET genérico. In-Sight Explorer incluye archivos .L5X, que pueden usarse para copiar los datos de etiquetas del controlador PLC a o de etiquetas de programa fáciles de usar; representan señales del sensor de visión que ejecuta firmware de In-Sight de la versión 5.2.x o posteriores.

  1. Abra RSLogix 5000 y cargue el proyecto del PLC.

    Nota: El PLC debe estar sin conexión para añadir conexiones en RSLogix 5000.

  2. Añada una conexión a la tarjeta de comunicaciones Ethernet. Debajo del nodo Configuración de E/S, seleccione el nodo Ethernet que hay en el módulo Ethernet, haga clic con el botón derecho del ratón en el icono y seleccione Nuevo módulo del menú.

  3. En el cuadro de diálogo Seleccionar módulo, en la ficha Catálogo, seleccione Comunicación como filtro de categoría del tipo de módulo, Allen-Bradley como filtro de proveedor del tipo de módulo, seleccione MÓDULO ETHERNET (módulo Ethernet genérico) y pulse el botón Crear.

  4. En el cuadro de diálogo Nuevo módulo, introduzca lo siguiente:

    • El nombre y la dirección IP del sensor de visión In-Sight.
    • Los parámetros de conexión. En el caso de los sensores de visión In-Sight que ejecutan firmware de la versión 5.x.x, el apartado Objetos del ensamblador de entrada/salida define la instancia del ensamblador que debe configurarse.

  5. Después de añadir el sensor de visión al proyecto de RSLogix, puede usar el archivo de importación de peldaños L5X para crear datos estructurados para la conexión. Puede acceder a la rutina principal desde Tareas > Tarea principal > Programa principal del panel Organizador del controlador.

    Nota: Si se trata de un programa de escalera nuevo, se puede usar el peldaño vacío 0. Si el sensor de visión se va a integrar en un programa existente, Cognex recomienda añadir un peldaño en la parte superior de la escalera para asegurarse de que los datos actualizados se lean y escriban en los ensamblados de entrada y salida del sensor antes de que se ejecute el resto de la escalera.

    1. En el programa principal, haga clic con el botón derecho del ratón en un peldaño vacío y seleccione la opción Importar peldaños...

    2. Vaya al archivo .L5X; los archivos se encuentran en la siguiente ubicación: C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      Importe el archivo InSightGenEth_11_CopyRung.L5X. Una vez que haya seleccionado el archivo, pulse el botón Importar...

  6. A continuación, se usará el cuadro de diálogo Importar configuración para cambiar los nombres de las etiquetas creadas para que coincidan con la configuración. El módulo genérico creará una única matriz de datos sin procesar ni estructurar para las entradas y las salidas del módulo. El ensamblado de entrada será una matriz contigua que consta del bloque de estado y de la matriz de resultados de inspección. El ensamblado de salida será una matriz contigua que consta del bloque de control y de la matriz de datos de usuario. Ambos carecen de etiquetas de identificación.

    Después de que el proyecto se haya descargado al PLC y se haya ejecutado por primera vez el peldaño con las instrucciones de copia, se crearán dos matrices nuevas que contienen las etiquetas.

    1. Los nombres genéricos de las etiquetas tendrán que modificarse. Las dos líneas superiores tendrán una X junto a ellas y tendrá que modificarse el nombre de cada una.

    2. Al hacer clic en el espacio en blanco del campo Nombre, aparecerá una flecha que proporcionará un menú desplegable con opciones de sustitución de la estructura de nombre predeterminada. La lista contendrá nombres que coinciden con el nombre indicado en el Paso 4 (el nombre del sensor de visión In-Sight; en este ejemplo, el nombre proporcionado era In-Sight 2000, de modo que la lista contiene In-Sight 2000:I e In-Sight 2000:O).

      Sustituya los dos nombres genéricos por las opciones del menú desplegable.

    3. También tendrán que editarse las dos líneas inferiores. Haga clic en el texto del nombre para que aparezca el icono del cursor y, a continuación, sustituya el texto anterior a "_In" y _Out" por el nombre del módulo genérico o por otro nombre fácil de identificar (p. ej., "In-Sight 2000" en este ejemplo, ya que solo hay un sensor de visión).

      Nota: El nombre indicado en esta instancia debe ser único para cada sensor de visión que se añada a la configuración de E/S. Si se van a implementar varios sensores de visión, tiene que seguir estos pasos para cada sensor de visión, ya que cada instancia de los peldaños de copia que se crea señalará a un sensor de visión específico. Por lo tanto, teniendo en mente la solución de problemas posteriores, procure que los nombres utilizados puedan identificarse fácilmente.

    4. Cuando haya actualizado todos los valores predeterminados de las etiquetas, pulse el botón Aceptar.

  7. Se habrá añadido un peldaño nuevo a la rutina principal, debajo del peldaño que se había añadido (el peldaño vacío puede eliminarse).

  8. Ahora puede descargarse el proyecto al PLC y el PLC puede ponerse en modo de ejecución.

  9. Una vez ejecutados los peldaños que contienen las instrucciones de copia, se crearán las etiquetas nuevas en la tabla de etiquetas del controlador.

    En este ejemplo, In-Sight 2000:I e In-Sight 2000:O son los ensamblados de entrada y salida sin procesar procedentes del sistema de visión, y In-Sight 2000_In e In-Sight 2000_Out contendrán los bloques de control y de estado, así como las matrices Datos de usuario y Resultados de inspección.


Integración de sistemas de visión In-Sight en RSLogix 5000 v17-19

Este tema trata la integración de sistemas de visión In-Sight que ejecuten In-Sight 5.2.0 o posterior en RSLogix 5000, versión 17-19. Estas versiones de RSLogix 5000 no admiten los archivos EDS y tiene que usar en su lugar un MÓDULO ETHERNET genérico. In-Sight Explorer incluye archivos .L5X, que pueden usarse para copiar los datos de etiquetas del controlador PLC a o de etiquetas de programa fáciles de usar; representan señales del sensor de visión que ejecuta firmware de In-Sight de la versión 5.2.x o posteriores.

  1. Abra RSLogix 5000 y cargue el proyecto del PLC.

    Nota: El PLC debe estar sin conexión para añadir conexiones en RSLogix 5000.

  2. Añada una conexión a la tarjeta de comunicaciones Ethernet. Debajo del nodo Configuración de E/S, seleccione el nodo Ethernet que hay en el módulo Ethernet, haga clic con el botón derecho del ratón en el icono y seleccione Nuevo módulo del menú.

  3. En el cuadro de diálogo Seleccionar módulo, en la ficha Catálogo, seleccione Comunicación como filtro de categoría del tipo de módulo, Allen-Bradley como filtro de proveedor del tipo de módulo, seleccione MÓDULO ETHERNET (módulo Ethernet genérico) y pulse el botón Crear.

  4. En el cuadro de diálogo Nuevo módulo, introduzca lo siguiente:

    • El nombre y la dirección IP del sensor de visión In-Sight.
    • Los parámetros de conexión. En el caso de los sensores de visión In-Sight que ejecutan firmware de la versión 5.x.x, el apartado Objetos del ensamblador de entrada/salida define la instancia del ensamblador que debe configurarse.

  5. Después de añadir el sensor de visión al proyecto de RSLogix, puede usar el archivo de importación de peldaños L5X para crear datos estructurados para la conexión. Puede acceder a la rutina principal desde Tareas > Tarea principal > Programa principal del panel Organizador del controlador.

    Nota: Si se trata de un programa de escalera nuevo, se puede usar el peldaño vacío 0. Si el sensor de visión se va a integrar en un programa existente, Cognex recomienda añadir un peldaño en la parte superior de la escalera para asegurarse de que los datos actualizados se lean y escriban en los ensamblados de entrada y salida del sensor antes de que se ejecute el resto de la escalera.

    1. En el programa principal, haga clic con el botón derecho del ratón en un peldaño vacío y seleccione la opción Importar peldaños...

    2. Vaya al archivo .L5X; los archivos se encuentran en la siguiente ubicación: C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      Importe el archivo InSightGenEth_11_CopyRung.L5X. Una vez que haya seleccionado el archivo, pulse el botón Importar...

  6. A continuación, se usará el cuadro de diálogo Importar configuración para cambiar los nombres de las etiquetas creadas para que coincidan con la configuración. El módulo genérico creará una única matriz de datos sin procesar ni estructurar para las entradas y las salidas del módulo. El ensamblado de entrada será una matriz contigua que consta del bloque de estado y de la matriz de resultados de inspección. El ensamblado de salida será una matriz contigua que consta del bloque de control y de la matriz de datos de usuario. Ambos carecen de etiquetas de identificación.

    Después de que el proyecto se haya descargado al PLC y se haya ejecutado por primera vez el peldaño con las instrucciones de copia, se crearán dos matrices nuevas que contienen las etiquetas.

    1. Los nombres genéricos de las etiquetas tendrán que modificarse. Las dos líneas superiores tendrán una X junto a ellas y tendrá que modificarse el nombre de cada una.

      Al hacer clic en el espacio en blanco del campo Nombre, aparecerá una flecha que proporcionará un menú desplegable con opciones de sustitución de la estructura de nombre predeterminada. La lista contendrá nombres que coinciden con el nombre indicado en el Paso 4 (el nombre del sensor de visión In-Sight; en este ejemplo, el nombre proporcionado era In-Sight 2000, de modo que la lista contiene In-Sight 2000:I e In-Sight 2000:O).

      Sustituya los dos nombres genéricos por las opciones del menú desplegable.

    2. También tendrán que editarse las dos líneas inferiores. Haga clic en el texto del nombre para que aparezca el icono del cursor y, a continuación, sustituya el texto anterior a "_In" y _Out" por el nombre del módulo genérico o por otro nombre fácil de identificar (p. ej., "In-Sight 2000" en este ejemplo, ya que solo hay un sensor de visión).

      3. Nota: El nombre indicado en esta instancia debe ser único para cada sensor de visión que se añada a la configuración de E/S. Si se van a implementar varios sensores de visión, tiene que seguir estos pasos para cada sensor de visión, ya que cada instancia de los peldaños de copia que se crea señalará a un sensor de visión específico. Por lo tanto, teniendo en mente la solución de problemas posteriores, procure que los nombres utilizados puedan identificarse fácilmente.

    3. Una vez cambiados todos los nombres de etiquetas predeterminados, hay que especificar dónde se crearán las etiquetas. Para poner las etiquetas en la tabla de etiquetas de controlador, haga clic con el botón derecho en el cuadro vacío (resaltado a continuación) y seleccione Toggle Tag Scope (Alternar ámbito de etiqueta).

    4. Cuando haya actualizado todos los valores predeterminados de las etiquetas, pulse el botón Aceptar.

  7. Se habrá añadido un peldaño nuevo a la rutina principal, debajo del peldaño que se había añadido (el peldaño vacío puede eliminarse).

  8. Ahora puede descargarse el proyecto al PLC y el PLC puede ponerse en modo de ejecución.

  9. Una vez ejecutados los peldaños que contienen las instrucciones de copia, se crearán las etiquetas nuevas en la tabla de etiquetas del controlador.

    En este ejemplo, In-Sight 2000:I e In-Sight 2000:O son los ensamblados de entrada y salida sin procesar procedentes del sistema de visión, y In-Sight 2000_In e In-Sight 2000_Out contendrán los bloques de control y de estado, así como las matrices Datos de usuario y Resultados de inspección.


Integración de sistemas de visión In-Sight en RSLogix 5000 v20

Este tema trata la integración de sistemas de visión In-Sight que ejecuten In-Sight 5.2.0 o posterior en RSLogix 5000, versión 20 o superior. Estas versiones de RSLogix 5000 admiten archivos EDS. In-Sight Explorer incluye archivos .L5X, que colocan datos en etiquetas de programa fáciles de usar, las cuales representan señales en el sensor de visión que ejecuta un firmware de In-Sight 5.2.x o posterior. Se utilizará el archivo InSight_11_CopyRung.L5X para sensores que ejecuten el firmware 5.X.

  1. Crear y añadir un módulo EDS en RSlogix5000

    1. Los archivos EDS se instalan con el software Insight Explorer en la siguiente ubicación: C:\Archivos de programa (x86)\Cognex\In-Sight\In-Sight Explorer 5.2.3\Factory Protocol Description\EDS
    2. En el menú desplegable Herramientas de RSLogix5000, ejecute la herramienta de instalación de EDS para instalar el archivo EDS para In-Sight 2000.
    3. En la sección I/O Configuration de RSLogix5000, haga clic con el botón derecho sobre el nodo de red y seleccione New Module en el menú.

    4. En el cuadro de diálogo Select Module (Seleccionar módulo), abra el nodo de comunicaciones, seleccione In-Sight 2000-xxx en la lista y pulse OK.

      El cuadro de diálogo será sustituido por otro diálogo de configuración New Module.

      Introduzca el nombre del sensor de visión, su dirección IP y parámetros de conexión como se indica anteriormente. Si hay varios sensores de visión, cada uno debería tener su propio nombre. En este ejemplo, solo hay un sensor de visión que configurar.

      Sugerencia: Consulte los archivos de ayuda de In-Sight Explorer para el Modelo de objetos EtherNet/IP (bits de ensamblado de entrada y salida) que correspondan a la versión de firmware que ejecute el sensor de visión.

  2. Importar peldaño

    1. Acceda a la rutina principal que podrá encontrar en la carpeta Tasks > Main Task > Main Program del panel Controller Organizer (Organizador de controlador). Si este es un programa nuevo de escalera, puede utilizarse el peldaño cerdo vacío. Si el sensor de visión se va a integrar en un programa existente, se recomienda añadir un peldaño en lo alto de la escalera para asegurarse de que los datos actualizados se lean y escriban en los ensamblados de entrada y salida del sensor antes que en el resto de la escalera en ejecución.

    2. Cuando haya un peldaño vacío en lo alto del programa de escalera, haga clic con el botón derecho sobre dicho peldaño y seleccione Import Rung (Importar peldaño) en el menú.

    3. Use el cuadro de diálogo Import Rung para buscar la ubicación de la carpeta que contiene este documento y los dos archivos de peldaño para importar. Dado que Insight 2000 usa un firmware 5.X, se empleará el archivo InSight_11_CopyRung.L5X.

    4. Una vez seleccionado el archivo pertinente, haga clic en el botón Import.

    5. Aparecerá el cuadro de diálogo Import Configuration (Importar configuración) con los nombres genéricos que usar para la generación de etiquetas.

  3. Renombrar etiquetas: El módulo genérico creará una matriz simple de datos sin procesar no estructurados para la entrada, tanto la que va al módulo como la que procede de él. En este ejemplo, el módulo genérico ha creado In-Sight 2000:I, In-Sight 2000:0 e In-Sight 2000:C (que no se usa). El ensamblado de entrada será una matriz contigua compuesta por el bloque de estado y la matriz de resultados de inspección; y el ensamblado de salida será una matriz contigua compuesta por el bloque de control y la matriz de datos de usuario. Una vez que se descargue el proyecto en el PLC y se ejecute por primera vez el peldaño con las instrucciones de copia, se crearán dos matrices nuevas que contendrán las etiquetas (e idénticas a estas verá si hay disponible un módulo de perfil de complemento ["Add-On Profile"]).

    1. Habrá que editar las dos líneas del final con un indicador a su izquierda, para ello haga clic en el espacio blanco del campo Name (Nombre). Estas etiquetas contienen los datos sin procesar no estructurados de los ensamblados de E/S en In-Sight. Tras hacer clic en el espacio, aparecerá una flecha abajo.

    2. Al hacer clic en la flecha, se mostrará un menú desplegable con opciones de sustitución para el nombre predeterminado. En dicha lista, estarán los nombres que coincidan con el nombre del módulo genérico. En este ejemplo, el módulo genérico se llamaba In-Sight 2000, por lo que en la lista aparecerán “In-Sight 2000:I” y “In-Sight 2000:O”. Sustituya las dos líneas con el nombre correspondiente que coincida con el nombre del módulo genérico. Fíjese que In-Sight 2000:C no se utiliza.

    3. A continuación, edite las dos líneas de arriba en Import Configuration. Haga clic en el texto del nombre para que aparezca el cursor. Lo mejor es sustituir todo lo anterior a “_In” y “_Out” por el nombre del módulo genérico o por algún otro nombre fácil de identificar. Dado que este ejemplo solo utiliza un sensor de visión, se ha empleado el nombre “In-Sight 2000”.

    4. Ahora que se han cambiado todos los nombres de etiquetas predeterminados, hay que especificar dónde se crearán las etiquetas. Si se omite ese paso, las nuevas etiquetas se ubicarán en la tabla de etiquetas de programa, justo encima de la rutina principal.

      Para poner las etiquetas en la tabla de etiquetas de controlador —como haría un perfil Add-On Profile (AOP), de estar disponible—, haga clic con el botón derecho del ratón encima del cuadro vacío que hay junto a cada uno de los nombres de importación donde falte el icono de la tarjeta de controlador. Estos espacios se han resaltado en la imagen de captura siguiente. Al hacer clic con el botón derecho, aparecerá un menú desplegable en el que puede seleccionarse Toggle Tag Scope (Alternar ámbito de etiqueta). Esto pondrá el icono de la tarjeta del controlador en el cuadro que antes estaba vacío.

    5. Una vez cambiados todos los nombres y que no presenten sus valores predeterminados, haga clic en el botón OK.

      6. Sugerencia: Los nombres, In-Sight 2000_In e In-Sight 2000_Out, pueden ser cualquier nombre, siempre que sea único para cada sensor de visión añadido a la configuración de E/S. Si se van a desplegar varios sensores, se deben seguir estos pasos para cada sensor, ya que cada caso de peldaños de copia que se cree apuntará a un sensor concreto. Hay que tener cuidado al elegir nombres para facilitar futuras resoluciones de problemas y evitar confusiones. Por ejemplo, si hay más de un sensor presente, los nombres podrían ser “Line_One_In-Sight 2000_In” y “Line_One_In-Sight 2000_Out".

    6. Se añadirá un nuevo peldaño vacío a la rutina principal. Este peldaño puede eliminarse.

  4. Descargado al PLC

    1. Descargue el proyecto al PLC.

    2. Ponga el PLC en modo de ejecución. Una vez ejecutadas las instrucciones de copia, se crearán las nuevas etiquetas en la tabla Program Tags (lo mismo ocurriría con el perfil Add-on Profile, de existir).

      En este ejemplo, In-Sight 2000:I e In-Sight 2000:O son los ensamblados de entrada y salida a partir del sensor de visión, y MyCamera_In y MyCamera_Out contendrán los bloques de control y de estado así como las matrices de datos de usuario y resultados de inspección, como muestra la tabla siguiente:


Objetos de ensamblado de entrada y salida del sistema de visión In-Sight

Encontrará más detalles en el tema Modelo de objetos EtherNet/IP y objetos de ensamblado de entrada y salida - Firmware de In-Sight 5.x.x.


Configuración de sistemas de visión In-Sight para comunicaciones con PLC

Para comunicar con un PLC, primero realice lo siguiente:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC o Controlador de movimiento en la lista desplegable Dispositivo.
  3. En la lista desplegable Fabricante, seleccione el fabricante del PLC/MC. Si el fabricante de su PLC/MC no aparece, elija Otro.
  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones. La lista contiene los protocolos de comunicaciones que ofrezca el fabricante seleccionado.
  5. Pulse el botón Aceptar.

A continuación, puede hacer lo siguiente:

  • Disparador sobre EtherNet/IP
  • Obtener datos de un sistema de visión In-Sight
  • Enviar datos a un sistema de visión In-Sight


Disparo a través de EtherNet/IP

Para configurar el sensor de visión In-Sight 2000 para el disparo a través de EtherNet/IP:

  1. Inicie sesión en el sensor de visión.
  2. En el paso Configurar imagen, establezca el tipo de disparo en Ethernet industrial.

  3. En el paso Comunicación:

    1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
    2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC o Controlador de movimiento en la lista desplegable Dispositivo.
    3. En la lista desplegable Fabricante, seleccione el fabricante del PLC/MC. Si el fabricante de su PLC/MC no aparece, elija Otro.
    4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones. La lista contiene los protocolos de comunicaciones que ofrezca el fabricante seleccionado.
    5. Pulse el botón Aceptar.

  4. Ponga el sensor de visión In-Sight en línea.

  5. En las etiquetas del ensamblador de E/S del PLC, establezca el bit Disparador habilitado en Alto y, a continuación, establezca el bit Disparador en Alto para que dispare (los bits a los que se hace referencia se resaltan en amarillo).


Establecer la conexión usando el perfil Add-On Profile

Encontrará más información en el tema Establecer la conexión usando el perfil Add-On Profile.

Si ya se hay configurado un sistema de visión en su proyecto de RSLogix con el archivo EDS, puede actualizar el perfil de EDS con el nuevo perfil Add-On Profile (AOP). Encontrará más información en el tema Actualizar un perfil de EDS instalado con el nuevo perfil AOP.


Obtención de datos de un sensor de visión In-Sight de la serie 2000

Obtener datos de un sistema de visión In-Sight

Configurar la comunicación entre el sistema de visión In-Sight y el PLC:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC en la lista desplegable PLC / Controlador de movimiento.
  3. En la lista desplegable Fabricante, seleccione el fabricante del PLC/MC. Si el fabricante de su PLC/MC no aparece, elija Otro.
  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones: La lista contiene los protocolos de comunicaciones que ofrezca el fabricante seleccionado.
  5. Pulse el botón Aceptar.

Configurar los datos para comunicación:

Los datos procedentes de tareas de EasyBuilder, como los resultados de herramientas individuales o los resultados totales de una tarea (solo salida), se pueden comunicar a través de Ethernet/IP. Los datos de entrada se leerán después de que el sensor adquiera una imagen, mientras que los datos de salida se enviarán después de que el sensor haya completado la ejecución de la tarea.

  6. Haga clic en la ficha Formatear datos de entrada o Formatear datos de salida.
  7. Pulse el botón Agregar para abrir los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida.
  8. Los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección agregada a su tarea, así como los resultados totales de esta (solo salida). En el cuadro de diálogo, seleccione los datos adecuados que desee enviar desde el sensor In-Sight (o al sensor) y pulse el botón Aceptar.
  9. Una vez que haya añadido los datos, puede modificar el tipo de datos predeterminado de los datos seleccionados si elige un tipo de datos distinto en la lista desplegable Tipo de datos.

    10. Nota: Si selecciona Cadena en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (bytes) y puede especificar la longitud de la cadena mediante la selección del número correcto de bytes.

  10. Cambie el orden de los datos que va a enviar o recibir seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
  11. Ponga el sensor de visión In-Sight en línea.
  12. Dispare el sistema.

  13. Los datos deberían mostrarse en el nodo Controller -> Program Tags (Controlador -> Etiquetas de programa) de RSLogix 5000.


Envío de datos a un sensor de visión In-Sight de la serie 2000

Enviar datos a un sistema de visión In-Sight

Configurar la comunicación entre el sistema de visión In-Sight y el PLC:

  1. En el cuadro de grupo Comunicaciones, pulse el botón Agregar dispositivo.
  2. En el cuadro de grupo Configuración de dispositivo, seleccione PLC en la lista desplegable PLC / Controlador de movimiento.
  3. En la lista desplegable Fabricante, seleccione el fabricante del PLC/MC. Si el fabricante de su PLC/MC no aparece, elija Otro.
  4. En la lista desplegable Protocolo, seleccione el protocolo de comunicaciones: La lista contiene los protocolos de comunicaciones que ofrezca el fabricante seleccionado.
  5. Pulse el botón Aceptar.

Los datos procedentes de tareas de EasyBuilder, como los resultados de herramientas individuales o los resultados totales de una tarea (solo salida), se pueden comunicar a través de Ethernet/IP. Los datos de entrada se leerán después de que el sensor adquiera una imagen, mientras que los datos de salida se enviarán después de que el sensor haya completado la ejecución de la tarea.

Para formatear sus datos:

  1. Haga clic en la ficha Formatear datos de entrada o Formatear datos de salida.
  2. Pulse el botón Agregar para abrir los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida.
  3. Los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección agregada a su tarea, así como los resultados totales de esta (solo salida). En el cuadro de diálogo, seleccione los datos adecuados que desee enviar desde el sensor In-Sight (o al sensor) y pulse el botón Aceptar.
  4. Una vez que haya añadido los datos, puede modificar el tipo de datos predeterminado de los datos seleccionados si elige un tipo de datos distinto en la lista desplegable Tipo de datos.

    5. Nota: Si selecciona Cadena en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (bytes) y puede especificar la longitud de la cadena mediante la selección del número correcto de bytes.

  5. Cambie el orden de los datos que va a enviar o recibir seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.
  6. Ponga el sensor de visión In-Sight en línea.
  7. En RSLogix 5000, abra el cuadro de diálogo Program Tags (Etiquetas de programa) y cambie el valor de las etiquetas InSight_Top:O.Data[1] y InSight_Top:O.Data[2].

  8. Determine si es necesario el establecimiento de comunicación por datos de usuario. Si está marcada la opción Enable User Data Bypass (Habilitar derivación de datos de usuario), el intercambio de datos imitará el de las cámaras 4.x.x. Si la derivación de datos de usuario no está habilitada (valor predeterminado), este nuevo bit añadirá un establecimiento de comunicación adicional al intercambio de datos entre el PLC y el sensor de visión In-Sight. Habrá que dar más pasos para visualizar los datos en la hoja de cálculo.

    1. Si la opción Enable User Data Bypass está marcada/habilitada en el cuadro de diálogo Network Setting (Ajustes de red) para la cámara, los valores de EasyBuilder se actualizarán de inmediato.

    2. Si la opción Enable User Data Bypass NO está habilitada en el cuadro de diálogo Network Setting para la cámara:

      1. Establezca la etiqueta User Data (información de usuario), el bit SetUserData es una etiqueta con nombre, en este ejemplo sería InSight_Top:O.Control.SetUserData.
      2. Borre la etiqueta User Data anterior una vez que reciba el bit de confirmación de información de usuario. El bit SetUserDataAck es una etiqueta con nombre, en este ejemplo sería InSIght_Top:I.Status. SetUserDataAck.


Ejemplo de carga de tarea del sistema de visión In-Sight desde un PLC con RSLogix

Encontrará más detalles en el tema Ejemplo de carga de tarea implícita desde un PLC con RSLogix.


Película

El paso Película se utiliza para configurar un sistema de visión o un emulador para que reproduzca las imágenes guardadas en el PC o para revisar las imágenes y los resultados guardados en el sistema de visión. La película PC suele utilizarse para la configuración y supervisión a corto plazo de las imágenes conocidas de aceptación y rechazo durante la conexión a un PC. La película Sensores suele utilizarse para la supervisión y la depuración en tiempo de ejecución. Para obtener más información sobre la película, haga clic aquí.

  • Ajustes de PC
  • Ajustes de sensores

Nota: Si no se muestra la película, haga clic en Película del menú Ver o en el botón Película [image] de la barra de herramientas de EasyBuilder.


Ajustes de sensores

Cuando el sistema de visión está en línea y adquiriendo imágenes, la película Sensores puede utilizarse para supervisar el rendimiento de una tarea. A medida que se adquieren las imágenes, los resultados de la tarea, incluidos la imagen adquirida y los datos de la tarea asociados, se guardan en la RAM del sistema de visión. A medida que se guardan los resultados en el sistema de visión, se añade un gráfico de aceptación o rechazo a la película. Se pueden guardar hasta 20 resultados, en función de la resolución del sistema de visión y de la RAM disponible.

Ejemplo de supervisión de los resultados de la película desde un sistema de visión en línea

Closed Configurar los ajustes del sensor

Nota: Al habilitar la película Sensores puede aumentar el tiempo de ejecución de la tarea; asegúrese de que el tiempo añadido sea aceptable para su aplicación. Si no es aceptable, seleccione Deshabilitada en el menú desplegable Cola.

El cuadro de grupo Ajustes de sensores permite configurar los ajustes de la película Sensores:

Closed Cola

Especifica qué resultados se guardarán; Deshabilitada (no se guardan resultados), Resultados de aceptación, Resultados de rechazo, Resultados de aceptación y rechazo o Separar resultados de aceptación y rechazo. (valor predeterminado = Deshabilitada)

Notas:
  • Cuando se selecciona Separar resultados de aceptación y rechazo:
    • La lista desplegable Tamaño de la cola está desactivada.
    • Están activadas las listas desplegables Tamaño de aceptación y Tamaño de rechazo.
    • Los botones Resultados de aceptación y Resultados de rechazo se muestran junto a la película; alterne entre estos botones para mostrar los resultados de aceptación y/o de rechazo en la película.

Closed Tamaño de la cola

Especifica el número de resultados que se guardarán. Se pueden guardar hasta 20 resultados, en función de la resolución del sistema de visión y de la RAM disponible. Si el tamaño de la cola especificado supera la RAM disponible del sistema de visión, se asigna al sistema de visión el mayor número de resultados posibles de forma automática.

Nota: Esta opción está desactivada si se ha seleccionado Separar resultados de aceptación y rechazo en la lista desplegable Cola.

Closed Tamaño de aceptación

El número de resultados de aceptación guardados en el sistema de visión. La combinación de Tamaño de aceptación y Tamaño de rechazo no superará el tamaño de la cola permitido que tiene asignado el sistema de visión. Esta opción solo está activada si se ha seleccionado Separar resultados de aceptación y rechazo en la lista desplegable Cola. (Mínimo = 1)

Closed Tamaño de rechazo

El número de resultados de rechazo guardados en el sistema de visión. La combinación de Tamaño de aceptación y Tamaño de rechazo no superará el tamaño de la cola permitido que tiene asignado el sistema de visión. Esta opción solo está activada si se ha seleccionado Separar resultados de aceptación y rechazo en la lista desplegable Cola. (Mínimo = 1)

Closed Tipo de cola

Especifica si se guardará el número (X) de resultados Solo primero o Más reciente, donde X = tamaño de la cola. (valor predeterminado= Más reciente)

Closed Borrar al poner en el modo en línea

Si la opción está activada (valor predeterminado), se borra la cola cada vez que el sistema de visión se pone en línea.

Closed Modo de presentación

Especifica si la película se debe Inmovilizar en caso de rechazo, Pausar en caso de rechazo o no debe ocurrir nada como respuesta a un resultado de rechazo (Normal). (valor predeterminado = Normal)

Closed Retardo de la pausa

Especifica la duración de la pausa en segundos si se ha seleccionado Pausar en caso de rechazo como modo de presentación. (1–120; valor predeterminado= 5)

Closed Estilo de LED

Muestra los resultados de aceptación y rechazo en la película como formas geométricas (círculo verde [image] y rectángulo rojo [image]) en verde Correcto [image] y en rojo Incorrecto [image], o bien con una marca de comprobación verde [image] y una X roja [image].

Closed Ruta de almacenamiento

Especifica una ubicación para guardar las imágenes de la película. El usuario debe tener privilegios de "escritura" para la ubicación especificada.

Closed Supervisar los resultados desde el sensor

La película puede usarse para la supervisión en línea o la revisión en línea o sin conexión de los resultados de una tarea.

  1. Haga clic en el botón En línea [image] de la barra de herramientas de EasyBuilder para poner el sistema de visión en línea.
  2. Dispare la adquisición de imágenes en el sistema de visión. A medida que se adquieren las imágenes, se guardan en el sistema de visión y se rellenan en la película en función de la opción Cola especificada en el cuadro de grupo Ajustes de sensores.
  3. Vea los gráficos de estado actualizados en la película que representan los resultados de aceptación o rechazo. El sistema de visión permanece en línea, pero la película deja de actualizarse y pasa al modo "inmovilizado" (esto se indica con una barra amarilla en la parte superior del área de visualización) si se da cualquiera de las siguientes situaciones:
    • Un resultado recibe el estado de rechazo y se ha especificado Inmovilizar en caso de rechazo o Pausar en caso de rechazo en el cuadro de grupo Ajustes de sensores.

    • Se selecciona un gráfico de estado en la película, se hace clic en un botón de navegación o en el botón Inmovilizar.

    En el modo "inmovilizado", es posible navegar por los resultados en la película o guardar imágenes del sistema de visión al PC. Se desactivan todos los pasos de aplicación para impedir la edición accidental de los parámetros de la tarea. Mientras tanto, la tarea continúa ejecutándose, pero no se añade nada a la cola. La película reanuda su actualización y se activan todos los pasos de aplicación si se da cualquiera de las siguientes situaciones:

    • Ha transcurrido el Retardo de la pausa especificado.
    • Se hace clic en el botón Continuar.
    • Se hace clic en el botón Borrar la cola.
  4. Cuando haya acabado de supervisar los resultados, vuelva a hacer clic en el botón En línea de la barra de herramientas para dejar el sistema sin conexión.
Closed Guardar imágenes desde el sensor al PC

Puede guardar las imágenes desde un sistema de visión en línea o sin conexión en cualquier carpeta del PC para la que tenga privilegios de "escritura" y utilizar el modo Reproducción desde el PC para reproducir las imágenes.

Closed Verificar la ruta de almacenamiento
  1. Verifique que el sistema de visión esté sin conexión.

  2. Haga clic en el botón "Examinar" que hay junto al campo Ruta de almacenamiento.

  3. En el cuadro de diálogo Buscar carpetaque aparece, especifique la carpeta de destino que desee y haga clic en Aceptar. La ruta de la carpeta seleccionada se muestra ahora en el campo Ruta de almacenamiento.
Closed Almacenamiento de imágenes desde un sistema de visión en línea o sin conexión a un PC
  1. Seleccione un resultado en la película o haga clic en el botón Inmovilizar para acceder al modo "Inmovilizado". Este modo se indica mediante una barra amarilla en la parte superior del área de visualización. Se desactivan todos los pasos de aplicación para impedir la edición accidental de los parámetros de la tarea. Mientras tanto, la tarea continúa ejecutándose, pero no se añade nada a la cola.

  2. Haga clic en el botón Guardar en PC en la película.

  3. Para añadir más imágenes a la carpeta de destino, salga del modo "Inmovilizado" haciendo clic en el botón Continuar o en el botón Borrar la cola en la película, permita que se añada otro conjunto de resultados a la cola y repita los pasos 1 y 2.


Ajustes en el PC

El botón Reproducción abre el diálogo Opciones de grabación/reproducción, que permite configurar los ajustes de grabación y reproducción de sistemas de visión y emuladores individuales. El modo de reproducción del PC, al que puede accederse mientras el sistema de visión está en línea o sin conexión, permite reproducir hasta 10.000 imágenes para ayudar a comprobar una tarea; la imagen se envía al sistema de visión y la tarea se ejecuta contra la imagen que se está reproduciendo.

Ejemplo de película durante la reproducción desde el PC

Closed Configurar los ajustes de grabación

Nota: Al grabar imágenes en color en el PC, se guardan como imágenes de 16 bits, no de 24 bits. Si necesita utilizar las imágenes en color para comprobar herramientas de colores, puede exportarlas a través de FTP (agregando un dispositivo FTP en el paso de aplicación Comunicación) para guardar las imágenes con toda la profundidad de colores.

  1. Haga clic en Reproducción en el cuadro de grupo Ajustes de PC.
  2. En el diálogo Opciones de grabación/reproducción que aparecerá a continuación, haga clic en la ficha Grabación.
  3. Seleccione la carpeta en la que desee guardar las grabaciones y configure los demás parámetros de grabación.
  4. Una vez especificados todos los ajustes de grabación, haga clic en Aceptar para cerrar el diálogo Opciones de grabación/reproducción.
Closed Grabar imágenes
  1. En la película, haga clic en el botón PC.
  2. En la barra de herramientas de EasyBuilder, haga clic en el botón Grabar.
  3. Active la adquisición de imágenes en el sistema de visión. Según se van adquiriendo las imágenes, se van clasificando y almacenando automáticamente como aceptaciones y rechazos en la carpeta especificada.
  4. Para detener la grabación, vuelva a hacer clic en el botón Grabar.
Closed Configurar los ajustes de reproducción
  1. Haga clic en Reproducción en el cuadro de grupo Ajustes de PC.
  2. En el diálogo Opciones de grabación/reproducción que aparecerá a continuación, haga clic en la ficha Reproducción.
  3. Seleccione la carpeta en la que desee guardar las reproducciones y configure los demás parámetros de reproducción.

Nota: De forma predeterminada, la carpeta Playback se refiere a la carpeta EasyBuilder Sample Jobs. Las tareas de ejemplo de EasyBuilder demuestran claramente la utilidad de las opciones de grabación y reproducción. Con las opciones de grabación y reproducción se pueden procesar cíclicamente una serie de imágenes capturadas con anterioridad, proporcionando información instantánea sobre los resultados de la herramienta y permitiendo configurar rápidamente los umbrales y límites.

  4. Una vez especificados todos los ajustes de reproducción, haga clic en Aceptar para cerrar el diálogo Opciones de grabación/reproducción.
Closed Reproducción de imágenes desde el PC

Nota: Para permitir la reproducción de imágenes cuando un sistema de visión se encuentra en modo en línea, el parámetro Disparador del paso de aplicación Configurar imagen debe ajustarse a Externo, Manual o Red.

  1. En la película, haga clic en el botón PC.

  2. Si el parámetro Disparador (en el paso de aplicación Configurar imagen) está ajustado a Cámara o Continuo, para poder reproducir imágenes deberá poner el sistema de visión en el modo sin conexión. Si el parámetro Disparador está ajustado a Externo, Manual o Red, el sistema de visión puede permanecer en línea para reproducir imágenes.
  3. En la película, haga clic en el botón Reproducir para reproducir las imágenes o haga clic en los botones de navegación (mostrados abajo) para revisar cíclicamente las imágenes de forma manual.

    4. reproducir | pausa
seleccionar primero | seleccionar anterior
seleccionar siguiente | seleccionar último
  4. Haga clic en el paso de aplicación Ejecutar tarea para mostrar la Tabla de resultados (o haga clic en la ficha Resultados de la paleta).


Guardar tarea

Este paso permite ejecutar diversas tareas de gestión de archivos y de mantenimiento de sensores.

Nota: Si se activa la casilla de verificación Permitir guardado del trabajo en línea del diálogo Usuario, los usuarios con acceso Completo o Protegido pueden guardar tareas mientras se encuentren en línea. Si la casilla Permitir guardado del trabajo en línea está desactivada, para poder guardar tareas el sistema de visión deberá estar sin conexión.

  • Guardar (o Guardar como) una tarea
  • Configurar ajustes de inicio
  • Crear una copia de respaldo de tareas, imágenes y ajustes de sensores
  • Restaurar una copia de respaldo de tareas, imágenes y ajustes de sensores


Guardar (o guardar como) una tarea

Cuando se guarda una tarea, solo se guardan los ajustes de herramientas y la información específica de esa tarea.

Nota: Aunque una tarea se puede guardar durante pasos anteriores de EasyBuilder, el paso "Guardar tarea" sirve como recordatorio importante. EasyBuilder no incorpora ninguna función de "guardado automático", por lo que todos los cambios pendientes de guardar se perderán si se apaga el sensor.

Si una tarea aún no ha sido guardada, la función "Guardar" opera igual que la función "Guardar como", es decir, abriendo el cuadro de diálogo Guardar como.

Closed Guardar (o guardar como) una tarea no guardada:

  1. Presione CTRL+S o bien, en el cuadro de grupo Guardar tarea, haga clic en Guardar o en Guardar como para abrir el cuadro de diálogo Guardar como.
  2. En el cuadro de diálogo, navegue a la ubicación deseada si fuese necesario.
  3. Asigne un nombre a la tarea.
  4. Haga clic en la opción Guardar del cuadro de diálogo.

Closed Para guardar una tarea ya guardada anteriormente, elija uno de los siguientes procedimientos:
  • Haga clic en Guardar en el cuadro de grupo Guardar tarea.
  • Presione CTRL+S.
Nota: Para guardar la imagen actual de un sensor, haga clic en Guardar imagen como... del menú "Archivo". Para guardar los ajustes del sensor y todas las imágenes, cree una copia de respaldo de su sensor In-Sight o emulador.


Configurar ajustes de inicio

Los controles del cuadro de grupo Opciones de inicio permiten especificar tareas que se ejecutarán automáticamente cuando se encienda un sensor/sistema de visión o emulador In-Sight, incluidas la carga de una tarea predeterminada o el cambio del sensor/sistema de visión al estado en línea.

Solo los usuarios con acceso completo pueden configurar los ajustes de inicio.

Seleccionar una tarea de inicio

  1. Haga clic en el botón [image]. Se abrirá el cuadro de diálogo Inicio.
    1. En el cuadro de diálogo, seleccione la casilla de verificación Cargar tarea en inicio. La lista esta habilitada y muestra las tareas almacenadas en el sensor/sistema de visión conectado, en la tarjeta SD instalada en el sistema de visión conectado o emulador.

    2. Si el servidor de tareas está habilitado, verifique la casilla Cargar tarea remota en inicio en el cuadro de diálogo. La lista se habilita y muestra las tareas almacenadas en el servidor de tareas.

      Nota:
      • De forma predeterminada, el servidor de tareas está deshabilitado. Utilice el cuadro de diálogoAjustes del servidor de tareas para habilitar y configurar el servidor de tareas.
      • Si está habilitado el servidor de tareas, solo se puede seleccionar una tarea guardada en el servidor de tareas. Si al iniciar que se cargue una tarea guardada en el sistema de visión, desactive el servidor de tareas.
      • El servidor de tareas no es compatible en el sensor de visión In-Sight de la serie 2000.
  2. Seleccione la tarea que desea añadir automáticamente en el inicio.
  3. Haga clic en OK. Se cerrará el cuadro de diálogo.

  4. En el cuadro de texto de la tarea se muestra la tarea de inicio seleccionada.

    Nota:
    • Si se selecciona la tarea grabada en la tarjeta SD, el cuadro de texto de tarea mostrará "SDCARD/xxx.job".
    • El cuadro de texto de la tarea es solo de lectura. Para modificar la tarea de inicio, haga clic en el botón [image].
  5. Si desea anular la selección de la tarea de inicio y comenzar con una tarea vacía, vuelva a hacer clic en el botón [image] y anule la selección de Cargar tarea en inicio o Cargar tarea remota en inicio.

Iniciar el sensor en línea

  1. Marque la casilla de verificación Iniciar sensor en modo en línea para que inicie automáticamente el sensor actual en el modo en línea al iniciarse.

    Nota: También puede habilitar este ajuste mediante el cuadro de diálogo Inicio.


Creación de una copia de respaldo

El botón Copia de seguridad permite a los usuarios con acceso total o protegido almacenar una copia de respaldo de los ajustes de tareas, imágenes y sensor de un sistema/sensor de visión o emulador de In-Sight en el disco duro de su PC local.

Antes de crear una copia de respaldo de un sistema/sensor de visión o emulador en el PC, haga clic en Opciones en el menú de sistema para garantizar que la carpeta de destino, o el directorio de la copia de respaldo, para los datos archivados se ha configurado según sus necesidades.

Creación de una copia de respaldo del sensor o emulador actual:

  1. Haga clic en Copia de respaldo en el cuadro de grupo Mantenimiento de sensores.
Consejo: El cuadro de diálogo Copia de respaldo (sistema > copia de respaldo), le permite almacenar copias de respaldo de diferentes sistemas/sensores/emuladores de visión en el PC o en la tarjeta SD instalada en el sistema de visión. Para obtener más información, consulte el tema del cuadro de diálogo Copia de respaldo.


Restauración de una copia de respaldo

El botón Restaurar permite a los usuarios con acceso total o protegido restaurar una copia archivada de los ajustes de tareas, imágenes y sensores desde su PC local para restaurarlos en el sistema/sensor o emulador de visión In-Sight original; la copia se debe guardar como copia de respaldo en el PC antes de que los archivos aparezcan en el cuadro de diálogo.

Restauración de una copia de respaldo en sensor o emulador actual:

  1. Haga clic en Restaurar en el cuadro de grupo Mantenimiento de sensores.

Consejo: Con el cuadro de diálogo Restaurar o Restaurar desde (Sistema > Restaurar desde), puede restaurar una copia archivada en un sistema/sensor/emulador de visión diferente o restaurar una copia de respaldo almacenada en la tarjeta SD en el sistema de visión. Para más información, consulte el tema de los cuadros de diálogo Restaurar o Restaurar desde.


Ejecutar tarea

Una vez que haya ajustado todos los parámetros de la tarea, puede ejecutarla, revisar los resultados y modificar o solucionar los problemas de los ajustes si fuera necesario, así como probar la tarea para asegurarse de que todos los parámetros estén dentro de sus límites y el sistema de visión In-Sight adquiera las imágenes con precisión.

  • Ejecución de la tarea en un sistema de visión In-Sight
  • Revisión de la tabla de resultados
  • Prueba de tareas con TestRun™


Ejecución de una tarea en un sensor.

La ejecución de una tarea en un sensor únicamente implica cambiar el sensor al estado en línea.

Nota: Si se fuerza la "activación" o "desactivación" de una salida o línea de salida en el paso de aplicación Entradas/Salidas, aparecerá una advertencia en el cuadro de grupo Estado de la tarea. En este caso, asegúrese de que no se producirá ningún daño si el equipo se activa o desactiva antes de cambiar el estado del sensor a En línea o Sin conexión.

Cambiar el estado del sensor a En línea o Sin conexión:

  • Para cambiarlo a En línea: Haga clic en el botón En línea en el panel de ajustes. El botón es un alternador y se vuelve naranja para indicar el estado En línea.
    Aspecto del botón cuando está Sin conexión
  • Para cambiarlo a Sin conexión: Haga clic en el botón En línea naranja en el panel de ajustes. El botón vuelve a su color original para indicar su estado Sin conexión.
    Aspecto del botón cuando está En línea


Modificación o impresión de la tabla de resultados

Haga clic en Opciones en el panel de ajustes para abrir el cuadro de diálogo Opciones de visualización de resultados, que permite modificar la tabla de resultados.

El cuadro de diálogo Opciones de visualización contiene los controles siguientes:

  • Opciones de visualización Closed : Permite inhabilitar o habilitar el redimensionamiento automático de los anchos de columnas y visualizar las tasas de aceptación o rechazo como porcentajes o como recuentos, así como quitar o agregar las columnas de iconos de herramientas, tiempos, resultados, gráficos de dependencias de herramientas, aceptación/rechazo y de estado de habilitación de herramientas en la tabla de resultados.

    La columna Estado de habilitación de herramienta indica el estado de activación de una herramienta ("Encendida", "Apagada" o línea de entrada relacionada), que se define en los pasos Detectar pieza e Inspeccionar pieza .
  • Opciones de herramienta Closed : Permite ocultar/mostrar las superposiciones gráficas de una herramienta en el panel Imagen (columna Mostrar gráfico) y ocultar/mostrar el perfil de una herramienta en la tabla de resultados (columna Mostrar herramienta).

    Para aplicar estos ajustes a herramientas individuales, active o desactive las casillas de verificación. Para aplicarlos a todas o a ninguna de las herramientas de la tarea, haga clic en los botones Todas o Ninguna en la sección Cambiar opciones.

    De forma predeterminada, todas las casillas de verificación están activadas.
  • Restaurar valores predeterminados Closed : Borra la clasificación y restablece los ajustes predeterminados de la tabla de resultados. Las columnas predeterminadas son las de indicador de aceptación/rechazo, gráficos de dependencias de herramientas, iconos de herramientas, nombres, resultados, aceptaciones/rechazos (visualizados como recuentos) y tiempo. Las columnas se redimensionan automáticamente para adaptarse al ancho de EasyBuilder View.

Otros controles del panel de ajustes relacionados con la tabla de resultados son los siguientes:

  • Imprimir Closed : Abre la ventana Vista preliminar, que permite imprimir todas las páginas, aplicar zoom en porcentajes preestablecidos, definir el número de páginas a visualizar cada vez y seleccionar páginas específicas. También puede abrir el cuadro de diálogo Configuración de página para seleccionar el tamaño, el origen y la orientación del papel, así como los márgenes de página y la impresora.
  • Poner a cero aceptaciones y rechazos Closed : Pone a cero los contadores de aceptación/rechazo y reanuda el recuento.


Revisión de la tabla de resultados

La tabla de resultados del panel de ajustes muestra un perfil de cada herramienta de la tarea. Para ordenar la tabla por los valores de una columna, haga clic en el título de la columna; para invertir el orden de clasificación, vuelva a hacer clic en el título de la columna. Para restablecer el orden predeterminado, haga clic por tercera vez en el título de la columna. Para reordenar las herramientas dentro de la tabla, arrástrelas y suéltelas en la posición deseada dentro de la tabla.

Nota: Las herramientas se pueden reorganizar en la tabla Resultados arrastrando y soltando las herramientas en el orden deseado. Esto puede hacerse tanto en la tabla Resultados de tareas ejecutadas como en la tabla Resultados de Palette, y se reflejará en ambas tablas. La clasificación mediante la técnica “arrastrar y soltar” solo se habilita al seleccionar la columna Orden de las herramientas y gráficos de dependencias (esta columna está seleccionada por defecto). Para invertir el orden, seleccione de nuevo la columna. La función de reorganización de la lista se desactivará si la tarea se aproxima o supera el límite de tamaño de la tarea.

La tabla de resultados contiene las siguientes columnas predeterminadas (de izquierda a derecha):

  • Indicador de aceptaciones/rechazos: Utiliza un círculo verde [image] y un rectángulo rojo [image] para representar éxito y fallo, respectivamente. Los criterios de aceptación/rechazo se especifican en los pasos Localizar pieza e Inspeccionar pieza.

  • Gráficos de orden de herramientas y dependencia: Muestra el orden de las herramientas y las dependencias entre la herramienta seleccionada (resaltada en naranja) y otras herramientas. Para ordenar las herramientas en su orden de inclusión en la tarea, seleccione esta columna. Ajustar el orden de esta columna también permite arrastrar y soltar las herramientas en el orden deseado. Las herramientas de una Herramienta de matemáticas & lógica Grupo pueden añadirse al grupo o quitarse de él ampliando la herramienta y arrastrando la herramienta en cuestión hacia el grupo o fuera de él.

    Nota: Las herramientas agrupadas no se pueden arrastrar debajo de otras herramientas de grupo. Por otra parte, no se pueden añadir a una herramienta de grupo otras herramientas que generarían una referencia circular.

    Existe una dependencia cuando una herramienta hace referencia a otra herramienta. Cada dependencia tiene dos partes, una precedente y una dependiente, interconectadas por una línea. La precedente se refiere al origen de los datos (es decir, a la herramienta que proporciona la entrada) y se representa mediante un círculo; la dependiente es el destino de los datos (es decir, la herramienta que recibe la salida) y se representa mediante una flecha. Los gráficos de dependencias azules indican que la herramienta seleccionada es el destino; los verdes indican que la herramienta seleccionada es el origen.

  • Icono de la herramienta: Indica visualmente el tipo de herramienta utilizado (por ejemplo, presencia/ausencia de margen, texto de identificación leído, recuento de blobs).
  • Nombre: Enumera el nombre de la herramienta cuyo nombre predeterminado puede cambiarse en el paso Localizar pieza o Inspeccionar pieza.

  • Resultado: Enumera los resultados de datos de la herramienta, que también aparecen en la ficha Ajustes o Límites de rango del panel de ajustes de Detectar pieza o Inspeccionar pieza.

    Modelos In-Sight | Resultados

    Sensores de visión In-Sight 2000-110 y 2000-120/120C

             Solo estado de aceptación/rechazo
    Sensores de visión In-Sight 2000-130/130C

    Herramientas de inspección de medición y recuento: Resultados estándar (datos numéricos)
    Herramienta de presencia/ausencia de patrones: Estado de aprobado/rechazado y puntuación de patrón
    Otras herramientas: Solo estado de aceptación/rechazo
    Sistemas de visión In-Sight y sensor de visión In-Sight 2000-23M | Resultados estándar
  • Aceptación: Muestra la tasa de aceptaciones de la herramienta, ya sea como número de resultados aceptados/totales (ajuste predeterminado) o como porcentaje.
  • Rechazo: Muestra la tasa de rechazos de la herramienta, ya sea como número de resultados rechazados/totales (ajuste predeterminado) o como porcentaje.

    • Nota: Cuando se desactiva una herramienta, sus señales permanecen en su último estado. Si la herramienta mostraba un rechazo cuando se desactivó, Aceptación será 0 y Rechazo será 1. Sin embargo, las aceptaciones o los rechazos de la tarea global no se verán afectados por la aceptación o el rechazo de la herramienta desactivada.

  • Tiempo (ms): Indica el tiempo, en milisegundos, necesario para ejecutar la herramienta.

  • Tipo: Muestra el tipo de herramienta. Por ejemplo, se muestra "Patrones PatMax RedLine™ (1-10)" para la herramienta de ubicación de patrones PatMax RedLine™ (1-10) y "Patrones PatMax® (1-10)", para la herramienta de ubicación de patrones PatMax® (1-10).

    Nota: Para ocultar la columna Tipo, haga clic con el botón derecho y seleccione Mostrar columna Tipo.

El cuadro de grupo Estado de la tarea que hay a la izquierda de la tabla de resultados muestra la tasa de aceptaciones general (Tasa) de todas las imágenes vistas desde la última vez que se puso a cero el contador de aceptaciones/rechazos, así como el tiempo de ejecución de la tarea (Tiempo) correspondiente a la imagen actual.

  • Modificación o impresión de la tabla de resultados


Optimización de tareas y resolución de problemas

Puede utilizar esta información para identificar problemas u optimizar ajustes de tareas.

Algunos posibles usos de la tabla de resultados para identificar problemas:

  • Recuentos de aceptaciones/rechazos: Permite identificar qué herramientas están fallando.
  • Gráficos de dependencias de herramientas: Permite determinar si un fallo de herramienta está relacionado con el fallo de otra herramienta mediante la visualización de dependencias entre herramientas.
  • Cadenas de resultados: Permite determinar qué herramientas se están saliendo de la especificación.

Optimizar la tarea a menudo implica disminuir el tiempo de procesamiento, que puede variar según las capacidades de sensores In-Sight individuales. La optimización de tareas sólo es importante para aplicaciones que requieren una elevada precisión de control de tiempos (como las que implican velocidades de línea elevadas).

Durante la ejecución de una tarea de EasyBuilder, las siguientes fases son las que requieren mayor precisión de control de tiempos:

  • Tiempo de adquisición: Tiempo de exposición + tiempo de transferencia al CCD (dispositivo acoplado por carga)
  • Funcionamiento de la herramienta: Suma del tiempo de procesamiento de todas las herramientas y funciones

A continuación se proporcionan algunas pautas generales para reducir el tiempo de ejecución de tareas:

  • Reducir el tiempo de exposición.
  • Efectuar una adquisición parcial.
  • Especificar una región de interés menor.
  • Minimizar la rotación de la imagen.

En caso necesario, puede regresar al paso Configurar imagen, Detectar pieza o Inspeccionar pieza para modificar los parámetros como corresponda.

Asimismo, las velocidades relativas de las herramientas principales Detectar e Inspeccionar pieza son (de rápida a lenta):

  • Margen
  • Blob
  • Patrón

Por lo tanto, si una herramienta de márgenes y una herramienta de patrones proporcionan el mismo resultado, utilice la primera.

Nota: El tiempo de ejecución real en producción puede ser menor que el tiempo de ejecución durante el paso "Ejecutar tarea", debido al posible solapamiento de las funciones de adquisición y de procesamiento.


Prueba de tareas con TestRun™

TestRun™ realiza pruebas en el sistema de visión In-Sight y contrasta los resultados de dichas pruebas con los valores previstos. TestRun incluye las siguientes pruebas para los sistemas de visión In-Sight:

  • Pruebas de límites: Consulta una lista de parámetros y determina si el valor actual queda entre los límites superior e inferior, según se haya configurado para el parámetro en cuestión. Estos parámetros pueden configurarlos los usuarios directamente desde dentro de la tarea, las entradas discretas pueden leerse en la tarea y los valores pueden enviarse desde un dispositivo externo utilizando un protocolo de comunicaciones.
  • Pruebas de imagen: Envía una serie de imágenes de calidad conocida ("buena" y "mala") a un sistema de visión y determina si los resultados de la tarea actual concuerdan con los resultados previstos para cada imagen.
  • Pruebas del hardware: Contrasta la calidad de la imagen actual procedente del sistema de visión con la calidad de imagen prevista para determinar si se han producido cambios en la posición de la cámara, el enfoque, la iluminación, etcétera.

Antes de utilizar TestRun

Nota: TestRun está disponible únicamente para los usuarios que disponen de privilegios de acceso completo.

TestRun presupone lo siguiente:

  • La aplicación de visión artificial ya está desarrollada y se ha guardado como archivo .job en un sistema de visión In-Sight.
  • En el paso Establecer conexión, ya se ha establecido la conexión con el sistema de visión y se ha cargado el archivo .job.
  • Se ha creado una base de datos de imágenes que contiene las imágenes que se utilizan en la aplicación.

Nota: Lo ideal es que la base de datos contenga ejemplos de imágenes "buenas" (que consiguen el resultado de Aceptación) e imágenes "malas" (que ofrecen un resultado de Rechazo). TestRun puede funcionar con diferentes estructuras de organización de archivos para la base de datos de imágenes, pero es aconsejable clasificar las imágenes en carpetas de "buenas" y "malas" antes de abrir TestRun para así simplificar el proceso.

Utilización de TestRun

Después de conectar el sistema de visión In-Sight deseado y tras cargar en el sistema de visión el archivo .job correspondiente, podrá comenzar a configurar TestRun. TestRun se configura por medio del cuadro de diálogo Configuración de TestRun, que incluye una serie de pantallas de procesos paso a paso para programar TestRun. A la izquierda del cuadro de diálogo se incluye un panel de navegación que permite seleccionar las diferentes pantallas de configuración.

Nota: Una vez realizada la configuración de TestRun, podrá regresar a cualquiera de dichos pasos simplemente seleccionándolo en el panel de navegación.

Configuración de RestRun

  1. En la paleta, haga clic en la ficha TestRun.

Nota: Si no está visible la paleta, seleccione Paleta en el menú Ver.

  2. Pulse el botón Configurar para abrir el cuadro de diálogo Configuración de TestRun.
  3. Siga la serie de pantallas paso a paso para configurar TestRun. Si desea más información de la configuración de TestRun, consulte la ayuda de In-Sight Explorer.


Avisos legales

El software descrito en este documento se suministra bajo licencia y únicamente se puede usar o copiar de acuerdo con las condiciones de dicha licencia y con la inclusión del aviso de derechos de autor que aparece en esta página. El software, el presente documento ni ninguna copia de este se proporcionarán o pondrán a disposición de ninguna persona excepto el licenciatario. La titularidad y propiedad de este software corresponde a Cognex Corporation o sus emisores de licencia. Cognex Corporation no se hace responsable del uso o la confiabilidad de su software en equipos no suministrados por Cognex Corporation. Cognex Corporation no otorga garantías, ni expresas ni implícitas respecto al software descrito, la comercialización, la adecuación para un uso concreto ni la no infracción.

La información de este documento está sujeta a cambios sin previo aviso y no debe interpretarse como un compromiso de Cognex Corporation. Cognex Corporation no se hace responsable de los errores que pudiera haber presentes en este documento o en el software relacionado.

Las empresas, los nombres y los datos utilizados en los ejemplos de la documentación son ficticios, a menos que se indique lo contrario. Queda prohibida, con cualquier propósito, la reproducción de todo o parte de este documento por cualquier medio y en cualquier formato, ya sea electrónico o mecánico, y la transferencia a cualquier otro soporte mediático o idioma sin la autorización por escrito de Cognex Corporation.

Revision: 5.6.1.14

09/14/2018 4:18 PM

Copyright @ 2008 -2018 Cognex Corporation. Reservados todos los derechos.

Partes del hardware y software suministrado por Cognex pueden estar protegidas por una o varias de las patentes de EE. UU. o extranjeras que se enumeran a continuación, o pueden estar pendientes de solicitudes de patentes de EE. UU. y extranjeras. Estas patentes de EE. UU. y extranjeras pendientes que se publiquen después de la fecha de este documento constan en el sitio web de Cognex, en la dirección: http://www.cognex.com/patents.

5481712, 5742037, 5751853, 5845007, 5909504, 5943441, 5949905, 5960125, 5978080, 5978081, 6005978, 6137893, 6141033, 6154567, 6215915, 6301396, 6327393, 6381375, 6408109, 6457032, 6490600, 6563324, 6658145, 6690842, 6771808, 6804416, 6836567, 6850646, 6856698, 6859907, 6920241, 6941026, 6959112, 6963338, 6975764, 6985625, 6993192, 7006712, 7016539, 7043081, 7058225, 7065262, 7069499, 7088862, 7107519, 7164796, 7175090, 7181066, 7251366, 7720315, JP 3927239

Cognex, In-Sight, EasyBuilder, VisionView, DataMan y DVT son marcas registradas de Cognex Corporation.

El logotipo de Cognex, SmartLink, EdgeCount, FeatureCount son marcas de Cognex Corporation.

Windows es una marca o una marca registrada de Microsoft Corporation en EE. UU. y otros países. Otros productos y otras marcas de empresas identificadas aquí son marcas de sus respectivos propietarios.


Formateo de los datos de entrada/salida

Los datos de las tareas de EasyBuilder, como los resultados individuales de tarea o los resultados totales de tarea (solo de salida), pueden comunicarse a través de Ethernet/IP, DeviceNet, Modbus TCP, PROFINET y POWERLINK. Los datos de entrada formateados se leen después de que el sensor adquiera una imagen, y los datos de salida se envían una vez que el sensor completa la ejecución de la tarea.

Nota: DeviceNet, POWERLINK y CC-Link solo están disponibles en sistemas de visión In-Sight que utilicen la versión 4.x.x del firmware de In-Sight; no están disponibles en sistemas de visión In-Sight con las versiones 5.1.0 y posteriores del firmware de In-Sight. Consulte Versiones de firmware para ver una lista completa de modelos y de versiones de firmware compatibles.

Para formatear los datos:

  1. Haga clic en la ficha Formatear datos de entrada o Formatear datos de salida.
  2. Pulse el botón Agregar para abrir los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida.
  3. Los cuadros de diálogo Seleccionar datos de entrada o Seleccionar datos de salida contienen los datos de cualquier herramienta de ubicación o de inspección agregada a su tarea, así como los resultados totales de esta (solo salida). En el cuadro de diálogo, seleccione los datos adecuados que desee enviar desde el sensor In-Sight (o al sensor) y pulse el botón Aceptar.

  4. Una vez que haya añadido los datos, puede modificar el tipo de datos predeterminado de los datos seleccionados si elige un tipo de datos distinto en la lista desplegable Tipo de datos.

    Notas:
    • Si selecciona Cadena o Cadena de intercambio de bytes en la lista desplegable Tipo de datos, se habilita el control Tamaño de elemento (bytes) y puede especificar la longitud de la cadena mediante la selección del número correcto de bytes.
    • Si utiliza PROFINET, la longitud máxima de los datos de entrada y salida es de 4.000 bytes. Si utiliza POWERLINK, la longitud máxima de los datos de entrada y salida es de 256 bytes.

  5. También puede personalizar el orden de bytes si especifica bytes bajos primero en lugar de bytes altos primero mediante la desactivación de la casilla de verificación Bytes altos/bytes bajos (está desactivada de forma predeterminada para todos los protocolos, excepto PROFINET). Puede personalizar el orden de relevancia de bytes si especifica bytes menos significativos primero en lugar de bytes más significativos primero mediante la desactivación de la casilla de verificación Bytes más significativos/bytes menos significativos (está desactivada de forma predeterminada). Cualquier cambio efectuado en la ficha Formatear datos de salida se actualizará en la vista previa.

    Nota: Cualquier cambio realizado en el orden de los bytes o en el de la relevancia de los bytes repercutirán en todas las señales de datos de las fichas Formatear datos de salida y Formatear datos de entrada.
  6. Cambie el orden de los datos que va a enviar o recibir seleccionándolos en la lista y haciendo clic en el botón Subir o Bajar para establecer el orden que desee.


Matrices Calibre

Las matrices Calibre permiten aislar márgenes dentro de una región de la imagen utilizando el método de modelo de márgenes, consistente en detectar picos de márgenes en calibres individuales mediante un kernel 1D. La matriz Calibre produce una representación 1D de la porción de la imagen que contiene los márgenes de interés. Esta imagen 1D contendrá no sólo los márgenes de interés, sino también otros márgenes generados por ruido, así como otras informaciones no deseadas que puedan existir en la imagen original. Aplicando a la imagen 1D los parámetros Tamaño del calibre, Ancho del margen y Contraste mínimo de la ficha Márgenes de cualquier herramienta que utilice la matriz Calibre se intensifican los márgenes de interés y al mismo tiempo se reduce el ruido en la imagen.

Cada Calibre existente en la matriz se evalúa individualmente, y los candidatos a márgenes existentes en su interior se puntúan para determinar cuál de ellos debe seleccionarse. En lo referente a defectos posicionales, se genera una línea con el mejor ajuste posible basándose en cada margen encontrado. A continuación, se determinan los defectos comparando el margen encontrado con la línea de mejor ajuste posible en busca de variaciones con respecto a las tolerancias especificadas. Para detectar defectos de anchura, se calcula la distancia entre los dos márgenes encontrados dentro del Calibre con el fin de determinar su distancia. Los defectos se determinan comparando la distancia con respecto al rango esperado.

La matriz Calibre contenida en la región define el tamaño de los defectos y/o espacios detectables. El tamaño del defecto o espacio detectable se determina a partir del número de márgenes detectables, el cual, a su vez, está determinado por el número de calibres situados a lo largo del margen. Los calibres se visualizan en la región en forma de rectángulos rojos si se activa la casilla de verificación Mostrar todos los calibres (desactivada de forma predeterminada).

Nota: Cuantos más calibres se apliquen dentro de la región, más tiempo necesitará la herramienta para ejecutarse.


Agregar y editar de modelos de colores

Un modelo de colores es una colección de colores que se utiliza para definir un objeto y un fondo en una imagen. Cada modelo de colores representa un espacio de colores tridimensional en el que pueden sumarse o restarse los valores RGB de los colores del objeto y del fondo que se está adquiriendo.

Closed Adición de un modelo de colores
  1. En la ficha Ajustes, seleccione la biblioteca de colores a la que hacer referencia en el menú desplegable Biblioteca de colores. De forma predeterminada, aparece seleccionada la primera biblioteca de colores (ExtractColorLibrary_1).
  2. Presione el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor.
  3. En el cuadro de grupo Modelos de colores del diálogo Entrenamiento de ExtractColor, presione el botón Nuevo modelo para agregar un nuevo modelo de colores a la biblioteca de colores. El nombre predeterminado es "Model_1" (si se trata del primer Modelo de colores agregado a la biblioteca de colores. En caso contrario, se irá incrementado, es decir "Model_2", "Model_3", etc.).
  4. Si lo desea, cambie el nombre del modelo de colores a otro más descriptivo de su aplicación, especialmente si trabaja con varios modelos de colores. El nombre de un modelo de colores se puede cambiar en cualquier momento resaltando el modelo de colores y presionando el botón Cambiar nombre situado sobre el directorio de la Biblioteca de colores.
  5. Para quitar Modelos de colores de la lista, seleccione Modelo de colores y presione el botón Eliminar modelo.
Closed Suma o resta de colores en modelos de colores
Closed Suma o resta de un solo color en un modelo de colores
  1. Seleccione el Modelo de colores a modificar.
  2. En el cuadro de grupo Entrenar, seleccione Color más dominante (ajuste predeterminado).
  3. En el cuadro de grupo Entrenar, seleccione el tipo de región que se utilizará para definir el Color: Región, Círculo, Espacio anular, Polígono o Manual.
  4. Presione el botón Agregar nuevo color o Restar nuevo color y configure la región dentro de la imagen de modo que sólo contenga los valores RGB que desee sumar o restar.
  5. Una vez que haya configurado la región, elija entre hacer doble clic en la región o presionar el botón Aceptar en la barra de herramientas de edición de tareas.
  6. Para una Operación de suma, el Color agregado al Modelo de colores contiene los valores RGB pico de la región, y estos valores se agregarán al Modelo de colores acumulativo.
  7. Para una Operación de resta, el Color agregado al Modelo de colores contiene los valores RGB pico de la región, y estos valores serán restados del Modelo de colores acumulativo.
  8. Los colores contenidos en la lista Modelo de colores pueden moverse dentro de la lista para definir qué Color comienza o termina la operación. El primer Color aplicado a la inspección aparece en primer lugar.
Closed Suma o resta de varios colores en un modelo de colores
  1. Seleccione el Modelo de colores a modificar.
  2. En el cuadro de grupo Entrenar, seleccione Múltiples colores.
  3. En el cuadro de grupo Entrenar, seleccione el tipo de región que se utilizará para definir el Color: Región, Círculo, Espacio anular, Polígono o Manual.
  4. Presione el botón Agregar nuevo color o Restar nuevo color y configure la región dentro de la imagen de modo que sólo contenga los valores RGB que desee sumar o restar.
  5. Una vez que haya configurado la región, elija entre hacer doble clic en la región o presionar el botón Aceptar en la barra de herramientas de edición de tareas.
  6. Para una Operación de suma, el Color agregado al Modelo de colores contiene los valores RGB pico de la región, y estos valores se agregarán al Modelo de colores acumulativo.
  7. Para una Operación de resta, el Color agregado al Modelo de colores contiene los valores RGB pico de la región, y estos valores serán restados del Modelo de colores acumulativo.
  8. Los colores contenidos en la lista Modelo de colores pueden moverse dentro de la lista para definir qué Color comienza o termina la operación. El primer Color aplicado a la inspección aparece en primer lugar.
Closed Ajuste de la tolerancia de colores de un color

El uso conjunto de los controles Marcado de imágenes y de los controles Tolerancia de colores permite determinar qué porción del objeto se está detectando y ajustar los controles Tolerancia de colores para aumentar o reducir la sensibilidad de la herramienta mediante los ajustes Más oscuro, Más claro, Resaltes y Matices en el cuadro de grupo Tolerancia de colores del diálogo Entrenamiento de ExtractColor.

Sugerencia: Para configurar los controles Tolerancia de colores, sitúe el diálogo Entrenamiento de ExtractColor de modo que pueda ver fácilmente la imagen. Según vaya ajustando los controles, la imagen se actualizará para reflejar los cambios, dependiendo del tipo de Marcado de imágenes seleccionado.

Closed Controles de tolerancia de colores
Closed Más oscuro

Aumente este ajuste si desea agregar espacio al Color hacia el negro (0, 0, 0).

Closed Más claro

Aumente este ajuste si desea agregar espacio al Color hacia el blanco (255, 255, 255).

Closed Resaltes

Aumente este ajuste si desea agregar espacio al Color desde la posición de Color inicial hacia el blanco (255, 255, 255).

Closed Matices

Aumentando este ajuste se aumenta el "cuadro" 3D del Color inicial en tres dimensiones dentro del espacio de colores.

Closed Controles de marcado de imágenes

Los botones Marcado de imágenes permiten determinar qué porción de la imagen debe resaltarse al sumar o restar Color(es) y Modelo(s) de colores.

Closed Marcar resultados para todo el grupo

En la imagen se marcan todos los Colores del Modelo de colores.

Closed Marcar resultados hasta el color seleccionado

Si selecciona el segundo Color en una lista de tres, en la imagen se marcan los Colores primero y segundo.

Closed Marcar sólo los colores seleccionados

En la imagen sólo se marca el Color seleccionado.

Closed Edición de un modelo de colores
  1. En la ficha Ajustes, seleccione la biblioteca de colores a la que hacer referencia en el menú desplegable Biblioteca de colores.
  2. Presione el botón Entrenar color para abrir el diálogo Entrenamiento de ExtractColor.
  3. Seleccione el Modelo de colores a modificar y utilice los controles del diálogo para editar el Modelo de colores.


Agregar y editar colores

Los colores se definen por región y almacenan los valores medios RGB y HSI incluidos en la región en el momento del entrenamiento. La biblioteca puede contener hasta 100 colores distintos, que están compuestos por los valores RGB/HSI del objeto que se está examinando.

Closed Agregar un color
  1. Desde la ficha Ajustes, seleccione Biblioteca de colores para tomar como referencia el menú desplegable Biblioteca de colores. De forma predeterminada, se selecciona la primera Biblioteca de colores (BibliotecaColoresCoincidentes_1).
  2. Pulse el botón Entrenar colores para abrir el cuadro de diálogo Entrenamiento de colores coincidentes.
  3. En el cuadro de grupo Entrenar seleccione el tipo de región que se utilizará para definir el color. Región, círculo, espacio anular, polígono, dibujo a mano alzada o punto.
  4. Pulse el botón Agregar color nuevo y configure la región dentro de la imagen de forma que solo incluya los valores RGB que desea agregar o restar.
  5. Haga doble clic en la región o pulse el botón OK en la barra de herramientas Editar tarea una vez que haya configurado la región.
  6. Si se desea, renombre el color con un nombre más específico para su aplicación, especialmente si tiene múltiples colores. El color se puede renombrar en cualquier momento resaltando el color y pulsando el botón Renombrar situado sobre el directorio Biblioteca de colores.
  7. Los colores se pueden eliminar de la lista seleccionando el color y pulsando el botón Borrar modelo.
Closed Ajuste de la tolerancia de un color

Si utiliza los controles de Tolerancia de color, puede determinar qué porcentaje del objeto se ha detectado y ajustar los controles de tolerancia de color para aumentar o reducir la sensibilidad de la herramienta utilizando los ajustes en el cuadro de grupo Tolerancia de color de el cuadro de diálogo Entrenamiento de colores coincidentes.

Consejo: Al configurar los controles de Tolerancia de color, coloque el cuadro de diálogo Entrenamiento de colores coincidentes de forma que pueda ver la imagen fácilmente. Mientras ajusta los controles, la imagen se actualizará para reflejar los cambios.

Closed Más oscuro

Especifica el límite de oscuridad (0 a 1,0; valor predeterminado = 1,0). Si el espacio de color se fija en RGB, el límite de oscuridad amplía el color entrenado proporcionalmente menor junto a una línea a partir de (0,0,0) para el valor RGB del color entrenado. Si el espacio de colo se fija en HSI, el límite de oscuridad amplía el valor de intensidad del color entrenado menor.

Closed Más claro

Especifica el límite de claridad (1,0 a 10,0; valor predeterminado = 1,0). Si el espacio de color se fija en RGB, el límite de claridad amplía el color entrenado proporcionalmente mayor junto a una línea a partir de (0,0,0) para el valor RGB del color entrenado. Si el espacio de colo se fija en HSI, el límite de claridad amplía el valor de intensidad del color entrenado mayor.

Closed Edición del modelo de colores
  1. Desde la ficha Ajustes, seleccione Biblioteca de colores para tomar como referencia el menú desplegable Biblioteca de colores.
  2. Pulse el botón Entrenar colores para abrir el cuadro de diálogo Entrenamiento para extraer colores.
  3. Seleccione el modelo de colores para modificar y utilizar los controles en el cuadro de diálogo para editar el modelo de colores.


Candidatos a márgenes

Cuando se utilizan herramientas que incluyen matrices de Calibre, los candidatos a márgenes se identifican con círculos pequeños de colores.

Closed Ejemplo - Línea recta con el mejor ajuste aceptada

Closed Ejemplo - Línea recta con el mejor ajuste rechazada

Closed Ejemplo - Línea circular con el mejor ajuste rechazada


Herramienta de presencia/ausencia Nitidez - ficha Ajustes

Closed Suavidad

Define una operación de suavizado de imágenes (0-2; predeterminado = 0) para ayudar a eliminar el ruido de alta frecuencia que pueda estar presente en la región. Si se pone a 0, no se producirá ningún suavizado y este ajuste proporcionará el funcionamiento más rápido. Si se pone a 1, se aplicará un grado de suavizado que eliminará el ruido de muy altas frecuencias en la región. Si se pone a 2, se aplicará un grado mayor de suavizado que eliminará tanto el ruido de alta frecuencia como el de muy alta frecuencia en la región.