接続

EasyBuilder® ビューへようこそ。EasyBuilder はステップバイステップのアプローチで、マシンビジョンのアプリケーションを構築します。[接続] ステップでは、In-Sight ビジョンシステム、ビジョンセンサやエミュレータに接続したり、設定をしたり、ジョブのビルドを始めたりすることができます。

  • In-Sight ビジョンシステム、ビジョンセンサまたはエミュレータに接続するには
  • EasyBuilder ジョブを新規作成する、またはジョブを開くには
注:
  • ジョブの作成中は、定期的にジョブを保存 (「ファイル」メニュー>「ジョブの保存」または Ctrl+S) してください。[ユーザ] ダイアログの [オンラインでもジョブを保存] チェックボックスを ON にすると、フルアクセスまたはプロテクトのアクセス権を持つユーザは、オンライン中のジョブ保存が許可されます。[オンラインでもジョブを保存] チェックボックスが OFF の場合、ジョブを保存するにはビジョンシステムをオフラインにする必要があります。
  • アクセスレベル、現在使用中のジョブの状態、あるいは接続先 (ビジョンセンサまたはエミュレータなど) の条件によっては、EasyBuilder のアプリケーションステップが薄く表示されたり、グレーアウトしていることがあります。

EasyBuilder ヘルプ

EasyBuilder ヘルプには、パレットヘルプとオンラインヘルプの 2 種類のフォーマットがあります。EasyBuilder パレットヘルプは、パレットの [ヘルプ] タブに表示されます。EasyBuilder オンラインヘルプは、CHM フォーマットのヘルプシステムで、検索機能を持ちます。F1 キーボードを押すか、パレットの [ヘルプ] タブのヘルプ [image] ボタンを押すか、あるいは [ヘルプ] メニューから [EasyBuilder ヘルプ] を選択して、EasyBuilder オンラインヘルプを開きます。

注:
  • EasyBuilder ヘルプファイルには、In-Sight Explorer ヘルプファイルへのリンクが含まれています。EasyBuilder パレットヘルプでこれらのリンクをクリックすると、In-Sight Explorer オンラインヘルプが開き、リンクしたトピックが表示されます。しかし、EasyBuilder オンラインヘルプでこれらのリンクをクリックしても、In-Sight Explorer オンラインヘルプは開かず、リンクしたトピックはEasyBuilder オンラインヘルプ内に表示されます。EasyBuilder オンラインヘルプのトピックに戻るには、[戻る] ボタンを押してください。
  • EasyBuilder オンラインヘルプの[検索] タブを使用して検索すると、In-Sight Explorer オンラインヘルプの検索結果も表示されます。


In-Sight センサまたはエミュレータに接続するには

[In-Sight センサまたはエミュレータの選択] グループボックスに、使用可能な In-Sight センサおよびローカルエミュレータが表示されます。EasyBuilder に一度に接続できるのは、1 台のセンサまたは 1 つのエミュレータのみです。接続後、センサまたはエミュレータの名前が [センサの情報] グループボックスの [接続先] および[モデル番号] フィールドに表示されます。

使用するセンサまたはエミュレータに接続されていない場合は、次のいずれかの操作を行います。

  • 使用するセンサまたはエミュレータをダブルクリックします。
  • 使用するセンサまたはエミュレータを選択してから、[接続] ボタンをクリックします。

現在接続中のセンサまたはエミュレータとの通信を切断する場合は、[切断] ボタンをクリックしてください。

設定ペインのコントロールを使用して、次の作業を行うことができます。

  • リストにないセンサに接続するには
  • ローカルエミュレータのモードを変更するには
注:
  • 使用するセンサまたはエミュレータに他のユーザがすでにログオンしている場合、警告メッセージが表示されます。他のユーザの接続を切断し、ログオンする場合は [はい] を、ログオンをキャンセルして EasyBuilder に戻る場合は [いいえ] をクリックしてください。
  • 使用するセンサまたはエミュレータに接続する権限がない場合、[ログオン/ログオフ] ダイアログが表示されます。

  • センサおよびネットワークに接続できない場合、ネットワークカードに問題がある場合があります。
  • In-Sight ビジョンシステムに接続している場合、モデルタイプによって、使用可能な位置決めおよび検査ツールは異なります。


リストにないセンサに接続するには

接続する必要のあるセンサが物理的にローカルサブネット上に接続されているが、リストに表示されていない場合は、[更新] または [追加] ボタンをクリックしてください (センサのネットワーク設定により異なります)。

  • [更新] ボタンはリストを更新して、ローカルサブネットワークに接続されているすべての In-Sight センサを表示します。
  • [追加] ボタンは [センサ/デバイスをネットワークに追加] ダイアログを開き、フルアクセスの権限を持つユーザに、ローカルサブネットと互換性のないローカルネットワーク上のセンサのネットワーク再設定を許可します。正しく設定されると、センサは自動的にローカルサブネットに追加され、通信を行うことができます。

接続する必要のあるセンサが異なるサブネット上にある場合、[システム] メニューから [Explorer のホストテーブル] を選択して、 [Explorer のホストテーブルの設定] ダイアログを開きます。


ローカルエミュレータのモードを変更するには

  1. [In-Sight センサまたはエミュレータの選択] グループボックスから使用するエミュレータを選択してクリックします。
  2. [エミュレータ] ボタンを押して、[エミュレータのオプション] ダイアログを開きます。ダイアログには、サポートされているすべての In-Sight ビジョンシステムおよびセンサが使用できるツールが含まれています。
  3. [モデル] ドロップダウンリストから、エミュレートする In-Sight センサモデルを選択します。デフォルトでは、[標準] が選択されています。[標準] は、In-Sight ビジョンセンサが備えている主要な機能を提供します。画像解像度は、640×480 です。
  4. 選択後、[OK] を押してエミュレータの設定を変更します。

注: [OK] ボタンをクリックした後、いったん接続を終了して再接続するために、遅延が生じます。


EasyBuilder ジョブを新規作成する、またはジョブを開くには

Closed ジョブの新規作成:
  1. センサがオンラインでないことを確認します。
  2. [ジョブのロード] グループボックスの [ジョブの新規作成] ボタンをクリックするか、または CTRL+N を押して、[ジョブの新規作成] ダイアログを開きます。
  3. ダイアログの [現在のジョブデータはすべて失われます。続けますか？] に対し、[はい] をクリックします。　(現在のジョブを保存する場合、ダイアログの [いいえ] をクリックしてから CTRL+S を押し、ジョブを新規作成する前に「保存」操作を完了します)。

新規作成のジョブ名は、名前を付けて保存されるまで、[センサの情報] グループボックスの [現在のジョブ] フィールドには表示されません。

Closed ジョブを開く:
  1. センサがオンラインでないことを確認します。
  2. [ジョブのロード] グループボックスの [ジョブを開く] ボタンをクリックするか、または CTRL+O を押して、[開く] ダイアログを開きます。
  3. ジョブを選択します。
  4. ジョブをダブルクリックするか、またはジョブを選択してから [開く] をクリックします。
  5. [ジョブを開く] ダイアログが開きます。ダイアログの [現在のジョブデータはすべて失われます。ジョブを開きますか？] に対し [はい] をクリックします。 (現在のジョブを保存する場合、ダイアログの [いいえ] をクリックしてから CTRL+S を押し、ジョブを新規作成する前に「保存」操作を完了しておいてください)。

開いたジョブの名前が [現在のジョブ] フィールドに表示されます。

注:
  • In-Sight 2000 シリーズビジョンセンサで作成されたジョブは、他の In-Sight モデルで作成されたジョブとは互換性がありません。
  • EasyBuilder のみ使用できるビジョンシステムは、スプレッドシートで編集された EasyBuilder ジョブを開くことはできません。
  • In-Sight Explorer のスプレッドシートビューで作成されたジョブは EasyBuilder で開くことはできません。 開こうとすると、アプリケーションステップが薄く表示されたり、グレーアウトされてしまいます。 In-Sight Explorer 環境でジョブを使用するには、EasyBuilder の [表示] メニューから [スプレッドシート] をクリックしてください。
  • In-Sight 4.7.3 以前を使用して作成した EasyBuilder ジョブを、 In-Sight 5.x.x ファームウェアを搭載したビジョンシステムにロードした場合、シンボリックタグ (EasyBuilder タグ) がジョブから削除されてしまうことがあります。


画像の設定

[画像の設定] ステップでは、画像の取り込みやロードを行ったり、In-Sight センサの画像取り込み設定を調整したり、アプリケーションをミリメートルやインチといった実単位に変換する必要がある場合に、キャリブレーションを実行したりすることができます。

  • 画像を取り込み、またはロードするには
  • 画像取り込みの設定を調整するには

  • キャリブレーション (画像単位を実単位に変換) を行うには (In-Sight ビジョンシステム)

    注:このトピックでは、In-Sight ビジョンシステムのキャリブレーション機能について説明します。 In-Sight 2000-130/130C または 2000-23M ビジョンセンサに接続している場合、[画像の設定] の [FOV (幅)] セクションをご参照ください。


画像を取り込み、またはロードするには

[画像取り込み/ロード] グループボックスを使用して、ビジョンシステムから画像を取り込んだり、アクティブなライブビデオ画像を表示したり、以前に取り込んだ画像を PC からロードしたりすることができます。

In-Sight 2000 シリーズビジョンセンサ

  • 画像を取り込み、またはロードするには

In-Sight ビジョンシステム

  • 画像を取り込み、またはロードするには


画像を取り込み、またはロードするには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。 In-Sight ビジョンシステムに接続している場合、画像を取り込み、またはロードするにはを参照してください。

Closed トリガ

[トリガ] ボタンを押して、 単一の画像を取り込みます。 またはキーボードの F5 キーを押すか、EasyBuilder ツールバーの [image] ボタンを押してください。 ([トリガ] コントロールを [手動] に設定する必要があります。)

Closed ライブビデオ

[ライブビデオ] ボタンは、ビジョンセンサをライブ表示にします。ライブ表示にして、ビジョンセンサに装着されたレンズのフォーカスを調整したり、レンズの絞りを調整して露光や輝度を最適にしたりすることができます。 画像にフォーカスが合い、輝度が調整されてコントラストが最大になっている時に、アプリケーションが最適に機能します。

注:
  • [画像] メニューから [ライブビデオ] を選択するか、または EasyBuilder ツールバーの [image] ボタンをクリックして、ライブビデオモードに入ることもできます。 これらのライブビデオのオプションは、すべてのアプリケーションステップで使用することができます。
  • ライブビデオモード中で’も、自動/手動露光、露光時間、最適露光、照明制御モードおよび画像拡大モードの設定の変更を行うことができます。

画像の下に表示されるフォーカスメトリクスは、画像フォーカス得点を決定するのに使用することができます。フォーカスメトリクスは、「シーン」内で認識可能な最小の特徴が画像または画像領域に含まれる度合いを示します。

注:

  • In-Sight 2000 シリーズビジョンセンサに接続している場合、フォーカスメトリクスの [最小]、[最大]、[フォーカス] 値は表示されません。
  • ライブビデオ モード中に、E [image] asyBuilder ツールバーの [フォーカスメトリクス] アイコンを押して、フォーカスメトリクスを非表示にすることができます。 または、[表示] メニューの [フォーカスメトリクス] を選択して、非表示にすることもできます。
Closed フォーカス調整
  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

注: ビジョンセンサはオフラインにてください。

  2. In-Sight 2000 Mini シリーズビジョンセンサを使用している場合、[オートフォーカス] ボタンを使用して自動的にレンズをフォーカスすることができます。 または、検査する特徴がはっきりとした高コントラストとなるように、[フォーカス距離 (%)] スライダーコントロールを使用して、手動でフォーカスを調整することもできます。
  3. 他の In-Sight 2000 シリーズビジョンセンサを使用している場合、検査する特徴がはっきりとた高コントラストとなるように、ビジョンセンサに装着された照明モジュールを手動で調整してください。
  4. 満足のいく画質が得られたら、[ライブビデオ] ボタンを再び押します。
Closed 輝度調整
  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

  2. EasyBuilder ツールバーから、[露光過多・過少を表示] アイコンを押します。 暗すぎる画像エリアは青で表示され、明るすぎる画像エリアは赤で表示されます。

    注: [表示] メニューから、[露光過多・過少を表示] を選択することもできます。

  3. 次のいずれかの方法で、画像の輝度を調整することができます。
  • ビジョンセンサに装着されたレンズの絞りを手動で調整し、赤および青で表示されている画像エリアを最小にします。
  • [露光時間] コントロールを調整して、赤および青で表示されている画像エリアを最小にします。 詳細については、露光時間をご参照ください。
  • [自動露光] を選択します。 詳細については、自動露光をご参照ください。

  4. 満足のいく画質が得られたら、露光過多・過小を表示 [image] アイコンを再び押し、表示を OFF にします。

    注: [表示] メニューから、[露光過多・過少を表示] を選択して、表示を OFF にすることもできます。

Closed PC から画像をロード

[PC から画像をロード] ボタンを押すと、[記録再生のオプション] ダイアログが開き、ビジョンセンサまたはエミュレータの記録および再生を設定することができます。 ダイアログの設定が済むと、指定の [記録フォルダ] および [再生フォルダ] に保存された画像を記録および再生することができます。

注:
  • ジョブ実行時のモニタリングおよびデバッグ用に、PC ではなく、ビジョンセンサに画像を保存することができます。[フィルムストリップ] アプリケーションステップで [センサの設定] を使用して設定してください。

  • PC にカラー画像を記録する場合、24 ビット画像でなく、16 ビット画像で保存されます。カラー画像を使用して、カラーツールをテストする必要がある場合、FTP 経由で画像をエクスポートし ([通信] アプリケーションステップで FTP デバイスを追加します) 、画像を保存することによってフルカラーを保持することができます。
Closed [再生] タブ

[再生] タブを設定してから、PC のフィルムストリップの [再生] ボタンを押すと、PC 上の指定の [再生] フォルダに保存された画像はビジョンシステムに送信され、再生中の画像に対してジョブが実行されます。デフォルトでは、再生フォルダは EasyBuilder Sample Jobs フォルダを参照します。

Closed [記録] タブ

[記録] タブを設定してから、EasyBuilder ツールバーの [記録] ボタンを押すと、画像が取り込まれ、PASS および FAIL 画像が記録され、PC 上の指定の [再生] フォルダに保存されます。オンラインまたはオフラインのビジョンシステムから、書き込み権限を持つ PC 上の任意のフォルダに結果を保存することができます。 PC に保存できる画像の数は最大 10,000 です。


画像を取り込み、またはロードするには

[画像取り込み/ロード] グループボックスを使用して、ビジョンシステムから画像を取り込んだり、アクティブなライブビデオ画像を表示したり、以前に取り込んだ画像を PC からロードしたりすることができます。

Closed トリガ

[トリガ] ボタンは、ビジョンシステムから単一の画像を取り込むのに使用されます。 [トリガ] ボタンを押して、単一の画像を取り込みます。 またはキーボードの F5 キーを押すか、EasyBuilder ツールバーの [image] を押してください。 ([画像取り込みの設定] グループボックスの [トリガ] コントロールを [手動] に設定する必要があります。)

Closed ライブビデオ

[ライブビデオ] ボタンはビジョンシステムをライブ表示にします。ライブ表示にして、ビジョンシステムに装着されたレンズのフォーカスを調整したり、露光や輝度を調整したりすることができます。 画像にフォーカスが合い、輝度が調整されてコントラストが最大になっている時に、アプリケーションが最適に機能します。

画像の下に表示されるフォーカスメトリクスは、画像フォーカス得点を決定するのに使用することができます。フォーカスメトリクスは、「シーン」 (その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像または画像領域に含まれる度合いを示し、[フォーカス領域] ボタンを使用して定義します。

注:
  • 関連するデータを提供するには、まったく同一のシーンから取得した別の画像のフォーカスメトリックス得点と比較する必要があります。
  • ライブビデオモード中に、EasyBuilder ツールバーの [フォーカスメトリクス] [image] アイコンを押して、フォーカスメトリクスを非表示にすることができます。
Closed フォーカス調整
Closed In-Sight 5000 シリーズ、In-Sight Microシリーズおよび C マウントレンズ装着の In-Sight 7000 シリーズビジョンシステムおよび 8000 シリーズビジョンシステム
  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

注: ビジョンシステムはオフラインにてください。

  2. 検査する特徴がはっきりとた高コントラストで、許容可能なフォーカスメトリクス得点となるように、ビジョンセンサに装着されたレンズのフォーカスリングを手動で調整します。
  3. 満足のいく画質が得られたら、[ライブビデオ] ボタンを再び押します。
  4. 最後に取り込まれた画像が表示されます。
Closed オートフォーカス M12 レンズを装着した In-Sight 7000 シリーズビジョンシステム

注:[フォーカス制御] は、In-Sight Explorer 4.7.3 以降、In-Sight ファームウェア4.7.3 以降を使用している In-Sight 70xx - 74xx シリーズビジョンシステムで使用可能です。

  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。

注: ビジョンシステムはオフラインにてください。

  2. [オートフォーカス] ボタンを押すか、あるいは検査する特徴がはっきりとた高コントラストで、許容可能なフォーカスメトリクス得点となるように、フォーカス位置スライダを手動で調整します。

注: [オートフォーカス] ボタンを押すと、フォーカス位置スライダおよび [フォーカスの保存] ボタンは無効となります。

  3. [オートフォーカス] ボタンを押すと、フォーカス位置の値は更新され、新しい画像が表示されます。
  4. 満足のいく画質および得点が得られたら、[フォーカスの保存] ボタンを押します。 現在のフォーカス位置がデフォルトのフォーカス位置として保存され、ビジョンシステムを再起動すると現在の位置に自動的にレンズが移動します。
Closed 輝度調整
  1. [ライブビデオ] ボタンを押すか、 EasyBuilder ツールバーの [image] ボタンを押してください。
  2. EasyBuilder ツールバーから、[露光過多・過少を表示] アイコンを押します。 暗すぎる画像エリアは青で表示され、明るすぎる画像エリアは赤で表示されます。
  3. 次のいずれかの方法で、画像の輝度を調整することができます。
  • ビジョンシステムに装着されたレンズの絞りを手動で調整し、赤および青で表示されている画像エリアを最小にします。
  • [画像取り込みの設定] グループボックスの [露光時間] コントロールの数字を大きくし、赤および青で表示されている画像エリアを最小にします。
  • [画像取り込みの設定] グループボックスの [自動露光] ドロップダウンメニューから　[連続] または [シングルショット] を選択します。 [連続] は、画像が取り込まれるたびにビジョンシステムをアクティブにし、照明の状態に基づいて自動的に露光を調整します。 [シングルショット] は、最初に取り込まれた画像を基に露光を調整します。この露光時間の値は、その後、画像が取り込まれても変更されません。
  4. 満足のいく画質が得られたら、露光過多・過小を表示 [image] アイコンを再び押し、表示を OFF にします。
Closed PC から画像をロード

[PC から画像をロード] ボタンを押すと、[記録再生のオプション] ダイアログが開き、ビジョンセンサまたはエミュレータの記録および再生を設定することができます。 ダイアログの設定が済むと、指定の [記録フォルダ] および [再生フォルダ] に保存された画像を記録および再生することができます。

注:
  • ジョブ実行時のモニタリングおよびデバッグ用に、PC ではなく、ビジョンシステムに画像を保存することができます。[フィルムストリップ] アプリケーションステップで [センサの設定] を使用して設定してください。

  • PC にカラー画像を記録する場合、24 ビット画像でなく、16 ビット画像で保存されます。カラー画像を使用して、カラーツールをテストする必要がある場合、FTP 経由で画像をエクスポートし ([通信] アプリケーションステップで FTP デバイスを追加します) 、画像を保存することによってフルカラーを保持することができます。
Closed [再生] タブ

[再生] タブを設定してから、PC のフィルムストリップの [再生] ボタンを押すと、PC 上の指定の [再生] フォルダに保存された画像はビジョンシステムに送信され、再生中の画像に対してジョブが実行されます。 デフォルトでは、再生フォルダは EasyBuilder Sample Jobs フォルダを参照します。

注:[再生] フォルダは、デフォルトでEasyBuilder サンプルジョブフォルダを参照しています。これらのサンプルジョブを使用して、[記録再生のオプション] の便利な使い方についてデモンストレーションを行うことができます。記録再生のオプションは、以前に取り込んだ画像を繰り返し再生し、ツール結果を即時に表示することから、しきい値や制限の設定を短時間で行うことができます。

Closed [記録] タブ

[記録] タブを設定してから、EasyBuilder ツールバーの [記録] ボタンを押すと、画像が取り込まれ、PASS および FAIL 画像が記録され、PC 上の指定の [再生] フォルダに保存されます。 オンラインまたはオフラインのビジョンシステムから、書き込み権限を持つ PC 上の任意のフォルダに結果を保存することができます。 PC に保存できる画像の数は最大 10,000 です。


画像取り込みの設定を調整するには

[画像取り込みの設定] グループボックスのコントロールを使用して、画像取り込みトリガのコントロールを調整したり、露光および輝度の補正を行ったり、In-Sight センサの照明をコントロールすることができます。

In-Sight 2000 シリーズビジョンセンサ

  • 画像の設定

In-Sight ビジョンシステム

  • トリガ制御
  • 露光制御
  • 画像センサ転送制御
  • 照明制御
  • ホワイトバランス
  • フォーカス領域
  • フォーカス制御
  • 画像の設定
  • ラインスキャンの設定


画像の設定

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。 In-Sight ビジョンシステムに接続している場合、画像取り込みの設定を調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

トリガ

[トリガ] コントロール ([種類]、[遅延] および [間隔]) を使用して、画像を取得したり、検査を実行したりする方法やタイミングをカスタマイズすることができます。

Closed 種類

ドロップダウンメニューから、In-Sight センサのオンライン時に、画像を取り込むソースを指定することができます。

カメラ | ビジョンセンサの専用取り込みトリガ入力において検出される、立ち上がりエッジで画像取り込みを有効にします。
連続 (デフォルト) | 「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。
手動 | F5 キーが押されたときに、画像取り込みを有効にします。 注: ビジョンセンサの TRG ボタンを押して、センサにトリガをかけることができます。
産業用イーサネット | EtherNet/IP、PROFINET または SLMP スキャナなどの産業用イーサネットプロトコルからのトリガを有効にします。
Closed 遅延 (msec)

トリガを受信してから In-Sight ビジョンセンサが画像取り込みを始めるまでの、遅延時間をミリ秒単位で指定することができます (0～10,000) 。 [トリガ] タイプは、[カメラ] に設定する必要があります。

注:
  • 遅延は、1 ミリ秒から最大ライン露光時間 (64 マイクロ秒) を引いた値から、要求されたミリ秒数に最大ライン露光時間を足した値までの範囲です。
  • [入力/出力] ステップの [信号のタイプ] で、[画像取り込み開始] が選択された場合、指定時間分、出力が遅延します。
Closed 間隔 (msec)

[トリガ] を [連続] に設定した場合、画像取り込み間隔をミリ秒単位で指定することができます (0～10,000、デフォルトは 0) 。

注: この遅延は、画像処理を完了するのに必要な時間によって異なります。 例えば、[トリガ間隔] を 500 ミリ秒に設定した場合、ジョブが 500 ミリ秒以内に画像処理を完了する条件で、In-Sight ビジョンセンサは画像を 500 ミリ秒ごとに取り込みます。 そうでなければ、In-Sight ビジョンセンサは画像処理が完了した時点で画像を取り込みます。

フォーカス (オートフォーカス機能付き In-Sight 2000 ビジョンセンサのみ)

[フォーカス] タブを使用して、自動的にレンズのフォーカスを合わせたり、特定のフォーカス位置にレンズを移動したりして、サポートされているオートフォーカス機能付き In-Sight 2000 ビジョンセンサのレンズのフォーカス位置を制御します。

Closed オートフォーカス領域

レンズを自動的にフォーカスするときに使用する、画像領域を指定します。 [オートフォーカス領域] ボタンを押して、領域を設定してください。

Closed [オートフォーカス] ボタン

自動的にレンズの焦点を合わせ、領域内の画像シャープネスを最大にします。

Closed ジョブロード時にオートフォーカスを実行
  • OFF (デフォルト): 現在の [フォーカス距離 (%)] をジョブに保存します。
  • ON: ジョブがロードされたときに、ビジョンセンサはレンズを自動的にフォーカスします。
Closed フォーカス距離 (%)

手動でフォーカス位置を調整します (0～100%。デフォルト: 6.2mm レンズ = 66%、16mm レンズ = 69.2%)。 ビジョンセンサの近くに置かれた対象物にフォーカスするには、ハンドルを左に (0% のほうに) 動かします。 ビジョンセンサの遠くに置かれた対象物にフォーカスするには、ハンドルを右に (100% のほうに) 動かします。 ライブビデオモードのステータスに関わらず、ハンドルを動かすことができます。

注: 0% は、最も近いフォーカス面を表します。 例えば、対象物がビジョンセンサに非常に近い時、0% となります。 100% は、最も遠いフォーカス面を表します。これは、本質的に「無限遠焦点」です。

照明

注: 条件によっては、オートフォーカス機能付き　In-Sight 2000 ビジョンセンサの照度が、他の In-Sight 2000 シリーズビジョンセンサーの照度よりも暗くなることがあります。

Closed 自動露光

画像取り込みごとに、露光を自動的に計算します。 光を乱反射する金属物など、影が動き背景の照明が変化するといった照明のばらつきを調整することができます。 [自動露光] はデフォルトで OFF になっています。

Closed 手動露光

画像取得の際に使用する、固定された露光値を設定します。 手動露光はデフォルトで ON になっています。 OFF にするには、[自動露光] を ON にしてください。

Closed 画像の目標輝度

輝度レベル (0～100、デフォルト = 50) を指定することができます。値は、ハンドルを調整したり、対応する編集ボックスに値を入力したりして調整できます。 値は、露光領域内で許容される飽和状態 (＝白) のピクセルのパーセンテージです。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

Closed 露光時間 (msec)

画像取得時の露光時間を設定します (0.000 ～ 1000.000; デフォルト = 0.250)。 露光時間が長いほど、取り込まれた画像の輝度が高くなります。 このコントロールは、[自動露光] が選択されている場合、無効となります。

Closed 照明輝度
注: [照明輝度] スライダーバーは、In-Sight 2000 Mini シリーズビジョンセンサではサポートされていません。

LED の輝度レベルをパーセンテージで指定することができます (0～100、デフォルト = 70、OFF = 0)。値は、ハンドルを調整したり、対応する編集ボックスに値を入力したりして調整できます。 輝度はジョブに保存されます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

青い背景は、現在の設定で使用可能な最大輝度値を示します。 最大照明輝度値は、[画像の目標輝度]、[露光時間]、[画像エリアの高さ]、[画像拡大モード] などの、他の画像の設定によって異なります。

注: スライダコントロール上にマウスポインタを重ねると、最大値が表示されます。

Closed [露光領域] ボタン (領域の設定)

露光時間の自動計算に使用される領域を指定します。

注: [デフォルト領域にリセット] ボタンをクリックして、デフォルト設定に戻すことができます。

Closed 最適露光

自動的に露光時間を最適化します。 最適化後、画像取り込み時に、常に同じ露光時間が使用されます。

Closed 照明制御モード

[ON (露光)] は、露光時間中のみリング照明を点灯します。 [OFF] に設定した場合、照明は OFF となり、センサは周囲 (室内) の照明に依存することになります。

ホワイトバランス (In-Sight 2000 カラーセンサのみ)

Closed [ホワイトバランス領域] および [ホワイトバランスの設定]

画像の赤、緑および青 (RGB) 値を計算し補正を行うことによって、カラー画像からカラーキャスト (色かぶり) を削除します。 その結果、白いアイテムが画像でも白く表示されます。

新規ジョブを作成すると、最後に実行されたホワイトバランス設定が使用されます。 ホワイトバランス設定はジョブに保存され、ジョブがロードされるとホワイトバランス設定がリストアされます。

注:
  • ホワイトバランスの設定は、手動露光中に行ってください。

  • [照明輝度] パラメータを大幅に変更した場合、最も正確なカラーを画像に再現するため、ホワイトバランスを再度実行してください。

  1. マット仕上げの白い紙など、平らなテストオブジェクトに対し、In-Sight ビジョンセンサのフォーカスを合わせ、照明制御を設定してください。この際、露光過多にならないようにしてください。

  2. [ホワイトバランス領域] ボタンをクリックし、明るいピクセルのみを含む領域を囲んでください。この時、『ホットスポット』が領域に入らないようにしてください。

    注: [デフォルト領域にリセット] ボタンをクリックして、画像全体を含むようにすることができます。

  3. [ホワイトバランスの設定] ボタンをクリックします。 その後、この設定を使用して、画像が取り込まれます。
ホワイトバランス前 | ホワイトバランス | ホワイトバランス後

画像

Closed 画像エリアの高さ

画像を取り込む際の、取り込み行数を指定します。対象エリアが画像内の同じ帯に常に制限されている場合に使用できます。 左ハンドル (開始行) や右ハンドル (終了行) を調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

In-Sight モデル | 解像度 | 開始行の値 | 終了行の値
2000-110 2000-110 Mini | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
2000-120 & 2000-120C 200-120 Mini & 2000-120C Mini | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
2000-1301 & 2000-130C1 2000-130 Mini 1 & 2000-130C Mini1 | 640 ✕ 480 (デフォルト) | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
 | 800 ✕ 600 | 0～599 (デフォルト = 0) | 0～599 (デフォルト = 599)
2000-23M1 | 640 ✕ 480 | 0～479 (デフォルト = 0) | 0～479 (デフォルト = 479)
 | 800 ✕ 600 (デフォルト) | 0～599 (デフォルト = 0) | 0～599 (デフォルト = 599)
1解像度は、[画像の設定] ダイアログで設定できます。
Closed 画像拡大モード

[画像拡大モード] を ON にします。 ON にすると FOV は 50% 減少し、光解像度は 200% に増加します。

In-Sight モデル | 解像度 | 画像拡大モード
2000-110 2000-110 Mini | 640 ✕ 480 | サポートされていません
2000-120 & 2000-120C 2000-120 Mini & 2000-120C Mini | 640 ✕ 480 | ON/OFF に設定可
2000-1301 & 2000-130C1 2000-130 Mini1 & 2000-130C Mini1 | 640 ✕ 480 (デフォルト) | ON/OFF に設定可
 | 800 ✕ 600 | 常に ON
2000-23M1 | 640 ✕ 480 | ON/OFF に設定可
 | 800 ✕ 600 (デフォルト) | 常に ON
1解像度は、[画像の設定] ダイアログで設定できます。

画像拡大モード 無効 | 画像拡大モード 有効
Closed キャリブレーションタイプ

検査ツールをピクセルから実単位に変換またはキャリブレートします。 2 つのオプション ([FOV (幅)] または [インポート] ) があります。

注:

  • [FOV (幅)] は、次のビジョンセンサでのみ使用できます: In-Sight 2000-130、2000-130C、2000-130 Mini、2000-130C Mini および 2000-23M。
  • [インポート] オプションは、In-Sight 2000-23M ビジョンセンサでのみ使用できます。
Closed FOV (幅)

寸法測定ツールの結果を、ピクセルから実単位 (ミリメートル、センチメートルまたはインチ) に変換します。

FOV (幅) = 640 ピクセル/ 125 ミリメートル
  1. [キャリブレーションタイプ] ドロップダウンメニューから、[FOV (幅)] を選択します。
  2. ドロップダウンメニューから使用する実単位 (ミリメートル、センチメートルまたはインチ) を選択します。 デフォルトでは [ピクセル] が選択されており、値を変更することはできません。
  3. FOV (視野) の値を選択した単位で可能な限り正確に計測し、その値を入力します。

  4. 入力後、すぐに単位が変換されます。 例えば、FOV (幅) を 125 ミリメートルに設定し、2 つのエッジの幅が 490 ピクセルである場合、結果は 95.703mm を返します。

    注: 以下に、数式および例で実際に使用された計算方法を示します。
    • FOV (実単位) / FOV (ピクセル) * 測定値 (ピクセル) = 結果 (実単位)
    • 125/640*490 = 95.703mm
Closed インポート

[インポート] キャリブレーションタイプを使用して、N 点キャリブレーションツールで作成したキャリブレーションファイルをロードしたり、In-Sight ビジョンセンサのローカルファイルシステムにエクスポートしたりすることができます。 インポートされたキャリブレーションファイルは、ロード次第、自動的にジョブをキャリブレーションします。

注: [キャリブレーションタイプ] から [インポート] を選択する前に、まず N 点キャリブレーションツールをジョブに追加、設定してください。その後、キャリブレーションファイルを In-Sight ビジョンセンサのローカルファイルシステムにエクスポートしてください。

N 点キャリブレーションツールは、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。 このツールは、以下の変換を行います。

  • 2 次元での変換 (5 つ以上の点を使用) 。
  • 3 つの軸についての回転 (4 つ以上の点を使用) 。
  • 2 次元でのスケール (2 つ以上の点を使用) 。
  • 平行四辺形化またはスキュー (4 つ以上の点を使用) 。
  • 平行四辺形化またはスキュー (4 つ以上の点を使用) 。

使用法

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[インポート] を選択します。
  2. EasyBuilder は、N 点キャリブレーションツールで生成されたキャリブレーションファイルがジョブに含まれているかどうかを調査し、キャリブレーションファイルをロードします。 1 個以上のキャリブレーションファイルを作成した場合、[ファイル名] ドロップダウンメニューから使用するファイルを選択してください。
  3. [単位] ドロップダウンメニューからキャリブレーションを定義する実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  4. このオプションが選択されるとすぐにキャリブレーションが実行され、値が設定されます。


トリガ制御

[トリガ]、[トリガ遅延] および [トリガ間隔] を使用して、いつ、どのように画像が取り込まれるかをカスタマイズすることができます。

  • [トリガ]: In-Sight ビジョンシステムのオンライン時に、画像を取り込むソースを指定することができます。

    • カメラ (デフォルト): ビジョンシステムの専用取り込みトリガ入力において検出される、立ち上がりエッジで画像取り込みを有効にします。
    • 連続: 「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。

    • 外部: シリアルコマンド、または画像取り込みトリガとして設定されているディスクリート入力ビットが立ち上がりエッジになったときの、いずれかで画像取り込みを有効にします。

      注:

      • ビジョンシステムの内蔵画像取り込みトリガ入力 ([トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
      • [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] 出力は、ビジョンシステムから送信されません。[エラー: 画像取り込みミス] 信号は、[トリガ] パラメータを [カメラ] に設定したときのみ送信されます。
    • 手動: F5 キーが押されたときに、画像取り込みを有効にします。
    • 産業用イーサネット: 産業用イーサネットプロトコルによるトリガを有効にします (EtherNet/IP、POWERLINK、Profinet、SLMP スキャナ)。
    • タイムスタンプ: PLC から EtherNet/IP を介し、ビジョンシステムにタイムスタンプトリガが送信されたときに、画像取り込みを有効にします。 [タイムスタンプ] オプションは次のビジョンシステムのみでサポートされています。
      • In-Sight 7000 Gen2 シリーズビジョンシステム

      • 128MB 以上の不揮発性フラッシュメモリを持ち、ファームウェアバージョン 4.5.0 以降を搭載した In-Sight 5000 シリーズビジョンシステム

        注: In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステムおよび In-Sight 5705C ビジョンシステムではサポートされていません。
      • In-Sight 9902L ラインスキャンビジョンシステム

  • [トリガ遅延]: トリガを受信してからビジョンシステムが画像取り込みを始めるまでの、遅延時間をミリ秒単位で指定することができます (0～10,000)。

    注:

    • この機能を有効にするには、[トリガ] を [カメラ] または [ネットワーク] に設定する必要があります。
    • 遅延は、要求されたミリ秒数から最大ライン露光時間 (64 マイクロ秒) を引いた値から、要求されたミリ秒数に最大ライン露光時間を足した値までの範囲です。
    • [入力/出力] ステップの [信号のタイプ] で、[画像取り込み開始] または [ストロボ] が選択された場合、指定時間分、出力が遅延します。

  • [トリガ間隔]: [トリガ] を [連続] に設定した場合、画像取り込み間隔をミリ秒単位で指定することができます (0～10,000、デフォルトは 500)。

    注: この遅延は、画像処理を完了するのに必要な時間によって異なります。 例えば、[トリガ間隔] を 5,000 ミリ秒に設定した場合、ジョブが 5,000 ミリ秒以内に画像処理を完了する条件で、In-Sight ビジョンシステムは画像を 5,000 ミリ秒ごとに取り込みます。 そうでなければ、In-Sight ビジョンセンサは画像処理が完了した時点で画像を取り込みます。


露光制御

露光制御を使用して、照明のばらつきと輝度のバランスを調整し、検査に使用する特徴を最大限に際立たせるように、アプリケーションをカスタマイズすることができます。

Closed 露光時間

[露光時間] を使用して、露光時間を指定することができます。 In-Sight ビジョンシステムがトリガ信号を受信すると、指定された露光時間の間、イメージャーに光が蓄積されます。

注:

  • In-Sight 5604、5614 または 9902L ラインスキャンビジョンシステムに接続されている場合、露光時間はマイクロ秒 (µsec) 単位で設定されます。

  • このパラメータが技術的に 0 に設定されている場合、露光時間は In-Sight ビジョンシステムに依存します。露光時間の値が 0 の場合は、デフォルトで、選択したビジョンシステムの最小露光時間 (ミリ秒またはマイクロ秒単位) となります。

In-Sight モデル | 解像度 | レンズ | 露光時間 (ms)
In-Sight Micro 1020, 1050, 1100, 1110, 1100C, 1400, 1410, 1400C | 640 ✕ 480 | CCD、グローバルシャッタ | 0.016～1000
In-Sight Micro 1402, 1412 | 1280 ✕ 1024 | CMOS、グローバルシャッタ | 0.016 ～ 950
In-Sight Micro 1403, 1413, 1403C | 1600 ✕ 1200 | CCD、グローバルシャッタ | 0.052 ～1000
In-Sight Micro 15001 | 640 ✕ 480 | CMOS、グローバルシャッタ | 0.004 ～ 500
 | 800 ✕ 600 | CMOS、グローバルシャッタ | 0.005 ～ 500
In-Sight 2000-110, 2000-120, 2000-120C, 2000-130, 2000-130C，2000-110 Mini, 2000-120 Mini, 2000-120C Mini, 2000-130 Mini, 2000-130C Mini, 2000-23M1 | 640 ✕ 480 | CMOS、グローバルシャッタ | 0.001 ～ 1000
In-Sight 2000-130, 2000-130C, 2000-130 Mini, 2000-130C Mini, 2000-23M1 | 800 ✕ 600 | CMOS、グローバルシャッタ | 0.001 ～ 1000
In-Sight 5100, 5110, 5100C, 5400, 5410, 5400C, 5600, 5610 | 640 ✕ 480 | CCD、グローバルシャッタ | 0.016～1000
In-Sight 5403, 5413, 5603, 5613 | 1600 ✕ 1200 | CCD、グローバルシャッタ | 0.027 ～ 1000
In-Sight 5604, 5614 ラインスキャン2 | 1024 ✕ 1 | CCD、グローバルシャッタ | 1.33 ～ 1000 µs
In-Sight 5605, 5615, 5705, 5715 | 2448 ✕ 2048 | CCD、グローバルシャッタ | 0.014 ～ 1000
In-Sight 5705C | 2448 ✕ 2048 | CCD、グローバルシャッタ | 0.016～1000
In-Sight 7010, 7010C, 7020, 7050, 7200, 7210, 7230, 7200C, 7400, 7410, 7430, 7400C | 800 ✕ 600 | CMOS、グローバルシャッタ | 0.016 ～ 950
In-Sight 7402, 7412, 7432, 7402C | 1280 ✕ 1024 | CMOS、グローバルシャッタ | 0.016 ～ 950
In-Sight 7600, 7600C, 7800, 7800C, 7900, 7900C1 | 800 ✕ 600 | CMOS、グローバルシャッタ | 0.014 ～ 550
 | 640 ✕ 480 | CMOS、グローバルシャッタ | 0.014 ～ 520
In-Sight 7801, 7801C, 7901, 7901C | 1280 ✕ 1024 | CMOS、グローバルシャッタ | 0.017 ～ 750
In-Sight 7802, 7802C, 7902, 7902C1 | 1600 ✕ 1200 | CMOS、グローバルシャッタ | 0.020 ～ 940
 | 800 x 600 (低照明モード) | CMOS、グローバルシャッタ | 0.020 ～ 940
In-Sight 7905, 7905C | 2448 ✕ 2048 | CMOS、グローバルシャッタ | 0.021 ～ 1000
In-Sight 8200, 8200C, 8400, 8400C | 640 ✕ 480 | CMOS、グローバルシャッタ | 0.014 ～ 520
In-Sight 8401, 8401C | 1280 ✕ 1024 | CMOS、グローバルシャッタ | 0.0174 ～ 750
In-Sight 8402, 8402C | 1600 ✕ 1200 | CMOS、グローバルシャッタ | 0.020 ～ 940
In-Sight 84053 | 2592 ✕ 1944 | CMOS、ローリングシャッタ | 0.032～1000
In-Sight 9902L ラインスキャン2 | 2048 ✕ 1 | CMOS、グローバルシャッタ | 2.00 µsec～1000 µsec
 | 1024 ✕ 1
1解像度は [画像の設定] ダイアログで設定することができます。 21K 解像度 (低照明モード) および最大画像高は [ラインスキャンの設定] ダイアログで設定することができます。 3 In-Sight Micro 8405 でストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、ローリングシャッターの操作をご参照ください。
Closed 自動露光

[自動露光] を使用して、In-Sight ビジョンシステムが自動的に露光を設定できるようにします。 光を乱反射する金属物などのように、画像のコントラストが大きく変化するアプリケーションや、影が動き背景の照明が変化するといった照明のばらつきに対して、露光時間を自動で調整することができます。

  • [連続]: 照明の状態を基にして、画像取り込みごとに自動的に露光を調整します。

    注: [連続] モードでは、画像取り込みの間隔を別途設定できます。
  • [シングルショット]: 最初に取り込まれた画像を基に露光を調整します。この露光時間の値は、その後、画像が取り込まれても変更されません。
    • [最初の画像取り込み]: ビジョンシステムがオフラインの場合、最初の取り込みは露光時間の決定のために使用されます。この露光時間の値は、シングルショットが無効にされるまで保存されます。 ビジョンシステムがオフラインの間に取り込みが行われなかった場合、ビジョンシステムをオンラインにしたときの最初の取り込みが露光時間の決定に使用されます。
    • [2 回目以降の画像取り込み]: ビジョンシステムは、最初の取り込みで計算された露光時間の値を使用して、画像を取り込みます。

    注:

    • ビジョンシステムまたはビジョンセンサがこの機能をサポートしない場合、表示されません。
    • 異なる [自動露光] モードを選択すると、露光時間の値がリセットされます。 露光時間のリセット後に行われた最初の取り込みは、新しい露光時間の値を決定するために使用されます。
Closed [露光領域] ボタン

露光時間の自動計算に使用される領域を指定します。

注:この機能を有効にするには、[自動露光] ドロップダウンリストから、[連続] または [シングルショット] を選択してください。
Closed 露光時間

適切な露光時間の決定の際に使用される最大露光時間を指定することができます。

Closed 画像の目標輝度

輝度レベル (0～100) を指定することができます。

注:この機能を有効にするには、[自動露光] ドロップダウンリストから、[連続] または [シングルショット] を選択してください。


画像センサ転送制御

画像センサ転送制御を使用して、画像転送を開始する画像センサ (CCD または CMOS) の行や、画像を生成するのに使用される画像センサの行数を定義することができます。

In-Sight ビジョンシステムは、非同期リセットとプログレッシブスキャンを使用してすべての画像を取り込みます。グレースケールの In-Sight ビジョンシステムは 8 ビットの画像を生成し、カラーの In-Sight ビジョンシステムは 24 ビットの画像を生成します。すべてのビジョンシステムで約 250µs 以内に画像取り込みが開始され、次のように進行します。

  1. 画像センサは、[露光時間] 制御で設定された時間の間、光を蓄積します。
  2. 画像センサに蓄積された画像は行単位でシリアルシフトレジスタに転送されます。
  3. すべての行転送に対し、センサはピクセルごとに画像センサ外部でシフトレジスタをクロッキングして、ピクセル値を転送します。
  4. 転送は取り込み開始行から開始され、指定された行数が処理されます。
Closed 取り込み開始行

画像センサから In-Sight ビジョンシステムのメモリに転送される最初の行を定義します。

解像度 | 有効な取り込み開始行の値
640 ✕ 480 | 0～479
800 ✕ 600 | 0 ～ 599
1024 ✕ 768 | 0～767
1280 × 1024 | 0 ～ 1023
1600 ✕ 1200 | 0～1199
2448 ✕ 2048 | 0～2047
2592 ✕ 1944 | 0～1943
Closed 取り込み行数

In-Sight ビジョンシステムのメモリに転送される行数を定義します。

解像度 | 許容される行数
640 ✕ 480 | 1 ～ 480
800 ✕ 600 | 1 ～ 600
1024 ✕ 768 | 1 ～ 768
1280 ✕ 1024 | 1 ～ 1024
1600 ✕ 1200 | 1～1200
2448 ✕ 2048 | 1～2048
2592 ✕ 1944 | 1～1944

注: エミュレータ に接続し、部分画像取り込みパラメータを有効にして In-Sight ビジョンシステムが取り込んだ画像を表示する場合、エミュレータの[取り込み開始行] および [行数] パラメータは、In-Sight ビジョンシステムのパラメータと同じに設定してください。


照明制御

照明制御を使用して、In-Sight ビジョンシステムの LED 照明バンクおよびリングを設定することができます。

注:この機能を有効にするには、[自動露光] ドロップダウンリストから、[連続] または [シングルショット] を選択してください。

Closed 照明制御モード (In-Sight 5000 シリーズおよび In-Sight 70xx～74xx シリーズのみ)

[照明制御モード] は、In-Sight 5000 シリーズまたは 70xx～74xx シリーズビジョンシステムのリング照明を、指定された露光時間のみ点灯するか、常に点灯しておくかを指定します。 [ON (露光)] は、露光時間中のみリング照明を点灯します。 [常に ON] は、リング照明を常に点灯し、画像を露光していないときに 50% の輝度で LED を点灯し続けることにより、ストロボの効果を低減させます。

Closed 照明制御 (In-Sight 5000 シリーズのみ)

In-Sight ビジョンシステムの LED 照明バンクを最大 4 つまで制御します。

Closed 例 - In-Sight 5000 センサシリーズのリング照明

  • [水平] は、水平 LED バンク × 2 を有効にします。
  • [垂直] は、垂直 LED バンク × 2 を有効にします。
  • [すべて] は、水平および垂直 LED バンク (各 2) を有効にします。
Closed 照明輝度 (In-Sight 70xx～74xx シリーズのみ)

LED の輝度を制御します。 輝度はジョブに保存されます。

  • In-Sight 70xx～74xx シリーズビジョンシステム: 0 ～ 100、デフォルト =1、OFF = 0
Closed ゲイン (In-Sight 7000 シリーズのみ)

A/D コンバータの前段の増幅器のゲインを制御します。

In-Sight モデル | ゲインの設定
70xx ～ 74xx シリーズ | 0 ～ 7; デフォルト = 0
7600、7600C、7800、7800C、7801、7801C、7802、7802C、7900、7900C、7901、7901C、7902、7902C | 0 ～ 6; デフォルト = 0
7905、7905C | 0 ～ 255; デフォルト = 60


ホワイトバランス (In-Sight カラービジョンシステムのみ)

注: このトピックでは、In-Sight カラービジョンシステム接続時のホワイトバランス機能について説明します。 In-Sight 2000 シリーズカラービジョンセンサに接続している場合、画像の設定のホワイトバランスセクションをご参照ください。

カラーの In-Sight センサおよびカラーを有効にしたエミュレータを使用している場合のみ、[ホワイトバランス] ボタンを使用することができます。[ホワイトバランス] は、画像の赤、緑および青 (RGB) 値を計算し、In-Sight ジョブに保存されたカラーテーブルに従って補正を行うことによって、画像のカラーキャスト (色かぶり) を削除します。 その結果、白いアイテムが画像でも白く表示されます。

ホワイトバランス前 | ホワイトバランス | ホワイトバランス後

基準となるニュートラル (灰色) 画像を取り込んで、カラーテーブルを作成します。画像全体に 18-18-18 のような均一の RGB 値を持つ灰色の画像をニュートラル画像と呼びます。このとき、画像を飽和状態 (255-255-255) にしないでください。 続いて [ホワイトバランス] ボタンを押すと、EasyBuilder は各カラーチャネル (赤、緑、青) のヒストグラムを作成します。そして、最も大きな値を各チャネルの値で割ることでスケールファクタ (倍率) を求め、これを RGB 値の均等化に使用します。例えば、200-100-50 の RGB 値によって、1-2-4 倍のスケールファクターが求められます。

使用中のセンサのカラーテーブル設定は、ジョブファイルに保存されています。 適切なホワイトバランス情報を画像に適用するには、画像のロードや取り込みの前にジョブをロードする必要があります。

ホワイトバランス機能を使用するには、次の手順に従います。

  1. 黒い印字のある白紙の断片など、平らなテストオブジェクトに対し、In-Sight センサのフォーカスを合わせ、[画像の目標輝度] を設定します。

    注: [ホワイトバランス領域] ボタンを使用して、画像のホワイトバランスを計算する領域を指定します。 [ホワイトバランス領域] ボタンを押して、領域を指定してください。

  2. テストオブジェクトの上に、白紙の紙などほかのオブジェクトを差し込みます。 2 番目のオブジェクトも、最初のオブジェクトと同様、視野に入るようにします。

  3. [ホワイトバランス] ボタンを押します。

  4. EasyBuilder は、これらの設定をジョブファイルに保存します。その後、カラーバランス設定を使用して、画像が取り込まれます。

    注: ホワイトバランス設定は、ジョブファイルに保存され、In-Sight ビジョンシステム上には保存されません。 ジョブを新規作成する場合、上記のステップを繰り返して、ホワイトバランス設定をジョブファイルに適用する必要があります。 EasyBuilder では、ホワイトバランス設定をビジョンシステム上に保持することはできません。


フォーカス領域

[フォーカス領域] ボタンは、画像の領域を指定するのに使用されます。この領域は、ライブモード時に表示されるフォーカスメトリクスの画像フォーカスを計算するのに使用されます。[フォーカス領域] ボタンを押して、領域を設定してください。


フォーカス制御

[フォーカス制御] を使用して、自動的にレンズの焦点を合わせたり、特定の焦点位置にレンズを移動したりして、サポートされている In-Sight 7000 シリーズビジョンシステムのレンズの焦点位置を制御します。

注:
  • [フォーカス制御] は、In-Sight Explorer 4.7.3 以降、In-Sight ファームウェア4.7.3 以降を使用している In-Sight 70xx - 74xx シリーズビジョンシステムで使用可能です。
  • [フォーカス制御] は、ビジョンシステムのオフライン時にのみ使用できます。
  • [オートフォーカス] および [フォーカスの保存] ボタンは、スプレッドシートビューおよび EasyBuilder ビューの両方に表示されるライブビデオモードからもアクセスすることができます。

Closed フォーカス制御

[フォーカス制御] を有効にするかどうかを指定します。 デフォルトでは、有効なデフォルトのフォーカス位置がセンサに設定されている場合、[フォーカス制御] は有効となります。フォーカス位置が設定されていない場合、[フォーカス制御] は無効となります。

Closed [オートフォーカス] ボタン

自動的にレンズの焦点を合わせ、領域内の画像シャープネスを最大にします。

Closed オートフォーカスオフセット (In-Sight 70xx - 74xx シリーズのみ)

オートフォーカス完了後に、レンズ位置に適用するオフセット値 (-100～100。デフォルト = 0) を指定します。

注: この設定は、In-Sight 76xx～79xx シリーズビジョンシステムではサポートされていません。
Closed フォーカス位置

特定の焦点位置にレンズを移動し、新しい画像を取り込みます。

  • In-Sight 70xx~74xx シリーズ: 0 - 100; デフォルト = 0
  • In-Sight 76xx~79xx シリーズ: 0 - 250; デフォルト = 0
Closed 焦点位置とジョブの保存

フォーカス位置をジョブに保存し、ジョブをリロードした際にレンズに適用するかどうかを指定します。 デフォルトでは、[フォーカス位置をジョブに保存] チェックボックスは ON になっています。


ラインスキャン制御

ラインスキャン制御を使用して、In-Sight 5604 または 9902L ラインスキャンビジョンシステムを設定することができます。ラインスキャンは、ターゲットオブジェクトが真下を通り過ぎるたびに、行ごとに画像を生成することから、円筒形状の対象物全体の曲がりのない画像や、表面を薄切りした連続画像を生成することが可能です。ご用意いただいたエンコーダ使用して、ターゲットスピードのばらつきに関わらず、高精度の画像を提供することができます。

注:

  • これらの制御を有効にするには、In-Sight 5604 または 9902L ラインスキャンビジョンシステムまたはエミュレータに接続する必要があります。
  • フルアクセス権限を持つユーザのみが、ラインスキャンの設定をすることができます。
  • ラインスキャンビジョンシステムはオフラインにしてください。

トリガ: ラインスキャンビジョンシステムのオンライン時における、画像取り込みトリガソースを定義することができます。

  • カメラ (デフォルト): ビジョンシステムの専用取り込みトリガ入力において検出される、立ち上がりエッジで画像取り込みを有効にします。
  • 連続: 「フリーランニング」による画像取り込み (可能な限り高速) を有効にします。

  • 外部: シリアルコマンド、または画像取り込みトリガとして設定されているディスクリート入力ビットが立ち上がりエッジになったときの、いずれかで画像取り込みを有効にします。

    注:

    • ビジョンシステムの内蔵画像取り込みトリガ入力 ([トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
    • [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] 出力は、ビジョンシステムから送信されません。[エラー: 画像取り込みミス] 信号は、[トリガ] パラメータを [カメラ] に設定したときのみ送信されます。
  • 手動: F5 キーが押されたときに、画像取り込みを有効にします。
  • 産業用イーサネット: 産業用イーサネットプロトコルによるトリガを有効にします (EtherNet/IP、POWERLINK、Profinet、SLMP スキャナ)。
  • タイムスタンプ: PLC から EtherNet/IP を介し、ビジョンシステムにタイムスタンプトリガが送信されたときに、画像取り込みを有効にします。 [タイムスタンプ] オプションは次のビジョンシステムのみでサポートされています。
    • In-Sight 7000 Gen2 シリーズビジョンシステム

    • 128MB 以上の不揮発性フラッシュメモリを持ち、ファームウェアバージョン 4.5.0 以降を搭載した In-Sight 5000 シリーズビジョンシステム

      注: In-Sight 5605 ビジョンシステム (ハードウェアタイプ 821-0032-1R)、In-Sight 5705 ビジョンシステムおよび In-Sight 5705C ビジョンシステムではサポートされていません。
    • In-Sight 9902L ラインスキャンビジョンシステム

ラインディレイ (ライン): 画像取り込み開始前に、カメラがトリガを受信してからの遅延ライン数を定義します。

注: このコントロールを有効にするには、[トリガ] パラメータを [カメラ] に設定してください。

トリガ間隔: [トリガ] コントロールが [連続] に設定されている場合の、画像取り込み間隔をミリ秒単位で定義します (0～10,000、デフォルトは 500)。

注: この遅延は、画像処理を完了するのに必要な時間によって異なります。例えば、[トリガ間隔] を 5,000 ミリ秒に設定した場合、ジョブが 5,000 ミリ秒以内に画像処理を完了する条件で、In-Sight ビジョンシステムは画像を 5,000 ミリ秒ごとに取り込みます。そうでない場合、In-Sight は、画像処理を終了次第、画像を取り込みます。

露光時間 (µsec): 露光時間をマイクロ秒単位で定義します (0～1,000 µsec、デフォルトは 8 µsec)。In-Sight 5604 がトリガ信号を受信すると、指定された露光時間の間、CCD アレイに光が蓄積されます。

注:

  • 5604 では、このパラメータは 0 に設定可能ですが、1.33 µsec 以下の値に設定した場合、[露光時間] で定義した時間に関わらず 1.33 µsec の間露光します。

  • 9902L では、このパラメータは 0 に設定可能ですが、2.00 µsec 以下の値に設定した場合、[露光時間] で定義した時間に関わらず 2.00 µsec の間露光します。

ライントリガタイプ: エンコーダタイプを指定します。選択肢は、[ソフトウェアエンコーダ] または [ハードウェアエンコーダ] です。このコントロールを ON にするには、In-Sight 5604 または 9902L に接続する必要があります。このコントロールは、ラインスキャンエミュレータでは OFF になっています。

  • ハードウェアエンコーダ: ライントリガの駆動に [ステップ/ライン] 設定値と外部ハードウェアエンコーダが使用されます。ハードウェアエンコーダは、ターゲットオブジェクトが指定の方向または距離を動くたびに遷移信号を提供し、その位置をデジタル化するデバイスです。In-Sight 5604 および 9902L では、[単位相] および [4 位相] の 2 種類のハードウェアエンコーダをサポートします。この設定は、[ラインスキャンの設定] ダイアログで指定することができます。
  • ソフトウェアエンコーダ (デフォルト): [ライン間隔] 設定で指定した間隔で周期的にライントリガが駆動されます。ソフトウェアエンコーダは、ハードウェアエンコーダのソフトウェアエミュレーションで、指定された周期でラインを取り込みます。この方法はターゲットスピードの変化に対して脆弱で (低周波加速および高周波振動) 、垂直方向の画像に悪影響を及ぼすことがあるため、主に設定およびトラブルシューティングに使用されます。

ライン数: ラインスキャンビジョンシステムからの画像を生成するために取り込む行数を定義します。

  • In-Sight 5604 は、デフォルトで、解像度 1024 × 2048 の標準画像を生成します。幅は、変更できません。高さは、[ラインスキャンの設定] ダイアログの [画像最大高] ドロップダウンを使用して変更することができます。ライン数の値は、1～ [画像最大高] の範囲を使用することができます。

  • In-Sight 9902L は、デフォルトで、解像度 2048 × 4096 の標準画像を生成します。幅および画像最高高は、エンコーダの設定ボタンから開くことができる [ラインスキャンの設定] ダイアログで設定することができます。1K 解像度 (低照明モード) チェックボックスを ON にすると、幅は 1024 に減少し、照明感度が向上します。ライン数の値は、1～ [画像最大高] の範囲を使用することができます。

In-Sight モデル | 解像度 | 最小 | 最大 | デフォルト
In-Sight 5604 | 1024 x 1 | 1 | 8192 | 2048
In-Sight 9902L | 2048 x 1 | 1 | 16384 | 4096
 | 1024 x 1

注:

  • 回転するターゲット画像を取り込む場合、画像トリガミスを防ぐため、[ライン数] は 2 フレーム間のトリガより少ない値としてください。
  • このパラメータは 1 に設定可能ですが、8 以下に設定すると、画像取り込みに失敗します。

ステップ/ライン: [ライントリガタイプ] を [ハードウェアエンコーダ] に設定した場合に、画像ラインごとのエンコーダステップの数を定義します。4 位相ハードウェアエンコーダが使用されている場合、エンコーダ信号が 1 サイクルを完了することを「ステップ」と呼びます。シングルラインハードウェアエンコーダの場合は、1 ステップは 2 回の信号変化に等しく、4 位相ハードウェアエンコーダの場合は 4 回の信号変化に等しくなります。

In-Sight モデル | ステップ/ライン
In-Sight 5604 | 0.250～256.000; デフォルト = 40.000
In-Sight 9902L | 0.250～8191.000; デフォルト = 40.000

注:

  • [ステップ/ライン] の値は、単位相ラインハードウェアエンコーダでは 0.5 ずつ、4 位相ハードウェアエンコーダでは 0.25 ずつ増分してください。
  • 5604 では、ライントリガの欠落を避けるため、[ステップ/ライン] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 (最短 1.33 µs) より 21.47 µs 長くなるように設定する必要があります。
  • 9902L では、ライントリガの欠落を避けるため、[ステップ/ライン] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 より 3 µs 長くなる値か、もしくは 15µsec か、大きい値のほうに設定する必要があります。
Closed ステップ/ラインハードウェアエンコーダのタイミング図

ライン間隔 (µsec): [ライントリガタイプ] を [ソフトウェアエンコーダ] に設定した場合に、画像ラインごとの間隔をマイクロ秒単位で定義します。

In-Sight モデル | ライン間隔
In-Sight 5604 | 21.000～1000000.000; デフォルト = 40.000
In-Sight 9902L | 21.000～1000000.000; デフォルト = 40.000
In-Sight エミュレータ | 10.000～1000000.000; デフォルト = 40.000

注:

  • 5604 では、ライントリガの欠落を避けるため、[ライン間隔] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 (最短 1.33 µs) より 21.47 µs 長くなるように設定する必要があります。

  • 9902L では、ライントリガの欠落を避けるため、[ライン間隔] の値を、任意の 2 つのライン間の最短時間が [露光時間] 設定値 より 3 µs 長くなる値か、もしくは 15µsec か、大きい値のほうに設定する必要があります。

クリップモード: 画像取り込みトリガを受信したときに指定された数のラインの取り込みが完了していない場合の動作を指定します。

  • クリップングなし (デフォルト): 画像トリガを無視し、「画像取り込みエラー」イベントを生成するように指定します。
  • 黒く塗りつぶし: 残りのラインを黒いピクセルで埋め、新しい画像を即座に開始するように指定します。「画像取り込みエラー」イベントは生成されません
  • ラインスキャンラインの間引き: 現在の画像を現在取り込んだ行数のサイズに縮小し、即座に新しい画像を開始するように指定します。

注:

  • [黒く塗りつぶし] または [ラインスキャンラインの間引き] が有効な場合:
    • 画像を正しくクリッピングするには、[トリガ] タイプを [カメラ] に設定する必要があります。その他のトリガタイプが設定されている場合、画像取り込み中にトリガを受信すると、現在の画像はクリッピングされず、新たに受信したトリガは無視されます。
    • Set Event ネイティブモードコマンドを送信して画像取り込みをトリガを試みた場合に、画像取り込み中にそのトリガを受信すると、現在の画像はクリッピングされず、新たに受信したトリガは無視されます。
  • 時間に厳密なアプリケーションの場合は [ラインスキャンラインの間引き] オプションを選択します。[黒く塗りつぶし] オプションを使用する場合は、埋める行数は数百行程度までに抑えます。
    • 5604 では、[黒く塗りつぶし] オプションでは、1 行埋めるのに約 2 µs かかります (100 行あたり 0.2 ミリ秒)。
    • 9902L では、[黒く塗りつぶし] オプションでは、1 行埋めるのに約 3 µs かかります (100 行あたり 0.3 ミリ秒)。

画像取り込み期間: [クリップ] モードを [黒く塗りつぶし] または [ラインスキャン] の間引きに設定した場合に、いつ画像取り込みを終了するかを定義します。このオプションは、In-Sight 9902L ビジョンシステムで [トリガ] タイプが [カメラ] に設定されている場合のみサポートされています。

  • 0 = 次のトリガ (デフォルト): トリガパルスの立ち上がりエッジで画像取り込みを開始し、次のトリガ信号開始時に、画像取り込みを終了します。
  • 1 = トリガ終了: トリガパルスの立ち上がりエッジで画像取り込みを開始し、現在のトリガ信号終了時に、画像取り込みを終了します。次の状態のときに、画像取り込み完了となります。
    • 指定の [ライン数] が取り込まれたとき。トリガパルスの後端が到着していない場合でも、完了となります。

    • 指定の [ライン数] を取り込む前に、パルスの後端が到着し画像取り込みが終了したとき。

      注: 注: [トリガ終了] を選択すると、[遅延] パラメータは無効となり、画像取得の際に遅延は適用されません。


ラインスキャンの設定

[ラインスキャンの設定] ダイアログでは、ラインスキャンビジョンシステムのハードウェアエンコーダを設定します。また、このビジョンシステムの特定の診断値を表示します。

注意: 4 位相ハードウェアエンコーダを利用しているときに、ビジョンシステムが画像の取り込みを開始し、4 位相ハードウェアエンコーダが、反対方向に移動してフレームトリガの開始点を通過したという信号を出力した場合、取り込まれた画像は正常には生成されておらず、使用することはできません。 このような状況が発生した場合は、方向を反転したという信号を出力したときに、ビジョンシステムをオフラインにします。 次に、4 位相ハードウェアエンコーダが以前の方向に戻ったという信号を出力したときに、ビジョンシステムをオンラインに戻します。

  • [画像最大高]: ラインスキャンビジョンシステムにおいて、画像の生成に使用される最大行数および最大画像バッファ数を指定します。

    ビジョンシステム 画像最大高
    In-Sight 5604

    2048 (デフォルト)

    4096

    8192
    In-Sight 9902L

    2048

    4096 (デフォルト)

    8192

    12288

    16384

    注:

    • ラインスキャンビジョンシステムの [画像最大高] の設定を変更するには、ビジョンシステムを再起動する必要があります。その結果、すべてのジョブおよび設定ファイルが不揮発性フラッシュメモリから消去されます。 続行する前に、ジョブを保存するかバックアップしてください。
    • 起動時にビジョンシステムに割り当てられる画像バッファのデフォルト数は、ビジョンシステムの解像度と RAM サイズによって異なります。 [画像最大高] の設定を調整すると、ビジョンシステムで利用可能な画像バッファの最大数が増加または減少します。 必要に応じて、[画像バッファ] ダイアログを使用し、起動時にビジョンシステムに割り当てる画像バッファの数を変更してください。

    • ラインスキャンビジョンシステムを使用する際、[位置決め] または [検査] ツールの領域の幅には、上限があります。 領域の幅を広げるには、スプレッドシートビューにアクセスし、数式バーに領域の値を手動で入力するか、あるいはコントロールまたは構造体関数を作成し、ツールの [領域] パラメータから参照する必要があります。

      ビジョンシステム | 解像度 | 画像最大高 | プロパティシートの最大幅
      In-Sight 5604 | 1024 ✕ 1 | 8192 | 3072
      In-Sight 9902L 2048 ✕ 1

      8192 以上

               6144
      1024 ✕ 1 | 4096 以上 | 3072
  • [ハードウェアエンコーダ]
    注: [エンコーダタイプ] または [方向] を変更するには、[画像の設定] アプリケーションステップの [ライントリガタイプ] パラメータを [ハードウァアエンコーダ] に設定し、ラインスキャンビジョンシステムをオフラインにし、ユーザはフルアクセスのアクセス権を持っている必要があります。

    • [エンコーダタイプ]: ラインをトリガするために使用されるエンコーダのタイプとして、[単位相] (デフォルト) または [4 位相] を指定します。

      注:

      • エンコーダタイプを [単位相] に設定した場合、単位相ラインエンコーダを 1 番目のエンコーダ入力に配線する必要があります。2 番目の入力にラインを接続しても、動作しません。
      • [4 位相] エンコーダは、方向に関する情報を提供し、2 点の高速入力が必要です。

    • [方向]: [4 位相] エンコーダの方向を指定します。選択肢は、[プラス] (デフォルト) または [マイナス] になります。 ラインスキャンビジョンシステムは [方向] を使用して、正しい操作方向を決定します。 逆方向のステップは無効とみなされ、現在のフレームは破棄されてしまいます。

      注: このコントロールは、[エンコーダタイプ] に [単位相] が設定されている場合には無効化されます。
  • [診断]
    • [エンコーダ数]: エンコーダのステップ数 (ソフトウェアエンコーダの場合はミリ秒) を表示します。
    • [ライン数]: カウンタが前回リセットされてから現在までに実行された画像取り込みライン数の合計を表示します。
    • [ラインオーバラップ数]: エンコーダレートが大きすぎたために失われたラインの数を表示します。
    • [バッファオーバラン数]: ラインスキャンビジョンシステムで画像バッファが不足した回数を表示します。
    • [フレーム/秒]: 1 秒あたりに取り込まれたフレームの数を表示します。

    • [ステップ/秒]: 1 秒間に外部エンコーダから受信するステップの数を表示します。

      注: ソフトウェアエンコーダが使用されている場合、1 秒間のマイクロ秒数を表示します。

    • [リセット] ボタン: すべての診断統計情報を 0 にリセットします。

      注: 診断統計は、[リセット] ボタンをクリックしたとき、またはビジョンシステムがオンラインまたはオフラインに切り替わったときに、リセットされます。
  • 1K 解像度 (低照明モード): 解像度が減少し、照明感度が向上します。 このオプションは、In-Sight 9902L ビジョンシステムのみでサポートされています。


キャリブレーション (画像単位を実単位に変換) を行うには

注:このトピックでは、In-Sight ビジョンシステムのキャリブレーション機能について説明します。 In-Sight 2000-130/130C または 2000-23M ビジョンセンサに接続している場合、[画像の設定] の [FOV (幅)] セクションをご参照ください。

[キャリブレーション (画像座標系をワールド座標系に変換) グループボックスを使用して、位置決めおよび検査ツールの結果をキャリブレーションし、ピクセル単位ではなく、実単位 (ミクロン、ミリメートル、センチメートル、インチ) で表示することができます。

In-Sight ビジョンシステムにおいて、キャリブレーションとは、画像領域を「マッピング」して、画像内の特徴と、既知の実世界の測定単位との関係を確立することです。 このプロセスでは、2 次元 (2D) 変換によって、画像のピクセル座標の点をワールド座標へ数学的にマッピングします。 画像のキャリブレーションが完了すると、位置決めおよび検査ツールは、結果をキャリブレーションされた単位 (実世界値) で報告できるようになります。

In-Sight ビジョンシステムのキャリブレーションには、[X/Y スケール]、[エッジ]、[X/Y エッジ]、[円]、[グリッド]、[インポート] および [9 点] の 7 つがあり、それぞれ精度が異なります。

ジョブでキャリブレーションを実行するには、[キャリブレーションタイプ] ドロップダウンメニューから、キャリブレーションのオプションを選択してください。

  • なし (デフォルト)
  • X/Y スケール
  • エッジ
  • X/Y エッジ
  • 9 点
  • 円
  • グリッド
  • インポート
注:
  • [X/Y スケール]、[エッジ]、[X/Y エッジ]、[円]、[グリッド]、[インポート] および [9 点] キャリブレーションオプションは、画像内でユーザが指定した、1～16 点を使用し、検査対象物の実世界の計測値に関連付けます。 これらのキャリブレーションオプションは、線形および非線形の歪みのみを補正します。 正確を期すためには、グリッドキャリブレーションオプションを使用してください。
  • これらのキャリブレーションオプションは、線形および非線形の歪みのみを補正します。
  • [X と Y を入れ替える] チェックボックスを ON にすると、スプレッドシートビューの座標 (Y/X) 配置でキャリブレーションの結果を表示することができます。
  • キャリブレーション実行時の、物理的・光学的な設定 (レンズ、ビジョンシステム、およびビジョンシステムと画像を取り込むシーン間の物理的関係) を同一にしてください。 このうちのいずれかが変更された場合、システムを再キャリブレーションする必要があります。 よって、キャリブレーション時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することに留意してください。 ビジョンシステムおよびレンズも、既存構成の設定およびキャリブレーション設定を保持するようにしてください。 例えば、 (解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、ピクセルをワールド座標にマッピングした 2D 変換計算が無効となってしまいます。


[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションタイプ

[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションオプションは、検査対象物またはオブジェクトの実際の寸法が分かっている場合に有用なアプリケーションです。

注: スケールを使用したキャリブレーションは、レンズの歪みを考慮に入れていません。正確を期すためには、検査する表面に対して直角にIn-Sight ビジョンシステムを取り付けるようにする必要があります。そうでない場合は、歪みを取り除き、より正確に画像のキャリブレーションを行うことができるように、グリッドを使用したキャリブレーションを使用してください。

Closed X/Y スケール

X および Y 値がわかっている場合の、シンプルなキャリブレーション計算に使用します。

注: このオプションは、歪みを考慮しません。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[X/Y スケール] を選択します。
  2. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  3. [水平スケール] パラメータに水平スケール値 (0～9,999,999) を入力します。
  4. [垂直スケール] パラメータに水平スケール値 (0～9,999,999) を入力します。
  5. このオプションが選択されるとすぐにキャリブレーションが実行され、値が設定されます。
Closed エッジ

2 つのエッジ特徴間の距離が分かっている場合に使用します。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[エッジ] を選択します。
  2. [エッジの選択] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  3. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  4. 次に、2 番目のスマートフィーチャーを選択します。

注: 目的の特徴が EasyBuilder によって自動的に検出されない場合は、[スマートフィーチャー] チェックボックスを OFF にして、特徴の上に領域を配置してください。

  5. [OK] ボタンを押して、特徴を定義します。
  6. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  7. [寸法] フィールドに、選択した単位の寸法を入力します。
  8. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。
Closed X/Y エッジ

2 つのエッジ特徴間 (1 つは水平方向、もう 1 つは垂直方向) の距離が分かっている場合に使用します。水平方向の測定寸法と垂直方向の測定寸法を結合することにより、2 つの異なるスケールを作成します。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[X/Y エッジ] を選択します。
  2. [水平距離の定義] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  3. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  4. 次に、2 番目のスマートフィーチャーを選択します。

注: 目的の特徴が EasyBuilder によって自動的に検出されない場合は、[スマートフィーチャー] チェックボックスを OFF にして、特徴の上に領域を配置してください。

  5. [OK] ボタンを押して、特徴を定義します。
  6. [垂直距離の定義] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  7. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  8. 次に、2 番目のスマートフィーチャーを選択します。
  9. [OK] ボタンを押して、特徴を定義します。
  10. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  11. [水平寸法] フィールドに、選択した単位の寸法を入力します。
  12. [垂直寸法] フィールドに、選択した単位の寸法を入力します。
  13. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。
Closed 円

特徴の直径が分かっている場合に使用します。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[円] を選択します。
  2. [円の選択] ボタンを押すと、EasyBuilder は画像を検査し、特徴をスマートフィーチャーとして自動的に検出して水色で提示します。
  3. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。

注: 目的の特徴が EasyBuilder によって自動的に検出されない場合は、[スマートフィーチャー] チェックボックスを OFF にして、特徴の上に領域を配置してください。

  4. [OK] ボタンを押して、特徴を定義します。
  5. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  6. [寸法] フィールドに、選択した単位の寸法を入力します。
  7. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。


[9 点] キャリブレーションタイプ

[9 点] キャリブレーションオプションは、ロボットアプリケーションにおいて正確な座標空間を作成する場合に有用です。このキャリブレーションオプションは、下のイラストに示されるように円ターゲットを基にしています。グリッドパターンでは、等間隔に並べられた 9 個のターゲットからなるキャリブレーションプレートが理想です。キャリブレーションを実行する前にターゲット間の水平および垂直距離を把握しておく必要があります。

注:
  • ロボット座標システムでは、9 個のターゲットの中心ターゲットが原点 (0,0) とみなされます。
  • 水平ターゲットの間隔は、一定である必要があります。垂直ターゲットも同様です。しかし、水平および垂直ターゲットの間隔は同一である必要はありません。
  • 各ターゲットの円の直径は、25 ピクセル以上必要です。
Closed 例 - 単一のターゲット

Closed 例 - 9 個のターゲット

注: 座標は実際の画像には表示されていません。イラスト用に挿入されているだけです。

注: [9 点] キャリブレーションオプションでは、レンズの歪みは考慮されません。正確を期すためには、検査する表面に対して直角に In-Sight ビジョンシステムを取り付けるようにする必要があります。

キャリブレーションを実行する前に、等間隔に並べられた 9 個のターゲットを含むキャリブレーションプレート画像を取り込んでください。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[9 点] を選択します。

  2. [モデル編集] ボタンを押し、中央のターゲットを囲むように領域を設定してから、[OK] ボタンを押します。ターゲットを囲む領域を設定する際には、円の外側のエッジと領域の間に 3～4 ピクセル以上のスペースを空けるようにしてください。また、領域の中心をターゲットの中心にできるだけ合わせてください。

    Closed 例

  3. モデル設定後、画像内のすべてのターゲットが検出され、緑の十字マークがターゲット上に表示されます。

注: ターゲットのフィデューシャル (十字部分) は検出されたものの、フィデューシャルを囲む円が検出されない場合、赤の十字マークが表示されます。この場合、モデルを再登録するか、新たに画像を取り込んで、問題を解決してください。

  4. [単位] ドロップダウンメニューから実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  5. [X 寸法] フィールドに、同じ行にある 2 つのターゲット間の水平距離 (ターゲットの中心から別ターゲットの中心までの距離) の実寸を入力します。(ターゲットの中心から別ターゲットの中心の距離)
  6. [Y 寸法] フィールドに、同じ列にある 2 つのターゲット間の垂直距離 (ターゲットの中心から別ターゲットの中心までの距離) の実寸を入力します。(ターゲットの中心から別ターゲットの中心の距離)
  7. [キャリブレーション] ボタンを押して、キャリブレーションのプロセスを終了します。位置決めおよび検査ツールの結果が、実単位で表示されるようになります。


グリッドを使用したキャリブレーション

In-Sight ビジョンシステムは、設置環境によって、レンズなど特定の設定条件によって引き起こされた歪みや遠近歪みを含む画像を取り込むことがあります。レンズによっては、樽型歪みまたは糸巻型歪みのパターンが生成される場合があり、これによって、実世界の直線が画像内では曲線に見えてしまうことがあります。遠近歪みは、In-Sight ビジョンシステムを検査領域に対して垂直に取り付けることができない場合に生じます。このような状況では、画像内の特徴が、視野内の位置に応じて引き延ばされたように表示され、不正確な結果となることがあります。

[グリッド] キャリブレーションオプションは、ドットまたは正方形のチェッカボードによるグリッドパターン画像を取り込むことで、画像領域の「マップ」を生成します。この関数は、グリッド内で検出された特徴 (ドットまたは正方形の交点) を、ユーザが指定したグリッドパターンのグリッド間隔に関連付けます。このプロセスによって、非常に正確な計算が可能になり、それを使用して歪んだ特徴を正しい形状に変換することができます。

In-Sight ビジョンシステムをキャリブレーションすることによって、画像の周辺部にある対象物をより正確に検出できます。また、In-Sight ビジョンシステムを検査面に対して最大 45 度の角度で取り付けることができるなど、柔軟な設置が可能になります。

ヒント: [グリッド] キャリブレーションをアプリケーションに使用する必要がある場合、変換画像フィルタツールを使用して、歪みのない結果を表示することができます。また、その出力画像を、他の検査ツールのツール画像として参照することができます。

  1. [キャリブレーションタイプ] ドロップダウンメニューから、[グリッド] を選択します。
  2. [キャリブレーション] ボタンを押して、[CalibrateGrid] ダイアログを開きます。


[インポート] キャリブレーションタイプ

[インポート] キャリブレーションタイプを使用して、N 点またはシーケンス N 点キャリブレーションツールで作成したキャリブレーションファイルをロードしたり、In-Sight ビジョンシステムのローカルファイルシステムにエクスポートしたりすることができます。インポートされたキャリブレーションファイルは、ロード次第、自動的にジョブをキャリブレーションします。

注: [キャリブレーションタイプ] から [インポート] を選択する前に、まず N 点またはシーケンス N 点キャリブレーションツールをジョブに追加、設定してください。その後、キャリブレーションファイルを In-Sight ビジョンシステムのローカルファイルシステムにエクスポートしてください。

N 点およびシーケンス N 点キャリブレーションツールは、ピクセル座標系とワールド座標系間で変換を行うための 2D 変換を作成します。このプロセスで、線形および非線形歪みを補正します。また、5 個以上の点を使用した場合、[X/Y スケール]、[エッジ]、[X/Y エッジ] および [円] キャリブレーションメソッドよりも高精度です。このツールは、以下の変換を行います。

  • 2 次元での変換 (5 つ以上の点を使用)。
  • 3 つの軸についての回転 (4 つ以上の点を使用)。
  • 2 次元でのスケール (2 つ以上の点を使用)。
  • 遠近歪み (4 つ以上の点を使用)。
  • 平行四辺形化またはスキュー (4 つ以上の点を使用)。
Closed インポート
  1. [キャリブレーションタイプ] ドロップダウンメニューから、[インポート] を選択します。
  2. EasyBuilder は、N 点またはシーケンス N 点キャリブレーションツールで生成されたキャリブレーションファイルがジョブに含まれているかどうかを調査し、キャリブレーションファイルをロードします。1 個以上のキャリブレーションファイルを作成した場合、[ファイル名] ドロップダウンメニューから使用するファイルを選択してください。
  3. [単位] ドロップダウンメニューからキャリブレーションを定義する実単位 (ミクロン、ミリメートル、センチメートルまたはインチ) を選択します。
  4. このオプションを選択し、値を設定次第、キャリブレーションが実行されます。


位置決め

位置決めツールは、画像中の特徴の定義に使われ、その位置データを提供します。 そして、回転や移動を伴う検査対象物に素早く確実に追従するフィクスチャを作成します。

注:
  • 位置データが不要な場合、または常に同じ場所に検査対象物が存在する場合、位置決めをする必要はありません。[検査] ステップに進んでください。
  • In-Sight 2000-110 および 120/120C ビジョンセンサでは、ジョブに追加できるフィクスチャは 1 つのみです。
  • 位置決めツールを追加、削除、編集するには
  • 位置決めツールを選択するには

  • 位置決めツールと検査ツールの間にリンクを作成するには

    注: [リンク] タブは、In-Sight 2000 シリーズビジョンシステムではサポートされていません。

位置決めツールは、次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | パターン位置決めツール: PASS/FAIL ステータスおよびパターンの得点 その他の位置決めツール: PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果 (位置データ*、PASS/FAIL ステータス)
* ツールの結果はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


位置決めツールを追加、削除、編集するには

Closed ツールを追加する

ジョブにツールを追加するには、[ツールの追加] リストからツールを選択して [追加] ボタンを押すか、またはそのツールをダブルクリックしてください。続いて、EasyBuilder のスマートフィーチャーまたは領域グラフィックスを使用して、位置決め用の特徴を定義します。

特徴の定義後、ツールの機能をチューニングすることができます。ツールの各種パラメータを操作してください。

注: [ツール] サーチボックスを使用して、ツールを動的にサーチすることができます。

Closed ツールを削除する

ジョブからツールを削除するには、次のいずれかの方法で行います。

  • パレットの [結果] テーブルでツールを選択し、キーボードの Delete キーを押します。
  • パレットの [結果] テーブルでツールを選択し、標準ツールバーの [削除] アイコンをクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[削除] を選びます。
Closed ツールを編集する

EasyBuilder のどのステップからでも、次のいずれかの方法でツールを編集することができます。

  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。

[ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。

  • 画像内の領域グラフィックスを選択します。
  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。
  • [ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。
注:
  • In-Sight ビジョンシステムが In-Sight Explorer スプレッドシートプログラミング環境へのアクセスをサポートしている場合、右クリックすると [このツールにジャンプして編集] オプションが表示されます。スプレッドシートプログラミング環境に精通し、その操作方法を熟知している場合のみ、この環境にアクセスすることを推奨します。In-Sight Explorer オンラインヘルプファイルのスプレッドシートの EasyBuilder ジョブの編集トピックをご参照ください。
  • [結果] テーブル内のツールをドラッグ & ドロップすることによって、ツールの順番を変更することができます。この操作は、ジョブの実行 [結果] テーブルおよびパレットの [結果] タブの両方で実行でき、その結果は両方のテーブルに反映されます。ドラッグ & ドロップソーティングは、テーブルの [ツールの順番および依存関係グラフィックス] 行を選択しているときのみ、有効となります。行を再度選択すると、順番は逆になります。リストの順番を変更する機能は、ジョブがジョブサイズ制限に近づくと、無効になります。

注:ツールを追加するのに十分なスペースがジョブにない場合、[位置決め] または [検査] アプリケーションステップを終了し、[センサ] メニューから [ジョブサイズ制限] を選択します。このダイアログで、ツールが追加できるよう、ジョブサイズを調整することができます。In-Sight ビジョンシステムのジョブサイズを調整するには、ビジョンシステムを再起動する必要があります。その際、すべてのジョブおよび設定ファイルが不揮発性メモリから消去されます。継続する前に、ジョブを保存、バックアップしてください。


特徴とは

マシンビジョンでは、特徴は「画像の中の検査対象物」と呼ばれます。ビジョンによる検査は画像中に検出された特徴に対して行われます。

[位置決め] ステップで検出される特徴には次の種類があります。

Closed エッジ

白ピクセルと黒ピクセルとの遷移が直線状に並んでいる部分を指します。検査対象物の端、電子基板上のピン、ネジの山などがエッジにあたります。エッジ検出は、さまざまなビジョンツールの中でも高速な部類に入ります。フィクスチャとして使用する場合は、一方向 (水平または垂直) のみに移動する、高コントラストな特徴を選択してください。

Closed エッジフィクスチャの例

この例では、エアフレッシュナーのスプレー容器が画像ごとに違う場所に表示されます。スプレー容器は垂直方向に表示されますが、水平方向に移動します。2 つのエッジ位置決めツールがフィクスチャとして使用されており、左側のフィクスチャは、スプレー容器下部の外側エッジを位置決めし、左側にある検査ツールの領域を追従させます。一方、右側のフィクスチャは、右側のツールを追従させます。

Closed 円

本質的にはエッジですが、特に白ピクセルと黒ピクセルとの遷移が円形状に並んでいる部分を指します。 高コントラストな円であれば比較的速く検出されます。フィクスチャとして使用する場合は、円の角度データが提供されないことにご注意ください。

Closed 円フィクスチャの例

この例では、2 つのフィクスチャが使用されています。1 番目のフィクスチャであるブロブ位置決めツールは、パイプ外側を位置決めし、2 番目のフィクスチャである円位置決めツールは、パイプの基本的な形状である円を、検出されたブロブ内で位置決めします。アプリケーションの設定に従い、検出された形状の基準点から距離を計算してネジの長さを決定しますが、その長さは均一である必要があります。

Closed パターン

パターンには、反復模様のようなシンプルなものからロゴやラベルといった複雑なものまでさまざまな形状が含まれます。フィクスチャとして使用する場合、パターンは非常に高い信頼性を発揮します。回転、移動、スケール変化にも対応することができますが、一般的に検査時間は長めです。

Closed パターンフィクスチャの例

この例では、2D コードが画像内のさまざまな位置および向きに表示されます。PatMax パターン位置決めツールがフィクスチャを作成するのに使用され、ID コードの読み取り識別ツールのサーチを追従させます。このように PatMax パターン位置決めツールは、さまざまな位置、向きおよびスケールに対応しながら、複雑なパターンを位置決めすることができます。

Closed ブロブ

黒い背景上の白いしみや、白いベルトコンベヤ上の黒いネジなど、黒色または白色のピクセルの塊をブロブと呼びます。ブロブの検査時間はエッジツールとパターンツールの中間に位置し、パターンツールと比較した場合、特徴の形状やサイズの変化が大きくても検出することができる特徴があります。フィクスチャとして使用する場合は、一般に角度の値を制限して使用します。

Closed ブロブフィクスチャの例

この例では、検査特徴 (ネジ) が対象物 (パイプ) 内にあり、その方向や垂直および水平位置が画像によって異なるため、2 つのフィクスチャが使用されています。パイプのフランジが不規則な形を作るため、視野内のパイプを位置決めするフィクスチャとして、ブロブ位置決めツールが使用されています。


領域

領域は、位置決めおよび検査ツールが検査を行う画像領域を定義します。領域は、検査対象領域 (ROI) とも呼ばれます。

EasyBuilder では、使用するツールによって、異なるタイプの領域が使用されます。領域の種類は、次の通りです。

  • 矩形
  • 円
  • 円環
  • ポリゴン


円環領域

円環領域は円形エッジ特徴の定義に使用されます。円環領域には、内半径および外半径があるため、円の中心を無視して、円形エッジ特徴を定義することが可能です。

Closed 円環領域マウス動作

 | コントロール | 説明
1 | 移動 | 内半径および外半径の間にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、画像の内部の任意の場所にこの領域をドラッグできるようになります。
2 | サイズ変更 | 円環領域の内半径または外半径の上にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、この領域をドラッグして、サイズを変更できるようになります (内半径および外半径は、それぞれ別にサイズ変更する必要があります)。
Closed 円環領域スキャン方向

円環領域のスキャン方向 - 円特徴の内側から外側へ

Closed 円環領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


円領域

円領域は円特徴の定義に使用されます。円領域は、円内のすべてのものをキャプチャします。円の中心を無視して円特徴を定義するには、円環領域を使用します。

Closed 円領域マウス動作

 | コントロール | 説明
1 | 移動 | 領域内にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、画像の内部の任意の場所にこの領域をドラッグできるようになります。
2 | サイズ変更 | 円領域の境界にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、この領域をドラッグして、サイズを変更できるようになります。
Closed 円領域スキャン方向

円領域のスキャン方向： 円特徴の内側から外側へ

Closed 円領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


ポリゴン領域

ポリゴン領域を使用して、ラインセグメントから作成された不規則な特徴を定義します。使用用途にあわせて、必要な形状に設定してください。

Closed ポリゴン領域の凡例

 | コントロール | 説明
1 | サイズ変更可能な端点マーク | ポリゴン領域の三隅を定義します (1 つのポリゴン領域では、最大 100 までの点を作成することができます)。端点をクリックして、三隅の 1 つから領域のサイズを変更することができます。
2 | 回転ハンドル | 領域を 360°回転させることができます。
Closed ポリゴン領域マウス動作

領域内のさまざまな場所にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、以下の動作を行うことができます。

マウスアイコン | 説明
 | 画像の内部の任意の場所にポリゴン領域全体をドラッグできます。
 | 領域全体を水平または垂直に拡大縮小することができます。
 | 領域を現在の向きから 360 度回転させることができます。
 | ポリゴン領域のサイズ変更可能な端点マークの 1 つを移動させることができます。
 | ポリゴン領域にサイズ変更可能な端点マークを追加することができます。
Closed ポリゴン領域スキャン方向

 | コントロール | 説明
1 | トップ | 水平方向にスキャンされることを示します。
2 | サイド | 垂直方向にスキャンされることを示します。
Closed ポリゴン領域カラーコード

 | 説明
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


矩形領域

矩形領域は、検査の定義に最もよく使用される領域です。使用するアプリケーションのニーズに合わせて、矩形領域のサイズを変更し、円弧または円環領域にすることができます。

Closed 矩形領域の凡例

 | コントロール | 説明
1 | サイズ変更用端点マーク (× 4) | 矩形領域の四隅を定義します。端点の 1 つをクリックして、四隅の 1 つから領域のサイズを変更することができます。
2 | スキャン方向インジケータ (× 2) | 矩形領域で特徴がスキャンされる方向を定義します。
3 | カーブ用ハンドル | 矩形領域を円弧または円形に曲げることができます。
4 | 回転用ハンドル | 領域を 360 度回転させることができます。
Closed 矩形領域のマウス動作

 | コントロール | 説明
1 | 移動 | 領域の内側にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、画像の内部の任意の場所にこの領域をドラッグできるようになります。
2 | 曲げ | 曲げハンドル上にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、矩形領域を扇形に変形できるようになります。 例えば、その後で、形状の四辺を円形に変更できます。
3 | サイズ変更 | 4 つの端点マークのいずれか、または四辺のいずれか沿いにマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、この領域をドラッグしてサイズを変更できるようになります。
4 | 回転 | 回転ハンドル上にマウスカーソルを置くことにより、マウスカーソルアイコンが自動的に変わり、領域を現在の向きから 360 度回転させることができます。
Closed 矩形領域のスキャン方向

 | コントロール | 説明
1 | トップ | 水平方向にスキャンされることを示します。
2 | サイド | 垂直方向にスキャンされることを示します。
Closed 矩形領域カラーコード

 | Description
1 | 新しく追加された、未選択の領域
2 | 選択されているが、設定されていない領域
3 | 選択、設定されている PASS 領域
4 | 選択されていないが、設定は行われている PASS 領域
5 | 選択、設定されている FAIL 領域
6 | 選択されていないが、設定は行われている FAIL 領域


フィクスチャ

[位置決め] ステップの位置決めツールはフィクスチャを作成します。フィクスチャは、他のビジョンツールの基準点として機能します。

フィクスチャを作成する際には、検査対象物をよく観察して、どの特徴タイプを使用するかを検討します。パターン、エッジ、サークル、ブロブのどれを使うのが効果的か、また、その特徴がすべての画像に存在するかを考慮してください。そして、その特徴に適した位置決めツールを選択します。

特徴をフィクスチャとして使用するため、In-Sight センサは特徴検出を行います。検出に成功すると、その検出位置が他のビジョンツールの基準点として使われ、ツールの検査領域が決まります。

Closed 例 - パターンフィクスチャを使用したジョブ

Closed 例 - パターンフィクスチャを使用しないジョブ

注:
  • すべての画像で常に同じ場所に検査対象物が存在している場合、位置決めをする必要はありません。
  • 1 つのジョブに複数のフィクスチャを作成することができます。また、それらのフィクスチャを連結することも可能です。
  • 他のツールによって使用することができる、フィクスチャを生成するのは、次の検査ツールです。エッジ有無判定ツール、PatMax パターン有無判定ツール、パターン有無判定ツール 、ID の読み取り識別ツール、PatMax パターン (1-10) 識別ツール 、パターン (1-10) 識別ツール、角度結果寸法測定ツール、距離寸法測定ツール、円の同心度寸法測定ツール、円の直径寸法測定ツール、2 点間の中点幾何・計測ツール、N 点を通る近似円幾何・計測ツール。


位置決めツールを選択するには

検査目的や仕様に対してどのタイプの特徴が向いているか、検査対象物をよく観察して検討します。

  • PatMax RedLine™ パターン
  • PatMax® パターン
  • パターン
  • PatMax RedLine™ パターン (1-10)
  • PatMax® パターン (1-10)
  • パターン (1-10)
  • エッジ
  • エッジ交点
  • ブロブ
  • ブロブ (1-10)
  • カラーブロブ
  • カラーブロブ (1-10)
  • 円
  • フィクスチャ計算


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール

注:
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) は、登録済みのパターン表現 (モデルと呼ばれます) を基に、PatMax RedLine または PatMax アルゴリズムを使用して、パターンを位置決めします。 PatMax RedLine パターンおよび PatMax パターンツールは単一のパターンの位置決めに使用され、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) ツールは、最大 10 パターンまでの位置決めに使用されます。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

これらのツールは、正確な位置決めが必要とされるロボットガイダンスなどのアプリケーションに有用です。 また、このツールは他のビジョンツールに対してサーチベースのフィクスチャを提供するのに特に有用です。

  1. PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールを設定するには
    1. パターンを選択するには
    2. PatMax RedLine パターン、PatMax パターンおよびパターン
  2. PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールのパラメータを調整するには
  3. PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールの入出力プロパティを使用するには


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。

  4. ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


パターン特徴を選択するには

パターンを選択する際には、次のガイドラインを参考にしてください。

  • そのパターンがすべての画像に存在していること。
  • ユニーク性の高い特徴や一貫性の高い特徴をできるだけ多くそのパターンに含めること。また、検査対象物全体の形状に対してそのパターンが常に一定の位置に、かつ明確に存在すること。
  • できるだけ大きなパターンを選択すること。大きなパターンはユニークな特徴を多く含むため、それだけ一貫した正確な検査を行うことができます。


PatMax RedLine パターン、PatMax パターンおよびパターン

注:PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールの設定ペインには次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [モデル] および [サーチ] タブ
  • [登録画像] タブ
  • テーブル

注: [テーブル] タブは、PatMax パターン (1-10) 位置決めツールにのみ表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

Closed 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別する登録インスタンスの数が多いほど、実行時間は増大します。

Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注: PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

Closed 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。デフォルトでは、[PatMax] が選択されています。PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

Closed クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

Closed 極性を無視

モデルパターンに対し、カラー変換したマッチ特徴を検出パターンに含むかどうか指定します (デフォルト = OFF)。[極性を無視] を ON にすると、例えば、モデルパターン内の黒/白 vs. 白/黒など、カラー変換した特徴を含む検出パターンが、モデルパターンにマッチしていると分類されます。

Closed ソート

検出パターンのソート方法を定義します。選択肢は、[得点] (デフォルト) 、[X]、[Y] です。[得点] を選択した場合、検出パターンは得点を基に、最高得点のパターンから降順でソートされます。[X] を選択した場合、検出パターンは X 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。[Y] を選択した場合、検出パターンは Y 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。

Closed 水平オフセット

検出パターンの中心座標を基準にした水平方向のオフセットをピクセル単位で指定します。検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

Closed 垂直オフセット

検出パターンの中心座標を基準にした垂直方向のオフセットをピクセル単位で指定します。検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

Closed タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 5,000 に設定されています。
Closed 結果

検出パターンの中心座標、角度、得点 (モデルパターンとの類似度) が表示されます。[水平オフセット]/[垂直オフセット] の値が指定されている場合、その分だけ座標が調整されます。

注: [検出する数] パラメータを 2 以上に設定していても、[ソート] パラメータを [X] または [Y] に設定した場合以外は、[結果] フィールドには、最高得点の結果だけが表示されます。

注:
  • PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールには、[検出モード] パラメータは含まれていません。
  • 検出する数およびソートパラメータは、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) でのみサポートされています。


[モデル] および [サーチ] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


[登録画像] タブ (PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


テーブル (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツール)

検出されたパターンの結果を表示します。

Closed インデックス

検出されたパターンの順番を表示します。EasyBuilder では 0 から数えます。

Closed X

検出パターンの中心の X 座標を表示します。[水平オフセット] の値を指定した場合、その分だけ座標が調整されます。

Closed Y

検出パターンの中心の Y 座標を表示します。[垂直オフセット] の値を指定した場合、その分だけ座標が調整されます。

Closed 角度

モデルパターンを基準にした、検出パターンの角度を表示します。

Closed 得点

検出パターンとモデルパターンとの類似度を表示します。

Closed スケール

検出パターンのスケールを表示します。


PatMax RedLine パターン、PatMax パターン、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
コントラストしきい値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部再登録 | 整数値 | X |  | 入出力
検出モード1 | 整数値 | X | X | 入出力
水平オフセット | 浮動小数点 | X | X | 入出力
極性を無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
クラッタ | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
垂直オフセット | 浮動小数点 | X | X | 入出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.得点 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
フィクスチャ.スケール | 浮動小数点 | X | X | 出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
パターン | 文字列 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
モデル | 動作 | X | X |
登録 | 動作 | X | X |
サーチ | 動作 | X | X |
検出する数2 | 整数値 | X | X | 入出力
ソート2 | 整数値 | X | X | 入出力
フィクスチャ1-9.角度2,3 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.得点2,3 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.X2,3 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.Y2,3 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.スケール2,3 | 浮動小数点 | X | X | 出力
検出する数2 | 浮動小数点 | X | X | 出力
1 このツールプロパティは、PatMax パターンおよび PatMax パターン (1-10) 位置決めツールでのみ使用可能です。 2これらのツールプロパティは、PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールでのみ使用可能です。 3 PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 位置決めツールの、1-9 までのフィクスチャ出力 (フィクスチャ 1、 フィクスチャ2、フィクスチャ3 など) のことです。


パターン/パターン (1-10) 位置決めツール

パターン位置決めツールおよびパターン (1-10) 位置決めツールは、登録済みのパターン表現 (モデルと呼ばれます) を基に、PatFind アルゴリズムを使用して、パターンを位置決めします。 パターンツールは単一のパターンの位置決めに使用され、パターン (1-10) ツールは、最大 10 パターンまでの位置決めに使用されます。

パターン位置決めツールおよびパターン (1-10) 位置決めツールは、正確な位置決めが必要とされるロボットガイダンスなどのアプリケーションに有用です。 また、このツールは他のビジョンツールに対してサーチベースのフィクスチャを提供するのに特に有用です。

注:In-Sight 2000 シリーズビジョンセンサは、パターン (1-10) 位置決めツールをサポートしていません。

  1. パターン位置決め/パターン位置決め (1-10) ツールを設定するには
    1. パターンを選択するには
    2. PatMax RedLine パターン、PatMax パターンおよびパターン
  2. パターン位置決め/パターン位置決め (1-10)ツールのパラメータを調整するには
  3. パターン位置決め/パターン位置決め (1-10) ツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | PASS/FAIL ステータスおよびパターンの得点
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | XY 座標*、角度、得点、PASS/FAIL ステータス
*座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


パターン/パターン (1-10) 位置決めツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。

  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

注: モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。

  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。

  4. 領域の設定を確定すると、モデル領域の代わりに検出パターンの位置および角度方向を示すアイコン [image] が表示されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターン位置決め/パターン位置決め (1-10) ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

注:In-Sight 2000 シリーズビジョンセンサは、パターン (1-10) 位置決めツールをサポートしていません。

In-Sight ビジョンシステム

パターンおよびパターン (1-10) 位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [登録画像] タブ
  • テーブル

注: テーブルは、パターン (1-10) 位置決めツールにのみ表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


パターン位置決めツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、パターン位置決め/パターン位置決め (1-10) ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

Closed PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

Closed 回転許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 45 度です。大きな値を設定すると、ツールの実行時間が増大します。左ハンドルはマイナスの回転許容値を、右ハンドルはプラスの回転許容値を設定します。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、回転許容値を調整することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

Closed パーツ検出メータ

パーツ検出メータは、ツールがいかによく特徴を検出したかを表示し、最小アクセプトしきい値を設定します。最小アクセプトしきい値は、手動で設定することができます。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を調整してください。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

メータの示す値がしきい値より高い場合、パーツは検出されたとみなされ、メータは緑で表示されます。しきい値より低い場合、パーツは検出されなかったとみなされ、メータは表示されなくなります。パーツ以外の物を検出したり、間違った特徴を検出したりしている場合、ハンドルを右に動かしてください。パーツ検出に失敗している場合、ハンドルを左に動かしてください (または、モデル領域を新規作成してください)。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

PASS
FAIL

注: スライダコントロール上にマウスポインタを重ねると、[結果] および [しきい値] が表示されます。

Closed ±10% スケール許容

検出パターンとモデルパターン間の ±10% のスケール変化を許容するかどうかを指定します。

登録パターン | 検出パターン: +10% | 検出パターン: -10%
OFF (デフォルト) | (FAIL) | (FAIL)
ON | (PASS) | (PASS)
Closed 手動タイムアウトを使用する

タイムアウト設定を使用するかどうかを指定します。

  • OFF (デフォルト): タイムアウト設定は無効です (タイムアウトしません)。

  • ON: タイムアウト設定を有効にします。 編集ボックスを使用して、手動でタイムアウト値をミリ秒単位で指定します。(0 ～ 30000)

    注: 値を 0 に設定すると設定が無効になり、タイムアウトは適用されません。
Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 名前

検査ツールの名前を定義します。 デフォルト名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注:
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed モデル領域

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


[全般] タブ (パターン/パターン (1-10) 位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン/パターン (1-10) 位置決めツール)

Closed 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注:
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
Closed 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。 ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。 識別する登録インスタンスの数が多いほど、実行時間は増大します。

Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

モデルパターンの大きさを基準とした、検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。 デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。 スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

Closed ソート

検出パターンのソート方法を定義します。選択肢は、[得点] (デフォルト)、[X]、[Y] です。 [得点] を選択した場合、検出パターンは得点を基に、最高得点のパターンから降順でソートされます。 [X] を選択した場合、検出パターンは X 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。 [Y] を選択した場合、検出パターンは Y 軸からの距離を基に、近いものから遠いパターンの降順でソートされます。

Closed 水平オフセット

検出パターンの中心座標を基準にした水平方向のオフセットをピクセル単位で指定します。 検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

Closed 垂直オフセット

検出パターンの中心座標を基準にした垂直方向のオフセットをピクセル単位で指定します。 検出パターンの中心から離れた場所を割り当てることができるため、ロボットガイダンスのピックポイントを定義するのに有効です。

Closed モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

Closed 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

Closed タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed 結果

検出パターンの中心座標、角度、得点 (モデルパターンとの類似度) が表示されます。 [水平オフセット]/[垂直オフセット] の値が指定されている場合、その分だけ座標が調整されます。

注: [検出する数] パラメータを 2 以上に設定していても、[ソート] パラメータを [X] または [Y] に設定した場合以外は、[結果] フィールドには、最高得点の結果だけが表示されます。

注: パターン位置決めツールには、[検出する数] および [ソート] パラメータは含まれていません。


[テーブル] タブ (パターン位置決めツール)

検出されたパターンの結果を表示します。

Closed インデックス

検出されたパターンの順番を表示します。EasyBuilder では 0 から数えます。

Closed X

検出パターンの中心の X 座標を表示します。[水平オフセット] の値を指定した場合、その分だけ座標が調整されます。

Closed Y

検出パターンの中心の Y 座標を表示します。[垂直オフセット] の値を指定した場合、その分だけ座標が調整されます。

Closed 角度

モデルパターンを基準にした、検出パターンの角度を表示します。

Closed 得点

検出パターンとモデルパターンとの類似度を表示します。

Closed スケール

検出パターンのスケールを表示します。


[登録画像] タブ (パターン/パターン (1-10) 位置決めツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン位置決め/パターン位置決め (1-10) ツールのパラメータを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | 入力
高精度モード | 整数値 |  | 入力
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
外部登録 | 整数値 |  | 入力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
フィクスチャ.得点* | 浮動小数点 | X | 出力
水平オフセット | 浮動小数点 |  | 入力
総合判定に含める | 整数値 |  | 入力
モデル | 動作 | X |
モデルタイプ | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
結果 | 文字列 | X |
角度許容値 | 整数値 | X | 入力
スケール許容 | 整数値 | X | 入力
サーチ | 動作 | X |
ステータス | 整数値 | X |
タイムアウト | 整数値 | X | 入力
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |
登録 | 動作 | X |
垂直オフセット | 浮動小数点 |  | 入力
*In-Sight 2000-130/130C ビジョンセンサのみ

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | 入出力
高精度モード | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
外部登録 | 整数値 |  | 入出力
水平オフセット | 浮動小数点 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
モデルタイプ | 整数値 | X | 入出力
角度許容値 | 整数値 | X | 入出力
スケール許容 | 整数値 | X | 入出力
タイムアウト | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
垂直オフセット | 浮動小数点 | X | 入出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.得点 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X | 出力
パターン | 文字列 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 整数値 | X | 出力
ツール有効ステータス | 整数値 | X | 出力
モデル | 動作 | X |
サーチ | 動作 | X |
登録 | 動作 | X |
登録の入力 | 整数値 | X | 入出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.得点 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
高精度モード | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部登録 | 整数値 | X |  | 入出力
水平オフセット | 浮動小数点 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
モデルタイプ | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
垂直オフセット | 浮動小数点 | X | X | 入出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.得点 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
パターン | 文字列 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
検出する数1 | 整数値 | X | X | 入出力
ソート1 | 整数値 | X | X | 入出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |
登録 | 動作 | X | X |
登録の入力 | 整数値 | X | X | 入出力
フィクスチャ1～9.角度1,2 | 浮動小数点 | X | X | 出力
フィクスチャ1～9.得点1,2 | 浮動小数点 | X | X | 出力
フィクスチャ1～9.X1,2 | 浮動小数点 | X | X | 出力
フィクスチャ1～9.Y1,2 | 浮動小数点 | X | X | 出力
検出する数1 | 整数値 | X | X |
1 これらのツールプロパティは、PatMax パターン (1-10) 位置決めツールでのみ使用可能です。 2パターン (1-10) 位置決めツールの、1 から 9 までのフィクスチャ出力 (フィクスチャ1、 フィクスチャ2, フィクスチャ3、など) のことです。


エッジ位置決めツール

エッジ位置決めツールは、指定したパラメータに合致する直線エッジ特徴を位置決めします。

エッジ位置決めツールは、高速なツールの 1 つです。パターン位置決めツールよりも短時間で特徴を検出することができます。 高コントラストのエッジがあり、対象物が一方向のみ移動し、かつ、回転が 10 度以内である場合は、他のビジョンツールのフィクスチャとして有効に機能します。

  1. エッジ位置決めツールを設定するには
  2. エッジ位置決めツールのパラメータを調整するには
  3. エッジ位置決めツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 検出エッジの中点の XY 座標*、角度、PASS/FAIL ステータス
*座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジ位置決めツールを設定するには

ツールを追加したら、フィクスチャとして使用する特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 特徴の 1 つをクリックすると、紫色に変わります。
  3. [OK] ボタンを押して、エッジを確定してください。(ツールをジョブに追加しない場合は [キャンセル] ボタンを押します)。選択したエッジを囲むエッジ領域が作成され、検出されたエッジの位置とその向きを示す [image] アイコンが表示されます。

注: 必要に応じて、検出エッジ周囲の領域を回転したり、サイズ変更したりしてください。

  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジ位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はエッジ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジ位置決めツール)

Closed エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出する基準

複数のエッジが存在する場合に、目的とする 1 つのエッジに絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確なエッジ (コントラストが最も高いもの) が選択されます。
  • 最初のエッジ: 領域のスキャン開始点に最も近いエッジが選択されます。
  • 最後のエッジ: 領域のスキャン開始点から最も遠いエッジが選択されます。
Closed 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。

Closed 結果

検出されたエッジの中心座標および角度方向を返します。


グラフ (エッジ位置決めツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


エッジ位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度範囲 | 整数値 |  | 入力
説明 | 文字列 | X | 入力
エッジのコントラスト | 整数値 |  | 入力
エッジの遷移 | 整数値 |  | 入力
エッジ幅 | 整数値 |  | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
検出する基準 | 整数値 |  | 入力
総合判定に含める | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度範囲 | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
検出する基準 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エッジ | 文字列 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
角度範囲 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
検出する基準 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エッジ | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


エッジ交点位置決めツール

エッジ交点位置決めツールは、2 つのエッジ特徴の交点を指定します。

  1. エッジ交点ツールを設定するには
  2. エッジ交点位置決めツールのパラメータを調整するには
  3. エッジ交点位置決めツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 交点の XY 座標、2 つのエッジ間の 2 等分角度、PASS/FAIL ステータス
*座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジ交点位置決めツールを使用するには

ツールを追加したら、交差するエッジ特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 次に、交差するエッジ特徴を選択してください。
  4. EasyBuilder は自動的に直線の交点を決定し、検出された交点の位置および方向を示す [image] アイコンを挿入します。同時に、エッジ有無判定ツールを挿入し、未設定のエッジ特徴を設定します。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ交点位置決めツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

エッジ交点位置決めツールの設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]および[通信]) で参照されます。デフォルトのツール名は交点_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


エッジ交点位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


ブロブ/ブロブ (1-10) 位置決めツール

ブロブ位置決めツールおよびブロブ (1-10) 位置決めツールは、指定したパラメータに合致しているブロブを位置決めします。ツールは、検出したブロブの重心座標や角度を返します。ブロブツールが 1 個のブロブの位置決めに使用されるのに対し、ブロブ (1-10) 位置決めツールは最大 10 個までのブロブの位置決めに使用されます。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

ブロブ/ブロブ (1-10) 位置決めツールの性能は、エッジ位置決めツールとパターン位置決めツールの中間に位置します。一般に、ブロブ位置決めツールはパターン位置決めツールより高速ですが、エッジ位置決めツールより時間がかかります。このツールは、一定の形状を持たない対象物 (例: 白い背景上の黒いしみ、パターンツールの許容範囲を超えて形状変化するもの、など) を他のビジョンツールのフィクスチャとして利用するのに有効です。

  1. ブロブ/ブロブ (1-10) 位置決めツールを設定するには
  2. ブロブ/ブロブ (1-10) 位置決めツールのパラメータを調整するには
  3. ブロブ/ブロブ (1-10) 位置決めツールの入出力プロパティを使用するには


ブロブ/ブロブ (1-10) 位置決めツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 ブロブをフィクスチャとして使用する場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 領域の設定を確定すると、検出されたブロブの重心点とその向きを示す [image] アイコンが表示されます。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ブロブ/ブロブ (1-10) 位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ/ブロブ (1-10) 位置決めツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • テーブル
  • [ヒストグラム] タブ
  • [合成領域] タブ

注: [テーブル] タブは、ブロブ (1-10) 位置決めツールにのみ表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ブロブ/ブロブ (1-10) 位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ/ブロブ (1-10) 位置決めツール)

Closed しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、常に [ブロブしきい値] の値が使用されます。デフォルトは [自動] です。

Closed ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。ヒストグラムを参考にして、最適な値を設定してください。

Closed ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
  • 任意: 黒白両方のブロブを返します。
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed 最小面積

ブロブ面積の最小値をピクセル単位で指定します (0～900,000)。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

Closed 最大面積

ブロブ面積の最大値をピクセル単位で指定します (0～900,000)。デフォルトは、100,000 です。指定された値より大きなブロブは検出されません。

Closed 角度を無視

ブロブ重心の角度方向を考慮するかどうかを指定します。デフォルトは ON (無視する) です。

注: ブロブの角度は変動しやすくフィクスチャへの影響が大きいため、このパラメータのデフォルトは ON となっています。

Closed 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別するブロブの数が多いほど、実行時間は増大します。

Closed ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
Closed 結果

検出されたブロブの重心座標と角度を表示します。[角度を無視] チェックボックスが ON の場合は、90度 ([画像の設定] ステップの [X と Y を入れ替える] が ON の場合は 0度) に固定されます。

注: [検出する数] パラメータを 2 以上に設定していても、[ソート] パラメータを [X] または [Y] に設定した場合以外は、[結果] フィールドには、最高得点の結果だけが表示されます。

注: ブロブ面積位置決めツールには、[検出する数] パラメータは含まれていません。


[テーブル] タブ (ブロブ (1-10) 位置決めツール)

注:
  • ブロブ位置決めツールは、[テーブル] タブをサポートしていません。ブロブ (1-10) 位置決めツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

Closed インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

Closed X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

Closed 面積

検出したブロブの面積を返します (ピクセル単位)。

Closed ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

Closed ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


[合成領域] タブ (ブロブ/ブロブ (1-10) 位置決めツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ヒストグラム (ブロブ (1-10) 位置決めツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


ブロブ/ブロブ (1-10) 位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
ブロブの色 | 整数値 | X | X | 入出力
ブロブしきい値 | 整数値 | X | X | 入出力
境界ブロブ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
角度を無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
ソート | 整数値 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
面積 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.検出 | 整数値 | X | X | 入出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 |  | X |
検出する数1 | 整数値 | X | X | 入出力
ブロブ面積1 | 浮動小数点 | X | X | 出力
ブロブ面積1-91 | 浮動小数点 | X | X | 出力
フィクスチャ1～19.角度1 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.検出1 | 整数値 | X | X | 出力
フィクスチャ1～19.X1 | 浮動小数点 | X | X | 出力
フィクスチャ1～19.Y1 | 浮動小数点 | X | X | 出力
検出する数1 | 浮動小数点 | X | X | 出力
1 ブロブ (1-10) 位置決めツールのみ使用可能。


カラーブロブ/カラーブロブ (1-10) 位置決めツール

カラーブロブおよびカラーブロブ (1-10) 位置決めツールは、指定したパラメータに合致しているブロブを位置決めし、検出したブロブの重心座標や角度を返します。カラーブロブツールが 1 個のブロブの位置決めに使用されるのに対し、カラーブロブ (1-10) 位置決めツールは最大 10 個までのブロブの位置決めに使用されます。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

カラーブロブ/カラーブロブ (1-10) ツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする、領域内のピクセル数を決定します。ツールは、その後、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定した、2 値化グレースケール出力画像を作成します。この 2 値化出力画像を使用して、有効なカラーモデルによって生成されたブロブ特徴を画像からサーチします。

  1. カラーブロブ/カラーブロブ (1-10) 位置決めツールを設定するには
  2. カラーブロブ/カラーブロブ (1-10) 位置決めツールのパラメータを調整するには
  3. カラーブロブ/カラーブロブ (1-10) 位置決めツールの入出力プロパティを使用するには


カラーブロブ/カラーブロブ (1-10) 位置決めツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 ブロブをフィクスチャとして使用する場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブに戻り使用する [カラーライブラリ] を選択してから、[ライブラリ] タブで [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。

  5. 領域の設定を確定すると、検出されたブロブの重心点とその向きを示す [image] アイコンが表示されます。

  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ/カラーブロブ (1-10) 位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ/カラーブロブ (1-10) 位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ライブラリ] タブ
  • [テーブル] タブ
  • [合成領域] タブ

注: [テーブル] タブは、カラーブロブ (1-10) 位置決めツールでのみ有効になります。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 アプリケーションに合わせて、名前を変更することができます。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
Closed 最小面積

ブロブ面積の最小値をピクセル単位で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

Closed 最大面積

ブロブ面積の最大値をピクセル単位で指定します。指定された値より大きなブロブは検出されません。

Closed 角度を無視

ブロブ重心の角度方向を考慮するかどうかを指定します。デフォルトは ON (無視する) です。

注: ブロブの角度は変動しやすくフィクスチャへの影響が大きいため、このパラメータのデフォルトは ON となっています。

Closed 検出する数

検出するカラーブロブの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のブロブを位置決めすることもできます。検出するブロブの数が多いほど、実行時間は長くなります。

注: このコントロールは、カラーブロブ (1-10) 位置決めツールのみに表示されます。

Closed ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
Closed 結果

検出されたブロブの重心座標と角度を表示します。[角度を無視] チェックボックスが ON の場合は、90 度 ([画像の設定] ステップの [X と Y を入れ替える] が ON の場合は 0 度) に固定されます。


[合成領域] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


[テーブル] タブ (カラーブロブ (1-10) 位置決めツール)

注:
  • カラーブロブ位置決めツールは、[テーブル] タブをサポートしていません。カラーブロブ (1-10) 位置決めツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

Closed インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

Closed X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

Closed 面積

検出したブロブの面積を返します (ピクセル単位)。

Closed ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

Closed ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


[ライブラリ] タブ (カラーブロブ/カラーブロブ (1-10) 位置決めツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


カラーブロブ/カラーブロブ (1-10) 位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注:カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
境界ブロブ | 整数値 | X | X | 入出力
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部モデル有効の適用 | 整数値 | X |  | 入出力
角度を無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
ソート | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
平滑化係数 | 整数値 | X | X | 入出力
オリジナル画像の表示 | 整数値 | X | X | 入出力
面積 | 浮動小数点 | X | X | 出力
ブロブ | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |
モデル有効の適用 | 動作 | X | X |
検出する数1 | 整数値 | X | X | 入出力
面積1-91 | 浮動小数点 | X | X | 出力
フィクスチャ1～19.角度1 | 浮動小数点 | X | X | 出力
フィクスチャ1～19.X1 | 浮動小数点 | X | X | 出力
フィクスチャ1～19.Y1 | 浮動小数点 | X | X | 出力
検出する数1 | 浮動小数点 | X | X | 出力
1 カラーブロブ (1-10) 位置決めツールのみ使用可能。

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


円位置決めツール

円位置決めツールは、指定したパラメータに合致する円形状の特徴を位置決めします。

円位置決めツールは、高速なツールの 1 つです。パターン位置決めツールよりも短時間で特徴を検出することができます。 回転を伴わない円形の対象物を検査する場合、他のビジョンツールのフィクスチャとして有効に機能します。

  1. 円位置決めツールを設定するには
  2. 円位置決めツールのパラメータを調整するには
  3. 円位置決めツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 検出された円の XY 座標 (中心)、直径、PASS/FAIL ステータス*
*座標および円の直径の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


円位置決めツールを設定するには

ツールを追加したら、円検査領域を定義します。

  1. 円形状の特徴の上に円領域を配置します。特徴とちょうど同じぐらいの大きさになるように調整してください。円をフィクスチャとして選択する場合、すべての画像のほぼ同じ位置に存在し、ピクセルの白黒の差がはっきりした、高コントラストの円を選択してください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 円形状の特徴の周囲にドーナツ領域が表示され、検出された円の中心位置とその向きを示す [image] アイコン が表示されます。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円位置決めツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円位置決めツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (円位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (円位置決めツール)

Closed エッジのコントラスト

円が検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出する基準

複数の円が存在する場合に、目的とする 1 つの円に絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確な円 (コントラストが最も高いもの) が選択されます。
  • 最小円: 最も小さい円が選択されます。
  • 最大円: 最も大きい円が選択されます。
Closed 結果

検出された円の中心座標および直径を表示します。


グラフ (円位置決めツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


円位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
エッジのコントラスト | 整数値 |  | 入力
エッジの遷移 | 整数値 |  | 入力
エッジ幅 | 整数値 |  | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
検出する基準 | 整数値 |  | 入力
総合判定に含める | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
検出する基準 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
円環 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
検出する基準 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
円環 | 動作 | X | X |


フィクスチャ計算位置決めツール

フィクスチャ計算位置決めツールは、他の位置決め/検査ツールが出力した数式に基いて、フィクスチャの位置を計算するのに使用します。このツールは、計算したフィクスチャの XY 座標および角度を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • このツールを [グリッド] キャリブレーションと連動して使用すると、キャリブレーションした角度値が変化した場合に、不正確な結果を生成することがあります。この場合、[エッジ] や [円]、[インポート] キャリブレーションを使用してください。

フィクスチャ計算位置決めツールは、位置決め/検査ツールで生成された特定の点や、ライン、角度データを使用して、フィクスチャを計算したい場合に有用です。例えば、2 個のエッジとその交点および2 等分角度結果を基にして、フィクスチャを作成したい場合などです。このシナリオでは、エッジ有無判定ツールを使用してエッジを定義し、角度 2 等分幾何・計測ツールを使用して X、Y および角度の値を定義します。フィクスチャ計算位置決めツールは、その後、角度 2 等分幾何・計測ツールの出力データを使用して、X (2等分_1.点.X) 、Y (2等分_1.点.Y) および角度結果 (2等分_1.角度) 式を入力します。

  1. フィクスチャ計算位置決めツールを設定するには
  2. フィクスチャ計算位置決めツールのパラメータを調整するには
  3. フィクスチャ計算位置決めツールの入出力プロパティを使用するには


フィクスチャ計算位置決めツールを設定するには

ツールを追加したら、[式] に [X]、[Y] および [角度結果] 値を入力します。

注: 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

  1. 設定ペインの左側から演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. すべての [式] を作成したら、計算されたフィクスチャの位置とその向きを示す アイコン [image] が表示されます。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


フィクスチャ計算位置決めツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

フィクスチャ計算位置決めツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [X]、[ Y] および [角度] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (フィクスチャ計算位置決めツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィクスチャ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (フィクスチャ計算位置決めツール)

Closed 結果

計算された X、Y および 角度の値を表示します。

Closed カラー

計算されたフィクスチャ位置のカラーを定義します。デフォルト (=緑)、暗い赤、暗い緑、暗い黄色、暗い青、暗い赤紫、暗い水色、赤、緑、黄色、青、赤紫、水色、暗い灰色、灰色、黒または白。


[X]、[Y]、[角度結果] タブ (フィクスチャ計算位置決めツール)

[X]、[Y]および [角度結果] タブを使用して、フィクスチャの X、Y および 角度座標を定義する数式を作成します。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


フィクスチャ計算位置決めツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


検査

検査ステップは、ジョブを作成する検査ツールを組み立てたり、設定したりするのに使用されます。 製品を調べ、どのタイプの特徴がアプリケーションの条件を最も満たしているか、さらにどの検査ツールが問題解決に最も適しているかを判断します。

  • 検査ツールを追加、削除、編集するには
  • 検査ツールを選択するには

  • 位置決めツールと検査ツールの間にリンクを作成するには

    注: [リンク] タブは、In-Sight 2000 シリーズビジョンシステムではサポートされていません。

検査ツールは、次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | 寸法測定および計数ツール: 標準の結果 (数値データ) 有無判定ツール: PASS/FAIL ステータスおよびパターンの得点 その他のツール:PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果


検査ツールを追加、削除、編集するには

Closed ツールを追加する

ジョブにツールを追加するには、[ツールの追加] リストからツールを選択して [追加] ボタンを押すか、またはそのツールをダブルクリックしてください。続いて、EasyBuilder のスマートフィーチャーまたは領域グラフィックスを使用して、位置決め用の特徴を定義します。

特徴の定義後、ツールの機能をチューニングすることができます。ツールの各種パラメータを操作してください。

注: [ツール] サーチボックスを使用して、ツールを動的にサーチすることができます。

Closed ツールを削除する

ジョブからツールを削除するには、次のいずれかの方法で行います。

  • パレットの [結果] テーブルでツールを選択し、キーボードの Delete キーを押します。
  • パレットの [結果] テーブルでツールを選択し、標準ツールバーの [削除] アイコンをクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[削除] を選びます。
Closed ツールを編集する

EasyBuilder のどのステップからでも、次のいずれかの方法でツールを編集することができます。

  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。

[ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。

  • 画像内の領域グラフィックスを選択します。
  • パレットの [結果] テーブルでツールをダブルクリックします。
  • パレットの [結果] テーブルでツールを右クリックし、[このツールへジャンプして編集] を選択します。
  • [ジョブの実行] ステップの [結果] テーブルでツールをダブルクリックします。
注:
  • In-Sight ビジョンシステムが In-Sight Explorer スプレッドシートプログラミング環境へのアクセスをサポートしている場合、右クリックすると [このツールにジャンプして編集] オプションが表示されます。スプレッドシートプログラミング環境に精通し、その操作方法を熟知している場合のみ、この環境にアクセスすることを推奨します。In-Sight Explorer オンラインヘルプファイルのスプレッドシートの EasyBuilder ジョブの編集トピックをご参照ください。
  • [結果] テーブル内のツールをドラッグ & ドロップすることによって、ツールの順番を変更することができます。この操作は、ジョブの実行 [結果] テーブルおよびパレットの [結果] タブの両方で実行でき、その結果は両方のテーブルに反映されます。ドラッグ & ドロップソーティングは、テーブルの [ツールの順番および依存関係グラフィックス] 行を選択しているときのみ、有効となります。行を再度選択すると、順番は逆になります。リストの順番を変更する機能は、ジョブがジョブサイズ制限に近づくと、無効になります。

注: ツールを追加するのに十分なスペースがジョブにない場合、[位置決め] または [検査] アプリケーションステップを終了し、[センサ] メニューから [ジョブサイズ制限] を選択します。このダイアログで、ツールが追加できるよう、ジョブサイズを調整することができます。In-Sight ビジョンシステムのジョブサイズを調整するには、ビジョンシステムを再起動する必要があります。その際、すべてのジョブおよび設定ファイルが不揮発性メモリから消去されます。継続する前に、ジョブを保存、バックアップしてください。


特徴とは

マシンビジョンでは、特徴は「画像の中の検査対象物」と呼ばれます。ビジョンによる検査は画像中に検出された特徴に対して行われます。

[検査] ステップで検出される特徴には次の種類があります。

Closed エッジ

白ピクセルと黒ピクセルとの遷移が、水平または垂直方向、円またはカーブ状に並んでいる部分を指します。検査対象物の端、電子基板上のピン、ネジの山、ボトルの底、バネのコイルなどがエッジにあたります。これらのタイプの特徴は、一般的に最も速く簡単に検出されます。

Closed エッジの例

Closed 円、線および点

寸法計算に使用される、標準的な幾何学参照図形。

Closed 円、線および点の例

Closed パターン

パターンには、反復模様のようなシンプルなものからロゴやラベルといった複雑なものまでさまざまな形状が含まれます。パターンは非常に高い信頼性を発揮します。回転、移動、スケール変化にも対応することができますが、一般的に検査時間は長めです。

Closed パターンの例

Closed ブロブ

黒い背景上の白いしみや、白いベルトコンベヤ上の黒いネジなど、黒色または白色のピクセルの塊をブロブと呼びます。比較的早く検出され、ブロブの形状およびサイズのばらつきに対応することができますが、ブロブの角度データが制限されていることにご注意ください。

Closed ブロブの例

Closed 文字

英数字の文字列を指します。

Closed 文字列の例

Closed コード

英数字のデータ文字列を含むバーコード、2D マトリックスコード、およびシンボルを指します。

Closed コードの例

Closed ビード

ビードとは、指定した幅値を使用して、ピクセル値の異なる 2 つの領域間の境界を定義する、連続したエッジペアのことです (必ずしも閉じている必要はありません)。例えば、溶接メタル、接着剤、またはシーラントのパスは、「ビード」パスと呼ばれます。

Closed ビードの例


位置決めおよび検査ツール間にリンクを作成するには

位置決め/検査ツールをジョブに追加すると、[パレット] の [リンク] タブを使用し、プロパティ (入力パラメータおよび出力結果) を結びつけることができます。[リンク] タブでは、ツールの出力結果を他のツールの入力パラメータとして使用することができます。

Closed [リンク] タブを使用するには

[パレット] の [リンク] タブには、現在ジョブにロードされている位置決め/検査ツールのツリービューが表示されます。ツールのプロパティ (入力パラメータおよび出力結果) は、シンボリックタグに参照されています。シンボリックタグとは、ツールプロパティに含まれる値を参照しているシンボルのことです。また、値は、データタイプ (動作、浮動小数点、整数値、または文字列) に関連付けられています。

ツールプロパティは入力および出力プロパティに分けられ、出力プロパティから入力プロパティのみリンクすることができます。出力プロパティは複数かつ個別の入力プロパティとリンクすることができますが、入力プロパティがリンクできるのは、1 つの出力プロパティのみです。

表示するツールプロパティを選択して [リンク] タグで設定するには、ツールプロパティを右クリックし、[プロパティの選択] ダイアログを開きます。[プロパティの選択] ダイアログには、ジョブに含まれるすべてのツールのツリービューリストおよび関連するツールプロパティ (入力・出力とも) が含まれています。表示するプロパティを選択することによって、[リンク] タグのツールプロパティをカスタマイズすることができます。複数のツールプロパティを選択し、[追加]/[削除] ボタンを使用して、一度に複数のツールプロパティを追加または削除することができます。

Closed [リンク] タブのコントロール
[リンク] タブのコントロール

ジョブに含まれるすべてのツールプロパティを開きます。

ジョブに含まれるすべてのツールプロパティを閉じます。

ツールプロパティの表示オプションを切り替えます。

  • デフォルト: [プロパティの選択] メニューで選択したツールプロパティのみを表示します。
  • 標準プロパティを表示: ツールプロパティをサブセットで表示します。説明、総合判定に含める、エラー_数、実行_時間、FAIL_数、PASS_数、ツール有効ステータス および反転は、非表示となります。
  • すべてのプロパティを表示: すべてのツールプロパティを表示します。

ツールプロパティの順番をソートします。

  • デフォルト: ジョブに追加した順番でツールを表示します。最初に追加したツールがリストの 1 番上となります。
  • アルファベット順: ツール名に基づき、アルファベット→カタカナ→漢字の順番でソートします。
  • 依存関係順: 依存関係の順番でツールを表示します。入力プロパティは出力プロパティの上に表示されます。
注:
  • 他のツールにリンクされたツールを削除すると、そのリンクは自動的に削除されます。
  • 入力・出力両方のプロパティがリンクされているツールをジョブにコピー＆ペーストすると、入力プロパティのみが保持されます。
Closed ツール間にリンクを作成するには

ツール出力プロパティと入力プロパティの間のリンクは、出力プロパティノードを適切な入力プロパティノードにドラッグするか、または入力プロパティを右クリックし、[リンク先] コンテクストメニューから適切な出力プロパティを選択することによって作成することができます。

注: リンクプロパティにドラッグ＆ドロップする方法を使用する場合、ショートカットアイコンが表示され、暗い青の矢印がカーソルに表示されます。プロパティをリンクすることができない場合、カーソルに黒いアイコンが表示されます。

ツールプロパティをリンクすると、入力プロパティパラメータはグレーアウトされ、使用不可能になり、ツール名の右側にリンクアイコンが表示されます。リンクアイコンの上にマウスカーソルを動かすと、リンクのソースを示すツールのヒントが表示され、リンクアイコンを右クリックすると、リンクを解除するコンテクストメニューが開きます。

注: 作成したリンクを取り消すには、EasyBuilder ツールバーの取り消しボタンを押すか、またはCTRL+Z を使用します。

Closed ツール間のリンクを削除するには

入力プロパティと出力プロパティの間のリンクを削除するには、入力リンクのプロパティを選択し、Delete キーを押すか、または右クリックしてコンテクストメニューを表示し、[リンク削除] を選択します。

注: リンクの削除を取り消すには、EasyBuilder ツールバーの取り消しボタンを押すか、またはCTRL+Z を使用します。

Closed 例
Closed ID コードの読み取り識別ツールと文字認識識別ーツールをリンクするには

文字認識識別ツールを使用して、ID コードの読み取り識別ツールが返した文字列が正しいかどうかを検証することができます。まず、文字認識ツールの [モード] を [照合] に設定し、[マッチ文字列] に予想される文字列を入力します。次に ID コードの読み取りツールの [文字列] 出力結果を文字認識ツールの [マッチ文字列] 入力パラメータにリンクします。すると、文字列認識ツールは ID コードの読み取りツールによって検査されたコードが正しい文字列かどうかを検証します。


領域

領域は、位置決めおよび検査ツールが検査を行う画像領域を定義します。領域は、検査対象領域 (ROI) とも呼ばれます。

EasyBuilder では、使用するツールによって、異なるタイプの領域が使用されます。領域の種類は、次の通りです。

  • 矩形
  • 円
  • 円環
  • ポリゴン
  • マスク領域
  • ポリラインパス


マスク領域

マスク領域は、エッジ解析を実行する画像エリアを定義するのに使用されます。領域は、エッジの正確な位置を特定するキャリパアレイと連動して使用されます。

Closed マスク領域の凡例

 | コントロール | 説明
1 | サイズ変更用端点マーク (× 4) | 矩形領域の四隅を定義します。端点の 1 つをクリックして、四隅の 1 つから領域のサイズを変更することができます。
2 | マスク | 画像解析を実行しない画像エリアを定義します。領域内からマスクを削除したり、サイズ変更したりすることができます。領域には、最大 99 までのマスクを追加することができます。マスクを始めて追加した場合、領域の始めに追加され、その後に追加されたマスクは、以前に追加されたマスクの次に追加されます。 注: マスクは重ねることができません。マスクが重なるように設定されている場合、自動的に 1 ピクセルバッファが挿入され、マスクの重なりを防ぎます。
3 | スキャン方向インジケータ (× 2) | マスク領域で特徴がスキャンされる方向を定義します。
4 | エッジ検出インジケータ | エッジ遷移が検出される領域内のエリアを定義します。また、領域に新しいマスクを追加することを可能にします。
5 | 回転用ハンドル | 領域を 360 度回転させることができます。
6 | カーブ用ハンドル | 矩形領域を円弧または円形に曲げることができます。
Closed マスク領域のマウス動作

領域内のさまざまな場所にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、以下の動作を行うことができます。

マウスアイコン | 説明
 | 画像内の任意の場所にマスク領域全体をドラッグできます。
 | 領域全体を水平または垂直に拡大縮小することができます。また、マスクのサイズ変更にも使用されます。
 | マウスカーソルの位置により、以下の 2 つの動作を行うことができます。回転用ハンドルの上にある場合、領域を現在の向きから 360 度回転させることができます。カーブ用ハンドルの上にある場合、領域を円弧または円環に再形成して、円状のエッジ特徴を検出できるようにします。
 | 領域内にマスクをドラッグできます。
 | 領域内にマスクを追加したり、削除したりできます。このアイコンを表示し、マウスを右クリックすると、[マスクの追加] または [マスクの削除] オプションメニューが開きます。


ポリラインパス領域

ポリラインパス領域は、エッジ解析を実行する画像エリアを定義するのに使用されます。領域は、エッジの正確な位置を特定するキャリパアレイと連動して使用されます。

注:

  • グラフィックスの編集中は、右クリックメニューを使用して、線分を追加または削除することができます。

  • ポリラインパス領域では、領域の最大化ボタンは OFF となっています。
Closed ポリラインパス領域の凡例

 | コントロール | 説明
1 | ポリラインパスの頂点 (x3) | ポリライン線分のパスを定義します。頂点をクリックして、ポリラインの位置を決めます。
2 | スキャン方向インジケータ (× 2) | ポリラインパス領域で特徴がスキャンされる方向を定義します。
3 | ポリラインパス | ポリラインのプロットをグラフィカルに表示します。
4 | 回転用ハンドル | 領域を 360 度回転させることができます。
Closed ポリライン領域のマウス動作

領域内のさまざまな場所にマウスカーソルを置くと、マウスカーソルアイコンが自動的に変わり、以下の動作を行うことができます。

コントロール | 説明
 | 画像内の任意の場所にポリライン領域全体をドラッグできます。
 | 領域全体を水平または垂直に拡大縮小することができます。また、マスクのサイズ変更にも使用されます。
 | 領域を現在の向きから 360 度回転できます。
 | 領域内でポリラインを移動できます。
 | ポリラインパスに頂点を追加できます。1 つのポリラインに最大 99 個の頂点を追加できます。99 個の頂点をポリラインに追加すると、このオプションは無効になります。


EasyBuilder スマートセレクションとは

EasyBuilder スマートセレクション – スマートフィーチャー、スマートリミットおよびスマートセッティング – を使用すると、ツールおよびアプリケーションの条件に基づいて、インテリジェントなデフォルトしきい値を自動的に決定することにより、アプリケーションの設置をスピードアップすることができます。

注: EasyBuilder でアプリケーションを設定する場合は、アプリケーションに適したデフォルトのしきい値を設定できるように、検査対象製品または対象物の『PASS』画像を使用してください。

  • スマートフィーチャー
  • スマートリミット
  • スマートセッティング


スマートフィーチャーとは

特定の位置決めおよび検査ツールでは、選択したツールに基づいて画像から特徴を抽出し、検査に使用する特徴をポイント＆クリックして選択することができます。

これらのツールがジョブに追加された場合、ツールは画像を自動的に検査し、どの特徴がツールの条件にマッチするかを決定します。例えば、エッジ位置決めツールでは、水平または垂直方向のエッジのみを返し、円の直径および円の同心度寸法測定ツールでは、円形状の特徴のみを返します。

Closed 例
Closed スマートフィーチャー - エッジ

Closed スマートフィーチャー - 円

特徴が事前に定義されていない場合、水色で提示されます。既存の特徴 (他の位置決めまたは検査ツールで定義された、パターン、ブロブ重心、距離、エッジまたは円など) は緑色で提示されます。

Closed 例

スマートフィーチャー – 新たに検出されたものと、定義済みのもの

検査に使用する特徴をクリックしてください。領域が未定義の場合、EasyBuilder はその特徴に適した領域を自動的に作成します。

注: 目的の特徴がスマートフィーチャーとして表示されない場合は、次のいずれかの方法を行ってください。
  • ほかのスマートフィーチャーを選択し、自動的に作成された領域を目的の特徴の上に移動します。そして、目的の特徴が検出されるようにツールのパラメータを調整します。
  • 有無判定または幾何・計測ツールを使用して、検査に使用する特徴を定義します。次に、ツールを再度追加して、目的の特徴を選択します。


スマートリミットとは

[制限範囲] タブの表示される検査ツールでは、自動的に [最大] および [最小] 範囲が設定されます。

ヒント: よりよい結果を得るため、スマートセッティングを使用の際には『PASS』画像の登録から始めてください。

[制限範囲] タブの表示されるツールがジョブに追加されると、ツールは画像を自動的に検査し、ツールの条件に基づいて適切な最大および最小範囲を決定します。例えば、距離および角度結果寸法測定ツールの最大および最小制限範囲は、距離および角度値の ±5% 内であるのに対し、計数ツールの制限範囲は、最初の画像で検出された特徴の数によって決定されます。


スマートセッティングとは

円およびエッジを定義する位置決めおよび検査ツールでは、[コントラスト] パラメータ値をエッジ特徴が検出されるまで自動的に増加させることにより、アプリケーションに基づいたしきい値をすばやく設定できることができます。

注: よりよい結果を得るため、スマートセッティングを使用の際には『PASS』画像の登録から始めてください。

円またはエッジ位置決め/検査ツールがジョブに追加されると、ツールは画像を自動的に検査します。同時に、適切なコントラスト設定を決定して、設定値を2 レベル分下げたしきい値を設定します。デフォルトのコントラスト設定は 25 で、最小は 5 です。


検査ツールを選択するには

検査ツールは、検査タイプによってグループ分けされます。

Closed 有無判定ツール

画像内の特徴の有無を判定します。

  • 輝度
  • コントラスト
  • PatMax RedLine パターン
  • PatMax パターン
  • パターン
  • ピクセル計数
  • カラーピクセル計数
  • ブロブ
  • カラーブロブ
  • エッジ
  • 円
  • シャープネス
Closed 寸法測定ツール

画像中の特徴の距離、直径、角度および面積を測定するのに使用します。

  • 距離
  • 角度
  • ブロブ面積
  • ブロブ面積 (1-10)
  • カラーブロブ面積
  • カラーブロブ面積 (1-10)
  • 円の直径
  • 円の同心度
  • 半径測定
  • 最小/最大点
Closed 計数ツール

画像中の特徴の距離、直径、角度および面積を測定するのに使用します。

  • ブロブ
  • カラーブロブ
  • エッジ
  • エッジペア
  • PatMax RedLine パターン
  • PatMax パターン
  • パターン
Closed 識別ツール

画像内のバーコード、2D コード、シンボル、英数字文字列、パターン特徴およびカラーを識別、検証するのに使用します。

  • 1D コードの読み取り
  • 1D コードの読み取り (1-20)
  • 2D コードの読み取り
  • 2D コードの読み取り (1-20)
  • 郵便コードの読み取り
  • ID コードの読み取り*
  • 文字認識*
  • 文字認識 (OCRMax)
  • PatMax RedLine パターン (1-10)
  • PatMax パターン (1-10)
  • パターン (1-10)
  • カラー
  • カラーモデル

* ID コードの読み取りおよび文字認識ツールはレガシーツールで、In-Sight Explorer 4.7.0 以降のシステムではサポートされていません。

Closed 幾何・計測ツール

画像内に幾何学参照図形を作成します。演算＆ロジックツールや寸法測定ツールなどの他の検査ツールによって参照することができます。

  • 2 点間の直線
  • 2 点間の中点
  • 2 点間の距離
  • 垂直線
  • 直線交点
  • 角度 2 等分
  • N 点を通る直線
  • N 点を通る近似円
  • 円-直線交点
  • ユーザ定義点
  • ユーザ定義直線
  • 最適円
  • 最適ライン
Closed 演算＆ロジックツール

ツールデータおよびジョブデータに結果に基づき、条件付きでツールをリンクさせたり、出力されたツールに数学演算を実行したり、ツールの統計処理を行ったり、ツールをグループ化したり、演算順序のステップを作成したりするのに使用します。

  • 演算
  • ロジック
  • トレンド
  • 統計
  • グループ
  • シーケンス
  • 点計算
  • 変数
Closed プロットツール

数式に基づき、画像にグラフィックスを計算するのに使用します。

  • 円弧
  • 円
  • 十字
  • ライン
  • 点
  • 領域
  • 文字列
Closed 画像フィルタツール

画像解析用に、画像または画像領域を強調するのに使用します。

  • フィルタ
  • 近傍
  • シーン補正
  • 輝度
  • カラーからグレースケール変換
  • カラーから二値化変換
  • 変換
  • 比較
Closed キャリブレーションツール

ジョブ間で共有可能なキャリブレーションファイルを作成します。

  • N 点
  • シーケンス N 点
Closed 欠陥検出ツール

検査対象物に、亀裂、ひだ、くぼみ、ギャップ、切り目、または傷などの欠陥があるかどうかを決定するのに使用します。

  • 傷検査
  • エッジ
  • エッジペア
  • エッジ幅
  • ビードファインダー
  • ビードトラッカー

注: 位置決めおよび検査カラーツールを有効にするには、In-Sight カラービジョンシステムまたはエミュレータに接続する必要があります。


輝度有無判定ツール

輝度有無判定ツールは、領域内ピクセルの平均グレー値 (＝輝度) を基に特徴の有無を判定し、 その値を表示します。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果

輝度有無判定ツールは、良品の特徴が不良品の特徴と比較して非常に黒い、または白い場合に有用です。 特徴の輝度の上昇または低下は、検査対象物の有無を示します。 例えば、領域内の輝度を計測することによって、黒または白の瓶キャップの有無をすばやく判定することができます。

  1. 輝度有無判定ツールを設定するには
    1. 特徴を選択するには
  2. 輝度有無判定ツールのパラメータを調整するには
  3. 輝度有無判定ツールの入出力プロパティを使用するには


輝度有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


特徴を選択するには

特徴を選択する際には、次のガイドラインを参考にしてください。

  • フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにしてください。または、特徴が移動しても十分にカバーできる大きさに領域を設定するようにするにしてください。
  • 輝度ツールは、検査対象に単一のグレー値 (黒または白など) のみ存在するといったアプリケーションに有用です。
Closed 例

この例では、ボトルキャップ対し、2 つのエッジ位置決めツールが、2 つの検査ツールをフィクスチャするために使用されています。1 つは輝度ツールで、液体の有無を検知するための領域が設定されています。もう 1 つは、コントラストツールで、ボトルキャップが締められているかどうかを検知するための領域が設定されています。輝度ツールは液体部分に領域が設定されています。これは、液体がボトルに入っている場合、単一のグレー値 (約10～20) となり、入っていない場合はグレー値が 255 となるためです。シールが破けた場合にグレー値が複数となるため、コントラストツールの領域は、ボトルキャップ部分に設定されています。


輝度有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

輝度有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


輝度有無判定ツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、輝度有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

Closed PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

Closed 輝度メータおよび PASS 範囲

最小および最大輝度レベルを設定します。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

  • 左ハンドル: 平均グレースケール値の最小許容範囲を設定します。(0 - 255)
  • 右ハンドル: 平均グレースケール値の最大許容範囲を設定します。(0 - 255)
  • 結果インジケータ: 領域内のピクセルの平均グレースケール値を表示します。インジケータが左右ハンドルの間にある場合、ツールは PASS となり、結果インジケータは緑で表示されます。そうでない場合、ツールは FAIL となり、結果インジケータは赤で表示されます。
PASS
FAIL

注: スライダコントロール上にマウスポインタを重ねると、[結果] および [PASS 範囲] が表示されます。

Closed [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

Closed 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 名前

輝度ツールの名前を定義します。デフォルト名は輝度_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注: このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (輝度有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は輝度_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (輝度有無判定ツール)

Closed 最大

最大グレー値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 輝度

領域内に検出されたピクセルの平均グレー値 (0～255) を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

最小グレー値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (輝度有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の 3 本の垂直線は、[最小]、[輝度] および [最高] パラメータのグレー値 (ピクセル) を順番に表します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (輝度有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


輝度有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
輝度 | 浮動小数点 | X |
合成領域 | 動作 | X |
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 | X | 入力
最大 | 浮動小数点 | X | 入力
最小 | 浮動小数点 | X | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
輝度 | 浮動小数点 | X | 出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X | 出力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X | 出力
ステータス | 整数値 | X | 出力
ツール有効ステータス | 整数値 | X | 出力
合成領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
輝度 | 浮動小数点 | X | X | 出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
合成領域 | 動作 |  | X |


コントラスト有無判定ツール

コントラスト有無判定ツールは、領域内のピクセル特徴間のコントラスト値を基に、特徴の有無を判定し、その値を表示します。 (コントラスト値とは、しきい値以上の平均グレー値としきい値以下の平均グレー値の差分を示す値です) 。

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果

コントラスト有無判定ツールは、良品の特徴に、不良品の特徴と比較して非常に白い、または黒いエリアがある場合に有用です。 例えば、白ラベル上の黒い印字の有無を検証する場合などです。

  1. コントラスト有無判定ツールを設定するには
    1. 特徴を選択するには
  2. コントラスト有無判定ツールのパラメータを調整するには
  3. コントラスト有無判定ツールの入出力プロパティを使用するには


コントラスト有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


特徴を選択するには

特徴を選択する際には、次のガイドラインを参考にしてください。

  • フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにしてください。または、特徴が移動しても十分にカバーできる大きさに領域を設定するようにするようにしてください。
  • コントラストツールは、検査対象に特徴が存在する場合に複数のグレー値が含まれ、存在しない場合にグレー値が均一となるといったアプリケーションに有用です。
  • 輝度やコントラストより微妙な差別化がアプリケーションに必要な場合、ピクセル計数ツールを使用してください。ピクセル計数ツールは、コントラストツールより差異を正確に計測することができます。
Closed 例

この例では、ボトルキャップ対し、2 つのエッジ位置決めツールが、2 つの検査ツールをフィクスチャするために使用されています。1 つは輝度ツールで、液体の有無を検知するための領域が設定されています。もう 1 つは、コントラストツールで、ボトルキャップが締められているかどうかを検知するための領域が設定されています。輝度ツールは液体部分に領域が設定されています。これは、液体がボトルに入っている場合、単一のグレー値 (約10～20) 、入っていない場合はグレー値が 255 となるためです。シールが破けた場合に、複数のグレー値となるため、コントラストツールの領域は、ボトルキャップ部分に設定されています。


コントラスト有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

コントラスト有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


コントラスト有無判定ツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、コントラスト有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

Closed PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

Closed コントラストメータおよび PASS 範囲

最小および最大コントラストレベルを設定します。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

  • 左ハンドル: 平均グレースケール値の最小許容範囲を設定します。(0 - 255)
  • 右ハンドル: 平均グレースケール値の最大許容範囲を設定します。(0 - 255)
  • 結果インジケータ: 領域内のピクセルの平均グレースケール値を表示します。インジケータが左右ハンドルの間にある場合、ツールは PASS となり、結果インジケータは緑で表示されます。そうでない場合、ツールは FAIL となり、結果インジケータは赤で表示されます。
PASS
FAIL

注: スライダコントロール上にマウスポインタを重ねると、[結果] が表示されます。

Closed [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

Closed 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
Closed 名前

検査ツールの名前を定義します。デフォルト名はコントラスト_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注: このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (コントラスト有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はコントラスト_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (コントラスト有無判定ツール)

Closed 最大

最大コントラスト値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed コントラスト

「スマート」しきい値上下の平均グレー値間の差を表示します。値が [最小]～[最大] の範囲内にある場合、 PASS を返します。

Closed 最小

最小コントラスト値 (0～255) を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (コントラスト有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の 3 本の垂直線は、しきい値下の平均グレー値、しきい値、およびしきい値上の平均グレー値を順番に表します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (コントラスト有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


コントラスト有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
合成領域 | 動作 | X |
コントラスト | 浮動小数点 | X |
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 | X | 入力
最大 | 浮動小数点 | X | 入力
最小 | 浮動小数点 | X | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
コントラスト | 浮動小数点 | X | 出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X | 出力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X | 出力
ステータス | 整数値 | X | 出力
ツール有効ステータス | 整数値 | X | 出力
合成領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
コントラスト | 浮動小数点 | X | X | 出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
合成領域 | 動作 |  | X |


PatMax RedLine パターン および PatMax パターン有無判定ツール

注:
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターンおよび PatMax RedLine パターン (1-10) 位置決めツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン および PatMax パターン有無判定ツールは、登録済みのパターン (モデルと呼ばれます) を基に、PatMax RedLine または PatMax アルゴリズムを使用して、パターンの有無を決定します。

これらのツールは、不良品にはなく良品に認識できる特徴がある場合に、あるいはその逆の場合に有用です。 例えば、機械の組み立てにおいてネジ山の有無を検証する場合などです。

  1. PatMax RedLine パターンおよび PatMax パターン有無判定ツールを設定するには
    1. PatMax RedLine パターン、PatMax パターンおよびパターン
    2. パターンを選択するには
  2. PatMax RedLine パターンおよび PatMax パターン有無判定ツールのパラメータを調整するには
  3. PatMax RedLine パターンおよび PatMax パターン有無判定ツールの入出力プロパティを使用するには


PatMax RedLine パターンおよび PatMax パターン有無判定ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。
  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


PatMax RedLine パターン、PatMax パターンおよびパターン

注:PatMax RedLine パターン有無判定ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


パターンを選択するには

パターンを選択する際には、次のガイドラインを参考にしてください。

  • そのパターンがすべての画像に存在していること。
  • ユニーク性の高い特徴や一貫性の高い特徴をできるだけ多くそのパターンに含めること。また、検査対象物全体の形状に対してそのパターンが常に一定の位置に、かつ明確に存在すること。
  • できるだけ大きなパターンを選択すること。大きなパターンはユニークな特徴を多く含むため、それだけ一貫した正確な検査を行うことができます。


PatMax RedLine パターンおよび PatMax パターン有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax RedLine パターンおよび PatMax パターン有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [モデル] および [サーチ] タブ
  • [登録画像] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注: PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

Closed 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。デフォルトでは、[PatMax] が選択されています。PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

Closed クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

Closed 極性を無視

モデルパターンに対し、カラー変換したマッチ特徴を検出パターンに含むかどうか指定します (デフォルト = OFF)。[極性を無視] を ON にすると、例えば、モデルパターン内の黒/白 vs. 白/黒など、カラー変換した特徴を含む検出パターンが、モデルパターンにマッチしていると分類されます。

Closed 反転
ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。 ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 5,000 に設定されています。
Closed 結果

ツールの結果が表示されます。パターン特徴が検出された場合は、[あり] が表示され、モデルパターンとの類似度が表示されます。パターン特徴が検出されなかった場合、または複数のインスタンスのパターンが検出された場合、[なし] が表示されます。Present equates to a Boolean value of 1 (Pass); Not Present equates to a Boolean value of 0 (Fail).

注:PatMax RedLine パターンには、[検出モード] パラメータは含まれていません。


[モデル] および [サーチ] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


[登録画像] タブ (PatMax RedLine パターンおよび PatMax パターン有無判定ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


PatMax RedLine パターンおよび PatMax パターン有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
コントラストしきい値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部再登録 | 整数値 | X |  | 入出力
検出モード1 | 整数値 | X | X | 入出力
極性を無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
クラッタ | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
パターン | 文字列 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
スケール | 浮動小数点 | X | X | 出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |
登録 | 動作 | X | X |
1 このツールプロパティは、PatMax パターン有無判定ツールでのみ使用可能です。


パターン有無判定ツール

パターン有無判定ツールは、登録済みのパターン (モデルと呼ばれます) を基に、パターンの有無を決定します。

パターン有無判定ツールは、不良品にはなく良品に認識できる特徴がある場合に、あるいはその逆の場合に有用です。 例えば、機械の組み立てにおいてネジ山の有無を検証する場合などです。

  1. パターン有無判定ツールを設定するには
    1. パターンを選択するには
    2. PatMax パターン vs. パターン
  2. パターン有無判定ツールのパラメータを調整するには
  3. パターン有無判定ツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000-110 および 2000-120/120C ビジョンセンサ | PASS/FAIL ステータスのみ
In-Sight 2000-130/130C ビジョンセンサ | PASS/FAIL ステータスおよびパターンの得点
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果


パターン有無判定ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。
  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

注: モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。

  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターン有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

パターン有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [登録画像] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


パターン有無判定ツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、パターン有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

Closed PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

Closed 回転許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 45 度です。大きな値を設定すると、ツールの実行時間が増大します。左ハンドルはマイナスの回転許容値を、右ハンドルはプラスの回転許容値を設定します。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、回転許容値を調整することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

Closed パーツ検出メータ

パーツ検出メータは、ツールがいかによく特徴を検出したかを表示し、最小アクセプトしきい値を設定します。最小アクセプトしきい値は、手動で設定することができます。ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を調整してください。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

メータの示す値がしきい値より高い場合、パーツは検出されたとみなされ、メータは緑で表示されます。しきい値より低い場合、パーツは検出されなかったとみなされ、メータは表示されなくなります。パーツ以外の物を検出したり、間違った特徴を検出したりしている場合、ハンドルを右に動かしてください。パーツ検出に失敗している場合、ハンドルを左に動かしてください (または、モデル領域を新規作成してください)。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

PASS
FAIL

注: スライダコントロール上にマウスポインタを重ねると、[結果] および [しきい値] が表示されます。

Closed 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
Closed ±10% スケール許容

検出パターンとモデルパターン間の ±10% のスケール変化を許容するかどうかを指定します。

登録パターン | 検出パターン: +10% | 検出パターン: -10%
OFF (デフォルト) | (FAIL) | (FAIL)
ON | (PASS) | (PASS)
Closed 手動タイムアウトを使用する

タイムアウト設定を使用するかどうかを指定します。

  • OFF (デフォルト): タイムアウト設定は無効です (タイムアウトしません)。

  • ON: タイムアウト設定を有効にします。 編集ボックスを使用して、手動でタイムアウト値をミリ秒単位で指定します。(0 ～ 30000)

    注: 値を 0 に設定すると設定が無効になり、タイムアウトは適用されません。
Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 名前

検査ツールの名前を定義します。 デフォルト名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注: このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。

Closed 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注:
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed モデル領域

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


[全般] タブ (パターン有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン有無判定めツール)

Closed 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注:
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。 デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。 スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

Closed 反転
ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。 ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

Closed 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

Closed タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed 結果

ツールの結果が表示されます。パターン特徴が検出された場合は、[あり] が表示され、モデルパターンとの類似度が表示されます。パターン特徴が検出されなかった場合、または複数のインスタンスのパターンが検出された場合、[なし] が表示されます。 [あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。


登録画像タブ (パターン有無判定ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | 入力
高精度モード | 整数値 |  | 入力
角度許容値 | 整数値 | X | 入力
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
外部登録 | 整数値 |  | 入力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 | X | 入力
モデル | 動作 | X |
モデルタイプ | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
結果 | 文字列 | X |
スケール許容 | 整数値 | X | 入力
得点* | 浮動小数点 | X | 出力
サーチ | 動作 | X |
ステータス | 整数値 | X |
タイムアウト | 整数値 | X | 入力
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |
登録 | 動作 | X |
*In-Sight 2000-130/130C ビジョンセンサのみ

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | 入出力
高精度モード | 整数値 | X | 入出力
角度許容値 | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
外部登録 | 整数値 |  | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
モデルタイプ | 整数値 | X | 入出力
スケール許容 | 整数値 | X | 入出力
タイムアウト | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X | 出力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X | 出力
パターン | 文字列 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 整数値 | X | 出力
ツール有効ステータス | 整数値 | X | 出力
モデル | 動作 | X |
サーチ | 動作 | X |
登録 | 動作 | X |
登録の入力 | 整数値 | X | 入出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
高精度モード | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部登録 | 整数値 | X |  | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
モデルタイプ | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
パターン | 文字列 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |
登録 | 動作 | X | X |
登録の入力 | 整数値 | X | X | 入出力


ピクセル計数有無判定ツール

ピクセル計数有無判定ツールは、領域内の白または黒のピクセル数を基に、特徴の有無を判定し、その値を表示します。

このツールは、白黒ピクセル間の画像を切り分けるグレーしきい値 (0～255) の最適な値を計算し、しきい値以上または以下 (設定によって異なります) のピクセル数をカウントします。

ピクセル計数有無判定ツールは、領域内の白または黒ピクセル数を基に、特徴の有無を判定する場合に有用です。 例えば、回路基板リードの周囲に適切な量のはんだが施されたかどうか、またはラベル上にインクジェットの文字列があるかどうかを検証する場合などです。

  1. ピクセル計数有無判定ツールを設定するには
    1. 特徴を選択するには
  2. ピクセル計数有無判定ツールのパラメータを調整するには
  3. ピクセル有無判定ツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果


ピクセル計数有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


特徴を選択するには

特徴を選択する際には、次のガイドラインを参考にしてください。

  • フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在すること。または、特徴が移動しても十分にカバーできる大きさに領域を設定するようにすること。
  • ピクセル計数は、検査対象に特徴が存在する場合に複数のグレー値が含まれ、存在しない場合にグレー値が均一となるといったアプリケーションに有用です。
  • ピクセル計数ツールは、輝度とコントラストの間の微妙な違いを差別化することができます。したがって、輝度有無判定ツールやコントラスト有無判定ツールより正確に差異を計測することができます。
Closed 例

この例では、はんだパッドが適切に基板とリードにはんだ付けされていることを確認するため 3 つのピクセル計数ツールが使用され、さらにこの 3 つのピクセル計数をフィクスチャするために、2 つのエッジ位置決めツールが回路基板のコントラストの高いエッジで使用されています。


ピクセル計数有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

ピクセル計数有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ピクセル計数有無判定ツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、ピクセル計数有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

Closed PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

Closed ピクセルセレクタ

白黒ピクセルのエリアを、どのように切り分けるかを定義します。 デフォルトでは、黒ピクセルの数がカウントされ、領域内の黒ピクセルが黄色にハイライトされて表示されます。

オリジナル画像

選択されたピクセルの色 = 黒

左ハンドルはしきい値 (低) を、右ハンドルはしきい値 (高) を設定します (0～255)。 ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

白ピクセルの数をカウントするには、 [image] を押してください。 領域内の白ピクセルが黄色にハイライトされて表示されます。

選択されたピクセルの色 = 白
Closed [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

Closed ピクセル計数メータおよび PASS 範囲

領域内で許容されるピクセル数を指定します。 ハンドルを使用して、黒または白ピクセルの最小および最大数を設定します。カウントされたピクセル数が設定範囲内であれば、ツールは PASS となります。

PASS
FAIL

結果が左右ハンドルの間にある場合、ツールは PASS となり、メータが緑色の線で囲われます。 そうでない場合、ツールは FAIL となり、赤い線で囲われます。

ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

注: スライダコントロール上にマウスポインタを重ねると、[結果] (領域内で検出されたピクセルの数) および [PASS 範囲] が表示されます。

Closed 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
Closed 詳細の表示

カウントされたピクセルを EasyBuilder の画像エリアに常に表示するかどうかを定義します (黄色でハイライトされます)。

ヒント: カウントされたピクセルを VisionView で表示するには、[通信] アプリケーションステップの EasyView 内で [詳細の表示] シンボリック名を選択し、VisionView アプリケーション上の Show_Details チェックボックスを ON にします。 VisionView 上でのデータの表示方法についての詳細は、EasyView を設定するにはをご参照ください。

  • ON ( [image] = デフォルト): カウントされたピクセルは常に画像エリアに表示されます。ただし、他の位置決めまたは検査ツールが編集されている場合は除きます。

  • OFF ( [image]): このツールが編集されているときのみ、カウントされたピクセルは画像エリアに表示されます。

Closed 選択したピクセルを反転させる

カウントするピクセルの色を変更します (黒 [image] または白 [image] 、デフォルト = 黒)

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 名前

検査ツールの名前を定義します。 デフォルト名はピクセル_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注: このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (ピクセル計数有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はピクセル_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ピクセル計数有無判定ツール)

Closed しきい値モード

画像領域を白黒のピクセルに切り分けるグレー値を決める方法を指定します。[自動] (デフォルトは [自動]) を選択した場合、画像取り込みのたびにツールは画像に基づいてスマートセッティングを作成し、画像間の輝度の変化を調整します。[手動] を選択した場合、2 つのしきい値の値を手動で入力、調整してください。

Closed しきい値 (低)

白ピクセルを黒ピクセルから切り分けるグレー値を定義します (0～255、有効時)。[しきい値 (高)] で設定した値 ≤ [しきい値 (低)] で設定した値の場合、白ピクセルは [しきい値 (低)] ≤ 値 ≤ [しきい値 (高)] として指定されます。また、[しきい値 (高)] < [しきい値 (低)] の場合、白ピクセルは、値 ≤ [しきい値 (高)] または [しきい値 (低)] ≤ 値として指定されます。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。[ヒストグラム] タブのグラフを参考にして、最適な値を設定してください。

  • しきい値 (低) ≤ しきい値 (高): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「白」とみなされ、 範囲外の値は「黒」とみなされます。
  • しきい値 (高) ≤ しきい値 (低): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「黒」とみなされ、 範囲外の値は「白」とみなされます。
Closed しきい値 (高)

白ピクセルを黒ピクセルから切り分けるグレー値を定義します (0～255、有効時)。[しきい値 (高)] で設定した値 ≥ [しきい値 (低)] で設定した値の場合、白ピクセルは [しきい値 (低)] ≤ 値 ≤ [しきい値 (高)] として指定されます。また、[しきい値 (高)] < [しきい値 (低)] の場合、白ピクセルは、値 ≤ [しきい値 (高)] または [しきい値 (低)] ≤ 値として指定されます。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。[ヒストグラム] タブのグラフを参考にして、最適な値を設定してください。

  • しきい値 (低) ≤ しきい値 (高): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「白」とみなされ、 範囲外の値は「黒」とみなされます。
  • しきい値 (高) ≤ しきい値 (低): 実際のグレースケール値に関わらず、2 つのしきい値の範囲内のすべての値は「黒」とみなされ、 範囲外の値は「白」とみなされます。
Closed 極性

ピクセルの色を定義します。選択肢は、黒または白 (デフォルト) です。


[制限範囲] タブ (ピクセル計数有無判定ツール)

Closed 最大

領域内の最大ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed ピクセル

領域内に検出されたピクセル数を表示します。値は 0～ [最大] で設定された値となります。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

領域内の最小ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (ピクセル計数有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ピクセル計数有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ピクセル有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
合成領域 | 動作 | X |
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
しきい値 (高) | 整数値 | X | 入力
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 | X | 入力
しきい値 (低) | 整数値 | X | 入力
最大 | 整数値 | X | 入力
最小 | 整数値 | X | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ピクセル | 整数値 | X |
極性 | 整数値 | X | 入力
詳細の表示 | 整数値 | X | 入力
ステータス | 整数値 | X |
しきい値モード | 整数値 | X | 入力
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 整数値 | X | 入出力
最小 | 整数値 | X | 入出力
極性 | 整数値 | X | 入出力
しきい値 (低) | 整数値 | X | 入出力
しきい値 (高) | 整数値 | X | 入出力
しきい値モード | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X | 出力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X | 出力
ピクセル | 整数値 | X | 出力
ステータス | 整数値 | X | 出力
ツール有効ステータス | 整数値 | X | 出力
合成領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
極性 | 整数値 | X | X | 入出力
しきい値 (低) | 整数値 | X | X | 入出力
しきい値 (高) | 整数値 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
ピクセル | 整数値 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
合成領域 | 動作 |  | X |


カラーピクセル計数有無判定ツール

カラーピクセル計数有無判定ツールは、カラーテーブル内の登録カラーにマッチするピクセル数 (In-Sight 2000 シリーズカラービジョンセンサ) または登録ライブラリの選択したカラーモデル領域にマッチする領域内のピクセル数 (In-Sight カラービジョンシステム) を基に特徴の有無を判定し、値を返します。

注:In-Sight 2000 シリーズビジョンセンサに接続している場合、ツールは PASS/FAIL ステータスのみを表示します。

  1. カラーピクセル計数有無判定ツールを設定するには
  2. カラーピクセル計数有無判定ツールのパラメータを調整するには
  3. カラーピクセル有無判定ツールの入出力プロパティを使用するには


カラーピクセル計数有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

In-Sight 2000 シリーズカラービジョンセンサ

In-Sight カラービジョンシステム

In-Sight 2000 シリーズカラービジョンセンサ

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、ツールのカラー設定を登録します。

    注: カラーを選択するまで、ツールの結果はデフォルトで自動的に FAIL となります。

  4. [カラーの登録] ボタンを押します。 カラー登録コンテキストペインが開きます。
  5. をクリックして、カラーを追加します。
  6. カーソルを画像エリアに動かします。 コンテキストペインに、カラーを選択しやすいよう、拡大画像が表示されます。

  7. クリックして、カラーを選択します。 選択後、カラーは下のカラーテーブルに追加され、選択したカラーにマッチする領域内のピクセルが黄色で表示されます。

    カラー追加前 カラーの選択 カラー追加後
  8. ステップ 6～7 を繰り返して、カラーテーブルに必要なカラーを追加します。
  9. カラーを減算するには、 [image] をクリックしてステップ 6～8 を繰り返します。
  10. [カラー選択の終了] ボタンをクリックして、全般コンテキストペインに戻ります。
  11. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  12. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他の外部デバイスへ出力します。

In-Sight カラービジョンシステム

カラーピクセル計数有無判定ツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする領域内のピクセル数を決定します。 ツールは、その後、有効なカラーモデルにマッチする各ピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、2 値化グレースケール出力画像を作成します。 この 2 値化出力画像を使用して、画像をサーチし、有効なカラーモデルにマッチするピクセル数を記録します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 特徴の全体を囲むように領域を配置します (領域は、特徴のみ含めるようにしてください。領域が特徴より大きいと、背景の輝度も測定されてしまうため、不正確な結果が返されることがあります)。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その特徴がすべての画像のほぼ同じ場所に存在するようにするか、または特徴が移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


カラーピクセル計数有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

ピクセル計数有無判定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


カラーピクセル計数有無判定ツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、ピクセル計数有無判定ツールのパラメータを調整するにはの [In-Sight ビジョンシステム] セクションをご参照ください。

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

全般コンテキストペイン

Closed PASS/FAIL インジケータ

緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。

Closed カラーの登録

カラー登録コンテキストペインを開きます。

Closed カラータイル

カラー登録コンテキストペインで [追加カラーの選択] ボタンを使用して追加した、最初の 5 色の登録カラーを表示します。 カラータイルをクリックすると、カラー登録コンテキストペインが開きます。

Closed ピクセル計数メータおよび PASS 範囲

領域内で許容されるピクセル数を指定します。 ハンドルを使用して、ピクセルの最小および最大数を設定します。カウントされたピクセル数が設定範囲内であれば、ツールは PASS となります。

PASS
FAIL

結果が左右ハンドルの間にある場合、ツールは PASS となり、メータが緑色の線で囲われます。 そうでない場合、ツールは FAIL となり、赤い線で囲われます。

ハンドルを調整したり、対応する編集ボックスに値を入力したりして、値を設定することができます。

ヒント: 矢印キー (上、下、右、左) を使って、ハンドルを動かすことができます。

注: スライダコントロール上にマウスポインタを重ねると、[結果] (領域内で検出されたピクセルの数) および [PASS 範囲] が表示されます。

Closed [自動] ボタン

最大結果値の +/-10% を最新のツール結果に加算し、制限範囲を自動的に設定します。例えば、最大結果値が 255 で、最新のツール結果が 150 の場合、[自動] ボタンをクリックすると、最小制限範囲は 125 (=150-25)、最大制限範囲は 175 (=150+25) に自動的に設定されます。

Closed 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
Closed 詳細の表示

カウントされたピクセルを EasyBuilder の画像エリアに常に表示するかどうかを定義します (黄色でハイライトされます)。

ヒント: カウントされたピクセルを VisionView で表示するには、[通信] アプリケーションステップの EasyView 内で [詳細の表示] シンボリック名を選択し、VisionView アプリケーション上の Show_Details チェックボックスを ON にします。 VisionView 上でのデータの表示方法についての詳細は、EasyView を設定するにはをご参照ください。

  • ON ( [image] = デフォルト): カウントされたピクセルは常に画像エリアに表示されます。ただし、他の位置決めまたは検査ツールが編集されている場合は除きます。

  • OFF ( [image]): このツールが編集されているときのみ、カウントされたピクセルは画像エリアに表示されます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 名前

検査ツールの名前を定義します。 デフォルト名はカラーピクセル_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed フィクスチャ

ツールに使用するフィクスチャを選択します。フィクスチャコントロールが有効な場合、[フィクスチャ] ボタンはオレンジ色になります。

注: このコントロールは、フィクスチャを定義するツールがすでに追加されている場合のみ、有効になります。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

カラー登録コンテキストペイン

Closed [追加カラーの選択] および [減算カラーの選択] ボタン

  • 追加カラーの選択: 追加カラーをカラーテーブルに追加します。 領域内に存在するピクセルの数を決定する際に、このボタンで選択したカラーが計算に含まれます。 選択後、追加カラーにマッチする領域内のピクセルが黄色で表示されます。

    注: このボタンを使用して追加した最初の 5 色のカラーは、「カラータイル」として全般コンテキストペインに表示されます。

    カラー追加前 カラー追加後
  • 減算カラーの選択: 減算カラーをカラーテーブルに追加します。 領域内に存在するピクセルの数を決定する際に、このボタンで選択したカラーは除外されます。

[追加カラーの選択] または [減算カラーの選択] ボタンのクリック後、カーソルを画像エリアに移動すると、カラーを選択しやすいように、コンテキストペインに拡大画像が表示されます。

拡大画像
Closed カラーテーブル

  • カラー: [追加カラーの選択] および [減算カラーの選択] ボタンを使用して追加したカラーを表示します。

    注: スライダコントロール上にマウスポインタを重ねると、RBG 値が表示されます。

  • 許容値: カラーの許容値を定義します (0 - 10; デフォルト = 2)。 許容値を上げる/下げると、登録カラーの色相がより多く/少なく含まれるようになります。

    注: スライダコントロール上にマウスポインタを重ねると、許容値が表示されます。

    オリジナル画像

    許容値 = 0.5

             許容値 = 2 (デフォルト) 許容値 = 7
  • 操作:
    • カラー減算に変更: 領域内でカラーは黄色に表示され、領域内に存在するピクセルの数を決定する際に計算に含まれます。 このボタンはトグルです。カラー減算に変更するには、このボタンをクリックしてください。
    • カラー追加に変更: 領域内に存在するピクセルの数を決定する際に除外されます。 このボタンはトグルです。カラー追加に変更するには、このボタンをクリックしてください。

    • 上へ/下へ: テーブル内のカラーの操作順を変更します。 カラー操作は上から下の順番で実行されます。

    • カラーの削除: カラーをテーブルから削除します。
Closed 輝度を無視

[輝度を無視] チェックボックスが ON の場合 (デフォルト)、登録カラーより暗い/明るいピクセルが多数、計算に含まれます。 このオプションを使用すると、画像の輝度が視野内を通して均一でない場合、ツールのパフォーマンスを上げることができます。 ただし、登録カラー以外の黒/白ピクセルを計算に含むべきでない場合、チェックボックスを OFF にしてください。

Closed カラー選択の終了

[全般] コンテキストペインに戻ります。

カラー操作の例

Closed 例

この例では、画像中の「青」と「緑」のチョークを選択します。

例 1

  1. 画像中の「青」と「緑」のチョークを [追加カラーの選択] [image] ボタンを使用して選択します。

    オリジナル画像 「青 (追加)」および「緑 (追加)」を選択

  2. その結果、紫のチョークも部分的にハイライトされてしまいます。これは、これらの色 (青、緑および紫) がよく似ているからです。 「紫」は「青」から派生しており (次の画像をご参照ください) 、青 (もしくはダークシアン) を選択すると、似た色が紫から選択されてしまいます。

  3. 次に、画像から「紫」を減算します。 紫のチョークのハイライトされた部分から、[減算カラーの選択] [image] ボタンを使用して、「紫」を選択します。

    「紫 (減算)」を選択
  4. 青と緑のチョークの選択に成功しました。

例 2

この例では、画像中の「青」と「緑」のチョークを選択します。ただし、カラー操作の順番が例 1 とは異なるため、望む結果が得られない可能性があります。

  1. 画像中の「青」のチョークを [追加カラーの選択] [image] ボタンを使用して選択します。

  2. [減算カラーの選択] [image] ボタンを使用して、「紫」を選択します。

    「青 (追加)」および「紫 (減算)」を選択

  3. 画像中の「緑」を [追加カラーの選択] [image] ボタンを使用して選択します。

    「緑 (追加)」を選択
  4. その結果、紫のチョークも部分的にハイライトされてしまいます。これは、緑が紫によく似ているからです。 緑を選択すると、似た色が紫から選択されてしまいます。
  5. 画像から紫を取り除くには、[下へ] [image] ボタンを使用して紫のカラー操作を下に動かすか、 あるいは、[減算カラーの選択] [image] ボタンを使用して、「緑」の後に 2 番めの「紫」カラー操作を追加します。


[全般] タブ (カラーピクセル計数有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーピクセル計数有無判定ツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール


[制限範囲] タブ (カラーピクセル計数有無判定ツール)

Closed 最大

領域内の最大ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed ピクセル

領域内に検出されたピクセル数を表示します。値は 0～ [最大] で設定された値となります。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

領域内の最小ピクセル数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


カラーライブラリ (カラーピクセル計数有無判定ツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


[合成領域] タブ (カラーピクセル計数有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーピクセル有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズカラービジョンセンサ

注: OPC は In-Sight 2000 シリーズカラービジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラーライブラリ | 整数値 |  | 入力
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
外部モデル有効の適用 | 整数値 |  | 入力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
最大 | 整数値 |  | 入力
最小 | 整数値 |  | 入力
モデル有効 | 整数値 |  | 入力
モデル有効の選択 | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
詳細の表示 | 整数値 | X | 入力
オリジナル画像の表示 | 整数値 |  | 入力
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight カラービジョンシステム

注:カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部モデル有効の適用 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
オリジナル画像の表示 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ピクセル | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |
モデル有効の適用 | 動作 | X | X |

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


ブロブ有無判定ツール

ブロブ有無判定ツールは、ブロブの有無を判定します。ブロブが検出された場合、[あり] を表示し、PASS となります。ブロブが検出されなかったり、指定された範囲に合致しなかったりした場合、[なし] を表示し、結果は FAIL となります。

ブロブ有無判定ツールは、高速のツールの 1 つで、パターン有無判定ツールより短時間で特徴を検出することができます。このツールは、ピクセルの塊の有無を判定するのに有用です。例えば、型打ちした金属製品に穴があるかどうかを検証する場合などです。

  1. ブロブ有無判定ツールを設定するには
  2. ブロブ有無判定ツールのパラメータを調整するには
  3. ブロブ有無判定ツールの入出力プロパティを使用するには


ブロブ有無判定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ブロブ有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ブロブ有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ有無判定ツール)

Closed しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、常に [ブロブしきい値] の値が使用されます。デフォルトは [自動] です。

Closed ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。グラフを参考にして、最適な値を設定してください。

Closed ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
  • 任意: 黒白両方のブロブを返します。
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed 最小面積

ブロブ面積の最小値をピクセル単位 (0～900000) で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

Closed 最大面積

ブロブ面積の最大値をピクセル単位 (0～900000) で指定します。デフォルトは 100000です。指定された値より大きなブロブは検出されません。

Closed 結果

ツールの結果が表示されます。ブロブが検出された場合は、[あり] が表示されます。ブロブが検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。


[ヒストグラム] タブ (ブロブ有無判定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ブロブ有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ブロブ有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
ブロブの色 | 整数値 | X | X | 入出力
ブロブしきい値 | 整数値 | X | X | 入出力
境界ブロブ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 |  | X |


カラーブロブ有無判定ツール

カラーブロブ有無判定ツールは、カラーブロブの有無を判定します。

カラーブロブツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする領域内のピクセル数を決定します。ツールは、その後、有効なカラーモデルにマッチする各ピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、2 値化グレースケール出力画像を作成します。この 2 値化出力画像を使用して、有効なカラーモデルによって生成されたブロブ特徴を画像からサーチします。

  1. カラーブロブ有無判定ツールを設定するには
  2. カラーブロブ有無判定ツールのパラメータを調整するには
  3. カラーブロブ有無判定ツールの入出力プロパティを使用するには


カラーブロブ有無判定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。
  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。
  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーブロブ有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ有無判定ツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed 最小面積

ブロブ面積の最小値をピクセル単位で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

Closed 最大面積

ブロブ面積の最大値をピクセル単位で指定します。指定された値より大きなブロブは検出されません。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed 結果

ツールの結果が表示されます。ブロブが検出された場合は、[あり] が表示されます。ブロブが検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。


[合成領域] タブ (カラーブロブ有無判定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーライブラリ (カラーブロブ有無判定ツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


カラーブロブ有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注:カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
境界ブロブ | 整数値 | X | X | 入出力
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部モデル有効の適用 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
平滑化係数 | 整数値 | X | X | 入出力
オリジナル画像の表示 | 整数値 | X | X | 入出力
ブロブ関数 | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |
モデル有効の適用 | 動作 | X | X |

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


エッジ有無判定ツール

エッジ有無判定ツールは、指定したパラメータに合致するエッジ特徴の有無を判定します。

エッジ有無判定ツールは、高速なツールの 1 つで、パターン有無判定ツールより短時間で特徴を検出することができます。

  1. エッジ有無判定ツールを設定するには
  2. エッジ有無判定ツールのパラメータを調整するには
  3. 3.エッジ有無判定ツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果


エッジ有無判定ツールを使用するには

ツールを追加したら、特徴検査領域を定義します。

  1. エッジ特徴を直線領域の上に配置してください。
Closed 例

エッジ特徴を直線領域の上に配置

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. EasyBuilder が、選択したエッジを囲むエッジ領域を自動的に作成します。
Closed 例

自動的に作成された領域

  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジ有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はエッジ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジ有無判定ツール)

Closed エッジのコントラスト

円が検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出する基準

複数のエッジが存在する場合に、目的とする 1 つのエッジに絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確なエッジ (コントラストが最も高いもの) が選択されます。
  • 最初のエッジ: 領域のスキャン開始点に最も近いエッジが選択されます。
  • 最後のエッジ: 領域のスキャン開始点から最も遠いエッジが選択されます。
Closed 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。

Closed 結果

ツールの結果が表示されます。エッジが検出された場合は、[あり] が表示されます。エッジが検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。


グラフ (エッジ有無判定ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


エッジ有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度範囲 | 整数値 |  | 入力
説明 | 文字列 | X | 入力
エッジのコントラスト | 整数値 |  | 入力
エッジの遷移 | 整数値 |  | 入力
エッジ幅 | 整数値 |  | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
検出する基準 | 整数値 |  | 入力
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度範囲 | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
検出する基準 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エッジ | 文字列 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
角度範囲 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
検出する基準 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エッジ | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


円有無判定ツール

円有無判定ツールは、指定したパラメータに合致する円特徴の有無を判定します。

円有無判定ツールは、高速のツールの 1 つで、パターン有無判定ツールより短時間で特徴を検出することができます。

  1. 円有無判定ツールを設定するには
  2. 円有無判定ツールのパラメータを調整するには
  3. 円有無判定ツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果


円有無判定ツールを設定するには

ツールを追加したら、特徴検査領域を定義します。

  1. 円形状の特徴の上に円領域を配置、設定します。特徴とちょうど同じぐらいの大きさになるように調整してください。
Closed 例

特徴の上に円領域を配置

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. EasyBuilder が、選択した円を囲む円領域を自動的に作成します。
Closed 例

円形エッジ特徴を囲む円環領域

  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (円有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (円有無判定ツール)

Closed エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出する基準

複数の円が存在する場合に、目的とする 1 つの円に絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確な円 (コントラストが最も高いもの) が選択されます。
  • 最小円: 最も小さい円が選択されます。
  • 最大円: 最も大きい円が選択されます。
Closed 結果

ツールの結果が表示されます。円が検出された場合は、[あり] が表示されます。円が検出されなかった場合、または指定の範囲に合致しなかった場合、[なし] が表示されます。[あり] はブール値 1 (PASS) 、[なし] はブール値 0 (FAIL) となります。

Closed 反転
ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。 ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。


グラフ (円有無判定ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


円有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
エッジのコントラスト | 整数値 |  | 入力
エッジの遷移 | 整数値 |  | 入力
エッジ幅 | 整数値 |  | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
検出する基準 | 整数値 |  | 入力
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
検出する基準 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
円.半径 | 浮動小数点 | X | 出力
円.X | 浮動小数点 | X | 出力
円.Y | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
円環 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
検出する基準 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
円環 | 動作 | X | X |


シャープネス有無判定ツール

シャープネス有無判定ツールは、領域内の画像シャープネス得点に基づき、画像が正しくフォーカスされているかどうかを定義します。このツールは、In-Sight ビジョンシステムのレンズを再フォーカスする反復プロセスの一部として、入力画像の相対的な焦点を計測します。

画像シャープネス得点は、「シーン」 (その画像でキャプチャされた対象物とその背景) 内で認識可能な最小の特徴が画像領域内に含まれる度合いを示します。

  1. シャープネス有無判定ツールを設定するには
  2. シャープネス有無判定ツールのパラメータを調整するには
  3. シャープネス有無判定ツールの入出力プロパティを使用するには


シャープネス有無判定ツールを設定するには

ツールを追加したら、領域を設定します。

  1. 「シーン」 (その画像でキャプチャされた対象物とその背景) の重要な部分を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの確定後、まったく同一のシーンから取得した他の画像シャープネス得点 (対象物とその背景が同じ、In-Sight ビジョンシステムの方向および位置が同じ、照明が同じなど) と比較する必要があります。単一の画像シャープネス得点だけでは、画像領域内の絶対シャープネスについての情報は十分ではありません。
  4. [画像の設定] ステップに戻り、[ライブビデオ] モードに入ります。In-Sight ビジョンシステムのレンズを再フォーカスして、シーンに変更がないことを確認します。
  5. [ライブビデオ] モードを終了します。画像シャープネス得点が再計算されます。
  6. 再計算後の得点と、以前の得点を比較します。得点が高いほど、焦点がシャープになっています。
  7. 4 ～ 6 までのステップを繰り返し、許容範囲になるまで焦点をあわせます。

注: 　フォーカスに問題が残る場合、レンズの交換や、レンズと対象物間の距離の調整、[画像の設定] アプリケーションステップでの他の画像の取り込みパラメータの調整などを試してください。


シャープネス有無判定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

シャープネス有無判定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (シャープネス有無判定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はシャープネス_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (シャープネス有無判定ツール)

Closed 最大

画像シャープネスの最大得点値を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed シャープネス

領域内の画像シャープネス得点を返します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

画像シャープネスの最小平均得点値を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


シャープネス有無判定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
スムーズネス | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
シャープネス | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |


距離寸法測定ツール

距離寸法測定ツールは、任意に選択した 2 つの入力特徴の距離を測定します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うか (In-Sight ビジョンシステム) 、あるいは [FOV (幅)] コントロールを使用すると (In-Sight 2000-130/130C ビジョンセンサおよび 2000-23M ビジョンセンサ)、その単位で表示されます。

距離寸法測定ツールは、検査対象物を正確に測定するのに有用です。 例えば、検査対象物の両端の間の距離や、2 つの穴の中心から中心までの距離を測定する場合などです。

  1. 距離寸法測定ツールを設定するには
  2. 距離寸法測定ツールのパラメータを調整するには
  3. 距離寸法測定ツールの入出力プロパティを使用するには


距離寸法測定ツールを使用するには

ツールを追加したら、検査する特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的に特徴間の距離を測定します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


距離寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

距離寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (距離寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は距離_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (距離寸法測定ツール)

Closed 測定タイプ

エッジ間の距離の測定方法を指定します。選択肢は、[中点から線へ] (デフォルト設定。エッジ間の垂直距離を測定します) 、または [中点から中点へ] です。

注: このコントロールは 2 つの特徴のうち、1 つ以上がエッジである場合のみに有効になります。それ以外の場合、次の方法で自動的に距離を測定します。
  • 円から線へ: 円の中心からエッジまたは参照線の水平交点までの距離を計測します。
  • 点から線へ: 点からエッジまたは参照線の垂直交点までの距離を計測します。
  • 円から点へ: 円の中心から点までの距離を計測します。
  • 円から円へ: 円の中心からもう 1 つの円の中心までの距離を計測します。
  • 点から点へ: 2 点間の距離を計測します。

点とは定義済みの特徴、つまりブロブ、円、エッジ、パターン、または点のことで、次のように認識されます。

  • ブロブ: ブロブ重心の XY 座標から計測します。
  • 円: 円の中心の　XY 座標から計測します。
  • エッジ: 中点の XY 座標から計測されます。
  • パターン: モデルパターンの　XY 原点座標から計測します。
  • 点: 点の XY 座標から計測します。


[制限範囲] タブ (距離寸法測定ツール)

Closed 最大

最大距離を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 距離結果

2 特徴間に測定された距離を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小距離を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


距離寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
距離 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
最大 | 浮動小数点 |  | 入力
測定タイプ | 整数値 |  | 入力
最小 | 浮動小数点 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
測定タイプ | 整数値 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
距離 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
測定タイプ | 整数値 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
距離 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


角度結果寸法測定ツール

角度結果寸法測定ツールは、2 つの特徴間の角度を測定します。

角度結果寸法測定ツールは、検査対象物を正確に測定する必要がある場合などに有用です。

  1. 角度結果計測寸法測定ツールを設定するには
  2. 角度結果寸法測定ツールのパラメータを調整するには
  3. 角度結果計測寸法測定ツールの入出力プロパティを使用するには


角度結果寸法測定ツールを設定するには

ツールを追加したら、検査する特徴を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的に 2 つの特徴間の角度を計算し、2 つのエッジの交点および測定角度を画像中にグラフィックスとして描画します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


角度結果寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

角度結果寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (角度結果寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は角度_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (角度結果寸法測定ツール)

Closed 最大

最大角度を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 角度結果

2 特徴間に測定された角度を表示します。値が [最小]～[最大] の範囲内にある場合、 PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小角度を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


角度結果計測寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度 | 浮動小数点 | X | 出力
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
最大 | 浮動小数点 |  | 入力
最小 | 浮動小数点 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
角度 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
角度 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール

ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールは、検出された最大ブロブ特徴の面積を測定します。ブロブ面積ツールが 1 個のブロブ面積の測定に使用されるに対し、ブロブ面積 (1-10) ツールは最大 10 個までのブロブ面積の測定に使用されます。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

ブロブ面積およびブロブ面積 (1-10) 寸法測定ツールは、特徴の予想面積を測定したり、スルーホールの遮蔽物を検出する場合などに有用です。

  1. ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールを設定するには
  2. ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールの入出力プロパティを使用するには
  3. ブロブ面積/ブロブ面積 (1-10)寸法測定ツールの入出力プロパティを使用するには


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ面積およびブロブ面積 (1-10) 寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [テーブル] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ
注:
  • 注: [ヒストグラム] タブは、ツール FAIL 時には表示されません。
  • [テーブル] タブは、ブロブ面積 (1-10) 寸法測定ツールでのみ有効になります。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

Closed しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、常に [ブロブしきい値] の値が使用されます。デフォルトは [自動] です。

Closed ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。ヒストグラムを参考にして、最適な値を設定してください。

Closed ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
  • 任意: 黒白両方のブロブを返します。
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed 最小面積制限

ブロブ検出時の、最小面積をピクセルで定義します (0～900,000。デフォルト = 50)。報告されるのは、[最小面積制限] の値より面積が大きいブロブのみです。

注: [制限範囲] タブの [最小] パラメータがツールの PASS/FAIL を決定するのに対し、[最小面積制限] パラメータはブロブを報告するかどうかを決定します。

Closed 最大面積制限

ブロブ検出時の、最大面積をピクセルで定義します (0～900,000。デフォルト = 307,200)。報告されるのは、[最大面積制限] の値より面積が小さいブロブのみです。

注: [制限範囲] タブの [最大] パラメータがツールの PASS/FAIL を決定するのに対し、[最大面積制限] パラメータはブロブを報告するかどうかを決定します。

Closed 検出する数

検出するモデルパターンのインスタンスの数 (1～10) を定義します。デフォルトは 1 です。ほとんどのアプリケーションは 1 つのフィクスチャで十分ですが、複数のインスタンス (実体) を位置決めすることもできます。識別するブロブの数が多いほど、実行時間は増大します。

Closed ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。

注: ブロブ面積寸法測定ツールには、[検出する数] パラメータは含まれていません。


[制限範囲] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

Closed 最大

最大ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed ブロブ面積結果

測定されたブロブ面積を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[テーブル] タブ (ブロブ面積 (1-10) 寸法測定ツール)

注:
  • ブロブ面積寸法測定ツールは、[テーブル] タブをサポートしていません。ブロブ面積 (1-10) 寸法測定ツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

Closed インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

Closed 面積

検出したブロブの面積を返します (ピクセル単位)。

Closed X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

Closed エラー

検出したブロブにエラーが発生した場合、エラーを返します。

Closed ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

Closed ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


グラフ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ブロブ面積/ブロブ面積 (1-10) 寸法測定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ブロブ面積/ブロブ面積 (1-10) 寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
ブロブの色 | 整数値 | X | X | 入出力
ブロブしきい値 | 整数値 | X | X | 入出力
境界ブロブ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
最大面積制限 | 浮動小数点 | X | X | 入出力
最小面積制限 | 浮動小数点 | X | X | 入出力
ソート | 整数値 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
ブロブ面積 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
検出する数1 | 整数値 | X | X | 入出力
ブロブ面積1～91 | 浮動小数点 | X | X | 出力
検出する数1 | 浮動小数点 | X | X | 出力
合成領域 | 動作 |  | X |
1 ブロブ面積 (1-10) 寸法測定ツールのみ使用可能。


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール

カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールは、検出された最大ブロブ特徴の面積を測定します。カラーブロブ面積ツールが 1 個のブロブ面積の測定に使用されるのに対し、カラーブロブ面積 (1-10) ツールは最大 10 個までのブロブ面積の測定に使用されます。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

カラーブロブ面積/カラーブロブ面積 (1-10) ツールは、登録済みカラーモデルライブラリを参照し、選択した登録済みカラーモデルにマッチする領域内のピクセル数を決定します。ツールは、その後、有効なカラーモデルにマッチする各ピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、2 値化グレースケール出力画像を作成します。この 2 値化出力画像を使用して、有効なカラーモデルによって生成されたブロブ特徴を画像からサーチします。

  1. カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールを設定するには
  2. カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールのパラメータを調整するには
  3. カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールの入出力プロパティを使用するには


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[カラーライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [範囲設定] タブ
  • [ライブラリ] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ

注: [テーブル] タブは、カラーブロブ面積 (1-10) 寸法測定ツールでのみ有効になります。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーブロブ面積_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed ソート

ツールが検出したブロブをどのように計測し、ソートするかを定義します。選択肢は、[面積]、[行]、[列]、[グリッド: フィクスチャから X、次に Y]、[グリッド: フィクスチャから Y、次に X]、[フィクスチャ原点からの距離]、[フィクスチャ行軸からの角度 (CCW)]、および [角度絶対値]。デフォルトは、[面積] です。

  • [面積]: 検出ブロブの面積を最大から最小の順番にソートします。
  • [行]: 行画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [列]: 列画像軸に沿った距離を基準に、距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから X、次に Y]: まず、フィクスチャの行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [グリッド: フィクスチャから Y、次に X]: まず、フィクスチャの列画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートし、次に行画像軸に沿った距離を基準に距離の短いものから長いものの順 (降順) でソートします。
  • [フィクスチャ原点からの距離]: フィクスチャの原点からブロブの重心までの距離を、短いものから長いものの順 (降順) にソートします。
  • [フィクスチャ行軸からの角度 (CCW)]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
  • [角度絶対値]: フィクスチャ座標系の行画像軸からブロブの重心とフィクスチャの原点により定義される線分までの角度 (-180 ～ 180 度) の絶対値を、小さいものから大きいものの順 (降順) にソートします。
Closed 検出する数

検出するブロブ数 (1～10) を定義します。デフォルトは 1 です。検出するブロブ数が多いほど、実行時間は長くなります。

注: このコントロールは、カラーブロブ面積 (1-10) 寸法測定ツールにのみ表示されます。


[制限範囲] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

Closed 最大

最大ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed ブロブ面積

測定されたブロブ面積を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小ブロブ面積を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ライブラリ] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


[テーブル] タブ (カラーブロブ面積 (1-10) 寸法測定ツール)

注:
  • カラーブロブ面積寸法測定ツールは、[テーブル] タブをサポートしていません。カラーブロブ面積 (1-10) 寸法測定ツールのみに表示されます。

  • [ソート] パラメータが [面積] 以外のオプションに設定されている場合、[ピクセル列] および [ピクセル行] がテーブルに追加されます。ピクセル [列] および [ピクセル行] は、In-Sight ビジョンシステムの画像センサ (アレイの列および行) の 2D グリッドに基づく画像座標を参照し、実座標 (X/Y) と逆 (Y/X) になります。

  • [画像の設定] ステップのキャリブレーション (画像座標系をワールド座標系に変換) グループボックスで、[X と Y を入れ替える] オプションを ON にした場合、XY 座標は画像座標 (Y/X) と同じになります。

[テーブル] タブには、検出したブロブの結果が報告されます。その数は、[設定] タブの [検出する数] パラメータによります。

Closed インデックス

[設定] タブの [ソート] パラメータに基づいて、検出したブロブの順番を表示します。EasyBuilder では 0 から数えます。

Closed 面積

検出したブロブの面積を返します (ピクセル単位)。

Closed X

検出したブロブ重心の X 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed Y

検出したブロブ重心の Y 座標を返します。座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 角度結果

領域の中心を基準に、検出したブロブ重心の角度を返します。

Closed エラー

検出したブロブにエラーが発生した場合、エラーを返します。

Closed ピクセル行

検出したブロブの重心画像行 (X) 座標を返します。

Closed ピクセル列

検出したブロブの重心画像行 (Y) 座標を返します。


[合成領域] タブ (カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注:カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
境界ブロブ | 整数値 | X | X | 入出力
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部モデル有効の適用 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
ソート | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
平滑化係数 | 整数値 | X | X | 入出力
オリジナル画像の表示 | 整数値 | X | X | 入出力
ブロブ面積 | 浮動小数点 | X | X | 出力
ブロブ | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |
モデル有効の適用 | 動作 | X | X |
ブロブ面積1～91 | 浮動小数点 | X | X | 出力
検出する数1 | 浮動小数点 | X | X | 出力
検出する数1 | 整数値 | X | X | 入出力
1 カラーブロブ面積 (1-10) 寸法測定ツールのみ使用可能。

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


円の直径寸法測定ツール

円の直径寸法測定ツールは、円形エッジ特徴の直径を測定します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-130/130C および In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

  1. 円の直径寸法測定ツールを設定するには
  2. 円の直径寸法測定ツールのパラメータを調整するには
  3. 円の直径寸法測定ツールの入出力プロパティを使用するには


円の直径寸法測定ツールを使用するには

ツールを追加したら、検査する特徴を選択します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つをクリックすると、紫色に変わります。
  3. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  4. EasyBuilder は自動的に特徴の直径を測定します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円の直径寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

円の直径寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (円の直径寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は直径_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (円の直径寸法測定ツール)

Closed エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出する基準

複数の円が存在する場合に、目的とする 1 つの円に絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確な円 (コントラストが最も高いもの) が選択されます。
  • 最小円: 最も小さい円が選択されます。
  • 最大円: 最も大きい円が選択されます。


[制限範囲] タブ (円の直径寸法測定ツール)

Closed 最大

最大直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 直径結果

描画された円の直径を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


グラフ (円の直径寸法測定ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


円の直径寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
直径 | 浮動小数点 | X | 出力
エッジのコントラスト | 整数値 |  | 入力
エッジの遷移 | 整数値 |  | 入力
エッジ幅 | 整数値 |  | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
検出する基準 | 整数値 |  | 入力
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
最大 | 浮動小数点 |  | 入力
最小 | 浮動小数点 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
検出する基準 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
円.半径 | 浮動小数点 | X | 出力
円.X | 浮動小数点 | X | 出力
円.Y | 浮動小数点 | X | 出力
直径 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
円環 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
検出する基準 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
直径 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
円環 | 動作 | X | X |


円の同心度寸法測定ツール

円の同心度寸法測定ツールは、2 つの円特徴の中心距離を測定するのに使用されます。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

このツールは、円形ラベルが円形キャップの中心にあるかどうか検証したり、機械加工の皿穴の同心度を測定する場合などに有用です。

  1. 円の同心度寸法測定ツールを設定するには
  2. 円の同心度寸法測定ツールのパラメータを調整するには
  3. 円の同心度寸法測定ツールの入出力プロパティを使用するには


円の同心度寸法測定ツールを設定するには

ツールを追加したら、円の同心度の測定に使用される、入力特徴 (円特徴または参照円) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的に特徴間の距離を測定します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円の同心度寸法測定ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

円の同心度寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (円の同心度寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は同心度_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (円の同心度寸法測定ツール)

Closed 最大

2 つの円の間の最大直径を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 距離結果

2 つの円の間に測定された距離を表示します。値が、0～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


円の同心度寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
距離 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
距離 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


半径計測寸法測定ツール

半径計測寸法測定ツールは、カーブエッジ特徴を定義し、カーブの軸を示す参照線と参照点を作成します。 このツールは、カーブの半径を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

  1. 半径計測寸法測定ツールを設定するには
  2. 半径計測寸法測定ツールのパラメータを調整するには
  3. 半径計測寸法測定ツールの入出力プロパティを使用するには


半径計測寸法測定ツールを設定するには

ツールを追加したら、カーブエッジ特徴の検査領域を定義します。

  1. 領域をカーブエッジ特徴の上に配置してください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. EasyBuilder が、カーブ半径を自動的に計算し、カーブ軸を示す参照線および参照点を作成します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じて パラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


半径計測寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

半径計測寸法測定ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (半径計測寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はカーブ_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (半径計測寸法測定ツール)

Closed エッジのコントラスト

円が検出されたとみなすための最小コントラスト得点 (1～100) を指定します。初期値はスマートセッティングによって自動的に決定されます。このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出する基準

複数のエッジが存在する場合に、目的とする 1 つのエッジに絞り込む方法を定義します。デフォルトは [得点の高い順] です。

  • 得点の高い順: 最も明確なエッジ (コントラストが最も高いもの) が選択されます。
  • 最初のエッジ: 領域のスキャン開始点に最も近いエッジが選択されます。
  • 最後のエッジ: 領域のスキャン開始点から最も遠いエッジが選択されます。


[範囲制限] タブ (半径計測寸法測定ツール)

Closed 最大

最大半径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 半径 (単位)

検出されたカーブエッジ特徴を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小半径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


半径計測寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
検出する基準 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
円.半径 | 浮動小数点 | X | 出力
円.X | 浮動小数点 | X | 出力
円.Y | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
半径 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
検出する基準 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
半径 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


最小/最大点寸法測定ツール

最小/最大点寸法測定ツールは、エッジの位置を測定し、検出エッジまたはエッジを定義する領域から一番近いエッジ点と遠いエッジ点を指定します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。エッジの識別後、最適ラインまたは最適円 (エッジ特徴にカーブがあるかどうかによります) をエッジ特徴の上に作成し、最適ラインまたは最適円に一番近いエッジ点と遠いエッジ点を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

最小/最大点寸法測定ツールは、検査対象物またはオブジェクトが予想される範囲内の位置から外れていないことを確認する場合などに有用です。例えば、刃に切れ目やくぼみ、突起がないこととを確認するのに使用します。

  1. 最小/最大寸法測定ツールを設定するには
  2. 最小/最大寸法測定ツールのパラメータを調整するには
  3. 最小/最大寸法測定ツールの入出力プロパティを使用するには


最小/最大点寸法測定ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円を正しく作成していることを確認してください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


最小/最大点寸法測定ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

最小/最大点寸法測定ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (最小/最大点寸法測定ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は最小最大点_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (最小/最大点寸法測定ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (最小/最大点寸法測定ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

Closed エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

Closed 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[最適ライン] タブ (最小/最大点寸法測定ツール)

[最適ライン] タブを選択すると、領域内で検出されたすべてのエッジ候補および最適円または最適ラインの結果が表示されます。エッジ候補は、最適ラインまたは最適円作成時に使用可能なエッジを表し、小さな円で表示されます。

Closed 最適ライン

検出されたエッジから作成される、最適ラインのタイプを指定します ([なし]、[最適直線]、[最適円]、[自動調節] (デフォルト) または [領域])。

  • [なし] を選択すると、最適ラインは作成されません。検出エッジの位置は領域の中心を基準に計測されます。
  • [最適直線] を選択すると、検出エッジから最適直線が作成されます。検出エッジの位置は、最適ラインを基準に計測されます。
  • [最適円] を選択すると、検出エッジから最適円が作成されます。検出エッジの位置は、最適ラインを基準に計測されます。
  • [自動調節] を選択すると、検出エッジから最適直線または最適円が作成されます。検出エッジの位置は、最適ラインを基準に計測されます。
  • [領域] を選択すると、検出エッジから最適直線または最適円が自動的に作成されます。検出エッジの位置は、領域の側面を基準に計測されます。
Closed 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

Closed 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注: このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。

Closed 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

Closed 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

Closed 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注: この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。

Closed 結果

画像中の最適ラインを表示し、最適ラインに一番近い点と一番遠い点を返します。


最小/最大点寸法測定ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
外れ値の除外 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
最適距離フィルタ | 整数値 | X | X | 入出力
最端フィルタ距離 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最適ライン | 整数値 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
再計算 | 整数値 | X | X | 入出力
再得点 | 整数値 | X | X | 入出力
規則: 最初のエッジ | 整数値 | X | X | 入出力
規則: エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ライン.終点_X | 浮動小数点 | X | X | 出力
ライン.終点_Y | 浮動小数点 | X | X | 出力
ライン.始点_X | 浮動小数点 | X | X | 出力
ライン.始点t_Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
点1.X | 浮動小数点 | X | X | 出力
点1.Y | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |


ブロブ計数ツール

ブロブ計数ツールは、画像の領域内に存在するブロブ特徴のインスタンスの個数を返します。

ブロブ計数ツールは、高速なツールの 1 つです。パターン有無判定ツールよりも短時間でブロブ特徴を検出することができます。このツールは、コネクタ上に正しい数のピンがあるかを検証したり、クッキーのチョコレートチップを計数する場合などに有用です。

  1. ブロブ計数ツールを設定するには
  2. ブロブ計数ツールのパラメータを調整するには
  3. ブロブ計数ツールの入出力プロパティを使用するには


ブロブ計数ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

注: ピクセルの白黒の差がはっきりした、高コントラストのブロブを選択してください。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


ブロブ計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ブロブ計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [ヒストグラム] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ブロブ計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ブロブ計数ツール)

Closed しきい値モード

ブロブと背景を切り分けるためのグレー値を決める方法を指定します。[自動] を選択した場合、画像取り込みのたびに自動的にしきい値が計算されます。[手動] を選択した場合、常に [ブロブしきい値] の値が使用されます。デフォルトは [自動] です。

Closed ブロブしきい値

ブロブと背景を切り分けるグレー値 (0～255) を定義します。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。 グラフを参考にして、最適な値を設定してください。

Closed ブロブの色

ブロブの色を定義します。選択肢は [黒]、[白]、[任意] (デフォルト) です。

  • 黒: ブロブしきい値より低いグレー値で構成されたブロブを返します。
  • 白: ブロブしきい値より高いグレー値で構成されたブロブを返します。
  • 任意: 黒白両方のブロブを返します。
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed 最小面積

ブロブ面積の最小値をピクセル単位で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

Closed 最大面積

ブロブ面積の最大値をピクセル単位で指定します。指定された値より大きなブロブは検出されません。


[制限範囲] タブ (ブロブ計数ツール)

Closed 最大

検出する最大ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed ブロブ数

検出されたブロブ数を表示します。(ブロブは 0 から数えます。) 値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

検出する最小ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[ヒストグラム] タブ (ブロブ計数ツール)

ヒストグラムは、領域内のピクセルのグレー値をヒストグラムで表したものです。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 青の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


[合成領域] タブ (ブロブ計数ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


ブロブ計数ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
ブロブの色 | 整数値 | X | X | 入出力
ブロブしきい値 | 整数値 | X | X | 入出力
境界ブロブ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
ブロブ数 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 |  | X |


カラーブロブ計数ツール

カラーブロブ計数ツールは、画像の領域内に存在するブロブ特徴のインスタンスの個数を返します。

カラーブロブ計数ツールは、高速なツールの 1 つです。パターン有無判定ツールよりも短時間でブロブ特徴を検出することができます。このツールは、コネクタ上に正しい数のピンがあるかを検証したり、クッキーのチョコレートチップを計数する場合などに有用です。

  1. カラーブロブ計数ツールを設定するには
  2. カラーブロブ計数ツールのパラメータを調整するには
  3. カラーブロブ計数ツールの入出力プロパティを使用するには


カラーブロブ計数ツールを設定するには

ツールを選択したら、ブロブ特徴の検査領域を設定します。

  1. [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 ブロブの全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのブロブがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、ブロブが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブで使用する [カラーライブラリ] を選択してから、[カラーライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーブロブ計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーブロブ計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • カラーライブラリタブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーブロブ計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はブロブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーブロブ計数ツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
Closed 境界ブロブ

領域の境界に接しているブロブを結果に加えるかどうかを指定します。デフォルトは OFF です。

  • OFF: 領域の境界に接しているブロブを無視します。つまり、検出対象となるブロブは領域内に完全に含まれている必要があります。
  • ON: 領域の境界に接しているブロブも検出します。
Closed 最小面積

ブロブ面積の最小値をピクセル単位で指定します。デフォルトは 100 です。指定された値より小さなブロブは検出されません。

Closed 最大面積

ブロブ面積の最大値をピクセル単位で指定します。指定された値より大きなブロブは検出されません。


[制限範囲] タブ (カラーブロブ計数ツール)

Closed 最大

検出する最大ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed ブロブ数

検出されたブロブ数を表示します。(ブロブは 0 から数えます。) 値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

検出する最小ブロブ数を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


カラーライブラリタブ (カラーブロブ計数ツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


[合成領域] タブ (カラーブロブ計数ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーブロブ計数ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注:カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
境界ブロブ | 整数値 | X | X | 入出力
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部モデル有効の適用 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
平滑化係数 | 整数値 | X | X | 入出力
オリジナル画像の表示 | 整数値 | X | X | 入出力
ブロブ数 | 浮動小数点 | X | X | 出力
ブロブ関数 | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |
モデル有効の適用 | 動作 | X | X |

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


エッジ計数ツール

エッジ計数ツールは、画像の領域内に存在するエッジ特徴の個数を返します。

このツールは、ネジのねじ山を計数したり、トレイのクラッカーを計数する場合などに有用です。

  1. エッジ計数ツールを設定するには
  2. エッジ計数ツールのパラメータを調整するには
  3. エッジ計数ツールの入出力プロパティを使用するには


エッジ計数ツールを使用するには

ツールを追加したら、エッジ検査領域を設定します。

  1. 特徴全体を囲むように領域を配置します。スキャン方向を示す矢印に特に注意して、エッジ検出を最適化するように領域を配置してください。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけツールの実行時間が増大します。

処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、そのエッジがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、特徴が移動しても十分にカバーできる大きさに領域を設定してください。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジ計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]]、[通信]) で参照されます。ツールのデフォルト名はエッジ_1 で、末尾の番号はツールに応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジ計数ツール)

Closed エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。ツールのグラフを参考にして、適切な値に設定してください。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジの遷移

エッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。


[制限範囲] タブ (エッジ計数ツール)

Closed 最大

検出する最大エッジ数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed エッジ

検出されたエッジ数を表示します。エッジは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

検出する最小エッジ数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


グラフ (エッジ計数ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


エッジ計数ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度範囲 | 整数値 |  | 入力
説明 | 文字列 | X | 入力
エッジのコントラスト | 整数値 |  | 入力
エッジ数 | 整数値 | X | 出力
エッジの遷移 | 整数値 |  | 入力
エッジ幅 | 整数値 |  | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
最大 | 整数値 |  | 入力
最小 | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
角度範囲 | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
エッジのコントラスト | 整数値 | X | 入出力
エッジの遷移 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 整数値 | X | 入出力
最小 | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エッジ数 | 整数値 | X | 出力
エッジ | 文字列 | X | 出力
エラー_数 | 整数値 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
領域 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
角度範囲 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エッジ数 | 整数値 | X | X | 出力
エッジ | 文字列 | X | X | 出力
エラー_数 | 整数値 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


エッジペア計数ツール

エッジペア計数ツールは、画像の領域内に存在する直線エッジペアのインスタンスの個数を返します。

エッジペア計数ツールは、エッジ計数ツールと違い、エッジペア間の予想幅を設定できます。このツールは、歯車の歯数やコンピュータチップのリードを計数するといったアプリケーションに有用です。

  1. エッジペア計数ツールを設定するには
  2. エッジペア計数ツールのパラメータを調整するには
  3. エッジペア計数ツールの入出プロパティを使用するには


エッジペア計数ツールを使用するには

ツールを追加したら、エッジ検査領域を設定します。

  1. 特徴全体を囲むように領域を配置します。領域のスキャン方向、[設定] タブのパラメータおよび [制限範囲] の設定により、検出されるエッジペアの数が変わります。特徴全体を囲むように領域を配置します。

領域のスキャン方向、[設定] タブのパラメータおよび [制限範囲] の設定により、検出されるエッジペアの数が変わります。

Closed 例 1

Closed 例 2

Closed 例 3

処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、そのエッジがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、特徴が移動しても十分にカバーできる大きさに領域を設定してください。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジペア計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジペア計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • グラフ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジペア計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]]、[通信]) で参照されます。ツールのデフォルト名はエッジ_1 で、末尾の番号はツールに応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (エッジペア計数ツール)

Closed エッジのコントラスト

エッジが検出されたとみなすための最小コントラスト得点 (1～100) を指定します (初期値はスマートセッティングによって自動的に決定されます) 。 このパラメータは、ツールが特徴と背景を切り分けるためのエッジ検出感度を意味します。

注: パラメータが 0 に設定されている場合、ツールが予期しないエッジを返すことがあります。
Closed エッジ 1 の遷移

1 番目のエッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ 2 の遷移

2 番目のエッジの遷移状態 ([黒→白]、[白→黒]、[両方]) を指定します。デフォルトは [両方] です。 検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ幅

エッジ遷移が発生する場所のピクセル距離を指定します (1～50、デフォルト = 3)。画像からノイズを削除することができます。

Closed 角度範囲

検出されたエッジが取り得る、角度の最大値 (0～10 度) を定義します。デフォルトは 10 度です。 角度の許容範囲を広げると、ツールの実行時間が増大します。

Closed 最小距離

検出されたすべてのエッジペアのエッジ間の最小距離をピクセルで定義します (0～900000、デフォルトは 10)。定義された値以上の距離のエッジペアのみ認識されます。

Closed 最大距離

検出されたすべてのエッジペアのエッジ間の最大距離をピクセルで定義します (0～900000、デフォルトは 50)。定義された値以下の距離のエッジペアのみ認識されます。


[制限範囲] タブ (エッジペア計数ツール)

Closed エッジペア

検出されたエッジペア数を表示します。エッジペアは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最大

検出する最大エッジペア数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 最小

検出する最小エッジペア数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


グラフ (エッジペア計数ツール)

グラフは、検査領域のグレー値の一次微分を表したものです。グラフ中の山と谷は大きなエッジ遷移を示します。

エッジツールや円ツールでは、検出エッジと指定パラメータがどの程度マッチしているかを得点軸で確認することができます。

  • 得点 ＞ 0: 黒→白に遷移するエッジを示しています。
  • 得点 ＜ 0: 白→黒に遷移するエッジを示しています。
  • 得点 ＝ 0: エッジが検出されなかったことを示しています。

オフセット軸は、エッジ検出領域の長さ方向を示します。グラフの左端 (オフセット 0) は領域の開始位置を、右端は領域の全長をピクセル単位で示します。 山または谷の頂点が、検出されたエッジポジションを示します。

注: グラフは、オンライン/オフラインステータスおよびツールの PASS/FAIL ステータスに関わらず表示されます。 ただし、ツールが FAIL している場合、グラフは更新されないことがあります。


エッジペア計数ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
角度範囲 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジのコントラスト | 整数値 | X | X | 入出力
第_1_エッジの遷移 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最大距離 | 浮動小数点 | X | X | 入出力
最少 | 整数値 | X | X | 入出力
最小距離 | 浮動小数点 | X | X | 入出力
第_2_エッジの遷移 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エッジ数 | 浮動小数点 | X | X | 出力
エッジペア数 | 浮動小数点 | X | X | 出力
エッジペア | 文字列 | X | X | 出力
エッジ | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


PatMax RedLine パターンおよび PatMax パターン計数ツール

注:
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターン計数ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターンおよび PatMax パターン計数ツールは、登録済みのパターン表現 (モデルと呼ばれます) を基に、PatMax RedLine または PatMax アルゴリズムを使用して、パターンのインスタンスの個数を返します。

これらのツールは、機械の組み立てにおいてボルトを計数したり、トレイのバイラルを計数したりするアプリケーションなどに有用です。

  1. PatMax RedLine パターンおよび PatMax パターン計数ツールを設定するには
    1. PatMax RedLine パターン、PatMax パターンおよびパターン
    2. パターンを選択するには
  2. PatMax RedLine パターンおよび PatMax パターン計数ツールのパラメータを調整するには
  3. PatMax RedLine パターンおよび PatMax パターン計数ツールの入出力プロパティを使用するには


PatMax RedLine パターンおよび PatMax パターン計数ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。
  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


PatMax RedLine パターン、PatMax パターンおよびパターン

注:PatMax RedLine パターン計数ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


PatMax RedLine パターンおよび PatMax パターン計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax パターン計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • [モデル] および [サーチ] タブ
  • [登録画像] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。 PatMax RedLine パターンではデフォルト = 10、有効なパラメータ範囲は 0～100 です。 PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。 低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注: PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。 よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。 特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。 PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

Closed 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。 デフォルトでは、[PatMax] が選択されています。 PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

Closed クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは ON です。 クラッタが ON の場合、検出パターン中の特徴欠落によって得点が減点されます。

Closed 極性を無視

モデルパターンに対し、カラー変換したマッチ特徴を検出パターンに含むかどうか指定します (デフォルト = OFF)。[極性を無視] を ON にすると、例えば、モデルパターン内の黒/白 vs. 白/黒など、カラー変換した特徴を含む検出パターンが、モデルパターンにマッチしていると分類されます。

Closed タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 5,000 に設定されています。

注:PatMax RedLine パターンには、[検出モード] パラメータは含まれていません。


[制限範囲] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

Closed 最大

検出する最大パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed パターン

検出されたパターン数を表示します。パターンは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

検出する最小パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


[モデル] および [サーチ] タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


登録画像タブ (PatMax RedLine パターンおよび PatMax パターン計数ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


PatMax RedLine パターンおよび PatMax パターン計数ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
コントラストしきい値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部再登録 | 整数値 | X |  | 入出力
検出モード1 | 整数値 | X | X | 入出力
極性を無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
クラッタ | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
パターン数 | 浮動小数点 | X | X | 出力
パターン | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
スケール | 浮動小数点 | X | X | 出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |
登録 | 動作 | X | X |
1 PatMax パターンでのみ使用可能。


パターン計数ツール

パターン計数ツールは、登録済みのパターン表現 (モデルと呼ばれます) を基に、パターンのインスタンスの個数を返します。

パターン計数ツールは、機械の組み立てにおいてボルトを計数したり、トレイのバイラルを計数したりするアプリケーションなどに有用です。

  1. パターン計数ツールを設定するには
    1. PatMax パターン vs. パターン
    2. パターンを選択するには
  2. パターン計数ツールのパラメータを調整するには
  3. パターン計数ツールの入出力プロパティを使用するには


パターン計数ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

  1. 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。
  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

注: モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。

  3. [OK] ボタンを押し、2 つの領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターンを選択するには

パターンを選択する際には、次のガイドラインを参考にしてください。

  • そのパターンがすべての画像に存在していること。
  • ユニーク性の高い特徴や一貫性の高い特徴をできるだけ多くそのパターンに含めること。また、検査対象物全体の形状に対してそのパターンが常に一定の位置に、かつ明確に存在すること。
  • できるだけ大きなパターンを選択すること。大きなパターンはユニークな特徴を多く含むため、それだけ一貫した正確な検査を行うことができるます。


パターン計数ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

パターン計数ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [制限範囲] タブ
  • 登録画像タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (パターン計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はパターン_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン計数ツール)

Closed 登録の入力

モデルパターンを入力ラインを介して登録するかどうかを定義します。デフォルトは OFF で、無効です。

  • 入力: モデルパターンを入力ラインを介して登録します。 選択した入力ラインは、登録シグナルとして使用されます。

    注:
    • このオプションは、In-Sight ビジョンシステムにディスクリート入力がない場合 (例えば、直接接続 I/O を使用している In-Sight 8000 シリーズビジョンシステムなど) 、表示されません。
    • 入力/出力ステップで、 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定してください。
    • モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。
    • 詳細については、 入力: 入力ラインを介してモデルパターンを登録するにはをご参照ください。
Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。 この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。 この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。 設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。 大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。 デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。 スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

Closed モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

Closed 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

Closed タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。


[制限範囲] タブ (パターン計数ツール)

Closed 最大

検出する最大パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed パターン

検出されたパターン数を表示します。パターンは 0 から数えます。値が [最小]～[最大] の範囲内にある場合、 PASS を返します。

Closed 最小

検出する最小パターン数を指定します。画像に基づきデフォルトの「スマートリミット」が設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


登録画像タブ (パターン計数ツール)

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン計数ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
アクセプトしきい値 | 整数値 |  | 入力
高精度モード | 整数値 |  | 入力
角度許容値 | 整数値 |  | 入力
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
外部登録 | 整数値 |  | 入力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 |  | 入力
最大 | 整数値 |  | 入力
最小 | 整数値 |  | 入力
モデルタイプ | 整数値 |  | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
パターン数 | 整数値 | X | 出力
スケール許容 | 整数値 |  | 入力
ステータス | 整数値 | X |
タイムアウト | 整数値 |  | 入力
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | 入出力
高精度モード | 整数値 | X | 入出力
角度許容値 | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
外部登録 | 整数値 |  | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 整数値 | X | 入出力
最小 | 整数値 | X | 入出力
モデルタイプ | 整数値 | X | 入出力
スケール許容 | 整数値 | X | 入出力
タイムアウト | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
パターン数 | 整数値 | X | 出力
パターン | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
モデル | 動作 | X |
サーチ | 動作 | X |
登録 | 動作 | X |
登録の入力 | 整数値 | X | 入出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
高精度モード | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部登録 | 整数値 |  |  | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
モデルタイプ | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
パターン数 | 整数値 | X | X | 出力
パターン | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |
登録 | 動作 | X | X |
登録の入力 | 整数値 | X | X | 入出力


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール

1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールは、バーコードやスタックドバーコードを ReadIDMax® を使用してデコードしたり照合したりします。ツールは、デコード情報を返します。また、正しくデコードされ、コードが指定のしきい値内にある場合、PASS となります。

1D コードの読み取り識別ツールは、領域内の 1 個のコードを読み取り/照合するのに使用します。一方、1D コードの読み取り (1-20) 識別ツールは、領域内にある最大 20 個のコードを読み取り/照合するのに使用します。

  1. 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールを使用するには
  2. 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールのパラメータを調整するには
  3. 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールの入出力プロパティを使用するには


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールを設定するには

ツールを追加したら、領域を設定します。

  1. コードやシンボル全体を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[設定] タブでパラメータを指定します。
  1. [モード] パラメータで、ツールの操作方法を指定します。選択肢は、[読み取り] (デフォルト) または [マッチ文字列] です。
  2. 1D コードの読み取り (1-20) 識別ツールを使用する場合、[最大結果] パラメータを設定して、デコードするコードやシンボルの数を指定する必要があります。デフォルトは、1 です。
  4. ツールは、デコードされたコードやシンボルの周りを囲む四角形のボックスを描画します (このボックスは編集できません)。また、デコードされたコードやシンボルからフィクスチャが作成されたことを示す [image] アイコンが挿入されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [1D] タブ
  • [スタックド] タブ
  • [結果] タブ
  • テーブル
注:
  • [結果] タブは、1D コードの読み取り識別ツールのみに表示されます。
  • テーブルは、1D コードの読み取り (1-20) 識別ツールのみに表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


/ [全般] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

Closed 最大結果

読み取りを実行するコードやシンボルの最大数を指定します (1～20、デフォルト = 1)。

注: [最大結果] で指定した値が視野に含まれるコードやシンボルの数を超えている場合、ツールは指定した数のコードやシンボルを検出し続けます。視野に含まれるコードやシンボルの数にばらつきがある場合、[タイムアウト] パラメータの値を調整することによって、ツールの実行時間を短くすることができます。

Closed 登録

特定のコードやシンボルが登録済みかどうかを表示します。登録済みの場合 1 を、未登録の場合 0 を表示します。

Closed 登録

コードやシンボルの読み取りモデルを登録します。登録された情報は、[登録解除] ボタンを押すまで保持されます。コードやシンボルを再登録するには、 [登録解除] ボタンを押してから、新しいコードやシンボルに対して [登録] ボタンを押します。登録は、デコードするコードやシンボルのタイプをツールに学習させるため、使用すると、ツールのスピードおよびパフォーマンスが向上します。1D コードの読み取り (1-20) 識別ツールまたは 2D コードの読み取り (1-20) 識別ツールで登録を使用する場合、1 つのコードやシンボルの周りを囲むように領域を設定してから、[登録] ボタンを押してください。コードやシンボルが登録されたら、領域を調整し、視野 (FOV) を広げて、複数のコードやシンボルをサーチすることができるようになります。登録することができるのは、領域内の 1 つのコードやシンボルのみです。領域内の複数のコードやシンボルに対して [登録] ボタンを押すと、どのコード、シンボルが登録されるのか分からなくなります。登録前に、[1D] および [スタックド] タブで正しいコードタイプが選択されていることを確認してください。

Closed 登録解除

コードやシンボルの登録済みモデルの登録を解除します。シンボルを再登録するには、[登録解除] ボタンを押してから、新しいコードに対して [登録] ボタンを押します。

Closed モード

ツールのモードを指定します。選択肢は、[読み取り] (デフォルト) と [マッチ文字列] です。

  • 読み取り: 目的のコードやシンボルの情報がない場合に使用されます。ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。
  • マッチ文字列: 既知のコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。
Closed マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注: マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードやシンボルと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ツールの結果は FAIL となり、[マッチ文字列] には TRIG が表示されます。

Closed マッチモード

領域内のデコードされたすべてのコードやシンボルを、[マッチ文字列] パラメータで指定した文字列にマッチさせるかどうかを指定します。このオプションを有効にするには、[マッチ文字列] パラメータに文字列を入力する必要があります。

  • 全てマッチ: デコードされたコードやシンボルは、[マッチ文字列] パラメータで指定された文字列とすべてマッチする必要があります。
  • 任意のマッチ: デコードされたコードやシンボルが、[マッチ文字列] パラメータで指定された文字列と最低 1 つマッチする必要があります。
Closed チェックサム

エラー検出アルゴリズムを使用して、信頼性を保証するために、コードやシンボルを検証するかどうかを指定します。デフォルトで、この設定は OFF となっています。チェックサムアルゴリズムが含まれるコードやサンプルのみに、チェックサムは適用されます。コードやサンプルには、それぞれ固有のチェックサムアルゴリズムが存在します。選択されたコードやシンボルにより、使用されるチェックサムの種類は異なります。

注: Code 128、Code 93、RSS、UPC および EAN バーコードは、このパラメータに関わらず、チェックサムを使用して検証されます。その他のバーコードで [チェックサム] を ON にし、チェックサムがエンコードされていない場合、読み取りに失敗します。

Closed ソートモード

結果を表示する順番を指定します。選択肢は、[なし] (デフォルト)、[上→下]、[左→右]、[アルファベット順]、[文字数] です。

  • なし: デコードされた順番に結果をソートします。その次に、デコードできなかった結果が表示されます。
  • 上→下: X フィクスチャ座標値の順番に、昇順でソートします。
  • 左→右: Y フィクスチャ座標値の順番に、昇順でソートします。
  • アルファベット順: 結果をアルファベット順にソートします。
  • 文字数: 結果を文字列の長さ順にソートします (短→長)。
  • 行: シンボルを行で分類し、各行内で左→右の順番にソートします。
  • 列: シンボルを列で分類し、各列内で上→下の順番にソートします。
Closed 同一 1D シンボルの許容

領域内のすべてのシンボルを、同一でもデコードするかどうかを指定します。長さおよびシンボルタイプが同一で、文字列がデコードされている場合、2 つのシンボルは、同一であるとみなされます (デフォルトでは、この設定は OFF となっています)。

Closed 照合

印刷精度テストを実行するかどうかを指定します。デフォルトは、OFF です。

Closed 拡張 UPC-E

デコードされたシンボルが 6 桁の UPC-E 文字列を返すか、あるいは 11 桁の UPC-A 同等文字列を返すかを定義します (デフォルトで、この設定は有効となっています)。

注:拡張 UPC-E パラメータは、バージョン 4.10.1 以降のファームウェアを搭載した In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズおよび In-Sight 70xx - 74xx シリーズビジョンシステムのみでサポートされています。

Closed タイムアウト

ツールがコードやシンボルをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed デコード数

デコードしたコードやシンボルの数を表示します。

注: [最大結果]、[マッチモード]、[ソートモード]、[同一 1D シンボルの許容] および [デコード数] パラメータは、1D コードの読み取り (1-20) 識別ツールのみに表示されます。


[1D] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

このタブを使用して、デコードを試みるコードやシンボルを指定します。デフォルトで、すべてのコードやシンボルタイプが有効となっており、複数のシンボルを選択して、読み取ることができます。

Closed Code 128

Code 128 の読み取りを試みるかどうかを指定します。

Closed Code 39

Code 39 の読み取りを試みるかどうかを指定します (Code 39 は、Code 3 of 9 または BC39 ともよばれます)。

Closed インターリーブド 2 of 5

ITF-14 の読み取りを試みるかどうかを指定します。

Closed Pharmacode

PharmaCode の読み取りを試みるかどうかを指定します。

Closed UPC/EAN

UPC (Universal Product Code) および EAN (European Article Numbering) の読み取りを試みるかどうかを指定します。UPC は、バージョン A (標準バージョン) およびバージョン E (ゼロ抑制バージョン) の UPC バーコードと、2 文字および 5 文字の補足コードをサポートします。EAN は、EAN-8 および EAN-13 バーコードと同時に、2 文字および 5 文字の補足コードをサポートします。

Closed Code 93

Code 93 の読み取りを試みるかどうかを指定します。

Closed Codabar

Codabar の読み取りを試みるかどうかを指定します (Codabar は、USD-4 または Code 2 of 7 ともよばれます)。


/ [スタックド] タブ (1D コードの読み取り/1D コードの読み取り (1-20) 識別ツール)

このタブを使用して、デコードを試みるコードやシンボルを指定します。デフォルトで、すべてのコードやシンボルタイプが有効となっており、複数のシンボルを選択して、読み取ることができます。

Closed PDF 417

PDF 417 の読み取りを試みるかどうかを指定します。

Closed DataBar

DataBar の読み取りを試みるかどうかを指定します。

Closed DataBar リミテッド

DataBar リミテッドの読み取りを試みるかどうかを指定します。

Closed DataBar Expanded

DataBar Expanded の読み取りを試みるかどうかを指定します。

Closed EAN.UCC コンポジット

EAN.UCC コンポジットの読み取りを試みるかどうかを指定します。


[結果] タブ (1D コードの読み取り識別ツール)

[結果] タブには、デコードされたコードやシンボルの情報が表示されます。

Closed 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

Closed シンボル

デコードされたシンボルのタイプを返します。

Closed グレード

デコードされたコードやシンボルのグレードを返します。


テーブル (1D コードの読み取り (1-20) 識別ツール)

デコードされたコードやシンボルの情報がテーブルに表示されます。

Closed インデックス

[ソートモード] パラメータに基づいて、デコードされたコードやシンボルの順番を表示します (1～20)。EasyBuilder では 0 から数えます。

Closed 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

Closed シンボル

デコードされたシンボルのタイプを返します。

Closed X

デコードされたコードやシンボルのフィクスチャ出力の X 座標を返します。

Closed Y

デコードされたコードやシンボルのフィクスチャ出力の Y 座標を返します。

Closed 角度結果

デコードされたコードやシンボルのフィクスチャ出力の角度値を返します。

Closed グレード

デコードされたコードやシンボルのグレードを返します。


/ 1D コードの読み取り/1D コードの読み取り (1-20) 識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
チェックサム | 整数値 | X | X | 入出力
Codabar | 整数値 | X | X | 入出力
Code_128 | 整数値 | X | X | 入出力
Code_39 | 整数値 | X | X | 入出力
Code_93 | 整数値 | X | X | 入出力
DataBar | 整数値 | X | X | 入出力
DataBar_Expanded | 整数値 | X | X | 入出力
DataBar_リミテッド | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
EAN.UCC_コンポジット | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
インターリーブド_2_of_5 | 整数値 | X | X | 入出力
マッチ文字列 | 文字列 | X | X | 入出力
モード | 整数値 | X | X | 入出力
PDF_417 | 整数値 | X | X | 入出力
Pharamacode | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
同一 1D シンボルの許容 | 整数値 | X | X | 入出力
UPC_EAN | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 文字列 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
フィクスチャ1～19.角度* | 浮動小数点 | X | X | 出力
フィクスチャ1～19.X* | 浮動小数点 | X | X | 出力
フィクスチャ1～19.Y* | 浮動小数点 | X | X | 出力
グレード | 浮動小数点 | X | X | 出力
グレード1～19* | 浮動小数点 | X | X | 出力
デコード数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
文字列 | 文字列 | X | X | 出力
文字列1～19* | 文字列 | X | X | 出力
シンボル | 文字列 | X | X | 出力
シンボル1～19* | 文字列 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
登録 | 浮動小数点 | X | X | 出力
領域 | 動作 |  | X |
登録 | 動作 |  | X |
登録解除 | 動作 |  | X |

注: * は、1D コードの読み取り (1-20) 識別ツールにのみ表示されます。


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツール

2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールは、QR コードやデータマトリックスシンボルを ReadIDMax® を使用してデコードしたり照合したりします。ツールは、デコード情報を返します。また、正しくデコードされ、コードが指定のしきい値内にある場合、PASS となります。

2D コードの読み取り識別ツールは、領域内の 1 個のシンボルを読み取り/照合するのに使用します。一方、2D コードの読み取り (1-20) 識別ツールは、領域内にある最大 20 個のシンボルを読み取り/照合するのに使用します。

  1. 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールを設定するには
  2. 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールのパラメータを調整するには
  3. 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールの入出力プロパティを使用するには


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールを設定するには

ツールを追加したら、領域を設定します。

  1. コードやシンボル全体を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。

注: 2D コード読み取りの際には、コードと領域の間に「クワイエットゾーン」が必要です。クワイエットゾーンとは、コードの端とコード定義領域の間の最小 3 ピクセルのスペースのことです。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[設定] タブでパラメータを指定します。
  1. [シンボルグループ] パラメータでシンボルのタイプを指定します。選択肢は、[データマトリックス] (デフォルト) または [QR コード] です。
  2. [モード] パラメータで、ツールの操作方法を指定します。選択肢は、[読み取り] (デフォルト) または [マッチ文字列] です。
  3. 2D コードの読み取り (1-20) 識別ツールを使用する場合、[最大結果] パラメータを設定して、デコードするコードやシンボルの数を指定する必要があります。デフォルトは、1 です。
  4. ツールは、デコードされたコードやシンボルの周りを囲む四角形のボックスを描画します (このボックスは編集できません)。また、デコードされたコードやシンボルからフィクスチャが作成されたことを示す [image] アイコンが挿入されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [結果] タブ
  • テーブル
注:
  • [結果] タブは、2D コードの読み取り識別ツールのみに表示されます。
  • テーブルは、2D コードの読み取り (1-20) 識別ツールのみに表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


/ [全般] タブ (2D コードの読み取り/2D コードの読み取り (1-20) 識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


/ [設定] タブ (2D コードの読み取り/2D コードの読み取り (1-20) 識別ツール)

Closed シンボルグループ

デコードを試みるシンボルのタイプを指定します。選択肢は、[データマトリックス] (デフォルト) または [QR コード] です。

注: QR コードを選択すると、ツールはすべての QR コードタイプ (QR モデル 1/2、マイクロ QR および QR モデル 1/2) のデコードを試みます。

Closed 最大結果

読み取りを実行するコードやシンボルの最大数を指定します (1～20、デフォルト = 1)。

注: [最大結果] で指定した値が視野に含まれるコードやシンボルの数を超えている場合、ツールは指定した数のコードやシンボルを検出し続けます。視野に含まれるコードやシンボルの数にばらつきがある場合、[タイムアウト] パラメータの値を調整することによって、ツールの実行時間を短くすることができます。

Closed 登録済み

特定のコードやシンボルが登録済みかどうかを表示します。登録済みの場合 1 を、未登録の場合 0 を表示します。

Closed 登録

コードやシンボルの読み取りモデルを登録します。登録された情報は、[登録解除] ボタンを押すまで保持されます。コードやシンボルを再登録するには、 [登録解除] ボタンを押してから、新しいコードやシンボルに対して [登録] ボタンを押します。登録は、デコードするコードやシンボルのタイプをツールに学習させるため、使用すると、ツールのスピードおよびパフォーマンスが向上します。1D コードの読み取り (1-20) 識別ツールまたは 2D コードの読み取り (1-20) 識別ツールで登録を使用する場合、1 つのコードやシンボルの周りを囲むように領域を設定してから、[登録] ボタンを押してください。コードやシンボルが登録されたら、領域を調整し、視野 (FOV) を広げて、複数のコードやシンボルをサーチすることができるようになります。登録することができるのは、領域内の 1 つのコードやシンボルのみです。領域内の複数のコードやシンボルに対して [登録] ボタンを押すと、どのコード、シンボルが登録されるのか分からなくなります。登録する前に、[シンボルグループ] パラメータで、シンボルグループ (データマトリックスまたは QR) が正しく選択されていることを確認して下さい。

Closed 登録解除

コードやシンボルの登録済みモデルの登録を解除します。シンボルを再登録するには、[登録解除] ボタンを押してから、新しいコードに対して [登録] ボタンを押します。

Closed 遠近補正

データマトリックスシンボルのデコード設定 ([遠近補正なし] = デフォルト、[遠近補正]、[遠近補正データを登録]) を指定します。 このパラメータを有効にするには、[シンボルグループ] パラメータを [データマトリックス] に設定する必要があります。

  • 遠近補正なし: 遠近歪みのないデータマトリックスシンボルをデコードします。
  • 遠近補正: 遠近歪みを持つデータマトリックスシンボルをデコードします。遠近歪みは、モデルの登録中およびランタイムに、個別に予測されます。
  • 遠近補正データを登録: 既知の遠近歪みを持つデータマトリックスシンボルをデコードします。 シンボルの登録モデルを使用している場合、遠近補正は、そのほかの属性とともに登録されます。 ランタイムに、登録済み属性を使用して入力画像の遠近歪みが補正されている空間から、このシンボルがサーチされます。 このオプションでは、ランタイムシンボルを、登録シンボルと同じ平面に配置する必要があります。 このオプションを指定すると、既知の遠近歪みを持つひどく損傷したシンボルでもデコードを行うことができます。

ヒント: In-Sight ビジョンシステムは入射角 (センサの光軸と、シンボルが存在する平面の法線ベクトルの角度含む) が 40 度を超えないように、またシンボルの解像度が 1 セルあたり最低 5 ピクセルになるように取り付けることを推奨します。

Closed モード

ツールのモードを指定します。選択肢は、[読み取り] (デフォルト) と [マッチ文字列] です。

  • 読み取り: 目的のコードやシンボルの情報がない場合に使用されます。ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。
  • マッチ文字列: 既知のコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。
Closed マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注: マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードやシンボルと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ツールの結果は FAIL となり、[マッチ文字列] には TRIG が表示されます。

Closed マッチモード

領域内のデコードされたすべてのコードやシンボルを、[マッチ文字列] パラメータで指定した文字列にマッチさせるかどうかを指定します。このオプションを有効にするには、[マッチ文字列] パラメータに文字列を入力する必要があります。

  • 全てマッチ: デコードされたコードやシンボルは、[マッチ文字列] パラメータで指定された文字列とすべてマッチする必要があります。
  • 任意のマッチ: デコードされたコードやシンボルが、[マッチ文字列] パラメータで指定された文字列と最低 1 つマッチする必要があります。
Closed ソートモード

結果を表示する順番を指定します。選択肢は、[なし] (デフォルト)、[上→下]、[左→右]、[アルファベット順]、[文字数] です。

  • なし: デコードされた順番に結果をソートします。その次に、デコードできなかった結果が表示されます。
  • 上→下: X フィクスチャ座標値の順番に、昇順でソートします。
  • 左→右: Y フィクスチャ座標値の順番に、昇順でソートします。
  • アルファベット順: 結果をアルファベット順にソートします。
  • 文字数: 結果を文字列の長さ順にソートします (短→長)。
  • 行: シンボルを行で分類し、各行内で左→右の順番にソートします。
  • 列: シンボルを列で分類し、各列内で上→下の順番にソートします。
Closed 照合

印刷精度テストを実行するかどうかを指定します。デフォルトは、OFF です。

Closed バイナリ結果の許容

16 進数 ASCII データマトリックスシンボルを base-256 バイナリデータとしてデコードするかどうかを指定します (デフォルトでは、この設定は OFF となっています)。

Closed タイムアウト

ツールがコードやシンボルをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed デコード数

デコードしたコードやシンボルの数を表示します。

注: [最大結果]、[マッチモード]、[ソートモード] および [デコード数] パラメータは、2D コードの読み取り (1-20) 識別ツールのみに表示されます。


[結果] タブ (2D コードの読み取り識別ツール)

[結果] タブには、デコードされたコードやシンボルの情報が表示されます。

Closed 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

Closed シンボル

デコードされたシンボルのタイプを返します。

Closed グレード

デコードされたコードやシンボルのグレードを返します。


テーブル (2D コードの読み取り (1-20) 識別ツール)

デコードされたコードやシンボルの情報がテーブルに表示されます。

Closed インデックス

[ソートモード] パラメータに基づいて、デコードされたコードやシンボルの順番を表示します (1～20)。EasyBuilder では 0 から数えます。

Closed 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

Closed シンボル

デコードされたシンボルのタイプを返します。

Closed X

デコードされたコードやシンボルのフィクスチャ出力の X 座標を返します。

Closed Y

デコードされたコードやシンボルのフィクスチャ出力の Y 座標を返します。

Closed 角度

デコードされたコードやシンボルのフィクスチャ出力の角度値を返します。

Closed グレード

デコードされたコードやシンボルのグレードを返します。


/ 2D コードの読み取り/2D コードの読み取り (1-20) 識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
マッチモード* | 整数値 | X | X | 入出力
マッチ文字列 | 文字列 | X | X | 入出力
モード | 整数値 | X | X | 入出力
最大結果* | 整数値 | X | X | 入出力
モード | 整数値 | X | X | 入出力
遠近補正 | 整数値 | X | X | 入出力
ソートモード* | 整数値 | X | X | 入出力
シンボルグループ | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
照合 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
フィクスチャ1～19.角度* | 浮動小数点 | X | X | 出力
フィクスチャ1～19.X* | 浮動小数点 | X | X | 出力
フィクスチャ1～19.Y* | 浮動小数点 | X | X | 出力
グレード | 浮動小数点 | X | X | 出力
グレード1～19* | 浮動小数点 | X | X | 出力
デコード数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
文字列 | 文字列 | X | X | 出力
文字列1～19* | 文字列 | X | X | 出力
シンボル | 文字列 | X | X | 出力
シンボル1～19* | 文字列 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
登録済み | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |
登録 | 動作 | X | X |
登録解除 | 動作 | X | X |

注: * は、2D コードの読み取り (1-20) 識別ツールにのみ表示されます。


ID コードの読み取り識別ツール

ID コードの読み取り識別ツールは、バーコードおよび　2D マトリックスシンボルに含まれる情報を自動的にデコードしたり検証したりします。

注:ID コードの読み取り識別ツールは、In-Sight Explorer 4.5.0 以降では、ReadIDMax® をサポートしない In-Sight ビジョンシステムでのみご使用いただけます。

  1. ID コードの読み取り識別ツールを設定するには
    1. サポートする ID コードの種類
  2. ID コードの読み取り識別ツールのパラメータを調整するには
  3. ID コードの読み取り識別ツールの入出力プロパティを使用するには


ID コードの読み取り識別ツールを使用するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. コードまたはシンボル全体を囲むように領域を配置します。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。

注: 2D コード読み取りの際には、コードと領域の間に「クワイエットゾーン」が必要です。クワイエットゾーンとは、コードの端とコード定義領域の間の最小 3 ピクセルのスペースのことです。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 領域の確定後、[設定] タブの [モード] を定義してください。選択肢は、[読み取り] (デフォルト) または [マッチ文字列]です。
  4. ツールはコードタイプを記憶し、ジョブ実行時に指定のコードタイプをサーチするようになります。コードタイプが変更された場合、[設定] タブの[学習] ボタンを押してください。ツールは新しいコードタイプを認識するようになり、そのコードタイプをサーチします。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


サポートする ID コードの種類

ID コードの読み取り識別ツールは、次のタイプのコードおよびシンボルをサポートします。

Code 39* | Code 128
Code I2of5* | UPC
EAN | PharmaCode
POSTNET | PLANET
RSS-14 & スタックド | RSS-リミテッド
Codabar (NW-7)* | Code 93
UPU 4-State | Australia Post 4-State
Japan Post 4-State | USPS OneCode 4-State
データマトリックス | QR
RSS CC-A | RSS CC-B
PDF 417 |
* チェックサムアルゴリズムが含まれるコードおよびシンボル (オプション)。


ID コードの読み取り識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ID コードの読み取り識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ID コードの読み取り識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (ID コードの読み取り識別ツール)

Closed [学習] ボタン

新規のコードタイプまたはシンボルを定義します。[学習] ボタンは、ツールに新しいコードやシンボルを追加する時に使用されます。 ツールに新しいコードやシンボルを提示してから[学習] ボタンを押すと、ツールは自動的にデコードを試みます。 デコード後、ツールはそのタイプのコードまたはシンボルのみ、読み取りまたは照合を行うようになります。

Closed コード

デコードされたコードまたはシンボルを表示します。

Closed モード

ツールのモードを定義します。選択肢は、[読み取り] と [マッチ文字列] です。

[読み取り] (デフォルト) は、目的のコードやシンボルの情報がない場合に使用されます。 ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。

[マッチ文字列] は、既知のバーコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。 ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。

注: このツールには、PASS と FAIL の 2 つのステータスしかありません。したがって、ツールの [モード] コントロールを [マッチ文字列] に設定している際に FAIL が返される場合、2 つのシナリオが考えられます。1 つは、読み取りに失敗した場合、もう 1 つは、読み取りには成功したものの、デコードした情報が [マッチ文字列] パラメータに入力した文字列と一致しない場合です。

後者の場合、ツールはミスマッチデータ ([ミスマッチ] および [ミスマッチ数]) を出力します。このデータは、EasyView および [通信] アプリケーションステップの他のコミュニケーションデバイスで使用することができます。ミスマッチデータは、[EasyView アイテムの選択]、[OPC タグの選択] または [入力/出力データ] ダイアログから選択することができます。

ミスマッチデータは、ツールがコードの読み取りに失敗したのか、それとも、コードの読み取りに成功したものの、デコード情報が [マッチ文字列] で定義した情報と一致しないのかを決定する必要がある場合に有用です。例えば、ツールがコードの読み取りに失敗した場合、ラベル印刷のプロセスやビジョンシステムのセットアップに問題がある可能性があります。コードの読み取りに成功したもののデコード情報が [マッチ文字列] で定義した情報に一致しない場合、異なるラベルが印刷されている可能性があります。

Closed マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注: マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ID コードの読み取りツールの結果は FAIL となり、[マッチ文字列] には TRIG　が表示されます。

Closed タイムアウト

ツールがコードをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed 文字列

デコードされた情報を表示します。


ID コードの読み取り識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
マッチ文字列 | 文字列 | X | X | 入出力
モード | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
コード | 文字列 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ID | 文字列 | X | X | 出力
ミスマッチ | 浮動小数点 | X | X | 出力
マッチ数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
文字列 | 文字列 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


カラー識別ツール

カラー識別ツールは、登録済みカラーライブラリのどの色が、画像中の色に一番マッチするかを決定するのに使用されます。

このツールは、検査対象物の色を基に、製造ライン上に正しい製品が流れていることを確認したり、他の生産現場のデバイスに、認識した製品の情報を通信したりするアプリケーションにおいて有用です。

  • カラー識別ツールを設定するには
  1. ピクセルの色成分
  • カラー識別ツールのパラメータを調整するには
  • カラー識別ツールの入出力パラメータを使用するには


カラー識別ツールを設定するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 カラー全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのカラーがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、カラーが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. 領域を設定したら、ツールのカラーライブラリを設定し、使用するカラーを有効にしてください。
  • カラー識別ツールを始めて追加した場合、まずカラーライブラリおよびカラーを定義する必要があります。
  • カラー識別ツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーを使用したい場合は、[設定] タブに戻って [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラー] のチェックボックスを ON にします。
  • カラーライブラリが定義されるまで、ツールは自動的に FAIL を返します (デフォルト)。カラーライブラリが定義されると、ツールは自動的にそのライブラリを使用し、ライブラリに含まれるカラーを有効にします。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ピクセルの色成分

各カラーピクセルは、3 つの個別の色成分によって構成されています。これらの成分は、赤、緑、および青の組み合わせ (RGB) または色相、彩度、および明度の組み合わせ (HSI) として表されます。RGB も HSI も、ピクセルの各成分は 0～255 の値に変換されます。

Closed RGB

RGB の場合、異なる割合の赤、緑、および青の色調の組み合わせによって作成されます。この組み合わせによって、各ピクセルに特定の色が生成されます。

Closed HSI

HSI の場合、色の色相は、放射線の電磁スペクトルの可視部でのその色の位置に対応しています。

色の彩度は、その色に灰色または白色が混ざっている度合いです。彩度が飽和状態の場合は、純色になります。白色 (または灰色) が混ざっている度合いが高くなるほど、彩度が低下します。

色の明度は、明るさの尺度です。色の明度は、色を構成する赤、緑、および青成分の平均値として定義されます。色相、彩度、および明度の組み合わせによって、各ピクセルの正確な色が生成されます。

Closed RGB 値および HSI 値の比較

RGB 値 = 255, 0, 0

HSI 値 = 0, 255, 85

RGB 値 = 0, 255, 0

HSI 値 = 85, 255, 85

RGB 値 = 0, 0, 255

HSI 値 = 170, 255, 85


カラー識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラー識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
  • [ライブラリ] タブ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラー識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラー識別_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラー識別ツール)

Closed カラーの登録

[MatchColor 登録] ダイアログを開き、選択したカラーライブラリのカラーを定義します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[MatchColor 登録] ダイアログが開きます。EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。各カラーライブラリには、検査対象物の RGB/HSI 値から構成される、最大 100 個のカラーを含めることができます。

Closed カラー空間

ツールに使用される値を定義します。選択肢は、[RGB] (デフォルト) または [HSI] です。各カラーピクセルは、3 つの色成分によって構成されています。これらの成分は、赤、緑、青の組み合わせ (RGB)、または色相、彩度、および明度の組み合わせ (HSI) として表されます。RGB も HSI もピクセルの各成分は 0～255 の値に変換されます。

Closed モード

ツールのモードを定義します。選択肢は、[識別] または [マッチ] です。

  • [識別]: 画像内のカラーが不明な場合に使用します。このツールは、どのカラーモデルが画像中の色に一番マッチするかを決定します。選択したカラーライブラリに有効なカラーモデルが複数ある場合、そのピクセル数に基づき結果を順番付けし、ランクを決定します。
  • [マッチ]: 指定したカラーモデルが画像に存在するかを検証します。このツールは画像を処理し、画像内のカラーが [マッチカラー] パラメータで指定したカラーモデルと一致するかどうかを決定します。
Closed マッチカラー

検出されるカラーモデルを指定します。このフィールドは、[モード] パラメータを [マッチ] に設定した場合にのみ有効となります。検出するカラーモデルの名前をフィールドに入力してください。

Closed アクセプトしきい値

検出された色がサンプルカラーに類似していなければならない度合いを 0～100 で定義します。デフォルトは 90 です。

Closed カラー

検出された色の名前を表示します。


テーブル (カラー識別ツール)

最もマッチした検出カラーを、ランクおよび得点順にソートして 10 位まで表示します (読み取り専用)。

Closed ランク

検査基準に最もマッチしているカラーをランク順に 1～10 まで表示します。

Closed カラー名

検出されたカラーの名前を表示します。

Closed 得点

検出されたカラーの得点を表示します。


ライブラリ (カラー識別ツール)

Closed カラー名

選択したマッチカラーライブラリに含まれる、カラーのリストを表示します (読み取り専用)。カラー名の横にあるチェックボックスを ON または OFF にすることによって、カラーを有効にしたり、無効にすることができます。

注: マッチカラーライブラリに含まれる既存のカラーは、ツール追加時に自動的に有効となります (デフォルト)。カラーを無効にする場合は、選択したカラーライブラリを参照するツールを手動で無効にする (OFF にする) 必要があります。選択したカラーライブラリに登録済みのカラーがない場合、リストは空欄となります。

Closed RGB

選択したマッチカラーライブラリに含まれるカラーの RGB 平均値のリストを表示します (読み取り専用)。

Closed HSI

選択したマッチカラーライブラリに含まれるカラーの HSI 平均値のリストを表示します (読み取り専用)。


[合成領域] タブ (カラー識別ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラー識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注: カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
カラー有効 | 整数値 | X | X | 入出力
カラー有効の選択 | 整数値 | X | X | 入出力
カラーライブラリ | 整数値 | X | X | 入出力
カラー空間 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部カラー有効の適用 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
マッチカラー | 整数値 | X | X | 入出力
モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
青 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
緑 | 浮動小数点 | X | X | 出力
色相 | 浮動小数点 | X | X | 出力
彩度 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
赤 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
明度 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
カラー有効の適用 | 動作 | X | X |
合成領域 | 動作 | X | X |

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | A | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


郵便コードの読み取り識別ツール

郵便コードの読み取り識別ツールは、領域内の 1 つのポスタルスタックドシンボルを ReadIDMax® を使用してデコードしたり照合したりします。ツールは、デコード情報を返します。また、正しくデコードされ、コードやシンボルが指定のしきい値内にある場合、PASS となります。

  1. 郵便コードの読み取り識別ツールを設定するには
  2. 郵便コードの読み取り識別ツールのパラメータを調整するには
  3. 郵便コードの読み取り識別ツールの入出力プロパティを使用するには


郵便コードの読み取り識別ツールを設定するには

ツールを追加したら、領域を設定します。

  1. コードやシンボル全体を囲むように領域を配置します。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[設定] タブでパラメータを指定します。 [モード] パラメータで、ツールの操作方法を指定します。選択肢は、[読み取り] (デフォルト) または [マッチ文字列] です。
  4. ツールは、デコードされたコードやシンボルの周りを囲む四角形のボックスを描画します (このボックスは編集できません)。また、デコードされたコードやシンボルからフィクスチャが作成されたことを示す [image] アイコンが挿入されます。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


郵便コードの読み取り識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

郵便コードの読み取り識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ポスタル] タブ
  • [結果] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (郵便コードの読み取り識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は ID コード_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (郵便コードの読み取り識別ツール)

Closed 登録済み

特定のコードやシンボルが登録済みかどうかを表示します。登録済みの場合 1 を、未登録の場合 0 を表示します。

Closed 登録

コードやシンボルの読み取りモデルを登録します。登録された情報は、[登録解除] ボタンを押すまで保持されます。コードやシンボルを再登録するには、 [登録解除] ボタンを押してから、新しいコードやシンボルに対して [登録] ボタンを押します。登録は、デコードするコードやシンボルのタイプをツールに学習させるため、使用すると、ツールのスピードおよびパフォーマンスが向上します。1D コードの読み取り (1-20) 識別ツールまたは 2D コードの読み取り (1-20) 識別ツールで登録を使用する場合、1 つのコードやシンボルの周りを囲むように領域を設定してから、[登録] ボタンを押してください。コードやシンボルが登録されたら、領域を調整し、視野 (FOV) を広げて、複数のコードやシンボルをサーチすることができるようになります。登録することができるのは、領域内の 1 つのコードやシンボルのみです。領域内の複数のコードやシンボルに対して [登録] ボタンを押すと、どのコード、シンボルが登録されるのか分からなくなります。登録する前に、[ポスタル] タブでコードタイプが正しく選択されていることを確認して下さい。

Closed 登録解除

コードやシンボルの登録済みモデルの登録を解除します。シンボルを再登録するには、[登録解除] ボタンを押してから、新しいコードに対して [登録] ボタンを押します。

Closed モード

ツールのモードを指定します。選択肢は、[読み取り] (デフォルト) と [マッチ文字列] です。

  • 読み取り: 目的のコードやシンボルの情報がない場合に使用されます。ツールが情報を自動的にデコードして、デコードされた情報を [文字列] パラメータに表示します。
  • マッチ文字列: 既知のコードやシンボルが存在し、読み取り可能かどうかを検証するのに使用されます。ツールは情報をデコードし、その情報と [マッチ文字列] に入力された情報を比較します。
Closed マッチ文字列

読み取りされる文字列を定義します ([モード] パラメータが [マッチ文字列] に設定されているときのみ有効となります)。デコードする情報を入力してください。

注: マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードやシンボルと比較することができます。マッチ文字列が外部デバイスから入力されるまで、ツールの結果は FAIL となり、[マッチ文字列] には TRIG が表示されます。

Closed モード

領域内のデコードされたすべてのコードやシンボルを、[マッチ文字列] パラメータで指定した文字列にマッチさせるかどうかを指定します。このオプションを有効にするには、[マッチ文字列] パラメータに文字列を入力する必要があります。

  • 全てマッチ: デコードされたコードやシンボルは、[マッチ文字列] パラメータで指定された文字列とすべてマッチする必要があります。
  • 任意のマッチ: デコードされたコードやシンボルが、[マッチ文字列] パラメータで指定された文字列と最低 1 つマッチする必要があります。
Closed 照合

印刷精度テストを実行するかどうかを指定します。デフォルトは、OFF です。

Closed タイムアウト

ツールがコードやシンボルをサーチする時間をミリ秒単位で指定します (0～30000、デフォルト = 0)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed 全方向読み取り

全方向読み取りモードを使用して、バーコードの読み取りを試みるかどうかを決定します (デフォルトは、OFF)。バーコードのエレメントをすべて検出するために、領域内に抽出されるスキャンラインの方向を指定します。1D シンボルの場合、バーコードはバーに対して垂直な最大 10 本の等間隔ライン (スキャンライン) に分割されます。デコードを成功させるには、バーコードのすべてのエレメント間で、少なくとも 1 つのスキャンラインを抽出する必要があります。OFF の場合、スキャンラインは領域に平行なバーコードを検出するような 1 方向のみにプロジェクションされます。ON の場合、スキャンラインは領域に対して回転したバーコードを検出するように、複数の角度でプロジェクションされます。


[ポスタル] タブ (郵便コードの読み取り識別ツール)

このタブを使用して、デコードを試みるコードやシンボルを指定します。デフォルトで、すべてのコードやシンボルタイプが有効となっており、複数のシンボルを選択して、読み取ることができます。

Closed POSTNET

POSTNET の読み取りを試みるかどうかを指定します。

Closed PLANET

PLANET の読み取りを試みるかどうかを指定します。

Closed 日本郵便

日本郵便の読み取りを試みるかどうかを指定します。

Closed オーストラリア郵便

オーストラリア郵便の読み取りを試みるかどうかを指定します。

Closed UPU

UPU の読み取りを試みるかどうかを指定します。

Closed インテリジェントメールバーコード

インテリジェントメールバーコードの読み取りを試みるかどうかを指定します。


[結果] タブ (郵便コードの読み取り識別ツール)

[結果] タブには、デコードされたコードやシンボルの情報が表示されます。

Closed 文字列

デコードされたコードやシンボルに含まれる文字列を返します。

Closed シンボル

デコードされたシンボルのタイプを返します。

Closed グレード

デコードされたコードやシンボルのグレードを返します。


郵便コードの読み取り識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
オーストラリア郵便 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
インテリジェントメールバーコード | 整数値 | X | X | 入出力
マッチ文字列 | 文字列 | X | X | 入出力
モード | 整数値 | X | X | 入出力
PLANET | 整数値 | X | X | 入出力
POSTNET | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
UPU | 整数値 | X | X | 入出力
照合 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度 | 文字列 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
グレード | 浮動小数点 | X | X | 出力
デコード数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
文字列 | 文字列 | X | X | 出力
シンボル | 文字列 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
登録済み | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |
登録 | 動作 | X | X |
登録解除 | 動作 | X | X |


文字認識 (OCRMax) 識別ツール

文字認識 (OCRMax) 識別ツールを使用して、ユーザ定義の文字フォントの登録・作成後、領域内の文字列の認識/照合に使用します。

文字認識 (OCRMax) 識別ツールは、セグメント化および分類化プロセスを実行することにより、光学文字認識 (OCR) を行います。しきい値技術を使用して、文字列を含む画像エリアを識別し、セグメント化します。その後、文字を登録し、フォントデータベースに保存します。ランタイム中に分類化が行われ、セグメント化が実行された後、検出された文字に対して読み取りが行われます。これは、セグメント化された文字を、フォント中の登録文字に比較することによって実行されます。

  1. 文字認識 (OCRMax) 識別ツールを設定するには
  2. 文字認識 (OCRMax) 識別ツールのパラメータを調整するには
  3. 文字認識 (OCRMax) 識別ツールの入出力プロパティを使用するには


文字認識 (OCRMax) 識別ツールを設定するには

文字認識 (OCRMax) 識別ツールの操作は、2 つのステップ (登録および実行) からなります。

  • 登録ステップでは、読み取りを行う文字の複数の画像をロードし、画像から文字を抽出およびセグメント化し、文字の登録フォントデータベースを作成します。
  • 実行ステップでは、In-Sight ビジョンシステムをオンラインにし、画像を取り込み、登録フォントデータベースを基に文字の抽出および分類を行います。

注: ツールを設定する前に、登録画像をロードしてください。フォントデータベースの登録の際には、文字の外観を最もよく表す画像 (最良の画像) を使用してプロセスを開始し、最後に最も状態の悪い画像を使用することを推奨します。

Closed 文字認識 (OCRMax) 識別ツールを登録するには
  1. 最初の画像をロードします。
  2. 文字認識 (OCRMax) 識別ツールを追加します。
  3. 画像内の領域を設定します。読み取りを行う文字列を囲むように領域を配置します。
  • 領域の X 軸は文字列のベースラインに対して平行になるように、Y 軸は文字の垂直のストロークと平行になるように領域を設定します。文字に歪み (スキュー) がない場合、Y 時期は X 軸に対して直角になります。

  • X 軸の正の方向は、読み取りの方向となります。

  • 領域には、1 つの文字列およびその背景のみ含むようにしてください。背景には、ノイズが多かったり、多数の勾配/影があることがあります。
  • 明瞭に印刷され、ノイズがほとんどない画像では、領域を文字列より大幅に大きく設定することが可能です。
  • ノイズの多い画像では、文字列を囲む領域を狭く設定する必要があります。
  • 経験則として、可能な場合、領域はすべての側でテキスト行より文字幅の半分以上大きくします (領域の境界に、他の特徴が含まれてしまう場合を除きます)。
注:
  • 文字列のベースラインが傾いている (0～360 度) 場合、領域もほぼ同じ程度の角度で傾くように設定してください。
  • 領域には、文字列以外の顕著な特徴を含むことはできません。例えば、異なる文字列やラベルのエッジなどの一部が領域に含まれないようにしてください。
  • 領域に角度がある場合、ツールは画像から自動的に角度を取り除き、歪み補正した「カーブ領域位置」ラベル付きの領域を出力します。この領域は、表示用に画像内で再配置されている可能性があります。
  4. [セグメント] タブの設定に基づいて、文字の周囲に矩形が自動的に作成されます。

  5. 関数がテキスト周囲の文字領域を正しく描画しなかった場合は、2 つのオプションがあります。
  • [オートチューン] ダイアログを使用して、文字認識 (OCRMax) 識別ツールのセグメントの最適設定を自動的に計算します。[オートチューン] ダイアログは、セグメントおよび登録の 2 段階を 1 つにまとめます。[オートチューン] ダイアログトピックの指示にしたがって、フォントデータベースをセグメントし、登録してください。
  • [セグメント] タブでテキストが個々の文字領域で正しく囲まれるまでパラメータを調整します。セグメントプロセスにしたがって、登録前に画像データベース内のすべての文字をセグメントしてください。
注:
  • ノイズが多かったり、読み取りにくい文字の場合、[詳細設定] タブを使用して、これらの条件を補正することが可能です。
  • 文字間にスペースがある場合、[スペース] タブを開き、パラメータを調整してスペースの設定を調整してください。
Closed セグメント後に、文字認識 (OCRMax) 識別ツールを手動で登録するには

文字をセグメントすると、文字を登録しフォントに追加することができます。まず、[設定] タブを開き、フォントライブラリパラメータからフォントを選択します。

  • 新規にカスタムフォントを作成する場合、[登録] タブを開き、登録する文字列を入力してから、[すべてを登録] ボタンを押します。選択中のカスタムフォントに文字が追加・保存されます。

既存のカスタムフォントに文字を追加するには、登録する文字が含まれる別の画像を取得またはロードします。必要な場合、領域やセグメント化関連のパラメータを再設定し、文字を正しくセグメント化します。次に、[登録] タブの [新規文字を登録] または [選択中の文字を登録] ボタンを押します。

注: カスタムフォントは、[登録] タブから OCRMax データファイル (*.ocm) としてエクスポートしたり、インポートしたりすることができます。

  • 定義済みの OCRA または OCRBフォントを使用している場合、読み取りを行う文字の上にツールの領域を配置すると、[セグメント] および [詳細設定] タブで定義したパラメータ設定に基づいて、領域内の文字は自動的にセグメント化されます。

注: 義済みの OCRA/OCRB フォントは編集できません。

Closed 実行ステップ

フォントデータベース登録後、実行ステップに進むことができます。

  1. [検査モード] を設定します。ランタイム中に、領域内の文字を読み取るだけなのか、または読み取られた文字が正しいかどうかを認識/照合するかを決定します。
  2. 実行時に、In-Sight ビジョンシステムはオンラインになり、ジョブによって定義されているとおりに画像を取り込みます。画像が取り込まれると、画像内のテキスト文字列は [セグメント] パラメータに基づいて自動的にセグメンテーションされ、登録済みインスタンスと比較されます。


文字認識 (OCRMax) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

文字認識 (OCRMax) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [セグメント] タブ
  • [詳細設定] タブ
  • [スペース] タブ
  • [可変長] タブ
  • [登録] タブ
  • [フィールド化] タブ
  • [診断] タブ
  • [結果] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (文字認識 (OCRMax) 識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は文字_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (文字認識 (OCRMax) 識別ツール)

Closed フォントライブラリ

ツールが参照するフォントデータベースを指定します。定義済みのフォントタイプ (OCR-A/OCR-B、白地に黒/黒地に白) から選択するか、あるいは文字モデルを登録してカスタムフォントを作成してください (ジョブには 8 個までのカスタムフォントデータベースを作成することができます)。

注: 4 種類の OCRA/OCRB フォントは読み取り専用で、再登録や、削除、名前の変更をすることはできません。

  • 定義済みのフォントを選択した場合、読み取りを行う文字の上にツールの領域を配置すると、領域内の文字は自動的にセグメント化されます。
  • カスタムフォントを選択した場合、文字認識 (OCRMax) 識別ツールを設定するにはトピックで説明されたステップに従って、カスタムフォントデータベース新規作成してください。既存のカスタムフォントを変更する場合、同一のカスタムフォントを使用している他の文字認識 (OCRMax) ツールも変更されます。
Closed 検査モード

ツールのモードを指定します。選択肢は、[読み取り] または [認識と照合] です。

  • [読み取り]: 登録済み文字インスタンスに基づき、領域内の文字の読み取りを試みます。
  • [認識と照合]: 登録済み文字インスタンスに基づき、領域内の文字の読み取りを試みた後、[マッチ文字列] で指定した文字列に対応しているかどうかを検証します。
Closed マッチ文字列

[認識と照合] 検査モード時に、マッチさせる文字列を指定します。

Closed アクセプトしきい値

各文字の許容できる最低一致得点 (0～100、デフォルト = 80) を指定します。マッチ得点がアクセプトしきい値以下の場合、FAIL となります。

Closed コンフュージョンしきい値

最高得点の文字と 2 番目の得点の文字のマッチ得点の間に必要な最小の値 (0～40、デフォルト = 0) を指定します。

Closed サブサンプリングを使用

画像のサブサンプリングを有効にするかどうかを指定します。ON にすると、文字の解像度は低くなりますが、読み取り速度は早くなります。

Closed タイムアウト

文字のサーチ時間 (0 ～ 30000、デフォルト = 5000) をミリ秒単位で指定します。指定された時間が経過すると、実行は停止し、#ERR が返されます。値を 0 に設定すると、OFF になり、タイムアウトは適応されません。

Closed 文字の表示

文字および文字の領域をすべてのアプリケーションステップで表示するか、あるいは位置決めおよび検査アプリケーションステップでのみ表示するかどうかを指定します。(デフォルト = ON)

Closed 文字ラベル位置

文字を囲む領域に対し、文字ラベルを表示する場所を指定します。選択肢は、文字の上 (デフォルト)、文字の右、文字の下、または文字の左です。


[セグメント] タブ (文字認識 (OCRMax) 識別ツール)

[セグメント] タブでは、領域内のセグメント化文字の設定を調整したり、修正したりします。デフォルト値を使用して、ほとんどの文字を読み取ることができますが、比較的難しいケースの場合、パラメータ値を調整する必要が生じることもあります。これらのケースでは、文字幅の最小値や、最大値、最小ピッチ値 (文字の左エッジから、次の文字の左エッジまでといった、文字間の距離) を指定して、補正を行なってください。困難なケースの場合、フォントデータベースの作成時間を短縮するために、[オートチューン] ボタンを使用して、[オートチューン] ダイアログを開き、セグメントの最適設定を自動的に計算することができます。

Closed セグメント化のガイドライン
  • 強いテクスチャや多くのノイスが背景に含まれている場合、文字が背景に溶けこんでしまい、セグメント化は困難です。
  • 領域には、読み取る文字のみ含まれるようにし、別の文字やラベルエッジなど、無関係な強い特徴は含まれないようにしてください。
  • 2 つの文字が接触している場合、ほとんどのケースでパラメータを調整する必要があります。接触している文字の幅が固定幅の場合、文字幅を指定することにより、補正が可能です。ただし、接触している文字がプロポーショナルフォントの場合、補正は簡単ではありません。正しくプロセスできる場合もありますが、そうでない場合もあります。
  • 文字列が短い場合 (3 文字以下の場合など) や、多くのラインジッタが含まれる比較的短い文字列の場合、[角度範囲] を指定することにより、短い文字列の方向を決定する際に生じる不確実性を補正することができます。
  • 文字列に含まれる文字は、すべて同じ方向およびスキューである必要があります。
  • ドットマトリクス印刷で、ドットとドットが離れている場合、文字を正しくセグメント化するには、[最小文字フラグメントサイズ] などのパラメータ調整が必要です。
  • 文字のストローク幅は、2 ピクセル以上である必要があります。
  • 大きな文字 (アルファベットなど) の最小文字サイズは 8 x 8 ピクセルです。小さな文字 (ピリオドなど) の最小文字サイズは、2 x 2 ピクセルです。
Closed オートチューン

文字認識 (OCRMax) 識別ツールとともに使用される [オートチューン] ダイアログを開き、オートチューンモデルを作成し、オートチューン記録を構成することによって、ツールのセグメントパラメータを設定し、フォントデータベースを登録します。オートチューン記録は、画像、登録文字列および画像内でユーザが検証した文字の位置から構成されています。オートチューンモデルとは、1 つまたは複数のオートチューン記録、さらにオートチューン記録内のすべての画像においての最適なセグメント設定から構成されています。

注:
  • オートチューンを使用する場合、In-Sight ビジョンシステム上でなく、In-Sight エミュレータ上で実施することを推奨します。文字認識 (OCRMax) 識別ツールのオートチューンアルゴリズムには、非常に多くの計算リソースが必要であるため、ビジョンシステムよりエミュレータで計算を行ったほうが、より良く機能します。
  • フォントデータベースを登録するのに [オートチューン] ダイアログを使用する場合、文字の外観を最もよく表す画像 (最良の画像) を使用してプロセスを開始し、最後に最も状態の悪い画像を使用することを推奨します。このプロセスにより、文字認識 (OCRMax) 識別ツールのオートチューンアルゴリズムを最善の状態で使用することができます。
Closed 文字の極性

入力画像の文字極性を指定します。選択肢は、[黒 (白い背景)]、[白 (黒い背景)] または [自動] (デフォルト) です。

注: 文字の極性を指定することによって、ツールのパフォーマンスを向上することができます。

  • [黒 (白い背景)]: 白い背景上に黒い文字。
  • [白 (黒い背景)]: 黒い背景上に白い文字。
  • [自動]: 自動的に文字の色および背景の極性を決定します。
Closed 文字幅のタイプ

フォント内の文字幅がどのように異なるかを指定します。選択肢は、[自動] (デフォルト)、[固定] または [変数] です。

注: 文字幅とは、文字を囲む矩形の幅のことです。領域ではありません。

  • [自動]: 文字幅は不明です。フォントの幅は、固定またはプロポーショナルである可能性があります。
  • [固定]: フォント内の文字を囲む矩形は、すべて等幅です。
  • [変数]: フォント内の文字を囲む矩形の幅は異なっています。
Closed 文字幅の最小値

文字を囲む矩形の最小幅 (1～1000、デフォルトは 3) をピクセル単位で指定します。

Closed 文字の高さの最小値

文字を囲む矩形の最小の高さ (1～1000、デフォルトは 3) をピクセル単位で指定します。

Closed 文字幅の最大値を使用

文字を囲む矩形の幅の最大許容可能値を考慮に入れるかどうかを指定します (デフォルトは、OFF)。

注: ON にすると、指定値より幅が広い文字は、2 つのセグメントに分割されます。

Closed 文字幅の最大値

文字を囲む矩形の最大幅 (1～5000、デフォルトは 100) をピクセル単位で指定します。

Closed 文字の高さの最大値を使用

文字を囲む矩形の高さの最大許容可能値を考慮に入れるかどうかを指定します (デフォルトは、OFF)。

注: この値の使用方法は 2 種類あります。1 つは、全体的なラインの検出に使用します。垂直線に隣接したノイズや、垂直線に隣接した文字の他のラインを除外したりします。もう 1 つの使用方法は、この値を超える高さの各文字をトリミングして、この高さに合うようにします。

Closed 文字の高さの最大値

文字を囲む矩形の最大の高さ (1～5000、デフォルトは 100) をピクセル単位で指定します。

Closed 最小文字アスペクト比を使用

文字のアスペクト比の最小許容可能値を考慮に入れるかどうかを指定します。アスペクト比とは、文字列全体の高さを文字列を囲む矩形の幅で割ったものです。(デフォルトは ON)。

注: ON の場合、アスペクト比が指定値より小さい文字 (幅が広すぎるなど) は、複数のセグメントに分割されます。

Closed 最小文字アスペクト比

許容可能な最小アスペクト比 (0～500、デフォルトは 80) を指定します。

Closed 角度範囲

角度のサーチ範囲 (0～45、デフォルトは 0) を指定します。

注: 0 以上の値に設定すると、セグメント化実行時間が長くなります。

Closed スキュー範囲

スキューのサーチ範囲 (0～45、デフォルトは 0) を指定します。

Note: 0 以上の値に設定すると、セグメント化実行時間が長くなります。

Closed 診断の表示

画像のグラフィックス診断データを表示するかどうかを指定します。有効にした場合、保存された文字 (緑)、除外した文字 (赤)、保存されたフラグメント (水色)、不合格フラグメント (黄)、文字のメインライン (青) および文字の延長メインライン (紫) の周囲に領域が描画されます。


[詳細設定] タブ (文字認識 (OCRMax) 識別ツール)

Closed 文字フラグメントマージモード

セグメント化中に文字を形成しているときの、文字のマージ方法を指定します。選択肢は、[要オーバラップ] (デフォルト)、[最小文字間ギャップ値に設定] または [最小文字間ギャップ値/最大文字内ギャップ値に設定] です。

  • [要オーバラップ]: マージするには、文字フラグメントが最低 1 ピクセル分、水平に重なっている必要があります。
  • [最小文字間ギャップ値に設定]: 水平ギャップのある文字フラグメントが、[最小文字間ギャップ値] で指定した値より小さい場合、マージし文字を形成します。
  • [最小文字間ギャップ値/最大文字内ギャップ値に設定]: [最小文字間ギャップ値] および [最大文字内ギャップ値] パラメータに基づき、水平ギャップのある文字フラグメントをマージし、文字を形成します。
Closed 文字フラグメントの最小オーバーラップ値

2 つの文字フラグメントが X 方向に重なりあい、同じ文字の一部としてみなすのに必要な、最小フラグメント値 (0～100、デフォルトは 0) を指定します。

Closed 最大文字内ギャップ値

1 つの文字内 (損傷した文字を含む) で起こり得る最大ギャップサイズ (0～1000、デフォルトは 5) をピクセル単位で指定します。

Closed 最小文字間ギャップ値

1 つの文字内で起こり得る最小ギャップサイズをピクセル単位で指定します　(0～1000、デフォルトは 0)。ギャップとは、文字の矩形の右エッジから次の文字の矩形の左エッジまでの距離のことです。2 つのフラグメント間のギャップがこの値より小さい場合、2 つの文字を合わせた幅が広すぎない限り ([文字幅の最大値] や [最小文字アスペクト比] で指定します)、これらのフラグメントを同じ文字の一部とみなします。

Closed 最小文字フラグメントサイズ

フラグメントを文字としてみなすために必要な、前景色 (文字など) の最小ピクセル値 (0～1000、デフォルトは、15) を指定します。文字フラグメントとは、2 値化画像内のブロブのことです。

Closed 文字サイズの最小値

文字として報告するために必要な、前景色 (文字など) の最小ピクセル値 (0～5000、デフォルトは、15) を指定します。

Closed 正規化モード

画像の正規化に使用するモードを指定します。選択肢は、[なし]、[グローバル]、[ローカル] または [ローカル詳細設定](デフォルト) です。

注: この設定は、登録時もランタイム時も同じである必要があります。登録後に設定を変更すると、分類化に問題が生じます。

  • [なし]: 正規化は実行されません。
  • [グローバル]: 領域全体を使用して、グローバル正規化を実行します。ローカルバリエーションは使用されません。
  • [ローカル]: 領域内の各ローカル文字の矩形についての情報を使用して、正規化を実行します。
  • [ローカル詳細設定]: 領域内の各ローカル文字の矩形についての情報を使用して、正規化を実行します。正規化の際には、背景だけでなく、前景色のコントラストの調整も実行されます。
Closed ストローク幅フィルタを使用

正規化画像から、ストローク幅が異なるものをすべて削除するかどうかを指定します (デフォルトは、ON)。この設定は、細いノイズストリークのせいで、文字がつながって見える場合などに有用です。ただし、この設定を使用すると、ストローク幅が均一でない場合、文字を誤って削除してしまう可能性があります。

注: この設定は、登録時もランタイム時も同じである必要があります。登録後に設定を変更すると、分類化に問題が生じます。

Closed 境界フラグメントを無視

領域の境界上にあるフラグメントを完全に無視するかどうかを指定します (デフォルトでは、この設定は OFF です)。この設定は、ラベルのエッジなどの文字以外の特徴が領域に含まれている場合に有用です。

注: 文字矩形の境界から文字のメインラインに至るフラグメントは文字とみなされます。このパラメータを ON に設定した場合、フラグメントを無視するには、文字のメインラインに至らないようにしてください。

Closed 2 値化しきい値

2 値化しきい値の計算に使用される範囲内のパーセンテージ修飾子 (0～100、デフォルトは、50) を指定します。2 値化しきい値は、正規化画像内で画像を前景色と背景に 2 値化します。

Closed 文字フラグメントのコントラストしきい値

[2 値化しきい値] を基準にして、フラグメントを文字とみなすのに必要な最小コントラスト値 (正規化画像内のグレーレベル、0～255、デフォルトは 30) を指定します。

Closed メインラインまでの最大フラグメント距離

文字列の水平線「メインライン」から削除されるフラグメントの距離を、ピクセル単位で (0～1000、デフォルトは 0) 指定します。

Closed セグメント解析モード

文字セグメント化を実行する、文字解析モードタイプを指定します。選択肢は、[最小] または [標準](デフォルト) です。

  • [最小]: セグメント化パラメータに基づき、簡単なセグメント化を実行します。
  • [標準]: 文字の間隔を含む、文字列ライン全体の解析を行い、最適なセグメント方法を決定します。
Closed 最小ピッチ値

2 つの文字間で起こり得る、最小ピッチ値 (0～1000、デフォルトは 0) をピクセル単位で指定します。ピッチは、[文字ピッチ位置] パラメータに基づいて計算されます。2 つのフラグメント間のピッチがこの値より小さい場合、2 つの文字を合わせた幅が広すぎない限り ([文字幅の最大値] や [最小文字アスペクト比] で指定します)、これらのフラグメントを同じ文字の一部とみなします。ピッチは、隣り合う文字の対応点間の距離によって定義します。文字の終わりから、次の文字の始めの間の距離は、文字間のギャップと呼ばれます。

Closed 文字ピッチ位置

文字間のピッチの測定方法を指定します。選択肢は、[自動](デフォルト)、[左-左]、[中央-中央] または [右-右] です。

注:
  • [セグメント解析モード] パラメータを [最小] に設定した場合、このパラメータは無効になります。
  • 「左」および「右」とは、領域が定義する座標を基準にしています。例えば、「右」は、X の正方向と同意です。
  • [自動]: 未知のメトリックスが使用されている場合に指定します。他のピッチ位置が適切なピッチ位置である場合もあれば、一定したピッチ位置 (プロポーショナルピッチフォントの場合など) がない場合もあります。
  • [左-左]: 文字を囲む矩形の左端から、次の文字の矩形の左端までの距離を使用して測定したピッチを指定します。
  • [中央-中央]: 文字を囲む矩形の中央から、次の文字の矩形の中央までの距離を使用して測定したピッチを指定します。
  • [右-右]: 文字を囲む矩形の右端から、次の文字の矩形の右端までの距離を使用して測定したピッチを指定します。
Closed 文字のピッチタイプ

文字間隔の定義に使用するメトリックスを指定します。選択肢は、[自動](デフォルト)、[固定]、[比例] または [変数] です。

注: [セグメント解析モード] パラメータを [最小] に設定した場合、このパラメータは無効になります。

  • [自動]: ピッチタイプが [固定] または[比例] タイプであるが、どちらか不明の場合に指定します。[変数] タイプには使用できません。
  • [固定]:　文字の矩形の幅にかかわらず、2 つの文字間のピッチが一定の、固定ピッチである場合に指定します。ピッチは、[文字ピッチ位置] を基に計測します。
  • [比例]: 2 つの文字間のピッチが、文字によって異なる、プロポーショナルピッチである場合に指定します。

注:
  • どのピッチ計測法も文字列内で一定ではありません。一般的に、文字の矩形の右端から次の文字の矩形の左端までの距離である文字間ギャップは、おおよそ一定です。
  • 「左」および「右」とは、領域が定義する座標を基準にしています。例えば、「右」は、X の正方向と同意です。
  • [変数]: 文字間距離のメトリックスが文字列内で一定でない場合に指定します。例えば、文字位置が一定しておらず、ピッチが [固定] または [比例] のいずれでもない場合などです。

注: [変数] ピッチは、[自動] とは異なります。[自動] は、未知のピッチが [固定] または [比例] である場合を想定しています。

Closed 追加の文字検証をスキップ

分類化中に追加の文字検証を実行するかどうかを指定します (デフォルトは、OFF)。OFF の場合、分類化中に追加の文字検証を実行し、誤読が発生する機会を減少させます。

Closed 出力画像グラフィックス

表示する出力画像のタイプを指定します。選択肢は、[入力画像](デフォルト)、[正規化画像] または [バイナリ画像] です。

  • [入力画像]： アクティブな入力画像が表示されます。
  • [正規化画像]: 正規化された画像が表示されます。
  • [バイナリ画像]: 2 値化画像が表示されます。


[スペース] タブ (文字認識 (OCRMax) 識別ツール)

[スペース] タブを使用して、必要な場合に、文字間のスペースをどのように取り扱うかを指定します。文字認識 (OCRMax) 識別ツールは、文字間ギャップをユーザ定義のスペース文字として分類、処理します。

Closed スペースの検出

文字間のギャップにどのようにスペース文字を挿入するかを指定します。選択肢は、[なし](デフォルト)、[シングルスペースの挿入] または [複数スペースの挿入] です。

  • [なし]: 文字間のギャップの大きさにかかわらず、スペース文字は挿入されません。
  • [シングルスペースの挿入]: 文字間のギャップの大きさにかかわらず、文字間に 1 つのスペース文字を挿入します。
  • [複数スペースの挿入]: 文字間ギャップに x 個 (0 または 1 以上) のスペース文字を挿入します。
Closed スペース得点モード

スペースの得点方法を指定します。選択肢は、[常に 100 を得点] または [クラッタを基に得点] です。

  • [常に 100 を得点]: スペース文字は常に 100 点となります。
  • [クラッタを基に得点]: 背景にあるピクセルフラグメントに基づいて、スペース文字を得点します。背景ピクセルのみからなるスペース文字は 100 点を得点します。
Closed スペース最小幅

スペース文字の最小幅値をピクセル単位で指定します。(0～1000、デフォルトは、10)

Closed スペース最大幅

スペース文字の最大幅値をピクセル単位で指定します。(0～1000、デフォルトは、100)


[可変長] タブ (文字認識 (OCRMax) 識別ツール)

[可変長] タブを使用して、 どの文字が文字中の異なる位置に表示されるかという情報を提供します。

注: これらのパラメータは、[フィールド化] タブのパラメータを有効にし、設定したときのみ、使用します。

Closed 文字数

フィールド化を実行する文字列の長さを指定します。選択肢は、[固定](デフォルト) または [変数] です。

  • [変数]: 可変長モードで操作されます。
  • [固定]: 固定の文字列数モードで操作されます。
Closed 最大文字列長

文字列の最大許容文字数を指定します。(0～100、デフォルトは、15)。

注: このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。

Closed 最小文字列長

文字列の最小許容文字数を指定します。(0～100、デフォルトは、5)。

注: このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。

Closed 最後にフィールド化した最大インデックス値

フィールド化サブシーケンスを指定します。フィールド化サブシーケンス開始位置は、このインデックス値より小さい値である必要があります。(0～100、デフォルトは、100)

注: このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。

Closed 最初にフィールド化した最小インデックス値

フィールド化サブシーケンスを指定します。フィールド化サブシーケンス終了位置は、このインデックス値より大きい値である必要があります。(0～100、デフォルトは、0)

注: このパラメータは、[文字数] パラメータが [固定] の場合、OFF となります。


[登録] タブ (文字認識 (OCRMax) 識別ツール)

[登録] タブを使用して、登録、表示、名前の変更および文字の削除などを行うことができます。このタブは、文字登録パラメータを指定するタブと、登録済みフォントを管理するタブの 2 つのグループに分かれています。

注:
  • [登録] タブでは、領域を調整することができます (編集グラフィックスボタンが ON になります)。領域が修正されると、セグメント化グラフィックス (文字の矩形) が更新されます。
  • 複数バイトの文字名 (漢字など) はサポートされていません。複数バイトの文字を登録することは可能ですが、文字名はシングルバイト名である必要があります。
Closed 登録グループボックスの設定項目

注: 文字を登録する前に、正しくセグメント化が行われている必要があります。

  • [文字列の登録]: 登録する文字列を指定します。[文字列の登録] テキスト入力ボックス内の文字数は、セグメント化された文字の数と一致する必要があります。最大 50 までの文字を登録できます。
  • [すべてを登録]: 領域内のすべての文字を登録します。登録する文字を [文字列の登録] テキスト入力ボックスに入力してから、[すべてを登録] ボタンを押します。テキスト入力ボックス内の文字数は、セグメント化された文字の数と一致する必要があります。
  • [新規文字を登録]: 領域内の新規文字のみを登録します。登録する文字を [文字列の登録] テキスト入力ボックスに入力してから、[新規文字を登録] ボタンを押します。テキスト入力ボックス内の文字数は、セグメント化された文字の数と一致する必要があります。
  • [選択中の文字を登録]: 領域内の指定の文字を登録します。このオプションを選択すると、[文字列の登録] テキスト入力ボックスは無効となり、[個々の文字をフォントに追加] ダイアログが開きます。ダイアログには、領域内の矩形で囲まれた画像と、その下にラベルとテキスト入力ボックスが表示されます。ラベルには、その画像に現在関連付けられているシンボルが表示されます (未登録の文字では、「?」が表示されます)。ラベルの下にはテキスト入力ボックスが表示されます。セグメント化された文字のラベル名をテキスト入力ボックスに入力してください。その文字を保持しない場合は、テキスト入力ボックスには何も入力しないでください。[登録] ボタンを押して、ダイアログを閉じます。
Closed 文字グループボックスの設定項目

登録後、登録済みの文字は、ツリーに表示されます。各文字にはフォルダおよびラベルが割り当てられ、グループ化 (同じラベルの文字がある場合) されます。

  • ルートフォルダを選択して、右側のパネルにフォント内のすべての文字を表示します。文字はアイコンとして表示され、その下にはラベルが表示されます。
  • 文字フォルダを選択して、右側のパネルにその文字の登録インスタンスを表示します。文字はアイコンとして表示され、その下にはラベルが表示されます。
  • 文字の登録インスタンスを選択して、右側のパネルに拡大された文字を表示します。

ヒント: 各文字に対して複数のインスタンスを登録することにより、ランタイム中に、類似の文字タイプをより正確に識別することができるようになります。しかし、複数の文字インスタントの登録には、長所と短所が存在します。長所は、誤って分類してしまう可能性がある文字 (8 と B など) を読み取る際などに、より正確に分類化を行うことができる点です。短所としては、次の点があげられます: ツールの実行時間が長くなったり、信頼性得点が低くなったりすることがある。複数の登録インスタンスは得点を上げるが、2 番目に高い得点も上げてしまう。悪い文字を登録してしまうことがある。

  • インポート: [開く] ダイアログを開き、OCRMax データファイル (*.ocm) として保存されたフォントをインポートします。
  • エクスポート: [名前をつけて保存] ダイアログを開き、OCRMax データファイル (*.ocm) として保存されたフォントをエクスポートします。
  • 名前の変更: アイテムを選択し、名前を変更します。ツリー中または右側のリストパネル中のいかなるアイテムの名前も変更することができます。

注: 文字グループの名前を変更すると、グループ内のすべての文字に対して新しいラベルが割り当てられます。単一の文字の名前を変更すると、選択中の 1 つの文字に対して新しいラベルが割り当てられ、その文字はツリー内の新しいグループまたは別のグループに移動します。

  • 削除: フォントから削除するアイテムを選択してから、ボタンを押します。ツリー中または右側のリストパネル中のいかなるアイテムも削除することができます。

注: フォントフォルダを削除すると、フォントが消去され、すべての文字が削除されます。文字グループを削除すると、同じラベル名のすべての文字が削除されます。


[フィールド化] タブ (文字認識 (OCRMax) 識別ツール)

[フィールド化] タブは、文字認識 (OCRMax) 識別ツールのフィールド文字列およびフィールド定義のグラフィックスを作成、編集します。結果値は、リテラル文字列としてツールに挿入されます。

フィールド化することにより、文字列が正しいかどうか検証・訂正し、最もマッチする有効な文字列セットを返すことができます。フィールド化には主に 2 つの使用方法があります。

  • OCR 結果の検証。フィールド文字列およびフィールド定義パラメータに基づき、返された文字列が正しいかどうかを決定します。
  • OCR 結果の訂正。返された文字列が許容可能な結果リストにない場合、フィールド化によって許容された、返された文字列に一番近い文字列の検出を試みます。

フィールド化の一般的なユーザケースは、文字列に接頭辞/接尾辞が含まれる場合です。フィールドを使用して、これらの接頭辞/接尾辞を無視します。この場合、フィールド文字列およびフィールド定義は領域内の文字列ポジションオフセットを決定します。

Closed フィールド文字列

文字列に含まれる文字数を指定します。フィールド文字列エントリには、(A～Z)、(a～z)、(0～9)、ハイフン (-) 、ドット (.) 、スペース ( ) など、[テキスト入力] ダイアログのすべての文字を使用できます。

フィールド文字列の各文字は、0～31 のインデックス付きポジションに対応します。フィールド文字列には、最低でも、文字列中の文字のポジション数と同じ数の文字が含まれていないと、PASS 結果は得られません。例えば、文字列に 10 個の文字があり、フィールド文字列が 9 文字のみ指定している場合、1 番マッチする 9 個の文字が返されます。反対に、文字列に 8 個の文字があり、フィールド文字列が 9 文字を指定している場合、#ERR が返されます。デフォルトでは、フィールド文字列の各ポジションは、アスタリスク (*) 、つまり英数字の「ワイルドカード」で示されます。これは、文字列のそのポジションではすべての文字が有効であることを意味します。

ただし、フィールド文字列の個別の位置は、その位置に一部の文字しか想定されないように制限することができます。すると、対象外の文字は読み取り時に考慮されないため、全体的な性能と信頼性が向上します。

定義済みのフィールド文字列エントリは、次のとおりです。

フィールド文字列 エントリ | 説明 | 有効な文字
* | ワイルドカード | Any trained character in the font.
N | 数字 | 0123456789
A | 大文字の英字 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小文字の英字 | abcdefghijklmnopqrstuvwxyz
H | 16 進値 (大文字の英字と数字) | 0123456789ABCDEF
h | 16 進値 (小文字の英字と数字) | 0123456789abcdef
O | 8 進値 | 01234567

注:

  • フィールド文字列のある位置を特定の文字に制限する場合は、その文字を入力してください。文字はフォントに登録されている必要があります。また、「フィールド定義」パラメータを使用して再割り当てしない限り、上記の定義済みフィールド文字列エントリの文字を使用することはできません。
  • スペースを含む文字列を読み取るには、フィールド文字列にスペースを含めます。その位置の対応するフィールド文字列エントリがアスタリスク (*) の場合、ReadText 関数はスペースを読み取りません。
Closed フィールド文字列の例 1

フィールド文字列が「**********AN」の場合、1～10 番目のフィールド文字列位置ではフォントに含まれるすべての文字が有効です。ただし、11 番目の位置は、読み取り時に大文字の英字だけが想定されます。また、12 番目の位置は、数字だけが想定されます。

Closed フィールド文字列の例 2

フォントには、0～9 の数字と / だけが含まれます。フィールド文字列が「NN/NN/NN」の場合、1、2、4、5、7、および 8 番目の位置では数字だけが想定されています。また、3 および 6 番目の位置ではスラッシュ (/) だけが想定されています。

ただし、フィールド文字列が「NN/NN/AA」の場合は、フォントに英字が含まれていないため、#ERR が返されます。

Closed フィールド化していない文字を無視

各文字ポジションにおいて、文字のフィールド化で指定した文字のみ含むよう、結果を制限するかどうかを指定します。ON にすると、分類化得点にかかわらず、フォント内のすべてのほかの文字を無視します。

Closed フィールド定義

必要に応じて、フィールド文字列のユーザ定義エントリを作成するためにフィールド定義設定を使用できます。このエントリをフィールド文字列に入力すると、その位置の読み取り対象文字が、定義リストに含まれる文字のみに限定されます。システム定義のフィールド定義の他に、ユーザ定義のフィールド定義も追加することができます。システム定義のフィールド定義は、グレーのテキストで表示され、削除したり、編集したりすることはできません。有効にしたり、無効にしたりすることのみ可能です。ユーザ定義のフィールド定義は、黒のテキストで表示され、追加したり、削除したり、または編集したりすることができます。フィールド定義を追加するには、[新規追加] ボタンを押して、その文字のアイコンを割り当ててから、定義を割りててください。

フィールド定義エントリのために示す文字は、フォントに含まれている必要があります。例えば、#=123 は、ユーザ登録フォントに 1、2、3 が含まれる場合に有効です。ただし、#=123 は、フォントに 1、2、3 が含まれない場合は無効です。

注: 定義済みのエントリ (*, A, a, N, H, h, O) をフィールド定義パラメータで使用すると、新しい定義で有効な文字のリストが再割り当てされます。

Closed フィールド定義の例 1

フィールド定義の値が「#=123;$=3456;%=789」でフィールド文字列が「#$%*******」の場合、1 番目の位置では 1、2、または 3 だけが、2 番目の位置では 3、4、5、または 6 だけが、3 番目の位置では 7、8、または 9 だけが有効です。また、4～10 番目の位置ではフォントに含まれるすべての文字が有効です。

Closed フィールド定義の例 2

フィールド定義の値が「#=123;$=3456;%=789, A=A」でフィールド文字列が「#$%******A」の場合、1 番目の位置では 1、2、または 3 だけが、2 番目の位置では 3、4、5、または 6 だけが、3 番目の位置では 7、8、または 9 だけが有効です。また、4～9 番目の位置ではフォントに含まれるすべての文字が有効です。フィールド定義「A=A」は定義済みのフィールド文字列エントリを再割り当てするため、10 番目の位置では A だけが想定されています。


Read Text (OCRMax) Identification Tool - Diagnostics Tab

[診断] タブ (文字認識 (OCRMax) 識別ツール)

文字認識 (OCRMax) ツールが、領域内でどのようにセグメント化されているかについての情報を表示します。このデータは、どのパラメータをどの程度調整するか、文字や文字フラグメントが正しくセグメントされているかどうかを判断するのに有用です。診断データのグラフィックス表示方法を設定する [診断の表示] パラメータとともに、このタブを使用してください。

Closed メインライン角度

領域を基準にして、文字領域の角度値を度数で表示します。

Closed 文字スキュー

領域を基準にして、文字領域のスキュー角度値を度数で表示します。

Closed 文字間ギャップ

文字間ギャップの最小および最大値をピクセル単位で表示します。

Closed 文字内ギャップ

文字内ギャップの最小および最大値をピクセル単位で表示します。

Closed 文字ピッチ

文字の最小および最大ピッチ値をピクセル単位で表示します。

Closed 合格フラグメントのサイズ

合格フラグメントの最小および最大サイズをピクセル単位で表示します。

Closed 合格フラグメントのコントラスト

合格フラグメントの最小および最大コントラスト値をピクセル単位で表示します。

Closed 合格フラグメントのメインラインまでの距離 (%)

すべての合格フラグメントの最大 Y 距離を、メインラインの高さのパーセンテージとして表示します。

Closed 除外したフラグメントのサイズ

除外したフラグメントの最小および最大サイズをピクセル単位で表示します。

Closed 除外したフラグメントのコントラスト

除外したフラグメントの最小および最大コントラスト値をピクセル単位で表示します。

Closed 除外したフラグメントのメインラインまでの距離 (%)

すべての除外したフラグメントの最大 Y 距離を、メインラインの高さのパーセンテージとして表示します。

Closed 合格した文字の幅

合格した文字の最小および最大幅をピクセル単位で表示します。

Closed 合格した文字の高さ

合格した文字の最小および最大の高さをピクセル単位で表示します。

Closed 合格した文字のサイズ

合格した文字の最小および最大サイズをピクセル単位で表示します。

Closed 除外した文字の幅

除外した文字の最小および最大幅をピクセル単位で表示します。

注: 除外した文字がない場合、#ERR が表示されます。

Closed 除外した文字の高さ

除外した文字の最小および最大の高さをピクセル単位で表示します。

注: 除外した文字がない場合、#ERR が表示されます。

Closed 除外した文字のサイズ

除外した文字の最小および最大サイズをピクセル単位で表示します。

注: 除外した文字がない場合、#ERR が表示されます。


[結果] タブ (文字認識 (OCRMax) 識別ツール)

Closed 文字

そのポジションで読み取った文字を表示します。

Closed ステータス

読み取った文字のステータス ([読み取り (Bad)]、[読み取り (Good)]、[無視]、[コンフュージョン]、[ミスマッチ]、[コンフュージョンミスマッチ] または [検証失敗]) を返します。

  • [読み取り (Bad)]: 読み取り成功とみなす、[アクセプトしきい値] を上回る得点を獲得した文字がない場合に返されます。
  • [読み取り (Good)]: このポジションの文字の読み取りに成功した場合に返されます。
  • [無視]: フィールドを有効にしたときに、読み取った文字列がフィールド文字列で指定した文字数より短い場合、文字列の最初または最後の文字は (黄色で) セグメント化されますが、全体の結果には含まれません。例えば、フィールド定義が ABC で、読み取った文字列が「12ABC34」の場合、「1234」は無視されます。
  • [コンフュージョン]: 読み取り成功 (得点が [アクセプトしきい値] パラメータを上回る) に十分な高得点の文字を識別しましたが、他の文字もほぼ同じスコア ([コンフュージョンしきい値] 内) を得点したため、正しい文字を選択したかどうか、確信が持てない場合に返されます。[コンフュージョン = (最高得点 - 2 番目に高い得点)/信頼性しきい値]
  • [ミスマッチ]: フィールド化に一致しない文字を検出しましたが、その文字がフィールド化に一致しない文字より高い得点を獲得している場合に返されます。フィールド化に一致しない文字がこのポジションに印刷されている可能性が高いです。[フィールド化] タブを有効にしたときのみ、このステータスが返されます。
  • [コンフュージョンミスマッチ]: [コンフュージョン] および [ミスマッチ] の両方の条件を満たす文字を検出したときに返されます。
  • [検証失敗]: [追加の文字検証をスキップ] パラメータを無効にした場合に、追加の検証ステップを使用して文字を解析しますが、その検証に失敗した場合に返されます。
Closed 得点

読み取った文字が、フォントデータベース内の登録文字にどれだけマッチしているか、その得点を返します。

Closed コンフュージョン

2 番目にマッチする文字を返します。

Closed コンフュージョン得点

2 番目にマッチする文字と比較して、選択したマッチがどれだけ信頼性があるかを返します。


文字認識 (OCRMax) 識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 浮動小数点 | X | X | 入出力
角度範囲 | 浮動小数点 | X | X | 入出力
2 値化しきい値 | 整数 | X | X | 入出力
文字フラグメントの コントラストしきい値 | 浮動小数点 | X | X | 入出力
文字フラグメント マージモード | 整数 | X | X | 入出力
文字ラベル位置 | 整数 | X | X | 入出力
文字ピッチ位置 | 整数 | X | X | 入出力
文字のピッチタイプ | 整数 | X | X | 入出力
文字の極性 | 整数 | X | X | 入出力
文字幅のタイプ | 整数 | X | X | 入出力
フォントをクリア | 動作 | X | X |
コンフュージョン しきい値 | 浮動小数点 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エラー_数 | 整数 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
外部クリア | 整数 | X | X | 入出力
外部登録 | 整数 | X | X | 入出力
FAIL | 整数 | X | X | 出力
FAIL_数 | 整数 | X | X | 出力
フィールド定義 | 文字列 | X | X | 入出力
フィールド文字列 | 文字列 | X | X | 入出力
スペースの検出 | 整数 | X | X | 入出力
フォントライブラリ | 整数 | X | X | 入出力
境界フラグメントを無視 | 整数 | X | X | 入出力
フィールド化していない 文字を無視 | 整数 | X | X | 入出力
総合判定に含める | 整数 | X | X | 入出力
検査モード | 整数 | X | X | 入出力
マッチ文字列 | 文字列 | X | X | 入出力
最大文字内ギャップ値 | 整数 | X | X | 入出力
文字の高さの最大値 | 整数 | X | X | 入出力
文字幅の最大値 | 整数 | X | X | 入出力
メインラインまでの 最大フラグメント距離 | 浮動小数点 | X | X | 入出力
最後にフィールド化した 最大インデックス値 | 整数 | X | X | 入出力
最大文字列長 | 整数 | X | X | 入出力
最小文字間ギャップ値 | 整数 | X | X | 入出力
最小文字アスペクト比 | 整数 | X | X | 入出力
文字フラグメントの 最小オーバラップ値 | 浮動小数点 | X | X | 入出力
文字の高さの最小値 | 整数 | X | X | 入出力
最小文字サイズ | 整数 | X | X | 入出力
文字幅の最小値 | 整数 | X | X | 入出力
最初にフィールド化した 最小インデックス値 | 整数 | X | X | 入出力
最小ピッチ値 | 整数 | X | X | 入出力
最小文字列長 | 整数 | X | X | 入出力
正規化モード | 整数 | X | X | 入出力
OCRMax | 文字列 | X | X | 出力
出力画像グラフィックス | 整数 | X | X | 入出力
PASS | 整数 | X | X | 出力
PASS_数 | 整数 | X | X | 出力
領域 | 動作 | X | X |
結果長 | 整数 | X | X | 出力
セグメント解析モード | 整数 | X | X | 入出力
スキュー幅 | 浮動小数点 | X | X | 入出力
スペース最大幅 | 整数 | X | X | 入出力
スペース最小幅 | 整数 | X | X | 入出力
スペース得点モード | 整数 | X | X | 入出力
ステータス | 整数 | X | X | 出力
文字列 | 文字列 | X | X | 出力
文字列長 | 整数 | X | X | 入出力
タイムアウト | 整数 | X | X | 入出力
ツール有効 | 整数 | X | X | 入出力
ツール有効ステータス | 整数 | X | X | 出力
登録 | 動作 | X | X |
登録ダイアログ | 文字列 |  | X | 出力
登録モード | 整数 | X | X | 入出力
登録文字列 | 文字列 | X | X | 入出力
文字の高さの 最大値を使用 | 整数 | X | X | 入出力
文字幅の 最大値を使用 | 整数 | X | X | 入出力
最小文字 アスペクト比を使用 | 整数 | X | X | 入出力
ストローク幅 フィルタを使用 | 整数 | X | X | 入出力
サブサンプリング を使用 | 整数 | X | X | 入出力

注: VisionView® アプリケーションの登録ダイアログプロパティにアクセスしている場合、データタイプが文字列であってもボタンとして表示されます。


文字認識識別ツール

文字認識識別ツールは、登録済みの文字モデルを基に、英数文字列の照合/認識に使用されます。

注: In-Sight Explorer 4.7.0 以降では、文字認識識別ツールは OCRMax をサポートしない In-Sight ビジョンシステムでのみ使用できます。また、In-Sight ファームウェア 5.1.0 以降ではサポートされていません。

  1. 文字認識識別ツールを設定するには
    1. 認識させる文字を選択するには
  2. 文字認識識別ツールのパラメータを調整するには
  3. 文字認識識別ツールの入出力プロパティを使用するには


文字認識識別ツールを設定するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. 文字全体を囲むように領域を配置します (認識させる文字を選択するにはトピックを参考にしてください)。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけツールの実行時間が増大します。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. [設定] タブの [モード] (選択肢は、[読み取り]、[照合] または [認識と照合]) 、[フォント] (選択肢は、[OCR-A 白地に黒]、[OCR-A 黒地に白]、[OCR-B 白地に黒]、[OCR-B 黒地に白] または [カスタム]) 、および [フィールド文字列] または [マッチ文字列] の文字数を定義してください ([モード] によってどちらの文字数を指定するかが決まります)。
  • [モード] で [読み取り] を選択し、OCR-A または OCR-B フォントを選択した場合、[フィールド文字列] の文字数を指定してから [チューニング] を押してスケールを設定します。
  • [モード] で [照合] または [認識と照合] を選択し、OCR-A または OCR-B フォントを選択した場合、[マッチ文字列] の文字を指定してから[チューニング] を押してスケールを設定します。

注: OCR-A または OCR-B フォントを使用している場合、画像中の文字は 15～60 ピクセルである必要があります。[チューニング] ボタンを押して、文字スケールを正しく設定してください。 文字が 15 ピクセル以下の場合、または 60 ピクセル以上の場合、カスタムフォントを作成する必要があります。

  • [フォント] で [カスタム] を選択した場合、[フォントの登録] ボタンを押して、フォントライブラリを作成してください。 その後、[モード] [読み取り] を選択した場合、[フィールド文字列] の文字数を指定し、[照合] または [認識と照合] を選択した場合には [マッチ文字列] の文字を指定します。
  • 1 つのジョブ内で、4 つまでのカスタムフォント (例: Custom_1～4) を使用することができます。また、ジョブに登録されたカスタムフォントは、他の文字認識識別ツールと共有することができます。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カスタムフォントを作成するには

  1. カスタムフォントを設定するには、[設定] タブをクリックし、[フォントの登録] ボタンを押します。[OCV/OCR フォントの登録] ダイアログが開き、アプリケーションに合わせて文字を設定することができます。

注: 1 つのジョブ内で、4 つまでのカスタムフォント (例: Custom_1～4) を使用することができます。

  2. [登録] タブで、フォントに名前を付けることができます。複数のフォントライブラリがある場合、この機能は有用です。
  3. 文字の [極性] を設定します。登録する文字が周囲の背景よりも明るい場合は、[極性] として [白 (黒い背景) ] を選択します。登録する文字が周囲の背景よりも暗い場合は、[黒 (白い背景) ] を選択します。

注: [フォントの追加] をクリックする前に、登録する文字の極性が正しく設定されていることを確認してください。文字モデルをフォントに追加した後に極性を変更することはできません。

  4. 識別されるべき文字列を定義します。 識別される文字列はモデル文字と大文字または小文字までマッチするようにしてください。モデル文字にスペースがある場合、識別される文字列にもスペースを入れてください。
  5. 文字列を入力したら、[セグメント] ボタンをクリックします。 各文字には個別の領域と識別子が含まれるようにしてください。含まれない場合は、[セグメントの調整] を使用して次の作業を行ってください。
  • [修正] ボタンを押して、個々のインスタンスを囲む領域を変更します。
  • [ラベルの変更] ボタンを押して、文字インスタンスに新しい名前を割り当てます。
  • [削除] ボタンを押して、文字インスタンスを削除します。
  6. 画像内の文字の識別に問題がなければ、[フォントの追加] ボタンをクリックします。 識別された各文字のインスタンスがユーザフォントとして登録されます。
  7. ユーザフォントにはいくつかの文字モデルが含まれています。いくつかのモデルは、複数のインスタンスにより構成されています。スペースや句読点を含むすべての文字が切り出され、文字モデルとして登録されます。
  8. ここで、すべての文字モデルを参照して、特定のモデルまたはインスタンスの追加、削除、編集、名前変更、または有効化/無効化を行うことが可能です。

注: ジョブに登録されたカスタムフォントは、他の文字認識識別ツールと共有することができます。

  9. 登録されたフォントに問題がなければ、[OK] ボタンを押してください。


認識させる文字を選択するには

一貫した結果を得るために、次のガイドラインを参考にしてください。

Closed フォント
  • OCR/OCV アプリケーション専用にデザインされた特殊フォントを使用してください。
  • 文字のストローク幅が 5 ピクセル以上あるようにしてください。文字ができるだけ画像を満たすようにしてください。文字のピクセル数が多いほどツールの正確性が高まるが、実行時間は増大します。
  • 画像中に複数のフォントタイプが存在する場合、各フォントタイプごとに異なる文字認識識別ツールを使用してください。
  • 画像中に複数のフォントサイズが存在する場合、各フォントサイズごとに異なる文字認識識別ツールを使用してください。
Closed OCR/OCV 専用特殊フォント

Closed 文字モデルとインスタンス
  • 明瞭かつ特徴ある文字モデルを作成するために、高解析度の文字を使用するしてください。
  • 各文字認識識別ツールは最大 255 種類の文字モデルをサポートし、各文字モデルは最大 8 種類までの登録済みインスタンスから作られています。文字モデルのインスタンスを追加登録すると、文字モデルの変化の許容値は増大します。アプリケーションの変化の許容値が低い場合、高品質の文字モデル 1 つのみを登録してください。アプリケーションの変化の許容値が高い場合、できるだけ多くのインスタンスを文字モデルとして登録してください。
  • 文字モデルの登録の際には、印字にできるだけ一貫性があるようにしてください。文字の形やサイズが大幅に変化すると、悪い文字モデルとなりジョブの実行時に FAIL となります。
Closed 登録インスタンス例

良い登録インスタンス

悪い登録インスタンス


文字認識識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

文字認識識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 文字モデルテーブル

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (文字認識識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は文字_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (文字認識識別ツール)

Closed フォントの登録

[OCV/OCR フォントの登録] ダイアログが開き、フォント (文字モデルおよびそのインスタンス) の定義や編集を行うことができます。

Closed モード

ツールのモードを指定します。選択肢は、[読み取り]、[照合]、または [認識と照合] です。

  • [読み取り]: 登録済みの文字モデルを基に、文字列をデコードします。デコードされた文字列は、[フィールド文字列] で定義された文字数にマッチする必要があります。
  • [照合]: [マッチ文字列] で定義された文字列を基に、文字列をデコードします。
  • [認識と照合]: 文字列をデコードし、[マッチ文字列] で定義された文字列とデコードされた文字列を比較します。PASS の結果を得るためには、デコードされた文字列は、[マッチ文字列] で定義された文字列と合致している必要があります。

注: このツールには、PASS と FAIL の 2 つのステータスしかありません。したがって、ツールの [モード] コントロールを [照合] または [認識と照合] に設定している際に FAIL が返される場合、2 つのシナリオが考えられます。1 つは、読み取りに失敗した場合、もう 1 つは、読み取りには成功したものの、[マッチ文字列] パラメータに入力した文字列と一致しない場合です。

後者の場合、[認識と照合] が選択されている時に、ツールはミスマッチデータ ([ミスマッチ] および [ミスマッチ数]) を出力します。このデータは、EasyView および [通信] アプリケーションステップの他のコミュニケーションデバイスで使用することができます。ミスマッチデータは、[EasyView アイテムの選択]、[OPC タグの選択] または [入力/出力データ] ダイアログから選択することができます。

ミスマッチデータは、ツールがコードの読み取りに失敗したのか、それとも、コードの読み取りに成功したものの、文字列が [マッチ文字列] で定義した情報と一致しないのかを決定する必要がある場合に有用です。例えば、ツールが文字列の読み取りに失敗した場合、文字列印刷のプロセスやビジョンシステムのセットアップに問題がある可能性があります。文字列の読み取りに成功したものの、[マッチ文字列] で定義した情報に一致しない場合、異なる文字列が印刷されている可能性があります。

Closed フォント

フォントのタイプを定義します。 定義済みのフォントタイプ (OCR-A/OCR-B、白地に黒/黒地に白) から選択するか、あるいは文字モデルを登録することによってカスタムフォントを作成することができます。

注: 1 つのジョブ内で、4 つまでのカスタムフォント (例: Custom_1～4) を使用することができます。

Closed フィールド文字列

[読み取り] モードを選択した際に、文字列に含まれる文字数を定義します。フィールド文字列の各文字は、0～31 のインデックス付きポジションに対応します。フィールド文字列には、文字列の文字と同じ数のポジションが含まれている必要があります。

フィールド文字列エントリには、(A～Z)、(a～z)、(0～9)、ハイフン (-) 、ドット (.) 、スペース ( ) を使用することができます。デフォルトでは、フィールド文字列の各ポジションは、アスタリスク (*) 、つまり英数字の「ワイルドカード」で示されます。これは、文字列のそのポジションではすべての文字が有効であることを意味します。

フィールド文字列の個別のポジションは、そのポジションに一部の文字しか想定されないように制限することができます。これにより、全体的な性能と信頼性が向上します。

フィールド文字列 エントリ | 説明 | 有効な文字
* | ワイルドカード | フォントに含まれる任意の登録文字です。
N | 数字 | 0123456789
A | 大文字の英字 | ABCDEFGHIJKLMNOPQRSTUVWXYZ
a | 小文字の英字 | abcdefghijklmnopqrstuvwxyz
H | 16 進値 (大文字の英字と数字) | 0123456789ABCDEF
h | 16 進値 (小文字の英字と数字) | 0123456789abcdef
O | 8 進値 | 01234567
Closed マッチ文字列

読み取りされる文字列を定義します。[モード] で、[照合] または [認識と照合] が選択された場合のみに有効となります。デコードする情報を入力してください。

注: マッチ文字列は他のデバイスから入力されることがあります。ジョブの実行時に、識別ツールを使用して入力デバイスからの文字列を読み取って、認識済みの ID コードと比較することができます。マッチ文字列が外部デバイスから入力されるまで、文字認識ツールの結果は FAIL となり、[マッチ文字列] には TRIG　が表示されます。

Closed [チューニング] ボタン

フォントライブラリ登録済み文字モデルと画像中の文字間のスケール差 (50～200%) を計算します。[チューニング] ボタンは、文字モデルと文字列の文字間のサイズ差が ±5% 以上の場合のみ使用してください。

Closed アクセプトしきい値

文字列中の各文字のスコアを 0～100 で定義します。デフォルトは 70 です。この設定以下の文字が 1 つでも文字列に含まれると、文字列全体の結果は FAIL となります。

Closed モードの読み取り

文字列を読み取る際のアルゴリズムモードを定義します。選択肢は、[高速モード] (デフォルト) および [高精度モード] です。[高速モード] は、鮮明で高コントラストの画像を使用して、ツールを高速処理する必要がある場合に有用です。[高精度モード] は、不鮮明で低コントラストの画像を使用して、ツールの処理時間が問題とならない場合に有用です。

Closed 得点差しきい値

1 番得点の高い文字と 2 番目の得点の文字間の得点差を 0～20 で定義します。デフォルトは 0 です。 得点差が指定の値と同じ、またはそれ以下の場合、文字列全体の結果は FAIL となります。

Closed 擬似背景

画像内のそのほかの特徴が、文字列と判別しにくい場合に補正を行います。デフォルトは OFF です。 [擬似背景] を ON にした場合、ツールの処理速度は遅くなります。領域内のほかの特徴が文字列の先頭と誤って認識されてしまう場合に有用です。

Closed スケール許容

文字スケールのばらつきを許容します。デフォルトは OFF です。

領域内のほかの特徴が文字列の先頭と誤って認識されてしまう場合に有用です。

Closed タイムアウト

ツールがテキストをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed 結果

デコード、または検証された文字列情報を表示します。


文字モデルテーブル (文字認識識別ツール)

Closed インデックス

文字列の文字ポジションを表示します。

Closed 文字

最高得点の文字モデルを表示します。つまり、文字列の文字に一番マッチする文字モデルが表示されます。

Closed 得点

最高得点の文字モデルにおける信頼性得点を表示します。[設定] タブの [アクセプトしきい値] より低い値が返された場合、文字列全体の結果は FAIL となります。

Closed 合格

結果の PASS/FAIL を表示します。[得点] および [得点差] の値が、[設定] タブの [アクセプトしきい値] および [得点差しきい値] と同等または下の場合は FAIL を、上の場合は PASS を返します。

Closed 第 2 候補文字

2 番目に高い得点の文字モデルを表示します。つまり、文字列の文字に二番目にマッチする文字モデルが表示されます。

Closed 第 2 候補得点

2 番目に高い得点の文字モデルにおける信頼性得点を表示します。

Closed 得点差

最高得点と 2 番目に高い得点の間の差を表示します。この値が [得点差しきい値] と同等または下の場合は、文字列全体の結果は　FAIL となります。


文字認識識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
議事背景 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
得点差しきい値 | 整数値 | X | X | 入出力
フィールド文字列 | 文字列 | X | X | 入出力
文字列 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
マッチ文字列 | 文字列 | X | X | 入出力
モード | 整数値 | X | X | 入出力
読み取りモード | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ミスマッチ | 浮動小数点 | X | X | 出力
マッチ数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |
チューニング | 動作 | X | X |


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール

注:
  • In-Sight ファームウェア 5.5.0 以降、ツールのアルゴリズムが変更され、条件によっては、より正確な結果を返すようになり、実行時間が短縮されました。
  • この変更により、In-Sight ファームウェア 5.5.0 以降で作成されたこのツールを含むジョブを、ファームウェアバージョン 5.4.x 以前を搭載した In-Sight ビジョンシステムにロードしようとすると、エラーメッセージが表示されます。
  • PatMax RedLine パターン識別ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターンおよび PatMax パターン識別ツールは、PatMax RedLine または PatMax アルゴリズムを使用して、パターンの特徴を登録し、画像中に抽出した特定のパターンの特徴を検証または識別するのに使用されます。

これらのツールは、ロゴやラベル、部品を基に、製造ライン上に正しい製品が流れていることを確認したり、他の生産現場のデバイスに、認識した製品の情報を通信したりするアプリケーションにおいて有用です。

  1. PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールを設定するには
    1. PatMax RedLine パターン、PatMax パターンおよびパターン
    2. パターンを選択するには
  2. PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールのパラメータを調整するには
  3. PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールの入出力プロパティを使用するには


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールは、最大 10 までのモデルパターンのライブラリを作成することができます。各モデルパターンは、それぞれ別のパターンを使用して登録する必要があります。ツールは、登録済みパターンから個々のインスタンスをサーチします。1 つの画像から複数のインスタンスを認識することはできません。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 登録するパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [サーチ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。パターンの出現する可能性がある場所をサーチ領域で囲みます。処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

  3. [OK] ボタンを押し、領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。モデル領域の色が変わり、定義済みを表す緑色に提示されます。

  4. 2 番目のモデルパターンを定義するには、新しいパターンが存在する新しい画像をロードするか取り込んでください。テーブルから未登録のパターンを選択し ([登録済み] 列に [未登録] と表示されています)、[モデル領域] ボタンをクリックし、1～3 までのステップを繰り返してください。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


PatMax RedLine パターン、PatMax パターンおよびパターン

注:PatMax RedLine パターン識別ツールは、In-Sight ファームウェア 5.2.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

PatMax RedLine パターン、PatMax パターンおよびパターンツールは、どちらも登録済みのモデルパターンを検出する、最も高精度な検査ツールです。中でも PatMax RedLine パターンおよび PatMax パターンツールは、照明の条件やパターンのポジションが大幅に変わっても特徴を検出できるため、より強力な検査ツールと言えます。PatMax RedLine パターンおよび PatMax パターンツールは、スケール変化、回転、部分的な遮蔽、照明のばらつきによる外観変化に対しても、より優れた認識能力を発揮します。

PatMax RedLine パターンと PatMax パターンの主な違いはそのスピードにあります。PatMax RedLine パターンは最新のパターンマッチアルゴリズムを使用し、5 メガピクセルの画像内の登録した特徴を PatMax パターンの最大 7 倍の速さで検出します。よって、PatMax RedLine パターンは高解像度のビジョンシステムに最適と言えます。

通常、パターンツールは PatMax パターンツールより高速に動作します。しかし、次のような状況では PatMax RedLine または PatMax パターンツールの正確性および信頼性が必要とされる場合があります。

  • 照明のばらつきや反射の抑制が困難な場合 (例: 光を乱反射しやすい金属物を検査する場合)。
  • 検査対象物に似た形状やシェーディングが背景上にある場合、またはパターンが重なっていたり、他の物体によって部分的に隠蔽されていたりする場合。
  • 他の類似したパターンを除外し、目的の検査パターンを正確に検出したい場合。
  • 設置環境の状態によって、パターンツールでは一貫した信頼性のある検査を実行できない場合。


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [モデル] および [サーチ] タブ
  • テーブル

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 計数ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は品種 ID_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール)

Closed モード

ツールのモードを定義します。選択肢は、[識別] または [照合] です。

[識別] (デフォルト) は、検査するパターンが未知の場合に使用されます。ツールは領域に基づいて画像を自動的に検査し、登録済みパターンライブラリからどのパターンが表示されているかを判断し、その情報を [結果] パラメータに返します。

[照合] は、正しいパターンが存在する場合に使用されます。ツールは指定のパターンをサーチして、検出されたパターンと [パターン] パラメータで指定されたパターンを比較します。

Closed パターン

照合する登録パターンを定義します。この設定を有効にするには、[モード] から [照合] を選択する必要があります。登録済みのパターンから選択してください。

Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 65 です。この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed コントラストしきい値

検出パターンに存在する必要のある、最小コントラスト値を指定します。有効なインスタンスとみなすには、検出パターンのコントラストが [コントラストしきい値] より高い必要があります。PatMax RedLine パターンではデフォルト = 0、有効なパラメータ範囲は 0～100 です。PatMax パターンではデフォルト = 10、有効なパラメータ範囲は 0～255 です。低コントラストの画像には、低いコントラストしきい値が使用され、高コントラストの画像には、高いコントラストしきい値が使用されます。

注: PatMax RedLine パターンでは、登録パターン内の特徴とサーチ画像内のマッチする特徴との間のコントラスト差をパーセンテージで表した、「相対」コントラストが報告されます。よって、特徴のコントラストがパターンコントラストと同じまたはより高い場合、報告されるコントラストは ~100 となります。特徴のコントラストがパターンコントラストより低い場合、報告されるコントラストは <100 となります。PatMax RedLine パターンのコントラストは PatMax パターンのコントラストは異なります。PatMax パターンでは、サーチ ROI 内の「絶対」画像コントラストがグレースケール値で報告されます。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

モデルパターンの大きさを基準とした、検出パターンで許容されるスケール変化量を指定します (0～50、デフォルトは 0% です)。この値を 5 に設定すると、モデルの大きさに対して 95～105% のサイズのパターンが検出対象となります。大きな値を設定すると、ツールの実行時間が増大します。

Closed 得点差しきい値

検出されたパターンと任意の登録済みモデルパターンの得点差を 0～20 で定義します。デフォルトは 0 です。この値は、任意の 2 つの登録モデルパターンの間の得点差です。つまり、得点差しきい値が 5 の場合、他のモデルパターンより 5 得点以上のパターンを検出します。

Closed 検出モード

パターンの登録および認識に使用されるサーチモードを指定します。選択肢は、[PatMax] (デフォルト) または [PatQuick] です。デフォルトでは、[PatMax] が選択されています。PatMax は、PatQuick より高精度ですが、実行時間が長くなります。一方、PatQuick は、PatMax より精度が低いですが、実行時間は短くなります。

Closed クラッタ

モデルパターンと比較して、検出パターンの欠落または遮蔽された特徴を得点に考慮するかどうかを定義します。デフォルトは OFF、すなわち欠落があっても得点は減点されません。クラッタを ON にすると、検出パターン中の特徴欠落によって得点が減点されます。

Closed タイムアウト
ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。デフォルトで、このパラメータは 1,000 に設定されています。
Closed 結果

識別されたパターンの名前を表示します。

注:PatMax RedLine パターンには、[検出モード] パラメータは含まれていません。


[モデル] および [サーチ] タブ (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール)

[モデル] および [サーチ] タブを使用して、ツールのモデルおよびサーチ領域の合成領域を設定します。 合成領域は、サブ領域 (矩形、円環、円またはポリゴン) の集合体で、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • [モデル] タブでは、[モデル領域] ボタンを押した後にのみ、合成領域を有効にすることができます。
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


テーブル (PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツール)

テーブルには、登録済みパターンテーブルおよび登録済みパターンのサムネイル画像が表示されます。

Closed テーブル

名前: 登録済みパターンの名前が表示されます。アプリケーションに合わせて、名前を変更することができます。

登録済み: パターンが登録済みかどうかを表示します。登録済みパターンの場合、[登録済み] が表示され、未登録の場合は [未登録] が表示されます。

得点: 検出された登録済みパターンの得点を表示します。

注:
  • パターンをツールから削除するには、テーブルタブ内のパターンを右クリックし、メニューから [削除] を選びます。
  • テーブルタブ表示には、[サムネイル表示]、[詳細表示] および [並べて表示]の 3 つのオプションがあります。設定ペインの異なる表示オプションを選択するには、テーブル内の任意の場所で右クリックし、[表示] サブメニューから使用するオプションを選択してください。
Closed [モデル領域] ボタン

パターンを登録します。

Closed [名前の変更] ボタン

テーブルの登録パターンを選択してからこのボタンを押すと、アプリケーションに合わせた名前に変更することができます。

Closed 登録画像のサムネイル

[モデル領域] ボタンの下に、モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


PatMax RedLine パターン (1-10) および PatMax パターン (1-10) 識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
コントラストしきい値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
得点差しきい値 | 整数値 | X | X | 入出力
検出モード1 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
モード | 整数値 | X | X | 入出力
パターン | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
クラッタ | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |
フィクスチャ1-9.角度2 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.得点2 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.X2 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.Y2 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.得点2 | 浮動小数点 | X | X | 出力
フィクスチャ1-9.検出2 | 浮動小数点 | X | X | 出力
1 Tこのツールプロパティは、PatMax パターン (1-10) 識別ツールでのみ使用可能です。 21 から 9 までのフィクスチャ出力 (フィクスチャ1、 フィクスチャ2、フィクスチャ3 など) のことです。


パターン (1-10) 識別ツール

パターン (1-10) 識別ツールは、パターン特徴のオカレンスを登録し、画像中のオカレンスを検証または識別するのに使用されます。

このツールは、ロゴやラベル、部品を基に、製造ライン上に正しい製品が流れていることを確認したり、他の生産現場のデバイスに、認識した製品の情報を通信したりするアプリケーションにおいて有用です。

  1. パターン (1-10) 識別ツールを設定するには
    1. PatMax パターン vs. パターン
    2. パターンを選択するには
  2. パターン (1-10) 識別ツールのパラメータを調整するには
  3. パターン (1-10) 識別ツールの入出力プロパティを使用するには


パターン (1-10) 識別ツールを設定するには

ツールを追加したら、パターン定義領域 (モデル領域) とパターン検出領域 (サーチ領域) を設定します。

パターン (1-10) 識別ツールは、最大 10 までのモデルパターンのライブラリを作成することができます。各モデルパターンは、それぞれ別のパターンを使用して登録する必要があります。ツールは、登録済みパターンから個々のインスタンスをサーチします。1 つの画像から複数のインスタンスを認識することはできません。

  1. 1 番目の登録モデルとして使用されるパターンを囲むようにモデル領域を配置します。モデル領域は、重要なパターン特徴のみ含めるようにしてください。
  2. パターンの出現する可能性がある場所をサーチ領域で囲みます。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。

注: モデルおよびサーチ領域は、円弧またはドーナツ状に曲げることはできません。

  3. [OK] ボタンを押し、領域を確定してください (ツールの追加を取りやめるには [キャンセル] ボタンを押します)。モデル領域の色が変わり、定義済みを表す緑色に提示されます。
  4. 2 番目のモデルパターンを定義するには、新しいパターンが存在する新しい画像をロードするか取り込んでください。テーブルから未登録のパターンを選択し ([登録済み] 列に [未登録] と表示されています) 、[モデル領域]　ボタンをクリックし、1～3　までのステップを繰り返してください。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


パターン (1-10) 識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

パターン (1-10) 識別ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (パターン (1-10) 識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名は品種 ID_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (パターン (1-10) 識別ツール)

Closed モード

ツールのモードを定義します。選択肢は、[識別] または [照合] です。

[識別] (デフォルト) は、検査するパターンが未知の場合に使用されます。ツールは領域に基づいて画像を自動的に検査し、登録済みパターンライブラリからどのパターンが表示されているかを判断し、その情報を [結果] パラメータに返します。

[照合] は、正しいパターンが存在する場合に使用されます。ツールは指定のパターンをサーチして、検出されたパターンと [パターン] パラメータで指定されたパターンを比較します。

Closed パターン

照合する登録パターンを定義します。この設定を有効にするには、[モード] から [照合] を選択する必要があります。登録済みのパターンから選択してください。

Closed アクセプトしきい値

検出パターンがモデルパターンに類似していなければならない度合いを 0～100 で定義します。デフォルトは 50 です。この設定値以上の類似度が検出時に得られた場合、マッチしていると判断されます。この設定値を大きくするとツールの実行時間を短縮することができますが、それだけ検出パターンはモデルパターンとの高い類似性が要求されます。設定値を小さくすると、モデルとは異なるパターンを誤検出するなど、不正確な結果を返す恐れがあります。

Closed 角度許容値

検出パターンが回転していても認識される許容角度 (0～±180 度) を指定します。デフォルトは 15 度です。大きな値を設定すると、ツールの実行時間が増大します。

Closed スケール許容

検出パターンのスケール変化 (±10% 以内) を許容するかどうかを指定します。デフォルトは OFF です。大きな値を設定すると、ツールの実行時間が増大します。スケール許容を ON にすると、±10% の範囲でパターンを検出しますが、スケール変化量が大きくなるほど、特徴の得点は低くなります。

Closed 得点差しきい値

検出されたパターンと任意の登録済みモデルパターンの得点差を 0～20 で定義します。デフォルトは 0 です。この値は、任意の 2 つの登録モデルパターンの間の得点差です。つまり、得点差しきい値が 5 の場合、他のモデルパターンより 5 得点以上のパターンを検出します。

Closed モデルタイプ

ツールが、どのようにモデルパターンを作成するかを定義します。選択肢は、[エリアモデル] または [エッジモデル] です。[エリアモデル] は、モデル領域からのグレースケース値の均一サンプリングに基づいてパターンを作成します。[エッジモデル] は、モデル領域内のパターンの検出エッジ (白/黒の遷移) に基づいて、モデルパターンを作成します。

Closed 高精度モード

ツールがどのように精度/信頼性と実行速度のトレードオフを評価するか定義します。選択肢は、[高精度]、[中程度] (デフォルト) および [高速] です。[高精度] は、精度/信頼性が高くなる反面、実行速度が遅くなります。[高速] は、実行速度が速くなる反面、精度/信頼性が低くなります。[中程度] は、その中間を取るように指定します。

Closed タイムアウト

ツールがパターンをサーチする時間をミリ秒単位で定義します (0～30,000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed 結果

識別されたパターンの名前を表示します。


テーブル (パターン (1-10) 識別ツール)

テーブルには、登録済みパターンテーブルおよび登録済みパターンのサムネイル画像が表示されます。

Closed テーブル

名前: 登録済みパターンの名前が表示されます。アプリケーションに合わせて、名前を変更することができます。

登録済み: パターンが登録済みかどうかを表示します。登録済みパターンの場合、[登録済み] が表示され、未登録の場合は [未登録] が表示されます。

得点: 検出された登録済みパターンの得点を表示します。

注:
  • パターンをツールから削除するには、テーブルタブ内のパターンを右クリックし、メニューから [削除] を選びます。
  • テーブルタブ表示には、[サムネイル表示]、[詳細表示] および [並べて表示]の 3 つのオプションがあります。設定ペインの異なる表示オプションを選択するには、テーブル内の任意の場所で右クリックし、[表示] サブメニューから使用するオプションを選択してください。
Closed [モデル領域] ボタン

パターンを登録します。

Closed [名前の変更] ボタン

テーブルの登録パターンを選択してからこのボタンを押すと、アプリケーションに合わせた名前に変更することができます。

Closed 登録画像のサムネイル

モデルパターンのサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


パターン (1-10) 識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
アクセプトしきい値 | 整数値 | X | X | 入出力
高精度モード | 整数値 | X | X | 入出力
角度許容値 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
得点差しきい値 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
モード | 整数値 | X | X | 入出力
モデルタイプ | 整数値 | X | X | 入出力
パターン | 整数値 | X | X | 入出力
スケール許容 | 整数値 | X | X | 入出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
モデル | 動作 | X | X |
サーチ | 動作 | X | X |


カラーモデル識別ツール

カラーモデル識別ツールは、カラーモデルライブラリ中のどのカラーモデルが、画像中の色に一番マッチするかを決定し、そのカラーモデルの名前を返します。

カラーモデルツールは、登録済みのカラーモデルライブラリを参照し、ライブラリ内の選択した登録済みカラーモデルにマッチする、領域内のピクセル数を決定します。ツールのモード (デフォルト設定の[識別] または [マッチ]) に基づき、検査基準に最もマッチするカラーモデルの名前を返します。また、ツールは、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、二値化グレースケール出力画像を生成します。

  1. カラーモデル識別ツールを設定するには
  2. カラーモデル識別ツールのパラメータを調整するには
  3. カラーモデル識別ツールの入出力プロパティを使用するには


カラーモデル識別ツールを設定するには

ツールを追加したら、領域のタイプを選択し、画像を設定します。

  1. [モデル] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 カラー全体を囲むように領域を配置、設定します。 処理時間を短縮するため、サーチ領域のサイズをなるべく小さくすることを推奨します。サーチ領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、そのカラーがすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、カラーが移動しても十分にカバーできる大きさに領域を設定してください。

    注:ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブに戻り [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーモデル識別ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーモデル識別ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
  • ライブラリ
  • [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーモデル識別ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はカラーモデル識別_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーモデル識別ツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール
Closed モード

ツールのモードを定義します。選択肢は、[識別] または [マッチ] です。

  • [識別]: 画像内のカラーが不明な場合に使用します。このツールは、どのカラーモデルが画像中の色に一番マッチするかを決定します。選択したカラーライブラリに有効なカラーモデルが複数ある場合、そのピクセル数に基づき結果を順番付けし、ランクを決定します。
  • [マッチ]: 指定したカラーモデルが画像に存在するかを検証します。このツールは画像を処理し、画像内のカラーが [マッチカラー] パラメータで指定したカラーモデルと一致するかどうかを決定します。
Closed マッチカラー

検出されるカラーモデルを指定します。このフィールドは、[モード] パラメータを [マッチ] に設定した場合にのみ有効となります。検出するカラーモデルの名前をフィールドに入力してください。

Closed 最小ピクセル数

カラーモデルがマッチするとみなされる、最小ピクセル数しきい値を定義します (0～9,999,999、デフォルトは 1,000)。例えば、[識別] モードで、このしきい値を 1,000 に設定すると、ピクセル数が 1,000 以下のカラーモデルはすべて除外されます。[マッチ] モードでは、指定のカラーモデルにマッチするカラーモデルが 1,000 ピクセル以下だと、ツールは FAIL を返します。

Closed 結果

検出されたカラーモデルの名前を表示します。


ライブラリ (カラーモデル識別ツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


テーブル (カラーモデル識別ツール)

最もマッチした検出カラーモデルを、ランクおよび得点順にソートして 10 位まで表示します (読み取り専用)。

Closed ランク

検査基準に最もマッチしているカラーモデルをランク順に 1～10 まで表示します。

Closed 名前

検出されたカラーモデルの名前を表示します。

Closed ピクセル数

検出されたカラーモデルのピクセル数を表示します。


[合成領域] タブ (カラーモデル識別ツール)

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。

Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


カラーモデル識別ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注:カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
マッチカラー | 文字列 | X | X | 入出力
最小ピクセル数 | 整数値 | X | X | 入出力
モード | 整数値 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
オリジナル画像の表示 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
合成領域 | 動作 | X | X |
モデル有効の適用 | 動作 | X | X |

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


2 点間の直線幾何・計測ツール

2 点間の直線幾何・計測ツールは、2 つの入力特徴 (点、フィクスチャ原点または円特徴の中心) の間に参照線を作成し、その線の両端の座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

  1. 2 点間の直線幾何・計測ツールを設定するには
  2. 2 点間の直線幾何・計測ツールのパラメータを調整するには
  3. 2 点間の直線幾何・計測ツールの入出力プロパティを使用するには


2 点間の直線幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は 2 つの特徴の間に自動的に直線を作成します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


2 点間の直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

2 点間の直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


2 点間の直線幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


2 点間の中点幾何・計測ツール

2 点間の中点幾何・計測ツールは、2 つの入力特徴 (点、フィクスチャ原点または円特徴の中心) の中点を計算し、特徴間に参照線を作成します。同時に、フィクスチャを基準とした中点の角度と、中点の座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

  1. 2 点間の中点幾何・計測ツールを設定するには
  2. 2 点間の中点幾何・計測ツールのパラメータを調整するには
  3. 2 点間の中点幾何・計測ツールの入出力プロパティを使用するには


2 点間の中点幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。

  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。

  3. 2 番目の特徴を選択します。

  4. EasyBuilder は 2 つの特徴の間に自動的に直線を作成し、中点の場所に [image] を配置します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


2 点間の中点幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

2 点間の中点幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は中点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed 結果

2 つの入力特徴間の中点座標、およびフィクスチャを基準にした中点の角度方向を返します。

注:　座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


2 点間の中点幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


2 点間の距離幾何・計測ツール

2 点間の距離幾何・計測ツールは、2 つの入力特徴 (点、フィクスチャ原点または円特徴の中心) の中点間の距離をエッジまたは直線を基準に計算します。同時に、距離を示す参照線を作成し、その寸法を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

2 点間の距離幾何・計測ツールは、組み立て時の配置を正確に測定する場合に有用です。

  1. 2 点間の距離幾何・計測ツールを設定するには
  2. 2 点間の距離幾何・計測ツールのパラメータを調整するには
  3. 2 点間の距離幾何・計測ツールの入出力パラメータを使用するには


2 点間の距離幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 2 番目の特徴を選択します。
  4. EasyBuilder は自動的にジョブを検査し、計測用の参照線として使用するエッジまたは直線スマートフィーチャーを提示します。参照するエッジまたは直線を選択してください。
  5. その後、EasyBuilder は特徴の中点から、参照エッジまたは直線に対して垂直の参照線を引き、その参照線と参照エッジ/直線の間の距離を計算します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


2 点間の距離幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

2 点間の距離幾何・計測ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (2 点間の距離幾何・計測ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は寸法_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (2 点間の距離幾何・計測ツール)

Closed 最大

最大距離を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 距離

参照エッジまたは参照線を基準にして、2 つの特徴の中点から垂直に引いた 2 本の参照線の間の距離を表示します。値が [最小] ～ [最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小距離を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


2 点間の距離幾何・計測ツールの入出力パラメータを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
距離 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
距離 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


垂直線幾何・計測ツール

垂直線幾何・計測ツールは、直線またはエッジ特徴に対して垂直の参照線を作成し、その両端の座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

  1. 垂直線幾何・計測ツールを設定するには
  2. 垂直線幾何・計測ツールのパラメータを調整するには
  3. 垂直線幾何・計測ツールの入出力プロパティを使用するには


垂直線幾何・計測ツールを設定するには

ツールを追加したら、直線またはエッジ特徴に対する垂直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 直線またはエッジ特徴を選択すると、EasyBuilder は、特徴に対して垂直の直線の交点を自動的に決定します。同時に、垂直線を定義する参照線およびエッジ有無判定ツールを挿入し、未設定の特徴を設定します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


垂直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

垂直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


垂直線幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


直線交点幾何・計測ツール

直線交点幾何・計測ツールは、2 つのエッジ特徴/参照線の交点を特定し、その座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

  1. 直線交点幾何・計測ツールを設定するには
  2. 直線交点幾何・計測ツールのパラメータを調整するには
  3. 直線交点幾何・計測ツールの入出力プロパティを使用するには


直線交点幾何・計測ツールを使用するには

ツールを追加したら、交差するエッジ特徴または直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 次に、交差するエッジ特徴または直線を選択してください。
  4. EasyBuilder は自動的に直線の交点を決定し、交点を定義する点を挿入します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


直線交点幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

直線交点幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は交点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


直線交点幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


角度 2 等分幾何・計測ツール

角度 2 等分幾何・計測ツールは、2 つのエッジ特徴または 2 本の直線間の角度を 2 等分する参照線を作成し、その両端の座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

角度 2 等分幾何・計測ツールは、検査対象物の特徴を 2 等分する角度を特定したり、他の計測用参照点として 2 等分した角度を使用したりする場合などに有用です。

  1. 角度 2 等分幾何・計測ツールを設定するには
  2. 角度 2 等分幾何・計測ツールのパラメータを調整するには
  3. 角度 2 等分幾何・計測ツールの入出力プロパティを使用するには


角度 2 等分幾何・計測ツールを設定するには

ツールを追加したら、角度 2 等分参照線の作成に使用される、エッジ特徴または直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 次に、2 番目のエッジまたは直線をクリックして、2 等分するエリアを定義してください。
  4. EasyBuilder が、選択したエッジまたは直線から、自動的に参照線を作成します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


角度 2 等分幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

角度 2 等分幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は 2 等分_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


角度 2 等分幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
角度 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
角度 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


N 点を通る直線幾何・計測ツール

N 点を通る直線幾何・計測ツールは、2～10 の入力特徴 (点、フィクスチャ原点または円特徴の中心) から参照線を作成し、その両端の座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

N 点を通る直線幾何・計測ツールは、画像に存在する複数の特徴から参照線を作成する場合に有用です。

  1. N 点を通る直線幾何・計測ツールを設定するには
  2. N 点を通る直線幾何・計測ツールのパラメータを調整するには
  3. N 点を通る直線幾何・計測ツールの入出力プロパティを使用するには


N 点を通る直線幾何・計測ツールを設定するには

ツールを追加したら、ラインを作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 次に、直線を定義する特徴をすべて選択してください。 最小 2 から最大 10 までの入力特徴を選択することができます。
  4. 目的の特徴をすべて選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)
  5. EasyBuilder が、選択した入力特徴から、自動的に参照線を作成します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


N 点を通る直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

N 点を通る直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


N 点を通る直線幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


N 点を通る近似円幾何・計測ツール

N 点を通る近似円幾何・計測ツールは、3～10 の入力特徴 (点、フィクスチャ原点または円特徴の中心) から参照円を作成し、その直径を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

N 点を通る近似円幾何・計測ツールは、画像に存在する特徴から参照円を作成する場合に有用です。

  1. N 点を通る近似円幾何・計測ツールを設定するには
  2. N 点を通る近似円幾何・計測ツールのパラメータを調整するには
  3. N 点を通る近似円幾何・計測ツールの入出力プロパティを使用するには


N 点を通る近似円幾何・計測ツールを設定するには

ツールを追加したら、参照円を作成するのに使用される、入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 次に、円の定義に使用する特徴をすべて選択してください。 最小 3 から最大 10 までの入力特徴を選択することができます。
  4. 目的の特徴をすべて選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)
  5. EasyBuilder が、選択した入力特徴から、自動的に参照円を作成します。 同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  6. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  7. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


N 点を通る近似円幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

N 点を通る近似円幾何・計測ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (N 点を通る近似円幾何・計測ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は円_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[制限範囲] タブ (N 点を通る近似円幾何・計測ツール)

Closed 最大

最大直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 直径

作成された円の直径を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

Closed 最小

最小直径を指定します。画像に基づきデフォルトのスマートリミットが設定されます。アプリケーションに合わせて適切な値に設定してください。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。


N 点を通る近似円幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
最大 | 浮動小数点 | X | 入出力
最小 | 浮動小数点 | X | 入出力
ツール有効 | 整数値 | X | 入出力
円.半径 | 浮動小数点 | X | 出力
円.X | 浮動小数点 | X | 出力
円.Y | 浮動小数点 | X | 出力
直径 | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
最大 | 浮動小数点 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
直径 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


円-直線交点幾何・計測ツール

円-直線交点幾何・計測ツールは、直線と円の交点を特定し、その座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

円-直線交点幾何・計測ツールは、円特徴とエッジ特徴が正確に配置されているかを検証する場合などに有用です。

  1. 円-直線幾何・計測ツールを設定するには
  2. 円-直線幾何・計測ツールのパラメータを調整するには
  3. 円-直線幾何・計測ツールの入出力パラメータを使用するには


円-直線幾何・計測ツールを設定するには

ツールを追加したら、円と交差するエッジ特徴または直線を定義します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴を水色のスマートフィーチャーとして提示します。同時に、他のツールで定義済みの特徴を緑色で提示します。
  2. スマートフィーチャーの 1 つを選択してクリックすると、紫色に変わり、特徴の外側にもう一本の線が伸びます。
  3. 次に、円と交差するエッジまたは直線を選択してください。
  4. EasyBuilder は自動的に円と直線の交点を決定し、交点を定義する 2 点を挿入します。同時に、エッジ有無判定ツールや円有無判定ツールを挿入し、未定義の特徴を設定します (ツールや特徴のタイプによります)。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円-直線幾何・計測ツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

円-直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [検査の結果] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は交点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


円-直線幾何・計測ツールの入出力パラメータを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
点1.X | 浮動小数点 | X | 出力
点1.Y | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
点1.X | 浮動小数点 | X | X | 出力
点1.Y | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


ユーザ定義点幾何・計測ツール

ユーザ定義点幾何・計測ツールは、参照点を画像中の任意の場所に作成し、その座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

ユーザ定義点幾何・計測ツールは、検査対象物またはオブジェクトの特徴以外の参照点に基づいて計測を行う場合に有用です。

注:このツールの点は、角度情報を持ちませんが、他のツールのフィクスチャとしても使用可能です。

  1. ユーザ定義点幾何・計測ツールを設定するには
  2. ユーザ定義点幾何・計測ツールのパラメータを調整するには
  3. ユーザ定義点幾何・計測ツールの入出力プロパティを使用するには


ユーザ定義点幾何・計測ツールを設定するには

  1. ツールを追加したら、紫色のクロスヘアが画像に表示されます。
  2. クロスヘアを任意の場所に配置して、[OK] ボタンを押してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。

  4. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。

    注:このツールの点は、角度情報を持ちませんが、他のツールのフィクスチャとしても使用可能です。


ユーザ定義点幾何・計測ツールのパラメータを調整するには

検査領域の確定後、用途に合わせてツールをカスタマイズしたり、チューニングしたりすることができます。

ユーザ定義点幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名は点_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ユーザ定義点幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
点 | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
点 | 動作 | X | X |


ユーザ定義直線幾何・計測ツール

ユーザ定義直線幾何・計測ツールは、参照線を画像内の任意の場所に作成し、その両端の座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

ユーザ定義直線幾何・計測ツールは、検査対象物またはオブジェクトの特徴以外の参照線に基づいて計測を行う場合に有用です。

  1. ユーザ定義直線幾何・計測ツールを設定するには
  2. ユーザ定義直線幾何・計測ツールのパラメータを調整するには
  3. ユーザ定義直線幾何・計測ツールの入出力プロパティを使用するには


ユーザ定義直線幾何・計測ツールを設定するには

  1. ツールを追加すると、紫色の直線が画像に表示されます。
  2. 直線を任意の場所に配置して、[OK] ボタンを押してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ユーザ定義直線幾何・計測ツールのパラメータを調整するには

検査領域の確定後、用途に合わせてツールをカスタマイズしたり、チューニングしたりすることができます。

ユーザ定義直線幾何・計測ツール設定ペインには、次のコントロールが表示されます。

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力]、[出力]、[通信]) で参照されます。ツールのデフォルト名はライン_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed ライン

作成した線分の両端の座標を返します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ユーザ定義直線幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
ライン | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
ライン | 動作 | X | X |


最適円幾何・計測ツール

最適円幾何・計測ツールは、検出されたエッジに基づき、最適円を作成します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。エッジを識別すると、エッジ特徴の上に最適円を作成し、その半径と中心を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

最適円幾何・計測ツールは、検査対象物またはオブジェクトが同一の形状であることを確認したい場合などに有用です。このツールは、例えば、N 点を通る近似円幾何・計測ツールより正確な最適円を作成することができますが、速度は遅くなります。

  1. 最適円幾何・計測ツールを設定するには
  2. 最適円幾何・計測ツールのパラメータを調整するには
  3. 最適円幾何・計測ツールの入出力プロパティを使用するには


最適円幾何・計測ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. 円環状のマスク領域をエッジ特徴上に配置、設定します。円環の外半径および内半径を調整して、エッジが正しく検出されるようにしてください。領域を配置、設定する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジ特徴を囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円が正しく作成されていることを確認してください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


最適円幾何・計測ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

最適円幾何・計測ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (最適円幾何・計測ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は最適円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[最適ライン] タブ (最適円幾何・計測ツール)

[最適ライン] タブを選択すると、領域内に検出されたすべてのエッジ候補および最適円の結果が表示されます。エッジ候補は、最適円作成時に使用可能なエッジを表し、小さなカラーコード化された円で表示されます。

Closed 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

Closed 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注: このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。

Closed 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

Closed 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

Closed 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注: この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。

Closed 結果

画像中の最適ラインを表示し、最適円の半径および中心を返します。


[エッジ] タブ (最適円幾何・計測ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (最適円幾何・計測ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

Closed エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

Closed 規則: 最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則: エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


最適円幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
外れ値の除外 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
最適距離フィルタ | 整数値 | X | X | 入出力
最端フィルタ距離 | 整数値 | X | X | 入出力
総合得点に含める | 整数値 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
再計算 | 整数値 | X | X | 入出力
再得点 | 整数値 | X | X | 入出力
規則_最初のエッジ | 整数値 | X | X | 入出力
規則_エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |


最適ライン幾何・計測ツール

最適ライン幾何・計測ツールは、検出されたエッジに基づき、最適ラインを作成します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。エッジを識別すると、エッジ特徴の上に最適ラインを作成し、ラインセグメントの始点と終点の座標を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

最適ライン幾何・計測ツールは、検査対象物またはオブジェクトが同一の形状をしていることを確認したい場合などに有用です。このツールは、例えば、N 点を通る直線幾何・計測ツールより正確な最適ラインを作成することができますが、速度は遅くなります。

  1. 最適ライン幾何・計測ツールを設定するには
  2. 最適ライン幾何・計測ツールのパラメータを調整するには
  3. 最適ライン幾何・計測ツールの入出力パラメータを使用するには


最適円幾何・計測ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円が正しく作成されていることを確認してください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


最適ライン幾何・計測ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

最適ライン幾何・計測ツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (最適円幾何・計測ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は最適ライン_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[最適ライン] タブ (最適ライン幾何・計測ツール)

[最適ライン] タブを選択すると、領域内に検出されたすべてのエッジ候補および最適ラインの結果が表示されます。エッジ候補は、最適ライン作成時に使用可能なエッジを表し、小さなカラーコード化された円で表示されます。

Closed 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

Closed 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注: このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。

Closed 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

Closed 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

Closed 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注: この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。

Closed 結果

画像中の最適ラインを表示し、ラインセグメントの始点と終点の座標を返します。


[エッジ] タブ (最適ライン幾何・計測ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (最適ライン幾何・計測ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

Closed エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

Closed 規則: 最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則: エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


最適円幾何・計測ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
外れ値の除外 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
最適距離フィルタ | 整数値 | X | X | 入出力
最端フィルタ距離 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
再計算 | 整数値 | X | X | 入出力
再得点 | 整数値 | X | X | 入出力
規則: 最初のエッジ | 整数値 | X | X | 入出力
規則: エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ライン.終点_X | 浮動小数点 | X | X | 出力
ライン.終点_Y | 浮動小数点 | X | X | 出力
ライン.始点_X | 浮動小数点 | X | X | 出力
ライン.始点_Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |


演算演算＆ロジックツール

演算演算＆ロジックツールでは、標準の数学関数、演算子、論理演算、統計、三角関数を使用して、ツールおよびジョブデータを処理する数式を作成することができます。

演算演算＆ロジックツールは、2 つのツールが検出した欠陥数を追加したり、寸法測定ツールの平均値を返したりするのに有用です。

  1. 演算演算＆ロジックツールを設定するには
  2. 演算演算＆ロジックツールのパラメータを調整するには
  3. 演算演算＆ロジックツールの入出力プロパティを使用するには


演算演算＆ロジックツールを設定するには

注: 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、式を作成します。

  1. 設定ペインの左側から演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してからダブルクリックするか、または[挿入] ボタンを押します。
  2. [式] を作成したら、[制限範囲] タブをクリックして、ツールの制限範囲を定義します。デフォルトでは、[最大] は 9,999,999 に、[最小] は -9,999,999 に設定されています。アプリケーションに合わせて制限範囲をカスタマイズしてください。

注: 式の結果が文字列を返す場合、[最大] および [最小] 制限は無効となります。

  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


演算演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

演算演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [制限範囲] タブ
  • 式

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (演算演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は演算_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


式 (演算演算＆ロジックツール)

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。

ヒント: 文字列が他の文字列と一致しているかどうかを見るには、Exact 関数を使用してください。If 関数は、値を比較するときに使用するため、If 関数を使用して文字列を比較しようとした場合、EasyBuilder はエラーを返します。
例:
  • ID コードの読み取り識別ツールで使用されている文字列が、文字認識識別ツールで読み取った文字列と一致しているかどうかを比較する必要ある場合、次の数式を [式] に作成することができます:　Exact(IDコード_1.文字列,Text_1.結果)。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


[制限範囲] タブ (演算演算＆ロジックツール)

Closed 最大

数式の最大許容値を設定します。デフォルトで、最大値 9,999,999 がツールに割り当てられています。アプリケーションに合わせて、値をカスタマイズする必要があります。

Closed 結果

[式] の結果を表示します。値が [最小]～[最大] の範囲内にある場合、PASS を返します。

Closed 最小

数式の最小許容値を設定します。デフォルトで、最小値 -9,999,999 がツールに割り当てられてます。アプリケーションに合わせて、値をカスタマイズする必要があります。

Closed 反転

ツールの PASS/FAIL ロジックを反転するかどうかを定義します (デフォルトは、OFF)。

  • OFF - 標準的な結果が適用されます。検出された特徴が指定の範囲に合致する場合、PASS となります。
  • ON - 結果を反転します。検出された特徴が指定の範囲に合致する場合、FAIL となります。
Closed [範囲設定] ボタン

スマートリミット設定に基づいて、制限範囲を定義します。このボタンは、パラメータが変更されたため制限範囲を調整する必要がある場合や、ツールが追加されて制限範囲が定義されていない場合などに有用です。

注: 式の結果が文字列を返す場合、[最大] および [最小] 制限は無効となります。


演算演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
ツール有効 | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
最小 | 浮動小数点 | X | 入出力
結果 | 浮動小数点 | X | 出力
最大 | 浮動小数点 | X | 入出力
反転 | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
ツール有効ステータス | 整数値 | X | 出力
PASS | 整数値 |  | 出力
FAIL | 整数値 |  | 出力
ステータス | 整数値 | X | 出力
PASS_数 | 整数値 | X | 出力
FAIL_数 | 整数値 | X | 出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
ツール有効 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最小 | 浮動小数点 | X | X | 入出力
結果 | 浮動小数点 | X | X | 出力
最大 | 浮動小数点 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
ツール有効ステータス | 整数値 | X | X | 出力
PASS | 整数値 | X |  | 出力
FAIL | 整数値 | X |  | 出力
ステータス | 整数値 | X | X | 出力
PASS_数 | 整数値 | X | X | 出力
FAIL_数 | 整数値 | X | X | 出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力


ロジック演算＆ロジックツール

ロジック演算＆ロジックツールでは、標準ブール値ロジック演算子を使用して、PASS/FAIL データを処理する数式を作成することができます。

  1. ロジック演算＆ロジックツールを設定するには
  2. ロジック演算＆ロジックツールのパラメータを調整するには
  3. ロジック演算＆ロジックツールの入出力プロパティを使用するには

次の結果を返します。

In-Sight モデル | 結果
In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く) | PASS/FAIL ステータスのみ
In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果


ロジック演算＆ロジックツールを設定するには

注: 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、式を作成します。[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。

In-Sight 2000 シリーズビジョンセンサ

  1. ツールの PASS/FAIL 結果を追加して、式を作成します。[式] エディタに PASS/FAIL 結果を入力するには、結果を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. 式の作成後、ツールの PASS/FAIL ロジックを反転させることができます (オプション)。
  3. ツールの初期設定を済ませたら、結果を考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

In-Sight ビジョンシステム

  1. ツールの PASS/FAIL 結果を追加して、式を作成します。[式] エディタに PASS/FAIL 結果を入力するには、結果を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. 式の作成後、ツールの PASS/FAIL ロジックを [設定] タブを使用して反転させることができます (オプション)。
  3. ツールの初期設定を済ませたら、結果を考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


ロジック演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

In-Sight 2000 シリーズビジョンセンサ

  • [ツールの編集] グループボックス

In-Sight ビジョンシステム

ロジック演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 式

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


ロジック演算＆ロジックツールのパラメータを調整するには

注: このトピックでは、In-Sight 2000 シリーズビジョンセンサ接続時に表示されるユーザインタフェースについて説明します。In-Sight ビジョンシステムに接続している場合、ロジック演算＆ロジックツールのパラメータを調整するにはをご参照ください。

Closed 式

[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:[式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。

Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決め/検査ツールが出力する PASS/FAIL 結果が含まれています。ジョブ/ツールデータは、データに含まれる値のシンボル参照です。次の 2 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。

注:使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、シンボルを [式] に入力することができます。使用するシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

Closed 左括弧、コンマ (,)、右括弧、 AND、OR および NOT ボタン

[(] (左括弧)、[,] (コンマ)、[)] (右括弧)、AND、OR または NOT ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

Closed [削除] ボタン

[削除] ボタンを使用して、ハイライトしたワードやシンボルを [式] から削除することができます。削除するワードまたはシンボルをハイライトして、[削除] をクリックしてください。

Closed 結果を反転

ON にした場合、結果が制限範囲内にあると、ツール結果は FAIL となります。(デフォルト = OFF)

PASS/FAIL | (反転) | PASS/FAIL
PASS/FAIL | (反転) | PASS/FAIL
Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 名前

検査ツールの名前を定義します。デフォルト名はロジック_1 で、末尾の番号はツールの追加に応じて増加します。

Closed 有効

検査ツールの実行可否を定義します。

  • デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。
  • 入力ラインを選択すると、ディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます (HIGH 信号、1、は ON、LOW 信号、0 は OFF)。 そうすることにより、どのツールをいつ実行すべきかを PLC などの制御システムから選択することができます。
Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[全般] タブ (ロジック演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。デフォルト名はロジック_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


式 (ロジック演算＆ロジックツール)

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決め/検査ツールが出力する PASS/FAIL 結果が含まれています。ジョブ/ツールデータは、データに含まれる値のシンボル参照です。次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注:使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、シンボルを [式] に入力することができます。使用するシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

Closed 左括弧、コンマ (,)、右括弧、 AND、OR および NOT ボタン

[(] (左括弧)、[,] (コンマ)、[)] (右括弧)、AND、OR または NOT ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

Closed [削除] ボタン

[削除] ボタンを使用して、ハイライトしたワードやシンボルを [式] から削除することができます。削除するワードまたはシンボルをハイライトして、[削除] をクリックしてください。


[設定] タブ (ロジック演算＆ロジックツール)

Closed 結果

式の結果を報告します。

Closed 反転

ツールの PASS/FAIL 結果を反転させるかどうかを定義します。

  • OFF (デフォルト): PASS/FAIL 結果を反転しません。
  • ON: PASS/FAIL 結果を反転します。


ロジック演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 |  | 入力
反転 | 整数値 | X | 入力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X |
結果 | 浮動小数点 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X | 入力
ツール有効ステータス | 整数値 | X |

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
エラー_数 | 整数値 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 整数値 |  | 出力
FAIL_数 | 整数値 | X | 出力
総合判定に含める | 整数値 | X | 入出力
反転 | 整数値 | X | 入出力
PASS | 整数値 |  | 出力
PASS_数 | 整数値 | X | 出力
結果 | 浮動小数点 | X | 出力
ステータス | 整数値 | X | 出力
ツール有効 | 整数値 | X | 入出力
ツール有効ステータス | 整数値 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  | 出力
FAIL_数 | 整数値 | X | X | 出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
PASS | 整数値 | X |  | 出力
PASS_数 | 整数値 | X | X | 出力
結果 | 浮動小数点 | X | X | 出力
ステータス | 整数値 | X | X | 出力
ツール有効 | 整数値 | X | X | 入出力
ツール有効ステータス | 整数値 | X | X | 出力


トレンド演算＆ロジックツール

トレンド演算＆ロジックツールは、位置決め/検査ツール値または入力ラインの、リセット前の指定サンプル数に対する、最大値、最小値、平均、サンプル数および標準偏差統計を返します。

トレンド演算＆ロジックツールは、製造過程の解析用に、特定ツールの結果について、ジョブ実行中にわたって統計情報を蓄積したい場合などに有用です。

  1. トレンド演算＆ロジックツールを設定するには
  2. トレンド演算＆ロジックツールのパラメータを調整するには
  3. トレンド演算＆ロジックツールの入出力プロパティを使用するには


トレンド演算＆ロジックツールを使用するには

ツールを追加したら、処理する値を指定し、ツールのパラメータを設定します。

  1. アプリケーションに合わせて、[全般] タブを設定します。
  2. [設定] タブをクリックし、統計データを蓄積する値を指定します。ツールをジョブに追加すると、EasyBuilderはその時点でのアプリケーションを精査し、[最後の値] パラメータが参照可能な値を表示します。値を選択したら、タブの他のパラメータを設定してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


トレンド演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

トレンド演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [テーブル] タブ
  • [値] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (トレンド演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はトレンド_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (トレンド演算＆ロジックツール)

Closed 最後の数値

ツールが計算する値を指定します。デフォルトでは、[未定義] が選択されており、統計は蓄積されません。ツールまたは入力値の統計を蓄積するには、ツールが返す値、またはジョブに入力する値を選択してください。

Closed 最大サンプル

ツールの統計蓄積に使用する、最大サンプル数を指定します。デフォルトでは、100 サンプルが使用されます。サンプル数は、最小 10～最大 5,000 の範囲となります。ツールが最大サンプル数に達したら、一番古い値が捨てられ、新しい値が加わります。

Closed 表示

計算値をどこに表示するかを指定します。選択肢は、[最後の数値]、[最小]、[最大]、[平均] または [標準偏差] です。デフォルトでは、[最後の数値] が選択されています。

Closed 結果

[表示] パラメータで指定した、現在の計算値を表示します。

Closed [リセット] ボタン

データ蓄積を 0 にリセットします。

Closed オンラインリセット

In-Sight ビジョンシステムをオンラインに切り替えるたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。

Closed ジョブロードのリセット

In-Sight ビジョンシステムがツールを含むジョブをロードするたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。


[値] タブ (トレンド演算＆ロジックツール)

グラフを使用して、値をグラフィックスで表示します。


[テーブル] タブ (トレンド演算＆ロジックツール)

トレンド演算＆ロジックツールのテーブルには、[設定] タブの [最大サンプル] で指定したサンプル数に対して、[最後の数値] パラメータで指定した値を蓄積した結果が表示されます。


トレンド演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
表示 | 整数値 | X | 入出力
外部リセット | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ジョブロードのリセット | 整数値 | X | 入出力
最大サンプル | 整数値 | X | 入出力
オンラインリセット | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
チャート | チャート1 | X |
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
最後の数値 | 浮動小数点 | X | 出力
最大 | 浮動小数点 | X | 出力
平均 | 浮動小数点 | X | 出力
最小 | 浮動小数点 | X | 出力
サンプル数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
標準偏差 | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
リセット | 動作 | X |
1 トレンド演算＆ロジックツールには、[値] タブで作成されるチャートを参照する [チャート] データタイプが含まれます。

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
表示 | 整数値 | X | X | 入出力
外部リセット | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ジョブロードのリセット | 整数値 | X | X | 入出力
最大サンプル | 整数値 | X | X | 入出力
オンラインリセット | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
チャート | チャート1 | X | X |
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
最後の数値 | 浮動小数点 | X | X | 出力
最大 | 浮動小数点 | X | X | 出力
平均 | 浮動小数点 | X | X | 出力
最小 | 浮動小数点 | X | X | 出力
サンプル数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
標準偏差 | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
リセット | 動作 | X | X |
1 トレンド演算＆ロジックツールには、[値] タブで作成されるチャートを参照する [チャート] データタイプが含まれます。


統計演算＆ロジックツール

統計演算＆ロジックツールは、位置決め/検査ツール値または入力ラインの、最大値、最小値、平均、サンプル数および標準偏差統計を返します。

統計演算＆ロジックツールは、製造過程の解析用に、特定ツールの結果について、統計情報を蓄積したい場合などに有用です。

  1. 統計演算＆ロジックツールを設定するには
  2. 統計演算＆ロジックツールのパラメータを調整するには
  3. 統計演算＆ロジックツールの入出力プロパティを使用するには


統計演算＆ロジックツールを使用するには

ツールを追加したら、処理する値を指定し、ツールのパラメータを設定します。

  1. アプリケーションに合わせて、[全般] タブを設定します。
  2. [設定] タブをクリックし、統計データを蓄積する値を指定します。ツールをジョブに追加すると、EasyBuilder はその時点でのアプリケーションを精査し、[最後の値] パラメータが参照可能な値を表示します。値を選択したら、タブの他のパラメータを設定してください。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


統計演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

統計演算＆ロジックツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • テーブル

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (統計演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は統計_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (統計演算＆ロジックツール)

Closed 最後の数値

ツールが計算する値を指定します。デフォルトでは、[未定義] が選択されており、統計データは蓄積されません。ツールまたは入力値の統計データを蓄積するには、ツールが返す値、またはジョブに入力する値を選択してください。

Closed 表示

どの計算値を表示するかを指定します。選択肢は、[最後の数値]、[最小]、[最大]、[平均] または [標準偏差] です。デフォルトでは、[最後の数値] が選択されています。

Closed 結果

[表示] パラメータで指定した、現在の計算値を表示します。

Closed オフライン時にカウント

In-Sight ビジョンシステムがオフライン時に、取り込んだ画像を結果に含めるかどうかを指定します。デフォルトは ON で、ビジョンシステムがオフラインでも統計データは蓄積されます。チェックボックスを OFF にすると、In-Sight ビジョンシステムがオンライン時のみ、統計データを蓄積します。

Closed [リセット] ボタン

データ蓄積を 0 にリセットします。

Closed 外部リセット

外部デバイスによって、データ蓄積をリセット可能にするかどうか指定します。デフォルトは OFF で、外部デバイスからは制御できません。PLC または VisionView® オペレータインタフェースパネルなどの外部デバイスからこのツールをリセットするには、チェックボックスを ON にして、通信ステップでデータを設定してください。

Closed オンラインリセット

In-Sight ビジョンシステムをオンラインに切り替えるたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。

Closed ジョブロードのリセット

ビジョンシステムがツールを含むジョブをロードするたびに、ツールがデータ蓄積を自動的にリセットするかどうかを指定します。デフォルトは OFF で、手動でのリセットが必要です。


テーブル (統計演算＆ロジックツール)

統計演算＆ロジックツールのテーブルには、[設定] タブの [最後の数値] パラメータで指定した値を蓄積したデータ結果が表示されます。


統計演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
オフライン時にカウント | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
表示 | 整数値 | X | 入出力
外部リセット | 整数値 |  | 入出力
総合判定に含める | 整数値 | X | 入出力
ジョブロードのリセット | 整数値 | X | 入出力
オンラインリセット | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
最後の数値 | 浮動小数点 | X | 出力
最大 | 浮動小数点 | X | 出力
平均 | 浮動小数点 | X | 出力
最小 | 浮動小数点 | X | 出力
サンプル数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
標準偏差 | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
リセット | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
オフライン時にカウント | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
表示 | 整数値 | X | X | 入出力
外部リセット | 整数値 | X |  | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ジョブロードのリセット | 整数値 | X | X | 入出力
オンラインリセット | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
最後の数値 | 浮動小数点 | X | X | 出力
最大 | 浮動小数点 | X | X | 出力
平均 | 浮動小数点 | X | X | 出力
最小 | 浮動小数点 | X | X | 出力
サンプル数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
標準偏差 | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
リセット | 動作 |  | X |


グループ演算＆ロジックツール

グループ演算＆ロジックツールは、位置決めおよび検査ツールをグループ化します。その結果、ツール実行は連結され、グループ内のツールは有効ステータスを共有します。

グループ演算＆ロジックツールは、対象物の 1 つの特徴が PASS かどうかを判定するのに複数のツールが必要な場合や、複数の画像取り込みが必要なジョブ、またはたくさんのツールが必要なジョブなどに有用です。

  1. グループ演算＆ロジックツールを設定するには
  2. グループ演算＆ロジックツールのパラメータを調整するには
  3. グループ演算＆ロジックツールの入出力プロパティを使用するには


グループ演算＆ロジックツールを設定するには

注: 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、どのツールをグループに含めるかを指定します。

  1. ツールをジョブに追加すると、EasyBuilder はその時点のジョブを調査し、ジョブに含まれるツールを [ツールグループ] タブにすべて表示します。
  2. グループに追加するツールを選択し (CTRL キーを押したまま複数のツールを個々に選択するか、または SHIFT キーを押したまま順番に並んだ複数のツールをまとめて選択します) 、[追加] ボタンを押します。
  3. グループの設定が済んだら、[グループ有効条件] タブを選択し、グループ実行制御ロジックを提供する [式] をカスタマイズすることができます。デフォルトでは、[式] は　1 に設定されており、グループは常に有効となります。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


グループ演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

グループ演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [ツールグループ] タブ
  • [グループ有効条件] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (グループ演算＆ロジックツール)

Closed ツール名

Defines the name of your inspection tool, which will be utilized in configuring the results Inputs/Outputs and Communication); the default name is “Group_1” (if it is the first Group Math & Logic Tool added to the job, otherwise it will be incremented, e.g. “Group_2”, “Group_3”, etc.). ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

注: [グループ有効条件] タブを設定して [式] を使用する場合、正常に作動させるためには、[ツール有効] パラメータを [式] に設定する必要があります。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (グループ演算＆ロジックツール)

Closed グループ ID

[グループ ID] 数は、グループ演算＆ロジックツールに含まれるツールが FAIL となった場合に、ツール失敗を表示するのに使用されます。グループ演算＆ロジックツールでは、ツールが PASS と等しい場合に 0 を返し、FAIL の場合にグループ ID 番号を返します。グループ ID 番号は、1～9,999,999 から選択することができます。グループ ID はデフォルトで 10 に設定されており、新たなグループ演算＆ロジックツールが追加されても増分されることはありません。


[ツールグループ] タブ (グループ演算＆ロジックツール)

[ツールグループ] タブを使用して、選択中のグループ演算＆ロジックツールにツールを追加したり、削除することができます。

左側のリストにはグループに含まれていないツール、右側のリストにはグループに含まれているツールが表示されています。デフォルトでは、右側のリストは空欄となっています。

Closed [追加] ボタン

左側のツールを選択すると、[追加] ボタンが有効になります。

  • ツールを 1 つずつ追加するには、ツールを選択してから、[追加] ボタンを押します。
  • 順番に並んでいない、複数のツールをまとめて追加するには、CTRL キーを押したまま各ツールを順番にハイライトし、[追加] ボタンを押します。
  • 順番に並んでいる、複数のツールをまとめて追加するには、SHIFT キーを押したまま最初のツールをハイライトし、次に最後のツールをハイライトしてから[追加] ボタンを押します。
Closed [削除] ボタン

右側のツールを選択すると、[削除] ボタンが有効になります。

  • ツールを 1 つずつ削除するには、ツールを選択してから、[削除] ボタンを押します。
  • 順番に並んでいない、複数のツールをまとめて削除するには、CTRL キーを押したまま各ツールを順番にハイライトし、[削除] ボタンを押します。
  • 順番に並んでいる、複数のツールを削除するには、SHIFT キーを押したまま最初のツールをハイライトし、次に最後のツールをハイライトしてから、[削除] ボタンを押します。
注:
  • ツールは、1 つのグループ演算＆ツールのみに含めることができます。既にグループ演算＆ロジックツールに含まれているツールを他のグループ演算＆ロジックツールに追加するには、まずグループ演算＆ロジックツールから削除し、その後、別の演算＆ロジックツールに追加します。
  • グループ演算＆ロジックツールには、他のグループ演算＆ロジックツールに含まれるツールを追加することはできません。
  • グループ演算＆ロジックツールをコピー＆ペーストする場合、グループ演算＆ロジックツールに含まれるすべてのツールがコピー＆ペーストされます。
  • グループ演算＆ロジックツールを削除する場合、グループ演算＆ロジックツールに含まれるツールをすべて削除してもよいかを確認するダイアログが表示されます。グループに含まれるツールを削除したくない場合、ツールをグループから削除してから、グループ演算＆ロジックツールを削除してください。


[グループ有効条件] タブ (グループ演算＆ロジックツール)

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

[グループ有効条件] タブを使用して、ツール実行を決定する数式を作成します。デフォルトで [式] は 1 に設定され、画像取り込みトリガ時にツールは実行されます。 このコントロールを有効にするには、[全般] タブの[ツール有効] コントロールを [式] に設定する必要があります。

In-Sight 2000-130/130C ビジョンセンサ

Closed 式

[式] テキストボックスを使用して、ツールの PASS/FAIL 結果を処理する数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:[式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。

Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決め/検査ツールが出力する PASS/FAIL 結果が含まれています。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 2 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。

注:使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、シンボルを [式] に入力することができます。使用するシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

Closed 左括弧、コンマ (,)、右括弧、 AND、OR および NOT ボタン

[(] (左括弧)、[,] (コンマ)、[)] (右括弧)、AND、OR または NOT ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

Closed [削除] ボタン

[削除] ボタンを使用して、ハイライトしたワードやシンボルを [式] から削除することができます。削除するワードまたはシンボルをハイライトして、[削除] をクリックしてください。

In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ

注: グループ演算＆ロジックツールとシーケンス演算＆ロジックツール実行を連結するには、グループ演算＆ロジックツールの式をシーケンス演算＆ロジックツールに設定し (例: Sequence_1.Current_Step=1) 、さらに [全般] タブの [ツール有効] コントロールを [式] に設定する必要があります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


グループ演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000 シリーズビジョンシステム (In-Sight 2000-23M ビジョンセンサを除く)

注: OPC は In-Sight 2000 シリーズビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入力
実行_時間 | 浮動小数点 | X |
FAIL_数 | 整数値 | X |
総合判定に含める | 整数値 | X | 入力
PASS_数 | 整数値 | X |
ステータス | 整数値 | X |
ツール有効 | 整数値 | X |
ツール有効ステータス | 整数値 | X | 入力
FAIL | 整数値 |  | 出力
PASS | 整数値 |  | 出力

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
グループ_ID | 整数値 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
不正コード | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
グループ_ID | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
不正コード | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


シーケンス演算＆ロジックツール

シーケンス演算＆ロジックツールは、複数の画像取り込みが必要なジョブのステップ数や、組み立て工程におけるステージを定義します。このツールは、グループ演算＆ロジックツールと連動して使用され、グループ内のツールの実行順序を制御します。

シーケンス演算＆ロジックツールは、組み立て/製造工程の順序に基づいて、画像取り込みや検査ツールの実行を同期させる場合などに有用です。例えば、特定シーケンスの結果を基にして組み立てを継続するかどうかを決定するのに、部品をさまざまな製造工程で検査したい場合などです。

  1. シーケンス演算＆ロジックツールを設定するには
  2. シーケンス演算＆ロジックツールのパラメータを調整するには
  3. シーケンス演算＆ロジックツールの入出力プロパティを使用するには


シーケンス演算＆ロジックツールを設定するには

ツールを追加したら、ツールのパラメータを設定します。

  1. アプリケーションに合わせて [全般] タブを設定します。
  2. [設定] タブをクリックし、パラメータをアプリケーションに合わせて設定します。

注: グループ演算＆ロジックツールとシーケンス演算＆ロジックツールを連結するには、シーケンス演算＆ロジックツールの [現在のステップ] シンボルを使用して、グループ演算＆ロジックツールの [式] を作成する必要があります。(例: グループ_1.有効=シーケンス_1.現在のステップ=1)

  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


シーケンス演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

シーケンス演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (シーケンス演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はステップ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 アプリケーションに合わせて、名前を変更することができます。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (シーケンス演算＆ロジックツール)

Closed ステップ

ツールが制御するステップの数を指定します。デフォルトは、4 ステップです。

Closed [ステップをリセット] ボタン

次の画像を取り込む際に、最初のステップで、0 に戻し、シーケンスを再スタートします。

Closed 次のステップを有効に

[次のステップ] パラメータが、外部デバイスによって制御可能かどうかを指定します。デフォルトは OFF で、外部デバイスからは制御できません。このパラメータを ON にすると、ツールから外部デバイスに送信されるステップ番号は、次の画像取り込みから [現在のステップ] となります。この構成では、ステップを順番に実行する必要はなく、入力されたステップ番号によっては、ステップをスキップすることも可能です (例えば、ステップの数が 6 で、ツールの現在のステップが 2 のときに、[次のステップ] から 5 が入力された場合、ステップ 3 および 4 はスキップされます)。

Closed 次のステップ

シーケンスにおいて、次のステップを開始するステップを指定します。デフォルトでは、1 が選択されています。このコントロールは、[次のステップを有効に] パラメータが ON の場合のみ、有効となります。PLC または VisionView® オペレータインタフェースパネルなどの外部デバイスからこのツールをリセットするには、[次のステップを有効に] チェックボックスを ON にして、通信ステップの [次のステップ] パラメータにて次のステップの値を設定してください。

Closed 現在のステップ

アクティブなステップを表示します。デフォルトは 1.000 です。現在のステップを定義します。


シーケンス演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
外部リセット | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
次のステップ | 整数値 | X | X | 入出力
次のステップを有効に | 整数値 | X | X | 入出力
ステップ | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
現在のステップ | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
ステップをリセット | 動作 | X | X |


点計算演算＆ロジックツール

点計算演算＆ロジックツールは、他の位置決め/検査ツールが出力した数式に基いて、画像中の点を計算するのに使用します。この点は、他のツールによって参照可能です。 ツールは、計算した点の XY 座標を返します。

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。

点計算演算＆ロジックツールは、他のツールによって参照可能な画像中の点を、プログラミングによって識別したい場合などに有用です。これに対し、ユーザ定義点幾何・計測ツールは、グラフィックスによって画像中に固定点を定義します。 例えば、演算関数の結果やエッジ有無判定ツールで検出された中点やエッジといった、特定ツールの結果に基づいて画像中に点を配置したい場合に、点計算演算＆ロジックツールは、ツール結果を入力として使用して点を計算することができます。また、画像中の点の位置は、参照するツールの出力を反映して変化します。 演算演算＆ロジックツールで、その他のロジックを決定するのに、計算された点を使用することができます。

  1. 点計算演算＆ロジックツールを設定するには
  2. 点計算演算＆ロジックツールのパラメータを調整するには
  3. 点計算演算＆ロジックツールの入出力プロパティを使用するには


点計算演算＆ロジックツールを設定するには

注: 他の位置決め/検査ツールを入力として使用します。入力として使用する他の位置決め/検査ツールを設定してから、このツールを追加してください。そうしないと、[式] を設定することができず、他のツールを設定してから、このツールに戻って設定し直すことになります。

ツールを追加したら、[式] を作成して、X および Y 値を定義します。

  1. 設定ペインの左側から演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してからダブルクリックするか、または [挿入] ボタンを押します。
  2. [式] を作成すると、画像に点アイコンが挿入され、計算された点の場所を示します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


点計算演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

点計算演算＆ロジックツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [X]、[Y] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (点計算演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は点_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。.

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (点計算演算＆ロジックツール)

Closed 結果

計算された X および Y 式の結果を表示します。


[X]、[Y] タブ (点計算演算＆ロジックツール)

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

[X] および [Y] タブを使用して、点の X および Y 座標を定義する数式を作成します。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


点計算演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
FAIL | 浮動小数点 |  | 出力
PASS | 浮動小数点 |  | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
説明 | 文字列 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL_数 | 浮動小数点 | X | 出力
総合判定に含める | 整数値 | X | 入出力
PASS_数 | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
FAIL | 浮動小数点 | X |  | 出力
PASS | 浮動小数点 | X |  | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
説明 | 文字列 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
総合判定に含める | 整数値 | X | X | 入出力
PASS_数 | 浮動小数点 | X | X | 出力


変数演算＆ロジックツール

変数演算＆ロジックツールは、外部デバイスからジョブに入力する整数、浮動小数点または文字列を定義します。これらの値は、定義後、位置決め、検査ツール、あるいは PLC や VisionView® オペレータインタフェースパネルなどの外部デバイスによって、参照することができるようになります。

変数演算＆ロジックツールは、PLC などの外部デバイスから位置決めまたは検査ツールに値を入力したり、演算演算＆ロジックツールやグループ演算＆ロジックツールの [式] から値を入力したりする場合などに有用です。例えば、文字認識識別ツールに文字列を入力したり、ブロブ計数ツールがサーチするブロブ数を制御する整数を入力したり、グループ演算＆ロジックツールの数式の一部として浮動小数点を入力したりするアプリケーションがある場合に、変数演算＆ロジックツールでそれらの値を作成してから、他のツールや通信ステップによってシンボル参照することができます。

  1. 変数演算＆ロジックツールを設定するには
  2. 変数演算＆ロジックツールのパラメータを調整するには
  3. 変数演算＆ロジックツールの入出力プロパティを使用するには


変数演算＆ロジックツールを設定するには

ツールを追加したら、入力変数に使用する値を定義します。

  1. アプリケーションに合わせて [全般] タブを設定します。
  2. [全般] タブ横の設定ペインは、入力変数テーブルです。値がブール値の場合は [ブール値の追加] ボタンを、値が整数の場合は [整数の追加] ボタンを、値が浮動小数点の場合は [浮動小数点の追加] ボタンを、値が文字列の場合は [文字列の追加] ボタンを押します。
  3. 入力変数を追加したら、アプリケーションに合わせて変数をカスタマイズしてください。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。

  5. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。

    注: リストから変数を削除するには、変数の隣のチェックボックスを ON にしてから [削除] ボタンを押します。([削除] ボタンを有効にするには、チェックボックスを ON にする必要があります。)


変数演算＆ロジックツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

変数演算＆ロジックツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • 入力変数テーブル

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (変数演算＆ロジックツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は変数_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


入力変数テーブル (変数演算＆ロジックツール)

変数演算＆ロジックツールの入力変数テーブルを使用して、入力変数を追加、編集および削除します。変数演算＆ロジックツールでは、32 個までの入力変数を作成することができます。

Closed [ブール値の追加] ボタン

値がブールロジック値の場合、[ブール値の追加] ボタンを押します。デフォルトでは、0 が追加されます (右にあるチェックボックスを ON にすると、ブール値は 1 に設定されます)。デフォルトのツール名は ブーリアン0 で、末尾の番号はツールの追加に応じて増加します。アプリケーションに合わせて、名前を変更することができます。

Closed [整数の追加] ボタン

値が整数の場合、[整数の追加] ボタンを押します。デフォルトでは、0 が追加されます。デフォルトのツール名は Integer0 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。整数の範囲は、-9,999,999～9,999,999 です。

Closed [浮動小数点の追加] ボタン

値が浮動小数点の場合、[浮動小数点の追加] ボタンを押します。デフォルトでは、0 が追加されます。デフォルトのツール名は Float0 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。浮動小数点の範囲は、-9,999,999～9,999,999 です。

Closed [文字列の追加] ボタン

値が文字列の場合、[文字列を追加] ボタンを押します。デフォルトで、文字列は空欄になっています。デフォルトの文字列名は String0 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。文字列は 32 文字まで入力可能です。

Closed [削除] ボタン

[削除] ボタンを押して、値をテーブルから削除します。変数をリストから削除するには、変数の隣のチェックボックスを ON にしてから [削除] ボタンを押します。([削除] ボタンを有効にするには、チェックボックスを ON にする必要があります。)


変数演算＆ロジックツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
説明 | 文字列 | X | 入出力
ツール有効 | 整数値 | X | 入出力
FAIL | 浮動小数点 |  | 出力
PASS | 浮動小数点 |  | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL_数 | 浮動小数点 | X | 出力
浮動小数点0 | 浮動小数点 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
整数値0 | 整数値 | X | 入出力
PASS_数 | 浮動小数点 | X | 出力
文字列0 | 文字列 | X | 入出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
FAIL | 浮動小数点 | X |  | 出力
PASS | 浮動小数点 | X |  | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
浮動小数点0 | 浮動小数点 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
整数値0 | 整数値 | X | X | 入出力
PASS_数 | 浮動小数点 | X | X | 出力
文字列0 | 文字列 | X | X | 入出力


円弧プロットツール

円弧プロットツールは、円弧の中心X、中心Y、半径、開始角度および範囲値を定義する数式に基づき画像上に円弧グラフィックスをプロットし、 円弧を定義する値を返します。

  1. 円弧プロットツールを設定するには
  2. 円弧プロットツールのパラメータを調整するには
  3. 円弧プロットツールの入出力プロパティを使用するには

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。


円弧プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円弧プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円弧プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [中心X」、[中心Y]、[半径]、[開始角度] および [範囲] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (円弧プロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円弧_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed 結果

ツール数式タブの結果を返します。円弧の X、Y、半径、開始角度および範囲値を表示します。


[中心 X]、[中心 Y]、[半径]、[開始角度] および [範囲] 数式タブ (円弧プロットツール)

円弧プロットツールには、[中心X]、[中心Y]、[半径]、[開始角度] および [範囲] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


円弧プロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
円弧.半径 | 浮動小数点 | X | 出力
円弧.範囲 | 浮動小数点 | X | 出力
円弧.開始角度 | 浮動小数点 | X | 出力
円弧.X | 浮動小数点 | X | 出力
円弧.Y | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
円弧.半径 | 浮動小数点 | X | X | 出力
円弧.範囲 | 浮動小数点 | X | X | 出力
円弧.開始角度 | 浮動小数点 | X | X | 出力
円弧.X | 浮動小数点 | X | X | 出力
円弧.Y | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


円プロットツール

円プロットツールは、円の X、Y および半径の値を定義する数式に基づき画像上に円グラフィックスをプロットし、 円を定義する値を返します。

  1. 円プロットツールを設定するには
  2. 円プロットツールのパラメータを調整するには
  3. 円プロットツールの入出力プロパティを使用するには

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。


円プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


円プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

円プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y] および [半径] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (円プロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は円_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed 結果

ツール数式タブの結果を返します。円の X、Y、および半径の値を表示します。


[X]、[Y] および [半径] 数式タブ (円プロットツール)

円プロットツールには、[X]、[Y] および [半径] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


円プロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
円.半径 | 浮動小数点 | X | 出力
円.X | 浮動小数点 | X | 出力
円.Y | 浮動小数点 | X | 出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


十字プロットツール

十字プロットツールは、十字の X、Y および角度結果の値を定義する数式に基づき画像上に十字グラフィックスをプロットし、 十字を定義する値を返します。

  1. 十字プロットツールを設定するには
  2. 十字プロットツールのパラメータを調整するには
  3. 十字プロットツールの入出力プロパティを使用するには
注:
  • 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。
  • 十字プロットツールの出力は、他ツールのフィクスチャとして使用することができます。


十字プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


十字プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

十字プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y] および [角度結果] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (十字プロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は十字_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed 結果

ツール数式タブの結果を返します。円の X、Y、および角度結果の値を表示します。


[X]、[Y] および [角度結果] 数式タブ (十字プロットツール)

十字プロットツールには、[X]、[Y] および [角度結果] タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


十字プロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | 出力
フィクスチャ.X | 浮動小数点 | X | 出力
フィクスチャ.Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フィクスチャ.角度結果 | 浮動小数点 | X | X | 出力
フィクスチャ.X | 浮動小数点 | X | X | 出力
フィクスチャ.Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


ラインプロットツール

ラインプロットツールは、ラインの始点 X、始点 Y、終点 X および終点 Y 値を定義する数式に基づき画像上にライングラフィックスをプロットし、 ラインを定義する値を返します。

  1. ラインプロットツールを設定するには
  2. ラインプロットツールのパラメータを調整するには
  3. ラインプロットツールの入出力プロパティを使用するには

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。


ラインプロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ラインプロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ラインプロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [始点X]、[始点Y]、[終点X] および [終点Y] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (ラインプロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はライン_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed 結果

ツール数式タブの結果を返します。ラインの始点/終点の X、Y 値を表示します。


[始点X]、[始点Y]、[終点X] および [終点Y] 数式タブ (ラインプロットツール)

ラインプロットツールには、[始点X]、[始点Y]、[終点X] および [終点Y] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


ラインプロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
ライン.終点_X | 浮動小数点 | X | 出力
ライン.終点_Y | 浮動小数点 | X | 出力
ライン.始点_X | 浮動小数点 | X | 出力
ライン.始点_Y | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ライン.終点_X | 浮動小数点 | X | X | 出力
ライン.終点_Y | 浮動小数点 | X | X | 出力
ライン.始点_X | 浮動小数点 | X | X | 出力
ライン.始点_Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


点プロットツール

点プロットツールは、点の X および Y 値を定義する数式に基づき画像上に点グラフィックスをプロットし、 点を定義する値を返します。

  1. 点プロットツールを設定するには
  2. 点プロットツールのパラメータを調整するには
  3. 点プロットツールの入出力プロパティを使用するには

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。


点プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


点プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

点プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X] および [Y] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (点プロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は点_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed 結果

ツール数式タブの結果を返します。点の X および Y 値を表示します。


[X] および [Y] 数式タブ (点プロットツール)

点プロットツールには、[X] および [Y] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


点プロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
点.X | 浮動小数点 | X | 出力
点.Y | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
点.X | 浮動小数点 | X | X | 出力
点.Y | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


領域プロットツール

領域プロットツールは、領域の X、Y、高さ、幅、角度結果およびカーブ値を定義する数式に基づき画像上に領域グラフィックスをプロットし、 領域を定義する値を返します。

  1. 領域プロットツールを設定するには
  2. 領域プロットツールのパラメータを調整するには
  3. 領域プロットツールの入出力プロパティを使用するには

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。


領域プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


領域プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

領域プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (領域プロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は領域_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed 結果

ツール数式タブの結果を返します。領域の X、Y、高さ、幅、角度およびカーブ値を表示します。


[X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブ (領域プロットツール)

領域プロットツールには、[X]、[Y]、[高さ]、[幅]、[角度] および [カーブ] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。[X] 数式タブは領域の第 1 頂点の位置を定義し、[Y] 数式タブは、その他の頂点を定義します。[高さ] 数式タブは X 軸 (+)、[幅] 数式タブは Y 軸 (+) の領域の距離を定義します。[角度] 数式タブは X 軸 (+) から領域の最初の境界までの領域の角度を定義します。[カーブ] 数式タブは領域の両端の境界の間の角度を定義します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


領域プロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


文字列プロットツール

文字列プロットツールは、文字列の X および Y 値を定義する数式に基づき画像上に文字列グラフィックスをプロットし、 文字列の X/Y 位置を定義する値を返します。

  1. 文字列プロットツールを設定するには
  2. 文字列プロットツールのパラメータを調整するには
  3. 文字列プロットツールの入出力プロパティを使用するには

注: 結果はピクセルで表示されます。ただし、[画像の設定] アプリケーションステップでキャリブレーションを行うか (In-Sight ビジョンシステムに接続している場合)、あるいは [FOV (幅)] コントロールを使用した場合 (In-Sight 2000-23M ビジョンセンサに接続している場合)、その単位で表示されます。


文字列プロットツールを設定するには

ツールを追加したら、グラフィックスを定義する数式を作成します。

  1. 設定ペインの左側からグラフィックスを定義する演算関数を、右側から値 (ツール/ジョブデータ) を選択してから入力し、式を作成します。[式] エディタに入力するには、関数または値を選択してから Enter キーを押すか、ダブルクリックするか、または[挿入] ボタンを押します。
  2. EasyBuilder がデータを処理し、グラフィックスを作成します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


文字列プロットツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

領域プロットツールのツール設定ペインには、次のコントロールが表示されます。

  • [全般] および [設定] タブ
  • [X]、[Y] および [文字列] 数式タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] および [設定] タブ (文字列プロットツール)

Closed [全般] タブ
Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は文字列_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。

Closed [設定] タブ
Closed 結果

ツール数式タブの結果を返します。文字列およびその X および Y 値を表示します。

Closed カラー

表示グラフィックスのカラーを定義します。ジョブで現在他ツールによって使用されているカラーが、デフォルトとなります。

Closed フォント名

文字列グラフィックスに使用するフォントタイプを定義します。デフォルトは、Arial です。

Closed フォントスタイル

文字列グラフィックスに使用するフォントスタイル (標準、斜体、太字、太字 斜体) を定義します。デフォルトは、標準です。

Closed フォントサイズ

文字列グラフィックスに使用するフォントサイズを定義します。デフォルトは、9 ポイントです。


[X]、[Y] および [文字列] 数式タブ (文字列プロットツール)

文字列プロットツールには、[X]、[Y] および [文字列] 数式タブが表示され (タブ内のコントロールはすべて同じです)、プロットしたグラフィックスを作成します。数式タブがエラー状態 (#ERR) にある場合、画像上にグラフィックスはプロットされず、数式タブにエラーがあることを示すメッセージが返されます。

注: これらのコントロールは、In-Sight ビジョンシステムオンライン時には、無効となります。

Closed 式

[式] テキストボックスを使用して、ツール結果およびデータを処理する数式を作成します。演算関数の名前またはジョブ/ツールデータをキーボードで入力するか、あるいは左側のビジョンツールツリー、演算関数ツリー、文字列関数ツリーおよびビジョンデータアクセスツリー、または右側のジョブ/ツールデータシンボルツリーを使用して、数式を作成します。アイテムを入力するには、ダブルクリックするか、またはハイライトしてから [挿入] ボタンを押します。

注:
  • [式] が参照するツールが削除されている場合、自動的に「Job.MissingArg」が数式に表示されます。参照が修正されるまで、ツールは FAIL を返します。
  • 式を作成する場合に、EasyBuilder はセルアドレス (例: A3_MyTool または P10_SortTool) で始まるツール名を正しく解析できません。これらのツール用に式を作成する場合、式を作成する前にツールの名前を変更してください。
Closed ビジョンツール

ビジョンツールツリーに含まれるエッジ関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [エッジ] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [エッジ] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 演算関数ツリー

演算関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [数値演算] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [数値演算] を展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed 文字列関数ツリー

文字列関数ツリーに含まれる演算関数を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [文字列関数] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [文字列関数] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。

注: 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。

Closed ビジョンデータアクセス

ビジョンデータアクセスツリーに含まれる追加データ (デフォルトでは使用できません) を使用して、[式] を作成します。次の 3 つの方法で、[式] に関数を追加することができます。

  • [ビジョンデータアクセス] ツリーを展開し、使用する関数を選択してから、[挿入] ボタンを押します。
  • [ビジョンデータアクセス] ツリーを展開し、使用する関数をダブルックリックします。
  • [式] テキストボックスに、使用する関数の名前をキーボードで直接入力します。
注:
  • 使用可能な関数は、[式] 中のカーソル位置により異なります。[式] 中、関数を追加できない位置にカーソルがある場合は、関数は無効となります。有効にするには、関数の追加が可能な位置にカーソルを動かしてください。
  • EasyBuilder でサポートしているのは、ブロブ、エッジおよびパターンビジョンデータアクセス関数のみです。
Closed ジョブ/ツールデータシンボルツリー

ジョブ/ツールデータシンボルツリーには、位置決めおよび検査ツール、入力ライン、ジョブデータ (画像取り込みパラメータなど) の出力データが含まれます。 ジョブ/ツールデータは、データに含まれる値のシンボル参照です。 次の 3 つの方法で、[式] にシンボルを追加することができます。

  • ツリーを展開し、使用するシンボル参照を選択しから、[挿入] ボタンを押します。
  • ツリーを展開し、使用するシンボル参照をダブルックリックします。
  • [式] テキストボックスに、使用するシンボル参照の名前をキーボードで入力します。

注: 使用可能なシンボルは、[式] 中のカーソル位置により異なります。 [式] 中、シンボルを追加できない位置にカーソルがある場合は、シンボルは無効となります。有効にするには、シンボルの追加が可能な位置にカーソルを動かしてください。

Closed [挿入] ボタン

[挿入] ボタンを使用して、演算関数およびシンボルを [式] に入力することができます。使用する演算関数またはシンボルを選択し、[挿入] ボタンを押して、関数またはシンボルを [式] に追加します。

注: このコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、[挿入] ボタンは有効となります。

Closed 左括弧、コンマ (,) 、右括弧ボタン

[ (] (左括弧) 、[,] (コンマ) および[) ] (右括弧) ボタンを使用して、数式を作成します。適切なボタンを押して、数式に追加してください。

注: これらのコントロールは、演算関数ツリーおよびジョブ/ツールデータシンボルツリーに連動しています。リストから選択したアイテムが、[式] テキストボックス中のカーソル位置に追加可能な場合、ボタンは有効となります。


文字列プロットツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
カラー | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
結果 | 文字列 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
カラー | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


フィルタ画像フィルタツール

注: このツールは、In-Sight 5.1.0 以降を搭載している In-Sight ビジョンシステムでのみ使用可能です。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

フィルタ画像フィルタツールは、画像の一部または画像の全体領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めツールまたは検査ツールによって参照することができます。

フィルタ画像フィルタツールは多目的フィルタで、低コントラスト画像や画像内の特徴を強調するのに使用する、カラーまたはグレースケール出力画像を生成します。このツールは、検出したい特徴を強調したり、不要な特徴を最小にしたりするのに有効です。効果的に使用することによって、検査アプリケーションの信頼性・再現性を高めることができます。

フィルタ画像フィルタツールでは、さまざまな画像フィルタを使用することができます。[フィルタタイプ] から、使用するフィルタを選択してください。

  1. フィルタ画像フィルタツールを設定するには
  2. フィルタ画像フィルタツールのパラメータを調整するには
  3. フィルタ画像フィルタツールの入出力プロパティを使用するには


フィルタ画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


フィルタ画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

フィルタ画像フィルタツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (フィルタ画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (フィルタ画像フィルタツール)

Closed フィルタタイプ

領域に適用する画像フィルタを定義します。選択後、領域内の画像は自動的に更新されます。

注: 各フィルタタイプの詳細については、[フィルタ] トピックをご参照ください。

フィルタタイプ | 説明
2 値化 (デフォルト)

グレースケールしきい値を元に画像にフィルタをかけ、白 (255) または黒 (0) のどちらになるかを判定します。しきい値以上の入力ピクセル値は白に、しきい値を下回る値は黒になります。

注: カラー入力画像が使用される場合、出力画像はグレースケール画像となります。
ボトムハット

フィルタサイズより小さい暗い特徴以外のすべてにフィルタをかけます。暗い特徴が明るいピクセルで表示され、背景が暗く表示された画像を出力します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
クリップ

入力ピクセルのグレースケール値と最小値および最大値を比較し、画像にフィルタをかけます。グレースケールスペクトルの両端を除去し、特徴がより均一な画像を出力します。
クローズ

フィルタサイズより小さい黒い特徴にフィルタをかけます。全体的な明度がわずかに高くなった画像を出力します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
膨張

明るい特徴を拡大し、暗い特徴を縮小します。明るいピクセルがより大きな領域を占める画像を出力します。このフィルタは、暗い斑点の除去に有用です。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
エッジ強調

明るい特徴と暗い特徴にフィルタをかけます。明るいピクセルでエッジを表示した画像を出力します。この操作は、対角線方向のエッジを表現できますが、「勾配 全方向」より実行時間が長くなります。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
等化 | ヒストグラム平坦化 (最も多いグレースケール値を平坦化して、分布をより均一にする) に基づいて画像にフィルタをかけます。コントラストが強められた画像を出力します。
収縮

明るい特徴を縮小し、暗い特徴を拡大します。暗いピクセルがより大きな領域を占める画像を出力します。このフィルタは、明るい斑点の除去に有用です。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
黒穴塗りつぶし | 明るいピクセルで囲まれた暗いピクセルを明るいピクセルに変換します。暗い穴が埋められた画像を出力します。
白穴塗りつぶし | 暗いピクセルで囲まれた明るいピクセルを暗いピクセルに変換します。明るい穴が埋められた画像を出力します。
勾配 全方向 | 垂直方向および垂直方向のエッジ特徴にフィルタをかけます。垂直方向および垂直方向のエッジが明るいピクセルで表示された画像を出力します。この操作は対角線方向のエッジは表現しませんが、「エッジ強調」操作より実行時間が短くなります。
勾配 水平方向 | 水平方向のエッジ特徴にフィルタをかけます。水平方向のエッジが明るいピクセルで表示された画像を出力します。
勾配 垂直方向 | 垂直方向のエッジ特徴にフィルタをかけます。垂直方向のエッジが明るいピクセルで表示された画像を出力します。
グレースケール距離

各出力ピクセルのグレースケール値を、各入力ピクセルのグレースケール値としきい値レベルの差としてフィルタをかけます。例えば、入力ピクセル値が 100 で、しきい値が 25 の場合、出力ピクセルは 75 となります。
ハイパス

エッジ特徴にフィルタをかけ、そのほかの特徴を抑制します。むらのないグレースケール勾配を持つ領域に対し、相対的にエッジが強調された画像を出力します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
反転 | ピクセル値のグレースケール反転を基にフィルタをかけます。入力画像の「ネガティブ」状態の画像を出力します。
ローカル中央値

近傍カーネル内のピクセル値の中央ピクセル値を計算し、その結果を出力画像のピクセル値に使用します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
正規化したローカル中央値

画像から背景を減算します。この操作は、入力画像から入力画像のローカル中央値を減算し、結果を右に 1 つシフトし、128 を加算して出力ピクセル値を生成します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
ローパス

エッジ特徴を除去し、ほかの特徴を使用してエッジをぼやかします。エッジが「平滑化」された、またはぼやけた画像を出力します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
最大 (トップハット/ボトムハット)

トップハットおよびボトムハット操作の最大値を使用します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
オープン

フィルタサイズより小さい明るい特徴にフィルタをかけます。全体的な輝度がわずかに低くなった画像を出力します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
光密度

対数目盛に基づく、ピクセル値の反転を指定します。対象物と特徴を通り抜ける光の量を測定し、その密度を明らかにする画像を出力します。対象物と特徴の密度が高いほど、出力画像ではより明るいピクセルで表示されます。
シャープ

エッジ強調に使用する「シャープネス」操作を行います。隣接ピクセル間のコントラストを評価し、高コントラストの場合、コントラストを上げます。隣接ピクセル間の大きなコントラスト差は、通常エッジを表します。しかし、この操作はローカルエッジの検出ために使用されるべきではありません。この操作の効果は、画像コンテンツおよび解像度によって異なります。

  • [ゲイン] パラメータは、シャープネスの強度を決定します。ピクセル間の一定の差を無視することによって、軽い陰影のあるエリアを過度にシャープしてしまうことを防ぎます。
引き伸ばし | グレースケール値を線状に拡大縮小したり、または「引き伸ばし」することにより、フィルタをかけます。コントラストが強められた画像を出力します。
しきい値範囲

各入力ピクセルを、2 つのしきい値 (最小値と最大値) で比較し、出力ピクセルが白または黒のどちらになるかを判定する、2 値化 (白黒) しきい値に基づいてフィルタをかけます。入力ピクセル値が最小値または最大値と等しいか、またはそれを超える場合、出力ピクセルは白となります。入力ピクセル値が最小値と最大値の間にある場合、出力ピクセルは黒となります。
トップハット

フィルタサイズより小さい明るい特徴以外のすべてにフィルタをかけます。暗い背景に、明るい特徴が明るいピクセルで表示された画像を出力します。

注: [カーネル行] および [カーネル列] パラメータを ON にします。カーネルは、奇数の整数である必要があります。
Closed カーネル行

カーネル行数を指定します。(1–25: デフォルト = 3) カーネルとは長方形の数配列のことで、画像の各ピクセル位置に対して近傍処理操作を行います。ピクセルの近傍グレースケール値は、出力画像上のピクセル位置のグレースケール値を定義します。

注:

  • カーネルは非加重です。

  • カーネルは、奇数の整数である必要があります。通常、カーネルは 3 ✕ 3 ですが、そのサイズは任意です。

このパラメータは、フィルタが次のタイプに設定されている場合に、ON になります。

  • ボトムハット
  • クローズ
  • 膨張
  • エッジ強調
  • 収縮
  • ハイパス
  • ローカル中央値
  • 正規化したローカル中央値
  • ローパス
  • 最大 (トップハット/ボトムハット)
  • オープン
  • トップハット
Closed カーネル列

カーネル列数を指定します。(1–25: デフォルト = 3) カーネルとは長方形の数配列のことで、画像の各ピクセル位置に対して近傍処理操作を行います。ピクセルの近傍グレースケール値は、出力画像上のピクセル位置のグレースケール値を定義します。

注:

  • カーネルは非加重です。

  • カーネルは、奇数の整数である必要があります。通常、カーネルは 3 ✕ 3 ですが、そのサイズは任意です。

このパラメータは、フィルタが次のタイプに設定されている場合に、ON になります。

  • ボトムハット
  • クローズ
  • 膨張
  • エッジ強調
  • 収縮
  • ハイパス
  • ローカル中央値
  • 正規化したローカル中央値
  • ローパス
  • 最大 (トップハット/ボトムハット)
  • オープン
  • トップハット
Closed しきい値モード

[フィルタタイプ] を [2 値化]、[グレースケール距離] または [しきい値範囲] に設定した場合に、しきい値レベルを自動的に設定するかどうかを指定します。

  • 手動: [しきい値] パラメータを ON にし、しきい値を手動で設定します。
  • 自動 (デフォルト):
    • [フィルタタイプ] を [2 値化] に設定した場合に、指定領域内のグレースケール値に基いて、しきい値レベルを自動的に設定します。
    • [フィルタタイプ] を [グレースケール距離] に設定した場合に、指定領域内の平均グレースケール値に基いて、しきい値レベルを自動的に計算します。
    • [フィルタタイプ] を [しきい値範囲] に設定した場合に、次の操作が自動的に行われrます。
      • ピクセル値が [最小] パラメータ設定より小さい場合、あるいはピクセル値が [最大] パラメータ設定より大きい場合、ピクセル値は背景に設定されます。
      • ピクセル値が [最小] および [最大] パラメータ設定の範囲内にある場合、 ピクセル値は前景に設定されます。
Closed しきい値

[フィルタタイプ] を [2 値化]、[グレースケール距離] または [しきい値範囲] に設定した場合に、しきい値レベルを自動的に設定します (0～255; デフォルト = 128) 。

Closed 最小

[フィルタタイプ] を [クリップ]、[引き伸ばし] または [しきい値範囲] に設定した場合に、最小グレースケール値を指定します (0～255; デフォルト = 128) 。

Closed 最大

[フィルタタイプ] を [クリップ]、[引き伸ばし] または [しきい値範囲] に設定した場合に、最大グレースケール値を指定します (0～255; デフォルト = 128) 。

Closed ゲイン

[フィルタタイプ] を [シャープ] に設定した場合に、ゲイン値を指定します (0～10; デフォルト = 1) 。 このパラメータは、エッジコントラストの強度を制御することによって、シャープネス強度を決定します。エッジ周囲のピクセルはその最小値または最大値により、エッジをよりシャープにします。

Closed スムーズネス

[フィルタタイプ] を [シャープ] に設定した場合に、ガウス (ガウシアン) カーネルのスムーズネス値を指定します (1～4; デフォルト = 1) 。スムーズネスは、ガウス (ガウシアン) カーネルの標準偏差を制御します。高スムーズネス値は、スムーズ操作では広い「絞り」となり、特徴をシャープにするのに役立ちます。

注:
  • ガウス (ガウシアン) とは釣鐘型の曲線のことを指し、ROI 内のピクセルに加重平均を適用します。


フィルタ画像フィルタツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
領域 | 動作 |  | X |
ツール有効 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
フィルタタイプ | 整数値 | X | X | 入出力
カーネル行 | 整数値 | X | X | 入出力
カーネル列 | 整数値 | X | X | 入出力
しきい値 | 整数値 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
ゲイン | 浮動小数点 | X | X | 入出力
スムーズネス | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
PASS | 整数値 | X |  | 出力
FAIL | 整数値 | X |  | 出力
ステータス | 整数値 | X | X | 出力
ツール有効ステータス | 整数値 | X | X | 出力
PASS_数 | 整数値 | X | X | 出力
FAIL_数 | 整数値 | X | X | 出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力


輝度画像フィルタツール

注: このツールは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

輝度画像フィルタツールは、各ピクセルに「グローバルな」画像強調技術 (2 値化、反転、ヒストグラム平坦化、クリッピングまたはグレースケール伸長など) を使用して、画像領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

「グローバルな」画像強調操作では、ツール領域にある個々のグレースケール値に基づいて、出力ピクセルにグレースケール値を割り当てます。

輝度画像フィルタツールは、OCR 文字をより正確に読み取るために表面からホットスポットをクリッピングしたり、コントラストを強調するために検査対象物の特徴を引き伸ばしたりするなど、特徴をより正確に検査するために画像領域を強調する場合に有用です。

  1. 輝度画像フィルタツールを設定するには
  2. 輝度画像フィルタツールのパラメータを調整するには
  3. 輝度画像フィルタツールの入出力プロパティを使用するには


輝度フィルタ画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ツール画像 (画像フィルタツールおよびカラーツール)

画像フィルタツール (フィルタ、近傍、輝度、シーン補正、カラーからグレースケール変換、カラーから二値化変換、変換、および比較) およびカラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) の出力画像を、位置決めおよび検査ツールのツール画像として使用することができます。

[ツール画像] パラメータは、[ツール画像] を出力するジョブがツールに追加された後に、ツールの [全般] タブに表示されます。すべてのツールは、取り込み画像以外にも、ツール画像を入力画像として使用することができます。ツール画像は、[使用法] 設定ペインでドロップダウンメニューからも選択することができます。

位置決めまたは検査ツールの [ツール画像] パラメータを、ツール画像を出力するツールに設定した場合 (画像フィルタツールは、他の画像フィルタを入力画像として使用することができます) 、これらのツールはフィルタ画像を使用して検査を実行します。このとき、ツール領域は、ツール画像領域を出力するツール内に含まれる必要があります。

[ツール画像] パラメータを画像フィルタツールに設定するには、画像フィルタツールを追加してから、追加済みツールの [全般] タブに戻り、[ツール画像] ドロップダウンリストから、画像フィルタツール (例: フィルタ_1.画像) を選択します。

注: [ツール画像] を出力する画像フィルタツールまたはカラーツールをジョブに追加した後、取り込み画像以外の画像を入力画像としてサポートするツールをジョブに追加するたびに、設定ペインの [使用法] グループボックスで、ツールの入力画像を設定する必要があります。デフォルトは、現在取り込んでいる、フィルタなし画像 ([カメラ画像]) となります。


輝度フィルタ画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

輝度フィルタ画像フィルタツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • [フィルタ前]/[フィルタ後] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (輝度フィルタ画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (輝度フィルタ画像フィルタツール)

Closed 操作

領域に適用する画像強調技術を定義します。選択後、領域は自動的に更新されます。

操作 | 説明
2 値化 (デフォルト) | グレースケールしきい値を元に画像にフィルタをかけ、白 (255) または黒 (0) のどちらになるかを判定します。しきい値以上の入力ピクセル値は白に、しきい値を下回る値は黒になります。
クリップ | 入力ピクセルのグレースケール値と最小値および最大値を比較し、画像にフィルタをかけます。グレースケールスペクトルの両端を除去し、特徴がより均一な画像を出力します。
等化 | ヒストグラム平坦化 (最も多いグレースケール値を平坦化して、分布をより均一にする) に基づいて画像にフィルタをかけます。コントラストが強められた画像を出力します。
グレースケール距離 | 各出力ピクセルのグレースケール値を、各入力ピクセルのグレースケール値としきい値レベルの差としてフィルタをかけます。例えば、入力ピクセル値が 100 で、しきい値が 25 の場合、出力ピクセルは 75 となります。
反転 | ピクセル値のグレースケール反転を基にフィルタをかけます。入力画像の「ネガティブ」状態の画像を出力します。
しきい値範囲 | 各入力ピクセルを、2 つのしきい値 (最小値と最大値) で比較し、出力ピクセルが白または黒のどちらになるかを判定する、2 値化 (白黒) しきい値に基づいてフィルタをかけます。入力ピクセル値が最小値または最大値と等しいか、またはそれを超える場合、出力ピクセルは白となります。入力ピクセル値が最小値と最大値の間にある場合、出力ピクセルは黒となります。
光密度 | 対数メモリ上のピクセル値の反転に基づきフィルタをかけます。対象物と特徴を通り抜ける光の量を測定し、その密度を明らかにする画像を出力します。対象物と特徴の密度が高いほど、出力画像ではより明るいピクセルで表示されます。
引き伸ばし | グレースケール値を線状に拡大縮小したり、または「引き伸ばし」することにより、フィルタをかけます。コントラストが強められた画像を出力します。
Closed 最小

[クリップ] または [しきい値範囲] 操作の最小グレースケール値 (0～255) を指定します。このコントロールは、この 2 つの操作のどちらかが選択されている場合のみ、有効になります。

Closed 最大

[クリップ] または [しきい値範囲] 操作の最大グレースケール値 (0～255) を指定します。このコントロールは、この 2 つの操作のどちらかが選択されている場合のみ、有効になります。

Closed しきい値モード

[2 値化]、[グレースケール距離] または [しきい値範囲] を選択した場合に、画像領域を白黒のピクセルに切り分けるグレースケール値を決める方法を指定します。[自動] (デフォルトは [自動]) を選択した場合、画像取り込みのたびにツールは画像に基づいてスマートセッティングを作成し、画像間の輝度の変化を調整します。[手動] を選択した場合、値を手動で入力、調整してください。

Closed [しきい値]

[2 値化] または [グレースケール] 演算を選択した場合に、白ピクセルを黒ピクセルから切り分けるグレースケール値 (0～255) を定義します。しきい値以下のピクセル値は黒となり、しきい値以上のピクセルは白となります。このコントロールは通常グレーアウトされています。有効にするには [しきい値モード] を [手動] に設定してください。グラフを参考にして、最適な値を設定してください。


[フィルタ前]/[フィルタ後] タブ (輝度フィルタ画像フィルタツール)

[フィルタ前]/[フィルタ後] タブは、領域内にあるピクセルのグレー値をヒストグラムで表したものです。[フィルタ前] タブには、画像処理前の画像領域のヒストグラムが表示されます。一方、[フィルタ後] タブには、画像処理を実行した後の画像領域のヒストグラムが表示されます。

  • グラフの横軸は、256 階調のグレー値 (0～255) を表します。
  • グラフの縦軸は、各グレー値を持つピクセルの数を表します。縦軸のスケールは、最も大きなピクセル数を基準に調整されます。
  • 緑の垂直線は、画像の黒い部分と白い部分を切り分けるしきい値を表します。垂直線より左側が黒、右側が白とみなすことができます。


輝度フィルタ画像フィルタツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大 | 整数値 | X | X | 入出力
最小 | 整数値 | X | X | 入出力
操作 | 整数値 | X | X | 入出力
しきい値 | 整数値 | X | X | 入出力
しきい値モード | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力


近傍画像フィルタツール

注: このツールは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

近傍画像フィルタツールは、各画像に「局所的」な画像強調技術 (縮小、拡大、塗りつぶし、平滑化またはエッジ強調など) を使用して、画像領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

「局所的」な画像強調操作では、ツール領域の「近傍」ピクセルのグレースケール値に基づいて、出力ピクセルにグレースケール値を割り当てます。「近傍」サイズを指定するには、[フィルタ行] および [フィルタ列] パラメータを使用します。

近傍画像フィルタツールは、ドットピーンコードをより正確に読み取るために、金属表面の反射を低減させたり、OCR 文字の読み取り時に、グレースケールスペクトルの白側の端を膨張して黒い点を取り除いたりするなど、特徴をより正確に検出するために、画像領域を強調する場合に有用です。

  1. 近傍画像フィルタツールを設定するには
  2. 近傍画像フィルタツールのパラメータを調整するには
  3. 近傍画像フィルタツールの入出力プロパティを使用するには


近傍フィルタ画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


近傍フィルタ画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

近傍フィルタ画像フィルタツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (近傍フィルタ画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (近傍フィルタ画像フィルタツール)

Closed 操作

領域に適用する画像強調技術を定義します。選択後、領域は自動的に更新されます。

操作 | 説明
ボトムハット | フィルタサイズより小さい暗い特徴以外のすべてにフィルタをかけます。暗い特徴が明るいピクセルで表示され、背景が暗く表示された画像を出力します。
クローズ | フィルタサイズより小さい特徴にフィルタをかけます。全体的な明度がわずかに高くなった画像を出力します。
膨張 | 明るい特徴を拡大し、暗い特徴を縮小します。明るいピクセルがより大きな領域を占める画像を出力します。このフィルタは、暗い斑点の除去に有用です。
エッジ強調 | 明るい特徴と暗い特徴にフィルタをかけます。明るいピクセルでエッジを表示した画像を出力します。この操作は、対角線方向のエッジを表現できますが、「勾配 全方向」より実行時間が長くなります。
収縮 | 明るい特徴を縮小し、暗い特徴を拡大します。暗いピクセルがより大きな領域を占める画像を出力します。このフィルタは明るい斑点の除去に有効です。
黒穴塗りつぶし | 明るいピクセルで囲まれた暗いピクセルを明るいピクセルに変換します。暗い穴が埋められた画像を出力します。
白穴塗りつぶし | 暗いピクセルで囲まれた明るいピクセルを暗いピクセルに変換します。明るい穴が埋められた画像を出力します。
勾配 垂直方向 | 垂直方向のエッジ特徴にフィルタをかけます。垂直方向のエッジが明るいピクセルで表示された画像を出力します。
勾配 水平方向 | 水平方向のエッジ特徴にフィルタをかけます。水平方向のエッジが明るいピクセルで表示された画像を出力します。
勾配 全方向 | 垂直方向および垂直方向のエッジ特徴にフィルタをかけます。垂直方向および垂直方向のエッジが明るいピクセルで表示された画像を出力します。この操作は対角線方向のエッジは表現しませんが、「エッジ強調」操作より実行時間が短くなります。
ハイパス | エッジ特徴にフィルタをかけ、そのほかの特徴を抑制します。むらのないグレースケール勾配を持つ領域に対し、相対的にエッジが強調された画像を出力します。
ローパス (デフォルト) | エッジ特徴を除去し、ほかの特徴を使用してエッジをぼやかします。エッジが「平滑化」された、またはぼやけた画像を出力します。
オープン | フィルタサイズより小さい明るい特徴にフィルタをかけます。全体的な輝度がわずかに低くなった画像を出力します。
トップハット | フィルタサイズより小さい明るい特徴以外のすべてにフィルタをかけます。暗い背景に、明るい特徴が明るいピクセルで表示された画像を出力します。
Closed フィルタ行

近傍処理を行う画像の水平方向のサイズを指定します (1～25; デフォルト = 3)。

Closed フィルタ列

近傍処理を行う画像の垂直方向のサイズを指定します (1～25; デフォルト = 3)。


近傍フィルタ画像フィルタツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
フィルタ行数 | 整数値 | X | X | 入出力
フィルタ列数 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
操作 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


シーン補正画像フィルタツール

注: このツールは、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

シーン補正画像フィルタツールは、ピクセルごとの「局所的」な画像強調技術 (「平均明度」と呼ばれます) を使用して画像の領域にフィルタをかけ、位置決めまたは検査ツールによって参照するツール画像を出力します。

「平均明度」画像強調技術は、取り込み行数および列数パラメータで定義される、近傍処理に使用するピクセル明度を基に画像にフィルタをかけます。このフィルタは、各ピクセルの明度を近傍処理に使用するピクセルの平均明度と比較して、むらのある照明または影を画像から除外するシミュレーションを実行します。ばらつきがない、あるいは少ない画像エリアは、元の明度に関わらず、ニュートラル (灰色) で表示されます。周囲のピクセルより黒いピクセルは、周囲よりもどれぐらい黒いかによって、ニュートラル (灰色) より黒い色で表示されます。同様に、周囲のピクセルより白いピクセルは、ニュートラル (灰色) より白い色で表示されます。エッジおよびシャープな遷移は、「ハイパス」操作同様、保持されます。

シーン補正画像フィルタツールは、画像内にむらのある照明や影がある場合に有用です。

  1. シーン補正画像フィルタツールを設定するには
  2. シーン補正画像フィルタツールのパラメータを調整するには
  3. シーン補正画像フィルタツールの入出力プロパティを使用するには


シーン補正画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


シーン補正画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

シーン補正画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (シーン補正画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (シーン補正画像フィルタツール)

Closed 取り込み行数

近傍処理を行う画像の水平方向のサイズを指定します (1～画像の最大の高さ; デフォルト = 11)。

注:
  • 最大値は、In-Sight ビジョンシステムの画像エリア (640 × 480, 1024 × 768 または 1600 × 1200 など) の最大サイズによって定義されます。
  • 近傍処理の画像サイズには、奇数のみが使用できます。偶数が入力されると、自動的に切り上げられます。
Closed 列数

近傍処理を行う画像の垂直方向のサイズを指定します (1–～画像の最大幅; デフォルト = 11)。

注:
  • 最大値は、In-Sight ビジョンシステムの画像エリア (640 × 480, 1024 × 768 または 1600 × 1200 など) の最大サイズによって定義されます。
  • 近傍処理の画像サイズには、奇数のみが使用できます。偶数が入力されると、自動的に切り上げられます。
Closed タイムアウト

ツールが画像の明度を計算する時間をミリ秒単位で定義します (0～30,000; デフォルト = 0)。この時間を過ぎると、計算は終了し、ツールは FAIL を返します。値を 0 に設定すると、パラメータは無効となります。


シーン補正画像フィルタツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
取り込み行数 | 整数 | X | X | 入出力
列数 | 整数 | X | X | 入出力
総合判定に含める | 整数 | X | X | 入出力
操作 | 整数 | X | X | 入出力
ツール有効 | 整数 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


カラーからグレースケール変換画像フィルタツール

カラーからグレースケール画像フィルタツールは、指定の操作に基づき、領域内のカラーピクセルをグレースケール値に変換し、画像の領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

カラーからグレースケール変換ツールは、「純色の」赤、緑、青 (RGB)、色相、彩度、明度 (HSI)、輝度、もしくは RGB 成分の加重平均の補間の、いずれか 1 つのカラーパラメータからなる単純なフィルタに基づいて、領域内の各カラーピクセルをグレースケール値に変換します。

  1. カラーからグレースケール画像フィルタツールを設定するには
  2. カラーからグレースケール変換画像フィルタツールのパラメータを調整するには
  3. カラーからグレースケール変換画像フィルタツールの入出力プロパティを使用するには


カラーからグレースケール変換画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーからグレースケール変換画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーからグレースケール変換画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーからグレースケール変換画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーからグレースケール変換画像フィルタツール)

Closed 操作
操作 | 説明
輝度 (デフォルト) | 輝度の出力画像です。概念上、輝度は明度に密接に関係しており、特定の領域から放射または反射される光の量の尺度です。入力画像でピクセルから放射される光が多いほど、出力画像での表示が明るくなります。
赤 | ピクセルの赤 (255,0,0) 以外の成分がフィルタで除去されます。入力画像のピクセルの赤の値が大きいほど、出力画像での表示が明るくなります。
緑 | ピクセルの緑 (0,255,0) 以外の成分がフィルタで除去されます。入力画像のピクセルの緑の値が大きいほど、出力画像での表示が明るくなります。
青 | ピクセルの青 (0,0,255) 以外の成分がフィルタで除去されます。入力画像のピクセルの青の値が大きいほど、出力画像での表示が明るくなります。
色相 | ピクセルの色相以外の成分がフィルタで除去されます。入力画像のピクセルの色相値が大きいほど、出力画像での表示が明るくなります。
彩度 | ピクセルの彩度以外の成分がフィルタで除去されます。入力画像のピクセルの彩度値が大きいほど、出力画像での表示が明るくなります。
明度 | ピクセルの明度以外の成分がフィルタで除去され、ピクセルの RGB 成分の平均輝度が判定されます。入力画像のピクセルの輝度値が大きいほど、出力画像での表示が明るくなります。
補間方法 | ピクセルの RGB (赤、緑、および青) 成分の加重平均である、補完を使用します。輝度フィルタと同様に、結果は、ピクセルの輝度以外の成分がフィルタで除去されます。入力画像のピクセルの輝度値が大きいほど、出力画像での表示が明るくなります。ただし、補間フィルタは RGB 成分の「加重」平均輝度を判定する、非標準の変換フィルタです。


カラーからグレースケール変換画像フィルタツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
操作 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


カラーから二値化変換画像フィルタツール

カラーから二値化変換画像フィルタツールは、有効なカラーモデルにマッチするピクセルを白に、それ以外のピクセルを黒に変換することにより、画像領域にフィルタをかけ、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

カラーから二値化変換ツールは、登録済みのカラーモデルライブラリを参照し、選択した登録済みのカラーモデルにマッチする領域内のピクセル数を決定します。ツールは、有効なカラーモデルにマッチするピクセルを白 (255) に、それ以外のピクセルを黒 (0) に設定する、二値化グレースケール出力画像を作成します。

  1. カラーから二値化変換画像フィルタツールを設定するには
  2. カラーから二値化変換画像フィルタツールのパラメータを調整するには
  3. カラーから二値化変換画像フィルタツールの入出力プロパティを使用するには


カラーから二値化変換画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. サーチ領域を設定したら、ツールの [カラーライブラリ] を設定し、使用する [カラーモデル] を有効にします。

  • カラーツール (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、カラーから二値化変換画像フィルタツール) を始めて追加した場合、まずカラーライブラリおよびカラーツールを定義する必要があります。

  • カラーツールがすでに追加されており、既存のカラーライブラリおよび登録済みのカラーモデルを使用したい場合は、[設定] タブでに戻って [カラーライブラリ] を選択してから、[ライブラリ] タブで使用する [カラーモデル] のチェックボックスを ON にします。

  • [カラーライブラリ] を定義するまで、ツール結果は自動的に FAIL となります (デフォルト)。[カラーライブラリ] を定義すると、ツールは自動的にライブラリを使用して、ライブラリに含まれる [カラーモデル] すべてを有効にします。

  4. [カラーモデル] および [カラーライブラリ] を設定したら、ツールは画像を処理します。選択した　[カラーモデル] に一致する、サーチ領域内のピクセルはすべて白くなり (255)、選択した [カラーモデル] にマッチしないピクセルはすべて黒くなります (0)。

  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


カラーから二値化変換画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

カラーから二値化変換画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • カラーライブラリ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (カラーから二値化変換画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はカラーフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (カラーから二値化変換画像フィルタツール)

Closed [カラーの登録] ボタン

[ExtractColor 登録] ダイアログを開きます。選択したカラーライブラリのカラーモデルを定義するのに使用します。

Closed カラーライブラリ

ツールが参照するカラーライブラリを定義します。ドロップダウンリストから、変更するカラーライブラリを選択し、[カラーの登録] ボタンを押すと、[ExtractColor 登録] ダイアログが開きます。各カラーライブラリには、それぞれ個別の色からなる最大 100 個のカラーモデルを含めることができます。

EasyBuilder ジョブには、最大 5 個のカラーライブラリを含むことができます。また、カラーライブラリは以下のツールと共有することができます。

  • カラーブロブ位置決めツール
  • カラーブロブ (1-10) 位置決めツール
  • カラーピクセル計数有無判定ツール
  • カラーブロブ面積寸法測定ツール
  • カラーブロブ面積 (1-10) 寸法測定ツール
  • カラーブロブ計数ツール
  • カラーモデル識別ツール
  • カラーから二値化変換画像フィルタツール


カラーライブラリ (カラーから二値化変換画像フィルタツール)

Closed [カラーモデル] リスト

選択したカラーモデルに含まれる、カラーモデルリスト (読み取り専用) を表示します。カラーモデル名の横にあるチェックボックスを ON または OFF にすることによって、カラーモデルを有効にしたり、無効にすることができます。

Closed カラーテーブル

選択した [カラーモデル] に含まれるカラーのテーブルを表示します (読み取り専用)。

Closed カラー名

選択したカラーモデルに含まれるカラー名を表示します。

Closed RGB

選択したカラーモデルに含まれるカラーの RGB 値を表示します。

Closed 操作

選択したカラーモデルに含まれるカラー操作 (追加または減算) を表示します。


カラーから二値化変換画像フィルタツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

注: カラーツール (カラーブロブおよびカラーブロブ (1-10) 位置決めツール、カラーピクセル計数およびカラーブロブ有無判定ツール、カラーブロブ面積およびカラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツールまたはカラーからニ値化変換画像フィルタツール) が追加されると、定義済みカラーライブラリの名前が自動的に表示され、そのプロパティが OPC、EasyView または入出力データの選択ダイアログに含まれます。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
カラーライブラリ | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部モデル有効の適用 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
モデル有効 | 整数値 | X | X | 入出力
モデル有効の選択 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
Status | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
モデル有効の適用 | 動作 | X | X |
領域 | 動作 | X | X |

ExtractColorLibrary_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
登録イベント | 動作 | X | X | 入出力
登録モデル | 文字列 | X | X | 入出力
登録手順 | 整数値 | X | X | 入出力
登録処理 | 整数値 | X | X |
登録領域 | 動作 | X | X |

MatchColorLibrar_1～5 プロパティ

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
暗限界 | 浮動小数点 | X | X | 入出力
明限界 | 浮動小数点 | X | X | 入出力
カラーの登録 | 文字列 | X | X | 入出力
登録イベント | 動作 | X | X |
登録領域 | 動作 | X | X |


変換画像フィルタツール

変換画像フィルタツールは、画像領域の線形や非線形、レンズの歪みにフィルタをかけ、[画像の設定] ステップの[グリッド] キャリブレーションを使用して、実単位とピクセル間の変換を適用し、ツール画像を出力します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

変換画像フィルタツールは、[画像の設定] ステップの [グリッド] キャリブレーションと連動して使用します。このツールは、光学歪みを補正 (画像を「変換」) して、非常に正確な計測値を返し、ピクセル単位を、ミリメートルやインチなどの実世界の測定単位に変換します。このツールと [グリッド] キャリブレーションを使用して、画像の周辺部にある対象物をより正確に検出することができます。また、In-Sight ビジョンシステムを検査面に対して最大 45 度の角度で取り付けることができるなど、柔軟な設置が可能になります。

  1. 変換画像フィルタツールを設定するには
  2. 変換画像フィルタツールのパラメータを調整するには
  3. 変換画像フィルタツールの入出力プロパティを使用するには


変換画像フィルタツールを設定するには

注: このツールを追加する前に、[画像の設定] ステップで [グリッド] キャリブレーションを実行してください。

ツールを追加し、強調したい画像エリアに検査領域を設定します。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


変換画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

変換画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (変換画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名は変換_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (変換画像フィルタツール)

Closed 画像スケール

変換後の画像の表示スケールを定義します (0.01～10、デフォルトは 1.0)。

Closed 基準点

変換に使用される基準点を指定します。[画像の中心] (デフォルト) では、基準点は画像の中心になります。[領域の中心] では、基準点は領域の中心になります。

Closed 画像の表示

取り込み画像の代わりに、変換された画像を表示するかどうかを定義します。デフォルトでは、パラメータは ON (有効) で、変換された画像が常に表示されます。

注: 他の位置決めまたは検査ツールが、変換フィルタを適用した画像ではなく、取り込み画像を使用して検査を実行している可能性があると、グラフィックスオーバーレイが、変換された画像とは関係なく表示されることがあります。その場合、[ジョブの実行] ステップで [グラフィックスの表示] オプションを OFF にして、これらのツールのグラフィックスオーバーレイを非表示にすることができます。


変換画像フィルタツールの入出力パラメータを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
エッジ範囲 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ピクセル比較 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAILI | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
比較 | 動作 | X | X |
領域 | 動作 | X | X |
登録 | 動作 | X | X |


比較画像フィルタツール

比較画像フィルタツールは、入力画像とテンプレート画像を比較し、各ピクセルが正規化された差を表すグレースケール出力画像を生成します。ツール画像は、位置決めまたは検査ツールによって参照することができます。

『比較』画像強調プロセスでは、テンプレートのピクセルを入力画像にマッピングして入力画像とテンプレートを比較し、グレースケール出力画像を生成します。テンプレート画像と一致しないピクセルは、白ピクセルとして表示されます。

比較画像フィルタツールは、製造工程中に検査対象またはその一部の傷を検出したい場合などに有用です。例えば、比較画像フィルタツールに、傷のない検査対象またはその一部を登録してから、登録画像と取得した画像を比較します。ブロブ計数ツールなど、その他のツールが、比較画像フィルタツールが出力したツール画像に対して検査を実行します。ブロブ計数ツールのロジックを反転させておくと、ブロブが検出されない場合はツールは PASS を返し、ブロブを検出した場合は FAIL を返します。

  1. 比較画像フィルタツールを設定するには
  2. 比較画像フィルタツールのパラメータを調整するには
  3. 比較画像フィルタツールの入出力プロパティを使用するには


比較画像フィルタツールを設定するには

ツールを追加し、強調したい画像エリアに検査領域を設定します。

注: このツールは、画像中に背景ノイズが存在しない場合に、最も性能を発揮します。また、各画像は、検査対象またはその一部がほぼ同じ場所に存在するなど、ほぼ同一にするようにしてください。また、傷がある場合は、顕著で大きい必要があります。画像にノイズがある場合、輝度フィルタ画像フィルタツールを使用し、2 値化操作を実行して、画像中のグレースケール差を取り除いてください。

  1. 領域は、フィルタをかける画像エリアのみ含めるようにしてください。処理の必要がない領域が含まれると、不正確な結果が返されることがあります。処理時間を短縮するため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけ検査時間が増大します。フィクスチャを使用しない場合、画像領域がすべての画像のほぼ同じ場所に存在するようにしてください。
  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. その後、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


比較画像フィルタツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

比較画像フィルタツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 登録画像タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (比較画像フィルタツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はフィルタ_1 で、末尾の番号はツールの追加に応じて増加します。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (比較画像フィルタツール)

Closed ピクセル比較

テンプレートを入力画像にマッピングするときに使用する、ピクセル比較のタイプを定義します。選択肢は、[最近傍間] または [バイリニア] です。

[最近傍間] (デフォルト設定) では、テンプレートの各ピクセルを入力画像内の最近傍ピクセルと比較し、正規化されたグレースケールの差分をピクセルごとに計算します。これは高速ですが、精度の低い方法です。

[バイリニア] では、テンプレートの各ピクセルを加重平均 (入力画像の 4 つの最近傍ピクセルのグレースケール値を表す) と比較し、正規化されたグレースケールの差をピクセルごとに計算します。これは、比較的正確な方法ですが、速度は遅くなります。

Closed エッジ範囲

画像の比較時に許容されるエッジ周辺のピクセル数を定義します (0～24、デフォルト = 3)。数値が大きいほど、一致が不完全なエッジが、出力画像に差分として示される可能性が低くなります。


登録画像タブ (比較画像フィルタツール)

モデルテンプレート画像のサムネイルが表示されます。モデルパターンを再登録するには [モデル領域] ボタンを押してモデル領域を調整してから、[登録] ボタンを押してください。


比較画像フィルタツールの入出力パラメータを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボル名 | データタイプ | OPC | EasyView | 入出力データ
説明 | 文字列 | X | X | 入出力
画像スケール | 浮動小数点 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
基準点 | 整数値 | X | X | 入出力
画像の表示 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
領域 | 動作 | X | X |


傷検査欠陥検出ツール

傷検査欠陥検出ツールは、ピクセル明度のばらつきに基づき、小さな傷を検出するのに使用します。このツールは、グレースケールまたはカラー画像で、細い傷や切れ目、破れ、欠けといった傷を検出するように設計されています。

傷検査欠陥検出ツールは、輝度や色に局部的な変化のあるエリアを検出するように設計されています。ツールは内部でフィルタ操作を実行して、色やグレースケールに急激な変化があるエッジやエリアをハイライトしてから、ブロブで解析して傷があるかどうかを決定します。このツールは、急激な輝度の変化が欠陥であると分類されるような、均一のエリアがあるパーツの検査に有用です。

傷検査欠陥検出ツールでは、必要に応じて、画像の検査エリアをハイライトする一方で検査の必要のないエリアを除外する、内蔵画像マスクを使用することができます。

  1. 傷検査欠陥検出ツールを設定するには
    1. 傷検査欠陥検出ツールマスクを設定するには
  2. 傷検査欠陥検出ツールのパラメータを調整するには
  3. 傷検査欠陥検出ツールの入出力プロパティを使用するには


傷検査欠陥検出ツールを設定するには

ツール設定には、傷が存在するかどうかを決定するのに使用する、しきい値設定が含まれます。 検査するパーツの画像データベース (PASS および FAIL の両方の画像を含む) を PC からロードして、設定を始めてください。

  1. エラーのない状態のパーツ画像をロードします。次に、傷検査欠陥検出ツールを追加します。

  2. 画像領域を設定します。 [領域タイプ] ドロップダウンリストから、領域のタイプを選択します。選択肢は、[矩形] (デフォルト)、[円]、[円環] または [ポリゴン] です。 領域がすべての傷および傷が発生する可能性のある場所を囲んでいることを確認して下さい。

    注:
    • パフォーマンスを上げるため、領域のサイズをなるべく小さくすることを推奨します。領域を広げると、その分だけツールの実行時間が増大します。 フィクスチャを使用しない場合、その傷がすべての画像のほぼ同じ場所に存在するようにしてください。あるいは、傷が移動しても十分にカバーできる大きさに領域を設定してください。
    • ツールを追加した後に、画像内の領域を右クリックし、[領域の変更] オプションから使用する形状を選び、領域のタイプを変更することができます。
  3. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。
  4. エラーのない画像を使用して、ツールが傷を検出しないようパラメータを調整します。 [傷検出] タブの [表示画像] パラメータを使用すると、パラメータ調整がツール結果にどのような影響を与えるか、視覚的なフィードバックを表示することができます。 四角形の赤ボックス内に検出される傷がすべて含まれるように、[画像表示] パラメータを [傷候補] に設定します。

注: 必要に応じて、マスクを生成して画像の検査エリアをハイライトし、その他のエリアを検査から排除することができます。 テキスト、ラベルまたは他の特徴を無視する検査を設定する場合などに、マスクは非常に有用です。

  5. パラメータ調整の際に、ツールの領域が検査エリアを正しく囲むように ROI 設定されていることを確認して下さい。また、領域から不必要な特徴 (ラベルや文字のエッジまたはロゴなど) が排除されるようにしてください。 検査にパーツのエッジが含まれる場合、領域はエッジと平行に配置してください。(円状の領域にも同じことが適用されます。円領域の円弧はパーツのエッジと並行に配置してください。)
  6. 次に、[サンプリング係数] および [平滑化係数] パラメータを調整してください。 勾配の少ない傷を検出したり、低コントラストの大きな傷を検出したりするには、[サンプル化係数] を大きくします。 [平滑化係数] を大きくすると、小さな偽の傷を排除することができます。
  7. [検出タイプ]、[検出サイズ] および [検出軸] パラメータを調整します。 ほとんどのアプリケーションにおいて、[検出タイプ] を [高速] に、[検出サイズ] を 1 に設定することが可能です。 [検出タイプ] を [白]、[黒]、[白および黒] に設定する必要があるアプリケーションでは、[検出サイズ] パラメータを検出する傷の半径より大きく設定する必要があります。 領域がエッジに並行するように設定されている場合、検出軸は領域に並行するように設定する必要があります。
  8. [最小傷面積]、[最大傷面積] および [最小コントラスト] パラメータを調整します。
  9. エラーのない状態のパーツを正しく検査するようになったら、傷のあるパーツ画像をロードします。 上記のパラメータ調整プロセスを再度行い、傷を正しく認識するようにツールを調整します。 傷のあるパーツ画像を更にロードし、必要に応じて、別の傷を認識するようにパラメータを調整します。
  10. 傷を認識するようになったら、傷のない状態のパーツ画像を再度ロードし、検査の結果傷が検出されないことを確認します。 正しく設定されていることが確認できたら、ランタイム検査にツールを使用する準備が整ったことになります。
  11. 最後に、必要に応じて、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスへ出力します。


傷検査欠陥検出ツールマスクを設定するには

傷検査欠陥検出ツールでは、内部マスクを生成して、検査エリアをハイライトし、他のエリアを検査から除外することができます。

  1. [マスク] タブを開き、[マスク有効] チェックボックスを ON にします。
  2. マスクをどのように生成するかを決定します (最大セグメントまたはエッジ)。デフォルトでは、エッジが使用され ([マスク方法] パラメータが [エッジマスク] に設定されます)、エッジ強度に応じて画像マスクを生成します。この画像マスクでは、エッジピクセルのみがマスクされ、その他のピクセルは表示されます。最大セグメントを選択した場合、検査特徴エリアは最大セグメントとなり、背景を検査から排除します。
  3. マスク表示画像パラメータを設定します。選択したマスクは、カラーコード化されインデックス番号が与えられたセグメントを表示することによって、マスク特徴をハイライトするのに有用なマスクを生成します。
  4. マスク平滑化パラメータを調整します。画像のエッジが正しくハイライトされていることを確認して下さい。
  5. [穴塗りつぶし最大サイズ]、[カーネルサイズ中央値] および [収縮マスク数] パラメータを調整します。これらのパラメータは順番に、画像マスクの穴の塗りつぶし、境界線の平滑化、および細い切れの除外に使用されます。[マスク方法] パラメータが [エッジマスク] に設定されが選択されている場合、[穴塗りつぶし最大サイズ] パラメータは 0 に設定してください。
  6. マスクが特徴を正しくハイライトし、その他のエリアを除外するよう調整したら、[登録] ボタンを押しマスクを設定します。

注: 領域以外のパラメータが変更された場合、マスクを更新し強制的に再登録されます。領域が移動したりサイズ変更された場合、[登録] ボタン再度押してマスクを更新してください。


傷検査欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

傷検査欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [マスク] タブ
  • [傷検出] タブ
  • [統計]、[傷] および [合成領域] タブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (傷検査欠陥検出ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名は傷検査_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[マスク] タブ (傷検出欠陥検出ツール)

Closed マスク有効

マスクを使用するかどうかを定義します (デフォルト = OFF)。

Closed マスク登録

現在設定されているパラメータでマスクを登録するかどうかを定義します。

Closed マスク方法

マスクの生成方法を定義します。選択肢は、[最大セグメント] または [エッジマスク] (デフォルト) です。

  • 最大セグメント: 最大のセグメントを使用してマスクを生成します。
  • エッジマスク: エッジを使用してマスクを生成します ([最小エッジコントラスト] パラメータがどのエッジを使用するか定義します)。
Closed マスク表示画像

表示する出力画像を定義します。選択肢は、[入力画像]、[エッジ画像]、[セグメント化した画像] または [マスク画像] (デフォルト) です。

  • 入力画像: 現在取得されている画像を表示します。
  • エッジ画像: エッジ強度画像を表示します。
  • セグメント化した画像: 色分けされた、セグメント画像を表示します。
  • マスク画像: セグメント化およびマスク生成処理後に作成されたバイナリマスク画像を表示します (フィクスチャ入力適用後)。ピクセル値 255 = ピクセルを考慮します。ピクセル値 0 = ピクセル値を考慮しません。

注: この画像は表示のみに使用されます。他の機能の入力としては使用できません。

Closed マスク平滑化係数

画像の平滑化に使用するシグマ係数を定義します (0～100; デフォルト = 1)。

Closed 最小エッジコントラスト

エッジ検出に使用する最小コントラストを定義します (1～100; デフォルト = 1)。

注: このパラメータは、[マスク方法] パラメータが [エッジマスク] に設定されている場合に有効となります。

Closed 最小セグメントサイズ

セグメントを抽出するのに必要な最小面積をピクセル単位で定義します (1～50000; デフォルト = 1000)。

Closed 穴塗りつぶし最大サイズ

「穴」として考慮されないよう、小さな穴を塗りつぶすために必要な最大サイズを定義します (0～1000; デフォルト = 100)。

Closed カーネルサイズ中央値

マスク画像のエッジを平滑化するのに使用するカーネルサイズ中央値を定義します(0～50000; デフォルト = 0)。

Closed 収縮マスク数

生成画像が収縮される回数を定義します (-100～100; デフォルト = 0)。値には正の値および負の値の両方が使用できます。負の値は画像を膨張させます。

Closed 反転

白を黒に、または黒を白になど、マスクを反転させるかどうかを定義します。white for black, black for white.


[傷検出] タブ (傷検出欠陥検出ツール)

Closed 検出タイプ

欠陥が存在するかを決定するために画像に適用する画像処理の方法を定義します。選択肢は、[高速] (デフォルト)、[白]、[黒]、[白および黒] です。

  • 高速: 細い線や傷といった、「エッジ」タイプの傷の明度遷移を検出するのに有用です。傷のエッジをハイライトする、収縮誇張処理を適用します。実行時間は一番短いですが、報告されるのは傷の面積ではなく、周囲長のみとなります。
  • 白: 黒い背景上にある白い「ブロブ」タイプの傷の検出に有用です。傷面積のピクセルサイズに基づいて、傷を検出します。「トップハット」フィルタ処理を行い、[検出サイズ] パラメータで指定した値より小さい白い特徴以外をすべて取り除き、潜在的な傷を検出します。
  • 黒: 白い背景上にある黒い「ブロブ」タイプの傷の検出に有用です。傷面積のピクセルサイズに基づいて、傷を検出します。「ボトムハット」フィルタ処理を行い、[検出サイズ] パラメータで指定した値より小さい黒い特徴以外をすべて取り除き、潜在的な傷を検出します。
  • 白および黒: 黒または白背景上にある「ブロブ」タイプの傷の検出に有用です。傷面積のピクセルサイズに基づいて、傷を検出します。「ボトムハット」および「トップハット」両方の処理を行い、両方の処理の最大結果を使用します。

注: 白、黒または白および黒傷タイプタイプが選択されている場合、[検出サイズ] パラメータは検出される傷の最大サイズに設定する必要があります。

Closed 表示画像

出力画像を定義します。選択肢は、[入力画像]、[サンプリング画像]、[傷候補]、[傷マスク画像] (デフォルト) です。

  • 入力画像: 現在取得されている画像を表示します。
  • サンプリング画像: 平滑化したサンプル画像が表示されます。角度やカーブのある領域が入力に使用されている場合、平滑化・サンプル効果に加え、歪み補正を実行し変換した画像が表示されます。
  • 傷候補: 傷候補が表示されます。傷候補は背景と対象をなす色でハイライトされます。
  • 傷マスク画像: 傷が表示されます。傷は白で、その他のエリアは黒で描画されされます。この表示オプションでは、傷定義指定範囲外 ([最小傷面積] および [最大傷面積])の傷も表示します。

注: この画像は表示のみに使用されます。他の機能の入力としては使用できません。

Closed サンプリング係数

解像度を下げることにより、どの入力画像をサンプリングするか定義します (1～ 99999; デフォルト = 1)。サンプリングによりツールの実行時間は短くなりますが、その精度さは下がります。サンプル係数値 1 は、サンプリングを実行しない、 フル解像度の画像となります。サンプル係数値が増えると解像度および精度は下がり、実行時間は短くなります。

Closed 自動平滑化

画像を平滑化する、最適平滑化係数を決定するかどうかを定義します (デフォルト = OFF)。通常、最適平滑化係数を選択することにより、パフォーマンスを上げることができます。

注: [自動平滑化] パラメータはデフォルトで OFF となっています。ON にするには、 [サンプリング係数] パラメータを 1 以上の値に設定してください。[サンプリング係数] パラメータを 1 以上の値に設定した場合に、[自動平滑化] パラメータを ON にしたくない場合は、[自動平滑化] パラメータを OFF にし、[平滑化係数] パラメータを適切な数値に設定してください。

Closed 平滑化係数

画像を平滑化する係数を定義します (0～99999; デフォルト = 0)。最適値を決定する場合、サンプリング係数で指定した値と近い値から始めてください。平滑化を行わない場合は、0 に設定してください。

注: [自動平滑化] パラメータを ON にした場合、このパラメータは無効となります。[自動平滑化] パラメータが ON の場合、[サンプリング係数] パラメータを 1 以上に設定して、[自動平滑化] パラメータを OFF にした後で、 [平滑化係数] パラメータの数値を増分することができます。

Closed 検出軸

傷候補を検出する軸を定義します。選択肢は、[X]、[Y]、[X および Y] (デフォルト) です。

Closed 検出サイズ

検出近傍サイズをピクセル単位で定義します (1～99999; デフォルト = 1)。このパラメータは、[操作] パラメータともに使用して、近傍処理の作成やカーネルに使用されます。[操作] パラメータを [高速] 以外に設定した場合、サイズ値は検出する傷の長さまたは幅と最低同じ値にする必要があります。

Closed 最小コントラスト

傷検出に使用する明度しきい値を定義します (1～255;デフォルト = 20)。傷を検出するには、明度は背景の値と異なる必要があります。

Closed 最小傷面積

検出する傷の最小サイズをピクセル単位で定義します (1～99999; デフォルト = 30)。

注:この値は、常にピクセル単位で表示されます。ジョブが、[画像の設定] ステップで実世界の計測値にキャリブレートされている場合もピクセル表示となります。

Closed 最大傷面積

検出する傷の最大サイズをピクセル単位で定義します (1～99999; デフォルト = 99999)。

注:この値は、常にピクセル単位で表示されます。ジョブが、[画像の設定] ステップで実世界の計測値にキャリブレートされている場合もピクセル表示となります。

Closed タイムアウト

ツールが傷をサーチする時間をミリ秒単位で定義します (0～30,000; デフォルト = 5000)。この時間を過ぎると、サーチは終了し、ツールは FAIL を返します。

Closed すべての傷

検出された傷の総数を表示します。


[統計]、[傷]、および [合成領域] タブ (傷検出欠陥検出ツール)

Closed [統計] タブ

傷総数および累積サイズについてのデータを表示します。

Closed [傷] タブ

最初に検出された 10 個の傷を面積でソートし、最大から最小の順番で表示します。 テーブルには、画像内の傷の位置 (X/Y 座標)、面積、周囲長、新エンドおよび明度が表示されます。

Closed [合成領域] タブ

[合成領域] タブを使用して、サブ領域 (矩形、円環、円またはポリゴン) の集合体である、合成領域を設定します。サブ領域は、領域に追加 (画像解析時に領域を含める) するか、あるいは領域から減算 (画像解析時に領域を除外: 「マスキング」) します。

注:
  • 最大 32 までのサブ領域を使用して、合成領域を作成することができます。
  • 画像中の領域を右クリックして、サブ領域の形状を変更したり、サブ領域を追加/減算したり、選択中のサブ領域の操作 ([追加] または [減算]) を変更したりすることができます。
Closed [合成領域] テーブル

合成領域からなるサブ領域のタイプ、およびその操作 ([追加] または [減算]) を表示します。サブ領域を選択すると、[削除]、[上に移動] または [下に移動] ボタンが有効になります。 [削除] ボタンを押すと、選択中のサブ領域がリストから削除されます。[上に移動] ボタンを押すと、選択中のサブ領域が上に移動します。[下に移動] ボタンを押すと、選択中のサブ領域が下に移動します。

注: 合成領域は、リスト中のサブ領域の順番を基に作成されます。 サブ領域の [追加] または [減算] 操作を特定の順序で行うと、画像の一部がハイライトされ、その他の部分は無視されるようになります。 以下に、サブ領域を正しい順番に並べて、画像の一部を除外し、その他の部分にフォーカスを当てる方法を示します。 まず、[矩形] を [追加] 操作に設定し、[減算] 操作を行う [円] を中央に配置します。 次に、[追加] 操作を行う小さな [矩形] を設定し、[円] の中央に配置します。 [円] は画像の一部分を除外し、小さな [矩形] は画像の一部を画像解析に追加し直します。 2 段目のイラストでは、小さな [矩形] が [円] の前に追加されたため、[円] が小さな [矩形] をマスクし、画像解析から除外されてしまっています。
Closed 形状

選択中のサブ領域の形状を表示します(矩形, 円, 円環またはポリゴン)。 形状を変更するには、ドロップダウンメニューから使用する領域タイプを選択してください。

Closed 操作

領域内にある、選択中のサブ領域の動作を定義します。選択肢は、[追加] または [減算] です。[追加] は、画像解析にサブ領域を含め、[減算] は画像解析からサブ領域を除外します (マスキング)。

Closed 矩形

矩形サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円環

円環サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed 円

円サブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。

Closed ポリゴン

ポリゴンサブ領域を合成領域に挿入します。 必要に応じて、領域の形状およびサイズを設定してください。


傷検査欠陥検出ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
自動平滑化 | 整数値 | X | X | 入出力
合成領域 | 動作 |  | X |
累積傷サイズ | 浮動小数点 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
検出軸 | 整数値 | X | X | 入出力
検出サイズ | 整数値 | X | X | 入出力
検出画像 | 整数値 | X | X | 入出力
マスク有効 | 整数値 | X | X | 入出力
収縮マスク数 | 整数値 | X | X | 入出力
エラー_数 | 整数値 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 整数値 | X |  |
FAIL_数 | 整数値 | X | X | 出力
検出タイプ | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
反転 | 整数値 | X | X | 入出力
マスク表示画像 | 整数値 | X | X | 入出力
マスク方法 | 整数値 | X | X | 入出力
マスク平滑化係数 | 整数値 | X | X | 入出力
最大傷面積 | 浮動小数点 | X | X | 入出力
穴塗りつぶし最大サイズ | 整数値 | X | X | 入出力
カーネルサイズ中央値 | 整数値 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
最小エッジコントラスト | 整数値 | X | X | 入出力
最小傷面積 | 浮動小数点 | X | X | 入出力
最小セグメントサイズ | 整数値 | X | X | 入出力
PASS | 整数値 | X |  |
PASS_数 | 整数値 | X | X | 出力
サンプリング係数 | 整数値 | X | X | 入出力
サンプリング係数 | 整数値 | X | X | 入出力
ステータス | 整数値 | X | X | 出力
タイムアウト | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
ツール有効ステータス | 整数値 | X | X | 出力
すべての傷 | 文字列 | X | X | 出力
マスクの登録 | 動作 |  | X |


エッジ欠陥検出ツール

エッジ欠陥検出ツールは、エッジ特徴の正確な位置を特定するエッジ解析キャリパアレイを使用して、エッジ特徴に最も適合するラインまたは円を作成します。エッジの識別後、最適ラインまたは最適円 (エッジ特徴にカーブがあるかどうかによります) をエッジ特徴の上に作成し、欠陥またはギャップなどの偏差があるかどうかを決定して、検出した欠陥/ギャップの数を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

エッジ欠陥検出ツールは、、検査対象物またはオブジェクトのエッジ特徴に、欠陥またはギャップなどの偏差が無いことを確認する場合などに有用です。例えば、検査対象物/オブジェクトの外側が同じ形状を維持しているかどうか、小さなくぼみや切れ目がないかどうかを確認するのに使用します。

  1. エッジ欠陥検出ツールを設定するには
  2. エッジ欠陥検出ツールのパラメータを調整するには
  3. エッジ欠陥検出ツールの入出力プロパティを使用するには


エッジ欠陥検出ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン]、[欠陥] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円を正しく作成していることを確認してください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [欠陥] および [ギャップ] テーブルタブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジ欠陥検出ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はエッジ欠陥_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (エッジ欠陥検出ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (エッジ欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]) を指定します。デフォルトは、[左→右] です。

Closed エッジの遷移

エッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには、遷移タイプを明示してください。

Closed 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[最適ライン] タブ (エッジ欠陥検出ツール)

[最適ライン] タブを選択すると、領域内で検出されたすべてのエッジ候補や、最適円または最適ラインの結果が表示されます。

エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。エッジ候補はカラーコード化された小さな円で表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

Closed 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注: このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。

Closed 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

Closed 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

Closed 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注: この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。


[欠陥] タブ (エッジ欠陥検出ツール)

[欠陥] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「欠陥」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed 最小距離

エッジおよび最適ライン/最適円からの最小距離をピクセルで指定します (0.001～1920、デフォルト = 4)。この値より距離が短い場合、欠陥とみなされません。

Closed 最大距離

エッジおよび最適ライン/最適円からの最大距離をピクセルで指定します (0.001～1920、デフォルト = 1000)。この値より距離が長い場合、欠陥とみなされません。

Closed サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。最適ラインまたは最適円からの連続偏差がこの値より小さい場合、欠陥とみなされません。

Closed 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。最適ラインまたは最適円からの連続偏差がこの値より大きい場合、欠陥とみなされません。

Closed 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、最適ラインまたは最適円沿いの長さ、および欠陥エッジの最適ラインまたは最適円からの欠陥エッジの長さを考慮します。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

Closed 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。

Closed 欠陥フィルタ

最適ラインを基準に、欠陥をフィルタするかどうかを定義します。選択肢は、フィルタなし (デフォルト)、最適ライン左の欠陥を無視、最適ライン右の欠陥を無視。


[ギャップ] タブ (エッジ欠陥検出ツール)

[ギャップ] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「ギャップ」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

Closed 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

Closed 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

Closed 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 結果

検出された欠陥/ギャップの総数を表示します。


[欠陥] および [ギャップ] テーブルタブ (エッジ欠陥検出ツール)

[欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップをエッジ上の位置でソートして表示します。

Closed インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

Closed X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

Closed サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

Closed キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

Closed キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジ欠陥検出ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
面積有効 | 整数値 | X | X | 入出力
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジの遷移 | 整数値 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
外れ値の除外 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
ギャップの検出 | 整数値 | X | X | 入出力
最適距離フィルタ | 整数値 | X | X | 入出力
最端フィルタ距離 | 整数値 | X | X | 入出力
終端ギャップを無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最大距離 | 浮動小数点 | X | X | 入出力
最大サイズ | 浮動小数点 | X | X | 入出力
最大ギャップ | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
最小距離 | 浮動小数点 | X | X | 入出力
最小サイズ | 浮動小数点 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
最小ギャップ | 浮動小数点 | X | X | 入出力
再得点 | 整数値 | X | X | 入出力
再得点 | 整数値 | X | X | 入出力
規則_最初のエッジ | 整数値 | X | X | 入出力
規則_エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
サイズ有効 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
欠陥 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ギャップ | 浮動小数点 | X | X | 出力
InspectEdgeForDefect | 文字列 | X | X | 出力
ライン.終点_X | 浮動小数点 | X | X | 出力
ライン.終点_Y | 浮動小数点 | X | X | 出力
ライン.始点_X | 浮動小数点 | X | X | 出力
ライン.始点_Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
すべての傷 | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |


エッジペア欠陥検出ツール

エッジペア欠陥検出ツールは、エッジ特徴の正確な位置を特定するエッジ解析キャリパアレイを使用して、エッジ特徴に最も適合するラインまたは円のペアを作成します。エッジの識別後、最適ラインまたは最適円 (エッジ特徴にカーブがあるかどうかによります) のペアをエッジ特徴の上に作成し、欠陥またはギャップなどの偏差があるかどうかを決定して、検出した欠陥/ギャップの数を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

エッジペア欠陥検出ツールは、欠陥またはギャップなどの偏差が、検査対象物またはオブジェクトのエッジ特徴に無いことを確認する場合などに有用です。例えば、検査対象物/オブジェクトの外側が同じ形状を維持し、小さなくぼみや切れ目がないことを確認するのに使用します。

  1. エッジペア欠陥検出ツールを設定するには
  2. エッジペア欠陥検出ツールのパラメータを調整するには
  3. エッジペア欠陥検出ツールの入出力プロパティを使用するには


エッジペア欠陥検出ツールを設定するには

ツールを追加したら、エッジ特徴上のマスク領域を設定します。

  1. エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  1. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  2. 領域を設定したら、[エッジ]、[エッジ得点]、[最適ライン]、[欠陥] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際、エッジ候補を正しく検出し、最適ラインや最適円を正しく作成していることを確認してください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  3. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  4. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジペア欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジペア欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [最適ライン] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジペア欠陥検出ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はエッジペア欠陥_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (エッジペア欠陥検出ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (エッジペア欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます (領域は選択し、調整することができます)。エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。パラメータを調整して、使用するエッジ候補を検出してください。

検出された欠陥およびギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

Closed エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

Closed ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[最適ライン] タブ (エッジペア欠陥検出ツール)

[最適ライン] タブを選択すると、領域内で検出されたすべてのエッジ候補や、最適円または最適ラインの結果が表示されます。

エッジ候補とは、最適ラインまたは最適円作成時に使用可能なエッジのことです。エッジ候補はカラーコード化された小さな円で表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を、最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

Closed 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注: このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。

Closed 最端フィルタ距離

除外距離を指定します (1～1920、デフォルト = 1000)。この値の外にあるエッジは、最小距離および最大距離を決定するのに使用されません。この値より大きなエッジは無視されます。

Closed 再得点

最初に破棄した検出エッジが削除されているかどうかを確認するのに、検出エッジを再得点するかどうかを指定します。デフォルトは、OFF です。

Closed 再計算

エッジ得点の再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注: この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。


[欠陥] タブ (エッジペア欠陥検出ツール)

[欠陥] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「欠陥」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed 最小距離

エッジおよび最適ライン/最適円からの最小距離をピクセルで指定します (0.001～1920、デフォルト = 4)。この値より距離が短い場合、欠陥とみなされません。

Closed 最大距離

エッジおよび最適ライン/最適円からの最大距離をピクセルで指定します (0.001～1920、デフォルト = 1000)。この値より距離が長い場合、欠陥とみなされません。

Closed サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。最適ラインまたは最適円からの連続偏差がこの値より小さい場合、欠陥とみなされません。

Closed 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。最適ラインまたは最適円からの連続偏差がこの値より大きい場合、欠陥とみなされません。

Closed 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、最適ラインまたは最適円沿いの長さ、および欠陥エッジの最適ラインまたは最適円からの欠陥エッジの長さを考慮します。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

Closed 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。

Closed 欠陥フィルタ

最適ラインを基準に、欠陥をフィルタするかどうかを定義します。選択肢は、フィルタなし (デフォルト)、最適ライン左の欠陥を無視、最適ライン右の欠陥を無視。


[ギャップ] タブ (エッジペア欠陥検出ツール)

[ギャップ] タブを選択すると、最適円または最適ラインの結果と、検出された欠陥またはギャップが表示されます。「ギャップ」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

Closed 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

Closed 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

Closed 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 結果

検出された欠陥/ギャップの総数を表示します。


[エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブ (エッジペア欠陥検出ツール)

[エッジ 0 欠陥]、[エッジ 1 欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップをエッジ上の位置でソートして表示します。「エッジ0」は最初のエッジを、「エッジ1」は 2 番目のエッジを指します。

Closed インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

Closed X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

Closed サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

Closed キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

Closed キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジペア欠陥検出ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
面積有効 | 整数値 | X | X | 入出力
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
エッジ0_の遷移 | 整数値 | X | X | 入出力
エッジ1_の遷移 | 整数値 | X | X | 入出力
外れ値の除外 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
ギャップの検出 | 整数値 | X | X | 入出力
最適距離フィルタ | 整数値 | X | X | 入出力
最端フィルタ距離 | 整数値 | X | X | 入出力
終端ギャップを無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最大距離 | 浮動小数点 | X | X | 入出力
最大サイズ | 浮動小数点 | X | X | 入出力
最大ギャップ | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
最小距離 | 浮動小数点 | X | X | 入出力
最小サイズ | 浮動小数点 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
最小ギャップ | 浮動小数点 | X | X | 入出力
ペアサイズ | 整数値 | X | X | 入出力
再計算 | 整数値 | X | X | 入出力
再得点 | 整数値 | X | X | 入出力
規則_最初のエッジ | 整数値 | X | X | 入出力
規則_ペアサイズ | 整数値 | X | X | 入出力
規則_エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
サイズ有効 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
円.半径 | 浮動小数点 | X | X | 出力
円.X | 浮動小数点 | X | X | 出力
円.Y | 浮動小数点 | X | X | 出力
円1.半径 | 浮動小数点 | X | X | 出力
円1.X | 浮動小数点 | X | X | 出力
円1.Y | 浮動小数点 | X | X | 出力
欠陥 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ギャップ | 浮動小数点 | X | X | 出力
InspectEdgeForDefect | 文字列 | X | X | 出力
ライン.終点_X | 浮動小数点 | X | X | 出力
ライン.終点_Y | 浮動小数点 | X | X | 出力
ライン.始点_X | 浮動小数点 | X | X | 出力
ライン.始点_Y | 浮動小数点 | X | X | 出力
ライン1.終点_X | 浮動小数点 | X | X | 出力
ライン1.終点_Y | 浮動小数点 | X | X | 出力
ライン1.始点_X | 浮動小数点 | X | X | 出力
ライン1.始点_Y | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効_ステータス | 浮動小数点 | X | X | 出力
すべての傷 | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |


エッジ幅欠陥検出ツール

エッジ幅欠陥検出ツールは、エッジペアの幅が許容範囲内にあるかどうかを計測、検証します。特徴の正確な位置を特定するエッジ解析キャリパアレイを使用し、欠陥またはギャップなどの偏差があるかどうかを決定して、検出した欠陥/ギャップの数を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

エッジ幅欠陥検出ツールは、欠陥またはギャップなどの偏差が、検査対象物またはオブジェクトのエッジ特徴に無いことを確認する場合などに有用です。例えば、溶接の継ぎ目が適切な幅を維持しているかどうかを確認するのに使用します。

  1. エッジ幅欠陥検出ツールを設定するには
  2. エッジ幅欠陥検出ツールのパラメータを調整するには
  3. エッジ幅欠陥検出ツールの入出力プロパティを使用するには


エッジ幅欠陥検出ツールを設定するには

ツールを追加したら、領域タイプを選択し、エッジ特徴上で領域を設定します。

  1. [領域タイプ] ドロップダウンメニューから、領域のタイプ ([マスク領域] または [ポリラインパス])を選択してください。エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[エッジ]、[エッジ得点]、[外れ値]、[欠陥]、[ギャップ] などのタブを選択し、パラメータおよび領域を必要に応じて調整して、エッジ候補が正しく検出されていることを確認して下さい。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用します。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。

注: [外れ値] タブの [再得点] チェックボックスをON にすると、最適ラインまたは最適円が作成されます (オプション)。

  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


エッジ幅欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

エッジ幅欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [外れ値] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [幅欠陥] および [ギャップ] テーブルタブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (エッジ幅欠陥検出ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はエッジ幅_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 領域タイプ

エッジ特徴を検出する際に使用する、領域のタイプを指定します。選択肢は、[マスク領域] (デフォルト) または [ポリラインパス] です。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[エッジ] タブ (エッジ幅欠陥検出ツール)

[エッジ] タブを選択すると、領域内で検出されたすべてのエッジが暗い緑色で表示されます。[キャリパサイズ]、[キャリパ間隔]、[エッジ幅] および [最小コントラスト] パラメータを必要に応じて調整し、使用するエッジを検出することができます。

[すべてのキャリパを表示] チェックボックスを ON にすると、すべてのキャリパが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (エッジ幅欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補が、カラーコード化された小さな円で表示されます　(領域は選択し、調整することができます)。パラメータを調整して、使用するエッジ候補を検出してください。

注: [外れ値] タブの [再得点] チェックボックスをON にすると、最適ラインまたは最適円が作成されます (オプション)。

検出された欠陥およびギャップが表示されるほか、エッジの最小および最大幅も黄色の線で表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

Closed エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ 1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed コントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

Closed 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

Closed ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[外れ値] タブ (エッジ幅欠陥検出ツール)

[外れ値] タブを選択すると、領域内で検出されたすべてのエッジ候補、および最適円または最適ラインの結果が表示されます。エッジ候補は、最適ラインまたは最適円作成時に使用可能なエッジを表します。エッジ候補はカラーコード化された小さな円で表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

検出された欠陥およびギャップが表示されるほか、エッジの最小および最大幅も黄色の線で表示されます。

Closed 再得点

エッジの得点再計算後に、最適ラインの再計算を行うように指定します。デフォルトは、OFF です。

注: この機能を有効にすると、最適ラインの精度が向上しますが、処理時間は長くなります。

Closed 最適ライン

検出されたエッジから作成する、最適ラインのタイプを指定します ([自動調節] (デフォルト)、[最適直線]、[最適円])。

注: このパラメータを使用するには、[再得点] パラメータを有効にする必要があります。

Closed 外れ値の除外

[最適距離フィルタ] パラメータで指定されている距離より遠い点を最適ラインから削除するかどうかを指定します。デフォルトは、OFF です。

Closed 最適距離フィルタ

エッジが元の最適ラインから離れている必要がある距離をピクセルで指定します (1～1920、デフォルト = 2)。この値は、最適合計算で使用します。この設定は、欠陥が最適ラインに影響を与えないようにする場合に有効です。

注: このパラメータを使用するには、[外れ値の除外] パラメータを ON (有効) にする必要があります。


[欠陥] タブ (エッジ幅欠陥検出ツール)

[欠陥] タブを選択すると、検出したエッジペアの最小幅および最大幅 (黄色の線) と、検出した欠陥またはギャップが表示されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed 最小幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より幅距離が短い場合、欠陥とみなされません。

Closed 最大幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より幅距離が長い場合、欠陥とみなされません。

Closed サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。最適ラインまたは最適円からの連続偏差がこの値より小さい場合、欠陥とみなされません。

Closed 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。最適ラインまたは最適円からの連続偏差がこの値より大きい場合、欠陥とみなされません。

Closed 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、最適ラインまたは最適円沿いの長さ、および欠陥エッジの最適ラインまたは最適円からの欠陥エッジの長さを考慮します。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

Closed 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。


[ギャップ] タブ (エッジ幅欠陥検出ツール)

[ギャップ] タブを選択すると、最適円または最適ラインの結果 (ON の場合) と、検出された欠陥またはギャップが表示されます。「ギャップ」は、最適ラインまたは最適円からのエッジ偏差として指定されます。

このタブの選択中に、領域を選択し、調整することもできます。

Closed ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

Closed 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

Closed 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

Closed 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 結果

検出された欠陥/ギャップの総数を表示します。


[幅欠陥] および [ギャップ] テーブルタブ (エッジ幅欠陥検出ツール)

[幅欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップをエッジ上の位置でソートして表示します。

Closed インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

Closed X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

Closed サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

Closed キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

Closed キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


エッジ幅欠陥検出ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
面積有効 | 整数値 | X | X | 入出力
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
コントラスト上限 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
エッジ0_の遷移 | 整数値 | X | X | 入出力
エッジ1_の遷移 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
ギャップの検出 | 整数値 | X | X | 入出力
終端ギャップの無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最大サイズ | 浮動小数点 | X | X | 入出力
最大幅 | 浮動小数点 | X | X | 入出力
最大ギャップ | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
最小サイズ | 浮動小数点 | X | X | 入出力
最小幅 | 浮動小数点 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
最小ギャップ | 浮動小数点 | X | X | 入出力
ペアサイズ | 整数値 | X | X | 入出力
領域タイプ | 整数値 | X | X | 入出力
規則_最初のエッジ | 整数値 | X | X | 入出力
規則_ペアサイズ | 整数値 | X | X | 入出力
規則_エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
サイズ有効 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
欠陥 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ギャップ | 浮動小数点 | X | X | 出力
InspectEdgeWidth | 文字列 | X | X | 出力
最大幅 | 浮動小数点 | X | X | 出力
最小幅 | 浮動小数点 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効_ステータス | 浮動小数点 | X | X | 出力
すべての傷 | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |
ポリラインパス | 動作 | X | X |


ビードファインダー欠陥検出ツール

ビードファインダー欠陥検出ツールは、ビードの中心を検出し、ビード幅の検査に使用される領域を作成して、形状に関わらずビード特徴 (エッジペアにより定義されます) を識別します。このツールはエッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。ビード特徴を識別したら、ビードをプロットし、ビード幅が許容範囲外にある場合、欠陥またはギャップとして返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

ビードファインダー欠陥検出ツールは、視野内に不規則に表示される接着ビードなどのビード特徴の幅を識別、検証する場合などに有用です。

  1. ビードファインダー欠陥検出ツールを設定するには
  2. ビードファインダー欠陥検出ツールのパラメータを調整するには
  3. ビードファインダー欠陥検出ツールの入出力プロパティを使用するには


ビードファインダー欠陥検出ツールを設定するには

ツールを追加したら、領域タイプを選択し、エッジ特徴上で領域を設定します。

  1. [領域タイプ] ドロップダウンメニューから、領域のタイプ ([マスク領域] または [ポリラインパス])を選択してください。エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[検出ビード]、[エッジ]、[エッジ得点]、[欠陥]、[ギャップ] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際に、エッジ候補が正しく検出され、ポリラインが正しく作成されていることを確認して下さい。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用してください。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。
  4. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  5. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ビードファインダー欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ビードファインダー欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [検出ビード] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [統計]、[幅欠陥] および [ギャップ] テーブルタブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ビードファインダー欠陥検出ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はビードファインダー_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 領域タイプ

解析中の画像エリア定義に使用される領域のタイプを指定します。選択肢は、[マスク領域] (デフォルト) および [ポリラインパス] です。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[検出ビード] タブ (ビードファインダー欠陥検出ツール)

[検出ビード] タブを選択すると、ビード特徴の位置に関連するグラフィックスが表示されます。表示されるのは、検出されたエッジ (暗い緑色) や、領域内 (選択し、調整することができます) で検出されたエッジ候補 (カラーコード化された小さな円で表示されます)、およびビード位置 (青のポリライン) です。

パラメータを調整して、使用するエッジおよびエッジ候補を検出することができます。エッジ候補は、ビード特徴の輪郭となるポリラインパスを作成するのに使用されます。

Closed 検出ビードのキャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 8)。キャリパは、検査方向に沿って解析します。

Closed 検出ビードのキャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed 検出ビードのエッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 検出ビードの最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed 検出ビードのエッジ方向

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

Closed 検出ビードエッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 検出ビードエッジ1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 検出ビード規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 検出ビード規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 検出ビードのコントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

Closed 検出ビード規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 検出ビードの得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。

Closed 検出ビードのキャリパ

領域内のキャリパ総数を表示します。

Closed 検出ビードのキャリパインデックス

検出および表示する、キャリパを指定します。

Closed 検出ビードの全キャリパ表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ] タブ (ビードファインダー欠陥検出ツール)

[エッジ] タブを選択すると、ビードパスの位置 (青) 、検出されたすべてのエッジ (緑)、ビードパスの位置から生成されたポリラインパスを定義するキャリパ (水色) が表示されます。水色のキャリパは、[ポリライン幅] パラメータを使用してのみ、調整することができます。[ポリライン幅]、[キャリパサイズ]、[キャリパ間隔]、および [最小コントラスト] パラメータを必要に応じて調整して、使用するエッジを検出することができます。

Closed ポリライン幅

ポリラインを定義するのに使用する、キャリパの幅を指定します (1～1920、デフォルト = 25)。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (ビードファインダー欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補 (カラーコード化された小さな円で表示されます) や、検出されたエッジ (暗い緑色)、ビード位置 (青のポリライン) 、ビードの最大幅および最小幅 (黄色の線)が表示されます。同時に、検出された欠陥またはギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[外→内] です。

Closed エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ 1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed コントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

Closed 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

Closed ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[欠陥] タブ (ビードファインダー欠陥検出ツール)

[欠陥] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

Closed 最小幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より幅距離が短い場合、欠陥とみなされません。

Closed 最大幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より幅距離が長い場合、欠陥とみなされません。

Closed サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小サイズ

最小欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 3)。ポリラインからの連続偏差がこの値より小さい場合、欠陥とみなされません。

Closed 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。ポリラインからの連続偏差がこの値より大きい場合、欠陥とみなされません。

Closed 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、ポリライン上の長さ、ポリラインからの欠陥エッジの長さを考慮します。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

Closed 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。


[ギャップ] タブ (ビードファインダー欠陥検出ツール)

[ギャップ] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

Closed ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

Closed 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

Closed 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

Closed 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 結果

検出された欠陥/ギャップの総数を表示します。


[統計]、[幅欠陥] および [ギャップ] テーブルタブ (ビードファインダー欠陥検出ツール)

[統計] テーブルタブは、一定時間内のツールのデータを記録します。[幅欠陥] および [ギャップ] テーブルタブは、最初に検出された 10 個の欠陥/ギャップを表示します。

Closed インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

Closed X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

Closed サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

Closed キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

Closed キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


ビードファインダー欠陥検出ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
面積有効 | 整数値 | X | X | 入出力
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
コントラスト上限 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
エッジ0_の遷移 | 整数値 | X | X | 入出力
エッジ1_の遷移 | 整数値 | X | X | 入出力
検出ビードのキャリパインデックス | 整数値 | X | X | 入出力
検出ビードのキャリパサイズ | 整数値 | X | X | 入出力
検出ビードのキャリパ間隔 | 整数値 | X | X | 入出力
検出ビードのコントラスト上限 | 整数値 | X | X | 入出力
検出ビードのエッジ方向 | 整数値 | X | X | 入出力
検出ビードのエッジ幅 | 整数値 | X | X | 入出力
検出ビードのエッジ0_の遷移 | 整数値 | X | X | 入出力
検出ビードのエッジ1_の遷移 | 整数値 | X | X | 入出力
検出ビードの最小コントラスト | 整数値 | X | X | 入出力
検出ビードのペアサイズ | 整数値 | X | X | 入出力
検出ビード規則_最初のエッジ | 整数値 | X | X | 入出力
検出ビード規則_ペアサイズ | 整数値 | X | X | 入出力
検出ビード規則_エッジ強度 | 整数値 | X | X | 入出力
検出ビードの得点しきい値 | 整数値 | X | X | 入出力
検出ビードのすべてのキャリパを表示 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
ギャップの検出 | 整数値 | X | X | 入出力
終端ギャップの無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
最大サイズ | 浮動小数点 | X | X | 入出力
最大幅 | 浮動小数点 | X | X | 入出力
最大ギャップ | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
最小サイズ | 浮動小数点 | X | X | 入出力
最小幅 | 浮動小数点 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
最小ギャップ | 浮動小数点 | X | X | 入出力
ペアサイズ | 整数値 | X | X | 入出力
ポリライン幅 | 整数値 | X | X | 入出力
領域タイプ | 整数値 | X | X | 入出力
規則_最初のエッジ | 整数値 | X | X | 入出力
規則_ペアサイズ | 整数値 | X | X | 入出力
規則_エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
サイズ有効 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
キャリパ.不良.累積 | 浮動小数点 | X | X | 出力
キャリパ.不良.最大 | 浮動小数点 | X | X | 出力
キャリパ.不良.パーセンテージ | 浮動小数点 | X | X | 出力
キャリパ.不良.最小 | 浮動小数点 | X | X | 出力
キャリパ.良.累積 | 浮動小数点 | X | X | 出力
キャリパ.良.最大 | 浮動小数点 | X | X | 出力
キャリパ.良.パーセンテージ | 浮動小数点 | X | X | 出力
キャリパ.良.最小 | 浮動小数点 | X | X | 出力
欠陥.数 | 浮動小数点 | X | X | 出力
欠陥.累積 | 浮動小数点 | X | X | 出力
欠陥.最大 | 浮動小数点 | X | X | 出力
欠陥.過大幅.累積 | 浮動小数点 | X | X | 出力
欠陥.過大幅.最大 | 浮動小数点 | X | X | 出力
欠陥.過大幅.パーセンテージ | 浮動小数点 | X | X | 出力
欠陥.過大幅.最小 | 浮動小数点 | X | X | 出力
欠陥.最小 | 浮動小数点 | X | X | 出力
欠陥.過小幅.累積 | 浮動小数点 | X | X | 出力
欠陥.過小幅.最大 | 浮動小数点 | X | X | 出力
欠陥.過小幅.パーセンテージ | 浮動小数点 | X | X | 出力
欠陥.過小幅.最小 | 浮動小数点 | X | X | 出力
キャリパ数 | 浮動小数点 | X | X | 出力
欠陥 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
検出ビードのキャリパ | 浮動小数点 | X | X | 出力
ギャップ.数 | 浮動小数点 | X | X | 出力
ギャップ.累積 | 浮動小数点 | X | X | 出力
ギャップ.最大 | 浮動小数点 | X | X | 出力
ギャップ.最小 | 浮動小数点 | X | X | 出力
InspectEdgeWidth | 文字列 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
傷総数 | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |
ポリラインパス | 動作 | X | X |


ビードトラッカー欠陥検出ツール

ビードトラッカー欠陥検出ツールは、ビード特徴 (エッジペアにより定義) の位置、形状および幅を検査します。ユーザが作成したビード特徴のモデルに基づき、エッジ解析キャリパアレイを使用して、エッジ特徴の正確な位置を特定します。ビード特徴モデルを作成すると、ジョブ実行時に、取り込んだ画像中のビード特徴とビードモデルを比較して、ビードが正しい位置あるかどうか、欠陥またはギャップなどの偏差がビードにあるかどうかを決定し、検出された欠陥/ギャップの数を返します。

注:
  • 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。
  • 入力値はすべてピクセル単位です。キャリブレーションでワールド座標に変換されている場合でも、入力値はピクセル単位となります。

ビードトラッカー欠陥検出ツールは、溶接ビードなどのビード特徴が同じ位置に存在し、ビードの形状や幅に偏差がないかを確認する場合などに有用です。

  1. ビードトラッカー欠陥検出ツールを設定するには
  2. ビードトラッカー欠陥検出ツールのパラメータを調整するには
  3. ビードトラッカー欠陥検出ツールの入出力プロパティを使用するには


ビードトラッカー欠陥検出ツールを設定するには

ツールを追加したら、領域タイプを選択し、エッジ特徴上で領域を設定します。

  1. [領域タイプ] ドロップダウンメニューから、領域のタイプ ([マスク領域] または [ポリラインパス])を選択してください。エッジ特徴を囲むように領域を配置、設定します。領域を配置する際には、エッジが領域のサーチ方向と並行になっていること、および領域ができるだけ多くのエッジを囲んでいることを確認して下さい。また領域から意味のない不必要なノイズが除外されるようにしてください。最初にツールを設定する際には、理想的なエッジ特徴を含む画像を使用してください。その後、エッジ候補を含む画像を取り込み、欠陥やギャップなどの偏差があるかどうかを決定します。

注: マスク領域内の黄色の破線は、エッジ遷移が検出される領域内のエリアを定義します。

  2. [OK] ボタンを押し、領域を確定してください。ツールの追加を取りやめるには、[キャンセル] ボタンを押します。

  3. 領域を設定したら、[登録ビード]、[エッジ]、[エッジ得点]、[欠陥]、[ギャップ]、[ポジション] などのタブを選択し、パラメータおよび領域を必要に応じて調整します。その際に、エッジ候補が正しく検出され、ポリラインが正しく作成されいることを確認して下さい。
  4. 領域およびパラメータを調整したら、[登録ビード] タブを開き、[登録] ボタンを押して、ビードエッジモデルを作成します。その後、画像を取り込み、登録ビードエッジモデルと比較します。
  5. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  6. 必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


ビードトラッカー欠陥検出ツールのパラメータを調整するには

ツールの領域を確定したら、用途にあわせてツールを最適化してください。

ビードトラッカー欠陥検出ツールの設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [登録ビード] タブ
  • [エッジ] タブ
  • [エッジ得点] タブ
  • [欠陥] タブ
  • [ギャップ] タブ
  • [ポジション] タブ
  • [統計]、[幅欠陥]、[ギャップ] および [位置欠陥] テーブルタブ

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (ビードトラッカー欠陥検出ツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。ツールのデフォルト名はビードトラッカー_1 で、末尾の番号はツールに応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール画像

ツールが検査を実行する画像を指定します。選択肢は、フィルタなしの取り込み画像 (デフォルト) 、または画像フィルタツールあるいはカラーツールの出力画像 (カラーブロブ/カラーブロブ (1-10) 位置決めツール、カラーピクセル計数、カラーブロブ有無判定ツール、カラーブロブ面積/カラーブロブ面積 (1-10) 寸法測定ツール、カラーブロブ計数ツール、カラーモデル識別ツール、およびカラーから二値化変換画像フィルタツール) です。このコントロールは、画像フィルタツールまたはカラーツールが追加されている場合のみ有効になります。

Closed ツールフィクスチャ

ツールのフィクスチャを定義します。このコントロールは、フィクスチャを定義する他のツールがすでに追加されている場合のみ有効になります。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 領域タイプ

解析中の画像エリア定義に使用される領域のタイプを指定します。選択肢は、[マスク領域] (デフォルト) および [ポリラインパス] です。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[登録ビード] タブ (ビードファインダー欠陥検出ツール)

[登録ビード] タブを選択すると、ビード特徴の位置に関連するグラフィックスが表示されます。表示されるのは、領域内で検出されたすべてのエッジ候補 (カラーコード化された小さな円で表示されます)および、ビード位置 (青のポリライン)です。領域は、調整することができます。

Closed [登録] ボタン

ビードエッジモデルを定義します。[登録] ボタンは、ビードエッジモデルの設定に使用します。ツールのパラメータおよび領域を設定したら、[登録] ボタンを押して、ビードエッジモデルの関連特徴を強調させます。ビードエッジモデルを登録すると、取り込んだ画像中のビード特徴と登録したビードエッジモデルを比較して、欠陥またはギャップなどの偏差があるかどうかを決定します。

注: ビードエッジモデルを登録するまで、ツール結果は FAIL となります。

Closed 登録ビードのキャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 8)。キャリパは、検査方向に沿って解析します。

Closed 登録ビードのキャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed 登録ビードのエッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 登録ビードの最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed 登録ビードのエッジ方向

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[左→右] です。

Closed 登録ビードのエッジ0 遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 登録ビードのエッジ1 遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 登録ビード規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 登録ビード規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 登録ビードのコントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

Closed 登録ビード規則: ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 登録ビードの得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。

Closed 登録ビードのキャリパ

領域内のキャリパ総数を表示します。

Closed 登録ビードのキャリパインデックス

検出および表示する、キャリパを指定します。

Closed 登録ビードの全キャリパ表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ] タブ (ビードトラッカー欠陥検出ツール)

[エッジ] タブを選択すると、ビードパスの位置 (青) 、検出されたすべてのエッジ (緑)、ビードパスの位置から生成されたポリラインパスを定義するキャリパ (水色) が表示されます。水色のキャリパは、[ポリライン幅] パラメータを使用してのみ、調整することができます。[ポリライン幅]、[キャリパサイズ]、[キャリパ間隔]、および [最小コントラスト] パラメータを必要に応じて調整して、使用するエッジを検出することができます。

Closed ポリライン幅

ポリライン定義に使用するキャリパの幅を指定します (1～1920、デフォルト = 25)。

Closed キャリパサイズ

各キャリパのピクセル数を指定します (1～639、デフォルト = 5)。キャリパは、検査方向に沿って解析します。

Closed キャリパ間隔

キャリパの終端から、次のキャリパの開始位置までの距離をピクセルで指定します(-1～639、デフォルト = 0)。

Closed エッジ幅

エッジ遷移が発生する位置のピクセル距離を指定します (1～10、デフォルト = 3)。画像からノイズを削除することができます。

Closed 最小コントラスト

エッジとみなされる、最小グレースケールコントラスト遷移を指定します (1～255、デフォルト = 10)。

Closed キャリパ数

領域内のキャリパ総数を表示します。

Closed キャリパインデックス

検出および表示する、キャリパを指定します。

Closed すべてのキャリパを表示

領域内のキャリパを常にすべて表示するかどうかを指定します。デフォルトは、OFF (非表示) です。


[エッジ得点] タブ (ビードトラッカー欠陥検出ツール)

[エッジ得点] タブを選択すると、領域内で検出されたすべてのエッジ候補 (カラーコード化された小さな円で表示されます) や、検出されたエッジ (暗い緑色)、ビード位置 (青のポリライン) 、ビードの最大幅および最小幅 (黄色の線)が表示されます。同時に、検出された欠陥またはギャップも表示されます。

Closed エッジ方向の検出

領域を基準に、エッジを検出する方向 ([左→右]、[右→左]、[内→外] [外→内]) を指定します。デフォルトは、[外→内] です。

Closed エッジ0 の遷移

最初に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed エッジ 1 の遷移

2 番目に検出されたエッジの遷移 ([暗→明]、[明→暗]、[任意]) を指定します。デフォルトは、[任意] です。検出精度や処理時間を向上するには遷移タイプを明示してください。

Closed 規則:最初のエッジ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、最初に検出されたエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed 規則:エッジ強度

エッジ候補がエッジ基準を満たすかどうかを決定する際に、コントラスト遷移が最も強いエッジを第一に考慮するかどうかを指定します。デフォルトは、ON です。

Closed コントラスト上限

エッジとみなされる、エッジコントラスト遷移の上限を定義します (2～255、デフォルト = 255)。この値よりエッジコントラスト遷移が高いエッジは、同じ最高得点を返します。

Closed 規則:ペアサイズ

エッジ候補がエッジ基準を満たすかどうかを決定する際に、[ペアサイズ] パラメータで指定した値に最も近いサイズのエッジペアを第一に考慮するかどうかを指定します。デフォルトは、OFF です。

Closed ペアサイズ

最高得点を与えるエッジペアサイズを指定します (1～1920、デフォルト = 5)。このパラメータを有効にすると、この値より大きいまたは小さいサイズのエッジペアが検出されたとき、この値に近いエッジペアが選択されます。例えば、[ペアサイズ] を10に設定しているとき、8 と 14 のエッジペアが検出されると、14 より 8 のほうが 10 に近いので、8 が選択されます。このパラメータを使用するには、[規則: ペアサイズ] チェックボックスを ON にする必要があります。

Closed 得点しきい値

得点しきい値を指定します。この値より得点の低いエッジは削除されます (0～255、デフォルト = 10)。


[欠陥] タブ (ビードトラッカー欠陥検出ツール)

[欠陥] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

Closed 最小幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より幅距離が短い場合、欠陥とみなされません。

Closed 最大幅

検出されたエッジペア間の幅距離をピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より幅距離が長い場合、欠陥とみなされません。

Closed サイズ有効

サイズ欠陥 (エッジ沿いの長さ) を考慮するかどうかを指定します。デフォルトは、ON です。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 10)。ポリラインからの連続偏差がこの値より小さい場合、欠陥とみなされません。

Closed 最大サイズ

最大欠陥サイズをピクセルで定義します (0.001～1920、デフォルト = 1000)。ポリラインからの連続偏差がこの値より大きい場合、欠陥とみなされません。

Closed 面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、ポリライン上の長さ、ポリラインからの欠陥エッジの長さを考慮します。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 最小面積

最小面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

Closed 最大面積

最大面積サイズをピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。


[ポジション] タブ (ビードトラッカー欠陥検出ツール)

[ポジション] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。最後に登録したビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

Closed 位置欠陥有効

位置欠陥を考慮するかどうかを指定します。デフォルトは ON です。

Closed 位置欠陥の最小距離

エラーとみなされない、ビードエッジモデル中心からのエッジ候補の最小距離をピクセルで指定します (0.001～1920、デフォルト = 3)。

Closed 位置欠陥サイズ有効

位置エラー定義に、サイズ測定基準も使用するかどうかを指定します。デフォルトは、ON です。サイズエラーは、エッジの長さ上に検出されます。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 位置欠陥の最小サイズ

最小欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 3)。ポリラインからの連続偏差がこの値より小さい場合、欠陥とみなされません。

Closed 位置欠陥の最大サイズ

最大欠陥サイズをピクセルで指定します (0.001～1920、デフォルト = 1000)。ポリラインからの連続偏差がこの値より大きい場合、欠陥とみなされません。

Closed 位置欠陥面積有効

面積欠陥を考慮するかどうかを指定します。デフォルトは、ON です。面積欠陥は、ポリライン上の長さ、ポリラインからの欠陥エッジの長さを考慮します。

注: [サイズ有効] および [面積有効] の両チェックボックスを ON にした場合、両方の条件を満たさない欠陥のみが表示されます。

Closed 位置欠陥の最小面積

最小面積欠陥をピクセルで指定します (0.001～1000000、デフォルト = 10)。この値より面積が小さい場合、欠陥とみなされません。

Closed 位置欠陥の最大面積

最大面積欠陥をピクセルで指定します (0.001～1000000、デフォルト = 1000000)。この値より面積が大きい場合、欠陥とみなされません。

Closed 結果

検出された欠陥、ギャップ、位置エラーの総数を表示します。


[統計]、[幅欠陥] [ギャップ] および [位置欠陥] テーブルタブ (ビードトラッカー欠陥検出ツール)

[統計] テーブルタブは、一定時間内のツールのデータを記録します。 [幅欠陥] および [ギャップ] および [位置欠陥] テーブルタブは、最初に検出された 10 個の欠陥/ギャップを表示します。

Closed インデックス

検出された欠陥/ギャップの順番。エッジ上の位置によりソートされます (1～10)。EasyBuilder では 0 から数えます。

Closed X

欠陥/ギャップの周りを囲む四角形の X 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed Y

欠陥/ギャップの周りを囲む四角形の Y 座標を返します ([キャリブレーション単位] を選択し、[画像の設定] ステップでキャリブレーションした場合。それ以外は、ピクセル値を返します)。

Closed 面積

欠陥/ギャップの周りを囲む四角形の面積を返します。

Closed サイズ

エッジ上の欠陥/ギャップのサイズ (長さ) を返します。

Closed キャリパ

欠陥/ギャップが及ぶキャリパの範囲を返します。

Closed キャリブレーション単位/ピクセル

テーブルに表示する結果の単位 (ワールド座標 = キャリブレーション単位、またはピクセル) を指定します。

注: 座標の値はピクセル単位で表示されます。ただし、[画像の設定] でキャリブレーションを行うと、その単位で表示されます。


[ギャップ] タブ (ビードトラッカー欠陥検出ツール)

[ギャップ] タブを選択すると、検査対象物またはオブジェクトに発生しているエラーの識別/分類に関連したグラフィックスが表示されます。ビードの位置は青のポリラインで、ビードの最大幅および最小幅は黄色の線で表示されるほか、検出された欠陥/ギャップも表示されます。

Closed ギャップの検出

検出エッジ中のギャップを考慮するかどうかを指定します。デフォルトは、ON です。

Closed 最小ギャップ

最小ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 3)。この値より小さい場合、ギャップとみなされません。

Closed 最大ギャップ

最大ギャップをピクセル単位で指定します (0.001～1920、デフォルト = 1000)。この値より大きい場合、ギャップとみなされません。

Closed 終端ギャップを無視

領域の始まりと終わりで検出されたギャップを考慮するかどうかを指定します。デフォルトは、OFF です。

Closed 結果

検出された欠陥/ギャップの総数を表示します。


ビードトラッカー欠陥検出ツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
面積有効 | 整数値 | X | X | 入出力
キャリパインデックス | 整数値 | X | X | 入出力
キャリパサイズ | 整数値 | X | X | 入出力
キャリパ間隔 | 整数値 | X | X | 入出力
コントラスト上限 | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
エッジ幅 | 整数値 | X | X | 入出力
エッジ0_の遷移 | 整数値 | X | X | 入出力
エッジ1_の遷移 | 整数値 | X | X | 入出力
エッジ方向の検出 | 整数値 | X | X | 入出力
ギャップの検出 | 整数値 | X | X | 入出力
終端ギャップの無視 | 整数値 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
最大面積 | 浮動小数点 | X | X | 入出力
位置欠陥の最大面積 | 浮動小数点 | X | X | 入出力
位置欠陥の最大サイズ | 浮動小数点 | X | X | 入出力
最大サイズ | 浮動小数点 | X | X | 入出力
最大幅 | 浮動小数点 | X | X | 入出力
最大ギャップ | 浮動小数点 | X | X | 入出力
最小面積 | 浮動小数点 | X | X | 入出力
位置欠陥の最小面積 | 浮動小数点 | X | X | 入出力
位置欠陥の最小距離 | 浮動小数点 | X | X | 入出力
位置欠陥の最小サイズ | 浮動小数点 | X | X | 入出力
最小サイズ | 浮動小数点 | X | X | 入出力
最小幅 | 浮動小数点 | X | X | 入出力
最小コントラスト | 整数値 | X | X | 入出力
最小ギャップ | 浮動小数点 | X | X | 入出力
ペアサイズ | 整数値 | X | X | 入出力
ポリライン幅 | 整数値 | X | X | 入出力
位置欠陥面積有効 | 整数値 | X | X | 入出力
位置欠陥サイズ有効 | 整数値 | X | X | 入出力
位置欠陥有効 | 整数値 | X | X | 入出力
領域タイプ | 整数値 | X | X | 入出力
規則_最初のエッジ | 整数値 | X | X | 入出力
規則_ペアサイズ | 整数値 | X | X | 入出力
規則_エッジ強度 | 整数値 | X | X | 入出力
得点しきい値 | 整数値 | X | X | 入出力
すべてのキャリパを表示 | 整数値 | X | X | 入出力
サイズ有効 | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
登録ビードのキャリパインデックス | 整数値 | X | X | 入出力
登録ビードのキャリパサイズ | 整数値 | X | X | 入出力
登録ビードのキャリパ間隔 | 整数値 | X | X | 入出力
登録ビードのコントラスト上限 | 整数値 | X | X | 入出力
登録ビードのエッジ方向 | 整数値 | X | X | 入出力
登録ビードのエッジ幅 | 整数値 | X | X | 入出力
登録ビードエッジ0_の遷移 | 整数値 | X | X | 入出力
登録ビードエッジ1_の遷移 | 整数値 | X | X | 入出力
登録ビードの最小コントラスト | 整数値 | X | X | 入出力
登録ビードのペアサイズ | 整数値 | X | X | 入出力
登録ビードの規則_最初のエッジ | 整数値 | X | X | 入出力
登録ビードの規則_ペアサイズ | 整数値 | X | X | 入出力
登録ビードの規則_エッジ強度 | 整数値 | X | X | 入出力
登録ビードの得点しきい値 | 整数値 | X | X | 入出力
登録ビードの全キャリパを表示 | 整数値 | X | X | 入出力
キャリパ数 | 浮動小数点 | X | X | 出力
キャリパ.不良.数 | 浮動小数点 | X | X | 出力
キャリパ.不良.累積 | 浮動小数点 | X | X | 出力
キャリパ.不良.最大 | 浮動小数点 | X | X | 出力
キャリパ.不良.パーセンテージ | 浮動小数点 | X | X | 出力
キャリパ.不良.最小 | 浮動小数点 | X | X | 出力
キャリパ.良.数 | 浮動小数点 | X | X | 出力
キャリパ.良.累積 | 浮動小数点 | X | X | 出力
キャリパ.良.最大 | 浮動小数点 | X | X | 出力
キャリパ.良.パーセンテージ | 浮動小数点 | X | X | 出力
キャリパ.良.最小 | 浮動小数点 | X | X | 出力
欠陥.数 | 浮動小数点 | X | X | 出力
欠陥.累積 | 浮動小数点 | X | X | 出力
欠陥.最大 | 浮動小数点 | X | X | 出力
欠陥.過大幅.数 | 浮動小数点 | X | X | 出力
欠陥.過大幅.累積 | 浮動小数点 | X | X | 出力
欠陥.過大幅.最大 | 浮動小数点 | X | X | 出力
欠陥.過大幅.パーセンテージ | 浮動小数点 | X | X | 出力
欠陥.過大幅.最小 | 浮動小数点 | X | X | 出力
欠陥.最小 | 浮動小数点 | X | X | 出力
欠陥.過小幅.数 | 浮動小数点 | X | X | 出力
欠陥.過小幅.累積 | 浮動小数点 | X | X | 出力
欠陥.過小幅.最大 | 浮動小数点 | X | X | 出力
欠陥.過小幅.パーセンテージ | 浮動小数点 | X | X | 出力
欠陥.過小幅.最小 | 浮動小数点 | X | X | 出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
ギャップ.数 | 浮動小数点 | X | X | 出力
ギャップ.累積 | 浮動小数点 | X | X | 出力
ギャップ.最大 | 浮動小数点 | X | X | 出力
ギャップ.最小 | 浮動小数点 | X | X | 出力
InspectEdgeWidth | 文字列 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
Pass_数 | 浮動小数点 | X | X | 出力
位置.数 | 浮動小数点 | X | X | 出力
位置.累積 | 浮動小数点 | X | X | 出力
位置.最大 | 浮動小数点 | X | X | 出力
位置.最小 | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効_ステータス | 浮動小数点 | X | X | 出力
傷総数 | 浮動小数点 | X | X | 出力
マスク領域 | 動作 | X | X |
ポリラインパス | 動作 | X | X |
登録 | 動作 | X | X |


N 点キャリブレーションツール

N 点キャリブレーションツールは、2～16 の入力特徴と、そのワールド座標を使用して、キャリブレーションファイルを作成します。キャリブレーションファイルをエクスポートして、[画像の設定] ステップでキャリブレーションタイプとして選択し、他のジョブに使用することができます。

ヒント: キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

このツールは、検査対象物またはオブジェクトの実際の寸法がCAD 図面などから分かっており、その値をキャリブレーションとして適用したい場合に有用です。このタイプのアプリケーションでは、In-Sight ビジョンシステムが検査対象物またはオブジェクトの画像を取り込み、実単位を画像のピクセル座標に関連付けます。ビジョンシステムのローカルファイルシステムに保存することにより、他のジョブにキャリブレーション結果を適用することができます。

  1. N 点キャリブレーションツールを設定するには
  2. N 点キャリブレーションツールのパラメータを調整するには
  3. N 点キャリブレーションツールの入出力プロパティを使用するには
注:
  • キャリブレーション点を定義するのに、他の位置決め/検査ツールを入力として使用します。必要な位置決め/検査ツールを設定してから、このツールを追加してください。
  • N 点またはシーケンス N 点キャリブレーションツールを使用している場合、キャリブレーション時およびジョブ実行時の、物理的・光学的な設定 (レンズ、ビジョンシステム、およびビジョンシステムと画像を取り込むシーン間の物理的関係) を同一にしてください。設定が変更されてしまうと、システムをキャリブレーションし直す必要があります。よって、キャリブレーション時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することを推奨します。ビジョンシステムおよびレンズも、オリジナル設定およびキャリブレーション設定を保持するようにしてください。例えば、 (解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、ピクセルをワールド座標にマッピングした 2D 変換計算が無効となってしまいます。


N 点キャリブレーションツールを設定するには

ヒント: キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

ツールを追加したら、キャリブレーションの作成に使用される入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールにジョブを追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。同時に、円有無判定ツールを挿入し、未設定の円特徴を定義します。

  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。

  3. 次に、キャリブレーションの定義に使用する特徴をすべて選択してください。最小 2 から最大 16 までの入力特徴を選択することができます。

  4. 目的の特徴をすべて選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)

  5. ツールを追加し、入力変数に使用する値を定義したら、各入力特徴の実単位値を定義します。点テーブルから点を選択し、その実単位値を [ワールド X] および [ワールド Y] フィールドに手動または増減コントロールを使用して入力します。
  6. ジョブファイルを保存します。
  7. [設定] タブの [エクスポート] ボタンを押すと、In-Sight ビジョンシステムのローカルファイルシステムのキャリブレーションファイルがセットされます。同時に、[画像の設定] ステップ、キャリブレーションタイプの [インポート] オプションが選択され、キャリブレーションが有効になります。
  8. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  9. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


N 点キャリブレーションツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

N 点キャリブレーションツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 点テーブル

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (N 点キャリブレーションツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([画像の設定]、[入力/出力] および [通信]) で参照されます。デフォルトのツール名はキャリブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (N 点キャリブレーションツール)

Closed ファイル名

キャリブレーションファイル名を定義します。デフォルトのファイル名は、[デフォルト] です。

Closed フルネーム

[画像の設定] ステップで、[キャリブレーションタイプ] を [インポート] に設定した場合に、キャリブレーションファイルのフルネームが表示されます。[画像の設定] ステップで表示される前に、ファイルをエクスポートしておく必要があります。

Closed エクスポート

キャリブレーションファイルを In-Sight ビジョンシステムのローカルファイルシステムにエクスポートします。

Closed 自動エクスポート

ジョブファイルがロードされたとき、または画像が取り込まれたときに、自動的にキャリブレーションファイルをエクスポートするかどうかを定義します。 有効 (ON) にした場合、ツールは自動的にキャリブレーションファイルをエクスポートします (デフォルトは、無効/OFF)。

注: [自動エクスポート] チェックボックスを ON にした場合、キャリブレーションデータを含むジョブファイルを保存してから、エクスポートする必要があります。 ジョブファイルの保存後、キャリブレーションファイルが In-Sight ファイルペインに表示されない場合、ほかの In-Sight ビジョンシステムまたはエミュレータをクリックします。 その後、使用しているビジョンシステムを選択し直すと、ジョブファイルは表示されます。


テーブル (N 点キャリブレーションツール)

ピクセルおよびワールド座標点テーブルを使用して、キャリブレーション用の実単位を表示、定義します。

Closed 点

検出した点の読み取り専用インデックスリスト (1～16) を表示します (EasyBuilder では 0 から数えます)。

Closed ピクセル行

点のピクセル行 (X) ロケーションを表示します。

Closed ピクセル列

点の画像列 (X) 座標を表示します。

Closed ワールド X

点の X 座標値 (実単位) を表示します。

Closed ワールド Y

点の Y 座標値 (実単位) を表示します。

Closed ワールド X

選択した点の X 座標値 (実単位) を定義します。

Closed ワールド Y

選択した点の Y 座標値 (実単位) を定義します。

Closed [点の選択]

点として使用する入力特徴の選択を可能にします。このボタンを押すと、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。


N 点キャリブレーションツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

In-Sight 2000-23M ビジョンセンサ

注: OPC は In-Sight 2000-23M ビジョンセンサではサポートされていません。

シンボリック名 | データ型 | EasyView | 入出力データ
自動エクスポート | 整数値 | X | 入出力
説明 | 文字列 | X | 入出力
外部エクスポート | 整数値 | X | 入出力
ファイル名 | 文字列 | X | 入出力
総合判定に含める | 整数値 | X | 入出力
ツール有効 | 整数値 | X | 入出力
ワールド点0～15.X | 浮動小数点 | X | 入出力
ワールド点0～15.Y | 浮動小数点 | X | 入出力
エラー_数 | 浮動小数点 | X | 出力
実行_時間 | 浮動小数点 | X | 出力
エクスポート完了 | 浮動小数点 | X | 出力
FAIL | 浮動小数点 |  | 出力
FAIL_数 | 浮動小数点 | X | 出力
フルネーム | 文字列 | X | 出力
PASS | 浮動小数点 |  | 出力
PASS_数 | 浮動小数点 | X | 出力
ピクセル点0～15.X | 浮動小数点 | X | 出力
ピクセル点0～15.Y | 浮動小数点 | X | 出力
ステータス | 浮動小数点 | X | 出力
ツール有効ステータス | 浮動小数点 | X | 出力
エクスポート | 動作 | X |

In-Sight ビジョンシステム

シンボリック名 | データ型 | OPC | EasyView | 入出力データ
自動エクスポート | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部エクスポート | 整数値 | X | X | 入出力
ファイル名 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
ワールド点0～15.X | 浮動小数点 | X | X | 入出力
ワールド点0～15.Y | 浮動小数点 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
エクスポート完了 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フルネーム | 文字列 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ピクセル点0～15.X | 浮動小数点 | X | X | 出力
ピクセル点0～15.Y | 浮動小数点 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
エクスポート | 動作 | X | X |


シーケンス N 点キャリブレーションツール

シーケンス N 点キャリブレーションツールは、1 個の入力特徴とそのワールド座標を使用し、連続する画像取り込みに対して、キャリブレーションファイルを作成します。キャリブレーションファイルをエクスポートして、[画像の設定] ステップでキャリブレーションタイプとして選択し、他のジョブに使用することができます。

ヒント: キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

このツールは、In-Sight ビジョンシステムとロボットの座標システムをキャリブレーションする場合に有用です。このタイプのアプリケーションでは、ロボットコントローラが、画像取り込みごとに 1 つづつ、異なる複数のロケーションの検査対象物をビジョンシステムに提示します。画像取り込むごとに、点がキャリブレーションテーブルに追加されていきます。ロボットがロケーションすべてを提示し、点がすべて保存されると、キャリブレーションファイルをエクスポートし、ジョブファイルを保存することができます。

  1. シーケンス N 点キャリブレーションツールを設定するには
  2. シーケンス N 点キャリブレーションツールのパラメータを調整するには
  3. シーケンス N 点キャリブレーションツールの入出力プロパティを使用するには
注:
  • キャリブレーション点を定義するのに、他の位置決め/検査ツールを入力として使用します。必要な位置決め/検査ツールを設定してから、このツールを追加してください。
  • N 点またはシーケンス N 点キャリブレーションツールを使用している場合、キャリブレーション時およびジョブ実行時の、物理的・光学的な設定 (レンズ、ビジョンシステム、およびビジョンシステムと画像を取り込むシーン間の物理的関係) を同一にしてください。設定が変更されてしまうと、システムをキャリブレーションし直す必要があります。よって、キャリブレーション時とジョブ実行時に、同一のビジョンシステムおよびレンズを使用することを推奨します。ビジョンシステムおよびレンズも、オリジナル設定およびキャリブレーション設定を保持するようにしてください。例えば、 (解像度を変更することによって) 画像取り込みフォーマットを変更したり、ビジョンシステムを動かしたりすると、ピクセルをワールド座標にマッピングした 2D 変換計算が無効となってしまいます。


シーケンス N 点キャリブレーションツールを設定するには

ヒント: キャリブレーション作成後、ジョブファイルを保存することを推奨します。その後、キャリブレーションを実行するには、キャリブレーションジョブをロードし、画像を取り込んでから、更新したキャリブレーションファイルを参照するジョブに自動エクスポートします。

ツールを追加したら、キャリブレーションの作成に使用される入力特徴 (点、フィクスチャ原点または円特徴の中心) を定義します。

  1. ツールにジョブを追加すると、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。同時に、円有無判定ツールを挿入し、未設定の円特徴を定義します。
  2. 水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。
  3. 目的の特徴を選択した後、[OK] ボタンを押してください。(ツールの追加を取りやめるには、[キャンセル] ボタンを押してください。)
  4. [設定] タブの [点の数] パラメータを定義して、キャリブレーションを定義する点/画像取り込みの数を指定します
  5. ロボットコントローラを移動して、次のロケーションで点の画像を取得します。このプロセスを繰り返して、すべての点を取り込みます。
  6. すべての点を追加したら、点の実単位値を定義します。点テーブルから点を選択し、その実単位値を [ワールド X] および [ワールド Y] フィールドに手動または増減コントロールを使用して入力します。
  7. [設定] タブの [エクスポート] ボタンを押すと、in-Sight ビジョンシステムのローカルファイルシステムのキャリブレーションファイルがセットされます。 同時に、[画像の設定] ステップ、キャリブレーションタイプの [インポート] オプションが選択され、キャリブレーションが有効になります。
  8. ツールの初期設定を済ませたら、検査対象物のばらつきを考慮して、いくつかの画像をロードし、必要に応じてパラメータを調整してください。
  9. 最後に、必要な場合、ツールの入出力プロパティを使用して、ツールデータを他のツール/外部デバイスと共有します。


シーケンス N 点キャリブレーションツールのパラメータを調整するには

ツールの確定後、用途に合わせてツールの動作をカスタマイズしたり、チューニングしたりすることができます。

シーケンス N 点キャリブレーションツール設定ペインには、次のコントロールが表示されます。

  • [全般] タブ
  • [設定] タブ
  • 点テーブル

ヒント: ジョブをテストするには、TestRun を使用してください。TestRun は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。ジョブが予想される範囲内で動作するか、または検査対象物のばらつきを許容するのにパラメータの調整が必要かどうかを確認することができます。


[全般] タブ (シーケンス N 点キャリブレーションツール)

Closed ツール名

検査ツールの名前を定義します。この名前は [結果の設定] の各ステップ ([入力/出力] および [通信]) で参照されます。デフォルトのツール名はキャリブ_1 で、末尾の番号はツールの追加に応じて増加します。ツールの用途に合わせて適切な名前に変更してください。 ツールの用途に合わせて適切な名前に変更してください。

Closed ツール有効

検査ツールの実行可否を定義します。デフォルトは [ON] で、 [OFF] を選択するとツールは実行されません。[式] を選択すると、[式] の結果に応じてツールが実行されます。([式] パラメータがあるツールにのみ表示されます)。また、[入力] を選択すると、画像取り込み時点のディスクリート入力ラインの状態に応じてツール実行可否を切り替えることができます。そうすることにより、どのツールを実行すべきかを、PLC などの制御システムから選択することができます。

Closed 総合判定に含める

ジョブの総合 PASS/FAIL ステータスに、ツールの PASS/FAIL を含めるかどうかを定義します。デフォルトは ON で、ジョブの総合 PASS/FAIL ステータスに含めます。チェックボックスを OFF にすると、そのツールの PASS/FAIL ステータスは、ジョブの他のツールから切り離されます。ツールが FAIL するように設定されている場合、このコントロールは OFF である必要があります。例えば、2 つの PatMax パターン (1-10) 識別ツールを使用して、対象物が右側のパーツであるか左側のパーツであるかを決定する場合、検査のたびに、2 つのツールのうち 1 つは FAIL となります。チェックボックスが ON になっていると、パーツが識別されても、ジョブは検査のたびに FAIL となってしまいます。

Closed 実行時間 (ms)

検査実行にかかった時間をミリ秒単位で表示します。実行時間は、さまざまな要因 (シーンの複雑さ、特徴の出現位置、許容範囲の設定) によって大きく変化します。

Closed 説明

ツールの目的を説明するコメントを入れることができます (デフォルト = 空白)。255 字までの英数字、または 127 字までのアジア言語の文字をサポートします。


[設定] タブ (シーケンス N 点キャリブレーションツール)

Closed 点の数

取り込む点の数を定義します (2～16、デフォルトは 12)。

Closed リセット

取り込みカウントを 0 にリセットします。

Closed オンラインリセット

In-Sight ビジョンシステムをオンラインに切り替えたときに、取り込みカウントをリセットするかどうかを定義します。デフォルトは、無効 (OFF) です。

Closed ジョブロードのリセット

ジョブファイルがロードされたときに、取り込みカウントをリセットするかどうかを定義します。デフォルトは有効 (ON) です。

Closed ファイル名

キャリブレーションファイル名を定義します。デフォルトのファイル名は、[デフォルト] です。

Closed フルネーム

[画像の設定] ステップで、[キャリブレーションタイプ] を [インポート] に設定した場合に、キャリブレーションファイルのフルネームが表示されます。[画像の設定] ステップで表示される前に、ファイルをエクスポートしておく必要があります。

Closed エクスポート

キャリブレーションファイルを In-Sight ビジョンシステムのローカルファイルシステムにエクスポートします。

Closed 自動エクスポート

ジョブファイルがロードされたとき、または画像が取り込まれたときに、自動的にキャリブレーションファイルをエクスポートするかどうかを定義します。 有効 (ON) にした場合、ツールは自動的にキャリブレーションファイルをエクスポートします (デフォルトは、無効/OFF)。

注: [自動エクスポート] チェックボックスを ON にした場合、キャリブレーションデータを含むジョブファイルを保存してから、エクスポートする必要があります。 ジョブファイルの保存後、キャリブレーションファイルが In-Sight ファイルペインに表示されない場合、ほかの In-Sight ビジョンシステムまたはエミュレータをクリックします。 その後、使用しているビジョンシステムを選択し直すと、ジョブファイルは表示されます。

Closed 結果

ツールの PASS/FAIL ステータスを表示します。


テーブル (シーケンス N 点キャリブレーションツール)

ピクセルおよびワールド座標点テーブルを使用して、キャリブレーション用の実単位を表示、定義します。

Closed 点

検出した点の読み取り専用インデックスリスト (1～16) を表示します (EasyBuilder では 0 から数えます)。

Closed ピクセル行

点のピクセル行 (X) ロケーションを表示します。

Closed ピクセル列

点の画像列 (X) 座標を表示します。

Closed ワールド X

点の X 座標値 (実単位) を表示します。

Closed ワールド Y

点の Y 座標値 (実単位) を表示します。

Closed ワールド X

選択した点の X 座標値 (実単位) を定義します。

Closed ワールド Y

選択した点の Y 座標値 (実単位) を定義します。

Closed [点の選択]

点として使用する入力特徴の選択を可能にします。このボタンを押すと、EasyBuilder はその時点の画像を調査し、自動的に抽出した特徴 (点、フィクスチャ原点、円特徴の中心) を水色のスマートフィーチャーとして提示します。同時に他のツールで定義済みの特徴を緑色で提示します。水色のエッジまたは直線で提示されている特徴の 1 つをクリックすると、紫色に変わります。


シーケンス N 点キャリブレーションツールの入出力プロパティを使用するには

次の表に、ツールのプロパティ (入力パラメータおよび出力結果) を示します。表には、シンボリック名、データタイプ、および OPC 通信や EasyView アイテムとして使用できるか、入力/出力データとして外部デバイスに使用できるかどうかが表記されています。

Closed シンボリック名

ツールプロパティのシンボリック名は修正することができません。外部通信で使用される場合、ツールの [ツール名] パラメータで設定した名前から始まります (ブロブ (1-10) 位置決めツールの境界入力パラメータ、「ブロブ_1.境界ブロブ」など)。

Closed データタイプ

動作、浮動小数点、整数値、文字列の 4 種類があります。

  • 動作: 領域またはボタンといった、動作を強制する入力パラメータ (文字認識識別ツール、[設定] ペインの [フォントの登録] ボタンなど)。
  • 浮動小数点: 浮動小数点値 (パターン位置決めツール、フィクスチャ.X 出力結果の浮動小数点値、335.264 など)。
  • 整数値: 整数値 (ブロブ (1-10) 位置決めツール、検出する数入力パラメータに使用される整数値、4 など)。
  • 文字列: 文字列値 (円位置決めツール、結果出力結果の文字列、(857.9、666.6) 直径 = 144.4 など)。
Closed OPC

[通信] アプリケーションステップの [OPC タグの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed EasyView

[通信] アプリケーションステップの [EasyView アイテムの選択] ダイアログにツールのプロパティを表示するかどうかを示します。

Closed 入出力データ

[通信] アプリケーションステップで、PLC やロボットなどの外部デバイスとの通信を設定する際に、[入力データの選択] または [出力データの選択] ダイアログにツールプロパティを表示するかどうかを示します。

シンボリック名 | データタイプ | OPC | EasyView | 入出力データ
自動エクスポート | 整数値 | X | X | 入出力
説明 | 文字列 | X | X | 入出力
外部エクスポート | 整数値 | X | X | 入出力
外部リセット | 整数値 | X | X | 入出力
ファイル名 | 文字列 | X | X | 入出力
総合判定に含める | 整数値 | X | X | 入出力
ジョブロードのリセット | 整数値 | X | X | 入出力
点数 | 整数値 | X | X | 入出力
オンラインリセット | 整数値 | X | X | 入出力
ツール有効 | 整数値 | X | X | 入出力
ワールド点0～15.X | 浮動小数点 | X | X | 入出力
ワールド点0～15.Y | 浮動小数点 | X | X | 入出力
エラー_数 | 浮動小数点 | X | X | 出力
実行_時間 | 浮動小数点 | X | X | 出力
エクスポート完了 | 浮動小数点 | X | X | 出力
FAIL | 浮動小数点 | X |  | 出力
FAIL_数 | 浮動小数点 | X | X | 出力
フルネーム | 文字列 | X | X | 出力
PASS | 浮動小数点 | X |  | 出力
PASS_数 | 浮動小数点 | X | X | 出力
ピクセル点0～15.X | 浮動小数点 | X | X | 出力
ピクセル点0～15.Y | 浮動小数点 | X | X | 出力
結果 | 文字列 | X | X | 出力
ステータス | 浮動小数点 | X | X | 出力
ツール有効ステータス | 浮動小数点 | X | X | 出力
エクスポート | 動作 | X | X |
リセット | 動作 | X | X |


入力/出力

[入力/出力] ステップは、サポートされている In-Sight ビジョンシステムおよび I/O モジュールのディスクリート入出力ライン設定を定義します。 ラインの名前をカスタマイズしたり、信号タイプを設定したり、信号のエッジ遷移や強制入出力の設定をして、アプリケーションのテストを行うことができます。

  • 入出力ラインを設定するには
    • I/O モジュールの設定
    • 入出力の数
    • デフォルトの入出力ライン
    • 出力 [詳細] ダイアログのコントロール
  • 入力: ジョブファイルをロードするには
  • 入力: 位置決めツールおよび検査ツールの ON/OFF を切り替えるには
  • 入力: 画像取り込みをトリガするには
  • 入力: 入力ラインを介してモデルパターンを登録するには
  • 出力: 画像取り込みミスを送信するには
  • 出力: 画像取り込み時に照明を同期させるには
  • 出力: 位置決めツールまたは検査ツールの結果をラインに設定するには
注:
  • このアプリケーションステップは、エミュレータ使用時に無効となります。
  • ディスクリート入出力ラインの設定前に、使用する出力デバイスが PNP (ソース) または NPN (シンク) かに留意し、In-Sight センサまたはモジュールに正しく接続されていることを確認してください。 詳細については、In-Sight センサまたは I/O モジュールの取扱説明書をご参照ください。


入出力ラインを設定するには

  1. [I/O の種類] ボタンをクリックして、[I/O モジュールの設定] ダイアログを開きます (オプション)。 I/O モジュールを設定したら [OK] ボタンを押し、[I/O モジュールの設定] ダイアログを閉じます。ビジョンシステムと I/O モジュールが接続されると、リストの I/O モジュール名の隣に「 (接続済み) 」のメッセージが表示されます。I/O モジュールに接続後、ラインをカスタマイズすることができます。
  2. 設定する入力または出力ラインを選択してください。 利用できる入力または出力ラインの数は、In-Sight のモデルと I/O モジュールの接続状況によって異なります。詳細については、このトピックをご参照ください。
  3. In-Sight 76xx～79xx シリーズのみ: ラインが双方向I I/O をサポートする場合、[方向] ドロップダウンから [入力] または [出力] を選択してください。
  4. [名前] フィールドに新しい名前を入力して、入力ライン名をカスタマイズすることができます。 名前は 15 バイトまで入力可能です。ライン名は表示のためだけに用意されており、出力ラインの機能を変更したり、参照したりすることはできません。

  5. 次に、選択した入力ラインの [信号タイプ] を定義します。 次のいずれかの方法で、各ラインを設定することができます。

    入力信号タイプ 説明
    ユーザ用

    汎用入力ラインです。位置決めツールおよび検査ツールを ON/OFF にします。
    リセットカウンタ

    EasyBuilder カウンタ (Job.Fail_Count、Job.Inspection_Count、Job.Pass_Count、<Tool>.Error_Count、<Tool>.Fail_Count および <Tool>.Pass_Count) を 0 にリセットします。

    注:

    • この信号タイプは、ビジョンシステムがオンライン時のみに使用できます。
    • リセットカウンタに設定できるのは、1 つの入力のみです。
    • 入力ラインを [リセットカウンタ] に設定した後にジョブを新規作成すると、新しいジョブは自動的に入力ラインを [イベントトリガ] に戻してしまいます (In-Sight 2000 シリーズセンサでは空白)。

    イベントトリガ

    スプレッドシートビューで作成されたロジックを使用して、イベントをトリガします。 スプレッドシートを更新するには、このディスクリート入力ライン番号にトリガパラメータを設定したイベント構造体がスプレッドシートに含まれる必要があります。

    注:

    • この信号タイプは、ビジョンシステムがオンライン時のみに使用できます。
    • 入力ラインを介してモデルパターンを登録する場合以外、このオプションを使用するには、スプレッドシートビューへのアクセスが必要です。

    ジョブ ID 番号

    ジョブ ID 番号を構成する 1 ビットです。別のラインに割り当てた [ジョブを開く] の入力ラインが ON になったときにジョブ ID 番号が読み込まれます。

    注:

    • ジョブ ID 番号の機能を使用する場合は、ジョブファイル名の先頭に 0 ～ 127 の接頭辞を付けておく必要があります。
    • ジョブ ID 番号の最小値は、I/O モジュール上のディスクリート入力ラインの最小値に対応しています。

    オンライン/オフライン*

    In-Sight ビジョンシステムをオフラインまたはオンラインにします (LOW (0) = オフライン、HIGH (1) = オンライン)。

    注: In-Sight Explorer の手動操作で In-Sight ビジョンシステムをオフラインにしているとき、あるいはネイティブモードコマンド SO0 で In-Sight ビジョンシステムをオフラインにしているときは、この信号タイプに設定したラインを ON にしてもオンラインモードになりません。

    画像取り込みトリガ*
    (In-Sight 2000 シリーズセンサおよび CIO-1400 ではサポートされていません)

    In-Sight ビジョンシステムの画像取り込みをトリガします。

    注:

    • [画像取り込みの設定] グループボックスの [トリガ] パラメータを [外部] にして、[画像取り込みトリガ] 入力を使用します。画像取り込みトリガを使用するには、信号ラインは In-Sight ビジョンシステムの入力に物理的に接続する必要があります。
    • ビジョンシステムの内蔵画像取り込みトリガ入力 ([トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
    • [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] 出力は、ビジョンシステムから送信されません。[エラー: 画像取り込みミス] 信号は、[トリガ] パラメータを [カメラ] に設定したときのみ送信されます。

    ジョブを開く*

    入力ラインの状態が ON になると、すべてのジョブ ID 番号を読み取り、指定されたジョブをロードします。

    注: ビジョンシステムはオフラインにてください。

    ジョブ変更 (パルス)

    (I/O 直接接続の In-Sight 2000 シリーズセンサでのみサポート)

    異なるパルス幅の入力パルスを検出することにより、ジョブ変更を開始します。 このパルスは外部デバイス (PLC など) によって生成され、In-Sight 2000 センサに送信されます。 まず、外部デバイスから開始パルスを生成します。 次に、外部デバイスから、パルス間にギャップのあるカウントパルスを発行します。 最後に、外部デバイスから停止パルスを発行します。

    パルスの種類 | パルス幅
    開始パルス | 20ms (±2ms)
    カウントパルス | 10ms (±1ms)
    パルスギャップ | 10ms (± 1ms)
    停止パルス | 20ms (±2ms)

    すべてのパルスおよびパルスギャップが指定のパルス長にマッチすると、ジョブ変更リクエストに成功し、ジョブがセンサにロードされます。 これらの条件に 1 つでも満たない場合 (パルスまたはパルスギャップのタイミングが正しくない場合)、ジョブ変更リクエストに失敗し、ジョブ変更は起こりません。

    注:

    • この信号タイプは、ビジョンセンサがオンライン時のみに使用できます。
    • [ジョブ変更 (パルス)] 信号タイプ機能を使用するには、ジョブ名が 0～31 の数字で始まるジョブが (例: 1PinInspection.job) 1 つ以上、センサに保存されている必要があります。 カウントパルスの数は、ロードするジョブの接頭辞と一致する必要があります。
    • SetSystemConfig("PulseJobChangeTiming") ネイティブモードコマンドを使用して、開始パルス、カウントパルス、パルスギャップおよび停止パルスの幅を設定することができます。
    • オプションとして、ディスクリート出力ラインを [ジョブを開く - 完了] または [エラー: ジョブを開く] タイプに設定し、出力をパルスすることによって、ジョブ変更リクエストの成功または失敗を報告することができます。

    シリアル受信
    (直接接続)

    シリアル受信ラインとして設定します。

    注:

    • この信号タイプは、In-Sight Explorer 4.7.1 以降を使用し、In-Sight 4.7.1 以降のファームウェアが搭載されている In-Sight 70xx - 74xx シリーズビジョンシステムに接続している場合のみ使用可能です。
    • この信号タイプは、[直接接続 I/O] 選択時に、入力ライン 1 でのみ使用可能です。
    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
    • In-Sight 70xx - 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
    *この [信号タイプ] を、複数の入力ラインに割り当てることはできません。
  6. 選択された入力ラインの [エッジタイプ] を設定します。これは、エッジの遷移に対する入力ラインの状態を制御します。
    • [立ち上がりエッジ]: パルスの立ち上がりエッジで入力ラインの状態が変わります。
    • [立ち下がりエッジ]: パルスの立ち下がりエッジで入力ラインの状態が変わります。
    • [両方のエッジ]: パルスの立ち上がりエッジおよび立ち下がりエッジの両方で入力ラインの状態が変わります。 このオプションは、イベントトリガ選択時のみ有効です。

  7. 次に、選択した出力ラインの [信号タイプ] を定義します。 次のいずれかの方法で、各ラインを設定することができます。

    出力信号タイプ | 説明
    ジョブの結果 (デフォルト) | 位置決めツールまたは検査ツールの結果によって、この出力ラインの状態を制御するようにします。 パルスまたはレベル信号です。
    ハイ (High) | 出力を High (1) にします。
    ロー (Low) | 出力を Low (0) にします。
    画像取り込み開始

    ビジョンシステムが画像取り込みを開始したことを示す信号です。 常にパルスとなります。

    注: In-Sight Micro 8405 ビジョンシステムでは、最初のピクセル行が露光したときに、画像取り込み開始信号がパルスされます。 詳細については、ローリングシャッターの操作をご参照ください。
    画像取り込み終了

    ビジョンシステムの画像取り込み終了を示す信号です。 常にパルスとなります。

    注: In-Sight Micro 8405 ビジョンシステムでは、画像読み出しがすべて完了したときに、画像取り込み終了信号がパルスされます。 詳細については、ローリングシャッターの操作をご参照ください。
    ジョブ完了 | EasyBuilder の更新を完了するたびに示す信号です。 常にパルスとなります。
    システムビジー | ビジョンシステムがジョブを実行しているとき、またはユーザ入力に応答しているときは HIGH になります。ビジョンシステムがアイドルの場合は LOW です。
    ジョブを開く - 完了 | ジョブのロードが成功したことを示す信号です。 常にパルスとなります。
    エラー: ジョブを開く | ジョブのロードが失敗したことを示す信号です。 常にパルスとなります。
    エラー: 画像取り込みミス

    画像取り込み終了信号が送信される前に画像取り込みトリガを受信したか、または画像取り込みトリガを受信したときに画像バッファが利用できないことを示す信号です。常にパルスとなります。

    注:[画像の設定] ステップ、[画像取り込みの設定] グループボックスの [トリガ] パラメータを [カメラ] に設定して、エラー: 画像取り込みミス出力を使用します。
    エラー: トラックオーバラン | 予想時間よりやや遅れて EasyBuilder が遅延ディスクリート出力信号を出力したことを示す信号です。 常にパルスとなります。
    エラー: トラックキューフル | 同時に別の出力が発生するように予定されたラインに、EasyBuilder が遅延ディスクリート出力信号を出力したことを示す信号です。 常にパルスとなります。
    オンライン/オフライン | In-Sight がオンラインのときは HIGH (1) になります。In-Sight がオフラインのときは LOW (0) です。
    ストロボ | 信号の立ち上がりエッジまたは立ち下がりエッジでストロボにトリガをかけることができます。
    照明制御
    (CIO-1460 のみ)     		信号の立ち上がりエッジまたは立ち下がりエッジで照明にトリガをかけることができます。
    I/O モジュールスタンバイ
    (CIO-1450 および CIO-1460 のみ)

    [ON] は、I/O モジュールがビジョンシステムと I/O モジュールの間の通信エラーを検知し、再接続を試みていることを示します。 [OFF] は、I/O モジュールの検出したエラーが修正されたことを示します。は、I/O モジュールの検出したエラーが修正されたことを示します。

    注: この出力タイプは、CIO-1450 または CIO-1460 の設定時に、ライン 0～7 のみで有効です。
    ライフライン
    (CIO-MICRO および CIO-MICRO-CC のみ)     		In-Sight Micro ビジョンシステムが CIO-MICRO または CIO-MICRO-CC にアクティブに接続されているときは HIGH になります。 ビジョンシステムが接続に失敗すると、LOW です。
    波形

    スプレッドシート中の Waveform、WriteWaveformPulseTrain または WriteWaveformClocked 関数を有効にし、出力ラインの状態を制御します。

    注: このオプションを使用するには、スプレッドシートビューへのアクセスが必要です。
    シリアル送信

    シリアル送信ラインとして設定します。

    注:

    • この信号タイプは、In-Sight Explorer 4.7.1 以降を使用し、In-Sight 4.7.1 以降のファームウェアが搭載されている In-Sight 70xx - 74xx シリーズビジョンシステムに接続している場合のみ使用可能です。
    • この信号タイプは、[直接接続 I/O] 選択時に、ライン 1 でのみ使用可能です。
    • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
    • In-Sight 70xx - 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
    ジョブの PASS/FAIL (In-Sight 76xx～79xx シリーズおよび In-Sight 9902L のみ) | 現在のジョブ全体の PASS/FAIL ステータスに基づき、ビジョンシステムの PASS/FAIL LED およびインジケータリングが、緑 (PASS) または赤 (FAIL) に点灯します。
  8. [信号タイプ] で 詳細設定 が可能な場合、[詳細] ボタンを押して、選択した出力ラインのラインの出力詳細ダイアログを開きます。

  9. [オフライン中は出力を OFF にする] チェックボックスを ON にして、ビジョンシステムオフライン時に出力を OFF にすることができます (オプション)。

    注: [オフライン中は出力を OFF にする] チェックボックスが ON で、CIO-MICRO または CIO-MICRO-CC I/O の出力ラインが [ライフライン] 信号タイプに設定されている場合、接続中のビジョンシステムがオフラインでもラインは HIGH となります。
  10. [強制] オプションを使用して、設置前または設置後に、アプリケーションのテストやデバッグを行うことができます。[強制] オプションはライン設定をオーバライドして、In-Sight センサの オンライン 時に入力または出力ラインを強制的に ON にし、結果をテストします。
    1. テストするラインを選択します。
    2. [強制] 設定を ON にします。設定した動作を強制的に実行するようになります。
    3. ビジョンシステムをオンラインにし、トリガします。
    4. ラインのテストを終了したら、ビジョンシステムをオフラインにし、[強制] を [OFF] または [なし] に設定し直してください。

    注:

    • 出力ラインにおいて、[強制] 機能では、実際に出力はされません。出力の値を変更するのみです。

    • 電気的接続を出力ライン上でテストする場合、[強制] を使用するのではなく、[HIGH] または [LOW] を使用し、ビジョンシステムをオンラインに設定することを推奨します。こうすることにより、ビジョンシステムはオンラインモードであるため、出力信号はハイまたはローのままとなります。その後、マルチメーターを使用して、電気路が期待通りに動いているかどうかを確認することができます。

  11. 設定を変更した場合、このステップを終了する際に自動的に In-Sight ビジョンシステムに保存されます (ジョブファイルには保存されません) 。


I/O モジュールの設定

Closed CIO-1400、CIO-1450、または CIO-1460 を設定する
  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから、CIO-1400、CIO-1450 またはCIO-1460 を選択します。
  4. [OK] をクリックして、ダイアログを閉じます。
Closed CIO-MICRO または CIO-MICRO-CC を設定する
  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから、CIO-MICRO または CIO-MICRO-CC を選択します。
  4. [接続先] ドロップダウンリストから、適切な I/O モジュールを選択します。

注: I/O モジュールのホスト名がリストに表示されない場合は、<IP アドレスによって接続> を選択し、I/O モジュールの IP アドレスを手動で入力してください。

  5. [更新間隔] フィールドに、In-Sight Micro ビジョンシステムと CIO-MICRO または CIO-MICRO-CC I/O モジュール間の入出力を同期させるのに必要な時間間隔を入力してください。(1ms～500ms。デフォルトは、20ms)

注: 出力信号の大幅な遅延が問題になる場合は、アプリケーションに必要なだけ更新時間を短くします。ただし、更新時間は必要以上に短くしないでください。更新時間が短くなると、ジョブの実行にかかる時間が長くなることがあります。

  6. 必要に応じて、[設定の変更] ボタンをクリックして、I/O モジュールのネットワーク設定を行います。
    • デフォルトで、In-Sight CIO-MICRO および CIO-MICRO-CC I/O モジュールは、起動時に DHCP サーバによって動的に設定されます。 新しいホスト名を割り当てることもできますが、ダイアログ内のそのほかのフィールドはすべて無効です。

注: DHCP サーバが使用できない場合は、I/O モジュールはタイムアウトし、リンクローカル IP アドレスを取得します。

  • CIO-MICRO および CIO-MICRO-CC には、固定 IP アドレスも使用することができます。[DHCP サーバの使用] チェックボックスを OFF にして、[IP アドレス]、[サブネットマスク]、[デフォルトゲートウェイ]、[DNS サーバ] および [ドメイン名] フィールドを設定してください。
  7. [OK] をクリックして、ダイアログを閉じます。
Closed CIO-WENET を設定する

CIO-WENET I/O モジュールに IP アドレスを割り当ててから、 In-Sight Explorer で設定します。

  1. In-Sight Explorer から、サポートしているビジョンシステムに接続します。
  2. [I/O モジュールの設定] ダイアログを開きます。
  3. [I/O モジュールの選択] ドロップダウンリストから [CIO-WENET] を選択します。
  4. [IP アドレス] フィールドに、CIO-WENET に割り当てた IP アドレスを入力します。
  5. [更新間隔] フィールドに、In-Sight Micro ビジョンシステムと CIO-WENET I/O モジュール間の入出力を同期させるのに必要な時間間隔を入力してください。(1ms～500ms。デフォルトは、20ms)
注:
  • 出力信号の大幅な遅延が問題になる場合は、アプリケーションに必要なだけ更新時間を短くします。 ただし、更新時間は必要以上に短くしないでください。更新時間が短くなると、ジョブの実行にかかる時間が長くなることがあります。
  • CIO-WENET では、同期させるのに必要な時間は、[更新時間] より 3ms 長くなります。
  6. [OK] をクリックして、ダイアログを閉じます。


入出力の数

直接接続 (内蔵) 出力の数は、次のように、In-Sight ビジョンシステムによって異なります。

In-Sight ビジョンシステム | 直接接続 (内蔵) 入力 | 直接接続 (内蔵) 出力
In-Sight Micro 1000 シリーズ | なし | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 2000 シリーズ | 汎用入力✕ 1 | 高速出力✕ 4 ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、黄✕ 1)
In-Sight 5000 シリーズ | なし | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 70xx～74xx シリーズ | 汎用入力✕ 3 | 高速出力✕ 4 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 76xx～79xx シリーズ | 汎用入力✕ 3 (最大)2 | 高速出力✕ 4 (最大) ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、赤✕ 1)
In-Sight Micro 8000 シリーズ | なし | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑✕ 1、赤✕ 1)
In-Sight 9902L | 汎用入力✕ 1 | 高速出力✕ 2 ユーザ設定可能 LED ✕ 2 (緑または赤✕ 1、赤✕ 1)

注:

  • In-Sight 5000 シリーズ、7000 シリーズおよび Micro シリーズのビジョンシステムには、画像取り込みトリガ専用入力 (×1) があります。詳細については、In-Sight Explorer ソフトウェアに格納されているインストールガイドをご参照ください
  • ブレークアウトケーブル接続時、In-Sight 76xx - 79xx シリーズビジョンシステムは双方向高速出力および汎用入力を、HS OUT 2 /汎用入力 2 および HS OUT 3 / 汎用入力 3 で使用することができます。 これらのラインはデフォルトで出力に設定されています。

I/O モジュールを使用して、ディスクリート入出力数を追加することができます。 I/O モジュールのディスクリート入出力数は次の通りです。

I/O モジュール | サポートされている In-Sight ビジョンシステム | ディスクリート入力 | ディスクリート出力
CIO-1400 | In-Sight 5000 シリーズ (5604 を除く)、In-Sight 2000 シリーズ、In-Sight 76xx～79xx シリーズ | 汎用✕ 7 | 汎用出力✕ 6
CIO-MICRO | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ、In-Sight 70xx～79xx シリーズ、In-Sight Micro 8000 シリーズ | 汎用✕ 8 | 汎用✕ 8
CIO-MICRO-CC | In-Sight Micro 1000 シリーズ、In-Sight 5000 シリーズ (5705、5705C および 5715 を除く)、In-Sight 70xx～74xx0 シリーズ | 汎用✕ 8 | 汎用✕ 8
CIO-1450 | In-Sight 5000 シリーズ (5604、5705、5705C および 5715 を除く) | 汎用✕ 8 | 汎用✕ 8
CIO-1460 | In-Sight 5000 シリーズ (5604、5605、5705、5705C および 5715) | 汎用✕ 8 | 汎用✕ 8
CIO-WENET | In-Sight Micro 1000 シリーズ | 汎用✕ 8 | 汎用✕ 8

注:

  • CIO-1400 I/O モジュールは、ファームウェア 5.3.0 以降を搭載した In-Sight 2000 シリーズビジョンセンサをサポートします。
  • CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以降を使用している In-Sight 76xx～79xx シリーズビジョンシステムをサポートしています。 このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。
  • CIO-MICRO I/O モジュールは、ファームウェア 5.3.0 以降を搭載した In-Sight 5705、5705C、5715 および In-Sight Micro 8000 シリーズビジョンシステムをサポートします。
  • CIO-MICRO および CIO-MICRO-CC I/O モジュールがサポートしているのは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズ、および 5400 シリーズのビジョンシステムです。 モデルはタイプ番号 (821-xxxx-xx) で特定できます。 このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。 モデル一覧、タイプ番号および不揮発性フラッシュメモリの詳細については、ここをクリックしてください。
  • CIO-1450、CIO-1460 および CIO-WENET I/O モジュールのサポートは終了しました。これらの I/O モジュールはご購入いただくことはできませんが、下位互換性のみを目的として In-Sight Explorer ではサポートされています。


デフォルトの入出力ライン

Closed In-Sight Micro 1000 シリーズ

注:

  • HS OUT 0 および HS OUT 1 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。

直接接続 I/O

出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | 緑 LED
5 | 赤 LED

CIO-MICRO または CIO-MICRO-CC

入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED

CIO-WENET

入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
Closed In-Sight 2000 シリーズ

注:

  • 汎用入力 0 は内蔵入力で、ビジョンシステムと直接接続しています。

  • HS OUT 0、HS OUT 1、HS OUT 2 および HS OUT 3 は内蔵高速出力で、ビジョンシステムと直接接続しています。

  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。

  • 緑 LED/赤 LED は単一の LED 出力で、緑・赤ともユーザ定義可能です。

直接接続 I/O

入力 | 名前
0 | IN 0
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | HSOUT 2
3 | HSOUT 3
4 | 緑 LED
 | 赤 LED
5 | 黄 LED

CIO-1400

入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
 | ライン 5
5 | ライン 6
7 | ライン 7
8 | 緑 LED
9 | 赤 LED
10 | 黄 LED
11 | 無効
12 | 無効
Closed In-Sight 5000 シリーズ

CIO-1400

入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | 緑 LED
9 | 赤 LED

CIO-1450

注: ディスクリートパルス信号が CIO-1450 I/O モジュールから出力される場合、パルス幅は指定より 10 ミリ秒以上長く設定する必要があります。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED

CIO-1460

注: CIO-1460 I/O モジュールの電源を入れ直すと、ディスクリート出力は初期設定時に約 250 ミリ秒後に出力されます。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
12 | 無効
13 | 無効

CIO-MICRO/CIO-MICRO-CC

注:

  • CIO-MICRO I/O モジュールは、ファームウェア 5.3.0 以降を搭載した In-Sight 5705、5705C、5715 および In-Sight Micro 8000 シリーズビジョンシステムをサポートします。
  • CIO-MICRO および CIO-MICRO-CC I/O モジュールがサポートしているのは、128MB 以上の不揮発性フラッシュメモリを持つ In-Sight 5100 シリーズ、および 5400 シリーズのビジョンシステムです。 モデルはタイプ番号 (821-xxxx-xx) で特定できます。 このタイプ番号は、ビジョンシステムに添付されているラベルに記載されています。 モデル一覧、タイプ番号および不揮発性フラッシュメモリの詳細については、ここをクリックしてください。
入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
Closed In-Sight 70xx～74xx シリーズ

注:

  • In-Sight 70xx - 74xx シリーズビジョンシステムでは、ブレークアウトケーブルと、CIO-MICRO または CIO-MICRO-CC I/O モジュールとの同時接続がサポートされています。
  • 汎用入力 1、汎用入力 2 および 汎用入力 3 は内蔵入力で、ビジョンシステムと直接接続しています。In-Sight 7000 シリーズ (70xx - 79xx) ビジョンシステムの内蔵入力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • 内蔵入力、ビジョンシステムと直接接続。In-Sight 70xx - 74xx シリーズビジョンシステムの高速出力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。

  • ビジョンシステムは、HSOUT 0 ラインで [ストロボ] 信号タイプをサポートします。

  • 外部ストロボデバイスを In-Sight 70xx - 74xx シリーズビジョンシステムの外部照明ケーブルに接続している場合、[照明の設定] ダイアログを使用して、外部照明を設定してください。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight 70xx - 74xx シリーズのビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

直接接続 I/O

入力 | 名前
1 | IN 1/シリアル受信
2 | IN 2
3 | IN 3
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1/シリアル通信
2 | HSOUT 2
3 | HSOUT 3
4 | 緑 LED
5 | 赤 LED

CIO-MICRO/CIO-MICRO-CC

注:

  • ビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへのイーサネット接続が確立している場合:

    • I/O モジュールの I/O ポート (DB15) および TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。リモートデバイスからこれらの端子にリード線を接続しないでください。

    • I/O モジュールの I/O ポート (DB15) はサポートされていません。このポートには何も接続しないでください。

    • ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効になっています。I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。

入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
9 | IN 11
10 | IN 21
11 | IN 31
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | HSOUT 2
11 | HSOUT 3
12 | 緑 LED
13 | 赤 LED
Closed In-Sight 76xx～79xx シリーズ

注:

  • In-Sight 76xx - 79xx シリーズビジョンシステムでは、ブレークアウトケーブルと、CIO-MICRO I/O モジュールとの同時接続がサポートされています。サポートされているハードウェアの I/O 設定については、In-Sight 7000 Gen2 ハードウェア I/O の設定をご参照ください。
  • 汎用入力 1、汎用入力 2 および 汎用入力 3 は内蔵入力で、ビジョンシステムと直接接続しています。 In-Sight 7000 シリーズ (70xx - 79xx) ビジョンシステムの内蔵入力は、ビジョンシステムがブレークアウトケーブルに接続されている場合のみサポートされます。
  • HS OUT 0、HS OUT 1、HS OUT 2 および HS OUT 3 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。

  • 外部ストロボデバイスを In-Sight 76xx - 79xx シリーズビジョンシステムの外部照明ケーブルに接続している場合、または照明アクセサリをビジョンシステムのフェースプレートに接続している場合、[照明の設定] ダイアログを使用して照明を設定してください。

直接接続 I/O

入力 | 方向 | 名前
1 | 固定入力 | IN 1
2 | 入力2 | IN 2
3 | 入力2 | IN 3
出力 | 方向 | 名前
0 | 固定出力 | HSOUT 0
1 | 固定出力 | HSOUT 1
2 | 出力2 | HSOUT 2
3 | 出力2 | HSOUT 3
4 | 固定出力 | PASS/FAIL LED
5 | 固定出力 | エラー LED

CIO-1400

注:

  • CIO-1400 I/O モジュール接続時、ビジョンシステムの 汎用入力 1、汎用入力 2、汎用入力 3、HS OUT 2 および HS OUT 3 ラインはサポートされていません。

  • CIO-1400 I/O モジュールは、In-Sight Explorer 5.4.0 以降を使用している In-Sight 76xx～79xx シリーズビジョンシステムをサポートしています。このバージョン以前の In-Sight Explorer を使用してビジョンシステムにログオンし、CIO-1400 I/O に接続して I/O ラインを設定した場合、その変更は保持されません。

入力 | 名前
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | PASS/FAIL LED
9 | エラー LED

CIO-MICRO

注:

  • In-Sight 76xx ～ 79xx シリーズビジョンシステムがブレークアウトケーブルに接続されており、CIO-MICRO I/O モジュールへのイーサネット接続が確立している場合:
    • ビジョンシステムは双方向高速出力および汎用入力を、汎用入力 2/HS OUT 2 および 汎用入力 3/HS OUT 3 で使用することができます。これらのラインはデフォルトで出力に設定されています。
    • CIO-MICRO I/O モジュールの TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON 端子はサポートされていません。 リモートデバイスからこれらの端子にリード線を接続しないでください。
    • ブレークアウトケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効になっています。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • In-Sight 76xx～79xx シリーズビジョンシステムが I/O モジュールケーブルを介して CIO-MICRO I/O モジュールに接続されている場合:

    • ビジョンシステムの 汎用入力 1、汎用入力 2、汎用入力 3、HS OUT 2 および HS OUT 3 ラインは [ディスクリート I/O の設定] ダイアログに表示されますが、サポートされていません。これらのラインは、ビジョンシステムがブレークアウトケーブルに接続されているときのみ、サポートされています。

    • TRIGGER+、TRIGGER-、HS OUT 0、HS OUT 1 および HS COMMON は、CIO-MICRO I/O モジュール端子を介して接続されます。
    • ビジョンシステムのフェイスプレートまたは LIGHT コネクタに装着されている照明アクセサリは、サポートされていません。 これらの照明アクセサリが装着されている場合、ブレークアウトケーブルを介してビジョンシステムに電源を供給し、I/O モジュールへの接続はイーサネットを介してのみ行うようにしてください。
入力 | 方向 | 名前
0 | 固定入力 | ライン 0
1 | 固定入力 | ライン 1
2 | 固定入力 | ライン 2
3 | 固定入力 | ライン 3
4 | 固定入力 | ライン 4
5 | 固定入力 | ライン 5
6 | 固定入力 | ライン 6
7 | 固定入力 | ライン 7
9 | 固定入力 | IN 1
10 | 入力 | IN 2
11 | 入力 | IN 3
出力 | 方向 | 名前
0 | 固定出力 | ライン 0
1 | 固定出力 | ライン 1
2 | 固定出力 | ライン 2
3 | 固定出力 | ライン 3
4 | 固定出力 | ライン 4
5 | 固定出力 | ライン 5
6 | 固定出力 | ライン 6
7 | 固定出力 | ライン 7
8 | 固定出力 | HSOUT 0
9 | 固定出力 | HSOUT 1
10 | 出力 | HSOUT 2
11 | 出力 | HSOUT 3
12 | 固定出力 | PASS/FAIL LED
13 | 固定出力 | エラー LED
Closed In-Sight Micro 8000 シリーズ

注:

  • HS OUT 0 および HS OUT 1 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight Micro 8405 でストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、ローリングシャッターの操作をご参照ください。

直接接続 I/O

出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | 緑 LED
5 | 赤 LED

CIO-MICRO

入力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
出力 | 名前
0 | ライン 0
1 | ライン 1
2 | ライン 2
3 | ライン 3
4 | ライン 4
5 | ライン 5
6 | ライン 6
7 | ライン 7
8 | HSOUT 0
9 | HSOUT 1
10 | 緑 LED
11 | 赤 LED
Closed In-Sight 9902L ラインスキャンビジョンシステム

Note:

  • 汎用入力 1 は内蔵入力で、ビジョンシステムと直接接続しています。
  • HS OUT 0 および HS OUT 1 は内蔵高速出力で、ビジョンシステムと直接接続しています。
  • ビジョンセンサは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight 9902L ラインスキャンビジョンシステムで、ストロボを使用する場合、
    • ストロボは PNP 配線を使用し、[ストロボ]/[照明制御] トリガを [立ち上がりエッジ] に設定してください。
    • ビジョンシステムが画像取り込みトリガを受信すると、出力ラインはパルスを発信し、ストロボが露光時間中、点灯します。 露光完了後、次の画像トリガを受信する前に、最低 100µs が必要です。それ以下の場合、ストロボ正しく機能しません。

直接接続 I/O

入力 | 名前
1 | IN 1
出力 | 名前
0 | HSOUT 0
1 | HSOUT 1
4 | PASS/FAIL LED
5 | エラー LED


出力 [詳細] ダイアログのコントロール

  • [パルス]: このチェックボックスが ON のときは、出力はパルスになります。 OFF にすると定常状態に設定されます。 [取り込み遅延] が 0 以外の場合、パルス出力になります。

  • [パルス幅 (ミリ秒)]: 出力パルスの持続時間を指定します。

    ビジョンシステム/ビジョンセンサ | 最小パルス幅 | 最大パルス幅 | デフォルトのパルス幅
    汎用出力 | 高速出力
    In-Sight Micro 1000 シリーズ (1402、1412 および 1500 を除く) | 10ms | 10ms | 1000ms | 10ms
    In-Sight Micro 1402、1412 および 1500 | 10ms | 1ms | 1000ms | 10ms
    In-Sight 2000 シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight 5000 シリーズ | 10ms | 10ms | 1000ms | 10ms
    In-Sight 70xx～74xx シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight 76xx～79xx シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight Micro 8000 シリーズ | 10ms | 1ms | 1000ms | 10ms
    In-Sight 9902L | N/A | 1ms | 1000ms | 10ms

    注:

    • CIO-MICRO または CIO-MICRO-CC I/O モジュールをサポートしているビジョンシステムと共に使用しているときに、汎用出力の最小パルス幅は [I/O モジュールの設定] ダイアログの [更新間隔] 設定によって制限されます。 例えば、[更新間隔] が 20ms の場合、最小パルス幅は 30ms 以下に設定できません。 詳細については、 [I/O モジュールの設定] ダイアログをご参照ください。
    • In-Sight 76xx - 79xx シリーズおよび 8000 シリーズでは、最小パルス幅 1ms は、In-Sight ファームウェアバージョン 5.5.0 以降でのみサポートされています。 それ以前のファームウェアバージョンでは、最小パルス幅は 10ms です。

  • [取り込み遅延 (N)]: 信号のパルスを出力線が受信した後、出力を遅延させるための画像取り込みパルスまたはトラッキングパルスの数 (0～1000) を指定します。 取り込み遅延が 0 の場合、In-Sight ビジョンシステムは、EasyBuilder ジョブを評価するとすぐに出力ラインを更新します。 [取り込み遅延] が 0 よりも大きい場合、出力ラインは常にパルスとなります。

    注: [取り込み遅延] と [トリガ後の時間] を同時に使用することはできません。これらは個別に使用する必要があります。例えば、[取り込み遅延] が有効になると、[トリガ後の時間] は無効になります。逆に、[トリガ後の時間] が有効になると、[取り込み遅延] は無効になります。

  • トリガ後の時間 (ms): このチェックボックスを ON にすると、指定された時間 (0 ～ 10000 ミリ秒) の経過後に、出力が行われます。

    注: [取り込み遅延] と [トリガ後の時間] を同時に使用することはできません。これらは個別に使用する必要があります。例えば、[取り込み遅延] が有効になると、[トリガ後の時間] は無効になります。逆に、[トリガ後の時間] が有効になると、[取り込み遅延] は無効になります。

  • [ストロボ/照明制御のトリガ]: 立ち上がりまたは立ち下がりエッジ信号を使用して、ストロボまたは照明制御にトリガをかけます。
    • NPN の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が HIGH となり、それ以外は LOW になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が LOW になり、それ以外は HIGH となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    • PNP の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が LOW となり、それ以外は HIGH になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が HIGH になり、それ以外は LOW となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

      注:

      • In-Sight 5600 シリーズ、5705、5705C、5715 および 9902L ビジョンシステムでは、ストロボ動作が反転しています。例えば、NPN 配線では、立ち上がりエッジおよび立ち下がりエッジが PNP 配線のように動作します。
      • In-Sight 9902L ラインスキャンビジョンシステムで、ストロボを使用する場合、
        • ストロボは PNP 配線を使用し、[ストロボ]/[照明制御] トリガを [立ち上がりエッジ] に設定してください。
        • ビジョンシステムが画像取り込みトリガを受信すると、出力ラインはパルスを発信し、ストロボが露光時間中、点灯します。 露光完了後、次の画像トリガを受信する前に、最低 100µs が必要です。それ以下の場合、ストロボ正しく機能しません。
  • ストロボ開始位置: ストロボ出力を開始する位置を指定します。 このオプションは、In-Sight 9902L ビジョンシステムではサポートされていません。
    • 画像取り込み開始: In-Sight ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • カメラトリガ: カメラトリガイベントを受信したときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。

    • すべての行を露光: すべてのピクセル行を露光するときのみストロボ出力を開始します。In-Sight Micro 8405 ビジョンシステムでのみサポートされています。

      注: In-Sight Micro 8405 でストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、ローリングシャッターの操作をご参照ください。

  • 三色 LED: 三色 LED ラインの動作を設定します。 (OFF/緑、OFF/赤、赤/緑。デフォルト = OFF/緑) このオプションは、ラインが三色 LED をサポートする場合のみ使用できます。

    注: このオプションは、In-Sight 76xx～79xx シリーズビジョンシステムの PASS/FAIL LED でサポートされていますが、PASS/FAIL ジョブセルを信号タイプで選択している場合、使用することはできません。


入力: ジョブファイルをロードするには

In-Sight 2000 シリーズビジョンセンサ

この機能を使用するには、ジョブファイル名の先頭に 0~31 の数値が付いたジョブを 1 つ以上保存しておく必要があります (例: 2PinInspection.job)。

  1. [入力ライン 0] を選択し、[信号タイプ] を [ジョブ変更 (パルス)] に設定します。

  2. 2PinInspection.job をセンサにロードするには、外部デバイス (PLC など) から一連のパルスを In-Sight 2000 センサに対して発行します。

    パルスの種類 | パルス幅
    開始パルス | 20ms (±2ms)
    カウントパルス | 10ms (±1ms)
    パルスギャップ | 10ms (± 1ms)
    停止パルス | 20ms (±2ms)
    1. 外部デバイスが、パルスギャップに続き、開始パルスを生成します。
    2. 次に、外部デバイスがカウントパルスを生成します。 各カウントパルス間、および最後のカウントパルスの後にパルスギャップが発生します。 カウントパルスの数は、ロードするジョブの接頭辞と一致する必要があります。例えば、2PinInspection.job には、カウントパルスが 2 つ必要です。
    3. 外部デバイスから、停止パルスを発行します。 すべてのパルスおよびパルスギャップが指定のパルス長にマッチすると、ジョブ変更リクエストに成功し、2PinInspection.job がセンサにロードされます。 これらの条件に 1 つでも満たない場合 (パルスまたはパルスギャップのタイミングが正しくない場合)、ジョブ変更リクエストに失敗し、ジョブ変更は起こりません。

    注:

    • SetSystemConfig("PulseJobChangeTiming") ネイティブモードコマンドを使用して、開始パルス、カウントパルス、パルスギャップおよび停止パルスの幅を設定することができます。
    • オプションとして、ディスクリート出力ラインを [ジョブを開く - 完了] または [エラー: ジョブを開く] タイプに設定し、出力をパルスすることによって、ジョブ変更リクエストの成功または失敗を報告することができます。 指定の入力パルス長が使用されない場合、ジョブロードに失敗し、出力はパルスされません。

In-Sight ビジョンシステム

この機能を使用するには、ジョブファイル名の先頭に 0~127 の数値が付いたジョブを 1 つ以上保存しておく必要があります (例: 1PinInspection.job)。

  1. 入力ラインを選択し、[信号タイプ] を [ジョブを開く] に設定します。どのジョブファイルがロードされるかは、[ジョブ ID 番号] に設定した入力ラインの状態 (0 または 1) によって決まります。
  2. 信号タイプの設定で [ジョブ ID 番号] の入力ラインを 1 本以上用意しておきます。
  3. [ジョブ ID 番号] に設定した入力ラインは、2 進数の 1 ビットとして扱われます。 続いて同様に [ジョブ ID 番号] に設定した他の入力ラインも 2 進数の追加ビットとして扱われます。 これらのビットで構成された 2 進数の値が、ロードするジョブの番号となります。ジョブファイルは、あらかじめファイル名の先頭に 10 進数のジョブ番号を付けて保存 (例: 6test.job) しておく必要があります。

例 1

4 本のディスクリート入力ラインを [ジョブ ID 番号] に割り当てます。 そのときジョブ番号は 4 ビットの 2 進数値で表されます。これらの 4 本の入力状態が 1-1-1-0 であったとすると、2 進数の 1110、すなわち 10 進数の 14 が指定され、"14" で始まるジョブファイル (例: 14inspect.job) がロードされます。

例 2

3inspection.job、6inspection.job および 9inspection.job という名前の付いた3 つのジョブファイルがあります。 センサが PLC から HIGH 信号を受信する時に、ジョブファイル 6inspection.job がロードされるように指定するとします。 ディスクリート入力 1 は、現在画像取り込みトリガとして使用されています。

  1. 入力ライン 1 を PLC に接続します。
  2. 入力ライン 1 の [信号タイプ] を [ジョブを開く] に設定します。
  3. ジョブファイルの先頭の数値が 3～9 なので、[ジョブ ID 番号] に 4 点の入力が必要となります (9 は2 進数では 1001)。

  4. ジョブ ID 番号ラインの状態が順番に 1-1-0-0 (6 は2 進数で 1100) で、入力ライン 2 の状態が HIGH (1) のとき、ジョブ名 6inspeciton.job がロードされます。

    注: 同じ先頭の数値を持つファイルが　In-Sight センサに保存されている場合、ファイルは英数字順にロードされます。


位置決めツールおよび検査ツールの ON/OFF を切り替えるには

位置決めツールおよび検査ツールの実行可否が、入力ラインと関連付けられていることがあります。そうすることにより、どのツールを実行すべきかを PLC などの制御システムから選択することができます。

  1. 入力ラインを選択し、[信号タイプ] を [ユーザ用] に設定します。
  2. 目的の位置決めツールまたは検査ツールに戻り、ツールの [ツール有効] ドロップダウンメニューから、ステップ　1 で定義した入力ラインを選択します。
  3. 制御システムがツールの ON/OFF を切り替えるようになります (HIGH = 1 は ON 、LOW = 0 はOFF)。


画像取り込みをトリガするには

PLC、光電ビジョンシステムまたはその他のデバイスから入力ラインを介して画像取り込みトリガを受信するように In-Sight ビジョンシステムを設定するには、次の手順に従ってください。

  1. [画像の設定] ステップをクリックします。

  2. [画像の取り込みの設定] グループボックスの [トリガ] ドロップダウンメニューから [外部] を選択します。

    注:
    • [外部] トリガは、In-Sight 2000 シリーズビジョンシステムではサポートされていません。
    • ビジョンシステムの内蔵画像取り込みトリガ入力 ([トリガ] パラメータを [カメラ] に設定) に対し、汎用入力ラインを画像取り込みトリガ ([トリガ] パラメータを [外部] に設定) として設定することにより、より高速にトリガを実行することができます。
    • [トリガ] パラメータを [外部] に設定したときに画像取り込みに失敗した場合、[エラー: 画像取り込みミス] 出力は、ビジョンシステムから送信されません。[エラー: 画像取り込みミス] 信号は、[トリガ] パラメータを [カメラ] に設定したときのみ送信されます。
  3. [入力] ステップに戻ります。
  4. 入力ラインを選択して、[信号タイプ] を [画像取り込みトリガ] に設定します。
  5. [エッジタイプ] を [立ち上がりエッジ] または [立ち下がりエッジ] に設定します。
  6. 入力デバイスのワイヤを In-Sight ビジョンシステムのブレークアウトケーブルまたは I/O モジュールのトリガ入力に接続します。詳細については、In-Sight ビジョンシステムまたは I/O モジュール取扱説明書を参照してください。


入力: 入力ラインを介してモデルパターンを登録するには

入力ラインを介してモデルパターンを登録するように In-Sight ビジョンシステムを設定するには、次の手順に従ってください。

  1. パターン/パターン (1 - 10) 位置決めツール、パターン有無判明ツールまたはパターン計数ツールにおいて、登録信号として使用する入力ラインを [登録の入力] ドロップダウンリストから選択します。

    注: In-Sight ビジョンシステムまたは In-Sight 2000-23M ビジョンセンサ接続時、[登録の入力] ドロップダウンリストは [設定] タブに含まれています。

  2. [入力/出力] アプリケーションステップに戻ります。
  3. 選択した入力ラインの [信号タイプ] を [イベントトリガ] に設定します。
  4. [エッジタイプ] を [立ち上がりエッジ]、[立ち下がりエッジ] または [両方のエッジ] に設定します。

  5. In-Sight ビジョンシステム/センサをオンラインにします。

    注: モデルパターンの登録には、ビジョンシステム/センサが取り込んだ最新の画像が使用されます。 登録するために、ビジョンシステム/センサを再度トリガする必要はありません。

  6. 選択した [エッジタイプ] のエッジで、モデルパターンが登録されます。


画像取り込みミスを送信するには

画像取り込み終了信号が送信される前に画像取り込みトリガを受信したか、または画像取り込みトリガを受信したときに画像バッファが利用できないことを示す信号です。常にパルスとなります。

注:[画像の設定] ステップ、[画像取り込みの設定] グループボックスの [トリガ] パラメータを [カメラ] に設定して、エラー: 画像取り込みミス出力を使用します。

画像取り込みミスを送信するには、次の手順に従ってください。

  1. 出力ラインを選択し、[信号タイプ] を [画像取り込み終了] に設定します。[詳細] ボタンを押し、パルス幅を指定します。
  2. 他の出力ラインを選択し、[信号タイプ] を [エラー: 画像取り込みミス]　に設定します。[詳細] ボタンを押し、パルス幅を指定します。


出力: 画像取り込み時に照明を同期させるには

Closed ストロボのトリガ

信号の立ち上がりエッジまたは立ち下がりエッジでストロボにトリガをかけることができます。

ストロボをトリガする信号を送信するには、次の手順に従ってください。

  1. [画像の設定] ステップで画像取り込みトリガを定義します。 露光時間は外部照明デバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。
  2. 出力ラインの [信号タイプ] を [ストロボ] に設定します。
  3. [詳細] ボタンを押して、信号の [立ち上がりエッジ] または [立ち下りエッジ] でストロボにトリガをかけるように設定します。
    • NPN の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が HIGH となり、それ以外は LOW になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が LOW になり、それ以外は HIGH となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

    • PNP の設定: トリガを [立ち上がりエッジ] に設定すると、画像センサの露光時に信号が LOW となり、それ以外は HIGH になります。[立ち下がりエッジ] に設定すると、画像センサの露光時に信号が HIGH になり、それ以外は LOW となります。露光時は常にパルスとなります。 露光時間は外部ストロボデバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。

      注:

      • In-Sight 5600 シリーズ、5705、5705C、5715 および 9902L ビジョンシステムでは、ストロボ動作が反転しています。例えば、NPN 配線では、立ち上がりエッジおよび立ち下がりエッジが PNP 配線のように動作します。
      • In-Sight 9902L ラインスキャンビジョンシステムで、ストロボを使用する場合、
        • ストロボは PNP 配線を使用し、[ストロボ]/[照明制御] トリガを [立ち上がりエッジ] に設定してください。
        • ビジョンシステムが画像取り込みトリガを受信すると、出力ラインはパルスを発信し、ストロボが露光時間中、点灯します。 露光完了後、次の画像トリガを受信する前に、最低 100µs が必要です。それ以下の場合、ストロボ正しく機能しません。
  4. [ストロボ開始位置] を指定します。 このオプションは、In-Sight 9902L ビジョンシステムではサポートされていません。
    • 画像取り込み開始: In-Sight ビジョンシステムが画像取り込みを開始するときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • カメラトリガ: カメラトリガイベントを受信したときにストロボ出力を開始するよう指定します。In-Sight Micro 8405 ビジョンシステムを除くすべてのビジョンシステムモデルでサポートされています。
    • すべての行を露光: すべてのピクセル行を露光するときのみストロボ出力を開始します。In-Sight Micro 8405 ビジョンシステムでのみサポートされています。

注:

  • 照明デバイスを正常に作動させるには、In-Sight ビジョンシステムと照明デバイスが共通のグラウンドに接続されている必要があります。
  • In-Sight Micro 1000 シリーズ、In-Sight 2000 シリーズ、In-Sight 5000 シリーズ (5604 を除く), In-Sight 76xx - 79xx シリーズ, In-Sight Micro 8000 シリーズおよび In-Sight 9902L ビジョンシステムは、HSOUT 1 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight 70xx - 74xx シリーズビジョンシステムは、HSOUT 0 ラインで [ストロボ] 信号タイプをサポートします。
  • In-Sight Micro 8405 ビジョンシステムでは、ストロボ開始位置は [すべての行を露光] に固定されています。すべてのピクセル行が露光されたときのみ、パルス信号が出力されます。 In-Sight Micro 8405 でストロボを使用している場合、フルフレーム画像キャプチャでは、ストロボのパルス時にすべてのピクセル行が露光されるよう、露光時間を 72ms 以上に設置することが推奨されます。詳細については、ローリングシャッターの操作をご参照ください。
Closed 外部照明のトリガ (CIO-1460 のみ)

信号の立ち上がりまたは立ち下がりエッジで外部照明にトリガをかけることができます。

外部照明をトリガする信号を送信するには、次の手順に従ってください。

  1. In-Sight 5000 シリーズビジョンシステムにログオンし、CIO-1460 I/O モジュールに接続します。
  2. [画像の設定] ステップで画像取り込みトリガを定義します。 露光時間は外部照明デバイスで設定されているストロボパルス時間よりも 0.50 ミリ秒以上長くする必要があります。
  3. 出力ライン HSOUT1 の [信号タイプ] を [照明制御] に設定します。
  4. [詳細] ボタンを押して、信号の [立ち上がりエッジ] または [立ち下りエッジ] でストロボにトリガをかけるように設定します。

注:

  • 照明デバイスを正常に作動させるには、In-Sight ビジョンシステムと照明デバイスが共通のグラウンドに接続されている必要があります。
  • この出力タイプは、In-Sight 5000 ビジョンシステムシリーズを使用し、CIO-1460 I/O モジュールを設定した場合、高速出力ライン 1 (HSOUT1) でのみ有効です。


位置決めツールまたは検査ツールの結果を出力ラインに設定するには

位置決めツールまたは検査ツールの結果に基づいて信号を送信するには、次の手順に従ってください。

  1. 出力ラインを選択し、[信号タイプ] を [ジョブの結果] に設定します。
  2. [ジョブの結果] ドロップダウンメニューから、出力するツールの結果を選択します。リスト中のツールの結果は、個々のツール (Text_1 など) の　PASS/FAIL の総数を表します。ジョブの結果は、すべてのツールの PASS/FAIL を総合した結果です。ツールの結果が PASS のときは HIGH (1) になります。FAIL のときは LOW (0) です。
  3. [詳細] ボタンを押して、パルス幅および取り込み遅延を指定してください。これらの設定が指定されないときは、信号はパルスとなります。


通信

[通信] ステップは、オープンデータアクセスおよびエクスチェンジ (OPC 用) に検査の結果を定義したり、VisionView オペレータインタフェース用に EasyView を設定したり、FTP を介したり SD カードに画像を転送したり、In-Sight ビジョンシステムのネットワーク通信およびシリアル通信を設定したりすることによって、ロボットまたは PLC/モーションコントローラ (MC) などの他のデバイスとの通信を可能にします。

  • OPC サーバを介してデータを共有するには

    注:In-Sight 2000 シリーズビジョンセンサは、OPC をサポートしていません。

  • EasyView を設定するには
  • FTP を介して画像またはデータを転送するには
    • 画像
    • データ

  • SD カードに画像またはデータを転送するには

    注: この機能は SD カードがインストールされた In-Sight ビジョンシステムのみでサポートされています。

    • 画像
    • データ
  • デバイスを追加、編集するには

注:

  • 通信ステップでのプログラミングを可能にするには、In-Sight センサをオフラインにしてください。
  • ジョブの通信プロトコルをエミュレータを使用して設定、保存した後に、In-Sight ビジョンシステムにロードして、ジョブを実行することができます。 ただし、ProfiNet および CC-Link プロトコルはエミュレータでも選択可能ですが、シミュレートできません。 これらのプロトコルは、ProfiNet または CC-Link ネットワークに接続された In-Sight ビジョンシステムで、ジョブの通信プロトコルを開発、保存する必要があります。

サポートしているプロトコル

最大 2 つまでのプロトコルをジョブに追加することができます。 プロトコルを 2 つ追加する場合、「プライマリ」プロトコル✕ 1 と、「セカンダリ」プロトコル✕ 1 を追加することができます。 例えば、[SLMP スキャナ] プロトコル (プライマリ) の追加後、[デバイスの追加] ボタンをクリックして [TCP/IP] プロトコル (セカンダリ) を追加することができます。

注: 「プライマリ」プロトコル✕ 2 または、「セカンダリ」プロトコル✕ 2 を追加することはできません。

In-Sight ファームウェア 4.x.x

 | プライマリまたは セカンダリ | Micro 1000 シリーズ | 5000 シリーズ (5705 & 5705C を除く) | 70xx - 74xx シリーズ
CC-Link | プライマリ | X | X | X
イーサネットネイティブ | プライマリ | X | X | X
イーサネットネイティブロボット | プライマリ | X | X | X
イーサネットネイティブ文字列 | プライマリ | X | X | X
EtherNet/IP | プライマリ | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X
POWERLINK | プライマリ |  |  | X
PROFINET | プライマリ | X | X | X
シリアル Kuka | プライマリ | X | X | X
シリアル Motoman | プライマリ | X | X | X
シリアルネイティブ | プライマリ | X | X | X
シリアルネイティブロボット | プライマリ | X | X | X
シリアルネイティブ文字列 | プライマリ | X | X | X
シリアルテキスト | プライマリ | X | X | X
SLMP | プライマリ | X | X | X
SLMP スキャナ | プライマリ | X | X | X
TCP/IP | セカンダリ | X | X | X
UDP | セカンダリ | X | X | X

In-Sight ファームウェア 5.x.x

 | プライマリまたは セカンダリ | 2000 シリーズ | 5705 & 5705C | 76xx - 79xx シリーズ | Micro 8000 シリーズ
イーサネットネイティブ | プライマリ |  | X | X | X
イーサネットネイティブロボット | プライマリ |  | X | X | X
イーサネットネイティブ文字列 | プライマリ |  | X | X | X
EtherNet/IP | プライマリ | X | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X | X
PROFINET | プライマリ | X | X | X | X
シリアル Kuka | プライマリ |  | X | X | X
シリアル Motoman | プライマリ |  | X | X | X
シリアルネイティブ | プライマリ | X (ベーシック) | X | X | X
シリアルネイティブロボット | プライマリ |  | X | X | X
シリアルネイティブ文字列 | プライマリ |  | X | X | X
シリアルテキスト | プライマリ | X | X | X | X
SLMP | プライマリ | X | X | X | X
SLMP スキャナ | プライマリ | X | X | X | X
TCP/IP | セカンダリ | X | X | X | X
UDP | セカンダリ | X | X | X | X


OPC サーバを介してデータを共有するには

ジョブアプリケーションに OPC サーバを使用するほかのデバイスとの通信が含まれる場合、検査結果 (または入力データ) を有効にし、OPC サーバにポストすることができます。

注:
  • In-Sight 2000 シリーズビジョンセンサは、OPC をサポートしていません。
  • この機能を有効にするには、In-Sight OPC サーバソフトウェアをインストールする必要があります。 詳細については、In-Sight OPC サーバのヘルプファイルをご参照ください。

OPC サーバのエクスチェンジデータを有効にするには、次の手順に従ってください。

  1. [通信]グループボックスの [OPC] ボタンを押します。
  2. [選択中の OPC タグ] の [追加] ボタンを押して、[OPC タグの選択] ボタンを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。ダイアログから、有効にするデータを選択します。
  4. [OK] をクリックし、変更を受け入れます。OPC タグが [選択中の OPC タグ] に表示されます。


EasyView を設定するには

HMI アプリケーションを使用している場合、 データ表示方法をカスタマイズしたり、オペレータにデータ編集を許可するかどうかを決定したりすることができる EasyView を作成することができます。 まず、EasyBuilder で EasyView を作成し、センサのジョブに保存します。 次に、PC にインストールした VisionView PC デモまたは Web HMI アプリケーションを使用して、正しく設定されているかどうかを確認します。

EasyView を設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [EasyView] を選択します。
  2. [選択中の EasyView アイテム] の [追加] ボタンを押し、[EasyView アイテムの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決め/検査ツール、画像取り込み、およびジョブ設定のデータが含まれています。 使用するアイテムをハイライトしてから [追加] ボタンを押すか、または使用するアイテムの EasyView チェックボックスを ON にして、EasyView に追加するデータを選択してください。
注:
  • 順番に並んでいない複数のアイテムをまとめて選択するには、CTRL キーを押したまま各アイテムを順番にハイライトしてください。
  • 順番に並んでいる複数のアイテムをまとめて選択するには、SHIFT キーを押したままリストの最初のアイテムをハイライトし、次に最後のアイテムをハイライトしてください。
  4. [OK] をクリックし、変更を受け入れます。 ツールデータが [選択中の EasyView アイテム] に表示されます。
注:
  • 順番に並んでいない複数のアイテムをまとめて選択するには、CTRL キーを押したまま各アイテムを順番にハイライトしてください。
  • 順番に並んでいる複数のアイテムをまとめて選択するには、SHIFT キーを押したままリストの最初のアイテムをハイライトし、次に最後のアイテムをハイライトしてください。
  5. [編集の可否] チェックボックスを ON にすると、オペレータが VisionView オペレータインタフェースパネル上で、ツールデータを変更することができます (オプション)。

注: VisionView からツールデータを編集するには、読み取り/書き込み許可が必要です。

  6. [ラベルの挿入] ボタンを押して、ヘッダラベルを作成します (オプション)。 ラベルは、ツールデータをグループ化するのに有用です。
  7. [キャプション] は、HMI アプリケーションで表示される名前です。 デフォルトの [キャプション] を変更するには、ツールバーまたはラベルの [キャプション] フィールドをクリックして、新しい名前を入力します。 <ENTER> キーを押すか、キャプションフィールドの外をクリックして、変更を受け入れます。キャンセルするには、<ESCAPE> キーを押します。
  8. [上へ] または [下へ] ボタンを押して、ツールデータまたはラベルの順番を変更することができます。
  9. ジョブファイルに保存します。

注: [通信] ステップから他のステップに移るときにも、EasyView 設定は自動的に In-Sight センサに保存されます。

  10. EasyView がどのように表示されるかをプレビューするには、VisionView PC デモアプリケーションまたは Web HMI を起動してください。

    注: ご使用の PC に VisionView PC デモがインストールされている場合、デフォルトのインストールディレクトリは、C:\Program Files\Cognex\VisionView\PC Demo x.x.x となります。 VisionView PC デモがインストールされていない場合、VisionView サポートサイトからアプリケーションをダウンロードできます。

  11. VisionView PC デモアプリケーションまたは Web HMI を起動したら、[接続] ステップでセンサを [切断] してください。

  12. Web HMI を使用している場合、EasyView ペインで EasyView をプレビューすることができます。

    VisionView PC デモを使用している場合、[選択中のセンサ] リストに使用中のセンサを追加してから、実行モードに入ります。[表示切り替え] ボタンを押して、EasyView をプレビューします。

注:
  • EasyView をプレビューするには、まず [HMI ビューの設定] ダイアログの [EasyView] オプションを ON にします。
  • VisionView PC Demo は、45 分で自動的にタイムアウトします。 すべての機能を使用することが可能で、タイムアウトすることのないライセンスバージョンを購入するには、VisionView PC ソフトウェアをインストールして下さい。VisionView PC ソフトウェアは、VisionView サポートサイトからダウンロードすることができます。
  • VisionView PC デモアプリケーションのルック&フィールは、VisionView オペレータインタフェースパネルとは多少異なります。
  • エミュレータにログオン中に EasyView をプレビューするには、まず、VisionView アプリケーションの [選択中のセンサ] リストに手動でエミュレータを追加する必要があります。


FTP を介して画像を転送するには

ネットワーク上の FTP サーバに画像を転送するように、In-Sight ビジョンシステムを設定することができます。 このように設定すると、アーカイブ用に取り込んだ画像を (ツールまたはジョブの PASS/FAIL 状態に基づいて) 転送して、他のデバイスに保存することができます。 また、保存した画像を確認することによって、生産過程で発生した問題の原因究明に役立てることもできます。

FTP 接続を設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [FTP] を選択します。
  2. [画像] タブを選択します。
  3. [追加] ボタンを押してエントリを追加し、画像転送のパラメータを設定します。

注: 1 つのジョブで、複数の画像を転送させることもできます。

  4. [設定] タブを選択して FTP サーバを設定します。
  5. In-Sight ビジョンシステムをオンラインにします。 画像転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時には画像は転送できません。
  6. ビジョンシステムの画像取り込みをトリガします。 画像を取り込むたびに、画像ファイルを転送し、パラメータで指定したホストに保存します。画像ファイルは、[ファイルフォーマット] パラメータで BMP または JPG を指定することができます。

注:

  • [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、画像ファイルを転送します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、画像ファイルを転送します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、画像ファイルを転送し、FTP サーバに保存します。
  • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます([ProgramData]\Cognex\In-Sight\Emulators\x.x.x)。 このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます(FTP ルートディレクトリ)。 FTP ルートディレクトリの詳細については、[オプション] ダイアログトピック (エミュレーションパネル) をご参照ください。

[画像] タブ

転送する画像、画像フォーマット、画像をいつ、どこに転送するかを定義するパラメータを設定します。

Closed [有効] チェックボックス

画像転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteImageFTP_1.ツール_有効など) として公開するかどうかを定義します。

注: 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。

Closed 名前

転送する画像の名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[出力]、[通信]) で参照されます。デフォルト名は、WriteImageFtp_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

Closed 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつデータを FTP サーバに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびにデータを転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、転送は実行されません。

Closed デバイス

FTP サーバを定義します。FTP サーバは [設定] タブで定義され、転送されるデータを受信します。 デフォルトでは、[デバイス 1] が選択されています。

Closed ファイルフォーマット

転送画像のファイルフォーマットを定義します。選択肢は、[BMP] (Windows ビットマップフォーマット) または [JPG] (標準エンコード JPEG フォーマット) です。 デフォルトでは、[BMP] が選択されています。

Closed 画像サイズ

転送画像の解像度を定義します。選択肢は、[フル (1/1)]、[ハーフ(1/2)]、[クォーター (1/4)] です。 デフォルトでは、[フル (1/1)] が選択されています。

Closed グラフィックを含む

[位置決め] および [検査] ツール用に、オーバレイグラフィックスのデータを含む SVG ファイルを作成するかどうかを定義します。 SVG ファイルおよび画像ファイルを表示するには、SVG ファイルタイプをサポートする (Microsoft Internet Explorer 9.0 など) ウェブブラウザを使用して、SVG ファイルおよび画像ファイルを開きます。 SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注:
  • 「グラフィックを含む」を有効にするには、右側のグループボックス内、[グラフィックを含む] チェックボックスを ON にしてください。 テーブル内の [グラフィックを含む] チェックボックスは、読み取り専用です。
  • ON にした場合、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • [設定] タブの [ホスト名] パラメータを In-Sight エミュレータに設定した場合、svg ファイルはエミュレータディレクトリ ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) に保存され、[In-Sight のファイル]ペインに表示されます。
  • [結果表示のオプション] ダイアログの [ツールのオプション] を使用して、[位置決め] および [検査] ツールのオーバレイグラフィックスを非表示に設定している場合、SVG 画像は出力されません。 デフォルトでは、すべてのツールはオーバレイグラフィックスを表示します。
  • ウェブブラウザといったサードパーティーのアプリケーションを使用してグラフィックスを表示するため、オーバレイグラフィックスのデータは、ピクセル単位で正確に一致しません。
  • In-Sight ファームウェアは、すべての SVG および画像ファイルぺアの送信を保証しません。 In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。
Closed ファイル名プレビュー

転送する画像ファイルの名前のプレビューを表示します。デフォルトでは、Image999 が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータを使用してカスタマイズすることができます。

注:
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
  • [カウンターの追加] パラメータを ON にすると、カウンターの最大値が [ファイル名プレビュー] に常に表示されます。
Closed デフォルトファイル名

転送する画像ファイルの名前を定義します。デフォルトは「Image」です。ロングファイル名がサポートされています。

Closed リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注:
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
Closed タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注: In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。

Closed カウンターの追加

転送するファイルの名前に、カウンターを追加するかどうかを定義します。デフォルトは、ON です。 ON にすると、カウンターの最大値を指定することができます (0～9999999; デフォルト = 999)。 各画像ファイルが転送されるごとにカウンタが 1 つ増加します。 カウンタが最大値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

Closed [追加] ボタン

転送操作をリストに追加します。

Closed [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。

Closed [すべてのカウンターをリセット] ボタン

リストにある画像転送の [ファイル名] に追加した数値を 000 にリセットします。

[設定] タブ

[設定] タブでは、パラメータを使用して 2 台の出力デバイスを定義することができます。 出力先デバイスには、In-Sight エミュレータや、ネットワーク上で FTP サーバとして動作するホストがあります。

Closed ホスト名

出力先デバイスの FTP サーバのホスト名 (または IP アドレス) を定義します。

注:
  • 無効な [ホスト名] を指定した場合、最大 30 秒後に接続はタイムアウトします。

  • [ホスト名] または [ユーザ名] を指定している場合、名前の前後にスペースを使用しないようにしてください。 [ホスト名] または [ユーザ名] 設定の前後にスペースがある場合、画像エクスポートに失敗し、指定したサーバに画像を書き込むことができません。

  • FTP サーバがインストールされている PC が他にある場合、保存場所を選択することができます。 In-Sight Explorer ソフトウェアは FTP サーバとして機能するため、 サードパーティーの FTP サーバを使用している場合、In-Sight Explorer を閉じる必要があります。 FTP サーバが動作していないのであれば、In-Sight Explorer を動作させる必要があります。 サードパーティーの FTP サーバを使用している場合、ホスト名のパラメータに PC の IP アドレスを使用してください。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。 例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。
Closed ユーザ名

出力先デバイスの FTP サーバ用に有効なユーザ名を定義します。ユーザ名には、最大 255 文字まで使用できます。 ユーザ名は、画像ファイルを転送する In-Sight ビジョンシステム上に存在する必要はありません。

Closed パスワード

出力デバイスの FTP サーバ用に有効なパスワードを定義します。 パスワードは最大 20 文字で、大文字と小文字の区別があります。

注:
  • セキュリティの目的から、入力されたパスワードは、フィールド内では "*" の表示でマスクされます。
  • パスワードは、暗号化されたフォーマットでジョブファイルに保存されます。
Closed 接続タイプ

画像転送の接続タイプを定義します。選択肢は、[標準 FTP]、[SFTP]、[三菱 GOT] です。 [SFTP] は、ファイル転送を保護し、SFTP アプリケーションとともに使用されます。[三菱 GOT] は、三菱 GOT 表示器での画像表示をサポートします。

注: [設定] タブの [接続タイプ] パラメータを [三菱 GOT] に設定した場合、最良の画質で表示するために [ファイルフォーマット] パラメータは [JPG] に設定してください。

Closed [FTP の設定] ボタン

[FTP の設定] ダイアログを開きます。

注: In-Sight センサ間ですべての FTP 接続が行われる In-Sight 専用のローカルネットワークでは、通常、デフォルト設定を変える必要はありません。 ただし、In-Sight ビジョンシステムとほかのネットワークデバイスの間や、別のネットワークの In-Sight センサとの間で FTP 接続が必要になる場合は、デフォルトの FTP 設定を変更しなければならないことがあります。

Closed 最終ネットワークエラー

転送中にエラーが発生した場合、エラーの原因を示すテキストを表示します。 画像のトリガなど、転送条件発生のイベントはファイルタブで指定されます。フィールドを更新するには、In-Sight ビジョンシステムをオンラインにする必要があります。


FTP を介してデータファイルを転送したり、またはデータ文字列の追記を行うには

ネットワーク上の FTP サーバにデータファイルを転送するように、In-Sight ビジョンシステムを設定することができます。 この機能は、データ結果のログ作成に使用されます。 このログはファイルで参照できます。

FTP 接続を設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [FTP] を選択します。
  2. [ファイル] タブを選択します。
  3. [追加] ボタンを押してエントリを追加し、転送のパラメータを設定します。

注: 1 つのジョブで、複数のファイルを転送させることもできます。

  4. [設定] タブを選択して FTP サーバを設定します。
  5. In-Sight ビジョンシステムをオンラインにします。 データ転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時にはデータは転送できません。
  6. ビジョンシステムをトリガします。 トリガのたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。ファイルは、[設定] タブで指定した FTP サーバに保存されます。

注:

  • [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。
  • In-Sight エミュレータを FTP サーバとして使用している場合、デフォルトで、ファイルは次のエミュレータフォルダに書き込まれます([ProgramData]\Cognex\In-Sight\Emulators\x.x.x)。 このディレクトリ以外のユーザ指定のロケーションにもファイルを書き込むことができます(FTP ルートディレクトリ)。 FTP ルートディレクトリの詳細については、[オプション] ダイアログトピック (エミュレーションパネル) をご参照ください。

[ファイル] タブ

転送するデータ、データフォーマット、データをいつ、どこに転送するかを定義するパラメータを設定します。

Closed [有効] チェックボックス

転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteIFtp_1.ツール_有効など) として公開するかどうかを定義します。

注: 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。

Closed 名前

転送するデータの名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[出力]、[通信]) で参照されます。デフォルト名は、WriteFtp_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

Closed 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつデータを FTP サーバに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびにデータを転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、転送は実行されません。

Closed デバイス

FTP サーバを定義します。FTP サーバは [設定] タブで定義され、転送されるデータを受信します。 デフォルトでは、[デバイス 1] が選択されています。

Closed ファイルタイプ

転送ファイルのフォーマットを定義します。選択肢は、Text、HTML (デフォルト)、XML または CSV です。

Closed 書き込みタイプ ([上書き] または [追加])

データをファイルに書き込む方法を指定します。

  • 上書き: ファイル内のデータを上書きします。
  • 追加: ファイルの最後にデータ文字列を追記します。
Closed ファイルコンテンツ/[カスタムフォーマット] ボタン

ファイルに書き込むデータを [フォーマット文字列] ダイアログを使用して定義します。

Closed ファイル名プレビュー

転送するファイルの名前のプレビューを表示します。デフォルトでは、「File」が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加] および [タイムスタンプの追加] パラメータを使用してカスタマイズすることができます。

注:
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加] および [タイムスタンプの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
Closed デフォルトファイル名

転送するファイルの名前を定義します。デフォルトは「File」です。 ロングファイル名がサポートされています。

Closed リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注:
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
Closed タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注: In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。

Closed [追加] ボタン

転送操作をリストに追加します。

Closed [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。

[設定] タブ

[設定] タブでは、パラメータを使用して 2 台の出力デバイスを定義することができます。 出力先デバイスには、In-Sight エミュレータや、ネットワーク上で FTP サーバとして動作するホストがあります。

Closed ホスト名

出力先デバイスの FTP サーバのホスト名 (または IP アドレス) を定義します。

注:
  • 無効な [ホスト名] を指定した場合、最大 30 秒後に接続はタイムアウトします。

  • [ホスト名] または [ユーザ名] を指定している場合、名前の前後にスペースを使用しないようにしてください。 [ホスト名] または [ユーザ名] 設定の前後にスペースがある場合、画像エクスポートに失敗し、指定したサーバに画像を書き込むことができません。

  • FTP サーバがインストールされている PC が他にある場合、保存場所を選択することができます。 In-Sight Explorer ソフトウェアは FTP サーバとして機能するため、 サードパーティーの FTP サーバを使用している場合、In-Sight Explorer を閉じる必要があります。 FTP サーバが動作していないのであれば、In-Sight Explorer を動作させる必要があります。 サードパーティーの FTP サーバを使用している場合、ホスト名のパラメータに PC の IP アドレスを使用してください。
  • FTP サーバ接続のポート番号を変更するには、ホスト名 (または IP アドレス)、コロン (:)、新しいポート番号の順に追記します。 例えば、現在のホスト名が PRODUCTION1 である場合、ポート番号をデフォルト (ポート 21) からポート 34 に変更するには、ホスト名パラメータに PRODUCTION1:34 と指定します。
Closed ユーザ名

出力先デバイスの FTP サーバ用に有効なユーザ名を定義します。ユーザ名には、最大 255 文字まで使用できます。 ユーザ名は、画像ファイルを転送する In-Sight ビジョンシステム上に存在する必要はありません。

Closed パスワード

出力デバイスの FTP サーバ用に有効なパスワードを定義します。 パスワードは最大 20 文字で、大文字と小文字の区別があります。

注:
  • セキュリティの目的から、入力されたパスワードは、フィールド内では "*" の表示でマスクされます。
  • パスワードは、暗号化されたフォーマットでジョブファイルに保存されます。
Closed 接続タイプ

画像転送の接続タイプを定義します。選択肢は、[標準 FTP]、[SFTP]、[三菱 GOT] です。 [SFTP] は、ファイル転送を保護し、SFTP アプリケーションとともに使用されます。[三菱 GOT] は、三菱 GOT 表示器での画像表示をサポートします。

注: [設定] タブの [接続タイプ] パラメータを [三菱 GOT] に設定した場合、最良の画質で表示するために [ファイルフォーマット] パラメータは [JPG] に設定してください。

Closed [FTP の設定] ボタン

[FTP の設定] ダイアログを開きます。

注: In-Sight センサ間ですべての FTP 接続が行われる In-Sight 専用のローカルネットワークでは、通常、デフォルト設定を変える必要はありません。 ただし、In-Sight ビジョンシステムとほかのネットワークデバイスの間や、別のネットワークの In-Sight センサとの間で FTP 接続が必要になる場合は、デフォルトの FTP 設定を変更しなければならないことがあります。

Closed 最終ネットワークエラー

転送中にエラーが発生した場合、エラーの原因を示すテキストを表示します。 画像のトリガなど、転送条件発生のイベントはファイルタブで指定されます。フィールドを更新するには、In-Sight ビジョンシステムをオンラインにする必要があります。


SD カードに画像を転送するには

In-Sight ビジョンシステムにイントールされた SD カードに画像を転送するように、In-Sight ビジョンシステムを設定することができます。 このように設定すると、アーカイブ用に取り込んだ画像を (ツールまたはジョブの PASS/FAIL 状態に基づいて) 転送して保存することができます。 また、保存した画像を確認することによって、生産過程で発生した問題の原因究明に役立てることもできます。

注: この機能は SD カードがインストールされた In-Sight ビジョンシステムのみでサポートされています。

SD カードに画像を送るには

  1. [通信] グループボックスの [SD カード] を選択します。
  2. [画像] タブを選択します。
  3. [追加] ボタンを押してエントリを追加し、画像転送のパラメータを設定します。

注: 1 つのジョブで、複数の画像を転送させることもできます。

  4. In-Sight ビジョンシステムをオンラインにします。 画像転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時には画像は転送できません。

  5. ビジョンシステムの画像取り込みをトリガします。 画像を取り込むたびに、画像ファイルを転送し、ビジョンシステムにインストールされた SD カードに保存します。画像ファイルは、[ファイルフォーマット] パラメータで BMP または JPG を指定することができます。

    注: [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、画像ファイルを転送します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、画像ファイルを転送します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、画像ファイルを転送し、FTP サーバに保存します。

コントロール

Closed [有効] チェックボックス

画像転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteImageLocal_1.ツール_有効など) として公開するかどうかを定義します。

注: 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。

Closed 名前

転送する画像の名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[通信]) で参照されます。デフォルト名は、WriteImageLocal_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

Closed 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつ画像を SD カードに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびに画像を転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、画像転送は実行されません。

注: 画像取り込みのたびに画像を転送するなど、特定の転送条件を高頻度で実行する場合、In-Sight ビジョンシステムの画像キューが一杯になり、その他の画像転送操作が実行不可能となって、すべての画像が転送されないことがあります。

Closed ファイルフォーマット

転送画像のファイルフォーマットを定義します。選択肢は、[BMP] (Windows ビットマップフォーマット) または [JPG] (標準エンコード JPEG フォーマット) です。 デフォルトでは、[BMP] が選択されています。

Closed 画像サイズ

転送画像の解像度を定義します。選択肢は、[フル (1/1)]、[ハーフ(1/2)]、[クォーター (1/4)] です。 デフォルトでは、[フル (1/1)] が選択されています。

Closed グラフィックを含む

[位置決め] および [検査] ツール用に、オーバレイグラフィックスのデータを含む SVG ファイルを作成するかどうかを定義します。 SVG ファイルおよび画像ファイルを表示するには、SVG ファイルタイプをサポートする (Microsoft Internet Explorer 9.0 など) ウェブブラウザを使用して、SVG ファイルおよび画像ファイルを開きます。 SVG ファイルには、このファイルに関連する取得画像へのリンクが含まれており、ブラウザで SVG ファイルを開くと、このリンクを使用して、取得画像と共にオーバレイグラフィックスを表示します。

注:
  • 「グラフィックを含む」を有効にするには、右側のグループボックス内、[グラフィックを含む] チェックボックスを ON にしてください。 テーブル内の [グラフィックを含む] チェックボックスは、読み取り専用です。
  • ON にした場合、SVG ファイルは [ファイル名] パラメータで指定した名前を使用します。
  • [設定] タブの [ホスト名] パラメータを In-Sight エミュレータに設定した場合、svg ファイルはエミュレータディレクトリ ([ProgramData]\Cognex\In-Sight\Emulators\x.x.x) に保存され、[In-Sight のファイル]ペインに表示されます。
  • [結果表示のオプション] ダイアログの [ツールのオプション] を使用して、[位置決め] および [検査] ツールのオーバレイグラフィックスを非表示に設定している場合、SVG 画像は出力されません。 デフォルトでは、すべてのツールはオーバレイグラフィックスを表示します。
  • ウェブブラウザといったサードパーティーのアプリケーションを使用してグラフィックスを表示するため、オーバレイグラフィックスのデータは、ピクセル単位で正確に一致しません。
  • In-Sight ファームウェアは、すべての SVG および画像ファイルぺアの送信を保証しません。 In-Sight ビジョンシステムがオーバーロードしている場合、検査や画像取得をミスしないよう、SVG/画像ファイルの片方、または両方の送信をスキップします。
Closed ファイル名プレビュー

転送する画像ファイルの名前のプレビューを表示します。デフォルトでは、Image999 が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータを使用してカスタマイズすることができます。

注:
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加]、[タイムスタンプの追加]、[カウンターの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
  • [カウンターの追加] パラメータを ON にすると、カウンターの最大値が [ファイル名プレビュー] に常に表示されます。
Closed デフォルトファイル名

転送する画像ファイルの名前を定義します。デフォルトは「Image」です。ロングファイル名がサポートされています。

Closed リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注:
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
Closed タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注: In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。

Closed カウンターの追加

転送するファイルの名前に、カウンターを追加するかどうかを定義します。デフォルトは、ON です。 ON にすると、カウンターの最大値を指定することができます (0～9999999; デフォルト = 999)。 各画像ファイルが転送されるごとにカウンタが 1 つ増加します。 カウンタが最大値に達するとリセットされ、出力先のシステムにある画像ファイルは同じ名前の新しいファイルで上書きされます。

Closed [追加] ボタン

転送操作をリストに追加します。

Closed [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。

Closed [すべてのカウンターをリセット] ボタン

リストにある画像転送の [ファイル名] に追加した数値を 000 にリセットします。


SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うには

SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うように、In-Sight ビジョンシステムを設定することができます。 この機能は、データ結果のログ作成に使用されます。 このログはファイルで参照できます。

注: この機能は SD カードがインストールされた In-Sight ビジョンシステムのみでサポートされています。

SD カードにデータファイルを転送したり、またはデータ文字列の追記を行うには:

  1. [通信] グループボックスの [SD カード] を選択します。
  2. [ファイル] タブを選択します。
  3. [追加] ボタンを押してエントリを追加し、画像転送のパラメータを設定します。

注: 1 つのジョブで、複数のファイルを転送させることもできます。

  4. In-Sight ビジョンシステムをオンラインにします。 データ転送を実行するには、ビジョンシステムをオンラインにする必要があります。オフライン時にはデータは転送できません。

  5. ビジョンシステムをトリガします。 トリガのたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。ファイルは、SD カードに保存されます。

    注: [転送条件] を [なし] (デフォルト) に設定している場合、画像を取り込むたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 [転送条件] を [なし] 以外に設定している場合、指定のイベントが発生するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します。 例えば、[転送条件] を [ジョブ.FAIL] に設定している場合、ジョブが FAIL するたびに、データファイルを転送するか、あるいはデータ文字列をファイルに追記します

コントロール

Closed [有効] チェックボックス

転送操作の実行可否 (デフォルトは ON) を定義したり、VisionView オペレータインタフェースパネルに表示し、オペレータによって編集可能な EasyView アイテム (WriteILocal_1.ツール_有効など) として公開するかどうかを定義します。

注: 有効にするには、[有効] チェックボックスを ON にしてください。 テーブル内で設定できるのは、このパラメータのみです。

Closed 名前

転送するデータの名前を定義します。この名前は、[結果の設定] の各ステップ ([入力/出力]、[出力]、[通信]) で参照されます。デフォルト名は、WriteLocal_1 で、末尾の番号は操作の増加に応じて増加します。 転送条件などに合わせて適切な名前に変更してください。

Closed 転送条件

ツールの PASS または FAIL 時、または入力を受信したときなど、いつ画像を SD カードに送信するかを定義します。 デフォルトは、[なし] です。[有効] チェックボックスが ON の場合、画像を取り込むたびにデータを転送します。 [有効] チェックボックスが OFF になっている場合、または参照されたツールが無効になっている場合は、転送は実行されません。

Closed ファイルタイプ

転送ファイルのフォーマットを定義します。選択肢は、Text、HTML (デフォルト)、XML または CSV です。

Closed 書き込みタイプ ([上書き] または [追加])

データをファイルに書き込む方法を指定します。

  • 上書き: ファイル内のデータを上書きします。
  • 追加: ファイルの最後にデータ文字列を追記します。
Closed ファイルコンテンツ/[カスタムフォーマット] ボタン

ファイルに書き込むデータを [フォーマット文字列] ダイアログを使用して定義します。

Closed ファイル名プレビュー

転送するファイルの名前のプレビューを表示します。デフォルトでは、「File」が表示されます。 ファイル名は、[デフォルトファイル名]、[リンクの追加] および [タイムスタンプの追加] パラメータを使用してカスタマイズすることができます。

注:
  • 最低 1 つ以上のパラメータを定義する必要があります。 [デフォルトファイル名] が空白で、[リンクの追加] および [タイムスタンプの追加] パラメータが OFF の場合、ファイルの転送に失敗します。
  • パラメータの順番は変更することはできません。
Closed デフォルトファイル名

転送するファイルの名前を定義します。デフォルトは「File」です。 ロングファイル名がサポートされています。

Closed リンクの追加

選択したツールをリンクして、その結果を転送するファイルの名前に追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。

注:
  • リンクされているツールの文字列に、<、>,、:、"、/、\、|、? または *が含まれている場合、ファイルの転送に失敗します。
  • リンク可能なツールを EasyBuilder が検出できない場合、[リンクの追加] チェックボックスはグレーアウトされます。
  • ジョブからリンクが削除されると、[リンクの追加] チェックボックスは自動的に OFF となります。
  • [リンクの追加] チェックボックスを ON にし、ドロップダウンリストから [未定義] を選択すると、予期しない結果が起こることがあります。
Closed タイムスタンプの追加

転送するファイルの名前に、タイムスタンプを追加するかどうかを定義します。 デフォルトでは、チェックボックスは OFF となっています。 ON にすると、ドロップダウンリストから次の定義済タイムスタンプフォーマットを選択することができます: MMDDYY、YYYYMMDD_HHMMSS、DDMMYY_HHMMSS、MM-DD-YYYY_HH.MM.SS、HHMMSS, YYMMDD_HHMMSS または YYDDMM_HHMMSS

注: In-Sight ビジョンシステムの日付/時刻は、[日付/時刻の設定] ダイアログを使用して設定することができます。

Closed [追加] ボタン

転送操作をリストに追加します。

Closed [削除] ボタン

転送操作をリストから削除します。 1 度に削除できるのは、転送操作 1 つのみです。


デバイスの設定

ロボットや PLC などの外部デバイスとデータ通信するには、まず In-Sight センサのネットワークおよびシリアル通信設定を定義する必要があります。

  • PLC/モーションコントローラ と通信するには
  • ロボットと通信するには
  • 三菱電機社製デバイスと通信するには
  • Modbus TCP 上で通信するには
  • TCP/IP 上で通信するには
  • UPD 上で通信するには
  • POWERLINK 上で通信するには
  • 識別ツールにデータを入力するには
  • 出力文字列をフォーマットするには

注: EasyBuilder では、位置決めまたは検査ツールの出力が無効な場合、そのツールのデフォルト値が出力データバッファに使用されます。 例えば、パターン位置決めツールがマッチするパターンを検出できない場合、そのツールの X および Y データは無効となるため、デフォルト値 0 が出力に使用されます。 したがって、出力データを送信するようにデバイスを設定する場合、ツールの結果だけでなく、ツールの PASS/FAIL ステータスも送信し、ツールのデータが有効であるかどうかを確認することを推奨します。 ツールの結果が無効な際に、出力バッファのデフォルト値を変更するには、In-Sight ネイティブモードコマンドを送信します。データの場合、SetSystemConfig("FormatOutputBufferErrData",-1111)。-1111 は既知のエラーを表します。出力文字列の場合、EV SetSystemConfig("FormatOutputBufferErrString","Error")。"Error" はエラー文字列を表します。

サポートしているプロトコル

最大 2 つまでのプロトコルをジョブに追加することができます。 プロトコルを 2 つ追加する場合、「プライマリ」プロトコル✕ 1 と、「セカンダリ」プロトコル✕ 1 を追加することができます。 例えば、[SLMP スキャナ] プロトコル (プライマリ) の追加後、[デバイスの追加] ボタンをクリックして [TCP/IP] プロトコル (セカンダリ) を追加することができます。

注: 「プライマリ」プロトコル✕ 2 または、「セカンダリ」プロトコル✕ 2 を追加することはできません。

In-Sight ファームウェア 4.x.x

 | プライマリまたは セカンダリ | Micro 1000 シリーズ | 5000 シリーズ (5705 & 5705C を除く) | 70xx - 74xx シリーズ
CC-Link | プライマリ | X | X | X
イーサネットネイティブ | プライマリ | X | X | X
イーサネットネイティブロボット | プライマリ | X | X | X
イーサネットネイティブ文字列 | プライマリ | X | X | X
EtherNet/IP | プライマリ | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X
POWERLINK | プライマリ |  |  | X
PROFINET | プライマリ | X | X | X
シリアル Kuka | プライマリ | X | X | X
シリアル Motoman | プライマリ | X | X | X
シリアルネイティブ | プライマリ | X | X | X
シリアルネイティブロボット | プライマリ | X | X | X
シリアルネイティブ文字列 | プライマリ | X | X | X
シリアルテキスト | プライマリ | X | X | X
SLMP | プライマリ | X | X | X
SLMP スキャナ | プライマリ | X | X | X
TCP/IP | セカンダリ | X | X | X
UDP | セカンダリ | X | X | X

In-Sight ファームウェア 5.x.x

 | プライマリまたは セカンダリ | 2000 シリーズ | 5705 & 5705C | 76xx - 79xx シリーズ | Micro 8000 シリーズ
イーサネットネイティブ | プライマリ |  | X | X | X
イーサネットネイティブロボット | プライマリ |  | X | X | X
イーサネットネイティブ文字列 | プライマリ |  | X | X | X
EtherNet/IP | プライマリ | X | X | X | X
Modbus TCP サーバ | プライマリ | X | X | X | X
PROFINET | プライマリ | X | X | X | X
シリアル Kuka | プライマリ |  | X | X | X
シリアル Motoman | プライマリ |  | X | X | X
シリアルネイティブ | プライマリ | X (ベーシック) | X | X | X
シリアルネイティブロボット | プライマリ |  | X | X | X
シリアルネイティブ文字列 | プライマリ |  | X | X | X
シリアルテキスト | プライマリ | X | X | X | X
SLMP | プライマリ | X | X | X | X
SLMP スキャナ | プライマリ | X | X | X | X
TCP/IP | セカンダリ | X | X | X | X
UDP | セカンダリ | X | X | X | X


PLC/モーションコントローラ と通信するには

PLC/MC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。

  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。

    注:DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、設定ペインに表示されるタブを設定して下さい。

利用可能な PLC/モーションコントローラのプロトコル

注: サポートされているプロトコルの一覧は、[デバイスの設定] をご参照ください。

  • Modbus TCP サーバ
  • CC-Link
  • SLMP
  • SLMP スキャナ
  • EtherNet/IP
  • PROFINET
  • DeviceNet


Modbus TCP 上で通信するには

In-Sight センサを、ネットワーク上にある他の Modbus TCP デバイス用 Modbus サーバとして使用することができます。

In-Sight センサを Modbus サーバとして設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [PLC] または [その他] を選択します。

注: [PLC] を選択した場合、[メーカー] ドロップダウンリストから PLC のメーカーまたは [その他] を選択し、次に [プロトコル] ドロップダウンリストから [Modbus TCP サーバ] を選択します。

  3. [プロトコル] ドロップダウンリストから [Modbus TCP サーバ] を選択します。
  4. [OK] ボタンを押します。
  5. デフォルトで、[フォーマット出力データ] タブが最初に表示されます。 2 つのタブのコントロールは同じで、データの追加後に有効となります。

  6. [追加] ボタンを押して [入力データの選択] または [出力データの選択] (どちらのタブが選択されているかによります) を開きます。 ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 Modbus マスタに公開するデータをダイアログから選択して、[OK] ボタンを押してください。

  7. 追加されたデータの [名前]、[データタイプ]、[バイト数]、[値] および選択されたデータの [レジスタ] 開始数 (Modbusクライアントの Read および Write コマンドがこの数字を参照し、信号がどのレジスタかどうかを判断します) がテーブルに表示されます。 テーブルの右側は、Modbus 登録のデータフォーマットを表示する Modbus レジスタプレビューウィンドウです。

  8. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [データ型] ドロップダウンリストから [文字列] または [バイト変換文字列] を選択すると、[エレメントごとのデータ長 (ワード)] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
  • EasyBuilder に実装されている Modbus TCP プロトコルは、ビット、8 ビットおよび符号なしデータ型をサポートしていません。

  9. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、32 ビット浮動小数点および 32 ビット整数のバイトオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。 また、[ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、32 ビット浮動小数点および 32 ビット整数のワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。 変更事項は、Modbus レジスタプレビューウィンドウに更新されます。

注:バイトオーダまたはワードオーダに関する変更は、[フォーマット出力データ] および [フォーマット入力データ] タブのすべてのデータ符号に影響します。

  10. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
  11. In-Sight ビジョンシステムの設定が済んだら、In-Sight ビジョンシステムにデータ読み取り/書き込みを命令する、Read および Write コマンドを送信するよう Modbus クライアントを設定する必要があります。

注:オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


CC-Link 通信

注: CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

CC-Link プロトコルは、In-Sight CIO-MICRO-CC に接続した In-Sight ビジョンシステムと三菱シーケンサの間でデータを送受信するのに使用されます。 CC-Link 通信は、In-Sight CIO-MICRO-CC I/O モジュール上の CC-link 接続と三菱シーケンサ上の CC-link 接続の間で確立されます。

注: CC-Link 通信を有効にするには、In-Sight ビジョンシステムを In-Sight CIO-Micro-CC I/O モジュール に接続する必要があります。

CC-link を介して三菱シーケンサ/モーションコントローラと通信するように In-Sight ビジョンシステムを設定するには、まず [CC-Link 通信設定] タブのパラメータを設定し、次に三菱シーケンサと In-Sight ビジョンシステムの間で送受信されるデータを設定します。

  • [CC-Link 通信設定] タブを設定するには
  • [フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには


SLMP 通信

SLMP は、三菱電機社製シーケンサと In-Sight ビジョンシステム間での、データ送受信に使用されます。

まず、[SLMP 設定] タブのパラメータを設定します。このタブでは、コントローラタイプ、IP アドレス、ポート番号、三菱電機社製シーケンサの読み出し/書き込み先レジスタ、およびタイムアウトの情報を設定します。

次に、[フォーマット入データ] および [フォーマット出力データ] タブを設定します。これらのタブでは、シーケンサに送受信するツールまたはデータを定義します。

  • [SLMP 設定] タブを設定するには
  • [フォーマット入力データ] および [フォーマット出力データ] タブを設定するには


SLMP スキャナ通信

SLMP スキャナは、三菱電機社製シーケンサと In-Sight ビジョンシステム間での、データ送受信に使用されます。

まず、[設定] タブのパラメータを設定します。このタブでは、三菱電機社製シーケサとの通信を確立するのに必要な情報を定義します。

次に、[デバイスのアドレス指定] タブを設定します。このタブでは、シーケンサのアドレスや、シーケンサ通信用の各種データブロックのサイズを定義します。

最後に、[フォーマット入力データ] および [フォーマット出力データ] タブを設定します。これらのタブでは、シーケンサに送受信するツールまたはデータを定義します。

  • SLMP スキャナ [設定] タブを設定するには
  • SLMP スキャナ [デバイスのアドレス指定] タブを設定するには
  • SLMP スキャナ [フォーマット入力データ] および [フォーマット出力データ] タブを設定するには


DeviceNet シリアルポートの設定

EasyBuilder は、DeviceNet コントローラの標準シリアルポート設定をデフォルトとして使用します。 コントローラが別の設定を使用する場合は、[シリアルポートの設定] タブをクリックし、DeviceNet コントローラと同じシリアルポート設定をするように、In-Sight ビジョンシステムのシリアルポートを設定してください。 [通信] ステップから他のステップに移るときに、シリアルモード設定は In-Sight ビジョンシステムに保存されます。

注:
  • DeviceNet は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。
  • DeviceNet の設定には、Cognex 社製以外の RS-232 からの DeviceNet ゲートウェイアダプタが必要です。 これらの設定は、レガシーインストールに使用可能です。新しいアプリケーションでは、RS-232 からの DeviceNet ゲートウェイコンバータがそのアプリケーションに適しているかどうか検証されていない限り、使用しないでください。

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。


ロボットと通信するには

ロボットガイダンスのアプリケーションでは、EasyBuilder が開発効率を大幅に向上します。EasyBuilder はアプリケーションを自動的に検査して、フィクスチャデータ (または位置決めツールや検査ツールが出力する位置データ) を各メーカーおよびプロトコルに準じたフォーマットに整形します。 その後、再びネイティブモードコマンドを使用して、ロボットが In-Sight センサに対しフォーマットされた文字列を送信するようにリクエストします。

ロボットコントローラと通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[ロボット] を選択します。
  3. [メーカー] ドロップダウンリストから、[ロボット] を選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、データを定義してください。

  • イーサネットネイティブ通信 (ロボット)
  • シリアルネイティブ通信 (ロボット)
  • シリアル Kuka 通信 (ロボット)
  • シリアル Motoman 通信 (ロボット)
  • Ethernet IP 通信 (FANUC ロボットコントローラ)


イーサネットネイティブ通信 (ロボット)

注: 次の説明は、[通信] グループボックスで [デバイス] から [ロボット] を選択し、[プロトコル] から [イーサネットネイティブ] を選択した場合のみ適用となります。

  1. [プロトコル] から [イーサネットネイティブ] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ文字列を作成します。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。
  3. 文字列がフォーマットされたら、ロボットコントローラは、In-Sight ネイティブモードコマンド、EV GetCellValue("Job.Robot.FormatString") を送信して、データをリクエストすることができるようになります。EV GetCellValue ("Job.Robot.FormatString") は、一回のコマンドで文字列にフォーマットされたすべてのデータを返します。

注: 定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。


シリアルネイティブ通信 (ロボット)

注: 次の説明は、[通信] セクションで、[デバイス] から [ロボット] を選択し、[プロトコル] から [シリアルネイティブ] を選択した場合のみに適用となります。

  1. [プロトコル] から [シリアルネイティブ] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。
  3. [シリアルポートの設定] タブをクリックし、シリアルポートを定義してください (必要な場合のみ)。 EasyBuilder は、[デバイスの設定] グループボックスに基づいて、シリアルプロトコルを自動的に検討します。 [通信] ステップから他のステップに移るときに、シリアルポート設定は In-Sight ビジョンシステムに保存されます。
注:

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。
  4. 文字列がフォーマットされたら、ロボットコントローラは、In-Sight ネイティブモードコマンド、EV GetCellValue("Job.Robot.FormatString") を送信して、データをリクエストすることができるようになります。 EV GetCellValue ("Job.Robot.FormatString") は、一回のコマンドで文字列にフォーマットされたすべてのデータを返します。

注:定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。


シリアル Kuka 通信 (ロボット)

Kuka ロボットコントローラは、複雑ですが非常に強力なエラーチェックプロトコルを使用して、RS-232 シリアルポート経由でほかのデバイスと通信します。 Kuka シリアル通信用に設定すると、In-Sight ビジョンシステムはこのプロトコルを認識して、Kuka コントローラから受信したコマンドに応答できるようになります。

注:
  • In-Sight ビジョンシステムと通信するには、Kuka ロボットは P3964R モードである必要があります。また、後述のように、ビジョンシステムは [シリアル Kuka] モードである必要があります。
  • In-Sight ビジョンシステムは、Kuka のデフォルトのプロトコル設定 (すなわち、トランザクションにおいて、Kuka ロボットの優先度が高く、In-Sight ビジョンシステムの優先度が低い設定) を使用するように設定されています。

  1. [プロトコル] から [シリアル Kuka] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。 [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。 また、[エンコードされたロケーション] も表示され、In-Sight ネイティブモードコマンド、GV[EncodedLocation] を入力するときに、Kuka ロボットコントローラが参照するデータが表示されます。

注:定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。

  2. EasyBuilder ビジョンシステムは、Kuka コントローラの標準のシリアルポート設定をデフォルトとして使用するようになります。 ただし、コントローラが別の設定を使用する場合には、[シリアルポートの設定] タブをクリックし、Kuka コントローラと同じシリアルポート設定を使用するように、In-Sight を設定してください。 [通信] ステップから他のステップに移るときに、シリアルモード設定は In-Sight ビジョンシステムに保存されます。
注:
  • Kuka KR C2 および KR C2 Edition 2005 ロボットコントローラがサポートされます。

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。
  3. Kuka ロボットコントローラは、In-Sight ビジョンシステムとの間のすべてのデータ通信をネイティブモードコマンドを使用して開始します。 GV[EncodedLocation] コマンドは、このステップで設定された文字列を返します。また、このコマンドは、EasyBuilder で開発されたジョブに使用してください。

シリアル Kuka モードは、In-Sight のネイティブモード通信の拡張です。 シリアル Kuka モードはネイティブモードに基づくので、In-Sight のジョブをネイティブモードで開発してテストした後、実際のロボットコントローラが In-Sight センサに接続されている場合のみシリアル Kuka モードに切り替えることができます。 ジョブにその他の変更を加える必要はありません。

Closed サポートする In-Sight ネイティブモード (シリアル Kuka 通信)
ネイティブモードコマンド | シンタックス
Get Job | GJ
Get Online | GO
Get Value | GV[EncodedLocation]
Get Value | GV[シンボリック名]
Load File | LF[ファイル名]
Set Event | SE[整数]
Store File | TF[ファイル名]
Set Float | SF[シンボリック名][不動小数点]
Set Integer | SI[シンボリック名][整数]
Set Job | SJ[ID]
Set Online | SO[整数]
Set String | SS[シンボリック名][文字列]


シリアル Motoman 通信 (ロボット)

Motoman MRC、MRC-II、および XRC ロボットコントローラは、複雑ですが非常に強力なエラーチェックプロトコルを使用して、RS-232 シリアルポート経由で他のデバイスと通信します。 Motoman シリアル通信用に設定すると、In-Sight ビジョンシステムはこのプロトコルを認識して、Motoman コントローラから受信したコマンドに応答できるようになります。

注:
  • コントローラは、DCI モードで通信するように設定する必要があります。 In-Sight から Motoman ロボットコントローラに対して開始された、ホストモードで動作している通信は、現時点ではサポートされていません。
  • Motoman コントローラではフロー制御を「なし」に指定している場合でも、In-Sight ビジョンシステムでは Motoman コントローラとの通信時に「ハードウェア」によるフロー制御 (ハードウェアフロー制御) が必要です。
  • Motoman XRC コントローラのみテスト済みです。
  • シリアルMotoman モードは ネイティブモードに基づくので、In-Sight のジョブをネイティブモードで開発してテストした後、実際のロボットコントローラが In-Sight ビジョンシステムに接続されている場合のみ、シリアル Motoman モードに切り替えることができます。 ジョブにその他の変更を加える必要はありません。

  1. [プロトコル] から [シリアル Motoman] を選択すると、EasyBuilder は自動的にジョブからフィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。

注:定義済みのフィクスチャがジョブにない場合、またはカスタマイズされた文字列を作成したり、文字列のフォーマットをカスタマイズしたい場合は、[カスタムフォーマット...] ボタンを押して、[FormatString] ダイアログを開いてください。このダイアログを使用して、異なる文字列を追加したり、文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。文字列の変更を終了したら、[OK] ボタンを押します。

  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。 ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。 ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。 フォーマットされた文字列が表示されます。また、文字列の文字数も参照用に表示されます。
  3. [エンコードされたロケーション] に、In-Sight ビジョンシステムからデータを取得するときに、Motoman ロボットコントローラが使用する CC + RRR データが表示されます。
  4. EasyBuilder ビジョンシステムは、Motoman コントローラの標準のシリアルポート設定をデフォルトとして使用するようになります。 ただし、コントローラが別の設定を使用する場合には、[シリアルポートの設定] タブをクリックし、Motoman コントローラと同じシリアルポート設定を使用するように、In-Sight を設定してください。 [通信] ステップから他のステップに移るときに、シリアルモード設定は In-Sight ビジョンシステムに保存されます。
注:

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight 70xx - 74xx シリーズビジョンシステムが CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用するように構成されている場合、電源 I/O ケーブルの RS-232 TRANSMIT および RS-232 RECEIVE ピンは無効です。 I/O モジュールの RS-232 OUT ポート (DB9) を使用して、シリアルデバイスに接続してください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。
  5. Motoman ロボットコントローラは、In-Sight ビジョンシステムとの間のすべてのデータ通信をネイティブモードコマンドを使用して開始します。 GV[EncodedLocation] コマンドは、このステップで設定された文字列を返します。また、このコマンドは、EasyBuilder で開発されたジョブに使用してください。

シリアル Motoman モードは、In-Sight のネイティブモード通信の拡張です。 Motoman ロボットコントローラは、RS-232 ポートを介して数値テキストのみを送信します。In-Sight の標準ネイティブモードコマンドを送信することはできません。。 その代わりに、Motoman コントローラは、ネイティブモードコマンドの数値表現に必要に応じて追加パラメータを付加したものを In-Sight ビジョンシステムに送信する必要があります

この他の Motoman コマンドについては、次のトピックを参照してください。

  • Motoman コマンド
  • Motoman コマンドの例


ロボット EtherNet/IP 通信 (FANUC)

FANUC ロボットコントローラと EtherNet/IP (EIP) を介して通信するように、In-Sight ビジョンシステムを設定することができます。

  1. [デバイス] から [ロボット] を選択し、[メーカー] から [FANUC] を選択した後に [EtherNet/IP ロボット] を選択すると、EasyBuilder は自動的にジョブを検証して、フィクスチャを定義する位置決めツールまたは検査ツールをサーチし、データ列を作成します。

    注:
    • FANUC ロボットコントローラ用に通信を設定する際に、[メーカー] から [その他] を選択すると、EasyBuilder は他のデバイス用の EtherNet/IP 設定を表示します。
    • イーサネットネイティブロボットまたはシリアルネイティブロボットプロトコルを使用して FANUC ロボットコントローラを使用する場合は、イーサネットネイティブロボット通信トピックまたはロボットシリアルネイティブ通信トピックをご参照ください。
  2. [フォーマット出力文字列] タブの [ポジション名] ドロップダウンリストに、フィクスチャを作成するすべてのツールが表示されます。ジョブにポジションを返すツールが 1 つしか含まれていない場合、そのツールがデフォルトとして選択されます。ポジションを返すツールが 2 つ以上ある場合は、[ポジション名] ドロップダウンリストから、送信する出力文字列のツールを選択してください。出力バッファに文字列が表示されます。また、メッセージサイズ (バイト) も参照用に表示されます。

注: FANUC ロボットコントローラの詳細については、ロボット通信 - FANUC ロボットコントローラトピックをご参照ください。


三菱電機社製デバイスと通信するには

Closed 三菱シーケンサと通信するには

次の手順で設定してください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、[三菱電機] を選択します。

  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。選択肢は、[SLMP]、[SLMP スキャナ] または [CC-Link] です。

    注: CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムでのみ使用可能です。In-Sight ファームウェア 5.1.0 以降を搭載した In-Sight ビジョンシステムでは使用できません。モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、三菱電機社製シーケンサデバイスとの通信を設定してください。

  • CC-Link
  • SLMP
  • SLMP スキャナ

注: In-Sight ビジョンシステムを SLMP、SLMP スキャナ、または CC-Link を介して PLC と通信するように設定した場合、プロトコルはビジョンシステムと PLC 間のデータ転送のみをサポートします。

Closed 三菱ロボットと通信するには

次の手順で設定してください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[ロボット] を選択します。
  3. [メーカー] ドロップダウンリストから、[三菱電機] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。選択肢は、[イーサネットネイティブ文字列] または [シリアルネイティブ文字列] です。
  5. [OK] ボタンを押します。
  6. オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。

[通信] グループボックスの設定後、In-Sight ビジョンシステムとロボット間の通信データを設定して下さい。

  • 三菱イーサネットネイティブ文字列通信を設定するには
  • 三菱イーサネットシリアル文字列通信を設定するには


[CC-Link 通信設定] タブを設定するには

[CC-Link 通信設定] タブは、CC-Link ネットワーク上の In-Sight CIO-MICRO-CC I/O モジュール通信を設定するのに使用されます。

注: CIO-MICRO-CC I/O モジュールに接続していない場合、すべてのコントロールは無効となります。

Closed 有効

CIO-MICRO-CC I/O モジュール上の CC-Link インタフェースを有効にするかどうかを指定します。デフォルトでは、[有効] チェックボックスは ON で、In-Sight CIO-MICRO-CC I/O モジュール上の CC-Link インタフェースは有効となっています。[有効] チェックボックスを OFF にして、必要な場合に CC-Link 接続を診断、デバッグします。

Closed バージョン

CC-Link の仕様互換性を指定します。選択肢は、[V1] または [V2] です。デフォルトでは、[V1] が選択されています。

Closed ビット/秒

CC-Link ネットワークの CC Link ビット/秒を指定します。選択肢は、[10M]、[5M]、[2.5M]、[625k]、および [156k] です。デフォルトでは、[10M] が選択されています。

Closed 局番号:

CC-Link スレーブの局番号を指定します (1～64、 デフォルトは、1)。

注: [局番号] および [局数] パラメータには、最大 64 までの値を割り当てることができます。

Closed 局数:

CC-Link ネットワーク上で In-Sight CIO-MICRO-CC I/O モジュールが占める局数を指定します (1～4、 デフォルトは、1)。

注: [局番号] および [局数] パラメータには、最大 64 までの値を割り当てることができます。

Closed 拡張サイクル:

CC-Link ネットワーク上で In-Sight CIO-MICRO-CC I/O モジュールが使用する拡張サイクルの数を指定します。選択肢は、[1X (無効) ]、[2X]、[4X]、または [8X] です。デフォルトでは、[1X (無効) ] が選択されています。

注: このオプションは、[バージョン] パラメータを [V2] に設定した場合のみ有効です。

Closed 入力

入力ビットで使用可能なビット数、およびワードバッファで使用可能なワード数を表示します。

入力バッファで使用可能なビット数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2]　にして、さらに [拡張サイクル] パラメータを有効にした場合: 32× (局数) × (拡張サイクル) -16

入力バッファで使用可能なワード数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] を有効にした場合: 4× (局数) × (拡張サイクル)
Closed 出力

出力ビットで使用可能なビット数、およびワードバッファで使用可能なワード数を表示します。

出力バッファで使用可能なビット数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 32× (局数) -16
  • [バージョン] パラメータを [V2] にして、さらに [拡張サイクル] パラメータを有効にした場合: 32× (局数) × (拡張サイクル) -16× (拡張サイクル) -16

出力バッファで使用可能なワード数を指定するには

  • [バージョン] パラメータを [V1] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] に、[拡張サイクル] パラメータを [1X (無効) ] に設定した場合: 4× (局数)
  • [バージョン] パラメータを [V2] に、[拡張サイクル] を有効にした場合: 4× (局数) × (拡張サイクル)


[フォーマット入力ビット/ワードデータ] タブおよび [フォーマット出力ビット/ワードデータ] タブを設定するには

[CC-Link 通信設定] タブの設定後、[フォーマット入力ビットデータ]、[フォーマット入力ワードデータ]、[フォーマット出力ビットデータ] および [フォーマット出力ワードデータ] タブを設定します。これらのタブでは、三菱シーケンサと In-Sight ビジョンシステムの間で、CC-Link ネットワークを介し送受信されるツールまたはジョブデータが定義されます。

Closed [フォーマット入力ビットデータ] を設定するには

[フォーマット入力ビットデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返されるすブールデータタイプに、ビットオフセットを関連付けます。 最大 32 までの入力を設定することができます。

  1. シーケンサから In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット入力ビットデータ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。
  4. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
Closed [フォーマット入力ワードデータ] タブを設定するには

[フォーマット入力ワードデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返される In-Sight ビジョンシステムへの入力を定義します。 最大 32 までの入力を設定することができます。

注: ワード数は、[CC-Link 通信設定] タブのパラメータで設定した上限を越えることはできません。

  1. シーケンサから In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット入力ワードデータ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス] (開始アドレスは、ワードのフィールドオフセット) 、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。
  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数 (最大 128) を選択して文字列長を指定することができます。
  • EasyBuilder に実装されている CC-Link は、8 ビットおよび符号なしデータ型をサポートしていません。

  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
Closed [フォーマット出力ビットデータ] タブを設定するには

[フォーマット出力ビットデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、またはジョブの結果が返すブールデータタイプに、ビットオフセットを関連付けます。 各ジョブに対し 64 以上の出力を定義することができます。 (ジョブサイズによって上限が変わります) 。

  1. In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット出力ビットデータ] タブをクリックします。
  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

注: デフォルトで、Job.Inspection_CountJ データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。

  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。
  4. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
Closed [フォーマット出力ワードデータ] タブを設定するには

[フォーマット出力ワードデータ] タブを使用して、位置決め/検査ツール結果、画像取り込みデータ、または入力によって返される In-Sight ビジョンシステムへの出力を定義します。 各ジョブに対し 32 以上の出力を定義することができます。 (ジョブサイズによって上限が変わります) 。

  1. In-Sight ビジョンシステムに転送されるデータを設定するには、まず [フォーマット出力ビットデータ] タブをクリックします。
  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

注: デフォルトで、Job.Inspection_CountJ データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。

  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] (開始アドレスは、ワードでのフィールドオフセット) がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。
  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数 (最大 128) を選択して文字列長を指定することができます。
  • EasyBuilder に実装されている CC-Link は、8 ビットおよび符号なしデータ型をサポートしていません。

  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


[SLMP 設定] タブを設定するには

[SLMP 設定] タブは、シーケンサのコントローラタイプ、IP アドレス、TCP ポート番号、タイムアウト、読み出し先/書き込み先のレジスタロケーションを設定するのに使用されます。

Closed コントローラタイプ

三菱シーケンサのタイプを指定します。選択肢は、 iQ-R/Q/L シリーズ (3E フレーム)、 iQ-F シリーズ (3E フレーム) または FX シリーズ (1E フレーム) です。 デフォルトは、iQ-R/Q/L シリーズ (3E フレーム) です。

注: iQ-F シリーズ (3E フレーム) オプションは、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
Closed IP アドレス

三菱シーケンサの IP アドレスを指定します。In-Sight ビジョンシステムに接続する、三菱シーケンサの IP アドレスを入力してください。

Closed ポート番号

三菱シーケンサの TCP ポート番号を 10 進数 または 16 進数で定義します (10 進数: 1～65535、16 進数: 1～0xFFFF。デフォルトは、10 進数 = 12288)。

注:

  • この値は、三菱シーケンサの SLMP ポートで設定するポート番号設定と一致する必要があります。

  • [ポート番号] は、In-Sight Explorer を閉じたときに [10 進値] にリセットされます。

Closed タイムアウト (ms)

読み取りおよび書き込み操作でのタイムアウト時間 (5～30,000 ミリ秒) を指定します。デフォルトは、1,000 ミリ秒です。

注: このパラメータの設定によっては、ジョブの実行時間が長くなる可能性があります。読み取りおよび書き込み操作に失敗した場合、両方のタイムアウト時間が重なってしまうため、2 倍のタイムアウト時間がジョブに追加されます。

Closed 読み出し先
Closed デバイス

三菱シーケンサの読み出し先デバイスレジスタを定義します。

iQ-R/Q/L シリーズ (3E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー | ビット
Y - 出力リレー | ビット
M - 内部リレー | ビット
L - ラッチリレー | ビット
F - アナンシエータ | ビット
B - リンクリレー | ビット
D - データレジスタ | ワード
W - リンクレジスタ | ワード
R - ファイルブロックレジスタ | ワード
ZR - ファイルレジスタ | ワード
TN - タイマ値 | ワード
CN - カウンタ値 | ワード

iQ-F シリーズ (3E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー | ビット
Y - 出力リレー | ビット
M - 内部リレー | ビット
F - アナンシエータ | ビット
D - データレジスタ | ワード

FX シリーズ (1E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー | ビット (8 進数)
Y - 出力リレー | ビット (8 進数)
M - 内部リレー | ビット
D - データレジスタ | ワード
TN - タイマ値 | ワード
CN - カウンタ値 | ワード
R - 拡張レジスタ | ワード
S - ステートリレー | ビット

注: デバイスタイプのフォーマットによって、[フォーマット入力データ] タブで使用できるデータの種類が決定されます。デバイスタイプのフォーマットがビットの場合、[フォーマット入力データ] タブに入力できるデータタイプは [ビット] のみです。

Closed オフセット

読み出し開始を指定するシーケンサデータテーブルの数字部分です。

Closed 書き込み先
Closed デバイス

三菱シーケンサの書き込み先デバイスレジスタを定義します。

iQ-R/Q/L シリーズ (3E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー | ビット
Y - 出力リレー | ビット
M - 内部リレー | ビット
L - ラッチリレー | ビット
F - アナンシエータ | ビット
B - リンクリレー | ビット
D - データレジスタ | ワード
W - リンクレジスタ | ワード
R - ファイルブロックレジスタ | ワード
ZR - ファイルレジスタ | ワード
TN - タイマ値 | ワード
CN - カウンタ値 | ワード

iQ-F シリーズ (3E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー | ビット
Y - 出力リレー | ビット
M - 内部リレー | ビット
F - アナンシエータ | ビット
D - データレジスタ | ワード

FX シリーズ (1E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー | ビット (8 進数)
Y - 出力リレー | ビット (8 進数)
M - 内部リレー | ビット
D - データレジスタ | ワード
TN - タイマ値 | ワード
CN - カウンタ値 | ワード
R - 拡張レジスタ | ワード
S - ステートリレー | ビット

注: デバイスタイプのフォーマットによって、[フォーマット出力データ] タブで使用できるデータの種類が決定されます。デバイスタイプのフォーマットがビットの場合、[フォーマット出力データ] タブに入力できるデータタイプは [ビット] のみです。

Closed オフセット

書き込み開始を指定するシーケンサデータテーブルの数字部分です。


[フォーマット入力データ] および [フォーマット出力データ] タブを設定するには (SLMP)

[設定] タブの設定後、[フォーマット入力データ] および [フォーマット出力データ] タブを設定します。これらのタブを使用して、三菱シーケンサと In-Sight ビジョンシステムの間で送受信されるツールまたはジョブデータを定義します。

Closed [フォーマット入力データ] タブを設定するには

[フォーマット入力データ] タブを使用して、In-Sight ビジョンシステムへの入力を指定します。各ジョブに対し、最大 32 までの入力を設定することができます。

  1. [フォーマット入力データ] タブを使用して、In-Sight ビジョンシステムへの入力を指定します。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

注: [設定] タブの [読み出し先] デバイスの設定により、追加できるデータ型が異なります。 各ビットアドレスに対し、[読み出し先] デバイスをビットデバイスに設定した場合は、ブールデータタイプを追加し、使用するビットを割り当てます。 [読み出し先] デバイスをワードデバイスに設定した場合、[データ型] が設定可能となります。その場合、開始アドレスは入力データデバイスアドレスおよびワードのフィールドオフセットとなります。

  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。
  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [設定] タブの [読み出し先] デバイスの設定により、追加可能な [データ型] の選択肢が異なります。 [読み出し先] デバイス設定をビットデバイスに設定した場合、[データ型] ドロップダウンリストには、[ビット] のみ含まれます。 [読み出し先] デバイス設定をワードデバイスに設定した場合、[データ型] ドロップダウンリストの選択肢は、[ビット]、[16 ビット整数]、[16 ビット符号なし整数]、[32 ビット整数]、[32 ビット浮動小数点数] および [文字列] となります。
  • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。 [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードになります。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
  • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大入力データ長は 1920 バイトです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大入力データ長は 128 バイトです。 入力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
  • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
  • EasyBuilder に実装されている SLMP/MC プロトコルは、8 ビットおよび符号なしデータ型をサポートしていません。

  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
Closed [フォーマット出力データ] タブを設定するには

[フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムからの出力を指定します。各ジョブに対し、最大 128 までの出力を設定することができます。

  1. [フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムからの出力を指定します。
  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。

注:
  • デフォルトで、Job.Inspection_Count データシンボルが自動的に出力データテーブルに追加されます。 このシンボルは、In-Sight ビジョンシステムが新しい画像を取り込み、新しい検査結果が到達したことを、シーケンサに警告します。 このシンボルは、アプリケーションに必要ない場合、削除可能です。
  • [設定] タブの [書き込み先] デバイスの設定により、追加できるデータ型が異なります。 [書き込み先] デバイスを、各ビットアドレスに対し、ビットデバイスに設定した場合、ブールデータ型を追加し、使用するビットを割り当てます。[書き込み先] デバイスをワードデバイスに設定した場合、[データ型] が設定可能となり、開始アドレスは入力データデバイスアドレスおよびワードのフィールドオフセットとなります。

  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。
  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [設定] タブの [書き込み先] デバイスの設定により、追加可能な [データ型] が異なります。 [書き込み先] デバイス設定をビットデバイスに設定した場合、[データ型] ドロップダウンリストには、[ビット] のみ含まれます。 [書き込み先] デバイスをワードデバイスに設定した場合、[データ型] ドロップダウンリストの選択肢は、[ビット]、[16 ビット整数]、[16 ビット符号無し整数]、[32 ビット整数]、[32 ビット浮動小数点数] および [文字列] となります。
  • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。 [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードになります。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
  • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大入力データ長は 1920 バイトです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大出力データ長は 128 バイトです。 出力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
  • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
  • EasyBuilder に実装されている SLMP は、8 ビットおよび符号なしデータ型をサポートしていません。

  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


[設定] タブを設定するには

SLMP スキャナの [設定] タブを使用して、三菱電機社製シーケンサとの接続を確率するのに必要な通信情報を定義します。

Closed コントローラタイプ

三菱シーケンサのタイプを指定します。選択肢は、 iQ-R/Q/L シリーズ (3E フレーム)、 iQ-F シリーズ (3E フレーム) または FX シリーズ (1E フレーム) です。 デフォルトは、iQ-R/Q/L シリーズ (3E フレーム) です。

注: iQ-F シリーズ (3E フレーム) オプションは、In-Sight 4.x.x ファームウェアを搭載した In-Sight ビジョンシステムではサポートされていません。
Closed IP アドレス

三菱シーケンサの IP アドレスを指定します。 In-Sight ビジョンシステムに接続する、三菱シーケンサの IP アドレスを入力してください。

Closed ポート番号

三菱シーケンサの TCP ポート番号を 10 進数 または 16 進数で定義します (10 進数: 1～65535、16 進数: 1～0xFFFF。デフォルトは、10 進数 = 12288)。

注:
  • この値は、三菱シーケンサの SLMP ポートで設定するポート番号設定と一致する必要があります。
  • [ポート番号] は、In-Sight Explorer を閉じたときに [10 進値] にリセットされます。
Closed タイムアウト (ms)

読み取りおよび書き込み操作のタイムアウト時間 (5～30,000 ミリ秒) を指定します。デフォルトは、1,000 ミリ秒です。

注: このパラメータの設定によっては、ジョブの実行時間が長くなる可能性があります。読み取りおよび書き込み操作に失敗した場合、両方のタイムアウト時間が重なってしまうため、2 倍のタイムアウト時間がジョブに追加されます。

Closed ポーリング間隔 (ms)

三菱シーケンサ上のビジョンコントロールのポール間隔を指定します (5 ～30,000 ms。デフォルトは 1,000 ms)。

Closed リモートステーションに接続
  • [コントローラタイプ] で [iQ-F/R/Q/L シリーズ (3E フレーム)] を選択している場合、このチェックボックスを ON にすると、[ネットワーク番号]、[PC 番号] および [書込み先モジュール] コントロールを有効にします。
  • [コントローラタイプ] で [FX シリーズ (1E フレーム)] を選択している場合、このチェックボックスを ON にすると、[PC 番号] コントロールを有効にします。

デフォルトは、OFF で、In-Sight ビジョンシステムは [IP アドレス] で指定されたイーサネットモジュールを使用して、PLC に直接接続されています。

Closed ネットワーク番号

SLMP スキャナのネットワーク番号 (0～239、デフォルトは 0 = ローカルネットワーク) を指定します。 このコントロールは、[リモートステーションに接続] コントロールが ON の場合のみ、有効になります。

Closed PC 番号 (16 進数)

[書込み先モジュール] で指定したネットワークの識別子を 16 進数で指定します。 このコントロールは、[リモートステーションに接続] コントロールが ON の場合のみ、有効になります。

16 進数 | 説明
0xFF (デフォルト) | ローカルステーションへの直接接続
0x7E | CC-Link IE フィールド上のマスターステーション
0x1～0x78 | CC Link IE フィールドネットワークアダプタ上のステーション。
Closed 書込み先モジュール

接続するデバイスのモジュール識別子を指定します。 このコントロールは、[リモートステーションに接続] コントロールが ON の場合のみ、有効になります。

モジュールタイプ
03ff - ローカルステーション (デフォルト)
0x3d0 - コントロールシステム CPU
0x3d1 - スタンドバイシステム CPU
0x3d2 - システム A CPU
0x3d3 - システム B CPU
0x3e0 - CPU 1
0x3e1 - CPU 2
0x3e2 - CPU 3
0x3e3 - CPU 4
Closed [リセット] ボタン

すべての設定をデフォルト設定にリセットします。

Closed [テスト接続] ボタン

テスト用に、三菱シーケンサとの接続を開始します。


[デバイスのアドレス指定] タブを設定するには (SLMP スキャナ)

SLMP スキャナの [デバイスのアドレス指定] タブを使用して、シーケンサのアドレスや、シーケンサ通信用の各種データブロックのサイズを定義します。 [デバイスタイプ] およびデータブロックサイズは、[設定] タブで定義する、[コントローラタイプ] ([iQ-R/Q/L シリーズ]、[iQ-F シリーズ] または [FX シリーズ]) によって異なります。

Closed 名前

三菱シーケンサと通信するデータブロックの名前です。

Closed 選択中のデバイス

データブロックの読み取り、書き込みに使用する三菱シーケンサデバイスを指定します。 ドロップダウンリストには、次のオプションが含まれています。

iQ-R/Q/L シリーズのデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー* | ビット
Y - 出力リレー* | ビット
M - 内部リレー* | ビット
L - ラッチリレー* | ビット
F - アナンシエータ* | ビット
B - リンクリレー* | ビット
D - データレジスタ | ワード
W - リンクレジスタ | ワード
R - ファイルブロックレジスタ | ワード
ZR - ファイルレジスタ | ワード
*[コントロール] および [ステータス] データブロックでのみサポートされています。

iQ-F シリーズのデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー* | ビット
Y - 出力リレー* | ビット
M - 内部リレー* | ビット
F - アナンシエータ* | ビット
D - データレジスタ | ワード
*[コントロール] および [ステータス] データブロックでのみサポートされています。

FX シリーズ (1E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー* | ビット
Y - 出力リレー* | ビット
M - 内部リレー* | ビット
D - データレジスタ | ワード
R - 拡張レジスタ | ワード
S - ステートリレー* | ビット
*[コントロール] および [ステータス] データブロックでのみサポートされています。

注:
  • [なし] を選択すると、データブロックは通信されません。
  • [タイマ値] および [カウンタ値] デバイスはサポートされていません。
Closed オフセット

データブロックを読み取ったり、書き込んだりするデバイステーブルのオフセット値を定義します。 オフセット値は、[選択中のデバイス] のタイプにより、10 進数、16 進数または 8 進数で入力します。

iQ-R/Q/L シリーズのデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー* | 16 進数
Y - 出力リレー* | 16 進数
M - 内部リレー* | 10 進数
L - ラッチリレー* | 10 進数
F - アナンシエータ* | 10 進数
B - リンクリレー* | 16 進数
D - データレジスタ | 10 進数
W - リンクレジスタ | 16 進数
R - ファイルブロックレジスタ | 10 進数
ZR - ファイルレジスタ | 10 進数
*[コントロール] および [ステータス] データブロックでのみサポートされています。

iQ-F シリーズのデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー* | 8 進数
Y - 出力リレー* | 8 進数
M - 内部リレー* | 10 進数
F - アナンシエータ* | 10 進数
D - データレジスタ | 10 進数
*[コントロール] および [ステータス] データブロックでのみサポートされています。

FX シリーズ (1E フレーム) のデバイスタイプ

デバイスタイプ | フォーマット
X - 入力リレー* | 8 進数
Y - 出力リレー* | 8 進数
M - 内部リレー* | 10 進数
D - データレジスタ | 10 進数
R - 拡張レジスタ | 10 進数
S - ステートリレー* | 10 進数
*[コントロール] および [ステータス] データブロックでのみサポートされています。

Closed デバイス数

三菱シーケンサと通信するデータブロックのサイズを指定します。 サイズは、シーケンサデバイスの単位 (ワードまたはビット) で指定してください。入力ブロック、出力ブロック、コマンドおよびコマンド結果の最大データサイズは、[コントローラタイプ] ([iQ-R/Q/L シリーズ]、[iQ-F シリーズ] または [FX シリーズ]) によって異なります。

ブロック名 | デバイス数
 | iQ-R/Q/L シリーズおよび iQ-F シリーズ | FX シリーズ
コントロール | 32 ビット (読み取り専用)
ステータス | 32 ビット (読み取り専用)
入力ブロック | 4 + 入力データ長 (最大: 960 ワード) | 4 + 入力データ長 (最大: 64 ワード)
出力ブロック | 12 + 出力データ長 (最大: 960 ワード) | 12 + 出力データ長 (最大: 64 ワード)
コマンド | 0 ～ 960 ワード | 0 ～ 64 ワード
コマンド結果 | 0 ～ 960 ワード | 0 ～ 64 ワード

注: iQ-R/Q/L シリーズ は、現在使用可能なほとんどのフレームフォーマットを処理することができます (3E フレーム)。 しかし、FX シリーズ は、第一世代のプロトコルメッセージフレーム (1E フレーム) のみを処理することが可能で、パケット内で通信できるデータ量も限られています。

最大データサイズ

iQ-R/Q/L シリーズおよび iQ-F シリーズ | FX シリーズ
バッチ読み取りビット | 7904 ビット | 256 ビット
バッチ読み取りワード | 960 ワード | 64 ワード
バッチ書き込みビット | 7904 ビット | 160 ビット
バッチ書き込みワード | 690 ワード | 64 ワード
Closed 説明

データブロックの説明。


[フォーマット入力データ] および [フォーマット出力データ] タブを設定するには (SLMP スキャナ)

[設定] および [デバイスのアドレス指定] タブの設定後、[フォーマット入力データ] および [フォーマット出力データ] タブを設定します。これらのタブを使用して、三菱シーケンサと In-Sight ビジョンシステムの間で送受信されるツールまたはジョブデータを定義します。

Closed [フォーマット入力データ] タブを設定するには

[フォーマット入力データ] タブを使用して、In-Sight ビジョンシステムへの入力を指定します。各ジョブに対し、最大 32 までの入力を設定することができます。

  1. [フォーマット入力データ] タブを使用して、In-Sight ビジョンシステムへの入力を指定します。
  2. [追加] ボタンを押し、[入力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよび入力などのジョブデータが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [開始アドレス]、入力の [名前]、[データタイプ]、[サイズ] および [値] がテーブルに表示されます。
  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [データ型] ドロップダウンリストから [文字列] または [バイト変換文字列] を選択すると、[エレメントごとのデータ長 (ワード)] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
  • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードになります。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
  • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 1,920 バイトになります。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。 入力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
  • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
  • EasyBuilder に実装されている SLMP スキャナは、8 ビットデータ型をサポートしていません。

  5. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、バイトオーダをカスタマイズすることができます。デフォルトでは、PROFINET を除き、OFF となります。 [ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、ワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。

    注:バイトオーダまたはワードオーダに関する変更は、[フォーマット出力データ] および [フォーマット入力データ] タブのすべてのデータ符号に影響します。

  6. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。

Closed [フォーマット出力データ] タブを設定するには

[フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムからの出力を指定します。各ジョブに対し、最大 128 までの出力を設定することができます。

  1. [フォーマット出力データ] タブを使用して、In-Sight ビジョンシステムからの出力を指定します。
  2. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータおよびジョブ全体の結果などが含まれています。 In-Sight ビジョンシステムからシーケンサに転送するデータを選択し、[OK] ボタンを押してください。
  3. 追加されたデータの [名前]、[データタイプ]、[サイズ]、[値]、および選択中のデータの [開始アドレス] がテーブルに表示されます。 テーブルの右側は、シーケンサレジスタのデータフォーマットを表示するレジスタプレビューウィンドウです。
  4. [データ型] ドロップダウンリストから、データ型を選択して、デフォルトのデータ型をカスタマイズすることができます。

注:
  • [データ型] ドロップダウンリストから [文字列] または [バイト変換文字列] を選択すると、[エレメントごとのデータ長 (ワード)] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。
  • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大メッセージサイズは 960 ワードになります。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 64 ワードになります。
  • [コントローラタイプ] を [iQ-R/Q/L シリーズ (3E フレーム)] または [iQ-F シリーズ (3E フレーム)] に指定している場合、最大入力データ長は 1920 バイトです。 [コントローラタイプ] を [FX シリーズ (1E フレーム)] に指定している場合、最大メッセージサイズは 128 バイトになります。 出力データサイズは、[メッセージサイズ (バイト)] フィールドに表示されます。
  • [データタイプのリセット] ボタンは、すべての [データタイプ] をデフォルト設定に戻します。
  • EasyBuilder に実装されている SLMP スキャナは、8 ビットデータ型をサポートしていません。

  5. 変更事項は、プレビューウィンドウに更新されます。
  6. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


三菱イーサネットネイティブ文字列ロボット通信を設定するには

個々のツールやジョブの結果などの EasyBuilder ジョブデータを使用して、ロボットコントローラと通信することができます。データを選択し文字列にフォーマットした後、ロボットコンローラは、文字列中のすべてのフォーマットデータを返す、In-Sight ネイティブモードコマンド GetValue (GVJob.Robot.FormatString) を送信してデータを要求することができます。

ネイティブモード通信用にデータを文字列にフォーマットするには、次の手順に従ってください。

注: これらのコントロールを有効にするには、In-Sight ビジョンシステムをオフラインにしてください。

  1. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータや入力データなどの追加ジョブデータが含まれています。
  2. [出力データの選択] ダイアログから、In-Sight ビジョンシステムから送信するデータを選択し、[OK] ボタンを押します。1 個の文字列には、最大 40 までのアイテムを選択することができます。
  3. データを追加したら、リスト中のアイテムを選択し、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。また、[削除] ボタンを押して、不必要なアイテムを削除することができます。
  4. アイテムのデータタイプに [浮動小数点] が含まれる場合、[小数部の桁数] コントロールが有効になります。このコントロールを使用して、浮動小数点の小数点の桁数を設定することができます (0~6、デフォルト = 3)
  5. データリストの右にあるウィンドウに、参照用として、フォーマット文字列および文字列長 (文字列中の文字数) が表示されます。文字列中の値を区切るために、コンマが自動的に挿入されます。
  6. 文字列がフォーマットされた後、ロボットコントローラは In-Sight ネイティブモード コマンド、GetValue (GVJob.Robot.FormatString) を送信して、データ文字列を要求することができます。


三菱シリアルネイティブ文字列ロボット通信を設定するには

個々のツールやジョブの結果などの EasyBuilder ジョブデータを使用して、ロボットコントローラと通信することができます。データを選択し文字列にフォーマットした後、ロボットコンローラは、文字列中のすべてのフォーマットデータを返す、In-Sight ネイティブモードコマンド GetValue (GVJob.Robot.FormatString) を送信してデータを要求することができます。

ネイティブモード通信用にデータを文字列にフォーマットするには、次の手順に従ってください。

注: これらのコントロールを有効にするには、In-Sight ビジョンシステムをオフラインにしてください。

  1. [追加] ボタンを押し、[出力データの選択] ダイアログを開きます。ダイアログには、ジョブに追加された位置決めまたは検査ツール、画像取り込みデータや入力データなどの追加ジョブデータが含まれています。
  2. [出力データの選択] ダイアログから、In-Sight ビジョンシステムから送信するデータを選択し、[OK] ボタンを押します。1 個の文字列には、最大 40 までのアイテムを選択することができます。
  3. データを追加したら、リスト中のアイテムを選択し、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更することができます。また、[削除] ボタンを押して、不必要なアイテムを削除することができます。
  4. アイテムのデータタイプに [浮動小数点] が含まれる場合、[小数部の桁数] コントロールが有効になります。このコントロールを使用して、浮動小数点の小数点の桁数を設定することができます (0~6、デフォルト = 3)
  5. データリストの右にあるウィンドウに、参照用として、フォーマット文字列および文字列長 (文字列中の文字数) が表示されます。文字列中の値を区切るために、コンマが自動的に挿入されます。
  6. 文字列がフォーマットされた後、ロボットコントローラは In-Sight ネイティブモード コマンド、GetValue (GVJob.Robot.FormatString) を送信して、データ文字列を要求することができます。
  7. [シリアルポートの設定] タブをクリックし、シリアルポートを定義してください (必要な場合のみ)。 EasyBuilder は、[デバイスの設定] グループボックスに基づいて、シリアルプロトコルを自動的に検討します。 [通信] ステップから他のステップに移るときに、シリアルポート設定は In-Sight ビジョンシステムに保存されます。
注:

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。


TCP/IP 上で通信するには

In-Sight センサと他の TCP/IP デバイスを接続し、ネットワークを介してデータを共有する TCP/IP クライアントデバイスとして動作するように、In-Sight センサを設定することができます。 TCP/IP 接続が確立したら、EasyBuilder はネットワーク上の他の TCP/IP デバイスと通信を開始することができます。

In-Sight センサを TCP/IP サービスクライアントデバイスとして設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [その他] を選択します。
  3. [プロトコル] ドロップダウンリストから [TCP/IP] を選択します。
  4. [OK] ボタンを押します。
  5. [TCP/IP] タブをダブルクリックし、接続を確定する TCP/IP サービスデバイスの名前を [サーバホスト名] フィールドに入力します。
  6. TCP/IP デバイスとの間で接続を確立する TCP/IP サーバのポート番号を　[ポート] フィールドに入力します。 入力されたポート番号は、サーバにも割り当てる必要があります。

注: 有効なポート番号は、In-Sight の通信に使用されるポートを除く、1～65535　の間の未使用の番号です。 PC のサービスで予約されているポート番号との競合を避けるために、In-Sight エミュレータの設定では、必ず 3000 (デフォルト) 以降のポート番号を割り当ててください。

  7. TCP/IP 接続の確立を試みてから中断するまでの待機時間をミリ秒単位 (100～15000、デフォルト = 1000) で指定します。
  8. [終端記号] ドロップダウンリストから、カスタマ終端記号の文字列を選択して、ASCII 文字 (0～255) を指定します。
Closed カスタマ終端記号文字列
終端記号 | 説明
文字列 CR+LF (デフォルト) | ASCII 文字 13 (キャリッジリターン) と 10 (ラインフィード) が文字列データに追加されます。
文字列 CR (13) | ASCII 文字 13 (キャリッジリターン) が文字列データに追加されます。
文字列 LF (10) | ASCII 文字 10 (ラインフィード) が文字列データに追加されます。
文字列 ヌル文字 (0) | ASCII 文字 0 (ヌル文字) が文字列データに追加されます。
  9. TCP/IP 設定が確立したら、[フォーマット文字列] タブをクリックして、通信されるデータフォーマットを選択します。
注: TCP/IP は「セカンダリ」プロトコルです。「プライマリ」プロトコルと共にジョブも追加することもできます。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


UPD 上で通信するには

In-Sight ビジョンシステムと他の UDP サーバを接続し、ネットワークを介してデータを共有する UDP サーバまたはクライアントデバイスとして動作するように、In-Sight ビジョンシステムを設定することができます。

TCP の代換プロトコルである UDP (ユーザデータグラムプロトコル)は、インターネット上でメッセージを交換する場合に、限られた量のサービスを提供する、コネクションレス通信トランスポート方法です。 TCP とは異なり、UDP は確認応答したり、データを確実に届けたり、シーケンスパケットを提供したりしません。

ビジョンシステムを UDP クライアントデバイスまたはサーバデバイスとして設定するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [その他] を選択します。
  3. [プロトコル] ドロップダウンリストから [UDP] を選択します。
  4. [OK] ボタンを押します。
  5. [UDP の設定] タブを設定したら、必要に応じて、入力文字列およびフォーマット出力文字列を選択します。
Closed [UDP の設定] タブ
Closed モード

In-Sight ビジョンシステムをクライアントまたはサーバとして設定するかどうかを指定します。選択肢は、[クライアント]、[クライアント (応答あり)]、[サーバ]、[サーバ (応答あり) ] で、デフォルトは、[クライアント] です。 UDP 通信のパラダイムでは、クライアントとは、ネットワーク上の他のコンピュータシステム (サーバ) のリモートサービスにアクセスするシステムのことです。一方、サーバとは、他のネットワーク上のデバイスからのデータ要求を処理する、ネットワーク上のデバイスのことです。

  • クライアント: ビジョンシステムは、指定サーバにデータを送信します。
  • クライアント (応答あり): ビジョンシステムは、指定サーバにデータを送信し、[タイムアウト] パラメータで設定した制限時間中、サーバからの応答メッセージを待ちます。
  • サーバ: ビジョンシステムは、指定サーバからデータを受信します。
  • サーバ (応答あり): ビジョンシステムは、指定サーバとしてデータを受信し、クライアントデバイスに確認応答メッセージを送信します。
Closed サーバホスト名

UDP サーバのホスト名または IP アドレスを指定します。 [モード] パラメータが [サーバ] または [サーバ (応答あり)] に設定されていると、このパラメータは無効となります。

Closed ポート

UDP サーバと UDP デバイス間の通信ポート番号を指定します。 In-Sight ビジョンシステムをサーバとして設定し、[サーバホスト名] を指定すると、[ポート] パラメータはデバイスにポート番号を割り当てます。 ビジョンシステムをクライアントとして設定する場合、ポート番号は UDP サーバのポート番号と同一にする必要があります。

Closed タイムアウト

クライアントデバイスからメッセージが送信されたときに、サーバデバイスからの確認応答を受信するまでの時間制限をミリ秒単位で指定します (100～15000、デフォルト = 1000)。

注: [タイムアウト] パラメータは、[モード] パラメータを [クライアント (応答あり)] に設定した場合のみ、有効となります。

Closed [入力文字列] タブ

他のデバイスから EasyBuilder ツールの文字列入力に使用する文字列を指定します。入力文字列には、マッチ文字列 ([検査] ステップの ID コードの読み取り、1D コードの読み取り、1D コードの読み取り (1-20)、2D コードの読み取り、2D コードの読み取り (1-20)、郵便コードの読み取り識別ツール、または文字認識識別ツールで指定します) などがあります。

注: [入力文字列] タブは、[モード] パラメータを [クライアント] に設定した場合、無効となります。

Closed 入力名

ドロップダウンメニューから、入力する EasyBuilder ジョブまたはツールプロパティを選択します。

注: 識別ツールで PLC または PC などの外部デバイスから文字列を入力するには、トピック「識別ツールにデータを入力するには」をご参照ください。

Closed フォーマット出力文字列

[モード] パラメータを [クライアント]、[クライアント (応答あり)]、または [サーバ (応答あり)] に設定したときに、UDP サーバに送信するデータを指定します。

注: [フォーマット出力文字列] タブは、[モード] パラメータを [サーバ] に設定した場合、無効となります。

Closed カスタムフォーマット
  1. [フォーマット出力文字列] タブから、[カスタムフォーマット] ボタンをクリックして、[FormatString] ダイアログ開きます。このダイアログを使用して、ロボットに送信されるデータを追加したり、カスタマイズしたり、データの順番を変更したりすることができます。
  2. ダイアログの [追加] ボタンを押して、[出力データの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。 In-Sight センサから送信するデータをダイアログから選択したら、[OK] ボタンを押します。
  4. [FormatString] ダイアログが再び表示されます。
  5. 文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更したりすることができます。 文字列の変更を終了したら、[OK] ボタンを押します。
  6. 文字列がフォーマットされたら、ジョブの終了後に、出力データを送信するようになります。
注: UDP は「セカンダリ」プロトコルです。「プライマリ」プロトコルと共にジョブも追加することもできます。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


POWERLINK 上で通信するには

POWERLINK ネットワークと通信するように、In-Sight ビジョンシステムを設定することができます。

POWERLINK と通信するには、次の手順に従ってください。

  1. [通信] アプリケーションステップを開きます。 [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [PLC] を選択します。
  3. [メーカー] ドロップダウンリストから [B&R] を選択します。
  4. [プロトコル] ドロップダウンリストから [POWERLINK] を選択します。
  5. [OK] ボタンを押します。

[通信] グループボックスの設定後、[設定]、[フォーマット入力データ] および [フォーマット出力データ] タブを設定してください。

  • Closed [POWERLINK の設定] ダイアログ

    有効: In-Sight ビジョンシステム上で POWERLINK を有効にします (デフォルト = OFF)。

    ノード ID: POWERLINK ネットワーク上の In-Sight ビジョンシステムのノード ID (1～239、デフォルト = 1) を定義します。 このコントロールは、[有効] チェックボックスが ON の場合のみ、有効になります。 ノード ID を POWERLINK ネットワークの NAT IP アドレスと共に使用することによって、POWERLINK ネットワーク外のデバイスと通信することができます。 例えば、デフォルトの NAT IP アドレスは 192.168.101.0 です。 ノード ID が 26 である In-Sight ビジョンシステムと通信するには、NAT IP アドレスをノード ID と結合し、192.168.101.26 とします。

    注: POWERLINK プロトコルを有効にするには、In-Sight ビジョンシステムを再起動する必要があります。

  • フォーマット入力/出力タブ
注:
  • ビジョンシステム上の POWERLINK 設定の詳細については、In-Sight Explorer ヘルプの POWERLINK トピックをご参照ください。
  • オプションで、[デバイスの追加] ボタンをクリックして「セカンダリ」プロトコルをジョブに追加します。 詳細については、デバイスの設定の『サポートしているプロトコル』をご参照ください。


識別ツールにデータを入力するには

PLC や PC などの外部デバイスから識別ツールに文字列を入力するには、次の手順に従ってください。

  1. [検査] ステップで、ID コードの読み取り、1D コードの読み取り、1D コードの読み取り (1-20)、2D コードの読み取り、2D コードの読み取り (1-20)、郵便コードの読み取り識別ツール、または文字認識識別ツールを追加します。
  2. ID コードの読み取り、1D コードの読み取り、1D コードの読み取り (1-20)、2D コードの読み取り、2D コードの読み取り (1-20)、郵便コードの読み取り識別ツールでは、[設定] タブの [モード] を [マッチ文字列] に設定します。文字認識ツールでは、[設定] タブの[モード] を [照合] または [認識と照合] に設定します。
  3. [通信] アプリケーションステップをクリックします。
  4. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  5. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから [その他] を選択します。
  6. [プロトコル] ドロップダウンリストから [シリアルテキスト] を選択します。
  7. [OK] ボタンを押します。
  8. [入力文字列] タブをクリックします。
  9. [入力名] ドロップダウンリストから、マッチ文字列の結果を選択します。 EasyBuilder は自動的にジョブを検査し、定義済みツールのマッチ文字列をメニューに表示します。
  10. [シリアルポートの設定] タブをクリックし、アプリケーションに合わせて設定を調整します (必要な場合のみ)。
注:

  • [シリアルポート設定] オプションは、In-Sight モデルおよび I/O モジュールによって異なります。サポートしている I/O モジュールに接続している場合、[I/O モジュール] ボタンをクリックし、[I/O モジュールの設定] ダイアログを開いて、I/O モジュールを設定します。

  • In-Sight Micro 1000 シリーズビジョンシステムは、CIO-MICRO または CIO-MICRO-CC I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • In-Sight 70xx - 74xx シリーズ上でシリアル通信を有効にするには、ブレークアウトケーブルを使用するか、CIO-MICRO または CIO-MICRO-CC I/O モジュールを使用します。 ブレークアウトケーブルに接続している場合 (I/O モジュールに接続されていない場合)、ディスクリート入出力ライン (各 1) をシリアル受信およびシリアル送信に設定することができます。 詳細については、In-Sight 70xx - 74xx ビジョンシステムのシリアル通信を有効にするにはをご参照ください。
  • In-Sight Micro 8000 シリーズビジョンシステムは、CIO-MICRO I/O モジュールに接続している場合のみ、シリアル通信をサポートします。

  • CIO-WENET I/O モジュールは、シリアル通信をサポートしません。
  11. [フォーマット出力文字列] タブをクリックし、[カスタムフォーマット] ボタンを押します。[FormatString] ダイアログから、ツールの結果を選択し、フォーマットします。

注: 外部デバイスからマッチ文字列が入力されるまで、ID コードの読み取りツールまたは文字認識ツールの結果は FAIL となり、マッチ文字列フィールドは TRIG を表示します。

  12. ダイアログの [追加] ボタンを押して、[出力データの選択] ダイアログを開きます。
  13. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。 In-Sight センサから送信するデータをダイアログから選択したら、[OK] ボタンを押します。
  14. [FormatString] ダイアログが再び表示されます。
  15. 文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更したりすることができます。 文字列の変更を終了したら、[OK] ボタンを押します。
  16. 文字列がフォーマットされたら、ジョブの終了後に、出力データを送信するようになります。
  17. In-Sight センサをオンラインにすると、ツールは入力文字列を受信し、文字列の読み取りまたは照合を試みます。


出力文字列をフォーマットするには

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[その他] を選択します。
  3. [プロトコル] ドロップダウンリストから、[イーサネットネイティブ]、[シリアルネイティブ]、[シリアルテキスト] または [TCP/IP] を選択します。
  4. [フォーマット出力文字列] タブから、[カスタムフォーマット] ボタンをクリックして、[FormatString] ダイアログ開きます。このダイアログを使用して、ロボットに送信されるデータを追加したり、カスタマイズしたり、データの順番を変更したりすることができます。
  5. ダイアログの [追加] ボタンを押して、[出力データの選択] ダイアログを開きます。
  6. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータおよびジョブ全体の結果が含まれています。In-Sight センサから送信するデータをダイアログから選択したら、[OK] ボタンを押します。
  7. [FormatString] ダイアログが再び表示されます。
  8. 文字列を変更したり、[上へ] または [下へ] ボタンを押して、送信されるデータの順番を変更したりすることができます。文字列の変更を終了したら、 [OK] ボタンを押します。
  9. 文字列がフォーマットされたら、ジョブの終了後に、出力データを送信するようになります。


Rockwell ControlLogix PLC と通信するには

ここでは、In-Sight 2000 ビジョンシステムと ControlLogix または CompactLogix PLC の間で、 EtherNet/IP ネットワークを介し、Rockwell RSLogix 5000 ソフトウェアを使用してデータ送受信を行う方法を説明します。

ステップ 1: RSLogix の IO Structure で、In-Sight ビジョンシステムを設定するには

ステップ 2: In-Sight 2000 ビジョンシステムを PLC 通信用に設定するには


RSLogix の IO Structure で、In-Sight ビジョンシステムを設定するには

RSLogix 5000 との統合

非明示的接続およびデータ送受信を設定する手順は、ビジョンセンサにインストールされているファームウェアバージョンおよび RSLogix 5000 ソフトウェアのバージョンによって異なります。

詳細については、[Communicate with a Rockwell ControlLogix PLC] トピックをご参照ください。


In-Sight ビジョンシステムを RSLogix 5000 v14-16 に統合するには

このトピックでは、In-Sight 5.2.0 以降のファームウェアを搭載する In-Sight ビジョンシステムを、バージョン 20 以降の RSLogix 5000 に統合する方法について説明します。 RSLogix 5000 のこれらのバージョンは EDS ファイルをサポートしていないため、汎用の ETHERNET-MODULE を使用する必要があります。 In-Sight Explorer には、.L5X ファイルが含まれています。このファイルは、PLC コントローラのタグデータとユーザフレンドリーなプログラムタグの間でコピーすることができ、In-Sight 5.2.x 以降のファームウェアを搭載するビジョンセンサの信号を示します。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. Ethernet Communications Card に接続を追加します。 [I/O Configuration] ノードで、Ethernet Module の下にある [Ethernet] ノードを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  3. [Catalog] タブの [Select Module Type] ダイアログから、Communication Module Type Category Filter、Allen-Bradley を Module Type Vendor Filter として選択し、更に ETHERNET-MODULE (Generic Ethernet Module) を選択してから、[Create] ボタンを押します。

  4. [New Module] ダイアログに以下を入力します。

    • In-Sight vision センサの名前および IP アドレス。
    • 接続パラメータ。 5.x.x ファームウェアを搭載する In-Sight ビジョンセンサでは、アセンブリインスタンスを定義する入出力アセンブリオブジェクトを設定する必要があります。

  5. ビジョンセンサを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造データを作成することができます。 [Main Routine] にアクセスします ([Controller Organizer] ペインの [Tasks] > [Main Task] > [Main Program])。

    注: ラダープログラムを新規作成する場合、空のラング 0 を使用することができます。 ビジョンセンサを既存のプログラムに統合する場合、他のラダーを実行する前に、更新されたデータがセンサの入出力アセンブリに読み取りまたは書き込みされるよう、ラングをラダーの一番上に追加することを推奨します。

    1. メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。

    2. .L5X ファイルを選択します。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      InSightGenEth_11_CopyRung.L5X ファイルをインポートします。 ファイルを選択したら、 [Import...] をクリックします。

  6. [Import Configuration] を使用して、作成されたタグの名前を、構成と一致するように変更します。 ジェネリックモジュールは、モジュールへの入出力用に、未処理の非構造データからなる単一アレイを作成します。 Input アセンブリは、Status ブロックと Inspection Results アレイから構成される、1 つの連続した配列となります。 Output アセンブリは、Control ブロックと User Data アレイから構成される、連続した配列となります。 両者とも識別タグは付いていません。

    プロジェクトが PLC にダウンロードされ、コピー命令付きのラングが初めて実行されると、タグを含む 2 つの新しいアレイが作成されます。

    1. ジェネリックな名前がついているタグの名前を変更する必要があります。 X マークの付いている上の 2 ラインの名前を変更します。

    2. [Name] フィールドの空白をクリックすると矢印が表示され、デフォルトの [Name] 構造の変更オプションがドロップダウンに表示されます。 リストには、ステップ 4 で指定した名前と一致する名前が含まれています (In-Sight ビジョンセンサの名前。この例では、In-Sight 2000 と指定されたため、リストに表示される名前は、In-Sight 2000:I および In-Sight 2000:O)。

      これらのジェネリックな名前を、ドロップダウンのオプションと置き換えます。

    3. 下 2 ラインも同様に編集する必要があります。 名前をクリックするとカーソルアイコンが表示されます。 "_In" および "_Out" の前のテキストを、ジェネリックモジュール名あるいは簡単に識別できる名前に置き換えます (この例では、1 台のビジョンセンサのみなので、"In-Sight 2000")。

      注: このインスタンスでは、I/O 構成に追加された各ビジョンセンサに、固有の名前が付ける必要があります。 複数のセンサを配置する場合は、作成されるコピーラングの各インスタンスが特定のセンサを指定するため、各センサごとに、これらの手順を実行する必要があります。 トラブルシューティングのためにも、簡単に識別できる名前を使用してください。

    4. すべてタグ名をデフォルト値から変更したら、[OK] ボタンを押してください。

  7. 追加したラングの下の Main Routine に新しいラングが追加されました (空のラングは削除可能です)。

  8. プロジェクトを PLC にダウンロードし、Run Mode にしてください。

  9. コピー命令付きのラングの実行後、新規タグが [Controller Tags] テーブルに作成されます 。

    この例では、In-Sight 2000:I および In-Sight 2000:O はビジョンセンサからの未処理の入出力アセンブリで、 In-Sight 2000_In および In-Sight 2000_Out は Control および Status ブロック、さらに UserData および InspectionResults アレイを含みます。


In-Sight ビジョンシステムを RSLogix 5000 v17-19 に統合するには

このトピックでは、In-Sight 5.2.0 以降のファームウェアを搭載する In-Sight 2000 ビジョンシステムを、バージョン 14-16 の RSLogix 5000 に統合する方法について説明します。 RSLogix 5000 のこれらのバージョンは EDS ファイルをサポートしていないため、汎用の ETHERNET-MODULE を使用する必要があります。 In-Sight Explorer には、.L5X ファイルが含まれています。このファイルは、PLC コントローラのタグデータとユーザフレンドリーなプログラムタグの間でコピーすることができ、In-Sight 5.2.x 以降のファームウェアを搭載するビジョンセンサの信号を示します。

  1. RSLogix 5000 を開き、PLC のプロジェクトをロードします。

    注: RSLogix 5000 に接続を追加するには、PLC がオフラインである必要があります。

  2. Ethernet Communications Card に接続を追加します。 [I/O Configuration] ノードで、Ethernet Module の下にある [Ethernet] ノードを選択し、アイコンを右クリックして、メニューから [New Module] を選択します。

  3. [Catalog] タブの [Select Module Type] ダイアログから、Communication Module Type Category Filter、Allen-Bradley を Module Type Vendor Filter として選択し、更に ETHERNET-MODULE (Generic Ethernet Module) を選択してから、[Create] ボタンを押します。

  4. [New Module] ダイアログに以下を入力します。

    • In-Sight vision センサの名前および IP アドレス。
    • 接続パラメータ。 5.x.x ファームウェアを搭載する In-Sight ビジョンセンサでは、アセンブリインスタンスを定義する入出力アセンブリオブジェクトを設定する必要があります。

  5. ビジョンセンサを RSLogix プロジェクトに追加後、L5X ラングインポートファイルを使用して、接続用の構造データを作成することができます。 [Main Routine] にアクセスします ([Controller Organizer] ペインの [Tasks] > [Main Task] > [Main Program])。

    注: ラダープログラムを新規作成する場合、空のラング 0 を使用することができます。 ビジョンセンサを既存のプログラムに統合する場合、他のラダーを実行する前に、更新されたデータがセンサの入出力アセンブリに読み取りまたは書き込みされるよう、ラングをラダーの一番上に追加することを推奨します。

    1. メインプログラム内で、空のラングを右クリックし、[Import Rungs...] オプションを選択します。

    2. .L5X ファイルを選択します。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\RSLogix

      InSightGenEth_11_CopyRung.L5X ファイルをインポートします。 ファイルを選択したら、 [Import...] をクリックします。

  6. [Import Configuration] を使用して、作成されたタグの名前を、構成と一致するように変更します。 ジェネリックモジュールは、モジュールへの入出力用に、未処理の非構造データからなる単一アレイを作成します。 Input アセンブリは、Status ブロックと Inspection Results アレイから構成される、1 つの連続した配列となります。 Output アセンブリは、Control ブロックと User Data アレイから構成される、連続した配列となります。 両者とも識別タグは付いていません。

    プロジェクトが PLC にダウンロードされ、コピー命令付きのラングが初めて実行されると、タグを含む 2 つの新しいアレイが作成されます。

    1. ジェネリックな名前がついているタグの名前を変更する必要があります。 X マークの付いている上の 2 ラインの名前を変更します。

      [Name] フィールドの空白をクリックすると矢印が表示され、デフォルトの [Name] 構造の変更オプションがドロップダウンに表示されます。 リストには、ステップ 4 で指定した名前と一致する名前が含まれています (In-Sight ビジョンセンサの名前。この例では、In-Sight 2000 と指定されたため、リストに表示される名前は、In-Sight 2000:I および In-Sight 2000:O)。

      これらのジェネリックな名前を、ドロップダウンのオプションと置き換えます。

    2. 下 2 ラインも同様に編集する必要があります。 名前をクリックするとカーソルアイコンが表示されます。 "_In" および "_Out" の前のテキストを、ジェネリックモジュール名あるいは簡単に識別できる名前に置き換えます (この例では、1 台のビジョンセンサのみなので、"In-Sight 2000")。

      3. 注: このインスタンスでは、I/O 構成に追加された各ビジョンセンサに、固有の名前が付ける必要があります。 複数のセンサを配置する場合は、作成されるコピーラングの各インスタンスが特定のセンサを指定するため、各センサごとに、これらの手順を実行する必要があります。 トラブルシューティングのためにも、簡単に識別できる名前を使用してください。

    3. デフォルトのタグ名を変更したら、タグがどこに作成されたのか識別する必要があります。 タグを [Controller Tag] テーブルに置くには、空のボックスを右クリックし、[Toggle Tag Scope] を選択します。

    4. すべてタグ名をデフォルト値から変更したら、[OK] ボタンを押してください。

  7. 追加したラングの下の Main Routine に新しいラングが追加されました (空のラングは削除可能です)。

  8. プロジェクトを PLC にダウンロードし、Run Mode にしてください。

  9. コピー命令付きのラングの実行後、新規タグが [Controller Tags] テーブルに作成されます 。

    この例では、In-Sight 2000:I および In-Sight 2000:O はビジョンセンサからの未処理の入出力アセンブリで、 In-Sight 2000_In および In-Sight 2000_Out は Control および Status ブロック、さらに UserData および InspectionResults アレイを含みます。


In-Sight ビジョンシステムを RSLogix 5000 v20 に統合するには

このトピックでは、In-Sight 5.2.0 以降のファームウェアを搭載する In-Sight 2000 ビジョンシステムを、バージョン 20 以降の RSLogix 5000 に統合する方法について説明します。 EDS ファイルは、バージョン 20 以降の RSLogix 5000 でサポートされています。 In-Sight Explorer には、.L5X ファイルが含まれています。このファイルは、In-Sight 5.2.x 以降のファームウェアを搭載するビジョンセンサの信号が表示するタグデータを、使いやすいプログラムタグに置きかえます。 InSight_11_CopyRung.L5X ファイルは、 5.x ファームウェアを搭載しているセンサに使用されます。

  1. EDS モジュールを RSlogix5000 に作成・追加します。

    1. EDS ファイルは、Insight Explorer ソフトウェアとともに、以下のディレクトリにインストールされます。C:\Program Files (x86)\Cognex\In-Sight\In-Sight Explorer 5.x.x\Factory Protocol Description\EDS
    2. RSLogix5000 の [Tools] ドロップダウンメニューから、EDS インストールツールを実行し、In-Sight 2000 用の EDS ファイルをインストールします。
    3. RSLogix5000 の [IO Configuration] セクションのネットワークノードを右クリックして、[New Module] メニューを選択します。

    4. [Select Module] ダイアログの [Communications] ノードを開きます。リストから In-Sight 2000-xxx を選択して OK をクリックします。

      [New Module] ダイアログが開きます。

      ビジョンセンサの名前、IP アドレスおよび接続パラメータを上に示す通りに入力します。 2 台以上のビジョンセンサが接続されている場合、各センサには固有の名前が必要です。 この例では、1 台のビジョンセンサのみを設定します。

      ヒント: ビジョンセンサが搭載するファームウェアバージョンに対応する EtherNet/IP オブジェクトモデル (入出力アセンブリビット) については、『In-Sight Explorer ヘルプ』ファイルをご参照ください。

  2. ラングのインポート

    1. [Main Routine] にアクセスします ([Controller Organizer] ペインの [Tasks] > [Main Task] > [Main Program])。 ラダープログラムを新規作成する場合、空のラング 0 を使用することができます。 ビジョンセンサを既存のプログラムに統合する場合、他のラダーを実行する前に、更新されたデータがセンサの入出力アセンブリに読み取りまたは書き込みされるよう、ラングをラダーの一番上に追加することを推奨します。

    2. ラダーの一番上にある空のラングをライトクリックし、メニューから [Import Rung] を選択します。

    3. [Import Rung] ダイアログで、インポートするラングファイル 2 個が含まれるフォルダロケーションまでナビゲートします。 In-Sight 2000 は 5.x ファームウェアを使用しているので、InSight_11_CopyRung.L5X ファイルを使用します。

    4. 適切なファイルを選択したら、[Import] ボタンをクリックします。

    5. [Import Configuration] ダイアログが開きます。タグ作成には、ジェネリックな名前が使用されています。

  3. タグ名の変更: ジェネリックモジュールは、モジュールへの入出力用に、未処理の非構造化データからなる単一アレイを作成します。 この例では、ジェネリックモジュールは In-Sight 2000:I、In-Sight 2000:0、および In-Sight 2000:C (未使用) を作成しました。 Input アセンブリは、Status ブロックと Inspection Results アレイで構成される 1 つの連続した配列となり、Output アセンブリは、Control ブロックと User Data アレイで構成された連続した配列となります。両者とも、識別タグは付いていません。 プロジェクトが PLC にダウンロードされ、コピー命令付きのラングが初めて実行されると、タグを含む 2 つの新しいアレイが作成されます (アドオン・プロファイル・モジュールが使用可能な場合に表示されるタグと同じです)。

    1. 左にフラグのついた下 2 ラインの、[Name] フィールドの空白をクリックして編集してください。 これらのタグには、In-Sight の I/O アセンブリの未処理の非構造化データが含まれています。 スペースをクリックすると、下向きの矢印が表示されます。

    2. 矢印をクリックすると、デフォルト名の変更オプションがドロップダウンに表示されます。 ここでは、ジェネリックモジュールの名前にマッチする名前が表示されています。 この例では、ジェネリックモジュールの名前が In-Sight 2000 なので、“In-Sight 2000:I” および “In-Sight 2000:O” がリストに表示されています。 両ラインを、ジェネリックモジュールの名前とマッチ/対応する名前に変更します。 注: In-Sight 2000:C は使用されていません。

    3. 次に、[Import Configuration] の上 2 ラインを編集します。 名前のテキストをクリックすると、カーソルが表示されます。 “_In” および “_Out” の前のすべての文字をジェネリックモジュールの名前に置き換えるか、あるいは簡単に識別できる名前に置き換えることを推奨します。 この例では 1 台のビジョンセンサのみを使用しているため、“In-Sight 2000” を使用します。

    4. デフォルトのタグ名がすべて変更されたため、タグがどこに作成されたのか識別する必要があります。 このステップをスキップすると、[Main Routine] の上にある [Program Tag] テーブルに新規タグが置かれることになります。

      タグを [Controller Tag] テーブルに置くには、AOP がある場合と同様に、コントローラカードアイコンのない [Import Names] 横の空のボックスを右クリックします。 これらのボックスは、次のスクリーンショットでハイライトされています。 ボックスを右クリックすると、ドロップダウンメニューが開き、[Toggle Tag Scope] を選択することができます。 選択後、コントローラカードアイコンがこれらのボックスに表示されます。

    5. すべての名前をデフォルト値から変更したら、OK ボタンを押します。

      6. ヒント: In-Sight 2000_In および In-Sight 2000_Out の名前は、I/O 構成に追加された各ビジョンセンサに固有の名前が付けられているのであれば、どのような名前でも構いません。 複数のセンサを配置する場合は、作成されるコピーラングの各インスタンスが特定のセンサを指定するため、各センサごとに、これらの手順を実行する必要があります。 したがって、将来のトラブルシューティングを容易にし、混乱を避けるため、名前を選択するときは注意が必要です。 例えば、2 台以上のセンサが配置されている場合、センサの名前は、“Line_One_In-Sight 2000_In” および “Line_One_In-Sight 2000_Out" とすることができます。

    6. 新しい、空のラングが [Main Routine] に追加されます。 このラングは削除できます。

  4. PLC へのダウンロード

    1. プロジェクトを PLC にダウンロードします。

    2. PLC を Run Mode にします。 コピー命令付きのラングの実行後、新規タグが [Program Tags] テーブルに作成されます (アド・オン・プロファイルがある場合、同様のことが起こります)。

      この例では、次のテーブルに示されるように、In-Sight 2000:I および In-Sight 2000:O はビジョンセンサからの未処理の入出力アセンブリで、 MyCamera_In および MyCamera_Out は Control および Status ブロック、さらに UserData および InspectionResults アレイが含まれます。


In-Sight ビジョンシステムの入出力アセンブリオブジェクト

詳細については、『EtherNet/IP Object Model and Input/Output Assembly Objects - In-Sight 5.x.x Firmware』 トピックをご参照ください。


In-Sight ビジョンシステムを PLC 通信用に設定するには

PLC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。

設定後、次の操作が実行できるようになります。

  • EtherNet/IP 上でトリガするには
  • In-Sight ビジョンシステムからデータを取得するには
  • In-Sight ビジョンシステムにデータを送信するには


EtherNet/IP 上でトリガするには

EtherNet/IP 上でトリガするよう、In-Sight 2000 ビジョンセンサを設定するには、次の手順に従ってください。

  1. ビジョンセンサにログオンします。
  2. [画像の設定] ステップで、[トリガ] を [産業用イーサネット] に設定します。

  3. [通信] ステップで、次の設定を行います。

    1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
    2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
    3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
    4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
    5. [OK] ボタンを押します。

  4. In-Sight ビジョンセンサをオンラインにします。

  5. PLC の I/O アセンブリタグで、Trigger Enable ビットをハイ(High) に設定し、Trigger ビットハイ(High) をトリガに設定します (参照されているビットは黄色でハイライトされます)。


Add-On プロファイルを使用して接続を確立するには

詳細については、[Add-On プロファイルを使用して接続を確立するには] トピックをご参照ください。

すでにビジョンシステムが EDS ファイルを使用して RSLogix プロジェクトに設定されている場合、新しい AOP プロファイルで EDS プロファイルを更新することができます。 詳細については、[新しい Add-On プロファイルを使用して以前にインストールした EDS プロファイルを更新するには] トピックをご参照ください。


In-Sight 2000 ビジョンセンサからデータを取得するには

In-Sight ビジョンシステムからデータを取得するには

PLC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。

通信用にデータを設定します。

各ツールの結果またはジョブ全体の結果 (出力のみ) といった、EasyBuilder ジョブのデータを Ethernet/IP 上で取得することができます。 入力データはセンサが画像を取得した後に読み込まれ、出力データはセンサがジョブ実行を完了した後に送信されます。

  6. [フォーマット入力データ] または [フォーマット出力データ] タブをクリックします。
  7. [追加] ボタンを押し、[入力データの選択] または [出力データの選択] ダイアログを開きます。
  8. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 In-Sight センサから送信 (または受信) するデータを選択し、[OK] ボタンを押してください。
  9. データを追加したら、[データ型] ドロップダウンリストを使用して、デフォルトのデータタイプを変更することができます。

    10. 注:[データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。

  10. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
  11. In-Sight ビジョンセンサをオンラインにします。
  12. システムをトリガします。

  13. データが、RSLogix 5000 のController -> Program Tags ノードに表示されます。


In-Sight 2000 ビジョンセンサにデータを送信するには

In-Sight ビジョンシステムにデータを送信するには

PLC と通信するには、次の手順に従ってください。

  1. [通信] グループボックスの [デバイスの追加] ボタンを押します。
  2. [デバイスの設定] グループボックスの [デバイス] ドロップダウンリストから、[PLC/モーションコントローラ] を選択します。
  3. [メーカー] ドロップダウンリストから、PLC/MC のメーカーを選択します。 メーカー名がリストにない場合は、[その他] を選択します。
  4. [プロトコル] ドロップダウンリストから、通信プロトコルを選択します。 選択したメーカーが使用する通信プロトコルがリストに表示されます。
  5. [OK] ボタンを押します。

各ツールの結果またはジョブ全体の結果 (出力のみ) といった、EasyBuilder ジョブのデータを Ethernet/IP 上で取得することができます。 入力データはセンサが画像を取得した後に読み込まれ、出力データはセンサがジョブ実行を完了した後に送信されます。

データをフォーマットするには、次の手順に従ってください。

  1. [フォーマット入力データ] または [フォーマット出力データ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] または [出力データの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 In-Sight センサから送信 (または受信) するデータを選択し、[OK] ボタンを押してください。
  4. データを追加したら、[データ型] ドロップダウンリストを使用して、デフォルトのデータタイプを変更することができます。

    5. 注:[データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのデータ長 (ワード) ] コントロールが有効となり、ワード数を選択して文字列長を指定することができます。

  5. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。
  6. In-Sight ビジョンセンサをオンラインにします。
  7. RSLogix 5000 で、[Program Tags] ダイアログを開き、InSight_Top:O.Data[1] および InSight_Top:O.Data[2] タグの値を変更します。

  8. ユーザデータハンドシェイクが必要かどうかを判断します。 ユーザデータバイパスが有効になっている場合、データエクスチェンジは 4.x.x カメラと同じ動きをします。 ユーザデータバイパスが無効になっている場合 (デフォルト状態)、新ビットにより PLC と In-Sight ビジョンセンサの間のデータエクスチェンジに、新たなハンドシェイクが追加されます。 スプレッドシートにデータを表示するには、追加の手順を実行する必要があります。

    1. [ネットワークの設定] ダイアログの [ユーザデータバイパスの有効化] が ON になっている場合、EasyBuilder 上の値はすぐに更新されます。

    2. [ネットワークの設定] ダイアログの [ユーザデータバイパスの有効化] が ON になっていない場合、

      1. ユーザーデータタグを設定します。SetUserDataビットは名前付きタグです。この例では、InSight_Top：O.Control.SetUserDataとなります。
      2. User Data Ack ビットを受信すると、上記の User Data タグをクリアします。 SetUserDataAck ビットは名前付きタグで、この例では InSIght_Top：I.Status となります。 SetUserDataAck。


In-Sight 2000 ビジョンシステムに RSLogix PLC からジョブをロードするには

詳細については、[Implicit Job Load Example From RSLogix PLC] トピックをご参照ください。


フィルムストリップ

[フィルムストリップ] ステップを使用して、PC に保存してある画像を再生したり、ビジョンシステムに保存した画像と結果を確認したりすることができます。PC のフィルムストリップは、一般的に、PC 接続時に一時的なセットアップをしたり、既知の PASS および FAIL 画像をモニタリングするのに使用されます。センサのフィルムストリップは、一般的に、ジョブ実行時のモニタリングおよびデバックに使用されます。フィルムストリップについての詳細については、ここをクリックしてください。

  • PC の設定
  • センサの設定

注: フィルムストリップが表示されていない場合、[表示] メニューの [フィルムストリップ] を選択するか、EasyBuilder ツールバーのフィルムストリップボタン [image] をクリックしてください。


センサの設定

ビジョンセンサオンライン時に画像を取り込む場合に、センサのフィルムストリップを使用してジョブのパフォーマンスをモニタすることができます。 画像が取得されると、取り込んだ画像および付随するジョブデータを含む、ジョブの結果がビジョンシステムの RAM に保存されます。 結果がビジョンシステムに保存されると、PASS または FAIL 画像がフィルムストリップに追加されます。 最大 20 の結果を保存することができますが、その数はビジョンシステムの解像度および RAM 空き容量によります。

例: オンラインのビジョンシステムからフィルムストリップの結果をモニタ

Closed センサを設定するには

注: フィルムストリップを有効にすると、ジョブの実行時間が長くなります。 このことが問題にならないかをご確認ください。問題となる場合、[キュー] ドロップダウンメニューから [無効] を選択してください。

[センサの設定] グループボックスでは、センサのフィルムストリップを設定することができます。

Closed [キュー]

保存する結果を指定します。選択肢は、[無効] (結果を保存しません) 、[成功結果]、[失敗結果]、[成功/失敗結果]、または[成功/失敗結果を分ける] です。 デフォルトは、[無効] です。

注:
  • [成功/失敗結果を分ける] が選択されている場合、
    • [キューのサイズ] ドロップダウンは OFF となります。
    • [PASS サイズ] および [FAIL サイズ] ドロップダウンは ON となります。
    • 成功結果および失敗結果ボタンがフィルムストリップの隣に表示されます。これらのボタンをクリックして、フィルムストリップの PASS/FAIL 結果表示を切り替えることができます。

Closed [キューのサイズ]

保存する結果の数を指定します。 最大 20 の結果を保存することができますが、その数はビジョンシステムの解像度および RAM 空き容量によります。 指定されたキューのサイズがセンサの空き RAM 容量を超える場合、保存可能な最大結果数が自動的にセンサに割り当てられます。

注: このオプションは、[成功/失敗結果を分ける] が [キュー] ドロップダウンから選択されている場合、OFF となります。

Closed PASS サイズ

ビジョンシステムに保存される成功結果の数。 [PASS サイズ] および [FAIL サイズ] の総計は、ビジョンシステムがサポートする [キュー] サイズを超過することはできません。 [キュー] ドロップダウンから、[成功/失敗結果を分ける] が選択されている場合のみ、このオプションは有効になります。(最小 = 1)

Closed FAIL サイズ

ビジョンシステムに保存される失敗結果の数。 [PASS サイズ] および [FAIL サイズ] の総計は、ビジョンシステムがサポートする [キュー] サイズを超過することはできません。 [キュー] ドロップダウンから、[成功/失敗結果を分ける] が選択されている場合のみ、このオプションは有効になります。(最小 = 1)

Closed [キューのタイプ]

[最初のみ] または [最後] の X 個の結果を保存するか指定します。X 個 = [キューのサイズ]。 デフォルトは、[最後] です。

Closed [オンラインモードへの切り替え時にクリアする]

ON の場合 (デフォルト) 、センサがオンラインになるたびにキューをクリアします。

Closed [表示モード]

FAIL の結果を受け取ったときのフォルムストリップの動作を指定します。選択肢は、[失敗時に停止]、[失敗時に一時停止]、または何もしない ([ノーマル]) です。 デフォルトは、[ノーマル] です。

Closed [表示停止時間]

[表示モード] で [失敗時に一時停止] を選択した場合に、一時停止の時間を秒単位で指定します。 (1–120、デフォルト = 5)

Closed [LED スタイル]

フィルムストリップの PASS/FAIL 結果を図形で表示します。(緑の円 [image] および赤の四角 [image])。緑の OK [image] および赤の NG [image] 、または緑のチェックマーク [image] および赤の X [image] 。

Closed [保存フォルダ]

フィルムストリップ画像を保存するロケーションを指定します。 書き込み権限が必要です。

Closed センサから結果をモニタするには

フィルムストリップは、ジョブパフォーマンスのモニタ用 (オンライン時) として、または確認用 (オンライン/オフライン時) として使用することができます。

  1. EasyBuilder ツールバーのオンラインボタン [image] をクリックし、ビジョンシステムをオンラインにします。
  2. ビジョンシステム上で画像取り込みをトリガします。 画像が取り込まれると、[センサの設定] グループボックスで指定した [キュー] の設定に基づいて、画像はビジョンシステムに保存され、フィルムストリップに表示されます。
  3. PASS/FAIL 結果を示すステータスグラフィックスが更新され、表示されます。 次の場合、ビジョンシステムはオンラインのままですが、フィルムストリップは更新を停止し、「フリーズ」モードになります (画像ペイン上部の黄色のバーで表示されます)。
    • [表示モード] で [失敗時に停止] または [失敗時に一時停止] が指定され、FAIL の結果を受信した場合。

    • フィルムストリップでステータスグラフィックスが選択され、フィルムストリップの [停止] ボタンがクリックされた場合。

    「フリーズ」モードでは、フィルムストリップの結果をナビゲートしたり、ビジョンシステムから PCに画像を保存したりすることができます。 ジョブのパラメータを誤って編集してしまうのを防ぐために、すべてのアプリケーションステップは、薄く表示されたり、グレーアウトされたりします。 その間、ジョブは引き続き実行されます。 次の場合に、フィルムストリップは更新を再開し、すべてのアプリケーションステップは利用可能となります。

    • 指定された [一時停止時間] が過ぎた場合。
    • [停止] ボタンがクリックされた場合。
    • [すべての結果をクリア] ボタンがクリックされた場合。
  4. 結果のモニタを終了したら、ツールバーのオンラインボタンを再度クリックし、ビジョンシステムをオフラインに切り替えてください。
Closed センサから PC に結果を保存するには

オンラインまたはオフラインのビジョンシステムから、書き込み権限を持つ PC 上の任意のフォルダに結果を保存することができます。その後、PC の再生モードを使用して、結果を確認します。

Closed [保存フォルダ] の確認
  1. ビジョンシステムがオフラインであることを確認します。

  2. [保存フォルダ] フィールド右の「参照」ボタンをクリックします。

  3. [フォルダの参照] ダイアログが開きます。保存フォルダを指定してから、[OK] をクリックします。 フォルダのパスが [保存フォルダ] フィールドに表示されます。
Closed オンラインまたはオフラインのセンサから PC に結果を保存するには
  1. フィルムストリップの結果を選択するか、[停止] ボタンをクリックして、停止モードに入ります。 このモードは、画像ペイン上部の黄色のバーで表示され、フィルムストリップをナビゲートすることができます。 ジョブのパラメータを誤って編集してしまうのを防ぐために、すべてのアプリケーションステップは、薄く表示されたり、グレーアウトされたりします。 その間、ジョブは引き続き実行されます。

  2. フィルムストリップの PC に保存ボタンをクリックします。

  3. 保存先フォルダ内の既存の結果に新しい結果を追加するには、フィルムストリップの [更新再開] ボタンまたはすべての結果をクリアボタンをクリックし、停止モードを終了します。その後、ステップ 1～2 を繰り返してください。


PC の設定

[再生] ボタンを押すと、[記録再生のオプション] ダイアログが開き、各ビジョンシステムおよびエミュレータの記録および再生を設定することができます。ビジョンシステムのオンラインまたはオフライン時にアクセス可能な PC の再生モードでは、最大 10,000 の画像を再生し、ジョブの検証を行うことができます。画像はビジョンシステムに送信され、再生された画像に対しジョブが実行されます。

例: PC から再生中のフィルムストリップ

Closed [記録] を設定するには

注: PC にカラー画像を記録する場合、24 ビット画像でなく、16 ビット画像で保存されます。カラー画像を使用して、カラーツールをテストする必要がある場合、FTP 経由で画像をエクスポートし ([通信] アプリケーションステップで FTP デバイスを追加します) 、画像を保存することによってフルカラーを保持することができます。

  1. [PC の設定] グループボックスの [再生] をクリックします。
  2. [記録再生のオプション] ダイアログが開いたら、[記録] タブをクリックします。
  3. [記録フォルダ] を指定してから、残りの記録パラメータを設定してください。
  4. すべての記録設定を指定したら、[OK] をクリックして、[記録再生のオプション] ダイアログを閉じます。
Closed 画像を記録するには
  1. フィルムストリップの [PC] ボタンをクリックします。
  2. EasyBuilder ツールバーから、記録ボタンをクリックします。
  3. ビジョンシステム上で画像取り込みをトリガします。画像が取り込まれると、PASS および FAIL 画像は自動的にソートされ、指定のフォルダに保存されます。
  4. 記録ボタンを再度クリックして、記録を停止します。
Closed 再生を設定するには
  1. [PC の設定] グループボックスの [再生] をクリックします。
  2. [記録再生のオプション] ダイアログが開いたら、[再生] タブをクリックします。
  3. [再生フォルダ] を指定してから、残りの記録パラメータを設定してください。

注: [再生] フォルダは、デフォルトでEasyBuilder サンプルジョブフォルダを参照しています。これらのサンプルジョブを使用して、[記録再生のオプション] の便利な使い方についてデモンストレーションを行うことができます。記録再生のオプションは、以前に取り込んだ画像を繰り返し再生し、ツール結果を即時に表示することから、しきい値や制限の設定を短時間で行うことができます。

  4. すべての再生設定を指定したら、[OK] をクリックして、[記録再生のオプション] ダイアログを閉じます。
Closed PC から画像を再生するには

注: ビジョンシステムのオンラインモード時に画像を再生するには、[画像の設定] アプリケーションステップで [トリガ] パラメータを [外部]、[手動] または [ネットワーク] に設定する必要があります。

  1. フィルムストリップの [PC] ボタンをクリックします。
  2. [トリガ] パラメータ ([画像の設定] アプリケーションステップ) が、[カメラ] または [連続] に設定されている場合、ビジョンシステムをオフラインにしてから、画像を再生してください。[トリガ] パラメータが [外部]、[手動] または [ネットワーク] に設定されている場合、ビジョンシステムはオンラインのまま画像を再生することができます。
  3. フィルムストリップの再生ボタンをクリックして、画像を再生するか、または下に説明されたナビゲーションボタンをクリックして手動で画像を循環させます。
    4. 再生 | 一時停止
最初の画像 | 前の画像
次の画像 | 最後の画像
  4. [ジョブの実行] アプリケーションステップをクリックして、[結果] テーブルを表示します (または、パレットの [結果] タブをクリックします)。


ジョブの保存

このステップを使用して、ファイル管理およびセンサメンテナンスに関するさまざまなタスクを、センサのオフライン中に行うことができます。

注:[ユーザ] ダイアログの [オンラインでもジョブを保存] チェックボックスを ON にすると、フルアクセスまたはプロテクトのアクセス権を持つユーザは、オンライン中のジョブ保存が許可されます。[オンラインでもジョブを保存] チェックボックスが OFF の場合、ジョブを保存するにはビジョンシステムをオフラインにする必要があります。

  • ジョブを保存 (または新規保存) するには
  • スタートアップの設定を行うには
  • ジョブ、画像およびセンサ設定のアーカイブコピーをバックアップするには
  • ジョブ、画像およびセンサ設定のアーカイブコピーをリストアするには


ジョブを保存 (または新規保存) するには

ジョブを Closed 保存する場合、ツールの設定およびジョブの固有情報のみが保存されます。

注: このステップ以前でもジョブを保存することはできますが、[ジョブの保存] ステップは、ジョブの保存を促す役割を果たします。EasyBuilder には「自動保存」機能はありません。保存されていないジョブは、センサの電源を入れ直すと失われてしまいます。

ジョブをはじめて保存する場合、[保存] は、[名前を付けて保存] と同じ動作をし、[名前を付けて保存] ダイアログを開きます。

Closed ジョブを保存 (または新規保存) するには

  1. CTRL+S を押すか、[ジョブの上書き保存] グループボックスの [保存] または [名前を付けて保存] をクリックして、[名前を付けて保存] ダイアログを開きます。
  2. ダイアログ中、必要であれば保存するロケーションまで移動します。
  3. ジョブに名前を付けます。
  4. ダイアログの [保存] をクリックします。

Closed 以前に保存したジョブを保存するには、次のいずれかの作業を行う必要があります。
  • [ジョブの保存] グループボックスの [保存] をクリックします。
  • CTRL+S を押します。

注: 現在のジョブの画像を保存するには、[ファイル] メニューから [画像に名前を付けて保存] をクリックします。センサ設定およびすべての画像を保存するには、In-Sight センサまたはエミュレータにバックアップを作成します。


スタートアップの設定を行うには

[スタートアップのオプション] のコントロールを使用して、In-Sight ビジョンシステム/センサまたはエミュレータが ON になったときの、ジョブの起動方法を設定できます。この機能によって、ワークフローを効率化することができます。

フルアクセス権を持つユーザのみが、スタートアップの設定をすることができます。

起動ジョブの指定

  1. ボタンをクリックします。 [スタートアップ] ダイアログが開きます。
    1. [スタートアップ時にジョブをロード] チェックボックスを ON にします。 リストが有効になり、接続中のビジョンシステム/センサ、接続中のビジョンシステムにインストールされた SD カードまたはエミュレータに保存されたジョブが表示されます。

    2. ジョブサーバが有効な場合、[スタートアップ時にリモートからジョブをロード] チェックボックスを ON にします。 リストが有効になり、ジョブサーバに保存されたジョブが表示されます。

      注:
      • デフォルトで、ジョブサーバは無効になっています。 [ジョブサーバの設定] ダイアログを使用して、ジョブサーバを有効にしてください。
      • ジョブサーバを有効にした場合、ジョブサーバに保存したジョブのみ選択することができます。 ビジョンシステム上に保存したジョブをスタートアップ時にロードするには、ジョブサーバを無効にしてください。
      • ジョブサーバは、In-Sight 2000 シリーズビジョンセンサではサポートされていません。
  2. 起動時に自動的にロードするジョブを選択します。
  3. [OK] をクリックします。 ダイアログを閉じます。

  4. [ジョブ] テキストボックスに、スタートアップジョブが表示されます。

    注:
    • SD カードに保存されたジョブが選択された場合、[ジョブ] テキストボックスに "SDCARD/xxx.job" と表示されます。
    • [ジョブ] テキストボックスは読み取り専用です。 スタートアップジョブを変更するには、 [image] ボタンをクリックしてください。
  5. スタートアップジョブを未選択にし、空のジョブで起動したい場合は、 [image] ボタンをもう一度クリックし、[スタートアップ時にジョブをロード] または [スタートアップ時にリモートからジョブをロード] チェックボックスを OFF にしてください。

[起動時にオンラインモードにする]

  1. [起動時にオンラインモードにする] チェックボックスを ON にすると、スタートアップ時に現在接続中のセンサをオンラインモードにします。

    注: この設定は、[スタートアップ] ダイアログでも有効にすることができます。


アーカイブコピーをバックアップするには

バックアップ機能を使用して、フルアクセスまたはプロテクトのアクセス権を持つユーザは、ジョブ、画像およびセンサ設定のアーカイブコピーを In-Sight ビジョンシステム/センサまたはエミュレータから、ローカル PC のハードディスクに保存することができます。

ビジョンシステム/センサまたはエミュレータのバックアップを行う前に、[システム] メニューの [オプション] ダイアログをクリックし、アーカイブデータの保存先フォルダまたはバックアップディレクトリが正しく設定されているかどうかを確認してください。

現在使用中のセンサまたはエミュレータをバックアップするには、次の手順に従ってください。

  1. [センサのメンテナンス] グループボックスの [バックアップ] をクリックします。
ヒント: [バックアップ] ダイアログ ([システム] > [バックアップ]) を使用して、異なるビジョンシステム/センサ/エミュレータから、PC または In-Sight ビジョンシステムにインストールされている SD カードにバックアップを保存することができます。 詳細については、[バックアップダイアログ] トピックをご参照ください。


アーカイブコピーをリストアするには

リストア機能を使用して、フルアクセスまたはプロテクトのアクセス権を持つユーザは、ジョブ、画像およびセンサ設定のアーカイブコピーをローカル PC のハードディスクから元の In-Sight ビジョンシステム/センサまたはエミュレータに取得することができます。ダイアログを開く前に、PC にコピーをバックアップしてください

現在使用中のセンサまたはエミュレータにアーカイブコピーをリストアするには、次の手順に従ってください。

  1. [センサのメンテナンス] グループボックスの　[リストア] をクリックします。

ヒント: [リストア] ダイアログまたは [選択してリストア] ダイアログ ([システム] > [リストア] または [選択してリストア]) を使用して、アーカイブコピーを異なる In-Sight ビジョンシステム/センサまたはエミュレータに取得したり、SD カードに保存されたバックアップをビジョンセンサにリストアしたりすることができます。 詳細については、[リストア] ダイアログトピックまたは [選択してリストア] ダイアログトピックをご参照ください。


ジョブの実行

すべてのパラメータの設定が済んだら、ジョブを実行し、結果を確認したり、トラブルシューティングの設定を行うこともできます。さらに、必要に応じて、すべてのパラメータが制限範囲内にあるか、In-Sight ビジョンシステムが正確に画像を取り込んでいるかどうかを確認するテストを行います。

  • In-Sight ビジョン上でジョブを実行するには
  • [結果] テーブルを確認するには
  • TestRun™ でジョブをテストするには


センサ上でジョブを実行するには

センサ上でジョブを実行するには、センサをオンラインに切り替える必要があります。

注: [入力/出力] ステップで、入出力ラインの [強制] の設定を ON または OFF にした場合、[ジョブのステータス] グループボックスに警告が表示されます。 この場合、機器の電源が ON または OFF になっても危険が生じないよう、センサをオンラインまたはオフラインに切り替える前に十分注意してください。

センサをオンラインまたはオフラインに切り替えるには、次の手順に従ってください。

  • オンラインに切り替えるには: 設定ペインの [オンライン] ボタンをクリックします。 このボタンはトグルボタンで、オンライン状態ではオレンジ色となります。
    オフライン時のボタン
  • オフラインに切り替えるには: 設定ペインの [オフライン] ボタンをクリックします。 ボタンの色は青に変わり、オフライン状態に切り替わります。
    オンライン時のボタン


[結果] テーブルを変更または印刷するには

設定ペインの [オプション] をクリックして、[結果表示のオプション] ダイアログを開き、[結果] テーブルを変更することができます。

[結果表示のオプション] ダイアログのコントロールは、次の通りです。

  • 表示オプション Closed [列の幅の自動調整] 機能を ON/OFF にしたり、[ツールの　PASS/FAIL 数] をカウント表示またはパーセント表示にしたり、ツールのアイコン、処理時間、結果文字列、依存関係グラフィックス、有効/無効ステータスを [結果] テーブルから削除または追加することができます。

    [ツールの有効/無効ステータス] 列は、[位置決め] または [検査] ステップで定義された、ツールの ON/OFF 状態を示します。
  • ツールのオプション Closed 画像ペインのツールのグラフィックスオーバレイを表示/非表示にしたり ([グラフィックスの表示]) 、[結果] テーブルのツールのプロファイルを表示/非表示に切り替えることができます ([ツールの表示])。

    チェックボックスを ON/OFF にして、個々のツールに設定を適用することができます。すべてのツールを ON にするときは、[オプションの変更] の [すべて] ボタンをクリックし、すべてのツールを OFF にするときは [なし] をクリックしてください。デフォルトでは、すべてのチェックボックスは ON となっています。

    デフォルトでは、すべてのチェックボックスは ON となっています。
  • [初期値に戻す] ボタン Closed ソートをクリアし、[結果] テーブルをリセットして、デフォルト設定に戻します。デフォルトの表には、PASS/FAIL インジケータ、ツールの依存度関係グラフィックス、ツールのアイコン、名前、結果、PASS/FAIL (カウント表示) および時間が含まれます。列の幅は、EasyBuilder ビューにあわせて自動的に調整されます。

設定ペイン内の [結果] テーブル関連のその他のコントロールは、次の通りです。

  • [印刷] ボタン Closed [印刷プレビュー] ウィンドウを開きます。このウィンドウを使用して、すべてのページを印刷したり、プリセットのパーセンテージを使用してズームしたり、一度に表示するページ数を選択したり、特定のページを選択して表示したりすることができます。[ページの設定]　ダイアログを開いて、用紙のサイズ、印刷の向き、ページの余白およびプリンタを選択することができます。
  • PASS/FAIL のクリア Closed PASS/FAIL 数を 0 に戻し、カウントを再開します。


[結果] テーブルを確認するには

設定ペインの [結果] テーブルには、各ツールのプロファイルが表示されます。 テーブルを列によって並び替えるには、タイトル欄をクリックします。 並べかえの順番を逆にするときは、タイトル欄をもう一度クリックします テーブル内でツールをドラッグ & ドロップすることによって、ツールの順番を入れ替えることもできます。

注:[結果] テーブル内のツールをドラッグ & ドロップすることによって、ツールの順番を変更することができます。この操作は、ジョブの実行 [結果] テーブルおよびパレットの [結果] タブの両方で実行でき、その結果は両方のテーブルに反映されます。ドラッグ & ドロップソーティングは、テーブルの [ツールの順番および依存関係グラフィックス] 行を選択しているときのみ、有効となります。行を再度選択すると、順番は逆になります。リストの順番を変更する機能は、ジョブがジョブサイズ制限に近づくと、無効になります。

デフォルトに戻すには、再度タイトル欄をクリックします。

  • PASS/FAIL インジケータ: 緑の円 [image] は PASS、赤の四角 [image] は FAIL を示します。 PASS/FAIL の基準は、[位置決め] および [検査] ステップで設定されます。

  • ツールの順番および依存関係グラフィックス: 選択されたツール (オレンジ色で提示) と他のツール間のツールの順番および依存関係を表示します。 この列を選択して、ツールをジョブに追加した順でソートします。 また、ドラッグ & ドロップしてツールの順番を変更することが可能です。 グループ演算 & ロジックツール内のツールも、必要に応じてツールをドラッグすることによって、ツールを追加したり、削除したりすることも可能です。

    注: グループツールを他のグループツールにドロップすることはできません。また、循環参照が発生するツールをグループツールに追加することはできません。

    ツールが別のツールを参照しているときには依存関係が存在します。 各依存関係には、参照元と参照先の 2 つの部分があり、線で連結されています。 参照元とはデータのソース (入力を提供するツール) のことで、円で表されます。参照先とはデータのディスティネーション (出力を受け取るツール) のことで、矢印で表されます。 青い依存関係グラフィックスは選択したツールが参照先であることを、緑色のグラフィックスは選択したツールが参照元であることを示します。

  • ツールアイコン: 使用されているツールのタイプを視覚的に表示します。(エッジ有無判定ツール、ID コードの読み取りツール、ブロブ計数ツールなど)。
  • 名前: ツールの名前を表示します。[位置決め] または [検査] ステップでデフォルト名から変更できます。

  • 結果: ツールの結果を表示します。[位置決め] または [検査] ステップの [設定] または [制限範囲] タブにも、ツールの結果は表示されます。

    In-Sight モデル | 結果

    In-Sight 2000-110 および 2000-120/120C ビジョンセンサ

             PASS/FAIL ステータスのみ
    In-Sight 2000-130/130C ビジョンセンサ

    寸法測定および計数ツール: 標準の結果 (数値データ)
    有無判定ツール: PASS/FAIL ステータスおよびパターンの得点
    その他のツール:PASS/FAIL ステータスのみ
    In-Sight ビジョンシステムおよび In-Sight 2000-23M ビジョンセンサ | 標準の結果
  • PASS: ツールの PASS 率 (PASS 結果数/すべての結果数) を数字 (デフォルト) またはパーセンテージで表示します。
  • FAIL: ツールのFAIL 率 (FAIL 結果数/すべての結果数) を数字 (デフォルト) またはパーセンテージで表示します。

    • 注: ツールが OFF になっている場合、その信号は最後の状態のままとなります。 ツールが OFF になったときに FAIL 状態だった場合、PASS は 0、FAIL は 1 となります。 ただし、OFF になったツールの PASS/FAIL は、ジョブの総合 PASS/FAIL 判定には影響しません。

  • 時間 (ms): ツール実行に必要な時間をミリ秒単位で表示します。

  • 種類: ツールの種類を表示します。 例えば、PatMax RedLine™ パターン (1-10) 位置決めツールでは「PatMax RedLine™ パターン (1-10)」が表示され、PatMax® 位置決めパターン (1-10) では「PatMax® パターン (1-10)」が表示されます。

    注: [種類] コラムを非表示にするには、右クリックして [種類を表示] を選択します。

PASS 率 (PASS/FAIL を最後にクリアしてからの総数) および表示画像のジョブ時間が、テーブル左の [ジョブのステータス] グループボックスに表示されます。

  • [結果] テーブルを変更または印刷するには


ジョブの最適化およびトラブルシューティング

この情報を使用して、トラブルシューティングをしたり、ジョブの設定を最適化 することができます。

[結果] テーブルを使用したトラブルシューティングの例は、次の通りです。

  • PASS/FAIL 数: どのツールが FAIL かを特定します。
  • ツールの依存度グラフィックス: ツールの FAIL 原因が、別の FAIL 結果のツールによるものかどうかを、両ツール間の依存関係を表示して判断します。
  • 結果文字列: どのツールが仕様外かを判断します。

ジョブの最適化を行うことによって、ジョブの処理時間を短くすることができますが、その短縮時間は個々の In-Sight センサの性能によって異なります。ジョブの最適化は、高速ラインを使用したジョブなど、応答時間が鍵となるアプリケーションにおいて有用です。

EasyBuilder ジョブを実行する際に、処理時間が長いのは次の段階です。

  • 画像取り込み時間露光時間 + CCD への転送時間
  • ツール処理: すべてのツールおよび関数の総合処理時間

ジョブの処理時間を短縮するための一般的ガイドラインは次の通りです。

  • 露光時間を短くします。
  • 部分取り込みをします。
  • 検査対象領域を小さくします。
  • 画像の回転を最小限にします。

必要であれば、[画像の設定]、 [位置決め] または [検査] ステップに戻り、パラメータを適宜変更してください。

また、主な位置決めツールおよび検査ツールの相対的な速度は次の通りです (速い順)。

  • エッジ
  • ブロブ
  • パターン

エッジツールとパターンツールを使用して同じ結果が得られるのであれば、エッジツールを使用したほうがジョブの実行時間は短くなります。

注: 画像取り込みおよび関数処理を同時に行うことがあるので、[ジョブの実行] ステップより設置環境でのランタイムのほうが、実行時間が速いことがあります。


TestRun™ でジョブをテストするには

TestRun™ は In-Sight ビジョンシステムに対しテストを行い、そのテスト結果を予想値と比較します。TestRun は次のテストから構成されます。

  • リミットテスト: 現在のパラメータ値が、設定した上限・下限値内にあるかどうかを決定します。これらのパラメータは、ユーザがジョブ内で直接設定したり、通信プロトコルを介して外部デバイスからジョブまたは値をディスクリート入力で読み取って設定したりすることができます。
  • 画像テスト: 「良品」または「不良品」であることが分かっている一連の画像をビジョンシステムに送信し、現在のジョブ結果が各画像の予想結果と一致するかどうかを決定します。
  • ハードウェアテスト: ビジョンシステムの現在の画像品質を予想画像と比較し、カメラの位置、焦点、照明などに変化が生じたかどうかを決定します。

TestRun を使用する前に

注: TestRun を使用できるのは、フルアクセス権限のあるユーザのみです。

TestRun は、次の条件を前提としています。

  • マシンビジョンアプリケーションがすでに設置されていて、In-Sight ビジョンシステムにジョブファイルとして保存されている。
  • [接続] ステップで、ビジョンシステムへの接続が確立されており、ジョブファイルがロードされている。
  • アプリケーションで使用される画像を含む画像データベースがすでに作成されている。

注: 画像データベースには、「良品」 (PASS となる画像) と「不良品」 (FAIL となる画像) の両方の画像が含まれていることが望ましいです。TestRun は、様々な画像データベースファイル構成に対応していますが、TestRun を実行する前に「良品」フォルダと「不良品」フォルダに画像をソートしておくと、プロセスを簡略化することができます。

TestRun を使用するには

In-Sight ビジョンシステムに接続し、ジョブファイルをロードすると、TestRun の設定を始めることができます。TestRun の設定には、ステップバイステップで TestRun をプログラムできる [TestRun 設定] ダイアログを使用します。ダイアログの左にはナビゲーションパネルが表示され、設定するステップのセットアップ画面を選択することができます。

注: TestRun の初期設定後、ナビゲーションパネルのステップをクリックして、各ステップに戻ることができます。

TestRun を設定するには

  1. [パレット] の [TestRun] タブをクリックします。

注: [パレット] が表示されていない場合、[表示] メニューから [パレット] を選択します。

  2. [設定] ボタンを押し、[TestRun 設定] ダイアログを開きます。
  3. ナビゲーションパネルに従いステップバイステップで、TestRun を設定します。TestRun 設定についての詳細は、In-Sight Explorer ヘルプをご参照ください。


Legal Notices

法律上の表示

本書で説明する本ソフトウェアは、ライセンスのもとで提供されており、かかるライセンス条項にしたがい、かつ本ページに記されている著作権表示を行うことを条件として使用および複製が許諾されます。本ソフトウェア、本書、あるいはそれらのコピーをライセンスの保有者以外に提供することはできません。

本ソフトウェアのあらゆる権利は Cognex Corporation あるいは正当な権限を有する第三者に帰属します。Cognex Corporation は、当社の供給によらない装置上での本ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本ソフトウェアの商業性、非侵害または特定目的に対する適合性に関して、明示的にも黙示的にも一切の保証を行いません。

本書の内容は、予告なしに変更することがあります。本書のいかなる内容も、Cognex Corporation が何らかの約束を実行するものと解釈されてはなりません。本書あるいは関連するソフトウェアに含まれる誤りについて、Cognex Corporation はいかなる責任も負いません。

本書で例として使用されている企業名、人名およびデータは、特に断りがない限り架空のものです。本書のいかなる部分も、Cognex Corporation の書面による許諾なく複製すること、手段・方法・目的を問わず電子的または機械的に転載すること、他のメディアに変換すること、および他の言語に翻訳することを禁じます。

Revision: 5.6.1.14

09/14/2018 4:24 PM

Copyright @ 2008 -2018 Cognex Corporation. All Rights Reserved.

Cognex の提供するハードウェアおよびソフトウェアの一部は、下記に示す米国およびその他の国の特許、または申請中特許で保護されています。本書の出版以降に申請された米国および他国の特許は、Cognex のウェブサイト http://www.cognex.com/patents に記載されています。

5481712, 5742037, 5751853, 5845007, 5909504, 5943441, 5949905, 5960125, 5978080, 5978081, 6005978, 6137893, 6141033, 6154567, 6215915, 6301396, 6327393, 6381375, 6408109, 6457032, 6490600, 6563324, 6658145, 6690842, 6771808, 6804416, 6836567, 6850646, 6856698, 6859907, 6920241, 6941026, 6959112, 6963338, 6975764, 6985625, 6993192, 7006712, 7016539, 7043081, 7058225, 7065262, 7069499, 7088862, 7107519, 7164796, 7175090, 7181066, 7251366, 7720315, JP 3927239

Cognex、In-Sight、EasyBuilder、VisionView、DataMan および DVT は Cognex Corporation の登録商標です。

Cognex ロゴ、SmartLink、EdgeCount、FeatureCount および ObjectLocate は Cognex Corporation の商標です。

Windows は米国およびその他の国の Microsoft Corporation の登録商標または商標です。その他の製品名および商標は、各所有者の商標です。


入出力データをフォーマットするには

個々のツールの結果またはジョブ全体の結果 (出力のみ) などの EasyBuilder のジョブデータを Ethernet/IP、DeviceNet、Modbus、TCP 、PROFINET および POWERLINK を介して通信することができます。 フォーマットされた入力データは、センサが画像を取り込み、ジョブを完了して出力データが送信された後に読み込まれます。

注:DeviceNet、POWERLINK および CC-Link は、In-Sight ファームウェア 4.x.x を搭載した In-Sight ビジョンシステムのみで使用可能です。In-Sight ファームウェア 5.1.0 以降をを搭載した In-Sight ビジョンシステムでは使用できません。 モデル一覧およびサポートされているファームウェアバージョンについては、ファームウェアバージョンをご参照ください。

データをフォーマットするには、次の手順に従ってください。

  1. [フォーマット入力データ] または [フォーマット出力データ] タブをクリックします。
  2. [追加] ボタンを押し、[入力データの選択] または [出力データの選択] ダイアログを開きます。
  3. ダイアログには、ジョブに追加された位置決めツールまたは検査ツールのデータ、およびジョブ全体の結果 (出力のみ) が含まれています。 In-Sight センサから送信 (または受信) するデータを選択し、[OK] ボタンを押してください。

  4. データを追加したら、[データ型] ドロップダウンリストを使用して、デフォルトのデータタイプを変更することができます。

    注:
    • [データ型] ドロップダウンリストから [文字列] を選択すると、[エレメントごとのバイト数] ドロップダウンリストが有効となり、バイト数を選択して文字列長を指定することができます。
    • PROFINET 使用時の最大入力および出力データ長は 4,000 バイトです。 POWERLINK 使用時の最大入力および出力データ長は 256 バイトです。

  5. [ハイバイト/ローバイト] チェックボックスを OFF にし、ローバイトを先にするように指定することによって、バイトオーダをカスタマイズすることができます。デフォルトでは、PROFINET を除き、OFF となります。 [ハイワード/ローワード] チェックボックスを OFF にし、ローワードを先にするように指定することによって、ワードオーダをカスタマイズすることができます。デフォルトでは、チェックボックスは OFF となります。[フォーマット出力データ] タブで変更を加えると、プレビューウィンドウが更新されます。

    注:バイトオーダまたはワードオーダに関する変更は、[フォーマット出力データ] および [フォーマット入力データ] タブのすべてのデータ符号に影響します。
  6. [上へ] または [下へ] ボタンを押して、送受信されるデータの順番を変更することができます。


キャリパアレイ

キャリパアレイは、1D カーネルを用いて各キャリパ内のエッジピークを検出するエッジモデルメソッドを使用し、画像領域内のエッジ成分を検出します。キャリパアレイは、検査対象エッジを含む画像の一部分を 1D で表示しますが、この 1D 画像には、検査対象エッジだけでなく、オリジナルの画像中のノイズやその他の不必要な情報が含まれています。キャリパアレイを使用して、1D 画像にツールの [エッジ] タブの [キャリパサイズ]、[エッジ幅] および [最小コントラスト] パラメータを適用することによって、検査対象エッジの強度を増し、同時に画像中のノイズを軽減します。

アレイ中の各キャリパは個別に評価され、エッジ候補を得点化して、どのエッジを選択するかを決定します。位置欠陥では、検出エッジに基づいて最適ラインを作成し、指定許容範囲外のばらつきに対し、検出エッジと最適ラインを比較して、欠陥を決定します。幅欠陥では、キャリパ内で検出された 2 つのエッジ間の距離を計算して、その距離を決定し、その距離と許容範囲を比較して欠陥を決定します。

領域内のキャリパアレイは、検出可能な欠陥/ギャップのサイズを定義します。検出可能な欠陥またはギャップのサイズは、検出可能なエッジ数によって決定されますが、その数はエッジ上に位置するキャリパ数によって決定されます。[すべてのキャリパを表示] チェックボックスを ON にすると (デフォルトは、OFF)、領域内のキャリパは赤の矩形として表示されます。

注: 領域内のキャリパ数が多いほど、ツールの実行時間が増大します。


カラーモデルを追加、編集するには

カラーモデルは、画像内の対象物と背景を定義するために使用するカラーの集合です。各カラーモデルは 3 次元色空間を表しています。カラーモデルに対し、取り込む対象物および背景のカラーの RGB 値を加算または減算します。

Closed カラーモデルを追加する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。デフォルトでは、[ExtractColorLibrary_1] が、選択されています。
  2. [カラーの登録] ボタンを押して、[ExtractColor 登録] ダイアログを開きます。
  3. [ExtractColor 登録] ダイアログ、[カラーモデル] グループボックスの、[新規モデル] ボタンを押して、新しいカラーモデルをカラーライブラリに追加します。ツールのデフォルト名は モデル_1 で、末尾の番号はツールに応じて増加します。
  4. 複数のカラーモデルが追加される場合など、必要に応じて、カラーモデル名を変更します。カラーモデルの名前は、該当するカラーモデルをハイライトし、[ライブラリ] リストの上にある名前変更ボタンをクリックすることで、いつでも変更できます。
  5. 必要に応じて、カラーモデルをハイライトし、モデルの削除ボタンをクリックして、カラーモデルを削除できます。
Closed カラーモデルにカラーを加算または減算する
Closed カラーモデルに単一のカラーを加算または減算する
  1. 変更するカラーモデルを選択します。
  2. [登録] グループボックスから、[最大ドミナントカラー] を選択します (デフォルト設定)。
  3. [登録] グループボックスから、カラーの定義に使用する領域タイプを選択します。選択肢は、領域、円、ドーナツ領域、ポリゴンまたはフリーハンドです。
  4. [加色の作成] または [減色の作成] ボタンを押し、加算または減算する RGB 値のみが含まれるように、画像内に領域を設定します。
  5. 領域を設定したら、領域をダブルクリックするか、またはジョブの編集ツールバーで [OK] ボタンを押します。
  6. カラーの [追加] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルに累積的に追加されます。
  7. カラーの [減算] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルから累積的に減算されます。
  8. カラーモデル内の色の適用順序を変更できます。リストの上にあるカラーから順に検査に使用されます。
Closed カラーモデルに複数のカラーを加算または減算する
  1. 変更するカラーモデルを選択します。
  2. [登録] グループボックスから、[マルチカラー] を選択します。
  3. [登録] グループボックスから、カラーの定義に使用する領域タイプを選択します。選択肢は、領域、円、ドーナツ領域、ポリゴンまたはフリーハンドです。
  4. [加色の作成] または [減色の作成] ボタンを押し、加算または減算する RGB 値のみが含まれるように、画像内に領域を設定します。
  5. 領域を設定したら、領域をダブルクリックするか、またはジョブの編集ツールバーで [OK] ボタンを押します。
  6. カラーの [追加] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルに累積的に追加されます。
  7. カラーの [減算] 操作では、カラーモデルに加算されたカラーに、領域内のピーク RGB 値が含まれます。また、その値はカラーモデルから累積的に減算されます。
  8. カラーモデル内の色の適用順序を変更できます。リストの上にあるカラーから順に検査に使用されます。
Closed [カラー許容値] を調整する

[ExtractColor 登録] ダイアログの[カラー許容値] コントロールとともに [画像マーク] コントロールを使用して、対象物がどの程度検出されるかを決定したり、[カラー許容値] コントロールの [暗]、[明]、[ハイライト]、および [色相] の設定値を使用して、感度を増減したりすることができます。

ヒント: [カラー許容値] コントロールを設定する際には、画像がよく表示されるように [ExtractColor 登録] ダイアログを配置してください。コントロールを調整すると、[画像マーク] で選択したタイプに基づき、変更を反映して画像が更新されます。

Closed [カラー許容値] コントロール
Closed 暗

この設定値を大きくすると、黒 (0,0,0) の方向に色空間が加算されます。

Closed 明

この設定値を大きくすると、白 (255,255,255) の方向に色空間が加算されます。

Closed ハイライト

この設定値を大きくすると、最初の色の位置から白 (255,255,255) の方向に色空間が加算されます。

Closed 色相

この設定値を大きくすると、色の 3 次元「ボックス」が色空間の 3 方向に大きくなります。

Closed [画像マーク] コントロール

[画像マーク] ボタンを使用して、カラーおよびカラーモデルを追加/減算したときに画像内の何をハイライトするかを設定できます。

Closed すべてのモデルの結果をマーク

カラーモデルのすべての色が画像内でマークされます。

Closed 選択したカラーまでの結果をマーク

3 つのカラーがあるリストの 2 番目のカラーを選択すると、最初のカラーと 2 番目のカラーが画像内でマークされます。

Closed 選択したカラーのみをマーク

選択したカラーのみが画像内でマークされます。

Closed カラーモデルを編集する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。
  2. [カラーの登録] ボタンを押して、[ExtractColor 登録] ダイアログを開きます。
  3. 変更するカラーモデルを選択し、ダイアログのコントロールを使用してカラーモデルを編集します。


カラーを追加、編集するには

カラーは領域によって定義され、登録時に領域内に含まれる平均 RGB および HSI 値を保存します。 ライブラリには、検査対象物の RGB/HSI 値によって構成される 100 個までの異なるカラーを含むことができます。

Closed カラーを追加する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。 デフォルトでは、[MatchColorLibrary_1] が、選択されています。
  2. [カラーの登録] ボタンを押して、[MatchColor 登録] ダイアログを開きます。
  3. [登録] グループボックスから、カラーの定義に使用する領域タイプを選択します。選択肢は、領域、円、ドーナツ領域、ポリゴン、フリーハンドで描画または点です。
  4. [加色の作成] ボタンを押し、加算または RGB 値のみが含まれるように、画像内に領域を設定します。
  5. 領域を設定したら、領域をダブルクリックするか、またはジョブの編集ツールバーで [OK] ボタンを押します。
  6. 複数のカラーモデルが追加される場合など、必要に応じて、カラーモデル名を変更します。 カラーの名前は、該当するカラーモデルをハイライトし、[カラーライブラリ] リストの上にある名前変更ボタンをクリックすることで、いつでも変更できます。
  7. 必要に応じて、カラーをハイライトし、カラーの削除ボタンをクリックして、カラーを削除できます。
Closed カラーの [カラー許容値] を調整する

[MatchColor 登録] ダイアログの [カラー許容値] コントロールを使用して、対象物がどの程度検出されるかを決定したり、[カラー許容値] コントロールの設定値を使用して、感度を増減したりすることができます。

ヒント: [カラー許容値] コントロールを設定する際には、画像がよく表示されるように [MatchColor 登録] ダイアログを配置してください。 コントロールを調整すると、変更を反映して画像が更新されます。

Closed 暗

暗限界を指定します (0～1.0、デフォルトは 1.0) 。 [色空間] を [RGB] に設定した場合、[暗] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比的に低くなります。 [色空間] が [HSI] に設定されている場合、[暗] の範囲を拡大すると、登録されるカラーの明度が小さくなります。

Closed 明

明限界を指定します (1.0～10.0、デフォルトは 1.0) 。 [色空間] を [RGB] に設定した場合、[明] の範囲を拡大すると、登録されるカラーは (0,0,0) から登録される色の RGB 値までの線に沿って比的に高くなります。 [色空間] が [HSI] に設定されている場合、[明] の範囲を拡大すると、登録されるカラーの明度が大きくなります。

Closed カラーモデルを編集する
  1. [設定] タブの [カラーライブラリ] ドロップダウンリストからカラーライブラリを選択します。
  2. [カラーの登録] ボタンを押して、[ExtractColor 登録] ダイアログを開きます。
  3. 変更するカラーモデルを選択し、ダイアログのコントロールを使用してカラーモデルを編集します。


エッジ候補

キャリパアレイを内蔵したツールを使用している場合、エッジ候補はカラーコード化された小さな円で表示されます。

Closed 例 - 直線最適ライン (PASS)

Closed 例 - 直線最適ライン (FAIL)

Closed 例 - 円状最適ライン (FAIL)


[設定] タブ (シャープネス有無判定ツール)

Closed スムーズネス

領域内に存在する高周波ノイズを除去する、画像平滑化処理を定義します (0～2; デフォルト = 0)。この値を 0 に設定すると、平滑化は実行されず、処理時間は最速となります。1 に設定すると、平滑化が適用され、領域内の非常に高い周波数のノイズを除去します。2 に設定すると、さらにレベルの高い平滑化が実行され、領域内の高周波ノイズおよび非常に高い周波数のノイズを除去します。