DataMan 300: 问题与解答


欢迎屏幕


欢迎

建议使用左侧 应用步骤 大号按钮快速设置设备。每个模块都配有 基本 或 高级 配置选项卡。 保存设置 操作按钮可将配置数据保存到读码器中，并且只需点击一次即可将配置数据备份到电脑中。下面这些问题描述每个应用步骤中不是一目了然的配置选项。


在应用类型选项下能进行哪些设置？

点击右侧箭头，从下拉菜单中选择合适的读取模式。


在优化图像步骤中可以做什么？

在此可对连接的设备进行配置、调谐和测试，也可对此设备进行照明设置。


在代码详情选项下能选择哪些设置？

在此可选择 DataMan 必须读取的条码符号，也可选择不同的多代码方案。也可在此菜单中进行高级解码器设置。


在应用详情 步骤中可以进行哪些设置？

可在此定义触发和曝光设置。触发助手、间隔时间助手和曝光助手可方便地帮您完成这些设置。

在"高级选项卡下，可在表视图中实现更多设置。


在格式化数据选项下能做哪些配置？

可以使用基本格式化或 Perl Style 正则表达式利用预定义的构建模块构建自定义输出字符串，或使用 JavaScript 引擎构建灵活的数据格式化脚本程序，从设备中获取所需的数据输出。


在输入/输出步骤中可以进行哪些设置？

在此面板中可设置按钮操作、输入和输出行。可在此设置脉冲编码器参数和蜂鸣器脉冲长度。此面板有一个到图像缓冲设置的连接，可将 FTP 图像传输至服务器。


在通信应用步骤中可以进行哪些设置？

可利用通信应用步骤中的三个选项卡对串口和以太网进行设置。点击合适的选项卡，输入设置值。


保存设置选项可做哪些操作？

保存设置是一个操作而不是步骤，要慎重执行。此操作可将当前配置保存到读码器永久存储器中，重启读码器后即会加载这些配置。DataMan 设置工具也会将备份文件存储到当前电脑的默认备份文件夹中。


什么是配置备份文件？

配置备份文件中包含设备所有参数和配置。可以用来将设备的设置恢复成已知状态，或通过选择备份属性中配置参数来配置新的设备，或不设置参数。


连接至读码器


如何将读码器连接至设置工具？

无论使用何种读码器，按下列步骤将 DataMan 读码器连接至设置工具:

  1. 通过 Windows 开始菜单或设置工具帮助菜单，为特定读码器打印一份读码器配置代码文档。

  2. 在读码器和运行设置工具的 PC 之间连接必要的电缆。有关详细信息，请参阅快速参考文件。

  3. 单击设置工具中的刷新。

  4. 选择显示连接读码器的 COM 端口或网络设备。

  5. 单击连接。


为什么无法将设置工具连接至读码器？

如果无法连接，查看下列设置：

  • 确保扫描了与所用物理连接类型相匹配的配置代码（USB COM 或 RS-232 串行）（不适用于仅支持以太网的读码器）。

  • 确保电脑中安装的防火墙或防病毒应用程序能通过对应端口（Cognamer端口号:1069；设置工具端口号:44444）访问以太网设备。

  • 确保 COM 端口列表中显示一个连接读码器的端口。

    DataMan 60、300、370系列、470系列、503、8000 系列：如果读码器连接至以太网，查看读码器是否出现在网络设备列表中。

    单击刷新以确定读码器已连接了哪些端口。

    注：单击刷新发送所有 COM 端口和以太网子网中的查询字符串。DataMan 8000 无线读码器必须唤醒以响应查询。可以长按触发器唤醒读码器。

  • 确保未使用键盘、键盘仿真或 HID 连接：必须使用 USB 串行、RS-232 串行、以太网或无线网络将设置工具连接至读码器。

  • DataMan 60、300、370系列、470系列、503、8000 系列：确保添加设备选项中提供的 IP 地址是正确的。

  • 仅 DataMan 8000 无线读码器：确保读码器未处于休眠模式（长按触发器进行唤醒）。

  • 仅 DataMan 8000 无线读码器：确保读码器与连接至 PC 的基站建立连接。为确保正确连接，可以扫描印在快速参考指南上断开链接的配置代码，从基站上拔下电源线和通讯电缆，重新连接电缆，然后再将手持设备放入基站。再次尝试连接之前，一直等到手持设备显示已链接（有声频信号）为止。

  • 仅 DataMan 8000 无线读码器：确保基站连接至电源。

如果读码器已连接至 PC 的 COM 端口，可以使用 HyperTerminal 等终端仿真程序，确定读码器是否在发送任何数据。


为什么我看到设备图标的右上角中有叠加图标？

箭头图标表示它是手动添加的设备。V图标表示该设备是虚拟设备。


什么是虚拟设备？

设备图标右上角的V覆盖图标表示设备是虚拟设备。在维修和支持模式下可以从自定义配置文件或带默认配置的设备创建虚拟设备。虚拟设备可用来查看设置工具中不同的面板，而无需连接到实际设备。

创建的虚拟设备对网络上的其他设备不可见。虚拟设备在多个设置工具实例中持续存在。

能以同样的方式连接所创建的虚拟设备作为常规设备，除非所有配置更改都遭到拒绝（全都是只读型）且虚拟设备上没有特性、功能和操作工作。


仍无法连接至读码器或基站：可以将它重置吗？

对于 DataMan 8000 基站：

使用与基站相关联的无线读码器，扫描将基站重置为出厂默认值命令（适用于 DM8000 基站），将基站还原至出厂默认状态。

适用于 DataMan 503 和 8000 系列读码器：

扫描印在快速参考指南背面的重启扫描器命令，执行软重置操作。虽然读码器中的非易失性存储器不会清除，但读码器会关机并重启。

如果失败，扫描将扫描器重置为出厂默认值命令，将读码器还原至出厂默认状态。

如果失败且有线读码器正在使用中，请断开读码器的电源（在 DataMan 9500 中不可执行此操作）。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。

如果失败且 DataMan 8000 无线读码器正在使用中，请取出读码器的电池并将其放置到基站。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。

适用于 DataMan 50、60 和 70 读码器：

通过 Windows 开始菜单或设置工具帮助菜单，为特定读码器打印一份配置代码文档。

扫描重启读码器代码，执行软重置操作。虽然不会清除读码器中的非易失性存储器，但读码器会关机并重新启动。

如果仍无法连接读码器，扫描将读码器重置为出厂默认值代码，将读码器还原至出厂默认状态。

如果仍不能解决问题，断开读码器的电源（包括 DC 电源和 USB，如已连接）。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。


如何知道哪台是我的设备？

适用于 DataMan 260、300、473、503 和 8000 读码器：

在设备列在连接至读码器下方的树结构中，右键单击读码器并选择识别。读码器的状态指示灯给出信号，使其能够被识别。


为什么有些设备显示为绿色？

新发现的设备以绿色显示几秒钟，表示新设备已添加到树视图中。


什么是进程监控？

DataMan 读码器在操作时，会记录接收的触发信号数量、符号读取（和未读取）数量、触发信号超出数量等统计数据。可以使用各种方法查看或请求这些统计数据。例如，可以连接 VisionView 应用软件监控读码器尝试解码的次数，或使用 DataMan 控制命令 (DMCC) 界面建立连接并通过串行或 Telnet 连接检索日志信息。

在默认情况下，DataMan 读码器连接至设置工具时，会停止生成有关尝试解码次数的统计数据。如要在连接至设置工具时重新启用进程统计数据，必须启动进程监控。即使使用设置工具和 VisionView 应用软件等为单个读码器建立了多个连接，如果未启用进程监控，读码器也不会记录解码的统计数据。


DataMan 50、60、70、300、370、470、503、8000 系列、MX-1000、MX-1500 和 DataMan 8000 基站：为什么在连接时，设置工具要求提供密码？

在连接到设置工具之前，可以配置读码器和基站要求提供密码。通过通讯设置面板网络设置选项中的验证选项卡启用密码。请注意，串行连接也使用该密码。


DataMan 60、300、370、470、503、8000 系列 和 DataMan 8000 基站：可以直接使用以太网将读码器连接至 PC 吗？

可以将读码器或基站直接连接至 PC 的以太网接口 (RJ-45)。如果设备配置了 DHCP，它会在大约 20 秒后出现在网络设备列表中。但请注意，PC 可能还需要数分钟时间来解决 IP 地址问题。完成之前，无法通过设置工具连接至设备。

如果设备已设置为静态 IP 地址，只有当设备与 PC 共用同一子网时它才会出现。


DataMan 60、300、370、470、503、8000 系列、MX-1000 和 DataMan 8000 基站：如何将网络设备列表中的列表映射到特定读码器？

在默认情况下，网络设置中出现的每个 DataMan 都带有 DM 前缀和设备上 MAC 地址的后 6 个字符。


DataMan 60、300、370、470、503、8000 系列、MX-1000、MX-1500 和 DataMan 8000 基站：如果网络设备列表中不出现读码器或基站怎么办？

如果所需的读码器或基站未列出，可以反复开关电源来添加。设备在接通电源后出现在列表中可能需要 60 秒的时间。

如果反复开关电源未能解决问题，设置工具可能因网络配置原因无法与设备通讯，从而使它未出现在网络设备列表中。

检查与读码器或基站的以太网连接，然后点击设置工具中的刷新。

如果知道读码器或基站的 IP 地址，使用添加设备选项。

这种方法可使 DataMan 读码器或基站出现在网络设备列表中，这样就能通过设置工具和以太网来连接。


比较配置按钮如何工作？

比较配置按钮可启动设置工具的配置比较功能，表格视图样式工具用来设置、复制、比较或恢复设备配置。该功能在新的文档页面中打开。

在按下按钮之前如果未从设备列表中选择设备，则会打开一个空文档。如果选择了一个或多个设备，就会用这些设备的设置来填充比较文档。


网络中显示的 RTM Lean 设备是什么？

实时监控（RTM）Lean 是内置于 DataMan 设置工具中的特色工具，能够对网络上与设备相关的各种类型数据和读取的数据进行收集和分析。可以选择设备将其和 RTM Lean 连接，然后在新打开的文档中进行数据收集设置。RTM Lean 仅主动收集已连接上并正在运行的设备所发送的数据。

在启动设置选项中，会要求用户选择 RTM Lean 将要检测的设备和收集的何种类型的数据（默认值之外的选项）。可在功能区菜单上配置选项中重新定义。默认情况下，RTM Lean 收集统计数据（读取速率、触发计数、触发失效、缓冲区溢出和过程控制仪表。设置设备中这些参数后才能收集到这些数据）。

注：RTM Lean可以一次从一个设备采集数据，并将数据保存48小时。


如何将读码器连接至设置工具？

无论使用何种读码器，按下列步骤将 DataMan 读码器连接至设置工具:

  1. 在读码器和运行设置工具的 PC 之间连接必要的电缆。有关详细信息，请参阅快速参考文件。

  2. 单击设置工具中的刷新。

  3. 单击连接。


优化图像


在 应用类型选项下能进行哪些设置？

点击右侧箭头，从下拉菜单中选择合适的读取模式。


在优化图像步骤中可以做什么？

在此可对连接的设备进行配置、调谐和测试。

建议选择 基本 或 高级 配置选项，然后点击中间的应用步骤 大号按钮，来快速设置设备。使用保存设置操作按钮可以直接保存所有配置数据。


如何将采集的图像保存为文件？

点击图像面板或图像查看器栏中的保存图像按钮。

也可以将图像拖放至 PC。单击图像显示窗口中的图像，将它拖到设置工具外并松开。

注：如果想用拖放方式保存图像且它并非最后一个图像（正从读取结果历史记录中保存），图像将以显示的图像设置保存。在默认情况下，质量会降低。在显示的图像设置下方，将图像大小更改为全尺寸和位图格式。


如何使用实时按钮？

在基本选项卡下，点击实时 按钮进入实时模式。实时模式不仅监视设备读取的内容，而且还能解码。点击按钮的最右边打开更多选项。

如果想要设备对所拍摄的图像解码，请选中解码。选中后，焦点反馈在图像视图右侧显示颜色编码仪表。仪表显示镜头焦点（越低聚焦越少）。

选中正确根据自动曝光选项可让读码器自动确定图像中的最佳曝光设置。滑块（图像视图区域下方）显示目标的像素亮度。

可在高级选项卡下看到图像设置的表视图。


如何使用调谐按钮？

点击基本 选项卡上的调谐按钮自动找到数据读取的最佳设置。此下拉窗口（点击按钮最右端将其打开）显示 优化焦点、 优化亮度、 条码符号助手、 触发类型、 训练代码、 高级触发设置和其他调谐功能。

注：调谐工作所需的最小 ROI 尺寸为 144 ?144 像素。

下拉窗口顶部的选项在以下单独的问题中进行描述说明。

点击 优化亮度 以自动设置设备的建议亮度（只有设置下方手动曝光时才有效），或点击按钮旁边的链接以导航到 应用详情 应用步骤中，在此可以手动设置光照强度并找到高级设置。

选择自动曝光选项可让读码器自动确定图像中的最佳曝光设置。增益系数滑块（图像视图区域下方）显示目标的像素亮度。

为手动曝光选择手动曝光选项，然后向左或向右拖动最大曝光滑块为相机曝光指定精确设置。或者，可以使用图像视图区域下方的滑块。最大增益系数设置用于设置目标的最大像素亮度。

点击 优化焦点 以自动设置设备的建议焦点，或点击按钮旁边的链接以导航到 应用详情 下方相应的面板，在此可以手动设置相机焦点并找到高级设置。通过使用图像视图字段下方的滑块（带有焦点图标）还可优化焦点。请注意，它只在使用液体透镜时出现。

点击 训练代码 以训练或（在代码已经训练的情况下）未训练代码，或点击按钮旁边的链接导航到 代码详情 应用步骤中的高级代码训练设置。

条码符号助手是一个引导完成读取和解码相应或所需条码符号设置的向导。也可以通过点击助手旁边的链接可导航到 代码详情 应用步骤中，手动调整条码符号设置。

用任何以下触发类型配置读码器：

  • 单次触发采集单个图像并尝试对所含的任何符号进行解码。此触发模式支持读取超时。

  • 演示触发在每次检测到符号时，就会对它连续扫描并解码。

  • 只要触发信号仍然有效，手动触发就可以采集图像，在找到符号并解码或触发信号结束时停止。

  • 连击触发采集一组图像，并对这组中第一个检测到的符号进行解码。可以配置每次连击的图像数量和每次图像采集的间隔时间。此触发模式支持读取超时。

  • 自触发与演示触发类似，读码器不断扫描符号并对每次检测到的符号进行解码。

  • 只要触发信号仍然有效，连续触发就可以采集图像，读码器以特定的时间间隔采集图像并尝试扫描每个连续图像所包含的任何符号。

注：并非所有设备的所有触发类型都可用！如需了解设备型号可用触发类型的详细信息，请查看相应的参考手册。

点击底部的高级触发设置链接可导航到 应用详情 步骤中，在此可完成更多设置。

在"高级 选项卡下，可在表视图中设置具体数值。


如果选择了调谐照明箱会怎么？

如果设置了调谐照明箱，该设备会调谐照明箱。如果知道要使用哪些照明设置，禁用它，这样调谐就不会撤销预置项。


如果选择了彻底调谐会怎样？

选择此选项将强制调谐照明箱。禁用彻底谐且读码器用主照明设置成功读码（序列中的第一个）后，它会停止以尝试其他照明箱组合。

如果彻底调谐开启，读码器将继续尝试所有组合以寻找最佳，而不论第一个是否成功。


如果选择启用过滤器调谐会怎样？

如果选择了启用过滤器调谐，DataMan 设置工具会将过滤器应用到读取的图像。代码是使用哪种过滤器成功读取，之后会显示在图像过滤器下方的调谐结果面板中。


如果选择了调谐时优化焦点会怎样？

如果要在调谐过程中自动优化焦点，请选中调谐时优化焦点选项。


如果选择了调谐后训练代码会怎样？

如果要确保您的设备在调谐后训练读取的代码，请选中调谐后训练代码。发现的代码将显示在 DataMan 设置工具窗口的底部。

注：使用此功能时，DataMan 设置工具将只识别发现的代码类型，因此不使用任何其他要读取的代码类型。


如果选择了排除环境光选项结果会怎样？

如果不想仅为调谐过程自动选择环境光结果（除非是固定式读码器的主要照明类型），请选中排除环境光结果。


如何使用测试按钮？

点击测试按钮来测试带配置的设备，无需中断生产。

如果选择了外部（任何非 演示或自触发模式）实时按钮下方的触发类型，可以在测试模式下自动触发读码器。使用触发器开和触发器关次数可以在测试模式下自动触发读码器。为方便起见，可以查看计算的触发频率。

可以减少触发器开或触发器关的次数以缩减周期时间，从而增加触发频率。

注：根据读取设置、要读取的代码和连接接口的不同，可能会有速度限制，在更高的速度下，可有助于禁用图像传输。

以下是一些典型用例：

  • 触发器开 = 20 毫秒，触发器关 = 1980 毫秒 -> 频率 > = 0.5 赫兹（默认值）
  • 触发器开 = 20 毫秒，触发器关 = 980 毫秒 -> 频率 = 1 赫兹
  • 触发器开 = 20 毫秒，触发器关 = 480 毫秒 -> 频率 = 2 赫兹
  • 触发器开 = 20 毫秒，触发器关 = 180 毫秒 -> 频率 = 5 赫兹
  • 触发器开 = 20 毫秒，触发器关 = 80 毫秒 -> 频率 = 10 赫兹
  • 触发器开 = 20 毫秒，触发器关 = 30 毫秒 -> 频率 = 20 赫兹


读码性能面板用来做什么？

通过右侧的读码性能面板，可以监视解码时间和实时读码率。点击清除按钮以重置图形。


如何知道调谐何时结束？

正在进行调谐时，调谐按钮将更改为取消。调谐结束后，按钮重新改回为调谐。此外，还将看到读码器前红色 LED 灯最佳照明的一个更新图像。

还可以监视右侧调谐结果面板上的调谐过程。调谐过程在右下角有一个进度条，它显示实时调谐的状态。


如何调节图像曝光？

单击调谐自动选择最佳的读取设置。如果要进一步配置调谐，点击调谐按钮的最右侧以显示高级设置，或导航至调谐面板。

单击优化亮度自动设置建议的照明强度。如果选定了手动曝光控制，这项功能可用。要启用手动曝光或进一步设置，单击优化亮度按钮旁边的图标。或者，向左或向右拖动图像下方的曝光滑块，或键入曝光值。如需进一步设置，单击右边文本框旁边的图标。

注：如果一个 RoI 尺寸小于 144，优化亮度和调谐不工作。


如何调节图像焦点？

单击调谐自动选择最佳的读取设置。不仅可以启用优化亮度和训练代码功能，也可以启用优化焦点功能（如果可用）。

单击优化焦点尽可能设置最佳焦点。这项功能只有在读码器装有液体镜头时才可用。如需进一步设置，单击 优化焦点 按钮旁边的链接。或者，通过拖动使用图像下方的 焦点 滑块，或输入焦点值︰值可以是屈光度或距离（毫米）。还可以使用+和-按钮来更改值，但要注意+减小屈光度值，而-增加屈光度。滑块上橙色区域（大于 500 毫米）距离不可用，因此将滑块移动到此区域时，设置工具会自动禁用距离设置。将滑块或设置的值移出橙色区域可重新启用距离。点击 高级焦点设置 链接可导航到 焦点设置 面板中，在此面板中可实现更多设置。

也可以在试用实时显示时，更改焦点值设置。


如何快速打开或关闭读码器所有的照明？

在显示 LED 照明的图像上单击右键。在列表中，选择想要打开或关闭的照明。

在图像中点击各个单独的照明也可将其打开或关闭。

更改会根据选择立即生效。


什么是符号诊断（需要的功能键）？

符号诊断是一项从未读取条形码的设备提供图形化反馈的功能。通过查看反馈，可以解决条码无法解码的问题。从提供的反馈可以获知以下问题（在条形码区域内）︰

  • 未找到开始或停止样式（代码上的橙色箭头）。被箭头指定的区域无法解码。失败原因如下（要详细了解每种情况的图像，请查看相应的技术说明）：

    • 开始或停止样式已剪切或损坏

    • 代码被剪切（由于图像边界或被物体挡住代码）

    • 图像质量下降（通常，但不是总是由照明质量造成）

    • 条形码标签翘曲和折叠

  • 条形码内部损坏/打印错误（代码上的红色矩形区域）。矩形内的区域是找到的损坏或有打印问题的位置。常见打印问题的例子（要详细了解每种情况的图像，请查看相应的技术说明）：

    • 渗漏的墨水把条码合成一片

    • 条码错误打印导致厚度降低，超出解码公差

  • 静区不足（代码上的洋红色矩形区域）。当条形码的一侧或两侧的空白不足时，会出现静区违规。视条码符号的不同，读码器会允许一些静区违规。静区违规通常发生在条形码周围的文本或矩形过于靠近条形码的一侧或两侧，或由于代码被图像边界剪切（要详细了解每种情况的图像，请查看相应的技术说明）。

  • 校验和验证失败（代码周围的蓝色矩形）。校验和验证失败的常见原因如下（要详细了解每种情况的图像，请查看相应的技术说明）：

    • 条形码损坏（可以这样折叠和对齐条形码，以便解码所有的数据字符，但仍不读取，因为未能通过校验和验证）

    • 打印了不正确的样式（编码的字符串与打印的条形码样式不匹配，如果条码符号支持校验和，那么解码器就会显示此类故障）

除了图形诊断外，符号诊断还返回每个未读取结果的可读性指标，显示在未读取代码的左上角。指标可以帮助评估图像或打印质量，有助于改善现有的设置。

符号诊断仅适用于上载的 PNG 图像（操作 > 图像 > 上载图像），它由 Cognex 读码器做标记（不一定是相同的读码器；用读码器保存时自动标记图像）。上载图像后，查看符号诊断反馈的图像面板或快速设置图像窗口。

除了图形诊断外，符号诊断还返回每个未读取结果的可读性指标。像符号对比度和最低边缘对比度等指标可以帮助用户评估图像或打印质量，并有助于改善现有的设置。指标显示在每个未读取条形码的左上角。

下表列出了显示的指标名称与其完整名称之间的映射关系。请参阅可读性指标以了解每个指标测量的内容。

全名 | 显示的名称 | 可能的等级
符号对比度 | C | A、B、C、D、F
最低边缘对比度 | EC | A、F
打印增加量 | PG | A、F
最小反射比 | MR | A、F

注：注：符号诊断是一项专门由功能键激活的功能。


什么是显示的图像设置？

显示的图像设置控制着读码器如何显示响应采集触发信号而采集的图像以及读码器的实时图像。更改这些设置不会影响读码器的性能，只会影响读码器与设置工具之间的图像质量和传输速率。

注：设备正在获取或解码图像时，无法更改一些图像相关的属性（如图像大小、筛选）。

注：保存图像面板上次拍摄的图像（通过拖放）时，显示的图像设置没有任何效果。上次的图像总是以全尺寸（设备的分辨率最大值）保存。

  • 大小：在默认情况下，设置工具会显示每个采集图像整体像素的四分之一或每个实时显示图像的一小部分。选择不同的图像尺寸可使读码器对每个图像进行子采样，这可极大提高从读码器到设置工具的传输速度，但图像的精细度会有所降低。

  • 格式：在默认情况下，读码器以 .jpeg 格式储存采集的每个图像，它所需内存较少，并且能比 .bmp 格式的图像以更快的速度从读码器传输到设置工具。

  • 质量：仅在使用 .jpeg 图像格式时才可用。该滑块可调节内部参数，使读码器在采集的图像上执行流畅的操作，可降低或提高从读码器传输至设置工具的速度。


对要使用的图像可以使用什么设置？

实时显示期间可以根据要查看的图像选择原始或过滤。进入图像过滤面板进行更多设置。

注：此选项在 DM262 中不存在。


如何更改红色照明 LED 的亮度？

在照明分组框下方，使用亮度滑块更改读码器用来照亮检验符号的红色照明 LED 的亮度。

也可以单击照明设置下方显示图像上的 LED 组。

请注意，并非所有的平台和照明配置都支持强度控制。关于受支持的配置，请参看下表：

平台 | 强度控制 | 个别 LED 或灯段开/关 | 备注
DM150 | 否 | 是 | 多种 LED 颜色
DM260 | 否 | 是 | 多种 LED 颜色
DM300 | 是 | 否 | 多种 LED 颜色
带 HPIL 的 DM300 | 是 | 是 |


为什么高频灯复选框禁用？

要启用高频灯，必须关闭内部照明。要关闭内部照明，右键单击照明设置中的读码器图像并单击全部关闭。


高频灯框中的始终打开启用选项用来做什么？

如果内部照明关闭而启用 高频灯，并且如果长时间内没有产生触发，在关闭高频灯 (HFL)后可以在此处设置超时。超时以秒为单位指定。将超时值设为 0 可关闭超时处理程序且灯始终保持打开。更改操作模式或打开实时图像视图将关闭 HFL。


如何使用外部照明源？

在照明与图像设置面板中，为照明类型选择外部。

要使用外部照明，按快速参考指南所述将其连接至外部线路。

  • 输出线路必须作为灌电流接入。

  • 共用输出必须为逻辑接地。

  • 电流的限制为 50 mA @ 24 VDC。


如果同时使用外部光源与连接至一条输出线的频闪，会发生什么情况？

频闪输出信号在专用照明输出前出现。外部光源输出延迟。在图像采集过程中，两个照明灯都打开。


预充电时间适用于什么？

此设置适用于专用照明连接器和系统设置面板中配置的离散 I/O。


预充电时间的不同外部照明选项有哪些？

  • Cognex 外部：Cognex 外部照明灯

  • Cognex HPIA：Cognex 高功率照明配件

  • SVL 条形灯：智能视觉灯 YL、ODL 和 L 系列

  • CCS 灯：标准 CCS 灯

  • 自定义光源灯：任何其他外部照明


前盖过滤器设置用来做什么？

可以从下拉框中选择当前使用的镜头盖类型。


如何在每个采集的图像内指定兴趣区？

通过更改图像尺寸（兴趣区）子面板中的设置。


选中了传输并显示图像，为什么看不到图像？

如果启动触发器中断了图像传输，就无法传输任何图像。而且，读码结果历史记录窗格中较旧的结果可能不包含图像。

如果输出延迟时间短于读码器需要读取图片并进行结果解码的时间，设置工具将不能从读码器接收结果图像。


何时应使用训练代码按钮？

在默认情况下，读码器会使用代码类型设置面板中所有启用的代码类型尝试对符号解码。训练代码按钮仅在单击、连击和连续和自触发模式下启用，采集新图像并解码，熟悉图像中的符号属性。使用希望的代码类型训练读码器可减少对连续性符号解码所需的时间，这是因为读码器无需循环通过启用的代码类型。

如果要解码符号的代码类型一致，使用训练代码功能。但是请注意，如果显示的代码类型不是训练所用的代码，读码器就无法对符号解码。单击不训练代码按钮禁用训练参数，并允许读码器对照所有启用的代码类型检查下一个符号。

要训练读码器对单个图像中的多个代码解码，有关更多信息，参见代码类型设置下方的问题要解码多个符号，如何进行训练？。


为什么与代码类型和型号大小相同的代码作为训练代码不能解码？

确保训练代码与要解码代码的尺寸相差不超过 10%。


什么是实时显示？

如果启用实时显示（通过单击顶部任务栏或操作选项卡上的实时显示图标），图像显示不断显示读码器所见到的内容。不尝试对符号解码时，可以使用此模式查看读码器读取的内容。

要更改实时显示图像的大小和质量，进入显示的图像设置面板。

注：该选项不适用于 DM262 和 DM362。


如何提高图像传输速度？

如果选择传输并显示图像复选框，设置工具会在每次解码操作时传输采集的图像。如果在传输当前图像时再次收到触发信号，读码器将放弃部分传输的图像并开始传输新的图像。

图像传输速度视读码器执行的图像压缩程度而定。通过选择显示的图像设置选项，可以控制影像的压缩值。减小图像大小或降低图像质量可提高传输速度。


如何查看连击触发期间获取的所有图像？

要查看连击触发期间采集的所有图像：

  1. 确保将触发类型设置为连击。
  2. 核取传输所有图像复选框。

结果历史记录面板包含多触发期间采集的图像。要查看幻灯片，必须单击读码结果历史记录窗格中的结果。

图像数量应与照明与图像设置面板中设定的连击长度相匹配。

注：如果输出延迟时间短于读码器需要读取图片并进行结果解码的时间，设置工具将不能从读码器接收结果图像。


传输所有图像的作用是什么？

核取传输所有图像，以查看与每次触发相关的所有连击图像。

选择后，无论图像是否包含解码结果，连击触发模式下采集的所有图像都可从结果历史记录面板中存取。

只有将照明与图像设置面板中的触发类型选择为连击，此选项才可用。

注：如果输出延迟时间短于读码器需要读取图片并进行结果解码的时间，设置工具将不能从读码器接收结果图像。


如何使读码器对焦？

选中焦点反馈并单击实时显示。随着读码器的移动，会看到显示焦点值一栏。此栏根据焦点的清晰度呈现红色、黄色或绿色。此栏以绿色显示时，表示代码清晰，可以对图像解码（停止实时显示后）。

确保实时显示使用原始图像，而不是过滤图像。

注：DM262 不支持此功能。


虽然 Data Matrix 代码使用了焦点反馈，但焦点只有在很接近时才清晰，该怎么办？

首先，确保启用了 Data Matrix 代码类型。然后进入调谐并单击调谐。选取最佳参数后，就可以对图像解码了。


代码细节


如何快速禁用所有代码符号？

点击代码详情应用步骤中基本选项卡顶部的取消所有条码符号选项，或按下 Ctrl+D 快捷键。


为什么所有的代码类型复选框都禁用？

可以使用连续符号的预期条码训练读码器。如果读码器经过训练，就无法更改代码类型是启用还是禁用。这时必须不训练读码器以启用或禁用各种代码类型。


如何调整高级代码类型设置？

点击代码详情下的高级 选项卡，完成更多设置。


读码器会自动区别不同的代码类型吗？

读码器可以自动检测、识别设置工具中启用的任何代码类型并解码。


为什么无法更改条码符号，为什么所有的设置都呈灰色？

只有在手动和演示触发模式下才可以启用和禁用代码类型。


单个代码类型支持哪些度量？

下表列出了哪些代码类型支持哪些度量。

度量 | DataMatrix ISO/IEC 15415 | DataMatrix AIM-DPM | QR | PDF417 | Code 128 UPC/EAN, Code93, Code39, I2/5, Codabar, MSI
symbolContrast | x | x | x | ? | x
UEC | x | x | x | x | ?
axialNonUniformity | x | x | x | ? | ?
printGrowth | x | x | x | ? | x
modulation | x | x | ? | ? | ?
fixedPatternDamage | x | x | ? | ? | ?
gridNonUniformity | x | x | ? | ? | ?
extremeReflectance | x | x | ? | ? | ?
reflectMin | ? | ? | ? | ? | x
edgeContrastMin | ? | ? | ? | ? | x
singleScanInt | ? | ? | ? | ? | x
multiScanInt | ? | ? | ? | ? | x


限制启用代码类型的数目可提高读码器性能吗？

为了达到最佳性能，只启用那些预计会读取的代码符号类型。


Data Matrix属性中使用类型被禁用

除非从代码类型设置面板中选择 ID Max 算法，否则禁用 IDMax 使用类型。

除非从代码类型设置面板中选择 ID Quick 算法，否则禁用 IDQuick 使用类型。

IDQuick 使用类型

许多应用可以使用解码速度最快的速度优先设置。要解码的符号出现扭曲、歪曲或背景不均匀的情况时，选择读取率优先。扩展用于读取高品质的直接部件标记 (DPM) 2-D 码，包括点阵符号。


"Data Matrix属性"中打印变形

打印变形选项可使读码器可以接受部分残缺的代码。如果必须读取不规则打印的代码或连续标签代码上有柱状扭曲变形，使用中等（默认值） 。


"Data Matrix属性"中符号损坏

符号损坏可使读码器接受部分损坏的代码。如果读取经受正常磨损的代码，使用中等（默认值）；如果由于掩蔽或磨损，代码的固定样式有明显损坏，使用极端以启用 DPM 数据矩阵读取的突破性技术 PowerGrid (TM)。

注：启用的国家电网公司 (TM) 通过设置极端设置需要购买相应的功能键。


忽略极性-Data Matrix属性

忽略极性-Data Matrix属性

选择后，处于已训练状态的设备就能读取与训练代码极性相反的代码。

选择后，处于已训练状态的设备就能读取与训练代码方格大小稍有不同（+/- 一级）的代码。也就是说，如果训练了 12x12 的 Data Matrix 代码，由于方格大小可变，那么也就能够确定大小为 10x10 或 14x14 的代码了。


EAN.UCC Composite 属性有哪些不同的设置？

  • 标准（线性和 2D）：由与相邻 2D 组成要素（解码补充数据，如批号或到期日）相关联的线性要素（解码物品的主要标识）组成。

  • 仅线性：由对物品主要标识进行解码的线性要素组成。


什么是 CC-C？

CC-C 是三个 EAN.UCC 2D 复合要素之一，专指首个数据字码位置中带 920 字码的 PDF417 符号，作为连接标记表明 EAN.UCC 数据压缩。


Data Matrix 属性：仅 DataMan X 型号读码器

进程控制度量

在 Data Matrix 属性面板中启用一组进程控制度量后，可以使用标准格式化面板的度量选项卡。

度量还可以通过脚本存取。如果未启用任何进程控制度量，则会返回 -1。

进程控制度量为-1或NA

当符号的印刷或图像质量非常差，不能用基准解码算法测量进程控制度量时，度量将报告为 -1 或 NA。例如，通过使用图像过滤功能提高印刷或图像质量。


什么是 DataMatrix 质量度量？

有关代码质量度量的信息，请参阅 DataMan 通信与编程指南。


1D 条码符号属性

短静区

核取短静区选项后，可以对下列 1-D 符号静区执行范围更宽泛的搜索：Code 128、Code 39 和 Code 93。

短高度代码

选中短高度代码选项可提高对极短极宽符号的解码能力。

更改方向

在默认情况下，DM300X、DM503QL 和 DM503X 读码器的方向设置为全方位。

在默认情况下，DM300L 和 DM503L 读码器的方向设置为栅栏（如下所示）。

代码方向被禁用

如果已用训练方向功能训练了 1D 代码，则代码方向禁用。

用于数据格式化的进程控制/代码度量

在代码质量面板（需要功能键）中启用 1-D 质量指标后，可以在标准格式化面板的指标选项卡中使用它们。

度量值还可以通过脚本存取。如果未启用任何过程控制指标，则返回 -1。

进程控制/代码质量度量报告为 -1 或 NA

当符号的印刷或图像质量非常差，不能用基准解码算法测量进程控制度量时，度量将报告为 -1 或 NA。例如，通过使用图像过滤功能提高印刷或图像质量。

这意味着为了解码，必须将代码对齐该方向。

如果代码与传感器保持垂直，将该方向改为梯子（如下所示）。

这意味着为了解码，必须将代码对齐该方位。

如果代码与栅栏对齐或与传感器垂直，将该方向改为栅栏和梯子。

请注意， DM300L 和 DM503L 读码器仅支持梯子和栅栏方向。

1D数据拼结

数据拼接通过合并和扩展部分读取来提高读码效率。只有安装了功能键 1DDataStitching，才能激活该功能。

使用类型

扩展策略可以对较难读取的条形码解码，但比标准策略需要更长的时间。


1D 条码符号属性：使用类型之间有何不同？

扩展策略可以对较难读取的条形码解码，但比标准策略需要更长的时间。


1D 条码符号属性：输出前应如何设置最小解码量？

设置高数量以增加解码稳定性。如果优先考虑性能速度，则设置低数量。


指定代码大小的好处

指定明确的代码大小可提高读码器对符号有效解码的能力。如果读取不同的代码大小，选择任意。


Code 39 属性

  • Full ASCII 启用 Code 39 扩展码。

  • 校验字符仅对含有效校验字符的符号解码。

  • 传输校验字符包括含解码数据的校验字符。

  • 转换为代码 32 转换代码 39 字符集代码 32 如果选中。


Interleaved 2 of 5 属性

  • 校验字符仅对含有效校验字符的符号解码。

  • 传输校验字符包括含解码数据的校验字符。


Code 25 属性

  • 校验字符仅对含有效校验字符的符号解码。

  • 传输校验字符包括含解码数据的校验字符。


Pharmacode 属性

指定代码大小和方向的好处

指定明确的代码大小和方向可提高读码器对符号有效解码的能力。

在任何符号中数据字符数和线条数

数据字符: 线条

  • 1: 3 注：读码器读取的字符代码中，只有 1 个有 3 个或以上的线条。 以上仅指6、7、8 和 9。

  • 2: 3 至 6

  • 3: 6 至 9

  • 4: 9 至 13

  • 5: 13 至 16

  • 6: 16


Codabar 属性

  • 校验字符仅对含有效校验字符的符号解码。
  • 传输校验字符包括含解码数据的校验字符。
  • 传输开始和停止字符包括含解码数据的开始和停止字符。


MSI 属性

  • 校验字符仅对含有效校验字符的符号解码。
  • 传输校验字符包括含解码数据的校验字符。
  • 校验和计算方法可选择用于计算校验和的方法。


DataBar 属性

  • GS1 DataBar 有限：对线性条码中含有指标数字为 0 或 1 的 14 位 EAN.UCC 商品标识解码，它用于不在销售点扫描的小件商品上

  • GS1 DataBar：对线性符号中的全部 14 位 EAN.UCC 商品标识解码，可由已适当编程的销售点扫描器进行全方位地扫描

  • GS1 Databar 展开：长度可变、种类扩展的代码类型能够对 14 位 GTIN 和其他数据，包括有效日期、原产地和多达 74 个数字或 41 个字母数字字符的序列号解码。


Postal 属性

  • POSTNET：由美国邮政局用于协助收发邮件的一种条码符号。ZIP 码或 ZIP+4 码以这种的独特代码类型编码，它用不同高度的线条对数据编码。

  • PLANET：邮政字母数字编码技术 (Postal Alpha Numeric Encoding Technique, PLANET) 条码由美国邮政局采用，用于在分发过程中识别和跟踪邮件。与 POSTNET 一样，它以不同高度的线条对数据编码。

注：只有出现在栅栏位置，才可以解码邮政编码。


支持的Quick Response (QR) 代码版本

QR (Quick Response) 代码是 2-D 代码类型，具有用来对数据解码的一组方形黑白模块的特征。读码器可以辨认三种不同的类型：

  • 型号-1: 原版

  • 型号-2: 增强版

  • Micro QR Code：非常小的 QR 代码，适用于比其他 QR 码数据量更少和空间更小的应用场合


QR Code 属性

忽略极性

选择后，处于已训练状态的设备就能读取与训练代码极性相反的代码。

可变栅格大小

选择后，处于已训练状态的设备就能读取与训练代码方格大小稍有不同（+/- 一级）的代码。也就是说，如果训练了 25x25 的 QR 码，由于方格大小可变，那么也能够对大小为 21x21 或 29x29 的代码解码了。

最大栅格大小

最大网格尺寸允许对尺寸大于 49 的 QR 码解码。可以拖动滑块或向右侧的文本框键入特定的代码尺寸。

QR代码质量度量

有关代码质量度量的信息，请参阅 DataMan 通信与编程指南。


QR Code 属性：仅 DataMan X 型号读码器

用于数据格式化的进程控制度量

在 QR Code 属性面板中启用进程控制度量之后，可以在标准格式化面板的度量选项卡中使用。

度量还可以通过脚本存取。如果未启用任何进程控制度量，则会返回 -1。

进程控制度量为-1或NA

当符号的印刷或图像质量非常差，不能用基准解码算法测量进程控制度量时，度量将报告为 -1 或 NA。例如，通过使用图像过滤功能提高印刷或图像质量。


DotCode 属性

指定数据行数和列数

指定最小和最大数据行数和列数可以提高读码器对符号可靠解码的能力。

极性设置

可以设置该设备作为与其背景相关的模块（点）要定义的是什么。亮中暗设置意味着设备扫描并解码明亮背景上的暗点，而暗中亮则相反（黑暗背景上的亮点）。

默认情况下，任一设置都会扫描其各自背景上的这两种模块，但这可能会导致解码速度较慢。


ID Max 和 ID Quick 算法有何不同？

ID Quick 可对格式较好、具有高对比度的代码提供高速解码，而 ID Max 采用了先进的图像处理和图像分析技术，可确保由激光、打标、ECE 和喷墨技术制作的 DPM 代码具有最高解码率。


如何启用多代码结果？

可以为所有触发器类型设置多代码，但只会在单次、手动、多次和连续触发类型中才会生成多代码结果。演示和自触发模式将找到的结果显示为单独的结果。

在 代码详情 应用步骤 高级 标签中，通过 代码数 字段确定图像的最大代码数。也允许根据应用程序来指定读取器要解码的每个符号类型的数量。为了获得最佳性能，要读取的代码数量应等于个别代码类型的最大代码数量字段总和（例如总数量为 3，其中 DataMatrix 设为 2，1D 设为 1）。要读取的单个代码数量不能超过整个代码数量字段中的数值。


多代码

允许的部分结果

图像包含的代码较代码数量指定的代码少时，启用允许部分结果允许读码器返回成功的读码结果。

允许相同的 1D 符号

即使读码器检测到一个以上长度、代码类型和数据字符串都相同的符号，启用允许相同的 1D 符号允许读码器返回图像中的多个结果。

允许相同 1 D 符号仅适用于两个或更多相同 1 D 符号，在一个单一的图像中出现。即使发现同一个相同的符号，允许相同 1 D 符号控制项也不会影响一个接一个获取的图像（无论何种模式）。

排序优先

排序优先列表可确定读码器报告多个结果的方式。

  • 使用向上和向下按钮可将任何选项移到更高或更低的优先级别。

  • 使用逆序按钮可对所选选项逆序排列。

  • 请注意，排列选项（从上到下或从左到右）是指符号的中心。

  • 在连击或连续触发模式下使用图像顺序，早期图像中的解码符号在后期图像中的解码符号之前报告。


QR Code/MaxiCode最大代码数量呈灰色

可以读取含 MaxiCode 的多码图像，但仅对每个图像的一个 MaxiCode 解码。这表明，如果要读取含 MaxiCode 的多码图像，也必须在一般选项卡中启用 QR Code。


训练

在默认情况下，使用一般选项卡中所有启用的代码类型，读码器将尝试对符号解码。使用希望的代码类型训练读码器可减少对符号连续解码所需的时间，这是因为读码器无需循环通过启用的代码类型。但是请注意，如果显示的代码类型不是训练所用的代码，读码器就无法对符号解码。

使用训练选项卡控制已训练代码类型的状态。

除非取消对禁用不训练代码类型复选框的选择并启用增量训练，否则设置工具会禁用读码器不希望训练的代码类型。

训练代码按钮

读码器采集了包含希望在连续图像中出现的代码类型的符号图像后，单击 动作 顶部面板上的 训练代码 。

如果仅读取特定代码类型的符号，单击 训练代码 为所有连续图像中的代码类型准备读码器，直至单击 不训练代码 为止（可以在符号设置面板中看到不训练戴按钮）。

成功训练后，已训练代码类型的 型号信息 将显示读入符号的预期大小，并且将启用 不训练代码 按钮。

要对多个符号解码时训练

设置工具允许在对多个符号解码的应用中将读码器训练成读取一个以上的代码类型。

如果单个图像显示所有希望的代码类型，单击 动作 面板上的 训练代码 训练读码器。已训练代码符号的型号信息将显示读入符号的预期大小，并且为那些代码类型启用不训练代码按钮。

如果单个图像不能提供显示所有希望的代码类型，选择增量训练并为图像中存在的代码类型单击训练代码。然后采集想要训练的其他代码符号图像并单击训练代码，将它们添加到训练读码器解码的现有代码类型集中。启用增量训练后，读码器除保留现有训练参数的同时，还可以提供和训练新的代码类型。

训练方向

仅适用于 1D、Stacked 和 Postal 符号，选择训练方向，使用最新解码符号的角度训练读码器。如果符号以训练角度出现，后续解码操作将更加快速。

注：只有出现在栅栏位置，才可以解码邮政编码。

训练之后将读码器恢复到对任何条码符号的符号解码状态

对于任何已训练的代码类型，必须单击不训练代码，允许读码器对所有符号解码，而不管代码类型是否训练。但是请注意，必须在读码器的一般选项卡中启用符号进行识别。

手动代码训练

如果知道要训练的设备的所有代码参数，可以在手册代码训练下提供这些参数。给出所有的参数后，勾选有效框以训练代码。从现在起点击上面的不训练代码，就可以不训练代码。


如何将不可打印的 ASCII 字符输出更改为键盘可识别的对等字符？

进入通信设置下的不可打印字符面板，并选取已启用。也可以通过启用标准格式化并在完整字符串前后添加 ASCII 命令，来在已转换的字符串前后添加不可打印的 ASCII 命令。


UPC/EAN 属性的不同设置有哪些？

  • 扩展启用对扩展型代码的解码。

  • 补充控制读码器如何对补充代码解码。

  • 删除前导零用于删除解码字符串中的前导零。

  • 允许 EAN8 补充启用对 EAN8 符号中补充代码的解码。

  • UPCE1 已启用启用对 UPC E1 符号的解码。


UPC/EAN 属性：扩展复选框表示什么？

这是一个布尔符号，表示报告的 UPC-EAN 解码字符串是否应扩展到 13 位 EAN13 格式或以标准 UPC-E 6 位数字格式传输。

选中（默认）时，解码的字符串以 EAN-13 格式（例如 0012345000065）传输。未选中时，结果将传输为 <数制> + 6 个数据位 + <校验字符>（例如 01234565）。


应用细节


在 应用详情 步骤中可以进行哪些设置？

在基本选项卡中可以进行触发设置和曝光设置。触发助手、 间隔时间助手和曝光助手可方便地帮您完成这些设置。

在"高级选项卡下，可在表视图中实现更多设置。


触发类型有哪些？

启动解码尝试的触发器可以来自读码器的外部来源，也可以由读码器本身内部的计时机制产生。

配置好读码器以响应外部触发时，任何下列事件都可以向读码器发送信号以执行解码尝试：

  • 按下读码器侧面的按钮

  • 通过 USB、串行或网络连接连接读码器时，发送 DataMan 控制命令 (DMCC) 触发信号

  • 通过 I/O 电缆的触发器线路接收数字输入信号

  • 单击设置工具中的触发按钮

  • 设置工具获得焦点时按下键盘 Ctrl+T

使用任何下列触发类型配置读码器以响应外部事件：

  • 单击触发采集单个图像并尝试对所含的任何符号进行解码。此触发模式支持读取超时。

  • 只要触发信号仍然有效，手动触发就可以采集图像，并在找到符号并解码或触发信号结束时停止。此触发模式不支持读取超时。

  • 连击触发采集一组图像并对这组中第一个检测到的符号进行解码。可以配置每次连击的图像数量和每次图像采集的间隔时间。此触发模式支持读取超时。超时指连击时每个图像所需时间的长短，而不是整个连击的时间。

  • 只要触发信号仍然有效，连续触发就可以采集图像，读码器以特定的时间间隔采集图像并尝试扫描每个连续图像所包含的任何符号。如果读码器对符号解码，就会停止接收触发信号。如果没有对符号解码，只要触发信号保持活动，图像采集就会继续。如果触发信号结束，读码器没有扫描到符号并解码，就会返回无读码结果。

    如果配置读码器以扫描多个符号，读码器在扫描完第一个符号并解码后不会停止采集图像，而是继续扫描符号，直至检测完所需的符号数量或触发信号停止。读码器找到所需的符号数量并解码之前，如果触发信号结束，读码器会返回无读码结果。

    可以控制图像采集之间的时间间隔，并指定触发信号到达和读码器开始图像采集之间的时间延迟。在连续触发模式下，触发间隔间接指定读取超时。

剩下的触发类型不依赖于外部事件，但只要选择就开始采集图像：

  • 演示触发在每次检测到符号时，就会对它连续扫描并解码。

    可以在演示模式中指定几个参数，如读码器是否多次读取同一代码或在扫描下一个符号之前读码器必须等待多长时间。使用系统设置面板和解码设置选项配置演示触发。

    在演示模式下，使用自动曝光设置使读码器确定图像所需亮度的最佳曝光设置。然而，请注意，读码器会使用采集的初始图像来确定这些设置，可能会丢失包含解码符号的图像。可以切换至手动曝光设置并指定成像器曝光的精确设置。

    请注意，对任何特定图像进行解码尝试时，在此期间采集的所有后续图像将会丢弃。

    此触发模式不支持读取超时。

  • 自触发与演示触发类似，读码器不断扫描符号并对每次检测到的符号进行解码。但是与演示模式不同的是，读码器对每个图像尝试解码，并且禁用自动曝光设置，允许读码器自动确定所需图像亮度的最佳曝光设置。

    可以在自触发模式中指定几个参数，如读码器是否多次读取同一代码或在扫描下一个代码之前等待多长的时间。使用系统设置面板和解码设置选项配置自触发模式。在自触发模式下，触发间隔间接指定读取超时。

注：几个固定式读码器有各种型号（短型、长型等），其中有很多仅支持特定触发类型。要了解哪种型号支持哪些触发类型，请查阅相应的参考手册。


触发助手

首先为助手选择工作的触发类型。从下拉列表中选择触发源：未定义、没有或在外部。从助手获取建议的触发模式。触发类型的图片演示帮助您做决定。选择已选中的触发类型并点击保存和关闭。


时间间隔助手

在连击触发、自触发和连续触发模式下，内部助手可帮您做更多设置。可选择三种方式计算必要的数据。在右上角选择计算单位（标准或度量）。

根据测量的物理视场和给定的最大线速度和最长代码大小，点击视场计算可能的最长间隔时间。

如果需要设置镜头代码距离可点击镜头/代码距离选项。从下拉列表中设置焦距并选择代码传输方向。也可以在此设置最大线速度和最长代码的大小。

点击代码元素大小计算最窄代码元素的大小。启用测试模式读取代码。也可以在此设置代码传输方向、最大线速度和最长代码的大小。

从助手底部获取推荐的最大间隔时间。


曝光助手

曝光助手与间隔助手功能非常类似。可以三种相同方式计算：视场尺寸、代码距离和代码元素大小。

根据测量的物理视场和给定的最大线速度，点击视场计算推荐的最大曝光时间。可以启用测试模式读取最小代码。

如果需要设置镜头代码距离可点击 镜头/代码距离 。从下拉列表中设置焦距并选择代码传输方向。也需要在此设置最大线速度。

点击代码元素大小计算最窄代码元素的大小。启用 测试模式 读取代码。也需要在此设置代码传输方向和最大线速度。

从助手底部获取当前推荐的最大曝光时间。


多个读取设置如何与超时设置交互？

启用多个读取设置时，超时分别影响每个设置，而并非将所有设置作为一个整体。其结果就是，在一个触发循环中读取所花的总时间就是启用设置数量与超时量的乘积。


一旦出现有效读取，将会获得更多图像？

不，当读取之前的设置失败时才获得更多的图像。一旦设置生成一个有效的图像，读码器在触发器周期内和解码开始时将不再尝试其他设置。读码器将按优先级顺序，从指定的最高优先级设置开始尝试每个启用的设置，依次进行，直至获得有效读取。


第一次读取后和上次读取延迟后选项之间有何不同？

第一次读取后延迟是在第一次读取给定的代码后开始计时，计时器将不会重置。这意味着，如果读码器在多个图像模式（如连续模式）下，以及如果代码放在读码器前方的时间量等于或超过重读延迟，可能会重新读取代码。

上次读取后每次图像中出现给定的代码就重置计时器。这意味着只要代码放在读码器前方，就不会重读代码。对于时间等于或超过重读延迟的代码，只有从读码器视场中移除才会重读该代码。


如果再次触发读码器，我的代码读取两次，为什么？

重读延迟和相同代码从不读取两次选项仅影响单触发循环内的采集。对于相同代码从不读取两次，触发读码器将清除计时器和上次读取的代码。


什么是相同代码从不读取两次？

相同代码从不读取两次选项启用后，禁止在一行中或单触发序列内两次报告相同的代码字符串。它适用于所有的触发模式，但只对多代码读取有效，因为在单触发序列中获得一个以上代码的唯一方法就是多代码读取。如果未选中相同代码从不读取两次，设备将在指定的代码重读延迟（以毫秒计）后重新读取并重新传输相同的代码。


相同代码从不读取两次在多个读码器同步系统中如何工作？

如果在主读码器中指定 相同代码从不读取两次 并且辅助读码器读取到相同的代码，不论其来源如何，主读码器都会考虑所有结果并过滤掉重复的读数。


什么是延迟模式和代码重读延迟？

延迟模式选项可设置与第一次或最后一次读取相对的代码重读延迟。

代码重读延时（以毫秒计）选项可指定读码尝试次数之间的延时。为这种延时指定非零数值有助于防止数据覆盖连接至读码器的设备。


不重读最近 N 个代码用来做什么？

如果使用了不重读最近 N 个代码选项，阻止设备读取最近N次读取的代码。必须在下框中填写N，否则（如果数字为 0）会禁用此选项。该选项适用于一个触发序列内的所有读取代码。


什么是动作侦测？

动作侦测允许用户设置设备，以在设备的视场中侦测到动作后的一段时间内切换到活动的演示或自触发模式。

动作侦测设置只在触发类型设置为演示或自触发时才可用。动作侦测启用时，设备不考虑图像，而是在后台侦测其视场中是否出现动作场景。

如果处于运转状态，设备会像演示或自触发模式一样积极获取图像。超时设置允许设备从活动的触发模式切换回动作侦测后指定时间段（以秒为单位），但此超时每次会在成功读取代码动作后重设。

可以设置动作侦测灵敏度来定义设备识别何种程度的动作以开启活动的演示和自触发模式。


如何从键盘发送触发信号？

按下 Ctrl+T（设置工具窗口必须处于活动状态）。


为什么 DataMan 在响应单触发时返回多个结果？

这在使用硬件触发器输入线路时可能会出现，因为线路上的信号围绕其最终值振荡，读码器将振荡视为单独的触发信号。增加系统设置面板输入选项卡中的防抖动延时可导致读码器将所有振荡视为单触发信号。


什么是触发延迟和超时值？

在触发延迟组中，可以给延迟类型设置时间或距离，并在读码器接收到触发信号开始图像采集之前指定要等待的毫秒数时长开始和结束时间或毫秒数时长。在符号完全位于视场下方前，知道读码器接收触发信号时使用延迟很有用。仅单击、连击和连续触发类型支持触发延迟。

单触发和多触发模式有开始延迟时间和开始延迟距离，但无结束延迟时间或结束延迟距离。连续模式具有所有可用的延迟类型。

超时值指定读码器尝试对任何检测符号解码的固定时间量。如果在此超时期间读码器无法对符号解码，就会返回到未读取状态，好像图像不包含可检测的符号一样。如果未指定超时，性能可能会受到影响，原因是读码器将在移动到下一个图像之前在当前图像中尝试对任何供选代码解码。


如何调节图像曝光？

演示和手动触发类型使用自动曝光设置，自动确定每个图像中所需亮度级别的最佳设置。采用其中一种触发类型，可以使用生产环境所需的最大曝光设置，或选择手动曝光并设置精确的曝光时间（以微秒计）。

使用手动曝光时，可点击结果历史记录面板上的优化亮度，生成受最大曝光值限制的曝光设置固定值。最大增益系数设置用于设置目标的最大像素亮度。


如何确定连击触发类型的最佳参数？

由于连击触发最适用于移动应用，为了部件在成像器下方移动时采集所需的部件长度，需要确定正确的连击大小和间隔时间。一旦确定了间隔时间，就可以根据部件长度调整连击大小。此计算所需的变量包括：

  1. 线路速度（毫米/秒）

  2. 带静区的代码大小（以毫米计）

  3. FOV = 视场（x 或 y）（以毫米计）

然后，可以使用以下等式确定间隔时间：

间隔时间 = 1000 * （（FOV 2（代码大小）） / 线路速度）

一旦确定了间隔时间，就可以根据采集代码的长度调整连击大小。最大的物体长度（以毫米计）为：

连击大小 * （FOV （2*代码大小））

（2*代码大小）可随所获帧的重叠而变化。这考虑了一个帧（采集）中代码稍微超出视场的情况。（2 * 代码大小）将重叠连续帧之间的视场，使代码可以在下一个帧的视场中查看。


如何设置较长的连击长度？

可以根据该设备现有的资源指定最大的连击长度。在默认情况下，最大连击长度为 202 个图像，但可以增加内存以存储读码器采集的图像来提高它。通过取出当前无助于增加图像数量的图像插槽和减小成像器视场的大小，以增大存储连击图像的可用内存。这可以通过图像尺寸（兴趣区）面板来完成：

  1. 选择图像尺寸（兴趣区）面板。
  2. 选中成像器 FoV 复选框（单击、连击和连续触发模式）并减少成像器 FoV 的大小。

一旦减小，可以在应用详情步骤中增加连击触发长度参数。


如何计算自触发和连续触发模式的间隔值？

时间间隔助手帮你计算数据。点击时间间隔助手 ，可方便辅助设置。

由于自触发和连续触发模式可用作移动应用，为了部件在成像器下方移动时采集所需的部件长度，需要确定正确的间隔时间。此计算所需的变量包括：

  1. 线路速度（毫米/秒）

  2. 带静区的代码大小（以毫米计）

  3. FOV = 视场（x 或 y）（以毫米计）

然后，可以使用以下等式确定大致的间隔时间：

间隔时间 = 1000 * （（FOV 2（代码大小）） / 线路速度）

（2*代码大小）可随所获帧的重叠而变化。这考虑了一个帧（采集）中代码稍微超出视场的情况。（2 * 代码大小）将重叠连续帧之间的视场，使代码可以在下一个帧的视场中查看。


如何快速打开或关闭读码器所有的照明？

在显示 LED 照明的图像上单击右键。可以选择以下选项：

  • 全开

  • 全关

  • 南北

  • 东西

更改会根据选择立即生效。


何时应修改最大曝光？

必须读取移动物体时，减少最大曝光值。


曲线图显示什么内容？

曲线图显示每个可用照明设置的各种亮度级别的当前分数。


最佳结果下的彩点代表什么？

这些点代表上图的一组结果。


必须从调谐的图像中选择一个图像吗？

调谐结束后，设置工具会显示三个或更少的候选图像。最佳图像将自动选择和应用到非易失性存储器，但是也可以选择和应用任何其他候选图像。


如果在多代码设置中使用调谐会怎么样？

如果视场中有一个以上的代码，就只能对其中的一个代码进行调谐。


显示失败，符号未找到。消息，该怎么办？

转至代码符号设置并启用想要解码的代码符号。


格式化数据


数据格式化如何工作？

在 基本 面板中选择需要使用的格式化类型。

通过使用单个条码符号选项卡上的预定义构造块，利用标准面板创建自定义的输出字符串：

  • 输出字符串以前导文本字段中输入的文本开头。

  • 从一般、验证和指标（适用时）选项卡中的列表选择项目，然后点击添加将它们添加到输出字符串。要添加解码数据的特定字符范围，单击设定子字符串范围，然后输入要添加的字符范围（例如 1-3,5,8,10-），然后单击列表中的子字符串并单击添加按钮。

  • 输出字符串也包括任何添加到结束文本字段的文本。

  • 要以回车/换行对结束整个字符串，选择 CR/LF复选框。


为什么"标准" 下会有不同的选项卡？

为不同的代码类型分别指定格式，或使用通用选项卡为任何解码的符号指定数据格式，这优先于指定代码类型的选项卡。


怎样才能使用代码符号指定和通用格式化这两个选项？

使用特殊条码符号选项卡和通用选项卡时， 标准格式化面板采用下列标准：

  • 如果启用，每个单独的结果将通过代码类型指定格式化程序。相同代码类型的多个结果将使用相同的设置分别格式化。

  • 如果启用通用选项卡，个别结果将通过代码类型指定格式化程序（如果启用），然后使用通用选项卡上的格式化规则来增强。对于多个结果（位于支持的读码器上），结果将以选定的分隔符连结或隔开，结尾处无额外的分隔符。连结的字符串将被视为通用选项卡上保留格式化规则的单个字符串。

  • 对于多个结果，连续字符串中的结果顺序为 1) Data Matrix 2) QR Code 3) 1D 代码 4) Vericode 5) DotCode 6) OCR。

  • 任何添加到仅适用于整个解码过程（例如解码时间或触发信号索引）的代码类型指定格式的令牌，将报告此全局值。


如果标准格式化未启用，发送什么数据？

读码器传输完整个解码字符串时，后接回车/换行对。


如何才能只传送解码数据，而不发送回车/换行对？

启用格式化，将全部字符串添加到输出字符串，并确保未选择 CR/LF 复选框。

要只发送回车，在结束文本字段中输入 \r。


什么是输入字符串？

输入字符串是可列为脚本格式中部分读码器属性的格式标记或作为标准数据格式的标记。请注意，不能在设置工作中更改输入字符串的更多属性，其参数仅适用于 DMCC。


如何让 Excel 停止跳过单元格？

默认情况下，读码器会在每个传输代码后面添加回车/换行对。使用键盘连接将传输代码输入到 Excel 时，回车/换行对会导致 Excel 在每个代码后前进两行。为避免此类情况发生，配置读码器使它仅发送回车：

  1. 单击标准格式化。

  2. 在代码类型选项卡中指定正在使用的代码类型。

  3. 选取格式化已启用框。

  4. 单击一般选项卡中的全部字符串。

  5. 单击添加。

  6. 在结束文本的文本字段中输入 \r 并取消 CR/LF 框的选择。


数据验证启用时如何输出解码数据的特定元素？

首先，在 数据验证 面板中选择需要验证的类型。启用格式化数据应用步骤基本选项卡上的基本格式化选项。选择标准选项卡的验证选项卡，然后将所需的数据字段添加到输出字符串，包括企业标识符、序列号、部件号、独特项目和 GS1 应用标识符。


在标准选项卡的数据字段中，一般选项卡里个别选项是什么？

  • 子字符串：在符号中解码的子字符串。要使用此选项，必须指定子字符串的范围。

  • 全部字符串：符号中解码的全部字符

  • 解码时间：读码器对符号解码的时间量，以毫秒为单位。这个时间段不包括图像采集、等待图像处理、通讯时间和其他处理（例如，数据格式化）。

  • 触发时间：接收触发信号和完成解码操作之间的时间量，以毫秒为单位

  • 代码类型：解码符号的代码类型

  • CR/LF：换行回车

  • TAB：制表符。

  • SP：空格字符。

  • 代码类型标识符：ISO/IEC 15424:2008 规定的代码类型识别符

  • 模块大小：符号中每个模块的宽度（或高度），以像素计

  • 代码位置：解码符号每个角的图像坐标

  • 代码方向：对符号解码的方向以度数为单位报告。顺时针旋转的解码的符号被认为是积极的变化方向。

  • 对比度：使用 0 和 1 之间的值表示解码符号的对比度总量。高值表示符号中的明暗模块有大范围的灰度值，而低值表示明暗模块由相似的灰度值组成。

  • UEC：符号中未使用的纠错量。纠错是指对因符号破坏而丢失数据的重建或替换方法。100是个理想值。1D 条码总是返回 -1。

  • 输入字符串：接收的（串口或以太网）输入字符串。

  • 过滤时间：以毫秒 (ms) 为单位的过滤时长。

  • 结果来源：设备的名称。

不论读码器是否连接至设置工具，所有以下值都将增加。

  • 读码总数：解码符号的总数

  • 未码总数：收到触发信号但未对符号解码的数量

  • 触发信号总数：触发信号总数 = 读码总数 + 未码总数 + 丢失的触发信号总数

  • 丢失的触发信号：检测到触发信号时由于没有可用的图像缓冲而丢失的触发信号数量

  • 触发信号索引：读码器检测的触发信号总数。

无论是在进程监控面板中清除进程统计数据，还是在读码器重新启动后，随时重置为 0 的值如下：

  • 总读取数

  • 未码总数

  • 总触发器

  • 丢失的触发器

触发索引只有在读码器重启后，而不是在清除进程统计数据后才重置为 0。


如何模拟 Alt 键、Ctrl 键或 Shift 键组合？

要使用此功能，可使用四个转义序列：\ALT-、\CTRL-\、SHIFT- 和 \K。\ALT- 用于 <ALT 键> 序列，\CTRL- 用于 <CTRL 键> 序列，\SHIFT- 用于 <SHIFT 键> 序列，\K 用于特殊键。请注意，反斜杠后面的按键字母需要大写，否则就不能识别特殊的按键组合。

在标准面板的前导/结束文本字段中输入此序列。

支持的特殊键盘序列

应使用下列格式：

\ALT- 后接键名，再接 ;

或者

\CTRL- 后接键名，再接 ;

或者

\SHIFT- 后接键名，再接 ;

或者

\K 后接键名，再接 ;

必须使用终止分号来区分带相同前缀的序列，否则就可能任意解释按键序列，例如 \KF11 经检测就毫无意义，它的意思是按 F11 键还是按 F1 键之后再按 1 。

请注意，如果广义空格的位置输入连续的 2 个 Esc，它们也会被应用于未读码结果中。

支持的按键序列和按键

以下列表包含当前支持的按键组合：

  • ALT-A 至 ALT-Z

  • CTRL-A 至 CTRL-Z

  • CTRL-F1 至 CTRL-F12

  • SHIFT-F1 至 SHIFT-F12

  • F1 至 F12

  • ALT-F1 至 ALT-F12

  • PageUp、PageDown、Home、End、箭头键（上、下、左、右），Insert、Delete、Backspace、Tab、Esc、Print Screen、GUI（左、右）键

    这些按键的转义序列如下：

    • PageUp -> \KPup;

    • PageDown -> \KPdn;

    • Home -> \KHome;

    • End -> \KEnd;

    • 上箭头 -> \KUar;

    • 下箭头 -> \KDar;

    • 左箭头 -> \KLar;

    • 右箭头 -> \KRar;

    • Insert -> \KIns;

    • Delete -> \KDel;

    • Backspace -> \KBksp;

    • Tab -> \KTab;

    • Esc -> \KEsc;

    • Print Screen -> \KPrtScr;

    • 左 GUI -> \KLGui;

    • 右 GUI -> \KRGui;

  • 暂停输出 -> \KPAUSE;

以下是一些例子：

  • 要生成 <ALT-V> 序列，使用 \ALT-V；

  • 要模拟按下 <F10> 键，使用 \KF10；

  • 要模拟按下 <Home> 键，使用 \KHome；

  • 要启用/禁用记事本中的状态栏 (<Alt-v><s>)，序列应为 \Alt-v;s

如果使用的序列不正确或不完整，标志转义序列的这两个字符将会忽略。在这种情况下，将跳过转义序列的前两个字母，发送剩余的字符。例如，\ALT-M11;序列是无效的，结果将显示LT-M11;


如何测试数据格式化？

使用页面底部的测试按钮以测试结果如何显示。

扫描一个符号并在状态栏中查看格式化的结果。也可以选择结果历史记录面板，然后读码。结果历史记录会列出指定的格式化结果。


什么是输出选项功能？

使用输出选项功能，能以不同格式输出所需的输出数据元素。例如，如果选择了逗号并已选择输出完整字符串加条码符号类型，则输出结果为完整数据字符串，加逗号，再加文本Datamatrix。要测试不同的输出，可以选择特定的输出类型，然后选择测试按钮以查看相邻显示窗口中的输出。请注意，如果选择了数据验证并且代码未能通过数据验证，输出选项功能将不启用。


测试按钮为何呈灰色？

仅在首次成功解码后才能测试代码。


可以使用十六进制或八进制 ASCII 代码指定字符吗？

在前导文本和结束文本字段中，可以将字符指定为 \nnn，此时 nnn 为八进制 ASCII 码。通过输入 \xnn，可以按十六进制指定字符，此时 nn 为十六进制 ASCII 码。

也可以使用以下预定义的代码：

  • \a 警报 (ASCII 7)
  • \b 退格 (ASCII 8)
  • \E ESC (ASCII 27)
  • \f 换页 (ASCII 12)
  • \n 换行 (ASCII 10)
  • \t 水平制表 (ASCII 9)
  • \r 回车 (ASCII 13)
  • \v 垂直制表 (ASCII 11)
  • \\ 反斜杠 (ASCII 92)


读码器在不读码时传输什么？

如果读码器无法读码，通常不会传输任何数据。如果想知道由于读不到数据而看不到任何输出的原因，通过使用基本面板中的 未读取输出字符串，可以指定最多 32 个字符的特定字符串。


什么是代码位置结果？

对于 DataMatrix 符号，代码位置表示符号四个角的报告位置。读码器返回 4 对座标：

  • 第一对表示扫描器样式的交叉。

  • 第二对表示水平扫描器样式和垂直定时器样式的交叉。

  • 第三对表示定时器样式的交叉（沿对角线与第一对相反）。

  • 第四对表示垂直扫描器样式和水平定时器样式的交叉。

Cognex 建议选择分隔符（如逗号）来分隔每个值，使结果数据易于阅读。


仅 DataMan X 型号读码器：如何将进程控制度量用于数据格式化？

在Data Matrix 属性或 QR Code 属性面板中启用进程控制度量之后，可以在标准格式化面板的度量选项卡中使用。

度量还可以通过脚本存取。如果未启用任何进程控制度量，则会返回 -1。


仅 DataMan X 型号读码器：进程控制度量报告为 -1 或 NA 时是指什么意思？

当符号的印刷或图像质量非常差，不能用基准解码算法测量进程控制度量时，度量将报告为 -1 或 NA。例如，通过使用图像过滤功能提高印刷或图像质量。


应该选择哪种数据格式化方法？

可以使用基本格式化（标准或 Perl 样式），或在脚本面板的数据格式选项卡中编写自己的 JavaScript 脚本程序。这两种方法的区别如下：

  • 基本格式化允许拖放预定义的数据格式化元素。

  • 除格式化读取的结果和数据外，脚本格式化还允许写入能够使读码器执行发哔音或拉起 output 1 等操作的脚本。


通信选项卡的用途是什么？

在此选项卡中，可以编辑自定义的通信协议脚本。


脚本格式化的限制是什么？

在脚本格式化中，限制为两个自定义事件和覆盖系统事件。


何处能找到脚本示例？

下列选项可将脚本插入脚本面板的主窗口：

  • 单击顶部工具栏的插入代码片断按钮，并按需从列表中选择相应的代码片断。

  • 用鼠标右键单击主窗口任意位置，并选择插入代码片断...。按需单击列表中的相应代码片断。

  • 按下 Ctrl-K、X 键

注：如果插入代码段按钮未处于活动状态，则设备上运行的固件版本不支持当前脚本选项卡的代码段。


FTP 存储选项卡的用途是什么？

此选项卡用于图像和代码质量报告的 FTP 文件名生成。


如何载入脚本？

通过点击功能区菜单进行存取，然后点击打开脚本选项。可以使用保存脚本按钮将脚本保存。

注：脚本只支持 UTF-8 字符编码！


什么是补充字词选项？

通过以下方法，可以将脚本的字词补充完整：

  • 在上方工具栏中单击补充字词按钮

  • 用鼠标右键单击主窗口任意位置，并选择补充字词

  • 按下 Ctrl-K、W

然后，可以从对象列表中选择，以插入脚本。


如何快速编辑脚本？

使用上方工具栏的剪切、复制或粘贴按钮，或者用鼠标右键单击主窗口任意位置并选择剪切、复制、粘贴、删除或全选。


为什么在选择系统 -> 保存设置后所有变量都重置？

每当脚本更改或编辑器焦点离开时，传送到读码器的脚本会导致脚本引擎的上下文无效。脚本上下文无效会导致所有变量被重置。


仅 DataMan X 型号读码器：如何将进程控制度量用于数据格式化？

在 Data Matrix 属性或 QR Code 属性面板中启用进程控制度量之后，还可通过脚本存取。如果未启用任何进程控制度量，则会返回 -1。


如何使用脚本查看设备日志中的错误？

使用 Throw() 命令报告出现的反常情况（例外），当设备未连接到设置工具时，设备日志中会出现错误。可以通过单击安装工具菜单栏中的 系统，然后单击显示设备日志访问错误日志。

当设备连接到设置工具时，例外情况会出现在脚本面板中的脚本下方。


何处可以获取有关脚本格式化的更多信息？

有关更多信息，请参见 DataMan 通信和编程指南，可通过 Windows 开始菜单或设置工具帮助菜单获取。


在代码输出中如何设置延迟？

要在代码输出中设置暂停，可以添加序列 \Pause<time>; 到数据格式化面板中的文本字段。

<time> 包含一个以毫秒为单位的值，例如，要等待 4 秒钟，序列为 \Pause4000。

配有 USB HID 或 RS232 可使用此功能。对于 RS232，此功能需要使用 DMCC 命令 COM.RS232-ENABLE-PAUSE 来启用。对于 USB HID，它会默认为启用。


为什么顶部会有不同的选项卡？

为不同的符号分别指定格式，或使用通用选项卡为任何解码符号指定 perl 样式的正则表达式格式化。


此面板为何呈灰色？

要启用 Perl 样式正则表达式格式化功能，首先必须在读码器对特定符号类型进行解码的数据格式化主面板中启用基本格式化。


如何指定任意文本替换？

在正则表达式： 文本框中输入文本。字符串的语法为：

        /search/replace/g

其中，搜索是要搜索的字符串，替换是要替换搜索的字符串。在默认情况下，仅替换第一次出现的搜索。要替换所有内容，请在命令结尾处添加 g。

例如，如果读码器要对这个字符串解码：

        UPC 05214275600

通过使用此替换字符串，用字符串 "SKU CODE:" 替换字符串 "UPC"：

        /UPC/SKU CODE:/

可以生成此输出字符串：

        SKU CODE: 05214275600

可以输入多对取代项，以空格分隔。依次使用多个配对：第一对的结果用作第二对的输入内容，依以类推。


放弃不匹配的数据指什么？

在默认情况下，不属于匹配字符串的任何文本通过时都不会更改。如果选择放弃不匹配的数据，仅发送替代后的字符串。


要避开的特殊字符有哪些？

在搜索和替换字符串中，以下字符有特殊的含义：

              ., (  )  [  ] $ \ / * + |

如果在搜索或替换字符串中包含所有这些字符，必须在前面加上反斜杠字符 \。要包括反斜杠字符，输入 \\。要输入任意的 ASCII 字符，输入 \xhh，其中 hh 是十六进制字符数值（无法使用 \ooo 指定八进制 ASCII 值）。


如何使用通配符来匹配不同的字符或样式？

在搜索字符串中使用这些特殊字符，可以匹配任意单个字符、一组字符中的任意字符、字符范围内的任意字符，或不在字符范围内的任意字符：

.匹配任意单个字符

[abcd...]匹配组合 a, b, c, d ... 中的任意单个字符

[a-z] 匹配 a 到 z 字符（可以使用字母或数字）范围内的任意单个字符

要使用字符组或范围转化通配符方向，请在字符前加上 ^。

要匹配可变数量的字符，在匹配的字符或通配符上附加以下一个修饰符字符：

+ 匹配一个或多个前导字符

* 匹配零个或多个前导字符

? 匹配零个或一个前导字符

{n} 匹配 n 个前导字符

{n,m} 匹配至少 n 个但不多于 m 个前导字符

{n,} 匹配至少 n 个前导字符

以下为一些通配符匹配的实例：

/A.B/AB/g 移除输入字符串中A和B间的任何单个字符

/A.*B/AB/g 移除输入字符串中A和B间的任何数量的字符


有匹配特殊字符的通配符吗？

使用下列换码序列以匹配特殊字符和字符类型：

\n 换行字符

\w 字母数字字符（字母或数字）

\W 非字母数字字符

\s 空白处字符

\S 非空白处字符

\d 数字

\D 非数字

可以将这些字符与上述所列多字符匹配通配符组合使用。


如何锚定搜索字符串？

在搜索字符串前加上 ^ 仅匹配字符串的开头。在搜索字符串前加上 $ 仅匹配字符串的结尾。


如何在结果字符串中重新使用部分搜索字符串？

在括号中包含要在结果字符串中使用的搜索字符串。可以使用令牌 \1、\2 等在结果字符串中查找包含的字串。


Perl 样式正则表达式有最大大小吗？

任何一个选项卡中输入的脚本的最大大小为 512 个字符，但代码类型指定的选项卡将在通用选项卡之前运行。如果同时使用两者，则可以写入最多 1024 个字符的脚本。


何处可以获取更多有关 Perl 样式正则表达式的信息？

此处。请注意，读码器并不能执行该页面描述的所有功能。


输入/输出


为什么 3 秒按钮操作选项呈灰色？

仅可在单击、连击和自触发模式下选择触发按钮按压功能。

注意，只有它上方的所有其他选项（从优化亮度到设置匹配字符串）都未选中，才可启用测试模式选项（即可以选择）。


触发器按钮选项卡中的禁用读码器按钮复选框起什么作用？

如果选中禁用读码器按钮，在按下读码器按钮时，读码器不再开始读码、调谐或训练尝试。请注意，该功能不禁用设置工具按钮栏上的触发按钮或串行触发命令。


如果按住触发按钮 3 秒钟，可以配置哪些操作？

在单击、连击或自触发模式下，可以设置读码器在按住按钮 3 秒钟后有何反应。如果核取更多选项，则功能会按列表顺序运行。

按住读码器触发按钮 3 秒钟可以：

  • 如果当前触发模式下支持这些操作，优化采集图像的亮度

  • 从配置代码文档中读取配置代码

  • 如果安装了液体镜头模块，对该模块进行自动对焦

  • 用连续符号中想要的代码符号训练读码器

  • 如果执行匹配字符串验证，设置匹配字符串

  • 让设备进行测试模式

按住触发按钮与使用设置工具按钮栏上的触发按钮效果相同。


调谐按钮选项卡中的禁用读码器按钮复选框起什么作用？

如果选中禁用读码器按钮，在按下读码器按钮时，读码器不再开始读码、调谐或训练尝试。请注意，该功能不禁用设置工具按钮栏上的触发按钮或串行触发命令。


在 输入 标签下每条输入线路执行什么操作？

使用输入线路动作设置，配置读码器将采取的操作。在默认情况下，读码器不响应输入线路 1、2 或 3 上的信号。触发信号仅可以使用输入线路 0 和 1。

只有在下一个触发信号后，才执行输入线路操作训练代码、优化明亮、训练匹配字符串和读码器配置代码。

可以将读码器配置为任何下列操作：

  • 在相同的输入线路中，默认情况下会启用触发器开和触发器关。触发器关与触发器开自动相反。如果将两个信号放在分开的线路中，则可按需单独设置极性。

  • 编码器指连接到此输入线路的编码器。

  • 训练代码指采用预期符号类型训练读码器，可以减少对连续符号解码所需的时间。

  • 优化亮度指读码器找到了读码的最佳照明与图像设置。

    注：如果一个 RoI 尺寸小于 144，优化亮度不工作。

  • 训练匹配字符串指解码后的代码将是与连续代码匹配且经过验证的代码。

  • 优化焦点（仅适用于带有液体透镜的读码器）指读码器找到了读码的最佳焦点设置。

  • 已读取配置代码指读码器应考虑到代码未作为图像，而作为配置命令被读取，从而减少了触发次数且不会生成未读取图像。

  • 调谐指读码器找到了读取的最佳设置。

    注：如果一个 RoI 尺寸小于 144，调谐不工作。

  • 允许缓冲的未读取图像指，如果希望甚至可以缓冲未读取的图象，例如，查看为何有未读取的图像。

  • 清除输出是指如果设置了此操作，当输入受到触发，所有输出都会立即重置。此选项不会重置任何输出延迟设置。

    注：如果其中一个输入设置为清除输出，其中一个输出的输出选项卡设置读取操作，此输出的脉冲宽度选项卡设置为非零值，输出仍将打开，直至设置的脉冲宽度时间结束为止，无论在设置的脉冲宽度时间内是否激活输入。

  • 极性 是指如果设置了极性，会产生信号变化，触发图像采集。

  • 为了有效识别，使用防抖动延时 选项可定义必须探测的触发信号时长。


可以更改哪些触发侦测设置？

使用极性选项设置触发图像采集的信号变化。

为了有效识别，使用防抖动延时文本框，确定必须检测的触发信号时长。使用较短的值来弥补 ESD 线路的噪声，使用更高的值来弥补机电继电器的噪声。为了选择最适合生产环境的值，可能需要试用此设置。


防抖动时间怎么设置？

最短防抖动时间内为 0。增加数字表示增加防抖动时间。最大值为 6。


可以在输出选项卡中配置哪些设置？

输出选项卡可配置读码器上所有可用输出线路的状态。对于任何线路，都可以配置输出线路的事件及操作。

在未读码的情况下，还可以在无法读码时指定要传输的特定字符串。


选定的操作何时发生？

选中复选框后，指定给输入的操作不会在激活输入后立即发生。只在执行下一次触发时才发生。


什么是允许缓冲的未读取图像选项？

当此输入激活并连接时，例如数据包检测传感器，即使缓冲可能应用到所有图像，不读取图像也只在传感器将信号升至特定输入时才会缓冲。因此，当传感器实际检测到数据包时，读码器仅缓冲不读取图像。此选项仅用于连续触发模式。


如何为成功读码设置哔声长度？

勾选输出选项卡上的读取成功时启用蜂鸣器选项。然后，将哔声长度设置为 0 至 50 毫秒。


光圈脉冲持续时间设置用来做什么？

对于带光圈的读码器，在此处可以指定光圈照明状态的持续时间（以毫秒为单位）。


如何生成验证通过事件？

如果激活了数据验证，在读码且验证通过的情况下仅获得已读取事件信号。已读取和未读取事件指定为两次输出，以下逻辑适用：

  1. 成功读取、验证通过：已读取输出

  2. 成功读取、验证失败：不输出

  3. 失败读取：失败读取输出

或者，可以将验证失败事件指定为输出。


如何知道设备上的错误指示灯表示什么？

选择系统->显示设备日志并查看与该信息有关的日志。


如何重置读码器？

扫描印在快速参考指南背面的重启扫描器命令，执行软重置操作。虽然读码器中的非易失性存储器不会清除，但读码器会关机并重启。

扫描将扫描器重置为出厂默认值命令，将读码器还原至出厂默认状态。


可以关闭无时限的输出线路吗？

可以将脉冲宽度指定为 0 毫秒无限期地关闭输出线路，但请注意，任何情况下触发此输出线路都将导致其继续关闭，直至给读码器循环供电或用非关联的输入设置清除输出。


操作字段中打开和关闭选项有什么作用？

打开或关闭状态表示继电器的状态。如果因选中上述列表中的选项而触发事件，就会打开或关闭输出。例如，如果发送读事件，在关闭状态下，0 输出会变成 1 输出。也可以将脉冲宽度指定为 0 毫秒而无限期地关闭输出线路，但请注意，任何触发此输出线路的事件都将导致其继续关闭，直至给读码器循环供电或用离散输入设置清除输出。


为什么特定输出栏上的所有选项都禁用？

如果核取使用此反向输出线路的频闪，则选项会禁用。


什么是触发器超时运行？

触发器超时运行指由于相机繁忙（例如，由于不断连击或长时间曝光）而无法采集图像。


什么是缓冲器溢流？

缓冲器溢流指可能采集图像，但没有剩余的保存空间。换言之，图像的采集比处理速度快。一种可能的情况是解码时间长于图像/触发间隔时间。


读码器在不读码时传输什么？

通常，如果无法读码，读码器就不会传输数据。可以通过指定不读取字符串发送长度不大于 32 个字符的指定字符串。单击系统设置节点，然后在输出节点下的未读取输出字符串字段中输入字符串，并按下 <Enter> 键。


读码器在不读码时传输什么？

如果读码器无法读码，通常不会传输任何数据。可以通过指定不读取字符串发送长度不大于 32 个字符的指定字符串。单击系统设置节点，然后在输出节点下的未读取输出字符串字段中输入字符串，并按下 <Enter> 键。


什么是频闪选项？

核取输出线路之一的频闪可以为外部照明灯保留输出。在相应的输出栏中选择打开或关闭，还可以配置极性。


如何设置输出延迟？

可以指定输出延迟时间并以毫秒设置。也可以指定与触发开始或触发结束相关的输出延迟。

注：如果输出延迟时间短于读码器需要读取图片并进行结果解码的时间，设置工具将不能从读码器接收结果图像。


如何使用输出延迟和触发延迟？

两个触发器都相对于物理触发边缘，而不是图像采集的延迟开始（如果已设置触发延迟）。


为什么输出延迟无法设置？

只能在手动、单击、连击、连续触发模式下才可以设置输出延迟。


哪条数字输出线路受输出延迟的影响？

基于以下事件的所有操作：

  • 读码/未读码

  • 验证失败

延迟。以下输出线路会受到影响：

  • 任何数字输出的设置

  • 通过 RS-232、以太网或 USB 的任何数据传输

  • LED 照明

  • 拉响蜂鸣器


什么是输出距离？

使用脉冲编码器时，可以指定输出距离，并将脉冲映射到此距离。输出距离值根据分辨率数值进行校正（调整到最接近分辨率四舍五入后的倍数，以毫米计）。

在输出延迟选项卡中，使用输出距离（毫米） 控件设置触发到结果输出时的距离。

在脉冲编码器选项卡中，使用分辨率（毫米）控件指定分辨率。


什么是脉冲编码器？

对于外部触发模式，可以使用编码器控制数据字符串输出的计时装置。通常编码器安装在传送带上，随着传送带移动，编码器轴将旋转并输出电脉冲以表示其角旋转。编码器的旋转量与传送带的传送距离成正比。

将编码器连接至输入线路 1 或 2。选择的输入线路将专门由编码器使用。对于任何其他操作，请选择别的输入线路。

也可以将编码器连接至多个读码器同步组中的主读码器。


可以对脉冲编码器进行哪些设置？

可以指定输出距离并将脉冲映射到此距离。输出距离值根据分辨率数值进行校正（调整到最接近分辨率四舍五入后的倍数，以毫米计）。

在输出延迟选项卡中，使用输出距离（毫米） 控件设置触发到结果输出时的距离。

在脉冲编码器选项卡中，使用分辨率（毫米）控件指定分辨率。

还是在脉冲解码器选项卡中，如果您启用了双速率，您的编码器将会把输入线路上的两个边缘均计入。注意编码器忙闲度必须为 50%如果您禁用双速率，则编码器将仅计入所选边缘。


为什么要更改设备名称？

可以为生产环境下的设备起个更有意义的名称，如位置或检查任务。


可以给设备添加什么描述？

设备描述是可随意编辑的文本字段，在此可以给设备添加注释或重要的附加信息。


如何更改设备名称？

要更改设备名称：

  1. 在设备名称中输入设备的新名称。

  2. 弹出更改需要重新启动后才能生效，是否应用更改并立即重新启动？的询问对话框。单击是。

  3. 如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启设备。

下一次启动设置工具或单击主页屏幕中的刷新，将显示新的设备名称。


错误LED脉冲持续时间设置选项中能进行哪些设置？

可将滑块移到至所需要的毫秒位置，用于确定固定安装设备需要的错误LED脉冲时间。可在设备顶部看到错误LED选项。如果检索到设备日志，将滑块设置为0会将红色错误LED灯关闭，到达所选时间后，只要超过0值即会自动关闭红色错误LED灯。


什么是唤醒消息？

如果启用唤醒时输出诊断字符串，读码器会在启动时传输诊断字符串。

对于 Telnet 连接，读码器使用每个新连接传输诊断字符串。对于串行连接，无论设置工具如何设置，波特率都会在发送消息时自动设定为 38,400。


通信


可以使用长于一个字符的串行触发命令吗？

触发器打开和触发器关闭命令支持结果序列的字符限制最多为 32 个字节。根据使用转义序列的数量而定，这意味着可接受字符串的有效长度介于 32 个字符（无转义序列）和 128 个字符（32 * 4 个字符转义序列 [如 \002]）之间。


启用 Echo 命令有何用处？

启用后，一旦接收到由命令头和命令脚注字符串分隔的命令时，Echo 命令会反馈发送到读码器的命令。


为什么无法在终端程序中试用触发命令或应答命令？

自定义命令可通过 PLC 或相似设备提供，不需要手动输入。内部字符延迟的设定值很小，约 50 毫秒，以便缓慢键入自定义命令时不会在第一个字符通过时就被识别。大于一个字符的触发器打开或触发器关闭命令必须作为另一个应用的字符串发送。


在通信应用步骤中可以进行哪些设置？

可利用 通信 应用步骤中的三个选项卡对串口和以太网进行设置。点击适当的标签输入设置值。

在"高级选项卡下，可在表视图中输入更多设置。


如何更改读码器的串行端口设置？

在通信应用步骤中的串口选项卡下输入新的设置。还可以扫描配置代码文档（可通过 Windows 开始菜单或设置工具帮助菜单）。


什么是多端口（RS-232 共享）功能？

此连接模式允许多个（相同类型的）DataMan 读码器在一台 PC 或其他配备串行端口的设备上共享一个单独的串行连接。多端口连接可建立读码器的串级链。每个读码器接收前一个读码器的串行数据，然后传输给下一个读码器。读码器传输数据时，会通过串级链中的每个读码器。

必须自己构建符合系统配置要求的电缆。电缆必须为每个 DataMan 设备提供 DB-15 端子，为 PC 串行端口提供 DB-9 端子。每个 DB-15 端子必须提供 Tx 数据、Rx 数据、触发器 (Input 0)、接地和 DC 电源。必须连接相邻端子上的 Tx 数据和 Rx 数据引脚以提供多端口连接。

必须使用 USB 连接将每台 DataMan 设备连接到 DataMan 设置工具，并为多端口操作设置 DataMan。要为多端口操作配置设备，点击启用多端口（RS-232 共用）复选框。

关于多端口的更多详细信息，请查阅相应参考手册中的多端口连接章节。多端口共用功能具有以下性能和限制：

  • 链接中的每个读码器仍然通过 USB 连接至 PC 或其他设备。

  • 链接中的每个读码器必须接收自己的触发信号。DataMan 不支持串行触发。

  • 链接中的每个读码器必须个别配置。

  • 每个读码器的所有数据在传输至 PC 或其他设备时均不排序，也不过滤。


如何配置读码器的网络设置？

如果使用无线 DataMan 8000 读码器，在基站上配置网络设置。如果使用有线读码器，使用网络选项卡配置网络设置。

选择使用 DHCP 服务器选项，通过 DHCP 服务器（如果有）或手动输入网络设置为读码器指定 IP 地址。有关相应值，联系网络管理员。

更改设置时，会弹出更改需要重新启动后才能生效，要应用更改并立即重新启动吗？的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启读码器。


复制电脑端网络设置的这一选项是什么？

如果想要将 DataMan 设备配置为与您的电脑处于同一子网，则需点击复制电脑端网络设置按钮。选择想要使用的网络，设置便会被复制到使用静态 IP 位址窗口中。注：请记得更新您 DataMan 设备的 IP 地址。所复制的 IP 地址属于您的电脑。要使更改生效，需要重启设备。


字符间延迟设置用来做什么？

该设置将提供的毫秒用作键盘/字符读取模式下每个读取字符之间的延迟时间。这在由于后续读码的速度而丢失一些读取字符时变得很有用。


工业协议

EtherNet/IP 协议

勾选以太网选项卡的 工业协议框中的EtherNet/IP选项，使读码器采用 EtherNet/IP 协议。

更改值必须重启后才生效显示在通信横条右侧。点击保存设置，然后重启读码器。

PROFINET 协议

勾选PROFINET，使读码器采用 PROFINET 协议。点击使用站名框，输入站名。

更改值必须重启后才生效显示在通信横条右侧。点击 保存设置 ，然后重启读码器。

SLMP 协议

勾选SLMP 协议，使读码器采用 SLMP 协议，然后根据需要设置参数。

更改值必须重启后才生效显示在通信横条右侧。点击保存设置，然后切换读码器的电源或扫描 复位 符号，重启读码器，使设置生效。

Modbus TCP

勾选Modbus TCP，使读码器采用 Modbus TCP 协议，然后根据需要设置参数。

更改值必须重启后才生效显示在通信横条右侧。点击 保存设置 ，然后切换读码器的电源或扫描 复位 符号，重启读码器，使设置生效。

EtherNet/IP、PROFINET、SLMP 协议或 Modbus TCP 选项呈灰色

在特定时间内只可以使用一种以太网工业协议。选择一种协议时，另一种协议就不可用了。


工业协议下的状态字段

工业协议的状态字段显示状态对话框的上次记录的消息。该消息一直保持显示，直至记录另一条消息为止。如果未启用工业协议，该状态字段保持空白。

状态消息因协议而不同，有些协议不记录任何消息。有关消息和显示这些消息的协议的详细信息，请见 DataMan 工业协议手册。


Modbus TCP：空闲超时设置

空闲超时是指端口保持开放而无外出通讯量的时间量。一旦读码器打开至 FTP 服务器的连接，只要出现通讯量，读码器都将保持连接开放。

如果在设置了空闲超时时间而没有出现通讯量，连接将会关闭。这在很少进行 FTP 传输以及网络需付款，不需要使连接保持打开时很有用。

首先需要启用能设置空闲超时的启用 Modbus TCP。


如何使用验证选项？

如果启用验证，在通过网络尝试连接至可用的读码器或基站时，设置工具将提示用户以管理员帐户输入密码。


如何建立 TCP/IP 连接？

读码器可以将 TCP 连接到端口 23，它是 Telnet 应用程序的默认 TCP 端口。如果使用 Telnet 客户端，唯一需要提供的参数就是读码器的 IP 地址。如果正在使用其他应用程序或要连接 SDK，请确保使用的 TCP 端口设置与读码器设置相同。TCP 端口可以在 Telnet 面板中更改。读码器将通过该连接自动发送代码输出。还可以通过该连接传输 DataMan 控制命令 (DMCC)。

更改 Telnet 端口时，会弹出更改需要重新启动后才能生效，是否应用更改并立即重新启动？的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置并重启读码器。


什么是网络客户端？

网络客户端是用于 DataMan ID 读码器主动打开网络中另一台设备以太网连接的工具。一旦打开，连接将具有与 DataMan Telnet 连接相同的基本操作性能；可以生成读取结果（结果传输到外部设备），并可以用作 DMCC 服务器（从外部设备接收处理命令）。


什么是主机？

主机是 DataMan 将连接的网络设备。指定主机设备的以太网地址和端口号。地址可以是完全符合条件的域名（例如server.mynetwork.com）或十进制点格式的 IP 地址（例如192.169.0.1）。


什么是客户端端口？

客户端端口是客户端连接的读码器上的以太网端口。默认值 0 表明网络客户端使用任何可用端口。在特殊情况下，可能需要指定特定的客户端端口。只需将客户端端口设置为所需的值。请注意，最典型的情况是使用默认值 0。如不能肯定，请使用默认值。


如何连接？

客户端将按照所选的打开连接选项进行连接。当接通 DataMan 电源时可用选项将进行连接，或者在有数据活动时进行连接（即读码时连接）。


如何关闭连接？

有两个可用的关闭连接选项。连接可以永远保持打开状态，或者可以在数据传输完成后关闭连接。如果选择读码器数据传输后选项，还可以在连接断开后设置一个数字（秒），若这段时间内读码器闲置。闲置期的长度的调节范围为 1 到 3600 秒。


什么是连接超时？

连接超时是 DataMan 等待连接打开的时间量（毫秒）。请注意，如果选择了通电选项，则读码器会不断尝试打开连接。


什么是重新连接延迟？

它是尝试重新打开连接之前读码器暂停的时间量（毫秒）。


什么是不可打印字符特性？

通常情况下，在配置读码器的 COM 通讯时，传输不可打印字符的原始值。当读码器以键盘接口配置时，这些值根本不可见。通过启用转换不可打印字符特性来配置读码器，将不可打印字符转换成键盘可打印字符的序列，例如 <CR>。


哪些不可打印字符要转换？

转换不可打印字符启用时，转换具有 0x00 至 0x1F 和 0x7F 值的八位 ASCII 字符码。符号对应着 ASCII 符号名称，如下所列：

0x00 <NUL>

0x01 <SOH>

0x02 <STX>

0x03 <ETX>

0x04 <EOT>

0x05 <ENQ>

0x06 <ACK>

0x07 <BEL>

0x08 <BS>

0x09 <HT>

0x0A <LF>

0x0B <VT>

0x0C <FF>

0x0D <CR>

0x0E <SO>

0x0F <SI>

0x10 <DLE>

0x11 <DC1>

0x12 <DC2>

0x13 <DC3>

0x14 <DC4>

0x15 <NAK>

0x16 <SYN>

0x17 <ETB>

0x18 <CAN>

0x19 <EM>

0x1A <SUB>

0x1B <ESC>

0x1C <FS>

0x1D <GS>

0x1E <RS>

0x1F <US>

0x7F <DEL>


启用转换不可打印字符会怎么样？

此参数仅影响实际的代码内容。任何其他的格式都不能碰，如页眉和页脚。它具有结合此参数使用控制字符的能力，例如，在代码之间插入换行符或导航至电子表格中的下一单元格。


代码中包含不可打印字符时传输什么？

通常传输不可打印字符的原始值。可以配置读码器，将不可打印字符转换成可打印字符的序列，例如 <CR>。进入不可打印字符面板并选取已启用。


维修和支持


什么是维修和支持？

维修和支持页面可用于设置未正确配置网络设备的网络设置或将串行设备的 HID 模式更改为 CDC。


刷新选项用来做什么？

单击刷新按钮可刷新可用设备的列表。


如何将网络设备添加到显示设备列表？

通过单击添加网络设备可以添加网络设备或编辑已添加设备的 IP 地址。添加网络设备对话框打开，可在此提供设备的 IP 地址。单击确定以保存所做的更改，该设备也将显示在连接页面。


如何编辑设备属性？

从设备列表中选择设备以查看可用选项。在打开面板中，可以编辑属于所选设备的网络设置以及设置身份验证选项。单击应用以保存所做的更改。


导出图标有何用处？

点击导出 Cognex 支持文件图标开始 Cognex 支持文件生成，它生成一个含一系列预设数据日志的 .zip 文件。至少选定一台设备，这项功能才可用。

点击按钮会弹出一个对话框，可以在此指定复选框列表中支持.zip 文件所包括的数据类型：

  1. Cfg

  2. Cdc

  3. 最近的图像

  4. 发现的设备

  5. 设备统计信息

  6. 内存统计信息

  7. 用户评论（可以由用户手动编辑）

可以使用...图标修改支持文件的目标文件夹。在文件生成后可以选择打开包含它的文件夹或将它作为附件用默认的电子邮件客户端 (.eml) 发送。

过程的输出是 .zip 文件。文件名包含设备名称和创建日期。Zip 中附加的 descriptor.xml 包含以下数据：

  1. 日期

  2. 发现 ID

  3. 设备名称

  4. 设备类型

  5. 序列号

  6. MAC 地址

  7. 功能键

  8. 通信接口

  9. 固件版本

  10. zip 文件中的文件列表


添加虚拟设备按钮用来做什么？

此功能允许基于自定义配置文件或带默认配置的设备来创建虚拟设备。不需要连接设备，就可用于查看设置工具中不同的面板。按下按钮启动向导，引导完成创建虚拟设备的步骤。初始选项将使用配置/备份文件进行创建或使用出厂默认设置。

向导完成后，新的虚拟设备添加到发现的设备列表，用虚拟设备图标表示。创建的虚拟设备对网络上的其他设备不可见。虚拟设备在多个设置工具实例中自始至终存在。

能以同样的方式连接所创建的虚拟设备作为常规设备，除非所有配置更改都遭到拒绝（全都是只读型）且虚拟设备上没有特性、功能和操作工作。


复制电脑端网络设置这一选项是什么？

当您在网络下选择某个设备时，网络设置对话框便会出现在右侧。

点击复制电脑端网络设置按钮来复制您电脑的网络设置，从而无需费力查找您电脑的子网掩码和默认网关设置。需注意所复制的 IP 地址是您电脑的 IP 地址。IP 地址的红色边框是提醒您需要手动将该字段更新为 DataMan 设备的 IP 地址。


备份


如何使用备份功能？

使用此功能，可以通过点击右下角中的备份按钮 （或按下 Alt + B）生成包含配置和一台或多台读码器日志的备份文件。 至少选定一台设备，这项功能才可用。

点击打开备份文件夹按钮导航至放置备份文件的文件夹。可以在首页-> 选项-> 备份位置下方设置文件夹。

如果选择多个设备，每个设备会生成一个备份文件。每个备份文件放在匹配设备名称的子文件夹中。备份文件名包含设备名称和生成日期。

备份文件是带 .dmb 扩展名的 .zip 文件。该文件包含：config.cdc、config.cfg 和 descriptor.xml。xml 包含下列数据：

  1. 日期

  2. 发现 ID

  3. 设备名称

  4. 设备类型

  5. 序列号

  6. MAC 地址

  7. 功能键

  8. 通信接口

  9. 固件版本

  10. zip 文件中的文件列表


可以在哪为备份功能设置备份文件夹？

可以在首页-> 选项-> 备份位置下方设置文件夹


还原


如何使用还原功能？

还原功能允许在一台或多台设备上还原备份配置文件。此功能只有在选择至少一台设备且指定有效的配置源后才可用。

在顶部配置源下方，可以指定用于还原的源设置工具：

  1. 配置文件：选择此选项时，设置工具使用指定的还原配置文件。点击...图标以指定包含要使用备份文件的文件夹。有关如何设置文件夹的更多信息，参见备份下方的问答。

    注：只有在某个兼容设备被选为目标时，还原按钮才启用。

  2. 设备：选择此选项时，设置工具使用指定的单个设备以将其配置还原到所有的目标设备。

  3. 最新备份：选择此选项时，设置工具为选定的设备搜索最新备份。如果选择多台设备，所有设备都会获得自己最新的备份。

  4. 出厂默认值：选择此选项时，设置工具软件即会将配置还原为出厂默认值。

选择源以及目标设备后，点击右下角的还原按钮。


如何使用网络设置下拉按钮进行还原？

用网络设置还原工作方式与使用还原按钮相同，但它从备份文件夹中包含的 .cdc 文件而不是 .cfg 文件来还原配置。只有指定源中有 .cdc 且目标选择包含单个设备时，此选项才启用。


更新固件


如何更新读码器固件？

连接您的读码器后，选择系统->更新固件...，然后选择固件文件。

注：固件文件以压缩档案的方式提供。固件必须以压缩形式上载；在上载固件之前不要尝试解压。


如何使用更新固件功能？

此功能为所选的设备更新到所需的固件版本。

  1. 从设备列表中选择要更新的设备。

  2. 通过点击...图标浏览固件文件。如果在设备列表中选定单台设备，就会打开该设备相应的固件文件夹。如果选择多台设备，而他们具有相同的固件设备 ID，则会打开相应的文件夹。如果未选择设备或选择更多的设备，但他们具有不同的固件设备 ID，则会打开固件根文件夹。

  3. 点击上传固件按钮。只有选定的固件版本与设备选择相兼容，该按钮才启用。

  4. 如果您想要设置工具以与备份功能相同的方式来备份配置文件，则在弹出窗口中，勾选固件更新之前备份设备。（更多详细信息请见备份部分的问答内容）。

  5. 点击是来开始上传新固件。

注：使用串行设备的情况下，在能够更新固件之前需要通过手动刷新去发现它们。


比较配置


比较配置：一般布局与结构

比较配置是用于设置、复制、比较或还原设备配置的表视图样式工具。文档页面的主要区域包含带设备属性的网格，该设备在打开连接到读码器页面之前已选定。

每个设置工具文档类型使用它自己的连接。使用串行通信的情况下，一次只能打开一个连接。

标题行显示所选的设备名称。下面的第二标题行显示设备的可用设置。通过点击它旁边的图标可折叠或打开下面的行标题（以粗体显示）。断开设备连接时，其标题行会出现重新连接图标。

与读取设置不相关的设置只显示在第一列中（主设置）。


比较配置：控件（鼠标和键盘）

选择：

  • 鼠标：点击网格中的单元格并进行选择，会突出显示单元格的行标题以及设备和设置所属的列标题。菜单按钮和功能区菜单项可以根据选择进行更改。如果所选的单元格位于行标题行中，属于标题的当前列中所有的单元格都会被选择。

  • 键盘：光标移动键可将选择导航到相应的单元格。突出显示和选择操作与使用鼠标相同。

添加/更改值：

  • 鼠标：对于采用嵌入式编辑器的单元格，点击编辑器控件（组合框、复选框、数字选择）允许输入值。对于采用自定义编辑器的单元格（...图标），弹出式编辑器将打开，允许输入值。

  • 键盘：对于采用嵌入式编辑器的单元格，按下 Enter 或 F2 启动编辑模式，按下Esc 键取消编辑，第二次按下 Enter 键确认编辑。不用进入编辑模式，即可以在选定的文本中输入值，在此情况下第一次击键将会覆盖当前值。

    对于数值单元格，除了嵌入式文本编辑器单元格外，向上和向下箭头可增加和减小值。

    对于下拉式单元格，按下 输入 键启动编辑模式并显示下拉菜单项，而 向上和向下箭头 可移动所选的内容。第二次按下 Enter 键应用选定的值，按下 Esc 键取消编辑。

    对于复选框单元格，使用 Space 可切换选中/未选中状态。

复制和粘贴：

使用组合键 Ctrl+C 和 Ctrl+V 进行复制和粘贴，欲了解更多信息，请查看相关功能区菜单项的复制粘贴介绍。


比较配置：功能区菜单

功能区菜单可在表视图样式网格上方找到。其内容和活动图标可能会随网格中单元格、行或列的选择而变化。菜单可分成几组。

  • 设备：此组中的设置与设备及其配置文件有关。使用添加设备...按钮打开一个对话框，从中选择添加一个或多个要比较的设备。添加配置文件...按钮将打开向导，在此可浏览配置或备份文件 (.dmb,.cdc,.cfg)。如果所选的设备文件不包含所有需要的信息，必须设置缺失参数，否则会自动选择默认选项。这同样适用于虚拟设备数据库无法将参数匹配给可用选项的情况（例如，未找到匹配的固件版本）。

    注：添加的虚拟设备是只读的，因为在其标题行被标记了挂锁图标。

    点击删除设备按钮可删除当前选定的设备（即包含当前所选单元格的那一个）。重启设备可重新启动所选的设备。保留设备上的配置可将所选设备的配置文件保存到它的闪存中。使用重置出厂默认值可将所选的设备重置为其默认值。

  • 编辑：使用复制（或键盘上的 Ctrl + C）从当前选定的单元格复制值。粘贴只能用于同一行中或任何文本编辑器中。重置值用于重置所选单元格的值。

  • 突出显示：此菜单组中的按钮和设置提供选项以突出显示特定的单元格背景。使用非默认值设置，具有非默认值的单元格会突出显示（这在不同设备或读取设置的单个行中可能会不同）。不同于参考设置突出显示单元格，这些单元格与参考读取设置（和设备）同一行中的单元格具有不用的值。选择第三个设置，所有的值和标题都会突出显示，包含文本框中指定的文本。此外，包含的文本本身也使用不同的文本背景突出显示。同样按下 Enter 键也会应用仅显示突出行按钮的功能。

    启用时，仅显示突出行折叠所有不包含突出显示子节点的节点。激活时，设置参考读取设置在使用不同于参考突出显示模式时指定用作参考的读取设置（和设备）。当按钮处于活动状态时，当前所选单元格的列（读取设置）变为参考设置。当前的参考设置在设置名称标题行中被标记。

  • 过滤：设置读取设置只查看与读取设置相关的设置。设置全局设置只查看在不同读取设置中不能有不同值的设置。设置所有设置以同时查看所有设置。如果条目的值出现在多个读取设置中，它们将显示在不同的列中。

  • 其他：使用展开所有行以展开网格中所有折叠的行。使用折叠所有行以折叠网格中所有展开的行。重置布局重新计算列宽度以用完所有可用的空间。如果可用空间不够，会使用最小列宽度。


比较配置：比较编辑器

点击...图标后，比较编辑器可打开比较配置表视图中的每个脚本项（它的任何一个子类别）。打开之后，可以查看打开比较编辑器所在设备的脚本源。

通过点击默认，该脚本将恢复为特定设备的默认脚本。通过点击比较，默认脚本出现在右侧的第二个设备上，但可以使用顶部的下拉菜单更改哪个脚本与左侧的脚本相比较。刷新按钮出现在选项卡的中间（红色、 圆形箭头），可以用来刷新所有的脚本文本。

点击关闭，可将比较关闭并移回到比较配置内的表视图。


图像窗口


什么是图像查看器？

在此窗口中，可以看到设备的图像读取。

使用放大镜图标到自动调整图像以适应图像查看器窗口的大小，放大和缩小图像或分别以像素到像素模式显示图像。

此外也可以在实时显示模式下启用或禁用图像的焦点反馈，可以将图像复制到剪贴板。

使用保存图像选项仅保存当前图像或所有连击图像，记录选项将所有不读取或所有解码图像记录到文件系统。

也可以选择检查读取图像的直方图和图像中所选点的亮度数据。使用此窗口工具栏功能区上的按钮可执行这些任务。


结果历史记录


什么是结果历史记录？

在此面板中，可以看到每次读取后的解码信息。

使用暂停按钮暂停/冻结结果历史记录工具视图，这使得寻找特定的读取信息更加容易。所有从设备进入的结果都被结果历史记录窗口拒绝，直到取消暂停。

使用清除历史记录清除历史记录列表。也可以通过使用复制和复制全部选项，分别导出单个或所有已解码字符串。

在记录下方，可以勾选生成代码质量报告，将代码质量数据纳入解码信息，勾选生成数据验证报告以纳入数据验证信息，并将所有结果都记录到文件系统以将所有结果历史记录项目都局部保存本地硬盘。通过单击记录和报告设置可以访问更多这些选项。

自定义允许添加或删除表格列以个性化设置结果历史记录中的信息。

关于结果过滤，参见以下问题。


结果过滤如何工作？

可以使用结果历史记录工具视图功能区菜单中的过滤...按钮来过滤视图中显示的读取结果。点击按钮启用过滤。若要设置过滤参数，可点击按钮右侧打开选项。

注：只有操作系统支持时才显示过滤按钮。

过滤设置中有两种模式：标准过滤和高级过滤。可以通过一般下方的下拉菜单选择任何一种模式。

使用标准过滤时，过滤类别在下拉窗口中显示为活动（结果状态、验证方法、验证状态和条码符号）。通过点击可以选择每个类别下方的个别过滤器。一旦启用，这些过滤器就用于结果历史记录中的所有未来项，也具有可追溯性。未被过滤器指定的项从结果历史记录中删去，直至过滤被禁用为止。请注意，在标准过滤中，触发序列中单个有效的读码结果会计为整个触发序列的有效读码。因此，例如标准过滤不适用于多代码场合；多代码场合使用高级过滤脚本。

使用高级过滤时，标准过滤类别变为非活动状态，高级过滤设置在下拉窗口中被激活。点击它打开一个新窗口，在此可以编辑过滤器表达式。如果之前启用了预定义过滤器，此时在对话框中可看到生成的表达式。编辑表达式不会对预定义过滤器产生任何反向效果。

过滤器表达式本身是一个 JavaScript 函数。使用结果的数据成员就像使用基于脚本的格式化一样。表达式结果可以在窗口底部看到。如果 JavaScript 错误，会有错误消息显示在文本窗口中。请注意，尽管相似，但高级过滤并不是数据格式化脚本，只是在设置工具上运行的显示过滤器。


为什么符号显示绿色轮廓，但在结果历史记录列表中却没有出现任何数据？

如果在标准格式化面板中选择了标准格式化启用，则必须构建定制的输出字符串，否则即使解码了也不显示结果数据。


为什么有些结果前面有图标？

以图标开头的结果具有与其关联的已保存图像。点击结果行以显示解码尝试和与其关联的图像。


如何查看多代码结果？

要启用多代码结果，必须在代码符号设置面板中的多代码选项卡上，将默认值 1 开始增加代码数量参数。

如果读码器在相同图像中检测多个符号并解码，每个符号显示绿色轮廓，并且读码结果历史记录窗格中显示一个单行，显示一行中所有连结的解码数据。结果分开显示，后接 CR (<0x0d>) 和 LF (<0x0a>) 的 ASCII 字符。要查看每个符号的个别结果，单击与连结结果相邻的+号。

单击单个结果时，图像查看器将突出显示相应的符号。


为什么在自触发模式下看到的是单个结果，而非多代码结果？

在自触发模式下，读码器在读码结果历史记录单行中返回多条单个结果。与其他触发模式不同，此处这些结果不能连接。默认情况下，自触发模式允许显示部分结果。


代码质量


代码质量用来做什么？

使用代码质量可以验证所用的符号符合受 Cognex 支持的代码质量标准之一的质量准则。在评定所给代码质量标准的选定或所有（默认）指标后，为代码提供总体等级。代码质量由功能键激活。

有关特定代码质量标准及其指标的更详细信息，请查阅 DataMan 通信与编程指南或 www.iso.org 网站上相应的 ISO 标准文件。


如何使用一般面板？

一般面板作为中心，能为不同的代码类型进行代码质量评定：1D 条形码、Data Matrix、QR 码和 DotCode。对于每种条码符号类型，都可以指定读码器用哪种代码质量标准来评定读取代码。

如果选择了所需的指标，必要时导航到相应的 1D 条形码和/或2D 代码子选项卡以进一步自定义代码质量评定。

启用代码质量等级后，设备在代码质量工具视图中为每个启用了代码质量的读取符号提供质量结果。如果要检查代码质量评定的详情，确保通过点击视图下方的代码质量启用代码质量工具视图。在工具视图中显示每个所用指标和总体质量的等级。


在 1D 条形码和 2D 代码选项卡下方可以使用哪些设置？

在一般选项卡上一旦选择了想为代码类型的质量标准要使用的所需代码质量标准，可导航至 1D 条形码或 2D 代码选项卡下方相应的代码质量标准子选项卡并为特定等级自定义评级阈值，包括总体等级中的特定等级以及报告中显示内容。

请注意，代码质量等级不支持 microQR。


在 1D 条形码选项卡中能设置什么？

将设备连接至电脑以计算 Cognex 1D 可读性或用于 1D 条形码的 ISO/IEC 15416（位于代码质量面板中的一般选项卡下方）后，此选项卡允许管理该代码评定类型的各个方面。

在总体结果的最小通过等级下拉框中，为给定代码质量标准指定哪个最小等级可接受为通过。

通过勾选自定义阈值复选框，可以撤消和自定义最初在给定的代码质量标准中定义的阈值设置。请注意，如果取消并重新选中复选框，阈值会重置为默认值。这些提供标准的指标列表，其中每个指标都具有以下设置：

  • 等级 A、 B、 C 和 D 可以设置阈值。如果指标超过此阈值，就会指定各自的等级。如果值未达到等级 D 的阈值，就指定等级 F。请注意，有些指标没有阈值，这符合 ISO 标准（各自的 ISO 标准详见 http://www.iso.org）。

  • 用作总体计算：如果勾选，此指标用作总体等级计算。

  • 列于报告中：如果勾选，此指标列于直接来自读码器的代码质量报告（通过 FTP 传输或通过报告记录由设置工具生成）以及能在结果字符串选项卡中启用的结果字符串中。

请注意，由于其特性（如标准中所定义），并不是所有的指标都具有所有选项（例如，如果 ISO 标准未为指标指定等级）。


哪些个别指标可用于 1D 可读性？

以下是为 1D 可读性质量评定计算的指标列表。有关此代码质量标准及其指标的更详细信息，请查阅 DataMan 通信与编程指南。

  • 多次扫描完整性 (Multi-scan Integrity) 是指通过合并符号的多次扫描获得符号解码性的测量。测量值越高，等级越高。

  • 边缘对比度最小值是指两个相邻元素的黑条反射比与空白反射比之间的最小差别，它表示边缘清晰度。相差越大，等级越高。

  • 反射比最小值是指扫描中的最小反射值，用于测量条形码的最黑暗部分。值越小，等级越高。

  • 打印增加量测量黑条和空白宽度与预期宽度（显示于条码符号规格中）的偏差，即它测量符号中的黑条是否比空白更窄/更宽。相差越大，等级越低。

  • 符号对比度是指扫描的最高和最低反射值之间的差（最暗黑条和最亮空白之间的反射差） 。相差越大，等级更高。

  • 单次扫描完整性 (Single-scan Integrity) 是指用单次扫描测量符号的解码性。如果条形码的多个位置受损，解码性会较低。


哪些个别指标可用于 ISO/IEC 15416？

以下是为 ISO/IEC 15416 质量评定计算的指标列表。有关此代码质量标准及其指标的更详细信息，请查阅 DataMan 通信与编程指南或 www.iso.org 网站上相应的 ISO 标准文件。

  • 解码度是指与特定条码符号基准解码算法相比，对条形码打印精度的测量。解码度表示符号中最异常元素的宽度错误范围。偏差越小，等级越高。

  • 缺陷是指元素不规则（黑条和空白）和静区。该参数用于测量由扫描反射配置文件中不必要的谷值和峰值所产生的噪音。缺陷越小，等级越高。

  • 边缘对比度最小值是指两个相邻元素的黑条反射比与空白反射比之间的最小差别，它表示边缘清晰度。相差越大，等级越高。

  • 反射比最小值是指扫描中的最小反射值，用于测量条形码的最黑暗部分。该值越小，等级越高。

  • 调节是指边缘对比度最小值与符号对比度的比率，或测量扫描器看见宽元素（黑条或空白）相对于窄元素的程度。边缘对比度最小值和符号对比度之间的差值越大，等级越低。

  • >符号对比度是指扫描的最高和最低反射值之间的差（最暗黑条和最亮空白之间的反射差） 。相差越大，等级更高。

  • 基准解码是指标准 2D DataMatrix 算法是否能够找到此特殊标记并解码的指标。

    这种指标生成的等级为 A 或 F。

  • 边缘确定是指扫描反射配置文件中检测到的边数。如果检测到的边数大于或等于预期的边数，等级为 4。否则，等级为 0。


在 2D 代码选项卡中可以设置什么？

将设备连接至电脑以计算 ISO/IEC 15415、AIM-DPM/ISO/IEC TR29158、SEMI T10 或 DotCode（位于代码质量面板中的一般选项卡下方）后，此选项卡允许管理该代码评定类型的各个方面。

在总体结果的最小通过等级下拉框中，为给定代码质量标准指定哪个最小等级可接受为通过。

通过勾选 自定义阈值 复选框，可以撤消和自定义最初在给定的代码质量标准中定义的客户阈值设置。请注意，如果取消并重新选中复选框，阈值会重置为默认值。这些选项提供标准的指标列表，其中每个指标都具有以下设置：

  • 等级 A、 B、 C 和 D 可以设置阈值。如果指标超过此阈值，就会指定各自的等级。如果值未达到等级 D 的阈值，就指定等级 F。请注意，有些指标（例如 SEMI 10）没有阈值，这符合 ISO 标准（各自的 ISO 标准文档详见 http://www.iso.org）。

  • 用作总体计算：如果勾选，此指标用作总体等级计算。请注意，SEMI T10 指标没有此选项。

  • 列于报告中：如果勾选，此指标列于直接来自读码器的代码质量报告（通过 FTP 传输或通过报告记录由设置工具生成）以及能在结果字符串选项卡中启用的结果字符串中。

请注意，由于其特性，并不是所有的指标都具有所有选项（例如，如果 ISO 标准未为指标指定等级）。

注：2D 代码质量等级不支持 MicroQR。


哪些个别指标可用于 AIM-DPM/ISO/IEC TR29158？

以下是用于AIM-DPM/ISO/IEC TR29158 质量评定的指标列表。有关此代码质量标准及其指标的更详细信息，请查阅 DataMan 通信与编程指南或 www.iso.org 网站上相应的 ISO 标准文件。

  • 网格非一致性是使用符号的定时样式测量一致空间面板的单个单元格的定位错误的数量测量。

  • 未使用的纠错是指纠错之后符号中留有的码字的百分比测量。

    计算未使用的纠错时，如果至少一个单元格在全局阈值的错误一侧，码字就被认为是错误的。2D DataMatrix 符号具有内置代码冗余或出现重复的数据内容。

    值为 1.00 表示码字内没有出现错误。

  • 轴向非一致性是指符号内单个单元格的对称性测量，即沿符号轴的偏差量。

  • 单元格对比度是指测量符号中明单元格和暗单元格之间的反射比不同，以明单元格的平均反射值百分比表示。

    AIM-DPM/ISO/IEC TR 29158 规范要求对图像进行调整，使明单元格的平均反射值为完全饱和的 78%。

  • 固定样式损坏是指标记内扫描器、定时器和静区样式的质量。

    读码器使用每个符号中的几个样式查找所含数据并解码。读码器利用与单元格调节分数相同的方法生成固定样式损坏级别，特别是反射比信度测量。

  • 调节是指实际标记的可读性测量。

    级别是明单元格和暗单元格接近特定标记全局阈值程度的反映，表示特定标记的明单元格和暗单元格之间的灰度级分隔点。

    当读码器的信度相对低，能将单个单元格分类为明或暗时，标记会生成较低的调节等级。分数还会考虑符号内置的纠错能力（较大的符号具有较强的纠错能力）。例如，某个标记将接收较低的调节等级，但如果大多数单元格接近更改状态，则会得到较高的未使用的纠错等级，然而实际上并非如此。

  • 打印增加量测量黑条和空白宽度与预期宽度（显示于条码符号规格中）的偏差，即它测量符号中的黑条是否比空白更窄/更宽。相差越大，等级越低。


哪些个别指标可用于 ISO/IEC 15415？

以下是用于 ISO/IEC 15415 质量评定的指标列表。有关此代码质量标准及其指标的更详细信息，请查阅DataMan 通信与编程指南或 www.iso.org 网站上相应的 ISO 标准文件。

  • 网格非一致性是使用符号的定时样式测量一致空间面板的单个单元格的定位错误的数量测量。

  • 未使用的纠错是指纠错之后符号中留有的码字的百分比测量。

    计算未使用的纠错时，如果至少一个单元格在全局阈值的错误一侧，码字就被认为是错误的。2D DataMatrix 符号具有内置代码冗余或出现重复的数据内容。

    值为 1.00 表示码字内没有出现错误。

  • 轴向非一致性是指符号内单个单元格的对称性测量，即沿符号轴的偏差量。

  • 符号对比度是指扫描中最高和最低反射值之间的差（最暗黑条和最亮空白之间的反射差） 。相差越大，等级更高

  • 极限反射比为是/否值，表示符号周围的基材是否包含能干扰读取的反射比极限。

  • 固定样式损坏是指标记内扫描器、定时器和静区样式的质量。

    读码器使用每个符号中的几个样式查找所含数据并解码。读码器利用与单元格调节分数相同的方法生成固定样式损坏级别，特别是反射比信度测量。

  • 调节是指边缘对比度最小值与符号对比度的比率，或测量扫描器看见宽元素（黑条或空白）相对于窄元素的程度。边缘对比度最小值和符号对比度之间的差值越大，等级越低。

  • 打印增加量测量黑条和空白宽度与预期宽度（显示于条码符号规格中）的偏差，即它测量符号中的黑条是否比空白更窄/更宽。相差越大，等级越低。


哪些个别指标可用于 SEMI T10？

以下是用于 SEMI T10 规格的指标列表。有关此代码质量规格及其指标的更详细信息，请查阅 DataMan 通信与编程指南或 www.semi.org 网站上相应的 SEMI 规格。

  • 扫描器样式缺陷是指扫描器样式中不正确像素占总像素的比率。

  • 单元格缺陷是指网格中不正确像素占总像素的比率。

  • 垂直标记错位是指 Data Matrix 标记距其最优 Data Matrix 单元格中心点的平均垂直错位。

  • 水平标记错位是指 Data Matrix 标记距其最优 Data Matrix 单元格中心点的平均水平错位。

  • Data Matrix 单元格高度是指矩阵中每个单元格的平均高度（以像素为单位）。

  • Data Matrix 单元格宽度是指矩阵中每个单元格的平均宽度（以像素为单位）。

  • 垂直标记增加量是指标记符号的高低趋势跟踪，即实际标记的单元格与其标称尺寸之间的垂直尺寸比较。

  • 水平标记增加量是指标记符号的高低趋势跟踪，即实际标记的单元格与其标称尺寸之间的水平尺寸比较。

  • 信噪比 (SNR)是指符号中符号对比度与明或暗灰度等级的最大偏差（即噪声）的相对测量值。

  • 未使用的纠错是指纠错之后符号中留有的码字的百分比测量。

    计算未使用的纠错时，如果至少一个单元格在全局阈值的错误一侧，码字就被认为是错误的。2D DataMatrix 符号具有内置代码冗余或出现重复的数据内容。

    值为 1.00 表示码字内没有出现错误。

  • 符号对比度是指扫描中最高和最低反射值之间的差（最暗黑条和最亮空白之间的反射差） 。相差越大，等级更高


哪些个别指标可用于 DotCode？

以下是用于DotCode 质量评定的指标列表。有关此代码质量标准及其指标的更详细信息，请查阅DataMan 通信与编程指南或 www.iso.org 网站上相应的 ISO 标准文件。

  • 网格非一致性是使用符号的定时样式测量一致空间面板的单个单元格的定位错误的数量测量。

  • 未使用的纠错是指纠错之后符号中留有的码字的百分比测量。

    计算未使用的纠错时，如果至少一个单元格在全局阈值的错误一侧，码字就被认为是错误的。2D DataMatrix 符号具有内置代码冗余或出现重复的数据内容。

    值为 1.00 表示码字内没有出现错误。

  • 打印增加量测量黑条和空白宽度与预期宽度（显示于条码符号规格中）的偏差，即它测量符号中的黑条是否比空白更窄/更宽。相差越大，等级越低。

  • 轴向非一致性是指符号内单个单元格的对称性测量，即沿符号轴的偏差量。

  • 符号对比度是指扫描中最高和最低反射值之间的差值（最暗黑条和最亮空白之间的反射差） 。相差越大，等级更高


结果字符串选项卡用来做什么？

通过勾选将代码质量数据追加给结果字符串复选框，基于数据格式化启用令牌，并允许代码质量结果数据追加到结果字符串。如果选中，输出总体等级在结果字符串中输出总体代码质量等级（即被定为选定指标的最低等级）。

在报告的数据下方，可以指定在结果字符串数据中是否要列入等级、值、两者或其中一个。数据元素的分隔符部分允许在结果字符串中列入的代码质量值之前和之间设置分隔符。

质量报告自定义描述允许设置添加到可用代码质量报告标题的自定义文本，它通过 FTP 传输直接来自于读码器或通过报告记录由设置工具生成。

请注意，如果是多代码，<PCM Data> 格式化令牌必须追加到所有使用的条码符号。


复选框中的双矩形表示什么？

较大空心矩形内的较小实心矩形称为中间核取状态。在这种情况下，它表示虽然启用了该选项，但还没有完全生效（这种情况主要是因为该令牌是从脚本面板中手动移除）。


报告 FTP 传输选项卡用来做什么？

报告 FTP 传输选项卡允许设置要通过 FTP 以 HTML 报告形式发送的代码质量结果。必须勾选启用代码质量报告传输复选框，允许设备通过 FTP 发送结果并通过提供服务器地址、用户名、密码和服务器类型找出所要发送数据的服务器。

空闲超时是指端口保持开放而无外出通讯量的时间量。一旦读码器打开至 FTP 服务器的连接，只要出现通讯量，读码器都将保持连接开放。如果在设置了空闲超时时间而没有出现通讯量，连接将会关闭。这在很少进行 FTP 传输以及网络需付款，不需要使连接保持打开时很有用。首先需要选中能设置空闲超时的启用空闲超时。

文件名下方的设置决定 FTP 报告文件的名称生成。有以下选项可供设置：

  • 自定义文件名生成：如果要自己提供文件名，选择此选项。可以在文件名下方指定名称。文件名字段中不仅可以输入文件名，还可以输入路径名称。正斜杠用作分隔符。例如，/images/image。追加设置允许设置文件名生成的编号规则：最大追加值设置文件名编号的最大数目，最大追加起始值设置文件名编号开始位置。

  • 脚本生成的文件名：启用此选项后，点击蓝色选项名称以立即导航至脚本 > FTP 传输，在此已提供文件名生成的示例脚本。

  • 服务器生成的文件名：选择此选项后在此处提供服务器地址以生成基于服务器的报告文件名。一些 FTP 服务器支持此功能，在将传入的文件保存到磁盘之前为其唯一命名。


如果服务器生成的文件名 FTP 传输程序不工作，应该怎么办？

验证 FTP 服务器是否可以处理 "STOU - Store Unique 命令。此命令的作用为 STOR，除在当前具有唯一名称的目录中创建目标文件以外。


为什么整个面板在传输文件时都禁用？

禁用面板以实现图像 FTP 传输的最大稳定性。根据连接至 FTP 服务器的速度和图像大小以及要传输的图像数量，图像 FTP 传输可能需要一些时间。


代码质量工具视图


在代码质量工具视图中能看到什么？

在代码质量工具视图下方可查看代码质量评估的结果。能够在此处查看结果之前，必须在代码质量面板上（需要功能键）启用代码质量计算。对于结果历史记录工具视图中选定的每次读取，之前设置的代码质量标准和指标显示在代码质量工具视图中。在每种类型的代码质量标准的顶部，都可以看到读码的整体等级。

属性列出了给定标准的个别指标，值是指个别指标所计算的数值差异。等级是指给出指标的代码质量等级（此列中也出现彩色图标；绿色 = 通过，红色 = 失败，黄色 = 阈值）。平均值是指基于该指标最近 100 次读取的平均等级（用 + 和 - 表示趋势）。

关于代码质量标准、等级和指标的更多信息，请查阅 DataMan 通信与编程指南或参见 www.iso.org 网站相应的 ISO 标准文档。


测试模式


什么是测试模式？

测试模式可在不中断任何生产的情况下，使用实时系统测试和设置设备。在此模式下，所有触发源（除设置工具和按钮触发外）都处于禁用状态。


什么是自动触发？

自动触发可在外部触发模式下内部（自动）触发设备。也就是说，即使选择了外部触发类型（任何非演示或自触发模式)，也可以在测试模式下自动触发读码器。可以通过这种方式确定设备是否能运行常规模式中使用的参数。


哪些功能在测试模式下会受到禁用/限制？

  • 除设置工具和按钮触发外的所有触发源都会禁用。

  • 可以禁用所有的输入和输出。如果这样做，结果仅会发送到设置工具，LED 灯/蜂鸣器会工作，但不会有任何输出。


可接受的触发器数量是多少？

在禁用所有触发源之前，可以定义将接受的触发器数量。


读取设置


读码设置对哪种触发模式有效？

读取设置可用于单触发、自触发、多触发和连续触发模式。下一个读取设置在指定的间隔时间 （在照明与成像器设置面料中指定）后变为活动状态。对于所有其他触发模式，如果已经配置了多种设置，则只会使用当前选定的活动设置（在状态栏中显示）。因为单击触发模式无间隔时间，所以当上一次采集完成后立即进行下一次读取设置。


如何添加、复制或删除设置？

要添加读取设置，点击添加设置按钮。在弹出的窗口中，可以确定是否要为新设置使用默认值，或者是否要从现有设置中复制值。

要删除读取设置，通过选择读取设置栏进行选择，然后点击删除设置按钮。

要复制和粘贴读取设置，选择要复制的列并点击复制按钮或按下 Ctrl+C，然后进入将被新设置覆盖的设置栏。点击 粘贴 按钮或按下 Ctrl+V组合键. 该栏中原有值将被剪切的值替代。


什么是开始设置选项？

如果启用了多个设置，读码器全部扫过，当读到代码后停止获取图像。要读取下一个代码，可以确定读码器是否从所选设置或从最后成功解码的设置开始检查。


可以更改读码设置的顺序吗？

可以点击更改顺序按钮并重新排列弹出窗口中读取设置的顺序。设置将重新连续计数。


什么是顶部的筛选器字段？

可以键入要查找的参数，例如，大小或多次触发，然后按下 Enter 键。找到的项目将突出显示，并且只有那些包含搜索项的参数节点才会展开。可以通过删除所键入的内容并按下 Enter 键关闭搜索。


调谐如何影响读码设置参数？

调谐面板中的最佳结果表格用于当前活动的设置。只有调谐的参数受影响。


为何无法使用更多设置？

如果使用图像过滤，则由于设置内存的内部原因，可能无法启用所有设置。


读取设置：一般布局与结构

读取设置是用来设置、复制、比较或恢复读取设置的表视图样式工具。文档页面的主区域包含一个带设备属性的网格。

标题行显示所选的设备名称。下面的第二标题行显示设备的可用设置。通过点击它旁边的图标可折叠或打开下面的行标题（以粗体显示）。断开设备连接时，其标题行会出现重新连接图标。


读取设置：控件（鼠标和键盘）

选择：

  • 鼠标：点击网格中的单元格并进行选择，会突出显示单元格的行标题以及设备和设置所属的列标题。菜单按钮和功能区菜单项可以根据选择进行更改。如果所选的单元格位于行标题行中，属于标题的当前列中所有的单元格都会被选择。

  • 键盘：光标移动键可将选择导航到相应的单元格。突出显示和选择操作与使用鼠标相同。

添加/更改值：

  • 鼠标：对于采用嵌入式编辑器的单元格，点击编辑器控件（组合框、复选框、数字选择）允许输入值。对于采用自定义编辑器的单元格（...图标），弹出式编辑器将打开，允许输入值。

  • 键盘：对于采用嵌入式编辑器的单元格，按下 Enter 或 F2 启动编辑模式，按下 Esc 键取消编辑，第二次按下 Enter 键确认编辑。不用进入编辑模式，即可以在选定的文本中输入值，在此情况下第一次击键将会覆盖当前值。

    对于数值单元格，除了嵌入式文本编辑器单元格外，向上和向下箭头可增加和减小值。

    对于下拉式单元格，按下 输入 键启动编辑模式并显示下拉菜单项，而 向上和向下箭头 可移动所选的内容。第二次按下 Enter 键应用选定的值，按下 Esc 键取消编辑。

    对于复选框单元格，使用 Space 可切换选中/未选中状态。

复制和粘贴：

使用组合键 Ctrl+C 和 Ctrl+V 进行复制和粘贴，欲了解更多信息，请查看相关功能区菜单项的复制粘贴介绍。


读取设置：功能区菜单

功能区菜单可在表视图样式网格上方找到。其内容和活动图标可能会随网格中单元格、行或列的选择而变化。菜单可分成几组。

  • 表视图：使用添加设置按钮添加读取设置。在弹出的窗口中，可以确定是否要为新设置使用默认值，或者是否要从现有设置中复制值。删除设置按钮用来删除选定的读取设置。更改顺序按钮会打开一个弹出框，在此可重新排列读取设置的顺序。设置将重新连续计数。

  • 开始设置：如果启用了多个设置，读码器全部扫过，当读到代码后停止获取图像。要读取下一个代码，可以确定读码器是否从所选设置或从上次成功解码的设置开始检查。在此可以从下拉列表中选择该开始设置。或者，选择上次成功解码以选择上次成功解码的读取设置作为开始设置。

  • 编辑：使用复制（或键盘上的 Ctrl + C）从当前选定的单元格复制值。粘贴只能用于同一行中或任何文本编辑器中。重置值用于重置所选单元格的值。

  • 突出显示：此菜单组中的按钮和设置提供选项以突出显示特定的单元格背景。使用非默认值设置，具有非默认值的单元格会突出显示（这在不同设备或读取设置的单个行中可能会不同）。不同于参考设置突出显示单元格，这些单元格与参考读取设置（和设备）同一行中的单元格具有不用的值。选择第三个设置，所有的值和标题都会突出显示，包含文本框中指定的文本。此外，包含的文本本身也使用不同的文本背景突出显示。同样按下 Enter 键也会应用仅显示突出显行按钮的功能。

    启用时，仅显示突出行会折叠所有不包含突出显示子节点的节点。激活时，设置参考读取设置在使用不同于参考突出显示模式时指定用作参考的读取设置（和设备）。当按钮处于活动状态时，当前所选单元格的列（读取设置）变为参考设置。当前的参考设置在设置名称标题行中被标记。

  • 过滤：自动设置读取设置，允许只查看与读取设置相关的设置。设置全局设置只查看在不同读取设置中不能有不同值的设置。设置所有设置以同时查看所有设置。如果条目的值出现在多个读取设置中，它们将显示在不同的列中。

  • 其他：使用展开所有行以展开网格中所有折叠的行。使用折叠所有行以折叠网格中所有展开的行。重置布局将重新计算列宽度以用完所有可用的空间。如果可用空间不够，会使用最小列宽度。


设备日志


什么是设备日志？

此视图显示设备上红色 LED 闪烁时生成的日志。当此日志不再需要时可以刷新或删除。


图像尺寸


对器兴趣区 (ROI) 解码设置有什么用处？

使用此功能可指定读码器用来寻找符号并解码的准确图像区域。这对两个 Data Matrix 代码间相距很近，并且需要确保仅读取沿目标瞄准线的代码很有好处。缩小兴趣区不一定会缩短解码时间或提高图像传输率。

注：设备正在获取或解码图像时，无法更改一些图像相关的属性（如图像大小、筛选）。


为什么要更改成像器视场 (FoV)？

适用于单触发、多触发和连续触发类型，可以修改视场以减少读码器采集的每个图像的尺寸，这可以增加内存量，从而使指定的连击长度更长。


为什么无法更改解码器 ROI？

确保成像器 FOV 未选中。如果成像器 FOV 选中，就无法设置比成像器 ROV 边界更大的解码器 ROI。


解码器 ROI 的大小对读码器配置代码是否会产生影响？

限制兴趣区过小可能会导致读码器无法读取读码器配置代码。


焦点设置


优化焦点用来做什么？

与快速设置面板一样，优化焦点按钮将根据当前视场将液体镜头设置为优化值。


如果打开启用优化焦点反馈选项会怎样？

通过选中此复选框，启用优化焦点反馈，依次以彩圈覆盖图案的方式在图案显示区域（位于快速设置下方）或图像面板上提供视觉反馈。红区位于焦点外，而绿区位于焦点内（圆圈越大，焦点越多）。


焦点确定模式选项用来做什么？

焦点确定模式选项允许在触发过程中为图像采集的液体镜头确定时间指定预设配置。 为正常确定的模式设置正常，为速度较慢、但更精确的模式设置精确。


如何确定液体镜头的焦点值是否正确？

要确定最佳的焦点扫掠设置，单击实时显示已启用复选框并根据实时图像试用滑块。


焦点扫掠为什么不可选？

焦点扫掠仅支持手动和演示触发模式。


如何使用焦点范围设置？

通过使用滑块、滑块两端的+和-按钮或键入值，可以使用焦点范围选项手动更改设备的焦点距离。焦点范围的单位可以是毫米或屈光度。当提供其中一种值时，设置工具将自动计算另一个值以匹配已更改的那个值。

滑块的橙色区域表示扩展的范围（超过 500 毫米），此处仅适用于屈光度。当设置处于此区域内时，禁用以毫米为单位的值（当值再次处于扩展的范围之外时重新启用）。

注意，使用+按钮时屈光度减小，使用-按钮时屈光度增加。


如何计算距读码器的距离？

根据从镜头盖前方到要解码图像的距离来计算距离（以毫米计）。

设置时，也从镜头前端到图像来测量屈光度。


图像过滤


如何使用图像过滤？

  1. 单击添加并从堆栈过滤器列表中选择过滤器。

  2. 在过滤器属性组合框中，为指定的过滤器选择适当的参数。通过使用向上和向下按钮移动过滤器，也可以指定完成过滤的顺序。

  3. 根据要过滤的代码类型在要使用的图像分组框中更改选择（在确保启用此代码类型后）。

  4. 进入显示的图像设置面板，根据想在实时显示中看到原始图像还是过滤图像，更改要使用的图像。


什么是不同的过滤器？

  • 均衡：该过滤器重新分配图像中像素的亮度值，从而使亮度级别的范围体现得更为均衡。如果图像过暗或过亮，可使用这个过滤器。

  • 拉伸：该过滤器可将输入图像的灰度值按线性比例放大或拉伸到全 256 级灰度，结果使输出图像的对比度增加。

  • 低通：使用该过滤器会导致输出图像的边缘出现光滑或模糊不清的情况。

  • 扩展：该过滤器可增强明特性并降低暗特性，结果使输出图像的明像素区域更大。使用这个过滤器可删除暗斑。

  • 削弱：该过滤器可降低明特性并增强暗特性，结果使输出图像的暗像素区域更大。使用这个过滤器可删除亮斑。

  • 松散：该过滤器根据扩展情况执行削弱操作，过滤掉比处理周围尺寸小的明特性。结果使输出图像的总体亮度稍有降低。

  • 紧密：该过滤器根据削弱情况执行扩展操作，过滤掉比处理周围尺寸小的暗特性。结果使输出图像的总体亮度稍有增加。

  • 自动拉伸：该过滤器可减少像素值范围，它映射的像素值范围从 0 至 255。

  • 光密度：该过滤器根据对数标度指定倒置的像素值。结果是输出图像通过测量通过它们的光量显示出输入图像中的对象密度和特性。对象和特性的密度越大，表示输出图像的像素越亮。

  • 倒置：该过滤器根据 256 级灰度指定倒置的像素值。结果是使输出图像呈现输入图像的底片。

  • 中值：此过滤器应用于图像的所有像素。对于每个像素，过滤器观察周围像素的亮度，并将像素设置为中值。这使得图像更平滑，具有较少和较弱的极限值。

  • 伽马校正：此过滤器基于作为子设置提供的伽马校正值进行亮度调整。

  • 缩放比例：此过滤器允许图像沿 X 轴和 Y 轴（各自或同时）进行百分比缩放。


什么是未读取图像？

如果读码器不对图像解码，结果历史记录会根据未读取图像下方的选择显示图像。例如，如果选择 Data Matrix，结果历史记录将显示选择的 Data Matrix 图像：原始或过滤。


为什么所有的过滤器选项都禁用？

在演示和自触发模式下，所有的过滤器选项都禁用。如果在这些触发模式下仍想使用图像过滤，请先切换到另一种触发类型，设置过滤器并改回演示或自触发模式。


XPand ROI 设置


Xpand ROI 设置有什么用处？

可以使用此功能来指定读码器通过 FOVE 看到的每一部分图像的确切区域。这可能有助于禁用相同代码检测两次时图像中间的重影区。缩小兴趣区 (ROI) 不一定会缩短解码时间或提高图像传输率。

现有的视场扩展器 (FOVE) 已预配置最适当的设置，但可以通过手动调整参数来微调设置（自定义设置）以达到在用特定 FOVE 的最佳效果。读码器、FOVE 和镜头以不同方式使用了系数。

注：设备正在获取或解码图像时，无法更改一些图像相关的属性（如图像大小、筛选）。

注：务必检查正在使用的设备是否与尝试校准的 FOVE 相兼容！


为什么要更改视场 (FoV)？

适用于单击、多击和连续触发类型，可以单独修改每个视场的区域以减少读码器捕捉的每个图像的尺寸，这可以增加内存量，从而使指定的连击长度更长。设置这些视场可以排除些由于与视场扩展器 (FOVE) 有关的光学现象，篡改或干扰代码检测的一些图像区域。


ROI 的大小对读码器配置代码是否会产生影响？

限制兴趣区过小可能会导致读码器无法读取读码器配置代码。


OCR


什么是 OCR？

光学字符识别 (OCR) 是一种能为用户提供使用 DataMan 设备将打印字符转换为编码文本的功能。该设备必须首先用能够使用 OCR 所需的字体进行训练。OCR 仅适用于单触发模式，不支持多代码。


如何设置 OCR？

根据步骤（见下文）完成 OCR 设置，但这些步骤可以按任何顺序导航。请注意，OCR 仅在单触发模式下工作。使用上一个和下一个按钮或点击 OCR 面板顶部的面板直接进入面板来导航。摘要面板列出所有设置，红色表示错误。可以使用修复图标直接导航至与错误相关的面板。

字体︰可以上载要用于 OCR 读码器的字体。在对话框中显示已使用的字体。点击其中任意一个可以在对话框下方进行附加操作。请注意，编辑字体与上载字体的操作相似，但可以选择上载中要包含的字符。这样可减少文件大小，使设备的加载时间更快。使用Ctrl + 点击在弹出窗口中逐一添加字符。可以使用字体弹出窗口中确定按钮旁边的箭头以显示上载为，用它可以更改字体文件的文件名。

固定︰可以使用图像框中读取图像上的 ROI （兴趣区）字段在条码符号或样式上设置固定装置，以便将 OCR 读码器定位在与固定项有关的位置。固定在样式上时，黄色区域用于训练的样式，橙色区域用来提供在操作过程中查找样式的框架。固定在条码符号上时，必须设置设备查找的相应代码。在这两种情况下，都必须使用训练固定项以完成固定。

OCR 字符串：要完成 OCR 设置，导航至 OCR 字符串 1。绿色的训练或红色的不训练表示 OCR 字符串的状态（此颜色代码也适用于该选项卡名称）。可以从已上载的字体类型中选择所选字体下方字符串的字体。

勾选字段，以设置在 OCR 读取过程中哪些字符可以位于特定位置。工具提示（导航鼠标指针置于字段组右侧的文本字段）表示字段字符串中字符代表的意义。

接着，导航 OCR ROI 字段进入图像中文本上方的位置，然后输入训练文本。

接受阈值是一个字符得分，允许控制 OCR 读取接受哪些字段的阈值。图像上的读取是彩色编码。

在仍被接受的 OCR 读取中，第一和第二个匹配之间最小的字符得分差异上设置信度阈值。

一切设置完成后，点击训练 OCR 以完成 OCR 字符串的训练。请注意，如果正在使用条码符号固定，或要读取代码而非 OCR，那么继续选中允许部分结果！

在 OCR 字符串 2-4 下方也可以设置其他 OCR 字符串，每个都有专属的视觉提示（分别以彩色 ROI 框表示） 。请注意，训练的 OCR 字符串越多，设备运行速度越慢。

注：不支持多代码训练。


代码数量有什么用处？

可以同时读取多种类型的代码。在这种情况下，在代码数量下方提供将要读取的代码数量。之后必须提供最大 OCR 代码数量，确定将要读取 OCR 字符串的数量（例如，代码数量是 3，最大 OCR 代码数量是 1，那么要读取 3 个代码，其中一个是 OCR，另外 2 个是其他代码类型，例如 DataMatrix）。在链接的条码符号设置面板中可以设置其余的最大代码数量。

允许部分结果：如果勾选，即使找不到在代码数量和最大 OCR 代码数量下方设置的所有代码，此选项也能使设备报告有效读取。如果正在使用条码符号固定，或要读取代码而非 OCR，那么继续选中允许部分结果！

允许 OCR 总是报告有效读取：如果勾选，此选项会导致设备将无效读取报告为有效读取，以便用户可以看到如何读取单个字符。绿框表示有效读取，蓝框表示读取低于接受阈值的 25%、黄框表示信度得分低于信度阈值，红框表示无效读取。请注意，当设置工具从设备断开连接时，此选项自动不勾选。


何时需要重新训练 OCR？

必须最开始就训练 OCR，但当设置发生更改时，必须重新训练。作为一般规则，当设置和一致性出现重大更改时，包括更改字体类型、代码类型以及首次完成样式与条码符号固定之间的更改（切换回样式或条码符号固定不需要重新训练），必须重新训练 OCR。


OCR 训练会获取图像吗？

在 OCR 训练过程中不会获取新的图像。读码器在上次解码尝试后保留的图像上工作（这可保证在相同图像上正好执行多个训练步骤）。这通常是设置工具中显示的图像，但也可能有例外：

a) 在焦点或亮度优化后，新的图像发送到设置工具，但 OCR 训练不在该图像上工作。相反，OCR 在上次读取后保留的图像上工作。

b) 如果使用多个读取设置，显示的图像不一定是使用启用读取设置获取的图像。

基于上述原因，强烈建议启用一个读取设置（启用的那一个），并触发设备以在训练前获取新的图像。


数据验证


什么是数据验证？

数据验证是用于确认符号解码数据是否符合特定公司、行业或国际标准的正确格式。


数据验证的结果历史记录在何处显示？

数据验证通过/失败和输出结果显示在结果历史记录中。结果历史记录列表中的结果条目将出现+图标，用于打开验证尝试的结果详细信息。能以同样的方式在结果历史记录中查看过去的验证结果。


验证错误代码表示什么？

数据验证失败的结果如下：

  • 1：条码符号标识符无效。条码符号标识符是 3 个字符串，不仅识别用于数据编码的条码符号类型，还描述了如何处理数据。此字符串可选作输入传递给工具，除此之外，还可作为单独实体或把它作为前缀加到数据流的解码数据。

    示例：对于 UCC/EAN-128 符号，该条码符号标识符为 ]C1。在某些应用中，这将是唯一准确且自动区分内部或行业 Code 128 和 UCC/EAN-128（即编码 EAN.UCC 应用标识符）符号的方法。没有条码符号标识符，就不知道如何处理符号中的数据。

  • 2：样式不匹配。

  • 3：数据限定符（AI、DI 或 TEI）无效。

  • 4：应用标识符 (AI) 无效。

  • 5：数据标识符 (DI) 无效。

  • 6：文本元素标识符 (TEI) 无效。

  • 7：数据无效：数据是否与数据限定符的类型、长度或值不一致。

  • 8：字符分隔符无效。

  • 9：不兼容 ISO/IEC 15434。

  • 10：不支持的格式（例如在 DoD UID 应用中，格式并非 05、06 或 DD）。

  • 11：格式代码无效：格式代码非 00-99 和 DD。

  • 12：如果选中 ISO/IEC 15434 验证选项，但解码流并非来自 2D 符号，则不支持 ISO/IEC 15434。只有当条码符号标识符作为输入传递给工具时，才可以报告此次失败。

  • 13：应用字段无效：应用中不支持的字段。

  • 14：应用字段不受支持：应用中支持，但工具不支持的字段。

  • 15：应用数据无效：数据是否不能满足特定应用的要求。

    示例：DoD UID 应用有以下要求: 字符的企业 ID 字符串不超过 13 个字符，不包括数据限定符。字符的原始部分、批次字符串（包括允许的特殊字符）不超过 32 个字符，不包括数据限定符。字符的序列号字符串（包括允许的特殊字符）不超过 30 个字符，不包括数据限定符。

  • 16：同一数据流中存在多种格式（例如在 DoD UID 应用中，数据流中不能出现一种以上的格式）。

  • 17：字段重复：同一符号中多次出现相同的数据限定符。某些应用（如 DoD UID 应用）不允许同一符号中重复字段。

  • 18：UID 无效：并非所有构造有效 Construct #1 或 Construct #2 UID 的字段都要出现。

  • 19：Construct #1 UID 无效：并非所有构造有效 Construct #1 UID 的字段都要出现。

  • 20：Construct #2 UID 无效：并非所有构造有效 Construct #2 UID 的字段都要出现。

  • 21：检查 ISO 15434 语法或 DoD UID 符合性时丢失格式尾部。

  • 22：检查 ISO 15434 语法或 DoD UID 符合性时丢失消息尾部。


什么是 DoD UID 验证？

DoD UID 验证是用于评估用 Data Matrix 解码的数据是否根据美国国防部军用标准 130 准则正确解码。美国国防部现在要求所有接收或维持的存货商品（价值超过 5,000 美元或具有独特的序列化）都采用唯一的序列号 (UII) 和特定语法格式标记。DoD UID 验证工具是用于确定代码中的数据格式是否符合国防部构造类型 1 或 2 。DoD UID 验证功能也自动确定数据字符串是否符合 ISO 15434 和 ISO 15418。连接的 UII 输出（或只是 UII 的数据元素，无 ISO 15434 句法和 ISO 15418 数据限定符）显示在结果任务面板中验证结果字段的第一个结果字段中。

构造 1 数据元素包括：制造商的企业标识符 EID（CAGE、DUNS、EAN.UCC），公司标识符加上 EID 标识符内的零件序列号。根据公司是否使用 DI、AI 或 TEI 格式，用指定数据标识符来表示企业标识符和序列号。

构造 2 数据元素包括：制造商企业标识符 (EID)、零件制造商的部件号 (PN) 和零件批号 (BN) 标识符以及制造商指定零件编号内唯一的零件序列号。根据公司是否使用 DI、AI 或 TEI 格式，用指定数据标识符来表示企业标识符、部件号/批号和序列号。

注：该选项并非适用于所有的读码器。


DoD UID 验证应使用何种代码类型？

美国国防部现已将 Data Matrix 代码指定为 UID 标记的标准。


什么是预期的 EID？

预期的 EID 是指 UII 数据字符串中的制造商企业标识符。制造商的企业标识符 (EID) 表示制造商的 CAGE、DUNS、EAN.UCC 代码或其他标识符。预期的 EID 是 DoD 指定值。


什么是预期的 PN？

预期的 PN 是指 UII 数据字符串中的制造商部件号。预期的 PN 是 DoD 指定值。


什么是预期的 BN？

预期的 BN 是指 UII 数据字符串中的制造商批号。预期的 BN 是 DoD 指定值。


什么是 ISO 验证？

ISO 验证功能是用于确定数据字符串是否根据 ISO 15434 语法或 ISO 15434 以及 ISO 15418 正确解码。

ISO 15434 确定数据字符串是否用正确的语法来解码，其包括对字符串中的不可打印ASCII 字符的赋值，例如信息标题、记录分隔符、格式代码（用于 AI、DI 或 TEI）、组分隔符和传输字符的结尾。

ISO 15418 确定每个数据元素的数据字符串是否使用正确的数据标识符来解码。视制造商是否使用 AI、DI 或 TEI 格式而定，每个数据元素（制造商的 EIN 码、部件号和序列号）前都有特定的代码或数据标识符。

注：该选项并非适用于所有的读码器。

注：此选项还允许文本元素标识符按 ATA CSDD 规范进行定义。


什么是 GS1 验证？

GS1 验证可对照 GS1 规范检验符号的句法和语意。读码器可按照可配置标识符字符串检验解码数据。支持所有的应用程序标识符。

默认情况下，读码器对照欧洲制药工业协会联合会 (EFPIA) 的格式字符串检验输入的符号，例如：

<AI(01)><AI(10)><AI(17)><AI(21)>

使用 GS1 验证，当符号中的数据（包括回车符和换行符）未通过验证验证时，可配置读码器传输的内容。详细结果面板将显示每个符号的通过或失败情况，并列出符号中每个应用标识符连同随附的数据元素。


什么是匹配字符串验证？

匹配字符串验证可指定确切的字符串以匹配由符号解码的字符串。只有符号中包含匹配特定字符串的字符串，才能生成通过结果。


如何使用变化值验证字符串？

启用递增/递减数字要素控制项，指明要验证的字符串部分为每次连续读码增加或减少的数值。


递增/递减数字要素有什么用处？

在解码数据序列化应用或某些线性情况下出现变化时，使用此功能执行匹配字符串验证。例如，使用条形码跟踪页码的杂志或书本装订应用，可从递增/递减数字要素中获益，确保无重页或跳页。


如何配置递增/递减数字要素设置？

如果正在验证的字符串包含一系列每次连续读码增加或减少的数字 (0-9)，可以使用此功能。要使用此功能，在开始位置字段指定增加或减少数字的起始位置（0 为第一个字符的位置），并在长度字段中指定将发生变化的字符数量。如果在长度中选择自动，读码器将从起始位置的所有连续数字视作增加或减少数值。使用步长指定读码之间的数值变化量。如果数量减少，选择一个负值。

例如，如果起始字符串为 ABC_123XXPY，随着每一次连续读取，123都增加一，则会指定开始位置为 4，长度为 3，步长为 1。（如果确定位置 7 上绝不可能是数字，也可以将长度指定为自动。）请注意，自动设置在达到最大编号时不会增加位数，但会用任何固定的位数设置来重置编号（例如，两位数在达到 99 时，不会变到 100，而是重置为 00）。

在默认情况下，如果字符串无效或无法读取，则期望的数值不会更改。当未读码或代码无效，或同时出现这两种情况时，可以使用未读码更新和验证失败更新复选框来指定要更改的期望值。


模式匹配验证有什么用处？

模式匹配验证允许用户输入指定字符串以确定他们是否出现在数据字符串中。例如，用户可以输入以 DI 格式使用的模式 17V 以识别制造商的企业标识符。如果代码中出现字符 17V，读码器则发送该代码通过验证的信号。如果不出现该字符，读码器将发送验证失败的信号。

必须使用正则表达式作为样式验证的样式。


验证失败操作有什么用处？

验证失败操作用于确定在验证失败之后读码器输出的内容。用户可以选择不同的选项：

  1. 传输验证失败- 读码器在代码验证失败之后将输出字符串验证失败
  2. 传输验证失败+ 解码字符串 - 读码器在完成解码字符串之后将输出字符串验证失败
  3. 传输带注解的解码字符串 - 读码器将输出解码字符串连同错误类型信息和字符串中的错误位置
  4. 不传输 - 读码器将不输出任何信息。
  5. 传输验证失败 + 引用的解码字符串 读码器将输出字符串验证失败，随后引用解码字符串的一部分。


验证失败操作添加 CR/LF 复选框有何用处？

CR/LF 复选框用于在验证失败输出之后提供回车/换行。


如何搜索多个匹配字符串？

使用样式匹配验证并输入 Perl 格式化匹配字符串。例如，要匹配字符串 123、456 或 789，键入以下内容：

^(123?456?789)$


启用数据验证时会怎样？

数据验证状态显示在结果历史记录面板结果状态的结果列表条目中。成功验证的状态为有效，失败验证为无效。要查看更多验证结果的详细信息，可以展开结果。


什么是失败验证的数据格式？

如果数据验证失败，基本格式化数据格式不应用到结果中。相反，执行验证失败操作。这不同于脚本格式化数据格式。如果启用了脚本格式化，则不执行验证失败操作，而是执行脚本格式化功能。例如，它允许通过脚本细化数据验证状态。


备份设置


什么是自动读码器配置备份？

自动备份用于通过以太网连接的设备。启用时，每次配置保存到闪存时，此功能都会将设备配置备份到外部存储器（FTP 服务器）。Cognex Explorer 服务可以接收备份数据。可以通过设置工具、DMCC 命令或 Cognex Explorer 手动进行恢复。

以所需的 IP 地址和端口号配置读码器，以指定配置的保存位置。还可以设置用户名和密码组合。


打印设备备份代码


打印设备备份代码选项用来做什么？

使用此选项打印读码器备份代码（硬重置并重启代码），以便通过读码器读数来替代设备。这些代码也包含网络设置和串行设置。

在 备注 部分，可以填写也会显示在打印页上的重要事项。如果需要打印单独的重设代码页，则要勾选 在各自页面中打印重设代码 复选框。


打印配置代码


打印配置代码选项用来做什么？

使用此选项可打印读码器配置代码（硬重置并重启代码），以此设备或需要配置的设备来读取。

在 备注 部分，可以填写也会显示在打印页上的重要事项。如果需要打印单独的重设代码页，则要勾选 在各自页面中打印重设代码 复选框。


多个读码器同步


哪项触发组合支持多个读码器同步触发？

只有主读码器和辅助读码器使用特定的经许可的触发模式时，多个读码器同步触发才能准确工作。触发模式组合如下：

  • 自触发/自触发

  • 单击/连击、单击/单击、连击/连击，连击/单击

  • 手动/连续、手动/手动、连续/连续、连续/手动

  • 演示/演示、自/演示、演示/自


什么是组触发？

同组和同一子网中的所有读码器只受活动的主读码器这个触发源触发。


如何收集和报告结果？

当 组触发 启用时，读码器收集辅助读码器的结果，此时该读码器作为主读码器；之后该读码器会当做辅助读码器，然后将结果发送给主读码器。


如何添加新的组名称？

  1. 单击新增按钮。

  2. 新增组对话框出现。选择所需的组名称并单击确定。确保使用唯一的组名称。

  3. 查看新组是否出现在组名称列表中以及读码器是否位于右边的列表中。

  4. 对于组中任何不想被干挠的设备，可以在网络设置面板的验证选项卡中设置密码。


如何让主读码器根据多个读码器组中每个读码器来记录所有代码结果？

在多个读码器同步模式下，可以配置主读码器使其能够记录其自身代码结果并能够记录所有辅助读码器中的代码结果。为此，在 符号设置 面板的 多代码 选项卡中，必须为主读码器配置 代码数量 。这个值必须设置为多个读码器同步组返回的代码总数。

例如，如果主读码器和辅助读码器均读取一个单独的代码，则主读码器的代码数量设置为2。如果辅助读码器读取了3个代码且主读码器读取1个代码，则主读码器的代码数量设置为4。主读码器中的代码数量设置可以各不相同，从 1 到一个单独的多个读码器同步组中所有读码器读取的代码总数。

请注意，如果辅助读码器读取多个代码，还必须配置辅助读码器的多代码设置，以便能够读码并将多个代码结果返回到主读码器。


为什么组名称消失了？

没有将任何读码器指定给那个组名称。只有将至少指定一台读码器，组才存在。将最后一台读码器移到别的组会删除该组。


哪个读码器是主读码器？

如果组中的读码器正在使用自触发或演示触发模式，则每部读码器的此组中的读码器列表中将显示一个复选框。勾选读码器前的复选框，使其作为主读码器。

如果读码器组正在使用外部触发或接收到软件触发（例如从设置工具），则先接收触发的读码器将作为主读码器。

对于所有的触发模式，一组中只有一部读码器能够在指定时间用作主读码器。


为什么无法在列表中找到我的读码器？

如果设置工具在与读码器相连的不同子网的 PC 上运行，读码器将不会列在任何一个列表中。使用添加设备按钮将读码器添加至列表中。


如何防止组中的其他人连接至我的读码器？

为读码器设置密码。进入网络设置面板，在验证选项卡中设置密码。


什么是辅助读码器响应超时？

辅助读码器响应超时是指主读码器等待辅助读码器结果的时间（以毫秒计）。


为什么辅助读码器的数据格式化操作没有生效？

在多个读码器同步模式下，主读码器将辅助读码器的所有代码结果作为自己的结果。这意味着主读码器的数据格式化操作将生效，但不会考虑辅助读码器的格式化规则。


触发延迟在多个读码器同步模式下如何工作？

主读码器和辅助读码器通常同时触发，但是可以为主读码器和组中的每部辅助读码器设置触发延迟。主读码器的触发延迟总时间就是主读码器中设置的触发延迟时间。辅助读码器的触发延迟总时间为主读码器触发延迟时间 + 辅助读码器触发延迟时间。


什么是同步读码器选项？

在单击、连击、连续和自触发模式下，可以使用同步接口同步多个设备上的图像采集。

同步可使用一个共用的频闪照明同时曝光所有的传感器。最多可同步 16 台读码器，以规定的顺序有选择地触发，以避免相对的读码器互挡光线。请注意，同步触发仅支持专用连接器上的外部照明。

请注意，这一机制不能同步和其他的成像器设置 例如，必须在每台读码器上单独配置曝光和增益。此功能仅通过现有多个代码同步机制同步实际的图像采集、触发次数。

要在读码器上设置同步采集，则要在同步的读码器 (IEEE1588)下方Dataman设置工具的 多个读码器同步 面板中启用 PTP（精确时间协议）选项。对每个读码器设置仅辅助相机，来定义 多个读码器同步 读码器关系。

以下步骤对设置进行了更详细的介绍：

  1. 勾选启用 PTP。

  2. 如果网络中已有 PTP 码时钟，保持选中仅辅助相机复选框（至少一台读码器以其他方式取消选中该复选框）。

  3. 在状态框中查看协议状态。

  4. 启用由PTP同步的MRS以同步多个读码器同步触发。

  5. 如果需要，设置触发开始与同步采集时间戳记之间的时间。这是指主读码器添加到触发器的时间，以确保所有设备在此时间戳之前已收到 TCP 数据包。

  6. 如果需要，设置已添加到同步采集时间戳的本地偏移。这表示辅助读码设备添加到时间戳以实现偏移图像采集的时间。


相同代码从不读取两次在多个读码器同步系统中如何工作？

如果在主读码器解码设置中启用 相同代码从不读取两次 功能并且辅助读码器读取到相同的代码，不论其来源如何，主读码器都会考虑所有结果并过滤掉重复的读数。


数据记录


什么是数据记录？

数据记录允许将成功读取的图像和未能读取的图像自动保存到指定的文件位置。此外，如果对读码器扫描的代码类型已启用数据验证，则还可以为验证的符号保存数据验证报告。对于数据记录，确保保持连接至设置工具。


何时在报告中禁用图形覆盖？

如果不希望在 PDF 文件中要读取代的码周围出现绿方块，检查在报告中禁用图形覆盖。


设备时间设置


设备时间设置下有什么设置？

可以从下拉菜单中为设备选择时区。以下文本框显示了设置的相关 POSIX 样式时区文本，可随意编辑。

如果选中了启用 NTP，设备的时区设置与下框 (NTP1) 中指定的服务器会同步。第二个框 (NTP2) 指向第二个可用于备份的 NTP 服务器，以及消除两个服务器之间的连接特定时间差异。指定 NTP1 已足够，但是如果包括两个服务器，就会增加时间精确度和可靠性。请注意，基于脚本格式化中的日期对象也会使用时区信息。


图像工具视图


什么是图像面板？

在此面板中，可以看到由设备所读取的图像。

使用放大镜图标可自动调整图像以适应图像工具视图窗口的大小，放大和缩小图像或分别以像素到像素模式显示图像。

此外可以启用或禁用焦点反馈在 LiveDisplay 模式下图像上，您可以将图像复制到剪贴板。

使用保存图像选项仅保存当前图像或所有连击图像，记录选项将所有不读取或所有解码图像记录到文件系统。通过选项菜单，单击上次记录选项记录和报告设置...以打开设置工具选项窗口，这也适用于设置工具的主页屏幕。

注：从图像面板保存上次拍摄的图像（通过拖放）时，显示的图像设置没有任何影响。上次的图像总是以全尺寸（设备的分辨率最大值）保存。


如果在读取符号时遇到了问题，该怎么办？

  • 确保读码器处于为符号大小和类型指定的工作距离内，如快速参考指南中所列。

  • 确保将符号置于读码器成像区的中间位置；确保触发设备时，符号置于红色激光瞄准束的中央。

  • 如已启用，单击优化亮度，使读码器自动调整图像亮度。（并非所有的触发模式都支持，不支持自动曝光。）

    注：如果一个 RoI 尺寸小于 144，优化亮度不工作。

  • 单击代码类型设置并确保使用的代码类型已启用。


如何使用设置工具触发读码器？

单击最上面工具栏中的触发按钮（照明按钮）或按下 Ctrl+T。


如何将采集的图像保存为文件？

单击工具栏中的保存图像按钮。通过打开下拉列表并单击保存所有连击图像可以保存连击模式下所有的图像。

也可以将图像拖放至 PC。单击图像查看器中的图像，将它拖至设置工具之外并松开。

请注意，如果想用拖放方式保存图像且它并非最后一个图像（正从读取结果历史记录中保存），图像将以显示的图像设置保存。在默认情况下，质量会降低。在显示的图像设置下方，将图像大小更改为全尺寸和位图格式。


为何在高帧/秒传输速率时无法看到所有图像？

如果正在使用可能以 100 帧/秒（或更高）的速率读取和传输图像的设置（自触发、演示或外部触发模式），则设备会将这些图像存储到自身的图像缓冲区，但设置工具无法传输所有图像。确保未核取显示的图像设置面板中的传输并显示图像复选框，以确保保持很高的传输速率。


什么是符号诊断（需要的功能键）？

符号诊断是一项从未读取条形码的设备提供图形化反馈的功能。通过查看反馈，可以解决条码无法解码的问题。从提供的反馈可以获知以下问题（在条形码区域内）︰

  • 未找到开始或停止样式（代码上的橙色箭头）

  • 条形码内部损坏/打印错误（代码上的红色矩形区域）

  • 静区不足（代码上的洋红色矩形区域）

  • 校验和验证失败（代码周围的蓝色矩形）

除了图形诊断外，符号诊断还返回每个未读取结果的可读性指标，显示在未读取代码的左上角。指标可以帮助评估图像或打印质量，有助于改善现有的设置。

符号诊断仅适用于上载的 PNG 图像（操作 > 图像 > 上载图像），它由 Cognex 读码器做标记（不一定是相同的读码器；用读码器保存时自动标记图像）。上载图像后，查看符号诊断反馈的图像面板或快速设置图像窗口。

注：符号诊断是一项专门由功能键激活的功能。


符号诊断中橙色箭头表示什么错误？

橙色箭头表示找不到开始或停止样式。被箭头指定的区域无法解码。失败原因如下（要详细了解每种情况的图像，请查看相应的技术说明）：

  • 开始或停止样式已剪切或损坏

  • 代码被剪切（由于图像边界或被物体挡住代码）

  • 图像质量下降（通常，但不是总是由照明质量造成）

  • 条形码标签翘曲和折叠

注：注：符号诊断是一项专门由功能键激活的功能。


在符号诊断中条形码内的红色矩形表示什么？

红色矩形表示条形码有物理损坏或打印问题。矩形内的区域是找到的损坏或有打印问题的位置。常见打印问题的例子（要详细了解每种情况的图像，请查看相应的技术说明）：

  • 渗漏的墨水把条码合成一片

  • 条码错误打印导致厚度降低，超出解码公差

注：注：符号诊断是一项专门由功能键激活的功能。


在符号诊断中条形码内的洋红色矩形表示什么？

洋红色矩形表示有静区违规。当条形码的一侧或两侧的空白不足时，会出现静区违规。视条码符号的不同，读码器会允许一些静区违规。静区违规通常发生在条形码周围的文本或矩形过于靠近条形码的一侧或两侧，或由于代码被图像边界剪切（要详细了解每种情况的图像，请查看相应的技术说明）。

注：注：符号诊断是一项专门由功能键激活的功能。


在符号诊断中条形码周围的蓝色矩形表示什么？

蓝色矩形表示此条码的校验和验证失败。校验和验证失败的常见原因如下（要详细了解每种情况的图像，请查看相应的技术说明）：

  • 条形码损坏（可以这样折叠和对齐条形码，以便解码所有的数据字符，但仍不读取，因为未能通过校验和验证）

  • 打印了不正确的样式（编码的字符串与打印的条形码样式不匹配，如果条码符号支持校验和，那么解码器就会显示此类故障）

注：注：符号诊断是一项专门由功能键激活的功能。


在符号诊断中的条形码区域附近会看到什么图形文本？

除了图形诊断外，符号诊断还返回每个未读取结果的可读性指标。像符号对比度和最低边缘对比度等指标可以帮助用户评估图像或打印质量，并有助于改善现有的设置。指标显示在每个未读取条形码的左上角。

下表列出了显示的指标名称与其完整名称之间的映射关系。请参阅可读性指标以了解每个指标测量的内容。

全名 | 显示的名称 | 可能的等级
符号对比度 | C | A、B、C、D、F
最低边缘对比度 | EC | A、F
打印增加量 | PG | A、F
最小反射比 | MR | A、F

注：注：符号诊断是一项专门由功能键激活的功能。


缓冲和传输


什么是缓冲的图像设置？

缓冲的图像设置控制着读码器如何缓冲响应采集触发信号而采集的图像以及读码器的实时图像。更改这些设置不会影响读码器的性能，只会影响读码器与设置工具之间的图像质量和传输速率。

  • 大小：在默认情况下，设置工具会显示每个采集图像整体像素的四分之一或每个实时显示图像的一小部分。选择不同的图像尺寸可使读码器对每个图像进行子采样，这可极大提高从读码器到设置工具的传输速度，但图像的精细度会有所降低。

  • 格式：在默认情况下，读码器以 .jpeg 格式储存采集的每个图像，它所需内存较少，并且能比 .bmp 格式的图像以更快的速度从读码器传输到设置工具。

  • 质量：仅在使用 .jpeg 图像格式时才可用。该滑块可调节内部参数，使读码器在采集的图像上执行流畅的操作，可降低或提高从读码器传输至设置工具的速度。


什么是叠加图形选项？

核取此选项时，保存（通过 FTP 或录制）的图像将包含叠加图形，与图像文件共同作为 SVG 文件。

要录制和播放图像时，此选项十分有用。缓冲和传输功能不进行任何解码，但如果核取了叠加图形选项，则解码的数据将与图像文件共同保存，并会在播放保存的图像时显示。


为什么看不到解码的图像？

缓冲和传输功能不执行任何解码。在缓冲图像设置中启用叠加图形，图像将以叠加图形保存（SVG 文件），播放图像时可显示。这些图形将在其他解码器信息中显示解码数据。


缓冲和传输可用来做什么？

缓冲和传输可控制读码器上记录和保存哪些图像，查看读码器上保存的图像，将那些图像传送到 PC。

  • 图像缓冲选项卡可控制读码器上保存哪些图像。

  • 图像 PC 传输选项卡可控制如何将图像从读码器传送到 PC。

  • 图像 FTP 传输选项卡可设置从读码器到 PC 的自动图像传送。

  • 结果 FTP 传输选项卡为读码器配置 IP 地址和端口号，需要时向 FTP 服务器发送解码的结果。


可以向 FTP 服务器发送解码结果吗？

使用 图像 FTP 传输选项卡为读码器配置必要的 IP 地址和端口号，以向 FTP 服务器发送解码结果。该选项卡还包含用户名和密码组合设置，连同要存储结果的文件名称。


如何将 FTP 数据储存到非根目录的目录？

文件名字段中不仅可以输入文件名，还可以输入路径名称。正斜杠用作分隔符。例如，/images/image。


为什么在 FTP 目录中看不到图像和结果？

确保拥有创建文件的必要权限。如果核取了添加，请确保 FTP 用户拥有添加权限（与写入权限不同）。FTP 用户也必须仔细检查正确 FTP 服务器的 IP 地址。


缓冲区列表结果用于什么？

缓冲区列表结果允许选择读码器内部缓冲的图像类型、是否包含解码信息（已读码）、无解码信息（未读码）、两者都（全部）或验证失败、哪些情况下只有成功解码而验证失败的图像可保存。

然而请注意，在连击和连续模式下，会根据确定序列是已读码或未读码存储整个序列的所有图像。对于连击模式，整个序列意味着按连击次数指定的所有采集图像。在连续模式下，只要触发信号仍处于活动状态，就会触发采集图像，这意味着在触发信号结束前存储和保存所有的图像。


什么是缓冲图像的结果？

可以选择缓冲图像的结果。相同结果指，对于成功读取，读码器仅储存找到了代码的图像。


什么是按结果限制的图像？

可以设置每个结果图像保存的数量。该数字不能大于图像缓冲区最大大小。

如果触发器要多次采集多代码，会希望限制图像，原因是可能有多个成功读码。还可以将这种限制用于未读取和多个无法解码的图像。


图像缓冲区的最大尺寸是多少？

图像缓冲区最大尺寸是指读码器最多可以缓冲多少个图像。这由读码器的内存决定，但设置数量应低于最大数量，防止超过 FTP 服务器或 PC 中所需保存的图像。

请注意，在连击模式下，连击长度+图像缓冲区最大大小必须等于读码器图像缓冲区的最大数量。如果连击长度增加，则设置工具将自动降低图像缓冲区最大大小，使得连击长度+图像缓冲区最大大小会大于读码器缓冲区最大数量。

虽然在设备上存储图像的缓冲区和图像处理的缓冲区共享，但在单拍模式下拍摄一系列图像及触发率很高时，也建议降低存储图像的数量。这可确保该设备具有足够的缓冲区进行正常处理。


什么是设置工具 / DMCC 设置的可用性？

设置工具 / DMCC 是指未被采集系统或图像录制所用的图像数量。这是可以将一个结果传输给设置工具或 SDK 的最大结果图像数。

注：这是无法更改的信息值。


如何设置未读取图像模式？

未读取图像对每次触发仅储存一个图像，可以选择其中一个。未读取图像周期储存每 n 个读取失败的图像。这根据整个触发模式进行评估。例如，如果选择了长度为 5 的连击触发模式并将周期设置为 3，则会储存首击的第 1 和第 4 个图像，第二次单击的第 2 和第 5 个图像。


什么是未读取图像周期？

未读取图像周期是指缓冲未读取图像的速率。如果值被设置为 1，则所有的未读取图像都会被缓冲。如果将值设置为整数 N，其中 N 大于 1，则每隔 N 幅图像才缓冲。

将未读取图像周期的值设置为大于 1，可降低缓冲未读取图像的数量。

如果将缓冲结果设置为已读取，未读取图像周期的值也会影响图像缓冲，因为已读取的图像缓冲时，所有与单次读取触发相关的图像都标记为已读取，这样之前采集的未读取图像也可以缓冲。设置未读取图像周期的值可降低缓冲这些图像的数量。


什么是未读取图像编号？

允许保存最终未读取的第 N 个连击图像。因此，如果触发模式不是连击模式或连击长度小于 N，则根本不会缓冲。


什么是未读取图像速率？

未读取图像速率时间是指未读取图像速率计数（图像）的频率。可以指定一个确切的数字和设置此时间的单位。此计数和时间可确定读取图像失败时持续速率。多次触发可确定每次的峰值速率。


什么是未读取图像范围？

未读取图像范围存储从此未读取图像编号到最后未读取图像编号之间所有读取到的质量差的图像。


如何设置有效读取图像模式？

除非设置限定的速率，否则成功读取图像可存储所有缓冲的成功读取图像。

通过选择速率受限可以限制有效读取图像缓冲的数量。设置读取图像速率（缓冲图像的数量和此计数的频率）和多次触发速率，这是每个设置时间的峰值速率。


选取允许缓冲区覆盖选项会怎么样？

允许缓冲区覆盖选项可控制是将图像存储到缓冲区覆盖旧图像，还是在缓冲区已满时停止缓冲。


如何确保图像在传输后删除？

核取传输后删除复选框，可以控制是否删除传输后的图像。这适用于任何传输模式，包括图像 FTP 传输和从读码器传输到 PC。


为什么不能启用立即传输按钮？

如果读码器中有缓冲图像，就必须先选择要记录图像的文件夹。在开始传输之前，还必须停止记录。


清除传输文件夹按钮也会清除幻灯片吗？

清除传输文件夹按钮会删除文件夹中所有的图像。如果图像幻灯片中当前显示的图像相同，图像幻灯片也会被清除。


如果所选文件夹中已有文件，会被覆盖吗？

如果匹配 [索引] 格式的所选文件夹已存在文件，起始索引将自动增加到无现有匹配为止，然后才开始传输。图像文件不会被覆盖。


可以逐个查看图像吗？

可以逐一查看图像，但必须选择图像所在的整个文件夹。选定文件夹中的图像一旦显示，就可以使用前进和后退按钮单击这些图像。


如果离开面板，就得重新开始查看图像吗？

不用，离开缓冲和传输面板就像单击暂停按钮一样暂停播放。


如何向 FTP 服务器传送图像？

使用 FTP 选项卡配置必要的设置，向 FTP 服务器传输图像。该选项卡包含服务器 IP 地址和端口号的设置以及用户名和密码组合。请注意，使用 FTP 发送图像并不能保证一定会发送，只有当读码器以更高频率运行且无法安排时间传送图像时才会发送。此外请注意，通过无线链路传输可能比常规网络通信慢得多。在这种情况下，建议使用缩减像素采样/压缩图像。

文件名选项可以指定这些图像要存储的文件。文件名字段可以指定与 FTP 服务器根目录相关的路径（例如 /failed_images/image）。跟在文件名后面显示在标签中的文件扩展名（.jpg 或 .BMP）与缓冲的图像设置面板上的图像格式设置相匹配。请注意，读码器不创建目录；目录必须已建好并能存取。

最大添加值控制项显示文件名中使用的增量限值。值为 0 表示没有增量要添加，该文件可以被覆盖。

脚本生成的文件名称允许在脚本面板的 FTP 存储选项卡上编写生成文件名的脚本。

服务器生成的文件名选项以空路径开头，这表示 FTP 服务器的根目录。


运行时图像 FTP 传输不工作。该怎么办？

确保满足以下条件：

  • 服务器地址、用户名和密码设置正确。

  • 将传输模式设置为FTP - 运行时。

  • 将缓冲选项卡中的缓冲结果设置为除无以外的任何值（按需要）。

  • FTP 服务器支持图像传输。


什么是脚本生成的文件名？

可以在脚本面板的 FTP 存储选项卡上编写生成 FTP 传输文件名的脚本。


什么是服务器生成的文件名？

一些 FTP 服务器支持此功能，在将传入的文件保存到磁盘之前为其唯一命名。


有哪些不同的传输模式？

单击设置工具中的立即传输或发送适当的 DMCC 时，按要求传输模式传送图像。如果选择 FTP - 运行时 传输模式，只要连接处于活动状态，就可以将图像自动传输至 FTP 服务器。


为什么整个面板在传输文件时都禁用？

禁用面板以实现图像 FTP 传输的最大稳定性。图像 FTP 传输视连接至 FTP 服务器的速度以及传输图像的大小和数量，可能需要几分钟。


为什么不能在高帧/秒传输速率时将图像运行时间发送到外部 FTP 服务器？

如果正在使用可能以 100 帧/秒（或更高）的速率读取和传输图像的设置（自触发、演示或外部触发模式），则设备会将这些图像存储到自身的图像缓冲区，但无法将图像发送到外部 FTP 服务器。

如果核取了允许缓冲区覆盖选项，则图像将极有可能被覆盖。如果未核取，则直至缓冲区再次有可用空间之前，新的图像都不会缓冲。


什么是 Mitsubishi GOT 服务器设置？

此设置通过允许使用空闲超时（通过添加定期 NOOP）和可选超时关闭空闲控制连接，增强 Mitsubishi GOT 和其他 FTP 服务器上的 FTP 连接。它还提供 Mitsubishi GOT 写模式支持。


什么是 SFTP 服务器设置？

此设置允许使用安全文件传输协议传输加密文件。


空闲超时设置用来做什么？

空闲超时是指端口保持开放而无外出通讯量的时间量。一旦读码器打开至 FTP 服务器的连接，只要出现通讯量，读码器都将保持连接开放。

如果在设置了空闲超时时间而没有出现通讯量，连接将会关闭。这在很少进行 FTP 传输以及网络需付款，不需要使连接保持打开时很有用。

首先需要选中能设置空闲超时的启用空闲超时。


过程监控


如何使用进程监控？

单击显示读取统计数据可查看统计数据。单击清除统计数据按钮可导致存储的读取结果统计数据和图像丢弃。注：此选项仅适用于以太网读码器。

切换到配置模式选项可进入选定读码器的配置选项。


可以将读码结果保存为文件吗？

按下 Ctrl+C 从读码结果历史记录框中复制数据，然后将其贴进所选的另一个应用程序中。


什么是项目计数？

项目计数是指允许缓冲的不读取图像选项处于活动状态时，导致无效读取的数据包。


选项


可以在选项页面设置什么？

使用 DataMan 设置工具的选项页，用户可以自定义应用程序中的设置。


在语言设置选项中可以设置什么？

可以选择设置工具使用的语言。默认为英语。

注：重启应用程序后设置才能生效。


可以在代码显示字段的代码页中设置什么？

可以根据将要解码的读取字符串设置方法。


可以在配色方案字段中设置什么？

在此字段中选择 DataMan 设置工具窗口的代码方案。


在重置设置框中可以设置什么？

在此框中，从下拉菜单内选择要重置为默认值的类别（例如通讯或验证）。


什么是备份位置设置？

在此可以设置由备份功能使用的文件夹以保存备份文件。


数据记录选项卡中可使用哪些设置？

在此选项卡中，可以设置结果代码、解码的图像、不读取图像和报告所要保存的文件夹，以及记录数据时更改文件名和扩展名的选项。


如何能生成数据验证报告？

在结果历史记录面板中的记录下方选择生成数据验证报告。


可以在图像缓冲和传输中设置什么？

可以设置传输的图片在哪个文件夹中存储。


在蜂鸣器设置选项中可以设置什么？

如果设置工具从 DataMan 读码器接收到较好的读取结果时，打开电脑的蜂鸣器。如果 DataMan 读码器内部没有蜂鸣器时此功能很有用。可以在接收较好读数时将蜂鸣器频率设置为 1000 Hz-10000Hz 之间，持续时间设置为 10ms-1000ms 之间。


如何能激活报告功能？

一旦填完报告字段，就需要打开数据验证以生成报告。


结果代码、解码的图像或不读取图像均未出现在相应的目录中，这是什么问题？

需要在相应的记录下拉列表框中启用。


实时监测


RTM Lean工具有何用处？

实时监控（RTM）Lean 是内置于 DataMan 的设置工具中的特色工具，能够对网络上与的单一设备相关的各种类型数据和读取的数据进行收集和分析。通过功能区菜单上配置选项可以设置采集此数据的目标设备，也可以选择收集的数据类型。默认情况下，RTM Lean 收集统计数据（读取速率、未读计数、平均解码时间、触发计数、触发失效、缓冲区溢出和过程控制指标。在设备中设置了这些参数后才能收集到这些数据）。


配置中有哪些可以使用的选项？

在配置中可以连同其它设置选项对 RTM Lean7 数据采集进行设置：

设备配置: 选择数据采集对象的设备。使用 添加设备 按钮将设备添加至列表中。此时会打开一个新窗口，在此窗口中点击添加网络设备按钮可以手动添加已分配 IP 地址的设备。使用刷新按钮可以刷新设备列表，同时使用删除手动添加的设备按钮可将所选设备从列表中删除。使用删除设备 选项可删除已添加设备列表中的设备，但此时会弹出警告提示：此操作会将设备中所有收集的数据（图像、统计数据等）完全清除。RTM Lean 可以监控有密码保护的设备，但需要在网络中输入用户名和密码。

数据收集：此列表显示 RTM Lean 能够收集到的所有类型信息。勾选复选框收集所需数据。默认情况下，RTM Lean 收集统计数据（读取速率、未读计数、平均解码时间、触发计数、触发失效、缓冲区溢出和过程控制指标。在设备中设置了这些参数后才能收集到这些数据）。列表中提供数据类型不在默认收集数据中，可以通过设置标签设置：

  • 未读取的详细触发信息：启用此功能后，当没有读取到数据时，RTM Lean 会个别存储触发数据。如果未读数据中包括部分结果或多个读码器同步信息，这些信息也会被存储。

  • 未读图像（通过 FTP）：启用此功能后，该设备会将未读图像发送给 RTM Lean。

  • 成功读取详细触发信息：该设置可以使功能区菜单详细视图下的触发性能页面生效。触发性能为成功读取数据的个别触发收集数据。该数据所有值都在触发性能页面的绘制值下拉菜单中显示。

  • 热图的代码位置：每次成功读取后，RTM Lean 都为每次发现的代码存储矩形。此信息用于创建 2 维热图，显示代码在视场中被读取的位置。

  • 设备配置更改：勾选此选项后，只要配置被更改，设备即会通知 RTM Lean。RTM Lean 存储所有被设备发送的配置文件。配置更改事件会显示在事件历史页面中，可以被导出或做对比使用。

注意：根据触发频率，使用触发级数据会降低系统处理速度。

分类：如果 Cognex In-Sight 设备与 DataMan 设备配套使用，RTM 控制器会根据未读事件原因收集分类数据。勾选从 InSight 收集图像分类框并从下拉列表中选择 分类器设备选项，必须指定分类后才能使用 In-Sight 设备。勾选存储 InSight 图像到 RTM 选框以存储分类图像。

注意：根据用户设置的触发配置和未读图像频率，存储图像操作会占用大量磁盘空间。

不要覆盖 DataMan 中通信脚本程序：勾选此框防止覆盖设备上的脚本。

网络：此面板显示被 RTM Lean 主动监控（勾选左侧启用收集选项）的设备名称和地址。点击齿轮图标打开子菜单，确定 RTM Lean 如何识别设备（IP 地址或 MAC 地址）。如果需要从被设置密码的设备上收集数据，从左侧列表中选择待监控的设备后必须提供用户名和密码。


显示设置下有什么可用的设置？

在此可以设置将警告线显示在图表上。

  • 显示读数速率参考线：勾选该选项显示警告线。

  • 读数速率参考线值(%)：可以设置表示警告百分比的百分值，警告线会在读取速率 图表上绘出。

  • 图表类型确定显示线条的类型。

  • 未读缓冲区大小和未读图像历史相关，此处设置的数值表示页面上最大的线条数量（触发）。

  • 在返回的最大触发详情数框中设置返回的触发详情最大数。


在功能区菜单设备选项下能够做哪些设置？

除了显示 RTM Lean 当前连接的设备识别号，显示的图标能够提示用户数据采集处于启用状态（显示标）还是非启用状态（暂停图标）。根据启动 RTM Lean 时或在配置中设置的参数，可以使用下拉菜单中的选项暂停或开始收集数据。也可以从配置中的下拉菜单中选择执行诊断操作。


聚合视图和详细视图 - 一般信息

聚合视图功能区菜单选项和详细视图功能区菜单选项可以显示 RTM Lean 收集的数据（结构化表示），主要以交互式实时图表形式显示。最短显示时间间隔为 1 分钟。如果一分钟内产生多次触发，RTM Lean 则在一分钟间隔时间内会对这些触发所收集的数据进行整合。

使用配置>显示设置选项能够设置显示在图表上的警告线。勾选复选框使警告线显示在每张图表上。图表类型确定显示的线条类型，在参考线可以给出警告百分比，线条根据这个值绘制在图表上。

注意:连接时 RTM Lean 只收集显示在视图菜单子项中的信息，并且只有启用的设备才能收集数据（通过配置或下拉菜单中的设备选项启用数据采集）。


性能概览采集和显示什么数据？

根据左上方设置中的显示情况，性能概览可以在图表上实时显示读取速率、每分钟读数和每分钟未读数。最上一行的最后[时间间隔]按钮是可以点击的，启用状态会显示橙色。可以使用按钮设置性能概览使用的间隔时间。

需要触发被监控的设备，将数据显示图表上。

使用配置>显示设置选项能够设置显示在图表上的警告线。勾选复选框使警告线显示在每张图表上。图表类型 确定显示的线条类型，读取速率参考线值 (%)表示线条在图表上所占的百分比。


代码质量概览收集和显示什么数据？

根据左上角设置>绘制值中设置，代码质量概览可将代码质量等级和度量值实时显示图表上。选择需要监控的设备度量值或等级。只有在受监控设备上设置后，绘制值中代码质量标准才可用（因此空的下拉框表示设备没有启用标准）。通过更改目标设备启用的代码质量标准，可以为其他标准收集数据。

多代码情况下，设备上可设置了多个代码质量标准。在此情况下，图表显示两条数据线（平均值在上方显示）。

注：因为RTM Lean使用最短一分钟时间间隔，因此等级会有一个中间值。

最上一行的最后[时间间隔]按钮是可以点击的，启用状态会显示橙色。可以使用按钮设置代码质量概览使用的间隔时间。在此显示平均绘制值。

使用配置>显示设置选项能够设置显示在图标上的警告线。勾选复选框使警告线显示在每张图表上。图表类型 确定显示的线条类型， 读取速率参考线值 (%) 表示线条在图表上所占的百分比。


事件历史采集和显示什么数据？

根据左上角 设置>绘制值中的设置情况，事件历史可将统计数据和代码质量采集值实时显示图表上。RTM Lean监控设备上所选值。对于代码质量度量值和等级，只有被监控设备被设置代码质量标准才在绘制值处于可用状态。通过更改目标设备启用的代码质量标准，可以为其他标准收集数据。

可将滚动条移动到所需点位置，及时查看特定时间的数据。可以通过修改滚动条长度（按住鼠标拖拽）来改变监控时间间隔。选择时间段（通过定位滚动条来确定）绘制值的聚合值显示在所选时间段的聚合值选项下的顶部中间位置。

数据收集位于图表的底线位置，用点表示监控期间的事件。每个事件详细信息显示在右侧列表中（时间邮戳和事件类型）。列表下有两个按钮：

  • 可使用保存设备备份将列表中选择的与事件关联的设备配置导出。当对给定统计数据、度量值或等级内产生变化的原因进行查找时，此项可用来检查详细信息。

  • 使用比较配置选项可打开文档，在此文档中对所选事件关联的设备配置进行比较；只有在列表中选择了多个事件时才有效。


在代码定位热图面板中能看到什么？

代码定位热图绘制成功读取到的热图，显示区域会根据发现的代码频繁度着色。颜色越暖表示该区域发现到的代码越频繁。可将滚动条移动到所需点位置，及时查看特定时间的热图。可以通过修改滚动条长度（按住鼠标拖拽）来改变监控时间间隔。


未读图像历史面板显示什么数据？

未读图像历史显示受监控设备拍摄的最近未读图像。左侧列表视图以列表形式显示图像各种属性，右侧图像窗口显示滑块视图中选择的图像。点击保存图标保存当前所选图像。

如果选择配置>设置>分类下的收集分类选项，左下角分类图表显示已产生的未读事件类型。


触发性能面板显示什么数据？

为了启用触发性能，需要在设置选项卡下的数据收集内勾选成功读取详细触发信息一项。

触发性能不能像其他面板一样聚合 1 分钟间隔内的数据，但是可以在图表上显示每次触发。个别触发使用图表上的点来表示并显示数值。可从绘制值下拉框中选择可能的值，为绘制值（受监控对象）赋值。注意：被监控设备使用的固件版本不一样，绘制值列表可能会有区别。

可将滚动条移动到所需点位置，及时查看特定时间的数据。可以通过修改滚动条长度（按住鼠标拖拽）来改变监控时间间隔。可以根据颜色区基于设置来设定图表上点的着色标准。

如果触发成功读取图像，可以点击图表上一个点（触发），在右侧显示 RTM Lean 收集到的所有相关数据。如果读取失败，点击保存图标后，RTM Lean 会显示已被保存的图像。


系统标签下有哪些可以使用的选项？

可以在此删除数据和配置设置。点击清空数据库将会删除所有存储数据，点击重置配置将会删除设备的配置设置和所有存储数据。


表视图


为什么有些值以突出显示？

突出显示的值最初都是非默认值。可以在功能区菜单的突出显示部分更改突出显示规则，参见问题表视图：功能区菜单获取更多信息。


为什么有些值以粗体显示？

以粗体显示的值是可扩展和显示的子值。


如何知道可能的值是什么？

如有可能，将鼠标移至某一值上，就会显示一个悬浮文本最小值、最大值和默认值。


表视图：一般布局与结构

表视图是使用网格样式的查看工具。

标题行显示设备名称。下面的第二标题行显示设备的可用设置。通过点击它旁边的图标可折叠或打开下面的行标题（以粗体显示）。断开设备连接时，其标题行会出现重新连接图标。

与读取设置不相关的设置只显示在第一列中（主设置）。


表视图：控件（鼠标和键盘）

选择：

  • 鼠标：点击网格中的单元格并进行选择，会突出显示单元格的行标题以及设备和设置所属的列标题。菜单按钮和功能区菜单项可以根据选择进行更改。如果所选的单元格位于行标题行中，属于标题的当前列中所有的单元格都会被选择。

  • 键盘：光标移动键可将选择导航到相应的单元格。突出显示和选择操作与使用鼠标相同。

添加/更改值：

  • 鼠标：对于采用嵌入式编辑器的单元格，点击编辑器控件（组合框、复选框、数字选择）允许输入值。对于采用自定义编辑器的单元格（...图标），弹出式编辑器将打开，允许输入值。

  • 键盘：对于采用嵌入式编辑器的单元格，按下 Enter 或 F2 启动编辑模式，按下 Esc 键取消编辑，第二次按下 Enter 键确认编辑。不用进入编辑模式，即可以在选定的文本中输入值，在此情况下第一次击键将会覆盖当前值。

    对于数值单元格，除了嵌入式文本编辑器单元格外，向上和向下箭头可增加和减小值。

    对于下拉式单元格，按下 输入 键启动编辑模式并显示下拉菜单项，而 向上和向下箭头 可移动所选的内容。第二次按下 Enter 键应用选定的值，按下 Esc 键取消编辑。

    对于复选框单元格，使用 Space 可切换选中/未选中状态。

复制和粘贴：

使用组合键 Ctrl+C 和 Ctrl+V 进行复制和粘贴，欲了解更多信息，请查看相关功能区菜单项的复制粘贴介绍。


表视图：功能区菜单

功能区菜单可在表视图网格上方找到。其内容和活动图标可能会随网格中单元格、行或列的选择而变化。菜单可分成几组。

  • 表视图：使用添加设置按钮将读取设置添加或复制到所选的设备。删除设置按钮删除选定的读取设置。更改顺序按钮允许更改设备之间的读取设置顺序。

  • 编辑：使用复制（或键盘上的 Ctrl + C）从当前选定的单元格复制值。粘贴只能用于同一行中或任何文本编辑器中。重置值用于重置所选单元格的值。

  • 突出显示：此菜单组中的按钮和设置提供选项以突出显示特定的单元格背景。使用非默认值设置，具有非默认值的单元格会突出显示（这在不同设备或读取设置的单个行中可能会不同）。不同于参考设置突出显示值与参考读取设置（和设备）同一行中单元格不同的单元格。选择第三个设置，所有的值和标题都会突出显示，包含文本框中指定的文本。此外，包含的文本本身也使用不同的文本背景突出显示。同样按下 Enter 键也会应用仅显示突出显示的行按钮的功能。

    启用时，仅显示突出显示的行折叠所有不包含突出显示子节点的节点。激活时，设置参考读取设置在使用不同于参考突出显示模式时指定用作参考的读取设置（和设备）。当按钮处于活动状态时，当前所选单元格的列（读取设置）变为参考设置。当前的参考设置在设置名称标题行中标记。

  • 过滤：全局设置，默认设置，只显示在不同读取设置中不能有不同值的设置。设置读取设置只查看与读取设置相关的设置。设置所有设置以同时查看所有设置。如果条目的值出现在多个读取设置中，它们将显示在不同的列中。

  • 其他：使用展开所有行以展开网格中所有折叠的行。使用折叠所有行以折叠网格中所有展开的行。重置布局重新计算列宽度以用完所有可用的空间。如果可用空间不够，会使用最小列宽度。


法律信息


版权

Cognex Corporation 对使用非 Cognex Corporation 提供的设备软件或其可靠性不负任何责任。Cognex Corporation 对于相关描述软件及其任何特殊用途的适销性或适用不作任何明示或暗示的担保。

本文档中的信息如有更改，恕不另行通知，不应被解释为由 Cognex Corporation 作出的承诺。Cognex Corporation 对本文档或相关软件中出现的任何错误概不负责。

版权 ? 2019 Cognex Corporation 保留所有权利

未得到 Cognex Corporation 书面许可，任何人不能复制本文档，也不得将其转让给任何其他媒体或翻译为其他语言。

硬件和本文档中所述软件部分可能受一个或多个美国专利的保护，具体内容参见 Cognex 网站 http://www.cognex.com/patents.asp。其他美国和国外专利尚在申请中。


许可软件

SpiderMonkey

本软件遵循 Mozilla Public License, v. 2.0 的条款。可以从 http://mozilla.org/MPL/2.0/ 获得 MPL 的副本。

若要获取 SpiderMonkey 的源代码副本，请发送电子邮件至 <spidermonkey@cognex.com> 与 Cognex 技术支持联系

PCRE 许可证

PCRE 是一种支持其语法和语义学与 Perl 5 语言尽可能相近的正则表达式的功能库。

PCRE 版本 5 的发行受 BSD许可证的约束，如下所示。doc目录下提供的 PCRE 文档依据软件本身条款的规定发行。

编写者：Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.电话：+44 1223 334714.

版权 (c) 1997-2004 University of Cambridge 保留所有权利。

在满足以下条件的前提下，允许用户将修改后或未经修改的软件以源代码或二进制的格式进行重新发布或使用：

  • 重新发布源代码时必须保留上面的版权声明、此处的条款列表和下面的免责声明。
  • 如果以二进制格式重新发布，必须在该文档和/或随发布提供的其他材料中包含上面的版权声明、此处的条款列表和下面的免责声明。
  • 未经事先书面许可，不得使用University of Cambridge及其他责任者的名称宣传或促销在本软件基础上开发的产品。

本软件仅以版权持有人和其他责任人 按原样 形式提供，不做任何明确或隐含的担保，包括但不限于对适销性和对特定用途的适用性的担保。在任何情况下，版权拥有者或其他责任者对由于使用本软件而造成的任何直接、间接、偶然、特殊、惩罚性或因果性的损害（包括但不限于更换商品或服务、无法使用、丢失数据、损失利润或业务中断）不承担任何责任，无论由于什么原因、根据何种责任理由；无论是否签署了合同、负有严格的责任限制；无论是否由于使用本软件而引起纠纷（因疏忽或其他原因），即使事先已被告知可能会造成这种损害。

结束

JPEG 软件

本软件的某些部分基于独立 JPEG 组的工作。

zlib 压缩库

本软件的某些部分基于 Jean-loup Gailly 和 Mark Adler 的工作。

Parsifal XML 解析器

版权 (c) 2002-2005 Toni Uusitalo 发行到公共域名 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal 对商业和非商业软件的使用和重新发行免费，但需要提供保留完整的作者版权和免责声明。可以自行修改 Parsifal 用于个人使用以及在提供明确记载修改的内容后重新发布。

免责声明

本程序是基于使用目的而加以发布，然而不负任何担保责任；也不对适售性或特定目的适用性所作的默示性担保。使用时请自行承担一切风险。


专利信息

本产品是受下列一个或多个美国专利、美国申请和/或国外专利保护，http://www.cognex.com/patents 将列出任何其后发布的相关专利

5742037、5943441、6215915、6236769、6282328、6381375、6408109、6457032、6690842、6941026、7175090、7181066、7412106、7427028、7549582、7604174、7614563、7617984、US-2005-0087601-A1、US-2006-0131418-A1、US-2006-0131419-A1、US-2006-0133757-A1、US-2007-0090193-A1、US-2007-0091332-A1、US-2007-0152064-A1、US-2007-0170259-A1、US-2008-0004822-A1、US-2008-0011855-A1、US-2008-0142604-A1、US-2008-0143838-A1、US-2008-0158365-A1、US-2009-0090781-A1、US-2009-0108073、US-2009-0121027-A1、US-2009-0166424-A1、US-2009-0294541-A1、WO06065619A1 和 EP1687752