DataMan : 问题与解答


连接至读码器


如何将读码器连接至设置工具？

无论使用何种读码器，按下列步骤将 DataMan 读码器连接至设置工具:

  1. 在读码器和运行设置工具的 PC 之间连接必要的电缆。有关详细信息，请参阅快速参考文件。

  2. 单击设置工具中的刷新。

  3. 单击连接。


为什么我看到设备图标的右上角中有叠加图标？

箭头图标表示它是手动添加的设备。


为什么有些设备显示为绿色？

新发现的设备以绿色显示几秒钟，表示新设备已添加到树视图中。


优化图像


代码细节


应用细节


输入/输出


通信


维修和支持


什么是维修和支持？

维修和支持页面可用于设置未正确配置网络设备的网络设置或将串行设备的 HID 模式更改为 CDC。


刷新选项用来做什么？

单击刷新按钮可刷新可用设备的列表。


如何将网络设备添加到显示设备列表？

通过单击添加网络设备可以添加网络设备或编辑已添加设备的 IP 地址。添加网络设备对话框打开，可在此提供设备的 IP 地址。单击确定以保存所做的更改，该设备也将显示在连接页面。


如何编辑设备属性？

从设备列表中选择设备以查看可用选项。在打开面板中，可以编辑属于所选设备的网络设置以及设置身份验证选项。单击应用以保存所做的更改。


复制电脑端网络设置这一选项是什么？

当您在网络下选择某个设备时，网络设置对话框便会出现在右侧。

点击复制电脑端网络设置按钮来复制您电脑的网络设置，从而无需费力查找您电脑的子网掩码和默认网关设置。需注意所复制的 IP 地址是您电脑的 IP 地址。IP 地址的红色边框是提醒您需要手动将该字段更新为 DataMan 设备的 IP 地址。


备份


还原


如何使用还原功能？

还原功能允许在一台或多台设备上还原备份配置文件。此功能只有在选择至少一台设备且指定有效的配置源后才可用。

可在顶部配置源中选择列表的最后一项出厂默认值，RTM控制器将配置还原为出厂默认值。

注：对于RTM控制器其他被设置为源的选项来实现还原是不可用的。

选择源以及目标设备后，点击右下角的还原按钮。


更新固件


如何使用更新固件功能？

此功能为所选的设备更新到所需的固件版本。

  1. 从设备列表中选择要更新的设备。

  2. 通过点击“...”图标浏览固件文件。如果在设备列表中选定单台设备，就会打开该设备相应的固件文件夹。如果选择多台设备，而他们具有相同的固件设备 ID，则会打开相应的文件夹。如果未选择设备或选择更多的设备，但他们具有不同的固件设备 ID，则会打开固件根文件夹。

  3. 点击上传固件按钮。只有选定的固件版本与设备选择相兼容，该按钮才启用。

  4. 如果您想要设置工具以与备份功能相同的方式来备份配置文件，则在弹出窗口中，勾选固件更新之前备份设备。（更多详细信息请见备份部分的问答内容）。

  5. 点击是来开始上传新固件。

注：使用串行设备的情况下，在能够更新固件之前需要通过手动刷新去发现它们。


比较配置


图像窗口


结果历史记录


设备日志


图像尺寸


数据验证


打印设备备份代码


打印配置代码


数据记录


图像工具视图


选项


表视图


法律信息


版权

Cognex Corporation 对使用非 Cognex Corporation 提供的设备软件或其可靠性不负任何责任。Cognex Corporation 对于相关描述软件及其任何特殊用途的适销性或适用不作任何明示或暗示的担保。

本文档中的信息如有更改，恕不另行通知，不应被解释为由 Cognex Corporation 作出的承诺。Cognex Corporation 对本文档或相关软件中出现的任何错误概不负责。

版权 © 2019 Cognex Corporation 保留所有权利

未得到 Cognex Corporation 书面许可，任何人不能复制本文档，也不得将其转让给任何其他媒体或翻译为其他语言。

硬件和本文档中所述软件部分可能受一个或多个美国专利的保护，具体内容参见 Cognex 网站 http://www.cognex.com/patents.asp。其他美国和国外专利尚在申请中。


许可软件

SpiderMonkey

本软件遵循 Mozilla Public License, v. 2.0 的条款。可以从 http://mozilla.org/MPL/2.0/ 获得 MPL 的副本。

若要获取 SpiderMonkey 的源代码副本，请发送电子邮件至 <spidermonkey@cognex.com> 与 Cognex 技术支持联系

PCRE 许可证

PCRE 是一种支持其语法和语义学与 Perl 5 语言尽可能相近的正则表达式的功能库。

PCRE 版本 5 的发行受“ BSD”许可证的约束，如下所示。“doc”目录下提供的 PCRE 文档依据软件本身条款的规定发行。

编写者：Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.电话：+44 1223 334714.

版权 (c) 1997-2004 University of Cambridge 保留所有权利。

在满足以下条件的前提下，允许用户将修改后或未经修改的软件以源代码或二进制的格式进行重新发布或使用：

  • 重新发布源代码时必须保留上面的版权声明、此处的条款列表和下面的免责声明。
  • 如果以二进制格式重新发布，必须在该文档和/或随发布提供的其他材料中包含上面的版权声明、此处的条款列表和下面的免责声明。
  • 未经事先书面许可，不得使用“University of Cambridge”及其他责任者的名称宣传或促销在本软件基础上开发的产品。

本软件仅以版权持有人和其他责任人“ 按原样 ”形式提供，不做任何明确或隐含的担保，包括但不限于对适销性和对特定用途的适用性的担保。在任何情况下，版权拥有者或其他责任者对由于使用本软件而造成的任何直接、间接、偶然、特殊、惩罚性或因果性的损害（包括但不限于更换商品或服务、无法使用、丢失数据、损失利润或业务中断）不承担任何责任，无论由于什么原因、根据何种责任理由；无论是否签署了合同、负有严格的责任限制；无论是否由于使用本软件而引起纠纷（因疏忽或其他原因），即使事先已被告知可能会造成这种损害。

结束

JPEG 软件

本软件的某些部分基于独立 JPEG 组的工作。

zlib 压缩库

本软件的某些部分基于 Jean-loup Gailly 和 Mark Adler 的工作。

Parsifal XML 解析器

版权 (c) 2002-2005 Toni Uusitalo 发行到公共域名 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal 对商业和非商业软件的使用和重新发行免费，但需要提供保留完整的作者版权和免责声明。可以自行修改 Parsifal 用于个人使用以及在提供明确记载修改的内容后重新发布。

免责声明

本程序是基于使用目的而加以发布，然而不负任何担保责任；也不对适售性或特定目的适用性所作的默示性担保。使用时请自行承担一切风险。