DataMan 8600 : 问题与解答


欢迎屏幕


欢迎

建议使用左侧 “应用步骤” 大号按钮快速设置设备。每个模块都配有 “基本” 或 “高级” 配置选项卡。 “保存设置” 操作按钮可将配置数据保存到读码器中，并且只需点击一次即可将配置数据备份到电脑中。下面这些问题描述每个“应用步骤”中不是一目了然的配置选项。


在“应用类型”选项下能进行哪些设置？

点击右侧箭头，从下拉菜单中选择合适的读取模式。


在“优化图像”步骤中可以做什么？

在此可对连接的设备进行配置、调谐和测试，也可对此设备进行照明设置。


在“代码详情”选项下能选择哪些设置？

在此可选择 DataMan 必须读取的条码符号，也可选择不同的多代码方案。也可在此菜单中进行高级解码器设置。


在“应用详情” 步骤中可以进行哪些设置？

可在此定义触发和曝光设置。“触发助手”、“间隔时间助手”和“曝光助手”可方便地帮您完成这些设置。

在"高级”选项卡下，可在表视图中实现更多设置。


在“格式化数据”选项下能做哪些配置？

可以使用“基本格式化”或 Perl Style 正则表达式利用预定义的构建模块构建自定义输出字符串，或使用 JavaScript 引擎构建灵活的数据格式化脚本程序，从设备中获取所需的数据输出。


在“输入/输出”步骤中可以进行哪些设置？

在此面板中可设置按钮操作、输入和输出行。可在此设置脉冲编码器参数和蜂鸣器脉冲长度。此面板有一个到图像缓冲设置的连接，可将 FTP 图像传输至服务器。


在“通信应用”步骤中可以进行哪些设置？

可利用“通信应用”步骤中的三个选项卡对串口和以太网进行设置。点击合适的选项卡，输入设置值。


“保存设置”选项可做哪些操作？

“保存设置”是一个操作而不是步骤，要慎重执行。此操作可将当前配置保存到读码器永久存储器中，重启读码器后即会加载这些配置。DataMan 设置工具也会将备份文件存储到当前电脑的默认备份文件夹中。


什么是“配置备份”文件？

“配置备份”文件中包含设备所有参数和配置。可以用来将设备的设置恢复成已知状态，或通过选择备份属性中配置参数来配置新的设备，或不设置参数。


连接至读码器


如何将读码器连接至设置工具？

无论使用何种读码器，按下列步骤将 DataMan 读码器连接至设置工具:

  1. 通过 Windows 开始菜单或设置工具帮助菜单，为特定读码器打印一份读码器配置代码文档。

  2. 在读码器和运行设置工具的 PC 之间连接必要的电缆。有关详细信息，请参阅快速参考文件。

  3. 单击设置工具中的刷新。

  4. 选择显示连接读码器的 COM 端口或网络设备。

  5. 单击连接。


为什么无法将设置工具连接至读码器？

如果无法连接，查看下列设置：

  • 确保扫描了与所用物理连接类型相匹配的配置代码（USB COM 或 RS-232 串行）（不适用于仅支持以太网的读码器）。

  • 确保电脑中安装的防火墙或防病毒应用程序能通过对应端口（Cognamer端口号:1069；设置工具端口号:44444）访问以太网设备。

  • 确保 COM 端口列表中显示一个连接读码器的端口。

    DataMan 60、300、370系列、470系列、503、8000 系列：如果读码器连接至以太网，查看读码器是否出现在网络设备列表中。

    单击刷新以确定读码器已连接了哪些端口。

    注：单击刷新发送所有 COM 端口和以太网子网中的查询字符串。DataMan 8000 无线读码器必须唤醒以响应查询。可以长按触发器唤醒读码器。

  • 确保未使用键盘、键盘仿真或 HID 连接：必须使用 USB 串行、RS-232 串行、以太网或无线网络将设置工具连接至读码器。

  • DataMan 60、300、370系列、470系列、503、8000 系列：确保添加设备选项中提供的 IP 地址是正确的。

  • 仅 DataMan 8000 无线读码器：确保读码器未处于休眠模式（长按触发器进行唤醒）。

  • 仅 DataMan 8000 无线读码器：确保读码器与连接至 PC 的基站建立连接。为确保正确连接，可以扫描印在快速参考指南上断开链接的配置代码，从基站上拔下电源线和通讯电缆，重新连接电缆，然后再将手持设备放入基站。再次尝试连接之前，一直等到手持设备显示已链接（有声频信号）为止。

  • 仅 DataMan 8000 无线读码器：确保基站连接至电源。

如果读码器已连接至 PC 的 COM 端口，可以使用 HyperTerminal 等终端仿真程序，确定读码器是否在发送任何数据。


为什么我看到设备图标的右上角中有叠加图标？

箭头图标表示它是手动添加的设备。“V”图标表示该设备是虚拟设备。


什么是虚拟设备？

设备图标右上角的“V”覆盖图标表示设备是虚拟设备。在维修和支持模式下可以从自定义配置文件或带默认配置的设备创建虚拟设备。虚拟设备可用来查看设置工具中不同的面板，而无需连接到实际设备。

创建的虚拟设备对网络上的其他设备不可见。虚拟设备在多个设置工具实例中持续存在。

能以同样的方式连接所创建的虚拟设备作为常规设备，除非所有配置更改都遭到拒绝（全都是只读型）且虚拟设备上没有特性、功能和操作工作。


USB 连接要使用什么端口？

如果使用 USB 端口连接读码器或基站，确保扫描读码器配置代码文档上的 USB-COM/RS-232 配置代码。然后单击刷新并选择确认为连接至读码器的端口。

注：单击刷新发送所有 COM 端口和以太网子网中的查询字符串。DM7550 和 DM8000 无线读码器应唤醒以应答查询。长按触发器以唤醒读码器。


仍无法连接至读码器或基站：可以将它重置吗？

对于 DataMan 8000 基站：

使用与基站相关联的无线读码器，扫描将基站重置为出厂默认值命令（适用于 DM8000 基站），将基站还原至出厂默认状态。

适用于 DataMan 503 和 8000 系列读码器：

扫描印在快速参考指南背面的重启扫描器命令，执行软重置操作。虽然读码器中的非易失性存储器不会清除，但读码器会关机并重启。

如果失败，扫描将扫描器重置为出厂默认值命令，将读码器还原至出厂默认状态。

如果失败且有线读码器正在使用中，请断开读码器的电源（在 DataMan 9500 中不可执行此操作）。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。

如果失败且 DataMan 8000 无线读码器正在使用中，请取出读码器的电池并将其放置到基站。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。

适用于 DataMan 50、60 和 70 读码器：

通过 Windows 开始菜单或设置工具帮助菜单，为特定读码器打印一份配置代码文档。

扫描重启读码器代码，执行软重置操作。虽然不会清除读码器中的非易失性存储器，但读码器会关机并重新启动。

如果仍无法连接读码器，扫描将读码器重置为出厂默认值代码，将读码器还原至出厂默认状态。

如果仍不能解决问题，断开读码器的电源（包括 DC 电源和 USB，如已连接）。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。


如何知道哪台是我的设备？

适用于 DataMan 260、300、473、503 和 8000 读码器：

在设备列在连接至读码器下方的树结构中，右键单击读码器并选择识别。读码器的状态指示灯给出信号，使其能够被识别。


为什么有些设备显示为绿色？

新发现的设备以绿色显示几秒钟，表示新设备已添加到树视图中。


DataMan 50、60、70、300、370、470、503、8000 系列、MX-1000、MX-1500 和 DataMan 8000 基站：为什么在连接时，设置工具要求提供密码？

在连接到设置工具之前，可以配置读码器和基站要求提供密码。通过通讯设置面板网络设置选项中的验证选项卡启用密码。请注意，串行连接也使用该密码。


DataMan 60、300、370、470、503、8000 系列 和 DataMan 8000 基站：可以直接使用以太网将读码器连接至 PC 吗？

可以将读码器或基站直接连接至 PC 的以太网接口 (RJ-45)。如果设备配置了 DHCP，它会在大约 20 秒后出现在网络设备列表中。但请注意，PC 可能还需要数分钟时间来解决 IP 地址问题。完成之前，无法通过设置工具连接至设备。

如果设备已设置为静态 IP 地址，只有当设备与 PC 共用同一子网时它才会出现。


DataMan 60、300、370、470、503、8000 系列、MX-1000 和 DataMan 8000 基站：如何将网络设备列表中的列表映射到特定读码器？

在默认情况下，网络设置中出现的每个 DataMan 都带有 DM 前缀和设备上 MAC 地址的后 6 个字符。


DataMan 60、300、370、470、503、8000 系列、MX-1000、MX-1500 和 DataMan 8000 基站：如果网络设备列表中不出现读码器或基站怎么办？

如果所需的读码器或基站未列出，可以反复开关电源来添加。设备在接通电源后出现在列表中可能需要 60 秒的时间。

如果反复开关电源未能解决问题，设置工具可能因网络配置原因无法与设备通讯，从而使它未出现在网络设备列表中。

检查与读码器或基站的以太网连接，然后点击设置工具中的刷新。

如果知道读码器或基站的 IP 地址，使用添加设备选项。

这种方法可使 DataMan 读码器或基站出现在网络设备列表中，这样就能通过设置工具和以太网来连接。


DataMan 8000 无线读码器：如何将无线读码器关联到不同的基站？

如果想要关联无线读码器的基站已关联了另一台读码器，就必须通过扫描从基站解除读码器指定代码断开该链接。要将读码器指定到新的基站，只需将新的读码器放进基站即可。它们会自动配对。


DataMan 8000 基站：如何重设基站的 USB 连接？

如果在基站和 PC 之间建立或维护 USB 连接有困难，请根据以下步骤重设 USB 连接：

  1. 断开基站的 USB 电缆和电源线。

  2. 重新连接基站的 USB 电缆和电源线。

  3. 将读码器放入基站。

  4. 从基站中移除读码器并扫描 USB-COM/RS_232 配置代码。


比较配置按钮如何工作？

比较配置按钮可启动设置工具的配置比较功能，表格视图样式工具用来设置、复制、比较或恢复设备配置。该功能在新的文档页面中打开。

在按下按钮之前如果未从设备列表中选择设备，则会打开一个空文档。如果选择了一个或多个设备，就会用这些设备的设置来填充比较文档。


网络中显示的 RTM Lean 设备是什么？

实时监控（RTM）Lean 是内置于 DataMan 设置工具中的特色工具，能够对网络上与设备相关的各种类型数据和读取的数据进行收集和分析。可以选择设备将其和 RTM Lean 连接，然后在新打开的文档中进行数据收集设置。RTM Lean 仅主动收集已连接上并正在运行的设备所发送的数据。

在启动设置选项中，会要求用户选择 RTM Lean 将要检测的设备和收集的何种类型的数据（默认值之外的选项）。可在功能区菜单上“配置”选项中重新定义。默认情况下，RTM Lean 收集统计数据（读取速率、触发计数、触发失效、缓冲区溢出和过程控制仪表。设置设备中这些参数后才能收集到这些数据）。

注：RTM Lean可以一次从一个设备采集数据，并将数据保存48小时。


优化图像


在 “应用类型”选项下能进行哪些设置？

点击右侧箭头，从下拉菜单中选择合适的读取模式。


在“优化图像”步骤中可以做什么？

在此可对连接的设备进行配置、调谐和测试。

建议选择 “基本” 或 “高级” 配置选项，然后点击中间的“应用步骤” 大号按钮，来快速设置设备。使用“保存设置”操作按钮可以直接保存所有配置数据。


如何将采集的图像保存为文件？

点击图像面板或图像查看器栏中的保存图像按钮。

也可以将图像拖放至 PC。单击图像显示窗口中的图像，将它拖到设置工具外并松开。

注：如果想用拖放方式保存图像且它并非最后一个图像（正从读取结果历史记录中保存），图像将以显示的图像设置保存。在默认情况下，质量会降低。在显示的图像设置下方，将图像大小更改为全尺寸和位图格式。


如何使用实时按钮？

在 “基本” 标签下，点击 “实时” 按钮进入“实时”模式。实时模式不仅监视设备读取的内容，而且还能解码。点击按钮的最右边打开更多选项。

如果想要设备对所拍摄的图像解码，请选中解码。选中后，焦点反馈在图像视图右侧显示颜色编码仪表。仪表显示镜头焦点（越低聚焦越少）。

选中自动曝光选项可让读码器自动确定图像中的最佳曝光设置。滑块（图像视图区域下方）显示目标的像素亮度。

可在“高级”选项卡下看到图像设置的表视图。


读码性能面板用来做什么？

通过右侧的读码性能面板，可以监视解码时间和实时读码率。点击清除按钮以重置图形。


在此处可以更改哪些照明设置？

可以设置打开哪一个 UltraLight 象限。此外，还可以使用出厂配置的照明设置并在照明与成像器设置面板上进一步修改成像器配置。


可以更改哪些触发器设置？

可以将触发类型设置为手动 ( 按钮 ) 或演示（内部）。对于更多触发设置，通过点击相应的功能区项并选择触发设置选项卡进入照明与图像设置面板。

请注意，在演示模式下，当操作员扣动触发器时，读码器切换到手动模式，直至设备重新停靠进基站中。

更多信息请参见“应用详情”问答。


如何设置 DataMan 8600 的焦点值？

焦点值设置的焦点范围从 0 至 500 毫米。

如果更改焦点设置面板（位于 照明与成像器设置下方）上的调焦步幅，就可以在快速设置面板上设置两格。它们将指定更低和更高的焦点值。


如何更改 DataMan 8600 的曝光值？

使用手动曝光（可通过照明与图像设置面板切换）时，启用这项设置。


如何快速打开或关闭读码器所有的照明？

在显示 LED 照明的图像上单击右键。在列表中，选择想要打开或关闭的照明。

在图像中点击各个单独的照明也可将其打开或关闭。

更改会根据选择立即生效。


什么是显示的图像设置？

显示的图像设置控制着读码器如何显示响应采集触发信号而采集的图像以及读码器的实时图像。更改这些设置不会影响读码器的性能，只会影响读码器与设置工具之间的图像质量和传输速率。

注：设备正在获取或解码图像时，无法更改一些图像相关的属性（如图像大小、筛选）。

注：保存图像面板上次拍摄的图像（通过拖放）时，显示的图像设置没有任何效果。上次的图像总是以全尺寸（设备的分辨率最大值）保存。

  • 大小：在默认情况下，设置工具会显示每个采集图像整体像素的四分之一或每个实时显示图像的一小部分。选择不同的图像尺寸可使读码器对每个图像进行子采样，这可极大提高从读码器到设置工具的传输速度，但图像的精细度会有所降低。

  • 质量：仅在使用 .jpeg 图像格式时才可用。该滑块可调节内部参数，使读码器在采集的图像上执行流畅的操作，可降低或提高从读码器传输至设置工具的速度。


在何处可以了解更多有关使用 UltraLight 的知识？

有关 UltraLight 中可用功能的完整概述，请参阅 UltraLight 教程视频，网址： <a>http://www.cognex.com/</a>。


如何在每个采集图像内指定兴趣区？

更改图像尺寸（兴趣区）面板中的设置。


什么是激光强度？

可以从此下拉框中选择是否使用 2 类激光读码器，或在所有正常使用条件下都安全的降级类型（1M 激光器）读码器。


什么是 UltraLight？

UltraLight 系统提供两种独立可控的照明源：

  • 四个独立可控象限的低角度离轴 LED，可以提供暗场照明，这有助于反射面上刻划或蚀刻标记的图像。

  • 高漫射的同轴灯可提供明场照明，适合读取多种表面上低对比度或高对比度的代码。


为什么 UltraLight 的顶部象限没有打开？

在多数情况下，操作员倾向于与读取表面有一定角度来持握读码器。禁用顶部照明象限，可减小反射和闪光。

读码器的四个设置在出厂时都使用了默认值，但通用只在第一次设置时才启用。通用设置仅启用来自西面、南面和东面的低角度照明。可以修改此设置，启用所有的离轴照明部分。


什么是实时显示？

如果启用实时显示（通过单击顶部任务栏或操作选项卡上的实时显示图标），图像显示不断显示读码器所见到的内容。不尝试对符号解码时，可以使用此模式查看读码器读取的内容。

要更改实时显示图像的大小和质量，进入显示的图像设置面板。

注：该选项不适用于 DM262 和 DM362。


如何提高图像传输速度？

如果选择传输并显示图像复选框，设置工具会在每次解码操作时传输采集的图像。如果在传输当前图像时再次收到触发信号，读码器将放弃部分传输的图像并开始传输新的图像。

图像传输速度视读码器执行的图像压缩程度而定。通过选择显示的图像设置选项，可以控制影像的压缩值。减小图像大小或降低图像质量可提高传输速度。


选中了“传输并显示图像”，为什么看不到图像？

如果单击触发器中断了图像的传输，就不传输任何图像。同样，读码历史记录窗格中较早的图像中可能不包括图像。

注：如果“输出延迟”时间短于读码器需要读取图片并进行结果解码的时间，设置工具将不能从读码器接收结果图像。


如何为 DataMan 8600 设置聚焦值？

聚焦值将聚焦设置在 0 到 500 毫米范围内。

如果更改了 Focus Settings 窗格（Light and Imager Settings 下方）的 Focus Steps，则可以设置快速设置窗格上的两个条块。它们会指定聚焦值的上限和下限。

请注意，焦距是从镜头开始测量而不是从读码器的前盖开始测量。


代码细节


如何快速禁用所有代码符号？

点击“代码详情”应用步骤中“基本”选项卡顶部的“取消所有条码符号”选项，或按下 Ctrl+D 快捷键。


如何调整高级代码类型设置？

点击“代码详情”下的“高级” 选项卡，完成更多设置。


读码器会自动区别不同的代码类型吗？

读码器可以自动检测、识别设置工具中启用的任何代码类型并解码。


限制启用代码类型的数目可提高读码器性能吗？

为了达到最佳性能，只启用那些预计会读取的代码符号类型。


Data Matrix 属性：什么是符号难度？

符号难度控制读码器尝试对每个图像解码的难易程度。设置易将对高对比度、高印刷质量的代码解码，并使读码器灵活性最大化。设置难将对具有挑战性的直接部件标记解码，但会降低读码器的灵活性。


EAN.UCC Composite 属性有哪些不同的设置？

  • 标准（线性和 2D）：由与相邻 2D 组成要素（解码补充数据，如批号或到期日）相关联的线性要素（解码物品的主要标识）组成。

  • 仅线性：由对物品主要标识进行解码的线性要素组成。


什么是 CC-C？

CC-C 是三个 EAN.UCC 2D 复合要素之一，专指首个数据字码位置中带 920 字码的 PDF417 符号，作为连接标记表明 EAN.UCC 数据压缩。


什么是 DataMatrix 质量度量？

有关代码质量度量的信息，请参阅 DataMan 通信与编程指南。


1D 条码符号属性：什么是目标解码？

目标解码模拟激光条形码扫描器的特性。不是查看整个视场，而是读码器尝试对激光瞄准点下放置的 1D 条形码解码。这样可以避免操作员意外读取附近的其他 1D 条形码。


1D 条码符号属性：什么是短静区选项？

在默认情况下，启用了短静区选项，就可以对下列 1-D 符号的静区执行范围更宽泛的搜索：Code 128、Code 39 和 Code 93。


1D 条码符号属性：输出前应如何设置最小解码量？

设置高数量以增加解码稳定性。如果优先考虑性能速度，则设置低数量。


指定代码大小的好处

指定明确的代码大小可提高读码器对符号有效解码的能力。如果读取不同的代码大小，选择任意。


Code 39 属性

  • Full ASCII 启用 Code 39 扩展码。

  • 校验字符仅对含有效校验字符的符号解码。

  • 传输校验字符包括含解码数据的校验字符。

  • 转换为代码 32 转换代码 39 字符集代码 32 如果选中。


Interleaved 2 of 5 属性

  • 校验字符仅对含有效校验字符的符号解码。

  • 传输校验字符包括含解码数据的校验字符。


Pharmacode 属性

指定代码大小和方向的好处

指定明确的代码大小和方向可提高读码器对符号有效解码的能力。

在任何符号中数据字符数和线条数

数据字符: 线条

  • 1: 3 注：读码器读取的字符代码中，只有 1 个有 3 个或以上的线条。 以上仅指6、7、8 和 9。

  • 2: 3 至 6

  • 3: 6 至 9

  • 4: 9 至 13

  • 5: 13 至 16

  • 6: 16


Codabar 属性

  • 校验字符仅对含有效校验字符的符号解码。
  • 传输校验字符包括含解码数据的校验字符。
  • 传输开始和停止字符包括含解码数据的开始和停止字符。


MSI 属性

  • 校验字符仅对含有效校验字符的符号解码。
  • 传输校验字符包括含解码数据的校验字符。
  • 校验和计算方法可选择用于计算校验和的方法。


DataBar 属性

  • GS1 DataBar 有限：对线性条码中含有指标数字为 0 或 1 的 14 位 EAN.UCC 商品标识解码，它用于不在销售点扫描的小件商品上

  • GS1 DataBar：对线性符号中的全部 14 位 EAN.UCC 商品标识解码，可由已适当编程的销售点扫描器进行全方位地扫描

  • GS1 Databar 展开：长度可变、种类扩展的代码类型能够对 14 位 GTIN 和其他数据，包括有效日期、原产地和多达 74 个数字或 41 个字母数字字符的序列号解码。


Postal 属性

  • POSTNET：由美国邮政局用于协助收发邮件的一种条码符号。ZIP 码或 ZIP+4 码以这种的独特代码类型编码，它用不同高度的线条对数据编码。

  • PLANET：邮政字母数字编码技术 (Postal Alpha Numeric Encoding Technique, PLANET) 条码由美国邮政局采用，用于在分发过程中识别和跟踪邮件。与 POSTNET 一样，它以不同高度的线条对数据编码。

注：只有出现在栅栏位置，才可以解码邮政编码。


支持的Quick Response (QR) 代码版本

QR (Quick Response) 代码是 2-D 代码类型，具有用来对数据解码的一组方形黑白模块的特征。读码器可以辨认三种不同的类型：

  • 型号-1: 原版

  • 型号-2: 增强版

  • Micro QR Code：非常小的 QR 代码，适用于比其他 QR 码数据量更少和空间更小的应用场合


QR Code 属性：什么是符号难度？

符号难度控制读码器尝试对每个图像解码的难易程度。设置易将对高对比度、高印刷质量的代码解码，并使读码器灵活性最大化。设置难将对具有挑战性的直接部件标记解码，但会降低读码器的灵活性。


QR Code 属性

最大栅格大小

最大网格尺寸允许对尺寸大于 49 的 QR 码解码。可以拖动滑块或向右侧的文本框键入特定的代码尺寸。

QR代码质量度量

有关代码质量度量的信息，请参阅 DataMan 通信与编程指南。


DotCode 属性

指定数据行数和列数

指定最小和最大数据行数和列数可以提高读码器对符号可靠解码的能力。

极性设置

可以设置该设备作为与其背景相关的模块（点）要定义的是什么。亮中暗设置意味着设备扫描并解码明亮背景上的暗点，而暗中亮则相反（黑暗背景上的亮点）。

默认情况下，任一设置都会扫描其各自背景上的这两种模块，但这可能会导致解码速度较慢。


UPC/EAN 属性的不同设置有哪些？

  • 扩展启用对扩展型代码的解码。

  • 补充控制读码器如何对补充代码解码。

  • 删除前导零用于删除解码字符串中的前导零。

  • 允许 EAN8 补充启用对 EAN8 符号中补充代码的解码。

  • UPCE1 已启用启用对 UPC E1 符号的解码。


UPC/EAN 属性：扩展复选框表示什么？

这是一个布尔符号，表示报告的 UPC-EAN 解码字符串是否应扩展到 13 位 EAN13 格式或以标准 UPC-E 6 位数字格式传输。

选中（默认）时，解码的字符串以 EAN-13 格式（例如 0012345000065）传输。未选中时，结果将传输为 <数制> + 6 个数据位 + <校验字符>（例如 01234565）。


应用细节


在 “应用详情” 步骤中可以进行哪些设置？

在“基本”选项卡中可以进行触发设置和曝光设置。“触发助手”、 “间隔时间助手”和“曝光助手”可方便地帮您完成这些设置。

在"高级”选项卡下，可在表视图中实现更多设置。


触发类型有哪些？

  • 演示触发在每次检测到符号时，就会对它连续扫描并解码。演示触发依靠读码器内部的计时装置和动作侦测。

    可以在演示模式下指定几个参数，如读码器是否多次读取同一代码或扫描下一个代码之前等待多长的时间。使用系统设置面板和解码设置选项配置演示触发。

    在演示模式下，使用自动曝光设置使读码器确定图像所需亮度的最佳曝光设置。然而，请注意，读码器会使用采集的初始图像来确定这些设置，可能会丢失包含解码符号的图像。可以切换至手动曝光设置并指定成像器曝光的精确设置。

    • 将设备放入基站。
    • 在设置工具中切换到手动触发模式，然后切换回演示模式。
    • 扫描输入演示读码器配置代码。

  • 手动触发开始采集图像以响应下列事件：

    • 按下读码器按钮

    • 通过 USB 或串行连接连接至读码器时，发送 DataMan 控制命令 (DMCC) 触发信号

    • 单击设置工具中的触发按钮

    • 设置工具获得焦点时按下键盘 Ctrl+T

    只要信号仍然有效，读码器就会继续采集图像，在找到符号并解码或触发信号结束时停止。

=


触发助手

首先为助手选择工作的触发类型。从下拉列表中选择触发源：未定义、没有或在外部。从助手获取建议的触发模式。触发类型的图片演示帮助您做决定。选择已选中的触发类型并点击“保存和关闭”。


时间间隔助手

在连击触发、自触发和连续触发模式下，“内部助手”可帮您做更多设置。可选择三种方式计算必要的数据。在右上角选择计算单位（标准或度量）。

根据测量的物理视场和给定的最大线速度和最长代码大小，点击“视场”计算可能的最长间隔时间。

如果需要设置镜头代码距离可点击“镜头/代码距离”选项。从下拉列表中设置焦距并选择代码传输方向。也可以在此设置最大线速度和最长代码的大小。

点击“代码元素大小”计算最窄代码元素的大小。启用“测试模式”读取代码。也可以在此设置代码传输方向、最大线速度和最长代码的大小。

从“助手”底部获取推荐的最大间隔时间。


曝光助手

“曝光助手”与“间隔助手”功能非常类似。可以三种相同方式计算：视场尺寸、代码距离和代码元素大小。

根据测量的物理视场和给定的最大线速度，点击“视场”计算推荐的最大曝光时间。可以启用“测试模式”读取最小代码。

如果需要设置镜头代码距离可点击 “镜头/代码距离” 。从下拉列表中设置焦距并选择代码传输方向。也需要在此设置最大线速度。

点击“代码元素大小”计算最窄代码元素的大小。启用 “测试模式” 读取代码。也需要在此设置代码传输方向和最大线速度。

从“助手”底部获取当前推荐的最大曝光时间。


一旦出现有效读取，将会获得更多图像？

不，当读取之前的设置失败时才获得更多的图像。一旦设置生成一个有效的图像，读码器在触发器周期内和解码开始时将不再尝试其他设置。读码器将按优先级顺序，从指定的最高优先级设置开始尝试每个启用的设置，依次进行，直至获得有效读取。


第一次读取后和上次读取延迟后选项之间有何不同？

第一次读取后延迟是在第一次读取给定的代码后开始计时，计时器将不会重置。这意味着，如果读码器在多个图像模式（如连续模式）下，以及如果代码放在读码器前方的时间量等于或超过重读延迟，可能会重新读取代码。

上次读取后每次图像中出现给定的代码就重置计时器。这意味着只要代码放在读码器前方，就不会重读代码。对于时间等于或超过重读延迟的代码，只有从读码器视场中移除才会重读该代码。


如果再次触发读码器，我的代码读取两次，为什么？

重读延迟和相同代码从不读取两次选项仅影响单触发循环内的采集。对于相同代码从不读取两次，触发读码器将清除计时器和上次读取的代码。


什么是相同代码从不读取两次？

相同代码从不读取两次选项启用后，禁止在一行中或单触发序列内两次报告相同的代码字符串。它适用于所有的触发模式，但只对多代码读取有效，因为在单触发序列中获得一个以上代码的唯一方法就是多代码读取。如果未选中相同代码从不读取两次，设备将在指定的代码重读延迟（以毫秒计）后重新读取并重新传输相同的代码。


什么是延迟模式和代码重读延迟？

延迟模式选项可设置与第一次或最后一次读取相对的代码重读延迟。

代码重读延时（以毫秒计）选项可指定读码尝试次数之间的延时。为这种延时指定非零数值有助于防止数据覆盖连接至读码器的设备。


什么是动作侦测？

动作侦测允许用户设置设备，以在设备的视场中侦测到动作后的一段时间内切换到活动的演示或自触发模式。

动作侦测设置只在触发类型设置为演示或自触发时才可用。动作侦测启用时，设备不考虑图像，而是在后台侦测其视场中是否出现动作场景。

如果处于运转状态，设备会像演示或自触发模式一样积极获取图像。超时设置允许设备从活动的触发模式切换回动作侦测后指定时间段（以秒为单位），但此“超时”每次会在成功读取代码动作后重设。

可以设置动作侦测灵敏度来定义设备识别何种程度的动作以开启活动的演示和自触发模式。


如何从键盘发送触发信号？

按下 Ctrl+T（设置工具窗口必须处于活动状态）。


如何调节图像曝光？

演示和手动触发类型使用自动曝光设置，自动确定每个图像中所需亮度级别的最佳设置。使用任一触发类型，都可以使用生产环境所需的最大曝光设置，或选择手动曝光并设置精确的曝光时间（以微秒计）。增益滑块（图像视图区域下方）显示目标的像素亮度。


读码器使用何种照明与成像器设置？

可以配置四种不同的读取设置。在尝试读码时，读码器依次使用每个已启用的设置尝试读码。要启用设置，单击读取设置处的设置照明或选择读取设置面板处的设置。启用的设置用绿灯标记。

在开始新扫描时，如果启用了多个设置，读码器总是从最近使用过的设置开始。读码器会根据解码的尝试次数切换设置，即在默认设置下，经过 2 次或 3 次解码不成功后，就会转至下一个设置。选择树状视图中系统设置下方的触发器设置面板，更改尝试解码的次数。


冲压式点阵标记应使用何种设置？

如果冲压式点阵标记位于高度反射的表面, 使用打标故障或纹理表面设置。否则，通用设置应读取多数冲压式点阵码。


可以启用所有的设置吗？

应仅启用适用于零件和标记的设置。请谨记，尝试读码时，读码器循环使用所有启用的设置。启用的设置越多，读码器读码所花的时间可能越长。

默认情况下，所有读取设置都已启用。确保为所有已启用的读取设置启用所需的代码质量设置，否则 1D 质量指标不返回数据。


不运行设置工具时如何更改启用的设置？

对于随时扫描以启用单个设置（并禁用其他 3 个设置）的代码，扫描配置代码文档（可通过 Windows 开始菜单或设置工具帮助菜单获取）。


如何快速打开或关闭读码器所有的照明？

在显示 LED 照明的图像上单击右键。可以选择以下选项：

  • 全开

  • 全关

  • 南北

  • 东西

更改会根据选择立即生效。


格式化数据


数据格式化如何工作？

在 “基本” 面板中选择需要使用的格式化类型。

通过使用单个条码符号选项卡上的预定义构造块，利用“标准”面板创建自定义的输出字符串：

  • 输出字符串以前导文本字段中输入的文本开头。

  • 从一般、验证和指标（适用时）选项卡中的列表选择项目，然后点击添加将它们添加到输出字符串。要添加解码数据的特定字符范围，单击设定子字符串范围，然后输入要添加的字符范围（例如 1-3,5,8,10-），然后单击列表中的子字符串并单击添加按钮。

  • 输出字符串也包括任何添加到结束文本字段的文本。

  • 要以回车/换行对结束整个字符串，选择 CR/LF复选框。


为什么"标准" 下会有不同的选项卡？

为不同的代码类型分别指定格式，或使用通用选项卡为任何解码的符号指定数据格式，这优先于指定代码类型的选项卡。


怎样才能使用代码符号指定和通用格式化这两个选项？

使用特殊条码符号选项卡和“通用”选项卡时， “标准格式化”面板采用下列标准：

  • 如果启用，每个单独的结果将通过代码类型指定格式化程序。相同代码类型的多个结果将使用相同的设置分别格式化。

  • 如果启用通用选项卡，个别结果将通过代码类型指定格式化程序（如果启用），然后使用通用选项卡上的格式化规则来增强。对于多个结果（位于支持的读码器上），结果将以选定的分隔符连结或隔开，结尾处无额外的分隔符。连结的字符串将被视为通用选项卡上保留格式化规则的单个字符串。

  • 对于多个结果，连续字符串中的结果顺序为 1) Data Matrix 2) QR Code 3) 1D 代码 4) Vericode 5) DotCode 6) OCR。

  • 任何添加到仅适用于整个解码过程（例如解码时间或触发信号索引）的代码类型指定格式的令牌，将报告此全局值。


如果标准格式化未启用，发送什么数据？

读码器传输完整个解码字符串时，后接回车/换行对。


如何才能只传送解码数据，而不发送回车/换行对？

启用格式化，将全部字符串添加到输出字符串，并确保未选择 CR/LF 复选框。

要只发送回车，在结束文本字段中输入 \r。


什么是输入字符串？

输入字符串是可列为脚本格式中部分读码器属性的格式标记或作为标准数据格式的标记。请注意，不能在设置工作中更改输入字符串的更多属性，其参数仅适用于 DMCC。


如何让 Excel 停止跳过单元格？

默认情况下，读码器会在每个传输代码后面添加回车/换行对。使用键盘连接将传输代码输入到 Excel 时，回车/换行对会导致 Excel 在每个代码后前进两行。为避免此类情况发生，配置读码器使它仅发送回车：

  1. 单击标准格式化。

  2. 在代码类型选项卡中指定正在使用的代码类型。

  3. 选取格式化已启用框。

  4. 单击一般选项卡中的全部字符串。

  5. 单击添加。

  6. 在结束文本的文本字段中输入 \r 并取消 CR/LF 框的选择。


数据验证启用时如何输出解码数据的特定元素？

首先，在 “数据验证” 面板中选择需要验证的类型。启用“格式化数据”应用步骤“基本”选项卡上的“基本格式化”选项。选择“标准”选项卡的“验证”选项卡，然后将所需的数据字段添加到输出字符串，包括企业标识符、序列号、部件号、独特项目和 GS1 应用标识符。


在“标准”选项卡的“数据”字段中，“一般”选项卡里个别选项是什么？

  • 子字符串：在符号中解码的子字符串。要使用此选项，必须指定子字符串的范围。

  • 全部字符串：符号中解码的全部字符

  • 解码时间：读码器对符号解码的时间量，以毫秒为单位。这个时间段不包括图像采集、等待图像处理、通讯时间和其他处理（例如，数据格式化）。

  • 触发时间：接收触发信号和完成解码操作之间的时间量，以毫秒为单位

  • 代码类型：解码符号的代码类型

  • CR/LF：换行回车

  • TAB：制表符。

  • SP：空格字符。

  • 代码类型标识符：ISO/IEC 15424:2008 规定的代码类型识别符

  • 模块大小：符号中每个模块的宽度（或高度），以像素计

  • 代码位置：解码符号每个角的图像坐标

  • 代码方向：对符号解码的方向以度数为单位报告。顺时针旋转的解码的符号被认为是积极的变化方向。

  • 对比度：使用 0 和 1 之间的值表示解码符号的对比度总量。高值表示符号中的明暗模块有大范围的灰度值，而低值表示明暗模块由相似的灰度值组成。

  • UEC：符号中未使用的纠错量。纠错是指对因符号破坏而丢失数据的重建或替换方法。“100”是个理想值。1D 条码总是返回 -1。

  • 输入字符串：接收的（串口或以太网）输入字符串。

  • 过滤时间：以毫秒 (ms) 为单位的过滤时长。

  • 结果来源：设备的名称。

不论读码器是否连接至设置工具，所有以下值都将增加。

  • 读码总数：解码符号的总数

  • 未码总数：收到触发信号但未对符号解码的数量

  • 触发信号总数：触发信号总数 = 读码总数 + 未码总数 + 丢失的触发信号总数

  • 丢失的触发信号：检测到触发信号时由于没有可用的图像缓冲而丢失的触发信号数量

  • 触发信号索引：读码器检测的触发信号总数。

无论是在进程监控面板中清除进程统计数据，还是在读码器重新启动后，随时重置为 0 的值如下：

  • 总读取数

  • 未码总数

  • 总触发器

  • 丢失的触发器

触发索引只有在读码器重启后，而不是在清除进程统计数据后才重置为 0。


如何模拟 Alt 键、Ctrl 键或 Shift 键组合？

要使用此功能，可使用四个转义序列：\ALT-、\CTRL-\、SHIFT- 和 \K。\ALT- 用于 <ALT 键> 序列，\CTRL- 用于 <CTRL 键> 序列，\SHIFT- 用于 <SHIFT 键> 序列，\K 用于特殊键。请注意，反斜杠后面的按键字母需要大写，否则就不能识别特殊的按键组合。

在“标准”面板的“前导/结束文本”字段中输入此序列。

支持的特殊键盘序列

应使用下列格式：

\ALT- 后接键名，再接 ;

或者

\CTRL- 后接键名，再接 ;

或者

\SHIFT- 后接键名，再接 ;

或者

\K 后接键名，再接 ;

必须使用终止分号来区分带相同前缀的序列，否则就可能任意解释按键序列，例如 \KF11 经检测就毫无意义，它的意思是“按 F11 键”还是“按 F1 键之后再按 1” 。

请注意，如果广义空格的位置输入连续的 2 个 Esc，它们也会被应用于未读码结果中。

支持的按键序列和按键

以下列表包含当前支持的按键组合：

  • ALT-A 至 ALT-Z

  • CTRL-A 至 CTRL-Z

  • CTRL-F1 至 CTRL-F12

  • SHIFT-F1 至 SHIFT-F12

  • F1 至 F12

  • ALT-F1 至 ALT-F12

  • PageUp、PageDown、Home、End、箭头键（上、下、左、右），Insert、Delete、Backspace、Tab、Esc、Print Screen、GUI（左、右）键

    这些按键的转义序列如下：

    • PageUp -> \KPup;

    • PageDown -> \KPdn;

    • Home -> \KHome;

    • End -> \KEnd;

    • 上箭头 -> \KUar;

    • 下箭头 -> \KDar;

    • 左箭头 -> \KLar;

    • 右箭头 -> \KRar;

    • Insert -> \KIns;

    • Delete -> \KDel;

    • Backspace -> \KBksp;

    • Tab -> \KTab;

    • Esc -> \KEsc;

    • Print Screen -> \KPrtScr;

    • 左 GUI -> \KLGui;

    • 右 GUI -> \KRGui;

  • 暂停输出 -> \KPAUSE;

以下是一些例子：

  • 要生成 <ALT-V> 序列，使用 \ALT-V；

  • 要模拟按下 <F10> 键，使用 \KF10；

  • 要模拟按下 <Home> 键，使用 \KHome；

  • 要启用/禁用记事本中的状态栏 (<Alt-v><s>)，序列应为 \Alt-v;s

如果使用的序列不正确或不完整，标志转义序列的这两个字符将会忽略。在这种情况下，将跳过转义序列的前两个字母，发送剩余的字符。例如，“\ALT-M11;”序列是无效的，结果将显示“LT-M11;”


如何测试数据格式化？

使用页面底部的测试按钮以测试结果如何显示。

扫描一个符号并在状态栏中查看格式化的结果。也可以选择结果历史记录面板，然后读码。结果历史记录会列出指定的格式化结果。


什么是输出选项功能？

使用输出选项功能，能以不同格式输出所需的输出数据元素。例如，如果选择了逗号并已选择输出完整字符串加条码符号类型，则输出结果为完整数据字符串，加逗号，再加文本“Datamatrix”。要测试不同的输出，可以选择特定的输出类型，然后选择测试按钮以查看相邻显示窗口中的输出。请注意，如果选择了数据验证并且代码未能通过数据验证，输出选项功能将不启用。


测试按钮为何呈灰色？

仅在首次成功解码后才能测试代码。


可以使用十六进制或八进制 ASCII 代码指定字符吗？

在前导文本和结束文本字段中，可以将字符指定为 \nnn，此时 nnn 为八进制 ASCII 码。通过输入 \xnn，可以按十六进制指定字符，此时 nn 为十六进制 ASCII 码。

也可以使用以下预定义的代码：

  • \a 警报 (ASCII 7)
  • \b 退格 (ASCII 8)
  • \E ESC (ASCII 27)
  • \f 换页 (ASCII 12)
  • \n 换行 (ASCII 10)
  • \t 水平制表 (ASCII 9)
  • \r 回车 (ASCII 13)
  • \v 垂直制表 (ASCII 11)
  • \\ 反斜杠 (ASCII 92)


读码器在不读码时传输什么？

如果读码器无法读码，通常不会传输任何数据。结果历史记录将显示一条空结果字符串和一个红叉图标，并显示消息“未读”作为结果状态。


什么是代码位置结果？

对于 DataMatrix 符号，代码位置表示符号四个角的报告位置。读码器返回 4 对座标：

  • 第一对表示扫描器样式的交叉。

  • 第二对表示水平扫描器样式和垂直定时器样式的交叉。

  • 第三对表示定时器样式的交叉（沿对角线与第一对相反）。

  • 第四对表示垂直扫描器样式和水平定时器样式的交叉。

Cognex 建议选择分隔符（如逗号）来分隔每个值，使结果数据易于阅读。


应该选择哪种数据格式化方法？

可以使用“基本格式化”（标准或 Perl 样式），或在“脚本”面板的数据格式选项卡中编写自己的 JavaScript 脚本程序。这两种方法的区别如下：

  • 基本格式化允许拖放预定义的数据格式化元素。

  • 除格式化读取的结果和数据外，脚本格式化还允许写入能够使读码器执行发哔音或拉起 output 1 等操作的脚本。


通信选项卡的用途是什么？

在此选项卡中，可以编辑自定义的通信协议脚本。


脚本格式化的限制是什么？

在脚本格式化中，限制为两个自定义事件和覆盖系统事件。


何处能找到脚本示例？

下列选项可将脚本插入脚本面板的主窗口：

  • 单击顶部工具栏的插入代码片断按钮，并按需从列表中选择相应的代码片断。

  • 用鼠标右键单击主窗口任意位置，并选择插入代码片断...。按需单击列表中的相应代码片断。

  • 按下 Ctrl-K、X 键

注：如果插入代码段按钮未处于活动状态，则设备上运行的固件版本不支持当前脚本选项卡的代码段。


FTP 存储选项卡的用途是什么？

此选项卡用于图像和代码质量报告的 FTP 文件名生成。


如何载入脚本？

通过点击功能区菜单进行存取，然后点击打开脚本选项。可以使用保存脚本按钮将脚本保存。

注：脚本只支持 UTF-8 字符编码！


什么是补充字词选项？

通过以下方法，可以将脚本的字词补充完整：

  • 在上方工具栏中单击补充字词按钮

  • 用鼠标右键单击主窗口任意位置，并选择补充字词

  • 按下 Ctrl-K、W

然后，可以从对象列表中选择，以插入脚本。


如何快速编辑脚本？

使用上方工具栏的剪切、复制或粘贴按钮，或者用鼠标右键单击主窗口任意位置并选择剪切、复制、粘贴、删除或全选。


为什么在选择系统 -> 保存设置后所有变量都重置？

每当脚本更改或编辑器焦点离开时，传送到读码器的脚本会导致脚本引擎的上下文无效。脚本上下文无效会导致所有变量被重置。


如何使用脚本查看设备日志中的错误？

使用 Throw() 命令报告出现的反常情况（例外），当设备未连接到设置工具时，设备日志中会出现错误。可以通过单击安装工具菜单栏中的 系统，然后单击显示设备日志访问错误日志。

当设备连接到设置工具时，例外情况会出现在脚本面板中的脚本下方。


何处可以获取有关脚本格式化的更多信息？

有关更多信息，请参见 DataMan 通信和编程指南，可通过 Windows 开始菜单或设置工具帮助菜单获取。


在代码输出中如何设置延迟？

要在代码输出中设置暂停，可以添加序列 \Pause<time>; 到数据格式化面板中的文本字段。

<time> 包含一个以毫秒为单位的值，例如，要等待 4 秒钟，序列为 \Pause4000。

配有 USB HID 或 RS232 可使用此功能。对于 RS232，此功能需要使用 DMCC 命令 COM.RS232-ENABLE-PAUSE 来启用。对于 USB HID，它会默认为启用。


为什么顶部会有不同的选项卡？

为不同的符号分别指定格式，或使用通用选项卡为任何解码符号指定 perl 样式的正则表达式格式化。


如何指定任意文本替换？

在正则表达式： 文本框中输入文本。字符串的语法为：

        /search/replace/g

其中，搜索是要搜索的字符串，替换是要替换搜索的字符串。在默认情况下，仅替换第一次出现的搜索。要替换所有内容，请在命令结尾处添加 g。

例如，如果读码器要对这个字符串解码：

        UPC 05214275600

通过使用此替换字符串，用字符串 "SKU CODE:" 替换字符串 "UPC"：

        /UPC/SKU CODE:/

可以生成此输出字符串：

        SKU CODE: 05214275600

可以输入多对取代项，以空格分隔。依次使用多个配对：第一对的结果用作第二对的输入内容，依以类推。


“放弃不匹配的数据”指什么？

在默认情况下，不属于匹配字符串的任何文本通过时都不会更改。如果选择放弃不匹配的数据，仅发送替代后的字符串。


要避开的特殊字符有哪些？

在搜索和替换字符串中，以下字符有特殊的含义：

            ˆ  ., (  )  [  ] $ \ / * + |

如果在搜索或替换字符串中包含所有这些字符，必须在前面加上反斜杠字符 \。要包括反斜杠字符，输入 \\。要输入任意的 ASCII 字符，输入 \xhh，其中 hh 是十六进制字符数值（无法使用 \ooo 指定八进制 ASCII 值）。


如何使用通配符来匹配不同的字符或样式？

在搜索字符串中使用这些特殊字符，可以匹配任意单个字符、一组字符中的任意字符、字符范围内的任意字符，或不在字符范围内的任意字符：

.匹配任意单个字符

[abcd...]匹配组合 a, b, c, d ... 中的任意单个字符

[a-z] 匹配 a 到 z 字符（可以使用字母或数字）范围内的任意单个字符

要使用字符组或范围转化通配符方向，请在字符前加上 ^。

要匹配可变数量的字符，在匹配的字符或通配符上附加以下一个修饰符字符：

+ 匹配一个或多个前导字符

* 匹配零个或多个前导字符

? 匹配零个或一个前导字符

{n} 匹配 n 个前导字符

{n,m} 匹配至少 n 个但不多于 m 个前导字符

{n,} 匹配至少 n 个前导字符

以下为一些通配符匹配的实例：

/A.B/AB/g 移除输入字符串中“A”和“B”间的任何单个字符

/A.*B/AB/g 移除输入字符串中“A”和“B”间的任何数量的字符


有匹配特殊字符的通配符吗？

使用下列换码序列以匹配特殊字符和字符类型：

\n 换行字符

\w 字母数字字符（字母或数字）

\W 非字母数字字符

\s 空白处字符

\S 非空白处字符

\d 数字

\D 非数字

可以将这些字符与上述所列多字符匹配通配符组合使用。


如何锚定搜索字符串？

在搜索字符串前加上 ^ 仅匹配字符串的开头。在搜索字符串前加上 $ 仅匹配字符串的结尾。


如何在结果字符串中重新使用部分搜索字符串？

在括号中包含要在结果字符串中使用的搜索字符串。可以使用令牌 \1、\2 等在结果字符串中查找包含的字串。


Perl 样式正则表达式有最大大小吗？

任何一个选项卡中输入的脚本的最大大小为 512 个字符，但代码类型指定的选项卡将在通用选项卡之前运行。如果同时使用两者，则可以写入最多 1024 个字符的脚本。


何处可以获取更多有关 Perl 样式正则表达式的信息？

此处。请注意，读码器并不能执行该页面描述的所有功能。


输入/输出


我可以更改哪些系统设置？

您可以禁用或启用蜂鸣器。

通过 Advanced 选项卡的 System Settings 下拉列表可以控制读码器在读取代码、无法读取代码以及读取的代码未通过验证时的操作。

  • Sound level 控制信号音的音高。

  • Number of tones 控制发出信号音的次数。

  • LED color 设置读码器状态指示灯（安装在读码器背面）显示的颜色。

  • Enable vibration 控制是否通过振动表示有效读取。


在调谐按钮设置下可以更改什么？

按下调谐按钮时可以设置设备使用什么输入。默认情况下，DataMan 8600 的 延长的读取尝试按钮用于调谐优化。调谐优化会为当前解码自动选择最佳的读取设置，并在 DataMan 设置工具中将它设置为不可见的读取设置 4，当禁用其他读取设置时锁定条码符号、曝光、照明设置、焦点等。这对重复读取相同类型的代码提供了更便捷读取的用例。

要执行调谐优化，可按住延长的读取尝试按钮直到黄色/绿色指示灯闪烁，然后松开按钮。指示灯继续闪烁，直到代码被读取为止。按下触发器读取代码时，指示灯循环，通过启用读取设置执行多次触发，然后闪烁停止。哔声和稳定的绿色指示灯表示调谐已结束，读码器已优化。可以通过再次按住延长的读取尝试按钮撤消调谐，直至指示灯变红。

也可以选择由延长的读取尝试按钮使用的替代读码选项：

  • 训练匹配字符串：用光学按钮配备设备（通过按住延长的读取尝试按钮）后，下一个触发器将读取代码设置为匹配字符串（要使用匹配字符串需要功能键）。

  • 启用检验器：配备装置（通过按住延长的读取尝试按钮）后，触发启用读取代码上的验证（要使用验证需要功能键）。

若要禁用延长的读取尝试按钮，可在此使用禁用读码器按钮。


使用调谐按钮选项卡中的 3 秒按钮操作，可以设置什么？

可以设置读码器对按住调谐按钮 3 秒钟后应如何作出反应。如果核取更多选项，则功能会按列表顺序运行。


如果选中禁用读码器按钮选项会怎样？

选择此选项会导致读码器的调谐按钮被禁用。


调谐按钮选项卡中的禁用读码器按钮复选框起什么作用？

如果选取禁用读码器按钮复选框，在按下读码器按钮时，读码器不再启动读码操作或训练尝试。请注意，该功能不禁用设置工具按钮栏上的触发按钮或串行触发命令。


可以更改哪些系统设置？

可以提供自定义设备名称。还可以管理输入、照明输出和声音输出按钮。可以在此处禁用或启用蜂鸣器。


在哪里设置用户事件？

切换至格式化数据面板，启用脚本格式化。在脚本选项卡的数据格式化窗口中，可以添加您的事件。


选定的操作何时发生？

选中复选框后，指定给输入的操作不会在激活输入后立即发生。只在执行下一次触发时才发生。


如何重置读码器？

扫描印在快速参考指南背面的重启扫描器命令，执行软重置操作。虽然读码器中的非易失性存储器不会清除，但读码器会关机并重启。

扫描将扫描器重置为出厂默认值命令，将读码器还原至出厂默认状态。


读码器在不读码时传输什么？

如果读码器无法读码，通常不会传输任何数据。可以通过指定不读取字符串发送长度不大于 32 个字符的指定字符串。单击系统设置节点，然后在输出节点下的未读取输出字符串字段中输入字符串，并按下 <Enter> 键。


为什么要更改设备名称？

可以为生产环境下的设备起个更有意义的名称，如位置或检查任务。


如何更改设备名称？

要更改设备名称：

  1. 在设备名称中输入设备的新名称。

  2. 弹出“更改需要重新启动后才能生效，是否应用更改并立即重新启动？”的询问对话框。单击是。

  3. 如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启设备。

下一次启动设置工具或单击主页屏幕中的刷新，将显示新的设备名称。


可以更改哪些系统设置？

可以禁用或启用蜂鸣器。

可以通过“高级”选项卡的“系统设置”下拉列表，在读码、不读码以及读码验证失败时控制读码器的具体操作。

  • 音量控制信号音的大小。

  • 音调次数控制信号响起的次数。

  • LED 颜色设置读码器状态指示器上显示的颜色（装在读码器背面）。

  • 启用振动控制是否由振动发送有效读码信号。


什么是唤醒消息？

如果启用唤醒时输出诊断字符串，读码器或基站会在启动时传输诊断字符串。

此功能对 USB 连接不可用。对于串行连接，无论设置工具如何设置，波特率都会在发送消息时自动设定为 38,400。


通信


在“通信应用”步骤中可以进行哪些设置？

可利用 “通信” 应用步骤中的三个选项卡对串口和以太网进行设置。点击适当的标签输入设置值。

在"高级”选项卡下，可在表视图中输入更多设置。


如何更改读码器的串行端口设置？

在“通信”应用步骤中的“串口”选项卡下输入新的设置。还可以扫描配置代码文档（可通过 Windows 开始菜单或设置工具帮助菜单）。


何时应使用 USB 驱动程序兼容模式？

默认情况下，DataMan 读码器使用能够帮助读码器从静电放电 (ESD) 事件恢复的 USB 驱动程序。如果需要严格符合 USB 规范或者 DataMan 读码器同 Cognex SensorView 产品一起使用，请使用 USB 驱动程序兼容模式。

更改 USB 驱动程序兼容模式时，会弹出“更改需要重新启动后才能生效，要应用更改并立即重新启动吗？”的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启读码器。


更改 USB 模式会对什么产生影响？

通过串行 USB 连线连接至读码器时，可以将该连接的 USB 速度更改为 1.1 或 2.0。

连接至无线读码器时，更改 USB 模式对基站不会产生影响。更改的设置将保留在读码器内存中，如果将无线滑块更改为串行滑块，读码器将连接至（之前）选定的 USB 模式。


如何使用读码器替代 USB 连接的键盘？

要模拟 USB 键盘，只需扫描读码器配置代码文档中的 USB 键盘代码（可通过 Windows 开始菜单或设置工具帮助菜单）并确保断开与设置工具的连接。


用通信信道下拉菜单设置能设置什么？

可以在此通过 USB 设置通信方式。根据所用的设备，可使用以下选项：

  • 仅 USB-COM：选择此选项可通过串行端口连接设备。

  • 仅 USB HID：此选项可确保设备像 USB 键盘一样使用。

  • USB-COM + USB-HID：这是上述模式的组合。

注：在仅 USB-COM，一些设备也可能会列出下 'HID 设备'，尽管他们缺乏 HID 功能。


如何使用读码器替代 PS/2 键盘？

要仿真 PS/2 键盘，必须使用如快速参考指南中所述的串行电缆、外部电源和键盘接口电缆。从阅读器配置代码文档扫描 PS/2 键盘仿真启用代码（可通过 Windows 开始菜单或设置工具帮助菜单）。要安装 PS/2 适配器，必须完全断开 PC 的电源。使用上面列出的线缆连接读码器。然后打开计算机，读码器就可以仿真 PS/2 键盘了。


询问时不重启读码器会怎么样？

更改的设置不生效。如果改变想法，可以单击系统并选择保存设置。然后重启读码器。


什么是补零？

补零是在传输的数据中放置前导零，这在某些接受由读码器发送的数据应用时需要。


如何配置读码器的网络设置？

如果使用无线 DataMan 8000 读码器，在基站上配置网络设置。如果使用有线读码器，使用网络选项卡配置网络设置。

选择使用 DHCP 服务器选项，通过 DHCP 服务器（如果有）或手动输入网络设置为读码器指定 IP 地址。有关相应值，联系网络管理员。

更改设置时，会弹出“更改需要重新启动后才能生效，要应用更改并立即重新启动吗？”的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启读码器。


复制电脑端网络设置的这一选项是什么？

如果想要将 DataMan 设备配置为与您的电脑处于同一子网，则需点击复制电脑端网络设置按钮。选择想要使用的网络，设置便会被复制到使用静态 IP 位址窗口中。注：请记得更新您 DataMan 设备的 IP 地址。所复制的 IP 地址属于您的电脑。要使更改生效，需要重启设备。


读码器和基站之间的通信设置同步吗？

必须将读码器放进基站，以便它们能同步交换和更新设置。如果更改通讯设置时读码器已在基站中，拿起读码器并再次将它放进基站中。


如果读码器以 802.11b 通讯，这会导致所有其他的 WiFi 设备以 802.11b 的速度通讯吗？

由于读码器和基站是点对点的连接，它不与第三方 WiFi 网络连接，因此基站和读码器之间的通信速度不会影响其他的 WiFi 设备。


为什么 WiFi 选项卡上所有的选项都禁用了？

如果读码器已与基站关联，选项字段呈灰色显示。如果要更改任何配置，连接至基站。


为什么蓝牙选项卡上所有的选项都禁用了？

如果读码器已与基站关联，选项字段呈灰色显示。如果要更改任何配置，连接至基站。


如何从基站解除读码器的指定？

单击关联基站分组框中的解除指定 按钮。请注意，单击解除指定后，设置工具将丢失连接。确保预先保存所有的更改。

也可以通过扫描解取读码器指定配置代码断开连接。


什么是“固件启动时重新列举”？

在某些情况下，虽然可以列举 COM 端口，但启动固件所需的时间较长，COM 端口超时会被解释为断开连接。为了防止这种情况，此复选框可确保在固件重启后，再一次重新列举 COM 端口。


工业协议

EtherNet/IP 协议

勾选“以太网”选项卡的 “工业协议”框中的EtherNet/IP选项，使读码器采用 EtherNet/IP 协议。

“更改值必须重启后才生效”显示在“通信”横条右侧。点击“保存设置”，然后重启读码器。

PROFINET 协议

勾选PROFINET，使读码器采用 PROFINET 协议。点击“使用站名”框，输入站名。

“更改值必须重启后才生效”显示在“通信”横条右侧。点击 “保存设置” ，然后重启读码器。

SLMP 协议

勾选“SLMP 协议”，使读码器采用 SLMP 协议，然后根据需要设置参数。

“更改值必须重启后才生效”显示在“通信”横条右侧。点击“保存设置”，然后切换读码器的电源或扫描 “复位” 符号，重启读码器，使设置生效。

Modbus TCP

勾选“Modbus TCP”，使读码器采用 Modbus TCP 协议，然后根据需要设置参数。

“更改值必须重启后才生效”显示在“通信”横条右侧。点击 “保存设置” ，然后切换读码器的电源或扫描 “复位” 符号，重启读码器，使设置生效。

EtherNet/IP、PROFINET、SLMP 协议或 Modbus TCP 选项呈灰色

在特定时间内只可以使用一种以太网工业协议。选择一种协议时，另一种协议就不可用了。


如何使用验证选项？

如果启用验证，在通过网络尝试连接至可用的读码器或基站时，设置工具将提示用户以管理员帐户输入密码。


如何建立 TCP/IP 连接？

读码器可以将 TCP 连接到端口 23，它是 Telnet 应用程序的默认 TCP 端口。如果使用 Telnet 客户端，唯一需要提供的参数就是读码器的 IP 地址。如果正在使用其他应用程序或要连接 SDK，请确保使用的 TCP 端口设置与读码器设置相同。TCP 端口可以在 Telnet 面板中更改。读码器将通过该连接自动发送代码输出。还可以通过该连接传输 DataMan 控制命令 (DMCC)。

更改 Telnet 端口时，会弹出“更改需要重新启动后才能生效，是否应用更改并立即重新启动？”的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置并重启读码器。


可以向 FTP 服务器发送图像吗？

使用 FTP 图像选项卡配置必要的设置，向 FTP 服务器传输图像。该选项卡包含服务器 IP 地址和端口号的设置以及用户名和密码组合。请注意，使用 FTP 发送图像并不能保证一定会发送，只有当读码器以更高频率运行且无法安排时间传送图像时才会发送。此外请注意，通过无线链路传输可能比常规网络通信慢得多。在这种情况下，建议使用缩减像素采样/压缩图像。

文件名选项可以指定这些图像要存储的文件。文件名字段可以指定与 FTP 服务器根目录相关的路径（例如 /failed_images/image）。跟在文件名后面显示在标签中的文件扩展名（.jpg 或 .BMP）与缓冲的图像设置面板上的图像格式设置相匹配。请注意，读码器不创建目录；目录必须已建好并能存取。

最大添加值控制项显示文件名中使用的增量限值。值为 0 表示没有增量要添加，该文件可以被覆盖。

服务器生成的文件名选项以空路径开头，这表示 FTP 服务器的根目录。

可以从要传输何种图像列表中选择发送到 FTP 服务器的图像类型。请注意，FTP 服务器需要支持图像传输。


什么是网络客户端？

网络客户端是用于 DataMan ID 读码器主动打开网络中另一台设备以太网连接的工具。一旦打开，连接将具有与 DataMan Telnet 连接相同的基本操作性能；可以生成读取结果（结果传输到外部设备），并可以用作 DMCC 服务器（从外部设备接收处理命令）。


什么是主机？

主机是 DataMan 将连接的网络设备。指定主机设备的以太网地址和端口号。地址可以是完全符合条件的域名（例如“server.mynetwork.com”）或十进制点格式的 IP 地址（例如“192.169.0.1”）。


什么是客户端端口？

客户端端口是客户端连接的读码器上的以太网端口。默认值 0 表明网络客户端使用任何可用端口。在特殊情况下，可能需要指定特定的客户端端口。只需将客户端端口设置为所需的值。请注意，最典型的情况是使用默认值 0。如不能肯定，请使用默认值。


如何连接？

客户端将按照所选的打开连接选项进行连接​​。当接通 DataMan 电源时可用选项将进行连接，或者在有数据活动时进行连接（即读码时连接）。


如何关闭连接？

有两个可用的关闭连接选项​​。连接可以永远保持打开状态，或者可以在数据传输完成后关闭连接。如果选择读码器数据传输后选项​​，还可以在连接断开后设置一个数字（秒），若这段时间内读码器闲置。闲置期的长度的调节范围为 1 到 3600 秒。


什么是连接超时？

连接超时是 DataMan 等待连接打开的时间量（毫秒）。请注意，如果选择了通电选项，则读码器会不断尝试打开连接。


什么是重新连接延迟？

它是尝试重新打开连接之前读码器暂停的时间量（毫秒）。


代码中包含不可打印字符时传输什么？

通常传输不可打印字符的原始值。


维修和支持


什么是维修和支持？

维修和支持页面可用于设置未正确配置网络设备的网络设置或将串行设备的 HID 模式更改为 CDC。


刷新选项用来做什么？

单击刷新按钮可刷新可用设备的列表。


如何将网络设备添加到显示设备列表？

通过单击添加网络设备可以添加网络设备或编辑已添加设备的 IP 地址。添加网络设备对话框打开，可在此提供设备的 IP 地址。单击确定以保存所做的更改，该设备也将显示在连接页面。


如何编辑设备属性？

从设备列表中选择设备以查看可用选项。在打开面板中，可以编辑属于所选设备的网络设置以及设置身份验证选项。单击应用以保存所做的更改。


导出图标有何用处？

点击导出 Cognex 支持文件图标开始 Cognex 支持文件生成，它生成一个含一系列预设数据日志的 .zip 文件。至少选定一台设备，这项功能才可用。

点击按钮会弹出一个对话框，可以在此指定复选框列表中支持.zip 文件所包括的数据类型：

  1. Cfg

  2. Cdc

  3. 最近的图像

  4. 发现的设备

  5. 设备统计信息

  6. 内存统计信息

  7. 用户评论（可以由用户手动编辑）

可以使用“...”图标修改支持文件的目标文件夹。在文件生成后可以选择打开包含它的文件夹或将它作为附件用默认的电子邮件客户端 (.eml) 发送。

过程的输出是 .zip 文件。文件名包含设备名称和创建日期。Zip 中附加的 descriptor.xml 包含以下数据：

  1. 日期

  2. 发现 ID

  3. 设备名称

  4. 设备类型

  5. 序列号

  6. MAC 地址

  7. 功能键

  8. 通信接口

  9. 固件版本

  10. zip 文件中的文件列表


添加虚拟设备按钮用来做什么？

此功能允许基于自定义配置文件或带默认配置的设备来创建虚拟设备。不需要连接设备，就可用于查看设置工具中不同的面板。按下按钮启动向导，引导完成创建虚拟设备的步骤。初始选项将使用配置/备份文件进行创建或使用出厂默认设置。

向导完成后，新的虚拟设备添加到发现的设备列表，用虚拟设备图标表示。创建的虚拟设备对网络上的其他设备不可见。虚拟设备在多个设置工具实例中自始至终存在。

能以同样的方式连接所创建的虚拟设备作为常规设备，除非所有配置更改都遭到拒绝（全都是只读型）且虚拟设备上没有特性、功能和操作工作。


复制电脑端网络设置这一选项是什么？

当您在网络下选择某个设备时，网络设置对话框便会出现在右侧。

点击复制电脑端网络设置按钮来复制您电脑的网络设置，从而无需费力查找您电脑的子网掩码和默认网关设置。需注意所复制的 IP 地址是您电脑的 IP 地址。IP 地址的红色边框是提醒您需要手动将该字段更新为 DataMan 设备的 IP 地址。


备份


如何使用备份功能？

使用此功能，可以通过点击右下角中的备份按钮 （或按下 Alt + B）生成包含配置和一台或多台读码器日志的备份文件。 至少选定一台设备，这项功能才可用。

点击打开备份文件夹按钮导航至放置备份文件的文件夹。可以在首页-> 选项-> 备份位置下方设置文件夹。

如果选择多个设备，每个设备会生成一个备份文件。每个备份文件放在匹配设备名称的子文件夹中。备份文件名包含设备名称和生成日期。

备份文件是带 .dmb 扩展名的 .zip 文件。该文件包含：config.cdc、config.cfg 和 descriptor.xml。xml 包含下列数据：

  1. 日期

  2. 发现 ID

  3. 设备名称

  4. 设备类型

  5. 序列号

  6. MAC 地址

  7. 功能键

  8. 通信接口

  9. 固件版本

  10. zip 文件中的文件列表


可以在哪为备份功能设置备份文件夹？

可以在首页-> 选项-> 备份位置下方设置文件夹


还原


如何使用还原功能？

还原功能允许在一台或多台设备上还原备份配置文件。此功能只有在选择至少一台设备且指定有效的配置源后才可用。

在顶部配置源下方，可以指定用于还原的源设置工具：

  1. 配置文件：选择此选项时，设置工具使用指定的还原配置文件。点击“...”图标以指定包含要使用备份文件的文件夹。有关如何设置文件夹的更多信息，参见备份下方的问答。

    注：只有在某个兼容设备被选为目标时，还原按钮才启用。

  2. 设备：选择此选项时，设置工具使用指定的单个设备以将其配置还原到所有的目标设备。

  3. 最新备份：选择此选项时，设置工具为选定的设备搜索最新备份。如果选择多台设备，所有设备都会获得自己最新的备份。

  4. 出厂默认值：选择此选项时，设置工具软件即会将配置还原为出厂默认值。

选择源以及目标设备后，点击右下角的还原按钮。


如何使用网络设置下拉按钮进行还原？

用网络设置还原工作方式与使用还原按钮相同，但它从备份文件夹中包含的 .cdc 文件而不是 .cfg 文件来还原配置。只有指定源中有 .cdc 且目标选择包含单个设备时，此选项才启用。


更新固件


如何更新读码器固件？

连接您的读码器后，选择系统->更新固件...，然后选择固件文件。

注：固件文件以压缩档案的方式提供。固件必须以压缩形式上载；在上载固件之前不要尝试解压。


如何使用更新固件功能？

此功能为所选的设备更新到所需的固件版本。

  1. 从设备列表中选择要更新的设备。

  2. 通过点击“...”图标浏览固件文件。如果在设备列表中选定单台设备，就会打开该设备相应的固件文件夹。如果选择多台设备，而他们具有相同的固件设备 ID，则会打开相应的文件夹。如果未选择设备或选择更多的设备，但他们具有不同的固件设备 ID，则会打开固件根文件夹。

  3. 点击上传固件按钮。只有选定的固件版本与设备选择相兼容，该按钮才启用。

  4. 如果您想要设置工具以与备份功能相同的方式来备份配置文件，则在弹出窗口中，勾选固件更新之前备份设备。（更多详细信息请见备份部分的问答内容）。

  5. 点击是来开始上传新固件。

注：使用串行设备的情况下，在能够更新固件之前需要通过手动刷新去发现它们。


比较配置


比较配置：一般布局与结构

比较配置是用于设置、复制、比较或还原设备配置的表视图样式工具。文档页面的主要区域包含带设备属性的网格，该设备在打开连接到读码器页面之前已选定。

每个设置工具文档类型使用它自己的连接。使用串行通信的情况下，一次只能打开一个连接。

标题行显示所选的设备名称。下面的第二标题行显示设备的可用设置。通过点击它旁边的图标可折叠或打开下面的行标题（以粗体显示）。断开设备连接时，其标题行会出现重新连接图标。

与读取设置不相关的设置只显示在第一列中（主设置）。


比较配置：控件（鼠标和键盘）

选择：

  • 鼠标：点击网格中的单元格并进行选择，会突出显示单元格的行标题以及设备和设置所属的列标题。菜单按钮和功能区菜单项可以根据选择进行更改。如果所选的单元格位于行标题行中，属于标题的当前列中所有的单元格都会被选择。

  • 键盘：光标移动键可将选择导航到相应的单元格。突出显示和选择操作与使用鼠标相同。

添加/更改值：

  • 鼠标：对于采用嵌入式编辑器的单元格，点击编辑器控件（组合框、复选框、数字选择）允许输入值。对于采用自定义编辑器的单元格（“...”图标），弹出式编辑器将打开，允许输入值。

  • 键盘：对于采用嵌入式编辑器的单元格，按下 Enter 或 F2 启动编辑模式，按下Esc 键取消编辑，第二次按下 Enter 键确认编辑。不用进入编辑模式，即可以在选定的文本中输入值，在此情况下第一次击键将会覆盖当前值。

    对于数值单元格，除了嵌入式文本编辑器单元格外，向上和向下箭头可增加和减小值。

    对于下拉式单元格，按下 “输入” 键启动编辑模式并显示下拉菜单项，而 向上和向下箭头 可移动所选的内容。第二次按下 Enter 键应用选定的值，按下 Esc 键取消编辑。

    对于复选框单元格，使用 Space 可切换选中/未选中状态。

复制和粘贴：

使用组合键 Ctrl+C 和 Ctrl+V 进行复制和粘贴，欲了解更多信息，请查看相关功能区菜单项的复制粘贴介绍。


比较配置：功能区菜单

功能区菜单可在表视图样式网格上方找到。其内容和活动图标可能会随网格中单元格、行或列的选择而变化。菜单可分成几组。

  • 设备：此组中的设置与设备及其配置文件有关。使用添加设备...按钮打开一个对话框，从中选择添加一个或多个要比较的设备。添加配置文件...按钮将打开向导，在此可浏览配置或备份文件 (.dmb,.cdc,.cfg)。如果所选的设备文件不包含所有需要的信息，必须设置缺失参数，否则会自动选择默认选项。这同样适用于虚拟设备数据库无法将参数匹配给可用选项的情况（例如，未找到匹配的固件版本）。

    注：添加的虚拟设备是只读的，因为在其标题行被标记了挂锁图标。

    点击删除设备按钮可删除当前选定的设备（即包含当前所选单元格的那一个）。重启设备可重新启动所选的设备。保留设备上的配置可将所选设备的配置文件保存到它的闪存中。使用重置出厂默认值可将所选的设备重置为其默认值。

  • 编辑：使用复制（或键盘上的 Ctrl + C）从当前选定的单元格复制值。粘贴只能用于同一行中或任何文本编辑器中。重置值用于重置所选单元格的值。

  • 突出显示：此菜单组中的按钮和设置提供选项以突出显示特定的单元格背景。使用非默认值设置，具有非默认值的单元格会突出显示（这在不同设备或读取设置的单个行中可能会不同）。不同于参考设置突出显示单元格，这些单元格与参考读取设置（和设备）同一行中的单元格具有不用的值。选择第三个设置，所有的值和标题都会突出显示，包含文本框中指定的文本。此外，包含的文本本身也使用不同的文本背景突出显示。同样按下 Enter 键也会应用仅显示突出行按钮的功能。

    启用时，仅显示突出行折叠所有不包含突出显示子节点的节点。激活时，设置参考读取设置在使用不同于参考突出显示模式时指定用作参考的读取设置（和设备）。当按钮处于活动状态时，当前所选单元格的列（读取设置）变为参考设置。当前的参考设置在设置名称标题行中被标记。

  • 过滤：设置读取设置只查看与读取设置相关的设置。设置全局设置只查看在不同读取设置中不能有不同值的设置。设置所有设置以同时查看所有设置。如果条目的值出现在多个读取设置中，它们将显示在不同的列中。

  • 其他：使用展开所有行以展开网格中所有折叠的行。使用折叠所有行以折叠网格中所有展开的行。重置布局重新计算列宽度以用完所有可用的空间。如果可用空间不够，会使用最小列宽度。


比较配置：比较编辑器

点击“...”图标后，比较编辑器可打开比较配置表视图中的每个脚本项（它的任何一个子类别）。打开之后，可以查看打开比较编辑器所在设备的脚本源。

通过点击默认，该脚本将恢复为特定设备的默认脚本。通过点击比较，默认脚本出现在右侧的第二个设备上，但可以使用顶部的下拉菜单更改哪个脚本与左侧的脚本相比较。刷新按钮出现在选项卡的中间（红色、 圆形箭头），可以用来刷新所有的脚本文本。

点击关闭，可将比较关闭并移回到比较配置内的表视图。


图像窗口


什么是图像查看器？

在此窗口中，可以看到设备的图像读取。

使用放大镜图标到自动调整图像以适应图像查看器窗口的大小，放大和缩小图像或分别以像素到像素模式显示图像。

此外也可以在实时显示模式下启用或禁用图像的焦点反馈，可以将图像复制到剪贴板。

使用保存图像选项仅保存当前图像或所有连击图像，记录选项将所有不读取或所有解码图像记录到文件系统。

也可以选择检查读取图像的直方图和图像中所选点的亮度数据。使用此窗口工具栏功能区上的按钮可执行这些任务。


结果历史记录


什么是结果历史记录？

在此面板中，可以看到每次读取后的解码信息。

使用暂停按钮暂停/冻结结果历史记录工具视图，这使得寻找特定的读取信息更加容易。所有从设备进入的结果都被结果历史记录窗口拒绝，直到取消暂停。

使用清除历史记录清除历史记录列表。也可以通过使用复制和复制全部选项，分别导出单个或所有已解码字符串。

在记录下方，可以勾选生成代码质量报告，将代码质量数据纳入解码信息，勾选生成数据验证报告以纳入数据验证信息，并将所有结果都记录到文件系统以将所有结果历史记录项目都局部保存本地硬盘。通过单击记录和报告设置可以访问更多这些选项。

自定义允许添加或删除表格列以个性化设置结果历史记录中的信息。

关于结果过滤，参见以下问题。


结果过滤如何工作？

可以使用结果历史记录工具视图功能区菜单中的过滤...按钮来过滤视图中显示的读取结果。点击按钮启用过滤。若要设置过滤参数，可点击按钮右侧打开选项。

注：只有操作系统支持时才显示过滤按钮。

过滤设置中有两种模式：标准过滤和高级过滤。可以通过一般下方的下拉菜单选择任何一种模式。

使用标准过滤时，过滤类别在下拉窗口中显示为活动（结果状态、验证方法、验证状态和条码符号）。通过点击可以选择每个类别下方的个别过滤器。一旦启用，这些过滤器就用于结果历史记录中的所有未来项，也具有可追溯性。未被过滤器指定的项从结果历史记录中删去，直至过滤被禁用为止。请注意，在标准过滤中，触发序列中单个有效的读码结果会计为整个触发序列的有效读码。因此，例如标准过滤不适用于多代码场合；多代码场合使用高级过滤脚本。

使用高级过滤时，标准过滤类别变为非活动状态，高级过滤设置在下拉窗口中被激活。点击它打开一个新窗口，在此可以编辑过滤器表达式。如果之前启用了预定义过滤器，此时在对话框中可看到生成的表达式。编辑表达式不会对预定义过滤器产生任何反向效果。

过滤器表达式本身是一个 JavaScript 函数。使用结果的数据成员就像使用基于脚本的格式化一样。表达式结果可以在窗口底部看到。如果 JavaScript 错误，会有错误消息显示在文本窗口中。请注意，尽管相似，但高级过滤并不是数据格式化脚本，只是在设置工具上运行的显示过滤器。


为什么符号显示绿色轮廓，但在结果历史记录列表中却没有出现任何数据？

如果在标准格式化面板中选择了标准格式化启用，则必须构建定制的输出字符串，否则即使解码了也不显示结果数据。


为什么有些结果前面有图标？

以图标开头的结果具有与其关联的已保存图像。点击结果行以显示解码尝试和与其关联的图像。


代码质量


验证用来做什么？

验证是 DM8600 上的功能键激活功能。它用来评估 Data Matrix 符号是否符合 AIM DPM（直接部件标记）ISO/IEC TR 29158 质量指引。


如何设置验证？

要为 DataMan 8600 检验器设置验证，请查阅 DataMan 8600 系列手持检验器参考手册中的入门指南一章，其中描述了初次校准。之后，验证选项卡会在系统校准旁边显示绿色图标。要更新 DataMan 8600 的检验器状态，请查阅DataMan 8600 系列手持检验器参考手册中的升级验证设备。

在初次校准后，要读码和查看验证结果，请执行以下步骤：

  • 导航到设置 > 代码质量。

  • 在验证选项卡下方，选中验证已启用。

  • 选择代码质量工具视图（通过点击视图下方的代码质量激活）。

  • 检验器与符号相对放置并扣下触发器。符号必须居于视场的中心位置，并且必须经适当转动，使读码器与包含符号的平面保持垂直。必须远离检验器以确保符号正确显示以及照明符合 AIM-DPM/ ISO/IEC TR 29158 质量准则的要求。

  • 移动读码器，直至图像面板中红色矩形的中心位于绿色目标矩形内。读码器发出蜂鸣声表示该符号已读取并经验证。

可以代码质量工具视图窗口查看验证结果。对于在结果历史记录工具视图中选择的每次读取，验证指标都显示在代码质量工具视图中。在顶部可以看到读码的整体等级。

属性列出了个别指标，值是指读取内容与这些个别指标阈值之间的差值。等级是指给出指标的代码质量等级（此列中也出现彩色图标；绿色 = 通过，红色 = 失败，黄色 = 阈值）。平均值是基于该指标最近 100 次的读取。

请注意，校准读码器时，会校准所有启用的照明选项，但不会校准未启用的照明选项。如果启用未校准的照明选项，设备会处于未校准状态。如果尝试使用未校准的读码器执行验证，设备会发出失败音且不会检验任何符号。重新校准能再次进行验证的设备。

关于如何使用数据格式化中的结果，请查阅 DataMan 8600 系列手持检验器参考手册。


验证选项卡上有哪些其他选项？

验证目前支持 AIM-DPM/ISO/IEC TR29158。在选项卡上的质量指标区域可以设置最小通过等级。给符号指标定等级时，此设置是验证获得通过的最小等级。如果勾选，图形已启用允许可缩放矢量图形出现在图像面板中读取代码的问题区域。

参见更多关于以下其他设置的信息。


什么是进程控制？

进程控制度量提供 2D DataMatrix 符号内单个单元格的单元格大小测量反馈。进程监控度量启用时，读码器可以确定连续符号的单元格大小是否变化，或单元格大小是否保持不变。

要使用进程监控度量，必须校准读码器。

启用了进程控制后，代码质量工具视图报告出现标记的单元格增加量，它可用来跟踪一段时间内单元格增加量的变化。


如何使用 AIM DPM 和 ISO/IEC 15415 度量为通过/失败设置自己的级别阈值？

从最小通过等级设置选择所需的等级。这两种度量支持不同的默认通过级别。


应选择哪种照明设置？

不同的照明源可得到不同的标记类型和标记表面。固定的安装照明支持不反射物体上高对比度符号的明场照明，和反射表面低对比度符号的暗场照明。如果可提供可靠的代码质量级别结果，可以选择任何组合。

注意，固定照明配件上不同的照明箱必须连接至扩展 I/O 模块上特定的输出线路，如下所示：

  • 明场 – 漫射垂直 (90)：I/O 线路 2、3

  • 暗场 - 30 度全象限 (30Q)：I/O 线路 4、5、6、7

  • 暗场 – 30 度 E-W 象限 (30T)：I/O 线路 4、6

  • 暗场 – 30 度 N-S 象限 (30T)：I/O 线路 5、7


如何知道 DataMan 8600 是否经授权执行符号验证？

要了解 DataMan 8600 能否执行符号验证，请执行以下步骤：

  1. 将设置工具连接至 DataMan 8600。

  2. 从菜单栏中选择 视图->系统信息。

  3. 扫描验证密钥的功能密钥列表。

    如果显示验证密钥，那么 DataMan 8600 就可以执行符号验证了。


DataMan 检验器可检验的最大 Datamatrix 区域大小是多少？

DataMan 检验器的最大检验区为 1.5 英寸 x 1.5 英寸。


启用了多个照明配置时，读码器如何执行验证？

设备将开始验证首先选择的照明配置并继续，直至接收到总体通过级别。如果照明配置均未达到通过等级，与包含最佳总体等级配置相对应的图像和图形会返回给用户。通过级别受符合 AIM-DPM/ISO/IEC TR 29158 与 ISO 15415 标准的最小通过级别参数的控制。AS9132 质量度量制定了通过或失败的符号等级。


什么是单个的 AIM DPM 代码质量度量？

根据自动识别与移动技术 (Automatic Identification and Mobility, AIM) 协会对 2D DataMatrix 符号制定的标准，代码质量结果会对符号质量提供详细的反馈。所有 DataMan 检验器均为每个检验的符号提供总体级别，也为单个度量提供级别，包括：

  • 单元格调节：实际标记的可读性测量。

    级别是明单元格和暗单元格接近特定标记全局阈值程度的反映，表示特定标记的明单元格和暗单元格之间的灰度级分隔点。

    当读码器的信度相对低，能将单个单元格分类为明或暗时，标记会生成较低的单元格调节级别。分数还会考虑符号内置的纠错能力（较大的符号具有较强的纠错能力）。例如，某个标记将接收较低的单元格调节级别，但如果大多数单元格接近更改状态，则会得到较高的未使用的纠错级别，然而实际上并非如此。

  • 固定样式损坏：标记中扫描器、定时和静区图案的质量。

    读码器使用每个符号中的几个样式查找所含数据并解码。读码器利用与单元格调节分数相同的方法生成固定样式损坏级别，特别是反射比信度测量。

  • 基准解码算法：标准的 2D DataMatrix 算法是否能够找到此特殊标记并解码的表示法。

    这种度量生成的级别为 A 或 F。

  • 单元格对比度：测量符号中明单元格和暗单元格之间的反射比不同，以明单元格的平均反射值百分比表示。

    AIM-DPM/ISO/IEC TR 29158 规范要求对图像进行调整，使明单元格的平均反射值为完全饱和的 78%。

  • 轴向不一致性：测量符号中单个单元格的对称性。

  • 未使用的纠错：测量纠错之后符号中留有的码字的百分比。

    计算未使用的纠错时，如果至少一个单元格在全局阈值的错误一侧，码字就被认为是错误的。2D DataMatrix 符号具有内置代码冗余或出现重复的数据内容。

    值为 1.00 表示码字内没有出现错误。

  • 窗格不一致性：使用符号的定时样式测量一致区间窗格的单个单元格的定位错误的数量。

  • 单元格增加量：测量在水平和垂直方向上单元格增加量的变化。

    单元格大小沿符号的水平 (CGH) 和垂直 (CGV) 计时样式单独测量，并以实际尺寸报告。

    此指标不用于生成总体符号等级，仅用于进程控制，只有在启用代码质量任务面板上的代码质量等级时才可用。


如何用特定符号连同图像的验证结果来创建报告？

  1. 在选项中，选择数据记录。

  2. 查找报告。可以指定 DataMan 设置工具保存报告的位置。此外，可以指定文件名的结构、指定文件名前缀，并禁用每个报告中的叠加图形。

    注意 DataMan 设置工具不具备作为有效字符前缀的功能。如果使用无效的字符，如冒号 (:)，DataMan 设置工具将不生成报告。

  3. 确保在结果历史记录工具视图中的记录下方选中生成代码质量报告。

只要读码器连接至 DataMan 设置工具，每个成功读码的报告都会自动生成到选定的文件位置。


代码质量用来做什么？

使用代码质量可以验证所用的符号符合受 Cognex 支持的代码质量标准之一的质量准则。在评定所给代码质量标准的选定或所有（默认）指标后，为代码提供总体等级。代码质量由功能键激活。

有关特定代码质量标准及其指标的更详细信息，请查阅 DataMan 通信与编程指南或 www.iso.org 网站上相应的 ISO 标准文件。


如何使用一般面板？

代码质量面板作为中心，能为不同的代码类型进行代码质量评定：1D 条形码、Data Matrix、QR 码和 DotCode。对于每种条码符号类型，都可以指定读码器用哪种代码质量标准来评定读取代码。

启用代码质量等级后，设备在脚本中为每个启用了代码质量的读取符号提供质量结果。


代码质量工具视图


在代码质量工具视图中能看到什么？

在代码质量工具视图下方可查看验证结果。能够在此处查看结果之前，必须在代码质量面板上（需要功能键）启用验证。对于结果历史记录工具视图中选定的每次读取，验证指标显示在代码质量工具视图中。在顶部可以看到读码的整体等级。

属性列出了个别指标，值是指读取内容与这些个别指标阈值之间的差值。等级是指给出指标的代码质量等级（此列中也出现彩色图标；绿色 = 通过，红色 = 失败，黄色 = 阈值）。平均值是基于该指标最近 100 次的读取。

关于验证的更多信息，请查阅 DataMan 8600 系列手持检验器参考手册。


读取设置


如何管理设置？

DM8600 执行一套固定的读取设置。通过使用功能区栏下方每个读取设置的启用复选框，可以启用或禁用个别的读取设置。

请注意，对一个读取设置所做的更改不会自动转移给其他启用的读取设置。


什么是开始设置选项？

如果启用了多个设置，读码器全部扫过，当读到代码后停止获取图像。要读取下一个代码，可以确定读码器是否从所选设置或从最后成功解码的设置开始检查。


什么是顶部的筛选器字段？

可以键入要查找的参数，例如，“大小”或“多次触发”，然后按下 Enter 键。找到的项目将突出显示，并且只有那些包含搜索项的参数节点才会展开。可以通过删除所键入的内容并按下 Enter 键关闭搜索。


应使用何种设置？

通用设置可读取多数代码。其他附加设置可以处理特定、难读的标记代码。

  • 曲面适用于表面弯曲、反射和部分反射物体上的标记。

  • 打标故障可以帮助读取冲压式点阵码位于不平表面、很小或成形不好的冲压式点阵码。

  • 变形表面适合部分表面具有需要纹理轴定向照明的应用。


读取设置：一般布局与结构

读取设置是用来设置、复制、比较或恢复读取设置的表视图样式工具。文档页面的主区域包含一个带设备属性的网格。

标题行显示所选的设备名称。下面的第二标题行显示设备的可用设置。通过点击它旁边的图标可折叠或打开下面的行标题（以粗体显示）。断开设备连接时，其标题行会出现重新连接图标。


读取设置：控件（鼠标和键盘）

选择：

  • 鼠标：点击网格中的单元格并进行选择，会突出显示单元格的行标题以及设备和设置所属的列标题。菜单按钮和功能区菜单项可以根据选择进行更改。如果所选的单元格位于行标题行中，属于标题的当前列中所有的单元格都会被选择。

  • 键盘：光标移动键可将选择导航到相应的单元格。突出显示和选择操作与使用鼠标相同。

添加/更改值：

  • 鼠标：对于采用嵌入式编辑器的单元格，点击编辑器控件（组合框、复选框、数字选择）允许输入值。对于采用自定义编辑器的单元格（“...”图标），弹出式编辑器将打开，允许输入值。

  • 键盘：对于采用嵌入式编辑器的单元格，按下 Enter 或 F2 启动编辑模式，按下 Esc 键取消编辑，第二次按下 Enter 键确认编辑。不用进入编辑模式，即可以在选定的文本中输入值，在此情况下第一次击键将会覆盖当前值。

    对于数值单元格，除了嵌入式文本编辑器单元格外，向上和向下箭头可增加和减小值。

    对于下拉式单元格，按下 “输入” 键启动编辑模式并显示下拉菜单项，而 向上和向下箭头 可移动所选的内容。第二次按下 Enter 键应用选定的值，按下 Esc 键取消编辑。

    对于复选框单元格，使用 Space 可切换选中/未选中状态。

复制和粘贴：

使用组合键 Ctrl+C 和 Ctrl+V 进行复制和粘贴，欲了解更多信息，请查看相关功能区菜单项的复制粘贴介绍。


读取设置：功能区菜单

功能区菜单可在表视图样式网格上方找到。其内容和活动图标可能会随网格中单元格、行或列的选择而变化。菜单可分成几组。

  • 表视图：使用添加设置按钮添加读取设置。在弹出的窗口中，可以确定是否要为新设置使用默认值，或者是否要从现有设置中复制值。删除设置按钮用来删除选定的读取设置。更改顺序按钮会打开一个弹出框，在此可重新排列读取设置的顺序。设置将重新连续计数。

  • 开始设置：如果启用了多个设置，读码器全部扫过，当读到代码后停止获取图像。要读取下一个代码，可以确定读码器是否从所选设置或从上次成功解码的设置开始检查。在此可以从下拉列表中选择该开始设置。或者，选择上次成功解码以选择上次成功解码的读取设置作为开始设置。

  • 编辑：使用复制（或键盘上的 Ctrl + C）从当前选定的单元格复制值。粘贴只能用于同一行中或任何文本编辑器中。重置值用于重置所选单元格的值。

  • 突出显示：此菜单组中的按钮和设置提供选项以突出显示特定的单元格背景。使用非默认值设置，具有非默认值的单元格会突出显示（这在不同设备或读取设置的单个行中可能会不同）。不同于参考设置突出显示单元格，这些单元格与参考读取设置（和设备）同一行中的单元格具有不用的值。选择第三个设置，所有的值和标题都会突出显示，包含文本框中指定的文本。此外，包含的文本本身也使用不同的文本背景突出显示。同样按下 Enter 键也会应用仅显示突出显行按钮的功能。

    启用时，仅显示突出行会折叠所有不包含突出显示子节点的节点。激活时，设置参考读取设置在使用不同于参考突出显示模式时指定用作参考的读取设置（和设备）。当按钮处于活动状态时，当前所选单元格的列（读取设置）变为参考设置。当前的参考设置在设置名称标题行中被标记。

  • 过滤：自动设置读取设置，允许只查看与读取设置相关的设置。设置全局设置只查看在不同读取设置中不能有不同值的设置。设置所有设置以同时查看所有设置。如果条目的值出现在多个读取设置中，它们将显示在不同的列中。

  • 其他：使用展开所有行以展开网格中所有折叠的行。使用折叠所有行以折叠网格中所有展开的行。重置布局将重新计算列宽度以用完所有可用的空间。如果可用空间不够，会使用最小列宽度。


设备日志


什么是设备日志？

此视图显示设备上红色 LED 闪烁时生成的日志。当此日志不再需要时可以刷新或删除。


图像尺寸


图像尺寸（兴趣区）设置有什么用处？

使用此功能可指定读码器用来寻找符号并解码的准确图像区域。这对两个 Data Matrix 码间相距很近，并且需要确保仅读取沿目标瞄准线的代码很有好处。缩小兴趣区不一定会缩短解码时间或提高图像传输率。

如果设备支持多个设置，则可以为每个设置设定不同的兴趣区。


解码器 ROI 的大小对读码器配置代码是否会产生影响？

限制兴趣区过小可能会导致读码器无法读取读码器配置代码。


焦点设置


如何计算到读码器的距离？

按照从镜头盖前部到要解码的图像的距离计算，以毫米为单位。

请注意，焦距是从镜头开始测量而不是从读码器的前盖开始测量。


对我来说最佳聚焦设置是什么？

如果您的应用具有一致的读取范围，请将聚焦范围设为固定设置。这样设置时性能最快。

如果您的应用有多种代码类型和大小，请使用不同读取设置，并将聚焦范围设置为更大的景深。

请注意，焦距是从镜头开始测量而不是从读码器的前盖开始测量。


如果将聚焦步长设置为 1，那么上限和下限是多少？

仅限手动触发模式，如果将聚焦步长设置为 1 或 2，则聚焦范围会在上限和下限两个值之间进行切换。这是通过将一个滑块分为两个可单独更改的滑块来表示的。

对于毫米距离，两个滑块分别是高扫描范围和低扫描范围。对于屈光度，两个滑块分别是高功率范围和低功率范围。

请注意，焦距是从镜头开始测量而不是从读码器的前盖开始测量。


如何使用聚焦范围设置？

可以使用聚焦范围选项手动更改设备的聚焦距离，方式是使用滑块或滑块两端的“+”和“-”按钮，或键入值。可以以毫米的形式提供聚焦范围。

请注意，焦距是从镜头开始测量而不是从读码器的前盖开始测量。


对我来说，什么是最佳焦点设置？

如果应用的读码范围恒定，可以将聚焦范围设为固定设置。这将使性能达到最快。

如果应用的代码类型和大小有变化，可使用不同的读取设置并将焦点范围设置为更宽的景深。


将焦点调幅设为零（固定）会怎么样？

如果焦点调幅等于零，焦点会处于一个位置，就只能采集一个图像。无法搜索最佳的焦点。


如果将焦点调幅设为 1，低-高是指什么？

仅在手动触发模式下，如果将调焦步幅设为 1 或 2，焦点范围会在较低和较高的两个值之间切换。这表示滑块被分成两个，可分别更改。

如果是毫米距离，两个滑块代表扫描范围高和扫描范围低。如果是屈光度，两个滑块为倍率范围高和倍率范围低。


如何使用焦点范围设置？

通过使用滑块、滑块两端的“+”和“-”按钮或键入值，可以使用焦点范围选项手动更改设备的焦点距离。焦点范围的单位可以是毫米。


如何计算距读码器的距离？

根据从镜头盖前方到要解码图像的距离来计算距离（以毫米计）。


数据验证


什么是数据验证？

数据验证是用于确认符号解码数据是否符合特定公司、行业或国际标准的正确格式。


数据验证的结果历史记录在何处显示？

数据验证通过/失败和输出结果显示在结果历史记录中。结果历史记录列表中的结果条目将出现“+”图标，用于打开验证尝试的结果详细信息。能以同样的方式在结果历史记录中查看过去的验证结果。


验证错误代码表示什么？

数据验证失败的结果如下：

  • 1：条码符号标识符无效。条码符号标识符是 3 个字符串，不仅识别用于数据编码的条码符号类型，还描述了如何处理数据。此字符串可选作输入传递给工具，除此之外，还可作为单独实体或把它作为前缀加到数据流的解码数据。

    示例：对于 UCC/EAN-128 符号，该条码符号标识符为 ]C1。在某些应用中，这将是唯一准确且自动区分内部或行业 Code 128 和 UCC/EAN-128（即编码 EAN.UCC 应用标识符）符号的方法。没有条码符号标识符，就不知道如何处理符号中的数据。

  • 2：样式不匹配。

  • 3：数据限定符（AI、DI 或 TEI）无效。

  • 4：应用标识符 (AI) 无效。

  • 5：数据标识符 (DI) 无效。

  • 6：文本元素标识符 (TEI) 无效。

  • 7：数据无效：数据是否与数据限定符的类型、长度或值不一致。

  • 8：字符分隔符无效。

  • 9：不兼容 ISO/IEC 15434。

  • 10：不支持的格式（例如在 DoD UID 应用中，格式并非 05、06 或 DD）。

  • 11：格式代码无效：格式代码非 00-99 和 DD。

  • 12：如果选中 ISO/IEC 15434 验证选项，但解码流并非来自 2D 符号，则不支持 ISO/IEC 15434。只有当条码符号标识符作为输入传递给工具时，才可以报告此次失败。

  • 13：应用字段无效：应用中不支持的字段。

  • 14：应用字段不受支持：应用中支持，但工具不支持的字段。

  • 15：应用数据无效：数据是否不能满足特定应用的要求。

    示例：DoD UID 应用有以下要求: 字符的企业 ID 字符串不超过 13 个字符，不包括数据限定符。字符的原始部分、批次字符串（包括允许的特殊字符）不超过 32 个字符，不包括数据限定符。字符的序列号字符串（包括允许的特殊字符）不超过 30 个字符，不包括数据限定符。

  • 16：同一数据流中存在多种格式（例如在 DoD UID 应用中，数据流中不能出现一种以上的格式）。

  • 17：字段重复：同一符号中多次出现相同的数据限定符。某些应用（如 DoD UID 应用）不允许同一符号中重复字段。

  • 18：UID 无效：并非所有构造有效 Construct #1 或 Construct #2 UID 的字段都要出现。

  • 19：Construct #1 UID 无效：并非所有构造有效 Construct #1 UID 的字段都要出现。

  • 20：Construct #2 UID 无效：并非所有构造有效 Construct #2 UID 的字段都要出现。

  • 21：检查 ISO 15434 语法或 DoD UID 符合性时丢失格式尾部。

  • 22：检查 ISO 15434 语法或 DoD UID 符合性时丢失消息尾部。


对于验证失败的代码，如何更改读码器的输出音调和 LED 颜色？

选择系统设置任务面板。在验证失败操作部分，可以选择音调类型、强度和 LED 颜色。


什么是 DoD UID 验证？

DoD UID 验证是用于评估用 Data Matrix 解码的数据是否根据美国国防部军用标准 130 准则正确解码。美国国防部现在要求所有接收或维持的存货商品（价值超过 5,000 美元或具有独特的序列化）都采用唯一的序列号 (UII) 和特定语法格式标记。DoD UID 验证工具是用于确定代码中的数据格式是否符合国防部构造类型 1 或 2 。DoD UID 验证功能也自动确定数据字符串是否符合 ISO 15434 和 ISO 15418。连接的 UII 输出（或只是 UII 的数据元素，无 ISO 15434 句法和 ISO 15418 数据限定符）显示在结果任务面板中验证结果字段的第一个结果字段中。

构造 1 数据元素包括：制造商的企业标识符 EID（CAGE、DUNS、EAN.UCC），公司标识符加上 EID 标识符内的零件序列号。根据公司是否使用 DI、AI 或 TEI 格式，用指定数据标识符来表示企业标识符和序列号。

构造 2 数据元素包括：制造商企业标识符 (EID)、零件制造商的部件号 (PN) 和零件批号 (BN) 标识符以及制造商指定零件编号内唯一的零件序列号。根据公司是否使用 DI、AI 或 TEI 格式，用指定数据标识符来表示企业标识符、部件号/批号和序列号。

注：该选项并非适用于所有的读码器。


DoD UID 验证应使用何种代码类型？

美国国防部现已将 Data Matrix 代码指定为 UID 标记的标准。


什么是预期的 EID？

预期的 EID 是指 UII 数据字符串中的制造商企业标识符。制造商的企业标识符 (EID) 表示制造商的 CAGE、DUNS、EAN.UCC 代码或其他标识符。预期的 EID 是 DoD 指定值。


什么是预期的 PN？

预期的 PN 是指 UII 数据字符串中的制造商部件号。预期的 PN 是 DoD 指定值。


什么是预期的 BN？

预期的 BN 是指 UII 数据字符串中的制造商批号。预期的 BN 是 DoD 指定值。


什么是 ISO 验证？

ISO 验证功能是用于确定数据字符串是否根据 ISO 15434 语法或 ISO 15434 以及 ISO 15418 正确解码。

ISO 15434 确定数据字符串是否用正确的语法来解码，其包括对字符串中的“不可打印”ASCII 字符的赋值，例如信息标题、记录分隔符、格式代码（用于 AI、DI 或 TEI）、组分隔符和传输字符的结尾。

ISO 15418 确定每个数据元素的数据字符串是否使用正确的数据标识符来解码。视制造商是否使用 AI、DI 或 TEI 格式而定，每个数据元素（制造商的 EIN 码、部件号和序列号）前都有特定的代码或“数据标识符”。

注：该选项并非适用于所有的读码器。

注：此选项还允许文本元素标识符按 ATA CSDD 规范进行定义。


什么是 GS1 验证？

GS1 验证可对照 GS1 规范检验符号的句法和语意。读码器可按照可配置标识符字符串检验解码数据。支持所有的应用程序标识符。

默认情况下，读码器对照欧洲制药工业协会联合会 (EFPIA) 的格式字符串检验输入的符号，例如：

<AI(01)><AI(10)><AI(17)><AI(21)>

使用 GS1 验证，当符号中的数据（包括回车符和换行符）未通过验证验证时，可配置读码器传输的内容。详细结果面板将显示每个符号的通过或失败情况，并列出符号中每个应用标识符连同随附的数据元素。


什么是匹配字符串验证？

匹配字符串验证可指定确切的字符串以匹配由符号解码的字符串。只有符号中包含匹配特定字符串的字符串，才能生成通过结果。


如何使用变化值验证字符串？

启用递增/递减数字要素控制项，指明要验证的字符串部分为每次连续读码增加或减少的数值。


递增/递减数字要素有什么用处？

在解码数据序列化应用或某些线性情况下出现变化时，使用此功能执行匹配字符串验证。例如，使用条形码跟踪页码的杂志或书本装订应用，可从递增/递减数字要素中获益，确保无重页或跳页。


如何配置递增/递减数字要素设置？

如果正在验证的字符串包含一系列每次连续读码增加或减少的数字 (0-9)，可以使用此功能。要使用此功能，在开始位置字段指定增加或减少数字的起始位置（0 为第一个字符的位置），并在长度字段中指定将发生变化的字符数量。如果在长度中选择自动，读码器将从起始位置的所有连续数字视作增加或减少数值。使用步长指定读码之间的数值变化量。如果数量减少，选择一个负值。

例如，如果起始字符串为 ABC_123XXPY，随着每一次连续读取，“123”都增加一，则会指定开始位置为 4，长度为 3，步长为 1。（如果确定位置 7 上绝不可能是数字，也可以将长度指定为自动。）请注意，自动设置在达到最大编号时不会增加位数，但会用任何固定的位数设置来重置编号（例如，两位数在达到 99 时，不会变到 100，而是重置为 00）。

在默认情况下，如果字符串无效或无法读取，则期望的数值不会更改。当未读码或代码无效，或同时出现这两种情况时，可以使用未读码更新和验证失败更新复选框来指定要更改的期望值。


模式匹配验证有什么用处？

模式匹配验证允许用户输入指定字符串以确定他们是否出现在数据字符串中。例如，用户可以输入以 DI 格式使用的模式 17V 以识别制造商的企业标识符。如果代码中出现字符 17V，读码器则发送该代码通过验证的信号。如果不出现该字符，读码器将发送验证失败的信号。

必须使用正则表达式作为样式验证的样式。


验证失败操作有什么用处？

验证失败操作用于确定在验证失败之后读码器输出的内容。用户可以选择不同的选项：

  1. 传输“验证失败”- 读码器在代码验证失败之后将输出字符串“验证失败”
  2. 传输“验证失败”+ 解码字符串 - 读码器在完成解码字符串之后将输出字符串“验证失败”
  3. 传输带注解的解码字符串 - 读码器将输出解码字符串连同错误类型信息和字符串中的错误位置
  4. 不传输 - 读码器将不输出任何信息。
  5. 传输“验证失败” + 引用的解码字符串 — 读码器将输出字符串“验证失败”，随后引用解码字符串的一部分。


验证失败操作添加 CR/LF 复选框有何用处？

CR/LF 复选框用于在验证失败输出之后提供回车/换行。


如何搜索多个匹配字符串？

使用样式匹配验证并输入 Perl 格式化匹配字符串。例如，要匹配字符串 123、456 或 789，键入以下内容：

^(123¦456¦789)$


启用数据验证时会怎样？

数据验证状态显示在结果历史记录面板结果状态的结果列表条目中。成功验证的状态为“有效”，失败验证为“无效”。要查看更多验证结果的详细信息，可以展开结果。


什么是失败验证的数据格式？

如果数据验证失败，“基本格式化”数据格式不应用到结果中。相反，执行“验证失败操作”。这不同于“脚本格式化”数据格式。如果启用了“脚本格式化”，则不执行“验证失败操作”，而是执行脚本格式化功能。例如，它允许通过脚本细化“数据验证”状态。


备份设置


什么是自动读码器配置备份？

自动备份用于通过以太网连接的设备。启用时，每次配置保存到闪存时，此功能都会将设备配置备份到外部存储器（FTP 服务器）。Cognex Explorer 服务可以接收备份数据。可以通过设置工具、DMCC 命令或 Cognex Explorer 手动进行恢复。

以所需的 IP 地址和端口号配置读码器，以指定配置的保存位置。还可以设置用户名和密码组合。


打印设备备份代码


打印设备备份代码选项用来做什么？

使用此选项打印读码器备份代码（硬重置并重启代码），以便通过读码器读数来替代设备。这些代码也包含网络设置和串行设置。

在 备注 部分，可以填写也会显示在打印页上的重要事项。如果需要打印单独的重设代码页，则要勾选 “在各自页面中打印重设代码” 复选框。


打印配置代码


打印配置代码选项用来做什么？

使用此选项可打印读码器配置代码（硬重置并重启代码），以此设备或需要配置的设备来读取。

在 备注 部分，可以填写也会显示在打印页上的重要事项。如果需要打印单独的重设代码页，则要勾选 “在各自页面中打印重设代码” 复选框。


数据记录


什么是数据记录？

数据记录允许将成功读取的图像自动保存到指定的文件位置。此外，如果对读码器扫描的代码类型已启用数据验证，则还可以为验证的符号保存数据验证报告。对于数据记录，确保保持连接至设置工具。


何时在报告中禁用图形覆盖？

如果不希望在 PDF 文件中要读取代的码周围出现绿方块，检查在报告中禁用图形覆盖。


图像工具视图


什么是图像面板？

在此面板中，可以看到由设备所读取的图像。

使用放大镜图标可自动调整图像以适应图像工具视图窗口的大小，放大和缩小图像或分别以像素到像素模式显示图像。

此外可以启用或禁用焦点反馈在 LiveDisplay 模式下图像上，您可以将图像复制到剪贴板。

使用保存图像选项仅保存当前图像或所有连击图像，记录选项将所有不读取或所有解码图像记录到文件系统。通过选项菜单，单击上次记录选项记录和报告设置...以打开设置工具选项窗口，这也适用于设置工具的主页屏幕。

注：从图像面板保存上次拍摄的图像（通过拖放）时，显示的图像设置没有任何影响。上次的图像总是以全尺寸（设备的分辨率最大值）保存。


将图像放在何处才能让读码器读到？

确保符号位于读码器图像区域的中心，红色的瞄准激光点位于符号中心。


我的读码器读码时遇到问题，该怎么办？

  • 确保按住触发按钮。如果在读码操作完成之前松开触发按钮，读码器将放弃读码尝试。

  • 查看读码器是否处于代码大小和类型指定的工作距离内，如扫描图文档所列。

  • 确保将代码置于读码器成像区的中间位置并在扣动触发器之前，代码置于绿色瞄准线的中央。

  • 单击照明与图像设置（适用于 DM7500 和 DM8600 的 UltraLight 设置），然后调整照明设置。

  • 单击代码类型设置并确保要使用的代码类型已启用。


如果在读取符号时遇到了问题，该怎么办？

  • 确保读码器处于为符号大小和类型指定的工作距离内，如快速参考指南中所列。

  • 确保将符号置于读码器成像区的中间位置；确保触发设备时，符号置于红色激光瞄准束的中央。

  • 单击代码类型设置并确保使用的代码类型已启用。


如何使用设置工具触发读码器？

单击最上面工具栏中的触发按钮（照明按钮）或按下 Ctrl+T。


如何将采集的图像保存为文件？

单击工具栏中的保存图像按钮。通过打开下拉列表并单击保存所有连击图像可以保存连击模式下所有的图像。

也可以将图像拖放至 PC。单击图像查看器中的图像，将它拖至设置工具之外并松开。

请注意，如果想用拖放方式保存图像且它并非最后一个图像（正从读取结果历史记录中保存），图像将以显示的图像设置保存。在默认情况下，质量会降低。在显示的图像设置下方，将图像大小更改为全尺寸和位图格式。


缓冲和传输


什么是缓冲的图像设置？

在缓冲的图像设置下方，可以更改通过 FTP 传输的图像大小、格式和质量。

  • 大小：缓冲图像的默认图像大小是全尺寸图像。选择不同的图像尺寸可使读码器对每个图像进行子采样，这可极大提高图像传输速度，但图像的精细度会有所降低。

  • 格式：在默认情况下，读码器以 .bmp 格式储存采集的每个图像。

  • 质量：仅在使用 .jpeg 图像格式时才可用。该滑块可调节内部参数，使读码器在采集的图像上执行流畅的操作，可降低或提高传输速度。


什么是叠加图形选项？

核取此选项时，保存（通过 FTP 或记录）的图像将包含叠加图形，与图像文件共同作为 SVG 文件。


为什么看不到解码的图像？

缓冲和传输功能不执行任何解码。在缓冲图像设置中启用叠加图形，图像将以叠加图形保存（SVG 文件），播放图像时可显示。这些图形将在其他解码器信息中显示解码数据。


缓冲和传输可用来做什么？

缓冲和传输可控制读码器上记录和保存哪些图像，查看读码器上保存的图像，将那些图像传送到 PC。

  • 图像缓冲选项卡可控制读码器上保存哪些图像。

  • 图像 PC 传输选项卡可控制如何将图像从读码器传送到 PC。

  • 图像 FTP 传输选项卡可设置从读码器到 PC 的自动图像传送。

  • 结果 FTP 传输选项卡为读码器配置 IP 地址和端口号，需要时向 FTP 服务器发送解码的结果。


可以向 FTP 服务器发送解码结果吗？

使用 图像 FTP 传输选项卡为读码器配置必要的 IP 地址和端口号，以向 FTP 服务器发送解码结果。该选项卡还包含用户名和密码组合设置，连同要存储结果的文件名称。


如何将 FTP 数据储存到非根目录的目录？

文件名字段中不仅可以输入文件名，还可以输入路径名称。正斜杠用作分隔符。例如，/images/image。


为什么在 FTP 目录中看不到图像和结果？

确保拥有创建文件的必要权限。如果核取了添加，请确保 FTP 用户拥有添加权限（与写入权限不同）。FTP 用户也必须仔细检查正确 FTP 服务器的 IP 地址。


缓冲区列表结果用于什么？

缓冲区列表结果允许选择读码器内部缓冲的图像类型、是否包含解码信息（已读码）、无解码信息（未读码）、两者都（全部）或验证失败、哪些情况下只有成功解码而验证失败的图像可保存。


什么是缓冲图像的结果？

可以选择缓冲图像的结果。相同结果指，对于成功读取，读码器仅储存找到了代码的图像。


图像缓冲区的最大尺寸是多少？

图像缓冲区最大尺寸是指读码器最多可以缓冲多少个图像。这由读码器的内存决定，但设置数量应低于最大数量，防止超过 FTP 服务器或 PC 中所需保存的图像。


什么是设置工具 / DMCC 设置的可用性？

设置工具 / DMCC 是指未被采集系统或图像录制所用的图像数量。这是可以将一个结果传输给设置工具或 SDK 的最大结果图像数。

注：这是无法更改的信息值。


如何设置有效读取图像模式？

除非设置限定的速率，否则“成功读取图像”可存储所有缓冲的成功读取图像。

通过选择速率受限可以限制有效读取图像缓冲的数量。设置读取图像速率（缓冲图像的数量和此计数的频率）和多次触发速率，这是每个设置时间的峰值速率。


选取允许缓冲区覆盖选项会怎么样？

允许缓冲区覆盖选项可控制是将图像存储到缓冲区覆盖旧图像，还是在缓冲区已满时停止缓冲。


如何确保图像在传输后删除？

核取传输后删除复选框，可以控制是否删除传输后的图像。这适用于任何传输模式，包括图像 FTP 传输和从读码器传输到 PC。


为什么不能启用立即传输按钮？

如果读码器中有缓冲图像，就必须先选择要记录图像的文件夹。在开始传输之前，还必须停止记录。

请注意，超出与设备（在手持设备的情况下）配对的基站范围时，立即传输不工作，这是因为超出范围时缓冲区被清除且禁用。


清除传输文件夹按钮也会清除幻灯片吗？

清除传输文件夹按钮会删除文件夹中所有的图像。如果图像幻灯片中当前显示的图像相同，图像幻灯片也会被清除。


如果所选文件夹中已有文件，会被覆盖吗？

如果匹配 [索引] 格式的所选文件夹已存在文件，起始索引将自动增加到无现有匹配为止，然后才开始传输。图像文件不会被覆盖。


可以逐个查看图像吗？

可以逐一查看图像，但必须选择图像所在的整个文件夹。选定文件夹中的图像一旦显示，就可以使用前进和后退按钮单击这些图像。


如果离开面板，就得重新开始查看图像吗？

不用，离开缓冲和传输面板就像单击暂停按钮一样暂停播放。


如何向 FTP 服务器传送图像？

使用 FTP 选项卡配置必要的设置，向 FTP 服务器传输图像。该选项卡包含服务器 IP 地址和端口号的设置以及用户名和密码组合。请注意，使用 FTP 发送图像并不能保证一定会发送，只有当读码器以更高频率运行且无法安排时间传送图像时才会发送。此外请注意，通过无线链路传输可能比常规网络通信慢得多。在这种情况下，建议使用缩减像素采样/压缩图像。

文件名选项可以指定这些图像要存储的文件。文件名字段可以指定与 FTP 服务器根目录相关的路径（例如 /failed_images/image）。跟在文件名后面显示在标签中的文件扩展名（.jpg 或 .BMP）与缓冲的图像设置面板上的图像格式设置相匹配。请注意，读码器不创建目录；目录必须已建好并能存取。

最大添加值控制项显示文件名中使用的增量限值。值为 0 表示没有增量要添加，该文件可以被覆盖。

脚本生成的文件名称允许在脚本面板的 FTP 存储选项卡上编写生成文件名的脚本。

服务器生成的文件名选项以空路径开头，这表示 FTP 服务器的根目录。


运行时图像 FTP 传输不工作。该怎么办？

确保满足以下条件：

  • 服务器地址、用户名和密码设置正确。

  • 将传输模式设置为“FTP - 运行时”。

  • 将缓冲选项卡中的“缓冲结果”设置为除无以外的任何值（按需要）。

  • FTP 服务器支持图像传输。


什么是脚本生成的文件名？

可以在脚本面板的 FTP 存储选项卡上编写生成 FTP 传输文件名的脚本。


什么是服务器生成的文件名？

一些 FTP 服务器支持此功能，在将传入的文件保存到磁盘之前为其唯一命名。


如果服务器生成的文件名 FTP 传输程序不工作，应该怎么办？

验证 FTP 服务器是否可以处理 "STOU - Store Unique” 命令。此命令的作用为 STOR，除在当前具有唯一名称的目录中创建目标文件以外。


有哪些不同的传输模式？

单击设置工具中的立即传输或发送适当的 DMCC 时，按要求传输模式传送图像。如果选择 FTP - 运行时 传输模式，只要连接处于活动状态，就可以将图像自动传输至 FTP 服务器。

请注意，超出与设备（在手持设备的情况下）配对的基站范围时，立即传输不工作，这是因为超出范围时缓冲区被清除且禁用。


为什么整个面板在传输文件时都禁用？

禁用面板以实现图像 FTP 传输的最大稳定性。图像 FTP 传输视连接至 FTP 服务器的速度以及传输图像的大小和数量，可能需要几分钟。


选项


可以在选项页面设置什么？

使用 DataMan 设置工具的选项页，用户可以自定义应用程序中的设置。


在语言设置选项中可以设置什么？

可以选择设置工具使用的语言。默认为英语。

注：重启应用程序后设置才能生效。


可以在代码显示字段的代码页中设置什么？

可以根据将要解码的读取字符串设置方法。


可以在配色方案字段中设置什么？

在此字段中选择 DataMan 设置工具窗口的代码方案。


在重置设置框中可以设置什么？

在此框中，从下拉菜单内选择要重置为默认值的类别（例如通讯或验证）。


什么是备份位置设置？

在此可以设置由备份功能使用的文件夹以保存备份文件。


数据记录选项卡中可使用哪些设置？

在此选项卡中，可以设置结果代码、解码的图像、不读取图像和报告所要保存的文件夹，以及记录数据时更改文件名和扩展名的选项。


如何能生成数据验证报告？

在结果历史记录面板中的记录下方选择生成数据验证报告。


可以在图像缓冲和传输中设置什么？

可以设置传输的图片在哪个文件夹中存储。


在蜂鸣器设置选项中可以设置什么？

如果设置工具从 DataMan 读码器接收到较好的读取结果时，打开电脑的蜂鸣器。如果 DataMan 读码器内部没有蜂鸣器时此功能很有用。可以在接收较好读数时将蜂鸣器频率设置为 1000 Hz-10000Hz 之间，持续时间设置为 10ms-1000ms 之间。


如何能激活报告功能？

一旦填完报告字段，就需要打开数据验证以生成报告。


结果代码、解码的图像或不读取图像均未出现在相应的目录中，这是什么问题？

需要在相应的“记录”下拉列表框中启用。


表视图


为什么有些值以突出显示？

突出显示的值最初都是非默认值。可以在功能区菜单的突出显示部分更改突出显示规则，参见问题表视图：功能区菜单获取更多信息。


为什么有些值以粗体显示？

以粗体显示的值是可扩展和显示的子值。


如何知道可能的值是什么？

如有可能，将鼠标移至某一值上，就会显示一个悬浮文本最小值、最大值和默认值。


表视图：一般布局与结构

表视图是使用网格样式的查看工具。

标题行显示设备名称。下面的第二标题行显示设备的可用设置。通过点击它旁边的图标可折叠或打开下面的行标题（以粗体显示）。断开设备连接时，其标题行会出现重新连接图标。

与读取设置不相关的设置只显示在第一列中（主设置）。


表视图：控件（鼠标和键盘）

选择：

  • 鼠标：点击网格中的单元格并进行选择，会突出显示单元格的行标题以及设备和设置所属的列标题。菜单按钮和功能区菜单项可以根据选择进行更改。如果所选的单元格位于行标题行中，属于标题的当前列中所有的单元格都会被选择。

  • 键盘：光标移动键可将选择导航到相应的单元格。突出显示和选择操作与使用鼠标相同。

添加/更改值：

  • 鼠标：对于采用嵌入式编辑器的单元格，点击编辑器控件（组合框、复选框、数字选择）允许输入值。对于采用自定义编辑器的单元格（“...”图标），弹出式编辑器将打开，允许输入值。

  • 键盘：对于采用嵌入式编辑器的单元格，按下 Enter 或 F2 启动编辑模式，按下 Esc 键取消编辑，第二次按下 Enter 键确认编辑。不用进入编辑模式，即可以在选定的文本中输入值，在此情况下第一次击键将会覆盖当前值。

    对于数值单元格，除了嵌入式文本编辑器单元格外，向上和向下箭头可增加和减小值。

    对于下拉式单元格，按下 “输入” 键启动编辑模式并显示下拉菜单项，而 向上和向下箭头 可移动所选的内容。第二次按下 Enter 键应用选定的值，按下 Esc 键取消编辑。

    对于复选框单元格，使用 Space 可切换选中/未选中状态。

复制和粘贴：

使用组合键 Ctrl+C 和 Ctrl+V 进行复制和粘贴，欲了解更多信息，请查看相关功能区菜单项的复制粘贴介绍。


表视图：功能区菜单

功能区菜单可在表视图网格上方找到。其内容和活动图标可能会随网格中单元格、行或列的选择而变化。菜单可分成几组。

  • 表视图：使用添加设置按钮将读取设置添加或复制到所选的设备。删除设置按钮删除选定的读取设置。更改顺序按钮允许更改设备之间的读取设置顺序。

  • 编辑：使用复制（或键盘上的 Ctrl + C）从当前选定的单元格复制值。粘贴只能用于同一行中或任何文本编辑器中。重置值用于重置所选单元格的值。

  • 突出显示：此菜单组中的按钮和设置提供选项以突出显示特定的单元格背景。使用非默认值设置，具有非默认值的单元格会突出显示（这在不同设备或读取设置的单个行中可能会不同）。不同于参考设置突出显示值与参考读取设置（和设备）同一行中单元格不同的单元格。选择第三个设置，所有的值和标题都会突出显示，包含文本框中指定的文本。此外，包含的文本本身也使用不同的文本背景突出显示。同样按下 Enter 键也会应用仅显示突出显示的行按钮的功能。

    启用时，仅显示突出显示的行折叠所有不包含突出显示子节点的节点。激活时，设置参考读取设置在使用不同于参考突出显示模式时指定用作参考的读取设置（和设备）。当按钮处于活动状态时，当前所选单元格的列（读取设置）变为参考设置。当前的参考设置在设置名称标题行中标记。

  • 过滤：全局设置，默认设置，只显示在不同读取设置中不能有不同值的设置。设置读取设置只查看与读取设置相关的设置。设置所有设置以同时查看所有设置。如果条目的值出现在多个读取设置中，它们将显示在不同的列中。

  • 其他：使用展开所有行以展开网格中所有折叠的行。使用折叠所有行以折叠网格中所有展开的行。重置布局重新计算列宽度以用完所有可用的空间。如果可用空间不够，会使用最小列宽度。


法律信息


版权

Cognex Corporation 对使用非 Cognex Corporation 提供的设备软件或其可靠性不负任何责任。Cognex Corporation 对于相关描述软件及其任何特殊用途的适销性或适用不作任何明示或暗示的担保。

本文档中的信息如有更改，恕不另行通知，不应被解释为由 Cognex Corporation 作出的承诺。Cognex Corporation 对本文档或相关软件中出现的任何错误概不负责。

版权 © 2019 Cognex Corporation 保留所有权利

未得到 Cognex Corporation 书面许可，任何人不能复制本文档，也不得将其转让给任何其他媒体或翻译为其他语言。

硬件和本文档中所述软件部分可能受一个或多个美国专利的保护，具体内容参见 Cognex 网站 http://www.cognex.com/patents.asp。其他美国和国外专利尚在申请中。


许可软件

SpiderMonkey

本软件遵循 Mozilla Public License, v. 2.0 的条款。可以从 http://mozilla.org/MPL/2.0/ 获得 MPL 的副本。

若要获取 SpiderMonkey 的源代码副本，请发送电子邮件至 <spidermonkey@cognex.com> 与 Cognex 技术支持联系

PCRE 许可证

PCRE 是一种支持其语法和语义学与 Perl 5 语言尽可能相近的正则表达式的功能库。

PCRE 版本 5 的发行受“ BSD”许可证的约束，如下所示。“doc”目录下提供的 PCRE 文档依据软件本身条款的规定发行。

编写者：Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.电话：+44 1223 334714.

版权 (c) 1997-2004 University of Cambridge 保留所有权利。

在满足以下条件的前提下，允许用户将修改后或未经修改的软件以源代码或二进制的格式进行重新发布或使用：

  • 重新发布源代码时必须保留上面的版权声明、此处的条款列表和下面的免责声明。
  • 如果以二进制格式重新发布，必须在该文档和/或随发布提供的其他材料中包含上面的版权声明、此处的条款列表和下面的免责声明。
  • 未经事先书面许可，不得使用“University of Cambridge”及其他责任者的名称宣传或促销在本软件基础上开发的产品。

本软件仅以版权持有人和其他责任人“ 按原样 ”形式提供，不做任何明确或隐含的担保，包括但不限于对适销性和对特定用途的适用性的担保。在任何情况下，版权拥有者或其他责任者对由于使用本软件而造成的任何直接、间接、偶然、特殊、惩罚性或因果性的损害（包括但不限于更换商品或服务、无法使用、丢失数据、损失利润或业务中断）不承担任何责任，无论由于什么原因、根据何种责任理由；无论是否签署了合同、负有严格的责任限制；无论是否由于使用本软件而引起纠纷（因疏忽或其他原因），即使事先已被告知可能会造成这种损害。

结束

JPEG 软件

本软件的某些部分基于独立 JPEG 组的工作。

zlib 压缩库

本软件的某些部分基于 Jean-loup Gailly 和 Mark Adler 的工作。

Parsifal XML 解析器

版权 (c) 2002-2005 Toni Uusitalo 发行到公共域名 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal 对商业和非商业软件的使用和重新发行免费，但需要提供保留完整的作者版权和免责声明。可以自行修改 Parsifal 用于个人使用以及在提供明确记载修改的内容后重新发布。

免责声明

本程序是基于使用目的而加以发布，然而不负任何担保责任；也不对适售性或特定目的适用性所作的默示性担保。使用时请自行承担一切风险。


专利信息

本产品是受下列一个或多个美国专利、美国申请和/或国外专利保护，http://www.cognex.com/patents 将列出任何其后发布的相关专利

5742037、5943441、6215915、6236769、6282328、6381375、6408109、6457032、6690842、6941026、7175090、7181066、7412106、7427028、7549582、7604174、7614563、7617984、US-2005-0087601-A1、US-2006-0131418-A1、US-2006-0131419-A1、US-2006-0133757-A1、US-2007-0090193-A1、US-2007-0091332-A1、US-2007-0152064-A1、US-2007-0170259-A1、US-2008-0004822-A1、US-2008-0011855-A1、US-2008-0142604-A1、US-2008-0143838-A1、US-2008-0158365-A1、US-2009-0090781-A1、US-2009-0108073、US-2009-0121027-A1、US-2009-0166424-A1、US-2009-0294541-A1、WO06065619A1 和 EP1687752