DataMan : Q&A


リーダへの接続


リーダと Setup Tool の接続方法:

DataMan リーダと Setup Tool の接続手順は、各リーダとも共通で次のように行います:

  1. リーダとPCで動作させる Setup Tool に必要なケーブルを接続します。詳しい内容は、『クイックリファレンス』を参照してください。

  2. Setup Tool の[更新]をクリックします。

  3. [接続] をクリックします。


デバイスのアイコン右上にオーバーレイのアイコンが表示される理由:

手動で追加したデバイスには、矢印アイコンが表示されます。


緑色で表示されたデバイス:

新たに検出されたデバイスは数秒間緑色で表示し、ツリービューにデバイスが追加されたことを知らせます。


画像の最適化


コード詳細


アプリケーションのプロパティ


入力/出力


通信


修理とサポート


[修理とサポート] とは:

[修理とサポート] ページは、構成ミスのあるネットワークデバイスのネットワーク設定や、シリアルデバイスのHIDモードをCDCに変更する時に使用します。


[更新]の使用方法:

使用可能なデバイスのリストを更新する時に、[更新]ボタンをクリックしてください。


表示されたデバイス一覧に、ネットワークデバイスを追加する方法:

[ネットワークデバイスの追加]をクリックすると、ネットワークデバイスの追加ができるほか、既に追加されているデバイスのIPアドレスを編集できます。[ネットワークデバイスの追加]ダイアログに、デバイスのIPアドレスを入力します。OKをクリックして変更を保存すると、[接続]ページにそのデバイスが表示されるようになります。


デバイスのプロパティの編集方法:

リストからデバイスを選択して、可能なオプションを確認してください。開いたペインで選択したデバイスに関するネットワーク設定の編集および認証オプションの設定ができます。[適用]をクリックすると、変更が保存されます。


PCネットワーク設定のコピーについて

[ネットワーク] でデバイスを選択すると、右側に [ネットワーク設定] ボックスが現れます。

[PCネットワーク設定のコピー] をクリックするとPCのネットワーク設定がコピーでき、PCのサブネットマスクやデフォルトゲートウェイを探す時間と手間が省けます。コピーしたIPアドレスは、ご使用のPCのものになります。IPアドレスを囲う赤い長方形は、DataManデバイスのIPアドレスに手動でアップデートするよう促すためのものです。


バックアップ


復元


[復元] 機能の使い方:

[復元] 機能では、バックアップした設定ファイルを1つまたは複数のデバイスに復元することができます。この機能は1つ以上のデバイスを選択し、有効な設定ソースを指定している場合にのみ使用できます。

先頭の [設定ソース] でリスト内の最終項目の「工場出荷時のデフォルト値」を設定でき、RTMコントローラが設定をデフォルト値に復元します。

RTMコントローラには復元ソースとして使用する他のオプションを設定することはできませんので、注意が必要です。

ソースと対象デバイスを選択してから、右下の [復元] ボタンをクリックしてください。


ファームウェア更新


[ファームウェア更新] 機能の使い方:

選択したデバイス (複数可) を希望のファームウェアバージョンに更新する機能です。

  1. デバイスの一覧から、アップデートしたいデバイス (複数可) を選択します。

  2. [...] をクリックしてファームウェアのファイルを参照します。デバイスの一覧からデバイスを1つだけ選択した場合、そのデバイスにに該当するファームウェアのフォルダが開きます。同一のファームウェアデバイスIDを持つ複数のデバイスを選択した場合は、該当するフォルダが開きます。デバイスが選択されていない場合、あるいは、異なるファームウェアデバイスIDを持つ複数のデバイスを選択した場合は、ファームウェアのルートフォルダが開きます。

  3. [ファームウェアのアップロード] ボタンをクリックします。選択したファームウェアバージョンとデバイスに互換性がある場合のみ、このボタンは操作可能になります。

  4. バックアップ機能と同様にして Setup Tool で設定ファイルをバックアップしたい場合は、ポップアップ画面の [ファームウェア更新前にデバイスをバックアップ] を有効にします (詳しくは「バックアップのQ&A」を参照)。

  5. [はい] をクリックすると、新しいファームウェアのアップロードを開始します。

注意: 連続してデバイスを更新する場合は、ファームウェアの更新をする前にまず手動でリフレッシュをかけてデバイスを検索してください。


設定を比較


画像ウィンドウ


結果履歴


デバイスログ


画像サイズ


データ妥当性検査


プリント装置 バックアップコード


設定コードを印刷


データログ


画像ツールビュー


オプション


テーブルビュー


法的情報


著作権

Cognex Corporation は、同社が提供していない装置における同社製ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本書で記述されているソフトウェアの内容、商品価値および特定目的に対する責任につき、明示または黙示にかかわらずいかなる保証も行いません。

本書の内容は、予告なしに変更することがあります。 内容の変更について、Cognex Corporation はいかなる責任も負いません。本書あるいは関連ソフトウェアにおける誤りについて、Cognex Corporation はいかなる責任も負いません。

Copyright © 2019 Cognex Corporation All Rights Reserved

本書のいかなる部分も Cognex Corporation の書面による許可なく複製、他のメディアに送信すること、および他の言語に翻訳することを禁じます。

本書で説明しているハードウェアおよびソフトウェアの一部については、Cognex ウェブサイト http://www.cognex.com/patents.asp に示す 1 つまたは複数の米国特許で保護されています。その他の米国および、他国の特許については申請中です。


ライセンスソフトウェア

SpiderMonkey

このソフトウェアには Mozilla Public License, v. 2.0 の条件が適用されます。MPL の入手先： http://mozilla.org/MPL/2.0/

SpiderMonkey のソースコードをご希望のお客様は、Cognex テクニカルサポート (Eメール: <spidermonkey@cognex.com>) までお問い合わせください。

PCRE ライセンス

PCRE は、正規表現をサポートする関数ライブラリで、その構文とセマンティックスは、Perl 5 言語に可能な限り近似しています。

PCRE のリリース 5 は、下記に規定する "BSD" ライセンスの条項に基づいて配布されます。"doc" ディレクトリに入っている PCRE 関連文書も、同ソフトウェアと同じ条項に従って配布されます。

著作者: Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.電話: +44 1223 334714

Copyright (c) 1997-2004 University of Cambridge All rights reserved.

ソースおよびバイナリ形式での再配布および使用は、変更のあるなしにかかわらず、次の条件を満たす場合に限り許可されます。

  • ソースコードの再配布では、上記の著作権告知、この条件リストおよび下記の免責条項を保持する必要があります。
  • バイナリ形式の再配布においては、上記の著作権告知、この条件リストおよび下記の免責条項を配布される文書その他に記載する必要があります。
  • 特定の書面による事前の許可なく、本ソフトウェアから派生する製品の推奨または奨励のため、Cambridge 大学の名前も寄稿者の名前も、使用することを禁じます。

本ソフトウェアはその著作権者および寄稿者によって、「現状有姿」で提供され、商品性および特定目的に対する適合性を含みそれに限定されない、一切の明示的または黙示的保証を行いません。本ソフトウェアの使用によってあらゆるかたちで生じる、直接損害、間接損害、付随的損害、特殊損害、派生的または結果的損害 (代替商品またはサービスの調達、使用機会またはデータの喪失、逸失利益、または事業の中断を含みそれらに限定されない) に対して、著作権者または寄稿者は一切責任を負いません。 それらが契約責任であれ厳格責任であれ、または不法行為責任 (過失責任その他を含む) であれ、いかなる責任理由によっても同様であり、またたとえ、それら損害の可能性について事前に知らされていたとしても同様です。

以上

JPEG ソフトウェア

本ソフトウェアの一部は、Independent JPEG Group の成果に基づいています。

zlib 圧縮ライブラリ

本ソフトウェアの一部は、Jean-loup Gailly および Mark Adler の成果に基づいています。

Parsifal XML パーサー

Copyright (c) 2002-2005 Toni Uusitalo パブリックドメイン 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/ に公開

Parsifal は商業使用も非商業使用も再配布も自由ですが、著作者の著作権および免責条項を無修正で保持することが条件です。また、個人使用のために Parsifal を修正することも、修正した Parsifal を再配布することもできます。 ただしその修正を明確に文書に記していることが条件です。

免責条項

本プログラムは、有用性を期待して配布されますが、特定目的に対する商品性または適合性の黙示的な保証を含む、一切の保証はありません。ご使用は、リスクが自己責任であることに同意されたとみなされます。