DataMan 8000 Series Base Station : Fragen und Antworten


Verbindung zum Lesegerät


Wie wird die Basisstation mit dem Setup Tool verbunden?

Zum Verbinden Ihres DataMan mit dem Setup Tool führen Sie folgende Schritte aus:

  1. Drucken Sie ein Exemplar des Dokumentes Konfigurationscodes für das Lesegerät für die von Ihnen verwendete Basisstation aus. Sie können darauf über das Windows-Menü Start oder das Setup Tool-Menü Hilfe zugreifen.

  2. Schließen Sie die erforderlichen Kabel an, um die Basisstation mit dem PC zu verbinden, auf dem das Setup Tool ausgeführt wird. Ausführliche Informationen finden Sie in der gedruckten Kurzanleitung zum DataMan 8xx0.

  3. Scannen Sie den gewünschten Code für die Kommunikationseinstellungen oder den Verbindungstyp, z. B. USB.

  4. Klicken Sie im Setup Tool auf Aktualisieren.

  5. Wählen Sie den COM-Anschluss bzw. das Netzwerkgerät aus, für den bzw. das eine Verbindung zu Ihrem Lesegerät angezeigt wird.

  6. Klicken Sie auf Verbinden.


Welchen Anschluss wird für USB-Verbindungen verwendet?

Wenn Sie das Lesegerät oder die Basisstation an den USB-Anschluss anschließen, scannen Sie den Konfigurationscode USB-COM/RS-232 im Dokument „Konfigurationscodes für das Lesegerät“. Klicken Sie dann auf Aktualisieren und wählen den Anschluss aus, an dem das Lesegerät erkannt wurde.

Hinweis: Beim Klicken auf Aktualisieren wird eine Abfrage an alle COM-Anschlüsse und das Subnetz des Ethernet-Netzwerks gesendet. Damit die Abfrage beantwortet werden kann, muss der kabellose DataMan 7550 oder 8000 eingeschaltet sein. Drücken Sie auf den Auslöser, um das Lesegerät einzuschalten.


Zum Lesegerät bzw. zur Basisstation kann noch immer keine Verbindung hergestellt werden: Können die Einstellungen zurückgesetzt werden?

Basisstation DataMan 8000:

Um die Basisstation auf die Werkseinstellungen zurückzusetzen, scannen Sie den Befehl Basisstation auf Werkseinstellungen zurücksetzen (Basisstation DM8000). Beachten Sie bitte, dass dabei das kabellose Lesegerät der Basisstation zugewiesen sein muss.

Lesegeräte DataMan 503 und 8000:

Um einen Warmstart vorzunehmen, scannen Sie den Befehl Scanner neu starten auf der Rückseite der Kurzanleitung. Der permanente Speicher des Lesegerätes wird nicht gelöscht, sondern das Lesegerät wird heruntergefahren und erneut gestartet.

Wenn die Aktion fehlschlägt, scannen Sie den Befehl Scanner auf Werkseinstellungen zurücksetzen, um das Lesegerät auf die Werkseinstellungen zurückzusetzen.

Wenn die Aktion bei einem kabelgebundenen Lesegerät fehlschlägt, trennen Sie das Lesegerät von der Stromversorgung (dieses Verfahren kann nicht beim DataMan 9500 angewendet werden). Drücken Sie den Auslöser und schließen Sie das Gerät mit gedrücktem Auslöser wieder an die Stromversorgung an. Halten Sie den Auslöser mindestens 6 Sekunden lang gedrückt, bis Sie einen zweifachen Signalton hören. Die Kontrollleuchten am Lesegerät blinken in verschiedenen Farben.

Wenn die Aktion bei einem kabellosen DataMan 8000-Lesegerät fehlschlägt, nehmen Sie die Batterie aus dem Lesegerät und legen es auf die Basisstation. Drücken Sie den Auslöser und schließen Sie das Gerät mit gedrücktem Auslöser wieder an die Stromversorgung an. Halten Sie den Auslöser mindestens 6 Sekunden lang gedrückt, bis Sie einen zweifachen Signalton hören. Die Kontrollleuchten am Lesegerät blinken in verschiedenen Farben.

Lesegeräte DataMan 50, 60 und 70:

Drucken Sie ein Exemplar des Dokumentes Konfigurationscodes für das von Ihnen verwendete Lesegerät aus. Sie können darauf über das Windows-Menü Start oder das Setup Tool-Menü Hilfe zugreifen.

Scannen Sie den Code Scanner neu starten, um einen Warmstart durchzuführen. Der permanente Speicher des Lesegerätes wird nicht gelöscht, sondern das Lesegerät wird heruntergefahren und erneut gestartet.

Wenn Sie auch jetzt keine Verbindung mit dem Lesegerät herstellen können, scannen Sie den Code Scanner auf Werkseinstellungen zurücksetzen, um das Lesegerät auf die Werkseinstellungen zurückzusetzen.

Falls das Problem dadurch nicht gelöst wird, trennen Sie das Lesegerät von der Stromversorgung (je nach Anschluss Gleichstrom oder USB). Drücken Sie den Auslöser und schließen Sie das Gerät mit gedrücktem Auslöser wieder an die Stromversorgung an. Halten Sie den Auslöser mindestens 6 Sekunden gedrückt, bis Sie einen zweifachen Signalton hören. Die Kontrollleuchten am Lesegerät blinken in verschiedenen Farben.


DataMan-Serien 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 und DataMan 8000-Basisstation: Warum wird bei einem Verbindungsversuch vom Setup Tool ein Kennwort gefordert?

Das Lesegerät und die Basisstation können so konfiguriert werden, dass vor dem Verbinden mit dem Setup Tool ein Kennwort eingegeben werden muss. Das Kennwort wird im Fenster Kommunikationseinstellungen unter Netzwerkeinstellungen über die Registerkarte Authentifizierung aktiviert. Beachten Sie, dass das Kennwort auch für serielle Verbindungen verwendet wird.


DataMan 60, 300, 370, 470, 503, Serie 8000 und DataMan 8000-Basisstation: Kann das Lesegerät per Ethernet direkt an einen PC angeschlossen werden?

Das Lesegerät bzw. die Basisstation kann über einen Ethernet-Anschluss (RJ-45) am PC direkt angeschlossen werden. Wenn Ihr Gerät für DHCP konfiguriert ist, wird es nach ca. 20 Sekunden in der Liste Netzwerkgeräte angezeigt. Berücksichtigen Sie jedoch, dass der PC möglicherweise eine weitere Minute braucht, um die IP-Adresse aufzulösen. Sie können keine Verbindung mit Ihrem Gerät über das Setup Tool herstellen, solange dieser Vorgang nicht beendet ist.

Wenn für Ihr Gerät eine statische IP-Adresse festgelegt wurde, wird es nur dann angezeigt, wenn das Gerät und der PC dasselbe Subnetz verwenden.


DataMan-Serien 60, 300, 370, 470, 503, 8000, MX-1000 und DataMan 8000-Basisstation: Können die einzelnen Elemente in der Liste Netzwerkgeräte einem bestimmten Lesegerät zugeordnet werden?

Standardmäßig werden alle DataMan Geräte in der Liste Netzwerkgeräte mit dem Präfix „DM“ und den sechs letzten Ziffern der gerätespezifischen MAC-Adresse angezeigt, die auf das Gerät aufgedruckt ist.


DataMan-Serien 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 und DataMan 8000-Basisstation: Wie verfährt man, wenn ein Lesegerät bzw. eine Basisstation nicht in der Liste der Netzwerkgeräte angezeigt wird?

Wenn das gewünschte Lesegerät oder die gewünschte Basisstation nicht aufgeführt sind, können sie durch Aus- und erneutes Einschalten hinzugefügt werden. Es kann bis zu 60 Sekunden dauern, bis das Gerät nach dem Einschalten angezeigt werden.

Wenn sich das Problem durch Aus- und erneutes Einschalten nicht beheben lässt, kann vom Setup Tool möglicherweise wegen der Netzwerkkonfiguration keine Verbindung mit Ihrem Gerät hergestellt werden und es wird nicht in der Liste der Netzwerkgeräte angezeigt.

Überprüfen Sie die Ethernet-Verbindung mit dem Lesegerät bzw. der Basisstation und klicken im Setup Tool auf Aktualisieren.

Verwenden Sie die Option Gerät hinzufügen, wenn Sie die IP-Adresse des Lesegerätes bzw. der Basisstation kennen.

Mit diesem Verfahren wird das DataMan-Lesegerät bzw. die DataMan-Basisstation danach in der Liste der Netzwerkgeräte angezeigt und Sie können über den Ethernet-Anschluss eine Verbindung mit dem Setup Tool herstellen.


Kabelloses DataMan-Lesegerät 8000: Wie kann ein kabelloses Lesegerät einer anderen Basisstation zugewiesen werden?

Wenn der Basisstation, der Sie das kabellose Lesegerät zuweisen möchten, schon ein anderes kabelloses Lesegerät zugewiesen ist, müssen Sie diese Verbindung trennen. Scannen Sie dazu den Code Zuweisung Lesegerät/Basisstation aufheben. Um das kabellose Lesegerät einer neuen Basisstation zuzuweisen, legen Sie das neue Lesegerät einfach auf die Basisstation. Die Geräte erkennen sich automatisch.


DataMan 8000-Basisstation: Wie kann die USB-Verbindung zur Basisstation zurückgesetzt werden?

Wenn Schwierigkeiten beim Herstellen oder Aufrechterhalten der USB-Verbindung zwischen Basisstation und PC bestehen, führen Sie zum Zurücksetzen der USB-Verbindung die folgenden Schritte aus:

  1. Ziehen Sie USB-Kabel und Netzkabel von der Basisstation ab.

  2. Schließen Sie USB-Kabel und Netzkabel wieder an die Basisstation an.

  3. Legen Sie das Lesegerät auf die Basisstation.

  4. Nehmen Sie das Lesegerät von der Basisstation und scannen den Konfigurationscode USB-COM/RS_232.


Eingänge/Ausgänge


Welche Systemeinstellungen kann ich ändern?

Sie können den Signalton deaktivieren bzw. aktivieren. Beachten Sie jedoch, dass die Anzahl Töne oder die LED-Farben nicht geändert werden können.


Wie wird die Basisstation zurückgesetzt?

Scannen Sie den Konfigurationscode (für die DM8000 Basisstation) „Auf Werkseinstellungen zurücksetzen“. Verwenden Sie dazu das kabellose Lesegerät, das Ihrer Basisstation zugewiesen ist.


Wie wird das kabellose Lesegerät anstelle einer Tastatur verwendet?

Um die Basisstation im HID-Modus zu verwenden, scannen Sie den Code USB-Tastatur für die Basisstation aktivieren im Dokument Konfigurationscodes für das Lesegerät (verfügbar über das Windows-Menü Start oder das Setup Tool-Menü Hilfe).


Wozu dient ein geänderter Gerätename?

Sie können einen für die Produktionsumgebung aussagekräftigen Namen für das Gerät eingeben, z. B. den Standort oder die Prüfaufgabe.


Wie wird der Gerätename geändert?

So ändern Sie den Gerätenamen:

  1. Geben Sie unter Gerätename einen neuen Namen für das Gerät ein.

  2. Die folgende Frage wird angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“.

  3. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten Ihr Gerät anschließend neu.

Beim nächsten Start des Setup Tools oder durch Klicken auf Aktualisieren auf der Startseite wird der neue Gerätename angezeigt.


Was ist eine Einschaltmeldung?

Ist Ausgabe einer Diagnosezeichenkette beim Einschalten aktiviert, überträgt das Lesegerät oder die Basisstation eine Diagnosezeichenkette, sobald das Gerät eingeschaltet wird.

Diese Funktion ist bei USB-Verbindungen nicht verfügbar. Bei seriellen Verbindungen wird die Baudrate beim Senden der Meldung automatisch auf 38.400 bps festgelegt, unabhängig von den Einstellungen im Setup Tool.


Kommunikation


Wie kann ich die Einstellungen der seriellen Schnittstelle der Basisstation ändern?

Beim Scannen des Konfigurationscodes RS-232 seriell im Dokument „Konfigurationscodes für das Lesegerät“ wird die Basisstation automatisch mit der Baudrate konfiguriert, die auch im Setup Tool eingestellt ist. Dies gilt auch für die übrigen Einstellungen der seriellen Schnittstelle.

Wenn Sie die Basisstation an ein Gerät mit spezifischer Baudrate oder bestimmten anderen Einstellungen für die serielle Schnittstelle verbinden möchten, scannen Sie die entsprechenden Codes im Dokument Konfigurationscodes für das Lesegerät (verfügbar über das Windows-Menü Start oder das Setup Tool-Menü Hilfe. Beachten Sie, dass Sie die Codes RS-232 seriell bzw. USB seriell erneut scannen müssen, um eine Verbindung mit dem Setup Tool herzustellen.


Wie wirken sich Änderungen des USB-Modus aus?

Besteht eine serielle USB-Verbindung mit dem Lesegerät, können Sie die USB-Geschwindigkeit auf 1.1 oder 2.0 festlegen.

Bei Verbindung mit einem kabellosen Lesegerät wirken sich Änderungen des USB-Modus nicht auf die Basisstation aus. Die geänderten Einstellungen werden im Speicher des Lesegerätes abgelegt, bei Änderung des kabellosen Einschubmoduls in ein serielles Einschubmodul stellt das Lesegerät die Verbindung mit dem (bereits vorher) ausgewählten USB-Modus her.


Wann wird der Kompatibilitätsmodus für USB-Treiber verwendet?

Standardmäßig wird von der Basisstation ein USB-Treiber verwendet, der die Wiederherstellung nach einer elektrostatischen Entladung (Electrostatic Discharge, ESD) unterstützt. Verwenden Sie Kompatibilitätsmodus für USB-Treiber, wenn die vollständige Konformität mit der USB-Spezifikation erforderlich ist oder wenn Sie eine DataMan Basisstation zusammen mit Cognex SensorView verwenden.

Wenn Sie Kompatibilitätsmodus für USB-Treiber ändern, wird die folgende Frage angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten das Lesegerät anschließend neu.


Welche Optionen werden über das Drop-down-Menü „Verwendeter Kommunikationskanal“ festgelegt?

Sie können festlegen, welche USB-Kommunikationsmethode verwendet werden soll. Je nach verwendetem Gerät stehen die folgenden Optionen zur Auswahl:

  • Nur USB-COM: Bei dieser Option wird die Verbindung mit dem Gerät über eine serielle Schnittstelle hergestellt.

  • Nur USB-HID: Bei Auswahl dieser Option verhält sich das Gerät wie eine USB-Tastatur.

  • USB-COM + USB-HID: Diese Option kombiniert die beiden vorhergehenden Modi.

HINWEIS: Bei Auswahl von Nur USB-COM werden manche Geräte möglicherweise auch unter den HID-Geräten aufgeführt, auch wenn sie nicht über HID-Funktionen verfügen.


Wie wird bei bestehender USB-Verbindung die Basisstation anstelle einer Tastatur verwendet?

Um für Ihr kabelloses Lesegerät eine USB-Tastatur zu emulieren, scannen Sie den Code USB-Tastatur für die Basisstation aktivieren im Dokument Konfigurationscodes für das Lesegerät (verfügbar über das Windows-Menü Start oder im Setup Tool-Menü Hilfe) und trennen Sie die Verbindung zum Setup Tool.


Wie wird die Basisstation mithilfe des PS/2-Adapters anstelle einer Tastatur verwendet

Zum Emulieren einer PS/2-Tastatur müssen Sie ein serielles Kabel, das externe Netzteil und ein Tastaturweichenkabel verwenden (siehe Kurzanleitung). Scannen Sie den Code PS/2-Tastaturemulation aktivieren im Dokument Konfigurationscodes für das Lesegerät (verfügbar über das Windows-Menü Start oder im Setup Tool-Menü Hilfe). Für die Installation des PS/2-Adapters müssen Sie den PC vollständig ausschalten. Schließen Sie die Basisstation mit den oben aufgeführten Kabeln an. Schalten Sie anschließend den Computer ein. Ihr kabelloses Lesegerät emuliert jetzt eine PS/2-Tastatur.


Welche Auswirkung hat es, wenn die Basisstation nach der entsprechenden Aufforderung nicht neu gestartet wird?

Die geänderten Einstellungen werden nicht angewendet. Klicken Sie auf System und wählen Einstellungen speichern aus, wenn Sie sich anders entscheiden. Starten Sie anschließend die Basisstation neu.


Wozu dient die Option „RS-232-Routing“?

Wenn Sie die Verbindung zur Basisstation über RS-232 herstellen, können Sie wählen, ob die Daten an die Basisstation weitergeleitet werden sollen oder ob Sie direkt mit dem der Basisstation zugewiesenen Lesegerät kommunizieren möchten.

Ist der Basisstation kein Lesegerät zugewiesen, wird für die RS-232-Schnittstelle unabhängig von der ausgewählten Routing-Option die Basisstation konfiguriert. Wird für das zugewiesene Lesegerät die Zuweisung vorgenommen oder aufgehoben, wird der Betriebsmodus der RS-232-Schittstelle nach dem Aus- und Wiedereinschalten der Basisstation automatisch geändert.


Wie werden die Netzwerkeinstellungen für die Basisstation konfiguriert?

Aktivieren Sie die Option DHCP-Server verwenden, wenn dem Lesegerät eine IP-Adresse von einem DHCP-Server (sofern verfügbar) zugewiesen werden soll, oder geben Sie die Netzwerkeinstellungen manuell ein. Den richtigen Wert können Sie bei Ihrem Netzwerkadministrator erfragen.

Wenn Sie die Einstellungen ändern, wird die folgende Frage angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten das Lesegerät anschließend neu.


Welche Subnetze für IP-Adressen kann ich verwenden?

Wenn Sie zu einer statischen IP-Adresse wechseln, können Sie mit Ausnahme der Subnetze 172.16.2.x und 172.16.0.x alle Subnetze für IP-Adressen verwenden. Verwenden Sie die angegebenen Subnetze weder für die Basisstation noch für die IP-Adresse des kabellosen Lesegerätes.


Wie wird einer Basisstation ein neues Lesegerät zugewiesen?

Legen Sie das Lesegerät auf die Basisstation. Die Zuweisung erfolgt automatisch.


Ist die Änderung eines Kennworts sofort wirksam?

Nach Eingabe eines (neuen) Kennworts müssen Sie die Eingabetaste drücken. Wenn Sie die Tabulatortaste drücken oder das Fenster schließen, ohne die Eingabetaste gedrückt zu haben, wird Ihr Kennwort nicht wirksam.


Muss das Kennwort immer zweimal eingegeben werden?

Wenn Sie „Anzeigen“ markieren, müssen Sie das Kennwort nur einmal eingeben. Wenn Sie „Anzeigen“ nicht markiert haben, müssen Sie das Kennwort erneut eingeben. Sind beide Eingaben nicht identisch, gibt das Setup Tool eine Warnmeldung aus.


Welche Auswirkung hat die Deaktivierung von Kabellos?

Wenn das Kontrollkästchen Kabellos aktivieren deaktiviert ist, können Sie nur dann eine Verbindung zu Ihrem Lesegerät herstellen, wenn es auf der Basisstation liegt. Lesungen können Sie jedoch weiterhin mit Ihrem Lesegerät vornehmen. Die erfassten Bilder können Sie später übertragen, wenn das Gerät wieder auf der Basisstation liegt und Sie es angeschlossen haben.


Wie wirkt sich die Deaktivierung von Bluetooth aus?

Wenn das Kontrollkästchen Bluetooth aktivieren deaktiviert ist, können Sie nur dann eine Verbindung mit dem Lesegerät herstellen, wenn es auf der Basisstation liegt. Es können jedoch weiterhin Lesevorgänge mit dem Lesegerät ausgeführt werden. Die erfassten Bilder können Sie später übertragen, wenn das Gerät wieder auf der Basisstation liegt und per Kabel an diese angeschlossen ist.


Wann wird die Option „Zuweisung aufheben“ verwendet?

Wenn Sie Ihrer Basisstation ein anderes Lesegerät zuweisen möchten, klicken Sie auf Zuweisung aufheben. Ist Ihr neues Lesegerät keiner Basisstation zugewiesen, legen Sie es nun einfach auf Ihre Basisstation. Die Zuweisung erfolgt automatisch. Ist Ihr Lesegerät bereits einer anderen Basisstation zugewiesen, scannen Sie den Konfigurationscode für das Lesegerät Zuweisung für Lesegerät aufheben und legen Sie Ihr Lesegerät anschließend auf die Basisstation.


Wozu dient die IP-Adresse unter „Zugewiesenes Lesegerät“?

Diese IP-Adresse wird für die interne Kommunikation von Lesegerät und Basisstation verwendet. Diese Einstellung kann nicht geändert werden. Verwenden Sie diese IP-Adresse nicht für die Netzwerkkommunikation.


Werden die Kommunikationseinstellungen von Lesegerät und Basisstation synchronisiert?

Damit zwischen dem Lesegerät und der Basisstation Einstellungen ausgetauscht und aktualisiert werden können, müssen Sie das Lesegerät auf die Station legen. Befindet sich das Lesegerät bereits auf der Basisstation, wenn Sie Ihre Kommunikationseinstellungen ändern, heben Sie das Lesegerät kurz an und legen es zurück auf die Station.


Industrieprotokolle

Ethernet/IP-Protokoll

Um für das Lesegerät die Verwendung des Ethernet/IP-Protokolls zu aktivieren, setzen Sie auf der Registerkarte Ethernet im Gruppenfeld Industrieprotokolle ein Häkchen bei der Option EtherNet/IP.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Klicken Sie auf Einstellungen speichern, und starten Sie dann das Lesegerät neu.

PROFINET-Protokoll

Um für das Lesegerät die Verwendung des PROFINET-Protokolls zu aktivieren, setzen Sie bei der Option PROFINET ein Häkchen. Sie können den Namen der Station eingeben, indem Sie auf Stationsnamen verwenden klicken.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Klicken Sie auf Einstellungen speichern, und starten Sie dann das Lesegerät neu.

SLMP-Protokoll

Um für das Lesegerät die Verwendung des SLMP-Protokolls zu aktivieren, setzen Sie bei der Option SLMP-Protokoll ein Häkchen, und stellen Sie dann die Parameter nach Bedarf ein.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Wählen Sie Einstellungen speichern, und starten Sie das Lesegerät anschließend neu, damit die Einstellung wirksam wird. Der Neustart kann über die Umschaltung der Stromversorgung auf das Lesegerät oder durch Scannen des Symbols Zurücksetzen erfolgen.

Modbus-TCP

Um für das Lesegerät die Verwendung des Modbus-TCP-Protokolls zu aktivieren, setzen Sie bei der Option Modbus TCP ein Häkchen, und stellen Sie dann die Parameter nach Bedarf ein.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Wählen Sie Einstellungen speichern, und starten Sie das Lesegerät anschließend neu, damit die Einstellung wirksam wird. Der Neustart kann über die Umschaltung der Stromversorgung auf das Lesegerät oder durch Scannen des Symbols Zurücksetzen erfolgen.

Eine der Optionen EtherNet/IP, PROFINET, SLMP-Protokoll oder Modbus TCP ist abgeblendet

Es kann jeweils nur ein Ethernet-Industrieprotokoll verwendet werden. Wenn eines dieser Protokolle ausgewählt ist, ist das jeweils andere Protokoll nicht verfügbar.


Wie wird die Option „Authentifizieren“ verwendet?

Bei aktivierter Option Authentifizieren wird der Benutzer vom Setup Tool aufgefordert, ein Administrator-Kennwort einzugeben, sobald versucht wird, über das Netzwerk eine Verbindung mit einem verfügbaren Lesegerät bzw. einer verfügbaren Basisstation herzustellen.


Wie wird eine TCP/IP-Verbindung hergestellt?

TCP-Verbindungen mit der Basisstation sind an Port 23 möglich. Dies ist der TCP-Standardport für Telnet-Anwendungen. Wenn Sie einen Telnet-Client verwenden, müssen Sie als Parameter lediglich die IP-Adresse der Basisstation eingeben. Wenn Sie für die Verbindung eine andere Anwendung oder SDK verwenden, muss dafür dieselbe TCP-Port-Einstellung verwendet wird wie von der Basisstation. Der TCP-Port kann im Fenster „Telnet“ geändert werden. Die Basisstation sendet automatisch Code-Ausgaben über diese Verbindung. Sie können über diese Verbindung außerdem DMMC-Steuerungsbefehle (DataMan Control Commands) übertragen.

Wenn Sie den Telnet-Port ändern, wird die folgende Frage angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten die Basisstation neu.


Was ist der Netzwerk-Client?

Das Verhalten Netzwerk-Client ist eine Option, bei der das DataMan-ID-Lesegerät aktiv eine Ethernet-Verbindung mit einem anderen Gerät im Netzwerk herstellen kann. Nach Herstellung der Verbindung verhält sich diese im Betrieb in den grundlegenden Aspekten wie die DataMan-Telnet-Verbindung: Sie kann Erfassungsergebnisse ausgeben (Übertragung von Ergebnissen an das externe Gerät) und die Funktion eines DMCC-Servers übernehmen (Verarbeitung der vom externen Gerät empfangenen Befehle).


Was ist ein Host?

Der Host ist das Gerät im Netzwerk, mit dem das DataMan-Gerät eine Verbindung herstellt. Geben Sie die Ethernet-Adresse und die Port-Nummer des Hostgeräts an. Bei der Adresse kann es sich um einen vollqualifizierten Domänennamen (z. B. „server.meinnetzwork.com“) oder um eine durch Punkte getrennte IP-Adresse im Dezimalformat (z. B. „192.169.0.1“) handeln.


Was ist ein Client-Port?

Der Client-Port ist der Ethernet-Anschluss am Lesegerät, von dem aus die Client-Verbindung hergestellt wird. Beim Standardwert 0 verwendet der Netzwerk-Client jeden verfügbaren Port. In besonderen Fällen müssen Sie möglicherweise einen bestimmten Client-Port angeben. Legen Sie dazu den Client-Port auf den geforderten Wert fest. Beachten Sie, dass in den meisten Fällen der Standardwert 0 verwendet werden kann. Verwenden Sie den Standardwert, wenn Sie sich nicht sicher sind.


Wie wird eine Verbindung hergestellt?

Der Client stellt die Verbindung entsprechend der für Verbindung öffnen ausgewählten Option her. Die Verbindung kann entweder beim Einschalten des DataMan oder bei Datenaktivität (d. h. beim Erfassen eines Codes) hergestellt werden.


Wie wird eine Verbindung getrennt?

Für Verbindung schließen stehen zwei Optionen zur Verfügung. Die Verbindung kann entweder unbegrenzt aufrechterhalten oder nach Abschluss der Datenübertragung getrennt werden. Bei Auswahl der Option Nach Datenübertragung Lesegerät können Sie außerdem die Anzahl Sekunden festlegen, nach der die Verbindung getrennt wird, wenn das Lesegerät in dieser Zeitspanne inaktiv ist. Für die Inaktivitätsdauer kann ein Wert zwischen 1 und 3600 Sekunden festgelegt werden.


Was ist das Zeitlimit für die Verbindung?

Das Zeitlimit für die Verbindung ist die Dauer (in Millisekunden), die das DataMan-Gerät auf die Herstellung einer Verbindung wartet. Beachten Sie, dass das Lesegerät bei Auswahl der Verbindungsoption Beim Einschalten fortlaufend erneut versucht, die Verbindung herzustellen.


Was ist die Verzögerung für erneuten Verbindungsversuch?

Dabei handelt es sich um die Dauer (in Millisekunden), die das Lesegerät wartet, bevor es erneut versucht, eine Verbindung herzustellen.


Sicherungseinstellungen


Wozu dient die Funktion „Automatische Sicherung der Lesegerätkonfiguration“?

Die automatische Sicherung ist bei Geräten möglich, die eine Ethernet-Verbindung verwenden. Bei Aktivierung dieser Funktion wird bei jedem Speichern der Konfiguration im Flash-Speicher eine Sicherung der Lesegerätkonfiguration auf einem externen Speicher (FTP-Server) erstellt. Ein Cognex Explorer-Dienst kann die Sicherungsdaten empfangen. Die Daten können manuell über das Setup Tool, DMCC-Befehle oder Cognex Explorer wiederhergestellt werden.

Konfigurieren Sie das Lesegerät mit der IP-Adresse und der Port-Nummer, die für die Angabe des Speicherorts der Konfiguration benötigt werden. Sie können außerdem einen Benutzernamen mit Kennwort festlegen.


Tabellenansicht


Warum sind bestimmte Werte markiert?

Markierte Werte sind Werte, die von der Standardeinstellung abweichen. Die Markierungsregeln können Sie im Abschnitt Markierung des Menübandmenüs ändern. Die Antwort zu Tabellenansicht: Menübandmenü enthält weitere Informationen.


Warum sind bestimmte Werte fett markiert?

Fett markierte Werte können erweitert werden und enthalten untergeordnete Werte.


Welches sind die möglichen Werte?

Bewegen Sie den Mauszeiger über einen Wert. Gegebenenfalls erscheint dort ein Text mit den Mindest-, Höchst- und Standardwerten.


Rechtliche Informationen


Copyright

Die Cognex Corporation übernimmt keinerlei Verantwortung für die Verwendung und Zuverlässigkeit ihrer Software bei Anlagen, die nicht von der Cognex Corporation stammen. Die Cognex Corporation übernimmt keinerlei ausdrückliche oder implizite Garantien hinsichtlich der beschriebenen Software, ihrer Marktgängigkeit oder ihrer Eignung für einen bestimmten Zweck.

Die in diesem Dokument enthaltenen Informationen können sich jederzeit und ohne Vorankündigung ändern und sind für die Cognex Corporation nicht bindend. Die Cognex Corporation übernimmt keinerlei Verantwortung für Fehler in diesem Dokument oder in der zugehörigen Software.

Copyright © 2019 Cognex Corporation. Alle Rechte vorbehalten

Dieses Dokument darf ohne schriftliche Genehmigung der Cognex Corporation weder vollständig noch teilweise kopiert oder auf andere Medien oder in andere Sprachen übertragen werden.

Hardware und Teile der in diesem Dokument beschriebenen Software sind möglicherweise durch ein oder mehrere US-Patente geschützt, die auf der Cognex Website http://www.cognex.com/patents.asp aufgeführt sind. Weitere US-Patente und ausländische Patente sind angemeldet.


Lizenzierte Software

SpiderMonkey

Diese Software unterliegt den Bestimmungen der Mozilla Public License 2.0 (MPL). Unter http://mozilla.org/MPL/2.0/ können Sie eine Kopie der MPL abrufen.

Wenden Sie sich an den technischen Kundendienst von Cognex unter <spidermonkey@cognex.com>, wenn Sie eine Kopie des SpiderMonkey-Quellcodes benötigen.

PCRE-Lizenz

PCRE ist eine Funktionsbibliothek zur Unterstützung regulärer Ausdrücke, deren Syntax und Semantik weitestgehend der Sprache PERL 5 entlehnt sind.

Die Distribution von PCRE Version 5 erfolgt gemäß den Bedingungen der nachstehend aufgeführten „BSD“-Lizenz. Die Distribution der im Verzeichnis „doc“ befindlichen PCRE-Dokumentation erfolgt unter den gleichen Bedingungen wie bei der Software.

Verfasst von: Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England. Telefon: +44 1223 334714.

Copyright (c) 1997–2004 University of Cambridge. Alle Rechte vorbehalten.

Die Weitergabe und Verwendung im Quell- oder Binärformat in veränderter oder unveränderter Form ist erlaubt, wenn die folgenden Bedingungen erfüllt sind:

  • Bei Weitergabe des Quellcodes müssen der vorstehende Copyright-Hinweis, diese Liste der Bedingungen sowie der nachstehende Haftungsausschluss mit weitergegeben werden.
  • Bei Weitergabe in Binärform müssen in der Dokumentation und in den übrigen Weitergabeunterlagen der vorstehende Copyright-Hinweis, diese Liste der Bedingungen sowie der nachstehende Haftungsausschluss enthalten sein.
  • Ohne vorherige schriftliche Genehmigung dürfen weder der Name der University of Cambridge noch die Namen der Mitarbeiter dazu verwendet werden, ein Produkt zu kennzeichnen oder zu bewerben, das aus dieser Software abgeleitet wurde.

DIESE SOFTWARE WIRD VON DEN COPYRIGHT-INHABERN UND MITARBEITERN IN DER VORLIEGENDEN FORM ZUR VERFÜGUNG GESTELLT. ALLE AUSDRÜCKLICHEN ODER IMPLIZITEN GARANTIEN EINSCHLIESSLICH, ABER NICHT NUR, DER IMPLIZITEN GARANTIEN DER MARKTGÄNGIGKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK WERDEN AUSGESCHLOSSEN. UNTER KEINEN UMSTÄNDEN HAFTEN DER COPYRIGHT-EIGENTÜMER ODER SEINE MITARBEITER FÜR DIREKTE, INDIREKTE ODER BEISPIELHAFTE SCHÄDEN SOWIE FÜR SONDER-, NEBEN- ODER FOLGESCHÄDEN (EINSCHLIESSLICH DER BESCHAFFUNG VON ERSATZGÜTERN UND -DIENSTLEISTUNGEN, NUTZUNGSAUSFÄLLE, DATENVERLUSTE, ENTGANGENER GEWINNE ODER GESCHÄFTSUNTERBRECHUNGEN), DIE SICH AUFGRUND BELIEBIGER URSACHEN UND HAFTUNGSTHEORIEN AUS VERTRAG, STRENGER HAFTUNG ODER WEGEN UNERLAUBTER HANDLUNG (FAHRLÄSSIGKEIT ODER SONSTIGE GRÜNDE EINGESCHLOSSEN) DURCH VERWENDUNG DIESER SOFTWARE IN BELIEBIGER FORM ERGEBEN KÖNNEN. DIES GILT AUCH FÜR DEN FALL, DASS DIE MÖGLICHKEIT EINES DERARTIGEN SCHADENS VORAB ANGEKÜNDIGT WURDE.

Ende

JPEG-Software

Diese Software basiert zum Teil auf den Arbeiten der Independent JPEG Group.

zlib-Komprimierungsbibliothek

Diese Software basiert zum Teil auf den Arbeiten von Jean-Loup Gailly und Mark Adler.

Parsifal XML-Parser

Copyright (c) 2002–2005 Toni Uusitalo, Veröffentlichung als Public-Domain-Software am 15.11.2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal ist für die kommerzielle und nichtkommerzielle Nutzung und Weitergabe frei verfügbar, wenn Copyright und Haftungsausschluss des Autors in unveränderter Form weitergegeben werden. Sie dürfen Parsifal für persönliche Zwecke ändern und mit Ihren Veränderungen weitergeben, wenn Sie die Änderungen klar dokumentieren.

HAFTUNGSAUSSCHLUSS

Die Weitergabe dieses Programms erfolgt, um Ihnen nützlich zu sein. EINE GARANTIEZUSAGE ERFOLGT NICHT. Dieser Ausschluss bezieht sich auch auf die Marktfähigkeit oder die Eignung für einen bestimmten Zweck. Die Verwendung erfolgt AUF EIGENES RISIKO.


Patenthinweise

Dieses Produkt ist durch eines oder mehrere der unten aufgeführten US-Patente, US-Anwendungen und/oder ausländische Patente geschützt. Auf http://www.cognex.com/patents werden ggf. relevante später erteilte Patente aufgeführt.

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 und EP1687752