RTM Lean : 问题与解答


实时监测


RTM Lean工具有何用处？

实时监控（RTM）Lean 是内置于 DataMan 的设置工具中的特色工具，能够对网络上与的单一设备相关的各种类型数据和读取的数据进行收集和分析。通过功能区菜单上配置选项可以设置采集此数据的目标设备，也可以选择收集的数据类型。默认情况下，RTM Lean 收集统计数据（读取速率、未读计数、平均解码时间、触发计数、触发失效、缓冲区溢出和过程控制指标。在设备中设置了这些参数后才能收集到这些数据）。


配置中有哪些可以使用的选项？

在配置中可以连同其它设置选项对 RTM Lean7 数据采集进行设置：

设备配置: 选择数据采集对象的设备。使用 添加设备 按钮将设备添加至列表中。此时会打开一个新窗口，在此窗口中点击添加网络设备按钮可以手动添加已分配 IP 地址的设备。使用刷新按钮可以刷新设备列表，同时使用删除手动添加的设备按钮可将所选设备从列表中删除。使用删除设备 选项可删除已添加设备列表中的设备，但此时会弹出警告提示：此操作会将设备中所有收集的数据（图像、统计数据等）完全清除。RTM Lean 可以监控有密码保护的设备，但需要在网络中输入用户名和密码。

数据收集：此列表显示 RTM Lean 能够收集到的所有类型信息。勾选复选框收集所需数据。默认情况下，RTM Lean 收集统计数据（读取速率、未读计数、平均解码时间、触发计数、触发失效、缓冲区溢出和过程控制指标。在设备中设置了这些参数后才能收集到这些数据）。列表中提供数据类型不在默认收集数据中，可以通过设置标签设置：

  • 未读取的详细触发信息：启用此功能后，当没有读取到数据时，RTM Lean 会个别存储触发数据。如果未读数据中包括部分结果或多个读码器同步信息，这些信息也会被存储。

  • 未读图像（通过 FTP）：启用此功能后，该设备会将未读图像发送给 RTM Lean。

  • 成功读取详细触发信息：该设置可以使功能区菜单详细视图下的触发性能页面生效。触发性能为成功读取数据的个别触发收集数据。该数据所有值都在触发性能页面的绘制值下拉菜单中显示。

  • 热图的代码位置：每次成功读取后，RTM Lean 都为每次发现的代码存储矩形。此信息用于创建 2 维热图，显示代码在视场中被读取的位置。

  • 设备配置更改：勾选此选项后，只要配置被更改，设备即会通知 RTM Lean。RTM Lean 存储所有被设备发送的配置文件。配置更改事件会显示在事件历史页面中，可以被导出或做对比使用。

注意：根据触发频率，使用触发级数据会降低系统处理速度。

分类：如果 Cognex In-Sight 设备与 DataMan 设备配套使用，RTM 控制器会根据未读事件原因收集分类数据。勾选从 InSight 收集图像分类框并从下拉列表中选择 分类器设备选项，必须指定分类后才能使用 In-Sight 设备。勾选存储 InSight 图像到 RTM 选框以存储分类图像。

注意：根据用户设置的触发配置和未读图像频率，存储图像操作会占用大量磁盘空间。

不要覆盖 DataMan 中通信脚本程序：勾选此框防止覆盖设备上的脚本。

网络：此面板显示被 RTM Lean 主动监控（勾选左侧启用收集选项）的设备名称和地址。点击齿轮图标打开子菜单，确定 RTM Lean 如何识别设备（IP 地址或 MAC 地址）。如果需要从被设置密码的设备上收集数据，从左侧列表中选择待监控的设备后必须提供用户名和密码。


显示设置下有什么可用的设置？

在此可以设置将警告线显示在图表上。

  • 显示读数速率参考线：勾选该选项显示警告线。

  • 读数速率参考线值(%)：可以设置表示警告百分比的百分值，警告线会在读取速率 图表上绘出。

  • 图表类型确定显示线条的类型。

  • 未读缓冲区大小和未读图像历史相关，此处设置的数值表示页面上最大的线条数量（触发）。

  • 在返回的最大触发详情数框中设置返回的触发详情最大数。


在功能区菜单设备选项下能够做哪些设置？

除了显示 RTM Lean 当前连接的设备识别号，显示的图标能够提示用户数据采集处于启用状态（显示标）还是非启用状态（暂停图标）。根据启动 RTM Lean 时或在配置中设置的参数，可以使用下拉菜单中的选项暂停或开始收集数据。也可以从配置中的下拉菜单中选择执行诊断操作。


聚合视图和详细视图 - 一般信息

聚合视图功能区菜单选项和详细视图功能区菜单选项可以显示 RTM Lean 收集的数据（结构化表示），主要以交互式实时图表形式显示。最短显示时间间隔为 1 分钟。如果一分钟内产生多次触发，RTM Lean 则在一分钟间隔时间内会对这些触发所收集的数据进行整合。

使用配置>显示设置选项能够设置显示在图表上的警告线。勾选复选框使警告线显示在每张图表上。图表类型确定显示的线条类型，在参考线可以给出警告百分比，线条根据这个值绘制在图表上。

注意:连接时 RTM Lean 只收集显示在视图菜单子项中的信息，并且只有启用的设备才能收集数据（通过配置或下拉菜单中的设备选项启用数据采集）。


性能概览采集和显示什么数据？

根据左上方设置中的显示情况，性能概览可以在图表上实时显示读取速率、每分钟读数和每分钟未读数。最上一行的最后[时间间隔]按钮是可以点击的，启用状态会显示橙色。可以使用按钮设置性能概览使用的间隔时间。

需要触发被监控的设备，将数据显示图表上。

使用配置>显示设置选项能够设置显示在图表上的警告线。勾选复选框使警告线显示在每张图表上。图表类型 确定显示的线条类型，读取速率参考线值 (%)表示线条在图表上所占的百分比。


代码质量概览收集和显示什么数据？

根据左上角设置>绘制值中设置，代码质量概览可将代码质量等级和度量值实时显示图表上。选择需要监控的设备度量值或等级。只有在受监控设备上设置后，绘制值中代码质量标准才可用（因此空的下拉框表示设备没有启用标准）。通过更改目标设备启用的代码质量标准，可以为其他标准收集数据。

多代码情况下，设备上可设置了多个代码质量标准。在此情况下，图表显示两条数据线（平均值在上方显示）。

注：因为RTM Lean使用最短一分钟时间间隔，因此等级会有一个中间值。

最上一行的最后[时间间隔]按钮是可以点击的，启用状态会显示橙色。可以使用按钮设置代码质量概览使用的间隔时间。在此显示平均绘制值。

使用配置>显示设置选项能够设置显示在图标上的警告线。勾选复选框使警告线显示在每张图表上。图表类型 确定显示的线条类型， 读取速率参考线值 (%) 表示线条在图表上所占的百分比。


事件历史采集和显示什么数据？

根据左上角 设置>绘制值中的设置情况，事件历史可将统计数据和代码质量采集值实时显示图表上。RTM Lean监控设备上所选值。对于代码质量度量值和等级，只有被监控设备被设置代码质量标准才在绘制值处于可用状态。通过更改目标设备启用的代码质量标准，可以为其他标准收集数据。

可将滚动条移动到所需点位置，及时查看特定时间的数据。可以通过修改滚动条长度（按住鼠标拖拽）来改变监控时间间隔。选择时间段（通过定位滚动条来确定）绘制值的聚合值显示在所选时间段的聚合值选项下的顶部中间位置。

数据收集位于图表的底线位置，用点表示监控期间的事件。每个事件详细信息显示在右侧列表中（时间邮戳和事件类型）。列表下有两个按钮：

  • 可使用保存设备备份将列表中选择的与事件关联的设备配置导出。当对给定统计数据、度量值或等级内产生变化的原因进行查找时，此项可用来检查详细信息。

  • 使用比较配置选项可打开文档，在此文档中对所选事件关联的设备配置进行比较；只有在列表中选择了多个事件时才有效。


在代码定位热图面板中能看到什么？

代码定位热图绘制成功读取到的热图，显示区域会根据发现的代码频繁度着色。颜色越暖表示该区域发现到的代码越频繁。可将滚动条移动到所需点位置，及时查看特定时间的热图。可以通过修改滚动条长度（按住鼠标拖拽）来改变监控时间间隔。


未读图像历史面板显示什么数据？

未读图像历史显示受监控设备拍摄的最近未读图像。左侧列表视图以列表形式显示图像各种属性，右侧图像窗口显示滑块视图中选择的图像。点击保存图标保存当前所选图像。

如果选择配置>设置>分类下的收集分类选项，左下角分类图表显示已产生的未读事件类型。


触发性能面板显示什么数据？

为了启用触发性能，需要在设置选项卡下的数据收集内勾选成功读取详细触发信息一项。

触发性能不能像其他面板一样聚合 1 分钟间隔内的数据，但是可以在图表上显示每次触发。个别触发使用图表上的点来表示并显示数值。可从绘制值下拉框中选择可能的值，为绘制值（受监控对象）赋值。注意：被监控设备使用的固件版本不一样，绘制值列表可能会有区别。

可将滚动条移动到所需点位置，及时查看特定时间的数据。可以通过修改滚动条长度（按住鼠标拖拽）来改变监控时间间隔。可以根据颜色区基于设置来设定图表上点的着色标准。

如果触发成功读取图像，可以点击图表上一个点（触发），在右侧显示 RTM Lean 收集到的所有相关数据。如果读取失败，点击保存图标后，RTM Lean 会显示已被保存的图像。


系统标签下有哪些可以使用的选项？

可以在此删除数据和配置设置。点击清空数据库将会删除所有存储数据，点击重置配置将会删除设备的配置设置和所有存储数据。