RTM Lean : Q&A


リアルタイムモニタリング


RTM Lean の用途:

Real Time Monitoring (RTM：リアルタイムモニタリング) LeanはDataMan Setup Toolに組み込まれている機能で、ネットワーク上の単一デバイスと読み取りに関連する各種データの収集・分析を行えるようにします。データの取得対象となるデバイスおよび収集するデータのタイプは、リボンメニューの [設定] で指定できます。デフォルトでは RTM Lean が統計データ (読み取り率、読み取り無効画像のカウント、平均デコード時間、トリガのカウント、トリガのオーバーラン、バッファのオーバーフロー、(有効になっている場合は) プロセス管理) を収集します。


設定で使用できる項目：

設定では RTM Lean のデータ取得設定を始め、その他の設定が可能です：

デバイス設定：データ取得対象となるデバイスを設定します。[デバイスの追加] ボタンでデバイスをリストに追加します。別の画面が開き、[ネットワークデバイスの追加] ボタンで、IPを基にデバイスを手動で追加します。デバイスのリストを更新するには [更新] ボタンを、指定したデバイスをリストから削除するには [手動で追加したデバイスの削除] ボタンを使います。[デバイスの削除] では追加したデバイスのリストからデバイスを削除できますが、操作に伴い収集したデバイスのデータ (画像や統計データなど) が失われる旨の警告メッセージ画面が現れます。RTM Lean でパスワード保護されたデバイスを監視することが可能ですが、設定には [ネットワーク] でユーザー名とパスワードを設定する必要があります。

データ収集：このリストには RTM Lean が収集できるすべての情報タイプが含まれます。収集したいデータはチェックボックスにチェックを入れます。デフォルトでは RTM Lean が統計データ (読み取り率、読み取り無効画像のカウント、平均デコード時間、トリガのカウント、トリガのオーバーラン、バッファのオーバーフロー、(有効になっている場合は) プロセス管理測定) を収集します。リストに入っているデータのタイプは、デフォルトの収集データには入っておらず、[設定] タブで設定できます。

  • 無効な読み取りのトリガ詳細情報：有効にすると、読み取り無効が発生するたびに RTM Lean がトリガデータを保存します。読み取り無効画像に部分的な結果やマルチリーダ同期情報が含まれる場合は、これらも保存されます。

  • 無効な読み取り画像 (FTPから)：有効にすると、読み取り無効画像がデバイスから RTM Lean に送信されます。

  • 成功した読み取りのトリガ詳細情報：リボンメニュー > [トリガのパフォーマンス] ページ > [詳細ビュー] の使用を有効にする設定です。[トリガのパフォーマンス] は読み取りに成功した個々のトリガのデータを収集します。ここでのデータ値はすべて、[トリガのパフォーマンス] ページにある [プロットした値] ドロップダウンメニューで見ることができます。

  • ヒートマップのコード位置：読み取りが成功すると、RTM Lean が検出した各コードの長方形を保存します。この情報は2D ヒートマップの作成に使用され、視野の中でコードを読み取る位置を表示します。

  • デバイス設定変更：チェックを入れると、設定に変更があった時はデバイスが RTM Lean に通知します。RTM Lean はデバイスが送信したすべての設定ファイルを保存します。設定変更のイベントは [イベントの履歴] ページに表示され、エクスポートや比較ができるようになっています。

トリガ周波数によっては、トリガレベルのデータを有効にすることでシステムの速度が低下することがあります。

分類：Cognex In-Sight デバイスと DataMan デバイスがペアリングされていれば、読み取り無効のイベントの原因に基づき、RTMコントローラが分類データを収集することができます。画像の分類に使う In-Sight デバイスは [In-Sightからの画像分類データの収集] ボックスにチェックを入れ、ドロップダウンメニューから [分類用デバイス] を選択してください。分類画像を保存するには、[InSight 画像を RTM に保存] にチェックを入れます。

トリガの設定と読み取り無効画像の頻度によっては、画像を保存することでディスクの使用量が大幅に増えることがありますのでご注意ください。

DataManの通信スクリプトを上書きしないでください：デバイスに入っているスクリプトを上書きしたくない時に、このボックスにチェックを入れます。

ネットワーク：このペインには RTM Lean がアクティブに監視しているデバイスの名前とアドレスを表示します ([収集有効] の左にチェックマーク)。歯車アイコンをクリックするとサブメニューが開き、RTM Lean のデバイスの認識方法 (IPアドレスまたはMACアドレス) を決められます。パスワード保護されたデバイスからデータを収集したい場合は、左のリストから監視するデバイスを選択した後で、ユーザー名とパスワードを入力する必要があります。


[ディスプレイ設定] で可能な設定内容:

グラフに表示する警告線は、ここで設定できます。

  • 読み取り率 基準線の表示：チェックボックスをマークすると、警告ラインが表示されます。

  • 読み取り率 基準線の値 (%)：読み取り率グラフに引かれたラインの警告率をパーセンテージで設定できます。

  • [グラフの種類] では、表示する線の種類を決めます。

  • [読み取り無効 バッファサイズ] は読み取り無効画像の履歴に関わり、ここで設定される値がそのページで考慮される線 (トリガ) の最大数です。

  • 戻ってきたトリガに関する情報の最大件数は、[戻ってきたトリガ詳細の最大件数] で設定します。


リボンメニューの [デバイス] 設定項目：

RTM Lean と接続が確立しているデバイスのID表示以外に、データ収集を実行中 (実行アイコン) か停止中 (停止アイコン) かをアイコンでお知らせします。ドロップダウンメニューから、RTM Lean または [設定] の開始時に指定したパラメータセットに従い、アクティブなデータ収集を一時停止/実行します。[設定] 同様に、ドロップダウンメニューから診断を実行することも可能です。


集合ビューと詳細ビューに関する一般情報：

[集合ビュー] リボンメニューの項目と [詳細ビュー] リボンメニューは、いずれも RTM Lean が収集したデータを構造化し、主にインタラクティブなリアルタイムのグラフで表示します。表示の最短間隔は1分です。1分間に複数のトリガが発信された場合は、RTM Lean がこの1分間のトリガから集合データを収集します。

グラフに表示する警告線は、[設定] > [ディスプレイ設定]で設定できます。チェックボックスをマークすると、各グラフに警告線が表示されます。[グラフの種類] で表示する線の種類が決まり、[基準線の値] でグラフに引かれる警告線のパーセンテージを入力できます。

動作中のデバイスとの接続が確立し、収集が有効になっている RTM Lean は、ビューのメニュー項目に表示された情報のみを収集します (データ収集は [設定] または [デバイス] で有効にできます)。


[パフォーマンスの概要] が収集・表示するデータ：

[パフォーマンスの概要] では、左上の [表示] に応じて読み取り率、1 分あたりの読み取り件数、1 分あたりの読み取り無効件数をリアルタイムのグラフで表示できます。最上行の [時間間隔] ボタンをクリックすると、アクティブなものがオレンジ色で囲まれます。[パフォーマンスの概要] が使用するインターバルの設定にはボタンを使用します。

グラフにデータを表示するには、モニタリング中のデバイスをトリガする必要があります。

グラフに表示する警告線は、[設定] > [ディスプレイ設定]で設定できます。チェックボックスをマークすると、各グラフに警告線が表示されます。[グラフの種類] は表示するラインの種類を決めます。[読み取り率基準ラインの値 (%)] は、グラフに引くラインのパーセンテージです。


[コード品質の概要] が収集・表示するデータ：

[コード品質の概要] は、左上の [設定] > [プロットした値] の内容に応じてコードの品質グレードを表示し、測定をリアルタイムのグラフで表示できます。デバイスでモニタリングしたい測定またはグレードを選択します。モニタリング中のデバイスで設定したコードの品質基準以外は、[プロットした値] で使用することができません (ドロップボックスに何も無い時は、デバイスに有効な基準が無いことを意味します)。対称のデバイスで有効なコードの品質基準を変更すると、別の基準でデータの収集ができます。

マルチコードでは、デバイスにコードの品質基準を複数設定する場合もあります。このような時はグラフに2本のデータ線が表示されます (平均は上に表示)。

注意: RTM Lean は1分間隔であるため、グレードは中間値になることがあります。

最上行の [時間間隔] ボタンをクリックすると、アクティブなものがオレンジ色で囲まれます。[コード品質の概要] が使用するインターバルの設定にはボタンを使用します。プロットした値の平均はここに表示されます。

グラフに表示する警告線は、[設定] > [ディスプレイ設定]で設定できます。チェックボックスをマークすると、各グラフに警告線が表示されます。[グラフの種類] は表示するラインの種類を決めます。[読み取り率基準ラインの値 (%)] は、グラフに引くラインのパーセンテージです。


[イベントの履歴] が収集・表示するデータ：

[イベントの履歴] は、左上の [設定] > [プロットした値] の内容に応じて、統計とコードの品質データの取得をリアルタイムのグラフにまとめています。RTM Lean はデバイスで選択した値をモニタリングします。コード品質測定とグレードには、モニタリングするデバイスで設定したコード品質基準のみが、[プロットした値] で使用できます。対称のデバイスで有効なコードの品質基準を変更すると、別の基準でデータの収集ができます。

特定の時間のデータを見たい時は、その時間にスクロールバーを動かしてください。スクロールバーの長さを (クリックしたままドラッグ) 変更して、モニタリング間隔を変えることもできます。(スクロールバーを合わせて) 選択した期間にプロットした値の集合値は、最上部中央 [選択した期間] の [集合値] に表示されます。

データ収集で一番下に線が追加され、モニタリング中のイベントを点で示します。それぞれのイベントは右側に説明付き (タイムスタンプ、イベントの種類) でリスト化されます。リストの下にある2つのボタン：

  • [デバイスのバックアップを保存] は、選択したリスト上のイベントに関わるデバイスの設定をエクスポートします。統計や測定、グレードに生じた変更の理由を探りたい時の、内容の精査に役立ちます。

  • [設定比較] は、選択したイベントに関するデバイスの設定を比較するドキュメントが開きます。この機能は、リストから1つ以上のイベントを選択していないと使用できません。


[コードの位置 ヒートマップ] ペインの表示項目:

[コードの位置 ヒートマップ] は、検知したコードの頻度に応じて領域を色分けし、成功した読み取りのヒートマップを表示します。暖色はその領域でより頻繁に検知されたコードを示します。特定の時間のヒートマップを見たい時は、その時間にスクロールバーを動かしてください。スクロールバーの長さを (クリックしたままドラッグ) 変更して、モニタリング間隔を変えることもできます。


[読み取り無効画像の履歴] ペインに表示されるデータ：

[読み取り無効画像の履歴] では、モニタリング中のデバイスによる直近の読み取り無効画像が表示されます。左側の表には画像の特徴がリストアップされ、右側の画像画面にはその下のスライドビューから選択した画像が表示されます。選択中の画像は [アイコンの保存] をクリックして保存できます。

[設定] > [設定] > [分類] で分類データの収集を選択すると、左下端の [分類] グラフに発生した読み取り無効画像の種類が表示されます。


[トリガのパフォーマンス] ペインに表示されるデータ：

[トリガのパフォーマンス] を使う場合は、[設定] タブの [データ収集] リストで [読み取り成功画像のトリガ詳細情報] を有効にします。

[トリガのパフォーマンス] は他のペインのように1分間隔で集合データを作成することがない代わりに、毎回のトリガをグラフに表示します。個々のトリガはグラフ上で点で表され、数値も示されます。(モニタリング中の) [プロットした値] は、[プロットした値] ドロップダウンメニューで提示された数から選択できます。モニタリング中のデバイスに入っているファームウェアのバージョンによって、プロットした値のリストが異なる場合があります。

特定の時間のデータを見たい時は、その時間にスクロールバーを動かしてください。スクロールバーの長さを (クリックしたままドラッグ) 変更して、モニタリング間隔を変えることもできます。グラフ上の点の色に基準を設定したい時は、[プロットの色分け基準] を使用します。

トリガの読み取りが成功すると、グラフ上の一つの点 (トリガ) をクリックして、RTM Lean が収集した関連データすべてを右側に表示することができます、読み取りに失敗した場合は、RTM Lean が表示した撮影画像を [保存] アイコンで保存できます。


[システム] タブで使用できる項目：

ここでは、データと設定の内容を削除することができます。[データベースを空にする] をクリックすると保存データをすべて削除し、[設定のリセット] はデバイスの設定と全ての保存データを削除します。