DataMan 8600 : Perguntas e Respostas


Tela de boas-vindas


Bem-vindo

Para configurar rapidamente seu dispositivo, é recomendado seguir os Passos do aplicativo representados por botões maiores, no lado esquerdo. Cada seção possui uma guia com opções de configuração Básicas ou Avançadas. O botão de ação Salvar configurações salva os dados da configuração no leitor e salva um backup em seu PC com um único clique. As perguntas abaixo descrevem as opções de configuração em cada Passo do aplicativo que não são autoexplicativas.


O que posso configurar em Tipo de aplicativo?

Clicar na seta à direita permite que você selecione os modos de leitura adequados a partir do menu suspenso.


O que posso fazer no passo Otimizar imagem?

Você pode realizar o processo de configuração, calibragem e teste de seu dispositivo conectado aqui e pode configurar seus ajustes de iluminação para o dispositivo.


O que posso selecionar em Detalhes do código?

Aqui, você pode selecionar as simbologias que o DataMan tem de ler, bem como cenários de códigos múltiplos diferentes. As configurações avançadas do decodificador também podem ser efetuadas neste menu.


O que posso configurar no passo Detalhes do aplicativo?

Aqui podem ser definidas as configurações do disparo e de exposição. Para um uso fácil, um Assistente de disparo, um Assistente de intervalo e um Assistente de exposição ajudam-no com estas configurações.

Na guia Avançadas podem ser implementadas configurações mais detalhadas na visualização de tabela.


O que posso configurar em Dados do formato?

Para construir a saída de dados desejada a partir do dispositivo você pode usar expressões regulares de estilo Perl ou formatação básica para construir um cadeia de saída personalizada, usando os blocos de criação predefinidos, ou usar o mecanismo de JavaScript para construir um script de formatação de dados flexível.


O que posso configurar no passo Entradas/Saídas?

Neste painel podem ser configurados o comportamento dos botões e as linhas de entrada e de saída. Aqui também podem ser configurados os detalhes para um codificador de pulso e a duração do pulso do bipe. Este painel também possui o link para as configurações do buffer de imagens para enviar imagens FTP para um servidor.


O que posso configurar no passo do aplicativo Comunicações?

Nas três guias do passo do aplicativo Comunicações podem ser implementadas as configurações de Ethernet e serial. Clique na guia adequada para inserir seus valores de configuração.


Qual a função de Salvar configurações?

Salvar configurações é mais propriamente uma ação do que um passo, mas importante de realizar. Esta ação salvará a configuração atual na memória persistente do leitor, de modo que as mesmas configurações sejam carregadas após reiniciar. O DataMan Setup Tool armazenará também um arquivo de backup localmente, no PC atual, na pasta de backup.


O que é o arquivo Backup de configuração?

O arquivo Backup de configuração contém todos os parâmetros e a configuração do dispositivo. Pode ser usado para restaurar configurações para um estado conhecido ou configurar novos dispositivos, selecionando parâmetros de configuração com ou sem propriedades de backup.


Conecte-se ao leitor


Como conectar meu leitor ao Setup Tool?

Independente de qual leitor você esteja usando, siga estes passos para conectar seu leitor DataMan ao Setup Tool:

  1. Imprima uma cópia do documento Códigos de configuração do leitor referentes ao seu leitor específico, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.

  2. Conecte os cabos necessários entre o seu leitor e o computador executando o Setup Tool. Consulte a documentação "Referência Rápida" para obter mais informações.

  3. Clique em Atualizar no Setup Tool.

  4. Selecione a Porta COM ou o Dispositivo de rede mostrando uma conexão para o seu leitor.

  5. Clique em Conectar.


Por que o Setup Tool falha ao se conectar ao meu leitor?

Se você não conseguir se conectar, verifique as seguintes opções:

  • Verifique se o código de configuração que você escaneou (USB COM ou RS-232 Serial) está de acordo com o tipo de conexão física que você está usando (não funciona com os leitores que usam apenas a conexão via Ethernet).

  • Certifique-se de que o aplicativo de firewall ou de antivírus instalado em seu computador permite a comunicação com dispositivos de Ethernet, permitindo as portas adequadas (Cognamer:1069 e Setup Tool:44444).

  • Certifique-se que a lista das portas COM mostra uma porta onde o seu leitor está conectado.

    DataMan séries 60, 300, 370, 470, 503 e 8000: Se o seu leitor estiver conectado à sua rede Ethernet, verifique se ele aparece na lista de Dispositivos de rede.

    Clique em Atualizar para determinar quais portas possuem leitores conectados.

    Observação: Ao clicar em Atualizar, uma cadeia de consulta será enviada para todas as portas COM e toda a sub-rede da rede Ethernet. O leitor sem fio DataMan 8000 deve estar ativo para responder ao comando. Você pode pressionar o disparador para ativar o leitor.

  • Verifique se você não está usando o teclado, a conexão do teclado ou a conexão HID. Você deve usar uma rede USB Serial, RS-232 Serial, Ethernet ou sem fio para conectar o Setup Tool ao leitor.

  • DataMan séries 60, 300, 370, 470, 503 e 8000: Certifique-se que o endereço IP fornecido na opção Adicionar dispositivo está correto.

  • Apenas para leitores DataMan 8000 sem fio: Certifique-se que o leitor não está no modo de suspensão (aperte o disparador para despertá-lo).

  • Apenas para os leitores DataMan 8000 sem fio: Verifique se há uma conexão estabelecida entre o leitor e a estação base conectada ao seu computador. Para garantir, leia o código de configuração Desvincular impresso no guia de consulta rápida, desconecte ambos os cabos de comunicação e energia da estação base, reconecte os cabos e depois recoloque o leitor na estação base. Aguarde até que o leitor indique que está conectado (com um sinal audível) antes de tentar conectar novamente.

  • Apenas para leitores DataMan 8000 sem fio: Certifique-se que a estação base está energizada.

Você pode usar um programa de simulação como o HyperTerminal para determinar se o leitor está enviando quaisquer dados ou se o leitor está conectado a uma porta COM no PC.


Por que vejo um ícone de sobreposição no canto superior direito do ícone do meu dispositivo?

O ícone de seta indica que o dispositivo foi adicionado manualmente. O ícone ‘V’ indica que o dispositivo é um dispositivo virtual.


O que são dispositivos virtuais?

O ícone de sobreposição ‘V’ no canto superior direito do ícone do dispositivo indica que o dispositivo é um dispositivo virtual. Os Dispositivos virtuais podem ser criados em Reparo e suporte, a partir de um arquivo de configuração personalizada ou um dispositivo com configuração padrão. Os Dispositivos virtuais podem ser usados para visualizar os diferentes painéis do Setup Tool sem necessidade de conectar a um dispositivo real.

O dispositivo virtual criado não está visível para outros dispositivos na rede. O dispositivo virtual persiste através de múltiplas instâncias de Setup Tool.

O dispositivo virtual criado pode ser conectado da mesma forma que um dispositivo normal, com a exceção de que todas as alterações de configuração são rejeitadas (tudo é somente leitura) e nenhuma característica, função e ação funciona em dispositivos virtuais.


Qual porta usar para uma conexão USB?

Se você conectar o leitor ou a estação base usando a porta USB, faça a leitura do código de configuração USB-COM/RS-232 do documento "Códigos de configuração do leitor". Depois clique em Atualizar e selecione a porta que é identificada como conectada ao leitor.

Observação: Ao clicar em Atualizar, uma cadeia de consulta será enviada para todas as portas COM e toda a sub-rede da rede Ethernet. O leitor sem fio DM7550 e DM8000 deve estar ativo para receber o comando. Pressione o disparador para ativar o leitor.


Ainda não é possível conectar meu leitor à estação base: Posso reinicializá-lo?

Na estação base do DataMan Série 8000:

Usando o leitor sem fio associado à estação base, faça a leitura do comando Redefinir a estação base com o padrão de fábrica (para a DM8000Base) para fazer com que a estação base volte ao estado padrão de fábrica.

Para leitores das séries 503 e 8000 DataMan:

Faça a leitura do comando Reinicializar scanner impresso na parte posterior do documento "Guia de consulta rápida" para reinicializar pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Se isto falhar, faça a leitura do comando Reinicializar o scanner com os padrões de fábrica para que o leitor volte ao estado padrão de fábrica.

Se isto falhar e você estiver usando um leitor com fio, desconecte o leitor da fonte de alimentação (este procedimento não pode ser usado no DataMan 9500). Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.

Se isso falhar e você estiver usando o leitor sem fio DataMan 8000, remova a bateria do leitor e coloque-a na estação de base. Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.

Para leitores DataMan 50, 60 e 70:

Imprima uma cópia do documento Códigos de configuração referentes ao seu leitor específico, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.

Faça a leitura do código Reiniciar scanner para fazer uma reinicialização pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Se você ainda não pode se conectar ao leitor, faça a leitura do código Reinicializar o scanner com os padrões de fábrica para retornar o leitor ao seu estado padrão de fábrica.

Se isto não resolver a questão, desconecte o leitor da alimentação de força (tanto força de corrente contínua - CC quanto USB, se conectado). Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.


Como saber qual é o meu dispositivo?

Para os leitores DataMan 260, 300, 473, 500, 503 e 8000:

Na lista de seleção, os dispositivos estão listados em Conecte-se ao leitor, clique com o botão direito do mouse no leitor e selecione Identificar. O indicador de status do leitor emite um sinal, possibilitando que você o identifique.


Por que alguns leitores são mostrados em verde?

Os dispositivos recentemente descobertos são exibidos em verde por alguns segundos para que você saiba que é um novo dispositivo na lista de seleção.


DataMan séries 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 e estação de base do DataMan 8000: Por que o Setup Tool pede uma senha quando quero me conectar?

O leitor e a estação base podem ser configurados para solicitar uma senha antes de se conectar ao Setup Tool. A senha é habilitada na guia Autenticação na opção Configurações de rede do painel Configurações de comunicação. Saiba que a senha é usada também para conexão serial.


DataMan séries 60, 300, 370, 470, 503, 8000 e estação de base do DataMan 8000: É possível conectar o leitor com meu PC usando diretamente a Ethernet?

O leitor ou a estação base pode ser conectado diretamente a um conector Ethernet (RJ-45) no seu PC. Se o dispositivo estiver configurado para DHCP, então ele aparecerá na lista de Dispositivos de rede depois de aproximadamente 20 segundos. Favor considerar, todavia, que seu PC pode precisar de um tempo adicional para que seu endereço IP seja configurado. Até que isso termine, você não pode se conectar ao dispositivo por meio do Setup Tool.

Se o dispositivo foi ajustado em um endereço IP fixo, ele aparecerá apenas se o leitor e o PC compartilharem a mesma sub-rede.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000 e estação de base do DataMan 8000: Como relacionar um dispositivo na lista de dispositivos de rede com um leitor específico?

De modo padrão, cada DataMan aparece nos Dispositivos de rede com um prefixo DM e os últimos seis caracteres em seu endereço MAC, que são impressos no dispositivo.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 e estação de base do DataMan 8000: O que ocorre se o leitor ou a estação base não aparece na lista de Dispositivos de rede?

Se o leitor ou a estação base desejado não estiver listado(a), adicione-o(a) ligando e desligando o dispositivo. O dispositivo leva até 60 segundos para aparecer na lista, após ser desligado e ligado.

Se a operação de desligar e ligar não resolver o problema, o Setup Tool não poderá se comunicar com o dispositivo devido à configuração de rede e ele não aparecerá na lista de Dispositivos de rede.

Verifique sua conexão Ethernet com o leitor ou com a estação de base e clique em Atualizar no Setup Tool.

Se você souber o endereço IP do leitor ou da estação base, use a opção Adicionar dispositivo.

Esse método permite que o leitor DataMan ou a estação de base apareça na lista de Dispositivos de rede, de modo que você possa se conectar ao dispositivo através do Setup Tool e de sua conexão Ethernet.


Leitor sem fio DataMan Série 8000: Como associar um leitor sem fio a uma estação base diferente?

Se a estação base com a qual você deseja associar o leitor sem fio já estiver associada com outro leitor, você deverá interromper esta associação, fazendo a leitura do código Cancelar atribuição do leitor da estação base. Para associar o leitor à nova estação base, simplesmente coloque o novo leitor na estação base. Eles se emparelharão automaticamente.


Estação base do DataMan 8000: Como reinicializar a conexão USB na estação base?

Se você sentir alguma dificuldade para estabelecer ou manter uma conexão USB entre a estação base e seu PC, siga estes passos para reinicializar a conexão USB:

  1. Desconecte o cabo USB e o cabo de força da estação base.

  2. Reconecte o cabo USB e o cabo de força à estação base.

  3. Coloque o leitor na estação base.

  4. Remova o leitor da estação base e faça a leitura do código de configuração do USB-COM/RS_232.


Como funciona o botão Comparar configuração?

O botão Comparar configuração inicia a função de comparação de configuração do Setup Tool, uma ferramenta do estilo de visualização de tabela usada para configurar, copiar, comparar ou restaurar as configurações do dispositivo. A função abre em uma página de documento nova.

Se não for selecionado nenhum dispositivo da lista de dispositivos antes de pressionar o botão, é aberto um documento vazio. Se um ou mais dispositivos forem selecionados, o documento de comparação é preenchido com as configurações desses dispositivos.


O que é o RTM Lean ou o dispositivo RTM exibido em Rede?

O Monitoramento em tempo real (RTM) Lean é um recurso incluído no DataMan Setup Tool e o RTM é um aplicativo de software suportado pelo hardware acessível através do DataMan Setup Tool, que permite a coleção e análise de diferentes tipos de dados relacionados com os dispositivos na rede e respectivas leituras. Você pode conectar-se ao RTM Lean ou ao RTM como faria a um dispositivo, avançando de seguida para a configuração da coleção de dados em um documento recentemente aberto. O RTM Lean ou RTM somente coleta os dados ativamente durante o funcionamento e quando você está conectado a ele.

Durante a configuração inicial, será solicitado que você escolha o dispositivo que será monitorado pelo RTM Lean ou pelo RTM e, de seguida, que tipo de dados (fora do padrão) o mesmo irá coletar. Isto pode ser redefinido em Configuração, no menu de faixa de opções. Como padrão, o RTM Lean ou o RTM coleta os dados estatísticos (Taxa de leitura, contagem do disparo, saturação do disparo, estouro de buffer e métricas de controle do processo, se estiverem habilitados no dispositivo).

OBSERVAÇÃO: O RTM Lean pode adquirir dados de um único dispositivo de cada vez e manter os dados durante 48 horas. A versão completa do RTM não tem essas limitações.


Otimizar imagem


O que posso fazer no passo Otimizar imagem?

Você pode realizar o processo de configuração, calibragem e teste de seu dispositivo conectado aqui.

Para configurar rapidamente seu dispositivo, é recomendado seguir os Passos do aplicativo representados por botões maiores no centro, onde você pode selecionar a partir de opções de configuração Básicas ou Avançadas. Com o botão de ação Salvar configurações você pode salvar todos os seus dados de configuração de forma simples. As perguntas abaixo descrevem as opções de configuração em cada Passo do aplicativo que não são autoexplicativas.


Como salvar uma imagem adquirida em um arquivo?

Clique no botão Salvar imagem na barra de ferramentas do Painel de imagens ou Visualizador de imagens.

Também é possível arrastar e soltar a imagem para o seu computador. Clique na imagem, na janela Visualização da imagem, arraste-a para fora do Setup Tool e solte-a.

OBSERVAÇÃO: Caso você queira salvar uma imagem arrastando-a e soltando-a, mas a imagem não é a mais recente (você está salvando de Histórico de resultados da leitura), a imagem será salva com as configurações da imagem exibida. Como padrão, a qualidade é reduzida. Em Configurações da imagem visualizada, é possível alterar o tamanho da imagem para o tamanho cheio e formatá-la para Bitmap.


Como posso usar o botão Ao vivo?

Na guia Básicas, clique no botão Ao vivo para entrar no modo Ao vivo. O modo Ao vivo não monitora somente o que o dispositivo lê, mas também decodifica. Clicando no lado mais à direita do botão, abre outras opções.

Selecione Decodificar se você deseja que o dispositivo decodifique imagens obtidas. Quando selecionada, a opção Retorno do foco exibe um medidor codificado por cores do lado direito da visualização de imagem. O medidor indica o foco da lente (menor é menos focado).

Selecione a opção Exposição automática para que o leitor determine automaticamente as melhores configurações de exposição na imagem. O controle deslizante (abaixo da área de visualização de imagem) indica o brilho dos pixels do alvo.

Na guia Avançado, pode ser visualizada uma visualização de tabela das configurações da imagem.


Utilizo o painel de Desempenho de leitura para o quê?

Com os gráficos no painel Desempenho da leitura, à direita, você pode monitorar tempos de decodificação e taxas de leitura em tempo real. Clique no botão Apagar para reinicializar o gráfico.


Quais são os ajustes de iluminação que podem ser alterados?

É possível definir qual quadrante do UltraLight deve ser ligado. Também é possível usar os ajustes de iluminação padrão de fábrica e aplicar outras configurações no processador de imagens no painel Configurações de iluminação e do processador de imagens.


Quais configurações do disparo podem ser alteradas?

É possível configurar o Tipo de disparo para Manual (botão) ou Apresentação (interno). Para configurações de disparo adicionais, vá até ao painel Configurações da iluminação e do processador de imagens, clicando no item da respetiva faixa e selecione a guia Configurações do disparo.

Observe que no modo Apresentação, assim que o operador aciona o disparador, o leitor comuta para o modo Manual até o dispositivo ser encaixado de novo na estação de base.

Consulte as Perguntas e Respostas dos Detalhes do aplicativo para obter mais informações.


Como determinar o valor de foco correto do leitor DataMan Série 8600?

O valor de foco configura o foco na variação de 0 a 500 milímetros.

Se você alterar a opção Passos do foco no painel Configurações do foco (em Configurações da iluminação e do processador de imagens), será possível configurar duas barras no painel Configuração rápida. Eles especificarão os valores de foco menor e superior.


Como determinar o valor de exposição do leitor DataMan Série 8600?

Esta configuração é habilitada quando se usa a exposição manual (que pode ser habilitada no painel Configurações da iluminação e do processador de imagens).


Como ligar ou desligar rapidamente todas as luzes do leitor?

Clique com o botão direito do mouse na imagem que exibe os quadrantes de luz. É possível selecionar estas opções:

  • Todos ligados

  • Todos desligados

  • Norte-Sul

  • Leste-Oeste

As alterações serão válidas imediatamente de acordo com a sua seleção.


O que são as Configurações da imagem visualizada?

As Configurações da imagem visualizada controlam como o leitor mostra as imagens adquiridas em resposta aos disparos de aquisição, assim como as imagens ao vivo obtidas de qualquer leitor. A alteração destas configurações não afeta o desempenho do leitor, afeta apenas a qualidade da imagem e a taxa de transferência entre o leitor e o Setup Tool.

OBSERVAÇÃO: Algumas propriedades relacionadas às imagens (por exemplo, tamanho da imagem e filtros) não podem ser alteradas quando o dispositivo está obtendo ou decodificando imagens.

OBSERVAÇÃO: As configurações da imagem exibida não têm efeito ao salvar a última imagem obtida a partir do Painel de imagens (através de arrastar e soltar). A última imagem é sempre salva em tamanho total (resolução máxima do dispositivo).

  • tamanho: Por padrão, o Setup Tool exibe um terço de todos os pixels de cada imagem adquirida ou uma fração de cada imagem durante a Visualização ao vivo. A escolha entre os tamanhos da imagem permite ao leitor realizar uma subamostra de cada imagem, o que pode melhorar drasticamente a velocidade de transferência da imagem do leitor para o Setup Tool com o comprometimento de alguns detalhes da imagem.

  • qualidade: Disponível apenas se você estiver usando um formato de imagem .jpeg, este controle deslizante ajusta os parâmetros internos que permitem ao leitor realizar uma operação regular na imagem obtida capaz de reduzir ou melhorar a velocidade de transferência do leitor para o Setup Tool.


Onde é possível aprender mais sobre o uso do UltraLight?

Para uma visão geral completa das funções disponíveis no UltraLight, consulte o vídeo tutorial do UltraLight disponível em <a>http://www.cognex.com/</a>.


Como especificar uma região de interesse dentro de cada imagem adquirida?

Altere suas configurações no painel Tamanho da imagem (região de interesse).


O que é a intensidade do Laser?

Você pode selecionar nessa caixa suspensa se deseja usar o leitor com laser Classe 2 ou com um tipo reduzido (laser 1M) que seja seguro em todas as condições normais de uso.


O que é UltraLight?

O sistema Ultralight fornece duas fontes de iluminação controláveis independentes:

  • Quatro quadrantes de LEDs fora de eixo controláveis individualmente, com ângulo curto que fornece iluminação de campo escuro, o que poderá ajudar a imagem traçada ou marcas incisivas em superfícies reflexivas.

  • Uma fonte de iluminação no eixo altamente difusa, única, que fornece iluminação de campo claro, o que é apropriado para a leitura de códigos de contraste alto e baixo em muitos tipos de superfície.


Por que o quadrante superior do UltraLight não está ligado?

Na maioria dos casos, os operadores tendem a segurar o leitor em um ângulo na superfície que está sendo lida. Ao desabilitar o quadrante de iluminação superior, os reflexos e brilhos são minimizados.

O leitor é enviado com os valores padrão para cada um dos quatro ajustes, mas apenas o primeiro ajuste, Objetivo geral é habilitado. O ajuste de objetivo geral habilita apenas as luzes de ângulo baixo leste, sul e oeste. Você pode modificar este ajuste para habilitar todos os segmentos de iluminação fora de eixo.


Como mudar a intensidade das luzes?

Use os controles do cursor em Intensidade da guia de iluminação e Intensidade do campo claro para ajustar a intensidade de iluminação no nível desejado. Use o botão Reinicializar na parte inferior do painel de tarefas para voltar aos ajustes padrão de fábrica, se desejado.


O que é a Visualização ao vivo?

Se você habilitar a Visualização ao vivo (clicando no ícone Visualização ao vivo na barra de tarefas superior ou na guia Ação), a visualização da imagem exibe continuamente o que o leitor vê. Você pode usar este modo para verificar o que o leitor está vendo, sem tentar decodificar símbolos.

Para alterar a qualidade e o tamanho da imagem exibida ao vivo, acesse o painel Configurações da imagem visualizada.

OBSERVAÇÃO: Essa opção não está disponível em DM262 e DM362.


Como posso aumentar a velocidade de transferência da imagem?

Se a caixa de seleção Transferir e visualizar imagem estiver marcada, o Setup Tool transferirá a imagem adquirida para cada operação de decodificação. Se um novo disparo for recebido enquanto a imagem atual está sendo transferida, o leitor descartará a imagem transferida parcialmente e iniciará a transferência da nova imagem.

A velocidade de transferência da imagem depende do grau de compactação de imagem realizada pelo leitor. Controle o valor de compactação da imagem, selecionando a opção Configurações da imagem visualizada. A redução do tamanho da imagem ou da qualidade da imagem aumentará a taxa de transferência.


Marquei a opção "Transferir e visualizar imagens". Por que não visualizo uma imagem?

Se você interromper a transferência da imagem clicando no Disparo, então nenhuma imagem será transferida. Além disto, imagens mais antigas na grade Histórico de leitura podem não incluir imagens.

Observação: Se o Atraso de saída for mais curto do que a necessidade de o leitor de adquirir uma imagem e decodificar qualquer resultado, o Setup Tool poderá não receber imagens de resultados do leitor.


Detalhes do código


Qual a maneira mais rápida para desabilitar todas as simbologias?

Clique em Desabilitar todas as simbologias na parte superior da guia Básicas, no passo do aplicativo Detalhes do código, ou pressione Ctrl+D.


Como ajustar as configurações avançadas de simbologia?

Clique na guia Avançadas em Detalhes do código para especificar configurações mais detalhadas.


O leitor discrimina automaticamente tipos de simbologia diferentes?

O leitor detecta e decodifica automaticamente símbolos codificados usando qualquer das simbologias habilitadas no Setup Tool.


O leitor melhora o desempenho limitando o número de simbologias habilitadas?

Para melhor desempenho, habilite apenas os tipos de simbologia que você esperar encontrar.


Propriedades DataMatrix: O que é a Dificuldade do símbolo?

A Dificuldade do símbolo controla a configuração da dificuldade que o leitor emprega para decodificar cada imagem. A configuração Fácil decodificará códigos bem impressos de alto contraste e maximizará a definição de leitura. A configuração Difícil decodificará códigos DPM difíceis de ler, mas com tempos de resposta mais lentos.


Quais são as possíveis configurações para as propriedades do EAN.UCC Composite?

  • Padrão (linear e 2D): Consiste de um componente linear (codificação da identificação primária do item) associado com um componente de composição 2D adjacente (dados suplementares de codificação, como o número de grupo ou data de vencimento)

  • Apenas linear: Consiste apenas da codificação do componente linear na identificação primária do item.


O que é CC-C?

CC-C é um dos três componentes do EAN.UCC 2D Composite, especificamente um símbolo PDF417 com uma palavra código de 920 na posição da palavra código do primeiro dado como uma bandeira de conexão e denotando a compactação de dados EAN.UCC.


O que são as métricas de qualidade DataMatrix?

Para obter informações sobre as métricas de qualidade de código, consulte o Guia de programação e configurações do DataMan®.


Propriedades de simbologia 1D: O que é a função decodificação do alvo?

A decodificação do alvo simula o comportamento de um scanner de código de barras a laser. Em vez de olhar para todo o campo de visão, todavia, o leitor tenta decodificar os códigos de barra 1D que ficam apenas sob o ponto alvo a laser. Isto evita que o operador leia acidentalmente outros códigos de barra 1D que estejam ao redor.


Propriedades de simbologia 1D: O que é a opção Área silenciosa pequena?

Como padrão, a opção Área silenciosa pequena é habilitada para permitir alguma flexibilidade de busca em relação à área silenciosa destes símbolos 1-D: Código 128, código 39 e código 93.


Propriedades de simbologia 1D: Como configurar a Decodificação mínima antes da saída?

Configure um número alto para aumentar a robustez da decodificação. Configure um número baixo caso a sua prioridade seja a velocidade de desempenho.


Vantagem de especificar um tamanho de código

A especificação de um tamanho de código explícito pode melhorar a habilidade do leitor de decodificar os símbolos com confiabilidade. Selecione Qualquer se você está lendo tamanhos de códigos diferentes.


Propriedades do código 39

  • O ASCII completo habilita os códigos 39 estendidos.

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.

  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.

  • Se marcada, a opção Converter para Código 32 converte o conjunto de caracteres do Código 39 para o Código 32.


Propriedades de Intercalado 2 de 5

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.

  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.


Propriedades de Pharmacode

Vantagem de especificar um tamanho de código e uma orientação

Especificando um tamanho de código e orientação explícitos pode melhorar a habilidade do leitor para decodificar símbolos confiáveis.

O número dos caracteres de dados e o número de barras em qualquer símbolo

Caracteres de dados: Barras

  • 1: 3 Observação: o único código de caractere 1 que o leitor lê é o código com 3 barras ou mais. Isto significa apenas 6, 7, 8 e 9.

  • 2: 3 a 6

  • 3: 6 a 9

  • 4: 9 a 13

  • 5: 13 a 16

  • 6: 16


Propriedades da Codabar

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.
  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.
  • A opção Transmitir caracteres de início e de parada inclui os caracteres de início e de parada com os dados decodificados.


Propriedades MSI

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.
  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.
  • Método de cálculo de soma de verificação permite que você selecione o método usado para o cálculo da soma de verificação.


Propriedades da barra de dados

  • GS1 DataBar Limited: Codifica uma identificação de item EAN.UCC de 14 dígitos com dígitos indicadores de zero ou um em um símbolo linear para uso em itens pequenos que não serão lidos no ponto de venda

  • GS1 DataBar: Codifica a identificação do item EAN.UCC de 14 dígitos completo em um símbolo linear que pode ser digitalizado omnidirecionalmente pelos scanners programados adequadamente no ponto de venda

  • GS1 DataBar Expanded: Comprimento variável, versão expandida da simbologia capaz de codificar o GTIN de 14 dígitos e dados adicionais incluindo datas de vencimento, o país de origem e números de série – até 74 caracteres numéricos ou 41 alfabéticos.


Propriedades postais

  • POSTNET: A simbologia do código de barras que é usada no serviço postal dos Estados Unidos para ajudar a direcionar as correspondências. O cep ou código postal+4 está codificado nesta simbologia única que decodifica dados em barras de diferentes alturas.

  • PLANET: O código de barras da técnica de codificação alfa-numérica postal (PLANET) é usado para o serviço postal dos Estados Unidos identificar e pesquisar peças de correspondências durante a entrega. Como o POSTNET, ele codifica os dados em barras de diferentes alturas.

OBSERVAÇÃO: Os códigos postais somente podem ser decodificados quando apresentados em posição horizontal.


Versões do código de resposta rápida (QR) suportadas

O código de resposta rápida (QR) é uma simbologia 2D que contém uma sequência de módulos quadrados escuros e brancos usados para codificar dados. O leitor pode discernir entre três tipos diferentes:

  • modelo-1 Versão original

  • modelo-2 Versão melhorada

  • Código MicroQR: Um código QR muito pequeno que se encaixa em certas aplicações, necessitando de um espaço menor e usando quantidades menores de dados que outras versões de código QR


Propriedades do código QR: O que é a Dificuldade do símbolo?

A Dificuldade do símbolo controla a configuração da dificuldade que o leitor emprega para decodificar cada imagem. A configuração Fácil decodificará códigos bem impressos de alto contraste e maximizará a definição de leitura. A configuração Difícil decodificará códigos DPM difíceis de ler, mas com tempos de resposta mais lentos.


Propriedades do código QR

Tamanho máximo da grade

O Tamanho máximo da grade permite decodificar códigos QR que maiores que o tamanho 49. Você pode arrastar o controle deslizante ou digitar um tamanho de código específico na caixa de texto à direita.

Métricas de qualidade do código QR

Para obter informações sobre as métricas de qualidade de código, consulte o Guia de programação e configurações do DataMan®.


Propriedades DotCode

Especificar o número de linhas e colunas de dados

A especificação do número mínimo e máximo de linhas e colunas de dados pode melhorar a capacidade do leitor de decodificar símbolos de forma confiável.

Configuração de polaridade

É possível configurar o que o dispositivo define como módulo (ponto) em relação a seu plano de fundo. A configuração Escuro no claro significa que o dispositivo faz a varredura e decodifica os pontos escuros em um plano claro, enquanto Claro no escuro significa o oposto (pontos claros em um plano de fundo escuro).

A configuração padrão Qualquer um faz a varredura de ambos os tipos de módulos, em seus respetivos planos de fundo, porém isso pode conduzir a uma decodificação um pouco mais lenta.


Quais são os ajustes diferentes para as propriedades UPC/EAN?

  • Expandido habilita a decodificação dos símbolos expandidos.

  • Suplementar controla como o leitor decodifica os códigos suplementares.

  • Excluir os zeros à esquerda exclui os zeros à esquerda das cadeias decodificadas.

  • Permitir EAN8 suplementares habilita a decodificação dos códigos suplementares em símbolos EAN8.

  • UPCE1 habilitado habilita a decodificação dos símbolos UPC E1.


Propriedades UPC/EAN: O que a caixa de seleção Expandida significa?

Ela representa um valor booleano para indicar se a cadeia decodificada para UPC-EAN reportada deve ser expandida para um formato EAN13 de 13 dígitos ou transmitida no formato padrão UPC-E de 6 dígitos.

Quando marcada (padrão), a cadeia decodificada é transmitida no formato EAN-13, em 13 dígitos (p. ex. 0012345000065). Quando desmarcada, o resultado é transmitido como <sistema numérico> + 6 dígitos de dados + <caractere de verificação> (p. ex. 01234565).


Detalhes do aplicativo


O que posso configurar no passo Detalhes do aplicativo?

Na guia Básicas, podem ser definidas as configurações do disparo e as configurações de exposição. Para um uso fácil, um Assistente de disparo, um Assistente de intervalo e um Assistente de exposição ajudam-no com estas configurações.

Na guia Avançadas podem ser implementadas configurações mais detalhadas em visualização de tabela.


Quais são os tipos de disparo?

  • O disparo de Apresentação busca continuamente por um símbolo e decodifica-o cada vez que um é detectado. Um disparo de apresentação usa um mecanismo interno de temporização e de detecção de movimento para o leitor.

    Você pode especificar vários parâmetros no modo de apresentação, por exemplo, se o leitor vai ler o mesmo código mais de uma vez ou por quanto tempo deve aguardar antes de fazer a leitura do próximo código. Use as opções Configurações de decodificação no painel Configurações do sistema para configurar o disparo de apresentação.

    No modo de apresentação, use as configurações de Exposição automática para fazer com que o leitor determine as melhores configurações de exposição para um nível desejável de brilho na imagem. Observe, entretanto, que o leitor usa as imagens iniciais adquiridas para determinar estas configurações, e pode perder imagens que contenham um símbolo para decodificação. Você pode mudar para configurações de Exposição manual e especificar uma configuração precisa para a exposição do processador de imagens.

    • Encaixe o leitor na estação de base.
    • Mude para o modo de disparo Manual em Setup Tool e, em seguida, altere novamente para o Modo de apresentação.
    • Faça a varredura do Código de configuração do leitor Inserir apresentação.

  • O disparo Manual começa a adquirir imagens em resposta a qualquer um dos seguintes eventos:

    • Pressionando o botão no leitor

    • Enviando o comando de controle Disparo do DataMan (DMCC) quando conectado ao leitor por uma conexão USB ou serial

    • Clicando no botão Disparo no Setup Tool

    • Pressionando Ctrl+T no teclado quando o Setup Tool obtiver o foco

    O leitor continua a adquirir imagens enquanto o sinal continuar ativo e para quando um símbolo é encontrado e decodificado ou o sinal do disparo termina.

=


Assistente de disparo

Você precisa selecionar primeiro o tipo de disparo para que este assistente funcione. Selecione a fonte do disparo a partir da lista suspensa: Indefinido, Nenhum ou Externo. Você recebe uma recomendação do assistente para os modos de disparo. As apresentações gráficas dos tipos de disparo ajudam-no a decidir. Selecione o tipo de disparo escolhido e clique em Salvar e fechar.


Assistente de intervalo

No caso dos modos Burst, Automático e Contínuo, o Assistente de intervalo pode ajudá-lo a efetuar configurações mais detalhadas. Você pode selecionar três maneiras de calcular os dados necessários. No canto superior direito, selecione as unidades (padrão ou métricas) em que você deseja calcular.

Clique em Campo de visão para calcular o tempo de intervalo mais longo possível, medindo o campo de visão físico e inserindo a velocidade linear máxima e o tamanho do código mais longo.

Clique em Lente / Distância até o código se você desejar inserir a distância do código a partir da lente. Insira a distância focal a partir da caixa suspensa e selecione a direção na qual o código está se deslocando. Você também precisa inserir aqui a velocidade linear máxima e o tamanho do código mais longo.

Clique em Tamanho do elemento de código para calcular com o tamanho do elemento de código mais restrito. Habilitar o Modo de teste para ler seu código. Você também precisa inserir a direção na qual seu código está se deslocando, a velocidade linear máxima e o tamanho do código mais longo.

No lado inferior do Assistente, você pode obter o tempo de intervalo máximo recomendado.


Assistente de exposição

O Assistente de exposição é muito semelhante ao Assistente de intervalo. Você pode selecionar as mesmas três maneiras para seus cálculos: tamanho do campo de visão, distância até o código e tamanho do elemento de código.

Clique em Campo de visão para calcular o tempo de exposição máximo recomendado, medindo o campo de visão físico e inserindo a velocidade linear máxima. Você pode habilitar o Modo de teste para ler seu código menor.

Clique em Lente / Distância até o código se você desejar inserir a distância do código a partir da lente. Insira a distância focal a partir da caixa suspensa e selecione a direção na qual o código está se deslocando. Você também precisa inserir aqui a velocidade linear máxima.

Clique em Tamanho do elemento de código para calcular com o tamanho do elemento de código mais restrito. Habilitar o Modo de teste para ler seu código. Você também precisa inserir a direção na qual seu código está se deslocando e a velocidade linear máxima.

No lado inferior do Assistente, você pode obter o tempo de exposição atual e o recomendado.


Mais imagens serão obtidas quando ocorrer uma leitura válida?

Não, imagens adicionais serão obtidas conforme as leituras de configurações anteriores falharem. Se uma configuração produzir uma imagem válida, o leitor não tentará outras configurações durante este ciclo do disparo e a decodificação começará. O leitor testará cada configuração habilitada em ordem de prioridade, começando pela configuração de prioridade mais alta especificada e avançando até que uma leitura válida seja adquirida.


Qual é a diferença entre a opção Após a primeira leitura e Após atraso da última leitura?

O atraso Após a primeira leitura começa a contar após a primeira vez que um determinado código é lido; o cronômetro não reinicializa. Isso significa que um código pode ser lido novamente se o leitor for disparado em um modo de várias imagens, como contínuo, e se o código permanecer na frente do leitor por um tempo igual ou superior ao Atraso da releitura.

Após a última leitura redefine o cronômetro a cada vez que um determinado código é exibido em uma imagem. Isso significa que o código não será lido novamente, desde que permaneça em frente ao leitor. Somente quando o código for removido do campo de visão do leitor durante um tempo igual ou superior ao Atraso da releitura do código o código será lido novamente.


Meu código é lido duas vezes se eu disparo o leitor novamente. Por quê?

As opções Atraso da releitura e Nunca ler o mesmo código duas vezes afetam apenas aquisições realizadas dentro de um único ciclo do disparo. O disparo do leitor zerará os cronômetros e o último código de leitura da opção Nunca ler o mesmo código duas vezes.


O que faz a opção Nunca ler o mesmo código duas vezes?

A opção Nunca ler o mesmo código duas vezes suprime o relatório da mesma cadeia de códigos duas vezes seguidas e dentro de uma sequência única de disparo, quando habilitada. Está disponível para todos os modos de disparo, mas só é válida na Leitura de códigos múltiplos, pois a única forma de obter mais do que um código em uma sequência única de disparo é em leituras de códigos múltiplos. Se a caixa de seleção Nunca ler o mesmo código duas vezes for desmarcada, o leitor relerá e retransmitirá o mesmo código depois do Atraso da releitura do código especificado (em milésimos de segundo).


O que são Modo de atraso e Atraso da releitura do código?

A opção Modo de atraso define o atraso de releitura do código em relação à primeira leitura ou à última.

A opção Atraso da releitura do código (em milésimos de segundo) permite especificar o atraso entre as tentativas de leitura. A especificação de um valor diferente de zero para este atraso pode ajudar a evitar que os dados confundam o dispositivo que está conectado ao leitor.


O que é a Detecção de movimento?

A Detecção de movimento permite que os usuários configurem seu dispositivo para que ele comute para Apresentação ativa ou modo de disparo Automático, por um período de tempo, após ele detectar movimento no campo de visão do dispositivo.

As configurações da Detecção de movimento somente estarão disponíveis se o tipo de disparo estiver definido para Apresentação ou Automático. Quando a Detecção de movimento está habilitada, o dispositivo não está obtendo imagens, mas detecta no plano de fundo se o cenário em seu campo de visão está em movimento ou não.

Se ele estiver em movimento, o dispositivo adquire imagens ativamente segundo o modo de disparo de Apresentação ou Automático. A configuração Tempo de espera permite que você especifique o período de tempo (em segundos) após o qual o dispositivo comuta novamente para a Detecção de movimento a partir do disparo ativo, porém esse Tempo de espera reinicializa cada vez por meio do movimento ou de uma boa leitura.

A Sensibilidade de detecção de movimento pode ser configurada para definir como o dispositivo reconhece os movimentos substanciais, para ligar os modos de disparo de Apresentação e Automático ativos.


Como enviar um disparo pelo teclado?

Pressione <ctrl>-T (A janela do Setup Tool deve estar ativa).


Como ajustar a exposição da imagem?

Os tipos de disparo manual e de apresentação usam as configurações de Exposição automática para determinar automaticamente as melhores configurações para um nível desejado de brilho em cada imagem. Usando qualquer um destes tipos de disparo, você pode usar os ajustes de Exposição máxima da forma necessária para seu ambiente de produção ou selecionar Exposição manual e ajustar um tempo de exposição preciso, em microssegundos. O controle deslizante Ganho (abaixo da área de visualização de imagem) indica o brilho do pixel do alvo.


Quais Configurações da iluminação e do processador de imagens o leitor usa?

Você pode configurar quatro ajustes de leitura diferentes. Quando você tentar ler um código, o leitor usa cada configuração habilitada por sua vez, para tentar ler o código. Para habilitar uma configuração, clique na configuração de luz nas Configurações de leitura ou selecione a configuração no painel Configurações de leitura. Os ajustes ativados são marcados com uma luz verde.

Quando você inicia uma nova leitura, o leitor sempre começa com a configuração usada mais recentemente, se várias configurações estiverem habilitadas. O leitor troca de configuração com base no número de tentativas de decodificação, ou seja, na configuração padrão o leitor irá para a próxima configuração após 2 ou 3 decodificações sem sucesso. Altere o número de tentativas de decodificação selecionando o painel Configurações do disparo no grupo Configurações do sistema no modo de exibição em árvore.


Que ajuste deve ser usado para marcas de martelamento a frio?

Se suas marcas puncionadas estiverem em uma superfície altamente refletora, use a configuração Micropercussão – difícil ou a Superfície texturizada. De outra forma, o ajuste Objetivo geral deve ler a maioria dos códigos puncionados.


É possível habilitar todas as configurações?

Você deve habilitar apenas os ajustes que são adequados para sua parte e marcas. Lembre-se que o leitor circula por todas as configurações habilitadas quando você tentar ler um código. Quantos mais configurações forem habilitadas, mais tempo o leitor pode levar para ler um código.

Por padrão, todas as configurações de leitura estão habilitadas. Certifique-se de habilitar as configurações de qualidade do código desejadas para todas as configurações de leitura habilitadas, de outra forma, a métrica de qualidade 1D não retornará os dados.


Como mudar a configuração que está habilitada sem executar o Setup Tool?

Faça a leitura do documento Códigos de configuração (disponível através do menu Iniciar do Windows ou no menu Ajuda do Setup Tool) para acessar os códigos que você pode ler a qualquer momento para habilitar uma configuração única (e desabilitar os outros 3).


Como é possível ligar e desligar rapidamente todas as luzes do leitor?

Clique com o botão direito do mouse na imagem que exibe os quadrantes de luz. É possível selecionar estas opções:

  • Todos ligados

  • Todos desligados

  • Norte-Sul

  • Leste-Oeste

As alterações serão válidas imediatamente de acordo com a sua seleção.


Dados do formato


Como a formatação de dados trabalha?

No painel Básicas você pode selecionar que tipo de formatação pretende usar.

Você usa o painel Padrão para construir uma cadeia de saída personalizada, usando os blocos de criação predefinidos nas guias de simbologia individual:

  • A cadeia de saída inicia com qualquer texto que seja inserido no campo Texto principal.

  • Selecione os itens das listas nas guias Geral, Validação e (quando aplicável) Métricas e clique em Adicionar para adicioná-los à cadeia de saída. Para adicionar um intervalo específico de caracteres a partir do dado decodificado, clique em Ajuste o intervalo da subcadeia, depois insira o intervalo de caracteres a adicionar (assim como 1-3,5,8,10-), depois clique em Subcadeia na lista e clique no botão Adicionar.

  • A cadeia de saída inclui também qualquer texto que você adiciona ao campo Texto de finalização.

  • Para terminar toda a cadeia com um retorno de carro/alimentação de linha, marque a caixa de seleção Retorno de carro/aliment. de linha.


Por que existem guias diferentes embaixo da guia Padrão?

Você pode especificar a formatação separadamente para os tipos de simbologia diferentes ou usar a guia Universal para especificar a formatação de dados para algum símbolo decodificado, que tem precedência sobre as guias para os tipos de simbologia específicos.


Como posso usar a formatação universal e a simbologia específica?

O painel Formatação padrão emprega os seguintes critérios quando usa as guias específicas de simbologia e a guia Universal:

  • Cada resultado individual passará através do formatador específico da simbologia, se habilitado. Os resultados múltiplos de mesma simbologia serão formatados separadamente com as configurações idênticas.

  • Se a guia Universal for habilitada, os resultados individuais passarão pelo formatador específico de simbologia, se habilitado, e depois serão aumentados com a formatação das regras na guia Universal. Para resultados múltiplos (nos leitores suportados), os resultados serão concatenados e separados pelo delimitador escolhido, sem qualquer delimitador extra no final. A cadeia concatenada será tratada como uma cadeia simples para as regras de formatação restantes na guia Universal.

  • Para resultados múltiplos, a ordem dos resultados em uma cadeia concatenada é 1) DataMatrix 2) Código QR 3) Códigos 1D 4) Vericode 5) DotCode 6) OCR.

  • Qualquer token adicionado à formatação específica de simbologia, que é válido apenas para o processo de decodificação geral (assim como o tempo de decodificação ou índice do disparo), informará este valor global.


Quais dados são enviados se a Formatação padrão não estiver habilitada?

O leitor transmite toda a cadeia decodificada seguida pelo par de retorno de carro/alimentação de linha.


Como enviar apenas os dados decodificados sem o par de retorno de carro/alimentação de linha?

Habilite a formatação, adicione a Cadeia completa na cadeia de saída e certifique-se que a caixa de seleção Retorno de carro/aliment. de linha não está marcada.

Para enviar apenas o retorno do carro, entrar \r no campo Texto de finalização.


O que é Série de entrada?

Série de entrada é um token de formatação que você pode incluir como parte das propriedades do leitor na formatação baseada em script ou como um símbolo de Formatação de dados padrão. Observe que você não pode alterar nenhuma outra propriedade da série de entrada no Setup Tool; os parâmetros dela estão disponíveis apenas em DMCC.


Como impedir o Excel de saltar as células?

Como padrão, o leitor acrescenta o par retorno de carro/alimentação de linha depois de cada código transmitido. Quando você usa uma conexão de teclado para inserir os códigos transmitidos em Excel, o par de retorno de carro/alimentação de linha faz com que Excel avance por duas linhas depois de cada código. Para evitar que isto aconteça, configure o leitor para enviar apenas o retorno de carro:

  1. Clique em Formatação padrão.

  2. Especifique a simbologia que você está usando nas guias de Simbologia.

  3. Marque a caixa Formatação habilitada.

  4. Clique em Cadeia completa na guia Geral.

  5. Clique em Adicionar.

  6. Em Texto de finalização, insira \r no campo de texto e desmarque a caixa Retorno de carro/aliment. de linha.


Como fornecer elementos específicos dos dados codificados quando a validação de dados é habilitada?

Primeiro, selecione o tipo de validação necessário no painel Validação de dados. Habilite a Formatação básica na guia Básicas do passo do aplicativo Dados do formato. Selecione a guia Validação da guia Padrão e depois adicione o(s) campo(s) de dados desejado(s) para a cadeia de saída, incluindo o identificador da empresa, número de série, número de peça, item único e identificadores do aplicativo GS1.


Quais são as opções individuais na guia Geral, no campo Dados da guia Padrão?

  • Subcadeia: Uma subcadeia de caracteres codificados no símbolo. Especificar um intervalo na subcadeia para usar esta opção.

  • Cadeia completa: Todos os caracteres codificados no símbolo

  • Tempo de decodificação: A quantidade de tempo, em milésimos de segundos, que o leitor leva para decodificar o símbolo. Este período de tempo não inclui a aquisição de imagem, processamento da imagem pendente, tempo de comunicação e processamento adicional (por exemplo, formatação de dados).

  • Tempo do disparo: A quantidade de tempo, em milésimos de segundos, entre o momento que o disparo foi recebido e quando a operação do decodificador foi completada.

  • Simbologia: A simbologia do símbolo decodificado

  • Retorno de carro/aliment. de linha: Retorno do carro com uma alimentação de linha

  • INDICADOR: Um caractere do indicador.

  • SP: Um caractere do espaço.

  • Identificador da simbologia: O identificador da simbologia como especificado pela ISO/IEC 15424:2008

  • Tamanho do módulo: A largura (ou altura), em pixels, de cada módulo no símbolo

  • Posição do código: As coordenadas da imagem de cada canto do símbolo decodificado

  • Orientação do código: A orientação, indicada em graus, do símbolo decodificado. Rotações no sentido horário do símbolo decodificado são consideradas mudanças positivas na orientação.

  • Contraste: Um valor, entre 0 e 1, para indicar a quantidade total de contraste no símbolo decodificado. Um valor alto indica que os módulos escuros e iluminados no símbolo possuem um intervalo de valores cinza, enquanto um valor baixo indica que os módulos escuros e iluminados apresentam valores cinzas similares.

  • UEC: A quantidade de correções de erro não usadas disponíveis no símbolo. Correção do erro é um método de reconstrução ou substituição de dados que são perdidos através de danos no símbolo. Um valor de "100" é ideal. A simbologia 1D sempre -1.

  • Série de entrada: A série de entrada (serial ou Ethernet) recebida.

  • Tempo de filtro: A duração da filtragem em milésimos de segundo (ms).

  • Origem do resultado: O nome do dispositivo.

Todos os valores a seguir aumentarão independentemente de o leitor estar ou não conectado ao Setup Tool.

  • Total de leituras: Número total de símbolos decodificados

  • Total de imagens sem leitura: Número de vezes que o disparo foi recebido mas nenhum símbolo foi decodificado

  • Total de disparos: Total de disparos= Total de leituras + Total de imagens sem leitura + Total de disparos perdidos

  • Disparos perdidos: Número de disparos perdidos porque nenhum buffer de imagem estava disponível quando o disparo foi detectado

  • Índice do disparo: Número total de disparos detectados pelo leitor.

Os valores que serão redefinidos para 0 quando a opção Estatística do processo for apagada do painel Monitor de processo ou após a reinicialização do leitor são os seguintes:

  • Total de leituras

  • Total de imagens não lidas

  • Total de disparos

  • Disparos ignorados

O Índice do disparo será redefinido para 0 somente após a reinicialização do leitor, mas não depois que a opção Estatística do processo for apagada.


Como simular combinações com a tecla Alt, Ctrl ou Shift?

Para usar este recurso, estão disponíveis quatro sequências de escape, \ALT-, \CTRL- \SHIFT- e \K. \ALT- é usado para sequências de tecla ALT, \CTRL- é usado para sequências de tecla CTRL>, \SHIFT- é usado para sequências de tecla SHIFT e \K para teclas especiais. Observe que a tecla depois da barra invertida precisa estar em letra maiúscula, caso contrário nenhuma combinação especial de teclas será reconhecida.

As sequências são inseridas nos campos Texto principal/Texto de finalização do painel Padrão.

Sequências especiais do teclado suportadas

O seguinte formato deve ser usado:

\ALT- seguido pelo nome da tecla, seguido por ;

ou

\CTRL- seguido pelo nome da tecla, seguido por ;

ou

\SHIFT- seguido pelo nome da tecla, seguido por ;

ou

\K seguido pelo nome da tecla, seguido por ;

A terminação em ponto e vírgula é necessária para se poder distinguir entre as sequências com o mesmo prefixo, de outra forma as sequências chave podem ser interpretadas arbitrariamente, por exemplo, não seria possível saber se \KF11 significa "pressione F11" ou "Pressione F1 seguido por um 1".

Certifique-se que caso estas duas sequências de escape estejam inseridas na guia Universal, elas também sejam aplicadas aos resultados não lidos.

Sequências de teclas e teclas suportadas

A lista a seguir contém as teclas/combinações de teclas suportadas atualmente:

  • ALT-A a ALT-Z

  • CTRL-A a CTRL-Z

  • CTRL-F1 a CTRL-F12

  • SHIFT-F1 a SHIFT-F12

  • F1 a F12

  • ALT-F1 a ALT-F12

  • Teclas PageUp, PageDown, Home, End, Seta (para cima, para baixo, esquerda, direita), Insert, Delete, Backspace, Tab, Esc, Print Screen, GUI (esquerda, direita)

    As sequências de escape para estas são:

    • PageUp -> \KPup;

    • PageDown -> \KPdn;

    • Home -> \KHome;

    • End -> \KEnd;

    • Seta para cima -> \KUar;

    • Seta para baixo -> \KDar;

    • Seta esquerda -> \KLar;

    • Seta direita -> \KRar;

    • Insert -> \KIns;

    • Delete -> \KDel;

    • Backspace -> \KBksp;

    • Tab -> \KTab;

    • Esc -> \KEsc;

    • Print Screen -> \KPrtScr;

    • Left GUI -> \KLGui;

    • Right GUI -> \KRGui;

  • Pause output -> \KPAUSE;

Aqui estão alguns exemplos:

  • Para gerar a sequência <ALT-V>, use \ALT-V;

  • Para simular a tecla <F10> pressionada, use \KF10;

  • Para simular a tecla <Home> pressionada, use \KHome;

  • Para habilitar/desabilitar a barra de status no bloco de notas (<Alt-v><s>), a sequência deve ser \Alt-v;s

Se uma sequência errada ou incompleta é usada, os dois caracteres que marcam a sequência de escape são ignorados. Neste caso, as primeiras duas letras da sequência de escape são puladas e os caracteres remanescente serão enviados. Por exemplo, a sequência "\ALT-M11;" é inválida e irá resultar na visualização de "LT-M11;"


Como testar minha formatação de dados?

Use o botão Testar na parte inferior da página para testar como o resultado será exibido.

Leia um símbolo e visualize o resultado formatado na barra de status. Você também pode selecionar o painel Histórico de resultados e ler um símbolo. O Histórico de resultados mostra os resultados da formatação especificada.


Qual é a característica das Opções de saída?

As características das Opções de saída possibilitam que você defina os elementos de dados de saída desejados em diferentes formatos. Como exemplo, se uma vírgula é selecionada e você selecionou um resultado de saída de uma cadeia completa, seguida do tipo de simbologia, o resultado será uma cadeia de dados completa, seguida por uma vírgula, seguida pelo texto "Datamatrix". Para testar resultados diferentes, você pode selecionar um tipo de resultado em particular e depois selecionar o botão teste para ver a saída na janela de visualização adjacente. Observe que se a validação de dados é selecionada e um código falha na validação de dados, as características das opções de saída não serão habilitadas.


Por que o botão Testar está esmaecido?

Você pode testar seu código somente após a primeira decodificação bem-sucedida.


É possível especificar os caracteres usando códigos ASCII hexadecimais ou octal?

Nos campos Texto principal e Texto de finalização, é possível especificar caracteres como \nnn em que nnn é o código ASCII octal. Você pode especificar caracteres em hexadecimais inserindo \xnn onde nn é o código ASCII hexadecimal.

Você também pode usar os seguintes códigos predefinidos:

  • \a Alerta (ASCII 7)
  • \b Retrocesso (ASCII 8)
  • \E Escape (ASCII 27)
  • \f Avançar página (ASCII 12)
  • \n Alimentação de linha (ASCII 10)
  • \t Tabulação horizontal (ASCII 9)
  • \r Retorno do carro (ASCII 13)
  • \v Tabulação vertical (ASCII 11)
  • \\ Barra invertida (ASCII 92)


O que o leitor transmite quando nenhum código é lido?

Normalmente, nenhum dado é transmitido pelo leitor se um código não pode ser lido. O histórico de resultados exibirá uma cadeia de resultado vazia e um ícone de cruz vermelha com a mensagem “Sem leitura” como Status do resultado.


O que é o resultado da Posição do código?

Para símbolos Data Matrix, a Posição do código representa a localização relatada dos quatro cantos do símbolo. O leitor retorna 4 pares de coordenadas:

  • O primeiro par representa a interseção do padrão do finder.

  • O segundo par representa a interseção do padrão do finder do ícone horizontal e o padrão de temporização vertical.

  • O terceiro par representa a interseção dos padrões de temporização (diagonal oposto ao primeiro par).

  • O quarto par representa a interseção do padrão do finder do ícone vertical e o padrão de temporização horizontal.

A Cognex recomenda a seleção de um delimitador, como uma vírgula, para separar cada valor e tornar os dados do resultado mais fáceis de ler.


Qual método de formatação de dados devo selecionar?

Você pode usar a Formatação básica (padrão ou estilo Perl) ou escrever seu próprio script em JavaScript na guia Formatação de dados do painel Geração de script. Os dois métodos diferem da seguinte maneira:

  • A formatação básica permite que você arraste e solte os elementos de formatação de dados pré-definidos.

  • A formatação por script permite que você escreva um script que, além de formatar os resultados e os dados de leitura, é capaz de fazer com que o leitor execute operações como o bipe ou saída 1.


Para que serve a guia Comunicação?

Nessa guia, você pode editar seu script de protocolo de comunicação personalizado.


Quais são as limitações da formatação por script?

Você estará limitado a ter dois eventos personalizados e a reescrever o evento do sistema na formatação por script.


Onde posso encontrar um exemplo de script?

Você terá as seguintes opções para inserir um script na janela principal do painel Script:

  • Clique no botão Inserir trecho localizado na barra de ferramentas superior e selecione o trecho da lista de acordo com as suas necessidades.

  • Clique com o botão direito do mouse na janela principal e selecione Inserir trecho.... Clique no trecho apropriado da lista, de acordo com o que precisar.

  • Pressione Ctrl-K, X

OBSERVAÇÃO: Se o botão Inserir trecho não estiver ativo, a versão de firmware em execução no dispositivo não suporta trechos para a guia atual do script.


Para que serve a guia Armazenamento em FTP?

Essa guia é usada para a geração de nome de arquivo FTP de imagens e relatórios de qualidade de código.


Como carrego meus scripts?

Acesse-os clicando no menu de faixa de opções e, em seguida, clicando na opção Abrir script. É possível salvar seus scripts com o botão Salvar script.

OBSERVAÇÃO: A geração de script somente suporta a codificação de caracteres UTF-8!


Qual é a função da opção Completar palavra?

Complete as palavras do seu script usando os seguintes métodos:

  • clicando no botão Completar palavra na barra de ferramentas superior

  • clique com o botão direito do mouse na janela principal e selecionando Completar palavra

  • pressionando Ctrl-K, W

Em seguida, selecione a partir de uma lista de objetos para inserir no script.


Como posso editar meu script rapidamente?

Use os botões Cortar, Copiar ou Colar na barra de ferramentas superior, ou clique com o botão direito do mouse em qualquer lugar da janela principal e selecione cortar, copiar, colar, excluir ou selecionar tudo.


Por que todas as variáveis são redefinidas ao selecionar Sistema->Salvar configurações?

Sempre que um script é alterado e o foco do editor é abandonado, o script é transmitido para o leitor, causando uma invalidação de contexto do mecanismo de script. A invalidação de contexto de script faz com que todas as variáveis sejam redefinidas.


Como posso ver erros no registro do dispositivo usando scripts?

Use o comando Throw() para relatar a ocorrência de uma situação anormal (exceção) e o erro será exibido no registro do dispositivo quando o dispositivo não estiver conectado ao Setup Tool. Você pode acessar o registro de erros acessando a barra de menu do Setup Tool e clicando em Sistema e em Exibir registro do dispositivo.

Enquanto o dispositivo é conectado ao Setup Tool, a exceção é exibida abaixo do script no painel de script.


Como posso obter mais informações sobre a formatação por script?

Para obter mais informações, consulte o documento Guia de programação e configurações do DataMan, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.


Como configurar um atraso na saída de código?

Para definir uma pausa na saída de código, a sequência \Pausa<tempo>; pode ser adicionada aos campos de texto no painel Formatação de dados.

<tempo> contém um valor em milésimos de segundo; por exemplo, para aguardar 4 segundos, a sequência será \Pausa4000;.

Esse recurso pode ser usado com USB HID ou RS232. Para RS232, o recurso necessita ser habilitado, usando o comando DMCC COM.RS232-ENABLE-PAUSE. Para USB HID, ele é habilitado como padrão.


Por que existem guias diferentes ao longo do topo?

Você pode especificar a formatação separadamente para simbologia diferente ou use a guia Universal para especificar a formatação de expressão regular de estilo Perl para qualquer símbolo decodificado.


Como especificar a substituição de texto arbitrário?

Insira o texto na caixa de texto Expressão regular:. A sintaxe para a cadeia é:

        /search/replace/g

onde pesquisar é a cadeia a ser pesquisada e substituir é a cadeia para substituir com pesquisar. Por padrão, apenas a primeira ocorrência de pesquisar é substituída. Para substituir todas as instâncias, adicione g no final do comando.

Por exemplo, se o leitor decodifica esta cadeia:

        UPC 05214275600

Você pode substituir a cadeia "UPC" com a cadeia "CÓDIGO SKU", usando esta cadeia de substituição:

        /UPC/SKU CODE:/

que produziria esta cadeia de saída:

        SKU CODE: 05214275600

Você pode inserir pares de substituição múltipla separados por um espaço. Os pares múltiplos são usados em sequência: o resultado do primeiro par é usado como entrada para o segundo par e assim por diante.


O que significa "descartar dados não correspondentes"?

Por padrão, qualquer texto que não faça parte da cadeia de correspondência é passado como não alterado. Se você marcar Descartar dados não correspondentes, então apenas a cadeia resultante da substituição é enviada.


Quais caracteres especiais precisam ser evitados?

Os seguintes caracteres têm um significado especial na cadeias de pesquisa e substituição:

            ˆ  . , (  )  [  ] $ \ / * + |

Se você deseja incluir algum destes caracteres em sua cadeia de pesquisa ou substituição, você deve precedê-los com um caractere de barra invertida \. Para incluir um caractere de barra invertida, insira \\. Para inserir um caractere ASCII arbitrário, insira \xhh onde hh é o valor do caractere hexadecimal (você não pode usar \ooo para especificar os valores ASCII octais).


Como usar um curinga para corresponder caracteres ou padrões diferentes?

Você pode corresponder qualquer caractere único, qualquer caractere de um conjunto de caracteres, qualquer caractere de uma gama de caracteres ou qualquer caractere que não está dentro da gama de caracteres usando estes caracteres especiais na cadeia de pesquisa:

. Corresponda qualquer caractere único

[abcd...] Corresponda qualquer caractere único do conjunto a, b, c, d...

[a-z] Corresponde a qualquer caractere único dentro da gama de caracteres a até z (letras ou números podem ser usados)

Para inverter o sentido de um curinga usando um conjunto ou cadeia de caracteres, preceda-os com um caractere ^.

Para corresponder um número variável de caracteres, adicione um dos seguintes caracteres modificadores para o caractere ou curinga que está sendo correspondido:

+ corresponde a um ou mais dos caracteres anteriores

* corresponde a zero ou mais dos caracteres anteriores

? corresponde a zero ou um dos caracteres anteriores

{n} corresponde a n vezes do caractere anterior

{n,m} corresponde ao menos a n mas não mais que m vezes do caractere anterior

{n,} corresponde ao menos a n vezes do caractere anterior

Aqui estão alguns exemplos de correspondência do curinga:

/A.B/AB/g remove qualquer caractere único entre 'A' e 'B' na cadeia de entrada

/A.*B/AB/g remove qualquer número de caracteres entre 'A' e 'B' na cadeia de entrada


Existem curingas para a correspondência de caracteres especiais?

Use as seguintes sequências de escape para corresponder caracteres especiais e tipos de caracteres:

\n um caractere de nova linha

\w um caractere alfanumérico (letra ou dígito)

W um caractere não alfanumérico

\s um caractere de espaço em branco

\S um caractere de espaço não em branco

\d um dígito

\D um não dígito

Você pode usar estes caracteres em combinação com os curingas correspondentes com caracteres múltiplos listados no item anterior.


Como ancorar a cadeia de pesquisa?

Preceda à cadeia de pesquisa com um ^ para fazer a correspondência apenas no início da cadeia. Preceda à cadeia de pesquisa com um $ para fazer a correspondência apenas no final da cadeia.


Como reutilizar partes da cadeia de pesquisa na cadeia de resultados?

Anexe a parte ou partes da cadeia de pesquisa que você deseja usar na cadeia de resultados em parênteses. Você pode consultar as cadeias anexas na cadeia de resultado usando os tokens \1, \2 e assim por diante.


Existe um tamanho máximo para Expressões regulares de estilo Perl?

O tamanho máximo do script inserido em qualquer guia é de 512 caracteres, mas a guia específica de simbologia será executada antes da guia universal. Se as duas forem usadas simultaneamente, um script de até 1024 caracteres poderá ser gravado.


Como posso obter mais informações sobre as expressões regulares de estilo Perl?

Aqui. Observe que nem todas as funções descritas nesta página são implementadas pelo leitor.


Entradas / Saídas


O que pode ser alterado nas configurações do botão CALIBRAGEM?

Você pode definir qual entrada o dispositivo usa quando o botão Calibragem é pressionado sobre ela. Como padrão, o botão Tentativas de leitura estendidas do DataMan 8600 é usado para Otimização de calibragem. A Otimização de calibragem escolhe automaticamente a melhor Configuração de leitura para a decodificação atual e define-a como uma Configuração de leitura 4 oculta, no DataMan Setup Tool, bloqueando Simbologia, Exposição, Configurações de iluminação, Foco, etc, enquanto as outras Configuração de leitura são desabilitadas. Isso fornece uma leitura mais rápida para casos de utilização onde o mesmo tipo de código é lido repetidamente.

Para executar a Otimização de calibragem, pressione e mantenha (pressionado) o botão Tentativas de leitura estendidas até que uma luz amarela/verde pisque, depois largue o botão. As luzes continuam piscando até o código ser lido. Quando o disparador é pressionado para ler um código, as luzes circulam, realizando um disparo burst através das Configuração de leitura habilitadas, depois para de pisca. Um bipe e uma luz verde consistente significa que a calibragem terminou e o leitor está otimizado. Você pode desfazer a calibragem mantendo pressionado o botão Tentativas de leitura estendidas, novamente, até o indicador ficar vermelho.

Também podem ser selecionadas opções de leitura alternativas, que são utilizadas pelo botão de Tentativas de leitura estendidas:

  • Treinar cadeia de correspondência: Após armar o dispositivo (mantendo pressionado o botão Tentativas de leitura estendidas) com o botão ótico, o próximo disparo define o código lido como uma Cadeia de correspondência (licença necessária para que a Cadeia de correspondência esteja disponível).

  • Habilitar verificador: Após armar o dispositivo (mantendo pressionado o botão Tentativas de leitura estendidas), o disparo habilita a verificação no código lido (licença necessária para que a verificação esteja disponível).

Para desabilitar o botão Tentativas de leitura estendidas, usar Desabilitar o botão do leitor, aqui.


O que posso configurar com a ação de pressionar o botão por 3 segundos na guia botão CALIBRAGEM?

É possível definir como o leitor reagirá ao pressionar o botão de calibragem por três segundos. Se você marcar mais opções, a funcionalidade será executada na ordem listada.


O que acontece se eu marcar a opção Desabilitar botão do leitor?

A seleção dessa opção faz com que o botão de calibragem do leitor fique desabilitado.


Qual é a função da caixa de seleção Desabilitar o botão do leitor na guia Botão CALIBRAGEM?

Se você marcar Desabilitar o botão do leitor, o leitor não iniciará mais uma leitura ou tentativa de treinamento quando o botão de pressão do leitor for pressionado. Saiba que este recurso não desabilita o botão Disparo na barra de botões do Setup Tool ou no comando do disparo serial.


Quais configurações do sistema podem ser alteradas?

É possível habilitar ou desabilitar o beeper.

A lista suspensa das Configurações do sistema na guia Avançadas permite que você controle o que o leitor faz quando lê um código, quando não consegue ler um código e quando lê um código que falha na validação.

  • Nível de som controla a densidade do tom do sinal.

  • Número de tons controla quantas vezes o sinal é ouvido.

  • Cor LED ajusta a cor visualizada pelo indicador de status do leitor (montado na parte posterior do leitor).

  • Habilitar vibração controla se uma boa leitura é assinalada por vibração.


Quais configurações do sistema podem ser alteradas?

Aqui, você pode habilitar ou desabilitar o bipe, bem como atribuir um nome personalizado ao dispositivo. Você pode também gerenciar as entradas do botão, saídas da iluminação e saídas do som.


Como reinicializar meu leitor?

Faça a leitura do comando Reinicializar scanner impresso na parte posterior do documento "Guia de consulta rápida" para reinicializar pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Faça a leitura do comando Reinicializar o scanner com os padrões de fábrica para que o leitor volte ao estado padrão de fábrica.


Por que deveria mudar o nome do dispositivo?

Dê um nome mais significativo ao seu dispositivo para seu ambiente de produção, como a localização ou a tarefa de inspeção. Use o campo Nome do dispositivo na guia Avançadas.


Como mudar o nome do dispositivo?

Para mudar o nome do dispositivo:

  1. Insira um novo nome para o dispositivo no Nome do dispositivo.

  2. A pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim.

  3. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Selecione Sistema->Salvar configurações e, em seguida, reinicialize seu dispositivo.

A próxima vez que você iniciar o Setup Tool ou clicar em Atualizar no painel Conecte-se ao leitor, ele refletirá o novo nome do dispositivo.


O que é uma Mensagem de ativação?

Se a função Enviar cadeia de diagnóstico ao ativar estiver habilitada, o leitor ou a estação de base transmitirá uma cadeia de diagnósticos sempre que o dispositivo iniciar.

Esta funcionalidade não está disponível para conexões USB. Para conexões seriais, a taxa de transmissão está automaticamente ajustada em 38.400 quando a mensagem é enviada, apesar dos ajustes realizados no Setup Tool.


Comunicações


O que posso configurar no passo do aplicativo Comunicações?

Nas três guias do passo do aplicativo Comunicações, podem ser implementadas as configurações de Ethernet e serial. Clique na guia adequada para inserir seus valores de configuração.

Na guia Avançadas podem ser implementadas configurações mais detalhadas em uma visualização de tabela.


Como mudar as configurações da porta serial do leitor?

Na guia Serial do passo do aplicativo Comunicações, insira as novas configurações. É possível também ler o documento Códigos de configuração (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool).


Quando devo usar o Modo de compatibilidade do driver USB?

Por padrão, o leitor DataMan usa um driver USB que pode ajudar o leitor a recuperar-se de um evento de descarga eletrostática (ESD). Use o Modo de compatibilidade do driver USB se você precisa estar estritamente em conformidade à especificação USB ou se você está usando um leitor DataMan junto com o produto de Cognex SensorView.

Quando você altera o modo de compatibilidade do driver USB, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e depois reinicialize seu leitor.


O que será afetado pela mudança do modo USB?

Quando você estiver conectado ao leitor por meio da conexão serial USB, poderá mudar a velocidade da conexão USB para 1.1 ou 2.0.

Quando você estiver conectado ao leitor sem fio, a alteração do modo USB não afetará a estação base. As configurações alteradas permanecerão na memória do leitor, e se você alterar o adaptador sem fio para um adaptador serial, o leitor se conectará ao modo USB selecionado (anteriormente).


Como usar o leitor em vez do teclado quando estiver conectado com USB?

Para emular um teclado USB, basta fazer a leitura do código do Teclado USB do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool) e verificar se você desconectou o Setup Tool.


O que é possível configurar com o menu suspenso Canal de comunicação usado?

Aqui, você pode definir o método de comunicação por USB. Dependendo do dispositivo utilizado, as opções a seguir estão disponíveis.

  • USB-COM apenas: Escolha essa opção para alcançar o dispositivo usando uma porta serial.

  • USB-HID apenas: Essa opção assegura que o dispositivo se comporte como um teclado USB.

  • USB-COM + USB-HID: É uma combinação dos modos acima.

OBSERVAÇÃO: No caso da opção USB-COM apenas, alguns dispositivos também podem ser listados em "dispositivos HID", mesmo que não tenham a funcionalidade HID.


Como usar o leitor em vez do teclado através do adaptador PS/2?

Para emular um teclado PS/2, você deve usar o cabo serial, fonte de alimentação externa e cabo de outro dispositivo ou programa além do teclado, como descrito no Guia de consulta rápida. Faça a leitura do código Habilitar emulação de teclado PS/2 do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool). Para instalar o adaptador PS/2, você deve desligar o seu PC da tomada. Conecte o leitor usando os cabos mencionados acima. Em seguida, ligue seu computador e o leitor emulará um teclado PS/2.


O que acontece se meu leitor não for reinicializado quando solicitado?

As mudanças nas configurações não serão aplicadas. Se você mudar de ideia, clique em Sistema e selecione Salvar configurações. Em seguida, reinicialize o leitor.


O que é enchimento zero?

O enchimento zero coloca zeros à esquerda dentro de seus dados transmitidos, o que é necessário em algumas aplicações que aceitam os dados enviados pelo leitor.


Como definir as configurações de rede do leitor?

Se você estiver usando o leitor sem fio DataMan 8000, configure as configurações de rede da estação base. Se você estiver usando um leitor com cabo, use a guia Rede para configurar as configurações de rede.

Selecione a opção Usar servidor DHCP para ter o leitor atribuído a um endereço IP por um servidor DHCP (se um estiver disponível) ou insira as configurações de rede manualmente. Entre em contato com o seu administrador de rede para obter os valores apropriados.

Quando você altera as configurações, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e depois reinicialize seu leitor.


Copiar configurações de rede do PC

Se você clicar no botão Copiar configurações de rede do PC, a partir do menu suspenso, você pode selecionar Dell GigabitEthernet, Bluetooth Device, Microsoft Wi-Fi Direct Virtual Adapter, Dell Wireless 1560 802. 11ac. Suas próprias configurações de rede do PC serão copiadas nos campos acima.


As configurações de comunicação estão sincronizadas entre o leitor e a estação base?

Coloque o leitor na estação base para que os dispositivos troquem informações e atualizem as configurações a serem sincronizadas. Se o leitor já estiver na estação base quando você alterar as configurações de comunicação, levante o leitor e coloque-o novamente na estação base.


Se o leitor se comunicar a 802.11b, ele fará com que outros dispositivos WiFi se comuniquem na velocidade 802.11b?

Como o leitor e a estação de base possuem uma conexão ponto-a-ponto e não estão conectados a uma rede WiFi de terceiros, a velocidade de comunicação entre a estação de base e o leitor não afetará outros dispositivos WiFi.


Por que todas as opções estão desabilitadas na guia WiFi?

Se o leitor já estiver associado a uma estação de base, os campos de opção estarão esmaecidos. Conecte o leitor à estação base se quiser alterar alguma configuração.


Por que todas as opções estão desabilitadas na guia Bluetooth?

Se o leitor já estiver associado a uma estação de base, os campos de opção estarão esmaecidos. Conecte o leitor à estação base se quiser alterar alguma configuração.


Como cancelar a atribuição do leitor da estação base?

Clique no botão Cancelar atribuição na caixa do grupo Estação base associada. Após clicar no botão Cancelar atribuição, a conexão com o Setup Tool será cancelada. Salve suas alterações, antes de efetuar essa operação.

Também é possível desconectar, fazendo a leitura do código de configuração Cancelar atribuição do leitor.


Para que serve a função "Nova enumeração na inicialização do firmware"?

Em alguns casos, a porta COM é enumerada, mas a inicialização do firmware leva mais tempo e os tempos de espera da porta COM são interpretados como uma conexão perdida. Para evitar esses casos, essa caixa de seleção faz com que a porta COM seja enumerada novamente depois que o firmware é reiniciado.


Protocolos industriais

Protocolo EtherNet/IP

Para habilitar o leitor a usar o protocolo Ethernet/IP, marque EtherNet/IP na caixa Protocolos industriais da guia Ethernet.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize seu leitor.

Protocolo PROFINET

Para habilitar o leitor a usar o protocolo PROFINET, marque PROFINET. Você pode inserir o nome da estação clicando na caixa Usar o nome da estação.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize seu leitor.

Protocolo SLMP

Para habilitar o leitor a usar o protocolo SLMP, marque Protocolo SLMP e, em seguida, configure os parâmetros conforme necessário.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize o leitor para o ajuste fazer efeito, tanto alternando a força do leitor ou digitalizando o símbolo Reinicializar.

Modbus TCP

Para habilitar o leitor a usar o protocolo Modbus TCP, marque Modbus TCP e, em seguida, configure os parâmetros conforme necessário.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize o leitor para o ajuste fazer efeito, tanto alternando a força do leitor ou digitalizando o símbolo Reinicializar.

EtherNet/IP, PROFINET, Protocolo SLMP ou Modbus TCP acinzentado

Apenas um protocolo industrial de Ethernet pode ser usado por vez. Quando um protocolo estiver selecionado, o outro não estará disponível.


Como usar a opção autenticar?

Quando a opção Autenticar for habilitada, o Setup Tool irá solicitar ao usuário uma senha para a conta administrador quando for feita alguma tentativa de conexão a um leitor ou a uma estação base disponível na rede.


Como estabelecer uma conexão TCP/IP?

O leitor está habilitado para estabelecer conexões TCP usando a porta 23, que é a porta padrão TCP para aplicações Telnet. Se você usar o cliente Telnet, o único parâmetro que terá que fornecer é o endereço IP do leitor. Se você estiver usando outra aplicação ou SDK para conectar, verifique se utiliza a mesma configuração de porta TCP usada pelo seu leitor. A porta TCP pode ser alterada no painel Telnet. O leitor enviará o código de saída automaticamente através da conexão. Você também pode transmitir comandos de controle DataMan (DMCC) através desta conexão.

Quando você altera a porta Telnet, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e reinicialize seu leitor.


É possível enviar mensagens a um servidor FTP?

Use a guia Imagem FTP para definir as configurações necessárias para transferir imagens para um servidor FTP. A guia contém configurações para o endereço IP e número da porta do servidor assim como uma combinação do nome do usuário e senha. Certifique-se que as imagens enviadas usando o FTP não são garantidas a serem enviadas, o que pode acontecer quando o leitor está operando em uma frequência maior e não pode agendar tempo para transferir imagens. Observe também que a transferência por meio de ligações sem fio pode ser muito mais lenta do que a comunicação por rede comum. Nesses casos, é recomendado o uso de imagens compactadas/com resolução reduzida.

A opção Nome do arquivo permite especificar o arquivo onde as imagens serão armazenadas. O campo Nome do arquivo permite a você especificar um caminho em relação ao diretório raiz do servidor FTP (por exemplo, /failed_images/image). A extensão do nome do arquivo (.jpg ou .bmp) apresentada na etiqueta após o nome do arquivo corresponde à configuração de formato da imagem no painel Configurações da imagem no buffer. Certifique-se que o leitor não crie diretórios; o diretório deve estar disponível e acessível.

O controle Valor máx. de acréscimo indica o limite do valor aumentado usado no nome do arquivo. Um valor de 0 indica que nenhum aumento será inserido e o arquivo pode ser sobrescrito.

A opção Nome do arquivo gerado pelo servidor inicia com um caminho em branco, que indica o diretório raiz no servidor FTP.

A lista Quais imagens serão transferidas permite escolher quais tipos de imagens serão enviadas para o servidor FTP. Saiba que o servidor FTP precisa suportar a transferência de imagem.


O que é o Cliente de rede?

O comportamento do Cliente de rede é um meio para que a ID do leitor DataMan abra ativamente uma conexão Ethernet com outro dispositivo da rede. Quando estiver aberta, a conexão terá o mesmo comportamento operacional básico da conexão DataMan Telnet. Ela produzirá resultados de leitura (transmitindo resultados para o dispositivo externo) e pode atuar como servidor DMCC (processando comandos recebidos do dispositivo externo).


O que é um host?

O host é o dispositivo da rede com o qual o DataMan se conectará. Especifique o endereço da Ethernet e o número da porta do dispositivo host. O endereço pode ser um nome de domínio totalmente qualificado (por exemplo: “server.mynetwork.com”) ou um endereço IP de formato de pontos decimais (por exemplo: “192.169.0.1“).


O que é a porta do cliente?

A porta do cliente é a porta Ethernet do leitor a partir da qual a conexão do cliente será originada. O valor padrão de 0 instrui o cliente de rede para usar qualquer porta disponível. Em casos especiais, você precisará definir uma porta do cliente específica. Basta definir a porta do cliente colocando o valor necessário. Observe que o caso mais comum é usar o valor padrão de 0. Se você estiver em dúvida, use o valor padrão.


Como posso estabelecer uma conexão?

O cliente se conectará com base na opção Abrir conexão selecionada. As opções disponíveis são a conexão quando o DataMan for ligado ou a conexão assim que houver atividades de dados (ou seja, a conexão quando um código for lido).


Como desligo a conexão?

Há duas opções de Fechar conexão disponíveis. A conexão pode ficar sempre aberta ou pode ser fechada após a transferência de dados for completada. Se você selecionar a opção Após a transferência de dados do leitor, poderá definir um número de segundos definidos para a conexão desligar se o leitor estiver inativo por um período de tempo. A duração do período inativo é ajustada de 1 até 3600 segundos.


O que é o Tempo limite da conexão?

O tempo limite da conexão é o período de tempo (em milésimos de segundos) que o DataMan espera para abrir a conexão. Observe que caso a opção Em inicialização estiver selecionada, o leitor continuará tentando abrir a conexão.


O que é o Atraso da reconexão?

É o período de tempo (em milésimos de segundos) que o leitor pausará antes de tentar reabrir a conexão.


O que é transmitido quando um código contém caracteres não imprimíveis?

Normalmente, os valores brutos para caracteres não imprimíveis são transmitidos.


Reparo e suporte


O que é Reparo e suporte?

A página de Reparo e suporte pode ser usada para definir as configurações de rede de um dispositivo de rede configurado incorretamente ou alterar o modo HID de um dispositivo serial para CDC.


Para que serve a opção Atualizar?

Clique no botão Atualizar para atualizar a lista de dispositivos disponíveis.


Como posso adicionar um dispositivo de rede à lista de dispositivos exibidos?

Você pode adicionar um dispositivo de rede ou editar o endereço IP de um dispositivo adicionado clicando em Adicionar dispositivo de rede. A caixa de diálogo Adicionar dispositivo de rede será aberta e você poderá fornecer o endereço IP do dispositivo. Clique em OK para salvar as alterações e exibir o dispositivo também na página Conectar.


Como editar as propriedades de um dispositivo?

Selecione um dispositivo na lista de dispositivos para ver as opções disponíveis. No painel que abrirá, você poderá editar as configurações de rede que pertencem ao dispositivo selecionado; também poderá definir uma opção de autenticação. Clique em Aplicar para salvar as alterações.


DataMan séries 60, 300, 503, 8000 e estação de base do DataMan 8000: Como usar a opção Adicionar dispositivo?

A opção Adicionar dispositivo permite que você adicione manualmente o seu DataMan à lista de Dispositivos de rede, de modo que possa conectar o leitor ou a estação base DataMan ao Setup Tool pela rede Ethernet, em vez de usar portas de comunicação em seu PC.

Você deve ter o endereço IP do leitor ou da estação base para usar a opção Adicionar dispositivo. Execute o seguinte procedimento para descobrir o endereço IP atualmente designado ao leitor ou à estação base:

  1. Conecte o leitor ou a estação base ao Setup Tool por meio de uma conexão RS-232 no PC (Porta COM do Setup Tool).

  2. Selecione a guia Rede em Configurações de comunicação.

  3. Copie o Endereço IP mostrado.

  4. Volte ao painel Conecte-se ao leitor e clique em Desconectar.

  5. Clique em Adicionar dispositivo.

  6. Cole o endereço IP do DataMan aqui.

Depois que os campos Nome e Endereço IP forem preenchidos, clique em OK. O leitor ou a estação base deve aparecer na lista de dispositivos DataMan acessíveis na lista Dispositivos de rede e, agora, você poderá conectar o Setup Tool ao leitor ou à estação base pela rede Ethernet.

O recurso Adicionar dispositivo armazena o nome do leitor ou da estação base na máquina local e não ficará visível em outras máquinas que também executam o Setup Tool.


Para que posso usar o ícone Exportar?

Clicando no ícone Exportar arquivo de suporte Cognex, é iniciada a geração de Arquivo de suporte Cognex, que gera um arquivo .zip contendo uma coleção de registros de dados predefinidos. Esse recurso somente está disponível se estiver selecionado pelo menos um dispositivo.

Ao clicar no botão, surge uma caixa de diálogo onde você pode especificar os tipos de dados a serem incluídos no arquivo de suporte .zip, em uma lista de caixas de seleção:

  1. Cfg

  2. Cdc

  3. Última imagem

  4. Dispositivos localizados

  5. Estatísticas do dispositivo

  6. Estatísticas da memória

  7. Comentário do usuário (pode ser editado manualmente pelo usuário)

A pasta de destino do arquivo de suporte pode ser modificada, usando o ícone '...’. É possível selecionar para abrir a pasta contida após a criação do arquivo ou enviá-la como um anexo, com o cliente de e-mail padrão (.eml).

A saída do processo é um arquivo .zip. O nome do arquivo contém o nome do dispositivo e a data de criação. Um descritor.xml no zip contém os seguintes dados:

  1. Data

  2. ID de descoberta

  3. Nome do dispositivo

  4. Tipo de dispositivo

  5. Número de série

  6. Endereço MAC

  7. Licenças

  8. Interface de comunicação

  9. Versão de firmware

  10. Lista dos arquivos presentes no zip


Qual a função do botão Adicionar dispositivo virtual?

Essa função permite criar um dispositivo virtual baseado em um arquivo de configuração personalizada ou um dispositivo com configuração padrão. Ela pode ser usada para visualizar os diferentes painéis do Setup Tool sem necessidade de conectar a um dispositivo. Pressionar o botão inicia um assistente que guia você pelos passos de criação de um dispositivo virtual. As opções iniciais são usar um arquivo de configuração/backup para a criação ou usar configurações de fábrica padrão.

Após o assistente terminar, é adicionado um novo dispositivo virtual à lista de dispositivos localizados, indicado por um ícone como um dispositivo virtual. O dispositivo virtual criado não está visível para outros dispositivos na rede. O dispositivo virtual persiste durante múltiplas instâncias de Setup Tool.

O dispositivo virtual criado pode ser conectado da mesma forma que um dispositivo normal, com a exceção de que todas as alterações de configuração são rejeitadas (tudo é somente de leitura) e nenhuma característica, função e ação funciona em dispositivos virtuais.


Backup


Como posso usar a função Backup?

Usando essa função, você pode gerar um arquivo de backup contendo a configuração e registros de um ou mais leitores, clicando no botão Backup, no canto inferior direito (ou pressionando Alt+B). Esse recurso somente está disponível se estiver selecionado pelo menos um dispositivo.

Clicando no botão Abrir pasta de backup, navega para a pasta onde os arquivos de backup são colocados. Você pode configurar a pasta em Home->Opções->Local do backup.

Se forem selecionados múltiplos dispositivos, cada dispositivo gerará um arquivo de backup. Cada arquivo de backup é colocado em uma subpasta que corresponde ao nome do dispositivo. O nome do arquivo de backup contém o nome do dispositivo e a data de criação.

O arquivo de backup é um arquivo .zip com uma extensão .dmb. O arquivo contém: config.cdc, config.cfg e descritor.xml. O xml possui os seguintes dados:

  1. Data

  2. ID de descoberta

  3. Nome do dispositivo

  4. Tipo de dispositivo

  5. Número de série

  6. Endereço MAC

  7. Licenças

  8. Interface de comunicação

  9. Versão de firmware

  10. Lista dos arquivos presentes no zip


Onde posso configurar a pasta de backup para a função de Backup?

É possível configurar a pasta em Home->Opções->Local do backup


Restaurar


Como posso usar a função Restaurar?

A função Restaurar permite a restauração de arquivos de configuração de backup em um ou mais dispositivos. Esse recurso somente está disponível se estiver selecionado pelo menos um dispositivo e se uma fonte de configuração válida for especificada.

Em Fonte da configuração, na parte superior, você pode especificar a fonte que Setup Tool usará para a restauração:

  1. Arquivo de configuração: Selecionando essa opção, o Setup Tool usa o arquivo de configuração especificado para a restauração. Clique no ícone '...’ para especificar a pasta que contém o arquivo de backup que deseja usar. Consulte Perguntas e Respostas em Backup para mais informações sobre como definir a pasta.

    Observação: O botão Restaurar somente fica habilitado quando um dispositivo compatível é selecionado como alvo.

  2. Dispositivo: Ao selecionar essa opção, o Setup Tool usa um único dispositivo especificado para restaurar a sua configuração para todos os dispositivos alvo.

  3. Último Backup: Ao selecionar essa opção, o Setup Tool procura o último backup para o dispositivo selecionado. Se forem selecionados múltiplos dispositivos, todos os dispositivos obtêm seu próprio último backup.

  4. Padrões de fábrica: Ao selecionar esta opção, o Setup Tool restaura a respectiva configuração para os padrões de fábrica.

Após ser selecionada a origem, bem como o dispositivo de destino (ou dispositivos), clique no botão Restaurar, no canto inferior direito.


Como funciona o botão suspenso Restaurar com configurações de rede?

Restaurar com configurações de rede funciona da mesma forma que o botão Restaurar, porém ele restaura a configuração do arquivo .cdc contido na pasta de backup em vez do arquivo .cfg. Essa opção só é habilitada se um .cdc estiver disponível em uma origem específica e a seleção de destino contiver um único dispositivo.


Atualizar firmware


Como atualizar o firmware do leitor?

Selecione Sistema->Atualizar Firmware..., depois selecione o arquivo de firmware.

Observação: Os arquivos de firmware são fornecidos na forma de arquivos compactados. O firmware deve ser carregado em sua forma compactada; não tente descompactar um arquivo de firmware antes de carregá-lo.


Como usar a função Atualizar firmware?

Essa função atualiza o dispositivo ou dispositivos selecionados para a versão de firmware desejada. Selecione o dispositivo ou dispositivos que deseja atualizar a partir da lista de dispositivos.

Navegue por arquivos de firmware clicando no ícone '...’. Se um único dispositivo estiver selecionado na lista de dispositivos, a pasta de firmware apropriada para esse dispositivo é aberta. Se estiverem selecionados múltiplos dispositivos, mas tiverem o mesmo ID de dispositivo de firmware, é aberta a pasta apropriada. Se nenhum dispositivo estiver selecionado ou estiverem selecionados mais dispositivos, mas tiverem diferentes IDs de dispositivo de firmware, é aberta a pasta de firmware de raiz.

Se a caixa de seleção na parte inferior estiver selecionada, o Setup Tool faz o backup dos arquivos de configuração do mesmo modo que a função Backup faz (consulte Perguntas e Respostas de Backup para mais detalhes).

Após selecionar o arquivo de firmware, clique em Atualizar firmware, no canto inferior direito. O botão somente é habilitado se a versão de firmware selecionada e a seleção de dispositivo for compatível.

Observação: No caso de dispositivos seriais, você precisa descobri-los primeiro, atualizando manualmente antes de poder atualizar o firmware.


Comparar configuração


Comparar configuração: Disposição geral e estrutura

Comparar configuração é uma ferramenta do estilo de visualização de tabela usada para configurar, copiar, comparar ou restaurar configurações do dispositivo. A área principal da página do documento contém uma grade com as propriedades do dispositivo, que foi selecionada antes de iniciada na página Conectar ao leitor.

Cada tipo de documento de Setup Tool usa sua própria conexão. Em caso de comunicação serial, somente pode ser aberta uma conexão de cada vez.

A linha de cabeçalho exibe o nome ou nomes do dispositivo selecionado. A linha do segundo cabeçalho, embaixo da primeira, exibe as configurações disponíveis para o dispositivo. Os cabeçalhos de linha abaixo (a negrito) podem ser recolhidos ou abertos, clicando no ícone junto deles. Quando um dispositivo é desconectado, surge um ícone reconectar na linha de cabeçalho dele.

As configurações que não são dependentes da configuração de leitura são exibidas somente na primeira coluna (Configuração principal).


Comparar configuração: Controles (mouse e teclado)

Seleção:

  • Mouse: Ao clicar em uma célula da grade, ela é selecionada; o que realça o cabeçalho de linha da célula e o(s) cabeçalho(s) da coluna onde o dispositivo e a configuração pertencem. Os botões do menu e itens no menu de faixa de opções podem mudar em linha com a seleção. Se a célula selecionada estiver na linha de uma linha de cabeçalho, todas as células na coluna atual que pertencem ao cabeçalho são selecionadas.

  • Teclado: As teclas de movimento do cursor navegam a seleção para a célula apropriada. O procedimento de destaque e seleção é o mesmo que por mouse.

Adicionar/alterar valores:

  • Mouse: Para células com editores integrados, clicando no controle do editor (caixa de combinação, caixa de seleção, numérico acima-abaixo) permite a entrada de valores. Para células com editores personalizados (o ícone '...’), abre um editor pop-up, permitindo a entrada do valor.

  • Teclado: Para células com editores integrados, pressionar Enter ou F2 inicia o modo de edição, Esc cancela a edição e um segundo Enter confirma a edição. Os valores podem ser inseridos no texto selecionado sem entrar no modo de edição; no caso, o valor atual é substituído no primeiro pressionamento de tecla.

    Para células numéricas, para além das células com editor de texto integrado, as setas para cima e para baixo aumentam e diminuem o valor.

    Para células suspensas, Enter inicia o modo de edição e exibe os itens suspensos, enquanto as setas para cima e para baixo movem a seleção. Um segundo Enter aplica o valor selecionado e Esc cancela a edição.

    Para células com caixa de seleção, usar o Espaço para alternar estados marcados/desmarcados.

Copiar e colar:

Use as combinações do teclado Ctrl+C e Ctrl+V para copiar e colar, respectivamente; consulte a descrição de copiar-colar dos itens do menu de faixa de opções relacionados para mais informações.


Comparar configuração: Menu de faixa de opções

O menu de faixa de opções pode ser encontrado acima da grade de estilo de visualização de tabela. Seus conteúdos e ícones ativos podem mudar em linha com a seleção das células, linhas ou colunas, na grade. O menu está separado em vários grupos.

  • Dispositivo: As configurações nesse grupo estão relacionadas com os dispositivos e seus arquivos de configuração. Use o botão Adicionar dispositivo... para abrir uma caixa de diálogo onde um ou mais dispositivos podem ser selecionados para serem adicionados à comparação. O botão Adicionar arquivo de configuração... abre um assistente onde você pode pesquisar uma configuração ou arquivo de backup (.dmb,.cdc,.cfg). Se o arquivo selecionado para o dispositivo não contiver toda a informação necessária, os parâmetros em falta devem ser definidos, caso contrário as opções padrão são selecionadas automaticamente. O mesmo se aplica aos casos onde a base de dados do dispositivo virtual não pode corresponder os parâmetros às opções disponíveis (por exemplo, não é encontrada a versão de firmware compatível).

    Observação: Os dispositivos virtuais adicionados são somente de leitura, conforme marcado pelo ícone de cadeado na sua linha de cabeçalho.

    Clicar no botão Remover dispositivo remove o(s) dispositivo(s) selecionado(s) atualmente (aquele que contém a(s) célula(s) selecionada(s) atualmente). Reiniciar dispositivo reinicia os dispositivos selecionados. Configuração de persistência no dispositivo salva o arquivo de configuração do dispositivo selecionado para a memória flash. Use Reinicializar para padrões de fábrica para reinicializar o(s) dispositivo(s) selecionado(s) para seus padrões.

  • Editar: Use Copiar (ou Ctrl+C no teclado) para copiar um valor da célula selecionada atualmente. Colar somente pode ser usado na mesma linha ou em qualquer editor de texto. Redefinir valores é usado para redefinir o valor (ou valores) da(s) célula(a) selecionada(s).

  • Destaque: Os botões e configurações nesse grupo do menu fornecem opções para destacar planos de fundo específicos da célula. Com o parâmetro Valores não padrão, as células que possuem valores não padrão são destacadas (isso pode ser diferente em uma única linha para diferentes dispositivos ou configurações de leitura). A configuração Diferença para referência destaca células que possuam valores diferentes da célula na mesma linha da configuração de leitura de referência (e dispositivo). A terceira configuração está selecionada; todos os valores e cabeçalhos que contêm o texto especificado na caixa de texto estão destacados. Adicionalmente, o próprio texto contido está destacado com um plano de fundo de texto diferente. Pressionar Enter também aplica a função do botão Exibir somente linhas destacadas.

    Quando habilitado, Exibir somente linhas destacadas recolhe todos os nós que não tenham qualquer subnó destacado. Quando ativado, Definir configuração de leitura de referência especifica a configuração de leitura (e dispositivo) que é usada como referência quando o modo de destaque Diferença para referência é usado. Quando o botão está ativo, a coluna da célula atualmente selecionada (configuração de leitura) torna-se a configuração de referência. A configuração de leitura atual é marcada na linha de cabeçalho do nome da configuração.

  • Filtragem: Defina Parâmetros da configuração de leitura para visualizar somente as configurações que são dependentes da configuração de leitura. Defina Configurações globais para visualizar somente configurações que não podem conter valores diferentes em diferentes configurações de leitura. Defina Todas as configurações para visualizar todas as configurações simultaneamente. Se uma entrada possuir valores em mais configurações de leitura, eles estão visíveis em colunas diferentes.

  • Outro: Use Expandir todas as linhas para expandir todas as linhas que tenham sido recolhidas na grade. Use Recolher todas as linhas para recolher todas as linhas expandidas na grade. Redefinir layout recalcula as larguras da coluna para utilizar todo o espaço disponível. Se o espaço disponível não for suficiente, é aplicada uma largura de coluna mínima.


Comparar configuração: Comparar editor

Comparar editor abre para cada item de Script na visualização de tabela Comparar configuração (em qualquer uma de suas subcategorias), após clicar no ícone '...’. Após abrir, pode visualizar a origem de script do dispositivo onde Comparar editor foi aberto.

Clicando em Padrão, o script reverte para o script padrão, para o dispositivo particular. Clicando em Comparar, o script padrão surge no segundo dispositivo, à direita, porém o menu suspenso na parte superior pode ser usado para alterar qual o script a comparar ao do lado esquerdo. É exibido um botão Atualizar no meio, entre as guias (vermelho, setas circulares), que pode ser usado para atualizar todos os textos de script.

Clicar Fechar fecha a comparação e volta à visualização de tabela dentro de Comparar configuração.


Janela de imagem


Para que serve o Visualizador de imagens?

Nessa janela, você pode ver a imagem lida pelo seu dispositivo.

Use os ícones de lupa para ajustar automaticamente a imagem ao tamanho da janela Visualizador de imagens, para aumentar e diminuir o zoom da imagem ou para exibir a imagem em um modo pixel a pixel, respectivamente.

Você também pode habilitar ou desabilitar o Retorno do foco na imagem no modo Visualização ao vivo, além de copiar a imagem para a área de transferência.

Use a opção Salvar imagem para salvar a imagem atual ou todas as imagens do burst e as opções de Registro para registrar todas as imagens não lidas ou decodificadas no sistema de arquivos.

Você também pode escolher verificar o histograma da imagem lida e os dados de brilho de um ponto selecionado na imagem. Use os botões da barra da faixa de opções da janela para realizar essas tarefas.


Histórico de resultados


Para que serve o Histórico de resultados?

Nesse painel você pode ver as informações decodificadas após cada leitura.

Use o botão Pausa para pausar/congelar a Visualização de ferramenta do histórico de resultados, que torna a localização de informação de leitura específica mais fácil. Todos os resultados de Entrada do dispositivo serão rejeitados pela janela de histórico de resultados até que ele não esteja pausado.

Use Apagar histórico para apagar a lista do histórico. Você também pode exportar uma única cadeia decodificada ou todas elas usando as opções Copiar e Copiar tudo, respectivamente.

Em Registro em log, marque Gerar relatórios de qualidade de código para incluir os dados de qualidade de código nas informações decodificadas, marque Gerar relatórios de validação de dados para incluir informações de validação de dados e Registrar em log todos os resultados no sistema de arquivos para salvar todos os itens do histórico de resultados no disco rígido local. Outras opções para isso podem ser acessadas clicando em Configurações de registro e relatório.

A opção Personalizar permite adicionar ou remover colunas da tabela para personalizar as informações do histórico de resultados.

Para filtragem de resultado, observe a questão abaixo.


Como funciona a filtragem de resultado?

É possível usar o botão Filtrar... no menu de faixa de opções da Visualização de ferramenta Histórico de resultados para filtrar os resultados de leitura apresentados na exibição. Clicando no botão, a filtragem é habilitada. Para configurar parâmetros de filtragem, abra as opções, clicando no lado direito do botão.

Observação: O botão de Filtro somente é exibido se o sistema operacional o suportar.

Estão disponíveis dois modos nas configurações de filtragem: filtragem padrão e filtragem avançada. Você pode selecionar qualquer um no menu suspenso em Geral.

Quando é usada a filtragem padrão, as categorias de filtragem são exibidas como ativas na janela suspensa (Status do resultado, Método de validação, Status da validação e Simbologia). É possível selecionar filtros individuais em cada categoria, clicando neles. Uma vez habilitados, esses filtros são usados em todos os itens futuros, em histórico de resultados e retroativamente também. Os itens não especificados pelos filtros são descartados do histórico de resultados até a filtragem estar desabilitada. Observe que, na filtragem padrão, um único resultado de boa leitura em uma sequência de disparo conta como uma boa leitura para toda a sequência de disparo. Logo, por exemplo, a filtragem padrão não é aplicável aos cenários de códigos múltiplos; use scripts de filtragem avançada para cenários de códigos múltiplos.

Usando a filtragem avançada, as categorias de filtragem padrão ficam inativas e Configurações avançadas da filtragem é ativado na janela suspensa. Ao clicar aí, uma nova janela abre, onde você pode editar as expressões do filtro. Se um filtro predefinido tiver sido habilitado previamente, a expressão gerada pode ser visualizada aí, no diálogo. A edição da expressão não possui qualquer efeito retrogrado nos filtros predefinidos.

A expressão do filtro em si mesma é uma função JavaScript. O uso de membros de dados do resultado é o mesmo daquele com a formatação por script. O resultado da expressão pode ser visualizado na janela, no lado inferior. Em caso de erro de JavaScript, a mensagem de erro é exibida na janela de texto. Observe que, apesar das semelhanças, a filtragem avançada não é um script de formatação de dados, apenas um filtro de exibição em funcionamento no Setup Tool.


Por que o símbolo aparece destacado em verde mas nenhum dado aparece na lista Histórico de resultados?

Se a caixa de seleção Formatação padrão habilitada estiver marcada no painel Formatação padrão, neste caso, você deverá construir uma cadeia de saída personalizada ou nenhum dado de resultado aparecerá, ainda que o leitor tenha decodificado o símbolo.


Por que alguns resultados possuem um ícone na frente?

Os resultados encabeçados por um ícone possuem uma imagem salva associada a ele. Clique na linha de resultado para visualizar a tentativa de decodificação e a imagem associada a ele.


Qualidade do código


Para que é usada a verificação?

A verificação é um recurso ativado por licença em DM8600. Ela é usada para avaliar se um símbolo Data Matrix atende à Diretriz de Qualidade AIM DPM (Marcação Direta na Peça) /ISO/IEC TR 29158.


Como configurar a verificação?

Para configurar a verificação para o seu Verificador DataMan 8600, por favor consulte o capítulo Procedimentos iniciais no Manual de referência do verificador portátil DataMan série 8600, onde a calibração inicial é descrita. Em seguida, a guia Verificação exibe um ícone verde ao lado de Sistema calibrado. Para atualizar seu DataMan 8600 para o status de verificador, por favor consulte Atualizar um dispositivo para verificação no Manual de referência do verificador portátil DataMan série 8600.

Após a calibração inicial, para ler os símbolos e ver os resultados da verificação, realize os seguintes passos:

  • Navegue até Configurações > Qualidade do código.

  • Na guia Verificação, marque Verificação habilitada.

  • Selecione Visualização de ferramenta de qualidade do código (ative clicando em Qualidade do código, em Exibição).

  • Posicione o verificador contra o símbolo e aperte o disparador. O símbolo deve estar centrado dentro do campo de visão e o leitor deve ficar perpendicular à superfície, contendo o símbolo, e na rotação correta. A distância do verificador deve ser usada para garantir a apresentação correta do símbolo e os requisitos de iluminação para a Diretriz de Qualidade AIM-DPM/ ISO/IEC TR 29158.

  • Mova o símbolo até que o centro do retângulo vermelho fique dentro do retângulo alvo verde no Painel de imagens. O leitor emite um bipe para indicar que o símbolo foi lido e verificado.

É possível visualizar os resultados da verificação na janela de Visualização da ferramenta de qualidade do código. Para cada leitura selecionada na visualização de ferramenta de Histórico de resultados, as métricas são exibidas na Visualização de ferramenta de qualidade do código. Na parte superior, você pode visualizar o grau geral atribuído ao código que foi lido.

Propriedade lista as métricas individuais, Valor é a diferença de valor entre o que foi lido e o que foi o limite para essas métricas individuais. Grau é o grau de qualidade do código que foi atribuído à métrica (também surge um ícone colorido nessa linha; verde = aprovado, vermelho = falha, amarelo = o valor está no limite). Média é baseada nas últimas 100 leituras dessa métrica.

Observe que, quando você calibra o leitor, ele calibra todas as opções de iluminação habilitadas e descalibra qualquer opção de iluminação que não esteja habilitada. Se você habilitar uma opção de iluminação não calibrada, o dispositivo fica não calibrado. Se você tenta efetuar uma verificação com um leitor não calibrado, o som de falha voltará e não será verificado nenhum símbolo. Volte a calibrar o dispositivo para poder efetuar a verificação novamente.

Para saber como usar os resultados na formatação de dados, por favor consulte o Manual de referência do verificador portátil DataMan série 8600.


Que outras opções existem na guia Verificação?

Atualmente, AIM-DPM/ISO/IEC TR29158 é suportado para verificação. É possível definir o Grau mínimo de aprovação na área Métricas de qualidade na guia. Essa configuração corresponde ao grau mínimo ao qual a verificação atribui uma Aprovação, ao graduar métricas de símbolo. Se marcado, Gráficos habilitados permite que os gráficos vetoriais escalonáveis apareçam em áreas problemáticas do código lido, no Painel de imagens.

Consulte as informações adicionais sobre outra configuração abaixo.


O que é o Controle do processo?

A Métrica de controle do processo fornece retorno sobre o tamanho da célula medida nas células individuais dentro de um símbolo de Data Matrix 2D. Com a Métrica de controle do processo habilitada, o leitor pode determinar se os símbolos sucessivos exibem uma mudança no tamanho da célula ou se o tamanho da célula continua constante.

Para usar a Métrica do controle de processo, o leitor deve estar calibrado.

Com Controle do processo habilitado, a exibição de ferramenta de Qualidade do código relata qualquer crescimento da célula da marca apresentada, que você pode usar para pesquisar mudanças no crescimento da célula em um período de tempo.


Como ajustar meu próprio limite de grau para Passar/Falhar usando a métrica AIM DPM e ISO/IEC 15415?

Selecione o grau desejado da configuração Grau mínimo de aprovação. As duas métricas suportam diferentes graus de passagem padrão.


Qual Configuração de iluminação deve ser selecionada?

Tipos diferentes de marcação e superfícies podem se beneficiar com fontes de iluminação diferentes. A iluminação fixa suporta uma iluminação de campo claro para símbolos de alto contraste em objetos não reflexivos e iluminação de campo escuro para símbolos de baixo contraste em superfícies reflexivas. Qualquer combinação poderá ser selecionada, se oferecer um grau confiável de qualidade do código.

Saiba que diferentes conjuntos de acessórios fixos de iluminação devem ser conectados a portas de saída específicas no módulo E/S expandido, como a seguir:

  • Campo claro – perpendicular difuso (90): Porta E/S 2, 3

  • Campo escuro – 30 graus em todos os quadrantes (30Q): Portas E/S 4, 5, 6, 7

  • Campo escuro – 30 graus quadrantes L - O (30T): Portas E/S 4, 6

  • Campo escuro – 30 graus quadrantes N - S (30T): Portas E/S 5, 7


Como saber se meu DataMan 8600 está licenciado para efetuar uma verificação de símbolo?

Siga os passos abaixo para saber se o seu DataMan 8600 pode efetuar uma verificação de símbolo:

  1. Conecte o Setup Tool ao DataMan 8600.

  2. Escolha Visualizar->Informações do sistema da barra de menu.

  3. Leia a lista das Licenças para a tecla de Verificação.

    Se a tecla Verificação estiver presente, então seu DataMan 8600 pode realizar a verificação de símbolo.


Qual é o tamanho máximo da área de DataMatrix que pode ser verificado pelos verificadores DataMan?

A área máxima para verificação para um verificador é 1,5 pol. x 1,5 pol.


Como o leitor desempenha uma verificação quando configurações de iluminação múltiplas estão habilitadas?

O dispositivo irá iniciar a verificação com a primeira configuração de iluminação selecionada e continuará até receber um grau geral de passagem. Se nenhuma das configurações de iluminação produzir um grau de passagem, a imagem e gráficos correspondentes para a configuração com o melhor grau geral são retornados ao usuário. O grau de aprovação é controlado com o parâmetro Grau mínimo de aprovação para AIM-DPM/ISO/IEC TR 29158 e ISO 15415. A métrica de qualidade AS9132 já produz um grau de símbolo que será definido como passar ou falhar.


O que são as métricas de qualidade do código AIM DPM individuais?

Os resultados da função Qualidade do código fornecem retorno detalhado na qualidade de um símbolo de acordo com o padrão da associação para identificação automática e mobilidade (AIM) para símbolos Data Matrix 2D. Os verificadores DataMan fornecem um grau geral para cada símbolo verificado assim como o grau para métricas individuais, que incluem:

  • Modulação da célula: Uma medição da capacidade de leitura para a marca atual.

    O grau é um reflexo de quão perto as células de brilho e as células escuras se aproximam de um limite global para uma marca em particular, indicando o ponto de separação do nível cinza entre as células de brilho e as células escuras de qualquer marca em particular.

    Uma marca gera um grau baixo da Modulação da célula quando existe uma confiança relativamente baixa de o leitor conseguir classificar células individuais como claras ou escuras. O score também leva em consideração a capacidade de correção do erro construída no símbolo (com símbolos grandes tendo mais capacidade de correção do erro). Por exemplo, uma marca irá receber um grau baixo de Modulação da célula mas um grau alto de Correção de erro não usada se a maioria das células estiverem prestes a mudar de estado mas não o fizerem de fato.

  • Dano do padrão fixo: A qualidade dos padrões do finder, clocking e área silenciosa dentro da marca.

    O leitor usa vários padrões dentro de cada símbolo para localizar e decodificar os dados que contém. O leitor gera o grau de Dano do padrão fixo usando o mesmo método que o score de Modulação da célula, especificamente uma medição da confiança da refletância.

  • Decodificação de referência: Uma indicação se o algoritmo Data Matrix 2D padrão foi capaz de localizar e decodificar esta marca em particular.

    Esta métrica gera um grau tanto de A ou F.

  • Contraste da célula: Uma medição da diferença do reflexo entre as células claras e as células escuras no símbolo, representada como uma porcentagem das células claras significa o valor refletido.

    A especificação AIM-DPM/ISO/IEC TR 29158 necessita que a imagem seja ajustada para que as células claras tenham um valor de reflexo principal de 78% da saturação completa.

  • Não uniformidade axial: Uma medição da simetria das células individuais dentro do símbolo.

  • Correção de erro não usada: Uma medição para a porcentagem de palavras código deixadas em um símbolo depois de corrigir qualquer erro.

    Quando calcular a Correção de erro não usada, uma palavra código é considerada errada se ao menos uma de suas células estiver no lado errado do limite global. Os símbolos Data Matrix 2D possuem uma redundância de código embutido ou a presença de conteúdo de dados duplicado.

    Um valor de 1.00 significa que nenhum erro estava presente em qualquer uma das palavras código.

  • Não uniformidade da grade: Uma medição da quantidade de localização de erros para células individuais para um grau de espaço uniforme como medido usando um padrão relógio de um símbolo.

  • Crescimento da célula: Uma medição da mudança no crescimento da célula nas direções horizontais e verticais.

    O tamanho da célula é medido independentemente junto com os padrões clocking horizontal (CGH) e vertical (CGV) do símbolo e relatado nas dimensões físicas.

    Esta métrica não é usada para criação do Grau do símbolo geral, mas para controle do processo apenas e está disponível somente quando você habilitar a graduação de qualidade do código no painel de tarefas Qualidade do código.


Como crio um relatório com os resultados da Verificação para um símbolo em particular junto com a imagem?

  1. Em Opções, selecione Registro de dados em log.

  2. Localize Relatório. Você pode especificar a localização onde o DataMan Setup Tool irá salvar os relatórios. Além disso, você pode especificar uma estrutura pelo nome do arquivo, especificar um prefixo do nome do arquivo e desabilitar os gráficos de sobreposição em cada relatório.

    Saiba que o DataMan Setup Tool não qualifica o prefixo para caracteres válidos. Se você usar um caractere inválido, como dois pontos (:), o DataMan Setup Tool não irá gerar o relatório.

  3. Certifique-se de que Gerar relatórios de qualidade de código esteja selecionado em Registro em log, na visualização de ferramenta Histórico de resultados.

Os relatórios para cada símbolo lido com sucesso irão automaticamente ser gerados para o local do arquivo selecionado, enquanto o leitor estiver conectado ao DataMan Setup Tool.


Qual a função da guia Qualidade do código?

A Qualidade do código permite validar que os símbolos que você usa atendem as diretrizes de qualidade, conforme delineado em um dos padrões de qualidade do código sustentados pela Cognex. É atribuído um grau geral aos códigos após serem graduadas as métricas selecionadas, ou todas (padrão), de um determinado padrão de qualidade do código. A Qualidade do código é ativada através de licença.

Para obter mais informações detalhadas sobre padrões de qualidade de código específicos e suas métricas, por favor consulte o Guia de programação e configurações ou a documentação padrão ISO correspondente, que pode ser encontrada em www.iso.org.


Como usar o Painel geral?

O painel Qualidade do código funciona como um concentrador, para habilitar a avaliação de qualidade do código para diferentes tipos de código: códigos de barras 1D, DataMatrix, códigos QR e DotCode. Para cada um desses tipos de simbologia, você pode especificar para que padrão de qualidade do código deseja que o leitor avalie os códigos lidos.

Após habilitar a graduação de qualidade do código, o dispositivo fornece resultados de qualidade para cada símbolo lido, para os quais a qualidade do código foi habilitada, na geração de script.


Visualização de ferramenta de qualidade do código


O que posso ver na Visualização de ferramenta de qualidade do código?

É possível visualizar os resultados da verificação em Visualização de ferramenta de qualidade do código. A verificação deve estar habilitada no painel Qualidade do código (licença necessária) antes de conseguir visualizar os resultados aqui. Para cada leitura selecionada na visualização de ferramenta de Histórico de resultados, as métricas de verificação são exibidas na Visualização de ferramenta de qualidade do código. Na parte superior, pode visualizar o grau geral atribuído ao código que foi lido.

Propriedade lista as métricas individuais, Valor é a diferença de valor entre o que foi lido e o que foi o limite para essas métricas individuais. Grau é o grau de qualidade do código que foi atribuído à métrica (também surge um ícone colorido nessa linha; verde = aprovado, vermelho = falha, amarelo = o valor está no limite). Média é baseada nas últimas 100 leituras dessa métrica.

Para obter mais informações detalhadas sobre verificação, por favor consulte o Manual de referência do verificador portátil DataMan série 8600.


Configurações de leitura


Como posso gerenciar as configurações?

O DM8600 funciona com um conjunto de configurações de leitura fixas. É possível habilitar ou desabilitar configurações de leitura individuais, usando a caixa de seleção Habilitar para cada configuração de leitura presente em baixo da faixa de opções.

Observe que as alterações que efetuar em uma Configuração de leitura não serão automaticamente transferidas para outras Configurações de leitura ativas.


Qual é a função da opção Iniciando a configuração?

Se várias configurações forem habilitadas, o leitor passa por todas elas e interrompe a aquisição de imagens depois de ter lido um código. Para ler o próximo código, decida se o leitor começará a acessar as configurações a partir da selecionada ou a partir da última decodificação com sucesso.


Para que serve o campo Filtrar na parte superior?

É possível digitar um parâmetro que deseja encontrar, por exemplo, "tamanho" ou "burst” e pressionar Enter. Os itens encontrados serão destacados e somente os nós dos parâmetros que contêm os itens procurados serão expandidos. É possível fechar a pesquisa, excluindo o que digitou e pressionando Enter.


Que configuração deve ser usada?

A configuração Objetivo geral irá ler a maioria dos códigos. As configurações adicionais podem lidar com tipos específicos, difíceis de ler, de códigos marcados.

  • A função Superfície curva é adequada para marcas sobre objetos convexos, reflexivos e parcialmente reflexivos.

  • A função Micropercussão difícil pode ajudar a ler códigos de ponto nos quais as marcas de ponto são pequenas, possuem superfícies irregulares ou mal formadas.

  • A função Superfície texturizada é adequada para aplicações nas quais parte da superfície requer iluminação direcional no eixo da textura.


É possível habilitar todas as configurações?

Você deve habilitar apenas os ajustes que são adequados para sua parte e marcas. Lembre-se que o leitor circula por todas as configurações habilitadas quando você tentar ler um código. Quantos mais configurações forem habilitadas, mais tempo o leitor pode levar para ler um código.

Por padrão, todas as configurações de leitura estão habilitadas. Certifique-se de que habilita as configurações de qualidade do código desejadas para todas as configurações de leitura habilitadas, de outra forma, a métrica de qualidade 1D não retornará os dados.


Configurações de leitura: Disposição geral e estrutura

Configurações de leitura é uma ferramenta do estilo de visualização de tabela usada para configurar, copiar, comparar ou restaurar configurações de leitura. A área principal da página do documento contém uma grade com as propriedades do dispositivo.

A linha de cabeçalho exibe o nome ou nomes do dispositivo selecionado. A linha do segundo cabeçalho, embaixo da primeira, exibe as configurações disponíveis para o dispositivo. Os cabeçalhos de linha abaixo (a negrito) podem ser recolhidos ou abertos, clicando no ícone junto deles. Quando um dispositivo é desconectado, surge um ícone reconectar na linha de cabeçalho dele.


Configurações de leitura: Controles (mouse e teclado)

Seleção:

  • Mouse: Ao clicar em uma célula da grade, ela é selecionada; o que realça o cabeçalho de linha da célula e o(s) cabeçalho(s) da coluna onde o dispositivo e a configuração pertencem. Os botões do menu e itens no menu de faixa de opções podem mudar em linha com a seleção. Se a célula selecionada estiver na linha de uma linha de cabeçalho, todas as células na coluna atual que pertencem ao cabeçalho são selecionadas.

  • Teclado: As teclas de movimento do cursor navegam a seleção para a célula apropriada. O procedimento de destaque e seleção é o mesmo que por mouse.

Adicionar/alterar valores:

  • Mouse: Para células com editores integrados, clicando no controle do editor (caixa de combinação, caixa de seleção, numérico acima-abaixo) permite a entrada de valores. Para células com editores personalizados (o ícone ‘...’), abre um editor pop-up, permitindo a entrada do valor.

  • Teclado: Para células com editores integrados, pressionar Enter ou F2 inicia o modo de edição, Esc cancela a edição e um segundo Enter confirma a edição. Os valores podem ser inseridos no texto selecionado sem entrar no modo de edição; no caso, o valor atual é substituído no primeiro pressionamento de tecla.

    Para células numéricas, para além das células com editor de texto integrado, as setas para cima e para baixo aumentam e diminuem o valor.

    Para células suspensas, Enter inicia o modo de edição e exibe os itens suspensos, enquanto as setas para cima e para baixo movem a seleção. Um segundo Enter aplica o valor selecionado e Esc cancela a edição.

    Para células com caixa de seleção, usar o Espaço para alternar estados marcados/desmarcados.

Copiar e colar:

Use as combinações do teclado Ctrl+C e Ctrl+V para copiar e colar, respectivamente; consulte a descrição de copiar-colar dos itens do menu de faixa de opções relacionados para mais informações.


Configurações de leitura: Menu de faixa de opções

O menu de faixa de opções pode ser encontrado acima da grade de estilo de visualização de tabela. Seus conteúdos e ícones ativos podem mudar em linha com a seleção das células, linhas ou colunas, na grade. O menu está separado em vários grupos.

  • Visualização de tabela: Use o botão Adicionar a configuração para adicionar uma configuração de leitura. Na janela que se abrirá, decida se quer usar os valores padrão na nova configuração ou decida se quer copiar valores de uma configuração existente. O botão Excluir configuração é usado para excluir a(s) configuração(ões) de leitura selecionada(s). O botão Alterar ordem abre uma caixa onde você pode reorganizar a ordem das configurações de leitura. As configurações serão renumeradas consecutivamente.

  • Iniciar a configuração: Se várias configurações forem habilitadas, o leitor passa por todas elas e interrompe a aquisição de imagens depois de ter lido um código. Para ler o próximo código, decida se o leitor começará a acessar as configurações a partir da selecionada ou a partir da última decodificação com sucesso. Aqui você pode escolher essa configuração inicial a partir de uma lista suspensa. Em alternativa, selecione Última decodificação com sucesso para selecionar a configuração de leitura com a última codificação bem sucedida como configuração inicial.

  • Editar: Use Copiar (ou Ctrl+C no teclado) para copiar um valor da célula selecionada atualmente. Colar somente pode ser usado na mesma linha ou em qualquer editor de texto. Redefinir valores é usado para redefinir o valor (ou valores) da(s) célula(a) selecionada(s).

  • Destaque: Os botões e configurações nesse grupo do menu fornecem opções para destacar planos de fundo específicos da célula. Com o parâmetro Valores não padrão, as células que possuem valores não padrão são destacadas (isso pode ser diferente em uma única linha para diferentes dispositivos ou configurações de leitura). A configuração Diferença para referência destaca células que possuam valores diferentes da célula na mesma linha da configuração de leitura de referência (e dispositivo). A terceira configuração está selecionada; todos os valores e cabeçalhos que contêm o texto especificado na caixa de texto estão destacados. Adicionalmente, o próprio texto contido está destacado com um plano de fundo de texto diferente. Pressionar Enter também aplica a função do botão Exibir somente linhas destacadas.

    Quando habilitado, Exibir somente linhas destacadas recolhe todos os nós que não tenham qualquer subnó destacado. Quando ativado, Definir configuração de leitura de referência especifica a configuração de leitura (e dispositivo) que é usada como referência quando o modo de destaque Diferença para referência é usado. Quando o botão está ativo, a coluna da célula atualmente selecionada (configuração de leitura) torna-se a configuração de referência. A configuração de leitura atual é marcada na linha de cabeçalho do nome da configuração.

  • Filtragem: Parâmetros da configuração de leitura é definido automaticamente, permitindo visualizar somente as configurações que são dependentes da configuração de leitura. Defina Configurações globais para visualizar somente configurações que não podem conter valores diferentes em diferentes configurações de leitura. Defina Todas as configurações para visualizar todas as configurações simultaneamente. Se uma entrada possuir valores em mais configurações de leitura, eles estão visíveis em colunas diferentes.

  • Outro: Use Expandir todas as linhas para expandir todas as linhas que tenham sido recolhidas na grade. Use Recolher todas as linhas para recolher todas as linhas expandidas na grade. Redefinir layout recalcula as larguras da coluna para utilizar todo o espaço disponível. Se o espaço disponível não for suficiente, é aplicada uma largura de coluna mínima.


Registro do dispositivo


O que é Registro do dispositivo?

Essa visão mostra os registros que são gerados quando o LED vermelho piscar no seu dispositivo. É possível atualizar esse registro ou excluí-lo quando ele não for mais necessário.


Configurações UltraLight


Quais são os tipos de disparo?

  • O disparo de Apresentação busca continuamente por um símbolo e decodifica-o cada vez que um é detectado. Um disparo de apresentação usa um mecanismo interno de temporização e de detecção de movimento para o leitor.

    Você pode especificar vários parâmetros no modo de apresentação, por exemplo, se o leitor vai ler o mesmo código mais de uma vez ou por quanto tempo deve aguardar antes de fazer a leitura do próximo código. Use as opções Configurações do disparo no painel Configurações do sistema para configurar o disparo de apresentação.

    No modo de apresentação, use as configurações de Exposição automática para fazer com que o leitor determine as melhores configurações de exposição para um nível desejável de brilho na imagem. Observe, entretanto, que o leitor usa as imagens iniciais adquiridas para determinar estas configurações, e pode perder imagens que contenham um símbolo para decodificação. Você pode mudar para configurações de Exposição manual e especificar uma configuração precisa para a exposição da câmera.

  • O disparo Manual começa a adquirir imagens em resposta a qualquer um dos seguintes eventos:

    • Pressionando o botão no leitor

    • Enviando o comando de controle Disparo do DataMan (DMCC) quando conectado ao leitor por uma conexão USB ou serial

    • Clicando no botão Disparo no Setup Tool

    • Pressionando Ctrl+T no teclado quando o Setup Tool obtiver o foco

    O leitor continua a adquirir imagens enquanto o sinal continuar ativo e para quando um símbolo é encontrado e decodificado ou o sinal do disparo termina.


A função Apontador habilitado foi desmarcada. Por que o apontador ainda está ligado?

Quando você altera o tipo de disparo para Apresentação, o disparo usa a detecção de movimento ao redor da área do ponto a laser. Por isso, o apontador a laser ficará ligado, mesmo quando a função estiver desabilitada.


Quais configurações UltraLight o leitor usa?

Você pode configurar quatro configurações de iluminação diferentes usando as quatro guias deste controle. Quando você tentar ler um código, o leitor usa cada configuração habilitada por sua vez, para tentar ler o código. Para habilitar um ajuste, clique na guia de configuração e marque a caixa de seleção Habilitado. Ajustes habilitados possuem marcas de seleção verdes em seus nomes.

Quando você inicia uma nova leitura, o leitor sempre começa com a configuração usada mais recentemente, se várias configurações estiverem habilitadas. O leitor troca de configuração com base no número de tentativas de decodificação, ou seja, na configuração padrão o leitor irá para a próxima configuração após 2 ou 3 decodificações sem sucesso. Altere o número de tentativas de decodificação selecionando o painel Configurações do disparo no grupo Configurações do sistema no modo de exibição em árvore.


Quando verificar o campo claro difuso?

Marque a caixa campo claro difuso se você quiser fazer a leitura de uma imagem em uma superfície plana.


Como ajustar a exposição da imagem?

Acesse o painel Controle do processador de imagens. Você pode especificar um brilho da imagem alvo e o leitor irá ajustar automaticamente sua exposição para obter este brilho da imagem ou você pode especificar manualmente os ajustes de exposição.


Como é possível mudar o número de tentativas de decodificação?

Use o controle Tentativas de decodificação. Você pode ajustar o número de tentativas de decodificação para cada configuração separadamente.


O que o botão "Reinicializar a configuração {0} no padrão inicial" reconfigura?

O botão Reinicializar a configuração {0} no padrão inicial reconfigura todos os controles dos subpainéis de Configurações UltraLight. Ou seja, suas alterações nos subpainéis Configurações do foco, Tamanho da imagem e Controle do processador de imagens também serão reconfiguradas com uma definição específica. Em outras palavras, se você clicar em Reinicializar a configuração {0} no padrão inicial no painel Superfície curva, todas as configurações correspondentes dos outros subpainéis também serão reconfiguradas.


Tamanho da imagem


Para que é usada a configuração Tamanho da imagem (região de interesse)?

Você pode usar esta função para especificar a região exata da imagem que o leitor irá usar para localizar e decodificar um código. Isto pode facilitar quando dois códigos Data Matrix estão próximos um do outro e você precisar garantir que irá ler apenas o código em uma determinada região. A redução da região de interesse não reduz necessariamente o tempo de codificação ou diminui a taxa de transferência da imagem.

Você pode ajustar uma região de interesse diferente para cada ajuste, se o seu dispositivo suportar ajustes múltiplos.


O tamanho do Região de interesse do decodificador tem efeito nos Códigos de configuração do leitor?

A restrição da Região de interesse para uma muito pequena pode impedir o leitor de conseguir ler os Códigos de configuração do leitor.


Configurações do foco


Qual é a melhor configuração de foco para mim?

Se a sua aplicação tiver um alcance de leitura consistente, defina a variação de foco para uma configuração fixa. Isto resultará no desempenho mais rápido.

Se sua aplicação tiver diversos tipos e tamanhos de código, use diferentes Configurações de leitura e defina a variação de foco para uma maior profundidade de campo.


O que acontece se os passos do foco forem definidos para zero (Fixo)?

Se os passos do foco forem iguais a zero, o foco estará configurado para uma posição e uma imagem será adquirida. Nenhuma busca para obter um melhor foco será realizada.


O que é "menor-superior" se eu ajustar os Passos do foco para 1?

Somente no modo de disparo Manual, se a função Passos do foco estiver ajustada para 1 ou 2, a variação de foco se alternará entre os dois valores: um valor menor e um superior. Isso é representado pelo controle deslizante sendo dividido em dois, que podem ser alterados separadamente.

No caso de distância de milímetros, os dois controles deslizantes são aumentados e baixados na faixa de varredura. No caso de dioptria, os dois controles deslizantes são aumentados ou diminuídos na faixa de potência.


Como usar a configuração Variação de foco?

Pode usar a opção Variação de foco para alterar manualmente a distância do foco do dispositivo usando o controle deslizante, os botões '+' e '-' nas extremidades do controle deslizante ou digitando os valores. A Variação de foco pode ser fornecida em milímetros.


Como é calculada a distância até o leitor?

A distância em milímetros é calculada como sendo a distância a partir da tampa da lente até à imagem a ser decodificada.


Validação de dados


O que é Validação de dados?

A Validação de dados é usada para confirmar se os dados codificados por um símbolo estão no formato correto, para uma companhia, indústria ou padrão internacional em particular.


Onde é exibido o Histórico de resultados de validação de dados?

Os resultados da Validação de dados aprovados/reprovados e os de saída são exibidos no Histórico de resultados. A entrada Resultado na lista do histórico de resultados irá receber um ícone ‘+’, abrindo os detalhes do resultado da tentativa de validação. Os resultados de validação anteriores podem ser visualizados no histórico de resultados, da mesma forma.


O que significam os códigos de erro de validação?

Os resultados de Falha de validação de dados são os seguintes:

  • 1: Identificador de simbologia inválido. O identificador de simbologia é a cadeia de três caracteres que não apenas identifica o tipo de simbologia usado para codificar os dados, mas também descreve como processar os dados. Essa série pode ser opcionalmente aprovada como entrada para a ferramenta, além dos dados decodificados como uma entidade separada ou prefixando-a no fluxo de dados.

    Exemplo: Para um símbolo UCC/EAN-128, o identificador de simbologia é ]C1. Em algumas aplicações, essa será a única maneira de diferenciar de forma precisa e automática símbolos de Code 128 internos ou da indústria e UCC/EAN-128 (que codificam os Identificadores de aplicação do EAN.UCC). Sem os identificadores de simbologia, não seria possível saber como processar os dados no símbolo.

  • 2: Modelo não correspondente.

  • 3: Qualificadores de dados inválidos (AI, DI ou TEI).

  • 4: Identificador da aplicação (AI) inválido.

  • 5: Identificador de dados (DI) inválido.

  • 6: Identificador de elemento de texto (TEI) inválido.

  • 7: Dados inválidos: quando os dados não coincidem com o tipo, o tamanho ou o valor do qualificador de dados.

  • 8: Separador de campo inválido.

  • 9: Fora de conformidade com a ISO/IEC 15434.

  • 10: Formatos não suportados (por exemplo, em aplicações do DoD UID, formatos diferentes de 05, 06 ou DD).

  • 11: Código de formato inválido: códigos de formato diferentes de 00-99 e DD.

  • 12: Norma ISO/IEC 15434 não suportada se a opção de validação da norma ISO/IEC 15434 for selecionada mas o fluxo decodificado não for de um símbolo 2D. É possível relatar essa falha apenas se o identificador de simbologia for aprovado como entrada para a ferramenta.

  • 13: Campo de aplicação inválido: campo que não é suportado pela aplicação.

  • 14: Campo de aplicação não suportado: campo que é suportado pela aplicação, mas não pela ferramenta.

  • 15: Dados de aplicação inválidos: quando os dados não atendem aos requisitos específicos da aplicação.

    Exemplo: As aplicações do DoD UID têm os seguintes requisitos: A cadeia de caracteres de ID da empresa não deve ultrapassar 13 caracteres, excluindo o qualificador de dados. A cadeia de caracteres de número de peça, lote ou grupo original (incluindo os caracteres especiais permitidos) não deve exceder 32 caracteres, excluindo o qualificador de dados. A cadeia de caracteres do número de série (incluindo os caracteres especiais permitidos) não deve exceder 30 caracteres, excluindo o qualificador de dados.

  • 16: Presença de vários formatos no mesmo fluxo de dados (por exemplo, em aplicações do DoD UID, não pode haver mais de um formato no fluxo de dados).

  • 17: Campos duplicados: várias ocorrências do mesmo qualificador de dados no mesmo símbolo. Algumas aplicações, como as do DoD UID não permitem campos duplicados no mesmo símbolo.

  • 18: UID inválido: nem todos os campos necessários para construir um Conceito nº1 ou Conceito nº2 válido do UID estão presentes.

  • 19: Conceito nº1 de UID inválido: nem todos os campos necessários para construir um Conceito nº1 válido de UID estão presentes.

  • 20: Conceito nº2 de UID inválido: nem todos os campos necessários para construir um Conceito nº2 válido de UID estão presentes.

  • 21: Código de fim de formato ausente durante a verificação de conformidade com a sintaxe da norma ISO 15434 ou DoD UID.

  • 22: Código de fim de mensagem ausente durante a verificação de conformidade com a sintaxe da norma ISO 15434 ou DoD UID.


Como mudar o tom da saída do leitor e a cor LED para códigos que falham na validação?

Selecione o painel de tarefas Configurações do sistema. Na seção Ação de falha de validação você pode selecionar o tipo de tom, intensidade e a cor LED.


O que é Validação DoD UID?

A Validação DoD UID é usada para avaliar se a codificação de dados em um código Data Matrix está codificada corretamente de acordo com as diretrizes Mil Standard 130 do Departamento de Defesa dos EUA. O Departamento de defesa americano solicita agora que todos os itens (acima de 5.000 dólares ou que são serializados de forma única) por ele recebidos ou mantidos em estoque sejam marcados com um número de série único (UII) e com um formato de sintaxe específico. A ferramenta Validação DoD UID é usada para confirmar se os dados de um código foram formatados corretamente, de acordo com os tipos de conceito 1 ou 2 do Departamento da Defesa dos EUA. O recurso de Validação DoD UID também confirma automaticamente se a cadeia de dados está em conformidade com as especificações ISO 15434 e ISO 15418. A saída do UII concatenado (ou apenas os Elementos de dados do UII sem a sintaxe do ISO 15434 e qualificadores de dados USI 15418) é exibida no primeiro campo de resultados, no campo Resultados da validação, no Painel de tarefas dos resultados.

Os elementos dos dados de construção 1 incluem: O identificador da empresa do fabricante EID (CAGE, DUNS, EAN.UCC), identificador para uma companhia, assim como o número de série do produto dentro do seu identificador EID. O identificador da empresa e números de série são representados por um qualificador de dados dependendo se a companhia está usando ou não, um formato DI, AI ou TEI.

Os elementos dos dados de construção 2 incluem: O identificador da empresa do fabricante (EID), o identificador do número de peça do fabricante (NP) e o identificador do número de lote (NL) para a peça e o número de série único para a peça dentro do número de peça específico do fabricante. O identificador da empresa, o número de lote/peça e os números de série são representados por um qualificador de dados específico dependendo se a companhia está usando um formato DI, AI ou TEI.

Observação: Esta opção não está disponível em todos os leitores.


Qual a simbologia que devo usar para a validação DoD UID?

O Departamento de Defesa americano especifica atualmente o código Data Matrix como padrão para a marca impressa UID.


O que é EID esperado?

O EID esperado refere-se ao identificador da empresa na cadeia de dados UII. O identificador da empresa (EID) representa o código CAGE, DUNS, EAN.UCC do fabricante ou outra identificação. O EID esperado é um valor DoD específico.


O que é NP esperado?

NP esperado refere-se ao número de peça fornecido pelo fabricante na série de dados do UII. O NP esperado é um valor DoD específico.


O que é NL esperado?

NL esperado refere-se ao número de lote fornecido pelo fabricante na série de dados do UII. O NL esperado é um valor DoD específico.


O que é validação ISO?

A função validação ISO é usada para determinar se uma cadeia de dados está codificada corretamente de acordo com a sintaxe da norma ISO 15434 ou ISO 15434 além de ISO 15418.

A norma ISO 15434 confirma se a cadeia de dados está codificada com a sintaxe correta que inclui a avaliação dos caracteres ASCII "não imprimíveis" na cadeia assim como o cabeçalho da mensagem, separador do registro, código de formato (Para AI, DI ou TEIs), separadores de grupo e o caractere indicador de fim da transmissão.

O ISO 15418 confirma se a cadeia de dados está codificada com os qualificadores de dados corretos para cada elemento de dados. Dependendo se um fabricante está usando um formato AI, DI ou TEI ou não, cada elemento de dados (código EIN do fabricante, número de peça e número de série) é precedido por um código específico ou 'qualificador de dados'.

Observação: Esta opção não está disponível em todos os leitores.

Observação: Essa opção também permite Identificadores de elemento de texto, conforme definido na especificação ATA CSDD.


O que é validação GS1?

A validação GS1 permite que você verifique a sintaxe e semântica dos símbolos comparando-os com a especificação GS1. O leitor pode validar os dados codificados perante uma cadeia configurável de identificadores. São suportados todos os identificadores da aplicação.

Por padrão, o leitor valida o símbolo de entrada perante a cadeia de formato da Federação Europeia das Indústrias e Associações Farmacêuticas (EFPIA), por exemplo:

<AI(01)><AI(10)><AI(17)><AI(21)>

Usando a validação GS1, você pode configurar o que o leitor transmite quando os dados em um símbolo não passam na verificação, incluindo um retorno de carro e alimentação de linha. O painel de resultados detalhados mostrará um APROVAR ou FALHAR para cada símbolo e listará cada identificador de aplicação no símbolo, acompanhado dos seus elementos de dados.


O que é a Validação de cadeia de correspondência?

A Validação de cadeia de correspondência permite que você especifique uma sequência exata para comparar com a sequência codificada pelo símbolo. Apenas os símbolos contendo uma cadeia que está de acordo com a cadeia especificada irão gerar um resultado positivo.


Como validar cadeias com valores que mudam?

Habilitar o controle Aumentar/Diminuir componente numérico para especificar que uma parte da cadeia para validar é um valor numérico que aumenta ou diminui com cada leitura sucessiva.


Para que é usado o Aumentar/Diminuir componente numérico?

Use esta função para realizar Validação de cadeia de correspondência em aplicações onde dados codificados são serializados ou mudam de alguma forma linear. Por exemplo, uma aplicação de revista ou encadernação onde os números da página são procurados usando códigos de barra para garantir que nenhuma página seja duplicada ou pulada, pode se beneficiar do Aumentar/Diminuir componente numérico.


Como definir as configurações de Aumentar/Diminuir componente numérico?

Você pode usar este recurso se a cadeia que você está validando contém uma sequência de dígitos (0–9) que tanto aumenta ou diminui com cada leitura sucessiva. Para usar esta função, especifique a posição inicial dos dígitos aumentados ou diminuídos no campo Posição inicial (0 é a posição do primeiro caractere) e o número de caracteres que irão mudar no campo Comprimento. Se você selecionar Automático para Comprimento, o leitor irá tratar todos os dígitos consecutivos da posição inicial como o valor de aumento ou diminuição. Use Tamanho do incremento para especificar quanto o valor muda entre as leituras. Selecione um valor negativo se o número diminuir.

Por exemplo, se sua cadeia inicial é ABC_123XXPY e com a leitura sucessiva "123" é aumentado em um, você deverá especificar uma Posição inicial de 4, um Comprimento de 3 e um Tamanho do incremento de 1. (Se você tem certeza que os caracteres em posição 7 nunca devem ter dois dígitos, você também pode especificar Automático para o Comprimento.) Observe que a configuração Auto não aumenta o número de dígitos quando é alcançado o número máximo, mas reinicializa o número como com qualquer configuração de dígito fixada (por exemplo, alcançando 99, com dois dígitos não passa a 100, mas a 00).

Por padrão, se a cadeia é inválida ou não pode ser lida, o valor numérico esperado não muda. Você pode usar as caixas de seleção Atualizar em caso de não leitura e Atualizar em caso de falha de validação para especificar que o valor esperado pode ser mudado quando nenhum código é lido, se o código é inválido ou ambos.


Para que é usada a Validação de correspondência do padrão?

A Validação de correspondência do padrão habilita um usuário a inserir uma cadeia específica de caracteres para confirmar se eles estão presentes na cadeia de dados. Por exemplo, um usuário pode entrar o padrão 17V que é usado em formatos DI para identificar o código da empresa. Se os caracteres 17V são apresentados no código, o leitor irá sinalizar um passe para validação para aquele código. Se os caracteres não estão presentes, o leitor irá sinalizar uma falha para validação.

Você deve usar uma expressão regular como modelo para a validação do modelo.


Para que é usada a Ação de falha de validação?

A Ação de falha de validação é usada para determinar o que é enviado pelo leitor depois de uma falha na validação. O usuário pode selecionar opções diferentes:

  1. Transmitir 'Falha de validação'- O leitor enviará a cadeia 'Falha de validação' depois que um código falhar a validação
  2. Transmitir 'Falha de validação' e cadeia codificada - O leitor enviará a cadeia 'Falha de validação' seguida pela cadeia decodificada completa
  3. Transmitir cadeia decodificada anotada - O leitor enviará a cadeia decodificada junto com a informação sobre o tipo de erro e localização do erro na cadeia
  4. Não transmitir nada - O leitor não irá emitir qualquer informação.
  5. Transmitir 'Falha de validação' + cadeia decodificada entre aspas - O leitor enviará a cadeia 'Falha de validação' seguida pela parte citada da cadeia decodificada


Para que é usada a caixa de seleção Acrescentar retorno de carro/aliment. de linha da Ação de falha de validação?

A caixa de seleção retorno de carro/aliment. de linha é usada para fornecer um retorno de carro/aliment. de linha depois de uma saída de falha de validação.


Como eu pesquiso cadeias de correspondência múltiplas?

Use a validação Correspondência de padrão e digite uma cadeia de correspondência formatada em Perl. Por exemplo, para comparar as cadeias 123, 456 ou 789, digite:

^(123¦456¦789)$


O que acontece quando a validação de dados é habilitada?

O status da validação de dados é mostrado na entrada da lista de resultados Status de resultados do painel Histórico de resultados. O status de uma validação bem-sucedida é "Válido", e o de uma que falhou é "Inválido". Para ver mais detalhes sobre o resultado de validação, o resultado pode ser expandido.


O que é Formatação de dados na validação que falhou?

A formatação de dados "Formatação básica" não é aplicada a um resultado se a validação de dados tiver falhado. Em vez disso, a "Ação de falha de validação" é executada. Ela é diferente em comparação com a formatação de dados "Formatação baseada em script". Se a "Formatação baseada em script" for habilitada, a "Ação de falha de validação" não será executada e a função de formatação de script será executada. Isso permite, por exemplo, refinar o status "Validação de dados" por script.


Configurações de backup


O que é o Backup automático da configuração do leitor?

O backup automático funciona com os dispositivos conectados através da Ethernet. Quando estiver selecionada, esta função faz um backup da configuração do dispositivo em um disco externo (um servidor FTP) sempre que a configuração for salva na memória flash. Um serviço do Cognex Explorer pode receber os dados de backup. A restauração pode ser feita manualmente pelos comandos do Setup Tool, DMCC ou Cognex Explorer.

Configure o leitor com o endereço IP e o número da porta necessário para especificar onde você quer salvar a configuração. Você também poderá definir um nome do usuário e uma senha.


Imprimir código de backup do dispositivo


Para que a opção Imprimir código de backup do dispositivo pode ser usada?

Use essa opção para imprimir os códigos de backup do leitor (reinicialização forçada e código de reinicialização) de modo que você possa substituir seu dispositivo, lendo-o pelo leitor. Esses códigos também contêm as configurações de rede e configurações de serial.

Na seção Observações, você pode escrever observações importantes que também serão exibidas na página impressa. Se você desejar imprimir os códigos de reinicialização em páginas separadas, marque a caixa de seleção Imprimir o código de reinicialização em sua própria página.


Imprimir código de configuração


Para que a opção Imprimir código de configuração pode ser usada?

Use essa opção para imprimir os códigos de configuração do leitor (reinicialização forçada e código de reinicialização) para que eles possam ser lidos pelo dispositivo ou dispositivos que você deseja configurar.

Na seção Observações, você pode escrever observações importantes que também serão exibidas na página impressa. Se você desejar imprimir os códigos de reinicialização em páginas separadas, marque a caixa de seleção Imprimir o código de reinicialização em sua própria página.


Registro de dados em log


O que é registro de dados em log?

O registro de dados em log permite que você salve automaticamente as imagens lida em um local de arquivo específico. Além disso, é possível salvar os relatórios de validação de dados dos símbolos que você verificar, se a opção Validação de dados estiver habilitada para o tipo de código escaneado pelo leitor. Você precisar estar conectado ao Setup Tool para que o registro de dados em log funcione.


Quando desabilitar a Gráficos de sobreposição em um relatório?

Marque Desabilitar os gráficos de sobreposição no relatório se você não quiser que o quadrado verde ao redor do código de leitura apareça no PDF.


Ferramenta de visualização de imagem


Para que serve o Painel de imagens?

Nesse painel você pode ver a imagem lida pelo seu dispositivo.

Use os ícones de lupa para ajustar automaticamente a imagem ao tamanho da janela da ferramenta de visualização de imagem, para aumentar e diminuir o zoom da imagem ou para exibir a imagem em um modo pixel a pixel, respectivamente.

Você também pode habilitar ou desabilitar o Retorno do foco na imagem no modo Visualização ao vivo, além de copiar a imagem para a área de transferência.

Use a opção Salvar imagem para salvar apenas a imagem atual ou todas as imagens do burst e as opções de Registro em log para registrar todas as imagens não lidas ou todas as imagens decodificadas no sistema de arquivos. Clique na última opção de Registro em log Configurações de registro em log e relatório... para abrir a janela Opções do Setup Tool, que também está disponível na Página Inicial do Setup Tool por meio do menu Opções.

OBSERVAÇÃO: As Configurações da imagem exibida não possuem efeito ao salvar a última imagem obtida a partir do Painel de imagens (com arrastar e soltar). A última imagem é sempre salva em tamanho total (resolução máxima do dispositivo).


Onde colocar a imagem para que o leitor possa fazer a leitura da mesma?

Verifique se o símbolo está centralizado dentro da área de imagem do leitor e se o ponto a laser de alvo vermelho está no centro do símbolo.


Estão ocorrendo problemas na leitura dos códigos em minhas partes. O que fazer?

  • Certifique-se de pressionar e manter pressionado o disparador. Se você liberar o disparador antes que a leitura esteja completa, o leitor abandona sua tentativa de leitura.

  • Verifique se o leitor está dentro da distância de funcionamento especificado para o tamanho e tipo de código, como listado no documento mapa de leitura.

  • Certifique-se que você possui o código centralizado dentro da área de imagem do leitor e que o código é centralizado dentro da luz do alvo verde, antes de puxar o disparador.

  • Clique em Configurações de iluminação e do processador de imagens (Configurações UltraLight para DM7500, DM8500 e DM8600), depois ajuste as definições de iluminação.

  • Clique em Configurações de simbologia e certifique-se se o tipo de simbologia que você está usando está habilitado.


Estão ocorrendo problemas na leitura dos símbolos. O que fazer?

  • Certifique-se que o leitor está dentro da distância de funcionamento especificada para o tamanho e tipo de símbolo, como listado no guia de consulta rápida.

  • Certifique-se que você tem o símbolo centralizado dentro da área de imagem do leitor; certifique-se que o símbolo está centralizado dentro do apontador por laser vermelho quando o dispositivo é disparado.

  • Clique em Configurações de simbologia e certifique-se de que a simbologia que você está usando está habilitada.


Como ativar o leitor usando o Setup Tool?

Clique no botão do Disparo (ícone de raio) na barra de ferramentas na parte superior ou pressione <Ctrl>-T.


Como salvar uma imagem adquirida em um arquivo?

Clique no botão Salvar imagem na barra de ferramentas. Você pode salvar todas as imagens de um burst abrindo a lista de seleção para baixo e clicando em Salvar todas as imagens do burst.

Também é possível arrastar e soltar a imagem para o seu computador. No Visualizador de imagens, clique na imagem, arraste-a para fora do Setup Tool e solte-a.

Caso você queira salvar uma imagem arrastando e soltando a imagem, mas a imagem não é a mais recente (você está salvando a partir do Histórico de resultados da leitura), a imagem será salva com as configurações de imagem exibida. Como padrão, a qualidade será reduzida. Em Configurações da imagem visualizada, é possível alterar o tamanho da imagem para o tamanho cheio e formatá-la para Bitmap.


Buffer e transferência


O que são as configurações da imagem no buffer?

Em Configurações da imagem no buffer, é possível alterar o tamanho, o formato e a qualidade da imagem transferida por FTP.

  • tamanho: O tamanho padrão da imagem das imagens armazenadas no buffer é o tamanho total da imagem. A escolha entre os tamanhos da imagem permite ao leitor realizar uma subamostra de cada imagem, o que pode melhorar drasticamente a velocidade de transferência da imagem com o comprometimento de alguns detalhes de precisão da imagem.

  • formato: Como padrão, o leitor armazena toda imagem adquirida no formato .bmp.

  • qualidade: Disponível apenas se você estiver usando um formato de imagem .jpeg, este cursor ajusta os parâmetros internos que permitem ao leitor realizar uma operação regular na imagem adquirida que pode reduzir ou melhorar a velocidade de transferência.


Qual é a função da opção Gráficos de sobreposição?

Ao marcar esta opção, as imagens que você salvou (no FTP ou pela gravação) terão gráficos de sobreposição como arquivos SVG, juntamente com os arquivos de imagem.


Por que não é possível ver as imagens decodificadas?

A função Armazenamento no buffer e transferência não realiza a decodificação. Habilite a opção Gráficos de sobreposição no painel Configurações da imagem no buffer e suas imagens serão salva com gráficos de sobreposição (em arquivos SVG), que serão exibidos quando você reproduzir as imagens. Estes gráficos mostrarão os dados decodificados entre outras informações do decodificador.


O que posso fazer com a função Armazenamento no buffer e transferência?

A função Armazenamento no buffer e transferência permite controlar quais imagens serão gravadas e salvas no leitor. Também permite que você veja imagens gravadas no leitor e possibilita que transfira essas imagens para o seu computador.

  • A guia Buffer de imagens permite controlar quais imagens serão gravadas no leitor.

  • A guia Transferência de imagens para o PC permite controlar como as imagens serão transferidas do leitor para o seu computador.

  • A guia Transferência de imagens por FTP permite configurar a transferência automática de imagens do leitor para o seu computador.

  • Use a guia Transferência de resultados por FTP para configurar o leitor com o endereço IP e o número da porta necessários para enviar os resultados decodificados para um servidor FTP.


É possível enviar resultados codificados a um servidor FTP?

Use a guia Transferência de imagens por FTP para configurar o leitor com o endereço IP e número da porta necessários para enviar os resultados decodificados para um servidor FTP. A guia também contém ajustes para uma combinação de nome do usuário e senha, junto com o nome do arquivo para armazenar os resultados.


Como posso armazenar dados FTP em um diretório diferente do diretório raiz?

O campo Nome do arquivo aceita nomes de arquivo e nomes de caminho. Use a barra como delimitador. Por exemplo, /imagens/imagem.


Por que não é possível ver imagens e resultados no meu diretório FTP?

Verifique se você tem as permissões necessárias para criar arquivos. Se a opção acrescentar estiver marcada, verifique se o usuário do FTP possui permissões para acrescentar (que são diferentes das permissões para escrever). O usuário do FTP deve verificar o endereço IP do servidor correto do FTP.


Para que serve a lista Quais resultados serão armazenados no buffer?

A lista Quais resultados serão armazenados no buffer permite que você selecione quais tipos de imagens são armazenadas internamente no buffer, se tiverem informações decodificadas (Leitura), informação não decodificadas (Sem leitura), ambas (Todos) ou a Falha de validação, neste caso, apenas as imagens decodificadas com sucesso, mas com falhas de validação serão armazenadas.


Para que serve a opção Quais imagens serão armazenadas no buffer para resultado?

Você pode selecionar quais imagens serão armazenadas no buffer para resultado. A opção Igual ao resultado significa que para obter uma boa leitura, o leitor armazena somente imagens com um código encontrado.


Qual é o Tamanho máximo do buffer de imagens?

O Tamanho máximo do buffer de imagem equivale ao número máximo de imagens que podem ser armazenadas no leitor. É equivalente ao limite de memória do leitor, porém poderá ser definido para um número inferior ao máximo para evitar que um número de imagens superior ao desejado seja salvo no servidor FTP ou no PC.


O que significa a configuração Disponível para Setup Tool/DMCC?

Disponível para Setup Tool/DMCC se refere ao número de imagens não utilizadas pelo sistema de aquisição ou Gravação de imagens. Trata-se do número máximo de imagens de resultados que pode ser transferido para o Setup Tool ou para o SDK para um resultado.

OBSERVAÇÃO: É um valor informativo que não pode ser alterado.


O que posso configurar no modo Imagem com leitura satisfatória?

O modo Imagem com leitura satisfatória armazena todas as imagens com boa leitura no buffer, a menos que você defina uma taxa limite.

Você pode limitar o número de imagens com leitura satisfatória que são armazenadas no buffer escolhendo Taxa limitada. Defina a taxa de imagens lidas (o número de imagens armazenadas no buffer e a frequência dessa contagem) e a taxa de burst (a taxa de pico pelo tempo definido).


E se a opção Permitir sobrescrever o buffer for marcada?

A opção Permitir sobrescrever o buffer controla se as imagens armazenadas no buffer sobrescrevem as imagens mais antigas ou se o buffer para quando estiver cheio.


Como verificar se as imagens foram excluídas após a transferência?

Marque a caixa "Excluir após a transferência", que controla se as imagens são excluídas após a transferência. Aplica-se a qualquer modo de transferência, incluindo transferência de imagens por FTP e a transferência do leitor para o PC.


Por que o botão Transferir agora não está ativado?

Se você tiver imagens armazenadas no buffer do leitor, deverá selecionar a pasta para gravar as imagens. Você também deverá interromper a gravação antes de iniciar a transferência.

Observe que Transferir agora não funciona quando está fora do alcance da estação de base emparelhada com o dispositivo (no caso dos dispositivos portáteis), pois o buffer é apagado e desabilitado quando está fora do alcance.


O botão Limpar pasta de transferência apaga a tira de filme também?

O botão Limpar pasta de transferência exclui todas as imagens da pasta. Se as mesmas imagens estão sendo exibidas na tira de filme, a tira de filme também será apagada.


Se já houver arquivos na pasta selecionada, eles serão sobrescritos?

Se houver arquivos na pasta selecionada que corresponda ao Formato [Índice], o índice inicial será automaticamente aumentado até que não haja correspondente existente e, em seguida, a transferência iniciará. Os arquivos de imagem não serão sobrescritos.


Como visualizar as imagens individualmente?

Você pode visualizar as imagens uma por uma, porém deverá selecionar a pasta inteira onde as imagens estão localizadas. Assim que as imagens na pasta selecionada forem exibidas, clique nelas usando os botões para frente e para trás.


É necessário começar a visualizar as imagens novamente, se tiver que deixar o painel?

Não, ao deixar o painel Armazenamento no buffer e transferência, ele pausará a exibição como se o botão de pausa fosse clicado.


Como transferir as imagens para um servidor FTP?

Use a guia FTP para definir as configurações necessárias para transferir imagens para um servidor FTP. A guia contém configurações para o endereço IP e número da porta do servidor assim como uma combinação do nome do usuário e senha. Certifique-se que as imagens enviadas usando o FTP não são garantidas a serem enviadas, o que pode acontecer quando o leitor está operando em uma frequência maior e não pode agendar tempo para transferir imagens. Observe também que a transferência por meio de ligações sem fio pode ser muito mais lenta do que a comunicação por rede comum. Nesses casos, é recomendado o uso de imagens compactadas/com resolução reduzida.

A opção Nome do arquivo permite especificar o arquivo onde as imagens serão armazenadas. O campo Nome do arquivo permite a você especificar um caminho em relação ao diretório raiz do servidor FTP (por exemplo, /failed_images/image). A extensão do nome do arquivo (.jpg ou .bmp) apresentada na etiqueta após o nome do arquivo corresponde à configuração de formato da imagem no painel Configurações da imagem no buffer. Certifique-se que o leitor não crie diretórios; o diretório deve estar disponível e acessível.

O controle Valor máx. de acréscimo indica o limite do valor aumentado usado no nome do arquivo. Um valor de 0 indica que nenhum aumento será inserido e o arquivo pode ser sobrescrito.

O Nome do arquivo gerado por script permite gravar um script gerando o nome do arquivo no painel Geração de script, na guia Armazenamento em FTP.

A opção Nome do arquivo gerado pelo servidor inicia com um caminho em branco, que indica o diretório raiz no servidor FTP.


O tempo de execução da Transferência de imagens por FTP não está funcionando. O que fazer?

Verifique se você seguiu esses passos:

  • Digitou o endereço do servidor, o nome do usuário e a senha corretamente.

  • O modo de transferência está definido como "FTP - Tempo de execução".

  • A guia "Quais resultados serão armazenados no buffer" está definida com qualquer opção, exceto Nenhum (de acordo com as suas necessidades).

  • O seu servidor FTP dá suporte à transferência de imagem.


O que é Nome do arquivo gerado por script?

Você pode gravar um script para gerar o nome de arquivo para a transferência por FTP no painel Script, na guia Armazenamento em FTP.


O que é Nome do arquivo gerado pelo servidor?

Alguns servidores FTP aceitam esta função para nomear os arquivos de entrada de forma exclusiva, antes de salvá-los no disco.


O que devo fazer se as transferências por FTP da opção Nome do arquivo gerado pelo servidor não funcionarem?

Verifique se o servidor FTP aceita o comando "STOU – Store Unique". Este comando se comporta como o STOR, exceto pelo fato de que o arquivo resultante será criado no diretório atual com um nome exclusivo neste diretório.


Quais são os diferentes Modos de transferência?

O modo de transferência Mediante solicitação transfere imagens quando você clica em Transferir agora no Setup Tool ou quando você envia o DMCC adequado. Se você selecionar o modo de transferência FTP - Tempo de execução, as imagens serão enviadas automaticamente ao servidor FTP, desde que a conexão esteja ativa.

Observe que Transferir agora não funciona quando está fora do alcance da estação de base emparelhada com o dispositivo (no caso dos dispositivos portáteis), pois o buffer é apagado e desabilitado quando está fora do alcance.


Por que o painel inteiro está desabilitado ao transferir os arquivos?

O painel está desabilitado para que seja mantida a estabilidade máxima de transferência de imagens por FTP. A transferência de imagens por FTP pode levar alguns minutos, dependendo da velocidade da conexão com o FTP, do tamanho e do número de imagens transferidas.


Opções


O que posso configurar na página opções?

A Painel de opções do DataMan Setup Tool possibilita fazer ajustes na aplicação de acordo com suas preferências.


O que posso configurar no campo Configurações de idioma?

Aqui você pode escolher o idioma com o qual gostaria de usar o Setup Tool. O idioma padrão é inglês.

OBSERVAÇÃO: o aplicativo precisa ser reiniciado para que as alterações sejam aplicadas.


O que posso configurar na Página de códigos do campo Exibição de códigos?

Aqui, você pode definir a maneira como a cadeia de leitura será codificada.


O que posso configurar no campo Esquema de cores?

Selecione o esquema de código da sua janela do DataMan Setup Tool nesse campo.


O que posso configurar na caixa Redefinir configurações?

Nessa caixa, selecione uma categoria (Comunicação, Layout, As mensagens não serão mostradas novamente, Registro de dados em log, Dispositivos excluídos, Página de código, Idioma, RTM Lean - Todas as configurações, Pastas padrão, Dispositivos virtuais, Verificação, Bipe, Assistentes) que você deseja redefinir para os padrões.


Para que serve a configuração Local do backup?

É possível definir aqui a pasta que é usada pela função de Backup para salvar os arquivos de backup.


Que configurações estão disponíveis na guia Registro de dados em log?

Nessa guia, você pode configurar as pastas onde os códigos de resultado, imagens decodificadas, imagens não lidas e relatórios serão salvos, bem como alterar nomes de arquivo e extensões quando registrar dados.


Como posso habilitar a geração de relatório de validação de dados?

Selecione Gerar relatórios de validação de dados em Registro em log no painel Histórico de resultados.


O que posso configurar no campo Buffer de imagens e transferência?

Você pode definir a pasta para onde podem ser transferidas as imagens.


O que posso configurar no campo Configurações do bipe?

Você pode definir a configuração de bipe de PC para boa leitura. Quando o Setup Tool recebe o resultado de boa leitura do leitor DataMan, ele ligará o bipe de PC. Isso pode ser útil para leitores DataMan que não possuem um dispositivo de bipe interno. Você pode definir a Frequência, de 1000 Hz até 10000 Hz, e a Duração, de 10 ms até 1000 ms, de um bipe de boa leitura.


Como você pode ativar a função de Relatório?

Após ter preenchido os campos do Relatório, precisará ligar a Validação de dados para gerar os relatórios.


O Código de resultado, Imagens decodificadas ou Imagens não lidas não são exibidos no diretório correspondente. Qual será o problema?

Você precisa habilitá-las nas caixas de listagem suspensas de Registro correspondentes.


Visualização de tabela


Por que alguns valores são mostrados em destaque?

Valores que estão destacados são valores não padrão, inicialmente. As regras de destaque podem ser alteradas na seção Destaque do menu de faixa de opções; consulte a questão Visualização de tabela: Menu de faixa de opções para obter mais informações.


Por que alguns valores são mostrados em negrito?

Valores em negrito são expansíveis e mostram subvalores.


Como saber quais são os valores possíveis?

Movimente o mouse sobre um valor e veja o texto flutuante que indica o valor mínimo, máximo e o padrão, quando for relevante.


Visualização de tabela: Disposição geral e estrutura

Visualização de tabela é uma ferramenta de exibição que usa um estilo de grade.

A linha de cabeçalho exibe o nome do dispositivo. A linha do segundo cabeçalho, embaixo da primeira, exibe as configurações disponíveis para o dispositivo. Os cabeçalhos de linha abaixo (a negrito) podem ser recolhidos ou abertos, clicando no ícone junto deles. Quando o dispositivo é desconectado, surge um ícone reconectar na linha de cabeçalho dele.

As configurações que não são dependentes da configuração de leitura são exibidas somente na primeira coluna (Configuração principal).


Visualização de tabela: Controles (mouse e teclado)

Seleção:

  • Mouse: Ao clicar em uma célula da grade, ela é selecionada; o que destaca o cabeçalho de linha da célula e o cabeçalho da coluna onde o dispositivo e a configuração pertencem. Os botões do menu e itens no menu de faixa de opções podem mudar em linha com a seleção. Se a célula selecionada estiver na linha de uma linha de cabeçalho, todas as células na coluna atual que pertencem ao cabeçalho são selecionadas.

  • Teclado: As teclas de movimento do cursor navegam a seleção para a célula apropriada. O procedimento de destaque e seleção é o mesmo que por mouse.

Adicionar/alterar valores:

  • Mouse: Para células com editores integrados, clicando no controle do editor (caixa de combinação, caixa de seleção, numérico acima-abaixo) permite a entrada de valores. Para células com editores personalizados (o ícone '...’), abre um editor pop-up, permitindo a entrada do valor.

  • Teclado: Para células com editores integrados, pressionar Enter ou F2 inicia o modo de edição, Esc cancela a edição e um segundo Enter confirma a edição. Os valores podem ser inseridos no texto selecionado sem entrar no modo de edição; no caso, o valor atual é substituído no primeiro pressionamento de tecla.

    Para células numéricas, para além das células com editor de texto integrado, as setas para cima e para baixo aumentam e diminuem o valor.

    Para células suspensas, Enter inicia o modo de edição e exibe os itens suspensos, enquanto as setas para cima e para baixo movem a seleção. Um segundo Enter aplica o valor selecionado e Esc cancela a edição.

    Para células com caixa de seleção, usar o Espaço para alternar estados marcados/desmarcados.

Copiar e colar:

Use as combinações do teclado Ctrl+C e Ctrl+V para copiar e colar, respectivamente; consulte a descrição de copiar-colar dos itens do menu de faixa de opções relacionados para mais informações.


Visualização de tabela: Menu de faixa de opções

O menu de faixa de opções pode ser encontrado acima da grade de visualização de tabela. Seus conteúdos e ícones ativos podem mudar em linha com a seleção das células, linhas ou colunas, na grade. O menu está separado em vários grupos.

  • Visualização de tabela: Use o botão Adicionar a configuração para adicionar ou copiar configurações de leitura para o dispositivo selecionado. Excluir configuração exclui a(s) configuração(ões) de leitura selecionada(s). O botão Alterar ordem habilita a alteração da ordem da configuração de leitura entre a qual o dispositivo alterna.

  • Editar: Use Copiar (ou Ctrl+C no teclado) para copiar um valor da célula selecionada atualmente. Colar pode ser usada somente na mesma linha ou em qualquer editor de texto.Redefinir valores é usado para redefinir o(s) valor(es) da célula ou células selecionada(s).

  • Destaque: Os botões e configurações nesse grupo do menu fornecem opções para destacar planos de fundo específicos da célula. Com o parâmetro Valores não padrão, as células que possuem valores não padrão são destacadas (isso pode ser diferente em uma única linha para diferentes dispositivos ou configurações de leitura). A configuração Diferença para referência destaca células que possuam valores diferentes da célula na mesma linha da configuração de leitura de referência (e dispositivo). A terceira configuração está selecionada; todos os valores e cabeçalhos que contêm o texto especificado na caixa de texto estão destacados. Adicionalmente, o próprio texto contido está destacado com um plano de fundo de texto diferente. Pressionar Enter também aplica a função do botão Exibir somente linhas destacadas.

    Quando habilitado, Exibir somente linhas destacadas recolhe todos os nós que não tenham qualquer subnó destacado. Quando ativado, Definir configuração de leitura de referência especifica a configuração de leitura (e dispositivo) que é usada como referência quando o modo de destaque Diferença para referência é usado. Quando o botão está ativo, a coluna da célula atualmente selecionada (configuração de leitura) torna-se a configuração de referência. A configuração de leitura atual é marcada na linha de cabeçalho do nome da configuração.

  • Filtragem: Configurações globais, a configuração padrão, somente exibe configurações que não podem conter valores diferentes em diferentes configurações de leitura. Defina Parâmetros da configuração de leitura para visualizar somente as configurações que são dependentes da configuração de leitura. Defina Todas as configurações para visualizar todas as configurações simultaneamente. Se uma entrada possuir valores em mais configurações de leitura, eles estão visíveis em colunas diferentes.

  • Outro: Use Expandir todas as linhas para expandir todas as linhas que tenham sido recolhidas na grade. Use Recolher todas as linhas para recolher todas as linhas expandidas na grade. Redefinir layout recalcula as larguras da coluna para utilizar todo o espaço disponível. Se o espaço disponível não for suficiente, é aplicada uma largura de coluna mínima.


Informações legais


Direitos autorais

A Cognex Corporation não assume qualquer responsabilidade para o uso ou confiabilidade deste software sobre equipamentos que não foram fornecidos pela Cognex Corporation. A Cognex Corporation não oferece nenhuma garantia, seja expressa ou implícita, relacionada ao software descrito, sua comercialidade ou sua adequação a qualquer propósito em particular.

As informações contidas neste documento estão sujeitas à alteração sem aviso prévio e não devem ser construídas como um compromisso da Cognex Corporation. A Cognex Corporation não é responsável por quaisquer erros que podem ser apresentados tanto neste documento ou no software associado.

Direitos autorais © 2019 Cognex Corporation. Todos os Direitos Reservados

Este documento não pode ser copiado no todo ou em parte nem transferido para qualquer outro meio ou idioma, sem a permissão por escrito da Cognex Corporation.

O hardware e porções do software descritos neste documento podem ser protegidos por uma ou mais das patentes americanas listadas no website Cognex http://www.cognex.com/patents.asp. Outras patentes americanas e estrangeiras estão pendentes.


Software licenciado

SpiderMonkey

Este software está sujeito aos termos de uso do documento "Mozilla Public License", v. 2.0. Acesse uma cópia do documento "MPL" em http://mozilla.org/MPL/2.0/.

Se quiser receber uma cópia do código fonte do SpiderMonkey, entre em contato com o suporte técnico da Cognex em <spidermonkey@cognex.com>

Licença PCRE

O PCRE é uma livraria de funções para suportar expressões regulares como sintaxe e semântica o mais próximo possível daqueles da linguagem Perl 5.

A liberação 5 da PCRE é distribuída sob os termos da licença "BSD", como especificado abaixo. A documentação para a PCRE, fornecida no diretório "doc", é distribuída sob os mesmos termos que o próprio software.

Escrito por: Philip Hazel <ph10@cam.ac.uk>

Universidade de Cambridge Computing Service, Cambridge, Inglaterra. Telefone: +44 1223 334714.

Direitos autorais (c) 1997-2004 Universidade de Cambridge. Todos os direitos reservados.

A redistribuição e o uso na fonte e formas binárias, com ou sem modificação, são permitidos sabendo-se que as seguintes condições são conhecidas:

  • As redistribuições do código fonte devem manter o aviso de direitos autorais acima, que lista as condições e a seguinte isenção de responsabilidade.
  • As redistribuições em forma binária devem reproduzir o aviso de direitos autorais acima, esta lista de condições e a seguinte isenção de responsabilidade na documentação e/ou outros materiais fornecidos com a distribuição.
  • Nem o nome da Universidade de Cambridge, nem os nomes de seus colaboradores podem ser usados para endossar ou promover produtos derivados deste software sem permissão por escrita anterior específica.

ESTE SOFTWARE É FORNECIDO PELOS TITULARES E CONTRIBUINTES DE DIREITOS AUTORAIS "DA FORMA ATUAL" E QUALQUER GARANTIA EXPRESSA OU IMPLÍCITA, INCLUINDO, MAS NÃO LIMITANDO, AS GARANTIAS IMPLÍCITAS DE MERCADO E AJUSTE PARA UM PROPÓSITO EM PARTICULAR, SÃO DECLINADOS. EM NENHUM EVENTO OS CONTRIBUINTES OU DETENTORES DE DIREITOS AUTORAIS SÃO RESPONSÁVEIS POR QUALQUER DANO DIRETO, INDIRETO, ESPECIAL, EXEMPLAR OU CONSEQUENTE (INCLUINDO, MAS NÃO LIMITADO AO ACORDO DE SUBSTITUIÇÃO DE BENS OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) TODAVIA CAUSADO E EM QUALQUER TEORIA DE RESPONSABILIDADE, SE NO CONTRATO, A RESPONSABILIDADE RESTRITA OU ATO ILÍCITO (INCLUINDO NEGLIGÊNCIA OU OUTRO) SURGIDO DE QUALQUER FORMA DO USO DESTE SOFTWARE, MESMO SE AVISADO DA POSSIBILIDADE DESTE DANO

Fim

Software JPEG

Este software é baseado em parte do trabalho do Grupo Independente JPEG.

biblioteca de compactação zlib

Este software é baseado em parte no trabalho de Jean-loup Gailly e Mark Adler.

Parsifal XML Parser

Direitos Autorais (c) 2002-2005 Toni Uusitalo liberou para domínio público em 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal é gratuito tanto para o uso e redistribuição comercial quanto não comercial, sabendo-se que os direitos autorais do autor e isenção de responsabilidade são mantidos intactos. Você é livre para modificar a Parsifal para seu próprio uso e para redistribuir Parsifal com suas modificações, desde que as modificações sejam claramente documentadas.

ISENÇÃO DE RESPONSABILIDADE

Este programa é distribuído na esperança que será útil, mas SEM NENHUMA GARANTIA; mesmo sem a garantia implícita de mercado ou ajuste para uma proposta em particular. Use SOB SUA PRÓPRIA RESPONSABILIDADE.


Informação de patente

Este produto é coberto por uma ou mais das patentes americanas listadas abaixo, aplicações americanas e/ou patentes estrangeiras http://www.cognex.com/patents irá listar qualquer patente relevante emitida subsequentemente

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 e EP1687752