DataMan 8072 : Preguntas y respuestas


Pantalla de bienvenida


Bienvenido

Para configurar su dispositivo rápidamente, se recomienda seguir los Pasos de aplicación representados por los botones grandes en el lado izquierdo. Cada sección tiene una pestaña con opciones de configuración básicas o avanzadas. El botón de acción Guardar configuración guarda los datos de configuración en el lector y guarda una copia de seguridad en su PC con un solo clic. Las preguntas siguientes describen las opciones de configuración en cada uno de los pasos de aplicación que requieren explicación.


¿Qué puedo configurar en Tipo de aplicación?

Al hacer clic en la flecha de la derecha, se pueden seleccionar los modos de lectura adecuados en el menú desplegable.


¿Qué puedo hacer en el paso Optimizar imagen?

Puede llevar a cabo el proceso de configuración, ajuste y prueba del dispositivo conectado, y puede establecer la configuración de iluminación del dispositivo.


¿Qué puedo seleccionar en Detalles de código?

Aquí puede seleccionar los símbolos que el DataMan debe leer, así como diferentes escenarios de código múltiple. Este menú también permite establecer la configuración avanzada del decodificador.


¿Qué puedo configurar en el paso Detalles de aplicación?

Aquí puede definir la configuración de disparo y de exposición. Para simplificar el proceso, un asistente para disparos, un asistente para intervalos y un asistente para la exposición le ayudarán con la configuración.

En la pestaña Avanzado, puede implementar más configuraciones en una vista de tabla.


¿Qué puedo configurar en Formatear datos?

Para crear la salida de datos deseada del dispositivo, puede utilizar expresiones regulares de formato básico o estilo Perl con el fin de generar una cadena de salida personalizada mediante módulos predefinidos, o utilizar el motor de JavaScript para crear una secuencia de comandos de formato de datos flexible.


¿Qué puedo configurar en el paso Entradas/Salidas?

En este panel, se puede configurar el comportamiento de los botones y líneas de entrada y salida. Aquí también se pueden configurar los detalles para un codificador de pulsos y la longitud de pulso de la alarma sonora. Este panel también incluye el enlace a la configuración de la imagen almacenada para enviar imágenes por FTP a un servidor.


¿Qué puedo configurar en el paso de aplicación Comunicaciones?

En las tres pestañas del paso de aplicación Comunicaciones, se puede implementar la configuración de Ethernet y serie. Haga clic en la pestaña adecuada para introducir los valores de configuración.


¿Qué hace la opción Guardar configuración?

Guardar configuración es una acción más que un paso, pero es importante realizarla. Esta acción guardará la configuración actual en la memoria persistente del lector, por lo que se cargará la misma configuración después de reiniciar. La herramienta de configuración DataMan también almacenará un archivo de copia de seguridad localmente en el PC actual en la carpeta de copia de seguridad predeterminada.


¿Qué es el archivo de backup de la configuración?

El archivo de backup de la configuración contiene todos los parámetros y configuraciones del dispositivo. Se puede utilizar para restaurar la configuración a un estado conocido o para configurar nuevos dispositivos seleccionando parámetros de configuración con propiedades de backup o sin.


Conectar al lector


¿Cómo conecto mi lector a la herramienta de configuración?

Independientemente de qué lector esté usando, siga estos pasos para conectar su lector DataMan a la herramienta de configuración:

  1. Imprima una copia del documento Códigos de configuración del lector para su lector, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.

  2. Conecte el cableado necesario entre su lector y el PC que ejecute la herramienta de configuración. Para más información, consulte su documentación impresa de referencia rápida.

  3. Haga clic en Actualizar en la herramienta de configuración.

  4. Seleccione el puerto COM o el Dispositivo de red que muestre una conexión con el lector.

  5. Haga clic en Conectar.


¿Por qué no se conecta la herramienta de configuración al lector?

Si no puede establecer una conexión, compruebe lo siguiente:

  • Asegúrese de que ha escaneado el código de configuración (USB COM o Serie RS-232) correspondiente al tipo de conexión física (no aplicable a lectores con solo Ethernet).

  • Asegúrese de que la aplicación antivirus o de firewall instalada en el ordenador admita la comunicación con dispositivos Ethernet permitiendo los puertos adecuados (Cognamer: 1069 y herramienta de configuración: 44444).

  • Asegúrese de que la lista de puertos COM muestre un puerto al que esté conectado el lector.

    DataMan series 60, 300, 370, 470, 503, 8000: si el lector se encuentra conectado a su red Ethernet, verifique que aparece en la lista de dispositivos de red.

    Haga clic en Actualizar para determinar qué puertos tienen lectores conectados.

    Nota: al hacer clic en Actualizar se envía una cadena de consulta a todos los puertos COM y por toda la subred de la red Ethernet. Debe haber activo un lector DataMan 8000 inalámbrico para responder a la consulta. Puede pulsar el disparador para activar el lector.

  • Asegúrese de que no está usando el teclado, el decodificador de teclado o la conexión HID: debe utilizar un Serie USB, un Serie RS-232, o una red Ethernet o inalámbrica para conectar la herramienta de configuración del lector.

  • DataMan series 60, 300, 370, 470, 503, 8000: asegúrese de que la dirección IP proporcionada en la opción Agregar dispositivo es correcta.

  • Solo lectores inalámbricos DataMan 8000: asegúrese de que el lector no está en modo de ahorro de energía (pulse el disparador para activarlo).

  • Solo lectores inalámbricos DataMan 8000: asegúrese de que se establezca una conexión entre el lector y la estación base conectada a su PC. Para comprobarlo, escanee el código de configuración Desconectar impreso en la guía de referencia rápida, desenchufe los cables de alimentación y comunicación de la estación base, vuelva a conectar los cables y, a continuación, vuelva a colocar la terminal en la estación base. Espere hasta que la terminal indique que está conectada (con una señal acústica) antes de intentar establecer una nueva conexión.

  • Solo lectores inalámbricos DataMan 8000: Asegúrese de que la estación base esté conectada a la fuente de alimentación.

Puede utilizar un programa de emulación de terminal como HyperTerminal para determinar si el lector está enviando datos si se encuentra conectado a un puerto COM en el PC.


¿Por qué veo un icono superpuesto en la parte superior derecha del icono de mi dispositivo?

Este icono de flecha indica que se trata de un dispositivo agregado manualmente. El icono «V» indica que el dispositivo es un dispositivo virtual.


¿Qué son los dispositivos virtuales?

El icono «V» superpuesto en la parte superior derecha del icono del dispositivo indica que el dispositivo es un dispositivo virtual. Los dispositivos virtuales pueden crearse en Reparación y asistencia a partir de un archivo de configuración personalizada o un dispositivo con configuración predeterminada. Los dispositivos virtuales pueden utilizarse para examinar distintos paneles en la herramienta de configuración sin la necesidad de conectar un dispositivo real.

El dispositivo virtual creado no es visible para los demás dispositivos de la red. El dispositivo virtual persiste durante varias instancias de la herramienta de configuración.

El dispositivo virtual creado puede conectarse del mismo modo que un dispositivo normal, pero todos los cambios de configuración son rechazados (todo es de solo lectura) y las características, funciones y acciones no funcionan en los dispositivos virtuales.


¿Qué puerto debo utilizar para una conexión USB?

Si conecta el lector o la estación base utilizando el puerto USB, debe escanear el código de configuración USB-COM/RS-232 que figura en el documento Códigos de configuración del lector. Después, haga clic en Actualizar y seleccione el puerto identificado como conectado al lector.

Nota: al hacer clic en Actualizar se envía una cadena de consulta a todos los puertos COM y por toda la subred de la red Ethernet. Debe haber activos un lector DM7550 y un DM8000 inalámbricos para poder responder a la consulta. Pulse el disparador para activar el lector.


Sigo sin poder establecer una conexión con el lector o con la estación base: ¿puedo reiniciarlo?

Para la estación base DataMan 8000:

Con el lector inalámbrico asociado a su estación base, escanee el comando Restablecer los valores predeterminados de la estación base (para la base DM8000) para devolver la estación base a sus valores predeterminados de fábrica.

Para lectores DataMan de las series 503 y 8000:

Escanee el comando Reiniciar el escáner impreso al final de la guía de referencia rápida para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y se reinicia.

Si el problema persiste, escanee el comando Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.

Si continúa sin poder establecer la conexión, y está usando un lector con cable, desenchufe el lector de la corriente (este procedimiento no es posible con el dispositivo DataMan 9500). Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.

Si el problema persiste y está usando un lector inalámbrico DataMan 8000, extraiga la batería del lector y colóquelo en la estación base. Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.

Para lectores DataMan 50, 60 y 70:

Imprima una copia del documento Códigos de configuración para su lector, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.

Escanee el código Reiniciar el escáner para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y reinicia.

Si sigue sin poder conectarse al lector, escanee el código Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.

Si eso no soluciona el problema, desenchufe el lector de la corriente (alimentación CC y USB, si procede). Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.


¿Cómo sé cuál es mi dispositivo?

Para lectores DataMan 260, 300, 473, 500, 503 y 8000:

En el árbol en el que se enumeran los dispositivos, en Conectar al lector, haga clic con el botón derecho del ratón en un lector y seleccione Identificar. El indicador de estado en el lector emite una señal, lo que le permite identificarlo.


¿Por qué aparecen en verde algunos dispositivos?

Los dispositivos descubiertos recientemente aparecen en verde durante unos segundos para comunicarle que se ha añadido un nuevo dispositivo a la vista de árbol.


DataMan series 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 y estación base DataMan 8000: ¿por qué solicita una contraseña la herramienta de configuración cuando quiero conectarme?

El lector y la estación base pueden configurarse para solicitar una contraseña antes de conectarse a la herramienta de configuración. La contraseña se activa en la pestaña Autenticación en la opción Configuración de red del panel Configuración de comunicación. Tenga en cuenta que la contraseña se emplea también para la conexión en serie.


DataMan 60, 300, 370, 470, 503, 8000 series y estación base DataMan 8000: ¿puedo conectar el lector a mi PC directamente mediante Ethernet?

El lector o la estación base pueden conectarse directamente a un conector Ethernet (RJ-45) en su PC. Si el dispositivo está configurado para DHCP, aparecerá en la lista de dispositivos de red aproximadamente unos 20 segundos después. Tenga en cuenta, no obstante, que su PC podría necesitar un minuto adicional para que se resuelva su dirección IP. No podrá conectar el dispositivo a través de la herramienta de configuración hasta que haya concluido esta operación.

Si su dispositivo se ha configurado para utilizar una dirección IP estática, dicho dispositivo solo aparecerá si comparte la misma subred que el PC.


DataMan series 60, 300, 370, 470, 503, 8000, MX-1000 y estación base DataMan 8000: ¿cómo hago corresponder un elemento de la lista de dispositivos de red con un lector específico?

De forma predeterminada, cada DataMan aparece en los dispositivos de red con un prefijo DM y los últimos seis caracteres de su dirección MAC, impresa en el dispositivo.


DataMan series 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 y estación base DataMan 8000: ¿qué hacer si mi lector o estación base no aparecen en la lista de dispositivos de red?

Si el lector o la estación base deseados no aparece en la lista, puede añadirlos reiniciándolos. Una vez encendidos, los dispositivos pueden tardar hasta 60 segundos en aparecer en la lista.

Si reiniciar el dispositivo no soluciona el problema, la herramienta de configuración quizás no sea capaz de comunicarse con el dispositivo debido a la configuración de red, y no aparecerá en la lista de dispositivos de red.

Compruebe la conexión Ethernet con el lector o la estación base y haga clic en Actualizar en la herramienta de configuración.

Si sabe cuál es la dirección IP del lector o de la estación base, utilice la opción Agregar dispositivo.

Este método permite que el lector o la estación base DataMan aparezca en la lista de dispositivos de red para que pueda conectarse al lector mediante la herramienta de configuración y su conexión Ethernet.


Lector inalámbrico DataMan 8000: ¿cómo puedo asociar un lector inalámbrico a otra estación base?

Si la estación base a la que desea asociar el lector inalámbrico ya está asociada a otro lector, debe romper esa conexión escaneando el código Desasignar lector de estación base. Para asignar el lector a una nueva estación base, simplemente coloque el nuevo lector en la estación base. Se emparejarán automáticamente.


Estación base DataMan 8000: ¿cómo puedo restablecer la conexión USB a la estación base?

Si tiene problemas para establecer o mantener una conexión USB entre una estación base y el PC, siga los pasos siguientes para restablecer la conexión USB:

  1. Desconecte el cable USB y el cable de alimentación de la estación base.

  2. Vuelva a conectar el cable USB y el cable de alimentación a la estación base.

  3. Coloque el lector en la estación base.

  4. Retire el lector de la estación base y escanee el código de configuración USB-COM/RS_232.


¿Cómo funciona el botón Comparar configuración?

El botón Comparar configuración inicia la función de comparación de configuraciones de la herramienta de configuración; se trata de una herramienta a estilo de vista de tabla que permite establecer, copiar, comparar o restaurar las configuraciones de los dispositivos. La función abre una nueva página de documento.

Si no se seleccionan dispositivos en la lista de dispositivos antes de pulsar el botón, se abrirá un documento vacío. Si se seleccionan uno o más dispositivos, el documento de comparación se llenará con la configuración de dichos dispositivos.


¿Qué es el dispositivo de RTM Lean o RTM que se muestra en Red?

Real Time Monitoring (RTM) Lean es una característica integrada en la herramienta de configuración DataMan y RTM es una aplicación de software compatible con el hardware accesible a través de la herramienta de configuración DataMan que permite recopilar y analizar distintos tipos de datos relacionados con los dispositivos en la red y sus lecturas. Puede conectarse a RTM Lean o RTM como si se tratase de un dispositivo y luego configurar la recopilación de datos en un documento recién abierto. RTM Lean o RTM solo recopila datos de forma activa cuando se está ejecutando y se está conectado a él.

Durante la configuración inicial, se le pedirá que elija el dispositivo que RTM Lean o RTM vaya a supervisar y luego el tipo de datos (fuera de los predeterminados) que se van a recopilar. Esto puede redefinirse en Configuración en el menú de la cinta. De forma predeterminada, RTM Lean o RTM recopila datos estadísticos (tasa de lectura, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo).

NOTA: RTM Lean puede adquirir datos de un solo dispositivo a la vez y conservar los datos durante 48 horas. La versión completa de RTM no tiene dichas limitaciones.


Optimizar imagen


¿Qué puedo hacer en el paso Optimizar imagen?

Aquí puede realizar el proceso de configuración, ajuste y prueba de su dispositivo conectado.

Para configurar su dispositivo rápidamente, se recomienda seguir los Pasos de aplicación representados por los botones grandes en el centro, donde podrá seleccionar opciones de configuración básicas o avanzadas. El botón de acción Guardar configuración le permite guardar todos sus datos de configuración de forma simple. Las preguntas siguientes describen las opciones de configuración en cada uno de los pasos de aplicación que requieren explicación.


¿Cómo puedo guardar una imagen adquirida en un archivo?

Haga clic en el botón Guardar imagen en la barra de herramientas del panel de imágenes o del visor de imágenes.

También puede arrastrar y colocar la imagen en su PC. Haga clic en la imagen en la ventana Pantalla de imagen, arrástrela fuera de la herramienta de configuración y suéltela.

NOTA: en caso de querer guardar una imagen que no sea la más reciente mediante arrastrar y colocar (está guardándola desde el Historial de resultados de lectura), la imagen se guardará con la configuración de la imagen mostrada. De manera predeterminada, esta será de calidad reducida. En Configuración de la imagen mostrada, puede cambiar el tamaño de la imagen a completo y el formato a mapa de bits.


¿Cómo puedo utilizar el botón En vivo?

En la pestaña Básico, haga clic en el botón En vivo para pasar al modo En vivo. El modo En vivo no solo supervisa las lecturas del dispositivo, sino que también las decodifica. Al hacer clic en el extremo derecho del botón, se abren más opciones.

Marque la opción Decodificación si desea que el dispositivo decodifique las imágenes tomadas. Cuando está marcada, Información del enfoque muestra un medidor codificado por colores a la derecha de la visualización de imágenes. El medidor indica el enfoque de la lente (cuanto menor es la medición, menos enfocada está la lente).

Marque la opción Exposición automática para que el lector determine automáticamente la mejor configuración de exposición en la imagen. El control (debajo del área de visualización de imágenes) indica la intensidad de la luz deseada de los píxeles.

En la pestaña Avanzado, se puede ver una vista de tabla de la configuración de la imagen.


¿Para qué se utiliza el panel Rendimiento de lectura?

Los gráficos del panel Rendimiento de lectura, situado a la derecha, le permiten supervisar los tiempos de decodificación y las tasas de lectura en tiempo real. Haga clic en el botón Borrar para restablecer el gráfico.


¿Qué configuraciones de disparo puedo modificar?

Puede configurar el Tipo de disparo como Manual (botón) o Presentación (interno). Para más configuraciones de disparo, vaya al panel Configuración de luz y generador de imágenes haciendo clic en el elemento correspondiente de la cinta y seleccione la pestaña Configuración de disparo.

Tenga en cuenta que en el modo Presentación, cuando el operador acciona el disparador, el lector cambia al modo Manual hasta que se vuelva a acoplar el dispositivo a la estación base.

Consulte las preguntas y respuestas sobre Detalles de aplicación para obtener más información.


¿Cómo puedo cambiar el valor de exposición para el DataMan 8050?

Esta configuración está activada cuando usa la opción de Exposición manual (que puede cambiar en el panel Configuración de luz y generador de imágenes).


¿Qué es Configuración de la imagen mostrada?

La configuración de la imagen mostrada controla el modo en el que el lector muestra las imágenes que adquiere como respuesta a las entradas del disparo de adquisición así como las imágenes en directo tomadas por cualquier lector. La modificación de esta configuración no afecta al rendimiento del lector, solo a la calidad de la imagen y a la velocidad de transferencia entre el lector y la herramienta de configuración.

NOTA: algunas propiedades relacionadas con las imágenes (p. ej. tamaño de imagen, filtrado) no pueden modificarse cuando el dispositivo está adquiriendo o decodificando imágenes.

NOTA: configuración de la imagen mostrada no tiene efecto cuando se guarda la última imagen tomada del Panel de imágenes (arrastrando y soltando). La última imagen siempre se guarda a tamaño completo (la máxima resolución del dispositivo).

  • tamaño: de forma predeterminada, la herramienta de configuración muestra un cuarto de todos los píxeles de la imagen adquirida, o una fracción de cada imagen durante una visualización en vivo. La elección entre diferentes tamaños de imagen permite al lector realizar un submuestreo de cada imagen, lo que puede mejorar considerablemente la velocidad de transferencia de la imagen del lector a la herramienta de configuración a costa de algunos detalles de imagen precisos.

  • calidad: disponible únicamente si se utiliza el formato de imagen .jpeg, este control ajusta los parámetros internos que permiten al lector realizar una operación de suavizado en la imagen adquirida, que puede reducir o mejorar la velocidad de transferencia del lector a la herramienta de configuración.


¿Qué puedo cambiar con el control deslizante Intensidad interna?

Puede establecer la intensidad de la luz de los LED de iluminación del DM8050,DM8070’.


¿Cómo especifico una región de interés en cada imagen adquirida?

Cambie su configuración a través del panel Tamaño de imagen (Región de interés).


¿Qué es la visualización en vivo?

Si activa Visualización en vivo activada (haciendo clic en el icono Visualización en vivo en la barra de tareas superior o en la pestaña Acción), la visualización de imagen muestra constantemente lo que está en el campo de visión del lector. Puede utilizar este modo para verificar lo que está viendo el lector sin intentar decodificar los símbolos.

Para cambiar el tamaño y la calidad de la imagen que se muestra en directo, vaya al panel Configuración de la imagen mostrada.

NOTA: está opción no está disponible en DM262 y DM362.


¿Cómo puedo aumentar la velocidad de transferencia de imágenes?

Si la casilla Transferir y mostrar imagen está marcada, la herramienta de configuración transfiere la imagen adquirida para cada operación de decodificación. Si se recibe una nueva señal de disparo durante la transferencia de la imagen actual, el lector descartará la imagen parcialmente transferida e iniciará la transferencia de la nueva imagen.

La velocidad de transferencia de la imagen depende de la cantidad de compresión de la imagen que aplica el lector. Puede controlar el valor de compresión de la imagen seleccionando la opción Configuración de la imagen mostrada. Al disminuir el tamaño o la calidad de la imagen, aumentará la velocidad de transferencia.


He marcado la casilla «Transferir y mostrar imágenes». ¿Por qué no veo ninguna imagen?

Si interrumpe la transferencia de imágenes pulsando el disparador, no se transferirá ninguna imagen. Asimismo, las imágenes antiguas en la cuadrícula Historial de lectura pueden no contener imágenes.

Nota: Si el retraso de salida es más corto de lo que necesita el lector para adquirir y decodificar una imagen para obtener resultados, la herramienta de configuración puede no recibir imágenes de resultados del lector.


Detalles de código


¿Cómo puedo desactivar todos los símbolos con rapidez?

Haga clic en Desactivar todas las simbologías en la parte superior de la pestaña Básico en el paso de aplicación Detalles de código o pulse Ctrl+D.


¿Cómo puedo ajustar la configuración de símbolos avanzada?

Haga clic en la pestaña Avanzado en Detalles de código para especificar más configuraciones.


¿Discrimina el lector automáticamente distintos tipos de símbolos?

El lector detecta, identifica y decodifica automáticamente símbolos codificados utilizando cualquiera de los símbolos activados en la herramienta de configuración.


¿Es posible que el rendimiento del lector mejore si se limita el número de símbolos activados?

Para mejorar el rendimiento, active únicamente los tipos de símbolos con los que espera encontrarse.


¿Cuáles son las distintas configuraciones para las propiedades EAN.UCC Compuesto?

  • Estándar (lineal y 2D): consta de un componente lineal (que codifica la identificación primaria del elemento) asociado a un componente compuesto 2D adyacente (que codifica datos adicionales, como el número de lote o la fecha de caducidad).

  • Solo lineal: consta únicamente del componente lineal que codifica la identificación primaria del elemento.


¿Qué es el CC-C?

CC-C es uno de los tres componentes del compuesto EAN.UCC 2D, específicamente un símbolo PDF417 con una palabra en clave de 920 en la primera posición de palabra como señal de enlace, y denotando la compresión de datos EAN.UCC.


Propiedades de los símbolos 1D: ¿Qué es la decodificación objetivo?

La decodificación objetivo simula el comportamiento de un escáner de códigos de barras láser. No obstante, en lugar de centrarse en todo el campo de visión, el lector intenta decodificar únicamente los códigos de barras 1D que estén bajo el punto de enfoque láser. De este modo, se evita que el operador lea de forma accidental otros códigos de barras 1D próximos.


Propiedades de los símbolos 1D: ¿Qué es la opción Zona de silencio corta?

De forma predeterminada, la opción Zona de silencio corta se encuentra activada para permitir cierta indulgencia en la búsqueda respecto a la zona de silencio de los siguientes símbolos 1D: Código 128, Código 39 y Código 93.


Propiedades de los símbolos 1D: ¿Qué valores debería configurar para Decodificaciones mínimas antes de salida?

Establezca un número alto para aumentar la solidez de la decodificación. Establezca un número bajo si su prioridad es la velocidad de rendimiento.


Ventaja de especificar un tamaño de código

Si se especifica un tamaño de código explícito, puede mejorar la capacidad del lector para decodificar símbolos con fiabilidad. Seleccione Cualquiera si va a leer distintos tamaños de código.


Propiedades del código 39

  • ASCII completo activa los códigos extendidos del código 39.

  • Carácter de control solo decodifica símbolos con un carácter de control válido.

  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.

  • Convertir a código 32 si se marca, convierte el conjunto de caracteres de código 39 a código 32.


Propiedades de intercalados 2 de 5

  • Carácter de control solo decodifica símbolos con un carácter de control válido.

  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.


Propiedades del código 25

  • Carácter de control solo decodifica símbolos con un carácter de control válido.

  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.


Propiedades de Pharmacode

Ventaja de especificar un tamaño de código y una orientación

Si se especifican un tamaño de código y una orientación explícitos, puede mejorar la capacidad del lector para decodificar símbolos con fiabilidad.

El número de caracteres de datos y el número de barras en cualquier símbolo

Caracteres de datos: barras

  • 1: 3 Nota: el único código de 1 carácter que leerá el lector será aquél que tenga 3 barras o más. Es decir, solo 6, 7, 8 y 9.

  • 2: 3 a 6

  • 3: 6 a 9

  • 4: 9 a 13

  • 5: 13 a 16

  • 6: 16


Propiedades de Codabar

  • Carácter de control solo decodifica símbolos con un carácter de control válido.
  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.
  • Transmitir caracteres de inicio y de fin incluye los caracteres de inicio y de fin con los datos de decodificación.


Propiedades de MSI

  • Carácter de control solo decodifica símbolos con un carácter de control válido.
  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.
  • Método de cálculo de suma de comprobación le permite seleccionar el método utilizado para calcular la suma de comprobación.


Propiedades de DataBar

  • GS1 DataBar limitado: codifica una identificación de elemento EAN.UCC de 14 dígitos con dígitos indicadores de cero o uno en un símbolo lineal para uso en elementos pequeños que no se escanearán en el punto de venta

  • GS1 DataBar: codifica la identificación de elemento EAN.UCC de 14 dígitos completa en un símbolo lineal que puede ser escaneado en cualquier dirección por escáneres en el punto de venta adecuadamente programados.

  • GS1 DataBar ampliado: distancia variable, versión expandida de los símbolos capaz de codificar el GTIN de 14 dígitos y datos adicionales que incluyen las fechas de caducidad, el país de origen y los números de serie; hasta 74 caracteres numéricos o 41 alfabéticos.


Propiedades de código postal

  • POSTNET: un conjunto de símbolos de código de barras que utiliza el Servicio Postal de los Estados Unidos para gestionar el envío de correo. El código ZIP o código ZIP+4 está codificado en este conjunto de símbolos único que codifica datos en barras de distintas alturas.

  • PLANET: el código PLANET (Postal Alpha Numeric Encoding Technique o técnica de codificación postal alfanumérica) es un código de barras utilizado por el Servicio Postal de los Estados Unidos para identificar y realizar un seguimiento del correo durante la entrega. Al igual que POSTNET, codifica datos en barras de distintas alturas.

NOTA: los códigos postales solo pueden decodificarse si se presentan con barras en vertical («picket fence»).


Versiones de código de respuesta rápida (QR) admitidas

El código QR (Quick Response, Respuesta rápida) es un conjunto de símbolos 2-D con una matriz cuadrada de módulos oscuros y blancos utilizados para codificar datos. El lector puede discernir entre tres tipos distintos:

  • modelo-1: versión original

  • modelo-2: versión mejorada

  • Código Micro QR: un código QR muy pequeño para aplicaciones que precisan menos espacio y utilizan menos cantidad de datos que otras versiones del código QR.


Propiedades del código QR

Tamaño máximo de cuadrícula

Tamaño máximo de cuadrícula permite decodificar códigos QR con un tamaño superior a 49. Puede arrastrar el control o escribir un tamaño de código específico en el cuadro de texto de la derecha.

Mediciones de calidad de los códigos QR

Para obtener información sobre las mediciones de calidad de los códigos, consulte la Guía de comunicaciones y programación del dispositivo DataMan®.


Propiedades de DotCode

Especificar el número de filas y columnas de datos

Especificar el número mínimo y máximo de filas y columnas de datos puede mejorar la capacidad del lector de decodificar símbolos con fiabilidad.

Configuración Polaridad

Puede establecer qué define el dispositivo como un módulo (punto) en relación con el fondo. La configuración Oscuro sobre claro implica que el dispositivo busca y decodifica puntos oscuros sobre un fondo claro, mientras que Claro sobre oscuro es lo contrario (puntos claros sobre un fondo oscuro).

La configuración predeterminada Cualquiera busca ambos tipos de módulos en su fondo respectivo, pero esto puede traducirse en decodificaciones ligeramente más lentas.


¿Cuáles son las distintas configuraciones para las propiedades UPC/EAN?

  • Expandida activa la decodificación de símbolos expandidos.

  • Opciones adicionales controla el modo en que el lector decodifica códigos adicionales.

  • Eliminar ceros a la izquierda elimina los ceros a la izquierda de las cadenas decodificadas.

  • Permitir opciones EAN8 adicionales permite decodificar códigos adicionales de los símbolos EAN8.

  • UPCE1 activado activa la decodificación de símbolos UPC E1.


Propiedades de UPC/EAN: ¿Qué significa la casilla Ampliado?

Se trata de una expresión booleana que indica si hay que expandir la cadena decodificada proporcionada para UPC-EAN a un formato EAN13 de 13 dígitos o si hay que transmitirla en el formato estándar de 6 dígitos de UPC-E.

Si está marcada (de forma predeterminada), la cadena decodificada se transmite en el formato EAN-13 de 13 dígitos (p. ej., 0012345000065). Si no está marcada, el resultado se transmite como <sistema numérico> + 6 dígitos de datos + <carácter de control> (p. ej., 01234565).


Detalles de aplicación


¿Qué puedo configurar en el paso Detalles de aplicación?

En la pestaña Básico, puede establecer la configuración de disparo y de exposición. Para simplificar el proceso, un asistente para disparos, un asistente para intervalos y un asistente para la exposición le ayudarán con la configuración.

En la pestaña Avanzado, puede implementar más configuraciones en una vista de tabla.


¿Cuáles son los tipos de disparo?

  • El disparo Presentación busca un símbolo de forma continua y lo decodifica cada vez que detecta uno. El modo de disparo Presentación depende de un mecanismo de temporización y detección de movimiento interno del lector.

    Puede especificar varios parámetros en el modo Presentación; p.ej., si el lector leerá el mismo código más de una vez o el tiempo que debe transcurrir antes de buscar el siguiente código. Utilice el panel Configuración del sistema y las opciones de Configuración de decodificación para configurar el modo de disparo Presentación.

    En el modo Presentación, utilice la opción Exposición automática para que el lector determine la mejor configuración de exposición para un nivel de intensidad de la luz deseable en la imagen. Sin embargo, tenga en cuenta que el lector utiliza las primeras imágenes que adquiere para determinar esta configuración y podría omitir imágenes que contengan un símbolo para decodificar. Puede cambiar a la opción Exposición manual y especificar una configuración precisa para la exposición del generador de imágenes.

    • Acople el dispositivo a la estación base.
    • Cambie al modo de disparo Manual en la herramienta de configuración y luego vuelva al modo de presentación.
    • Escanee el Código de configuración del lector Entrar presentación.

  • El disparo manual comienza con la adquisición de imágenes en respuesta a cualquiera de los siguientes acontecimientos:

    • Pulsar el botón del lector

    • Enviar el comando de control de DataMan (DMCC) «trigger» (disparo) cuando se conecte el lector a través de una conexión USB o de serie

    • Hacer clic en el botón de disparo en la herramienta de configuración

    • Pulsar Ctrl+T en el teclado cuando la herramienta de configuración tenga el enfoque

    El lector continuará con la adquisición de imágenes mientras que la señal permanezca activa y se detendrá al encontrar un símbolo y decodificarlo o si finaliza la señal de disparo.

=


Asistente para disparos

Para que este asistente funcione, primero debe seleccionar el tipo de disparo. Seleccione la fuente de disparo en la lista desplegable: Sin definir, Ninguno o Externo. Obtendrá una recomendación del asistente para los modos de disparo. Las representaciones gráficas de los tipos de disparo le ayudarán a tomar una decisión. Seleccione el tipo de disparo deseado y haga clic en Guardar y cerrar.


Asistente para intervalos

En el caso de los modos Ráfaga, Auto y Continuo, el asistente para intervalos puede ayudarle a realizar más configuraciones. Puede seleccionar tres maneras de calcular los datos necesarios. En la parte superior derecha, seleccione las unidades (estándar o métrica) en las que desee realizar el cálculo.

Haga clic en Campo de visión para calcular el mayor tiempo de intervalo posible midiendo el campo de visión físico y proporcionando la velocidad máxima de línea y el tamaño del código más largo.

Haga clic en Lente / Distancia hasta el código si desea proporcionar la distancia del código de la lente. Seleccione la distancia focal de la lista desplegable y seleccione la dirección de avance del código. Aquí también debe proporcionar la velocidad máxima de línea y el tamaño del código más largo.

Haga clic en Tamaño de elemento de código para realizar el cálculo con el tamaño de elemento de código más estrecho. Active Modo de prueba para leer el código. También debe proporcionar la dirección de avance del código, la velocidad máxima de línea y el tamaño del código más largo.

En la parte inferior del asistente, se mostrará el tiempo de intervalo máximo recomendado.


Asistente para la exposición

El asistente para la exposición es muy similar al asistente para intervalos. Puede seleccionar las tres mismas formas de cálculo: Tamaño de campo de visión, distancia hasta el código y tamaño de elemento de código.

Haga clic en Campo de visión para calcular el tiempo máximo de exposición recomendado midiendo el campo de visión físico y proporcionando la velocidad máxima de línea. Puede activar Modo de prueba para leer el código más pequeño.

Haga clic en Lente / Distancia hasta el código si desea proporcionar la distancia del código de la lente. Seleccione la distancia focal de la lista desplegable y seleccione la dirección de avance del código. Aquí también debe proporcionar la velocidad máxima de línea.

Haga clic en Tamaño de elemento de código para realizar el cálculo con el tamaño de elemento de código más estrecho. Active Modo de prueba para leer el código. También debe proporcionar la dirección de avance del código y la velocidad máxima de línea.

En la parte inferior del asistente, se mostrará el tiempo máximo de exposición recomendado.


¿Cuál es la diferencia entre las opciones de retraso Tras la primera lectura y Tras la última lectura?

El retraso Tras la primera lectura inicia la temporización después de la primera vez que se lee un código datos dado, y el temporizador no se restablece. Esto significa que se puede volver a leer un código si el lector está disparando en un modo de imagen múltiple, como Continuo, y si el código está delante del lector durante un tiempo igual o superior al Retraso de relectura.

Tras la última lectura restablece el temporizador cada vez que aparece un código dado en una imagen. Esto significa que no se volverá a leer el código siempre y cuando permanezca delante del lector. Únicamente se volverá a leer el código si se quita del campo de visión del lector por un tiempo igual o superior al Retraso de relectura.


Mi código se lee dos veces si vuelvo a disparar el lector. ¿Por qué?

Las opciones Retraso de relectura y Nunca leer el mismo código dos veces solo afectan a las adquisiciones realizadas en un ciclo de disparo único. Disparar el lector borrará los temporizadores y el último código leído para Nunca leer el mismo código dos veces.


¿Qué es Nunca leer el mismo código dos veces?

Cuando está activada, la opción Nunca leer el mismo código dos veces evita que se transmita el mismo código dos veces seguidas y en una secuencia de disparo único. Está disponible para todos los modos de disparo, pero solo es válida con Lectura de código múltiple, ya que la única manera de obtener más de un código en una secuencia de disparo único es en lecturas de código múltiple. Si no se marca la casilla Nunca leer el mismo código dos veces, el dispositivo vuelve a leer y a transmitir el mismo código después del Retraso de relectura de código especificado (en milisegundos).


¿Qué es Modo retraso y Retraso de relectura de código?

La opción Modo retraso configura el retraso de relectura de código relativo a la primera o a la última lectura.

La opción Retraso de relectura de código (en milisegundos) permite especificar el retraso entre los intentos de lectura. Especificar un valor distinto a cero para este tipo de retraso puede ayudar a evitar que los datos saturen el dispositivo conectado al lector.


¿Qué es Detección de movimiento?

Detección de movimiento permite a los usuarios configurar su dispositivo para que cambie al modo de disparo activo Presentación o Auto durante un periodo de tiempo después de que detecte movimiento en el campo de visión del dispositivo.

La opción Detección de movimiento solo está disponible si se establece el tipo de disparo Presentación o Auto. Si se activa Detección de movimiento, el dispositivo no toma de continuo imágenes, sino que detecta en segundo plano si la escena en su campo de visión está o no en movimiento.

Si está en movimiento, el dispositivo adquiere activamente imágenes según el modo de disparo Presentación o Auto. La configuración Tiempo de espera permite especificar el periodo de tiempo (en segundos) después del cual el dispositivo vuelve a Detección de movimiento desde el disparo activo, pero este tiempo de espera se reinicia cada vez que se detecta movimiento o una lectura correcta.

Sensibilidad de detección de movimiento puede ajustarse para definir qué grado de movimiento debe detectar el dispositivo para cambiar a los modos activos de disparo Presentación y Auto.


¿Cómo envío un disparo desde el teclado?

Pulse <Ctrl>-T (la ventana de la herramienta de configuración debe estar activa).


¿Cómo ajusto la exposición de la imagen?

Los tipos de disparo Presentación y Manual utilizan la configuración Exposición automática para determinar automáticamente la mejor configuración para un nivel de intensidad de la luz deseable en cada imagen. Con cualquiera de estos tipos de disparo, puede utilizar la configuración Exposición máxima de acuerdo con las necesidades de su entorno de producción o bien seleccionar Exposición manual y definir un tiempo de exposición preciso en microsegundos.

Con Exposición manual, puede hacer clic en Optimizar intensidad de la luz en el panel de Historial de resultados para generar un valor fijo para la configuración de exposición, limitado por el valor de Exposición máxima. La configuración Factor de ganancia máxima permite establecer la intensidad de luz máxima deseada de los píxeles.


¿Cómo ajusto la exposición de la imagen?

Los tipos de disparo Presentación y Manual utilizan la configuración Exposición automática para determinar automáticamente la mejor configuración para un nivel de intensidad de la luz deseable en cada imagen. Con cualquiera de estos tipos de disparo, puede utilizar la configuración Exposición máxima de acuerdo con las necesidades de su entorno de producción o bien seleccionar Exposición manual y definir un tiempo de exposición preciso en microsegundos.

Con Exposición manual, puede hacer clic en Optimizar intensidad de la luz en el panel de Historial de resultados para generar un valor fijo para la configuración de exposición, limitado por el valor de Exposición máxima. El control Ganancia (debajo del área de visualización de imágenes) indica la intensidad de la luz deseada de los píxeles.


Formatear datos


¿Cómo funciona el formato de datos?

En el panel Básico, puede seleccionar qué tipo de formato desea utilizar.

Utilice el panel Estándar para crear una cadena de salida personalizada utilizando módulos predefinidos en las pestañas individuales de símbolos:

  • La cadena de salida empieza con el texto introducido en el campo Texto inicial.

  • Seleccione elementos de las listas de las pestañas General, Validación y (cuando proceda) Mediciones, y haga clic en Agregar para agregarlos a la cadena de salida. Para agregar un intervalo de caracteres determinado de los datos decodificados, haga clic en Establecer intervalo de subcadenas, introduzca el intervalo de caracteres que desee agregar (como 1-3,5,8,10-), haga clic en Subcadena en la lista y, a continuación, en el botón Agregar.

  • La cadena de salida también incluye el texto introducido en el campo Texto final.

  • Para que toda la cadena termine con un par de retornos de carro/saltos de línea, marque la casilla de verificación CR/LF.


¿Por qué hay diferentes pestañas debajo de la pestaña Estándar?

Puede especificar el formato de forma independiente para diferentes tipos de símbolos, o utilizar la pestaña Universal para especificar el formato de datos para cualquier símbolo decodificado, que tenga prioridad sobre las pestañas de tipos de símbolos específicos.


¿Cómo puedo utilizar los símbolos específicos y el formato universal a la vez?

El panel Formato estándar utiliza los siguientes criterios cuando utiliza las pestañas de símbolos específicos y las pestañas Universales:

  • Cada resultado individual pasará por el formateador de símbolos específicos, si está activado. Se formatearán múltiples resultados de los mismos símbolos de forma independiente con idéntica configuración.

  • Si se activa la pestaña Universal, los resultados individuales pasarán por el formateador de símbolos específicos, si está activado, y posteriormente serán aumentados con las normas de formato de la pestaña Universal. Para múltiples resultados (en los lectores admitidos), los resultados serán concatenados y separados por el delimitador seleccionado, con ningún delimitador adicional al final. La cadena concatenada será tratada como una cadena sencilla para el resto de normas de formato de la pestaña Universal.

  • Para resultados múltiples, el orden de los resultados en una cadena concatenada es 1) Data Matrix, 2) Código QR, 3) Códigos 1D, 4) Vericode, 5) DotCode y 6) OCR.

  • Cualquier marca añadida al formato de símbolos específicos válidos solo para el proceso de decodificación en conjunto (como el tiempo de decodificación o el índice de disparo) ofrecerá este valor global.


¿Qué datos se envían si no está activado el formato estándar?

El lector transmite toda la cadena decodificada seguida de un par de retornos de carro/saltos de línea.


¿Cómo puedo enviar únicamente los datos decodificados sin el par de retornos de carro/saltos de línea?

Active el formato, agregue Cadena completa a la cadena de salida y compruebe que la casilla de verificación CR/LF no esté marcada.

Para enviar únicamente un retorno de carro, introduzca \r en el campo Texto final.


¿Qué es Cadena de entrada?

Cadena de entrada es un token de formato que puede incluir como parte de las propiedades del lector en el formato basado en secuencias de comandos o como un token del formato de datos estándar. Tenga en cuenta que no puede cambiar más propiedades de Cadena de entrada en la herramienta de configuración, sus parámetros solo están disponibles en DMCC.


¿Qué puedo hacer para que Excel no omita celdas?

De forma predeterminada, el lector añade un par de retornos de carro/saltos de línea después de cada código transmitido. Si utiliza una conexión de teclado para introducir los códigos transmitidos en Excel, el par de retornos de carro/saltos de línea hace que Excel avance dos filas después de cada código. Para evitar que esto ocurra, configure el lector para que envíe únicamente un retorno de carro:

  1. Haga clic en Formato estándar.

  2. Especifique el símbolo que esté utilizando en las pestañas de Símbolos.

  3. Marque la casilla Formato activado.

  4. Haga clic en Cadena completa en la pestaña General.

  5. Haga clic en Agregar.

  6. En Texto final, introduzca \r en el campo de texto y desactive la casilla CR/LF.


¿Cómo transmito elementos específicos de los datos codificados cuando está activada la validación de datos?

Primero, seleccione el tipo de validación que necesite en el panel Validación de datos. Active la opción Formato básico en la pestaña Básico del paso de aplicación Formatear datos. Seleccione la pestaña Validación de la pestaña Estándar y agregue el campo o los campos de datos deseados a la cadena de salida, incluido los identificadores de empresa, número de serie, número de referencia, identificador de elemento único y aplicación GS1.


¿Qué son las opciones individuales en la pestaña General, en el campo Datos de la pestaña Estándar?

  • Subcadena: una subcadena de los caracteres codificados en el símbolo. Para usar esta opción deberá especificar un intervalo para la subcadena.

  • Cadena completa: todos los caracteres codificados en el símbolo

  • Tiempo de decodificación: la cantidad de tiempo, en milisegundos, que le llevó al lector decodificar el símbolo. Este período de tiempo no incluye la adquisición de imagen, pendiente del procesamiento de imágenes, el tiempo de comunicación o el procesamiento adicional (por ejemplo, Formato de datos).

  • Tiempo de disparo: la cantidad de tiempo, en milisegundos, entre la recepción de la activación del disparo y la finalización de la operación de codificación

  • Símbolos: la simbología del símbolo decodificado

  • CR/LF: retorno de carro con salto de línea

  • TAB: un carácter de tabulación.

  • SP: un carácter de espacio.

  • Identificador de símbolos: el identificador de símbolos tal y como especifica la normativa ISO/IEC 15424:2008

  • Tamaño de módulo: la anchura (o altura), en píxeles, de cada módulo del símbolo

  • Posición de código: las coordenadas de imagen de cada esquina del símbolo decodificado

  • Orientación de los códigos: la orientación del símbolo decodificado indicada en grados. Las rotaciones en el sentido de las agujas del reloj del símbolo decodificado se consideran cambios positivos en orientación.

  • Contraste: un valor entre 0 y 1, que indica la cantidad total del contraste en el símbolo decodificado. Un valor elevado indica que los módulos de luz y los módulos oscuros del símbolo tienen un intervalo amplio de valores de gris, mientras que un valor bajo indicará que los módulos de luz y los módulos oscuros están formados por valores de gris similares.

  • UEC: la cantidad corrección de error sin utilizar disponible en el símbolo. La corrección de error es un método de reconstrucción o sustitución de datos perdidos cuando el símbolo está dañado. Lo ideal es un valor de «100». Los símbolos 1D siempre dan -1.

  • Cadena de entrada: la cadena de entrada (serie o Ethernet) recibida.

  • Tiempo de filtro: la duración del filtrado en milisegundos (ms).

  • Origen de los resultados: el nombre del dispositivo.

Todos los valores indicados a continuación aumentarán independientemente de si el lector se encuentra conectado a la herramienta de configuración.

  • Total de lecturas: el número total de símbolos decodificados

  • Total de no lecturas: el número de veces que se recibió un disparo, pero no se decodificó ningún símbolo

  • Total de disparos: total de disparos = Total de lecturas + Total de no lecturas + Total de disparos fallidos

  • Disparos fallidos: el número de disparos fallidos debido a que no había disponible ningún búfer de imagen cuando se detectó el disparo

  • Índice de disparos: el número total de disparos detectados por el lector.

Los valores que se restablecerán en 0 cuando se borre Estadísticas de procesos en el panel Monitor de procesos o después de que se reinicie el lector son los siguientes:

  • Total de lecturas

  • Total de no lecturas

  • Total de disparos

  • Disparos fallidos

El índice de disparo se restablecerá en 0 solo después de reiniciar el lector, pero no después de borrar las Estadísticas de procesos.


¿Cómo puedo simular las combinaciones de las teclas Alt, Ctrl o Mayús?

Para usar esta función, se encuentran disponibles cuatro secuencias de salida, \ALT-, \CTRL-, \SHIFT- y \K. \ALT- se utiliza para secuencias de <Tecla ALT>; \CTRL- para las de <Tecla CTRL>, \SHIFT- para las de <Tecla Mayús>, y \K para teclas especiales. Tenga en cuenta que la letra que siga a la barra inversa debe ser escrita en mayúscula o no se reconocerá la combinación de teclas especial.

Las secuencias se introducen en los campos Texto inicial/final del panel Estándar.

Secuencias de teclado especiales admitidas

Debe usarse el siguiente formato:

\ALT- seguido del nombre de tecla seguido de ;

o

\CTRL- seguido del nombre de tecla seguido de ;

o

\SHIFT- seguido del nombre de tecla seguido de ;

o

\K seguido del nombre de tecla seguido de ;

El punto y coma final es necesario para poder distinguir entre las secuencias con el mismo prefijo; de lo contrario, las secuencias de teclas se interpretarían de forma arbitraria, es decir, no habría forma de detectar si \KF11 significa «Pulse F11» o «Pulse F1 seguida de un uno».

Tenga en cuenta que si estas dos secuencias de salida se introducen en la pestaña Universal, se aplicarán también a los resultados No lectura.

Teclas y secuencias de teclas compatibles

La siguiente lista contiene las teclas/combinaciones de teclas compatibles actualmente:

  • ALT-A a ALT-Z

  • CTRL-A a CTRL-Z

  • CTRL-F1 a CTRL-F12

  • Mayús-F1 a Mayús-F12

  • F1 a F12

  • ALT-F1 a ALT-F12

  • Re Pág, Av Pág, Inicio, Fin, Cursor (arriba, abajo, izquierda, derecha), Insert, Supr, Retroceso, Tabulador, Esc, Impr Pant, teclas GUI (izquierda, derecha)

    Las secuencias de salida para estas son las que siguen:

    • Re Pág -> \KPup;

    • Av Pág -> \KPdn;

    • Inicio -> \KHome;

    • Fin -> \KEnd;

    • Cursor arriba -> \KUar;

    • Cursor abajo -> \KDar;

    • Cursor izquierda -> \KLar;

    • Cursor derecha -> \KRar;

    • Insert -> \KIns;

    • Supr -> \KDel;

    • Retroceso -> \KBksp;

    • Tabulador -> \KTab;

    • Esc -> \KEsc;

    • Impr Pant -> \KPrtScr;

    • GUI izquierda -> \KLGui;

    • GUI derecha -> \KRGui;

  • Pause output -> \KPAUSE;

He aquí algunos ejemplos:

  • Para generar una secuencia <ALT-V>, utilice \ALT-V;

  • Para simular la tecla <F10> pulsada, utilice \KF10;

  • Para simular la tecla <Inicio> pulsada, utilice \KHome;

  • Para activar/desactivar la barra de estado en el bloc de notas (<Alt-v><s>), la secuencia debe ser \Alt-v;s

Si se utiliza una secuencia equivocada o incompleta, se ignorarán los dos caracteres que marcan la secuencia de salida. En este caso, las dos primeras letras de la secuencia de salida se pasan por alto y se enviarán los caracteres restantes. Por ejemplo, la secuencia «\ALT-M11;» no es válida y mostrará «LT-M11;»


¿Cómo puedo probar el formato de datos?

Utilice el botón Prueba en la parte inferior de la página para comprobar el aspecto del resultado.

Escanee un símbolo y visualice el resultado formateado en la barra de estado. También puede seleccionar el panel Historial de resultados y, después, leer un símbolo. El Historial de resultados muestra los resultados del formato que usted ha especificado.


¿Qué es la función Opciones de salida?

La función Opciones de salida le permite transmitir los elementos de datos de salida deseados en distintos formatos. Por ejemplo, si se selecciona una coma y usted selecciona transmitir toda la cadena seguida por el tipo de símbolo, el resultado será la cadena de datos completa seguida de una coma y el texto «Data Matrix». Para probar las distintas opciones, puede seleccionar un tipo de salida determinado y hacer clic en el botón Prueba para ver el resultado en una ventana de visualización adyacente. Tenga en cuenta que si la opción Validación de datos está seleccionada y un código no supera la validación de datos, la función de opciones de salida no estará activada.


¿Por qué está marcado en gris el botón Prueba?

Solo puede probar su código tras la primera decodificación correcta.


¿Puedo especificar caracteres utilizando códigos ASCII hexadecimales u octales?

En los campos Texto inicial y Texto final, puede especificar los caracteres como \nnn, donde nnn es el código ASCII octal. Puede especificar caracteres en formato hexadecimal introduciendo \xnn, donde nn es el código ASCII hexadecimal.

También puede utilizar los siguientes códigos predefinidos:

  • \a Alerta (ASCII 7)
  • \b Retroceso (ASCII 8)
  • \E Escape (ASCII 27)
  • \f Salto de página (ASCII 12)
  • \n Salto de línea (ASCII 10)
  • \t Tabulación horizontal (ASCII 9)
  • \r Retorno de carro (ASCII 13)
  • \v Tabulación vertical (ASCII 11)
  • \\ Barra invertida (ASCII 92)


¿Qué transmite el lector cuando no se lee ningún código?

Normalmente, el lector no transmite ningún dato si no puede leer ningún código. El historial de resultados mostrará una cadena de resultados vacía y un icono de cruz roja con el mensaje «No leído» a modo de estado del resultado.


¿Qué es el resultado Posición de código?

Para los símbolos Data Matrix, la posición de código representa la ubicación indicada de las cuatro esquinas del símbolo. El lector devuelve 4 pares de coordenadas:

  • El primer par representa la intersección del patrón de búsqueda.

  • El segundo par representa la intersección del patrón de búsqueda horizontal y el patrón alternativo vertical.

  • El tercer par representa la intersección de los patrones alternativos (diagonal opuesta al primer par).

  • El cuarto par representa la intersección del patrón de búsqueda vertical y el patrón alternativo horizontal.

Cognex recomienda seleccionar un delimitador, como una coma, para separar cada valor y facilitar la lectura de los datos.


¿Qué método de formato de datos debería elegir?

Puede usar el Formato básico (Estándar o Estilo Perl) o puede escribir su propia secuencia de comandos en JavaScript en la pestaña Formato de datos del panel Secuencias de comandos. Los dos métodos difieren en lo siguiente:

  • El Formato básico le permite arrastrar y colocar elementos de formato de datos predefinidos.

  • El Formato basado en secuencias de comandos le permite crear una secuencia que, además de dar formato a los resultados de lectura y a los datos, es capaz de hacer que su lector realice operaciones tales como emitir un pitido o elevar la salida 1.


¿Cuál es el propósito de la pestaña Comunicación?

En esta pestaña, puede editar su secuencia de comandos de protocolo de comunicación personalizada.


¿Cuáles son las limitaciones en el formato basado en secuencias de comandos?

Está limitado a dos eventos personalizados y a sobrescribir el evento de sistema en el formato basado en secuencias de comandos.


¿Dónde puedo encontrar un ejemplo de secuencia de comandos?

Tiene las siguientes opciones para introducir una secuencia de comandos en la ventana principal del panel Secuencias de comandos:

  • Haga clic en el botón Insertar fragmento en la barra de herramientas superior y elija el fragmento apropiado de la lista, según sus necesidades.

  • Haga clic derecho en cualquier lugar de la pantalla principal y seleccione Insertar fragmento.... Haga clic en el fragmento apropiado de la lista, según sus necesidades.

  • Pulse Ctrl-K, X

NOTA: si el botón Insertar fragmento no está activo, significa que la versión de firmware que se ejecuta en el dispositivo no admite fragmentos de código en la pestaña de secuencia de comandos actual.


¿Cuál es el propósito de la pestaña Almacenamiento FTP?

Esta pestaña se utiliza para la generación de nombres de archivo en FTP para los informes de calidad de los códigos e imágenes.


¿Cómo puedo cargar mis secuencias de comandos?

Puede acceder a ellas si hace clic en el menú de la cinta y luego en la opción Abrir secuencia de comandos. Puede guardar sus secuencias de comandos con el botón Guardar secuencia de comandos.

NOTA: las secuencias de comandos solo admiten la codificación de caracteres UTF-8.


¿Qué es la opción Completar palabra?

Puede completar palabras en su secuencia de comandos mediante los siguientes métodos:

  • haciendo clic en el botón Completar palabra en la barra de herramientas superior;

  • haciendo derecho en cualquier lugar de la pantalla principal y seleccionando Completar palabra;

  • pulsando Ctrl-K, W.

Entonces podrá elegir de una lista de objetos para introducir en su secuencia de comandos.


¿Cómo puedo editar rápidamente mi secuencia de comandos?

Use los botones Cortar, Copiar o Pegar en la barra de herramientas superior, o haga clic derecho en cualquier lugar de la ventana principal y elija Cortar, Copiar, Pegar, Eliminar o Seleccionar todas.


¿Por qué se restablecen todas las variables al seleccionar Sistema->Guardar configuración?

Cuando se modifica una secuencia de comandos y se deja el enfoque del editor, la secuencia de comando se transmite al lector y se invalida el contexto del motor de secuencia de comandos. La invalidación del contexto de secuencia de comandos hace que se restablezcan todas las variables.


¿Cómo puedo ver errores en el registro del dispositivo utilizando secuencias de comandos?

Utilice el comando Throw() para informar de que se ha producido una situación anómala (excepción) y el error aparecerá en el registro del dispositivo cuando el dispositivo no esté conectado a la herramienta de configuración. Puede acceder al registro de errores haciendo clic en Sistema y luego en Mostrar registro del dispositivo en la barra de menús de la herramienta de configuración.

Si el dispositivo está conectado a la herramienta de configuración, la excepción aparecerá debajo de la secuencia de comandos en el panel de secuencias de comandos.


¿Dónde puedo encontrar más información acerca del Formato basado en secuencias de comandos?

Para obtener más información, consulte la Guía de comunicaciones y programación del dispositivo DataMan, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.


¿Cómo establezco un retraso en la transmisión de código?

Para establecer una pausa en la transmisión de código, se puede agregar la secuencia \Pause<tiempo>; a los campos de texto en el panel Formato de datos.

<tiempo> ha de contener un valor en milisegundos. Por ejemplo, para esperar 4 segundos, la secuencia será \Pause4000;.

Esta función puede utilizarse con USB HID o RS232. Con RS232, la función debe activarse mediante el comando COM.RS232-ENABLE-PAUSE de DMCC. Con USB HID, está activada de forma predeterminada.


¿Por qué hay diferentes pestañas en la parte superior?

Puede especificar el formato de forma independiente para diferentes tipos de símbolos, o utilizar la pestaña Universal para especificar el formato de expresiones regulares estilo Perl para cualquier símbolo decodificado.


¿Cómo puedo especificar una sustitución de texto arbitraria?

Introduzca texto en el cuadro de texto Expresión regular: la sintaxis de la cadena es la siguiente:

        /search/replace/g

donde búsqueda es la cadena que se desea buscar, y reemplazo la cadena que reemplazará la cadena de búsqueda. De forma predeterminada, solo se reemplaza la primera instancia de la cadena de búsqueda. Para reemplazar todas las instancias, agregue g al final del comando.

Por ejemplo, si el lector decodifica la siguiente cadena:

        UPC 05214275600

Puede reemplazar la cadena «UPC» por la cadena «CÓDIGO SKU:» utilizando esta cadena de sustitución:

        /UPC/SKU CODE:/

que generaría la siguiente cadena de salida:

        SKU CODE: 05214275600

Puede introducir varios pares de sustitución separados por un espacio. Los pares múltiples se utilizan secuencialmente: el resultado del primer par se utiliza como entrada para el segundo par y así sucesivamente.


¿Qué significa «Descartar datos no correspondientes»?

De forma predeterminada, todo texto que no forma parte de la cadena de correspondencia pasa sin sufrir ningún cambio. Si marca Descartar datos no correspondientes, entonces solo se envía la cadena resultante de la sustitución.


¿Cuáles son los caracteres especiales de escape?

Los siguientes caracteres tienen un significado especial en las cadenas de búsqueda y reemplazo:

            ˆ  . , (  )  [  ] $ \ / * + |

Si desea incluir alguno de estos caracteres en la cadena de búsqueda o reemplazo, deberá ir precedido del carácter de barra invertida \. Para incluir un carácter de barra invertida, introduzca \\. Para introducir un carácter ASCII arbitrario, introduzca \xhh, donde hh es el valor del carácter hexadecimal (no puede usar \ooo para especificar valores ASCII octales).


¿Cómo utilizo un comodín para representar distintos caracteres o patrones?

Puede representar un solo carácter, cualquier carácter de un conjunto de caracteres, cualquier carácter de un intervalo de caracteres o cualquier carácter que no esté dentro de un intervalo de caracteres utilizando los siguientes caracteres especiales en la cadena de búsqueda:

. Para representar cualquier carácter

[abcd...] para representar cualquier carácter del conjunto de caracteres a, b, c, d ...

[a-z] para representar cualquier carácter dentro del intervalo de caracteres a - z (se pueden utilizar letras o números)

Para invertir el significado de un comodín utilizando un conjunto de caracteres, debe preceder el carácter con el carácter ^.

Para representar un número variable de caracteres, añada uno de los siguientes caracteres modificadores al carácter o al comodín en cuestión:

+ representa uno o más del carácter precedente

* representa cero o más del carácter precedente

? representa cero o uno del carácter precedente

{n} representa n instancias del carácter precedente

{n,m} representa al menos n instancias, pero menos que m del carácter precedente

{n,} representa al menos n instancias del carácter precedente

Algunos ejemplos de correspondencia de comodines:

/A.B/AB/g elimina cualquier carácter entre «A» y «B» en la cadena de entrada

/A.*B/AB/g elimina cualquier número de caracteres entre «A» y «B» en la cadena de entrada


¿Existen comodines para representar caracteres especiales?

Utilice las siguientes secuencias de escape para representar caracteres especiales y tipos de caracteres:

\n un carácter de nueva línea

\w un carácter alfanumérico (letra o dígito)

\W un carácter no alfanumérico

\s un carácter de espacio

\S un carácter distinto a un espacio

\d un dígito

\D un carácter distinto a un dígito

Puede utilizar estos caracteres junto con los comodines de correspondencia de múltiples caracteres enumerados previamente.


¿Cómo fijo la cadena de búsqueda?

Preceda la cadena de búsqueda con ^ para limitar la correspondencia al principio de la cadena. Preceda la cadena de búsqueda con $ para limitar la correspondencia al final de la cadena.


¿Cómo puedo reutilizar parte de la cadena de búsqueda en la cadena de resultados?

Coloque la parte o las partes de la cadena de búsqueda que desee utilizar en la cadena de resultados entre paréntesis. Puede hacer referencia a las cadenas adjuntas a la cadena de resultados utilizando las marcas \1, \2 y así sucesivamente.


¿Existe un tamaño máximo para las expresiones regulares estilo Perl?

El tamaño máximo de la secuencia de comandos introducida en cualquiera de las pestañas es de 512 caracteres, pero la pestaña específica de los símbolos se ejecutará antes que la pestaña universal. Si ambas se utilizan simultáneamente, se puede escribir una secuencia de comandos de hasta 1024 caracteres.


¿Dónde puedo obtener más información acerca de las expresiones regulares estilo Perl?

Aquí. Tenga en cuenta que el lector no implementa todas las funciones descritas en esta página.


Entradas / Salidas


¿Qué configuraciones del sistema puedo modificar?

Aquí, puede desactivar o activar la alerta sonora, así como proporcionar un nombre de dispositivo personalizado. También puede gestionar las entradas de botones, las salidas de luz y las salidas de sonido.


¿Cómo puedo reiniciar el lector?

Escanee el comando Reiniciar el escáner impreso al final de la guía de referencia rápida para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y reinicia.

Escanee el comando Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.


¿Por qué cambiar el nombre del dispositivo?

Puede dar al dispositivo un nombre con más sentido en relación a su entorno de producción, como, por ejemplo, la localización o la tarea de inspección. Utilice el campo Nombre del dispositivo en la pestaña Avanzado.


¿Cómo cambio el nombre del dispositivo?

Para cambiar el nombre del dispositivo:

  1. Introduzca un nuevo nombre para el dispositivo en Nombre del dispositivo.

  2. Aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí».

  3. Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su dispositivo.

La próxima vez que inicie la herramienta de configuración o haga clic en Actualizar en el panel Conectar al lector, reflejará el nuevo nombre del dispositivo.


¿Qué configuración del sistema puedo modificar?

La lista desplegable Configuración del sistema en la pestaña Avanzado permite controlar qué hace el lector cuando lee un código, cuando no puede leerlo y cuando lee un código que no pasa la validación.

  • Nivel de sonido controla el tono de la señal acústica.

  • Número de tonos controla cuántas veces suena la señal.

  • Color de LED establece el color del indicador de estado del lector (situado en la parte trasera del lector).


¿Qué es un mensaje de activación?

Si la función Cadena de diagnóstico de salida al activar está activada, el lector o la estación base transmitirá una cadena de diagnóstico cuando el dispositivo se inicie.

Esta función no está disponible para conexiones USB. Para conexiones de serie, la velocidad en baudios se establece automáticamente a 38 400 cuando se envía el mensaje, independientemente de la configuración efectuada en la herramienta de configuración.


Comunicaciones


¿Qué puedo configurar en el paso de aplicación Comunicaciones?

En las tres pestañas del paso de aplicación Comunicaciones, se puede implementar la configuración de Ethernet y serie. Haga clic en la pestaña adecuada para introducir los valores de configuración.

En la pestaña Avanzado, puede introducir más configuraciones en una vista de tabla.


¿Cómo puedo cambiar la configuración del puerto serie del lector?

Introduzca la nueva configuración en la pestaña Serie del paso de aplicación Comunicaciones. También puede escanear el documento Códigos de configuración (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración).


¿Cuándo debería usar el modo de compatibilidad del controlador USB?

De forma determinada, el lector DataMan usa un controlador USB que puede ayudar al lector a recuperarse de una descarga electrostática (ESD). Utilice el Modo de compatibilidad del controlador USB si necesita una estricta conformidad a las especificaciones USB o si está usando un lector DataMan junto con el producto SensorView de Cognex.

Cuando cambie a modo de compatibilidad del controlador USB, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


¿Qué resulta afectado al cambiar el modo USB?

Cuando se conecte a su lector a través de una conexión USB de serie, podrá cambiar la velocidad USB de dicha conexión a 1.1 o 2.0.

Cuando se conecte a un lector inalámbrico, cambiar el modo USB no afectará a la estación base. La configuración modificada permanecerá en la memoria del lector, y si cambia el deslizante inalámbrico a un deslizante de serie, el lector se conectará con el (anteriormente) seleccionado modo USB.


¿Cómo utilizo el lector en lugar de un teclado cuando esté conectado mediante USB?

Para emular un teclado USB, simplemente escanee el código Teclado USB del documento Códigos de configuración del lector (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración) y asegúrese de desconectarse de la herramienta de configuración.


¿Qué puedo configurar con el menú desplegable Canal de comunicación utilizado?

Aquí puede configurar el método de comunicación mediante USB. En función del dispositivo utilizado, están disponibles las opciones siguientes:

  • Solo USB-COM: seleccione esta opción para tener acceso al dispositivo a través de un puerto serie.

  • Solo USB-HID: esta opción garantiza que el dispositivo se comporte como un teclado USB.

  • USB-COM + USB-HID: esta es una combinación de los modos anteriores.

NOTA: en el caso de Solo USB-COM, es posible que algunos dispositivos también aparezcan en la lista «Dispositivos HID» aunque no tengan funcionalidad HID.


¿Cómo utilizo el lector en lugar de un teclado a través del adaptador PS/2?

Para emular un teclado PS/2, utilice el cable serie, la fuente de alimentación externa y el cable de decodificador de teclado, del modo descrito en la guía de referencia rápida. Escanee el código Emulación de teclado PS/2 activada del documento Códigos de configuración del lector (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración). Para instalar el adaptador PS/2, deberá apagar completamente su PC. Conecte el lector usando los cables que se enumeran más arriba. Después, encienda su ordenador y el lector emulará un teclado PS/2.


¿Qué sucede si no reinicio el lector cuando se me solicita?

Los cambios en la configuración no tendrán efecto. Si cambia de opinión, haga clic en Sistema y elija Guardar configuración. Entonces reinicie el lector.


¿Qué es el relleno de ceros?

El relleno de ceros sitúa ceros por delante en sus datos transmitidos, lo que es necesario en algunas aplicaciones que aceptan los datos enviados por el lector.


¿Cómo establezco la configuración de red del lector?

Si utiliza un lector inalámbrico DataMan 8000, establezca la configuración de red en la estación base. Si está usando un lector con cable, utilice la pestaña Red para establecer la configuración de red.

Seleccione la opción Usar servidor DHCP para hacer que el servidor DHCP asigne una dirección IP al lector (si hay alguna disponible), o introduzca la configuración de red de forma manual. Póngase en contacto con su administrador de red para obtener un valor apropiado.

Cuando cambie la configuración, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


Copiar configuración de red del PC

Si hace clic en el botón Copiar configuración de red del PC, en el menú desplegable, puede seleccionar Dell GigabitEthernet, Bluetooth Device, Microsoft Wi-Fi Direct Virtual Adapter, Dell Wireless 1560 802. 11ac. La configuración de red de su PC se copiará en los campos mencionados.


¿Está sincronizada mi configuración de comunicación entre el lector y la estación base?

Debe colocar el lector en la estación base, de forma que puedan intercambiar y actualizar la configuración para estar sincronizados. Si el lector ya está en la estación base al cambiar la configuración de comunicación, levántelo y vuelva a colocarlo de nuevo en la estación base.


Si el lector se comunica mediante 802.11b, ¿hará que todos los demás dispositivos WiFi se comuniquen a velocidades de 802.11b?

Como el lector y la estación base tienen una conexión punto a punto y no se conectan a una red WiFi de una tercera parte, la velocidad de comunicación entre la estación base y el lector no afectará a otros dispositivos WiFi.


¿Por qué están desactivadas todas las opciones en la pestaña WiFi?

Si el lector ya está asociado a una estación base, los campos de las opciones se oscurecerán. Conéctese a la estación base si quiere cambiar alguna configuración.


¿Por qué están desactivadas todas las opciones en la pestaña Bluetooth?

Si el lector ya está asociado a una estación base, los campos de las opciones se oscurecerán. Conéctese a la estación base si quiere cambiar alguna configuración.


¿Cómo puedo desasignar el lector de la estación base?

Haga clic en el botón Desasignar en la casilla de grupo Estación base asociada. Tenga en cuenta que después de hacer clic en Desasignar, se perderá la conexión de la herramienta de configuración. Asegúrese de que guarda con antelación todos sus cambios.

También puede desconectarse al escanear el código de configuración Desasignar lector.


¿Qué es «Volver a enumerar al iniciar el firmware»?

En algunos casos se enumera el puerto COM, pero iniciar el firmware lleva más tiempo y el puerto COM agota el tiempo de espera, lo que se interpreta como una pérdida de conexión. Para evitar estos casos, esta casilla garantiza que se vuelva a enumerar el puerto COM una vez más después de que se reinicie el firmware.


Protocolos industriales

Protocolo de EtherNet/IP

Para permitir que el lector utilice el protocolo de EtherNet/IP, marque la opción EtherNet/IP en el cuadro Protocolos industriales de la pestaña Ethernet.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie su lector.

Protocolo PROFINET

Para permitir al lector utilizar el protocolo PROFINET, marque la opción PROFINET. Haga clic en la casilla Usar nombre de la estación para introducir el nombre de la estación.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie su lector.

Protocolo SLMP

Para permitir al lector utilizar el protocolo SLMP, marque la opción Protocolo SLMP y configure los parámetros según sea necesario.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie el lector para que tenga efecto la configuración, apagando y encendiéndolo o escaneando el símbolo Restablecer.

Modbus TCP

Para permitir al lector utilizar el protocolo Modbus TCP, marque la opción Modbus TCP y configure los parámetros según sea necesario.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie el lector para que tenga efecto la configuración, apagando y encendiéndolo o escaneando el símbolo Restablecer.

Selección EtherNet/IP, PROFINET, Protocolo SLMP o Modbus TCP marcada en gris

Solo se puede usar un protocolo industrial de Ethernet en cada momento. Cuando se seleccione un protocolo, el otro no estará disponible.


¿Cómo utilizo la opción Autenticación?

Cuando la opción Autenticar se encuentre activada, la herramienta de configuración pedirá al usuario una contraseña para la cuenta de administrador cuando se realice un intento de conectarse a un lector o estación base disponible a través de la red.


¿Cómo establezco una conexión TCP/IP?

El lector permite conexiones TCP al puerto 23, que es el puerto TCP por defecto para las aplicaciones de Telnet. Si utiliza un cliente de Telnet, el único parámetro que tendrá que proporcionar es la dirección IP del lector. Si utiliza otra aplicación o SDK para conectarse, asegúrese de que utilice la misma configuración de puerto TCP que su lector. El puerto TCP puede cambiarse en el panel de Telnet. El lector transmitirá automáticamente el código a través de esta conexión. También puede transmitir los comandos de control de DataMan (DMCC) a través de esta conexión.

Cuando cambie el puerto de Telnet, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


¿Puedo enviar imágenes a un servidor FTP?

Use la pestaña Imagen FTP para establecer la configuración necesaria para transferir imágenes a un servidor FTP. La pestaña contiene la configuración para la dirección IP y el número de puerto del servidor, así como una combinación de nombre de usuario y contraseña. Tenga en cuenta que las imágenes enviadas mediante FTP no tienen su envío garantizado, que podría no tener lugar cuando el lector esté operando a una frecuencia superior y no pueda programar el momento de transferencia de las imágenes. Tenga en cuenta también que la transferencia mediante conexiones inalámbricas puede ser más lenta que la comunicación de red normal. En dichos casos, se recomienda utilizar imágenes comprimidas o con una resolución más baja.

Las opciones de Nombre de archivo le permiten especificar el archivo donde se almacenarán las imágenes. El campo Nombre de archivo le permite especificar una ruta en relación al directorio raíz del servidor FTP (por ejemplo, /imágenes_erróneas/imagen). La extensión de nombre de archivo (.jpg o .bmp) que aparece en la etiqueta que sigue al nombre de archivo se corresponde con la configuración de formato de imagen en el panel Configuración de la imagen almacenada. Tenga en cuenta que el lector no crea directorios; el directorio debe estar disponible y accesible.

El control Máx. valor de adición indica el límite del valor de incremento usado en el nombre del archivo. Un valor de 0 indica que no se sumará ningún incremento y que el archivo puede sobrescribirse.

La opción Nombre de archivo generado por el servidor comienza con una ruta en blanco, que indica el directorio raíz del servidor FTP.

La lista Qué imágenes transferir le permitirá elegir qué tipo de imágenes se envían al servidor FTP. Tenga en cuenta que el servidor FTP debe ser compatible con la transferencia de imágenes.


¿Qué es un Cliente de red?

El comportamiento Cliente de red es la forma mediante la cual el lector ID DataMan abrirá activamente una conexión de Ethernet con otro dispositivo en la red. Una vez abierta, la conexión tendrá el mismo comportamiento operativo básico que la conexión Telnet DataMan; puede producir resultados de lectura (transmitir los resultados al dispositivo externo) y puede actuar como servidor DMCC (procesar comandos recibidos desde el dispositivo externo).


¿Qué es un host?

El dispositivo host es el dispositivo de la red al que se conectará el DataMan. Especifique la dirección Ethernet y el número de puerto del dispositivo host. La dirección puede ser un nombre de dominio completamente cualificado (por ejemplo, «servidor.mired.com») o una dirección IP con formato con notación decimal con punto (por ejemplo, «192.169.0.1»).


¿Qué es un puerto de cliente?

El puerto de cliente es el puerto de Ethernet en el lector desde el que se originará la conexión cliente. El valor predeterminado de 0 indica al cliente de red que use cualquier puerto disponible. En casos especiales, puede que tenga que definir un puerto de cliente específico. Solo tiene que configurar el puerto de cliente con el valor requerido. Tenga en cuenta que el caso más típico consiste en usar el valor predeterminado 0. En caso de duda, use el valor predeterminado.


¿Cómo establezco una conexión?

El cliente se conectará según el valor elegido para la opción Abrir conexión. Las opciones disponibles son conectarse cuando se encienda el dispositivo DataMan o hacerlo tan pronto como haya actividad de datos (es decir, conectarse cuando se lea un código).


¿Cómo cierro la conexión?

Hay dos opciones disponibles para Cerrar conexión. La conexión puede quedar abierta para siempre o puede cerrarse una vez se haya completado la transferencia de datos. Si elige la opción Tras la transferencia de datos del lector, también podrá establecer un número de segundos tras el cual la conexión se cerrará si el lector permanece inactivo durante dicho período de tiempo. La duración del período de inactividad se puede ajustar de 1 a 3 600 segundos.


¿Cuál es el tiempo de espera de la conexión?

El tiempo de espera de la conexión es la cantidad de tiempo (en milisegundos) que el DataMan esperará a que se abra la conexión. Tenga en cuenta que si se elige la opción en encendido, el lector reintentará abrir la conexión continuamente.


¿Qué es el tiempo de reconexión?

Es la cantidad de tiempo (en milisegundos) que el lector permanecerá en pausa antes de volver a intentar abrir la conexión.


¿Qué se transmite si un código contiene caracteres no imprimibles?

Normalmente, se transmiten los valores de los caracteres no imprimibles sin ser procesados.


Reparación y asistencia


¿Qué es Reparación y asistencia?

La página Reparación y asistencia puede utilizarse para establecer la configuración de red de un dispositivo de red con una configuración errónea o cambiar el modo HID de un dispositivo serie a CDC.


¿Para qué se utiliza la opción Actualizar?

Haga clic en el botón Actualizar para actualizar la lista de dispositivos disponibles.


¿Cómo puedo agregar un dispositivo de red a la lista de dispositivos mostrados?

Puede agregar un dispositivo de red o editar la dirección IP de un dispositivo ya agregado haciendo clic en Agregar dispositivo de red. Se abre el cuadro de diálogo Agregar dispositivo de red, donde puede proporcionar la dirección IP del dispositivo. Haga clic en Aceptar para guardar los cambios y el dispositivo también aparecerá en la página Conectar.


¿Cómo puedo editar las propiedades de un dispositivo?

Seleccione un dispositivo de la lista de dispositivos para ver las opciones disponibles. En el panel que se abre, puede editar la configuración de red del dispositivo seleccionado así como establecer una opción de autenticación. Haga clic en Aplicar para guardar los cambios.


DataMan series 60, 300, 503, 8000 y estación base DataMan 8000: ¿cómo puedo utilizar la opción Agregar dispositivo?

La opción Agregar dispositivo le permite añadir el DataMan de forma manual a la lista de dispositivos de red de modo que pueda conectar el lector o la estación base DataMan a la herramienta de configuración a través de la red Ethernet, en lugar de usar un puerto de comunicaciones en el PC.

Debe tener la dirección IP del lector o de la estación base para utilizar la opción Agregar dispositivo. Siga el siguiente procedimiento para averiguar la dirección IP asignada actualmente al lector o a la estación base:

  1. Conecte el lector o la estación base a la herramienta de configuración mediante una conexión RS-232 en el PC (puerto COM de la herramienta de configuración).

  2. Seleccione la pestaña Red bajo la Configuración de comunicación.

  3. Copie la dirección IP que aparece.

  4. Vuelva al panel Conectar al lector y haga clic en Desconectar.

  5. Haga clic en Agregar dispositivo.

  6. Pegue aquí la dirección IP para el DataMan.

Una vez completados los campos Nombre y Dirección IP haga clic en Aceptar. El lector o la estación base deberían aparecer en la lista de dispositivos DataMan accesibles en la lista dispositivos de red de forma que ahora podrá conectar la herramienta de configuración al lector o a la estación base a través de la red Ethernet.

Tenga en cuenta que la función Agregar dispositivo almacena el nombre del lector o de la estación base en el equipo local y no será visible para otros equipos que estén ejecutando la herramienta de configuración.


¿Para qué se utiliza el icono Exportar?

Si se hace clic en el icono Exportar archivo de asistencia de Cognex, se inicia la generación del archivo de asistencia de Cognex, que genera un archivo .zip con una serie de registros de datos predefinidos. Esta función solo está disponible si se selecciona al menos un dispositivo.

Al hacer clic en el botón, se abre un cuadro de diálogo donde puede especificar en una lista de casillas los tipos de datos que se incluirán en el archivo .zip de asistencia:

  1. Cfg

  2. Cdc

  3. Última imagen

  4. Dispositivos descubiertos

  5. Estadísticas del dispositivo

  6. Estadísticas de memoria

  7. Comentario del usuario (puede ser editado manualmente por el usuario)

La carpeta de destino del archivo de asistencia puede modificarse mediante el icono «...». Una vez generado el archivo, puede seleccionar abrir su carpeta contenedora o bien enviarlo como adjunto con el cliente de correo electrónico predeterminado (.eml).

El resultado del proceso es un archivo .zip. El nombre de archivo contiene el nombre del dispositivo y la fecha de creación. Un descriptor .xml adicional en el zip contiene los datos siguientes:

  1. Fecha

  2. ID de descubrimiento

  3. Nombre del dispositivo

  4. Tipo de dispositivo

  5. Número de serie

  6. Dirección MAC

  7. Claves de funciones

  8. Interfaz de comunicación

  9. Versión de firmware

  10. Lista de archivos presentes en el zip


¿Qué hace el botón Agregar dispositivo virtual?

Esta función permite crear un dispositivo virtual basado en un archivo de configuración personalizada o un dispositivo con configuración predeterminada. Puede utilizarse para examinar distintos paneles en la herramienta de configuración sin la necesidad de conectar un dispositivo. Al pulsar el botón, se inicia un asistente que le guiará a través de los pasos necesarios para crear un dispositivo virtual. Las opciones iniciales son utilizar un archivo de configuración/de copia de seguridad para la creación o utilizar la configuración predeterminada de fábrica.

Una vez finalizado el asistente, se agrega un nuevo dispositivo virtual a la lista de dispositivos descubiertos, indicado por un icono de dispositivo virtual. El dispositivo virtual creado no es visible para los demás dispositivos de la red. El dispositivo virtual persiste durante varias instancias de la herramienta de configuración.

El dispositivo virtual creado puede conectarse del mismo modo que un dispositivo normal, pero todos los cambios de configuración son rechazados (todo es de solo lectura) y las características, funciones y acciones no funcionan en los dispositivos virtuales.


Copia de seguridad


¿Cómo puedo utilizar la función Copia de seguridad?

Usando esta función puede generar un archivo de copia de seguridad con la configuración y los registros de uno o más lectores haciendo clic en el botón Copia de seguridad en la parte inferior derecha (o pulsando Alt+B). Esta función solo está disponible si se selecciona al menos un dispositivo.

Si se hace clic en el botón Abrir carpeta de copia de seguridad, se abrirá la carpeta donde están guardados los archivos de copia de seguridad. Puede establecer la carpeta en Inicio->Opciones->Copia de seguridad->Ubicación de copia de seguridad.

Si se han seleccionado varios dispositivos, cada dispositivo generará un archivo de copia de seguridad. Cada archivo de copia de seguridad se guarda en una subcarpeta que coincide con el nombre del dispositivo. El nombre del archivo de copia de seguridad contiene el nombre del dispositivo y la fecha de generación.

El archivo de copia de seguridad es un archivo .zip con extensión .dmb. El archivo contiene: config.cdc, config.cfg y descriptor.xml. El xml contiene los datos siguientes:

  1. Fecha

  2. ID de descubrimiento

  3. Nombre del dispositivo

  4. Tipo de dispositivo

  5. Número de serie

  6. Dirección MAC

  7. Claves de funciones

  8. Interfaz de comunicación

  9. Versión de firmware

  10. Lista de archivos presentes en el zip


¿Cómo puedo establecer la carpeta de copia de seguridad para la función Copia de seguridad?

Puede establecer la carpeta en Inicio->Opciones->Copia de seguridad->Ubicación de copia de seguridad.


Restaurar


¿Cómo puedo utilizar la función Restaurar?

La función Restaurar permite restaurar los archivos de configuración de copia de seguridad a uno o más dispositivos. Esta función solo está disponible si se selecciona al menos un dispositivo y si se especifica un origen de configuración válido.

En Origen de configuración en la parte superior, puede especificar la herramienta de configuración de origen que se utilizará para la restauración:

  1. Archivo de configuración: al seleccionar esta opción, la herramienta de configuración utiliza el archivo de configuración especificado para la restauración. Haga clic en botón «...» para especificar la carpeta que contenga el archivo de copia de seguridad que desee utilizar. Consulte las preguntas y respuestas que encontrará en Copia de seguridad para obtener más información sobre cómo establecer la carpeta.

    Nota: el botón Restaurar solo se activa si se selecciona como destino un dispositivo compatible.

  2. Dispositivo: al seleccionar esta opción, la herramienta de configuración utiliza un único dispositivo especificado para restaurar su configuración a todos los dispositivos de destino.

  3. Copia de seguridad más reciente: al seleccionar esta opción, la herramienta de configuración busca la copia de seguridad más reciente para el dispositivo seleccionado. Si se han seleccionado varios dispositivos, se aplicará a cada uno de los dispositivos su copia de seguridad más reciente.

  4. Valores predeterminados de fábrica: al seleccionar esta opción, la herramienta de configuración restaura su configuración a los valores predeterminados de fábrica.

Una vez seleccionado el origen, así como el dispositivo (o dispositivos) de destino, haga clic en el botón Restaurar en la parte inferior derecha.


¿Cómo funciona el botón desplegable Restaurar con configuración de red?

Restaurar con configuración de red funciona del mismo modo que el botón Restaurar, pero restaura la configuración del archivo .cdc contenido en la carpeta de copia de seguridad en lugar del archivo .cfg. Esta opción solo está activa si hay un .cdc disponible en el origen especificado y como destino se ha seleccionado un solo dispositivo.


Actualizar firmware


¿Cómo actualizo el firmware del lector?

Seleccione Sistema->Actualizar firmware... y, a continuación, seleccione el archivo de firmware.

Nota: los archivos de firmware se suministran como archivos comprimidos. El firmware se debe cargar en su forma comprimida; no intente descomprimir un archivo de firmware antes de cargarlo.


¿Cómo puedo utilizar la función Actualizar firmware?

Esta función actualiza el dispositivo o dispositivos seleccionados a la versión de firmware deseada. Seleccione el dispositivo o dispositivos que quiera actualizar en la lista de dispositivos.

Busque los archivos de firmware haciendo clic en el icono «...». Si se selecciona un dispositivo concreto en la lista de dispositivos, se abrirá la carpeta de firmware correspondiente para ese dispositivo. Si se seleccionan varios dispositivos, pero tienen el mismo ID de dispositivo de firmware, se abrirá la carpeta correspondiente. Si no se selecciona ningún dispositivo o se seleccionan varios dispositivos, pero con distintos ID de dispositivo de firmware, se abrirá la carpeta raíz de firmware.

Si se marca la casilla de la parte inferior, la herramienta de configuración realiza una copia de seguridad de los archivos de configuración del mismo modo que la función Copia de seguridad (consulte las preguntas y respuestas sobre copia de seguridad para obtener más información).

Después de seleccionar el archivo de firmware, haga clic en Actualizar firmware en la parte inferior derecha. El botón se activa solo si la versión de firmware seleccionada y la selección de dispositivos son compatibles.

Nota: en el caso de dispositivos serie, deberá descubrirlos primero actualizando manualmente antes de poder actualizar el firmware.


Comparar configuración


Comparar configuración: estructura y diseño general

Comparar configuración es una herramienta a estilo de vista de tabla que permite establecer, copiar, comparar o restaurar configuraciones de dispositivos. El área principal de la página de documento contiene una cuadrícula con las propiedades del dispositivo que se seleccionó antes de su inicialización en la página Conectar al lector.

Cada tipo de documento de la herramienta de configuración utiliza su propia conexión. En el caso de la comunicación serie, solo se puede abrir una conexión a la vez.

La fila de título muestra el nombre o nombres de los dispositivos seleccionados. La segunda fila de títulos debajo de la primera muestra las configuraciones disponibles para el dispositivo. Los títulos de fila inferiores (en negrita) pueden contraerse o abrirse haciendo clic en el icono situado junto a ellos. Si un dispositivo está desconectado, aparece un icono de reconexión en su fila de título.

Las configuraciones que no son dependientes de la configuración de lectura solo se muestran en la primera columna (configuración principal).


Comparar configuración: controles (ratón y teclado)

Selección:

  • Ratón: al hacer clic en una celda de la cuadrícula, se selecciona la celda y se resalta el título de su fila y el título de la/s columna/s a las que pertenecen el dispositivo y la configuración. Los botones de menú y los elementos del menú de la cinta pueden variar en función de la selección. Si la celda seleccionada se encuentra en una fila de título, se seleccionarán todas las celdas de la columna actual que pertenezcan a ese título.

  • Teclado: las teclas de movimiento del cursor permiten mover la selección a la celda apropiada. El funcionamiento en cuanto a resaltado y selección es el mismo que con el ratón.

Agregar/cambiar valores:

  • Ratón: en celdas con editores incorporados, hacer clic en el control del editor (cuadro de combinación, casilla, control numérico arriba-abajo) se podrán introducir valores. En celdas con editores personalizados (icono «...»), se abre un editor emergente que permite introducir valores.

  • Teclado: en celdas con editores incorporados, al pulsar Entrar o F2 se inicia el modo de edición; con Esc se cancela la edición y pulsando Entrar por segunda vez se confirma la edición. Los valores pueden introducirse en el texto seleccionado sin entrar en el modo de edición, en cuyo caso el valor actual se sobrescribirá con la primera tecla que se pulse.

    En las celdas numéricas, además de las celdas con editor de texto incorporado, las flechas arriba y abajo aumentan o disminuyen el valor.

    En celdas desplegables, Entrar inicia el modo de edición y muestra los elementos desplegables, mientras que las flechas arriba y abajo mueven la selección. Pulsando Entrar por segunda vez se aplica el valor seleccionado y con Esc se cancela la edición.

    En las celdas de casilla de verificación, utilice Espacio para alternar entre los estados marcado/no marcado.

Copiar y pegar:

Utilice las combinaciones de teclado Ctrl+C y Ctrl+V para copiar y pegar, respectivamente. Consulte la descripción de copiar-pegar de los elementos de menú de la cinta relacionados para obtener más información.


Comparar configuración: menú de la cinta

El menú de la cinta se encuentra encima de la cuadrícula a estilo de vista de tabla. Sus contenidos e iconos activos pueden cambiar en función de las celdas, filas o columnas que se seleccionen en la cuadrícula. El menú está dividido en varios grupos.

  • Dispositivo: las configuraciones en este grupo están relacionadas con dispositivos y con sus archivos de configuración. Utilice el botón Agregar dispositivo... para abrir un cuadro de diálogo donde podrá seleccionar uno o más dispositivos para agregar a la comparación. El botón Agregar archivo de configuración... abre un asistente donde se puede buscar un archivo de configuración o de copia de seguridad (.dmb, .cdc, .cfg). Si el archivo seleccionado para el dispositivo no contiene toda la información necesaria, deberán establecerse los parámetros que falten; de lo contrario, se seleccionarán automáticamente las opciones predeterminadas. Lo mismo se aplica a los casos en los que la base de datos de dispositivos virtuales no puede establecer correspondencias entre los parámetros y las opciones disponibles (por ejemplo, no se encuentra una versión de firmware coincidente).

    Nota: los dispositivos virtuales agregados son de solo lectura, tal y como indica el icono de candado en su fila de título.

    Si se hace clic en el botón Quitar dispositivo, se quitará el dispositivo o los dispositivos seleccionados actualmente (el que contenga la/s celda/s seleccionada/s actualmente). Reiniciar dispositivo reinicia los dispositivos seleccionados. Configuración persistente en el dispositivo guarda el archivo de configuración del dispositivo seleccionado en su memoria flash. Utilice Restablecer valores predeterminados de fábrica para restablecer el/los dispositivo/s seleccionado/s a sus valores predeterminados.

  • Edición: utilice Copiar (o Ctrl+C en el teclado) para copiar un valor de la celda seleccionada en ese instante. Pegar solo puede utilizarse en la misma fila o en cualquier editor de texto. Restablecer valores permite restablecer el/los valor/es de la/s celda/s seleccionada/s.

  • Resaltado: los botones y configuraciones de este grupo de menú ofrecen opciones para resaltar el fondo de celdas específicas. Con la configuración Valores no predeterminados se resaltan las celdas que tengan valores no predeterminados (puede variar en una misma fila para diferentes dispositivos o configuraciones de lectura). La configuración Distinto de referencia resalta las celdas que tengan valores diferentes a los de la celda de la misma fila en la configuración de lectura (y el dispositivo) de referencia. Si se selecciona la tercera configuración, se resaltarán todos los valores y títulos que contengan el texto especificado en el cuadro de texto. Además, el texto contenido se resaltará con un fondo de texto diferente. Al pulsar Entrar, también se aplica la función del botón Mostrar solo filas resaltadas.

    Al activar Mostrar solo filas resaltadas, se contraerán todos los nodos que no tengan ningún subnodo resaltado. Si se activa Establecer configuración de lectura de referencia, especifica la configuración de lectura (y el dispositivo) que se utilizará como referencia cuando se utilice el modo de resaltado Distinto de referencia. Si el botón está activo, la columna de la celda seleccionada en ese instante (configuración de lectura) pasa a ser la configuración de referencia. La configuración de referencia actual se marca en la fila de título del nombre de configuración.

  • Filtrado: establezca Parámetros de configuración de lectura para ver únicamente las configuraciones dependientes de la configuración de lectura. Establezca Configuración global para ver únicamente configuraciones que no tengan valores distintos en diferentes configuraciones de lectura. Establezca Todas las configuraciones para ver todas las configuraciones al mismo tiempo. Si una entrada tiene valores en más configuraciones de lectura, estos se mostrarán en diferentes columnas.

  • Otros: utilice Expandir todas las filas para expandir todas las filas que se hayan contraído en la cuadrícula. Utilice Contraer todas las filas para contraer todas las filas expandidas de la cuadrícula. Restablecer diseño vuelve a calcular los anchos de columna para utilizar todo el espacio disponible. Si el espacio disponible no es suficiente, se aplica un ancho de columna mínimo.


Comparar configuración: Editor de comparación

Editor de comparación se abre para cada elemento de Secuencias de comandos en la vista de tabla Comparar configuración (en cualquiera de sus subcategorías) después de hacer clic en el icono «...». Una vez abierto, podrá ver en él el origen de las secuencias de comandos del dispositivo en el que se abrió el editor de comparación.

Si se hace clic en Predeterminada, se revertirá la secuencia de comandos a la secuencia de comandos predeterminada para ese dispositivo específico. Si se hace clic en Comparar, se mostrará en la parte derecha la secuencia de comandos predeterminada en el segundo dispositivo; no obstante, puede utilizarse el menú desplegable de la parte superior para cambiar la secuencia de comandos que se comparará con la de la izquierda. En el centro aparece un botón Actualizar entre las pestañas (flechas circulares rojas), que puede utilizarse para actualizar todos los textos de las secuencias de comandos.

Si se hace clic en Cerrar, se cerrará la comparación y volverá a la vista de tabla dentro de Comparar configuración.


Ventana de la imagen


¿Qué es el Visor de imágenes?

En esta ventana, puede ver las imágenes leídas por el dispositivo.

Utilice los iconos de lupa para ajustar la imagen al tamaño de la ventana Visor de imágenes, para alejar y acercar la imagen, o para visualizar la imagen en un modo píxel a píxel, respectivamente.

También puede activar o desactivar Información del enfoque en la imagen en el modo Visualización en vivo y copiar la imagen en el portapapeles.

Utilice la opción Guardar imagen para guardar solamente la imagen actual o todas las imágenes de la ráfaga, y las opciones de Registro para registrar en el sistema de archivos todas las imágenes no leídas o todas las decodificadas.

También puede seleccionar comprobar el histograma de la imagen leída y los datos de intensidad de la luz de un punto seleccionado en la imagen. Utilice los botones en la cinta de barras de herramientas de esta ventana para llevar a cabo estas tareas.


Historial de resultados


¿Qué es Historial de resultados?

En este panel, puede ver la información de decodificación después de cada lectura.

Utilice el botón Pausar para pausar/congelar la vista de herramientas del historial de resultados, lo que facilitará la búsqueda de información específica de lectura. Todos los resultados entrantes del dispositivo serán rechazados por la ventana del historial de resultados hasta que se cancele la pausa.

Utilice Borrar historial para borrar la lista Historial. También puede exportar una sola cadena de decodificación o todas ellas con las opciones Copiar y Copiar todos, respectivamente.

En Registro, puede marcar Generar informes de calidad de los códigos para incluir los datos de calidad de los códigos en la información de decodificación, marcar Generar informes de validación de datos para incluir la información de validación de datos y Registrar todos los resultados en el sistema de archivos para guardar localmente todos los elementos del Historial de resultados en su unidad de disco duro. Se puede acceder a más opciones relacionadas haciendo clic en Configuración de registro e informes.

Personalizar permite agregar o quitar columnas de la tabla para personalizar la información del Historial de resultados.

Para el filtrado de resultados, consulte la pregunta a continuación.


¿Cómo funciona el filtrado de resultados?

Puede utilizar el botón Filtro... del menú de la cinta Vista de herramientas de Historial de resultados para filtrar los resultados de lectura que se muestran en la vista. Al hacer clic en el botón, se activa el filtrado. Para configurar los parámetros de filtrado, abra las opciones haciendo clic en la parte derecha del botón.

Nota: el botón Filtro solo se muestra si el sistema operativo lo admite.

Hay dos modos disponibles en la configuración de filtrado: filtrado estándar y filtrado avanzado. Puede seleccionar cualquiera de los modos en el menú desplegable que encontrará en General.

Si se utiliza el filtrado estándar, las categorías de filtrado se muestran como activas en la ventana desplegable (Estado de resultados, Método de validación, Estado de validación y Símbolos). Puede seleccionar filtros individuales en cada categoría haciendo clic en ellos. Una vez activados, estos filtros se utilizarán en todos los elementos futuros del historial de resultados y también de forma retroactiva. Los elementos no especificados por filtros se excluyen del historial de resultados hasta que se desactive el filtrado. Tenga en cuenta que en el filtrado estándar, un resultado de lectura correcta en una secuencia de disparo cuenta como una lectura correcta para toda la secuencia de disparo. Por consiguiente, por ejemplo, el filtrado estándar no es aplicable a escenarios de código múltiple; utilice secuencias de comandos de filtrado avanzado para escenarios de código múltiple.

Si se utiliza el filtrado avanzado, se desactivan las categorías de filtrado estándar y se activa la Configuración de filtrado avanzado en la ventana desplegable. Al hace clic en esta opción, se abre una nueva ventana donde puede editar las expresiones de filtro. Si se activó un filtro predefinido previamente, la expresión generada puede verse en este cuadro de diálogo. La edición de la expresión no tiene efecto retroactivo en los filtros predefinidos.

La expresión de filtro es una función de JavaScript. El uso de miembros de datos del resultado tiene el mismo efecto que el formato basado en secuencias de comandos. El resultado de una expresión puede verse en la ventana ubicada en la parte inferior. En caso de un error de JavaScript, el mensaje de error se mostrará en la ventana de texto. Tenga en cuenta que, pese a las similitudes, el filtrado avanzado no es una secuencia de comandos de formato de datos, solo un filtro de visualización que se ejecuta en la herramienta de configuración.


¿Por qué aparece el símbolo marcado en verde pero no aparecen datos en la lista Historial de resultados?

Si una casilla Formato estándar activado está marcada en el panel Formato estándar, debe crear una cadena de salida personalizada o no aparecerá ningún dato de resultado aunque el lector haya decodificado el símbolo.


¿Por qué algunos resultados tienen un icono delante?

Los resultados encabezados por un icono tienen una imagen guardada asociada. Haga clic en la línea del resultado para visualizar el intento de decodificación y la imagen asociada al mismo.


Registro de dispositivo


¿Qué es el Registro de dispositivos?

Esta vista muestra los registros que se generan cuando el LED rojo del dispositivo parpadea. Puede actualizar este registro o eliminarlo cuando ya no se necesite.


Tamaño de imagen


¿Para qué se utiliza la configuración Tamaño de imagen (Región de interés)?

Puede utilizar esta función para especificar la región exacta de la imagen que el lector utilizará para detectar y decodificar un símbolo. Puede ser de utilidad si hay dos códigos Data Matrix uno al lado del otro y resulta necesario asegurarse de que solo se lea el código que esté bajo la línea de enfoque del objetivo. La reducción de la región de interés no disminuye necesariamente el tiempo de decodificación ni aumenta la velocidad de transferencia de la imagen.


¿Tiene el tamaño del decodificador de la ROI algún efecto en los Códigos de configuración del lector?

Restringir la región de interés a un tamaño demasiado pequeño podría dar como resultado que el lector no pudiera leer los Códigos de configuración del lector.


Validación de datos


¿Qué es la validación de datos?

La validación de datos se utiliza para confirmar que los datos codificados por un símbolo estén en el formato correcto para una empresa, industria o estándar internacional determinados.


¿Dónde se visualiza el historial de resultados de la validación de datos?

Los resultados correcto/incorrecto y de salida de la validación de datos se visualizan en el historial de resultados. La entrada Resultado en la lista del historial de resultados mostrará un icono «+», que sirve para abrir los detalles del resultado del intento de validación. Los resultados de la validación de datos pueden visualizarse en el historial de resultados de la misma forma.


¿Qué significan los códigos de error de la validación?

Los resultados Incorrecto de la validación de datos son los siguientes:

  • 1: identificador de símbolos no válido. El identificador de símbolos es la cadena de tres caracteres que no solo identifica el tipo de símbolo utilizado para la codificación de los datos, sino que también describe cómo procesar los datos. Esta cadena se puede pasar de forma opcional como entrada a la herramienta junto a los datos de decodificación como una entidad independiente o prefijándola al flujo de datos.

    Ejemplo: Para un símbolo UCC/EAN-128, el identificador de símbolos es ]C1. En algunas aplicaciones, esta será la única manera de diferenciar de forma precisa y automática entre símbolos UCC/EAN-128 y Código 128 internos o de la industria. Sin los identificadores de símbolos, no sabría cómo procesar los datos en el símbolo.

  • 2: patrón no coincidente.

  • 3: calificadores de datos no válidos (AI, DI o TEI).

  • 4: identificador de aplicación no válido (AI).

  • 5: identificador de datos no válido (DI).

  • 6: identificador de elemento de texto no válido (TEI).

  • 7: datos no válidos (si los datos no coinciden con el calificador de datos en tipo, longitud o valor).

  • 8: separador de campo no válido.

  • 9: no compatible con ISO/IEC 15434.

  • 10: formatos no compatibles (p. ej. en aplicaciones DoD UID, formatos distintos de 05, 06 o DD).

  • 11: código de formato no válido (códigos de formato distintos de 00-99 y DD).

  • 12: no compatible con ISO/IEC 15434 si la opción de validación ISO/IEC 15434 está seleccionada, pero el flujo de decodificación no corresponde a un símbolo 2D. Solo es posible identificar este fallo si el identificador de símbolos se pasa como entrada a la herramienta.

  • 13: campo de aplicación no válido (un campo que no es compatible con la aplicación).

  • 14: campo de aplicación no compatible (un campo que es compatible con la aplicación pero no con la herramienta).

  • 15: datos de aplicación no válidos (si los datos no cumplen los requisitos específicos de la aplicación).

    Ejemplo: las aplicaciones DoD UID tienen los requisitos siguientes. La cadena de caracteres correspondiente al ID de la empresa no debe superar los 13 caracteres, sin incluir el calificador de datos. La cadena de caracteres correspondiente al número de lote o pieza original (incluidos los caracteres especiales permitidos) no debe superar los 32 caracteres, sin incluir el calificador de datos. La cadena de caracteres del número de serie (incluidos los caracteres especiales permitidos) no debe superar los 30 caracteres, sin incluir el calificador de datos.

  • 16: presencia de varios formatos en el mismo flujo de datos (p. ej. en aplicaciones DoD UID, no puede haber más de un formato en el flujo de datos).

  • 17: campos duplicados (varias ocurrencias del mismo calificador de datos en el mismo símbolo). Algunas aplicaciones, como las aplicaciones DoD UID, no permiten campos duplicados en el mismo símbolo.

  • 18: UID no válida (no están presentes todos los campos necesarios para crear una UID de Construcción # 1 o Construcción # 2 válida).

  • 19: UID de Construcción # 1 no válida (no están presentes todos los campos necesarios para crear una UID de Construcción # 1).

  • 20: UID de Construcción # 2 no válida (no están presentes todos los campos necesarios para crear una UID de Construcción # 2).

  • 21: falta el finalizador de formato al comprobar la conformidad con la sintaxis ISO 15434 o DOD UID.

  • 22: falta el finalizador de mensaje al comprobar la conformidad con la sintaxis ISO 15434 o DOD UID.


¿Cómo puedo cambiar la señal de salida del lector y el color del LED para códigos que no superen la validación?

Seleccione el panel de tareas Configuración del sistema. En la sección Validación de acción incorrecta, es posible que pueda seleccionar el tipo de tono, la intensidad y el color de LED.


¿Qué es la validación DoD UID?

La validación DoD UID se utiliza para evaluar si los datos codificados en un código Data Matrix se han codificado correctamente de acuerdo con las directrices Mil Standard 130 del Ministerio de Defensa estadounidense. Ahora el Ministerio de Defensa de los EE. UU. exige que todos los artículos (de más de 5 000 dólares o con un número de serie único) que reciba o mantenga en inventario se marquen con un número de serie único (UII) y con un formato sintaxis específica. La herramienta de validación DoD UID se utiliza para confirmar si los datos en un código tienen el formato correcto de acuerdo con los tipos de construcción 1 ó 2 del Ministerio de Defensa. La función Validación DoD UID también confirma automáticamente si la cadena de datos está en conformidad con las normas ISO 15434 e ISO 15418. La salida de UII concatenado (o simplemente los elementos de datos del UII sin la sintaxis ISO 15434 y los calificadores de datos ISO 15418) se muestra en el primer campo de resultados del campo Resultados de validación en el panel de tareas Resultados.

Los elementos de datos de construcción 1 incluyen: el identificador de empresa EID del fabricante (CAGE, DUNS, EAN.UCC) es el identificador de una empresa más el número de serie de la pieza dentro del identificador EID. El identificador de empresa y los números de serie están representados por calificadores de datos específicos en función de si una empresa utiliza el formato DI, AI o TEI.

Los elementos de datos de construcción 2 incluyen: el identificador de empresa (EID) del fabricante, el número de referencia del fabricante (PN) y el identificador del número de lote (BN) para la pieza y el número de serie único para la pieza dentro del número de referencia específico del fabricante. El identificador de empresa, el número de referencia/lote y los números de serie están representados por calificadores de datos específicos en función de si una empresa utiliza el formato DI, AI o TEI.

Nota: está opción no está disponible en todos los lectores.


¿Qué símbolo debería usar para la validación DoD UID?

Actualmente, el Ministerio de Defensa estadounidense especifica el código Data Matrix como el estándar para la marcación UID.


¿Qué es EID esperado?

EID esperado hace referencia al identificador de empresa del fabricante en la cadena de datos UII. El identificador de empresa (EID) del fabricante representa el código CAGE, DUNS, EAN.UCC del fabricante u otra identificación. EID esperado es un valor específico de DoD.


¿Qué es PN esperado?

PN esperado hace referencia al número de referencia del fabricante en la cadena de datos UII. PN esperado es un valor específico de DoD.


¿Qué es BN esperado?

BN esperado hace referencia al número de lote del fabricante en la cadena de datos UII. BN esperado es un valor específico de DoD.


¿Qué es la validación ISO?

La función Validación ISO se utiliza para determinar si una cadena de datos está correctamente codificada de acuerdo con la sintaxis ISO 15434 o ISO 15434 más ISO 15418.

ISO 15434 confirma si la cadena de datos se ha codificado con la sintaxis correcta que incluye la evaluación de los caracteres ASCII no imprimibles en la cadena tales como el título del mensaje, separador de datos, código del formato (para AI, DI o TEIs), separadores de grupo y carácter de fin de transmisión.

ISO 15418 confirma si la cadena de datos se ha codificado con los calificadores de datos correctos para cada elemento de datos. Dependiendo de qué formato esté usando el fabricante, ya sea AI, DI o TEI, cada elemento de datos (código EIN del fabricante, número de referencia y número de serie) está precedido por un código específico o un «calificador de datos».

Nota: está opción no está disponible en todos los lectores.

Nota: esta opción también permite Identificadores de elemento de texto como se define en la especificación ATA CSDD.


¿Qué es la validación GS1?

La validación GS1 le permite verificar la sintaxis y la semántica de los sistemas de símbolos respecto a la especificación GS1. El lector puede validar los datos codificados respecto a una cadena de identificadores configurable. Se admiten todos los identificadores de aplicación.

De forma predeterminada, el lector valida el símbolo entrante respecto a la cadena de formato de la Federación Europea de Industrias y Asociaciones Farmacéuticas (EFPIA), por ejemplo:

<AI(01)><AI(10)><AI(17)><AI(21)>

Al usar la validación GS1, podrá configurar qué transmitirá el lector cuando los datos de un símbolo no superen la verificación, incluidos un retorno de carro y un salto de línea. El panel de Resultados detallados mostrará un mensaje de CORRECTO o INCORRECTO para cada símbolo y listará cada identificador de aplicación en el símbolo junto con su elemento de datos acompañante.


¿Qué es la validación de cadena de correspondencia?

La validación de cadena de correspondencia le permite especificar una cadena exacta para que coincida con la cadena codificada por el símbolo. Solo los símbolos con una cadena que coincida con la cadena especificada generarán un resultado correcto.


¿Cómo puedo validar cadenas con valores que cambian?

Active el control Incrementar/Decrementar componente numérico para especificar que parte de la cadena para validar es un valor numérico que incrementa o decrementa con cada lectura sucesiva.


¿Para qué se utiliza el control Incrementar/Decrementar componente numérico?

Utilice esta función para realizar validaciones de cadena de correspondencia en aplicaciones en las que los datos codificados sean seriados o cambien de un modo lineal. Por ejemplo, la función Incrementar/Decrementar componente numérico puede ser muy útil en una aplicación de encuadernación de libros o de revistas en la que se utilicen códigos de barras para hacer un seguimiento de los números de página con el fin de evitar duplicados u omisiones.


¿Cómo configuro la función Incrementar/Decrementar componente numérico?

Puede utilizar esta función si la cadena que está validando contiene una secuencia de dígitos (0-9) que incrementan o decrementan con cada lectura sucesiva. Para utilizar esta función, especifique la posición inicial de los dígitos incrementados o decrementados en el campo Posición inicial (0 es la posición del primer carácter) y el número de caracteres que variarán en el campo Longitud. Si selecciona Automática como Longitud, el lector tratará todos los dígitos consecutivos desde la posición inicial como el valor incrementado o decrementado. Utilice la opción Tamaño de paso para especificar cuánto cambia el valor entre lecturas. Seleccione un valor negativo si el número disminuye.

Por ejemplo, si su cadena inicial es ABC_123XXPY y con cada lectura sucesiva «123» se incrementa en uno, especificaría una Posición inicial de 4, una Longitud de 3, y un Tamaño de paso de 1. (Si estuviera seguro de que los caracteres de la posición 7 en adelante nunca serían dígitos, también podría especificar Automática como Longitud.) Tenga en cuenta que la configuración Automática no incrementa el número de dígitos cuando se alcanza el número máximo, sino que restablece el número al igual que con cualquier configuración de dígitos fijos (por ejemplo, al alcanzar 99 con dos dígitos no se pasa a 100, sino a 00).

De forma predeterminada, si la cadena no es válida o no se puede leer, el valor numérico esperado no cambia. Puede marcar las casillas Actualizar en No lectura y Actualizar en caso de error de validación para especificar que el valor esperado cambie cuando no se lea ningún código, si el código no es válido o en ambos casos.


¿Para qué se utiliza la validación de correspondencia del patrón?

La validación de correspondencia del patrón permite a un usuario introducir una cadena de caracteres específica para confirmar si están presentes en la cadena de datos. Por ejemplo, un usuario podría introducir el patrón 17V, que se utiliza en los formatos DI para identificar el identificador de empresa del fabricante. Si los caracteres 17V están presentes en el código, el lector indicará que la validación es correcta para ese código. Si los caracteres no están presentes, el lector indicará una validación errónea.

Debe usar una Expresión regular como patrón para una validación de patrones.


¿Para qué se utiliza la validación de acción incorrecta?

La validación de acción incorrecta se utiliza para determinar qué transmitirá el lector después de un error de validación. El usuario puede seleccionar diferentes opciones:

  1. Transmitir «Error de validación»: el lector transmitirá la cadena «Error de validación» después de que un código no supere la validación
  2. Transmitir «Error de validación» + cadena decodificada: el lector transmitirá la cadena «Error de validación» después de una cadena decodificada por completo
  3. Transmitir cadena de decodificación anotada: el lector transmitirá la cadena decodificada junto con información sobre el tipo de error y la ubicación del error en la cadena
  4. No transmitir nada: el lector no transmitirá ninguna información
  5. Transmitir «Error de validación» + cadena de decodificación entrecomillada: el lector transmitirá la cadena «Error de validación» seguida de la parte entrecomillada de la cadena decodificada.


¿Para qué se utiliza la adición de validación de acción incorrecta de la casilla CR/LF?

La casilla CR/LF se utiliza para introducir un retorno de carro/salto de línea después de una salida de validación errónea.


¿Cómo buscar cadenas de correspondencia múltiples?

Use la validación de correspondencia de patrones e introduzca una cadena de correspondencia con formato Perl. Por ejemplo, para corresponder las cadenas 123, 456 o 789, introduzca lo siguiente:

^(123¦456¦789)$


¿Qué sucede cuando se activa la Validación de datos?

El estado de la Validación de datos se muestra en la entrada de la lista de resultados Estado de resultados del panel Historial de resultados. El estado para una validación correcta es «Válida» y para una validación incorrecta es «No válida». Para obtener más información sobre el resultado de la validación, se puede desplegar el resultado.


¿Qué es Formato de datos en la validación incorrecta?

El formato de datos «Formato básico» no se aplica a un resultado si falla la validación. En su lugar, se ejecuta la «Validación de acción incorrecta». Esto es diferente del formato de datos «Formato basado en secuencias de comandos». Si se activa «Formato basado en secuencias de comandos», no se ejecuta la «Validación de acción incorrecta» y se ejecuta la función de formato de secuencias de comandos. Esto permite, por ejemplo, matizar el estado de la «Validación de datos» mediante secuencias de comandos.


Configuración de copia de seguridad


¿Qué es la copia de seguridad automática de la configuración del lector?

La copia de seguridad automática funciona con dispositivos conectados a través de Ethernet. Cuando está activada, esta función realiza una copia de seguridad de la configuración del dispositivo en un dispositivo de almacenamiento externo (un servidor FTP) cada vez que la configuración se guarda en flash. Un servicio de Cognex Explorer puede recibir los datos de la copia de seguridad. La restauración se puede realizar manualmente con la herramienta de configuración, comandos DMCC o Cognex Explorer.

Configure el lector con la dirección IP y el número de puerto necesarios para especificar dónde quiere guardar la configuración. También puede establecer una combinación de nombre de usuario y contraseña.


Imprimir código de copia de seguridad del dispositivo


¿Para qué se utiliza la opción Imprimir código de copia de seguridad del dispositivo?

Utilice esta opción para imprimir los códigos de copia de seguridad del lector (código de restablecimiento de hardware y código de reinicio) de manera que pueda sustituir su dispositivo leyéndolo con el lector. Estos códigos también contienen la configuración de red y la configuración serie.

En la sección Notas, puede realizar anotaciones importantes que también se mostrarán en la página impresa. Si desea imprimir los códigos de restablecimiento en páginas separadas, marque la casilla Imprimir código de restablecimiento en la página.


Imprimir código de configuración


¿Para qué se utiliza la opción Imprimir código de configuración?

Utilice esta opción para imprimir los códigos de configuración del lector (restablecimiento de hardware y código de reinicio) de manera que puedan ser leídos por el dispositivo o los dispositivos que desee configurar.

En la sección Notas, puede realizar anotaciones importantes que también se mostrarán en la página impresa. Si desea imprimir los códigos de restablecimiento en páginas separadas, marque la casilla Imprimir código de restablecimiento en la página.


Registro de datos


¿Qué es el registro de datos?

El registro de datos le permite guardar automáticamente en la ubicación de archivos especificada las imágenes leídas correctamente. Además, también puede guardar los informes de validación de datos para los símbolos que verifique si se ha activado la validación de datos para el tipo de código escaneado por el lector. Asegúrese de que permanece conectado a la herramienta de configuración para que funcione el registro de datos.


¿Cuándo desactivo los gráficos superpuestos en un informe?

Seleccione Desactivar gráficos superpuestos en informe si no desea que el cuadrado verde que rodea un código leído aparezca en el PDF.


Vista de herramientas de imagen


¿Qué es el Panel de imágenes?

En este panel, puede ver las imágenes leídas por el dispositivo.

Utilice los iconos de lupa para ajustar la imagen al tamaño de la ventana Vista de herramientas de imagen para alejar y acercar la imagen, o para visualizar la imagen en un modo píxel a píxel, respectivamente.

También puede activar o desactivar Información del enfoque en la imagen en el modo Visualización en vivo y copiar la imagen en el portapapeles.

Utilice la opción Guardar imagen para guardar solamente la imagen actual o todas las imágenes de la ráfaga, y las opciones de Registro para registrar en el sistema de archivos todas las imágenes no leídas o todas las decodificadas. Haga clic en la última opción de Registro, Configuración de registro e informes... para abrir la ventana de Opciones de la herramienta de configuración, a la que también se puede acceder desde la pantalla de Inicio de la herramienta de configuración a través del menú Opciones.

NOTA: Configuración de la imagen mostrada no tiene efecto cuando se guarda la última imagen tomada del Panel de imágenes (arrastrando y soltando). La última imagen siempre se guarda a tamaño completo (la máxima resolución del dispositivo).


¿Dónde coloco la imagen para conseguir que el lector la lea?

Asegúrese de que el símbolo esté centrado en el área de imágenes del lector y de que el punto del láser de enfoque rojo se encuentre en el centro del símbolo.


Tengo problemas para leer el código de mis piezas. ¿Qué debo hacer?

  • Asegúrese de pulsar el disparador y no soltarlo. Si suelta el disparador antes de que la lectura se haya completado, el lector abandona la lectura.

  • Verifique que el lector se encuentre en la distancia de trabajo especificada para el tamaño y tipo de código, como se indica en el documento Scan Map.

  • Asegúrese de que el símbolo esté centrado en el área de imágenes del lector y de que el código esté centrado en la luz de enfoque verde antes de accionar el disparador.

  • Haga clic en Configuración de luz y generador de imágenes (Configuración de UltraLight para DM7500, DM8500 y DM8600), y luego ajuste la configuración de la luz.

  • Haga clic en Configuración de símbolos y asegúrese de que el tipo de símbolos que está utilizando está activado.


Tengo problemas con la lectura de los símbolos. ¿Qué debo hacer?

  • Compruebe que el lector se encuentre en la distancia de trabajo especificada para el tamaño y tipo de símbolo, como se indica en la guía de referencia rápida.

  • Asegúrese de que el símbolo esté centrado en el área de imágenes del lector; asegúrese de que el símbolo esté centrado en el enfoque del láser rojo cuando dispare el dispositivo.

  • Haga clic en Configuración de símbolos y asegúrese de que los símbolos que está utilizando estén activados.


¿Cómo puedo enviar un disparo al lector utilizando la herramienta de configuración?

Haga clic en el botón de disparo (icono de relámpago) en la barra de herramientas superior o pulse <Ctrl>-T.


¿Cómo puedo guardar una imagen adquirida en un archivo?

Haga clic en el botón Guardar imagen en la barra de herramientas. Puede guardar todas las imágenes de una ráfaga abriendo la lista desplegable y haciendo clic en Guardar todas las imágenes de ráfaga.

También puede arrastrar y colocar su imagen en su PC. Haga clic en la imagen en el Visor de imágenes, arrástrela fuera de la herramienta de configuración y suéltela.

Tenga en cuenta que, en caso de querer guardar una imagen con arrastrar y colocar y la imagen no es la más reciente (está guardándola desde el Historial de resultados de lectura), la imagen se guardará con la configuración de imagen mostrada. De manera predeterminada, esta será de calidad reducida. En Configuración de la imagen mostrada, puede cambiar el tamaño de la imagen a completo y el formato a Bitmap.


Almacenamiento y transferencia


¿Qué es la configuración de la imagen almacenada?

En Configuración de la imagen almacenada, puede cambiar el tamaño, formato y calidad de la imagen transferida a través del FTP.

  • tamaño: el tamaño de imagen predeterminado para las imágenes almacenadas es la imagen a tamaño completo. La elección entre diferentes tamaños de imagen permite al lector realizar un submuestreo de cada imagen, lo que puede mejorar considerablemente la velocidad de transferencia de imagen a costa de algunos detalles de imagen precisos.

  • formato: de manera predeterminada, el lector almacena cada imagen adquirida en formato .bmp.

  • calidad: disponible únicamente si se utiliza el formato de imagen .jpeg, este control ajusta los parámetros internos que permiten al lector realizar una operación de suavizado en la imagen adquirida, que puede reducir o mejorar la velocidad de transferencia.


¿Qué es la opción Gráficos superpuestos?

Cuando seleccione esta opción, las imágenes que guarde (a través de un FTP o grabándolas) contendrán gráficos superpuestos como archivos SVG adjuntos a los archivos de las imágenes.


¿Por qué no veo las imágenes decodificadas?

La función Almacenamiento y transferencia no realiza ninguna decodificación. Active Gráficos superpuestos en el panel Configuración de la imagen almacenada, y sus imágenes se guardarán con los gráficos superpuestos (como archivos SVG) que se mostrarán cuando reproduzca sus imágenes. Estos gráficos mostrarán los datos decodificados junto a otra información del decodificador.


¿Qué puedo hacer con Almacenamiento y transferencia?

Almacenamiento y transferencia le permite controlar qué imágenes se graban y guardan en el lector; le permite ver imágenes que se hayan guardado en el lector y le permite también transferirlas a su PC.

  • La pestaña Almacenamiento de imágenes le permite controlar qué imágenes se guardan en el lector.

  • La pestaña Transferencia a PC de imágenes le permite controlar cómo se transfieren las imágenes del lector a su PC.

  • La pestaña Transferencia por FTP de imágenes le permite configurar transferencias de imágenes automáticas del lector a su PC.

  • Use la pestaña Transferencia por FTP de resultados para configurar el lector con la dirección IP y el número de puerto necesarios para enviar los resultados de decodificación a un servidor FTP.


¿Puedo enviar resultados decodificados a un servidor FTP?

Use la pestaña Transferencia por FTP de imágenes para configurar en el lector la dirección IP y el número de puerto necesarios para enviar los resultados de decodificación a un servidor FTP. La pestaña también contiene la configuración de una combinación de nombre de usuario y contraseña, junto con el nombre del archivo para almacenar los resultados.


¿Cómo puedo almacenar los datos del FTP en un directorio diferente del directorio raíz?

El campo Nombre de archivo no solo acepta nombres de archivos sino también nombres de rutas. Use barras diagonales como delimitadores. Por ejemplo, /imágenes/imagen.


¿Por qué no puedo ver las imágenes y los resultados en mi directorio de FTP?

Asegúrese de que dispone de los permisos necesarios para crear archivos. Si se encuentra marcada la opción Adición, asegúrese de que el usuario de FTP disponga de permisos de adición (que son distintos de los permisos de escritura). El usuario de FTP también deberá comprobar la dirección IP del servidor FTP correcto.


¿Para qué se utiliza la lista Qué resultados almacenar?

La lista Qué resultados almacenar le permite elegir qué tipo de imágenes se almacenan de forma interna en el lector, tanto si contienen información de decodificación (Leídas), como si no contienen información de decodificación (No leídas), si contienen ambas (Todas) o si se produce un fallo de validación, en cuyo caso solo se almacenarán las imágenes decodificadas correctamente pero con fallo de validación.


¿Qué es la opción Qué imágenes almacenar para un resultado?

Puede elegir qué imágenes almacenar para un resultado. Igual al resultado significa que para una lectura correcta, el lector solo guarda imágenes con un código encontrado.


¿Qué es el tamaño máximo del búfer de almacenamiento?

El tamaño máximo del búfer de almacenamiento es el número máximo de imágenes que pueden almacenarse en el lector. Este número se encuentra limitado por la memoria de dicho lector, pero puede fijarse en un número menor que el máximo para impedir que se guarden más imágenes de las deseadas en el servidor FTP o en el PC.


¿Qué es la configuración Disponible para herramienta de configuración/DMCC?

Disponible para herramienta de configuración/DMCC indica el número de imágenes que no utiliza el sistema de adquisición o Grabación de imágenes. Hace referencia al número máximo de imágenes de resultados que pueden transferirse a la herramienta de configuración o al SDK para un único resultado.

NOTA: se trata de un valor informativo que no puede modificarse.


¿Qué puedo configurar con el modo Imagen leída correctamente?

Imagen leída correctamente guarda todas las imágenes leídas correctamente almacenadas a menos que establezca una tasa límite.

Puede limitar el número de imágenes leídas correctamente que se almacenan seleccionando Tasa limitada. Establezca la tasa de imágenes leídas (el número de imágenes almacenadas y la frecuencia de este recuento) y la ráfaga de la tasa, que es la tasa máxima para el tiempo establecido.


¿Qué sucede si marco la opción Permitir sobreescritura del búfer?

La opción Permitir sobreescritura del búfer controla si el almacenamiento de imágenes en el búfer sobrescribe las imágenes más antiguas o interrumpe el almacenamiento cuando el búfer esté lleno.


¿Cómo puedo asegurarme de que las imágenes se borran después de la transferencia?

Marque la casilla Borrar tras la transferencia, que controla si las imágenes se eliminan después de la transferencia. Esto se aplica a cualquier modo de transferencia, incluida la transferencia por FTP de imágenes y la transferencia del lector al PC.


¿Por qué no se encuentra activado el botón Transferir ahora?

Si ha almacenado imágenes en el lector, primero deberá seleccionar la carpeta en la que guardarlas. Debe interrumpir la grabación antes de que pueda comenzar la transferencia.

Tenga en cuenta que Transferir ahora no funciona si se está fuera del alcance de la estación base emparejada con el dispositivo (en el caso de dispositivos portátiles), ya que el búfer se borra y desactiva cuando se está fuera del alcance.


¿Limpia también la cinta de imágenes el botón Despejar carpeta de transferencia?

El botón Despejar carpeta de transferencia borra todas las imágenes de la carpeta. Si las mismas imágenes se muestran actualmente en la cinta de imágenes, ésta también se limpiará.


Si ya tengo los archivos en la carpeta seleccionada, ¿se sobrescriben?

Si en la carpeta seleccionada ya existen archivos que se correspondan con el formato [Índice], el índice inicial se incrementará de forma automática hasta que no exista una correspondencia, y después comenzará la transferencia. Los archivos de imágenes no se sobrescribirán.


¿Puedo ver las imágenes individualmente?

Puede ver las imágenes una por una, pero debe seleccionar toda la carpeta en la que están ubicadas las imágenes. Una vez que se muestren las imágenes de la carpeta seleccionada, haga clic en ellas, usando los botones de adelante y atrás.


¿Tengo que empezar de nuevo a visualizar las imágenes si tengo que abandonar el panel?

No, abandonar el panel Almacenamiento y transferencia detendrá la reproducción como si se hubiese hecho clic en el botón Pausa.


¿Cómo transfiero las imágenes a un servidor FTP?

Use la pestaña FTP para establecer la configuración necesaria para transferir imágenes a un servidor FTP. La pestaña contiene la configuración para la dirección IP y el número de puerto del servidor, así como una combinación de nombre de usuario y contraseña. Tenga en cuenta que las imágenes enviadas mediante FTP no tienen su envío garantizado, que podría no tener lugar cuando el lector esté operando a una frecuencia superior y no pueda programar el momento de transferencia de las imágenes. Tenga en cuenta también que la transferencia mediante conexiones inalámbricas puede ser más lenta que la comunicación de red normal. En dichos casos, se recomienda utilizar imágenes comprimidas o con una resolución más baja.

Las opciones de Nombre de archivo le permiten especificar el archivo donde se almacenarán las imágenes. El campo Nombre de archivo le permite especificar una ruta en relación al directorio raíz del servidor FTP (por ejemplo, /imágenes_erróneas/imagen). La extensión de nombre de archivo (.jpg o .bmp) que aparece en la etiqueta que sigue al nombre de archivo se corresponde con la configuración de formato de imagen en el panel Configuración de la imagen almacenada. Tenga en cuenta que el lector no crea directorios; el directorio debe estar disponible y accesible.

El control Máx. valor de adición indica el límite del valor de incremento usado en el nombre del archivo. Un valor de 0 indica que no se sumará ningún incremento y que el archivo puede sobrescribirse.

El Nombre de archivo generado por la secuencia de comandos permite escribir una secuencia de comandos que genere el nombre de archivo en la pestaña Almacenamiento FTP del panel Secuencias de comandos.

La opción Nombre de archivo generado por el servidor comienza con una ruta en blanco que indica el directorio raíz del servidor FTP.


No funciona la transferencia por FTP de imágenes en tiempo de ejecución. ¿Qué debo hacer?

Asegúrese de que se cumplen las siguientes condiciones:

  • La dirección del servidor, el nombre de usuario y la contraseña están correctamente configuradas.

  • El modo de transferencia se ha establecido como «FTP - Tiempo de ejecución».

  • La pestaña Búfer tiene establecida la opción «Qué resultados almacenar» con cualquier valor excepto Ninguna (de acuerdo con sus necesidades).

  • Su servidor FTP admite la transferencia de imágenes.


¿Qué es el Nombre de archivo generado por la secuencia de comandos?

Puede escribir una secuencia de comandos que genere el nombre de archivo para la transferencia por FTP en la pestaña Almacenamiento FTP del panel Secuencias de comandos.


¿Qué es el Nombre de archivo generado por el servidor?

Algunos servidores FTP son compatibles con esta funcionalidad para nombrar de forma única los archivos entrantes antes de guardarlos en el disco.


¿Qué debería hacer si no funcionan las transferencias por FTP de nombres de archivo generados por el servidor?

Verifique que su servidor FTP puede trabajar con el comando «STOU - Almacenamiento único». Este comando se comporta como el comando STOR, excepto que el archivo resultante se creará en el directorio actual con un nombre único para ese directorio.


¿Cuáles son los diferentes modos de transferencia?

El modo de transferencia A petición transferirá las imágenes cuando haga clic en Transferir ahora en la herramienta de configuración o cuando envíe el DMCC apropiado. Si elige el modo de transferencia FTP - Tiempo de ejecución las imágenes se enviarán automáticamente al servidor FTP tan pronto como se active la conexión.

Tenga en cuenta que Transferir ahora no funciona si se está fuera del alcance de la estación base emparejada con el dispositivo (en el caso de dispositivos portátiles), ya que el búfer se borra y desactiva cuando se está fuera del alcance.


¿Por qué se desactiva todo el panel cuando transfiero archivos?

El panel se desactiva para lograr la mayor estabilidad de transferencia por FTP de imágenes posible. La transferencia por FTP de imágenes puede llevar varios minutos, dependiendo de la velocidad de conexión al servidor FTP y del tamaño y número de imágenes transferidas.


Opciones


¿Qué puedo configurar en la página Opciones?

El panel Opciones de la herramienta de configuración DataMan le permite realizar configuraciones en la aplicación de acuerdo con sus preferencias.


¿Qué puedo establecer en el campo Configuración de idioma?

Aquí, puede seleccionar el idioma en el que desea utilizar la herramienta de configuración. El valor predeterminado es Inglés.

NOTA: Es preciso reiniciar la aplicación para que los cambios surtan efecto.


¿Qué puedo configurar en el campo Visualización de códigos de Página de códigos?

Aquí puede establecer de qué forma se codificará la cadena de lectura.


¿Qué puedo establecer en el campo Esquema de color?

Seleccione el esquema de color de la ventana Herramienta de configuración DataMan en este campo.


¿Qué puedo ajustar en el recuadro Restablecer configuración?

En este recuadro, seleccione para qué categoría (Comunicación, Diseño, Mensajes que no se volverán a mostrar, Registro de datos, Dispositivos excluidos, Página de códigos, Idioma, RTM Lean - Todas las configuraciones, Carpetas predeterminadas, Dispositivos virtuales, Verificación, Alerta sonora, Asistentes) desea restablecer los valores predeterminados.


¿Qué es la configuración Ubicación de copia de seguridad?

Aquí, puede establecer la carpeta que utilizará la función Copia de seguridad para guardar archivos de copia de seguridad.


¿Qué opciones hay disponibles en la pestaña Registro de datos?

En esta pestaña, puede establecer las carpetas en las que se guardarán los códigos de resultados, las imágenes decodificadas, las imágenes no leídas y los informes, así como opciones para cambiar nombres de archivo y extensiones cuando se registren datos.


¿Cómo puedo activar la generación de informes de validación de datos?

Seleccione Generar informes de validación de datos en Registro dentro del panel Historial de resultados.


¿Qué puedo configurar en el campo Almacenamiento y transferencia de imágenes?

Aquí, puede establecer la carpeta donde se pueden transferir las imágenes.


¿Qué puedo establecer en el campo Configuración de alerta sonora?

Puede establecer la configuración de alerta sonora del PC para las lecturas correctas. Cuando la herramienta de configuración reciba una lectura correcta del lector DataMan, activará la alerta sonora del PC. Esto puede ser práctico para lectores DataMan que no tienen una alerta sonora interna. Puede establecer la frecuencia (de 1000 a 10 000 Hz) y la duración (de 10 ms a 1000 ms) de la alerta de lectura correcta.


¿Cómo puedo activar la función Informes?

Una vez haya completado los campos de Informes, deberá cambiar a Validación de datos para generar informes.


El código de resultados, las imágenes decodificadas o las imágenes no leídas no aparecen en el directorio correspondiente. ¿Cuál puede ser el problema?

Debe activarlos en su correspondiente cuadro de lista desplegable Registro.


Vista de tabla


¿Por qué varios valores aparecen resaltados?

Los valores que están resaltados son valores que inicialmente no son predeterminados. Las reglas de resaltado pueden modificarse en la sección Resaltado del menú de la cinta. Consulte la pregunta Vista de tabla: menú de la cinta para obtener más información.


¿Por qué varios valores aparecen en negrita?

Los valores en negrita pueden expandirse y mostrar subvalores.


¿Cómo sé cuáles son los valores posibles?

Mueva el puntero del ratón sobre un valor y consulte el texto que aparecerá encima indicando los valores mínimos, máximos y predeterminados, donde fueran aplicables.


Vista de tabla: estructura y diseño general

Vista de tabla es una herramienta de visualización que utiliza un estilo de cuadrícula.

La fila de título muestra el nombre del dispositivo. La segunda fila de títulos debajo de la primera muestra las configuraciones disponibles para el dispositivo. Los títulos de fila inferiores (en negrita) pueden contraerse o abrirse haciendo clic en el icono situado junto a ellos. Si el dispositivo está desconectado, aparece un icono de reconexión en su fila de título.

Las configuraciones que no son dependientes de la configuración de lectura solo se muestran en la primera columna (configuración principal).


Vista de tabla: controles (ratón y teclado)

Selección:

  • Ratón: al hacer clic en una celda de la cuadrícula, se selecciona la celda y se resalta el título de su fila y el título de la columna a la que pertenecen el dispositivo y la configuración. Los botones de menú y los elementos del menú de la cinta pueden variar en función de la selección. Si la celda seleccionada se encuentra en una fila de título, se seleccionarán todas las celdas de la columna actual que pertenezcan a ese título.

  • Teclado: las teclas de movimiento del cursor permiten mover la selección a la celda apropiada. El funcionamiento en cuanto a resaltado y selección es el mismo que con el ratón.

Agregar/cambiar valores:

  • Ratón: en celdas con editores incorporados, hacer clic en el control del editor (cuadro de combinación, casilla, control numérico arriba-abajo) se podrán introducir valores. En celdas con editores personalizados (icono «...»), se abre un editor emergente que permite introducir valores.

  • Teclado: en celdas con editores incorporados, al pulsar Entrar o F2 se inicia el modo de edición; con Esc se cancela la edición y pulsando Entrar por segunda vez se confirma la edición. Los valores pueden introducirse en el texto seleccionado sin entrar en el modo de edición, en cuyo caso el valor actual se sobrescribirá con la primera tecla que se pulse.

    En las celdas numéricas, además de las celdas con editor de texto incorporado, las flechas arriba y abajo aumentan o disminuyen el valor.

    En celdas desplegables, Entrar inicia el modo de edición y muestra los elementos desplegables, mientras que las flechas arriba y abajo mueven la selección. Pulsando Entrar por segunda vez se aplica el valor seleccionado y con Esc se cancela la edición.

    En las celdas de casilla de verificación, utilice Espacio para alternar entre los estados marcado/no marcado.

Copiar y pegar:

Utilice las combinaciones de teclado Ctrl+C y Ctrl+V para copiar y pegar, respectivamente. Consulte la descripción de copiar-pegar de los elementos de menú de la cinta relacionados para obtener más información.


Vista de tabla: menú de la cinta

El menú de la cinta se encuentra encima de la cuadrícula de vista de tabla. Sus contenidos e iconos activos pueden cambiar en función de las celdas, filas o columnas que se seleccionen en la cuadrícula. El menú está dividido en varios grupos.

  • Vista de tabla: utilice el botón Agregar configuración para agregar o copiar configuraciones de lectura al dispositivo seleccionado. El botón Eliminar configuración elimina la/s configuración/es de lectura seleccionada/s. El botón Cambiar orden permite que el dispositivo alterne entre distintos órdenes de las configuraciones de lectura.

  • Edición: utilice Copiar (o Ctrl+C en el teclado) para copiar un valor de la celda seleccionada en ese instante. Pegar solo puede utilizarse en la misma fila o en cualquier editor de texto. Restablecer valores permite restablecer los valores de la/s celda/s seleccionada/s.

  • Resaltado: los botones y configuraciones de este grupo de menú ofrecen opciones para resaltar el fondo de celdas específicas. Con la configuración Valores no predeterminados se resaltan las celdas que tengan valores no predeterminados (puede variar en una misma fila para diferentes dispositivos o configuraciones de lectura). La configuración Distinto de referencia resalta las celdas que tengan valores diferentes a los de la celda de la misma fila en la configuración de lectura (y el dispositivo) de referencia. Si se selecciona la tercera configuración, se resaltarán todos los valores y títulos que contengan el texto especificado en el cuadro de texto. Además, el texto contenido se resaltará con un fondo de texto diferente. Al pulsar Entrar, también se aplica la función del botón Mostrar solo filas resaltadas.

    Al activar Mostrar solo filas resaltadas, se contraerán todos los nodos que no tengan ningún subnodo resaltado. Si se activa Establecer configuración de lectura de referencia, especifica la configuración de lectura (y el dispositivo) que se utilizará como referencia cuando se utilice el modo de resaltado Distinto de referencia. Si el botón está activo, la columna de la celda seleccionada en ese instante (configuración de lectura) pasa a ser la configuración de referencia. La configuración de referencia actual se marca en la fila de título del nombre de configuración.

  • Filtrado: Configuración global, la configuración predeterminada, solo muestra configuraciones que no tengan valores distintos en diferentes configuraciones de lectura. Establezca Parámetros de configuración de lectura para ver únicamente las configuraciones dependientes de la configuración de lectura. Establezca Todas las configuraciones para ver todas las configuraciones al mismo tiempo. Si una entrada tiene valores en más configuraciones de lectura, estos se mostrarán en diferentes columnas.

  • Otros: utilice Expandir todas las filas para expandir todas las filas que se hayan contraído en la cuadrícula. Utilice Contraer todas las filas para contraer todas las filas expandidas de la cuadrícula. Restablecer diseño vuelve a calcular los anchos de columna para utilizar todo el espacio disponible. Si el espacio disponible no es suficiente, se aplica un ancho de columna mínimo.


Información legal


Copyright

Cognex Corporation no asume ninguna responsabilidad por el uso o fiabilidad de su software en equipos no suministrados por Cognex Corporation. Cognex Corporation no otorga ningún tipo de garantía, expresa ni implícita, relacionada con el software descrito, su comerciabilidad o idoneidad para un fin determinado.

La información contenida en este documento está sujeta a cambios sin previo aviso y no debe interpretarse como un compromiso por parte de Cognex Corporation. Cognex Corporation no se responsabiliza de ningún error que pueda haber en este documento o en el software asociado.

Copyright © 2019 Cognex Corporation. Todos los derechos reservados

Este documento no se puede copiar, ni parcial ni íntegramente, ni transferir a otro medio o idioma sin el permiso por escrito de Cognex Corporation.

El hardware y las partes del software descritos en este documento pueden estar sujetos a una o más de las patentes estadounidenses enumeradas en la página web de Cognex http://www.cognex.com/patents.asp. Otras patentes estadounidenses y extranjeras están en trámite.


Software bajo licencia

SpiderMonkey

Este software está sujeto a los términos de la Licencia pública de Mozilla, v. 2.0. Puede obtener una copia de esta licencia en http://mozilla.org/MPL/2.0/.

Si desea obtener una copia del código fuente de SpiderMonkey, póngase en contacto con el equipo de asistencia técnica de Cognex en <spidermonkey@cognex.com>.

Licencia de PCRE

PCRE es una biblioteca de funciones compatible con expresiones regulares cuya sintaxis y semántica son prácticamente idénticas a las del lenguaje Perl 5.

La versión 5 de PCRE se distribuye de acuerdo con las condiciones de la licencia «BSD», del modo especificado a continuación. La documentación de PCRE, contenida en el directorio «doc», se distribuye bajo las mismas condiciones que el software.

Autor: Philip Hazel <ph10@cam.ac.uk>

Servicio Informático de la Universidad de Cambridge, Cambridge, Inglaterra. Teléfono: +44 1223 334714.

Copyright (c) 1997-2004 Universidad de Cambridge. Todos los derechos reservados.

Se permite el uso y la redistribución en formato binario/código fuente, con o sin modificación, siempre que se cumplan las condiciones siguientes:

  • Las redistribuciones del código fuente deben indicar el aviso de copyright anterior, esta lista de condiciones y los siguientes descargos de responsabilidad.
  • Las redistribuciones en formato binario deben reproducir el aviso de copyright anterior, esta lista de condiciones y los descargos de responsabilidad presentes en el documento y/o los materiales suministrados con la distribución.
  • No se puede utilizar el nombre de la Universidad de Cambridge ni el nombre de sus colaboradores para secundar o promover productos derivados de este software sin el permiso previo por escrito correspondiente.

ESTE SOFTWARE SE SUMINISTRA POR PARTE DE LOS COLABORADORES Y LOS TITULARES DE COPYRIGHT «TAL COMO ESTÁ» Y SE DECLINA TODA GARANTÍA EXPRESA O IMPLÍCITA, INCLUIDA A MODO ENUNCIATIVO PERO NO LIMITATIVO, CUALQUIER GARANTÍA IMPLÍCITA DE COMERCIABILIDAD E IDONEIDAD PARA UN FIN DETERMINADO. BAJO NINGUNA CIRCUNSTANCIA EL TITULAR DEL COPYRIGHT NI LOS COLABORADORES SERÁN RESPONSABLES DE NINGÚN DAÑO DIRECTO, INDIRECTO, INCIDENTAL, EMERGENTE, EJEMPLAR NI CONSECUENCIAL (INCLUIDO A MODO ENUNCIATIVO PERO NO LIMITATIVO, LA ADQUISICIÓN DE MERCANCÍAS O SERVICIOS SUSTITUTORIOS, LA PÉRDIDA DE USO, DATOS O BENEFICIOS, O LA INTERRUPCIÓN DEL NEGOCIO) AL MARGEN DE LA FORMA O ACCIÓN, BIEN SEA POR CONTRATO, AGRAVIO (INCLUIDA LA NEGLIGENCIA), RESPONSABILIDAD ESTRICTA DEL PRODUCTO U OTRO CASO, INCLUSO SI HUBIESEN SIDO ADVERTIDOS DE LA POSIBILIDAD DE DICHOS DAÑOS.

Fin

Software de JPEG

Este software se fundamenta en parte en el trabajo del grupo independiente JPEG.

Biblioteca de compresión zlib

Este software se fundamenta en parte en el trabajo de Jean-loup Gailly y Mark Adler.

Parsifal XML Parser

Copyright (c) 2002-2005 Toni Uusitalo. Fecha en la que pasó a ser de dominio público: 15/11/2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

El uso comercial y no comercial de Parsifal, así como su redistribución, son gratuitos siempre que no se modifiquen el copyright y los descargos de responsabilidad del autor. Puede modificar Parsifal para su propio uso y redistribuirlo con sus modificaciones, siempre y cuando las modificaciones estén claramente documentadas.

DESCARGO DE RESPONSABILIDAD

Este programa se distribuye esperando que sea útil, pero SIN NINGUNA GARANTÍA; ni siquiera la garantía implícita de comerciabilidad o idoneidad para un fin determinado. Utilícelo BAJO SU PROPIA RESPONSABILIDAD.


Información de la patente

Este producto se encuentra cubierto por una o más de las patentes de los EE.UU., aplicaciones de los EE.UU y/o patentes extranjeras http://www.cognex.com/patents listará cualquier patente emitida subsiguientemente que resulte relevante

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, y EP1687752