DataMan 8600 : Fragen und Antworten


Begrüßungsbildschirm


Willkommen

Zur schnellen Konfiguration Ihres Geräts empfehlen wir, die Anwendungsschritte durchzuarbeiten, die über den großen Schaltflächen im linken Bereich dargestellt sind. Jeder Abschnitt weist eine Registerkarte Einfach oder Erweitert mit Konfigurationsoptionen auf. Mit der Aktionsschaltfläche Einstellungen speichern können Sie mit einem einzelnen Klick die Konfigurationsdaten im Lesegerät und eine Sicherungskopie auf Ihrem PC speichern. Mit den nachfolgenden Fragen und Antworten werden die Konfigurationsoptionen zu jedem Anwendungsschritt beschrieben, die nicht selbsterklärend sind.


Was kann ich unter Anwendungstyp einstellen?

Mit einem Klick auf den Pfeil rechts können Sie den jeweils geeigneten Lesemodus aus dem Dropdown-Menü auswählen.


Was kann ich im Schritt Bild optimieren tun?

Hier können Sie ein angeschlossenes Gerät konfigurieren, tunen und testen. Ferner lassen sich hier die Beleuchtungseinstellungen für das Gerät festlegen.


Was kann ich unter Code-Details auswählen?

Hier können Sie die Symbologien (Barcodetypen), die das DataMan-Lesegerät lesen soll, sowie verschiedene Multicode-Szenarien auswählen. In diesem Menü können außerdem die erweiterten Decodiereinstellungen vorgenommen werden.


Was kann ich im Schritt Anwendungsdetails einstellen?

Hier können Sie Auslöser- und Belichtungseinstellungen festlegen. Als Hilfe stehen Ihnen ein Auslöserassistent, ein Intervallassistent und ein Belichtungsassistent zur Verfügung, mit denen Sie die betreffenden Einstellungen komfortabel vornehmen können.

Auf der Registerkarte Erweitert können in der Tabellenansicht weitere Einstellungen vorgenommen werden.


Was kann ich unter Daten formatieren konfigurieren?

Zum Definieren der gewünschten Datenausgabe des Geräts können Sie mit einfacher Formatierung oder regulären Ausdrücken im Perl-Format eine benutzerdefinierte Ausgabezeichenkette zusammenstellen. Dabei können Sie vordefinierte Bausteine verwenden oder über das JavaScript-Modul ein flexibles Datenformatierungsskript erstellen.


Was kann ich im Schritt Eingänge/Ausgänge einstellen?

In diesem Fenster können das Verhalten der Tasten, Eingangs- und Ausgangsleitungen festgelegt werden. Auch die Details für einen Impulscodierer und die Länge des Signaltonimpulses können hier festgelegt werden. Dieses Fenster weist auch einen Link zu den Bildpuffereinstellungen auf, um Bilder an einen FTP-Server zu senden.


Was kann ich im Anwendungsschritt Kommunikation einstellen?

Auf den drei Registerkarten des Anwendungsschritts Kommunikation können Einstellungen für serielle und Ethernet-Übertragung festgelegt werden. Klicken Sie auf die entsprechende Registerkarte, um die gewünschten Einstellungswerte einzugeben.


Was bewirkt Einstellungen speichern?

Einstellungen speichern ist eher eine Aktion als ein Schritt, aber es ist wichtig, diese Aktion durchzuführen. Mit ihr wird die aktuelle Konfiguration dauerhaft im Speicher des Lesegeräts gespeichert, sodass die betreffenden Einstellungen nach einem Neustart erneut geladen werden. Mit dem DataMan Setup Tool wird außerdem eine Sicherungsdatei lokal im standardmäßigen Sicherungsordner auf dem aktuellen PC gespeichert.


Wozu dient die Konfigurationssicherungsdatei?

Die Konfigurationssicherungsdatei enthält die gesamte Konfiguration des Gerätes mit allen Parametern. Sie kann zum Wiederherstellen der Einstellungen in einen bekannten Zustand oder Konfigurieren neuer Geräte durch Auswahl der Konfigurationsparameter mit oder ohne Sicherungseigenschaften verwendet werden.


Verbindung zum Lesegerät


Wie wird das Lesegerät mit dem Setup Tool verbunden?

Führen Sie, unabhängig vom verwendeten Lesegerät, die folgenden Schritte aus, um das DataMan-Lesegerät mit dem Setup Tool zu verbinden:

  1. Drucken Sie ein Exemplar des Dokumentes Konfigurationscodes für das Lesegerät für das von Ihnen verwendete Lesegerät aus. Sie können darauf über das Windows-Menü Start oder das Setup Tool-Menü Hilfe zugreifen.

  2. Schließen Sie die erforderlichen Kabel an, um das Lesegerät mit dem PC zu verbinden, auf dem das Setup Tool ausgeführt wird. Detailinformationen finden Sie im gedruckten Exemplar der Kurzanleitung.

  3. Klicken Sie im Setup Tool auf Aktualisieren.

  4. Wählen Sie den COM-Anschluss bzw. das Netzwerkgerät aus, für den bzw. das eine Verbindung zu Ihrem Lesegerät angezeigt wird.

  5. Klicken Sie auf Verbinden.


Warum kann das Setup Tool keine Verbindung mit dem Lesegerät herstellen?

Wenn keine Verbindung möglich ist, sollten Sie die folgenden Punkte überprüfen:

  • Vergewissern Sie sich, dass Sie den Konfigurationscode (USB-COM bzw. RS-232 seriell) gescannt haben, der dem physikalischen Verbindungstyp entspricht (gilt nicht für nur Ethernet-kompatible Lesegeräte).

  • Stellen Sie sicher, dass die auf Ihrem Computer installierte Firewall- oder Antivirusanwendung die Kommunikation mit Ethernet-Geräten über die entsprechenden Ports (Cognamer: 1069 und Setup Tool: 44444) zulässt.

  • Vergewissern Sie sich, dass in der Liste COM-Anschlüsse ein Anschluss angezeigt wird, mit dem Ihr Lesegerät verbunden ist.

    DataMan-Serien 60, 300, 370, Serie 470, Serien 503, 8000: Vergewissern Sie sich, dass das Lesegerät in der Liste Netzwerkgeräte angezeigt wird, wenn es mit dem Ethernet-Netzwerk verbunden ist.

    Klicken Sie auf Aktualisieren, um festzustellen, an welchen Anschlüssen Lesegeräte angeschlossen sind.

    Hinweis: Beim Klicken auf Aktualisieren wird eine Abfrage an alle COM-Anschlüsse und das Subnetz des Ethernet-Netzwerks gesendet. Damit die Abfrage beantwortet werden kann, muss der kabellose DataMan 8000 eingeschaltet sein. Drücken Sie auf den Auslöser, um das Lesegerät einzuschalten.

  • Es darf weder eine Tastatur oder Tastaturweiche noch eine HID-Verbindung verwendet werden: Sie müssen eines der Netzwerke USB seriell, RS-232 seriell, Ethernet oder Kabellos verwenden, um das Setup Tool mit dem Lesegerät zu verbinden.

  • DataMan-Serien 60, 300, 370, Serie 470, Serien 503, 8000: Vergewissern Sie sich, dass bei der Option Gerät hinzufügen die richtige IP-Adresse angegeben ist.

  • Nur kabellose Lesegeräte DataMan 8000: Vergewissern Sie sich, dass sich das Lesegerät nicht im Ruhemodus befindet (drücken Sie auf den Auslöser, um das Gerät zu aktivieren).

  • Nur kabellose Lesegeräte DataMan 8000: Vergewissern Sie sich, dass zwischen Ihrem Lesegerät und der am PC angeschlossenen Basisstation eine Verbindung besteht. Um sicherzugehen, scannen Sie den Konfigurationscode Verbindung zur Basisstation trennen in der Kurzanleitung, ziehen Netz- und Verbindungskabel von der Basisstation ab, schließen die Kabel wieder an und legen das mobile Lesegerät dann wieder auf die Basisstation. Warten Sie, bis das mobile Lesegerät (mit einem akustischen Signal) eine Verbindung anzeigt, bevor Sie erneut versuchen, eine Verbindung herzustellen.

  • Nur kabellose Lesegeräte DataMan 8000: Vergewissern Sie sich, dass die Basisstation an die Stromversorgung angeschlossen ist.

Sofern das Lesegerät über einen COM-Anschluss mit dem PC verbunden ist, können Sie mit einem Terminalemulationsprogramm wie HyperTerminal prüfen, ob das Lesegerät Daten sendet.


Warum wird oben rechts im Gerätesymbol ein überlagertes Symbol angezeigt?

Das Pfeilsymbol gibt an, dass das Gerät manuell hinzugefügt wurde. Das V-Symbol bedeutet, dass es sich um ein virtuelles Gerät handelt.


Was sind virtuelle Geräte?

Das überlagerte V-Symbol oben rechts im Gerätesymbol bedeutet, dass es sich um ein virtuelles Gerät handelt. Sie können virtuelle Geräte unter Reparatur und Support aus einer eigenen Konfigurationsdatei oder aus einem Gerät mit Standardkonfiguration erstellen. Mithilfe virtueller Geräte können Sie Fenster im Setup Tool anzeigen, ohne eine Verbindung mit einem physischen Gerät herstellen zu müssen.

Das erstellte virtuelle Gerät ist für andere Geräte im Netzwerk nicht sichtbar. Das virtuelle Gerät bleibt über mehrere Instanzen des Setup Tools erhalten.

Das erstellte virtuelle Gerät wird genauso wie ein physisches Gerät verbunden, mit der Ausnahme, dass alle Konfigurationsänderungen abgelehnt werden (alle Einstellungen sind schreibgeschützt) und mit virtuellen Geräten keine Funktionen oder Aktionen möglich sind.


Welchen Anschluss wird für USB-Verbindungen verwendet?

Wenn Sie das Lesegerät oder die Basisstation an den USB-Anschluss anschließen, scannen Sie den Konfigurationscode USB-COM/RS-232 im Dokument „Konfigurationscodes für das Lesegerät“. Klicken Sie dann auf Aktualisieren und wählen den Anschluss aus, an dem das Lesegerät erkannt wurde.

Hinweis: Beim Klicken auf Aktualisieren wird eine Abfrage an alle COM-Anschlüsse und das Subnetz des Ethernet-Netzwerks gesendet. Damit die Abfrage beantwortet werden kann, muss der kabellose DataMan 7550 oder 8000 eingeschaltet sein. Drücken Sie auf den Auslöser, um das Lesegerät einzuschalten.


Zum Lesegerät bzw. zur Basisstation kann noch immer keine Verbindung hergestellt werden: Können die Einstellungen zurückgesetzt werden?

Basisstation DataMan 8000:

Um die Basisstation auf die Werkseinstellungen zurückzusetzen, scannen Sie den Befehl Basisstation auf Werkseinstellungen zurücksetzen (Basisstation DM8000). Beachten Sie bitte, dass dabei das kabellose Lesegerät der Basisstation zugewiesen sein muss.

Lesegeräte DataMan 503 und 8000:

Um einen Warmstart vorzunehmen, scannen Sie den Befehl Scanner neu starten auf der Rückseite der Kurzanleitung. Der permanente Speicher des Lesegerätes wird nicht gelöscht, sondern das Lesegerät wird heruntergefahren und erneut gestartet.

Wenn die Aktion fehlschlägt, scannen Sie den Befehl Scanner auf Werkseinstellungen zurücksetzen, um das Lesegerät auf die Werkseinstellungen zurückzusetzen.

Wenn die Aktion bei einem kabelgebundenen Lesegerät fehlschlägt, trennen Sie das Lesegerät von der Stromversorgung (dieses Verfahren kann nicht beim DataMan 9500 angewendet werden). Drücken Sie den Auslöser und schließen Sie das Gerät mit gedrücktem Auslöser wieder an die Stromversorgung an. Halten Sie den Auslöser mindestens 6 Sekunden lang gedrückt, bis Sie einen zweifachen Signalton hören. Die Kontrollleuchten am Lesegerät blinken in verschiedenen Farben.

Wenn die Aktion bei einem kabellosen DataMan 8000-Lesegerät fehlschlägt, nehmen Sie die Batterie aus dem Lesegerät und legen es auf die Basisstation. Drücken Sie den Auslöser und schließen Sie das Gerät mit gedrücktem Auslöser wieder an die Stromversorgung an. Halten Sie den Auslöser mindestens 6 Sekunden lang gedrückt, bis Sie einen zweifachen Signalton hören. Die Kontrollleuchten am Lesegerät blinken in verschiedenen Farben.

Lesegeräte DataMan 50, 60 und 70:

Drucken Sie ein Exemplar des Dokumentes Konfigurationscodes für das von Ihnen verwendete Lesegerät aus. Sie können darauf über das Windows-Menü Start oder das Setup Tool-Menü Hilfe zugreifen.

Scannen Sie den Code Scanner neu starten, um einen Warmstart durchzuführen. Der permanente Speicher des Lesegerätes wird nicht gelöscht, sondern das Lesegerät wird heruntergefahren und erneut gestartet.

Wenn Sie auch jetzt keine Verbindung mit dem Lesegerät herstellen können, scannen Sie den Code Scanner auf Werkseinstellungen zurücksetzen, um das Lesegerät auf die Werkseinstellungen zurückzusetzen.

Falls das Problem dadurch nicht gelöst wird, trennen Sie das Lesegerät von der Stromversorgung (je nach Anschluss Gleichstrom oder USB). Drücken Sie den Auslöser und schließen Sie das Gerät mit gedrücktem Auslöser wieder an die Stromversorgung an. Halten Sie den Auslöser mindestens 6 Sekunden gedrückt, bis Sie einen zweifachen Signalton hören. Die Kontrollleuchten am Lesegerät blinken in verschiedenen Farben.


Wie können Geräte erkannt werden?

Lesegeräte DataMan 260, 300, 473, 500, 503 und 8000:

Klicken Sie in der Baumstruktur mit den Geräten unter „Verbindung zum Lesegerät“ mit der rechten Maustaste auf ein Lesegerät und anschließend auf „Identifizieren“. Die Statusanzeige auf dem Lesegerät sendet ein Signal aus, wodurch Sie es identifizieren können.


Warum werden einige Geräte grün markiert?

Neu erkannte Geräte werden einige Sekunden lang grün markiert, um Sie darauf aufmerksam zu machen, dass ein neues Gerät in die Baumstruktur aufgenommen wurde.


DataMan-Serien 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 und DataMan 8000-Basisstation: Warum wird bei einem Verbindungsversuch vom Setup Tool ein Kennwort gefordert?

Das Lesegerät und die Basisstation können so konfiguriert werden, dass vor dem Verbinden mit dem Setup Tool ein Kennwort eingegeben werden muss. Das Kennwort wird im Fenster Kommunikationseinstellungen unter Netzwerkeinstellungen über die Registerkarte Authentifizierung aktiviert. Beachten Sie, dass das Kennwort auch für serielle Verbindungen verwendet wird.


DataMan 60, 300, 370, 470, 503, Serie 8000 und DataMan 8000-Basisstation: Kann das Lesegerät per Ethernet direkt an einen PC angeschlossen werden?

Das Lesegerät bzw. die Basisstation kann über einen Ethernet-Anschluss (RJ-45) am PC direkt angeschlossen werden. Wenn Ihr Gerät für DHCP konfiguriert ist, wird es nach ca. 20 Sekunden in der Liste Netzwerkgeräte angezeigt. Berücksichtigen Sie jedoch, dass der PC möglicherweise eine weitere Minute braucht, um die IP-Adresse aufzulösen. Sie können keine Verbindung mit Ihrem Gerät über das Setup Tool herstellen, solange dieser Vorgang nicht beendet ist.

Wenn für Ihr Gerät eine statische IP-Adresse festgelegt wurde, wird es nur dann angezeigt, wenn das Gerät und der PC dasselbe Subnetz verwenden.


DataMan-Serien 60, 300, 370, 470, 503, 8000, MX-1000 und DataMan 8000-Basisstation: Können die einzelnen Elemente in der Liste Netzwerkgeräte einem bestimmten Lesegerät zugeordnet werden?

Standardmäßig werden alle DataMan Geräte in der Liste Netzwerkgeräte mit dem Präfix „DM“ und den sechs letzten Ziffern der gerätespezifischen MAC-Adresse angezeigt, die auf das Gerät aufgedruckt ist.


DataMan-Serien 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 und DataMan 8000-Basisstation: Wie verfährt man, wenn ein Lesegerät bzw. eine Basisstation nicht in der Liste der Netzwerkgeräte angezeigt wird?

Wenn das gewünschte Lesegerät oder die gewünschte Basisstation nicht aufgeführt sind, können sie durch Aus- und erneutes Einschalten hinzugefügt werden. Es kann bis zu 60 Sekunden dauern, bis das Gerät nach dem Einschalten angezeigt werden.

Wenn sich das Problem durch Aus- und erneutes Einschalten nicht beheben lässt, kann vom Setup Tool möglicherweise wegen der Netzwerkkonfiguration keine Verbindung mit Ihrem Gerät hergestellt werden und es wird nicht in der Liste der Netzwerkgeräte angezeigt.

Überprüfen Sie die Ethernet-Verbindung mit dem Lesegerät bzw. der Basisstation und klicken im Setup Tool auf Aktualisieren.

Verwenden Sie die Option Gerät hinzufügen, wenn Sie die IP-Adresse des Lesegerätes bzw. der Basisstation kennen.

Mit diesem Verfahren wird das DataMan-Lesegerät bzw. die DataMan-Basisstation danach in der Liste der Netzwerkgeräte angezeigt und Sie können über den Ethernet-Anschluss eine Verbindung mit dem Setup Tool herstellen.


Kabelloses DataMan-Lesegerät 8000: Wie kann ein kabelloses Lesegerät einer anderen Basisstation zugewiesen werden?

Wenn der Basisstation, der Sie das kabellose Lesegerät zuweisen möchten, schon ein anderes kabelloses Lesegerät zugewiesen ist, müssen Sie diese Verbindung trennen. Scannen Sie dazu den Code Zuweisung Lesegerät/Basisstation aufheben. Um das kabellose Lesegerät einer neuen Basisstation zuzuweisen, legen Sie das neue Lesegerät einfach auf die Basisstation. Die Geräte erkennen sich automatisch.


DataMan 8000-Basisstation: Wie kann die USB-Verbindung zur Basisstation zurückgesetzt werden?

Wenn Schwierigkeiten beim Herstellen oder Aufrechterhalten der USB-Verbindung zwischen Basisstation und PC bestehen, führen Sie zum Zurücksetzen der USB-Verbindung die folgenden Schritte aus:

  1. Ziehen Sie USB-Kabel und Netzkabel von der Basisstation ab.

  2. Schließen Sie USB-Kabel und Netzkabel wieder an die Basisstation an.

  3. Legen Sie das Lesegerät auf die Basisstation.

  4. Nehmen Sie das Lesegerät von der Basisstation und scannen den Konfigurationscode USB-COM/RS_232.


Welche Funktion bietet die Schaltfläche „Konfigurationsvergleich“?

Die Schaltfläche Konfiguration vergleichen startet die Konfigurationsvergleichsfunktion des Setup Tools. Es handelt sich um eine Tabellenansicht, mit der Sie Gerätekonfigurationen festlegen, kopieren, vergleichen und wiederherstellen können. Die Funktion wird auf einer neuen Dokumentenseite geöffnet.

Wurden vor Verwendung der Schaltfläche keine Geräte aus der Geräteliste ausgewählt, wird ein leeres Dokument geöffnet. Sind eines oder mehrere Geräte ausgewählt, wird das Vergleichsdokument mit den Einstellungen dieser Geräte geöffnet.


Worum handelt es sich bei RTM Lean oder dem RTM-Gerät/Echtzeitüberwachungsgerät, das im Netzwerk angezeigt wird?

Real Time Monitoring (RTM) Lean ist in das DataMan Setup Tool integriert, und das Echtzeitüberwachungsgerät ist eine hardwarebasierte Softwareanwendung, auf die Sie über das DataMan Setup Tool zugreifen können und mit der Sie verschiedene Arten von Daten zu den Geräten im Netzwerk und ihren Lesungen abrufen und analysieren können. Die Verbindung mit RTM Lean bzw. dem Echtzeitüberwachungsgerät wird wie bei einem Gerät hergestellt. Der Datenabruf wird dann in einem neu geöffneten Dokument konfiguriert. RTM Lean bzw. das Echtzeitüberwachungsgerät ruft Daten nur dann aktiv ab, wenn es aktiviert und verbunden ist.

Bei der Ersteinrichtung wählen Sie zunächst das Gerät aus, das von RTM Lean bzw. dem Echtzeitüberwachungsgerät überwacht werden soll, und dann die Art der Daten (über die Standardeinstellung hinaus), die abgerufen werden sollen. Diese Einstellungen können Sie im Menübandmenü unter Konfiguration ändern. Standardmäßig erfasst RTM Lean bzw. das Echtzeitüberwachungsgerät statistische Daten (Leserate, Auslösungen, Auslöserüberlauf, Pufferüberlauf und Prozesssteuerungsmetriken, sofern dies auf dem Gerät aktiviert ist).

HINWEIS: RTM Lean kann immer nur von einem Gerät Daten abrufen und diese 48 Stunden lang speichern. In der Vollversion der Echtzeitüberwachung bestehen keine derartigen Beschränkungen.


Bild optimieren


Was kann ich im Schritt Bild optimieren tun?

Hier können Sie ein angeschlossenes Gerät konfigurieren, tunen und testen.

Für die schnelle Konfiguration Ihres Geräts wird empfohlen, die Anwendungsschritte durchzuarbeiten, die über die großen Schaltflächen im mittleren Bereich dargestellt sind. Hier stehen Ihnen unter Einfach und Erweitert jeweils Konfigurationsoptionen zur Verfügung. Mit der Aktionsschaltfläche Einstellungen speichern können Sie alle Konfigurationsdaten komfortabel speichern. Mit den nachfolgenden Fragen und Antworten werden die Konfigurationsoptionen zu jedem Anwendungsschritt beschrieben, die nicht selbsterklärend sind.


Wie wird ein erfasstes Bild in einer Datei gespeichert?

Klicken Sie in der Symbolleiste des Bildfensters oder der Bildanzeige auf Bild speichern.

Alternativ können Sie das Bild auch per Drag-and-drop auf Ihren PC ablegen. Klicken Sie das Bild im Fenster „Bildanzeige“ an, ziehen es aus dem Setup Tool heraus und lassen es anschließend los.

HINWEIS: Wenn Sie ein nicht aktuelles Bild (aus dem Leseergebnisverlauf) per Drag-and-drop speichern möchten, wird dieses mit den Einstellungen für die Bildanzeige gespeichert. Standardmäßig ist es von geringerer Qualität. Unter Einstellungen für die Bildanzeige können Sie das Bild auf Vollgröße und das Format in Bitmap ändern.


Wie wird die Schaltfläche Live verwendet?

Klicken Sie auf der Registerkarte Einfach auf die Schaltfläche Live, um den Live-Modus aufzurufen. Der Live-Modus überwacht nicht nur die Lesevorgänge des Geräts, sondern decodiert auch. Klicken Sie ganz rechts auf die Schaltfläche, um weitere Optionen anzuzeigen.

Wählen Sie Decodierung aus, wenn das Gerät aufgenommene Bilder decodieren soll. Bei Auswahl von Fokusrückmeldung wird rechts von der Bildanzeige eine farbcodierte Messanzeige eingeblendet. Die Messanzeige entspricht dem Fokus des Objektivs (niedriger = weniger fokussiert).

Wählen Sie die Option Automatische Belichtung aus, damit das Lesegerät automatisch die optimalen Belichtungseinstellungen für das Bild auswählt. Der Schieberegler (unter dem Bildanzeigebereich) gibt die Pixelhelligkeit des Ziels an.

Auf der Registerkarte „Erweitert“ ist eine Tabellenansicht der Bildeinstellungen zu sehen.


Wozu dient das Fenster „Leseleistung“?

Mithilfe der Diagramme im Fenster Leseleistung rechts können Sie die Decodierzeiten und Leseraten in Echtzeit überwachen. Klicken Sie auf die Schaltfläche Löschen, um das Diagramm zurückzusetzen.


Welche Beleuchtungs-Setups können geändert werden?

Sie können festlegen, welcher UltraLight-Quadrant eingeschaltet wird. Sie können aber auch die werkseitig konfigurierten Beleuchtungs-Setups verwenden und im Fenster Beleuchtungs- und Kameraeinstellungen weitere Kamerakonfigurationen vornehmen.


Welche Auslösereinstellungen können geändert werden?

Für den Auslösertyp stehen Ihnen „Manuell“ (Taste) oder „Präsentation“ (intern) zur Verfügung. Weitere Auslösereinstellungen finden Sie im Fenster Beleuchtungs- und Kameraeinstellungen. Klicken Sie auf das entsprechende Menübandelement und wählen Sie die Registerkarte „Einstellungen Auslöser“ aus.

Hinweis: Wenn der Bediener den Auslöser im Präsentationsmodus betätigt, wechselt das Lesegerät in den Modus Manuell, bis das Gerät wieder auf der Basisstation abgelegt wird.

Weitere Informationen finden Sie unter den Fragen und Antworten für Anwendungsdetails.


Wie wird der Fokuswert beim DataMan 8600 festgelegt?

Mit dem Fokuswert wird der Fokus auf einen Abstand von 0 bis 500 Millimetern festgelegt.

Wenn Sie die Fokusschritte im Fenster Fokuseinstellungen (unter Beleuchtungs- und Kameraeinstellungen) ändern, stehen Ihnen im Fenster „Schnellkonfiguration“ zwei Balken zur Verfügung. Damit können Sie den unteren und oberen Fokuswert festlegen.


Wie wird der Belichtungswert beim DataMan 8600 geändert?

Bei Verwendung der manuellen Belichtung (Einschalten im Fenster Beleuchtungs- und Kameraeinstellungen möglich) ist diese Einstellung bereits aktiviert.


Wie lässt sich die gesamte Beleuchtung des Lesegeräts schnell ein- und ausschalten?

Klicken Sie mit der rechten Maustaste auf das Symbol mit den Beleuchtungsquadranten. Dort stehen folgende Auswahlmöglichkeiten zur Verfügung:

  • Alle an

  • Alle aus

  • Nord-Süd

  • Ost-West

Die Änderungen werden sofort entsprechend Ihrer Auswahl wirksam.


Wozu dienen die Einstellungen für die Bildanzeige?

Über die Einstellungen für die Bildanzeige können Sie steuern, wie erfasste Bilder nach der Auslösung von Lesevorgängen oder mit einem Lesegerät erfasste Live-Bilder angezeigt werden. Änderungen dieser Einstellungen wirken sich nicht auf die Leistung des Lesegeräts, sondern nur auf die Bildqualität und die Übertragungsgeschwindigkeit zwischen Lesegerät und Setup Tool aus.

HINWEIS: Bestimmte Bildeigenschaften (wie Bildgröße und Filterung) können nicht geändert werden, während das Gerät Bilder erfasst oder decodiert.

HINWEIS: Einstellungen für die Bildanzeige wirken sich nicht beim Speichern des letzten Bildes aus, das über das Bildfenster (durch Ziehen und Ablegen) erfasst wurde. Das letzte Bild wird immer in voller Größe gespeichert (maximale Auflösung des Geräts).

  • Größe: Standardmäßig zeigt das Setup Tool ein Viertel der Pixel jedes erfassten Bildes bzw. bei Live-Anzeige ein Teil jedes Bildes. Je nach ausgewählter Bildgröße kann das Lesegerät für jedes Bild ein Sub-Sampling vornehmen, das die Bildübertragung vom Lesegerät zum Setup Tool unter Verlust feiner Bilddetails erheblich beschleunigt.

  • Qualität: Diese Option ist nur bei Verwendung des JPEG-Bildformats verfügbar. Mit diesem Schieberegler können Sie interne Parameter so anpassen, dass das Lesegerät erfasste Bilder glättet. Die Übertragungsgeschwindigkeit vom Lesegerät zum Setup Tool kann dadurch erhöht oder verringert werden.


Wo finde ich ausführlichere Informationen zur Verwendung von UltraLight?

Eine vollständige Übersicht über die Funktionen von UltraLight erhalten Sie im UltraLight-Lernvideo unter <a>http://www.cognex.com/</a>.


Wie wird innerhalb der erfassten Bilder ein Zielbereich angegeben?

Die Änderung Ihrer Einstellungen können Sie im Fenster Bildgröße (Zielbereich) vornehmen.


Was ist die Laserintensität?

In diesem Drop-down-Feld können Sie auswählen, ob Sie das Lesegerät mit einem Laser der Klasse 2 oder mit einem reduzierten Typ (1M-Laser) verwenden möchten, der unter allen normalen Einsatzbedingungen sicher ist.


Was ist UltraLight?

Das UltraLight-System verfügt über zwei unabhängig steuerbare Beleuchtungsquellen:

  • Vier einzeln steuerbare Quadranten mit nicht axial angeordneten Flachwinkel-LEDs, die eine Dunkelfeldbeleuchtung erzielen und die Aufnahme geritzter oder geätzter Markierungen auf reflektierenden Oberflächen unterstützen.

  • Eine einzelne, axial angeordnete diffuse Lichtquelle, die eine Hellfeldbeleuchtung erzielt und für das Lesen von Codes mit niedrigen und hohen Kontrasten auf zahlreichen Oberflächentypen geeignet ist.


Weshalb ist der obere Quadrant von UltraLight nicht eingeschaltet?

Meistens hält der Benutzer das Lesegerät in einem Winkel zur gelesenen Oberfläche. Durch Deaktivierung des oberen Beleuchtungsquadranten werden Reflexionen und blendendes Licht minimiert.

Im Lieferzustand sind bei allen vier Setups die Standardwerte eingestellt, wobei allerdings nur das erste Setup Universal aktiviert ist. Im Setup „Universal“ sind nur die Flachwinkel-LEDs West, Süd und Ost aktiviert. Sie können dieses Setup rändern und alle nichtaxialen Beleuchtungssegmente aktivieren.


Wie wird die Intensität der Beleuchtung geändert?

Um die Beleuchtungsstärke auf das gewünschte Niveau einzustellen, verschieben Sie die Schieberegler unter Intensität Lichtleiter und Intensität Hellfeld. Mit der Schaltfläche Auf Standard zurücksetzen im unteren Teil des Fensters können Sie bei Bedarf zu den Werkseinstellungen zurückkehren.


Was ist die Live-Anzeige?

Wenn Sie „Live-Anzeige aktiviert“ aktivieren (durch Klicken auf das Live-Anzeige-Symbol in der obersten Taskleiste oder auf der Registerkarte „Aktion“), zeigt die Bildansicht fortlaufend an, was das Lesegerät sieht. Bei diesem Modus können Sie überprüfen, was das Lesegerät erfasst, ohne dass Symbole decodiert werden.

Rufen Sie das Fenster Einstellungen für die Bildanzeige auf, um Größe und Qualität des Bilds der Live-Anzeige zu ändern.

HINWEIS: Diese Option ist beim DM262 und DM362 nicht verfügbar.


Wie wird die Bildübertragung beschleunigt?

Wenn das Kontrollkästchen Bild übertragen und anzeigen aktiviert ist, überträgt das Setup Tool für jeden Decodiervorgang das erfasste Bild. Wenn ein neuer Auslöserimpuls empfangen wird, während das aktuelle Bild noch übertragen wird, verwirft das Lesegerät das teilweise übertragene Bild und beginnt mit der Übertragung des neuen Bildes.

Die Bildübertragungsgeschwindigkeit hängt vom Grad der Bildkomprimierung im Lesegerät ab. Sie können den Bildkomprimierungswert einstellen, indem Sie die Option Einstellungen für die Bildanzeige auswählen. Bei Verringerung der Bildgröße oder Bildqualität erhöht sich die Übertragungsgeschwindigkeit.


„Bilder übertragen und anzeigen“ ist aktiviert. Weshalb wird mir kein Bild angezeigt?

Wenn Sie die Bildübertragung durch Anklicken des Auslösers unterbrechen, wird kein Bild übertragen. Außerdem kann es sein, dass ältere Bilder im Leseergebnisverlauf keine Bilder enthalten.

Hinweis: Wenn die Ausgabeverzögerung kürzer ist als die Zeit, die das Lesegerät benötigt, um ein Bild aufzunehmen und zu decodieren, empfängt das Setup Tool möglicherweise keine Ergebnisbilder vom Lesegerät.


Code-Details


Wie werden alle Symbologien deaktiviert?

Klicken Sie im Anwendungsschritt Code-Details im oberen Bereich der Registerkarte Einfach auf Alle Symbologien deaktivieren, oder drücken Sie die Tastenkombination Strg+D.


Wie werden erweiterte Symbologieeinstellungen angepasst?

Klicken Sie unter Code-Details auf die Registerkarte Erweitert, um weitere Einstellungen festzulegen.


Unterscheidet das Lesegerät automatisch zwischen verschiedenen Symbologietypen?

Das Lesegerät erkennt, identifiziert und decodiert automatisch alle Symbole, die im Setup Tool aktiviert sind.


Kann die Leistung des Lesegerätes durch Begrenzen der Anzahl aktivierter Symbologien erhöht werden?

Um die bestmögliche Leistung zu erzielen, sollten Sie nur Symbologietypen aktivieren, die Sie auch erwarten.


DataMatrix-Eigenschaften: Was bedeutet „Schwierigkeitsgrad Symbol“?

Mit „Schwierigkeitsgrad Symbol“ wird festgelegt, wie umfassend das Lesegerät versucht, die einzelnen Bilder zu decodieren. Bei Einfach werden kontrastreiche Codes in einwandfreiem Druck decodiert und die Lesegeschwindigkeit maximiert. Bei Hoch decodiert das Lesegerät schwierig zu erfassende Direktmarkierungen, arbeitet dabei aber unter Umständen langsamer.


Welche Einstellungen können in den EAN.UCC-Composite-Eigenschaften festgelegt werden?

  • Standard (linear und 2D): Besteht aus einer linearen Komponente (Codierung der primären Kennung des Artikels) sowie einer anschließenden 2D-Composite-Komponente (Codierung ergänzender Daten wie Chargennummer oder Verfallsdatum).

  • Nur linear: Besteht nur aus der linearen Komponente, in der die primäre Kennung des Artikels codiert ist.


Wozu dient CC-C?

CC-C ist eine von drei EAN.UCC-2D-Composite-Komponenten: ein PDF417-Symbol mit Code-Wort 920 an der ersten Datenposition als Verknüpfungszeichen, das die EAN.UCC-Datenkomprimierung bezeichnet.


Worin bestehen die DataMatrix-Qualitätsmetriken?

Informationen zu den Code-Qualitätsmetriken finden Sie in der DataMan Kommunikations- und Konfigurationsanleitung.


1D-Symbologieeigenschaften: Was ist Zieldecodierung?

Bei der Zieldecodierung wird das Verhalten eines Laser-Barcode-Scanners simuliert. Anstatt das gesamte Sichtfeld zu betrachten, versucht das Lesegerät, lediglich die 1D-Barcodes zu decodieren, die unterhalb des Zielpunkts des Lasers liegen. So wird verhindert, dass ungewollt die angrenzenden 1D-Barcodes gelesen werden.


1D-Symbologieeigenschaften: Wozu dient die Option „Kurze Ruhezone“?

Die Option Kurze Ruhezone ist standardmäßig aktiviert, um bei der Suche einen gewissen Grad an Toleranz im Hinblick auf die Ruhezone der folgenden 1D-Symbole zuzulassen: Code 128, Code 39 und Code 93.


1D-Symbologieeigenschaften: Was sollte unter „Minimale Decodierung vor der Ausgabe“ eingestellt werden?

Wählen Sie eine hohe Zahl, wenn die Decodierschärfe verbessert werden soll. Wählen Sie eine niedrige Zahl, wenn Ihnen die Geschwindigkeit wichtig ist.


Vorteil der Angabe einer bestimmten Code-Größe

Die Angabe einer bestimmten Code-Größe kann die Zuverlässigkeit des Lesegeräts bei der Decodierung von Symbolen verbessern. Wenn verschiedene Code-Größen gelesen werden sollen, wählen Sie Alle aus.


Code 39-Eigenschaften

  • Bei Auswahl von Full-ASCII werden die erweiterten Code 39-Codes aktiviert.

  • Bei Auswahl von Prüfzeichen werden nur Symbole mit einem gültigen Prüfzeichen decodiert.

  • Bei Auswahl von Prüfzeichen übertragen wird das Prüfzeichen den decodierten Daten hinzugefügt.

  • Bei Aktivierung von In Code 32 umwandeln wird der Code 39-Zeichensatz in Code 32 umgewandelt.


Interleaved 2 aus 5-Eigenschaften

  • Bei Auswahl von Prüfzeichen werden nur Symbole mit gültigem Prüfzeichen decodiert.

  • Bei Auswahl von Prüfzeichen übertragen wird das Prüfzeichen den decodierten Daten hinzugefügt.


Pharmacode-Eigenschaften

Vorteil der Angabe einer Code-Größe und -Ausrichtung

Durch Angeben einer bestimmten Code-Größe und -Ausrichtung kann die Zuverlässigkeit des Lesegerätes bei der Decodierung von Symbolen verbessert werden.

Anzahl der Datenzeichen und Anzahl der Striche in einem beliebigen Symbol

Datenzeichen: Striche

  • 1: 3 Hinweis: Vom Lesegerät wird nur ein 1-Zeichen-Code mit mindestens 3 Strichen erfasst, d. h. nur 6, 7, 8 und 9.

  • 2: 3 bis 6

  • 3: 6 bis 9

  • 4: 9 bis 13

  • 5: 13 bis 16

  • 6: 16


Codabar-Eigenschaften

  • Bei Auswahl von Prüfzeichen werden nur Symbole mit gültigem Prüfzeichen decodiert.
  • Bei Auswahl von Prüfzeichen übertragen wird das Prüfzeichen den decodierten Daten hinzugefügt.
  • Bei Auswahl von Start- und Stoppzeichen übermitteln werden die Start- und Stoppzeichen den decodierten Daten hinzugefügt.


MSI-Eigenschaften

  • Bei Auswahl von Prüfzeichen werden nur Symbole mit gültigem Prüfzeichen decodiert.
  • Bei Auswahl von Prüfzeichen übertragen wird das Prüfzeichen den decodierten Daten hinzugefügt.
  • Über das Berechnungsverfahren für Prüfsumme können Sie das Verfahren zur Berechnung der Prüfsumme auswählen.


DataBar-Eigenschaften

  • GS1 DataBar Begrenzt: Codiert 14-stellige EAN.UCC-Artikelkennungen mit den Kennziffern 0 oder 1 in einem linearen Symbol zur Verwendung auf kleinen Artikeln, die nicht an der Kasse gescannt werden.

  • GS1 DataBar: Codiert die vollständige 14-stellige EAN.UCC-Artikelkennung in einem linearen Symbol, das von entsprechend programmierten Kassen-Scannern omnidirektional gelesen werden kann.

  • GS1 DataBar Erweitert: Variable Länge; erweiterte Version der Symbologie mit der Möglichkeit, die 14-stellige GTIN mit weiteren Daten zu konfigurieren, darunter Verfallsdatum, Herkunftsland und Seriennummern, bis zu 74 numerische oder 41 alphabetische Zeichen sind möglich.


Postal-Eigenschaften

  • POSTNET: Eine Barcode-Symbologie, die vom United States Postal Service für die Briefzustellungslenkung verwendet wird. Die Postleitzahl (ZIP Code oder ZIP+4 Code) wird in dieser eindeutigen Symbologie codiert, bei der Daten durch Striche unterschiedlicher Höhe dargestellt werden.

  • PLANET: Der PLANET-Barcode (Postal Alpha Numeric Encoding Technique) wird vom United States Postal Service zur Identifizierung und Verfolgung von Sendungen im Verlauf der Zustellung verwendet. Wie bei POSTNET werden die Daten durch unterschiedlich hohe Striche codiert.

HINWEIS: Postleitzahlen können nur decodiert werden, wenn sie in Gartenzaun-Lage präsentiert werden.


Unterstützte QR-Code-Versionen

QR-Code (Quick Response-Code) ist eine 2D-Symbologie, die Daten in Form eines quadratischen Feldes mit dunklen und weißen Modulen codiert. Das Lesegerät kann drei verschiedene Typen unterscheiden:

  • model-1: Originalversion

  • model-2: Erweiterte Version

  • Micro-QR-Code: QR-Code in sehr kleinem Format für Anwendungen, die kleinere Flächen und geringere Datenmengen als bei anderen QR-Code-Versionen erfordern


QR-Code-Eigenschaften: Was bedeutet „Schwierigkeitsgrad Symbol“?

Mit „Schwierigkeitsgrad Symbol“ wird festgelegt, wie umfassend das Lesegerät versucht, die einzelnen Bilder zu decodieren. Bei Einfach werden kontrastreiche Codes in einwandfreiem Druck decodiert und die Lesegeschwindigkeit maximiert. Bei Hoch decodiert das Lesegerät schwierig zu erfassende Direktmarkierungen, arbeitet dabei aber unter Umständen langsamer.


QR-Code-Eigenschaften

Maximale Rastergröße

Mit „Maximale Rastergröße“ können Sie QR-Codes decodieren, die größer als Größe 49 sind. Ziehen Sie dazu den Schieberegler oder geben Sie in das Textfeld rechts eine konkrete Codegröße ein.

QR-Code-Qualitätsmetriken

Informationen zu den Code-Qualitätsmetriken finden Sie in der DataMan Kommunikations- und Konfigurationsanleitung.


Dotcode-Eigenschaften

Angabe der Anzahl von Datenzeilen und -spalten

Wenn Sie die Mindest- und Höchstzahl der Datenzeilen und -spalten angeben, verbessern Sie die Zuverlässigkeit der Symboldecodierung durch das Lesegerät.

Einstellung „Polarität“

Sie können festlegen, was für das Gerät ein Modul (Punkt) im Verhältnis zum Hintergrund ist. Bei der Einstellung Dunkel auf hellem Grund scannt das Gerät nach dunklen Punkten auf hellem Hintergrund und decodiert diese, während sich Hell auf dunklem Grund umgekehrt verhält (helle Punkte auf einem dunklen Hintergrund).

Bei der Standardeinstellung Beliebig wird nach beiden Modulen auf dem entsprechenden Hintergrund gescannt. Die Decodierung kann dadurch jedoch verlangsamt werden.


Welche Einstellungen für die UPC-/EAN-Eigenschaften sind möglich?

  • Mit Erweitert können Sie die Decodierung erweiterter Symbole aktivieren.

  • Mit Ergänzungen können Sie steuern, wie das Lesegerät Ergänzungscodes decodiert.

  • Mit Lösche führende Nullen können Sie die führenden Nullen decodierter Zeichenketten löschen.

  • Mit EAN8-Ergänzungen zulassen können Sie die Decodierung der Ergänzungscodes auf EAN8-Symbolen aktivieren.

  • Mit UPCE1 aktiviert können Sie die Decodierung von UPC E1-Symbolen aktivieren.


UPC-/EAN-Eigenschaften: Was bedeutet das Kontrollkästchen „Erweitert“?

Dies ist ein boolescher Ausdruck mit dem angegeben wird, ob die für UPC-EAN ausgewiesene decodierte Zeichenkette auf das 13-stellige EAN13-Format erweitert oder im 6-stelligen UPC-E-Standardformat übertragen werden soll.

Bei Auswahl dieser Option (Standard) wird die decodierte Zeichenkette im 13-stelligen EAN13-Format übertragen (z. B. 0012345000065). Ist die Option nicht ausgewählt, wird das Ergebnis als <Zahlensystem> + 6 Datenstellen + <Prüfzeichen> übertragen (z. B. 01234565).


Anwendungsdetails


Was kann ich im Schritt Anwendungsdetails einstellen?

Auf der Registerkarte Einfach können Auslösereinstellungen und Belichtungseinstellungen festgelegt werden. Als Hilfe stehen Ihnen ein Auslöserassistent, ein Intervallassistent und ein Belichtungsassistent zur Verfügung, mit denen Sie die betreffenden Einstellungen komfortabel vornehmen können.

Auf der Registerkarte Erweitert können weitere Einstellungen in der Tabellenansicht vorgenommen werden.


Welche Auslösertypen gibt es?

  • Präsentation – Bei diesem Modus wird kontinuierlich nach Symbolen gesucht und erkannte Codes werden decodiert. Der Auslösermodus „Präsentation“ basiert auf einem internen Bewegungserkennungs- und Taktsystem des Lesegerätes.

    Beim Modus „Präsentation“ können verschiedene Parameter angegeben werden, z. B. ob das Lesegerät denselben Code mehrfach liest und wie lange es bis zum Scannen des nächsten Codes warten soll. Die Konfiguration des Auslösermodus „Präsentation“ erfolgt im Fenster Systemeinstellungen mithilfe der Optionen unter Decodiereinstellungen.

    Beim Modus „Präsentation“ können Sie durch Auswahl der Option Automatische Belichtung die besten Belichtungseinstellungen für die gewünschte Bildhelligkeit vom Lesegerät bestimmen lassen. Das Lesegerät verwendet jedoch zum Festlegen dieser Einstellungen die ersten Bilder, die es erfasst, und lässt dabei unter Umständen Bilder aus, die ein decodierbares Symbol enthalten. Bei Auswahl der Option Manuelle Belichtung können Sie eine exakte Belichtungseinstellung für die Kamera angeben.

    • Legen Sie das Lesegerät auf die Basisstation.
    • Aktivieren Sie im Setup Tool den Auslösermodus Manuell und wechseln Sie dann zurück in den Präsentationsmodus.
    • Scannen Sie den Lesegerätkonfigurationscode In Präsentationsmodus wechseln.

  • Manuell – Bei diesem Modus wird die Bilderfassung durch eines der folgenden Ereignisse gestartet:

    • Drücken der Taste am Lesegerät

    • Senden des DMCC-Auslösers (DataMan Control Command) bei einer bestehenden USB- oder seriellen Verbindung mit dem Lesegerät

    • Klicken auf die Schaltfläche „Auslöser“ im Setup Tool

    • Drücken von STRG+T auf der Tastatur, wenn das Setup Tool-Fenster aktiv ist.

    Das Lesegerät erfasst Bilder, solange das Auslösersignal aktiv ist. Der Lesevorgang wird gestoppt, sobald ein Symbol erkannt und decodiert wird oder das Auslösersignal endet.

=


Auslöserassistent

Bevor Sie diesen Assistenten starten, müssen Sie den Auslösertyp auswählen. Wählen Sie im Dropdown-Menü die Auslöserquelle aus: Nicht definiert, Keine oder Extern Daraufhin gibt Ihnen der Assistent eine Empfehlung für den auszuwählenden Auslösermodus. Als Entscheidungshilfe werden die Auslösermodi grafisch veranschaulicht. Wählen Sie den für Ihre Zwecke geeigneten Auslösertyp aus, und klicken Sie auf Speichern und schließen.


Intervallassistent

Bei Auswahl eines der Modi „Bildfolge“, „Automatisch“ oder „Fortlaufend“ können Sie sich bei den weiteren Einstellungen vom Intervallassistenten helfen lassen. Zur Berechnung der notwendigen Daten haben Sie die Auswahl unter drei Methoden. Wählen Sie in der oberen rechten Ecke die Einheiten (Standard oder Metrisch), in denen die Berechnung durchgeführt werden soll.

Klicken Sie auf Sichtfeld, um das längstmögliche Intervall zu berechnen. Dabei wird unter Berücksichtigung der maximalen Bahngeschwindigkeit und der Größe des längsten Codes das physische Sichtfeld gemessen.

Klicken Sie auf Objektiv/Abstand zu Code, wenn Sie den Abstand zwischen Code und Objektiv angeben möchten. Geben Sie im Dropdown-Menü die Brennweite an, und wählen Sie die Richtung aus, in die sich der Code bewegt. Hier müssen Sie außerdem die maximale Bahngeschwindigkeit und die Größe des längsten Codes angeben.

Klicken Sie auf Code-Elementgröße, um eine Berechnung mit der Größe des schmalsten Code-Elements durchzuführen. Aktivieren Sie den Testmodus, um den Code zu lesen. Hierzu müssen Sie außerdem die Richtung, in der sich der Code bewegt, die maximale Bahngeschwindigkeit und die Größe des längsten Codes angeben.

Im unteren Bereich des Assistenten wird das empfohlene Maximalintervall angezeigt.


Belichtungsassistent

Der Belichtungsassistent funktioniert auf sehr ähnliche Weise wie der Intervallassistent. Sie haben hier die Auswahl unter denselben drei Methoden für Ihre Berechnungen: Größe des Sichtfeldes, Abstand zum Code und Größe des Code-Elements.

Klicken Sie auf Sichtfeld, um die maximale Belichtungszeit zu berechnen. Dabei wird unter Berücksichtigung der maximalen Bahngeschwindigkeit das physische Sichtfeld gemessen. Sie können zum Lesen des kleinsten Codes den Testmodus aktivieren.

Klicken Sie auf Objektiv/Abstand zu Code, wenn Sie den Abstand zwischen Code und Objektiv angeben möchten. Geben Sie im Dropdown-Menü die Brennweite an, und wählen Sie die Richtung aus, in die sich der Code bewegt. Hierzu müssen Sie außerdem die maximale Bahngeschwindigkeit angeben.

Klicken Sie auf Code-Elementgröße, um eine Berechnung mit der Größe des schmalsten Code-Elements durchzuführen. Aktivieren Sie den Testmodus, um den Code zu lesen. Sie müssen außerdem die Richtung, in der sich der Code bewegt, und die maximale Bahngeschwindigkeit angeben.

Im unteren Bereich des Assistenten werden die aktuelle und die empfohlene maximale Belichtungszeit angezeigt.


Werden nach einer Gut-Lesung weitere Bilder erfasst?

Nein. Zusätzliche Bilder werden nur erfasst, wenn es in vorhergehenden Setups zu Fehllesungen kommt. Wird mit einem Setup ein gültiges Bild erfasst, versucht das Lesegerät in dem betreffenden Auslöserzyklus nicht mehr, das Bild mit weiteren Setups zu erfassen. Stattdessen wird die Decodierung gestartet. Das Lesegerät führt die Erfassungsversuche mit den einzelnen aktivierten Setups nach einer Prioritätenfolge aus. Dabei beginnt das Gerät mit dem Setup, für das die höchste Priorität angegeben ist, und arbeitet die Setupliste ab, bis eine Lesung gültig ist.


Was ist der Unterschied zwischen den Verzögerungsoptionen „Nach erster Lesung“ und „Nach letzter Lesung“?

Bei der Verzögerungsoption Nach erster Lesung beginnt die Taktung nach der ersten Lesung eines gegebenen Codes und der Zeitgeber wird nicht zurückgesetzt. Das bedeutet, dass ein Code erneut gelesen werden kann, wenn das Lesegerät in einem Modus für mehrere Bilder wie z. B. „Fortlaufend“ ausgelöst wird und sich der Code mindestens für die Dauer der Lesewiederholungsverzögerung vor dem Lesegerät befindet.

Bei Nach letzter Lesung wird der Zeitgeber jedes Mal zurückgesetzt, wenn ein gegebener Code in einem Bild enthalten ist. Das bedeutet, dass ein Code nicht erneut gelesen wird, während er sich vor dem Lesegerät befindet. Der betreffende Code wird nur erneut gelesen, wenn er mindestens für die Dauer der Lesewiederholungsverzögerung aus dem Sichtfeld des Lesegerätes entfernt wird.


Ein Code wird zweimal gelesen, wenn ich das Lesegerät neu auslöse. Woran liegt das?

Die Optionen Lesewiederholungsverzögerung und Nie zweimal denselben Code lesen wirken sich nur auf Erfassungsvorgänge in ein und demselben Auslöserzyklus aus. Wird das Lesegerät ausgelöst, löscht dies die Zeitgeber und den letzten gelesenen Code für Nie zweimal denselben Code lesen.


Was bedeutet „Nie zweimal denselben Code lesen“?

Ist die Option Nie zweimal denselben Code lesen aktiviert, wird eine gegebene Codezeichenkette in derselben Auslösersequenz nicht zweimal hintereinander ausgegeben. Die Option ist für alle Auslösermodi verfügbar, jedoch nur beim Lesen von Multicodes gültig, da dies die einzige Möglichkeit ist, in ein und derselben Auslösersequenz mehr als einen Code zu lesen. Ist Nie zweimal denselben Code lesen nicht aktiviert, wiederholt das Lesegerät nach Ablauf der angegebenen Code-Lesewiederholungsverzögerung (in Millisekunden) den Lesevorgang und überträgt erneut denselben Code.


Was sind der „Verzögerungsmodus“ und die „Code-Lesewiederholungsverzögerung“?

Mit der Option Verzögerungsmodus wird die Lesewiederholungsverzögerung für die erste oder die letzte Lesung festgelegt.

Mit der Option Code-Lesewiederholungsverzögerung (in Millisekunden) geben Sie die Verzögerung zwischen den Leseversuchen an. Wenn Sie als Verzögerung einen anderen Wert als null angeben, verhindern Sie, dass ein an Ihr Lesegerät angeschlossenes Gerät Daten aufgrund von Überlastung eventuell nicht verarbeiten kann.


Was ist die Bewegungserkennung?

Mit der Bewegungserkennung kann ein Lesegerät so eingerichtet werden, dass es nach Erkennung einer Bewegung im Sichtfeld des Gerätes für eine bestimmte Dauer in den aktiven Präsentations- oder Automatikmodus wechselt.

Die Einstellungen für die Bewegungserkennung sind nur verfügbar, wenn „Präsentation“ oder „Automatisch“ als Auslösertyp ausgewählt ist. Bei aktivierter Bewegungserkennung erfasst das Gerät keine Bilder, sondern erkennt im Hintergrund ggf. in dem im Sichtfeld liegenden Bereich erfolgende Bewegungen.

Erkennt das Gerät Bewegungen, erfasst es aktiv Bilder im Präsentations- bzw. Automatikauslösermodus. Über die Einstellung Zeitlimit können Sie die Zeitspanne (in Sekunden) angeben, nach der das Gerät von der aktiven Auslösung zurück in die Bewegungserkennung wechseln soll. Dieses Zeitlimit wird jedoch durch jede Bewegung bzw. jede Gut-Lesung zurückgesetzt.

Über Empfindlichkeit Bewegungserkennung können Sie festlegen, wie deutlich die Bewegungen sein sollen, die das Gerät erkennt, bis es in den aktiven Präsentations- oder Automatikauslösermodus wechselt.


Wie wird ein Auslösersignal über die Tastatur gesendet?

Drücken Sie STRG+T (das Setup Tool-Fenster muss aktiv sein).


Wie wird die Bildbelichtung eingestellt?

Beim Auslösermodus „Präsentation“ und „Manuell“ werden bei der Einstellung Automatische Belichtung automatisch die besten Einstellungen für die optimale Helligkeit jedes Bildes ermittelt. Bei beiden Auslösertypen können Sie die Einstellung Maximale Belichtung an die Bedingungen Ihrer Produktionsumgebung anpassen. Sie können auch die Einstellung Manuelle Belichtung auswählen und eine genaue Belichtungszeit in Mikrosekunden festlegen. Der Schieberegler Verstärkung (unter dem Bildanzeigebereich) gibt die Pixelhelligkeit des Ziels an.


Welche Beleuchtungs- und Kameraeinstellungen verwendet das Lesegerät?

Sie können vier verschiedene Lese-Setups konfigurieren. Bei einem Leseversuch probiert das Lesegerät nacheinander alle aktivierten Setups aus, um den betreffenden Code zu lesen. Um ein Setup zu aktivieren, klicken Sie unter Lese-Setups auf das Licht für das betreffende Setup oder wählen Sie das Setup im Fenster Lese-Setups aus. Aktivierte Setups sind mit einem grünen Licht gekennzeichnet.

Wenn mehrere Setups aktiviert sind, beginnt das Lesegerät beim Scannen immer mit dem zuletzt verwendeten Setup. Das Lesegerät wechselt das Setup ausgehend von der Anzahl Decodierversuche. Das bedeutet, dass das Lesegerät bei der Standardeinstellung nach 2 nicht erfolgreichen Decodierversuchen zum nächsten Setup wechselt. Rufen Sie in der Baumansicht über die Gruppe Systemeinstellungen das Fenster Auslöser-Setup auf, um die Anzahl der Decodierversuche zu ändern.


Welches Setup wird bei Prägemarkierungen verwendet?

Verwenden Sie das Setup Nadelprägung schwierig oder Uneinheitliche Oberfläche, wenn sich die Prägemarkierungen auf einer stark reflektierenden Oberfläche befinden. Ansonsten können mit dem Setup Universal die meisten Präge-Codes gelesen werden.


Ist es sinnvoll, alle Setups zu aktivieren?

Sie sollten nur die Setups aktivieren, die für Ihre Teile und deren Markierungen geeignet sind. Denken Sie daran, dass das Lesegerät beim Lesen eines Codes alle aktivierten Setups durchlaufen muss. Je mehr Setups aktiviert sind, desto mehr Zeit benötigt das Lesegerät für einen Lesevorgang.

Standardmäßig sind alle Lese-Setups aktiviert. Vergewissern Sie sich, dass Sie die gewünschten Code-Qualitätseinstellungen für alle aktivierten Lese-Setups aktivieren. Andernfalls geben die 1D-Qualitätsmetriken keine Daten zurück.


Wie wird ein anderes Setup aktiviert, wenn das Setup Tool nicht geöffnet ist?

Sie können jederzeit die Codes im Dokument Konfigurationscodes (verfügbar über das Windows-Menü Start oder das Setup Tool-Menü Hilfe) scannen, um ein bestimmtes Setup zu aktivieren (und die übrigen 3 zu deaktivieren).


Wie lässt sich die gesamte Beleuchtung des Lesegerätes schnell ein- und ausschalten?

Klicken Sie mit der rechten Maustaste auf das Symbol mit den Beleuchtungsquadranten. Dort stehen folgende Auswahlmöglichkeiten zur Verfügung:

  • Alle an

  • Alle aus

  • Nord-Süd

  • Ost-West

Die Änderungen werden sofort entsprechend Ihrer Auswahl wirksam.


Daten formatieren


Wie funktioniert die Datenformatierung?

Im Fenster Einfach können Sie die zu verwendende Art der Formatierung auswählen.

Im Fenster Standard können Sie aus vordefinierten Bausteinen auf den einzelnen Symbologieregisterkarten eine benutzerdefinierte Ausgabezeichenkette zusammenstellen:

  • Die Ausgabezeichenketten beginnen jeweils mit dem Text, den Sie im Feld Führende Zeichen eingegeben haben.

  • Wählen Sie auf den Registerkarten Allgemein, Validierung und ggf. Metriken eine oder mehrere Positionen aus und klicken Sie dann auf Hinzufügen, um diese der Ausgabezeichenkette hinzuzufügen. Um einen Zeichenbereich aus den decodierten Daten hinzuzufügen, klicken Sie auf Teilzeichenketten-Bereich einstellen und geben dann den gewünschten Zeichenbereich ein (beispielsweise 1-3, 5, 8, 10-). Klicken Sie dann in der Liste auf Teilzeichenkette und danach auf die Schaltfläche Hinzufügen.

  • Die Ausgabezeichenketten enthalten außerdem den Text, den Sie im Feld Nachfolgende Zeichen eingegeben haben.

  • Um die Zeichenkette mit Zeilenumschaltung/Zeilenvorschub abzuschließen, aktivieren Sie das Kontrollkästchen CR/LF.


Warum befinden sich unterhalb der Registerkarte Standard noch weitere Registerkarten?

Sie können die Formatierung für unterschiedliche Symbologietypen getrennt festlegen oder auf der Registerkarte Universell eine Datenformatierung für alle decodierten Symbole festlegen. Die Einstellungen auf dieser Registerkarte haben Vorrang vor den Einstellungen auf Registerkarten für bestimmte Symbologietypen.


Wie werden sowohl symbologiespezifische als auch universelle Formatierung verwendet?

Im Fenster Standardformatierung werden bei Verwendung symbologiespezifischer Registerkarten zusammen mit der Registerkarte Universell folgende Kriterien berücksichtigt:

  • Jedes einzelne Ergebnis durchläuft den symbologiespezifischen Formatierer, sofern dieser aktiviert ist. Mehrere Ergebnisse der gleichen Symbologie werden getrennt mit den gleichen Einstellungen formatiert.

  • Wenn die Registerkarte Universell aktiviert ist, durchlaufen die einzelnen Ergebnisse den symbologiespezifischen Formatierer, sofern aktiviert, und werden anschließend den Formatierungsregeln auf der Registerkarte Universell unterzogen. Bei mehreren Ergebnissen (falls vom Lesegerät unterstützt) werden die Ergebnisse aneinandergehängt und durch das ausgewählte Trennzeichen getrennt. Diese Verkettung trägt an ihrem Ende kein Trennzeichen. Die verkettete Zeichenfolge wird von den Formatierungsregeln auf der Registerkarte Universell als eine Zeichenfolge behandelt.

  • Bei mehreren Ergebnissen werden die Ergebnisse in folgender Reihenfolge in die verkettete Zeichenfolge aufgenommen: 1) DataMatrix, 2) QR-Code, 3) 1D-Codes, 4) Vericode, 5) Dotcode und 6) OCR.

  • Jedes der symbologiespezifischen Formatierung hinzugefügte Zeichen, das nur für den gesamten Decodierungsprozess gilt (z. B. Decodierzeit oder Auslöserindex), gibt diesen globalen Wert zurück.


Welche Daten werden gesendet, wenn „Standardformatierung“ nicht aktiviert ist?

Das Lesegerät überträgt die gesamte decodierte Zeichenkette, gefolgt von Zeilenumschaltung/Zeilenvorschub.


Wie können die decodierten Daten ohne Zeilenumschaltung/Zeilenvorschub gesendet werden?

Aktivieren Sie die Formatierung, erweitern Sie die Ausgabezeichenkette um Vollständige Zeichenkette und vergewissern Sie sich, dass das Kontrollkästchen CR/LF nicht aktiviert ist.

Um nur Zeilenumschaltung zu senden, geben Sie im Feld Nachfolgende Zeichen die Zeichenfolge \r ein.


Was ist eine Eingabezeichenkette?

Die Eingabezeichenkette ist eine Formatierungszeichenfolge, die Sie bei der skriptbasierten Formatierung als Teil der Lesegeräteigenschaften oder bei der Standarddatenformatierung als Zeichenfolge einschließen können. Sie können im Setup Tool keine weiteren Eigenschaften der Eingabezeichenkette ändern. Die Parameter sind nur in DMCC verfügbar.


Wie kann verhindert werden, dass in Excel Zellen übersprungen werden?

Standardmäßig hängt das Lesegerät jedem übertragenen Code Zeilenumschaltung/Zeilenvorschub an. Wenn Sie zur Eingabe der übertragenen Codes in Excel eine Tastaturverbindung verwenden, bewirkt Zeilenumschaltung/Zeilenvorschub in Excel nach jedem Code einen doppelten Zeilenvorschub. Damit dies nicht geschieht, müssen Sie das Lesegerät so konfigurieren, dass nur Zeilenumschaltung gesendet wird:

  1. Klicken Sie auf Standardformatierung.

  2. Spezifizieren Sie in den Registerkarten Symbologie die verwendete Symbologie.

  3. Aktivieren Sie das Kontrollkästchen Standardformatierung aktiviert.

  4. Klicken Sie auf der Registerkarte Allgemeines auf Vollständige Zeichenkette.

  5. Klicken Sie auf Hinzufügen.

  6. Geben Sie im Textfeld Nachfolgende Zeichen die Zeichenfolge \r ein und deaktivieren Sie das Kontrollkästchen CR/LF.


Wie können bei Aktivierung der Datenvalidierung einzelne Elemente der codierten Daten ausgegeben werden?

Wählen Sie im Fenster Datenvalidierung zunächst den benötigten Validierungstyp aus. Aktivieren Sie im Anwendungsschritt Daten formatieren auf der Registerkarte Einfach die Option Einfache Formatierung. Wählen Sie auf der Registerkarte Standard die Registerkarte Validierung, und fügen Sie die gewünschten Datenfelder zur Ausgabezeichenkette hinzu, beispielsweise Unternehmenskennung, Seriennummer, Teilenummer, eindeutige Artikelkennung oder GS1-Anwendungskennung.


Welche Einzeloptionen stehen auf der Registerkarte „Allgemeines“ der Registerkarte „Standard“ im Feld „Daten“ zur Verfügung?

  • Teilzeichenkette: Eine Teilzeichenkette der Zeichen, die im Symbol codiert sind. Für diese Option müssen Sie einen Bereich für die Teilzeichenkette angeben.

  • Vollständige Zeichenkette: Alle Zeichen, die im Symbol codiert sind.

  • Decodierzeit: Die Zeit in Millisekunden, die das Lesegerät zum Decodieren des Symbols gebraucht hat. In dieser Zeitdauer sind Bilderfassung, noch nicht ausgeführte Bildverarbeitungsvorgänge, die Zeit für die Verbindungsherstellung und zusätzliche Verarbeitungsvorgänge (z. B. Datenformatierung) nicht enthalten.

  • Auslöserzeit: Die Zeit in Millisekunden zwischen dem Empfang des Auslösersignals und dem Abschluss des Decodiervorgangs.

  • Symbologie: Die Symbologie des decodierten Symbols.

  • CR/LF: Zeilenumschaltung mit Zeilenvorschub (Carriage Return with Line Feed).

  • TAB: Tabstoppzeichen.

  • SP: Leerzeichen (Space).

  • Symbologiekennung: Die Symbologiekennung gemäß ISO/IEC 15424:2008.

  • Modulgröße: Die Breite (oder Höhe) in Pixel der einzelnen Module im Symbol.

  • Code-Position: Die Bildkoordinaten der Ecken des decodierten Symbols.

  • Code-Ausrichtung: Dies ist die Ausrichtung des decodierten Symbols in Grad. Werden decodierte Symbole im Uhrzeigersinn gedreht, gilt dies als positive Änderung der Ausrichtung.

  • Kontrast: Ein Wert zwischen 0 und 1, mit dem der Gesamtkontrast im decodierten Symbol angegeben wird. Ein hoher Wert weist auf einen breiten Grauwertbereich für die hellen und dunklen Module im Symbol hin, ein niedriger Wert gibt an, dass helle und dunkle Module aus ähnlichen Grauwerten gebildet sind.

  • UEC: Der Anteil an nicht verwendeter Fehlerkorrektur im Symbol. Bei der Fehlerkorrektur handelt es sich um ein Verfahren für die Wiederherstellung oder den Ersatz von Daten, die durch Beschädigungen des Symbols verloren gehen. Der Wert 100 ist optimal. 1D-Symbologie gibt immer den Wert -1 zurück.

  • Eingabezeichenkette: Dies ist die (seriell oder über Ethernet) empfangene Eingabezeichenkette.

  • Filterzeit: Dies ist die Filterungsdauer in Millisekunden (ms).

  • Ergebnisquelle: Dies ist der Name des Gerätes.

Alle folgenden Werte erhöhen sich unabhängig davon, ob das Lesegerät mit dem Setup Tool verbunden ist.

  • Summe Gelesen: Die Gesamtzahl decodierter Symbole.

  • Summe Fehllesungen: Die Anzahl Leseversuche, bei denen ein Auslöser empfangen, aber kein Symbol decodiert wurde.

  • Summe Auslösungen: Summe Auslösungen = Summe Gelesen + Summe Fehllesungen + Verpasste Auslösungen

  • Verpasste Auslösungen: Die Anzahl Auslösungen, die verpasst wurden, weil kein Bildpuffer bei Erkennung des Auslösers verfügbar war.

  • Auslöserindex: Die Gesamtzahl Auslösungen, die vom Lesegerät erkannt werden.

Die folgenden Werte werden stets auf 0 zurückgesetzt, wenn im Fenster Prozessmonitor die Prozessstatistik gelöscht oder das Lesegerät neu gestartet wird:

  • Summe Gut-Lesungen

  • Summe Fehllesungen

  • Summe Auslösungen

  • Verpasste Auslösungen

Der Auslöserindex wird nur nach einem Neustart des Lesegerätes und nicht nach dem Löschen der Prozessstatistik auf 0 zurückgesetzt.


Wie können Kombinationen mit den ALT-, STRG- und Umschalttasten simuliert werden?

Für diese Funktion stehen vier Escape-Sequenzen zur Verfügung: \ALT-, \CTRL-, SHIFT- und \K. \ALT- wird für ALT-Tastensequenzen, \CTRL- für STRG-Tastensequenzen, \SHIFT- für Umschalttastensequenzen und \K für Sondertasten verwendet. Beachten Sie, dass die Taste nach dem Backslash ein Großbuchstabe sein muss, damit eine Sondertastenkombination erkannt wird.

Die Sequenzen werden im Fenster Standard in die Felder Führende Zeichen/Nachfolgende Zeichen eingegeben.

Unterstützte Sonder-Tastenkombinationen

Sie müssen das folgende Format verwenden:

\ALT- gefolgt von Tastenname gefolgt von ;

oder

\STRG- gefolgt von Tastenname gefolgt von ;

oder

\SHIFT- gefolgt von Tastenname gefolgt von ;

oder

\K gefolgt von Tastenname gefolgt von ;

Das abschließende Semikolon muss eingegeben werden, damit zwischen Sequenzen mit demselben Präfix unterschieden werden kann. Andernfalls könnten die Tastensequenzen willkürlich interpretiert werden, d. h., es wäre dann nicht möglich zu erkennen, ob \KF11 „F11 drücken“ oder „F1 gefolgt von der Zahl 1 drücken“ bedeutet.

Beachten Sie, dass diese Escape-Sequenzen bei Eingabe auf der Registerkarte Universell auch auf die Ausgabezeichenkette bei Fehllesung angewendet werden.

Unterstützte Tastensequenzen und Tasten

In der folgenden Liste sind die derzeit unterstützten Tasten/Tastenkombinationen aufgeführt:

  • ALT+A bis ALT+Z

  • STRG+A bis STRG+Z

  • STRG+F1 bis STRG+F12

  • Umschalt+F1 bis Umschalt+F12

  • F1 bis F12

  • ALT+F1 bis ALT+F12

  • Bild auf, Bild ab, Pos1, Ende, Pfeiltasten (auf, ab, links, rechts), Einfügen, Entfernen, Rücktaste, Tabulatortaste, Escape-Taste, Drucktaste, Windows-Tasten (links, rechts)

    Für diese Tasten/Tastenkombinationen werden die folgenden Escape-Sequenzen verwendet:

    • BildAuf -> \KPup;

    • BildAb -> \KPdn;

    • Pos1 -> \KHome;

    • Ende -> \KEnd;

    • Pfeil nach oben -> \KUar;

    • Pfeil nach unten -> \KDar;

    • Pfeil nach links -> \KLar;

    • Pfeil nach rechts -> \KRar;

    • Einfügen -> \KIns;

    • Entfernen -> \KDel;

    • Rücktaste -> \KBksp;

    • Tabulator -> \KTab;

    • Escape -> \KEsc;

    • Drucktaste -> \KPrtScr;

    • Linke Windows-Taste -> \KLGui;

    • Rechte Windows-Taste -> \KRGui;

  • Ausgabe pausieren -> \KPAUSE;

Es folgen einige Beispiele:

  • Für die Sequenz „ALT+V“ verwenden Sie \ALT-V;

  • Um das Drücken der Taste F10 zu simulieren, verwenden Sie \KF10;

  • Um das Drücken der Taste Pos1 zu simulieren, verwenden Sie \KHome;

  • Zum Aktivieren/Deaktivieren der Statusleiste im Programm Editor („ALT+V;S“) wird die Sequenz \ALT-V;S verwendet.

Bei Eingabe falscher oder unvollständiger Sequenzen werden die beiden Zeichen zur Kennzeichnung der Escape-Sequenz ignoriert. In solchen Fällen werden die ersten beiden Buchstaben der Escape-Sequenz übersprungen und nur die verbleibenden Zeichen gesendet. Beispielsweise ist die Sequenz \ALT-M11; ungültig und führt zur Anzeige von LT-M11;.


Wie wird die Datenformatierung getestet?

Über die Schaltfläche Test unten auf der Seite können Sie eine Ergebnisvorschau anzeigen.

Scannen Sie ein Symbol und prüfen Sie das formatierte Ergebnis in der Statusleiste. Sie können auch das Fenster Ergebnisverlauf auswählen und dann ein Symbol lesen. Der Ergebnisverlauf enthält die Ergebnisse für die von Ihnen angegebene Formatierung.


Wozu dient die Funktion Ausgabeoptionen?

Mit der Funktion „Ausgabeoptionen“ können Sie die gewünschten Ausgabedatenelemente in verschiedenen Formaten ausgeben. Wenn zum Beispiel ein Komma ausgewählt ist und Sie die vollständige Zeichenkette gefolgt vom Symbologietyp ausgeben möchten, besteht die Ausgabe aus einer Zeichenkette mit den vollständigen Daten, gefolgt von einem Komma und dem Text „DataMatrix“. Um die verschiedenen Ausgaben zu testen, wählen Sie zuerst einen Ausgabetyp aus und klicken dann auf die Schaltfläche „Test“, um die Ausgabe im angrenzenden Fenster anzuzeigen. Bitte beachten Sie: Wenn die Datenvalidierung aktiviert ist und ein Code die Datenvalidierung nicht besteht, wird die Funktion „Ausgabeoptionen“ nicht aktiviert.


Warum ist die Schaltfläche Test abgeblendet?

Sie können einen Code erst nach der ersten erfolgreichen Decodierung testen.


Können Zeichen im hexadezimalen oder oktalen ASCII-Code angegeben werden?

In den Feldern Führende Zeichen und Nachfolgende Zeichen können Sie Zeichen als \nnn angeben, wobei nnn für den oktalen ASCII-Code steht. Um Zeichen im Hexadezimalformat anzugeben, geben Sie \xnn ein. Hierbei steht nn für den hexadezimalen ASCII-Code.

Sie können auch die folgenden vordefinierten Codes verwenden:

  • \a Warnung (ASCII 7)
  • \b Rücktaste (ASCII 8)
  • \E Escape (ASCII 27)
  • \f Seitenvorschub (ASCII 12)
  • \n Zeilenvorschub (ASCII 10)
  • \t Horizontaler Tabulator (ASCII 9)
  • \r Zeilenumschaltung (ASCII 13)
  • \v vertikaler Tabulator (ASCII 11)
  • \\ Backslash (ASCII 92)


Was überträgt das Lesegerät, wenn kein Code gelesen wird?

Normalerweise überträgt das Lesegerät keine Daten, wenn ein Code nicht gelesen werden kann. Im Ergebnisverlauf werden eine leere Ergebniszeichenkette und ein rotes Kreuz mit der Meldung „Fehllesung“ als Ergebnisstatus angezeigt.


Was bedeutet das Ergebnis Code-Position?

Bei DataMatrix-Symbolen entspricht die Code-Position der gemeldeten Position für die vier Ecken des Symbols. Das Lesegerät gibt vier Koordinatenpaare zurück:

  • Das erste Paar bezeichnet den Schnittpunkt des Findermusters.

  • Das zweite Paar bezeichnet den Schnittpunkt des horizontalen Findermusters mit dem vertikalen Taktmuster.

  • Das dritte Paar bezeichnet den Schnittpunkt der Taktmuster (diagonal entgegengesetzt zum ersten Paar).

  • Das vierte Paar bezeichnet den Schnittpunkt des vertikalen Findermusters mit dem horizontalen Taktmuster.

Cognex empfiehlt, ein Trennzeichen wie ein Komma festzulegen, um die Werte voneinander zu trennen und das Ergebnis leichter lesbar zu machen.


Welche Datenformatierungsmethode soll ich verwenden?

Sie können die Option „Einfache Formatierung“ (Standard- oder PERL-Format) verwenden oder auf der Registerkarte „Datenformatierung“ im Fenster Skripterstellung ein eigenes Skript in JavaScript erstellen. Die beiden Methoden unterscheiden sich wie folgt voneinander:

  • Bei der einfachen Formatierung können Sie vordefinierte Datenformatierungselemente per Drag-and-drop ziehen und ablegen.

  • Bei der skriptbasierten Formatierung können Sie ein Skript erstellen, mit dem das Lesegerät neben der Formatierung von Leseergebnissen und -daten auch Vorgänge wie die Ausgabe von Signaltönen oder ein Pull-up für Ausgang 1 ausführen kann.


Wozu dient die Registerkarte „Kommunikation“?

Auf dieser Registerkarte können Sie eigene Kommunikationsprotokollskripts erstellen.


Welche Begrenzungen gelten für die skriptbasierte Formatierung?

„Skriptbasierte Formatierung“ ist limitiert auf zwei benutzerdefinierte Ereignisse und Überschreibung von Systemereignissen.


Wo finde ich ein Skriptbeispiel?

Sie haben die folgenden Möglichkeiten, um im Hauptfenster „Skripterstellung“ ein Skript einzufügen:

  • Klicken Sie in der Symbolleiste oben auf Ausschnitt einfügen und wählen in der Liste den für Ihre Anforderungen geeigneten Ausschnitt aus.

  • Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im Hauptfenster und wählen Ausschnitt einfügen ... aus. Klicken Sie in der Liste auf den für Ihre Anforderungen geeigneten Ausschnitt.

  • Drücken Sie STRG+K, X.

HINWEIS: Bei deaktivierter Schaltfläche Ausschnitt einfügen unterstützt die auf dem Gerät ausgeführte Firmwareversion Ausschnitte für die aktuelle Skriptregisterkarte nicht.


Wozu dient die Registerkarte „FTP-Speicherung“?

Über diese Registerkarte werden die FTP-Dateinamen für Bilder und die Code-Qualitätsberichte generiert.


Wie werden Skripts geladen?

Um auf Ihre Skripts zuzugreifen, klicken Sie auf das Menübandmenü und anschließend auf die Option Skript öffnen. Sie können Ihre Skripts über die Schaltfläche Skript speichern speichern.

HINWEIS: Die Skripterstellung unterstützt ausschließlich UTF-8-Zeichencodierung.


Wozu dient die Option „Wort vervollständigen“?

Mit den folgenden Verfahren können Sie Wörter in einem Skript vervollständigen:

  • Klicken Sie in der Symbolleiste oben auf Wort vervollständigen.

  • Klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im Hauptfenster und wählen Wort vervollständigen aus.

  • Drücken Sie STRG+K, W.

Sie können dann in einer Liste das Objekt auswählen, das Sie in das Skript einfügen möchten.


Wie kann ich ein Skript schnell bearbeiten?

Verwenden Sie die Schaltflächen Ausschneiden, Kopieren und Einfügen in der Symbolleiste oben, oder klicken Sie mit der rechten Maustaste auf eine beliebige Stelle im Hauptfenster und wählen „Ausschneiden“, „Kopieren“, „Einfügen“, „Löschen“ oder „Alles auswählen“ aus.


Warum werden bei Auswahl von System -> Einstellungen speichern alle Variablen zurückgesetzt?

Bei jeder Skriptänderung, die bei Fokus des Editors im linken Bereich vorgenommen wird, wird das Skript an das Lesegerät übertragen. Dadurch wird der Kontext des Skriptmoduls ungültig. Aufgrund des ungültig gewordenen Skriptkontextes werden alle Variablen zurückgesetzt.


Wie kann ich Fehler im Geräteprotokoll mithilfe eines Skripts anzeigen?

Anomale Situationen (Ausnahmen) erfassen Sie mit dem Befehl „Throw()“. Entsprechende Fehler werden dann im Geräteprotokoll angezeigt, wenn das Gerät nicht mit dem Setup Tool verbunden ist. Das Fehlerprotokoll öffnen Sie, indem Sie in der Menüleiste des Setup Tools auf System und dann auf Geräteprotokoll anzeigen klicken.

Solange das Gerät mit dem Setup Tool verbunden ist, wird die Ausnahme im Skriptfenster unter dem Skript angezeigt.


Wo finde ich weitere Informationen zur skriptbasierten Formatierung?

Weitere Informationen finden Sie in der DataMan Kommunikations- und Konfigurationsanleitung, die Sie über das Windows-Menü Start oder das Setup Tool-Menü Hilfe aufrufen können.


Wir wird eine Verzögerung für die Code-Ausgabe festgelegt?

Um eine Pause für die Code-Ausgabe festzulegen, fügen Sie den Textfeldern im Fenster „Datenformatierung“ die Zeichenfolge „\Pause<Zeit>;“ hinzu.

„<Zeit>“ enthält einen Wert in Millisekunden. Um 4 Sekunden zu warten, lautet die Zeichenfolge beispielsweise „\Pause4000;“.

Diese Funktion kann mit USB-HID oder RS232 verwendet werden. Bei RS232 muss die Funktion über den DMCC-Befehl „COM.RS232-ENABLE-PAUSE“ aktiviert werden. Bei USB-HID ist die Funktion standardmäßig aktiviert.


Warum befinden sich oben mehrere Registerkarten?

Die Formatierung kann für unterschiedliche Symbologien getrennt angegeben werden. Auf der Registerkarte Universell können Sie für alle decodierten Symbole die Formatierung im PERL-Format vornehmen.


Wie wird beliebiger Text ersetzt?

Geben Sie in das Textfeld Regulärer Ausdruck: Ihren Text ein. Die Syntax für die Zeichenkette lautet:

        /search/replace/g

Dabei steht suchen für die zu suchende Zeichenkette und ersetzen für die Zeichenkette, durch die suchen ersetzt werden soll. Standardmäßig wird nur die erste Instanz von suchen ersetzt. Um alle Instanzen zu ersetzen, ergänzen Sie den Befehl um das Zeichen g.

Beispiel: Das Lesegerät decodiert die folgende Zeichenfolge:

        UPC 05214275600

Um die Zeichenkette „UPC“ durch die Zeichenkette „SKU CODE:“ zu ersetzen, können Sie die folgende Zeichenkette eingeben:

        /UPC/SKU CODE:/

Die Ausgabezeichenkette lautet:

        SKU CODE: 05214275600

Sie können auch mehrere Suchen/Ersetzen-Paare eingeben, die durch Leerzeichen voneinander getrennt sind. Die Verarbeitung mehrerer Paare erfolgt sequenziell: Das Ergebnis des ersten Paares bildet die Eingabe für das zweite Paar usw.


Was bewirkt die Option Daten ohne Übereinstimmung verwerfen?

Standardmäßig wird jeder Text, der nicht in der Suchzeichenkette enthalten ist, unverändert weitergegeben. Wenn Sie jedoch die Option Daten ohne Übereinstimmung verwerfen aktivieren, werden nur die aus dem Ersetzungsvorgang resultierenden Zeichenketten gesendet.


Welche Sonderzeichen müssen durch eine Escape-Sequenz ausgewiesen werden?

Die folgenden Zeichen haben in Suchen/Ersetzen-Zeichenketten eine besondere Bedeutung:

            ˆ  . , (  )  [  ] $ \ / * + |

Wenn Sie eines dieser Zeichen in Ihre Suchen/Ersetzen-Zeichenkette eingeben möchten, müssen Sie einen Backslash \ voranstellen. Um einen Backslash einzugeben, geben Sie \\ ein. Um ein beliebiges ASCII-Zeichen einzugeben, geben Sie \xhh ein, wobei hh der Hexadezimalwert ist (die Angabe von oktalen ASCII-Werten mit \ooo ist nicht möglich).


Wie werden Platzhalter verwendet, um nach mehreren Zeichen oder Mustern zu suchen?

Durch Einfügen dieser Sonderzeichen in die Suchzeichenkette können Sie nach einzelnen Zeichen, einzelnen Zeichen aus einer Gruppe von Zeichen und nach einzelnen Zeichen aus einem Zeichenbereich oder außerhalb eines Zeichenbereichs suchen.

. Suche nach einem beliebigen einzelnen Zeichen

[abcd...] Suche nach einem beliebigen einzelnen Zeichen aus der Gruppe a, b, c, d ...

[a-z] Suche nach einem beliebigen einzelnen Zeichen aus dem Zeichenbereich a bis z (es können Buchstaben oder Zahlen verwendet werden).

Um die Bedeutung eines Platzhalters umzukehren, der aus einer Zeichengruppe oder aus einem Zeichenbereich besteht, stellen Sie den Zeichen jeweils ein ^ voran.

Um nach einer beliebigen Anzahl Zeichen zu suchen, fügen Sie dem gesuchten Zeichen bzw. dem gesuchten Platzhalter eines der folgenden modifizierenden Zeichen hinzu:

+ Suche nach einer oder mehreren Instanzen des davor stehenden Zeichens.

* Suche nach null oder mehreren Instanzen des davor stehenden Zeichens.

? Suche nach null oder einer Instanz des davor stehenden Zeichens.

{n} Suche nach n Instanzen des davor stehenden Zeichens.

{n,m} Suche nach mindestens n und höchstens m Instanzen des davor stehenden Zeichens.

{n,} Suche nach mindestens n Instanzen des davor stehenden Zeichens.

Es folgen einige Beispiele zur Platzhaltersuche:

/A.B/AB/g Entfernt ein beliebiges einzelnes Zeichen zwischen „A“ und „B“ aus der Eingabezeichenkette.

/A.B/AB/g Entfernt eine beliebige Anzahl Zeichen zwischen „A“ und „B“ aus der Eingabezeichenkette.


Gibt es Platzhalter für die Suche nach Sonderzeichen?

Verwenden Sie die folgenden Escape-Sequenzen, um nach Sonderzeichen und Sonderzeichentypen zu suchen:

\n ein Zeichen zum Einfügen einer neuen Zeile

\w ein alphanumerisches Zeichen (Buchstabe oder Ziffer)

\W ein nicht alphanumerisches Zeichen

\s ein Leerzeichen

\S kein Leerzeichen

\d eine Ziffer

\D keine Ziffer

Sie können diese Zeichen mit den Platzhaltern zur Suche nach mehreren Zeichen (siehe oben) kombinieren.


Wie wird die Suchzeichenkette verankert?

Stellen Sie der Suchzeichenkette ein ^ voran, damit nur am Anfang der Zeichenkette gesucht wird. Stellen Sie der Suchzeichenkette ein $ voran, damit nur am Ende der Zeichenkette gesucht wird.


Wie werden Teile der Suchzeichenkette in der Ergebniszeichenkette wiederverwendet?

Setzen Sie die Teile der Suchzeichenkette in Klammern, die Sie in der Ergebniszeichenkette verwenden möchten. Die Zeichen \1, \2 usw. ermöglichen den Zugriff auf die in Klammern gesetzten Zeichenketten.


Ist die Größe von regulären Ausdrücken im PERL-Format begrenzt?

Auf Registerkarten eingegebene Skripts können jeweils maximal 512 Zeichen umfassen. Die symbologiespezifische Registerkarte wird jedoch vor der Registerkarte „Universell“ ausgeführt. Bei gleichzeitiger Verwendung beider Registerkarten können Sie ein Skript mit bis zu 1024 Zeichen erstellen.


Wo finde ich weitere Informationen zu regulären Ausdrücken im PERL-Format?

Hier. Bitte beachten Sie, dass nicht alle auf dieser Seite beschriebenen Funktionen in das Lesegerät implementiert sind.


Eingänge/Ausgänge


Was kann in den Einstellungen für die TUNE-Taste geändert werden?

Sie können die Eingabe festlegen, die das Gerät beim Drücken der Tune-Taste verwendet. Standardmäßig wird die Taste Versuche erweitertes Lesen des DataMan 8600 für die Tuningoptimierung verwendet. Die Tuningoptimierung wählt automatisch das beste Lese-Setup für die aktuelle Decodierung aus und legt dieses im DataMan Setup Tool als nicht angezeigtes Lese-Setup 4 fest. Symbologie, Belichtung, Beleuchtungseinstellungen, Fokus usw. sind dabei gesperrt und die anderen Lese-Setups werden deaktiviert. So ist für zügigere Lesevorgänge in Fällen gesorgt, in denen wiederholt derselbe Code-Typ gelesen wird.

Um die Tuningoptimierung auszuführen, halten Sie die Taste „Versuche erweitertes Lesen“ gedrückt, bis eine Leuchte gelb/grün blinkt. Lassen Sie die Taste dann los. Die Leuchte blinkt, bis ein Code gelesen wird. Wenn Sie den Auslöser betätigen, um einen Code zu lesen, geht die Leuchte aus und wieder an und es wird eine Bildfolge mit den aktivierten Lese-Setups aufgezeichnet. Anschließend hört die Leuchte auf zu blinken. Das Tuning ist beendet, wenn ein Signalton zu hören ist und die Leuchte dauerhaft grün leuchtet. Das Lesegerät ist dann optimiert. Sie können das Tuning rückgängig machen, indem Sie die Taste „Versuche erweitertes Lesen“ erneut drücken, bis die Statusanzeige zu Rot wechselt.

Sie können über die Taste „Versuche erweitertes Lesen“ auch alternative Leseoptionen zur Verwendung auswählen:

  • Suchzeichenkette trainieren Nach der Vorbereitung des Gerätes (durch Drücken der Taste „Versuche erweitertes Lesen“) mit der optischen Taste legt der nächste Auslöser den Lese-Code als Suchzeichenkette fest (Suchzeichenketten sind nur mit Feature Key verfügbar).

  • Verifizierer aktivieren: Nach der Vorbereitung des Gerätes (durch Drücken der Taste „Versuche erweitertes Lesen“) aktiviert die Auslösung die Überprüfung für den Lese-Code (Suchzeichenketten sind nur mit Feature Key verfügbar).

Um die Taste „Versuche erweitertes Lesen“ zu deaktivieren, verwenden Sie Taste des Lesegerätes deaktivieren hier.


Was wird mit „Aktion bei Tastendruck von 3 Sekunden“ auf der Registerkarte „TUNE-Taste“ festgelegt?

Damit können Sie festlegen, wie das Lesegerät beim Drücken der TUNE-Taste für 3 Sekunden reagieren soll. Wenn Sie weitere Optionen markieren, werden die Funktionen in der aufgeführten Reihenfolge ausgeführt.


Welche Auswirkung hat die Aktivierung der Option Taste des Lesegerätes deaktivieren?

Mit dieser Option wird die Tune-Taste am Lesegerät deaktiviert.


Welche Funktion hat das Kontrollkästchen „Taste des Lesegeräts deaktivieren“ auf der Registerkarte „TUNE-Taste“?

Wenn Sie das Kontrollkästchen Taste des Lesegerätes deaktivieren aktivieren, führt das Lesegerät beim Drücken dieser Taste am Lesegerät keine Erfassungs- oder Trainingsversuche durch. Beachten Sie, dass durch diese Funktion weder die Schaltfläche „Auslöser“ auf der Symbolleiste des Setup Tools noch der serielle Auslöserbefehl deaktiviert wird.


Welche Systemeinstellungen kann ich ändern?

Sie können den Signalton deaktivieren bzw. aktivieren.

Über das Dropdown-Menü „Systemeinstellungen“ auf der Registerkarte Erweitert können Sie festlegen, wie sich das Lesegerät verhält, wenn es einen Code liest, wenn das Lesen eines Codes fehlschlägt oder wenn es einen Code liest, dessen Validierung fehlschlägt.

  • Über Lautstärke steuern Sie die Tonhöhe des Signaltons.

  • Über Anzahl Signaltöne steuern Sie, wie oft der Signalton wiederholt wird.

  • Über LED-Farbe legen Sie die Farbe der Statusanzeige auf der Rückseite des Lesegerätes fest.

  • Über Vibration aktivieren legen Sie fest, ob eine Gut-Lesung durch Vibration gemeldet wird.


Welche Systemeinstellungen kann ich ändern?

Sie können hier den Signalton aktivieren bzw. deaktivieren sowie einen benutzerdefinierten Gerätenamen eingeben. Zudem können Sie Tasteneingaben und Licht- und Tonausgaben verwalten.


Wie wird das Lesegerät zurückgesetzt?

Um einen Warmstart vorzunehmen, scannen Sie den Befehl Scanner neu starten auf der Rückseite der Kurzanleitung. Der permanente Speicher des Lesegerätes wird nicht gelöscht, sondern das Lesegerät wird heruntergefahren und erneut gestartet.

Scannen Sie den Befehl Scanner auf Werkseinstellungen zurücksetzen, um das Lesegerät auf die Werkseinstellungen zurückzusetzen.


Wozu dient ein geänderter Gerätename?

Sie können einen für die Produktionsumgebung aussagekräftigen Namen für das Gerät eingeben, z. B. den Standort oder die Prüfaufgabe. Verwenden Sie dafür das Feld Gerätename auf der Registerkarte Erweitert.


Wie wird der Gerätename geändert?

So ändern Sie den Gerätenamen:

  1. Geben Sie unter Gerätename einen neuen Namen für das Gerät ein.

  2. Die folgende Frage wird angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“.

  3. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten Ihr Gerät anschließend neu.

Beim nächsten Start des Setup Tools oder durch Klicken auf Aktualisieren im Fenster Verbindung zum Lesegerät wird der neue Gerätename angezeigt.


Was ist eine Einschaltmeldung?

Ist Ausgabe einer Diagnosezeichenkette beim Einschalten aktiviert, überträgt das Lesegerät oder die Basisstation eine Diagnosezeichenkette, sobald das Gerät eingeschaltet wird.

Diese Funktion ist bei USB-Verbindungen nicht verfügbar. Bei seriellen Verbindungen wird die Baudrate beim Senden der Meldung automatisch auf 38.400 bps festgelegt, unabhängig von den Einstellungen im Setup Tool.


Kommunikation


Was kann ich im Anwendungsschritt „Kommunikation“ einstellen?

Auf den drei Registerkarten des Anwendungsschritts Kommunikation können Einstellungen für serielle und Ethernet-Übertragung festgelegt werden. Klicken Sie auf die entsprechende Registerkarte, um die gewünschten Einstellungswerte einzugeben.

Auf der Registerkarte Erweitert können in einer Tabellenansicht weitere Einstellungen vorgenommen werden.


Wie werden die Einstellungen der seriellen Anschlüsse des Lesegerätes geändert?

Geben Sie im Anwendungsschritt Kommunikation auf der Registerkarte Seriell die neuen Einstellungen ein. Sie können auch das Dokument Konfigurationscodes scannen, auf das Sie über das Windows-Menü Start oder das Setup Tool-Menü Hilfe zugreifen können.


Wann wird der Kompatibilitätsmodus für USB-Treiber verwendet?

Standardmäßig wird vom DataMan-Lesegerät ein USB-Treiber verwendet, der die Wiederherstellung des Lesegerätes nach einer elektrostatischen Entladung (Electrostatic Discharge, ESD) unterstützt. Verwenden Sie Kompatibilitätsmodus für USB-Treiber, wenn die vollständige Konformität mit der USB-Spezifikation erforderlich ist oder wenn Sie ein DataMan-Lesegerät zusammen mit Cognex SensorView verwenden.

Wenn Sie Kompatibilitätsmodus für USB-Treiber ändern, wird die folgende Frage angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten das Lesegerät anschließend neu.


Wie wirken sich Änderungen des USB-Modus aus?

Besteht eine serielle USB-Verbindung mit dem Lesegerät, können Sie die USB-Geschwindigkeit auf 1.1 oder 2.0 festlegen.

Bei Verbindung mit einem kabellosen Lesegerät wirken sich Änderungen des USB-Modus nicht auf die Basisstation aus. Die geänderten Einstellungen werden im Speicher des Lesegerätes abgelegt, bei Änderung des kabellosen Einschubmoduls in ein serielles Einschubmodul stellt das Lesegerät die Verbindung mit dem (bereits vorher) ausgewählten USB-Modus her.


Wie wird bei bestehender USB-Verbindung das Lesegerät anstelle einer Tastatur verwendet?

Um eine USB-Tastatur zu emulieren, scannen Sie den Code USB-Tastatur im Dokument Konfigurationscodes für das Lesegerät (verfügbar über das Windows-Menü Start oder im Setup Tool-Menü Hilfe) und trennen Sie die Verbindung zum Setup Tool.


Welche Optionen werden über das Drop-down-Menü „Verwendeter Kommunikationskanal“ festgelegt?

Sie können festlegen, welche USB-Kommunikationsmethode verwendet werden soll. Je nach verwendetem Gerät stehen die folgenden Optionen zur Auswahl:

  • Nur USB-COM: Bei dieser Option wird die Verbindung mit dem Gerät über eine serielle Schnittstelle hergestellt.

  • Nur USB-HID: Bei Auswahl dieser Option verhält sich das Gerät wie eine USB-Tastatur.

  • USB-COM + USB-HID: Diese Option kombiniert die beiden vorhergehenden Modi.

HINWEIS: Bei Auswahl von Nur USB-COM werden manche Geräte möglicherweise auch unter den HID-Geräten aufgeführt, auch wenn sie nicht über HID-Funktionen verfügen.


Wie wird das Lesegerät mithilfe des PS/2-Adapters anstelle einer Tastatur verwendet?

Zum Emulieren einer PS/2-Tastatur müssen Sie ein serielles Kabel, das externe Netzteil und ein Tastaturweichenkabel verwenden (siehe Kurzanleitung). Scannen Sie den Code PS/2-Tastaturemulation aktivieren im Dokument Konfigurationscodes für das Lesegerät (verfügbar über das Windows-Menü Start oder im Setup Tool-Menü Hilfe). Für die Installation des PS/2-Adapters müssen Sie den PC vollständig ausschalten. Schließen Sie das Gerät mit den oben aufgeführten Kabeln an. Schalten Sie anschließend den Computer ein. Das Lesegerät emuliert jetzt eine PS/2-Tastatur.


Welche Auswirkung hat es, wenn das Lesegerät nach der entsprechenden Aufforderung nicht neu gestartet wird?

Die geänderten Einstellungen werden nicht angewendet. Klicken Sie auf System und wählen Einstellungen speichern aus, wenn Sie sich anders entscheiden. Starten Sie anschließend das Lesegerät neu.


Was ist Auffüllen mit Nullen?

Durch Auffüllen mit Nullen werden führende Nullen in die übertragenen Daten eingefügt. Dieses Vorgehen ist bei manchen Anwendungen erforderlich, die vom Lesegerät gesendete Daten annehmen.


Wie werden die Netzwerkeinstellungen für das Lesegerät konfiguriert?

Wenn Sie das kabellose Lesegerät DataMan 8000 verwenden, konfigurieren Sie die Netzwerkeinstellungen an der Basisstation. Wenn Sie ein kabelgebundenes Lesegerät verwenden, wechseln Sie zur Registerkarte Netzwerk, um die Netzwerkeinstellungen zu konfigurieren.

Aktivieren Sie die Option DHCP-Server verwenden, wenn dem Lesegerät eine IP-Adresse von einem DHCP-Server (sofern verfügbar) zugewiesen werden soll, oder geben Sie die Netzwerkeinstellungen manuell ein. Den richtigen Wert können Sie bei Ihrem Netzwerkadministrator erfragen.

Wenn Sie die Einstellungen ändern, wird die folgende Frage angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten das Lesegerät anschließend neu.


PC-Netzwerkeinstellungen kopieren

Wenn Sie auf die Schaltfläche PC-Netzwerkeinstellungen kopieren klicken, können Sie im Dropdown-Menü eine der folgenden Einstellungen wählen: Dell GigabitEthernet, Bluetooth Device, Microsoft Wi-Fi Direct Virtual Adapter, Dell Wireless 1560 802. 11ac. Ihre eigenen Netzwerkeinstellungen werden in die obigen Felder kopiert.


Werden die Kommunikationseinstellungen von Lesegerät und Basisstation synchronisiert?

Damit zwischen dem Lesegerät und der Basisstation Einstellungen ausgetauscht und aktualisiert werden können, müssen Sie das Lesegerät auf die Station legen. Befindet sich das Lesegerät bereits auf der Basisstation, wenn Sie Ihre Kommunikationseinstellungen ändern, heben Sie das Lesegerät kurz an und legen es zurück auf die Station.


Gibt ein Lesegerät, das über 802.11b kommuniziert, allen anderen WiFi-Geräten die mit diesem Standard mögliche Geschwindigkeit vor?

Da das Lesegerät und die Basisstation direkt miteinander verbunden sind und keine Verbindung zu einem anderen WiFi-Netzwerk besteht, hat die Übertragungsgeschwindigkeit zwischen der Basisstation und dem Lesegerät keinen Einfluss auf andere WiFi-Geräte.


Warum sind auf der WiFi-Registerkarte sämtliche Optionen deaktiviert?

Ist das Lesegerät bereits einer Basisstation zugewiesen, sind die Optionsfelder abgeblendet. Wenn Sie Änderungen an der Konfiguration vornehmen möchten, verbinden Sie sich mit der Basisstation.


Warum sind auf der Bluetooth-Registerkarte sämtliche Optionen deaktiviert?

Ist das Lesegerät bereits einer Basisstation zugewiesen, sind die Optionsfelder abgeblendet. Wenn Sie Änderungen an der Konfiguration vornehmen möchten, verbinden Sie sich mit der Basisstation.


Wie wird die Zuweisung eines Lesegeräts zur Basisstation rückgängig gemacht?

Klicken Sie im Gruppenfeld „Zugewiesene Basisstation“ auf die Schaltfläche Zuweisung aufheben. Bitte beachten Sie, dass die Verbindung zum Setup Tool mit dem Anklicken dieser Schaltfläche getrennt wird. Sie müssen alle Änderungen vorher speichern.

Sie können die Verbindung auch trennen, indem Sie den Konfigurationscode Zuweisung für Lesegerät aufheben scannen.


Wozu dient die Option „Bei Firmwarestart neu auflisten“?

In manchen Fällen wird der COM-Anschluss aufgelistet, während der Firmwarestart länger dauert, sodass das Zeitlimit für den COM-Anschluss überschritten wird. Dies wird als Trennung der Verbindung interpretiert. Dies verhindern Sie durch Aktivierung dieses Kontrollkästchens, da der COM-Anschluss dabei nach dem Neustart der Firmware neu aufgelistet wird.


Industrieprotokolle

Ethernet/IP-Protokoll

Um für das Lesegerät die Verwendung des Ethernet/IP-Protokolls zu aktivieren, setzen Sie auf der Registerkarte Ethernet im Gruppenfeld Industrieprotokolle ein Häkchen bei der Option EtherNet/IP.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Klicken Sie auf Einstellungen speichern, und starten Sie dann das Lesegerät neu.

PROFINET-Protokoll

Um für das Lesegerät die Verwendung des PROFINET-Protokolls zu aktivieren, setzen Sie bei der Option PROFINET ein Häkchen. Sie können den Namen der Station eingeben, indem Sie auf Stationsnamen verwenden klicken.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Klicken Sie auf Einstellungen speichern, und starten Sie dann das Lesegerät neu.

SLMP-Protokoll

Um für das Lesegerät die Verwendung des SLMP-Protokolls zu aktivieren, setzen Sie bei der Option SLMP-Protokoll ein Häkchen, und stellen Sie dann die Parameter nach Bedarf ein.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Wählen Sie Einstellungen speichern, und starten Sie das Lesegerät anschließend neu, damit die Einstellung wirksam wird. Der Neustart kann über die Umschaltung der Stromversorgung auf das Lesegerät oder durch Scannen des Symbols Zurücksetzen erfolgen.

Modbus-TCP

Um für das Lesegerät die Verwendung des Modbus-TCP-Protokolls zu aktivieren, setzen Sie bei der Option Modbus TCP ein Häkchen, und stellen Sie dann die Parameter nach Bedarf ein.

Auf der rechten Seite des Fensters „Kommunikation“ wird die Meldung „Für die Übernahme der Änderungen ist ein Neustart erforderlich.“ angezeigt. Wählen Sie Einstellungen speichern, und starten Sie das Lesegerät anschließend neu, damit die Einstellung wirksam wird. Der Neustart kann über die Umschaltung der Stromversorgung auf das Lesegerät oder durch Scannen des Symbols Zurücksetzen erfolgen.

Eine der Optionen EtherNet/IP, PROFINET, SLMP-Protokoll oder Modbus TCP ist abgeblendet

Es kann jeweils nur ein Ethernet-Industrieprotokoll verwendet werden. Wenn eines dieser Protokolle ausgewählt ist, ist das jeweils andere Protokoll nicht verfügbar.


Wie wird die Option „Authentifizieren“ verwendet?

Bei aktivierter Option Authentifizieren wird der Benutzer vom Setup Tool aufgefordert, ein Administrator-Kennwort einzugeben, sobald versucht wird, über das Netzwerk eine Verbindung mit einem verfügbaren Lesegerät bzw. einer verfügbaren Basisstation herzustellen.


Wie wird eine TCP/IP-Verbindung hergestellt?

TCP-Verbindungen mit dem Lesegerät sind an Port 23 möglich. Dies ist der TCP-Standardport für Telnet-Anwendungen. Wenn Sie einen Telnet-Client verwenden, müssen Sie als Parameter lediglich die IP-Adresse des Lesegerätes eingeben. Wenn Sie für die Verbindung eine andere Anwendung oder SDK verwenden, muss dafür dieselbe TCP-Port-Einstellung verwendet werden wie vom Lesegerät. Der TCP-Port kann im Fenster „Telnet“ geändert werden. Das Lesegerät sendet automatisch Code-Ausgaben über diese Verbindung. Sie können über diese Verbindung außerdem DMMC-Steuerungsbefehle (DataMan Control Commands) übertragen.

Wenn Sie den Telnet-Port ändern, wird die folgende Frage angezeigt: „Für die Übernahme der Änderungen ist ein Neustart erforderlich. Sollen die Änderungen jetzt übernommen und ein Neustart ausgeführt werden?“ Klicken Sie auf „Ja“. Sie können die Änderungen auch anwenden, wenn Sie auf „Nein“ klicken. Wählen Sie System -> Einstellungen speichern aus und starten das Lesegerät neu.


Ist es möglich, Bilder an einen FTP-Server zu senden?

Über die Registerkarte FTP – Bild können Sie die Einstellungen vornehmen, die für die Übertragung von Bildern an einen FTP-Server erforderlich sind. Die Registerkarte enthält Einstellungen für die IP-Adresse und die Port-Nummer des Servers sowie für Benutzernamen und Passwort. Beachten Sie, dass per FTP gesendete Bilder nicht in allen Fällen tatsächlich übertragen werden, z. B. wenn das Lesegerät mit einem kurzen Takt betrieben wird und keine Zeit für die Bildübertragung eingeräumt werden kann. Die Übertragung über kabellose Verbindungen kann zudem wesentlich langsamer als bei der normalen Netzwerkkommunikation sein. In diesen Fällen wird empfohlen, die Bilder zu verkleinern/zu komprimieren.

Über die Optionen für Dateiname können Sie die Datei angeben, in der die Bilder gespeichert werden sollen. Im Feld Dateiname können Sie einen Pfad angeben, der mit dem Stammverzeichnis des FTP-Servers beginnt (z. B.: „/Fehllesungen_Bilder/Bild“). Die Dateinamenerweiterung (JPG oder BMP) hinter dem Dateinamen entspricht der Einstellung für das Bildformat im Fenster Einstellungen für gepufferte Bilder. Beachten Sie, dass vom Lesegerät keine Verzeichnisse erstellt werden. Es muss sich um ein bereits vorhandenes Verzeichnis mit Zugriffsmöglichkeit handeln.

Die Einstellung für Maximal angehängter Wert gibt die Grenze für die dem Dateinamen angehängten Werte an. Mit dem Wert 0 wird angegeben, dass kein Wert angehängt und die Datei überschrieben werden kann.

Die Option Servergenerierter Dateiname beginnt mit einem leeren Pfad, mit dem das Stammverzeichnis des FTP-Servers angegeben wird.

Über die Liste Zu übertragende Bilder können Sie auswählen, welche Bildtypen an den FTP-Server gesendet werden sollen. Berücksichtigen Sie, dass die Bildübertragung vom FTP-Server unterstützt werden muss.


Was ist der Netzwerk-Client?

Das Verhalten Netzwerk-Client ist eine Option, bei der das DataMan-ID-Lesegerät aktiv eine Ethernet-Verbindung mit einem anderen Gerät im Netzwerk herstellen kann. Nach Herstellung der Verbindung verhält sich diese im Betrieb in den grundlegenden Aspekten wie die DataMan-Telnet-Verbindung: Sie kann Erfassungsergebnisse ausgeben (Übertragung von Ergebnissen an das externe Gerät) und die Funktion eines DMCC-Servers übernehmen (Verarbeitung der vom externen Gerät empfangenen Befehle).


Was ist ein Host?

Der Host ist das Gerät im Netzwerk, mit dem das DataMan-Gerät eine Verbindung herstellt. Geben Sie die Ethernet-Adresse und die Port-Nummer des Hostgeräts an. Bei der Adresse kann es sich um einen vollqualifizierten Domänennamen (z. B. „server.meinnetzwork.com“) oder um eine durch Punkte getrennte IP-Adresse im Dezimalformat (z. B. „192.169.0.1“) handeln.


Was ist ein Client-Port?

Der Client-Port ist der Ethernet-Anschluss am Lesegerät, von dem aus die Client-Verbindung hergestellt wird. Beim Standardwert 0 verwendet der Netzwerk-Client jeden verfügbaren Port. In besonderen Fällen müssen Sie möglicherweise einen bestimmten Client-Port angeben. Legen Sie dazu den Client-Port auf den geforderten Wert fest. Beachten Sie, dass in den meisten Fällen der Standardwert 0 verwendet werden kann. Verwenden Sie den Standardwert, wenn Sie sich nicht sicher sind.


Wie wird eine Verbindung hergestellt?

Der Client stellt die Verbindung entsprechend der für Verbindung öffnen ausgewählten Option her. Die Verbindung kann entweder beim Einschalten des DataMan oder bei Datenaktivität (d. h. beim Erfassen eines Codes) hergestellt werden.


Wie wird eine Verbindung getrennt?

Für Verbindung schließen stehen zwei Optionen zur Verfügung. Die Verbindung kann entweder unbegrenzt aufrechterhalten oder nach Abschluss der Datenübertragung getrennt werden. Bei Auswahl der Option Nach Datenübertragung Lesegerät können Sie außerdem die Anzahl Sekunden festlegen, nach der die Verbindung getrennt wird, wenn das Lesegerät in dieser Zeitspanne inaktiv ist. Für die Inaktivitätsdauer kann ein Wert zwischen 1 und 3600 Sekunden festgelegt werden.


Was ist das Zeitlimit für die Verbindung?

Das Zeitlimit für die Verbindung ist die Dauer (in Millisekunden), die das DataMan-Gerät auf die Herstellung einer Verbindung wartet. Beachten Sie, dass das Lesegerät bei Auswahl der Verbindungsoption Beim Einschalten fortlaufend erneut versucht, die Verbindung herzustellen.


Was ist die Verzögerung für erneuten Verbindungsversuch?

Dabei handelt es sich um die Dauer (in Millisekunden), die das Lesegerät wartet, bevor es erneut versucht, eine Verbindung herzustellen.


Was wird übertragen, wenn ein Code nicht druckbare Zeichen enthält?

Normalerweise werden bei nicht druckbaren Zeichen die Rohwerte übertragen.


Reparatur und Support


Was ist „Reparatur und Support“?

Auf der Seite „Reparatur und Support“ können Sie die Netzwerkeinstellungen falsch konfigurierter Netzwerkgeräte einrichten sowie den HID-Modus serieller Geräte in CDC ändern.


Wozu dient die Option „Aktualisieren“?

Mit Aktualisieren aktualisieren Sie die Liste der verfügbaren Geräte.


Wie wird der Liste der angezeigten Geräte ein Netzwerkgerät hinzugefügt?

Klicken Sie auf Netzwerkgerät hinzufügen, um ein Netzwerkgerät hinzuzufügen oder die IP-Adresse eines bereits hinzugefügten Geräts zu ändern. Daraufhin wird das Dialogfenster Netzwerkgerät hinzufügen geöffnet. Hier können Sie die IP-Adresse des Geräts eingeben. Klicken Sie auf OK, um die Änderungen zu speichern. Das Gerät wird auch auf der Seite Verbinden angezeigt.


Wie werden die Eigenschaften eines Geräts geändert?

Wählen Sie ein Gerät aus der Geräteliste aus, um die verfügbaren Optionen anzuzeigen. In dem daraufhin angezeigten Fenster können Sie die Netzwerkeinstellungen für das ausgewählte Gerät bearbeiten und eine Authentifizierungsoption festlegen. Klicken Sie auf Übernehmen, um die Änderungen zu speichern.


DataMan-Serien 60, 300, 503, 8000 und DataMan 8000-Basisstation: Wie wird die Option „Gerät hinzufügen“ verwendet?

Mit der Option Gerät hinzufügen können Sie den DataMan der Liste Netzwerkgeräte manuell hinzufügen, sodass Sie das DataMan-Lesegerät bzw. die DataMan Basisstation statt über einen Kommunikationsanschluss am PC über das Ethernet-Netzwerk mit dem Setup Tool verbinden können.

Wenn Sie die Option Gerät hinzufügen verwenden möchten, benötigen Sie die IP-Adresse des Lesegerätes bzw. der Basisstation. Um die IP-Adresse zu ermitteln, die dem Lesegerät bzw. der Basisstation aktuell zugeordnet ist, führen Sie die folgenden Schritte aus:

  1. Stellen Sie über einen RS-232-Anschluss am PC eine Verbindung zwischen Lesegerät bzw. Basisstation und Setup Tool her (COM-Anschluss für das Setup Tool).

  2. Wählen Sie unter Kommunikationseinstellungen die Registerkarte Netzwerk aus.

  3. Kopieren Sie die angezeigte IP-Adresse.

  4. Wechseln Sie zurück zum Fenster Verbindung zum Lesegerät und klicken auf Trennen.

  5. Klicken Sie auf Gerät hinzufügen.

  6. Fügen Sie die IP-Adresse für den DataMan ein.

Klicken Sie nach Ausfüllen der Felder Name und IP-Adresse auf OK. Das Lesegerät bzw. die Basisstation wird unter Netzwerkgeräte in der Liste der verfügbaren Geräte angezeigt und Sie können eine Verbindung mit dem Setup Tool über den Ethernet-Anschluss herstellen.

Beachten Sie, dass der Name des Lesegerätes bzw. der Basisstation von der Funktion Gerät hinzufügen auf dem lokalen Computer gespeichert wird und nicht für andere Computer sichtbar ist, auf denen das Setup Tool ebenfalls ausgeführt wird.


Wozu dient das Exportsymbol?

Durch Klicken auf das Symbol Cognex-Supportdatei exportieren wird eine Cognex-Supportdatei als ZIP-Datei generiert, die eine Sammlung voreingestellter Datenprotokolle enthält. Diese Funktion ist nur verfügbar, wenn mindestens ein Gerät ausgewählt ist.

Klicken Sie auf die Schaltfläche, um ein Dialogfenster zu öffnen, in dem Sie die Datentypen angeben können, die in der ZIP-Supportdatei enthalten sein sollen:

  1. CFG

  2. CDC

  3. Letztes Bild

  4. Erkannte Geräte

  5. Gerätestatistik

  6. Speicherstatistik

  7. Benutzerkommentar (kann durch den Benutzer manuell bearbeitet werden)

Über das Symbol „...“ können Sie den Zielordner der Supportdatei ändern. Sie können festlegen, ob der enthaltene Ordner nach Generierung der Datei geöffnet oder diese als Anhang mit dem Standard-E-Mail-Client (.eml) gesendet werden soll.

Der Prozess gibt eine ZIP-Datei aus. Der Dateiname enthält den Gerätenamen und das Datum der Erstellung. Eine zusätzliche descriptor.xml-Datei in der ZIP-Datei enthält folgende Daten:

  1. Datum

  2. Erkennungs-ID

  3. Gerätename

  4. Gerätetyp

  5. Seriennummer

  6. MAC-Adresse

  7. Feature Keys

  8. Kommunikationsschnittstelle

  9. Firmwareversion

  10. Liste der in der ZIP enthaltenen Dateien


Wozu dient die Schaltfläche „Virtuelles Gerät hinzufügen“?

Mit dieser Funktion können Sie anhand einer Datei mit einer benutzerdefinierten Konfiguration oder anhand einer Standardkonfiguration ein virtuelles Gerät erstellen. Mit diesem Gerät können Sie Fenster im Setup Tool anzeigen, ohne eine Verbindung mit einem physischen Gerät herstellen zu müssen. Klicken Sie auf die Schaltfläche, um einen Assistenten zu starten, der Sie durch die Schritte zum Erstellen eines virtuellen Gerätes führt. Startoptionen zum Erstellen sind die Verwendung einer Konfigurations-/Backupdatei oder die Verwendung der werkseitigen Standardeinstellungen.

Nachdem der Assistent beendet ist, wird der Liste der erkannten Geräte ein neues virtuelles Gerät hinzugefügt, das mit einem entsprechenden Symbol als ein solches gekennzeichnet ist. Das erstellte virtuelle Gerät ist für andere Geräte im Netzwerk nicht sichtbar. Das virtuelle Gerät bleibt über mehrere Instanzen des Setup Tools erhalten.

Das erstellte virtuelle Gerät wird genauso wie ein physisches Gerät verbunden, mit der Ausnahme, dass alle Konfigurationsänderungen abgelehnt werden (alle Einstellungen sind schreibgeschützt) und mit virtuellen Geräten keine Funktionen oder Aktionen möglich sind.


Backup


Wie wird die Backupfunktion verwendet?

Mithilfe dieser Funktion können Sie eine Backupdatei erstellen, die die Konfiguration und die Protokolle eines oder mehrerer Lesegeräte enthält. Klicken Sie dazu auf die Schaltfläche Backup unten rechts (oder drücken Sie ALT+B). Diese Funktion ist nur verfügbar, wenn mindestens ein Gerät ausgewählt ist.

Klicken Sie auf die Schaltfläche Backupordner öffnen, um zu dem Ordner zu navigieren, in dem die Backupdateien gespeichert werden. Den Ordner können Sie unter Startseite -> Optionen -> Speicherort Backup festlegen.

Bei Auswahl mehrerer Geräte wird für jedes Gerät eine Backupdatei generiert. Die einzelnen Backupdateien werden in Unterordnern gespeichert, die dem Gerätenamen entsprechen. Der Backupdateiname enthält den Gerätenamen und das Datum der Generierung.

Backupdateien sind ZIP-Dateien mit DMB-Erweiterung. Die Datei enthält Folgendes: config.cdc, config.cfg und descriptor.xml. Die XML-Datei enthält folgende Daten:

  1. Datum

  2. Erkennungs-ID

  3. Gerätename

  4. Gerätetyp

  5. Seriennummer

  6. MAC-Adresse

  7. Feature Keys

  8. Kommunikationsschnittstelle

  9. Firmwareversion

  10. Liste der in der ZIP enthaltenen Dateien


Wo wird der Backupordner für die Backupfunktion festgelegt?

Sie können den Ordner unter Startseite -> Optionen -> Speicherort Backup festlegen.


Wiederherstellen


Wie wird die Wiederherstellungsfunktion verwendet?

Mit der Wiederherstellungsfunktion können Sie gesicherte Konfigurationsdateien eines oder mehrerer Geräte wiederherstellen. Diese Funktion ist nur verfügbar, wenn mindestens ein Gerät ausgewählt und eine gültige Konfigurationsquelle angegeben ist.

Unter Konfigurationsquelle im oberen Bereich können Sie die Quelle angegeben, die das Setup Tool zur Wiederherstellung verwendet:

  1. Konfigurationsdatei: Bei Auswahl dieser Option verwendet das Setup Tool für die Wiederherstellung die angegebene Konfigurationsdatei. Klicken Sie auf das Symbol „...“, um den Ordner anzugeben, der die Backupdatei enthält, die Sie verwenden möchten. Unter den Fragen und Antworten zu Backup finden Sie weitere Informationen dazu, wie dieser Ordner festgelegt wird.

    Hinweis: Die Schaltfläche Wiederherstellen ist nur verfügbar, wenn als Ziel ein kompatibles Gerät ausgewählt ist.

  2. Gerät: Bei Auswahl dieser Option verwendet das Setup Tool ein angegebenes Einzelgerät, dessen Konfiguration auf allen Zielgeräten wiederhergestellt wird.

  3. Neuestes Backup: Bei Auswahl dieser Option sucht das Setup Tool nach dem neuesten Backup für das ausgewählte Gerät. Sind mehrere Geräte ausgewählt, wird für jedes Gerät das jeweils letzte Backup verwendet.

  4. Werkseinstellungen: Bei Auswahl dieser Option stellt das Setup Tool die werkseitige Konfiguration wieder her.

Wenn Sie die Quelle und eines oder mehrerer Zielgeräte ausgewählt haben, klicken Sie auf die Schaltfläche Wiederherstellen unten rechts.


Wozu dient das Drop-down-Menü „Mit Netzwerkeinstellungen wiederherstellen“?

Mit Netzwerkeinstellungen wiederherstellen führt dieselbe Funktion wie die Schaltfläche Wiederherstellen aus, stellt die Konfiguration jedoch aus der im Backupordner enthaltenen CDC-Datei wieder her und nicht aus der CFG-Datei. Diese Option ist nur aktiviert, wenn die angegebene Quelle eine CDC-Datei enthält und die Zielauswahl nur ein Gerät umfasst.


Firmware aktualisieren


Wie wird die Firmware des Lesegerätes aktualisiert?

Wählen Sie System -> Firmware aktualisieren und dann die Firmware-Datei aus.

Hinweis: Die Firmware-Dateien werden als komprimierte Archive zur Verfügung gestellt. Die Firmware muss in komprimierter Form hochgeladen werden. Versuchen Sie nicht, eine Firmware-Datei vor dem Hochladen zu dekomprimieren.


Wie wird die Funktion „Firmware aktualisieren“ verwendet?

Mit dieser Funktion werden die ausgewählten Geräte auf die gewünschte Firmwareversion aktualisiert. Wählen Sie in der Liste die Geräte aus, die Sie aktualisieren möchten.

Klicken Sie auf das Symbol „...“, um nach Firmwaredateien zu suchen. Ist in der Geräteliste nur ein Gerät ausgewählt, wird der zugehörige Firmwareordner für das Gerät geöffnet. Bei Auswahl mehrerer Geräte mit derselben Firmware-Geräte-ID wird der entsprechende Ordner geöffnet. Sind keine oder mehrere Geräte mit unterschiedlicher Firmware-Geräte-ID ausgewählt, wird der Firmwarestammordner geöffnet.

Bei Auswahl der Option im unteren Bereich sichert das Setup Tool Konfigurationsdateien auf dieselbe Weise wie die Funktion Backup (weitere Informationen unter den Fragen und Antworten zu Backups).

Klicken Sie nach Auswahl der Firmwaredatei unten rechts auf Firmware aktualisieren. Diese Schaltfläche ist nur aktiviert, wenn die ausgewählte Firmwareversion und die Geräteauswahl kompatibel sind.

Hinweis: Serielle Geräte müssen zunächst durch manuelles Aktualisieren erkannt werden, bevor die Firmware aktualisiert werden kann.


Konfiguration vergleichen


Konfiguration vergleichen: Allgemeine Anordnung und Struktur

Konfiguration vergleichen ist eine Tabellenansicht, in der Sie Gerätekonfigurationen festlegen, kopieren, vergleichen oder wiederherstellen können. Der Hauptbereich der Dokumentenseite enthält ein Raster mit den Eigenschaften des Gerätes, das vor dem Initiieren auf der Seite Verbindung zum Lesegerät ausgewählt wurde.

Für jeden Dokumententyp des Setup Tools wird eine eigene Verbindung verwendet. Bei serieller Kommunikation kann jeweils immer nur eine Verbindung bestehen.

In der Kopfzeile werden die Namen der ausgewählten Geräte angezeigt. In der unteren Kopfzeile werden die für das Gerät verfügbaren Setups angezeigt. Die Zeilenköpfe (fett markiert) können per Klick auf das Symbol neben ihnen reduziert bzw. erweitert werden. Für getrennte Geräte wird in der Kopfzeile ein Symbol zum Wiederherstellen der Verbindung angezeigt.

Einstellungen, die nicht vom Lese-Setup abhängen, werden nur in der ersten Spalte angezeigt (Haupt-Setup).


Konfiguration vergleichen: Steuerung (Maus und Tastatur)

Auswahl:

  • Maus: Sie wählen eine Rasterzelle aus, indem Sie darauf klicken. Dadurch werden der Zeilenkopf der Zelle und die Spaltenköpfe zu Lesegerät und Setup markiert. Die Menüschaltflächen und -elemente im Menübandmenü können sich je nach Auswahl ändern. Wenn sich die ausgewählte Zelle in einer Kopfzeile befindet, werden alle Zellen in der aktuellen Spalte ausgewählt, die zu der Kopfzeile gehören.

  • Tastatur: Über die Tasten zum Bewegen des Cursors können Sie die gewünschte Zelle auswählen. Das Markierungs- und Auswahlverhalten entspricht dem mit einer Maus.

Hinzufügen/Ändern von Werten:

  • Maus: Bei Zellen mit integrierten Editors können Sie Werte eingeben, indem Sie auf die Editorsteuerung (Kombinationsfeld, Kontrollkästchen, numerisches Auf-Ab-Steuerelement) klicken. Bei Zellen mit benutzerdefinierten Editors (Symbol „...“), wird ein Pop-up-Editor geöffnet, in dem Sie Werte eingeben können.

  • Tastatur: Bei Zellen mit integrierten Editors starten Sie durch Drücken der Eingabetaste oder der Taste F2 den Bearbeitungsmodus. Mit Esc brechen Sie die Bearbeitung ab. Um eine Bearbeitung zu bestätigen, drücken Sie die Eingabetaste ein zweites Mal. Sie können Werte in ausgewählten Text eingeben, ohne in den Bearbeitungsmodus zu wechseln. In diesem Fall wird der aktuelle Wert mit dem ersten Tastaturanschlag überschrieben.

    Bei numerischen Zellen können Sie zusätzlich zu den integrierten Texteditorzellen den Wert über die Auf- und Abwärtspfeile erhöhen bzw. verringern.

    Bei Drop-down-Zellen wechseln Sie durch Drücken der Eingabetaste in den Bearbeitungsmodus. Daraufhin werden die Drop-down-Elemente angezeigt. Mit den Auf- und Abwärtspfeilen können Sie die Auswahl verschieben. Wenn Sie die Eingabetaste erneut drücken, wird der ausgewählte Wert übernommen. Drücken Sie Esc, um die Bearbeitung abzubrechen.

    Bei Zellen mit Kontrollkästchen können Sie über die Leertaste zwischen aktiviertem und deaktiviertem Status wechseln.

Kopieren und Einfügen:

Verwenden Sie zum Kopieren und Einfügen die Tastenkombinationen STRG+C und STRG+V. Weitere Informationen können Sie der Beschreibung für Kopieren und Einfügen der entsprechenden Menüelemente im Menübandmenü entnehmen.


Konfiguration vergleichen: Menübandmenü

Das Menübandmenü befindet sich über dem Tabellenansichtsraster. Inhalte und aktive Symbole können sich je nach den im Raster ausgewählten Zellen, Zeilen oder Spalten ändern. Das Menü ist in verschiedene Gruppen unterteilt.

  • Gerät: Die Einstellungen in dieser Gruppe gelten für Geräte und ihre Konfigurationsdateien. Über die Schaltfläche Gerät hinzufügen ... öffnen Sie ein Dialogfenster, in dem Sie eines oder mehrere Geräte zum Vergleichen auswählen können. Über die Schaltfläche Konfigurationsdatei hinzufügen ... starten Sie einen Assistenten, über den Sie nach einer Konfigurations- oder Backupdatei suchen können (.dmb, .cdc, .cfg). Enthält die ausgewählte Datei für das Gerät nicht alle erforderlichen Informationen, müssen die fehlenden Parameter festgelegt werden. Andernfalls werden automatisch die Standardoptionen ausgewählt. Dasselbe gilt für Fälle, in denen die Datenbank für virtuelle Geräte Parameter den verfügbaren Optionen nicht zuordnen kann (z. B., wenn keine passende Firmwareversion gefunden wird).

    Hinweis: Hinzugefügte virtuelle Geräte sind schreibgeschützt. Dies wird durch das Schlosssymbol in der zugehörigen Kopfzeile angezeigt.

    Durch Klicken auf die Schaltfläche Gerät entfernen entfernen Sie die aktuell ausgewählten Geräte (die Geräte, die die aktuell ausgewählten Zellen enthalten). Über Geräteneustart starten Sie die ausgewählten Geräte neu. Mit Konfiguration auf Gerät speichern speichern Sie die Konfigurationsdatei auf dem ausgewählten Gerät im Flash-Speicher. Über Auf Werkseinstellungen zurücksetzen setzen Sie die ausgewählten Geräte auf die Standardeinstellungen zurück.

  • Bearbeiten: Mit Kopieren (oder STRG+C auf der Tastatur) können Sie einen Wert aus der aktuell ausgewählten Zelle kopieren. Einfügen kann nur in derselben Zeile oder in einem Texteditor verwendet werden. Mit Werte zurücksetzen setzen Sie die Werte der ausgewählten Zellen zurück.

  • Markieren: Über die Schaltflächen und Einstellungen in dieser Menügruppe können Sie bestimmte Zellenhintergründe markieren. Bei der Einstellung Nicht-Standardwerte werden Zellen mit anderen als den Standardwerten markiert (diese können in ein und derselben Zeile für verschiedene Lese-Setups oder Geräte unterschiedlich sein). Bei der Einstellung Differenz zur Referenz werden Zellen markiert, die einen anderen Wert als die Zelle des Referenz-Lese-Setups (und -Geräts) in derselben Zeile haben. Bei Auswahl der dritten Einstellung werden alle Werte und Kopfzeilen markiert, die den im Textfeld angegebenen Text enthalten. Zusätzlich ist auch der enthaltene Text als solcher durch einen anderen Texthintergrund markiert. Drücken Sie die Eingabetaste, um auch die Funktion der Schaltfläche Nur markierte Zeilen anzeigen anzuwenden.

    Bei Auswahl von Nur markierte Zeilen anzeigen werden alle Knoten reduziert, die keinen markierten Unterknoten enthalten. Mit Referenz-Lese-Setup festlegen legen Sie das Lese-Setup (und das Gerät) fest, das bei Verwendung des Markierungsmodus Differenz zur Referenz als Referenz verwendet wird. Ist diese Schaltfläche aktiv, wird die Spalte (Lese-Setup) der aktuell ausgewählten Zelle als Referenz-Setup festgelegt. Das aktuelle Referenz-Setup ist in der Kopfzeile mit dem Setup-Namen gekennzeichnet.

  • Filterung: Über Lese-Setup-Einstellungen können Sie die Anzeige auf die Einstellungen einschränken, die vom Lese-Setup abhängen. Wählen Sie Allgemeine Einstellungen aus, um nur Einstellungen anzuzeigen, die keine abweichenden Werte für verschiedene Lese-Setups haben können. Wählen Sie Alle Einstellungen aus, um alle Einstellungen auf einmal anzuzeigen. Wenn ein Eintrag Werte in mehreren Lese-Setups hat, werden diese in mehreren Spalten angezeigt.

  • Sonstige: Mit Alle Zeilen erweitern erweitern Sie alle Zeilen, die im Raster reduziert sind. Mit Alle Zeilen reduzieren reduzieren Sie alle Zeilen, die im Raster erweitert sind. Mit Anordnung zurücksetzen werden die Spaltenbreiten neu berechnet, sodass der gesamte verfügbare Platz genutzt wird. Reicht der verfügbare Platz nicht aus, wird eine Spaltenmindestbreite verwendet.


Konfiguration vergleichen: Editorvergleich

Wenn Sie auf das Symbol ... klicken, wird für jedes Skripterstellungselement in der Tabellenansicht „Konfiguration vergleichen“ der Editorvergleich geöffnet (in allen Unterkategorien). Danach wird die Skriptquelle des Gerätes angezeigt, für das der Editorvergleich geöffnet wurde.

Klicken Sie auf Standard, um das Skript auf das Standardskript für das betreffende Gerät zurückzusetzen. Durch Klicken auf Vergleich wird das Standardskript auf dem zweiten Gerät rechts angezeigt. Über das Drop-down-Menü oben können Sie ein anderes Skript wählen, um es mit dem Skript auf der linken Seite zu verglichen. Zwischen den beiden Registerkarten wird die Schaltfläche Aktualisieren angezeigt (rote Kreispfeile), über die Sie alle Skripttexte aktualisieren können.

Klicken Sie auf Schließen, um den Vergleich zu schließen und zur Tabellenansicht „Konfiguration vergleichen“ zurückzukehren.


Bildfenster


Wozu dient die Bildanzeige?

In diesem Fenster wird das vom Gerät gelesene Bild angezeigt.

Mit den Lupensymbolen können Sie das Bild jeweils automatisch an die Größe des Bildanzeigefensters anpassen, das Bild vergrößern bzw. verkleinern und das Bild im 1:1-Pixel-Modus anzeigen.

Daneben können Sie die Fokusrückmeldung für das Bild im Live-Anzeige-Modus aktivieren bzw. deaktivieren und das Bild in die Zwischenablage kopieren.

Mit der Option „Bild speichern“ können Sie nur das aktuelle Bild oder alle Bilder einer Bildfolge speichern. Mit den Optionen unter „Protokollierung“ können Sie alle Bilder mit Fehllesung oder alle decodierten Bilder im Dateisystem speichern.

Darüber hinaus können Sie das Histogramm des gelesenen Bildes und die Helligkeitsdaten eines ausgewählten Punkts im Bild prüfen. Verwenden Sie dazu die Schaltflächen im Symbolleistenband in diesem Fenster.


Ergebnisverlauf


Wozu dient der „Ergebnisverlauf“?

In diesem Fenster werden nach einem Lesevorgang die decodierten Informationen angezeigt.

Mit der Schaltfläche Pause können Sie die Ergebnisverlauf-Toolansicht anhalten/einfrieren, sodass Sie besser nach spezifischen Leseinformationen suchen können. Der Ergebnisverlauf lehnt alle vom Gerät eingehenden Ergebnisse ab, bis der angehaltene Zustand beendet wird.

Sie können die Verlaufsliste löschen, indem Sie auf Verlauf löschen klicken. Mit den Optionen Kopieren bzw. Alles kopieren können Sie außerdem eine einzelne decodierte Zeichenkette oder alle Zeichenketten exportieren.

Wenn Sie unter Protokollierung die Option „Codequalitätsberichte generieren“ aktivieren, werden die decodierten Informationen um Codequalitätsdaten ergänzt. Wenn Sie „Datenvalidierungsberichte generieren“ aktivieren, werden Datenvalidierungsinformationen eingeschlossen. Mit „Alle Ergebniscodes im Dateisystem protokollieren“ speichern Sie alle Einträge im Ergebnisverlauf auf der lokalen Festplatte. Klicken Sie auf „Einstellungen Protokollierung und Berichte“, um weitere entsprechende Optionen anzuzeigen.

Mit Anpassen können Sie Tabellenspalten hinzufügen oder entfernen und so die Informationen im Ergebnisverlauf anpassen.

Informationen zur Ergebnisfilterung können Sie der Antwort auf die nächste Frage entnehmen.


Wie funktioniert die Ergebnisfilterung?

Mit der Schaltfläche Filter ... im Menübandmenü der Ergebnisverlauf-Toolansicht können Sie die in der Ansicht angezeigten Leseergebnisse filtern. Klicken Sie auf die Schaltfläche, um die Filterung zu aktivieren. Öffnen Sie durch Klicken auf den rechten Teil der Taste die Optionen, um die Filterparameter festzulegen.

Hinweis: Die Filter-Schaltfläche wird nur angezeigt, sofern das Betriebssystem diese Funktion unterstützt.

In den Filtereinstellungen sind zwei Modi verfügbar: Standardfilterung und erweiterte Filterung. Wählen Sie in dem Drop-down-Menü unter Allgemein einen Modus aus.

Bei der Standardfilterung werden die Filterkategorien in der Drop-down-Liste als aktiv angezeigt („Ergebnisstatus“, „Validierungsmethode“, „Validierungsstatus“ und „Symbologie“). Durch Klicken können Sie in jeder Kategorie einzelne Filter auswählen. Nach der Aktivierung werden diese Filter für alle zukünftigen Elemente im Ergebnisverlauf übernommen, auch rückwirkend. Nicht durch Filter angegebene Elemente werden nicht im Ereignisverlauf angezeigt, bis die Filterung deaktiviert wird. Hinweis: Bei der Standardfilterung wird eine einzige Gut-Lesung in einer Auslösersequenz als Gut-Lesung für die gesamte Auslösersequenz gewertet. Daher ist die Standardfilterung beispielsweise nicht auf Multicode-Szenarien anwendbar. Verwenden Sie für Multicode-Szenarien erweiterte Filterungsskripts.

Bei aktivierter erweiterter Filterung sind die Standardfilterkategorien inaktiv. Stattdessen sind in der Drop-down-Liste die Erweiterten Filtereinstellungen aktiviert. Durch Klicken öffnen Sie ein neues Fenster, in dem Sie Filterausdrücke bearbeiten können. War zuvor ein vordefinierter Filter aktiviert, wird der generierte Ausdruck in diesem Dialog angezeigt. Die Bearbeitung des Ausdrucks wirkt sich nicht rückwirkend auf vordefinierte Filter aus.

Der Filterausdruck an sich ist eine JavaScript-Funktion. Die Verwendung der Datenelemente des Ergebnisses entspricht der Verwendung in der skriptbasierten Formatierung. Das Ergebnis des Ausdrucks wird in dem Fenster unten angezeigt. Bei JavaScript-Fehlern wird im Textfenster eine Fehlermeldung angezeigt. Hinweis: Trotz der Ähnlichkeiten handelt es sich bei der erweiterten Filterung nicht um ein Datenformatierungsskript, sondern nur um einen Anzeigefilter im Setup Tool.


Warum ist das Symbol grün hervorgehoben, obwohl in der Ergebnisverlaufsliste keine Daten angezeigt werden?

Wenn im Fenster Standardformatierung das Kontrollkästchen Standardformatierung aktiviert aktiviert ist, müssen Sie eine benutzerdefinierte Ausgabezeichenkette erstellen. Andernfalls werden keine Ergebnisdaten angezeigt, auch wenn das Lesegerät das Symbol decodiert hat.


Warum wird vor manchen Ergebnissen ein Symbol angezeigt?

Zu Ergebnissen mit einem vorangestellten Symbol gibt es ein gespeichertes Bild. Klicken Sie auf die Ergebniszeile, um den Decodierversuch und das zugehörige Bild anzuzeigen.


Code-Qualität


Wozu dient die Prüffunktion?

Die Prüfung ist eine per Feature Key aktivierte Funktion des DM8600. Sie dient dazu zu beurteilen, ob ein DataMatrix-Symbol die Qualitätsrichtlinie AIM DPM (Direktmarkierung)/ISO/IEC TR 29158 erfüllt.


Wie wird die Prüfung eingerichtet?

Informationen zum Einrichten der Prüfung für den DataMan 8600 Verifizierer sind in der Bedienungsanleitung für mobile Verifizierer der Serie DataMan 8600 in dem Kapitel Erste Schritte enthalten. Dort wird die Erstkalibrierung beschrieben. Nach diesem Vorgang wird auf der Registerkarte Prüfung neben System kalibriert ein grünes Symbol angezeigt. Informationen zum Aufrüsten des DataMan 8600 auf den Verifizierer-Status finden Sie in der Bedienungsanleitung für mobile Verifizierer der Serie DataMan 8600 unter Aufrüsten von Geräten für die Prüfung.

Führen Sie nach der Erstkalibrierung die folgenden Schritte aus, um Symbole zu lesen und Prüfergebnisse anzuzeigen:

  • Navigieren Sie zu Einstellungen > Code-Qualität.

  • Wählen Sie auf der Registerkarte Prüfung die Option Prüfung aktiviert aus.

  • Wählen Sie die Toolansicht für die Code-Qualität aus (Aktivierung durch Klicken auf Code-Qualität unter Ansicht).

  • Platzieren Sie den Verifizierer am Symbol und betätigen Sie die Auslösertaste. Das Symbol muss sich mittig im Sichtfeld befinden und das Lesegerät muss im richtigen Drehwinkel senkrecht zu der Oberfläche montiert sein, auf der sich das Symbol befindet. Um die Anforderungen für Symbolpräsentation und Beleuchtung der Qualitätsrichtlinie AIM-DPM/ISO/IEC TR 29158 zu erfüllen, müssen Sie den Abstandhalter für den Verifizierer verwenden.

  • Bewegen Sie das Lesegerät, bis sich der mittlere Bereich des roten Rechtecks in dem grünen Ausrichtungsrechteck im Bildfenster befindet. Das Lesegerät gibt einen Signalton aus, der anzeigt, dass das Symbol gelesen und geprüft wurde.

Die Prüfergebnisse können Sie im Fenster Toolansicht für die Code-Qualität anzeigen. Für jede Gut-Lesung, die Sie in der Toolansicht Ergebnisverlauf auswählen, werden in der Toolansicht für die Code-Qualität die Prüfmetriken angezeigt. Oben wird der dem gelesenen Code zugeordnete Gesamtgrad angezeigt.

Unter Eigenschaft sind die einzelnen Metriken aufgeführt. Wert ist die Wertdifferenz zwischen dem gelesenen Wert und dem Grenzwert für die einzelnen Metriken. Grad ist der Code-Qualitätsgrad, der der Metrik zugeordnet ist (in dieser Zeile wird auch ein Farbsymbol angezeigt: grün = bestanden, rot = nicht bestanden, gelb = Wert ist Grenzwert). Der Mittelwert basiert auf den letzten 100 Gut-Lesungen für diese Metrik.

Hinweis: Bei der Kalibrierung des Lesegerätes werden nur die aktivierten Beleuchtungsoptionen kalibriert. Die Kalibrierung aller nicht aktivierten Beleuchtungsoptionen wird aufgehoben. Wenn Sie eine nicht kalibrierte Beleuchtungsoption aktivieren, wird das Gerät dekalibriert. Falls Sie eine Prüfung mit einem nicht kalibrierten Lesegerät durchführen, ertönt ein Fehlersignalton und die Symbole werden nicht geprüft. Kalibrieren Sie das Gerät neu, um die Prüfung erneut ausführen zu können.

Weitere Informationen zur Verwendung der Ergebnisse bei der Datenformatierung sind in der Bedienungsanleitung für mobile Verifizierer der Serie DataMan 8600 enthalten.


Welche sonstigen Optionen enthält die Registerkarte „Prüfung“?

Derzeit wird AIM-DPM/ISO/IEC TR29158 für die Prüfung unterstützt. Im Bereich „Qualitätsmetriken“ auf der Registerkarte können Sie den Mindestgrad für Bestanden festlegen. Bei dieser Einstellung handelt es sich um den Mindestgrad, den die Prüfung bei der Bewertung der Symbolmetriken zum Bestehen vergibt. Bei Auswahl von Grafiken aktiviert werden im Bildfenster in problematischen Bereichen des gelesenen Codes skalierbare Vektorgrafiken angezeigt.

Weitere Informationen zu sonstigen Einstellungen finden Sie unten.


Was ist die Prozesssteuerung?

Prozesssteuerungsmetriken liefern Feedback über die gemessene Zellengröße der einzelnen Zellen eines 2D-DataMatrix-Symbols. Bei aktivierten Prozesssteuerungsmetriken kann das Lesegerät feststellen, ob bei aufeinanderfolgenden Symbolen eine Änderung der Zellengröße auftritt oder ob die Zellengröße konstant bleibt.

Zur Verwendung der Prozesssteuerungsmetriken muss das Lesegerät kalibriert sein.

Bei aktivierter Prozesssteuerung werden in der Toolansicht für die Code-Qualität eventuelle Zellenentwicklungen in der vorliegenden Markierung angezeigt. Anhand dieser Meldungen können Sie Änderungen bei der Zellenentwicklung über einen gegebenen Zeitraum verfolgen.


Wie kann bei Verwendung der AIM-DPM- und ISO/IEC 15415-Metriken ein Grenzwert für Bestanden/Nicht bestanden festgelegt werden?

Wählen Sie in der Einstellung Mindestgrad für Bestanden den gewünschten Grad aus. Für die beiden Metriken sind verschiedene Gültig-Grade möglich.


Welche Beleuchtungseinstellung sollten ausgewählt werden?

Bei verschiedenen Markierungstypen und -oberflächen kann die Verwendung unterschiedlicher Beleuchtungsquellen hilfreich sein. Die fest montierte Beleuchtungsvorrichtung unterstützt Hellfeldbeleuchtung für kontrastreiche Symbole auf nicht reflektierenden Objekten ebenso wie Dunkelfeldbeleuchtung für kontrastarme Symbole auf reflektierenden Oberflächen. Sie können jede beliebige Kombination auswählen, die zuverlässige Ergebnisse beim Code-Qualitätsgrad liefert.

Beachten Sie, dass die einzelnen Bänke der fest montierten Beleuchtungsvorrichtung an unterschiedliche Ausgangsleitungen am erweiterten I/O-Modul angeschlossen werden müssen:

  • Hellfeld – diffus senkrecht (90): I/O-Leitungen 2, 3

  • Dunkelfeld – 30 Grad alle Quadranten (30Q): I/O-Leitungen 4, 5, 6, 7

  • Dunkelfeld – 30 Grad O-W-Quadranten (30T): I/O-Leitungen 4, 6

  • Dunkelfeld – 30 Grad N-S-Quadranten (30T): I/O-Leitungen 5, 7


Wie wird überprüft, ob ein DataMan 8600-Gerät für die Symbolprüfung lizenziert ist?

Führen Sie die folgenden Schritte aus, um festzustellen, ob Ihr DataMan 8600-Gerät Symbolprüfungen durchführen kann:

  1. Stellen Sie im Setup Tool eine Verbindung zum DataMan 8600 her.

  2. Wählen Sie in der Menüleiste Ansicht -> Systeminformationen aus.

  3. Suchen Sie in der Liste der Feature Keys nach dem Schlüssel Verification.

    Wenn der Schlüssel Prüfung vorhanden ist, kann Ihr DataMan 8600-Gerät Symbolprüfungen durchführen.


Welche maximale DataMatrix-Fläche kann von einem DataMan Verifizierer geprüft werden?

Es kann maximal eine Fläche von 1,5" x 1,5" (38 x 38 mm) geprüft werden.


Wie führt das Lesegerät die Prüfung durch, wenn mehrere Beleuchtungskonfigurationen aktiviert sind?

Das Gerät beginnt mit der ersten ausgewählten Beleuchtungskonfiguration und fährt so lange fort, bis der Gesamtgrad „Bestanden“ erreicht ist. Falls bei keiner der ausgewählten Beleuchtungskonfigurationen der Grad „Bestanden“ erreicht wird, werden dem Benutzer das Bild und die Grafiken der Konfiguration mit dem besten Gesamtgrad gemeldet. Der Grad „Bestanden“ wird bei AIM-DPM/ISO/IEC TR 29158 und ISO 15415 über den Parameter Mindestgrad für „Bestanden“ gesteuert. Die AS9132-Qualitätsmetriken erzeugen selbst einen Symbolgrad, der entweder „Bestanden“ oder „Nicht bestanden“ lautet.


Was bedeuten die einzelnen AIM-DPM-Code-Qualitätsmetriken?

Die Code-Qualitätsergebnisse enthalten detaillierte Informationen zur Qualität eines Symbols gemäß dem Standard der Association for Automatic Identification and Mobility (AIM) für 2D-DataMatrix-Symbole. Alle DataMan Verifier ermitteln einen Gesamtgrad für jedes geprüfte Symbol sowie Einzelgrade für die folgenden Metriken:

  • Zellenmodulation: Kennzahl für die Lesbarkeit der geprüften Markierung.

    Der Grad gibt an, wie weit sich die hellen und dunklen Zellen einer bestimmten Markierung einem globalen Grenzwert annähern, der den Graustufen-Separationspunkt zwischen hellen Zellen und dunklen Zellen jeder Markierung bildet.

    Eine Markierung erhält einen niedrigen Grad bei der Zellenmodulation, wenn dem Lesegerät eine relativ geringe Fähigkeit zur Klassifizierung einzelner Zellen als hell oder dunkel unterstellt wird. Beim Grad wird auch die Fehlerkorrekturkapazität berücksichtigt, die das Symbol beinhaltet (größere Symbole bieten eine höhere Fehlerkorrekturkapazität). Beispielsweise erhält eine Markierung einen niedrigen Grad bei der Zellenmodulation, aber einen hohen Grad bei der Metrik für Nicht verwendete Fehlerkorrektur, wenn sich die meisten Zellen kurz vor einem Wechsel ihres Status befinden, dieser tatsächlich aber nicht eintritt.

  • Fehler im festen Raster: Die Qualität der Finder-, Takt- und Ruhezonenmuster innerhalb der Markierung.

    Das Lesegerät lokalisiert und decodiert die in einem Symbol enthaltenen Daten anhand verschiedener Muster. Der vom Lesegerät generierte Grad für Fehler im festen Raster wird mit derselben Methode erzeugt wie der Grad für Zellenmodulation, insbesondere eine Kennzahl zur Messung der Reflektanz.

  • Referenzdecodierung: Angabe, ob diese Markierung vom standardmäßigen 2D-DataMatrix-Algorithmus gefunden und decodiert werden konnte.

    Diese Metrik wird durch den Grad A oder F ausgedrückt.

  • Zellenkontrast: Kennzahl für den Reflektanzunterschied zwischen hellen und dunklen Zellen im Symbol, ausgedrückt als Prozentsatz des mittleren Reflektanzwerts der hellen Zellen.

    Gemäß AIM-DPM/ISO/IEC TR 29158-Spezifikation muss das Bild so angepasst werden, dass die hellen Zellen einen mittleren Reflektanzwert von 78 % der vollständigen Sättigung aufweisen.

  • Axiale Ungleichförmigkeit: Kennzahl für die Symmetrie der einzelnen Zellen des Symbols.

  • Nicht verwendete Fehlerkorrektur: Kennzahl für den Prozentsatz von Code-Wörtern, die nach der Fehlerkorrektur in einem Symbol übrig sind.

    Bei der Berechnung des Werts für die Nicht verwendete Fehlerkorrektur wird ein Code-Wort als fehlerhaft betrachtet, wenn mindestens eine seiner Zellen den globalen Grenzwert überschritten hat. 2D-DataMatrix-Symbole weisen eine integrierte Code-Redundanz auf, d. h., Daten sind doppelt vorhanden.

    Der Wert 1.00 bedeutet, dass in keinem der Code-Wörter ein Fehler gefunden wurde.

  • Rasterungleichförmigkeit: Kennzahl für die Anzahl von Positionsabweichungen einzelner Zellen von einem gleichförmigen Raster, gemessen anhand des Taktmusters eines Symbols.

  • Zellenentwicklung: Kennzahl für Änderungen bei der Zellenentwicklung in horizontaler und vertikaler Richtung.

    Die Zellengröße wird unabhängig entlang der horizontalen (ZZH) und vertikalen (ZZV) Taktmuster des Symbols gemessen und mit ihren physischen Abmessungen angegeben.

    Diese Metrik wird nicht zur Generierung des Symbolgrads insgesamt verwendet, sondern nur für die Prozesssteuerung. Sie ist nur bei aktivierter Bewertung der Code-Qualität im Fenster Code-Qualität verfügbar.


Wie wird zusammen mit dem Bild ein Bericht mit den Prüfergebnissen zu einem bestimmten Symbol erstellt?

  1. Wählen Sie unter Optionen die Option Datenprotokollierung aus.

  2. Rufen Sie Berichte auf. Sie können den Speicherort angeben, an dem das DataMan Setup Tool die Berichte speichert. Außerdem können Sie ein Schema für den Namen der Datei angeben, ein Dateinamenspräfix festlegen und die überlagernden Grafiken in den Berichten deaktivieren.

    Das Präfix wird vom DataMan Setup Tool jedoch nicht auf gültige Zeichen überprüft. Bei Verwendung eines ungültigen Zeichens, z. B. eines Doppelpunkts (:), wird der Bericht vom DataMan Setup Tool nicht erzeugt.

  3. Wählen Sie in der Toolansicht Ergebnisverlauf unter Protokollierung unbedingt Codequalitätsberichte generieren aus.

Wenn das Lesegerät mit dem DataMan Setup Tool verbunden ist, werden automatisch Berichte zu jedem erfolgreich gelesenen Symbol am angegebenen Dateispeicherort erzeugt.


Wozu dient die Registerkarte „Code-Qualität“?

Anhand der Code-Qualität können Sie prüfen, ob die verwendeten Symbole die Qualitätsrichtlinien nach einem von Cognex unterstützten Code-Qualitätsstandard erfüllen. Codes werden nach Bewertung der ausgewählten oder (standardmäßig) aller Metriken für einen gegebenen Code-Qualitätsstandard mit einem Gesamtgrad bewertet. Die Code-Qualität wird per Feature Key aktiviert.

Ausführliche Informationen zu den einzelnen Code-Qualitätsstandards und den zugehörigen Metriken können Sie der Kommunikations- und Konfigurationsanleitung oder der Dokumentation der entsprechenden ISO-Norm entnehmen, die unter www.iso.org abgerufen werden kann.


Wie wird das Fenster „Allgemein“ verwendet?

Das Fenster Code-Qualität ist ein zentraler Ort zur Aktivierung der Code-Qualitätsprüfung für verschiedene Code-Typen: 1D-Barcodes, DataMatrix, QR-Codes und Dotcode. Sie können für jeden dieser Symbologietypen angeben, mit welchem Code-Qualitätsstandard das Lesegerät die gelesenen Codes prüfen soll.

Nach Aktivierung der Code-Qualitätsbewertung zeigt das Gerät Qualitätsergebnisse zu jedem gelesenen Symbol an, für das bei der Skripterstellung die Code-Qualität aktiviert wurde.


Toolansicht für die Code-Qualität


Was wird in der Toolansicht für die Code-Qualität angezeigt?

In der Toolansicht für die Code-Qualität können Sie die Prüfergebnisse anzeigen. Um die Ergebnisse hier anzeigen zu können, muss die Prüfung zuvor im Fenster Code-Qualität (Feature Key erforderlich) aktiviert werden. Für jede Gut-Lesung, die Sie in der Toolansicht Ergebnisverlauf anzeigen, werden in der Toolansicht für die Code-Qualität die Prüfmetriken angezeigt. Oben wird der dem gelesenen Code zugeordnete Gesamtgrad angezeigt.

Unter Eigenschaft sind die einzelnen Metriken aufgeführt. Wert ist die Wertdifferenz zwischen dem gelesenen Wert und dem Grenzwert für die einzelnen Metriken. Grad ist der Code-Qualitätsgrad, der der Metrik zugeordnet ist (in dieser Zeile wird auch ein Farbsymbol angezeigt: grün = bestanden, rot = nicht bestanden, gelb = Wert ist Grenzwert). Der Mittelwert basiert auf den letzten 100 Gut-Lesungen für diese Metrik.

Weitere Informationen zur Prüfung können Sie der Bedienungsanleitung für mobile Verifizierer der Serie DataMan 8600 entnehmen.


Lese-Setups


Wie werden Setups verwaltet?

Der DM8600 verwendet eine Reihe fester Lese-Setups. Sie können die einzelnen Lese-Setups über das Kontrollkästchen Aktivieren für jedes Lese-Setup unter der Menübandleiste aktivieren bzw. deaktivieren.

Hinweis: Änderungen an einem Lese-Setup werden nicht automatisch für die anderen aktiven Lese-Setups übernommen.


Wozu dient die Option „Start-Setup“?

Bei Aktivierung mehrerer Setups prüft das Lesegerät die einzelnen Setups und stoppt die Bilderfassung, sobald ein Code gelesen wurde. Sie können festlegen, ob das Lesegerät für den nächsten Code bei einem bestimmten Setup oder dem Setup der letzten Gut-Lesung beginnen soll.


Wozu dient das Feld „Filter“ im oberen Bereich?

Sie können einen Parameter eingeben, nach dem Sie suchen möchten, beispielsweise „Größe“ oder „Bildfolge“. Drücken Sie dann die Eingabetaste. Die gefundenen Elemente werden markiert und nur Parameterknoten, die die gesuchten Elemente enthalten, werden erweitert. Sie können die Suche beenden, indem Sie die Eingabe löschen und die Eingabetaste drücken.


Welches Setup wird verwendet?

Mit dem Setup Universal können die meisten Codes gelesen werden. Mit den anderen Setups können spezielle und schwierig zu lesende Code-Markierungen entziffert werden.

  • Gewölbte Oberfläche ist ideal für Markierungen auf konvexen, reflektierenden und teilweise reflektierenden Objekten.

  • Nadelprägung schwierig unterstützt das Lesen von Präge-Codes, deren Prägemarkierungen auf einer unebenen Fläche, klein oder undeutlich sind.

  • Uneinheitliche Oberfläche ist ideal für Anwendungen, bei denen die Oberfläche des Prüfteils uneinheitlich ist und gerichtete Beleuchtung auf die Achse der Unebenheit erfordert.


Lese-Setups: Allgemeine Anordnung und Struktur

Die Lese-Setups sind eine Tabellenansicht, in der Sie Lese-Setups festlegen, kopieren, vergleichen oder wiederherstellen können. Der Hauptbereich der Dokumentenseite enthält ein Raster mit den Geräteeigenschaften.

In der Kopfzeile werden die Namen der ausgewählten Geräte angezeigt. In der unteren Kopfzeile werden die für das Gerät verfügbaren Setups angezeigt. Die Zeilenköpfe (fett markiert) können per Klick auf das Symbol neben ihnen reduziert bzw. erweitert werden. Für getrennte Geräte wird in der Kopfzeile ein Symbol zum Wiederherstellen der Verbindung angezeigt.


Lese-Setups: Steuerung (Maus und Tastatur)

Auswahl:

  • Maus: Sie wählen eine Rasterzelle aus, indem Sie darauf klicken. Dadurch werden der Zeilenkopf der Zelle und die Spaltenköpfe zu Lesegerät und Setup markiert. Die Menüschaltflächen und -elemente im Menübandmenü können sich je nach Auswahl ändern. Wenn sich die ausgewählte Zelle in einer Kopfzeile befindet, werden alle Zellen in der aktuellen Spalte ausgewählt, die zu der Kopfzeile gehören.

  • Tastatur: Über die Tasten zum Bewegen des Cursors können Sie die gewünschte Zelle auswählen. Das Markierungs- und Auswahlverhalten entspricht dem mit einer Maus.

Hinzufügen/Ändern von Werten:

  • Maus: Bei Zellen mit integrierten Editors können Sie Werte eingeben, indem Sie auf die Editorsteuerung (Kombinationsfeld, Kontrollkästchen, numerisches Auf-Ab-Steuerelement) klicken. Bei Zellen mit benutzerdefinierten Editors (Symbol „...“), wird ein Pop-up-Editor geöffnet, in dem Sie Werte eingeben können.

  • Tastatur: Bei Zellen mit integrierten Editors starten Sie durch Drücken der Eingabetaste oder der Taste F2 den Bearbeitungsmodus. Mit Esc brechen Sie die Bearbeitung ab. Um eine Bearbeitung zu bestätigen, drücken Sie die Eingabetaste ein zweites Mal. Sie können Werte in ausgewählten Text eingeben, ohne in den Bearbeitungsmodus zu wechseln. In diesem Fall wird der aktuelle Wert mit dem ersten Tastaturanschlag überschrieben.

    Bei numerischen Zellen können Sie zusätzlich zu den integrierten Texteditorzellen den Wert über die Auf- und Abwärtspfeile erhöhen bzw. verringern.

    Bei Drop-down-Zellen wechseln Sie durch Drücken der Eingabetaste in den Bearbeitungsmodus. Daraufhin werden die Drop-down-Elemente angezeigt. Mit den Auf- und Abwärtspfeilen können Sie die Auswahl verschieben. Wenn Sie die Eingabetaste erneut drücken, wird der ausgewählte Wert übernommen. Drücken Sie Esc, um die Bearbeitung abzubrechen.

    Bei Zellen mit Kontrollkästchen können Sie über die Leertaste zwischen aktiviertem und deaktiviertem Status wechseln.

Kopieren und Einfügen:

Verwenden Sie zum Kopieren und Einfügen die Tastenkombinationen STRG+C und STRG+V. Weitere Informationen können Sie der Beschreibung für Kopieren und Einfügen der entsprechenden Menüelemente im Menübandmenü entnehmen.


Lese-Setups: Menübandmenü

Das Menübandmenü befindet sich über dem Tabellenansichtsraster. Inhalte und aktive Symbole können sich je nach den im Raster ausgewählten Zellen, Zeilen oder Spalten ändern. Das Menü ist in verschiedene Gruppen unterteilt.

  • Tabellenansicht: Über die Schaltfläche Setup hinzufügen können Sie ein Setup hinzufügen. Es wird ein Fenster geöffnet, in dem Sie für das neue Setup die Standardwerte übernehmen oder Werte aus einem bestehenden Setup kopieren können. Über die Schaltfläche Setup löschen löschen Sie die ausgewählten Lese-Setups. Über die Schaltfläche Reihenfolge ändern öffnen Sie ein Pop-up-Fenster, in dem Sie die Reihenfolge der Lese-Setups verändern können. Die Setups werden in der neuen Reihenfolge neu durchnummeriert.

  • Start-Setup: Bei Aktivierung mehrerer Setups prüft das Lesegerät die einzelnen Setups und stoppt die Bilderfassung, sobald ein Code gelesen wurde. Sie können festlegen, ob das Lesegerät für den nächsten Code bei einem bestimmten Setup oder dem Setup der letzten Gut-Lesung beginnen soll. Sie können das Start-Setup aus einer Drop-down-Liste auswählen. Alternativ können Sie auch Letzte erfolgreiche Decodierung auswählen, um das Lese-Setup mit der letzten erfolgreichen Decodierung als Start-Setup auszuwählen.

  • Bearbeiten: Mit Kopieren (oder STRG+C auf der Tastatur) können Sie einen Wert aus der aktuell ausgewählten Zelle kopieren. Einfügen kann nur in derselben Zeile oder in einem Texteditor verwendet werden. Mit Werte zurücksetzen setzen Sie die Werte der ausgewählten Zellen zurück.

  • Markieren: Über die Schaltflächen und Einstellungen in dieser Menügruppe können Sie bestimmte Zellenhintergründe markieren. Bei der Einstellung Nicht-Standardwerte werden Zellen mit anderen als den Standardwerten markiert (diese können in ein und derselben Zeile für verschiedene Lese-Setups oder Geräte unterschiedlich sein). Bei der Einstellung Differenz zur Referenz werden Zellen markiert, die einen anderen Wert als die Zelle des Referenz-Lese-Setups (und -Geräts) in derselben Zeile haben. Bei Auswahl der dritten Einstellung werden alle Werte und Kopfzeilen markiert, die den im Textfeld angegebenen Text enthalten. Zusätzlich ist auch der enthaltene Text als solcher durch einen anderen Texthintergrund markiert. Drücken Sie die Eingabetaste, um auch die Funktion der Schaltfläche Nur markierte Zeilen anzeigen anzuwenden.

    Bei Auswahl von Nur markierte Zeilen anzeigen werden alle Knoten reduziert, die keinen markierten Unterknoten enthalten. Mit Referenz-Lese-Setup festlegen legen Sie das Lese-Setup (und das Gerät) fest, das bei Verwendung des Markierungsmodus Differenz zur Referenz als Referenz verwendet wird. Ist diese Schaltfläche aktiv, wird die Spalte (Lese-Setup) der aktuell ausgewählten Zelle als Referenz-Setup festgelegt. Das aktuelle Referenz-Setup ist in der Kopfzeile mit dem Setup-Namen gekennzeichnet.

  • Filterung: Die Lese-Setup-Einstellungen werden automatisch festgelegt, sodass nur die Einstellungen angezeigt werden, die vom Lese-Setup abhängen. Wählen Sie Allgemeine Einstellungen aus, um nur Einstellungen anzuzeigen, die keine abweichenden Werte für verschiedene Lese-Setups haben können. Wählen Sie Alle Einstellungen aus, um alle Einstellungen auf einmal anzuzeigen. Wenn ein Eintrag Werte in mehreren Lese-Setups hat, werden diese in mehreren Spalten angezeigt.

  • Sonstige: Mit Alle Zeilen erweitern erweitern Sie alle Zeilen, die im Raster reduziert sind. Mit Alle Zeilen reduzieren reduzieren Sie alle Zeilen, die im Raster erweitert sind. Mit Anordnung zurücksetzen werden die Spaltenbreiten neu berechnet, sodass der gesamte verfügbare Platz genutzt wird. Reicht der verfügbare Platz nicht aus, wird eine Spaltenmindestbreite verwendet.


Geräteprotokoll


Wozu dient das Geräteprotokoll?

Hier werden die Protokolle angezeigt, die generiert werden, wenn die rote LED am Gerät blinkt. Sie können das Protokoll aktualisieren bzw. löschen, wenn Sie es nicht mehr benötigen.


UltraLight-Einstellungen


Welche Auslösertypen gibt es?

  • Präsentation – Bei diesem Modus wird kontinuierlich nach Symbolen gesucht und erkannte Codes werden decodiert. Der Auslösermodus „Präsentation“ basiert auf einem internen Bewegungserkennungs- und Taktsystem des Lesegerätes.

    Beim Modus „Präsentation“ können verschiedene Parameter angegeben werden, z. B. ob das Lesegerät denselben Code mehrfach liest und wie lange es bis zum Scannen des nächsten Codes warten soll. Die Konfiguration des Auslösermodus „Präsentation“ erfolgt im Fenster Systemeinstellungen mithilfe der Optionen unter Auslöser-Setup.

    Beim Modus „Präsentation“ können Sie durch Auswahl der Option Automatische Belichtung die besten Belichtungseinstellungen für die gewünschte Bildhelligkeit vom Lesegerät bestimmen lassen. Das Lesegerät verwendet jedoch zum Festlegen dieser Einstellungen die ersten Bilder, die es erfasst, und lässt dabei unter Umständen Bilder aus, die ein decodierbares Symbol enthalten. Bei Auswahl der Option Manuelle Belichtung können Sie eine exakte Belichtungseinstellung für die Kamera angeben.

  • Manuell – Bei diesem Modus wird die Bilderfassung durch eines der folgenden Ereignisse gestartet:

    • Drücken der Taste am Lesegerät

    • Senden des DMCC-Auslösers (DataMan Control Command) bei einer bestehenden USB- oder seriellen Verbindung mit dem Lesegerät

    • Klicken auf die Schaltfläche „Auslöser“ im Setup Tool

    • Drücken von STRG+T auf der Tastatur, wenn das Setup Tool-Fenster aktiv ist

    Das Lesegerät erfasst Bilder, solange das Auslösersignal aktiv ist. Der Lesevorgang wird gestoppt, sobald ein Symbol erkannt und decodiert wird oder das Auslösersignal endet.


Das Kontrollkästchen für „Zielvorrichtung aktiviert“ ist deaktiviert. Warum ist die Zielvorrichtung noch immer eingeschaltet?

Wenn Sie als Auslösertyp „Präsentation“ angeben, beruht der Auslösevorgang auf der Bewegungserkennung in der unmittelbaren Umgebung des Laserpunkts. Aus diesem Grunde wird die Laserzielvorrichtung auch dann eingeschaltet, wenn sie deaktiviert ist.


Welche UltraLight-Einstellungen verwendet das Lesegerät?

Auf den vier Registerkarten in diesem Fenster können Sie vier unterschiedliche Beleuchtungs-Setups konfigurieren. Bei einem Leseversuch probiert das Lesegerät nacheinander alle aktivierten Setups aus, um den Code zu lesen. Um ein Setup zu aktivieren, klicken Sie auf die Registerkarte des Setups und aktivieren das Kontrollkästchen Aktiviert. Aktivierte Setups haben neben ihrem Namen ein grünes Häkchen.

Wenn mehrere Setups aktiviert sind, beginnt das Lesegerät beim Scannen immer mit dem zuletzt verwendeten Setup. Das Lesegerät wechselt das Setup ausgehend von der Anzahl Decodierversuche. Das bedeutet, dass das Lesegerät bei der Standardeinstellung nach 2 nicht erfolgreichen Decodierversuchen zum nächsten Setup wechselt. Sie können die Anzahl der Decodierversuche ändern, indem Sie in das Fenster Auslöser-Setup wechseln, das in der Baumansicht unter der Gruppe Systemeinstellungen zu finden ist.


Wann wird die Option „Diffuses Hellfeld“ aktiviert?

Aktivieren Sie „Diffuses Hellfeld“, wenn Sie ein Bild auf einer ebenen Oberfläche erfassen möchten.


Wie wird die Bildbelichtung eingestellt?

Wechseln Sie in das Fenster Kamerasteuerung. Dort können Sie die Zielhelligkeit angeben. In diesem Fall passt das Lesegerät die Belichtung automatisch so an, dass die eingestellte Bildhelligkeit erreicht wird. Sie können die Belichtungseinstellungen aber auch manuell ändern.


Wie wird die Anzahl der Decodierversuche geändert?

Verwenden Sie das Steuerelement Versuche. Sie können die Anzahl der Decodierversuche für jedes Setup einzeln festlegen.


Was wird mit der Schaltfläche Setup n auf Standard zurücksetzen zurückgesetzt?

Mit der Schaltfläche Setup n auf Standard zurücksetzen werden alle Steuerungen in den Unterfenstern von „UltraLight-Einstellungen“ zurückgesetzt. Damit werden auch die Änderungen, die Sie in den Unterfenstern Fokuseinstellungen, Bildgröße und Kamerasteuerung vorgenommen haben, für das jeweilige Setup zurückgesetzt. Das heißt: Wenn Sie auf Setup 2 auf Standard zurücksetzen im Fenster Gewölbte Oberfläche klicken, werden auch alle zugehörigen Einstellungen in den anderen Unterfenstern zurückgesetzt.


Wie wird die gesamte Beleuchtung des Lesegerätes ein- bzw. ausgeschaltet?

Klicken Sie mit der rechten Maustaste auf das Symbol mit den Beleuchtungsquadranten. Dort stehen folgende Auswahlmöglichkeiten zur Verfügung:

  • Alle an

  • Alle aus

  • Nord-Süd

  • Ost-West

Die Änderungen werden sofort entsprechend Ihrer Auswahl wirksam.


Bildgröße


Wozu dient die Einstellung „Bildgröße (Zielbereich)“?

Mit dieser Funktion können Sie den genauen Bildbereich angeben, in dem das Lesegerät ein Symbol sucht und decodiert. Diese Funktion ist hilfreich, wenn Sie bei zwei unmittelbar benachbarten DataMatrix-Codes sicherstellen möchten, dass nur der Code entlang der Ziellinie gelesen wird. Bei der Verkleinerung des Zielbereichs wird jedoch nicht unbedingt die Decodierdauer verkürzt oder die Bildübertragungsgeschwindigkeit erhöht.

Für jedes Setup kann ein anderer Zielbereich festgelegt werden, sofern das verwendete Gerät mehrere Setups unterstützt.


Wirkt sich die Größe des Decodierer-Zielbereichs auf die Konfigurationscodes für das Lesegerät aus?

Ist ein zu kleiner Zielbereich festgelegt, kann das Lesegerät die Konfigurationscodes unter Umständen nicht erfassen.


Fokuseinstellungen


Welche Fokuseinstellung eignet sich für meine Anwendung?

Legen Sie den Fokusbereich bei Anwendungen mit festem Lesebereich auf eine feste Einstellung fest. Damit erzielen Sie die schnellste Leseleistung.

Verwenden Sie bei Anwendungen mit mehreren Code-Typen und -Größen verschiedene Lese-Setups und legen Sie für den Fokusbereich eine größere Tiefenschärfe fest.


Welche Auswirkung hat es, wenn für die Fokusschritte der Wert null (fester Fokus) festgelegt wird?

Wenn „Fokusschritte“ auf den Wert null eingestellt ist, wird der Fokus auf eine Position festgelegt und ein Bild erfasst. Der beste Fokus wird in diesem Fall nicht ermittelt.


Was bedeutet unterer – oberer bei Festlegung des Werts 1 für die Fokusschritte?

Nur im Auslösermodus „Manuell“ wechselt der Fokus zwischen dem niedrigeren und dem höheren Wert, wenn für die Fokusschritte als Wert 1 oder 2 festgelegt ist. Dies ist daran zu erkennen, dass sich der Schieberegler in zwei Regler teilt, die unabhängig voneinander verstellt werden können.

Für den Abstand in Millimetern entsprechen die beiden Schieberegler einem hohen und einem niedrigen Laufbereich. Für Dioptriewerte entsprechen die beiden Schieberegler einem hohen und einem niedrigen Stärkebereich.


Wie wird die Einstellung „Fokusbereich“ verwendet?

Mit der Option „Fokusbereich“ können Sie den Fokusabstand des Gerätes über den Schieberegler, die Schaltflächen „+“ und „–“ an den Enden des Schiebereglers oder durch Eingabe von Werten manuell ändern. Der Fokusbereich kann in Millimetern angegeben werden.


Wie wird der Abstand zum Lesegerät berechnet?

Der Abstand wird in Millimetern angegeben. Für die Berechnung gilt der Abstand zwischen der Vorderseite der Objektivabdeckung und dem zu decodierenden Bild.


Datenvalidierung


Was ist Datenvalidierung?

Mithilfe der Datenvalidierung wird bestätigt, dass die Daten in einem Symbol im vorgeschriebenen Format eines bestimmten Unternehmens, einer Branche oder eines internationalen Standards codiert sind.


Wo wird der Ergebnisverlauf der Datenvalidierung angezeigt?

Im Ergebnisverlauf werden bestandene und nicht bestandene Datenvalidierungen sowie die Ausgabeergebnisse angezeigt. Die Ergebnisdetails des Validierungsversuchs in der Ergebnisverlaufsliste können über das +-Symbol zu einem Ergebniseintrag angezeigt werden. Auf dieselbe Weise können auch frühere Validierungsergebnisse im Ergebnisverlauf angezeigt werden.


Was bedeuten die Fehlercodes bei der Validierung?

Nicht bestandene Datenvalidierungen können in folgenden Ergebnissen bestehen:

  • 1: Ungültige Symbologiekennung. Bei der Symbologiekennung handelt es sich um eine 3 Zeichen lange Zeichenkette, die den zur Datencodierung verwendeten Symbologietyp enthält und zudem angibt, wie die Daten verarbeitet werden müssen. Diese Zeichenkette kann zusätzlich zu den decodierten Daten als eigene Entität oder als Präfix des Datenstroms optional als Eingabe an das Tool übergeben werden.

    Beispiel: Die Symbologiekennung eines UCC/EAN-128-Symbols lautet ]C1. Bei bestimmten Anwendungen stellt dies die einzige Möglichkeit dar, einen internen oder gewerblichen Code 128 eindeutig und automatisch von UCC/EAN-128-Symbolen zu unterscheiden (die EAN.UCC-Anwendungskennungen codieren). Ohne Symbologiekennungen wäre nicht bekannt, wie die Daten im Symbol verarbeitet werden müssen.

  • 2: Keine Musterübereinstimmung.

  • 3: Ungültige Datenkennzeichner (AI, DI oder TEI).

  • 4: Ungültige Anwendungskennung (AI).

  • 5: Ungültige Datenkennung (DI).

  • 6: Ungültige Textelementkennung (TEI).

  • 7: Ungültige Daten: wenn Typ, Länge oder Wert der Daten nicht mit dem Datenkennzeichner übereinstimmt.

  • 8: Ungültiges Feldtrennzeichen.

  • 9: Nicht mit ISO/IEC 15434 konform.

  • 10: Nicht unterstützte Formate (z. B. andere Formate als 05, 06 und DD in DoD-UID-Anwendungen).

  • 11: Ungültiger Formatcode: andere Formatcodes als 00-99 und DD.

  • 12: ISO/IEC 15434 wird nicht unterstützt, wenn die Validierungsoption ISO/IEC 15434 ausgewählt ist, der decodierte Datenstrom jedoch nicht zu einem 2D-Symbol gehört. Dieser Fehler wird nur ausgegeben, wenn die Symbologiekennung als Eingabe an das Tool übergeben wird.

  • 13: Ungültiges Anwendungsfeld: ein Feld, das von der Anwendung nicht unterstützt wird.

  • 14: Nicht unterstütztes Anwendungsfeld: ein Feld, das von der Anwendung, aber nicht vom Tool unterstützt wird.

  • 15: Ungültige Anwendungsdaten: wenn die Daten anwendungsspezifische Anforderungen nicht erfüllen.

    Beispiel: Bei DoD-UID-Anwendungen gelten folgende Anforderungen: Die Zeichenkette für die Unternehmens-ID darf höchstens 13 Zeichen enthalten, den Datenkennzeichner nicht mitgerechnet. Die Zeichenkette für die Originalteile-, Los- oder Chargennummer (einschließlich zulässiger Sonderzeichen) darf höchstens 32 Zeichen enthalten, den Datenkennzeichner nicht mitgerechnet. Die Zeichenkette für die Seriennummer (einschließlich zulässiger Sonderzeichen) darf höchstens 30 Zeichen enthalten, den Datenkennzeichner nicht mitgerechnet.

  • 16: Ein gegebener Datenstrom enthält mehrere Formate (z. B. darf der Datenstrom bei DoD-UID-Anwendungen nur ein Format enthalten).

  • 17: Doppelte Felder: Derselbe Datenkennzeichner ist mehrfach in einem gegebenen Symbol enthalten. Bei bestimmten Anwendungen wie z. B. DoD-UID-Anwendungen sind doppelte Felder in einem Symbol nicht zulässig.

  • 18: Ungültige UID: Es fehlen Felder, die zur Erstellung einer gültigen UID vom Aufbautyp 1 oder 2 jedoch benötigt werden.

  • 19: Ungültige UID vom Aufbautyp 1: Es fehlen Felder, die zur Erstellung einer gültigen UID vom Aufbautyp 1 jedoch benötigt werden.

  • 20: Ungültige UID vom Aufbautyp 2: Es fehlen Felder, die zur Erstellung einer gültigen UID vom Aufbautyp 2 jedoch benötigt werden.

  • 21: Bei der Überprüfung der Konformität mit der ISO 15434-Syntax oder DoD-UID fehlt ein Formatnachspann.

  • 22: Bei der Überprüfung der Konformität mit der ISO 15434-Syntax oder DoD-UID fehlt ein Meldungsnachspann.


Wie werden der Ausgabesignalton des Lesegerätes und die LED-Farbe für Codes mit ungültiger Validierung verändert?

Wählen Sie das Aufgabenfenster Systemeinstellungen aus. Im Bereich Aktion bei Validierungsfehler können Sie gegebenenfalls Ton, Lautstärke und LED-Farbe auswählen.


Was ist DoD-UID-Validierung?

Anhand der DoD-UID-Validierung kann überprüft werden, ob die in einem DataMatrix-Code codierten Daten richtig nach den Richtlinien der Militärnorm MIL STD 130 des US-Verteidigungsministeriums (DoD) codiert sind. Das US Department of Defense schreibt derzeit vor, dass alle Artikel (mit einem Wert von über 5.000 USD oder Einzelartikel aus Serien), die es beschafft oder im Bestand hält, mit einer eindeutigen Seriennummer (UII) in einem speziellen Syntaxformat gekennzeichnet sein müssen. Mit dem DoD-UID-Validierungstool lässt sich überprüfen, ob Code-Daten entsprechend den Aufbautypen 1 oder 2 des US-Verteidigungsministeriums formatiert sind. Außerdem prüft die DoD-UID-Validierungsfunktion automatisch, ob eine Datenzeichenkette den Normen ISO 15434 und ISO 15418 entspricht. Die Ausgabe der verketteten UII (oder nur der Datenelemente der UII ohne ISO 15434-Syntax und ISO 15418-Datenkennzeichner) wird im Aufgabenfenster „Ergebnisse“ im ersten Ergebnisfeld des Feldes „Validierungsergebnisse“ angezeigt.

Aufbau 1 enthält die folgenden Datenelemente: Die EID-Unternehmenskennung (CAGE, DUNS, EAN.UCC) des Herstellers und die in der EID-Kennung enthaltene Seriennummer eines Teils. Unternehmenskennung und Seriennummern werden durch spezielle Datenkennzeichner markiert, abhängig davon, ob ein Unternehmen das DI-, AI- oder TEI-Format verwendet.

Aufbau 2 enthält die folgenden Datenelemente: Die Unternehmenskennung des Herstellers (EID), die Teilenummernkennung des Herstellers (PN) und die Chargennummernkennung (BN) für das betreffende Teil und die eindeutige Seriennummer des Teils in der spezifischen Teilenummer des Herstellers. Je nachdem, ob ein Unternehmen das DI-, AI- oder TEI-Format verwendet, werden Unternehmenskennung, Teilenummer/Chargennummer und Seriennummern durch spezielle Datenkennzeichner markiert.

Hinweis: Diese Option ist nicht bei allen Lesegeräten verfügbar.


Welche Symbologie wird für die DoD-UID-Validierung verwendet?

Das US Department of Defense schreibt derzeit den DataMatrix-Code als Standard für UID-Markierungen vor.


Was bedeutet EID erwartet?

Bei „EID erwartet“ handelt es sich um die Unternehmenskennung des Herstellers in der UII-Datenzeichenkette. Die Unternehmenskennung des Herstellers (EID) entspricht dem CAGE-, DUNS- oder EAN.UCC-Code oder auch einer anderen Herstellerkennung. Die erwartete EID ist ein DoD-spezifischer Wert.


Was bedeutet PN erwartet?

Bei „PN erwartet“ handelt es sich um die Teilenummer des Herstellers in einer UII-Datenzeichenkette. Die erwartete PN ist ein DoD-spezifischer Wert.


Was bedeutet „BN erwartet“?

Bei „BN erwartet“ handelt es sich um die Chargennummer des Herstellers in einer UII-Datenzeichenkette. Die erwartete BN ist ein DoD-spezifischer Wert.


Was ist ISO-Validierung?

Mit der ISO-Validierungsfunktion wird geprüft, ob eine Datenzeichenkette gemäß der Syntax von ISO 15434 oder ISO 15434 + ISO 15418 codiert ist.

Die Bestätigung für ISO 15434 erfolgt, wenn die Syntax einer Datenzeichenkette fehlerfrei ist. Geprüft werden unter anderem die „nicht druckbaren“ ASCII-Zeichen der Zeichenkette, wie zum Beispiel Meldungskopfzeile, Datensatztrennzeichen, Formatcode (bei AI-, DI- und TEI-Nummern), Gruppentrennzeichen und Übertragungsendzeichen.

Die Bestätigung für ISO 15418 erfolgt, wenn jedes Datenelement der Datenzeichenkette mit dem richtigen Datenkennzeichner codiert ist. Abhängig davon, ob ein Hersteller das AI-, DI- oder TEI-Format verwendet, wird den einzelnen Datenelementen (EIN-Code des Herstellers, Teilenummer und Seriennummer) jeweils ein bestimmter Code vorangestellt, der sogenannte „Datenkennzeichner“.

Hinweis: Diese Option ist nicht bei allen Lesegeräten verfügbar.

Hinweis: Bei dieser Option sind auch Textelementkennungen nach ATA CSDD-Spezifikation möglich.


Was ist GS1-Validierung?

Mit der GS1-Validierung können Sie Syntax und Semantik von Symbolen durch Abgleich mit der GS1-Spezifikation überprüfen. Das Lesegerät kann die codierten Daten anhand einer konfigurierbaren Kennungszeichenkette validieren. Es werden alle Anwendungskennungen unterstützt.

Standardmäßig validiert das Lesegerät eingehende Symbole anhand der Formatzeichenkette der European Federation of Pharmaceutical Industries and Associations (EFPIA). Beispiel:

<AI(01)><AI(10)><AI(17)><AI(21)>

Anhand der GS1-Validierung können Sie konfigurieren, welche Informationen vom Lesegerät übertragen werden, wenn die Daten in einem Symbol die Prüfung nicht erfolgreich durchlaufen, einschließlich Zeilenumschaltung und Zeilenvorschub. Im Fenster Detaillierte Ergebnisse werden für jedes Symbol „Bestanden“ oder „Nicht bestanden“ angezeigt und die einzelnen Anwendungskennungen im Symbol mit den entsprechenden Datenelementen aufgeführt.


Was ist die Validierung der Suchzeichenkette?

Bei der Validierung der Suchzeichenkette können Sie eine Zeichenkette angeben, mit der die im Symbol codierte Zeichenkette exakt übereinstimmen muss. Das Ergebnis „Bestanden“ erhalten nur Symbole, bei denen die enthaltene Zeichenkette exakt der angegebenen Zeichenkette entspricht.


Wie werden Zeichenketten mit veränderlichen Werten validiert?

Aktivieren Sie die Option Numerische Komponente erhöhen/verringern, um anzugeben, dass der betreffende Teil der zu validierenden Zeichenkette ein numerischer Wert ist, der sich bei jedem folgenden Lesevorgang erhöht oder verringert.


Wozu dient die Option Numerische Komponente erhöhen/verringern?

Verwenden Sie diese Funktion, um die Validierung der Suchzeichenkette in Anwendungen durchzuführen, bei denen die codierten Daten Seriennummern enthalten oder sonstige lineare Veränderungen aufweisen. Die Option „Numerische Komponente erhöhen/verringern“ ist beispielsweise sinnvoll in einer Zeitschriften- oder Buchbindeanwendung, bei der die Seitennummern mittels Barcodes überwacht werden, um sicherzustellen, dass keine Seiten doppelt vorkommen oder übersprungen werden.


Wie werden die Einstellungen der Option „Numerische Komponente erhöhen/verringern“ konfiguriert?

Diese Funktion kann verwendet werden, wenn die zu validierende Zeichenkette eine Folge von Ziffern (0-9) enthält, die sich bei jedem folgenden Lesevorgang entweder erhöht oder vermindert. Um diese Funktion einzusetzen, geben Sie im Feld Startposition die Startposition der sich erhöhenden oder vermindernden Ziffern (0 ist die Position des ersten Zeichens) und im Feld Länge die Anzahl sich verändernde Zeichen an. Bei Auswahl von Automatisch im Feld Länge behandelt das Lesegerät alle folgenden Ziffern ab der Startposition als sich erhöhenden oder vermindernden Wert. Im Feld Schrittgröße geben Sie die Differenz an, um die sich der Wert von einem Lesevorgang zum anderen ändert. Geben Sie einen negativen Wert ein, wenn sich die Zahl vermindert.

Beispiel: Wenn Ihre anfängliche Zeichenkette ABC_123XXPY lautet und „123“ sich bei jedem Lesevorgang um 1 erhöht, müssen Sie bei Startposition den Wert 4, bei Länge den Wert 3 und bei Schrittgröße den Wert 1 angeben. (Wenn Sie sicher sind, dass die Zeichen ab Position 7 nie Ziffern sind, könnten Sie auch Automatisch im Feld Länge auswählen.) Hinweis: Die Anzahl der Stellen bei Automatikeinstellung erhöht sich mit Erreichen der Höchstzahl nicht, sondern die Zahl wird wie bei jeder Einstellung mit fester Stellenzahl zurückgesetzt (Beispiel: wenn bei zwei Stellen 99 erreicht wird, wird die Zählung nicht mit 100 fortgesetzt, sondern auf 00 zurückgesetzt).

Wenn die Zeichenkette ungültig ist oder nicht gelesen werden kann, wird der erwartete numerische Wert nicht geändert. Durch Aktivieren der Kontrollkästchen Aktualisieren bei Fehllesung und Aktualisieren bei Validierungsfehler können Sie festlegen, dass der erwartete Wert geändert wird, falls der Code nicht gelesen wurde, ungültig ist oder beide Bedingungen zutreffen.


Was ist Musterübereinstimmungsvalidierung?

Bei der Musterübereinstimmungsvalidierung gibt der Benutzer eine bestimmte Zeichenkette ein, um sich bestätigen zu lassen, dass diese in der Datenzeichenkette enthalten ist. Beispielsweise kann ein Benutzer das Muster 17V eingeben. Es wird bei DI-Formaten zur Identifizierung der Unternehmenskennung des Herstellers verwendet. Wenn der Code die Zeichen 17V enthält, signalisiert das Lesegerät, dass der betreffende Code erfolgreich validiert wurde. Wenn die Zeichen nicht vorhanden sind, signalisiert das Lesegerät einen Validierungsfehler.

Zur Mustervalidierung müssen Sie als Muster einen regulären Ausdruck verwenden.


Wozu dient die Option „Aktion bei Validierungsfehler“?

Mithilfe der Option „Aktion bei Validierungsfehler“ kann die Ausgabe des Lesegerätes nach einem Validierungsfehler festgelegt werden. Der Benutzer kann zwischen verschiedenen Optionen wählen:

  1. „Validierungsfehler“ übertragen – Nach einer fehlgeschlagenen Code-Validierung gibt das Lesegerät die Zeichenkette „Validierungsfehler“ aus.
  2. „Validierungsfehler“ + decodierte Zeichenkette übertragen – Nach einer fehlgeschlagenen Code-Validierung gibt das Lesegerät die Zeichenkette „Validierungsfehler“ gefolgt von der vollständigen decodierten Zeichenkette aus.
  3. Decodierte Zeichenkette mit Anmerkungen übertragen – Das Lesegerät gibt die decodierte Zeichenkette mit Informationen zu Fehlertyp und Fehlerposition in der Zeichenkette aus.
  4. Nichts übertragen – Das Lesegerät gibt keinerlei Informationen aus.
  5. „Validierungsfehler“ + angegebene decodierte Zeichenkette übertragen – Nach einer fehlgeschlagenen Code-Validierung gibt das Lesegerät die Zeichenkette „Validierungsfehler“ gefolgt von dem angegebenen Teil der decodierten Zeichenkette aus.


Wozu dient das Kontrollkästchen CR/LF anhängen bei Aktion bei Validierungsfehler?

Bei Aktivierung des Kontrollkästchens CR/LF anhängen wird nach Ausgabe eines Validierungsfehlers eine Zeilenumschaltung mit Zeilenvorschub eingefügt.


Wie kann ich nach mehreren Suchzeichenketten suchen?

Verwenden Sie die Musterübereinstimmungs-Validierung und geben Sie eine Suchzeichenkette im PERL-Format ein. Um nach Übereinstimmungen für die Zeichenketten 123, 456 oder 789 zu suchen, geben Sie beispielsweise Folgendes ein:

^(123¦456¦789)$


Was geschieht bei aktivierter Datenvalidierung?

Der Status der Datenvalidierung wird im Fenster „Ergebnisverlauf“ im Ergebnislisteneintrag Ergebnisstatus angezeigt. Bestandene Validierungen haben den Status „Gültig“, nicht bestandene Validierungen den Status „Ungültig“. Weitere Informationen zum Validierungsergebnis können Sie anzeigen, indem Sie das Ergebnis erweitern.


Welche Datenformatierung haben nicht bestandene Validierungen?

Für Ergebnisse, die die Datenvalidierung nicht bestanden haben, wird die „Einfache Formatierung“ der Daten nicht übernommen. Stattdessen wird die konfigurierte „Aktion bei Validierungsfehler“ ausgeführt. Anders verhält es sich bei der skriptbasierten Datenformatierung. Bei Auswahl von „Skriptbasierte Formatierung“ wird statt der „Aktion bei Validierungsfehler“ die Skriptformatierungsfunktion ausgeführt. Auf diese Weise ist es beispielsweise möglich, den Status für die „Datenvalidierung“ per Skript genauer festzulegen.


Sicherungseinstellungen


Wozu dient die Funktion „Automatische Sicherung der Lesegerätkonfiguration“?

Die automatische Sicherung ist bei Geräten möglich, die eine Ethernet-Verbindung verwenden. Bei Aktivierung dieser Funktion wird bei jedem Speichern der Konfiguration im Flash-Speicher eine Sicherung der Lesegerätkonfiguration auf einem externen Speicher (FTP-Server) erstellt. Ein Cognex Explorer-Dienst kann die Sicherungsdaten empfangen. Die Daten können manuell über das Setup Tool, DMCC-Befehle oder Cognex Explorer wiederhergestellt werden.

Konfigurieren Sie das Lesegerät mit der IP-Adresse und der Port-Nummer, die für die Angabe des Speicherorts der Konfiguration benötigt werden. Sie können außerdem einen Benutzernamen mit Kennwort festlegen.


Gerätesicherungscode drucken


Wozu dient die Option „Gerätesicherungscode drucken“?

Mit dieser Option können Sie die Sicherungscodes des Lesegerätes (Codes für Kaltstart und Neustart) drucken, damit Sie Ihr Gerät ersetzen können, indem durch das Lesegerät gelesen wird. Diese Codes enthalten auch die Netzwerkeinstellungen und die seriellen Einstellungen.

Im Bereich Hinweise können Sie wichtige Hinweise eingeben, die mitgedruckt werden. Wenn die Reset-Codes auf getrennten Seiten gedruckt werden sollen, dann aktivieren Sie das Kontrollkästchen Reset-Code auf eigener Seite ausdrucken.


Konfigurationscode drucken


Wozu dient die Option „Konfigurationscode drucken“?

Mit dieser Option können Sie die Konfigurationscodes des Lesegerätes (Codes für Kaltstart und Neustart) drucken, damit die zu konfigurierenden Geräte diese lesen können.

Im Bereich Hinweise können Sie wichtige Hinweise eingeben, die mitgedruckt werden. Wenn die Reset-Codes auf getrennten Seiten gedruckt werden sollen, dann aktivieren Sie das Kontrollkästchen Reset-Code auf eigener Seite ausdrucken.


Datenprotokollierung


Was ist Datenprotokollierung?

Mit der Datenprotokollierung können Sie erfolgreich gelesene Bilder automatisch an einem bestimmten Speicherort speichern. Zusätzlich können Datenvalidierungsberichte der geprüften Symbole gespeichert werden, wenn für den mit dem Lesegerät gescannten Code-Typ die Option „Datenvalidierung“ aktiviert ist. Stellen Sie sicher, dass die Verbindung mit dem Setup Tool nicht unterbrochen wird. Nur dann funktioniert die Datenprotokollierung.


Wann werden überlagernde Grafiken in einem Bericht deaktiviert?

Aktivieren Sie Überlagernde Grafiken in Bericht deaktivieren, wenn in der PDF-Datei das grüne Quadrat um die gelesenen Codes nicht angezeigt werden soll.


Bildtoolansicht


Wozu dient das Bildfenster?

In diesem Fenster wird das vom Gerät gelesene Bild angezeigt.

Mit den Lupensymbolen können Sie das Bild jeweils automatisch an die Größe des Bildtoolansicht-Fensters anpassen, das Bild vergrößern bzw. verkleinern und das Bild im 1:1-Pixel-Modus anzeigen.

Daneben können Sie die Fokusrückmeldung für das Bild im Live-Anzeige-Modus aktivieren bzw. deaktivieren und das Bild in die Zwischenablage kopieren.

Mit der Option Bild speichern können Sie nur das aktuelle Bild oder alle Bilder einer Bildfolge speichern. Mit den Optionen unter Protokollierung können Sie alle Bilder mit Fehllesung oder alle decodierten Bilder im Dateisystem speichern. Klicken Sie auf die letzte Protokollierungsoption Einstellungen Protokollierung und Berichte ..., um das Fenster Setup Tool-Optionen zu öffnen. Sie können dieses Fenster jedoch auch auf der Startseite des Setup Tools über das Menü Optionen öffnen.

HINWEIS: Einstellungen für die Bildanzeige wirken sich nicht beim Speichern des letzten Bildes aus, das über das Bildfenster (durch Ziehen und Ablegen) erfasst wurde. Das letzte Bild wird immer in voller Größe gespeichert (maximale Auflösung des Gerätes).


Wie muss der Code positioniert sein, damit er vom Lesegerät erfasst wird?

Vergewissern Sie sich, dass das Symbol im Bildbereich des Lesegerätes zentriert ist und dass sich der rote Punkt des Ziellasers auf der Mitte des Symbols befindet.


Es treten Schwierigkeiten beim Lesen der Codes auf den Teilen auf. Wie lässt sich das Problem beheben?

  • Achten Sie darauf, dass Sie den Auslöser gedrückt halten. Wenn Sie den Auslöser loslassen, bevor der Lesevorgang abgeschlossen ist, bricht das Lesegerät den Leseversuch ab.

  • Überprüfen Sie, ob der Leseabstand des Lesegerätes den Vorgaben für Code-Größe und -typ entspricht (siehe Scan-Übersicht).

  • Vergewissern Sie sich, dass das Symbol im Bildbereich des Lesegerätes zentriert ist. Beim Drücken auf den Auslöser muss sich das Symbol in der Mitte der grünen Zielbeleuchtung befinden.

  • Klicken Sie auf Beleuchtungs- und Kameraeinstellungen (beim DM7500, DM8500 und DM8600 UltraLight-Einstellungen) und passen Sie die Beleuchtungseinstellungen an.

  • Klicken Sie auf Symbologieeinstellungen und vergewissern Sie sich, dass der von Ihnen verwendete Symbologietyp aktiviert ist.


Es treten Schwierigkeiten beim Lesen von Symbolen auf. Wie lässt sich das Problem beheben?

  • Vergewissern Sie sich, dass der Leseabstand des Lesegerätes den Angaben für Symbolgröße und -typ entspricht (siehe Kurzanleitung).

  • Vergewissern Sie sich, dass das Symbol im Bildbereich des Lesegerätes zentriert ist. Bei Auslösung des Geräts muss sich das Symbol in der Mitte des roten Ziel-Lasers befinden.

  • Klicken Sie auf Symbologieeinstellungen und vergewissern Sie sich, dass die von Ihnen verwendete Symbologie aktiviert ist.


Wie wird das Lesegerät über das Setup Tool ausgelöst?

Klicken Sie auf der obersten Symbolleiste auf die Auslöserschaltfläche (Blitzsymbol) oder drücken Sie STRG+T.


Wie wird ein erfasstes Bild in einer Datei gespeichert?

Klicken Sie in der Symbolleiste auf die Schaltfläche „Bild speichern“. Alle Bilder einer Bildfolge speichern Sie, indem Sie die Roll-down-Liste öffnen und auf Alle Bilder der Bildfolge speichern klicken.

Alternativ können Sie das Bild auch per Drag-and-drop auf Ihren PC ablegen. Klicken Sie auf das Bild in der Bildanzeige, ziehen es aus dem Setup Tool heraus und lassen es anschließend los.

Wenn Sie ein nicht aktuelles Bild (aus dem Leseergebnisverlauf) per Drag-and-drop speichern möchten, beachten Sie bitte, dass es mit den Einstellungen für die Bildanzeige gespeichert wird. Standardmäßig ist es von geringerer Qualität. Unter Einstellungen für die Bildanzeige können Sie das Bild auf Vollgröße und das Format in Bitmap ändern.


Pufferung und Übertragung


Wozu dienen die Einstellungen für gepufferte Bilder?

Unter den Einstellungen für gepufferte Bilder können Sie die Größe, das Format und die Qualität der per FTP übertragenen Bilder ändern.

  • Größe: Als Voreinstellung für die Bildgröße für gepufferte Bilder wurde die Vollgröße gewählt. Entsprechend der ausgewählten Bildgröße kann das Lesegerät für jedes Bild ein Sub-Sampling vornehmen, wodurch die Bildübertragung erheblich beschleunigt werden kann, allerdings unter Verlust feiner Bilddetails.

  • Format: Standardmäßig speichert das Lesegerät alle erfassten Bilder im BMP-Format.

  • Qualität: Nur bei Verwendung des JPEG-Bildformats verfügbar. Mit diesem Schieberegler können Sie interne Parameter so anpassen, dass vom Lesegerät eine Glättungsoperation am erfassten Bild durchgeführt wird. Die Übertragungsgeschwindigkeit kann dadurch erhöht oder verringert werden.


Wozu dient die Option „Überlagernde Grafiken“?

Ist diese Option aktiviert, enthalten gespeicherte Bilder (per FTP oder per Erfassung) zusammen mit den Bilddateien überlagernde Grafiken im Format SVG.


Warum werden keine decodierten Bilder angezeigt?

Die Pufferungs- und Übertragungsfunktion führt keine Decodierung aus. Wenn Sie im Fenster Einstellungen für gepufferte Bilder die Option Überlagernde Grafiken aktivieren, werden die Bilder mit überlagernden Grafiken (als SVG-Dateien) gespeichert. Diese werden dann bei Wiedergabe der Bilder mit angezeigt. Diese Grafiken zeigen – neben anderen Decodierinformationen – die decodierten Daten an.


Welche Möglichkeiten bietet die Pufferung und Übertragung?

In der Pufferung und Übertragung können Sie einstellen, welche Bilder erfasst und auf dem Lesegerät gespeichert werden und die auf dem Lesegerät gespeicherten Bilder anzeigen und an einen PC übertragen.

  • Auf der Registerkarte Bildpufferung können Sie einstellen, welche Bilder auf dem Lesegerät gespeichert werden.

  • Auf der Registerkarte Bildübertragung an PC legen Sie fest, wie Bilder vom Lesegerät an den PC übertragen werden.

  • Auf der Registerkarte FTP-Bildübertragung können Sie die automatische Bildübertragung vom Lesegerät an einen PC konfigurieren.

  • Auf der Registerkarte FTP-Ergebnisübertragung konfigurieren Sie das Lesegerät mit der IP-Adresse und der Port-Nummer, die für die Übertragung von Decodierergebnissen an einen FTP-Server erforderlich sind.


Ist es möglich, Decodierergebnisse an einen FTP-Server zu senden?

Über die Registerkarte FTP-Bildübertragung können Sie die IP-Adresse und die Port-Nummer konfigurieren, die für die Übertragung von Decodierergebnissen an einen FTP-Server erforderlich sind. Die Registerkarte ermöglicht die Konfigurierung eines Benutzernamens und Passworts sowie die des Namens für die Datei, in der die Ergebnisse gespeichert werden sollen.


Wie können FTP-Daten in einem anderen Verzeichnis als dem Stammverzeichnis gespeichert werden?

In das Feld „Dateiname“ können neben Dateinamen auch Pfade eingegeben werden. Verwenden Sie dabei Schrägstriche als Trennzeichen, Beispiel: /Bilder/Bild.


Weshalb werden im FTP-Verzeichnis keine Bilder und Ergebnisse angezeigt?

Vergewissern Sie sich, dass Sie über die erforderlichen Berechtigungen zum Erstellen von Dateien verfügen. Bei aktivierter Option „Anhängen“ muss der FTP-Benutzer über Berechtigungen zum Anhängen verfügen (die nicht mit Schreibberechtigungen identisch sind). Darüber hinaus muss der FTP-Benutzer die IP-Adresse des richtigen FTP-Servers überprüfen.


Wozu dient die Liste „Zu puffernde Ergebnisse“?

Über die Liste „Zu puffernde Ergebnisse“ können Sie festlegen, welche Bildtypen intern auf dem Lesegerät gepuffert werden sollen, je nach dem ob diese Decodierinformationen (Gut-Lesung), Fehlcodierinformationen (Fehllesung), beides (Alle) oder Validierungsfehler enthalten. Im letzten Fall werden nur erfolgreich decodierte Bilder mit Validierungsfehler gespeichert.


Wozu dient die Option „Für Ergebnis zu puffernde Bilder“?

Mit dieser Option legen Sie fest, welche Bilder für ein Ergebnis gepuffert werden. Wie Ergebnis bedeutet, dass das Lesegerät bei Gut-Lesung nur Bilder mit erkanntem Code speichert.


Was ist die maximale Bildpuffergröße?

Bei der maximalen Bildpuffergröße handelt es sich um die maximale Anzahl Bilder, die auf dem Lesegerät gepuffert werden können. Diese Anzahl ist durch den Speicher des Lesegerätes begrenzt, kann jedoch auf eine kleinere Anzahl als das Maximum festgelegt werden, damit nicht mehr als die gewünschte Anzahl Bilder auf dem FTP-Server oder PC gespeichert werden.


Wozu dient die Einstellung „Für Setup Tool/DMCC verfügbar“?

„Für Setup Tool/DMCC verfügbar“ gibt die Anzahl der Bilder an, die das Erfassungssystem oder die Bilderfassung nicht verwendet. Sie entspricht der maximalen Anzahl an Bildern, die für ein Ergebnis an das Setup Tool oder das SDK übertragen werden können.

HINWEIS: Der angegebene Wert dient ausschließlich zur Information und kann nicht geändert werden.


Welche Einstellungen gibt es für den Modus „Bild mit Gut-Lesung“?

Bei „Bild mit Gut-Lesung“ werden alle gepufferten Bilder mit Gut-Lesung gespeichert, sofern Sie keine begrenzende Rate festlegen.

Sie können die Anzahl der gepufferten Bilder mit Gut-Lesung begrenzen, indem Sie Rate begrenzt auswählen. Legen Sie die Bildrate für Gut-Lesung (die Anzahl der gepufferten Bilder und die zugehörige Zählfrequenz) und die Bildfolge für die Rate fest, die der Spitzenrate pro konfigurierte Zeiteinheit entspricht.


Welche Auswirkung hat die Aktivierung der Option „Überschreiben des Puffers zulassen“?

Mit der Option Überschreiben des Puffers zulassen wird gesteuert, ob beim Speichern von Bildern im Puffer ältere Bilder überschrieben oder bei vollem Puffer keine Bilder mehr gepuffert werden.


Wie kann sichergestellt werden, dass Bilder nach dem Übertragen gelöscht werden?

Aktivieren Sie das Kontrollkästchen Nach Übertragung löschen, mit dem gesteuert wird, ob Bilder nach dem Übertragen gelöscht werden. Diese Einstellung wird auf alle Übertragungsverfahren einschließlich der FTP-Bildübertragung und der Übertragung vom Lesegerät zum PC angewendet.


Warum ist die Schaltfläche „Übertragung starten“ nicht aktiviert?

Wenn auf dem Lesegerät Bilder gepuffert wurden, müssen Sie zuerst den Ordner auswählen, in dem die Bilder erfasst werden sollen. Außerdem müssen Sie den Erfassungsvorgang beenden, um die Übertragung starten zu können.

Hinweis: „Übertragung starten“ ist nicht verfügbar, wenn sich das Gerät außerhalb der Reichweite der gekoppelten Basisstation befindet (bei mobilen Geräten), da der Puffer außerhalb der Reichweite gelöscht und deaktiviert wird.


Wird über die Schaltfläche „Übertragungsordner löschen“ auch der Bildstreifen gelöscht?

Über die Schaltfläche „Übertragungsordner löschen“ werden alle Bilder in diesem Ordner gelöscht. Wenn diese Bilder aktuell im Bildstreifen angezeigt werden, wird auch dieser gelöscht.


Werden im ausgewählten Ordner bereits vorhandene Dateien überschrieben?

Wenn im ausgewählten Ordner bereits Dateien vorhanden sind, die dem Format [Index] entsprechen, wird der Startindex automatisch höher gesetzt, bis keine passende Datei mehr gefunden wird, und die Übertragung gestartet. Es werden keine Bilddateien überschrieben.


Können Bilder einzeln angezeigt werden?

Sie können Bilder einzeln anzeigen, aber Sie müssen den gesamten Ordner auswählen, in dem die Bilder gespeichert sind. Sobald die Bilder in dem ausgewählten Ordner angezeigt werden, können Sie diese mit den Vorwärts- und Rückwärtstasten einzeln aufrufen.


Muss mit der Bildanzeige vollständig von vorn begonnen werden, wenn das Fenster verlassen wird?

Nein. Beim Verlassen des Fensters für die Pufferung und Übertragung wird die Anzeige wie beim Drücken der Pausentaste angehalten.


Wie werden Bilder an einen FTP-Server gesendet?

Über die Registerkarte FTP können Sie die Einstellungen vornehmen, die für die Übertragung von Bildern an einen FTP-Server erforderlich sind. Die Registerkarte enthält Einstellungen für die IP-Adresse und die Port-Nummer des Servers sowie für Benutzernamen und Passwort. Beachten Sie, dass per FTP gesendete Bilder nicht in allen Fällen tatsächlich übertragen werden, z. B. wenn das Lesegerät mit einem kurzen Takt betrieben wird und keine Zeit für die Bildübertragung eingeräumt werden kann. Die Übertragung über kabellose Verbindungen kann zudem wesentlich langsamer als bei der normalen Netzwerkkommunikation sein. In diesen Fällen wird empfohlen, die Bilder zu verkleinern/zu komprimieren.

Über die Optionen für Dateiname können Sie die Datei angeben, in der die Bilder gespeichert werden sollen. Im Feld Dateiname können Sie einen Pfad angeben, der mit dem Stammverzeichnis des FTP-Servers beginnt (z. B.: „/Fehllesungen_Bilder/Bild“). Die Dateinamenerweiterung (JPG oder BMP) hinter dem Dateinamen entspricht der Einstellung für das Bildformat im Fenster Einstellungen für gepufferte Bilder. Beachten Sie, dass vom Lesegerät keine Verzeichnisse erstellt werden. Es muss sich um ein bereits vorhandenes Verzeichnis mit Zugriffsmöglichkeit handeln.

Die Einstellung für Maximal angehängter Wert gibt die Grenze für die dem Dateinamen angehängten Werte an. Mit dem Wert 0 wird angegeben, dass kein Wert angehängt und die Datei überschrieben werden kann.

Mit Skriptgenerierter Dateiname können Sie im Fenster Skripterstellung auf der Registerkarte FTP-Speicherung ein Skript schreiben, das den Dateinamen generiert.

Die Option Servergenerierter Dateiname beginnt mit einem leeren Pfad, mit dem das Stammverzeichnis des FTP-Servers angegeben wird.


Die Laufzeit-Bildübertragung per FTP funktioniert nicht. Wie lässt sich das Problem beheben?

Vergewissern Sie sich, dass folgende Voraussetzungen erfüllt sind:

  • Serveradresse, Benutzername und Kennwort sind richtig eingestellt.

  • Als Übertragungsmodus ist „FTP – Laufzeit“ eingestellt.

  • Auf der Registerkarte „Puffer“ ist für „Zu puffernde Ergebnisse“ nicht „Keine“ eingestellt (Einstellung je nach Bedarf).

  • Ihr FTP-Server unterstützt die Bildübertragung.


Was ist ein skriptgenerierter Dateiname?

Im Fenster Skripterstellung auf der Registerkarte FTP-Speicherung können Sie ein Skript erstellen, das den Dateinamen für die FTP-Übertragung generiert.


Was ist ein servergenerierter Dateiname?

Manche FTP-Server unterstützen diese Funktion, um empfangene Dateien vor dem Speichern auf der Festplatte eindeutig zu benennen.


Was ist zu tun, wenn FTP-Übertragungen mit servergenerierten Dateinamen nicht funktionieren?

Vergewissern Sie sich, dass der FTP-Server den Befehl „STOU“ (Store Unique, eindeutig speichern) ausführen kann. Dieser Befehl entspricht dem Befehl STOR, mit dem Unterschied, dass die entsprechende Datei im aktuellen Verzeichnis mit einem für dieses Verzeichnis eindeutigen Namen erstellt wird.


Welche Übertragungsmodi gibt es?

Beim Übertragungsmodus Auf Anforderung werden Bilder nur dann übertragen, wenn Sie im Setup Tool auf Übertragung starten klicken oder wenn Sie den entsprechenden Steuerungsbefehl (DMCC) senden. Wenn Sie den Übertragungsmodus FTP – Laufzeit wählen, werden Bilder automatisch an den FTP-Server gesendet, sobald eine Verbindung hergestellt wird.

Hinweis: „Übertragung starten“ ist nicht verfügbar, wenn sich das Gerät außerhalb der Reichweite der gekoppelten Basisstation befindet (bei mobilen Geräten), da der Puffer außerhalb der Reichweite gelöscht und deaktiviert wird.


Warum ist bei der Übertragung von Dateien das gesamte Fenster deaktiviert?

Das Fenster ist deaktiviert, damit für die Bildübertragung per FTP die höchstmögliche Stabilität erreicht wird. Die Bildübertragung per FTP kann je nach Verbindungsgeschwindigkeit zum FTP-Server und der Größe und Anzahl der zu übertragenden Bilder einige Minuten dauern.


Optionen


Welche Einstellungen sind auf der Seite „Optionen“ möglich?

Im Fenster „Optionen“ im DataMan Setup Tool können Sie die Anwendung nach Wunsch konfigurieren.


Was wird im Feld „Spracheinstellungen“ eingestellt?

Hier können Sie die Sprache auswählen, in der Sie das Setup Tool verwenden möchten. Die Standardeinstellung ist Englisch.

HINWEIS: Die Anwendung muss neu gestartet werden, damit die Änderungen wirksam werden.


Was wird im Feld „Codepage für Codeansicht“ eingestellt?

Hier können Sie festlegen, wie das Leseergebnis codiert werden soll.


Was wird im Feld „Farbschema“ eingestellt?

In diesem Feld können Sie das Farbschema für das DataMan Setup Tool-Fenster auswählen.


Was wird im Feld „Einstellungen zurücksetzen“ eingestellt?

In diesem Feld wählen Sie eine Kategorie aus (Kommunikation; Layout; Meldungen, die nicht mehr angezeigt werden sollen; Datenprotokollierung; Ausgeschlossene Geräte; Codepage; Sprache; RTM Lean - Alle Einstellungen; Standardordner; Virtuelle Geräte; Prüfung; Signalton; Assistenten), die auf die Standardeinstellungen zurückgesetzt werden soll.


Wozu dient die Einstellung „Speicherort Backup“?

Hier können Sie den Ordner festlegen, in dem die Backup-Funktion Backupdateien speichert.


Welche Einstellungen sind auf der Registerkarte „Datenprotokollierung“ möglich?

Auf dieser Registerkarte legen Sie die Ordner fest, in denen Ergebniscodes, decodierte Bilder, Bilder mit Fehllesung und Berichte gespeichert werden sollen. Zudem können Sie Dateinamen und Erweiterungen für die Datenprotokollierung ändern.


Wie wird die Generierung von Datenvalidierungsberichten aktiviert?

Wählen Sie im Fenster Ergebnisverlauf unter Protokollierung die Option Datenvalidierungsberichte generieren aus.


Welche Einstellungen sind im Feld „Bildpufferung und -übertragung“ möglich?

Hier können Sie den Ordner festlegen, in den die Bilder übertragen werden können.


Was wird im Feld „Signaltoneinstellungen“ eingestellt?

Hier können Sie den PC-Signalton bei Gut-Lesung einstellen. Wenn es sich bei dem Ergebnis, das das Setup Tool vom DataMan-Lesegerät empfängt, um eine Gut-Lesung handelt, wird der PC-Signalton aktiviert. Diese Funktion ist nützlich, wenn das DataMan-Lesegerät intern keinen Signalton erzeugen kann. Für den Signalton für Gut-Lesungen können Sie die Frequenz von 1000 Hz bis 10000 Hz und die Dauer von 10 ms bis 1000 ms festlegen.


Wie wird die Berichtsfunktion aktiviert?

Nach dem Ausfüllen der Berichtsfelder müssen Sie die Datenvalidierung aktivieren, um Berichte zu generieren.


Ergebniscode, decodierte Bilder oder Bilder mit Fehllesung werden nicht im entsprechenden Verzeichnis angezeigt. Wodurch kann dieses Problem verursacht werden?

Sie müssen sie in den entsprechenden Drop-down-Listen zur Protokollierung aktivieren.


Tabellenansicht


Warum sind bestimmte Werte markiert?

Markierte Werte sind Werte, die von der Standardeinstellung abweichen. Die Markierungsregeln können Sie im Abschnitt Markierung des Menübandmenüs ändern. Die Antwort zu Tabellenansicht: Menübandmenü enthält weitere Informationen.


Warum sind bestimmte Werte fett markiert?

Fett markierte Werte können erweitert werden und enthalten untergeordnete Werte.


Welches sind die möglichen Werte?

Bewegen Sie den Mauszeiger über einen Wert. Gegebenenfalls erscheint dort ein Text mit den Mindest-, Höchst- und Standardwerten.


Tabellenansicht: Allgemeine Anordnung und Struktur

Die Tabellenansicht ist ein Anzeigetool in Rasterform.

In der Kopfzeile wird der Gerätename angezeigt. In der unteren Kopfzeile werden die für das Gerät verfügbaren Setups angezeigt. Die Zeilenköpfe (fett markiert) können per Klick auf das Symbol neben ihnen reduziert bzw. erweitert werden. Für getrennte Geräte wird in der Kopfzeile ein Symbol zum Wiederherstellen der Verbindung angezeigt.

Einstellungen, die nicht vom Lese-Setup abhängen, werden nur in der ersten Spalte angezeigt (Haupt-Setup).


Tabellenansicht: Steuerung (Maus und Tastatur)

Auswahl:

  • Maus: Sie wählen eine Rasterzelle aus, indem Sie darauf klicken. Dadurch werden der Zeilenkopf der Zelle und der Spaltenkopf zu Lesegerät und Setup markiert. Die Menüschaltflächen und -elemente im Menübandmenü können sich je nach Auswahl ändern. Wenn sich die ausgewählte Zelle in einer Kopfzeile befindet, werden alle Zellen in der aktuellen Spalte ausgewählt, die zu der Kopfzeile gehören.

  • Tastatur: Über die Tasten zum Bewegen des Cursors können Sie die gewünschte Zelle auswählen. Das Markierungs- und Auswahlverhalten entspricht dem mit einer Maus.

Hinzufügen/Ändern von Werten:

  • Maus: Bei Zellen mit integrierten Editors können Sie Werte eingeben, indem Sie auf die Editorsteuerung (Kombinationsfeld, Kontrollkästchen, numerisches Auf-Ab-Steuerelement) klicken. Bei Zellen mit benutzerdefinierten Editors (Symbol „...“), wird ein Pop-up-Editor geöffnet, in dem Sie Werte eingeben können.

  • Tastatur: Bei Zellen mit integrierten Editors starten Sie durch Drücken der Eingabetaste oder der Taste F2 den Bearbeitungsmodus. Mit Esc brechen Sie die Bearbeitung ab. Um eine Bearbeitung zu bestätigen, drücken Sie die Eingabetaste ein zweites Mal. Sie können Werte in ausgewählten Text eingeben, ohne in den Bearbeitungsmodus zu wechseln. In diesem Fall wird der aktuelle Wert mit dem ersten Tastaturanschlag überschrieben.

    Bei numerischen Zellen können Sie zusätzlich zu den integrierten Texteditorzellen den Wert über die Auf- und Abwärtspfeile erhöhen bzw. verringern.

    Bei Drop-down-Zellen wechseln Sie durch Drücken der Eingabetaste in den Bearbeitungsmodus. Daraufhin werden die Drop-down-Elemente angezeigt. Mit den Auf- und Abwärtspfeilen können Sie die Auswahl verschieben. Wenn Sie die Eingabetaste erneut drücken, wird der ausgewählte Wert übernommen. Drücken Sie Esc, um die Bearbeitung abzubrechen.

    Bei Zellen mit Kontrollkästchen können Sie über die Leertaste zwischen aktiviertem und deaktiviertem Status wechseln.

Kopieren und Einfügen:

Verwenden Sie zum Kopieren und Einfügen die Tastenkombinationen STRG+C und STRG+V. Weitere Informationen können Sie der Beschreibung für Kopieren und Einfügen der entsprechenden Menüelemente im Menübandmenü entnehmen.


Tabellenansicht: Menübandmenü

Das Menübandmenü befindet sich über dem Tabellenansichtsraster. Inhalte und aktive Symbole können sich je nach den im Raster ausgewählten Zellen, Zeilen oder Spalten ändern. Das Menü ist in verschiedene Gruppen unterteilt.

  • Tabellenansicht: Über die Schaltfläche Setup hinzufügen können Sie dem ausgewählten Gerät Setups hinzufügen oder auf das Gerät kopieren. Mit Setup löschen löschen Sie die ausgewählten Lese-Setups. Mit der Schaltfläche Reihenfolge ändern können Sie die Reihenfolge der Lese-Setups ändern, zwischen denen das Gerät wechselt.

  • Bearbeiten: Mit Kopieren (oder STRG+C auf der Tastatur) können Sie einen Wert aus der aktuell ausgewählten Zelle kopieren. Einfügen kann nur in derselben Zeile oder in einem Texteditor verwendet werden. Mit Werte zurücksetzen setzen Sie die Werte der ausgewählten Zellen zurück.

  • Markieren: Über die Schaltflächen und Einstellungen in dieser Menügruppe können Sie bestimmte Zellenhintergründe markieren. Bei der Einstellung Nicht-Standardwerte werden Zellen mit anderen als den Standardwerten markiert (diese können in ein und derselben Zeile für verschiedene Lese-Setups oder Geräte unterschiedlich sein). Bei der Einstellung Differenz zur Referenz werden Zellen markiert, die einen anderen Wert als die Zelle des Referenz-Lese-Setups (und -Geräts) in derselben Zeile haben. Bei Auswahl der dritten Einstellung werden alle Werte und Kopfzeilen markiert, die den im Textfeld angegebenen Text enthalten. Zusätzlich ist auch der enthaltene Text als solcher durch einen anderen Texthintergrund markiert. Drücken Sie die Eingabetaste, um auch die Funktion der Schaltfläche Nur markierte Zeilen anzeigen anzuwenden.

    Bei Auswahl von Nur markierte Zeilen anzeigen werden alle Knoten reduziert, die keinen markierten Unterknoten enthalten. Mit Referenz-Lese-Setup festlegen legen Sie das Lese-Setup (und das Gerät) fest, das bei Verwendung des Markierungsmodus Differenz zur Referenz als Referenz verwendet wird. Ist diese Schaltfläche aktiv, wird die Spalte (Lese-Setup) der aktuell ausgewählten Zelle als Referenz-Setup festgelegt. Das aktuelle Referenz-Setup ist in der Kopfzeile mit dem Setup-Namen gekennzeichnet.

  • Filterung: Die Standardeinstellung Allgemeine Einstellungen zeigt nur Einstellungen an, die keine abweichenden Werte für verschiedene Lese-Setups haben können. Über Lese-Setup-Einstellungen können Sie die Anzeige auf die Einstellungen einschränken, die vom Lese-Setup abhängen. Wählen Sie Alle Einstellungen aus, um alle Einstellungen auf einmal anzuzeigen. Wenn ein Eintrag Werte in mehreren Lese-Setups hat, werden diese in mehreren Spalten angezeigt.

  • Sonstige: Mit Alle Zeilen erweitern erweitern Sie alle Zeilen, die im Raster reduziert sind. Mit Alle Zeilen reduzieren reduzieren Sie alle Zeilen, die im Raster erweitert sind. Mit Anordnung zurücksetzen werden die Spaltenbreiten neu berechnet, sodass der gesamte verfügbare Platz genutzt wird. Reicht der verfügbare Platz nicht aus, wird eine Spaltenmindestbreite verwendet.


Rechtliche Informationen


Copyright

Die Cognex Corporation übernimmt keinerlei Verantwortung für die Verwendung und Zuverlässigkeit ihrer Software bei Anlagen, die nicht von der Cognex Corporation stammen. Die Cognex Corporation übernimmt keinerlei ausdrückliche oder implizite Garantien hinsichtlich der beschriebenen Software, ihrer Marktgängigkeit oder ihrer Eignung für einen bestimmten Zweck.

Die in diesem Dokument enthaltenen Informationen können sich jederzeit und ohne Vorankündigung ändern und sind für die Cognex Corporation nicht bindend. Die Cognex Corporation übernimmt keinerlei Verantwortung für Fehler in diesem Dokument oder in der zugehörigen Software.

Copyright © 2019 Cognex Corporation. Alle Rechte vorbehalten

Dieses Dokument darf ohne schriftliche Genehmigung der Cognex Corporation weder vollständig noch teilweise kopiert oder auf andere Medien oder in andere Sprachen übertragen werden.

Hardware und Teile der in diesem Dokument beschriebenen Software sind möglicherweise durch ein oder mehrere US-Patente geschützt, die auf der Cognex Website http://www.cognex.com/patents.asp aufgeführt sind. Weitere US-Patente und ausländische Patente sind angemeldet.


Lizenzierte Software

SpiderMonkey

Diese Software unterliegt den Bestimmungen der Mozilla Public License 2.0 (MPL). Unter http://mozilla.org/MPL/2.0/ können Sie eine Kopie der MPL abrufen.

Wenden Sie sich an den technischen Kundendienst von Cognex unter <spidermonkey@cognex.com>, wenn Sie eine Kopie des SpiderMonkey-Quellcodes benötigen.

PCRE-Lizenz

PCRE ist eine Funktionsbibliothek zur Unterstützung regulärer Ausdrücke, deren Syntax und Semantik weitestgehend der Sprache PERL 5 entlehnt sind.

Die Distribution von PCRE Version 5 erfolgt gemäß den Bedingungen der nachstehend aufgeführten „BSD“-Lizenz. Die Distribution der im Verzeichnis „doc“ befindlichen PCRE-Dokumentation erfolgt unter den gleichen Bedingungen wie bei der Software.

Verfasst von: Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England. Telefon: +44 1223 334714.

Copyright (c) 1997–2004 University of Cambridge. Alle Rechte vorbehalten.

Die Weitergabe und Verwendung im Quell- oder Binärformat in veränderter oder unveränderter Form ist erlaubt, wenn die folgenden Bedingungen erfüllt sind:

  • Bei Weitergabe des Quellcodes müssen der vorstehende Copyright-Hinweis, diese Liste der Bedingungen sowie der nachstehende Haftungsausschluss mit weitergegeben werden.
  • Bei Weitergabe in Binärform müssen in der Dokumentation und in den übrigen Weitergabeunterlagen der vorstehende Copyright-Hinweis, diese Liste der Bedingungen sowie der nachstehende Haftungsausschluss enthalten sein.
  • Ohne vorherige schriftliche Genehmigung dürfen weder der Name der University of Cambridge noch die Namen der Mitarbeiter dazu verwendet werden, ein Produkt zu kennzeichnen oder zu bewerben, das aus dieser Software abgeleitet wurde.

DIESE SOFTWARE WIRD VON DEN COPYRIGHT-INHABERN UND MITARBEITERN IN DER VORLIEGENDEN FORM ZUR VERFÜGUNG GESTELLT. ALLE AUSDRÜCKLICHEN ODER IMPLIZITEN GARANTIEN EINSCHLIESSLICH, ABER NICHT NUR, DER IMPLIZITEN GARANTIEN DER MARKTGÄNGIGKEIT UND EIGNUNG FÜR EINEN BESTIMMTEN ZWECK WERDEN AUSGESCHLOSSEN. UNTER KEINEN UMSTÄNDEN HAFTEN DER COPYRIGHT-EIGENTÜMER ODER SEINE MITARBEITER FÜR DIREKTE, INDIREKTE ODER BEISPIELHAFTE SCHÄDEN SOWIE FÜR SONDER-, NEBEN- ODER FOLGESCHÄDEN (EINSCHLIESSLICH DER BESCHAFFUNG VON ERSATZGÜTERN UND -DIENSTLEISTUNGEN, NUTZUNGSAUSFÄLLE, DATENVERLUSTE, ENTGANGENER GEWINNE ODER GESCHÄFTSUNTERBRECHUNGEN), DIE SICH AUFGRUND BELIEBIGER URSACHEN UND HAFTUNGSTHEORIEN AUS VERTRAG, STRENGER HAFTUNG ODER WEGEN UNERLAUBTER HANDLUNG (FAHRLÄSSIGKEIT ODER SONSTIGE GRÜNDE EINGESCHLOSSEN) DURCH VERWENDUNG DIESER SOFTWARE IN BELIEBIGER FORM ERGEBEN KÖNNEN. DIES GILT AUCH FÜR DEN FALL, DASS DIE MÖGLICHKEIT EINES DERARTIGEN SCHADENS VORAB ANGEKÜNDIGT WURDE.

Ende

JPEG-Software

Diese Software basiert zum Teil auf den Arbeiten der Independent JPEG Group.

zlib-Komprimierungsbibliothek

Diese Software basiert zum Teil auf den Arbeiten von Jean-Loup Gailly und Mark Adler.

Parsifal XML-Parser

Copyright (c) 2002–2005 Toni Uusitalo, Veröffentlichung als Public-Domain-Software am 15.11.2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal ist für die kommerzielle und nichtkommerzielle Nutzung und Weitergabe frei verfügbar, wenn Copyright und Haftungsausschluss des Autors in unveränderter Form weitergegeben werden. Sie dürfen Parsifal für persönliche Zwecke ändern und mit Ihren Veränderungen weitergeben, wenn Sie die Änderungen klar dokumentieren.

HAFTUNGSAUSSCHLUSS

Die Weitergabe dieses Programms erfolgt, um Ihnen nützlich zu sein. EINE GARANTIEZUSAGE ERFOLGT NICHT. Dieser Ausschluss bezieht sich auch auf die Marktfähigkeit oder die Eignung für einen bestimmten Zweck. Die Verwendung erfolgt AUF EIGENES RISIKO.


Patenthinweise

Dieses Produkt ist durch eines oder mehrere der unten aufgeführten US-Patente, US-Anwendungen und/oder ausländische Patente geschützt. Auf http://www.cognex.com/patents werden ggf. relevante später erteilte Patente aufgeführt.

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 und EP1687752