DataMan 8050 : Questions - Réponses


Écran d'accueil


Bienvenue

Afin de configurer rapidement votre périphérique, nous vous conseillons de parcourir les Étapes de l'application représentées par de gros boutons sur le côté gauche. Chaque section comprend un onglet présentant les options de configuration Basiques ou Avancées. Le bouton d'action Enregistrer les paramètres enregistre les données de configuration dans le lecteur et enregistre une sauvegarde sur votre PC en un simple clic. Les questions ci-dessous décrivent pour chaque Étape de l'application les options de configuration qui ne sont pas explicites.


Que puis-je définir dans Type d'application ?

Cliquer sur la flèche à droite vous permet de sélectionner les modes de lecture appropriés dans le menu déroulant.


Que puis-je faire à l'étape Optimiser l'image ?

Ici, vous pouvez procéder à la configuration, au réglage et au test de votre périphérique connecté, et régler vos paramètres d'éclairage pour le périphérique.


Que puis-je sélectionner dans Détails du code ?

Ici, vous pouvez sélectionner les symbologies que DataMan devra lire, ainsi que différents scénarios multicode. Les paramètres avancés du décodeur peuvent également être modifiés depuis ce menu.


Que puis-je définir à l'étape Détails de l'application ?

Les paramètres de déclenchement et d'exposition peuvent être définis ici. Pour plus de facilité, un Assistant de déclenchement, un Assistant d'intervalle et un Assistant d'exposition vous aident à définir ces paramètres.

Il est possible d'ajouter de nouveaux paramètres dans la vue tabulaire depuis l'onglet Avancé.


Que puis-je configurer dans Données de format ?

Pour que le périphérique renvoie les données désirées, vous pouvez utiliser le Format de base ou les expressions Perl Style normales pour créer une chaîne de sortie personnalisée au moyen d'éléments prédéfinis, ou utiliser le moteur JavaScript pour créer un script de formatage de données flexible.


Que puis-je définir à l'étape Entrées/Sorties ?

Le comportement des boutons et des lignes d'entrée et de sortie peut être défini dans ce volet. Les détails relatifs à la longueur d'impulsion d'un codeur d'impulsions et de l'avertisseur sonore peuvent également être définis ici. Ce volet présente également le lien vers les paramètres de la mémoire tampon d'image permettant de transférer les images vers un serveur.


Que puis-je définir à l'étape Application de communications ?

Sur les trois onglets de l'étape Application de communications, vous pouvez exécuter les paramètres série et Ethernet. Cliquez sur l'onglet approprié pour saisir les valeurs de vos paramètres.


Que fait le bouton Enregistrer les paramètres ?

Enregistrer les paramètres est une action plus qu'une étape, mais elle est importante. Cette action permet d'enregistrer la configuration actuelle dans la mémoire permanente du lecteur, de sorte que les mêmes paramètres soient chargés après redémarrage. L'Outil de paramétrage DataMan enregistre également un fichier de sauvegarde localement sur le PC actuel dans le dossier de sauvegarde par défaut.


Qu'est-ce que le fichier de sauvegarde de configuration ?

Le fichier de sauvegarde de configuration contient tous les paramètres et les données de configuration du périphérique. Peut être utilisé pour restaurer les réglages à un état connu ou configurer de nouveaux périphériques en choisissant des paramètres de configuration avec ou sans les propriétés sauvegardées.


Connexion au lecteur


Comment connecter mon lecteur à l'outil de configuration ?

Quel que soit le lecteur utilisé, procédez comme suit pour connecter votre lecteur DataMan à l'outil de configuration :

  1. Imprimez une copie du document Codes de configuration du lecteur qui concerne votre lecteur en particulier, disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration.

  2. Connectez le câblage nécessaire entre votre lecteur et le PC en exécutant l'outil de configuration. Pour obtenir des détails, reportez-vous à la documentation papier de l'Aide-mémoire.

  3. Cliquez sur Actualiser dans l'outil de configuration.

  4. Sélectionnez le Port COM ou le Périphérique réseau indiquant une connexion à votre lecteur.

  5. Cliquez sur Connecter.


Pourquoi l'outil de configuration n'arrive-t-il pas à se connecter au lecteur ?

Si vous n'arrivez pas à vous connecter, vérifiez les points suivants :

  • Vérifiez que vous avez bien lu le code de configuration (USB COM ou RS-232 série) qui correspond au type de connexion physique utilisée (non applicable aux lecteurs fonctionnant uniquement via Ethernet).

  • Assurez-vous que le pare-feu ou l'antivirus installés sur votre ordinateur autorisent la communication avec des périphériques Ethernet en autorisant les ports concernés (Cognamer 1069 et Outil de configuration 44444).

  • Veillez à ce que la liste des ports COM indique le port où votre lecteur est connecté.

    DataMan séries 60, 300, 370, 470, 503 et 8000 : si votre lecteur est connecté à votre réseau Ethernet, vérifiez qu'il apparaît dans la liste des Périphériques réseau.

    Cliquez sur Actualiser pour détecter les ports connectés à des lecteurs.

    Remarque : lorsque vous cliquez sur Actualiser, une chaîne de requête est envoyée à tous les ports COM et à travers le sous-réseau Ethernet. Un lecteur sans fil DataMan 8000 doit être actif pour répondre à la requête. Appuyez sur la gâchette du lecteur pour l'activer.

  • Vérifiez que vous n'utilisez pas le clavier, l'émulation de clavier ou la connexion HID : vous devez utiliser la liaison USB Série, RS-232 Série, un réseau Ethernet ou sans fil pour connecter l'outil de configuration au lecteur.

  • DataMan séries 60, 300, 370, 470, 503 et 8000 : veillez à ce que l'adresse IP indiquée dans l'option Ajouter un périphérique soit correcte.

  • Lecteur DataMan 8000 sans fil uniquement : vérifiez que le lecteur n'est pas en mode veille (appuyez sur le déclencheur pour l'activer).

  • Lecteur DataMan 8000 sans fil uniquement : vérifiez qu'une connexion a bien été établie entre votre lecteur et la station de base connectée à votre PC. Pour vous en assurer, lisez le code de configuration Déconnecter imprimé dans l'Aide-mémoire, débranchez les câbles d'alimentation et de communication de la station de base, rebranchez-les, puis remettez le terminal en place dans la station de base. Patientez jusqu'à ce que le terminal indique qu'il est connecté (par un signal sonore) avant de réessayer de vous connecter.

  • Lecteur DataMan 8000 sans fil uniquement : vérifiez que la station de base est branchée à une source d'alimentation électrique.

Vous pouvez utiliser un programme d'émulation de terminal comme HyperTerminal pour déterminer si le lecteur envoie ou non des données lorsqu'il est connecté à un port COM du PC.


Pourquoi une icône superposée s'affiche dans le coin droit supérieur de mon icône de périphérique ?

La flèche indique qu'il s'agit d'un périphérique ajouté manuellement. L'icône « V » indique que le périphérique est un périphérique virtuel.


Que sont les périphériques virtuels ?

L'icône superposée « V » dans l'angle supérieur droit de l'icône de périphérique indique que le périphérique est un périphérique virtuel. Les périphériques virtuels peuvent être créés sous Réparation et assistance, soit à partir d'un fichier de configuration personnalisé ou d'un périphérique avec une configuration par défaut. Les périphériques virtuels peuvent servir à consulter différents volets dans l'outil de configuration sans devoir connecter un périphérique réel.

Le périphérique virtuel créé n'est pas visible pour les autres périphériques du réseau. Le périphérique virtuel est conservé pour de multiples instances de l'outil de configuration.

Le périphérique virtuel créé peut être connecté de la même façon qu'un périphérique normal, sauf que toutes les modifications de la configuration sont annulées (tout est en lecture seule) et aucune fonctionnalité, fonction ou action ne fonctionne sur les périphériques virtuels.


Quel port utiliser pour une connexion USB ?

Si vous connectez le lecteur ou la station de base à l'aide du port USB, veillez à bien lire le code de configuration USB-COM/RS-232 à partir du document Codes de configuration du lecteur. Cliquez ensuite sur Actualiser et sélectionnez le port connecté au lecteur.

Remarque : lorsque vous cliquez sur Actualiser, une chaîne de requête est envoyée à tous les ports COM et à travers le sous-réseau Ethernet. Un lecteur sans fil DM7550 et un lecteur sans fil DM8000 doivent être activés pour répondre à la requête. Appuyez sur le déclencheur du lecteur pour l'activer.


Je ne parviens toujours pas à connecter mon lecteur ou ma station de base : puis-je le réinitialiser ?

Pour la station de base DataMan 8000 :

A l'aide du lecteur sans fil associé à votre station de base, numérisez la commande Réinitialiser la base du lecteur avec les paramètres d'usine (pour DM8000 Base) pour reconfigurer la station de base avec les réglages d'usine.

Pour les lecteurs DataMan Séries 503 et 8000 :

Numérisez la commande Redémarrer le scanner imprimée au dos de l'Aide-mémoire pour effectuer une réinitialisation logicielle. A la réinitialisation, le lecteur s'arrête et redémarre sans que la mémoire non volatile du lecteur ne soit effacée.

Si cela ne fonctionne pas, numérisez la commande Réinitialiser le scanner avec les paramètres d'usine pour reconfigurer le lecteur sur ses réglages d'usine.

Si cela ne fonctionne pas et que vous utilisez un lecteur connecté à l'aide d'un câble, débranchez l'alimentation du lecteur (sauf pour le DataMan 9500). Tout en maintenant le déclencheur enfoncé, rebranchez l'alimentation du lecteur. Maintenez le déclencheur enfoncé pendant au moins 6 secondes jusqu'à entendre un double signal sonore (bip). Les voyants du lecteur clignotent de différentes couleurs.

Si cela ne fonctionne pas et que vous utilisez un lecteur DataMan 8000 sans fil, retirez la batterie du lecteur et placez-le sur la station de base du lecteur. Tout en maintenant le déclencheur enfoncé, rebranchez l'alimentation du lecteur. Maintenez le déclencheur enfoncé pendant au moins 6 secondes jusqu'à entendre un double signal sonore (bip). Les voyants du lecteur clignotent de différentes couleurs.

Pour les lecteurs DataMan séries 50, 60 et 70 :

Imprimez une copie du document Codes de configuration du lecteur qui concerne votre lecteur en particulier, disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration.

Scannez la commande Redémarrer le scanner pour effectuer une réinitialisation logicielle. A la réinitialisation, le lecteur s'arrête et redémarre sans que la mémoire non volatile du lecteur ne soit effacée.

Si vous ne réussissez toujours pas à connecter le lecteur, numérisez la commande Réinitialiser le scanner avec les paramètres d'usine pour reconfigurer le lecteur sur ses réglages d'usine.

Si cela ne résout pas le problème, débranchez l'alimentation du lecteur (alimentation CC et USB, le cas échéant). Tout en maintenant le déclencheur enfoncé, rebranchez l'alimentation du lecteur. Maintenez le déclencheur enfoncé pendant au moins 6 secondes jusqu'à entendre un double signal sonore (bip). Les voyants du lecteur clignotent de différentes couleurs.


Comment reconnaître mon périphérique ?

Pour les lecteurs DataMan séries 260, 300, 473, 500, 503 et 8000 :

Effectuez un clic droit sur un lecteur dans l'arborescence où les périphériques sont énumérés sous Connexion au lecteur puis sélectionnez Identifier. Le voyant lumineux d'état sur le lecteur émet un signal vous permettant de l'identifier.


Pourquoi certains périphériques apparaissent-ils en vert ?

Les nouveaux périphériques détectés s'affichent en vert pendant quelques secondes afin de vous signaler l'ajout d'un nouveau périphérique à l'arborescence.


DataMan séries 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 et base du lecteur DataMan 8000 : pourquoi l'outil de configuration me réclame-t-il un mot de passe lorsque je veux me connecter ?

Le lecteur et la station de base peuvent être configurés de manière à réclamer un mot de passe avant de se connecter à l'outil de configuration. Le mot de passe est activé sur l'onglet Authentification, au niveau de l'option Paramètres réseau du volet Paramètres de communication. Notez que le mot de passe est également utilisé pour la connexion série.


DataMan série 60, 300, 370, 470, 503, 8000 et base du lecteur DataMan 8000 : puis-je connecter le lecteur directement à mon PC en utilisant Ethernet ?

Le lecteur ou la station de base peuvent être connectés directement à un connecteur Ethernet (RJ-45) sur votre PC. Si votre périphérique est configuré pour DHCP, il apparaît dans la liste des Périphériques réseau au bout d'environ 20 secondes. Notez, cependant, qu'une minute supplémentaire peut être nécessaire à votre PC pour résoudre son adresse IP. Tant que cette opération n'est pas terminée, vous ne pouvez pas connecter votre périphérique via l'outil de configuration.

Si votre périphérique a été configuré sur une adresse IP statique, il n'apparaît que si le PC et lui partagent le même sous-réseau.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000 et station de base du lecteur DataMan 8000 : comment puis-je mettre en correspondance une liste de la liste des périphériques réseau avec un lecteur donné ?

Par défaut, chaque DataMan apparaît dans la liste des Périphériques réseau avec un préfixe DM et les six derniers caractères de son adresse MAC qui figure sur le périphérique lui-même.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 et station de base du lecteur DataMan 8000 : que faire si mon lecteur ou ma station de base n'apparaît pas dans la liste des périphériques réseau ?

Si le lecteur ou la station de base souhaité(e) n'est pas répertorié(e), vous pouvez l'ajouter en l'éteignant puis en le/la rallumant. Il peut s'écouler jusqu'à 60 secondes avant que le périphérique n'apparaisse dans la liste après la mise sous tension.

Si la procédure d'extinction/de rallumage ne parvient pas à résoudre le problème, l'outil de configuration peut ne pas être en mesure de communiquer avec votre périphérique en raison de la configuration du réseau et il n'apparaîtra pas dans la liste des périphériques réseau.

Vérifiez la connexion Ethernet du lecteur ou de la station de base puis cliquez sur Actualiser dans l'outil de configuration.

si vous connaissez l'adresse IP du lecteur ou de la station de base, utilisez l'option Ajouter un périphérique.

Cette méthode devrait permettre au lecteur ou à la station de base DataMan d'apparaître dans la liste des périphériques réseau de manière à ce que vous puissiez vous y connecter via l'outil de configuration et votre connexion Ethernet.


Lecteur sans fil DataMan 8000 : comment connecter un lecteur sans fil à une autre station de base ?

Si la station de base à laquelle vous souhaitez connecter votre lecteur sans fil est déjà connectée à un autre lecteur, vous devez supprimer cette connexion en lisant le code Désassigner le lecteur de la station de base. Pour assigner le lecteur à une nouvelle station de base, il suffit de placer le nouveau lecteur dans la station de base. Ils sont automatiquement synchronisés.


Station de base du DataMan 8000 : comment réinitialiser la connexion USB à la station de base ?

Si vous avez du mal à établir ou à conserver une connexion USB entre une station de base et votre PC, procédez comme suit pour reconfigurer la connexion USB :

  1. Déconnectez le câble USB et le câble d'alimentation de la station de base.

  2. Reconnectez le câble USB et le câble d'alimentation à la station de base.

  3. Placez le lecteur dans la station de base.

  4. Retirez le lecteur de la station de base et scannez le code de configuration USB-COM/RS_232.


Comment fonctionne le bouton Comparaison de la configuration ?

Le bouton Comparaison de la configuration démarre la fonction de comparaison de la configuration de l'outil de configuration, un outil de type vue tabulaire utilisé pour régler, copier, comparer ou rétablir les configurations des périphériques. La fonction s'ouvre dans une nouvelle page de document.

Si aucun périphérique n'est sélectionné dans la liste des périphériques avant d'appuyer sur le bouton, un document vide est ouvert. Si un ou plusieurs périphériques sont sélectionnés, le document de comparaison est peuplé avec les paramètres de ces périphériques.


Quel est le périphérique RTM Lean ou de surveillance en temps réel (RTM) qui apparaît sous Réseau ?

RTM (surveillance en temps réel, Real Time Monitoring en anglais) Lean est une fonction intégrée à l’Outil de configuration DataMan et la surveillance en temps réel est une application logicielle avec prise en charge matérielle, accessible par l’Outil de configuration DataMan, qui permet la collecte et l’analyse de différents types de données relatives aux périphériques sur le réseau et à leurs lectures. Vous pouvez vous connecter à RTM Lean ou RTM comme vous vous connecteriez à un périphérique, puis paramétrer la collecte des données dans un document nouvellement ouvert. L’application RTM Lean ou RTM ne collecte activement les données que lorsqu’elle est activée et que vous y êtes connecté.

Lors de la configuration initiale, vous devez sélectionner le périphérique devant être surveillé par RTM Lean ou RTM, puis quel type de données (outre les données par défaut) doivent être collectés. Ceci peut être redéfini sous Configuration sur le menu ruban. Par défaut, RTM Lean ou RTM collecte des données statistiques (taux de lecture, nombre de déclenchements, dépassement du déclencheur, dépassement de la mémoire tampon et les mesures de contrôle du processus, si cette option est activée).

REMARQUE : RTM Lean peut collecter des données à partir d’un seul périphérique à la fois et conserver ces données pendant 48 heures. La version complète de RTM n’est pas soumise à de telles limites.


Optimiser l’image


Que puis-je faire à l'étape Optimiser l'image ?

Vous pouvez ici procéder à la configuration, au réglage et au test de votre périphérique connecté.

Pour paramétrer rapidement votre périphérique, nous vous conseillons de parcourir les Étapes d'application représentées par de gros boutons placés au milieu parmi lesquels vous pouvez choisir entre les options de configuration Basiques ou Avancées. Le bouton d'action Enregistrer les paramètres vous permet d'enregistrer vos données de configuration très simplement. Les questions ci-dessous décrivent pour chaque Étape de l'application les options de configuration qui ne sont pas explicites.


Comment enregistrer une image acquise dans un fichier ?

Cliquez sur le bouton Enregistrer l'image dans la barre d'outils du Volet d'images ou de la Visionneuse d'images.

Vous pouvez également glisser et déposer votre image dans votre PC. Cliquez sur l'image dans la fenêtre Affichage de l'image, glissez-la hors de l'outil de configuration et relâchez-la.

REMARQUE : si vous souhaitez enregistrer une image avec la fonction glisser/déposer et si l'image n'est pas la plus récente (vous l'enregistrez à partir de l'Historique des résultats de lecture), l'image sera enregistrée avec les paramètres de qualité des images. Par défaut, sa qualité est réduite. Sous Paramètres de l'image affichée, vous pouvez changer la taille de l'image pour passer en plein écran et le format pour passer à Bitmap.


Comment puis-je utiliser le bouton Live ?

Dans l'onglet Basique, cliquez sur le Bouton Continu pour passer au mode Continu. Le mode Live ne surveille pas seulement ce qui est lu par le périphérique, il le décode également. Un clic sur l'extrémité droite du bouton ouvre d'autres options.

Cochez la case Décodage si vous souhaitez que le périphérique décode les images capturées. Lorsque la case Retour mise au point est cochée, une échelle de couleur est visible sur le côté gauche de la vue de l'image. Cette échelle indique la mise au point de la lentille (plus le curseur est bas, moins la mise au point est élevée).

Cliquez sur l'option Exposition automatique pour que le lecteur détermine automatiquement les meilleurs réglages d'exposition dans l'image. Le curseur (en-dessous de la zone de visionnage d'image) indique la luminosité de pixel de la cible.

Dans l'onglet Avancé, vous pouvez afficher une vue tabulaire des paramètres d'image.


À quelle fin puis-je utiliser le volet Performance de lecture ?

Avec les graphiques sous le volet Performance de lecture, vous pouvez surveiller les temps de décodage et les taux de lecture en temps réel. Cliquez sur le bouton Effacer pour réinitialiser le graphique.


Quels paramètres de déclenchement puis-je modifier ?

Vous pouvez définir le Type de déclencheur soit sur Manuel (bouton) soit sur Présentation (interne). Pour plus de paramètres de déclenchement, allez sur le volet Paramètres d'éclairage et d'imageur en cliquant sur l'élément de ruban correspondant et sélectionnez l'onglet Paramètres de déclenchement.

Veuillez noter qu'en mode de Présentation, lorsque l'opérateur actionne le déclencheur, le lecteur passe en mode Manuel jusqu'à ce que le périphérique soit à nouveau posé dans la station de base.

Pour de plus amples informations, consulter les Questions et Réponses Détails de l'application.


Comment puis-je modifier l'indice d'exposition pour le DataMan 8050 ?

Ce paramètre est activé lorsque vous utilisez l'Exposition manuelle (à laquelle vous pouvez passer dans le volet Paramètres d'éclairage et d'imageur).


Que désignent les paramètres de qualité des images ?

Les paramètres de qualité des images contrôlent la manière dont le lecteur affiche les images dont il procède à l'acquisition en réponse aux déclencheurs d'acquisition, ainsi que les images en direct issues de n'importe quel lecteur. La modification de ces paramètres n'affecte pas les performances du lecteur, mais uniquement la qualité des images et le débit de transfert entre le lecteur et l'outil de configuration.

REMARQUE : certaines propriétés relatives à l'image (par ex. taille de l'image, filtrage) ne peuvent pas être modifiées lorsque le périphérique est en train d'acquérir ou de décoder des images.

REMARQUE : les Paramètres d'affichage des images n'ont aucun effet lors de la sauvegarde de la dernière image prise du Volet d'images (par glisser-déposer) La dernière image est toujours sauvegardée en pleine taille (la résolution maximum du périphérique).

  • Taille : par défaut, l'outil de configuration affiche un quart de tous les pixels de chaque image acquise ou une fraction de chaque image pendant un affichage continu. Le choix d'une taille d'image permet au lecteur d'effectuer un sous-échantillonnage de chaque image, ce qui améliore considérablement la vitesse de transfert des images entre le lecteur et l'outil de configuration au détriment des détails précis des images.

  • Qualité : disponible uniquement si vous utilisez le format d'image .jpeg, ce curseur ajuste les paramètres internes qui permettent au lecteur de lisser l'image acquise. Cette opération peut diminuer ou améliorer la vitesse de transfert entre le lecteur et l'outil de configuration.


Que puis-je changer avec le curseur Intensité interne ?

Vous pouvez paramétrer l'intensité de la luminosité de l'éclairage LED du DM8050, DM8070.


Comment puis-je spécifier une zone d'intérêt dans chaque image acquise ?

Modifiez vos paramètres dans le volet Taille de l'image (zone d'intérêt).


Qu'est-ce que l'Affichage continu ?

Si vous activez Affichage continu activé (en cliquant sur l'icône de l'affichage continu dans la barre d'outils tout en haut ou dans l'onglet Action), l'affichage de l'image affiche en continu ce que le lecteur voit. Utilisez ce mode pour vérifier ce que le lecteur voit sans décoder de symboles.

Pour modifier la taille et la qualité de l'image affichée en direct, accédez au volet Paramètres de l'image affichée.

REMARQUE : cette option n'est pas disponible sur DM262 et DM362.


Comment accélérer le transfert des images ?

Lorsque la case Transférer et afficher l'image est cochée, l'outil de configuration transfère l'image acquise lors de chaque décodage. Si l'appareil reçoit un nouveau signal de déclenchement pendant le transfert de l'image, le lecteur supprime l'image partiellement transférée et commence à transférer la nouvelle image.

La vitesse de transfert de l'image dépend de la compression de l'image effectuée par le lecteur. Sélectionnez l'option Qualité de l'image affichée pour contrôler le rapport de compression des images. La diminution de la taille ou de la qualité de l'image accélère le transfert.


J'ai coché la case « Transférer et afficher les images ». Pourquoi aucune image n'est visible ?

Si vous interrompez le transfert d'image en appuyant sur le déclencheur, aucune image ne sera transférée. Les anciennes images de la grille Historique de lecture peuvent également ne pas s'afficher.

Remarque : Si le délai de sortie est plus court que le temps nécessaire au lecteur pour acquérir une image et obtenir des résultats du décodage, l'outil de configuration peut ne pas recevoir d'images de résultat du lecteur.


Détails du code


Comment puis-je désactiver rapidement toutes les symbologies ?

Cliquez sur Désactiver toutes les symbologies dans la partie supérieure de l'onglet Basique de l'étape d'application Détails du code ou appuyez sur Ctrl+D.


Comment définir les paramètres de symbologie avancés ?

Cliquez sur l'onglet Avancé sous Détails du code pour préciser davantage de paramètres.


Le lecteur distingue-t-il automatiquement les différents types de symbologie ?

Le lecteur détecte, identifie et décode automatiquement les symboles encodés à l'aide d'une des symbologies activées dans l'outil de configuration.


Les performances du lecteur sont-elles améliorées si on limite le nombre de symbologies activées ?

Pour de meilleurs résultats, activez uniquement les types de symbologie que vous pensez rencontrer.


Quels sont les paramètres des propriétés du code EAN.UCC Composite ?

  • Standard (linéaire et 2D) : comporte une composante linéaire (codage de l'identification primaire de l'article) associée à une composante 2D Composite (codage de données supplémentaires - ex. numéro de lot ou date de péremption)

  • Linéaire uniquement : uniquement composé du codage de la composante linéaire de codage d'identification primaire de l'article.


Qu'est-ce que CC-C ?

CC-C désigne l'une des trois composantes 2D Composite EAN.UCC, à savoir un symbole PDF417 doté d'un mot codé de 920 en première position de mot codé des données en tant qu'indicateur de lien et dénotant un compactage de données EAN.UCC.


Propriétés de la symbologie 1D : Qu'est-ce que le décodage cible ?

Le décodage cible simule le comportement d'un lecteur laser de codes-barres. Au lieu d'examiner l'ensemble du champ de vision, toutefois, le lecteur essaie de décoder les codes-barres 1D se trouvant seulement sous le point de pointage laser. Cela évite à l'utilisateur de lire accidentellement d'autres codes-barres 1D situés à proximité.


Propriétés de la symbologie 1D : En quoi consiste la fonction Petite zone de silence ?

Par défaut, l'option Petite zone de silence est activée afin d'autoriser une certaine indulgence de la recherche en ce qui concerne la marge des symboles 1D suivants : code 128, code 39 et code 93.


Propriétés de la symbologie 1D : Que dois-je définir pour un Décodage minimum avant sortie ?

Définissez un chiffre élevé pour augmenter la fiabilité de décodage. Définissez un chiffre peu élevé si votre priorité est la vitesse d'exécution.


Avantage de la spécification d'une taille de code

La spécification d'une taille de code particulière améliore la fiabilité du décodage des symboles par le lecteur. Sélectionnez Toutes si vous lisez différentes tailles de code.


Propriétés code 39

  • La commande ASCII complet permet d'utiliser les Codes 39 étendus.

  • La commande Caractère de vérification décode uniquement les symboles contenant un caractère de vérification valide.

  • La commande Transmettre le caractère de vérification inclut le caractère de vérification dans les données décodées.

  • La commande Convertir en code 32 convertit les caractères code 39 en code 32 si l'option est cochée.


Propriétés code 2/5 entrelacé

  • La commande Caractère de contrôle décode uniquement les symboles contenant un caractère de contrôle valide.

  • La commande Transmettre le caractère de vérification inclut le caractère de vérification dans les données décodées.


Propriétés Pharmacode

Avantage de la spécification d'une taille de code et d'une orientation

La spécification d'une taille de code et d'une orientation particulières améliore la fiabilité du décodage des symboles par le lecteur.

Nombre de caractères de données et nombre de barres dans un symbole

Caractères de données : barres

  • 1 : 3 Remarque : les seuls codes à 1 caractère lus par le lecteur sont ceux comportant 3 barres ou plus. C'est-à-dire seulement 6, 7, 8 et 9.

  • 2 : 3 à 6

  • 3 : 6 à 9

  • 4 : 9 à 13

  • 5 : 13 à 16

  • 6 : 16


Propriétés Codabar

  • La commande Caractère de contrôle décode uniquement les symboles contenant un caractère de contrôle valide.
  • La commande Transmettre le caractère de vérification inclut le caractère de vérification dans les données décodées.
  • La commande Transmettre les caractères de début et de fin inclut les caractères de début et de fin aux données décodées.


Propriétés MSI

  • La commande Caractère de contrôle décode uniquement les symboles contenant un caractère de contrôle valide.
  • La commande Transmettre le caractère de vérification inclut le caractère de vérification dans les données décodées.
  • Méthode de calcul du total de contrôle vous permet de sélectionner la méthode utilisée pour calculer le total de contrôle.


Propriétés DataBar

  • GS1 DataBar réduit : permet d'encoder sur 14 bits l'identification EAN.UCC d'un article avec les chiffres 0 ou 1 dans un symbole linéaire pour l'utiliser avec de petits articles qui ne seront pas lus sur le point de vente.

  • GS1 DataBar : permet d'encoder sur 14 bits l'identification EAN.UCC d'un article sous forme d'un symbole linéaire lisible dans toutes les directions par des lecteurs correctement programmés sur le point de vente.

  • GS1 DataBar étendu : longueur variable, version étendue de la symbologie capable d'encoder les données GTIN à 14 chiffres et données supplémentaires, notamment les dates de péremption, le pays d'origine et les numéros de série (jusqu'à 74 caractères numériques ou 41 caractères alphabétiques).


Propriétés postales

  • POSTNET : symbologie de codes-barres utilisée par le service postal aux États-Unis pour faciliter la distribution du courrier. Le code ZIP ou ZIP+4 utilise cette symbologie unique qui code des barres de différentes hauteurs.

  • PLANET : le code-barres PLANET (Postal Alpha Numeric Encoding Technique) est utilisé par le service postal aux États-Unis pour identifier et suivre le courrier lors de la distribution. De même que POSTNET, il code les données avec des barres de différentes hauteurs.

REMARQUE : les codes postaux peuvent seulement être décodés s'ils sont présentés en position palissade.


Versions du code QR (Quick Response) prises en charge

Le code QR (Quick Response) est une symbologie 2D qui comporte un carré de modules blancs et foncés utilisés pour coder les données. Le lecteur distingue 3 types :

  • Modèle 1 : version originale

  • Modèle 2 : version améliorée

  • Code Micro QR : très petite version du code QR adaptée aux applications qui exigent moins de place et utilisent moins de données que les autres versions du code QR


Propriétés code QR

Taille de grille maximale

La taille de grille maximale permet de décoder les codes QR plus larges que la taille 49. Vous pouvez soit faire glisser le curseur soit saisir une taille de code spécifique dans la zone de texte sur la droite.

Mesures de qualité du code QR

Pour plus d'informations sur les mesures de qualité du code, voir le Guide de communication et de programmation DataMan®.


Propriétés DotCode

Spécifier le nombre de lignes et de colonnes de données

La spécification du nombre minimal et maximal de lignes et de colonnes de données peut améliorer la faculté du lecteur à décoder des symboles de manière fiable.

Réglage de la polarité

Vous pouvez paramétrer ce que le périphérique définit comme module (point) en relation avec son arrière-plan. Le paramètre Foncé sur clair implique que le périphérique recherche et décode les points de couleur foncée sur fond clair, alors que Clair sur foncé est l'inverse (points clairs sur fond de couleur foncée).

Le paramètre par défaut L'un ou l'autre recherche les deux types de modules sur le fond correspondant, mais cela peut provoquer un ralentissement du décodage.


Quels sont les différents paramètres des propriétés du code UPC/EAN ?

  • L'option Étendu permet de décoder les symboles étendus.

  • L'option Suppléments contrôle le décodage des codes supplémentaires par le lecteur.

  • L'option Supprimer les zéros non significatifs supprime les zéros non significatifs des chaînes décodées.

  • L'option Permettre les options supplémentaires EAN8 permet de décoder les codes supplémentaires des symboles EAN8.

  • La propriété UPCE1 activé permet de décoder les symboles UPC E1.


Propriétés UPC/EAN : Que signifie la case Étendu ?

Il s'agit d'un élément booléen pour indiquer si la chaîne décodée rapportée pour UPC-EAN doit être étendue à un format EAN13 à 13 chiffres ou transféré au format standard UPC-E à 6 chiffres.

Lorsque la case est cochée (par défaut), la chaîne décodée est transmise au format EAN-13 à 13 chiffres (par ex. 0012345000065). Lorsque la case n'est pas cochée, le résultat est transmis comme <number system> + 6 chiffres de données + <check character> (par ex. 01234565).


Détails de l’application


Que puis-je définir à l'étape Détails de l'application ?

Dans l'onglet Basique, vous pouvez régler les paramètres de déclenchement et d'exposition. Pour plus de facilité, un Assistant de déclenchement, un Assistant d'intervalle et un Assistant d'exposition vous aident à définir ces paramètres.

Il est possible d'ajouter de nouveaux paramètres dans la vue tabulaire depuis l'onglet Avancé.


Quels sont les types de déclenchement ?

  • Le Déclenchement sur présentation recherche en permanence un symbole et le décode à chaque détection. Le déclenchement sur présentation est activé par un mécanisme de synchronisation et la détection de mouvements internes au lecteur.

    Plusieurs paramètres peuvent être spécifiés en mode déclenchement sur présentation, comme l'autorisation de lire plusieurs fois le même code ou le délai d'attente avant la recherche du code suivant. Utilisez le volet Paramètres système et les options Paramètres de décodage pour configurer le déclenchement sur présentation.

    En mode de déclenchement sur présentation, utilisez les paramètres d'Exposition automatique pour que le lecteur détermine les meilleurs paramètres d'exposition pour la luminosité souhaitée de l'image. N'oubliez pas cependant que le lecteur utilise les images acquises au départ pour déterminer ces paramètres ; il peut oublier des images qui contiennent un symbole à décoder. Vous pouvez sélectionner précisément des paramètres d'Exposition manuelle pour l'exposition de l'imageur.

    • Placez le périphérique dans la station de base du lecteur.
    • Passez au mode de déclenchement Manuel dans l'outil de configuration, puis retournez au mode présentation.
    • Numérisez le Code de configuration de lecteur Entrée présentation.

  • Le Déclenchement manuel débute l'acquisition des images en réponse à l'un des événements suivants :

    • Activation du bouton du lecteur

    • Envoi du déclencheur de la commande DMCC (DataMan Control Command) en cas de connexion au lecteur via une connexion USB ou série

    • Activation du bouton Déclencheur de l'outil de configuration

    • Activation de la combinaison Ctrl+T sur le clavier lorsque l'outil de configuration dispose de la mise au point

    Le lecteur continue d'acquérir des images tant que le signal du déclencheur reste actif et s'arrête lorsqu'un symbole est détecté et décodé ou que le signal du déclencheur prend fin.

=


Assistant de déclenchement

Vous devez commencer par choisir le type de déclenchement pour que cet assistant fonctionne. Sélectionnez la source du déclencheur dans le menu déroulant : Non-Défini, Aucun ou Externe. L'assistant vous adresse une recommandation pour les modes du déclencheur. Des présentations graphiques des types de déclenchement vous aident à choisir. Sélectionnez le déclencheur voulu puis cliquez sur Enregistrer et fermer.


Assistant d’intervalle

Lorsque vous utilisez les modes Salve, Auto ou Continu, l'Assistant d'intervalle peut vous aider à faire davantage de paramètres. Vous pouvez sélectionner trois façon de calculer les données nécessaires. Dans le coin supérieur droit, sélectionnez les unités (standard ou métriques) que vous souhaitez utiliser pour votre calcul.

Cliquez sur Champ de vue pour calculer le plus long intervalle de temps possible en mesurant le champ de vue physique et en donnant la vitesse linéaire maximale et la taille du plus grand code.

Cliquez sur Lentille / Distance avec le code si vous voulez préciser la distance entre le code et la lentille. Donnez la longueur focale dans le menu déroulant et sélectionnez le sens de défilement du code. Il est également possible que vous deviez ici indiquer la vitesse linéaire maximale et la taille du plus long code.

Cliquez sur Taille de l'élément de code pour calculer d'après la taille de l'élément de code le plus étroit. Activez le Mode Test pour lire votre code. Il est également possible que vous deviez indiquer le sens de défilement du code, la vitesse linéaire maximale et la taille du plus long code.

Vous trouverez la durée maximale de l'intervalle en bas de l'Assistant.


Assistant d’exposition

L'Assistant d'exposition est très similaire à l'Assistant d'intervalle. Vous pouvez sélectionner les trois mêmes façons d'effectuer vos calculs : Taille du champ de vue, distance avec le code et taille de l'élément de code.

Cliquez sur Champ de vue pour calculer l'exposition maximale recommandée en mesurant le champ de vue physique et en donnant la vitesse linéaire maximale. Vous pouvez activer le Mode Test pour lire votre plus petit code.

Cliquez sur Lentille / Distance avec le code si vous voulez préciser la distance entre le code et la lentille. Donnez la longueur focale dans le menu déroulant et sélectionnez le sens de défilement du code. Vous pouvez également indiquer ici la vitesse linéaire maximale.

Cliquez sur Taille de l'élément de code pour calculer d'après la taille de l'élément de code le plus étroit. Activez le Mode Test pour lire votre code. Il est également possible que deviez indiquer le sens de défilement de votre code et la vitesse linéaire maximale.

Vous trouverez les durées d'exposition maximale et recommandé en bas de l'Assistant.


Quelle est la différence entre les options de délai Après première lecture et Après dernière lecture ?

Le délai Après première lecture commence le chronométrage après la première fois qu'un code donné est lu et le chronomètre ne sera pas réinitialisé. Cela signifie que le code peut être relu si le lecteur est déclenché dans un mode à images multiples tel que le mode continu et si le code se trouve devant le lecteur pendant une durée égale ou supérieure au Délai de relecture.

L'option Après dernière lecture réinitialise le chronomètre à chaque fois qu'un code donné apparaît dans une image. Cela signifie que le code ne sera pas relu tant qu'il reste devant le lecteur. C'est uniquement après avoir retiré le code du champ de vue du lecteur pendant une durée égale ou supérieure au Délai de relecture que le code sera relu.


Mon code est lu deux fois si je déclenche le lecteur encore une fois. Pourquoi ?

Les options Délai de relecture et Ne jamais lire le même code deux fois affectent uniquement les acquisitions faites au sein d'un cycle de déclenchement unique. Le fait de déclencher le lecteur efface les chronomètres et le dernier code lu pour Ne jamais lire le même code deux fois.


Ne jamais lire le même code deux fois – De quoi s'agit-il ?

L'option Ne jamais lire le même code deux fois supprime le rapport d'une chaîne de code identique deux fois sur la même ligne et au sein d'une séquence de déclenchement unique, lorsque celle-ci est activée. Il est disponible pour tous les modes de déclenchement, mais est seulement valide en mode lecture Multicode, car la seule manière d'avoir plus d'un code dans une seule séquence de déclenchement est dans les lectures multicode. Si la case Ne jamais lire le même code deux fois n'est pas cochée, le périphérique lit et transmet le même code après le Délai de relecture de code spécifié (en millisecondes).


Qu'est-ce que le mode de délai et qu'est-ce que le délai de relecture de code ?

L'option Mode de délai définit le délai de relecture de code soit par rapport à la première soit par rapport à la dernière lecture.

L'option Délai de relecture de code (en millisecondes) permet de spécifier le délai entre les tentatives de lecture. La spécification d'une valeur non nulle pour ce délai peut éviter que les données encombrent le périphérique connecté à votre lecteur.


Qu'est-ce qu'est la Détection de mouvement ?

La Détection de mouvement permet aux utilisateurs de paramétrer leur périphérique pour basculer en mode Présentation active ou en mode Déclenchement automatique pour une durée déterminée après la détection d'un mouvement dans le champ de vue du périphérique.

Les paramètres de Détection de mouvement deviennent disponibles seulement si le type de déclenchement est paramétré sur Présentation ou Automatique. Lorsque la Détection de mouvement est activée, le périphérique ne prend pas d'images mais détecte en arrière-plan si la scène dans le champ de vue se déplace ou non.

Si elle se déplace, le périphérique acquiert activement des images selon le mode de déclenchement Présentation ou Automatique. Le paramètre Délai d'attente vous permet de déterminer la durée (en secondes) après laquelle le périphérique revient en mode Détection de mouvement à partir du déclenchement actif, mais ce délai d'attente est réinitialisé à chaque fois par le mouvement ou une bonne lecture.

La Sensibilité de détection de mouvement peut être paramétrée pour définir l'importance des mouvements reconnus par le périphérique pour activer les mode de déclenchement Présentation et Automatique.


Comment effectuer un déclenchement à partir du clavier ?

Appuyez sur les touches <ctrl>-T (la fenêtre de l'outil de configuration doit être active).


Comment régler l'exposition de l'image ?

Les déclenchements manuel et sur présentation utilisent les paramètres d'Exposition automatique de sorte que le lecteur détermine les meilleurs paramètres d'exposition pour la luminosité souhaitée de chaque image. Ces types de déclenchement vous permettent d'utiliser les paramètres Exposition maximale en fonction de votre environnement de production, ou de sélectionner Exposition manuelle pour définir une exposition précise en millisecondes.

Avec l'Exposition manuelle, vous pouvez cliquer sur Optimiser la luminosité dans le volet Historique des résultats afin de générer une valeur fixe pour le réglage de l'exposition, limitée par la valeur d'Exposition maximale. Le réglage Facteur de gain maximum sert à régler la luminosité maximum de pixel de la cible.


Comment régler l'exposition de l'image ?

Les déclenchements manuel et sur présentation utilisent les paramètres d'Exposition automatique de sorte que le lecteur détermine les meilleurs paramètres d'exposition pour la luminosité souhaitée de chaque image. Ces types de déclenchement vous permettent d'utiliser les paramètres Exposition maximale en fonction de votre environnement de production, ou de sélectionner Exposition manuelle pour définir une exposition précise en millisecondes.

Avec l'Exposition manuelle, vous pouvez cliquer sur Optimiser la luminosité dans le volet Historique des résultats afin de générer une valeur fixe pour le réglage de l'exposition, limitée par la valeur d'Exposition maximale. Le curseur Gain (en-dessous de la zone de visionnage d'image) indique la luminosité de pixel de la cible.


Données de format


Comment le formatage des données fonctionne-t-il ?

Dans le volet Basique, sélectionnez le type de formatage que vous voulez utiliser.

Utilisez le volet Standard pour construire une chaîne de sortie personnalisée à l'aide de blocs prédéfinis dans les différents onglets de symbologie :

  • La chaîne de sortie commence par n'importe quel texte saisi dans le champ Caractères de début de chaîne.

  • Sélectionnez des éléments dans les listes des onglets Général, Validation et (si applicable) Mesures, puis cliquez sur Ajouter pour les ajouter à la chaîne de sortie. Pour ajouter uniquement une partie des caractères de la chaîne décodée, cliquez sur Définir la plage des chaînes partielles, entrez la plage index des caractères à ajouter (ex. 1-3,5,8,10-) et cliquez sur Chaîne partielle dans la liste puis sur le bouton Ajouter.

  • La chaîne de sortie contient également le texte que vous souhaitez ajouter au champ Caractères de fin de chaîne.

  • Pour terminer l'ensemble de la chaîne entière par une paire de caractères retour chariot/nouvelle ligne, cochez la case CR/LF.


Pourquoi y a-t-il plusieurs onglets sous l'onglet Standard ?

Vous pouvez indiquer individuellement le formatage des divers types de symbologie ou utiliser l'onglet Universel pour indiquer le formatage des données d'un symbole décodé, qui sera prioritaire par rapport aux onglets des différents types de symbologie.


Comment puis-je utiliser à la fois un formatage universel et un formatage propre à la symbologie ?

Le volet Formatage standard s'appuie sur les critères suivants lorsque vous utilisez à la fois des onglets propres aux différentes symbologies et les onglets Universels :

  • Chaque résultat passe par le dispositif de formatage propre à la symbologie s'il est activé. Plusieurs résultats de la même symbologie sont formatés individuellement avec des paramètres identiques.

  • Si l'onglet Universel est activé, les différents résultats passent par le dispositif de formatage propre à la symbologie, s'il est activé, et sont complétés par les règles de formatage de l'onglet Universel. En cas de résultats multiples (sur les lecteurs pris en charge), les résultats sont concaténés et séparés par le délimiteur choisi sans délimiteur supplémentaire à la fin. La chaîne concaténée est considérée comme une chaîne unique pour les autres règles de formatage de l'onglet Universel.

  • En cas de résultats multiples, leur ordre dans une chaîne concaténée est la suivante : 1) Data Matrix, 2) Code QR, 3) Codes 1D 4) Vericode 5) DotCode 6) OCR.

  • Tout jeton ajouté au formatage propre à la symbologie, valide uniquement pour l'ensemble du processus de décodage (comme le temps de décodage ou l'indice de déclenchement), indique cette valeur globale.


Quelles sont les données envoyées si le formatage standard n'est pas activé ?

Le lecteur transmet la chaîne décodée suivie des deux caractères retour chariot/nouvelle ligne (CR/LF).


Comment envoyer uniquement les données décodées sans la paire retour chariot/nouvelle ligne (CR/LF) ?

Activez le formatage, ajoutez Chaîne complète à la chaîne de sortie et vérifiez que la case CR/LF n'est pas cochée.

Pour envoyer uniquement un retour chariot, entrez \r dans le champ Caractères de fin de chaîne.


Qu'est-ce qu'une chaîne d'entrée ?

Une Chaîne d'entrée est un jeton de formatage que vous pouvez inclure comme partie des propriétés du lecteur dans le formatage basé sur un script ou comme jeton de formatage standard des données. Veuillez noter que vous ne pouvez pas modifier d'autres propriétés de la chaîne d'entrée dans l'outil de configuration, ses paramètres sont uniquement disponibles dans DMCC.


Comment puis-je empêcher Excel d'ignorer des cases ?

Par défaut, le lecteur ajoute une paire de caractères retour chariot/nouvelle ligne à la fin de chaque code transmis. Lorsqu'une connexion avec clavier est utilisée pour saisir les codes transmis dans Excel, cette paire de caractères fait avancer Excel de deux lignes après chaque code. Pour éviter cela, configurez le lecteur de façon à envoyer uniquement un retour chariot :

  1. Cliquez sur Formatage standard.

  2. Spécifiez la symbologie que vous utilisez dans les onglets Symbologie.

  3. Cochez la case Formatage activé.

  4. Cliquez sur Chaîne complète dans l'onglet Général.

  5. Cliquez sur Ajouter.

  6. Dans Caractères de fin de chaîne, entrez \r dans la zone de texte et désactivez la case CR/LF.


Comment puis-je envoyer des éléments particuliers des données encodées lorsque la validation des données est active ?

Tout d'abord, sélectionnez le type de validation dont vous avez besoin dans le volet Validation des données. Activez Formatage de base dans l'onglet Basique de l'étape d'application Formater les données. Sélectionnez l'onglet Validation de l'onglet Standard puis ajoutez le(s) champ(s) de données souhaité(s) à la chaîne de sortie, y compris les éléments suivants : Identificateur d'entreprise, Numéro de série, Référence de la pièce, Identificateur unique de l'article et Identificateur de l'application GS1.


Quelles sont les différentes options de l'onglet Général dans le champ Données de l'onglet Standard ?

  • Chaîne partielle : sous-chaîne de caractères encodés dans le symbole. Vous devez indiquer une plage pour la sous-chaîne pour pouvoir utiliser cette option.

  • Chaîne complète : tous les caractères encodés dans le symbole

  • Temps de décodage : délai en millisecondes qu'il a fallu au lecteur pour décoder le symbole. Cette période ne comprend pas l'acquisition de l'image, le traitement de l'image en cours, le délai de communication et les autres traitements (par exemple, le formatage des données).

  • Temps de déclenchement : délai en millisecondes entre la réception du déclencheur et la fin de l'opération de décodage

  • Symbologie : symbologie du symbole décodé

  • CR/LF : retour chariot avec nouvelle ligne

  • TAB : caractère de tabulation

  • SP : espace

  • Identificateur de la symbologie : identificateur de la symbologie tel qu'il est indiqué par la norme ISO/CEI 15424:2008

  • Taille du module : largeur (ou hauteur) en pixels de chaque module du symbole

  • Position du code : coordonnées d'image de chaque coin du symbole décodé

  • Orientation du code : orientation du symbole décodé rapporté en degrés. Les rotations du symbole décodé dans le sens des aiguilles d'une montre sont considérées comme changements d'orientation positifs.

  • Contraste : valeur comprise entre 0 et 1 qui indique la quantité totale de contraste du symbole décodé. Une valeur élevée indique que les modules clairs et foncés du symbole disposent d'une large plage de niveaux de gris tandis qu'une valeur faible indique que les modules clairs et foncés consistent en niveaux de gris similaires.

  • UEC : pourcentage d'erreurs non corrigées du symbole. La correction des erreurs est une méthode de reconstruction ou de remplacement des données perdues par l'endommagement du symbole. La valeur 100 est idéale. La symbologie 1D retourne toujours -1.

  • Chaîne d'entrée : chaîne d'entrée reçue (série ou Ethernet).

  • Temps de filtrage : durée du filtrage en millisecondes (ms).

  • Source des résultats : nom du périphérique.

Pour toutes les valeurs suivantes, l'incrémentation aura lieu que le lecteur soit connecté ou non à l'outil de configuration.

  • Nbre total de lectures : nombre total de symboles décodés

  • Nbre total sans lecture : nombre de fois où un déclencheur a été reçu mais sans qu'aucun symbole ne soit décodé

  • Nb déclenchements : nb déclenchements = nbre total de lectures + nbre total sans lecture + total décl. manqués

  • Décl. manqués : nombre de déclenchements manqués en raison de l'indisponibilité d'une mémoire tampon d'images au moment où le déclenchement a été détecté

  • Indice de déclenchement : nombre total de déclenchements détectés par le lecteur.

Les valeurs qui seront remises à 0 à chaque fois que les Statistiques de processus sont effacées dans le volet Process Monitor ou que le lecteur est redémarré sont les suivantes :

  • Nb total de lectures

  • Nb total non-lecture

  • Nb déclenchements

  • Décl. manqués

L'indice de déclenchement sera remis à 0 seulement après un redémarrage du lecteur mais pas après avoir effacé les Statistiques de processus.


Comment puis-je simuler les combinaisons de touches Alt, Ctrl ou Maj ?

Pour utiliser cette fonction, quatre séquences d'échappement, \ALT-, \CTRL-, \MAJ- et \K, sont disponibles. \ALT- sert aux séquences <ALT-touche>, \CTRL-, aux séquences <CTRL-touche>, \MAJ-, aux séquences <MAJ-touche>, \K aux touches spéciales. Notez que la touche suivant la barre oblique doit être en majuscules. Sinon, aucune combinaison de touches spéciales n'est reconnue.

Les séquences sont saisies dans les champs Caractères de début de chaîne/Caractères de fin de chaîne du volet Standard.

Séquences du clavier spéciales prises en charge

Le format suivant doit être utilisé :

\ALT- suivi du nom de la touche, suivi du caractère ;

ou

\CTRL- suivi du nom de la touche, suivi du caractère ;

ou

\MAJ- suivi du nom de la touche, suivi du caractère ;

ou

\K suivi du nom de la touche, suivi du caractère ;

Le point virgule de fin est nécessaire afin de distinguer les séquences présentant le même préfixe. Sinon, les séquences de touche risqueraient d'être interprétées de manière arbitraire, par exemple, il serait impossible de savoir si \KF11 signifie « appuyez sur F11 » ou « appuyez sur F1, suivi de 1 ».

Notez que si ces deux séquences d'échappement sont saisies sur l'onglet Universel, elles sont également appliquées aux résultats Non lecture.

Séquences de touche et touches prises en charge

La liste suivante contient les touches/combinaisons de touches actuellement prises en charge :

  • ALT-A à ALT-Z

  • CTRL-A à CTRL-Z

  • CTRL-F1 à CTRL-F12

  • MAJ-F1 à MAJ-F12

  • F1 à F12

  • ALT-F1 à ALT-F12

  • Touches PagePréc, PageSuiv, Orig, Fin, Flèche (haut, bas, gauche, droite), Inser, Suppr, Retour arrière, Tabulation, Echap, Impr écran, GUI (gauche, droite)

    Les séquences d'échappement correspondantes sont les suivantes :

    • PagePréc -> \KPup;

    • PageSuiv -> \KPdn;

    • Orig -> \KHome;

    • Fin -> \KEnd;

    • Flèche haut -> \KUar;

    • Flèche bas -> \KDar;

    • Flèche gauche -> \KLar;

    • Flèche droite -> \KRar;

    • Insérer -> \KIns;

    • Supprimer -> \KDel;

    • Retour arrière -> \KRet-Arr;

    • Tabulation -> \KTab;

    • Echap -> \KEchap;

    • Impr Écran -> \KImprEcr;

    • GUI gauche -> \KGuiG;

    • GUI droite -> \KGuiD;

  • Pause output -> \KPAUSE;

Voici quelques exemples :

  • Pour générer la séquence <ALT-V>, utilisez \ALT-V;

  • Pour simuler l'activation de la touche <F10>, utilisez \KF10;

  • Pour simuler l'activation de la touche <Orig>, utilisez \KHome;

  • Pour activer/désactiver la barre d'état dans le Bloc-Notes (<Alt-v><s>), la séquence à utiliser est \Alt-v;s

Dans le cas d'une séquence incorrecte ou incomplète, les deux caractères marquant la séquence d'échappement sont ignorés. Dans ce cas, les deux premières lettres de la séquence d'échappement sont ignorées et les autres caractères sont envoyés. Par exemple, la séquence \ALT-M11; n'est pas valide et entraîne l'affichage de LT-M11;


Comment tester le formatage des données ?

Utilisez le bouton Test en bas de la page pour tester l'affichage des résultats.

Recherchez un symbole et affichez le résultat formaté dans la barre d'état. Vous pouvez aussi sélectionner le volet Historique des résultats puis lire un symbole. L'historique des résultats montre les résultats du formatage que vous avez spécifié.


En quoi consiste la fonction Options de sortie ?

La fonction Options de sortie vous permet d'envoyer les données de sortie de votre choix en différents formats. Par exemple, si une virgule est sélectionnée et si vous choisissez d'envoyer la chaîne complète suivie du type de symbologie, la sortie comportera la chaîne complète suivie d'une virgule et du texte Datamatrix. Pour tester les différentes sorties, vous pouvez sélectionner un type de sortie donné, puis cliquer sur le bouton Test pour afficher la sortie dans la fenêtre voisine. Remarque : si la validation des données est sélectionnée et si un code échoue lors de la validation, la fonction Options de sortie ne sera pas activée.


Pourquoi le bouton Test est-il grisé ?

Vous ne pouvez tester votre code qu'après le premier décodage réussi.


Puis-je spécifier les caractères à l'aide de codes ASCII en notation hexadécimale ou octale ?

Dans les champs Caractères de début de chaîne et Caractères de fin de chaîne, les caractères sont spécifiés sous la forme \nnn, où nnn est la valeur du caractère du code ASCII en notation octale. Vous pouvez spécifier les caractères au format hexadécimal en entrant \xnn, où nn est la valeur du code ASCII en notation hexadécimale.

Vous pouvez également utiliser les codes prédéfinis suivants :

  • \a Alerte (ASCII 7)
  • \b Retour arrière (ASCII 8)
  • \E Échappement (ASCII 27)
  • \f Saut de page (ASCII 12)
  • \n Saut de ligne (ASCII 10)
  • \t Tabulation horizontale (ASCII 9)
  • \r Retour chariot (ASCII 13)
  • \v Tabulation verticale (ASCII 11)
  • \\ Barre oblique inverse (ASCII 92)


Que transmet le lecteur lorsqu'aucun code n'est lu ?

En règle générale, le lecteur ne transmet aucune donnée si un code n'est pas lisible. L'historique des résultats affichera une chaîne de résultats vide et un icône de croix rouge avec le message « Pas de lecture » comme état du résultat.


Qu'est-ce que le résultat Position du code ?

Pour les symboles Data Matrix, la Position du code représente l'emplacement des quatre coins du symbole. Le lecteur renvoie 4 paires de coordonnées :

  • La première paire représente l'intersection des deux barres du motif de localisation en L.

  • La deuxième paire représente l'intersection entre la barre horizontale du motif de localisation en L et la barre verticale du motif de synchronisation en pointillés.

  • La troisième paire représente l'intersection entre les barres du motif de synchronisation (diagonale opposée à la première paire).

  • La quatrième paire représente l'intersection entre la barre verticale du motif de localisation en L et la barre horizontale du motif de synchronisation en pointillés.

Cognex recommande de sélectionner un délimiteur (ex. virgule) pour séparer chaque valeur et faciliter la lecture des résultats.


Quelle méthode de formatage des données dois-je choisir ?

Vous pouvez utiliser le formatage de base (standard ou de style Perl) ou écrire votre propre script en JavaScript dans l'onglet Formatage des données du volet Scripts. Les deux méthodes sont différentes :

  • le formatage de base vous permet de glisser et déposer des éléments de formatage de données prédéfinis ;

  • le formatage basé sur un script vous permet d'écrire un script qui, outre le formatage des résultats et données de lecture, peut permettre à votre lecteur de réaliser des opérations telles que le signal sonore ou le tirage de la sortie 1 vers le haut.


Quelle est la fonction de l'onglet Communication ?

Cet onglet permet de modifier votre script de protocole de communication personnalisé.


Quelles sont les limites du formatage basé sur un script ?

Vous êtes limité à deux événements personnalisés et à remplacer l'événement du système dans le formatage basé sur un script.


Où puis-je trouver un exemple de script ?

Les options suivantes sont disponibles pour insérer un script dans la fenêtre principale du volet Scripts :

  • Cliquez sur le bouton Insérer un fragment dans la barre d'outils supérieure et sélectionnez le fragment adapté dans la liste selon vos besoins.

  • Cliquez à l'aide du bouton droit dans la fenêtre principale et sélectionnez Insérer un fragment.... Cliquez sur le fragment adapté dans la liste selon vos besoins.

  • Appuyez sur Ctrl-K, X.

REMARQUE : si le bouton Insérer un fragment n'est pas activé, la version du microprogramme qui fonctionne sur le périphérique ne prend pas en charge les fragments pour l'onglet de script actuel.


Quelle est la fonction de l'onglet Stockage FTP ?

Cet onglet est utilisé pour la génération de noms de fichier FTP pour les images et les rapports de qualité des codes.


Comment charger mes scripts ?

Vous pouvez y accéder en cliquant sur le menu ruban puis sur l'option Ouvrir un script. Vous pouvez sauvegarder vos scripts avec le bouton Enregistrer le script.

REMARQUE : l'édition de script ne prend en charge que le codage de caractères UTF-8 !


Qu'est-ce que l'option Compléter les mots ?

Vous pouvez compléter les mots de votre script à l'aide des méthodes suivantes :

  • en cliquant sur le bouton Compléter les mots dans la barre d'outils supérieure ;

  • en cliquant à l'aide du bouton droit dans la fenêtre principale puis en sélectionnant Compléter les mots ;

  • en appuyant sur Ctrl-K, W.

Vous pouvez ensuite choisir dans une liste les objets à insérer dans votre script.


Comment modifier rapidement mon script ?

Utilisez les boutons Couper, Copier ou Coller dans la barre d'outils supérieure ou cliquez dans la fenêtre principale et sélectionnez Couper, Copier, Coller, Supprimer ou Tout sélectionner.


Pourquoi toutes les variables sont-elles réinitialisées lors de la sélection de Système->Enregistrement des paramètres ?

Lorsqu'un script est modifié et que la sélection de l'éditeur est quittée, le script est transmis au lecteur ce qui entraîne une invalidation contextuelle du moteur de script. Une invalidation contextuelle du script entraîne la réinitialisation de toutes les variables.


Comment puis-je afficher les erreurs dans le journal du périphérique en utilisant les scripts ?

Utilisez la commande Throw() pour rapporter l'apparition d'une situation anormale (exception) et l'erreur apparaîtra dans le journal du périphérique lorsque le périphérique n'est pas connecté à l'outil de configuration. Vous pouvez accéder au journal d'erreurs en cliquant sur Système dans la barre de menu de l'outil de configuration puis sur Afficher le journal du périphérique.

Lorsque le périphérique est connecté à l'outil de configuration, l'exception apparaît en-dessous du script sur le volet script.


Où puis-je trouver des informations sur le formatage basé sur un script ?

Pour plus d'informations, consultez le Guide de communication et programmation DataMan disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration.


Comment est-ce que je peux paramétrer un délai dans la sortie de code ?

Pour régler une pause dans la sortie de code, la séquence \Pause<time>; peut être ajoutée aux champs de texte dans le volet Formatage des données.

<Time> contient une valeur en millisecondes, par exemple, pour une attente de 4 secondes, la séquence est \Pause4000;.

Cette fonctionnalité peut être utilisée avec USB HID ou RS232. Pour RS232, la fonctionnalité doit être activée à l'aide de la commande DMCC suivante : COM.RS232-ENABLE-PAUSE. Pour USB HID, elle est activée par défaut.


Pourquoi y a-t-il plusieurs onglets en haut de l'écran ?

Vous pouvez indiquer individuellement le formatage des diverses symbologies ou utiliser l'onglet Universel afin d'indiquer le formatage d'une expression régulière de style Perl pour un symbole décodé.


Comment spécifier une substitution arbitraire du texte ?

Entrez le texte dans la zone de texte Expression régulière. La syntaxe de cette chaîne de caractères est la suivante :

        /search/replace/g

où rechercher est la chaîne de caractères à rechercher et remplacer est celle qui la remplace. Par défaut, seule la première occurrence de la chaîne à rechercher est remplacée. Pour remplacer toutes les occurrences, ajoutez g à la fin de la commande.

Par exemple, si le lecteur décode cette chaîne :

        UPC 05214275600

Vous pouvez remplacer la chaîne « UPC » par la chaîne « SKU CODE: » en utilisant cette chaîne de substitution :

        /UPC/SKU CODE:/

ce qui a pour résultat la chaîne suivante :

        SKU CODE: 05214275600

Vous pouvez entrer des paires de substitution multiples en les séparant par un espace. Les paires multiples sont utilisées séquentiellement : le résultat de la première paire est utilisé comme entrée de la seconde paire, et ainsi de suite.


Que signifie Ignorer les données qui ne correspondent pas ?

Par défaut, tout texte qui ne fait pas partie de la chaîne à rechercher est ignoré. Si vous cochez la case Ignorer les données qui ne correspondent pas, seule la chaîne résultant de la substitution est envoyée.


Quels sont les caractères spéciaux qui doivent être précédés d'un caractère d'échappement ?

Les caractères spéciaux suivants ont une signification spéciale dans les chaînes de substitution et de remplacement :

            ˆ  . , (  )  [  ] $ \ / * + |

Si vous voulez inclure l'un de ces caractères dans votre chaîne de recherche ou de remplacement, vous devez les précéder d'une barre oblique inverse (\). Pour inclure une barre oblique inverse, entrez \\. Pour entrer n'importe quel caractère ASCII, entrez \xhh où hh est la valeur hexadécimale du caractère (vous ne pouvez pas utiliser \ooo pour spécifier des valeurs ASCII en base octale).


Comment utiliser un caractère générique pour rechercher différents caractères ou modèles de chaînes ?

Les caractères spéciaux suivants représentent dans la chaîne à rechercher un caractère quelconque, un caractère d'un ensemble de caractères ne figurant pas dans cet ensemble :

. représente n’importe quel caractère unique

[abcd...] représente un caractère de l'ensemble a, b, c, d ...

[a-z] représente n'importe quel caractère unique dans la suite de caractères de a à z (vous pouvez utiliser des lettres ou des chiffres)

Pour inverser le sens d'un caractère générique à l'aide d'un ensemble ou d'une suite de caractères, précédez ceux-ci du caractère ^.

Pour représenter un nombre variable de caractères, ajoutez l'un des caractères de modification suivants après le caractère ou le caractère générique à rechercher :

+ représente une occurence ou plus du caractère précédent

* représente zéro ou plusieurs occurences du caractère précédent

? représente zéro ou une occurence du caractère précédent

{n} représente n occurrences du caractère précédent

{n,m} représente au moins n occurrences, mais pas plus de m occurrences du caractère précédent

{n,} représente au moins n occurrences du caractère précédent

Voici quelques exemples d'utilisation des caractères génériques :

/A.B/AB/g supprime tout caractère unique entre A et B dans la chaîne d'entrée

/A.*B/AB/g supprime n'importe quel nombre de caractères entre A et B dans la chaîne d'entrée


Existe-t-il des caractères génériques représentant les caractères spéciaux ?

Utilisez les séquences d'échappement suivantes pour représenter des caractères spéciaux et des types de caractères :

\n un caractère de saut de ligne

\w un caractère alphanumérique (lettre ou chiffre)

\W un caractère non alphanumérique

\s un espace

\S un caractère différent d'un espace

\d un chiffre

\D un caractère autre qu'un chiffre

Vous pouvez combiner ces caractères avec les caractères génériques de substitution de plusieurs caractères répertoriés plus haut.


Comment puis-je ancrer une chaîne à rechercher ?

Précédez la chaîne à rechercher du caractère ^ pour la représenter uniquement au début de la chaîne. Précédez la chaîne à rechercher du caractère $ pour la substituer uniquement à la fin de la chaîne.


Comment puis-je réutiliser une partie de la chaîne à rechercher dans la chaîne résultante ?

Placez entre parenthèses la ou les parties de la chaîne à rechercher que vous souhaitez utiliser dans la chaîne résultante. Vous faites référence à ces chaînes dans la chaîne résultante en utilisant les jetons \1, \2 et ainsi de suite.


Existe-t-il une taille maximum pour les expressions régulières Perl ?

La taille maximum du script entré dans n'importe quel onglet est de 512 caractères, mais l'onglet spécifique à la symbologie sera exécuté avant l'onglet universel. Si les deux sont utilisés simultanément, un script jusqu'à 1 024 caractères peut être écrit.


Où trouver plus d'informations sur les expressions régulières Perl ?

Ici. Remarque : toutes les fonctions décrites dans cette page ne sont pas implémentées par le lecteur.


Entrées / Sorties


Comment réinitialiser le lecteur ?

Numérisez la commande Redémarrer le scanner imprimée au dos de l'Aide-mémoire pour effectuer une réinitialisation logicielle. A la réinitialisation, le lecteur s'arrête et redémarre sans que la mémoire non volatile du lecteur ne soit effacée.

Numérisez la commande Réinitialiser le scanner avec les paramètres d'usine pour reconfigurer le lecteur sur ses réglages usine.


Pourquoi devrais-je changer le nom du périphérique ?

Vous pouvez attribuer au périphérique un nom plus évocateur pour votre environnement de production, comme son emplacement ou sa tâche d'inspection. Utilisez le champ Nom du périphérique dans l'onglet Avancé.


Comment puis-je changer le nom du périphérique ?

Pour changer le nom du périphérique :

  1. Saisissez le nouveau nom du périphérique dans le champ Nom du périphérique.

  2. La question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour prendre effet. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui.

  3. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre périphérique.

Lorsqu'ensuite vous relancez l'outil de configuration ou que vous cliquez sur Actualiser dans le volet Connexion au lecteur, vous voyez apparaître le nouveau nom du périphérique.


Quels paramètres système puis-je modifier ?

La liste déroulante Paramètres système dans l'onglet Avancé permet de déterminer le comportement du lecteur lors de la lecture d'un code, d'un échec de lecture et de la non-validation de la lecture d'un code.

  • Niveau sonore contrôle le volume du signal sonore.

  • Nombre de bips contrôle le nombre de bips sonores émis.

  • Couleur de la LED définit la couleur du voyant lumineux d'état du lecteur (au dos du lecteur).


Qu'est-ce qu'un message de sortie de mode veille ?

Si l'option Envoyer la chaîne de diagnostic à la sortie du mode veille est activée, le lecteur ou sa base transmettra une chaîne de diagnostic au démarrage du lecteur.

Cette fonction n'est pas disponible pour les connexions USB. Pour les connexions série, la vitesse de transfert est automatiquement configurée à 38 400 bps lorsque le message est envoyé, quels que soient les paramètres de l'outil de configuration.


Communications


Que puis-je définir à l'étape application de Communications ?

Sur les trois onglets de l'étape application des Communications, vous pouvez exécuter les paramètres série et Ethernet. Cliquez sur l'onglet approprié pour saisir les valeurs de vos paramètres.

Il est possible d'ajouter de nouveaux paramètres dans la vue tabulaire depuis l'onglet Avancé.


Comment modifier les paramètres du port série du lecteur ou de la station de base ?

Saisissez les nouveaux paramètres ans l'onglet Série de l'étape application Communications. Vous pouvez également numériser le document Codes de configuration (disponible dans le menu Démarrer de Windows ou dans le menu Aide).


Quand dois-je utiliser le mode de compatibilité du pilote USB ?

Par défaut, le lecteur DataMan utilise un pilote USB capable d'aider le lecteur à surmonter un problème de décharge électrostatique (ESD). Utilisez le Mode de compatibilité du pilote USB si vous devez pouvoir vous appuyer sur une conformité stricte à la spécification USB ou si vous utilisez un lecteur DataMan avec le produit Cognex SensorView.

Lorsque vous modifiez Mode de compatibilité du pilote USB, la question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour être prises en compte. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre lecteur.


Quelles modifications entraînent le changement du mode USB ?

Lorsque vous êtes connecté à votre lecteur à travers une connexion série USB, vous pouvez choisir la vitesse USB de cette connexion entre les valeurs 1.1 ou 2.0.

Lorsque vous êtes connecté à un lecteur sans fil, la modification du mode USB n'entraîne aucune modification de la station de base. Les paramètres modifiés restent dans la mémoire du lecteur et si vous passez du réglage sans fil à un réglage série, le lecteur se connecte au mode USB (précédemment) sélectionné.


Comment puis-je utiliser le lecteur à la place d'un clavier lorsqu'il est connecté via USB ?

Pour émuler un clavier USB, numérisez le code Clavier USB dans le document Codes de configuration du lecteur (disponible dans le menu Démarrer de Windows ou le menu Aide de l'outil de configuration) et assurez-vous de vous déconnecter de l'outil de configuration.


Que puis-je paramétrer avec le menu déroulant Canal de communication utilisé ?

Vous pouvez y paramétrer la méthode de communication via USB. Selon le périphérique utilisé, les options suivantes sont disponibles :

  • USB-COM uniquement : sélectionnez cette option pour accéder au périphérique via un port série.

  • USB-HID uniquement : cette option fait en sorte que le périphérique se comporte comme un clavier USB.

  • USB-COM + USB-HID : il s'agit d'une combinaison des modes ci-dessus.

REMARQUE : dans le cas de USB-COM uniquement, certains périphériques peuvent également figurer dans la liste sous « Périphériques HID », même s'ils ne sont pas dotés de la fonction HID.


Comment puis-je utiliser le lecteur à la place d'un clavier lors de l'utilisation d'un adaptateur PS/2 ?

Pour émuler un clavier PS/2, vous devez utiliser le câble série, l'alimentation externe et le câble d'émulation (voir l'Aide-mémoire. Numérisez le code de configuration Activer l'émulation clavier PS/2 à partir du document Codes de configuration du lecteur (disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration). Pour installer l'adaptateur PS/2, vous devez éteindre votre PC complètement. Connectez le lecteur en utilisant les câbles énumérés ci-dessus. Allumez ensuite votre ordinateur et le lecteur émulera un clavier PS/2.


Qu'arrive-t-il si je ne redémarre pas mon lecteur lorsqu'on me le demande ?

Les paramètres que vous avez modifiés ne prendront pas effet. Si vous changez d'avis, cliquez sur Système et sélectionnez Enregistrement des paramètres. Redémarrez ensuite le lecteur.


Qu'est-ce que le remplissage par des zéros ?

Le remplissage par des zéros place des zéros non significatifs au sein des données que vous transmettez, ce qui est nécessaire dans certaines des applications destinées à recevoir les données envoyées par le lecteur.


Comment puis-je configurer les paramètres réseau du lecteur ?

Si vous utilisez un lecteur DataMan 8000 sans fil, configurez les paramètres réseau sur la station de base. Si vous utilisez un lecteur filaire, utilisez l'onglet Réseau pour configurer les paramètres réseau.

Sélectionnez l'option Utiliser le serveur DHCP pour qu'un serveur DHCP (s'il en existe un) attribue une adresse IP au lecteur. Vous pouvez également saisir les paramètres réseau manuellement. Contactez votre administrateur réseau afin d'obtenir la valeur qui convient.

Lorsque vous modifiez les paramètres, la question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour prendre effet. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre lecteur.


Copier les paramètres réseau du PC

En cliquant sur le bouton Copier les paramètres réseau du PC, vous pourrez choisir Dell GigabitEthernet, Périphérique Bluetooth, Adaptateur virtuel Microsoft Wi-Fi Direct, Dell Wireless 1560 802. 11ac dans le menu déroulant. Les paramètres réseau de votre PC seront copiés dans les champs ci-dessus.


Mes paramètres de communication sont-ils synchronisés entre le lecteur et la station de base ?

Vous devez placer votre lecteur dans la station de base de sorte qu'ils puissent échanger et actualiser les paramètres afin d'être synchronisés. Si votre lecteur se trouve déjà dans la station de base lorsque vous modifiez vos paramètres de communication, enlevez votre lecteur et replacez-le dans la station de base.


Si le lecteur communique à 802.11b, fera-t-il communiquer tous les autres périphériques WiFi à une vitesse de 802.11b ?

Puisque le lecteur et sa base sont reliés par un raccordement point-à-point et vu qu'ils ne se connectent pas à un réseau WiFi d'autres fournisseurs, la vitesse de communication entre la base et le lecteur n'affectera pas les autres périphériques WiFi.


Pourquoi est-ce que tout est désactivé dans l'onglet WiFi ?

Si le lecteur est déjà associé à une base, les champs d'option sont grisés. Connectez-vous à la station de base si vous souhaitez modifier une configuration.


Pourquoi est-ce que tout est désactivé dans l'onglet Bluetooth ?

Si le lecteur est déjà associé à une base, les champs d'option sont grisés. Connectez-vous à la station de base si vous souhaitez modifier une configuration.


Comment puis-je désassigner mon lecteur de la station de base ?

Cliquez sur le bouton Désassigner dans la zone de groupe Station de base associée. Notez qu'après avoir cliqué sur Désassigner, votre connexion à l'outil de configuration sera perdue. Assurez-vous d'avoir enregistré toutes vos modifications auparavant.

Vous pouvez également vous déconnecter en numérisant le code de configuration Désassigner le lecteur.


« Recréer la liste au démarrage du microprogramme » – De quoi s'agit-il ?

Dans certains cas, le port COM figure dans la liste mais le démarrage du microprogramme met plus de temps et le délai d'attente du port COM expire ce qui est interprété comme une perte de connexion. Afin de prévenir ces cas, cette case assure que le port COM figure dans la liste recréée après le redémarrage du microprogramme.


Protocoles industriels

Protocole EtherNet/IP

Pour permettre au lecteur d'utiliser le protocole Ethernet/IP, cochez EtherNet/IP dans la boîte Protocoles industriels de l'onglet Ethernet.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres puis redémarrez votre lecteur.

Protocole PROFINET

Pour permettre à votre lecteur d'utiliser le protocole PROFINET, cochez PROFINET. Vous pouvez saisir le nom de la station en cliquant sur la boîte Utiliser nom de station.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres puis redémarrez votre lecteur.

Protocole SLMP

Pour permettre au lecteur d'utiliser le protocole SLMP, cochez Protocole SLMP puis réglez les paramètres selon vos besoins.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres, puis redémarrez le lecteur afin que le paramètre soit pris en compte en désactivant et activant l'alimentation du lecteur ou en lisant le symbole de Réinitialisation.

Modbus TCP

Pour permettre au lecteur d'utiliser le protocole Modbus TCP, cochez Modbus TCP puis réglez les paramètres selon vos besoins.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres, puis redémarrez le lecteur afin que le paramètre soit pris en compte en désactivant et activant l'alimentation du lecteur ou en lisant le symbole de Réinitialisation.

Sélection EtherNet/IP, PROFINET, Protocole SLMP ou Modbus TCP grisées

Un seul protocole Ethernet industriel peut être utilisé à la fois. Lorsqu'un protocole est sélectionné, l'autre est indisponible.


Comment utiliser l'option d'Authentification ?

Lorsque l'option Authentification est activée, l'outil de configuration invite l'utilisateur à saisir le mot de passe du compte admin à chaque tentative de connexion à un lecteur ou à une station de base disponible sur le réseau.


Comment puis-je établir une connexion TCP/IP ?

Le lecteur ‎permet les connexions TCP au port 23 qui est le port TCP par défaut pour les application Telnet. Si vous utilisez un client Telnet, le seul paramètre que vous devrez fournir est l'adresse IP du lecteur. Si vous utilisez SDK ou une autre application pour la connexion, assurez-vous qu'elle emploie le même paramètre de port TCP que votre lecteur. Le port TCP peut être modifié sur le volet Telnet. Le lecteur envoie automatiquement la sortie de code via cette connexion. Vous pouvez également émettre les commandes de contrôle Dataman (DMCC - DataMan Control Commands) via cette connexion.

Lorsque vous modifiez le port Telnet, la question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour prendre effet. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre lecteur.


Puis-je envoyer des images à un serveur FTP ?

Utilisez l'onglet Image FTP pour configurer les paramètres nécessaires au transfert d'images vers un serveur FTP. Cet onglet contient les paramètres d'adresse IP et de numéro de port du serveur, ainsi que la combinaison nom d'utilisateur/mot de passe. Notez que l'envoi des images par FTP n'est pas garanti, notamment lorsque le lecteur fonctionne à une fréquence supérieure et ne peut pas planifier l'heure de transfert des images. Veuillez également noter que le transfert via des connexions sans fil peut être beaucoup plus lent que la communication réseau normale. Dans ce cas, il est conseillé d'utiliser des images sous-échantillonnées/compressées.

Les options Nom du fichier permettent d'indiquer le fichier dans lequel les images seront stockées. Le champ Nom du fichier vous permet d'indiquer un chemin par rapport au répertoire racine du serveur FTP (par exemple, /échec_images/image). L'extension du nom de fichier (.jpg ou .bmp) présentée dans l'étiquette suivant le nom du fichier correspond au paramètre de format de l'image du volet Paramètres des images mises en mémoire tampon. Notez que le lecteur ne crée pas de répertoires. Le répertoire doit être disponible et accessible.

Le contrôle Valeur incrémentée max indique le seuil de la valeur incrémentée utilisée dans le nom du fichier. Une valeur 0 indique qu'aucun incrément ne sera ajouté et que le fichier peut être écrasé.

L'option Nom de fichier généré par le serveur commence par un chemin vide indiquant le répertoire racine du serveur FTP.

La liste Images à transférer vous permet de choisir le type d'images envoyées au serveur FTP. Notez que le serveur FTP doit prendre en charge le transfert d'images.


Qu'est-ce qu'un client réseau ?

Le comportement Client réseau permet au lecteur d'identifiants DataMan d'ouvrir activement une connexion Ethernet à un autre périphérique du réseau. Une fois ouverte, la connexion présente le même comportement opérationnel de base que la connexion DataMan Telnet : elle peut générer des résultats de lecture (transmettre des résultats à un périphérique externe) et agir en tant que serveur DMCC (en traitant les commandes reçues d'un périphérique externe).


Qu'est-ce qu'un hôte ?

L'hôte est le périphérique du réseau auquel le DataMan se connecte. Indiquez l'adresse Ethernet et le numéro de port du périphérique hôte. L'adresse peut être un nom de domaine complet (par ex. « serveur.monreseau.com ») ou une adresse IP à chiffres séparés par des points (par ex. « 192.169.0.1 »).


Qu'est-ce qu'un port client ?

Le port client est le port Ethernet du lecteur à l'origine de la connexion client. La valeur par défaut de 0 indique au client réseau d'utiliser n'importe quel port disponible. Dans certains cas, il peut être nécessaire de définir un port client spécifique. Définissez simplement le port client sur la valeur requise. Notez que, dans la plupart des cas, la valeur par défaut 0 s'applique. En cas de doute, utilisez la valeur par défaut.


Comment établir une connexion ?

Le client se connecte selon l'option Ouvrir la connexion choisie. Les options disponibles permettent de connecter le DataMan à l'allumage ou de le connecter dès la détection d'une activité de données (par ex. lorsqu'un code est lu).


Comment interrompre la connexion ?

Deux options Fermer la connexion sont disponibles. La connexion peut rester ouverte en permanence ou s'interrompre à la fin du transfert de données. Si vous choisissez l'option Après le transfert des données du lecteur, vous pouvez également définir un nombre de secondes après lesquelles la connexion s'interrompt si le lecteur demeure inactif. La durée de la période d'inactivité peut être réglée de 1 à 3 600 secondes.


Qu'est-ce que le délai d'attente de la connexion ?

Le délai d'attente de la connexion correspond à la durée (en millisecondes) observée par le DataMan avant l'ouverture de la connexion. Notez que si vous choisissez l'option de connexion À l'allumage, le lecteur réessaiera d'ouvrir la connexion en continu.


Qu'est-ce que le délai de reconnexion ?

Il s'agit de la durée (en millisecondes) de pause observée avant une nouvelle tentative de réouverture d'une connexion.


Quelles sont les données transmises lorsqu'un code contient des caractères non imprimables ?

En règle générale, les valeurs brutes des caractères non imprimables sont transmises.


Réparation et assistance


Qu'est-ce que Réparation et assistance ?

La Réparation et assistance peut être utilisée pour régler les paramètres réseau d'un périphérique réseau configuré de manière incorrecte ou pour changer le mode HID d'un périphérique série en CDC.


À quoi sert l'option Actualiser ?

Cliquez sur le bouton Actualiser pour actualiser la liste de périphériques disponibles.


Comment ajouter un périphérique réseau à la liste des périphériques affichés ?

Vous pouvez ajouter un périphérique réseau ou modifier l'adresse IP d'un périphérique déjà ajouté en cliquant sur Ajouter un périphérique réseau. Le dialogue Ajouter un périphérique réseau s'ouvre, permettant d'indiquer l'adresse IP du périphérique. Cliquez sur OK pour enregistrer les modifications et le périphérique s'affichera également à la page Connexion.


Comment puis-je changer les propriétés d'un périphérique ?

Sélectionnez un périphérique dans la liste des périphériques pour voir les options disponibles. Dans le volet d'ouverture, vous pouvez modifier les paramètres réseau appartenant au périphérique sélectionné ainsi que définir une option d'authentification. Cliquez sur Appliquer pour enregistrer les modifications.


DataMan séries 60, 300, 503, 8000, 8500 et station de base du lecteur DataMan 8000 : comment utiliser l'option Ajouter un périphérique ?

L'option Ajouter un périphérique vous permet d'ajouter manuellement votre DataMan à la liste des Périphériques réseau de manière à ce que vous puissiez connecter le lecteur ou la station de base DataMan à l'outil de configuration via votre réseau Ethernet au lieu d'utiliser un port de communication de votre PC.

Vous devez disposer de l'adresse IP du lecteur ou de la station de base pour pouvoir utiliser l'option Ajouter un périphérique. Procédez comme suit pour obtenir l'adresse IP actuellement attribuée au lecteur ou à la station de base :

  1. Connectez le lecteur ou la station de base à l'outil de configuration via une connexion RS-232 sur le PC (port COM de l'outil de configuration).

  2. Sélectionnez l'onglet Réseau sous Paramètres de communication.

  3. Copiez l'adresse IP indiquée.

  4. Revenez au volet Connexion au lecteur et cliquez sur Déconnecter.

  5. Cliquez sur Ajouter un périphérique.

  6. Collez ici l'adresse IP du lecteur DataMan.

Une fois les champs Nom et Adresse IP complétés, cliquez sur OK. Le lecteur ou la station de base doit apparaître dans la liste des périphériques DataMan accessibles dans la liste des Périphériques réseau et vous pouvez désormais connecter l'outil de configuration au lecteur ou à la station de base via le réseau Ethernet.

Notez que la fonction Ajouter un périphérique stocke le nom du lecteur ou de la station de base sur l'ordinateur local et qu'il ne sera pas visible sur les autres ordinateurs exécutant également l'outil de configuration.


À quelle fin puis-je utiliser l'icône d'exportation ?

Cliquez sur l'icône Exporter le fichier d'assistance Cognex pour déclencher la création du fichier d'assistance Cognex, ce qui génère un fichier .zip contenant une collection de journaux de données préconfigurés. Cette fonction est seulement disponible lorsqu'au moins un périphérique est sélectionné.

Un clic sur ce bouton ouvre une boîte de dialogue vous permettant de spécifier les type de données devant être inclus dans le fichier .zip d'assistance dans une liste de cases à cocher :

  1. Cfg

  2. Cdc

  3. Dernière image

  4. Périphériques détectés

  5. Statistiques du périphérique

  6. Statistiques de mémoire

  7. Commentaire utilisateur (peut être modifié manuellement par l'utilisateur)

Le dossier de destination du fichier d'assistance peut être modifié à l'aide de l'icône « ... ». Vous pouvez choisir d'ouvrir le dossier contenant le fichier après avoir généré le fichier ou de l'envoyer comme pièce jointe avec le client e-mail par défaut (.eml).

Le fichier de sortie du processus est un fichier .zip. Le nom de fichier contient le nom du périphérique et la date de création. Un fichier descriptor.xml dans le dossier .zip contient les données suivantes :

  1. Date

  2. Identifiant de détection

  3. Nom du périphérique

  4. Type de périphérique

  5. Numéro de série

  6. Adresse MAC

  7. Clés de fonctions

  8. Interface de communication

  9. Version du microprogramme

  10. Liste des fichiers se trouvant dans le dossier .zip


Quelle est la fonction du bouton Ajouter un périphérique virtuel ?

Cette fonction vous permet de créer un périphérique virtuel, soit sur la base d'un fichier de configuration personnalisé, soit sur la base d'un périphérique avec configuration par défaut. Ceci peut servir à consulter différents volets dans l'outil de configuration sans devoir connecter un périphérique. Un pression sur le bouton démarre un assistant qui vous guide à travers les étapes pour créer un périphérique virtuel. Les options initiales sont l'utilisation d'un fichier de configuration/de sauvegarde pour la création ou l'utilisation des paramètres d'usine.

Une fois l'assistant terminé, un nouveau périphérique virtuel est ajouté à la liste des périphériques détectés, signalé comme périphérique virtuel par une icône. Le périphérique virtuel créé n'est pas visible pour les autres périphériques du réseau. Le périphérique virtuel est conservé pendant de multiples instances de l'outil de configuration.

Le périphérique virtuel créé peut être connecté de la même façon qu'un périphérique normal, sauf que toutes les modifications de la configuration sont annulées (tout est en lecture seule) et aucune fonctionnalité, fonction ou action ne fonctionne sur les périphériques virtuels.


Sauvegarder


Comment utiliser la fonction Sauvegarde ?

Cette fonction vous permet de créer un fichier de sauvegarde contenant la configuration et les journaux d'un ou de plusieurs lecteurs en cliquant sur le bouton Sauvegarde dans le coin inférieur droit (ou en appuyant sur Alt+B). Cette fonction est seulement disponible lorsqu'au moins un périphérique est sélectionné.

Cliquez sur le bouton Ouvrir le dossier de sauvegarde pour accéder au dossier où se trouvent les fichiers de sauvegarde. Vous pouvez configurer le dossier sous Accueil->Options->Emplacement de sauvegarde.

Si de multiples périphériques sont sélectionnés, chaque périphérique crée un fichier de sauvegarde. Chaque fichier de sauvegarde est enregistré dans un sous-dossier correspondant au nom du périphérique. Le nom du fichier de sauvegarde contient le nom du périphérique et la date de création.

Le fichier de sauvegarde est un fichier .zip avec une extension .dmb. Le fichier contient : config.cdc, config.cfg et descriptor.xml. Le fichier xml contient les données suivantes :

  1. Date

  2. Identifiant de détection

  3. Nom du périphérique

  4. Type de périphérique

  5. Numéro de série

  6. Adresse MAC

  7. Clés de fonctions

  8. Interface de communication

  9. Version du microprogramme

  10. Liste des fichiers se trouvant dans le dossier .zip


Où puis-je configurer le dossier de sauvegarde pour la fonction de sauvegarde ?

Vous pouvez configurer le dossier sous Accueil->Options->Emplacement de sauvegarde


Restaurer


Comment puis-je utiliser la fonction Restaurer ?

La fonction Restaurer permet la restauration de fichiers de configuration sauvegardés sur un ou plusieurs périphériques. Cette fonction est seulement disponible lorsqu'au moins un périphérique est sélectionné et si une source de configuration valide est spécifiée.

En haut, sous Source de configuration, vous pouvez indiquer la source utilisée par l'outil de configuration pour la restauration.

  1. Fichier de configuration : lorsqu'il sélectionne cette option, l'outil de configuration utilise le fichier de configuration indiqué pour la restauration. Cliquer sur l'icône « ... » pour indiquer le dossier contenant le fichier de sauvegarde que vous souhaitez utiliser. Voir dans les Questions et Réponses sous Sauvegarde pour plus d'informations sur comment configurer le dossier.

    Remarque : le bouton Restaurer n'est activé que lorsqu'un périphérique compatible est sélectionné comme cible.

  2. Périphérique : lorsque l'outil de configuration sélectionne cette option, il utilise un périphérique unique déterminé pour restaurer sa configuration à tous les périphériques cibles.

  3. Sauvegarde la plus récente : lorsque l'outil de configuration sélectionne cette option, il recherche la sauvegarde la plus récente pour le périphérique sélectionné. Si de multiples périphériques sont sélectionnés, tous les périphériques reçoivent leur propre sauvegarde la plus récente.

  4. Paramètres d'usine par défaut : lorsque vous sélectionnez cette option, l’Outil de configuration rétablit les paramètres d’usine de la configuration.

Après que la source soit sélectionnée, ainsi qu'un périphérique (ou des périphériques) cible, cliquez sur le bouton Restaurer dans le coin inférieur droit.


Comment le bouton à liste déroulante Restaurer avec les paramètres réseau fonctionne-t-il ?

Restaurer avec les paramètres réseau fonctionne de la même manière que le bouton Restaurer, mais il restaure la configuration à partir du fichier .cdc se trouvant dans le dossier de sauvegarde au lieu du fichier .cfg. Cette option est seulement activée si un fichier .cdc est disponible dans la source indiquée, et que la sélection cible contient un seul périphérique.


Mise à jour du microprogramme


Comment mettre à jour le micrologiciel du lecteur ?

Sélectionnez Système->Mise à jour du micrologiciel... puis le fichier du micrologiciel.

Remarque : les fichiers du micrologiciel sont fournis sous forme d'archives compressées. Le micrologiciel doit être transféré dans le lecteur sous forme compressée ; n'essayez pas de décompresser un fichier de micrologiciel avant de le transférer.


Comment puis-je utiliser la fonction Mise à jour du microprogramme ?

Cette fonction met à jour le périphérique sélectionné avec la version de microprogramme souhaitée. Sélectionnez le périphérique ou les périphériques que vous souhaitez mettre à jour dans la liste des périphériques.

Rechercher les fichiers de microprogramme en cliquant sur l'icône « ... ». Si un périphérique unique est sélectionné dans la liste des périphériques, le dossier de microprogramme correspondant pour ce périphérique est ouvert. Si plusieurs périphériques sont sélectionnés, mais qu'ils ont le même ID de périphérique pour le microprogramme, le dossier correspondant est ouvert. Si aucun périphérique n'est sélectionné ou si un plus grand nombre de périphériques est sélectionné, mais qu'ils ont des ID de périphérique de microprogramme, le dossier de microprogramme racine est ouvert.

Si la case à cocher en bas est cochée, l'outil de configuration sauvegarde les fichiers de configuration de la même manière que la fonction Sauvegarde (voir Questions et Réponses pour de plus amples détails).

Après avoir sélectionné le fichier de microprogramme, cliquez sur Mettre à jour le microprogramme dans l'angle inférieur droit. Le bouton est activé seulement si la version du microprogramme sélectionnée et la sélection de périphérique sont compatibles.

Remarque : dans le cas de périphériques série, vous devez les découvrir d'abord en précédant à une actualisation manuelle avant de pouvoir mettre à jour le microprogramme.


Comparaison de la configuration


Comparaison de la configuration : Mise en page et structure générale

Comparaison de la configuration est un outil de type vue tabulaire utilisé pour le paramétrage, la copie, la comparaison ou la restauration des configurations de périphérique. La zone principale de la page de document contient un tableau avec les propriétés du périphérique préalablement sélectionné initialisées sur la page Connexion au lecteur.

Chaque type de document d'Outil de configuration utilise sa propre connexion. Dans le cas d'une communication en série, seule une connexion peut être ouverte simultanément.

La ligne d'en-tête affiche le nom ou les noms de périphérique sélectionné. La deuxième ligne d'en-tête en-dessous de la première affiche les configurations disponibles pour le périphérique. Les lignes d'en-tête en-dessous (en gras) peuvent être réduites ou développées en cliquant sur l'icône située à côté des lignes. Si un périphérique est déconnecté, une icône de reconnexion apparaît dans la ligne d'en-tête correspondante.

Les paramètres ne dépendant pas de la configuration de lecture sont seulement affichés dans la première colonne (configuration principale).


Comparaison de la configuration : Commandes (souris et clavier)

Sélection :

  • Souris : lors d'un clic sur une cellule dans le tableau, celle-ci est sélectionnée, ce qui met en surbrillance l'en-tête de ligne de la cellule et les en-têtes de colonne où appartiennent le périphérique et la configuration. Les boutons de menu et objets dans le menu ruban peuvent changer en fonction de la sélection. Si la cellule sélectionnée est dans la ligne d'une ligne d'en-tête, toutes les cellules dans la colonne correspondante à l'en-tête sont sélectionnées.

  • Clavier : les touches de mouvement de curseur permettent de naviguer dans la sélection jusqu'à la cellule souhaitée. Le mise en surbrillance et le comportement de sélection sont les mêmes que pour la souris.

Ajouter/modifier des valeurs :

  • Souris : pour les cellules avec éditeur intégré, un clic sur la commande d'éditeur (zone de liste modifiable, case à cocher, flèches monter/descendre pour chiffre) permettent de saisir des valeurs. Pour les cellules avec éditeur personnalisé, (l'icône « ... »), une fenêtre contextuelle s'ouvre, permettant la saisie des valeurs.

  • Clavier : pour les cellules avec éditeur intégré, le mode d'édition est démarré par la pression des touches Entrée ou F2, la touche Échap annule l'édition et une deuxième pression de la touche Entrée confirme l'édition. Les valeurs peuvent être saisies dans le texte sélectionné sans ouvrir le mode d'édition ; dans ce cas la valeur actuelle est écrasée par le premier caractère saisi.

    Pour les cellules contenant des chiffres, outre les cellules avec éditeur de texte intégré, les flèches haut et bas permettent d'augmenter et de réduire la valeur.

    Pour les cellules à menu déroulant, la touche Entrée ouvre le mode d'édition et affiche les éléments du menu déroulant, et les flèches haut et bas déplacent la sélection. Une deuxième pression sur Entrée applique la valeur sélectionnée et la touche Échap annule l'édition.

    Pour les cellules avec case à cocher, utiliser la touche Espace pour basculer entre l'état coché et non coché.

Copier et coller :

Utilisez respectivement les raccourcis clavier Ctrl+C et Ctrl+V pour copier et coller, voir la description copier-coller des éléments de menu du ruban correspondants pour plus d'informations.


Comparaison de la configuration : Menu ruban

Le menu ruban se trouve au-dessus du tableau de la vue tabulaire. Le contenu et les icônes activés peuvent changer en fonction des cellules, lignes ou colonnes sélectionnées dans le tableau. Le menu est divisé en plusieurs groupes.

  • Périphérique : les paramètres dans ce groupe sont reliés aux périphériques et à leurs fichiers de configuration. Utilisez le bouton Ajouter un périphérique... pour ouvrir une boîte de dialogue où un ou plusieurs périphériques peuvent être sélectionnés pour être ajoutés à la comparaison. Le bouton Ajouter fichier de configuration... ouvre un assistant vous permettant de rechercher un fichier de configuration ou de sauvegarde (.dmb, .cdc,.cfg). Si le fichier sélectionné pour le périphérique ne contient pas toutes les informations nécessaires, les paramètres manquants doivent être configurés, sinon, les options par défaut sont sélectionnées automatiquement. La même chose s'applique aux cas où la base de données du périphérique virtuel ne peut pas faire correspondre les paramètres aux options disponibles (par exemple, une version correspondante de microprogramme n'est pas trouvée).

    Remarque : les périphériques virtuels ajoutés sont en lecture seule, comme signalé par l'icône du cadenas dans la ligne d'en-tête.

    Un clic sur le bouton Supprimer périphérique supprime le(s) périphérique(s) actuellement sélectionnés (celui qui contient la/les cellule(s) actuellement sélectionnée(s)). Redémarrage du périphérique redémarre les périphériques sélectionnés. Conserver la configuration sur le périphérique enregistre le fichier de configuration du périphérique sélectionné dans sa mémoire flash. Utiliser Réinitialiser les paramètres d'usine pour réinitialiser les paramètres par défaut du/des périphérique(s) sélectionné(s).

  • Édition : utiliser Copier (ou Ctrl+C sur le clavier) pour copier une valeur à partir de la cellule actuellement sélectionnée. Coller ne peut être utilisé que dans la même ligne ou dans un éditeur de texte quelconque. Réinitialiser les valeurs est utilisé pour réinitialiser la/les valeur(s) des cellule(s) sélectionnée(s).

  • Surbrillance : les boutons et réglages dans ce groupe de menu permettent par différents moyens de mettre en surbrillance des arrière-plans spécifiques de cellules. Avec le réglage Valeurs non par défaut, les cellules contenant des valeurs différentes des valeurs par défaut sont mises en surbrillance (ceci peut être différent dans une seule ligne pour différents périphériques ou configurations de lecture). Le paramètre Différence par rapport à la référence met en surbrillance les cellules contenant des valeurs différentes de celles de la cellule dans la même ligne de la configuration de lecture de référence (et périphérique). Le troisième paramètre est sélectionné, toutes les valeurs et tous les en-têtes contenant le texte spécifié dans la boîte de texte sont mis en surbrillance. De plus, le texte contenu lui-même est mis en surbrillance avec un autre arrière-plan de texte. Une pression sur Entrée applique également la fonction du bouton Afficher uniquement les lignes en surbrillance.

    Lorsque la fonction est activée, Afficher uniquement les lignes en surbrillance réduit tous les nœuds dont aucun sous-nœud n'est en surbrillance. Lorsque l'option est activée, la Configuration de lecture référence fixe spécifie la configuration de lecture (et le périphérique) utilisée comme référence lorsque le mode de mise en surbrillance Différence par rapport à la référence est utilisé. Lorsque le bouton est activé, la colonne de la cellule actuellement sélectionnée (configuration de lecture) devient la configuration de référence. La configuration de référence actuelle est indiquée dans la ligne d'en-tête des noms de configuration.

  • Filtrage : Paramétrer Paramètres de configuration de lecture pour voir uniquement les paramètres dépendants de la configuration de lecture. Paramétrer Paramètres globaux pour voir uniquement les paramètres ne pouvant pas avoir de valeurs différentes au sein des différentes configurations de lecture. Paramétrer Tous les paramètres pour voir tous les paramètres simultanément. Si une entrée comporte des valeurs dans plusieurs configurations de lecture, elles sont visibles dans différentes colonnes.

  • Autres : utiliser Développer toutes les lignes pour développer toutes les lignes qui ont été réduites dans le tableau. Utiliser Réduire toutes les lignes pour réduire toutes les lignes développées du tableau. Réinitialiser la structure recalcule les largeurs de colonne pour utiliser tout l'espace disponible. Si l'espace disponible est insuffisant, une largeur de colonne minimum est appliquée.


Comparaison de la configuration : éditeur de comparaison

L'éditeur de comparaison s'ouvre pour chaque objet de Script dans la vue tabulaire de Comparaison des configurations (dans l'une de ses sous-catégories) après un clic sur l'icône « ... ». Après son ouverture, vous pouvez voir la source de script du périphérique où l'éditeur de comparaison a été ouvert.

En cliquant sur Rétablir les paramètres par défaut, le script revient au script par défaut pour ce périphérique en particulier. En cliquant sur Comparer, le script par défaut apparaît sur le deuxième périphérique sur la droite, mais le menu déroulant en haut peut être utilisé pour modifier le script qui est comparé avec celui sur la gauche. Un bouton Actualiser apparaît au milieu entre les onglets (rouge, flèches circulaires) permettant d'actualiser tous les textes de script.

Un clic sur Fermer ferme la comparaison et revient vers la vue tabulaire dans Comparer les configurations.


Fenêtre d'image


Qu'est-ce que la visionneuse d'images ?

Dans cette fenêtre, vous pouvez voir l'image lue par votre périphérique.

Utilisez les icônes de grossissement pour ajuster automatiquement l'image à la taille de la fenêtre de la visionneuse d'image, pour effectuer des zooms avant et arrière sur l'image ou pour afficher l'image en mode Pixel par pixel.

Vous pouvez également activer ou désactiver le Retour de mise au point sur l'image en mode Affichage continu et vous pouvez copier l'image dans le presse-papiers.

Utilisez l'option Enregistrer l'image pour enregistrer uniquement l'image actuelle out toutes les images de salve et les options Consignation pour consigner toutes les images de non lecture ou toutes les images décodées dans le système de fichiers.

Vous pouvez également choisir de vérifier l'histogramme de l'image lue et les données de luminosité d'un point sélectionné de l'image. Utilisez les boutons du ruban de cette fenêtre pour exécuter ces tâches.


Historique des résultats


Qu'est-ce que l'Historique des résultats ?

Dans ce volet, vous pouvez voir les informations décodées après chaque lecture.

Utiliser le bouton Pause pour mettre en pause/arrêter le défilement de la vue d'édition de l'historique des résultats, facilitant la recherche d'informations de lecture spécifiques. Tous les résultats entrants issus du périphérique seront rejetés par la fenêtre de l'historique des résultats jusqu'à l'arrêt de la pause.

Utilisez Effacer l'historique pour effacer la liste de l'historique. Vous pouvez également exporter une chaîne décodée unique ou toutes les chaînes en utilisant respectivement les options Copier et Copier tout.

Sous Consignation, vous pouvez cocher Générer des rapports de qualité du code afin d'inclure des données relatives à la qualité du code dans les informations décodées, cocher Générer des rapports de validation des données afin d'inclure des informations relatives à la validation des données et Consigner tous les résultats dans le système de fichiers pour enregistrer localement tous les éléments de l'historique des résultats sur votre disque dur local. D'autres options relatives à ce sujet sont accessibles en cliquant sur Paramètres de consignation et des rapports.

Personnaliser permet d'ajouter ou de supprimer des colonnes du tableau afin de personnaliser les informations dans l'historique des résultats.

Pour le filtrage des résultats, voir la question ci-dessous.


Comment fonctionne le filtrage des résultats ?

Vous pouvez utiliser le bouton Filtrer... dans la vue d'édition de l'Historique des résultats pour filtrer les résultats de lecture affichés dans la vue. Un clic sur le bouton active le filtrage. Pour configurer les paramètres de filtre, ouvrez les options en cliquant sur le côté droit du bouton.

Remarque : le bouton Filtre apparaît uniquement si le système d'exploitation le prend en charge.

Deux modes sont disponibles dans les paramètres de filtrage : filtrage standard et filtrage avancé. Vous pouvez sélectionner l'un des deux modes dans le menu déroulant sous Général.

Lors de l'utilisation du filtrage standard, les catégories de filtrage apparaissent activées dans la fenêtre de menu déroulant (état de lecture, méthode de validation, état de la validation et symbologie). Vous pouvez sélectionnez des filtres individuels sous chaque catégorie en cliquant dessus. Une fois activés, ces filtres sont utilisés sur tous les objets futurs dans l'historique des résultats mais également de manière rétroactive. Les objets non spécifiés par des filtres sont supprimés de l'historique des résultats jusqu'à la désactivation du filtrage. Veuillez noter que pour le filtrage standard, un seul résultat de lecture correcte au sein d'une séquence de déclenchement est considéré comme une lecture correcte pour toute la séquence de déclenchement. Ainsi, par exemple, le filtrage standard ne s'applique pas aux scénarios multicode ; utiliser les scripts de filtrage avancés pour les scénarios multicode.

Lors de l'utilisation du filtrage avancé, les catégories de filtrage standard sont désactivées et les Paramètres de filtrage avancé sont activés dans la fenêtre de menu déroulant. Un clic ouvre une nouvelle fenêtre où les expressions de filtre peuvent être modifiées. Si un filtre prédéfini était préalablement activé, l'expression générés peut être vue dans le dialogue à cet endroit. La modification de l'expression n'a pas d'effets négatifs sur les filtres prédéfinis.

L'expression de filtre est une fonction JavaScript. L'utilisation de membres de données du résultat est la même chose qu'avec le formatage basé sur un script. Le résultat de l'expression peut être vu dans la fenêtre du bas. En cas d'erreur JavaScript, le message d'erreur est affiché dans la fenêtre de texte. Veuillez noter que malgré les similitudes, le filtrage avancé n'est pas un script de formatage de données, uniquement un filtre d'affichage superposé à l'outil de configuration.


Pourquoi le symbole apparaît-il entouré de vert mais sans que des données ne s'affichent dans la liste de l'historique des résultats ?

Si la case Formatage standard activé est cochée dans le volet Formatage standard, vous devez construire une chaîne de sortie personnalisée où aucune donnée de résultat n'apparaîtra même si le lecteur a décodé le symbole.


Pourquoi certains résultats sont-ils précédés par une icône ?

Les résultats précédés d'une icône disposent d'une image de sauvegarde associée. Cliquez sur le résultat pour afficher la tentative de décodage et l'image associée.


Journal du périphérique


Qu'est-ce que le Journal du périphérique ?

Cette vue affiche les journaux générés lorsque la LED rouge sur votre périphérique clignote. Vous pouvez actualiser ce journal ou le supprimer lorsque vous n'en avez plus besoin.


Taille de l'image


À quoi sert l'option Taille de l'image (zone d'intérêt) ?

Vous pouvez utiliser cette fonction pour spécifier la zone exacte de l'image que le lecteur doit utiliser pour rechercher et décoder un symbole. Cela peut être utile si deux codes Data Matrix sont très proches l'un de l'autre et si vous devez être sûr de lire uniquement le code le long de la ligne de pointage cible. La diminution de la zone d'intérêt ne réduit pas nécessairement le temps de décodage ; elle ne diminue pas non plus la vitesse de transfert de l'image.


La taille de la zone d'intérêt du décodeur a-t-elle un effet sur les codes de configuration du lecteur ?

Une limitation trop restreinte de la zone d'intérêt peut empêcher le lecteur de lire les codes de configuration du lecteur.


Validation de données


Qu'est-ce que la validation des données ?

La validation des données confirme que les données encodées par un symbole sont au format correct pour une entreprise donnée, un secteur d'activités ou une norme internationale.


Où l'historique des résultats de la validation des données s'affiche-t-il ?

Les résultats (échec/réussite) de la validation des données et de sortie sont affichés dans l'historique des résultats. L'entrée du résultat dans la liste d'historique des résultats reçoit un icône « + » qui ouvre les détails du résultat de la tentative de validation. Les résultats de validation antérieurs peuvent être visionnés dans l'historique des résultats de la même manière.


Que signifient les codes d'erreur de validation ?

Les résultats d'échec de la validation des données sont les suivants :

  • 1 : identificateur de la symbologie non valide. L'identificateur de symbologie est la chaîne à 3 caractères qui n'identifie pas seulement le type de symbologie utilisé pour le codage des données mais qui décrit également la manière de traiter les données. La chaîne peut optionnellement être validée comme entrée dans l'outil en plus des données décodées soit comme une entité séparée soit comme préfixe du flux de données.

    Exemple : pour un symbole UCC/EAN-128, l'identificateur de symbologie est ]C1. Dans certaines applications, il s'agit de l'unique façon de différencier précisément et automatiquement les symboles code 128 et UCC/EAN-128 internes ou industriels (qui codent les identificateurs d'application EAN.UCC). Sans identificateurs de symbologie, il ne serait pas possible de savoir comment traiter les données dans le symbole.

  • 2 : non correspondance du modèle.

  • 3 : qualificateurs de données non valides (AI, DI ou TEI).

  • 4 : identificateur d'application (AI) non valide.

  • 5 : identificateur de données (DI) non valide.

  • 6 : identificateur d'élément de texte (TEI) non valide.

  • 7 : données non valides : si les données ne correspondent pas au qualificateur de données au niveau du type, de la longueur ou de la valeur.

  • 8 : séparateur de champ non valide.

  • 9 : non conforme à ISO/CEI 15434.

  • 10 : formats non pris en charge (par ex. dans les applications UID DoD, formats autres que 05, 06 ou DD).

  • 11 : code de format non valide : codes de format autres que 00-99 and DD.

  • 12 : ISO/CEI 15434 non pris en charge si l'option de validation ISO/CEI 15434 est sélectionnée et si le flux décodé ne provient pas d'un symbole 2D. Il est uniquement possible de rapporter cet échec si l'identificateur de symbologie est validé comme entrée dans l'outil.

  • 13 : champ d'application non valide : un champ non pris en charge par l'application.

  • 14 : champ d'application non pris en charge : un champ pris en charge dans l'application mais non pris en charge par l'outil.

  • 15 : données d'application non valides : si les données ne correspondent pas aux exigences spécifiques à l'application.

    Exemple : les applications UID DoD ont les exigences suivantes : la chaîne de caractères ID de l'entreprise ne dépassera pas 13 caractères, qualificateur de données exclu. La chaîne de caractères de la référence de la pièce et du numéro de lot d'origine (caractères spéciaux autorisés inclus) ne dépassera pas 32 caractères, qualificateur de données exclu. La chaîne de caractères du numéro de série (caractères spéciaux autorisés inclus) ne dépassera pas 30 caractères, qualificateur de données exclu.

  • 16 : présence de formats multiples dans le même flux de données (par ex. dans les applications UID DoD, il ne peut pas y avoir plus d'un format présent dans le flux de données).

  • 17 : champs en double : occurrences multiples du même qualificateur de données dans le même symbole. Certaines applications telles que les applications UID DoD n'autorisent pas les champs en double dans le même symbole.

  • 18 : UID non valide : tous les champs requis pour construire une UID de construction n° 1 ou n° 2 valide ne sont pas présents.

  • 19 : UID de construction n° 1 non valide : tous les champs requis pour construire une UID de construction n° 1 valide ne sont pas présents.

  • 20 : UID de construction n° 2 non valide : tous les champs requis pour construire une UID de construction n° 2 valide ne sont pas présents.

  • 21 : fin de format manquante lors de la vérification de la conformité à la syntaxe ISO 15434 ou UID DoD.

  • 22 : fin de message manquante lors de la vérification de la conformité à la syntaxe ISO 15434 ou UID DoD.


Comment puis-je modifier l'aspect de la sortie et la couleur de la diode pour les codes qui échouent au test de validation ?

Sélectionnez le volet Paramètres système. Dans la zone Action si échec de validation, vous pouvez sélectionner l'aspect, l'intensité et la couleur de la diode.


Qu'est-ce que la validation UID DoD ?

La validation UID DoD évalue les données d'un code Data Matrix et détermine si elles sont encodées conformément aux directives Mil Standard 130 du Département Américain de la Défense. Le Département Américain de la Défense exige désormais que tous les articles (d'une valeur supérieure à 5 000 US$ ou qui sont produits spécialement en série) qu'il reçoit ou conserve en stock soient dotés d'un numéro de série unique (UII) dans un format de syntaxe spécifique. L'outil de validation UID DoD s'utilise également pour confirmer que les données d'un code sont formatées correctement, conformément aux types de construction 1 et 2 du Département Américain de la Défense. La fonction de validation UID DoD confirme également automatiquement si une chaîne de caractères est conforme aux normes ISO 15434 et ISO 15418. La sortie du code UII concaténé (ou simplement les éléments de données du code UII sans la syntaxe ISO 15434 et les qualificateurs de données ISO 15418) s'affiche dans le premier champ de résultats du champ Résultats de la validation du volet Résultats.

Les éléments de données de la Construction 1 comprennent : l'identifiant d'entreprise du fabricant EID (CAGE, DUNS, EAN.UCC) d'une société accompagné du numéro de série de la pièce intégré à son identificateur EID. L'identifiant d'entreprise et les numéros de série sont représentés par des qualificateurs de données spécifiques qui dépendent du format utilisé par l'entreprise : DI, AI ou TEI.

Les éléments de données de la Construction 2 comprennent : l'identifiant d'entreprise du fabricant (EID), l'identificateur de la référence de la pièce (PN) et du numéro de lot du fabricant (BN) ainsi que le numéro de série unique de la pièce intégré à la référence de la pièce spécifique au fabricant. L'identifiant d'entreprise, la référence de la pièce/le numéro de lot et les numéros de série sont représentés par des qualificateurs de données spécifiques qui dépendent du format utilisé par l'entreprise : DI, AI ou TEI.

Remarque : cette option n'est pas disponible sur tous les lecteurs.


Quelle symbologie dois-je utiliser pour la validation UID DoD ?

Le Département Américain de la Défense spécifie actuellement le code Data Matrix comme standard pour le marquage UID.


Qu'est-ce que le code EID attendu ?

Le code EID attendu fait référence à l'identificateur d'entreprise du fabricant dans la chaîne de caractères UII. L'identificateur d'entreprise du fabricant (EID) représente le code CAGE, DUNS, EAN.UCC ou une autre identification du fabricant. L'EID attendu est une valeur spécifique DoD.


Qu'est-ce que le code PN attendu ?

Le code PN attendu fait référence à la référence de la pièce du fabricant dans la chaîne de caractères UII. Le PN attendu est une valeur spécifique DoD.


Qu'est-ce que le code BN attendu ?

Le code BN attendu fait référence au numéro de lot du fabricant dans la chaîne de caractères UII. Le BN attendu est une valeur spécifique DoD.


Qu'est-ce que la validation ISO ?

La fonction de validation ISO est utilisée pour déterminer si une chaîne de caractères est encodée conformément à la syntaxe ISO 15434 ou ISO 15434 avec l'additif ISO 15418.

La norme ISO 15434 vérifie que la chaîne de caractères est encodée avec la syntaxe correcte qui comprend l'évaluation des caractères ASCII « non imprimables » tels que l'en-tête du message, le séparateur d'enregistrement, le code du format (AI, DI ou TEI), les séparateurs de groupes et le caractère de fin de transmission.

La norme ISO 15418 confirme si la chaîne de caractères est encodée avec les qualificateurs de données corrects pour chaque élément de donnée. En fonction du format utilisé par le fabricant (AI, DI ou TEI), chaque élément de donnée (code EIN du fabricant, référence de la pièce et numéro de série) est précédé d'un code spécifique ou « qualificateur de donnée ».

Remarque : cette option n'est pas disponible sur tous les lecteurs.

Remarque : cette option autorise également les identificateurs d'élément de texte comme définis dans la spécification ATA CSDD.


Qu'est-ce que la validation GS1 ?

La validation GS1 vous permet de vérifier la syntaxe et la sémantique des symboles par rapport à la spécification GS1. Le lecteur peut valider les données encodées par rapport à une chaîne d'identificateurs configurable. Tous les identificateurs de l'application sont pris en charge.

Par défaut, le lecteur valide le symbole entrant par rapport à la chaîne de format EFPIA (European Federation of Pharmaceutical Industries and Associations), par exemple :

<AI(01)><AI(10)><AI(17)><AI(21)>

À l'aide de la validation GS1, vous pouvez définir ce que le lecteur transmet lorsque les données d'un symbole ne passent pas la vérification, y compris un retour chariot et un saut de ligne. Le volet Détails des résultats affichera alors une mention de réussite ou d'échec pour chaque symbole et répertoriera chaque identificateur d'application du symbole, accompagné de l'élément de donnée correspondant.


Qu'est-ce que la validation de la chaîne de recherche ?

La validation de la chaîne de recherche permet de spécifier une chaîne exacte de caractères à rechercher dans la chaîne encodée par le symbole. Seuls les symboles qui contiennent une chaîne qui correspond à la chaîne spécifiée produisent une évaluation réussie.


Comment puis-je valider des chaînes ayant des valeurs qui changent ?

Activez l'option Incrément/Décrément composante numérique pour spécifier que la partie de la chaîne à valider est une valeur numérique qui augmente ou diminue à chaque lecture.


A quoi sert la fonction Incrément/Décrément composante numérique ?

Utilisez cette fonction pour valider la chaîne de recherche dans les applications où des données sont codées en série ou varient linéairement. Par exemple, cette fonction est utile dans une application de reliure de magazines ou de livres où les numéros des pages sont suivis par des codes-barres pour vérifier qu'il n'y a pas de pages en double ou manquantes.


Comment configurer la fonction Incrément/Décrément composante numérique ?

Vous pouvez utiliser cette fonction si la chaîne que vous validez contient une suite de chiffres (0 à 9) qui augmente ou diminue à chaque lecture. Pour utiliser cette fonction, spécifiez la position de départ des chiffres à augmenter ou à diminuer dans le champ Position de départ (0 est la position du premier caractère) et le nombre de caractères qui changent dans le champ Longueur. Si vous sélectionnez Auto pour la Longueur, le lecteur traite tous les chiffres suivant la position de départ comme valeur à augmenter ou à diminuer. Utilisez l'option Incrément pour spécifier de combien la valeur change entre les lectures. Sélectionnez une valeur négative si le nombre diminue.

Par exemple, si la chaîne initiale est ABC_123XXPY et si « 123 » augmente d'une unité à chaque lecture, spécifiez 4 pour la Position de départ, 3 pour la Longueur et 1 pour l'Incrément. (Si vous êtes sûr que les caractères en position 7 ne sont jamais des chiffres, vous pouvez également spécifier Auto pour la Longueur.) Veuillez noter que le paramétrage automatique n'augmente pas le nombre des chiffres lorsque le nombre maximum est atteint, mais réinitialise le nombre comme avec tout réglage fixe de chiffre (par exemple, atteint 99 avec deux chiffres, ne passe pas à 100 mais à 00).

Par défaut, si la chaîne de caractères est incorrecte ou illisible, la valeur numérique attendue ne change pas. Vous pouvez cocher les cases Mise à jour si absence de lecture et Mise à jour si échec de validation pour spécifier que la valeur attendue change si aucun code n'est lu et/ou si le code est incorrect.


À quoi sert la validation de correspondance des modèles ?

La validation de correspondance des modèles permet à un utilisateur d'entrer une chaîne de caractères particulière de façon à confirmer sa présence dans la chaîne de caractères. Par exemple, un utilisateur peut entrer le modèle 17V utilisé dans les formats DI pour identifier l'identificateur d'entreprise du fabricant. Si les caractères 17V sont présents dans le code, le lecteur signale la réussite de la validation pour ce code. Si les caractères sont absents, le lecteur signale un échec de validation.

Vous devez utiliser une expression régulière en tant que modèle pour la validation des modèles.


À quoi sert la fonction Action si échec de validation ?

La fonction Action si échec de validation détermine ce que le lecteur envoie après un échec de validation. L'utilisateur peut faire son choix parmi diverses options :

  1. Transmettre la chaîne Echec de validation - Le lecteur envoie la chaîne Echec de validation lorsque la validation échoue pour un code
  2. Transmettre la chaîne Echec de validation + la chaîne décodée - Le lecteur envoie la chaîne Echec de validation suivie de la chaîne complète décodée
  3. Transmettre la chaîne décodée annotée - Le lecteur envoie la chaîne décodée accompagnée d'informations sur le type et l'emplacement de l'erreur dans la chaîne de caractères
  4. Ne rien transmettre - Le lecteur n'envoie aucune information
  5. Transmettre la chaîne « Échec de validation » + la chaîne décodée citée - Le lecteur envoie la chaîne « Échec de validation » suivie de la partie citée de la chaîne décodée


À quoi sert la case à cocher CR/LF en cas d'échec de validation ?

La case à cocher CR/LF introduit les caractères non imprimables retour chariot/nouvelle ligne après l'envoi d'un échec de validation.


Comment rechercher plusieurs chaînes de recherche ?

Utilisez la validation de recherche de modèle et saisissez une chaîne de recherche au format Perl. Par exemple, pour rechercher les chaînes 123, 456 ou 789, saisissez le modèle :

^(123¦456¦789)$


Qu'arrive-t-il lorsque la validation des données est activée ?

L'état de validation des données est affiché dans l'entrée État des résultats de la liste de résultats du volet Historique des résultats. L'état en cas de validation réussie est « Valide », celui en cas d'échec de la validation « Non valide ». Pour afficher plus de détails sur le résultat de la validation, le résultat peut être étendu.


Qu'est-ce que le formatage de données en cas d'échec de la validation ?

Le formatage de données « Formatage de base » n'est pas appliqué à un résultat si la validation des données a échoué. Au lieu de cela, l'«Action si échec de la validation » est exécutée. Elle est différente en comparaison avec le formatage de données « Formatage basé sur un script ». Si le « Formatage basé sur un script » est activé, l'« Action si échec de la validation » n'est pas exécutée et la fonction de formatage basé sur un script est exécutée. Cela permet, par exemple, d'affiner l'état de la « Validation des données » via un script.


Paramètres de sauvegarde


Qu'est-ce que la sauvegarde automatique de la configuration du lecteur ?

La sauvegarde automatique fonctionne avec les périphériques connectés par Ethernet. Lorsqu'elle est activée, cette fonction effectue une sauvegarde de la configuration du périphérique sur une mémoire de stockage externe (un serveur FTP) chaque fois que la configuration est enregistrée sur flash. Un service Cognex Explorer peut recevoir les données de sauvegarde. Une restauration peut être effectuée manuellement, soit par l'outil de configuration, soit par les commandes DMCC, soit par Cognex Explorer.

Configurez le lecteur avec l'adresse IP et le numéro de port nécessaires pour indiquer l'emplacement de la sauvegarde de la configuration. Vous pouvez également définir une combinaison de nom d'utilisateur et mot de passe.


Code de sauvegarde périphérique d'impression


À quoi sert l'option Imprimer le code de sauvegarde du périphérique ?

Utilisez cette option pour imprimer les codes de sauvegarde du lecteur (réinitialisation matérielle et code de redémarrage) de sorte que vous puissiez remplacer votre périphérique en les lisant à l'aide du lecteur. Ces codes contiennent également les paramètres réseau et série.

Dans la section Notes, vous pouvez écrire d'importantes notes qui figureront également sur la page imprimée. Si vous souhaitez imprimer les codes de réinitialisation sur des pages séparées, cochez la case Imprimer le code de réinitialisation sur sa propre page.


Imprimer le code de configuration


À quoi sert l'option Imprimer le code de configuration ?

Utilisez cette option pour imprimer les codes de configuration du lecteur (réinitialisation matérielle et code de redémarrage) de sorte que le(s) périphérique(s) que vous souhaitez configurer puisse(nt) les lire.

Dans la section Notes, vous pouvez écrire d'importantes notes qui figureront également sur la page imprimée. Si vous souhaitez imprimer les codes de réinitialisation sur des pages séparées, cochez la case Imprimer le code de réinitialisation sur sa propre page.


Enregistrement des données


Qu'est-ce que l'enregistrement des données ?

L'enregistrement des données vous permet d'enregistrer automatiquement les images qui ont été lues avec succès dans un emplacement de fichier spécifique. Vous pouvez aussi enregistrer des rapports de validation des données pour les symboles que vous vérifiez, si la validation des données a été activée pour le type de code en cours de numérisation par le lecteur. Assurez-vous de rester connecté à l'outil de configuration pour permettre le fonctionnement de l'enregistrement des données.


Quand dois-je désactiver les graphiques superposés dans un rapport ?

Cochez Désactiver les graphiques superposés dans le rapport si vous ne souhaitez pas qu'un carré vert figure dans le PDF autour d'un code de lecture.


Vue d'édition de l'image


Qu'est-ce que le Volet d'images ?

Dans ce volet, vous pouvez voir l'image lue par votre périphérique.

Utilisez les icônes de grossissement pour ajuster automatiquement l'image à la taille de la fenêtre de la vue d'édition de l'image, pour effectuer des zooms avant et arrière sur l'image ou pour afficher l'image en mode Pixel par pixel.

Vous pouvez également activer ou désactiver le Retour de mise au point sur l'image en mode Affichage continu et vous pouvez copier l'image dans le presse-papiers.

Utilisez l'option Enregistrer l'image pour enregistrer uniquement l'image actuelle out toutes les images de salve et les options Consignation pour consigner toutes les images de non lecture ou toutes les images décodées dans le système de fichiers. Cliquez sur la dernière option de consignation Paramètres de consignation et des rapports... pour ouvrir la fenêtre des Options de l'outil de configuration qui est également accessible depuis l'écran d'accueil de l'outil de configuration, via le menu Options.

REMARQUE : les Paramètres d'affichage des images n'ont aucun effet lors de la sauvegarde de la dernière image capturée du Volet d'images (par glisser-déposer) La dernière image est toujours sauvegardée en pleine taille (la résolution maximum du périphérique).


Où dois-je mettre l'image pour que le lecteur puisse la lire ?

Vérifiez que le symbole est bien centré dans la zone d'image du lecteur et que le point rouge du laser est au centre du symbole.


Je n'arrive pas à lire les codes sur mes pièces. Que faire ?

  • Veillez à bien appuyer sur le déclencheur et maintenez-le enfoncé. Si vous relâchez le déclencheur avant la fin de la lecture, le lecteur abandonne la tentative de lecture.

  • Vérifiez que le lecteur est situé suffisamment près du code, en fonction des formats et types répertoriés dans la Table de numérisation.

  • Vérifiez que le code est bien centré dans la zone d'image du lecteur et dans le champ de lumière verte avant d'appuyer sur le déclencheur.

  • Cliquez sur Paramètres d'éclairage et d'imageur (Paramètres UltraLight pour DM7DM8500 et DM8600), puis ajustez les paramètres d'éclairage.

  • Cliquez sur Paramètres de symbologie et vérifiez que le type de symbologie utilisé est bien activé.


Je rencontre des problèmes pour lire les symboles. Que faire ?

  • Vérifiez que le lecteur est situé suffisamment près du code, en fonction des formats et des types répertoriés dans l'Aide-mémoire.

  • Vérifiez que le symbole est bien centré dans la zone d'image du lecteur et assurez-vous que le symbole est centré dans le viseur laser rouge lorsque le périphérique est déclenché.

  • Cliquez sur Paramètres de symbologie et vérifiez que la symbologie utilisée est bien activée.


Comment déclencher le lecteur à l'aide de l'outil de configuration ?

Cliquez sur le bouton de déclenchement (icône d'éclair) de la barre d'outils tout en haut ou appuyez sur <Ctrl>-T.


Comment enregistrer une image acquise dans un fichier ?

Cliquez sur le bouton Enregistrer l'image dans la barre d'outils. Vous pouvez enregistrer toutes les images sous forme de salve en ouvrant la liste déroulante et en cliquant sur Enregistrer toutes les images de salve.

Vous pouvez également glisser et déposer votre image dans votre PC. Cliquez sur l'image dans la visionneuse d'images, glissez-la hors de l'outil de configuration et relâchez-la.

Veuillez noter que si vous souhaitez enregistrer une image avec la fonction glisser/déposer et si l'image n'est pas la plus récente (vous l'enregistrez à partir de l'Historique des résultats de lecture), l'image sera enregistrée avec les paramètres de qualité des images. Par défaut, sa qualité est réduite. Sous Paramètres de l'image affichée, vous pouvez changer la taille de l'image pour passer en plein écran et le format pour passer à Bitmap.


Mise en mémoire tampon et transfert


Que désignent les paramètres d'image mise en mémoire tampon ?

Sous Paramètres des images mises en mémoire tampon, vous pouvez changer la taille, le format et la qualité de l'image transférée via FTP.

  • Taille : la taille par défaut pour les images mises en mémoire tampon est l'image en taille réelle. Le choix d'une taille d'image permet au lecteur d'effectuer un sous-échantillonnage de chaque image, ce qui peut améliorer considérablement la vitesse de transfert des images au détriment de certains détails précis des images.

  • Format : par défaut, le lecteur stocke chaque image acquise au format .bmp.

  • Qualité : disponible uniquement si vous utilisez le format d'image .jpeg, ce curseur ajuste les paramètres internes qui permettent au lecteur de lisser l'image acquise. Cette opération peut diminuer ou améliorer la vitesse de transfert.


Qu'est-ce que l'option Graphique superposé ?

Lorsque cette option est activée, les images que vous sauvegardez (à travers le FTP ou en les enregistrant) contiennent un graphique superposé en tant que fichiers SVG accompagnant les fichiers images.


Pourquoi ne vois-je pas d'images décodées ?

La fonction Mise en mémoire tampon et transfert n'effectue aucun décodage. Activez Graphique superposé dans le volet Paramètres des images mises en mémoire tampon pour enregistrer vos images avec un graphique superposé (en tant que fichiers SVG) qui sera affiché à la lecture de vos images. Ce graphique présente les données décodées et d'autres informations sur le décodeur.


Que puis-je faire avec Mise en mémoire tampon et transfert ?

Mise en mémoire tampon et transfert vous permet de contrôler quelles images sont enregistrées et sauvegardées sur le lecteur, d'afficher les images enregistrées sur le lecteur et de transférer ces images vers votre PC.

  • L'onglet Mémoire des images vous permet de contrôler les images à enregistrer dans le lecteur.

  • L'onglet Transfert des images vers le PC vous permet de contrôler la manière dont les images sont transférées du lecteur vers votre PC.

  • L'onglet Transfert des images vers FTP vous permet de configurer le transfert automatique d'images du lecteur vers votre PC.

  • Utilisez l'onglet Transfert des résultats vers FTP pour configurer le lecteur avec l'adresse IP et le numéro de port nécessaires à l'envoi de résultats de décodage à un serveur FTP.


Puis-je envoyer les résultats d'un décodage à un serveur FTP ?

Utilisez l'onglet Transfert des images vers FTP pour configurer le lecteur avec l'adresse IP et le numéro de port nécessaires à l'envoi de résultats de décodage à un serveur FTP. Cet onglet contient également les paramètres d'une combinaison nom d'utilisateur/mot de passe, ainsi que le nom du fichier dans lequel les résultats seront stockés.


Comment puis-je enregistrer les données FTP dans un répertoire différent du répertoire racine ?

Le champ Nom de fichier accepte non seulement les noms de fichier, mais également les noms de chemin. Utilisez des barres obliques comme séparateurs. Par exemple, /images/image.


Pourquoi ne puis-je pas voir les images et résultats dans mon répertoire FTP ?

Assurez-vous que vous avez les permissions nécessaires pour créer des fichiers. Si l'option Ajouter est cochée, assurez-vous que l'utilisateur FTP a l'autorisation d'ajouter (qui est différente de l'autorisation d'écriture). L'utilisateur du FTP doit aussi vérifier l'adresse IP du serveur FTP correct.


A quoi sert la liste Résultats à mettre en mémoire tampon ?

La liste Résultats à mettre en mémoire tampon vous permet de choisir le type d'images à mettre en mémoire tampon en interne sur le lecteur, qu'elles contiennent des informations décodées (Lecture), non décodées (Non lecture), les deux (Toutes) ou des Échecs de validation, auquel cas non seulement les images correctement décodées seront enregistrées, mais également les échecs de validation.


Qu'est-ce que l'option Images à mettre en mémoire tampon pour un résultat ?

Vous pouvez choisir les images à mettre en mémoire tampon pour un résultat. Identique au résultat signifie que pour une lecture correcte, le lecteur ne stocke que les images dotées d'un code identifié.


Qu'est-ce que la Taille maximale de la mémoire tampon d'images ?

La Taille maximale de la mémoire tampon d'images est le nombre maximum d'images qui peuvent être mises en mémoire tampon sur le lecteur. Ce nombre est limité par la mémoire du lecteur, mais peut être défini sur un nombre inférieur au maximum afin d'éviter que le nombre des images enregistrées sur le serveur FTP ou sur le PC surpasse le nombre souhaité.


Qu'est-ce que l'option Disponible pour l'outil de configuration/DMCC ?

Disponible pour l'outil de configuration/DMCC signifie le nombre d'images non utilisées par le système d'acquisition ou l'enregistrement des images. Il s'agit du nombre maximal d'images de résultat pouvant être transférées à l'outil de configuration ou à SDK pour un résultat.

REMARQUE : il s'agit d'une valeur informative qui ne peut être modifiée.


Que permet de définir le mode d'image à lecture correcte ?

L'option Image à lecture correcte stocke toutes les images à lecture correcte mises en mémoire tampon à moins que vous ne définissiez un taux limite.

Vous pouvez limiter le nombre d'images à lecture correcte mises en mémoire tampon en sélectionnant Taux limité. Définissez le taux de lecture d'image (le nombre d'images mises en mémoire tampon et la fréquence de ce compte) et la salve du taux qui est le taux de point par durée définie.


Qu'advient-il si je coche l'option Autoriser l'effacement de la mémoire tampon ?

Cette option détermine si l'enregistrement des images dans la mémoire tampon écrase les images plus anciennes ou cesse la mise en mémoire tampon lorsque celle-ci est pleine.


Comment puis-je m'assurer que les images sont supprimées après le transfert ?

Cochez la case Supprimer après transfert qui contrôle la suppression des images après leur transfert. Cela s'applique à tous les modes de transfert, y compris le Transfert des images vers FTP et le transfert du lecteur au PC.


Pourquoi le bouton Transférer maintenant n'est-il pas activé ?

Si vous avez mis en mémoire tampon des images sur le lecteur, vous devez d'abord sélectionner le dossier dans lequel les enregistrer. Vous devez également cesser l'enregistrement avant de commencer le transfert.

Veuillez noter que Transférer maintenant ne fonctionne pas lorsque le périphérique est hors de portée de la station de base du lecteur (en cas de périphérique sans fil), car la mémoire tampon est vidée et désactivée lorsque hors de portée.


Est-ce que le bouton Effacer le dossier de transfert efface également la bande de film ?

Le bouton Effacer le dossier de transfert supprime toutes les images du dossier. Si les mêmes images sont actuellement affichées sur la bande de film, celle-ci sera également effacée.


Si j'ai déjà des fichiers dans le dossier sélectionné, seront-ils écrasés ?

Si des fichiers qui correspondent au Format [Index] existent déjà dans le dossier sélectionné, l'index de départ est automatiquement augmenté jusqu'à l'absence de correspondance, puis le transfert commence. Les fichiers d'image ne sont pas écrasés.


Puis-je afficher les images individuellement ?

Vous pouvez afficher les images l'une après l'autre, mais vous devez sélectionner l'intégralité du dossier où elles se trouvent. Une fois que les images du dossier sélectionné sont affichées, cliquez dessus en utilisant les boutons suivant et précédent.


Dois-je recommencer l'affichage des images depuis le début si je dois quitter le volet ?

Non, le fait de quitter le volet Mise en mémoire tampon et transfert met la lecture sur pause, comme si vous aviez cliqué sur le bouton Pause.


Comment transférer des images vers un serveur FTP ?

Utilisez l'onglet FTP pour configurer les paramètres nécessaires au transfert d'images vers un serveur FTP. Cet onglet contient les paramètres d'adresse IP et de numéro de port du serveur, ainsi que la combinaison nom d'utilisateur/mot de passe. Notez que l'envoi des images par FTP n'est pas garanti, notamment lorsque le lecteur fonctionne à une fréquence supérieure et ne peut pas planifier l'heure de transfert des images. Veuillez également noter que le transfert via des connexions sans fil peut être beaucoup plus lent que la communication réseau normale. Dans ce cas, il est conseillé d'utiliser des images sous-échantillonnées/compressées.

Les options Nom du fichier permettent d'indiquer le fichier dans lequel les images seront stockées. Le champ Nom du fichier vous permet d'indiquer un chemin par rapport au répertoire racine du serveur FTP (par exemple, /échec_images/image). L'extension du nom de fichier (.jpg ou .bmp) présentée dans l'étiquette suivant le nom du fichier correspond au paramètre de format de l'image du volet Paramètres des images mises en mémoire tampon. Notez que le lecteur ne crée pas de répertoires. Le répertoire doit être disponible et accessible.

Le contrôle Valeur incrémentée max indique le seuil de la valeur incrémentée utilisée dans le nom du fichier. Une valeur 0 indique qu'aucun incrément ne sera ajouté et que le fichier peut être écrasé.

Le Nom de fichier généré par le script permet d'écrire un script générant le nom de fichier dans l'onglet Stockage FTP du volet Scripts.

L'option Nom de fichier généré par le serveur commence par un chemin vide indiquant le répertoire racine du serveur FTP.


Le transfert d'images vers FTP en fonction de la durée d'exécution ne fonctionne pas. Que faire ?

Assurez-vous que les conditions suivantes sont remplies :

  • L'adresse du serveur, le nom d'utilisateur et le mot de passe sont correctement configurés.

  • Le mode de transfert est réglé sur « FTP - Durée d'exécution ».

  • Dans l'onglet Mémoire tampon, « Résultats à mettre en mémoire tampon » est défini sur un autre réglage que Aucun (en fonction de vos besoins).

  • Votre serveur FTP prend en charge le transfert d'images.


Qu'est-ce que le nom de fichier généré par le script ?

Vous pouvez écrire un script générant le nom de fichier pour le transfert vers FTP dans l'onglet Stockage FTP du volet Scripts.


Qu'est-ce que le nom de fichier généré par le serveur ?

Certains serveurs FTP prennent en charge cette fonction pour affecter des noms uniques aux fichiers entrants avant de les enregistrer sur le disque.


Que dois-je faire si les transferts par FTP avec des noms de fichiers générés par le serveur ne fonctionnent pas ?

Vérifiez que votre serveur FTP peut gérer la commande « STOU - Store Unique ». Le comportement de cette commande est similaire à celui de la commande STOR, mais le fichier de résultat doit être créé dans le répertoire en cours sous un nom unique dans ce répertoire.


Quels sont les différents modes de transfert ?

Le mode de transfert Sur demande transfère les images lorsque vous cliquez sur Transférer maintenant dans l'outil de configuration ou lorsque vous envoyez le DMCC adéquat. Si vous sélectionnez le mode de transfert FTP - Durée d'exécution, les images sont automatiquement envoyées au serveur FTP dès que la connexion devient active.

Veuillez noter que Transférer maintenant ne fonctionne pas lorsque le périphérique est hors de portée de la station de base du lecteur (en cas de périphérique sans fil), car la mémoire tampon est vidée et désactivée lorsque hors de portée.


Pourquoi le volet entier est-il désactivé lorsque je transfère des fichiers ?

Le volet est désactivé afin d'obtenir une stabilité maximale de transfert d'images vers FTP. Le transfert d'images vers FTP peut prendre plusieurs minutes selon la vitesse de la connexion au serveur FTP ainsi que de la taille et du nombre d'images transférées.


Options


Que puis-je définir sur la page Options ?

Le volet Options de l'outil de configuration DataMan permet de procéder à des paramétrages dans l'application selon vos préférences.


Que puis-je définir dans le champ Paramètres linguistiques ?

Vous pouvez choisir la langue de l'Outil de configuration ici. La valeur par défaut est Anglais.

REMARQUE : L'application doit être redémarrée pour valider les modifications.


Que puis-je définir sur la page des codes pour le champ Affichage du code ?

Ici, vous pouvez définir la manière dont la chaîne lue sera codée.


Que puis-je définir dans le champ Charte chromatique ?

Sélectionnez la charte chromatique de votre fenêtre de l'outil de configuration DataMan dans ce champ.


Que puis-je définir dans la zone Paramètres de Réinitialisation ?

Dans cette boîte, sélectionnez une catégorie (Communication, Mise en page, Messages à ne plus afficher, Journalisation des données, Périphériques exclus, Page de code, Langue, RTM Lean - Tous les paramètres, Dossiers par défaut, Périphériques virtuels, Vérification, Avertisseur sonore, Assistants) que vous souhaitez réinitialiser.


Qu'est-ce que le paramètre Emplacement de sauvegarde ?

Vous pouvez configurer ici le dossier utilisé par la fonction Sauvegarde pour l'enregistrement de fichiers de sauvegarde.


Quels paramètres sont disponibles dans l'onglet Enregistrement des données ?

Dans cet onglet, vous pouvez définir les dossiers dans lesquels les Codes de résultat, les Images décodées, les Images de non lecture et les Rapports doivent être enregistrés, ainsi que des options pour modifier les noms et extensions des fichiers lors de la saisie de données.


Comment puis-je activer la création de rapports de validation de données ?

Sélectionnez Générer des rapports de validation des données sous Journalisation dans le volet Historique des résultats.


Que puis-je définir dans le champ Mise en mémoire tampon et transfert ?

Vous pouvez définir ici le dossier où les images pourront être transférées.


Que puis-je définir dans le champ Paramètres de l'avertisseur sonore ?

Vous pouvez définir l'avertisseur de bonne lecture du PC. Lorsque l'outil de configuration reçoit un résultat de bonne lecture du lecteur DataMan, il active l'avertisseur sonore du PC. Cela peut s'avérer utile pour les lecteurs DataMan ne disposant pas d'un avertisseur interne au périphérique. Vous pouvez régler la Fréquence d'un bip de bonne lecture entre 1 000 Hz et 10 000 Hz, et la Durée entre 10 ms et 1 000 ms.


Comment peut-on activer la fonction Rapports ?

Une fois les champs de Rapports renseignés, vous devez ensuite activer la Validation des données pour générer les rapports.


Le Code de résultat, les Images décodées ou les Images de non lecture n'apparaissent pas dans le répertoire correspondant. Quel peut être le problème ?

Vous devez les activer dans les boîtes à menu déroulant à liste de journalisation correspondantes.


Vue tabulaire


Pourquoi certaines valeurs apparaissent-elles en surbrillance ?

Les valeurs en surbrillance sont des valeurs qui ne sont pas initialement par défaut. Les règles de mise en surbrillance peuvent être changées dans la section Mettre en surbrillance du menu ruban, voir la question Vue tabulaire : Menu ruban pour de plus amples informations.


Pourquoi certaines valeurs apparaissent-elles en gras ?

Les valeurs en gras peuvent être développées et contiennent des sous-valeurs.


Comment savoir quelles sont les valeurs possibles ?

Passez votre souris sur une valeur et vous verrez apparaître le texte flottant indiquant les valeurs minimum, maximum et par défaut, le cas échéant.


Vue tabulaire : Mise en page et structure générale

La Vue tabulaire est un outil de visionnage utilisant un style tabulaire.

La ligne d'en-tête affiche le nom de périphérique. La deuxième ligne d'en-tête en-dessous de la première affiche les configurations disponibles pour le périphérique. Les lignes d'en-tête en-dessous (en gras) peuvent être réduites ou développées en cliquant sur l'icône située à côté des lignes. Si le périphérique est déconnecté, une icône de reconnexion apparaît dans la ligne d'en-tête correspondante.

Les paramètres ne dépendant pas de la configuration de lecture sont seulement affichés dans la première colonne (configuration principale).


Vue tabulaire : Commandes (souris et clavier)

Sélection :

  • Souris : lors d'un clic sur une cellule dans le tableau, celle-ci est sélectionnée, ce qui met en surbrillance l'en-tête de ligne de la cellule et l'en-tête de colonne où appartiennent le périphérique et la configuration. Les boutons de menu et objets dans le menu ruban peuvent changer en fonction de la sélection. Si la cellule sélectionnée est dans la ligne d'une ligne d'en-tête, toutes les cellules dans la colonne correspondante à l'en-tête sont sélectionnées.

  • Clavier : les touches de mouvement de curseur permettent de naviguer dans la sélection jusqu'à la cellule souhaitée. Le mise en surbrillance et le comportement de sélection sont les mêmes que pour la souris.

Ajouter/modifier des valeurs :

  • Souris : pour les cellules avec éditeur intégré, un clic sur la commande d'éditeur (zone de liste modifiable, case à cocher, flèches monter/descendre pour chiffre) permettent de saisir des valeurs. Pour les cellules avec éditeur personnalisé, (l'icône « ... »), une fenêtre contextuelle s'ouvre, permettant la saisie des valeurs.

  • Clavier : pour les cellules avec éditeur intégré, le mode d'édition est démarré par la pression des touches Entrée ou F2, la touche Échap annule l'édition et une deuxième pression de la touche Entrée confirme l'édition. Les valeurs peuvent être saisies dans le texte sélectionné sans ouvrir le mode d'édition ; dans ce cas la valeur actuelle est écrasée par le premier caractère saisi.

    Pour les cellules contenant des chiffres, outre les cellules avec éditeur de texte intégré, les flèches haut et bas permettent d'augmenter et de réduire la valeur.

    Pour les cellules à menu déroulant, la touche Entrée ouvre le mode d'édition et affiche les éléments du menu déroulant, et les flèches haut et bas déplacent la sélection. Une deuxième pression sur Entrée applique la valeur sélectionnée et la touche Échap annule l'édition.

    Pour les cellules avec case à cocher, utiliser la touche Espace pour basculer entre l'état coché et non coché.

Copier et coller :

Utilisez respectivement les raccourcis clavier Ctrl+C et Ctrl+V pour copier et coller, voir la description copier-coller des éléments de menu du ruban correspondants pour plus d'informations.


Vue tabulaire : Menu ruban

Le menu ruban se trouve au-dessus du tableau de la vue tabulaire. Le contenu et les icônes activés peuvent changer en fonction des cellules, lignes ou colonnes sélectionnées dans le tableau. Le menu est divisé en plusieurs groupes.

  • Vue tabulaire : utiliser le bouton Ajouter une configuration pour ajouter ou copier des configurations de lecture au périphérique sélectionné. Supprimer configuration supprime la/les configuration(s) de lecture sélectionnée(s). Le bouton Modifier l'ordre autorise la modification de l'ordre des configurations de lecture entre lesquelles le périphérique alterne.

  • Édition : utiliser Copier (ou Ctrl+C sur le clavier) pour copier une valeur à partir de la cellule actuellement sélectionnée. Coller ne peut être utilisé que dans la même ligne ou dans un éditeur de texte quelconque. Réinitialiser les valeurs est utilisé pour réinitialiser la/les valeur(s) des cellule(s) sélectionnée(s).

  • Surbrillance : les boutons et réglages dans ce groupe de menu permettent par différents moyens de mettre en surbrillance des arrière-plans spécifiques de cellules. Avec le réglage Valeurs non par défaut, les cellules contenant des valeurs différentes des valeurs par défaut sont mises en surbrillance (ceci peut être différent dans une seule ligne pour différents périphériques ou configurations de lecture). Le paramètre Différence par rapport à la référence met en surbrillance les cellules contenant des valeurs différentes de celles de la cellule dans la même ligne de la configuration de lecture de référence (et périphérique). Le troisième paramètre est sélectionné, toutes les valeurs et tous les en-têtes contenant le texte spécifié dans la boîte de texte sont mis en surbrillance. De plus, le texte contenu lui-même est mis en surbrillance avec un autre arrière-plan de texte. Une pression sur Entrée applique également la fonction du bouton Afficher uniquement les lignes en surbrillance.

    Lorsque la fonction est activée, Afficher uniquement les lignes en surbrillance réduit tous les nœuds dont aucun sous-nœud n'est en surbrillance. Lorsque l'option est activée, la Configuration de lecture référence fixe spécifie la configuration de lecture (et le périphérique) utilisée comme référence lorsque le mode de mise en surbrillance Différence par rapport à la référence est utilisé. Lorsque le bouton est activé, la colonne de la cellule actuellement sélectionnée (configuration de lecture) devient la configuration de référence. La configuration de référence actuelle est indiquée dans la ligne d'en-tête des noms de configuration.

  • Filtrage : Paramètres globaux affiche uniquement les paramètres ne pouvant pas avoir de valeurs différentes au sein des différentes configurations de lecture. Paramétrer Paramètres de configuration de lecture pour voir uniquement les paramètres dépendants de la configuration de lecture. Paramétrer Tous les paramètres pour voir tous les paramètres simultanément. Si une entrée comporte des valeurs dans plusieurs configurations de lecture, elles sont visibles dans différentes colonnes.

  • Autres : utiliser Développer toutes les lignes pour développer toutes les lignes qui ont été réduites dans le tableau. Utiliser Réduire toutes les lignes pour réduire toutes les lignes développées du tableau. Réinitialiser la structure recalcule les largeurs de colonne pour utiliser tout l'espace disponible. Si l'espace disponible est insuffisant, une largeur de colonne minimum est appliquée.


Informations légales


Copyright

Cognex Corporation décline toute responsabilité concernant l'utilisation ou la fiabilité de son logiciel sur des matériels non fournis par Cognex Corporation. Cognex Corporation n'offre aucune garantie, expresse ou implicite, sur le logiciel décrit, son caractère commercialisable ou son adéquation à un usage particulier.

Les informations contenues dans ce document sont sujettes à modifications sans préavis et ne doivent pas être considérées comme un engagement de la part de Cognex Corporation. Cognex Corporation n'est pas responsable des erreurs qui pourraient figurer dans ce document ou dans le logiciel associé.

Copyright © 2019 Cognex Corporation. Tous droits réservés

Toute copie, totale ou partielle, ainsi que tout transfert sur un support ou dans une langue quelconque de ce document sont interdits sans l'accord écrit de Cognex Corporation.

Le matériel et les parties du logiciel décrits dans ce document peuvent être protégés par un ou plusieurs des brevets pour les États-Unis répertoriés sur le site Web de Cognex http://www.cognex.com/patents.asp. D'autres brevets, déposés aux États-Unis et à l'étranger, sont en cours d'homologation.


Logiciel sous licence

SpiderMonkey

Ce logiciel est soumis aux conditions de la licence publique Mozilla, v. 2.0 dont une copie est disponible sur http://mozilla.org/MPL/2.0/.

Pour obtenir une copie du code source de SpiderMonkey, veuillez contacter l'assistance technique de Cognex à l'adresse <spidermonkey@cognex.com>.

Licence PCRE

PCRE est une bibliothèque de fonctions conçue pour la prise en charge des expressions régulières dont la syntaxe et la sémantique sont aussi proches que possible de celles du langage Perl 5.

La version 5 de PCRE est distribuée dans le cadre de la licence « BSD », conformément aux indications ci-dessous. Les documents relatifs à la bibliothèque PCRE, figurant dans le répertoire « doc », sont distribués dans les mêmes conditions que le logiciel proprement dit.

Rédigé par : Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, Angleterre. Téléphone : +44 1223 334714.

Copyright (c) 1997-2004 Université de Cambridge. Tous droits réservés.

La redistribution et l'utilisation sous forme source et binaire, avec ou sans modification, sont autorisées aux conditions suivantes :

  • La redistribution du code source doit faire état du copyright ci-dessus, de la présente liste de conditions et de la clause de non-responsabilité suivante.
  • Les redistributions sous forme binaire doivent mentionner le copyright ci-dessus, la présente liste de conditions et la clause de non-responsabilité suivante dans les documents et/ou les autres éléments fournis avec la distribution.
  • Ni le nom de l'Université de Cambridge, ni ceux de ses collaborateurs ne peuvent être utilisés pour soutenir ou promouvoir des produits dérivés de ce logiciel sans autorisation écrite spécifique préalable.

CE LOGICIEL EST FOURNI PAR LES DÉTENTEURS DU COPYRIGHT ET LEURS COLLABORATEURS « EN L'ÉTAT », À L'EXCLUSION DE TOUTE GARANTIE EXPRESSE OU IMPLICITE, Y COMPRIS, MAIS SANS CARACTÈRE LIMITATIF, TOUTE GARANTIE IMPLICITE DE CARACTÈRE COMMERCIALISABLE ET D'ADAPTATION À UN USAGE PARTICULIER. EN AUCUN CAS, LE DÉTENTEUR DU COPYRIGHT OU SES COLLABORATEURS NE SAURAIENT ÊTRE TENUS RESPONSABLES DE DOMMAGES QUELCONQUES, QU'ILS SOIENT DIRECTS, INDIRECTS, ACCIDENTELS, SPÉCIAUX, EXEMPLAIRES OU CONSÉCUTIFS (Y COMPRIS, MAIS SANS CARACTÈRE LIMITATIF, LA FOURNITURE DE BIENS OU SERVICES DE REMPLACEMENT, PERTE D'USAGE, DONNÉES OU BÉNÉFICES, OU INTERRUPTION D'ACTIVITÉ COMMERCIALE) QUELLE QU'EN SOIT LA CAUSE ET INDÉPENDAMMENT DU TYPE DE RESPONSABILITÉ, CONTRACTUELLE, STRICTE OU DÉLICTUELLE (Y COMPRIS PAR NÉGLIGENCE OU AUTRE CAUSE) RÉSULTANT D'UNE MANIÈRE OU D'UNE AUTRE DE L'UTILISATION DE CE LOGICIEL, MÊME SI LA POSSIBILITÉ DE TELS DOMMAGES AVAIT FAIT L'OBJET D'UN AVIS PRÉALABLE.

Fin

Logiciel JPEG

Ce logiciel est partiellement fondé sur les travaux du groupe JPEG (Independent JPEG Group).

Bibliothèque de compression zlib

Ce logiciel est partiellement fondé sur les travaux de Jean-Loup Gailly et Mark Adler.

Programme d'analyse syntaxique XML Parsifal

Copyright (c) 2002-2005 Toni Uusitalo rendu public le 15-11-2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal est un logiciel libre pour l'utilisation et la redistribution commerciale et privée, à condition de mentionner le copyright et la clause de non-responsabilité de l'auteur. Vous pouvez librement modifier Parsifal pour votre usage particulier et le redistribuer avec les modifications apportées, à condition de clairement décrire celles-ci.

CLAUSE DE NON-RESPONSABILITÉ

Ce programme est distribué dans l'espoir d'être utile, mais SANS AUCUNE GARANTIE, pas même la garantie implicite de son caractère commercialisable ou d'adaptation à un usage particulier. Veuillez l'utiliser À VOS RISQUES ET PÉRILS.


Informations relatives aux brevets

Ce produit est couvert par un ou plusieurs des brevets américains, applications américaines et/ou brevets étrangers répertoriés ci-dessous. La page http://www.cognex.com/patents répertoriera les éventuels brevets significatifs émis ultérieurement

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 et EP1687752