DataMan 300: Preguntas y respuestas


Pantalla de bienvenida


Bienvenido

Para configurar su dispositivo rápidamente, se recomienda seguir los Pasos de aplicación representados por los botones grandes en el lado izquierdo. Cada sección tiene una pestaña con opciones de configuración básicas o avanzadas. El botón de acción Guardar configuración guarda los datos de configuración en el lector y guarda una copia de seguridad en su PC con un solo clic. Las preguntas siguientes describen las opciones de configuración en cada uno de los pasos de aplicación que requieren explicación.


¿Qué puedo configurar en Tipo de aplicación?

Al hacer clic en la flecha de la derecha, se pueden seleccionar los modos de lectura adecuados en el menú desplegable.


¿Qué puedo hacer en el paso Optimizar imagen?

Puede llevar a cabo el proceso de configuración, ajuste y prueba del dispositivo conectado, y puede establecer la configuración de iluminación del dispositivo.


¿Qué puedo seleccionar en Detalles de código?

Aquí puede seleccionar los símbolos que el DataMan debe leer, así como diferentes escenarios de código múltiple. Este menú también permite establecer la configuración avanzada del decodificador.


¿Qué puedo configurar en el paso Detalles de aplicación?

Aquí puede definir la configuración de disparo y de exposición. Para simplificar el proceso, un asistente para disparos, un asistente para intervalos y un asistente para la exposición le ayudarán con la configuración.

En la pestaña Avanzado, puede implementar más configuraciones en una vista de tabla.


¿Qué puedo configurar en Formatear datos?

Para crear la salida de datos deseada del dispositivo, puede utilizar expresiones regulares de formato básico o estilo Perl con el fin de generar una cadena de salida personalizada mediante módulos predefinidos, o utilizar el motor de JavaScript para crear una secuencia de comandos de formato de datos flexible.


¿Qué puedo configurar en el paso Entradas/Salidas?

En este panel, se puede configurar el comportamiento de los botones y líneas de entrada y salida. Aquí también se pueden configurar los detalles para un codificador de pulsos y la longitud de pulso de la alarma sonora. Este panel también incluye el enlace a la configuración de la imagen almacenada para enviar imágenes por FTP a un servidor.


¿Qué puedo configurar en el paso de aplicación Comunicaciones?

En las tres pestañas del paso de aplicación Comunicaciones, se puede implementar la configuración de Ethernet y serie. Haga clic en la pestaña adecuada para introducir los valores de configuración.


¿Qué hace la opción Guardar configuración?

Guardar configuración es una acción más que un paso, pero es importante realizarla. Esta acción guardará la configuración actual en la memoria persistente del lector, por lo que se cargará la misma configuración después de reiniciar. La herramienta de configuración DataMan también almacenará un archivo de copia de seguridad localmente en el PC actual en la carpeta de copia de seguridad predeterminada.


¿Qué es el archivo de backup de la configuración?

El archivo de backup de la configuración contiene todos los parámetros y configuraciones del dispositivo. Se puede utilizar para restaurar la configuración a un estado conocido o para configurar nuevos dispositivos seleccionando parámetros de configuración con propiedades de backup o sin.


Conectar al lector


¿Cómo conecto mi lector a la herramienta de configuración?

Independientemente de qué lector esté usando, siga estos pasos para conectar su lector DataMan a la herramienta de configuración:

  1. Imprima una copia del documento Códigos de configuración del lector para su lector, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.

  2. Conecte el cableado necesario entre su lector y el PC que ejecute la herramienta de configuración. Para más información, consulte su documentación impresa de referencia rápida.

  3. Haga clic en Actualizar en la herramienta de configuración.

  4. Seleccione el puerto COM o el Dispositivo de red que muestre una conexión con el lector.

  5. Haga clic en Conectar.


¿Por qué no se conecta la herramienta de configuración al lector?

Si no puede establecer una conexión, compruebe lo siguiente:

  • Asegúrese de que ha escaneado el código de configuración (USB COM o Serie RS-232) correspondiente al tipo de conexión física (no aplicable a lectores con solo Ethernet).

  • Asegúrese de que la aplicación antivirus o de firewall instalada en el ordenador admita la comunicación con dispositivos Ethernet permitiendo los puertos adecuados (Cognamer: 1069 y herramienta de configuración: 44444).

  • Asegúrese de que la lista de puertos COM muestre un puerto al que esté conectado el lector.

    DataMan series 60, 300, 370, 470, 503, 8000: si el lector se encuentra conectado a su red Ethernet, verifique que aparece en la lista de dispositivos de red.

    Haga clic en Actualizar para determinar qué puertos tienen lectores conectados.

    Nota: al hacer clic en Actualizar se envía una cadena de consulta a todos los puertos COM y por toda la subred de la red Ethernet. Debe haber activo un lector DataMan 8000 inalámbrico para responder a la consulta. Puede pulsar el disparador para activar el lector.

  • Asegúrese de que no está usando el teclado, el decodificador de teclado o la conexión HID: debe utilizar un Serie USB, un Serie RS-232, o una red Ethernet o inalámbrica para conectar la herramienta de configuración del lector.

  • DataMan series 60, 300, 370, 470, 503, 8000: asegúrese de que la dirección IP proporcionada en la opción Agregar dispositivo es correcta.

  • Solo lectores inalámbricos DataMan 8000: asegúrese de que el lector no está en modo de ahorro de energía (pulse el disparador para activarlo).

  • Solo lectores inalámbricos DataMan 8000: asegúrese de que se establezca una conexión entre el lector y la estación base conectada a su PC. Para comprobarlo, escanee el código de configuración Desconectar impreso en la guía de referencia rápida, desenchufe los cables de alimentación y comunicación de la estación base, vuelva a conectar los cables y, a continuación, vuelva a colocar la terminal en la estación base. Espere hasta que la terminal indique que está conectada (con una señal acústica) antes de intentar establecer una nueva conexión.

  • Solo lectores inalámbricos DataMan 8000: Asegúrese de que la estación base esté conectada a la fuente de alimentación.

Puede utilizar un programa de emulación de terminal como HyperTerminal para determinar si el lector está enviando datos si se encuentra conectado a un puerto COM en el PC.


¿Por qué veo un icono superpuesto en la parte superior derecha del icono de mi dispositivo?

Este icono de flecha indica que se trata de un dispositivo agregado manualmente. El icono «V» indica que el dispositivo es un dispositivo virtual.


¿Qué son los dispositivos virtuales?

El icono «V» superpuesto en la parte superior derecha del icono del dispositivo indica que el dispositivo es un dispositivo virtual. Los dispositivos virtuales pueden crearse en Reparación y asistencia a partir de un archivo de configuración personalizada o un dispositivo con configuración predeterminada. Los dispositivos virtuales pueden utilizarse para examinar distintos paneles en la herramienta de configuración sin la necesidad de conectar un dispositivo real.

El dispositivo virtual creado no es visible para los demás dispositivos de la red. El dispositivo virtual persiste durante varias instancias de la herramienta de configuración.

El dispositivo virtual creado puede conectarse del mismo modo que un dispositivo normal, pero todos los cambios de configuración son rechazados (todo es de solo lectura) y las características, funciones y acciones no funcionan en los dispositivos virtuales.


Sigo sin poder establecer una conexión con el lector o con la estación base: ¿puedo reiniciarlo?

Para la estación base DataMan 8000:

Con el lector inalámbrico asociado a su estación base, escanee el comando Restablecer los valores predeterminados de la estación base (para la base DM8000) para devolver la estación base a sus valores predeterminados de fábrica.

Para lectores DataMan de las series 503 y 8000:

Escanee el comando Reiniciar el escáner impreso al final de la guía de referencia rápida para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y se reinicia.

Si el problema persiste, escanee el comando Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.

Si continúa sin poder establecer la conexión, y está usando un lector con cable, desenchufe el lector de la corriente (este procedimiento no es posible con el dispositivo DataMan 9500). Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.

Si el problema persiste y está usando un lector inalámbrico DataMan 8000, extraiga la batería del lector y colóquelo en la estación base. Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.

Para lectores DataMan 50, 60 y 70:

Imprima una copia del documento Códigos de configuración para su lector, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.

Escanee el código Reiniciar el escáner para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y reinicia.

Si sigue sin poder conectarse al lector, escanee el código Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.

Si eso no soluciona el problema, desenchufe el lector de la corriente (alimentación CC y USB, si procede). Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.


¿Cómo sé cuál es mi dispositivo?

Para lectores DataMan 260, 300, 473, 500, 503 y 8000:

En el árbol en el que se enumeran los dispositivos, en Conectar al lector, haga clic con el botón derecho del ratón en un lector y seleccione Identificar. El indicador de estado en el lector emite una señal, lo que le permite identificarlo.


¿Por qué aparecen en verde algunos dispositivos?

Los dispositivos descubiertos recientemente aparecen en verde durante unos segundos para comunicarle que se ha añadido un nuevo dispositivo a la vista de árbol.


¿Qué es el monitor de procesos?

A medida que funciona, un lector DataMan registra estadísticas tales como el número de señales de disparo recibidas, el número de símbolos leídos (y no leídos), y el número de sobrecargas del disparador. Podrá ver o solicitar estas estadísticas usando diferentes medios. Por ejemplo, puede conectar el software de la aplicación VisionView para que controle los intentos de decodificación desde cualquier lector, o establezca una conexión mediante la interfaz de comandos de control de DataMan (DMCC) y recupere información de registro a través de una conexión de serie o de Telnet.

De forma determinada, un lector DataMan dejará de generar estadísticas sobre los intentos de decodificación cuando se encuentre conectado a la herramienta de configuración. Para reactivar las estadísticas de procesos cuando se conecte a la herramienta de configuración, deberá iniciar el monitor de procesos. Incluso si establece múltiples conexiones a un solo lector, como, por ejemplo, usando la herramienta de configuración y el software de la aplicación VisionView, el lector no registrará las estadísticas de decodificación a no ser que active el monitor de procesos.


DataMan series 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 y estación base DataMan 8000: ¿por qué solicita una contraseña la herramienta de configuración cuando quiero conectarme?

El lector y la estación base pueden configurarse para solicitar una contraseña antes de conectarse a la herramienta de configuración. La contraseña se activa en la pestaña Autenticación en la opción Configuración de red del panel Configuración de comunicación. Tenga en cuenta que la contraseña se emplea también para la conexión en serie.


DataMan 60, 300, 370, 470, 503, 8000 series y estación base DataMan 8000: ¿puedo conectar el lector a mi PC directamente mediante Ethernet?

El lector o la estación base pueden conectarse directamente a un conector Ethernet (RJ-45) en su PC. Si el dispositivo está configurado para DHCP, aparecerá en la lista de dispositivos de red aproximadamente unos 20 segundos después. Tenga en cuenta, no obstante, que su PC podría necesitar un minuto adicional para que se resuelva su dirección IP. No podrá conectar el dispositivo a través de la herramienta de configuración hasta que haya concluido esta operación.

Si su dispositivo se ha configurado para utilizar una dirección IP estática, dicho dispositivo solo aparecerá si comparte la misma subred que el PC.


DataMan series 60, 300, 370, 470, 503, 8000, MX-1000 y estación base DataMan 8000: ¿cómo hago corresponder un elemento de la lista de dispositivos de red con un lector específico?

De forma predeterminada, cada DataMan aparece en los dispositivos de red con un prefijo DM y los últimos seis caracteres de su dirección MAC, impresa en el dispositivo.


DataMan series 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 y estación base DataMan 8000: ¿qué hacer si mi lector o estación base no aparecen en la lista de dispositivos de red?

Si el lector o la estación base deseados no aparece en la lista, puede añadirlos reiniciándolos. Una vez encendidos, los dispositivos pueden tardar hasta 60 segundos en aparecer en la lista.

Si reiniciar el dispositivo no soluciona el problema, la herramienta de configuración quizás no sea capaz de comunicarse con el dispositivo debido a la configuración de red, y no aparecerá en la lista de dispositivos de red.

Compruebe la conexión Ethernet con el lector o la estación base y haga clic en Actualizar en la herramienta de configuración.

Si sabe cuál es la dirección IP del lector o de la estación base, utilice la opción Agregar dispositivo.

Este método permite que el lector o la estación base DataMan aparezca en la lista de dispositivos de red para que pueda conectarse al lector mediante la herramienta de configuración y su conexión Ethernet.


¿Cómo funciona el botón Comparar configuración?

El botón Comparar configuración inicia la función de comparación de configuraciones de la herramienta de configuración; se trata de una herramienta a estilo de vista de tabla que permite establecer, copiar, comparar o restaurar las configuraciones de los dispositivos. La función abre una nueva página de documento.

Si no se seleccionan dispositivos en la lista de dispositivos antes de pulsar el botón, se abrirá un documento vacío. Si se seleccionan uno o más dispositivos, el documento de comparación se llenará con la configuración de dichos dispositivos.


¿Qué es el dispositivo de RTM Lean o RTM que se muestra en Red?

Real Time Monitoring (RTM) Lean es una característica integrada en la herramienta de configuración DataMan y RTM es una aplicación de software compatible con el hardware accesible a través de la herramienta de configuración DataMan que permite recopilar y analizar distintos tipos de datos relacionados con los dispositivos en la red y sus lecturas. Puede conectarse a RTM Lean o RTM como si se tratase de un dispositivo y luego configurar la recopilación de datos en un documento recién abierto. RTM Lean o RTM solo recopila datos de forma activa cuando se está ejecutando y se está conectado a él.

Durante la configuración inicial, se le pedirá que elija el dispositivo que RTM Lean o RTM vaya a supervisar y luego el tipo de datos (fuera de los predeterminados) que se van a recopilar. Esto puede redefinirse en Configuración en el menú de la cinta. De forma predeterminada, RTM Lean o RTM recopila datos estadísticos (tasa de lectura, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo).

NOTA: RTM Lean puede adquirir datos de un solo dispositivo a la vez y conservar los datos durante 48 horas. La versión completa de RTM no tiene dichas limitaciones.


¿Cómo conecto mi lector a la herramienta de configuración?

Independientemente de qué lector esté usando, siga estos pasos para conectar su lector DataMan a la herramienta de configuración:

  1. Conecte el cableado necesario entre su lector y el PC que ejecute la herramienta de configuración. Para más información, consulte su documentación impresa de referencia rápida.

  2. Haga clic en Actualizar en la herramienta de configuración.

  3. Haga clic en Conectar.


Optimizar imagen


¿Qué puedo hacer en el paso Optimizar imagen?

Aquí puede realizar el proceso de configuración, ajuste y prueba de su dispositivo conectado.

Para configurar su dispositivo rápidamente, se recomienda seguir los Pasos de aplicación representados por los botones grandes en el centro, donde podrá seleccionar opciones de configuración básicas o avanzadas. El botón de acción Guardar configuración le permite guardar todos sus datos de configuración de forma simple. Las preguntas siguientes describen las opciones de configuración en cada uno de los pasos de aplicación que requieren explicación.


¿Cómo puedo guardar una imagen adquirida en un archivo?

Haga clic en el botón Guardar imagen en la barra de herramientas del panel de imágenes o del visor de imágenes.

También puede arrastrar y colocar la imagen en su PC. Haga clic en la imagen en la ventana Pantalla de imagen, arrástrela fuera de la herramienta de configuración y suéltela.

NOTA: en caso de querer guardar una imagen que no sea la más reciente mediante arrastrar y colocar (está guardándola desde el Historial de resultados de lectura), la imagen se guardará con la configuración de la imagen mostrada. De manera predeterminada, esta será de calidad reducida. En Configuración de la imagen mostrada, puede cambiar el tamaño de la imagen a completo y el formato a mapa de bits.


¿Cómo puedo utilizar el botón En vivo?

En la pestaña Básico, haga clic en el botón En vivo para pasar al modo En vivo. El modo En vivo no solo supervisa las lecturas del dispositivo, sino que también las decodifica. Al hacer clic en el extremo derecho del botón, se abren más opciones.

Marque la opción Decodificación si desea que el dispositivo decodifique las imágenes tomadas. Cuando está marcada, Información del enfoque muestra un medidor codificado por colores a la derecha de la visualización de imágenes. El medidor indica el enfoque de la lente (cuanto menor es la medición, menos enfocada está la lente).

Marque la opción Exposición automática para que el lector determine automáticamente la mejor configuración de exposición en la imagen. El control (debajo del área de visualización de imágenes) indica la intensidad de la luz deseada de los píxeles.

En la pestaña Avanzado, se puede ver una vista de tabla de la configuración de la imagen.


¿Cómo puedo utilizar el botón Ajustar?

Haga clic en el botón Ajustar en la pestaña Básico para determinar automáticamente la mejor configuración para su lectura. La ventana desplegable (haga clic en el extremo derecho del botón para abrirla) muestra Optimizar enfoque, Optimizar intensidad de la luz, Asistente para símbolos, Tipos de disparo, Aprender código, Configuración avanzada de disparo y otras funciones de ajuste.

NOTA: El tamaño mínimo de la ROI necesario para que Ajustar funcione correctamente es de 144x144 píxeles.

Las opciones de la parte superior de la ventana desplegable se describen en preguntas separadas a continuación.

Haga clic en Optimizar intensidad de la luz para establecer automáticamente la intensidad de la luz recomendada para su dispositivo (disponible solamente si se establece más abajo Exposición manual) o haga clic en el enlace situado junto al botón para ir al paso de aplicación Detalles de aplicación, donde puede establecer la intensidad de la luz manualmente y acceder a configuraciones avanzadas.

Seleccione la opción Exposición automática para que el lector determine automáticamente la mejor configuración de exposición en la imagen. El control Factor de ganancia (debajo del área de visualización de imágenes) indica la intensidad de la luz deseada de los píxeles.

Seleccione la opción Exposición manual para establecer la exposición manualmente y arrastre el control Exposición máxima hacia la izquierda o hacia la derecha para especificar una configuración precisa para la exposición de la cámara. También puede utilizar el control deslizante situado debajo del área de visualización de la imagen. La configuración Factor de ganancia máxima permite establecer la intensidad de luz máxima deseada de los píxeles.

Haga clic en Optimizar enfoque para establecer automáticamente el enfoque recomendado para su dispositivo o haga clic en el enlace situado junto al botón para ir al panel apropiado en Detalles de aplicación, donde puede establecer el enfoque de la cámara manualmente y acceder a configuraciones avanzadas. También puede optimizar el enfoque mediante el control deslizante situado debajo del campo de visualización de la imagen (con el icono de enfoque). Tenga en cuenta que solo aparece cuando se utiliza la lente líquida.

Haga clic en Aprender código para aprender o (en el caso de un código ya aprendido) desaprender códigos, o haga clic en el enlace junto al botón para acceder a configuraciones avanzadas de aprendizaje de códigos en el paso de aplicación Detalles de código.

El Asistente para símbolos es un asistente que le guía en la configuración de lectura y decodificación de los símbolos apropiados o deseados. También puede corregir manualmente la configuración de símbolos haciendo clic en el enlace situado junto al asistente para acceder al paso de aplicación Detalles de código.

Configure el lector con cualquiera de los siguientes Tipos de disparo:

  • El disparo Único adquiere una sola imagen e intenta decodificar cualquier símbolo que ésta pudiera contener. Este modo de disparo permite un tiempo de espera de lectura.

  • El disparo Presentación busca un símbolo de forma continua y lo decodifica cada vez que detecta uno.

  • El disparo Manual adquiere imágenes mientras que la señal de disparo permanece activa y se detiene cuando se encuentra y decodifica un símbolo o cuando finaliza la señal de disparo.

  • El disparo Ráfaga adquiere un número fijo de imágenes y decodifica el primer símbolo que detecta dentro del grupo. Puede configurar el número de imágenes en cada ráfaga y el intervalo entre la adquisición de cada imagen. Este modo de disparo permite un tiempo de espera de lectura.

  • El disparo Auto es similar al disparo de presentación en cuanto que el lector busca un símbolo de forma continua y lo decodifica cada vez que detecta uno.

  • El disparo Continuo adquiere imágenes mientras la señal de disparo permanece activa, tiempo durante el cual el lector adquiere las imágenes según un intervalo específico e intenta escanear cualquier símbolo que contenga cada imagen sucesiva.

Nota: No todos los tipos de disparo están disponibles para todos los dispositivos. Consulte los manuales de referencia correspondientes para obtener más información acerca de los tipos de disparo disponibles para su modelo de dispositivo.

Al hacer clic en el enlace de configuración avanzada de disparo en la parte inferior, accederá al paso Detalles de aplicación, donde dispondrá de más configuraciones.

En la pestaña Avanzado, puede configurar los valores en una vista de tabla.


¿Qué sucede si selecciono Ajustar bancos de luces?

Si establece Ajustar bancos de luces, el dispositivo ajusta los bancos de luces. Si sabe qué configuración de luz desea utilizar, desactívela para que el ajuste no la anule.


¿Qué sucede si selecciono Ajustes exhaustivos?

Seleccionar esta opción, permite forzar el ajuste de los bancos de luces. Si se desactiva Ajustes exhaustivos y el lector logra leer el código con la configuración de luz principal (la primera en la secuencia), ya no probará otras combinaciones de los bancos de luces.

Si se activa Ajustes exhaustivos, el lector seguirá probando todas las combinaciones para determinar la mejor, independiente de que la primera lectura sea correcta.


¿Qué sucede si selecciono Activar ajustes de filtro?

Si se selecciona Activar ajustes de filtro, la herramienta de configuración DataMan aplica filtros a la imagen leída. El filtro con el que se lee correctamente el código se mostrará entonces en el panel Resultados de ajustes, en Filtro de imagen.


¿Qué sucede si selecciono Optimizar enfoque durante los ajustes?

Si desea que el enfoque se optimice automáticamente durante los ajustes, marque la opción Optimizar enfoque durante los ajustes.


¿Qué sucede si selecciono Aprender código después de los ajustes?

Marque Aprender código después de los ajustes si desea asegurarse de que el dispositivo aprenda los códigos de lectura después de los ajustes. El código encontrado se mostrará en la parte inferior de la ventana de la herramienta de configuración DataMan.

NOTA: Cuando se utiliza esta función, la herramienta de configuración DataMan solo reconoce el tipo de código encontrado, por lo que no deberá utilizar ningún otro tipo de código para la lectura.


¿Qué sucede si selecciono Excluir resultados de luz ambiente?

Marque Excluir resultados de luz ambiente si no quiere que solo se seleccionen automáticamente los resultados de luz ambiente para el proceso de ajuste (que de otro modo sería el tipo de iluminación predominante para los lectores de montaje fijo).


¿Cómo puedo utilizar el botón Prueba?

Haga clic en el botón Prueba para probar su dispositivo con una configuración, sin interrumpir la producción.

Si ha seleccionado mediante el botón En vivo un tipo de disparo que sea externo (cualquier otro distinto de los modos de disparo Presentación o Auto), puede disparar el lector automáticamente en el modo de Prueba. Puede disparar el lector automáticamente en el modo de prueba mediante los tiempos Disparo ACTIVADO y Disparo DESACTIVADO. Para su comodidad, puede ver la frecuencia de disparo calculada.

Puede reducir los tiempos Disparo ACTIVADO o Disparo DESACTIVADO para reducir el ciclo de tiempo y, por consiguiente, aumentar la frecuencia de disparo.

NOTA: En función de la configuración de lectura, el código que desee leer y la interfaz de conexión, puede haber limitaciones de velocidad y, a velocidades más altas, puede ayudar desactivar la transferencia de imágenes.

Algunos casos de uso típicos:

  • Disparo ACTIVADO = 20 ms, Disparo DESACTIVADO = 1980 ms -> Frecuencia = 0,5 Hz (predeterminado)
  • Disparo ACTIVADO = 20 ms, Disparo DESACTIVADO = 980 ms -> Frecuencia = 1 Hz
  • Disparo ACTIVADO = 20 ms, Disparo DESACTIVADO = 480 ms -> Frecuencia = 2 Hz
  • Disparo ACTIVADO = 20 ms, Disparo DESACTIVADO = 180 ms -> Frecuencia = 5 Hz
  • Disparo ACTIVADO = 20 ms, Disparo DESACTIVADO = 80 ms -> Frecuencia = 10 Hz
  • Disparo ACTIVADO = 20 ms, Disparo DESACTIVADO = 30 ms -> Frecuencia = 20 Hz


¿Para qué se utiliza el panel Rendimiento de lectura?

Los gráficos del panel Rendimiento de lectura, situado a la derecha, le permiten supervisar los tiempos de decodificación y las tasas de lectura en tiempo real. Haga clic en el botón Borrar para restablecer el gráfico.


¿Cómo sé cuándo han finalizado los ajustes?

Mientras que los ajustes estén llevándose a cabo, el botón Ajustar cambia a Cancelar. Cuando los ajustes han finalizado, el botón vuelve a cambiar a Ajustar. También verá una imagen actualizada de la parte frontal del lector que muestra la mejor iluminación posible con los LED rojos.

También puede supervisar el proceso de ajuste en el panel Resultados de ajustes, situado a la derecha. El proceso de ajuste cuenta con una barra de progreso en la parte inferior derecha que indica el estado de los ajustes en tiempo real.


¿Cómo ajusto la exposición de la imagen?

Haga clic en Ajustar para seleccionar automáticamente la mejor configuración para su lectura. Si desea seguir afinando los ajustes, haga clic en la parte derecha del botón Ajustar para acceder a configuraciones avanzadas o vaya al panel Ajustes.

Haga clic en Optimizar intensidad de la luz para configurar automáticamente la intensidad de luz recomendada. Esta función está disponible si se selecciona el control Exposición manual. Para activar Exposición manual o acceder a más configuraciones, haga clic en el botón que hay junto al botón Optimizar intensidad de la luz. Como alternativa, arrastre el control de Exposición situado bajo la imagen hacia la izquierda o hacia la derecha, o escriba un valor para la exposición. Para acceder a más configuraciones, haga clic en el icono que hay junto al cuadro de texto de la derecha.

NOTA: Optimizar intensidad de la luz y Ajustar no funcionan si una de las dimensiones de la RoI es más pequeña que 144.


¿Cómo ajusto el enfoque de la imagen?

Haga clic en Ajustar para seleccionar automáticamente la mejor configuración para su lectura. Esto inicia la función Optimizar enfoque, en caso de estar disponible, junto a las funciones Optimizar intensidad de la luz y Aprender código.

Haga clic en Optimizar enfoque para establecer el mejor enfoque posible. Esta función solo está disponible para lectores con lente líquida. Para acceder a más configuraciones, haga clic en el enlace junto al botón Optimizar enfoque. Como alternativa, puede arrastrar el control Enfoque situado debajo de la imagen o escribir un valor para el enfoque: el valor puede proporcionarse en dioptrías o milímetros (distancia). También puede utilizar los botones «+» y «-» para cambiar los valores, pero tenga en cuenta que «+» disminuye el valor de las dioptrías y «-» lo incrementa. La distancia no es aplicable a la región naranja (por encima de 500 milímetros) del control deslizante, por lo que la herramienta de configuración desactiva automáticamente la distancia al mover el control a esa región. Si se establece el control o el valor fuera de la región naranja, se reactiva la distancia. Para acceder a más configuraciones, haga clic en el enlace Configuración avanzada de enfoque para ir al panel Configuración del enfoque.

También puede cambiar las configuraciones de Valor de enfoque mientras experimenta con la visualización en vivo.


¿Cómo puedo encender o apagar rápidamente las luces del lector?

Haga clic con el botón derecho del ratón en la imagen que muestra los cuadrantes de luz. Puede seleccionar las siguientes opciones:

  • Todo activado

  • Todo desactivado

  • Norte-Sur

  • Este-Oeste

Los cambios serán efectivos de inmediato, de acuerdo con su selección.


¿Qué es Diagnóstico de símbolos (se necesita clave de funciones)?

Diagnóstico de símbolos es una función que proporciona información gráfica proveniente del dispositivo para los códigos de barras no leídos. Examinar dicha información le permitirá determinar por qué no se ha decodificado un código de barras. La información proporcionada puede señalar los problemas siguientes (en una región del código de barras):

  • No se ha encontrado el patrón inicial o final (flecha naranja en el código). No se pudo decodificar la región indicada por la fecha. Las causas del fallo pueden ser las siguientes (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso):

    • El patrón inicial o final está cortado/dañado.

    • El código está cortado (debido a los límites de la imagen o por un objeto que tapa el código).

    • Degradación de la calidad de la imagen (a menudo, pero no siempre, debido a la calidad de la luz).

    • Etiquetas de códigos de barras deformadas o dobladas.

  • Daños o error de impresión en el propio código (región del rectángulo rojo en el código). La región interior del rectángulo es donde se encuentra el daño o el problema de impresión. Ejemplos habituales de problemas de impresión (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso):

    • Goteo de tinta que une varias barras en una.

    • Fallo de impresión de una barra que reduce su grosor por debajo de la tolerancia de decodificación.

  • La zona de silencio no es suficiente (región del rectángulo magenta en el código). Un incumplimiento de la zona de silencio se produce cuando no hay espacio suficiente a uno o ambos lados del código de barras. En función de los símbolos, los lectores toleran cierto incumplimiento de la zona de silencio. El incumplimiento de la zona de silencio suele deberse a que el texto o el rectángulo alrededor del código de barras está demasiado cerca del código de barras en uno o ambos lados o a que el código quedó cortado por los límites de la imagen (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso).

  • Error en la verificación de la suma de comprobación (rectángulo azul alrededor del código). Causas habituales del fallo de validación de la suma de comprobación (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso):

    • Código de barras dañado (los códigos de barras pueden estar doblados o alineados de manera que se decodifiquen todos los caracteres de los datos pero siga tratándose de una no lectura, porque la verificación de la suma de comprobación no es correcta).

    • Impresión de un patrón incorrecto (la cadena codificada y el patrón de código de barras impreso no coinciden, y si los símbolos admiten la suma de comprobación, el decodificador puede indicar dicho fallo).

Además del diagnóstico gráfico, Diagnóstico de símbolos ofrece mediciones de legibilidad para cada resultado no leído en la parte superior izquierda de los códigos no leídos. Las mediciones pueden ayudarle a evaluar la calidad de impresión o de la imagen, así como a mejorar la configuración ya existente.

Diagnóstico de símbolos solo está disponible para imágenes PNG cargadas (Acciones>Imágenes>Cargar imagen) que hayan sido firmadas por un lector de Cognex (no necesariamente el mismo lector; las imágenes se firman automáticamente cuando se guardan desde cualquier lector). Después de cargar una imagen, compruebe la información de Diagnóstico de símbolos en la ventana de imágenes Panel de imágenes o Configuración rápida.

Además del diagnóstico gráfico, el Diagnóstico de símbolos ofrece mediciones de legibilidad para cada resultado no leído. Mediciones como Contraste de símbolo y Contraste de borde mínimo pueden ayudar a los usuarios a evaluar la calidad de impresión o de la imagen, así como a mejorar la configuración ya existente. Las mediciones se muestran en la parte superior izquierda de cada código de barras no leído.

La tabla inferior muestra la correspondencia entre el nombre de medición mostrado y su nombre completo. Consulte las mediciones de legibilidad para entender qué mide cada medición.

Nombre completo | Nombre mostrado | Posibles calificaciones
Contraste de símbolo | C | A,B,C,D,F
Contraste de borde mínimo | EC | A,F
Cambio de tamaño de impresión | PG | A,F
Reflectancia mínima | MR | A,F

Nota: Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


¿Qué es Configuración de la imagen mostrada?

La configuración de la imagen mostrada controla el modo en el que el lector muestra las imágenes que adquiere como respuesta a las entradas del disparo de adquisición así como las imágenes en directo tomadas por cualquier lector. La modificación de esta configuración no afecta al rendimiento del lector, solo a la calidad de la imagen y a la velocidad de transferencia entre el lector y la herramienta de configuración.

NOTA: algunas propiedades relacionadas con las imágenes (p. ej. tamaño de imagen, filtrado) no pueden modificarse cuando el dispositivo está adquiriendo o decodificando imágenes.

NOTA: configuración de la imagen mostrada no tiene efecto cuando se guarda la última imagen tomada del Panel de imágenes (arrastrando y soltando). La última imagen siempre se guarda a tamaño completo (la máxima resolución del dispositivo).

  • tamaño: de forma predeterminada, la herramienta de configuración muestra todos los píxeles de la imagen adquirida, o una fracción de cada imagen durante una visualización en vivo. La elección entre diferentes tamaños de imagen permite al lector realizar un submuestreo de cada imagen, lo que puede mejorar considerablemente la velocidad de transferencia de la imagen del lector a la herramienta de configuración a costa de algunos detalles de imagen precisos.

  • formato: De forma predeterminada, el lector almacena cada imagen adquirida en un formato .jpeg, que precisa menos memoria y puede transferirse del lector a la herramienta de configuración más rápido que una imagen en formato .bmp

  • calidad: Disponible únicamente si se utiliza el formato de imagen .jpeg, este control ajusta los parámetros internos que permiten al lector realizar una operación de suavizado en la imagen adquirida, que puede reducir o mejorar la velocidad de transferencia del lector a la herramienta de configuración.


¿Qué opciones puedo establecer con Imagen a usar?

Seleccione Original o Filtrada, dependiendo de qué imagen quiera ver durante la visualización en vivo. Vaya al panel Filtrado de imagen para acceder a más configuraciones.

NOTA: esta opción no existe en DM262.


¿Cómo cambio la intensidad de los LED de iluminación rojos?

En el cuadro de grupo Iluminación, utilice el control Intensidad para cambiar la intensidad de los LED de iluminación rojos que el lector utiliza para iluminar el símbolo inspeccionado.

También puede hacer clic en los grupos de LED en la imagen que se muestra en Configuración de la luz.

Tenga en cuenta que no todas las plataformas y configuraciones de luz admiten Control de intensidad. Consulte las configuraciones admitidas en la tabla inferior:

Plataforma | Control de intensidad | Segmento o LED individual encendido/apagado | Comentario
DM150 | No | Sí | Varios colores de LED
DM260 | No | Sí | Varios colores de LED
DM300 | Sí | No | Varios colores de LED
DM300 con HPIL | Sí | Sí |


¿Por qué está desactivada la casilla Luces de alta frecuencia?

Tiene que apagar la iluminación interna para activar las luces de alta frecuencia. Para apagar la iluminación interna, haga clic con el botón derecho del ratón en la imagen del lector en el grupo Configuración de la luz y hacer clic en Todo desactivado.


¿Para que se utiliza la opción «Siempre conectado» activado en el recuadro Luces de alta frecuencia?

Si se apaga la iluminación interna y por consiguiente se activan las Luces de alta frecuencia, puede establecer aquí el tiempo de espera que debe transcurrir para que se apaguen las Luces de alta frecuencia (HFL) si no se produce ningún disparo durante un largo periodo de tiempo. El tiempo de espera se especifica en segundos. Si se establece el valor del tiempo de espera en 0, se desactiva el controlador del tiempo de espera y la luz permanece encendida permanentemente. Si se cambia el modo de operación o se activa la visualización de imágenes en vivo, se apagarán las HLF.


¿Cómo utilizo una fuente de luz externa?

En el panel Configuración de luz y generador de imágenes, seleccione Externo para el tipo de iluminación.

Para utilizar una luz externa, conéctela a la línea de salida seleccionada del modo descrito en la guía de referencia rápida.

  • La línea de salida debe estar conectada como sumidero de corriente.

  • La salida común debe ser la masa lógica.

  • La corriente máxima es 50 mA @ 24 VCC.


¿Qué sucederá si uso una fuente de luz externa junto a una estroboscópica conectada a una de las líneas de salida?

Las señales de salida estroboscópica aparecen antes de la salida de iluminación dedicada. La salida de la fuente de luz externa aparecerá con retraso. Durante la adquisición de las imágenes, ambas iluminaciones estarán conectadas.


¿A qué se aplica el Tiempo de precarga?

Este valor se aplica al conector de iluminación dedicada y a E/S discretos configurados en el panel Configuración del sistema.


¿Cuáles son las diferentes opciones de iluminación externa para el Tiempo de precarga?

  • Cognex External: Luces externas Cognex

  • Cognex HPIA: Accesorios de iluminación de alta potencia Cognex

  • Luces de barra SVL: Luces Smart Vision YL, ODL y L Series

  • Luces CCS: Luces CCS estándar

  • Luz personalizada: cualquier otro tipo de iluminación externa


¿Para qué se utiliza la configuración Filtro de cubierta frontal?

Puede seleccionar en el cuadro desplegable el tipo de cubierta para lente que esté utilizando.


¿Cómo especifico una región de interés en cada imagen adquirida?

Cambiando la configuración en el subpanel Tamaño de imagen (Región de interés).


He marcado la casilla «Transferir y mostrar imágenes». ¿Por qué no veo ninguna imagen?

Si interrumpe la transferencia de una imagen iniciando un disparo, no se transferirá ninguna imagen. Asimismo, los resultados antiguos en la cuadrícula Historial de resultados de lectura podrían no contener imágenes.

Si el retraso de salida es más corto de lo que necesita el lector para adquirir y decodificar una imagen para obtener resultados, la herramienta de configuración puede no recibir imágenes de resultados del lector.


¿Cuándo debo utilizar el botón Aprender código?

De forma predeterminada, el lector intentará decodificar un símbolo utilizando todos los conjuntos de símbolos activados en el panel Configuración de símbolos. El botón Aprender código, que únicamente está activado para los modos de disparo Único, Ráfaga, Continuo y Auto, adquiere y decodifica una imagen nueva aprendiendo los atributos del símbolo en la imagen. El aprendizaje del lector de los símbolos esperados puede disminuir el tiempo necesario para decodificar símbolos sucesivos, ya que el lector no tiene que buscar en los conjuntos de símbolos activados.

Si los símbolos que desea decodificar tienen una simbología consistente, utilice la función Aprender código. Sin embargo, tenga en cuenta que el lector no podrá decodificar un símbolo si aparece en un conjunto de símbolos distinto al que ha aprendido a utilizar. Haga clic en el botón Desaprender código para desactivar el parámetro de aprendizaje y permitir al lector buscar el siguiente símbolo en todos los conjuntos de símbolos activados.

Para enseñar a su lector a decodificar múltiples códigos en una imagen única, consulte la pregunta «¿Cómo puedo llevar a cabo un aprendizaje cuando quiero decodificar varios símbolos?» en la sección Configuración de símbolos para obtener más información.


¿Por qué no se decodifica un código de la misma simbología y tamaño de modelo que el código aprendido?

Asegúrese de que el código aprendido no difiere del código que quiere decodificar en más de un 10% de su tamaño.


¿Qué es la visualización en vivo?

Si activa Visualización en vivo activada (haciendo clic en el icono Visualización en vivo en la barra de tareas superior o en la pestaña Acción), la visualización de imagen muestra constantemente lo que está en el campo de visión del lector. Puede utilizar este modo para verificar lo que está viendo el lector sin intentar decodificar los símbolos.

Para cambiar el tamaño y la calidad de la imagen que se muestra en directo, vaya al panel Configuración de la imagen mostrada.

NOTA: está opción no está disponible en DM262 y DM362.


¿Cómo puedo aumentar la velocidad de transferencia de imágenes?

Si la casilla Transferir y mostrar imagen está marcada, la herramienta de configuración transfiere la imagen adquirida para cada operación de decodificación. Si se recibe una nueva señal de disparo durante la transferencia de la imagen actual, el lector descartará la imagen parcialmente transferida e iniciará la transferencia de la nueva imagen.

La velocidad de transferencia de la imagen depende de la cantidad de compresión de la imagen que aplica el lector. Puede controlar el valor de compresión de la imagen seleccionando la opción Configuración de la imagen mostrada. Al disminuir el tamaño o la calidad de la imagen, aumentará la velocidad de transferencia.


¿Cómo puedo visualizar todas las imágenes recogidas durante un disparo de ráfaga?

Para visualizar todas las imágenes recogidas durante un disparo de ráfaga:

  1. Asegúrese de que el tipo de disparo está establecido como Ráfaga.
  2. Marque la casilla Transferir todas las imágenes.

El panel Historial de resultados contendrá las imágenes capturadas durante el disparo de ráfaga. Para visualizar la cinta de imágenes, deberá hacer clic en el resultado de la cuadrícula Historial de resultados de lectura.

El número de imágenes corresponderá al conjunto Longitud de ráfaga en el panel de Configuración de luz y de generador de imágenes.

Nota: Si el retraso de salida es más corto de lo que necesita el lector para adquirir y decodificar una imagen para obtener resultados, la herramienta de configuración puede no recibir imágenes de resultados del lector.


¿Qué hace la opción Transferir todas imágenes?

Seleccione Transferir todas las imágenes para visualizar todas las imágenes de ráfagas asociadas a cada disparo.

Cuando lo haya seleccionado, se podrá acceder a todas las imágenes adquiridas en el modo de ráfagas desde el panel de Historial de resultados, independientemente de si alguna imagen contiene un resultado decodificado o no.

Esta opción solo está disponible si selecciona Ráfaga para el tipo de disparo en el panel Configuración de luz y generador de imágenes.

Nota: Si el retraso de salida es más corto de lo que necesita el lector para adquirir y decodificar una imagen para obtener resultados, la herramienta de configuración puede no recibir imágenes de resultados del lector.


¿Cómo puedo hacer que el lector esté enfocado?

Marque la opción Información del enfoque y haga clic en Visualización en vivo. A medida que mueva el lector, verá una columna que muestra el valor de enfoque. La columna será roja, amarilla o verde, dependiendo de la nitidez del enfoque. Cuando la columna se muestra de color verde, el código está enfocado y podrá decodificar su imagen (después de detener la visualización en vivo).

Asegúrese de que la visualización en vivo utiliza la imagen original y no la filtrada.

NOTA: esta función no es compatible con DM262.


He utilizado la información del enfoque en un código Data Matrix, pero el enfoque solo es nítido cuando me acerco demasiado. ¿Qué puedo hacer?

Primero, asegúrese de que tiene activada la simbología Data Matrix. Después, vaya a Ajustes y haga clic en Ajustar. Se elegirán los mejores parámetros y podrá decodificar su imagen.


Detalles de código


¿Cómo puedo desactivar todos los símbolos con rapidez?

Haga clic en Desactivar todas las simbologías en la parte superior de la pestaña Básico en el paso de aplicación Detalles de código o pulse Ctrl+D.


¿Por qué están desactivadas todas las casillas de símbolos?

Puede someter el lector al aprendizaje de los símbolos esperados para símbolos sucesivos. Si el lector ha sido sometido a un proceso de aprendizaje, no puede cambiar qué símbolos están activados o desactivados. Debe someter el lector a una operación de desaprendizaje para activar y desactivar varios símbolos.


¿Cómo puedo ajustar la configuración de símbolos avanzada?

Haga clic en la pestaña Avanzado en Detalles de código para especificar más configuraciones.


¿Discrimina el lector automáticamente distintos tipos de símbolos?

El lector detecta, identifica y decodifica automáticamente símbolos codificados utilizando cualquiera de los símbolos activados en la herramienta de configuración.


¿Por qué no puedo cambiar de símbolos? ¿Por qué están marcadas en gris todas las opciones?

Solo puede activar y desactivar los símbolos en los modos de disparo Manual y Presentación.


¿Qué mediciones son compatibles con los símbolos individuales?

En la siguiente tabla se indica qué mediciones son compatibles con qué símbolos.

Medición | DataMatrix ISO/IEC 15415 | DataMatrix AIM-DPM | QR | PDF417 | Código 128, UPC/EAN, Código 93, Código 39, I2/5, Codabar, MSI
symbolContrast | x | x | x |  | x
UEC | x | x | x | x |
axialNonUniformity | x | x | x |  |
printGrowth | x | x | x |  | x
modulation | x | x |  |  |
fixedPatternDamage | x | x |  |  |
gridNonUniformity | x | x |  |  |
extremeReflectance | x | x |  |  |
reflectMin |  |  |  |  | x
edgeContrastMin |  |  |  |  | x
singleScanInt |  |  |  |  | x
multiScanInt |  |  |  |  | x


¿Es posible que el rendimiento del lector mejore si se limita el número de símbolos activados?

Para mejorar el rendimiento, active únicamente los tipos de símbolos con los que espera encontrarse.


Tipos de uso desactivado en Propiedades de Data Matrix

Los Tipos de uso de IDMax se desactivan a menos que seleccione el algoritmo ID Max del panel Configuración de símbolos.

Los Tipos de uso de IDQuick se desactivan a menos que seleccione el algoritmo ID Quick del panel Configuración de símbolos.

Tipos de uso IDQuick

Muchas aplicaciones pueden usar la configuración Velocidad preferida para lograr los tiempos de decodificación más rápidos posibles. Elija Rendimiento preferido cuando los símbolos que quiera decodificar puedan aparecer deformados, distorsionados o dentro de un fondo no uniforme. Extendido es la opción pensada para la lectura de códigos 2-D de marcaje directo de piezas de alta calidad (DPM) 2-D que incluye símbolos de matriz de puntos.


Deformación de impresión en Propiedades de Data Matrix

Deformación de impresión permite a su lector aceptar el código a pesar de que este último esté deformado de algún modo. Use Moderado (predeterminado) si tiene que leer códigos impresos de forma irregular o si hay una deformación cilíndrica de códigos de etiqueta continuos.


Daño de símbolo en Propiedades de Data Matrix

Daño de símbolo permite a su lector aceptar el código a pesar de que este último esté dañado de algún modo. Use Moderado (predeterminado) si tiene que leer códigos impresos que estén sujetos a un desgaste normal; use Extremo para activar PowerGrid (TM), un gran adelanto en tecnología de lectura DPM Data Matrix, si hay un daño significativo en los patrones fijados del código debido a oclusión o desgaste.

NOTA: La activación de PowerGrid (TM) mediante el establecimiento de la configuración Extremo requiere la compra de la clave de funciones correspondiente.


Ignorar polaridad - Propiedades de Data Matrix

Ignorar polaridad - Propiedades de Data Matrix

Si está marcada, su dispositivo en estado aprendido podrá leer códigos con polaridad opuesta a la del código usado para el aprendizaje.

Cuando esté marcada, su dispositivo en estado aprendido puede leer códigos con tamaño de cuadrícula ligeramente diferente (+/- un nivel) al del código usado para el aprendizaje. Es decir, si ha aprendido un código Data Matrix 12x12, por ejemplo, con un tamaño de cuadrícula flexible, podrá decodificar también los códigos de tamaño 10x10 o 14x14.


¿Cuáles son las distintas configuraciones para las propiedades EAN.UCC Compuesto?

  • Estándar (lineal y 2D): consta de un componente lineal (que codifica la identificación primaria del elemento) asociado a un componente compuesto 2D adyacente (que codifica datos adicionales, como el número de lote o la fecha de caducidad).

  • Solo lineal: consta únicamente del componente lineal que codifica la identificación primaria del elemento.


¿Qué es el CC-C?

CC-C es uno de los tres componentes del compuesto EAN.UCC 2D, específicamente un símbolo PDF417 con una palabra en clave de 920 en la primera posición de palabra como señal de enlace, y denotando la compresión de datos EAN.UCC.


Propiedades de Data Matrix: Solo lectores modelo DataMan X

Medición control de procesos

Una vez haya activado uno de los grupos de medición de control de procesos en el panel Propiedades de Data Matrix, podrá usarla en la pestaña Mediciones del panel Formato estándar.

También se puede acceder a las mediciones a través de las secuencias de comandos. Si no ha activado la medición de control de procesos, el resultado mostrado será -1.

La medición de control de procesos es -1 o NA

Cuando la calidad de impresión o imagen del símbolo es tan baja que la medición de control de procesos no se puede calificar con un algoritmo de decodificación de referencia, la medición proporcionada será -1 o NA. Mejore la calidad de impresión usando, por ejemplo, la función Filtrado de imagen.


¿Qué son las mediciones de calidad DataMatrix?

Para obtener información sobre las mediciones de calidad de los códigos, consulte la Guía de comunicaciones y programación del dispositivo DataMan®.


Propiedades de los símbolos 1D

Zona de silencio corta

La opción Zona de silencio corta, cuando está seleccionada, permite cierta indulgencia en la búsqueda respecto a la zona de silencio de los siguientes símbolos 1-D: Código 128, Código 39 y Código 93.

Códigos cortos

Seleccionar la opción Códigos cortos mejora el rendimiento de decodificación de símbolos excepcionalmente cortos y anchos.

Cambiar la orientación

La orientación está fijada en Omnidireccional de manera predeterminada en los lectores DM300X, DM500QL, DM500X, DM503QL y DM503X.

La orientación está fijada en Picket Fence (tal y como se muestra más abajo) de manera predeterminada en los lectores DM300L, DM500L y DM503L.

Orientación de los códigos desactivada

Orientación de los códigos está desactivada si el código 1D ha sido aprendido con la función Aprender orientación.

Medición de control de procesos/de calidad de los códigos para el formato de datos

Una vez haya activado las mediciones de calidad 1D en el panel Calidad de los códigos (se necesita clave de funciones), podrá usarlas en la pestaña Mediciones del panel Formato estándar.

También se puede acceder a las mediciones a través de las secuencias de comandos. Si no ha activado la medición de control de procesos (PCM), el resultado mostrado será -1.

La medición de control de procesos/de calidad de los códigos es -1 o NA

Cuando la calidad de impresión o imagen del símbolo es tan baja que la medición de control de procesos no se puede calificar con un algoritmo de decodificación de referencia, la medición proporcionada será -1 o NA. Mejore la calidad de impresión usando, por ejemplo, la función Filtrado de imagen.

Esto significa que sus códigos deben estar alineados con esta orientación para que sean decodificados.

Cambie esta orientación a Escalera (tal y como se muestra más abajo) si sus códigos son perpendiculares al sensor.

Esto significa que sus códigos deben estar alineados con esta orientación para que sean decodificados.

Cambie esta orientación a Picket Fence y escalera si sus códigos están alineados con la orientación de picket fence o perpendiculares al sensor.

Tenga en cuenta que los lectores DM300L, DM500L y DM503L solo admiten orientaciones de Escalera y Picket Fence.

Unión de datos 1D

Unión de datos mejora la eficacia de la lectura fusionando y expandiendo las lecturas parciales. La función solo está activa si la clave de funciones 1DDataStitching está instalada.

Tipos de uso

La estrategia Extendida puede decodificar códigos de barras difíciles, pero precisa más tiempo que la estrategia Estándar.


Propiedades de los símbolos 1D: ¿Qué diferencia hay entre los tipos de uso?

La estrategia Extendida puede decodificar códigos de barras difíciles, pero precisa más tiempo que la estrategia Estándar.


Propiedades de los símbolos 1D: ¿Qué valores debería configurar para Decodificaciones mínimas antes de salida?

Establezca un número alto para aumentar la solidez de la decodificación. Establezca un número bajo si su prioridad es la velocidad de rendimiento.


Ventaja de especificar un tamaño de código

Si se especifica un tamaño de código explícito, puede mejorar la capacidad del lector para decodificar símbolos con fiabilidad. Seleccione Cualquiera si va a leer distintos tamaños de código.


Propiedades del código 39

  • ASCII completo activa los códigos extendidos del código 39.

  • Carácter de control solo decodifica símbolos con un carácter de control válido.

  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.

  • Convertir a código 32 si se marca, convierte el conjunto de caracteres de código 39 a código 32.


Propiedades de intercalados 2 de 5

  • Carácter de control solo decodifica símbolos con un carácter de control válido.

  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.


Propiedades del código 25

  • Carácter de control solo decodifica símbolos con un carácter de control válido.

  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.


Propiedades de Pharmacode

Ventaja de especificar un tamaño de código y una orientación

Si se especifican un tamaño de código y una orientación explícitos, puede mejorar la capacidad del lector para decodificar símbolos con fiabilidad.

El número de caracteres de datos y el número de barras en cualquier símbolo

Caracteres de datos: barras

  • 1: 3 Nota: el único código de 1 carácter que leerá el lector será aquél que tenga 3 barras o más. Es decir, solo 6, 7, 8 y 9.

  • 2: 3 a 6

  • 3: 6 a 9

  • 4: 9 a 13

  • 5: 13 a 16

  • 6: 16


Propiedades de Codabar

  • Carácter de control solo decodifica símbolos con un carácter de control válido.
  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.
  • Transmitir caracteres de inicio y de fin incluye los caracteres de inicio y de fin con los datos de decodificación.


Propiedades de MSI

  • Carácter de control solo decodifica símbolos con un carácter de control válido.
  • Transmitir carácter de control incluye el carácter de control con los datos de decodificación.
  • Método de cálculo de suma de comprobación le permite seleccionar el método utilizado para calcular la suma de comprobación.


Propiedades de DataBar

  • GS1 DataBar limitado: codifica una identificación de elemento EAN.UCC de 14 dígitos con dígitos indicadores de cero o uno en un símbolo lineal para uso en elementos pequeños que no se escanearán en el punto de venta

  • GS1 DataBar: codifica la identificación de elemento EAN.UCC de 14 dígitos completa en un símbolo lineal que puede ser escaneado en cualquier dirección por escáneres en el punto de venta adecuadamente programados.

  • GS1 DataBar ampliado: distancia variable, versión expandida de los símbolos capaz de codificar el GTIN de 14 dígitos y datos adicionales que incluyen las fechas de caducidad, el país de origen y los números de serie; hasta 74 caracteres numéricos o 41 alfabéticos.


Propiedades de código postal

  • POSTNET: un conjunto de símbolos de código de barras que utiliza el Servicio Postal de los Estados Unidos para gestionar el envío de correo. El código ZIP o código ZIP+4 está codificado en este conjunto de símbolos único que codifica datos en barras de distintas alturas.

  • PLANET: el código PLANET (Postal Alpha Numeric Encoding Technique o técnica de codificación postal alfanumérica) es un código de barras utilizado por el Servicio Postal de los Estados Unidos para identificar y realizar un seguimiento del correo durante la entrega. Al igual que POSTNET, codifica datos en barras de distintas alturas.

NOTA: los códigos postales solo pueden decodificarse si se presentan con barras en vertical («picket fence»).


Versiones de código de respuesta rápida (QR) admitidas

El código QR (Quick Response, Respuesta rápida) es un conjunto de símbolos 2-D con una matriz cuadrada de módulos oscuros y blancos utilizados para codificar datos. El lector puede discernir entre tres tipos distintos:

  • modelo-1: versión original

  • modelo-2: versión mejorada

  • Código Micro QR: un código QR muy pequeño para aplicaciones que precisan menos espacio y utilizan menos cantidad de datos que otras versiones del código QR.


Propiedades del código QR

Ignorar polaridad

Si está marcada, su dispositivo en estado aprendido podrá leer códigos con polaridad opuesta a la del código usado para el aprendizaje.

Tamaño de cuadrícula flexible

Cuando esté marcada, su dispositivo en estado aprendido puede leer códigos con tamaño de cuadrícula ligeramente diferente (+/- un nivel) al del código usado para el aprendizaje. Es decir, si ha aprendido un código QR 25x25, por ejemplo, con un tamaño de cuadrícula flexible, podrá decodificar también los códigos de tamaño 21x21 o 29x29.

Tamaño máximo de cuadrícula

Tamaño máximo de cuadrícula permite decodificar códigos QR con un tamaño superior a 49. Puede arrastrar el control o escribir un tamaño de código específico en el cuadro de texto de la derecha.

Mediciones de calidad de los códigos QR

Para obtener información sobre las mediciones de calidad de los códigos, consulte la Guía de comunicaciones y programación del dispositivo DataMan®.


Propiedades del código QR: Solo lectores modelo DataMan X

Medición de control de procesos para el formato de datos

Una vez haya activado las mediciones QR en el panel Propiedades del código QR, podrá usarlas en la pestaña Mediciones del panel Formato estándar.

También se puede acceder a las mediciones a través de las secuencias de comandos. Si no ha activado la medición de control de procesos, el resultado mostrado será -1.

La medición de control de procesos es -1 o NA

Cuando la calidad de impresión o imagen del símbolo es tan baja que la medición de control de procesos no se puede calificar con un algoritmo de decodificación de referencia, la medición proporcionada será -1 o NA. Mejore la calidad de impresión usando, por ejemplo, la función Filtrado de imagen.


Propiedades de DotCode

Especificar el número de filas y columnas de datos

Especificar el número mínimo y máximo de filas y columnas de datos puede mejorar la capacidad del lector de decodificar símbolos con fiabilidad.

Configuración Polaridad

Puede establecer qué define el dispositivo como un módulo (punto) en relación con el fondo. La configuración Oscuro sobre claro implica que el dispositivo busca y decodifica puntos oscuros sobre un fondo claro, mientras que Claro sobre oscuro es lo contrario (puntos claros sobre un fondo oscuro).

La configuración predeterminada Cualquiera busca ambos tipos de módulos en su fondo respectivo, pero esto puede traducirse en decodificaciones ligeramente más lentas.


¿Cuál es la diferencia entre los algoritmos ID Max e ID Quick?

ID Quick ofrece decodificación de alta velocidad de símbolos que están bien formados y tienen un alto contraste, mientras que ID Max utiliza técnicas de análisis y procesamiento de imágenes avanzadas para garantizar el mejor resultado con códigos DPM generados por láser, marcado de puntos, ECE y tecnologías de inyección de tinta.


¿Cómo puedo activar los resultados de código múltiple?

Código múltiple puede establecerse para todos los tipos de disparo, pero solo ofrecerá resultados de código múltiple en los tipos de disparo Único, Manual, Ráfaga y Continuo. Los modos de disparo Presentación y Auto mostrarán los resultados encontrados como resultados individuales.

En la pestaña Avanzado del paso de aplicación Detalles de código, especifique la cantidad máxima de códigos en una imagen con el campo Cantidad de códigos. También puede especificar la cantidad de tipos de símbolo que desea que el lector decodifique, basándose en su aplicación. Para mejorar el rendimiento, la Cantidad de códigos para leer debería equivaler a la suma de los campos Cantidad máx. de códigos de cada uno de los símbolos (p.ej., el número total de 3, con Data Matrix pasa a 2 y 1D a 1). El número de códigos individuales para leer no puede exceder el valor en el campo total Cantidad de códigos.


Código múltiple

Permitir resultados parciales

Active Permitir resultados parciales para permitir que el lector vuelva a obtener resultados de lectura satisfactorios cuando la imagen contenga menos códigos que lo especificados en la Cantidad de códigos.

Permitir símbolos 1D idénticos

Active Permitir símbolos 1D idénticos para permitir que el lector vuelva a obtener múltiples resultados de lectura en una imagen incluso si detecta más de un símbolo (en la misma imagen) con la misma longitud, simbología y cadena de datos.

Permitir símbolos 1D idénticos se aplica solo a dos o más símbolos 1D idénticos que aparecen en una sola imagen. El control Permitir símbolos 1D idénticos no tiene efecto en imágenes recogidas una después de la otra (independientemente del modo) aunque se encuentre el mismo símbolo.

Prioridad de clasificación

La lista de Prioridad de clasificación le permite determinar el modo en que el lector informará de resultados múltiples.

  • Use los botones Arriba y Abajo para aumentar o disminuir la prioridad de cualquier opción.

  • Use el botón Inverso para invertir el orden en una opción seleccionada.

  • Tenga en cuenta que las opciones de Posición (De arriba a abajo o De izquierda a derecha) se refieren al centro de los símbolos.

  • Use Orden de la imagen para los modos de disparo de Ráfaga o Continuo, en donde los símbolos que se decodifican en las imágenes anteriores se transmiten antes de los que se decodifican en las posteriores.


La opción Cantidad máx. de códigos para Código QR/MaxiCode aparece en gris

Podrá leer una imagen multicódigo, MaxiCode incluido, pero solo se podrá decodificar un MaxiCode por imagen. Esto quiere decir que si quiere leer una imagen multicódigo, MaxiCode incluido, tiene que activar también el código QR en la pestaña General.


Aprendizaje

De forma predeterminada, el lector intentará decodificar un símbolo utilizando todos los conjuntos de símbolos activados en la pestaña General. El aprendizaje del lector de los símbolos esperados puede disminuir el tiempo necesario para decodificar símbolos sucesivos, ya que el lector no tiene que buscar en los conjuntos de símbolos activados. Sin embargo, tenga en cuenta que el lector no podrá decodificar un símbolo si aparece en un conjunto de símbolos distinto al que ha aprendido a utilizar.

Use la pestaña Aprendizaje para controlar el estado de los símbolos aprendidos.

La herramienta de configuración desactiva los símbolos que el lector no espera porque no ha sido sometido a su aprendizaje, a no ser que desmarque la casilla Desactivar símbolos no aprendidos y active el Aprendizaje incremental.

Botón Aprender código

Haga clic en Aprender código en el panel superior Acciones después de que el lector haya capturado una imagen de un símbolo que espera que aparezca sobre imágenes sucesivas.

Sí únicamente está leyendo un determinado tipo de símbolos, al hacer clic en Aprender código, se preparará el lector para esos símbolos en todas las imágenes sucesivas hasta que haga clic en Desaprender código (el botón Desaprender código también se encuentra en el panel Configuración de símbolos).

Después de un correcto aprendizaje, la Información del modelo para los símbolos aprendidos mostrará el tamaño esperado para los símbolos entrantes y se activa el botón Desaprender código.

Llevar a cabo un aprendizaje cuando quiero decodificar varios símbolos

La herramienta de configuración le permite someter el lector a un proceso de aprendizaje para esperar más de un conjunto de símbolos en aplicaciones donde se descodificarán varios símbolos.

Si tiene una sola imagen en la que se muestran todos los símbolos esperados, haga clic en Aprender código en el panel superior Acciones para someter el lector a un proceso de aprendizaje. La Información del modelo para los símbolos aprendidos mostrará el tamaño esperado para los símbolos entrantes y se activarán los botones Desaprender código para esos conjuntos de símbolos.

Si no tiene una sola imagen en la que se muestren todos los conjuntos de símbolos esperados, marque Aprendizaje incremental y haga clic en Aprender código para el conjunto de símbolos presentes en la imagen. Luego, capture imágenes de otros conjuntos de símbolos que desee someter a aprendizaje y haga clic en Aprender código para añadirlos al conjunto existente de símbolos que el lector sabe decodificar. Si el Aprendizaje incremental está activado, puede presentar y someter a aprendizaje nuevos conjuntos de símbolos mientras el lector mantiene los parámetros de aprendizaje existentes.

Aprender orientación

Solo para símbolos 1D, apilados y postales, marque Aprender orientación para someter el lector a un proceso de aprendizaje con el ángulo del último símbolo decodificado. Las operaciones de decodificación subsiguientes serán más rápidas si los símbolos aparecen en el ángulo aprendido.

NOTA: los códigos postales solo pueden decodificarse si se presentan con barras en vertical («picket fence»).

Hacer que el lector vuelva a decodificar símbolos de cualquier conjunto de símbolos después del aprendizaje

Debe hacer clic en Desaprender código para cualquier conjunto de símbolos aprendidos para permitir que el lector decodifique cualquier símbolo sin importar la simbología. Sin embargo, tenga en cuenta que el símbolo debe ser activado en la pestaña General para que el lector lo reconozca.

Aprendizaje de códigos manual

Si conoce todos los parámetros de los códigos que vaya a someter a aprendizaje, puede proporcionarlos en Aprendizaje de códigos manual. Una vez proporcionados todos los parámetros, marque la casilla Es válido para aprender el código. En adelante puede desaprender el código haciendo clic arriba en Desaprender código.


¿Cómo cambio la salida de caracteres ASCII no imprimibles a equivalentes reconocibles en el teclado?

Vaya al panel Caracteres no imprimibles en Configuración de comunicación y marque la opción Activado. También puede agregar comandos ASCII no imprimibles antes y después de la cadena convertida activando Formato estándar y agregando comandos ASCII antes o después de la cadena completa.


¿Cuáles son las distintas configuraciones para las propiedades UPC/EAN?

  • Expandida activa la decodificación de símbolos expandidos.

  • Opciones adicionales controla el modo en que el lector decodifica códigos adicionales.

  • Eliminar ceros a la izquierda elimina los ceros a la izquierda de las cadenas decodificadas.

  • Permitir opciones EAN8 adicionales permite decodificar códigos adicionales de los símbolos EAN8.

  • UPCE1 activado activa la decodificación de símbolos UPC E1.


Propiedades de UPC/EAN: ¿Qué significa la casilla Ampliado?

Se trata de una expresión booleana que indica si hay que expandir la cadena decodificada proporcionada para UPC-EAN a un formato EAN13 de 13 dígitos o si hay que transmitirla en el formato estándar de 6 dígitos de UPC-E.

Si está marcada (de forma predeterminada), la cadena decodificada se transmite en el formato EAN-13 de 13 dígitos (p. ej., 0012345000065). Si no está marcada, el resultado se transmite como <sistema numérico> + 6 dígitos de datos + <carácter de control> (p. ej., 01234565).


Detalles de aplicación


¿Qué puedo configurar en el paso Detalles de aplicación?

En la pestaña Básico, puede establecer la configuración de disparo y de exposición. Para simplificar el proceso, un asistente para disparos, un asistente para intervalos y un asistente para la exposición le ayudarán con la configuración.

En la pestaña Avanzado, puede implementar más configuraciones en una vista de tabla.


¿Cuáles son los tipos de disparo?

Los disparos que inician un intento de decodificación provienen de una fuente externa o se generan por un mecanismo de temporización interno al propio lector.

Cualquiera de los siguientes acontecimientos indicará al lector que realice un intento de decodificación cuando el lector se configure para responder a un disparo externo:

  • Pulsar el botón en el lateral del lector

  • Enviar el comando de control de DataMan (DMCC) «trigger» (disparo) cuando se conecte el lector a través de una conexión USB, de serie o de red.

  • Recibir una señal de información digital a través de las líneas de disparo del cable E/S

  • Hacer clic en el botón de disparo en la herramienta de configuración

  • Pulsar Ctrl+T en el teclado cuando la herramienta de configuración tenga el enfoque

Puede configurar el lector con cualquiera de los siguientes tipos de disparo en respuesta a un acontecimiento externo:

  • El disparo Único adquiere una sola imagen e intenta decodificar cualquier símbolo que ésta pudiera contener. Este modo de disparo permite un tiempo de espera de lectura.

  • El disparo Manual adquiere imágenes mientras que la señal de disparo permanece activa y se detiene cuando se encuentra y decodifica un símbolo o cuando finaliza la señal de disparo. Este modo de disparo no permite un tiempo de espera de lectura.

  • El disparo Ráfaga adquiere un número fijo de imágenes y decodifica el primer símbolo que detecta dentro del grupo. Puede configurar el número de imágenes en cada ráfaga y el intervalo entre la adquisición de cada imagen. Este modo de disparo permite un tiempo de espera de lectura. Este tiempo de espera es la cantidad de tiempo que se empleará en cada imagen de la ráfaga, y no en la totalidad de dicha ráfaga.

  • El disparo Continuo adquiere imágenes mientras la señal de disparo permanece activa, tiempo durante el cual el lector adquiere las imágenes según un intervalo específico e intenta escanear cualquier símbolo que contenga cada imagen sucesiva. Si se decodifica un símbolo, el lector dejará de aceptar la señal de disparo. Si no se decodifica ningún símbolo, continuará la adquisición de imágenes mientras que permanezca activa la señal de disparo. Si finaliza la señal de disparo y no se ha escaneado ni decodificado ningún símbolo, el lector devolverá un resultado de No lectura.

    Si configura el lector para que escanee múltiples símbolos, entonces este no dejará de adquirir imágenes una vez haya sido escaneado y decodificado el primer símbolo, sino que continuará escaneando en busca de símbolos hasta que se haya detectado el número de símbolos deseado o finalice la señal de disparo. Si finaliza la señal de disparo antes de que se haya localizado y decodificado el número de símbolos deseado, el lector devolverá un resultado de No lectura.

    Puede controlar el intervalo entre la adquisición de imágenes y especificar una demora entre el momento en que llega la señal de disparo y el momento en el que el lector comienza la adquisición de imágenes. En el modo de disparo continuo, el intervalo de disparo especifica indirectamente un tiempo de espera de lectura.

Los tipos de disparo restantes no dependen de un acontecimiento exterior, sino que comenzarán la adquisición de imágenes tan pronto como los seleccione:

  • El disparo Presentación busca un símbolo de forma continua y lo decodifica cada vez que detecta uno.

    Puede especificar varios parámetros en el modo Presentación; p.ej., si el lector leerá el mismo código más de una vez o el tiempo que debe esperar el lector antes de buscar el siguiente símbolo. Utilice el panel Configuración del sistema y las opciones de Configuración de decodificación para configurar el modo de disparo Presentación.

    En el modo Presentación, utilice la opción Exposición automática para que el lector determine la mejor configuración de exposición para un nivel de intensidad de la luz deseable en la imagen. Sin embargo, tenga en cuenta que el lector utiliza las primeras imágenes que adquiere para determinar esta configuración y podría omitir imágenes que contengan un símbolo para decodificar. Puede cambiar a la opción Exposición manual y especificar una configuración precisa para la exposición de la cámara.

    Tenga en cuenta que durante un intento de decodificación para una imagen en particular, se descartarán todas las imágenes subsiguientes adquiridas durante ese tiempo.

    Este modo de disparo no permite un tiempo de espera de lectura.

  • El disparo Auto es similar al disparo de presentación en cuanto que el lector busca un símbolo de forma continua y lo decodifica cada vez que detecta uno. Sin embargo, a diferencia del modo Presentación, se lleva a cabo un intento de decodificación con cada imagen y el lector desactiva la configuración Exposición automática que permite al lector determinar automáticamente la mejor configuración de exposición para un nivel de brillo deseable en la imagen.

    Puede especificar varios parámetros en el modo de disparo Auto; p.ej., si el lector leerá el mismo código más de una vez o el tiempo que debe transcurrir antes de buscar el siguiente código. Utilice el panel Configuración del sistema y las opciones de Configuración de decodificación para configurar el modo de disparo Auto. En el modo de disparo Auto, el intervalo de disparo especifica indirectamente un tiempo de espera de lectura.

NOTA: Varios lectores de montaje fijo tienen variantes (modelos S, modelos L, etc.) y muchas de ellas solo admiten ciertos tipos de disparo. Consulte el manual de referencia correspondiente para comprobar qué tipos de disparo admite su variante.


Asistente para disparos

Para que este asistente funcione, primero debe seleccionar el tipo de disparo. Seleccione la fuente de disparo en la lista desplegable: Sin definir, Ninguno o Externo. Obtendrá una recomendación del asistente para los modos de disparo. Las representaciones gráficas de los tipos de disparo le ayudarán a tomar una decisión. Seleccione el tipo de disparo deseado y haga clic en Guardar y cerrar.


Asistente para intervalos

En el caso de los modos Ráfaga, Auto y Continuo, el asistente para intervalos puede ayudarle a realizar más configuraciones. Puede seleccionar tres maneras de calcular los datos necesarios. En la parte superior derecha, seleccione las unidades (estándar o métrica) en las que desee realizar el cálculo.

Haga clic en Campo de visión para calcular el mayor tiempo de intervalo posible midiendo el campo de visión físico y proporcionando la velocidad máxima de línea y el tamaño del código más largo.

Haga clic en Lente / Distancia hasta el código si desea proporcionar la distancia del código de la lente. Seleccione la distancia focal de la lista desplegable y seleccione la dirección de avance del código. Aquí también debe proporcionar la velocidad máxima de línea y el tamaño del código más largo.

Haga clic en Tamaño de elemento de código para realizar el cálculo con el tamaño de elemento de código más estrecho. Active Modo de prueba para leer el código. También debe proporcionar la dirección de avance del código, la velocidad máxima de línea y el tamaño del código más largo.

En la parte inferior del asistente, se mostrará el tiempo de intervalo máximo recomendado.


Asistente para la exposición

El asistente para la exposición es muy similar al asistente para intervalos. Puede seleccionar las tres mismas formas de cálculo: Tamaño de campo de visión, distancia hasta el código y tamaño de elemento de código.

Haga clic en Campo de visión para calcular el tiempo máximo de exposición recomendado midiendo el campo de visión físico y proporcionando la velocidad máxima de línea. Puede activar Modo de prueba para leer el código más pequeño.

Haga clic en Lente / Distancia hasta el código si desea proporcionar la distancia del código de la lente. Seleccione la distancia focal de la lista desplegable y seleccione la dirección de avance del código. Aquí también debe proporcionar la velocidad máxima de línea.

Haga clic en Tamaño de elemento de código para realizar el cálculo con el tamaño de elemento de código más estrecho. Active Modo de prueba para leer el código. También debe proporcionar la dirección de avance del código y la velocidad máxima de línea.

En la parte inferior del asistente, se mostrará el tiempo máximo de exposición recomendado.


¿Cómo interactúa Múltiples configuraciones de lectura con la opción Tiempo de espera?

Si se activa Múltiples configuraciones de lectura, el tiempo de espera afecta a cada configuración individualmente y no a todas las configuraciones en su conjunto. El resultado es que el tiempo total dedicado a la lectura en un ciclo de disparo es el producto del número de configuraciones activadas y el tiempo de espera.


¿Se recogerán más imágenes una vez se haya realizado una lectura válida?

No, solo se recogen imágenes adicionales cuando fallan las configuraciones previas. Una vez que una configuración produce una imagen válida, el lector ya no probará más configuraciones durante ese ciclo de disparo y se iniciará la decodificación. El lector probará cada configuración activada en un orden prioritario, empezando por la configuración de mayor prioridad especificada hasta que se obtenga una lectura válida.


¿Cuál es la diferencia entre las opciones de retraso Tras la primera lectura y Tras la última lectura?

El retraso Tras la primera lectura inicia la temporización después de la primera vez que se lee un código datos dado, y el temporizador no se restablece. Esto significa que se puede volver a leer un código si el lector está disparando en un modo de imagen múltiple, como Continuo, y si el código está delante del lector durante un tiempo igual o superior al Retraso de relectura.

Tras la última lectura restablece el temporizador cada vez que aparece un código dado en una imagen. Esto significa que no se volverá a leer el código siempre y cuando permanezca delante del lector. Únicamente se volverá a leer el código si se quita del campo de visión del lector por un tiempo igual o superior al Retraso de relectura.


Mi código se lee dos veces si vuelvo a disparar el lector. ¿Por qué?

Las opciones Retraso de relectura y Nunca leer el mismo código dos veces solo afectan a las adquisiciones realizadas en un ciclo de disparo único. Disparar el lector borrará los temporizadores y el último código leído para Nunca leer el mismo código dos veces.


¿Qué es Nunca leer el mismo código dos veces?

Cuando está activada, la opción Nunca leer el mismo código dos veces evita que se transmita el mismo código dos veces seguidas y en una secuencia de disparo único. Está disponible para todos los modos de disparo, pero solo es válida con Lectura de código múltiple, ya que la única manera de obtener más de un código en una secuencia de disparo único es en lecturas de código múltiple. Si no se marca la casilla Nunca leer el mismo código dos veces, el dispositivo vuelve a leer y a transmitir el mismo código después del Retraso de relectura de código especificado (en milisegundos).


¿Cómo funciona Nunca leer el mismo código dos veces en un sistema de Sincronización de múltiples lectores?

Si se especifica el comando Nunca leer el mismo código dos veces en el lector principal y los lectores secundarios leen el mismo código, el lector principal considera todos los resultados y filtra las lecturas duplicadas independientemente de su origen.


¿Qué es Modo retraso y Retraso de relectura de código?

La opción Modo retraso configura el retraso de relectura de código relativo a la primera o a la última lectura.

La opción Retraso de relectura de código (en milisegundos) permite especificar el retraso entre los intentos de lectura. Especificar un valor distinto a cero para este tipo de retraso puede ayudar a evitar que los datos saturen el dispositivo conectado al lector.


¿Qué efecto tiene No volver a leer los últimos n códigos?

En caso de utilizarse, la opción No volver a leer los últimos n códigos evita que el dispositivo lea códigos que fueron leídos en las últimas «n» lecturas. Debe introducir un valor para «n» en el cuadro inferior; de lo contrario (si el número es 0), la opción estará desactivada. La opción se aplica a todos los códigos de lectura en una secuencia de disparo.


¿Qué es Detección de movimiento?

Detección de movimiento permite a los usuarios configurar su dispositivo para que cambie al modo de disparo activo Presentación o Auto durante un periodo de tiempo después de que detecte movimiento en el campo de visión del dispositivo.

La opción Detección de movimiento solo está disponible si se establece el tipo de disparo Presentación o Auto. Si se activa Detección de movimiento, el dispositivo no toma de continuo imágenes, sino que detecta en segundo plano si la escena en su campo de visión está o no en movimiento.

Si está en movimiento, el dispositivo adquiere activamente imágenes según el modo de disparo Presentación o Auto. La configuración Tiempo de espera permite especificar el periodo de tiempo (en segundos) después del cual el dispositivo vuelve a Detección de movimiento desde el disparo activo, pero este tiempo de espera se reinicia cada vez que se detecta movimiento o una lectura correcta.

Sensibilidad de detección de movimiento puede ajustarse para definir qué grado de movimiento debe detectar el dispositivo para cambiar a los modos activos de disparo Presentación y Auto.


¿Cómo envío un disparo desde el teclado?

Pulse <Ctrl>-T (la ventana de la herramienta de configuración debe estar activa).


¿Por qué el DataMan devuelve varios resultados como respuesta a un disparo único?

Esto puede ocurrir cuando se utiliza la línea de entrada del disparador de hardware porque la señal en la línea está oscilando en torno a su valor final y el lector interpreta las oscilaciones como señales de disparo único. Aumentar el Retraso de rebote en la pestaña Entradas del panel Configuración del sistema puede hacer que el lector interprete todas las oscilaciones como una señal de disparo único.


¿Qué son los valores de tiempo de espera y retraso del disparo?

En el grupo Retraso del disparo, puede establecer el Tipo de retraso a Tiempo o Distancia y especificar el inicio y el final para la cantidad de milisegundos o milímetros que hay que esperar antes de dar comienzo a una adquisición de imagen una vez que el lector recibe el disparo. El uso de un valor de retraso puede ser útil cuando el lector recibe un disparo antes de que el símbolo esté completamente debajo del campo de visión. Solo los tipos de disparo Único, de Ráfaga y Continuo son compatibles con un retraso del disparo.

Los modos Único y Ráfaga tienen Retraso del inicio y Distancia de retraso del inicio, pero no Retraso del fin ni Distancia de retraso de fin. El modo Continuo tiene todos los tipos de retrasos disponibles.

El valor Tiempo de espera especifica la cantidad fija de tiempo que tiene el lector para intentar decodificar cualquier símbolo que detecte. Si el lector no puede decodificar el símbolo en ese tiempo, devuelve el estado No lectura como si la imagen no contuviese ningún símbolo detectable. Si no se especifica ningún tiempo de espera, el rendimiento podría resentirse, ya que el lector intentará decodificar cualquier candidato con código en la imagen actual antes de pasar a la siguiente.


¿Cómo ajusto la exposición de la imagen?

Los tipos de disparo Presentación y Manual utilizan la configuración Exposición automática para determinar automáticamente la mejor configuración para un nivel de intensidad de la luz deseable en cada imagen. Con cualquiera de estos tipos de disparo, puede utilizar la configuración Exposición máxima de acuerdo con las necesidades de su entorno de producción o bien seleccionar Exposición manual y definir un tiempo de exposición preciso en microsegundos.

Con Exposición manual, puede hacer clic en Optimizar intensidad de la luz en el panel de Historial de resultados para generar un valor fijo para la configuración de exposición, limitado por el valor de Exposición máxima. La configuración Factor de ganancia máxima permite establecer la intensidad de luz máxima deseada de los píxeles.


¿Cómo determino los parámetros óptimos para el tipo de disparo de ráfaga?

Dado que el modo de disparo Ráfaga es ideal para aplicaciones móviles, es necesario determinar el tamaño e intervalo de ráfaga correctos para capturar la longitud deseada de la pieza a medida que pasa por debajo de la cámara. Una vez haya determinado el intervalo, puede ajustar el tamaño de la ráfaga en función de la longitud de la pieza. Las variables necesarias para estos cálculos son las siguientes:

  1. Velocidad de la línea en mm por segundo

  2. Tamaño del código con zona de silencio en mm

  3. FoV = Campo de visión (x o y) en mm

Después puede utilizar la siguiente ecuación para determinar el intervalo:

Intervalo de tiempo = 1000 * ((Campo de visión (FoV) – 2(Tamaño del código)) / Velocidad de la línea)

Una vez haya determinado el intervalo, se puede ajustar el tamaño de la ráfaga en función de la longitud del código para capturar. La longitud máxima del objeto en mm es:

Tamaño de ráfaga * (Campo de visión (FoV) – (2*Tamaño del código))

La variable (2 * Tamaño del código) permite la superposición de los fotogramas tomados. Esto tiene en cuenta la condición en la que el código está ligeramente fuera del campo de visión en un fotograma (adquisición). La variable (2 * Tamaño del código) superpondrá el campo de visión entre fotogramas sucesivos y permitirá que el código se visualice en el campo de visión del siguiente fotograma.


¿Cómo establezco una longitud de ráfaga mayor?

La longitud máxima de ráfaga que puede especificar depende de los recursos disponibles en el dispositivo. Por defecto, la longitud máxima de ráfaga es 202 imágenes, pero la puede aumentar incrementando la memoria para almacenar imágenes capturadas por el lector. Aumente la memoria disponible para el almacenamiento de imágenes en ráfaga al dejar de reservar los espacios de imagen que están actualmente dedicados a la carga de imágenes y al disminuir el tamaño del campo de visión del generador de imágenes. Esto puede hacerse a través del panel de Tamaño de imagen (Región de interés):

  1. Seleccione el panel Tamaño de imagen (Región de interés):
  2. Marque la casilla FoV del generador de imágenes (en los modos de disparo Único, Ráfaga, Continuo y Auto) y reduzca el tamaño del campo de visión del generador de imágenes.

Una vez reducido, puede incrementar el parámetro de longitud de ráfaga en el paso Detalles de aplicación.


¿Cómo calculo el valor de intervalo en los modos de disparo Auto y Continuo?

El asistente para intervalos le ayuda a calcular estos datos. Haga clic en Asistente para intervalos para realizar los cálculos de forma fácil y asistida.

Dado que los modos de disparo Auto y Continuo se pueden utilizar en aplicaciones móviles, es necesario determinar el intervalo correcto para capturar la longitud deseada de la pieza a medida que pasa por debajo la cámara. Las variables necesarias para estos cálculos son las siguientes:

  1. Velocidad de la línea en mm por segundo

  2. Tamaño del código con zona de silencio en mm

  3. FoV = Campo de visión (x o y) en mm

Después puede utilizar la siguiente ecuación para determinar el intervalo aproximado:

Intervalo = 1000 * ((Campo de visión (FoV) – 2(Tamaño del código)) / Velocidad de la línea)

La variable (2 * Tamaño del código) permite la superposición de los fotogramas tomados. Esto tiene en cuenta la condición en la que el código está ligeramente fuera del campo de visión en un fotograma (adquisición). La variable (2 * Tamaño del código) superpondrá el campo de visión entre fotogramas sucesivos y permitirá que el código se visualice en el campo de visión del siguiente fotograma.


¿Cuándo debería modificar la Exposición máxima?

Disminuya el valor de la exposición máxima cuando tenga que leer objetos en movimiento.


¿Qué muestra el gráfico?

El gráfico muestra el resultado actual para cada nivel de intensidad de la luz para cada configuración de iluminación disponible.


¿Qué son los puntos de color que hay debajo de Mejores resultados?

Los puntos representan un juego de resultados del gráfico de arriba.


¿Tengo que seleccionar una imagen de las imágenes ajustadas?

Cuando se terminen de realizar los ajustes, la herramienta de configuración muestra tres candidatas o menos. La mejor se seleccionará automáticamente y se aplicará a una memoria no volátil, pero también puede seleccionar y aplicar cualquiera de las otras candidatas.


¿Qué sucede si quiero realizar ajustes en una configuración de código múltiple?

Si tiene más de un código en el campo de visión, la opción de ajustar solo funciona en uno de los códigos.


Se muestra el mensaje «Fallo. Símbolo no encontrado». ¿Qué puedo hacer?

Vaya a Configuración de símbolos y active el símbolo o símbolos que desee decodificar.


Formatear datos


¿Cómo funciona el formato de datos?

En el panel Básico, puede seleccionar qué tipo de formato desea utilizar.

Utilice el panel Estándar para crear una cadena de salida personalizada utilizando módulos predefinidos en las pestañas individuales de símbolos:

  • La cadena de salida empieza con el texto introducido en el campo Texto inicial.

  • Seleccione elementos de las listas de las pestañas General, Validación y (cuando proceda) Mediciones, y haga clic en Agregar para agregarlos a la cadena de salida. Para agregar un intervalo de caracteres determinado de los datos decodificados, haga clic en Establecer intervalo de subcadenas, introduzca el intervalo de caracteres que desee agregar (como 1-3,5,8,10-), haga clic en Subcadena en la lista y, a continuación, en el botón Agregar.

  • La cadena de salida también incluye el texto introducido en el campo Texto final.

  • Para que toda la cadena termine con un par de retornos de carro/saltos de línea, marque la casilla de verificación CR/LF.


¿Por qué hay diferentes pestañas debajo de la pestaña Estándar?

Puede especificar el formato de forma independiente para diferentes tipos de símbolos, o utilizar la pestaña Universal para especificar el formato de datos para cualquier símbolo decodificado, que tenga prioridad sobre las pestañas de tipos de símbolos específicos.


¿Cómo puedo utilizar los símbolos específicos y el formato universal a la vez?

El panel Formato estándar utiliza los siguientes criterios cuando utiliza las pestañas de símbolos específicos y las pestañas Universales:

  • Cada resultado individual pasará por el formateador de símbolos específicos, si está activado. Se formatearán múltiples resultados de los mismos símbolos de forma independiente con idéntica configuración.

  • Si se activa la pestaña Universal, los resultados individuales pasarán por el formateador de símbolos específicos, si está activado, y posteriormente serán aumentados con las normas de formato de la pestaña Universal. Para múltiples resultados (en los lectores admitidos), los resultados serán concatenados y separados por el delimitador seleccionado, con ningún delimitador adicional al final. La cadena concatenada será tratada como una cadena sencilla para el resto de normas de formato de la pestaña Universal.

  • Para resultados múltiples, el orden de los resultados en una cadena concatenada es 1) Data Matrix, 2) Código QR, 3) Códigos 1D, 4) Vericode, 5) DotCode y 6) OCR.

  • Cualquier marca añadida al formato de símbolos específicos válidos solo para el proceso de decodificación en conjunto (como el tiempo de decodificación o el índice de disparo) ofrecerá este valor global.


¿Qué datos se envían si no está activado el formato estándar?

El lector transmite toda la cadena decodificada seguida de un par de retornos de carro/saltos de línea.


¿Cómo puedo enviar únicamente los datos decodificados sin el par de retornos de carro/saltos de línea?

Active el formato, agregue Cadena completa a la cadena de salida y compruebe que la casilla de verificación CR/LF no esté marcada.

Para enviar únicamente un retorno de carro, introduzca \r en el campo Texto final.


¿Qué es Cadena de entrada?

Cadena de entrada es un token de formato que puede incluir como parte de las propiedades del lector en el formato basado en secuencias de comandos o como un token del formato de datos estándar. Tenga en cuenta que no puede cambiar más propiedades de Cadena de entrada en la herramienta de configuración, sus parámetros solo están disponibles en DMCC.


¿Qué puedo hacer para que Excel no omita celdas?

De forma predeterminada, el lector añade un par de retornos de carro/saltos de línea después de cada código transmitido. Si utiliza una conexión de teclado para introducir los códigos transmitidos en Excel, el par de retornos de carro/saltos de línea hace que Excel avance dos filas después de cada código. Para evitar que esto ocurra, configure el lector para que envíe únicamente un retorno de carro:

  1. Haga clic en Formato estándar.

  2. Especifique el símbolo que esté utilizando en las pestañas de Símbolos.

  3. Marque la casilla Formato activado.

  4. Haga clic en Cadena completa en la pestaña General.

  5. Haga clic en Agregar.

  6. En Texto final, introduzca \r en el campo de texto y desactive la casilla CR/LF.


¿Cómo transmito elementos específicos de los datos codificados cuando está activada la validación de datos?

Primero, seleccione el tipo de validación que necesite en el panel Validación de datos. Active la opción Formato básico en la pestaña Básico del paso de aplicación Formatear datos. Seleccione la pestaña Validación de la pestaña Estándar y agregue el campo o los campos de datos deseados a la cadena de salida, incluido los identificadores de empresa, número de serie, número de referencia, identificador de elemento único y aplicación GS1.


¿Qué son las opciones individuales en la pestaña General, en el campo Datos de la pestaña Estándar?

  • Subcadena: una subcadena de los caracteres codificados en el símbolo. Para usar esta opción deberá especificar un intervalo para la subcadena.

  • Cadena completa: todos los caracteres codificados en el símbolo

  • Tiempo de decodificación: la cantidad de tiempo, en milisegundos, que le llevó al lector decodificar el símbolo. Este período de tiempo no incluye la adquisición de imagen, pendiente del procesamiento de imágenes, el tiempo de comunicación o el procesamiento adicional (por ejemplo, Formato de datos).

  • Tiempo de disparo: la cantidad de tiempo, en milisegundos, entre la recepción de la activación del disparo y la finalización de la operación de codificación

  • Símbolos: la simbología del símbolo decodificado

  • CR/LF: retorno de carro con salto de línea

  • TAB: un carácter de tabulación.

  • SP: un carácter de espacio.

  • Identificador de símbolos: el identificador de símbolos tal y como especifica la normativa ISO/IEC 15424:2008

  • Tamaño de módulo: la anchura (o altura), en píxeles, de cada módulo del símbolo

  • Posición de código: las coordenadas de imagen de cada esquina del símbolo decodificado

  • Orientación de los códigos: la orientación del símbolo decodificado indicada en grados. Las rotaciones en el sentido de las agujas del reloj del símbolo decodificado se consideran cambios positivos en orientación.

  • Contraste: un valor entre 0 y 1, que indica la cantidad total del contraste en el símbolo decodificado. Un valor elevado indica que los módulos de luz y los módulos oscuros del símbolo tienen un intervalo amplio de valores de gris, mientras que un valor bajo indicará que los módulos de luz y los módulos oscuros están formados por valores de gris similares.

  • UEC: la cantidad corrección de error sin utilizar disponible en el símbolo. La corrección de error es un método de reconstrucción o sustitución de datos perdidos cuando el símbolo está dañado. Lo ideal es un valor de «100». Los símbolos 1D siempre dan -1.

  • Cadena de entrada: la cadena de entrada (serie o Ethernet) recibida.

  • Tiempo de filtro: la duración del filtrado en milisegundos (ms).

  • Origen de los resultados: el nombre del dispositivo.

Todos los valores indicados a continuación aumentarán independientemente de si el lector se encuentra conectado a la herramienta de configuración.

  • Total de lecturas: el número total de símbolos decodificados

  • Total de no lecturas: el número de veces que se recibió un disparo, pero no se decodificó ningún símbolo

  • Total de disparos: total de disparos = Total de lecturas + Total de no lecturas + Total de disparos fallidos

  • Disparos fallidos: el número de disparos fallidos debido a que no había disponible ningún búfer de imagen cuando se detectó el disparo

  • Índice de disparos: el número total de disparos detectados por el lector.

Los valores que se restablecerán en 0 cuando se borre Estadísticas de procesos en el panel Monitor de procesos o después de que se reinicie el lector son los siguientes:

  • Total de lecturas

  • Total de no lecturas

  • Total de disparos

  • Disparos fallidos

El índice de disparo se restablecerá en 0 solo después de reiniciar el lector, pero no después de borrar las Estadísticas de procesos.


¿Cómo puedo simular las combinaciones de las teclas Alt, Ctrl o Mayús?

Para usar esta función, se encuentran disponibles cuatro secuencias de salida, \ALT-, \CTRL-, \SHIFT- y \K. \ALT- se utiliza para secuencias de <Tecla ALT>; \CTRL- para las de <Tecla CTRL>, \SHIFT- para las de <Tecla Mayús>, y \K para teclas especiales. Tenga en cuenta que la letra que siga a la barra inversa debe ser escrita en mayúscula o no se reconocerá la combinación de teclas especial.

Las secuencias se introducen en los campos Texto inicial/final del panel Estándar.

Secuencias de teclado especiales admitidas

Debe usarse el siguiente formato:

\ALT- seguido del nombre de tecla seguido de ;

o

\CTRL- seguido del nombre de tecla seguido de ;

o

\SHIFT- seguido del nombre de tecla seguido de ;

o

\K seguido del nombre de tecla seguido de ;

El punto y coma final es necesario para poder distinguir entre las secuencias con el mismo prefijo; de lo contrario, las secuencias de teclas se interpretarían de forma arbitraria, es decir, no habría forma de detectar si \KF11 significa «Pulse F11» o «Pulse F1 seguida de un uno».

Tenga en cuenta que si estas dos secuencias de salida se introducen en la pestaña Universal, se aplicarán también a los resultados No lectura.

Teclas y secuencias de teclas compatibles

La siguiente lista contiene las teclas/combinaciones de teclas compatibles actualmente:

  • ALT-A a ALT-Z

  • CTRL-A a CTRL-Z

  • CTRL-F1 a CTRL-F12

  • Mayús-F1 a Mayús-F12

  • F1 a F12

  • ALT-F1 a ALT-F12

  • Re Pág, Av Pág, Inicio, Fin, Cursor (arriba, abajo, izquierda, derecha), Insert, Supr, Retroceso, Tabulador, Esc, Impr Pant, teclas GUI (izquierda, derecha)

    Las secuencias de salida para estas son las que siguen:

    • Re Pág -> \KPup;

    • Av Pág -> \KPdn;

    • Inicio -> \KHome;

    • Fin -> \KEnd;

    • Cursor arriba -> \KUar;

    • Cursor abajo -> \KDar;

    • Cursor izquierda -> \KLar;

    • Cursor derecha -> \KRar;

    • Insert -> \KIns;

    • Supr -> \KDel;

    • Retroceso -> \KBksp;

    • Tabulador -> \KTab;

    • Esc -> \KEsc;

    • Impr Pant -> \KPrtScr;

    • GUI izquierda -> \KLGui;

    • GUI derecha -> \KRGui;

  • Pause output -> \KPAUSE;

He aquí algunos ejemplos:

  • Para generar una secuencia <ALT-V>, utilice \ALT-V;

  • Para simular la tecla <F10> pulsada, utilice \KF10;

  • Para simular la tecla <Inicio> pulsada, utilice \KHome;

  • Para activar/desactivar la barra de estado en el bloc de notas (<Alt-v><s>), la secuencia debe ser \Alt-v;s

Si se utiliza una secuencia equivocada o incompleta, se ignorarán los dos caracteres que marcan la secuencia de salida. En este caso, las dos primeras letras de la secuencia de salida se pasan por alto y se enviarán los caracteres restantes. Por ejemplo, la secuencia «\ALT-M11;» no es válida y mostrará «LT-M11;»


¿Cómo puedo probar el formato de datos?

Utilice el botón Prueba en la parte inferior de la página para comprobar el aspecto del resultado.

Escanee un símbolo y visualice el resultado formateado en la barra de estado. También puede seleccionar el panel Historial de resultados y, después, leer un símbolo. El Historial de resultados muestra los resultados del formato que usted ha especificado.


¿Qué es la función Opciones de salida?

La función Opciones de salida le permite transmitir los elementos de datos de salida deseados en distintos formatos. Por ejemplo, si se selecciona una coma y usted selecciona transmitir toda la cadena seguida por el tipo de símbolo, el resultado será la cadena de datos completa seguida de una coma y el texto «Data Matrix». Para probar las distintas opciones, puede seleccionar un tipo de salida determinado y hacer clic en el botón Prueba para ver el resultado en una ventana de visualización adyacente. Tenga en cuenta que si la opción Validación de datos está seleccionada y un código no supera la validación de datos, la función de opciones de salida no estará activada.


¿Por qué está marcado en gris el botón Prueba?

Solo puede probar su código tras la primera decodificación correcta.


¿Puedo especificar caracteres utilizando códigos ASCII hexadecimales u octales?

En los campos Texto inicial y Texto final, puede especificar los caracteres como \nnn, donde nnn es el código ASCII octal. Puede especificar caracteres en formato hexadecimal introduciendo \xnn, donde nn es el código ASCII hexadecimal.

También puede utilizar los siguientes códigos predefinidos:

  • \a Alerta (ASCII 7)
  • \b Retroceso (ASCII 8)
  • \E Escape (ASCII 27)
  • \f Salto de página (ASCII 12)
  • \n Salto de línea (ASCII 10)
  • \t Tabulación horizontal (ASCII 9)
  • \r Retorno de carro (ASCII 13)
  • \v Tabulación vertical (ASCII 11)
  • \\ Barra invertida (ASCII 92)


¿Qué transmite el lector cuando no se lee ningún código?

Normalmente, el lector no transmite ningún dato si no puede leer ningún código. Si desea saber si la razón por la que no ve ninguna salida es que no se leyó ningún dato, podrá definir una cadena específica de hasta 32 caracteres de longitud al usar Cadena de salida no leída en el panel Básico.


¿Qué es el resultado Posición de código?

Para los símbolos Data Matrix, la posición de código representa la ubicación indicada de las cuatro esquinas del símbolo. El lector devuelve 4 pares de coordenadas:

  • El primer par representa la intersección del patrón de búsqueda.

  • El segundo par representa la intersección del patrón de búsqueda horizontal y el patrón alternativo vertical.

  • El tercer par representa la intersección de los patrones alternativos (diagonal opuesta al primer par).

  • El cuarto par representa la intersección del patrón de búsqueda vertical y el patrón alternativo horizontal.

Cognex recomienda seleccionar un delimitador, como una coma, para separar cada valor y facilitar la lectura de los datos.


Solo lectores modelo DataMan X: ¿Cómo puedo usar la medición de control de procesos para el formato de datos?

Una vez haya activado la medición de control de procesos en el panel Propiedades de Data Matrix o en el panel Propiedades del código QR, podrá usarla en la pestaña Mediciones del panel Formato estándar.

También se puede acceder a las mediciones a través de las secuencias de comandos. Si no ha activado la medición de control de procesos, el resultado mostrado será -1.


Solo lectores modelo DataMan X: ¿Qué indica que la medición de control de procesos proporcionada sea -1 o NA?

Cuando la calidad de impresión o imagen del símbolo es tan baja que la medición de control de procesos no se puede calificar con un algoritmo de decodificación de referencia, la medición proporcionada será -1 o NA. Mejore la calidad de impresión usando, por ejemplo, la función Filtrado de imagen.


¿Qué método de formato de datos debería elegir?

Puede usar el Formato básico (Estándar o Estilo Perl) o puede escribir su propia secuencia de comandos en JavaScript en la pestaña Formato de datos del panel Secuencias de comandos. Los dos métodos difieren en lo siguiente:

  • El Formato básico le permite arrastrar y colocar elementos de formato de datos predefinidos.

  • El Formato basado en secuencias de comandos le permite crear una secuencia que, además de dar formato a los resultados de lectura y a los datos, es capaz de hacer que su lector realice operaciones tales como emitir un pitido o elevar la salida 1.


¿Cuál es el propósito de la pestaña Comunicación?

En esta pestaña, puede editar su secuencia de comandos de protocolo de comunicación personalizada.


¿Cuáles son las limitaciones en el formato basado en secuencias de comandos?

Está limitado a dos eventos personalizados y a sobrescribir el evento de sistema en el formato basado en secuencias de comandos.


¿Dónde puedo encontrar un ejemplo de secuencia de comandos?

Tiene las siguientes opciones para introducir una secuencia de comandos en la ventana principal del panel Secuencias de comandos:

  • Haga clic en el botón Insertar fragmento en la barra de herramientas superior y elija el fragmento apropiado de la lista, según sus necesidades.

  • Haga clic derecho en cualquier lugar de la pantalla principal y seleccione Insertar fragmento.... Haga clic en el fragmento apropiado de la lista, según sus necesidades.

  • Pulse Ctrl-K, X

NOTA: si el botón Insertar fragmento no está activo, significa que la versión de firmware que se ejecuta en el dispositivo no admite fragmentos de código en la pestaña de secuencia de comandos actual.


¿Cuál es el propósito de la pestaña Almacenamiento FTP?

Esta pestaña se utiliza para la generación de nombres de archivo en FTP para los informes de calidad de los códigos e imágenes.


¿Cómo puedo cargar mis secuencias de comandos?

Puede acceder a ellas si hace clic en el menú de la cinta y luego en la opción Abrir secuencia de comandos. Puede guardar sus secuencias de comandos con el botón Guardar secuencia de comandos.

NOTA: las secuencias de comandos solo admiten la codificación de caracteres UTF-8.


¿Qué es la opción Completar palabra?

Puede completar palabras en su secuencia de comandos mediante los siguientes métodos:

  • haciendo clic en el botón Completar palabra en la barra de herramientas superior;

  • haciendo derecho en cualquier lugar de la pantalla principal y seleccionando Completar palabra;

  • pulsando Ctrl-K, W.

Entonces podrá elegir de una lista de objetos para introducir en su secuencia de comandos.


¿Cómo puedo editar rápidamente mi secuencia de comandos?

Use los botones Cortar, Copiar o Pegar en la barra de herramientas superior, o haga clic derecho en cualquier lugar de la ventana principal y elija Cortar, Copiar, Pegar, Eliminar o Seleccionar todas.


¿Por qué se restablecen todas las variables al seleccionar Sistema->Guardar configuración?

Cuando se modifica una secuencia de comandos y se deja el enfoque del editor, la secuencia de comando se transmite al lector y se invalida el contexto del motor de secuencia de comandos. La invalidación del contexto de secuencia de comandos hace que se restablezcan todas las variables.


Solo lectores modelo DataMan X: ¿Cómo puedo usar la medición de control de procesos para el formato de datos?

Una vez haya activado la medición de control de procesos en el panel Propiedades de Data Matrix o en el panel Propiedades del código QR, también podrá acceder a ella a través de las secuencias de comandos. Si no ha activado la medición de control de procesos, el resultado mostrado será -1.


¿Cómo puedo ver errores en el registro del dispositivo utilizando secuencias de comandos?

Utilice el comando Throw() para informar de que se ha producido una situación anómala (excepción) y el error aparecerá en el registro del dispositivo cuando el dispositivo no esté conectado a la herramienta de configuración. Puede acceder al registro de errores haciendo clic en Sistema y luego en Mostrar registro del dispositivo en la barra de menús de la herramienta de configuración.

Si el dispositivo está conectado a la herramienta de configuración, la excepción aparecerá debajo de la secuencia de comandos en el panel de secuencias de comandos.


¿Dónde puedo encontrar más información acerca del Formato basado en secuencias de comandos?

Para obtener más información, consulte la Guía de comunicaciones y programación del dispositivo DataMan, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.


¿Cómo establezco un retraso en la transmisión de código?

Para establecer una pausa en la transmisión de código, se puede agregar la secuencia \Pause<tiempo>; a los campos de texto en el panel Formato de datos.

<tiempo> ha de contener un valor en milisegundos. Por ejemplo, para esperar 4 segundos, la secuencia será \Pause4000;.

Esta función puede utilizarse con USB HID o RS232. Con RS232, la función debe activarse mediante el comando COM.RS232-ENABLE-PAUSE de DMCC. Con USB HID, está activada de forma predeterminada.


¿Por qué hay diferentes pestañas en la parte superior?

Puede especificar el formato de forma independiente para diferentes tipos de símbolos, o utilizar la pestaña Universal para especificar el formato de expresiones regulares estilo Perl para cualquier símbolo decodificado.


¿Por qué aparece en gris este panel?

Para activar la posibilidad de utilizar el formato de expresiones regulares estilo Perl, debe seleccionar en primer lugar Formato básico en el panel principal Formato de datos para las simbologías específicas que decodificará su lector.


¿Cómo puedo especificar una sustitución de texto arbitraria?

Introduzca texto en el cuadro de texto Expresión regular: la sintaxis de la cadena es la siguiente:

        /search/replace/g

donde búsqueda es la cadena que se desea buscar, y reemplazo la cadena que reemplazará la cadena de búsqueda. De forma predeterminada, solo se reemplaza la primera instancia de la cadena de búsqueda. Para reemplazar todas las instancias, agregue g al final del comando.

Por ejemplo, si el lector decodifica la siguiente cadena:

        UPC 05214275600

Puede reemplazar la cadena «UPC» por la cadena «CÓDIGO SKU:» utilizando esta cadena de sustitución:

        /UPC/SKU CODE:/

que generaría la siguiente cadena de salida:

        SKU CODE: 05214275600

Puede introducir varios pares de sustitución separados por un espacio. Los pares múltiples se utilizan secuencialmente: el resultado del primer par se utiliza como entrada para el segundo par y así sucesivamente.


¿Qué significa «Descartar datos no correspondientes»?

De forma predeterminada, todo texto que no forma parte de la cadena de correspondencia pasa sin sufrir ningún cambio. Si marca Descartar datos no correspondientes, entonces solo se envía la cadena resultante de la sustitución.


¿Cuáles son los caracteres especiales de escape?

Los siguientes caracteres tienen un significado especial en las cadenas de búsqueda y reemplazo:

            ˆ  . , (  )  [  ] $ \ / * + |

Si desea incluir alguno de estos caracteres en la cadena de búsqueda o reemplazo, deberá ir precedido del carácter de barra invertida \. Para incluir un carácter de barra invertida, introduzca \\. Para introducir un carácter ASCII arbitrario, introduzca \xhh, donde hh es el valor del carácter hexadecimal (no puede usar \ooo para especificar valores ASCII octales).


¿Cómo utilizo un comodín para representar distintos caracteres o patrones?

Puede representar un solo carácter, cualquier carácter de un conjunto de caracteres, cualquier carácter de un intervalo de caracteres o cualquier carácter que no esté dentro de un intervalo de caracteres utilizando los siguientes caracteres especiales en la cadena de búsqueda:

. Para representar cualquier carácter

[abcd...] para representar cualquier carácter del conjunto de caracteres a, b, c, d ...

[a-z] para representar cualquier carácter dentro del intervalo de caracteres a - z (se pueden utilizar letras o números)

Para invertir el significado de un comodín utilizando un conjunto de caracteres, debe preceder el carácter con el carácter ^.

Para representar un número variable de caracteres, añada uno de los siguientes caracteres modificadores al carácter o al comodín en cuestión:

+ representa uno o más del carácter precedente

* representa cero o más del carácter precedente

? representa cero o uno del carácter precedente

{n} representa n instancias del carácter precedente

{n,m} representa al menos n instancias, pero menos que m del carácter precedente

{n,} representa al menos n instancias del carácter precedente

Algunos ejemplos de correspondencia de comodines:

/A.B/AB/g elimina cualquier carácter entre «A» y «B» en la cadena de entrada

/A.*B/AB/g elimina cualquier número de caracteres entre «A» y «B» en la cadena de entrada


¿Existen comodines para representar caracteres especiales?

Utilice las siguientes secuencias de escape para representar caracteres especiales y tipos de caracteres:

\n un carácter de nueva línea

\w un carácter alfanumérico (letra o dígito)

\W un carácter no alfanumérico

\s un carácter de espacio

\S un carácter distinto a un espacio

\d un dígito

\D un carácter distinto a un dígito

Puede utilizar estos caracteres junto con los comodines de correspondencia de múltiples caracteres enumerados previamente.


¿Cómo fijo la cadena de búsqueda?

Preceda la cadena de búsqueda con ^ para limitar la correspondencia al principio de la cadena. Preceda la cadena de búsqueda con $ para limitar la correspondencia al final de la cadena.


¿Cómo puedo reutilizar parte de la cadena de búsqueda en la cadena de resultados?

Coloque la parte o las partes de la cadena de búsqueda que desee utilizar en la cadena de resultados entre paréntesis. Puede hacer referencia a las cadenas adjuntas a la cadena de resultados utilizando las marcas \1, \2 y así sucesivamente.


¿Existe un tamaño máximo para las expresiones regulares estilo Perl?

El tamaño máximo de la secuencia de comandos introducida en cualquiera de las pestañas es de 512 caracteres, pero la pestaña específica de los símbolos se ejecutará antes que la pestaña universal. Si ambas se utilizan simultáneamente, se puede escribir una secuencia de comandos de hasta 1024 caracteres.


¿Dónde puedo obtener más información acerca de las expresiones regulares estilo Perl?

Aquí. Tenga en cuenta que el lector no implementa todas las funciones descritas en esta página.


Entradas / Salidas


¿Por qué aparecen en gris las opciones de acción al pulsar el botón 3 segundos?

Puede elegir la funcionalidad de pulsación del botón de disparo solo en los modos de disparo Único, Ráfaga y Auto.

Tenga en cuenta que la opción de Modo de prueba solo se activa (es decir, se puede seleccionar) si todas las demás opciones encima de ella (desde Optimizar intensidad de la luz hasta Definir cadena de correspondencia) no están seleccionadas.


¿Para qué sirve la casilla Desactivar botón del lector en la pestaña del botón TRIG?

Si marca Desactivar botón de lector, el lector ya no inicia una lectura, un ajuste o un intento de aprendizaje cuando se pulsa el botón del lector. Tenga en cuenta que esta función no desactiva el botón de disparo de la barra de botones de la herramienta de configuración ni el comando de disparo en serie.


¿Qué acciones puedo configurar si mantengo pulsado el botón de disparo durante 3 segundos?

En los modos de disparo Único, Ráfaga o Auto podrá establecer la forma en la que debería reaccionar el lector al pulsar el botón durante 3 segundos. Si selecciona más opciones, la funcionalidad se ejecutará según el orden listado.

Al mantener pulsado el botón de disparo durante 3 segundos puede:

  • Optimizar la intensidad de la luz en las imágenes adquiridas si estas operaciones están admitidas en el modo de disparo actual

  • Lea un código de configuración del documento Códigos de configuración

  • Enfoque automáticamente el módulo de la lente líquida si corresponde

  • Someter el lector al aprendizaje de los símbolos esperados para símbolos sucesivos

  • Definir una cadena correspondiente si se está llevando a cabo la validación de cadena de correspondencia

  • Ponga el dispositivo en modo de prueba

Mantener pulsado el botón de disparo tiene el mismo efecto que usar el botón de disparo de la barra de botones de la herramienta de configuración.


¿Para qué sirve la casilla Desactivar botón del lector en la pestaña del botón TUNE?

Si marca Desactivar botón de lector, el lector ya no inicia una lectura, un ajuste o un intento de aprendizaje cuando se pulsa el botón del lector. Tenga en cuenta que esta función no desactiva el botón de disparo de la barra de botones de la herramienta de configuración ni el comando de disparo en serie.


¿Qué hace la acción de cada línea de entrada en la pestaña Entradas?

Utilice la configuración Acción de línea de entrada para configurar qué acción llevará a cabo el lector. De forma predeterminada, el lector no responde a una señal de línea de entrada 1, 2 ó 3. Solo se pueden usar las líneas de entrada 0 y 1 para la señal de disparo.

Las acciones de la línea de entrada Aprender código, Optimizar intensidad de la luz, Aprender cadena de correspondencia y Leer código de configuración solo se llevan a cabo tras el próximo disparo.

Puede configurar el lector para que lleve a cabo una de las siguientes acciones:

  • Disparo ACTIVADO y Disparo DESACTIVADO están activadas de forma predeterminada en la misma línea de entrada. Disparo DESACTIVADO será el contrario de Disparo ACTIVADO, de forma automática. Si coloca las dos señales en líneas separadas, podrá configurar la polaridad de forma independiente, según se ajuste a sus necesidades.

  • Codificador significa que conectará su codificador a esta línea de entrada.

  • Aprender código significa que el aprendizaje del lector se produce con la simbología esperada, que puede reducir el tiempo que necesita para decodificar símbolos sucesivos.

  • Optimizar intensidad de la luz significa que el lector encuentra la mejor configuración posible para la luz y para el generador de imágenes para poder leer un código.

    NOTA: Optimizar intensidad de la luz no funciona si una de las dimensiones de la RoI es más pequeña que 144.

  • Aprender cadena de correspondencia significa que el código decodificado será aquel contra el que se corresponderán y validarán los códigos sucesivos.

  • Optimizar enfoque (solo para lectores con lente líquida) significa que el lector encuentra la mejor configuración de enfoque posible para la lectura de un código.

  • Leer código de configuración significa que el lector debería considerar el código que debe leer no como una imagen, sino como un comando de configuración, reduciendo por lo tanto la cuenta de disparo y sin producir una imagen no leída.

  • Ajustar significa que el lector encuentra la mejor configuración posible para la lectura de un código.

    NOTA: Ajustar no funciona si una de las dimensiones de la RoI es más pequeña que 144.

  • Permitir almacenamiento de imágenes no leídas significa que puede almacenar incluso las imágenes no leídas si así lo desea, por ejemplo, para averiguar por qué hubo imágenes no leídas.

  • Borrar salidas significa que si se establece esta acción, se restablecerán inmediatamente todas las salidas si se acciona la entrada. Esta opción no restablece ninguna configuración de retraso de salida.

    NOTA: Si se establece Borrar salidas para una de las entradas y se establece una acción de Lectura en la pestaña Salidas para una de las salidas y la duración de la Duración del impulso para esta salida se establece en un valor distinto a cero, la salida seguirá activa hasta que finalice el tiempo de la duración del impulso, independientemente de que se active o no la entrada en el tiempo de la duración del impulso establecido.

  • Polaridad significa que si se establece la polaridad, se producirá un cambio en la señal que activa una adquisición de imagen

  • Retraso de rebote define cuánto tiempo debe detectarse la señal de activación para que se reconozca como válida.


¿Qué configuración de detección de disparo puedo modificar?

Use la opción Polaridad para configurar la modificación en la señal que activa una adquisición de imagen.

Use el cuadro de texto Retraso de rebote para definir la cantidad de tiempo necesaria para detectar la señal de disparo para que sea reconocida como válida. Utilice un valor más bajo para compensar por el ruido de la línea ESD y valores más elevados para compensar por el ruido en los relés electromecánicos. Podría tener que experimentar con la configuración para elegir el valor más adecuado para su entorno de producción.


¿Qué tiempo de rebote se puede establecer?

El tiempo de rebote mínimo es 0. Si se aumentan los números, aumentará el tiempo de rebote. El valor máximo es 6.


¿Qué opciones puedo configurar en la pestaña Salidas?

La pestaña Salidas le permite configurar el comportamiento de todas las líneas de salida disponibles para el lector. Para cualquier línea puede configurar el acontecimiento y la acción de la línea de salida.

Para la condición de no lectura, también puede especificar una cadena determinada que se transmita cuando no se pueda leer un código.


¿Cuándo se realiza la acción seleccionada?

Cuando se marca la casilla de verificación, la acción asignada a una entrada no sucede inmediatamente después de activar la entrada. Solo tiene lugar cuando se realiza el siguiente disparo.


¿Qué es la opción Permitir almacenamiento de imágenes no leídas?

Cuando esta entrada está activa y conectada a, por ejemplo, un sensor de detección de paquetes, aunque se pueda aplicar el almacenamiento para todas las imágenes, las imágenes no leídas solo se almacenarán cuando el sensor emita una señal para la entrada en particular. Como resultado, el lector solo almacenará las imágenes no leídas cuando el sensor verdaderamente detecte un paquete. Esta opción solo funciona con el modo de disparo Continuo.


¿Cómo puedo establecer la duración del pitido para las lecturas correctas?

Seleccione la opción Activar alerta sonora cuando la lectura sea correcta en la pestaña Salidas. Después, configure la Duración del pitido con un valor entre 0 y 50 ms.


¿Para qué puedo utilizar la configuración Duración de impulso de anillo luminoso?

Para los lectores con anillo luminoso, la duración del estado iluminado del anillo puede especificarse en milisegundos.


¿Cómo genero un evento con resultado correcto de validación de datos?

Si está activada la validación de datos, el evento de lectura solo será señalado si se leyó un código y la validación fue correcta. Con los eventos de lectura y no lectura asignados a dos salidas se aplica la siguiente lógica:

  1. lectura correcta, validación correcta: Salida de lectura

  2. lectura correcta, validación incorrecta: sin salida

  3. lectura incorrecta: Salida de lectura incorrecta

Alternativamente, puede asignar el evento con resultado incorrecto de validación a una salida.


¿Cómo puedo saber lo que significa la luz de error en el dispositivo?

Seleccione Sistema->Mostrar registro del dispositivo y compruebe el registro para encontrar esta información.


¿Cómo puedo reiniciar el lector?

Escanee el comando Reiniciar el escáner impreso al final de la guía de referencia rápida para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y reinicia.

Escanee el comando Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.


¿Puedo cerrar una línea de salida para un período de tiempo indefinido?

Puede cerrar una línea de salida de forma indefinida al especificar una duración de impulso de 0 milisegundos, pero tenga en cuenta que cualquier evento que dispare esta línea de salida provocará que se mantenga cerrada hasta que encienda el lector o borre salidas con una configuración de entrada discreta.


¿Qué significa Abierta y Cerrada en el campo Acción?

El estado de abierto o cerrado hace referencia al estado del relé. Si se produce un evento de la lista anterior, la salida puede estar abierta o cerrada. Por ejemplo, si se produce un evento de lectura, en el caso de Cerrada, la salida 0 pasará a ser 1. Asimismo, puede cerrar una línea de salida de forma indefinida especificando una duración de impulso de 0 milisegundos, pero tenga en cuenta que cualquier evento que active esta línea de salida provocará que se mantenga cerrada hasta que encienda el lector o borre salidas con una configuración de entrada discreta.


¿Por qué están desactivadas todas las opciones en una columna de salida en particular?

Las opciones estarán desactivadas si selecciona Estroboscópica, la cual usa esta línea de salida reservada en cualquier configuración de lectura activa.


¿Qué es la sobrecarga del disparador?

La sobrecarga del disparador implica que puede que no se pueda adquirir la imagen debido a que la cámara estaba demasiado ocupada (por ejemplo, debido a una ráfaga en curso o a una exposición larga).


¿Qué es el desbordamiento de la memoria intermedia?

El desbordamiento de la memoria intermedia conlleva que se podría adquirir una imagen, pero que no queda espacio para guardarla. En otras palabras, las imágenes se adquieren más rápido de lo que pueden procesarse. Una posible situación se produce cuando la decodificación lleva más tiempo que el valor del intervalo imagen/disparo.


¿Qué transmite el lector cuando no se lee ningún código?

Normalmente, el lector no transmite ningún dato si no puede leer ningún código. Puede enviar una cadena determinada de hasta 32 caracteres especificando una Cadena no leída. Haga clic en el nodo Configuración del sistema, introduzca la cadena en el campo Cadena de salida no leída y pulse <Intro>.


¿Qué es la opción Estroboscópica?

Puede reservar una salida para la iluminación externa si selecciona la opción Estroboscópica en una de las líneas de salida. También puede configurar la polaridad si elige Abierta o Cerrada en la columna de salidas apropiada.


¿Cómo puedo establecer el Retraso de salida?

Puede especificar el tiempo de retraso de salida y establecerlo en ms. También puede especificar el retraso de salida relativo al Inicio del disparo o al Fin del disparo.

Nota: Si el retraso de salida es más corto de lo que necesita el lector para adquirir y decodificar una imagen para obtener resultados, la herramienta de configuración puede no recibir imágenes de resultados del lector.


¿Cómo puedo usar el retraso de salida y el retraso del disparo?

Ambos disparos se relacionan con el borde del disparador físico y no con el inicio con retraso de la adquisición de imágenes (si se ha configurado retraso del disparo).


¿Por qué no se puede configurar el retraso de salida?

Solo puede configurar el retraso de salida en los modos de disparo Manual, Único, Ráfaga y Continuo.


¿Qué líneas de salida digitales se ven afectadas por el retraso de salida?

Todas las acciones basadas en los siguientes eventos:

  • lectura/no lectura

  • error de validación

se ven retrasados. Las siguientes líneas de salida se ven afectadas:

  • configuración de cualquier salida digital

  • cualquier transferencia de datos a través de RS-232, Ethernet o USB

  • iluminación de los LED

  • hacer sonar el pitido


¿Qué es la Distancia hasta la salida?

Al usar un codificador de pulsos, puede especificar la distancia hasta la salida y asignar el pulso a la distancia. El valor de la distancia hasta la salida se corrige según el valor de la resolución (se ajusta hasta el múltiplo más cercano de la resolución redondeado en milímetros).

En la pestaña Retraso de salida, utilice el control de Distancia hasta la salida (mm) para establecer la distancia entre el disparo y el momento de salida del resultado.

En la pestaña Codificador de pulsos, utilice el control de resolución (mm) para definir la resolución.


¿Qué es el Codificador de pulsos (encoder)?

Para los modos de disparo externos, puede utilizar un codificador para controlar la temporización de la salida de cadenas de datos. Normalmente, los codificadores se encuentran instalados en una cinta transportadora y, a medida que esta se mueve, el mango del codificador rotará y emitirá pulsos eléctricos para indicar su rotación angular. La medida de la rotación del codificador es directamente proporcional a la distancia recorrida por la cinta transportadora.

Conecte su codificador a las líneas de entrada 1 ó 2. La línea de entrada que elija se utilizará exclusivamente para el codificador. Para cualquier otra acción, seleccione otra línea de entrada.

También puede conectar un codificador (encoder) a un lector principal en un grupo de Sincronización de múltiples lectores.


¿Qué configuración puedo establecer para el codificador de pulsos?

Puede especificar la distancia hasta la salida y asignar el pulso a la distancia. El valor de la distancia hasta la salida se corrige según el valor de la resolución (se ajusta hasta el múltiplo más cercano de la resolución redondeado en milímetros).

En la pestaña Retraso de salida, utilice el control de Distancia hasta la salida (mm) para establecer la distancia entre el disparo y el momento de salida del resultado.

En la pestaña Codificador de pulsos, utilice el control de resolución (mm) para definir la resolución.


¿Por qué cambiar el nombre del dispositivo?

Puede dar al dispositivo un nombre con más sentido en relación a su entorno de producción, como, por ejemplo, la localización o la tarea de inspección. Utilice el campo Nombre del dispositivo en la pestaña Avanzado.


¿Qué puedo agregar a la descripción del dispositivo?

Descripción del dispositivo es un campo de texto editable en la pestaña Avanzado que le permite agregar notas al dispositivo o información adicional que considere importante.


¿Cómo cambio el nombre del dispositivo?

Para cambiar el nombre del dispositivo:

  1. Introduzca un nuevo nombre para el dispositivo en Nombre del dispositivo.

  2. Aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí».

  3. Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su dispositivo.

La próxima vez que inicie la herramienta de configuración o haga clic en Actualizar en el panel Conectar al lector, reflejará el nuevo nombre del dispositivo.


¿Qué puedo establecer con la configuración Duración del impulso del LED de error?

Puede mover el control al número de milisegundos deseado que se utilizará para determinar cuánto tiempo durará el impulso del LED de error en dispositivos de montaje fijo. Los LED de error se encuentran en la parte superior del dispositivo. Si el control se establece en «0», el LED de error rojo se apagará si se recupera el registro del dispositivo, mientras que si se establece en cualquier valor por encima de «0», el LED de error rojo se apagará automáticamente una vez haya transcurrido el tiempo seleccionado.


¿Qué es un mensaje de activación?

Si la función Cadena de diagnóstico de salida al activar está activada, el lector transmitirá una cadena de diagnóstico cuando el lector se inicie.

Para las conexiones de Telnet el lector transmitirá la cadena de diagnóstico con cada nueva conexión. Para conexiones de serie, la velocidad en baudios se establece automáticamente a 38 400 cuando se envía el mensaje, independientemente de la configuración efectuada en la herramienta de configuración.


Comunicaciones


¿Puedo utilizar un comando de disparo en serie que tenga más de un carácter?

Los comandos de Disparo ACTIVADO y Disparo DESACTIVADO admiten un límite de caracteres con una secuencia resultante que puede tener, como mucho, 32 bytes. Dependiendo de cuántas secuencias de escape utilice, esto significa que la longitud válida de la cadena aceptable puede variar entre 32 caracteres (sin secuencias de escape) y 128 (32 * secuencias de escape de 4-caracteres [p.ej. \002]) caracteres.


¿Qué hace la función de activar comandos de eco?

Cuando está activada, los comandos de eco devolverán los comandos que envía al lector tan pronto como se reciba el comando, delimitado por las cadenas de Encabezado del comando y Pie de página del comando.


¿Por qué no puedo probar mi comando de disparo o los comandos de eco en un programa de terminal?

Los comandos personalizados se proporcionan para ser utilizados por un dispositivo PLC o similar y no para ser introducidos manualmente. El tiempo entre caracteres se fija en un valor pequeño, apenas 50 ms, de modo que al teclear lentamente un comando personalizado no será reconocido hasta después de introducir el primer carácter. Debe enviarse un comando de Disparo ACTIVADO o Disparo DESACTIVADO mayor que un único carácter como cadena desde otra aplicación.


¿Qué puedo configurar en el paso de aplicación Comunicaciones?

En las tres pestañas del paso de aplicación Comunicaciones, se puede implementar la configuración de Ethernet y serie. Haga clic en la pestaña adecuada para introducir los valores de configuración.

En la pestaña Avanzado, puede introducir más configuraciones en una vista de tabla.


¿Cómo puedo cambiar la configuración del puerto serie del lector?

Introduzca la nueva configuración en la pestaña Serie del paso de aplicación Comunicaciones. También puede escanear el documento Códigos de configuración (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración).


¿Qué es la función Multipuerto (RS-232 compartido)?

Este modo de conexión permite que varios lectores DataMan (del mismo tipo) compartan una única conexión en serie a un PC u otro dispositivo equipado con un puerto serie. Una conexión multipuerto crea una cadena margarita de lectores. Cada lector recibe datos serie del lector anterior y los transmite al siguiente lector. Cuando un lector transmite datos, estos pasan a través de cada uno de los lectores de la cadena entre aquel y el PC.

Deberá construir su propio cable, que debe cumplir con los requisitos de la configuración de su sistema. El cable debe contar con un conector DB-15 para cada dispositivo DataMan y un conector DB-9 para el puerto serie del PC. Cada conector DB-15 debe contar con clavijas para transmisión de datos (Tx Data), recepción de datos (Rx Data), disparo (entrada 0), masa y alimentación CC. Las clavijas de transmisión de datos y recepción de datos de los conectores adyacentes deberán estar conectadas para proporcionar la conexión multipuerto.

Deberá conectar cada dispositivo DataMan a la herramienta de configuración DataMan mediante una conexión USB y configurar el DataMan para el funcionamiento multipuerto. Para configurar un dispositivo para el funcionamiento multipuerto, haga clic en la casilla de Activar multipuerto (RS-232 compartido).

Para obtener más información acerca del funcionamiento multipuerto, consulte el capítulo Conexiones multipuerto en el Manual de referencia correspondiente. La función de compartir multipuerto tiene los siguientes funcionamientos y limitaciones:

  • Cada lector de la cadena puede conectarse igualmente al PC o a otro dispositivo a través de una conexión USB.

  • Cada lector de la cadena debe recibir su propia señal de disparo. DataMan no admite el disparo en serie.

  • Cada lector de la cadena debe configurarse por separado.

  • Los datos de cada uno de los lectores llegan sin ordenar ni filtrar al PC o a otro dispositivo.


¿Cómo establezco la configuración de red del lector?

Si utiliza un lector inalámbrico DataMan 8000, establezca la configuración de red en la estación base. Si está usando un lector con cable, utilice la pestaña Red para establecer la configuración de red.

Seleccione la opción Usar servidor DHCP para hacer que el servidor DHCP asigne una dirección IP al lector (si hay alguna disponible), o introduzca la configuración de red de forma manual. Póngase en contacto con su administrador de red para obtener un valor apropiado.

Cuando cambie la configuración, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


Copiar configuración de red del PC

Si hace clic en el botón Copiar configuración de red del PC, en el menú desplegable, puede seleccionar Dell GigabitEthernet, Bluetooth Device, Microsoft Wi-Fi Direct Virtual Adapter, Dell Wireless 1560 802. 11ac. La configuración de red de su PC se copiará en los campos mencionados.


¿Que hace la configuración Retraso entre caracteres?

Esta configuración aplica los milisegundos especificados como retraso entre cada uno de los caracteres leídos en el modo de lectura de teclado/caracteres. Esta configuración es práctica cuando se pierden algunos de los caracteres leídos debido a la velocidad de las lecturas subsiguientes.


Protocolos industriales

Protocolo de EtherNet/IP

Para permitir que el lector utilice el protocolo de EtherNet/IP, marque la opción EtherNet/IP en el cuadro Protocolos industriales de la pestaña Ethernet.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie su lector.

Protocolo PROFINET

Para permitir al lector utilizar el protocolo PROFINET, marque la opción PROFINET. Haga clic en la casilla Usar nombre de la estación para introducir el nombre de la estación.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie su lector.

Protocolo SLMP

Para permitir al lector utilizar el protocolo SLMP, marque la opción Protocolo SLMP y configure los parámetros según sea necesario.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie el lector para que tenga efecto la configuración, apagando y encendiéndolo o escaneando el símbolo Restablecer.

Modbus TCP

Para permitir al lector utilizar el protocolo Modbus TCP, marque la opción Modbus TCP y configure los parámetros según sea necesario.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie el lector para que tenga efecto la configuración, apagando y encendiéndolo o escaneando el símbolo Restablecer.

Selección EtherNet/IP, PROFINET, Protocolo SLMP o Modbus TCP marcada en gris

Solo se puede usar un protocolo industrial de Ethernet en cada momento. Cuando se seleccione un protocolo, el otro no estará disponible.


Campo Estado en Protocolos industriales

El campo Estado de los protocolos industriales muestra el último mensaje registrado del cuadro de diálogo Estado. El mensaje se visualizará hasta que se registre otro mensaje. Si no se ha activado ningún protocolo industrial, el campo Estado permanece en blanco.

Los mensaje de estado varían en función del protocolo, y algunos protocolos no registran ningún mensaje. Consulte la página 110, Estado de los protocolos industriales, de la Guía de comunicaciones y programación del dispositivo DataMan para obtener más información sobre los mensajes y los protocolos que los emiten.


Modbus TCP: configuración Tiempo de espera

Tiempo de espera inactivo es la cantidad de tiempo que un puerto se mantiene abierto sin tráfico saliente. Una vez que el lector abre una conexión con un servidor FTP, el lector mantiene dicha conexión abierta mientras haya tráfico.

Si no hay tráfico en el periodo establecido como Tiempo de espera inactivo, se cierra la conexión. Esto puede ser útil si la transferencia por FTP se realiza únicamente de forma ocasional y no se desea sobrecargar la red manteniendo la conexión abierta.

Debe marcar la casilla Modbus TCP para poder establecer el tiempo de espera inactivo.


¿Cómo utilizo la opción Autenticación?

Cuando la opción Autenticar se encuentre activada, la herramienta de configuración pedirá al usuario una contraseña para la cuenta de administrador cuando se realice un intento de conectarse a un lector o estación base disponible a través de la red.


¿Cómo establezco una conexión TCP/IP?

El lector permite conexiones TCP al puerto 23, que es el puerto TCP por defecto para las aplicaciones de Telnet. Si utiliza un cliente de Telnet, el único parámetro que tendrá que proporcionar es la dirección IP del lector. Si utiliza otra aplicación o SDK para conectarse, asegúrese de que utilice la misma configuración de puerto TCP que su lector. El puerto TCP puede cambiarse en el panel de Telnet. El lector transmitirá automáticamente el código a través de esta conexión. También puede transmitir los comandos de control de DataMan (DMCC) a través de esta conexión.

Cuando cambie el puerto de Telnet, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


¿Qué es un Cliente de red?

El comportamiento Cliente de red es la forma mediante la cual el lector ID DataMan abrirá activamente una conexión de Ethernet con otro dispositivo en la red. Una vez abierta, la conexión tendrá el mismo comportamiento operativo básico que la conexión Telnet DataMan; puede producir resultados de lectura (transmitir los resultados al dispositivo externo) y puede actuar como servidor DMCC (procesar comandos recibidos desde el dispositivo externo).


¿Qué es un host?

El dispositivo host es el dispositivo de la red al que se conectará el DataMan. Especifique la dirección Ethernet y el número de puerto del dispositivo host. La dirección puede ser un nombre de dominio completamente cualificado (por ejemplo, «servidor.mired.com») o una dirección IP con formato con notación decimal con punto (por ejemplo, «192.169.0.1»).


¿Qué es un puerto de cliente?

El puerto de cliente es el puerto de Ethernet en el lector desde el que se originará la conexión cliente. El valor predeterminado de 0 indica al cliente de red que use cualquier puerto disponible. En casos especiales, puede que tenga que definir un puerto de cliente específico. Solo tiene que configurar el puerto de cliente con el valor requerido. Tenga en cuenta que el caso más típico consiste en usar el valor predeterminado 0. En caso de duda, use el valor predeterminado.


¿Cómo establezco una conexión?

El cliente se conectará según el valor elegido para la opción Abrir conexión. Las opciones disponibles son conectarse cuando se encienda el dispositivo DataMan o hacerlo tan pronto como haya actividad de datos (es decir, conectarse cuando se lea un código).


¿Cómo cierro la conexión?

Hay dos opciones disponibles para Cerrar conexión. La conexión puede quedar abierta para siempre o puede cerrarse una vez se haya completado la transferencia de datos. Si elige la opción Tras la transferencia de datos del lector, también podrá establecer un número de segundos tras el cual la conexión se cerrará si el lector permanece inactivo durante dicho período de tiempo. La duración del período de inactividad se puede ajustar de 1 a 3 600 segundos.


¿Cuál es el tiempo de espera de la conexión?

El tiempo de espera de la conexión es la cantidad de tiempo (en milisegundos) que el DataMan esperará a que se abra la conexión. Tenga en cuenta que si se elige la opción en encendido, el lector reintentará abrir la conexión continuamente.


¿Qué es el tiempo de reconexión?

Es la cantidad de tiempo (en milisegundos) que el lector permanecerá en pausa antes de volver a intentar abrir la conexión.


¿Qué es la función Caracteres no imprimibles?

Normalmente, se transmiten los valores de los caracteres no imprimibles sin ser procesados cuando el lector está configurado para comunicaciones COM. Estos valores no son visibles cuando el lector está configurado en modo de decodificador de teclado. Puede configurar el lector para que convierta los caracteres no imprimibles en secuencias de caracteres imprimibles del teclado como <CR> activando la función Traducir caracteres no imprimibles.


¿Qué caracteres no imprimibles se convierten?

Los códigos de caracteres ASCII de ocho bits con valores de 0x00 a 0x1F y a 0x7F se convierten cuando está activada la opción Traducir caracteres no imprimibles. Los caracteres se asignan a un nombre de carácter ASCII, tal y como se listan aquí:

0x00 <NUL>

0x01 <SOH>

0x02 <STX>

0x03 <ETX>

0x04 <EOT>

0x05 <ENQ>

0x06 <ACK>

0x07 <BEL>

0x08 <BS>

0x09 <HT>

0x0A <LF>

0x0B <VT>

0x0C <FF>

0x0D <CR>

0x0E <SO>

0x0F <SI>

0x10 <DLE>

0x11 <DC1>

0x12 <DC2>

0x13 <DC3>

0x14 <DC4>

0x15 <NAK>

0x16 <SYN>

0x17 <ETB>

0x18 <CAN>

0x19 <EM>

0x1A <SUB>

0x1B <ESC>

0x1C <FS>

0x1D <GS>

0x1E <RS>

0x1F <US>

0x7F <DEL>


¿Qué sucede si activo la opción Traducir caracteres no imprimibles?

Este parámetro solo afecta al propio contenido de códigos. Cualquier formato adicional como el encabezado y el pie de página permanecen inalterados. Esto es así para conservar la capacidad de usar caracteres de control en combinación con este parámetro, por ejemplo, para poder introducir saltos de línea entre códigos o para pasar a la siguiente celda en una hoja de cálculo.


¿Qué se transmite si un código contiene caracteres no imprimibles?

Normalmente, se transmiten los valores de los caracteres no imprimibles sin ser procesados. Puede configurar el lector para que convierta los caracteres no imprimibles en secuencias de caracteres imprimibles como <CR>. Vaya al panel Caracteres no imprimibles y marque la opción Activado.


Reparación y asistencia


¿Qué es Reparación y asistencia?

La página Reparación y asistencia puede utilizarse para establecer la configuración de red de un dispositivo de red con una configuración errónea o cambiar el modo HID de un dispositivo serie a CDC.


¿Para qué se utiliza la opción Actualizar?

Haga clic en el botón Actualizar para actualizar la lista de dispositivos disponibles.


¿Cómo puedo agregar un dispositivo de red a la lista de dispositivos mostrados?

Puede agregar un dispositivo de red o editar la dirección IP de un dispositivo ya agregado haciendo clic en Agregar dispositivo de red. Se abre el cuadro de diálogo Agregar dispositivo de red, donde puede proporcionar la dirección IP del dispositivo. Haga clic en Aceptar para guardar los cambios y el dispositivo también aparecerá en la página Conectar.


¿Cómo puedo editar las propiedades de un dispositivo?

Seleccione un dispositivo de la lista de dispositivos para ver las opciones disponibles. En el panel que se abre, puede editar la configuración de red del dispositivo seleccionado así como establecer una opción de autenticación. Haga clic en Aplicar para guardar los cambios.


DataMan series 60, 300, 503, 8000 y estación base DataMan 8000: ¿cómo puedo utilizar la opción Agregar dispositivo?

La opción Agregar dispositivo le permite añadir el DataMan de forma manual a la lista de dispositivos de red de modo que pueda conectar el lector o la estación base DataMan a la herramienta de configuración a través de la red Ethernet, en lugar de usar un puerto de comunicaciones en el PC.

Debe tener la dirección IP del lector o de la estación base para utilizar la opción Agregar dispositivo. Siga el siguiente procedimiento para averiguar la dirección IP asignada actualmente al lector o a la estación base:

  1. Conecte el lector o la estación base a la herramienta de configuración mediante una conexión RS-232 en el PC (puerto COM de la herramienta de configuración).

  2. Seleccione la pestaña Red bajo la Configuración de comunicación.

  3. Copie la dirección IP que aparece.

  4. Vuelva al panel Conectar al lector y haga clic en Desconectar.

  5. Haga clic en Agregar dispositivo.

  6. Pegue aquí la dirección IP para el DataMan.

Una vez completados los campos Nombre y Dirección IP haga clic en Aceptar. El lector o la estación base deberían aparecer en la lista de dispositivos DataMan accesibles en la lista dispositivos de red de forma que ahora podrá conectar la herramienta de configuración al lector o a la estación base a través de la red Ethernet.

Tenga en cuenta que la función Agregar dispositivo almacena el nombre del lector o de la estación base en el equipo local y no será visible para otros equipos que estén ejecutando la herramienta de configuración.


¿Para qué se utiliza el icono Exportar?

Si se hace clic en el icono Exportar archivo de asistencia de Cognex, se inicia la generación del archivo de asistencia de Cognex, que genera un archivo .zip con una serie de registros de datos predefinidos. Esta función solo está disponible si se selecciona al menos un dispositivo.

Al hacer clic en el botón, se abre un cuadro de diálogo donde puede especificar en una lista de casillas los tipos de datos que se incluirán en el archivo .zip de asistencia:

  1. Cfg

  2. Cdc

  3. Última imagen

  4. Dispositivos descubiertos

  5. Estadísticas del dispositivo

  6. Estadísticas de memoria

  7. Comentario del usuario (puede ser editado manualmente por el usuario)

La carpeta de destino del archivo de asistencia puede modificarse mediante el icono «...». Una vez generado el archivo, puede seleccionar abrir su carpeta contenedora o bien enviarlo como adjunto con el cliente de correo electrónico predeterminado (.eml).

El resultado del proceso es un archivo .zip. El nombre de archivo contiene el nombre del dispositivo y la fecha de creación. Un descriptor .xml adicional en el zip contiene los datos siguientes:

  1. Fecha

  2. ID de descubrimiento

  3. Nombre del dispositivo

  4. Tipo de dispositivo

  5. Número de serie

  6. Dirección MAC

  7. Claves de funciones

  8. Interfaz de comunicación

  9. Versión de firmware

  10. Lista de archivos presentes en el zip


¿Qué hace el botón Agregar dispositivo virtual?

Esta función permite crear un dispositivo virtual basado en un archivo de configuración personalizada o un dispositivo con configuración predeterminada. Puede utilizarse para examinar distintos paneles en la herramienta de configuración sin la necesidad de conectar un dispositivo. Al pulsar el botón, se inicia un asistente que le guiará a través de los pasos necesarios para crear un dispositivo virtual. Las opciones iniciales son utilizar un archivo de configuración/de copia de seguridad para la creación o utilizar la configuración predeterminada de fábrica.

Una vez finalizado el asistente, se agrega un nuevo dispositivo virtual a la lista de dispositivos descubiertos, indicado por un icono de dispositivo virtual. El dispositivo virtual creado no es visible para los demás dispositivos de la red. El dispositivo virtual persiste durante varias instancias de la herramienta de configuración.

El dispositivo virtual creado puede conectarse del mismo modo que un dispositivo normal, pero todos los cambios de configuración son rechazados (todo es de solo lectura) y las características, funciones y acciones no funcionan en los dispositivos virtuales.


Copia de seguridad


¿Cómo puedo utilizar la función Copia de seguridad?

Usando esta función puede generar un archivo de copia de seguridad con la configuración y los registros de uno o más lectores haciendo clic en el botón Copia de seguridad en la parte inferior derecha (o pulsando Alt+B). Esta función solo está disponible si se selecciona al menos un dispositivo.

Si se hace clic en el botón Abrir carpeta de copia de seguridad, se abrirá la carpeta donde están guardados los archivos de copia de seguridad. Puede establecer la carpeta en Inicio->Opciones->Copia de seguridad->Ubicación de copia de seguridad.

Si se han seleccionado varios dispositivos, cada dispositivo generará un archivo de copia de seguridad. Cada archivo de copia de seguridad se guarda en una subcarpeta que coincide con el nombre del dispositivo. El nombre del archivo de copia de seguridad contiene el nombre del dispositivo y la fecha de generación.

El archivo de copia de seguridad es un archivo .zip con extensión .dmb. El archivo contiene: config.cdc, config.cfg y descriptor.xml. El xml contiene los datos siguientes:

  1. Fecha

  2. ID de descubrimiento

  3. Nombre del dispositivo

  4. Tipo de dispositivo

  5. Número de serie

  6. Dirección MAC

  7. Claves de funciones

  8. Interfaz de comunicación

  9. Versión de firmware

  10. Lista de archivos presentes en el zip


¿Cómo puedo establecer la carpeta de copia de seguridad para la función Copia de seguridad?

Puede establecer la carpeta en Inicio->Opciones->Copia de seguridad->Ubicación de copia de seguridad.


Restaurar


¿Cómo puedo utilizar la función Restaurar?

La función Restaurar permite restaurar los archivos de configuración de copia de seguridad a uno o más dispositivos. Esta función solo está disponible si se selecciona al menos un dispositivo y si se especifica un origen de configuración válido.

En Origen de configuración en la parte superior, puede especificar la herramienta de configuración de origen que se utilizará para la restauración:

  1. Archivo de configuración: al seleccionar esta opción, la herramienta de configuración utiliza el archivo de configuración especificado para la restauración. Haga clic en botón «...» para especificar la carpeta que contenga el archivo de copia de seguridad que desee utilizar. Consulte las preguntas y respuestas que encontrará en Copia de seguridad para obtener más información sobre cómo establecer la carpeta.

    Nota: el botón Restaurar solo se activa si se selecciona como destino un dispositivo compatible.

  2. Dispositivo: al seleccionar esta opción, la herramienta de configuración utiliza un único dispositivo especificado para restaurar su configuración a todos los dispositivos de destino.

  3. Copia de seguridad más reciente: al seleccionar esta opción, la herramienta de configuración busca la copia de seguridad más reciente para el dispositivo seleccionado. Si se han seleccionado varios dispositivos, se aplicará a cada uno de los dispositivos su copia de seguridad más reciente.

  4. Valores predeterminados de fábrica: al seleccionar esta opción, la herramienta de configuración restaura su configuración a los valores predeterminados de fábrica.

Una vez seleccionado el origen, así como el dispositivo (o dispositivos) de destino, haga clic en el botón Restaurar en la parte inferior derecha.


¿Cómo funciona el botón desplegable Restaurar con configuración de red?

Restaurar con configuración de red funciona del mismo modo que el botón Restaurar, pero restaura la configuración del archivo .cdc contenido en la carpeta de copia de seguridad en lugar del archivo .cfg. Esta opción solo está activa si hay un .cdc disponible en el origen especificado y como destino se ha seleccionado un solo dispositivo.


Actualizar firmware


¿Cómo actualizo el firmware del lector?

Seleccione Sistema->Actualizar firmware... y, a continuación, seleccione el archivo de firmware.

Nota: los archivos de firmware se suministran como archivos comprimidos. El firmware se debe cargar en su forma comprimida; no intente descomprimir un archivo de firmware antes de cargarlo.


¿Cómo puedo utilizar la función Actualizar firmware?

Esta función actualiza el dispositivo o dispositivos seleccionados a la versión de firmware deseada. Seleccione el dispositivo o dispositivos que quiera actualizar en la lista de dispositivos.

Busque los archivos de firmware haciendo clic en el icono «...». Si se selecciona un dispositivo concreto en la lista de dispositivos, se abrirá la carpeta de firmware correspondiente para ese dispositivo. Si se seleccionan varios dispositivos, pero tienen el mismo ID de dispositivo de firmware, se abrirá la carpeta correspondiente. Si no se selecciona ningún dispositivo o se seleccionan varios dispositivos, pero con distintos ID de dispositivo de firmware, se abrirá la carpeta raíz de firmware.

Si se marca la casilla de la parte inferior, la herramienta de configuración realiza una copia de seguridad de los archivos de configuración del mismo modo que la función Copia de seguridad (consulte las preguntas y respuestas sobre copia de seguridad para obtener más información).

Después de seleccionar el archivo de firmware, haga clic en Actualizar firmware en la parte inferior derecha. El botón se activa solo si la versión de firmware seleccionada y la selección de dispositivos son compatibles.

Nota: en el caso de dispositivos serie, deberá descubrirlos primero actualizando manualmente antes de poder actualizar el firmware.


Comparar configuración


Comparar configuración: estructura y diseño general

Comparar configuración es una herramienta a estilo de vista de tabla que permite establecer, copiar, comparar o restaurar configuraciones de dispositivos. El área principal de la página de documento contiene una cuadrícula con las propiedades del dispositivo que se seleccionó antes de su inicialización en la página Conectar al lector.

Cada tipo de documento de la herramienta de configuración utiliza su propia conexión. En el caso de la comunicación serie, solo se puede abrir una conexión a la vez.

La fila de título muestra el nombre o nombres de los dispositivos seleccionados. La segunda fila de títulos debajo de la primera muestra las configuraciones disponibles para el dispositivo. Los títulos de fila inferiores (en negrita) pueden contraerse o abrirse haciendo clic en el icono situado junto a ellos. Si un dispositivo está desconectado, aparece un icono de reconexión en su fila de título.

Las configuraciones que no son dependientes de la configuración de lectura solo se muestran en la primera columna (configuración principal).


Comparar configuración: controles (ratón y teclado)

Selección:

  • Ratón: al hacer clic en una celda de la cuadrícula, se selecciona la celda y se resalta el título de su fila y el título de la/s columna/s a las que pertenecen el dispositivo y la configuración. Los botones de menú y los elementos del menú de la cinta pueden variar en función de la selección. Si la celda seleccionada se encuentra en una fila de título, se seleccionarán todas las celdas de la columna actual que pertenezcan a ese título.

  • Teclado: las teclas de movimiento del cursor permiten mover la selección a la celda apropiada. El funcionamiento en cuanto a resaltado y selección es el mismo que con el ratón.

Agregar/cambiar valores:

  • Ratón: en celdas con editores incorporados, hacer clic en el control del editor (cuadro de combinación, casilla, control numérico arriba-abajo) se podrán introducir valores. En celdas con editores personalizados (icono «...»), se abre un editor emergente que permite introducir valores.

  • Teclado: en celdas con editores incorporados, al pulsar Entrar o F2 se inicia el modo de edición; con Esc se cancela la edición y pulsando Entrar por segunda vez se confirma la edición. Los valores pueden introducirse en el texto seleccionado sin entrar en el modo de edición, en cuyo caso el valor actual se sobrescribirá con la primera tecla que se pulse.

    En las celdas numéricas, además de las celdas con editor de texto incorporado, las flechas arriba y abajo aumentan o disminuyen el valor.

    En celdas desplegables, Entrar inicia el modo de edición y muestra los elementos desplegables, mientras que las flechas arriba y abajo mueven la selección. Pulsando Entrar por segunda vez se aplica el valor seleccionado y con Esc se cancela la edición.

    En las celdas de casilla de verificación, utilice Espacio para alternar entre los estados marcado/no marcado.

Copiar y pegar:

Utilice las combinaciones de teclado Ctrl+C y Ctrl+V para copiar y pegar, respectivamente. Consulte la descripción de copiar-pegar de los elementos de menú de la cinta relacionados para obtener más información.


Comparar configuración: menú de la cinta

El menú de la cinta se encuentra encima de la cuadrícula a estilo de vista de tabla. Sus contenidos e iconos activos pueden cambiar en función de las celdas, filas o columnas que se seleccionen en la cuadrícula. El menú está dividido en varios grupos.

  • Dispositivo: las configuraciones en este grupo están relacionadas con dispositivos y con sus archivos de configuración. Utilice el botón Agregar dispositivo... para abrir un cuadro de diálogo donde podrá seleccionar uno o más dispositivos para agregar a la comparación. El botón Agregar archivo de configuración... abre un asistente donde se puede buscar un archivo de configuración o de copia de seguridad (.dmb, .cdc, .cfg). Si el archivo seleccionado para el dispositivo no contiene toda la información necesaria, deberán establecerse los parámetros que falten; de lo contrario, se seleccionarán automáticamente las opciones predeterminadas. Lo mismo se aplica a los casos en los que la base de datos de dispositivos virtuales no puede establecer correspondencias entre los parámetros y las opciones disponibles (por ejemplo, no se encuentra una versión de firmware coincidente).

    Nota: los dispositivos virtuales agregados son de solo lectura, tal y como indica el icono de candado en su fila de título.

    Si se hace clic en el botón Quitar dispositivo, se quitará el dispositivo o los dispositivos seleccionados actualmente (el que contenga la/s celda/s seleccionada/s actualmente). Reiniciar dispositivo reinicia los dispositivos seleccionados. Configuración persistente en el dispositivo guarda el archivo de configuración del dispositivo seleccionado en su memoria flash. Utilice Restablecer valores predeterminados de fábrica para restablecer el/los dispositivo/s seleccionado/s a sus valores predeterminados.

  • Edición: utilice Copiar (o Ctrl+C en el teclado) para copiar un valor de la celda seleccionada en ese instante. Pegar solo puede utilizarse en la misma fila o en cualquier editor de texto. Restablecer valores permite restablecer el/los valor/es de la/s celda/s seleccionada/s.

  • Resaltado: los botones y configuraciones de este grupo de menú ofrecen opciones para resaltar el fondo de celdas específicas. Con la configuración Valores no predeterminados se resaltan las celdas que tengan valores no predeterminados (puede variar en una misma fila para diferentes dispositivos o configuraciones de lectura). La configuración Distinto de referencia resalta las celdas que tengan valores diferentes a los de la celda de la misma fila en la configuración de lectura (y el dispositivo) de referencia. Si se selecciona la tercera configuración, se resaltarán todos los valores y títulos que contengan el texto especificado en el cuadro de texto. Además, el texto contenido se resaltará con un fondo de texto diferente. Al pulsar Entrar, también se aplica la función del botón Mostrar solo filas resaltadas.

    Al activar Mostrar solo filas resaltadas, se contraerán todos los nodos que no tengan ningún subnodo resaltado. Si se activa Establecer configuración de lectura de referencia, especifica la configuración de lectura (y el dispositivo) que se utilizará como referencia cuando se utilice el modo de resaltado Distinto de referencia. Si el botón está activo, la columna de la celda seleccionada en ese instante (configuración de lectura) pasa a ser la configuración de referencia. La configuración de referencia actual se marca en la fila de título del nombre de configuración.

  • Filtrado: establezca Parámetros de configuración de lectura para ver únicamente las configuraciones dependientes de la configuración de lectura. Establezca Configuración global para ver únicamente configuraciones que no tengan valores distintos en diferentes configuraciones de lectura. Establezca Todas las configuraciones para ver todas las configuraciones al mismo tiempo. Si una entrada tiene valores en más configuraciones de lectura, estos se mostrarán en diferentes columnas.

  • Otros: utilice Expandir todas las filas para expandir todas las filas que se hayan contraído en la cuadrícula. Utilice Contraer todas las filas para contraer todas las filas expandidas de la cuadrícula. Restablecer diseño vuelve a calcular los anchos de columna para utilizar todo el espacio disponible. Si el espacio disponible no es suficiente, se aplica un ancho de columna mínimo.


Comparar configuración: Editor de comparación

Editor de comparación se abre para cada elemento de Secuencias de comandos en la vista de tabla Comparar configuración (en cualquiera de sus subcategorías) después de hacer clic en el icono «...». Una vez abierto, podrá ver en él el origen de las secuencias de comandos del dispositivo en el que se abrió el editor de comparación.

Si se hace clic en Predeterminada, se revertirá la secuencia de comandos a la secuencia de comandos predeterminada para ese dispositivo específico. Si se hace clic en Comparar, se mostrará en la parte derecha la secuencia de comandos predeterminada en el segundo dispositivo; no obstante, puede utilizarse el menú desplegable de la parte superior para cambiar la secuencia de comandos que se comparará con la de la izquierda. En el centro aparece un botón Actualizar entre las pestañas (flechas circulares rojas), que puede utilizarse para actualizar todos los textos de las secuencias de comandos.

Si se hace clic en Cerrar, se cerrará la comparación y volverá a la vista de tabla dentro de Comparar configuración.


Ventana de la imagen


¿Qué es el Visor de imágenes?

En esta ventana, puede ver las imágenes leídas por el dispositivo.

Utilice los iconos de lupa para ajustar la imagen al tamaño de la ventana Visor de imágenes, para alejar y acercar la imagen, o para visualizar la imagen en un modo píxel a píxel, respectivamente.

También puede activar o desactivar Información del enfoque en la imagen en el modo Visualización en vivo y copiar la imagen en el portapapeles.

Utilice la opción Guardar imagen para guardar solamente la imagen actual o todas las imágenes de la ráfaga, y las opciones de Registro para registrar en el sistema de archivos todas las imágenes no leídas o todas las decodificadas.

También puede seleccionar comprobar el histograma de la imagen leída y los datos de intensidad de la luz de un punto seleccionado en la imagen. Utilice los botones en la cinta de barras de herramientas de esta ventana para llevar a cabo estas tareas.


Historial de resultados


¿Qué es Historial de resultados?

En este panel, puede ver la información de decodificación después de cada lectura.

Utilice el botón Pausar para pausar/congelar la vista de herramientas del historial de resultados, lo que facilitará la búsqueda de información específica de lectura. Todos los resultados entrantes del dispositivo serán rechazados por la ventana del historial de resultados hasta que se cancele la pausa.

Utilice Borrar historial para borrar la lista Historial. También puede exportar una sola cadena de decodificación o todas ellas con las opciones Copiar y Copiar todos, respectivamente.

En Registro, puede marcar Generar informes de calidad de los códigos para incluir los datos de calidad de los códigos en la información de decodificación, marcar Generar informes de validación de datos para incluir la información de validación de datos y Registrar todos los resultados en el sistema de archivos para guardar localmente todos los elementos del Historial de resultados en su unidad de disco duro. Se puede acceder a más opciones relacionadas haciendo clic en Configuración de registro e informes.

Personalizar permite agregar o quitar columnas de la tabla para personalizar la información del Historial de resultados.

Para el filtrado de resultados, consulte la pregunta a continuación.


¿Cómo funciona el filtrado de resultados?

Puede utilizar el botón Filtro... del menú de la cinta Vista de herramientas de Historial de resultados para filtrar los resultados de lectura que se muestran en la vista. Al hacer clic en el botón, se activa el filtrado. Para configurar los parámetros de filtrado, abra las opciones haciendo clic en la parte derecha del botón.

Nota: el botón Filtro solo se muestra si el sistema operativo lo admite.

Hay dos modos disponibles en la configuración de filtrado: filtrado estándar y filtrado avanzado. Puede seleccionar cualquiera de los modos en el menú desplegable que encontrará en General.

Si se utiliza el filtrado estándar, las categorías de filtrado se muestran como activas en la ventana desplegable (Estado de resultados, Método de validación, Estado de validación y Símbolos). Puede seleccionar filtros individuales en cada categoría haciendo clic en ellos. Una vez activados, estos filtros se utilizarán en todos los elementos futuros del historial de resultados y también de forma retroactiva. Los elementos no especificados por filtros se excluyen del historial de resultados hasta que se desactive el filtrado. Tenga en cuenta que en el filtrado estándar, un resultado de lectura correcta en una secuencia de disparo cuenta como una lectura correcta para toda la secuencia de disparo. Por consiguiente, por ejemplo, el filtrado estándar no es aplicable a escenarios de código múltiple; utilice secuencias de comandos de filtrado avanzado para escenarios de código múltiple.

Si se utiliza el filtrado avanzado, se desactivan las categorías de filtrado estándar y se activa la Configuración de filtrado avanzado en la ventana desplegable. Al hace clic en esta opción, se abre una nueva ventana donde puede editar las expresiones de filtro. Si se activó un filtro predefinido previamente, la expresión generada puede verse en este cuadro de diálogo. La edición de la expresión no tiene efecto retroactivo en los filtros predefinidos.

La expresión de filtro es una función de JavaScript. El uso de miembros de datos del resultado tiene el mismo efecto que el formato basado en secuencias de comandos. El resultado de una expresión puede verse en la ventana ubicada en la parte inferior. En caso de un error de JavaScript, el mensaje de error se mostrará en la ventana de texto. Tenga en cuenta que, pese a las similitudes, el filtrado avanzado no es una secuencia de comandos de formato de datos, solo un filtro de visualización que se ejecuta en la herramienta de configuración.


¿Por qué aparece el símbolo marcado en verde pero no aparecen datos en la lista Historial de resultados?

Si una casilla Formato estándar activado está marcada en el panel Formato estándar, debe crear una cadena de salida personalizada o no aparecerá ningún dato de resultado aunque el lector haya decodificado el símbolo.


¿Por qué algunos resultados tienen un icono delante?

Los resultados encabezados por un icono tienen una imagen guardada asociada. Haga clic en la línea del resultado para visualizar el intento de decodificación y la imagen asociada al mismo.


¿Cómo puedo visualizar los resultados de código múltiple?

Para activar resultados de código múltiple, debe incrementar el parámetro Cantidad de códigos del valor predeterminado 1 en la pestaña Código múltiple del panel Configuración de símbolos.

Si el lector detecta y decodifica varios símbolos en la misma imagen, cada símbolo aparece marcado en verde y la cuadrícula Historial de resultados de lectura muestra una única línea en la que están representados todos los datos decodificados concatenados en una línea. Los resultados son separados y seguidos de los caracteres ASCII para CR (<0x0d>) y LF (<0x0a>). Para visualizar los resultados por separado de cada símbolo, haga clic en el símbolo «+» al lado de los resultados concatenados.

Al hacer clic en un resultado individual, el Visor de imágenes resaltará el símbolo correspondiente.


¿Por qué veo los resultados individuales en lugar de los resultados de código múltiple en el modo de disparo Auto?

En el modo de disparo Auto, el lector devuelve múltiples resultados individuales en líneas separadas en el Historial de resultados de lectura. Al contrario que con otros modos de disparo, aquí los resultados no están concatenados. El modo de disparo Auto, de forma predeterminada, permite resultados parciales.


Calidad de los códigos


¿Para qué se utiliza la pestaña Calidad de los códigos?

Calidad de los códigos permite acreditar que los símbolos utilizados cumplen las directrices de calidad conforme a lo especificado en las normas de calidad de códigos admitidas por Cognex. Los códigos reciben una calificación global después de realizar las mediciones seleccionadas o todas (de forma predeterminada) para una determinada norma de calidad de códigos. Calidad de los códigos se activa mediante clave de funciones.

Para obtener información detallada acerca de las normas específicas de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación o la documentación de la norma ISO correspondiente, disponible en www.iso.org.


¿Cómo puedo utilizar el panel General?

El panel General funciona a modo de punto común para activar la evaluación de calidad de distintos tipos de códigos: códigos de barras 1D, Data Matrix, códigos QR y DotCode. Para cada uno de estos tipos de símbolos, puede especificar la norma de calidad de códigos en la que se basará el lector para evaluar los códigos leídos.

Si se han seleccionado las mediciones necesarias, vaya a las subpestañas Códigos de barras 1D y/o Códigos 2D para personalizar aún más la evaluación de calidad de los códigos, si es necesario.

Después de activar la evaluación de calidad de los códigos, el dispositivo proporciona resultados de calidad para cada uno de los símbolos leídos para los que se activó la calidad de los códigos en Vista de herramientas de calidad de los códigos. Si desea comprobar los detalles de la evaluación de calidad de los códigos, asegúrese de activar Vista de herramientas de calidad de los códigos haciendo clic en Calidad de los códigos, dentro de Ver. En la vista de herramientas aparecerán la calificación de cada medición utilizada y una calificación global.


¿Qué opciones hay disponibles en las pestañas Códigos de barras 1D y Códigos 2D?

Una vez haya seleccionado la norma de calidad de códigos que quiera utilizar para la evaluación de calidad de su tipo de código en la pestaña General, puede ir a la subpestaña de la norma de calidad de códigos correspondiente en las pestañas Códigos de barras 1D o Códigos 2D y personalizar umbrales de para calificaciones específicas, incluir calificaciones específicas en la calificación global y establecer su visualización en el informe.

Tenga en cuenta que microQR no es compatible con la evaluación de calidad de los códigos.


¿Qué puedo configurar en la pestaña Códigos de barras 1D?

Después de configurar su dispositivo para calcular la Legibilidad 1D de Cognex o ISO/IEC 15416 para códigos de barras 1D (en la pestaña General del panel Calidad de los códigos), esta pestaña le permite gestionar aspectos de ese tipo de evaluación de códigos.

En el cuadro desplegable Calificación mínima correcta del resultado global, puede especificar qué calificación mínima se aceptará como «Correcta» para la norma de calidad de códigos dada.

Al marcar la casilla Umbral personalizado, puede anular y personalizar la configuración de umbral originalmente definida en la norma de calidad de códigos dada. Tenga en cuenta que si desmarca y vuelve a marcar esta casilla, se restablecerán los valores de umbral predeterminados. Estas opciones proporcionan una lista de mediciones para la norma y cada una de estas mediciones tiene las configuraciones siguientes:

  • Umbral puede establecerse para las calificaciones A, B, C y D. Si el valor de una medición supera el umbral respectivo, se asignará la calificación correspondiente. La calificación F se asigna si el valor no alcanza el umbral de la calificación D. Tenga en cuenta que algunas mediciones no tienen umbrales, de conformidad con las normas ISO (para obtener más información, consulte http://www.iso.org para las normas ISO correspondientes).

  • Utilizar para cálculo global: si se marca, esta medición se utilizará para calcular la calificación global.

  • Incluir en informe: si se marca, esta medición se incluirá en el informe de calidad de los códigos disponible directamente desde el lector mediante transferencia por FTP o generado desde la herramienta de configuración mediante el registro de informes, y en la cadena de resultados que puede activarse en la pestaña Cadena de resultados.

Tenga en cuenta que, debido a su naturaleza (definida en las normas), no todas las mediciones tienen todas las opciones disponibles (por ejemplo, si la norma ISO no asigna una calificación a la medición).


¿Qué son las mediciones individuales utilizadas para Legibilidad 1D?

A continuación, encontrará una lista de las mediciones calculadas para la evaluación de calidad Legibilidad 1D. Para obtener información más detallada acerca de esta norma de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación.

  • Int. de escaneado múltiple (Integridad de escaneado múltiple) es una medición de la decodificabilidad del símbolo que se obtiene de combinar varios escaneados del símbolo. Cuanto mayor sea la medición, mejor será la calificación.

  • Contraste mínimo de borde es la diferencia más baja entre la reflectancia de las barras y la reflectancia de los espacios entre dos elementos adyacentes, que proporciona una indicación de la nitidez de los bordes. Cuanto mayor sea la diferencia, mejor será la calificación.

  • Reflectancia mínima es el valor de reflectancia más bajo del escaneado, una medición de la parte más oscura del código de barras. Cuanto menor sea el valor, mejor será la calificación.

  • Cambio de tamaño de impresión mide la desviación del ancho de las barras y los espacios con respecto a los anchos deseados (indicados en la especificación de los símbolos); esto es, mide si las barras son más estrechas/anchas en comparación con los espacios del símbolo. Cuanto mayor sea la diferencia, peor será la calificación.

  • Contraste de símbolo es la diferencia entre los valores de reflectancia más altos y más bajos de un escaneado (la diferencia de reflectancia entre la barra más oscura y el espacio más claro). Cuanto mayor sea la diferencia, mejor será la calificación.

  • Int. de escaneado simple (Integridad de escaneado simple) es una medición de la decodificabilidad del símbolo con un escaneado simple. La decodificabilidad será menor si son varias las partes dañadas en el código de barras.


¿Qué son las mediciones individuales utilizadas para ISO/IEC 15416?

A continuación, encontrará una lista de las mediciones calculadas para la evaluación de calidad ISO/IEC 15416. Para obtener información más detallada acerca de esta norma de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación o la documentación de la norma ISO correspondiente, disponible en www.iso.org.

  • Decodificabilidad es la medición de la precisión de impresión de los códigos de barras en relación con el algoritmo de decodificación de referencia específico de los símbolos en cuestión. La decodificabilidad indica la escala de error en el ancho del elemento mayor desviación en el símbolo. Cuanto menor sea la desviación, mejor será la calificación.

  • Defectos son irregularidades en elementos (barras y espacios) y zonas de silencio. El parámetro permite medir el «ruido» que resulta de los picos y caídas indeseados en el perfil de reflectancia de escaneado. Cuanto menor sea el defecto, mejor será la calificación.

  • Contraste mínimo de borde es la diferencia más baja entre la reflectancia de las barras y la reflectancia de los espacios entre dos elementos adyacentes, que proporciona una indicación de la nitidez de los bordes. Cuanto mayor sea la diferencia, mejor será la calificación.

  • Reflectancia mínima es el valor de reflectancia más bajo del escaneado, una medición de la parte más oscura del código de barras. Cuanto menor sea este valor, mejor será la calificación.

  • Modulación es la relación entre Contraste mínimo de borde y Contraste de símbolo, o bien, una medición de cómo un escáner ve los elementos anchos (barras o espacios) en relación con los elementos estrechos. Cuanto mayor sea la diferencia entre Contraste mínimo de borde y Contraste de símbolo, peor será la calificación.

  • Contraste de símbolo es la diferencia entre los valores de reflectancia más altos y más bajos de un escaneado (la diferencia de reflectancia entre la barra más oscura y el espacio más claro). Cuanto mayor sea la diferencia, mejor será la calificación.

  • Decodificación de referencia es una indicación de si el algoritmo Data Matrix 2D estándar ha podido detectar y decodificar esta marca específica.

    Esta devuelve una calificación de A o bien F.

  • Determinación de bordes es el número de bordes detectado en el perfil de reflectancia de escaneado. Si el número de bordes detectado es mayor o igual al número de bordes previsto, la calificación será 4. De lo contrario, la calificación será 0.


¿Qué puedo configurar en la pestaña Códigos 2D?

Después de configurar su dispositivo para calcular ISO/IEC 15415, AIM-DPM/ISO/IEC TR29158, SEMI T10 o DotCode para códigos 2D (en la pestaña General del panel Calidad de los códigos), esta pestaña le permite gestionar aspectos del tipo de evaluación de códigos en cuestión.

En el cuadro desplegable Calificación mínima correcta del resultado global, puede especificar qué calificación mínima se aceptará como «Correcta» para la norma de calidad de códigos dada.

Al marcar la casilla Umbral personalizado, puede anular y personalizar la configuración de umbral originalmente definida en la norma de calidad de códigos dada. Tenga en cuenta que si desmarca y vuelve a marcar esta casilla, se restablecerán los valores de umbral predeterminados. Estas opciones proporcionan una lista de mediciones para la norma en cuestión y cada una de estas mediciones tiene las configuraciones siguientes:

  • Umbral puede establecerse para las calificaciones A, B, C y D. Si el valor de una medición supera el umbral respectivo, se asignará la calificación correspondiente. La calificación F se asigna si el valor no alcanza el umbral de calidad D. Tenga en cuenta que algunas mediciones (p. ej., SEMI 10) no tienen umbrales, de conformidad con las normas ISO (para obtener más información, consulte http://www.iso.org para la documentación de la norma ISO correspondiente).

  • Utilizar para cálculo global: si se marca, esta medición se utilizará para calcular la calificación global. Tenga en cuenta que las mediciones SEMI T10 no disponen de esta opción.

  • Incluir en informe: si se marca, esta medición se incluirá en el informe de calidad de los códigos disponible directamente desde el lector mediante transferencia por FTP o generado desde la herramienta de configuración mediante el registro de informes, y en la cadena de resultados que puede activarse en la pestaña Cadena de resultados.

Tenga en cuenta que, debido a su naturaleza, no todas las mediciones tienen todas las opciones disponibles (por ejemplo, si la norma ISO no asigna una calificación a la medición).

Nota: MicroQR no es compatible con la evaluación de calidad de los códigos 2D.


¿Qué son las mediciones individuales utilizadas para AIM-DPM/ISO/IEC TR29158?

A continuación, encontrará una lista de mediciones utilizadas para la evaluación de calidad AIM-DPM/ISO/IEC TR29158. Para obtener información más detallada acerca de esta norma de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación o la documentación de la norma ISO correspondiente, disponible en www.iso.org.

  • No uniformidad de cuadrícula es una medición de la cantidad de error de ubicación de cada una de las celdas de una cuadrícula con espaciado uniforme utilizando el patrón alternativo de un símbolo.

  • Corrección de error sin utilizar es una medición del porcentaje de palabras de código que quedan en un símbolo después de corregir los errores.

    Cuando se calcula la Corrección de error sin utilizar, una palabra de código se considera errónea si al menos una de sus celdas se encuentra en el lado equivocado del umbral global. Los símbolos Data Matrix 2D tienen redundancia de código integrada, o tienen el contenido de datos duplicado.

    Un valor de 1,00 indica que no hay errores en ninguna de las palabras de código.

  • No uniformidad axial es una medición de la simetría de celdas individuales del símbolo, esto es, la cantidad de desviación a lo largo de los ejes del símbolo.

  • Contraste de celda es una medición de la diferencia de reflectancia entre las celdas luminosas y las celdas oscuras en el símbolo, representada como un porcentaje del valor medio reflejado de las celdas luminosas.

    La especificación AIM-DPM/ISO/IEC TR 29158 requiere que se ajuste la imagen para que las celdas luminosas tengan un valor de reflectancia medio del 78% de saturación completa.

  • Daño de patrón fijo es la calidad del patrón de búsqueda, el patrón alternativo y el patrón de zona de silencio dentro de la marca.

    El lector utiliza varios patrones en cada símbolo para detectar y decodificar los datos que contiene. El lector genera la calificación Daño de patrón fijo utilizando el mismo método que para el resultado de Modulación de celdas; en concreto, una medición de la confianza de reflectancia.

  • Modulación es una medida de legibilidad de la marca real.

    La calificación refleja cuánto se acercan las celdas luminosas y las celdas oscuras a un umbral global para una marca específica, indicando el punto de separación de nivel de gris entre las celdas luminosas y las celdas oscuras de una marca determinada.

    Una marca obtiene una calificación de Modulación poco satisfactoria si la confianza en que el lector pueda clasificar las celdas individuales en luminosas y oscuras es relativamente poca. El resultado también tiene en cuenta la capacidad de corrección de error del símbolo (cuanto más grandes sean los símbolos, mayor será la capacidad de corrección de error). Por ejemplo, una marca obtendrá una calificación de Modulación baja, pero una calificación de Corrección de error sin utilizar alta si la mayoría de las celdas están a punto de cambiar su estado, pero en realidad no lo cambian.

  • Cambio de tamaño de impresión mide la desviación del ancho de las barras y los espacios con respecto a los anchos deseados (indicados en la especificación de los símbolos); esto es, mide si las barras son más estrechas/anchas en comparación con los espacios del símbolo. Cuanto mayor sea la diferencia, peor será la calificación.


¿Qué son las mediciones individuales utilizadas para ISO/IEC 15415?

A continuación, encontrará una lista de mediciones utilizadas para la evaluación de calidad ISO/IEC 15415. Para obtener información más detallada acerca de esta norma de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación o la documentación de la norma ISO correspondiente, disponible en www.iso.org.

  • No uniformidad de cuadrícula es una medición de la cantidad de error de ubicación de cada una de las celdas de una cuadrícula con espaciado uniforme utilizando el patrón alternativo de un símbolo.

  • Corrección de error sin utilizar es una medición del porcentaje de palabras de código que quedan en un símbolo después de corregir los errores.

    Cuando se calcula la Corrección de error sin utilizar, una palabra de código se considera errónea si al menos una de sus celdas se encuentra en el lado equivocado del umbral global. Los símbolos Data Matrix 2D tienen redundancia de código integrada, o tienen el contenido de datos duplicado.

    Un valor de 1,00 indica que no hay errores en ninguna de las palabras de código.

  • No uniformidad axial es una medición de la simetría de celdas individuales del símbolo, esto es, la cantidad de desviación a lo largo de los ejes del símbolo.

  • Contraste de símbolo es la diferencia entre los valores de reflectancia más altos y más bajos de un escaneado (la diferencia de reflectancia entre la barra más oscura y el espacio más claro). Cuanto mayor sea la diferencia, mejor será la calificación.

  • Reflectancia extrema es un valor de tipo sí/no que indica si el sustrato que rodea el símbolo contiene extremos de reflectancia que pueden interferir en la lectura.

  • Daño de patrón fijo es la calidad del patrón de búsqueda, el patrón alternativo y el patrón de zona de silencio dentro de la marca.

    El lector utiliza varios patrones en cada símbolo para detectar y decodificar los datos que contiene. El lector genera la calificación Daño de patrón fijo utilizando el mismo método que para el resultado de Modulación de celdas; en concreto, una medición de la confianza de reflectancia.

  • Modulación es la relación entre Contraste mínimo de borde y Contraste de símbolo, o bien, una medición de cómo un escáner ve los elementos anchos (barras o espacios) en relación con los elementos estrechos. Cuanto mayor sea la diferencia entre Contraste mínimo de borde y Contraste de símbolo, peor será la calificación.

  • Cambio de tamaño de impresión mide la desviación del ancho de las barras y los espacios con respecto a los anchos deseados (indicados en la especificación de los símbolos); esto es, mide si las barras son más estrechas/anchas en comparación con los espacios del símbolo. Cuanto mayor sea la diferencia, peor será la calificación.


¿Qué son las mediciones individuales utilizadas para SEMI T10?

A continuación, encontrará una lista de las mediciones utilizadas en la especificación SEMI T10. Para obtener información más detallada acerca de esta especificación de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación o la especificación semi correspondiente, disponible en www.semi.org.

  • Defectos de patrón de búsqueda es la relación entre píxeles incorrectos y píxeles totales en el patrón de búsqueda.

  • Defectos de celdas es la relación entre píxeles incorrectos y píxeles totales en la cuadrícula.

  • Desviación de marca vertical es la desviación vertical media de las marcas Data Matrix con respecto a sus puntos de centro de celda Data Matrix óptimos.

  • Desviación de marca horizontal es la desviación horizontal media de las marcas Data Matrix con respecto a sus puntos de centro de celda Data Matrix óptimos.

  • Alto de celda de Data Matrix es la altura media de cada celda en la matriz (en píxeles).

  • Ancho de celda de Data Matrix es el ancho medio de cada celda en la matriz (en píxeles).

  • Cambio de tamaño de marca vertical es el seguimiento de la tendencia de marcar poco o demasiado el símbolo; esto es, una comparación entre el tamaño vertical de las celdas reales marcadas y su tamaño nominal.

  • Cambio de tamaño de marca horizontal es el seguimiento de la tendencia de marcar poco o demasiado el símbolo; esto es, una comparación entre el tamaño horizontal de las celdas reales marcadas y su tamaño nominal.

  • Relación señal-ruido (SNR) es una medición relativa del contraste del símbolo con respecto a la desviación máxima en niveles de escala de grises claros u oscuros en el símbolo (es decir, ruido).

  • Corrección de error sin utilizar es la medición del porcentaje de palabras de código que quedan en un símbolo después de corregir los errores.

    Cuando se calcula la Corrección de error sin utilizar, una palabra de código se considera errónea si al menos una de sus celdas se encuentra en el lado equivocado del umbral global. Los símbolos Data Matrix 2D tienen redundancia de código integrada, o tienen el contenido de datos duplicado.

    Un valor de 1,00 indica que no hay errores en ninguna de las palabras de código.

  • Contraste de símbolo es la diferencia entre los valores de reflectancia más altos y más bajos de un escaneado (la diferencia de reflectancia entre la barra más oscura y el espacio más claro). Cuanto mayor sea la diferencia, mejor será la calificación.


¿Qué son las mediciones individuales utilizadas para DotCode?

A continuación, encontrará una lista de las mediciones utilizadas para la evaluación de calidad de DotCode. Para obtener información más detallada acerca de esta norma de calidad de códigos y sus mediciones, consulte la Guía de comunicaciones y programación o la documentación de la norma ISO correspondiente, disponible en www.iso.org.

  • No uniformidad de cuadrícula es una medición de la cantidad de error de ubicación de cada una de las celdas de una cuadrícula con espaciado uniforme utilizando el patrón alternativo de un símbolo.

  • Corrección de error sin utilizar es la medición del porcentaje de palabras de código que quedan en un símbolo después de corregir los errores.

    Cuando se calcula la Corrección de error sin utilizar, una palabra de código se considera errónea si al menos una de sus celdas se encuentra en el lado equivocado del umbral global. Los símbolos Data Matrix 2D tienen redundancia de código integrada, o tienen el contenido de datos duplicado.

    Un valor de 1,00 indica que no hay errores en ninguna de las palabras de código.

  • Cambio de tamaño de impresión mide la desviación del ancho de las barras y los espacios con respecto a los anchos deseados (indicados en la especificación de los símbolos); esto es, mide si las barras son más estrechas/anchas en comparación con los espacios del símbolo. Cuanto mayor sea la diferencia, peor será la calificación.

  • No uniformidad axial es la medición de la simetría de celdas individuales del símbolo, esto es, la cantidad de desviación a lo largo de los ejes del símbolo.

  • Contraste de símbolo es la diferencia entre los valores de reflectancia más altos y más bajos de un escaneado (la diferencia de reflectancia entre la barra más oscura y el espacio más claro). Cuanto mayor sea la diferencia, mejor será la calificación.


¿Para qué se utiliza la pestaña Cadena de resultados?

Al marcar la casilla Añadir datos de calidad de los códigos a cadena de resultados, activa el formato de datos basado en tokens y permite que se añadan los datos de resultados de calidad de los códigos a las cadenas de resultados. Si se marca, la opción Transmitir calificación global transmite la calificación global de calidad de los códigos (que se define como la calificación mínima de las mediciones seleccionadas) en la cadena de resultados.

En Datos proporcionados, puede especificar si desea que se incluyan las calificaciones, los valores, ambos o ninguno en los datos de la cadena de resultados. La sección Separador para elementos de datos permite establecer separadores antes y entre los valores de calidad de los códigos incluidos en una cadena de resultados.

Descripción personalizada de informe de calidad permite especificar un texto personalizado que se agrega al encabezado del informe de calidad de los códigos, disponible directamente desde el lector mediante transferencia por FTP o generado desde la herramienta de configuración mediante registro de informes.

Tenga en cuenta que en caso de código múltiple, el token de formato <Datos de PCM> debe añadirse a todos los símbolos usados.


¿Qué indica el rectángulo doble que aparece en la casilla?

Un rectángulo pequeño con relleno dentro de un rectángulo vacío más grande corresponde a un estado de comprobación intermedio. En este caso, indica que aunque la opción está activada, no tiene pleno efecto (en este caso, principalmente porque el token fue eliminado manualmente en el panel Secuencias de comandos).


¿Para qué se utiliza la pestaña Transferencia por FTP de informes?

La pestaña Transferencia por FTP de informes permite establecer que los resultados de calidad de los códigos se envíen a través de FTP en forma de informe HTML. Debe marcar la casilla Activar transferencia de informes de calidad de los códigos para que el dispositivo envíe los resultados a través de FTP, e identificar el servidor al que desea enviar los datos proporcionando la dirección del servidor, el nombre de usuario, la contraseña y el tipo de servidor.

Tiempo de espera inactivo es la cantidad de tiempo que un puerto se mantiene abierto sin tráfico saliente. Una vez que el lector abre una conexión con un servidor FTP, el lector mantiene dicha conexión abierta mientras haya tráfico. Si no hay tráfico en el periodo establecido como Tiempo de espera inactivo, se cierra la conexión. Esto puede ser útil si la transferencia por FTP se realiza únicamente de forma ocasional y no se desea sobrecargar la red manteniendo la conexión abierta. Para poder establecer el tiempo de espera inactivo, primero debe marcar la casilla Activar tiempo de espera inactivo.

Las configuraciones de Nombre de archivo se aplican a la generación del nombre de archivo del informe FTP. Hay varias opciones de configuración:

  • Generación de Nombre de archivo personalizado: seleccione esta opción si quiere proporcionar el nombre de archivo usted mismo. Puede especificar el nombre en Nombre de archivo. El campo Nombre de archivo no solo acepta nombres de archivos sino también nombres de rutas. Use barras diagonales como delimitadores. Por ejemplo, /imágenes/imagen. Las configuraciones de adición permiten establecer las reglas de numeración para la generación del nombre de archivo: Máx. valor de adición establece el número máximo que alcanza la numeración de los nombres de archivo y Máx. valor inicial de adición establece donde comienza la numeración de los nombres de archivo.

  • Nombre de archivo generado por la secuencia de comandos: después de activar esta opción, haga clic en el nombre de opción en azul para acceder de inmediato a Secuencias de comandos > Transferencia por FTP, donde ya aparece la secuencia de comandos de muestra para la generación del nombre de archivo.

  • Nombre de archivo generado por el servidor: después de seleccionar esta opción, proporcione aquí la dirección del servidor para generar nombres de archivo de informes basados en un servidor. Algunos servidores FTP son compatibles con esta funcionalidad para nombrar de forma única los archivos entrantes antes de guardarlos en el disco.


¿Qué debería hacer si no funcionan las transferencias por FTP de nombres de archivo generados por el servidor?

Verifique que su servidor FTP puede trabajar con el comando «STOU - Almacenamiento único». Este comando se comporta como el comando STOR, excepto que el archivo resultante se creará en el directorio actual con un nombre único para ese directorio.


¿Por qué se desactiva todo el panel cuando transfiero archivos?

El panel se desactiva para lograr la mayor estabilidad de transferencia por FTP de imágenes posible. La transferencia por FTP de imágenes puede llevar algún tiempo, dependiendo de la velocidad de conexión al servidor FTP y del tamaño y número de imágenes que vaya a transferir.


Vista de herramientas de calidad de los códigos


¿Qué puedo ver en Vista de herramientas de calidad de los códigos?

En Vista de herramientas de calidad de los códigos, puede ver los resultados de la evaluación de calidad de los códigos. Para poder ver los resultados aquí, es necesario activar antes el cálculo de calidad de los códigos en el panel Calidad de los códigos (se necesita clave de funciones). Para cada lectura seleccionada en la vista de herramientas de Historial de resultados, se mostrarán en la vista de herramienta de calidad de los códigos las mediciones y normas de calidad de códigos establecidas previamente. Encima de cada tipo de norma de calidad de códigos, se puede ver la calificación global otorgada al código que se ha leído.

Propiedad muestra una lista de las mediciones individuales para la norma dada y Valor es la diferencia de valor numérico calculada para las mediciones individuales. Calificación es la calificación de calidad de los códigos que se otorgó a la medición (en esta fila también aparece un icono de color; verde = correcto, rojo = incorrecto, amarillo = el valor está en el umbral). Promedio es la calificación media (con + y - para la tendencia) basada en las últimas 100 lecturas de esa medición.

Para obtener información detallada acerca de las normas de calidad de los códigos, las calificaciones y las mediciones, consulte la Guía de comunicaciones y programación o la documentación de la norma ISO correspondiente, disponible en www.iso.org.


Modo de prueba


¿Qué es el Modo de prueba?

El Modo de prueba le permite probar y configurar su dispositivo mediante un sistema en vivo sin interrumpir la producción. En este modo, todas las fuentes de disparo (salvo el disparo con botón y con la herramienta de configuración) están desactivadas.


¿Qué es el disparo automático?

El disparo automático permite disparar internamente (de forma automática) el dispositivo en un modo de disparo externo. Esto es, aunque se seleccione un tipo de disparo que sea externo (cualquier otro distinto del modo de disparo Presentación o Auto), se puede disparar el lector automáticamente en modo de prueba. De esta forma, puede determinar si el dispositivo se está ejecutando con los parámetros que se utilizarán en modo normal.


¿Qué funciones están desactivadas/limitadas en el Modo de prueba?

  • Todas las fuentes de disparo están desactivadas, salvo el disparo con botón y con la herramienta de configuración.

  • Puede desactivar todas las entradas y salidas. En ese caso, los resultados solo se enviarán a la herramienta de configuración y los LED/alertas sonoras funcionarán, pero no otras salidas.


¿Qué es Número de disparos aceptados?

Puede definir el número de disparos que se aceptarán antes de que se desactiven todas las fuentes de disparo.


Configuraciones de lectura


¿Para qué modos de disparo son válidas las configuraciones de lectura?

Las configuraciones de lectura pueden utilizarse en los modos de disparo Único, Auto, Ráfaga y Continuo. La siguiente configuración de lectura se activa después del tiempo de Intervalo especificado (indicado en el panel Configuración de Luz y Generador de imágenes). Para todos los demás modos de disparo, si se han establecido varias configuraciones, solo se empleará la configuración activa actualmente seleccionada (indicada en la barra de estado). Puesto que en el modo de disparo Único no hay intervalos, una configuración de lectura pasará a la siguiente en cuanto finalice la adquisición anterior.


¿Cómo puedo agregar, copiar o eliminar configuraciones?

Para agregar una configuración de lectura, haga clic en el botón Agregar configuración. En la ventana que aparecerá, podrá decidir si quiere usar los valores predeterminados para la nueva configuración o si quiere copiar los valores de una configuración ya existente.

Para eliminar una configuración de lectura, selecciónela marcando la columna de la configuración de lectura en cuestión y haga clic en el botón Eliminar configuración.

Para copiar y pegar una configuración de lectura, seleccione la columna que desee copiar y haga clic en el botón Copiar o pulse Ctrl+C, y luego vaya a la columna de configuración en la que quiera sobrescribir la nueva configuración. Haga clic en el botón Pegar o pulse Ctrl+V. Los valores que copió y pegó se sobrescribirán sobre los de la columna.


¿Qué es la opción Iniciando configuración?

Si se activan varias configuraciones, el lector las revisará todas y dejará de adquirir imágenes cuando haya leído un código. Para leer el código siguiente, podrá decidir si el lector comenzará a revisar las configuraciones empezando por una seleccionada o por la última decodificación correcta.


¿Puedo cambiar el orden de la configuración de lectura?

Puede hacer clic en el botón Cambiar orden y reorganizar el orden de las configuraciones de lectura en la ventana emergente. Las configuraciones volverán a numerarse de forma consecutiva.


¿Qué es el campo Filtro en la parte superior?

Puede escribir un parámetro que desee encontrar, por ejemplo, «tamaño» o «ráfaga» y luego pulsar Entrar. Los elementos encontrados se resaltarán y solo se expandirán los nodos de aquellos parámetros que contengan los elementos buscados. Puede cerrar la búsqueda borrando lo que ha escrito y pulsando Entrar.


¿Cómo afectan los ajustes a mis parámetros de configuración de lectura?

La tabla Mejores resultados en el panel Ajustes se aplica a la configuración activa actualmente. Solo esos parámetros ajustados se ven afectados.


¿Por qué no puedo usar más configuraciones?

SI utiliza el Filtrado de imagen, es posible que no todas las configuraciones estén activadas, debido a razones internas de la memoria del dispositivo.


Configuraciones de lectura: estructura y diseño general

Configuraciones de lectura es una herramienta a estilo de vista de tabla que permite establecer, copiar, comparar o restaurar configuraciones de lectura. El área principal de la página de documento contiene una cuadrícula con las propiedades del dispositivo.

La fila de título muestra el nombre o nombres de los dispositivos seleccionados. La segunda fila de títulos debajo de la primera muestra las configuraciones disponibles para el dispositivo. Los títulos de fila inferiores (en negrita) pueden contraerse o abrirse haciendo clic en el icono situado junto a ellos. Si un dispositivo está desconectado, aparece un icono de reconexión en su fila de título.


Configuraciones de lectura: controles (ratón y teclado)

Selección:

  • Ratón: al hacer clic en una celda de la cuadrícula, se selecciona la celda y se resalta el título de su fila y el título de la/s columna/s a las que pertenecen el dispositivo y la configuración. Los botones de menú y los elementos del menú de la cinta pueden variar en función de la selección. Si la celda seleccionada se encuentra en una fila de título, se seleccionarán todas las celdas de la columna actual que pertenezcan a ese título.

  • Teclado: las teclas de movimiento del cursor permiten mover la selección a la celda apropiada. El funcionamiento en cuanto a resaltado y selección es el mismo que con el ratón.

Agregar/cambiar valores:

  • Ratón: en celdas con editores incorporados, hacer clic en el control del editor (cuadro de combinación, casilla, control numérico arriba-abajo) se podrán introducir valores. En celdas con editores personalizados (icono «...»), se abre un editor emergente que permite introducir valores.

  • Teclado: en celdas con editores incorporados, al pulsar Entrar o F2 se inicia el modo de edición; con Esc se cancela la edición y pulsando Entrar por segunda vez se confirma la edición. Los valores pueden introducirse en el texto seleccionado sin entrar en el modo de edición, en cuyo caso el valor actual se sobrescribirá con la primera tecla que se pulse.

    En las celdas numéricas, además de las celdas con editor de texto incorporado, las flechas arriba y abajo aumentan o disminuyen el valor.

    En celdas desplegables, Entrar inicia el modo de edición y muestra los elementos desplegables, mientras que las flechas arriba y abajo mueven la selección. Pulsando Entrar por segunda vez se aplica el valor seleccionado y con Esc se cancela la edición.

    En las celdas de casilla de verificación, utilice Espacio para alternar entre los estados marcado/no marcado.

Copiar y pegar:

Utilice las combinaciones de teclado Ctrl+C y Ctrl+V para copiar y pegar, respectivamente. Consulte la descripción de copiar-pegar de los elementos de menú de la cinta relacionados para obtener más información.


Configuraciones de lectura: menú de la cinta

El menú de la cinta se encuentra encima de la cuadrícula a estilo de vista de tabla. Sus contenidos e iconos activos pueden cambiar en función de las celdas, filas o columnas que se seleccionen en la cuadrícula. El menú está dividido en varios grupos.

  • Vista de tabla: Utilice el botón Agregar configuración para agregar una configuración de lectura. En la ventana que aparecerá, podrá decidir si quiere usar los valores predeterminados para la nueva configuración o si quiere copiar los valores de una configuración ya existente. El botón Eliminar configuración permite eliminar la/s configuración/es de lectura seleccionada/s. El botón Cambiar orden abre un cuadro emergente donde podrá reorganizar el orden de las configuraciones de lectura. Las configuraciones volverán a numerarse de forma consecutiva.

  • Configuración de inicio: Si se activan varias configuraciones, el lector pasará por todas y dejará de adquirir imágenes cuando haya leído un código. Para leer el código siguiente, podrá decidir si el lector comenzará a revisar las configuraciones empezando por una seleccionada o por la última decodificación correcta. Aquí puede seleccionar la configuración de inicio de una lista desplegable. También puede seleccionar Última decodificación correcta para seleccionar la configuración de lectura de la última decodificación correcta como configuración de inicio.

  • Edición: Utilice Copiar (o Ctrl+C en el teclado) para copiar un valor de la celda seleccionada en ese instante. Pegar solo puede utilizarse en la misma fila o en cualquier editor de texto. Restablecer valores permite restablecer el/los valor/es de la/s celda/s seleccionada/s.

  • Resaltado: los botones y configuraciones de este grupo de menú ofrecen opciones para resaltar el fondo de celdas específicas. Con la configuración Valores no predeterminados se resaltan las celdas que tengan valores no predeterminados (puede variar en una misma fila para diferentes dispositivos o configuraciones de lectura). La configuración Distinto de referencia resalta las celdas que tengan valores diferentes a los de la celda de la misma fila en la configuración de lectura (y el dispositivo) de referencia. Si se selecciona la tercera configuración, se resaltarán todos los valores y títulos que contengan el texto especificado en el cuadro de texto. Además, el texto contenido se resaltará con un fondo de texto diferente. Al pulsar Entrar, también se aplica la función del botón Mostrar solo filas resaltadas.

    Al activar Mostrar solo filas resaltadas, se contraerán todos los nodos que no tengan ningún subnodo resaltado. Si se activa Establecer configuración de lectura de referencia, especifica la configuración de lectura (y el dispositivo) que se utilizará como referencia cuando se utilice el modo de resaltado Distinto de referencia. Si el botón está activo, la columna de la celda seleccionada en ese instante (configuración de lectura) pasa a ser la configuración de referencia. La configuración de referencia actual se marca en la fila de título del nombre de configuración.

  • Filtrado: Parámetros de configuración de lectura se establece de forma automática, para que solo se muestren las configuraciones dependientes de la configuración de lectura. Establezca Configuración global para ver únicamente configuraciones que no tengan valores distintos en diferentes configuraciones de lectura. Establezca Todas las configuraciones para ver todas las configuraciones al mismo tiempo. Si una entrada tiene valores en más configuraciones de lectura, estos se mostrarán en diferentes columnas.

  • Otros: Utilice Expandir todas las filas para expandir todas las filas que se hayan contraído en la cuadrícula. Utilice Contraer todas las filas para contraer todas las filas expandidas de la cuadrícula. Restablecer diseño vuelve a calcular los anchos de columna para utilizar todo el espacio disponible. Si el espacio disponible no es suficiente, se aplica un ancho de columna mínimo.


Registro de dispositivo


¿Qué es el Registro de dispositivos?

Esta vista muestra los registros que se generan cuando el LED rojo del dispositivo parpadea. Puede actualizar este registro o eliminarlo cuando ya no se necesite.


Tamaño de imagen


¿Para qué se utiliza la configuración Decodificación de la región de interés (ROI)?

Puede utilizar esta función para especificar la región exacta de la imagen que el lector utilizará para detectar y decodificar un símbolo. Puede ser de utilidad si hay dos códigos Data Matrix uno al lado del otro y resulta necesario asegurarse de que solo se lea el código que esté bajo la línea de enfoque del objetivo. La reducción de la región de interés no disminuye necesariamente el tiempo de decodificación ni aumenta la velocidad de transferencia de la imagen.

NOTA: algunas propiedades relacionadas con las imágenes (p. ej. tamaño de imagen, filtrado) no pueden modificarse cuando el dispositivo está adquiriendo o decodificando imágenes.


¿Por qué cambiar el campo de visión del generador de imágenes (FoV)?

Disponible únicamente para los tipos de disparo único, por ráfagas y continuo, puede modificar el campo de visión para reducir el tamaño de cada imagen capturada por el lector, que puede aumentar la cantidad de memoria y permitirle especificar una longitud de ráfaga mayor.


¿Por qué no puedo cambiar la decodificación de la ROI?

Asegúrese de que el FoV del generador de imágenes no está marcado. Si el FoV del generador de imágenes está marcado, no se puede aumentar la decodificación de la ROI más allá de los límites del FoV del generador de imágenes.


¿Tiene el tamaño del decodificador de la ROI algún efecto en los Códigos de configuración del lector?

Restringir la región de interés a un tamaño demasiado pequeño podría dar como resultado que el lector no pudiera leer los Códigos de configuración del lector.


Configuración del enfoque


¿Qué hace la opción Optimizar enfoque?

Al igual que en el panel Configuración rápida, el botón Optimizar enfoque configurará para la lente líquida un valor óptimo basado en el campo de visión actual.


¿Qué sucede si activo la opción Información de Optimizar enfoque activada?

Al marcar la casilla, se activa la información sobre optimización de enfoque, que a su vez proporciona información visual en la visualización de la imagen (disponible en Configuración rápida o Panel de imágenes en forma de círculos de colores superpuestos a la imagen). Las zonas rojas están desenfocadas, mientras que las zonas verdes están enfocadas (cuanto mayor sea el círculo, mayor será el área enfocada).


¿Qué hace la opción Modo de estabilización de enfoque?

La opción Modo de estabilización de enfoque permite especificar configuraciones predefinidas para el tiempo de estabilización de la lente líquida para la adquisición de imágenes durante los disparos. Establezca Normal para el modo de estabilización normal y Preciso para un modo más lento, pero más preciso.


¿Cómo determino el valor de enfoque correcto para la lente líquida?

Para determinar la mejor configuración para el Barrido de enfoque, marque la casilla Visualización en vivo activada y experimente con el control según la imagen en directo.


¿Por qué no se puede seleccionar la opción Barrido de enfoque?

El barrido de enfoque solo es compatible en los modos de disparo Manual y Presentación.


¿Cómo puedo utilizar la configuración Rango de enfoque?

Puede utilizar la opción Rango de enfoque para cambiar manualmente la distancia de enfoque del dispositivo utilizando el control deslizante, los botones «+» y «-» en los extremos del control o escribiendo valores. El rango de enfoque puede proporcionarse en milímetros o dioptrías. Cuando se proporciona uno de estos valores, la herramienta de configuración calcula automáticamente el otro valor para ajustarlo al que se cambió.

La región naranja del control indica el rango extendido (por encima de 500 mm), donde solo se aplican dioptrías. Cuando el valor está dentro de esta región, los valores milimétricos se desactivan (y se vuelven a activar cuando el valor vuelve a estar fuera del rango extendido).

Tenga en cuenta que las dioptrías disminuyen cuando se utiliza el botón «+» e incrementan cuando se utiliza el botón «-».


¿Cómo se calcula la distancia hasta el lector?

La distancia en milímetros se calcula como la distancia desde la parte frontal de la cubierta de la lente hasta la imagen que se va a decodificar.

Cuando se establecen, las dioptrías también se calculan desde la parte frontal de la lente hasta la imagen.


Filtrado de imagen


¿Cómo utilizo el filtrado de imagen?

  1. Haga clic en Agregar y seleccione un filtro de la lista Filtros apilados.

  2. En cuadro de combinación Propiedades de filtro, seleccione los parámetros apropiados para el filtro seleccionado. También puede especificar el orden en el que se realizará el filtrado si mueve los filtros usando los botones Arriba y Abajo.

  3. Cambie la selección en la casilla de grupo Imagen a usar de acuerdo con los símbolos que quiere que se filtren (después de asegurarse de que dicha simbología está activada).

  4. Vaya al panel Configuración de la imagen mostrada y cambie las imágenes a usar de acuerdo con lo que quiera ver en la visualización en vivo: la imagen original o la filtrada.


¿Cuáles son los diferentes filtros?

  • Igualar: Este filtro redistribuye los valores de la intensidad de la luz de los píxeles en la imagen. Como resultado, la gama de niveles de la intensidad de la luz se encuentra representada de forma más igualada. Use este filtro si tiene imágenes demasiado oscuras o demasiado luminosas.

  • Extender: Este filtro aumenta la escala o extiende linealmente los valores de la escala de grises en la imagen de entrada hasta la escala de grises completa de 256 pasos. El resultado es una imagen de salida con un aumento de contraste.

  • Pase bajo: Utilizar este filtro da como resultado imágenes de salida en las que los bordes son suavizados o difuminados.

  • Dilatar: Este filtro aumenta las características luminosas y disminuye las oscuras. El resultado es una imagen de salida con áreas más grandes de píxeles luminosos. Use este filtro para eliminar las pequeñas manchas oscuras.

  • Disminuir: Este filtro disminuye las características luminosas y aumenta las oscuras. El resultado es una imagen de salida con áreas más grandes de píxeles oscuros. Use este filtro para eliminar las pequeñas manchas luminosas.

  • Abrir: Este filtro realiza un desgaste seguido de una dilatación para filtrar las propiedades de la intensidad de la luz que sean más pequeñas que el tamaño de lo que les rodea en el procesado. El resultado es una imagen de salida con una ligera disminución general de la intensidad de la luz.

  • Cerrar: Este filtro realiza una dilatación seguida de un desgaste para filtrar las propiedades oscuras que sean más pequeñas que el tamaño de lo que les rodea en el procesado. El resultado es una imagen de salida con un ligero aumento general de la intensidad de la luz.

  • Extensión automática: Este filtro reduce la gama de valores de pixel. Asigna los valores de pixel de 0 a 255.

  • Densidad óptica: Este filtro especifica una inversión de los valores de pixel basada en una escala logarítmica. El resultado es una imagen de salida que revela la densidad de los objetos y características en la imagen de entrada al medir la cantidad de luz que los atraviesa. Los objetos y características más densos se representan mediante píxeles más claros en la imagen de salida.

  • Invertir: Este filtro especifica una inversión de los valores de pixel basada en la escala de grises de 256 pasos. El resultado es una imagen de salida que es un «negativo» de la imagen de entrada.

  • Mediana: Este filtro se aplica a todos los píxeles de la imagen. Para cada píxel, el filtro observa la intensidad de luz de los píxeles circundantes y configura el píxel en la mediana de los mismos. El resultado es una imagen más suave que reduce y atenúa los extremos.

  • Corrección gamma: Este filtro realiza un ajuste de la intensidad de luz basado en el valor de corrección gamma proporcionado a modo de subconfiguración.

  • Escala: Este filtro permite el escalado porcentual de la imagen a lo largo de los ejes X e Y (uno o ambos).


¿Qué es la imagen no leída?

Si el lector no decodifica una imagen, el Historial de resultados muestra la imagen de acuerdo con su selección en Imagen no leída. Si ha seleccionado, por ejemplo, Data Matrix, el Historial de resultados le mostrará lo que haya seleccionado para Data Matrix: Original o Filtrada.


¿Por qué están desactivadas todas las opciones de filtros?

Todas las opciones de filtros se encuentran desactivadas en los modos de disparo Presentación y Auto. Si aún desea usar el filtrado de imagen en estos modos de disparo, cambie primero a otro tipo de disparo, establezca la configuración de filtro y vuelva al modo Presentación o al Auto.


Configuración Xpand ROI


¿Para qué se utiliza la configuración Xpand ROI?

Puede utilizar esta función para especificar la región exacta de cada parte de la imagen que ve el lector a través del FOVE. Esto puede ser útil para desactivar el área fantasma en el centro de la imagen donde el mismo código puede ser detectado dos veces. Reducir la región de interés (ROI) no disminuye necesariamente el tiempo de decodificación ni aumenta la velocidad de transferencia de la imagen.

La configuración más adecuada se ha establecido previamente para los expansores del campo de visión (FOVE) existentes, pero puede ajustar la configuración (configuración personalizada) estableciendo manualmente los parámetros con el fin de obtener los mejores resultados para el FOVE específico en uso. Los lectores, FOVE y lentes utilizados tienen efectos distintos.

NOTA: algunas propiedades relacionadas con las imágenes (p. ej. tamaño de imagen, filtrado) no pueden modificarse cuando el dispositivo está adquiriendo o decodificando imágenes.

NOTA: asegúrese de comprobar que el dispositivo que está utilizando sea compatible con el FOVE que está intentando calibrar.


¿Por qué cambiar el campo de visión (FoV)?

Disponible únicamente para los tipos de disparo único, por ráfagas y continuo, permite modificar el área individualmente para cada campo de visión con el fin de reducir el tamaño de cada imagen capturada por el lector, lo que puede aumentar la cantidad de memoria y permitirle especificar una longitud de ráfaga mayor. La configuración de estos FoV permite excluir algunas áreas de imagen donde la detección de códigos puede sufrir distorsiones o interferencias debido a algunos fenómenos ópticos relacionados con los expansores del campo de visión (FOVE).


¿Tiene el tamaño de la ROI algún efecto en los Códigos de configuración del lector?

Restringir la región de interés a un tamaño demasiado pequeño podría dar como resultado que el lector no pudiera leer los Códigos de configuración del lector.


OCR


¿Qué es OCR?

El reconocimiento óptico de caracteres (OCR, por sus siglas en inglés) es una función que permite a los usuarios utilizar dispositivos DataMan para convertir caracteres impresos en texto codificado. Para poder usar OCR, primero debe someter el dispositivo al aprendizaje de las fuentes deseadas. El OCR solo funciona en el modo de disparo único y no es compatible con Código múltiple.


¿Cómo configuro el OCR?

La configuración del OCR se realiza siguiendo varios pasos (ver más abajo), pero los pasos pueden completarse en cualquier orden. Tenga en cuenta que el OCR solo funciona en el modo de disparo único. Desplácese mediante los botones inferiores Siguiente y Anterior o haciendo clic en los paneles de la parte superior del panel OCR para ir directamente a un panel. El panel Resumen muestra todas las configuraciones y los errores aparecen en rojo. Puede utilizar el icono de reparación para ir directamente al panel relacionado con el error.

Fuentes: Puede cargar las fuentes que se utilizarán para las lecturas OCR. Las fuentes que ya se utilizan aparecen en el cuadro de diálogo. Al hacer clic en cualquiera de ellas, se muestran acciones adicionales debajo del cuadro de diálogo. Tenga en cuenta que Editar fuente tiene un funcionamiento parecido a Cargar fuente, pero puede seleccionar los caracteres que se incluirán en la carga. Esto permite reducir los tamaños de archivo, lo que se traducirá en tiempos de carga más rápidos del dispositivo. Utilice Ctrl+clic para agregar caracteres uno a uno en la ventana emergente. Puede utilizar la flecha situada junto al botón Aceptar de la venta emergente Fuente para acceder a Cargar como, que permite cambiar el nombre de archivo del archivo de fuentes.

Fijación: Puede configurar la fijación en símbolos o patrones utilizando campos ROI (región de interés) en la imagen de lectura del cuadro de imagen de manera que las lecturas de OCR puedan posicionarse en relación con el elemento fijado. Para la fijación en patrones, la región amarilla permite seleccionar el patrón de aprendizaje y la región naranja permite proporcionar el marco donde se buscará el patrón durante la operación. Para la fijación en símbolos, deberá establecer el código pertinente que ha de buscar el dispositivo. En ambos casos, deberá utilizar Aprender fijación para finalizar la fijación.

Cadenas de OCR: Para finalizar la configuración de OCR, vaya a Cadena de OCR 1. Un «Aprendido» en verde o un «Desaprendido» en rojo indicarán el estado de la cadena de OCR (este código de color se aplicará también al nombre de la pestaña). En Fuente seleccionada puede seleccionar la fuente para la cadena de entre los tipos de fuente ya cargados.

Puede marcar División en campos para establecer qué caracteres pueden aparecer en ciertas posiciones durante una lectura OCR. La información sobre herramientas (sitúe el puntero del ratón sobre el campo de texto a la derecha de División en campos) indica qué representan los caracteres en la cadena de campos.

A continuación, mueva el campo ROI de OCR a la posición que corresponda sobre el texto de la imagen e introduzca el texto de aprendizaje.

Umbral de aceptación es un resultado dado a los caracteres que permite modificar el umbral a partir del cual se aceptan los caracteres en una lectura OCR. Las lecturas están codificadas por colores en la imagen.

Umbral de confianza se fija en la diferencia mínima entre el resultado de los caracteres de la primera correspondencia y la segunda correspondencia que todavía se aceptan en las lecturas OCR.

Una vez haya ajustado todo, haga clic en Aprender OCR para finalizar el aprendizaje de la cadena de OCR. Tenga en cuenta que si utiliza fijación de símbolos o quiere leer códigos que no sean OCR, deberá dejar marcada la opción Permitir resultados parciales.

También se pueden configurar cadenas de OCR adicionales en Cadena de OCR 2-4, cada una con su propia indicación visual (marcos ROI con colores específicos). Tenga en cuenta que cuantas más cadenas de OCR se aprendan, más lento irá el dispositivo.

NOTA: El aprendizaje con Código múltiple no está admitido.


¿Para qué se utiliza Cantidad de códigos?

Puede leer varios tipos de códigos al mismo tiempo. En ese caso, especifique el número de códigos que se leerán en Cantidad de códigos. Luego deberá especificar Cant. máx. de códigos OCR, que determina la cantidad de cadenas de OCR que se leerán (por ejemplo, si Cantidad de códigos es 3 y Cant. máx. de códigos OCR es 1, entonces se leerán tres códigos; uno de ellos será OCR y los otros dos serán otro tipo de código, por ejemplo, DataMatrix). El resto de cantidades máximas de códigos se puede establecer en el panel de Configuración de símbolos asociado.

Permitir resultados parciales: Si se marca esta opción, el dispositivo indicará una lectura correcta aunque no haya podido encontrar todos los códigos configurados en Cantidad de códigos y Cant. máx. de códigos OCR. Si utiliza la fijación de símbolos o quiere leer códigos que no sean OCR, deje marcada la opción Permitir resultados parciales.

Permitir que OCR indique siempre lectura correcta: Si se marca esta opción, el dispositivo indicará las lecturas incorrectas como lecturas correctas para que los usuarios puedan ver cómo se leyeron los caracteres individuales. Un marco verde indica una lectura correcta, un marco azul indica que la lectura estaba por debajo del 25% del umbral de aceptación, un marco amarillo indica que el resultado de confianza está por debajo del umbral de confianza y un marco rojo indica que se trata de una lectura incorrecta. Tenga en cuenta que esta opción se desmarca automáticamente cuando la herramienta de configuración se desconecta del dispositivo.


¿Cuándo debe repetirse el aprendizaje de OCR?

El OCR debe aprenderse inicialmente, pero es posible que deba aprenderse de nuevo si hay cambios en la configuración. Por normal general, el aprendizaje de OCR debe realizarse de nuevo si hay un cambio considerable en la configuración y en su coherencia, incluidos cambios en el tipo de fuente o el tipo de código y la primera vez que se efectúa un cambio entre fijación de patrones y de símbolos (alternar después entre fijación de patrones y de símbolos no requiere reaprendizaje).


¿El aprendizaje de OCR adquiere imágenes?

Durante el aprendizaje de OCR no se adquieren imágenes nuevas. El lector trabaja con la última imagen que se conservó después de un intento de decodificación (esto garantiza que los distintos pasos de aprendizaje se realicen exactamente en la misma imagen). Suele ser la imagen mostrada en la herramienta de configuración, pero puede haber excepciones:

a) Después de la optimización de enfoque o de intensidad de la luz, se envía una nueva imagen a la herramienta de configuración, pero el aprendizaje de OCR no utilizará dicha imagen. En su lugar, el OCR trabaja con la que se conservó después de la última lectura.

b) Si se utilizan varias configuraciones de lectura, la imagen mostrada no será necesariamente una imagen adquirida con los parámetros de la configuración de lectura activa.

Para las excepciones mencionadas, se recomienda encarecidamente activar una sola configuración de lectura (la activa) y disparar el dispositivo para adquirir una nueva imagen antes del aprendizaje.


Validación de datos


¿Qué es la validación de datos?

La validación de datos se utiliza para confirmar que los datos codificados por un símbolo estén en el formato correcto para una empresa, industria o estándar internacional determinados.


¿Dónde se visualiza el historial de resultados de la validación de datos?

Los resultados correcto/incorrecto y de salida de la validación de datos se visualizan en el historial de resultados. La entrada Resultado en la lista del historial de resultados mostrará un icono «+», que sirve para abrir los detalles del resultado del intento de validación. Los resultados de la validación de datos pueden visualizarse en el historial de resultados de la misma forma.


¿Qué significan los códigos de error de la validación?

Los resultados Incorrecto de la validación de datos son los siguientes:

  • 1: identificador de símbolos no válido. El identificador de símbolos es la cadena de tres caracteres que no solo identifica el tipo de símbolo utilizado para la codificación de los datos, sino que también describe cómo procesar los datos. Esta cadena se puede pasar de forma opcional como entrada a la herramienta junto a los datos de decodificación como una entidad independiente o prefijándola al flujo de datos.

    Ejemplo: Para un símbolo UCC/EAN-128, el identificador de símbolos es ]C1. En algunas aplicaciones, esta será la única manera de diferenciar de forma precisa y automática entre símbolos UCC/EAN-128 y Código 128 internos o de la industria. Sin los identificadores de símbolos, no sabría cómo procesar los datos en el símbolo.

  • 2: patrón no coincidente.

  • 3: calificadores de datos no válidos (AI, DI o TEI).

  • 4: identificador de aplicación no válido (AI).

  • 5: identificador de datos no válido (DI).

  • 6: identificador de elemento de texto no válido (TEI).

  • 7: datos no válidos (si los datos no coinciden con el calificador de datos en tipo, longitud o valor).

  • 8: separador de campo no válido.

  • 9: no compatible con ISO/IEC 15434.

  • 10: formatos no compatibles (p. ej. en aplicaciones DoD UID, formatos distintos de 05, 06 o DD).

  • 11: código de formato no válido (códigos de formato distintos de 00-99 y DD).

  • 12: no compatible con ISO/IEC 15434 si la opción de validación ISO/IEC 15434 está seleccionada, pero el flujo de decodificación no corresponde a un símbolo 2D. Solo es posible identificar este fallo si el identificador de símbolos se pasa como entrada a la herramienta.

  • 13: campo de aplicación no válido (un campo que no es compatible con la aplicación).

  • 14: campo de aplicación no compatible (un campo que es compatible con la aplicación pero no con la herramienta).

  • 15: datos de aplicación no válidos (si los datos no cumplen los requisitos específicos de la aplicación).

    Ejemplo: las aplicaciones DoD UID tienen los requisitos siguientes. La cadena de caracteres correspondiente al ID de la empresa no debe superar los 13 caracteres, sin incluir el calificador de datos. La cadena de caracteres correspondiente al número de lote o pieza original (incluidos los caracteres especiales permitidos) no debe superar los 32 caracteres, sin incluir el calificador de datos. La cadena de caracteres del número de serie (incluidos los caracteres especiales permitidos) no debe superar los 30 caracteres, sin incluir el calificador de datos.

  • 16: presencia de varios formatos en el mismo flujo de datos (p. ej. en aplicaciones DoD UID, no puede haber más de un formato en el flujo de datos).

  • 17: campos duplicados (varias ocurrencias del mismo calificador de datos en el mismo símbolo). Algunas aplicaciones, como las aplicaciones DoD UID, no permiten campos duplicados en el mismo símbolo.

  • 18: UID no válida (no están presentes todos los campos necesarios para crear una UID de Construcción # 1 o Construcción # 2 válida).

  • 19: UID de Construcción # 1 no válida (no están presentes todos los campos necesarios para crear una UID de Construcción # 1).

  • 20: UID de Construcción # 2 no válida (no están presentes todos los campos necesarios para crear una UID de Construcción # 2).

  • 21: falta el finalizador de formato al comprobar la conformidad con la sintaxis ISO 15434 o DOD UID.

  • 22: falta el finalizador de mensaje al comprobar la conformidad con la sintaxis ISO 15434 o DOD UID.


¿Qué es la validación DoD UID?

La validación DoD UID se utiliza para evaluar si los datos codificados en un código Data Matrix se han codificado correctamente de acuerdo con las directrices Mil Standard 130 del Ministerio de Defensa estadounidense. Ahora el Ministerio de Defensa de los EE. UU. exige que todos los artículos (de más de 5 000 dólares o con un número de serie único) que reciba o mantenga en inventario se marquen con un número de serie único (UII) y con un formato sintaxis específica. La herramienta de validación DoD UID se utiliza para confirmar si los datos en un código tienen el formato correcto de acuerdo con los tipos de construcción 1 ó 2 del Ministerio de Defensa. La función Validación DoD UID también confirma automáticamente si la cadena de datos está en conformidad con las normas ISO 15434 e ISO 15418. La salida de UII concatenado (o simplemente los elementos de datos del UII sin la sintaxis ISO 15434 y los calificadores de datos ISO 15418) se muestra en el primer campo de resultados del campo Resultados de validación en el panel de tareas Resultados.

Los elementos de datos de construcción 1 incluyen: el identificador de empresa EID del fabricante (CAGE, DUNS, EAN.UCC) es el identificador de una empresa más el número de serie de la pieza dentro del identificador EID. El identificador de empresa y los números de serie están representados por calificadores de datos específicos en función de si una empresa utiliza el formato DI, AI o TEI.

Los elementos de datos de construcción 2 incluyen: el identificador de empresa (EID) del fabricante, el número de referencia del fabricante (PN) y el identificador del número de lote (BN) para la pieza y el número de serie único para la pieza dentro del número de referencia específico del fabricante. El identificador de empresa, el número de referencia/lote y los números de serie están representados por calificadores de datos específicos en función de si una empresa utiliza el formato DI, AI o TEI.

Nota: está opción no está disponible en todos los lectores.


¿Qué símbolo debería usar para la validación DoD UID?

Actualmente, el Ministerio de Defensa estadounidense especifica el código Data Matrix como el estándar para la marcación UID.


¿Qué es EID esperado?

EID esperado hace referencia al identificador de empresa del fabricante en la cadena de datos UII. El identificador de empresa (EID) del fabricante representa el código CAGE, DUNS, EAN.UCC del fabricante u otra identificación. EID esperado es un valor específico de DoD.


¿Qué es PN esperado?

PN esperado hace referencia al número de referencia del fabricante en la cadena de datos UII. PN esperado es un valor específico de DoD.


¿Qué es BN esperado?

BN esperado hace referencia al número de lote del fabricante en la cadena de datos UII. BN esperado es un valor específico de DoD.


¿Qué es la validación ISO?

La función Validación ISO se utiliza para determinar si una cadena de datos está correctamente codificada de acuerdo con la sintaxis ISO 15434 o ISO 15434 más ISO 15418.

ISO 15434 confirma si la cadena de datos se ha codificado con la sintaxis correcta que incluye la evaluación de los caracteres ASCII no imprimibles en la cadena tales como el título del mensaje, separador de datos, código del formato (para AI, DI o TEIs), separadores de grupo y carácter de fin de transmisión.

ISO 15418 confirma si la cadena de datos se ha codificado con los calificadores de datos correctos para cada elemento de datos. Dependiendo de qué formato esté usando el fabricante, ya sea AI, DI o TEI, cada elemento de datos (código EIN del fabricante, número de referencia y número de serie) está precedido por un código específico o un «calificador de datos».

Nota: está opción no está disponible en todos los lectores.

Nota: esta opción también permite Identificadores de elemento de texto como se define en la especificación ATA CSDD.


¿Qué es la validación GS1?

La validación GS1 le permite verificar la sintaxis y la semántica de los sistemas de símbolos respecto a la especificación GS1. El lector puede validar los datos codificados respecto a una cadena de identificadores configurable. Se admiten todos los identificadores de aplicación.

De forma predeterminada, el lector valida el símbolo entrante respecto a la cadena de formato de la Federación Europea de Industrias y Asociaciones Farmacéuticas (EFPIA), por ejemplo:

<AI(01)><AI(10)><AI(17)><AI(21)>

Al usar la validación GS1, podrá configurar qué transmitirá el lector cuando los datos de un símbolo no superen la verificación, incluidos un retorno de carro y un salto de línea. El panel de Resultados detallados mostrará un mensaje de CORRECTO o INCORRECTO para cada símbolo y listará cada identificador de aplicación en el símbolo junto con su elemento de datos acompañante.


¿Qué es la validación de cadena de correspondencia?

La validación de cadena de correspondencia le permite especificar una cadena exacta para que coincida con la cadena codificada por el símbolo. Solo los símbolos con una cadena que coincida con la cadena especificada generarán un resultado correcto.


¿Cómo puedo validar cadenas con valores que cambian?

Active el control Incrementar/Decrementar componente numérico para especificar que parte de la cadena para validar es un valor numérico que incrementa o decrementa con cada lectura sucesiva.


¿Para qué se utiliza el control Incrementar/Decrementar componente numérico?

Utilice esta función para realizar validaciones de cadena de correspondencia en aplicaciones en las que los datos codificados sean seriados o cambien de un modo lineal. Por ejemplo, la función Incrementar/Decrementar componente numérico puede ser muy útil en una aplicación de encuadernación de libros o de revistas en la que se utilicen códigos de barras para hacer un seguimiento de los números de página con el fin de evitar duplicados u omisiones.


¿Cómo configuro la función Incrementar/Decrementar componente numérico?

Puede utilizar esta función si la cadena que está validando contiene una secuencia de dígitos (0-9) que incrementan o decrementan con cada lectura sucesiva. Para utilizar esta función, especifique la posición inicial de los dígitos incrementados o decrementados en el campo Posición inicial (0 es la posición del primer carácter) y el número de caracteres que variarán en el campo Longitud. Si selecciona Automática como Longitud, el lector tratará todos los dígitos consecutivos desde la posición inicial como el valor incrementado o decrementado. Utilice la opción Tamaño de paso para especificar cuánto cambia el valor entre lecturas. Seleccione un valor negativo si el número disminuye.

Por ejemplo, si su cadena inicial es ABC_123XXPY y con cada lectura sucesiva «123» se incrementa en uno, especificaría una Posición inicial de 4, una Longitud de 3, y un Tamaño de paso de 1. (Si estuviera seguro de que los caracteres de la posición 7 en adelante nunca serían dígitos, también podría especificar Automática como Longitud.) Tenga en cuenta que la configuración Automática no incrementa el número de dígitos cuando se alcanza el número máximo, sino que restablece el número al igual que con cualquier configuración de dígitos fijos (por ejemplo, al alcanzar 99 con dos dígitos no se pasa a 100, sino a 00).

De forma predeterminada, si la cadena no es válida o no se puede leer, el valor numérico esperado no cambia. Puede marcar las casillas Actualizar en No lectura y Actualizar en caso de error de validación para especificar que el valor esperado cambie cuando no se lea ningún código, si el código no es válido o en ambos casos.


¿Para qué se utiliza la validación de correspondencia del patrón?

La validación de correspondencia del patrón permite a un usuario introducir una cadena de caracteres específica para confirmar si están presentes en la cadena de datos. Por ejemplo, un usuario podría introducir el patrón 17V, que se utiliza en los formatos DI para identificar el identificador de empresa del fabricante. Si los caracteres 17V están presentes en el código, el lector indicará que la validación es correcta para ese código. Si los caracteres no están presentes, el lector indicará una validación errónea.

Debe usar una Expresión regular como patrón para una validación de patrones.


¿Para qué se utiliza la validación de acción incorrecta?

La validación de acción incorrecta se utiliza para determinar qué transmitirá el lector después de un error de validación. El usuario puede seleccionar diferentes opciones:

  1. Transmitir «Error de validación»: el lector transmitirá la cadena «Error de validación» después de que un código no supere la validación
  2. Transmitir «Error de validación» + cadena decodificada: el lector transmitirá la cadena «Error de validación» después de una cadena decodificada por completo
  3. Transmitir cadena de decodificación anotada: el lector transmitirá la cadena decodificada junto con información sobre el tipo de error y la ubicación del error en la cadena
  4. No transmitir nada: el lector no transmitirá ninguna información
  5. Transmitir «Error de validación» + cadena de decodificación entrecomillada: el lector transmitirá la cadena «Error de validación» seguida de la parte entrecomillada de la cadena decodificada.


¿Para qué se utiliza la adición de validación de acción incorrecta de la casilla CR/LF?

La casilla CR/LF se utiliza para introducir un retorno de carro/salto de línea después de una salida de validación errónea.


¿Cómo buscar cadenas de correspondencia múltiples?

Use la validación de correspondencia de patrones e introduzca una cadena de correspondencia con formato Perl. Por ejemplo, para corresponder las cadenas 123, 456 o 789, introduzca lo siguiente:

^(123¦456¦789)$


¿Qué sucede cuando se activa la Validación de datos?

El estado de la Validación de datos se muestra en la entrada de la lista de resultados Estado de resultados del panel Historial de resultados. El estado para una validación correcta es «Válida» y para una validación incorrecta es «No válida». Para obtener más información sobre el resultado de la validación, se puede desplegar el resultado.


¿Qué es Formato de datos en la validación incorrecta?

El formato de datos «Formato básico» no se aplica a un resultado si falla la validación. En su lugar, se ejecuta la «Validación de acción incorrecta». Esto es diferente del formato de datos «Formato basado en secuencias de comandos». Si se activa «Formato basado en secuencias de comandos», no se ejecuta la «Validación de acción incorrecta» y se ejecuta la función de formato de secuencias de comandos. Esto permite, por ejemplo, matizar el estado de la «Validación de datos» mediante secuencias de comandos.


Configuración de copia de seguridad


¿Qué es la copia de seguridad automática de la configuración del lector?

La copia de seguridad automática funciona con dispositivos conectados a través de Ethernet. Cuando está activada, esta función realiza una copia de seguridad de la configuración del dispositivo en un dispositivo de almacenamiento externo (un servidor FTP) cada vez que la configuración se guarda en flash. Un servicio de Cognex Explorer puede recibir los datos de la copia de seguridad. La restauración se puede realizar manualmente con la herramienta de configuración, comandos DMCC o Cognex Explorer.

Configure el lector con la dirección IP y el número de puerto necesarios para especificar dónde quiere guardar la configuración. También puede establecer una combinación de nombre de usuario y contraseña.


Imprimir código de copia de seguridad del dispositivo


¿Para qué se utiliza la opción Imprimir código de copia de seguridad del dispositivo?

Utilice esta opción para imprimir los códigos de copia de seguridad del lector (código de restablecimiento de hardware y código de reinicio) de manera que pueda sustituir su dispositivo leyéndolo con el lector. Estos códigos también contienen la configuración de red y la configuración serie.

En la sección Notas, puede realizar anotaciones importantes que también se mostrarán en la página impresa. Si desea imprimir los códigos de restablecimiento en páginas separadas, marque la casilla Imprimir código de restablecimiento en la página.


Imprimir código de configuración


¿Para qué se utiliza la opción Imprimir código de configuración?

Utilice esta opción para imprimir los códigos de configuración del lector (restablecimiento de hardware y código de reinicio) de manera que puedan ser leídos por el dispositivo o los dispositivos que desee configurar.

En la sección Notas, puede realizar anotaciones importantes que también se mostrarán en la página impresa. Si desea imprimir los códigos de restablecimiento en páginas separadas, marque la casilla Imprimir código de restablecimiento en la página.


Maestro/Esclavo


¿Qué combinaciones de disparo admiten los disparos de Sincronización de múltiples lectores?

Los disparos de Sincronización de múltiples lectores solo funcionan correctamente si el lector principal y el lector secundario usan combinaciones permitidas y específicas de modos de disparo. Estas son las siguientes:

  • Auto/Auto

  • Único/Ráfaga, Único/Único, Ráfaga/Ráfaga, Ráfaga/Único

  • Manual/Continuo, Manual/Manual, Continuo/Continuo, Continuo/Manual

  • Presentación/Presentación, Auto/Presentación, Presentación/Auto


¿Qué es el Disparo en grupo?

Todos los lectores del mismo grupo y en la misma subred se disparan por una fuente única de disparo, que procede del lector principal activo.


¿Cómo se reúnen y presentan los resultados?

Cuando se activa la opción Disparo en grupo, el lector, como lector principal, combinará los resultados de los lectores secundarios y, como lector secundario, enviará los resultados al lector principal.


¿Cómo puedo agregar un nuevo Nombre de grupo?

  1. Haga clic en el botón Agregar nuevo.

  2. Aparecerá el diálogo Agregar nuevo grupo. Elija el nombre de grupo que desea y haga clic en Aceptar. Asegúrese de usar un nombre de grupo único.

  3. Compruebe que su nuevo grupo aparece en la lista Nombre de grupo y que su lector aparece en la lista a la derecha.

  4. Para cualquier dispositivo del grupo que no quiera que sea interrumpido, establezca una contraseña en la pestaña Autenticación del panel Configuración de red.


¿Cómo puedo hacer que el lector principal informe de todos los resultados de códigos de cada lector en el grupo de Sincronización de múltiples lectores?

En el modo Sincronización de múltiples lectores, se puede configurar el lector principal para que informe de sus propios resultados de códigos y de todos los resultados de códigos pertenecientes a todos los demás lectores secundarios. Para poder hacer esto, en la pestaña Código múltiple del panel Configuración de símbolos, deberá configurar el valor del Número de códigos para el lector principal. Este valor debe establecerse de acuerdo con el número total de códigos que quiere recibir del grupo de Sincronización de múltiples lectores.

Por ejemplo, si tiene un lector principal y un lector secundario, cada uno de los cuales lee un código individual, entonces el valor del número de códigos para el lector principal sería de 2. Si el lector secundario estuviera leyendo 3 códigos y el lector principal 1, entonces el número de códigos en el lector principal se configuraría como 4. La configuración del número de códigos en el lector principal puede variar desde 1 hasta el número total de códigos leídos por todos los lectores en un solo grupo de Sincronización de múltiples lectores.

Tenga en cuenta que si el lector secundario lee varios códigos, también deberá establecer la configuración de código múltiple del lector secundario para que lea y proporcione resultados de códigos múltiples al lector principal.


¿Por qué ha desaparecido mi nombre de grupo?

No ha asignado ningún lector a ese nombre de grupo. Un grupo existe solo mientras tenga un lector asignado a él. Si mueve el último lector a un grupo diferente, eliminará el grupo.


¿Qué lector es el lector principal?

Si los lectores del grupo están usando el modo de disparo Auto o el modo Presentación, entonces aparecerá una casilla para cada lector en la lista denominada Lectores en este grupo. Marque la casilla del lector que desee configurar como lector principal.

Si el grupo de lectores está usando un disparo externo o recibiendo un disparo de software (por ejemplo, de la herramienta de configuración), entonces el lector que reciba primero el disparo actuará como lector principal.

Para todos los modos de disparo, solo un lector por grupo podrá ser configurado como principal en un momento determinado.


¿Por qué no puedo encontrar mi lector en la lista?

Si la herramienta de configuración está ejecutándose en un PC que se encuentre en una subred diferente a la del lector al que se conecta, dicho lector no aparecerá en ninguna de las listas. Agregue su lector a la lista usando el botón Agregar dispositivo.


¿Cómo puedo impedir que otra persona conecte mi lector en el grupo?

Establezca una contraseña para ese lector. Vaya al panel Configuración de red y establezca una contraseña en la pestaña Autenticación.


¿Qué es el Tiempo de espera de respuesta del lector secundario?

El Tiempo de espera de respuesta del lector secundario es el tiempo medido en milisegundos que el lector principal esperará para un recibir un resultado del lector secundario.


¿Por qué no tiene efecto mi Formato de datos del lector secundario?

En el modo Sincronización de múltiples lectores, el lector principal actúa como si todos los resultados de códigos de los lectores secundarios fueran sus propios resultados. Esto quiere decir que el formato de datos del lector principal tendrá efecto, pero no se considerarán las reglas de formato en los lectores secundarios.


¿Cómo funciona el retraso del disparo en el modo Sincronización de múltiples lectores?

El lector principal y los lectores secundarios se disparan normalmente a la vez; no obstante, se puede establecer un retraso del disparo para el lector principal y para cada lector secundario del grupo. El tiempo total del retraso de disparo para el lector principal será simplemente el tiempo de retraso de disparo configurado en este. El tiempo total del retraso de disparo para el lector secundario será igual al tiempo de retraso de disparo del lector principal más el del lector secundario.


¿Qué es la opción Lectores sincronizados?

En los modos de disparo Único, Ráfaga, Continuo y Auto, es posible sincronizar la adquisición de imágenes en varios dispositivos usando la interfaz de sincronización.

La sincronización permite usar una iluminación estroboscópica compartida para exponer simultáneamente todos los sensores. Puede sincronizar hasta 16 lectores, disparándolos opcionalmente con una secuencia definida para evitar que lectores opuestos se cieguen mutuamente. Tenga en cuenta que el disparo sincronizado solo es compatible con la iluminación externa en el conector dedicado.

Tenga en cuenta que este mecanismo no sincronizará esta ni otras configuraciones del generador de imágenes; por ejemplo, deberá configurar la exposición y la ganancia de forma individual para cada lector. Esta característica solo sincroniza la adquisición de imagen, y el disparo tiene lugar a través del mecanismo de Sincronización de múltiples lectores existente.

Para configurar la adquisición sincronizada en el lector, active PTP (protocolo de tiempo de precisión) en el panel Sincronización de múltiples lectores de la herramienta de configuración DataMan, en Lectores sincronizados (IE1588). De forma individual en cada lector, establezca Solo lector secundario como corresponda para definir las relaciones de los lectores Sincronización de múltiples lectores.

Los siguientes pasos describen la configuración en más detalle:

  • 1. Marque la casilla Activar PTP.

  • 2. Deje la casilla Solo esclavo marcada si ya hay un reloj maestro PTP en la red (de lo contrario, desmarque la casilla en al menos un lector).

  • 3. Utilice los controles Prioridad 1 y Prioridad 2 para establecer la prioridad. Prioridad 1: puede asignar de forma estática a cada reloj una prioridad específica y establecerla aquí, definiendo previamente una prioridad entre ellos. Prioridad 2: orden establecido como respaldo en caso de que los otros criterios no sean suficientes. Debe ser un valor único en la red seleccionado por un administrador de TI.

  • 4. El estado del protocolo puede observarse en el cuadro Estado.

  • 5. Active SML sincronizada por PTP para sincronizar los disparos de Sincronización de múltiples lectores.

  • 6. Establezca Tiempo entre Inicio del disparador y la marca de fecha y hora de adquisición sincronizada si procede. Esto representa el tiempo que el lector principal agrega al disparo para asegurarse de que todos los dispositivos ya hayan recibido el paquete TCP antes de esta marca de fecha y hora.

  • 7. Establezca Offset local añadido a la marca de fecha y hora de adquisición sincronizada si procede. Esto representa el tiempo que el esclavo agrega a la marca de fecha y hora para realizar adquisiciones de imágenes offset.


¿Cómo funciona Nunca leer el mismo código dos veces en un sistema de Sincronización de múltiples lectores?

Si se activa el comando Nunca leer el mismo código dos veces en Configuración de decodificación en el lector principal y el lector secundario lee el mismo código, el lector principal considera todos los resultados y filtra las lecturas duplicadas independientemente de su origen.


Registro de datos


¿Qué es el registro de datos?

El registro de datos le permite usuario guardar automáticamente en la ubicación de archivos especificada las imágenes leídas correctamente y las que no se han podido leer. Además, también puede guardar los informes de validación de datos para los símbolos que verifique si se ha activado la validación de datos para el tipo de código escaneado por el lector. Asegúrese de que permanece conectado a la herramienta de configuración para que funcione el registro de datos.


¿Cuándo desactivo los gráficos superpuestos en un informe?

Seleccione Desactivar gráficos superpuestos en informe si no desea que el cuadrado verde que rodea un código leído aparezca en el PDF.


Configuración de hora del dispositivo


¿Qué opciones hay disponibles en Configuración de hora del dispositivo?

Puede seleccionar la zona horaria para su dispositivo en el menú desplegable. El cuadro de texto situado más abajo muestra el texto de la zona horaria de la configuración en estilo POSIX y se puede editar libremente.

Si se selecciona Activar NTP, el dispositivo sincroniza su configuración de zona horaria con el servidor especificado en los recuadros situados más abajo (NTP1). El segundo recuadro (NTP2) señala a un segundo servidor NTP, que puede utilizarse como respaldo, así como para eliminar diferencias horarias específicas de conexiones entre dos servidores. Es suficiente con especificar NTP1, pero la precisión y la fiabilidad horaria aumentan si se utilizan dos servidores. Tenga en cuenta que la información de zona horaria también se utiliza en el objeto de fecha en Formato basado en secuencias de comandos.


Vista de herramientas de imagen


¿Qué es el Panel de imágenes?

En este panel, puede ver las imágenes leídas por el dispositivo.

Utilice los iconos de lupa para ajustar la imagen al tamaño de la ventana Vista de herramientas de imagen para alejar y acercar la imagen, o para visualizar la imagen en un modo píxel a píxel, respectivamente.

También puede activar o desactivar Información del enfoque en la imagen en el modo Visualización en vivo y copiar la imagen en el portapapeles.

Utilice la opción Guardar imagen para guardar solamente la imagen actual o todas las imágenes de la ráfaga, y las opciones de Registro para registrar en el sistema de archivos todas las imágenes no leídas o todas las decodificadas. Haga clic en la última opción de Registro, Configuración de registro e informes... para abrir la ventana de Opciones de la herramienta de configuración, a la que también se puede acceder desde la pantalla de Inicio de la herramienta de configuración a través del menú Opciones.

NOTA: Configuración de la imagen mostrada no tiene efecto cuando se guarda la última imagen tomada del Panel de imágenes (arrastrando y soltando). La última imagen siempre se guarda a tamaño completo (la máxima resolución del dispositivo).


Tengo problemas con la lectura de los símbolos. ¿Qué debo hacer?

  • Compruebe que el lector se encuentre en la distancia de trabajo especificada para el tamaño y tipo de símbolo, como se indica en la guía de referencia rápida.

  • Asegúrese de que el símbolo esté centrado en el área de imágenes del lector; asegúrese de que el símbolo esté centrado en el enfoque del láser rojo cuando dispare el dispositivo.

  • Haga clic en la opción Optimizar intensidad de la luz si está activada para que el lector ajuste la intensidad de la luz de la imagen automáticamente. (No admitido para todos los modos de disparo ni para la exposición automática.)

    NOTA: Optimizar intensidad de la luz no funciona si una de las dimensiones de la RoI es más pequeña que 144.

  • Haga clic en Configuración de símbolos y asegúrese de que los símbolos que está utilizando estén activados.


¿Cómo puedo enviar un disparo al lector utilizando la herramienta de configuración?

Haga clic en el botón de disparo (icono de relámpago) en la barra de herramientas superior o pulse <Ctrl>-T.


¿Cómo puedo guardar una imagen adquirida en un archivo?

Haga clic en el botón Guardar imagen en la barra de herramientas. Puede guardar todas las imágenes de una ráfaga abriendo la lista desplegable y haciendo clic en Guardar todas las imágenes de ráfaga.

También puede arrastrar y colocar su imagen en su PC. Haga clic en la imagen en el Visor de imágenes, arrástrela fuera de la herramienta de configuración y suéltela.

Tenga en cuenta que, en caso de querer guardar una imagen con arrastrar y colocar y la imagen no es la más reciente (está guardándola desde el Historial de resultados de lectura), la imagen se guardará con la configuración de imagen mostrada. De manera predeterminada, esta será de calidad reducida. En Configuración de la imagen mostrada, puede cambiar el tamaño de la imagen a completo y el formato a Bitmap.


¿Por qué no puedo ver todas las imágenes con una velocidad de transferencia de alta frecuencia por segundo?

Si está usando una configuración (modos de disparo Auto, Presentación o Externo) que posibilite la lectura y la transferencia de imágenes con una velocidad de 100 fotogramas por segundo (o superior), el dispositivo almacenará estas imágenes en su propio búfer de almacenamiento, pero la herramienta de configuración no podrá transferir todas las imágenes. Asegúrese de deseleccionar la casilla Transferir y mostrar imagen en el panel Configuración de la imagen mostrada para conseguir que la velocidad de transferencia siga siendo elevada.


¿Qué es Diagnóstico de símbolos (se necesita clave de funciones)?

Diagnóstico de símbolos es una función que proporciona información gráfica proveniente del dispositivo para los códigos de barras no leídos. Examinar dicha información le permitirá determinar por qué no se ha decodificado un código de barras. La información proporcionada puede señalar los problemas siguientes (en una región del código de barras):

  • No se ha encontrado el patrón inicial o final (flecha naranja en el código)

  • Daños o error de impresión en el propio código (región del rectángulo rojo en el código)

  • La zona de silencio no es suficiente (región del rectángulo magenta en el código)

  • Error en la verificación de la suma de comprobación (rectángulo azul alrededor del código)

Además del diagnóstico gráfico, Diagnóstico de símbolos ofrece mediciones de legibilidad para cada resultado no leído en la parte superior izquierda de los códigos no leídos. Las mediciones pueden ayudarle a evaluar la calidad de impresión o de la imagen, así como a mejorar la configuración ya existente.

Diagnóstico de símbolos solo está disponible para imágenes PNG cargadas (Acciones>Imágenes>Cargar imagen) que hayan sido firmadas por un lector de Cognex (no necesariamente el mismo lector; las imágenes se firman automáticamente cuando se guardan desde cualquier lector). Después de cargar una imagen, compruebe la información de Diagnóstico de símbolos en la ventana de imágenes Panel de imágenes o Configuración rápida.

Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


¿Qué error indica una flecha naranja en el Diagnóstico de símbolos?

Una flecha naranja indica que no se ha detectado el patrón inicial o final. No se pudo decodificar la región indicada por la fecha. Las causas del fallo pueden ser las siguientes (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso):

  • El patrón inicial o final está cortado/dañado.

  • El código está cortado (debido a los límites de la imagen o por un objeto que tapa el código).

  • Degradación de la calidad de la imagen (a menudo, pero no siempre, debido a la calidad de la luz).

  • Etiquetas de códigos de barras deformadas o dobladas.

Nota: Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


¿Que indica un rectángulo rojo dentro del código de barras en Diagnóstico de símbolos?

Un rectángulo rojo indica que existe un daño físico o un problema de impresión en el código de barras. La región interior del rectángulo es donde se encuentra el daño o el problema de impresión. Ejemplos habituales de problemas de impresión (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso):

  • Goteo de tinta que une varias barras en una.

  • Fallo de impresión de una barra que reduce su grosor por debajo de la tolerancia de decodificación.

Nota: Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


¿Que indica un rectángulo magenta en el lateral de un código de barras en Diagnóstico de símbolos?

Un rectángulo de color magenta indica que no se respeta la zona de silencio. Un incumplimiento de la zona de silencio se produce cuando no hay espacio suficiente a uno o ambos lados del código de barras. En función de los símbolos, los lectores toleran cierto incumplimiento de la zona de silencio. El incumplimiento de la zona de silencio suele deberse a que el texto o el rectángulo alrededor del código de barras está demasiado cerca del código de barras en uno o ambos lados o a que el código quedó cortado por los límites de la imagen (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso).

Nota: Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


¿Que indica un rectángulo azul alrededor del código de barras en Diagnóstico de símbolos?

Un rectángulo azul indica que ha fallado la verificación de la suma de comprobación del código de barras. Causas habituales del fallo de validación de la suma de comprobación (consulte la nota técnica correspondiente para ver imágenes detalladas que ilustran cada caso):

  • Código de barras dañado (los códigos de barras pueden estar doblados o alineados de manera que se decodifiquen todos los caracteres de los datos pero siga tratándose de una no lectura, porque la verificación de la suma de comprobación no es correcta).

  • Impresión de un patrón incorrecto (la cadena codificada y el patrón de código de barras impreso no coinciden, y si los símbolos admiten la suma de comprobación, el decodificador puede indicar dicho fallo).

Nota: Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


¿Qué es el texto gráfico que se observa cerca de la región del código de barras en Diagnóstico de símbolos?

Además del diagnóstico gráfico, el Diagnóstico de símbolos ofrece mediciones de legibilidad para cada resultado no leído. Mediciones como Contraste de símbolo y Contraste de borde mínimo pueden ayudar a los usuarios a evaluar la calidad de impresión o de la imagen, así como a mejorar la configuración ya existente. Las mediciones se muestran en la parte superior izquierda de cada código de barras no leído.

La tabla inferior muestra la correspondencia entre el nombre de medición mostrado y su nombre completo. Consulte las mediciones de legibilidad para entender qué mide cada medición.

Nombre completo | Nombre mostrado | Posibles calificaciones
Contraste de símbolo | C | A,B,C,D,F
Contraste de borde mínimo | EC | A,F
Cambio de tamaño de impresión | PG | A,F
Reflectancia mínima | MR | A,F

Nota: Nota: Diagnóstico de símbolos es una función que se activa exclusivamente mediante clave de funciones.


Almacenamiento y transferencia


¿Qué es la configuración de la imagen almacenada?

La configuración de la imagen almacenada controla el modo en el que el lector almacena las imágenes que adquiere como respuesta a las entradas del disparo de adquisición así como las imágenes en directo tomadas por cualquier lector. La modificación de esta configuración no afecta al rendimiento del lector, sino solo a la calidad de la imagen y a la velocidad de transferencia entre el lector y la herramienta de configuración.

  • tamaño: de forma predeterminada, la herramienta de configuración muestra todos los píxeles de la imagen adquirida, o una fracción de cada imagen durante una visualización en vivo. La elección entre diferentes tamaños de imagen permite al lector realizar un submuestreo de cada imagen, lo que puede mejorar considerablemente la velocidad de transferencia de la imagen del lector a la herramienta de configuración a costa de algunos detalles de imagen precisos.

  • formato: De forma predeterminada, el lector almacena cada imagen adquirida en un formato .jpeg, que precisa menos memoria y puede transferirse del lector a la herramienta de configuración más rápido que una imagen en formato .bmp

  • calidad: Disponible únicamente si se utiliza el formato de imagen .jpeg, este control ajusta los parámetros internos que permiten al lector realizar una operación de suavizado en la imagen adquirida, que puede reducir o mejorar la velocidad de transferencia del lector a la herramienta de configuración.


¿Qué es la opción Gráficos superpuestos?

Cuando seleccione esta opción, las imágenes que guarde (a través de un FTP o grabándolas) contendrán gráficos superpuestos como archivos SVG adjuntos a los archivos de las imágenes.

Esta opción resultará útil cuando quiera grabar y reproducir imágenes. La función Almacenamiento y transferencia no realiza ninguna decodificación, pero si selecciona la opción Gráficos superpuestos, los datos de decodificación se guardarán junto al archivo de imagen y se mostrarán cuando reproduzca sus imágenes guardadas.


¿Por qué no veo las imágenes decodificadas?

La función Almacenamiento y transferencia no realiza ninguna decodificación. Active Gráficos superpuestos en el panel Configuración de la imagen almacenada, y sus imágenes se guardarán con los gráficos superpuestos (como archivos SVG) que se mostrarán cuando reproduzca sus imágenes. Estos gráficos mostrarán los datos decodificados junto a otra información del decodificador.


¿Qué puedo hacer con Almacenamiento y transferencia?

Almacenamiento y transferencia le permite controlar qué imágenes se graban y guardan en el lector; le permite ver imágenes que se hayan guardado en el lector y le permite también transferirlas a su PC.

  • La pestaña Almacenamiento de imágenes le permite controlar qué imágenes se guardan en el lector.

  • La pestaña Transferencia a PC de imágenes le permite controlar cómo se transfieren las imágenes del lector a su PC.

  • La pestaña Transferencia por FTP de imágenes le permite configurar transferencias de imágenes automáticas del lector a su PC.

  • Use la pestaña Transferencia por FTP de resultados para configurar el lector con la dirección IP y el número de puerto necesarios para enviar los resultados de decodificación a un servidor FTP.


¿Puedo enviar resultados decodificados a un servidor FTP?

Use la pestaña Transferencia por FTP de imágenes para configurar en el lector la dirección IP y el número de puerto necesarios para enviar los resultados de decodificación a un servidor FTP. La pestaña también contiene la configuración de una combinación de nombre de usuario y contraseña, junto con el nombre del archivo para almacenar los resultados.


¿Cómo puedo almacenar los datos del FTP en un directorio diferente del directorio raíz?

El campo Nombre de archivo no solo acepta nombres de archivos sino también nombres de rutas. Use barras diagonales como delimitadores. Por ejemplo, /imágenes/imagen.


¿Por qué no puedo ver las imágenes y los resultados en mi directorio de FTP?

Asegúrese de que dispone de los permisos necesarios para crear archivos. Si se encuentra marcada la opción Adición, asegúrese de que el usuario de FTP disponga de permisos de adición (que son distintos de los permisos de escritura). El usuario de FTP también deberá comprobar la dirección IP del servidor FTP correcto.


¿Para qué sirve la lista Qué resultados almacenar?

La lista Qué resultados almacenar le permite elegir qué tipo de imágenes se almacenan de forma interna en el lector, tanto si contienen información de decodificación (Leídas), como si no contienen información de decodificación (No leídas), si contienen ambas (Todas) o si se produce un fallo de validación, en cuyo caso solo se almacenarán las imágenes decodificadas correctamente pero con fallo de validación.

No obstante, tenga en cuenta que en los modos Ráfaga y Continuo todas las imágenes para toda la secuencia se almacenan según la decisión de si la secuencia era de Leídas o No leídas. Para el modo Ráfaga, toda la secuencia conlleva todas las imágenes especificadas por la cuenta de ráfaga. En el modo Continuo, el disparo adquiere las imágenes mientras la señal de disparo permanece activa, lo que quiere decir que todas las imágenes se almacenan y guardan hasta que termina dicha señal de disparo.


¿Qué es la opción Qué imágenes almacenar para un resultado?

Puede elegir qué imágenes almacenar para un resultado. Igual al resultado significa que para una lectura correcta, el lector solo guarda imágenes con un código encontrado.


¿Qué es el Límite de imágenes por resultado?

Puede establecer cuántas imágenes se guardan por resultado. Este número no puede ser superior al Tamaño máximo del búfer de almacenamiento.

Puede que quiera limitar las imágenes si un disparo realiza varias adquisiciones con código múltiple, ya que puede haber varias imágenes leídas correctamente. También puede usar este límite para las imágenes no leídas y para varias imágenes no decodificables.


¿Qué es el tamaño máximo del búfer de almacenamiento?

El tamaño máximo del búfer de almacenamiento es el número máximo de imágenes que pueden almacenarse en el lector. Este número se encuentra limitado por la memoria de dicho lector, pero puede fijarse en un número menor que el máximo para impedir que se guarden más imágenes de las deseadas en el servidor FTP o en el PC.

Tenga en cuenta que en el modo Ráfaga, el valor de la Longitud de ráfaga más el Tamaño máximo del búfer de almacenamiento debe igualar el número máximos de búferes de imagen en el lector. La herramienta de configuración reducirá automáticamente el Tamaño máximo del búfer de almacenamiento si el valor de la Longitud de ráfaga más el Tamaño máximo del búfer de almacenamiento es mayor que el número máximo de búferes en el lector.

Dado que los búferes para almacenar imágenes en el dispositivo y los búferes para el procesamiento de imágenes se comparten, también se recomienda reducir el número de imágenes almacenadas en el modo de disparo Único, en caso de que se recoja una serie de imágenes y la velocidad de disparo sea alta. Esto garantizará que el dispositivo tenga suficientes búferes para el procesamiento normal.


¿Qué es la configuración Disponible para herramienta de configuración/DMCC?

Disponible para herramienta de configuración/DMCC indica el número de imágenes que no utiliza el sistema de adquisición o Grabación de imágenes. Hace referencia al número máximo de imágenes de resultados que pueden transferirse a la herramienta de configuración o al SDK para un único resultado.

NOTA: se trata de un valor informativo que no puede modificarse.


¿Qué puedo establecer con el modo de Imagen no leída?

La Imagen no leída guarda solo una imagen por disparo y usted podrá elegir cuál. El Período de imagen no leída almacena cada enésima imagen leída incorrectamente. Se evalúa en los diferentes modos de disparo. Por ejemplo, si ha seleccionado el modo de disparo Ráfaga con una longitud de 5 un período configurado como 3, se almacenarán la 1ª y la 4ª imagen de la primera, pero la 2ª y la 5ª de la segunda.


¿Qué es el Período de imagen no leída?

El Período de imagen no leída es el ritmo al que se almacenan las imágenes no leídas. Si se establece un valor de 1, entonces se almacenan todas las imágenes no leídas. Si establece como valor un número integral N en el que N es mayor que 1, solo se almacenará cada enésima imagen no leída.

Configurar un período de imagen no leída mayor a 1 le permite reducir el número de imágenes no leídas que se almacenan.

El período de imágenes no leídas también afecta al almacenamiento de imágenes si la opción Qué resultados almacenar se establece como Leídas, porque cuando las imágenes leídas se almacenan, todas las imágenes asociadas con un disparo de lectura único se marcan como leídas, de forma que también se puedan almacenar las imágenes no leídas adquiridas con anterioridad. Configurar el valor de período de imagen no leída puede reducir el número de estas imágenes que se almacenan.


¿Qué es el Número de imagen no leída?

Le permite guardar la enésima imagen de una ráfaga que finalmente fue una imagen no leída. Por lo tanto, no se almacenará si el modo de disparo no es ráfaga o si la longitud de ráfaga es menor que N.


¿Qué es la Tasa de imágenes no leídas?

El tiempo Tasa de imágenes no leídas es la frecuencia del recuento Tasa de imágenes no leídas (número de imágenes). Puede especificar un número exacto y una unidad para especificar este tiempo. Este recuento y tiempo determinan el ritmo sostenido de imágenes leídas incorrectamente. La ráfaga determina la tasa máxima por tiempo.


¿Qué es el Intervalo de imágenes no leídas?

El intervalo de imágenes no leídas almacena todas las imágenes leídas incorrectamente desde el primer número de imagen no leída al último número de imagen no leída.


¿Qué puedo configurar con el modo Imagen leída correctamente?

Imagen leída correctamente guarda todas las imágenes leídas correctamente almacenadas a menos que establezca una tasa límite.

Puede limitar el número de imágenes leídas correctamente que se almacenan seleccionando Tasa limitada. Establezca la tasa de imágenes leídas (el número de imágenes almacenadas y la frecuencia de este recuento) y la ráfaga de la tasa, que es la tasa máxima para el tiempo establecido.


¿Qué sucede si marco la opción Permitir sobreescritura del búfer?

La opción Permitir sobreescritura del búfer controla si el almacenamiento de imágenes en el búfer sobrescribe las imágenes más antiguas o interrumpe el almacenamiento cuando el búfer esté lleno.


¿Cómo puedo asegurarme de que las imágenes se borran después de la transferencia?

Marque la casilla Borrar tras la transferencia, que controla si las imágenes se eliminan después de la transferencia. Esto se aplica a cualquier modo de transferencia, incluida la transferencia por FTP de imágenes y la transferencia del lector al PC.


¿Por qué no se encuentra activado el botón Transferir ahora?

Si ha almacenado imágenes en el lector, primero deberá seleccionar la carpeta en la que guardarlas. Debe interrumpir la grabación antes de que pueda comenzar la transferencia.


¿Limpia también la cinta de imágenes el botón Despejar carpeta de transferencia?

El botón Despejar carpeta de transferencia borra todas las imágenes de la carpeta. Si las mismas imágenes se muestran actualmente en la cinta de imágenes, ésta también se limpiará.


Si ya tengo los archivos en la carpeta seleccionada, ¿se sobrescriben?

Si en la carpeta seleccionada ya existen archivos que se correspondan con el formato [Índice], el índice inicial se incrementará de forma automática hasta que no exista una correspondencia, y después comenzará la transferencia. Los archivos de imágenes no se sobrescribirán.


¿Puedo ver las imágenes individualmente?

Puede ver las imágenes una por una, pero debe seleccionar toda la carpeta en la que están ubicadas las imágenes. Una vez que se muestren las imágenes de la carpeta seleccionada, haga clic en ellas, usando los botones de adelante y atrás.


¿Tengo que empezar de nuevo a visualizar las imágenes si tengo que abandonar el panel?

No, abandonar el panel Almacenamiento y transferencia detendrá la reproducción como si se hubiese hecho clic en el botón Pausa.


¿Cómo transfiero las imágenes a un servidor FTP?

Use la pestaña FTP para establecer la configuración necesaria para transferir imágenes a un servidor FTP. La pestaña contiene la configuración para la dirección IP y el número de puerto del servidor, así como una combinación de nombre de usuario y contraseña. Tenga en cuenta que las imágenes enviadas mediante FTP no tienen su envío garantizado, que podría no tener lugar cuando el lector esté operando a una frecuencia superior y no pueda programar el momento de transferencia de las imágenes. Tenga en cuenta también que la transferencia mediante conexiones inalámbricas puede ser más lenta que la comunicación de red normal. En dichos casos, se recomienda utilizar imágenes comprimidas o con una resolución más baja.

Las opciones de Nombre de archivo le permiten especificar el archivo donde se almacenarán las imágenes. El campo Nombre de archivo le permite especificar una ruta en relación al directorio raíz del servidor FTP (por ejemplo, /imágenes_erróneas/imagen). La extensión de nombre de archivo (.jpg o .bmp) que aparece en la etiqueta que sigue al nombre de archivo se corresponde con la configuración de formato de imagen en el panel Configuración de la imagen almacenada. Tenga en cuenta que el lector no crea directorios; el directorio debe estar disponible y accesible.

El control Máx. valor de adición indica el límite del valor de incremento usado en el nombre del archivo. Un valor de 0 indica que no se sumará ningún incremento y que el archivo puede sobrescribirse.

El Nombre de archivo generado por la secuencia de comandos permite escribir una secuencia de comandos que genere el nombre de archivo en la pestaña Almacenamiento FTP del panel Secuencias de comandos.

La opción Nombre de archivo generado por el servidor comienza con una ruta en blanco que indica el directorio raíz del servidor FTP.


No funciona la transferencia por FTP de imágenes en tiempo de ejecución. ¿Qué debo hacer?

Asegúrese de que se cumplen las siguientes condiciones:

  • La dirección del servidor, el nombre de usuario y la contraseña están correctamente configuradas.

  • El modo de transferencia se ha establecido como «FTP - Tiempo de ejecución».

  • La pestaña Búfer tiene establecida la opción «Qué resultados almacenar» con cualquier valor excepto Ninguna (de acuerdo con sus necesidades).

  • Su servidor FTP admite la transferencia de imágenes.


¿Qué es el Nombre de archivo generado por la secuencia de comandos?

Puede escribir una secuencia de comandos que genere el nombre de archivo para la transferencia por FTP en la pestaña Almacenamiento FTP del panel Secuencias de comandos.


¿Qué es el Nombre de archivo generado por el servidor?

Algunos servidores FTP son compatibles con esta funcionalidad para nombrar de forma única los archivos entrantes antes de guardarlos en el disco.


¿Cuáles son los diferentes modos de transferencia?

El modo de transferencia A petición transferirá las imágenes cuando haga clic en Transferir ahora en la herramienta de configuración o cuando envíe el DMCC apropiado. Si elige el modo de transferencia FTP - Tiempo de ejecución las imágenes se enviarán automáticamente al servidor FTP tan pronto como se active la conexión.


¿Por qué se desactiva todo el panel cuando transfiero archivos?

El panel se desactiva para lograr la mayor estabilidad de transferencia por FTP de imágenes posible. La transferencia por FTP de imágenes puede llevar varios minutos, dependiendo de la velocidad de conexión al servidor FTP y del tamaño y número de imágenes transferidas.


¿Por qué no puedo enviar el tiempo de ejecución de las imágenes a un servidor FTP externo con una velocidad de transferencia de alta frecuencia por segundo?

Si está usando una configuración (modos de disparo Auto, Presentación o Externo) que posibilite la lectura y la transferencia de imágenes con una velocidad de 100 fotogramas por segundo (o superior), el dispositivo almacenará estas imágenes en su propio búfer de almacenamiento, pero no podrá enviar imágenes a un servidor FTP externo.

Si tiene marcada la opción Permitir sobrescritura del búfer, lo más probable es que las imágenes se sobrescriban. Si no la ha marcado, las imágenes nuevas no se almacenarán hasta que vuelva a haber espacio disponible en el búfer.


¿Qué es la configuración Servidor Mitsubishi GOT?

Esta configuración optimiza las conexiones FTP en Mitsubishi GOT y otros servidores FTP permitiendo el uso de tiempos de espera inactivos (agregando NOOPs periódicos) y tiempos de espera opcionales para cerrar una conexión de control inactiva. También proporciona soporte para el modo de escritura Mitsubishi GOT.


¿Qué es la configuración Servidor SFTP?

Esta configuración permite utilizar el protocolo de transferencia segura de archivos para la transferencia cifrada de archivos.


¿Para qué se utiliza la configuración Tiempo de espera inactivo?

Tiempo de espera inactivo es la cantidad de tiempo que un puerto se mantiene abierto sin tráfico saliente. Una vez que el lector abre una conexión con un servidor FTP, el lector mantiene dicha conexión abierta mientras haya tráfico.

Si no hay tráfico en el periodo establecido como Tiempo de espera inactivo, se cierra la conexión. Esto puede ser útil si la transferencia por FTP se realiza únicamente de forma ocasional y no se desea sobrecargar la red manteniendo la conexión abierta.

Para poder establecer el tiempo de espera inactivo, primero debe marcar la casilla Activar tiempo de espera inactivo.


Monitor de procesos


¿Cómo utilizo el monitor de procesos?

Haga clic en Mostrar estadísticas de lectura para visualizar las estadísticas. Al hacer clic en el botón Borrar estadísticas, se descartarán las imágenes y estadísticas almacenadas para los resultados de lectura. NOTA: está opción no está disponible en todos los lectores Ethernet.

La opción Cambiar a Modo configuración muestra las opciones de configuración del lector o lectores seleccionados.


¿Puedo guardar resultados de lectura en un archivo?

Pulse <Ctrl>-C para copiar los datos del marco Historial de resultados de lectura y péguelo en otra aplicación.


¿Qué es el Recuento de elementos?

El Recuento de elementos es el número de paquetes que causan una lectura incorrecta cuando la opción Permitir almacenamiento de imágenes no leídas está activa.


Opciones


¿Qué puedo configurar en la página Opciones?

El panel Opciones de la herramienta de configuración DataMan le permite realizar configuraciones en la aplicación de acuerdo con sus preferencias.


¿Qué puedo establecer en el campo Configuración de idioma?

Aquí, puede seleccionar el idioma en el que desea utilizar la herramienta de configuración. El valor predeterminado es Inglés.

NOTA: Es preciso reiniciar la aplicación para que los cambios surtan efecto.


¿Qué puedo configurar en el campo Visualización de códigos de Página de códigos?

Aquí puede establecer de qué forma se codificará la cadena de lectura.


¿Qué puedo establecer en el campo Esquema de color?

Seleccione el esquema de color de la ventana Herramienta de configuración DataMan en este campo.


¿Qué puedo ajustar en el recuadro Restablecer configuración?

En este recuadro, seleccione para qué categoría (Comunicación, Diseño, Mensajes que no se volverán a mostrar, Registro de datos, Dispositivos excluidos, Página de códigos, Idioma, RTM Lean - Todas las configuraciones, Carpetas predeterminadas, Dispositivos virtuales, Verificación, Alerta sonora, Asistentes) desea restablecer los valores predeterminados.


¿Qué es la configuración Ubicación de copia de seguridad?

Aquí, puede establecer la carpeta que utilizará la función Copia de seguridad para guardar archivos de copia de seguridad.


¿Qué opciones hay disponibles en la pestaña Registro de datos?

En esta pestaña, puede establecer las carpetas en las que se guardarán los códigos de resultados, las imágenes decodificadas, las imágenes no leídas y los informes, así como opciones para cambiar nombres de archivo y extensiones cuando se registren datos.


¿Cómo puedo activar la generación de informes de validación de datos?

Seleccione Generar informes de validación de datos en Registro dentro del panel Historial de resultados.


¿Qué puedo configurar en el campo Almacenamiento y transferencia de imágenes?

Aquí, puede establecer la carpeta donde se pueden transferir las imágenes.


¿Qué puedo establecer en el campo Configuración de alerta sonora?

Puede establecer la configuración de alerta sonora del PC para las lecturas correctas. Cuando la herramienta de configuración reciba una lectura correcta del lector DataMan, activará la alerta sonora del PC. Esto puede ser práctico para lectores DataMan que no tienen una alerta sonora interna. Puede establecer la frecuencia (de 1000 a 10 000 Hz) y la duración (de 10 ms a 1000 ms) de la alerta de lectura correcta.


¿Cómo puedo activar la función Informes?

Una vez haya completado los campos de Informes, deberá cambiar a Validación de datos para generar informes.


El código de resultados, las imágenes decodificadas o las imágenes no leídas no aparecen en el directorio correspondiente. ¿Cuál puede ser el problema?

Debe activarlos en su correspondiente cuadro de lista desplegable Registro.


Supervisión en tiempo real


¿Para qué se utiliza RTM Lean?

Real Time Monitoring (RTM) Lean es una característica integrada en la herramienta de configuración DataMan que permite recopilar y analizar distintos tipos de datos relacionados con los dispositivos en la red y sus lecturas. El dispositivo de destino para esta adquisición de datos, así como la selección del tipo de datos recopilados, pueden establecerse en Configuración en el menú de la cinta. De forma predeterminada, RTM Lean recopila datos estadísticos (tasa de lectura, recuento de no lecturas, tiempo de decodificación medio, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo).


¿Qué opciones hay disponibles en Configuración?

Configuración permite configurar la adquisición de datos de RTM Lean junto a otras opciones:

Configuraciones de dispositivos: seleccione el dispositivo objeto de la adquisición de datos. Solo un dispositivo puede ser objeto de la adquisición de datos activa en un momento dado en RTM Lean, el que tiene Conexión activada marcada en la lista. Agregue dispositivos a la lista con el botón Agregar dispositivo. Se abrirá una nueva ventana, donde podrá agregar manualmente dispositivos basados en la IP con el botón Agregar dispositivo de red. El botón Actualizar puede utilizarse para actualizar la lista de dispositivos, mientras que el botón Quitar dispositivo agregado manualmente quita el dispositivo seleccionado de la lista. Quitar dispositivo permite quitar un dispositivo de la lista de dispositivos agregados, pero tal y como advierte la advertencia emergente, esto conlleva el purgado completo de los datos recopilados (imágenes, estadísticas, etc.) para ese dispositivo. Los dispositivos protegidos por contraseña pueden supervisarse con RTM Lean, pero debe proporcionar el nombre de usuario y la contraseña en Otras configuraciones.

Configuración de recopilación de datos: la lista incluye todos los tipos de información que RTM Lean puede recopilar. Marque las casillas para recopilar los datos deseados. De forma predeterminada, RTM Lean recopila datos estadísticos (tasa de lectura, recuento de no lecturas, tiempo de decodificación medio, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo). Los tipos de datos proporcionados en la lista no se encuentran entre los datos recopilados de forma predeterminada:

  • Información de disparo detallada para no lecturas: si se activa, RTM Lean almacena datos de disparos individuales cuando se produce una no lectura. Si la no lectura contiene resultados parciales o información de Sincronización de múltiples lectores, también se almacenan.

  • Imágenes no leídas: si se activa, el dispositivo envía la imagen o imágenes no leídas a RTM Lean.

  • Información de disparo detallada para lecturas correctas: esta configuración permite utilizar la página Rendimiento de disparo de Vistas detalladas en el menú de la cinta. Rendimiento de disparo recopila datos para disparos individuales que se traducen en una lectura correcta. Todos los valores de estos datos pueden verse en el menú desplegable Valores representados de la página Rendimiento de disparo.

  • Posición de los códigos para mapa de calor: para cada lectura correcta, RTM Lean almacena los rectángulos para cada uno de los códigos encontrados. Esta información se utiliza después para crear un mapa de calor 2D que muestra dónde se leyeron los códigos en el campo de visión.

  • Cambios de configuración del dispositivo: si está marcada, el dispositivo avisa a RTM Lean cuando hay cambios de configuración. RTM almacena todos los archivos de configuración enviados por los dispositivos. Los eventos de cambio de configuración se muestran en la página Historial de eventos, donde pueden exportarse o compararse.

Tenga en cuenta que en función de la frecuencia de disparo, la activación de los datos de nivel de disparo puede ralentizar el sistema.

Otras configuraciones: este panel muestra el nombre y la dirección del dispositivo que RTM Lean está supervisando de forma activa (Recopilación activada está marcada a la izquierda). Al hacer clic en el icono de la rueda dentada, se abre un submenú que permite determinar de qué manera RTM Lean debe identificar un dispositivo (dirección IP o dirección MAC). Si desea recopilar datos de un dispositivo protegido por contraseña, debe proporcionar el nombre de usuario y la contraseña después de seleccionar el dispositivo para supervisar en la lista de la izquierda.

NOTA: RTM Lean puede adquirir datos de un solo dispositivo a la vez. La versión completa de RTM no tiene dicha limitación.

NOTA: RTM Lean conserva los datos adquiridos durante 48 horas. La versión completa de RTM no tiene dicha limitación.


¿Qué opciones hay disponibles en Opciones de presentación?

Aquí puede configurar una línea de advertencia para que aparezca en los gráficos. Al marcar la casilla, se mostrará la línea de advertencia. Tipo de tabla determina qué tipo de línea se muestra, mientras que Porcentaje de advertencia es el porcentaje donde se dibuja la línea en los gráficos. Tamaño del búfer de no lecturas está relacionado con el Historial de imágenes no leídas, donde el número establecido aquí es el número máximo de líneas (disparos) que se considera en esa página.


¿Qué puedo configurar en Dispositivos del menú de la cinta?

Además de mostrar el ID del dispositivo al que RTM Lean está conectado actualmente, el icono mostrado indica si la recopilación de datos está activa (icono de reproducción) o inactiva (icono de pausa). El menú desplegable permite pausar o iniciar la recopilación de datos activa de acuerdo con los parámetros configurados al iniciar RTM Lean o en Configuración.


Vistas comunes y Vistas detalladas – Información general

Tanto los elementos Vistas comunes como Vistas detalladas del menú de la cinta muestran representaciones estructuradas de los datos recopilados por RTM Lean, mayoritariamente en forma de gráficos en tiempo real. El intervalo de tiempo más pequeño en estas representaciones es de un minuto. Si se producen varios disparos en un minuto, RTM Lean agrega los datos recopilados de estos disparos durante un intervalo de un minuto.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Porcentaje de advertencia es el porcentaje donde se dibuja la línea en los gráficos.

Tenga en cuenta que RTM Lean solo recopila información que se muestra en los elementos de menú de las vistas cuando está conectado y la recopilación está activada en el dispositivo activo (active la recopilación de datos en Configuración o en el menú desplegable en Dispositivos).


¿Qué datos recopila y muestra Vista general de rendimiento?

Vista general de rendimiento puede mostrar Tasa de lectura, Lecturas por minuto y No lecturas por minuto en un gráfico en tiempo real, en función de la configuración en la parte superior izquierda en Configuración. Es posible hacer clic en los botones Último [intervalo de tiempo] en la fila superior, y el activo está marcado en naranja. Puede utilizar los botones para establecer el intervalo que utiliza Vista general de rendimiento.

Debe accionar el dispositivo supervisado para que se muestren datos en el gráfico.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Porcentaje de advertencia es el porcentaje donde se dibuja la línea en los gráficos.


¿Qué datos recopila y muestra Vista general de calidad de los códigos?

Vista general de calidad de los códigos puede mostrar las calificaciones y mediciones de calidad de los códigos en un gráfico en tiempo real, en función de la configuración en la parte superior izquierda en Configuración > Valor representado. Seleccione la medición o calificación que desee supervisar en el dispositivo. Solo la norma de calidad de los códigos configurada en el dispositivo supervisado está disponible en Valor representado (por lo que un cuadro desplegable vacío significa que no hay ninguna norma activada en el dispositivo). Puede cambiar la norma de calidad de los códigos activada en el dispositivo de destino para recopilar datos para otra norma.

En caso de código múltiple, puede haber varias normas de calidad de los códigos establecidas en el dispositivo. En tal caso, el gráfico muestra dos líneas de datos (y su promedio se muestra arriba).

NOTA: dado que RTM Lean utiliza un intervalo mínimo de un minuto, las calificaciones pueden tener un valor intermedio.

Es posible hacer clic en los botones Último [intervalo de tiempo] en la fila superior, y el activo está marcado en naranja. Puede utilizar los botones para establecer el intervalo que utiliza Vista general de calidad de los códigos. El valor promedio representado se muestra aquí.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Porcentaje de advertencia es el porcentaje donde se dibuja la línea en los gráficos.


¿Qué datos recopila y muestra Historial de eventos?

Historial de eventos combina adquisición de datos estadísticos y de calidad de los códigos, en función de la configuración en la parte superior izquierda en Configuración > Valor representado. RTM Lean supervisa el valor seleccionado en el dispositivo. Para las mediciones y calificaciones de calidad de los códigos, solo la norma de calidad de los códigos establecida en el dispositivo supervisado está disponible en Valor representado. Puede cambiar la norma de calidad de los códigos activada en el dispositivo de destino para recopilar datos para otra norma.

Es posible mover la barra de desplazamiento al momento deseado para ver los datos de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado. Un valor agregado del valor representado del periodo de tiempo seleccionado (posicionando la barra de desplazamiento) se muestra en la parte superior central en Valor agregado en Periodo seleccionado.

La recopilación de datos llena la línea inferior del gráfico con puntos que representan eventos durante la supervisión. Cada evento se muestra en el lado derecho con detalles (marca de fecha y hora, y tipo de evento). Hay dos botones debajo de la lista:

  • Guardar backups de dispositivo permite exportar la configuración del dispositivo asociada al evento seleccionado en la lista. Esto podría usarse para verificar los detalles cuando se buscan los motivos de un cambio en una estadística, medición o calificación dada.

  • Comparar configuraciones abre el documento donde puede comparar las configuraciones de los dispositivos asociadas a los eventos seleccionados; solo funciona si se selecciona más de un evento en la lista.


¿Qué datos se muestran en el panel Historial de imágenes no leídas?

El historial de imágenes no leídas muestras las 10 últimas imágenes no leídas tomadas por el dispositivo supervisado. La vista de tabla de la izquierda muestra varios atributos de las imágenes, mientras que la ventana de la imagen de la derecha muestra la imagen seleccionada en la vista de diapositiva de debajo. Haga clic en el icono Guardar para guardar la imagen seleccionada actualmente.


¿Qué datos se muestran en el panel Rendimiento de disparo?

Para activar Rendimiento de disparo, debe marcar la opción Información de disparo detallada para lecturas correctas en Configuración > Configuración de recopilación de datos.

Rendimiento de disparo no agrega datos en intervalos de un minuto como otros paneles, sino que muestra cada disparo en el gráfico. Los disparos individuales se representan con puntos en el gráfico y se muestra su valor numérico. El valor representado (el que se supervisa) puede seleccionarse entre varios valores posibles en el cuadro desplegable Valores representados. Tenga en cuenta que la lista de valores representados puede ser distinta en función de la versión de firmware del dispositivo supervisado.

Es posible mover la barra de desplazamiento al momento deseado para ver los datos de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado. La opción Dividir datos en series por permite establecer los criterios para los colores de los puntos en el gráfico.

Es posible hacer clic en un punto individual (disparo) del gráfico para ver todos los datos relacionados que RTM Lean ha recopilado en el lado derecho si el disparo fue una lectura correcta. Si el resultado fue una lectura incorrecta, RTM Lean muestra la imagen tomada, que puede guardarse haciendo clic en el icono Guardar.


¿Qué puedo ver en el panel Mapa de calor de ubicaciones de los códigos?

Mapa de calor de ubicaciones de los códigos dibuja un mapa de calor de lecturas correctas, donde las regiones se colorean de acuerdo con la frecuencia con que se han encontrado códigos en ellas. Los colores más cálidos indican que en esa área se encontraron códigos con mayor frecuencia. Es posible mover la barra de desplazamiento al momento deseado para ver el mapa de calor de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado.


¿Para qué se utiliza RTM?

Real Time Monitoring (RTM) es una aplicación de software compatible con el hardware accesible a través de la herramienta de configuración DataMan que permite recopilar y analizar distintos tipos de datos relacionados con los dispositivos en la red y sus lecturas. El dispositivo de destino para esta adquisición de datos, así como la selección del tipo de datos recopilados, pueden establecerse en Configuración en el menú de la cinta. De forma predeterminada, RTM recopila datos estadísticos (tasa de lectura, recuento de no lecturas, tiempo de decodificación medio, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo).


¿Qué opciones hay disponibles en Configuración?

Configuración permite configurar la adquisición de datos de RTM junto a otras configuraciones:

Configuraciones de dispositivos: seleccione el dispositivo objeto de la adquisición de datos. Agregue dispositivos a la lista con el botón Agregar dispositivo. Se abrirá una nueva ventana, donde podrá agregar manualmente dispositivos basados en la IP con el botón Agregar dispositivo de red. El botón Actualizar puede utilizarse para actualizar la lista de dispositivos, mientras que el botón Quitar dispositivo agregado manualmente quita el dispositivo seleccionado de la lista. Quitar dispositivo permite quitar un dispositivo de la lista de dispositivos agregados, pero tal y como advierte la advertencia emergente, esto conlleva el purgado completo de los datos recopilados (imágenes, estadísticas, etc.) para ese dispositivo. RTM puede supervisar dispositivos protegidos por contraseña, pero debe proporcionar el nombre de usuario y contraseña en Red.

Configuración de recopilación de datos: la lista incluye todos los tipos de información que RTM puede recopilar. Marque las casillas para recopilar los datos deseados. De forma predeterminada, RTM recopila datos estadísticos (tasa de lectura, recuento de no lecturas, tiempo de decodificación medio, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo). Los tipos de datos proporcionados en la lista no se encuentran entre los datos recopilados predeterminados y pueden establecerse en la pestaña Configuración:

  • Información de disparo detallada para no lecturas: si se activa, RTM almacena datos de disparos individuales cuando se produce una no lectura. Si la no lectura contiene resultados parciales o información de Sincronización de múltiples lectores, también se almacenan.

  • Imágenes no leídas: si se activa, el dispositivo envía la imagen o imágenes no leídas a RTM.

  • Información de disparo detallada para lecturas correctas: esta configuración permite utilizar la página Rendimiento de disparo de Vistas detalladas en el menú de la cinta. Rendimiento de disparo recopila datos para disparos individuales que se traducen en una lectura correcta. Todos los valores de estos datos pueden verse en el menú desplegable Valores representados de la página Rendimiento de disparo.

  • Posición de los códigos para mapa de calor: para cada lectura correcta, RTM almacena los rectángulos para cada uno de los códigos encontrados. Esta información se utiliza después para crear un mapa de calor 2D que muestra dónde se leyeron los códigos en el campo de visión.

  • Cambios de configuración del dispositivo: si está marcada, el dispositivo avisa a RTM cuando hay cambios de configuración. RTM almacena todos los archivos de configuración enviados por los dispositivos. Los eventos de cambio de configuración se muestran en la página Historial de eventos, donde pueden exportarse o compararse.

Tenga en cuenta que en función de la frecuencia de disparo, la activación de los datos de nivel de disparo puede ralentizar el sistema.

Clasificación: El controlador de RTM puede recopilar datos de clasificación en función de los motivos de los eventos de no lectura si el dispositivo DataMan está emparejado a un dispositivo In-Sight de Cognex. Se debe especificar un dispositivo In-Sight para que funcione la clasificación marcando la casilla Recopilar clasificaciones de imágenes de In-Sight y seleccionando el dispositivo clasificador en la lista desplegable. Para almacenar las imágenes de clasificación, marque la casilla Almacenar imágenes.

Tenga en cuenta que, en función de la configuración de disparo y la frecuencia de imágenes no leídas, el almacenamiento de las imágenes puede aumentar el uso del disco de forma significativa.

No sobrescribir secuencia de comandos de comunicación en DataMan: marque esta casilla para que no se sobrescriba la secuencia de comandos en el dispositivo.

Red: este panel muestra el nombre y la dirección del dispositivo que RTM está supervisando de forma activa (Recopilación activada está marcada a la izquierda). Al hacer clic en el icono de la rueda dentada, se abre un submenú que permite determinar de qué manera RTM debe identificar un dispositivo (dirección IP o dirección MAC). Si desea recopilar datos de un dispositivo protegido por contraseña, debe proporcionar el nombre de usuario y la contraseña después de seleccionar el dispositivo para supervisar en la lista de la izquierda.

Configuración de almacenamiento de datos: este panel muestra las posibilidades de Opciones de almacenamiento y Eliminación de datos.

  • Opciones de almacenamiento muestra el almacenamiento disponible con sus nombres, tipos, espacio lleno y espacio libre que queda en GB, y el porcentaje de espacio utilizado.

  • Eliminación de datos: el controlador de RTM elimina los datos de nivel de disparo antiguos después de cierto tiempo para evitar el desbordamiento del almacenamiento. En Eliminar datos detallados después de puede modificar el periodo de tiempo de acuerdo con sus necesidades, entre una hora y un mes.

  • Limitación de imágenes: marque el botón de radio Transferir configuración de limitación de imágenes al dispositivo para activar la recopilación de imágenes no leídas. RTM incluye configuraciones predeterminadas predefinidas que pueden modificarse si se desea. El tiempo Tasa de imágenes es la frecuencia con que se recopilan imágenes no leídas. Puede especificar un número exacto y una unidad para especificar este tiempo. Este recuento y tiempo determinan el ritmo sostenido de imágenes leídas incorrectamente. La ráfaga determina la tasa máxima por tiempo. Al conectarse al dispositivo DataMan, RTM transferirá dicha configuración para establecer la comunicación. También establecerá la configuración óptima para las imágenes de salida en el lector.

Configuración de la hora: este panel muestra las opciones de configuración de la hora. El controlador de RTM no tiene un reloj integrado y una actualización de firmware restaura la configuración de la hora.

  • Aplicar la hora del sistema del PC cliente a RTM: haga clic en Establecer hora para aplicar la hora del sistema del PC cliente.

  • Activar NTP: puede proporcionar los nombres de host de los servidores NTP principal y secundario para aplicar su hora a RTM. Si se elimina el contenido del campo de texto y se hace clic en Aplicar, se restablecerá la configuración de la hora del servidor NTP a los valores predeterminados de fábrica.

Red CAM: este panel muestra las opciones de configuración de la red interna del controlador de RTM. Proporcione la dirección IP y la máscara de subred en los recuadros para determinar la dirección IP y la máscara de subred de la red interna del controlador de RTM. Si proporciona la subred del dispositivo que está conectado en el controlador de RTM, el controlador de RTM podrá reconocerlo.


¿Qué opciones hay disponibles en Opciones de presentación?

Aquí puede configurar una línea de advertencia para que aparezca en los gráficos.

  • Mostrar línea de referencia de tasa de lectura: al marcar la casilla, se mostrará la línea de advertencia.

  • Valor de línea de referencia de tasa de lectura (%): puede establecer un valor porcentual, que es el porcentaje de advertencia donde se dibujará la línea en el gráfico Tasa de lectura.

  • Tipo de tabla determina qué tipo de línea se muestra.

  • Tamaño del búfer de no lecturas está relacionado con el Historial de imágenes no leídas, donde el número establecido aquí es el número máximo de líneas (disparos) que se considera en esa página.

  • Establezca el número máximo de detalles de disparo devueltos en el cuadro Número máximo de detalles de disparo devueltos.


¿Qué puedo configurar en Dispositivos del menú de la cinta?

Además de mostrar los ID de los dispositivos a los que RTM está conectado actualmente, el icono mostrado indica si la recopilación de datos está activa (icono de reproducción) o inactiva (icono de pausa). El menú desplegable permite pausar o iniciar la recopilación de datos activa de acuerdo con los parámetros configurados al iniciar RTM o en Configuración. También puede ejecutar el diagnóstico desde el menú desplegable, de igual manera que en Configuración.


Vistas comunes y Vistas detalladas - Información general

Tanto los elementos Vistas comunes como Vistas detalladas del menú de la cinta muestran representaciones estructuradas de los datos recopilados por RTM, mayoritariamente en forma de gráficos en tiempo real. El intervalo de tiempo más pequeño en estas representaciones es de un minuto. Si se producen varios disparos en un minuto, RTM agrega los datos recopilados de estos disparos durante un intervalo de un minuto.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que en Valor de línea de referencia de tasa de lectura (%) puede proporcionar el porcentaje de advertencia donde se dibujará la línea en los gráficos.

Tenga en cuenta que RTM solo recopila información que se muestra en los elementos de menú de las vistas cuando está conectado y la recopilación está activada en el dispositivo activo (active la recopilación de datos en Configuración o en el menú desplegable en Dispositivos).


¿Qué datos recopila y muestra Vista general de rendimiento?

Vista general de rendimiento puede mostrar Tasa de lectura, Lecturas por minuto y No lecturas por minuto en un gráfico en tiempo real, en función de la configuración en la parte superior izquierda en Mostrando. Es posible hacer clic en los botones Último [intervalo de tiempo] en la fila superior, y el activo está marcado en naranja. Puede utilizar los botones para establecer el intervalo que utiliza Vista general de rendimiento.

Debe accionar el dispositivo supervisado para que se muestren datos en el gráfico.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Valor de línea de referencia de tasa de lectura (%) es el porcentaje donde se dibuja la línea en los gráficos.


¿Qué datos recopila y muestra Vista general de calidad de los códigos?

Vista general de calidad de los códigos puede mostrar las calificaciones y mediciones de calidad de los códigos en un gráfico en tiempo real, en función de la configuración en la parte superior izquierda en Configuración > Valor representado. Seleccione la medición o calificación que desee supervisar en el dispositivo. Solo la norma de calidad de los códigos configurada en el dispositivo supervisado está disponible en Valor representado (por lo que un cuadro desplegable vacío significa que no hay ninguna norma activada en el dispositivo). Puede cambiar la norma de calidad de los códigos activada en el dispositivo de destino para recopilar datos para otra norma.

En caso de código múltiple, puede haber varias normas de calidad de los códigos establecidas en el dispositivo. En tal caso, el gráfico muestra dos líneas de datos (y su promedio se muestra arriba).

NOTA: dado que RTM utiliza un intervalo mínimo de un minuto, las calificaciones pueden tener un valor intermedio.

Es posible hacer clic en los botones Último [intervalo de tiempo] en la fila superior, y el activo está marcado en naranja. Puede utilizar los botones para establecer el intervalo que utiliza Vista general de calidad de los códigos. El valor promedio representado se muestra aquí.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Valor de línea de referencia de tasa de lectura (%) es el porcentaje donde se dibuja la línea en los gráficos.


¿Qué datos recopila y muestra Historial de eventos?

Historial de eventos combina adquisición de datos estadísticos y de calidad de los códigos, en función de la configuración en la parte superior izquierda en Configuración > Valor representado. RTM supervisa el valor seleccionado en el dispositivo. Para las mediciones y calificaciones de calidad de los códigos, solo la norma de calidad de los códigos establecida en el dispositivo supervisado está disponible en Valor representado. Puede cambiar la norma de calidad de los códigos activada en el dispositivo de destino para recopilar datos para otra norma.

Es posible mover la barra de desplazamiento al momento deseado para ver los datos de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado. Un valor agregado del valor representado del periodo de tiempo seleccionado (posicionando la barra de desplazamiento) se muestra en la parte superior central en Valor agregado en Periodo seleccionado.

La recopilación de datos llena la línea inferior del gráfico con puntos que representan eventos durante la supervisión. Cada evento se muestra en el lado derecho con detalles (marca de fecha y hora, y tipo de evento). Hay dos botones debajo de la lista:

  • Guardar backups de dispositivo permite exportar la configuración del dispositivo asociada al evento seleccionado en la lista. Esto podría usarse para verificar los detalles cuando se buscan los motivos de un cambio en una estadística, medición o calificación dada.

  • Comparar configuraciones abre el documento donde puede comparar las configuraciones de los dispositivos asociadas a los eventos seleccionados; solo funciona si se selecciona más de un evento en la lista.


¿Qué datos se muestran en el panel Historial de imágenes no leídas?

El historial de imágenes no leídas muestras las últimas imágenes no leídas tomadas por el dispositivo supervisado. La vista de tabla de la izquierda muestra varios atributos de las imágenes, mientras que la ventana de la imagen de la derecha muestra la imagen seleccionada en la vista de diapositiva de debajo. Haga clic en el icono Guardar para guardar la imagen seleccionada actualmente.

La tabla Clasificación en la parte inferior izquierda muestra qué tipo de eventos de no lectura se han producido, si seleccionó la recopilación de clasificaciones en Configuración > Configuración > Clasificación.


¿Qué datos se muestran en el panel Rendimiento de disparo?

Para activar Rendimiento de disparo, debe marcar la opción Información de disparo detallada para lecturas correctas en Configuración > Configuración de dispositivo.

Rendimiento de disparo no agrega datos en intervalos de un minuto como otros paneles, sino que muestra cada disparo en el gráfico. Los disparos individuales se representan con puntos en el gráfico y se muestra su valor numérico. Los valores representados (los que se supervisan) pueden seleccionarse entre varios valores posibles en el cuadro desplegable Valores representados. Tenga en cuenta que la lista de valores representados puede ser distinta en función de la versión de firmware del dispositivo supervisado.

Es posible mover la barra de desplazamiento al momento deseado para ver los datos de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado. La opción Representaciones de color basadas en permite establecer los criterios para los colores de los puntos en el gráfico.

Es posible hacer clic en un punto individual (disparo) del gráfico para ver todos los datos relacionados que RTM ha recopilado en el lado derecho si el disparo fue una lectura correcta. Si el resultado fue una lectura incorrecta, RTM muestra la imagen tomada, que puede guardarse haciendo clic en el icono Guardar.


¿Qué opciones hay disponibles en la pestaña Sistema?

Aquí puede eliminar datos y configuraciones. Al hacer clic en Vaciar base de datos, se eliminan todos los datos almacenados. Restablecer configuración elimina las configuraciones del dispositivo y todos los datos almacenados, Restaurar valores predeterminados de fábrica restaura todos los valores predeterminados de fábrica y Reiniciar simplemente reinicia el sistema.


Vista de tabla


¿Por qué varios valores aparecen resaltados?

Los valores que están resaltados son valores que inicialmente no son predeterminados. Las reglas de resaltado pueden modificarse en la sección Resaltado del menú de la cinta. Consulte la pregunta Vista de tabla: menú de la cinta para obtener más información.


¿Por qué varios valores aparecen en negrita?

Los valores en negrita pueden expandirse y mostrar subvalores.


¿Cómo sé cuáles son los valores posibles?

Mueva el puntero del ratón sobre un valor y consulte el texto que aparecerá encima indicando los valores mínimos, máximos y predeterminados, donde fueran aplicables.


Vista de tabla: estructura y diseño general

Vista de tabla es una herramienta de visualización que utiliza un estilo de cuadrícula.

La fila de título muestra el nombre del dispositivo. La segunda fila de títulos debajo de la primera muestra las configuraciones disponibles para el dispositivo. Los títulos de fila inferiores (en negrita) pueden contraerse o abrirse haciendo clic en el icono situado junto a ellos. Si el dispositivo está desconectado, aparece un icono de reconexión en su fila de título.

Las configuraciones que no son dependientes de la configuración de lectura solo se muestran en la primera columna (configuración principal).


Vista de tabla: controles (ratón y teclado)

Selección:

  • Ratón: al hacer clic en una celda de la cuadrícula, se selecciona la celda y se resalta el título de su fila y el título de la columna a la que pertenecen el dispositivo y la configuración. Los botones de menú y los elementos del menú de la cinta pueden variar en función de la selección. Si la celda seleccionada se encuentra en una fila de título, se seleccionarán todas las celdas de la columna actual que pertenezcan a ese título.

  • Teclado: las teclas de movimiento del cursor permiten mover la selección a la celda apropiada. El funcionamiento en cuanto a resaltado y selección es el mismo que con el ratón.

Agregar/cambiar valores:

  • Ratón: en celdas con editores incorporados, hacer clic en el control del editor (cuadro de combinación, casilla, control numérico arriba-abajo) se podrán introducir valores. En celdas con editores personalizados (icono «...»), se abre un editor emergente que permite introducir valores.

  • Teclado: en celdas con editores incorporados, al pulsar Entrar o F2 se inicia el modo de edición; con Esc se cancela la edición y pulsando Entrar por segunda vez se confirma la edición. Los valores pueden introducirse en el texto seleccionado sin entrar en el modo de edición, en cuyo caso el valor actual se sobrescribirá con la primera tecla que se pulse.

    En las celdas numéricas, además de las celdas con editor de texto incorporado, las flechas arriba y abajo aumentan o disminuyen el valor.

    En celdas desplegables, Entrar inicia el modo de edición y muestra los elementos desplegables, mientras que las flechas arriba y abajo mueven la selección. Pulsando Entrar por segunda vez se aplica el valor seleccionado y con Esc se cancela la edición.

    En las celdas de casilla de verificación, utilice Espacio para alternar entre los estados marcado/no marcado.

Copiar y pegar:

Utilice las combinaciones de teclado Ctrl+C y Ctrl+V para copiar y pegar, respectivamente. Consulte la descripción de copiar-pegar de los elementos de menú de la cinta relacionados para obtener más información.


Vista de tabla: menú de la cinta

El menú de la cinta se encuentra encima de la cuadrícula de vista de tabla. Sus contenidos e iconos activos pueden cambiar en función de las celdas, filas o columnas que se seleccionen en la cuadrícula. El menú está dividido en varios grupos.

  • Vista de tabla: utilice el botón Agregar configuración para agregar o copiar configuraciones de lectura al dispositivo seleccionado. El botón Eliminar configuración elimina la/s configuración/es de lectura seleccionada/s. El botón Cambiar orden permite que el dispositivo alterne entre distintos órdenes de las configuraciones de lectura.

  • Edición: utilice Copiar (o Ctrl+C en el teclado) para copiar un valor de la celda seleccionada en ese instante. Pegar solo puede utilizarse en la misma fila o en cualquier editor de texto. Restablecer valores permite restablecer los valores de la/s celda/s seleccionada/s.

  • Resaltado: los botones y configuraciones de este grupo de menú ofrecen opciones para resaltar el fondo de celdas específicas. Con la configuración Valores no predeterminados se resaltan las celdas que tengan valores no predeterminados (puede variar en una misma fila para diferentes dispositivos o configuraciones de lectura). La configuración Distinto de referencia resalta las celdas que tengan valores diferentes a los de la celda de la misma fila en la configuración de lectura (y el dispositivo) de referencia. Si se selecciona la tercera configuración, se resaltarán todos los valores y títulos que contengan el texto especificado en el cuadro de texto. Además, el texto contenido se resaltará con un fondo de texto diferente. Al pulsar Entrar, también se aplica la función del botón Mostrar solo filas resaltadas.

    Al activar Mostrar solo filas resaltadas, se contraerán todos los nodos que no tengan ningún subnodo resaltado. Si se activa Establecer configuración de lectura de referencia, especifica la configuración de lectura (y el dispositivo) que se utilizará como referencia cuando se utilice el modo de resaltado Distinto de referencia. Si el botón está activo, la columna de la celda seleccionada en ese instante (configuración de lectura) pasa a ser la configuración de referencia. La configuración de referencia actual se marca en la fila de título del nombre de configuración.

  • Filtrado: Configuración global, la configuración predeterminada, solo muestra configuraciones que no tengan valores distintos en diferentes configuraciones de lectura. Establezca Parámetros de configuración de lectura para ver únicamente las configuraciones dependientes de la configuración de lectura. Establezca Todas las configuraciones para ver todas las configuraciones al mismo tiempo. Si una entrada tiene valores en más configuraciones de lectura, estos se mostrarán en diferentes columnas.

  • Otros: utilice Expandir todas las filas para expandir todas las filas que se hayan contraído en la cuadrícula. Utilice Contraer todas las filas para contraer todas las filas expandidas de la cuadrícula. Restablecer diseño vuelve a calcular los anchos de columna para utilizar todo el espacio disponible. Si el espacio disponible no es suficiente, se aplica un ancho de columna mínimo.


Información legal


Copyright

Cognex Corporation no asume ninguna responsabilidad por el uso o fiabilidad de su software en equipos no suministrados por Cognex Corporation. Cognex Corporation no otorga ningún tipo de garantía, expresa ni implícita, relacionada con el software descrito, su comerciabilidad o idoneidad para un fin determinado.

La información contenida en este documento está sujeta a cambios sin previo aviso y no debe interpretarse como un compromiso por parte de Cognex Corporation. Cognex Corporation no se responsabiliza de ningún error que pueda haber en este documento o en el software asociado.

Copyright © 2019 Cognex Corporation. Todos los derechos reservados

Este documento no se puede copiar, ni parcial ni íntegramente, ni transferir a otro medio o idioma sin el permiso por escrito de Cognex Corporation.

El hardware y las partes del software descritos en este documento pueden estar sujetos a una o más de las patentes estadounidenses enumeradas en la página web de Cognex http://www.cognex.com/patents.asp. Otras patentes estadounidenses y extranjeras están en trámite.


Software bajo licencia

SpiderMonkey

Este software está sujeto a los términos de la Licencia pública de Mozilla, v. 2.0. Puede obtener una copia de esta licencia en http://mozilla.org/MPL/2.0/.

Si desea obtener una copia del código fuente de SpiderMonkey, póngase en contacto con el equipo de asistencia técnica de Cognex en <spidermonkey@cognex.com>.

Licencia de PCRE

PCRE es una biblioteca de funciones compatible con expresiones regulares cuya sintaxis y semántica son prácticamente idénticas a las del lenguaje Perl 5.

La versión 5 de PCRE se distribuye de acuerdo con las condiciones de la licencia «BSD», del modo especificado a continuación. La documentación de PCRE, contenida en el directorio «doc», se distribuye bajo las mismas condiciones que el software.

Autor: Philip Hazel <ph10@cam.ac.uk>

Servicio Informático de la Universidad de Cambridge, Cambridge, Inglaterra. Teléfono: +44 1223 334714.

Copyright (c) 1997-2004 Universidad de Cambridge. Todos los derechos reservados.

Se permite el uso y la redistribución en formato binario/código fuente, con o sin modificación, siempre que se cumplan las condiciones siguientes:

  • Las redistribuciones del código fuente deben indicar el aviso de copyright anterior, esta lista de condiciones y los siguientes descargos de responsabilidad.
  • Las redistribuciones en formato binario deben reproducir el aviso de copyright anterior, esta lista de condiciones y los descargos de responsabilidad presentes en el documento y/o los materiales suministrados con la distribución.
  • No se puede utilizar el nombre de la Universidad de Cambridge ni el nombre de sus colaboradores para secundar o promover productos derivados de este software sin el permiso previo por escrito correspondiente.

ESTE SOFTWARE SE SUMINISTRA POR PARTE DE LOS COLABORADORES Y LOS TITULARES DE COPYRIGHT «TAL COMO ESTÁ» Y SE DECLINA TODA GARANTÍA EXPRESA O IMPLÍCITA, INCLUIDA A MODO ENUNCIATIVO PERO NO LIMITATIVO, CUALQUIER GARANTÍA IMPLÍCITA DE COMERCIABILIDAD E IDONEIDAD PARA UN FIN DETERMINADO. BAJO NINGUNA CIRCUNSTANCIA EL TITULAR DEL COPYRIGHT NI LOS COLABORADORES SERÁN RESPONSABLES DE NINGÚN DAÑO DIRECTO, INDIRECTO, INCIDENTAL, EMERGENTE, EJEMPLAR NI CONSECUENCIAL (INCLUIDO A MODO ENUNCIATIVO PERO NO LIMITATIVO, LA ADQUISICIÓN DE MERCANCÍAS O SERVICIOS SUSTITUTORIOS, LA PÉRDIDA DE USO, DATOS O BENEFICIOS, O LA INTERRUPCIÓN DEL NEGOCIO) AL MARGEN DE LA FORMA O ACCIÓN, BIEN SEA POR CONTRATO, AGRAVIO (INCLUIDA LA NEGLIGENCIA), RESPONSABILIDAD ESTRICTA DEL PRODUCTO U OTRO CASO, INCLUSO SI HUBIESEN SIDO ADVERTIDOS DE LA POSIBILIDAD DE DICHOS DAÑOS.

Fin

Software de JPEG

Este software se fundamenta en parte en el trabajo del grupo independiente JPEG.

Biblioteca de compresión zlib

Este software se fundamenta en parte en el trabajo de Jean-loup Gailly y Mark Adler.

Parsifal XML Parser

Copyright (c) 2002-2005 Toni Uusitalo. Fecha en la que pasó a ser de dominio público: 15/11/2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

El uso comercial y no comercial de Parsifal, así como su redistribución, son gratuitos siempre que no se modifiquen el copyright y los descargos de responsabilidad del autor. Puede modificar Parsifal para su propio uso y redistribuirlo con sus modificaciones, siempre y cuando las modificaciones estén claramente documentadas.

DESCARGO DE RESPONSABILIDAD

Este programa se distribuye esperando que sea útil, pero SIN NINGUNA GARANTÍA; ni siquiera la garantía implícita de comerciabilidad o idoneidad para un fin determinado. Utilícelo BAJO SU PROPIA RESPONSABILIDAD.


Información de la patente

Este producto se encuentra cubierto por una o más de las patentes de los EE.UU., aplicaciones de los EE.UU y/o patentes extranjeras http://www.cognex.com/patents listará cualquier patente emitida subsiguientemente que resulte relevante

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, y EP1687752