DMCC Overview

DataMan Control Commands Documentation 6.1.0

Overview

DataMan Control Commands (DMCC) are a method of configuring and controlling a DataMan reader from a COM port, either directly or programatically through a custom application. Depending on the DataMan reader you are using, the COM port connection be either RS232, USB, or the Telnet protocol in the case of Ethernet capable readers. By default, Ethernet capable readers are configured to communicate over TCP port number 23, but you can use the Setup Tool to assign a different port number as necessary.

Cognex recommends using HyperTerminal, a built-in Windows communications application, to test your ability to connect to an available reader.

Command Syntax

All DMCC commands are formed of a stream of ASCII printable characters with the following syntax:

command-header command [arguments] footer

For example:

||>trigger on\CR\LF

Command Header Syntax

||checksum:command-id>

All options are colon separated ASCII text. A header without the header-option block will use header defaults.

checksum
0: no checksum (default)
1: last byte before footer is XOR of bytes
command-id
An integer command sequence that can be reported back in acknowledgement.

Header Examples

Example | Description
||> | Default Header.
||0:123> | Header indicating no-checksum and ID of 123.
||1> | Header indicating checksum after command and data.

Command

The command is an ASCII typable string possibly followed by data. All command names and public parameters data are case insensitive. Only a single command may be issued within a header-footer block. Commands, parameters and arguments are separated by a space character.

Commands
Short names specifying an action.
A commonly used command is GET or SET followed by a Parameter and Value.
Parameters
Short names specifying a device setting.
Parameter names are organized with a group of similar commands with one level of structural organization separated by a period ('.').
Arguments
Boolean: ON or OFF
Integer: 123456
String: ASCII text string enclosed by quotes (“).The string content is passed to a function to translate the string to the final format. The following characters must be backslash escaped: quote (\”), backslash (\\), pipe (\|), tab (\t), CR(\r), LF (\n).

Footer

The footer is a carriage return and linefeed (noted as \CR\LF or \r\n).

Reader Response

The reader will have one of several response formats. The choice of response format is configured using the SET COM.DMCC-RESPONSE command. Note that while the reader can process a stream of DMCC commands, it is typically more robust to either wait for a response, or insert a delay between consecutive commands.

Silent: (Default) No response will be sent from the reader. Invalid commands are ignored without feedback. Command responses are sent in space delimited ASCII text without a header or footer.

Extended: The reader responds with a header data footer block similar to the command format.

||checksum:command-id[status]
checksum
The response uses the same checksum format as the command sent to the reader.
0: no checksum
1: last byte before footer is XOR of bytes
command-id
The command-id sent to the reader is returned in the response header.
status
An integer in ASCII text format.
0: no error
1: reader initiated read-string
100: unidentified error
101: command invalid
102: parameter invalid or missing feature
103: checksum incorrect
104: parameter rejected/altered due to reader state
105: reader is offline

Examples

Command | Silent Response | Extended Response | Description
||>GET SYMBOL.DATAMATRIX\r\n | ON | ||[0]ON\r\n | Is the DataMatrix symbology enabled?
||>SET SYMBOL.DATAMATRIX ON\r\n | no response | ||[0]\r\n | Enable the DataMatrix symbology.
||>TRIGGER ON\r\n | decoded data or no-read response | ||[0]\r\n ||[1]decoded data or no-read response in base64\r\n | Trigger Command


DMCC API - Action Commands

DataMan Control Commands

Action Commands

Code Quality Commands

Communication Commands

Data Formatting Commands

Data Validation Commands

Decoder Commands

I/O Commands

Light & Imager Commands

Record & Playback Commands

Symbology Commands

System Commands


DMCC API - Action Commands

Action Commands

Set/Get | Command | Arguments | Range | Meaning | Description | Support
BACKUP.EXPORT | Exports a human readable version of the current reader backup. | ALL
BEEP repetition
level
 [0-3]
[0-2]
Command audio beep. ALL
SET|GET BEEP.GLOBAL-ENABLE state

 [ON|OFF]
 ON: enable
OFF: disable 		This command will disable all beeps on the DataMan product. DM8050, DM8600
COM.BUFFER-RESET | Clears the content of the offline buffer. | DM8050, DM8600 and MX-1000.
COM.BUFFER-START-SEND | Valid if auto-flush is off. Activates buffer data output over Telnet channels (and flushes buffered codes). Data output is stopped every time when all Telnet channels are disconnected. | DM8050, DM8600 and MX-1000.
SET|GET CONFIG-BACKUP.ENABLE state
 [ON|OFF] enable/disable Enables automatic device configuration backup. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET CONFIG-BACKUP.IP-ADDRESS string
 IP address of the Cognex Explorer FTP service.
Uses dotted decimal form, such as "192.168.23.42". 		Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET CONFIG-BACKUP.PASSWORD string
 Password used to log in to Cognex Explorer FTP service. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET CONFIG-BACKUP.PORT port
 [0-65535] Port number of the Cognex Explorer FTP service. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET CONFIG-BACKUP.USER-NAME string
 User name used to log in to the Cognex Explorer FTP service. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
CONFIG.DEFAULT | Resets the device’s configuration settings to factory defaults. Device identification and communications settings are not changed. | ALL
CONFIG.EXPORT | Exports a human readable version of the current reader configuration. | ALL
CONFIG.LOAD num-bytes
 Load Configuration from communication channel. Make sure you use a robust communications channel (for example, Ethernet) because this command does not have error checking or retry support and might cause the device to hang. ALL
CONFIG.RESTORE | Restores Configuration from Non-Volatile Memory. | ALL
CONFIG.SAVE | Saves Configuration to Non-Volatile Memory. | ALL
CONFIG.SEND | Send device configuration to communication channel. | ALL
DEVICE-LOG.CLEAR | This command clears the device log. | DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050, DM8600, MX-1000 and MX-1502.
DEVICE.BACKUP | Send encrypted backup file (.cdc) to the PC. | ALL
DEVICE.DEFAULT | Resets all device settings to factory defaults. This command reboots the device. | ALL
GET | DEVICE.LOG | Get the device log of error and exception conditions such as missed triggers and trigger overruns. | DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
DEVICE.RESTORE file size
 Transmits backup file (.cdc) to the reader. File size is in bytes. File data follows footer. ALL
SET|GET DEVICE.TIMEZONE timezone
 Location or POSIX timezone Get or set the timezone for local time. All
DMCC.RESET | When sent, the DMCC resets the following DMCC back to default: COM.DMCC-RESPONSE, COM.DMCC-CHECKSUM, COM.DMCC-HEADER, DATA.RESULT-TYPE, DATA.RESULT-ENCODING, DATA.RESULT-ALWAYSSEND, DATA.IMAGE-TYPE. | ALL
DMCC.SAVE | Saves DMCC connection settings. It also saves the status for a new connection session for the following DMCC: COM.DMCC-RESPONSE, COM.DMCC-CHECKSUM, COM.DMCC-HEADER, DATA.RESULT-TYPE, DATA.RESULT-ENCODING, DATA.RESULT-ALWAYSSEND, DATA.IMAGE-TYPE. | ALL
SET|GET HPIT.INDICATOR-MODE IND_ID

IND_MODE

 [0-1]

[0-1]
 0 = Left indicator
1 = Right indicator
0 = OFF
1 = ON 		Allows to control the LED indicators located in Torch according to the selected mode. This command is intended only for usability testing. DM370 series, DM470 series readers.
IMAGE.SEND | Retrieve the last camera image acquired. Returns number of bytes of image data followed by \r\n followed by image data. Whatever is set for ||>IMAGE.SIZE, ||>IMAGE.FORMAT, and ||>IMAGE.QUALITY before requesting the image will be used for the corresponding size, format, and quality. | ALL
GET INPUT.STATE line
 [0-3] input line number Gets the current state of the input line specified. Returns 1 for high, 0 for low. Fixed-mount readers
SET|GET KEY.PAUSE-TIME Pause time
 [0-1000] 0 to 1000 millisecond pause Sets the time to pause for a specified pause key sequence. DM8050, DM8600 series
GET MOTION-DETECTION.ACTIVE state

 [ON|OFF]
 ON: Active or Lights Off
OFF: Inactive or Lights On 		Allows checking the current state of motion detection for presentation or self-internal trigger mode. DM50, DN60, DM70, DM150, DM260, DM300, DM360, DM474.
SET|GET MOTION-DETECTION.ENABLE state

 [ON|OFF]
 ON: enable
OFF: disable 		Enables or disables motion detection for Presentation trigger mode. DM50, DN60, DM70, DM150, DM260, DM300, DM474, DM503.
SET|GET MOTION-DETECTION.SENSITIVITY

[0|2]

 0: Low
1: Medium
2: High 		Sets or gets the motion detection sensitivity level when in presentation mode. DM50, DM60, DM70, DM150, DM260, DM300, DM474, DM503.

Technology Preview 		OUTPUT.DATAVALID-FAIL Virtual Data Validation Failure.
Device beeps, flashes indicator lights, and sets output lines as if the specified Data Validation failure event occurred. 		ALL

Technology Preview 		OUTPUT.GOOD Virtual Good-Read.
Device beeps, flashes indicator lights, and sets output lines as if the specified read event occurred. 		ALL

Technology Preview 		OUTPUT.NOREAD Virtual No-Read.
Device beeps, flashes indicator lights, and sets output lines as if the specified no-read event occurred. 		ALL
OUTPUT.USER1 | Device emits USER_EVENT_1 event. | DM8050, MX-1000, MX-1502, DM474, DM503 and DM300 series readers.
OUTPUT.USER2 | Device emits USER_EVENT_2 event. | DM8050, MX-1000, MX-1502, DM474, DM503 and DM300 series readers.
REBOOT Reboot the Device.
Rebooting the Device restores the Configuration stored in Non-Volatile Memory. Commands will not be processed for several seconds while the device reboots. If communication settings are changed, connection with device may be lost.
Note that when connected via USB-COM, the application must release the COM port. 		ALL
REBOOT.DELAYED | Reboot the Device after delay in seconds. Rebooting the Device restores the Configuration stored in Non-Volatile Memory. Commands will not be processed for several seconds while the device reboots.If communication settings are changed, connection with device may be lost. Note that when connected via USB-COM, the application must release the COM port. | All
GET RESULT target

 [0-1]
 0: Result string
1: XML formatted 		Optional Send Last Result. By default the result string is in ASCII format, but this can be changed to Base64 with the DATA.RESULT-ENCODING command. ALL
STATISTICS.RESET | Reset all statistics. | ALL
TRAIN.BRIGHT type

 [ON|OFF]
 ON: Start Train Brightness Algorithm
OFF: Abort Train Brightness Algorithm 		Generate a fixed value for the exposure setting based on the particular scene, similar to the Optimize Brightness button in the Setup Tool. Fixed mount devices.
TRAIN.CODE state
 [ON|OFF] enable/disable Train symbology using next sucessful decode. Fixed mount devices.
TRAIN.FOCUS state
 [ON|OFF] enable/disable Optimize lens focus. DM503, DM474 and DM300 series readers.
TRAIN.MATCH-STRING | Triggers the reader and sets the match string to the value of the decoded string. Match String validation must be enabled for this command to work. | Fixed mount devices, DM8050 and DM8600.
TRIGGER state

 [ON|OFF] enable/disable ON: Scanning process is initiated, displaying the preview if necessary, decoding frames, etc.
OFF: Scanning process is terminated, even if a barcode has not been decoded. 		Software Trigger. ALL
GET TRIGGER state

 [0|1]
 0: Off
1: On 		Get current state of the trigger. ALL
TUNE.CANCEL

0: Tuning is cancelled.
104: Tuning is not running or there is an error.
101: Tuning is not available. 		Cancel tuning. DM300 series readers, DM474, DM70, DM260, and DM150.
TUNE.START

0: Tuning started.
104: Tuning is already running or there is an error.
101: Tuning is not available. 		Start tuning. DM300 series readers, DM474, DM70, DM260, and DM150.
GET TUNE.STATUS
Returns ON if tuning is running, OFF otherwise. Fixed mount devices.
UNTRAIN.MODEL enum

index
 [0-5]

0 		0: All Symbologies
1: DataMatrix
2: QR Code/MaxiCode/AztecCode
3: Linear/ Postal/ Stacked
4: VeriCode®
5: DotCode
 Deletes the specified model.
AztecCode is only supported on the DM503 and DM300 series readers. 		Fixed mount readers.
UPTIME | Shows the time since device started. | All

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Code Quality Commands

Code Quality Commands

SET|GET CQ state
 [ON|OFF] enable/disable Enable Code Quality.
Code Quality Measurements require reader calibration and the Verification Feature Key. 		DM8600V
GET | CQ.CALIB-DATE | Device Code Quality Calibration Date. | DM8600V
SET|GET CQ.ILLUMINATION illumination-option

state
 [0-4]

[ON|OFF] 		0: Direct on axis
1: 30-deg All Quadrants
2: 30-deg E-W Quadrants
3: 30-deg N-S Quadrants
4: Custom
enable/disable 		Code Quality Illumination Option. DM8600V
SET|GET CQ.METRICS metric

 [0-3]

 0: AIM-DPM/ISO/IEC TR 29158
1: ISO/IEC 15415
2: AS9132 Laser-etch
3: AS9132 Dot-peen 		Code Quality Enabled Metrics. DM8600V
SET|GET CQ.MINPASS metric

min-pass

 [0-1]

[0-4]

 0: AIM-DPM/ISO/IEC TR 29158
1: ISO/IEC 15415
0: F
1: D
2: C
3: B
4: A 		Code Quality Minimum Passing Grade.
Determines the threshold for "validation failure action" including beep and configured line output. 		DM8600V
SET|GET CQ.PROCESSM state
 [ON|OFF] enable/disable Code Quality Process Control Metrics. DM8600V
CQ.RESET-CALIBRATION Invalidates code quality calibration data.
Reboot is required. 		DM8600V
SET|GET CQ.UNITS option

 [0-3]

 0: mils
1: mm
2: inches
3: pixels 		Code Quality Units. DM8600V
SET|GET SYMBOL.C39-CONVERT-TO-C32 state
 [ON|OFF] enable/disable Parameter enables or disables Code39 to Code 32 conversion. DM70, DM150, DM260

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Communication Commands

Communication Commands

SET|GET ACCEL-SENSOR.OPERATION-MODE int

 [0-1]
 0: Acceleration Sensor is not used for waking the reader up from hibernation.
1: Acceleration Sensor is used for waking the reader up from hibernation. 		Configures the application of the acceleration sensor.
This command is only valid for Bluetooth-connected readers. 		DM8050, DM8600.
SET|GET ACCEL-SENSOR.SENSITIVITY int

 [0-2]

 0: Low
1: Medium
2: High 		Gets/sets the sensitivity of the acceleration sensor of/to the predefined value. DM8050, DM8600.
SET|GET ANDROID.AOA-SWITCH-TIMEOUT timeout [ms]
 0-3600000 Timeout in milliseconds. After boot the MX device won’t switch to AOA mode for this amount of time. MX-1000, MX-1502
SET|GET ANDROID.ROLE role

 0-2

 0: Auto
1: Device
2: AOA 		Sets the USB role of the MX device when in Android mode. MX-1000, MX-1502
GET | BLUETOOTH.MAC-ADDRESS | Returns the own Bluetooth address of the device. | DM8050, DM8600.
SET|GET BLUETOOTH.MAX-RF-POWER int
 -23-7 Maximum output power in dBm DM8050, DM8600, and Bluetooth base stations.
SET|GET BUTTON.SAVE-MATCH-STRING state
 [ON|OFF] enable/disable Enables or disables saving the trained match string directly to flash when Set Match String is enabled for the 3 sec button press action. If disabled, the match string is only stored in RAM and if the configuration is not saved manually it will be gone after reboot. DM474, DM503, and DM300 series readers.
SET|GET COM.BAUD-RATE rate

 [1-5]

 1: 115200
2: 57600
3: 38400
4: 19200
5: 9600 		ALL except for MX-1000.
SET|GET COM.BUFFER-AUTO-FLUSH state
 [ON|OFF] enable/disable Determines if the whole content of the offline buffer is automatically flushed to the first Telnet client. If not, flushing must be activated by the client. Wireless readers.
SET|GET COM.BUFFER-DATA state
 [ON|OFF] enable/disable Offline buffering. Wireless readers.
SET|GET COM.BUFFER-MODE int

 [0-1]
 0: Multiple
1: Single 		Sets or gets the offline buffering mode. Wireless DM8000 readers.
GET COM.COMMUNICATIONS-MODULE type

 [0-3]

 0: Serial
1: Ethernet
2: Wireless
3: Bluetooth 		Returns the type of communication module being used. MX-1000 and DM8000 series readers.
SET|GET COM.DATA-BITS bits
 [7,8] ALL except for MX-1000.
SET|GET COM.DMCC-RESPONSE mode

 [0|1]
 0: Silent (default)
1: Extended 		DMCC response format. ALL
SET|GET COM.MULTI-PORT state
 [ON|OFF] enable/disable Enable daisy chaining of readers so they share one COM port. Fixed mount readers.
SET|GET COM.PARITY parity

 [0-4]

 0: None
1: Even
2: Odd
3: Space
4: Mark 		All except for MX-1000 and MX-1502.
SET|GET COM.PROTOCOL type

 0..1
 0: Off
1: RTS/CTS 		Sets hardware handshake type of serial port. Devices with RTS/CTS lines
SET|GET COM.RS232-ENABLE-PAUSE mode
 ON/OFF Enable/disable pause in output data stream. DM300 series readers, DM60, DM50, DM70, DM474
SET|GET COM.RS232-INTERCHAR-DELAY us
 [0-5000] milliseconds Sets or gets the internal delay between sending characters to the serial port. DM300 series readers, DM60, DM50, DM70, DM360 series readers, DM474, DM503
SET|GET COM.RS232-ROUTE value

 [0-1]
 0: base station
1: associated reader 		Controls to which device RS-232 communication is routed. DM8000 series wireless readers.
SET|GET COM.SCRIPT num-bytes
 GET: Retrieves the current communication script. SET: Uploads a communication script. Fixed-mount readers.
SET|GET COM.SCRIPT-ENABLED bool
 Enables/disables communication scripting or retrieves current state. Fixed-mount readers.
GET COM.SCRIPT-ERROR message
 script error message Get the error message for the Custom Communication protocol script Fixed-mount readers.
SET|GET COM.STOP-BITS bits
 [1-2] ALL except for MX-1000.
SET|GET COM.USB-COMPATIBILITY-MODE legacy

 [ON|OFF]
 ON: use pre-3.5.0 driver
OFF: default 		Controls USB driver.
Reboot is required. 		DM50, DM70 and DM8000 series readers.
SET|GET COM.USB-HID-ONLY state
 [ON|OFF] enable/disable When enabled, the base station will appear as a single USB Keyboard device on its USB port, instead of a composite device. DM8000 base station G2
SET|GET COM.USB-MODE type

 [0-1]
 0: USB COM
1: USB HID 		Controls USB based communication channels. DM50, DM60, DM70, MX-1000, MX-1502 and DM8000 series readers.
SET|GET COM.USB-RE-ENUMERATE-ON-START state

 [ON|OFF] [ON|OFF]
 enable/disable ON: USB 1.1 mode
OFF: USB 2.0 mode 		Feature to re-enumerate the COM port after firmware is started. DM8000 series readers.
SET|GET COM.USB-REQUIRE-DTR state
 [ON|OFF] [ON|OFF] enable/disable Enable/Disable Turns the requirement to assert DTR signal during USB communication On or Off. DM8050
SET|GET COM.USB-SPEED int

 [ON|OFF]
 ON: USB 1.1 mode
OFF: USB 2.0 mode 		Forces the USB into full speed mode. Every reader connected through USB except MX-1000.
SET|GET COM.WAKEUP state
 [ON|OFF] enable/disable Wakeup Message. ALL
SET|GET COM.XLATEPRNT state
 [ON|OFF] enable/disable Translate unprintable characters that are embedded in a symbol. The translated result is output over the connection (for example, COM, USB, Ethernet, USB-KEYBOARD). Note that Data Formatting leading and terminating text are not translated. The characters translated are ASCII values between 0x00 and 0x1F. For example, 0x00 = <NUL>, 0x04 = <EOT>, 0x0a = <LF>, 0x0d = <CR>. ALL
SET|GET CONFIG-BACKUP.SERVER-TYPE type

 [0-1]
 0: Generic
1: Mitsubishi GOT 		Configuration backup server type. DM474, DM503 and DM300 series readers.
SET|GET CUSTOM-CMD.COMMAND-FOOTER string
 End of the string to be echoed.
See the Overview topic for formatting requirements for the string argument. 		Fixed mount readers.
SET|GET CUSTOM-CMD.COMMAND-HEADER string
 Start of the string to be echoed. Fixed mount readers.
SET|GET CUSTOM-CMD.ECHO state
 [ON|OFF] enable/disable Indicates if characters received between a COMMAND-HEADER and COMMAND-FOOTER are echoed. Fixed mount readers.
SET|GET CUSTOM-CMD.TRIGGER state
 [ON|OFF] enable/disable Indicates if reader will respond to the TRIGGER-ON or TRIGGER-OFF string. Fixed mount readers.
SET|GET CUSTOM-CMD.TRIGGER-OFF string
 String that will stop a trigger.
See the Overview topic for formatting requirements for the string argument. 		Fixed mount readers.
SET|GET CUSTOM-CMD.TRIGGER-ON string
 String that will start a trigger.
See the Overview topic for formatting requirements for the string argument. 		Fixed mount readers.
SET|GET DATA.RESULT-ENCODING encoding

 [0|1]
 0: ASCII (default)
1: Base64 		Result string encoding. ALL
GET | DEVICE.MAC-ADDRESS | Reader's MAC address. | Ethernet readers.
SET|GET DEVICE.SSID string
 Network name. Wireless readers.
SET|GET ETHERNET-IP.ENABLED state
 [ON|OFF] enable/disable Enabled or disabled EtherNet/IP communications. Ethernet readers. The DM8000 series wireless readers also support this protocol if the base station is connected through Ethernet. In the case of a Bluetooth connection, the command has to be sent to the base station, not to the reader.
SET|GET FTP-IMAGE.CUSTOM-FILE-NAME state
 [ON|OFF] enable/disable Enable/disable FTP server generated file name. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.FILE-NAME string
 File name of FTP image. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.FILE-NAME-USE-SCRIPT state
 [ON|OFF] enable/disable Enables FTP file name generation script. DM474, DM503 and DM300 series readers.
SET|GET FTP-IMAGE.IDLE-LIMIT state
 [ON|OFF] enable/disable Limit duration of idle connections. DM474, DM503 and DM300 series readers.
SET|GET FTP-IMAGE.IDLE-TIME seconds
 Maximum duration of telling the FTP server that the reader is alive. DM474, DM503 and DM300 series readers.
SET|GET FTP-IMAGE.IP-ADDRESS string
 IP address of target FTP server.
Uses dotted decimal form, such as "192.168.23.42". 		Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.MAX-APPEND value
 [0-65535] Max increment value to append to image name. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.MAX-APPEND-START-VALUE value
 [0-65535] Initial increment value to append to image name. DM503
SET FTP-IMAGE.PASSWORD string
 Password used to login to target FTP server. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.PORT port
 [0-65535] FTP server port number. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.SERVER-PATH string
 Path for FTP image. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-IMAGE.SERVER-PATH-SCRIPT num-bytes
 Set: loads the script from the host to the reader. Get: sends the script from the reader to the host. DM474, DM503 and DM300 series readers.
GET FTP-IMAGE.SERVER-PATH-SCRIPT-ERROR message
 script error message Gets the script error message for FTP Storage name generation . Fixed-mount readers.
SET|GET FTP-IMAGE.SERVER-TYPE type

 [0-2]

 0: Generic
1: Mitsubishi GOT
2: SFTP 		FTP image server type. 2 means that the server is an S(SH)FTP server. DM474, DM503 and DM300 series readers.
SET|GET FTP-IMAGE.USER-NAME string
 Username used to login to target FTP server. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-PCM-REPORT.CUSTOM-FILE-NAME state

 ON/OFF
 enable
disable 		Enable/disable customize file name generation (if disabled the FTP server has to generate a unique name). Ethernet readers
SET|GET FTP-PCM-REPORT.ENABLE enable
 ON/OFF Enable or disable a PCM Report FTP connection. Ethernet readers
SET|GET FTP-PCM-REPORT.FILE-NAME string
 File name of PCM Report. Ethernet readers
SET|GET FTP-PCM-REPORT.FILE-NAME-USE-SCRIPT state

 ON/OFF
 enable
disable 		Enables PCM report file name generation by script. Ethernet readers
SET|GET FTP-PCM-REPORT.IDLE-LIMIT state

 ON/OFF
 enable
disable 		Limit duration of idle connections after a data transfer. Ethernet readers
SET|GET FTP-PCM-REPORT.IDLE-TIME seconds
 [0-3600] Maximum duration of idle connections after a data transfer. Ethernet readers
SET|GET FTP-PCM-REPORT.IP-ADDRESS server
 IP address or DNS name Set the PCM Report FTP server. Ethernet readers
SET|GET FTP-PCM-REPORT.MAX-APPEND value
 [0-65535] Max increment value to append to PCM report file name. Ethernet readers
SET|GET FTP-PCM-REPORT.MAX-APPEND-START-VALUE value
 [0-65535] Initial increment value to append to PCM report file name. Ethernet readers
SET|GET FTP-PCM-REPORT.PASSWORD string
 PASSWORD used to login to target PCM Report FTP server. Ethernet readers
SET|GET FTP-PCM-REPORT.PORT port
 [0-65535] PCM Report FTP server port number. Ethernet readers
GET FTP-PCM-REPORT.SCRIPT-ERROR message
 script error message Gets the script error message for FTP PCM report file name generation. Ethernet readers
SET|GET FTP-PCM-REPORT.SERVER-PATH string
 Path for PCM Reports which has to be named by the FTP Server. Ethernet readers
SET|GET FTP-PCM-REPORT.SERVER-TYPE type

 [0-2]

 0: Generic
1: Mitsubishi GOT
2: SFTP(encrypted) 		FTP server type. Ethernet readers
SET|GET FTP-PCM-REPORT.USER-NAME string
 Username used to login to target PCM Report FTP server. Ethernet readers
SET|GET FTP-RESULT.APPEND type

 [ON|OFF]
 ON: Append result to existing file.
OFF: Overwrite file content with result. 		Append to or overwrite file when result is sent via FTP to the file specified by FTP-RESULT.FILE-NAME. The file will be created if it does not exist. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-RESULT.ENABLE state
 [ON|OFF] enable/disable Enable/disable FTP transfer of reader results. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-RESULT.FILE-NAME string
 File name of FTP result. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-RESULT.IDLE-LIMIT state
 [ON|OFF] enable/disable Limit duration of idle connections after a data transfer. DM474, DM503 and DM300 series readers.
SET|GET FTP-RESULT.IDLE-TIME seconds
 [0-3600] Maximum duration of idle connections after a data transfer. DM474, DM503 and DM300 series readers.
SET|GET FTP-RESULT.IP-ADDRESS string
 IP address of target FTP server.
Uses dotted decimal form, such as "192.168.23.42". 		Ethernet readers and MX-1000. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET FTP-RESULT.PASSWORD string
 Password used to login to target FTP server. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-RESULT.PORT port
 [0-65535] FTP server port number. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
SET|GET FTP-RESULT.SERVER-TYPE type

 [0-2]

 0: Generic
1: Mitsubishi GOT
2: SFTP 		FTP server type.2 means that the server is an S(SH)FTP server. DM474, DM503 and DM300 series readers.
SET|GET FTP-RESULT.USER-NAME string
 Username used to login to target FTP server. Ethernet readers. DM8000 series wireless readers also support FTP if the base station is connected through Ethernet.
GET HPIT.FRONT-COVER

[0-4]

 0 = No cover
1 = Cross polarized NEWC Linear Polarized S
2 = Clear cover
3 = Undefined
4 = Diffused 		Detected front cover type. DM370 series, DM470 series readers.
SET|GET INPUT1.SAVE-MATCH-STRING state
 [ON|OFF] enable/disable Enables or disables saving the match string to flash when Set Match String is enabled as Input line 1 action. DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET
Technology Preview 		INTER-MESSAGE.DELAY value
 [0-10000] milliseconds Transmission delay between buffered read strings. Wireless readers.
SET|GET KEY.INTERCHAR-DELAY us
 [0-1000] milliseconds Sets or gets the delay time between characters when in HID keyboard mode. DM300 series readers, DM60, DM50, DM70, DM474.
SET|GET MASTER-SLAVE.GROUP-NAME name
 Gets or sets the name of the master slave group. DM60, DM474, DM503, and DM300 series readers.
SET|GET MASTER-SLAVE.MODE mode

 [0-2]

 0: OFF
1: ON
2: Master 		Switches the master-slave functioning of the reader on or off. DM60, DM474, DM503, and DM300 series readers.
MASTER-SLAVE.TEST mode

message
 [0-2]

 0: Slave to Master
1: Master to Slave
2: Master to Slave to Master
 Transmits the test message from reader to reader as designated by mode. The terminating reader will output the message preceded by the initiating device delimited by a space Fixed-mount readers.
SET|GET MASTER-SLAVE.TEST-EFP-OUTPUT state

 [ON|OFF]
 ON: enable
OFF: disable 		Enables or disables mst-test messages on the Industrial Protocol interfaces. DM300 series readers, DM474.
SET|GET MASTER-SLAVE.TIMEOUT milliseconds
 [0-10000] Gets or sets the time to wait for results from slave cameras. DM60, DM474, DM503, and DM300 series readers.
SET|GET MASTER-SLAVE.TIMEOUT-DISTANCE int
 [0-1000000] Distance The distance for a master slave timeout. DM60, DM70, DM260, DM474, DM503, and DM300 series readers.
SET|GET MASTER-SLAVE.TIMEOUT-MODE mode

 [0-1]
 0: Time
1: Distance 		Controls if the mater slave response timeout will be time or distance based. DM60, DM260, DM474, DM503, and DM300 series readers.
SET|GET MODBUSTCP.ENABLED state
 [ON|OFF] enable/disable Enable or disable Modbus/TCP communication. Ethernet readers. The DM8000 series wireless readers also support this protocol if the base station is connected through Ethernet. In the case of a Bluetooth connection, the command has to be sent to the base station, not to the reader.
SET|GET MODBUSTCP.HOLDING-ONLY state
 [ON|OFF] enable/disable Ethernet readers. DM8000 series wireless readers also support this protocol if the base station is connected through Ethernet.
SET|GET NET-LOCAL.DHCP state
 [ON|OFF] enable/disable Enable/Disable DHCP on reader. Ethernet readers.
SET|GET NET-LOCAL.DNS-SERVER server
 Gets or sets the DNS Server address. Ethernet readers.
SET|GET NET-LOCAL.GATEWAY string
 Reader's default gateway IP address.
Uses dotted decimal form, such as "192.168.23.1". 		Ethernet readers.
SET|GET NET-LOCAL.IP-ADDRESS string
 Reader's IP address.
Uses dotted decimal form, such as "192.168.23.42". 		Ethernet readers.
SET|GET NET-LOCAL.PORT port
 [1-65535] Setup Tool server TCP port on reader. Ethernet readers.
SET|GET NET-LOCAL.READER-IP-ADDRESS string
 dotted decimal form IPv4 address Base station's IP address.
Uses dotted decimal form, such as "192.168.23.42". 		Base stations.
SET|GET NET-LOCAL.READER-SUBNET-MASK string
 dotted decimal form IPv4 address Base station's subnet mask.
Uses dotted decimal form, such as "192.168.23.255". 		Base stationss.
SET|GET NET-LOCAL.SUBNET-MASK string
 Reader's subnet mask.
Uses dotted decimal form, such as "192.168.23.255". 		Ethernet readers.
SET|GET NETWORK-CLIENT.CLIENT-PORT int
 [0-65535] The port on the reader to use as the outbound port (default is 0). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.CLOSE-CONNECTION int

 [0-1]
 0: Never
1: After reader data transfer 		Whether or not to keep the connection open after data transfer (default is 0). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.CONNECTION-TIMEOUT int
 [1000-60000] How long to wait before considering the connection dead (default is 3000). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.ENABLED state
 [ON|OFF] enable/disable Switch the Network Client feature on or off. Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.HOST-ADDRESS string
 Max length = 255 The address of the server to connect to. Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.HOST-PORT int
 [0–65535] The remote port on the server to connect to (default is 1000). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.IDLE-TIMEOUT int
 [1–3600] How long to keep the connection open after transfer (default is 1). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.OPEN-CONNECTION us

 [0-1]
 0: on Power-up
1: on Data Activity 		When to open the connection to the remote host (default is 0). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.PROTOCOL int

 [0-1]
 0: TCP
1: UDP 		Which protocol to use for the connection (default is 0). Ethernet readers except for the DM8000 wireless.
SET|GET NETWORK-CLIENT.RECONNECT-DELAY int
 [100-60000] How long to wait before reconnecting if the connection is lost (default is 1000). Ethernet readers except for the DM8000 wireless.
SET|GET NTP.ENABLE state
 [ON|OFF] enable/disable Enable/Disable Enables or disables NTP. All
SET|GET NTP.SERVER1 server
 IP address or DNS name Set the NTP server 1. All
SET|GET NTP.SERVER2 server
 IP address or DNS name Set the NTP server 2. All
SET|GET OUTPUT.USER-CONFIGURE event number

beep tone

beep number

LED color

vibration

 [1,2]

[0-2]

[0-3]

[0-7]

[ON|OFF] 		1: USER_EVENT_1
2: USER_EVENT_2

[0]: Low
[1]: Medium
[2]: High

Number of beeps

[0]: Off
[1]: Blue
[2]: Green
[3]: Cyan
[4]: Red
[5]: Magenta
[6]: Yellow
[7]: White
enable/disable ON: The reader vibrates on the given user event.
OFF: The reader does not vibrate on the given user event. 		Sets the beeper tone and the number of beeps for USER_EVENT_1 or USER_EVENT_2. DM8050 (except for the vibration parameter), ON|OFF is supported on DM8600 and MX-1000.
SET|GET PROFINET.ENABLED state
 [ON|OFF] enable/disable Enabled or disabled PROFINET communications. Ethernet readers. The DM8000 series wireless readers also support this protocol if the base station is connected through Ethernet. In the case of a Bluetooth connection, the command has to be sent to the base station, not to the reader.
SET|GET PTP-SYNC.DELAY time
 [0-1000000] Time between trigger start and the synchronized acquisition timestamp. DM360 series readers, DM474
SET|GET PTP-SYNC.ENABLE mode
 [ON|OFF] Enables MST synchronized by PTP. DM360 series readers, DM474
SET|GET PTP-SYNC.LOCAL-OFFSET time
 [0-1000000] Local offset added to the synchronized acquisition timestamp. DM360 series readers, DM474
SET|GET PTP.ENABLE mode

 [ON|OFF] enable/disable OFF: Disable the PTP timestamp synchronization
ON: Enable the PTP timestamp synchronization 		Enable the PTP timestamp synchronization. DM360 series readers, DM474
SET|GET PTP.PRIORITY1 level
 [0-255] This is the first 8-bit priority value (lower number denotes a higher priority). Normally, this is set at 128 for master capable devices. DM360 series readers, DM474
SET|GET PTP.PRIORITY2 level
 [0-255] This is the second 8-bit priority value (lower number denotes a higher priority). This parameter allows to configure backup clocks. DM360 series readers, DM474
SET|GET PTP.SLAVE-ONLY mode

 [ON|OFF] enable/disable OFF: Disables PTP slave only configuration of the reader
ON: Configures the reader as PTP slave only 		This parameter configures the reader as PTP slave only, even if no other master is active. DM360 series readers, DM474
SET|GET READER.ASSIGNED state
 [ON|OFF] enable/disable Unassignins the reader and the base station that is associated with it. Base
SET|GET SDCARD.BACKUP-FILE state
 [ON|OFF] enable/disable SD card is used for creating and restoring a configuration file backup. DM360 series readers, DM474
GET SDCARD.PRESENT
Returns True if the SD card was detected, False otherwise. DM360 series readers, DM474
SET|GET SLMP-PROTOCOL.ENABLED state
 [ON|OFF] enable/disable Enables or disables SLMP-Protocol communication. Ethernet readers. DM8000 series wireless readers also support this protocol if the base station is connected through Ethernet. In the case of a Bluetooth connection, the command has to be sent to the base station, not to the reader.
SET|GET SYNC-ACQUISITION.CABLE-END state
 [ON|OFF] enable/disable Sets or gets whether your device is a bus terminator at the end of the synchronization interface bus. DM503
SET|GET SYNC-ACQUISITION.DELAY us
 [0-25000] microseconds Synchronized acquisition delay: the time the reader waits after sending or receiving the synchronized interface signal before the regular acquisition sequence starts. DM503
SET|GET SYNC-ACQUISITION.ENABLED state
 [ON|OFF] enable/disable Enables or disables synchronized triggering. DM503
SET|GET SYNC-ACQUISITION.MASTER state
 [ON|OFF] enable/disable Sets or gets whether the device is the master among the synchronized readers. DM503
SET|GET TELNET.CUSTOM-PORTS port
 [0-65535] Comma separated list of TCP ports Additional Telnet TCP ports for custom communication. Ethernet readers
SET|GET TELNET.PORT value
 [0-65535] Telnet server TCP port on reader. Ethernet readers.
TEST-MODE.ACCEPT-TRIGGERS value
 [0-2000000000] number of accepted triggers from all inputs Allows a limited number of triggers from external inputs even if triggering from those should be rejected using TEST-MODE.INPUTS-ENABLE. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TEST-MODE.AUTOMATIC state
 [ON|OFF] enable/disable Enables automatic triggering. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TEST-MODE.AUTOMATIC-OFF-US microseconds
 [0-2000000000] Inactive trigger phase for automatic triggering. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TEST-MODE.AUTOMATIC-ON-US microseconds
 [0-2000000000] Active trigger phase for automatic triggering. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TEST-MODE.ENABLE state
 [ON|OFF] enable/disable Enables test mode. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TEST-MODE.INPUTS-ENABLE state
 [ON|OFF] enable/disable Disables external trigger sources during test mode. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TEST-MODE.OUTPUTS-ENABLE state
 [ON|OFF] enable/disable Disables result reporting to external destinations during test mode. DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET WIFI.AUTH-MODE int

 [0-3]

 0 – no auth
1 – WPA-PSK
2 – WPA2-PSK
3 – EAP/TLS
4 – PEAP-MSCHAPV2 		Sets the authentication method. DM8000
SET|GET WIFI.CA-CERT string
 NA Used In WPA-Enterprise. This is the certificate of the certification authority we trust. PEM formatted certificate, terminated by a space. DM8000;Base
SET|GET WIFI.CHANNEL int
 [1-11] Sets the wifi channel number.
SET|GET WIFI.CLIENT-CERT string
 NA Used in WPA-Enterprise (EAP-TLS). This is the certificate of the reader signed by the trusted CA (set with the previous command). PEM formatted certificate, terminated by a space. DM8000;Base
SET|GET WIFI.CLIENT-IDENTITY string
 NA The identity the client certificate is issued to. DM8000;Base
SET|GET WIFI.CLIENT-PRIVATE-KEY string
 NA Used in WPA-Enterprise (EAP-TLS). The private key of the reader. PEM formatted private key, terminated by a space. DM8000;Base
SET|GET WIFI.ENABLED state
 [ON|OFF] enable/disable Enables or disables wifi in ad-hoc mode.
SET|GET WIFI.ENC-METHOD int

 [0-5]

 0 – off
1 – WEP40
2 – WEP104
3 – TKIP
4 – AES
5 – TKIP/AES 		Sets the authentication method. DM8000;Base
SET|GET WIFI.NETWORK-TYPE int

 [0-1]
 0 – Infrastructure mode
1 – AD-HOC mode 		Sets whether wifi works in infrastructure or ad-hoc mode. DM8000
SET|GET WIFI.PASSPHRASE string
 NA In WEP encrpytion and in WPA(2)-PSK it is the passphrase set by the AP. DM8000;Base
SET|GET WIFI.SSID string
 NA Assigns an SSID name to the network.

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Data Formatting Commands

Data Formatting Commands

SET|GET | FORMAT.ADVANCED | state | [ON|OFF] | enable/disable | Enable Data Formatting Advanced Mode. Advanced Mode Formatting Enables: Regexp Pattern Substitution. | ALL
SET|GET | FORMAT.CRLF-END | state | [ON|OFF] | enable/disable | Data Formatting CRLF Terminator. Requires Data Formatting Standard Mode Enabled. | ALL
SET|GET | FORMAT.DELIMITER | delimiter-option | [0-5] | 0: none 1: space 2: comma 3: tab 4: label 5: xml | Data Formatting Delimiter. Sets the delimeter between Data Formatting Tokens. Requires Data Formatting Standard Mode Enabled. | ALL
SET|GET | FORMAT.DISCARD-UNMATCHED | state | [ON|OFF] | enable/disable | Data Formatting Discard Unmatched Data. | ALL
SET|GET | FORMAT.MODE | mode | [0-1] | 0: basic formatting 1: script-based formatting | Specifies data formatting mode. By default, basic formatting is the set formatting mode. | DM50, DM60, DM70, DM474, DM503, MX-1000, MX-1502 and DM300 series readers.
SET|GET | FORMAT.MULTICODE-DELIMITER | type | [0-6] | 0: none 1: space 2: comma 3: tab 4: label 5: xml 6: CRLF | Data Formatting Delimiter. Sets the delimiter between codes in a multicode result. | Fixed mount readers.
SET|GET | FORMAT.PROG-TARG | category | [0-5] | 0: Universal 1: DataMatrix 2: QR Code/MaxiCode/AztecCode 3: Linear/ Postal/ Stacked 4: VeriCode® 5: DotCode | Data Formatting Programming Target. Data Formatting Symbology Set to be modified by subsequent commands. Once issued, it changes the subsequent behavior of the reader. AztecCode is only supported on the DM503 and DM300 series readers. | ALL
SET|GET | FORMAT.REGEXP | string |  | regular expression string | Data Formatting Regular Expression. Requires Data Formatting Advanced Mode Enabled. See the Overview topic for formatting requirements for the string argument. | ALL
SET|GET | FORMAT.SCRIPT | num-bytes |  |  | Set: loads the script from the host to the reader. Get: sends the script from the reader to the host. | DM474, DM503, MX-1000, MX-1502 and DM300 series readers.
SET|GET | FORMAT.STANDARD | state | [ON|OFF] | enable/disable | Enable Data Formatting Standard Mode. Standard Mode Formatting Enables: Leading Text, Data, Data Delimeter, Terminating Text, Terminating CRLF. | ALL
SET|GET | FORMAT.TEXT-BEGIN | string |  | leading output text | Data Formatting Leading Text. Requires Data Formatting Standard Mode Enabled. See the Overview topic for formatting requirements for the string argument. | ALL
SET|GET | FORMAT.TEXT-END | string |  | trailing text | Data Formatting Trailing Text. Requires Data Formatting Standard Mode Enabled. See the Overview topic for formatting requirements for the string argument. | ALL
SET|GET | FORMAT.TOKEN | string |  | token string | Data Formatting Standard Data. Regardless of the parameters given to GET FORMAT.TOKEN, it will return the current data formatting token string contained in the Standard Formatting window pointed to by the current value of GET FORMAT.PROG-TARG. See Data Formatting Token Table for available elements. See the Overview topic for formatting requirements for the string argument. | ALL
SET|GET | INPUT-STRING.ENABLE | state | [ON|OFF] | enable/disable | Enables or disables the use of the Input String feature (available for serial, telnet, NetworkClient). When enabled, a header and the footer can be set by the INPUT-STRING.HEADER and INPUT-STRING.FOOTER commands, respectively. A string of characters can be given between the header and the footer, which will be sent with the formatted output (for example, [hello world], if the header is set to ’[’ and the footer to ’]’). Since the input string is saved temporarily, it appears only in the next result output. Use Setup Tool (the <Input String> option) or <ISTR> with DMCC (see SET FORMAT.TOKEN) to allow Input string in the result output. | ALL
SET|GET | INPUT-STRING.FOOTER | string |  | token string | Sets the footer for the Input String character string. | ALL
SET|GET | INPUT-STRING.HEADER | string |  | token string | Sets the header for the Input String character string. | ALL
SET|GET | INPUT-STRING.MODE | int | [0-4] | 0: Store 1: Send 2: Send with header and footer 3: Send with formatting 4: Send with header and footer formatting | Controls whether the input string data is sent out as a result or stored in an internal variable. | Fixed-mount readers.
SET|GET | INPUT-STRING.VALUE | string |  | token string | Sets the content of the Input String character string. | Fixed-mount readers
 | SCRIPT.LOAD | num-bytes |  |  | Loads the formatting script from the host to the reader. | DM50, DM60, DM70, DM474, DM503, MX-1000, MX-1502 and DM300 series readers.
 | SCRIPT.SEND |  |  |  | Sends the formatting script from the reader to the host. | DM50, DM60, DM70, DM474, DM503, MX-1000, MX-1502 and DM300 series readers.

Data Formatting Tokens

General Tokens

Token | Description
<BRDC> | Total No-Reads
<CANG> | Code Orientation
<CCTR> | Code Center
<CNTR> | Contrast
<CPOS> | Code Position
<CRLF> | CR/LF
<DATA> | Full String
<DSUB> | Sub-string. For example <DSUB(1-2)>.
<FVDC> | Failed Validation
<GRDC> | Total Reads
<IALT> | Image acquisition local time
<IAUT> | Image acquisition UTC time
<ICNT> | Buffered Allowed No Reads
<IGEN> | Result Source
<IRCLT> | Subresult creation local time
<IRCUT> | Subresult creation UTC time
<ISTR> | Input String
<ITFL> | Filter Time
<LTIM> | Current local time
<MOSI> | Module Size
<MTRG> | Missed Triggers
<PCMR> | PCM Data
<PVDC> | Passed Validation
<RDSI> | Used Read Setup
<SMID> | Symbology Identifier
<SMSI> | Symbol Size
<SPAC> | SP
<SYMB> | Symbology
<TABS> | TAB
<TCLT> | Trigger creation local time
<TCUT> | Trigger creation UTC time
<TELT> | Trigger execution local time
<TEUT> | Trigger execution UTC time
<TIDX> | Trigger Index
<TMDC> | Decode Time
<TMTR> | Trigger Time
<TTRG> | Total Triggers
<UTIM> | Current UTC time
<UUEC> | Unused Error Correction

Validation Tokens

Token | Description
<AI00> | Serial Shipping Container Code (SSCC)
<AI01> | Global Trade Item Number
<AI02> | GTIN of Contained Trade Items
<AI10> | Batch or Lot Number
<AI11> | Production Date
<AI12> | Due Date for Amount on Payment Slip
<AI13> | Packaging Date
<AI15> | Best Before Date
<AI16> | Sell By Date
<AI17> | Expiration Date
<AI20> | Product Variant Number
<AI21> | Serial Number
<AI240> | Additional Product Identification Assigned by the Manufacturer
<AI241> | Customer Part Number
<AI242> | Made-to-Order Variation Number
<AI243> | Packaging Component Number
<AI250> | Secondary Serial Number
<AI251> | Reference to Source Entity
<AI253> | Global Document Type Identifier (GDTI)
<AI254> | GLN Extension Component
<AI255> | Global Coupon Number (GCN)
<AI30> | Variable Count of Items
<AI310x> | Net weight (kilograms)
<AI311x> | Length or first dimension
<AI312x> | Width, diameter, or second dimension
<AI313x> | Depth, thickness, height, or third dimension
<AI314x> | Area (sq meters)
<AI315x> | Net Volume (liters)
<AI316x> | Net Volume (cubic meters)
<AI320x> | Net Weight (pounds)
<AI321x> | Length or first dimension (inches)
<AI322x> | Length or first dimension (feet)
<AI323x> | Length or first dimension (yards)
<AI324x> | Width, diameter, or second dimension (inches)
<AI325x> | Width, diameter, or second dimension (feet)
<AI326x> | Width, diameter, or second dimension (yards)
<AI327x> | Depth, thickness, height, or third dimension (inches)
<AI328x> | Depth, thickness, height, or third dimension (feet)
<AI329x> | Depth, thickness, height, or third dimension (yards)
<AI330x> | Logistic weight (kilograms)
<AI331x> | Length or first dimension (meters)
<AI332x> | Width, diameter, or second dimension (meters)
<AI333x> | Depth, thickness, height, or third dimension (meters)
<AI334x> | Area (sq meters)
<AI335x> | Logistic volume (liters)
<AI336x> | Logistic volume (cubic meters)
<AI337x> | Kilograms Per Square Metre
<AI340x> | Logistic weight (pounds)
<AI341x> | Length or first dimension (inches)
<AI342x> | Length or first dimension (feet)
<AI343x> | Length or first dimension (yards)
<AI344x> | Width, diameter, or second dimension (inches)
<AI345x> | Width, diameter, or second dimension (feet)
<AI346x> | Width, diameter, or second dimension (yards)
<AI347x> | Depth, thickness, height, or third dimension (inches)
<AI348x> | Depth, thickness, height, or third dimension (feet)
<AI349x> | Depth, thickness, height, or third dimension (yards)
<AI350x> | Area (sq inches)
<AI351x> | Area (sq feet)
<AI352x> | Area (sq yards)"
<AI353x> | Area (sq inches)
<AI354x> | Area (sq feet)
<AI355x> | Area (sq yards)
<AI356x> | Net weight (troy ounces)
<AI357x> | Net weight or volume (ounces)
<AI360x> | Net volume (quarts)
<AI361x> | Net volume (gallons us)
<AI362x> | Logistic volume (quarts)
<AI363x> | Logistic volume (gallons us)
<AI364x> | Net Volume (cubic inches)
<AI365x> | Net Volume (cubic feet)
<AI366x> | Net Volume (cubic yards)
<AI367x> | Logistic volume (cubic inches)
<AI368x> | Logistic volume (cubic feet)
<AI369x> | Logistic volume (cubic yards)
<AI37> | Count of Trade Items Contained in a Logistic Unit
<AI390x> | Amount Payable - Single Monetary Area
<AI391x> | Amount Payable and ISO Currency Code
<AI392x> | Amount Payable for a Variable Measure Trade Item - Single Monetary Area
<AI393x> | Amount Payable for a Variable Measure Trade Item and ISO Currency Code
<AI400> | Customer's Purchase Order Number
<AI401> | Global Identification Number for Consignment (GINC)
<AI402> | Global Shipment Identification Number (GSIN)
<AI403> | Routing Code
<AI410> | Ship to - Deliver to Global Location Number
<AI411> | Bill to - Invoice to Global Location Number
<AI412> | Purchased from Global Location Number
<AI413> | Ship for - Deliver for - Forward to Global Location Number
<AI414> | Identification of a Physical Location - Global Location Number
<AI415> | Global Location Number of the Invoicing Party
<AI420> | Ship to - Deliver to Postal Code within a Single Postal Authority
<AI421> | Ship to - Deliver to Postal Code with Three-Digit ISO Country Code
<AI422> | Country of Origin of a Trade Item
<AI423> | Country of Initial Processing
<AI424> | Country of Processing
<AI425> | Country of Disassembly
<AI426> | Country Covering Full Process Chain
<AI427> | Country Subdivision of Origin Code for a Trade Item
<AI7001> | Stock Number (NSN)
<AI7002> | UN/ECE Meat Carcasses and Cuts Classification
<AI7003> | Expiration Date and Time
<AI7004> | Active Potency
<AI7005> | Catch Area
<AI7006> | First Freeze Date
<AI7007> | Harvest Date
<AI7008> | Species for Fishery Purposes
<AI7009> | Fishing Gear Type
<AI7010> | Production Method
<AI703x> | Number of Processor with Three-Digit ISO Country Code
<AI710> | National Healthcare Reimbursement Number (Germany)
<AI711> | National Healthcare Reimbursement Number (France)
<AI712> | National Healthcare Reimbursement Number (Spain)
<AI713> | National Healthcare Reimbursement Number (Brazil)
<AI8001> | Roll Products - Width, Length, Core Diameter, Direction, Splices
<AI8002> | Cellular Mobile Telephone Identifier
<AI8003> | Global Returnable Asset Identifier (GRAI)
<AI8004> | Global Individual Asset Identifier (GIAI)
<AI8005> | Price per Unit of Measure
<AI8006> | Identification of the Components of a Trade Item
<AI8007> | International Bank Account Number (IBAN)
<AI8008> | Date and Time of Production
<AI8010> | Component / Part Identifier
<AI8011> | Component / Part Identifier Serial Number
<AI8017> | Global Service Relation Numbers (GSRN) - Provider
<AI8018> | Global Service Relation Numbers (GSRN) - Recipient
<AI8019> | Service Relation Instance Number (SRIN)
<AI8020> | Payment Slip Reference Number
<AI8100> | GS1-128 Coupon Extended Bar Code
<AI8101> | GS1-128 Coupon Extended Bar Code
<AI8102> | GS1-128 Coupon Extended Bar Code
<AI8110> | Coupon Code Identification for Use in North America
<AI8200> | Extended Packaging URL
<AI90> | Information Mutually Agreed Between Trading Partners
<AI91> | Company Internal Information
<AI92> | Company Internal Information
<AI93> | Company Internal Information
<AI94> | Company Internal Information
<AI95> | Company Internal Information
<AI96> | Company Internal Information
<AI97> | Company Internal Information
<AI98> | Company Internal Information
<AI99> | Company Internal Information
<VEID> | Enterprise Identifier
<VPNU> | Part Number
<VSNU> | Serial Number
<VUID> | Unique Item Identifier

Code Quality Tokens

Data Matrix - ISO/IEC 15415

Token | Description
<ANG1> | Axial Non-uniformity 15415 Grade
<ANM1> | Axial Non-uniformity 15415 Metric
<CCG1> | Cell Contrast 15415 Grade
<CCM1> | Cell Contrast 15415 Metric
<EXR0> | Extreme Reflectance Grade
<FPD1> | Fixed Pattern Damage Grade 15415
<GNG1> | Grid Non-uniformity 15415 Grade
<GNM1> | Grid Non-uniformity 15415 Metric
<MOD1> | Modulation 15415
<PGG1> | Print Growth Grade 15415
<PGM1> | Print Growth Metric 15415
<UEG1> | Unused Error Correction 15415 Grade
<UEM1> | Unused Error Correction 15415 Metric

Data Matrix - ISO/IEC TR 29158 (AIM DPM)

Token | Description
<ANG0> | Axial Non-uniformity AIM-DPM Grade
<ANM0> | Axial Non-uniformity AIM-DPM Metric
<CCG0> | Cell Contrast AIM-DPM Grade
<CCM0> | Cell Contrast AIM-DPM Metric
<FPD0> | Fixed Pattern Damage Grade
<GNG0> | Grid Non-uniformity AIM-DPM Grade
<GNM0> | Grid Non-uniformity AIM-DPM Metric
<MOD0> | Modulation AIM-DPM
<MRG0> | Minimum Reflectance AIM-DPM Grade
<MRM0> | Minimum Reflectance AIM-DPM Metric
<UEG0> | Unused Error Correction AIM-DPM Grade
<UEM0> | Unused Error Correction AIM-DPM Metric

Data Matrix - Semi T10

Token | Description
<CCM0> | Symbol Contrast
<UEM0> | Unused Error Correction
<CDEFG> | Cell Defects Semi-T10 Metric
<DMCHG> | Data Matrix Cell Height Semi-T10 Metric
<DMCWG> | Data Matrix Cell Width Semi-T10 Metric
<FPDFV> | Finder Pattern Semi-T10 Metric
<HMGV> | Horizontal Mark Growth Semi-T10 Metric
<HZMMV> | Horizontal Mark Misplacement Semi-T10 Metric
<SNRV> | Signal to Noise Ratio Semi-T10 Metric
<VMGV> | Vertical Mark Growth Semi-T10 Metric
<VTMMV> | Vertical Mark Misplacement Semi-T10 Metric

QR - ISO/IEC 15415

Token | Description
<ANG5> | Axial Non-uniformity QR Grade
<ANM5> | Axial Non-uniformity QR Metric
<CCG5> | Cell Contrast Grade
<CCM5> | Cell Contrast Raw
<EXR5> | Extreme Reflectance QR Grade 15415
<FPD5> | Fixed Pattern Damage QR Grade 15415
<GNG5> | Grid Non-uniformity QR Grade 15415
<GNM5> | Grid Non-uniformity QR Metric 15415
<MOD5> | Modulation QR Grade 15415
<PGG5> | Print Growth QR Grade
<PGM5> | Print Growth QR Metric
<UEG5> | Unused Error Correction QR Grade
<UEM5> | Unused Error Correction QR Metric

QR - ISO/IEC TR 29158 (AIM DPM)

Token | Description
<ANG7> | Axial Non-Uniformity QR Grade
<ANM7> | Axial Non-Uniformity QR Metric
<CCG7> | Cell Contrast QR Grade
<CCM7> | Cell Contrast QR Metric
<FPD7> | Fixed Pattern Damage QR Grade
<GNG7> | Grid Non-uniformity QR Grade
<GNM7> | Grid Non-uniformity QR Metric
<MOD7> | Cell Modulation QR Grade
<MRG7> | Minimum Reflectance QR Grade
<MRM7> | Minimum Reflectance QR Metric
<PGG7> | Print Growth QR Grade
<PGM7> | Print Growth QR Metric
<UEG7> | Unused Error Correction QR Grade
<UEM7> | Unused Error Correction QR Metric

1D Readability (Cognex)

Token | Description
<CCG4> | Symbol Contrast 1D Grade
<CCM4> | Symbol Contrast 1D Metric
<ECG4> | Edge Contrast Min 1D Grade
<ECM4> | Edge Contrast Min 1D Metric
<MRG4> | Reflect Min 1D Grade
<MRM4> | Reflect Min 1D Metric
<MSG4> | Multi Scan Integrity 1D Grade
<MSM4> | Multi Scan Integrity 1D Metric
<PGG4> | Print Growth 1D Grade
<PGM4> | Print Growth 1D Barcode Metric
<SSG4> | Single Scan Integrity 1D Grade

ISO/IEC 15416

Token | Description
<CCG8> | Symbol Contrast 1D Barcode Grade (ISO 15416)
<CCM8> | Symbol Contrast 1D Barcode Metric (ISO 15416)
<DCG8> | Decodability Grade (ISO 15416)
<DCV8> | Decodability Metric (ISO 15416)
<ECG8> | Edge Contrast Minimum Grade (ISO15416)
<ECM8> | Edge Contrast Minimum Metric (ISO15416)
<EDG8> | Edge Determination Grade (ISO 15416)
<EDV8> | Edge Determination Metric (ISO 15416)
<DEG8> | Defects Grade (ISO 15416)
<DEV8> | Defects Metric (ISO 15416)
<MOD2> | Modulation Metric (ISO 15416)
<MOD8> | Modulation Grade (ISO 15416)
<MRG8> | Minimum Reflectance Grade (ISO 15416)
<MRM8> | Minimum Reflectance (ISO15416)
<OVG8> | Overall Grade (ISO 15416)
<OVV8> | Overall Metric (ISO 15416)
<RDC8> | Reference Decode Grade (ISO 15416)
<RDV8> | Reference Decode Metric (ISO15416)

Dot Code AIM

Token | Description
<ANG6> | Axial Non-uniformity DotCode Grade (* change from AIM Specification thresholds)
<ANM6> | Axial Non-uniformity DotCode Metric
<CCG6> | Cell Contrast DotCode Grade
<CCM6> | Cell Contrast DotCode Metric
<GNG6> | Grid non-uniformity DotCode Grade
<GNM6> | Grid Non-uniformity DotCode Metric
<PGG6> | Print Growth DotCode Grade
<PGM6> | Print Growth DotCode Metric
<UEG6> | Unused Error Correction DotCode Grade
<UEM6> | Unused Error Correction DotCode Metric

Code Quality

Token | Description
<CBRD> | Consecutive Bad Reads
<PGAV> | Overall Print Growth (Average of H&V)
<PGHZ> | Print Growth Horizontal
<PGVT> | Print Growth Vertical
<PVDC> | Passed Validations
<TDFA> | Dark Field light angle
<TSTA> | Angle Test
<TSTD> | Distortion Test
<TSTP> | Position Test
<CCG2> | Cell Contrast AS9132-LE Grade
<CCM2> | Cell Contrast AS9132-LE Metric
<CUM1> | Contrast Uniformity 15415 Metric
<CUM5> | Contrast Uniformity QR Metric
<DAG2> | Distortion Angle AS9132 Grade
<DAM2> | Distortion Angle AS9132 Metric
<FHG2> | Cell Fill Horizontal AS9132-LE Grade
<FHM2> | Cell Fill Horizontal AS9132-LE Metric
<FVG2> | Cell Fill Vertical AS9132-LE Grade
<FVM2> | Cell Fill Vertical AS9132-LE Metric
<GRD0> | Symbol Grade (AIM-DPM)
<GRD1> | Symbol Grade 15415
<GRD2> | Symbol Grade AS9132-LE
<GRD3> | Symbol Grade AS9132-DP
<PGM0> | Print Growth AIM-DPM Metric
<PSG3> | Position Failure AS9132-DP Grade
<PSM3> | Position Failure AS9132-DP Metric
<RDC0> | Reference Decode AIM-DPM
<RDC1> | Reference Decode 15415
<RMG1> | Reflectance Margin 15415 Grade
<RMG5> | Reflectance Margin QR Grade
<RMM1> | Reflectance Margin 15415 Metric
<RMM5> | Reflectance Margin QR Metric
<SOG3> | Size and Ovality Failure AS9132-DP Grade
<SOM3> | Size and Ovality Failure AS9132-DP Metric

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Data Validation Commands

Data Validation Commands

Set/Get Command Arguments Range Meaning Description Support
SET|GET DVALID.DOD-EXEID string
 expected-EID DoD Expected Enterprise ID (EID). ALL
SET|GET DVALID.DOD-EXPN string
 expected-PN DoD Expected Part Number.
See the Overview topic for formatting requirements for the string argument. 		ALL
SET|GET DVALID.DODCNSTRT construct

 [0-3]

 0: Any
1: Construct #1
2: Construct #2
3: Equivalent 		Data Validation DoD Construct. ALL
SET|GET DVALID.FAIL-ACTION action

 [0-3]

 0: Transmit "Validation Failure"
1: Transmit "Validation Failure" + decoded string
2: Transmit annotated decode string
3: Transmit nothing 		Data Validation Failure Action. ALL
SET|GET DVALID.FAIL-XMT-CRLF state
 [ON|OFF] enable/disable Data Validation Transimit CRLF on Failure. ALL
SET|GET DVALID.GS1-FORMAT string
 GS1 format string Set GS1 format string. ALL
SET|GET DVALID.ISO-CONSTRUCT construct

 [0-1]
 0: ISO 15434
1: ISO 15434 & ISO 15418 		ISO Construct. ALL
SET|GET DVALID.MATCH-STRING string
 match-string Data Validation Match-String.
See the Overview topic for formatting requirements for the string argument. 		ALL
SET|GET DVALID.MATCH-STRING-PARAMS increment
start
length
step
no-read
validation-fail
 [ON|OFF]
[0-*]
[1-*]
[-2|-1|0|1|2]
[ON|OFF]
[ON|OFF] 		enable/disable
start position of numerical match
number of digits
increment
enable/disable update on no-read
enable/disable update on validation failure 		Data Validation Match-String Parameters. ALL
SET|GET DVALID.PATTERN string
 pattern-string Data Validation Pattern.
Regexp Data Validation.
See the Overview topic for formatting requirements for the string argument. 		ALL
SET|GET DVALID.PROG-TARG category

 [1-5]

 1: DataMatrix
2: QR Code/MaxiCode/AztecCode
3: Linear/ Postal/ Stacked
4: VeriCode®
5: DotCode 		Data Validation Programming Target.
Data Validation Symbology Set to be modified by subsequent commands.
Once issued, this command changes the subsequent behavior of the reader. 		ALL
SET|GET DVALID.TYPE type

 [0-5]

 0: None
1: DoD UID
2: ISO
3: Pattern
4: Match String
5: GS1 		ALL

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Decoder Commands

Decoder Commands

SET|GET AZTEC.TRAINED-MODEL grid size
module size
polarity

 [15-151]
[1-1000]
[0-2]

 Grid size
Module size * 10
0: dark-on-light
1: light-on-dark
2: either 		Set training parameters for Aztec symbology. Fixed-mount readers
SET|GET DATAMATRIX.DAMAGE damage level

 [2,4]
 2: moderate
4: extreme 		Set Extreme to enable PowerGrid. DM300 series readers, DM360, DM474 readers
SET|GET DATAMATRIX.QUALITY-METRICS type

 [0-3]

 0: none
1: AIM DPM
2: ISO 15415
3: SEMI T10 		Code quality metrics for DataMatrix. ALL
SET|GET DATAMATRIX.TRAINED-MODEL rows
columns
module-size
polarity

mirrored

 [8-144]
[8-144]
[1-1000]
[0-2]

[ON|OFF]
 Number of rows
Number of columns
Module size * 10
0: dark-on-light
1: light-on-dark
2: either
ON: mirrored
OFF: not mirrored 		Train Data Matrix from the given parameters without needing to capture an image. Fixed-mount readers
SET|GET DECODER.1D-DATA-STITCH state
 [ON|OFF] enable/disable Enables/disables 1D data-stitching.
Requires the 1DDataStitching feature key. 		DM70, DM150, DM260, DM300 series readers, DM474, DM503.
SET|GET DECODER.1D-EXTENDED-RESOLUTION state
 [ON|OFF] enable/disable Enables/disables the 1D extended resolution decoding method.
Requires the 1DExtendedRes feature key. 		DM70, DM150, DM260, DM300 series readers, DM474, DM503.
SET|GET DECODER.1D-LEARN-ORIENT state
 [ON|OFF] enable/disable Learn Orientation of 1D Symbols. Fixed mount readers.
SET|GET DECODER.1D-QUALITY-METRICS mode

 [0-1]
 0: none
1: 1D readability 		Enables/disables 1D Process Control Metrics. ALL
SET|GET DECODER.1D-SHORT-QUIET-ZONE state
 [ON|OFF] enable/disable When ON, the reader is tolerant with non-standard (i.e. short) quiet zones. ALL
SET|GET DECODER.1D-SYMBOL-ORIENTATION orientation

 [0-3]

 0: Omnidirectional
1: Ladder and Picket Fence (default)
2: Ladder
3: Picket Fence 		Sets or gets the orientation at which codes can be found. Omnidirectional requires the Omnidirectional feature key. DM50, DM60, DM70, DM474, DM503, MX-1000, MX-1502 and DM300 series readers. DM503L readers support only 2: Ladder and 3: Picket Fence.
SET|GET DECODER.1D-USAGE usage

 [0-1]
 0: Standard
1: Extended 		1D Symbology Usage Type. Fixed mount readers.
SET|GET DECODER.ALLOW-ALL-MST-RESULTS state

 [ON|OFF]
 ON: enable
OFF: disable 		Enables or disables re-read delay processing for slave results. DM300 series readers, DM474, DM503, DM70, DM150, DM260
SET|GET DECODER.CENTERING-WINDOW center x perc, center y perc, size x perc, size y perc
 [0-100] Percentage Location and size of centering window as a percentage of the sensor size. DM50, DM60, DM70, DM150 DM260, DM300, DM360, DM474, MX-1000 series
SET|GET DECODER.DISPLAY-TARGET state
 [ON|OFF] Enable/Disable Displays centering window graphics. DM50, DM60, DM70, DM150 DM260, DM300, DM360, DM474, MX-1000 series
SET|GET DECODER.EFFORT int
 [0-5] Sets the effort level used by the decoding algorithms. Default is 2. All
SET|GET DECODER.MAC-SCAN-TIMEOUT int
 [0-60] DM50, DM60, DM70, DM150 DM260, DM300, DM360, DM474, MX-1000, MX1502
SET|GET DECODER.REREAD-MODE mode

 [0-1]
 0: last read
1: first read 		Code re-reading delay relative to either the first read or the last. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET DECODER.REREAD-NEVER2X state
 [ON|OFF] enable/disable Never read the same code twice.
All trigger modes, e.g. Multicode Reading. 		ALL
SET|GET DECODER.REREAD-NOT-LAST-N int

 [0-100]
 0: no restriction
1-100 Define N 		Do not read code if this code was read within the last N reads. All
SET|GET DECODER.REREAD-TIME ms
 [0-10000] Milliseconds Code re-reading delay in milliseconds. ALL
SET|GET DECODER.ROI left (multiple of 8)
right (multiple of 8)
top (multiple of 4)
bottom (multiple of 4)
 [0...]
[left+64...]
[0...]
[top+64...] 		left of the ROI rectangle
right of the ROI rectangle
top of the ROI rectangle
bottom of the ROI rectangle 		Decoder Region of Interest.
Image Region examined by decoder for enabled symbols. Pixel coordinates are relative to the upper left corner of the displayed image. Left < Right and Top < Bottom.
Values must not be outside the specified CAMERA.FOV settings. 		ALL
SET|GET DECODER.TARGET-DECODING state
 [ON|OFF] enable/disable Enable target decoding, where the reader attempts to symbols that lie only under the aiming dots. MX-1000, MX-1502 series readers.
SET|GET DECODER.TIMEOUT ms
 [0-10000] milliseconds Decoder Timeout.
Maximum allowed decode time. 		Fixed mount readers.
SET|GET DECODER.USE-CENTERING state
 [ON|OFF] Enable/Disable Only reads codes within the centering window. DM50, DM60, DM70, DM150, DM260, DM300, DM360, DM474, MX-1000 series
SET|GET DOTCODE.MAXIMUM-COLUMNS int
 [11-128] The default is 128. DM300 series readers, DM474, DM8050X and DM8600.
SET|GET DOTCODE.MAXIMUM-ROWS int
 [5-128] The default is 32. DM300 series readers, DM474, DM8050X and DM8600.
SET|GET DOTCODE.MINIMUM-COLUMNS int
 [11-128] The default is 16. DM300 series readers, DM474, DM8050X and DM8600.
SET|GET DOTCODE.MINIMUM-ROWS int

 [5-128]
 The default is 6.
 DM300 series readers, DM474, DM8050X and DM8600.
SET|GET DOTCODE.POLARITY int

 [0-2]

 0: Dark on Light
1: Light on Dark
2: Either 		DM300 series readers, DM474, DM8050X and DM8600.
SET|GET FILTER.IMAGE-TO-USE-SYMBOL symbology

input

 [1-5]

[0-1]
 1: DataMatrix
2: QR Code/MaxiCode/AztecCode
3: Linear/ Postal/ Stacked
4: VeriCode®
5: DotCode
0: original image
1: filtered image 		Sets or gets which type of symbology should be filtered or not.
AztecCode is only supported on the DM503 and DM300 series readers. 		DM50, DM60, DM70, DM150, DM260, DM300 series readers, DM474.
SET|GET FILTER.NOREAD-IMAGE symbology

 [0-5]

 0: Any
1: DataMatrix
2: QR Code/MaxiCode/AztecCode
3: Linear/ Postal/ Stacked
4: VeriCode®
5: DotCode 		Sets or gets if the symbology selected should be filtered if the image is no-read.
AztecCode is only supported on the DM503 and DM300 series readers. 		DM50, DM60, DM70, DM150, DM260, DM300 series readers, DM474.
SET|GET FILTER.STACK step
method

value1 value2 value3
 [1-4]
[0-11]

[0-255] 		Filter step
0: no filtering
1: equalize
2: stretch
3: low pass
4: dilate
5: erode
6: open
7: close
8: auto stretch
9: optical density
10: invert
11: median
method parameter 		The first value sets the order of the filter steps. Filter step 1 is the first step, filter step 2 is the second, and so on. The second value sets the filter to be used. The third value means the additional properties that you can set for the given filter. You cannot configure the whole stack with one statement, but each on its own.The following example: SET FILTER.STACK 2 2 0 100 0 sets the second step in the filter, for stretch from 0 to 100, leaving the third value unused (0).The following example: GET FILTER.STACK 3 (for the third filter) returns 5 4 3 meaning that filter number 5, that is, erode is on, with parameters 4, 3. DM50, DM60, DM70, DM150, DM260, DM300 series readers, DM474.
SET|GET MAXICODE.TRAINED-MODEL module size
 [1-1000] Module size * 10 Set training parameters for MaxiCode symbology. Fixed-mount readers
SET|GET OUTPUT.DELAY-DISTANCE millimeters
 [0-100000] Distance to output when using the Encoder. DM474, DM503, and DM300 series readers.
SET|GET OUTPUT.DELAY-REFERENCE mode

 [0-1]
 0: Trigger Start
1: Trigger End 		Sets or gets whether output is delayed relative to trigger start or trigger end. DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET OUTPUT.DELAY-TIME milliseconds
 [0-10000] Output delay in milliseconds. DM50, DM60, DM70, DM503, DM300 series readers, DM474.
SET|GET OUTPUT.DELAY-TYPE mode

 [0-1]
 0: None
1: Time 		Sets or gets whether output is delayed, and if so, whether according to time. DM50, DM60, DM70, DM300 series readers, DM474.
SET|GET OUTPUT.DELAY-TYPE mode

 [0-2]

 0: None
1: Time
2: Distance 		Sets or gets whether output is delayed, and if so, whether according to time or distance. DM503
SET|GET PCM-RESULT-STRING.EXTEND enable
 [ON|OFF] Enable or disable extending the result string with metric information. Ethernet readers.
SET|GET PCM-RESULT-STRING.METRIC-FORMAT type

 [0-2]

 0: Grade
1: Value
2: Grade + Value 		Set the format of a single metric entry. Ethernet readers.
SET|GET PCM-RESULT-STRING.METRIC-PREFIX type

 [0-2]

 0: None
1: Acronym
2: Name 		Defines the prefix for a single metric entry. Ethernet readers.
SET|GET PCM-RESULT-STRING.METRIC-SEPARATOR string
 Defines the metric separator. Ethernet readers.
SET|GET PCM-RESULT-STRING.OVERALL-GRADE type
 [ON|OFF] enable Enables or disables showing the overall grade in at the beginning of the result string. Ethernet readers.
SET|GET PCM-RESULT-STRING.SEPARATOR string
 Defines the main separator between result data and metric section. Ethernet readers.
SET|GET PCM.CUSTOM-DESCRIPTION string
 Ethernet readers.
SET|GET PCM.METRIC-PARM-OVERALL type

type

state

 [0-5]

[0-27]

[ON|OFF]
 0: AIM-DPM
1: ISO-IEC 15415
2: ANSI-ISO-IEC 15416
3: SemiT10
4: 1D readability
5: DotCode Readybility
0: Symbol Contrast
1: Axial Non Uniformity
2: Print Growth
3: UEC
4: Modulation
5: Fixed Pattern Damage
6: Grid Non Uniformity
7: Extreme Reflectance
8: Reflect Min
9: Edge Contrast Min
10: Single Scan Int
11: Multi Scan Int
12: Signal To Noise Ratio
13: Horizontal Mark Growth
14: Vertical Mark Growth
15: Data Matrix Cell Width
16: Data Matrix Cell Height
17: Horizontal Mark Misplacement
18: Vertical Mark Misplacement
19: Cell Defects
20: Finder Pattern Defects
21: Overall Grade
22: Edge Determination
23: Defects
24: Reference Decode
25: Decodability
26: Contrast Uniformity
27: Reflectance Margin
ON: use for overall calculation
OFF: do not use for overall calculation 		Use the the metric grading result for calculating the overall result if enabled (e.g. AIM-DPM → Symbol Contrast → Use for Overall Calculation = ON) Not all metrics are available for each standard: AIM-DPM (0, 1, 2, 3, 4, 5, 6, 8), ISO-IEC 15415 (0, 1, 3, 4, 5, 6, 7), ANSI-ISO-IEC 15416 (1, 4, 8, 9, 22, 23, 24, 25), 1D readability (0, 2, 8, 9, 10, 11), DotCode (0, 1, 2, 3, 6, 8) Ethernet readers.
SET|GET PCM.METRIC-PARM-REPORT type

type

state

 [0-5]

[0-27]

[ON|OFF]
 0: AIM-DPM
1: ISO-IEC 15415
2: ANSI-ISO-IEC 15416
3: SemiT10
4: 1D readability
5: DotCode Readybility
0: Symbol Contrast
1: Axial Non Uniformity
2: Print Growth
3: UEC
4: Modulation
5: Fixed Pattern Damage
6: Grid Non Uniformity
7: Extreme Reflectance
8: Reflect Min
9: Edge Contrast Min
10: Single Scan Int
11: Multi Scan Int
12: Signal To Noise Ratio
13: Horizontal Mark Growth
14: Vertical Mark Growth
15: Data Matrix Cell Width
16: Data Matrix Cell Height
17: Horizontal Mark Misplacement
18: Vertical Mark Misplacement
19: Cell Defects
20: Finder Pattern Defects
21: Overall Grade
22: Edge Determination
23: Defects
24: Reference Decode
25: Decodability
26: Contrast Uniformity
27: Reflectance Margin
ON: include in report
OFF: do not include in report 		Include the metric grading result for selected quality standard and metric in the report if enabled. Only available if not use for overall calculation (e.g. ISO-IEC 15415 → Modulation → Show in Report = ON) Not all metrics are available for each standard: AIM-DPM (0, 1, 2, 3, 4, 5, 6, 8), ISO-IEC 15415 (0, 1, 2, 3, 4, 5, 6, 7), ANSI-ISO-IEC 15416 (0, 4, 8, 9, 22, 23, 24, 25), SemiT10 (1, 4, 12, 13, 14, 15, 16, 17, 18, 19, 20), 1D readability (0, 2, 8, 9, 10, 11), DotCode (0, 1, 2, 3, 6, 8). Ethernet readers.
SET|GET PCM.METRIC-PARM-THRESHOLD type

type

grade

value
 [0-5]

[0-25]

[1-4]

[0-1000] 		0: AIM-DPM
1: ISO-IEC 15415
2: ANSI-ISO-IEC 15416
3: SemiT10
4: 1D readability
5: DotCode Readybility
0: Symbol Contrast
1: Axial Non Uniformity
2: Print Growth
3: UEC
4: Modulation
5: Fixed Pattern Damage
6: Grid Non Uniformity
7: Extreme Reflectance
8: Reflect Min
9: Edge Contrast Min
10: Single Scan Int
11: Multi Scan Int
12: Signal To Noise Ratio
13: Horizontal Mark Growth
14: Vertical Mark Growth
15: Data Matrix Cell Width
16: Data Matrix Cell Height
17: Horizontal Mark Misplacement
18: Vertical Mark Misplacement
19: Cell Defects
20: Finder Pattern Defects
21: Overall Grade
22: Edge Determination
23: Defects
24: Reference Decode
25: Decodability
1: D
2: C
3: B
4: A Threshold raw value
 Set the raw value threshold for the selected quality standard, metric and grade (e.g. AIM-DPM → UEC → Threshold B = 50). Not all metrics are available for each standard: AIM-DPM (0, 1, 3, 4, 6, 8), ISO-IEC 15415 (0, 1, 3, 4, 6), ANSI-ISO-IEC 15416 (1, 4, 8, 9, 23, 25), 1D readability (0, 2, 8, 9, 11), DotCode (0, 1, 2, 3, 6, 8) Ethernet readers.
SET|GET PCM.MIN-PASS type

grade

 [0-5]

[0-4]

 0: AIM-DPM
1: ISO-IEC 15415
2: ANSI-ISO-IEC 15416
3: SemiT10
4: 1D readability
5: DotCode Readybility
0: F
1: D
2: C
3: B
4: A 		Set the overall minimum passing grade. Results under this grade will mean the reading failed. Ethernet readers.
SET|GET PCM.USE-CUSTOM-THRESHOLDS type

state

 [0-5]

[ON|OFF]
 0: AIM-DPM
1: ISO-IEC 15415
2: ANSI-ISO-IEC 15416
3: SemiT10
4: 1D readability
5: DotCode Readybility
ON: do regrading
OFF: keep current result 		Enable or disable regrading of metric results by using the custom thresholds. Ethernet readers.
SET|GET QR.QUALITY-METRICS type

 [0-2]

 0: none
1: ISO/IEC 15415
2: AIM-DPM / ISO/IEC TR 29158 		Code quality metrics for QR codes. ALL
SET|GET QR.TRAINED-MODEL grid size
module size
model

polarity

mirrored

 [11-177]
[1-1000]
[0-3]

[0-2]

[ON|OFF] [ON|OFF]
 Grid size
Module size * 10
0: Unknown model
1: Model-1
2: Model-2
3: Micro-QR
0: dark-on-light
1: light-on-dark
2: either
enable/disable ON: mirrored
OFF: not mirrored 		Set training parameters for QR-Code symbology.
Option 3 for argument "model": Micro-QR is not applicable for 6.0.1. 		Fixed-mount readers
GET | TRUCHECK.AG | Returns the AG (average grade) score from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.AG-GRADE | Returns the AG (average grade) grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.ANU | Returns the ANU (axial non-uniformity) score from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.ANU-GRADE | Returns the ANU (axial non-uniformity) grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.DECODE-GRADE | Returns the DECODE grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.FPD | Returns the FPD (fixed pattern damage) score from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.FPD-GRADE | Returns the FPD (fixed pattern damage) grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.GNU | Returns the GNU (grid non-uniformity) score from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.GNU-GRADE | Returns the GNU (grid non-uniformity) grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.MOD-GRADE | Returns the MOD (modulation) grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.RM-GRADE | Returns the RM grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.SC | Returns the SC (symbol contrast) score from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.SC-GRADE | Returns the SC (symbol contrast) grade from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.UEC | Returns the UEC (unused error correction) score from the last verification attempt. | DM8072 Verifier
GET | TRUCHECK.UEC-GRADE | Returns the UEC (unused error correction) grade from the last verification attempt. | DM8072 Verifier

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - I/O Commands

I/O Commands

SET|GET BEEP.DATAVALID-FAIL repetition
level

 [0-3]
[0-2]

 number of beeps
0: Lo pitch
1: Med pitch
2: Hi pitch 		Data Validation Failure Beep Settings. ALL except for DM50, DM60 and DM70.
SET|GET BEEP.DATAVALID-FAIL-OL repetition
level

 [0-3]
[0-2]

 number of beeps
0: Lo pitch
1: Med pitch
2: Hi pitch 		Data Validation Failure Beep Settings when offline. Wireless readers.
SET|GET BEEP.GOOD repetition
level

 [0-3]
[0-2]

 number of beeps
0: Lo pitch
1: Med pitch
2: Hi pitch 		Good Read Beep Settings. ALL except for DM50, DM60 and DM70.
SET|GET BEEP.GOOD-OL repetition
level

 [0-3]
[0-2]

 number of beeps
0: Lo pitch
1: Med pitch
2: Hi pitch 		Good Read Beep Settings when offline. Wireless readers.
SET|GET BEEP.NO-READ repetition
level

 [0-3]
[0-2]

 number of beeps
0: Lo pitch
1: Med pitch
2: Hi pitch 		No-Read Beep Settings. ALL except for DM50, DM60 and DM70.
SET|GET BEEP.NO-READ-OL repetition
level

 [0-3]
[0-2]

 number of beeps
0: Lo pitch
1: Med pitch
2: Hi pitch 		No-Read Beep Settings when offline. Wireless readers.
SET|GET BEEPER.ENABLED state
 [ON|OFF] Enable/disable beeper in general. All
SET|GET BUTTON.3SEC-ACTION mode

state
 [0-6]

[ON|OFF] 		0: Train
1: Optimize Brighness
2: Set Match String
3: Optimize Focus
4: Read Configuration Code
5: Tune
6: Toggle Test Mode
enable/disable 		Three Second Button Action. Fixed mount readers. Test Mode is only supported on the DM503, DM300 series readers and DM474.
SET|GET BUTTON.ACTION button
action

 [0-2]
[0-1]
 Index of button (0:Left;1:Right;2:Grip)
0: disabled
1: trigger 		Sets and gets the assigned feature for hardware buttons. MX-1000
SET|GET BUTTON.ENABLE state
 [ON|OFF] enable/disable Enables or disables the trigger button. Fixed mount readers.
SET|GET ENCODER.COUNT value
 [0-2 billion] value to set Gets the encoder count or sets it to the specified value. Fixed-mount readers
SET|GET ENCODER.DISTANCE-TO-OUTPUT int

 0-1000000 mm

 Default: 0
Min: 0
Max: 1000000
Step: 1 		Sets the output distance from the trigger on the sensor. DM300 series readers, DM474.
SET|GET ENCODER.DOUBLE-RATE boolean
 [ON|OFF] Edge detection If set to ON, Encoder will count both edges on the Encoder Input line. If set to OFF, Encoder will count only the selected edge. DM503
SET|GET ENCODER.DOUBLE-RATE boolean
 [ON|OFF] Edge detection If set to ON, Encoder will count both edges on the Encoder Input line. If set to OFF, Encoder will count only the selected edge. DM360, DM370, and DM470 series readers.
ENCODER.FLUSH | Flushes all encoder actions. | DM474, DM503 and DM300 series readers.
SET|GET ENCODER.MODE value

 [0-4]

 0: Encoder A signal counts up, Encoder B signal counts down.
1: Encoder A signal counts up, Encoder B signal counts down.
2: Encoder A and Encoder B form quadrature (SIN/COS) signal, 1 count per cycle.
3: Encoder A and Encoder B form quadrature (SIN/COS) signal, 2 counts per cycle.
4: Encoder A and Encoder B form quadrature (SIN/COS) signal, 4 counts per cycle. 		Encoder mode. Sets the mode the encoder signals are interpreted if the Encoder Direction pin is defined. Fixed-mount readers
ENCODER.RESET
Resets the encoder count to 0 and clears all encoder related events. Fixed-mount readers
SET|GET ENCODER.RESOLUTION int

 0-1000000 um

 Default: 5000
Min: 0
Max: 1000000
Step: 1 		Sets the distance per pulse of the encoder. DM474, DM503, and DM300 series readers.
SET|GET INPUT.ACTION line
action

state

 [0-3]
[0-11]

[ON|OFF]
 Input line number
0: Train Code
1: Optimize Brightness
2: Set Match String
3: Optimize Focus
4: Read Configuration Code
5: Trigger Off
6: Encoder
7: Allow Buffered No-Read Images
8: Clear Outputs
9: Tune (DM300 only)
10: Encoder direction
11: Trigger on
ON: execute action when line is triggered
OFF: no action 		Sets or gets the state for the specified line action.
The input actions "Train Code," "Optimize Brightness," "Set Match String," and "Read Configuration Code" are carried out only after the next trigger. 		Fixed-mount readers.
SET|GET INPUT.ACTION1 mode

state
 [0-3]

[ON|OFF] 		0: Train Code
1: Optimize Brighness
2: Set Match String
3: Optimize focus (Only for readers with a liquid lens.)
enable/disable 		Input Line 1 Action. Fixed mount readers.
SET|GET IO-LINE.DIRECTION line

direction

 [2,3]

[0,1]
 line=2: sets direction of I/O Line 2
line=3: sets direction of I/O Line 3
direction=0: defines line as output
direction=1: defines line as input 		Sets the direction of the programmable I/O lines of DM360 and DM474 series readers. DM360 series, DM474 readers
SET|GET KEY.LANGUAGE language

 [0-7]

 0: Alt Key Combo
1: DE
2: US
3: JP
4: FR
5: ES
6: NO
7: FI 		ALL except for DM60, DM474, DM503, and DM300 series readers.
SET|GET KEY.ZERO-PAD language
 [ON|OFF] enable/disable ALL except for DM60, DM474, DM503, and DM300 series readers.
SET|GET LIGHTCURTAIN.BEAM-SPACING spacing
 [1-300000] micrometers Distance (in um) between beams of the Light Curtain. This determines the resolution of the light curtain. DM503
SET|GET LIGHTRING.DURATION duration

 [0..10000]
 0: Default behavior
10..10000: duration of lightring event in ms, step 10 ms 		Controls the duration of the lightring illumination event. DM36x, DM474 and DM503
OUTPUT-QUEUE.FLUSH int

 [0-1]
 0: throw output away
1: send all output now 		To flush or send all output. DM474, DM503, and DM300 series readers.
SET|GET
Technology Preview 		OUTPUT.ACTION line
action

 [0-7]
[0-1]
 line number
0: Open
1: Close 		Output Action.
Open or Close output line on event. Only supported on line 1. 		Fixed mount readers.
SET|GET
Technology Preview 		OUTPUT.EVENTS line
read

no-read

validation-failure

trigger-overrun

buffer-overflow

user event 1

user event 2

 [0-7]
[0-1]

[0-1]

[0-1]

[0-1]

[0-1]

[0-1]

[0-1]
 i/o line number
0: Off
1: On
0: Off
1: On
0: Off
1: On
0: Off
1: On
0: Off
1: On
0: Off
1: On
0: Off
1: On 		Output Events.
Configure output line to signal based on event. 		Fixed mount readers.
SET|GET OUTPUT.PULSE-WIDTH line
ms
 [0-7]
[0-30000] 		i/o line number
milliseconds 		Output Pulse-width. Fixed mount readers.
SET|GET OUTPUT.RESERVED line
reserved
 [0-7]
[ON|OFF] 		i/o line number
enable/disable 		Output Reserved for External Illumination. Line will be controlled by acquisition system when enabled. Fixed mount readers, except DM50, DM60 and DM70.
SET|GET RESULT.NO-READ-STRING string
 no-read-string No-Read Output String. ALL
SET|GET TRIGGER.DEBOUNCE-DELAY delay

 [0-6]

 0: short
1:
2: default
3:
4:
5:
6: long 		Sets or gets how long the trigger signal must be detected in order to be recognized as valid. Fixed-mount readers.
SET|GET TRIGGER.END-HOLDOFF-DISTANCE distance
 [0-10000 mm] distance for hold-off at trigger end When greater than 0, the distance with which to cancel a pending trigger off and allow the trigger to continue. DM474, DM503 and DM300 series readers.
SET|GET TRIGGER.END-HOLDOFF-TIME rime
 [0-10000 ms] time for hold-off at trigger end When greater than 0, the time with which to cancel a pending trigger off and allow the trigger to continue. Fixed-mount readers
SET|GET TRIGGER.HOLDOFF-DISTANCE distance
 [0-10000 mm] distance for hold-off at trigger start When greater than 0, the distance with which to cancel a pending trigger on and act like there was no trigger at all. DM474, DM503 and DM300 series readers.
SET|GET TRIGGER.HOLDOFF-TIME time
 [0-10000 ms] time for hold-off at trigger start When greater than 0, the time with which to cancel a pending trigger on and act like there was no trigger at all. Fixed-mount readers
SET|GET TRIGGER.HOLDOFF-TYPE type

 [0-2]

 0 = None
1 = Time
2 = Distance 		Which type of trigger hold-off to use, none, time or distance. Fixed-mount readers
SET|GET TRIGGER.POLARITY line
polarity

 [0-3]
[ON|OFF]
 Input line
ON: Rising edge
OFF: Falling edge 		Sets or gets the polarity at which an input will be triggered. Fixed mount readers.
SET|GET TUNE-BUTTON.ENABLE state
 [ON|OFF] enable/disable Enables or disables the tune button. DM474, DM503, and DM300 series readers.

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Light & Imager Commands

Light & Imager Commands

Set/Get Command Arguments Range Meaning Description Support
SET|GET CAMERA.AUTO-REGULATION auto

 [ON|OFF]
 ON: Automatic
OFF: Manual 		Camera Parameters where exposure is in microseconds. DM50, DM60, DM70, DM150, DM260, DM300 series readers, DM360 series readers, DM474, DM503, DM8600
SET|GET CAMERA.BURST-LENGTH count
 [2-*] number-images Burst Length.
Number of Acquired Images in Burst Trigger-Mode.
Actual maximum can be increased by reducing the camera field of view or reserving fewer images for Process Monitor/Record and Playback. 		Fixed mount readers.
SET|GET CAMERA.EXPOSURE auto

target
exposure

gain
 [ON|OFF]

[0-255]
[0-22]

[4-60] 		ON: Automatic
OFF: Manual
target pixel value
0: 1/10000
1: 1/7500
2: 1/5000
3: 1/4000
4: 1/3000
5: 1/2500
6: 1/2000
7: 1/1500
8: 1/1250
9: 1/1000
10: 1/750
11: 1/500
12: 1/300
13: 1/250
14: 1/200
15: 1/150
16: 1/125
17: 1/100
18: 1/75
19: 1/50
20: 1/40
21: 1/30000
22: 1/15000
camera gain 		Camera Parameters. The arguments 'exposure' and 'gain' have no effect if 'auto' is ON and the 'target' has no effect if 'auto' is OFF. DM700.
SET|GET CAMERA.EXPOSURE exposure
 [18-25000] exposure Camera Parameters where exposure is in microseconds. DM50, DM60, DM70, DM150, and DM260
SET|GET CAMERA.EXPOSURE exposure

 [5-1000]

[12-1000]

[5-100000]

 DM300 and DM302 internal illumination
DM303 internal illumination
with external or no illumination 		Camera Parameters where exposure is in microseconds. DM300 series readers, DM360 series readers, DM474, DM8600.
SET|GET CAMERA.EXPOSURE exposure
 [12-100000] exposure independent of illumination Camera Parameters where exposure is in microseconds. DM503
GET CAMERA.EXPOSURE-LIMIT-US exposure
 maximum value allowed for SET CAMERA.EXPOSURE-US Get the maximum allowed exposure limited by current settings in us. Fixed Mount readers.
SET|GET CAMERA.EXPOSURE-US auto

target
exposure
gain
 [ON|OFF]

[0-255]
[18-25000]
[0-60] 		ON: Automatic
OFF: Manual
target pixel value
exposure
camera gain 		Camera Parameters where exposure is in microseconds. The argument 'exposure' and 'gain' has no effect if 'auto' is ON and 'target' has no effect at all. DM50, DM60, DM70, DM150, DM260
SET|GET CAMERA.EXPOSURE-US auto

target
exposure

gain
 [ON|OFF]

[0-255]
[5-1000]

[12-1000]

[5-100000]

[0-106] 		ON: Automatic
OFF: Manual
target pixel value
DM300 and DM302 internal illumination
DM303 internal illumination
with external or no illumination
camera gain 		Camera Parameters where exposure is in microseconds. The argument 'exposure' and 'gain' has no effect if 'auto' is ON and 'target' has no effect at all. DM300 series readers, DM360 series readers, DM474, DM8600.
SET|GET CAMERA.EXPOSURE-US auto

target
exposure
gain
 [ON|OFF]

[0-255]
[12-100000]
[0-41] 		ON: Automatic
OFF: Manual
target pixel value
exposure independent of illumination
camera gain 		Camera Parameters where exposure is in microseconds. The argument 'exposure' and 'gain' has no effect if 'auto' is ON and 'target' has no effect at all. DM503
SET|GET CAMERA.EXPOSURE-US auto

target
exposure
gain
 [ON|OFF]

[0-255]
[50-25000]
[0-60] 		ON: Automatic
OFF: Manual
target pixel value

camera gain 		Camera Parameters where exposure is in microseconds. The argument 'exposure' and 'gain' has no effect if 'auto' is ON and 'target' has no effect at all. MX-1000 and DM8000 series readers.
SET|GET
Technology Preview 		CAMERA.FOV left (multiple of 8)
right (multiple of 8)
top (multiple of 4)
bottom (multiple of 4)
 [0...]
[left+64...]
[0...]
[top+64...] 		pixels from left
pixels from right
pixels from top
pixels from bottom 		The camera field of view is the area of the camera used for image acquisition. ALL
SET|GET CAMERA.FOV-ENABLED state
 [ON|OFF] enable/disable Indicates whether the full FoV or a custom FoV will be used for image acquisition.
You can change this value only for the following trigger types: single, burst, and continuous. 		ALL
SET|GET CAMERA.FULL-BLACK-LEVEL-CORRECTION state
 [ON|OFF] enable/disable Enables Full black level correction. DM300 series readers, DM474.
SET|GET CAMERA.GAIN gain
 [1.00-31.76] The gain has no effect if the camera runs with automatic exposure DM300 series readers, DM474.
SET|GET CAMERA.GAIN gain
 [1.00-13.88] The gain has no effect if the camera runs with automatic exposure DM503
SET|GET CAMERA.GAIN gain
 [1.00-15.00] The gain has no effect if the camera runs with automatic exposure DM50, DM60, DM70
SET|GET CAMERA.GAIN-LIMIT gain
 [1.00-max_gain] 1.00-max_gain: The maximum gain to use Controls the maximum gain the tuning and auto-regulation process uses to find the best reader settings. Useful to limit noise in Images. Fixed mount readers.
SET|GET CAMERA.HDR-MODE mode

 [0-2]

 0: Off
1: Global
2: Local 		HDR mode DM470 series readers.
SET|GET CAMERA.HDR-MODE mode

 [0-1]
 0: Off
1: Global 		HDR mode DM370 series readers.
SET|GET CAMERA.INTERVAL-US us

 [*-1000000]

 Microseconds. Step size is 250.

* By default the minimum range is 6000 but this can change depending on decode timeout and field of view. 		Acquisition Interval, the time between successive camera acquisitions in microseconds. Supported with Burst, Self, and Continuous trigger types. DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET CAMERA.MAX-EXPOSURE-US exposure

 [1-50]
[1-410]
[1-100000] 		with HPIA
without HPIA
with external or no illumination 		Maximum exposure limit in microseconds for autoregulation.
HPIA = High Powered Illumination Accessory. 		DM70, DM150, DM260, DM474, DM503, and DM300 series readers.
SET|GET CAMERA.MAX-EXPOSURE-US exposure
 [18-25000] Maximum exposure limit in microseconds for autoregulation. DM50, DM60, DM70.
SET|GET CAMERA.MIRROR-HORIZONTAL state
 [ON|OFF] enable/disable Mirror acquired image over the vertical axis. DM474, DM503 and DM300 series readers.
SET|GET CAMERA.MIRROR-VERTICAL state
 [ON|OFF] enable/disable Mirror acquired image over the horizontal axis. DM70, DM260, DM474, DM503 and DM300 series readers.
SET|GET CAMERA.TARGET-BRIGHTNESS target
 [0-255] target pixel value Camera Parameters where exposure is in microseconds. All, except MX series readers.
SET|GET CAMERA.XPAND-ROI ROI index
left
right
top
bottom
 [1-2]
[0 - sensor width]
[0 - sensor width]
[0 - sensor height]
[0 - sensor height] 		ROI index
pixels from left
pixels from right
pixels from top
pixels from bottom 		Specifies custom FOVE regions.
Requires the 1DDataStitching feature key. 		DM70, DM150, DM260, DM300 series readers, DM474, DM503.
SET|GET CAMERA.XPAND-ROI-TYPE int

 [0-3]

 0: None
1: Xpand-15
2: Xpand-25
3: Custom 		Indicates the used FOVE type.
Requires the 1DDataStitching feature key. 		DM70, DM150, DM260, DM300 series readers, DM474, DM503.
SET|GET FOCUS.DISTANCE int
 Distance in mm from the front of the camera to the part.
This command returns the value only if Focus Steps is set to 0, otherwise you need to use FOCUS.SWEEP-RANGE instead. 		DM300 series readers, DM474.
GET FOCUS.EXTENDED-RANGE value
 [ON|OFF] Extended Focus Range Indicates that the reader operates in the extended focus range of ON. In this mode GET FOCUS.DISTANCE will return with an error. Fixed-mount readers with Liquid Lens
SET|GET FOCUS.FEEDBACK state
 [ON|OFF] enable/disable Enables focus feedback. DM474, DM503 and DM300 series readers.
SET|GET FOCUS.POWER optical power
 [-6.0 .. 20.00] Optical Power in Diopters Conrols the optical power of the liquid lens. The actual range is dependent on the hardware and on manufacturing tolerances. Fixed-mount readers with Liquid Lens
SET|GET FOCUS.PRECISION settle mode

 [0..1]
 0: normal focus control
1: precise focus control 		Controls the liquid lens focus control between normal focus control and slow but more precise mode. Fixed mount readers with a liquid lens.
SET|GET FOCUS.PROGRESS enable

 [ON|OFF]
 ON: focus progress on
OFF: focus progress off 		Enable transfer of intermittent focus images during adjust focus. Fixed mount readers with a liquid lens.
SET|GET FOCUS.SWEEP-POWER Optical Power for near distance
Optical Power for far distance
 liquid lens specific
liquid lens specific 		Optical Power in Diopters
Optical Power in Diopters 		Returns near (first value) and far (second value) optical power values. Readers with Liquid Lens.
SET|GET FOCUS.SWEEP-RANGE DM8000

DM300

 [0-500]
[0-500]

[40-500]
[40-500]
 low sweep range
high sweep range
low sweep range
high sweep range 		Defines the sweep range to be used for focusing. Low must be less than high. The low value is ignored if FOCUS.SWEEP-STEPS is set to 0. DM70, DM260, DM300 series, DM474 and DM8000 series readers.
SET|GET FOCUS.SWEEP-STEPS value
 [0-8] number of steps to divide the sweep range Sets the number of steps the sweep range should be divided by. If steps is set to 0 only the high sweep range value is used. DM70, DM260, DM474, DM8000 series and DM300 series readers.
GET HEIGHT-SENSOR.CURRENT-MEASUREMENT
[0-4000] Distance from the C-Mount Flange in mm Returns the read out of the ToF range distance in mm. DM370 series, DM470 series readers.
SET|GET IMAGE.FORMAT format

 [0-2]

 0: Bitmap
1: JPEG
2: PNG 		Image File Format. ALL
SET|GET IMAGE.QUALITY quality
 [10, 15, 20... 85, 90] JPEG Quality Quality of the jpeg image. ALL
SET|GET IMAGE.SIZE size

 [0-3]

 0: Full
1: 1/4
2: 1/16
3: 1/64 		Image Size. ALL
SET|GET LIGHT.AIMER aimer-mode

 [0-1]
 0: Off
1: On 		Aimer Enable.
Default is ON. 		ALL except for DM503 and DM8050.
SET|GET LIGHT.AIMER aimer-mode

 [0,1,3]

 0: Off
1: On
3: Activated by Acceleration Sensor 		Aimer Enable.
Default is ON. 		DM8050
SET|GET LIGHT.AIMER aimer-mode

 [0-1]
 0: Off
1: On 		Enables or disables the aimer. DM370 series, DM470 readers.
SET|GET LIGHT.AIMER-TIMEOUT int
 [0-600] seconds Aimer Timeout in seconds. MX-1000 and DM8000 series readers.
SET|GET LIGHT.DARKFIELD-INTENSITY value
 [0-15] Intensity Darkfield Illumination Intensity. DM8600
SET|GET LIGHT.DIFFUSE-INTENSITY level
 [0-15] Intensity Diffuse Brightfield Illumination Intensity. DM8600
SET|GET LIGHT.DIRECT north
east
south
west
NORTH
EAST
SOUTH
WEST
 [ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF] 		enable/disable
enable/disable
enable/disable
enable/disable
enable/disable
enable/disable
enable/disable
enable/disable 		Sets the quadrants on the DM300. Small letters refer to the inner, capital letters to the outer circle, possible values are ON and OFF for each segment. Example for a SET command: SET LIGHT.DIRECT ON OFF ON ON OFF OFF OFF OFF if you want to have the inner north, south, and west lights on. DM300 series readers, DM474.
SET|GET LIGHT.DIRECT north-east
north-west
south-east
south-west
 [ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF] 		enable/disable
enable/disable
enable/disable
enable/disable 		Sets the quadrants on the DM70, DM150 and DM260. Possible values are ON and OFF for each segment. Example for a SET command: SET LIGHT.DIRECT ON OFF OFF ON if you want to have the top-left and bottom-right LED on. DM70, DM150 and DM260 readers.
SET|GET LIGHT.DIRECT state
 [ON|OFF] enable/disable Turns on/off light banks for the 8072V. Verification should only take place with lighting combinations that can be described as 30 single, 30T (opposite sides), 30Q (all 30 panels), 45Q (all 45 panels), or 90. Other lighting combinations are allowed by the firmware, but will not result in valid verification result. DM8072 Verifier
SET|GET LIGHT.DIRECT North
Corners
South
East-West
 [ON|OFF]
[ON|OFF]
[ON|OFF]
[ON|OFF] 		enable/disable
enable/disable
enable/disable
enable/disable 		Enables or disables the HPIT quadrants. DM370 series, DM470 series readers.
SET|GET LIGHT.DIRECT-INTENSITY level
 [0-15] Intensity Direct Illumination Intensity. DM50, DM60, DM474, DM503 and DM300 series readers.
SET|GET LIGHT.DIRECT-INTENSITY level
 [1-15] Intensity Direct Illumination Intensity. DM8050
SET|GET LIGHT.EXTERNAL-ENABLE enable
 [ON|OFF] enable/disable Enable external illumination supported by I/O. Fixed mount readers.
SET|GET LIGHT.EXTERNAL-INTENSITY level
 [0-15] Intensity Sets the intensity of the external illumination. Fixed mount readers.
SET|GET LIGHT.EXTERNAL-POLARITY polarity

 [0-1]
 0: Active Low
1: Active High 		External illlumination output polarity. Fixed mount readers except for DM70, DM150, DM260.
SET|GET
Technology Preview 		LIGHT.EXTERNAL-PRECHARGE-TIME time
 [1-980] microseconds External light precharge time. Fixed mount readers.
SET|GET LIGHT.HIGH-FREQUENCY enable
 [ON|OFF] enable/disable Enables High Frequency Lights to avoid flickering illumination. DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET LIGHT.HIGH-FREQUENCY-ALWAYS enable
seconds
 [ON|OFF]
0-86400 		enable/disable
auto off duration 		Enables High Frequency Light in Continuous trigger mode even if no trigger is active. After duration seconds the High Frequency Light is turned off. If the duration is 0 the light is never turned off. DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET LIGHT.INTERNAL-ENABLE enable
 [ON|OFF] enable/disable Enable the built-in internal illumination. Default value is OFF. DM50, DM60, DM70, DM8050, MX-1000, MX-1502, Mobile.
SET|GET LIGHT.LOW-ANGLE state
 [ON|OFF] [ON|OFF] enable/disable low-angle illumination Controls the DM262 UHD low-angle illumination. DM262
SET|GET LIGHT.ON-AXIS state
 [ON|OFF] [ON|OFF] enable/disable on-axis illumination Controls the DM262 UHD on-axis illumination. DM262
SET|GET LIGHT.POLARIZED polarized LED count
 [0|2|4] Number of polarized filtered LEDs in the illumination Use this command after applying a different HPIL front cover to publish the illumination filter status to the device. DM70, DM150, DM260
SET|GET LIVEIMG.MODE mode

 [0,2]
 0: Disable
2: Enable 		Controls live image display. ALL
LIVEIMG.SEND size

format

quality
 [0-3]

[0-2]

[10, 15, 20... 85, 90] 		0: Full
1: 1/4
2: 1/16
3: 1/64
0: Bitmap
1: JPEG
2: PNG
JPEG Quality 		Request image transfer to PC when LIVEIMG.MODE is set to 3.
SET|GET MASTER-SLAVE.RX-HEIGHT-SENSOR enable
 [ON|OFF]* enable/disable Enables or disables this system receiving height information from another system in the network group. DM60, DM474 and DM300 series readers.
SET|GET MONITOR-MODE.AUTOEXPOSURE state
 [ON|OFF] enable/disable Enable/disable autoregulation while in monitor mode. ALL
SET|GET MONITOR-MODE.DECODE-ENABLE mode
 [ON|OFF] enable/disable ALL
SET|GET MONITOR-MODE.ENABLE state
 [ON|OFF] enable/disable Enable/disable monitor mode. ALL
SET|GET SETUP.ENABLE state
 [ON|OFF] enable/disable Setup Enable.
One Setup must always be enabled. Enable the desired Setup, before disabiling another Setup. For DM300 series readers, this command works for the active setup. 		DM50, DM60, DM70, DM150, DM260, DM474, DM503, DM8600, MX-1000 and DM300 series readers.
SET|GET SETUP.NAME name
 Setup Name.
User defined name. 		DM50, DM60, DM70, DM150, DM260, DM474, DM503, DM8600, MX-1000, and DM300 series readers.
SET|GET SETUP.PROG-TARGET category

 [0-3]

 0: General Purpose
1: Curved Surface
2: Under Marked
3: Mirrored Surface 		Setup Programming Target.
Setup to be modified by subsequent commands. 		DM70, DM150, DM260, DM8600 and MX-1000
SET|GET SETUP.PROG-TARGET category
 [0-15] A number signifying an already existing setup. Setup Programming Target.
Setup to be modified by subsequent commands. 		DM50, DM60, DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET SETUP.START-WITH-LAST-READ mode

 [ON|OFF] enable/disable OFF: Start with fixed setup
ON: Start with setup of last good read 		Sets read setup. DM8600, DM70, DM150, DM260, DM474, DM503, MX-1000, MX-1502 and DM300 series readers.
SET|GET SETUP.START-WITH-SETUP setup
 [0-15] setup number to start with Starts read setup. DM8600, DM70, DM150, DM260, DM474, DM503, MX-1000, MX-1502 and DM300 series readers.
SETUP.USE int
state
 [1-15]
[ON|OFF] 		Setup to change
enable/disable Disables/Enables setup to be used. 		Adds or removes a setup from the list of usable Read Setups. DM8600, DM70, DM150, DM260, DM474, DM503 and DM300 series readers.
SET|GET TRIGGER.DELAY-DISTANCE millimeter
 [0-2147483646] Delay camera acquisition by distance specified in millimeters. DM503, DM474 and DM300 series readers.
SET|GET TRIGGER.DELAY-TIME milliseconds
 [0-10000] Trigger delay in milliseconds.
Delay camera acquisition by specified number of milliseconds. 		DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET TRIGGER.DELAY-TYPE mode

 [0-1]
 0: none
1: time 		Sets or gets whether trigger delay is according to time. DM50, DM60 and DM70
SET|GET TRIGGER.DELAY-TYPE mode

 [0-2]

 0: none
1: time
2: distance 		Sets or gets whether trigger delay is according to time or distance. DM503, DM474 and DM300 series readers.
SET|GET TRIGGER.END-DELAY-DISTANCE millimeters
 [0-2147483646] Sets or gets trigger end delay distance. DM474, DM503 and DM300 series readers.
SET|GET TRIGGER.END-DELAY-TIME milliseconds
 [0-10000] Sets or gets trigger end delay time. DM50, DM60, DM70, DM474, DM503, and DM300 series readers.
SET|GET TRIGGER.TYPE type

 [0-5]

 0: Single (external)
1: Presentation (internal)
2: Manual (button)
3: Burst (external)
4: Self (internal)
5: Continuous (external) 		Trigger Type. The camera API should return the current trigger type value. DM700 and DM8000 series readers support only Presentation and Manual trigger types. MX-1000, MX-1502 and Mobile support only Manual and Continuous trigger types.
SET|GET TUNE.ADJUST-FOCUS state
 [ON|OFF] Enables or disables using adjusting focus while tuning. DM70, DM150, DM260, DM474 and DM300 series readers with liquid lens.
SET|GET TUNE.EXCLUDE-AMBIENT-RESULTS disable ambient

 [ON|OFF]
 ON: Disables the automatic selection of ambient light results
OFF: Allows ambient light results for atomatic seletion 		Control the automatic selection of tuning results where the prevailing illumination type is ambient light. Fixed mount readers.
SET|GET TUNE.TRAIN-CODE state
 [ON|OFF] Enables or disables code training while tuning. DM300 series readers, DM474, DM70, DM260, and DM150.
SET|GET TUNE.TUNE-LIGHT-BANKS state
 [ON|OFF] Enables or disables using light banks while tuning.
Only available when internal illumination is used. 		DM300 series readers, DM474, DM260, DM70 and DM150.
SET|GET TUNE.TUNE-LIGHT-COMBINATIONS mode
 [ON|OFF] If it is ON, light combinations will always be tuned. DM300 series readers, DM474, DM260, DM70 and DM150.

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Record & Playback Commands

Record & Playback Commands

SET|GET IMAGEBUFFER.ALLOW-OVERWRITE state
 [ON|OFF] enable/disable Allow buffered images that have not been transfered to be overwritten if all available buffers are used and new images arrive. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.AUTO-PREFER-CENTER
Controls whether to use the decoders best symbol or the symbol closer to the ROI center. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
IMAGEBUFFER.DELETE | Release stored images. | DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.DELETE-AFTER-TRANSFER state
 [ON|OFF] enable/disable Release stored images automatically after image has been transfered. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.FORMAT format

 [0-2]

 0: Bitmap
1: JPEG
2: PNG 		DM50, DM60, DM70, DM474, DM503, MX-1000, DM8000 series and DM300 series readers.
SET|GET IMAGEBUFFER.GOOD-IMAGE-MODE mode

 [0-1]
 0: Unlimited
1: Rate limited 		Good Read Image stores all buffered good read images unless you set a limit rate. DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.GOOD-IMAGE-RATE-BURST interval
 [1-1000] Burst determines the peak rate of the number of good read images buffered. DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.GOOD-IMAGE-RATE-COUNT interval
 Number of good read images to be buffered at a time unit (for example, minutes or hours) specified with IMAGEBUFFER.GOOD-IMAGE-RATE-COUNT. DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.GOOD-IMAGE-RATE-TIME type

 [0-3]

 0: seconds
1: minutes
2: hours
3: days 		Time unit of good read images to be buffered at a rate number specified with IMAGEBUFFER.GOOD-IMAGE-RATE-TIME. DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.IMAGE-TYPE int

 [0-2]

 0: All
1: Same as result
2: Auto 		Sets "What images to Buffer for a Result". When "Auto" is selected, the reader does intelligent image buffering.
Requires the IntImageBuffer feature key to select the "Auto" option. 		DM70, DM150, DM260, DM300 series readers, DM474, DM503.
SET|GET IMAGEBUFFER.MAX-IMAGES-PER-RESULT size
 [0-*] Sets or gets how many images (n) per result are stored. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.MAX-NUM size
 [0-*] Maximum number of images that can be buffered.
* Range varies depending depending on Camera ROI and memory allocated for burst length. 		DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.NO-READ-IMAGE-NUMBER limit

 [n]
[Max Int]
 In Burst trigger mode, n is the number of images in a burst
In other trigger modes, there is no limit 		Store exactly one image. DM50, DM60, DM70, DM474, DM503, DM300 series readers, only in Single, Burst, Self and Continuous modes.
SET|GET IMAGEBUFFER.NO-READ-IMAGE-PERIOD interval
 [1-200] Sets or gets the interval to save the image of a bad read. If, for example, you use an interval of 6, the first bad image is saved and the next 5 are not. The default is 1 which saves each bad read image. DM50, DM60, DM70, DM474, DM503, DM300 series readers, only in Single, Burst, Self and Continuous modes.
SET|GET IMAGEBUFFER.NO-READ-IMAGE-RATE-BURST interval
 [1-1000] Burst determines the peak rate of the number of bad read images buffered. DM474, DM503, DM300 series readers, only in Single, Burst, Self and Continuous modes.
SET|GET IMAGEBUFFER.NO-READ-IMAGE-RATE-COUNT interval
 Number of bad read images to be buffered at a time unit (for example, minutes or hours) specified with IMAGEBUFFER.NO-READ-IMAGE-RATE-COUNT. DM503, DM300 series readers, only in Single, Burst, Self and Continuous modes.
SET|GET IMAGEBUFFER.NO-READ-IMAGE-RATE-TIME type

 [0-3]

 0: seconds
1: minutes
2: hours
3: days 		Time unit of bad read images to be buffered at a rate number specified with IMAGEBUFFER.NO-READ-IMAGE-RATE-TIME. DM474, DM503, DM300 series readers, only in Single, Burst, Self and Continuous modes.
GET IMAGEBUFFER.NUM size
 Returns the number of currently buffered images. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.OVERLAY state
 [ON|OFF] enable/disable Enables Overlay Graphics (SVG) for buffered images. DM50, DM60, DM70, DM474, DM503, DM300 series readers, DM8050 and DM8600.
SET|GET IMAGEBUFFER.QUALITY quality
 [10, 15, 20... 85, 90] JPEG Quality DM50, DM60, DM70, DM474, DM503, MX-1000, DM8000 series and DM300 series readers.
SET|GET IMAGEBUFFER.RECORD-TYPE type

 [0-5]

 0: None
1: No-Read
2: Read
3: All
4: Validation Failure
5: No-Read + Validation failure 		Sets or gets the type of image to buffer.
In case of No-Read, the image is buffered if the reader fails to read. 		DM50, DM60, DM70, DM474, DM503, MX-1000, DM8000 series and DM300 series readers.
IMAGEBUFFER.SEND-FTP | Transmit buffered images to designated FTP server. | DM60, DM474, DM503, DM8000 series and DM300 series readers.
SET|GET IMAGEBUFFER.SIZE size

 [0-3]

 0: Full
1: 1/4
2: 1/16
3: 1/64 		DM50, DM60, DM70, DM474, DM503, MX-1000, DM8000 series and DM300 series readers.
SET|GET IMAGEBUFFER.TRANSFER-MODE interval

 [0-1]
 0: On Request
1: FTP - runtime 		Sets or gets whether buffered images should automatically sent FTP or if they should be send only after requested. DM60, DM70, DM474, DM503, MX-1000, DM8000 series, and DM300 series readers and DM260.

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - Symbology Commands

Symbology Commands

SET|GET 2D.ALGORITHM algorithm

 [0-1]
 0: IDMax ©
1: IDQuick 		IDQuick or IDMax© X, XM, SX and QE fixed-mount readers. All Q models except for DM503Q.
SET|GET C11.CHKCHAR state

 [ON|OFF]
 ON: enable
OFF: disable (default) 		Code 11 Check Character Mobile
SET|GET C11.CHKCHAR-OPTION int

 [0-1]
 0: disable
1: enable (default) 		Mobile
SET|GET C11.CODESIZE any, min, max

 [ON|OFF]

[1-max]

[min-80]

 any length code
minimum code length
maximum code length 		Code 11 Code Size ALL
SET|GET C128.CODESIZE any
min
max
 [ON|OFF]
[1-max]
[min-80] 		any length code
minimum code length
maximum code length 		Code 128 Allowed Size. ALL
SET|GET C25.CHKCHAR state

 [ON|OFF]
 ON: enable
OFF: disable 		Code 25 Check Character ALL
SET|GET C25.CODESIZE any, min, max

 [ON|OFF]

[1-max]

[min-80]

 any length code
minimum code length
maximum code length 		Code 25 Code Size. For the Manatee Works SDK, all of the Code 25 variants use the same minimum length; thus it will accept either C25.CODESIZE or I205.CODESIZE. ALL
SET|GET C25.QZ-SIZE size
 [0..100] any length code Sets or gets the single side strictness as a percentage. ALL
SET|GET C25.XMTCHK state

 [ON|OFF]
 ON: enable
OFF: disable 		Sets or gets whether to transmit the check digit. ALL
SET|GET C39.ASCII state
 [ON|OFF] enable/disable Code 39 Full ASCII. ALL
SET|GET C39.CHKCHAR state
 [ON|OFF] enable/disable Code 39 Check Character. ALL
SET|GET C39.CODESIZE any
min
max
 [ON|OFF]
[1-max]
[min-80] 		any length code
minimum code length
maximum code length 		Code 39 Code Size. ALL
SET|GET C39.XMTCHK state
 [ON|OFF] enable/disable Code 39 Transmit Check Character. ALL
SET|GET C93.CODESIZE any
min
max
 [ON|OFF]
[1-max]
[min-80] 		any length code
minimum code length
maximum code length 		Code 93 Code Size. ALL
SET|GET CODABAR.CHKCHAR state
 [ON|OFF] enable/disable Codabar Check Character. ALL
SET|GET CODABAR.CODESIZE any
min
max
 [ON|OFF]
[1-max]
[min-80] 		any length code
minimum code length
maximum code length 		Codabar Code Size. ALL
SET|GET CODABAR.XMTCHK state
 [ON|OFF] enable/disable Codabar Transmit Check Character. ALL
SET|GET DATABAR.EXPANDED state
 [ON|OFF] enable/disable Enable Databar expanded. ALL
SET|GET DATABAR.GROUP state
 [ON|OFF] enable/disable Enable Databar group. ALL
SET|GET DATABAR.LIMITED state
 [ON|OFF] enable/disable Enable Databar limited. ALL
SET|GET DATAMATRIX.ALGORITHM-VERSION version

 [0-2]

 0: speed preferred
1: yield preferred
2: extended 		IDQuick Usage Type. Fixed mount readers except for DM300L, DM503L, and DM503QL. 2 (extended) is supported by DM50, DM60, DM70, DM150, DM260.
SET|GET DATAMATRIX.EXTREME-PRINT-GROWTH state
 [ON|OFF] enable/disable Enable extreme print growth for DataMatrix symbols. ALL except for DM50, DM60, DM70, DM300, DM503, DM8050 and DM8600.
SET|GET DATAMATRIX.PRINT-DEFORMATION state

 [0|1]
 0: Minimal
1: Moderate 		Sets the IDMax Properties. DM300, DM474, DM503.
SET|GET DATAMATRIX.SYMBOL-DIFFICULTY int

 [0-2]

 0: Easy
1: Medium
2: Hard 		Level of DataMatrix code symbol difficulty. DM8600.
SET|GET DATAMATRIX.TRAINED-FLEX-GRID state
 [ON|OFF] enable/disable Switches the Trained Code Property "Flexible Grid Size". DM300, DM474, DM503.
SET|GET DATAMATRIX.TRAINED-IGNORE-POLARITY state
 [ON|OFF] enable/disable Switches the Trained Code Property "Ignore Polarity". DM300, DM474, DM503.
SET|GET DATAMATRIX.USAGE Usage Type

 [0-1]
 0: Default
1: High speed ink jet mode 		IDMax Usage Type. ALL except for DM50, DM60, DM70, DM300, DM503.
SET|GET DECODER.1D-MINIMUM-DECODES int
 [0-5] Minimum number of decoded scans to report a confident decoding (to prevent misread). ALL
SET|GET EAN-UCC.CC-C state
 [ON|OFF] enable/disable Enable or disable Composite Code C. ALL
SET|GET EAN-UCC.XMTMODE mode

 [0-1]
 0: Standard (linear & 2D)
1: Linear only 		EAN-UCC Transmit mode. ALL
SET|GET I2O5.CHKCHAR state
 [ON|OFF] enable/disable I2of5 Check Character. ALL
SET|GET I2O5.CODESIZE any
min
max
 [ON|OFF]
[4-max]
[min-80] 		any length code
minimum code length
maximum code length 		I2of5 Code Size. For the Manatee Works SDK, all of the Code 25 variants use the same minimum length; thus it will accept either C25.CODESIZE or I205.CODESIZE. ALL
SET|GET I2O5.XMTCHK state
 [ON|OFF] enable/disable I2of5 Transmit Check Character. ALL
SET|GET MSI.CHKCHAR state
 [ON|OFF] enable/disable Sets or gets whether check character is used. Default value is OFF. DM300 series, DM474, DM503, MX-1000, MX-1502, Mobile.
SET|GET MSI.CHKCHAR-OPTION mode

 [0-5]

 0: Mod10
1: Mod11
2: Mod1010
3: Mod1110
4:
5: 		Sets or gets the method for calculating checksum. DM474, DM503 and DM300 series, MX-1000, MX-1502, Mobile.
SET|GET MSI.CODESIZE mode
min
max
 [ON|OFF]
[1-max]
[min-80] 		any length code
minimum code length
maximum code length 		Sets or gets the expected code size. DM474, DM503, DM300 series readers, MX-1000, MX-1502.
SET|GET MSI.QZ-SIZE size
 [0-100] Sets or gets the single side strictness as a percentage DM474, DM503 and DM300 series readers.
SET|GET MSI.XMTCHK state
 [ON|OFF] enable/disable Sets or gets whether to transmit the check digit. DM474, DM503 and DM300 series readers.
SET|GET MULTICODE.HORIZONTAL-REVERSE state

 [ON|OFF]
 ON: sort right to left
OFF: sort left to right 		Horizontal positional sorting order priority. Fixed mount readers.
SET|GET MULTICODE.IDENTICAL-SYMBOLS state
 [ON|OFF] enable/disable Enables/disables output of identical symbols when multicode is enabled. Fixed mount readers.
SET|GET MULTICODE.IMAGE-REVERSE state

 [ON|OFF]
 ON: sort last image first
OFF: sort first image first 		Image sorting order preference. Fixed mount readers.
SET|GET MULTICODE.MAX-NUM-CODES symbology

number
 [1-5]

[1-255] 		1: DataMatrix
2: QR Code/MaxiCode/AztecCode
3: Linear/ Postal/ Stacked
4: VeriCode®
5: DotCode
 The expected maximum number of codes to find for each symbology grouping 1 - 4; no expected value for any single symbology can exceed parameter 0, the total number of codes to find. Fixed mount readers.
SET|GET MULTICODE.NUM-CODES number
 [1-255] Number of codes readers must find for a successful read result. Fixed mount readers.
SET|GET MULTICODE.PARTIAL-RESULTS state
 [ON|OFF] enable/disable Controls how the reader interprets the number of codes to find. ON = reader will return a successful read if 1 or more codes are found. OFF = reader will return a successful read only if number of codes found equals MULTICODE.NUM-CODES value. Fixed mount readers.
SET|GET MULTICODE.SORT-PRIORITY symbology
image
vertical position
horizontal position
 [0-3]
[0-3]
[0-3]
[0-3] 		Range for all four arguments indicates sort priority. Must be different for each criteria.

 Sorting order for multicode results: 0 is highest priority, 3 is lowest priority. Fixed mount readers.
SET|GET MULTICODE.SYMBOLOGY-REVERSE state

 [ON|OFF]
 ON: DotCode, VeriCode ®, Linear/Postal/Stacked, QR Code/MaxiCode/AztecCode, Data Matrix
OFF: Data Matrix, QR Code/MaxiCode/AztecCode, Linear/Postal/Stacked, VeriCode ®, DotCode 		Symbology sorting order preference. Fixed mount readers.
SET|GET MULTICODE.VERTICAL-REVERSE state

 [ON|OFF]
 ON: sort bottom to top
OFF: sort top to bottom 		Vertical position sorting order preference. Fixed mount readers.
SET|GET PHARMA.CODE-ORIENTATION direction

 [0-2]

 0: Any (default)
1: Horizontal
2: Vertical 		Preferred orientation for decoding Pharmacode symbols. ALL
SET|GET PHARMA.CODESIZE any
min
max
 [ON|OFF]
[1-6]
[1-6] 		any length code
minimum code length
maximum code length 		Expected Pharmacode size. ALL
SET|GET PHARMA.HORIZONTAL-DIRECTION direction

 [0-1]
 0: left-to-right (default)
1: right-to-left 		Horizontal direction preference for decoding Pharmacode symbols. ALL
SET|GET PHARMA.VERTICAL-DIRECTION direction

 [0-1]
 0: top-to-bottom (default)
1: bottom-to-top 		Vertical direction preference for decoding Pharmacode symbols. ALL
SET|GET PLANET.XMTCHK state
 [ON|OFF] enable/disable PLANET Transmit Check Character. ALL
SET|GET POSTNET.XMTCHK state
 [ON|OFF] enable/disable POSTNET Transmit Check Character. ALL
SET|GET QR.MAXIMUM-GRID-SIZE size
 [49-177] Step size: 4. Maximum grid size which can be read by the QR decoder. ALL
SET|GET QR.MICRO state
 [ON|OFF] enable/disable Micro QR Code. ALL except for DM300L, DM503L, and DM503QL.
SET|GET QR.MODEL1 state
 [ON|OFF] enable/disable QR model-1. ALL except for DM300L, DM503L, and DM503QL.
SET|GET QR.MODEL2 state
 [ON|OFF] enable/disable QR model-2. ALL except for DM300L, DM503L, and DM503QL.
SET|GET QR.SYMBOL-DIFFICULTY int

 [0-2]

 0: Easy
1: Medium
2: Hard 		Level of QR code symbol difficulty. DM8600.
SET|GET RSS.EXPANDED state
 [ON|OFF] enable/disable RSS Expanded. ALL
SET|GET SYMBOL.4STATE-AUS state
 [ON|OFF] enable/disable Enable 4-State Australia Post Symbology. ALL except for DM150QL, DM260QL, DM300L, DM503L, and DM503QL.
SET|GET SYMBOL.4STATE-IMB state
 [ON|OFF] enable/disable Enable 4-State Intelligent Mail Barcode. ALL except for DM150QL, DM260QL, DM300L, DM503L, and DM503QL.
SET|GET SYMBOL.4STATE-JAP state
 [ON|OFF] enable/disable Enable 4-State Japan Post Symbology. ALL except for DM150QL, DM260QL, DM300L, DM503L, and DM503QL.
SET|GET SYMBOL.4STATE-UPU state
 [ON|OFF] enable/disable Enable 4-State UPU Symbology. ALL except for DM150QL, DM260QL, DM300L, DM503L, and DM503QL.
SET|GET SYMBOL.AZTECCODE state
 [ON|OFF] enable/disable Enable Aztec code symbology. DM70, DM150, DM260, DM503, DM300 series readers, DM474, DM8050, DM8600, MX-1000, MX-1502, Mobile.
SET|GET SYMBOL.C11 state
 [ON|OFF] enable/disable Enable Code 11 Symbology. ALL
SET|GET SYMBOL.C128 state
 [ON|OFF] enable/disable Enable Code 128 Symbology. ALL
SET|GET SYMBOL.C25 state
 [ON|OFF] enable/disable Enable Code 25 Symbology. Manatee Works supports 7 subcodes: Standard, Interleaved, ITF-14, IATA, Matrix, COOP, and Inverted. ALL
SET|GET SYMBOL.C39 state
 [ON|OFF] enable/disable Enable Code 39 Symbology. ALL
SET SYMBOL.C39-CONVERT-TO-C32 state
 [ON|OFF] enable/disable Enables/disables the conversion of Code39 to Code32. ALL
SET|GET SYMBOL.C93 state
 [ON|OFF] enable/disable Enable Code 93 Symbology. ALL
SET|GET SYMBOL.CODABAR state
 [ON|OFF] enable/disable Enable Codabar Symbology. ALL
SET|GET SYMBOL.COOP state
 [ON|OFF] enable/disable ALL
SET|GET SYMBOL.DATABAR state
 [ON|OFF] enable/disable Enable Databar. It will enable EXPANDED and LIMITED in Manatee Works SDK (just like MX). ALL
SET|GET SYMBOL.DATAMATRIX state
 [ON|OFF] enable/disable Enable DataMatrix Symbology. ALL except for DM150QL, DM260QL, DM300L, DM503L, and DM503QL.
SET|GET SYMBOL.DOTCODE state
 [ON|OFF] enable/disable Enable DotCode symbology. DM70, DM150, DM260, DM300 series readers, DM474, DM8050X, DM8600, MX-1000, MX-1502, Mobile.
SET|GET SYMBOL.EAN-UCC state
 [ON|OFF] enable/disable Enable EAN-UCC Symbology. ALL
SET|GET SYMBOL.I2O5 state
 [ON|OFF] enable/disable Enable Interleaved 2 of 5 Symbology. ALL
SET|GET SYMBOL.IATA state
 [ON|OFF] enable/disable ALL
SET|GET SYMBOL.INVERTED state
 [ON|OFF] enable/disable ALL
SET|GET SYMBOL.ITF14 state
 [ON|OFF] enable/disable ALL
SET|GET SYMBOL.MATRIX state
 [ON|OFF] enable/disable Enable Matrix symbology. All.
SET|GET SYMBOL.MAXICODE state
 [ON|OFF] enable/disable Enable MaxiCode symbology. DM50, DM60, DM70, DM150, DM260, DM300 series readers, DM474, DM503, DM8050, DM8600, MX-1000 and MX-1502, Mobile.
SET|GET SYMBOL.MICROPDF417 state
 [ON|OFF] enable/disable Enable Micro-PDF 417 Symbology. ALL
SET|GET SYMBOL.MSI state
 [ON|OFF] enable/disable Sets or gets whether MSI Code is enabled or disabled DM70, DM150, DM260, DM503, DM300 series readers, DM474, MX-1000, MX-1502, Mobile.
SET|GET SYMBOL.PDF417 state
 [ON|OFF] enable/disable Enable PDF 417 Symbology. ALL
SET|GET SYMBOL.PHARMACODE state
 [ON|OFF] enable/disable Enable Pharmacode symbology. ALL
SET|GET SYMBOL.PLANET state
 [ON|OFF] enable/disable Enable PLANET Symbology. ALL except for DM150QL, DM260QL, DM300L, DM302L, DM503L, and DM503QL.
SET|GET SYMBOL.POSTNET state
 [ON|OFF] enable/disable Enable POSTNET Symbology. ALL except for DM150QL, DM260QL, DM300L, DM503L, and DM503QL.
SET|GET SYMBOL.QR state
 [ON|OFF] enable/disable Enable QR-Code Symbology. Enables QR and Micro QR in Manatee Works SDK. ALL except for DM150QL, DM260QL, DM300L, DM503L and DM503QL.
SET|GET SYMBOL.UPC-EAN state
 [ON|OFF] enable/disable Enable UPC/EAN Symbology. It will enable UPC-A, UPC-E, EAN-8, and EAN-13 in Manatee Works SDK (just like MX). ALL
SET|GET SYMBOL.VERICODE state
 [ON|OFF] enable/disable Enable VeriCode ® symbology. DM70, DM150 and DM260 readers with VeriCode ® license.
SET|GET
Technology Preview 		TRAIN.AUTO-DISABLE state
 [ON|OFF] enable/disable Indicates whether untrained symbology groups will be disabled after the next attempt to train. Fixed mount readers.
SET|GET TRAIN.INCREMENTAL state
 [ON|OFF] enable/disable Indicates whether incremental training is used during the next attempt to train. Fixed mount readers.
GET | TRAINED-CODE.INFO | Gets information about the currently trained code type ('Untrained' if no code is trained). | Fixed mount devices.
SET|GET UPC-EAN.DELZERO state
 [ON|OFF] enable/disable UPC/EAN Delete Leading Zero. ALL
SET|GET UPC-EAN.EAN13 state
 [ON|OFF] enable/disable UPC/EAN Allow EAN13. ALL
SET|GET UPC-EAN.EAN8 state
 [ON|OFF] enable/disable UPC/EAN Allow EAN8. ALL
SET|GET UPC-EAN.EAN8SUPL state
 [ON|OFF] enable/disable UPC/EAN Allow EAN8 Supplementals. ALL
SET|GET UPC-EAN.EXPANDED state
 [ON|OFF] enable/disable UPC/EAN Expanded. ALL
SET|GET UPC-EAN.SUPPLEMENT option

 [0-4]

 0: Ignore
1: Required
2: Required 2 digit
3: Required 5 digit
4: Not required 		UPC/EAN Supplementals. The Manatee Works SDK only supports turning UPC/EAN supplement code support on/off, while the DMCC command allows them to be off, required, require a 2 digit, require a 5 digit, or optionally permit them. The Manatee Works SDK will treat options 1-4 the same; to simply enable them. ALL
SET|GET UPC-EAN.UPC-A state
 [ON|OFF] enable/disable UPC/EAN UPC-A enabled. ALL
SET|GET UPC-EAN.UPC-E state
 [ON|OFF] enable/disable UPC/EAN UPC-E enabled. ALL
SET|GET UPC-EAN.UPCE1 state
 [ON|OFF] enable/disable UPC/EAN UPCE1 enabled. ALL
SET|GET UPC-EAN.UPCE1 state
 [ON|OFF] enable/disable UPC/EAN UPCE1 Enabled. ALL

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


DMCC API - System Commands

System Commands

GET BATTERY.CHARGE int
 [0-100] Displays, in percentage, current battery level. MX-1000 and DM8000 series readers.
GET BATTERY.INFO battery

 [0-1]
 0: internal battery
1: grip battery 		Gets verbose battery status. MX-1000
SET|GET DATA.RESULT-TYPE bit-field

 [0,1,512]

 0 = None
1 = Result
512 = MS test response 		Controls automatic, result transmitted from reader. Default bits are 1 and 512 (which is 513). ALL
SET|GET DEVICE.DESCRIPTION state
 [0-127] description Store device description for inventory management. ALL
GET | DEVICE.FEATURE-KEYS | Device Feature Keys. | ALL
GET | DEVICE.FIRMWARE-VER | Device Firmware Version. | ALL
SET|GET DEVICE.NAME string
 Device Name. MX + the last six digits of DEVICE.SERIAL-NUMBER ALL
GET | DEVICE.SERIAL-NUMBER | Device Serial Number. | ALL
GET | DEVICE.TYPE | Device Type. | ALL
SET|GET ERROR-LED.ON-TIME-MS duration
 Sets the duration for the Error LED in ms. Use 0 for unlimited duration. All devices with an error LED.
SET|GET POWER.HIBERNATE-DISABLE state
 [ON|OFF] enable/disable Turning the Hibernation feature on or off. ON means that the device never hibernates. OFF means that Hibernation is not disabled (it is enabled), thus the device will go into hibernation mode. DM8000 wireless readers.
SET|GET POWER.HIBERNATE-TIMEOUT int
 [1-600] seconds Hibernation timeout. DM8000 wireless readers.
SET|GET POWER.POWEROFF-DISABLE state
 [ON|OFF] enable/disable Turning the Power Off feature on or off. ON means that the device never turns off. OFF means that Power Off is not disabled (it is enabled), thus the device will turn off. DM8050, DM8600, MX-1000 and MX-1502.
SET|GET POWER.POWEROFF-TIMEOUT int
 [1-600] seconds Power Off timeout. DM8050, DM8600, MX-1000 and MX-1502.
SET|GET TUNE-BUTTON.3SEC-ACTION action
state
 [0-6]
[ON|OFF] 		action code (see BUTTON.3SEC-ACTION), enabled
enable/disable 		Defines actions when the user pushes the tune button for more than 3 seconds. DM474, DM503 and DM300 readers.
SET|GET TUNE-BUTTON.3SEC-ACTION action

state
 [2,7]

[ON|OFF] 		2: Set Match String
7: Extended Read Attempts
enable/disable 		Defines actions when the user pushes the tune button for more than 3 seconds. DM8600 readers.
SET|GET TUNE-BUTTON.SAVE-MATCH-STRING state
 [ON|OFF] enable/disable tune button enabled Enables the 'save match string' action when the user pushes the tune button for more than 3 seconds. DM474, DM503, DM8600 and DM300 readers.
SET|GET VIBRATION.GOOD state
 [ON|OFF] enable/disable Enables vibration. Handheld readers, except for DM8050.

Technology Preview Technology Preview

DMCC Commands marked with Technology Preview are pre-release documentation. These functions are provided as is in DataMan Software version 6.1.0. Future releases may change syntax or remove functionality altogether.
Important: Use [0,1] or [true,false] instead of [ON|OFF] when scripting.


Copyright Information

Cognex Corporation assumes no responsibility for the use or reliability of its software on equipment that is not supplied by Cognex Corporation. Cognex Corporation makes no warranties, either express or implied, regarding the described software, its merchantability or its fitness for any particular purpose.

The information in this document is subject to change without notice and should not be construed as a commitment by Cognex Corporation. Cognex Corporation is not responsible for any errors that may be present in either this document or the associated software.

Copyright © 2019 Cognex Corporation All rights reserved.

This document may not be copied in whole or in part, nor transferred to any other media or language, without the written permission of Cognex Corporation.

The hardware and portions of the software described in this document may be covered by one or more of the U.S. patents listed on the Cognex web site http://www.cognex.com/patents. Other U.S. and foreign patents are pending.

Note: Descriptions of standard JavaScript entities are mainly from https://developer.mozilla.org/en-US/docs/JavaScript/Reference/Global_Objects, created by Mozilla Contributors.


Licensed Software

SpiderMonkey

This software is subject to the terms of the Mozilla Public License, v. 2.0. You can obtain a copy of the MPL at http://mozilla.org/MPL/2.0/.

If you want to get a copy of the source code of SpiderMonkey please contact Cognex technical support at <spidermonkey@cognex.com>

PCRE Licence

PCRE is a library of functions to support regular expressions whose syntax and semantics are as close as possible to those of the Perl 5 language.

Release 5 of PCRE is distributed under the terms of the "BSD" licence, as specified below. The documentation for PCRE, supplied in the "doc" directory, is distributed under the same terms as the software itself.

Written by: Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England. Phone: +44 1223 334714.

Copyright (c) 1997-2004 University of Cambridge All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  • Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  • Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  • Neither the name of the University of Cambridge nor the names of its contributors may be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE

End

JPEG software

This software is based in part on the work of the Independent JPEG Group.

zlib compression library

This software is based in part on the work of Jean-loup Gailly and Mark Adler.

Parsifal XML Parser

Copyright (c) 2002-2005 Toni Uusitalo released to the public domain 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal is free for both commercial and non-commercial use and redistribution, provided that author's copyright and disclaimer are retained intact. You are free to modify Parsifal for your own use and to redistribute Parsifal with your modifications, provided that the modifications are clearly documented.

DISCLAIMER

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of Merchantability or fitness for a particular purpose. Please use it AT YOUR OWN RISK.

lwIP TCP/IP stack

Copyright (c) 2001-2004 Swedish Institute of Computer Science. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided that the following conditions are met:

  1. Redistributions of source code must retain the above copyright notice, this list of conditions and the following disclaimer.
  2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the following disclaimer in the documentation and/or other materials provided with the distribution.
  3. The name of the author may not be used to endorse or promote products derived from this software without specific prior written permission.

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.


Patent Information

This product is covered by one or more of the below listed US patents, US applications, and/or foreign patents. http://www.cognex.com/patents will list any relevant subsequently issued patents.

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, and EP1687752