DataMan 8000 Series Base Station : 问题与解答


连接至读码器


如何将基站连接至设置工具？

按以下步骤将 DataMan 读码器连接至设置工具：

  1. 通过 Windows 开始菜单或设置工具帮助菜单，为基站打印一份读码器配置代码文档。

  2. 在基站和运行设置工具的 PC 之间连接必要的电缆。有关详细信息，请参阅 DataMan 8xx0 快速参考硬稿文档。

  3. 扫描通讯设置所需的符号或连接类型代码，如 USB。

  4. 单击设置工具中的刷新。

  5. 选择显示连接读码器的 COM 端口或网络设备。

  6. 单击连接。


USB 连接要使用什么端口？

如果使用 USB 端口连接读码器或基站，确保扫描读码器配置代码文档上的 USB-COM/RS-232 配置代码。然后单击刷新并选择确认为连接至读码器的端口。

注：单击刷新发送所有 COM 端口和以太网子网中的查询字符串。DM7550 和 DM8000 无线读码器应唤醒以应答查询。长按触发器以唤醒读码器。


仍无法连接至读码器或基站：可以将它重置吗？

对于 DataMan 8000 基站：

使用与基站相关联的无线读码器，扫描将基站重置为出厂默认值命令（适用于 DM8000 基站），将基站还原至出厂默认状态。

适用于 DataMan 503 和 8000 系列读码器：

扫描印在快速参考指南背面的重启扫描器命令，执行软重置操作。虽然读码器中的非易失性存储器不会清除，但读码器会关机并重启。

如果失败，扫描将扫描器重置为出厂默认值命令，将读码器还原至出厂默认状态。

如果失败且有线读码器正在使用中，请断开读码器的电源（在 DataMan 9500 中不可执行此操作）。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。

如果失败且 DataMan 8000 无线读码器正在使用中，请取出读码器的电池并将其放置到基站。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。

适用于 DataMan 50、60 和 70 读码器：

通过 Windows 开始菜单或设置工具帮助菜单，为特定读码器打印一份配置代码文档。

扫描重启读码器代码，执行软重置操作。虽然不会清除读码器中的非易失性存储器，但读码器会关机并重新启动。

如果仍无法连接读码器，扫描将读码器重置为出厂默认值代码，将读码器还原至出厂默认状态。

如果仍不能解决问题，断开读码器的电源（包括 DC 电源和 USB，如已连接）。在按住触发器按钮的同时，重新连接读码器的电源。按住触发按钮至少 6 秒钟，直至听到双哔声。读码器的指示灯以不同颜色闪烁。


DataMan 50、60、70、300、370、470、503、8000 系列、MX-1000、MX-1500 和 DataMan 8000 基站：为什么在连接时，设置工具要求提供密码？

在连接到设置工具之前，可以配置读码器和基站要求提供密码。通过通讯设置面板网络设置选项中的验证选项卡启用密码。请注意，串行连接也使用该密码。


DataMan 60、300、370、470、503、8000 系列 和 DataMan 8000 基站：可以直接使用以太网将读码器连接至 PC 吗？

可以将读码器或基站直接连接至 PC 的以太网接口 (RJ-45)。如果设备配置了 DHCP，它会在大约 20 秒后出现在网络设备列表中。但请注意，PC 可能还需要数分钟时间来解决 IP 地址问题。完成之前，无法通过设置工具连接至设备。

如果设备已设置为静态 IP 地址，只有当设备与 PC 共用同一子网时它才会出现。


DataMan 60、300、370、470、503、8000 系列、MX-1000 和 DataMan 8000 基站：如何将网络设备列表中的列表映射到特定读码器？

在默认情况下，网络设置中出现的每个 DataMan 都带有 DM 前缀和设备上 MAC 地址的后 6 个字符。


DataMan 60、300、370、470、503、8000 系列、MX-1000、MX-1500 和 DataMan 8000 基站：如果网络设备列表中不出现读码器或基站怎么办？

如果所需的读码器或基站未列出，可以反复开关电源来添加。设备在接通电源后出现在列表中可能需要 60 秒的时间。

如果反复开关电源未能解决问题，设置工具可能因网络配置原因无法与设备通讯，从而使它未出现在网络设备列表中。

检查与读码器或基站的以太网连接，然后点击设置工具中的刷新。

如果知道读码器或基站的 IP 地址，使用添加设备选项。

这种方法可使 DataMan 读码器或基站出现在网络设备列表中，这样就能通过设置工具和以太网来连接。


DataMan 8000 无线读码器：如何将无线读码器关联到不同的基站？

如果想要关联无线读码器的基站已关联了另一台读码器，就必须通过扫描从基站解除读码器指定代码断开该链接。要将读码器指定到新的基站，只需将新的读码器放进基站即可。它们会自动配对。


DataMan 8000 基站：如何重设基站的 USB 连接？

如果在基站和 PC 之间建立或维护 USB 连接有困难，请根据以下步骤重设 USB 连接：

  1. 断开基站的 USB 电缆和电源线。

  2. 重新连接基站的 USB 电缆和电源线。

  3. 将读码器放入基站。

  4. 从基站中移除读码器并扫描 USB-COM/RS_232 配置代码。


输入/输出


可以更改哪些系统设置？

可以禁用或启用蜂鸣器。请注意，无法设置哔声次数或指定 LED 颜色。


如何重置基站？

使用与基站相关联的无线读码器扫描重置为出厂默认值（适用于 DM8000Base）配置代码。


如何使用无线读码器，而不是键盘？

要在 HID 模式下使用基站，必须扫描读码器配置代码文档中的启用基站的 USB 键盘代码（可通过 Windows 开始菜单或设置工具帮助菜单）。


为什么要更改设备名称？

可以为生产环境下的设备起个更有意义的名称，如位置或检查任务。使用高级选项卡下的设备名称字段。


如何更改设备名称？

要更改设备名称：

  1. 在设备名称中输入设备的新名称。

  2. 弹出更改需要重新启动后才能生效，是否应用更改并立即重新启动？的询问对话框。单击是。

  3. 如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启设备。

下一次启动设置工具或单击连接读码器面板上的刷新，将显示新的设备名称。


什么是唤醒消息？

如果启用唤醒时输出诊断字符串，读码器或基站会在启动时传输诊断字符串。

此功能对 USB 连接不可用。对于串行连接，无论设置工具如何设置，波特率都会在发送消息时自动设定为 38,400。


通信


如何更改基站的串行端口设置？

扫描读码器配置代码文档的 RS-232 串行配置代码时，基站的波特率（以及其他串行端口设置）自动配置到与设置工具所使用的相同。

如果需要将基站连接至具有特定波特率或其他串行端口设置的设备，请从读码器配置代码文档扫描相应的代码（可通过 Windows 开始菜单或设置工具帮助菜单）。请注意，需要使用设置工具重新扫描 RS-232 串行或 USB 串行代码以进行连接。


更改 USB 模式会对什么产生影响？

通过串行 USB 连线连接至读码器时，可以将该连接的 USB 速度更改为 1.1 或 2.0。

连接至无线读码器时，更改 USB 模式对基站不会产生影响。更改的设置将保留在读码器内存中，如果将无线滑块更改为串行滑块，读码器将连接至（之前）选定的 USB 模式。


何时应使用 USB 驱动程序兼容模式？

在默认情况下，基站使用可帮助读码器从静电放电 (ESD) 事件恢复的 USB 驱动程序。如果需要严格符合 USB 规范或 DataMan 读码器同 Cognex SensorView 产品一起使用，请使用 USB 驱动程序兼容模式。

更改 USB 驱动程序兼容模式时，会弹出更改需要重新启动后才能生效，要应用更改并立即重新启动吗？的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启读码器。


用通信信道下拉菜单设置能设置什么？

可以在此通过 USB 设置通信方式。根据所用的设备，可使用以下选项：

  • 仅 USB-COM：选择此选项可通过串行端口连接设备。

  • 仅 USB HID：此选项可确保设备像 USB 键盘一样使用。

  • USB-COM + USB-HID：这是上述模式的组合。

注：在仅 USB-COM，一些设备也可能会列出下 'HID 设备'，尽管他们缺乏 HID 功能。


通过 USB 连接时如何使用基站，而不是使用键盘？

要使无线读码器模拟 USB 键盘，可以从读码器配置代码文档扫描启用基站的 USB 键盘代码（可通过 Windows 开始菜单或设置工具帮助菜单），并确保断开与设置工具的连接。


如何通过 PS/2 适配器使用基站，而不是键盘？

要仿真 PS/2 键盘，必须使用如快速参考指南中所述的串行电缆、外部电源和键盘接口电缆。从阅读器配置代码文档扫描 PS/2 键盘仿真启用代码（可通过 Windows 开始菜单或设置工具帮助菜单）。要安装 PS/2 适配器，必须完全断开 PC 的电源。使用上面列出电缆连接基站。然后打开计算机，此时无线读码器就可以仿真 PS/2 键盘了。


询问时不重启基站会怎么样？

更改的设置不生效。如果改变想法，可以单击系统并选择保存设置。然后重启基站。


什么是 RS-232 路由选项？

通过 RS-232 连接基站时，可以更改数据路由到基站本身，还是要直接与基站关联的读码器通信。

没有读码器分配至基站时，无论路由选项中如何选择，RS-232 接口都用于配置基站。当关联的读码器已分配或未分配时，在对基站循环通电后，RS-232 接口的操作模式会自动改变。


如何配置基站的网络设置？

选择使用 DHCP 服务器选项，通过 DHCP 服务器（如果有）或手动输入网络设置为读码器指定 IP 地址。有关相应值，联系网络管理员。

更改设置时，会弹出更改需要重新启动后才能生效，要应用更改并立即重新启动吗？的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置，然后重启读码器。


可以使用哪些 IP 地址子网？

如果切换到使用静态 IP 地址，则可以使用 172.16.2.x 和 172.16.0.x 以外的任何 IP 地址子网。不要将其用于基站或无线读码器的 IP 地址。


如何将新的读码器指定给该基站？

将读码器放入基站中。它们会自动指定。


如果更改密码，它会立即更新吗？

输入（新）密码后，必须按下 Enter 键。如果按下 TAB 键或拿开鼠标而没有按下 Enter 键，密码就不会生效。


总是需要输入两次密码吗？

如果选中显示，就只需要输入一次密码。如果未选中显示，就必须再次输入密码，如果两次输入不匹配，设置工具会显示警告信息。


如果禁用无线连接会怎么样？

取消选中启用无线时，如果将它放进基站，就只能与读码器连接和通讯。虽然可以用读码器一直读码，但只有将它放回基站并以任何有线方式连接，才可以发送图像。


禁用蓝牙会怎么样？

取消选中启用蓝牙时，如果将它放进基站，就只能与读码器连接和通讯。虽然可以用读码器一直读码，但只有将它放回基站并以任何有线方式连接，才可以发送图像。


何时应单击解除指定？

如果想让另一台读码器与基站关联，单击解除指定。如果新的读码器还未指定给任何基站，现在只需要把它放进基站即可。指定会自动进行。如果读码器已指定给了另一基站，扫描解除读码器指定读码器编程代码，然后将读码器放进基站中。


关联读码器的 IP 地址是什么？

该 IP 地址用于读码器和基站之间的内部通信。此设置无法更改。不要将此 IP 地址用于网络通信。


读码器和基站之间的通信设置同步吗？

必须将读码器放进基站，以便它们能同步交换和更新设置。如果更改通讯设置时读码器已在基站中，拿起读码器并再次将它放进基站中。


工业协议

EtherNet/IP 协议

勾选以太网选项卡的 工业协议框中的EtherNet/IP选项，使读码器采用 EtherNet/IP 协议。

更改值必须重启后才生效显示在通信横条右侧。点击保存设置，然后重启读码器。

PROFINET 协议

勾选PROFINET，使读码器采用 PROFINET 协议。点击使用站名框，输入站名。

更改值必须重启后才生效显示在通信横条右侧。点击 保存设置 ，然后重启读码器。

SLMP 协议

勾选SLMP 协议，使读码器采用 SLMP 协议，然后根据需要设置参数。

更改值必须重启后才生效显示在通信横条右侧。点击保存设置，然后切换读码器的电源或扫描 复位 符号，重启读码器，使设置生效。

Modbus TCP

勾选Modbus TCP，使读码器采用 Modbus TCP 协议，然后根据需要设置参数。

更改值必须重启后才生效显示在通信横条右侧。点击 保存设置 ，然后切换读码器的电源或扫描 复位 符号，重启读码器，使设置生效。

EtherNet/IP、PROFINET、SLMP 协议或 Modbus TCP 选项呈灰色

在特定时间内只可以使用一种以太网工业协议。选择一种协议时，另一种协议就不可用了。


如何使用验证选项？

如果启用验证，在通过网络尝试连接至可用的读码器或基站时，设置工具将提示用户以管理员帐户输入密码。


如何建立 TCP/IP 连接？

基站可以将 TCP 连接到端口 23，它是 Telnet 应用程序的默认 TCP 端口。如果使用 Telnet 客户端，唯一需要提供的参数就是读码器的 IP 地址。如果正在使用其他应用程序或 SDK 连接，请确保使用与基站相同的 TCP 端口设置。TCP 端口可以在 Telnet 面板中更改。基站将通过该连接自动发送代码输出。还可以通过该连接传输 DataMan 控制命令 (DMCC)。

更改 Telnet 端口时，会弹出更改需要重新启动后才能生效，要应用更改并立即重新启动吗？的询问对话框。单击是。如果由于某种原因单击否，仍可以应用这些更改。选择系统->保存设置并重启基站。


什么是网络客户端？

网络客户端是用于 DataMan ID 读码器主动打开网络中另一台设备以太网连接的工具。一旦打开，连接将具有与 DataMan Telnet 连接相同的基本操作性能；可以生成读取结果（结果传输到外部设备），并可以用作 DMCC 服务器（从外部设备接收处理命令）。


什么是主机？

主机是 DataMan 将连接的网络设备。指定主机设备的以太网地址和端口号。地址可以是完全符合条件的域名（例如server.mynetwork.com）或十进制点格式的 IP 地址（例如192.169.0.1）。


什么是客户端端口？

客户端端口是客户端连接的读码器上的以太网端口。默认值 0 表明网络客户端使用任何可用端口。在特殊情况下，可能需要指定特定的客户端端口。只需将客户端端口设置为所需的值。请注意，最典型的情况是使用默认值 0。如不能肯定，请使用默认值。


如何连接？

客户端将按照所选的打开连接选项进行连接。当接通 DataMan 电源时可用选项将进行连接，或者在有数据活动时进行连接（即读码时连接）。


如何关闭连接？

有两个可用的关闭连接选项。连接可以永远保持打开状态，或者可以在数据传输完成后关闭连接。如果选择读码器数据传输后选项，还可以在连接断开后设置一个数字（秒），若这段时间内读码器闲置。闲置期的长度的调节范围为 1 到 3600 秒。


什么是连接超时？

连接超时是 DataMan 等待连接打开的时间量（毫秒）。请注意，如果选择了通电选项，则读码器会不断尝试打开连接。


什么是重新连接延迟？

它是尝试重新打开连接之前读码器暂停的时间量（毫秒）。


备份设置


什么是自动读码器配置备份？

自动备份用于通过以太网连接的设备。启用时，每次配置保存到闪存时，此功能都会将设备配置备份到外部存储器（FTP 服务器）。Cognex Explorer 服务可以接收备份数据。可以通过设置工具、DMCC 命令或 Cognex Explorer 手动进行恢复。

以所需的 IP 地址和端口号配置读码器，以指定配置的保存位置。还可以设置用户名和密码组合。


表视图


为什么有些值以突出显示？

突出显示的值最初都是非默认值。可以在功能区菜单的突出显示部分更改突出显示规则，参见问题表视图：功能区菜单获取更多信息。


为什么有些值以粗体显示？

以粗体显示的值是可扩展和显示的子值。


如何知道可能的值是什么？

如有可能，将鼠标移至某一值上，就会显示一个悬浮文本最小值、最大值和默认值。


法律信息


版权

Cognex Corporation 对使用非 Cognex Corporation 提供的设备软件或其可靠性不负任何责任。Cognex Corporation 对于相关描述软件及其任何特殊用途的适销性或适用不作任何明示或暗示的担保。

本文档中的信息如有更改，恕不另行通知，不应被解释为由 Cognex Corporation 作出的承诺。Cognex Corporation 对本文档或相关软件中出现的任何错误概不负责。

版权 ? 2018 Cognex Corporation 保留所有权利

未得到 Cognex Corporation 书面许可，任何人不能复制本文档，也不得将其转让给任何其他媒体或翻译为其他语言。

硬件和本文档中所述软件部分可能受一个或多个美国专利的保护，具体内容参见 Cognex 网站 http://www.cognex.com/patents.asp。其他美国和国外专利尚在申请中。


许可软件

SpiderMonkey

本软件遵循 Mozilla Public License, v. 2.0 的条款。可以从 http://mozilla.org/MPL/2.0/ 获得 MPL 的副本。

若要获取 SpiderMonkey 的源代码副本，请发送电子邮件至 <spidermonkey@cognex.com> 与 Cognex 技术支持联系

PCRE 许可证

PCRE 是一种支持其语法和语义学与 Perl 5 语言尽可能相近的正则表达式的功能库。

PCRE 版本 5 的发行受 BSD许可证的约束，如下所示。doc目录下提供的 PCRE 文档依据软件本身条款的规定发行。

编写者：Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.电话：+44 1223 334714.

版权 (c) 1997-2004 University of Cambridge 保留所有权利。

在满足以下条件的前提下，允许用户将修改后或未经修改的软件以源代码或二进制的格式进行重新发布或使用：

  • 重新发布源代码时必须保留上面的版权声明、此处的条款列表和下面的免责声明。
  • 如果以二进制格式重新发布，必须在该文档和/或随发布提供的其他材料中包含上面的版权声明、此处的条款列表和下面的免责声明。
  • 未经事先书面许可，不得使用University of Cambridge及其他责任者的名称宣传或促销在本软件基础上开发的产品。

本软件仅以版权持有人和其他责任人 按原样 形式提供，不做任何明确或隐含的担保，包括但不限于对适销性和对特定用途的适用性的担保。在任何情况下，版权拥有者或其他责任者对由于使用本软件而造成的任何直接、间接、偶然、特殊、惩罚性或因果性的损害（包括但不限于更换商品或服务、无法使用、丢失数据、损失利润或业务中断）不承担任何责任，无论由于什么原因、根据何种责任理由；无论是否签署了合同、负有严格的责任限制；无论是否由于使用本软件而引起纠纷（因疏忽或其他原因），即使事先已被告知可能会造成这种损害。

结束

JPEG 软件

本软件的某些部分基于独立 JPEG 组的工作。

zlib 压缩库

本软件的某些部分基于 Jean-loup Gailly 和 Mark Adler 的工作。

Parsifal XML 解析器

版权 (c) 2002-2005 Toni Uusitalo 发行到公共域名 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal 对商业和非商业软件的使用和重新发行免费，但需要提供保留完整的作者版权和免责声明。可以自行修改 Parsifal 用于个人使用以及在提供明确记载修改的内容后重新发布。

免责声明

本程序是基于使用目的而加以发布，然而不负任何担保责任；也不对适售性或特定目的适用性所作的默示性担保。使用时请自行承担一切风险。


专利信息

本产品是受下列一个或多个美国专利、美国申请和/或国外专利保护，http://www.cognex.com/patents 将列出任何其后发布的相关专利

5742037、5943441、6215915、6236769、6282328、6381375、6408109、6457032、6690842、6941026、7175090、7181066、7412106、7427028、7549582、7604174、7614563、7617984、US-2005-0087601-A1、US-2006-0131418-A1、US-2006-0131419-A1、US-2006-0133757-A1、US-2007-0090193-A1、US-2007-0091332-A1、US-2007-0152064-A1、US-2007-0170259-A1、US-2008-0004822-A1、US-2008-0011855-A1、US-2008-0142604-A1、US-2008-0143838-A1、US-2008-0158365-A1、US-2009-0090781-A1、US-2009-0108073、US-2009-0121027-A1、US-2009-0166424-A1、US-2009-0294541-A1、WO06065619A1 和 EP1687752