DataMan 8000 Series Base Station : Perguntas e Respostas


Conecte-se ao leitor


Como conectar minha estação de base ao Setup Tool?

Sigas esses passos para conectar o leitor DataMan ao Setup Tool:

  1. Imprima uma cópia do documento Códigos de configuração do leitor referentes à estação base, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.

  2. Conecte os cabos necessários entre a estação base e o computador que está executando o Setup Tool. Consulte o documento impresso "Guia de consulta rápida do DataMan Série 8xx0" para obter mais informações.

  3. Leia o símbolo das Configurações de comunicação desejadas ou o código do Tipo de conexão (Ex.:USB).

  4. Clique em Atualizar no Setup Tool.

  5. Selecione a Porta COM ou o Dispositivo de rede mostrando uma conexão para o seu leitor.

  6. Clique em Conectar.


Qual porta usar para uma conexão USB?

Se você conectar o leitor ou a estação base usando a porta USB, faça a leitura do código de configuração USB-COM/RS-232 do documento "Códigos de configuração do leitor". Depois clique em Atualizar e selecione a porta que é identificada como conectada ao leitor.

Observação: Ao clicar em Atualizar, uma cadeia de consulta será enviada para todas as portas COM e toda a sub-rede da rede Ethernet. O leitor sem fio DM7550 e DM8000 deve estar ativo para receber o comando. Pressione o disparador para ativar o leitor.


Ainda não é possível conectar meu leitor à estação base: Posso reinicializá-lo?

Na estação base do DataMan Série 8000:

Usando o leitor sem fio associado à estação base, faça a leitura do comando Redefinir a estação base com o padrão de fábrica (para a DM8000Base) para fazer com que a estação base volte ao estado padrão de fábrica.

Para leitores das séries 503 e 8000 DataMan:

Faça a leitura do comando Reinicializar scanner impresso na parte posterior do documento "Guia de consulta rápida" para reinicializar pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Se isto falhar, faça a leitura do comando Reinicializar o scanner com os padrões de fábrica para que o leitor volte ao estado padrão de fábrica.

Se isto falhar e você estiver usando um leitor com fio, desconecte o leitor da fonte de alimentação (este procedimento não pode ser usado no DataMan 9500). Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.

Se isso falhar e você estiver usando o leitor sem fio DataMan 8000, remova a bateria do leitor e coloque-a na estação de base. Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.

Para leitores DataMan 50, 60 e 70:

Imprima uma cópia do documento Códigos de configuração referentes ao seu leitor específico, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.

Faça a leitura do código Reiniciar scanner para fazer uma reinicialização pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Se você ainda não pode se conectar ao leitor, faça a leitura do código Reinicializar o scanner com os padrões de fábrica para retornar o leitor ao seu estado padrão de fábrica.

Se isto não resolver a questão, desconecte o leitor da alimentação de força (tanto força de corrente contínua - CC quanto USB, se conectado). Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.


DataMan séries 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 e estação de base do DataMan 8000: Por que o Setup Tool pede uma senha quando quero me conectar?

O leitor e a estação base podem ser configurados para solicitar uma senha antes de se conectar ao Setup Tool. A senha é habilitada na guia Autenticação na opção Configurações de rede do painel Configurações de comunicação. Saiba que a senha é usada também para conexão serial.


DataMan séries 60, 300, 370, 470, 503, 8000 e estação de base do DataMan 8000: É possível conectar o leitor com meu PC usando diretamente a Ethernet?

O leitor ou a estação base pode ser conectado diretamente a um conector Ethernet (RJ-45) no seu PC. Se o dispositivo estiver configurado para DHCP, então ele aparecerá na lista de Dispositivos de rede depois de aproximadamente 20 segundos. Favor considerar, todavia, que seu PC pode precisar de um tempo adicional para que seu endereço IP seja configurado. Até que isso termine, você não pode se conectar ao dispositivo por meio do Setup Tool.

Se o dispositivo foi ajustado em um endereço IP fixo, ele aparecerá apenas se o leitor e o PC compartilharem a mesma sub-rede.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000 e estação de base do DataMan 8000: Como relacionar um dispositivo na lista de dispositivos de rede com um leitor específico?

De modo padrão, cada DataMan aparece nos Dispositivos de rede com um prefixo DM e os últimos seis caracteres em seu endereço MAC, que são impressos no dispositivo.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 e estação de base do DataMan 8000: O que ocorre se o leitor ou a estação base não aparece na lista de Dispositivos de rede?

Se o leitor ou a estação base desejado não estiver listado(a), adicione-o(a) ligando e desligando o dispositivo. O dispositivo leva até 60 segundos para aparecer na lista, após ser desligado e ligado.

Se a operação de desligar e ligar não resolver o problema, o Setup Tool não poderá se comunicar com o dispositivo devido à configuração de rede e ele não aparecerá na lista de Dispositivos de rede.

Verifique sua conexão Ethernet com o leitor ou com a estação de base e clique em Atualizar no Setup Tool.

Se você souber o endereço IP do leitor ou da estação base, use a opção Adicionar dispositivo.

Esse método permite que o leitor DataMan ou a estação de base apareça na lista de Dispositivos de rede, de modo que você possa se conectar ao dispositivo através do Setup Tool e de sua conexão Ethernet.


Leitor sem fio DataMan Série 8000: Como associar um leitor sem fio a uma estação base diferente?

Se a estação base com a qual você deseja associar o leitor sem fio já estiver associada com outro leitor, você deverá interromper esta associação, fazendo a leitura do código Cancelar atribuição do leitor da estação base. Para associar o leitor à nova estação base, simplesmente coloque o novo leitor na estação base. Eles se emparelharão automaticamente.


Estação base do DataMan 8000: Como reinicializar a conexão USB na estação base?

Se você sentir alguma dificuldade para estabelecer ou manter uma conexão USB entre a estação base e seu PC, siga estes passos para reinicializar a conexão USB:

  1. Desconecte o cabo USB e o cabo de força da estação base.

  2. Reconecte o cabo USB e o cabo de força à estação base.

  3. Coloque o leitor na estação base.

  4. Remova o leitor da estação base e faça a leitura do código de configuração do USB-COM/RS_232.


Entradas / Saídas


Quais configurações do sistema podem ser alteradas?

É possível habilitar ou desabilitar o beeper. Fique ciente de que não é possível definir o número de bipes ou especificar as cores LED.


Como reinicializar a estação base?

Faça a leitura do código de configuração Reinicializar com os padrões de fábrica (para o dispositivo DM8000Base) com o leitor sem fio associado à sua estação base.


Como usar o leitor sem fio em vez do teclado?

Para usar a estação base no modo HID, você deve fazer a leitura do código do Habilitar teclado USB para estação base do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool).


Por que deveria mudar o nome do dispositivo?

Dê um nome mais significativo ao seu dispositivo para seu ambiente de produção, como a localização ou a tarefa de inspeção. Use o campo Nome do dispositivo na guia Avançadas.


Como mudar o nome do dispositivo?

Para mudar o nome do dispositivo:

  1. Insira um novo nome para o dispositivo no Nome do dispositivo.

  2. A pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim.

  3. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Selecione Sistema->Salvar configurações e, em seguida, reinicialize seu dispositivo.

A próxima vez que você iniciar o Setup Tool ou clicar em Atualizar no painel Conecte-se ao leitor, ele refletirá o novo nome do dispositivo.


O que é uma Mensagem de ativação?

Se a função Enviar cadeia de diagnóstico ao ativar estiver habilitada, o leitor ou a estação de base transmitirá uma cadeia de diagnósticos sempre que o dispositivo iniciar.

Esta funcionalidade não está disponível para conexões USB. Para conexões seriais, a taxa de transmissão está automaticamente ajustada em 38.400 quando a mensagem é enviada, apesar dos ajustes realizados no Setup Tool.


Comunicações


Como devo mudar as configurações da porta serial da estação base?

Quando você faz a leitura do código de configuração RS-232 serial do documento Códigos de configuração do leitor, a estação base é automaticamente configurada para usar a mesma taxa de transmissão de dados (e outras configurações da porta serial) que o Setup Tool usa.

Se você precisa conectar a estação base a um dispositivo com uma taxa de transmissão específica ou outras configurações da porta serial, faça a leitura dos códigos relevantes do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool). Observe que será necessário fazer uma nova leitura do código RS-232 serial ou USB serial a ser conectado, usando o Setup Tool.


O que será afetado pela mudança do modo USB?

Quando você estiver conectado ao leitor por meio da conexão serial USB, poderá mudar a velocidade da conexão USB para 1.1 ou 2.0.

Quando você estiver conectado ao leitor sem fio, a alteração do modo USB não afetará a estação base. As configurações alteradas permanecerão na memória do leitor, e se você alterar o adaptador sem fio para um adaptador serial, o leitor se conectará ao modo USB selecionado (anteriormente).


Quando devo usar o Modo de compatibilidade do driver USB?

Por padrão, a estação base usa um driver USB que pode ajudar a estação base a recuperar-se de um evento de descarga eletrostática (ESD). Use o Modo de compatibilidade do driver USB se for necessário seguir estritamente a conformidade com a especificação USB ou se você estiver usando uma estação base DataMan junto com o Cognex SensorView.

Quando você altera o modo de compatibilidade do driver USB, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e depois reinicialize seu leitor.


O que é possível configurar com o menu suspenso Canal de comunicação usado?

Aqui, você pode definir o método de comunicação por USB. Dependendo do dispositivo utilizado, as opções a seguir estão disponíveis.

  • USB-COM apenas: Escolha essa opção para alcançar o dispositivo usando uma porta serial.

  • USB-HID apenas: Essa opção assegura que o dispositivo se comporte como um teclado USB.

  • USB-COM + USB-HID: É uma combinação dos modos acima.

OBSERVAÇÃO: No caso da opção USB-COM apenas, alguns dispositivos também podem ser listados em "dispositivos HID", mesmo que não tenham a funcionalidade HID.


Como usar a estação base em vez do teclado quando estiver conectado com USB?

Para emular um teclado USB no leitor sem fio, faça a leitura do código Habilitar teclado USB para estação base, disponível no documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool) e verifique se você desconectou o Setup Tool.


Como usar a estação base em vez do teclado usando o adaptador PS/2?

Para emular um teclado PS/2, você deve usar o cabo serial, fonte de alimentação externa e cabo de outro dispositivo ou programa além do teclado, como descrito no Guia de consulta rápida. Faça a leitura do código Habilitar emulação de teclado PS/2 do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool). Para instalar o adaptador PS/2, você deve desligar o seu PC da tomada. Conecte a estação base usando os cabos mencionados acima. Em seguida, ligue o computador e o leitor sem fio emulará um teclado PS/2.


O que acontece se minha estação base não for reinicializada quando solicitado?

As mudanças nas configurações não serão aplicadas. Se você mudar de ideia, clique em Sistema e selecione Salvar configurações. Em seguida, reinicialize a estação base.


Qual é a função da opção Roteamento RS-232?

Quando você conectar a estação base por meio do RS-232, poderá alterá-la se os dados forem roteados para a própria estação base ou se quiser se comunicar diretamente com o leitor associado com a estação base.

Quando não houver nenhum leitor associado à estação base, a interface RS-232 será usada para configurar a estação base, independente do que selecionar na opção Roteamento. Quando a atribuição do leitor associado for realizado ou cancelado, o modo de operação da interface RS-232 mudará automaticamente, após desligar e reiniciar a estação base.


Como configurar as configurações de rede da estação base?

Selecione a opção Usar servidor DHCP para ter o leitor atribuído a um endereço IP por um servidor DHCP (se um estiver disponível) ou insira as configurações de rede manualmente. Entre em contato com o seu administrador de rede para obter os valores apropriados.

Quando você altera as configurações, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e depois reinicialize seu leitor.


Quais são as sub-redes de endereço IP que posso usar?

Se você alterar para usar um endereço IP estático, poderá usar cada sub-rede de endereço IP exceto as sub-redes 172.16.2.x e 172.16.0.x. Não use estas sub-redes para o endereço IP da estação base ou do leitor sem fio.


Como associar um novo leitor a esta estação base?

Coloque o leitor na estação base. A associação será realizada automaticamente.


Se a senha for alterada, ela será atualizada automaticamente?

É necessário pressionar Enter após digitar a (nova) senha. Se você pressionar TAB ou clicar em outro lugar com o mouse, sem pressionar Enter, a senha não será reconhecida.


A senha deve ser sempre digitada duas vezes?

Se você marcar a opção Exibir, poderá digitar a senha apenas uma vez. Se a opção Exibir não estiver marcada, será necessário digitar a senha novamente e, caso elas não correspondam, o Setup Tool exibirá uma mensagem de aviso.


O que acontece se a conexão sem fio for desabilitada?

Se você desmarcar a função Habilitar sem fio, somente será possível conectar-se e comunicar com o leitor se ele estiver na estação base. Você poderá efetuar leituras usando o leitor e enviar imagens, assim que colocá-lo novamente na estação base e conectá-lo com os cabos.


O que acontece se a conexão Bluetooth for desabilitada?

Se você desmarcar a função Habilitar Bluetooth, somente será possível se conectar ao leitor e se comunicar com ele se ele estiver na estação de base. Porém, você ainda poderá efetuar leituras usando o leitor e enviar as imagens assim que colocá-lo novamente na estação base e conectá-lo com os cabos.


Quando clicar em Cancelar atribuição?

Clique em Cancelar atribuição se quiser associar outro leitor à estação base. Se o novo leitor não estiver associado à outra estação base, basta colocá-lo na estação base neste momento. A associação é automática. Se o leitor já estiver associado a outra estação base, faça a leitura do código de programação do leitor Cancelar atribuição do leitor e, em seguida, coloque o leitor na estação base.


Qual é o endereço IP do leitor associado?

O endereço IP é usado para a comunicação interna entre o leitor e a estação base. Esta configuração não pode ser alterada. Não use este endereço IP para a comunicação de rede.


As configurações de comunicação estão sincronizadas entre o leitor e a estação base?

Coloque o leitor na estação base para que os dispositivos troquem informações e atualizem as configurações a serem sincronizadas. Se o leitor já estiver na estação base quando você alterar as configurações de comunicação, levante o leitor e coloque-o novamente na estação base.


Protocolos industriais

Protocolo EtherNet/IP

Para habilitar o leitor a usar o protocolo Ethernet/IP, marque EtherNet/IP na caixa Protocolos industriais da guia Ethernet.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize seu leitor.

Protocolo PROFINET

Para habilitar o leitor a usar o protocolo PROFINET, marque PROFINET. Você pode inserir o nome da estação clicando na caixa Usar o nome da estação.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize seu leitor.

Protocolo SLMP

Para habilitar o leitor a usar o protocolo SLMP, marque Protocolo SLMP e, em seguida, configure os parâmetros conforme necessário.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize o leitor para o ajuste fazer efeito, tanto alternando a força do leitor ou digitalizando o símbolo Reinicializar.

Modbus TCP

Para habilitar o leitor a usar o protocolo Modbus TCP, marque Modbus TCP e, em seguida, configure os parâmetros conforme necessário.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize o leitor para o ajuste fazer efeito, tanto alternando a força do leitor ou digitalizando o símbolo Reinicializar.

EtherNet/IP, PROFINET, Protocolo SLMP ou Modbus TCP acinzentado

Apenas um protocolo industrial de Ethernet pode ser usado por vez. Quando um protocolo estiver selecionado, o outro não estará disponível.


Como usar a opção autenticar?

Quando a opção Autenticar for habilitada, o Setup Tool irá solicitar ao usuário uma senha para a conta administrador quando for feita alguma tentativa de conexão a um leitor ou a uma estação base disponível na rede.


Como estabelecer uma conexão TCP/IP?

A estação base possibilita conexões TCP à porta 23, que é a porta padrão TCP para aplicações Telnet. Se você usar o cliente Telnet, o único parâmetro que terá que fornecer é o endereço IP da estação base. Se você estiver usando outra aplicação ou SDK para conectar, verifique se utiliza a mesma configuração de porta TCP usada pela estação base. A porta TCP pode ser alterada no painel Telnet. A estação base enviará o código de saída automaticamente através da conexão. Você também pode transmitir comandos de controle DataMan (DMCC) através desta conexão.

Quando você altera a porta Telnet, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e reinicialize sua estação base.


O que é o Cliente de rede?

O comportamento do Cliente de rede é um meio para que a ID do leitor DataMan abra ativamente uma conexão Ethernet com outro dispositivo da rede. Quando estiver aberta, a conexão terá o mesmo comportamento operacional básico da conexão DataMan Telnet. Ela produzirá resultados de leitura (transmitindo resultados para o dispositivo externo) e pode atuar como servidor DMCC (processando comandos recebidos do dispositivo externo).


O que é um host?

O host é o dispositivo da rede com o qual o DataMan se conectará. Especifique o endereço da Ethernet e o número da porta do dispositivo host. O endereço pode ser um nome de domínio totalmente qualificado (por exemplo: “server.mynetwork.com”) ou um endereço IP de formato de pontos decimais (por exemplo: “192.169.0.1“).


O que é a porta do cliente?

A porta do cliente é a porta Ethernet do leitor a partir da qual a conexão do cliente será originada. O valor padrão de 0 instrui o cliente de rede para usar qualquer porta disponível. Em casos especiais, você precisará definir uma porta do cliente específica. Basta definir a porta do cliente colocando o valor necessário. Observe que o caso mais comum é usar o valor padrão de 0. Se você estiver em dúvida, use o valor padrão.


Como posso estabelecer uma conexão?

O cliente se conectará com base na opção Abrir conexão selecionada. As opções disponíveis são a conexão quando o DataMan for ligado ou a conexão assim que houver atividades de dados (ou seja, a conexão quando um código for lido).


Como desligo a conexão?

Há duas opções de Fechar conexão disponíveis. A conexão pode ficar sempre aberta ou pode ser fechada após a transferência de dados for completada. Se você selecionar a opção Após a transferência de dados do leitor, poderá definir um número de segundos definidos para a conexão desligar se o leitor estiver inativo por um período de tempo. A duração do período inativo é ajustada de 1 até 3600 segundos.


O que é o Tempo limite da conexão?

O tempo limite da conexão é o período de tempo (em milésimos de segundos) que o DataMan espera para abrir a conexão. Observe que caso a opção Em inicialização estiver selecionada, o leitor continuará tentando abrir a conexão.


O que é o Atraso da reconexão?

É o período de tempo (em milésimos de segundos) que o leitor pausará antes de tentar reabrir a conexão.


Configurações de backup


O que é o Backup automático da configuração do leitor?

O backup automático funciona com os dispositivos conectados através da Ethernet. Quando estiver selecionada, esta função faz um backup da configuração do dispositivo em um disco externo (um servidor FTP) sempre que a configuração for salva na memória flash. Um serviço do Cognex Explorer pode receber os dados de backup. A restauração pode ser feita manualmente pelos comandos do Setup Tool, DMCC ou Cognex Explorer.

Configure o leitor com o endereço IP e o número da porta necessário para especificar onde você quer salvar a configuração. Você também poderá definir um nome do usuário e uma senha.


Visualização de tabela


Por que alguns valores são mostrados em destaque?

Valores que estão destacados são valores não padrão, inicialmente. As regras de destaque podem ser alteradas na seção Destaque do menu de faixa de opções; consulte a questão Visualização de tabela: Menu de faixa de opções para obter mais informações.


Por que alguns valores são mostrados em negrito?

Valores em negrito são expansíveis e mostram subvalores.


Como saber quais são os valores possíveis?

Movimente o mouse sobre um valor e veja o texto flutuante que indica o valor mínimo, máximo e o padrão, quando for relevante.


Informações legais


Direitos autorais

A Cognex Corporation não assume qualquer responsabilidade para o uso ou confiabilidade deste software sobre equipamentos que não foram fornecidos pela Cognex Corporation. A Cognex Corporation não oferece nenhuma garantia, seja expressa ou implícita, relacionada ao software descrito, sua comercialidade ou sua adequação a qualquer propósito em particular.

As informações contidas neste documento estão sujeitas à alteração sem aviso prévio e não devem ser construídas como um compromisso da Cognex Corporation. A Cognex Corporation não é responsável por quaisquer erros que podem ser apresentados tanto neste documento ou no software associado.

Direitos autorais © 2018 Cognex Corporation. Todos os Direitos Reservados

Este documento não pode ser copiado no todo ou em parte nem transferido para qualquer outro meio ou idioma, sem a permissão por escrito da Cognex Corporation.

O hardware e porções do software descritos neste documento podem ser protegidos por uma ou mais das patentes americanas listadas no website Cognex http://www.cognex.com/patents.asp. Outras patentes americanas e estrangeiras estão pendentes.


Software licenciado

SpiderMonkey

Este software está sujeito aos termos de uso do documento "Mozilla Public License", v. 2.0. Acesse uma cópia do documento "MPL" em http://mozilla.org/MPL/2.0/.

Se quiser receber uma cópia do código fonte do SpiderMonkey, entre em contato com o suporte técnico da Cognex em <spidermonkey@cognex.com>

Licença PCRE

O PCRE é uma livraria de funções para suportar expressões regulares como sintaxe e semântica o mais próximo possível daqueles da linguagem Perl 5.

A liberação 5 da PCRE é distribuída sob os termos da licença "BSD", como especificado abaixo. A documentação para a PCRE, fornecida no diretório "doc", é distribuída sob os mesmos termos que o próprio software.

Escrito por: Philip Hazel <ph10@cam.ac.uk>

Universidade de Cambridge Computing Service, Cambridge, Inglaterra. Telefone: +44 1223 334714.

Direitos autorais (c) 1997-2004 Universidade de Cambridge. Todos os direitos reservados.

A redistribuição e o uso na fonte e formas binárias, com ou sem modificação, são permitidos sabendo-se que as seguintes condições são conhecidas:

  • As redistribuições do código fonte devem manter o aviso de direitos autorais acima, que lista as condições e a seguinte isenção de responsabilidade.
  • As redistribuições em forma binária devem reproduzir o aviso de direitos autorais acima, esta lista de condições e a seguinte isenção de responsabilidade na documentação e/ou outros materiais fornecidos com a distribuição.
  • Nem o nome da Universidade de Cambridge, nem os nomes de seus colaboradores podem ser usados para endossar ou promover produtos derivados deste software sem permissão por escrita anterior específica.

ESTE SOFTWARE É FORNECIDO PELOS TITULARES E CONTRIBUINTES DE DIREITOS AUTORAIS "DA FORMA ATUAL" E QUALQUER GARANTIA EXPRESSA OU IMPLÍCITA, INCLUINDO, MAS NÃO LIMITANDO, AS GARANTIAS IMPLÍCITAS DE MERCADO E AJUSTE PARA UM PROPÓSITO EM PARTICULAR, SÃO DECLINADOS. EM NENHUM EVENTO OS CONTRIBUINTES OU DETENTORES DE DIREITOS AUTORAIS SÃO RESPONSÁVEIS POR QUALQUER DANO DIRETO, INDIRETO, ESPECIAL, EXEMPLAR OU CONSEQUENTE (INCLUINDO, MAS NÃO LIMITADO AO ACORDO DE SUBSTITUIÇÃO DE BENS OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) TODAVIA CAUSADO E EM QUALQUER TEORIA DE RESPONSABILIDADE, SE NO CONTRATO, A RESPONSABILIDADE RESTRITA OU ATO ILÍCITO (INCLUINDO NEGLIGÊNCIA OU OUTRO) SURGIDO DE QUALQUER FORMA DO USO DESTE SOFTWARE, MESMO SE AVISADO DA POSSIBILIDADE DESTE DANO

Fim

Software JPEG

Este software é baseado em parte do trabalho do Grupo Independente JPEG.

biblioteca de compactação zlib

Este software é baseado em parte no trabalho de Jean-loup Gailly e Mark Adler.

Parsifal XML Parser

Direitos Autorais (c) 2002-2005 Toni Uusitalo liberou para domínio público em 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal é gratuito tanto para o uso e redistribuição comercial quanto não comercial, sabendo-se que os direitos autorais do autor e isenção de responsabilidade são mantidos intactos. Você é livre para modificar a Parsifal para seu próprio uso e para redistribuir Parsifal com suas modificações, desde que as modificações sejam claramente documentadas.

ISENÇÃO DE RESPONSABILIDADE

Este programa é distribuído na esperança que será útil, mas SEM NENHUMA GARANTIA; mesmo sem a garantia implícita de mercado ou ajuste para uma proposta em particular. Use SOB SUA PRÓPRIA RESPONSABILIDADE.


Informação de patente

Este produto é coberto por uma ou mais das patentes americanas listadas abaixo, aplicações americanas e/ou patentes estrangeiras http://www.cognex.com/patents irá listar qualquer patente relevante emitida subsequentemente

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 e EP1687752