DataMan 70 Series : Perguntas e Respostas


Tela de boas-vindas


Bem-vindo

Para configurar rapidamente seu dispositivo, é recomendado seguir os Passos do aplicativo representados por botões maiores, no lado esquerdo. Cada seção possui uma guia com opções de configuração Básicas ou Avançadas. O botão de ação Salvar configurações salva os dados da configuração no leitor e salva um backup em seu PC com um único clique. As perguntas abaixo descrevem as opções de configuração em cada Passo do aplicativo que não são autoexplicativas.


O que posso configurar em Tipo de aplicativo?

Clicar na seta à direita permite que você selecione os modos de leitura adequados a partir do menu suspenso.


O que posso fazer no passo Otimizar imagem?

Você pode realizar o processo de configuração, calibragem e teste de seu dispositivo conectado aqui e pode configurar seus ajustes de iluminação para o dispositivo.


O que posso selecionar em Detalhes do código?

Aqui, você pode selecionar as simbologias que o DataMan tem de ler, bem como cenários de códigos múltiplos diferentes. As configurações avançadas do decodificador também podem ser efetuadas neste menu.


O que posso configurar no passo Detalhes do aplicativo?

Aqui podem ser definidas as configurações do disparo e de exposição. Para um uso fácil, um Assistente de disparo, um Assistente de intervalo e um Assistente de exposição ajudam-no com estas configurações.

Na guia Avançadas podem ser implementadas configurações mais detalhadas na visualização de tabela.


O que posso configurar em Dados do formato?

Para construir a saída de dados desejada a partir do dispositivo você pode usar expressões regulares de estilo Perl ou formatação básica para construir um cadeia de saída personalizada, usando os blocos de criação predefinidos, ou usar o mecanismo de JavaScript para construir um script de formatação de dados flexível.


O que posso configurar no passo Entradas/Saídas?

Neste painel podem ser configurados o comportamento dos botões e as linhas de entrada e de saída. Aqui também podem ser configurados os detalhes para um codificador de pulso e a duração do pulso do bipe. Este painel também possui o link para as configurações do buffer de imagens para enviar imagens FTP para um servidor.


O que posso configurar no passo do aplicativo Comunicações?

Nas três guias do passo do aplicativo Comunicações podem ser implementadas as configurações de Ethernet e serial. Clique na guia adequada para inserir seus valores de configuração.


Qual a função de Salvar configurações?

Salvar configurações é mais propriamente uma ação do que um passo, mas importante de realizar. Esta ação salvará a configuração atual na memória persistente do leitor, de modo que as mesmas configurações sejam carregadas após reiniciar. O DataMan Setup Tool armazenará também um arquivo de backup localmente, no PC atual, na pasta de backup.


Conecte-se ao leitor


Como conectar meu leitor ao Setup Tool?

Independente de qual leitor você esteja usando, siga estes passos para conectar seu leitor DataMan ao Setup Tool:

  1. Imprima uma cópia do documento Códigos de configuração do leitor referentes ao seu leitor específico, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.

  2. Conecte os cabos necessários entre o seu leitor e o computador executando o Setup Tool. Consulte a documentação "Referência Rápida" para obter mais informações.

  3. Clique em Atualizar no Setup Tool.

  4. Selecione a Porta COM ou o Dispositivo de rede mostrando uma conexão para o seu leitor.

  5. Clique em Conectar.


Por que o Setup Tool falha ao se conectar ao meu leitor?

Se você não conseguir se conectar, verifique as seguintes opções:

  • Verifique se o código de configuração que você escaneou (USB COM ou RS-232 Serial) está de acordo com o tipo de conexão física que você está usando (não funciona com os leitores que usam apenas a conexão via Ethernet).

  • Certifique-se que a lista das portas COM mostra uma porta onde o seu leitor está conectado.

    DataMan séries 60, 300, 370, 470, 503 e 8000: Se o seu leitor estiver conectado à sua rede Ethernet, verifique se ele aparece na lista de Dispositivos de rede.

    Clique em Atualizar para determinar quais portas possuem leitores conectados.

    Observação: Ao clicar em Atualizar, uma cadeia de consulta será enviada para todas as portas COM e toda a sub-rede da rede Ethernet. O leitor sem fio DataMan 8000 deve estar ativo para responder ao comando. Você pode pressionar o disparador para ativar o leitor.

  • Verifique se você não está usando o teclado, a conexão do teclado ou a conexão HID. Você deve usar uma rede USB Serial, RS-232 Serial, Ethernet ou sem fio para conectar o Setup Tool ao leitor.

  • DataMan séries 60, 300, 370, 470, 503 e 8000: Certifique-se que o endereço IP fornecido na opção Adicionar dispositivo está correto.

  • Apenas para leitores DataMan 8000 sem fio: Certifique-se que o leitor não está no modo de suspensão (aperte o disparador para despertá-lo).

  • Apenas para os leitores DataMan 8000 sem fio: Verifique se há uma conexão estabelecida entre o leitor e a estação base conectada ao seu computador. Para garantir, leia o código de configuração Desvincular impresso no guia de consulta rápida, desconecte ambos os cabos de comunicação e energia da estação base, reconecte os cabos e depois recoloque o leitor na estação base. Aguarde até que o leitor indique que está conectado (com um sinal audível) antes de tentar conectar novamente.

  • Apenas para leitores DataMan 8000 sem fio: Certifique-se que a estação base está energizada.

Você pode usar um programa de simulação como o HyperTerminal para determinar se o leitor está enviando quaisquer dados ou se o leitor está conectado a uma porta COM no PC.


Por que vejo um ícone de sobreposição no canto superior direito do ícone do meu dispositivo?

O ícone de seta indica que o dispositivo foi adicionado manualmente. O ícone ‘V’ indica que o dispositivo é um dispositivo virtual.


O que são dispositivos virtuais?

O ícone de sobreposição ‘V’ no canto superior direito do ícone do dispositivo indica que o dispositivo é um dispositivo virtual. Os Dispositivos virtuais podem ser criados em Reparo e suporte, a partir de um arquivo de configuração personalizada ou um dispositivo com configuração padrão. Os Dispositivos virtuais podem ser usados para visualizar os diferentes painéis do Setup Tool sem necessidade de conectar a um dispositivo real.

O dispositivo virtual criado não está visível para outros dispositivos na rede. O dispositivo virtual persiste através de múltiplas instâncias de Setup Tool.

O dispositivo virtual criado pode ser conectado da mesma forma que um dispositivo normal, com a exceção de que todas as alterações de configuração são rejeitadas (tudo é somente leitura) e nenhuma característica, função e ação funciona em dispositivos virtuais.


Qual porta usar para uma conexão USB?

Se você conectar o leitor ou a estação base usando a porta USB, faça a leitura do código de configuração USB-COM/RS-232 do documento "Códigos de configuração do leitor". Depois clique em Atualizar e selecione a porta que é identificada como conectada ao leitor.

Observação: Ao clicar em Atualizar, uma cadeia de consulta será enviada para todas as portas COM e toda a sub-rede da rede Ethernet. O leitor sem fio DM7550 e DM8000 deve estar ativo para receber o comando. Pressione o disparador para ativar o leitor.


Ainda não é possível conectar meu leitor à estação base: Posso reinicializá-lo?

Na estação base do DataMan Série 8000:

Usando o leitor sem fio associado à estação base, faça a leitura do comando Redefinir a estação base com o padrão de fábrica (para a DM8000Base) para fazer com que a estação base volte ao estado padrão de fábrica.

Para leitores das séries 503 e 8000 DataMan:

Faça a leitura do comando Reinicializar scanner impresso na parte posterior do documento "Guia de consulta rápida" para reinicializar pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Se isto falhar, faça a leitura do comando Reinicializar o scanner com os padrões de fábrica para que o leitor volte ao estado padrão de fábrica.

Se isto falhar e você estiver usando um leitor com fio, desconecte o leitor da fonte de alimentação (este procedimento não pode ser usado no DataMan 9500). Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.

Se isso falhar e você estiver usando o leitor sem fio DataMan 8000, remova a bateria do leitor e coloque-a na estação de base. Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.

Para leitores DataMan 50, 60 e 70:

Imprima uma cópia do documento Códigos de configuração referentes ao seu leitor específico, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.

Faça a leitura do código Reiniciar scanner para fazer uma reinicialização pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Se você ainda não pode se conectar ao leitor, faça a leitura do código Reinicializar o scanner com os padrões de fábrica para retornar o leitor ao seu estado padrão de fábrica.

Se isto não resolver a questão, desconecte o leitor da alimentação de força (tanto força de corrente contínua - CC quanto USB, se conectado). Enquanto mantém pressionado o botão Disparo, reconecte o leitor a fonte de alimentação. Mantenha pressionado o botão Disparo por pelo menos 6 segundos, até que seja ouvido um bipe duplo. O leitor irá acender sua luz indicadora em cores diferentes.


Como saber qual é o meu dispositivo?

Para os leitores DataMan 260, 300, 473, 500, 503 e 8000:

Na lista de seleção, os dispositivos estão listados em Conecte-se ao leitor, clique com o botão direito do mouse no leitor e selecione Identificar. O indicador de status do leitor emite um sinal, possibilitando que você o identifique.


Por que alguns leitores são mostrados em verde?

Os dispositivos recentemente descobertos são exibidos em verde por alguns segundos para que você saiba que é um novo dispositivo na lista de seleção.


O que é o Monitor de processo?

Como ele opera, as estatísticas de registro do leitor DataMan como o número de disparos recebidos, o número de símbolos lidos (e não lidos) e o número de saturações do disparo. Você pode visualizar ou solicitar estas estatísticas usando uma variedade de significados. Por exemplo, você pode conectar o software de aplicação VisionView para monitorar as tentativas de decodificação de qualquer leitor ou estabelecer uma conexão usando a interface Comandos de controle DataMan (DMCC) e retirar informações de log em uma conexão Telnet ou serial.

Por padrão, o leitor DataMan para de gerar estatísticas sobre as tentativas de decodificação quando conectado ao Setup Tool. Para reabilitar a estatística de processos quando conectado ao Setup Tool, você deve iniciar o monitor de processo. Mesmo se você estabelecer conexões múltiplas a um único leitor, tal como usar tanto o Setup Tool quanto o software aplicativo VisionView, o leitor não registrará estatísticas de decodificação a menos que você habilite o monitor de processo.


DataMan séries 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 e estação de base do DataMan 8000: Por que o Setup Tool pede uma senha quando quero me conectar?

O leitor e a estação base podem ser configurados para solicitar uma senha antes de se conectar ao Setup Tool. A senha é habilitada na guia Autenticação na opção Configurações de rede do painel Configurações de comunicação. Saiba que a senha é usada também para conexão serial.


Como funciona o botão Comparar configuração?

O botão Comparar configuração inicia a função de comparação de configuração do Setup Tool, uma ferramenta do estilo de visualização de tabela usada para configurar, copiar, comparar ou restaurar as configurações do dispositivo. A função abre em uma página de documento nova.

Se não for selecionado nenhum dispositivo da lista de dispositivos antes de pressionar o botão, é aberto um documento vazio. Se um ou mais dispositivos forem selecionados, o documento de comparação é preenchido com as configurações desses dispositivos.


O que é o RTM Lean ou o dispositivo RTM exibido em Rede?

O Monitoramento em tempo real (RTM) Lean é um recurso incluído no DataMan Setup Tool e o RTM é um aplicativo de software suportado pelo hardware acessível através do DataMan Setup Tool, que permite a coleção e análise de diferentes tipos de dados relacionados com os dispositivos na rede e respectivas leituras. Você pode conectar-se ao RTM Lean ou ao RTM como faria a um dispositivo, avançando de seguida para a configuração da coleção de dados em um documento recentemente aberto. O RTM Lean ou RTM somente coleta os dados ativamente durante o funcionamento e quando você está conectado a ele.

Durante a configuração inicial, será solicitado que você escolha o dispositivo que será monitorado pelo RTM Lean ou pelo RTM e, de seguida, que tipo de dados (fora do padrão) o mesmo irá coletar. Isto pode ser redefinido em Configuração, no menu de faixa de opções. Como padrão, o RTM Lean ou o RTM coleta os dados estatísticos (Taxa de leitura, contagem do disparo, saturação do disparo, estouro de buffer e métricas de controle do processo, se estiverem habilitados no dispositivo).

OBSERVAÇÃO: O RTM Lean pode adquirir dados de um único dispositivo de cada vez e manter os dados durante 48 horas. A versão completa do RTM não tem essas limitações.


Otimizar imagem


O que posso fazer no passo Otimizar imagem?

Você pode realizar o processo de configuração, calibragem e teste de seu dispositivo conectado aqui.

Para configurar rapidamente seu dispositivo, é recomendado seguir os Passos do aplicativo representados por botões maiores no centro, onde você pode selecionar a partir de opções de configuração Básicas ou Avançadas. Com o botão de ação Salvar configurações você pode salvar todos os seus dados de configuração de forma simples. As perguntas abaixo descrevem as opções de configuração em cada Passo do aplicativo que não são autoexplicativas.


Como salvar uma imagem adquirida em um arquivo?

Clique no botão Salvar imagem na barra de ferramentas do Painel de imagens ou Visualizador de imagens.

Também é possível arrastar e soltar a imagem para o seu computador. Clique na imagem, na janela Visualização da imagem, arraste-a para fora do Setup Tool e solte-a.

OBSERVAÇÃO: Caso você queira salvar uma imagem arrastando-a e soltando-a, mas a imagem não é a mais recente (você está salvando de Histórico de resultados da leitura), a imagem será salva com as configurações da imagem exibida. Como padrão, a qualidade é reduzida. Em Configurações da imagem visualizada, é possível alterar o tamanho da imagem para o tamanho cheio e formatá-la para Bitmap.


Como posso usar o botão Ao vivo?

Na guia Básicas, clique no botão Ao vivo para entrar no modo Ao vivo. O modo Ao vivo não monitora somente o que o dispositivo lê, mas também decodifica. Clicando no lado mais à direita do botão, abre outras opções.

Selecione Decodificar se você deseja que o dispositivo decodifique imagens obtidas. Quando selecionada, a opção Retorno do foco exibe um medidor codificado por cores do lado direito da visualização de imagem. O medidor indica o foco da lente (menor é menos focado).

Selecione a opção Exposição automática para que o leitor determine automaticamente as melhores configurações de exposição na imagem. O controle deslizante (abaixo da área de visualização de imagem) indica o brilho dos pixels do alvo.

Na guia Avançadas, pode ser visualizada uma visualização de tabela das configurações da imagem.


Como posso usar o botão Calibragem?

Clique no botão Calibragem na guia Básicas para encontrar automaticamente as melhores configurações para sua leitura. A janela suspensa (clique no lado mais à direita do botão para abrir) mostra os recursos de calibragem Otimizar foco, Otimizar brilho, Assistente de simbologia, Tipos de disparo, Aprender código, Configurações avançadas do disparo e outros.

OBSERVAÇÃO: O tamanho mínimo de ROI necessário para que a Calibragem funcione é 144x144 pixels.

As opções na parte superior da janela suspensa são descritas em perguntas separadas, abaixo.

Clique em Otimizar brilho para definir automaticamente o brilho recomendado para seu dispositivo (somente disponível se a Exposição manual estiver definida abaixo) ou clique no link ao lado do botão para navegar para o passo do aplicativo Detalhes do aplicativo, onde você pode definir manualmente a intensidade de luz e acessar configurações avançadas.

Selecione a opção Exposição automática para que o leitor determine automaticamente as melhores configurações de exposição na imagem. O controle deslizante Fator de ganho (abaixo da área da visualização de imagem) indica o brilho dos pixels do alvo.

Selecione a opção Exposição manual para exposição manual e depois arraste o controle deslizante Exposição máxima para a esquerda ou para a direita, para especificar uma configuração precisa para a exposição da câmera. Também é possível usar o controle deslizante abaixo da área de visualização de imagem. A configuração Fator de ganho máximo é usada para definir o brilho máximo do pixel do alvo.

Clique em Otimizar foco para definir automaticamente o foco recomendado para seu dispositivo ou clique no link ao lado do botão para navegar para o painel apropriado, em Detalhes do aplicativo, onde você pode definir manualmente o foco da câmera e acessar configurações avançadas. Você também pode otimizar o foco, usando o controle deslizante abaixo do campo de visão da imagem (com o ícone de foco). Observe que ele somente apareça ao usar uma lente líquida.

Clique em Aprender código para treinar ou (caso um código já esteja treinado) desfazer treinamento de códigos, ou clique no link ao lado do botão para navegar para as configurações avançadas de treinamento de código no passo do aplicativo Detalhes do código.

O Assistente de simbologia é um assistente que guia você pela configuração de leitura e decodificação das simbologias apropriadas ou desejadas. Você também pode ajustar manualmente as configurações de simbologia, clicando no link ao lado do assistente, que irá navegar até ao passo do aplicativo Detalhes do código.

Configure o leitor com qualquer um dos seguintes Tipos de disparo:

  • O disparo Único adquire uma imagem única e tenta decodificar qualquer símbolo que ela possa conter. Este modo de disparo aceita um tempo limite de leitura.

  • O disparo de Apresentação busca continuamente por um símbolo e decodifica-o cada vez que um é detectado.

  • O disparo Manual adquire imagens enquanto o sinal do disparo continuar ativo e para quando um símbolo é encontrado e decodificado ou quando o sinal do disparo acaba.

  • O disparo Burst adquire um número definido de imagens e decodifica o primeiro símbolo que é detectado dentro do grupo. Você pode configurar o número de imagens dentro de cada burst assim como o intervalo entre cada aquisição de imagem. Este modo de disparo aceita um tempo limite de leitura.

  • O disparo Automático é similar ao disparo de apresentação, no qual o leitor busca continuamente por um símbolo e decodifica-o cada vez que um for detectado.

  • O disparo Contínuo adquire imagens enquanto o sinal do disparo permanecer ativo, onde o leitor adquire imagens em um intervalo específico e tenta fazer a varredura de qualquer símbolo que cada imagem sucessiva contenha.

Observação: Não estão disponíveis todos os tipos de disparo para todos os dispositivos! Consulte os Manuais de referência correspondentes para mais informações sobre os tipos de disparo disponíveis do modelo do seu dispositivo.

Clicando no link Configurações avançadas do disparo você navega até ao passo Detalhes do aplicativo, onde pode acessar configurações mais detalhadas.

Na guia Avançadas você pode definir os valores em uma visualização de tabela.


O que acontece se eu selecionar Calibragem de bancos de luz?

Se você definir Calibragem de bancos de luz, o dispositivo calibrará os bancos de luz. Se você souber quais definições de luz deseja usar, desabilite a opção de modo que a calibragem não anule suas predefinições.


O que acontece se eu selecionar Calibragem exaustiva?

A seleção dessa opção força a calibragem dos bancos de luz. Quando a Calibragem exaustiva é desabilitada e o leitor consegue ler o código com a configuração de luz primária (primeira na sequência), ele para de tentar outras combinações do banco de luz.

Se a Calibragem exaustiva estiver ligada, o leitor continuará tentando todas as combinações para procurar a melhor, mesmo que a primeira seja bem-sucedida.


O que acontece se eu selecionar Habilitar calibragem de filtro?

Se Habilitar calibragem de filtro for selecionado, o DataMan Setup Tool aplica filtros na imagem lida. O filtro, cujo código é lido com sucesso, é então exibido no painel Resultados de calibragem, em Filtro de imagem.


O que acontece se eu selecionar Otimizar foco durante a calibragem?

Se desejar que o foco seja automaticamente otimizado durante a calibragem, selecione a opção Otimizar foco durante a calibragem.


O que acontece se eu selecionar Aprender código após calibragem?

Selecione Aprender código após calibragem se quiser garantir que os códigos lidos são aprendidos para o seu dispositivo após a calibragem. O código encontrado será exibido no lado inferior da janela do DataMan Setup Tool.

OBSERVAÇÃO: Quando essa função é usada, o DataMan Setup Tool somente reconhecerá o tipo de código encontrado, portanto, não use qualquer outro tipo de código a ser lido.


O que acontece se eu selecionar Excluir resultados de luz ambiente?

Selecione Excluir resultados de luz ambiente se não desejar que sejam automaticamente selecionados somente resultados de luz ambiente para o processo de calibragem (que seria, de outra forma, o tipo de iluminação prevalente para leitores fixos).


Como posso usar o botão Testar?

Clique no botão Testar para testar seu dispositivo com uma configuração, sem qualquer interrupção para a produção.

Se você selecionar um tipo de disparo sob o botão Ao vivo, que seja externo (qualquer um diferente de Apresentação ou modo de disparo Automático), você pode disparar o leitor automaticamente no modo Teste. Você pode disparar o leitor automaticamente no modo Teste, usando os tempos Disparo ligado e Disparo desligado. Para sua comodidade, pode visualizar a frequência de disparo calculada.

Você pode também reduzir os tempos Disparo Ligado ou Disparo desligado para reduzir a duração do ciclo e, ainda, aumentar a frequência de disparo.

OBSERVAÇÃO: Dependendo da configuração de leitura, código a ler e interface de conexão, podem existir limitações de velocidade e, a altas velocidades, isso pode ajudar a desabilitar a transferência da imagem.

Alguns casos típicos de utilização são os seguintes:

  • Disparo ligado = 20 ms, Disparo desligado = 1980 ms -> Frequência = 0,5 Hz (padrão)
  • Disparo ligado = 20 ms, Disparo desligado = 980 ms -> Frequência = 1 Hz
  • Disparo ligado = 20 ms, Disparo desligado = 480 ms -> Frequência = 2 Hz
  • Disparo ligado = 20 ms, Disparo desligado = 180 ms -> Frequência = 5 Hz
  • Disparo ligado = 20 ms, Disparo desligado = 80 ms -> Frequência = 10 Hz
  • Disparo ligado = 20 ms, Disparo desligado = 30 ms -> Frequência = 20 Hz


Utilizo o painel de Desempenho de leitura para o quê?

Com os gráficos no painel Desempenho da leitura, à direita, você pode monitorar tempos de decodificação e taxas de leitura em tempo real. Clique no botão Apagar para reinicializar o gráfico.


Como ajustar a exposição da imagem?

Clique em Calibragem para selecionar automaticamente as melhores configurações para o seu leitor. Esta opção inicializa os recursos Otimizar brilho e Aprender código.

OBSERVAÇÃO: As funções Melhorar brilho e Calibragem não funcionam se a dimensão de região de interesse for menor que 144.

Clique em Otimizar brilho para configurar automaticamente a intensidade de luz recomendada. Esse recurso estará disponível se o controle Exposição manual estiver selecionado. Para habilitar a Exposição manual para acessar mais configurações, clique no ícone ao lado do botão Otimizar brilho. Também é possível arrastar o controle deslizante Exposição abaixo da imagem para a esquerda ou para a direita, ou digitar um valor para a exposição. Para acessar configurações mais detalhadas, clique no ícone ao lado da caixa de texto à esquerda.

Também é possível alterar as configurações de Exposição enquanto estiver testando com a função Visualização ao vivo.


Como ajustar o foco da imagem?

Clique em Calibragem para selecionar automaticamente as melhores configurações para o seu leitor. Esta opção inicializa o recurso Otimizar foco, se disponível, para além dos recursos Otimizar brilho e Aprender código.

Clique em Otimização do foco para configurar o melhor foco possível. Este recurso está disponível apenas em leitores com lente líquida. Para acessar configurações mais detalhadas, clique no link ao lado do botão Otimizar foco. Alternativamente, use o controle deslizante Foco, abaixo da imagem, arrastando-o ou digite um valor para o foco: o valor pode ser fornecido em dioptria ou distância (milímetros). Também é possível usar os botões '+' e '-' para alterar os valores, mas tenha em atenção que '+' diminui o valor de dioptria e '-' o aumenta. A distância não é aplicável para a região laranja (acima de 500 milímetros) do controle deslizante, de modo que o Setup Tool desativa automaticamente a distância se o controle deslizante for movido para aí. Mover o controle deslizante ou o valor para fora da região laranja volta a ativar a distância. Para acessar configurações mais detalhadas, clique no link Configurações avançadas de foco para navegar até ao painel Configurações do foco

Você também pode alterar as configurações de Valor de foco enquanto estiver testando com a função Visualização ao vivo.


Como ligar ou desligar rapidamente todas as luzes do leitor?

Clique com o botão direito do mouse na imagem que exibe os quadrantes de luz. É possível selecionar estas opções:

  • Todos ligados

  • Todos desligados

  • Norte-Sul

  • Leste-Oeste

As alterações serão válidas imediatamente de acordo com a sua seleção.


O que é Diagnósticos de símbolo (licença necessária)?

Diagnósticos de símbolo é um recurso que fornece retorno gráfico do dispositivo para códigos de barras sem leitura. Olhando para o retorno, você pode localizar o problema pelo qual um código de barras falhou a codificação. O retorno fornecido pode sinalizar os seguintes problemas (em uma região do código de barras):

  • Padrão Iniciar ou Parar não foi encontrado (seta laranja no código). A área designada pela seta falhou a decodificação. As razões para a falha são mostradas a seguir (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso):

    • Padrão Iniciar ou Parar está cortado/danificado

    • O código está cortado (devido ao limite da imagem ou por um objeto bloqueando o código)

    • Degradação da qualidade da imagem (frequentemente, porém nem sempre, causada pela qualidade da luz)

    • Deformação e dobragem das etiquetas dos códigos de barras

  • Dano/erro de impressão dentro do código de barras (região do retângulo vermelho no código). A área dentro do retângulo é onde o dano ou problema de impressão se encontra. São exemplos comuns de problemas de impressão (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso):

    • Vazamento de tinta que une as barras em uma só

    • Erro de impressão de uma barra que reduz sua espessura para além da tolerância de decodificação

  • Área silenciosa não é suficiente (região do retângulo magenta no código). A violação da Área silenciosa ocorre quando não existe espaço suficiente em um ou ambos os lados do código de barras. Dependendo da simbologia, os leitores toleram alguma violação da Área silenciosa. A violação da Área silenciosa normalmente ocorre devido a texto ou retângulo em torno do código de barras, que está demasiado perto do código de barras, em um ou ambos os lados, ou porque o código foi cortado pelo limite da imagem (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso).

  • Verificação da soma de verificação falhou (retângulo azul em torno do código). Razões comuns para a falha de validação da soma de verificação são mostradas a seguir (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso):

    • Código de barras danificado (os códigos de barras podem ser dobrados e alinhados de forma a que todos os caracteres de dados decodifiquem, mas ainda é uma não leitura, pois a verificação da soma não é transmitida)

    • É impresso um padrão incorreto (a cadeia codificada e o padrão de código de barras impresso não correspondem e se a simbologia suportar a soma de verificação, então o decodificador pode indicar essa falha)

Para além dos diagnósticos gráficos, a função Diagnósticos de símbolo mostra as métricas da capacidade de leitura para cada resultado sem leitura, exibidas no canto superior esquerdo dos códigos sem leitura. As métricas podem ajudar você a acessar à imagem ou à qualidade de impressão e ajudar no melhoramento da configuração existente.

A função Diagnósticos de símbolo somente está disponível para imagens PNG carregadas (Ações>Imagens>Carregar imagem), que são assinaladas por um leitor Cognex (não necessariamente o mesmo leitor; as imagens são assinaladas automaticamente quando salvas de qualquer leitor). Após carregar uma imagem, consulte o Painel de imagem ou a janela de Configuração rápida da imagem para retorno de Diagnósticos de símbolo.

Para além dos diagnósticos gráficos, a função Diagnósticos de símbolo mostra as métricas da capacidade de leitura para cada resultado sem leitura. Métricas como Contraste do símbolo e Contraste mínimo da borda podem ajudar os usuários a acessar à imagem ou à qualidade de impressão e ajudar a melhorar a configuração existente. As métricas são exibidas no canto superior esquerdo de cada código de barras sem leitura.

A tabela abaixo mostra um mapeamento entre o nome da métrica exibida e seu nome completo. Por favor consulte as Métricas da capacidade de leitura para entender o que cada métrica mede.

Nome completo | Nome exibido | Graus possíveis
Contraste do símbolo | C | A,B,C,D,F
Contraste mínimo da borda | EC | A,F
Crescimento da impressão | PG | A,F
Refletância mínima | MR | A,F

Observação: Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


O que são as Configurações da imagem visualizada?

As Configurações da imagem visualizada controlam como o leitor mostra as imagens adquiridas em resposta aos disparos de aquisição, assim como as imagens ao vivo obtidas de qualquer leitor. A alteração destas configurações não afeta o desempenho do leitor, mas afeta apenas a qualidade da imagem e a taxa de transferência entre o leitor e o Setup Tool.

OBSERVAÇÃO: Algumas propriedades relacionadas às imagens (por exemplo, tamanho da imagem e filtros) não podem ser alteradas quando o dispositivo está obtendo ou decodificando imagens.

OBSERVAÇÃO: As configurações da imagem exibida não têm efeito ao guardar a última imagem obtida a partir do Painel de imagens (através de arrastar e soltar). A última imagem é sempre salva em tamanho total (resolução máxima do dispositivo).

  • tamanho: Por padrão, o Setup Tool visualiza um terço de todos os pixels de cada imagem adquirida ou uma fração de cada imagem durante a Visualização ao vivo. A escolha entre os tamanhos da imagem permite ao leitor realizar uma subamostra de cada imagem, o que pode melhorar drasticamente a velocidade de transferência da imagem do leitor para o Setup Tool com o comprometimento de alguns detalhes da imagem.

  • formato: Por padrão, o leitor armazena cada imagem adquirida em um formato .jpeg, que necessita de menos memória e pode ser transferida do leitor para o Setup Tool mais rápido que uma imagem de formato .bmp.

  • qualidade: Disponível apenas se você estiver usando um formato de imagem .jpeg, este controle deslizante ajusta os parâmetros internos que permitem ao leitor realizar uma operação regular na imagem adquirida que pode reduzir ou melhorar a velocidade de transferência do leitor para o Setup Tool.


Como configurar a Imagem para usar?

Selecione Original ou Filtrada, de acordo com a imagem que deseja visualizar durante a Visualização ao vivo. Acesse o painel Filtro de imagem para acessar outras configurações.

OBSERVAÇÃO: Essa opção não existe em DM262.


Como mudar a intensidade dos LEDs de iluminação vermelhos?

Na caixa do grupo Iluminação, use o cursor Intensidade para mudar a intensidade dos LEDs de iluminação vermelho que o leitor usa para iluminar o símbolo sob verificação.

Observe que nem todas as plataformas e configurações de luz suportam o Controle de intensidade. Consulte a tabela abaixo sobre as configurações suportadas:

Plataforma | Controle de intensidade | Ligar/Desligar LED individual ou segmento | Comentário
DM50 | Sim | Não | Somente 1 LED vermelho
DM60 | Sim | Não |
DM70 | Não | Sim |
DM503 | Sim | Não | Iluminação externa


Por que caixa Luzes de alta frequência está desabilitada?

Para habilitar a função Luzes de alta frequência, altere as Configurações do processador de imagens para Exposição manual, altere o Tipo de disparo para Automático (interno) e altere o intervalo para um valor entre 16000 - 20000, 32000 - 34000 ou para qualquer valor acima de 64000.


Para que a opção "Sempre ligado" habilitada na caixa Luzes de alta frequência pode ser usada?

Se a iluminação interna estiver desativada e a opção Luzes de alta frequência estiver habilitada, você pode definir aqui um tempo de espera após o qual a luz de alta frequência será desativada se nenhum disparo ocorrer durante um longo período de tempo. O tempo de espera é especificado em segundos. A configuração do valor do tempo de espera para 0 desliga o manipulador de tempo de espera, assim, a luz ficará acesa permanentemente. A mudança do modo de operação ou ativação da visualização de imagem ao vivo desligará a luz de alta frequência.


Como usar uma fonte de iluminação externa?

  1. No passo Entradas / Saídas, na guia Saídas, marque Estroboscópio para uma linha de saída.
  2. No painel Configurações da iluminação e do processador de imagens, selecione Externa para o tipo de iluminação.

Para usar uma iluminação externa, conecte-a à saída selecionada como descrito no guia de consulta rápida.

  • A porta de saída deve ser conectada como Current Sink.

  • A saída comum deve ser conectada ao GND lógico.

  • O limite de corrente é de 50 mA @ 24 VCC.


Como usar uma fonte de iluminação externa?

  1. Na guia Saídas, no painel Configurações do sistema, marque Estroboscópio para uma linha de saída.

Para usar uma iluminação externa, conecte-a à saída selecionada como descrito no guia de consulta rápida.

  • A porta de saída deve ser conectada como Current Sink.

  • A saída comum deve ser conectada ao GND lógico.

  • O limite de corrente é de 50 mA @ 24 VCC.


O que acontece se eu usar um fonte de iluminação externa, juntamente com um estroboscópico conectado a uma das portas de saída?

Os sinais de saída da iluminação strobe aparecerão antes da saída de iluminação específica. A fonte de iluminação externa aparecerá com um atraso. Durante a aquisição da imagem, as duas iluminações estarão ligadas.


Em qual função o Tempo de pré-carga é usado?

Esta configuração é usada para o conector de iluminação específico e para uma E/S discreta, ambos configurados no painel Configurações do sistema.


Quais são as opções diferentes de iluminação externa para o Tempo de pré-carga?

  • Cognex externo: Luzes externas Cognex

  • Cognex HPIA: Cognex High Power Illumination Accessories (Acessórios de iluminação de alta capacidade)

  • Luzes de barra SVL: Smart Vision Lights Série YL, ODL e L

  • Luzes CCS: Luzes padrão CCS

  • Luz personalizada: qualquer iluminação externa


Para que é usada a configuração Filtro da tampa da frente?

É possível selecionar o tipo de tampa da lente usada atualmente a partir da caixa suspensa.


Como especificar uma região de interesse dentro de cada imagem adquirida?

Alterando suas configurações no subpainel Tamanho da imagem (região de interesse).


Marquei a opção "Transferir e visualizar imagens". Por que não visualizo uma imagem?

Se você interromper a transferência da imagem iniciando um disparo, então nenhuma imagem será transferida. Além disto, resultados antigos na grade Histórico de resultados da leitura podem não incluir imagens.


Quando usar o botão Aprender código?

Por padrão, o leitor irá tentar decodificar um símbolo usando todas as simbologias habilitadas no painel Configurações de simbologia. O botão Aprender código, que é habilitado apenas para modos de disparo único, burst, automático e contínuo, adquire e decodifica uma nova imagem, aprendendo os atributos do símbolo na imagem. O treinamento do leitor com a simbologia esperada pode diminuir o tempo necessário para decodificar os símbolos sucessivos, pois o leitor não precisa checar todas as simbologias habilitadas.

Se os símbolos que você deseja decodificar possuem uma simbologia consistente, use a função Aprender código. Saiba, entretanto, que o leitor falhará na decodificação de um símbolo se ele aparecer em uma simbologia diferente daquela que ele foi treinado para identificar. Clique no botão Desfazer treinamento do código para desabilitar o parâmetro de treinamento e permitir ao leitor verificar o próximo símbolo em todas as simbologias habilitadas.

Para treinar seu leitor a decodificar códigos múltiplos em uma única imagem, consulte a pergunta "Como realizar o treinamento quando desejo decodificar símbolos múltiplos?" em Configurações de simbologia para obter mais informações.


Por que um código com a mesma simbologia e tamanho de modelo do código treinado não é decodificado?

Verifique se o código que você treinou não é diferente do código que você quer decodificar em mais de 10% do tamanho.


O que é a Visualização ao vivo?

Se você habilitar a Visualização ao vivo (clicando no ícone Visualização ao vivo na barra de tarefas superior ou na guia Ação), a visualização da imagem exibe continuamente o que o leitor vê. Você pode usar este modo para verificar o que o leitor está vendo, sem tentar decodificar símbolos.

Para alterar a qualidade e o tamanho da imagem exibida ao vivo, acesse o painel Configurações da imagem visualizada.

OBSERVAÇÃO: Essa opção não está disponível em DM262 e DM362.


Como posso aumentar a velocidade de transferência da imagem?

Se a caixa de seleção Transferir e visualizar imagem estiver marcada, o Setup Tool transferirá a imagem adquirida para cada operação de decodificação. Se um novo disparo for recebido enquanto a imagem atual está sendo transferida, o leitor descartará a imagem transferida parcialmente e iniciará a transferência da nova imagem.

A velocidade de transferência da imagem depende do grau de compactação de imagem realizada pelo leitor. Controle o valor de compactação da imagem, selecionando a opção Configurações da imagem visualizada. A redução do tamanho da imagem ou da qualidade da imagem aumentará a taxa de transferência.


Como visualizar todas as imagens tiradas durante um disparo burst?

Para visualizar todas as imagens coletadas durante um disparo burst:

  1. Verifique se o tipo de disparo está configurado como burst.
  2. Marque a caixa de seleção Transferir todas as imagens.

O painel de Histórico de resultados conterá as imagens capturadas durante o disparo do burst. Para visualizar a tira de filme você deve clicar no resultado na grade Histórico de resultados da leitura.

O número de imagens irá corresponder ao Comprimento burst ajustado no painel de configurações da iluminação e do processador de imagens.


O que a função Transferir todas as imagens faz?

Marque a função Transferir todas as imagens para ver todas as imagens do burst associadas a cada disparo.

Quando marcadas, todas as imagens obtidas no modo Burst serão acessíveis no painel Histórico de resultados, independente de qualquer outra imagem com um resultado decodificado ou não.

Esta opção somente estará disponível se você selecionar o modo de disparo Burst no painel Configurações da iluminação e do processador de imagens.


Como é possível ajustar o foco do meu leitor?

Marque a opção Retorno do foco e clique em Visualização ao vivo. Conforme você movimenta o leitor, você verá uma coluna exibindo o valor de foco. A coluna poderá ter a cor vermelha, amarela ou verde, dependendo da precisão do foco. Quando a coluna estiver na cor verde, o código estará em foco e você poderá decodificar sua imagem (após parar a função Visualização ao vivo).

Verifique se a função Visualização ao vivo usa a opção Original e não usa a opção Imagem filtrada.

OBSERVAÇÃO: Esse recurso não é suportado no DM262.


O recurso Retorno do foco foi usado em um código Data Matrix; porém, o foco só fica nítido quando me aproximo. O que fazer?

Em primeiro lugar, verifique se a simbologia Data Matrix está habilitada. Em seguida, acesse Calibragem e clique em Calibragem. Os melhores parâmetros serão selecionados e você poderá decodificar sua imagem.


Como é possível ligar e desligar rapidamente todas as luzes do leitor?

Clique com o botão direito do mouse na imagem que exibe os quadrantes de luz. É possível selecionar estas opções:

  • Todos ligados

  • Todos desligados

  • Norte-Sul

  • Leste-Oeste

As alterações serão válidas imediatamente de acordo com a sua seleção.


Detalhes do código


Qual a maneira mais rápida para desabilitar todas as simbologias?

Clique em Desabilitar todas as simbologias na parte superior da guia Básicas, no passo do aplicativo Detalhes do código, ou pressione Ctrl+D.


Por que todas as caixas de seleção da simbologia estão desabilitadas?

Você pode treinar o leitor com a simbologia esperada para símbolos sucessivos. Se o leitor é treinado, você não pode mudar quais simbologias estão habilitadas ou desabilitadas. Você deve retirar o treinamento do leitor para habilitar e desabilitar várias simbologias.


Como ajustar as configurações avançadas de simbologia?

Clique na guia Avançadas em Detalhes do código para especificar configurações mais detalhadas.


O leitor discrimina automaticamente tipos de simbologia diferentes?

O leitor detecta e decodifica automaticamente símbolos codificados usando qualquer das simbologias habilitadas no Setup Tool.


Por que não posso alterar as simbologias? Por que está tudo acinzentado?

Somente é possível habilitar e desabilitar as simbologias nos modos de disparo Manual e Apresentação.


Por que são exibidas apenas as simbologias 1D?

Os leitores DataMan 50L e 60L não leem símbolos bidimensionais. Portanto, essas simbologias não aparecem no Setup Tool.


Quais métricas são suportadas para as simbologias individuais?

A tabela a seguir lista quais métricas são suportadas para as simbologias individuais.

Métrica | DataMatrix ISO/IEC 15415 | DataMatrix AIM-DPM | QR | PDF417 | Code 128, UPC/EAN, Code93, Code39, I2/5, Codabar, MSI
contraste de símbolo | x | x | x |  | x
UEC | x | x | x | x |
não uniformidade axial | x | x | x |  |
crescimento de impressão | x | x | x |  | x
modulação | x | x |  |  |
dano do padrão fixo | x | x |  |  |
não uniformidade da grade | x | x |  |  |
refletância extrema | x | x |  |  |
refletância mínima |  |  |  |  | x
contraste mínimo de borda |  |  |  |  | x
varredura única interna |  |  |  |  | x
varredura múltipla interna |  |  |  |  | x


O leitor melhora o desempenho limitando o número de simbologias habilitadas?

Para melhor desempenho, habilite apenas os tipos de simbologia que você esperar encontrar.


Como habilitar a decodificação VeriCode?

Para suportar a decodificação VeriCode, você deve ter uma licença VeriCode válida. Para carregar uma licença VeriCode, selecione Sistema->Licença do VeriCode e insira a cadeia de licença fornecida pela Veritec. Entre em contato com a Veritec para obter o código da licença em www.veritecinc.com.

Observação: O VeriCode não suporta a validação de dados ou a decodificação de códigos múltiplos.


Tipos de uso desabilitados em Propriedades DataMatrix

Os Tipos de uso ID Max estão desabilitados a não ser que você selecione o algoritmo ID Max do painel de Configurações de simbologia.

Os Tipos de uso ID Quick estarão desabilitados a não ser que você selecione o algoritmo ID Quick do painel Configurações de simbologia.

Tipos de uso ID Quick

Muitas aplicações podem usar o ajuste de Velocidade preferida para agilizar o tempo de decodificação. Escolha Rendimento preferido quando os símbolos que você deseja decodificar possam parecer falsos, distorcidos ou aparecer dentro de um plano de fundo não uniforme. A opção Estendido é usada para fazer a leitura de códigos DPM 2-D de alta qualidade, incluindo os símbolos de matriz de ponto.


Deformação de impressão em Propriedades DataMatrix

A Deformação de impressão permite que o leitor aceite um código mesmo que ele esteja deformado de algum modo. Use a opção Moderado (padrão), caso você tenha códigos de impressão irregulares ou se houver formas cilíndricas dos códigos de rótulos contínuos.


Dano do símbolo em Propriedades DataMatrix

O Dano do símbolo permite que o leitor aceite um código mesmo que ele esteja deformado de algum modo. Use Moderado (padrão) se precisar ler códigos que sofreram desgaste normal; use Extremo para habilitar o PowerGrid™, um avanço da tecnologia de leitura do DPM Data Matrix, se houver dano significativo nos modelos fixos do código devido à oclusão ou desgaste.

OBSERVAÇÃO: A habilitação do PowerGrid™ por meio da configuração Extremo requer a compra da licença correspondente.


Ignorar polaridade - Propriedades DataMatrix

Ignorar polaridade - Propriedades DataMatrix

Quando esta função estiver marcada, o dispositivo em estado treinado poderá ler os códigos com a polaridade oposta à polaridade usada para o código de treinamento.

Quando esta função estiver marcada, o dispositivo em estado treinado poderá ler os códigos com tamanho da grade um pouco diferente (+/- um nível) do tamanho de grade do código de treinamento. Ou seja, se você treinou um código 12x12 Data Matrix, por exemplo, com tamanho de grade flexível, você poderá escolher entre os códigos de tamanho 10x10 ou 14x14.


Propriedades DataMatrix: Apenas para os leitores DataMan modelo X

Métrica de controle do processo

Após você habilitar um dos grupos de métrica de controle do processo no painel Propriedades da Data Matrix, poderá usá-las na guia Métrica do painel Formatação padrão.

A métrica também é acessível por meio de scripts. Se você não habilitou nenhuma métrica de controle do processo, elas retornarão -1.

As métricas de controle do processo são -1 ou NA

Se a qualidade da impressão ou da imagem do símbolo for tão ruim que não é possível medir as métricas de controle do processo com um algoritmo de decodificação de referência, a métrica relatada será -1 ou NA. Você poder melhorar a qualidade de impressão ou imagem usando a função Filtro de imagem, por exemplo.


O que são as métricas de qualidade DataMatrix?

Para obter informações sobre as métricas de qualidade de código, consulte o Guia de programação e configurações do DataMan®.


Propriedades de simbologia 1D: O que é a função decodificação do alvo?

A decodificação do alvo simula o comportamento de um scanner de código de barras a laser. Em vez de olhar para todo o campo de visão, todavia, o leitor tenta decodificar os códigos de barra 1D que ficam apenas dentro das barras com alvo verde. Isto evita que o operador leia acidentalmente outros códigos de barra 1D que estejam ao redor.


Propriedades de simbologia 1D

Área silenciosa pequena

A opção Área silenciosa pequena, quando está habilitada, permite alguma flexibilidade de busca em relação à área silenciosa destes símbolos 1-D: Código 128, código 39 e código 93.

Códigos de pouca altura

Quando a opção Códigos de pouca altura está habilitada, ela melhora o desempenho de decodificação de símbolos que são muito curtos e largos.

Mudar Orientação

Como padrão, a orientação está configurada para Omnidirecional nos leitores DM300X, DM500QL, DM500X, DM503QL e DM503X.

A orientação está configurada para Horizontal (conforme o exemplo abaixo) como padrão nos leitores DM300L, DM500L e DM503L.

Orientação do código desabilitada

A orientação do código é desabilitada se o código 1-D foi treinado com o recurso Treinamento de orientação.

Métricas de controle do processo/qualidade do código para a formatação de dados

Depois que você habilitar as Métricas de qualidade 1-D no painel Qualidade do código (licença necessária), pode usar essas métricas na guia Métricas do painel Formatação padrão.

As métricas também são acessíveis por meio de scripts. Se você não habilitou nenhuma métrica de controle do processo, elas mostram -1.

As Métricas de controle do processo/qualidade do código relatadas são -1 ou NA

Se a qualidade da impressão ou da imagem do símbolo for tão ruim que não é possível medir as métricas de controle do processo com um algoritmo de decodificação de referência, a métrica relatada será -1 ou NA. Você poder melhorar a qualidade de impressão ou imagem usando a função Filtro de imagem, por exemplo.

Isso significa que os seus códigos devem estar alinhados nesta orientação, em ordem, para que sejam decodificados.

Mude a orientação para Vertical (conforme o exemplo abaixo), se os seus códigos estiverem perpendiculares ao sensor.

Isso significa que os seus códigos devem estar alinhados nesta orientação, em ordem, para que sejam decodificados.

Mude esta orientação para Vertical e Horizontal, caso seus códigos estejam alinhados à horizontal ou perpendiculares ao sensor.

Nos leitores DM300L, DM500L e DM503L apenas às orientações Vertical e Horizontal são suportadas.

Combinação de dados 1D

A combinação de dados 1D aumenta a eficiência de leitura mesclando e ampliando leituras parciais. O recurso fica ativo apenas se a licença 1DDataStitching estiver instalada.

Tipos de uso

A estratégia Estendido pode decodificar códigos de barras difíceis, mas leva mais tempo que a estratégia Padrão.


Propriedades de simbologia 1D: Como configurar a Decodificação mínima antes da saída?

Configure um número alto para aumentar a robustez da decodificação. Configure um número baixo caso a sua prioridade seja a velocidade de desempenho.


Vantagem de especificar um tamanho de código

A especificação de um tamanho de código explícito pode melhorar a habilidade do leitor de decodificar os símbolos com confiabilidade. Selecione Qualquer se você está lendo tamanhos de códigos diferentes.


Propriedades do código 39

  • O ASCII completo habilita os códigos 39 estendidos.

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.

  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.

  • Se marcada, a opção Converter para Código 32 converte o conjunto de caracteres do Código 39 para o Código 32.


Propriedades de Intercalado 2 de 5

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.

  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.


Propriedades do código 25

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.

  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.


Propriedades de Pharmacode

Vantagem de especificar um tamanho de código e uma orientação

Especificando um tamanho de código e orientação explícitos pode melhorar a habilidade do leitor para decodificar símbolos confiáveis.

O número dos caracteres de dados e o número de barras em qualquer símbolo

Caracteres de dados: Barras

  • 1: 3 Observação: o único código de caractere 1 que o leitor lê é o código com 3 barras ou mais. Isto significa apenas 6, 7, 8 e 9.

  • 2: 3 a 6

  • 3: 6 a 9

  • 4: 9 a 13

  • 5: 13 a 16

  • 6: 16


Propriedades da Codabar

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.
  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.
  • A opção Transmitir caracteres de início e de parada inclui os caracteres de início e de parada com os dados decodificados.


Propriedades MSI

  • A opção Caractere de verificação só decodifica símbolos com um caractere de verificação válido.
  • A opção Transmitir caractere de verificação inclui o caractere de verificação com os dados decodificados.
  • Método de cálculo de soma de verificação permite que você selecione o método usado para o cálculo da soma de verificação.


Propriedades da barra de dados

  • GS1 DataBar Limited: Codifica uma identificação de item EAN.UCC de 14 dígitos com dígitos indicadores de zero ou um em um símbolo linear para uso em itens pequenos que não serão lidos no ponto de venda

  • GS1 DataBar: Codifica a identificação do item EAN.UCC de 14 dígitos completo em um símbolo linear que pode ser digitalizado omnidirecionalmente pelos scanners programados adequadamente no ponto de venda

  • GS1 DataBar Expanded: Comprimento variável, versão expandida da simbologia capaz de codificar o GTIN de 14 dígitos e dados adicionais incluindo datas de vencimento, o país de origem e números de série – até 74 caracteres numéricos ou 41 alfabéticos.


Propriedades postais

  • POSTNET: A simbologia do código de barras que é usada no serviço postal dos Estados Unidos para ajudar a direcionar as correspondências. O cep ou código postal+4 está codificado nesta simbologia única que decodifica dados em barras de diferentes alturas.

  • PLANET: O código de barras da técnica de codificação alfa-numérica postal (PLANET) é usado para o serviço postal dos Estados Unidos identificar e pesquisar peças de correspondências durante a entrega. Como o POSTNET, ele codifica os dados em barras de diferentes alturas.

OBSERVAÇÃO: Os códigos postais somente podem ser decodificados quando apresentados em posição horizontal.


Versões do código de resposta rápida (QR) suportadas

O código de resposta rápida (QR) é uma simbologia 2D que contém uma sequência de módulos quadrados escuros e brancos usados para codificar dados. O leitor pode discernir entre três tipos diferentes:

  • modelo-1 Versão original

  • modelo-2 Versão melhorada

  • Código MicroQR: Um código QR muito pequeno que se encaixa em certas aplicações, necessitando de um espaço menor e usando quantidades menores de dados que outras versões de código QR


Propriedades do código QR

Ignorar polaridade

Quando esta função estiver marcada, o dispositivo em estado treinado poderá ler os códigos com a polaridade oposta à polaridade usada para o código de treinamento.

Tamanho da grade flexível

Quando esta função estiver marcada, o dispositivo em estado treinado poderá ler os códigos com tamanho da grade um pouco diferente (+/- um nível) do tamanho de grade do código de treinamento. Ou seja, se você treinou um código 25x25 QR, por exemplo, com tamanho da grade flexível, você poderá escolher entre os códigos de tamanho 21x21 ou 29x29.

Tamanho máximo da grade

O Tamanho máximo da grade permite decodificar códigos QR que maiores que o tamanho 49. Você pode arrastar o controle deslizante ou digitar um tamanho de código específico na caixa de texto à direita.

Métricas de qualidade do código QR

Para obter informações sobre as métricas de qualidade de código, consulte o Guia de programação e configurações do DataMan®.


Propriedades do código QR: Apenas para os leitores DataMan modelo X

Métricas de controle do processo para a formatação de dados

Após você habilitar a Métrica QR no painel Propriedades do código QR, use essas opções na guia Métrica no painel Formatação padrão.

A métrica também é acessível por meio de scripts. Se você não habilitou nenhuma métrica de controle do processo, elas retornarão -1.

As métricas de controle do processo são -1 ou NA

Se a qualidade da impressão ou da imagem do símbolo for tão ruim que não é possível medir as métricas de controle do processo com um algoritmo de decodificação de referência, a métrica relatada será -1 ou NA. Você poder melhorar a qualidade de impressão ou imagem usando a função Filtro de imagem, por exemplo.


Propriedades DotCode

Especificar o número de linhas e colunas de dados

A especificação do número mínimo e máximo de linhas e colunas de dados pode melhorar a capacidade do leitor de decodificar símbolos de forma confiável.

Configuração de polaridade

É possível configurar o que o dispositivo define como módulo (ponto) em relação a seu plano de fundo. A configuração Escuro no claro significa que o dispositivo faz a varredura e decodifica os pontos escuros em um plano claro, enquanto Claro no escuro significa o oposto (pontos claros em um plano de fundo escuro).

A configuração padrão Qualquer um faz a varredura de ambos os tipos de módulos, em seus respetivos planos de fundo, porém isso pode conduzir a uma decodificação um pouco mais lenta.


Qual é a diferença entre os algoritmos ID Max e ID Quick?

ID Quick fornece decodificação de alta velocidade dos símbolos que são bem formados e aparecem em alto contraste, enquanto o ID Max usa o processamento de imagem avançado e técnicas de análise para garantir maior capacidade de decodificação de códigos DPM produzidos por tecnologias a laser, sinal de ponto, ECE e jato de tinta.


Como habilito os resultados de códigos múltiplos?

Códigos múltiplos pode ser definido para todos os tipos de disparo, porém somente resultará em resultados de códigos múltiplos nos tipos de disparo Único, Manual, Burst e Contínuo. Os modos de disparo Apresentação e Automático mostrarão os códigos encontrados como resultados individuais.

Na guia Avançadas do passo do aplicativo Detalhes do código, especifique o número máximo de códigos em uma imagem com o campo Número de códigos. Você também pode especificar quantos tipos de cada símbolo deseja que o leitor decodifique, baseado em seu aplicativo. Para melhor desempenho, o Número de códigos para leitura deve ser igual à soma dos campos Número máximo de códigos das simbologias individuais (por ex., número total de 3, com Data Matrix definida com o valor 2 e 1D definido com o valor de 1). O número de códigos individuais para leitura não pode exceder o valor no campo geral Número de códigos.


Multicode

Permitir resultados parciais

Habilite Permitir resultados parciais para permitir que o leitor retorne um resultado de leitura com sucesso mesmo quando a imagem contém menos códigos que o Número de códigos especificado.

Permitir símbolos 1D idênticos

Habilite Permitir símbolos 1D idênticos para permitir ao leitor retornar resultados múltiplos em uma imagem, mesmo se o leitor detecta mais de um símbolo (na mesma imagem), com o mesmo comprimento, simbologia e cadeia de dados.

Permitir símbolos 1D idênticos aplica-se apenas a dois ou mais símbolos 1D idênticos que são exibidos em uma única imagem. O controle Permitir símbolos 1D idênticos não tem efeito sobre as imagens obtidas uma após a outra (independentemente do modo), mesmo se o mesmo símbolo idêntico for encontrado.

Prioridade de classificação

A lista para Prioridade de classificação permite que você determine como o leitor relata resultados múltiplos.

  • Use os botões Para cima e Para baixo para mover qualquer opção para uma prioridade maior ou menor.

  • Use o botão Inverso para inverter a ordem dentro de uma opção selecionada.

  • Saiba que as opções Posição (de cima para baixo ou da esquerda para a direita) se referem ao centro dos símbolos.

  • Use Ordem da imagem para os modos de disparo Burst ou Contínuo, onde os símbolos que são decodificados nas imagens anteriores são relatados antes dos símbolos decodificados nas imagens posteriores.


O Número máximo de códigos acinzentado nas funções Código QR/Código MaxiCode

É possível ler uma imagem de códigos múltiplos com um código MaxiCode, mas somente um código MaxiCode por imagem será decodificado. Isso significa que se você quiser ler uma imagem de códigos múltiplos com um código MaxiCode, terá que habilitar também a função Código QR na guia Geral.


Treinamento

Por padrão, o leitor tentará decodificar um símbolo usando todas as simbologias habilitadas na guia Geral. O treinamento do leitor com a simbologia esperada pode diminuir o tempo necessário para decodificar os símbolos sucessivos, pois o leitor não precisa checar todas as simbologias habilitadas. Saiba, entretanto, que o leitor falhará na decodificação de um símbolo se ele aparecer em uma simbologia diferente daquela que ele foi treinado para identificar.

Use a guia Treinamento para controlar o status das simbologias treinadas.

O Setup Tool desabilita as simbologias para as quais o leitor não está treinado, a menos que você desmarque a caixa de seleção Desabilitar as simbologias sem treinamento e habilitar Treinamento incremental.

Botão Aprender código

Clique em Aprender código no painel superior Ações depois de o leitor capturar uma imagem de um símbolo com uma simbologia que você espera encontrar em imagens sucessivas.

Se você está lendo apenas símbolos de uma simbologia em particular, clicando em Aprender código irá preparar o leitor para aquela simbologia em todas as imagens sucessivas até você clicar em Desfazer treinamento do código (você também pode encontrar o botão Desfazer treinamento do código no painel de Configurações de simbologia).

Depois de um treinamento com sucesso, a Informação do modelo para as simbologias treinadas irá exibir o tamanho esperado para os símbolos de entrada e o botão Desfazer treinamento do código é habilitado.

Treinamento quando desejo decodificar símbolos múltiplos

O Setup Tool permite que você treine o leitor a detectar mais que uma simbologia em aplicações, onde mais de um símbolo será decodificado.

Usando apenas uma única imagem contendo todas as simbologias esperadas, clique em Aprender código no painel superior Ações para treinar o leitor. A Informação do modelo para as simbologias treinadas irá visualizar o tamanho esperado para os símbolos de entrada e o botão Código não treinado irá ser habilitado.

Se você não pode apresentar uma única imagem mostrando todas as simbologias esperadas, marque a caixa Treinamento incremental e clique em Aprender código para as simbologias que estão presentes na imagem. Depois capture imagens de outras simbologias que você deseja treinar e clique em Aprender código para adicioná-los ao conjunto existente de simbologias que o leitor é treinado para decodificar. Com Treinamento incremental habilitado, você pode apresentar e treinar novas simbologias enquanto o leitor retém os parâmetros de treinamento existentes.

Treinamento de orientação

Apenas para símbolos 1D, Stacked e Postal, verifique a Treinamento de orientação para treinar o leitor com o ângulo do último símbolo codificado. Operações de decodificação subsequentes serão mais rápidas se os símbolos aparecerem no ângulo treinado.

OBSERVAÇÃO: Os códigos postais somente podem ser decodificados quando apresentados em posição horizontal.

Voltar o leitor para a decodificação de símbolos de qualquer simbologia depois do treinamento

Você deve clicar em Desfazer treinamento do código para qualquer simbologia treinada para permitir que o leitor decodifique qualquer símbolo independente da simbologia. Saiba, entretanto, que o símbolo deve estar habilitado na guia Geral para o leitor reconhecê-lo.

Treinamento de código manual

Se souber todos os parâmetros dos códigos para os quais irá treinar o dispositivo, você pode fornecer esses parâmetros em Treinamento de código manual. Após serem fornecidos todos os parâmetros, marque a caixa É válido para treinar o código. Doravante, você pode desfazer o treinamento do código, clicando acima, em Desfazer treinamento do código.


Como alterar a saída de caracteres ASCII não impressos para os equivalentes reconhecidos pelo teclado?

Acesse o painel Caracteres não imprimíveis em Configurações de comunicação e marque a opção Habilitado. Você também pode adicionar comandos ASCII não imprimíveis, antes e depois da cadeia convertida, habilitando a Formatação padrão e adicionando os comandos ASCII antes ou depois da cadeia completa.


Quais são os ajustes diferentes para as propriedades UPC/EAN?

  • Expandido habilita a decodificação dos símbolos expandidos.

  • Suplementar controla como o leitor decodifica os códigos suplementares.

  • Excluir os zeros à esquerda exclui os zeros à esquerda das cadeias decodificadas.

  • Permitir EAN8 suplementares habilita a decodificação dos códigos suplementares em símbolos EAN8.

  • UPCE1 habilitado habilita a decodificação dos símbolos UPC E1.


Propriedades UPC/EAN: O que a caixa de seleção Expandida significa?

Ela representa um valor booleano para indicar se a cadeia decodificada para UPC-EAN reportada deve ser expandida para um formato EAN13 de 13 dígitos ou transmitida no formato padrão UPC-E de 6 dígitos.

Quando marcada (padrão), a cadeia decodificada é transmitida no formato EAN-13, em 13 dígitos (p. ex. 0012345000065). Quando desmarcada, o resultado é transmitido como <sistema numérico> + 6 dígitos de dados + <caractere de verificação> (p. ex. 01234565).


Detalhes do aplicativo


O que posso configurar no passo Detalhes do aplicativo?

Na guia Básicas, podem ser definidas as configurações do disparo e as configurações de exposição. Para um uso fácil, um Assistente de disparo, um Assistente de intervalo e um Assistente de exposição ajudam-no com estas configurações.

Na guia Avançadas podem ser implementadas configurações mais detalhadas em visualização de tabela.


Assistente de disparo

Você precisa selecionar primeiro o tipo de disparo para que este assistente funcione. Selecione a fonte do disparo a partir da lista suspensa: Indefinido, Nenhum ou Externo. Você recebe uma recomendação do assistente para os modos de disparo. As apresentações gráficas dos tipos de disparo ajudam-no a decidir. Selecione o tipo de disparo escolhido e clique em Salvar e fechar.


Assistente de intervalo

No caso dos modos Burst, Automático e Contínuo, o Assistente de intervalo pode ajudá-lo a efetuar configurações mais detalhadas. Você pode selecionar três maneiras de calcular os dados necessários. No canto superior direito, selecione as unidades (padrão ou métricas) em que você deseja calcular.

Clique em Campo de visão para calcular o tempo de intervalo mais longo possível, medindo o campo de visão físico e inserindo a velocidade linear máxima e o tamanho do código mais longo.

Clique em Lente / Distância até o código se você desejar inserir a distância do código a partir da lente. Insira a distância focal a partir da caixa suspensa e selecione a direção na qual o código está se deslocando. Você também precisa inserir aqui a velocidade linear máxima e o tamanho do código mais longo.

Clique em Tamanho do elemento de código para calcular com o tamanho do elemento de código mais restrito. Habilitar o Modo de teste para ler seu código. Você também precisa inserir a direção na qual seu código está se deslocando, a velocidade linear máxima e o tamanho do código mais longo.

No lado inferior do Assistente, você pode obter o tempo de intervalo máximo recomendado.


Assistente de exposição

O Assistente de exposição é muito semelhante ao Assistente de intervalo. Você pode selecionar as mesmas três maneiras para seus cálculos: tamanho do campo de visão, distância até o código e tamanho do elemento de código.

Clique em Campo de visão para calcular o tempo de exposição máximo recomendado, medindo o campo de visão físico e inserindo a velocidade linear máxima. Você pode habilitar o Modo de teste para ler seu código menor.

Clique em Lente / Distância até o código se você desejar inserir a distância do código a partir da lente. Insira a distância focal a partir da caixa suspensa e selecione a direção na qual o código está se deslocando. Você também precisa inserir aqui a velocidade linear máxima.

Clique em Tamanho do elemento de código para calcular com o tamanho do elemento de código mais restrito. Habilitar o Modo de teste para ler seu código. Você também precisa inserir a direção na qual seu código está se deslocando e a velocidade linear máxima.

No lado inferior do Assistente, você pode obter o tempo de exposição atual e o recomendado.


Como as Configurações múltiplas de leitura interagem com a configuração de Tempo de espera?

Quando a opção Configurações múltiplas de leitura estiver habilitada, o tempo de espera afetará cada configuração individualmente, e não todas as configurações de maneira geral. O resultado é que o tempo total gasto na leitura em um ciclo do disparo será o produto do número de configurações habilitadas e o tempo de espera.


Mais imagens serão obtidas quando ocorrer uma leitura válida?

Não, imagens adicionais serão obtidas conforme as leituras de configurações anteriores falharem. Se uma configuração produzir uma imagem válida, o leitor não tentará outras configurações durante este ciclo do disparo e a decodificação começará. O leitor testará cada configuração habilitada em ordem de prioridade, começando pela configuração de prioridade mais alta especificada e avançando até que uma leitura válida seja adquirida.


Quais são os tipos de disparo?

Os disparos que iniciam uma tentativa de decodificação podem vir de uma fonte externa ao leitor ou são gerados por um mecanismo interno de temporização do próprio leitor.

Qualquer um dos seguintes eventos sinaliza o leitor para realizar uma tentativa de decodificação quando ele está configurado para responder a um disparo externo:

  • Enviando o comando de controle Disparo do DataMan (DMCC) quando conectado ao leitor por uma conexão USB, serial ou de rede

  • Recebendo um sinal digital de entrada nas portas do disparo do cabo de E/S

  • Clicando no botão Disparo no Setup Tool

  • Pressionando Ctrl+T no teclado quando o Setup Tool obtiver o foco

Você pode configurar o leitor com qualquer um dos tipos de disparo a seguir, em resposta a um evento externo:

  • O disparo Único adquire uma imagem única e tenta decodificar qualquer símbolo que possa conter. Este modo de disparo aceita um tempo limite de leitura.

  • O disparo Manual adquire imagens enquanto o sinal do disparo continuar ativo e para quando um símbolo é encontrado e decodificado ou quando o sinal do disparo acaba. Este modo de disparo não aceita um tempo limite de leitura.

  • O disparo Burst adquire um número definido de imagens e decodifica o primeiro símbolo que é detectado dentro do grupo. Você pode configurar o número de imagens dentro de cada burst assim como o intervalo entre cada aquisição de imagem. Este modo de disparo aceita um tempo limite de leitura. O tempo limite é o período de tempo que o burst ficará em cada imagem e não é o tempo do burst total.

  • O disparo Contínuo adquire imagens enquanto o sinal do disparo permanecer ativo, quando o leitor adquire imagens em um intervalo específico e tenta fazer a leitura de qualquer símbolo que cada imagem sucessiva contenha. Se um símbolo é decodificado, o leitor para de aceitar o sinal do disparo. Se nenhum símbolo é decodificado, a aquisição de imagem continua enquanto o sinal do disparo continuar ativo. Se o sinal do disparo parar e não houver sido feita a leitura e decodificação de nenhum símbolo, o leitor retornará um resultado de Sem leitura.

    Se você configurar o leitor para ler símbolos múltiplos, então o leitor não irá parar de adquirir imagens depois que for feita a leitura e decodificação do primeiro símbolo, mas continuará a leitura dos símbolos até que o número desejado de símbolos seja detectado ou o sinal do disparo pare. Se o sinal do disparo terminar antes que o número desejado de símbolos tenha sido localizado e decodificado, o leitor retornará um resultado de Sem leitura.

    Você pode controlar o intervalo entre a aquisição de imagens e especificar o atraso entre quando o sinal do disparo chega e quando o leitor inicia a aquisição de imagem. No modo de disparo contínuo, o intervalo do disparo indiretamente especifica o tempo limite de leitura.

Os tipos de disparo remanescentes não necessitam de um evento externo mas começam a adquirir imagens assim que você os seleciona:

  • O disparo de Apresentação busca continuamente por um símbolo e decodifica-o cada vez que um é detectado.

    Você pode especificar vários parâmetros no modo de apresentação, como se o leitor irá ler o mesmo código mais de uma vez ou por quanto tempo o leitor deve aguardar antes de ler o próximo símbolo. Use as opções Configurações de decodificação no painel Configurações do sistema para configurar o disparo de apresentação.

    No modo de apresentação, use as configurações de Exposição automática para fazer com que o leitor determine as melhores configurações de exposição para um nível desejável de brilho na imagem. Observe, entretanto, que o leitor usa as imagens iniciais adquiridas para determinar estas configurações, e pode perder imagens que contenham um símbolo para decodificação. Você pode mudar para configurações de Exposição manual e especificar uma configuração precisa para a exposição da câmera.

    Saiba que durante uma tentativa de decodificação para qualquer imagem em particular, todas as imagens subsequentes adquiridas durante aquele momento são descartadas.

    Este modo de disparo não aceita um tempo limite de leitura.

  • O disparo Automático é similar ao disparo de Apresentação, no qual o leitor busca continuamente por códigos e os decodifica assim que um deles for encontrado. Entretanto, diferentemente do modo de apresentação, uma tentativa de decodificação ocorre com todas as imagens e o leitor desabilita as configurações da Exposição automática que lhe determinam automaticamente o melhor ajuste de exposição para um nível desejável de brilho na imagem.

    Você pode especificar vários parâmetros no modo de disparo Automático, por exemplo, se o leitor irá ler o mesmo código mais de uma vez ou por quanto tempo o leitor deve aguardar antes de ler o próximo código. Use as opções Configurações de decodificação no painel Configurações do sistema para configurar o modo de disparo automático. No modo de disparo automático, o intervalo do disparo indiretamente especifica o tempo limite de leitura.


Quais são as configurações avançadas que podem ser configuradas para o disparo?

Se a caixa de seleção Nunca ler o mesmo código duas vezes for marcada, o leitor será impedido de ler o mesmo código duas vezes em um único ciclo do disparo. Se a caixa de seleção Nunca ler o mesmo código duas vezes for desmarcada, o leitor relerá e retransmitirá o mesmo código depois do Atraso da releitura do código especificado (em milésimos de segundo).

A opção Atraso da releitura do código (em milésimos de segundo) permite especificar o atraso entre as tentativas de leitura. A especificação de um valor diferente de zero para este atraso pode ajudar a evitar que os dados confundam o dispositivo que está conectado ao leitor.


Qual é a diferença entre a opção Após a primeira leitura e Após atraso da última leitura?

O atraso Após a primeira leitura começa a contar após a primeira vez que um determinado código é lido; o cronômetro não reinicializa. Isso significa que um código pode ser lido novamente se o leitor for disparado em um modo de várias imagens, como contínuo, e se o código permanecer na frente do leitor por um tempo igual ou superior ao Atraso da releitura.

Após a última leitura redefine o cronômetro a cada vez que um determinado código é exibido em uma imagem. Isso significa que o código não será lido novamente, desde que permaneça em frente ao leitor. Somente quando o código for removido do campo de visão do leitor durante um tempo igual ou superior ao Atraso da releitura do código o código será lido novamente.


Meu código é lido duas vezes se eu disparo o leitor novamente. Por quê?

As opções Atraso da releitura e Nunca ler o mesmo código duas vezes afetam apenas aquisições realizadas dentro de um único ciclo do disparo. O disparo do leitor zerará os cronômetros e o último código de leitura da opção Nunca ler o mesmo código duas vezes.


O que faz a opção Nunca ler o mesmo código duas vezes?

A opção Nunca ler o mesmo código duas vezes suprime o relatório da mesma cadeia de códigos duas vezes seguidas e dentro de uma sequência única de disparo, quando habilitada. Está disponível para todos os modos de disparo, mas só é válida na Leitura de códigos múltiplos, pois a única forma de obter mais do que um código em uma sequência única de disparo é em leituras de códigos múltiplos. Se a caixa de seleção Nunca ler o mesmo código duas vezes for desmarcada, o leitor relerá e retransmitirá o mesmo código depois do Atraso da releitura do código especificado (em milésimos de segundo).


Como a opção Nunca ler o mesmo código duas vezes funciona em um sistema mestre/escravo?

Se a opção Nunca ler o mesmo código duas vezes for especificada no mestre e o escravo ler o mesmo código, o mestre considerará todos os resultados e filtrará as leituras duplicadas independentemente da origem.


O que são Modo de atraso e Atraso da releitura do código?

A opção Modo de atraso define o atraso de releitura do código em relação à primeira leitura ou à última.

A opção Atraso da releitura do código (em milésimos de segundo) permite especificar o atraso entre as tentativas de leitura. A especificação de um valor diferente de zero para este atraso pode ajudar a evitar que os dados confundam o dispositivo que está conectado ao leitor.


Qual é a função de Não reler últimos códigos N?

Quando usada, a opção Não reler últimos códigos N previne que o dispositivo leia códigos que foram lidos nas últimas leituras “N”. Você deve atribuir “N” na caixa abaixo, de outra forma (se o número for 0), a opção está desabilitada. A opção aplica-se a todos os códigos lidos dentro de uma sequência de disparo.


O que é a Detecção de movimento?

A Detecção de movimento permite que os usuários configurem seu dispositivo para que ele comute para Apresentação ativa ou modo de disparo Automático, por um período de tempo, após ele detectar movimento no campo de visão do dispositivo.

As configurações da Detecção de movimento somente estarão disponíveis se o tipo de disparo estiver definido para Apresentação ou Automático. Quando a Detecção de movimento está habilitada, o dispositivo não está obtendo imagens, mas detecta no plano de fundo se o cenário em seu campo de visão está em movimento ou não.

Se ele estiver em movimento, o dispositivo adquire imagens ativamente segundo o modo de disparo de Apresentação ou Automático. A configuração Tempo de espera permite que você especifique o período de tempo (em segundos) após o qual o dispositivo comuta novamente para a Detecção de movimento a partir do disparo ativo, porém esse Tempo de espera reinicializa cada vez por meio do movimento ou de uma boa leitura.

A Sensibilidade de detecção de movimento pode ser configurada para definir como o dispositivo reconhece os movimentos substanciais, para ligar os modos de disparo de Apresentação e Automático ativos.


Como enviar um disparo pelo teclado?

Pressione <ctrl>-T (A janela do Setup Tool deve estar ativa).


Por que meu DataMan retorna vários resultados em resposta a um único disparo?

Isso pode ocorrer quando a entrada do disparo do hardware estiver sendo utilizada, pois o sinal na linha está oscilando em torno do seu valor final e o leitor interpreta as oscilações como sinais separados do disparo. O aumento do Atraso do debounce no painel Configurações do sistema, na guia Entradas pode fazer com que o leitor interprete todas as oscilações como um sinal único do disparo.


O que são os atrasos do disparo e valores de tempo limite?

No grupo Atraso do disparo, é possível definir o tempo do Tipo de atraso e especificar o início e o fim dos milésimos de segundos de espera necessários, antes de iniciar uma aquisição de imagem após o leitor receber um disparo. O uso do atraso pode ser útil quando você sabe que o leitor recebe um disparo antes de o símbolo estar completamente sob o campo de visualização. Apenas os tipos de disparo Único, Burst e Contínuo suportam um atraso.

Os modos Único e Burst têm Tempo de atraso inicial, mas não têm Tempo de atraso final. O modo Contínuo tem todos os tipos de atraso disponíveis.

O valor Tempo limite especifica uma quantidade fixa de tempo que o leitor tentará decodificar qualquer símbolo detectado. Se o leitor não conseguir decodificar o símbolo dentro deste período de tempo, ele retornará o status Sem leitura, como se a imagem não contivesse nenhum símbolo detectável. Se o tempo limite não for especificado, o desempenho talvez seja afetado, pois o leitor tentará decodificar qualquer código na imagem atual, antes de seguir para a próxima imagem.


Como ajustar a exposição da imagem?

Os tipos de disparo manual e de apresentação usam as configurações de Exposição automática para determinar automaticamente as melhores configurações para um nível desejado de brilho em cada imagem. Em qualquer um destes tipos de disparo, você pode usar os ajustes Exposição máxima da forma necessária para seu ambiente de produção ou selecionar Exposição manual e ajustar um tempo de exposição preciso, em microssegundos.

Com Exposição manual, você pode clicar em Otimizar brilho no painel Histórico de resultados para gerar um valor fixo para o ajuste de exposição limitado pelo valor Exposição máxima. A configuração Fator de ganho máximo é usada para definir o brilho máximo do pixel do alvo.


Como determinar os melhores parâmetros para o tipo de disparo burst?

Já que um disparo burst é ideal para aplicações em movimento, é necessário determinar o tamanho correto do burst e o intervalo, de forma a capturar o comprimento desejado do código enquanto ele se move sob a câmera. Uma vez que o tempo de intervalo seja determinado, você pode ajustar o tamanho do burst dependendo do comprimento do código. As variáveis necessárias para este cálculo são:

  1. Velocidade linear em mm por segundo

  2. Tamanho do código c/área livre em mm

  3. FOV = Campo de visualização (x ou y) em mm

Você pode então usar a seguinte equação para determinar o tempo de intervalo:

Tempo de Intervalo = 1000 X ((FOV – 2(Tamanho do código)) / Velocidade linear)

Uma vez que o tempo de intervalo é determinado, o tamanho do burst pode ser ajustado dependendo do comprimento do código a ser capturado. O comprimento máximo do objeto em mm é:

Tamanho do burst X (FOV – (2 X Tamanho do código))

A variável (2 X tamanho do código) permite a sobreposição dos quadros obtidos. Isto leva em consideração a condição onde o código está levemente fora do campo de visualização em um quadro (aquisição). A variável (2 X tamanho do código) irá sobrepor o campo de visualização entre os quadros sucessivos e permitir que o código seja visualizado no campo de visualização do próximo quadro.


Como ajustar um comprimento de burst mais longo?

O comprimento burst máximo que você pode especificar depende dos recursos disponíveis no dispositivo. Por padrão, o comprimento de burst máximo é de 202 imagens, mas você pode melhorar isto aumentando a memória para armazenar imagens capturadas pelo leitor. Aumente a memória disponível para o armazenamento de imagens burst, reservando os slots de imagem que estão atualmente dedicados para a elevação de imagem e aumentando o tamanho do campo de visão do processador de imagem. Isto pode ser realizado através do painel tamanho da imagem (região de interesse):

  1. Selecione o painel tamanho da imagem (região de interesse).
  2. Marque a caixa de seleção Campo de visão do processador de imagens (nos modos de disparo único, burst e contínuo) e reduza o tamanho do Campo de visão do processador de imagens.

Uma vez reduzido, você pode aumentar o parâmetro de comprimento do burst no passo Detalhes do aplicativo.


Como calcular o valor de intervalo para os modos de disparo automático e contínuo?

O Assistente de intervalo ajuda-o a calcular estes dados. Clique no Assistente de intervalo para um modo fácil e assistido.

Uma vez que os modos de disparo automático e contínuo podem ser usados para aplicações em movimento, é necessário determinar o tamanho do intervalo correto de forma a capturar o comprimento desejado do código enquanto o mesmo se move sob a câmera. As variáveis necessárias para este cálculo são:

  1. Velocidade linear em mm por segundo

  2. Tamanho do código c/área livre em mm

  3. FOV = Campo de visualização (x ou y) em mm

Você pode então usar a seguinte equação para determinar o tempo de intervalo aproximado:

Intervalo = 1000 X ((FOV – 2(tamanho do código)) / velocidade linear)

A variável (2 X tamanho do código) permite a sobreposição dos quadros obtidos. Isto leva em consideração a condição onde o código está levemente fora do campo de visualização em um quadro (aquisição). A variável (2 X tamanho do código) irá sobrepor o campo de visualização entre os quadros sucessivos e permitir que o código seja visualizado no campo de visualização do próximo quadro.


Quando alterar a exposição máxima?

Reduza o valor da exposição máxima quando você tiver que ler objetos em movimento.


O que o gráfico mostra?

O gráfico mostra o nível atual de cada nível de brilho de cada configuração de iluminação.


O que representam os pontos coloridos em Melhores resultados?

Os pontos representam um conjunto de resultados do gráfico acima.


Deve-se selecionar uma imagem das imagens calibradas?

Quando a calibragem estiver concluída, o Setup Tool exibirá três candidatos ou menos. O melhor será selecionado automaticamente e será aplicado à memória não volátil, porém você também pode selecionar e aplicar um dos outros candidatos.


O que acontece se eu quiser usar a calibragem em configurações de códigos múltiplos?

Se você tiver mais de um código no campo de visão, a calibragem só funcionará em um dos códigos.


A mensagem "Falha. Símbolo não encontrado." será exibida. O que fazer?

Acesse as Configurações de simbologia e habilite a simbologia ou as simbologias que você gostaria de decodificar.


Dados do formato


Como a formatação de dados trabalha?

No painel Básicas você pode selecionar que tipo de formatação pretende usar.

Você usa o painel Padrão para construir uma cadeia de saída personalizada, usando os blocos de criação predefinidos nas guias de simbologia individual:

  • A cadeia de saída inicia com qualquer texto que seja inserido no campo Texto principal.

  • Selecione os itens das listas nas guias Geral, Validação e (quando aplicável) Métricas e clique em Adicionar para adicioná-los à cadeia de saída. Para adicionar um intervalo específico de caracteres a partir do dado decodificado, clique em Ajuste o intervalo da subcadeia, depois insira o intervalo de caracteres a adicionar (assim como 1-3,5,8,10-), depois clique em Subcadeia na lista e clique no botão Adicionar.

  • A cadeia de saída inclui também qualquer texto que você adiciona ao campo Texto de finalização.

  • Para terminar toda a cadeia com um retorno de carro/alimentação de linha, marque a caixa de seleção Retorno de carro/aliment. de linha.


Por que existem guias diferentes embaixo da guia Padrão?

Você pode especificar a formatação separadamente para os tipos de simbologia diferentes ou usar a guia Universal para especificar a formatação de dados para algum símbolo decodificado, que tem precedência sobre as guias para os tipos de simbologia específicos.


Como posso usar a formatação universal e a simbologia específica?

O painel Formatação padrão emprega os seguintes critérios quando usa as guias específicas de simbologia e a guia Universal:

  • Cada resultado individual passará através do formatador específico da simbologia, se habilitado. Os resultados múltiplos de mesma simbologia serão formatados separadamente com as configurações idênticas.

  • Se a guia Universal for habilitada, os resultados individuais passarão pelo formatador específico de simbologia, se habilitado, e depois serão aumentados com a formatação das regras na guia Universal. Para resultados múltiplos (nos leitores suportados), os resultados serão concatenados e separados pelo delimitador escolhido, sem qualquer delimitador extra no final. A cadeia concatenada será tratada como uma cadeia simples para as regras de formatação restantes na guia Universal.

  • Para resultados múltiplos, a ordem dos resultados em uma cadeia concatenada é 1) DataMatrix 2) Código QR 3) Códigos 1D 4) Vericode 5) DotCode 6) OCR.

  • Qualquer token adicionado à formatação específica de simbologia, que é válido apenas para o processo de decodificação geral (assim como o tempo de decodificação ou índice do disparo), informará este valor global.


Quais dados são enviados se a Formatação padrão não estiver habilitada?

O leitor transmite toda a cadeia decodificada seguida pelo par de retorno de carro/alimentação de linha.


Como enviar apenas os dados decodificados sem o par de retorno de carro/alimentação de linha?

Habilite a formatação, adicione a Cadeia completa na cadeia de saída e certifique-se que a caixa de seleção Retorno de carro/aliment. de linha não está marcada.

Para enviar apenas o retorno do carro, entrar \r no campo Texto de finalização.


O que é Série de entrada?

Série de entrada é um token de formatação que você pode incluir como parte das propriedades do leitor na formatação baseada em script ou como um símbolo de Formatação de dados padrão. Observe que você não pode alterar nenhuma outra propriedade da série de entrada no Setup Tool; os parâmetros dela estão disponíveis apenas em DMCC.


Como impedir o Excel de saltar as células?

Como padrão, o leitor acrescenta o par retorno de carro/alimentação de linha depois de cada código transmitido. Quando você usa uma conexão de teclado para inserir os códigos transmitidos em Excel, o par de retorno de carro/alimentação de linha faz com que Excel avance por duas linhas depois de cada código. Para evitar que isto aconteça, configure o leitor para enviar apenas o retorno de carro:

  1. Clique em Formatação padrão.

  2. Especifique a simbologia que você está usando nas guias de Simbologia.

  3. Marque a caixa Formatação habilitada.

  4. Clique em Cadeia completa na guia Geral.

  5. Clique em Adicionar.

  6. Em Texto de finalização, insira \r no campo de texto e desmarque a caixa Retorno de carro/aliment. de linha.


Como fornecer elementos específicos dos dados codificados quando a validação de dados é habilitada?

Primeiro, selecione o tipo de validação necessário no painel Validação de dados. Habilite a Formatação básica na guia Básicas do passo do aplicativo Dados do formato. Selecione a guia Validação da guia Padrão e depois adicione o(s) campo(s) de dados desejado(s) para a cadeia de saída, incluindo o identificador da empresa, número de série, número de peça, item único e identificadores do aplicativo GS1.


Quais são as opções individuais na guia Geral, no campo Dados da guia Padrão?

  • Subcadeia: Uma subcadeia de caracteres codificados no símbolo. Especificar um intervalo na subcadeia para usar esta opção.

  • Cadeia completa: Todos os caracteres codificados no símbolo

  • Tempo de decodificação: A quantidade de tempo, em milésimos de segundos, que o leitor leva para decodificar o símbolo. Este período de tempo não inclui a aquisição de imagem, processamento da imagem pendente, tempo de comunicação e processamento adicional (por exemplo, formatação de dados).

  • Tempo do disparo: A quantidade de tempo, em milésimos de segundos, entre o momento que o disparo foi recebido e quando a operação do decodificador foi completada.

  • Simbologia: A simbologia do símbolo decodificado

  • Retorno de carro/aliment. de linha: Retorno do carro com uma alimentação de linha

  • INDICADOR: Um caractere do indicador.

  • SP: Um caractere do espaço.

  • Identificador da simbologia: O identificador da simbologia como especificado pela ISO/IEC 15424:2008

  • Tamanho do módulo: A largura (ou altura), em pixels, de cada módulo no símbolo

  • Posição do código: As coordenadas da imagem de cada canto do símbolo decodificado

  • Orientação do código: A orientação, indicada em graus, do símbolo decodificado. Rotações no sentido horário do símbolo decodificado são consideradas mudanças positivas na orientação.

  • Contraste: Um valor, entre 0 e 1, para indicar a quantidade total de contraste no símbolo decodificado. Um valor alto indica que os módulos escuros e iluminados no símbolo possuem um intervalo de valores cinza, enquanto um valor baixo indica que os módulos escuros e iluminados apresentam valores cinzas similares.

  • UEC: A quantidade de correções de erro não usadas disponíveis no símbolo. Correção do erro é um método de reconstrução ou substituição de dados que são perdidos através de danos no símbolo. Um valor de "100" é ideal. A simbologia 1D sempre -1.

  • Série de entrada: A série de entrada (serial ou Ethernet) recebida.

  • Tempo de filtro: A duração da filtragem em milésimos de segundo (ms).

  • Origem do resultado: O nome do dispositivo.

Todos os valores a seguir aumentarão independentemente de o leitor estar ou não conectado ao Setup Tool.

  • Total de leituras: Número total de símbolos decodificados

  • Total de imagens sem leitura: Número de vezes que o disparo foi recebido mas nenhum símbolo foi decodificado

  • Total de disparos: Total de disparos= Total de leituras + Total de imagens sem leitura + Total de disparos perdidos

  • Disparos perdidos: Número de disparos perdidos porque nenhum buffer de imagem estava disponível quando o disparo foi detectado

  • Índice do disparo: Número total de disparos detectados pelo leitor.

Os valores que serão redefinidos para 0 quando a opção Estatística do processo for apagada do painel Monitor de processo ou após a reinicialização do leitor são os seguintes:

  • Total de leituras

  • Total de imagens não lidas

  • Total de disparos

  • Disparos ignorados

O Índice do disparo será redefinido para 0 somente após a reinicialização do leitor, mas não depois que a opção Estatística do processo for apagada.


Como simular combinações com a tecla Alt, Ctrl ou Shift?

Para usar este recurso, estão disponíveis quatro sequências de escape, \ALT-, \CTRL- \SHIFT- e \K. \ALT- é usado para sequências de tecla ALT, \CTRL- é usado para sequências de tecla CTRL>, \SHIFT- é usado para sequências de tecla SHIFT e \K para teclas especiais. Observe que a tecla depois da barra invertida precisa estar em letra maiúscula, caso contrário nenhuma combinação especial de teclas será reconhecida.

As sequências são inseridas nos campos Texto principal/Texto de finalização do painel Padrão.

Sequências especiais do teclado suportadas

O seguinte formato deve ser usado:

\ALT- seguido pelo nome da tecla, seguido por ;

ou

\CTRL- seguido pelo nome da tecla, seguido por ;

ou

\SHIFT- seguido pelo nome da tecla, seguido por ;

ou

\K seguido pelo nome da tecla, seguido por ;

A terminação em ponto e vírgula é necessária para se poder distinguir entre as sequências com o mesmo prefixo, de outra forma as sequências chave podem ser interpretadas arbitrariamente, por exemplo, não seria possível saber se \KF11 significa "pressione F11" ou "Pressione F1 seguido por um 1".

Certifique-se que caso estas duas sequências de escape estejam inseridas na guia Universal, elas também sejam aplicadas aos resultados não lidos.

Sequências de teclas e teclas suportadas

A lista a seguir contém as teclas/combinações de teclas suportadas atualmente:

  • ALT-A a ALT-Z

  • CTRL-A a CTRL-Z

  • CTRL-F1 a CTRL-F12

  • SHIFT-F1 a SHIFT-F12

  • F1 a F12

  • ALT-F1 a ALT-F12

  • Teclas PageUp, PageDown, Home, End, Seta (para cima, para baixo, esquerda, direita), Insert, Delete, Backspace, Tab, Esc, Print Screen, GUI (esquerda, direita)

    As sequências de escape para estas são:

    • PageUp -> \KPup;

    • PageDown -> \KPdn;

    • Home -> \KHome;

    • End -> \KEnd;

    • Seta para cima -> \KUar;

    • Seta para baixo -> \KDar;

    • Seta esquerda -> \KLar;

    • Seta direita -> \KRar;

    • Insert -> \KIns;

    • Delete -> \KDel;

    • Backspace -> \KBksp;

    • Tab -> \KTab;

    • Esc -> \KEsc;

    • Print Screen -> \KPrtScr;

    • Left GUI -> \KLGui;

    • Right GUI -> \KRGui;

  • Pause output -> \KPAUSE;

Aqui estão alguns exemplos:

  • Para gerar a sequência <ALT-V>, use \ALT-V;

  • Para simular a tecla <F10> pressionada, use \KF10;

  • Para simular a tecla <Home> pressionada, use \KHome;

  • Para habilitar/desabilitar a barra de status no bloco de notas (<Alt-v><s>), a sequência deve ser \Alt-v;s

Se uma sequência errada ou incompleta é usada, os dois caracteres que marcam a sequência de escape são ignorados. Neste caso, as primeiras duas letras da sequência de escape são puladas e os caracteres remanescente serão enviados. Por exemplo, a sequência "\ALT-M11;" é inválida e irá resultar na visualização de "LT-M11;"


Como testar minha formatação de dados?

Use o botão Testar na parte inferior da página para testar como o resultado será exibido.

Leia um símbolo e visualize o resultado formatado na barra de status. Você também pode selecionar o painel Histórico de resultados e ler um símbolo. O Histórico de resultados mostra os resultados da formatação especificada.


Qual é a característica das Opções de saída?

As características das Opções de saída possibilitam que você defina os elementos de dados de saída desejados em diferentes formatos. Como exemplo, se uma vírgula é selecionada e você selecionou um resultado de saída de uma cadeia completa, seguida do tipo de simbologia, o resultado será uma cadeia de dados completa, seguida por uma vírgula, seguida pelo texto "Datamatrix". Para testar resultados diferentes, você pode selecionar um tipo de resultado em particular e depois selecionar o botão teste para ver a saída na janela de visualização adjacente. Observe que se a validação de dados é selecionada e um código falha na validação de dados, as características das opções de saída não serão habilitadas.


Por que o botão Testar está esmaecido?

Você pode testar seu código somente após a primeira decodificação bem-sucedida.


É possível especificar os caracteres usando códigos ASCII hexadecimais ou octal?

Nos campos Texto principal e Texto de finalização, é possível especificar caracteres como \nnn em que nnn é o código ASCII octal. Você pode especificar caracteres em hexadecimais inserindo \xnn onde nn é o código ASCII hexadecimal.

Você também pode usar os seguintes códigos predefinidos:

  • \a Alerta (ASCII 7)
  • \b Retrocesso (ASCII 8)
  • \E Escape (ASCII 27)
  • \f Avançar página (ASCII 12)
  • \n Alimentação de linha (ASCII 10)
  • \t Tabulação horizontal (ASCII 9)
  • \r Retorno do carro (ASCII 13)
  • \v Tabulação vertical (ASCII 11)
  • \\ Barra invertida (ASCII 92)


O que o leitor transmite quando nenhum código é lido?

Normalmente, nenhum dado é transmitido pelo leitor se um código não pode ser lido. Se você deseja saber se o motivo pelo qual você não visualiza a saída é porque nenhum dado foi lido, especifique uma cadeia específica de até 32 caracteres usando a Cadeia de saída para imagens sem leitura no painel Básicas.


O que é o resultado da Posição do código?

Para símbolos Data Matrix, a Posição do código representa a localização relatada dos quatro cantos do símbolo. O leitor retorna 4 pares de coordenadas:

  • O primeiro par representa a interseção do padrão do finder.

  • O segundo par representa a interseção do padrão do finder do ícone horizontal e o padrão de temporização vertical.

  • O terceiro par representa a interseção dos padrões de temporização (diagonal oposto ao primeiro par).

  • O quarto par representa a interseção do padrão do finder do ícone vertical e o padrão de temporização horizontal.

A Cognex recomenda a seleção de um delimitador, como uma vírgula, para separar cada valor e tornar os dados do resultado mais fáceis de ler.


Qual método de formatação de dados devo selecionar?

Você pode usar a Formatação básica (padrão ou estilo Perl) ou escrever seu próprio script em JavaScript na guia Formatação de dados do painel Geração de script. Os dois métodos diferem da seguinte maneira:

  • A formatação básica permite que você arraste e solte os elementos de formatação de dados pré-definidos.

  • A formatação por script permite que você escreva um script que, além de formatar os resultados e os dados de leitura, é capaz de fazer com que o leitor execute operações como o bipe ou saída 1.


Para que serve a guia Comunicação?

Nessa guia, você pode editar seu script de protocolo de comunicação personalizado.


Quais são as limitações da formatação por script?

Você estará limitado a ter dois eventos personalizados e a reescrever o evento do sistema na formatação por script.


Onde posso encontrar um exemplo de script?

Você terá as seguintes opções para inserir um script na janela principal do painel Script:

  • Clique no botão Inserir trecho localizado na barra de ferramentas superior e selecione o trecho da lista de acordo com as suas necessidades.

  • Clique com o botão direito do mouse na janela principal e selecione Inserir trecho.... Clique no trecho apropriado da lista, de acordo com o que precisar.

  • Pressione Ctrl-K, X

OBSERVAÇÃO: Se o botão Inserir trecho não estiver ativo, a versão de firmware em execução no dispositivo não suporta trechos para a guia atual do script.


Para que serve a guia Armazenamento em FTP?

Essa guia é usada para a geração de nome de arquivo FTP de imagens e relatórios de qualidade de código.


Como carrego meus scripts?

Acesse-os clicando no menu de faixa de opções e, em seguida, clicando na opção Abrir script. É possível salvar seus scripts com o botão Salvar script.

OBSERVAÇÃO: A geração de script somente suporta a codificação de caracteres UTF-8!


Qual é a função da opção Completar palavra?

Complete as palavras do seu script usando os seguintes métodos:

  • clicando no botão Completar palavra na barra de ferramentas superior

  • clique com o botão direito do mouse na janela principal e selecionando Completar palavra

  • pressionando Ctrl-K, W

Em seguida, selecione a partir de uma lista de objetos para inserir no script.


Como posso editar meu script rapidamente?

Use os botões Cortar, Copiar ou Colar na barra de ferramentas superior, ou clique com o botão direito do mouse em qualquer lugar da janela principal e selecione cortar, copiar, colar, excluir ou selecionar tudo.


Por que todas as variáveis são redefinidas ao selecionar Sistema->Salvar configurações?

Sempre que um script é alterado e o foco do editor é abandonado, o script é transmitido para o leitor, causando uma invalidação de contexto do mecanismo de script. A invalidação de contexto de script faz com que todas as variáveis sejam redefinidas.


Apenas para os leitores DataMan modelo X: Como posso usar a Métrica de controle do processo para a formatação de dados?

Após você habilitar a métrica de controle do processo no painel Propriedades da Data Matrix ou no painel Propriedades do código QR, você também poderá acessá-las por meio de scripts. Se você não habilitou nenhuma métrica de controle do processo, elas retornarão -1.


Apenas para os leitores DataMan modelo X: O que significam as métricas de controle do processo relatadas -1 ou NA?

Se a qualidade de impressão ou imagem do símbolo for tão ruim de forma a não ser mais possível medir a métrica de controle do processo com um algoritmo de decodificação de referência, a métrica relatada será -1 ou NA. Você poder melhorar a qualidade de impressão ou imagem usando a função Filtro de imagem, por exemplo.


Como posso ver erros no registro do dispositivo usando scripts?

Use o comando Throw() para relatar a ocorrência de uma situação anormal (exceção) e o erro será exibido no registro do dispositivo quando o dispositivo não estiver conectado ao Setup Tool. Você pode acessar o registro de erros acessando a barra de menu do Setup Tool e clicando em Sistema e em Exibir registro do dispositivo.

Enquanto o dispositivo é conectado ao Setup Tool, a exceção é exibida abaixo do script no painel de script.


Como posso obter mais informações sobre a formatação por script?

Para obter mais informações, consulte o documento Guia de programação e configurações do DataMan, disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool.


Como configurar um atraso na saída de código?

Para definir uma pausa na saída de código, a sequência \Pausa<tempo>; pode ser adicionada aos campos de texto no painel Formatação de dados.

<tempo> contém um valor em milésimos de segundo; por exemplo, para aguardar 4 segundos, a sequência será \Pausa4000;.

Esse recurso pode ser usado com USB HID ou RS232. Para RS232, o recurso necessita ser habilitado, usando o comando DMCC COM.RS232-ENABLE-PAUSE. Para USB HID, ele é habilitado como padrão.


Por que existem guias diferentes ao longo do topo?

Você pode especificar a formatação separadamente para simbologia diferente ou use a guia Universal para especificar a formatação de expressão regular de estilo Perl para qualquer símbolo decodificado.


Por que este painel está acinzentado?

Para habilitar o uso da formatação de expressão regular de estilo Perl, selecione primeiro a Formatação básica no painel Formatação de dados para acessar as simbologias específicas que seu leitor irá decodificar.


Como especificar a substituição de texto arbitrário?

Insira o texto na caixa de texto Expressão regular:. A sintaxe para a cadeia é:

        /search/replace/g

onde pesquisar é a cadeia a ser pesquisada e substituir é a cadeia para substituir com pesquisar. Por padrão, apenas a primeira ocorrência de pesquisar é substituída. Para substituir todas as instâncias, adicione g no final do comando.

Por exemplo, se o leitor decodifica esta cadeia:

        UPC 05214275600

Você pode substituir a cadeia "UPC" com a cadeia "CÓDIGO SKU", usando esta cadeia de substituição:

        /UPC/SKU CODE:/

que produziria esta cadeia de saída:

        SKU CODE: 05214275600

Você pode inserir pares de substituição múltipla separados por um espaço. Os pares múltiplos são usados em sequência: o resultado do primeiro par é usado como entrada para o segundo par e assim por diante.


O que significa "descartar dados não correspondentes"?

Por padrão, qualquer texto que não faça parte da cadeia de correspondência é passado como não alterado. Se você marcar Descartar dados não correspondentes, então apenas a cadeia resultante da substituição é enviada.


Quais caracteres especiais precisam ser evitados?

Os seguintes caracteres têm um significado especial na cadeias de pesquisa e substituição:

            ˆ  . , (  )  [  ] $ \ / * + |

Se você deseja incluir algum destes caracteres em sua cadeia de pesquisa ou substituição, você deve precedê-los com um caractere de barra invertida \. Para incluir um caractere de barra invertida, insira \\. Para inserir um caractere ASCII arbitrário, insira \xhh onde hh é o valor do caractere hexadecimal (você não pode usar \ooo para especificar os valores ASCII octais).


Como usar um curinga para corresponder caracteres ou padrões diferentes?

Você pode corresponder qualquer caractere único, qualquer caractere de um conjunto de caracteres, qualquer caractere de uma gama de caracteres ou qualquer caractere que não está dentro da gama de caracteres usando estes caracteres especiais na cadeia de pesquisa:

. Corresponda qualquer caractere único

[abcd...] Corresponda qualquer caractere único do conjunto a, b, c, d...

[a-z] Corresponde a qualquer caractere único dentro da gama de caracteres a até z (letras ou números podem ser usados)

Para inverter o sentido de um curinga usando um conjunto ou cadeia de caracteres, preceda-os com um caractere ^.

Para corresponder um número variável de caracteres, adicione um dos seguintes caracteres modificadores para o caractere ou curinga que está sendo correspondido:

+ corresponde a um ou mais dos caracteres anteriores

* corresponde a zero ou mais dos caracteres anteriores

? corresponde a zero ou um dos caracteres anteriores

{n} corresponde a n vezes do caractere anterior

{n,m} corresponde ao menos a n mas não mais que m vezes do caractere anterior

{n,} corresponde ao menos a n vezes do caractere anterior

Aqui estão alguns exemplos de correspondência do curinga:

/A.B/AB/g remove qualquer caractere único entre 'A' e 'B' na cadeia de entrada

/A.*B/AB/g remove qualquer número de caracteres entre 'A' e 'B' na cadeia de entrada


Existem curingas para a correspondência de caracteres especiais?

Use as seguintes sequências de escape para corresponder caracteres especiais e tipos de caracteres:

\n um caractere de nova linha

\w um caractere alfanumérico (letra ou dígito)

W um caractere não alfanumérico

\s um caractere de espaço em branco

\S um caractere de espaço não em branco

\d um dígito

\D um não dígito

Você pode usar estes caracteres em combinação com os curingas correspondentes com caracteres múltiplos listados no item anterior.


Como ancorar a cadeia de pesquisa?

Preceda à cadeia de pesquisa com um ^ para fazer a correspondência apenas no início da cadeia. Preceda à cadeia de pesquisa com um $ para fazer a correspondência apenas no final da cadeia.


Como reutilizar partes da cadeia de pesquisa na cadeia de resultados?

Anexe a parte ou partes da cadeia de pesquisa que você deseja usar na cadeia de resultados em parênteses. Você pode consultar as cadeias anexas na cadeia de resultado usando os tokens \1, \2 e assim por diante.


Existe um tamanho máximo para Expressões regulares de estilo Perl?

O tamanho máximo do script inserido em qualquer guia é de 512 caracteres, mas a guia específica de simbologia será executada antes da guia universal. Se as duas forem usadas simultaneamente, um script de até 1024 caracteres poderá ser gravado.


Como posso obter mais informações sobre as expressões regulares de estilo Perl?

Aqui. Observe que nem todas as funções descritas nesta página são implementadas pelo leitor.


Entradas / Saídas


Por que as opções de ação de pressionar o botão por 3 segundos estão acinzentadas?

É possível escolher a função de pressionamento do botão do disparo apenas nos modos de disparo único, burst e automático.

Observe que a opção Modo de teste fica ativa (por exemplo, pode ser selecionada) apenas se todas as outras opções acima dela (de Otimizar brilho até Configurar cadeia de correspondência) estiverem desmarcadas.


Qual é a função da caixa de seleção Desabilitar o botão do leitor na guia Botão TRIG?

Se você marcar Desabilitar o botão do leitor, o leitor não iniciará mais uma leitura ou tentativa de treinamento quando o botão de pressão do leitor for pressionado. Saiba que este recurso não desabilita o botão Disparo na barra de botões do Setup Tool ou no comando do disparo serial.


Quais ações podem ser configuradas se pressionar e manter pressionado o botão Disparo por três segundos?

Nos modos de disparo único, burst e automático, você pode configurar como o leitor reagirá ao pressionar o botão por três segundos. Se você marcar mais opções, a funcionalidade será executada na ordem listada.

Pressionando e mantendo pressionado o botão Disparo no leitor por 3 segundos, você pode:

  • Otimizar o brilho das imagens adquiridas, se estas operações são suportadas pelo modo atual do disparo

  • Fazer a leitura de um Código de configuração usando o documento Códigos de configuração

  • Focalizar automaticamente o módulo de lente líquido se um for anexado

  • Treinar o leitor com a simbologia que você espera nos símbolos sucessivos

  • Definir uma cadeia de correspondência se você estiver realizando uma validação da cadeia de correspondência

  • Colocar o dispositivo no modo de teste

Pressionar e manter pressionado o botão Disparo é o mesmo que usar o botão Disparo na barra de botões do Setup Tool.


Qual é a função da caixa de seleção Desabilitar o botão do leitor na guia Botão CALIBRAGEM?

Se você marcar Desabilitar o botão do leitor, o leitor não iniciará mais uma leitura ou tentativa de treinamento quando o botão de pressão do leitor for pressionado. Saiba que este recurso não desabilita o botão Disparo na barra de botões do Setup Tool ou no comando do disparo serial.


Qual é a função de cada ação da entrada na guia Entradas?

Use as configurações da ação da entrada para configurar qual ação o leitor irá executar. Por padrão, o leitor não responde a um sinal da entrada 1, 2 ou 3. Somente as entradas 0 e 1 podem ser usadas para o sinal de disparo.

As ações da entrada Aprender código, Otimizar brilho, Cadeia de correspondência de treinamento e Código de configuração do leitor são executadas somente após o próximo disparo.

É possível configurar o leitor para executar as seguintes ações:

  • As funções Disparo ligado e Disparo desligado são habilitadas como padrão na mesma entrada. O Disparo desligado é automaticamente o inverso do Disparo ligado. Se você colocar dois sinais em entradas separadas, poderá configurar a polaridade de forma independente, conforme as suas necessidades.

  • O Codificador significa que você conectou o codificador a esta entrada.

  • Direção do codificador

  • O Aprender código significa que o leitor está treinado com a simbologia esperada, que pode diminuir o tempo necessário para decodificar símbolos sucessivos.

  • A função Otimizar brilho significa que o leitor encontra as melhores configurações da luz e do processador de imagens possíveis para ler um código.

    OBSERVAÇÃO: A função Melhorar brilho não funciona se uma dimensão de ROI for menor que 144.

  • A função Cadeia de correspondência de treinamento significa que o código decodificado será o código usado para comparação e validação dos códigos sucessivos.

  • A função Otimização do foco (apenas disponível nos leitores com lente líquida) significa que o leitor encontrará as melhores configurações do foco possíveis para ler um código.

  • O Código de configuração do leitor significa que o leitor deve considerar o código a ser lido não como uma imagem, mas como um comando de configuração, por sua vez, reduzindo a contagem do disparo e sem produzir uma imagem sem leitura.

  • A função Calibragem significa que o leitor encontra a melhor configuração possível para ler um código.

    OBSERVAÇÃO: A função Calibragem não funciona se uma dimensão de ROI for menor que 144.

  • A função Habilitar as imagens sem leitura no buffer significa que quando esta entrada estiver habilitada e conectada a um sensor que detecta um pacote, o leitor armazenará as imagens sem leitura no buffer. É útil quando você quiser saber porque houve imagens sem leitura, por exemplo.

  • Apagar saídas faz com que todas as saídas sejam redefinidas imediatamente quando a entrada for disparada. Essa opção não redefine nenhuma configuração de atraso de saída.

  • Polaridade significa que, se a polaridade estiver definida, esta causa uma mudança no sinal que dispara uma aquisição de imagem

  • Atraso do debounce significa que é definido quanto tempo o sinal do disparo deve ser detectado para ser reconhecido como válido.


Quais configurações da detecção do disparo podem ser alteradas?

Use a opção Polaridade para ajustar a mudança no sinal que dispara uma aquisição de imagem.

Use a caixa de texto Atraso do debounce para definir em quanto tempo o sinal do disparo deve ser detectado para ser reconhecido como válido. Use um valor menor para compensar os ruídos da linha ESD o os valores maiores para compensar os ruídos nos relés eletromecânicos. Você pode ter que experimentar com o ajuste para escolher o valor mais adequado para seu ambiente de produção.


Qual tempo de debounce pode ser definido?

O tempo de debounce mais curto é 0. Números maiores significa um aumento do tempo de debounce. O valor máximo é 6.


Quais configurações podem ser definidas na guia Saídas?

A guia Saídas permite que você configure o comportamento de todas as portas de saída disponíveis no leitor. Você pode configurar o evento e a ação da porta de saída de qualquer porta.

Para a condição de Sem leitura, você também pode especificar uma cadeia específica para transmitir quando um código não pode ser lido.


Quando a ação selecionada ocorrerá?

Quando a caixa de seleção for selecionada, a ação atribuída a uma entrada não ocorrerá imediatamente após a ativação da entrada. Ocorrerá apenas quando o disparo seguinte for executado.


Qual é a função da opção Habilitar as imagens sem leitura no buffer?

Quando essa entrada está ativa e conectada a, por exemplo, um sensor de detecção de pacote, mesmo que o armazenamento em buffer possa ser aplicado a todas as imagens, as imagens não lidas serão armazenadas no buffer apenas quando o sensor gerar um sinal para a entrada particular. Como resultado, o leitor armazenará no buffer imagens não lidas apenas quando o sensor detectar um pacote. Esta opção só funciona no modo de disparo Contínuo.


Como posso configurar a Duração do bipe para as boas leituras?

Marque a opção Habilitar bipe para boa leitura na guia Saídas. Em seguida, configure a Duração do bipe com um valor entre 0 e 50 ms.


Qual a finalidade da configuração Duração do pulso da iluminação circular?

Para leitores com iluminação circular, a duração do estado iluminado da iluminação circular pode ser especificada aqui, em milésimos de segundo.


Como posso gerar um evento de Validação aprovada?

Se a validação de dados for habilitada, o evento Leitura só será sinalizado se um código for lido e aprovado. Os eventos Leitura e Sem leitura atribuídos a duas saídas aplicam a seguinte lógica:

  1. Boa leitura, validação aprovada: leitura saída

  2. Boa leitura, falha de validação: sem saída

  3. Leitura ruim: saída de leitura ruim

Também é possível atribuir um evento de falha de validação a uma leitura.


Como sei o que o erro da luz significa no dispositivo?

Selecione Sistema->Exibir registro do dispositivo e examine o registro para esta informação.


Como reinicializar meu leitor?

Faça a leitura do comando Reinicializar scanner impresso na parte posterior do documento "Guia de consulta rápida" para reinicializar pelo software. A memória não volátil do leitor não foi apagada, mas o leitor foi desligado e reiniciado.

Faça a leitura do comando Reinicializar o scanner com os padrões de fábrica para que o leitor volte ao estado padrão de fábrica.


É possível fechar uma porta de saída por um período indefinido de tempo?

Você pode fechar uma linha de saída indefinidamente, especificando um comprimento de pulso por 0 milésimos de segundos, mas saiba que qualquer evento que disparar esta linha de saída fará com que ela permaneça fechada até que você desligue e ligue o leitor ou apague as saídas com uma configuração de entrada discreta.


O que é Aberta e Fechada no campo Ação?

O estado aberto ou fechado significa o estado do relé. Se acontecer um Evento da lista acima, a saída pode ser aberta ou fechada. Por exemplo, se acontecer um evento Leitura, no caso de Fechada, a saída 0 será a saída 1. Além disso, você pode fechar uma linha de saída indefinidamente, especificando um comprimento de pulso de 0 milésimos de segundos, mas saiba que qualquer evento que disparar esta linha de saída fará com que ela permaneça fechada até que você desligue e ligue o leitor ou apague as saídas com uma configuração de entrada discreta.


Por que todas as opções de uma coluna de saída específica estão desabilitadas?

As opções são desabilitadas se você marcar a opção Estroboscópico, que usa esta linha de saída reservada em qualquer configuração de leitura ativa.


O que é a Saturação do disparo?

A saturação do disparo significa que a imagem não será adquirida porque a câmera estava em uso (por exemplo, por causa de um burst contínuo ou por causa de uma longa exposição).


O que é o estouro do buffer?

O estouro do buffer significa será possível adquirir uma imagem, mas não haverá espaço para salvá-la. Em outras palavras, as imagens serão adquiridas mais rápido do que podem ser processadas. Uma situação possível é quando a decodificação leva mais tempo do que o tempo do intervalo do disparo ou da imagem.


O que o leitor transmite quando nenhum código é lido?

Normalmente, nenhum dado é transmitido pelo leitor se um código não pode ser lido. Você pode enviar uma cadeia específica de até 32 caracteres de comprimento, especificando uma Cadeia para imagens sem leitura. Clique no nó Configurações do sistema, depois insira a cadeia no campo Cadeia de saída para imagens sem leitura e pressione <Enter>.


Qual é a função da opção Estroboscópico?

É possível reservar uma saída de iluminação externa marcando a opção Estroboscópico em uma das portas de saída. Também é possível configurar a polaridade escolhendo a opção Aberta ou Fechada na coluna Saídas.


Como é possível configurar o Atraso de saída?

Especifique o tempo do atraso de saída e configure-o em milésimos de segundos. Especifique o atraso de saída relativo ao Início do disparo ou ao Final do disparo.


Como usar o Atraso de saída e o Atraso do disparo ao mesmo tempo?

Os dois disparos são relativos ao limite físico do disparador e não ao início atrasado da aquisição da imagem (se o atraso do disparo estiver definido).


Por que não é possível configurar o Atraso de saída?

Somente é possível definir o Atraso de saída nos modos de disparo: manual, único, burst e contínuo.


Quais portas de saída digital são afetadas pelo atraso de saída?

Todas as ações baseadas nos seguintes eventos:

  • leitura/sem leitura

  • falha de validação

são atrasados. As seguintes portas de saída são afetadas:

  • a configuração de qualquer saída digital

  • qualquer transferência de dados por meio do RS-232, Ethernet ou USB

  • iluminação dos LEDs

  • som do bipe


Qual é a Distância até a saída?

Usando um codificador de pulso, você pode especificar a distância até a saída e mapear o pulso em relação à distância. O valor da distância até a saída é corrigido com base no valor da resolução (é ajustado para o múltiplo mais próximo da resolução arredondado para milímetros).

Na guia Atraso de saída, use o controle Distância até a saída (mm) para configurar a distância do disparo até o momento de saída do resultado.

Na guia Codificador de pulso, use o controle Resolução (mm) para definir a resolução.


O que é o Codificador de pulsos?

Nos modos de disparo externos, é possível usar um codificador para controlar o tempo de saída da cadeia de dados. Normalmente, os codificadores são instalados em uma esteira e, conforme a esteira se movimenta, o eixo do codificador irá girar e emitir pulsos elétricos para indicar a respectiva rotação angular. O valor de rotação do codificador é diretamente proporcional à distância percorrida pela esteira.

Conecte o codificador às portas de entrada 1 ou 2. A entrada selecionada será usada exclusivamente pelo codificador. Para executar outras ações, favor selecionar outra entrada.

Também é possível conectar um codificador a um leitor mestre de um grupo mestre/escravo.


Quais são as configurações que podem ser usadas no codificador de pulsos?

Especifique a distância até a saída e mapeie o pulso em relação à distância. O valor da distância até a saída é corrigido com base no valor da resolução (é ajustado para o múltiplo mais próximo da resolução arredondado para milímetros).

Na guia Atraso de saída, use o controle Distância até a saída (mm) para configurar a distância do disparo até o momento de saída do resultado.

Na guia Codificador de pulso, use o controle Resolução (mm) para definir a resolução.


Por que deveria mudar o nome do dispositivo?

Dê um nome mais significativo ao seu dispositivo para seu ambiente de produção, como a localização ou a tarefa de inspeção. Use o campo Nome do dispositivo na guia Avançadas.


O que pode ser adicionado à descrição do dispositivo?

A descrição do dispositivo é um campo de texto editável na guia Avançadas onde você pode adicionar notas ao dispositivo ou informação adicional que considere importante.


Como mudar o nome do dispositivo?

Para mudar o nome do dispositivo:

  1. Insira um novo nome para o dispositivo no Nome do dispositivo.

  2. A pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim.

  3. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Selecione Sistema->Salvar configurações e, em seguida, reinicialize seu dispositivo.

A próxima vez que você iniciar o Setup Tool ou clicar em Atualizar no painel Conecte-se ao leitor, ele refletirá o novo nome do dispositivo.


O que pode ser configurado com a configuração Duração do pulso do LED de erro?

Você pode deslocar o controle deslizante para o milésimo de segundo desejado, o qual é usado para determinar o tempo que LED de erro pulsa em dispositivos de suporte fixo. O LED de erro pode ser encontrado no topo do dispositivo. Configurar o controle deslizante para ‘0’ faz com que o LED de erro vermelho desligue se o registro do dispositivo for recuperado, enquanto todos os valores acima de ‘0’ fazem com que o LED de erro vermelho desligue automaticamente após expirado o tempo selecionado.


O que é uma Mensagem de ativação?

Se a opção Enviar diagnóstico de saída ao ativar estiver habilitada, o leitor transmitirá uma cadeia de diagnósticos sempre que iniciar.

Para conexões Telnet, os leitores transmitem a cadeia de diagnóstico com cada nova conexão. Para conexões seriais, a taxa de transmissão está automaticamente ajustada em 38.400 quando a mensagem é enviada, apesar dos ajustes realizados no Setup Tool.


Comunicações


É possível usar um comando do disparo serial que seja maior que um caractere?

Os comandos Disparo LIGADO e Disparo DESLIGADO suportam um limite de caracteres com uma sequência resultante que pode ter, no máximo, 32 bytes. Dependendo de quantas sequências de escape forem usadas, isto significará que o comprimento válido da cadeia aceitável pode variar entre 32 caracteres (sem sequências de escape) e 128 (32 * sequências de escape de 4 caracteres [por ex. \002]) caracteres.


O que a habilitação dos Comandos Eco faz?

Quando habilitados, os comandos de eco irão ecoar os comandos que você enviou ao leitor assim que o comando, delimitado pelas cadeias Cabeçalho do comando e Rodapé do comando for recebido.


Por que não é possível testar o comando de disparo ou a função de eco no programa do terminal?

Os comandos personalizados são fornecidos para serem usados por um PLC ou por um dispositivo semelhante e não devem ser inseridos manualmente. O retardo entre caracteres é ajustado em um valor pequeno, aproximadamente 50 ms, de modo que a digitação lenta de um comando personalizado não será reconhecido após o primeiro caractere. Um comando disparo LIGADO ou disparo DESLIGADO maior que um simples caractere deve ser enviado como uma cadeia de outra aplicação.


O que posso configurar no passo do aplicativo Comunicações?

Nas três guias do passo do aplicativo Comunicações, podem ser implementadas as configurações de Ethernet e serial. Clique na guia adequada para inserir seus valores de configuração.

Na guia Avançadas podem ser implementadas configurações mais detalhadas em uma visualização de tabela.


Como mudar as configurações da porta serial do leitor?

Na guia Serial do passo do aplicativo Comunicações, insira as novas configurações. É possível também ler o documento Códigos de configuração (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool).


Quando devo usar o Modo de compatibilidade do driver USB?

Por padrão, o leitor DataMan usa um driver USB que pode ajudar o leitor a recuperar-se de um evento de descarga eletrostática (ESD). Use o Modo de compatibilidade do driver USB se você precisa estar estritamente em conformidade à especificação USB ou se você está usando um leitor DataMan junto com o produto de Cognex SensorView.

Quando você altera o modo de compatibilidade do driver USB, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e depois reinicialize seu leitor.


Como usar o leitor em vez do teclado quando estiver conectado com USB?

Para emular um teclado USB, basta fazer a leitura do código do Teclado USB do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool) e verificar se você desconectou o Setup Tool.


O que é possível configurar com o menu suspenso Canal de comunicação usado?

Aqui, você pode definir o método de comunicação por USB. Dependendo do dispositivo utilizado, as opções a seguir estão disponíveis.

  • USB-COM apenas: Escolha essa opção para alcançar o dispositivo usando uma porta serial.

  • USB-HID apenas: Essa opção assegura que o dispositivo se comporte como um teclado USB.

  • USB-COM + USB-HID: É uma combinação dos modos acima.

OBSERVAÇÃO: No caso da opção USB-COM apenas, alguns dispositivos também podem ser listados em "dispositivos HID", mesmo que não tenham a funcionalidade HID.


Como usar o leitor em vez do teclado através do adaptador PS/2?

Para emular um teclado PS/2, você deve usar o cabo serial, fonte de alimentação externa e cabo de outro dispositivo ou programa além do teclado, como descrito no Guia de consulta rápida. Faça a leitura do código Habilitar emulação de teclado PS/2 do documento Códigos de configuração do leitor (disponível no menu Iniciar do Windows ou no menu Ajuda do Setup Tool). Para instalar o adaptador PS/2, você deve desligar o seu PC da tomada. Conecte o leitor usando os cabos mencionados acima. Em seguida, ligue seu computador e o leitor emulará um teclado PS/2.


O que acontece se meu leitor não for reinicializado quando solicitado?

As mudanças nas configurações não serão aplicadas. Se você mudar de ideia, clique em Sistema e selecione Salvar configurações. Em seguida, reinicialize o leitor.


O que é o recurso de portas múltiplas (compartilhamento RS-232)?

Este modo de conexão permite que vários leitores DataMan (do mesmo tipo) compartilhem uma única conexão serial em um PC ou outro dispositivo equipado com uma porta serial. Uma conexão de portas múltiplas cria uma conexão em série dos leitores. Cada leitor recebe dados seriais do leitor anterior e os transmite para o próximo leitor. Quando um leitor transmite dados, ele passou através de cada um dos leitores na cadeia entre ele e o PC.

Você deve construir seu próprio cabo que atenda aos requisitos da configuração do seu sistema. O cabo deve fornecer um conector DB-15 para cada dispositivo DataMan e um conector DB-9 para a porta serial do PC. Cada conector DB-15 deve fornecer dados Tx, dados Rx, disparador (entrada 0), aterramento e alimentação CC. Os pinos dos dados Tx e dos dados Rx em conectores adjacentes devem ser conectados para fornecer a conexão de portas múltiplas.

Você deve conectar cada dispositivo DataMan ao DataMan Setup Tool, usando uma conexão USB e ajustando o DataMan para uma operação de portas múltiplas. Para configurar um dispositivo para operação de portas múltiplas, clique na caixa de seleção Habilitar portas múltiplas (Compartilhamento de RS-232).

Para obter mais informações detalhadas sobre Portas múltiplas, consulte o capítulo Conexões de portas múltiplas no Manual de referência correspondente. A função Compartilhamento de portas múltiplas tem os seguintes comportamentos e limitações:

  • Cada leitor na cadeia ainda pode ser conectado ao PC ou a outro dispositivo através de uma conexão USB.

  • Cada leitor na cadeia deve receber seu próprio sinal do disparo. O DataMan não suporta o disparo serial.

  • Cada leitor na cadeia deve ser configurado separadamente.

  • Todos os dados de cada leitor chegam sem classificação e sem filtragem para o PC ou outro dispositivo.


O que é enchimento zero?

O enchimento zero coloca zeros à esquerda dentro de seus dados transmitidos, o que é necessário em algumas aplicações que aceitam os dados enviados pelo leitor.


Como definir as configurações de rede do leitor?

Se você estiver usando o leitor sem fio DataMan 8000, configure as configurações de rede da estação base. Se você estiver usando um leitor com cabo, use a guia Rede para configurar as configurações de rede.

Selecione a opção Usar servidor DHCP para ter o leitor atribuído a um endereço IP por um servidor DHCP (se um estiver disponível) ou insira as configurações de rede manualmente. Entre em contato com o seu administrador de rede para obter os valores apropriados.

Quando você altera as configurações, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e depois reinicialize seu leitor.


Copiar configurações de rede do PC

Se você clicar no botão Copiar configurações de rede do PC, a partir do menu suspenso, você pode selecionar Dell GigabitEthernet, Bluetooth Device, Microsoft Wi-Fi Direct Virtual Adapter, Dell Wireless 1560 802. 11ac. Suas próprias configurações de rede do PC serão copiadas nos campos acima.


Para que serve a função "Nova enumeração na inicialização do firmware"?

Em alguns casos, a porta COM é enumerada, mas a inicialização do firmware leva mais tempo e os tempos de espera da porta COM são interpretados como uma conexão perdida. Para evitar esses casos, essa caixa de seleção faz com que a porta COM seja enumerada novamente depois que o firmware é reiniciado.


Para que serve a configuração Atraso entre caracteres?

A configuração aplica os milésimos de segundo fornecidos como atrasos entre cada caractere lido no modo de leitura de teclado/caractere. Isso é útil quando alguns caracteres lidos são perdidos devido à velocidade das leituras subsequentes.


Protocolos industriais

Protocolo EtherNet/IP

Para habilitar o leitor a usar o protocolo Ethernet/IP, marque EtherNet/IP na caixa Protocolos industriais da guia Ethernet.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize seu leitor.

Protocolo PROFINET

Para habilitar o leitor a usar o protocolo PROFINET, marque PROFINET. Você pode inserir o nome da estação clicando na caixa Usar o nome da estação.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize seu leitor.

Protocolo SLMP

Para habilitar o leitor a usar o protocolo SLMP, marque Protocolo SLMP e, em seguida, configure os parâmetros conforme necessário.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize o leitor para o ajuste fazer efeito, tanto alternando a força do leitor ou digitalizando o símbolo Reinicializar.

Modbus TCP

Para habilitar o leitor a usar o protocolo Modbus TCP, marque Modbus TCP e, em seguida, configure os parâmetros conforme necessário.

“É necessário reinicializar para que as mudanças façam efeito.” é exibido no lado direito da faixa Comunicações. Clique em Salvar configurações e depois reinicialize o leitor para o ajuste fazer efeito, tanto alternando a força do leitor ou digitalizando o símbolo Reinicializar.

EtherNet/IP, PROFINET, Protocolo SLMP ou Modbus TCP acinzentado

Apenas um protocolo industrial de Ethernet pode ser usado por vez. Quando um protocolo estiver selecionado, o outro não estará disponível.


Campo Status em Protocolos industriais

O campo Status dos protocolos industriais exibe a última mensagem registrada da caixa de diálogo de status. A mensagem permanecerá em exibição até que outra mensagem seja registrada. Se nenhum protocolo industrial estiver habilitado, o campo de status permanecerá em branco.

As mensagens de status variam de acordo com o protocolo, e alguns protocolos não registram nenhuma mensagem. Consulte o Guia de programação e configurações do Dataman, página 110, Status dos Protocolos industriais, para obter informações detalhadas sobre as mensagens e protocolos que os exibem.


Modbus TCP: configuração do Tempo limite de ociosidade

O Tempo limite de ociosidade é a quantidade de tempo que uma porta será mantida aberta sem nenhum tráfego de saída. Assim que o leitor abrir uma conexão com um servidor FTP, o leitor manterá essa conexão aberta enquanto houver tráfego.

Se não houver tráfego durante o período de Tempo limite de ociosidade definido, a conexão é fechada. Isso pode ser útil se uma transferência FTP somente acontecer pontualmente e não for desejada a sobrecarga da rede para manter a conexão aberta.

Você precisa primeiro habilitar a opção Modbus TCP para poder definir o tempo de espera inativo.


Como usar a opção autenticar?

Quando a opção Autenticar for habilitada, o Setup Tool irá solicitar ao usuário uma senha para a conta administrador quando for feita alguma tentativa de conexão a um leitor ou a uma estação base disponível na rede.


Como estabelecer uma conexão TCP/IP?

O leitor está habilitado para estabelecer conexões TCP usando a porta 23, que é a porta padrão TCP para aplicações Telnet. Se você usar o cliente Telnet, o único parâmetro que terá que fornecer é o endereço IP do leitor. Se você estiver usando outra aplicação ou SDK para conectar, verifique se utiliza a mesma configuração de porta TCP usada pelo seu leitor. A porta TCP pode ser alterada no painel Telnet. O leitor enviará o código de saída automaticamente através da conexão. Você também pode transmitir comandos de controle DataMan (DMCC) através desta conexão.

Quando você altera a porta Telnet, a pergunta "É necessário reinicializar para que as mudanças façam efeito. Deseja aplicar as mudanças e reinicializar agora?" aparecerá. Clique em Sim. Se, por qualquer motivo, você clicar em Não, ainda poderá aplicar as mudanças. Escolha Sistema->Salvar configurações e reinicialize seu leitor.


É possível enviar mensagens a um servidor FTP?

Use a guia Imagem FTP para definir as configurações necessárias para transferir imagens para um servidor FTP. A guia contém configurações para o endereço IP e número da porta do servidor assim como uma combinação do nome do usuário e senha. Certifique-se que as imagens enviadas usando o FTP não são garantidas a serem enviadas, o que pode acontecer quando o leitor está operando em uma frequência maior e não pode agendar tempo para transferir imagens.

A opção Nome do arquivo permite a você especificar o arquivo onde as imagens serão armazenadas. O campo Nome do arquivo permite a você especificar um caminho em relação ao diretório raiz do servidor FTP (por exemplo, /failed_images/image). A extensão do nome do arquivo (.jpg ou .bmp) apresentada na etiqueta após o nome do arquivo corresponde à configuração de formato da imagem no painel Configurações da imagem no buffer. Certifique-se que o leitor não crie diretórios; o diretório deve estar disponível e acessível.

O controle Valor máx. de acréscimo indica o limite do valor aumentado usado no nome do arquivo. Um valor de 0 indica que nenhum aumento será inserido e o arquivo pode ser sobrescrito.

A opção Nome do arquivo gerado pelo servidor inicia com um caminho em branco, que indica o diretório raiz no servidor FTP.

A lista Quais imagens serão transferidas permite escolher quais tipos de imagens serão enviadas para o servidor FTP. Saiba que o servidor FTP precisa suportar a transferência de imagem.


O que é o Cliente de rede?

O comportamento do Cliente de rede é um meio para que a ID do leitor DataMan abra ativamente uma conexão Ethernet com outro dispositivo da rede. Quando estiver aberta, a conexão terá o mesmo comportamento operacional básico da conexão DataMan Telnet. Ela produzirá resultados de leitura (transmitindo resultados para o dispositivo externo) e pode atuar como servidor DMCC (processando comandos recebidos do dispositivo externo).


O que é um host?

O host é o dispositivo da rede com o qual o DataMan se conectará. Especifique o endereço da Ethernet e o número da porta do dispositivo host. O endereço pode ser um nome de domínio totalmente qualificado (por exemplo: “server.mynetwork.com”) ou um endereço IP de formato de pontos decimais (por exemplo: “192.169.0.1“).


O que é a porta do cliente?

A porta do cliente é a porta Ethernet do leitor a partir da qual a conexão do cliente será originada. O valor padrão de 0 instrui o cliente de rede para usar qualquer porta disponível. Em casos especiais, você precisará definir uma porta do cliente específica. Basta definir a porta do cliente colocando o valor necessário. Observe que o caso mais comum é usar o valor padrão de 0. Se você estiver em dúvida, use o valor padrão.


Como posso estabelecer uma conexão?

O cliente se conectará com base na opção Abrir conexão selecionada. As opções disponíveis são a conexão quando o DataMan for ligado ou a conexão assim que houver atividades de dados (ou seja, a conexão quando um código for lido).


Como desligo a conexão?

Há duas opções de Fechar conexão disponíveis. A conexão pode ficar sempre aberta ou pode ser fechada após a transferência de dados for completada. Se você selecionar a opção Após a transferência de dados do leitor, poderá definir um número de segundos definidos para a conexão desligar se o leitor estiver inativo por um período de tempo. A duração do período inativo é ajustada de 1 até 3600 segundos.


O que é o Tempo limite da conexão?

O tempo limite da conexão é o período de tempo (em milésimos de segundos) que o DataMan espera para abrir a conexão. Observe que caso a opção Em inicialização estiver selecionada, o leitor continuará tentando abrir a conexão.


O que é o Atraso da reconexão?

É o período de tempo (em milésimos de segundos) que o leitor pausará antes de tentar reabrir a conexão.


O que é a função Caracteres não imprimíveis?

Normalmente, os valores brutos para caracteres não imprimíveis são transmitidos quando o leitor está configurado para comunicações COM. Estes valores não são visíveis em forma nenhuma quando o leitor é configurado nas configurações de outro dispositivo ou programa além do teclado. Você pode configurar o leitor para converter caracteres não imprimíveis em sequências de caracteres imprimíveis do teclado como <CR> habilitando a função Converter caracteres não imprimíveis.


Quais caracteres não imprimíveis são convertidos?

Os códigos ASCII de oito bits com valores de 0x00 por meio de 0x1F e 0x7F são convertidos quando a função "Converter caracteres não imprimíveis" estiver habilitada. Os caracteres são mapeados com um nome de caractere ASCII, conforme listado abaixo:

0x00 <NUL>

0x01 <SOH>

0x02 <STX>

0x03 <ETX>

0x04 <EOT>

0x05 <ENQ>

0x06 <ACK>

0x07 <BEL>

0x08 <BS>

0x09 <HT>

0x0A <LF>

0x0B <VT>

0x0C <FF>

0x0D <CR>

0x0E <SO>

0x0F <SI>

0x10 <DLE>

0x11 <DC1>

0x12 <DC2>

0x13 <DC3>

0x14 <DC4>

0x15 <NAK>

0x16 <SYN>

0x17 <ETB>

0x18 <CAN>

0x19 <EM>

0x1A <SUB>

0x1B <ESC>

0x1C <FS>

0x1D <GS>

0x1E <RS>

0x1F <US>

0x7F <DEL>


O que acontece se a função Converter caracteres não imprimíveis for habilitada?

Esse parâmetro somente afeta o conteúdo do código atual. Qualquer formatação adicional, como o cabeçalho e o rodapé, não será alterada. Desta maneira, será preservada a habilidade de usar os caracteres de controle juntamente com este parâmetro, por exemplo, a capacidade de inserir quebras de linha entre os códigos ou navegar para a próxima célula em uma planilha de dados.


O que é transmitido quando um código contém caracteres não imprimíveis?

Normalmente, os valores brutos para caracteres não imprimíveis são transmitidos. Você pode configurar o leitor para converter caracteres não imprimíveis em sequências de caracteres imprimíveis como <CR>. Acesse o painel Caracteres não imprimíveis e marque a opção Habilitada.


Reparo e suporte


O que é Reparo e suporte?

A página de Reparo e suporte pode ser usada para definir as configurações de rede de um dispositivo de rede configurado incorretamente ou alterar o modo HID de um dispositivo serial para CDC.


Para que serve a opção Atualizar?

Clique no botão Atualizar para atualizar a lista de dispositivos disponíveis.


Como posso adicionar um dispositivo de rede à lista de dispositivos exibidos?

Você pode adicionar um dispositivo de rede ou editar o endereço IP de um dispositivo adicionado clicando em Adicionar dispositivo de rede. A caixa de diálogo Adicionar dispositivo de rede será aberta e você poderá fornecer o endereço IP do dispositivo. Clique em OK para salvar as alterações e exibir o dispositivo também na página Conectar.


Como editar as propriedades de um dispositivo?

Selecione um dispositivo na lista de dispositivos para ver as opções disponíveis. No painel que abrirá, você poderá editar as configurações de rede que pertencem ao dispositivo selecionado; também poderá definir uma opção de autenticação. Clique em Aplicar para salvar as alterações.


DataMan séries 60, 300, 503, 8000 e estação de base do DataMan 8000: Como usar a opção Adicionar dispositivo?

A opção Adicionar dispositivo permite que você adicione manualmente o seu DataMan à lista de Dispositivos de rede, de modo que possa conectar o leitor ou a estação base DataMan ao Setup Tool pela rede Ethernet, em vez de usar portas de comunicação em seu PC.

Você deve ter o endereço IP do leitor ou da estação base para usar a opção Adicionar dispositivo. Execute o seguinte procedimento para descobrir o endereço IP atualmente designado ao leitor ou à estação base:

  1. Conecte o leitor ou a estação base ao Setup Tool por meio de uma conexão RS-232 no PC (Porta COM do Setup Tool).

  2. Selecione a guia Rede em Configurações de comunicação.

  3. Copie o Endereço IP mostrado.

  4. Volte ao painel Conecte-se ao leitor e clique em Desconectar.

  5. Clique em Adicionar dispositivo.

  6. Cole o endereço IP do DataMan aqui.

Depois que os campos Nome e Endereço IP forem preenchidos, clique em OK. O leitor ou a estação base deve aparecer na lista de dispositivos DataMan acessíveis na lista Dispositivos de rede e, agora, você poderá conectar o Setup Tool ao leitor ou à estação base pela rede Ethernet.

O recurso Adicionar dispositivo armazena o nome do leitor ou da estação base na máquina local e não ficará visível em outras máquinas que também executam o Setup Tool.


Para que posso usar o ícone Exportar?

Clicando no ícone Exportar arquivo de suporte Cognex, é iniciada a geração de Arquivo de suporte Cognex, que gera um arquivo .zip contendo uma coleção de registros de dados predefinidos. Esse recurso somente está disponível se estiver selecionado pelo menos um dispositivo.

Ao clicar no botão, surge uma caixa de diálogo onde você pode especificar os tipos de dados a serem incluídos no arquivo de suporte .zip, em uma lista de caixas de seleção:

  1. Cfg

  2. Cdc

  3. Última imagem

  4. Dispositivos localizados

  5. Estatísticas do dispositivo

  6. Estatísticas da memória

  7. Comentário do usuário (pode ser editado manualmente pelo usuário)

A pasta de destino do arquivo de suporte pode ser modificada, usando o ícone '...’. É possível selecionar para abrir a pasta contida após a criação do arquivo ou enviá-la como um anexo, com o cliente de e-mail padrão (.eml).

A saída do processo é um arquivo .zip. O nome do arquivo contém o nome do dispositivo e a data de criação. Um descritor.xml no zip contém os seguintes dados:

  1. Data

  2. ID de descoberta

  3. Nome do dispositivo

  4. Tipo de dispositivo

  5. Número de série

  6. Endereço MAC

  7. Licenças

  8. Interface de comunicação

  9. Versão de firmware

  10. Lista dos arquivos presentes no zip


Qual a função do botão Adicionar dispositivo virtual?

Essa função permite criar um dispositivo virtual baseado em um arquivo de configuração personalizada ou um dispositivo com configuração padrão. Ela pode ser usada para visualizar os diferentes painéis do Setup Tool sem necessidade de conectar a um dispositivo. Pressionar o botão inicia um assistente que guia você pelos passos de criação de um dispositivo virtual. As opções iniciais são usar um arquivo de configuração/backup para a criação ou usar configurações de fábrica padrão.

Após o assistente terminar, é adicionado um novo dispositivo virtual à lista de dispositivos localizados, indicado por um ícone como um dispositivo virtual. O dispositivo virtual criado não está visível para outros dispositivos na rede. O dispositivo virtual persiste durante múltiplas instâncias de Setup Tool.

O dispositivo virtual criado pode ser conectado da mesma forma que um dispositivo normal, com a exceção de que todas as alterações de configuração são rejeitadas (tudo é somente de leitura) e nenhuma característica, função e ação funciona em dispositivos virtuais.


Backup


Como posso usar a função Backup?

Usando essa função, você pode gerar um arquivo de backup contendo a configuração e registros de um ou mais leitores, clicando no botão Backup, no canto inferior direito (ou pressionando Alt+B). Esse recurso somente está disponível se estiver selecionado pelo menos um dispositivo.

Clicando no botão Abrir pasta de backup, navega para a pasta onde os arquivos de backup são colocados. Você pode configurar a pasta em Home->Opções->Local do backup.

Se forem selecionados múltiplos dispositivos, cada dispositivo gerará um arquivo de backup. Cada arquivo de backup é colocado em uma subpasta que corresponde ao nome do dispositivo. O nome do arquivo de backup contém o nome do dispositivo e a data de criação.

O arquivo de backup é um arquivo .zip com uma extensão .dmb. O arquivo contém: config.cdc, config.cfg e descritor.xml. O xml possui os seguintes dados:

  1. Data

  2. ID de descoberta

  3. Nome do dispositivo

  4. Tipo de dispositivo

  5. Número de série

  6. Endereço MAC

  7. Licenças

  8. Interface de comunicação

  9. Versão de firmware

  10. Lista dos arquivos presentes no zip


Onde posso configurar a pasta de backup para a função de Backup?

É possível configurar a pasta em Home->Opções->Local do backup


Restaurar


Como posso usar a função Restaurar?

A função Restaurar permite a restauração de arquivos de configuração de backup em um ou mais dispositivos. Esse recurso somente está disponível se estiver selecionado pelo menos um dispositivo e se uma fonte de configuração válida for especificada.

Em Fonte da configuração, na parte superior, você pode especificar a fonte que Setup Tool usará para a restauração:

  1. Arquivo de configuração: Selecionando essa opção, o Setup Tool usa o arquivo de configuração especificado para a restauração. Clique no ícone '...’ para especificar a pasta que contém o arquivo de backup que deseja usar. Consulte Perguntas e Respostas em Backup para mais informações sobre como definir a pasta.

    Observação: O botão Restaurar somente fica habilitado quando um dispositivo compatível é selecionado como alvo.

  2. Dispositivo: Ao selecionar essa opção, o Setup Tool usa um único dispositivo especificado para restaurar a sua configuração para todos os dispositivos alvo.

  3. Último Backup: Ao selecionar essa opção, o Setup Tool procura o último backup para o dispositivo selecionado. Se forem selecionados múltiplos dispositivos, todos os dispositivos obtêm seu próprio último backup.

  4. Padrões de fábrica: Ao selecionar esta opção, o Setup Tool restaura a respectiva configuração para os padrões de fábrica.

Após ser selecionada a origem, bem como o dispositivo de destino (ou dispositivos), clique no botão Restaurar, no canto inferior direito.


Como funciona o botão suspenso Restaurar com configurações de rede?

Restaurar com configurações de rede funciona da mesma forma que o botão Restaurar, porém ele restaura a configuração do arquivo .cdc contido na pasta de backup em vez do arquivo .cfg. Essa opção só é habilitada se um .cdc estiver disponível em uma origem específica e a seleção de destino contiver um único dispositivo.


Atualizar firmware


Como atualizar o firmware do leitor?

Selecione Sistema->Atualizar Firmware..., depois selecione o arquivo de firmware.

Observação: Os arquivos de firmware são fornecidos na forma de arquivos compactados. O firmware deve ser carregado em sua forma compactada; não tente descompactar um arquivo de firmware antes de carregá-lo.


Como usar a função Atualizar firmware?

Essa função atualiza o dispositivo ou dispositivos selecionados para a versão de firmware desejada. Selecione o dispositivo ou dispositivos que deseja atualizar a partir da lista de dispositivos.

Navegue por arquivos de firmware clicando no ícone '...’. Se um único dispositivo estiver selecionado na lista de dispositivos, a pasta de firmware apropriada para esse dispositivo é aberta. Se estiverem selecionados múltiplos dispositivos, mas tiverem o mesmo ID de dispositivo de firmware, é aberta a pasta apropriada. Se nenhum dispositivo estiver selecionado ou estiverem selecionados mais dispositivos, mas tiverem diferentes IDs de dispositivo de firmware, é aberta a pasta de firmware de raiz.

Se a caixa de seleção na parte inferior estiver selecionada, o Setup Tool faz o backup dos arquivos de configuração do mesmo modo que a função Backup faz (consulte Perguntas e Respostas de Backup para mais detalhes).

Após selecionar o arquivo de firmware, clique em Atualizar firmware, no canto inferior direito. O botão somente é habilitado se a versão de firmware selecionada e a seleção de dispositivo for compatível.

Observação: No caso de dispositivos seriais, você precisa descobri-los primeiro, atualizando manualmente antes de poder atualizar o firmware.


Comparar configuração


Comparar configuração: Disposição geral e estrutura

Comparar configuração é uma ferramenta do estilo de visualização de tabela usada para configurar, copiar, comparar ou restaurar configurações do dispositivo. A área principal da página do documento contém uma grade com as propriedades do dispositivo, que foi selecionada antes de iniciada na página Conectar ao leitor.

Cada tipo de documento de Setup Tool usa sua própria conexão. Em caso de comunicação serial, somente pode ser aberta uma conexão de cada vez.

A linha de cabeçalho exibe o nome ou nomes do dispositivo selecionado. A linha do segundo cabeçalho, embaixo da primeira, exibe as configurações disponíveis para o dispositivo. Os cabeçalhos de linha abaixo (a negrito) podem ser recolhidos ou abertos, clicando no ícone junto deles. Quando um dispositivo é desconectado, surge um ícone reconectar na linha de cabeçalho dele.

As configurações que não são dependentes da configuração de leitura são exibidas somente na primeira coluna (Configuração principal).


Comparar configuração: Controles (mouse e teclado)

Seleção:

  • Mouse: Ao clicar em uma célula da grade, ela é selecionada; o que realça o cabeçalho de linha da célula e o(s) cabeçalho(s) da coluna onde o dispositivo e a configuração pertencem. Os botões do menu e itens no menu de faixa de opções podem mudar em linha com a seleção. Se a célula selecionada estiver na linha de uma linha de cabeçalho, todas as células na coluna atual que pertencem ao cabeçalho são selecionadas.

  • Teclado: As teclas de movimento do cursor navegam a seleção para a célula apropriada. O procedimento de destaque e seleção é o mesmo que por mouse.

Adicionar/alterar valores:

  • Mouse: Para células com editores integrados, clicando no controle do editor (caixa de combinação, caixa de seleção, numérico acima-abaixo) permite a entrada de valores. Para células com editores personalizados (o ícone '...’), abre um editor pop-up, permitindo a entrada do valor.

  • Teclado: Para células com editores integrados, pressionar Enter ou F2 inicia o modo de edição, Esc cancela a edição e um segundo Enter confirma a edição. Os valores podem ser inseridos no texto selecionado sem entrar no modo de edição; no caso, o valor atual é substituído no primeiro pressionamento de tecla.

    Para células numéricas, para além das células com editor de texto integrado, as setas para cima e para baixo aumentam e diminuem o valor.

    Para células suspensas, Enter inicia o modo de edição e exibe os itens suspensos, enquanto as setas para cima e para baixo movem a seleção. Um segundo Enter aplica o valor selecionado e Esc cancela a edição.

    Para células com caixa de seleção, usar o Espaço para alternar estados marcados/desmarcados.

Copiar e colar:

Use as combinações do teclado Ctrl+C e Ctrl+V para copiar e colar, respectivamente; consulte a descrição de copiar-colar dos itens do menu de faixa de opções relacionados para mais informações.


Comparar configuração: Menu de faixa de opções

O menu de faixa de opções pode ser encontrado acima da grade de estilo de visualização de tabela. Seus conteúdos e ícones ativos podem mudar em linha com a seleção das células, linhas ou colunas, na grade. O menu está separado em vários grupos.

  • Dispositivo: As configurações nesse grupo estão relacionadas com os dispositivos e seus arquivos de configuração. Use o botão Adicionar dispositivo... para abrir uma caixa de diálogo onde um ou mais dispositivos podem ser selecionados para serem adicionados à comparação. O botão Adicionar arquivo de configuração... abre um assistente onde você pode pesquisar uma configuração ou arquivo de backup (.dmb,.cdc,.cfg). Se o arquivo selecionado para o dispositivo não contiver toda a informação necessária, os parâmetros em falta devem ser definidos, caso contrário as opções padrão são selecionadas automaticamente. O mesmo se aplica aos casos onde a base de dados do dispositivo virtual não pode corresponder os parâmetros às opções disponíveis (por exemplo, não é encontrada a versão de firmware compatível).

    Observação: Os dispositivos virtuais adicionados são somente de leitura, conforme marcado pelo ícone de cadeado na sua linha de cabeçalho.

    Clicar no botão Remover dispositivo remove o(s) dispositivo(s) selecionado(s) atualmente (aquele que contém a(s) célula(s) selecionada(s) atualmente). Reiniciar dispositivo reinicia os dispositivos selecionados. Configuração de persistência no dispositivo salva o arquivo de configuração do dispositivo selecionado para a memória flash. Use Reinicializar para padrões de fábrica para reinicializar o(s) dispositivo(s) selecionado(s) para seus padrões.

  • Editar: Use Copiar (ou Ctrl+C no teclado) para copiar um valor da célula selecionada atualmente. Colar somente pode ser usado na mesma linha ou em qualquer editor de texto. Redefinir valores é usado para redefinir o valor (ou valores) da(s) célula(a) selecionada(s).

  • Destaque: Os botões e configurações nesse grupo do menu fornecem opções para destacar planos de fundo específicos da célula. Com o parâmetro Valores não padrão, as células que possuem valores não padrão são destacadas (isso pode ser diferente em uma única linha para diferentes dispositivos ou configurações de leitura). A configuração Diferença para referência destaca células que possuam valores diferentes da célula na mesma linha da configuração de leitura de referência (e dispositivo). A terceira configuração está selecionada; todos os valores e cabeçalhos que contêm o texto especificado na caixa de texto estão destacados. Adicionalmente, o próprio texto contido está destacado com um plano de fundo de texto diferente. Pressionar Enter também aplica a função do botão Exibir somente linhas destacadas.

    Quando habilitado, Exibir somente linhas destacadas recolhe todos os nós que não tenham qualquer subnó destacado. Quando ativado, Definir configuração de leitura de referência especifica a configuração de leitura (e dispositivo) que é usada como referência quando o modo de destaque Diferença para referência é usado. Quando o botão está ativo, a coluna da célula atualmente selecionada (configuração de leitura) torna-se a configuração de referência. A configuração de leitura atual é marcada na linha de cabeçalho do nome da configuração.

  • Filtragem: Defina Parâmetros da configuração de leitura para visualizar somente as configurações que são dependentes da configuração de leitura. Defina Configurações globais para visualizar somente configurações que não podem conter valores diferentes em diferentes configurações de leitura. Defina Todas as configurações para visualizar todas as configurações simultaneamente. Se uma entrada possuir valores em mais configurações de leitura, eles estão visíveis em colunas diferentes.

  • Outro: Use Expandir todas as linhas para expandir todas as linhas que tenham sido recolhidas na grade. Use Recolher todas as linhas para recolher todas as linhas expandidas na grade. Redefinir layout recalcula as larguras da coluna para utilizar todo o espaço disponível. Se o espaço disponível não for suficiente, é aplicada uma largura de coluna mínima.


Comparar configuração: Comparar editor

Comparar editor abre para cada item de Script na visualização de tabela Comparar configuração (em qualquer uma de suas subcategorias), após clicar no ícone '...’. Após abrir, pode visualizar a origem de script do dispositivo onde Comparar editor foi aberto.

Clicando em Padrão, o script reverte para o script padrão, para o dispositivo particular. Clicando em Comparar, o script padrão surge no segundo dispositivo, à direita, porém o menu suspenso na parte superior pode ser usado para alterar qual o script a comparar ao do lado esquerdo. É exibido um botão Atualizar no meio, entre as guias (vermelho, setas circulares), que pode ser usado para atualizar todos os textos de script.

Clicar Fechar fecha a comparação e volta à visualização de tabela dentro de Comparar configuração.


Janela de imagem


Para que serve o Visualizador de imagens?

Nessa janela, você pode ver a imagem lida pelo seu dispositivo.

Use os ícones de lupa para ajustar automaticamente a imagem ao tamanho da janela Visualizador de imagens, para aumentar e diminuir o zoom da imagem ou para exibir a imagem em um modo pixel a pixel, respectivamente.

Você também pode habilitar ou desabilitar o Retorno do foco na imagem no modo Visualização ao vivo, além de copiar a imagem para a área de transferência.

Use a opção Salvar imagem para salvar a imagem atual ou todas as imagens do burst e as opções de Registro para registrar todas as imagens não lidas ou decodificadas no sistema de arquivos.

Você também pode escolher verificar o histograma da imagem lida e os dados de brilho de um ponto selecionado na imagem. Use os botões da barra da faixa de opções da janela para realizar essas tarefas.


Histórico de resultados


Para que serve o Histórico de resultados?

Nesse painel você pode ver as informações decodificadas após cada leitura.

Use o botão Pausa para pausar/congelar a Visualização de ferramenta do histórico de resultados, que torna a localização de informação de leitura específica mais fácil. Todos os resultados de Entrada do dispositivo serão rejeitados pela janela de histórico de resultados até que ele não esteja pausado.

Use Apagar histórico para apagar a lista do histórico. Você também pode exportar uma única cadeia decodificada ou todas elas usando as opções Copiar e Copiar tudo, respectivamente.

Em Registro em log, marque Gerar relatórios de qualidade de código para incluir os dados de qualidade de código nas informações decodificadas, marque Gerar relatórios de validação de dados para incluir informações de validação de dados e Registrar em log todos os resultados no sistema de arquivos para salvar todos os itens do histórico de resultados no disco rígido local. Outras opções para isso podem ser acessadas clicando em Configurações de registro e relatório.

A opção Personalizar permite adicionar ou remover colunas da tabela para personalizar as informações do histórico de resultados.

Para filtragem de resultado, observe a questão abaixo.


Como funciona a filtragem de resultado?

É possível usar o botão Filtrar... no menu de faixa de opções da Visualização de ferramenta Histórico de resultados para filtrar os resultados de leitura apresentados na exibição. Clicando no botão, a filtragem é habilitada. Para configurar parâmetros de filtragem, abra as opções, clicando no lado direito do botão.

Observação: O botão de Filtro somente é exibido se o sistema operacional o suportar.

Estão disponíveis dois modos nas configurações de filtragem: filtragem padrão e filtragem avançada. Você pode selecionar qualquer um no menu suspenso em Geral.

Quando é usada a filtragem padrão, as categorias de filtragem são exibidas como ativas na janela suspensa (Status do resultado, Método de validação, Status da validação e Simbologia). É possível selecionar filtros individuais em cada categoria, clicando neles. Uma vez habilitados, esses filtros são usados em todos os itens futuros, em histórico de resultados e retroativamente também. Os itens não especificados pelos filtros são descartados do histórico de resultados até a filtragem estar desabilitada. Observe que, na filtragem padrão, um único resultado de boa leitura em uma sequência de disparo conta como uma boa leitura para toda a sequência de disparo. Logo, por exemplo, a filtragem padrão não é aplicável aos cenários de códigos múltiplos; use scripts de filtragem avançada para cenários de códigos múltiplos.

Usando a filtragem avançada, as categorias de filtragem padrão ficam inativas e Configurações avançadas da filtragem é ativado na janela suspensa. Ao clicar aí, uma nova janela abre, onde você pode editar as expressões do filtro. Se um filtro predefinido tiver sido habilitado previamente, a expressão gerada pode ser visualizada aí, no diálogo. A edição da expressão não possui qualquer efeito retrogrado nos filtros predefinidos.

A expressão do filtro em si mesma é uma função JavaScript. O uso de membros de dados do resultado é o mesmo daquele com a formatação por script. O resultado da expressão pode ser visualizado na janela, no lado inferior. Em caso de erro de JavaScript, a mensagem de erro é exibida na janela de texto. Observe que, apesar das semelhanças, a filtragem avançada não é um script de formatação de dados, apenas um filtro de exibição em funcionamento no Setup Tool.


Por que o símbolo aparece destacado em verde mas nenhum dado aparece na lista Histórico de resultados?

Se a caixa de seleção Formatação padrão habilitada estiver marcada no painel Formatação padrão, neste caso, você deverá construir uma cadeia de saída personalizada ou nenhum dado de resultado aparecerá, ainda que o leitor tenha decodificado o símbolo.


Por que alguns resultados possuem um ícone na frente?

Os resultados encabeçados por um ícone possuem uma imagem salva associada a ele. Clique na linha de resultado para visualizar a tentativa de decodificação e a imagem associada a ele.


Como visualizar os resultados de códigos múltiplos?

Para habilitar os resultados de códigos múltiplos, você deve aumentar o parâmetro Número de códigos do valor padrão de 1 na guia Códigos múltiplos no painel Configurações de simbologia.

Se o seu leitor detecta e decodifica vários símbolos na mesma imagem, cada símbolo aparece destacado em verde e a grade do histórico de resultados da leitura visualiza uma única linha mostrando todos os dados decodificados concatenados em uma linha. Os resultados são separados e seguidos de caracteres ASCII para retorno de carro (<0x0d>) e aliment. de linha (<0x0a>). Para visualizar o resultado separado para cada símbolo, clique no sinal "+" próximo aos resultados concatenados.

Quando você clicar em um resultado individual, o Visualizador de imagens destacará o símbolo correspondente.


Por que são vistos resultados individuais em vez de resultados de código múltiplo no modo de disparo automático?

No modo de disparo automático, o leitor mostra resultados individuais múltiplos em linhas separadas no Histórico de resultados da leitura. Ao contrário dos outros modos de disparo, nesta opção, os resultados não são concatenados. Como padrão, o modo de disparo automático aceita resultados parciais.


Qualidade do código


Qual a função da guia Qualidade do código?

A Qualidade do código permite validar que os símbolos que você usa atendem as diretrizes de qualidade, conforme delineado em um dos padrões de qualidade do código sustentados pela Cognex. É atribuído um grau geral aos códigos após serem graduadas as métricas selecionadas, ou todas (padrão), de um determinado padrão de qualidade do código. A Qualidade do código é ativada através de licença.

Para obter mais informações detalhadas sobre padrões de qualidade de código específicos e suas métricas, por favor consulte o Guia de programação e configurações ou a documentação padrão ISO correspondente, que pode ser encontrada em www.iso.org.


Como usar o Painel geral?

O painel Geral funciona como um concentrador, para habilitar a avaliação de qualidade de código para diferentes tipos de códigos: códigos de barras 1D, DataMatrix, códigos QR e DotCode. Para cada um desses tipos de simbologia, você pode especificar para que padrão de qualidade do código deseja que o leitor avalie os códigos lidos.

Se as métricas necessárias tiverem sido selecionadas, navegue para as subguias Códigos de barras 1D e/ou Códigos 2D apropriadas para personalizar adicionalmente a avaliação da qualidade do código, se necessário.

Após habilitar a graduação de qualidade do código, o dispositivo fornece resultados de qualidade para cada símbolo lido, para o qual a qualidade do código foi habilitada em Visualização de ferramenta de qualidade do código. Se deseja verificar os detalhes da avaliação da qualidade do código, certifique-se de habilitar Visualização de ferramenta de qualidade do código, clicando em Qualidade do código em Exibição. Na Visualização de ferramenta, são exibidos o grau para cada métrica usada e um grau geral.


Que configurações estão disponíveis nas guias Códigos de barras 1D e Códigos 2D?

Após ter selecionado o padrão de qualidade do código desejado que pretende usar para a avaliação de qualidade do seu tipo de código, na guia Geral, você pode navegar para a subguia de padrão de qualidade do código apropriada, em Códigos de barras 1D ou guias Códigos 2D e personalizar os limites para graus específicos, inclusão de graus específicos no grau geral e suas exibições no relatório.

Observe que microQR não é suportado para a graduação de qualidade do código.


O que pode ser configurado na guia Códigos de barras 1D?

Após configurar seu dispositivo para computorizar a Capacidade de leitura 1D ou ISO/IEC 15416 Cognex para Códigos de barras 1D (na guia Geral no painel Qualidade do código), essa guia permite que você gerencie aspetos da avaliação desse tipo de código.

Na caixa suspensa Grau mínimo de aprovação para o resultado geral, você pode especificar que grau mínimo é aceito como uma “Aprovação” para o padrão de qualidade do código em questão.

Marcando a caixa de seleção Personalizar limite, você pode anular e personalizar configurações do limite definidas originalmente no padrão de qualidade do código fornecido. Observe que se você marcar e desmarcar a caixa de seleção, os valores de limite são redefinidos para os valores-padrão. Eles fornecem uma lista de métricas para o padrão e cada uma dessas métricas possui as seguintes configurações:

  • Limite pode ser configurado para os graus A, B, C e D. Se um valor métrico exceder esse limite, é atribuído o respetivo grau. O grau F é atribuído se o valor não alcançar o limite do grau D. Observe que algumas métricas não possuem limites, de acordo com os padrões ISO (para detalhes, consulte http://www.iso.org, para os respetivos padrões ISO).

  • Usar para cálculo geral: se marcada, essa métrica é usada para o cálculo do grau geral.

  • Incluir no relatório: se marcada, essa métrica é incluída no relatório de qualidade do código, diretamente disponível do leitor, via transferência FTP ou gerada pelo Setup Tool, via relatório de registro, e na cadeia de resultados que pode ser habilitada na guia Cadeia de resultados.

Observe que, devido à sua natureza (como definido nos padrões), nem todas as métricas possuem todas as opções disponíveis (por exemplo, se o padrão ISO não atribui um grau à métrica).


Que métricas individuais são usadas para a Capacidade de leitura 1D?

Abaixo consta uma lista das métricas calculadas para a avaliação da qualidade da Capacidade de leitura 1D. Para obter mais informações detalhadas sobre esse padrão de qualidade do código e suas métricas, por favor consulte o Guia de programação e configurações.

  • Int varredura múltipla (Integridade de varredura múltipla) é uma medição da decodabilidade do símbolo, que você obtém através da combinação de múltiplas varreduras do símbolo. Quanto maior for a medição, maior é o grau.

  • Contraste mínimo da borda é a diferença mais baixa entre a refletância da barra e a refletância do espaço de dois elementos adjacentes, que fornece uma indicação da nitidez das bordas. Quanto maior for a diferença, maior é o grau.

  • Refletância mínima é o valor mínimo de refletância na varredura, uma medição da parte mais escura do código de barras. Quanto mais baixo for o valor, maior é o grau.

  • Crescimento da impressão mede o desvio da barra e largura do espaço das larguras correspondentes (indicado na especificação da simbologia), ou seja, mede se as barras são mais estreitas/mais largas comparativamente aos espaços no símbolo. Quanto maior for a diferença, mais baixo é o grau.

  • Contraste do símbolo é a diferença entre os valores de refletância mais baixos e mais altos de uma varredura (a diferença na refletância entre a barra mais escura e o espaço mais claro). O grau é maior com uma diferença maior.

  • Int varredura única (Integridade de varredura única) é uma medição da decodabilidade do símbolo com uma única varredura. A decodabilidade é mais baixa se as múltiplas localizações do código de barras estiverem danificadas.


Que métricas individuais são usadas para ISO/IEC 15416?

Abaixo consta uma lista das métricas calculadas para a avaliação da qualidade ISO/IEC 15416. Para obter mais informações detalhadas sobre esse padrão de qualidade do código e suas métricas, por favor consulte o Guia de programação e configurações ou a documentação padrão ISO correspondente, que pode ser encontrada em www.iso.org.

  • Decodabilidade é a mediação da precisão de impressão do código de barras relativamente ao algoritmo de decodificação de referência específico da simbologia. A decodabilidade indica a escala de erro na largura do elemento com maior desvio no símbolo. Quanto mais baixo for o desvio, maior é o grau.

  • Defeitos são irregularidades nos elementos (barras e espaços) e áreas silenciosas. O parâmetro é usado para medir o “ruído” resultante dos declives e picos indesejados, no Perfil de refletância da varredura. Quanto menor for o defeito, melhor é o grau.

  • Contraste mínimo da borda é a diferença mais baixa entre a refletância da barra e a refletância do espaço de dois elementos adjacentes, que fornece uma indicação da nitidez das bordas. Quanto maior for a diferença, maior é o grau.

  • Refletância mínima é o valor mínimo de refletância na varredura, uma medição da parte mais escura do código de barras. Quanto mais baixo for esse valor, maior é o grau.

  • Modulação é a taxa de Contraste mínimo da borda para Contraste do símbolo ou uma medição de como um scanner visualiza elementos largos (barras ou códigos) relativamente a elementos estreitos. Quanto maior for a diferença entre Contraste mínimo da borda e Contraste do símbolo, mais baixo é o grau.

  • Contraste do símbolo é a diferença entre os valores de refletância mais baixos e mais altos de uma varredura (a diferença na refletância entre a barra mais escura e o espaço mais claro). O grau é maior com uma diferença maior.

  • Decodificação de referência indica se o algoritmo Data Matrix 2D padrão foi capaz de localizar e decodificar essa marca em particular.

    Essa métrica gera um grau de A ou F.

  • Determinação da borda é o número de bordas detectadas no Perfil de refletância da varredura. Se o número de bordas detectadas for maior ou igual ao número de bordas esperadas, o grau é 4. De outro modo, o grau é 0.


O que pode ser configurado na guia Códigos 2D?

Após configurar seu dispositivo para computorizar ISO/IEC 15415, AIM-DPM/ISO/IEC TR29158, SEMI T10 ou DotCode para Códigos 2D, (na guia Geral, no painel Qualidade do código), essa guia permite que você gerencie aspectos da avaliação desse tipo de código.

Na caixa suspensa Grau mínimo de aprovação para o resultado geral, você pode especificar que grau mínimo é aceito como uma “Aprovação” para o padrão de qualidade do código em questão.

Marcando a caixa de seleção Personalizar limite, você pode anular e personalizar configurações do limite personalizadas, definidas originalmente no padrão de qualidade do código fornecido. Observe que se você marcar e desmarcar a caixa de seleção, os valores de limite são redefinidos para os seus padrões. Essas opções fornecem uma lista de métricas para o padrão e cada uma dessas métricas possui as seguintes configurações:

  • Limite pode ser configurado para os graus A, B, C e D. Se um valor métrico exceder esse limite, é atribuído o respetivo grau. O grau F é atribuído se o valor não alcançar o limite do grau D. Observe que algumas métricas (p. ex. SEMI 10) não possuem limites, de acordo com os padrões ISO (para detalhes, consulte http://www.iso.org, para a documentação do respetivo padrão ISO).

  • Use para cálculo geral: se marcada, essa métrica é usada para o cálculo do grau geral. Observe que as métricas SEMI T10 não possuem essa opção.

  • Incluir no relatório: se marcada, essa métrica é incluída no relatório de qualidade do código, diretamente disponível do leitor, via transferência FTP ou gerada pelo Setup Tool, via relatório de registro, e na cadeia de resultados que pode ser habilitada na guia Cadeia de resultados.

Observe que, devido à sua natureza, nem todas as métricas possuem todas as opções disponíveis (por exemplo, se o padrão ISO não atribui um grau à métrica).

Observação: MicroQR não é suportado para a graduação de qualidade do código 2D.


Que métricas individuais são usadas para AIM-DPM/ISO/IEC TR29158?

Abaixo consta uma lista das métricas usadas para a avaliação da qualidade AIM-DPM/ISO/IEC TR29158. Para obter mais informações detalhadas sobre esse padrão de qualidade do código e suas métricas, por favor consulte o Guia de programação e configurações ou a documentação padrão ISO correspondente, que pode ser encontrada em www.iso.org.

  • Não uniformidade da grade é uma medição para quantidade de localização de erros para as células individuais de uma grade de espaço uniforme, como medido, usando o padrão relógio de um símbolo.

  • Correção de erro não usada é uma medição para a porcentagem de palavras código deixadas em um símbolo depois de corrigir qualquer erro.

    Ao calcular a Correção de erro não usada, uma palavra código é considerada errada se ao menos uma de suas células estiver no lado errado do limite global. Os símbolos Data Matrix 2D possuem uma redundância de código embutido ou a presença de conteúdo de dados duplicado.

    Um valor de 1.00 significa que nenhum erro estava presente em qualquer uma das palavras código.

  • Não uniformidade axial é uma medição da simetria das células individuais dentro do símbolo, ou seja, a quantidade de desvio ao longo dos eixos do símbolo.

  • Contraste da célula é uma medição da diferença da refletância entre as células claras e as células escuras no símbolo, representada como uma porcentagem das células claras, significa o valor refletido.

    A especificação AIM-DPM/ISO/IEC TR 29158 necessita que a imagem seja ajustada para que as células claras tenham um valor de refletância principal de 78 % da saturação completa.

  • Dano do padrão fixo é a qualidade dos padrões finder, clocking e área silenciosa dentro da marca.

    O leitor usa vários padrões dentro de cada símbolo para localizar e decodificar os dados que contém. O leitor gera o grau de Dano do padrão fixo usando o mesmo método que o score de Modulação da célula, especificamente uma medição da confiança da refletância.

  • Modulação é uma medição da capacidade de leitura para a marca atual.

    O grau é um reflexo de quão perto as células de brilho e as células escuras se aproximam de um limite global para uma marca em particular, indicando o ponto de separação do nível cinza entre as células de brilho e as células escuras de qualquer marca em particular.

    Uma marca gera um grau baixo de Modulação quando existe uma confiança relativamente baixa de o leitor conseguir classificar células individuais como claras ou escuras. O score também leva em consideração a capacidade de correção do erro construída no símbolo (com símbolos grandes tendo mais capacidade de correção do erro). Por exemplo, uma marca irá receber um grau baixo de Modulação mas um grau alto de Correção de erro não usada se a maioria das células estiverem prestes a mudar de estado mas não o fizerem de fato.

  • Crescimento da impressão mede o desvio da barra e largura do espaço das larguras correspondentes (indicado na especificação da simbologia), ou seja, mede se as barras são mais estreitas/mais largas comparativamente aos espaços no símbolo. Quanto maior for a diferença, mais baixo é o grau.


Que métricas individuais são usadas para ISO/IEC 15415?

Abaixo consta uma lista das métricas usadas para a avaliação da qualidade ISO/IEC 15415. Para obter mais informações detalhadas sobre esse padrão de qualidade do código e suas métricas, por favor consulte o Guia de programação e configurações ou a documentação padrão ISO correspondente, que pode ser encontrada em www.iso.org.

  • Não uniformidade da grade é uma medição para quantidade de localização de erros para as células individuais de uma grade de espaço uniforme, como medido, usando o padrão relógio de um símbolo.

  • Correção de erro não usada é uma medição para a porcentagem de palavras código deixadas em um símbolo depois de corrigir qualquer erro.

    Ao calcular a Correção de erro não usada, uma palavra código é considerada errada se ao menos uma de suas células estiver no lado errado do limite global. Os símbolos Data Matrix 2D possuem uma redundância de código embutido ou a presença de conteúdo de dados duplicado.

    Um valor de 1.00 significa que nenhum erro estava presente em qualquer uma das palavras código.

  • Não uniformidade axial é uma medição da simetria das células individuais dentro do símbolo, ou seja, a quantidade de desvio ao longo dos eixos do símbolo.

  • Contraste do símbolo é a diferença entre os valores de refletância mais baixos e mais altos em uma varredura (a diferença na refletância entre a barra mais escura e o espaço mais claro). O grau é maior com uma diferença maior

  • Refletância extrema é um valor sim/não indicando se o substrato em torno do símbolo contém extremos de refletância que podem interferir com a leitura.

  • Dano do padrão fixo é a qualidade dos padrões finder, clocking e área silenciosa dentro da marca.

    O leitor usa vários padrões dentro de cada símbolo para localizar e decodificar os dados que contém. O leitor gera o grau de Dano do padrão fixo usando o mesmo método que o score de Modulação da célula, especificamente uma medição da confiança da refletância.

  • Modulação é a taxa de Contraste mínimo da borda para Contraste do símbolo ou uma medição de como um scanner visualiza elementos largos (barras ou códigos) relativamente a elementos estreitos. Quanto maior for a diferença entre Contraste mínimo da borda e Contraste do símbolo, mais baixo é o grau.

  • Crescimento da impressão mede o desvio da barra e largura do espaço das larguras correspondentes (indicado na especificação da simbologia), ou seja, mede se as barras são mais estreitas/mais largas comparativamente aos espaços no símbolo. Quanto maior for a diferença, mais baixo é o grau.


Que métricas individuais são usadas para SEMI T10?

Abaixo consta uma lista com as métricas usadas na especificação de SEMI T10. Para obter mais informações detalhadas sobre essa especificação de qualidade do código e suas métricas, por favor consulte o Guia de programação e configurações ou a especificação semi correspondente, que pode ser encontrada em www.semi.org.

  • Defeitos no padrão do finder é a taxa de pixels incorretos para pixels totais no padrão do finder.

  • Defeitos da célula é a taxa de pixels incorretos para pixels totais na grade.

  • Desvio vertical da marca é o desvio médio vertical das marcas DataMatrix dos seus Pontos de célula centrais ideais DataMatrix.

  • Desvio horizontal da marca é o desvio médio horizontal das marcas DataMatrix dos seus Pontos de célula centrais ideais DataMatrix.

  • Altura da célula DataMatrix é a altura média de cada célula na matriz (em pixels).

  • Largura da célula DataMatrix é a largura média de cada célula na matriz (em pixels).

  • Crescimento vertical da marca é o rastreamento da tendência para marcar o símbolo acima ou abaixo, ou seja, uma comparação de tamanho vertical entre as células marcadas atuais vs. o seu tamanho nominal.

  • Crescimento horizontal da marca é o rastreamento da tendência para marcar o símbolo acima ou abaixo, ou seja, uma comparação de tamanho horizontal entre as células marcadas atuais vs. s seu tamanho nominal.

  • Relação sinal-ruído é uma medida relativa do Contraste do símbolo para o desvio máximo em níveis claros ou em tons de cinza escuro no símbolo (ou seja, ruído).

  • Correção de erro não usada é a medição para a porcentagem de palavras código deixadas em um símbolo depois de corrigir qualquer erro.

    Ao calcular a Correção de erro não usada, uma palavra código é considerada errada se ao menos uma de suas células estiver no lado errado do limite global. Os símbolos Data Matrix 2D possuem uma redundância de código embutido ou a presença de conteúdo de dados duplicado.

    Um valor de 1.00 significa que nenhum erro estava presente em qualquer uma das palavras código.

  • Contraste do símbolo é a diferença entre os valores de refletância mais baixos e mais altos em uma varredura (a diferença na refletância entre a barra mais escura e o espaço mais claro). O grau é maior com uma diferença maior


Que métricas individuais são usadas para DotCode?

Abaixo consta uma lista das métricas usadas para a avaliação da qualidade de DotCode. Para obter mais informações detalhadas sobre esse padrão de qualidade do código e suas métricas, por favor consulte o Guia de programação e configurações ou a documentação padrão ISO correspondente, que pode ser encontrada em www.iso.org.

  • Não uniformidade da grade é uma medição para quantidade de localização de erros para as células individuais de uma grade de espaço uniforme, como medido, usando o padrão relógio de um símbolo.

  • Correção de erro não usada é a medição para a porcentagem de palavras código deixadas em um símbolo depois de corrigir qualquer erro.

    Ao calcular a Correção de erro não usada, uma palavra código é considerada errada se ao menos uma de suas células estiver no lado errado do limite global. Os símbolos Data Matrix 2D possuem uma redundância de código embutido ou a presença de conteúdo de dados duplicado.

    Um valor de 1.00 significa que nenhum erro estava presente em qualquer uma das palavras código.

  • Crescimento da impressão mede o desvio da barra e largura do espaço das larguras correspondentes (indicado na especificação da simbologia), ou seja, mede se as barras são mais estreitas/mais largas comparativamente aos espaços no símbolo. Quanto maior for a diferença, mais baixo é o grau.

  • Não uniformidade axial é uma medição da simetria das células individuais dentro do símbolo, ou seja, a quantidade de desvio ao longo dos eixos do símbolo.

  • Contraste do símbolo é o valor de diferença entre os valores de refletância mais baixos e mais altos em uma varredura (a diferença na refletância entre a barra mais escura e o espaço mais claro). O grau é maior com uma diferença maior


Qual a função da guia Cadeia de resultados?

Marcando a caixa de seleção Acrescentar dados de qualidade do código à cadeia de resultados, você habilita a formatação de dados baseada em token e permite que os dados do resultado de qualidade do código sejam acrescentados às cadeias de resultados. Se selecionada, a Saída do grau geral emite o grau geral de qualidade do código (que é definido como o grau mínimo das métricas selecionadas) na cadeia de resultados.

Em Dados reportados, pode especificar se deseja que graus, valores, ambos ou nenhum sejam incluídos nos dados da cadeia de resultados. A seção Separador para elementos de dados permite definir separadores antes e entre os valores de qualidade do código incluídos em uma cadeia de resultados.

Descrição personalizada do relatório de qualidade permite definir um texto personalizado, que é adicionado ao cabeçalho do relatório de qualidade do código, diretamente disponível a partir do leitor, via transferência FTP ou gerado pelo Setup Tool, via relatório de registro.

Observe que, no caso de códigos múltiplos, o token de formatação <Dados PCM> tem de ser acrescentado a todas as simbologias usadas.


O que indica ou retângulo duplo que aparece na caixa de seleção?

Um retângulo preenchido mais pequeno dentro de um retângulo mais largo não preenchido é chamado um estado de verificação intermediária. Nesse caso, ele indica que, apesar de a opção estar habilitada, ela não está atuando totalmente (nesse caso, principalmente porque o token foi removido manualmente no painel Geração de script).


Qual a função da guia Transferência de relatório por FTP?

A guia Transferência de relatório por FTP permite configurar resultados de qualidade do código a serem enviados via FTP em forma de um relatório HTML. Você deve marcar a caixa de seleção Habilitar transferência do relatório de qualidade do código para permitir que o dispositivo envie os resultados por FTP e para identificar o servidor para o qual você pretende enviar os dados, fornecendo o endereço do servidor, nome do usuário, senha e tipo do servidor.

O Tempo limite de ociosidade é a quantidade de tempo que uma porta será mantida aberta sem nenhum tráfego de saída. Assim que o leitor abrir uma conexão com um servidor FTP, ele manterá essa conexão aberta enquanto houver tráfego. Se não houver tráfego durante o período de Tempo limite de ociosidade definido, a conexão é fechada. Isso pode ser útil se uma transferência FTP somente acontecer pontualmente e não for desejada a sobrecarga da rede para manter a conexão aberta. Primeiro, é necessário marcar a opção Habilitar tempo limite de ociosidade para poder definir o tempo limite de ociosidade.

As configurações em Nome do arquivo regem a criação do nome do arquivo do relatório de FTP. Existem opções disponíveis para configurar:

  • Geração de Nome de arquivo personalizado: selecione essa opção se pretender fornecer você mesmo o nome do arquivo. É possível especificar o nome em Nome do arquivo. O campo Nome do arquivo aceita nomes de arquivo e nomes de caminho. Use a barra como delimitador. Por exemplo, /imagens/imagem. Acrescentar configurações permite definir as regras de numeração para geração do nome do arquivo: Valor máx. de acréscimo define o número máximo até ao qual a numeração do nome do arquivo vai, Valor de acréscimo máx. inicial define onde inicia a numeração do nome do arquivo.

  • Nome do arquivo gerado por script: após habilitar essa opção, clique no nome da opção azul para navegar imediatamente para Geração de script > Transferência por FTP, onde já é fornecida a amostra de script para a geração do nome do arquivo.

  • Nome do arquivo gerado pelo servidor: forneça aí o endereço do servidor após selecionar essa opção para gerar nomes do arquivo do relatório baseados em um servidor. Alguns servidores FTP aceitam esta função para nomear os arquivos de entrada de forma exclusiva, antes de salvá-los no disco.


O que devo fazer se as transferências por FTP da opção Nome do arquivo gerado pelo servidor não funcionarem?

Verifique se o servidor FTP aceita o comando "STOU – Store Unique". Este comando se comporta como o STOR, exceto pelo fato de que o arquivo resultante será criado no diretório atual com um nome exclusivo neste diretório.


Por que o painel inteiro está desabilitado ao transferir os arquivos?

O painel está desabilitado para que seja mantida a estabilidade máxima de transferência de imagens por FTP. A transferência de imagens por FTP pode levar algum tempo, dependendo da velocidade da conexão com o servidor FTP, do tamanho da imagem e do número de imagens a transferir.


Visualização de ferramenta de qualidade do código


O que posso ver na Visualização de ferramenta de qualidade do código?

Você pode visualizar os resultados da avaliação da qualidade do código em Visualização de ferramenta de qualidade do código. A computação de qualidade do código deve estar habilitada no painel Qualidade do código (licença necessária) antes de conseguir visualizar os resultados aqui. Para cada leitura selecionada na visualização de ferramenta em Histórico de resultados, os padrões de qualidade do código e métricas definidos anteriormente são exibidos na Visualização de ferramenta de qualidade do código. Na parte superior de cada tipo de padrão de qualidade do código, pode visualizar o grau geral atribuído ao código que foi lido.

Propriedade lista as métricas individuais para o padrão apresentado, Valor é a diferença de valor numérico calculada para as métricas individuais. Grau é o grau de qualidade do código que foi atribuído à métrica (também surge um ícone colorido nessa linha; verde = aprovado, vermelho = falha, amarelo = o valor está no limite). Média é o grau médio (com + e - para tendência), com base nas últimas 100 leituras dessa métrica.

Para obter mais informações detalhadas sobre padrões de qualidade do código, graus e métricas, por favor consulte o Guia de programação e configurações ou a documentação da norma ISO correspondente, que pode ser encontrada em www.iso.org.


Modo de teste


O que é modo de teste?

O modo de teste permite testar e configurar o dispositivo com um sistema ao vivo, sem nenhuma interrupção na produção. Neste modo, todas as fontes do disparo (exceto o Setup Tool e o botão de disparo) são desabilitadas.


O que é Disparo automático?

O disparo automático permite disparar internamente (de forma automática) seu dispositivo em um modo de disparo externo. Ou seja, mesmo que você selecione um tipo de disparo externo (qualquer um diferente dos modos Apresentação ou Disparo automático), você pode disparar o leitor automaticamente no modo de teste. Dessa forma, consegue determinar se o dispositivo está funcionando com os parâmetros que serão usados no modo regular.


Quais recursos são desabilitados/limitados no modo de teste?

  • Todas as fontes do disparo, exceto o Setup Tool e o botão de disparo, são desabilitadas.

  • Você pode desabilitar todas as entradas e saídas. Se fizer isso, os resultados serão enviados apenas para o Setup Tool e os LEDs e bipe funcionarão, mas nenhuma outra saída funcionará.


O que é Número de disparos a serem aceitos?

Você pode definir o número de disparos que serão aceitos antes de todas as fontes de disparo serem desabilitadas.


Configurações de leitura


Para quais modos de disparo as Configurações de leitura são válidas?

As configurações de leitura podem ser usadas nos modos de disparo Único, Automático, Burst e Contínuo. A próxima Configuração de leitura se torna ativa após o tempo de Intervalo especificado (especificação feita no painel Configurações da iluminação e do processador de imagens). Em todos os outros modos de disparo, se várias configurações forem definidas, apenas a configuração ativa selecionada no momento (indicada na barra de status) será usada. Uma vez que não existe um intervalo para o modo de disparo Único, uma configuração de leitura irá para a próxima assim que a primeira aquisição for concluída.


Como posso adicionar, copiar ou excluir configurações?

Para adicionar uma Configuração de leitura, clique no botão Adicionar a configuração. Na janela que se abrirá, decida se quer usar os valores padrão na nova configuração ou decida se quer copiar valores de uma configuração existente.

Para excluir uma Configuração de leitura, selecione-a, selecionando a coluna da configuração de leitura, e clique no botão Excluir configuração.

Para copiar e colar uma Configuração de leitura, selecione a coluna que deseja copiar e clique no botão Copiar ou pressione Ctrl+C e, em seguida, acesse a coluna da Configuração onde deseja que a nova Configuração seja substituída. Clique no botão Colar ou pressione Ctrl+V. Os valores da coluna serão substituídos pelos valores que você copiou e colou.


Qual é a função da opção Iniciando a configuração?

Se várias configurações forem habilitadas, o leitor passa por todas elas e interrompe a aquisição de imagens depois de ter lido um código. Para ler o próximo código, decida se o leitor começará a acessar as configurações a partir da selecionada ou a partir da última decodificação com sucesso.


Posso alterar a ordem das configurações de leitura?

É possível clicar no botão Alterar ordem e reorganizar a ordem das configurações de leitura na janela que irá surgir. As configurações serão renumeradas consecutivamente.


Para que serve o campo Filtrar na parte superior?

É possível digitar um parâmetro que deseja encontrar, por exemplo, "tamanho" ou "burst” e pressionar Enter. Os itens encontrados serão destacados e somente os nós dos parâmetros que contêm os itens procurados serão expandidos. É possível fechar a pesquisa, excluindo o que digitou e pressionando Enter.


Configurações de leitura: Disposição geral e estrutura

Configurações de leitura é uma ferramenta do estilo de visualização de tabela usada para configurar, copiar, comparar ou restaurar configurações de leitura. A área principal da página do documento contém uma grade com as propriedades do dispositivo.

A linha de cabeçalho exibe o nome ou nomes do dispositivo selecionado. A linha do segundo cabeçalho, embaixo da primeira, exibe as configurações disponíveis para o dispositivo. Os cabeçalhos de linha abaixo (a negrito) podem ser recolhidos ou abertos, clicando no ícone junto deles. Quando um dispositivo é desconectado, surge um ícone reconectar na linha de cabeçalho dele.


Configurações de leitura: Controles (mouse e teclado)

Seleção:

  • Mouse: Ao clicar em uma célula da grade, ela é selecionada; o que realça o cabeçalho de linha da célula e o(s) cabeçalho(s) da coluna onde o dispositivo e a configuração pertencem. Os botões do menu e itens no menu de faixa de opções podem mudar em linha com a seleção. Se a célula selecionada estiver na linha de uma linha de cabeçalho, todas as células na coluna atual que pertencem ao cabeçalho são selecionadas.

  • Teclado: As teclas de movimento do cursor navegam a seleção para a célula apropriada. O procedimento de destaque e seleção é o mesmo que por mouse.

Adicionar/alterar valores:

  • Mouse: Para células com editores integrados, clicando no controle do editor (caixa de combinação, caixa de seleção, numérico acima-abaixo) permite a entrada de valores. Para células com editores personalizados (o ícone ‘...’), abre um editor pop-up, permitindo a entrada do valor.

  • Teclado: Para células com editores integrados, pressionar Enter ou F2 inicia o modo de edição, Esc cancela a edição e um segundo Enter confirma a edição. Os valores podem ser inseridos no texto selecionado sem entrar no modo de edição; no caso, o valor atual é substituído no primeiro pressionamento de tecla.

    Para células numéricas, para além das células com editor de texto integrado, as setas para cima e para baixo aumentam e diminuem o valor.

    Para células suspensas, Enter inicia o modo de edição e exibe os itens suspensos, enquanto as setas para cima e para baixo movem a seleção. Um segundo Enter aplica o valor selecionado e Esc cancela a edição.

    Para células com caixa de seleção, usar o Espaço para alternar estados marcados/desmarcados.

Copiar e colar:

Use as combinações do teclado Ctrl+C e Ctrl+V para copiar e colar, respectivamente; consulte a descrição de copiar-colar dos itens do menu de faixa de opções relacionados para mais informações.


Configurações de leitura: Menu de faixa de opções

O menu de faixa de opções pode ser encontrado acima da grade de estilo de visualização de tabela. Seus conteúdos e ícones ativos podem mudar em linha com a seleção das células, linhas ou colunas, na grade. O menu está separado em vários grupos.

  • Visualização de tabela: Use o botão Adicionar a configuração para adicionar uma configuração de leitura. Na janela que se abrirá, decida se quer usar os valores padrão na nova configuração ou decida se quer copiar valores de uma configuração existente. O botão Excluir configuração é usado para excluir a(s) configuração(ões) de leitura selecionada(s). O botão Alterar ordem abre uma caixa onde você pode reorganizar a ordem das configurações de leitura. As configurações serão renumeradas consecutivamente.

  • Iniciar a configuração: Se várias configurações forem habilitadas, o leitor passa por todas elas e interrompe a aquisição de imagens depois de ter lido um código. Para ler o próximo código, decida se o leitor começará a acessar as configurações a partir da selecionada ou a partir da última decodificação com sucesso. Aqui você pode escolher essa configuração inicial a partir de uma lista suspensa. Em alternativa, selecione Última decodificação com sucesso para selecionar a configuração de leitura com a última codificação bem sucedida como configuração inicial.

  • Editar: Use Copiar (ou Ctrl+C no teclado) para copiar um valor da célula selecionada atualmente. Colar somente pode ser usado na mesma linha ou em qualquer editor de texto. Redefinir valores é usado para redefinir o valor (ou valores) da(s) célula(a) selecionada(s).

  • Destaque: Os botões e configurações nesse grupo do menu fornecem opções para destacar planos de fundo específicos da célula. Com o parâmetro Valores não padrão, as células que possuem valores não padrão são destacadas (isso pode ser diferente em uma única linha para diferentes dispositivos ou configurações de leitura). A configuração Diferença para referência destaca células que possuam valores diferentes da célula na mesma linha da configuração de leitura de referência (e dispositivo). A terceira configuração está selecionada; todos os valores e cabeçalhos que contêm o texto especificado na caixa de texto estão destacados. Adicionalmente, o próprio texto contido está destacado com um plano de fundo de texto diferente. Pressionar Enter também aplica a função do botão Exibir somente linhas destacadas.

    Quando habilitado, Exibir somente linhas destacadas recolhe todos os nós que não tenham qualquer subnó destacado. Quando ativado, Definir configuração de leitura de referência especifica a configuração de leitura (e dispositivo) que é usada como referência quando o modo de destaque Diferença para referência é usado. Quando o botão está ativo, a coluna da célula atualmente selecionada (configuração de leitura) torna-se a configuração de referência. A configuração de leitura atual é marcada na linha de cabeçalho do nome da configuração.

  • Filtragem: Parâmetros da configuração de leitura é definido automaticamente, permitindo visualizar somente as configurações que são dependentes da configuração de leitura. Defina Configurações globais para visualizar somente configurações que não podem conter valores diferentes em diferentes configurações de leitura. Defina Todas as configurações para visualizar todas as configurações simultaneamente. Se uma entrada possuir valores em mais configurações de leitura, eles estão visíveis em colunas diferentes.

  • Outro: Use Expandir todas as linhas para expandir todas as linhas que tenham sido recolhidas na grade. Use Recolher todas as linhas para recolher todas as linhas expandidas na grade. Redefinir layout recalcula as larguras da coluna para utilizar todo o espaço disponível. Se o espaço disponível não for suficiente, é aplicada uma largura de coluna mínima.


Registro do dispositivo


O que é Registro do dispositivo?

Essa visão mostra os registros que são gerados quando o LED vermelho piscar no seu dispositivo. É possível atualizar esse registro ou excluí-lo quando ele não for mais necessário.


Tamanho da imagem


Para que é usada a configuração da Região de interesse do decodificador (ROI)?

Você pode usar esta função para especificar a região exata da imagem que o leitor usará para localizar e decodificar um código. Isto pode facilitar quando dois códigos Data Matrix estão próximos um do outro e você precisar garantir que irá ler apenas o código em uma determinada região. A redução da região de interesse não reduz necessariamente o tempo de codificação ou diminui a taxa de transferência da imagem.

OBSERVAÇÃO: Algumas propriedades relacionadas às imagens (por exemplo, tamanho da imagem e filtros) não podem ser alteradas quando o dispositivo está obtendo ou decodificando imagens.


Por que mudar o Campo de visão do processador de imagens?

Disponível para os tipos de disparo único, burst e contínuo, você pode modificar o campo de visualização da câmera para reduzir o tamanho de cada imagem capturada pelo leitor, o que pode aumentar a quantidade da memória e permitir que especifique um comprimento de burst maior.


Por que não é possível alterar a Região de interesse do decodificador?

Verifique se a função Campo de visão do processador de imagens está desmarcada. Se a função Campo de visão do processador de imagens estiver marcada, não será possível fazer com que a Região de interesse do decodificador fique maior que os limites do Campo de visão do processador de imagens.


O tamanho do Região de interesse do decodificador tem efeito nos Códigos de configuração do leitor?

A restrição da Região de interesse para uma muito pequena pode impedir o leitor de conseguir ler os Códigos de configuração do leitor.


Configurações do foco


Qual é a função da opção Otimizar foco?

Conforme no painel de Configuração rápida, o botão Otimizar foco irá ajustar a lente líquida em um valor ideal baseado no campo de visão atual.


O que acontece se eu ligar a opção Retorno da otimização do foco habilitado?

Ao selecionar a caixa, está a habilitar o Retorno da otimização do foco, que, por sua vez, fornece retorno visual da exibição da imagem (pode ser encontrado em Configuração rápida ou Painel de imagem em forma de círculos coloridos sobrepostos na imagem. As zonas vermelhas estão fora do foco, enquanto as zonas verdes estão em foco (quanto maior for o círculo, mais em foco).


Qual é a função da opção Modo de ajuste do foco?

A opção de Modo de ajuste do foco permite especificar um parâmetro pré-configurado para o tempo de ajuste da Lente líquida para aquisição da imagem durante os disparos. Configurar Normal para modo de ajuste normal e Preciso para um modo mais lento, mas mais preciso.


Como determinar o valor de foco correto para a lente líquida?

Para determinar o melhor ajuste para a Varredura do foco, clique na caixa de seleção Visualização ao vivo habilitada e teste com o controle deslizante baseado na imagem ao vivo.


Por que não é possível selecionar Varredura do foco?

A varredura do foco apenas é suportada nos modos de disparo Manual e Apresentação.


Como usar a configuração Variação de foco?

Pode usar a opção Variação de foco para alterar manualmente a distância do foco do dispositivo usando o controle deslizante, os botões '+' e '-' nas extremidades do controle deslizante ou digitando os valores. A variação do foco pode ser fornecida em milímetros ou dioptria. Quando um desses valores é fornecido, o Setup Tool calcula automaticamente o outro valor para corresponder com o que foi alterado.

A região laranja do controle deslizante denota uma faixa estendida (superior a 500 mm), onde somente é aplicável a dioptria. Quando a configuração se encontra dentro dessa região, os valores em milímetros são desabilitados (e são reativados quando os valores estiverem novamente fora da faixa estendida).

Observe que a dioptria diminui quando é usado o botão '+’ e aumenta quando é usado o botão '-’.


Como é calculada a distância até o leitor?

A distância em milímetros é calculada como sendo a distância a partir da tampa da lente até à imagem a ser decodificada.

Quando configurada, a dioptria também é medida a partir da lente até à imagem.


Qual é a função do recurso Configuração da lente modular?

É possível selecionar o tipo de lente líquida que está usando, aqui, no menu suspenso.


Propriedades de EAN.UCC Composite


Quais são as possíveis configurações para as propriedades do EAN.UCC Composite?

  • Padrão (linear e 2D): Consiste de um componente linear (codificação da identificação primária do item) associado com um componente de composição 2D adjacente (dados suplementares de codificação, como o número de grupo ou data de vencimento)

  • Apenas linear: Consiste apenas da codificação do componente linear na identificação primária do item.


O que é CC-C?

CC-C é um dos três componentes do EAN.UCC 2D Composite, especificamente um símbolo PDF417 com uma palavra código de 920 na posição da palavra código do primeiro dado como uma bandeira de conexão e denotando a compactação de dados EAN.UCC.


Validação de dados


O que é Validação de dados?

A Validação de dados é usada para confirmar se os dados codificados por um símbolo estão no formato correto, para uma companhia, indústria ou padrão internacional em particular.


Onde é exibido o Histórico de resultados de validação de dados?

Os resultados da Validação de dados aprovados/reprovados e os de saída são exibidos no Histórico de resultados. A entrada Resultado na lista do histórico de resultados irá receber um ícone ‘+’, abrindo os detalhes do resultado da tentativa de validação. Os resultados de validação anteriores podem ser visualizados no histórico de resultados, da mesma forma.


O que significam os códigos de erro de validação?

Os resultados de Falha de validação de dados são os seguintes:

  • 1: Identificador de simbologia inválido. O identificador de simbologia é a cadeia de três caracteres que não apenas identifica o tipo de simbologia usado para codificar os dados, mas também descreve como processar os dados. Essa série pode ser opcionalmente aprovada como entrada para a ferramenta, além dos dados decodificados como uma entidade separada ou prefixando-a no fluxo de dados.

    Exemplo: Para um símbolo UCC/EAN-128, o identificador de simbologia é ]C1. Em algumas aplicações, essa será a única maneira de diferenciar de forma precisa e automática símbolos de Code 128 internos ou da indústria e UCC/EAN-128 (que codificam os Identificadores de aplicação do EAN.UCC). Sem os identificadores de simbologia, não seria possível saber como processar os dados no símbolo.

  • 2: Modelo não correspondente.

  • 3: Qualificadores de dados inválidos (AI, DI ou TEI).

  • 4: Identificador da aplicação (AI) inválido.

  • 5: Identificador de dados (DI) inválido.

  • 6: Identificador de elemento de texto (TEI) inválido.

  • 7: Dados inválidos: quando os dados não coincidem com o tipo, o tamanho ou o valor do qualificador de dados.

  • 8: Separador de campo inválido.

  • 9: Fora de conformidade com a ISO/IEC 15434.

  • 10: Formatos não suportados (por exemplo, em aplicações do DoD UID, formatos diferentes de 05, 06 ou DD).

  • 11: Código de formato inválido: códigos de formato diferentes de 00-99 e DD.

  • 12: Norma ISO/IEC 15434 não suportada se a opção de validação da norma ISO/IEC 15434 for selecionada mas o fluxo decodificado não for de um símbolo 2D. É possível relatar essa falha apenas se o identificador de simbologia for aprovado como entrada para a ferramenta.

  • 13: Campo de aplicação inválido: campo que não é suportado pela aplicação.

  • 14: Campo de aplicação não suportado: campo que é suportado pela aplicação, mas não pela ferramenta.

  • 15: Dados de aplicação inválidos: quando os dados não atendem aos requisitos específicos da aplicação.

    Exemplo: As aplicações do DoD UID têm os seguintes requisitos: A cadeia de caracteres de ID da empresa não deve ultrapassar 13 caracteres, excluindo o qualificador de dados. A cadeia de caracteres de número de peça, lote ou grupo original (incluindo os caracteres especiais permitidos) não deve exceder 32 caracteres, excluindo o qualificador de dados. A cadeia de caracteres do número de série (incluindo os caracteres especiais permitidos) não deve exceder 30 caracteres, excluindo o qualificador de dados.

  • 16: Presença de vários formatos no mesmo fluxo de dados (por exemplo, em aplicações do DoD UID, não pode haver mais de um formato no fluxo de dados).

  • 17: Campos duplicados: várias ocorrências do mesmo qualificador de dados no mesmo símbolo. Algumas aplicações, como as do DoD UID não permitem campos duplicados no mesmo símbolo.

  • 18: UID inválido: nem todos os campos necessários para construir um Conceito nº1 ou Conceito nº2 válido do UID estão presentes.

  • 19: Conceito nº1 de UID inválido: nem todos os campos necessários para construir um Conceito nº1 válido de UID estão presentes.

  • 20: Conceito nº2 de UID inválido: nem todos os campos necessários para construir um Conceito nº2 válido de UID estão presentes.

  • 21: Código de fim de formato ausente durante a verificação de conformidade com a sintaxe da norma ISO 15434 ou DoD UID.

  • 22: Código de fim de mensagem ausente durante a verificação de conformidade com a sintaxe da norma ISO 15434 ou DoD UID.


O que é Validação DoD UID?

A Validação DoD UID é usada para avaliar se a codificação de dados em um código Data Matrix está codificada corretamente de acordo com as diretrizes Mil Standard 130 do Departamento de Defesa dos EUA. O Departamento de defesa americano solicita agora que todos os itens (acima de 5.000 dólares ou que são serializados de forma única) por ele recebidos ou mantidos em estoque sejam marcados com um número de série único (UII) e com um formato de sintaxe específico. A ferramenta Validação DoD UID é usada para confirmar se os dados de um código foram formatados corretamente, de acordo com os tipos de conceito 1 ou 2 do Departamento da Defesa dos EUA. O recurso de Validação DoD UID também confirma automaticamente se a cadeia de dados está em conformidade com as especificações ISO 15434 e ISO 15418. A saída do UII concatenado (ou apenas os Elementos de dados do UII sem a sintaxe do ISO 15434 e qualificadores de dados USI 15418) é exibida no primeiro campo de resultados, no campo Resultados da validação, no Painel de tarefas dos resultados.

Os elementos dos dados de construção 1 incluem: O identificador da empresa do fabricante EID (CAGE, DUNS, EAN.UCC), identificador para uma companhia, assim como o número de série do produto dentro do seu identificador EID. O identificador da empresa e números de série são representados por um qualificador de dados dependendo se a companhia está usando ou não, um formato DI, AI ou TEI.

Os elementos dos dados de construção 2 incluem: O identificador da empresa do fabricante (EID), o identificador do número de peça do fabricante (NP) e o identificador do número de lote (NL) para a peça e o número de série único para a peça dentro do número de peça específico do fabricante. O identificador da empresa, o número de lote/peça e os números de série são representados por um qualificador de dados específico dependendo se a companhia está usando um formato DI, AI ou TEI.

Observação: Esta opção não está disponível em todos os leitores.


Qual a simbologia que devo usar para a validação DoD UID?

O Departamento de Defesa americano especifica atualmente o código Data Matrix como padrão para a marca impressa UID.


O que é EID esperado?

O EID esperado refere-se ao identificador da empresa na cadeia de dados UII. O identificador da empresa (EID) representa o código CAGE, DUNS, EAN.UCC do fabricante ou outra identificação. O EID esperado é um valor DoD específico.


O que é NP esperado?

NP esperado refere-se ao número de peça fornecido pelo fabricante na série de dados do UII. O NP esperado é um valor DoD específico.


O que é NL esperado?

NL esperado refere-se ao número de lote fornecido pelo fabricante na série de dados do UII. O NL esperado é um valor DoD específico.


O que é validação ISO?

A função validação ISO é usada para determinar se uma cadeia de dados está codificada corretamente de acordo com a sintaxe da norma ISO 15434 ou ISO 15434 além de ISO 15418.

A norma ISO 15434 confirma se a cadeia de dados está codificada com a sintaxe correta que inclui a avaliação dos caracteres ASCII "não imprimíveis" na cadeia assim como o cabeçalho da mensagem, separador do registro, código de formato (Para AI, DI ou TEIs), separadores de grupo e o caractere indicador de fim da transmissão.

O ISO 15418 confirma se a cadeia de dados está codificada com os qualificadores de dados corretos para cada elemento de dados. Dependendo se um fabricante está usando um formato AI, DI ou TEI ou não, cada elemento de dados (código EIN do fabricante, número de peça e número de série) é precedido por um código específico ou 'qualificador de dados'.

Observação: Esta opção não está disponível em todos os leitores.

Observação: Essa opção também permite Identificadores de elemento de texto, conforme definido na especificação ATA CSDD.


O que é validação GS1?

A validação GS1 permite que você verifique a sintaxe e semântica dos símbolos comparando-os com a especificação GS1. O leitor pode validar os dados codificados perante uma cadeia configurável de identificadores. São suportados todos os identificadores da aplicação.

Por padrão, o leitor valida o símbolo de entrada perante a cadeia de formato da Federação Europeia das Indústrias e Associações Farmacêuticas (EFPIA), por exemplo:

<AI(01)><AI(10)><AI(17)><AI(21)>

Usando a validação GS1, você pode configurar o que o leitor transmite quando os dados em um símbolo não passam na verificação, incluindo um retorno de carro e alimentação de linha. O painel de resultados detalhados mostrará um APROVAR ou FALHAR para cada símbolo e listará cada identificador de aplicação no símbolo, acompanhado dos seus elementos de dados.


O que é a Validação de cadeia de correspondência?

A Validação de cadeia de correspondência permite que você especifique uma sequência exata para comparar com a sequência codificada pelo símbolo. Apenas os símbolos contendo uma cadeia que está de acordo com a cadeia especificada irão gerar um resultado positivo.


Como validar cadeias com valores que mudam?

Habilitar o controle Aumentar/Diminuir componente numérico para especificar que uma parte da cadeia para validar é um valor numérico que aumenta ou diminui com cada leitura sucessiva.


Para que é usado o Aumentar/Diminuir componente numérico?

Use esta função para realizar Validação de cadeia de correspondência em aplicações onde dados codificados são serializados ou mudam de alguma forma linear. Por exemplo, uma aplicação de revista ou encadernação onde os números da página são procurados usando códigos de barra para garantir que nenhuma página seja duplicada ou pulada, pode se beneficiar do Aumentar/Diminuir componente numérico.


Como definir as configurações de Aumentar/Diminuir componente numérico?

Você pode usar este recurso se a cadeia que você está validando contém uma sequência de dígitos (0–9) que tanto aumenta ou diminui com cada leitura sucessiva. Para usar esta função, especifique a posição inicial dos dígitos aumentados ou diminuídos no campo Posição inicial (0 é a posição do primeiro caractere) e o número de caracteres que irão mudar no campo Comprimento. Se você selecionar Automático para Comprimento, o leitor irá tratar todos os dígitos consecutivos da posição inicial como o valor de aumento ou diminuição. Use Tamanho do incremento para especificar quanto o valor muda entre as leituras. Selecione um valor negativo se o número diminuir.

Por exemplo, se sua cadeia inicial é ABC_123XXPY e com a leitura sucessiva "123" é aumentado em um, você deverá especificar uma Posição inicial de 4, um Comprimento de 3 e um Tamanho do incremento de 1. (Se você tem certeza que os caracteres em posição 7 nunca devem ter dois dígitos, você também pode especificar Automático para o Comprimento.) Observe que a configuração Auto não aumenta o número de dígitos quando é alcançado o número máximo, mas reinicializa o número como com qualquer configuração de dígito fixada (por exemplo, alcançando 99, com dois dígitos não passa a 100, mas a 00).

Por padrão, se a cadeia é inválida ou não pode ser lida, o valor numérico esperado não muda. Você pode usar as caixas de seleção Atualizar em caso de não leitura e Atualizar em caso de falha de validação para especificar que o valor esperado pode ser mudado quando nenhum código é lido, se o código é inválido ou ambos.


Para que é usada a Validação de correspondência do padrão?

A Validação de correspondência do padrão habilita um usuário a inserir uma cadeia específica de caracteres para confirmar se eles estão presentes na cadeia de dados. Por exemplo, um usuário pode entrar o padrão 17V que é usado em formatos DI para identificar o código da empresa. Se os caracteres 17V são apresentados no código, o leitor irá sinalizar um passe para validação para aquele código. Se os caracteres não estão presentes, o leitor irá sinalizar uma falha para validação.

Você deve usar uma expressão regular como modelo para a validação do modelo.


Para que é usada a Ação de falha de validação?

A Ação de falha de validação é usada para determinar o que é enviado pelo leitor depois de uma falha na validação. O usuário pode selecionar opções diferentes:

  1. Transmitir 'Falha de validação'- O leitor enviará a cadeia 'Falha de validação' depois que um código falhar a validação
  2. Transmitir 'Falha de validação' e cadeia codificada - O leitor enviará a cadeia 'Falha de validação' seguida pela cadeia decodificada completa
  3. Transmitir cadeia decodificada anotada - O leitor enviará a cadeia decodificada junto com a informação sobre o tipo de erro e localização do erro na cadeia
  4. Não transmitir nada - O leitor não irá emitir qualquer informação.
  5. Transmitir 'Falha de validação' + cadeia decodificada entre aspas - O leitor enviará a cadeia 'Falha de validação' seguida pela parte citada da cadeia decodificada


Para que é usada a caixa de seleção Acrescentar retorno de carro/aliment. de linha da Ação de falha de validação?

A caixa de seleção retorno de carro/aliment. de linha é usada para fornecer um retorno de carro/aliment. de linha depois de uma saída de falha de validação.


Como eu pesquiso cadeias de correspondência múltiplas?

Use a validação Correspondência de padrão e digite uma cadeia de correspondência formatada em Perl. Por exemplo, para comparar as cadeias 123, 456 ou 789, digite:

^(123¦456¦789)$


O que acontece quando a validação de dados é habilitada?

O status da validação de dados é mostrado na entrada da lista de resultados Status de resultados do painel Histórico de resultados. O status de uma validação bem-sucedida é "Válido", e o de uma que falhou é "Inválido". Para ver mais detalhes sobre o resultado de validação, o resultado pode ser expandido.


O que é Formatação de dados na validação que falhou?

A formatação de dados "Formatação básica" não é aplicada a um resultado se a validação de dados tiver falhado. Em vez disso, a "Ação de falha de validação" é executada. Ela é diferente em comparação com a formatação de dados "Formatação baseada em script". Se a "Formatação baseada em script" for habilitada, a "Ação de falha de validação" não será executada e a função de formatação de script será executada. Isso permite, por exemplo, refinar o status "Validação de dados" por script.


Configurações de backup


O que é o Backup automático da configuração do leitor?

O backup automático funciona com os dispositivos conectados através da Ethernet. Quando estiver selecionada, esta função faz um backup da configuração do dispositivo em um disco externo (um servidor FTP) sempre que a configuração for salva na memória flash. Um serviço do Cognex Explorer pode receber os dados de backup. A restauração pode ser feita manualmente pelos comandos do Setup Tool, DMCC ou Cognex Explorer.

Configure o leitor com o endereço IP e o número da porta necessário para especificar onde você quer salvar a configuração. Você também poderá definir um nome do usuário e uma senha.


Imprimir código de backup do dispositivo


Para que a opção Imprimir código de backup do dispositivo pode ser usada?

Use essa opção para imprimir os códigos de backup do leitor (reinicialização irrecuperável e código de reinicialização) para que eles possam ser lidos pelo dispositivo. Esses códigos também contêm as configurações de rede.

Na seção Observações, você pode escrever observações importantes que também serão exibidas na página impressa. A seleção da opção Imprimir o código de reinicialização em sua própria página faz com que os códigos de reinicialização sejam impressos em páginas separadas.


Imprimir código de configuração


Para que a opção Imprimir código de configuração pode ser usada?

Use essa opção para imprimir os códigos de configuração do leitor (reinicialização irrecuperável e código de reinicialização) para que eles possam ser lidos pelo dispositivo que você deseja configurar.

Na seção Observações, você pode escrever observações importantes que também serão exibidas na página impressa. A seleção da opção Imprimir o código de reinicialização em sua própria página faz com que os códigos de reinicialização sejam impressos em páginas separadas.


Mestre/escravo


Quais combinações de disparo suportam o grupo mestre/escravo?

O grupo do disparo mestre/escravo funciona corretamente apenas se o mestre e escravo usarem combinações específicas e permitidas dos modos de disparo. As combinações são as seguintes:

  • Automático/Automático

  • Único/Burst, Único/Único, Burst/Burst, Burst/Único

  • Manual/Contínuo, Manual/Manual, Contínuo/Contínuo, Contínuo/Manual

  • Apresentação/Apresentação, Automático/Apresentação, Apresentação/Automático


O que é o disparo em grupo?

Todos os leitores do mesmo grupo e na mesma sub-rede são disparados por uma origem única de disparo, originada de um leitor mestre ativo.


Como os resultados são compilados e comunicados?

Quando o Disparo em grupo está habilitado, o leitor irá, como mestre, combinar os resultados dos escravos e, como escravo, enviará os resultados para o mestre.


Como adicionar um novo Nome do grupo?

  1. Clique no botão Adicionar novo.

  2. A caixa de diálogo Adicionar novo grupo aparecerá. Selecione o nome do grupo desejado e clique em OK. Verifique se você usou um nome de grupo único.

  3. Veja se o novo grupo aparece na lista de Nome de grupo e se o leitor aparece na lista do lado direito.

  4. Em todos os dispositivos que você não deseja alterar, defina uma senha na guia de autenticação, no painel Configurações de rede.


Como posso fazer com que o leitor mestre comunique todos os resultados dos códigos de cada leitor do grupo Mestre/escravo?

No modo Mestre/escravo, o leitor mestre pode ser configurado para comunicar os próprios resultados de código e todos os resultados de código de todos os leitores escravos. Para configurar, acesse o painel Configurações de simbologia e a guia Multicode, e será necessário configurar o ajuste de Número de códigos do leitor mestre. Este número deve ser configurado com o número total de códigos que você gostaria de receber do grupo de leitores mestre/escravo.

Por exemplo, se você tiver um leitor mestre e um leitor escravo, cada um lendo um único código, neste caso, a configuração Número de códigos do leitor mestre deverá ser 2. Se o leitor escravo lia 3 códigos e o leitor mestre lia 1, neste caso, o número de códigos do leitor mestre deverá ser definido como 4. O Número de códigos definido no leitor mestre pode varia de 1 até o número total de códigos lidos por todos os leitores em um grupo único de leitores mestre/escravo.

Observe que se um leitor escravo estiver lendo códigos múltiplos, você também deverá configurar as configurações de códigos múltiplos do leitor escravo de modo que ele lê e retorna os resultados dos códigos múltiplos ao leitor mestre.


Por que o nome do grupo desapareceu?

Você não atribuiu um leitor àquele nome do grupo. Um grupo existe desde que haja pelo menos um leitor atribuído ao grupo. Ao transferir o último leitor para um grupo diferente, o grupo vazio será removido.


Qual é o leitor mestre?

Se os leitores do grupo estiverem usando o modo de disparo automático ou apresentação, neste caso, uma caixa de seleção aparecerá em cada leitor na lista chamada Leitores deste grupo. Marque a caixa de seleção do leitor que você quer definir como o leitor mestre.

Se o grupo de leitores estiver usando um disparo externo ou estiver recebendo um disparo de software (por exemplo, a partir do Setup Tool), neste caso, o leitor que recebe o disparo primeiro atuará como o leitor mestre.

Em todos os modos de disparo, somente um leitor do grupo pode ser o mestre a cada momento.


Por que não é possível encontrar o leitor na lista?

Se o Setup Tool estiver sendo executado em um computador, que estiver em uma sub-rede diferente da subrede de conexão do leitor, o leitor não aparecerá na lista. Adicione o leitor à lista usando o botão Adicionar dispositivo.


Como evitar que outra pessoa se conecte ao meu leitor no grupo?

Defina uma senha para esse leitor específico. Acesse o painel Configurações de rede e defina a senha na guia de autenticação.


O que é o Tempo limite de resposta de escravo?

O Tempo limite de resposta de escravo é o tempo em milésimos de segundos que o mestre espera para receber um resultado de um escravo.


Por que a configuração de Formatação de dados do leitor escravo não funcionou?

No modo Mestre/escravo, o leitor mestre atua como se todos os resultados de código de todos os escravos sejam seus próprios resultados. Isto significa que a formatação de dados do leitor mestre será usada, mas as regras de formatação dos leitores escravos serão desconsideradas.


Como o atraso do disparo no modo Mestre/escravo funciona?

Os leitores mestre e escravo normalmente executam o disparo ao mesmo tempo, entretanto, o atraso do disparo pode ser configurado para o mestre e cada escravo do grupo. O tempo total do atraso do disparo do leitor mestre será definido simplesmente como o tempo do atraso do disparo do leitor mestre. O tempo total do atraso do disparo do leitor escravo será definido como o tempo do atraso do disparo do leitor mestre e o tempo do atraso do disparo do leitor escravo.


Como a opção Nunca ler o mesmo código duas vezes funciona em um sistema mestre/escravo?

Se a opção Nunca ler o mesmo código duas vezes estiver habilitada nas Configurações de decodificação no mestre e o escravo ler o mesmo código, o mestre considerará todos os resultados e filtrará as leituras duplicadas independentemente da origem.


Registro de dados em log


O que é registro de dados em log?

O registro de dados em log permite que você salve automaticamente, em um local de arquivo específico, as imagens lidas com sucesso e as imagens com falha de leitura. Além disso, é possível salvar os relatórios de validação de dados dos símbolos que você verificar, se a opção Validação de dados estiver habilitada para o tipo de código escaneado pelo leitor. Você precisar estar conectado ao Setup Tool para que o registro de dados em log funcione.


Quando desabilitar a Gráficos de sobreposição em um relatório?

Marque Desabilitar os gráficos de sobreposição no relatório se você não quiser que o quadrado verde ao redor do código de leitura apareça no PDF.


Configurações de hora do dispositivo


Que configurações estão disponíveis em Configurações de hora do dispositivo?

É possível selecionar o fuso horário para o seu dispositivo a partir do menu suspenso. A caixa de texto abaixo exibe o texto do fuso horário relacionado, de estilo POSIX, da configuração, e pode ser editada livremente.

Se Habilitar NTP estiver selecionado, o dispositivo sincroniza sua configuração de fuso horário com o servidor designado nas caixas abaixo (NTP1). A segunda caixa (NTP2) aponta para um segundo servidor NTP, que pode ser usado como backup, bem como para eliminar conexões de diferenças de tempo específicas entre os dois servidores. É suficiente especificar NTP1, porém o tempo, precisão e fiabilidade aumentam se estiverem envolvidos dois servidores. Observe que a informação de fuso horário também é usada pelo objeto da data na Formatação por script.


Ferramenta de visualização de imagem


Para que serve o Painel de imagens?

Nesse painel você pode ver a imagem lida pelo seu dispositivo.

Use os ícones de lupa para ajustar automaticamente a imagem ao tamanho da janela da ferramenta de visualização de imagem, para aumentar e diminuir o zoom da imagem ou para exibir a imagem em um modo pixel a pixel, respectivamente.

Você também pode habilitar ou desabilitar o Retorno do foco na imagem no modo Visualização ao vivo, além de copiar a imagem para a área de transferência.

Use a opção Salvar imagem para salvar apenas a imagem atual ou todas as imagens do burst e as opções de Registro em log para registrar todas as imagens não lidas ou todas as imagens decodificadas no sistema de arquivos. Clique na última opção de Registro em log Configurações de registro em log e relatório... para abrir a janela Opções do Setup Tool, que também está disponível na Página Inicial do Setup Tool por meio do menu Opções.

OBSERVAÇÃO: As Configurações da imagem exibida não possuem efeito ao salvar a última imagem obtida a partir do Painel de imagens (com arrastar e soltar). A última imagem é sempre salva em tamanho total (resolução máxima do dispositivo).


Estão ocorrendo problemas na leitura dos símbolos. O que fazer?

  • Certifique-se que o leitor está dentro da distância de funcionamento especificada para o tamanho e tipo de símbolo, como listado no guia de consulta rápida.

  • Certifique-se que você tem o símbolo centralizado dentro da área de imagem do leitor; certifique-se que o símbolo está centralizado dentro do apontador por laser vermelho quando o dispositivo é disparado.

  • Clique em Otimizar brilho, se esta opção estiver habilitada, para que o leitor ajuste automaticamente o brilho da imagem. (Não há suporte para todos os modos de disparo e não há suporte com a exposição automática.)

    OBSERVAÇÃO: A função Otimizar brilho não funciona se uma dimensão de ROI for menor que 144.

  • Clique em Configurações de simbologia e certifique-se que a simbologia que você está usando está habilitada.


Como ativar o leitor usando o Setup Tool?

Clique no botão do Disparo (ícone de raio) na barra de ferramentas na parte superior ou pressione <Ctrl>-T.


Como salvar uma imagem adquirida em um arquivo?

Clique no botão Salvar imagem na barra de ferramentas. Você pode salvar todas as imagens de um burst abrindo a lista de seleção para baixo e clicando em Salvar todas as imagens do burst.

Também é possível arrastar e soltar a imagem para o seu computador. No Visualizador de imagens, clique na imagem, arraste-a para fora do Setup Tool e solte-a.

Caso você queira salvar uma imagem arrastando e soltando a imagem, mas a imagem não é a mais recente (você está salvando a partir do Histórico de resultados da leitura), a imagem será salva com as configurações de imagem exibida. Como padrão, a qualidade será reduzida. Em Configurações da imagem visualizada, é possível alterar o tamanho da imagem para o tamanho cheio e formatá-la para Bitmap.


Como carregar uma imagem e decodificar qualquer símbolo que ela contenha?

Disponível apenas no modo de disparo Único. Clique em Carregar imagem na guia Ações para carregar um arquivo não compactado de 8 bits em escala de cinza (.jpg ou .bmp) contendo um ou mais símbolos. Uma vez carregado, o leitor tenta imediatamente decodificar qualquer símbolo que a imagem contenha.


Por que não consigo ver todas as imagens com um alto nível de taxa de transferência do quadro por segundo?

Se você estiver usando configurações (modo de disparo automático, apresentação ou externo) que possibilitam a leitura e a transferência de imagens com taxa de 100 quadros por segundo (ou superior), o dispositivo armazena estas imagens no próprio buffer, mas o Setup Tool não poderá transferir todas as imagens. Verifique se a caixa de seleção Transferir e visualizar imagens está desmarcada no painel Configurações da imagem visualizada para garantir que a taxa de transferência permaneça alta.


O que é Diagnósticos de símbolo (licença necessária)?

Diagnósticos de símbolo é um recurso que fornece retorno gráfico do dispositivo para códigos de barras sem leitura. Olhando para o retorno, você pode localizar o problema pelo qual um código de barras falhou a codificação. O retorno fornecido pode sinalizar os seguintes problemas (em uma região do código de barras):

  • Iniciar ou Parar padrão não foi encontrado (seta laranja no código)

  • Dano/erro de impressão dentro do código de barras (região do retângulo vermelho no código)

  • Área silenciosa não é suficiente (região do retângulo magenta no código)

  • Verificação da soma de verificação falhou (retângulo azul em torno do código)

Para além dos diagnósticos gráficos, a função Diagnósticos de símbolo mostra as métricas da capacidade de leitura para cada resultado sem leitura, exibidas no canto superior esquerdo dos códigos sem leitura. As métricas podem ajudar você a acessar à imagem ou à qualidade de impressão e ajudar no melhoramento da configuração existente.

A função Diagnósticos de símbolo somente está disponível para imagens PNG carregadas (Ações>Imagens>Carregar imagem), que são assinaladas por um leitor Cognex (não necessariamente o mesmo leitor; as imagens são assinaladas automaticamente quando salvas de qualquer leitor). Após carregar uma imagem, consulte o Painel de imagem ou a janela de Configuração rápida da imagem para retorno de Diagnósticos de símbolo.

Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


Que erro indica uma seta laranja em Diagnósticos de símbolo?

Uma seta laranja indica que o padrão Iniciar ou Parar não foi encontrado. A área designada pela seta falhou a decodificação. As razões para a falha são mostradas a seguir (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso):

  • Padrão Iniciar ou Parar está cortado/danificado

  • O código está cortado (devido ao limite da imagem ou por um objeto bloqueando o código)

  • Degradação da qualidade da imagem (frequentemente, porém nem sempre, causada pela qualidade da luz)

  • Deformação e dobragem das etiquetas dos códigos de barras

Observação: Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


O que indica um retângulo vermelho dentro de um código de barras, em Diagnósticos de símbolo?

Um retângulo vermelho indica que existe um dano físico ou um problema de impressão no código de barras. A área dentro do retângulo é onde o dano ou problema de impressão se encontra. São exemplos comuns de problemas de impressão (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso):

  • Vazamento de tinta que une as barras em uma só

  • Erro de impressão de uma barra que reduz sua espessura para além da tolerância de decodificação

Observação: Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


O que indica um retângulo magenta do lado de um código de barras, em Diagnósticos de símbolo?

Um retângulo de cor magenta indica que existe uma violação da Área silenciosa. A violação da Área silenciosa ocorre quando não existe espaço suficiente em um ou ambos os lados do código de barras. Dependendo da simbologia, os leitores toleram alguma violação da Área silenciosa. A violação da Área silenciosa normalmente ocorre devido a texto ou retângulo em torno do código de barras, que está demasiado perto do código de barras, em um ou ambos os lados, ou porque o código foi cortado pelo limite da imagem (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso).

Observação: Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


O que indica um retângulo azul em torno de um código de barras, em Diagnósticos de símbolo?

Um retângulo azul indica que a verificação da soma desse código de barras falhou. Razões comuns para a falha de validação da soma de verificação são mostradas a seguir (por favor consultar a Nota Técnica correspondente para imagens detalhadas que ilustram cada caso):

  • Código de barras danificado (os códigos de barras podem ser dobrados e alinhados de forma a que todos os caracteres de dados decodifiquem, mas ainda é uma não leitura, pois a verificação da soma não é transmitida)

  • É impresso um padrão incorreto (a cadeia codificada e o padrão de código de barras impresso não correspondem e se a simbologia suportar a soma de verificação, então o decodificador pode indicar essa falha)

Observação: Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


O que significa o texto gráfico ser exibido ao lado da região do código de barras, em Diagnósticos de símbolo?

Para além dos diagnósticos gráficos, a função Diagnósticos de símbolo mostra as métricas da capacidade de leitura para cada resultado sem leitura. Métricas como Contraste do símbolo e Contraste mínimo da borda podem ajudar os usuários a acessar à imagem ou à qualidade de impressão e ajudar a melhorar a configuração existente. As métricas são exibidas no canto superior esquerdo de cada código de barras sem leitura.

A tabela abaixo mostra um mapeamento entre o nome da métrica exibida e seu nome completo. Por favor consulte as Métricas da capacidade de leitura para entender o que cada métrica mede.

Nome completo | Nome exibido | Graus possíveis
Contraste do símbolo | C | A,B,C,D,F
Contraste mínimo da borda | EC | A,F
Crescimento da impressão | PG | A,F
Refletância mínima | MR | A,F

Observação: Observação: Diagnósticos de símbolo é um recurso que é ativado exclusivamente por licença.


Buffer e transferência


O que são as configurações da imagem no buffer?

As Configurações da imagem no Buffer controlam como o leitor memoriza as imagens adquiridas em resposta aos disparos de aquisição, assim como as imagens ao vivo obtidas de qualquer leitor. A alteração destas configurações não afeta o desempenho do leitor, mas afeta apenas a qualidade da imagem e a taxa de transferência entre o leitor e o Setup Tool.

  • tamanho: Por padrão, o Setup Tool visualiza um terço de todos os pixels de cada imagem adquirida ou uma fração de cada imagem durante a Visualização ao vivo. A escolha entre os tamanhos da imagem permite ao leitor realizar uma subamostra de cada imagem, o que pode melhorar drasticamente a velocidade de transferência da imagem do leitor para o Setup Tool com o comprometimento de alguns detalhes da imagem.

  • formato: Por padrão, o leitor armazena cada imagem adquirida em um formato .jpeg, que necessita de menos memória e pode ser transferida do leitor para o Setup Tool mais rápido que uma imagem de formato .bmp.

  • qualidade: Disponível apenas se você estiver usando um formato de imagem .jpeg, este controle deslizante ajusta os parâmetros internos que permitem ao leitor realizar uma operação regular na imagem adquirida que pode reduzir ou melhorar a velocidade de transferência do leitor para o Setup Tool.


Por que não é possível ver as imagens decodificadas?

A função Armazenamento no buffer e transferência não realiza a decodificação. Habilite a opção Gráficos de sobreposição no painel Configurações da imagem no buffer e suas imagens serão salva com gráficos de sobreposição (em arquivos SVG), que serão exibidos quando você reproduzir as imagens. Estes gráficos mostrarão os dados decodificados entre outras informações do decodificador.


O que posso fazer com a função Armazenamento no buffer e transferência?

A função Armazenamento no buffer e transferência permite controlar quais imagens serão gravadas e salvas no leitor. Também permite que você veja imagens gravadas no leitor e possibilita que transfira essas imagens para o seu computador.

  • A guia Buffer de imagens permite controlar quais imagens serão gravadas no leitor.

  • A guia Transferência de imagens para o PC permite controlar como as imagens serão transferidas do leitor para o seu computador.

  • A guia Transferência de imagens por FTP permite configurar a transferência automática de imagens do leitor para o seu computador.

  • Use a guia Transferência de resultados por FTP para configurar o leitor com o endereço IP e o número da porta necessários para enviar os resultados decodificados para um servidor FTP.


É possível enviar resultados codificados a um servidor FTP?

Use a guia Transferência de imagens por FTP para configurar o leitor com o endereço IP e número da porta necessários para enviar os resultados decodificados para um servidor FTP. A guia também contém ajustes para uma combinação de nome do usuário e senha, junto com o nome do arquivo para armazenar os resultados.


Como posso armazenar dados FTP em um diretório diferente do diretório raiz?

O campo Nome do arquivo aceita nomes de arquivo e nomes de caminho. Use a barra como delimitador. Por exemplo, /imagens/imagem.


Por que não é possível ver imagens e resultados no meu diretório FTP?

Verifique se você tem as permissões necessárias para criar arquivos. Se a opção acrescentar estiver marcada, verifique se o usuário do FTP possui permissões para acrescentar (que são diferentes das permissões para escrever). O usuário do FTP deve verificar o endereço IP do servidor correto do FTP.


Para que serve a lista Quais resultados serão armazenados no buffer?

A lista Quais resultados serão armazenados no buffer permite que você selecione quais tipos de imagens são armazenadas internamente no buffer, se tiverem informações decodificadas (Leitura), informação não decodificadas (Sem leitura), ambas (Todos) ou a Falha de validação, neste caso, apenas as imagens decodificadas com sucesso, mas com falhas de validação serão armazenadas.

Entretanto, leve em consideração que, nos modos burst e contínuo, as imagens da sequência inteira serão armazenadas com base na decisão se a sequência foi configurada para Lida ou Sem leitura. No modo burst, a sequência inteira significa que todas as imagens adquiridas foram especificadas pela contagem do burst. No modo contínuo, o disparo adquire as imagens, desde que o sinal do disparo permaneça ativo. Isso significa que todas as imagens serão armazenadas e gravadas até que o sinal do disparo termine.


Para que serve a opção Quais imagens serão armazenadas no buffer para resultado?

Você pode selecionar quais imagens serão armazenadas no buffer para resultado. A opção Igual ao resultado significa que para obter uma boa leitura, o leitor armazena somente imagens com um código encontrado.


Para que ser a opção Imagens por limite de resultado?

É possível definir quantas imagens por resultado serão armazenadas. Este número não pode ser maior do que o Tamanho máximo do buffer de imagem.

Talvez você queira limitar as imagens se um disparo obtiver várias aquisições com o modo códigos múltiplos porque talvez haja várias imagens com boa leitura. Também é possível usar este limite para várias imagens não decodificadas e sem leitura.


Qual é o Tamanho máximo do buffer de imagens?

O Tamanho máximo do buffer de imagem equivale ao número máximo de imagens que podem ser armazenadas no leitor. É equivalente ao limite de memória do leitor, porém poderá ser definido para um número inferior ao máximo para evitar que um número de imagens superior ao desejado seja salvo no servidor FTP ou no PC.

Observe que no modo burst, o comprimento do burst e o tamanho máximo do buffer de imagem devem ser iguais ao número máximo de imagens no buffer do leitor. O Setup Tool automaticamente reduzirá o tamanho máximo do buffer de imagem, se o comprimento de burst for aumentado, de maneira que o comprimento do burst e o tamanho máximo do buffer sejam maiores que o número máximo de buffers no leitor.

Como os buffers para armazenar as imagens no dispositivo e os buffers para processamento de imagens são compartilhados, recomendamos a redução também do número de imagens armazenadas no modo Captura única se uma série de imagens for obtida e a taxa do disparo for alta. Isso assegurará que o dispositivo tenha buffers suficientes para o processamento normal.


O que posso configurar no modo de Imagem sem leitura?

O modo Imagem sem leitura armazena apenas uma imagem por disparo e você poderá selecionar qual delas quer armazenar. A configuração Período de imagem sem leitura armazena toda enésima imagem com leitura ruim. A imagem é avaliada em todos os modos de disparo. Por exemplo, se você selecionar o modo de disparo burst, com comprimento 5 e período definido para 3, a primeira e a quarta imagens do primeiro burst, mas a segunda e a quinta imagens do segundo burst, serão armazenadas.


O que é o Período de imagem sem leitura?

O período de imagem sem leitura é a taxa de armazenagem no buffer das imagens sem leitura. Se o valor for definido como 1, todas as imagens sem leitura serão armazenadas no buffer. Se definir o valor de um número inteiro N, em que N seja superior a 1, então apenas cada imagem múltipla de N será armazenada no buffer.

A configuração do valor do Período de imagem sem leitura maior que 1, permite que você reduza o número de imagens sem leitura que são armazenadas no buffer.

O valor do Período de imagem sem leitura também afeta o buffer de imagem se a função Quais imagens serão armazenadas no buffer estiver definida como lidas, pois quando as imagens lidas são armazenadas no buffer, todas as imagens associadas a um disparo de única leitura serão marcadas como lidas. As imagens sem leitura adquiridas anteriormente poderão ser armazenadas no buffer também. A configuração do valor do Período de imagem sem leitura pode reduzir o número de imagens sem leitura que são armazenadas no buffer.


O que é o Número de imagem sem leitura?

Permite que você salve cada enésima (N) imagem de um burst que foi definido como sem leitura. Portanto, esta opção não armazenará no buffer se o modo de disparo não for o burst ou se o comprimento do burst for inferior ao número N.


O que é Taxa de imagens não lidas?

O tempo da Taxa de imagens não lidas é a frequência da contagem da Taxa de imagens não lidas (número de imagens). Você pode especificar um número exato e uma unidade para definir esse tempo. A contagem e o tempo determinam a taxa sustentada de imagens com leitura insatisfatória. O burst determina a taxa de pico por tempo.


E se a opção Permitir sobrescrever o buffer for marcada?

A opção Permitir sobrescrever o buffer controla se as imagens armazenadas no buffer sobrescrevem as imagens mais antigas ou se o buffer para quando estiver cheio.


Como verificar se as imagens foram excluídas após a transferência?

Marque a caixa "Excluir após a transferência", que controla se as imagens são excluídas após a transferência. Aplica-se a qualquer modo de transferência, incluindo transferência de imagens por FTP e a transferência do leitor para o PC.


Por que o botão Transferir agora não está ativado?

Se você tiver imagens armazenadas no buffer do leitor, deverá selecionar a pasta para gravar as imagens. Você também deverá interromper a gravação antes de iniciar a transferência.


O botão Limpar pasta de transferência apaga a tira de filme também?

O botão Limpar pasta de transferência exclui todas as imagens da pasta. Se as mesmas imagens estão sendo exibidas na tira de filme, a tira de filme também será apagada.


Se já houver arquivos na pasta selecionada, eles serão sobrescritos?

Se houver arquivos na pasta selecionada que corresponda ao Formato [Índice], o índice inicial será automaticamente aumentado até que não haja correspondente existente e, em seguida, a transferência iniciará. Os arquivos de imagem não serão sobrescritos.


Como visualizar as imagens individualmente?

Você pode visualizar as imagens uma por uma, porém deverá selecionar a pasta inteira onde as imagens estão localizadas. Assim que as imagens na pasta selecionada forem exibidas, clique nelas usando os botões para frente e para trás.


É necessário começar a visualizar as imagens novamente, se tiver que deixar o painel?

Não, ao deixar o painel Armazenamento no buffer e transferência, ele pausará a exibição como se o botão de pausa fosse clicado.


Como transferir as imagens para um servidor FTP?

Use a guia FTP para definir as configurações necessárias para transferir imagens para um servidor FTP. A guia contém configurações para o endereço IP e número da porta do servidor assim como uma combinação do nome do usuário e senha. Certifique-se que as imagens enviadas usando o FTP não são garantidas a serem enviadas, o que pode acontecer quando o leitor está operando em uma frequência maior e não pode agendar tempo para transferir imagens. Observe também que a transferência por meio de ligações sem fio pode ser muito mais lenta do que a comunicação por rede comum. Nesses casos, é recomendado o uso de imagens compactadas/com resolução reduzida.

A opção Nome do arquivo permite especificar o arquivo onde as imagens serão armazenadas. O campo Nome do arquivo permite a você especificar um caminho em relação ao diretório raiz do servidor FTP (por exemplo, /failed_images/image). A extensão do nome do arquivo (.jpg ou .bmp) apresentada na etiqueta após o nome do arquivo corresponde à configuração de formato da imagem no painel Configurações da imagem no buffer. Certifique-se que o leitor não crie diretórios; o diretório deve estar disponível e acessível.

O controle Valor máx. de acréscimo indica o limite do valor aumentado usado no nome do arquivo. Um valor de 0 indica que nenhum aumento será inserido e o arquivo pode ser sobrescrito.

O Nome do arquivo gerado por script permite gravar um script gerando o nome do arquivo no painel Geração de script, na guia Armazenamento em FTP.

A opção Nome do arquivo gerado pelo servidor inicia com um caminho em branco, que indica o diretório raiz no servidor FTP.


O tempo de execução da Transferência de imagens por FTP não está funcionando. O que fazer?

Verifique se você seguiu esses passos:

  • Digitou o endereço do servidor, o nome do usuário e a senha corretamente.

  • O modo de transferência está definido como "FTP - Tempo de execução".

  • A guia "Quais resultados serão armazenados no buffer" está definida com qualquer opção, exceto Nenhum (de acordo com as suas necessidades).

  • O seu servidor FTP dá suporte à transferência de imagem.


O que é Nome do arquivo gerado por script?

Você pode gravar um script para gerar o nome de arquivo para a transferência por FTP no painel Script, na guia Armazenamento em FTP.


O que é Nome do arquivo gerado pelo servidor?

Alguns servidores FTP aceitam esta função para nomear os arquivos de entrada de forma exclusiva, antes de salvá-los no disco.


Quais são os diferentes modos de transferência?

O modo de transferência Mediante solicitação transfere imagens quando você clica em Transferir agora no Setup Tool ou quando você envia o DMCC adequado. Se você selecionar o modo de transferência FTP - Tempo de execução, as imagens serão enviadas automaticamente ao servidor FTP, desde que a conexão esteja ativa.


Por que o painel inteiro está desabilitado ao transferir os arquivos?

O painel está desabilitado para que seja mantida a estabilidade máxima de transferência de imagens por FTP. A transferência de imagens por FTP pode levar alguns minutos, dependendo da velocidade da conexão com o FTP, do tamanho e do número de imagens transferidas.


Por que não posso enviar imagens no tempo de execução para um servidor FTP externo a um alto nível de taxa de transferência do quadro por segundo?

Se você estiver usando configurações (modo de disparo automático, apresentação ou externo) que possibilitam a leitura e a transferência de imagens com taxa de 100 quadros por segundo (ou superior), o dispositivo armazena estas imagens no próprio buffer, mas não enviará as imagens para um servidor FTP externo.

Se a opção Permitir sobrescrever o buffer estiver marcada, provavelmente as imagens serão gravadas por cima de outras. Se esta opção estiver desmarcada, as novas imagens não serão armazenadas no buffer até que o espaço esteja disponível no buffer novamente.


Para que serve a configuração do servidor Mitsubishi GOT?

Essa configuração melhora as conexões FTP nos servidores Mitsubishi GOT e outros servidores FTP, permitindo o uso de tempos de espera inativos (adicionando NOOPs periódicos) e tempos de espera inativos para controlar a conexão fechada e em ociosa. Ela também fornece suporte ao modo Mitsubishi GOT.


Para que serve a configuração do servidor SFTP?

Essa configuração permite o uso do Protocolo de Transferência Segura de Arquivos para transferência de arquivos encriptados.


O que é a configuração de Tempo de espera inativo?

O Tempo limite de ociosidade é a quantidade de tempo que uma porta será mantida aberta sem nenhum tráfego de saída. Assim que o leitor abrir uma conexão com um servidor FTP, o leitor manterá essa conexão aberta enquanto houver tráfego.

Se não houver tráfego durante o período de Tempo limite de ociosidade definido, a conexão é fechada. Isso pode ser útil se uma transferência FTP somente acontecer pontualmente e não for desejada a sobrecarga da rede para manter a conexão aberta.

Primeiro, é preciso marcar a opção Habilitar tempo de espera inativo para poder definir o tempo limite de ociosidade.


Monitor de processo


O que é monitor de processo?

Como ele opera, as estatísticas de registro do leitor DataMan como o número de disparos recebidos, o número de símbolos lidos (e não lidos) e o número de saturações do disparo. Você pode visualizar ou solicitar estas estatísticas usando uma variedade de significados. Por exemplo, você pode conectar o software de aplicação VisionView para monitorar as tentativas de decodificação de qualquer leitor ou estabelecer uma conexão usando a interface Comandos de controle DataMan (DMCC) e retirar informações de log em uma conexão Telnet ou serial.

Por padrão, o leitor DataMan para de gerar estatísticas sobre as tentativas de decodificação quando conectado ao Setup Tool. Para reabilitar a estatística de processos quando conectado ao Setup Tool, você deve iniciar o monitor de processo. Mesmo se você estabelecer conexões múltiplas a um único leitor, tal como usar tanto o Setup Tool quanto o software aplicativo VisionView, o leitor não registrará estatísticas de decodificação a menos que você habilite o monitor de processo.


Como usar o Monitor de processo?

Clique em Mostrar estatísticas de leitura para visualizar as estatísticas. Para descartar estatísticas de resultados de leitura e imagens, clique no botão Apagar estatísticas. Observação: esta opção está disponível apenas nos leitores Ethernet.

A opção Mudar para o modo de configuração leva você para as opções de configuração dos leitores selecionados.


Como visualizar as imagens armazenadas?

Clique em Mudar para o modo de configuração e configure o leitor para armazenar imagens no painel Buffer de imagens. As imagens são salvas no diretório especificado para Buffer de imagens e transferência em Opções -> Buffer de imagens e transferência.


É possível salvar os resultados lidos em um arquivo?

Pressione <ctrl>-C para copiar os dados do quadro Histórico de resultados da leitura e cole em outra aplicação de sua escolha.


O que é a Saturação do disparo?

A Saturação do disparo significa que a imagem não será adquirida porque a câmera estava em uso (por exemplo, por causa de um burst contínuo ou por causa de uma longa exposição).


Opções


O que posso configurar na página opções?

A Painel de opções do DataMan Setup Tool possibilita fazer ajustes na aplicação de acordo com suas preferências.


O que posso configurar na Página de códigos do campo Exibição de códigos?

Aqui, você pode definir a maneira como a cadeia de leitura será codificada.


O que posso configurar no campo Esquema de cores?

Selecione o esquema de código da sua janela do DataMan Setup Tool nesse campo.


O que posso configurar na caixa Redefinir configurações?

Nessa caixa, selecione uma categoria (Layout, Comunicação, Linguagem, Página de código ou Registro de dados em log) que você deseja redefinir para os padrões.


Para que serve a configuração Local do backup?

É possível definir aqui a pasta que é usada pela função de Backup para salvar os arquivos de backup.


Que configurações estão disponíveis na guia Registro de dados em log?

Nessa guia, você pode configurar as pastas onde os códigos de resultado, imagens decodificadas, imagens não lidas e relatórios serão salvos, bem como alterar nomes de arquivo e extensões quando registrar dados.


Como posso habilitar a geração de relatório de validação de dados?

Selecione Gerar relatórios de validação de dados em Registro em log no painel Histórico de resultados.


O que posso configurar na função Buffer de imagens e transferência?

Nessa guia, você pode configurar a pasta em que as imagens lidas serão salvas.


Como você pode ativar a função de Relatório?

Após ter preenchido os campos do Relatório, precisará ligar a Validação de dados para gerar os relatórios.


O Código de resultado, Imagens decodificadas ou Imagens não lidas não são exibidos no diretório correspondente. Qual será o problema?

Você precisa habilitá-las nas caixas de listagem suspensas de Registro correspondentes.


Visualização de tabela


Por que alguns valores são mostrados em destaque?

Valores que estão destacados são valores não padrão, inicialmente. As regras de destaque podem ser alteradas na seção Destaque do menu de faixa de opções; consulte a questão Visualização de tabela: Menu de faixa de opções para obter mais informações.


Por que alguns valores são mostrados em negrito?

Valores em negrito são expansíveis e mostram subvalores.


Como saber quais são os valores possíveis?

Movimente o mouse sobre um valor e veja o texto flutuante que indica o valor mínimo, máximo e o padrão, quando for relevante.


Visualização de tabela: Disposição geral e estrutura

Visualização de tabela é uma ferramenta de exibição que usa um estilo de grade.

A linha de cabeçalho exibe o nome do dispositivo. A linha do segundo cabeçalho, embaixo da primeira, exibe as configurações disponíveis para o dispositivo. Os cabeçalhos de linha abaixo (a negrito) podem ser recolhidos ou abertos, clicando no ícone junto deles. Quando o dispositivo é desconectado, surge um ícone reconectar na linha de cabeçalho dele.

As configurações que não são dependentes da configuração de leitura são exibidas somente na primeira coluna (Configuração principal).


Visualização de tabela: Controles (mouse e teclado)

Seleção:

  • Mouse: Ao clicar em uma célula da grade, ela é selecionada; o que destaca o cabeçalho de linha da célula e o cabeçalho da coluna onde o dispositivo e a configuração pertencem. Os botões do menu e itens no menu de faixa de opções podem mudar em linha com a seleção. Se a célula selecionada estiver na linha de uma linha de cabeçalho, todas as células na coluna atual que pertencem ao cabeçalho são selecionadas.

  • Teclado: As teclas de movimento do cursor navegam a seleção para a célula apropriada. O procedimento de destaque e seleção é o mesmo que por mouse.

Adicionar/alterar valores:

  • Mouse: Para células com editores integrados, clicando no controle do editor (caixa de combinação, caixa de seleção, numérico acima-abaixo) permite a entrada de valores. Para células com editores personalizados (o ícone '...’), abre um editor pop-up, permitindo a entrada do valor.

  • Teclado: Para células com editores integrados, pressionar Enter ou F2 inicia o modo de edição, Esc cancela a edição e um segundo Enter confirma a edição. Os valores podem ser inseridos no texto selecionado sem entrar no modo de edição; no caso, o valor atual é substituído no primeiro pressionamento de tecla.

    Para células numéricas, para além das células com editor de texto integrado, as setas para cima e para baixo aumentam e diminuem o valor.

    Para células suspensas, Enter inicia o modo de edição e exibe os itens suspensos, enquanto as setas para cima e para baixo movem a seleção. Um segundo Enter aplica o valor selecionado e Esc cancela a edição.

    Para células com caixa de seleção, usar o Espaço para alternar estados marcados/desmarcados.

Copiar e colar:

Use as combinações do teclado Ctrl+C e Ctrl+V para copiar e colar, respectivamente; consulte a descrição de copiar-colar dos itens do menu de faixa de opções relacionados para mais informações.


Visualização de tabela: Menu de faixa de opções

O menu de faixa de opções pode ser encontrado acima da grade de visualização de tabela. Seus conteúdos e ícones ativos podem mudar em linha com a seleção das células, linhas ou colunas, na grade. O menu está separado em vários grupos.

  • Visualização de tabela: Use o botão Adicionar a configuração para adicionar ou copiar configurações de leitura para o dispositivo selecionado. Excluir configuração exclui a(s) configuração(ões) de leitura selecionada(s). O botão Alterar ordem habilita a alteração da ordem da configuração de leitura entre a qual o dispositivo alterna.

  • Editar: Use Copiar (ou Ctrl+C no teclado) para copiar um valor da célula selecionada atualmente. Colar pode ser usada somente na mesma linha ou em qualquer editor de texto.Redefinir valores é usado para redefinir o(s) valor(es) da célula ou células selecionada(s).

  • Destaque: Os botões e configurações nesse grupo do menu fornecem opções para destacar planos de fundo específicos da célula. Com o parâmetro Valores não padrão, as células que possuem valores não padrão são destacadas (isso pode ser diferente em uma única linha para diferentes dispositivos ou configurações de leitura). A configuração Diferença para referência destaca células que possuam valores diferentes da célula na mesma linha da configuração de leitura de referência (e dispositivo). A terceira configuração está selecionada; todos os valores e cabeçalhos que contêm o texto especificado na caixa de texto estão destacados. Adicionalmente, o próprio texto contido está destacado com um plano de fundo de texto diferente. Pressionar Enter também aplica a função do botão Exibir somente linhas destacadas.

    Quando habilitado, Exibir somente linhas destacadas recolhe todos os nós que não tenham qualquer subnó destacado. Quando ativado, Definir configuração de leitura de referência especifica a configuração de leitura (e dispositivo) que é usada como referência quando o modo de destaque Diferença para referência é usado. Quando o botão está ativo, a coluna da célula atualmente selecionada (configuração de leitura) torna-se a configuração de referência. A configuração de leitura atual é marcada na linha de cabeçalho do nome da configuração.

  • Filtragem: Configurações globais, a configuração padrão, somente exibe configurações que não podem conter valores diferentes em diferentes configurações de leitura. Defina Parâmetros da configuração de leitura para visualizar somente as configurações que são dependentes da configuração de leitura. Defina Todas as configurações para visualizar todas as configurações simultaneamente. Se uma entrada possuir valores em mais configurações de leitura, eles estão visíveis em colunas diferentes.

  • Outro: Use Expandir todas as linhas para expandir todas as linhas que tenham sido recolhidas na grade. Use Recolher todas as linhas para recolher todas as linhas expandidas na grade. Redefinir layout recalcula as larguras da coluna para utilizar todo o espaço disponível. Se o espaço disponível não for suficiente, é aplicada uma largura de coluna mínima.


Informações legais


Direitos autorais

A Cognex Corporation não assume qualquer responsabilidade para o uso ou confiabilidade deste software sobre equipamentos que não foram fornecidos pela Cognex Corporation. A Cognex Corporation não oferece nenhuma garantia, seja expressa ou implícita, relacionada ao software descrito, sua comercialidade ou sua adequação a qualquer propósito em particular.

As informações contidas neste documento estão sujeitas à alteração sem aviso prévio e não devem ser construídas como um compromisso da Cognex Corporation. A Cognex Corporation não é responsável por quaisquer erros que podem ser apresentados tanto neste documento ou no software associado.

Direitos autorais © 2018 Cognex Corporation. Todos os Direitos Reservados

Este documento não pode ser copiado no todo ou em parte nem transferido para qualquer outro meio ou idioma, sem a permissão por escrito da Cognex Corporation.

O hardware e porções do software descritos neste documento podem ser protegidos por uma ou mais das patentes americanas listadas no website Cognex http://www.cognex.com/patents.asp. Outras patentes americanas e estrangeiras estão pendentes.


Software licenciado

SpiderMonkey

Este software está sujeito aos termos de uso do documento "Mozilla Public License", v. 2.0. Acesse uma cópia do documento "MPL" em http://mozilla.org/MPL/2.0/.

Se quiser receber uma cópia do código fonte do SpiderMonkey, entre em contato com o suporte técnico da Cognex em <spidermonkey@cognex.com>

Licença PCRE

O PCRE é uma livraria de funções para suportar expressões regulares como sintaxe e semântica o mais próximo possível daqueles da linguagem Perl 5.

A liberação 5 da PCRE é distribuída sob os termos da licença "BSD", como especificado abaixo. A documentação para a PCRE, fornecida no diretório "doc", é distribuída sob os mesmos termos que o próprio software.

Escrito por: Philip Hazel <ph10@cam.ac.uk>

Universidade de Cambridge Computing Service, Cambridge, Inglaterra. Telefone: +44 1223 334714.

Direitos autorais (c) 1997-2004 Universidade de Cambridge. Todos os direitos reservados.

A redistribuição e o uso na fonte e formas binárias, com ou sem modificação, são permitidos sabendo-se que as seguintes condições são conhecidas:

  • As redistribuições do código fonte devem manter o aviso de direitos autorais acima, que lista as condições e a seguinte isenção de responsabilidade.
  • As redistribuições em forma binária devem reproduzir o aviso de direitos autorais acima, esta lista de condições e a seguinte isenção de responsabilidade na documentação e/ou outros materiais fornecidos com a distribuição.
  • Nem o nome da Universidade de Cambridge, nem os nomes de seus colaboradores podem ser usados para endossar ou promover produtos derivados deste software sem permissão por escrita anterior específica.

ESTE SOFTWARE É FORNECIDO PELOS TITULARES E CONTRIBUINTES DE DIREITOS AUTORAIS "DA FORMA ATUAL" E QUALQUER GARANTIA EXPRESSA OU IMPLÍCITA, INCLUINDO, MAS NÃO LIMITANDO, AS GARANTIAS IMPLÍCITAS DE MERCADO E AJUSTE PARA UM PROPÓSITO EM PARTICULAR, SÃO DECLINADOS. EM NENHUM EVENTO OS CONTRIBUINTES OU DETENTORES DE DIREITOS AUTORAIS SÃO RESPONSÁVEIS POR QUALQUER DANO DIRETO, INDIRETO, ESPECIAL, EXEMPLAR OU CONSEQUENTE (INCLUINDO, MAS NÃO LIMITADO AO ACORDO DE SUBSTITUIÇÃO DE BENS OU SERVIÇOS; PERDA DE USO, DADOS OU LUCROS; OU INTERRUPÇÃO DE NEGÓCIOS) TODAVIA CAUSADO E EM QUALQUER TEORIA DE RESPONSABILIDADE, SE NO CONTRATO, A RESPONSABILIDADE RESTRITA OU ATO ILÍCITO (INCLUINDO NEGLIGÊNCIA OU OUTRO) SURGIDO DE QUALQUER FORMA DO USO DESTE SOFTWARE, MESMO SE AVISADO DA POSSIBILIDADE DESTE DANO

Fim

Software JPEG

Este software é baseado em parte do trabalho do Grupo Independente JPEG.

biblioteca de compactação zlib

Este software é baseado em parte no trabalho de Jean-loup Gailly e Mark Adler.

Parsifal XML Parser

Direitos Autorais (c) 2002-2005 Toni Uusitalo liberou para domínio público em 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal é gratuito tanto para o uso e redistribuição comercial quanto não comercial, sabendo-se que os direitos autorais do autor e isenção de responsabilidade são mantidos intactos. Você é livre para modificar a Parsifal para seu próprio uso e para redistribuir Parsifal com suas modificações, desde que as modificações sejam claramente documentadas.

ISENÇÃO DE RESPONSABILIDADE

Este programa é distribuído na esperança que será útil, mas SEM NENHUMA GARANTIA; mesmo sem a garantia implícita de mercado ou ajuste para uma proposta em particular. Use SOB SUA PRÓPRIA RESPONSABILIDADE.


Informação de patente

Este produto é coberto por uma ou mais das patentes americanas listadas abaixo, aplicações americanas e/ou patentes estrangeiras http://www.cognex.com/patents irá listar qualquer patente relevante emitida subsequentemente

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 e EP1687752