DataMan 8000 Series Base Station : Q&A


リーダへの接続


ベースステーションと Setup Tool の接続方法:

DataMan と Setup Tool の接続手順:

  1. Windowsのスタートメニューまたは Setup Tool のヘルプメニューから、ご使用のベースステーションに合った設定コードを表示、印刷します。

  2. ベースステーションとPCで動作させる Setup Tool に必要なケーブルを接続します。詳しい内容は、DataMan 8xx0 の『クイックリファレンス』を参照してください。

  3. 目的の[通信設定]、またはUSBなどの[接続の種類]コードのシンボルをスキャンします。

  4. Setup Tool の[更新]をクリックします。

  5. COMポートかネットワークデバイスを選択し、リーダの接続を表示します。

  6. [接続] をクリックします。


USB 接続に使用するポート:

USB ポートによってリーダまたはベースステーションを接続する場合は、『設定コード』の USB-COM/RS-232設定コードを確実にスキャンします。次に、[更新] をクリックして、リーダに接続していると識別されたポートを選択します。

注: [更新]のクリックによって、クエリ文字列がすべての COM ポートとEthernetネットワークのサブネットへ送信されます。クエリに応答するため、DataMan 7550 および DataMan 8000 ワイヤレスリーダはウェイクアップしている必要があります。トリガを引くと、リーダをウェイクアップさせることができます。


それでもリーダまたはベースステーションに接続できない場合のリセット方法：

DataMan 8000 ベースステーション:

ベースステーションにつなげたワイヤレスリーダでベースステーションの設定を工場出荷時のデフォルト値にリセットする（DM8000Base用）コマンドをスキャンして、ベースステーションを工場出荷時のデフォルト状態に戻します。

DataMan 503 および 8000 シリーズリーダ:

『クイックリファレンス』の裏表紙に印刷されたスキャナを再起動するコマンドをスキャンして、ソフトリセットを実行します。リーダの不揮発性メモリはクリアされませんが、リーダはシャットダウンされて、再起動します。

それでもリセットできない時は、DataMan の設定を工場出荷時のデフォルト値にリセットするコマンドをスキャンして、リーダを工場出荷時のデフォルト状態に戻します。

それでもリセットができない有線リーダは、一度リーダの電源を切ってください (DataMan 9500 にはこの操作は適用できません)。トリガボタンを押し続けながら、リーダの電源を再び入れます。ビープ音が2度鳴るまで、トリガボタンをそのまま 6 秒以上押し続けます。リーダの表示ライトがさまざまな色で点滅します。

それでもリセットできない場合、DataMan 8000ワイヤレスリーダを使用している場合は、リーダのバッテリを抜いてベースステーションにセットしてください。トリガボタンを押し続けながら、リーダの電源を再び入れます。ビープ音が2度鳴るまで、トリガボタンをそのまま 6 秒以上押し続けます。リーダの表示ライトがさまざまな色で点滅します。

DataMan 50、60 および 70 リーダ:

Windowsのスタートメニューまたは Setup Tool のヘルプメニューから、ご使用のリーダに合った設定コードを表示、印刷します。

DataManの再起動コードをスキャンして、ソフトリセットを実行します。リーダの不揮発性メモリはクリアされませんが、リーダはシャットダウンされて、再起動します。

それでもリーダに接続できない時は、DataMan の設定を工場出荷時のデフォルト値にリセットするコードをスキャンして、リーダを工場出荷時のデフォルト状態に戻します。

それでも問題が解決しない場合は、一度リーダの電源を切ってください (DC 電源と USB を接続している場合は、両方とも切ります)。トリガボタンを押し続けながら、リーダの電源を再び入れます。ビープ音が2度鳴るまで、トリガボタンをそのまま 6 秒以上押し続けます。リーダの表示ライトがさまざまな色で点滅します。


DataMan 50、60、70、300、370、470、503、8000 シリーズ、MX-1000、MX-1500、および DataMan 8000 ベースステーション: 接続時に Setup Tool がパスワードを要求する理由:

リーダやベースステーションを Setup Tool と接続する前に、パスワードを要求するように設定できます。パスワードは[通信設定]ペインにある[ネットワーク設定]の[認証]タブで有効にできます。パスワードはシリアル接続でも有効になりますのでご注意ください。


DataMan 60、300、370、470、503、8000 シリーズおよび DataMan 8000 ベースステーション: PCとリーダを Ethernet 経由で直接接続する方法:

PCのEthernet コネクタ(RJ-45)を使ってリーダまたはベースステーションを直接接続できます。デバイスが DHCP IPアドレスの自動取得用に設定されていれば、20秒程度待つとネットワークデバイスリストに表示されます。ただし、PCがIPアドレスを解決するまでさらに若干の時間を要することがあります。この作業が完了すると Setup Tool でデバイスに接続できるようになります。

デバイスが固定のIPアドレスを持っている場合は、デバイスとPCが同じサブネットを共有している場合のみデバイスが表示されます。


DataMan 60、300、370、470、503、8000 シリーズ、MX-1000 および DataMan 8000 ベースステーション: ネットワークデバイスリスト内のリストで特定のリーダをマッピングする方法:

DataMan はいずれも、頭に "DM_" 、そしてデバイスに印刷されている MAC アドレスの末尾6文字がデフォルトでネットワークデバイスに表示されるようになっています。


DataMan 60、300、370、470、503、8000 シリーズ、MX-1000、MX-1500、および DataMan 8000 ベースステーション: ネットワークデバイスのリストに使用中のリーダ/ベースステーションが表示されない場合の対処法:

目的のリーダ/ベースステーションが表示されていない時は、電源をいったん切ってすぐに入れ直すと追加できます。表示されるまで、デバイスの電源を入れてから最大 60 秒ほど要します。

電源を入れ直しても問題が解決しない場合は、ネットワーク設定によって Setup Tool とデバイスの通信が途切れます。ネットワークデバイスのリストに表示されることもありません。

リーダ/ベースステーションと Ethernet の接続を確認してから、Setup Toolの [更新] をクリックしてください。

リーダ/ベースステーションのIPアドレスが分かっている場合は、[デバイスの追加]を実行します。

いずれかの方法を用いると、DataManリーダ/ベースステーションがネットワークデバイスのリストに表示されますので、その後はSetup ToolでEthernet接続が確立されます。


DataMan 8000 ワイヤレスリーダ異なるベースステーションにワイヤレスリーダを関連付ける方法:

ワイヤレスリーダを関連付けたいベースステーションに、既に関連付けられた他のワイヤレスリーダがある場合、ベースステーションのリーダ割り当て解除コードのスキャンによって、その関連付けを断ち切る必要があります。新規ベースステーションにリーダを割り当てる場合は、単に新しいリーダをベースステーションに置いてください。ペアリングは自動的に行われます。


DataMan 8000 ベースステーションベースステーションへの USB 接続をリセットする方法:

ベースステーションと PC 間の USB 接続の確立、または維持が困難な場合は、以下の手順に従って USB 接続をリセットします。

  1. USB ケーブルと電源コードをベースステーションから外します。

  2. USB ケーブルと電源コードをベースステーションに再接続します。

  3. ベースステーションにリーダを置きます。

  4. リーダをベースステーションから外し、USB-COM/RS_232設定コードをスキャンします。


入力/出力


変更できるシステム設定:

ビープ音のオン/オフが可能です。ビープの数や LED の色を指定することはできませんので、ご注意ください。


ベースステーションのリセット方法:

ベースステーションに属するワイヤレスリーダで、設定コード [工場出荷時のデフォルト値にリセットする] （DM8000Base の場合）をスキャンします。


キーボードの代わりにワイヤレスリーダを使用するには：

HID モードでベースステーションを使用するには、リーダ設定コードドキュメント (Windows の [スタート] メニューまたは Setup Tool の [ヘルプ] メニューからアクセスできますからアクセスできます) の [ベースステーションで USB キーボードを有効にする] コードをスキャンする必要があります。


デバイス名の変更について:

場所や検査課題といった製造環境に合わせて、デバイスの名前に分かりやすい意味を持たせることができます。[アドバンスト] タブの [デバイス名] で操作してください。


デバイス名の変更方法：

デバイスの名前を変更する：

  1. [デバイス名]フィールドに、新しいデバイス名を入力します。

  2. "変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。

  3. 「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、デバイスを再起動してください。

次回 Setup Tool を起動するか、[リーダへの接続]ペインの[更新]をクリックすると、新しいデバイス名が反映されます。


ウェイクアップメッセージの機能:

ウェイクアップ時の[診断文字列出力] が有効になっていると、リーダまたはベースステーションが起動したときに常に診断文字列を送信します。

この機能は USB 接続には使用できません。シリアル接続の場合は Setup Tool の設定に関係なく、メッセージが送信された時のボーレートが自動的に 38,400 にセットされています。


通信


ベースステーションのシリアルポート設定の変更方法:

『リーダ設定コード』の RS-232 シリアル設定コードをスキャンすると、リーダとベースステーションが自動的に、Setup Tool で使用されるのと同じボーレート (およびそのほかのシリアルポート設定) に設定されます。

ベースステーションを、特定のボーレートまたはほかのシリアルポート設定のデバイスに接続する場合は、該当するコードをリーダ設定コードドキュメント (Windows の [スタート] メニューまたは Setup Tool のヘルプメニューからアクセスできます) でスキャンします。Setup Tool を使用して接続する場合は、RS-232 シリアルまたは USB シリアルコードの再スキャンが必要であることに注意してください。


USB モードの変更による影響：

リーダの接続にシリアル USB を使用する場合は、USB の転送速度を 1.1 か 2.0 に変更できます。

ワイヤレスリーダの接続では、USB モードを変更してもベースステーションに影響はありません。変更した設定はリーダのメモリに保存され、ワイヤレススライドインからシリアルスライドインに変えた時には、 (前回) 選択した USB モードで接続されます。


USB ドライバ互換モードの使用方法:

デフォルトではベースステーションは USB ドライバを採用しており、静電放電 (ESD) 発生時にリーダの回復をサポートします。厳密に USB の仕様との適合性を図りたい場合や、DataMan ベースステーションと Cognex SensorView 製品を併用する場合には、[USB ドライバ互換モード]を使用してください。

[USB ドライバ互換モード]を変更すると、"変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、リーダを再起動してください。


[使われた通信チャンネル]ドロップダウンで選択できること:

USBでの通信方法を設定することができます。使用している機器によって、次のオプションが使用可能です。

  • USB-COMのみ: シリアルポートでデバイスとやり取りする場合に選択します。

  • USB-HIDのみ: デバイスをUSBキーボードのように扱うことができるオプションです。

  • USB-COM + USB-HID: 両方のモードを組み合わせたオプションです。

注意: USB-COMのみを選んだ場合、HIDの機能がなくても「HIDデバイス」にリストアップされることがあります。


USB 接続中、キーボードの代わりにベースステーションを使用するには：

ワイヤレスリーダで USB キーボードをエミュレートするには、リーダ設定コードドキュメント (Windows の [スタート] メニューまたは Setup Tool のヘルプメニューからアクセスできます) の [ベースステーションで USB キーボードを有効にする] コードをスキャンし、 Setup Tool への接続を忘れずに切ってください。


PS/2 アダプタでキーボードの代わりにベースステーションを使用するには：

『クイックリファレンス』に記載されているように、PS/2 キーボードをエミュレートするにはシリアルケーブル、外部電源、キーボードウェッジケーブルが必要になります。[Ps/2のキーボードエミュレーション有効] 設定コードをスキャンします (リーダ設定コードは、Windows の [スタート] メニューまたはSetup Toolの [ヘルプ] メニューからアクセスできます)。PS/2 アダプタのインストールは、必ず PC の電源を完全に切って行ってください。ベースステーションを上記のケーブルで接続します。コンピュータの電源を入れると、ワイヤレスリーダが PS/2 キーボードをエミュレートします。


ベースステーションの再起動を行わなかった場合の動作:

変更した設定は有効になりません。システムをクリックして設定の保存を選択し、ベースステーションを再起動してください。


RS-232 ルーティングオプションの機能：

ベースステーションの接続に RS-232 を使用すると、データのルーティングをベースステーションにするか、ベースステーションにつなげているリーダと直接通信するか選択することができます。

ベースステーションにつながっているリーダがない場合、RS-232 インターフェースはルーティングオプションの選択内容に関係なくベースステーションとの通信設定で動作します。つながっているリーダが割り当てられたり除外されたりした時は、ベースステーションの電源を入れなおすたびに RS-232 のモードが自動で切り替わります。


ベースステーションのネットワーク設定方法:

[DHCP サーバを使用する]を選択して、 (利用可能な場合は) DHCP サーバ からリーダに IP アドレスを割り当てるか、[固定IPアドレスを使用する]を選択して手動でIPアドレスを割り当てネットワーク設定をします。入力する値は担当のネットワーク管理者にお尋ねください。

設定を変更すると、"変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、リーダを再起動してください。


使用できる IP アドレスのサブネットマスク:

固定 IP アドレスを使った接続は、172.16.2.x と 172.16.0.x を除いた サブネットマスクで IP アドレスを使うことができます。上記のサブネットマスクは、ベースステーションにもワイヤレスリーダの IP アドレスにも使用できません。


ベースステーションに新しいリーダを割り当てる方法:

ベースステーションにリーダを置きます。自動的に割り当てが開始します。


変更したパスフレーズの反映:

(新たに) パスフレーズを入力した後は、必ず [Enter] を押してください。[Enter] を押さずに TAB を押したりマウスをクリックしても、入力したパスフレーズは反映されません。


パスフレーズの再入力について:

[表示] にチェックが入っていれば、パスフレーズの入力は一回で済みます。[表示] にチェックが入っていなければ、再度パスフレーズを入力してください。入力されたパスフレーズが一致しない時は、 Setup Tool に警告が現れます。


ワイヤレスを無効にした場合の動作:

[ワイヤレスを有効にする] のチェックを外すと、ベースステーションに置いた時だけリーダの接続・通信が可能です。リーダでの読み取りは続行できますが、画像の送信はベースステーションにリーダを戻した際におこなわれます。


Bluetoothを無効にした場合の動作:

[Bluetoothを有効にする] のチェックを外すと、ベースステーションに置いた時だけリーダの接続・通信が可能です。リーダでの読み取りは続行できますが、画像の送信はベースステーションにリーダを戻した際におこなわれます。


割り当て解除の使用方法:

ベースステーションに別のリーダをつなげたい場合は、[割り当て解除] をクリックします。どのベースステーションにも割り当てられていないリーダは、そのままベースステーションに置くだけで構いません。割り当ては自動で実行されます。別のベースステーションに割り当てられているリーダは、プログラミングコードの [リーダの割り当て解除] をスキャンしてから、ベースステーションに置きます。


接続したリーダの IP アドレスの意味:

リーダとベースステーション間での内部通信に使われる IP アドレスです。設定の変更はできません。また、ネットワーク通信にこの IP アドレスを使用することはできません。


リーダとベースステーションの通信設定の同期:

設定をやり取りしたり更新を同期する時は、必ずリーダをベースステーションに置きます。ベースステーションにセットしたままリーダの通信設定を変更した場合は、いったんリーダをベースステーションから持ち上げて離し、置き直してください。


産業用プロトコル

Ethernet/IP プロトコル

リーダがEthernet/IPプロトコルを使用できるようにするには、[Ethernet] タブ > [産業用プロトコル] の [EtherNet/IP] にチェックを入れます。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] をクリックし、リーダを再起動します。

PROFINET プロトコル

リーダがPROFINETプロトコルを使用できるようにするには、[PROFINET] にチェックを入れます。[ステーション名を使用] をクリックすると、ステーションの名前を入力できます。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] をクリックし、リーダを再起動します。

SLMP プロトコル

リーダがSLMPプロトコルを使用できるようにするには、[SLMP プロトコル] にチェックを入れ、必要なパラメータを設定します。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] を選んだ後、変更内容を反映させるためにリーダの電源を切ってから入れ直すか、またはリーダ設定コード表のリセットコードを読み取り、リーダを再起動してください。

Modbus TCP

リーダがModbus TCPプロトコルを使用できるようにするには、[Modbus TCP プロトコル] にチェックを入れ、必要なパラメータを設定します。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] を選んだ後、変更内容を反映させるためにリーダの電源を切ってから入れ直すか、またはリーダ設定コード表のリセットコードを読み取り、リーダを再起動してください。

EtherNet/IP、PROFINET、SLMPプロトコル、Modbus TCP の選択項目がグレーアウトしている理由:

一度に使用できるEthernet産業用プロトコル は一つだけです。一つのプロトコルが指定されている間、他のものは選択できません。


認証オプションの使用方法:

[認証]が有効になると、ネットワーク経由で稼働可能なリーダまたはベースステーションに接続しようとするたびに、 Setup Tool がユーザに対して管理アカウントへのパスワードを要求します。


TCP/IP 接続の確立方法:

ベースステーションは、Telnet TCP接続用のデフォルト端末設定であるポート番号23のTCP接続に対応しています。Telnetクライアントを使用していれば、必要となるパラメータはベースステーションのIPアドレスのみです。接続に他のアプリケーションやSDKを使用している場合は、TCPポートの設定がベースステーションのそれと同じであることを確認してください。TCPポートはTelnetペインで変更できます。接続すると、ベースステーションが自動的にコード出力を送信します。DataMan Control Commands (DMCC) も、この接続方法で転送することが可能です。

Telnetポートを変更すると、"変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、ベースステーションを再起動してください。


ネットワーククライアントの機能:

ネットワーククライアントは、DataMan ID リーダがネットワーク上の別のデバイスに対し、イーサネット接続をオープンする手段として機能します。一度接続がオープンすると、DataMan の Telnet 接続も同じ基本動作を行います。すなわち読み取り結果を作成 (結果を外部デバイスに送信) できるようになり、DMCC サーバ (外部デバイスから受信した処理コマンド) として処理できるようになります。


ホストの機能:

ホストとは、DataMan を接続するネットワーク上のデバイスを意味します。ホストの設定には、イーサネットアドレスとホストデバイスのポート番号が必要です。アドレスは有効なドメイン名 (server.mynetwork.com など) またはドット付き 10 進数形式の IP アドレス (192.169.0.1 など) のいずれかを入力します。


クライアントポートの機能:

クライアントポートとは、クライアント接続の元となるリーダのイーサネットポートです。デフォルト値の 0 は、ネットワーククライアントに空いているポートの使用を指示します。ただし場合によっては、クライアントポートを指定する必要があることもあります。その際は、規定の値をクライアントポートに入力してください。通常の使用であれば、デフォルト値の 0 を変更する必要はありません。特に何もなければデフォルト値のままにしておいてください。


接続の確立方法:

クライアントは[接続を開く]オプションの選択に従って接続を行います。接続は DataMan 起動時、またはデータ関連の動作 (コードの読み取りなど) が発生した時のいずれかを選べます。


接続の切断方法:

[接続を閉じる]オプションには 2 つの種類があります。一つは接続を切らずに維持するか、もしくはデータの転送完了時に接続を切るかです。リーダのデータ転送後では任意の秒数を設定できます。リーダが指定の待機時間を過ぎると、接続が切れます。入力できる時間は 1 ～ 3600 秒です。


接続のタイムアウトの働き:

[接続のタイムアウト]では、接続がオープンになるまで DataMan が待機する合計時間をミリ秒で表します。ただしパワーアップ オンが選択されている場合、リーダは接続がオープンになるまで再試行を繰り返します。


再接続遅延の意味：

再接続を試行するまで、リーダが一時的に停止する合計時間をミリ秒で表しています。


バックアップ設定


自動リーダ設定バックアップの働き:

自動バックアップは、イーサネット環境にあるデバイスに対応しています。このオプションが有効になると、設定がフラッシュメモリに保存されるたびに、外部メモリ(FTPサーバ)にデバイス設定の内容がバックアップされます。Cognex Explorer サービスでバックアップデータの受信ができます。Setup Tool、DMCCコマンド、Cognex Explorerのいずれでも、データの復元は手動で行えます。

設定を保存したいデバイスには、IP アドレスとポート番号を指定してください。もしくは、ユーザー名とパスワードの組み合わせでも構いません。


テーブルビュー


ハイライト表示された値:

ハイライトされた値は、最初は非デフォルトの値を示しています。ハイライトのルールは、リボンメニューの [ハイライト] セクションで変更することができます。詳しくは、[テーブルビュー: リボンメニュー」を参照してください。


太字で表示された値:

太字で表示された値は、展開が可能でサブバリューを持ったものです。


可能な値を知る方法:

値の上にマウスを動かすと、吹き出しに表示された最小値、最大値、デフォルト値（当てはまる場合）を見ることができます。


法的情報


著作権

Cognex Corporation は、同社が提供していない装置における同社製ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本書で記述されているソフトウェアの内容、商品価値および特定目的に対する責任につき、明示または黙示にかかわらずいかなる保証も行いません。

本書の内容は、予告なしに変更することがあります。 内容の変更について、Cognex Corporation はいかなる責任も負いません。本書あるいは関連ソフトウェアにおける誤りについて、Cognex Corporation はいかなる責任も負いません。

Copyright ｩ 2018 Cognex Corporation All Rights Reserved

本書のいかなる部分も Cognex Corporation の書面による許可なく複製、他のメディアに送信すること、および他の言語に翻訳することを禁じます。

本書で説明しているハードウェアおよびソフトウェアの一部については、Cognex ウェブサイト http://www.cognex.com/patents.asp に示す 1 つまたは複数の米国特許で保護されています。その他の米国および、他国の特許については申請中です。


ライセンスソフトウェア

SpiderMonkey

このソフトウェアには Mozilla Public License, v. 2.0 の条件が適用されます。MPL の入手先： http://mozilla.org/MPL/2.0/

SpiderMonkey のソースコードをご希望のお客様は、Cognex テクニカルサポート (Eメール: <spidermonkey@cognex.com>) までお問い合わせください。

PCRE ライセンス

PCRE は、正規表現をサポートする関数ライブラリで、その構文とセマンティックスは、Perl 5 言語に可能な限り近似しています。

PCRE のリリース 5 は、下記に規定する "BSD" ライセンスの条項に基づいて配布されます。"doc" ディレクトリに入っている PCRE 関連文書も、同ソフトウェアと同じ条項に従って配布されます。

著作者: Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.電話: +44 1223 334714

Copyright (c) 1997-2004 University of Cambridge All rights reserved.

ソースおよびバイナリ形式での再配布および使用は、変更のあるなしにかかわらず、次の条件を満たす場合に限り許可されます。

  • ソースコードの再配布では、上記の著作権告知、この条件リストおよび下記の免責条項を保持する必要があります。
  • バイナリ形式の再配布においては、上記の著作権告知、この条件リストおよび下記の免責条項を配布される文書その他に記載する必要があります。
  • 特定の書面による事前の許可なく、本ソフトウェアから派生する製品の推奨または奨励のため、Cambridge 大学の名前も寄稿者の名前も、使用することを禁じます。

本ソフトウェアはその著作権者および寄稿者によって、「現状有姿」で提供され、商品性および特定目的に対する適合性を含みそれに限定されない、一切の明示的または黙示的保証を行いません。本ソフトウェアの使用によってあらゆるかたちで生じる、直接損害、間接損害、付随的損害、特殊損害、派生的または結果的損害 (代替商品またはサービスの調達、使用機会またはデータの喪失、逸失利益、または事業の中断を含みそれらに限定されない) に対して、著作権者または寄稿者は一切責任を負いません。 それらが契約責任であれ厳格責任であれ、または不法行為責任 (過失責任その他を含む) であれ、いかなる責任理由によっても同様であり、またたとえ、それら損害の可能性について事前に知らされていたとしても同様です。

以上

JPEG ソフトウェア

本ソフトウェアの一部は、Independent JPEG Group の成果に基づいています。

zlib 圧縮ライブラリ

本ソフトウェアの一部は、Jean-loup Gailly および Mark Adler の成果に基づいています。

Parsifal XML パーサー

Copyright (c) 2002-2005 Toni Uusitalo パブリックドメイン 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/ に公開

Parsifal は商業使用も非商業使用も再配布も自由ですが、著作者の著作権および免責条項を無修正で保持することが条件です。また、個人使用のために Parsifal を修正することも、修正した Parsifal を再配布することもできます。 ただしその修正を明確に文書に記していることが条件です。

免責条項

本プログラムは、有用性を期待して配布されますが、特定目的に対する商品性または適合性の黙示的な保証を含む、一切の保証はありません。ご使用は、リスクが自己責任であることに同意されたとみなされます。


特許情報

本製品は下記の 1 つまたは複数の米国特許ならびに米国出願、海外特許で保護されています。現時点を経過して発行された関連特許については、http://www.cognex.com/patents に掲示します。

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, EP1687752