DataMan 70 Series : Q&A


初期画面


ようこそ

デバイスのセットアップを手早く済ませられるよう、左側の大きな [アプリケーションステップ] ボタンを使うことをお勧めします。それぞれのセクションに [基本] もしくは [アドバンスト] (詳細) 設定のタブが付いています。[設定の保存] ボタンを押すとリーダに設定データを保存するほか、シングルクリックでPCにバックアップを保存します。下記のQ&Aは、分かりにくいアプリケーションステップの設定項目について説明してあります。


[アプリケーションタイプ] の設定項目：

右の矢印をクリックして、ドロップダウンメニューから読み取りモードを選択します。


[画像の最適化] の内容：

接続したデバイスの設定、調整、テストを行うことができます。また、照明もここで設定できます。


[コード詳細] の選択項目：

DataManに読み取らせるコードと、マルチコードの環境を選ぶことができます。デコーダの詳細設定も、このメニューから行います。


[アプリケーションの詳細] の設定項目：

ここではトリガと露光の設定ができます。設定はトリガアシスタント、間隔アシスタント、露光アシスタントを利用すると便利です。

[アドバンスト] タブではテーブルビューに詳細設定を加えることが可能です。


[データフォーマット] の設定項目：

デバイスからのデータ出力を構築する際に、定義済みの基本要素で出力文字列をカスタマイズする [基本フォーマット] か、Javaスクリプトエンジンで自由度の高いデータ形式スクリプトを作れる [Perlスタイルの正規表現] を使うことができます。


[アプリケーションの詳細] の設定項目：

このペインで設定できるのは、ボタンの挙動と入出力ラインです。その他、パルスエンコーダの詳細設定とビープのパルス幅もここで設定します。また、このペインにはFTP画像をサーバに送信するための、イメージバッファ設定へのリンクもあります。


[アプリケーションの詳細] の設定項目：

通信アプリケーションにある3つのタブでは、シリアル＆イーサネット設定を行えます。目的のタブをクリックし、設定値を入力してください。


[設定の保存] の内容：

[設定の保存] は作業ステップというよりも、必須の作業項目に近い意味を持っています。この操作で現在の設定をリーダの不揮発性メモリ (Persistent memory) に保存し、再起動後も同じ設定を読み込めるようにします。DataMan Setup Tool は、使用中のPCにあるデフォルトバックアップフォルダにもバックアップファイルを保存します。


リーダへの接続


リーダと Setup Tool の接続方法:

DataMan リーダと Setup Tool の接続手順は、各リーダとも共通で次のように行います:

  1. Windowsのスタートメニューまたは Setup Tool のヘルプメニューから、ご使用のリーダに合った設定コードを表示、印刷します。

  2. リーダとPCで動作させる Setup Tool に必要なケーブルを接続します。詳しい内容は、『クイックリファレンス』を参照してください。

  3. Setup Tool の[更新]をクリックします。

  4. COMポートかネットワークデバイスを選択し、リーダの接続を表示します。

  5. [接続] をクリックします。


Setup Tool が、リーダへの接続に失敗する理由:

接続できない場合は、次の点を確認してください。

  • 接続方法の種類に一致する設定コード (USB COMまたは RS-232 シリアル) をスキャンしたかどうか確認します。

  • COMポートのリストに、接続したリーダのポートが入っていることを確認します。

    DataMan 60、300、370シリーズ、470シリーズ、503、8000シリーズ：Ethernetネットワークに接続されているリーダは、ネットワークデバイスのリストに入っていることを確認します。

    [更新] をクリックして、リーダが接続されたポートを判断します。

    注: [更新]のクリックによって、クエリ文字列がすべての COM ポートとEthernetネットワークのサブネットへ送信されます。クエリに応答するため、DataMan 8000 ワイヤレスリーダは必ずウェイクアップしている必要があります。トリガを引くと、リーダをウェイクアップさせることができます。

  • この時、キーボード、HID 接続、またはキーボードウェッジを使用しないでください。Setup Tool をリーダに接続するため、USB シリアル、RS-232 シリアル、Ethernet ネットワークまたはワイヤレスネットワークを使用する必要があります。

  • DataMan 60、300、370シリーズ、470シリーズ、503、8000シリーズ：[デバイスの追加]にあるIPアドレスに誤りがないことを確認してください。

  • DataMan 8000 ワイヤレスリーダのみ：リーダがスリープモードになっていないことを確認します (ウェイクアップさせる場合はトリガを引きます)。

  • DataMan 8000 ワイヤレスリーダのみ：リーダとPCにつないだベースステーションの間で、接続が確立していることを確かめます。確認するには、『クイックリファレンス』に印刷されたリンク解除設定コードをスキャンし、ベースステーションから電源コードと通信ケーブルをいったん抜き、再接続してから、ハンドセットをベースステーションに再び置きます。再び接続する前に、ハンドセットがリンクされたことが (可聴信号によって) 確認されるまで待ちます。

  • DataMan 8000 ワイヤレスリーダのみ：ベースステーションが電源に接続されているか確認してください。

リーダが PC の COM ポートに接続されていると、HyperTerminal のようなターミナルエミュレーションプログラムを使用して、リーダが何らかのデータを送信しているかどうかを判断することができます。


デバイスのアイコン右上にオーバーレイのアイコンが表示される理由:

手動で追加したデバイスには、矢印アイコンが表示されます。「V」のアイコンは、それがバーチャルデバイスであることを示します。


バーチャルデバイスとは:

「V」のオーバーレイアイコンがデバイスアイコンの右上にあるときは、これがバーチャルデバイスであることを示します。バーチャルデバイスは、[修理とサポート] 内で、カスタム設定ファイルまたはデフォルト設定のデバイスから作成することができます。バーチャルデバイスは、接続先の実際のデバイスは不要なまま、Setup Tool内で別のペインを見るときに使用できます。

作成されたバーチャルデバイスは、ネットワーク上の他のデバイスには見えません。バーチャルデバイスは、複数のSetup Toolのインスタンスを通し存続します。

作成されたバーチャルデバイスは通常のデバイスと同様に接続することができますが、設定変更がすべて拒否されたものは接続できず (すべて読み取りのみとなる)、また、バーチャルデバイス上の特徴、機能、アクションは無効です。


USB 接続に使用するポート:

USB ポートによってリーダまたはベースステーションを接続する場合は、『設定コード』の USB-COM/RS-232設定コードを確実にスキャンします。次に、[更新] をクリックして、リーダに接続していると識別されたポートを選択します。

注: [更新]のクリックによって、クエリ文字列がすべての COM ポートとEthernetネットワークのサブネットへ送信されます。クエリに応答するため、DataMan 7550 および DataMan 8000 ワイヤレスリーダはウェイクアップしている必要があります。トリガを引くと、リーダをウェイクアップさせることができます。


それでもリーダまたはベースステーションに接続できない場合のリセット方法：

DataMan 8000 ベースステーション:

ベースステーションにつなげたワイヤレスリーダでベースステーションの設定を工場出荷時のデフォルト値にリセットする（DM8000Base用）コマンドをスキャンして、ベースステーションを工場出荷時のデフォルト状態に戻します。

DataMan 503 および 8000 シリーズリーダ:

『クイックリファレンス』の裏表紙に印刷されたスキャナを再起動するコマンドをスキャンして、ソフトリセットを実行します。リーダの不揮発性メモリはクリアされませんが、リーダはシャットダウンされて、再起動します。

それでもリセットできない時は、DataMan の設定を工場出荷時のデフォルト値にリセットするコマンドをスキャンして、リーダを工場出荷時のデフォルト状態に戻します。

それでもリセットができない有線リーダは、一度リーダの電源を切ってください (DataMan 9500 にはこの操作は適用できません)。トリガボタンを押し続けながら、リーダの電源を再び入れます。ビープ音が2度鳴るまで、トリガボタンをそのまま 6 秒以上押し続けます。リーダの表示ライトがさまざまな色で点滅します。

それでもリセットできない場合、DataMan 8000ワイヤレスリーダを使用している場合は、リーダのバッテリを抜いてベースステーションにセットしてください。トリガボタンを押し続けながら、リーダの電源を再び入れます。ビープ音が2度鳴るまで、トリガボタンをそのまま 6 秒以上押し続けます。リーダの表示ライトがさまざまな色で点滅します。

DataMan 50、60 および 70 リーダ:

Windowsのスタートメニューまたは Setup Tool のヘルプメニューから、ご使用のリーダに合った設定コードを表示、印刷します。

DataManの再起動コードをスキャンして、ソフトリセットを実行します。リーダの不揮発性メモリはクリアされませんが、リーダはシャットダウンされて、再起動します。

それでもリーダに接続できない時は、DataMan の設定を工場出荷時のデフォルト値にリセットするコードをスキャンして、リーダを工場出荷時のデフォルト状態に戻します。

それでも問題が解決しない場合は、一度リーダの電源を切ってください (DC 電源と USB を接続している場合は、両方とも切ります)。トリガボタンを押し続けながら、リーダの電源を再び入れます。ビープ音が2度鳴るまで、トリガボタンをそのまま 6 秒以上押し続けます。リーダの表示ライトがさまざまな色で点滅します。


接続するデバイスの確認：

DataMan 260、300、473、500、503、8000リーダ:

[リーダへの接続]にあるデバイスのツリーリストで、リーダを右クリックして[確認]を選択します。リーダのステータスインジケータLEDが点灯し、どのリーダかを確認することが出来ます。


緑色で表示されたデバイス:

新たに検出されたデバイスは数秒間緑色で表示し、ツリービューにデバイスが追加されたことを知らせます。


プロセスモニタの働き:

操作中、DataMan リーダは検知したトリガの数、読み取った (あるいは無効な) シンボルの数、トリガがオーバーランした回数などの統計値を記録しています。こうした統計値はさまざまな方法で閲覧、呼び出しが可能です。例えば、アプリケーションソフトウェアの VisionView に接続してリーダのデコード試行を監視したり、 DataMan Control Commands (DMCC) インターフェースで接続を確立する、シリアル接続や Telnet 接続でログデータを取り出すことなどができます。

デフォルトでは、DataMan リーダは Setup Tool に接続するとデコードの試行に関する統計値の作成を停止します。Setup Tool 接続中に統計処理を再度有効にしたい場合は、プロセスモニタを起動してください。Setup Tool と VisionView の同時利用など、1 台のリーダに Setup Tool 以外の機能が接続されていても、プロセスモニタが有効になっていない限り、リーダはデコードの統計値を記録することはありません。


DataMan 50、60、70、300、370、470、503、8000 シリーズ、MX-1000、MX-1500、および DataMan 8000 ベースステーション: 接続時に Setup Tool がパスワードを要求する理由:

リーダやベースステーションを Setup Tool と接続する前に、パスワードを要求するように設定できます。パスワードは[通信設定]ペインにある[ネットワーク設定]の[認証]タブで有効にできます。パスワードはシリアル接続でも有効になりますのでご注意ください。


[設定を比較]ボタンの機能:

[設定を比較] ボタンで、Setup Toolの設定比較機能が起動されます。Setup Toolとは、デバイスの設定のセット、コピー、比較、復元に使用するテーブルビュースタイルのツールです。この機能では、新しいドキュメントページが開きます。

このボタンを押す前にデバイスの一覧からデバイスが選択されていない場合は、空のドキュメントが開きます。また、1つ以上のデバイスが選択されている場合は、そのデバイスの設定が比較ドキュメントに追加されます。


ネットワークで表示されるRTM Lean/RTMデバイスについて：

Real Time Monitoring (RTM：リアルタイムモニタリング) LeanはDataMan Setup Toolに組み込まれている機能です。RTMはDataMan Setup Toolでアクセスできるハードウェア支援型ソフトウェアであり、ネットワーク上のデバイスと読み取りに関連する各種データの収集・分析を行えるようにします。RTM LeanまたはRTMとデバイスをつなぐと、新たに開いたドキュメントで設定データの収集を行います。RTM LeanまたはRTMは機能が実行中であり、かつ接続中である場合にだけ、データを積極的に収集します。

初期設定中にRTM LeanとRTMのいずれでデバイス監視するか、および収集するデータの種類 (デフォルト以外) を選択する画面が現れます。設定はリボンメニューの設定で変更できます。デフォルトではRTM LeanかRTMが統計データを収集します (読み取り率、トリガのカウント、トリガのオーバーラン、バッファのオーバーフロー、(有効になっている場合は) プロセス管理)。

注意: RTM Leanは一度に一台のデバイスからデータを取得し、その後48時間保存します。RTMのフルバージョンは無制限です。


画像の最適化


[アプリケーションタイプ] の設定項目：

右矢印をクリックして、ドロップダウンメニューから読み取りモードを選択します。


[画像の最適化] の内容：

ここでは、設定プロセスの実行、接続デバイスのチューニングとテストができます。

デバイスのセットアップを手早く済ませられるよう、中央の大きな [アプリケーションステップ] ボタンを使うことをお勧めします。ここから [基本] もしくは [アドバンスト] (設定) 設定の選択ができます。[設定の保存] ボタンを押すだけで、すべての設定データが保存されます。下記のQ&Aは、分かりにくいアプリケーションステップの設定項目について説明してあります。


取得した画像をファイルに保存する方法:

画像パネルまたは画像ビューアのツールバーで [画像の保存] をクリックします。

画像を PC にドラッグ＆ドロップすることもできます。画像表示ウィンドウにある画像をクリックして、Setup Tool の外にドラッグしてから放します。

注意: 最新のものではない画像をドラッグ＆ドロップで保存する場合は (すなわち [読み取り結果履歴]から保存する場合)、実行時に表示画像設定に設定されていた状態で画像が保存されます。デフォルトでは最高画質ではありません。表示画像設定で、画像をフルサイズのビットマップ形式に変更できます。


[ライブ] ボタンの使い方:

[基本] タブから[ライブ] ボタンをクリックすると、ライブモードに入ります。ライブモードはデバイスの読み込みを監視するだけでなく、デコードも行います。ボタンの右端をクリックすると、詳細オプションが開きます。

デバイスで画像のデコードをしたい場合は、[デコード] をチェックします。これをチェックすると [焦点フィードバック] で画像ビューの右側にカラーコードメーターが表示されます。このメーターは、レンズのフォーカスを指定します (「低」は甘いフォーカス)。

リーダで自動的に画像の最適な露光設定を決定するには、[自動露光] オプションをチェックします。[ゲイン] スライダー (画像ビューエリアの下) は、対象のピクセルの明るさを指定します。

画像設定のテーブルビューは、[アドバンスト] タブで確認できます。


[チューニング] ボタンの使い方:

[基本] タブの [チューニング] ボタンをクリックすると、読み取りに最適な設定が自動選択されます。ドロップダウン (ボタンの右端をクリック) を開くと、[焦点の最適化]、[明るさの最適化]、[シンボルのアシスタント]、[トリガの種類]、[コードの登録]、[アドバンストトリガ設定]、その他のチューニング項目が表示されます。

注意: チューニングに必要な最小ROIサイズは、144x144ピクセルです。

ドロップダウンの上部にあるオプションについては、別途説明します。

[明るさの最適化] をクリックすると、デバイスに最適な明るさを自動的に推奨します (手動露光がその下で設定できるときのみ)。もしくは、ボタンの隣のリンクをクリックすると [アプリケーションの詳細] に移り、照明の光量の手動設定や詳細設定を行うことができます。

リーダで画像の最適な露光設定を自動的に決定するには、[自動露光] オプションをチェックします。[ゲイン係数] スライダー (画像ビューエリアの下) は、対象のピクセルの明るさを指定します。

手動で露光を設定するには [マニュアル露光] オプションを選択し [最大露光] スライダーを左右にスライドすると、カメラの露光を細かく設定できます。あるいは、画像ビューエリアの下のスライダーを使うこともできます。[ゲイン係数上限] 設定は、対象のピクセルの明るさの最大値を設定するときに使用します。

[焦点の最適化] をクリックすると、デバイスに最適な焦点を自動的に推奨します。もしくは、ボタン横のリンクをクリックすると [アプリケーションの詳細] のペインに移り、焦点の手動設定や詳細設定を行うことができます。焦点の最適化は、画像ビューエリアの下にある、焦点アイコンのついたスライダーでも行うことができます。なお、このオプションは、リキッドレンズ使用時のみ表示されます。

コードを登録するには [コードの登録] をクリックします。登録を解除する場合は、そのコードをクリックします。ボタン横のリンクをクリックすると、コード登録の [詳細設定] に移動します。

[シンボルのアシスタント] は、適切なシンボルまたは必要なシンボルの読み込みまたはデコードの設定を段階的にガイドするウィザードです。アシスタント横のリンクをクリックすると [コード詳細] ペインに移り、手動でシンボル設定の微調整を行うこともできます。

リーダの設定は、次の [トリガの種類] で行います。

  • [シングル] リーダがトリガを検知すると、画像を1枚取得してその画像に含まれるシンボルのデコードを試行します。このトリガモードはタイムアウト設定に対応しています。

  • [自動読み取り] ではシンボルのスキャンが続行され、シンボルを見つけるたびにデコードが行われます。

  • [マニュアル] トリガ信号を受信している間はずっと画像を取得します。シンボルを検知してデコードを行うか、トリガ信号が消えると停止します。

  • [バースト] は一定数の画像を取得し、そのグループ内で検知した最初のシンボルをデコードします。バーストで取得する画像数と画像を取得する間隔が設定できます。このトリガモードはタイムアウト設定に対応しています。

  • [セルフ] トリガでは、自動読み取りのようにリーダがシンボルのスキャンを続行し、シンボルを見つけるたびにデコードが行われます。

  • [連続] トリガ信号を受信している間はずっと画像を取得します。リーダは特定の間隔で画像の取得を続け、目的の画像に含まれるシンボルをスキャンしていきます。

注意: すべてのデバイスでどの種類のトリガも利用できるわけではありません。該当のリファレンス・マニュアルで、お使いのデバイスモデルで利用できるトリガの種類についての詳しい情報をチェックしてください。

一番下にある [アドバンストトリガ設定] のリンクをクリックすると、[アプリケーションの詳細] に移って細かな設定ができます。

[アドバンスト] タブではテーブルビューの設定が可能です。


ライトバンクのチューニング機能:

[ライトバンクのチューニング]では、デバイスがライトバンクをチューニングします。使用する照明設定が決まっている場合は、無効にしてご使用ください。


[完全チューニング]の機能:

強制的にライトバンクをチューニングするオプションです。完全チューニングをオフにした状態の時に、一番の照明設定(シーケンスで最初のもの)でリーダがコードの読み取りに成功すると、他のライトバンクの組み合わせを試行しなくなります。

完全チューニングがオンになっていると、リーダは最初の読み取り結果に関わらず、すべての組み合わせを試してベストなものを探します。


[フィルタのチューニングを有効にする] の機能:

[フィルタのチューニングを有効にする] を選択するとDataMan Setup Toolがフィルタを読み取り画像に適用します。その時、コード読み取りが成功したときに使用したフィルタが画像フィルタの下の [チューニング結果] ペインに表示されます。


[チューニング中に焦点を最適化] の機能:

チューニング中に焦点を自動的に最適化したい場合は、[チューニング中に焦点を最適化] オプションにチェックを入れます。


[チューニング後にコードを登録] の機能:

チューニング後、読み取ったコードをデバイスに登録したい場合は、[チューニング後にコードを登録] にチェックを入れます。検出されたコードは、DataMan Setup Toolウィンドウの下部に表示されます。

注意: この機能を使用するとき、DataMan Setup Toolは検出されたコードタイプのみ認識するため、その他のコードタイプの読み取りには使用しないでください。


[環境光の結果を除外] の機能:

チューニングのプロセスで環境光の結果だけが自動的に選択されないようにするには、[環境光の結果を除外] をチェックします (そうしない場合は、これが固定型リーダに一般的な照明タイプになります)。


[テスト] ボタンの使い方:

[テスト] ボタンをクリックすると、作業を中断せずに設定された内容でデバイスをテストできます。

トリガの種類を [ライブ] ボタンで選択、すなわち外部トリガ ([プレゼンテーション] または [セルフ] トリガモード以外) を選択した場合、[テスト] モードで自動的にリーダのトリガが実行されます。[トリガ オン] と [トリガ オフ] の回数を使って、自動的にテストモードでリーダのトリガをかけることができます。トリガ頻度を計算したものがありますので、参考にしてください。

[トリガ オン] または [トリガ オフ] のどちらかの回数を減らすとサイクル時間が短縮され、よってトリガの頻度を増やすことができます。

注意: 読み取り設定、読み取るコード、また接続インターフェイスによってスピードに限界が生じることがあり、高速時には画像送信が無効になる場合があります。

一般的な使用例は次のとおりです。

  • トリガ オン = 20 ms, トリガ オフ = 1980 ms -> 頻度 = 0.5 Hz (デフォルト)
  • トリガ オン = 20 ms, トリガ オフ = 980 ms -> 頻度 = 1 Hz
  • トリガ オン = 20 ms, トリガ オフ = 480 ms -> 頻度 = 2 Hz
  • トリガ オン = 20 ms, トリガ オフ = 180 ms -> 頻度 = 5 Hz
  • トリガ オン = 20 ms, トリガ オフ = 80 ms -> 頻度 = 10 Hz
  • トリガ オン = 20 ms, トリガ オフ = 30 ms -> 頻度 = 20 Hz


[読み取りのパフォーマンス] ペインの使用:

右側の [読み取りのパフォーマンス] ペインにあるグラフで、デコード回数と読み取り率をリアルタイムでモニターすることができます。グラフをリセットするには、[消去] ボタンをクリックします。


露光時間を調整する方法:

チューニングをクリックすると、読み取りに最適な設定が自動選択されます。これにより明るさの最適化とコード登録機能を開始します。

注意: ROI のサイズが144以下の時は、明るさの最適化とチューニングができません。

明るさの最適化をクリックすると、推奨される輝度が自動的に設定されます。この機能はマニュアル露光が選択されている場合に使用できます。マニュアル露光やその他の設定は、明るさの最適化ボタンの横にあるアイコンをクリックします。もしくは画像下の [露光] スライダを左右のいずれかにドラッグするか、露光の値を入力してください。より詳細な設定は、右側テキストボックスの横にあるアイコンをクリックします。

ライブ表示で調整を行っている最中に、露光を変更することも可能です。


画像の焦点を調整する方法:

チューニングをクリックすると、読み取りに最適な設定が自動選択されます。これによって [明るさの最適化]、[コード登録] とは別に、[焦点位置の最適化] 機能が実行できる場合は実行します。

[焦点位置の最適化] ボタンをクリックすると、推奨される焦点が設定されます。この機能はリキッドレンズを装着したリーダにのみ対応しています。より詳細な設定は、[焦点位置の最適化] ボタンの横にあるリンクをクリックします。あるいは、画像の下の [焦点] のスライダーをドラッグで動かすか、焦点の値を入力すると、この値がジオプターか距離 (mm) のどちらかで渡されます。[+] と [-] ボタンを使用しても値を変更することができますが、[+] はジオプター値を小さくし、[-] は大きくするため、注意してください。スライダーのオレンジのエリア (500mm上) は距離を指定できないため、この域にスライダーを動かすとSetup Toolが距離を自動的に無効にします。スライダーや数値がオレンジの域を外れると、距離が再び有効になります。[アドバンスト焦点設定] のリンクをクリックすると、詳細設定ができる [焦点設定] ペインに移動します。

ライブ表示で調整を行っている最中に、焦点値を変更することも可能です。


リーダの照明のオン/オフを早く切り替える方法:

現在の照明設定が表示されている画像を右クリックします。メニュが表示されるので、次に項目を選択します。

  • すべてオン

  • すべてオフ

  • 北-南

  • 東-西

選択内容に応じた変更は、すぐに反映されます。


シンボル診断とは (機能キー要):

シンボル診断は、読み取り無効なバーコードについて、デバイスからシンボルを表示することでフィードバックを提供する機能です。このフィードバックを見ることで、バーコードがデコードされなかった理由に対して対応できます。フィードバックは、次の問題を知らせます (バーコードの範囲内)。

  • スタートまたはストップのパターン非検出 (コード上にオレンジの矢印)矢印で示された範囲が、デコード失敗の部分です。失敗の理由は次のとおりです (関連のテックノートで、1つ1つのケースを詳しく説明しています）。

    • スタートまたはストップのパターンの途切れ/破損

    • コードの途切れ (画像の端にあったため、またはコードを遮蔽する物体のため）

    • 低い画像品質 (必ずではないものの、光の質が関係していることがよくある)

    • バーコードラベルの反りや折れ

  • バーコード内の破損/印刷エラー (コード上に赤い長方形)長方形内の範囲が、破損またはプリントエラーが検出された部分です。プリントエラーの例には次のようなものがあります (関連のテックノートで、1つ1つのケースを詳しく説明しています）。

    • インクのにじみでバーどうしがつながった場合

    • バーのミスプリントで、デコードの許容範囲を超えてバーが細くなった場合

  • クワイエットゾーンが不十分 (コード上に赤紫色の長方形)クワイエットゾーンの違反は、バーコード上または両側に十分なスペースがないときに起こります。シンボルによっては、リーダがクワイエットゾーンの違反を許容する場合があります。クワイエットゾーン違反は、一般的にバーコードの周囲の文字や縁取りがバーコードの左右に近すぎるために起こります。また、コードが画像の端にあるため途切れてしまった場合にも起こります (関連のテックノートで、1つ1つのケースを詳しく説明しています)。

  • チェックサム検証失敗 (コードの周りにブルーの長方形)チェックサム検証失敗の主な理由は次のとおりです (関連のテックノートで、1つ1つのケースを詳しく説明しています）。

    • バーコードの破損 (バーコードは、折れていても並んで置いてあってもすべてのデータ文字をデコードできますが、チェックサム検証にパスしないときは読み取り不能になります)

    • 不正なパターンの印刷 (エンコードされた文字列とプリントされたバーコードパターンが一致しない場合。シンボルがチェックサムに対応している場合は、デコーダがこうしたエラーを示すことがあります)

グラフィックによる診断のほか、シンボル診断は読み取り無効となった結果それぞれに対して読み取り可能性測定を出し、読み取り無効コードの左上に表示します。測定値によって画像またはプリントの品質を見積もることができ、また既存の設定の改善にも役立ちます。

シンボル診断は、アップロードされたPNG画像 ([アクション] > [画像] > [画像のアップロード]) で、Cognexリーダがサインしたものだけ利用できます (同一のリーダである必要はありません。画像はどのリーダからでも自動的にサインされます)。画像のアップロード後に、画像パネルまたはクイックセットアップの画像ウィンドウでシンボル診断のフィードバックをチェックしてください。

グラフィックによる診断のほか、シンボル診断は読み取り無効となった結果それぞれに対して読み取り可能性測定を出します。「シンボルのコントラスト」や「最小のエッジコントラスト」によって、画像またはプリントの品質を見積もることができ、また既存の設定の改善にも役立ちます。測定は読み取り無効のバーコードの左上に表示されます。

下の表では、表示された測定名とその正式名の間にマッピングを表示しています。読み取り可能性測定を参照して、各測定値について理解してください。

正式名 | 表示名 | 推定グレード
シンボルのコントラスト | C | A,B,C,D,F
最小のエッジコントラスト | EC | A,F
印刷太り | PG | A,F
最小反射率 | MR | A,F

注意: 注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


表示画像設定の働き:

表示画像設定では、トリガでリーダが取得した画像や、リーダが撮ったライブ画像の表示方法を管理します。この設定を変更することでリーダの性能には影響ありませんが、画質、そしてリーダと Setup Tool 間の転送率にのみ影響が出ます。

注意: 画像関連のプロパティの中には(画像サイズやフィルタリングなど)、デバイスが画像を取得中またはデコード中に変更できないものもあります。

注意: 表示された画像設定は、画像ペインから (ドラッグ&ドロップで) 取得した最後の画像を保存するときには影響しません。最後の画像は常にフルサイズです (デバイスの最大解像度)。

  • サイズ: デフォルトでは Setup Tool は取得した画像の全ピクセル中 1/4 を表示するか、ライブ表示中の一部画像を表示します。画像サイズを選択すると、リーダは各画像のサブサンプリングを実行できるようになります。 これによってリーダから Setup Tool への画像の転送速度が大幅に向上しますが、画像の精密さは若干損なわれます。

  • 形式: デフォルトではリーダが取得した画像は .jpeg 形式で保存されます。 このフォーマットは .bmp 形式の画像に比べてそれほどメモリを必要としない上、リーダから Setup Tool への転送が早く行えるためです。

  • 画像品質: .jpeg 形式で画像を扱う場合のみ使用できます。 スライダを使用して内部パラメータを調節することで、リーダから Setup Tool への転送速度を増減し、取得した画像がリーダでスムーズに処理できるようになります。


[使用する画像] の設定項目:

ライブ表示中に見たい画像を [オリジナル] または [フィルタ済] から選びます。詳細設定は [画像のフィルタリング] ペインで行います。

注意: このオプションはDM262にはありません。


赤いLED照明の輝度の変更方法：

[照明] グループボックスで [内部輝度] スライダを使用して、、リーダが検査中のシンボルを照らす赤いLED照明の輝度を調節してください。

なお、プラットフォームによっては輝度調節に対応していないものがあります。下記の対応表をご参照ください。

プラットフォーム | 輝度調節 | 個々のLEDまたはセグメントのオン/オフ | 備考
DM50 | はい | いいえ | 赤いLED1個のみ
DM60 | はい | いいえ |
DM70 | いいえ | はい |
DM503 | はい | いいえ | 外部照明


高周波照明のチェックボックスが使用できない理由:

高周波照明を有効にするには、画像設定を [マニュアル露光] に、トリガのタイプを [セルフ（内蔵）] に変更し、間隔を 16000 ～ 20000 または 32000 ～ 34000 もしくは 64000 以上の任意の値に変更してください。


[高周波照明]のチェックボックスで"常にオン" を指定した時の動作:

内部照明をオフにして高周波照明が有効になると、長時間トリガの発信がなかった時に高周波照明(HFL)を消すまでのタイムアウトを設定できます。タイムアウトは秒単位で設定してください。タイムアウトの値を0に設定するとタイムアウトのハンドラーがオフになり、照明が消えなくなります。操作モードかライブ画像のビューをオンにすると、HFLが消えます。


外部光源を使用する方法:

  1. [入力/出力] の [出力] タブで、出力ラインの [ストロボ] にチェックを入れます。
  2. [照明とイメージャの設定] ペインの照明の種類で [外部] を選択します。

外部からのライトは、『クイックリファレンス』に従って選択した出力ラインに接続すると使用できます。

  • 出力ラインは必ず電流シンクとして配線してください。

  • 共通出力部は必ずシャーシアースにつないでください。

  • 最大電流は 50 mA / 24 VDC です。


外部光源を使用する方法:

  1. [システム設定] ペインの[出力]タブで、出力ラインの[ストロボ] にチェックを入れます。

外部からのライトは、『クイックリファレンス』に従って選択した出力ラインに接続すると使用できます。

  • 出力ラインは必ず電流シンクとして配線してください。

  • 共通出力部は必ずシャーシアースにつないでください。

  • 最大電流は 50 mA / 24 VDC です。


外部光源と出力ラインからのストロボを併用した場合の動作:

照明出力よりもストロボの信号が先に発信し、外部光源の出力は若干遅れます。画像の取得中は両方の照明がオンになります。


プリチャージ時間の設定先:

この設定は専用の照明コネクタと、[システム設定]ペインで設定したディスクリート入出力の両方に使えます。


プリチャージで使用できる外部照明オプション:

  • Cognex外部照明: Cognex 外部照明

  • Cognex HPIA: Cognex 高出力照明アクセサリー

  • SVL バー照明: Smart Vision Lights YL、ODL、L シリーズ

  • CCS 照明: 標準 CCS 照明

  • カスタム照明:その他の外部照明


[フロントカバーフィルタ] 設定について:

お使いのレンズカバータイプを、ドロップダウンボックスから選択できます。


取得したそれぞれの画像でROIを設定する方法：

[画像サイズ(ROI)] サブペインの設定を変更します。


[画像の転送と表示] をチェックしても画像が見えない理由:

画像の転送中にトリガを引いて割り込むと、画像は転送されません。また、[読み取り結果履歴] グリッドの旧結果にも、画像は含まれない場合があります。


登録コードボタンの使用方法:

デフォルトではリーダは [シンボル設定] ペインで有効になっているシンボルすべてを利用してシンボルのデコードを試行します。[コード登録]ボタンはシングル、バースト、セルフ、連続の各トリガモードでのみ有効にでき、画像内にあるシンボルのアトリビュートを覚えることで新しい画像を取得、デコードします。有効になったシンボルを繰り返す必要がないため、目的のシンボルを覚えたリーダはデコードの時間を短縮することが可能になります。

同じコードが続くシンボルをデコードする場合には、[コード登録] 機能を使うと便利です。しかし、登録していないコードを含むシンボルをデコードするとエラーになってしまうことがあります。[コード登録解除] ボタンをクリックすると登録パラメータがオフになり、有効なシンボルすべてに照らして次のシンボルをチェックできるようになります。

1 件の画像で複数の画像をデコードできるように登録するには、シンボル設定の「1つの画像から複数のシンボルをデコードする際の登録操作方法」を参照してください。


登録済みのシンボルとモデルサイズが同じものでも、コードがデコードされない理由:

登録したコードとデコードしたいコードのサイズで 10% 以上の差がないことを確かめてください。


ライブ表示の働き:

[ライブ表示有効]を選択(一番上のタスクバーまたはアクションタブにあるライブ表示アイコンをクリック)すると、リーダが映している画像をずっと表示し続けます。シンボルのデコードを試行せず、リーダに映っているものを確認したい場合に使用できるモードです。

ライブ表示された画像のサイズや画質を変更するには、[表示画像設定]ペインを選択します。

注意: DM262 と DM362 にはこのオプションがありません。


画像の転送を高速化する方法:

[画像の転送と表示] チェックボックスにチェックを入れると、デコードを実行するたびに Setup Tool が取得した画像を転送します。現在の画像の転送中に新たなトリガを受けると、リーダは転送する画像の一部を廃棄して、新しい画像の転送を開始します。

画像の転送速度は、リーダによって実行される画像の圧縮量によって異なります。[表示画像設定] オプションを選択することで、画像の圧縮値を制御できます。画像サイズを小さくしたり、画質を落とすと、転送レートがアップします。


バーストモードのトリガで取得した全画像を表示する方法：

バーストモードのトリガで取得した全画像表示する方法は、次の通りです。

  1. トリガタイプがバーストに設定されていることを確認してください。
  2. [すべての画像を転送]チェックボックスをオンにします。

[結果履歴]ペインには、バーストモードで取得した画像が含まれます。スライドモードで画像を表示する場合には、[読み取り結果履歴]グリッドの結果をクリックしてください。

多くの画像が[照明とイメージャの設定]ペインにある[バースト長さ] に合致するようになります。


[すべての画像を転送]とは：

[すべての画像を転送]にチェックを入れると、それぞれのトリガに伴ったバースト画像をすべて表示することができます。

チェックを入れると、デコードの結果が画像に含まれているかどうかに関わらず、バーストモードで取得した全画像が[結果履歴]ペインから確認できるようになります。

この機能は [照明とイメージャの設定] ペインでトリガのタイプを [バースト] に指定している場合にのみ使用可能です。


リーダの焦点を合わせる方法:

[焦点フィードバック] をチェックし、ライブ表示をクリックします。ライブ表示にて、焦点値を表すセルが表示されます。セルは焦点のシャープネスに応じて赤、黄色、緑のいずれかの色がついています。グリーンのセルであれば、コードは焦点が合っており、画像がデコード可能な状態です（ライブ表示は停止してください）。

ライブ表示は必ずフィルタ済みの画像ではなく、オリジナル画像に使用します。

注意: この機能は、DM262では使用できません。


Data Matrix コードに [焦点フィードバック] を使用しても、接近しすぎないと焦点が合わない場合の対処方法:

まず、Data Matrix が有効になっているかどうかを確認してください。その後 [チューニング] ペインを開き、[チューニング] をクリックします。最適なパラメータが選び出され、画像のデコードができるようになります。


コード詳細


すぐに全てのシンボルを無効にする方法:

[コード詳細] の [基本] タブ上にある [全てのシンボルを無効にする] をクリックするか、Ctrl+Dを押します。


シンボルのチェックボックスがすべて無効になっている理由:

取得する画像で想定されるシンボルをリーダに登録することができます。リーダが登録済みの場合、シンボルの有効または無効を変更することはできません。さまざまなシンボルを有効または無効にするには、リーダの登録を行わないでください。


アドバンストシンボル設定を調整する方法:

[コード詳細] の [アドバンスト] をクリックして操作を続けます。


異なるシンボル種類の、リーダによる自動識別:

Setup Tool で有効にされているシンボルは、リーダが自動的に検出・識別し、デコードされます。


シンボルの変更ができず、すべてグレーアウトしている理由:

シンボルの有効/無効が操作できるのは、[マニュアル] と [自動読み取り] トリガモードに限られます。


1D シンボルだけが表示される理由:

DataMan 50L および 60L リーダは 2D シンボルを読み取れないため、 Setup Tool には表示されません。


個々のシンボルと、対応している測定の種類:

シンボルと測定の関係を下の表にまとめました。

測定 | DataMatrix ISO/IEC 15415 | DataMatrix AIM-DPM | QR | PDF417 | Code 128、 UPC/EAN、 Code93、 Code39、 I2/5、 Codabar、 MSI
symbolContrast | x | x | x | ? | x
UEC | x | x | x | x | ?
axialNonUniformity | x | x | x | ? | ?
printGrowth | x | x | x | ? | x
modulation | x | x | ? | ? | ?
fixedPatternDamage | x | x | ? | ? | ?
gridNonUniformity | x | x | ? | ? | ?
extremeReflectance | x | x | ? | ? | ?
reflectMin | ? | ? | ? | ? | x
edgeContrastMin | ? | ? | ? | ? | x
singleScanInt | ? | ? | ? | ? | x
multiScanInt | ? | ? | ? | ? | x


有効化するシンボルの数を減らせば、リーダの動作が向上するか：

最良の性能を得るためには、対象となるシンボルだけを有効にすることです。


VeriCode でのデコードを有効にする方法：

VeriCodeを使用する際には有効なVeriCodeライセンスが必要です。VeriCodeライセンスをロードするには、[システム] [VeriCode ライセンス]を選び、Veritec から与えられたライセンスコードを入力してください。ライセンスコードの取得については、Veritec 社（www.veritecinc.com）にお問い合わせください。

注: VeriCode は妥当性検査やマルチコードのデコードには対応していません。


[Data Matrixプロパティ] で無効になる使用タイプ：

[シンボル設定]ペインでID Maxのアルゴリズムが選択されていないと、[IDMax]は無効になります。

[シンボル設定]ペインでID Quickのアルゴリズムが選択されていないと、[IDQuick]は無効になります。

IDQuick 使用タイプ

大抵のアプリケーションでは、[速度優先]設定でデコード時間を最大限に短縮できるようになっています。デコードするシンボルが歪んでいる、変形している、背景ムラがある、などの場合は[読み取り能力優先]を選択してください。[拡張]はドットマトリックスシンボルを含む、高品質なDPM (ダイレクトパーツマーキング) 2-D コードの読み取り用です。


[Data Matrixプロパティ] でのプリントの変形：

プリントの変形は、何らかの変形があるコードでも、デコードします。不規則な印刷のコードや筒状の歪みがある連続ラベルコードを読み取る場合には、中程度（デフォルト）を採用してください。


[Data Matrixプロパティ] でのシンボルのダメージ：

[シンボルのダメージ]は、何らかの損傷があるコードでも、デコードします。通常の摩耗程度にダメージを受けたコードを読み取る場合には中程度(デフォルト)を使用してください。擦れやすり減りで明らかなダメージがコードの固定パターンに生じている時は、最大を使用して、DPM Data Matrix の読み取りにおける画期的技術 "PowerGrid (TM)" を有効にしてください。

注意: 最大設定でPowerGrid (TM)を有効にするには、専用の機能キーを購入する必要があります。


[Data Matrixプロパティ] - [極性を無視]：

[Data Matrixプロパティ] - [極性を無視]：

この項目にチェックが入ると、登録完了状態のデバイスでも、登録に使用されたコードとは逆の極性を持つコードを読み取れるようになります。

この項目にチェックが入ると、登録完了状態のデバイスでも、登録に使用されたコードとは若干異なる（ｱ 1 程度）のグリッドサイズを持つコードを読み取れるようになります。例えば 12x12 Data Matrix コードを登録した後でフレキシブルなグリッドサイズをオンにすると、10x10 や 14x14 といったサイズのコードにも対応できるようになります。


Data Matrixプロパティ：DataMan X モデルのリーダのみ：

プロセス管理測定

[Data Matrixプロパティ]ペインでプロセス管理のいずれかを有効にすると、[標準フォーマット]ペインの[測定]タブで管理ができるようになります。

スクリプトから測定へのアクセスも可能です。プロセス管理が無効になっている場合は、測定を実行しても -1 と返されます。

プロセス管理が「1」または「NA」

シンボルの印刷状態や画質が著しく劣っている場合は、リファレンスのデコードアルゴリズムを用いたプロセス管理の測定が不可能になるため、「-1」または「NA」とレポートされます。画像のフィルタリング機能などで、印刷品質や画質を向上させてください。


DataMatrixの品質測定について:

コードの品質測定については、「DataManｮ 接続・プログラミングガイド」をご覧ください。


1D シンボルのプロパティ: ターゲットデコードの機能:

ターゲットデコードでは、レーザーバーコードスキャナの動作をシミュレートします。リーダは視野全体を見る代わりに、緑の照準線上にある 1D バーコードのみのデコードを試みます。これにより、オペレータが 1D バーコードの付近にある別の対象を誤って読み取ってしまうのを防ぎます。


1D シンボルのプロパティ

ショートクワイエットゾーン

ショートクワイエットゾーンにチェックが付いていると、次の 1D シンボルのクワイエットゾーンの検索エリアにゆとりを持たせられます: Code 128、Code 39、Code 93。

ショートコード

ショートコードにチェックを入れると、極端に短く幅広なシンボルのデコード性能が向上します。

コードの向きの変更

DM300X、DM500QL、DM500X、DM503QL、DM503X の各リーダでは、デフォルトで全方向に設定されています。

DM300L、DM500L、DM503L モデルでは、コードの向きのデフォルト設定がピケットフェンス（下記参照）になっています。

コードの向き：無効

角度の登録機能で 1D コードの学習が済んでいる場合は、 コードの向きが無効になります。

データフォーマットの 「プロセス管理」 / 「コード品質測定」

これは、[コード品質] ペインの [1-D 品質測定] を有効に (機能キー要) した後で、[標準フォーマット] ペインの [測定] タブで使用可能になります。

スクリプトから測定へのアクセスも可能です。プロセス管理が無効になっている場合は、測定を実行しても -1 と返されます。

「プロセス管理」/「コード品質測定」の結果が「-1」または「NA」

シンボルの印刷状態や画質が著しく劣っている場合は、リファレンスのデコードアルゴリズムを用いたプロセス管理の測定が不可能になるため、「-1」または「NA」とレポートされます。画像のフィルタリング機能などで、印刷品質や画質を向上させてください。

そのため、デコードの際はこの向きにコードを合わせる必要があります。

コードがセンサーに対して垂直になっている場合は、コードの向きをラダー（下記参照）に変更してください。

そのため、デコードの際はこの向きにコードを合わせる必要があります。

コードがピケットフェンスまたはセンサーに対して垂直である場合は、コード配置をピケットフェンスとラダーに変更してください。

ラダーとピケットフェンスに対応しているのはt DM300L、DM500L、DM503L のみです。

1Dデータ接続

読み取りの一部を統合・拡張することで、読み取り効率を高めるのがデータ接続(Data Stitching)です。機能キー[1DDataStitching]をインストールしていることが使用条件となります。

使用タイプ

拡張方法では、読み取りが難しいバーコードをデコードすることができますが、標準方法よりも時間がかかります。


1D シンボルのプロパティ: 出力前の最小デコード設定:

デコードの安定性を向上したい場合は、高い値を設定します。動作速度を優先させたい場合は低い値を設定します。


コードサイズを指定する利点:

コードサイズを指定すると、リーダがシンボルをデコードする能力が向上します。異なるコードサイズを読み取る場合は [任意] を選択してください。


Code 39プロパティ

  • フル ASCII では Code 39 拡張コードが有効です。

  • [チェック文字] は、有効なチェックキャラクタを持つシンボルのみをデコードします。

  • [チェック文字を送信] は、デコードされたデータを持つチェックキャラクタを含みます。

  • [Code 32 に変換]を指定すると、Code 39をCode 32に変換します。


Interleaved 2of5プロパティ

  • [チェック文字] は、有効なチェックキャラクタを持つシンボルのみをデコードします。

  • [チェック文字を送信] は、デコードされたデータを持つチェックキャラクタを含みます。


Code 25プロパティ

  • [チェック文字] は、有効なチェックキャラクタを持つシンボルのみをデコードします。

  • [チェック文字を送信] は、デコードされたデータを持つチェックキャラクタを含みます。


Pharmacode プロパティ

コードサイズと角度を指定する利点:

明確なコードサイズと角度を指定すると、リーダが確実にシンボルをデコードする能力が向上します。

データ文字数とシンボルに入っているバーの数：

データ文字：バー

  • 1: 3 注意: リーダが読み取る1つの文字コードのバーは3本以上です。つまり、6、7、8、9のみとなります。

  • 2: 3 ～ 6

  • 3: 6 ～ 9

  • 4: 9 ～ 13

  • 5: 13 ～ 16

  • 6: 16


Codabarのプロパティ

  • [チェック文字] は、有効なチェックキャラクタを持つシンボルのみをデコードします。
  • [チェック文字を送信] は、デコードされたデータを持つチェックキャラクタを含みます。
  • [開始文字と終了文字の転送] は、デコードされたデータを持つ開始文字と終了文字を含みます。


MSI のプロパティ

  • [チェック文字] は、有効なチェックキャラクタを持つシンボルのみをデコードします。
  • [チェック文字を送信] は、デコードされたデータを持つチェックキャラクタを含みます。
  • [チェックサム計算方法] で、チェックサムの計算方法を選択できます。


DataBarプロパティ

  • GS1DataBar　リミテッド: インジケータ 0 または 1 の14桁EAN.UCCアイテム識別コードをエンコードするリニアシンボルです。POSでスキャンできないような小さいアイテムに使用します。

  • GS1 DataBar: 14桁EAN.UCC識別コードをエンコードするリニアシンボルです。

  • GS1 DataBar　拡張: 14 桁の GTIN をエンコードできるシンボルの可変長・拡張版で、有効期限、原産国、シリアル番号、74 桁までの数字か 41 文字までのアルファベットを含むデータが追加できます。


Postal のプロパティ

  • POSTNET: 米国郵政公社で使用されている、郵便物処理用のバーコードシンボルです。独自のシンボル内で、郵便番号または郵便番号 +4 コードが高さの異なるバーを使ってエンコードされています。

  • PLANET: PLANET は米国郵政公社が配達中の郵便を識別、追跡するために使用しているバーコードです。POSTNET 同様、高さの異なるバーでデータがエンコードされています。

注意: 郵便番号は、ピケットフェンスの位置にあるときだけデコード可能です。


クイックレスポンス (QR) コードの対応バージョン:

QR (クイックレスポンス) コードは白黒の格子状にデータをエンコードした 2-D コードです。このリーダでは次の 3 種類のコードが識別できます。

  • モデル 1: オリジナル版

  • モデル 2: 拡張版

  • マイクロ QR コード: 小さなスペースに使用でき、QR コードより情報量が少ないものに向いている、ごく小さな QR コードです。


QR Codeプロパティ

極性を無視

この項目にチェックが入ると、登録完了状態のデバイスでも、登録に使用されたコードとは逆の極性を持つコードを読み取れるようになります。

フレキシブルなグリッドサイズ

この項目にチェックが入ると、登録完了状態のデバイスでも、登録に使用されたコードとは若干異なる（ｱ 1 程度）のグリッドサイズを持つコードを読み取れるようになります。例えば 25x25 QR コードを登録した後でフレキシブルなグリッドサイズをオンにすると、21x21 や 29x29 といったサイズのコードにも対応できるようになります。

最大グリッドサイズ

最大グリッドサイズではサイズ49以下のQRコードをデコードできます。スライダーをドラッグするか、右側のテキストボックスに特定のコードサイズを入力してください。

QRコード品質測定

コードの品質測定については、「DataManｮ 接続・プログラミングガイド」をご覧ください。


QR Codeプロパティ：DataMan X モデルのリーダのみ：

データフォーマットの [プロセス管理]

[QR 測定]または[QR Codeプロパティ]を有効にすると、[標準フォーマット]ペインの[測定]タブで管理ができるようになります。

スクリプトから測定へのアクセスも可能です。プロセス管理が無効になっている場合は、測定を実行しても -1 と返されます。

プロセス管理が「1」または「NA」

シンボルの印刷状態や画質が著しく劣っている場合は、リファレンスのデコードアルゴリズムを用いたプロセス管理の測定が不可能になるため、「-1」または「NA」とレポートされます。画像のフィルタリング機能などで、印刷品質や画質を向上させてください。


DotCode のプロパティ

データ行数と列数の指定:

データ行と列の最小数・最大数を指定することで、デコードしたシンボルの信頼性を高めることができます。

極性設定

デバイスが、背景に関連するモジュール (ドット) として定義するものを設定できます。[Dark on Light] 設定は、デバイスが明るい背景上で暗いドットをスキャンしたりデコードする場合で、[Light on Dark] 設定はその反対 (暗い背景上で明るいドット) の場合を表します。

デフォルトでは [どちらか一方] が設定されており、両方の種類のモジュールをそれぞれの背景に応じてスキャンします。ただし、デコードの速度はやや遅くなることがあります。


IDMax アルゴリズムとIDQuick アルゴリズムの違い：

ID Quick は形が整いハイコントラストのシンボルのデコードを高速で行います。 一方 ID Max は高度な画像処理および画像解析技術を採用しており、レーザ、ドットピーン、電気化学エッチングやインクジェットなどによる DPM コードにも最高レベルの読み取り能力を発揮します。


マルチコードの結果を有効にする方法:

マルチコードはすべてのトリガの種類で設定可能ですが、マルチコードの結果を生じるのはトリガの種類がシングル、マニュアル、バースト、連続のときのみです。プレゼンテーションモード、およびセルフモードでは個々の結果が表示されるのみです。

[コード詳細] の [アドバンスト] タブにある [コード数] で、画像内のコード上限数を設定します。お使いのアプリケーションに合わせ、リーダにデコードさせたいシンボルタイプの数を設定することも可能です。読み取るコード数と各シンボルの最大コード数フィールドの合計を等しくすると、最良の結果を得られます（例：Data Matrix を2、1D を1 = 合計3）。読み取る各コードの数は、コード数フィールドの総数を超えることはできません。


マルチコード

部分的な結果を許可する

[部分的な結果を許可する]を有効にすると、画像のコードがコード数の設定よりも少ない場合には、成功した読み取り結果に戻ります。

同一の 1D シンボルを許可する

[同一の 1D シンボルを許可する]を有効にすると、同じ長さ、コード、文字列のシンボルを（一つの画像の中で）複数検知した場合に、リーダは複数の結果を返します。

[同一の 1D シンボルを許可する]は、一つの画像に存在する複数の同一1Dシンボル以外には適用されません。また、同じシンボルが検知されたとしても、[同一の 1D シンボルを許可する]機能はモードを問わず後続の画像に影響することはありません。

ソートの優先順位

[ソートの優先順位] のリストでは、複数の結果を読み取った際のリーダのレポート順位を決められます。

  • 上、下ボタンで各項目を動かして優先順位を変更してください。

  • 逆にするボタンを使うと、選択した項目内の順序が逆になります。

  • 位置オプション（上から下または左から右）は、シンボルの中心をさしているのでご注意ください。

  • 画像の順序は[バースト]、[連続]トリガモードにて使用します。先にデコードされた画像から順にレポートします。


QRコード/MaxiCode の最大コード数がグレーアウトしている:

MaxiCode を含むマルチコード画像の読み取りはできますが、一つの画像でデコードされるのは一つの MaxiCode だけになります。MaxiCode を含むマルチコードを読み取る場合には、必ず[一般]タブで QR コードを有効にしてください。


登録機能

デフォルトではリーダは[一般]タブで有効になっているシンボルすべてを利用してシンボルのデコードを試行します。有効になったシンボルを繰り返す必要がないため、目的のシンボルを覚えたリーダはデコードの時間を短縮することが可能になります。しかし、登録していないコードを含むシンボルをデコードするとエラーになってしまうことがあります。

登録したコードの状況を管理する時は[登録]タブを使います。

Setup Tool では、[未登録のシンボルを無効にする]チェックボックスがオフになっており、 [追加登録]が有効になっている場合を除き、リーダに登録されていないシンボルを無効にします。

コード登録ボタン

リーダが目的のシンボルの画像を取得した後で、[アクション]ペインの[コード登録]をクリックします。

特定のバーコードのシンボルのみを読み取る時には、[コード登録]をクリックすれば取得したすべての画像からそのシンボルの読み取り準備をします。 解除する場合は[コード登録解除]をクリックします (コード登録解除ボタンもシンボル設定ペインにあります)。

登録が成功したら、登録したシンボルの[モデル情報]に登録されたシンボルの予測サイズが表示され、[コード登録]解除ボタンが有効になります。

複数のシンボルをデコードする際の登録操作：

Setup Tool では、複数のシンボルをデコードするアプリケーションで、1つ以上のシンボルをリーダに登録することができます。

登録したいシンボルがすべて表示された画像があれば、[アクション]ペインの[コード登録]をクリックしてリーダに登録してください。登録したシンボルの[モデル情報]に登録されてシンボルの予測サイズが表示され、これらシンボルの[コード登録解除]ボタンが有効になります。

登録したいシンボルが1つの画像にすべて表示されていない場合は、[追加登録]にチェックを入れてから、[コード登録]をクリックして画像に表示されたシンボルを登録して下さい。登録したい、まだ未登録のシンボルが含まれる画像を取得し、[コード登録]をクリックすることによって登録済みのシンボルに追加されます。[追加登録]が有効になっていると、リーダが既存の登録パラメータを保持している限り、新しいシンボルを登録することができます。

角度の登録

1D 、Stacked、Postalコードに限っては、[オリエンテーションの学習]チェックボックスをオンにすると、直前にデコードしたシンボルの角度をリーダに学習させることができます。以降、学習した角度でシンボルが表れるとデコードの操作が速く行えるようになります。

注意: 郵便番号は、ピケットフェンスの位置にあるときだけデコード可能です。

シンボルを登録した後で、デコードに戻る方法：

リーダをシンボルのデコードに戻す時には、[コード登録解除]を必ずクリックして下さい。この時、リーダが認識できるよう[一般]タブで該当するシンボルを有効にすることを忘れないで下さい。

手動コード登録機能

デバイスに登録するコードのパラメータがすべて分かっている場合は、そのパラメータを [手動コード登録機能] で与えることができます。すべてのパラメータを入れたあとで、[有効] のチェックボックスをチェックしてコードを登録します。これで、今後は上の [コード登録解除] をクリックするとコードの登録解除ができます。


印刷不能の ASCII 文字出力を、キーボード認識可能な文字に変える方法：

[通信設定] から [非印字文字] ペインを開き、有効にチェックを入れます。また、標準フォーマットを有効にし、全文字列の前後に ASCII コマンドを追加することで、変換された文字列の前後に印字不能の ASCII コマンドを追加することもできます。


UPC/EAN プロパティの異なる設定:

  • [拡張] では拡張されたシンボルのデコードが可能になります。

  • [サプリメンタル] はリーダがサプリメンタルコードをデコードする方法を制御します。

  • [先行ゼロを削除] はデコードした列から先行ゼロを削除します。

  • [EAN8 サプリメンタルを許容] は EAN8 シンボルのサプリメンタルコードのデコードを有効にします。

  • [UPCE1有効] は UPC E1 シンボルのデコードを有効にします。


UPC/EANプロパティ：[拡張] チェックボックスの意味:

レポートされたUPC-EAN用デコード済み文字列を、13桁のEAN13形式に拡張するか、標準のUPC-E 6桁形式転送するかを示すブーリアンです。

チェックが入った状態 (デフォルト) では、デコードされた文字列は13桁のEAN-13形式に転送されます (例: 0012345000065)。チェックがない状態では、結果は <ナンバーシステム> + 6データ桁 + <チェック文字> として転送されます (例: 01234565)。


アプリケーションのプロパティ


アプリケーションの詳細の設定項目：

[基本] タブではトリガ設定と露光設定が行えます。設定はトリガアシスタント、間隔アシスタント、露光アシスタントを利用すると便利です。

[アドバンスト] タブではテーブルビューに詳細設定を加えることが可能です。


トリガアシスタント

アシスタントを使用する前に、トリガの種類を選択しておいてください。ドロップダウンメニューからトリガソースを選択：未定 / なし / 外部トリガモードに合った設定をアシスタントがお勧めします。トリガタイプのグラフィックが現れますので、参考にしてください。トリガタイプを選択し、[保存して閉じる] をクリックします。


間隔 アシスタント

バースト、セルフ、連続の各モードでは、間隔アシスタントが詳細設定のお手伝いをします。必要なデータを割り出す方法には３種類あります。右上で計算する単位 (標準かメトリック) を選択。

視野をクリックすると、物理的視野の測定値と最大ライン速度、および最長コードのサイズを加え、最長の間隔時間を割り出します。

レンズからコードまでの距離を使いたい場合は、[レンズ / コードまでの距離] をクリックします。ドロップダウンメニューから焦点距離を入れ、コードの移動方向を選択します。最大ライン速度と最長コードの値も忘れずに入力してください。

[コードエレメントサイズ] をクリックし、最も細いコードエレメントのサイズで計算を行います。[テストモード] を有効にして、コードの読み取りを試してください。併せてコードの移動方向、最大ライン速度と最長コードの値も忘れずに入力してください。

アシスタントの一番下に、最大間隔時間の推奨値が表示されます。


露光のアシスタント

露光アシスタントは、間隔アシスタントと変わりありません。同じ3種類の計算方法から選ぶことができます：視野のサイズ、コードまでの距離、コードのエレメントサイズ。

[視野] をクリックすると、物理的視野の測定値と最大ライン速度で、最大露光時間の推奨値を割り出します。[テストモード] を有効にして、最も小さいコードを読み取ってください。

レンズからコードまでの距離を使いたい場合は、[レンズ / コードまでの距離] をクリックします。ドロップダウンメニューから焦点距離を入れ、コードの移動方向を選択します。最大ライン速度も忘れずに入力してください。

[コードエレメントサイズ] をクリックし、最も細いコードエレメントのサイズで計算を行います。[テストモード] を有効にして、コードの読み取りを試してください。併せてコードの移動方向、最大ライン速度の値も忘れずに入力してください。

アシスタントの一番下に現在の露光時間の他、最大露光時間の推奨値が表示されます。


複数のリードセットアップとタイムアウトとの関係:

[複数のリードセットアップ]が有効になっていると、セットアップをひとまとめに扱うのではなく、タイムアウトはそれぞれのセットアップを対象とします。一回のトリガサイクルに費やした読み取り動作の合計時間が、有効なセットアップとタイムアウトの合計になります。


有効な読み取りの後の撮影の可否:

追加で撮影をしても、前セットアップでの読み取りエラーと見なされます。セットアップが有効な画像を取得すると、リーダは同じトリガサイクルとデコードの開始中に、それ以上のセットアップを実行しなくなります。リーダは優先順位にならって有効なセットアップを一つずつ試行します。そして指定された最優先のセットアップを開始し、有効な読み取りが行われるまで動作を続けます。


トリガの種類:

トリガは外部からリーダに送られる信号か、リーダに内蔵されたタイミング機構によってデコードを試行します。

リーダが外部トリガに反応するように設定されていると、次の項目のうちいずれかでデコードの試行が実行されます:

  • リーダが USB 、シリアル、ネットワークのいずれかで接続されている時に、 DataMan コントロールコマンド(DMCC) トリガを送信する

  • 入出力ケーブルのトリガ配線からデジタル入力信号を受信する

  • Setup Tool のトリガボタンをクリックする

  • Setup Tool で焦点を合わせている時に、キーボードの Ctrl+T キーを押す

外部操作の内容に合わせ、リーダには以下のトリガタイプを自由に設定できます:

  • シングル リーダがトリガを検知すると、 画像を1枚視取得してその画像に含まれるシンボルのデコードを試行します。このトリガモードはタイムアウト設定に対応しています。

  • マニュアル トリガ信号を受信している間はずっと画像を取得します。シンボルを検知してデコードを行うか、トリガ信号が消えると停止します。このトリガモードはタイムアウト設定に対応していません。

  • バースト一定数の画像を取得し、そのグループ内で検知した最初のシンボルをデコードします。バーストで取得する画像数と画像を取得する間隔が設定できます。このトリガモードはタイムアウト設定に対応しています。タイムアウトはバースト全体ではなく、バーストの中でそれぞれの画像に費やす時間の合計を意味します。

  • 連続 トリガ信号を受信している間はずっと画像を取得します。リーダは特定の間隔で画像の取得を続け、目的の画像に含まれるシンボルをスキャンしていきます。シンボルがデコードされると、リーダはトリガ信号の受信を停止します。シンボルが1つもデコードされなければ、トリガ信号の受信が継続している限り画像の取得を続けます。トリガ信号が終了した時点でシンボルのスキャンもデコードも行われなかった場合、リーダの結果は「読み取り無効」となります。

    リーダが複数のシンボルをスキャンするよう設定してあると、最初のシンボルをスキャンおよびデコードした後も画像の取得が継続します。また、指定数のシンボルが検知されるまで、あるいはトリガ信号が停止するまでスキャンを続けます。トリガ信号が終了した時点でシンボルの検知とデコードが指定数に達しなかった場合、リーダの結果は「読み取り無効」となります。

    画像の取得間隔は設定可能です。また、リーダがトリガを受信した後に画像の取得を開始するまで、何ミリ秒待機 (遅延) するかを設定することもできます。連続トリガモードでは、トリガの間隔によって間接的にタイムアウトが決まります。

その他のトリガタイプは外部操作によるものではなく、設定後はただちに画像の取得を開始します:

  • 自動読み取り ではシンボルのスキャンが続行され、シンボルを見つけるたびにデコードが行われます。

    自動読み取りモードのパラメータのいくつかでは、リーダが同じコードを繰り返し読み取るかどうか、また次のシンボルをスキャンするまでのリーダの待機時間についてなどの内容を設定することができます。[システム設定] ペインと [デコード設定] オプションを使用し、自動読み取りでのトリガ動作を設定します。

    自動読み取りモードでは [自動露光] を使用し、対象画像に対して適当な明るさを取得するように最適な露光設定をリーダが設定します。しかし、リーダはこの設定に従った画像を使用するため、デコードするシンボルを含んだ画像を見落としてしまうことがあります。[マニュアル露光] 設定に切り替えると、カメラの露光設定を細かく指定できます。

    特定の画像のデコードを試行する際、その間に取得した後続の画像はすべて消去されてしまいますのでご注意ください。

    このトリガモードはタイムアウト設定に対応していません。

  • セルフトリガでは、自動読み取りのようにリーダがシンボルのスキャンを続行し、シンボルを見つけるたびにデコードが行われます。自動読み取りモードと異なる点は、画像の 1 つ 1 つでデコードを試行することと、リーダが対象に対して適当な明るさを設定する[自動露光] 設定が無効になることです。

    セルフトリガモードのパラメータのいくつかでは、リーダが同じコードを繰り返し読み取るかどうか、次のコードをスキャンするまでの待機時間などの内容を設定することができます。[システム設定] ペインと [デコード設定] オプションを使用し、セルフトリガモードでのトリガ動作を設定します。セルフトリガモードでは、トリガの間隔によって間接的にタイムアウトが決まります。


トリガの設定で、さらに便利な使用法:

[同一コード再読み取り禁止]をオンにすると、シングルトリガの実行中に同じコードを何度も読み取るのを防ぐことができます。[同一コード再読み取り禁止]チェックボックスがオンになっていない場合は、リーダが[コード再読み取り遅延]設定にならって同じコードを再読み取り、再送信します (単位：ミリ秒)。

[コード再読み取り遅延] (ミリ秒) で、読み取り試行の間の遅延を指定できます。遅延に 0 以外の値を指定すると、データがリーダに接続されたデバイスを圧迫するのを防ぐことができます。


[最初の読み取り後]と[最後の読み取り後]の遅延オプションの違い:

[最初の読み取り後]遅延は最初に与えられたコードの読み取り後のタイミングで遅延が始まり、タイマーがリセットされません。すなわち連続読み取りといった複数の画像を扱うモードでのトリガでは同じコードを何度も読み取る可能性があり、一定の時間リーダの前にかざされるコードは[再読み取り遅延]と同じか、それ以上に読み取りが繰り返されます。

[最後の読み取り後]では画像にコードが現れるたびにタイマーがリセットされます。この場合はリーダがコードの前にかざされたままでも、再読み取りが行われることはありません。リーダの視野からコードが外れた場合だけ、[再読み取り遅延]と同じか、それ以上の読み取りを実行することになります。


リーダのトリガを実行すると、再読み取りが行われる理由:

[再読み取り遅延]および[同一コード再読み取り禁止]オプションは、シングルトリガの連続実行中以外には働きません。リーダのトリガで、タイマーと[同一コード再読み取り禁止]の対象となる最後のコードが消去されます。


同一コード再読み取り禁止について:

[同一コード再読み取り禁止] を有効にすると、シングルトリガの連続実行中に同じ文字列を続けて読み取るのを防ぎます。この機能はすべてのトリガーモードで利用することができますが、マルチコード読み取りだけで有効です。1つ以上のコードをシングルトリガの実行中に取得できるのは、マルチコード読み取りだけであるためです。[同一コード再読み取り禁止] チェックボックスがオンになっていない場合、デバイスは [コード再読み取り遅延] 設定にならって同じコードを再読み取り、再送信します (単位: ミリ秒)。


同一コード再読み取り禁止における、マスター/スレーブ間の関係:

マスターで[同一コード再読み取り禁止]を指定した場合にスレーブが同じコードを読み取ると、マスターはすべての結果を考慮して、重複した読み取り結果をソースとは関係なくフィルタリングします。


遅延モードとコード再読み取り遅延について:

遅延モードオプションでは、最初または最後の読み取りでのコードの再読み取り遅延を設定します。

コード再読み取り遅延(ミリ秒) オプションでは、読み取り試行の間の遅延を指定できます。遅延に 0 以外の値を指定すると、データがリーダに接続されたデバイスを圧迫するのを防ぐことができます。


[最後の N コードを再読み取りしない]の機能:

[最後の N コードを再読み取りしない] オプションを使用すると、デバイスは最後の文字が「N」のコードを読み取りません。下のボックスに「N」を入れる必要があり、そうでない場合は (番号が0の場合は) このオプションは無効です。このオプションは、1回のトリガー実行中すべての読み取りコードに適用されます。


[動き検出]とは:

[動き検出] では、デバイスの視野に動きが検出されてから一定の時間、有効にしているプレゼンテーションモードまたはセルフトリガモードに切り替えるよう、デバイスを設定することができます。

[動き検出] の設定は、トリガタイプがプレゼンテーションまたはセルフに設定されているときのみ可能です。[動き検出] が有効になっているとき、デバイスは画像を取得しませんが、視野内に動くものがあるかないか、バックグラウンドで検出します。

動きが検出された場合、デバイスはプレゼンテーションまたはセルフトリガモードで画像を取得します。[タイムアウト] 設定では、デバイスがトリガ発動から動き検出状態に戻った後の時間を秒単位で特定することができます。ただし、タイムアウト時間は動きがあったり読み取りに成功するたびにリセットされます。

[動き検出の感度] は、どの程度の動きをデバイスが感知してプレゼンテーションおよびトリガモードに切り替えるかが設定できます。


キーボードからトリガを送る方法:

<ctrl>-T キーを押してください (Setup Tool ウィンドウは必ず開いておきます)。


シングルトリガのレスポンスで、DataManが複数の結果を返す理由:

この動作は、ハードウェアトリガの入力ラインが使用されている時に起こることがあります。ライン上のシグナルが最終値の周辺で変動しており、リーダがその動きを別のトリガ信号と判断することが原因です。システム設定ペインの入力タブにあるデバウンス遅延が大きくなると、リーダが全ての変動をシングルトリガ信号と判断することがあります。


トリガ遅延、タイムアウト値の働き:

トリガ遅延グループから、遅延のタイプ設定、ならびにリーダがトリガを受信してから画像の取得を開始するまで、何ミリ秒待機するかを指定できます。この機能は、シンボルが完全に視野に入る前にリーダがトリガを受信することが分かる場合に使うと便利です。[シングル]、[バースト]、[連続]の 3 種のトリガタイプのみが、トリガ遅延に対応しています。

[シングル]と[バースト]モードには開始遅延時間がありますが、終了遅延時間はありません。連続モードはすべての遅延タイプを使用できます。

[タイムアウト] 値は、検知したシンボルのデコードをリーダが試行する際の合計固定時間を決めることができます。決められた時間内にシンボルのデコードができなかった時は、画像にデコード可能なシンボルが含まれない場合の「読み取り無効」の状態となります。タイムアウトが設定されていないと、リーダは次の画像に写る前に現在の画像から何らかのコードを読み取ろうと試行するため、動作がもたつきます。


画像露光を調整する方法:

自動読み取り、マニュアルの各トリガでは [自動露光] を使うと、対象画像にふさわしい明るさを取得するために最適な設定が自動的に決まります。いずれのトリガでも製品環境の必要性に応じて [露光最大] 設定を使ったり、あるいは [マニュアル露光] で露光時間をマイクロ秒単位で設定することができます。

また [マニュアル露光] では、[結果履歴] ペインの [明るさの最適化] をクリックすると、[最大露光] 値の範囲内の露光設定に適した一定の値が得られます。[ゲイン係数上限] 設定は、対象のピクセルの明るさの最大値を設定するときに使用します。


バーストモードでのトリガに合ったパラメータの選び方：

バーストモードのトリガは動きを伴う場合の使用に適していますので、取り込み回数とカメラの下で動く対象に合った長さを捉えるための間隔を決めることが必要となります。一度間隔時間を決めると、対象の長さに応じて取り込み回数を調節することができます。計算に必要な変数は次のとおりです。

  1. ライン速度 (mm/ 秒)

  2. クワイエットゾーン (mm) を含むコードサイズ

  3. FOV = 視野 (x または y、mm)

次の式を使って、間隔時間を算出することができます。

間隔時間 = 1000 * ((FOV 2 (コードサイズ)) / ライン速度)

一度間隔時間を決めると、捉えるコードの長さに応じて取り込み回数を調節することができます。対象物の最大長 (mm) は次のとおりです。

取り込み回数 * (FOV (2*コードサイズ))

(2*コードサイズ)という変数はフレームのオーバーラップを可能にします。これはコードが1つのフレーム (取得) で若干視野を外れている場合を考慮してのことです。(2*コードサイズ)は対象がきちんと収まっているフレーム同士の視野をだぶらせて、次のフレームの視野でコードが表示されるようにします。


バースト長の延長方法：

使用しているSetup toolで有効なリソースによって、設定できるバーストの最大サイズが異なります。デフォルトでは最大202画像となっていますが、リーダが捉える画像の保存先メモリを増やすことで、この容量を強化することができます。画像を保存するメモリの容量は、画像リフトに使用している画像スロットを解放したり、画像の視野サイズを縮小することで増やせます。この操作は[画像サイズ（ROI）] ペインで行います。

  1. [画像サイズ (ROI)]ペインを選択します。
  2. [イメージャの視野（FoV）]チェックボックス（シングル、バースト、連続トリガモード）をオンにして、イメージャの視野サイズを縮小します。

縮小後は [アプリケーションの詳細] にある [バースト長] パラメータを上げることができます。


セルフトリガモード、連続トリガモードでの間隔を計算する方法:

[間隔アシスタント] を使うと計算が楽になります。[間隔アシスタント] をクリックすると、案内がスタートします。

セルフトリガモードと連続トリガモードは動きを伴う場合の使用に適していますので、カメラの下で動く対象物に合った長さを捉えるための正確な間隔時間を決めることが必要となります。計算に必要な変数は次のとおりです。

  1. ライン速度 (mm/ 秒)

  2. クワイエットゾーン (mm) を含むコードサイズ

  3. FOV = 視野 (x または y、mm)

次の式を使って、おおよその間隔時間を算出することができます。

間隔 = 1000* ((FOV 2(コードサイズ))/ライン速度）

(2*コードサイズ)という変数はフレームのオーバーラップを可能にします。これはコードが1つのフレーム (取得) で若干視野を外れている場合を考慮してのことです。(2*コードサイズ)は対象がきちんと収まっているフレーム同士の視野をだぶらせて、次のフレームの視野でコードが表示されるようにします。


最大露光を変更する環境:

動きのある物体を読み取る時は、最大露光の値を下げてください。


グラフの表示内容:

グラフには使用可能な照明設定ごとに、明るさレベルの現在のスコアが表示されます。


[最高結果] で、色分け表示された点の意味:

点は上記グラフからの結果一組を表しています。


チューニング済み画像からの画像選択:

チューニングが終わると、最大 3 枚の候補画像が Setup Tool に表示されます。その中で最も良いものが自動的に選ばれて不揮発性メモリに格納されますが、候補画像をユーザが選択して適用することも可能です。


マルチコード設定時のチューニング操作:

視野に複数のコードがある場合、その内の一つだけがチューニングの対象となります。


「失敗しました。シンボルが見つかりません」のメッセージが現れた場合の対処方法:

[シンボル設定]を開き、デコードしたいシンボルを有効にしてください。


データフォーマット


データフォーマットの用途:

[基本] ペインで使用するフォーマットのタイプを選択できます。

[標準] ぺインは、個々のバーコードタブに定義済みの基本要素を利用して出力文字列をカスタマイズするのに使用できます。

  • 出力文字列は、[先行テキスト] フィールドに入力する任意のテキストで開始されます。

  • [一般]、[妥当性検査]、[測定] (該当する場合) タブのリストから項目を選択して、[追加] をクリックすると、それらが出力文字列に追加されます。デコードしたデータから特定範囲の文字を追加する場合は、[従属文字列範囲の設定] をクリックしてから、追加する文字範囲を入力します (例えば 1 ～ 3、5、8、10 ～ など)。 次に、リストにある[従属文字列] をクリックしてから、最後に [追加] ボタンをクリックします。

  • 出力文字列には、[終端テキスト] フィールドに追加する任意のテキストを含めることができます。

  • 全体文字列を CR/LF で終端させる場合は、CR/LF チェックボックスにチェックを入れます。


[標準] タブの下に複数のタブがある理由：

バーコードの種類ごとにフォーマットを設定することができます。 あるいは共通タブを使用して、特定のバーコードタイプのタブよりも優先させるデータフォーマットを設定することができます。


特定 / 共通の両シンボルフォーマットの使用方法：

[標準フォーマット] ペインで、特定のタブと [共通] タブの両方のシンボルを使う際には、次のような基準を採用しています：

  • それぞれの結果の読み取りができて、フォーマット設定が有効になっている場合はそのシンボル固有のフォーマットが適用されます。同じシンボルで複数の結果が存在する場合には、同一設定で個別にフォーマットされます。

  • [共通]タブが有効になっている場合は、それぞれの結果がそのシンボル固有のフォーマットに適用され、[共通]タブのフォーマットルールに追加されます。複数の結果については（対応しているリーダで）、結果が連結され、指定の区切り文字で分けられます。 末尾に追加の区切り文字が付くことはありません。連結した文字列は、[共通]タブのフォーマットルールでは1つの文字列と見なされます。

  • 複数の結果がある場合、連結された文字列における結果の順序は、 1) Data Matrix、 2) QR コード、 3) 1D コード、4) VeriCode、5) DotCode、6) OCRとなっています。

  • 固有のシンボルフォーマット設定を追記する場合、コード時間やトリガインデックスなどの全般的なデコードプロセス要素はグローバルな値として返されます。


標準フォーマットが無効な場合に送信されるデータ:

リーダは、デコードした全文字列の後ろにCR/LF を付けて送信します。


デコードしたデータだけを、CR/LF なしで送信する方法:

フォーマットを有効にしてから、出力文字列に全文字列 を追加し、CR/LF チェックボックスがチェックされていないことを確認します。

CR のみを送信する場合は、[終端テキスト] フィールドに \r を入力します。


入力文字列について:

入力文字列はスクリプトベースのフォーマットにおけるリーダのプロパティの一部として、または標準データフォーマットのトークンとして含むことができるフォーマット用トークンです。Setup tool入力文字列の他のプロパティを変更することはできません。こうしたパラメータはDMCCでのみ使用可能です。


Excel でセルがスキップしないようにする方法:

デフォルトでリーダは、送信された各コードの後に CR/LF を付けます。送信されたコードの Excel 入力にキーボード接続を利用している場合、CR/LF は Excel が各コードの後で連続してセルを 2 つ進めてしまう原因になります。これを防ぐためには、リーダが CR のみを送信するように設定します。

  1. [標準フォーマット] をクリックします。

  2. 使用しているシンボルを、[シンボル] タブで指定します。

  3. [フォーマット有効] ボックスをチェックします。

  4. [一般] タブにある [全文字列] をクリックします。

  5. [追加] をクリックします。

  6. [終端テキスト] で、テキストフィールドに \r を入力し、CR/LF ボックスのチェックを外します。


データ妥当性検査が有効な状態で、エンコードされたデータの特定エレメントを出力する方法：

まず、[データ妥当性検査] ペインで希望する検査方法を選択します。[データフォーマット] > [基本] タブ > [基本フォーマット] を有効にします。[標準] タブの [妥当性検査]タブを選択し、企業ID、シリアル番号、部品番号、固有アイテム、 GS1のアプリケーションIDを含む出力文字列に、データフィールドを追加します。


[標準] タブのデータフィールドに入っている、[一般] タブの各項目：

  • 従属文字列: エンコードされたシンボルに含まれる従属文字列です。この機能を使うには、従属文字列の範囲を指定する必要があります。

  • 全文字列: エンコードされたシンボルの全ての文字

  • デコード時間: リーダがシンボルのデコードに要した合計時間をミリ秒で表したものです。画像の取得時間、画像処理の中断時間、通信時間、データフォーマットなどの追加処理に要する時間は、デコード時間に含まれません。

  • トリガ時間: トリガ信号を受信してからデコード処理が完了するまでの合計時間をミリ秒で表したものです。

  • シンボル：デコードしたシンボルのコード

  • CR/LF: 復帰改行

  • TAB: タブ文字です。

  • SP: 空白文字です。

  • シンボルの識別子: ISO/IEC 15424:2008 規格によるシンボルの識別子

  • モジュールサイズ: シンボル内の各モジュールの幅 (もしくは高さ) をピクセルで表したもの

  • コード位置: デコードしたシンボルの四隅の座標値

  • コードの向き: デコードしたシンボルの向きが角度で報告されます。時計回りで回転したデコード済みシンボルは、正方向の変化と見なされます。

  • コントラスト: デコードしたシンボルの、コントラストの合計を 0 と 1 の範囲で示した値です。値が高いとシンボル内の明/暗モジュールにおけるグレー値の範囲が広く、逆に低い場合は明/暗モジュールのグレー値は同等であることを示します。

  • UEC: シンボルの未使用誤り訂正率の合計数です。エラー訂正は、シンボルのダメージで損なわれたデータの再構築、置換えを行います。理想値は "100" です。１D シンボルは常に -1 を返します。

  • 入力文字列: 受信した(シリアル/Ethernet)入力文字列。

  • フィルタ時間: フィルタリングの継続時間(ミリ秒)。

  • 結果ソース: デバイスの名前。

以下の値はすべてリーダの Setup Tool への接続の有無に関わらずカウントされます。

  • 読み取り合計: デコードしたシンボルの合計数

  • 読み取り無効合計: トリガを受信したものの、シンボルの読み取りが行われなかった合計回数

  • トリガ合計: トリガ合計 = 読み取り合計 + 読み取り無効合計 + 外れたトリガ合計

  • 外れたトリガ: トリガが検知された時点で画像バッファが無かったために外れたトリガの数

  • トリガインデックス: リーダが検知したトリガの合計数です。

[プロセスモニタ]ペインで処理統計を消去した時や、リーダを再起動した時は常に、次の値が0にリセットされます。

  • 読み取り合計

  • 読み取り無効合計

  • トリガ合計

  • 外れたトリガ

トリガのインデックスはリーダを再起動した時だけ0にリセットされ、処理統計の消去後はリセットされません。


Alt キー、Ctl キー、Shift キーの組み合わせシミュレーション:

この機能には \ALT-、 \CTRL-、 \SHIFT- 、\K の 4 つのエスケープシーケンスを使います。\ALT- は <ALT-key> シーケンスに、 \CTRL- は <CTRL-key> シーケンスに、 \SHIFT- は <SHIFT-key> シーケンスに、 \K は特殊キーに使用します。バックスラッシュに続くキーは必ず大文字にしてください。小文字だと特殊キーの組み合わせが認識されません。

シーケンスは [標準] ペインの [先行テキスト]/[終端テキスト] フィールドに入力します。

対応しているキーボードの特殊シーケンス

次のフォーマットを使用してください:

\ALT- ＋ キー名 ＋ ;

または

\CTRL- ＋ キー名 ＋ ;

または

\SHIFT- ＋ キー名 ＋ ;

または

\K ＋ キー名 ＋ ;

シーケンス、そしてシーケンスと同じプレフィックスを区別するために、文末のセミコロンは必ず付けてください。セミコロンが欠けていると、例えば \KF11 が "F11キーを押す" か "F1キーに続いて1を押す" かが検知できずに、シーケンスが勝手に解釈されてしまいます。

[共通] タブに上記2つのエスケープシーケンスを入力すると、いずれも「読み取り無効」と見なされますのでご注意ください。

対応しているキーシーケンスおよびキー

現在サポートしているキー/キーの組み合わせのリストです:

  • ALT-A ～ ALT-Z

  • CTRL-A ～ CTRL-Z

  • CTRL-F1 ～ CTRL-F12

  • SHIFT-F1 ～ SHIFT-F12

  • F1 ～ F12

  • ALT-F1 ～ ALT-F12

  • PageUp、PageDown、Home、End、矢印キー (上、下、左、右) 、Insert、Delete、Backspace、Tab、Esc、Print Screen、GUI (左、右) キー

    これらのエスケープシーケンス:

    • PageUp -> \KPup;

    • PageDown -> \KPdn;

    • Home -> \KHome;

    • End -> \KEnd;

    • Up Arrow -> \KUar;

    • Down Arrow -> \KDar;

    • Left Arrow -> \KLar;

    • Right Arrow -> \KRar;

    • Insert -> \KIns;

    • Delete -> \KDel;

    • Backspace -> \KBksp;

    • Tab -> \KTab;

    • Esc -> \KEsc;

    • Print Screen -> \KPrtScr;

    • Left GUI -> \KLGui;

    • Right GUI -> \KRGui;

  • Pause output -> \KPAUSE;

入力例:

  • <ALT-V> シーケンスを作るには \ALT-V;

  • <F10> キーを押した状態のシミュレーションには \KF10;

  • <Home> キーを押した状態のシミュレーションには \KF10;

  • ノートパッドのステータスバー (<Alt-v><s>) を有効/無効にするためのシーケンスは \Alt-v;s となります

誤った、または不十分なシーケンスが使用されると、エスケープシーケンスを示す2文字は無視されます。この場合はエスケープシーケンスの最初の2文字が飛ばされて、残りの文字が送信されます。例えば "\ALT-M11;" という無効なシーケンスの結果表示は "LT-M11;" となります。


データフォーマットのテスト方法:

ページ下のテストボタンを使って、プレビューを確認します。

シンボルをスキャンし、ステータスバーに表示されるフォーマットの結果を確認します。[結果履歴]ぺインを選択してから、シンボルを読み取ることもできます。結果履歴では、指定したフォーマットの結果が示されます。


出力オプション機能の働き:

出力オプション機能では、ユーザがさまざまなフォーマットで必要な出力データエレメントを出力することができます。例えば、コンマを 1 つ選び、ユーザが全文字列に続いてシンボルタイプの出力を選択すると、全文字列の後にコンマと 'Datamatrix' が出力されます。異なる出力をテストするには、任意の出力タイプを選択してから [テスト] ボタンを選択すると、横のディスプレイウィンドウで出力を確認できます。データ妥当性検査が選択されており、コードがデータ妥当性検査に合格しない場合は、出力オプション機能が無効になりますのでご注意ください。


テストボタンがグレーアウトしている理由:

少なくとも一件のデコードが正常に完了しないと、コードのテストはできません。


16 進数コードまたは、8 進数ASCII コードで文字を指定:

[先行テキスト] および[終端テキスト] フィールドに、\nnn (nnnは 8 進数 ASCII コード) として任意の文字を指定できます。また、16 進数による文字は、\xnn (nnは 16 進数 ASCII コード) を入力することによって指定できます。

次の定義済みコードも使用できます。

  • \a アラート (ASCII 7)
  • \b バックスペース (ASCII 8)
  • \E Escape (ASCII 27)
  • \f フォームフィード (ASCII 12)
  • \n LF (ASCII 10)
  • \t 水平タブ (ASCII 9)
  • \r CR (ASCII 13)
  • \v 垂直タブ (ASCII 11)
  • \\ バックスラッシュ (ASCII 92)


何のコードも読み取られない場合の、リーダの送信内容:

通常は、コードが読み取られない場合には、リーダは何のデータも送信しません。読み取ったデータがなかったため出力結果が表示されないということを通知させたい場合は、[基本] ペインの [文字列の読み取り無効] を指定すると、32 文字までの特定の文字列を指定できます。


コード位置結果の意味:

Data Matrix のシンボルでは、レポートされたシンボル四隅の位置がコード位置に表示されます。リーダは次の 4 つの組み合わせを返します。

  • 最初のペアはファインダパターンの交点を表します。

  • 2つ目のペアは横のファインダパターンと縦のタイミングパターンの交点を表します。

  • 3つ目のペアはタイミングパターンの交点を表します（最初のペアの対角になります）。

  • 4つ目のペアは縦のファインダパターンと横のタイミングパターンの交点を表します。

Cognex ではカンマなどの区切り文字を選んでそれぞれの値を区切り、結果データを見やすくすることをお勧めしています。


データフォーマットの選択方法：

選択方法には基本フォーマット (標準 / Perl ) を使用するほか、[スクリプト] ペインの [データフォーマット] タブで JavaScript 形式のスクリプトを作成することができます。この 2 つの方法の違い:

  • [基本フォーマット]は、既定のデータフォーマットをドラッグ＆ドロップするだけで完了します。

  • [スクリプトベースのフォーマット]は読み取り結果のフォーマット以外にも、ビープ音や出力 1 のプルアップといったリーダの挙動のスクリプトもオリジナルで作成可能です。


[通信]タブの役割:

このタブでカスタム通信プロトコルのスクリプトを編集できます。


[スクリプトベースのフォーマット]の制限事項:

[スクリプトベースのフォーマット]ではカスタムイベント数 2 つ、システムイベントの上書きに制限されています。


スクリプトのサンプルがある場所:

[スクリプト]ペインにあるメインウィンドウにスクリプトを入れる方法には、次のものがあります。

  • トップ画面のツールバーにある[スニペットの挿入]ボタンをクリックし、希望のスニペットをリストから選択します。

  • メインウィンドウ上で右クリックし、[スニペットの挿入]を選択します。その後、希望のスニペットをリストから選択してください。

  • Ctrl + K、X を押します。

注意: [スニペットの挿入] ボタンがアクティブでない場合は、デバイスで使用中のファームウェアバージョンが現在のスクリプトタブに対するスニペットをサポートしていません。


[FTPストレージ]タブの役割:

画像のFTPファイル名作成とコード品質レポートに使用するタブです。


スクリプトのロード方法:

リボンメニューをクリックしてスクリプトにアクセスし、次に [スクリプトを開く...] オプションをクリックします。[スクリプトを保存] ボタンでスクリプトを保存することができます。

注意: スクリプティングは、UTF-8文字エンコードのみ対応しています。


テキストの完成オプションの機能

スクリプト内のテキストを完成させる方法:

  • 上のツールバーにある[テキストの完成]ボタンをクリック

  • メインウィンドウ上で右クリックし、[テキストの完成]を選択

  • Ctrl + K、X を押す

これでスクリプトに挿入するオブジェクトの選択リストが表示されます。


スクリプトの簡単な編集方法:

上のツールバーにある切り取り、コピー、貼り付けボタンをクリックするか、メインウィンドウ上で右クリックし、切り取り、コピー、貼り付け、削除、すべて選択のいずれかを選びます。


[システム]＞[設定の保存]を選択すると変数がすべてリセットされる理由:

スクリプトが変更されてエディタのフォーカスが残ると、リーダに転送されたスクリプトによってスクリプトエンジンのコンテキストが無効化されるためです。スクリプトのコンテキストが無効化されると、すべての変数がリセットされる仕組みになっています。


DataMan X モデルのリーダのみ：データフォーマットのプロセス管理の使用方法：

[Data Matrixプロパティ]または[QR Codeプロパティ]ペインでプロセス管理を有効にすると、スクリプトでもアクセスできるようになります。プロセス管理が無効になっている場合は、測定を実行しても -1 と返されます。


DataMan X モデルのリーダのみ：プロセス管理の結果が 1 または NA とレポートされている意味：

シンボルの印刷状態や画質が著しく劣っている場合は、リファレンスのデコードアルゴリズムを用いたプロセス管理の測定が不可能になるため、「-1」または「NA」とレポートされます。画像のフィルタリング機能などで、印刷品質や画質を向上させてください。


スクリプトを使用した、デバイスログ内のエラー閲覧:

"Throw()" コマンドを使用すると、異常な状況 (例外) が発生した際に通知があり、デバイスがSetup Toolに接続していないときはエラーがデバイスログに表示されます。Setup toolのメニューバーから[システム]＞[デバイスログの表示]をクリックすると、エラーログにアクセスできます。

デバイスがSetup Toolに接続されているときは、スクリプトペインのスクリプトの下に例外が表示されます。


スクリプトベースのフォーマットに関する詳細:

より詳しい説明は、 DataMan 接続・プログラミングガイドをご覧ください （Windows の [スタート] メニューまたは Setup Tool のヘルプメニューからアクセスできます）。


コード出力を遅らせる設定方法:

コード出力の一時停止を設定するには、\Pause<time>; のシーケンスを [データフォーマット] ペインのテキストフィールドに追加します。

<time> の値はミリ秒で入れます。たとえば4秒待つ場合、このシーケンスは \Pause4000; となります。

この機能は USB HID または RS232 で使用できます。RS232 では、この機能は、DMCC コマンドの COM.RS232-ENABLE-PAUSE を使用するときに有効である必要があります。USB HID では、デフォルトで有効になっています。


画面上方にあるタブにてコード別にフォーマット設定ができる理由：

バーコードの種類ごとにフォーマットを設定することができます。 あるいは[共通]タブを使用して、デコードを試行したシンボルに対し特定のPerl スタイル正規表現フォーマットを設定することができます。


このペインがグレーアウトしている理由:

[Perlスタイル正規表現フォーマット] を使用可能にするには、まずお使いのリーダでデコードするシンボルに合わせ、[データフォーマット]ペインの [基本フォーマット] を有効にしてください。


任意のテキストの置換を指定する方法:

テキストを [正規表現:] テキストボックスに入力します。シンタックスは次のとおりです。

        /search/replace/g

search にはターゲットとなる文字列が、replace には search と置き換える文字列が入ります。デフォルトでは最初に search が出現したもののみ置き換えられます。すべてのインスタンスで置き換えを行うには、コマンドの最後に g を加えてください。

例えば、リーダが次の文字列をデコードしたとします。

        UPC 05214275600

この置換え用文字列を使用して、"UPC" という文字列を "SKU CODE:" に置き換えたとします。

        /UPC/SKU CODE:/

こうすると、出力される文字列が次のようになります。

        SKU CODE: 05214275600

スペースで区切られた複数の置換用ペアを入力することができます。複数のペアは連続して使用します。最初のペアでの結果が次のペアの入力に使用され、といった具合に続きます。


[不一致データの廃棄] の働き:

デフォルトで、一致する文字列ではないテキスト部分はそのまま通過します。[不一致データの廃棄] をオンにすると、置換が行われた文字列のみが送信されます。


使用できない特殊文字:

search、replace いずれの文字列でも、次の記号は特別な意味があります。

              ., (  )  [  ] $ \ / * + |

search または replace の文字列中にこれらの記号を使用する必要がある場合は、前にバックスラッシュ \ を入れます。バックスラッシュを入れる場合は、\\ と入力します。任意の ASCII 文字を入れる場合は、\xhh を入力します。 hh は 16 進値になります (\ooo を使用して 8 進の ASCII 値を指定することはできません）。


異なる文字やパターンに一致させるためのワイルドカードの使用方法:

search 列に次の特殊文字を使用すると、任意の 1 文字、セットになった文字のうち任意の文字、一連の文字のうち任意の文字、一連の文字にない任意の文字を一致させることができます。

.任意の 1 文字を一致

[abcd...]次のセットから任意の 1 文字を一致 a、b、c、d...

[a-z] a から z までの一連の文字から任意の 1 文字を一致 (文字または数字が使用できます)

一連の文字や文字セットを使用してワイルドカードの方向を反対にするには、^ の記号を前に入れます。

文字の変数を一致させるには、一致させたい文字またはワイルドカードに次の修正文字のうち 1 つを付け加えます。

+ 先行文字の 1 かそれ以上を一致

* 先行文字の 0 かそれ以上を一致

? 先行文字の 0 か 1 を一致

{n}　先行文字の n インスタンスを一致

{n,m}　先行文字の n 以上、m 以下のインスタンスを一致

{n,}　先行文字の少なくとも n インスタンスを一致

ワイルドカードの一致例をいくつか紹介します。

/A.B/AB/g では、入力文字列の 'A' と 'B' 間から任意の 1文字を削除します。

/A.*B/AB/g では、入力文字列の 'A' と 'B' 間から任意の数文字を削除します。


特殊文字の一致に使用できるワイルドカード:

特殊文字と文字タイプを一致させるためには、次のエスケープシーケンスを使用します。

\n　改行文字

\w　英数字 (文字または桁)

\W　非英数字

\s　空白文字

\S　非空白文字

\d　1 桁

\D　非桁

これらの記号は、前の項目にリストされた複数の文字を一致させるワイルドカードと組み合わせて使用することができます。


Search 列の固定：

文字列の始めに一致させるには、search 列の前に ^ を付けてください。文字列の終わりに一致させるためには、search 列の前に $ を付けます。


結果文字列に search 列の一部を再利用する：

結果文字列内で使用したい search 列の一部または数か所をカッコで括ります。\1、\2 のようなトークンを使用すると、結果文字列に取り入れた列を参照することができます。


[Perlスタイル正規表現] のサイズ上限:

入力するスクリプトの最大サイズは、一つのタブで512文字です。ただし、シンボル固有のタブは共通タブより先になります。両者を同時に使用する場合は、1024文字が最大文字数です。


[Perlスタイルの正規表現]に関する詳細:

ここを参照して下さい。このページに記載されているすべての機能が、リーダによって実行されるわけではないことに注意してください。


入力/出力


3秒実行ボタンがグレーアウトしている原因:

トリガボタン実行機能に対応しているのは、シングル、バースト、セルフのトリガモードに限られます。

テストモードオプションは上位のオプション(明るさの最適化から文字列の一致設定まで)のチェックがすべて外されている時にだけ有効になります(選択可能になります)ので、ご注意ください。


TRIG ボタンタブにある、[リーダのボタンを無効にする] チェックボックスの働き:

[リーダのボタンを無効にする] をチェックすると、リーダのプッシュボタンを押しても読み取りや登録の動作が開始されなくなります。なお、この機能はSetup Toolのボタンバーにあるトリガボタンやシリアルトリガコマンドを無効にするものではありませんのでご注意ください。


トリガボタンを 3 秒押し続けることで設定できるアクション:

シングル、バースト、セルフの各トリガモードでチューニングボタンを 3 秒間押すと、リーダの反応を設定することができます。複数の項目を有効にすると、リストの順番で機能が実行されます。

トリガボタンを押し、そのまま 3 秒押し続けると次のことができます:

  • 最新のトリガモードがこの操作に対応している場合、取得した画像の明るさの最適化を登録する

  • 設定コードドキュメントから、設定コードを読み取る

  • リキッドレンズが装着されている場合に、オートフォーカスする

  • 読み取り可能と想定したシンボルをリーダに登録する

  • 文字列の一致検査を実行中に、一致した文字列をセットする

  • デバイスをテストモードにする

Setup Tool のボタンバーにあるトリガボタンを使っても、トリガボタンを押し続けるのと同じ操作ができます。


TUNE ボタンタブにある、[リーダのボタンを無効にする] チェックボックスの働き:

[リーダのボタンを無効にする] をチェックすると、リーダのプッシュボタンを押しても読み取りや登録の動作が開始されなくなります。なお、この機能はSetup Toolのボタンバーにあるトリガボタンやシリアルトリガコマンドを無効にするものではありませんのでご注意ください。


[入力] タブの入力ラインそれぞれの働き:

[入力ライン アクション] でリーダのアクションを設定することができます。デフォルトではリーダは入力ライン 1、2、3 の信号には応答しません。入力ライン 0 と 1 だけが、トリガ信号に使用できます。

入力ラインの [コード登録]、[明るさの最適化]、[一致した文字列の登録]、[設定コードの読み取り] は、次回のトリガからアクションを実行します。

選択できるアクションは次の通りです:

  • トリガオン＆トリガオフは、同じ入力ラインではデフォルトで有効になります。トリガオフはトリガオンの逆の機能になりますが、これらを別々のラインにつなげていれば、用途に合わせて個別に極性の設定ができます。

  • [エンコーダ]の入力ラインには、使用するエンコーダを接続します。

  • エンコーダの方向

  • [登録コード]で取得する画像から想定されるシンボルを登録しておくと、デコードにかかる時間を短縮することができます。

  • [明るさの最適化]は、コードの読み取りに最も適した明るさと、イメージャの設定をリーダが選択します。

    注意: ROI のサイズが144以下の時は、明るさの最適化ができません。

  • [一致した文字列の登録]は、デコードしたコードと以降のコードが合致するか検査します。

  • [焦点位置の最適化] (リキッドレンズ搭載リーダのみ) では、コードの読み取りに最も適した焦点位置の設定をリーダが選択します。

  • [設定コードの読み取り] は、リーダが読み取りの対象を画像ではなく設定コードとして認識するものです。そのためトリガのカウントが減り、読み取り無効画像が発生しません。

  • [チューニング]は、コードの読み取りに最も適した設定をリーダが選択します。

    注意: ROI のサイズが144以下の時は、チューニングができません。

  • [バッファした読み取り無効画像を許可]が有効になると、パッケージを検出するセンサーに接続した時に、リーダが読み取り無効画像をバッファするようになります。読み取り無効画像の原因を突き止めたい場合などに便利です。

  • [出力消去]は入力がトリガされると、直ちにすべての出力がリセットされる機能です。出力遅延設定はリセットされません。

  • [極性] は、極性が設定されている場合に撮像のトリガ信号を変えます。

  • [デバウンス遅延] テは、トリガ信号が有効と認識されるのに必要な検知時間を設定します。


トリガ検出の設定変更をするには

撮像トリガ信号の変更設定は、[極性]オプションを使います。

デバウンス遅延テキストボックスで、トリガ信号が有効と認識されるのに必要な検知時間を設定してください。ESD（静電気放電） のラインノイズを補正するには短い数値を、電気機械式リレーのノイズを補正するには高い数値を採用します。ご使用の製造環境に最も合う数値を選ぶため、設定の調整が必要な場合があります。


設定可能なデバウンス時間:

最短の時間は0です。数字が大きくなるほど、デバウンスの時間が延びます。最大の値は6です。


[出力] タブで設定できること:

[出力」タブでは、リーダにある全ての出力ラインの挙動を設定できます。どの出力ラインでも、イベントとアクションの設定が可能です。

読み取り無効の状態が発生したときのため、読み取れないコードがあると特定の文字列を送信するよう設定することもできます。


選択したアクションについて:

チェックボックスにチェックを入れると、すぐにはアクションを反映させません。アクションが実行されるのは、次回のトリガからになります。


[バッファした読み取り無効画像を許可]の機能:

この項目が有効になっており、かつパッケージ検出センサーなどに接続されている時に働く機能です。バッファが全画像に適用されていても、センサーが特定のインプット信号を発した時に、読み取り無効画像のみがバッファされます。結果としてセンサーが実際にパッケージを検出した時に、リーダが読み取り無効画像のみをバッファすることとなります。この機能が使用できるのは、連続トリガモードに限られます。


読み取り成功時のビープ音設定方法:

[出力] タブの [読み取り成功時のビープをオンにする] にチェックを入れます。その後、[ビープ音長さ]に 0 ～ 50 ミリ秒までの時間を入力してください。


[ライトリングパルス時間] 設定の用途:

ライトリングのあるリーダについて、ライトリングが点灯している時間をミリ秒単位で設定することができます。


データ妥当性の合格イベント作成方法:

データ妥当性検査がオンになっていると、コードが読み取られ、かつ妥当性検査に合格した場合に、読み取りイベントが送信されます。読み取り有効/読み取り無効のそれぞれのイベントが 2 つの出力に割り当てられている場合には、次のように経過します:

  1. 読み取り成功、妥当性検査合格: 読み取り出力

  2. 読み取り成功、妥当性検査不合格: 出力なし

  3. 読み取り失敗: 読み取り失敗出力

もしくは、出力に[検査エラー]イベントを割り当てることも可能です。


デバイスのエラーランプ点灯時の確認方法:

システム->デバイスログの表示からログを指定すると、記録が表示されます。


リーダのリセット方法:

『クイックリファレンス』の裏表紙に印刷されたスキャナを再起動するコマンドをスキャンして、ソフトリセットを実行します。リーダの不揮発性メモリはクリアされませんが、リーダはシャットダウンされて、再起動します。

DataMan の設定を工場出荷時のデフォルト値にリセットするコマンドをスキャンして、リーダを工場出荷時のデフォルト状態に戻します。


不特定の時間、出力ラインを閉にできるかどうか:

0ミリ秒のパルス幅設定で出力ラインをずっと閉にしておくことは可能ですが、この出力ラインでトリガを引いてもリーダの電源をいったん切ってすぐに入れ直すかディスクリート入力設定で出力を消去するまで閉の状態が続く場合がありますのでご注意ください。


[アクション] フィールドの開閉表示の意味：

ここでの「開/閉」は、リレーのステータスを意味しています。上のリストからイベントが発生すると、出力側が開か閉になります。例えば閉の場合だと、読み取りイベントが発生すると出力0が出力1になります。また、0ミリ秒のパルス幅設定で出力ラインをずっと閉にしておくことは可能ですが、この出力ラインでトリガを引いてもリーダの電源をいったん切ってすぐに入れ直すかディスクリート入力設定で出力を消去するまで閉の状態が続く場合がありますのでご注意ください。


特定の出力オプションがすべて無効になっている理由：

使用中のリードセットアップでその出力ラインを使用している[ストロボ]にチェックが入っていると、オプションが無効になります。


トリガのオーバーランの意味:

カメラがビジー状態なために画像の取得ができない場合に、トリガのオーバーランが生じます (例えばバースト中であったり、長時間露光の最中など)。


バッファのオーバーフローの意味:

画像は取得可能でも、そのための保存領域がない場合にバッファのオーバーフローが生じます。言わば、画像の取得に処理が追いつかない状態です。画像/トリガの間隔よりもデコードに時間がかかっている場合などに発生します。


何のコードも読み取られない場合の、リーダの送信内容:

通常は、コードが読み取られない場合には、リーダは何のデータも送信しません。[文字列の読み取り無効] を指定すると、32 文字までの特定の文字列を送信することができます。[システム設定] ノードをクリックし、[読み取り無効の出力文字列] フィールドに文字列を入力します。 その後 「Enter キー」 を押してください。


ストロボオプションの機能

出力ラインの一つでストロボにチェックを入れると、出力を外部光源に使用できます。該当する出力セルで開/閉を選択し、極性を設定することも可能です。


出力遅延の設定方法:

出力遅延時間を定め、ミリ秒単位で設定できます。また、トリガ開始/トリガ終了に関連した出力遅延も指定できます。


出力遅延、トリガ遅延を両方使用する方法:

いずれのトリガも物理的なトリガのエッジに関連しており、画像の取得開始の遅延には関連していません (トリガ遅延が設定されている場合)。


出力遅延が設定できない理由:

出力遅延が設定できるトリガモードは、マニュアル、シングル、バースト、連続のみです。


出力遅延で影響を受けるデジタル出力ライン:

すべてのアクションは以下のイベントに基づきます:

  • 読み取り/無効

  • 妥当性検査失敗

が遅延。影響を受ける出力ライン:

  • デジタル出力設定

  • RS-232、イーサネット、USB によるデータ転送

  • LED 照明

  • ビープ音


出力距離の意味:

パルスエンコーダを使用すると、出力までの距離を指定してパルスと距離をマッピングできます。出力距離は解像度の数値をベースにして修正されます (一番近い解像度の倍数を mm 単位で四捨五入して調整)。

[出力遅延]タブの出力距離 (mm)を使うと、トリガから結果出力タイミングまでの距離が設定できます。

[パルスエンコーダ]タブでは、解像度の管理に解像度 (mm) を使用します。


パルスエンコーダについて:

外部トリガモードでは、データ列の出力タイミングを制御するエンコーダが使用できます。通常エンコーダはコンベヤベルトに搭載されており、ベルトの動きに合わせて軸が回転することで、角回転を示す電気パルスを出力します。エンコーダの回転数は、コンベヤベルトの搬送距離と直接比例します。

エンコーダは入力ライン 1 または 2のいずれかに接続してください。選んだ入力ラインはエンコーダ専用となります。それ以外の操作では別の入力ラインを使用してください。

エンコーダをマスター/スレーブグループのマスター側につなげることも可能です。


パルスエンコーダで設定できること:

出力までの距離を指定し、パルスと距離をマッピングできます。出力距離は解像度の数値をベースにして修正されます (一番近い解像度の倍数を mm 単位で四捨五入して調整)。

[出力遅延]タブの出力距離 (mm)を使うと、トリガから結果出力タイミングまでの距離が設定できます。

[パルスエンコーダ]タブでは、解像度の管理に解像度 (mm) を使用します。


デバイス名の変更について:

場所や検査課題といった製造環境に合わせて、デバイスの名前に分かりやすい意味を持たせることができます。[アドバンスト] タブの [デバイス名] で操作してください。


デバイスの説明を追加する方法:

[アドバンスト] タブの [デバイスの説明] は自由に記入できるテキストフィールドで、デバイスに関するメモや必要な情報を追加することができます。


デバイス名の変更方法：

デバイスの名前を変更する：

  1. [デバイス名]フィールドに、新しいデバイス名を入力します。

  2. "変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。

  3. 「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、デバイスを再起動してください。

次回 Setup Tool を起動するか、[リーダへの接続]ペインの[更新]をクリックすると、新しいデバイス名が反映されます。


エラーLED パルス時間設定の内容：

エラーLEDのパルス時間を固定デバイスで指定する時は、スライダーをミリ秒単位で動かせます。エラーLEDはデバイスの一番上にあります。スライダーを '0' に合わせると、デバイスログを取得した時に赤いエラーLEDが消え、指定した時間が経過すると '0' 以上の値で赤いエラーLEDが自動消灯します。


ウェイクアップメッセージの機能:

[ウェイクアップ時の診断文字列出力] が有効になっていると、リーダが起動したときに常に診断文字列を送信します。

Telnet 接続では、接続が確立するたびにリーダが診断文字列を送信します。シリアル接続の場合は Setup Tool の設定に関係なく、メッセージが送信された時のボーレートが自動的に 38,400 にセットされています。


通信


1文字以上のシリアルトリガコマンドの操作方法：

トリガオン / トリガオフコマンドは、文字列で最大32バイトまで対応しています。対応可能な文字列の長さは32文字（エスケープ文字なし）～128文字（ 32 * エスケープ文字数 4 [例：\002]）まで幅があり、使用するエスケープ文字列の数により異なってきます。


[エコーコマンド]を有効にした場合の機能：

[エコーコマンド]を有効にした場合、コマンドヘッダおよびコマンドフッタで区切られたコマンドをリーダが受信すると、ただちにエコーバックが実行されます。


ターミナルプログラムでトリガコマンドやエコーコマンドが使用できない理由:

カスタムコマンドはPLCまたは類似のデバイスで使用可能になっており、手動入力はできません。文字間の遅延はおよそ50ミリ秒と小さく設定されていますので、最初の文字以降のカスタムコマンドの入力が遅れると認識されない場合があります。1文字を超えるトリガオン / トリガオフコマンドは、必ず別のアプリケーションから文字列として送信してください。


[アプリケーションの詳細] の設定項目：

[通信] アプリケーションにある3つのタブでは、シリアル＆イーサネット設定を行えます。目的のタブをクリックし、設定値を入力してください。

[アドバンスト] タブではテーブルビューに詳細設定を加えることが可能です。


リーダのシリアルポート設定変更方法:

[通信] アプリケーションの [シリアル] タブから設定を変更します。Windowsのスタートメニューまたは Setup Tool のヘルプメニューから、設定コードをスキャンすることもできます。


USB ドライバ互換モードの使用方法:

デフォルトでは DataMan リーダは USB ドライバを採用しており、静電放電 (ESD) 発生時にリーダの回復をサポートします。厳密に USB の仕様との適合性を図りたい場合や、DataMan と Cognex SensorView 製品を併用する場合には、[USB ドライバ互換モード]を使用してください。

[USB ドライバ互換モード]を変更すると、"変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、リーダを再起動してください。


USB 接続中、キーボードの代わりにリーダを使用するには：

USB キーボードをエミュレートするには、リーダ設定コードドキュメント (Windows の [スタート] メニューまたは Setup Tool のヘルプメニューからアクセスできます) の [USBキーボード] コードをスキャンし、 Setup Tool への接続を忘れずに切ってください。


[使われた通信チャンネル]ドロップダウンで選択できること:

USBでの通信方法を設定することができます。使用している機器によって、次のオプションが使用可能です。

  • USB-COMのみ: シリアルポートでデバイスとやり取りする場合に選択します。

  • USB-HIDのみ: デバイスをUSBキーボードのように扱うことができるオプションです。

  • USB-COM + USB-HID: 両方のモードを組み合わせたオプションです。

注意: USB-COMのみを選んだ場合、HIDの機能がなくても「HIDデバイス」にリストアップされることがあります。


PS/2 アダプタでキーボードの代わりにリーダを使用するには：

『クイックリファレンス』に記載されているように、PS/2 キーボードをエミュレートするにはシリアルケーブル、外部電源、キーボードウェッジケーブルが必要になります。[PS/2のキーボードエミュレーション有効] 設定コードをスキャンします (リーダ設定コードは、Windows の [スタート] メニューまたはSetup Toolの [ヘルプ] メニューからアクセスできます)。PS/2 アダプタのインストールは、必ず PC の電源を完全に切って行ってください。リーダを上記のケーブルで接続します。コンピュータの電源を入れると、リーダが PS/2 アダプタをエミュレートします。


リーダの再起動を行わなかった場合の動作:

変更した設定は有効になりません。システムをクリックして設定の保存を選択し、リーダを再起動してください。


マルチポート (RS-232 シェアリング) 機能:

この接続モードでは複数のDataManリーダ (同一機種) で、1台のPCまたはシリアルポートを搭載するほかのデバイスのシングルシリアル接続を共有することができます。マルチポートで接続すれば、リーダはデイジーチェーン状につながります。それぞれのリーダが前のリーダから連続してデータを受信し、さらにそれを次のリーダへと転送します。リーダがデータを転送する際は、輪の中にある各リーダPCを通過していきます。

ご利用のシステム設定条件に適したケーブルをご用意いただく必要があります。ケーブルはDataMan 1台ごとにDB-15コネクタを、コンピュータのシリアルポートにはDB-9コネクタを用意してください。各DB-15コネクタはTxデータ、Rxデータ、トリガ (Input-0)、グラウンド、DC電源を用意してください。隣接したコネクタのTx データとRxデータピンをつなげながらマルチポート接続を確立します。

必ずそれぞれのDataManをUSB接続で順番にDataMan Setup Toolと接続し、マルチポート操作用にDataManを設定してください。マルチポート用にデバイスの設定を行うには、[マルチポートを有効にする] (RS-232シェアリング) チェックボックスをクリックします。

マルチポートに関するさらに詳しい情報は、該当する「リファレンスマニュアル」の「マルチポート接続」の章を参照してください。このマルチポートシェアリング機能には、次の動作上の特徴と制限があります。

  • 共有中のリーダは、USB 接続によって PC やそのほかのデバイスにつなぐことができます。

  • リーダは必ず個別のトリガ信号を受信するようにしてください。DataMan はシリアルトリガには対応していません。

  • リーダは必ず個別に設定してください。

  • 各リーダからのデータは、すべてソートやフィルタリングが行われないまま PC やほかのデバイスに送られます。


ゼロパディングについて：

ゼロパディング（ゼロ詰め）とは、リーダが送信したデータを受け取る際、アプリケーションに応じて転送データの先頭にゼロ(0)を付加して固定長にするものです。


リーダのネットワーク設定方法:

DataMan 8000 ワイヤレスリーダでは、ベースステーションでネットワーク設定を行います。有線リーダでは ネットワーク タブから設定を行います。

[DHCP サーバを使用する]を選択して、 (利用可能な場合は) DHCP サーバ からリーダに IP アドレスを割り当てるか、[固定IPアドレスを使用する]を選択して手動でIPアドレスを割り当てネットワーク設定をします。入力する値は担当のネットワーク管理者にお尋ねください。

設定を変更すると、"変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、リーダを再起動してください。


PCネットワーク設定のコピー

[PCネットワーク設定のコピー] ボタンを押し、ドロップダウンメニューから Dell GigabitEthernet、Bluetooth Device、Microsoft Wi-Fi Direct Virtual Adapter、Dell Wireless 1560 802.11acのいずれかを選択します。PCのネットワーク設定が上のフィールドに保存されます。


ファームウェア開始の再リスト化:

COMポート名が列挙されてもファームウェアの開始に時間がかかった結果、COMポートがタイムアウトして通信が切れることがあります。このオプションを有効にすると、ファームウェアが再開した後でCOMポートのリスト化をもう一度繰り返し、そのような事態を防ぐことができます。


[文字間の遅延]の役割:

キーボード/文字の読み取りモードを使用中に、読み取った一つずつの文字の間でミリ秒単位の遅延を設ける設定です。連続読み取りの速度が原因で、一部読み取れない文字が生じる場合に便利な機能です。


産業用プロトコル

Ethernet/IP プロトコル

リーダがEthernet/IPプロトコルを使用できるようにするには、[Ethernet] タブ > [産業用プロトコル] の [EtherNet/IP] にチェックを入れます。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] をクリックし、リーダを再起動します。

PROFINET プロトコル

リーダがPROFINETプロトコルを使用できるようにするには、[PROFINET] にチェックを入れます。[ステーション名を使用] をクリックすると、ステーションの名前を入力できます。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] をクリックし、リーダを再起動します。

SLMP プロトコル

リーダがSLMPプロトコルを使用できるようにするには、[SLMP プロトコル] にチェックを入れ、必要なパラメータを設定します。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] を選んだ後、変更内容を反映させるためにリーダの電源を切ってから入れ直すか、またはリーダ設定コード表のリセットコードを読み取り、リーダを再起動してください。

Modbus TCP

リーダがModbus TCPプロトコルを使用できるようにするには、[Modbus TCP プロトコル] にチェックを入れ、必要なパラメータを設定します。

通信バナー右側に「再起動して変更を反映してください」というメッセージが現れます。[設定の保存] を選んだ後、変更内容を反映させるためにリーダの電源を切ってから入れ直すか、またはリーダ設定コード表のリセットコードを読み取り、リーダを再起動してください。

EtherNet/IP、PROFINET、SLMPプロトコル、Modbus TCP の選択項目がグレーアウトしている理由:

一度に使用できるEthernet産業用プロトコル は一つだけです。一つのプロトコルが指定されている間、他のものは選択できません。


産業用プロトコルの [ステータス] フィールド：

産業用プロトコルの[ステータス]フィールドには、ステータスダイアログで最後に記録されたメッセージが表示されます。このメッセージは新たなメッセージが記録されるまで表示されます。産業用プロトコルが有効になっていない時は、ステータスフィールドに何も表示されません。

ステータスメッセージはプロトコルによって異なり、中にはメッセージを記録しなプロトコルもあります。産業用プロトコルのステータスが扱うメッセージ、ならびに表示を行うプロトコルに関する詳しい説明は、「Dataman 接続・プログラミングガイド」の110ページに記載してあります。


Modbus TCP：待機状態のタイムアウト設定

[待機状態のタイムアウト] は、送信の無い状態でポートが開放されている時間の合計を指します。リーダがFTPサーバに接続されると、リーダは通信が発生するまで接続を維持します。

通信状態のタイムアウト時間内に通信が発生しない場合、接続は終了します。FTP転送の頻度が低く接続状態を維持するコストをかけたくない場合に便利です。

待機時間のタイムアウトを設定する前に、[Modbus TCP を有効にする]を確認してください。


認証オプションの使用方法:

[認証]が有効になると、ネットワーク経由で稼働可能なリーダまたはベースステーションに接続しようとするたびに、 Setup Tool がユーザに対して管理アカウントへのパスワードを要求します。


TCP/IP 接続の確立方法:

リーダは、Telnet TCP接続用のデフォルト端末設定であるポート番号23のTCP接続に対応しています。Telnetクライアントを使用していれば、必要となるパラメータはリーダのIPアドレスのみです。接続に他のアプリケーションやSDKを使用している場合は、TCPポートの設定がリーダのそれと同じであることを確認してください。TCPポートはTelnetペインで変更できます。接続すると、リーダが自動的にコード出力を送信します。DataMan Control Commands (DMCC) も、この接続方法で転送することが可能です。

Telnetポートを変更すると、"変更内容を有効にするには、再起動が必要です。今すぐ再起動しますか？" というメッセージが現れます。その際、「はい」をクリックしてください。「いいえ」をクリックすると、変更が実行されません。システム 設定の保存を選んでから、リーダを再起動してください。


FTP サーバへの画像の送信について:

FTP 画像タブで画像を FTP サーバに送信するための設定が行えます。このタブではサーバの IP アドレスとポート番号の設定以外にも、ユーザ名とパスワードの組み合わせを設定できます。リーダが高頻度で処理を行っていて画像転送の時間が取れない場合などは、FTP を使った画像送信は失敗する可能性もありますのでご注意ください。

ファイル名オプションでは画像の保存先となるファイルを指定できます。ファイル名フィールドには、 FTP サーバのルートディレクトリに関連付けたパスを指定することができます (例: /failed_images/image など)。ファイル名の後に付く拡張子 (.jpg か .bmp) は、[バッファ済画像の設定]ペインで設定したフォーマットに合わせます。リーダ本体でディレクトリを作成することはできません。必ずアクセス可能なディレクトリを用意しておいてください。

追加上限数は、ファイル名の末尾に付加される通し番号(インクリメント値)の上限を表示します。0の場合、通し番号は付加されず、同じ名前となるためファイル名は毎回上書きされることになります。

サーバが作成したファイル名オプションは FTP サーバのルートディレクトリに表示されている空白パスで開始します。

FTP サーバに送信する画像の種類を[転送する画像の種類]リストから選ぶことができます。使用する FTP サーバが画像転送に対応していることを必ず確認してください。


ネットワーククライアントの機能:

ネットワーククライアントは、DataMan ID リーダがネットワーク上の別のデバイスに対し、イーサネット接続をオープンする手段として機能します。一度接続がオープンすると、DataMan の Telnet 接続も同じ基本動作を行います。すなわち読み取り結果を作成 (結果を外部デバイスに送信) できるようになり、DMCC サーバ (外部デバイスから受信した処理コマンド) として処理できるようになります。


ホストの機能:

ホストとは、DataMan を接続するネットワーク上のデバイスを意味します。ホストの設定には、イーサネットアドレスとホストデバイスのポート番号が必要です。アドレスは有効なドメイン名 (server.mynetwork.com など) またはドット付き 10 進数形式の IP アドレス (192.169.0.1 など) のいずれかを入力します。


クライアントポートの機能:

クライアントポートとは、クライアント接続の元となるリーダのイーサネットポートです。デフォルト値の 0 は、ネットワーククライアントに空いているポートの使用を指示します。ただし場合によっては、クライアントポートを指定する必要があることもあります。その際は、規定の値をクライアントポートに入力してください。通常の使用であれば、デフォルト値の 0 を変更する必要はありません。特に何もなければデフォルト値のままにしておいてください。


接続の確立方法:

クライアントは[接続を開く]オプションの選択に従って接続を行います。接続は DataMan 起動時、またはデータ関連の動作 (コードの読み取りなど) が発生した時のいずれかを選べます。


接続の切断方法:

[接続を閉じる]オプションには 2 つの種類があります。一つは接続を切らずに維持するか、もしくはデータの転送完了時に接続を切るかです。リーダのデータ転送後では任意の秒数を設定できます。リーダが指定の待機時間を過ぎると、接続が切れます。入力できる時間は 1 ～ 3600 秒です。


接続のタイムアウトの働き:

[接続のタイムアウト]では、接続がオープンになるまで DataMan が待機する合計時間をミリ秒で表します。ただしパワーアップ オンが選択されている場合、リーダは接続がオープンになるまで再試行を繰り返します。


再接続遅延の意味：

再接続を試行するまで、リーダが一時的に停止する合計時間をミリ秒で表しています。


非印字文字機能の特徴:

通常、非印字文字の RAW 値はリーダが COM 通信用に設定されている場合に送信されます。これらの値は、リーダがキーボードウェッジ設定で設定されているとまったく表示されません。非印字文字を <CR> のようなキーボード印字可能文字列に変換する場合、[印刷不能文字の変換] 機能を有効にするとリーダの設定ができるようになります。


変換される非印字文字について:

[印刷不能文字の変換] が有効になっていると、0x00 - 0x1F、0x7F の値の 8 ビット ASCII 文字コードが変換されます。文字は次のリストの通り、ASCII のものに対応しています:

0x00 <NUL>

0x01 <SOH>

0x02 <STX>

0x03 <ETX>

0x04 <EOT>

0x05 <ENQ>

0x06 <ACK>

0x07 <BEL>

0x08 <BS>

0x09 <HT>

0x0A <LF>

0x0B <VT>

0x0C <FF>

0x0D <CR>

0x0E <SO>

0x0F <SI>

0x10 <DLE>

0x11 <DC1>

0x12 <DC2>

0x13 <DC3>

0x14 <DC4>

0x15 <NAK>

0x16 <SYN>

0x17 <ETB>

0x18 <CAN>

0x19 <EM>

0x1A <SUB>

0x1B <ESC>

0x1C <FS>

0x1D <GS>

0x1E <RS>

0x1F <US>

0x7F <DEL>


[印刷不能文字の変換] を有効にした場合の動作:

このパラメータは実際のコード内容にのみ影響します。ヘッダーやフッターといった、付加的なフォーマットには関与しません。これは、例えばコード間に改行を入れられるようにしたり、スプレッドシートの次のセルに移動できるようにするなど、このパラメータと制御文字を併用する能力を維持するための措置です。


非印字文字が含まれているコードの場合の送信内容:

通常は非印字文字の RAW 値が送信されます。非印字文字から <CR> のような印字可能文字のシーケンスに変換するよう、リーダを設定することができます。[非印字文字] ペインを開き、有効にチェックを入れます。


修理とサポート


[修理とサポート] とは:

[修理とサポート] ページは、構成ミスのあるネットワークデバイスのネットワーク設定や、シリアルデバイスのHIDモードをCDCに変更する時に使用します。


[更新]の使用方法:

使用可能なデバイスのリストを更新する時に、[更新]ボタンをクリックしてください。


表示されたデバイス一覧に、ネットワークデバイスを追加する方法:

[ネットワークデバイスの追加]をクリックすると、ネットワークデバイスの追加ができるほか、既に追加されているデバイスのIPアドレスを編集できます。[ネットワークデバイスの追加]ダイアログに、デバイスのIPアドレスを入力します。OKをクリックして変更を保存すると、[接続]ページにそのデバイスが表示されるようになります。


デバイスのプロパティの編集方法:

リストからデバイスを選択して、可能なオプションを確認してください。開いたペインで選択したデバイスに関するネットワーク設定の編集および認証オプションの設定ができます。[適用]をクリックすると、変更が保存されます。


DataMan 60、300、503、8000 シリーズ、および DataMan 8000 ベースステーション: [デバイスの追加]の使用方法:

[デバイスの追加]では、ネットワークデバイスのリストにご使用の DataMan を手動で追加することが可能です。追加後は、PCの通信ポートのかわりにEthernetで DataMan リーダ/ベースステーションと Setup Tool を接続することができます。

[デバイスの追加]には、リーダ/ベースステーションのIPアドレスを入力する必要があります。現在リーダ/ベースステーションに割り当てられているIPアドレスの確認には、以下の手順に従ってください:

  1. PC の RS-232 接続でリーダ/ベースステーションと Setup Tool を接続します(Setup Tool の[COM ポート])。

  2. [通信設定]で[ネットワーク]タブを選択します。

  3. 表示されたIP アドレスをコピーします。

  4. [ リーダへの接続]ペインに戻り、[切断]をクリックします。

  5. [デバイスの追加] をクリックします。

  6. DataMan のIP アドレスをここにペーストします。

名前とIP アドレスフィールドの入力が完了したら、OKをクリックします。ネットワークデバイスリストの、アクセス可能な DataMan デバイスのリスト内に指定のリーダ/ベースステーションが表示され、Ethernetで Setup Tool とリーダ/ベースステーションが接続できるようになります。

[デバイスの追加]機能では、リーダ/ベースステーションの名前はローカルコンピュータに保存されます。 Setup Tool を起動している他のコンピュータには表示されませんのでご注意ください。


エクスポートアイコンの用途:

[Cognexサポートファイルをエクスポート] アイコンにチェックを入れると、Cognexサポートファイルの生成を開始し、設定済みデータログを含んだ.zipファイルが生成されます。この機能は1つ以上のデバイスが選択されている場合に使用できます。

ボタンをクリックするとダイアログボックスがポップアップし、チェックボックスの一覧からサポートの .zipファイルに含めるデータタイプを指定できます。

  1. Cfg

  2. Cdc

  3. 最後の画像

  4. 検出したデバイス

  5. デバイス統計値

  6. メモリ統計値

  7. ユーザコメント (ユーザ自身で記入可能)

サポートファイルを生成するフォルダは [...] アイコンで変更することができます。ファイルの生成後は、保存場所のフォルダを選択して開くことができます。また、デフォルトのメールクライアント (.eml) に添付して送信することもできます。

プロセスの出力は .zipファイルです。ファイル名には、デバイス名と作成日が入っています。Zipファイル内の追加記述子 .xmlには、次のデータが含まれています。

  1. 日付

  2. ディスカバリID

  3. デバイス名

  4. デバイス タイプ

  5. シリアル番号

  6. MAC アドレス

  7. 機能キー

  8. 通信インターフェイス

  9. ファームウェアバージョン

  10. Zipファイル内のファイル一覧


[バーチャルデバイスの追加] ボタンの機能:

この機能では、カスタム設定ファイルまたはデフォルト設定のデバイスのどちらかに基づいて、バーチャルデバイスを作成することができます。これは、接続先のデバイスは不要なまま、Setup Tool内で別のペインを見るときに使用できます。ボタンを押すとウィザードが起動して、バーチャルデバイスの作成をステップごとにガイドします。最初のオプションでは、設定/バックアップファイルを使用するか、工場出荷時のデフォルト設定を使用するかを決めます。

ウィザードが終了すると、検出されたデバイスの一覧に新しいバーチャルデバイスが追加され、アイコンでバーチャルデバイスであることがわかります。作成されたバーチャルデバイスは、ネットワーク上の他のデバイスには見えません。バーチャルデバイスは、複数のSetup Toolのインスタンスの間存続します。

作成されたバーチャルデバイスは通常のデバイスと同様に接続することができますが、設定変更がすべて拒否されたものは接続できず (すべて読み取りのみとなる)、また、バーチャルデバイス上の特徴、機能、アクションは無効です。


バックアップ


[バックアップ] 機能の使い方:

この機能を使うと、右下の [バックアップ] ボタンをクリックする (または [Alt+B] を押す) ことで、1つ以上のリーダの設定およびログを含んだバックアップファイルを生成することができます。この機能は1つ以上のデバイスが選択されている場合に使用できます。

[バックアップフォルダを開く] ボタンをクリックすると、バックアップファイルが置かれているフォルダが開きます。フォルダは、[ホーム] > [オプション] > [バックアップの場所] で設定することができます。

複数のデバイスを選択した場合、それぞれのデバイスのバックアップファイルが作成されます。デバイスファイルはそれぞれ、デバイス名と同じ名前のサブフォルダ内に保存されます。バックアップファイル名には、デバイス名と作成日が入っています。

バックアップファイルは .dmbの拡張子がついた .zipファイルです。ファイルには「config.cdc」、「config.cfg」、「descriptor.xml」が入っています。.xml ファイルには、次のデータが格納されています。

  1. 日付

  2. ディスカバリID

  3. デバイス名

  4. デバイス タイプ

  5. シリアル番号

  6. MAC アドレス

  7. 機能キー

  8. 通信インターフェイス

  9. ファームウェアバージョン

  10. Zipファイル内のファイル一覧


バックアップ機能での、バックアップフォルダの設定:

フォルダは、[ホーム] > [オプション] > [バックアップの場所]で設定することができます。


復元


[復元] 機能の使い方:

[復元] 機能では、バックアップした設定ファイルを1つまたは複数のデバイスに復元することができます。この機能は1つ以上のデバイスを選択し、有効な設定ソースを指定している場合にのみ使用できます。

一番上の [設定ソース] で、Setup Toolが復元に使用するソースを次の中から指定することができます。

  1. 設定ファイル: これを選択すると、Setup Toolは指定した設定ファイルを使用して復元します。[...] をクリックして、使用したいバックアップファイルの保存フォルダを指定します。フォルダの設定方法について詳しくは、「バックアップ」の項を参照してください。

    注意: [復元] ボタンは、互換性のあるデバイスを対象として選択した場合のみ有効になります。

  2. デバイス：このオプションを選択すると、Setup Toolは指定した1デバイスを使って自身の設定を全対象デバイスに復元します。

  3. 最新のバックアップ: このオプションを選択すると、Setup Toolは選択したデバイスの最新のバックアップを検索します。複数のデバイスが選択されているときは、その全デバイスにそれぞれ最新のバックアップが得られます。

  4. 工場出荷時のデフォルト値：Setup Tool が設定を工場出荷時のデフォルト値に戻すオプションです。

ソースと対象デバイスを選択してから、右下の [復元] ボタンをクリックしてください。


[ネットワーク設定の復元] ドロップダウンボタンの機能:

[ネットワーク設定の復元] は、[復元]ボタンと同様に機能しますが、.cfgファイルではなくバックアップフォルダに含まれる .cdcファイルから設定を復元します。このオプションの利用は、.cdcが指定したソース内にあり、対象として選択したデバイスが1つ以上あることが条件です。


ファームウェア更新


リーダのファームウェアを更新する方法:

[システム] [ファームウェアの更新] を選択してから、ファームウェアファイルを選択します。

注: ファームウェアファイルは、圧縮アーカイブで提供されます。ファームウェアは圧縮形式でアップロードする必要があります。 アップロードの前にファームウェアファイルを解凍しないでください。


[ファームウェア更新] 機能の使い方:

選択したデバイス (複数可) を希望のファームウェアバージョンに更新する機能です。デバイスの一覧から、アップデートしたいデバイス (複数可) を選択します。

[...] をクリックしてファームウェアのファイルを参照します。デバイスの一覧からデバイスを1つだけ選択した場合、そのデバイスにに該当するファームウェアのフォルダが開きます。同一のファームウェアデバイスIDを持つ複数のデバイスを選択した場合は、該当するフォルダが開きます。デバイスが選択されていない場合、あるいは、異なるファームウェアデバイスIDを持つ複数のデバイスを選択した場合は、ファームウェアのルートフォルダが開きます。

下部のチェックボックスにチェックが入っている場合、Setup Toolは、[バックアップ] 機能のときと同様に設定ファイルのバックアップを取ります (詳しくは「バックアップ」の項を参照)。

ファームウェアファイルを選択したら、右下の[ファームウェア更新] をクリックします。選択したファームウェアバージョンとデバイスに互換性がある場合のみ、このボタンは操作可能になります。

注意: 連続してデバイスを更新する場合は、ファームウェアの更新をする前にまず手動でリフレッシュをかけてデバイスを検索してください。


設定を比較


設定比較: 全体的なレイアウトと構成

[設定比較]は、デバイスの設定のセット、コピー、比較、復元に使用するテーブルスタイルのツールです。ドキュメントページのメインエリアには、[リーダへの接続] ページで起動する前に選択したデバイスのプロパティがグリッドに表示されています。

Setup Toolドキュメントタイプがそれぞれ自身の接続を使用しています。連続通信の場合は、1度に1つの接続だけ開きます。

行見出しには選択したデバイス名が表示されています。1行目の下にある2つ目の行見出しにはそのデバイスで利用可能な設定が表示されています。その下の行見出し (太字) は、横のアイコンをクリックすると展開したり折りたたんだりすることができます。デバイスが切断されると、行見出しに再接続アイコンが表示されます。

リードセットアップに依存しない設定は第1列 (メインセットアップ) 内にのみ表示されます。


設定比較: コントロール (マウスとキーパッド)

選択:

  • マウス: グリッドのセルをクリックして選択すると、そのデバイスとセットアップが属するセルの行見出しと列見出しがハイライトされます。メニューボタンとリボンメニューの項目は、選択内容に伴って変わります。行見出し上のセルを選択すると、その行のセルがすべて選択されます。

  • キーボード: カーソル操作キーで希望のセルに合わせて選択します。選択時のハイライト対応はマウス操作時と同じです。

値の追加と変更:

  • マウス: エディタが組み込まれているセルは、エディタコントロール (コンボボックス、チェックボックス、数値の上下) で値を入力することができます。カスタムエディタのあるセル ([...]アイコン) では、ポップアップエディタが開いて値を入力することができます。

  • キーボード: エディタが組み込まれたセルでは、[Enter] または [F2] を押すと編集モードが起動します。[Esc] で編集をキャンセル、また2回目に [Enter] を押すと編集を確定します。編集モードでない場合でも、テキスト選択で値を入力することができ、その場合、次の任意のキーを押すと現在の値が上書きされます。

    数値セルでは、テキストエディタが埋め込まれたセルの他に、上下矢印キーで元の値を増減することができます。

    ドロップダウンメニューのあるセルでは、[Enter] キーで編集モードを始めてドロップダウンアイテムが表示されます。上下矢印キーで選択します。2回目に[Enter] を押すと選択した値が適用され、[Esc] で編集を取り消します。

    チェックボックスのあるセルでは、[Space] キーでチェックの有り無しの切り替えをします。

コピーとペースト:

[Ctrl+C] でコピー、[Ctrl+V] でペーストすることができます。コピーとペーストについては、関連するリボンメニューの項目で詳しい説明を見ることができます。


設定比較: リボンメニュー

リボンメニューは、テーブルビュースタイルグリッドの上部にあります。内容や使用可能なアイコンは、グリッド内のセル、行、列の選択によって変わります。メニューはいくつかのグループに分かれています。

  • デバイス：このグループでは、デバイスとその設定ファイルに関するものを設定します。[デバイスの追加...] ボタンでダイアログボックスを開いて、比較対象に1つまたは複数のデバイスを選択して追加します。[設定ファイルの追加...] ボタンはウィザードを開き、設定ファイルまたはバックアップファイル (.dmb、.cdc、.cfg) を参照することができます。デバイスに対応して選択したファイルに必要な情報がすべて揃っていない場合は、欠けているパラメータを設定する必要があり、設定されなければデフォルトのオプションが自動的に選択されます。バーチャルデバイスのデータベースで、パラメータと利用できるオプションのマッチングができない場合も同様です (たとえば、マッチするファームウェアバージョンが見つからない場合)。

    注意: 追加されたバーチャルデバイスは読み取りオンリーです。鍵のアイコンが行見出しに表示されます。

    [デバイスの削除] ボタンをクリックすると、選択中のデバイス (複数可、選択中のセルを含むデバイス) を削除することができます。[デバイスの再起動] は、選択したデバイスを再起動します。[デバイス上で設定を維持] は、選択したデバイスの設定ファイルをフラッシュメモリに保存します。[工場出荷時のデフォルトにリセット] は、選択したデバイスをデフォルトにリセットします。

  • 編集: [コピー] (または [Ctrl+C] キー) で、現在選択したセルの値をコピーすることができます。[ペースト] は、同じ行またはテキストエディタ内のみで使用できます。[値のリセット] は、選択したセルの値をリセットします。

  • ハイライト: このメニューグループのボタンと設定内容は、セルの背景のハイライトに関するオプションです。[デフォルト以外の値] を設定すると、デフォルト以外の値を持つセルがハイライトされます (別のデバイスまたはリードセットアップの列ではそうでない場合があります)。[参照元との差異] を設定すると、参照元のリードセットアップ (およびデバイス) と同じ行にあるセルと異なる値を持つセルがハイライトされます。3つ目の設定が選択されると、テキストボックスで特定したテキストを含むすべての値と見出しがハイライトされます。さらに、そのテキスト自体を別の色でハイライトします。[Enter] を押すと、[ハイライトした列のみ開く] ボタンの機能も適用します。

    [ハイライトした列のみ開く] を有効にすると、ハイライトされているサブノードがないすべてのノードは折りたたまれます。[参照元のリードセットアップを設定] では、[参照元との差異] のハイライトモードで参照元として使用するリードセットアップ (およびデバイス) を特定します。このボタンがアクティブになっているとき、今選択されているセルの列 (リードセットアップ) が参照元のセットアップになります。現在の参照元セットアップは、セットアップ名行見出し内でマーキングされます。

  • フィルタリング: [リードセットアップの設定] に設定すると、リードセットアップに依存する設定のみが表示されます。[グローバル設定] に設定すると、異なるリードセットアップ内で異なる値を持つことのできない設定のみ表示します。[すべての設定] に設定すると、すべての設定を一度に表示します。複数のリードセットアップに値がある場合は、別の列で表示します。

  • その他: [すべての行を開く] を使うと、グリッド内で折りたたまれている行がすべて開きます。[すべての行をたたむ] を使うと、グリッド内の行をすべて折りたたみます。[レイアウトをリセット] は、利用できるスペースをいっぱいに使って列幅を再調整します。利用できるスペースが十分ない場合は、最小の列幅が適用されます。


設定比較: 比較エディタ

比較エディタは、[...] アイコンをクリックすると、設定比較テーブルビュー (サブカテゴリ内) ででスクリプト実行アイテム1つ1つに対して開きます。これが開くと、比較エディタが開いているデバイスのスクリプトソースを見ることができます。

[デフォルト] をクリックすると、スクリプトはそのデバイスのデフォルトのスクリプトに戻ります。[比較] をクリックすると、デフォルトのスクリプトが右側にある2つ目のデバイス上に現れます。ただし、上部のドロップダウンメニューは、左側のスクリプトの比較対象を変更するときに使用します。[更新] ボタンはタブとタブの中間に表示され (赤い回転矢印)、スクリプトのテキストをすべて更新します。

[クローズ] をクリックすると、比較を終了して設定比較内のテーブルビューに戻ります。


画像ウィンドウ


画像ビューアの役割:

デバイスで読み取った画像を見ることができるウィンドウです。

ルーペのアイコンを使用して画像ビューアウィンドウのサイズと画像を合わせたり、画像の縮小/拡大、「ピクセル・トゥ・ピクセル」モードで画像を表示することができます。

その他、ライブ表示モード中の画像に対する焦点フィードバックを有効/無効にする、画像をクリップボードにコピーすることも可能です。

[画像の保存] オプションでは現在の画像だけではなく、すべてのバースト画像も保存でき、[ログ] オプションではすべての読み取り無効画像またはすべてのデコード済み画像をファイルシステムに記録できます。

読み取った画像のヒストグラムと、画像中で選択した箇所の明るさ情報を指定して確認することもできます。これらのタスクは、ウィンドウに表示されたツールバーのボタンで実行してください。


結果履歴


結果履歴の内容:

読み取り操作ごとにデコードした情報を見ることができます。

[一時停止] ボタンを使うとt、結果履歴のツールビューを一時停止または静止させることができ、読み取りに関する特定の情報を見つけることが簡単になります。一時停止を解除するまで、デバイスからのすべての結果は結果履歴ウィンドウに入りません。

履歴は[履歴のクリア]で消去することができます。デコードした一つの文字列もしくは全部の文字列を、[コピー]、[すべてコピー]でエクスポートすることも可能です。

[ログ]にある[コード品質レポートの作成]にチェックを入れると、デコード情報にコードの品質情報を入れることができます。また、[データ妥当性レポートの作成]にチェックを入れるとデータの妥当性情報を入れることができ、[全ての結果をファイルシステムに記録]はローカルのハードドライブにすべての結果履歴項目を保存することができます。その他のオプションは、[ログとレポートの設定]をクリックしてご確認ください。

表のカラムを追加/削除して結果履歴の情報をカスタマイズするには、[カスタマイズ]を選択します。

結果のフィルタリングについては、下の項目を参照してください。


結果フィルタリングの動作:

[結果履歴] ツールビューリボンメニューにある [フィルタ...] ボタンを使って、ビュー内に表示された読み取り結果にフィルタをかけることができます。ボタンをクリックするとフィルタが有効になります。フィルタのパラメータを設定するには、ボタンの右側をクリックしてオプションを開いてください。

注意: フィルタボタンは、オペレーティングシステムが対応している場合のみ表示されます。

フィルタ設定では、標準フィルタとアドバンストフィルタの2つのモードが利用できます。[一般] からドロップダウンメニューを開くと、どちらかのモードを選択することができます。

標準フィルタ使用時は、フィルタリングのカテゴリがドロップダウンウィンドウ内でアクティブ表示されます (結果ステータス、妥当性検査メソッド、妥当性検査のステータス、シンボル)。各カテゴリ内の個々のフィルタは、クリックすると選択できます。フィルタを有効に設定すると、結果履歴で表示されるアイテムに今後すべて、また遡って適用されます。フィルタにかからないアイテムは、フィルタを無効にするまでは結果履歴に入りません。なお標準フィルタでは、1回のトリガシーケンスにおける1件の読み取り成功結果を、トリガシーケンス全体での読み取り成功1回とカウントします。よって、たとえば、標準フィルタはマルチコードを扱うことはできません。マルチコードに対応するにはアドバンストフィルタのスクリプトをお使いください。

アドバンストフィルタ使用時は標準フィルタのカテゴリが非アクティブになり、[アドバンストフィルタの設定] がドロップダウンウィンドウ内でアクティブになります。これをクリックすると新しいウィンドウが開いて、フィルタ表現が編集できるようになります。定義済みのフィルタが事前に有効になっている場合は、生成された表現がここでダイアログ内に表示されます。表現を編集しても、定義済みのフィルタに逆に影響することはありません。

フィルタの編集自体はJavaScript機能です。結果内のデータメンバー使用は、スクリプトベースのフォーマットのときと同じです。表現の結果は下部のウィンドウに表示されます。JavaScriptエラーの場合は、エラーメッセージがテキストウィンドウ内に表示されます。なお、このように類似性はありますが、アドバンストフィルタはデータフォーマッティングスクリプトではなく、Setup Tool上で動く表示フィルタに過ぎません。


シンボルが緑色の線で囲まれているのに、[結果履歴] に何も表示されていない理由：

[データフォーマット]ペインの[標準]のチェックボックスがオンになっていると、出力文字列をカスタマイズする必要が生じます。 この操作が行われていない場合、シンボルがデコードされても結果データが表示されません。


結果によってフロントにアイコンがある理由:

先頭にアイコンのある結果は、その関連画像が保存されています。結果の行をクリックすると、デコードの試行と関連画像が表示されます。


マルチコードの結果を表示する方法：

マルチコードの結果を有効にするには、[シンボル設定]ペインの[マルチコード]タブで、[コード数パラメータ]をデフォルトの1から増やす必要があります。

リーダが同じ画像で複数のシンボルを検知,デコードした場合、それぞれのシンボルが緑色の線で囲まれ、[読み取り結果履歴] にはデコードしたすべてのデータを連結した1つの文字列が表示されます。結果は ASCII コードの CR (<0x0d>)、LF (<0x0a>) を使って分けられます。シンボルごとに結果を分けて表示する時は、連結文字列の横にある "+" マークをクリックします。

個々の結果をクリックすると、画像ビューアには対応するシンボルが強調されて表示されます。


セルフトリガモードで、マルチコード結果の代わりに個々の結果が表示される理由:

セルフトリガモードでは、リーダは [読み取り結果履歴] 内の一列ずつに、個別の結果を返します。他のトリガモードとは反対に、ここでは結果が連結されません。セルフトリガモードではデフォルトで部分結果に対応しています。


コード品質


[コード品質] タブについて:

[コード品質] では、使用するシンボルが、Cognexが対応可能なコード品質基準に定められた品質ガイドラインを満たしているか検証することができます。コードに全体のグレードが与えられるのは、既定のコード品質基準に合うよう選択された、あるいは (デフォルトでは) すべての測定にグレードが設定されてからです。コード品質は機能キーで有効化します。

特定のコード品質基準や測定についてのさらに詳しい情報は、「接続・プログラミングガイド」または関連する ISOスタンダードについての文書を参考にしてください。後者は www.iso.org で入手可能です。


[一般] ペインの使用方法:

[一般] ペインは、様々なコードタイプのコード品質を評価する上で中心的役割を持ち、それには、1Dバーコード、Data Matrix、QRコード、DotCodeがあります。これらのシンボルタイプそれぞれに対し、リーダが読み取ったコードを評価するときに使用するコード品質基準を指定することができます。

必要な測定結果を選択すれば、1Dバーコード および/または2Dコードの適切なサブタブが開き、必要に応じてさらにコード品質評価をカスタマイズすることができます。

コード品質のグレード設定を有効にすると、デバイスは読み取った各シンボルについて品質結果を提供します。そのコード品質は、[コード品質ツールビュー] で有効化されたものです。コード品質評価について詳細を確認する場合は、ビューにある [コード品質] をクリックし、[コード品質ツールビュー] を有効にしておいてください。ツールビュー内に、使用されている各測定のグレードと全体のグレードが表示されます。


[1Dバーコード] タブと[2Dコード] タブの設定項目:

[一般] タブでコードタイプの品質評価に使用するコード品質基準を選択すると、コード品質基準に関する適切なサブタブが [1Dバーコード] タブまたは [2Dコード] タブ内に開き、特定のグレード設定しきい値、全体グレードへの特定グレードの組み込み、レポート内表示をカスタマイズすることができます。

なお、マイクロQRはコード品質グレード設定に対応していません。


[1Dバーコード] タブの設定項目:

デバイスを設定して、[1D読み取り可能性] または1Dバーコード用ISO/IEC 15416 ([コード品質] ペインの [一般] タブ) の算定をした後、[1Dバーコード] タブで該当タイプのコード評価のアスペクトを管理することができます。

[全体の結果の最小合格グレード] ドロップダウンボックスで、既定のコード品質基準に「合格」と認められる最小グレードを指定することができます。

[カスタムしきい値] チェックボックスにチェックを入れると、既定のコード品質基準で元々定義されていたしきい値設定を却下し、カスタマイズすることができます。なお、このチェックボックスのチェックを外してから再度チェックすると、しきい値はリセットされて値はデフォルトになります。これで基準に対応した測定のリストができ、その基準1つ1つに次の設定が備わります。

  • [しきい値] はグレードA、B、C、Dに設定できます。測定値がこのしきい値を超えることで、それぞれのグレードが割り当てられます。グレードFは、値がグレードDのしきい値に達しなかったときに割り当てられます。なお、測定によってはしきい値を持たないものがあり、これはISO基準に従います (それぞれのISO基準について、詳しくは http://www.iso.org を参照してください)。

  • [全体の計算に使用]: これにチェックが入っている場合、測定は全体のグレードの算出に使用されます。

  • [レポートに含む]: これにチエックが入っている場合、測定はコード品質レポートに含まれます。レポートはリーダからFTP通信経由で直接利用できる、あるいはレポートログ経由でSetup Toolから生成されるもので、[結果文字列] タブ内で有効化される結果文字列内にあります。

なお、その特性上 (基準にて定義されているため)、すべての測定ですべてのオプションが利用可能とはなりません (たとえば、ISO基準は測定にグレードを割り当てません)。


「1D読み取り可能性」の評価時に用いる測定の種類:

以下に、1D読み取り可能性の品質評価用に算出される測定の種類を挙げます。コード品質基準とその測定に関するさらに詳しい情報は、「接続・プログラミングガイド」を参照してください。

  • [マルチスキャンの完全性]は、複数回のシンボルスキャンを組み合わせることで得たシンボルのデコーダビリティの測定値です。測定値が高いほど、グレードが高くなります。

  • [エッジのコントラスト 最小] は、2つの隣接したエレメントのバーの反射率とスペースの反射率の差の最低値で、エッジの鮮明さを示します。差が大きいほど、グレードが高くなります。

  • [反射率 最小] は、スキャンの最低反射値で、バーコードの一番暗い部分の測定値です。値が低いほど、グレードが高くなります。

  • [印刷太り]は、意図された幅 (シンボルの仕様で指定)、からバーとスペースの幅がどの程度ずれているかの測定値です。つまり、バーがシンボルのスペースと比較して狭いか広いかを測定します。差が大きいほど、グレードが低くなります。

  • [シンボルのコントラスト]は、1回のスキャンでの最大反射率と最低反射率の値の差です (最も暗いバーと最も明るいスペースの反射率の差)。差が大きいほど、グレードが高くなります。

  • [シングルスキャンの完全性]は、シングルスキャンでのシンボルのデコーダビリティの測定値です。デコーダビリティは、バーコードが複数箇所破損していると低くなります。


「ISO/IEC 15416」の評価時に用いる測定の種類:

以下に、「ISO/IEC 15416」の品質評価用に算出される測定の種類を挙げます。コード品質基準や測定についてのさらに詳しい情報は、「接続・プログラミングガイド」または関連する ISOスタンダードについての文書を参考にしてください。後者は www.iso.org で入手可能です。

  • [デコーダビリティ] は、シンボルが特定する参考デコードアルゴリズムに対する、バーコード印刷の正確性の測定値です。デコーダビリティは、シンボルの中で最も逸脱したエレメントの幅におけるエラーのスケールを示します。逸脱が少ないほど、グレードが高くなります。

  • [欠陥] は、エレメント (バーとスペース) とクワイエットゾーンの不揃いの度合いです。このパラメータは、スキャンの反射率プロファイルにおける不要な凸凹に起因する「ノイズ」の測定に使用します。欠陥が小さいほど、グレードは良くなります。

  • [エッジのコントラスト 最小] は、2つの隣接したエレメントのバーの反射率とスペースの反射率の差の最低値で、エッジの鮮明さを示します。差が大きいほど、グレードが高くなります。

  • [反射率 最小] は、スキャンの最低反射値で、バーコードの一番暗い部分の測定値です。値が低いほど、グレードが高くなります。

  • [変調] は、[シンボルのコントラスト]に対する[エッジのコントラスト 最小]の割合、もしくは、スキャナーが、幅の広いエレメント (バーとスペース) を幅の狭いエレメントと比較して見ることのできる度合いです。[エッジのコントラスト 最小]と[シンボルのコントラスト]の差が大きいほど、グレードは低くなります。

  • [シンボルのコントラスト] は、スキャンで得た最大反射率と最低反射率の値の差です (最も暗いバーと最も明るいスペースの反射率の差)。差が大きいほど、グレードが高くなります。

  • [リファレンスデコード] は、標準的な 2D Data Matrix アルゴリズムが目的のマークを検出、デコードすることができるかどうかを示します。

    この計測結果は A または F いずれかのグレードで表されます。

  • [エッジ検出] は、[スキャンの反射率プロファイル]で検出されるエッジの数です。検出されたエッジが期待エッジ数以上の場合、グレードは4です。それ以外の場合は、グレードは0になります。


[2Dコード] タブの設定項目:

デバイスを設定して、([コード品質] ペインの[一般] タブで) 2Dコード用にISO/IEC 15415、AIM-DPM/ISO/IEC TR29158、SEMI T10、DotCodeの算定をした後、[2Dコード] タブで該当タイプのコードグレード設定のアスペクトを管理することができます。

[全体の結果の最小合格グレード] ドロップダウンボックスでは、既定のコード品質基準に[合格」と認められる最小グレードを指定することができます。

[カスタムしきい値] チェックボックスにチェックを入れると、既定のコード品質基準で元々定義されていたカスタムのしきい値設定を却下し、カスタマイズすることができます。なお、このチェックボックスのチェックを外してから再度チェックすると、しきい値はリセットされて値はデフォルトになります。これらのオプションにより基準に対応した測定のリストができ、その基準1つ1つに次の設定が備わります。

  • [しきい値] はグレードA、B、C、Dに設定できます。測定値がこのしきい値を超えることで、それぞれのグレードが割り当てられます。グレードFは、値がグレードDのしきい値に達しなかったときに割り当てられます。なお、測定によってはしきい値を持たないものがあり (例: SEMI 10)、この場合はISO基準に従います (それぞれのISO基準の文書については、詳しくは http://www.iso.org を参照してください)。

  • [全体の計算に使用]: これにチェックが入っている場合、測定は全体のグレードの算出に使用されます。なお、SEMI T10の測定にはこのオプションがありません。

  • [レポートに含む]: これにチエックが入っている場合、測定はコード品質レポートに含まれます。レポートはリーダからFTP通信経由で直接利用できる、あるいはレポートログ経由でSetup Toolから生成されるもので、[結果文字列] タブ内で有効化される結果文字列内にあります。

なお、その特性上、すべての測定ですべてのオプションが利用可能とはなりません (たとえば、ISO基準は測定にグレードを割り当てません)。

注意: マイクロQRは2Dコード品質グレード設定に対応していません。


「AIM-DPM/ISO/IEC TR29158」の評価時に用いる測定の種類:

以下に、「IAIM-DPM/ISO/IEC TR29158」の品質評価に用いる測定の種類を挙げます。コード品質基準や測定についてのさらに詳しい情報は、「接続・プログラミングガイド」または関連する ISOスタンダードについての文書を参考にしてください。後者は www.iso.org で入手可能です。

  • [コードの歪み度合い] は、それぞれのセルの配置エラーの度合いを表します。シンボルのクロックパターンを使用して測ります。

  • [エラー訂正不使用率] は、エラーの訂正後シンボルに残ったコードワードの割合を示します。

    未使用誤り訂正率 を計算する際には、グローバルしきい値の誤った側にコードワードのセルが1つでもあれば、それがエラーと見なされます。2D Data Matrix のシンボルは冗長コードが組み込まれているか、または重複データのコンテンツが存在します。

    1.00 という値は、どのコードワードにもエラーが存在しなかったことを意味します。

  • [コードの歪み度合い] は、個々のセルの対称性を表します。つまり、シンボルの軸からの逸脱の度合いです。

  • [セルのコントラスト] はシンボルの白セル、黒セルの反射率における差を表し、白セルの平均反射値の割合として表示されます。

    AIM-DPM/ISO/IEC TR 29158を採用している場合は、白セルが最高彩度の 78% の平均反射値となるよう調節する必要があります。

  • [固定パターン損傷] は、マーク内のファインダ、クロック、クワイエットゾーンのパターンに関する品質です。

    リーダはシンボルに含まれる複数のパターンを使用してデータの検出やデコードを行います。リーダはセル変調と同じ方法で、特に反射率の信頼性の計測を使って固定パターン損傷のグレードを生成します。

  • [変調] は、実際のマークに対する読み取り可能性の度合いです。

    グレードは、特定のマークについて白セルと黒セルがどの程度グローバルしきい値に近いかを反映し、いずれか特定のマークの白セルと黒セル間におけるグレーレベルの分岐点を示しています。

    リーダが各セルの白か黒かを分類した確実性が比較的低い場合は、マークの変調グレードが低くなります。結果にはシンボルに組み込まれているエラーの補正量も影響します (大き目のシンボルであれば、エラーの補正量も大きくなります)。例えばセルの大半が境目にありながら実際には変更が生じない場合など、そのマークは変調のグレードが低く、未使用誤り訂正率 が高いという結果になります。

  • [印刷太り]は、意図された幅 (シンボルの仕様で指定)、からバーとスペースの幅がどの程度ずれているかの測定値です。つまり、バーがシンボルのスペースと比較して狭いか広いかを測定します。差が大きいほど、グレードが低くなります。


「ISO/IEC 15415」の評価時に用いる測定の種類:

以下に、「ISO/IEC 15415」の品質評価に用いる測定の種類を挙げます。コード品質基準や測定についてのさらに詳しい情報は、「接続・プログラミングガイド」または関連する ISOスタンダードについての文書を参考にしてください。後者は www.iso.org で入手可能です。

  • [コードの歪み度合い] は、それぞれのセルの配置エラーの度合いを表します。シンボルのクロックパターンを使用して測ります。

  • [エラー訂正不使用率] は、エラーの訂正後シンボルに残ったコードワードの割合を示します。

    未使用誤り訂正率 を計算する際には、グローバルしきい値の誤った側にコードワードのセルが1つでもあれば、それがエラーと見なされます。2D Data Matrix のシンボルは冗長コードが組み込まれているか、または重複データのコンテンツが存在します。

    1.00 という値は、どのコードワードにもエラーが存在しなかったことを意味します。

  • [コードの歪み度合い] は、個々のセルの対称性を表します。つまり、シンボルの軸からの逸脱の度合いです。

  • [シンボルのコントラスト] は、1回のスキャンでの最大反射率と最低反射率の値の差です (最も暗いバーと最も明るいスペースの反射率の差)。差が大きいほど、グレードが高くなります。

  • [極限反射率] では、シンボルの周りの素地に極限反射するものがあって読み取りを阻害するかどうかを、Yes/Noで指定します。

  • [固定パターン損傷] は、マーク内のファインダ、クロック、クワイエットゾーンのパターンに関する品質です。

    リーダはシンボルに含まれる複数のパターンを使用してデータの検出やデコードを行います。リーダはセル変調と同じ方法で、特に反射率の信頼性の計測を使って固定パターン損傷のグレードを生成します。

  • [変調] は、[シンボルのコントラスト]に対する[エッジのコントラスト 最小]の割合、もしくは、スキャナーが、幅の広いエレメント (バーとスペース) を幅の狭いエレメントと比較して見ることのできる度合いです。[エッジのコントラスト 最小]と[シンボルのコントラスト]の差が大きいほど、グレードは低くなります。

  • [印刷太り]は、意図された幅 (シンボルの仕様で指定)、からバーとスペースの幅がどの程度ずれているかの測定値です。つまり、バーがシンボルのスペースと比較して狭いか広いかを測定します。差が大きいほど、グレードが低くなります。


「SEMI T10」の評価時に用いる測定の種類:

SEMI T10の仕様に用いられる測定は次のとおりです。コード品質の仕様や測定についてのさらに詳しい情報は、「接続・プログラミングガイド」または関連するSEMIの仕様についての文書を参考にしてください。後者は www.semi.org で入手可能です。

  • [ファインダーパターンの欠陥] は、ファインダーパターン内の全ピクセルに対する不正なピクセルの割合です。

  • [セルの欠陥] は、グリッド内の全ピクセルに対する不正なピクセルの割合です。

  • [縦方向マーク誤配置] は、最適なData Matrixのセルセンターポイントに対する、Data Matrixのマークの縦方向の平均誤配置です。

  • [横方向マーク誤配置] は、最適なData Matrixのセルセンターポイントに対する、Data Matrixのマークの横方向の平均誤配置です。

  • [Data Matrixセル高さ] は、Matrix内各セルの平均の高さ (ピクセル) です。

  • [Data Matrixセル幅] は、Matrix内各セルの平均の幅 (ピクセル) です。

  • [縦方向マーク伸び率] は、シンボルより大きすぎ、または小さすぎる傾向をトラッキングしたもの、つまり、実際のセルと通常のサイズを縦サイズで比較したものです。

  • [縦方向マーク伸び率] は、シンボルより大きすぎ、または小さすぎる傾向をトラッキングしたもの、つまり、実際のセルと通常のサイズを縦サイズで比較したものです。

  • [シグナル対ノイズ比率] (SNR) は、シンボルのグレースケールの明度におけるずれの最大値に対する、シンボルのコントラストの相対値です。

  • [エラー訂正不使用率] は、エラーの訂正後シンボルに残ったコードワードの割合を示します。

    未使用誤り訂正率 を計算する際には、グローバルしきい値の誤った側にコードワードのセルが1つでもあれば、それがエラーと見なされます。2D Data Matrix のシンボルは冗長コードが組み込まれているか、または重複データのコンテンツが存在します。

    1.00 という値は、どのコードワードにもエラーが存在しなかったことを意味します。

  • [シンボルのコントラスト] は、1回のスキャンでの最大反射率と最低反射率の値の差です (最も暗いバーと最も明るいスペースの反射率の差)。差が大きいほど、グレードが高くなります。


「DotCode」の評価時に用いる測定の種類:

以下に、DotCodeの品質評価用に算出される測定の種類を挙げます。コード品質基準や測定についてのさらに詳しい情報は、「接続・プログラミングガイド」または関連する ISOスタンダードについての文書を参考にしてください。後者は www.iso.org で入手可能です。

  • [コードの歪み度合い] は、それぞれのセルの配置エラーの度合いを表します。シンボルのクロックパターンを使用して測ります。

  • [エラー訂正不使用率] は、エラーの訂正後シンボルに残ったコードワードの割合を示します。

    未使用誤り訂正率 を計算する際には、グローバルしきい値の誤った側にコードワードのセルが1つでもあれば、それがエラーと見なされます。2D Data Matrix のシンボルは冗長コードが組み込まれているか、または重複データのコンテンツが存在します。

    1.00 という値は、どのコードワードにもエラーが存在しなかったことを意味します。

  • [印刷太り]は、意図された幅 (シンボルの仕様で指定)、からバーとスペースの幅がどの程度ずれているかの測定値です。つまり、バーがシンボルのスペースと比較して狭いか広いかを測定します。差が大きいほど、グレードが低くなります。

  • [コードの歪み度合い] は、個々のセルの対称性を表します。つまり、シンボルの軸からの逸脱の度合いです。

  • [シンボルのコントラスト] は、1回のスキャンでの最大反射率と最低反射率の値の差です (最も暗いバーと最も明るいスペースの反射率の差)。差が大きいほど、グレードが高くなります。


[結果文字列] タブの用途:

[コード品質データを結果文字列に追加する] にチェックを入れると、トークンベースのデータフォーマットが可能になり、コード品質結果のデータを結果文字列に追加できるようになります。[全体のグレードを出力] にチェックが入っている場合、結果文字列内の全体のコード品質グレード (選択した測定の最低グレードとして定義される) が出力されます。

[データレポート] では、グレード、値、またはその両方を結果文字列のデータに含むか、もしくは両方とも含まないかが指定できます。[データエレメントのセパレータ] セクションでは、結果文字列に含まれるコード品質の値の前と間にセパレータを入れる設定ができます。

[コード品質レポートのカスタム説明] では、コード品質レポートの見出しにカスタムテキストを追加する設定ができます。このコード品質レポートはリーダからFTP通信経由で直接使用でき、また、レポートログを経由しSetup Toolから生成することもできます。

なお、マルチコードの場合、<PCMデータ> フォーマットのトークンをすべての使用シンボルに追加する必要があります。


チェックボックスに現れる二重の長方形の意味:

大きな枠だけの長方形の中に小さい塗りつぶされた長方形があるマークは、中間チェックステータスといいます。この場合、これはオプションが有効になっていても完全に有効ではないことを示します (ほとんどの場合はトークンが手動で [スクリプト] ペインから取り除かれたことが理由です)。


[FTP転送をレポート] タブの用途:

[FTP転送をレポート] タブでは、コード品質結果をHTMLレポート形式で、FTP経由で送信するよう設定できます。[コード品質レポート転送を有効にする] のチェックボックスをチェックして、デバイスがFTPで結果を送信し、サーバアドレス、ユーザ名、パスワード、サーバタイプを与えてデータ送信先のサーバが認識できるようにしてください。

[待機状態のタイムアウト] は、送信の無い状態でポートが開放されている時間の合計を指します。リーダがFTPサーバに接続されると、リーダは通信が発生するまで接続を維持します。通信状態のタイムアウト時間内に通信が発生しない場合、接続は終了します。FTP転送の頻度が低く接続状態を維持するコストをかけたくない場合に便利です。待機時間のタイムアウトを設定する前に、[待機状態のタイムアウトを有効にする] を確認してください。

[ファイル名] の下の設定で、FTPレポートファイル名生成を管理します。利用できる設定オプションは次のとおりです。

  • [カスタムファイル名] 作成: このオプションは、ファイル名を自分でつけるときに選択します。[ファイル名] で名前を付けることができます。ファイル名フィールドにはファイル名だけではなく、パス名も入れることができます。デリミターとして前にスラッシュを入れてください。例：/images/image追加設定では、ファイル名作成時のナンバリングのルールを設定することができます。[追加上限数] ではファイル名のナンバリングの上限を設定でき、[追加開始値の上限] ではファイル名のナンバリングをどこで開始するか設定できます。

  • [スクリプトが作成したファイル名]: このオプションを有効にしてから青いオプション名をクリックすると、即座に [スクリプト] > [FTP転送] が開き、そこではファイル名作成のためのサンプルスクリプトがすでに提供されています。

  • [サーバが作成したファイル名]: このオプションを選択してからサーバアドレスを与えると、サーバに基づいてレポートファイル名を作成します。FTPサーバの中には、ディスクに保存する前のファイルに固有の名前を付ける機能に対応しているものがあります。


サーバが作成したファイル名の FTP 転送エラー対処法:

FTP サーバが "STOU (重複回避)" コマンドを実行できるかどうか確認します。このコマンドの挙動は STOR に似ていますが、該当するファイルが現在のディレクトリ内で他と重複しないような名前を付けられる点が異なっています。


ファイル転送中に全てのペインが無効になる理由:

画像の FTP 転送の安定性を最優先するため、ペインは無効になります。FTPサーバへの接続速度や転送画像のサイズ・数量によっては、FTP転送に要する時間がかかるためです。


コード品質ツールビュー


[コード品質ツールビュー] の表示項目:

[コード品質ツールビュー] では、コード品質の評価結果を見ることができます。ここに結果が表示される前に、[コード品質] ペイン (機能キー要) でコード品質計算を有効化する必要があります。[結果履歴] ツールビュー上で選択した読み込み1つ1つに対し、事前に設定していたコード品質基準と測定が [コード品質ツールビュー] 内に表示されます。コード品質基準の種類それぞれの上部で、読み取れたコードの全体のグレードを見ることができます。

[プロパティ] には、設定した標準に対する個々の測定が一覧表示されています。[値] は、個々の測定について計算した差異の数値です。[グレード] は、評価に与えられたコード品質のグレードです (また、色付きのアイコンもこの列に表示されます。緑=合格、赤=失敗、黄=しきい値上)。[平均] は、その測定の最近100件の読み取りを基にしたグレードの平均 (+ と - で傾向を示す) です。

コード品質基準、グレード、測定についてさらに詳しい情報は、「接続・プログラミングガイド」または関連する ISOスタンダードの文書を参考にしてください。後者は www.iso.org で入手可能です。


テストモード


テストモードの働き:

作業を中断せずにデバイスのテストやセットアップができるのが、テストモードです。このモードでは全てのトリガソース (SetupTool とトリガボタン)がオフになります。


自動トリガの機能:

自動トリガを使用すると、外部トリガモードの状態でデバイスを内部から(自動で)トリガできるようになります。すなわち外部トリガ(プレゼンテーション、セルフトリガモード以外)を選択していても、テストモードで自動的にリーダのトリガが実行されます。通常のモードに使用するパラメータで、デバイスを操作するかどうかを決めることができるのです。


テストモード中にオフ/制限付きになる機能:

  • 全てのトリガソース (SetupTool とトリガボタン)がオフになります。

  • 全入出力をオフにすることができます。この操作をすると、結果だけがSetupToolに送られてLED/ビープが作動しますが、他の出力は働きません。


許可するトリガの数について:

全てのトリガソースがオフになる前に、許可するトリガの数を決めることができます。


セットアップの読み取り


リードセットアップが適用されるトリガモードの種類:

リードセットアップはシングル、セルフ、バースト、連続の各トリガモードで使用できます。次回のリードセットアップは指定の間隔が経過してから有効になります([照明とイメージャの設定]ペインで指定した時間)。その他のトリガモードでは、複数のセットアップが存在した場合、現在選択中のもの (ステータスバーに表示) だけが採用されます。[シングル] トリガモードはインターバルが無いため、一つの読み取り設定を次も維持する形になります。


セットアップの追加、コピー、削除方法:

リードセットアップを追加するには、[セットアップの追加]ボタンをクリックします。ウィンドウが表示されたら、デフォルトの値を新しいセットアップに指定するか、既存のセットアップから値をコピーするか選んでください。

リードセットアップを削除するには、リードセットアップの列を設定して [セットアップの削除] ボタンをクリックします。

リードセットアップのコピー＆ペーストは、希望の列を選択して [コピー] ボタンをクリックするか、[Ctrl+C] キーを押し、新しいセットアップで上書きしたいセットアップの列に行きます。[ペースト] ボタンをクリックするか、[Ctrl+V] キーを押します。この手順でセットアップの数値が上書きされます。


セットアップ実行順序オプションの機能

複数のセットアップを有効にすると、リーダはすべてのセットアップを実行し、コードを読み取った後で画像の取得を停止します。コードの読み取りにおいて、セットアップの指定で開始するセットアップを指定するか、前回成功したセットアップから開始するかを選択できます。


リードセットアップの並びの変更方法:

[並び順] ボタンをクリックしポップアップウィンドウが開き、そこでリードセットアップの順番を変更します。セットアップの順番はそのとおりとなります。


最上部の[フィルタ]について:

「サイズ」、「バースト」など検索したいパラメータをこのフィールドに入力してから [Enter] を押します。検索にヒットした項目は強調表示され、対象のパラメータノードに限って検索内容が展開表示されます。タイプした内容を消去して [Enter] を押すと、検索を閉じます。


リードセットアップ: 全体的なレイアウトと構成

リードセットアップは、リードセットアップの設定、コピー、比較、復元に使用するテーブルスタイルのツールです。ドキュメントページのメインエリアには、デバイスのプロパティを示すグリッドがあります。

行見出しには選択したデバイス名が表示されています。1行目の下にある2つ目の行見出しにはそのデバイスで利用可能な設定が表示されています。その下の行見出し (太字) は、横のアイコンをクリックすると展開したり折りたたんだりすることができます。デバイスが切断されると、行見出しに再接続アイコンが表示されます。


リードセットアップ: コントロール (マウスとキーパッド)

選択:

  • マウス: グリッドのセルをクリックして選択すると、そのデバイスとセットアップが属するセルの行見出しと列見出しがハイライトされます。メニューボタンとリボンメニューの項目は、選択内容に伴って変わります。行見出し上のセルを選択すると、その行のセルがすべて選択されます。

  • キーボード: カーソル操作キーで希望のセルに合わせて選択します。選択時のハイライト対応はマウス操作時と同じです。

値の追加と変更:

  • マウス: エディタが組み込まれているセルは、エディタコントロール (コンボボックス、チェックボックス、数値の上下) で値を入力することができます。カスタムエディタのあるセル ([...]アイコン) では、ポップアップエディタが開いて値を入力することができます。

  • キーボード: エディタが組み込まれたセルでは、[Enter] または [F2] を押すと編集モードが起動します。[Esc] で編集をキャンセル、また2回目に [Enter] を押すと編集を確定します。編集モードでない場合でも、テキスト選択で値を入力することができ、その場合、次の任意のキーを押すと現在の値が上書きされます。

    数値セルでは、テキストエディタが埋め込まれたセルの他に、上下矢印キーで元の値を増減することができます。

    ドロップダウンメニューのあるセルでは、[Enter] キーで編集モードを始めてドロップダウンアイテムが表示されます。上下矢印キーで選択します。2回目に[Enter] を押すと選択した値が適用され、[Esc] で編集を取り消します。

    チェックボックスのあるセルでは、[Space] キーでチェックの有り無しの切り替えをします。

コピーとペースト:

[Ctrl+C] でコピー、[Ctrl+V] でペーストすることができます。コピーとペーストについては、関連するリボンメニューの項目で詳しい説明を見ることができます。


リードセットアップ: リボンメニュー

リボンメニューは、テーブルビュースタイルグリッドの上部にあります。内容や使用可能なアイコンは、グリッド内のセル、行、列の選択によって変わります。メニューはいくつかのグループに分かれています。

  • テーブルビュー: [セットアップの追加] ボタンは、リードセットアップの追加に使います。ウィンドウが表示されたら、デフォルトの値を新しいセットアップに指定するか、既存のセットアップから値をコピーするか選んでください。[セットアップの削除] ボタンは、リードセットアップを削除するときに使います。[並び順] ボタンをクリックしポップアップウィンドウが開くと、そこでリードセットアップの順番を変更することができます。セットアップの順番はそのとおりとなります。

  • セットアップの開始: 複数のセットアップを有効にすると、リーダはすべてのセットアップを実行し、コードを読み取った後で画像の取得を停止します。コードの読み取りにおいて、セットアップの指定で開始するセットアップを指定するか、前回成功したセットアップから開始するかを選択できます。ここで、ドロップダウンリストからセットアップの開始方法を選択します。あるいは、[前回正常に実行したデコード] を選択して、前回正常にデコードが実行できたセットアップを開始方法として選択できます。

  • 編集: [コピー] (または [Ctrl+C] キー) で、現在選択したセルの値をコピーすることができます。[ペースト] は、同じ行またはテキストエディタ内のみで使用できます。[値のリセット] は、選択したセルの値をリセットします。

  • ハイライト: このメニューグループのボタンと設定内容は、セルの背景のハイライトに関するオプションです。[デフォルト以外の値] を設定すると、デフォルト以外の値を持つセルがハイライトされます (別のデバイスまたはリードセットアップの列ではそうでない場合があります)。[参照元との差異] を設定すると、参照元のリードセットアップ (およびデバイス) と同じ行にあるセルと異なる値を持つセルがハイライトされます。3つ目の設定が選択されると、テキストボックスで特定したテキストを含むすべての値と見出しがハイライトされます。さらに、そのテキスト自体を別の色でハイライトします。[Enter] を押すと、[ハイライトした列のみ開く] ボタンの機能も適用します。

    [ハイライトした列のみ開く] を有効にすると、ハイライトされているサブノードがないすべてのノードは折りたたまれます。[参照元のリードセットアップを設定] では、[参照元との差異] のハイライトモードで参照元として使用するリードセットアップ (およびデバイス) を特定します。このボタンがアクティブになっているとき、今選択されているセルの列 (リードセットアップ) が参照元のセットアップになります。現在の参照元セットアップは、セットアップ名行見出し内でマーキングされます。

  • フィルタリング: [リードセットアップの設定] が自動設定され、リードセットアップに依存する設定のみが表示されます。 [グローバル設定] に設定すると、異なるリードセットアップ内で異なる値を持つことのできない設定のみ表示します。[すべての設定] に設定すると、すべての設定を一度に表示します。複数のリードセットアップに値がある場合は、別の列で表示します。

  • その他: [すべての行を開く] を使うと、グリッド内で折りたたまれている行がすべて開きます。[すべての行をたたむ] を使うと、グリッド内の行をすべて折りたたみます。[レイアウトをリセット] は、利用できるスペースをいっぱいに使って列幅を再調整します。利用できるスペースが十分ない場合は、最小の列幅が適用されます。


デバイスログ


デバイスログについて:

デバイスの赤いLEDが点滅した時に作成されるログです。ログが不要になったら、更新または削除することができます。


画像サイズ


デコーダ ROI設定の目的：

リーダにシンボルの位置決めをして、デコードする画像の領域を厳密に指定する場合の機能です。2つの Data Matrix コードがお互い近接しており、ターゲットの照準線に合わせて確実に目的のコードだけを読み取る必要がある場合に役に立ちます。ROI を縮小しても、必ずしもデコード時間が短縮されたり、画像の転送率が上がるわけではありません。

注意: 画像関連のプロパティの中には(画像サイズやフィルタリングなど)、デバイスが画像を取得中またはデコード中に変更できないものもあります。


イメージャの視野（FoV）を変更する理由：

トリガの種類が[シングル]、[バースト]、[連続] の場合のみ使用できる設定です。 視野を変更してリーダが捉える各画像のサイズを縮小することができます。 メモリ量を増やし、取り込み回数の値を大きく設定。


デコーダ ROI が変更できない理由:

イメージャ の視野 (FOV) のチェックが外れていることを確認してください。イメージャ の視野 (FOV) にチェックが入っていると、FOV の境界以上のデコーダ ROI は設定できません。


デコーダ ROI のサイズがリーダ設定コードに与える影響:

画像サイズ（ROI）を小さくしすぎると、リーダ設定コードの読み取りが困難になります。


焦点の設定


[焦点位置の最適化]の機能:

[焦点位置の最適化] ボタンは、[クイックセットアップ] ペイン上にあるときと同様に、現在の視野に合わせてリキッドレンズの値を最適化します。


[焦点フィードバックの最適化有効]をオンにした場合:

このチェックボックスをオンにすると、焦点フィードバックの最適化が有効になり、画像ディスプレイ上に視覚的なフィードバックが現れます。 (クイックセットアップまたは画像パネルで、色付きの丸が画像上にオーバーレイされます)。赤いゾーンは焦点外、緑のゾーンは焦点が合っています (丸のサイズが大きいほど、フォーカスが広い範囲で合っている)。


[焦点確定モード] の機能:

[焦点確定モード] では、トリガ実行中にリキッドレンズで画像を取得する時間のプレ設定を特定することができます。ノーマルの確定モードは [ノーマル] と設定し、高速でなくともより正確なモードにするときは [正確] と設定します。


リキッドレンズの適正焦点値を決定する手順:

焦点範囲に最も適した値を決めるには、[ライブ表示有効]をクリックしてライブ画像を表示し、スライダを使いながらリアルタイムの画像を調整します。


焦点スイプが選択できない理由:

焦点スイプに対応しているトリガモードは、マニュアルおよび自動読み取りモードに限られています。


[焦点範囲] 設定の使用方法:

[焦点範囲] オプションでは、スライダーやスライダーの端の[+]、[-]ボタン、または値の入力でデバイスの焦点距離を手動変更することができます。焦点範囲は、ミリ単位またはジオプターで与えることができます。どちらかの値が与えられると、Setup Toolが自動的に他方の値を計算して、変更された値に合わせます。

スライダーのオレンジの領域は 拡張領域 (500mm超) を意味し、ジオプターだけが適用可能になります。設定がこの拡張領域に入ると、ミリ単位の値が無効化されます (値が拡張領域外になると再度有効化されます)。

なお、ジオプターは [+] ボタンで小さくなり、[-] ボタンで大きくなるため、注意してください。


リーダまでの距離の計算方法:

距離は、レンズカバーの前面からデコードする画像までをミリ単位で計算します。

計算して設定されると、レンズの前面から画像までのジオプターも計測します。


[モジュラーレンズ設定] について:

ここで、ドロップダウンメニューから、使用するリキッドレンズの種類を選択することができます。


EAN.UCC Compositeのプロパティ


EAN.UCC Composite プロパティ設定の種類:

  • 標準 (リニア、2D): 隣に 2D コンポジットコンポーネント (バッチ番号や期限日などの補助データのエンコード) を伴うリニアコンポーネント (アイテムの主要識別子のエンコード) で構成されます。

  • リニアのみ: アイテムの主要識別子をエンコードするリニアコンポーネントのみで構成されます。


CC-Cについて:

CC-Cは3種あるEAN.UCC 2D コンポジット コンポーネントのうちの1つで、特に最初のコード名にリンケージフラグおよび EAN.UCC 圧縮データを意味する 「920 」が付されたPDF417 シンボルです。


データ妥当性検査


データ妥当性検査の機能:

データ妥当性検査とは、シンボルからエンコードされたデータが特定の企業、工業規格や国際規格において正しいフォーマットでエンコードされていることを確認するためのものです。


データ妥当性検査の結果履歴の表示場所:

データ妥当性の合格/不合格、および出力結果は、[結果履歴] に示されます。結果履歴リスト内の結果には「+」のアイコンが付き、開くと妥当性検査結果の詳細を表示します。過去の妥当性検査結果を、同様の方法で結果履歴内に表示することもできます。


妥当性エラーコードの内容:

データ妥当性検査のエラーには次のようなものがあります。

  • 1: シンボルの識別子エラー。シンボルの識別子は3つの文字列です。データのエンコードに使われるシンボルの種類を識別するだけではなく、データの処理方法も記述されています。この文字列はデコードしたデータに加えて入力という形でツールに渡されることもある他、独立したものとして、またはデータストリームのプレフィックスとして渡されることがあります。

    例: UCC/EAN-128 のシンボルで、シンボルの識別子が]C1。一部のアプリケーションでは、社内/産業コード「Code 128」と「UCC/EAN-128」(EAN.UCCアプリケーション識別子のエンコード) を自動的かつ正確に区別する唯一の方法となります。シンボル識別子がないと、シンボル内のデータ処理方法が分からなくなります。

  • 2: パターンの不一致

  • 3: 無効なデータ限定子 (AI、DI、TEI)

  • 4: 無効なアプリケーション識別子 (AI)

  • 5: 無効なデータ識別子 (DI)

  • 6: 無効なテキスト要素識別子 (TEI)

  • 7: 無効なデータ：型、長さ、値において、データがデータ識別子と合致しない

  • 8: 無効なフィールドセパレータ

  • 9: ISO/IEC 15434 不適合

  • 10: 対応していないフォーマット (DoD UIDアプリケーション、05、06、DD以外のフォーマットなど)。

  • 11: 無効なフォーマットコード： 00～99、DD以外のフォーマットコード。

  • 12: ISO/IEC 15434検証オプションを指定している場合はISO/IEC 15434に非対応でありながら、2Dシンボル以外のストリームをデコード。シンボル識別子が入力としてツールに送られた場合にのみ、レポートされるエラーです。

  • 13: 無効なアプリケーションフィールド：アプリケーションがサポートしていないフィールド。

  • 14: サポート外のアプリケーションフィールド：アプリケーションではサポート外でも、ツールがサポートしているフィールド。

  • 15: 無効なアプリケーションデータ：データがアプリケーションの要件を満たしていない時のエラー。

    例: DoD UIDの適用には次の要件があります：企業のID文字列は、データ限定子を除く13文字以内であること。パーツ、ロット、バッチの文字列は(使用可能な特殊文字も含め)データ限定子を除く32文字であること。シリアル番号の文字列は(使用可能な特殊文字も含め)データ限定子を除く30文字であること。

  • 16: 同一のデータストリームに複数のフォーマットが存在(例：DoD UID適用時において、特定のデータストリーム内に複数のフォーマットが存在してはならない)。

  • 17: フィールドの重複：同一のシンボルに同じデータ限定子が複数存在。DoD UIDなど特定のアプリケーションでは、同じシンボルでフィールドが重複することができません。

  • 18: 無効なUID: 有効な Construct #1 または Construct #2 UID を構成するフィールドが揃っていない。

  • 19: 無効なConstruct #1 UID: 有効な Construct #1 UID を構成するフィールドが揃っていない。

  • 20: 無効なConstruct #2 UID: 有効な Construct #2 UID を構成するフィールドが揃っていない。

  • 21: ISO 15434シンタックスまたはDoD UIDの適合性チェックで、フォーマットトレーラーに不足あり。

  • 22: ISO 15434シンタックスまたはDoD UIDの適合性チェックで、メッセージトレーラーに不足あり。


DoD UID 妥当性検査の機能:

DoD UID 妥当性検査とは、Data Matrix コードにエンコードされたデータが、米国の MIL 規格に拠る 130 のガイドラインに従い正しくエンコードされているかどうかを判断するためのものです。米国国防総省では、調達 または 在庫管理におけるすべての品目 (5000 米ドル以上または独自に連番されたもの) に個別のシリアルナンバー (UII) およびシンタックスのフォーマットを付すよう現在要請しています。DoD UID 妥当性検査では、 コード 内のデータが国防総省のコンストラクトタイプ 1 または 2 に正しく準拠しているかを確認します。さらにDoD UID 妥当性検査機能は 自動的に データ列が ISO 15434 および ISO 15418 に適合しているかどうかも確認します。連結UIIの出力 (またはISO 15434シンタックスやISO 15418のデータ限定子がないUIIの データエレメントのみ) は、[結果タスク] ペイン内の [妥当性検査結果] フィールドにある最初の結果フィールドに表示されます。

コンストラクト 1 に含まれるデータエレメント：メーカの企業識別子EID (CAGE、DUNS、EAN.UCC) と、EID識別子に含まれる部品のシリアル番号。この 企業識別子およびシリアル番号は、会社が DI、AI、TEI フォーマットを採用しているかどうかにより特定のデータ識別子で表示されるものです。

コンストラクト 2 に含まれるデータエレメント：メーカの企業識別子 (EID)、部品の識別子であるメーカの部品番号 (PN)、バッチ番号 (BN)、メーカ固有の部品番号に含まれる 個別の部品用シリアル番号。企業識別子、部品番号/バッチ番号およびシリアル番号は、会社が DI、AI、TEI フォーマットを採用しているかどうかにより特定のデータ識別子で表示されるものです。

注: このオプションが付いていないリーダもあります。


DoD UID 妥当性検査で使用するシンボルについて：

現在、米国国防総省では UID マークの標準規格として Data Matrix コードを指定しています。


想定 EID の機能:

想定 EID は、UII データ文字列にあるメーカの企業識別子を参照するものです。メーカの企業識別子 (EID) は、メーカの CAGE、DUNS、EAN.UCC 各コードまたはそのほかの識別表示を表しています。想定EIDは、DoD固有の値です。


想定 PN の機能:

想定 PN は UII データ文字列にあるメーカの部品番号を参照するものです。想定PNは、DoD固有の値です。


想定 BN の機能:

想定 BN は UII データ文字列にあるメーカのバッチ番号を参照するものです。想定NNは、DoD固有の値です。


ISO 妥当性検査の機能:

ISO 妥当性検査機能は、データ文字列が ISO 15434 シンタックス、または ISO 15434、ISO 15418 に準拠して正しくエンコードされているかどうかを判断するものです。

ISO 15434はデータ文字列がその中にメッセージヘッダ、レコードセパレータ、フォーマットコード （AI、DIまたはTEI 各種用）、グループセパレータ、トランスミッションキャラクタなどの文字列が正しいシンタクスでエンコードされているかを、印刷不能の ASCII 文字の評価も含めて確認します。

ISO 15418 は、個々のデータエレメントに正しいデータ識別子でデータ文字列がエンコードされているかどうかを確認します。メーカが AI、DI、TEI フォーマットを採用しているかどうかによって、各データエレメント（メーカの EIN コード、部品番号、シリアル番号）には、特殊コードまたは「データ識別子」が先行します。

注: このオプションが付いていないリーダもあります。

注意: このオプションではまた、ATA CSDD仕様に規定されているテキスト要素識別子も可能です。


GS1 妥当性検査の機能:

GS1 妥当性検査ではシンボルのシンタックスや動作が GS1 の規格に準拠しているかどうかを検証できます。リーダは、エンコードされたデータが識別子の設定可能な文字列と合致していることを確認します。アプリケーション識別子はすべてサポートされています。

デフォルトでは、リーダは受信したシンボルが次のような欧州製薬業団体連合会 (EFPIA) のフォーマット文字列に準拠しているかどうかを検証します。たとえば次のようなものです。

<AI(01)><AI(10)><AI(17)><AI(21)>

シンボル内のデータにCR/LFを含む不適合があった際も、GS1 妥当性検査を使用すればリーダの送信内容を設定することが可能になります。各シンボルの合否、ならびにシンボル内のアプリケーション識別子とデータエレメントのリストは、詳細結果ペインに表示されます。


文字列の一致検査の機能:

文字列の一致検査では特定の文字列がシンボルからエンコードされた文字列と一致するよう設定できます。特定の文字列と一致する文字列が含まれているシンボルのみ、合格の結果が出ます。


変動する値で文字列を検査する方法：

[数値コンポーネントの増減] を有効にして、検査する文字列の一部が読み取り可能な範囲で上下する数値となるよう設定します。


数値コンポーネントの増減の目的：

この機能は、エンコードしたデータが連番されたり連続の内容に変更が加えられた場所での、文字列の一致検査を実行する際に使用します。例えば雑誌や製本などでは、ページ数の重複やぬけが無いようにバーコードを使用してページ数を監視しますが、このような場面で数値コンポーネントの増減が役に立ちます。


数値コンポーネントの増減の設定方法:

検査する文字列が数字の並び (0～9) であり、読み取り可能な範囲内で増減ができるものであれば、この機能が使用できます。その際、[開始位置] フィールドで増減する数字の開始位置を設定し (最初の文字の位置は0になります)、[長さ] フィールドで変更する文字数を設定します。[長さ] で [自動] を選択すると、リーダは開始位置から連続する数字すべてを増値あるいは減値として扱います。[ステップサイズ] では読み取り間の値の変化を設定できます。数字を減らす場合には、負の数を選択してください。

例えば最初の文字列が ABC_123XXPY であり、読み取り可能な "123" をそれぞれ増加させたい場合には [開始位置] を 4 に設定し、[長さ] を 3 に、[ステップサイズ] を 1 にします。(7 番目の文字が数字ではないことが確実な場合は [長さ] を [自動] にすることもできます)。なお、自動設定では最大数に達しても桁数を増やしませんが、設定した固定桁数でその数をリセットします (たとえば、2桁固定のとき99に達すると、次は100にならず00になります)。

デフォルトでは、こうした文字列が無効または読み取り不可である場合は想定した数値が変化しません。[読み取り無効の更新] および [妥当性検査エラーの更新] のチェックボックスを使用して、コードの読み取りが不可だった場合やコードが無効だった場合、あるいはその両方のケースで目的の値を変更するかどうかを設定することができます。


パターン一致検査の機能:

パターン一致検査では、ユーザが特定の文字列を入力し、データ文字列にそれが存在するかどうかを確認できるようにするものです。例えば、ユーザがメーカの企業識別子を確認するために、DI フォーマットで採用されている 17V というパターンを入力したとします。コードに 17V の文字が存在している場合は、リーダがそのコードの妥当性について合格の信号を送ります。文字が存在しない場合は、リーダは検査失敗の信号を送ります。

パターンの検証には[正規表現]を使用してください。


[妥当性検査失敗時の動作] の目的:

[妥当性検査失敗時の動作] は妥当性検査に失敗があった後で、リーダが何を出力するのかを決める目的があります。ユーザはいくつかのオプションから選択できます。

  1. [妥当性検査失敗]の送信 - コードが妥当性検査に失敗した後で、リーダが[妥当性検査失敗]の文字列を出力します。
  2. [妥当性検査失敗] + デコードされた文字列の送信 - リーダが [妥当性検査失敗] の文字列、続いてデコードされた全文字列を出力します。
  3. 注釈付きのデコード済み文字列の送信 - リーダはエラータイプおよび文字列中のエラー個所に関する情報を付したデコード済み文字列を出力します。
  4. 送信なし - リーダは情報を出力しません。
  5. [妥当性検査失敗] + 引用されたデコード済み文字列の送信 - リーダが [妥当性検査失敗] の文字列、続いて引用されたデコード済み文字列を出力します。


[妥当性検査失敗時の動作] のオプション CR/LF チェックボックスの目的:

CR/LF チェックボックスは、妥当性検査に失敗した出力の後に CR/LF を付加する目的があります。


一致する複数の文字列の検索方法：

パターンの一致検査を使用し、一致する文字列をPerl 形式で入力します。123,456 または 789, といった文字列の例：

^(123ｦ456ｦ789)$


データ妥当性検査が有効な状態での動作:

データ妥当性検査のステータスは、[結果履歴]ペインの[結果ステータス]にリストアップされます。正常に完了した検査は「有効」、エラーがあったものは「無効」と区別されます。たたまれているデータを開くと、結果について詳しい内容を見ることができます。


妥当性検査のエラーにおける「データフォーマット」:

データ妥当性検査でエラーが出た結果には、「基本フォーマット」が適用されません。その代わりに「妥当性検査失敗時の動作」が実行されます。この動作は「スクリプトベースのフォーマット」とは異なります。「スクリプトベースのフォーマット」が有効になると、「妥当性検査失敗時の動作」は実行されずにスクリプトのフォーマットが行われます。この動作は、スクリプトでデータ妥当性検査のステータスを改善する場合などに可能です。


バックアップ設定


自動リーダ設定バックアップの働き:

自動バックアップは、イーサネット環境にあるデバイスに対応しています。このオプションが有効になると、設定がフラッシュメモリに保存されるたびに、外部メモリ(FTPサーバ)にデバイス設定の内容がバックアップされます。Cognex Explorer サービスでバックアップデータの受信ができます。Setup Tool、DMCCコマンド、Cognex Explorerのいずれでも、データの復元は手動で行えます。

設定を保存したいデバイスには、IP アドレスとポート番号を指定してください。もしくは、ユーザー名とパスワードの組み合わせでも構いません。


プリント装置 バックアップコード


[リーダのバックアップコード印刷]の機能:

リーダのバックアップコード(ハードのリセットおよび再起動コード)を印刷し、リーダで読み取りたい場合に使用するオプションです。コードにはネットワーク設定も含まれます。

メモに注意事項を記載しておくと、ページに一緒に印刷されます。[各ページにリセットコードを印刷]を選択すると、リセットコードが個々のページに印刷されます。


設定コードを印刷


[設定コード印刷]の機能:

リーダの設定コード(ハードのリセットおよび再起動コード)を印刷し、設定を読み取りたいリーダに使用するオプションです。

メモに注意事項を記載しておくと、ページに一緒に印刷されます。[各ページにリセットコードを印刷]を選択すると、リセットコードが個々のページに印刷されます。


マスター/スレーブ


マスター/スレーブに対応しているトリガの組合せ:

マスター/スレーブトリガは、マスターとスレーブに規定の組合せのトリガモードを使用しないと正しく動作しません。有効な組み合わせは次の通りです:

  • セルフ/セルフ

  • シングル/バースト、シングル/シングル、バースト/バースト、バースト/シングル

  • マニュアル/連続、マニュアル/マニュアル、連続/連続、連続/マニュアル

  • 自動読み取り/自動読み取り、セルフ/自動読み取り、自動読み取り/セルフ


グループトリガの機能:

同じグループ、同じサブネットのリーダはすべて、アクティブなマスターリーダからの単一トリガソースでトリガされます。


結果の集計と報告方法:

グループトリガが有効になると、マスターリーダはスレーブから結果を集め、スレーブ側はマスターに結果を送信します。


グループ名の追加方法:

  1. [新規追加] ボタンをクリックします。

  2. [新規グループ追加] ダイアログがポップアップで開きます。希望のグループ名を選択して [OK] をクリックします。グループ名は重複しないように注意してください。

  3. グループ名リストに追加した名前が加わり、右側のリストにリーダが表示されていることを確認します。

  4. グループ内で他のユーザに使用されたくないデバイスがあれば、[ネットワーク設定] ペインの [認証] タブでパスワードの設定ができます。


マスター/スレーブグループに属する各リーダのコード結果を、マスターリーダに一括でレポートさせる方法:

マスター/スレーブモードのマスターリーダは、自身のコード結果だけではなく、他のスレーブリーダの結果もまとめてレポートするよう設定することが可能です。手順は、まず[シンボル設定]ペインの[マルチコード]タブで、マスターリーダの[コード数]を決めます。ここでマスター/スレーブグループから受け取りたいコードの合計数を設定してください。

例えば、マスターリーダに一台のスレーブリーダがあり、それぞれ 1 つのコードを読み取るというケースでは、マスターリーダのコード設定が「2」になります。スレーブ側が 3 つのコード、マスター側が 1 つのコードという組み合わせの場合は、マスター側の設定が「4」になります。このようにマスター側に設定するコードの数は、マスター/スレーブグループに属するリーダが読み取るコードの合計数に応じて、1 以上の数で変化します。

ただし、一台のスレーブリーダで複数のコードを読み取る場合は、スレーブ側のマルチコード設定も必ず行う必要があるので、注意してください。スレーブ側の設定がなければ、マスター側に複数のコード読み取り結果が送られません。


設定したグループ名が表示されない理由:

そのグループ名に割り当てられているリーダがないと、表示されません。一台以上のリーダが割り当てられているグループだけが残ります。最後のリーダを別のグループに移動すると、グループが消去されます。


マスターリーダの決定方法:

グループ内のリーダがセルフまたは自動読み取りモードを使用している場合、各リーダが[このグループのリーダ]フィールドにチェックボックスが付きでリスト表示されます。マスターに指定したいリーダのチェックボックスには、チェックを入れてください。

グループ内のリーダが外部トリガまたはソフトウェアトリガ (Setup Tool からのトリガなど) を使用している場合、最初にトリガを受信したリーダがマスターリーダとして機能します。

いずれのトリガモードでも、グループ内の複数のリーダを同時にマスターにすることはできません。


リーダがリストにない場合の対処法:

Setup Tool を実行している PC がリーダとは異なるサブネットを使用していると、リーダはいずれのリストにも表示されません。[デバイスの追加] ボタンでリーダをリストに追加してください。


グループ内の自分のリーダに誰も接続できないようにする方法:

リーダにパスワードを設定します。[ネットワーク設定] ペインを開き、[認証] タブでパスワードを設定してください。


スレーブ応答のタイムアウト機能:

スレーブ応答のタイムアウトは、マスターがスレーブから送られる結果を待つ、待機時間です。単位はミリ秒です。


スレーブリーダのデータフォーマットが反応しない理由:

マスター/スレーブモードでは、スレーブ側のコード結果もマスターリーダの結果として処理されます。そのためマスター側のデータフォーマットが機能するのに対し、スレーブ側のフォーマット設定は無視される結果となります。


マスター/スレーブモードでのトリガ遅延の内容:

通常はマスター/スレーブいずれも同時にトリガされますが、同一グループ内のマスターとスレーブで別々のトリガ遅延を設定することも可能です。マスターリーダのトリガ遅延時間の合計は、そのリーダに設定したトリガ遅延時間と変わりません。スレーブリーダのトリガ遅延時間の合計は、マスター側トリガ遅延時間 + スレーブ側トリガ遅延時間となります。


同一コード再読み取り禁止における、マスター/スレーブ間の関係:

マスターの[デコード設定]で[同一コード再読み取り禁止]を指定した場合にスレーブが同じコードを読み取ると、マスターはすべての結果を考慮して、重複した読み取り結果をソースとは関係なくフィルタリングします。


データログ


データログの機能:

データログでは、読み取りに成功した画像と読み取りに失敗した画像を特定のファイルに自動的に保存することができます。これ以外にも、リーダが読み取るコードの種類を指定したデータ妥当性検査を有効にしていれば、検証したシンボルのデータ検証レポートも保存することが可能です。操作時には必ず Setup Tool に接続し、データログを行うのを忘れないようにしてください。


レポート内のオーバレイ画像を無効にする方法:

レポート内のオーバーレイ画像を無効にするのボックスにチェックを入れると、PDF の読み取り済みコードを囲む緑の四角い枠が表示されなくなります。


デバイス時間の設定


[デバイス時間の設定] で可能な設定内容:

ドロップダウンメニューから、デバイスに設定するタイムゾーンを選択することができます。下のテキストボックスには、設定に対応するPOSIXスタイルのタイムゾーンテキストが表示され、自由に編集できます。

[NTPを有効にする] が選択されている場合、デバイスのタイムゾーン設定は下のボックス (NTP1) で指定したサーバと同期します。2つ目のボックス (NTP2) は、バックアップに使用する、また2サーバ間の接続時間の差の除去にも使用する2番目のNTPサーバを示しています。NTP1を指定しておくだけで十分ですが、2つのサーバを使うと時間、正確さ、信頼性が高まります。なお、タイムゾーンのデータは、スクリプトベースのフォーマットにおけるDateオブジェクトでも使用されます。


画像ツールビュー


画像パネルの役割:

デバイスで読み取った画像を見ることができるペインです。

ルーペのアイコンを使用して画像ツールビューウィンドウのサイズと画像を合わせたり、画像の縮小/拡大、「ピクセル・トゥ・ピクセル」モードで画像を表示することができます。

その他、ライブ表示モード中の画像に対する焦点フィードバックを有効/無効にする、画像をクリップボードにコピーすることも可能です。

[画像の保存] オプションでは現在の画像だけではなく、すべてのバースト画像も保存でき、[ログ] オプションではすべての読み取り無効画像またはすべてのデコード済み画像をファイルシステムに記録できます。[ログとレポートの設定]をクリックすると[Setup Toolオプション]ウィンドウが開きます。このウィンドウは[オプション]メニューの[Setup Tool]ホーム画面でも表示されます。

注意: 表示された画像設定は、画像ペインから (ドラッグ&ドロップで) 取得した最後の画像を保存するときには影響しません。最後の画像は常にフルサイズです (デバイスの最大解像度)。


シンボルの読み取りがうまくいかない場合の対処方法:

  • 『クイックリファレンス』の記載に従い、シンボルサイズと種類によって決められているワークディスタンス内にリーダがあることを確認します。

  • リーダの画像領域内の中心にシンボルがあること、デバイスでトリガを行う際に赤のレーザー照準光の中心にシンボルがあることを確認します。

  • 明るさの最適化をクリックして有効にすると、画像の明るさをリーダが自動調節するようになります。（非対応のトリガモードもあります。また、自動露光には対応していません）

    注意: ROI のサイズが144以下の時は、明るさの最適化ができません。

  • [シンボル設定] をクリックして、使用するシンボルが有効になっていることを確認します。


Setup Tool でトリガを操作する方法:

一番上のツールバーのトリガボタン(閃光のアイコン)をクリックするか、<Ctrl>-Tを押してください。


取得した画像をファイルに保存する方法:

ツールバーの [画像の保存] をクリックします。ドロップダウンメニューの [すべてのバースト画像を保存] をクリックすると、バーストモードで取得したすべての画像が保存されます。

画像を PC にドラッグ＆ドロップすることもできます。画像ビューアにある画像をクリックして、Setup Tool の外にドラッグしてから放します。

最新のものではない（[読み取り結果履歴]からの）画像をドラッグ＆ドロップで保存する場合には、実行時に表示画像設定に設定されていた状態で画像が保存されますのでご注意ください。デフォルトで画質を下げます。表示画像設定で、画像をフルサイズのビットマップ形式に変更できます。


画像をアップロードして、その中のシンボルをデコードする方法:

[シングル]トリガモードでのみ有効な方法です。[アクション]タブの[画像のロード]をクリックしてから、1 つ以上のシンボルを含む 8 ビットのグレースケールファイル (.jpg か .bmp) を圧縮せずにアップロードします。アップロードが完了すると、リーダがただちにその画像に入っているシンボルのデコードを試行します。


転送レートの高い画像がすべて表示されない理由:

1 秒あたり 100 以上のフレームレートで画像の読み取りと転送を実行する設定 (セルフ、自動読み取り、外部トリガの各モード) では、デバイス内部の画像バッファには画像が保存されるものの、Setup Tool が全ての画像を転送できなくなります。[表示画像設定]ペインにある[画像の転送と表示] のチェックを外して、高い転送レートを維持できるようにしてください。


シンボル診断とは (機能キー要):

シンボル診断は、読み取り無効なバーコードについて、デバイスからシンボルを表示することでフィードバックを提供する機能です。このフィードバックを見ることで、バーコードがデコードされなかった理由を調査し対応することができます。フィードバックは、次の問題を知らせます (バーコードの範囲内)。

  • スタートまたはストップのパターン非検出 (コード上にオレンジの矢印)

  • バーコード内の破損/印刷エラー (コード上に赤い長方形)

  • クワイエットゾーンが不十分 (コード上に赤紫色の長方形)

  • チェックサム検証失敗 (コードの周りにブルーの長方形)

グラフィックによる診断のほか、シンボル診断は読み取り無効となった結果それぞれに対して読み取り可能性測定を出し、読み取り無効コードの左上に表示します。測定値によって画像またはプリントの品質を見積もることができ、また既存の設定の改善にも役立ちます。

シンボル診断は、アップロードされたPNG画像 ([アクション] > [画像] > [画像のアップロード]) で、Cognexリーダがサインしたものだけ利用できます (同一のリーダである必要はありません。画像はどのリーダからでも自動的にサインされます)。画像のアップロード後に、画像パネルまたはクイックセットアップの画像ウィンドウでシンボル診断のフィードバックをチェックしてください。

注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


シンボル診断で「オレンジの矢印」が示すエラー:

オレンジの矢印は、スタートまたはストップパターンが検出されなかったことを表します。矢印で示された範囲が、デコード失敗の部分です。失敗の理由は次のとおりです (関連のテックノートで、1つ1つのケースを詳しく説明しています）。

  • スタートまたはストップのパターンの途切れ/破損

  • コードの途切れ (画像の端にあったため、またはコードを遮蔽する物体のため）

  • 低い画像品質 (必ずではないものの、光の質が関係していることがよくある)

  • バーコードラベルの反りや折れ

注意: 注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


シンボル診断での、バーコード内の「赤い長方形」の意味:

赤い長方形は、バーコードに物理的な破損または印刷上の問題があることを示します。長方形内の範囲が、破損またはプリントエラーが検出された部分です。プリントエラーの例には次のようなものがあります (関連のテックノートで、1つ1つのケースを詳しく説明しています）。

  • インクのにじみでバーどうしがつながった場合

  • バーのミスプリントで、デコードの許容範囲を超えてバーが細くなった場合

注意: 注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


シンボル診断での、バーコード内の「赤紫の長方形」の意味:

赤紫の長方形は、クワイエットゾーンの違反を示します。クワイエットゾーンの違反は、バーコード上または両側に十分なスペースがないときに起こります。シンボルによっては、リーダがクワイエットゾーンの違反を許容する場合があります。クワイエットゾーン違反は、一般的にバーコードの周囲の文字や縁取りがバーコードの左右に近すぎるために起こります。また、コードが画像の端にあるため途切れてしまった場合にも起こります (関連のテックノートで、1つ1つのケースを詳しく説明しています)。

注意: 注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


シンボル診断での、バーコードの周囲の「青い長方形」の意味:

青い長方形は、バーコードのチェックサム検証が失敗したことを示します。チェックサム検証失敗の主な理由は次のとおりです (関連のテックノートで、1つ1つのケースを詳しく説明しています）。

  • バーコードの破損 (バーコードは、折れていても並んで置いてあってもすべてのデータ文字をデコードできますが、チェックサム検証にパスしないときは読み取り不能になります)

  • 不正なパターンの印刷 (エンコードされた文字列とプリントされたバーコードパターンが一致しない場合。シンボルがチェックサムに対応している場合は、デコーダがこうしたエラーを示すことがあります)

注意: 注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


シンボル診断でバーコードの範囲の近くにグラフィカルなテキストが表示された場合:

グラフィックによる診断のほか、シンボル診断は読み取り無効となった結果それぞれに対して読み取り可能性測定を出します。「シンボルのコントラスト」や「最小のエッジコントラスト」によって、画像またはプリントの品質を見積もることができ、また既存の設定の改善にも役立ちます。測定は読み取り無効のバーコードの左上に表示されます。

下の表では、表示された測定名とその正式名の間にマッピングを表示しています。読み取り可能性測定を参照して、各測定値について理解してください。

正式名 | 表示名 | 推定グレード
シンボルのコントラスト | C | A,B,C,D,F
最小のエッジコントラスト | EC | A,F
印刷太り | PG | A,F
最小反射率 | MR | A,F

注意: 注意: シンボル診断は、機能キーでだけアクティブにすることができる機能です。


バッファと転送


バッファ済み画像設定の働き:

バッファ済み画像設定では、トリガでリーダが取得した画像や、リーダが撮ったライブ画像のバッファ方法を管理します。この設定を変更することでリーダの性能には影響ありませんが、画質、そしてリーダと Setup Tool 間の転送率にのみ影響が出ます。

  • サイズ: デフォルトでは Setup Tool は取得した画像の全ピクセル中 1/4 を表示するか、ライブ表示中の一部画像を表示します。画像サイズを選択すると、リーダは各画像のサブサンプリングを実行できるようになります。 これによってリーダから Setup Tool への画像の転送速度が大幅に向上しますが、画像の精密さは若干損なわれます。

  • 形式: デフォルトではリーダが取得した画像は .jpeg 形式で保存されます。 このフォーマットは .bmp 形式の画像に比べてそれほどメモリを必要としない上、リーダから Setup Tool への転送が早く行えるためです。

  • 画像品質: .jpeg 形式で画像を扱う場合のみ使用できます。 スライダを使用して内部パラメータを調節することで、リーダから Setup Tool への転送速度を増減し、取得した画像がリーダでスムーズに処理できるようになります。


デコードした画像を見られない理由:

[バッファと転送]機能はデコードを行いません。[バッファ済み画像の設定] ペインで[オーバーレイ画像] を有効にすると、オーバーレイ画像 (SVG形式) が保存されて画像の再生ができるようになります。これらの画像はデコーダ情報の他、デコードしたデータも表示します。


バッファと転送でできること:

[バッファと転送] では、リーダに記録・保存する画像のコントロールや、リーダに保存してある画像の閲覧ができます。また、PC への画像転送も可能です。

  • [画像バッファ] タブはリーダに保存する画像を管理します。

  • [画像をPCに転送] タブはリーダから PC への画像の転送方法を管理します。

  • [画像をFTPに転送] タブはリーダから PC への画像の自動転送を設定します。

  • デコード結果を FTP サーバに送信するために必要となるIP アドレスとポート番号を用いて、[結果をFTPに転送]タブでリーダの設定を行ってください。


FTP サーバへのデコード結果の送信について:

デコード結果をFTPサーバに送信するために必要となるIPアドレスとポート番号を用いて、[画像FTP転送] タブでリーダの設定を行ってください。このタブではユーザ名とパスワード設定の他、結果を保存するファイル名の設定もできます。


ルートディレクトリとは別のディレクトリにFTPデータを保存する方法:

ファイル名フィールドにはファイル名だけではなく、パス名も入れることができます。デリミターとして前にスラッシュを入れてください。例：/images/image


FTPディレクトリで画像と結果が見られない場合の対処法:

ファイルを作成する許可を得ているかどうかを確認してください。追加フィールドにチェックが入っていたら、FTPユーザが追加許可を得ているかどうかを確認します（書き込み許可とは異なります）。併せて、FTPユーザは必ずFTPサーバのIPアドレスに誤りがないことを再確認してください。


[バッファする結果の種類] リストの機能:

[バッファする結果の種類] リストではリーダ内部でバッファする画像の種類を選べます。選択肢の内容は、デコード情報を含む (読み取り有効)、デコード情報なし (読み取り無効)、両方 (すべて)、もしくは妥当性検査エラー (デコードは正常に完了したが、検査エラーの発生した画像のみ) です。

ただし、バーストおよび連続モードでは、シーケンスの選択（読み取り/読み取り無効）が、シーケンスすべての画像に適用されます。バーストモードでのシーケンス全体とは、バーストカウントに指定された取得画像のすべてを指します。連続モードでは、トリガ信号が有効な間に取得した画像を指します。つまり、トリガ信号が終了するまですべての画像が保存されることになります。


[結果としてバッファする画像] オプションの機能:

結果としてバッファする画像を選択できる機能です。[読み取り結果と同じ]は正常に読み取った画像に適用され、検出したコードのある画像だけをリーダに保存します。


[結果限度あたりの画像数]の機能:

結果ごとに何枚の画像を保存するかを設定できます。この数字は画像バッファの最大サイズより大きくすることはできません。

マルチコードにより一回のトリガで複数の画像を取得する場合は、読み取り結果が良好な画像が複数あるかもしれないため、画像を制限する必要が生じるケースがあります。このような制限設定は、読み取り無効画像や複数のデコード不能画像にも利用できます。


画像バッファの最大サイズとは:

画像バッファの最大サイズとはリーダがバッファする画像の最大数です。大きさはリーダに搭載されたメモリによって限られていますが、希望数を超えた画像が FTP サーバや PC に保存されるのを防ぐために、限度数よりも少ない数を設定することができます。

バーストモードではバースト長さと画像バッファの最大サイズの合計が、リーダの画像バッファの最大数と同じでなくてはなりません。バースト長さが延びて、画像バッファの最大サイズとの合計がリーダの画像バッファの最大数を超えた場合、Setup Tool は自動的に画像バッファの最大サイズを減らします。

デバイスに保存する画像と画像処理のバッファは共有されるため、連続の撮影でトリガレートが上昇することを踏まえて、シングルショットモードで保存する画像の数も減らしておくことをお勧めします。この措置で、通常の処理には十分なバッファ領域をデバイスに残しておくことができます。


[読み取り無効画像]モードの設定項目:

読み取り無効画像の数はトリガごとに 1 枚の画像だけを保存します。画像は選択可能です。[読み取り無効画像期間]では N 番目の読み取り無効画像を保存します。判断はトリガモードで決定します。例えばバーストトリガモードで長さ 5、期間を 3 と設定した場合、最初は 1 枚目と 4 枚目の画像が保存されますが、二回目のバーストトリガでは 2 番目と 5 番目が保存されます。


読み取り無効画像期間について:

読み取り無効画像期間とは、読み取り無効画像がバッファされるレートを指します。値が 1 に設定されている場合は、すべての読み取り無効画像がバッファされます。値に整数 N（N は 1 以上であること）を設定すると、N番目の画像ごとにバッファされます。

読み取り無効画像期間で 1 以上の値を設定すれば、バッファされる読み取り無効画像の数を減らせるようになります。

[バッファする結果の種類] が [読み取り] に設定されている場合は、読み取った画像をバッファする時にシングルトリガに関連付けられたすべての画像は読み取り済みとしてマークされるため、前回取得した読み取り無効画像もバッファされる可能性があります。そのため、読み取り無効画像期間は画像のバッファにも影響を与えます。読み取り無効画像時間を設定することで、バッファする画像の数を減らすことができます。


読み取り無効画像の数について:

バーストトリガで結果的に読み取り無効となった、N 枚目の画像を保存できるオプションです。そのため、トリガモードがバースト以外だったり、バースト長さが N 以下に設定されている場合は、全くバッファされないことになります。


読み取り無効画像の割合について:

読み取り無効画像の割合は、読み取りが無効となった画像の割合(枚数)をカウントする頻度を示します。ここでは枚数と時間単位を指定することが可能です。このカウントと時間が、読み取り不良の持続割合を決定します。バーストは時間あたりのピーク率を決定します。


[バッファの上書きを許可] とは:

[バッファの上書きを許可] はバッファに保存された画像を古いものから上書きしていくか、バッファがいっぱいになった時点でバッファを停止するかを決める機能です。


転送後に確実に画像を削除する方法:

転送後に削除チェックボックスにチェックを入れると、転送後の画像は削除されます。この機能はFTP画像転送やリーダからPCへの転送を含む、いずれの転送モードにも使用できます。


[今すぐ転送]ボタンが有効にならない時の対処法:

リーダでバッファした画像があれば、まず最初に画像を保存するフォルダを選択してください。転送が可能になるまで記録作業は行えません。


[転送フォルダの削除]ボタンとスライドの消去について:

[転送フォルダの削除]ボタンを押すと、フォルダ内の全画像が削除されます。同じ画像がスライド表示されていれば、そのスライドも消去されます。


指定のフォルダにファイルが存在していた場合の上書き処理について:

指定したフォルダに [Index] 形式に該当するファイルが存在していると、開始インデックスは重複しないよう自動的に増加してから転送を開始します。画像ファイルは上書きされません。


個々の画像を見る方法:

画像一つ一つを見ることは可能ですが、画像の保存先となっているフォルダすべてを選択する必要があります。指定のフォルダ内の画像が表示されたら、進む/戻るボタンで表示を切替えてください。


タスクペインを閉じた後も、最初から画像を見直さずに済むようにするには:

[バッファと転送]ペインの[一時停止]ボタンをクリックすると、再生を一時停止した状態で終えます。


FTP サーバへの画像の転送方法:

[FTP] タブで画像を FTP サーバに送信するための設定が行えます。このタブではサーバの IP アドレスとポート番号の設定以外にも、ユーザ名とパスワードの組み合わせを設定できます。リーダが高頻度で処理を行っていて画像転送の時間が取れない場合などは、FTP を使った画像送信は失敗する可能性もありますのでご注意ください。また、ワイヤレスリンクを使った転送では通常のネットワーク通信よりも時間がかかることがあります。このような時は解像度を落とすか、画像を圧縮することをお勧めします。

ファイル名オプションでは画像の保存先となるファイルを指定できます。ファイル名フィールドには、 FTP サーバのルートディレクトリに関連付けたパスを指定することができます (例: /failed_images/image など)。ファイル名の後に付く拡張子 (.jpg か .bmp) は、[バッファ済画像の設定]ペインで設定したフォーマットに合わせます。リーダ本体でディレクトリを作成することはできません。必ずアクセス可能なディレクトリを用意しておいてください。

追加上限数は、ファイル名の末尾に付加される通し番号(インクリメント値)の上限を表示します。0の場合、通し番号は付加されず、同じ名前となるためファイル名は毎回上書きされることになります。

[スクリプト]ペインの[FTPストレージ]タブに、[スクリプトが作成したファイル名]の名前を入力することができます。

サーバが作成したファイル名オプションは FTP サーバのルートディレクトリに表示されている空白パスで開始します。


[画像をFTPに転送]の実行時間が処理できない場合の対処方法:

以下の条件を満たしているか確認してください。

  • サーバアドレス、ユーザ名、パスワードに誤りがないこと。

  • 転送モードが [FTP ランタイム] に設定されている。

  • バッファタブに [バッファする結果の種類] があり、[なし] 以外が設定されている。

  • 使用する FTP が画像転送に対応している。


[スクリプトが作成したファイル名]について:

[スクリプト]ペインの[FTPストレージ]タブから、FTP転送用にスクリプトが作成するファイル名を付けることができます。


[サーバが作成したファイル名]について:

FTP サーバの中には、ディスクに保存する前のファイルに固有の名前を付ける機能に対応しているものがあります。


転送モードの種類:

指示転送モードは Setup Tool の [今すぐ転送] をクリックするか、DMCC トリガを送信した時に画像を転送します。FTP ランタイム転送モードは接続が確立された時点で FTP サーバに画像を自動転送します。


ファイル転送中に全てのペインが無効になる理由:

画像の FTP 転送の安定性を最優先するため、ペインは無効になります。FTP サーバへの接続速度や転送画像のサイズ・数量によって、FTP 転送に要する時間は異なってきます。


1 秒あたりのフレーム転送レートが高い状態で、外部 FTP サーバにランタイム画像転送ができない場合の対処法:

1 秒あたり 100 以上のフレームレートで画像の読み取りと転送を実行する設定 (セルフ、自動読み取り、外部トリガの各モード) では、デバイス内部の画像バッファに画像が保存され、外部 FTP への転送はできなくなります。

[バッファの上書きを許可] にチェックを入れると、画像は上書きをされます。このチェックを外すと、バッファに空き容量ができるまで新しい画像はバッファされません。


三菱GOTのサーバ設定について:

待機状態のタイムアウト(周期的なNoopの追加)と、待機状態の制御接続を終了するためのオプション的タイムアウトを許可することで、三菱GOTと他のFTPサーバのFTP接続を強化する設定です。また、三菱GOTの書き込みモードにも対応するようになります。


SFTPのサーバ設定について:

この設定では、暗号化によりファイルを送受信するSFTP (Secure File Transfer Protocol) が使用できます。


待機状態のタイムアウトについて:

[待機状態のタイムアウト] は、送信の無い状態でポートが開放されている時間の合計を指します。リーダがFTPサーバに接続されると、リーダは通信が発生するまで接続を維持します。

通信状態のタイムアウト時間内に通信が発生しない場合、接続は終了します。FTP転送の頻度が低く接続状態を維持するコストをかけたくない場合に便利です。

待機時間のタイムアウトを設定する前に、[待機状態のタイムアウトを有効にする]を確認してください。


プロセスモニタ


プロセスモニタの使用方法:

[読み取り統計値を表示]をクリックすると、統計値を見ることができます。保存してある読み取り結果の統計値と画像を破棄する場合は、[統計値の消去] ボタンをクリックしてください。注意：このオプションはEthernetリーダ限定です。

選択したリーダの設定オプションを見るには、[設定モードに切り替え]を使用します。


保存した画像の表示方法:

[設定モードに切り替え] をクリックし、[画像バッファ] ペインにリーダの画像を保存するよう設定します。画像は[画像のバッファと転送]にある[オプション]＞[バッファと転送]に指定したディレクトリに保存されます。


読み取り結果をファイルに保存する方法：

<ctrl>-C で、[読み取り結果ヒストリ]から読み取り結果ををコピーします。 その後、保存したいアプリケーションに貼り付けてください。


オプション


オプションページの設定:

DataMan Setup Toolの [オプション] ペインでは、目的に応じてアプリケーションの設定ができます。


コードページの[コード表示]設定：

読み取った文字列のエンコードに従って、表示方法を設定することができます。


カラースキームの設定:

お使いのDataMan Setup Toolのコードスキームを、このフィールドで選択します。


[設定のリセット] ボックスの設定:

このボックスではデフォルトにリセットしたいカテゴリ(レイアウト、通信、言語、コードページ、データログ)を選択できます。


[バックアップの場所] の設定項目:

[バックアップ] 機能でバックアップファイルを保存するときのフォルダを指定することができます。


[データログ]タブの設定項目:

結果コード、デコードした画像、読み取り無効画像、レポートを保存するフォルダを設定できます。また、データ記録の際のファイル名と拡張子の変更についても設定できます。


データ妥当性レポートを作成するには:

[結果履歴] ペイン内の [ログ] で [データ妥当性レポートの作成] を選択します。


[画像のバッファと転送]でできること:

読み取った画像を保存するフォルダを設定できます。


レポート機能を有効にするには:

[レポート] フィールドに入力してから、[データ妥当性検査]をオンにしてレポートを作成します。


結果コード、デコードした画像、読み取り無効画像が該当するディレクトリにない場合の対処法:

該当のログの、ドロップダウンリストボックスでこれらを有効にしてください。


テーブルビュー


ハイライト表示された値:

ハイライトされた値は、最初は非デフォルトの値を示しています。ハイライトのルールは、リボンメニューの [ハイライト] セクションで変更することができます。詳しくは、[テーブルビュー: リボンメニュー」を参照してください。


太字で表示された値:

太字で表示された値は、展開が可能でサブバリューを持ったものです。


可能な値を知る方法:

値の上にマウスを動かすと、吹き出しに表示された最小値、最大値、デフォルト値（当てはまる場合）を見ることができます。


テーブルビュー: 全体的なレイアウトと構成

テーブルビューは、グリッドスタイルをした視覚的なツールです。

行見出しにはデバイス名が表示されています。1行目の下にある2つ目の行見出しにはそのデバイスで利用可能な設定が表示されています。その下の行見出し (太字) は、横のアイコンをクリックすると展開したり折りたたんだりすることができます。デバイスが切断されると、行見出しに再接続アイコンが表示されます。

リードセットアップに依存しない設定は第1列 (メインセットアップ) 内にのみ表示されます。


テーブルビュー: コントロール (マウスとキーパッド)

選択:

  • マウス: グリッドのセルをクリックして選択すると、そのデバイスとセットアップが属するセルの行見出しと列見出しがハイライトされます。メニューボタンとリボンメニューの項目は、選択内容に伴って変わります。行見出し上のセルを選択すると、その行のセルがすべて選択されます。

  • キーボード: カーソル操作キーで希望のセルに合わせて選択します。選択時のハイライト対応はマウス操作時と同じです。

値の追加と変更:

  • マウス: エディタが組み込まれているセルは、エディタコントロール (コンボボックス、チェックボックス、数値の上下) で値を入力することができます。カスタムエディタのあるセル ([...]アイコン) では、ポップアップエディタが開いて値を入力することができます。

  • キーボード: エディタが組み込まれたセルでは、[Enter] または [F2] を押すと編集モードが起動します。[Esc] で編集をキャンセル、また2回目に [Enter] を押すと編集を確定します。編集モードでない場合でも、テキスト選択で値を入力することができ、その場合、次の任意のキーを押すと現在の値が上書きされます。

    数値セルでは、テキストエディタが埋め込まれたセルの他に、上下矢印キーで元の値を増減することができます。

    ドロップダウンメニューのあるセルでは、[Enter] キーで編集モードを始めてドロップダウンアイテムが表示されます。上下矢印キーで選択します。2回目に[Enter] を押すと選択した値が適用され、[Esc] で編集を取り消します。

    チェックボックスのあるセルでは、[Space] キーでチェックの有り無しの切り替えをします。

コピーとペースト:

[Ctrl+C] でコピー、[Ctrl+V] でペーストすることができます。コピーとペーストについては、関連するリボンメニューの項目で詳しい説明を見ることができます。


テーブルビュー: リボンメニュー

リボンメニューは、テーブルビューグリッドの上部にあります。内容や使用可能なアイコンは、グリッド内のセル、行、列の選択によって変わります。メニューはいくつかのグループに分かれています。

  • テーブルビュー: [セットアップの追加] ボタンで、リードセットアップを選択したデバイスに追加またはコピーすることができます。[セットアップの削除] ボタンは、リードセットアップを削除するときに使います。[並び順] ボタンは、デバイスが切り替えるリードセットアップの順番を変更することができます。

  • 編集: [コピー] (または [Ctrl+C] キー) で、現在選択したセルの値をコピーすることができます。[ペースト] は、同一の行内またはテキストエディタ内だけで使用することができます。[値のリセット] では、選択したセルの値をリセットすることができます。

  • ハイライト: このメニューグループのボタンと設定内容は、セルの背景のハイライトに関するオプションです。[デフォルト以外の値] を設定すると、デフォルト以外の値を持つセルがハイライトされます (別のデバイスまたはリードセットアップの列ではそうでない場合があります)。[参照元との差異] を設定すると、参照元のリードセットアップ (およびデバイス) と同じ行にあるセルと異なる値を持つセルがハイライトされます。3つ目の設定が選択されると、テキストボックスで特定したテキストを含むすべての値と見出しがハイライトされます。さらに、そのテキスト自体を別の色でハイライトします。[Enter] を押すと、[ハイライトした列のみ開く] ボタンの機能も適用します。

    [ハイライトした列のみ開く] を有効にすると、ハイライトされているサブノードがないすべてのノードは折りたたまれます。[参照元のリードセットアップを設定] では、[参照元との差異] のハイライトモードで参照元として使用するリードセットアップ (およびデバイス) を特定します。このボタンがアクティブになっているとき、今選択されているセルの列 (リードセットアップ) が参照元のセットアップになります。現在の参照元セットアップは、セットアップ名行見出し内でマーキングされます。

  • フィルタリング: [グローバル設定] はデフォルト設定です。異なるリードセットアップ内で異なる値を持つことのできない設定のみ表示します。[リードセットアップの設定] に設定すると、リードセットアップに依存する設定のみが表示されます。[すべての設定] に設定すると、すべての設定を一度に表示します。複数のリードセットアップに値がある場合は、別の列で表示します。

  • その他: [すべての行を開く] を使うと、グリッド内で折りたたまれている行がすべて開きます。[すべての行をたたむ] を使うと、グリッド内の行をすべて折りたたみます。[レイアウトをリセット] は、利用できるスペースをいっぱいに使って列幅を再調整します。利用できるスペースが十分ない場合は、最小の列幅が適用されます。


法的情報


著作権

Cognex Corporation は、同社が提供していない装置における同社製ソフトウェアの使用または信頼性についていかなる責任も負いません。Cognex Corporation は、本書で記述されているソフトウェアの内容、商品価値および特定目的に対する責任につき、明示または黙示にかかわらずいかなる保証も行いません。

本書の内容は、予告なしに変更することがあります。 内容の変更について、Cognex Corporation はいかなる責任も負いません。本書あるいは関連ソフトウェアにおける誤りについて、Cognex Corporation はいかなる責任も負いません。

Copyright ｩ 2018 Cognex Corporation All Rights Reserved

本書のいかなる部分も Cognex Corporation の書面による許可なく複製、他のメディアに送信すること、および他の言語に翻訳することを禁じます。

本書で説明しているハードウェアおよびソフトウェアの一部については、Cognex ウェブサイト http://www.cognex.com/patents.asp に示す 1 つまたは複数の米国特許で保護されています。その他の米国および、他国の特許については申請中です。


ライセンスソフトウェア

SpiderMonkey

このソフトウェアには Mozilla Public License, v. 2.0 の条件が適用されます。MPL の入手先： http://mozilla.org/MPL/2.0/

SpiderMonkey のソースコードをご希望のお客様は、Cognex テクニカルサポート (Eメール: <spidermonkey@cognex.com>) までお問い合わせください。

PCRE ライセンス

PCRE は、正規表現をサポートする関数ライブラリで、その構文とセマンティックスは、Perl 5 言語に可能な限り近似しています。

PCRE のリリース 5 は、下記に規定する "BSD" ライセンスの条項に基づいて配布されます。"doc" ディレクトリに入っている PCRE 関連文書も、同ソフトウェアと同じ条項に従って配布されます。

著作者: Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, England.電話: +44 1223 334714

Copyright (c) 1997-2004 University of Cambridge All rights reserved.

ソースおよびバイナリ形式での再配布および使用は、変更のあるなしにかかわらず、次の条件を満たす場合に限り許可されます。

  • ソースコードの再配布では、上記の著作権告知、この条件リストおよび下記の免責条項を保持する必要があります。
  • バイナリ形式の再配布においては、上記の著作権告知、この条件リストおよび下記の免責条項を配布される文書その他に記載する必要があります。
  • 特定の書面による事前の許可なく、本ソフトウェアから派生する製品の推奨または奨励のため、Cambridge 大学の名前も寄稿者の名前も、使用することを禁じます。

本ソフトウェアはその著作権者および寄稿者によって、「現状有姿」で提供され、商品性および特定目的に対する適合性を含みそれに限定されない、一切の明示的または黙示的保証を行いません。本ソフトウェアの使用によってあらゆるかたちで生じる、直接損害、間接損害、付随的損害、特殊損害、派生的または結果的損害 (代替商品またはサービスの調達、使用機会またはデータの喪失、逸失利益、または事業の中断を含みそれらに限定されない) に対して、著作権者または寄稿者は一切責任を負いません。 それらが契約責任であれ厳格責任であれ、または不法行為責任 (過失責任その他を含む) であれ、いかなる責任理由によっても同様であり、またたとえ、それら損害の可能性について事前に知らされていたとしても同様です。

以上

JPEG ソフトウェア

本ソフトウェアの一部は、Independent JPEG Group の成果に基づいています。

zlib 圧縮ライブラリ

本ソフトウェアの一部は、Jean-loup Gailly および Mark Adler の成果に基づいています。

Parsifal XML パーサー

Copyright (c) 2002-2005 Toni Uusitalo パブリックドメイン 2002-11-15 http://www.saunalahti.fi/~samiuus/toni/xmlproc/ に公開

Parsifal は商業使用も非商業使用も再配布も自由ですが、著作者の著作権および免責条項を無修正で保持することが条件です。また、個人使用のために Parsifal を修正することも、修正した Parsifal を再配布することもできます。 ただしその修正を明確に文書に記していることが条件です。

免責条項

本プログラムは、有用性を期待して配布されますが、特定目的に対する商品性または適合性の黙示的な保証を含む、一切の保証はありません。ご使用は、リスクが自己責任であることに同意されたとみなされます。


特許情報

本製品は下記の 1 つまたは複数の米国特許ならびに米国出願、海外特許で保護されています。現時点を経過して発行された関連特許については、http://www.cognex.com/patents に掲示します。

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, EP1687752