DataMan 8000 Series Base Station : Questions - Réponses


Connexion au lecteur


Comment connecter la base du lecteur à l'outil de configuration ?

Procédez comme suit pour connecter votre lecteur DataMan à l'outil de configuration :

  1. imprimez une copie du document Codes de configuration du lecteur qui concerne votre base du lecteur en particulier, disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration.

  2. Connectez le câblage nécessaire entre votre station de base et le PC exécutant l'outil de configuration. Pour obtenir des détails, reportez-vous à la documentation papier de l'Aide-mémoire du DataMan 8xx0.

  3. Numérisez le symbole du code des Paramètres de communication ou du Type de connexion souhaité, comme par exemple USB.

  4. Cliquez sur Actualiser dans l'outil de configuration.

  5. Sélectionnez le Port COM ou le Périphérique réseau indiquant une connexion à votre lecteur.

  6. Cliquez sur Connecter.


Quel port utiliser pour une connexion USB ?

Si vous connectez le lecteur ou la station de base à l'aide du port USB, veillez à bien lire le code de configuration USB-COM/RS-232 à partir du document Codes de configuration du lecteur. Cliquez ensuite sur Actualiser et sélectionnez le port connecté au lecteur.

Remarque : lorsque vous cliquez sur Actualiser, une chaîne de requête est envoyée à tous les ports COM et à travers le sous-réseau Ethernet. Un lecteur sans fil DM7550 et un lecteur sans fil DM8000 doivent être activés pour répondre à la requête. Appuyez sur le déclencheur du lecteur pour l'activer.


Je ne parviens toujours pas à connecter mon lecteur ou ma station de base : puis-je le réinitialiser ?

Pour la station de base DataMan 8000 :

A l'aide du lecteur sans fil associé à votre station de base, numérisez la commande Réinitialiser la base du lecteur avec les paramètres d'usine (pour DM8000 Base) pour reconfigurer la station de base avec les réglages d'usine.

Pour les lecteurs DataMan Séries 503 et 8000 :

Numérisez la commande Redémarrer le scanner imprimée au dos de l'Aide-mémoire pour effectuer une réinitialisation logicielle. A la réinitialisation, le lecteur s'arrête et redémarre sans que la mémoire non volatile du lecteur ne soit effacée.

Si cela ne fonctionne pas, numérisez la commande Réinitialiser le scanner avec les paramètres d'usine pour reconfigurer le lecteur sur ses réglages d'usine.

Si cela ne fonctionne pas et que vous utilisez un lecteur connecté à l'aide d'un câble, débranchez l'alimentation du lecteur (sauf pour le DataMan 9500). Tout en maintenant le déclencheur enfoncé, rebranchez l'alimentation du lecteur. Maintenez le déclencheur enfoncé pendant au moins 6 secondes jusqu'à entendre un double signal sonore (bip). Les voyants du lecteur clignotent de différentes couleurs.

Si cela ne fonctionne pas et que vous utilisez un lecteur DataMan 8000 sans fil, retirez la batterie du lecteur et placez-le sur la station de base du lecteur. Tout en maintenant le déclencheur enfoncé, rebranchez l'alimentation du lecteur. Maintenez le déclencheur enfoncé pendant au moins 6 secondes jusqu'à entendre un double signal sonore (bip). Les voyants du lecteur clignotent de différentes couleurs.

Pour les lecteurs DataMan séries 50, 60 et 70 :

Imprimez une copie du document Codes de configuration du lecteur qui concerne votre lecteur en particulier, disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration.

Scannez la commande Redémarrer le scanner pour effectuer une réinitialisation logicielle. A la réinitialisation, le lecteur s'arrête et redémarre sans que la mémoire non volatile du lecteur ne soit effacée.

Si vous ne réussissez toujours pas à connecter le lecteur, numérisez la commande Réinitialiser le scanner avec les paramètres d'usine pour reconfigurer le lecteur sur ses réglages d'usine.

Si cela ne résout pas le problème, débranchez l'alimentation du lecteur (alimentation CC et USB, le cas échéant). Tout en maintenant le déclencheur enfoncé, rebranchez l'alimentation du lecteur. Maintenez le déclencheur enfoncé pendant au moins 6 secondes jusqu'à entendre un double signal sonore (bip). Les voyants du lecteur clignotent de différentes couleurs.


DataMan séries 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 et base du lecteur DataMan 8000 : pourquoi l'outil de configuration me réclame-t-il un mot de passe lorsque je veux me connecter ?

Le lecteur et la station de base peuvent être configurés de manière à réclamer un mot de passe avant de se connecter à l'outil de configuration. Le mot de passe est activé sur l'onglet Authentification, au niveau de l'option Paramètres réseau du volet Paramètres de communication. Notez que le mot de passe est également utilisé pour la connexion série.


DataMan série 60, 300, 370, 470, 503, 8000 et base du lecteur DataMan 8000 : puis-je connecter le lecteur directement à mon PC en utilisant Ethernet ?

Le lecteur ou la station de base peuvent être connectés directement à un connecteur Ethernet (RJ-45) sur votre PC. Si votre périphérique est configuré pour DHCP, il apparaît dans la liste des Périphériques réseau au bout d'environ 20 secondes. Notez, cependant, qu'une minute supplémentaire peut être nécessaire à votre PC pour résoudre son adresse IP. Tant que cette opération n'est pas terminée, vous ne pouvez pas connecter votre périphérique via l'outil de configuration.

Si votre périphérique a été configuré sur une adresse IP statique, il n'apparaît que si le PC et lui partagent le même sous-réseau.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000 et station de base du lecteur DataMan 8000 : comment puis-je mettre en correspondance une liste de la liste des périphériques réseau avec un lecteur donné ?

Par défaut, chaque DataMan apparaît dans la liste des Périphériques réseau avec un préfixe DM et les six derniers caractères de son adresse MAC qui figure sur le périphérique lui-même.


DataMan séries 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 et station de base du lecteur DataMan 8000 : que faire si mon lecteur ou ma station de base n'apparaît pas dans la liste des périphériques réseau ?

Si le lecteur ou la station de base souhaité(e) n'est pas répertorié(e), vous pouvez l'ajouter en l'éteignant puis en le/la rallumant. Il peut s'écouler jusqu'à 60 secondes avant que le périphérique n'apparaisse dans la liste après la mise sous tension.

Si la procédure d'extinction/de rallumage ne parvient pas à résoudre le problème, l'outil de configuration peut ne pas être en mesure de communiquer avec votre périphérique en raison de la configuration du réseau et il n'apparaîtra pas dans la liste des périphériques réseau.

Vérifiez la connexion Ethernet du lecteur ou de la station de base puis cliquez sur Actualiser dans l'outil de configuration.

si vous connaissez l'adresse IP du lecteur ou de la station de base, utilisez l'option Ajouter un périphérique.

Cette méthode devrait permettre au lecteur ou à la station de base DataMan d'apparaître dans la liste des périphériques réseau de manière à ce que vous puissiez vous y connecter via l'outil de configuration et votre connexion Ethernet.


Lecteur sans fil DataMan 8000 : comment connecter un lecteur sans fil à une autre station de base ?

Si la station de base à laquelle vous souhaitez connecter votre lecteur sans fil est déjà connectée à un autre lecteur, vous devez supprimer cette connexion en lisant le code Désassigner le lecteur de la station de base. Pour assigner le lecteur à une nouvelle station de base, il suffit de placer le nouveau lecteur dans la station de base. Ils sont automatiquement synchronisés.


Station de base du DataMan 8000 : comment réinitialiser la connexion USB à la station de base ?

Si vous avez du mal à établir ou à conserver une connexion USB entre une station de base et votre PC, procédez comme suit pour reconfigurer la connexion USB :

  1. Déconnectez le câble USB et le câble d'alimentation de la station de base.

  2. Reconnectez le câble USB et le câble d'alimentation à la station de base.

  3. Placez le lecteur dans la station de base.

  4. Retirez le lecteur de la station de base et scannez le code de configuration USB-COM/RS_232.


Entrées / Sorties


Quels paramètres système puis-je modifier ?

Vous pouvez désactiver ou activer l'avertisseur sonore. Veuillez noter qu'il n'est pas possible de définir le nombre de signaux sonores (bips) ou de spécifier les couleurs des LED.


Comment réinitialiser la station de base ?

Numérisez le code de configuration Réinitialiser avec les paramètres d'usine (pour le DM8000Base) à l'aide du lecteur sans fil associé à votre station de base.


Comment puis-je utiliser le lecteur sans fil à la place d'un clavier ?

Pour utiliser la sattion de base en mode HID, vous devez numériser le code Activer le clavier USB pour la station de base dans le document Codes de configuration du lecteur (disponible via le menu Démarrer de Windows ou le menu Aide de l'outil de configuration).


Pourquoi devrais-je changer le nom du périphérique ?

Vous pouvez attribuer au périphérique un nom plus évocateur pour votre environnement de production, comme son emplacement ou sa tâche d'inspection. Utilisez le champ Nom du périphérique dans l'onglet Avancé.


Comment puis-je changer le nom du périphérique ?

Pour changer le nom du périphérique :

  1. Saisissez le nouveau nom du périphérique dans le champ Nom du périphérique.

  2. La question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour prendre effet. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui.

  3. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre périphérique.

Lorsqu'ensuite vous relancez l'outil de configuration ou que vous cliquez sur Actualiser dans le volet Connexion au lecteur, vous voyez apparaître le nouveau nom du périphérique.


Qu'est-ce qu'un message de sortie de mode veille ?

Si l'option Envoyer la chaîne de diagnostic à la sortie du mode veille est activée, le lecteur ou sa base transmettra une chaîne de diagnostic au démarrage du lecteur.

Cette fonction n'est pas disponible pour les connexions USB. Pour les connexions série, la vitesse de transfert est automatiquement configurée à 38 400 bps lorsque le message est envoyé, quels que soient les paramètres de l'outil de configuration.


Communications


Comment modifier les paramètres du port série de la station base ?

Lorsque vous lisez le code de configuration RS-232 série du document Codes de configuration du lecteur, la base du lecteur est configurée automatiquement pour utiliser la même vitesse de transmission (ainsi que les autres paramètres des ports série) que l'outil de configuration.

Si vous devez connecter la base du lecteur à un périphérique ayant une vitesse de transmission ou des paramètres de port série différents, lisez les codes appropriés dans le document Codes de configuration du lecteur (disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration). Remarque : vous devrez lire à nouveau le code RS-232 série ou USB série pour vous connecter à l'aide de l'outil de configuration.


Quelles modifications entraînent le changement du mode USB ?

Lorsque vous êtes connecté à votre lecteur à travers une connexion série USB, vous pouvez choisir la vitesse USB de cette connexion entre les valeurs 1.1 ou 2.0.

Lorsque vous êtes connecté à un lecteur sans fil, la modification du mode USB n'entraîne aucune modification de la station de base. Les paramètres modifiés restent dans la mémoire du lecteur et si vous passez du réglage sans fil à un réglage série, le lecteur se connecte au mode USB (précédemment) sélectionné.


Quand dois-je utiliser le mode de compatibilité du pilote USB ?

Par défaut, la station de base utilise un pilote USB capable l'aider à surmonter un problème de décharge électrostatique. Utilisez le Mode de compatibilité du pilote USB si vous devez pouvoir vous appuyer sur une conformité stricte à la spécification USB ou si vous utilisez une station de base DataMan avec le produit Cognex SensorView.

Lorsque vous modifiez Mode de compatibilité du pilote USB, la question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour être prises en compte. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre lecteur.


Que puis-je paramétrer avec le menu déroulant Canal de communication utilisé ?

Vous pouvez y paramétrer la méthode de communication via USB. Selon le périphérique utilisé, les options suivantes sont disponibles :

  • USB-COM uniquement : sélectionnez cette option pour accéder au périphérique via un port série.

  • USB-HID uniquement : cette option fait en sorte que le périphérique se comporte comme un clavier USB.

  • USB-COM + USB-HID : il s'agit d'une combinaison des modes ci-dessus.

REMARQUE : dans le cas de USB-COM uniquement, certains périphériques peuvent également figurer dans la liste sous « Périphériques HID », même s'ils ne sont pas dotés de la fonction HID.


Comment puis-je utiliser la station de base à la place d'un clavier lorsqu'elle est connectée via USB ?

Pour émuler un clavier USB pour votre lecteur sans fil, numérisez le code Activer le clavier USB pour la station de base dans le document Codes de configuration du lecteur (disponible dans le menu Démarrer de Windows ou le menu Aide de l'outil de configuration) et assurez-vous de vous déconnecter de l'outil de configuration.


Comment puis-je utiliser la station de base à la place d'un clavier lors de l'utilisation d'un adaptateur PS/2 ?

Pour émuler un clavier PS/2, vous devez utiliser le câble série, l'alimentation externe et le câble d'émulation (voir l'Aide-mémoire. Numérisez le code de configuration Activer l'émulation clavier PS/2 à partir du document Codes de configuration du lecteur (disponible dans le menu Démarrer de Windows ou dans le menu Aide de l'outil de configuration). Pour installer l'adaptateur PS/2, vous devez éteindre votre PC complètement. Connectez la station de base en utilisant les câbles énumérés ci-dessus. Allumez ensuite votre ordinateur et votre lecteur sans fil émulera un clavier PS/2.


Qu'arrive-t-il si je ne redémarre pas ma station de base lorsqu'on me le demande ?

Les paramètres que vous avez modifiés ne prendront pas effet. Si vous changez d'avis, cliquez sur Système et sélectionnez Enregistrement des paramètres. Redémarrez ensuite la station de base.


Qu'est-ce que l'option de routage RS-232 ?

Lorsque vous connectez votre station de base par le biais de RS-232, vous pouvez déterminer si les données doivent être dirigées vers la base du lecteur même ou si vous souhaitez communiquer directement avec le lecteur associé à la station de base.

Lorsqu'aucun lecteur n'est affecté à la station de base, l'interface RS-232 permet de configurer la station de base quel que soit votre choix dans l'option Routage. Après l'affectation ou l'annulation de l'affectation du lecteur associé, le mode d'opération de l'interface RS-232 est automatiquement modifié au redémarrage de la station de base.


Comment puis-je configurer les paramètres réseau de la station de base ?

Sélectionnez l'option Utiliser le serveur DHCP pour qu'un serveur DHCP (s'il en existe un) attribue une adresse IP au lecteur. Vous pouvez également saisir les paramètres réseau manuellement. Contactez votre administrateur réseau afin d'obtenir la valeur qui convient.

Lorsque vous modifiez les paramètres, la question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour prendre effet. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre lecteur.


Quels sous-réseaux de l'adresse IP puis-je utiliser ?

Si vous choisissez d'utiliser une adresse IP statique, vous pouvez utiliser tous les sous-réseaux de l'adresse IP sauf les sous-réseaux 172.16.2.x et 172.16.0.x. N'utilisez ces sous-réseaux ni pour la station de base ni pour l'adresse IP du lecteur sans fil.


Comment puis-je assigner un nouveau lecteur à cette station de base ?

Placez le lecteur dans votre station de base. L'assignation se fait automatiquement.


Si je modifie la phrase de sécurité, est-elle immédiatement mise à jour ?

Vous devez appuyer sur Entrée après avoir entré une (nouvelle) phrase de sécurité. Si vous appuyez sur TAB ou cliquez ailleurs avec votre souris sans avoir appuyé sur Entrée, votre phrase de sécurité ne prend pas effet.


Dois-je toujours taper la phrase de sécurité deux fois ?

Si vous cochez Afficher, vous n'aurez besoin de l'entrer qu'une seule fois. Si vous n'avez pas coché Afficher, vous devez entrer la phrase de sécurité une deuxième fois et si les deux ne correspondent pas, l'outil de configuration affiche un avertissement.


Que se passe-t-il si je désactive l'option sans fil ?

Si vous décochez Activer sans fil, vous pouvez vous connecter à votre lecteur et communiquer avec lui uniquement si vous le placez dans la station de base. Vous pouvez toutefois continuer la lecture des codes avec le lecteur et envoyer les images une fois que l'aurez replacé dans la station de base et vous y connecter de n'importe quelle manière filaire.


Que se passe-t-il si je désactive le Bluetooth ?

Si vous décochez Activer Bluetooth, vous pouvez vous connecter à votre lecteur et communiquer avec lui uniquement si vous le placez dans sa base. Vous pouvez toutefois continuer la lecture des codes avec le lecteur et envoyer les images une fois que l'aurez replacé dans la station de base et vous y connecter de n'importe quelle manière filaire.


Quand dois-je cliquer sur Désassigner ?

Cliquez sur Désassigner si vous souhaitez associer un autre lecteur à votre station de base. Si votre nouveau lecteur n'est assigné à aucune station de base, il vous suffit de le placer à présent dans la station de base. L'assignation est automatique. Si votre lecteur est déjà assigné à une autre station de base, numérisez le code de programmation du lecteur Désassigner le lecteur puis placez votre lecteur dans la station de base.


À quoi correspond l'adresse IP dans l'option Lecteur associé ?

Cette adresse IP est utilisée pour la communication interne entre le lecteur et la station de base. Ce paramètre ne peut pas être modifié. N'utilisez pas cette adresse IP pour la communication réseau.


Mes paramètres de communication sont-ils synchronisés entre le lecteur et la station de base ?

Vous devez placer votre lecteur dans la station de base de sorte qu'ils puissent échanger et actualiser les paramètres afin d'être synchronisés. Si votre lecteur se trouve déjà dans la station de base lorsque vous modifiez vos paramètres de communication, enlevez votre lecteur et replacez-le dans la station de base.


Protocoles industriels

Protocole EtherNet/IP

Pour permettre au lecteur d'utiliser le protocole Ethernet/IP, cochez EtherNet/IP dans la boîte Protocoles industriels de l'onglet Ethernet.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres puis redémarrez votre lecteur.

Protocole PROFINET

Pour permettre à votre lecteur d'utiliser le protocole PROFINET, cochez PROFINET. Vous pouvez saisir le nom de la station en cliquant sur la boîte Utiliser nom de station.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres puis redémarrez votre lecteur.

Protocole SLMP

Pour permettre au lecteur d'utiliser le protocole SLMP, cochez Protocole SLMP puis réglez les paramètres selon vos besoins.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres, puis redémarrez le lecteur afin que le paramètre soit pris en compte en désactivant et activant l'alimentation du lecteur ou en lisant le symbole de Réinitialisation.

Modbus TCP

Pour permettre au lecteur d'utiliser le protocole Modbus TCP, cochez Modbus TCP puis réglez les paramètres selon vos besoins.

Le message « Les modifications nécessitent un redémarrage avant de prendre effet » s'affiche sur le côté droit de la bannière Communications. Cliquez sur Enregistrement des paramètres, puis redémarrez le lecteur afin que le paramètre soit pris en compte en désactivant et activant l'alimentation du lecteur ou en lisant le symbole de Réinitialisation.

Sélection EtherNet/IP, PROFINET, Protocole SLMP ou Modbus TCP grisées

Un seul protocole Ethernet industriel peut être utilisé à la fois. Lorsqu'un protocole est sélectionné, l'autre est indisponible.


Comment utiliser l'option d'Authentification ?

Lorsque l'option Authentification est activée, l'outil de configuration invite l'utilisateur à saisir le mot de passe du compte admin à chaque tentative de connexion à un lecteur ou à une station de base disponible sur le réseau.


Comment puis-je établir une connexion TCP/IP ?

La station de base ‎permet les connexions TCP au port 23 qui est le port TCP par défaut pour les applications Telnet. Si vous utilisez un client Telnet, le seul paramètre que vous devrez fournir est l'adresse IP de la station de base. Si vous utilisez SDK ou une autre application pour la connexion, assurez-vous qu'elle emploie le même paramètre de port TCP que votre station de base. Le port TCP peut être modifié sur le volet Telnet. La station de base envoie automatiquement la sortie de code via cette connexion. Vous pouvez également émettre les commandes de contrôle Dataman (DMCC - DataMan Control Commands) via cette connexion.

Lorsque vous modifiez le port Telnet, la question suivante apparaît : « Les modifications apportées requièrent un redémarrage pour prendre effet. Appliquer les modifications et redémarrer maintenant ? ». Cliquez sur Oui. Si, pour une raison quelconque, vous cliquez sur Non, vous pourrez toujours appliquer les modifications. Sélectionnez Système->Enregistrement des paramètres puis redémarrez votre station de base.


Qu'est-ce qu'un client réseau ?

Le comportement Client réseau permet au lecteur d'identifiants DataMan d'ouvrir activement une connexion Ethernet à un autre périphérique du réseau. Une fois ouverte, la connexion présente le même comportement opérationnel de base que la connexion DataMan Telnet : elle peut générer des résultats de lecture (transmettre des résultats à un périphérique externe) et agir en tant que serveur DMCC (en traitant les commandes reçues d'un périphérique externe).


Qu'est-ce qu'un hôte ?

L'hôte est le périphérique du réseau auquel le DataMan se connecte. Indiquez l'adresse Ethernet et le numéro de port du périphérique hôte. L'adresse peut être un nom de domaine complet (par ex. « serveur.monreseau.com ») ou une adresse IP à chiffres séparés par des points (par ex. « 192.169.0.1 »).


Qu'est-ce qu'un port client ?

Le port client est le port Ethernet du lecteur à l'origine de la connexion client. La valeur par défaut de 0 indique au client réseau d'utiliser n'importe quel port disponible. Dans certains cas, il peut être nécessaire de définir un port client spécifique. Définissez simplement le port client sur la valeur requise. Notez que, dans la plupart des cas, la valeur par défaut 0 s'applique. En cas de doute, utilisez la valeur par défaut.


Comment établir une connexion ?

Le client se connecte selon l'option Ouvrir la connexion choisie. Les options disponibles permettent de connecter le DataMan à l'allumage ou de le connecter dès la détection d'une activité de données (par ex. lorsqu'un code est lu).


Comment interrompre la connexion ?

Deux options Fermer la connexion sont disponibles. La connexion peut rester ouverte en permanence ou s'interrompre à la fin du transfert de données. Si vous choisissez l'option Après le transfert des données du lecteur, vous pouvez également définir un nombre de secondes après lesquelles la connexion s'interrompt si le lecteur demeure inactif. La durée de la période d'inactivité peut être réglée de 1 à 3 600 secondes.


Qu'est-ce que le délai d'attente de la connexion ?

Le délai d'attente de la connexion correspond à la durée (en millisecondes) observée par le DataMan avant l'ouverture de la connexion. Notez que si vous choisissez l'option de connexion À l'allumage, le lecteur réessaiera d'ouvrir la connexion en continu.


Qu'est-ce que le délai de reconnexion ?

Il s'agit de la durée (en millisecondes) de pause observée avant une nouvelle tentative de réouverture d'une connexion.


Paramètres de sauvegarde


Qu'est-ce que la sauvegarde automatique de la configuration du lecteur ?

La sauvegarde automatique fonctionne avec les périphériques connectés par Ethernet. Lorsqu'elle est activée, cette fonction effectue une sauvegarde de la configuration du périphérique sur une mémoire de stockage externe (un serveur FTP) chaque fois que la configuration est enregistrée sur flash. Un service Cognex Explorer peut recevoir les données de sauvegarde. Une restauration peut être effectuée manuellement, soit par l'outil de configuration, soit par les commandes DMCC, soit par Cognex Explorer.

Configurez le lecteur avec l'adresse IP et le numéro de port nécessaires pour indiquer l'emplacement de la sauvegarde de la configuration. Vous pouvez également définir une combinaison de nom d'utilisateur et mot de passe.


Vue tabulaire


Pourquoi certaines valeurs apparaissent-elles en surbrillance ?

Les valeurs en surbrillance sont des valeurs qui ne sont pas initialement par défaut. Les règles de mise en surbrillance peuvent être changées dans la section Mettre en surbrillance du menu ruban, voir la question Vue tabulaire : Menu ruban pour de plus amples informations.


Pourquoi certaines valeurs apparaissent-elles en gras ?

Les valeurs en gras peuvent être développées et contiennent des sous-valeurs.


Comment savoir quelles sont les valeurs possibles ?

Passez votre souris sur une valeur et vous verrez apparaître le texte flottant indiquant les valeurs minimum, maximum et par défaut, le cas échéant.


Informations légales


Copyright

Cognex Corporation décline toute responsabilité concernant l'utilisation ou la fiabilité de son logiciel sur des matériels non fournis par Cognex Corporation. Cognex Corporation n'offre aucune garantie, expresse ou implicite, sur le logiciel décrit, son caractère commercialisable ou son adéquation à un usage particulier.

Les informations contenues dans ce document sont sujettes à modifications sans préavis et ne doivent pas être considérées comme un engagement de la part de Cognex Corporation. Cognex Corporation n'est pas responsable des erreurs qui pourraient figurer dans ce document ou dans le logiciel associé.

Copyright © 2018 Cognex Corporation. Tous droits réservés

Toute copie, totale ou partielle, ainsi que tout transfert sur un support ou dans une langue quelconque de ce document sont interdits sans l'accord écrit de Cognex Corporation.

Le matériel et les parties du logiciel décrits dans ce document peuvent être protégés par un ou plusieurs des brevets pour les États-Unis répertoriés sur le site Web de Cognex http://www.cognex.com/patents.asp. D'autres brevets, déposés aux États-Unis et à l'étranger, sont en cours d'homologation.


Logiciel sous licence

SpiderMonkey

Ce logiciel est soumis aux conditions de la licence publique Mozilla, v. 2.0 dont une copie est disponible sur http://mozilla.org/MPL/2.0/.

Pour obtenir une copie du code source de SpiderMonkey, veuillez contacter l'assistance technique de Cognex à l'adresse <spidermonkey@cognex.com>.

Licence PCRE

PCRE est une bibliothèque de fonctions conçue pour la prise en charge des expressions régulières dont la syntaxe et la sémantique sont aussi proches que possible de celles du langage Perl 5.

La version 5 de PCRE est distribuée dans le cadre de la licence « BSD », conformément aux indications ci-dessous. Les documents relatifs à la bibliothèque PCRE, figurant dans le répertoire « doc », sont distribués dans les mêmes conditions que le logiciel proprement dit.

Rédigé par : Philip Hazel <ph10@cam.ac.uk>

University of Cambridge Computing Service, Cambridge, Angleterre. Téléphone : +44 1223 334714.

Copyright (c) 1997-2004 Université de Cambridge. Tous droits réservés.

La redistribution et l'utilisation sous forme source et binaire, avec ou sans modification, sont autorisées aux conditions suivantes :

  • La redistribution du code source doit faire état du copyright ci-dessus, de la présente liste de conditions et de la clause de non-responsabilité suivante.
  • Les redistributions sous forme binaire doivent mentionner le copyright ci-dessus, la présente liste de conditions et la clause de non-responsabilité suivante dans les documents et/ou les autres éléments fournis avec la distribution.
  • Ni le nom de l'Université de Cambridge, ni ceux de ses collaborateurs ne peuvent être utilisés pour soutenir ou promouvoir des produits dérivés de ce logiciel sans autorisation écrite spécifique préalable.

CE LOGICIEL EST FOURNI PAR LES DÉTENTEURS DU COPYRIGHT ET LEURS COLLABORATEURS « EN L'ÉTAT », À L'EXCLUSION DE TOUTE GARANTIE EXPRESSE OU IMPLICITE, Y COMPRIS, MAIS SANS CARACTÈRE LIMITATIF, TOUTE GARANTIE IMPLICITE DE CARACTÈRE COMMERCIALISABLE ET D'ADAPTATION À UN USAGE PARTICULIER. EN AUCUN CAS, LE DÉTENTEUR DU COPYRIGHT OU SES COLLABORATEURS NE SAURAIENT ÊTRE TENUS RESPONSABLES DE DOMMAGES QUELCONQUES, QU'ILS SOIENT DIRECTS, INDIRECTS, ACCIDENTELS, SPÉCIAUX, EXEMPLAIRES OU CONSÉCUTIFS (Y COMPRIS, MAIS SANS CARACTÈRE LIMITATIF, LA FOURNITURE DE BIENS OU SERVICES DE REMPLACEMENT, PERTE D'USAGE, DONNÉES OU BÉNÉFICES, OU INTERRUPTION D'ACTIVITÉ COMMERCIALE) QUELLE QU'EN SOIT LA CAUSE ET INDÉPENDAMMENT DU TYPE DE RESPONSABILITÉ, CONTRACTUELLE, STRICTE OU DÉLICTUELLE (Y COMPRIS PAR NÉGLIGENCE OU AUTRE CAUSE) RÉSULTANT D'UNE MANIÈRE OU D'UNE AUTRE DE L'UTILISATION DE CE LOGICIEL, MÊME SI LA POSSIBILITÉ DE TELS DOMMAGES AVAIT FAIT L'OBJET D'UN AVIS PRÉALABLE.

Fin

Logiciel JPEG

Ce logiciel est partiellement fondé sur les travaux du groupe JPEG (Independent JPEG Group).

Bibliothèque de compression zlib

Ce logiciel est partiellement fondé sur les travaux de Jean-Loup Gailly et Mark Adler.

Programme d'analyse syntaxique XML Parsifal

Copyright (c) 2002-2005 Toni Uusitalo rendu public le 15-11-2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

Parsifal est un logiciel libre pour l'utilisation et la redistribution commerciale et privée, à condition de mentionner le copyright et la clause de non-responsabilité de l'auteur. Vous pouvez librement modifier Parsifal pour votre usage particulier et le redistribuer avec les modifications apportées, à condition de clairement décrire celles-ci.

CLAUSE DE NON-RESPONSABILITÉ

Ce programme est distribué dans l'espoir d'être utile, mais SANS AUCUNE GARANTIE, pas même la garantie implicite de son caractère commercialisable ou d'adaptation à un usage particulier. Veuillez l'utiliser À VOS RISQUES ET PÉRILS.


Informations relatives aux brevets

Ce produit est couvert par un ou plusieurs des brevets américains, applications américaines et/ou brevets étrangers répertoriés ci-dessous. La page http://www.cognex.com/patents répertoriera les éventuels brevets significatifs émis ultérieurement

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1 et EP1687752