RTM Lean : Preguntas y respuestas


Supervisión en tiempo real


¿Para qué se utiliza RTM Lean?

Real Time Monitoring (RTM) Lean es una característica integrada en la herramienta de configuración DataMan que permite recopilar y analizar distintos tipos de datos relacionados con un único dispositivo de la red y con sus lecturas. El dispositivo de destino para esta adquisición de datos, así como la selección del tipo de datos recopilados, pueden establecerse en Configuración en el menú de la cinta. De forma predeterminada, RTM Lean recopila datos estadísticos (tasa de lectura, recuento de no lecturas, tiempo de decodificación medio, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo).


¿Qué opciones hay disponibles en Configuración?

Configuración permite configurar la adquisición de datos de RTM Lean junto a otras opciones:

Configuraciones de dispositivos: seleccione el dispositivo objeto de la adquisición de datos. Agregue dispositivos a la lista con el botón Agregar dispositivo. Se abrirá una nueva ventana, donde podrá agregar manualmente dispositivos basados en la IP con el botón Agregar dispositivo de red. El botón Actualizar puede utilizarse para actualizar la lista de dispositivos, mientras que el botón Quitar dispositivo agregado manualmente quita el dispositivo seleccionado de la lista. Quitar dispositivo permite quitar un dispositivo de la lista de dispositivos agregados, pero tal y como advierte la advertencia emergente, esto conlleva el purgado completo de los datos recopilados (imágenes, estadísticas, etc.) para ese dispositivo. RTM Lean puede supervisar los dispositivos protegidos por contraseña, pero para ello es necesario proporcionar el nombre de usuario y contraseña en Red.

Recopilación de datos: la lista incluye todos los tipos de información que RTM Lean puede recopilar. Marque las casillas para recopilar los datos deseados. De forma predeterminada, RTM Lean recopila datos estadísticos (tasa de lectura, recuento de no lecturas, tiempo de decodificación medio, recuento de disparos, sobrecarga del disparador, desbordamiento de la memoria intermedia y medición de control de procesos, en caso de haberse activado en el dispositivo). Los tipos de datos proporcionados en la lista no se encuentran entre los datos recopilados predeterminados y pueden establecerse en la pestaña Configuración:

  • Información de disparo detallada para no lecturas: Si se activa, RTM Lean almacena datos de disparos individuales cuando se produce una no lectura. Si la no lectura contiene resultados parciales o información de Sincronización de múltiples lectores, también se almacenan.

  • Imágenes no leídas (a través de FTP): si se activa, el dispositivo envía la imagen o imágenes no leídas a RTM Lean.

  • Información de disparo detallada para lecturas correctas: esta configuración permite utilizar la página Rendimiento de disparo de Vistas detalladas en el menú de la cinta. Rendimiento de disparo recopila datos para disparos individuales que se traducen en una lectura correcta. Todos los valores de estos datos pueden verse en el menú desplegable Valores representados de la página Rendimiento de disparo.

  • Posiciones de los códigos para mapa de calor: para cada lectura correcta, RTM Lean almacena los rectángulos para cada uno de los códigos encontrados. Esta información se utiliza después para crear un mapa de calor 2D que muestra dónde se leyeron los códigos en el campo de visión.

  • Cambios de configuración del dispositivo: si está marcada, el dispositivo avisa a RTM Lean cuando hay cambios de configuración. RTM Lean almacena todos los archivos de configuración enviados por el dispositivo. Los eventos de cambio de configuración se muestran en la página Historial de eventos, donde pueden exportarse o compararse.

Tenga en cuenta que en función de la frecuencia de disparo, la activación de los datos de nivel de disparo puede ralentizar el sistema.

Clasificación: El controlador de RTM puede recopilar datos de clasificación en función de los motivos de los eventos de no lectura si el dispositivo DataMan está emparejado a un dispositivo In-Sight de Cognex. Se debe especificar un dispositivo In-Sight para que funcione la clasificación marcando la casilla Recopilar clasificaciones de imágenes de In-Sight y seleccionando el dispositivo clasificador en la lista desplegable. Para almacenar las imágenes de clasificación, marque la casilla Almacenar imágenes de In-Sight en RTM.

Tenga en cuenta que, en función de la configuración de disparo y la frecuencia de imágenes no leídas, el almacenamiento de las imágenes puede aumentar el uso del disco de forma significativa.

No sobrescribir secuencia de comandos de comunicación en DataMan: marque esta casilla para que no se sobrescriba la secuencia de comandos en el dispositivo.

Red: Este panel muestra el nombre y la dirección del dispositivo que RTM Lean está supervisando de forma activa (la casilla Recopilación activada está marcada a la izquierda). Al hacer clic en el icono de la rueda dentada, se abre un submenú que permite determinar de qué manera RTM Lean debe identificar un dispositivo (dirección IP o dirección MAC). Si desea recopilar datos de un dispositivo protegido por contraseña, debe proporcionar el nombre de usuario y la contraseña después de seleccionar el dispositivo para supervisar en la lista de la izquierda.


¿Qué opciones hay disponibles en Opciones de presentación?

Aquí puede configurar una línea de advertencia para que aparezca en los gráficos.

  • Mostrar línea de referencia de tasa de lectura: Al marcar la casilla, se mostrará la línea de advertencia.

  • Valor de línea de referencia de tasa de lectura (%): puede establecer un valor porcentual, que es el porcentaje de advertencia donde se dibujará la línea en el gráfico Tasa de lectura.

  • Tipo de tabla determina qué tipo de línea se muestra.

  • Tamaño del búfer de no lecturas está relacionado con el Historial de imágenes no leídas, donde el número establecido aquí es el número máximo de líneas (disparos) que se considera en esa página.

  • Establezca el número máximo de detalles de disparo devueltos en el cuadro Número máximo de detalles de disparo devueltos.


¿Qué puedo configurar en Dispositivos del menú de la cinta?

Además de mostrar el ID del dispositivo al que RTM Lean está conectado actualmente, el icono mostrado indica si la recopilación de datos está activa (icono de reproducción) o inactiva (icono de pausa). El menú desplegable permite pausar o iniciar la recopilación de datos activa de acuerdo con los parámetros configurados al iniciar RTM Lean o en Configuración. También puede ejecutar el diagnóstico desde el menú desplegable, de igual manera que en Configuración.


Vistas comunes y Vistas detalladas - Información general

Tanto los elementos Vistas comunes como Vistas detalladas del menú de la cinta muestran representaciones estructuradas de los datos recopilados por RTM Lean, mayoritariamente en forma de gráficos en tiempo real. El intervalo de tiempo más pequeño en estas representaciones es de un minuto. Si se producen varios disparos en un minuto, RTM Lean agrega los datos recopilados de estos disparos durante un intervalo de un minuto.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que en Valor de línea de referencia de tasa de lectura (%) puede proporcionar el porcentaje de advertencia donde se dibujará la línea en los gráficos.

Tenga en cuenta que RTM Lean solo recopila información que se muestra en los elementos de menú de las vistas cuando está conectado y la recopilación está activada en el dispositivo activo (active la recopilación de datos en Configuración o en el menú desplegable en Dispositivos).


¿Qué datos recopila y muestra Vista general de rendimiento?

En función de la configuración ajustada en Mostrando, en la parte superior izquierda, la Vista general de rendimiento puede mostrar Tasa de lectura, Lecturas por minuto y No lecturas por minuto en un gráfico en tiempo real. Es posible hacer clic en los botones Último [intervalo de tiempo] en la fila superior, y el activo está marcado en naranja. Puede utilizar los botones para establecer el intervalo que utiliza Vista general de rendimiento.

Debe accionar el dispositivo supervisado para que se muestren datos en el gráfico.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Valor de línea de referencia de tasa de lectura (%) es el porcentaje donde se dibuja la línea en los gráficos.


¿Qué datos recopila y muestra Vista general de calidad de los códigos?

Vista general de calidad de los códigos puede mostrar las calificaciones y mediciones de calidad de los códigos en un gráfico en tiempo real, en función de la configuración en la parte superior izquierda en Configuración > Valor representado. Seleccione la medición o calificación que desee supervisar en el dispositivo. Solo la norma de calidad de los códigos configurada en el dispositivo supervisado está disponible en Valor representado (por lo que un cuadro desplegable vacío significa que no hay ninguna norma activada en el dispositivo). Puede cambiar la norma de calidad de los códigos activada en el dispositivo de destino para recopilar datos para otra norma.

En caso de código múltiple, puede haber varias normas de calidad de los códigos establecidas en el dispositivo. En tal caso, el gráfico muestra dos líneas de datos (y su promedio se muestra arriba).

NOTA: dado que RTM Lean utiliza un intervalo mínimo de un minuto, las calificaciones pueden tener un valor intermedio.

Es posible hacer clic en los botones Último [intervalo de tiempo] en la fila superior, y el activo está marcado en naranja. Puede utilizar los botones para establecer el intervalo que utiliza Vista general de calidad de los códigos. El valor promedio representado se muestra aquí.

Puede configurar una línea de advertencia para que aparezca en los gráficos en Configuración > Opciones de presentación. Al marcar la casilla, se mostrará la línea de advertencia en cada gráfico. Tipo de tabla determina qué tipo de línea se muestra, mientras que Valor de línea de referencia de tasa de lectura (%) es el porcentaje donde se dibuja la línea en los gráficos.


¿Qué datos recopila y muestra Historial de eventos?

Historial de eventos combina adquisición de datos estadísticos y de calidad de los códigos, en función de la configuración en la parte superior izquierda en Configuración > Valor representado. RTM Lean supervisa el valor seleccionado en el dispositivo. Para las mediciones y calificaciones de calidad de los códigos, solo la norma de calidad de los códigos establecida en el dispositivo supervisado está disponible en Valor representado. Puede cambiar la norma de calidad de los códigos activada en el dispositivo de destino para recopilar datos para otra norma.

Es posible mover la barra de desplazamiento al momento deseado para ver los datos de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado. En Valor agregado en período seleccionado, situado en la parte superior central, se muestra un valor agregado del valor representado del período de tiempo seleccionado (posicionando la barra de desplazamiento).

La recopilación de datos llena la línea inferior del gráfico con puntos que representan eventos durante la supervisión. Cada evento se muestra en el lado derecho con detalles (marca de fecha y hora, y tipo de evento). Hay dos botones debajo de la lista:

  • Guardar backups de dispositivo permite exportar la configuración del dispositivo asociada al evento seleccionado en la lista. Esto podría usarse para verificar los detalles cuando se buscan los motivos de un cambio en una estadística, medición o calificación dada.

  • Comparar configuraciones abre el documento donde puede comparar las configuraciones de los dispositivos asociadas a los eventos seleccionados; solo funciona si se selecciona más de un evento en la lista.


¿Qué puedo ver en el panel Mapa de calor de ubicaciones de los códigos?

Mapa de calor de ubicaciones de los códigos dibuja un mapa de calor de lecturas correctas, donde las regiones se colorean de acuerdo con la frecuencia con que se han encontrado códigos en ellas. Los colores más cálidos indican que en esa área se encontraron códigos con mayor frecuencia. Es posible mover la barra de desplazamiento al momento deseado para ver el mapa de calor de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado.


¿Qué datos se muestran en el panel Historial de imágenes no leídas?

El historial de imágenes no leídas muestra las últimas imágenes no leídas tomadas por el dispositivo supervisado. La vista de tabla de la izquierda muestra varios atributos de las imágenes, mientras que la ventana de la imagen de la derecha muestra la imagen seleccionada en la vista de diapositiva de debajo. Haga clic en el icono Guardar para guardar la imagen seleccionada actualmente.

La tabla Clasificación en la parte inferior izquierda muestra qué tipo de eventos de no lectura se han producido, si seleccionó la recopilación de clasificaciones en Configuración > Configuración > Clasificación.


¿Qué datos se muestran en el panel Rendimiento de disparo?

Para activar Rendimiento de disparo, debe marcar la opción Información de disparo detallada para lecturas correctas de la lista Recopilación de datos, en la pestaña Configuración.

Rendimiento de disparo no agrega datos en intervalos de un minuto como otros paneles, sino que muestra cada disparo en el gráfico. Los disparos individuales se representan con puntos en el gráfico y se muestra su valor numérico. Los valores representados (los que se supervisan) pueden seleccionarse entre varios valores posibles en el cuadro desplegable Valores representados. Tenga en cuenta que la lista de valores representados puede ser distinta en función de la versión de firmware del dispositivo supervisado.

Es posible mover la barra de desplazamiento al momento deseado para ver los datos de ese momento determinado. Se puede modificar la longitud de la barra de desplazamiento (haciendo clic y arrastrando) para cambiar el intervalo supervisado. La opción Representaciones de color basadas en permite establecer los criterios para los colores de los puntos en el gráfico.

Es posible hacer clic en un punto individual (disparo) del gráfico para ver todos los datos relacionados que RTM Lean ha recopilado en el lado derecho si el disparo fue una lectura correcta. Si el resultado fue una lectura incorrecta, RTM Lean muestra la imagen tomada, que puede guardarse haciendo clic en el icono Guardar.


¿Qué opciones hay disponibles en la pestaña Sistema?

Aquí puede eliminar datos y configuraciones. Al hacer clic en Vaciar base de datos, se eliminan todos los datos almacenados, mientras que Restablecer configuración elimina las configuraciones del dispositivo y todos los datos almacenados.