DataMan 8000 Series Base Station : Preguntas y respuestas


Conectar al lector


¿Cómo conecto mi estación base a la herramienta de configuración?

Siga estos pasos para conectar su lector DataMan a la herramienta de configuración:

  1. Imprima una copia del documento Códigos de configuración del lector para su estación base, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.

  2. Conecte el cableado necesario entre su estación base y el PC que ejecute la herramienta de configuración. Para más información, consulte la documentación impresa de referencia rápida del DataMan 8xx0.

  3. Escanee el símbolo para el código de Configuración de comunicación o de Tipo de conexión deseado, como, por ejemplo, USB.

  4. Haga clic en Actualizar en la herramienta de configuración.

  5. Seleccione el puerto COM o el Dispositivo de red que muestre una conexión con el lector.

  6. Haga clic en Conectar.


¿Qué puerto debo utilizar para una conexión USB?

Si conecta el lector o la estación base utilizando el puerto USB, debe escanear el código de configuración USB-COM/RS-232 que figura en el documento Códigos de configuración del lector. Después, haga clic en Actualizar y seleccione el puerto identificado como conectado al lector.

Nota: al hacer clic en Actualizar se envía una cadena de consulta a todos los puertos COM y por toda la subred de la red Ethernet. Debe haber activos un lector DM7550 y un DM8000 inalámbricos para poder responder a la consulta. Pulse el disparador para activar el lector.


Sigo sin poder establecer una conexión con el lector o con la estación base: ¿puedo reiniciarlo?

Para la estación base DataMan 8000:

Con el lector inalámbrico asociado a su estación base, escanee el comando Restablecer los valores predeterminados de la estación base (para la base DM8000) para devolver la estación base a sus valores predeterminados de fábrica.

Para lectores DataMan de las series 503 y 8000:

Escanee el comando Reiniciar el escáner impreso al final de la guía de referencia rápida para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y se reinicia.

Si el problema persiste, escanee el comando Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.

Si continúa sin poder establecer la conexión, y está usando un lector con cable, desenchufe el lector de la corriente (este procedimiento no es posible con el dispositivo DataMan 9500). Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.

Si el problema persiste y está usando un lector inalámbrico DataMan 8000, extraiga la batería del lector y colóquelo en la estación base. Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.

Para lectores DataMan 50, 60 y 70:

Imprima una copia del documento Códigos de configuración para su lector, disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración.

Escanee el código Reiniciar el escáner para efectuar un restablecimiento de software. No se borra la memoria no volátil del lector, pero el lector se cierra y reinicia.

Si sigue sin poder conectarse al lector, escanee el código Restablecer los valores predeterminados de fábrica del escáner para restablecer los valores predeterminados del lector.

Si eso no soluciona el problema, desenchufe el lector de la corriente (alimentación CC y USB, si procede). Mientras mantiene el botón de disparo pulsado, vuelva a enchufar el lector a la corriente. Mantenga pulsado el botón de disparo durante al menos 6 segundos, hasta escuchar el pitido doble. Las luces indicadoras del lector parpadearán en distintos colores.


DataMan series 50, 60, 70, 300, 370, 470, 503, 8000, MX-1000, MX-1500 y estación base DataMan 8000: ¿por qué solicita una contraseña la herramienta de configuración cuando quiero conectarme?

El lector y la estación base pueden configurarse para solicitar una contraseña antes de conectarse a la herramienta de configuración. La contraseña se activa en la pestaña Autenticación en la opción Configuración de red del panel Configuración de comunicación. Tenga en cuenta que la contraseña se emplea también para la conexión en serie.


DataMan 60, 300, 370, 470, 503, 8000 series y estación base DataMan 8000: ¿puedo conectar el lector a mi PC directamente mediante Ethernet?

El lector o la estación base pueden conectarse directamente a un conector Ethernet (RJ-45) en su PC. Si el dispositivo está configurado para DHCP, aparecerá en la lista de dispositivos de red aproximadamente unos 20 segundos después. Tenga en cuenta, no obstante, que su PC podría necesitar un minuto adicional para que se resuelva su dirección IP. No podrá conectar el dispositivo a través de la herramienta de configuración hasta que haya concluido esta operación.

Si su dispositivo se ha configurado para utilizar una dirección IP estática, dicho dispositivo solo aparecerá si comparte la misma subred que el PC.


DataMan series 60, 300, 370, 470, 503, 8000, MX-1000 y estación base DataMan 8000: ¿cómo hago corresponder un elemento de la lista de dispositivos de red con un lector específico?

De forma predeterminada, cada DataMan aparece en los dispositivos de red con un prefijo DM y los últimos seis caracteres de su dirección MAC, impresa en el dispositivo.


DataMan series 60, 300, 370, 470, 503, 8000, MX-1000, MX-1500 y estación base DataMan 8000: ¿qué hacer si mi lector o estación base no aparecen en la lista de dispositivos de red?

Si el lector o la estación base deseados no aparece en la lista, puede añadirlos reiniciándolos. Una vez encendidos, los dispositivos pueden tardar hasta 60 segundos en aparecer en la lista.

Si reiniciar el dispositivo no soluciona el problema, la herramienta de configuración quizás no sea capaz de comunicarse con el dispositivo debido a la configuración de red, y no aparecerá en la lista de dispositivos de red.

Compruebe la conexión Ethernet con el lector o la estación base y haga clic en Actualizar en la herramienta de configuración.

Si sabe cuál es la dirección IP del lector o de la estación base, utilice la opción Agregar dispositivo.

Este método permite que el lector o la estación base DataMan aparezca en la lista de dispositivos de red para que pueda conectarse al lector mediante la herramienta de configuración y su conexión Ethernet.


Lector inalámbrico DataMan 8000: ¿cómo puedo asociar un lector inalámbrico a otra estación base?

Si la estación base a la que desea asociar el lector inalámbrico ya está asociada a otro lector, debe romper esa conexión escaneando el código Desasignar lector de estación base. Para asignar el lector a una nueva estación base, simplemente coloque el nuevo lector en la estación base. Se emparejarán automáticamente.


Estación base DataMan 8000: ¿cómo puedo restablecer la conexión USB a la estación base?

Si tiene problemas para establecer o mantener una conexión USB entre una estación base y el PC, siga los pasos siguientes para restablecer la conexión USB:

  1. Desconecte el cable USB y el cable de alimentación de la estación base.

  2. Vuelva a conectar el cable USB y el cable de alimentación a la estación base.

  3. Coloque el lector en la estación base.

  4. Retire el lector de la estación base y escanee el código de configuración USB-COM/RS_232.


Entradas / Salidas


¿Qué configuraciones del sistema puedo modificar?

Puede desactivar o activar la alerta sonora. Tenga en cuenta que no se puede establecer el número de pitidos o especificar los colores de LED.


¿Cómo puedo restablecer la estación base?

Escanee el código de configuración Restablecer los valores predeterminados de fábrica (para la base DM8000) con el lector inalámbrico asociado a su estación base.


¿Cómo utilizo el lector inalámbrico en lugar de un teclado?

Para utilizar la estación base en modo HID, debe escanear el código Activar teclado USB para la estación base del documento Códigos de configuración del lector (disponible en el menú Inicio de Windows en el menú Ayuda de la herramienta de configuración).


¿Por qué cambiar el nombre del dispositivo?

Puede dar al dispositivo un nombre con más sentido en relación a su entorno de producción, como, por ejemplo, la localización o la tarea de inspección.


¿Cómo cambio el nombre del dispositivo?

Para cambiar el nombre del dispositivo:

  1. Introduzca un nuevo nombre para el dispositivo en Nombre del dispositivo.

  2. Aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí».

  3. Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su dispositivo.

La próxima vez que inicie la herramienta de configuración o haga clic en Actualizar en la pantalla de Inicio, aparecerá el nuevo nombre del dispositivo.


¿Qué es un mensaje de activación?

Si la función Cadena de diagnóstico de salida al activar está activada, el lector o la estación base transmitirá una cadena de diagnóstico cuando el dispositivo se inicie.

Esta función no está disponible para conexiones USB. Para conexiones de serie, la velocidad en baudios se establece automáticamente a 38 400 cuando se envía el mensaje, independientemente de la configuración efectuada en la herramienta de configuración.


Comunicaciones


¿Cómo puedo cambiar la configuración del puerto de serie de la estación base?

Cuando escanee el código de configuración Serie RS-232 del documento Códigos de configuración del lector, la estación base se configurará automáticamente para utilizar la misma velocidad en baudios (y otras configuraciones de puerto serie) que utiliza la herramienta de configuración.

Si debe conectar la estación base a un dispositivo con una velocidad en baudios determinada o con otra configuración de puerto serie, escanee los códigos apropiados del documento Códigos de configuración del lector (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración). Deberá volver a escanear el código Serie RS-232 o Serie USB para poder establecer una conexión utilizando la herramienta de configuración.


¿Qué resulta afectado al cambiar el modo USB?

Cuando se conecte a su lector a través de una conexión USB de serie, podrá cambiar la velocidad USB de dicha conexión a 1.1 o 2.0.

Cuando se conecte a un lector inalámbrico, cambiar el modo USB no afectará a la estación base. La configuración modificada permanecerá en la memoria del lector, y si cambia el deslizante inalámbrico a un deslizante de serie, el lector se conectará con el (anteriormente) seleccionado modo USB.


¿Cuándo debería usar el modo de compatibilidad del controlador USB?

De forma predeterminada, la estación base usa un controlador USB que puede ayudar al lector a recuperarse de una descarga electrostática (ESD). Utilice el Modo de compatibilidad del controlador USB si necesita una estricta conformidad a las especificaciones USB o si está usando una estación base DataMan junto con el producto SensorView de Cognex.

Cuando cambie a modo de compatibilidad del controlador USB, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


¿Qué puedo configurar con el menú desplegable Canal de comunicación utilizado?

Aquí puede configurar el método de comunicación mediante USB. En función del dispositivo utilizado, están disponibles las opciones siguientes:

  • Solo USB-COM: seleccione esta opción para tener acceso al dispositivo a través de un puerto serie.

  • Solo USB-HID: esta opción garantiza que el dispositivo se comporte como un teclado USB.

  • USB-COM + USB-HID: esta es una combinación de los modos anteriores.

NOTA: en el caso de Solo USB-COM, es posible que algunos dispositivos también aparezcan en la lista «Dispositivos HID» aunque no tengan funcionalidad HID.


¿Cómo utilizo la estación base en lugar de un teclado cuando esté conectado mediante USB?

Para emular un teclado USB para su lector inalámbrico, escanee el código Activar teclado USB para la estación base del documento Códigos de configuración del lector (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración) y asegúrese de desconectarse de la herramienta de configuración.


¿Cómo utilizo la estación base en lugar de un teclado a través del adaptador PS/2?

Para emular un teclado PS/2, utilice el cable serie, la fuente de alimentación externa y el cable de decodificador de teclado, del modo descrito en la guía de referencia rápida. Escanee el código Emulación de teclado PS/2 activada del documento Códigos de configuración del lector (disponible en el menú Inicio de Windows o en el menú Ayuda de la herramienta de configuración). Para instalar el adaptador PS/2, deberá apagar completamente su PC. Conecte la estación base usando los cables que se enumeran más arriba. Después, encienda su ordenador y el lector inalámbrico emulará un teclado PS/2.


¿Qué sucede si no reinicio la estación base cuando se me solicita?

Los cambios en la configuración no tendrán efecto. Si cambia de opinión, haga clic en Sistema y elija Guardar configuración. Después, reinicie la estación base.


¿Qué es la opción de enrutamiento de RS-232?

Cuando conecte su estación base mediante RS-232, podrá establecer si los datos se enrutan hasta la propia estación base o si desea comunicar directamente el lector asociado con la estación base.

Cuando no haya asignado un lector a la estación base, la interfaz RS-232 se empleará para configurar la estación base independientemente de lo que haya elegido en la opción de enrutamiento. Cuando se asigna o desasigna el lector asociado, el modo de operación de la interfaz RS-232 cambia automáticamente, una vez usted reinicie su estación base.


¿Cómo establezco la configuración de red de la estación base?

Seleccione la opción Usar servidor DHCP para hacer que el servidor DHCP asigne una dirección IP al lector (si hay alguna disponible), o introduzca la configuración de red de forma manual. Póngase en contacto con su administrador de red para obtener un valor apropiado.

Cuando cambie la configuración, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su lector.


¿Qué subredes de dirección IP puedo usar?

Si cambia para usar una dirección IP estática, podrá usar cualquier subred de dirección IP excepto las subredes 172.16.2.x y las 172.16.0.x. No utilice estas para la estación base ni para la dirección IP del lector inalámbrico.


¿Cómo asigno un nuevo lector a esta estación base?

Coloque el lector en la estación base. La asignación tiene lugar de forma automática.


Si cambio la frase de contraseña, ¿se actualizará de inmediato?

Debe pulsar Entrar una vez haya introducido una (nueva) frase de contraseña. Si pulsa el tabulador o hace clic para salir con el ratón sin haber pulsado Entrar, su frase de contraseña no se actualizará.


¿Tengo siempre que escribir dos veces la frase de contraseña?

Si marca la opción Mostrar, solo tendrá que introducir una vez la frase de contraseña. Si no ha marcado la opción Mostrar, deberá introducir la frase de contraseña de nuevo, y si las dos no coinciden, la herramienta de configuración mostrará un aviso.


¿Qué sucede si desactivo la opción de inalámbrico?

Si desmarca Activar inalámbrico, solo podrá conectarse y comunicarse con su lector si lo coloca en la estación base. No obstante, podrá seguir leyendo con el lector y podrá enviar imágenes una vez vuelva a colocarlo en la estación base y lo conecte a ella mediante cualquier tipo de cable.


¿Qué sucede si desactivo la opción Bluetooth?

Si desmarca Activar Bluetooth, solo podrá conectarse y comunicarse con su lector si lo coloca en la estación base. No obstante, podrá seguir leyendo con el lector y podrá enviar imágenes una vez vuelva a colocarlo en la estación base y lo conecte a ella mediante cualquier tipo de cable.


¿Cuándo debería hacer clic en Desasignar?

Haga clic en Desasignar si quiere asociar otro lector a su estación base. Si el nuevo lector no está asignado a ninguna estación base, simplemente colóquelo ahora en la estación base. La asignación es automática. Si el lector ya está asignado a otra estación base, escanee el código de programación del lector Desasignar lector y luego coloque el lector en la estación base.


¿Cuál es la dirección IP que aparece como lector asociado?

Esta dirección IP se usa para la comunicación interna entre el lector y la estación base. Esta configuración no se puede cambiar. No utilice esta dirección IP para comunicación de red.


¿Está sincronizada mi configuración de comunicación entre el lector y la estación base?

Debe colocar el lector en la estación base, de forma que puedan intercambiar y actualizar la configuración para estar sincronizados. Si el lector ya está en la estación base al cambiar la configuración de comunicación, levántelo y vuelva a colocarlo de nuevo en la estación base.


Protocolos industriales

Protocolo de EtherNet/IP

Para permitir que el lector utilice el protocolo de EtherNet/IP, marque la opción EtherNet/IP en el cuadro Protocolos industriales de la pestaña Ethernet.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie su lector.

Protocolo PROFINET

Para permitir al lector utilizar el protocolo PROFINET, marque la opción PROFINET. Haga clic en la casilla Usar nombre de la estación para introducir el nombre de la estación.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie su lector.

Protocolo SLMP

Para permitir al lector utilizar el protocolo SLMP, marque la opción Protocolo SLMP y configure los parámetros según sea necesario.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie el lector para que tenga efecto la configuración, apagando y encendiéndolo o escaneando el símbolo Restablecer.

Modbus TCP

Para permitir al lector utilizar el protocolo Modbus TCP, marque la opción Modbus TCP y configure los parámetros según sea necesario.

Se mostrará «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados.» en el lado derecho del banner Comunicaciones. Haga clic en Guardar configuración y reinicie el lector para que tenga efecto la configuración, apagando y encendiéndolo o escaneando el símbolo Restablecer.

Selección EtherNet/IP, PROFINET, Protocolo SLMP o Modbus TCP marcada en gris

Solo se puede usar un protocolo industrial de Ethernet en cada momento. Cuando se seleccione un protocolo, el otro no estará disponible.


¿Cómo utilizo la opción Autenticación?

Cuando la opción Autenticar se encuentre activada, la herramienta de configuración pedirá al usuario una contraseña para la cuenta de administrador cuando se realice un intento de conectarse a un lector o estación base disponible a través de la red.


¿Cómo establezco una conexión TCP/IP?

La estación base permite conexiones TCP al puerto 23, que es el puerto TCP por defecto para las aplicaciones de Telnet. Si utiliza un cliente de Telnet, el único parámetro que tendrá que proporcionar es la dirección IP de la estación base. Si utiliza otra aplicación o SDK para conectarse, asegúrese de que utilice la misma configuración de puerto TCP que su estación base. El puerto TCP puede cambiarse en el panel de Telnet. La estación base transmitirá automáticamente el código a través de esta conexión. También puede transmitir los comandos de control de DataMan (DMCC) a través de esta conexión.

Cuando cambie el puerto de Telnet, aparecerá la pregunta «Es necesario reiniciar el equipo para que tengan efecto los cambios realizados. ¿Desea aplicar los cambios y reiniciar ahora?» Haga clic en «Sí». Si, por alguna razón, hace clic en «No» aún podrá aplicar los cambios. Elija Sistema->Guardar configuración y reinicie su estación base.


¿Qué es un Cliente de red?

El comportamiento Cliente de red es la forma mediante la cual el lector ID DataMan abrirá activamente una conexión de Ethernet con otro dispositivo en la red. Una vez abierta, la conexión tendrá el mismo comportamiento operativo básico que la conexión Telnet DataMan; puede producir resultados de lectura (transmitir los resultados al dispositivo externo) y puede actuar como servidor DMCC (procesar comandos recibidos desde el dispositivo externo).


¿Qué es un host?

El dispositivo host es el dispositivo de la red al que se conectará el DataMan. Especifique la dirección Ethernet y el número de puerto del dispositivo host. La dirección puede ser un nombre de dominio completamente cualificado (por ejemplo, «servidor.mired.com») o una dirección IP con formato con notación decimal con punto (por ejemplo, «192.169.0.1»).


¿Qué es un puerto de cliente?

El puerto de cliente es el puerto de Ethernet en el lector desde el que se originará la conexión cliente. El valor predeterminado de 0 indica al cliente de red que use cualquier puerto disponible. En casos especiales, puede que tenga que definir un puerto de cliente específico. Solo tiene que configurar el puerto de cliente con el valor requerido. Tenga en cuenta que el caso más típico consiste en usar el valor predeterminado 0. En caso de duda, use el valor predeterminado.


¿Cómo establezco una conexión?

El cliente se conectará según el valor elegido para la opción Abrir conexión. Las opciones disponibles son conectarse cuando se encienda el dispositivo DataMan o hacerlo tan pronto como haya actividad de datos (es decir, conectarse cuando se lea un código).


¿Cómo cierro la conexión?

Hay dos opciones disponibles para Cerrar conexión. La conexión puede quedar abierta para siempre o puede cerrarse una vez se haya completado la transferencia de datos. Si elige la opción Tras la transferencia de datos del lector, también podrá establecer un número de segundos tras el cual la conexión se cerrará si el lector permanece inactivo durante dicho período de tiempo. La duración del período de inactividad se puede ajustar de 1 a 3 600 segundos.


¿Cuál es el tiempo de espera de la conexión?

El tiempo de espera de la conexión es la cantidad de tiempo (en milisegundos) que el DataMan esperará a que se abra la conexión. Tenga en cuenta que si se elige la opción en encendido, el lector reintentará abrir la conexión continuamente.


¿Qué es el tiempo de reconexión?

Es la cantidad de tiempo (en milisegundos) que el lector permanecerá en pausa antes de volver a intentar abrir la conexión.


Configuración de copia de seguridad


¿Qué es la copia de seguridad automática de la configuración del lector?

La copia de seguridad automática funciona con dispositivos conectados a través de Ethernet. Cuando está activada, esta función realiza una copia de seguridad de la configuración del dispositivo en un dispositivo de almacenamiento externo (un servidor FTP) cada vez que la configuración se guarda en flash. Un servicio de Cognex Explorer puede recibir los datos de la copia de seguridad. La restauración se puede realizar manualmente con la herramienta de configuración, comandos DMCC o Cognex Explorer.

Configure el lector con la dirección IP y el número de puerto necesarios para especificar dónde quiere guardar la configuración. También puede establecer una combinación de nombre de usuario y contraseña.


Vista de tabla


¿Por qué varios valores aparecen resaltados?

Los valores que están resaltados son valores que inicialmente no son predeterminados. Las reglas de resaltado pueden modificarse en la sección Resaltado del menú de la cinta. Consulte la pregunta Vista de tabla: menú de la cinta para obtener más información.


¿Por qué varios valores aparecen en negrita?

Los valores en negrita pueden expandirse y mostrar subvalores.


¿Cómo sé cuáles son los valores posibles?

Mueva el puntero del ratón sobre un valor y consulte el texto que aparecerá encima indicando los valores mínimos, máximos y predeterminados, donde fueran aplicables.


Información legal


Copyright

Cognex Corporation no asume ninguna responsabilidad por el uso o fiabilidad de su software en equipos no suministrados por Cognex Corporation. Cognex Corporation no otorga ningún tipo de garantía, expresa ni implícita, relacionada con el software descrito, su comerciabilidad o idoneidad para un fin determinado.

La información contenida en este documento está sujeta a cambios sin previo aviso y no debe interpretarse como un compromiso por parte de Cognex Corporation. Cognex Corporation no se responsabiliza de ningún error que pueda haber en este documento o en el software asociado.

Copyright © 2019 Cognex Corporation. Todos los derechos reservados

Este documento no se puede copiar, ni parcial ni íntegramente, ni transferir a otro medio o idioma sin el permiso por escrito de Cognex Corporation.

El hardware y las partes del software descritos en este documento pueden estar sujetos a una o más de las patentes estadounidenses enumeradas en la página web de Cognex http://www.cognex.com/patents.asp. Otras patentes estadounidenses y extranjeras están en trámite.


Software bajo licencia

SpiderMonkey

Este software está sujeto a los términos de la Licencia pública de Mozilla, v. 2.0. Puede obtener una copia de esta licencia en http://mozilla.org/MPL/2.0/.

Si desea obtener una copia del código fuente de SpiderMonkey, póngase en contacto con el equipo de asistencia técnica de Cognex en <spidermonkey@cognex.com>.

Licencia de PCRE

PCRE es una biblioteca de funciones compatible con expresiones regulares cuya sintaxis y semántica son prácticamente idénticas a las del lenguaje Perl 5.

La versión 5 de PCRE se distribuye de acuerdo con las condiciones de la licencia «BSD», del modo especificado a continuación. La documentación de PCRE, contenida en el directorio «doc», se distribuye bajo las mismas condiciones que el software.

Autor: Philip Hazel <ph10@cam.ac.uk>

Servicio Informático de la Universidad de Cambridge, Cambridge, Inglaterra. Teléfono: +44 1223 334714.

Copyright (c) 1997-2004 Universidad de Cambridge. Todos los derechos reservados.

Se permite el uso y la redistribución en formato binario/código fuente, con o sin modificación, siempre que se cumplan las condiciones siguientes:

  • Las redistribuciones del código fuente deben indicar el aviso de copyright anterior, esta lista de condiciones y los siguientes descargos de responsabilidad.
  • Las redistribuciones en formato binario deben reproducir el aviso de copyright anterior, esta lista de condiciones y los descargos de responsabilidad presentes en el documento y/o los materiales suministrados con la distribución.
  • No se puede utilizar el nombre de la Universidad de Cambridge ni el nombre de sus colaboradores para secundar o promover productos derivados de este software sin el permiso previo por escrito correspondiente.

ESTE SOFTWARE SE SUMINISTRA POR PARTE DE LOS COLABORADORES Y LOS TITULARES DE COPYRIGHT «TAL COMO ESTÁ» Y SE DECLINA TODA GARANTÍA EXPRESA O IMPLÍCITA, INCLUIDA A MODO ENUNCIATIVO PERO NO LIMITATIVO, CUALQUIER GARANTÍA IMPLÍCITA DE COMERCIABILIDAD E IDONEIDAD PARA UN FIN DETERMINADO. BAJO NINGUNA CIRCUNSTANCIA EL TITULAR DEL COPYRIGHT NI LOS COLABORADORES SERÁN RESPONSABLES DE NINGÚN DAÑO DIRECTO, INDIRECTO, INCIDENTAL, EMERGENTE, EJEMPLAR NI CONSECUENCIAL (INCLUIDO A MODO ENUNCIATIVO PERO NO LIMITATIVO, LA ADQUISICIÓN DE MERCANCÍAS O SERVICIOS SUSTITUTORIOS, LA PÉRDIDA DE USO, DATOS O BENEFICIOS, O LA INTERRUPCIÓN DEL NEGOCIO) AL MARGEN DE LA FORMA O ACCIÓN, BIEN SEA POR CONTRATO, AGRAVIO (INCLUIDA LA NEGLIGENCIA), RESPONSABILIDAD ESTRICTA DEL PRODUCTO U OTRO CASO, INCLUSO SI HUBIESEN SIDO ADVERTIDOS DE LA POSIBILIDAD DE DICHOS DAÑOS.

Fin

Software de JPEG

Este software se fundamenta en parte en el trabajo del grupo independiente JPEG.

Biblioteca de compresión zlib

Este software se fundamenta en parte en el trabajo de Jean-loup Gailly y Mark Adler.

Parsifal XML Parser

Copyright (c) 2002-2005 Toni Uusitalo. Fecha en la que pasó a ser de dominio público: 15/11/2002 http://www.saunalahti.fi/~samiuus/toni/xmlproc/

El uso comercial y no comercial de Parsifal, así como su redistribución, son gratuitos siempre que no se modifiquen el copyright y los descargos de responsabilidad del autor. Puede modificar Parsifal para su propio uso y redistribuirlo con sus modificaciones, siempre y cuando las modificaciones estén claramente documentadas.

DESCARGO DE RESPONSABILIDAD

Este programa se distribuye esperando que sea útil, pero SIN NINGUNA GARANTÍA; ni siquiera la garantía implícita de comerciabilidad o idoneidad para un fin determinado. Utilícelo BAJO SU PROPIA RESPONSABILIDAD.


Información de la patente

Este producto se encuentra cubierto por una o más de las patentes de los EE.UU., aplicaciones de los EE.UU y/o patentes extranjeras http://www.cognex.com/patents listará cualquier patente emitida subsiguientemente que resulte relevante

5742037, 5943441, 6215915, 6236769, 6282328, 6381375, 6408109, 6457032, 6690842, 6941026, 7175090, 7181066, 7412106, 7427028, 7549582, 7604174, 7614563, 7617984, US-2005-0087601-A1, US-2006-0131418-A1, US-2006-0131419-A1, US-2006-0133757-A1, US-2007-0090193-A1, US-2007-0091332-A1, US-2007-0152064-A1, US-2007-0170259-A1, US-2008-0004822-A1, US-2008-0011855-A1, US-2008-0142604-A1, US-2008-0143838-A1, US-2008-0158365-A1, US-2009-0090781-A1, US-2009-0108073, US-2009-0121027-A1, US-2009-0166424-A1, US-2009-0294541-A1, WO06065619A1, y EP1687752